SharePoint Foundation 2010

Microsoft SharePoint Foundation 2010 est une technologie polyvalente dont les organisations et divisions de toutes tailles peuvent tirer parti pour accroître l'efficacité de leurs processus métier et améliorer la productivité de leurs équipes. Grâce à ses outils de collaboration permettant aux utilisateurs de rester connectés par delà les limites organisationnelles et géographiques, SharePoint Foundation 2010 permet à ces derniers d'accéder à l'information qu'ils recherchent.

Les sites basés sur SharePoint Foundation 2010, appelés sites SharePoint, apportent une nouvelle dimension au stockage des fichiers, car ils offrent aux communautés des fonctionnalités de collaboration en équipe permettant aux utilisateurs de travailler ensemble sur des documents, des tâches et des événements, et facilitant le partage de contacts et d'autres informations. SharePoint Foundation 2010 permet aux gestionnaires d'équipes et de sites de gérer facilement le contenu du site et les activités des utilisateurs.

SharePoint Foundation 2010 offre également une plateforme pour la conception d'applications professionnelles basées sur le Web pouvant être facilement adaptées de manière à répondre aux besoins variables et croissants de votre secteur. Des contrôles administratifs polyvalents permettant de gérer le stockage et l'infrastructure Web fournissent aux départements informatiques une façon rentable d'implémenter et de gérer un environnement de collaboration hautement performant.

Rubrique

Évaluation du produit pour SharePoint Foundation 2010

Planification et architecture pour SharePoint Foundation 2010

Déploiement pour SharePoint Foundation 2010

Opérations pour SharePoint Foundation 2010

Sécurité et protection pour SharePoint Foundation 2010

Référence technique de SharePoint Foundation 2010

Historique des modifications

Date | Description | Raison
12 mai 2010 | Publication initiale |


Nouveau contenu publié pour SharePoint Foundation 2010

Trouvez la liste de contenu récemment publié sur le site en français à l'adresse (éventuellement en anglais). Une partie de ce contenu n'a pas encore été traduite.


Feuille de route pour le contenu SharePoint Foundation 2010

Cet article décrit le contenu accessible aux professionnels de l'informatique pour les aider lors de la planification, du déploiement, de l'administration et du dépannage de SharePoint Foundation 2010.

Pour le contenu de développement SharePoint Foundation 2010, voir le Centre pour développeurs SharePoint (http://go.microsoft.com/fwlink/?linkid=159918&clcid=0x40C).

Ressources de contenu

Le TechCenter SharePoint Foundation 2010 (http://go.microsoft.com/fwlink/?linkid=188950&clcid=0x40C) constitue le principal point d'accès aux informations techniques approfondies concernant SharePoint Foundation 2010. Depuis le TechCenter, il est possible d'accéder aux éléments suivants :

  • Centres de ressources SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=188951&clcid=0x40C) Les centres de ressources fournissent des liens vers des informations spécifiques à une fonctionnalité donnée de SharePoint Foundation 2010. Il existe des centres de ressources pour des fonctionnalités telles que l'installation et le déploiement, les services Microsoft Business Connectivity, la gestion du contenu d'entreprise, la recherche d'entreprise, entre autres.

  • Téléchargements SharePoint Foundation 2010 (http://go.microsoft.com/fwlink/?linkid=188952&clcid=0x40C) Accédez à cette page pour télécharger des Service Packs, des compléments, des outils et des logiciels d'évaluation afin de vous aider à optimiser votre organisation SharePoint Foundation.

  • Bibliothèque SharePoint Foundation 2010 La bibliothèque propose le contenu le plus à jour destiné aux professionnels de l'informatique. Ce contenu est examiné et approuvé par l'équipe de produit SharePoint Foundation et évolue au cours du cycle de vie de SharePoint Foundation 2010. N'oubliez pas également de consulter le Nouveau contenu publié pour SharePoint Foundation 2010 dans la bibliothèque. Cet article contient une liste répertoriant le contenu nouveau ou mis à jour ; il est également disponible en tant que flux RSS (éventuellement en anglais). (http://go.microsoft.com/fwlink/?linkid=188953&clcid=0x40C). Il est mis à jour chaque fois qu'un nouvel article est publié ou qu'un article existant est mis à jour

  • Support technique SharePoint Foundation 2010 (http://go.microsoft.com/fwlink/?linkid=188954&clcid=0x40C) Recherchez des ressources de support technique et de dépannage pour SharePoint Foundation. Il est possible d'effectuer des recherches dans la Base de connaissances Microsoft, sur TechNet ou dans les blogs afin d'obtenir une assistance supplémentaire.

Ressources hors connexion

Si vous travaillez hors connexion et que vous souhaitez accéder aux articles de la bibliothèque, l'option suivante est disponible :

  • Bibliothèque technique de SharePoint Foundation 2010 Beta au format d'aide compilée (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=188955&clcid=0x40C) Ce fichier .chm téléchargeable est mis à jour chaque mois et contient tous les articles publiés dans la bibliothèque à la date de publication du fichier .chm.

Ressources supplémentaires

Les ressources visuelles suivantes viennent s'ajouter aux articles de la bibliothèque et peuvent vous aider lors de la planification de vos projets :

  • Diagrammes techniques (SharePoint Foundation 2010) Ces modèles à grande échelle fournissent une représentation visuelle des solutions recommandées et correspondent à divers articles de la bibliothèque. Vous pouvez modifier ces modèles à l'aide de Microsoft Office Visio 2007. de façon à refléter vos plans pour SharePoint Foundation et la façon dont il s'intègrera à votre propre environnement.

Ressources communautaires

Vous pouvez accéder aux ressources communautaires pour en savoir plus sur SharePoint Foundation 2010 et encourager les discussions, poser des questions et échanger des idées concernant votre expérience avec SharePoint Foundation 2010 :

  • Blog de l'équipe Microsoft SharePoint (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=82560&clcid=0x40C) Il s'agit du blog officiel du groupe de produit SharePoint. Il propose des articles rédigés par des membres de l'équipe de produit, ainsi que des mises à jour et des annonces relatives au produit.

  • To The SharePoint (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=188956&clcid=0x40C) Il s'agit du blog de l'équipe de documentation pour professionnels de l'informatique. Il propose des extraits de documentation et des annonces relatives à SharePoint Foundation 2010.

  • Forums SharePoint 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=188957&clcid=0x40C) Les forums offrent un lieu permettant aux utilisateurs et aux membres de l'équipe de produit SharePoint Foundation de discuter du produit.

Historique des modifications

Date | Description | Raison


Contenu téléchargeable pour SharePoint Foundation 2010

Le contenu de cette bibliothèque technique est enrichi d'un contenu disponible en téléchargement.

Contenu | Description
Diagrammes techniques (SharePoint Foundation 2010) | Illustrations de la taille d'une affiche de l'architecture et des concepts de Microsoft SharePoint Foundation 2010
Document téléchargeable : Prise en main de SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=191145&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur les fonctionnalités et éléments requis pour SharePoint Foundation 2010.
Document téléchargeable : Guide de planification pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=196218&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur la façon de planifier un déploiement de SharePoint Foundation 2010.
Document téléchargeable : Gestion de la continuité des opérations pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=203471&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur la gestion de la continuité des opérations pour SharePoint Foundation 2010.
Document téléchargeable : Mise à niveau vers SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=196159&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur la façon d'effectuer une mise à niveau vers SharePoint Foundation 2010.
Document téléchargeable : Guide de déploiement pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=190807&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur la façon de déployer SharePoint Foundation 2010.
Document téléchargeable : Guide des opérations pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=196162&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur l'exploitation et la maintenance des serveurs, batteries de serveurs, sites et solutions dans SharePoint Foundation 2010.
Document téléchargeable : Stockage BLOB distant pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=203468&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur la façon d'utiliser le stockage BLOB distant (RBS, Remote BLOB Storage) pour optimiser les ressources de stockage de base de données dans SharePoint Foundation 2010.
Document téléchargeable : Référence technique pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=196294&clcid=0x40C) | Contenu téléchargeable et imprimable (disponible aux formats de fichiers .doc, .pdf ou .xps) qui contient des informations sur le fournisseur SharePoint Foundation 2010 pour Windows PowerShell et d'autres informations de référence utiles concernant les paramètres généraux, la sécurité et les outils.
Déploiement de la diffusion de diaporamas SharePoint Foundation 2010 (livre blanc) | Guide pour installer et configurer cette solution en vue de diffuser des diaporamas Microsoft PowerPoint.
Utilisation de redirection d'URL AAM dans le processus de mise à niveau (SharePoint Foundation 2010) (livre blanc) | Décrit les activités de planification dont vous avez besoin pour correctement déployer et utiliser la fonctionnalité de redirection des URL de mappage des accès de substitution (AAM) dans Microsoft SharePoint Foundation 2010 afin de réduire les temps d'arrêt au cours de la mise à niveau d'un ordinateur serveur ou d'une batterie de serveurs.

Historique des modifications

Date | Description | Raison
14 octobre 2010 | 2010/10/11 | Mise à jour du contenu


Évaluation du produit pour SharePoint Foundation 2010

Cette section fournit des informations qui permettent aux informaticiens de proposer une analyse de rentabilité pour le choix de Microsoft SharePoint Foundation 2010. Elle contient une vue d'ensemble des fonctionnalités du produit, des comparatifs avec d'autres produits, la configuration système requise, un kit d'évaluation du produit, des informations et analyses, des études de cas, des indications sur la marche à suivre pour acheter le produit, des ateliers virtuels et un plan de mise en œuvre du produit.

Dans cette section :

  • Nouveautés de SharePoint Foundation 2010

  • Modifications entre Windows SharePoint Services 3.0 et SharePoint Foundation 2010

  • Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

  • Planifier la prise en charge des navigateurs (SharePoint Foundation 2010)

Historique des modifications


Nouveautés de SharePoint Foundation 2010

Microsoft SharePoint Foundation 2010 est la solution destinée aux organisations qui recherchent une plateforme de collaboration sécurisée, facile à gérer et basée sur le Web. Cette solution permet aux équipes de rester connectées et productives tout en leur facilitant l'accès aux personnes, documents et informations dont elles ont besoin pour prendre les bonnes décisions et remplir leur mission. Pour découvrir les nouveautés de SharePoint Foundation 2010, passez en revue les éléments suivants :

  • Nouveautés de Microsoft SharePoint Foundation 2010 (Bêta) (http://go.microsoft.com/fwlink/?linkid=188355&clcid=0x40C) La page du centre de ressources TechNet pointe vers les articles et autres ressources de présentation des nouvelles fonctionnalités telles que Windows PowerShell : interface de ligne de commande et langage de script ; le suivi d'intégrité : outil d'analyse d'intégrité intégré (Gestionnaire de maintenance SharePoint) qui permet à SharePoint de rechercher automatiquement les problèmes potentiels de configuration, de performance et d'utilisation ; les solutions en mode bac à sable : environnement d'exécution restreint qui permet aux programmes d'accéder uniquement à certaines ressources et d'empêcher les problèmes se produisant en mode bac à sable d'affecter le reste de l'environnement serveur.

  • Page d'accueil de SharePoint Foundation 2010 (http://go.microsoft.com/fwlink/?linkid=188906&clcid=0x40C) Ce site fournit une vue d'ensemble de SharePoint Foundation 2010 et inclut des vidéos qui illustrent les fonctionnalités clés permettant d'améliorer la productivité, d'effectuer un déploiement flexible et de créer une infrastructure unifiée évolutive.

Historique des modifications


Modifications entre Windows SharePoint Services 3.0 et SharePoint Foundation 2010

Cet article décrit les fonctionnalités dont l'utilisation est déconseillée ou qui ont été supprimées entre Windows SharePoint Services 3.0 et Microsoft SharePoint Foundation 2010. Les fonctionnalités déconseillées sont fournies dans SharePoint Foundation 2010 à des fins de compatibilité avec les versions antérieures du produit. Ces fonctionnalités seront supprimées dans les versions ultérieures.

Dans cet article :

  • Fonctionnalités déconseillées

  • Fonctionnalités supprimées de SharePoint Foundation 2010

Fonctionnalités déconseillées

La fonctionnalité suivante est incluse dans SharePoint Foundation 2010 mais sera supprimée dans les versions ultérieures.

Outil en ligne de commande Stsadm

Description : l'outil en ligne de commande Stsadm est déconseillé.

Raison du changement : l'outil en ligne de commande Stsadm sera remplacé par Windows PowerShell 2.0.

Possibilité de migration : l'outil en ligne de commande Stsadm est inclus pour prendre en charge la compatibilité avec les précédentes versions du produit. Vous devez utiliser Windows PowerShell 2.0 lors de l'exécution de tâches d'administration en ligne de commande.

Fonctionnalités supprimées de SharePoint Foundation 2010

Les fonctionnalités suivantes ne sont plus disponibles dans SharePoint Foundation 2010.

Systèmes d'exploitation 32 bits

Description : SharePoint Foundation 2010 requiert un système d'exploitation 64 bits. L'exécution de SharePoint Foundation 2010 sur des systèmes d'exploitation 32 bits n'est plus prise en charge.

Raison du changement : SharePoint Foundation 2010 comporte de nombreuses fonctionnalités qui tirent parti des performances fournies par les systèmes d'exploitation 64 bits.

Possibilité de migration : installez SharePoint Foundation 2010 sur des systèmes d'exploitation 64 bits.

Installation côte à côte

Description : la possibilité d'effectuer une installation côte à côte de Windows SharePoint Services 3.0 et de SharePoint Foundation 2010 sur le même serveur a été supprimée. Cette modification est liée à la suppression de la prise en charge de la Mise à niveau graduelle.

Raison du changement : les problèmes de compatibilité et de performances empêchent une installation côte à côte.

Possibilité de migration : effectuez une installation de type mise à niveau sur place sur le même matériel, ou attachez les bases de données à une nouvelle batterie de serveurs. Utilisez du nouveau matériel s'il est nécessaire de faire coexister les versions de Windows SharePoint Services 3.0 et SharePoint Foundation 2010 d'une batterie de serveurs.

Pour plus d'informations, voir Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010.

Mise à niveau graduelle

Description : la prise en charge de la mise à niveau graduelle est retirée dans le cadre de la suppression de l'Installation côte à côte.

Raison du changement : les problèmes de compatibilité et de performances empêchent une installation côte à côte.

Possibilité de migration : utilisez la fonctionnalité de base de données en lecture seule de Windows SharePoint Services 3.0 conjointement avec la fonctionnalité d'attachement de base de données de SharePoint Foundation 2010 pour réduire le temps mort.

Pour plus d'informations, voir Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010.

Pour les longues périodes de mise à niveau où vous devez gérer les versions de Windows SharePoint Services 3.0 et SharePoint Foundation 2010 d'une batterie de serveurs, vous pouvez utiliser la fonctionnalité de redirection d'URL par mappage des accès de substitution fournie dans SharePoint Foundation 2010. Les mises à niveau qui utilisent la redirection d'URL par mappage des accès de substitution sont effectuées à l'aide d'opérations en ligne de commande de mise à niveau avec attachement des bases de données au lieu d'événements basés sur les travaux du minuteur planifiés à partir de l'interface utilisateur.

Pour plus d'informations, voir Utilisation de redirection d'URL AAM dans le processus de mise à niveau (SharePoint Foundation 2010) (livre blanc).

Discussions sur le Web

Description : les discussions sur le Web permettent aux utilisateurs d'ajouter des commentaires sur les documents et les pages sans modifier leur contenu réel. SharePoint Foundation 2010 ne prend pas en charge les discussions sur le Web.

Raison du changement : cette fonctionnalité est déconseillée dans Windows SharePoint Services 3.0 en raison de son faible taux d'utilisation. Elle est à présent supprimée du produit.

Possibilité de migration : cette fonctionnalité n'est plus disponible.

Sources de données SQL Server 2000

Description : les sources de données SQL Server 2000 ne sont plus prises en charge dans SharePoint Foundation 2010.

Raison du changement : SQL Server 2000 ne prend pas complètement en charge de nombreuses nouvelles fonctionnalités relatives aux données et qui sont disponibles dans SharePoint Foundation 2010.

Possibilité de migration : utilisez les sources de données de Microsoft SQL Server 2005 ou Microsoft SQL Server 2008.

Sources de données ODBC

Description : les sources de données ODBC ne sont plus prises en charge dans SharePoint Foundation 2010.

Raison du changement : des options de connexion aux bases de données plus modernes et plus polyvalentes ont remplacé la fonctionnalité ODBC.

Possibilité de migration : ODBC n'est plus listé en tant qu'option de connexion à une source de données. Utilisez un autre type de connexion aux données.

Thèmes version 3

Description : un thème est un ensemble de couleurs, de polices et d'éléments décoratifs qui vous permettent de modifier rapidement l'apparence d'un site. Les fonctionnalités fournies dans les thèmes version 3 ne sont pas disponibles dans les tout nouveaux thèmes version 4.

Raison du changement : les thèmes version 4 ont fait l'objet d'une refonte afin de simplifier le processus de génération des thèmes. La nouvelle architecture n'est pas compatible avec celle des thèmes version 3.

Possibilité de migration : les thèmes version 3 continuent d'être pris en charge si le mode d'interface utilisateur est conservé à la version 3. Les thèmes version 3 ne sont pas pris en charge dans le mode d'interface utilisateur version 4.

Agents logiciels de type composants WebBot

Description : un agent logiciel de type composant WebBot est un objet dynamique de page Web qui est évalué lors de l'enregistrement de la page ou, dans certains cas, lors de l'ouverture de la page dans un navigateur Web. Les robots de recherche et les indexeurs sont des exemples de composants WebBot. Les développeurs ne peuvent plus utiliser de points d'entrée de type composants WebBot ; par ailleurs, les utilisateurs ne peuvent pas ajouter de composants WebBot aux sites SharePoint Foundation 2010.

Raison du changement : cette fonctionnalité est remplacée par les composants WebPart.

Possibilité de migration : utilisez des composants WebPart à la place de composants WebBot.

Groupes avec courrier électronique activé et service Microsoft SharePoint Directory Management (DMS)

Description : le service Microsoft SharePoint Directory Management (DMS) connecte les sites SharePoint à l'annuaire des utilisateurs d'une organisation pour fournir des fonctionnalités de courrier électronique améliorées. Si une batterie de serveurs utilise le service DMS, les utilisateurs ne peuvent pas activer l'utilisation du courrier électronique pour les groupes SharePoint.

Raison du changement : le type d'authentification utilisé dans le service DMS est remplacé par l'authentification basée sur les revendications.

Possibilité de migration : cette fonctionnalité n'est pas disponible dans SharePoint Foundation 2010. Utilisez l'authentification basée sur les revendications à la place.

Pour plus d'informations, voir Planifier l'authentification par revendications (SharePoint Foundation 2010).

Autorisations des sous-sites Web

Description : lorsque vous assignez un niveau d'autorisation à un site parent, tous les sous-sites Web du site parent héritent de ce niveau d'autorisation par défaut. Dans Windows SharePoint Services 3.0, si vous voulez qu'un sous-site Web n'ait pas les mêmes autorisations que son parent, vous pouvez modifier la définition du niveau d'autorisation hérité pour l'étendue du sous-site Web. Par conséquent, vous disposez de deux niveaux d'autorisation portant le même nom mais avec des autorisations distinctes, en fonction de leur étendue. Par exemple, vous avez assigné le niveau d'autorisation Conception à un site parent, mais vous voulez modifier les autorisations d'un sous-site Web de sorte que les utilisateurs ne puissent pas appliquer de feuilles de style aux pages de ce sous-site Web. Dans Windows SharePoint Services 3.0, vous modifiez le niveau d'autorisation Conception pour le sous-site Web en question, supprimez l'autorisation Appliquer des feuilles de style et enregistrez le niveau d'autorisation sous le nom Conception. Il n'est pas possible, en examinant uniquement les niveaux d'autorisation, de déterminer que le sous-site Web dispose en réalité d'un autre jeu d'autorisations que celui de son site parent.

Possibilité de migration : dans SharePoint Foundation 2010, pour accorder des autorisations distinctes à un sous-site Web, vous devez assigner un autre niveau d'autorisation au sous-site Web. Les collections de sites mises à niveau à partir de Windows SharePoint Services 3.0 et qui disposent de ces structures de niveaux d'autorisation uniques continueront de fonctionner. Toutefois, l'interface utilisateur de SharePoint Foundation 2010 n'offre aucun moyen de modifier un niveau d'autorisation hérité pour l'étendue du sous-site Web ; par conséquent, vous ne pouvez pas modifier ou créer de définitions de niveaux d'autorisation de ce type. Si pour des raisons spécifiques, vous devez continuer à utiliser le processus de Windows SharePoint Services 3.0, utilisez le modèle objet SharePoint Foundation 2010.

Noms de domaine internationaux

Description : bien que Windows SharePoint Services 3.0 prenne en charge les noms de domaine internationaux, ce n'est pas le cas de SharePoint Foundation 2010.

Raison du changement : la prise en charge des noms de domaine internationaux est déconseillée.

Possibilité de migration : si vous utilisez actuellement des noms de domaine internationaux avec Windows SharePoint Services 3.0 et si vous envisagez d'effectuer une mise à niveau ou une migration vers SharePoint Foundation 2010, vous devez au préalable cesser d'utiliser les noms de domaine internationaux, supprimer tous les paramètres relatifs aux noms de domaine internationaux, puis configurer un environnement qui n'utilise aucun nom de domaine international.

Historique des modifications


Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

Cet article mentionne les configurations logicielle et matérielle minimales requises pour installer et exécuter Microsoft SharePoint Foundation 2010.

Important :
Si vous contactez le support technique Microsoft concernant un système de production qui ne dispose pas de la configuration matérielle minimale décrite dans ce document, le support sera limité jusqu'à ce que le système soit mis à niveau de façon à satisfaire la configuration requise.

Dans cet article :

  • Présentation

  • Configuration matérielle requise—serveurs Web, serveurs d'applications et installations de serveurs uniques

  • Configuration matérielle requise—Serveurs de bases de données

  • Configuration logicielle requise

  • Accès aux logiciels applicables

Présentation

Microsoft SharePoint Foundation 2010 prend en charge une série de scénarios d'installation. Actuellement, ces installations comprennent les installations à serveur unique avec base de données intégrée et les installations de batterie de serveurs unique ou multiple.

Configuration matérielle requise—serveurs Web, serveurs d'applications et installations de serveurs uniques

Les spécifications indiquées dans le tableau suivant s'appliquent aux installations sur un serveur unique avec une base de données intégrée et aux serveurs exécutant SharePoint Foundation 2010 dans une installation de batterie à serveurs multiples.

Composant Configuration minimale

Processeur

64 bits, quatre cœurs

RAM
  • 4 Go pour une utilisation à des fins d'évaluation ou de développement

  • 8 Go pour une installation de serveur unique ou de batterie de serveurs en vue d'une utilisation en mode production

Disque dur

80 Go pour le lecteur système

Vous devez disposer d'un espace suffisant pour l'installation de base et pour les diagnostics, tels que la journalisation, le débogage, la création de vidages mémoire, et ainsi de suite. Pour une utilisation en mode de production, vous devez également disposer d'un espace disque supplémentaire pour les opérations quotidiennes. La quantité d'espace libre à ajouter doit représenter le double de la RAM pour les environnements de production. Pour plus d'informations, voir Capacity management and sizing for SharePoint Server 2010.

Configuration matérielle requise—Serveurs de bases de données

Les spécifications indiquées dans le tableau suivant s'appliquent aux serveurs de bases de données dans les environnements de production où la batterie contient plusieurs serveurs.

Remarque :
Nos définitions des petits et moyens déploiements sont celles décrites dans la section « Architectures de référence » dans Capacity management and sizing for SharePoint Server 2010.

Composant Configuration minimale

Processeur
  • 64 bits, quatre cœurs pour les déploiements à petite échelle

  • 64 bits, huit cœurs pour les déploiements à moyenne échelle

RAM
  • 8 Go pour les déploiements à petite échelle

  • 16 Go pour les déploiements à moyenne échelle

Pour les déploiements à grande échelle, voir la section « Estimation de la mémoire requise » dans Storage and SQL Server capacity planning and configuration (SharePoint Server 2010).

Remarque :
Ces valeurs sont supérieures aux valeurs minimales recommandées pour SQL Server en raison de la distribution des données requises pour un environnement SharePoint Products 2010. Pour plus d'informations sur la configuration requise de SQL Server, voir Configurations matérielle et logicielle requises pour l'installation de SQL Server 2008 R2 (http://go.microsoft.com/fwlink/?linkid=129377&clcid=0x40C).

Disque dur

80 Go pour le lecteur système

L'espace disque dépend de la taille de votre contenu SharePoint. Pour plus d'informations sur l'évaluation de la taille des bases de données de contenu et des autres bases de données pour votre déploiement, voir Storage and SQL Server capacity planning and configuration (SharePoint Server 2010).

Configuration logicielle requise

Les configurations indiquées dans les tableaux suivants concernent les installations de serveur unique avec base de données intégrée et les installations de batterie comportant un ou plusieurs serveurs.

Important :
SharePoint Foundation 2010 ne prend pas en charge les noms SLD (Single Label Domain). Pour plus d'informations, voir Informations sur la configuration des domaines Active Directory à l'aide de noms DNS en une seule partie.

L'Outil de préparation des produits Microsoft SharePoint, auquel vous accédez depuis la page de démarrage de SharePoint Foundation 2010, peut vous aider pour l'installation des logiciels requis pour SharePoint Foundation 2010. Vous devez disposer d'une connexion Internet, car certains de ces composants sont installés depuis Internet. Pour plus d'informations, voir Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010), Déployer un serveur unique avec une base de données intégrée (SharePoint Foundation 2010) et Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010).

Configurations minimales

Environnement Configuration minimale

Serveur de bases de données dans une batterie

L'une des applications suivantes :

  • L'édition 64 bits de Microsoft SQL Server 2008 R2.

  • L'édition 64 bits de SQL Server 2008 avec SP1 et mise à jour cumulative 2. Sur la page Package de mise à jour cumulative 2 pour SQL Server 2008 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=165962&clcid=0x40C), cliquez sur le lien View and request hotfix downloads et suivez les instructions affichées. Sur la page de demande de correctif, téléchargez le fichier SQL_Server_2008_SP1_Cumulative_Update_2. Lorsque vous installez Microsoft SQL Server 2008 SP1 sur Windows Server 2008 R2, un avertissement de compatibilité est susceptible de s'afficher. Vous pouvez l'ignorer et poursuivre l'installation.

    Remarque :
    Nous vous déconseillons d'utiliser CU3 ou CU4, mais plutôt CU2, CU5, ou un CU ultérieur à CU5. Pour plus d'informations, voir Package de mise à jour cumulative 5 pour SQL Server 2008 (http://go.microsoft.com/fwlink/?linkid=196928&clcid=0x40C). Téléchargez le fichier SQL_Server_2008_RTM_CU5_SNAC.

  • L'édition 64 bits de Microsoft SQL Server 2005 avec Service Pack 3 (SP3). Sur la page Package de mise à jour cumulative 3 pour SQL Server 2005 Service Pack 3 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=165748&clcid=0x40C), cliquez sur le lien View and request hotfix downloads et suivez les instructions affichées. Sur la page de demande de correctif, téléchargez le fichier SQL_Server_2005_SP3_Cumulative_Update_3.

Pour plus d'informations sur le choix d'une version de SQL Server, voir SQL Server 2008 R2 and SharePoint 2010 Products: Better Together (SharePoint Server 2010): white paper.

Serveur unique avec base de données intégrée
  • L'édition 64 bits de Windows Server 2008 Standard, Enterprise, Data Center ou Web Server avec SP2, ou l'édition 64 bits de Windows Server 2008 R2 Standard, Enterprise, Data Center ou Web Server. Si vous exécutez Windows Server 2008 sans SP2, l'Outil de préparation des produits Microsoft SharePoint installe Windows Server 2008 SP2 automatiquement.

    Remarque :
    Vous devez télécharger une mise à jour pour Windows Server 2008 et Windows Server 2008 R2 avant d'exécuter le programme d'installation. Cette mise à jour est un correctif logiciel pour le .NET Framework 3.5 SP1 installée par l'outil de préparation. Elle permet de prendre en charge l'authentification par jeton sans sécurité de transport ni chiffrement des messages dans WCF. Pour plus d'informations et des liens, voir la section « Accès aux logiciels applicables » plus loin dans cet article.

  • KB979917 - QFE pour les problèmes Sharepoint - Correctif du compteur de performance et emprunt d'identité d'utilisateur (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=192577&clcid=0x40C).

    • Pour Windows Server 2008 SP2, téléchargez le fichier Windows6.0-KB979917-x64.msu (Vista).

    • Pour Windows Server 2008 R2, téléchargez le fichier Windows6.1-KB979917-x64.msu (Win7).

    Pour plus d'informations, voir l'article de la Base de connaissance Deux problèmes se produisent lorsque vous déployez une application ASP.NET 2.0 sur un serveur qui exécute IIS 7.0 ou IIS 7.5 en mode intégré (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=192578&clcid=0x40C).

L'outil de préparation installe les éléments prérequis suivants :

  • Rôle Serveur Web (IIS)

  • Rôle de serveur d'applications

  • Microsoft .NET Framework version 3.5 SP1

  • SQL Server 2008 Express avec SP1

  • Microsoft Sync Framework Runtime v1.0 (x64)

  • Microsoft Filter Pack 2.0

  • Microsoft Chart Controls for Microsoft .NET Framework 3.5

  • Windows PowerShell 2.0

  • SQL Server 2008 Native Client

  • Microsoft SQL Server 2008 Analysis Services ADOMD.NET

  • Mise à jour d'ADO.NET Data Services pour le .NET Framework 3.5 SP1

  • Un correctif pour le .NET Framework 3.5 SP1 qui fournit une méthode pour prendre en charge l'authentification par jeton sans sécurité de transport ou chiffrement des messages dans WCF.

  • Windows Identity Foundation (WIF)

    Remarque :
    Si Microsoft « Geneva » Framework est installé, vous devez procéder à sa désinstallation avant d'installer Windows Identity Foundation (WIF).

Serveurs Web frontaux et serveurs d'applications dans une batterie de serveurs

  • L'édition 64 bits de Windows Server 2008 Standard, Enterprise, Data Center ou Web Server avec SP2, ou l'édition 64 bits de Windows Server 2008 R2 Standard, Enterprise, Data Center ou Web Server. Si vous exécutez Windows Server 2008 avec SP1, l'Outil de préparation des produits Microsoft SharePoint installe Windows Server 2008 SP2 automatiquement.

    Remarque :
    Vous devez télécharger une mise à jour pour Windows Server 2008 et Windows Server 2008 R2 avant d'exécuter le programme d'installation. Cette mise à jour est un correctif logiciel pour le .NET Framework 3.5 SP1 installée par l'outil de préparation. Elle permet de prendre en charge l'authentification par jeton sans sécurité de transport ni chiffrement des messages dans WCF. Pour plus d'informations et des liens, voir la section « Accès aux logiciels applicables ».

  • KB979917 - QFE pour les problèmes Sharepoint - Correctif du compteur de performance et emprunt d'identité d'utilisateur (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=192577&clcid=0x40C)

    • Pour Windows Server 2008 SP2, téléchargez le fichier Windows6.0-KB979917-x64.msu (Vista).

    • Pour Windows Server 2008 R2, téléchargez le fichier Windows6.1-KB979917-x64.msu (Win7).

    Pour plus d'informations, voir l'article de la Base de connaissance Deux problèmes se produisent lorsque vous déployez une application ASP.NET 2.0 sur un serveur qui exécute IIS 7.0 ou IIS 7.5 en mode intégré (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=192578&clcid=0x40C).

L'outil de préparation installe les éléments prérequis suivants :

  • Rôle Serveur Web (IIS)

  • Rôle de serveur d'applications

  • Microsoft .NET Framework version 3.5 SP1

  • Microsoft Sync Framework Runtime v1.0 (x64)

  • Microsoft Filter Pack 2.0

  • Microsoft Chart Controls for Microsoft .NET Framework 3.5

  • Windows PowerShell 2.0

  • SQL Server 2008 Native Client

  • Microsoft SQL Server 2008 Analysis Services ADOMD.NET

  • Mise à jour d'ADO.NET Data Services pour le .NET Framework 3.5 SP1

  • Un correctif pour le .NET Framework 3.5 SP1 qui fournit une méthode pour prendre en charge l'authentification par jeton sans sécurité de transport ou chiffrement des messages dans WCF.

  • Windows Identity Foundation (WIF)

    Remarque :
    Si Microsoft « Geneva » Framework est installé, vous devez procéder à sa désinstallation avant d'installer Windows Identity Foundation (WIF).

Ordinateur client
  • Un navigateur pris en charge. Pour plus d'informations, voir Planifier la prise en charge des navigateurs (SharePoint Foundation 2010).

Logiciels facultatifs

Environnement Logiciels facultatifs

Serveur unique avec base de données intégrée
  • Windows 7 ou Windows Vista. Pour plus d'informations, voir Configuration de l'environnement de développement pour SharePoint Server (http://go.microsoft.com/fwlink/?linkid=164557&clcid=0x40C).

Ordinateur client
  • Client Microsoft Office 2010. Pour plus d'informations, voir Microsoft Office 2010 (http://go.microsoft.com/fwlink/?linkid=195843&clcid=0x40C).

  • Microsoft Silverlight 3.

Accès aux logiciels applicables

Pour installer Windows Server 2008 ou Microsoft SQL Server, vous pouvez vous rendre sur les sites Web répertoriés dans cette section. Vous pouvez installer tous les autres logiciels obligatoires via la page de démarrage de SharePoint Foundation. La plupart des logiciels obligatoires sont également disponibles sur les sites Web répertoriés dans cette section. Les rôles Serveur Web (IIS) et Serveur d'application peuvent être activés manuellement dans le Gestionnaire de serveur.

Dans les scénarios dans lesquels l'installation des éléments prérequis directement à partir d'Internet n'est pas possible ou pas réalisable, vous pouvez les installer à partir d'un partage réseau. Pour plus d'informations, voir Éléments prérequis à l'installation depuis un partage réseau (SharePoint Foundation 2010).

  • SharePoint Foundation 2010 (http://go.microsoft.com/fwlink/?linkid=197422&clcid=0x40C)

  • Modules linguistiques pour SharePoint Foundation 2010 (http://go.microsoft.com/fwlink/?linkid=197424&clcid=0x40C)

  • Windows Server 2008 (http://go.microsoft.com/fwlink/?linkid=197426&clcid=0x40C)

  • Windows Server 2008 R2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=197428&clcid=0x40C)

  • SQL Server 2008 R2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=197429&clcid=0x40C)

  • SQL Server 2008 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179611&clcid=0x40C)

  • SQL Server 2005 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=197431&clcid=0x40C)

  • SQL Server 2008 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=166490&clcid=0x40C)

  • Package de mise à jour cumulative 2 pour SQL Server 2008 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=165962&clcid=0x40C).

  • Package de mise à jour cumulative 5 pour SQL Server 2008 (http://go.microsoft.com/fwlink/?linkid=197434&clcid=0x40C). Téléchargez le fichier SQL_Server_2008_RTM_CU5_SNAC.

  • Microsoft SQL Server 2005 Service Pack 3 (http://go.microsoft.com/fwlink/?linkid=166496&clcid=0x40C)

  • Package de mise à jour cumulative 3 pour SQL Server 2005 Service Pack 3 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=165748&clcid=0x40C).

  • Microsoft Windows Server 2008 SP2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166500&clcid=0x40C)

  • Correctif Windows Server 2008 avec SP2 : un correctif qui fournit une méthode pour prendre en charge l'authentification par jeton sans sécurité de transport ou chiffrement des messages dans WCF est disponible pour le .NET Framework 3.5 SP1 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=160770&clcid=0x40C).

  • Correctif Windows Server 2008 R2 : un correctif qui fournit une méthode pour prendre en charge l'authentification par jeton sans sécurité de transport ou chiffrement des messages dans WCF est disponible pour .NET Framework 3.5 SP1 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166231&clcid=0x40C).

  • Microsoft .NET Framework 3.5 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=131037&clcid=0x40C)

  • Microsoft® SQL Server® 2008 Express Edition Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=166503&clcid=0x40C)

  • Windows Identity Foundation pour Windows Server 2008 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=160381&clcid=0x40C)

  • Windows Identity Foundation pour Windows Server 2008 R2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166363&clcid=0x40C)

  • Microsoft Sync Framework v1.0 (http://go.microsoft.com/fwlink/?linkid=141237&clcid=0x40C)

  • Microsoft Office 2010 Filter Packs (http://go.microsoft.com/fwlink/?linkid=191851&clcid=0x40C)

  • Microsoft Chart Controls for Microsoft .NET Framework 3.5 (http://go.microsoft.com/fwlink/?linkid=141512&clcid=0x40C)

  • Windows PowerShell 2.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=161023&clcid=0x40C)

  • Microsoft SQL Server 2008 Feature Pack, août 2008 (http://go.microsoft.com/fwlink/?linkid=166505&clcid=0x40C)

  • Microsoft SQL Server 2008 Analysis Services ADOMD.NET (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=160390&clcid=0x40C)

  • KB979917 - QFE pour les problèmes Sharepoint - Correctif du compteur de performance et emprunt d'identité d'utilisateur (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=192577&clcid=0x40C)

    • Pour Windows Server 2008 SP2, téléchargez le fichier Windows6.0-KB979917-x64.msu (Vista).

    • Pour Windows Server 2008 R2, téléchargez le fichier Windows6.1-KB979917-x64.msu (Win7).

  • Mise à jour d'ADO.NET Data Services pour le .NET Framework 3.5 SP1 (http://go.microsoft.com/fwlink/?linkid=163519&clcid=0x40C) pour Windows Server 2008 SP2

  • Mise à jour d'ADO.NET Data Services pour le .NET Framework 3.5 SP1 (http://go.microsoft.com/fwlink/?linkid=163524&clcid=0x40C) pour Windows Server 2008 R2 ou Windows 7

  • Microsoft Silverlight 3 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166506&clcid=0x40C)

  • Microsoft Office 2010 (http://go.microsoft.com/fwlink/?linkid=195843&clcid=0x40C)

  • Office Communicator 2007 R2 (http://go.microsoft.com/fwlink/?linkid=196930&clcid=0x40C)

  • Microsoft SharePoint Designer 2010 (32 bits) (http://go.microsoft.com/fwlink/?linkid=196931&clcid=0x40C)

  • Microsoft SharePoint Designer 2010 (64 bits) (http://go.microsoft.com/fwlink/?linkid=196932&clcid=0x40C)

  • Microsoft SQL Server 2008 SP1 (http://go.microsoft.com/fwlink/?linkid=166490&clcid=0x40C)

  • Package de mise à jour cumulative 2 pour SQL Server 2008 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=165962&clcid=0x40C).

  • Microsoft SQL Server 2005 SP3 (http://go.microsoft.com/fwlink/?linkid=166496&clcid=0x40C)

  • Package de mise à jour cumulative 3 pour SQL Server 2005 Service Pack 3 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=165748&clcid=0x40C).

  • Microsoft Windows Server 2008 SP2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166500&clcid=0x40C)

  • Correctif Windows Server 2008 avec SP2 : un correctif qui fournit une méthode pour prendre en charge l'authentification par jeton sans sécurité de transport ou chiffrement des messages dans WCF est disponible pour .NET Framework 3.5 SP1 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=160770&clcid=0x40C).

  • Correctif Windows Server 2008 R2 : un correctif qui fournit une méthode pour prendre en charge l'authentification par jeton sans sécurité de transport ou chiffrement des messages dans WCF est disponible pour .NET Framework 3.5 SP1 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166231&clcid=0x40C).

  • Microsoft .NET Framework 3.5 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=131037&clcid=0x40C)

  • Microsoft SQL Server 2008 Express Edition Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=166503&clcid=0x40C)

  • Framework Windows Identity pour Windows Server 2008 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=160381&clcid=0x40C)

  • Framework Windows Identity pour Windows Server 2008 R2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166363&clcid=0x40C)

  • Microsoft Sync Framework v1.0 (http://go.microsoft.com/fwlink/?linkid=141237&clcid=0x40C)

  • Microsoft Office 2010 Filter Packs (http://go.microsoft.com/fwlink/?linkid=191851&clcid=0x40C)

  • Microsoft Chart Controls for Microsoft .NET Framework 3.5 (http://go.microsoft.com/fwlink/?linkid=141512&clcid=0x40C)

  • Windows PowerShell 2.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=161023&clcid=0x40C)

  • Microsoft SQL Server 2008 Native Client (http://go.microsoft.com/fwlink/?linkid=166505&clcid=0x40C)

  • Microsoft SQL Server 2008 Analysis Services ADOMD.NET (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=130651&clcid=0x40C)

  • KB979917 - QFE pour les problèmes Sharepoint - Correctif du compteur de performance et emprunt d'identité d'utilisateur (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=192577&clcid=0x40C)

    • Pour Windows Server 2008 SP2, téléchargez le fichier Windows6.0-KB979917-x64.msu (Vista).

    • Pour Windows Server 2008 R2, téléchargez le fichier Windows6.1-KB979917-x64.msu (Win7).

    Pour plus d'informations, voir l'article de la Base de connaissance Deux problèmes se produisent lorsque vous déployez une application ASP.NET 2.0 sur un serveur qui exécute IIS 7.0 ou IIS 7.5 en mode intégré (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=192578&clcid=0x40C).

  • Microsoft Office 2010 (http://go.microsoft.com/fwlink/?linkid=195843&clcid=0x40C)

  • Microsoft Silverlight 3 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166506&clcid=0x40C)

  • Mise à jour d'ADO.NET Data Services pour le .NET Framework 3.5 SP1 (http://go.microsoft.com/fwlink/?linkid=163519&clcid=0x40C) pour Windows Server 2008 SP2

  • Mise à jour d'ADO.NET Data Services pour le .NET Framework 3.5 SP1 (http://go.microsoft.com/fwlink/?linkid=163524&clcid=0x40C) pour Windows Server 2008 R2 ou Windows 7

Historique des modifications

Date | Description | Raison
8 juillet 2010 | 2010/07/05 | Mise à jour du contenu
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Planifier la prise en charge des navigateurs (SharePoint Foundation 2010)

Microsoft SharePoint Foundation 2010 prend en charge plusieurs navigateurs Web courants. Cet article décrit les différents niveaux de prise en charge des navigateurs Web et explique comment les contrôles ActiveX affectent les fonctionnalités.

Dans cet article :

  • À propos de la planification de la prise en charge des navigateurs

  • Principale phase de planification de la prise en charge des navigateurs

  • Contrôles ActiveX

À propos de la planification de la prise en charge des navigateurs

SharePoint Foundation 2010 prend en charge plusieurs navigateurs Web courants. Cependant, certains d'entre eux sont susceptibles d'altérer ou de limiter certaines fonctionnalités de SharePoint Foundation 2010 ou de ne les rendre accessibles qu'après réalisation de tâches spécifiques. Dans certains cas, certaines fonctionnalités ne sont pas disponibles dans le cadre de tâches administratives non critiques.

Dans le cadre de la planification de votre déploiement de SharePoint Foundation 2010, nous vous recommandons de faire le point sur les navigateurs utilisés dans votre entreprise afin de garantir des performances optimales avec SharePoint Foundation 2010.

Principale phase de planification de la prise en charge des navigateurs

La prise en charge des navigateurs est une phase importante de l'implémentation de SharePoint Foundation 2010. Avant d'installer SharePoint Foundation 2010, vous devez savoir quels navigateurs sont pris en charge par SharePoint Foundation 2010. Cette rubrique porte sur les thèmes suivants :

  • Niveaux de prise en charge des navigateurs

  • Matrice de prise en charge des navigateurs

  • Informations détaillées sur les navigateurs

Niveaux de prise en charge des navigateurs

Il existe trois niveaux de prise en charge des navigateurs par SharePoint Foundation 2010 :

  • Pris en charge

    Un navigateur pris en charge est un navigateur Web pris en charge par SharePoint Foundation 2010 et dont toutes les fonctionnalités sont utilisables normalement. En cas de problème, le service de support peut vous aider à trouver une solution.

  • Pris en charge malgré certaines limitations connues

    Un navigateur pris en charge malgré certaines limitations connues est un navigateur Web pris en charge par SharePoint Foundation 2010, mais dont le fonctionnement présente certaines limitations connues. La plupart des fonctionnalités sont parfaitement utilisables et si l'une d'entre elles ne fonctionne pas ou a été volontairement désactivée, la documentation permettant de résoudre les problèmes est facilement disponible.

  • Non testé

    Un navigateur Web non testé est un navigateur dont la compatibilité avec SharePoint Foundation 2010 n'a pas été testée et dont l'utilisation est susceptible de présenter certains problèmes. SharePoint Foundation 2010 fonctionnera de façon optimale avec les navigateurs Web mis à jour et normalisés.

Matrice de prise en charge des navigateurs

Le tableau suivant résume les niveaux de prise en charge des navigateurs courants.

Navigateur | Pris en charge | Pris en charge avec limitations | Non testé
Internet Explorer 8 (32 bits) | X |  |
Internet Explorer 7 (32 bits) | X |  |
Internet Explorer 8 (64 bits) |  | X |
Internet Explorer 7 (64 bits) |  | X |
Internet Explorer 6 (32 bits) |  |  | X
Mozilla Firefox 3.6 (sur les systèmes d'exploitation Windows) |  | X |
Mozilla Firefox 3.6 (sur les systèmes d'exploitation non-Windows) |  | X |
Safari 4.04 (sur les systèmes d'exploitation non-Windows) |  | X |

Informations détaillées sur les navigateurs

Pour faire en sorte que le navigateur Web fonctionne correctement avec SharePoint Foundation 2010 et réponde aux besoins de votre entreprise, examinez les informations détaillées ci-dessous relatives aux navigateurs Web que vous utilisez ou comptez utiliser dans l'entreprise.

Internet Explorer 8 (32 bits)

Internet Explorer 8 (32 bits) est pris en charge sur les systèmes d'exploitation suivants :

  • Windows Server 2008 R2

  • Windows Server 2008

  • Windows Server 2003

  • Windows 7

  • Windows Vista

  • Windows XP

Limitations connues

Il n'existe pas de limitation connue pour Internet Explorer 8 (32 bits).

Internet Explorer 7 (32 bits)

Internet Explorer 7 (32 bits) est pris en charge sur les systèmes d'exploitation suivants :

  • Windows Server 2008

  • Windows Server 2003

  • Windows Vista

  • Windows XP

Limitations connues

Il n'existe pas de limitation connue pour Internet Explorer 7 (32 bits).

Internet Explorer 6 (32 bits)

SharePoint Foundation 2010 ne prend pas en charge Internet Explorer 6 (32 bits).

Internet Explorer 8 (64 bits)

Internet Explorer 8.0 (64 bits) est pris en charge sur les systèmes d'exploitation suivants :

  • Windows Server 2008 R2

  • Windows Server 2008

  • Windows Server 2003

  • Windows 7

  • Windows Vista

  • Windows XP

Limitations connues

Le tableau ci-dessous recense les fonctionnalités et limitations connues d'Internet Explorer 8 (64 bits).

Fonctionnalité Limitation

Se connecter à Outlook, Connexion à Office et Synchroniser avec SharePoint Workspace

Fonctionne avec un contrôle ActiveX et le protocole stssync://. Cette fonctionnalité peut par conséquent être limitée en l'absence de contrôle ActiveX tel que celui fourni dans Microsoft Office 2010. Cette fonctionnalité nécessite également une application compatible avec le protocole stssync://, par exemple Microsoft Outlook.

Mode Feuille de données

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Modifier dans l'application Microsoft Office

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Mode Explorateur

Supprimé dans SharePoint Foundation 2010. Les bibliothèques mises à niveau à partir de versions précédentes de SharePoint Foundation 2010 sont susceptibles de contenir des modes Explorateur qui risquent de ne pas fonctionner.

Exporter vers Excel

Télécharge un fichier portant l'extension .iqy dans le navigateur Web. Si Microsoft Excel n'est pas installé et qu'aucune autre application n'est configurée pour ouvrir ce fichier, l'opération ne fonctionnera pas.

Téléchargement et copie de fichiers

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Intégration à Microsoft InfoPath 2010

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Intégration à la bibliothèque d'images Microsoft PowerPoint 2010

Nécessite un contrôle ActiveX 64 bits similaire à celui fourni dans Microsoft Office 2010. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut télécharger plusieurs images vers une bibliothèque d'images, il doit les télécharger une par une en utilisant Upload.aspx.

  • Si un utilisateur veut éditer une image d'une bibliothèque d'images, il doit télécharger l'image, l'éditer, puis la télécharger vers la bibliothèque.

  • Si un utilisateur veut télécharger plusieurs images depuis une bibliothèque d'images, il doit les télécharger une par une en cliquant sur le lien de l'image.

Création de diagramme Microsoft Visio 2010

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Nouveau document

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle. La commande Nouveau document risque de ne pas fonctionner, mais vous pouvez utiliser la fonction Télécharger un document. Si vous installez et configurez des applications Web Office sur le serveur, la commande Nouveau document fonctionnera et vous pourrez alors créer un document Office dans votre navigateur.

Envoyer vers

Peut exploiter un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle. Sans ce contrôle, il est impossible d'envoyer des fichiers d'une batterie de serveurs SharePoint vers une autre batterie de serveurs SharePoint. En revanche, les fichiers peuvent quand même être envoyés d'un site vers un autre site.

Signature de formulaires (InfoPath Forms Services)

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Intégration de feuille de calcul et de base de données

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut éditer un document, il doit télécharger le document, l'éditer, puis l'enregistrer à nouveau sur le serveur.

  • Dans les listes nécessitant qu'un document soit extrait pour pouvoir être édité, les utilisateurs doivent utiliser le menu Edition pour extraire le document, éditer le document, puis l'archiver en utilisant le menu Edition.

  • Exporter vers une feuille de calcul. Les utilisateurs peuvent exporter une liste SharePoint sous forme de feuille de calcul en cliquant sur Exporter vers une feuille de calcul dans l'onglet Liste du ruban.

Connexions de composant WebPart à composant WebPart

Peut nécessiter la désactivation des bloqueurs de fenêtres publicitaires intempestives des navigateurs pour l'accès aux sites SharePoint.

Internet Explorer 7 (64 bits)

Internet Explorer 7 (64 bits) est pris en charge sur les systèmes d'exploitation suivants :

  • Windows Server 2008

  • Windows Server 2003

  • Windows Vista

  • Windows XP

Limitations connues

Le tableau ci-dessous recense les fonctionnalités et limitations connues d'Internet Explorer 7 (64 bits).

Fonctionnalité Limitation

Se connecter à Outlook, Connexion à Office et Synchroniser avec SharePoint Workspace

Fonctionne avec un contrôle ActiveX et le protocole stssync://. Cette fonctionnalité peut par conséquent être limitée en l'absence de contrôle ActiveX tel que celui fourni dans Microsoft Office 2010. Cette fonctionnalité nécessite une application compatible avec le protocole stssync://, par exemple Microsoft Outlook.

Mode Feuille de données

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Modifier dans l'application Microsoft Office

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Mode Explorateur

Supprimé dans SharePoint Foundation 2010. Les bibliothèques mises à niveau à partir de versions précédentes de SharePoint Foundation 2010 sont susceptibles de contenir des modes Explorateur.

Exporter vers Excel

Télécharge un fichier portant l'extension .iqy dans le navigateur Web. Si Microsoft Excel n'est pas installé et qu'aucune autre application n'est configurée pour ouvrir ce fichier, l'opération ne fonctionnera pas.

Téléchargement et copie de fichiers

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Intégration à Microsoft InfoPath 2010

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Intégration à la bibliothèque d'images Microsoft PowerPoint 2010

Nécessite un contrôle ActiveX 64 bits similaire à celui fourni dans Microsoft Office 2010. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut télécharger plusieurs images vers une bibliothèque d'images, il doit les télécharger une par une en utilisant Upload.aspx.

  • Si un utilisateur veut éditer une image d'une bibliothèque d'images, il doit télécharger l'image, l'éditer, puis la télécharger vers la bibliothèque.

  • Si un utilisateur veut télécharger plusieurs images depuis une bibliothèque d'images, il doit les télécharger une par une en cliquant sur le lien de l'image.

Création de diagramme Microsoft Visio 2010

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Nouveau document

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle. La commande Nouveau document risque de ne pas fonctionner, mais vous pouvez utiliser la fonction Télécharger un document. Si vous installez et configurez des applications Web Office sur le serveur, la commande Nouveau document fonctionnera et vous pourrez alors créer un document Office dans votre navigateur.

Envoyer vers

Peut exploiter un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle. Sans ce contrôle, il est impossible d'envoyer des fichiers d'une batterie de serveurs SharePoint vers une autre batterie de serveurs SharePoint. En revanche, les fichiers peuvent quand même être envoyés d'un site vers un autre site.

Signature de formulaires (InfoPath Forms Services)

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle.

Intégration de feuille de calcul et de base de données

Nécessite un contrôle ActiveX 64 bits. Microsoft Office 2010 ne fournit pas de version 64 bits de ce contrôle. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut éditer un document, il doit télécharger le document, l'éditer, puis l'enregistrer à nouveau sur le serveur.

  • Dans les listes nécessitant qu'un document soit extrait pour pouvoir être édité, les utilisateurs doivent utiliser le menu Edition pour extraire le document, éditer le document, puis l'archiver en utilisant le menu Edition.

  • Exporter vers une feuille de calcul. Les utilisateurs peuvent exporter une liste SharePoint sous forme de feuille de calcul en cliquant sur Exporter vers une feuille de calcul dans l'onglet Liste du ruban.

Connexions de composant WebPart à composant WebPart

Peut nécessiter la désactivation des bloqueurs de fenêtres publicitaires intempestives des navigateurs pour l'accès aux sites SharePoint.

Mozilla Firefox 3.6 (sur les systèmes d'exploitation Windows)

Mozilla Firefox 3.6 est pris en charge sur les systèmes d'exploitation suivants :

  • Windows Server 2008 R2

  • Windows Server 2008

  • Windows Server 2003

  • Windows 7

  • Windows Vista

  • Windows XP

Limitations connues

Le tableau ci-dessous recense les fonctionnalités et limitations connues de Mozilla Firefox 3.6 (sur les systèmes d'exploitation Windows).

Fonctionnalité Limitation

Se connecter à Outlook, Connexion à Office et Synchroniser avec SharePoint Workspace

Fonctionne avec un contrôle ActiveX, mais nécessite un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle. Cette fonctionnalité nécessite une application compatible avec le protocole stssync://, par exemple Microsoft Outlook.

Mode Feuille de données

Nécessite un contrôle ActiveX similaire à celui fourni dans Microsoft Office 2010 ainsi qu'un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle.

Glisser-déplacer de composants WebPart

Le déplacement par glisser-déplacer sur les pages de composants WebPart est impossible. Les utilisateurs doivent cliquer sur Modifier sur le composant WebPart, sélectionner Modifier des composants WebPart, puis sélectionner la zone dans la section Disposition de la page des propriétés du composant WebPart. Les composants WebPart peuvent être déplacés par glisser-déplacer sur les pages.

Modifier dans l'application Microsoft Office

Nécessite un contrôle ActiveX similaire à celui fourni avec SharePoint Foundation 2010, ainsi qu'un adaptateur de contrôle Firefox. Pour plus d'informations sur le plug-in Firefox Microsoft Office 2010, voir Plug-in FFWinPlugin (http://go.microsoft.com/fwlink/?linkid=199867&clcid=0x40C). Si vous installez et configurez les applications Web Office sur le serveur, l'édition fonctionne et vous pouvez modifier les documents Office dans votre navigateur. Cette fonctionnalité n'est opérationnelle qu'avec Microsoft Office 2010 ou un produit équivalent avec un plug-in Firefox.

Mode Explorateur

Supprimé dans SharePoint Foundation 2010. Les bibliothèques mises à niveau à partir de versions précédentes de SharePoint Foundation 2010 sont susceptibles de contenir des modes Explorateur et ceux-ci risquent de ne pas fonctionner. Le mode Explorateur nécessite Internet Explorer.

Exporter vers Excel

Télécharge un fichier portant l'extension .iqy dans le navigateur Web. Si Microsoft Excel n'est pas installé et qu'aucune autre application n'est configurée pour ouvrir ce fichier, l'opération ne fonctionnera pas.

Téléchargement et copie de fichiers

Nécessite un contrôle ActiveX similaire à celui fourni dans Microsoft Office 2010 ainsi qu'un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle.

Intégration à Microsoft InfoPath 2010

Nécessite un contrôle ActiveX similaire à celui fourni dans Microsoft Office 2010 ainsi qu'un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle.

Intégration à la bibliothèque d'images Microsoft PowerPoint 2010

Nécessite un contrôle ActiveX similaire à celui fourni dans Microsoft Office 2010 ainsi qu'un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut télécharger plusieurs images vers une bibliothèque d'images, il doit les télécharger une par une en utilisant Upload.aspx.

  • Si un utilisateur veut éditer une image d'une bibliothèque d'images, il doit télécharger l'image, l'éditer, puis la télécharger vers la bibliothèque.

  • Si un utilisateur veut télécharger plusieurs images depuis une bibliothèque d'images, il doit les télécharger une par une en cliquant sur le lien de l'image.

Création de diagramme Microsoft Visio 2010

Nécessite un contrôle ActiveX similaire à celui fourni dans Microsoft Office 2010 ainsi qu'un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle.

Nouveau document

Nécessite un contrôle ActiveX, tel que celui fourni avecMicrosoft Office 2010, ainsi qu'un adaptateur de contrôle Firefox. Pour plus d'informations sur le plug-in Firefox Microsoft Office 2010, voir Plug-in FFWinPlugin (http://go.microsoft.com/fwlink/?linkid=199867&clcid=0x40C). La commande Nouveau document risque de ne pas fonctionner, mais vous pouvez utiliser la fonction Télécharger un document. Si vous installez et configurez des applications Web Office sur le serveur, la commande Nouveau document fonctionnera et vous pourrez alors créer un document Office dans votre navigateur.

Éditeur de texte enrichi - Barre d'outils de base

Un utilisateur peut mettre à jour la barre d'outils de base Éditeur de texte enrichi en un Éditeur de texte enrichi complet qui comprend un Ruban en modifiant les propriétés du champ de la manière suivante : dans FldEdit.aspx, dans le menu Paramètres de liste, sélectionnez Paramètres de champ. Ensuite, sous Colonnes, cliquez sur Description. Dans la section Paramètres de colonne supplémentaires, sous Spécifiez le type de texte à autoriser, sélectionnez Texte enrichi amélioré (Texte enrichi avec images, tableaux et liens hypertexte).

Envoyer vers

Peut exploiter un contrôle ActiveX similaire à celui fourni dans Microsoft Office 2010 ainsi qu'un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle. Sans ce contrôle, il est impossible d'envoyer des fichiers d'une batterie de serveurs SharePoint vers une autre batterie de serveurs SharePoint. En revanche, les fichiers peuvent quand même être envoyés d'un site vers un autre site.

Signature de formulaires (InfoPath Forms Services)

Nécessite un contrôle ActiveX similaire à celui fourni dans Microsoft Office 2010 ainsi qu'un adaptateur de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle.

Intégration de feuille de calcul et de base de données

Nécessite des contrôles ActiveX similaires à ceux fournis dans Microsoft Office 2010 ainsi que des adaptateurs de contrôle Firefox. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut éditer un document, il doit télécharger le document, l'éditer, puis l'enregistrer à nouveau sur le serveur.

  • Dans les listes nécessitant qu'un document soit extrait pour pouvoir être édité, les utilisateurs doivent utiliser le menu Edition pour extraire le document, éditer le document, puis l'archiver en utilisant le menu Edition.

  • Exporter vers une feuille de calcul. Les utilisateurs peuvent exporter une liste SharePoint sous forme de feuille de calcul en cliquant sur Exporter vers une feuille de calcul dans l'onglet Liste du ruban.

Connexions de composant WebPart à composant WebPart

Peut nécessiter la désactivation des bloqueurs de fenêtres publicitaires intempestives des navigateurs pour l'accès aux sites SharePoint.

Mozilla Firefox 3.6 (sur les systèmes d'exploitation autres que Windows)

Mozilla Firefox 3.6 est pris en charge sur les systèmes d'exploitation suivants :

  • Mac OSX

  • UNIX/Linux

Limitations connues

Le tableau ci-dessous recense les fonctionnalités et limitations connues de Mozilla Firefox 3.6 (sur les systèmes d'exploitation autres que Windows).

Fonctionnalité Limitation

Se connecter à Outlook, Connexion à Office et Synchroniser avec SharePoint Workspace

Nécessite une application compatible avec le protocole stssync://, par exemple Microsoft Outlook.

Mode Feuille de données

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle.

Glisser-déplacer de composants WebPart

Le déplacement par glisser-déplacer sur les pages de composants WebPart est impossible. Les utilisateurs doivent cliquer sur Modifier sur le composant WebPart, sélectionner Modifier des composants WebPart, puis sélectionner la zone dans la section Disposition de la page des propriétés du composant WebPart. Les composants WebPart peuvent être déplacés par glisser-déplacer sur les pages.

Modifier dans l'application Microsoft Office

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme. Si vous installez et configurez les applications Web Office sur le serveur, l'édition fonctionne et vous pouvez modifier les documents Office dans votre navigateur.

Mode Explorateur

Supprimé dans SharePoint Foundation 2010. Les bibliothèques mises à niveau à partir de versions précédentes de SharePoint Foundation 2010 sont susceptibles de contenir des modes Explorateur et ceux-ci risquent de ne pas fonctionner. Le mode Explorateur nécessite Internet Explorer.

Exporter vers Excel

Télécharge un fichier portant l'extension .iqy dans le navigateur Web. Nécessite une application configurée pour ouvrir ce fichier.

Téléchargement et copie de fichiers

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Intégration à Microsoft InfoPath 2010

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Intégration à la bibliothèque d'images Microsoft PowerPoint 2010

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme. Microsoft Office 2010 ne fournit pas d'adaptateur Firefox pour ce contrôle. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut télécharger plusieurs images vers une bibliothèque d'images, il doit les télécharger une par une en utilisant Upload.aspx.

  • Si un utilisateur veut éditer une image d'une bibliothèque d'images, il doit télécharger l'image, l'éditer, puis la télécharger vers la bibliothèque.

  • Si un utilisateur veut télécharger plusieurs images depuis une bibliothèque d'images, il doit les télécharger une par une en cliquant sur le lien de l'image.

Création de diagramme Microsoft Visio 2010

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Nouveau document

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme. La commande Nouveau document risque de ne pas fonctionner, mais vous pouvez utiliser la fonction Télécharger un document. Si vous installez et configurez des applications Web Office sur le serveur, la commande Nouveau document fonctionnera et vous pourrez alors créer un document Office dans votre navigateur.

Éditeur de texte enrichi - Barre d'outils de base

Un utilisateur peut mettre à jour la barre d'outils de base Éditeur de texte enrichi en un Éditeur de texte enrichi complet qui comprend un Ruban en modifiant les propriétés du champ de la manière suivante : dans FldEdit.aspx, dans le menu Paramètres de liste, sélectionnez Paramètres de champ. Ensuite, sous Colonnes, cliquez sur Description. Dans la section Paramètres de colonne supplémentaires, sous Spécifiez le type de texte à autoriser, sélectionnez Texte enrichi amélioré (Texte enrichi avec images, tableaux et liens hypertexte).

Envoyer vers

Peut exploiter un contrôle ActiveX non pris en charge sur cette plateforme. Sans ce contrôle, il est impossible d'envoyer des fichiers d'une batterie de serveurs SharePoint vers une autre batterie de serveurs SharePoint. En revanche, les fichiers peuvent quand même être envoyés d'un site vers un autre site.

Signature de formulaires (InfoPath Forms Services)

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Intégration de feuille de calcul et de base de données

Nécessite des contrôles ActiveX non pris en charge sur cette plateforme. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut éditer un document, il doit télécharger le document, l'éditer, puis l'enregistrer à nouveau sur le serveur.

  • Dans les listes nécessitant qu'un document soit extrait pour pouvoir être édité, les utilisateurs doivent utiliser le menu Edition pour extraire le document, éditer le document, puis l'archiver en utilisant le menu Edition.

  • Exporter vers une feuille de calcul. Les utilisateurs peuvent exporter une liste SharePoint sous forme de feuille de calcul en cliquant sur Exporter vers une feuille de calcul dans l'onglet Liste du ruban.

Connexions de composant WebPart à composant WebPart

Peut nécessiter la désactivation des bloqueurs de fenêtres publicitaires intempestives des navigateurs pour l'accès aux sites SharePoint.

Remarque :
Sur les systèmes UNIX/Linux, les navigateurs Firefox peuvent ne pas fonctionner avec le menu des composants WebPart.

Remarque :
Certaines fonctionnalités ActiveX, telles que l'affichage en mode Feuille de données de liste et le contrôle affichant les informations de présence des utilisateurs, ne fonctionnent pas dans Mozilla Firefox 3.6. Les utilisateurs de Firefox peuvent utiliser le plug-in Firefox Microsoft Office 2010 pour ouvrir des documents.

Safari 4.04 (sur les systèmes d'exploitation autres que Windows)

Safari 4.0.4 est pris en charge sur les systèmes d'exploitation suivants :

  • Mac OSX (Version 10.6, Snow Leopard)

Limitations connues

Le tableau ci-dessous recense les fonctionnalités et limitations connues de Safari 4.04 (sur les systèmes d'exploitation autres que Windows).

Fonctionnalité Limitation

Se connecter à Outlook, Connexion à Office et Synchroniser avec SharePoint Workspace

Nécessite une application compatible avec le protocole stssync://, par exemple Microsoft Outlook.

Mode Feuille de données

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Glisser-déplacer de composants WebPart

Le déplacement par glisser-déplacer sur les pages de composants WebPart est impossible. Les utilisateurs doivent cliquer sur Modifier sur le composant WebPart, sélectionner Modifier des composants WebPart, puis sélectionner la zone dans la section Disposition de la page des propriétés du composant WebPart. Les composants WebPart peuvent être déplacés par glisser-déplacer sur les pages.

Modifier dans l'application Microsoft Office

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme. Si vous installez et configurez les applications Web Office sur le serveur, l'édition fonctionne et vous pouvez modifier les documents Office dans votre navigateur.

Mode Explorateur

Supprimé dans SharePoint Foundation 2010. Les bibliothèques mises à niveau à partir de versions précédentes de SharePoint Foundation 2010 sont susceptibles de contenir des modes Explorateur. Le mode Explorateur nécessite Internet Explorer.

Exporter vers Excel

Télécharge un fichier portant l'extension .iqy dans le navigateur Web. Nécessite une application configurée pour ouvrir ce fichier.

Téléchargement et copie de fichiers

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Intégration à Microsoft InfoPath 2010

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Intégration à la bibliothèque d'images Microsoft PowerPoint 2010

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut télécharger plusieurs images vers une bibliothèque d'images, il doit les télécharger une par une en utilisant Upload.aspx.

  • Si un utilisateur veut éditer une image d'une bibliothèque d'images, il doit télécharger l'image, l'éditer, puis la télécharger vers la bibliothèque.

  • Si un utilisateur veut télécharger plusieurs images depuis une bibliothèque d'images, il doit les télécharger une par une en cliquant sur le lien de l'image.

Création de diagramme Microsoft Visio 2010

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Nouveau document

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme. La commande Nouveau document risque de ne pas fonctionner, mais vous pouvez utiliser la fonction Télécharger un document. Si vous installez et configurez des applications Web Office sur le serveur, la commande Nouveau document fonctionnera et vous pourrez alors créer un document Office dans votre navigateur.

Éditeur de texte enrichi - Barre d'outils de base

Un utilisateur peut mettre à jour la barre d'outils de base Éditeur de texte enrichi en un Éditeur de texte enrichi complet qui comprend un Ruban en modifiant les propriétés du champ de la manière suivante : dans FldEdit.aspx, dans le menu Paramètres de liste, sélectionnez Paramètres de champ. Ensuite, sous Colonnes, cliquez sur Description. Dans la section Paramètres de colonne supplémentaires, sous Spécifiez le type de texte à autoriser, sélectionnez Texte enrichi amélioré (Texte enrichi avec images, tableaux et liens hypertexte).

Envoyer vers

Peut exploiter un contrôle ActiveX non pris en charge sur cette plateforme. Sans ce contrôle, il est impossible d'envoyer des fichiers d'une batterie de serveurs SharePoint vers une autre batterie de serveurs SharePoint. En revanche, les fichiers peuvent quand même être envoyés d'un site vers un autre site.

Signature de formulaires (InfoPath Forms Services)

Nécessite un contrôle ActiveX non pris en charge sur cette plateforme.

Intégration de feuille de calcul et de base de données

Nécessite des contrôles ActiveX non pris en charge sur cette plateforme. Voici les solutions de contournement envisageables si aucun contrôle n'a été installé :

  • Si un utilisateur veut éditer un document, il doit télécharger le document, l'éditer, puis l'enregistrer à nouveau sur le serveur.

  • Dans les listes nécessitant qu'un document soit extrait pour pouvoir être édité, les utilisateurs doivent utiliser le menu Edition pour extraire le document, éditer le document, puis l'archiver en utilisant le menu Edition.

  • Exporter vers une feuille de calcul. Les utilisateurs peuvent exporter une liste SharePoint sous forme de feuille de calcul en cliquant sur Exporter vers une feuille de calcul dans l'onglet Liste du ruban.

Connexions de composant WebPart à composant WebPart

Peut nécessiter la désactivation des bloqueurs de fenêtres publicitaires intempestives des navigateurs pour l'accès aux sites SharePoint.

Contrôles ActiveX

Certaines fonctionnalités de SharePoint Foundation 2010 utilisent des contrôles ActiveX. Dans les environnements sécurisés, ces contrôles doivent être en mesure de fonctionner sur l'ordinateur client pour que les fonctionnalités correspondantes puissent fonctionner. Certains contrôles ActiveX, tels que ceux inclus dans Microsoft Office 2010, ne fonctionnent pas avec les versions 64 bits des navigateurs. Pour Microsoft Office 2010 (64 bits), seul le contrôle suivant fonctionne avec les navigateurs 64 bits :

  • name.dll -Informations de présence

Historique des modifications


Prise en charge IP (SharePoint Foundation 2010)
Voir aussi

Cet article porte sur la prise en charge de l'adressage Internet Protocol Version 4 (IPv4) et Internet Protocol Version 6 (IPv6) dans Produits Microsoft SharePoint 2010.

Produits SharePoint 2010 prennent en charge les environnements suivants :

  • Environnements exclusivement IPv4

  • Environnements mixtes IPv4 et IPv6

  • Environnements exclusivement IPv6

Dans un environnement SharePoint, « mixte » peut faire référence à l'un des scénarios probables suivants :

  • Les protocoles IPv4 et IPv6 sont exécutés dans votre environnement.

  • Certains de vos ordinateurs clients utilisent IPv4, tandis que d'autres ont recours à IPv6.

  • Vos ordinateurs clients utilisent IPv4, mais l'ordinateur exécutant Microsoft SQL Server emploie IPv6.

Par défaut, les protocoles IPv6 et IPv4 sont tous les deux installés et activés dans Windows Server 2008 et Windows Server 2008 R2. Lorsque les protocoles IPv4 st IPv6 sont tous deux activés, le protocole IPv6 a préséance sur le protocole IPv4. En outre, vous pouvez supprimer le protocole IPv4 pour faire en sorte que l'ordinateur utilise exclusivement le protocole IPv6.

Pour savoir quelle version est actuellement utilisée, vous pouvez utiliser l'outil IPConfig.exe. Pour plus d'informations, voir IPConfig (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=122336&clcid=0x40C).

La liste suivante fournit des observations importantes concernant IPv6 :

  • Pour tout ordinateur authentifié à l'aide d'un serveur de domaine et exécutant uniquement IPv6 dans un environnement des produits SharePoint, le contrôleur de domaine doit exécuter Windows Server 2008 ou Windows Server 2008 R2. Vérifiez que vous utilisez le Service Pack approprié et les éventuels logiciels supplémentaires requis. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  • Toutes les versions de Microsoft SQL Server prises en charge pour Produits SharePoint 2010 prennent également en charge IPv6. Pour plus d'informations sur la prise en charge d'IPv6 pour SQL Server 2008, voir Connexion avec IPv6 (http://go.microsoft.com/fwlink/?linkid=183115&clcid=0x40C). Pour plus d'informations sur la prise en charge d'IPv6 pour SQL Server 2005, voir Connexion avec IPv6 (http://go.microsoft.com/fwlink/?linkid=183118&clcid=0x40C).

  • Dans Produits SharePoint 2010, lors de l'utilisation du protocole IPv6, toutes les URL (Uniform Resource Locators) d'utilisateur doivent être basées sur des noms DNS avec des enregistrements AAAA. La navigation vers des URL de produits et technologies SharePoint utilisant des URL d'adresse littérale IPv6 n'est pas prise en charge. Un exemple d'URL d'adresse littérale est http://[2001:db8:85a3:8d3:1319:8a2e:370:7344]. Cependant, Produits SharePoint 2010 prennent en charge la saisie d'adresse IPv6 littérales pour certaines fonctionnalités d'administration de batterie de serveurs, par exemple la saisie du nom de serveur lors de la création ou de l'attachement de base de données. Pour les noms de serveurs qui utilisent un format d'adresse littéral, vous devez mettre l'adresse littérale entre crochets. Pour plus d'informations sur des enregistrements AAAA, voir Ajout d'un enregistrement de ressource à une zone de recherche directe (http://go.microsoft.com/fwlink/?linkid=181956&clcid=0x40C).

Pour plus d'informations sur le protocole IPv6, voir Protocole IPv6 (Internet Protocol Version 6) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=120794&clcid=0x40C) et Adressage IP (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=120795&clcid=0x40C).

Voir aussi

Autres ressources

Spécification du protocole Internet , Version 6 (IPv6) (éventuellement en anglais)

Historique des modifications


Prise en main de SharePoint Foundation 2010

Pour obtenir des informations de base sur les fonctionnalités et la configuration requise pour Microsoft SharePoint Foundation 2010, voir le centre de ressources de mise en route sur TechNet.

Historique des modifications


Mise en route de la Recherche de contenu d'entreprise dans les produits SharePoint 2010 (livre blanc)

Ce livre blanc présente la recherche de contenu d'entreprise dans les produits Microsoft SharePoint 2010. La recherche de contenu d'entreprise comprend bon nombre de fonctions, fonctionnalités et modèles de gestion des licences :

  • Microsoft SharePoint Foundation 2010

  • Microsoft Search Server 2010 Express

  • Microsoft Search Server 2010

  • Microsoft SharePoint Server 2010

  • Microsoft FAST Search Server 2010 for SharePoint

Pour télécharger le livre blanc dans le format souhaité, cliquez sur les liens suivants :

  • Mise en route de la recherche de contenu d'entreprise dans les produits SharePoint 2010 (Microsoft Office Word) (http://go.microsoft.com/fwlink/?linkid=189434&clcid=0x40C)

  • Mise en route de la recherche de contenu d'entreprise dans les produits SharePoint 2010 (PDF) (http://go.microsoft.com/fwlink/?linkid=189435&clcid=0x40C)

  • Mise en route de la recherche de contenu d'entreprise dans les produits SharePoint 2010 (XPS) (http://go.microsoft.com/fwlink/?linkid=189436&clcid=0x40C)

Historique des modifications


Planification et architecture pour SharePoint Foundation 2010

Les informaticiens peuvent utiliser le contenu lié à la planification et à l'architecture afin de développer des solutions conceptuelles, logiques et physiques pour la configuration de topologies, de serveurs et de fonctionnalités Microsoft SharePoint Foundation 2010. Cette section fournit également des recommandations pour les conceptions système basées sur des scénarios clients et comprend des informations qui permettent aux informaticiens de concevoir un système hautement fiable et constamment disponible et évolutif.

Ressources téléchargeables

  • Diagrammes techniques

  • Feuilles de planification

Articles relatifs à la planification

Planification de sites et de solutions Planification des environnements de batteries de serveurs et de serveurs
  • Composants fondamentaux de site

  • Sécurité des sites et du contenu

  • Solutions en bac à sable

  • Sites de collaboration

  • Gestion de documents

  • Données métier et processus

  • Gestion des quotas

  • Configuration système requise

  • Authentification

  • Renforcement de la sécurité

  • Modification automatique des mots de passe

  • Gestion de la continuité des opérations

  • Virtualisation

Historique des modifications


Diagrammes techniques (SharePoint Foundation 2010)

Bon nombre de ces ressources sont des représentations visuelles des solutions recommandées. Elles incluent des documents de la taille d'une affiche disponibles dans les formats de fichiers Microsoft Office Visio 2007. (.vsd), PDF et XPS. Vous aurez peut-être besoin de logiciels supplémentaires pour afficher ces fichiers. Voir le tableau suivant pour des informations sur l'ouverture de ces fichiers.

Type de fichier Logiciels

.vsd

Office Visio 2007 ou la visionneuse Visio gratuite (http://go.microsoft.com/fwlink/?linkid=118761&clcid=0x40C)

Si vous utilisez la visionneuse Visio, cliquez avec le bouton droit sur le lien VSD, puis cliquez sur Enregistrer la cible sous, enregistrez le flichier sur votre ordinateur et ouvrez-le depuis votre ordinateur.

.pdf

N'importe quelle visionneuse PDF, par exemple Adobe Reader (http://go.microsoft.com/fwlink/?linkid=134751&clcid=0x40C)

.xps

Windows 7, Windows Vista, Windows XP avec .NET Framework 3.0 ou XPS Essentials Pack (http://go.microsoft.com/fwlink/?linkid=134750&clcid=0x40C)

Modèles

Les modèles sont des affiches 86x112 cm qui détaillent une zone technique spécifique. Ces modèles sont destinés à être utilisés avec les articles correspondants sur TechNet. Ils sont créés à l'aide d'Office Visio 2007. Vous pouvez modifier les fichiers Visio pour illustrer comment vous envisagez d'incorporer les Produits Microsoft SharePoint 2010 dans votre propre environnement.

Titre Description

Déploiement des produits SharePoint 2010

Déploiement des produits SharePoint 2010

Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183024&clcid=0x40C)

PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183025&clcid=0x40C)

XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183026&clcid=0x40C)

Présente des informations sur le déploiement telles que les différentes phases et les différents environnements de déploiement, ainsi qu'un organigramme qui illustre les étapes d'installation et de configuration des Produits SharePoint 2010.

Services dans les produits SharePoint 2010

Services de SharePoint - 1 sur 2

Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167090&clcid=0x40C)

PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167092&clcid=0x40C)

XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167091&clcid=0x40C)

Décrit et illustre l'architecture des services, y compris les moyens de déployer des services dans la conception globale de votre solution.

Services entre batteries de serveurs dans les produits SharePoint 2010

Services de SharePoint - 2 sur 2

Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167093&clcid=0x40C)

PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167095&clcid=0x40C)

XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167094&clcid=0x40C)

Montre comment déployer des services dans les batteries de serveurs pour fournir une administration centralisée des services.

Topologies extranet pour produits SharePoint 2010

Topologies extranet pour produits SharePoint 2010

Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187987&clcid=0x40C)

PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187988&clcid=0x40C)

XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187986&clcid=0x40C)

Illustre les topologies extranet spécifiques qui ont été testées avec les produits SharePoint 2010. Fournit une comparaison entre ISA Server, Forefront TMG, Forefront UAG en cas d'utilisation en tant que produit servant de pare-feu ou de passerelle avec des produits SharePoint 2010.

Environnements d'hébergement dans les produits SharePoint 2010

Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167084&clcid=0x40C)

PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167086&clcid=0x40C)

XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167085&clcid=0x40C)

Présente une synthèse de la prise en charge des environnements d'hébergement et montre des architectures d'hébergement courantes.

Technologies de recherche pour les produits SharePoint 2010

Technologies de recherche - 1 sur 4

Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167731&clcid=0x40C)

PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167733&clcid=0x40C)

XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167732&clcid=0x40C)

Compare et met en opposition les technologies de recherche qui fonctionnent avec les produits SharePoint 2010 :

  • SharePoint Foundation 2010

  • Search Server 2010 Express

  • Search Server 2010

  • SharePoint Server 2010

  • FAST Search Server 2010 for SharePoint

Bases de données prenant en charge les produits SharePoint 2010

Bases de données prenant en charge les produits SharePoint 2010

Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187970&clcid=0x40C)

PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187969&clcid=0x40C)

XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187971&clcid=0x40C)

Décrit les bases de données Microsoft SQL Server sur lesquelles s'exécute SharePoint Foundation 2010.

Conseils d'impression pour les affiches

Si vous disposez d'un traceur, vous pouvez imprimer ces affiches à leur taille réelle. Sinon, suivez les étapes ci-après pour les imprimer en format réduit.

Imprimer des affiches en format réduit

  1. Ouvrez l'affiche dans Visio.

  2. Dans le menu Fichier, cliquez sur Mise en page.

  3. Sous l'onglet Mise en page, dans la section Papier de l'imprimante, sélectionnez la taille du papier sur lequel vous voulez imprimer.

  4. Sous l'onglet Configuration de l'impression, dans la section Zoom d'impression, cliquez sur Ajuster et entrez 1 page en largeur et 1 page en hauteur.

  5. Sous l'onglet Taille de la page, cliquez sur Ajuster au contenu du dessin, puis sur OK.

  6. Dans le menu Fichier, cliquez sur Imprimer.

Historique des modifications

Date | Description | Raison
17 juin 2010 | 2010/06/14 | Mise à jour du contenu


Planification de sites et de solutions (SharePoint Foundation 2010)
Voir aussi

Cette section contient des rubriques qui vous aideront à planifier votre site Microsoft SharePoint Foundation 2010 et les composants de solution.

  • Planification de site fondamentale (SharePoint Foundation 2010)

    Les rubriques de cette section vous aideront à planifier les sites qui utilisent des fonctionnalités SharePoint Foundation 2010.

  • Planification de la sécurité pour les sites et le contenu (SharePoint Foundation 2010)

    Les rubriques de cette section vous aideront à planifier les autorisations de contrôle d'accès à vos sites et au contenu.

  • Planification de solutions en mode bac à sable (SharePoint Foundation 2010)

    Les rubriques de cette section vous aideront à planifier des solutions en mode bac à sable qui s'exécutent dans des environnements d'exécution restreints au sein de votre entreprise.

  • Planification des sites de collaboration (SharePoint Foundation 2010)

    Les rubriques de cette section vous aideront à planifier des solutions qui implémentent des fonctionnalités de collaboration dans votre entreprise.

  • Planification de la gestion des documents (SharePoint Foundation 2010)

    Les rubriques de cette section fournissent des informations conceptuelles sur la gestion des documents.

  • Planification de données métier et de processus (SharePoint Foundation)

    Les rubriques de cette section vous aideront à planifier des solutions qui implémentent des processus d'entreprise au niveau des données de l'organisation.

    • Planifier Business Connectivity Services (SharePoint Foundation 2010)

      Les rubriques de cette section vous aideront à planifier des solutions qui permettent de connecter les données externes de votre organisation aux travailleurs de l'information utilisant des sites Web SharePoint.

    • Planifier les flux de travail (SharePoint Foundation 2010)

      Les rubriques de cette section vous aideront à planifier et à implémenter des processus dans vos solutions SharePoint.

  • Planifier la gestion des quotas (SharePoint Foundation 2010)

    Cet article contient des conseils sur la façon de déterminer les paramètres des modèles de quotas et des Corbeilles, ainsi que sur le choix ou le moment le plus opportun en matière de suppression des sites Web inutilisés.

Voir aussi

Concepts

Planification de batterie de serveurs et de l'environnement (SharePoint Foundation 2010)

Historique des modifications


Planification de site fondamentale (SharePoint Foundation 2010)

Cette section fournit des informations pour aider les professionnels de l'informatique à planifier des sites utilisant des fonctionnalités de Microsoft SharePoint Foundation 2010.

L'efficacité d'un site ou d'un groupe de sites dépend de nombreux facteurs. Un des facteurs plus importants est la capacité à localiser de manière prévisible le site et le contenu dont vous avez besoin dans le site. La structure d'un site ou d'un groupe de sites et la navigation à l'intérieur et parmi les sites sont importantes pour aider les utilisateurs à rechercher et partager des informations et à travailler ensemble.

Dans cette section :

  • Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010) décrit les collections de sites et les sites. Cet article contient également des informations sur les modèles de site utilisés pour créer des sites dans SharePoint Foundation 2010.

  • Planifier les sites et les collections de sites (SharePoint Foundation 2010) décrit les processus et les considérations importantes pour la planification de sites et de collections de sites de SharePoint Foundation 2010.

  • Vue d'ensemble de la navigation dans les sites (SharePoint Foundation 2010) fournit une vue d'ensemble des types de navigation disponibles dans un site.

  • Planifier la navigation sur les sites (SharePoint Foundation 2010) permet de concevoir la navigation de votre site.

  • Vue d'ensemble des thèmes (SharePoint Foundation 2010) fournit une vue d'ensemble des thèmes et de leur fonctionnement.

  • Planifier l'utilisation des thèmes (SharePoint Foundation 2010) explique comment planifier l'utilisation de thèmes sur vos sites, et il inclut des étapes importantes pour planifier l'utilisation de thèmes pour vos sites.

  • Planifier des sites multilingues (SharePoint Foundation 2010) explique comment planifier des sites SharePoint Foundation 2010 multilingues.

Historique des modifications


Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010)
Voir aussi

Une collection de sites Microsoft SharePoint Foundation 2010 est une structure de site hiérarchique composée d'un site de niveau supérieur et de sites inférieurs. Cet article décrit les collections de sites et les sites et contient des informations sur les modèles de sites utilisés pour créer des sites dans SharePoint Foundation 2010.

Dans cet article :

  • Vue d'ensemble des collections de sites

  • Vue d'ensemble des sites

  • Modèles de site inclus dans SharePoint Foundation 2010

Vue d'ensemble des collections de sites

Les sites contenus dans une collection de sites partagent les mêmes paramètres d'administration, le même système de navigation et d'autres fonctionnalités et éléments communs. Chaque collection de sites contient un site de niveau supérieur et (généralement) un ou plusieurs sites inférieurs dans une structure hiérarchique.

Regrouper le contenu et les fonctionnalités de votre site dans une collection de sites offre les avantages suivants :

  • Pour les concepteurs de site, les galeries et bibliothèques d'une collection de sites (par exemple la galerie des pages maîtres ou la bibliothèque des images de la collection de sites) permettent de proposer une utilisation personnalisée et unique pour tous les sites de la collection de sites.

  • Pour les administrateurs des collections de sites, une collection de sites fournit un mécanisme et une étendue unifiés pour l'administration. Par exemple, la sécurité, les stratégies et les fonctionnalités peuvent être gérées ensemble pour une collection de sites entière ; les rapports d'analyse Web de la collection de sites, les rapports du journal d'audit et d'autres données peuvent aider les administrateurs à effectuer le suivi des performances et de la sécurité des collections de sites.

  • En ce qui concerne les administrateurs de batteries de serveurs, les collections de sites leur procurent l'évolutivité nécessaire à la croissance en fonction de la quantité de contenu stocké. Étant donné que chaque collection de sites peut utiliser une base de données de contenu unique, les administrateurs peuvent facilement les déplacer vers des serveurs différents.

  • Pour les créateurs de site, les colonnes de site partagées d'une collection de sites, les composants WebPart, les ressources de création, les flux de travail et d'autres fonctionnalités fournissent un environnement de création cohérent.

  • Pour les utilisateurs de site, la navigation unifiée d'une collection de sites, la personnalisation et les outils de recherche offrent une expérience identique sur tout le site Web.

Vue d'ensemble des sites

Une collection de sites se compose d'un site de niveau supérieur et d'un ou plusieurs sites inférieurs. Chaque site de niveau supérieur et site inférieur dans la structure du site repose sur un modèle de site et peut avoir d'autres paramètres uniques, avec un contenu unique. Décomposez le contenu de votre collection de sites en sites séparés pour définir plus précisément l'apparence, le contenu et les fonctionnalités des différentes pages de votre collection de sites. La liste suivante inclut les fonctionnalités de site que vous pouvez configurer de manière unique :

  • Modèles Chaque site peut avoir un modèle unique. Pour plus d'informations, voir Modèles de site inclus dans SharePoint Foundation 2010.

  • Langue Si des modules linguistiques ont été installés sur le serveur Web, vous pouvez sélectionner un modèle de site propre à la langue lorsque vous créez un site. Le texte qui apparaît sur le site s'affiche dans la langue du modèle de site. Pour plus d'informations, voir Déployer des modules linguistiques (SharePoint Foundation 2010).

  • Sécurité Vous pouvez définir des groupes d'utilisateurs uniques et des autorisations pour chaque site.

  • Navigation Vous pouvez perfectionner l'expérience de navigation en configurant des liens de navigation propres à chaque partie de la hiérarchie de votre site. La navigation du site reflète les relations entre les sites d'une collection de sites. De ce fait, la planification de la navigation et la planification des structures de sites sont des activités étroitement liées. Pour plus d'informations, voir Vue d'ensemble de la navigation dans les sites (SharePoint Foundation 2010).

  • Pages Web Chaque site peut comporter une page d'accueil unique et d'autres pages.

  • Mises en page des sites Vous pouvez rendre disponibles des dispositions ou des pages maîtres uniques dans un site.

  • Thèmes Vous pouvez modifier les couleurs et les polices d'un site. Pour plus d'informations, voir Planifier l'utilisation des thèmes (SharePoint Foundation 2010).

  • Paramètres régionaux Vous pouvez modifier les paramètres régionaux, tels que le fuseau horaire, l'ordre de tri, le format d'heure et le type de calendrier.

  • Recherche Un site peut avoir ses propres paramètres de recherche. Par exemple, vous pouvez spécifier qu'un site particulier ne doit jamais figurer dans les résultats de la recherche.

  • Types de contenu Un site peut avoir des types de contenu et des colonnes de site uniques.

  • Flux de travail Chaque site peut avoir des flux de travail uniques. Pour plus d'informations, voir Planifier les flux de travail (SharePoint Foundation 2010).

Modèles de site inclus dans SharePoint Foundation 2010

La section qui suit contient des informations sur les modèles de site inclus dans SharePoint Foundation 2010. Bien que vous puissiez utiliser un modèle de site avec sa configuration par défaut, vous pouvez également modifier les paramètres par défaut du site en utilisant les pages administration du site, puis enregistrer le site comme nouveau modèle. De plus, vous pouvez modifier la conception et les fonctionnalités d'un modèle en utilisant Microsoft SharePoint Designer 2010 ou Microsoft Visual Studio 2010.

Le tableau suivant répertorie chaque modèle de site, décrit leur finalité et indique si le modèle est disponible au niveau de la collection de sites ou du site, ou les deux. La catégorie utilisée pour regrouper les modèles peut être différente, selon le niveau auquel un site a été créé.

Modèle | Objectif | Catégorie dans la collection de sites | Catégorie dans le site
< Sélectionner le modèle ultérieurement> | Site vide pour lequel vous pouvez sélectionner un modèle ultérieurement. | Personnalisé | N/A
Espace de travail Réunion de base | Site permettant de planifier, organiser et capturer les résultats d'une réunion. Il fournit des listes pour gérer l'ordre du jour, les participants et les documents de la réunion. | Réunions | Réunions
Espace de travail de réunion vide | Site de réunion vide, que vous pouvez personnaliser en fonction de vos besoins. | Réunions | Réunions
Site vide | Site vide, que vous pouvez personnaliser en fonction de vos besoins. | Collaboration | Vide ; personnalisé
Blog | Site permettant à une personne ou à une équipe de publier des idées, des observations et des connaissances que les visiteurs du site peuvent commenter. | Collaboration | Contenu
Espace de travail de réunion pour la prise de décision | Site de suivi ou de prise de décisions lors de réunions. Il fournit des listes pour créer des tâches, stocker des documents et enregistrer des décisions. | Réunions | Réunions
Espace de travail de document | Site permettant à des collègues de travailler ensemble sur un document. Il propose une bibliothèque de documents destinée à accueillir les principaux documents et les fichiers complémentaires, une liste des tâches permettant d'affecter les tâches et une liste de liens pour référencer les ressources ayant un rapport avec les documents. | Collaboration | Collaboration, contenu
Site de travail de groupe | Ce modèle fournit un synergiciel que les équipes peuvent utiliser pour créer, organiser et partager des informations. Il inclut le calendrier de groupe, la circulation, le mémo des appels téléphoniques, la bibliothèque de documents et les autres listes de base. | Collaboration | Collaboration
Espace de travail Réunion multipage | Site vous permettant de planifier une réunion et de capturer les décisions et autres résultats de la réunion. Il fournit des listes pour gérer l'ordre du jour et les participants à la réunion, avec deux pages vierges que vous pouvez personnaliser en fonction de vos besoins. | Réunions | Réunions
Espace de travail Réunion informelle | Un site sur lequel vous pouvez planifier des événements informels. Il propose des listes de suivi des participants, fournissant des instructions et stockant les images de l'événement. | Réunions | Réunions
Site d'équipe | Site permettant à une équipe d'organiser, créer et partager rapidement des informations. Il fournit une bibliothèque de documents et des listes pour la gestion des annonces, des éléments de calendrier, des tâches et des discussions. | Collaboration | Collaboration

Voir aussi

Concepts

Planifier les sites et les collections de sites (SharePoint Foundation 2010)
Vue d'ensemble de la navigation dans les sites (SharePoint Foundation 2010)
Planifier la navigation sur les sites (SharePoint Foundation 2010)

Historique des modifications


Planifier les sites et les collections de sites (SharePoint Foundation 2010)
Voir aussi

Les sites Microsoft SharePoint Foundation 2010 sont composés d'une collection de sites, qui est une structure hiérarchique contenant un site de niveau supérieur et tous les sites situés au-dessous de celui-ci. Cet article décrit le processus de planification de sites et de collections de sites SharePoint Foundation 2010, souligne des points importants à prendre en considération et recommande une méthode pour enregistrer les décisions que vous prenez au sujet de la structure des sites. Pour plus d'informations sur les sites et les collections de sites, ainsi que sur les modèles de sites utilisés pour la création de sites dans SharePoint Foundation 2010, voir Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010).

Dans cet article :

  • À propos de la planification des sites et des collections de sites

  • Déterminer les types de sites

    • Planifier des sites en tenant compte de la hiérarchie de l'entreprise

    • Planifier des sites d'application

    • Planifier des sites de présence Internet

    • Planifier d'autres sites

  • Déterminer les collections de sites

  • Feuille relative aux données sur la planification du site

À propos de la planification des sites et des collections de sites

En général, vous planifiez vos sites et collections de sites dans l'ordre suivant :

  • Déterminez le nombre et les types de sites de niveau supérieur et de sites au-dessous de ceux-ci dans la hiérarchie qui sont requis.

  • Déterminez le nombre et les types de collections de sites dans lesquelles les sites seront organisés.

Déterminer les types de sites

La première étape de la planification d'une solution basée sur SharePoint Foundation 2010 consiste à déterminer les types de sites dont votre organisation et ses clients ont besoin. Le fait de déterminer les types de sites a un impact sur les décisions de planification ultérieures, telles que les endroits où les sites seront implémentés dans votre topologie de serveurs, les fonctionnalités à planifier pour chaque site, la façon dont les processus qui couvrent plusieurs sites sont implémentés, et la façon dont les informations sont rendues disponibles sur un ou plusieurs sites. Cette section contient des informations sur la planification des différents types de sites.

Planifier des sites en tenant compte de la hiérarchie de l'entreprise

Planifiez les sites de base dont vous avez besoin selon l'échelle et la structure de votre organisation. Chacun de ces sites peut contenir les informations nécessaires pour un projet ou une division au sein d'une organisation plus vaste, et chacun aura des liens avec les sites de collaboration pertinents pour ce projet ou cette division. Certains sites pour des divisions ou des projets plus vastes vont également agréger des informations trouvées sur tous les sites plus petits consacrés à des divisions ou des projets de plus petite taille.

Utilisez les directives suivantes lorsque vous planifiez des sites basés sur la structure de l'organisation :

Sites de division ou d'équipe Prévoyez de créer un site pour une organisation de petite taille, ou un site pour chaque division ou projet de 50 à 100 personnes dans une organisation de taille moyenne à grande. Dans les grandes organisations, il peut exister plusieurs niveaux de sites, chaque site étant dédié à un contenu créé et géré à son niveau de l'organisation.

Vous pouvez créer un site pour que les membres de votre organisation collaborent sur du contenu relatif aux objectifs de votre entreprise ou de votre organisation. Ces sites peuvent être autonomes ou fonctionner avec d'autres sites comme éléments d'un processus de publication. Ces sites contiennent souvent un mélange de contenus collaboratifs utilisés en interne et de contenus destinés à la publication auprès d'une audience.

Sites d'agrégation Un site d'agrégation contient du contenu général transversal à l'organisation. Il permet aux utilisateurs des différentes divisions de trouver des informations, des experts et un accès aux processus mis en œuvre à l'échelle de l'organisation. Il contient souvent des sites liés à l'architecture informatique organisationnelle globale et qui sont généralement mappés à la structure des sites de division ou de projet. Pour chaque organisation, prévoyez de créer un site centralisé d'agrégation qui utilise une vue agrégée de tous les sites connexes.

Planifier des sites d'application

Un site d'application organise les processus d'équipe et fournit des mécanismes pour les exécuter. Les sites d'application incluent souvent des tableaux de bord numériques et d'autres fonctionnalités pour afficher et manipuler des données relatives aux objectifs du site. Les informations présentées dans un site d'application proviennent généralement de différentes sources, telles que des bases de données ou d'autres sites SharePoint.

Par exemple, l'organisation des ressources humaines d'une structure peut créer un site d'application afin d'offrir aux collaborateurs :

  • un accès aux informations générales, telles que des guides du collaborateur et les opportunités de carrière ;

  • des moyens pour accomplir des tâches courantes, telles que l'envoi des feuilles de temps et des notes de frais ;

  • des tableaux de bord pour afficher des informations personnalisées, telles que l'historique du salaire et des avantages des collaborateurs.

Autre exemple, le groupe du support technique interne au sein d'une organisation, qui peut concevoir un site d'application d'assistance pour fournir le support technique aux membres de l'organisation. Les fonctionnalités du site d'application peuvent être les suivantes :

  • l'accès à une base de connaissances des derniers incidents prise en charge et une documentation des pratiques recommandées ;

  • les moyens d'accomplir des tâches courantes, telles que le démarrage d'un incident de support technique ou la consultation du statut d'un incident en cours ;

  • l'intégration avec les fonctionnalités de communication prenant en charge les réunions et les discussions en ligne.

  • des vues personnalisées des données. Par exemple, les responsables du support peuvent afficher des tableaux de bord qui fournissent des vues de la productivité des membres d'équipe et des évaluations de satisfaction des clients. Les techniciens du support technique peuvent visualiser leurs incidents non résolus actifs.

Planifier des sites de présence Internet

Les sites de présence Internet sont des sites exposés aux clients. Ils sont généralement spécifiques à une organisation et sont caractérisés par des éléments stylistiques cohérents, tels que des couleurs, des polices et des logos, en plus d'éléments structurels tels que les fonctionnalités de navigation et la structure des pages du site. Bien que l'apparence d'un site de présence Internet soit étroitement contrôlée, le contenu du site peut être dynamique et peut changer fréquemment.

Par exemple, le site de présence Internet d'un groupe communique des informations importantes de la société aux clients, partenaires, investisseurs et collaborateurs potentiels. Il s'agit notamment de descriptions des produits et des services, d'actualités concernant la société, de rapports annuels, de publications légales et de postes vacants. Un autre exemple est celui d'un site Internet d'actualités en ligne fournissant des informations fréquemment mises à jour, ainsi que des fonctionnalités interactives, telles que des bandeaux de cours de bourse et des blogs.

Planifier d'autres sites

Vous pouvez permettre aux membres d'équipe de créer d'autres sites, tels que des sites d'espace de travail de document, lorsqu'ils collaborent sur des documents et d'autres projets. De même, vous pouvez donner accès aux utilisateurs d'un site Internet à des sites de collaboration dans le cadre d'un service Web. Par exemple, vous pouvez leur donner des autorisations pour créer des sites d'espace de travail de réunion et pour participer à des réunions en ligne dans le cadre de l'utilisation de votre site.

Pour plus d'informations sur les types de sites que vous pouvez créer, voir Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010).

Déterminer les collections de sites

Après la détermination des types de sites requis par votre solution, l'étape suivante consiste à planifier comment ces sites sont implémentés à travers des collections de sites. Une collection de sites est un ensemble hiérarchique de sites qui peuvent être gérés ensemble. Les sites dans une collection de sites ont des fonctionnalités communes, telles que des autorisations partagées, des galeries de modèles, des types de contenus et des composants WebPart, et ils partagent souvent une navigation commune. Un site est souvent implémenté en tant que collection de sites, le site de niveau supérieur faisant office de page d'accueil de la collection de sites.

En règle générale, lorsque vous planifiez une solution basée sur SharePoint Foundation 2010, placez les types de sites suivants dans des collections de sites distinctes :

  • Sites Internet (intermédiaires)

  • Sites Internet (production)

  • Tous les sites d'équipe liés à un site Internet ou à un site de division

Tous les sites d'une collection de sites sont stockés ensemble dans la même base de données SQL. Cela peut avoir une incidence sur les performances des sites et des serveurs, suivant la structure de vos collections de sites et de vos sites et la finalité de ces derniers. Gardez à l'esprit les limites suivantes lorsque vous planifiez l'allocation du contenu dans une ou plusieurs collections de sites :

  • Conservez les sites extrêmement actifs dans des collections de sites distinctes. Par exemple, un site de base de connaissances sur Internet autorisant un accès anonyme peut générer beaucoup d'activité de base de données. Si d'autres sites utilisent la même base de données, leurs performances pourraient être compromises. En plaçant le site de base de connaissances dans une collection de sites distincte avec sa propre base de données, vous pouvez rendre des ressources disponibles pour d'autres sites et éliminer les problèmes de concurrence d'accès à des ressources de base de données.

  • Étant donné que tout le contenu d'une collection de sites est stocké dans la même base de données de contenu, les performances des opérations de base de données, par exemple la sauvegarde et la restauration de contenu, dépendent du volume de contenu dans l'ensemble de la collection de sites, de la taille de la base de données, de la vitesse des serveurs hébergeant la base de données et d'autres facteurs. Selon le volume du contenu et la configuration de la base de données, vous devrez éventuellement scinder une collection de sites en plusieurs collections de sites pour satisfaire les contrats de niveau de service pour la sauvegarde et la restauration, le débit ou autres exigences. Il n'entre pas dans le cadre de cet article de fournir des instructions sur la façon de gérer la taille et les performances des bases de données.

  • La création d'un trop grand nombre de sites sous un site de niveau supérieur dans une collection de sites peut compromettre les performances et la souplesse d'utilisation. Limitez le nombre de sites d'un site de niveau supérieur à 2 000 au maximum.

Feuille relative aux données sur la planification du site

Télécharger une version Excel de la feuille relative aux données sur la planification du site (éventuellement en anglais). Utilisez cette feuille de calcul pour enregistrer la structure de votre site.

Voir aussi

Concepts

Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010)
Vue d'ensemble de la navigation dans les sites (SharePoint Foundation 2010)
Planifier la navigation sur les sites (SharePoint Foundation 2010)

Historique des modifications


Vue d'ensemble de la navigation dans les sites (SharePoint Foundation 2010)
Voir aussi

La navigation dans les sites fournit l'interface principale aux utilisateurs du site pour se déplacer sur les sites et les pages de votre site. Microsoft SharePoint Foundation 2010 inclut un ensemble de fonctionnalités de navigation personnalisables et extensibles, qui aide les utilisateurs de votre site à s'orienter dans ses sites et pages. Cet article décrit les contrôles de navigation disponibles dans SharePoint Foundation 2010. Il n'explique pas comment ajouter des contrôles de navigation aux pages Web, configurer des contrôles de navigation ou créer des contrôles de navigation personnalisés.

Dans cet article :

  • Vue d'ensemble des contrôles de navigation

  • Contrôles de navigation sur des pages maîtres

    • Navigation dans la barre de liens supérieure

    • Navigation dans la barre de lancement rapide

    • Navigation fil d'Ariane

    • Navigation dans l'arborescence

Vue d'ensemble des contrôles de navigation

Les contrôles de navigation peuvent être affichés sur les pages maîtres et, à l'aide des zones de composants WebPart, directement dans le contenu d'une page.

SharePoint Foundation 2010 base son modèle de navigation sur la structure hiérarchique de la collection de sites. À l'aide des fonctionnalités de navigation, vous pouvez lier les éléments suivants :

  • Les sites sous le site actif

  • Les sites homologues d'un site

  • Les sites plus élevés dans la structure du site

  • Les pages Web dans un site

En outre, vous pouvez créer des liens vers des emplacements arbitraires, tels qu'un site Web externe.

Dans SharePoint Foundation 2010, les liens de navigation sont sécurisés. Si un utilisateur du site n'a pas d'autorisations pour un site SharePoint Foundation 2010 ou une page liée par la navigation du site, l'utilisateur ne peut pas voir le lien. Les autres types de contenu qui possédaient des liens ajoutés manuellement à la navigation demeurent visibles par les utilisateurs.

La navigation SharePoint Foundation 2010 repose sur les fonctionnalités ASP.NET dans .NET Framework version 3.5, qui vous permettent de personnaliser les éléments suivants :

  • Le fournisseur du plan de site.

  • La source de données, qui ancre et filtre la structure fournie par le fournisseur du plan de site.

  • Les menus, qui contrôlent l'aspect visuel des éléments de navigation et la profondeur de la hiérarchie à afficher.

Contrôles de navigation sur des pages maîtres

Une page maître définit le cadre extérieur de la page Web dans un site. Les pages maîtres contiennent les éléments que toutes les pages de votre site doivent partager, tels que les informations de personnalisation, les commandes courantes telles que Rechercher et les éléments de navigation devant être disponibles dans tout le site. Cela englobe la navigation dans la barre de liens supérieure et la navigation dans la barre de lancement rapide.

Les pages maîtres fournissent également le style de menu des contrôles de navigation. Vous pouvez configurer le style de menu de page maître à l'aide de Microsoft SharePoint Designer 2010 ou Microsoft Visual Studio 2010.

Navigation dans la barre de liens supérieure

La barre de liens supérieure est un menu de navigation généralement lié aux sites situés à un niveau au-dessous du site actif dans une hiérarchie de sites. La barre de liens supérieure apparaît généralement en haut de chaque page d'un site. Par défaut, tous les sites situés à un niveau au-dessous du site actif sont ajoutés à la barre de liens supérieure et chaque site possède sa propre barre de liens supérieure pour la navigation. Les administrateurs de site peuvent personnaliser la navigation pour un site spécifique en supprimant un site de la barre de liens supérieure. Ils peuvent également configurer la barre de liens supérieure de manière à ce que seul le lien de la page d'accueil s'affiche et qu'aucun autre site dans la hiérarchie du site n'apparaisse.

Les administrateurs de site peuvent choisir d'hériter la barre de liens supérieure du site parent. Cette approche permet aux utilisateurs de passer d'un site à l'autre depuis n'importe quel endroit dans la collection de sites, la barre de liens supérieure demeurant la même dans tous les sites de la collection de sites. Par exemple, un site Internet qui sert à commercialiser les produits d'une organisation peut comporter un site pour chaque gamme de ses produits. En affichant le site de chaque produit dans la barre de liens supérieure de chaque site, les concepteurs du site donnent la possibilité aux utilisateurs de passer facilement d'un site à un autre sans devoir revenir à la page d'accueil du site.

Les autres fonctionnalités de configuration de la barre de liens supérieure sont les suivantes :

  • Liaison à des sites externes spécifiés.

  • Liaison à des sites ou pages spécifiés qui se trouvent n'importe où dans le site.

  • Tri manuel des éléments de la barre de liens supérieure.

Toutes les fonctionnalités de barre de liens supérieure, telles que la liaison à des sites externes, peuvent être définies de manière unique pour chaque site.

À l'aide de SharePoint Designer 2010 ou Visual Studio 2010, vous pouvez en outre personnaliser l'apparence et les fonctionnalités de la barre de liens supérieure. Par exemple, vous pouvez effectuer les opérations suivantes :

  • Personnaliser les feuilles de style en cascade pour modifier l'apparence de la barre de liens supérieure.

  • Modifier la source de données, par exemple pour diminuer le nombre de sites affichés dans la barre de liens supérieure.

Navigation dans la barre de lancement rapide

En règle générale, la navigation dans la barre de lancement rapide met en valeur le contenu important dans le site actif, tel que des listes et des bibliothèques. La navigation dans la barre de lancement rapide apparaît souvent à gauche de chaque page dans un site.

Les fonctionnalités de configuration de la navigation dans la barre de lancement rapide sont les suivantes :

  • Liaison à des sites externes spécifiques ou à des pages dans le site actif.

  • Organisation des liens sous des en-têtes.

  • Tri manuel des éléments de la navigation dans la barre de lancement rapide.

À l'image de la barre de liens supérieure, vous pouvez personnaliser l'aspect et les fonctionnalités de la navigation dans la barre de lancement rapide à l'aide de SharePoint Designer 2010 ou Visual Studio 2010.

Navigation fil d'Ariane

La navigation fil d'Ariane affiche un ensemble de liens généré de façon dynamique en haut des pages Web, pour indiquer aux utilisateurs leur position actuelle dans la hiérarchie du site. À l'aide de SharePoint Designer 2010 ou de Visual Studio 2010, vous pouvez configurer le contrôle de navigation fil d'Ariane. Par exemple, vous pouvez spécifier un fournisseur de navigation personnalisé.

Navigation dans l'arborescence

La navigation dans l'arborescence affiche le contenu de site, tel que des listes, des bibliothèques et des sites se trouvant au-dessous du site actif, dans une structure hiérarchique. La navigation dans l'arborescence apparaît souvent à gauche de chaque page dans un site.

Par défaut, la navigation dans l'arborescence est désactivée. Les administrateurs de site peuvent ajouter la navigation dans l'arborescence à un site à l'aide de la page Arborescence.

Voir aussi

Concepts

Planifier la navigation sur les sites (SharePoint Foundation 2010)
Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010)
Planifier les sites et les collections de sites (SharePoint Foundation 2010)

Historique des modifications


Planifier la navigation sur les sites (SharePoint Foundation 2010)
Voir aussi

La navigation de site fournit l'interface principale aux utilisateurs du site pour se déplacer sur les sites et les pages de votre site. Microsoft SharePoint Foundation 2010 inclut un ensemble de fonctionnalités de navigation que vous pouvez personnaliser et étendre pour aider les utilisateurs de votre site à s'orienter dans ses sites et pages. Cet article contient une aide générale sur la planification de la navigation de site pour vos sites SharePoint Foundation 2010. Il ne décrit pas les types de contrôles de navigation disponibles dans SharePoint Foundation 2010, ni la façon d'ajouter des contrôles de navigation aux pages Web, de configurer des contrôles de navigation ou de créer des contrôles de navigation personnalisés. Pour plus d'informations sur les contrôles de navigation de site, voir Vue d'ensemble de la navigation dans les sites (SharePoint Foundation 2010).

Dans cet article :

  • Créer un diagramme de navigation sur les sites

  • Présentation de la navigation héritée

  • Déterminer les sites qui héritent la barre de liens supérieure

  • Déterminer quels sont les liens supplémentaires à ajouter manuellement à la barre de liens supérieure

  • Déterminer les autres options de navigation de site

  • Feuille relative aux données sur la planification du site

Créer un diagramme de navigation sur les sites

Réalisez un diagramme des sites que vous souhaitez créer. Par exemple, le diagramme suivant est pour une agence de voyage de petite taille nommée Margie's Travel. La société possède un ensemble de sites internes afin d'organiser sa principale activité, qui consiste à planifier des conventions.

Diagramme de site pour Margie's travel

Votre schéma peut inclure une collection de sites unique, par exemple pour Margie's Travel, ou il peut se composer de plusieurs collections de sites si vous disposez d'un jeu plus complexe de sites. Veillez à inclure tous les sites Web de niveau supérieur, les sites, les sites d'espace de travail de réunion ou d'espace de travail de document et d'autres sites que vous souhaitez créer et à laisser de la place pour l'expansion future.

Vous souhaiterez peut-être également inclure les listes et bibliothèques pour chaque site, en particulier si vous décidez s'il faut ou non créer un site pour le stockage des documents ou une ou plusieurs bibliothèques de documents.

Présentation de la navigation héritée

La navigation globale, ou barre de liens supérieure, s'affiche en haut de toutes les pages dans le site, en dessous du titre de site. Par défaut, chaque site utilise sa propre barre de liens supérieure ou vous pouvez décider d'autoriser les sites à hériter la barre de liens supérieure du site parent.

La barre de liens supérieure peut afficher deux niveaux de sites dans une collection de sites. Par exemple, la barre de liens supérieure pour la collection de sites de Margie's Travel peut contenir des liens pour Margie's Travel Home, Office Management, Convention Planning et Sales ans Marketing. Dans cet exemple, la barre de liens supérieure ressemble à ceci :

Home | Office Management | Convention Planning | Sales and Marketing

Remarque :
Bien que la barre de liens supérieure puisse afficher deux niveaux de sites, cela ne signifie pas que tous les sous du deuxième niveau doivent être affichés. Vous pouvez déterminer si un site apparaît sur la barre de liens supérieure lors de sa création ou configurer la navigation plus loin dans Paramètres du site.

Toutefois, par défaut, les sites à un troisième niveau dans la hiérarchie n'apparaissent pas dans la barre de liens supérieure pour le site de niveau supérieur, même s'ils héritent la navigation. Par exemple, le site Reports n'apparaît pas dans la barre de liens supérieure de la page d'accueil Margie's Travel Home, car il se trouve sous le site Convention Planning. Si vous souhaitez afficher ce site, vous pouvez l'ajouter manuellement à la barre de liens supérieure ou le créer au deuxième niveau dans la hiérarchie du site (en tant que site sous la page d'accueil de Margie's Travel, et non en tant que site sous le site Convention Planning).

La barre de liens supérieure ne peut pas être partagée entre les sites de collections de sites différentes. Toutefois, vous pouvez toujours ajouter manuellement un lien vers un site d'une autre collection de sites.

Déterminer les sites qui héritent la barre de liens supérieure

Si vous souhaitez que l'onglet Accueil d'un site ouvre la page d'accueil de ce site au lieu de la page d'accueil du site de navigation héritée, vous devez utiliser la navigation unique. Dans le cas contraire, vous devez utiliser la navigation héritée. Par exemple, la collection de sites de Margie's Travel peut hériter les liens supérieurs entre tous les sites de second niveau, afin que tous les sites aient la même navigation :

Home | Office Management | Convention Planning | Sales and Marketing

Cela fonctionne pour une petite équipe, telle que celle de Margie's Travel, où l'ensemble des utilisateurs dans l'organisation travaillent avec tous les sites. Étant donné que chaque utilisateur de la collection de sites utilise chaque site, une barre de liens supérieure héritée est utile. Toutefois, si les équipes Convention Planning et Sales and Marketing travaillent de manière indépendante et n'ont pas besoin d'un accès aux autres sites, la navigation pour le site Margie's Travel peut être personnalisée afin d'être héritées au deuxième niveau, et non au niveau supérieur, comme dans l'exemple suivant :

Site Margie's Travel Home : Home | Office Management

Site Convention Planning : Convention Planning | Reports

Site Sales and Marketing : Sales and Marketing

Gardez à l'esprit que la barre de navigation globale contient toujours un lien vers le site de niveau supérieur dans la collection de sites. Par conséquent, même si les utilisateurs du site Convention planning ne peuvent pas visiter la page d'accueil de Margie's Travel à partir de la barre de liens supérieure, ils peuvent la visiter directement à partir de la barre de navigation globale.

Remarque :
Bien que le choix d'hériter une barre de navigation s'effectue lors de la création de site, vous pouvez modifier cette option ultérieurement. Vous devrez créer manuellement des liens si vous changez d'avis, mais vous pouvez le faire facilement à l'aide de la page Barre de liens supérieure dans les Paramètres du site pour les sites affectés.

Déterminer quels sont les liens supplémentaires à ajouter manuellement à la barre de liens supérieure

Que vous décidiez ou non d'hériter la barre de liens supérieure, vous pouvez la personnaliser pour inclure des liens vers n'importe quelle autre URL dont vous avez besoin. En fonction de l'étendue de la personnalisation dont vous avez besoin, vous pouvez choisir entre les méthodes suivantes pour personnaliser la barre de liens supérieure :

  • Si vous souhaitez ajouter, supprimer ou réorganiser les liens dans une barre de liens supérieure, utilisez la page Barre de liens supérieure dans les Paramètres du site.

  • Si vous souhaitez créer une barre de liens supérieure entièrement personnalisée et l'appliquer à tous les sites dans une collection de sites ou à des sites dans une autre collection de sites, utilisez Microsoft SharePoint Designer 2010 ou Microsoft Visual Studio 2010.

Déterminer les autres options de navigation de site

Parmi les autres options de navigation de site que vous pouvez configurer figurent la barre de lancement rapide et l'arborescence. En règle générale, la navigation de la barre de lancement rapide met en valeur le contenu important dans le site actif.

Vous pouvez personnaliser les éléments affichés dans la barre de lancement rapide en ajoutant de nouveaux liens, en ajoutant ou modifiant des titres et en modifiant l'ordre dans lequel les liens sont affichés. Pour configurer la navigation de la barre de lancement rapide, utilisez la page Lancement rapide dans Paramètres du site pour le site.

La navigation dans l'arborescence affiche le contenu de site, tel que des listes, des bibliothèques et des sites se trouvant au-dessous du site actif, de manière hiérarchique. La navigation dans l'arborescence apparaît souvent à gauche de chaque page dans un site. Par défaut, la navigation dans l'arborescence est désactivée.

Si vous souhaitez afficher le contenu de votre site de manière hiérarchique, vous pouvez afficher l'arborescence pour les utilisateurs du site. Pour activer l'arborescence pour un site, utilisez la page Arborescence dans Paramètres du site pour le site.

Feuille relative aux données sur la planification du site

Télécharger une version Excel de la feuille relative aux données sur la planification du site (éventuellement en anglais). Utilisez cette feuille de calcul pour enregistrer vos décisions sur la navigation de site.

Voir aussi

Concepts

Vue d'ensemble de la navigation dans les sites (SharePoint Foundation 2010)
Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010)
Planifier les sites et les collections de sites (SharePoint Foundation 2010)
Vue d'ensemble des thèmes (SharePoint Foundation 2010)
Planifier l'utilisation des thèmes (SharePoint Foundation 2010)

Historique des modifications


Vue d'ensemble des thèmes (SharePoint Foundation 2010)
Voir aussi

Les thèmes permettent d'appliquer rapidement et facilement des couleurs et des polices aux sites dans Microsoft SharePoint Foundation 2010. Lorsqu'un thème est appliqué à un site, la couleur de la plupart des éléments de page, tels que les images d'arrière-plan, le texte et les liens hypertexte, change. Les polices utilisées pour certains éléments de page, tels que les titres, changent également. Vous pouvez utiliser des thèmes avec les modèles de sites SharePoint Foundation 2010 standard ou avec des pages maîtres personnalisées, pour ensuite créer des thèmes que les propriétaires de site pourront appliquer à leurs sites. Cet article comprend une vue d'ensemble des thèmes et de leur fonctionnement. Il ne décrit pas la création de thèmes à l'aide d'applications Microsoft Office 2010, ni le téléchargement et la gestion des thèmes dans une bibliothèque de thèmes. Il n'aborde pas non plus la planification de la personnalisation globale des sites à l'aide de pages maîtres ou de feuilles de style en cascade. Pour plus d'informations, voir Bloc de construction : pages et interface utilisateur.

Dans cet article :

  • À propos de l'utilisation des thèmes

  • Modes d'utilisation des thèmes

À propos de l'utilisation des thèmes

Grâce aux thèmes, un propriétaire de site ou un utilisateur ayant les droits de conception peut apporter une personnalisation légère à un site SharePoint Foundation 2010 en modifiant les couleurs et les polices des éléments de l'interface utilisateur d'un site. Les thèmes sont directement appliqués dans l'interface utilisateur et ne requièrent pas de connaissances en matière de feuilles de style en cascade ou de pages maîtres.

Remarque :
Si vous appliquez un thème à un site SharePoint Foundation 2010, les utilisateurs anonymes parcourant le site ne verront que le site par défaut. Pour faire en sorte que le thème sélectionné soit visible par tous les utilisateurs, vous devez ajouter un lien dans la page maître vers le fichier CSS généré.

Un avantage de l'utilisation des thèmes est que les propriétaires de site et les utilisateurs dotés de droits de conception n'ont pas besoin de recourir à des ressources de développeur pour apporter des modifications simples à un site. Les thèmes constituent une méthode simple pour personnaliser un site.

Remarque :
Les thèmes dans SharePoint Foundation 2010 ont été reconçus pour simplifier leur processus de génération. Les thèmes créés dans Windows SharePoint Services 3.0 ne sont pas compatibles avec SharePoint Foundation 2010. Si vous effectuez une mise à niveau de Windows SharePoint Services 3.0 à SharePoint Foundation 2010, vous pouvez utiliser Mis à niveau visuel pour continuer à utiliser les sites dans l'ancienne interface utilisateur. Cependant, nous vous recommandons d'utiliser la nouvelle interface utilisateur dans SharePoint Foundation 2010 pour créer des thèmes et les appliquer à vos sites.

Modes d'utilisation des thèmes

Vous pouvez utiliser des thèmes de deux manières sur un site :

  • Utilisez un thème préinstallé.

  • Transférez un thème personnalisé dans la bibliothèque de thèmes.

Utilisation d'un thème préinstallé

SharePoint Foundation 2010 est fourni avec des thèmes préinstallés, dont le thème SharePoint par défaut. Lors de la création d'un site, celui-ci utilise le thème SharePoint par défaut.

Téléchargement de vos propres thèmes personnalisés vers la galerie de thèmes

Vous pouvez créer un thème personnalisé en modifiant les styles dans une application Office 2010, telle que Microsoft PowerPoint 2010, et en enregistrant le thème. Cette opération crée un fichier .thmx que vous pouvez télécharger vers la galerie de thèmes d'une collection de sites. Les thèmes personnalisés stockés dans la galerie de thèmes sont disponibles pour tous les sites de cette collection de sites.

Voir aussi

Concepts

Planifier l'utilisation des thèmes (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
2 septembre 2010 | 2010/08/30 | Mise à jour du contenu


Planifier l'utilisation des thèmes (SharePoint Foundation 2010)
Voir aussi

Les thèmes permettent d'appliquer rapidement et facilement des couleurs et des polices aux sites dans Microsoft SharePoint Foundation 2010. Lorsqu'un thème est appliqué à un site, la couleur de la plupart des éléments de page, tels que les images d'arrière-plan, le texte et les liens hypertexte, change. Les polices utilisées pour certains éléments de page, tels que les titres, changent également. Vous pouvez utiliser des thèmes avec les modèles de sites SharePoint Foundation 2010 standard ou avec des pages maîtres personnalisées, pour ensuite créer des thèmes que les propriétaires de site pourront appliquer à leurs sites. Pour plus d'informations, voir Vue d'ensemble des thèmes (SharePoint Foundation 2010).

Cet article explique comment planifier l'utilisation de thèmes dans vos sites SharePoint Foundation 2010 et indique les principales étapes de cette planification. Il ne décrit pas la création de thèmes à l'aide d'applications Microsoft Office 2010, ni le téléchargement et la gestion des thèmes dans une bibliothèque de thèmes. En outre, il n'aborde pas la planification de la personnalisation globale des sites à l'aide de pages maîtres ou de feuilles de style en cascade. Pour plus d'informations, voir Bloc de construction : pages et interface utilisateur.

Avant de lire cet article, vous devez avoir lu l'article Planifier les sites et les collections de sites (SharePoint Foundation 2010).

Dans cet article :

  • À propos de la planification de l'utilisation de thèmes

  • Évaluer la nécessité d'utiliser des thèmes

  • Déterminer le nombre de thèmes nécessaires

  • Décider du créateur des thèmes

  • Feuille relative aux données sur la planification du site

À propos de la planification de l'utilisation de thèmes

Lorsque vous envisagez d'utiliser des thèmes, vous devez prendre trois décisions principales :

  • Vous devez décider si vous allez utiliser des thèmes.

  • Si tel est le cas, déterminez le nombre de thèmes nécessaires.

  • Désignez la personne qui sera chargée d'élaborer les thèmes personnalisés.

La suite de cet article explique ces décisions et décrit en détail certains points supplémentaires à prendre en compte lors de la planification.

Évaluer la nécessité d'utiliser des thèmes

La première étape de la planification de l'utilisation de thèmes consiste à déterminer si cette utilisation constitue l'option appropriée pour votre scénario. Les autres options pour la personnalisation d'un site comprennent l'utilisation d'un autre fichier CSS et la création de pages maîtres personnalisées. Étant donné que l'implémentation de ces options nécessite des compétences de concepteur ou de développeur, il est possible qu'elles ne soient pas appropriées pour votre scénario.

Pour savoir s'il convient d'utiliser des thèmes, déterminez dans quelle proportion il est nécessaire de modifier l'apparence de vos sites, puis choisissez l'option qui répond le mieux à vos souhaits. Vous pouvez utiliser une combinaison de ces options, suivant le degré de personnalisation que vous souhaitez apporter à vos sites. Le tableau suivant décrit les différents niveaux de personnalisation et indique la meilleure option correspondante.

Pour | Utilisez
Autoriser les propriétaires de sites à modifier les couleurs et les polices | Thèmes
Apporter des modifications aux autres éléments de conception tels que la taille des polices et l'espacement | Feuilles de style en cascade
Modifier complètement la structure et la conception des pages | Pages maîtres
Remarque :
Si vous appliquez un thème à un site SharePoint Foundation 2010, les utilisateurs anonymes parcourant le site ne verront que le site par défaut. Pour faire en sorte que le thème sélectionné soit visible par tous les utilisateurs, vous devez ajouter un lien dans la page maître vers le fichier CSS généré.

Si vous décidez d'utiliser des thèmes, lisez la suite de cet article.

Déterminer le nombre de thèmes nécessaires

Après avoir décidé d'utiliser des thèmes, vous devez déterminer le nombre de thèmes nécessaires pour vos sites. Déterminez si les thèmes installés avec SharePoint Foundation 2010 vous suffisent ou si vous devez créer des thèmes personnalisés à utiliser sur les différents sites. Si vous créez des thèmes personnalisés, vous devez également déterminer le nombre de thèmes nécessaires et les sites utilisant des thèmes spécifiques.

Utilisez la feuille relative aux données sur la planification du site pour enregistrer les sites qui doivent utiliser un thème, ainsi que pour déterminer le nombre de thèmes uniques nécessaires.

Désigner le créateur des thèmes

Si vous envisagez d'utiliser des thèmes personnalisés, vous devez déterminer la personne qui sera chargée de créer les fichiers *.thmx. Dans la mesure où les thèmes personnalisés sont créés dans une application Office 2010 telle que PowerPoint, vous n'avez pas besoin de recourir à un graphiste pour élaborer un thème. Toutefois, vous pouvez faire appel à un graphiste pendant la phase de planification afin qu'il vous aide à déterminer les valeurs de couleur et les styles de police à utiliser dans les thèmes.

Vous devez également désigner la personne qui sera responsable du téléchargement des thèmes vers la galerie de thème. La personne qui crée les thèmes sera-t-elle également responsable du téléchargement des fichiers *.thmx vers la galerie de thèmes ou enregistrera-t-elle les fichiers de thèmes dans un répertoire, laissant le soin à un administrateur de collection de sites d'effectuer le téléchargement ? Un utilisateur ne peut télécharger des fichiers *.thmx vers la galerie de thèmes que s'il détient des privilèges d'administrateur ou de concepteur pour la collection de sites qui abrite la galerie.

Feuille relative aux données sur la planification du site

Télécharger une version Excel de la feuille relative aux données sur la planification du site (éventuellement en anglais). Utilisez cette feuille de calcul pour enregistrer vos décisions sur les thèmes.

Voir aussi

Concepts

Vue d'ensemble des thèmes (SharePoint Foundation 2010)
Vue d'ensemble des sites et des collections de sites (SharePoint Foundation 2010)
Planifier les sites et les collections de sites (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
2 septembre 2010 | 2010/08/30 | Mise à jour du contenu


Planifier des sites multilingues (SharePoint Foundation 2010)
Voir aussi

Microsoft SharePoint Foundation 2010 intègre plusieurs fonctionnalités qui permettent de prendre en charge des utilisateurs résidant dans différentes régions ou parlant différentes langues. Vous pouvez utiliser ces fonctionnalités pour créer des sites Web dans différentes langues.

Cet article explique comment planifier des sites SharePoint Foundation 2010 multilingues. Il ne décrit pas comment créer des sites multilingues ni comment installer des modules linguistiques. Pour plus d'informations sur la création de sites multilingues, voir Créer des sites dans des langues autres que la langue par défaut (éventuellement en anglais). Pour plus d'informations sur les modules linguistiques, voir Déployer des modules linguistiques (SharePoint Foundation 2010).

Dans cet article :

  • À propos de la planification des sites multilingues

  • Déterminer les exigences en matière de langues et de paramètres régionaux

  • Déterminer les exigences en matière de modules linguistiques

  • Déterminer les exigences relatives aux analyseurs lexicaux et aux analyseurs morphologiques

À propos de la planification des sites multilingues

Si votre organisation doit prendre en charge des utilisateurs dans différentes régions ou des utilisateurs parlant différentes langues, vous devez déterminer quelles sont vos exigences en matière de langue et planifier le déploiement de sites multilingues lors de la planification de la structure et de la navigation globales des sites.

Pour déterminer vos besoins multilingues, vous devez :

  • déterminer les langues et paramètres régionaux à prendre en charge.

Pour planifier le déploiement des sites multilingues, vous devez déterminer les fonctionnalités et composants linguistiques à installer ou à configurer sur vos serveurs. Il s'agit notamment des éléments suivants :

  • modules linguistiques ;

  • prise en charge des analyseurs lexicaux.

Remarque :
Bien que Windows SharePoint Services 3.0 prenne en charge les noms de domaine internationaux (IDN), ce n'est pas le cas de SharePoint Foundation 2010. Si vous utilisez actuellement des noms IDN avec Windows SharePoint Services 3.0 et que vous prévoyez de mettre à niveau ou de migrer vers SharePoint Foundation 2010, vous devez cesser d'utiliser des noms IDN, supprimer tous les paramètres IDN et configurer un environnement non-IDN avant d'effectuer la mise à niveau ou la migration vers SharePoint Foundation 2010.

Déterminer les exigences en matière de langues et de paramètres régionaux

Il se peut que vous deviez créer des sites dans plusieurs langues pour l'une des raisons suivantes :

  • vous souhaitez fournir du contenu de site Web à des utilisateurs dans différentes régions ;

  • vous êtes tenu par la loi de votre pays ou la stratégie de votre organisation de fournir du contenu de site Web en plusieurs langues.

N'oubliez pas de consulter tous les propriétaires de site éventuels lorsque vous déterminez vos besoins linguistiques et n'oubliez pas non plus de répertorier toutes les langues que vous pourriez avoir besoin de prendre en charge ultérieurement. Il est plus facile d'installer la prise en charge linguistique au cours du déploiement initial que d'attendre que vos serveurs soient en cours d'exécution dans un environnement de production complet pour l'installer. Une fois qu'un site a été créé dans une langue spécifique, la langue par défaut du site ne peut plus être modifiée. En revanche, un utilisateur connecté au site peut utiliser l'interface utilisateur multilingue pour sélectionner une autre langue d'affichage du site. Cela modifie la façon dont l'interface utilisateur du site est affichée pour l'utilisateur, mais ne modifie pas le contenu du site. Par exemple, si le site a été mis en service en français et que le module linguistique espagnol a également été installé sur le serveur, un utilisateur du site peut changer de langue de sorte que l'interface utilisateur soit en espagnol lorsqu'il visualise le site. Dans ce cas, seule l'interface utilisateur de cet utilisateur est modifiée ; cela n'affecte pas l'affichage du site pour les autres utilisateurs. De plus, tout contenu créé en français continuera d'être affiché en français. Pour plus d'informations sur l'interface utilisateur multilingue, voir Présentation de l'interface utilisateur multilingue (SharePoint Foundation 2010).

Remarque :
Si un utilisateur modifie ses paramètres de site personnels de façon à afficher le site dans une autre langue, certains éléments du site (tels que les noms des colonnes) peuvent continuer à être affichés dans la langue par défaut du site.

Ne vous croyez pas obligé de créer un site Web ou une collection de sites en plusieurs langues uniquement parce qu'une bibliothèque de documents contient des documents en plusieurs langues. Une bibliothèque de documents peut contenir des documents en plusieurs langues sans qu'il soit nécessaire de créer des sites Web ou des collections de sites en plusieurs langues. Par exemple, la bibliothèque de documents d'une collection de sites en anglais peut contenir des documents écrits en français et d'autres documents écrits en japonais.

Lorsque vous planifiez des sites multilingues, vous devez également prendre en compte les paramètres régionaux nécessaires à la prise en charge de vos sites. Les paramètres régionaux spécifient la façon dont les nombres, les dates et les heures sont affichés sur un site, mais ils ne modifient pas la langue dans laquelle le site est affiché. Par exemple, la sélection des paramètres régionaux Thai modifie l'ordre de tri par défaut des éléments de listes et utilise le calendrier bouddhiste au lieu du calendrier par défaut. Les paramètres régionaux sont configurés indépendamment de la langue spécifiée lors de la création d'un site, mais contrairement à la langue, ils peuvent être modifiés à tout moment. Pour plus d'informations sur la traduction de l'interface utilisateur, voir Déterminer les exigences en matière de modules linguistiques.

Déterminer les exigences en matière de modules linguistiques

En fonction des exigences linguistiques de votre site Web, déterminez les modules linguistiques à installer sur vos serveurs Web frontaux. Les modules linguistiques vous permettent de créer des sites et des collections de sites en plusieurs langues sans nécessiter des installations séparées de SharePoint Foundation 2010. Les modules linguistiques sont installés sur les serveurs Web frontaux de votre batterie de serveurs et contiennent des modèles de sites spécifiques à une langue. Lorsque vous créez un site ou une collection de sites basé(e) sur un modèle de site spécifique à une langue, le texte de l'interface utilisateur qui apparaît sur le site ou la collection de sites est affiché dans la langue du modèle de site spécifié. Par exemple, lorsque vous décidez de créer un site en français, les barres d'outils, barres de navigation, listes et en-têtes de colonnes de ce site apparaissent en français. De même, lorsque vous décidez de créer un site en arabe, les barres d'outils, barres de navigation, listes et en-têtes de colonnes de ce site apparaissent en arabe et l'orientation de gauche à droite par défaut du site change pour une orientation de droite à gauche afin d'afficher correctement le texte arabe.

S'il est prévu que des utilisateurs de votre site ne puissent pas travailler dans la langue par défaut que vous prévoyez d'utiliser pour le site, vous devez également installer des modules linguistiques qui permettront à vos utilisateurs de travailler dans la langue de leur choix à l'aide de l'interface utilisateur multilingue. Si vous ne fournissez pas la prise en charge de langues supplémentaires, les utilisateurs auront peut-être des difficultés à utiliser des fonctionnalités de site dans une langue autre que leur langue maternelle. Les modules linguistiques procurent une traduction des éléments d'interface utilisateur tels que les suivants :

  • éléments du Ruban ;

  • en-têtes de colonnes de sites et de listes ;

  • interface des paramètres de sites ;

  • modèles pour les nouveaux sites, listes et bibliothèques de documents ;

  • indexation de recherche pertinente du contenu qui n'est pas dans la langue par défaut du site.

Remarque :
Les modules linguistiques procurent une traduction uniquement de l'interface utilisateur. Ils ne traduisent pas le contenu créé et affiché dans les pages de contenu ou les composants WebPart.

La liste des langues disponibles que vous pouvez utiliser pour créer un site ou une collection de sites, et que les utilisateurs peuvent sélectionner dans l'interface utilisateur multilingue, est générée par les modules linguistiques installés sur les serveurs Web frontaux de votre batterie de serveurs. Par défaut, les sites et collections de sites sont créés dans la langue dans laquelle SharePoint Foundation 2010 a été installé. Par exemple, si vous avez installé la version espagnole de SharePoint Foundation 2010, la langue par défaut des sites, des collections de sites et des pages Web est l'espagnol. Si vous devez créer des sites, des collections de sites ou des pages Web dans une autre langue que la langue par défaut de SharePoint Foundation 2010, vous devez d'abord installer le module linguistique de cette autre langue sur les serveurs Web frontaux avant de pouvoir sélectionner une autre langue dans laquelle créer un site. Par exemple, si vous exécutez la version française de SharePoint Foundation 2010 et que vous souhaitez créer des sites en français, en anglais et en espagnol, vous devez installer les modules linguistiques anglais et espagnol sur les serveurs Web frontaux pour pouvoir créer les sites en anglais et en espagnol.

Les modules linguistiques de SharePoint Foundation 2010 ne sont pas fournis avec d'autres programmes ni regroupés dans des packages d'installation multilingues : vous devez installer un module linguistique spécifique pour chaque langue à prendre en charge. En outre, les modules linguistiques doivent être installés sur chaque serveur Web frontal de la batterie de serveurs pour garantir que chaque serveur Web peut afficher le contenu dans la langue spécifiée. Pour plus d'informations sur les modules linguistiques disponibles, voir Modules linguistiques (SharePoint Foundation 2010). Pour plus d'informations sur la façon de déployer des modules linguistiques, voir Déployer des modules linguistiques (SharePoint Foundation 2010).

Même si vous spécifiez une langue pour un site, certains éléments de l'interface utilisateur, tels que les messages d'erreur, les notifications ou les boîtes de dialogue, peuvent ne pas s'afficher dans la langue que vous avez choisie. Cela est dû au fait que SharePoint Foundation 2010 repose sur plusieurs technologies de prise en charge (telles que le .NET Framework, Microsoft Windows Workflow Foundation, ASP.NET et Microsoft SQL Server) et que certaines de ces technologies ne sont traduites que dans un nombre limité de langues. Si un élément de l'interface utilisateur est généré par l'une des technologies de prise en charge et que cette dernière n'est pas traduite dans la langue que l'administrateur de site a spécifiée pour le site, l'élément d'interface utilisateur apparaît en anglais.

En outre, du texte peut provenir de la langue d'installation d'origine, ce qui peut donner lieu à un mélange de langues. Seuls les créateurs de contenu ou les administrateurs de sites rencontrent ce type de situation, pas les utilisateurs des sites.

Remarque :
Les journaux d'erreurs stockés par SharePoint Foundation 2010 sur le serveur sont toujours en anglais.

Pour plus d'informations sur l'installation des modules linguistiques, voir Déployer des modules linguistiques (SharePoint Foundation 2010).

Déterminer les exigences relatives aux analyseurs lexicaux et aux analyseurs morphologiques

Les analyseurs lexicaux et les analyseurs morphologiques sont des composants qui font partie des processus d'indexation et d'interrogation. Un analyseur lexical est un composant qui sert à décomposer des chaînes de texte en mots individuels durant les processus d'indexation et d'interrogation. Un analyseur morphologique est un composant qui identifie le mot racine d'un terme et peut également générer des variantes de ce terme. Les règles de découpage et de recherche de radical ne sont pas les mêmes dans toutes les langues, et vous pouvez spécifier différentes règles pour différentes langues. Les analyseurs lexicaux pour chaque langue permettent d'obtenir la précision des termes obtenus dans la langue correspondante. Dans le cas où il existe un analyseur lexical pour une famille de langue, mais pas pour une sous-langue spécifique, la langue principale est utilisée. Par exemple, l'analyseur lexical français est utilisé pour gérer le texte français canadien. Si aucun analyseur lexical n'est disponible pour une langue particulière, l'analyseur lexical neutre est utilisé. Avec l'analyseur lexical neutre, les mots sont découpés à des caractères neutres tels que des espaces et des marques de ponctuation.

Si vous installez des modules linguistiques ou une prise en charge linguistique supplémentaire, nous vous recommandons d'installer l'analyseur lexical et l'analyseur morphologique appropriés pour chacune des langues que vous devez prendre en charge. Les analyseurs lexicaux et les analyseurs morphologiques doivent être installés sur tous les serveurs qui exécutent le service Recherche. Pour obtenir une liste des langues pour lesquelles SharePoint Foundation 2010 fournit des analyseurs lexicaux et des analyseurs morphologiques, voir Langues pour les séparateurs de mots et générateurs de forme (SharePoint Foundation 2010) .

Voir aussi

Concepts

Présentation de l'interface utilisateur multilingue (SharePoint Foundation 2010)
Planification de l'interface utilisateur multilingue (SharePoint Foundation 2010)

Historique des modifications


Présentation de l'interface utilisateur multilingue (SharePoint Foundation 2010)
Voir aussi

Cet article traite de la nouvelle fonctionnalité de l'interface utilisateur multilingue dans Microsoft SharePoint Foundation 2010. Dans la version antérieure de Windows SharePoint Services 3.0, lors de la création d'un site ou d'une collection de sites, si les modules linguistiques étaient installés sur le serveur, il était possible de choisir la langue d'affichage de l'interface utilisateur du site. Cependant, une fois que vous définissiez la langue d'un site, vous ne pouviez plus la modifier. La fonctionnalité de l'interface utilisateur multilingue introduit la notion de deuxième langue que l'utilisateur peut choisir. Cette fonctionnalité permet d'afficher l'interface utilisateur du site dans une deuxième langue que l'utilisateur choisit et qui est différente de la première langue choisie à la création du site.

Cet article décrit l'interface utilisateur multilingue dans SharePoint Foundation 2010. Il n'explique pas comment déployer les modules linguistiques nécessaires à l'utilisation de l'interface utilisateur multilingue, ni comment configurer les paramètres du site pour autoriser les utilisateurs à définir leur langue préférée. En outre, il n'aborde pas la planification de l'utilisation de l'interface utilisateur multilingue dans votre solution de site. Pour plus d'informations sur la façon de permettre aux utilisateurs de modifier la langue utilisée pour afficher l'interface utilisateur de leur site, voir Rendre plusieurs langues disponibles pour l'interface utilisateur de votre site (éventuellement en anglais). Pour plus d'informations sur la planification de l'utilisation de l'interface utilisateur multilingue, voir Planification de l'interface utilisateur multilingue (SharePoint Foundation 2010).

Dans cet article :

  • Utilisation et avantages de l'interface utilisateur multilingue

  • Fonctionnement de l'interface utilisateur multilingue

  • Éléments pris en charge par l'interface utilisateur multilingue

  • Ajout et modification de contenu d'application

  • Exportation et importation de contenu traduit

  • Limitations de l'interface utilisateur multilingue

Utilisation et avantages de l'interface utilisateur multilingue

L'interface utilisateur multilingue permet aux utilisateurs de collaborer dans un seul site dans leur langue secondaire indépendamment de la langue choisie à la création du site. Lorsque vous créez un nouveau site, si des modules linguistiques ont été installés sur le serveur, vous pouvez spécifier la langue principale du site. Le site utilisera cette langue pour afficher l'interface utilisateur du site telle que la navigation du site et les pages d'administration. Pour que les utilisateurs du site puissent afficher l'interface utilisateur du site dans une deuxième langue, vous pouvez spécifier quelles langues sont disponibles pour les utilisateurs depuis la page Paramètres linguistiques. Un utilisateur qui est connecté au site peut utiliser l'option Sélectionnez la langue d'affichage dans le menu Utilisateur pour sélectionner une deuxième langue dans laquelle afficher l'interface utilisateur du site. Au terme du choix de la langue par l'utilisateur, tous les sites contenus dans ce nom de domaine sont affichés dans la langue de leur choix. Cependant, cette opération ne modifie pas la langue principale, par défaut du site. Les autres utilisateurs qui consultent le site afficheront l'interface utilisateur du site dans la langue principale. L'interface utilisateur du site n'est modifiée que pour les utilisateurs ayant sélectionné une deuxième langue dans laquelle afficher le site.

Grâce à l'interface utilisateur multilingue, les membres de l'équipe peuvent collaborer sur des documents et des projets dans une langue commune qu'ils partagent, tout en affichant le site et en effectuant des tâches dans la langue de leur choix. Outre la collaboration en équipe, l'interface utilisateur du site permet aux administrateurs de site et de batterie d'effectuer les tâches administratives dans la langue de leur choix. Par exemple, les administrateurs de batterie peuvent modifier la langue principale du site Administration Centrale pour afficher dans la langue de leur choix les instructions et les liens d'administration.

Remarque :
L'interface utilisateur multilingue affiche uniquement les éléments d'interface utilisateur du site dans une autre langue. Elle ne traduit pas ni n'affiche de contenu, par exemple des éléments de liste ou des documents, dans une autre langue.

En plus de permettre aux utilisateurs de changer la langue principale, l'interface utilisateur multilingue permet aussi aux utilisateurs de modifier des contenus d'application nouveaux et existants, tels que les descriptions et titres de bibliothèque ou liste, ce qui permet aux utilisateurs de répercuter ces changements dans l'interface utilisateur d'autres utilisateurs d'autres langues. Par exemple, un membre d'équipe qui utilise l'anglais comme langue par défaut crée une nouvelle bibliothèque de document intitulée « Team Reports ». Un autre membre d'équipe dont la langue par défaut est l'allemand se connecte au site et remplace le titre de bibliothèque par « Mannschaftsberichte ». Lorsqu'un utilisateur dont la langue par défaut est l'allemand se reconnecte au site, le nom de la bibliothèque de document s'affiche comme « Mannschaftsberichte ». Cependant, un utilisateur dont la langue par défaut est l'anglais continue d'afficher le nom de bibliothèque de document comme « Team Reports ».

SharePoint Foundation 2010 fournit trois méthodes permettant de traduire certains contenus d'application, par exemple des descriptions et titres de bibliothèque ou liste : au moyen de l'interface utilisateur, en exportant et important des traductions pour un site et à l'aide du modèle d'objet.

Fonctionnement de l'interface utilisateur multilingue

Par défaut, lorsqu'un nouveau site est créé, celui-ci est créé dans la langue par défaut de l'installation SharePoint Foundation 2010 sur le serveur. Un administrateur de batteries doit installer des modules linguistiques sur le serveur avant de créer des sites dans des langues différentes de la langue par défaut. Pour plus d'informations, voir Déployer des modules linguistiques (SharePoint Foundation 2010).

Au terme de l'installation des modules linguistiques sur le serveur, le lien Paramètres linguistiques est ajouté à la page Paramètres du site. Les administrateurs du site utilisent cette page pour spécifier quelle deuxième langue le site prendra en charge. Une fois que l'administrateur du site a activé les deuxièmes langues d'un site, les utilisateurs peuvent se connecter au site et utiliser l'option Sélectionnez la langue d'affichage dans le menu utilisateur pour modifier la langue d'affichage lorsqu'ils accèdent à une page dans la collection de sites. Lorsqu'un utilisateur modifie la langue d'affichage d'une page, la nouvelle langue d'affichage devient la langue par défaut de l'utilisateur dans l'ensemble de la collection de sites.

SharePoint Foundation 2010 sélectionne la langue dans laquelle afficher les pages d'une collection de sites en faisant appel à la première des règles suivantes :

  1. Est-ce que l'utilisateur possède une langue par défaut pour cette collection de sites sur cet ordinateur ? Si oui, utilisez la langue par défaut de l'utilisateur.

  2. La langue par défaut définie dans le navigateur Web est-elle une des langues prises en charge pour la page ? Si oui, utilisez la langue par défaut du navigateur.

  3. Sinon, utilisez la langue par défaut de la collection de sites.

SharePoint Foundation 2010 fournit trois méthodes permettant de modifier certains contenus d'application, tels que les descriptions et titres de bibliothèque ou liste : au moyen de l'interface utilisateur, en exportant et important des traductions pour un site et à l'aide de la classe SPUserResource dans l'espace de noms Microsoft.SharePoint. Il n'est pas possible de modifier tous les éléments d'interface directement dans l'interface utilisateur. Par exemple, les actions et les commandes utilisateur peuvent être modifiées uniquement à l'aide de la classe SPUserResource. Pour plus d'informations, voir Classe SPUserResource (éventuellement en anglais).

Éléments pris en charge par l'interface utilisateur multilingue

Lorsqu'un utilisateur consulte un site dans une deuxième langue, certains éléments de l'interface utilisateur sont fournis dans la langue par défaut. La liste suivante inclut des exemples d'éléments pris en charge par l'interface utilisateur multilingue :

  • Pages de paramètres, tels que les répertoires virtuels _layouts et _admin.

  • Aide.

  • Contenu d'application, tel que des menus, des contrôles, des actions de site, une description et un titre de site, des descriptions et des titres de bibliothèque ou liste, des des barres de liens supérieure, des liens de lancement rapide, la navigation file d'Ariane locale, des types de contenu de liste et de site, et des colonnes de liste et de site.

  • Du contenu de développement, par exemple des fonctionnalités, des solutions.

Cependant, tous les éléments d'interface utilisateur ne sont pas traduits. La liste suivante inclut des exemples d'éléments qui ne sont pas pris en charge par l'interface de l'utilisateur multilingue :

  • Composants WebPart (sauf ceux qui sont liés à des listes ou des bibliothèques).

  • Fil d'Ariane globale.

  • Contenu créé par les utilisateurs, tels que des données d'éléments de liste, des documents et des pages Web dans des bibliothèques, des niveaux d'autorisation, des groupes, des affichages et des composants WebPart.

Même si la plupart des modèles de site sont pris en charge par l'interface utilisateur multilingue, les modèles de site suivants ne sont pas pris en charge :

  • Modèle Blog.

  • Modèles Espace de travail. .

  • Modèles Base de données Web.

Ajout et modification du contenu d'application

Un utilisateur peut ajouter ou modifier le contenu d'application, par exemple des titres de liste ou des descriptions et noms de colonne, comme suit : en ajoutant ou modifiant le contenu dans la langue principale ou en ajoutant ou modifiant le contenu dans une ou plusieurs deuxièmes langues.

Lorsqu'un utilisateur affiche un site dans la langue principale du site, tout contenu d'application nouveau créé s'affiche dans la langue principale même si le site est consulté dans une deuxième langue. Par exemple, si la langue principale d'un site est l'anglais et qu'un utilisateur affiche le site dans cette langue principale et crée une bibliothèque de document intitulée « Team Documents », le titre de la bibliothèque s'affiche toujours comme « Team Documents » lorsqu'un utilisateur consulte le site dans une deuxième langue. Pour traduire de nouvelles chaînes d'interface utilisateur dans une deuxième langue, un utilisateur doit modifier les préférences utilisateur pour afficher le site dans une deuxième langue, puis modifier l'élément de l'interface utilisateur.

Lorsqu'un utilisateur consulte un site dans une deuxième langue, tout nouveau contenu d'application créé s'affiche dans cette langue même si le site s'affiche dans la langue principale ou dans une autre deuxième langue. Par exemple, si la langue principale d'un site est l'anglais et qu'un utilisateur consulte le site en allemand et ajoute une bibliothèque de document intitulée « Mannschaftsdokumente », le titre de la bibliothèque s'affiche comme « Mannschaftsdokumente » même lorsque le site est consulté en anglais. Pour traduire de nouvelles chaînes d'interface utilisateur dans la langue principale ou dans une autre deuxième langue, l'utilisateur doit modifier les préférences de l'utilisateur pour afficher le site dans la langue requise puis modifier l'interface utilisateur. La page Paramètres linguistiques contient une option Remplacer les traductions qui affecte l'application des modifications de contenu d'application existant aux autres langues du site. Si l'option Remplacer les traductions est activée, tout changement apporté à l'interface utilisateur dans la langue principale remplace les modifications apportées aux éléments d'interface utilisateur dans des deuxièmes langues.

Par défaut, lorsqu'un utilisateur consulte un site dans la langue principale du site, les modifications apportées à un contenu d'application existant ne s'appliquent qu'à cette langue. Les chaînes associées à cet élément d'interface utilisateur dans les deuxièmes langues ne sont pas modifiées. Cependant, si l'option Remplacer les traductions est activée, les chaînes associées à cet élément d'interface utilisateur pour chaque langue sont remplacées par la nouvelle chaîne de la langue principale. Par exemple, si la langue principale du site est l'anglais et qu'un utilisateur remplace le titre de la bibliothèque « Shared Documents » par « Team Documents », par défaut, le titre est modifié uniquement pour la langue principale du site. Cependant, si l'option Remplacer les traductions est activée, le titre est remplacé par « Team Documents » pour chaque deuxième langue, et il doit être retraduit.

Lorsqu'un utilisateur consulte un site dans une deuxième langue, les modifications apportées à un contenu d'application existant ne s'appliquent qu'à cette langue. Les chaînes associées à cet élément d'interface utilisateur dans la langue principale et d'autres deuxièmes langues ne sont pas modifiées. Pour traduire les chaînes d'interface utilisateur dans la langue principale, l'utilisateur doit modifier les préférences utilisateur pour afficher le site dans la langue requise, puis modifier l'interface utilisateur.

Exportation et importation de contenu traduit

La fonctionnalité d'interface utilisateur vous permet d'exporter et d'importer un contenu d'application pour une traduction en bloc. Au lieu de traduire un contenu d'application un élément après l'autre, vous pouvez exporter les chaînes pour tout contenu d'application nouveau ou modifié dans la langue principale ou dans une des deuxièmes langues. Pour exporter le contenu, utilisez le lien Exporter des traductions de la page Paramètres du site. Lorsque vous exportez le contenu d'application pour une deuxième langue, vous pouvez décider d'exporter tout le contenu ou seul le contenu non traduit.

Lorsque le contenu d'application est exporté, il est enregistré comme fichier .resx qui peut être ouvert au moyen d'un éditeur de texte ou d'un outil tiers pouvant ouvrir des fichiers de ressource. Pour plus d'informations, voir Ressources au format de fichier .Resx. Après avoir traduit les chaînes de ressource, utilisez le lien Importer les traductions de la page Paramètres du site pour importer le fichier .resx.

Limitations de l'interface utilisateur multilingue

Comme indiqué précédemment, tous les éléments d'interface utilisateur ne sont pas pris en charge par l'interface utilisateur multilingue. La liste suivante décrit les limitations supplémentaires qui s'appliquent lorsque vous utilisez l'interface utilisateur multilingue :

  • Recherche La recherche indexe le contenu dans la langue par défaut de l'installation SharePoint. Même si le contenu est fourni dans des deuxièmes langues, ce contenu ne peut faire l'objet de recherche qu'à l'aide de la langue par défaut du site. Par exemple, si votre langue par défaut est l'allemand, mais la langue principale est l'anglais, rechercher « Freigegebene Dokumente» ne donne aucun résultat. En revanche, rechercher « Shared Documents» donne des résultats.

  • Composants WebPart Les titres et les descriptions de composants WebPart ne changent pas dans l'interface utilisateur sauf si un composant WebPart est un composant WebPart basé sur une liste. Par exemple, le titre et la description des composants WebPart qui affichent les données de liste et de bibliothèque, tels que les annonces et les documents partagés, s'affichent dans la langue par défaut de l'utilisateur, tandis que le titre et la description des autres composants WebPart, tels que les composants WebPart Éditeur de contenu et de requête de contenu, s'affichent uniquement dans la langue principale du site.

Voir aussi

Concepts

Planification de l'interface utilisateur multilingue (SharePoint Foundation 2010)
Planifier des sites multilingues (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
2011/01/10 | 2011/01/10 | Mise à jour du contenu
8 juillet 2010 | Publication initiale |


Planification de l'interface utilisateur multilingue (SharePoint Foundation 2010)
Voir aussi

L'interface utilisateur multilingue est une nouvelle fonctionnalité de Microsoft SharePoint Foundation 2010 qui permet à l'utilisateur de sélectionner une langue secondaire. L'interface utilisateur du site s'affiche alors dans la langue secondaire sélectionnée, celle-ci étant différente de la langue primaire choisie au moment de la création du site.

Cet article explique comment planifier l'utilisation de l'interface utilisateur multilingue dans votre solution de site SharePoint Foundation 2010. Il n'explique pas comment déployer les modules linguistiques nécessaires à l'utilisation de l'interface utilisateur multilingue, ni comment configurer les paramètres du site pour autoriser les utilisateurs à définir leur langue préférée. Pour plus d'informations sur la façon de permettre aux utilisateurs de modifier la langue utilisée pour afficher l'interface utilisateur de leur site, voir Rendre plusieurs langues disponibles pour l'interface utilisateur de votre site (éventuellement en anglais). Pour plus d'informations sur l'interface utilisateur multilingue, voir Présentation de l'interface utilisateur multilingue (SharePoint Foundation 2010).

Dans cet article :

  • Déterminer les langues requises pour vos sites

  • Planifier la traduction du contenu

  • Planifier l'installation des Service Packs

Déterminer les langues requises pour vos sites

Pour que vous puissiez utiliser l'interface utilisateur multilingue dans vos sites SharePoint, l'administrateur de batterie doit déployer des modules linguistiques sur le serveur pour les rendre accessibles sur les sites. Déterminez quels sont les modules linguistiques requis et quand ils devront être déployés sur le serveur. Les administrateurs de site doivent quant à eux configurer les paramètres de langue sur les sites individuels pour que des langues spécifiques soient accessibles aux utilisateurs de site. Vous devez déterminer les langues requises pour chaque site et demander aux administrateurs de site d'activer des langues spécifiques sur les sites qu'ils gèrent. Pour plus d'informations sur la planification de sites multilingues, voir Planifier des sites multilingues (SharePoint Foundation 2010). Pour plus d'informations sur le déploiement de modules linguistiques, voir Déployer des modules linguistiques (SharePoint Foundation 2010).

Planifier la traduction du contenu

Si vous activez l'interface utilisateur multilingue sur votre site pour offrir aux utilisateurs un moyen de collaborer dans leur langue préférée, vous devez déterminer si l'interface utilisateur multilingue par défaut est suffisante ou s'il est nécessaire de traduire le contenu de l'application. Si la traduction du contenu de votre application s'impose, répondez aux questions suivantes :

  • Comment allez-vous traduire le contenu existant et le nouveau contenu de l'application ? Est-ce que des membres spécifiques de l'équipe vont traduire le contenu de l'application directement dans l'interface utilisateur en fonction des besoins ou allez-vous exporter les fichiers de ressources pour les langues requises du site et traduire tout d'un coup ? Si les utilisateurs créent un nouveau contenu de l'application dans une langue secondaire, vous devez déterminer qui traduira ce contenu dans la langue primaire du site et dans les autres langues secondaires. Si vous planifiez de créer des pages complexes, telles que de nouvelles pages de menu, ou de développer les solutions personnalisées, telles que des fonctionnalités de création de listes, vous devez planifier d'utiliser le modèle objet pour fournir des traductions dans les langues secondaires.

  • Qui va traduire le contenu de l'application ? La traduction des fichiers de ressources sera-t-elle effectuée par une personne de votre organisation ou allez-vous faire appel à un tiers ?

  • Comment allez-vous gérer les mises à jour apportées au contenu de l'application ? Est-ce que les modifications apportées à l'interface utilisateur seront traduites au fur et à mesure ou à intervalles réguliers ? Ceci peut dépendre de la taille et de l'échelle des sites et du contenu à traiter.

  • Comment allez-vous gérer les remplacements de traduction ? Voulez-vous que les modifications apportées dans la langue primaire remplacent les valeurs de chaîne dans les langues secondaires ? Dans ce cas, vous devez activer l'option Remplacer les traductions dans la page de Paramètres de langue.

  • Quels sont les noms de colonnes qui doivent être modifiés ? Quels sont les noms de colonnes qui doivent être traduits et dans quelles langues ? Les noms de colonnes seront-ils situés au niveau de la liste ou au niveau du site ?

Planifier l'installation des Service Packs

Si des modules linguistiques sont mis à jour dans le cadre de la publication d'un Service Pack pour SharePoint, vous devez mettre à jour les modules linguistiques sur le serveur au moment de l'installation du Service Pack. Vous devez coordonner vos efforts avec l'administrateur de batterie pour suivre la publication des Service Packs et des modules linguistiques associés ; lorsque ceux-ci sont mis à jour, vous devrez les installer pour vos utilisateurs.

Voir aussi

Concepts

Présentation de l'interface utilisateur multilingue (SharePoint Foundation 2010)
Planifier des sites multilingues (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Planification de la sécurité pour les sites et le contenu (SharePoint Foundation 2010)

Certains sites dans votre entreprise comportent probablement du contenu qui ne doit pas être disponible pour tous les utilisateurs. Par exemple, les informations techniques propriétaires ne doivent être accessibles qu'au cas par cas. De même, un portail intranet pour les avantages accordés aux employés ne doit être disponible que pour les employés à temps complet, tandis que la page d'accueil d'un site Web Internet est accessible par les clients anonymes.

Les autorisations contrôlent l'accès à vos sites et à leur contenu. Vous pouvez gérer les autorisations à l'aide de groupes Microsoft SharePoint Foundation 2010, qui contrôlent l'appartenance, et d'autorisations affinées, qui permettent de sécuriser le contenu au niveau de l'élément et du document. Cette section décrit les autorisations relatives aux sites et à leur contenu et indique les points à prendre en considération lors du choix des autorisations.

Dans cette section :

  • Planifier les autorisations des sites (SharePoint Foundation 2010) vous aide à comprendre le mode d'attribution des autorisations et à choisir les autorisations à utiliser dans votre collection de sites ou votre sous-site.

  • Déterminer les niveaux d'autorisation et les groupes (SharePoint Foundation) passe en revue les niveaux d'autorisation disponibles et vous aide à déterminer si vous avez besoin de niveaux d'autorisation ou de groupes supplémentaires.

  • Choisir les groupes de sécurité (SharePoint Foundation 2010) vous aide à déterminer les comptes d'utilisateurs et de groupes de sécurité Microsoft Windows à utiliser pour accorder l'accès aux sites, à décider s'il faut utiliser le groupe Utilisateurs authentifiés et s'il faut autoriser l'accès anonyme.

  • Choisir les administrateurs et les propriétaires pour la hiérarchie d'administration (SharePoint Foundation 2010) définit les niveaux d'administration à partir du niveau de serveur vers le niveau de sous-site et vous aide à choisir des administrateurs pour chaque niveau.

  • Meilleures pratiques pour l'utilisation des permissions affinées (livre blanc) (SharePoint Foundation 2010) fournit des instructions concernant l'utilisation des permissions affinées dans les Produits SharePoint 2010.

Historique des modifications


Planifier les autorisations des sites (SharePoint Foundation 2010)

Cet article vous aide à planifier le contrôle d'accès aux niveaux de la collection de sites, du site et du sous-site. En outre, il décrit l'héritage des autorisations et les autorisations affinées, et explique comment déterminer les autorisations effectives des utilisateurs et des groupes suivant différentes étendues au sein d'une hiérarchie de collection de sites.

Dans cet article :

  • À propos des autorisations de site

  • À propos de l'affectation des autorisations

  • Héritage des autorisations et autorisations affinées

  • Héritage d'autorisations et sous-sites

  • À propos des autorisations effectives

  • Choisir les niveaux d'autorisation

  • Planifier l'héritage des autorisations

Introduction

Vous contrôlez l'accès au site et au contenu en accordant aux utilisateurs et aux groupes un jeu d'autorisations pour un site, une liste, une bibliothèque, un dossier, un document ou un élément spécifique. Lorsque vous développez votre plan pour l'accès au site et au contenu, vous devez prendre en considération les points suivants :

  • Dans quelle mesure vous souhaitez contrôler les autorisations pour le site ou le contenu du site. Par exemple, vous pouvez souhaiter contrôler l'accès au niveau du site ou avoir besoin de paramètres de sécurité plus restrictifs pour une liste, un dossier ou un élément spécifique.

  • La façon d'utiliser des groupes pour classer et gérer les utilisateurs. Les groupes ne possèdent pas d'autorisations tant qu'un niveau d'autorisation ne leur a pas été affecté pour un site ou un contenu de site spécifique. Lorsque vous affectez des niveaux d'autorisation à des groupes SharePoint au niveau de la collection de sites, par défaut, la totalité des sites et leur contenu héritent ces niveaux d'autorisation. Pour plus d'informations sur le classement des utilisateurs en groupes, voir « Choisir les groupes de sécurité ».

Cet article décrit les autorisations de site et vous aide à déterminer les sites ou le contenu de site nécessitant des autorisations uniques. Il n'aborde pas la planification de la sécurité de l'ensemble du serveur ou de la batterie de serveurs.

À propos des autorisations de site

Vous devez comprendre les concepts suivants avant de configurer l'accès aux sites et au contenu de site :

  • Autorisations utilisateur individuelles Les autorisations individuelles accordent à un utilisateur la possibilité d'exécuter des actions spécifiques. Par exemple, l'autorisation Afficher les éléments permet à l'utilisateur d'afficher des éléments dans une liste ou un dossier, mais pas d'ajouter ou de supprimer des éléments. Pour plus d'informations sur les autorisations disponibles, voir Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010).

  • Niveau d'autorisation Ce jeu d'autorisations accorde aux utilisateurs la possibilité d'effectuer un ensemble de tâches connexes. Par exemple, le niveau d'autorisation Lecture comprend, entre autres, les autorisations Afficher les éléments, Ouvrir les éléments, Afficher les pages et Afficher les versions, qui sont toutes nécessaires pour la lecture des documents, des éléments et des pages d'un site SharePoint. Les autorisations individuelles peuvent être incluses dans plus d'un niveau d'autorisation. Les niveaux d'autorisation peuvent être personnalisés par n'importe quel utilisateur affecté à un niveau d'autorisation qui inclut l'autorisation Gérer les autorisations. Les niveaux d'autorisation par défaut sont : Accès limité, Lecture, Collaboration, Conception et Contrôle total. Pour plus d'informations sur les niveaux d'autorisation par défaut et sur les autorisations incluses dans chaque niveau, voir Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010).

  • Groupe Un groupe peut être un groupe de sécurité Windows ou un groupe tel que Propriétaires du site, Membres du site ou Visiteurs du site. Les groupes sont créés et gérés au niveau de la collection de sites. Chaque groupe SharePoint reçoit un niveau d'autorisation par défaut, mais le niveau d'autorisation associé à n'importe quel groupe peut être personnalisé. Toute personne affectée à un niveau d'autorisation qui comprend l'autorisation Créer des groupes, incluse dans le niveau d'autorisation Contrôle total par défaut, peut créer des groupes SharePoint personnalisés.

  • Utilisateur Un utilisateur est une personne qui a un compte d'utilisateur qui peut être authentifié par la même méthode d'authentification que celle utilisée pour le serveur. Il est recommandé d'affecter des autorisations à des groupes plutôt qu'à des utilisateurs, bien que vous puissiez accorder directement à des utilisateurs spécifiques des autorisations sur un site ou sur un contenu de site spécifique, ou affecter directement un niveau d'autorisation à un utilisateur. Étant donné qu'il n'est pas efficace de gérer des comptes d'utilisateurs individuels, vous ne devez affecter des autorisations à un utilisateur spécifique qu'à titre exceptionnel. Pour plus d'informations sur les types de comptes d'utilisateur, voir Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010).

  • Objet sécurisable Un objet sécurisable est un site, une liste, une bibliothèque, un dossier, un document ou un élément pour lesquels des niveaux d'autorisation peuvent être affectés à des utilisateurs ou à des groupes. Par défaut, toutes les listes et bibliothèques au sein d'un site héritent les autorisations de ce site. Vous pouvez utiliser des autorisations au niveau de la liste, du dossier et de l'élément pour contrôler davantage les utilisateurs pouvant afficher ou manipuler le contenu du site. Par exemple, si un niveau d'autorisation pour un objet sécurisable spécifique comprend l'autorisation Gérer les autorisations, toute personne à laquelle est affecté ce niveau d'autorisation peut modifier les autorisations associées à cet objet sécurisable. Vous pouvez restaurer l'héritage des autorisations d'une liste parent, de la totalité du site ou d'un site parent à tout moment.

À propos de l'affectation des autorisations

Vous pouvez affecter à un utilisateur ou à un groupe un niveau d'autorisation pour un objet sécurisable spécifique. Des utilisateurs individuels ou des groupes peuvent avoir différents niveaux d'autorisation pour différents objets sécurisables.

À propos de l'héritage des autorisations

Les autorisations sur les objets sécurisables au sein d'un site sont héritées du site lui-même par défaut. Vous pouvez utiliser les autorisations affinées — autorisations uniques au niveau de la liste, de la bibliothèque, du dossier ou du document — pour contrôler davantage les actions que les utilisateurs peuvent effectuer sur votre site.

Héritage des autorisations et autorisations affinées

Vous pouvez interrompre l'héritage des autorisations pour n'importe quel objet sécurisable à un niveau inférieur dans la hiérarchie de site en créant une autorisation affinée sur cet objet sécurisable. Par exemple, vous pouvez modifier les autorisations pour une bibliothèque de documents, ce qui interrompt l'héritage du site. Toutefois, l'héritage est uniquement interrompu pour l'objet sécurisable pour lequel vous avez modifié des autorisations ; les autres autorisations du site demeurent inchangées. Vous pouvez à tout moment restaurer l'héritage des autorisations de la liste ou du site parents.

Conseil :
Si vous utilisez des autorisations affinées, vous devez utiliser des groupes pour ne pas avoir à effectuer le suivi de comptes d'utilisateurs individuels. Par exemple, les personnes pouvant intégrer ou quitter les équipes et changer de responsabilité fréquemment, le suivi de ces modifications et la mise à jour des autorisations associées à des objets sécurisés de manière unique prendraient beaucoup de temps et seraient source d'erreur.

Les objets sécurisables suivants peuvent accepter des affectations d'autorisations affinées :

  • Site : contrôle l'accès au site dans sa globalité.

  • Liste ou bibliothèque : contrôle l'accès à une liste ou bibliothèque spécifique.

  • Dossier : contrôle l'accès aux propriétés d'un dossier (telles que le nom du dossier).

  • Élément ou document : contrôle l'accès à un élément ou document de liste spécifique.

Héritage d'autorisations et sous-sites

L'héritage des autorisations est le comportement par défaut et la façon la plus simple pour gérer un groupe de sites Web. Toutefois, si un sous-site hérite les autorisations de son parent, ce jeu d'autorisations est partagé avec le parent. Si les propriétaires du sous-site modifient ses autorisations, les autorisations du site changent également, ce qui pourrait nuire à la sécurité ou empêcher les utilisateurs d'accéder au contenu.

Si vous souhaitez modifier les autorisations pour le sous-site uniquement, vous devez interrompre l'héritage des autorisations du site, puis créer des autorisations affinées sur le sous-site. Par exemple, si des listes, des bibliothèques, des dossiers, des éléments ou des documents spécifiques contiennent des données sensibles nécessitant un niveau de protection accru, vous pouvez créer des autorisations affinées pour un groupe ou un utilisateur spécifique nécessitant un accès.

La création d'autorisations uniques copie les groupes, les utilisateurs et les niveaux d'autorisation depuis le site parent vers le sous-site, puis interrompt l'héritage. Si vous restaurez les autorisations héritées, le sous-site hérite ses utilisateurs, ses groupes et ses niveaux d'autorisation du site parent de nouveau et vous perdez les utilisateurs, les groupes ou les niveaux d'autorisation qui étaient propres au sous-site.

Remarque :
En guise de meilleure pratique, vous devez organiser les sites et les sous-sites de manière à ce qu'ils partagent la plupart de leurs autorisations et procéder de même pour les listes et les bibliothèques. Placez toutes les données sensibles dans des listes, bibliothèques ou sous-sites distincts.

À propos des autorisations effectives

La configuration des paramètres de sécurité ou la réalisation d'opérations en bloc requièrent des informations précises sur les autorisations d'utilisateur et de groupe sur les ressources des sites. Par exemple, de nombreux sites SharePoint accordent à tous les utilisateurs authentifiés (groupe de domaines NTAUTHORITY\AUTHENTICATED USERS) l'accès à au moins une partie du contenu de site. Si vous souhaitez restreindre l'accès davantage, vous devez déterminer exactement les autorisations détenues par les utilisateurs authentifiés et le contenu de site sur lequel elles sont définies.

Le suivi des autorisations héritées et des zones dans lesquelles l'héritage est interrompu complique le processus de détermination des autorisations adéquates. Microsoft SharePoint Foundation 2010 utilise des autorisations effectives pour déterminer les autorisations d'un utilisateur ou d'un groupe sur toutes les ressources au sein d'une collection de sites. Vous pouvez désormais rechercher à la fois les autorisations affectées directement à l'utilisateur et les autorisations affectées à tout groupe dont il est membre.

Important :
Les autorisations effectives facilitent la recherche d'autorisations dans une collection de sites. Toutefois, elles ne doivent jamais se substituer à une structure d'autorisations soigneusement planifiée.

Choisir les niveaux d'autorisation

Lorsque vous créez des autorisations, vous devez rechercher le meilleur compromis entre, d'une part, la facilité d'administration et les performances et, d'autre part, la nécessité de contrôler l'accès à des éléments spécifiques. Si vous utilisez des autorisations affinées de manière intensive, vous allez consacrer plus de temps à la gestion des autorisations et les utilisateurs peuvent faire face à une baisse des performances lorsqu'ils essaient d'accéder au contenu du site.

Suivez les recommandations suivantes pour configurer les autorisations de site :

  • Suivez le principe des privilèges minimum : les utilisateurs ne doivent bénéficier que des niveaux d'autorisation ou des autorisations spécifiques dont ils ont besoin pour effectuer les tâches qui leur ont été affectées.

  • Utilisez des groupes standard (tels que Membres, Visiteurs et Propriétaires) et contrôlez les autorisations au niveau du site.

  • Intégrez la plupart des utilisateurs aux groupes Membres ou Visiteurs. Par défaut, les utilisateurs figurant dans le groupe Membres peuvent collaborer au site, ajouter ou supprimer des éléments ou des documents, mais ils ne peuvent pas modifier la structure, les paramètres ou l'apparence du site. Le groupe Visiteurs dispose d'un accès en lecture seule au site, ce qui signifie que ses membres peuvent afficher les pages et les éléments, ainsi qu'ouvrir des éléments et des documents, mais qu'ils ne peuvent pas ajouter ou supprimer de pages, d'éléments ou de documents.

  • Limitez le nombre de personnes dans le groupe Propriétaires. Seuls les utilisateurs dont vous estimez qu'ils peuvent modifier la structure, les paramètres ou l'apparence du site doivent être membres du groupe Propriétaires.

Vous pouvez créer des niveaux d'autorisation et des groupes SharePoint supplémentaires si vous devez contrôler davantage les actions que vos utilisateurs peuvent effectuer. Par exemple, si vous ne souhaitez pas que le niveau d'autorisation Lecture sur un sous-site spécifique inclue l'autorisation Créer des alertes, interrompez l'héritage et personnalisez le niveau d'autorisation Lecture pour ce sous-site.

Planifier l'héritage des autorisations

Il est beaucoup plus facile de gérer les autorisations lorsqu'il existe une hiérarchie claire des autorisations et des autorisations héritées. Cela devient plus difficile lorsque des autorisations affinées sont appliquées à certaines listes au sein d'un site et que certains sites disposent de sous-sites auxquels sont associées des autorisations uniques, tandis que d'autres disposent de sous-sites auxquels sont associées des autorisations héritées.

Par exemple, il est beaucoup plus facile de gérer un site qui bénéficie de l'héritage des autorisations, comme indiqué dans le tableau ci-dessous.

Objet sécurisable | Description | Autorisations uniques ou héritées
Site_A | Page d'accueil du groupe | Uniques
Site_A/Sous-site_A | Groupe sensible | Uniques
Site_A/Sous-site_A/Liste_A | Données sensibles | Uniques
Site_A/Sous-site_A/Bibliothèque_A | Documents critiques | Uniques
Site_A/Sous-site_B | Informations de projet partagées relatives au groupe | Héritées
Site_A/Sous-site_B/Liste_B | Données non sensibles | Héritées
Site_A/Sous-site_B/Bibliothèque_B | Documents non critiques | Héritées

Cependant, il n'est pas aussi facile de gérer un site qui bénéficie de l'héritage des autorisations, comme indiqué dans le tableau ci-dessous.

Objet sécurisable | Description | Autorisations uniques ou héritées
Site_A | Page d'accueil du groupe | Uniques
Site_A/Sous-site_A | Groupe sensible | Uniques
Site_A/Sous-site_A/Liste_A | Données non sensibles | Autorisations uniques, mais les mêmes que celles associées à Site_A
Site_A/Sous-site_A/Bibliothèque_A | Documents non critiques, mais existence d'un ou deux documents critiques | Autorisations héritées et existence d'autorisations uniques au niveau du document
Site_A/Sous-site_B | Informations de projet partagées relatives au groupe | Héritées
Site_A/Sous-site_B/Liste_B | Données non sensibles, mais existence d'un ou deux éléments sensibles | Autorisations héritées et existence d'autorisations uniques au niveau de l'élément
Site_A/Sous-site_B/Bibliothèque_B | Documents non critiques, mais existence d'un dossier spécial contenant des documents critiques | Autorisations héritées et existence d'autorisations uniques au niveau du dossier et du document

Historique des modifications

Date | Description | Raison
2010/12/13 | 2010/12/13 | Mise à jour du contenu


Déterminer les niveaux d'autorisation et les groupes (SharePoint Foundation)

Cet article passe en revue les groupes par défaut et les niveaux d'autorisation, et vous aide à déterminer si vous devez les utiliser, les personnaliser ou ajouter de nouveaux groupes et niveaux d'autorisation pour accroître la sécurité.

Dans cet article :

  • Passer en revue les groupes par défaut disponibles

  • Passer en revue les niveaux d'autorisation disponibles

  • Déterminer si vous avez besoin de niveaux d'autorisation ou de groupes supplémentaires

La décision la plus importante concernant la sécurité de votre site et de votre contenu dans Microsoft SharePoint Foundation 2010 porte sur le classement de vos utilisateurs et sur les niveaux d'autorisation à affecter.

Il existe plusieurs groupes SharePoint par défaut destinés à vous aider à classer vos utilisateurs en fonction des types d'actions qu'ils doivent effectuer, mais vous pouvez avoir vos propres besoins ou votre propre approche des ensembles d'utilisateurs. De même, il existe des niveaux d'autorisation par défaut, mais il est possible qu'ils ne correspondent pas exactement aux tâches que vos groupes doivent effectuer.

Dans cet article, vous passez en revue les groupes et les niveaux d'autorisation par défaut et décidez s'ils doivent être utilisés tels quels, être personnalisés ou si vous devez créer d'autres groupes et niveaux d'autorisation.

Passer en revue les groupes par défaut disponibles

Avec les groupes SharePoint, vous gérez des ensembles d'utilisateurs au lieu d'utilisateurs individuels. Les groupes SharePoint peuvent être composés de nombreux utilisateurs individuels, contenir un seul groupe de sécurité Windows ou être une combinaison des deux. Les groupes SharePoint n'accordent aucun droit spécifique sur le site ; ils sont simplement un moyen de regrouper un ensemble d'utilisateurs. Vous pouvez organiser les utilisateurs en une série de groupes dont le nombre dépend de la taille et de la complexité de votre organisation ou de votre site Web.

Le tableau suivant montre les groupes par défaut créés pour les sites dans SharePoint Foundation 2010.

Nom du groupe | Niveau d'autorisation par défaut
Visiteurs de <nom du site> | Lecture
Membres de <nom du site> | Collaboration
Propriétaires de <nom du site> | Contrôle total

En outre, les utilisateurs et les groupes spéciaux ci-dessous sont disponibles pour les tâches d'administration de niveau supérieur :

  • Administrateurs de collections de sites Vous pouvez désigner un ou plusieurs utilisateurs comme administrateurs de collections de sites principaux et secondaires. Ces utilisateurs sont enregistrés dans la base de données en tant que contacts pour la collection de sites, possèdent un contrôle total de tous les sites dans la collection de sites et peuvent auditer l'ensemble du contenu de site et recevoir des alertes d'administration (par exemple, une alerte visant à déterminer si le site est en cours d'utilisation). En règle générale, vous désignez les administrateurs de la collection de sites lorsque vous créez le site, mais vous pouvez les modifier au besoin à l'aide du site Administration centrale ou des pages Paramètres du site.

  • Administrateurs de la batterie : détermine les utilisateurs habilités à gérer les paramètres de serveur et de batterie de serveurs. Grâce au groupe Administrateurs de la batterie, il n'est plus nécessaire d'ajouter des utilisateurs au groupe Administrateurs pour le serveur. Les administrateurs de batterie n'ont pas accès au contenu de site par défaut. Ils doivent prendre possession du site pour afficher du contenu. À cet effet, ils s'ajoutent en tant qu'administrateurs de la collection de sites et cette action est enregistrée dans les journaux d'audit. Le groupe Administrateurs de la batterie n'est utilisé que dans l'Administration centrale et n'est disponible pour aucun site.

  • Administrateurs : les membres du groupe Administrateurs sur le serveur local peuvent effectuer toutes les actions des administrateurs de batterie ainsi que d'autres actions, par exemple :

    • installation de nouveaux produits ou de nouvelles applications ;

    • déploiement de composants WebPart et de nouvelles fonctionnalités dans le Global Assembly Cache ;

    • création d'applications Web et de sites Web IIS ;

    • démarrage des services.

    Comme le groupe Administrateurs de batterie, les membres du groupe Administrateurs sur le serveur local n'ont pas accès au contenu du site, par défaut.

Une fois que vous avez déterminé les groupes dont vous avez besoin, déterminez les niveaux d'autorisation à affecter à chaque groupe sur votre site.

Passer en revue les niveaux d'autorisation disponibles

La capacité à afficher, modifier ou gérer un site particulier est déterminée par le niveau d'autorisation que vous affectez à un utilisateur ou groupe. Ce niveau d'autorisation contrôle toutes les autorisations pour le site et pour les sous-sites, listes, bibliothèques de documents, dossiers et éléments ou documents éventuels, qui héritent des autorisations du site. Sans les niveaux d'autorisation appropriés, les utilisateurs peuvent ne pas être en mesure d'effectuer leurs tâches ou risquent d'effectuer des tâches que vous ne leur avez pas destinées.

Par défaut, les niveaux d'autorisation disponibles sont les suivants :

  • Accès limité : comprend les autorisations qui permettent aux utilisateurs d'afficher des listes, des bibliothèques de documents, des éléments de liste, des dossiers ou des documents spécifiques lorsqu'elles leur sont accordées.

  • Lecture : comprend les autorisations qui permettent aux utilisateurs d'afficher des éléments dans les pages du site.

  • Collaboration : comprend les autorisations qui permettent aux utilisateurs d'ajouter ou de modifier des éléments dans les pages du site ou dans les listes et les bibliothèques de documents.

  • Conception : comprend les autorisations qui permettent aux utilisateurs de modifier la présentation des pages du site à l'aide du navigateur ou de Microsoft Office SharePoint Designer 2007 ;.

  • Contrôle total : comprend toutes les autorisations.

Déterminer si vous avez besoin de niveaux d'autorisation ou de groupes supplémentaires

Les groupes et les niveaux d'autorisation par défaut fournissent une infrastructure générale pour les autorisations, couvrant de nombreux types d'organisations et rôles différents dans ces organisations. Toutefois, il est possible qu'ils ne correspondent pas exactement à la façon dont vos utilisateurs sont organisés ou aux nombreuses tâches différentes que vos utilisateurs effectuent sur vos sites. Si les groupes et les niveaux d'autorisation par défaut ne correspondent pas à votre organisation, vous pouvez créer des groupes personnalisés, modifier les autorisations incluses dans des niveaux d'autorisation spécifiques ou créer des niveaux d'autorisation personnalisés.

Avez-vous besoin de groupes personnalisés ?

La décision de créer des groupes personnalisés est relativement simple et a peu d'effet sur la sécurité de votre site. Pour l'essentiel, vous devez créer des groupes personnalisés au lieu d'utiliser les groupes par défaut si l'une des conditions ci-dessous s'applique :

  • Vous avez plus (ou moins) de rôles utilisateur au sein de votre organisation qu'il paraît dans les groupes par défaut. Par exemple, outre les concepteurs, si un ensemble de personnes est chargé de publier du contenu sur le site, vous pouvez souhaiter créer un groupe Éditeurs.

  • Il existe des noms connus pour des rôles uniques au sein de votre organisation qui exécutent des tâches très différentes dans les sites. Par exemple, si vous créez un site public pour vendre les produits de votre organisation, vous pouvez souhaiter créer un groupe Clients qui remplace le groupe Visiteurs ou Visualiseurs.

  • Vous souhaitez conserver une relation un à un entre les groupes de sécurité Windows et les groupes SharePoint (par exemple, votre organisation possède un groupe de sécurité Responsables de site Web et vous souhaitez utiliser ce nom en tant que nom de groupe pour faciliter l'identification lors de la gestion du site).

  • Vous préférez d'autres noms de groupes.

Avez-vous besoin de niveaux d'autorisation personnalisés ?

La décision de personnaliser les niveaux d'autorisation est moins simple que la décision de personnaliser les groupes SharePoint. Si vous personnalisez les autorisations affectées à un niveau d'autorisation, vous devez effectuer le suivi de cette modification, vérifier que l'opération fonctionne pour tous les groupes et sites affectés par cette modification et vous assurer que celle-ci n'affecte pas la sécurité ni la capacité ou les performances de votre serveur.

Par exemple, en ce qui concerne la sécurité, si vous personnalisez le niveau d'autorisation Collaboration pour inclure l'autorisation Créer des sous-sites qui fait généralement partie du niveau d'autorisation Contrôle total, les collaborateurs peuvent créer et posséder des sous-sites, avec le risque d'inviter des utilisateurs malveillants à visiter leurs sous-sites ou de publier du contenu non approuvé. Par ailleurs, en ce qui concerne la capacité, si vous modifiez le niveau d'autorisation Lecture pour inclure l'autorisation Créer des alertes qui fait généralement partie du niveau d'autorisation Collaboration, tous les membres du groupe Visiteurs peuvent créer des alertes, ce qui peut entraîner une surcharge pour vos serveurs.

Vous devez personnaliser les niveaux d'autorisation par défaut si l'une des situations ci-dessous s'applique :

  • Un niveau d'autorisation par défaut inclut toutes les autorisations sauf celle dont vos utilisateurs ont besoin pour effectuer leur travail et vous souhaitez ajouter cette autorisation.

  • Un niveau d'autorisation par défaut inclut une autorisation dont vos utilisateurs n'ont pas besoin.

    Remarque :
    Vous ne devez pas personnaliser les niveaux d'autorisation par défaut si votre organisation doit faire face à des problèmes liés à la sécurité ou à d'autres aspects concernant une autorisation en particulier et souhaite rendre cette autorisation non disponible pour tous les utilisateurs affectés aux niveaux d'autorisation comprenant cette autorisation. Dans ce cas, il est conseillé de désactiver cette autorisation pour toutes les applications Web dans la batterie de serveurs, plutôt que de modifier tous les niveaux d'autorisation.

Si vous avez devez apporter plusieurs modifications à un niveau d'autorisation en particulier, il est préférable de créer un niveau d'autorisation personnalisé, qui inclut toutes les autorisations dont vous avez besoin.

Vous pouvez souhaiter créer des niveaux d'autorisation supplémentaires si l'une des deux situations ci-dessous s'applique :

  • Vous souhaitez exclure plusieurs autorisations d'un niveau d'autorisation en particulier.

  • Vous voulez définir un ensemble unique d'autorisations pour un nouveau niveau d'autorisation.

Pour élaborer un niveau d'autorisation, vous pouvez copier un niveau d'autorisation existant, puis apporter les modifications de votre choix, ou vous pouvez créer un niveau d'autorisation, puis sélectionner les autorisations que vous souhaitez inclure.

Remarque :
Certaines autorisations dépendent d'autres autorisations. Si vous désactivez une autorisation dont dépend une autre autorisation, l'autre autorisation est également désactivée.

Historique des modifications

Date | Description | Raison
2010/12/13 | 2010/12/13 | Mise à jour du contenu


Choisir les groupes de sécurité (SharePoint Foundation 2010)

Cet article décrit les groupes de sécurité et de distribution inclus dans les services de domaine Active Directory (AD DS). En outre, il fournit des recommandations pour l'utilisation de ces groupes dans le but d'organiser les utilisateurs des sites SharePoint.

Dans cet article :

  • Déterminer les groupes de sécurité et les comptes Windows à utiliser pour l'octroi de l'accès aux sites

  • Décider s'il faut autoriser l'accès à tous les utilisateurs authentifiés

  • Décider s'il faut autoriser l'accès aux utilisateurs anonymes

Introduction

La gestion des utilisateurs des sites SharePoint est plus facile si vous attribuez des autorisations de site à des groupes au lieu de les attribuer à des utilisateurs individuels. Dans AD DS, les groupes suivants sont généralement utilisés pour organiser les utilisateurs :

  • Groupe de distribution Ce groupe, uniquement utilisé pour la distribution de courrier électronique, n'est pas sécurisé. Les groupes de distribution ne peuvent pas être répertoriés dans les listes de contrôle d'accès discrétionnaires, qui sont utilisées pour définir des autorisations sur les ressources et les objets.

  • Groupe de sécurité Ce groupe peut être répertorié dans les listes de contrôle d'accès discrétionnaires. Un groupe de sécurité peut également servir d'entité de messagerie.

Vous pouvez utiliser les groupes de sécurité pour contrôler les autorisations pour votre site en ajoutant directement le groupe de sécurité au site et en accordant les autorisations à l'ensemble du groupe. Vous ne pouvez pas ajouter directement des groupes de distribution de cette manière, mais vous pouvez développer un groupe de distribution et ajouter des membres individuels à un groupe SharePoint. Si vous utilisez cette méthode, vous devez conserver manuellement la synchronisation entre le groupe SharePoint et le groupe de distribution. Si vous utilisez des groupes de sécurité, il est inutile de gérer les utilisateurs individuels dans l'application SharePoint. Étant donné que vous avez inclus le groupe de sécurité lui-même et non les membres individuels du groupe, AD DS gère les utilisateurs pour vous.

Remarque :
Les groupes de sécurité qui contiennent les éléments suivants peuvent s'avérer difficiles à gérer :

  • groupes de sécurité imbriqués ;

  • contacts ou listes de distribution.

Déterminer les groupes de sécurité et les comptes Windows à utiliser pour l'octroi de l'accès aux sites

Chaque organisation configure ses groupes de sécurité Windows différemment. Pour faciliter la gestion des autorisations, les groupes de sécurité doivent être :

  • Suffisamment grands et stables pour que vous ne soyez pas constamment obligé d'ajouter des groupes à vos sites SharePoint.

  • Suffisamment petits pour que vous puissiez attribuer les autorisations appropriées.

Par exemple, un groupe de sécurité nommé « tous les utilisateurs du bâtiment 2 » n'est probablement pas assez petit pour attribuer des autorisations, sauf si tous les utilisateurs du bâtiment 2 ont la même fonction, telle que secrétaires à la comptabilité clients. Ceci étant rarement le cas, vous devez rechercher un ensemble d'utilisateurs plus petit et plus spécifique tel que « Comptabilité clients ».

Décider s'il faut autoriser l'accès à tous les utilisateurs authentifiés

Si vous souhaitez que tous les utilisateurs de votre domaine soient en mesure d'afficher le contenu de votre site, envisagez d'accorder l'accès à tous les utilisateurs authentifiés (le groupe de sécurité Windows Utilisateurs du domaine). Ce groupe spécial permet à tous les membres de votre domaine d'accéder à un site Web (au niveau d'autorisation que vous choisissez), sans qu'il soit nécessaire d'activer l'accès anonyme.

Décider s'il faut autoriser l'accès aux utilisateurs anonymes

Vous pouvez activer l'accès anonyme pour permettre aux utilisateurs d'afficher les pages de façon anonyme. La plupart des sites Web Internet autorisent l'affichage anonyme d'un site, mais peuvent exiger une authentification lorsqu'un utilisateur souhaite modifier le site ou acheter un élément sur un site d'achat. L'accès anonyme doit être accordé au niveau de l'application Web au moment de la création de celle-ci.

Si l'accès anonyme est activé pour l'application Web, les administrateurs de sites peuvent décider s'il faut :

  • Accorder l'accès anonyme à un site.

  • Accorder l'accès anonyme uniquement à des listes et des bibliothèques.

  • Bloquer complètement l'accès anonyme à un site.

L'accès anonyme repose sur le compte d'utilisateur anonyme sur le serveur Web. Ce compte est créé et géré par Internet Information Services (IIS), et non par votre site SharePoint. Par défaut, dans IIS, le compte d'utilisateur anonyme est IUSR. Lorsque vous activez l'accès anonyme, vous octroyez en effet à ce compte l'accès au site SharePoint. L'autorisation d'accès à un site, ou à des listes et des bibliothèques, accorde l'autorisation Afficher les éléments au compte d'utilisateur anonyme. Toutefois, même avec l'autorisation Afficher les éléments, il existe des restrictions aux tâches que les utilisateurs anonymes peuvent effectuer. Les utilisateurs anonymes ne peuvent pas :

  • Ouvrir des sites pour les modifier dans Microsoft SharePoint Designer 2010 ; autrement dit, ils ne peuvent pas utiliser l'appel de procédure distante (RPC, Remote Procedure Call).

  • Afficher des sites dans les Favoris réseau ; autrement dit, ils ne peuvent pas utiliser WebDAV (Web Distributed Authoring and Versioning), le protocole des dossiers Web dans Windows.

  • Télécharger ou modifier des documents dans les bibliothèques de documents, y compris dans les bibliothèques Wiki.

    Important :
    Pour améliorer la sécurité des sites, des listes ou des bibliothèques, n'activez pas l'accès anonyme. L'activation de l'accès anonyme permet aux utilisateurs de contribuer aux listes, aux discussions et aux enquêtes, en consommant éventuellement de l'espace disque sur le serveur et d'autres ressources. En outre, l'accès anonyme permet aux utilisateurs anonymes de découvrir des informations de site, notamment les adresses de messagerie des utilisateurs et du contenu publié dans les listes, les bibliothèques et les discussions.

Vous pouvez définir des stratégies d'autorisation pour l'utilisateur anonyme pour différentes zones (Internet, extranet, intranet ou autre) si une même application sert du contenu dans ces différentes zones. Les stratégies sont décrites dans la liste suivante :

  • Aucune Aucune stratégie. Il s'agit de l'option par défaut. Aucune restriction ou aucun ajout d'autorisation supplémentaire n'est appliqué aux utilisateurs anonymes des sites.

  • Lecture Les utilisateurs anonymes peuvent lire le contenu, à moins que l'administrateur du site ne désactive l'accès anonyme.

  • Refuser l'accès en écriture Les utilisateurs anonymes ne peuvent pas écrire du contenu, même si l'administrateur de site tente spécifiquement d'accorder cette autorisation au compte d'utilisateur anonyme.

  • Refuser tous les accès Les utilisateurs anonymes n'ont aucun accès, même si les administrateurs de sites tentent spécifiquement d'accorder au compte d'utilisateur anonyme un accès à leurs sites.

Historique des modifications

Date | Description | Raison
2010/12/13 | 2010/12/13 | Mise à jour du contenu


Choisir les administrateurs et les propriétaires pour la hiérarchie d'administration (SharePoint Foundation 2010)

Cet article décrit les rôles d'administrateur qui correspondent à la hiérarchie de sites et de serveurs Microsoft SharePoint Foundation 2010. De nombreuses personnes peuvent être impliquées dans la gestion de SharePoint Foundation 2010. L'administration de SharePoint Foundation 2010se produit aux niveaux suivants :

  • Batterie de serveurs

  • Services partagés

  • Sites

  • Bibliothèque de documents ou liste

  • Eléments spécifiques

Dans cet article :

  • Niveaux d'administration

Introduction

La plupart des niveaux de la hiérarchie de sites et de serveurs disposent d'un groupe d'administration correspondant. Le niveau d'application Web ne possède pas de groupe d'administrateurs unique, mais les administrateurs de batterie contrôlent les applications Web dans leur zone de responsabilité. Les membres du groupe Administrateurs de batterie et les membres du groupe Administrateurs du serveur local peuvent définir une stratégie pour accorder aux utilisateurs individuels des autorisations au niveau de l'application Web.

Niveaux d'administration

Les groupes d'utilisateurs suivants disposent d'autorisations d'administration à différents niveaux de la hiérarchie d'administration :

  • Niveau serveur ou batterie de serveurs

    • Groupe Administrateurs de batterie Les membres du groupe Administrateurs de batterie ont des autorisations pour tous les serveurs de la batterie de serveurs et en sont également responsables. Ils peuvent effectuer toutes les tâches d'administration dans l'Administration centrale pour le serveur ou la batterie de serveurs. Les membres de ce groupe peuvent également utiliser Windows PowerShell pour créer et gérer des objets de la base de données de configuration. Ils peuvent attribuer à des administrateurs la tâche de gérer des applications de service, qui sont des instances de services partagés. Ce groupe ne peut pas accéder à des sites individuels ni à leur contenu.

    • Groupe Administrateurs Les membres du groupe Administrateurs sur le serveur local peuvent effectuer toutes les actions des administrateurs de batterie en plus d'autres actions. Les administrateurs sur le serveur local peuvent effectuer des tâches supplémentaires, telles que l'installation de nouveaux produits ou applications, le déploiement de composants WebPart et de nouvelles fonctionnalités dans le Global Assembly Cache, la création d'applications Web et de sites Web IIS, ainsi que le démarrage de services. Comme les administrateurs de batterie, les membres de ce groupe sur le serveur local n'ont par défaut aucun accès au contenu des sites.

      Remarque :
      Les administrateurs de batterie et les administrateurs locaux peuvent prendre si nécessaire la propriété de collections de sites spécifiques. Par exemple, si un administrateur de site quitte l'organisation et qu'un nouvel administrateur doit être ajouté, l'administrateur de batterie ou un membre du groupe Administrateurs local peut prendre la propriété de la collection de sites pour effectuer la modification.

  • Niveau services partagés

    • Administrateurs d'application de service La fonction de ces administrateurs est déléguée par l'administrateur de la batterie de serveurs. Ces administrateurs peuvent configurer des paramètres pour une application de service spécifique au sein d'une batterie de serveurs. Toutefois, ils ne peuvent pas créer des applications de service, accéder à d'autres applications de service dans la batterie de serveurs ou effectuer des opérations au niveau de la batterie de serveurs, notamment des modifications de topologie. Par exemple, l'administrateur d'une application de service de recherche dans une batterie de serveurs peut configurer les paramètres pour cette application de service de recherche uniquement.

    • Administrateurs de fonctionnalités Un administrateur de fonctionnalité est associé à une fonctionnalité ou plusieurs fonctionnalités spécifiques d'une application de service. Ces administrateurs peuvent gérer un sous-ensemble des paramètres d'application de service, mais pas la totalité de l'application de service. Par exemple, un administrateur de fonctionnalité peut gérer la fonctionnalité Audiences de l'application de service Profil utilisateur.

  • Niveau de site

    • Administrateurs de la collection de sites Ces administrateurs disposent du niveau d'autorisation Contrôle total sur tous les sites Web au sein d'une collection de sites. Ils ont accès au contenu de tous les sites de cette collection de sites, même s'ils ne disposent pas d'autorisations explicites sur ce site.

    • Propriétaires de site Par défaut, les membres du groupe Propriétaires pour un site disposent du niveau d'autorisation Contrôle total sur ce site. Ils peuvent effectuer des tâches administratives pour le site et pour n'importe quelle liste ou bibliothèque au sein de ce site. Ils reçoivent des notifications par messagerie au sujet d'événements, tels que la suppression automatique en attente de sites inactifs et les demandes d'accès au site.

Historique des modifications

Date | Description | Raison
2010/12/13 | 2010/12/13 | Mise à jour du contenu


Meilleures pratiques pour l'utilisation des permissions affinées (livre blanc) (SharePoint Foundation 2010)

Ce livre blanc décrit les meilleures pratiques pour les permissions affinées et indique comment les utiliser dans votre organisation lors de l'implémentation de Microsoft SharePoint Foundation 2010.

Téléchargez le livre blanc à partir du lien suivant : http://go.microsoft.com/fwlink/?linkid=201596&clcid=0x40C (éventuellement en anglais)

Historique des modifications

Date | Description | Raison
16 septembre 2010 | Publication initiale |


Planification de solutions en mode bac à sable (SharePoint Foundation 2010)

Les solutions en mode bac à sable limitent l'accès aux ressources réseau et locales afin de fournir une sécurité et une stabilité plus importante. Vous pouvez utiliser les solutions en mode bac à sable pour des solutions d'équilibrage de charge, des solutions qui n'ont pas été complètement testées, ainsi que pour le déploiement de solutions utilisateur dans un environnement hébergé. Les solutions en mode bac à sable s'exécutent dans un thread de travail distinct de sorte qu'elles ne puissent pas accéder aux ressources qui appartiennent à d'autres solutions ; en outre, elles disposent d'un accès limité aux ressources locales et réseau.

Dans cette section

  • Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010)

  • Planification des solutions en bac à sable (SharePoint Foundation 2010)

Historique des modifications


Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010)
Voir aussi

Vous pouvez déployer une solution Microsoft SharePoint Foundation 2010 directement sur votre batterie de serveurs SharePoint Foundation, ou dans un bac à sable. Un bac à sable est un environnement d'exécution restreint qui permet aux programmes d'accéder à certaines ressources uniquement et qui empêche les problèmes se produisant dans le bac à sable d'affecter le reste de l'environnement du serveur.

Les solutions que vous déployez dans un bac à sable, appelées solutions en mode bac à sable, ne peuvent pas utiliser certaines ressources d'ordinateurs ou réseau, ni accéder au contenu en dehors de la collection de sites sur laquelle elles sont déployées. Pour plus d'informations à propos des restrictions sur les solutions en bac à sable, voir Contenu non autorisé pour une solution en bac à sable.

Étant donné que les solutions en mode bac à sable ne peuvent pas affecter la batterie de serveurs entière, leur déploiement ne nécessite pas un administrateur de batterie de serveurs. Les solutions en mode bac à sable peuvent être déployées par un administrateur de collection de sites ou, dans certaines cas, par un utilisateur qui dispose du contrôle total sur la racine de la collection de sites. Seul un administrateur de batterie de serveurs peut promouvoir une solution en bac à sable afin qu'elle s'exécute directement sur la batterie de serveurs, en dehors de son bac à sable.

Les solutions en mode bac à sable sont particulièrement appropriées dans deux scénarios :

  • Lorsqu'une organisation souhaite exécuter du code destiné aux employés sur un site SharePoint Foundation de production et que ce code n'a pas été révisé et testé de façon stricte.

  • Lorsqu'un hébergeur souhaite laisser les propriétaires de sites SharePoint Foundation hébergés télécharger et exécuter du code personnalisé.

Cet article introduit les concepts liés aux solutions en mode bac à sable, explique les différences entre les solutions en bac à sable et celles qui sont déployées sur la batterie de serveurs et résume comment les solutions en mode bac à sable sont déployées et exécutées. Cet article ne contient pas de procédures détaillées pour configurer la mise en bac à sable ou pour déployer des solutions en mode bac à sable.

Dans cet article :

  • Déploiement et exécution d'une solution en mode bac à sable

  • Isolation des solutions en bac à sable

  • Contenu non autorisé pour une solution en bac à sable

  • Comparaison entre solution en bac à sable et solution de batterie de serveurs

  • Avantages des solutions en mode bac à sable

Déploiement et exécution d'une solution en mode bac à sable

N'importe quelle page d'une application SharePoint Foundation peut contenir des composants qui s'exécutent dans un bac à sable parallèlement aux composants qui s'exécutent directement sur la batterie de serveurs. Les composants qui sont déployés sur la batterie de serveurs s'exécutent dans le processus de travail IIS (Internet Information Services). Les composants qui sont déployés dans le bac à sable s'exécutent dans un processus en bac à sable.

La liste suivante identifie plusieurs des composants que vous pouvez déployer dans un bac à sable :

  • Composants WebPart

  • Récepteurs d'événements

  • Récepteurs de fonctionnalité

  • Activités de flux de travail Microsoft SharePoint Designer personnalisé

  • Logique métier Microsoft InfoPath

Les étapes suivantes décrivent comment déployer une solution en mode bac à sable :

  1. Un administrateur de batterie de serveurs exécute les tâches suivantes, qui doivent être effectuées une seule fois.

    • Un administrateur de batterie de serveurs active la mise en bac à sable et démarre le service de mise en bac à sable sur chaque serveur qui exécutera des solutions en mode bac à sable.

    • Un administrateur de batterie de serveurs détermine quel schéma d'équilibrage de charge utiliser. Ce schéma s'applique à toutes les solutions en bac à sable dans toutes les collections de sites sur la batterie de serveurs.

    • Un administrateur de batterie de serveurs définit les quotas de ressources à ne pas dépasser pour la combinaison de toutes les solutions en bac à sable dans une collection de sites.

  2. Un administrateur de collection de sites ou un utilisateur qui dispose du contrôle total sur la racine de la collection de sites télécharge une solution dans la galerie de solutions de la collection de sites.

  3. Un administrateur de collection de sites active la solution. Si la solution ne contient pas d'assembly, un utilisateur qui dispose du contrôle total sur la racine de la collection de sites peut également activer la solution. Des outils de validation s'exécutent sur la solution. Si la validation échoue, la solution n'est pas activée.

Lorsqu'une demande d'exécution d'une solution en mode bac à sable est traitée, les activités suivantes se produisent :

  1. Selon le schéma d'équilibrage de charge, SharePoint Foundation détermine sur quel serveur exécuter la solution. Si l'équilibrage de charge est local, la solution s'exécute sur le serveur qui traite la demande. Si l'équilibrage de charge est distant, le serveur qui exécute la solution est choisi en fonction de l'affinité de solution. Dans les deux cas, le serveur doit exécuter le service de mise en bac à sable.

  2. SharePoint Foundation sélectionne un processus de travail de bac à sable dans lequel exécuter la solution, charge une bibliothèque de liaison dynamique (dll) « shim » dans le processus, puis charge l'assembly de la solution dans le processus.

  3. Lors de l'exécution de la solution, son code passe par la bibliothèque shim avant d'être exécuté par SharePoint Foundation. Si le code de la solution essaie d'utiliser des API que les solutions en mode bac à sable ne sont pas autorisées à utiliser, la bibliothèque shim signale une exception au lieu de laisser le code passer et s'exécuter.

  4. SharePoint Foundation surveille les ressources utilisées par les solutions en bac à sable. Si la solution en bac à sable dépasse une limite absolue (par exemple, si elle utilise davantage de temps processeur que la quantité prédéfinie), SharePoint Foundation termine le processus de travail de bac à sable. Si la combinaison de toutes les solutions en bac à sable dans la collection de sites dépasse le quota de ressources de la collection de sites, SharePoint Foundation désactive toutes les solutions en bac à sable dans la collection de sites pour le reste de la journée.

  5. Un administrateur de collection de sites peut surveiller les ressources utilisées par les solutions en bac à sable et désactiver des solutions dans la collection de sites.

Si nécessaire, un administrateur de batterie de serveurs peut bloquer l'exécution d'une solution sur la batterie de serveurs. Éventuellement, un administrateur de batterie de serveurs peut également supprimer l'exigence d'exécuter en bac à sable une solution. Si l'exigence d'exécution en bac à sable est supprimée, lorsque la solution est exécutée sur n'importe quelle collection de sites dans la batterie de serveurs, son exécution n'est plus effectuée en bac à sable.

Isolation des solutions en bac à sable

Vous pouvez isoler les solutions en bac à sable à des degrés divers. Chaque niveau supplémentaire d'isolation augmente votre capacité à protéger la partie principale de votre site SharePoint Foundation du code qui pourrait consommer trop de ressources. Au premier niveau, le code en bac à sable s'exécute dans un processus isolé aux droits restreints. La sécurité d'accès au code (CAS) limite les opérations que le code peut effectuer. Vous pouvez renforcer l'isolation à l'aide de l'équilibrage de charge à distance et en exécutant le service de mise en bac à sable sur des serveurs spécifiques uniquement. Dans un environnement de production, nous vous recommandons d'utiliser l'équilibrage de charge à distance et de dédier un serveur distinct pour l'exécution des solutions en bac à sable.

Contenu non autorisé pour une solution en bac à sable

Une solution SharePoint Foundation doit contenir le fichier de configuration nommé manifest.xml et peut également contenir des fichiers de configuration supplémentaires et des assemblys. Si la solution s'exécute dans un bac à sable, l'assembly et les fichiers de configuration sont limités quant à leur contenu.

La liste suivante répertorie les opérations les plus courantes qu'un assembly qui s'exécute dans un bac à sable ne peut pas faire.

  • Se connecter aux ressources qui ne se trouvent pas sur le serveur local.

  • Accéder à une base de données.

  • Modifier le modèle de threading.

  • Appeler du code non managé.

  • Écrire sur disque.

  • Accéder aux ressources dans une autre collection de sites.

Le fichier manifest.xml fait référence aux fichiers de composant fonctionnel, lesquels font référence aux fichiers d'éléments, lesquels contiennent des éléments feature. Les seuls éléments feature autorisés dans une solution en bac à sable sont :

  • ContentType

  • Field

  • CustomAction

  • Module

  • ListInstance

  • ListTemplate

  • Receivers

  • WebTemplate

  • WorkflowAssociation

  • PropertyBag

  • WorkflowActions

Comparaison entre solution en bac à sable et solution de batterie de serveurs

Le tableau suivant dresse un comparatif entre les solutions qui s'exécutent dans une batterie de serveurs et celles qui s'exécutent dans un bac à sable.

Aspect | Batterie de serveurs | Bac à sable
Processus de déploiement | Ajouter la solution, puis la déployer sur la batterie de serveurs. | Télécharger la solution sur une collection de sites, puis l'activer dans la collection de sites.
Qui peut déployer | Administrateur de batterie | Si la solution contient un assembly, seul un administrateur de collection de sites peut la déployer. Si elle ne contient pas d'assembly, un utilisateur qui dispose du contrôle total sur la racine de la collection de sites peut la déployer.
Accès aux données | Non restreint | La solution peut accéder uniquement au contenu de la collection de sites sur laquelle elle a été déployée.
Processus dans lequel la solution s'exécute | Processus de travail IIS non restreint ou processus dans lequel la solution est déployée. | Processus de travail distinct ayant des droits restreints.
Sécurité d'accès au code | Les développeurs de solutions peuvent définir la stratégie de sécurité d'accès au code lors de l'empaquetage de la solution. | Restreinte. Pour plus d'informations, voir Déploiement d'une solution en mode bac à sable (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=177369&clcid=0x40C).
Surveillance | Non contrôlée | Contrôlée et limitée par les quotas définis par l'administrateur de batterie de serveurs.
Équilibrage de charge | Varie en fonction du type de solution. | Configurable séparément des solutions qui ne sont pas en bac à sable.
Fonctionnalité de la solution | Non restreinte | Limitée, comme décrit dans la section Contenu non autorisé pour une solution en bac à sable.

Avantages des solutions en mode bac à sable

Les principaux avantages des solutions en mode bac à sable sont notamment :

  • Ces solutions peuvent être ajoutées à un environnement SharePoint Foundation de production sans risque d'affecter les processus à l'extérieur du bac à sable.

  • Les administrateurs de collection de sites peuvent déployer des solutions en mode bac à sable, libérant ainsi les administrateurs de batterie de serveurs de cette tâche.

  • L'évolutivité et la flexibilité sont améliorées car le mode bac à sable s'exécute dans un processus distinct qui peut être limité par des quotas et dont l'effet sur la batterie de serveurs peut être surveillé.

  • Aucune modification ou recompilation n'est requise si la solution est transférée du bac à sable pour s'exécuter directement sur la batterie de serveurs.

Voir aussi

Concepts

Planification de solutions en mode bac à sable (SharePoint Foundation 2010)

Autres ressources

Administration de solutions en mode bac à sable (SharePoint Foundation 2010)
Architecture des solutions en mode bac à sable (http://go.microsoft.com/fwlink/?linkid=177368&clcid=0x40C) (éventuellement en anglais)
Déploiement d'une solution en mode bac à sable (http://go.microsoft.com/fwlink/?linkid=177369&clcid=0x40C) (éventuellement en anglais)

Historique des modifications


Planification des solutions en bac à sable (SharePoint Foundation 2010)

Les solutions en bac à sable restreignent l'accès aux ressources réseau et locales, ce qui renforce la sécurité et la stabilité. Vous pouvez utiliser des solutions en bac à sable pour équilibrer la charge des solutions, pour des solutions qui n'ont pas été entièrement testées et pour déployer des solutions utilisateur dans un environnement hébergé. Étant donné que les solutions en bac à sable s'exécutent dans un thread de travail spécifique, elles ne peuvent pas accéder aux ressources appartenant aux autres solutions et elles disposent d'un accès limité aux ressources locales et réseau.

Lorsque vous envisagez des solutions en bac à sable, déterminez avant tout si leur utilisation est opportune. Vous devez déterminer si votre critère principal est la performance ou la sécurité. Une batterie de serveurs qui utilise des solutions en bac à sable génère davantage de processus de travail et de proxy qu'une batterie de serveurs qui n'en utilise pas. Le recours à des solutions en bac à sable facilite l'isolation des processus, ce qui renforce la sécurité de votre batterie de serveurs.

Pour plus d'informations sur les solutions en bac à sable, voir Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010).

Dans cet article :

  • Déterminer quand utiliser des solutions en bac à sable

  • Envisager d'équilibrer la charge du code des solutions en bac à sable

  • Déterminer où déployer les solutions en bac à sable

  • Déterminer qui peut déployer les solutions en bac à sable

  • Déterminer les collections de sites qui exécuteront les solutions en bac à sable

  • Planifier l'utilisation des quotas pour les solutions en bac à sable

  • Planifier la gouvernance des solutions en bac à sable

Déterminer quand utiliser des solutions en bac à sable

L'utilisation de solutions en bac à sable est appropriée dans les scénarios où vous souhaitez répartir la charge des solutions sur plusieurs serveurs ou rendre possible l'exécution d'un code qui n'a pas été entièrement testé ou que votre organisation ne prend pas en charge. Les solutions en bac à sable peuvent, dans le cadre d'un processus de déploiement adapté, jouer un rôle précieux pour les développeurs au sein de votre organisation, de leur environnement de test à une solution en bac à sable dans l'environnement de production. Les solutions en bac à sable peuvent ultérieurement se voir attribuer le statut de confiance totale par un administrateur de batterie qui les juge sûres pour un déploiement complet.

Il est particulièrement approprié d'utiliser les solutions en bac à sable dans les scénarios suivants :

  • Lorsque vous souhaitez répartir la charge des solutions sur plusieurs serveurs SharePoint Foundation.

  • Lorsqu'une organisation souhaite exécuter du code pour les employés sur un site SharePoint Foundation de production et que ce code n'a pas été rigoureusement révisé et testé.

  • Lorsqu'un fournisseur d'hébergement Internet souhaite que les propriétaires de sites SharePoint Foundation hébergés puissent télécharger et exécuter du code personnalisé.

Lorsque vous utilisez des solutions en bac à sable, vous devez activer le service d'exécution de code utilisateur sur l'ordinateur hôte SharePoint 2010 sur chaque serveur sur lequel vous souhaitez exécuter ces solutions.

Envisager d'équilibrer la charge du code des solutions en bac à sable

Vous disposez de deux schémas d'équilibrage de charge pour les solutions en bac à sable. Suivant le schéma d'équilibrage de charge, Microsoft SharePoint Foundation 2010 détermine le serveur sur lequel exécuter la solution. Dans le cas de l'équilibrage de charge local, la solution s'exécute sur le serveur qui a reçu la demande. Si vous optez pour l'équilibrage de charge distant, le serveur sur lequel s'exécute la solution est sélectionné en fonction de critères d'affinité avec celle-ci et la solution en bac à sable est exécutée sur un serveur sur lequel elle est déjà chargée et sur lequel elle a déjà été exécutée. Cette option permet de traiter plus rapidement la demande liée à la solution. Dans les deux cas, chaque serveur doit exécuter le service de code en mode bac à sable SharePoint Foundation.

Le choix du type d'équilibrage de charge que vous opérez détermine le modèle utilisé par la totalité de la batterie de serveurs SharePoint Foundation. Vous ne pouvez pas utiliser une combinaison d'équilibrage de charge local et distant, mais, au contraire, vous devez choisir d'implémenter l'un ou l'autre type d'équilibrage. Lorsque vous choisissez le mode à implémenter, tenez compte des éléments suivants :

  • Le mode local requiert moins d'administration, mais son évolutivité est limitée par les ressources du serveur local.

  • Le mode distant est plus évolutif que le mode local, mais il suppose l'exécution de tâches d'administration sur davantage de serveurs.

Le modèle d'équilibrage de charge distant offre de meilleures performances dans le cadre d'une batterie de serveurs SharePoint Foundation disposant de plusieurs serveurs pour l'exécution des solutions en bac à sable. Si vous utilisez des solutions en bac à sable dans le cadre d'un processus de développement et que vous souhaitez les limiter au serveur à partir duquel elles sont appelées, utilisez le mode d'équilibrage de charge local.

Pour plus d'informations, voir Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010).

Déterminer où déployer les solutions en bac à sable

Les solutions en bac à sable sont déployées à la racine d'une collection de sites. Tout administrateur de collection de sites peut déployer une solution en bac à sable. Lorsqu'elle est déployée dans une collection de sites, la solution en bac à sable peut être utilisée n'importe où dans cette collection de sites.

Vous pouvez choisir d'exécuter les solutions en bac à sable sur des serveurs spécifiques de votre batterie SharePoint Foundation ou sur tous les serveurs. Pour activer des solutions en bac à sable sur un serveur, vous devez activer le service de code en mode bac à sable SharePoint Foundation. Ce service doit être activé sur chaque serveur sur lequel vous souhaitez exécuter des solutions en bac à sable.

Déterminer qui peut déployer les solutions en bac à sable

Lorsque vous planifiez les rôles d'utilisateur impliqués dans le déploiement des solutions en bac à sable, vous devez déterminer qui sera autorisé à déployer les solutions et qui sera autorisé à les administrer. Les membres du groupe d'administrateurs de collections de sites peuvent déployer des solutions en bac à sable.

Vous devez être membre du groupe d'administrateurs de batterie pour effectuer les tâches d'administration telles que l'activation ou la désactivation du service de code en mode bac à sable SharePoint Foundation, le blocage ou le déblocage d'une solution et l'ajustement ou la redéfinition de quotas.

Remarque :
Il ne suffit pas d'être propriétaire de collection de sites ; pour déployer et activer une solution en bac à sable, vous devez être administrateur de collection de sites pour la collection de sites dans laquelle vous déployez la solution en bac à sable.

Étant donné que les administrateurs de batterie peuvent convertir les solutions en bac à sable en solutions entièrement fiables pouvant être déployées n'importe où dans la batterie de serveurs, vous devez veiller à limiter l'appartenance au groupe d'administrateurs de batterie aux utilisateurs appropriés. Vous devez agir avec la même prudence pour ajouter des utilisateurs au groupe d'administrateurs de collections de sites si la sécurité des solutions en bac à sable en cours de déploiement est en jeu.

Déterminer les collections de sites qui exécuteront des solutions en bac à sable à l'aide de quotas

Vous pouvez activer ou désactiver les solutions en bac à sable sur des collections de sites spécifiques en ajustant leurs quotas. Si vous définissez le quota des solutions en bac à sable sur 0 sur une collection de sites spécifique, les solutions en bac à sable ne s'exécuteront pas sur cette collection de sites. Ainsi, vous pouvez affiner l'utilisation des solutions en bac à sable dans votre batterie de serveurs.

Pour déterminer où déployer les solutions en bac à sable, vous devez définir les serveurs qui exécuteront le service de code en mode bac à sable SharePoint Foundation, ainsi que les collections de sites qui pourront exécuter les solutions en bac à sable. Si vous activez les solutions en bac à sable sur certaines collections de sites, vous devez les désactiver sur les autres collections de sites en définissant sur celles-ci les quotas sur 0.

Planifier l'utilisation des quotas pour les solutions en mode bac à sable

L'utilisation des ressources par les solutions en bac à sable fait l'objet d'une surveillance basée sur les quotas de ressources par défaut. Si une solution en bac à sable dépasse l'un des quotas de ressources, elle est désactivée pour le reste de la journée ou jusqu'à ce qu'un administrateur de batterie la réinitialise manuellement. Ainsi, les administrateurs peuvent déterminer qu'une solution en bac à sable particulière sollicite de façon excessive les ressources partagées ou, dans certains cas, qu'il est nécessaire d'accroître le quota associé à une solution en bac à sable gourmande en ressources.

Les quotas par défaut conviennent pour la plupart des scénarios ; toutefois, vous pouvez augmenter une limite de quota spécifique dans les situations appropriées.

Si vous constatez qu'une solution en bac à sable fait systématiquement un mauvais usage des ressources serveur, vous pouvez la bloquer jusqu'à ce que le développeur puisse corriger la situation. Pour plus d'informations sur le blocage et le déblocage des solutions en bac à sable, voir Bloquer ou débloquer une solution en mode bac à sable (SharePoint Foundation 2010).

Les valeurs par défaut affectées aux quotas des solutions en bac à sable sont répertoriées dans le tableau suivant.

Ressource | Description | Unités | Ressources par point | Limite absolue
AbnormalProcessTerminationCount | Processus anormalement terminé | occurrence | 1 | 1
CPUExecutionTime | Temps d'exécution de l'UC pour le site | secondes | 3 600 | 60
CriticalExceptionCount | Événements d'exception critiques | événements | 10 | 3
InvocationCount | Événements d'appel de solution | événements | <TBD> | <TBD>
PercentProcessorTime | Pourcentage d'utilisation d'UC par solution | pourcentage | 85 | 100
ProcessCPUCycles | Cycles de processeur de solution | cycles | 1 x10^11 | 1 x10^11
ProcessHandleCount | Nombre de handles Windows | éléments | 10 000 | 1 000
ProcessIOBytes | Nombre de handles Windows | éléments | 0 | 1 x10^8
ProcessThreadCount | Nombre de threads dans le processus global | instances | 10 000 | 200
ProcessVirtualBytes | Mémoire consommée | octets | 0 | 1.0x10^9
SharePointDatabaseQueryCount | Nombre de requêtes de base de données SharePoint | instances | 20 | 100
SharePointDatabaseQueryTime | Temps écoulé pour exécuter la requête | secondes | 120 | 60
UnhandledExceptionCount | Nombre d'exceptions non gérées | instances | 50 | 3
UnresponsiveProcessCount | Nombre de processus qui ne répondent pas | instances | 2 | 1

Planifier la gouvernance des solutions en bac à sable

Pendant la phase de planification des solutions en bac à sable, vous devez vous pencher sur les processus à mettre à œuvre pour les questions liées à la gouvernance, notamment les suivantes :

  • À quel stade l'administrateur de batterie bloquera-t-il ou débloquera-t-il une solution en bac à sable ? L'identification de la stratégie d'administration pour le blocage et le déblocage des solutions en bac à sable permettra d'éliminer toute confusion en cas de doute sur la nécessité de bloquer une solution.

  • À quel stade transférerez-vous une solution en bac à sable vers le catalogue global en tant que solution entièrement approuvée ? Cette décision s'applique au code de solution élaboré par les développeurs de votre organisation. Vous devez établir une stratégie permettant de déterminer le niveau de test requis pour qu'une solution en bac à sable soit considérée comme pouvant être utilisée dans l'environnement de production de votre organisation.

  • Lorsque vous déterminerez les personnes habilitées à déployer des solutions en bac à sable, les ajouterez-vous au groupe des administrateurs de collections de sites ou établirez-vous une procédure permettant à un nombre limité d'administrateurs de collections de sites de déployer les solutions en bac à sable au nom de leurs utilisateurs ? Suivant les contraintes liées à la sécurité au sein de votre organisation, vous pouvez décider d'ajouter des personnes directement au groupe des administrateurs de collections de sites plutôt que de les obliger à demander l'autorisation de déployer la solution en bac à sable.

Historique des modifications

Date | Description | Raison
2011/02/07 | 2011/02/07 | Mise à jour du contenu


Planification des sites de collaboration (SharePoint Foundation 2010)

Microsoft SharePoint Foundation 2010 permet de prendre en charge des sites de collaboration dans votre environnement. Les sites de collaboration stockent des informations que des personnes ou des groupes peuvent créer, partager et réviser ensemble. Il n'est pas nécessaire que ces sites soient associés à une collection de sites portail particulière ou fassent partie d'une collection de sites de publication. Il peut s'agir de sites autonomes, à la disposition des équipes ou des groupes d'utilisateurs qui ont besoin de collaborer sur des projets ou de partager des informations. Par exemple, une équipe d'un cabinet d'études peut souhaiter recourir à un site de collaboration pour discuter de l'état actuel d'un projet, affecter des tâches ou organiser des déjeuners de travail, sans publier ces informations internes dans l'intranet de l'entreprise.

Les sites de collaboration peuvent être mis à disposition pour la recherche à partir de votre site portail ou de publication afin que les informations de ces sites ne soient pas perdues pour votre organisation. Toutefois, pour simplifier la récupération et la gestion des données, les sites de collaboration doivent être hébergés sur une application Web distincte ou dans des bases de données de contenu distinctes dans la même application Web que votre site portail ou de publication.

Vous pouvez créer ces sites de collaboration pour vos utilisateurs ou les autoriser à créer leurs propres sites.

Pour plus d'informations sur les sites de collaboration et la planification architecturale, voir Conception de l'exemple d'architecture logique : sites de collaboration.

Dans cet article :

  • Déterminer le nombre de sites de collaboration

  • Chemins d'accès spécifiques

  • Chemins d'accès supplémentaires

Déterminer le nombre de sites de collaboration

Estimez le nombre approximatif de sites de collaboration que devrait compter votre environnement et combien de ces sites vous êtes disposé à prendre en charge. Si vous imposez aux utilisateurs de demander un site de collaboration, vous pouvez contrôler le nombre de sites créés. Si vous laissez les utilisateurs créer leurs propres sites de collaboration, votre environnement comportera un nombre élevé de ces sites.

Chemins d'accès spécifiques

Vous pouvez utiliser des chemins d'accès spécifiques dans Microsoft SharePoint Foundation 2010 pour contenir les collections de sites SharePoint, de la même manière que les dossiers contiennent des fichiers ou des documents dans le système de fichiers. Par défaut, lorsque vous créez une application Web, deux chemins d'accès sont disponibles :

  • Chemin d'accès racine (/) Ceci est une inclusion explicite pouvant contenir une collection de sites. Par exemple, si vous souhaitez qu'une URL apparaisse sous la forme http://nom_société/default.aspx, vous créez la collection de sites à ce chemin d'accès racine.

  • Chemin d'accès de sites (/sites) Ceci est un chemin d'accès général pouvant contenir plusieurs collections de sites. Par exemple, lorsque vous utilisez le chemin d'accès /sites, l'URL d'un site nommée Site_A est similaire à http://nom_serveur/sites/Site_A/default.aspx.

    Remarque :
    Le nom du chemin d'accès /sites varie en fonction de la langue qui a été utilisée lors de l'installation.

Chemins d'accès supplémentaires

Vous pouvez également créer des chemins d'accès supplémentaires. Cela vous permet de regrouper des collections de sites. Ensuite, lorsque vous créez une collection de sites, vous avez le choix entre les options suivantes :

  • créer la collection de sites à la racine de l'application Web (à condition qu'aucune collection de sites n'y ait déjà été créée) ;

  • créer la collection de sites sous le chemin d'accès /sites ;

  • créer la collection de sites sous des chemins d'accès supplémentaires qui ont été mis à la disposition de cette application Web.

En règle générale, le chemin d'accès /sites doit être suffisant pour la plupart des installations. Toutefois, envisagez d'utiliser d'autres chemins d'accès dans les cas suivants :

  • Votre installation est complexe, vous comptez détenir de nombreuses collections de sites et vous souhaitez regrouper les sites similaires.

    Par exemple, vous pouvez utiliser le chemin d'accès /personal pour les sites d'utilisateur individuels et /team pour les sites de collaboration, au lieu d'utiliser /sites pour tous les sites.

  • Vous souhaitez pouvoir ajouter un filtre à votre pare-feu ou votre routeur pour limiter un espace de noms spécifique à l'accès interne uniquement.

    Par exemple, vous pouvez exposer le chemin d'accès /team pour la collaboration d'équipe, mais par le chemin d'accès /personal.

Intégration à Microsoft SharePoint Workspace 2010

Microsoft SharePoint Workspace 2010 fournit un client enrichi pour Microsoft SharePoint Foundation 2010, ce qui permet une synchronisation en temps réel du contenu du bureau avec les documents et listes SharePoint. En outre, Microsoft SharePoint Workspace 2010 offre des options qui permettent de créer des espaces de travail de dossiers partagés et des espaces de travail de collaboration Groove ad hoc. Les informations peuvent être facilement synchronisées en ligne et en mode hors connexion avec un site SharePoint désigné ou avec des partenaires externes et des membres d'équipe hors site via des espaces de travail partagés. Microsoft SharePoint Workspace 2010 est automatiquement installé avec les versions d'entreprise de Microsoft Office 2010 ou peut être installé séparément à partir du Centre de téléchargement Microsoft (http://go.microsoft.com/fwlink/?linkid=48516&clcid=0x40C).

Pour plus d'informations, voir Plan for SharePoint Workspace 2010.

Historique des modifications


Planification de la gestion des documents (SharePoint Foundation 2010)

Ces articles vous guident dans les fonctionnalités de gestion de documents de votre solution basée sur Microsoft SharePoint Foundation 2010.

Les articles de cette section sont les suivants :

  • Planification de bibliothèque de documents (SharePoint Foundation 2010)

    Cet article explique comment utiliser des bibliothèques de documents pour organiser les documents dans votre entreprise.

  • Planification de types de contenu (SharePoint Foundation 2010)

    Cet article explique comment planifier des types de contenu, qui constituent les mécanismes de SharePoint Foundation 2010 pour définir et partager les attributs des documents, des éléments de listes et des dossiers.

  • Planification de contrôle de version, d'approbation de contenu et d'extraction (SharePoint Foundation 2010)

    Cet article explique comment planifier la gestion de contenu à l'aide du contrôle de version, de l'archivage et de l'extraction, et de l'approbation de la publication de contenu.

  • Vue d'ensemble de la co-création (SharePoint Foundation 2010) décrit la fonctionnalité et explique aux administrateurs quels sont les paramètres qui peuvent être utilisés pour gérer la co-création.

Historique des modifications


Planification de bibliothèque de documents (SharePoint Foundation 2010)

Cet article explique comment planifier des bibliothèques de documents et intégrer des bibliothèques dans votre solution de gestion de documents Microsoft SharePoint Foundation 2010.

Les bibliothèques de documents sont des collections de fichiers sous SharePoint Foundation 2010 que vous partagez avec d'autres utilisateurs du site. La plupart des fonctionnalités de gestion de documents sont fournies par le biais des bibliothèques de documents. Dans le cadre de la planification de la gestion de documents, vous devez déterminer le type des bibliothèques de documents qui correspondent le mieux aux besoins de votre organisation.

Planifier les bibliothèques de documents

Les bibliothèques de documents sont des collections de fichiers sous SharePoint Foundation 2010 que vous partagez avec d'autres utilisateurs du site. La plupart des fonctionnalités de gestion de documents de SharePoint Foundation 2010 sont fournies par le biais des bibliothèques de documents. Dans le cadre de la planification de la gestion de documents, vous devez déterminer les bibliothèques de documents qui correspondent le mieux aux besoins de votre organisation.

SharePoint Foundation 2010 comprend les types de bibliothèques de documents suivants :

  • Bibliothèque de documents Utilisez une bibliothèque de documents pour stocker des documents généraux, collaborer sur des documents et faciliter le partage de documents.

  • Bibliothèque d'images Utilisez une bibliothèque d'images pour partager, gérer et réutiliser des images numériques.

Utilisez des bibliothèques de documents pour stocker le contenu sur lequel votre groupe de travail collabore et pour créer des bases de connaissances partagées. Par exemple, un groupe de travail qui conçoit des produits peut utiliser une bibliothèque de documents pour stocker ses travaux actuels, par exemple des propositions de conception, des spécifications et des informations de support technique. Grâce aux métadonnées affichées sous forme de colonnes d'informations, il est possible de gérer et de rendre public l'état de chaque document de conception, ainsi que l'auteur de chaque document, le nom du projet, etc. Les documents terminés peuvent être stockés séparément dans une bibliothèque de documents de bases de connaissances dans laquelle il sera possible d'effectuer une recherche et qui servira de source d'informations lors de la recherche de nouveaux projets.

Dans SharePoint Foundation 2010, les bibliothèques de documents peuvent contenir plusieurs types de documents. Pour y parvenir, associez un ou plusieurs types de contenu à la bibliothèque de documents. Lorsque plusieurs types de contenu sont associés à une bibliothèque, la commande Nouveau de cette bibliothèque permet aux utilisateurs de créer des documents en fonction d'un des types de contenu associés à la bibliothèque ; par ailleurs, les métadonnées de tous les types de contenu que la bibliothèque peut comporter seront affichées dans les vues des bibliothèques de documents. Pour plus d'informations sur la planification des types de contenu, voir Planification de types de contenu (SharePoint Foundation 2010).

Les autres fonctionnalités de bibliothèque de documents qui prennent en charge la collaboration sont les suivantes :

  • Modèles Vous pouvez concevoir un modèle et l'associer à une bibliothèque de documents pour normaliser les documents créés dans la bibliothèque.

  • Flux de travail À l'aide d'un flux de travail personnalisé (voir Planifier les flux de travail (SharePoint Foundation 2010)), les processus d'entreprise peuvent s'exécuter sur des documents. Par exemple, un flux de travail peut envoyer un document pour révision.

  • Archivage et extraction Vous pouvez exiger que les utilisateurs archivent et extraient les documents d'une bibliothèque de documents avant de les modifier.

  • Gestion des versions Vous avez le choix parmi trois options de gestion des versions.

Historique des modifications


Planification de types de contenu (SharePoint Foundation 2010)

Cet article décrit les types de contenu et les flux de travail et fournit des conseils sur la planification de leur intégration à votre solution de gestion de documents Microsoft SharePoint Foundation 2010.

Planifier les types de contenu

Dans cette section :

  • Description des types de contenu

  • Modèles de colonnes

  • Types de contenu de dossier

Description des types de contenu

Un type de contenu définit les attributs d'un élément de liste, d'un document ou d'un dossier. Chaque type de contenu peut spécifier :

  • des propriétés à associer aux éléments de même type ;

  • des flux de travail qui peuvent être lancés à partir des éléments de son type ;

  • des modèles de documents (pour les types de contenu de document) ;

  • des conversions de document en vue de les mettre à la disposition des utilisateurs (pour les types de contenu de document) ;

  • des fonctionnalités personnalisées.

Vous pouvez associer un type de contenu à une liste ou une bibliothèque. Lorsque vous procédez ainsi, vous indiquez que la liste ou la bibliothèque peut contenir des éléments de ce type de contenu et que la commande Nouveau dans cette liste ou cette bibliothèque permettra aux utilisateurs de créer des éléments de ce type.

Remarque :
Vous pouvez également associer des propriétés, des flux de travail, des stratégies et des modèles directement à une liste ou une bibliothèque. Toutefois, cette opération peut limiter les associations à la liste ou à la bibliothèque et n'est pas réutilisable dans votre solution. Dans SharePoint Foundation 2010, les flux de travail de niveau site peuvent être associés à plusieurs listes ou bibliothèques.

Les bibliothèques de documents et les listes peuvent contenir plusieurs types de contenu. Par exemple, une bibliothèque peut contenir des documents et des graphiques associés à un projet. Lorsqu'une liste ou une bibliothèque contient plusieurs types de contenu, les points suivants s'appliquent :

  • Par défaut, la commande Nouveau dans cette liste ou bibliothèque permet aux utilisateurs d'effectuer une sélection parmi tous les types de contenu disponibles lorsqu'ils créent un élément. Les propriétaires de type de contenu peuvent configurer la commande Nouveau de manière à afficher uniquement certains types de contenu.

  • Les colonnes associées à tous les types de contenu disponibles sont affichées.

Les types de contenu personnalisés se définissent dans la galerie de types de contenu d'un site. Un type de contenu personnalisé doit être dérivé, directement ou indirectement, d'un type de contenu de base tel que Document ou Élément. Après avoir été défini dans un site, un type de contenu personnalisé est disponible dans ce site et tous les sites de niveau inférieur. Pour rendre un type de contenu plus largement accessible dans une collection de sites, définissez-le dans la galerie de types de contenu du site de niveau supérieur.

Par exemple, si votre organisation utilise un modèle de contrat particulier, dans la galerie des types de contenu du site de niveau supérieur dans une collection de sites, vous pouvez créer un type de contenu qui définit les métadonnées pour ce contrat, le modèle du contrat et les flux de travail nécessaires à l'examen et à la réalisation du contrat. Ensuite, n'importe quelle bibliothèque de documents dans votre collection de sites à laquelle vous associez le type de contenu Contrat comprendra toutes ces fonctionnalités et permettra aux auteurs de créer de nouveaux contrats basés sur le modèle.

Dans des sites basés sur SharePoint Foundation 2010, chaque élément de liste ou de bibliothèque par défaut, tel que Contact, Tâche ou Document, possède un type de contenu correspondant dans la galerie des types de contenu du site. Lorsque vous planifiez les types de contenu, vous pouvez utiliser ces définitions de types de contenu prêtes à l'emploi comme points de départ, en basant les nouveaux types de contenu sur des types existants en fonction de vos besoins ou en modifiant les types par défaut.

Les types de contenu sont organisés selon une hiérarchie qui permet à un type de contenu d'hériter ses caractéristiques d'un autre type de contenu. Ainsi, une même classe de documents peut avoir les mêmes caractéristiques partout dans l'organisation, chaque service étant ensuite libre de personnaliser ces caractéristiques selon la spécificité du site ou de la liste.

Par exemple, tous les documents des éléments livrables aux clients dans une entreprise peuvent exiger un ensemble de métadonnées telles que le numéro de compte, le numéro de projet et le responsable de projet. En créant un type de contenu de niveau supérieur Élément livrable au client, dont tous les autres types de documents d'éléments livrables aux clients tirent leurs caractéristiques, vous avez la garantie que les informations requises, telles que les numéros de compte et les numéros de projet, seront associées à toutes les variantes de documents d'éléments livrables aux clients dans votre organisation. Notez que si une autre colonne requise est ajoutée au type de contenu de niveau supérieur Élément livrable au client, le propriétaire du type de contenu peut propager les modifications vers tous les types de contenu qui héritent de celui-ci, ce qui se traduira par l'ajout de la nouvelle colonne à tous les documents d'éléments livrables aux clients.

Modèles de colonnes

Chaque élément de métadonnées associé à un type de contenu constitue une colonne, qui est un emplacement dans une liste destiné au stockage d'informations. Les listes ou les bibliothèques sont souvent affichées sous forme graphique en tant que colonnes d'informations. Toutefois, en fonction de l'affichage associé à la liste, les colonnes peuvent apparaître différemment, par exemple sous la forme de jours dans un affichage de type calendrier. Dans les formulaires associés à une liste ou à une bibliothèque, les colonnes sont affichées en tant que champs.

Vous pouvez définir des colonnes à utiliser dans plusieurs types de contenu. Pour ce faire, vous devez les créer dans une galerie de modèles de colonnes. Il existe une galerie de modèles de colonnes dans chaque site d'une collection de sites. Comme dans le cas des types de contenu, les colonnes définies dans la galerie de modèles de colonnes d'un site sont disponibles dans ce site et dans tous les sites sous ce dernier.

Types de contenu de dossier

Les types de contenu de dossier définissent les métadonnées associées à un dossier dans une liste ou bibliothèque. Lorsque vous appliquez un type de contenu de dossier à une liste ou bibliothèque, la commande Nouveau dans cette liste ou bibliothèque inclut le type de contenu de dossier, ce qui permet aux utilisateurs de créer des dossiers de ce type.

Vous pouvez définir, dans une liste ou bibliothèque, des affichages disponibles uniquement dans les dossiers d'un type de contenu particulier. Cela est utile lorsque vous souhaitez qu'un dossier contienne un type particulier de document et que les affichages dans ce dossier ne présentent que les colonnes qui sont pertinentes pour le type de document contenu dans ce dossier.

À l'aide du modèle objet SharePoint Foundation 2010, vous pouvez personnaliser la commande Nouveau pour un type de contenu de dossier de sorte que, lorsqu'un utilisateur crée un dossier de ce type, le dossier comporte déjà plusieurs fichiers et documents basés sur les modèles stockés sur le serveur. Cela est utile, par exemple, pour implémenter un type de document composé qui nécessite l'exploitation de plusieurs fichiers pour l'élaboration d'un document d'élément livrable unique.

Historique des modifications


Planification de contrôle de version, d'approbation de contenu et d'extraction (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment planifier l'utilisation du contrôle de version, de l'approbation du contenu et de l'extraction dans Microsoft SharePoint Foundation 2010 pour contrôler les versions des documents dans leur cycle de vie.

Dans cet article :

  • À propos du contrôle de version, de l'approbation de contenu et des extractions

  • Planifier le contrôle de version

  • Planifier l'approbation de contenu

  • Planifier l'extraction et l'archivage

À propos du contrôle de version, de l'approbation de contenu et des extractions

SharePoint Foundation 2010 inclut les fonctionnalités suivantes pouvant vous aider à contrôler les documents dans une bibliothèque de documents :

  • Le contrôle de version est la méthode qui permet de numéroter et d'enregistrer les nouvelles versions successives d'un document.

  • L'approbation du contenu est la méthode qu'utilisent les membres de sites ayant des autorisations d'approbateur pour contrôler la publication du contenu.

  • L'extraction et l'archivage sont des méthodes permettant aux utilisateurs de mieux contrôler à quel moment une nouvelle version d'un document est créée et d'inclure des commentaires sur les modifications qui ont été apportées lors de l'archivage d'un document.

Vous configurez les paramètres des fonctionnalités de contrôle de contenu décrites dans cet article dans les bibliothèques de documents. Pour partager ces paramètres dans l'ensemble des bibliothèques de votre solution, vous pouvez créer des modèles de bibliothèques de documents comprenant vos paramètres de contrôle de contenu ; ainsi, les nouvelles bibliothèques reflèteront les décisions que vous prenez en matière de contrôle de contenu.

Planifier le contrôle de version

Le contrôle de version d'une bibliothèque de documents dépend du modèle de la collection de sites. Cependant, vous pouvez configurer le contrôle de version d'une bibliothèque de documents en fonction de vos besoins particuliers. Chaque bibliothèque de documents peut avoir un contrôle de version différents adapté aux types de documents qu'elle contient. SharePoint Foundation 2010 a trois options de contrôle de version :

  • Aucun contrôle de version Indique qu'aucune version précédente du document n'est enregistrée. Lorsqu'aucun contrôle de version n'est utilisé, les versions précédentes des documents ne sont pas récupérables, et l'historique des documents n'est pas conservé car les commentaires qui accompagnent chaque itération d'un document ne sont pas enregistrés. Utilisez cette option pour les bibliothèques de documents dont le contenu est sans importance ou ne change jamais.

  • Créer des versions principales Spécifie que des versions numérotées des documents sont conservées en utilisant un schéma de contrôle de version simple (tel que 1, 2, 3). Pour contrôler l'impact sur l'espace de stockage, vous pouvez spécifier combien de versions précédentes il convient de conserver, en remontant à partir de la version actuelle.

    Dans cette option de contrôle de version, chaque fois qu'une nouvelle version d'un document est enregistrée, tous les utilisateurs disposant d'autorisations sur la bibliothèque de documents peuvent afficher son contenu. Utilisez cette option si vous n'avez pas besoin de distinguer les versions temporaires des versions publiées des documents. Par exemple, dans une bibliothèque de documents utilisée par un groupe de travail d'une organisation, la gestion des versions principales est un choix approprié si tous les membres de l'équipe doivent pouvoir afficher toutes les nouvelles versions de chaque document.

  • Créer des versions principales et secondaires (brouillon) Spécifie que les versions numérotées des documents sont conservées en utilisant un schéma de gestion des versions principales et secondaires (tel que 1.0, 1.1, 1.2, 2.0, 2.1). Les versions se terminant par .0 sont des versions principales et les autres sont des versions secondaires. Les versions principales et secondaires précédentes des documents sont enregistrées avec les versions actuelles. Pour contrôler l'impact sur l'espace de stockage, vous pouvez spécifier le nombre de versions principales précédentes à conserver, en incluant la version actuelle. Vous pouvez également indiquer combien de versions principales conservées doivent inclure leurs versions secondaires respectives. Par exemple, si vous spécifiez que les versions secondaires doivent être conservées pour deux versions principales et que la version principale en cours est 4.0, toutes les versions secondaires à partir de 3.1 seront conservées.

    Dans la gestion des versions principales et secondaires, tous les utilisateurs disposant d'une autorisation de lecture peuvent afficher les versions principales des documents. Vous pouvez indiquer les utilisateurs qui sont autorisés à afficher les versions secondaires. En règle générale, accordez aux utilisateurs qui peuvent modifier des éléments l'autorisation d'afficher et de travailler avec les versions secondaires, et limitez les utilisateurs disposant d'une autorisation de lecture à l'affichage des versions principales.

    Utilisez la gestion des versions principales et secondaires si vous avez besoin de faire la différence entre un contenu publié qui peut être affiché par un public et un contenu temporaire qui n'est pas encore prêt pour la publication. Par exemple, dans un site Web de ressources humaines décrivant les avantages de l'organisation, utilisez la gestion des versions principales et secondaires pour interdire l'accès des employés aux descriptions des avantages lorsque les descriptions sont en cours de révision.

Remarque :
Quel que soit le contrôle de version que vous choisissez, vous devez prendre en compte l'impact qu'aura la conservation de plusieurs versions du même document sur l'espace de stockage.

Planifier l'approbation de contenu

Utilisez l'approbation de contenu pour formaliser et contrôler le processus de mise à disposition de contenu à un public. Par exemple, une entreprise qui publie du contenu comme l'un de ses produits ou services peut exiger un contrôle juridique et une approbation avant la publication du contenu. La publication du contenu peut également être programmée en fonction de l'état du document.

Un brouillon de document en attente d'approbation est dans l'état En attente. Lorsqu'un approbateur examine le document pour approuver son contenu, il devient disponible pour être affiché par les utilisateurs du site disposant de l'autorisation de lecture. Un propriétaire de bibliothèque de documents peut activer l'approbation de contenu pour une bibliothèque de documents et éventuellement associer un flux de travail à la bibliothèque pour exécuter le processus d'approbation.

La manière dont les documents sont soumis à approbation varie en fonction des paramètres de contrôle de version dans la bibliothèque de documents :

  • Aucun contrôle de version Si aucun contrôle de versions n'est utilisé et si les modifications apportées à un document sont enregistrées, l'état du document passe à En attente. SharePoint Foundation 2010 conserve la version antérieure du document, de sorte que les utilisateurs disposant de l'autorisation de lecture peuvent continuer à l'afficher. Une fois les modifications en attente approuvées, la nouvelle version du document est mise à la disposition des utilisateurs disposant de l'autorisation de lecture pour l'affichage, et la version antérieure n'est pas conservée.

    Si aucun contrôle de version n'est utilisé et qu'un nouveau document est téléchargé dans la bibliothèque de documents, celui-ci est ajouté à la bibliothèque dans l'état En attente et il ne peut pas être affiché par les utilisateurs disposant de l'autorisation de lecture tant qu'il n'a pas été approuvé.

  • Créer des versions principales Si le contrôle de version est utilisé et que les modifications apportées à un document sont enregistrées, l'état du document passe à En attente et la version principale précédente du document est mise à la disposition des utilisateurs possédant l'autorisation de lecture pour l'affichage. Une fois les modifications du document approuvées, une nouvelle version principale du document est mise à la disposition des utilisateurs du site ayant l'autorisation de lecture, et la version précédente est enregistrée dans la liste de l'historique du document.

    Si la gestion des versions principales est utilisée et un nouveau document est téléchargé dans la bibliothèque de documents, celui-ci est ajouté à la bibliothèque dans l'état En attente et il ne peut pas être affiché par les utilisateurs disposant de l'autorisation de lecture tant qu'il n'a pas été approuvé en tant que version 1.

  • Créer des versions principales et secondaires (brouillon) Si la gestion des versions principales et secondaires est utilisée et les modifications apportées à un document sont enregistrées, l'auteur a la possibilité d'enregistrer une nouvelle version secondaire du document en tant que brouillon ou de créer une nouvelle version principale, auquel cas l'état du document passe à En attente. Une fois les modifications du document approuvées, une nouvelle version principale du document est créée et mise à la disposition des utilisateurs du site disposant de l'autorisation de lecture. Dans la gestion des versions principales et secondaires, les versions principales comme secondaires des documents sont conservées dans la liste de l'historique du document.

    Si la gestion des versions principales et secondaires est utilisée et qu'un nouveau document est téléchargé dans la bibliothèque de documents, celui-ci peut être ajouté à la bibliothèque dans l'état Brouillon en tant que version 0.1, ou l'auteur peut immédiatement demander son approbation, auquel cas l'état du document passe à En attente.

Planifier l'extraction et l'archivage

Vous pouvez exiger que les utilisateurs extraient les documents d'une bibliothèque de documents avant de les modifier. Cette pratique est recommandée. L'impératif d'extraction et d'archivage offre notamment les avantages suivants :

  • Amélioration du contrôle de la date de création des versions de documents. Lors de l'extraction d'un document l'auteur peut enregistrer le document sans l'archiver. Les autres utilisateurs de la bibliothèque de documents ne pourront pas voir ces modifications et aucune nouvelle version ne sera créée. Une nouvelle version (visible par les autres utilisateurs) est uniquement créée si l'auteur archive le document. Cela lui procure davantage de souplesse et de contrôle.

  • Amélioration de la capture des métadonnées. Lors de l'archivage d'un document, l'auteur peut écrire des commentaires décrivant les modifications qui ont été apportées au document. Ceci facilite la création d'un enregistrement historique permanent des modifications effectuées dans le document.

Si votre solution impose que les utilisateurs archivent et extraient les documents lorsqu'ils les modifient, les applications clientes de Microsoft Office 2010 incluent des fonctionnalités qui prennent en charge ces actions. Les utilisateurs peuvent extraire des documents, annuler des extractions et archiver des documents dans les applications clientes de Office 2010.

Lorsqu'un document est extrait, il est enregistré dans le dossier Mes documents de l'utilisateur, dans un sous-dossier nommé « Brouillons SharePoint ». Ce dossier s'affiche dans Office 2010. Tant que le document est extrait, l'utilisateur peut uniquement enregistrer les modifications dans ce dossier local. Lorsque l'utilisateur est prêt à archiver le document, le document est enregistré à l'emplacement serveur d'origine.

À partir des applications clientes de Office 2010, les utilisateurs peuvent également choisir de laisser les documents extraits sur le serveur en modifiant les options d'édition de contenu.

Voir aussi

Concepts

Planification de bibliothèque de documents (SharePoint Foundation 2010)

Historique des modifications


Vue d'ensemble de la co-création (SharePoint Foundation 2010)
Voir aussi

Dans les environnements de travail modernes basés sur le travail en réseau, les documents créés par plusieurs auteurs, éditeurs et parties prenantes deviennent la règle et non plus l'exception. Les entreprises exploitent les fonctions de communication et de collaboration de Microsoft SharePoint Foundation 2010 pour favoriser la communication et la collaboration entre les utilisateurs, mais aussi pour réduire le travail d'administration lié à la communication et à la collaboration. Microsoft Office 2010 poursuit sur cette voie en proposant une fonctionnalité de co-création des documents Microsoft PowerPoint 2010, Microsoft Word 2010 et Microsoft OneNote 2010 sur SharePoint Foundation 2010.

La co-création facilite la collaboration sur des documents stockés sur serveur et permet aux entreprises de réduire la charge de traitement des processus classiques de partage des documents par échange de pièces jointes. La co-création simplifie la collaboration en permettant à plusieurs utilisateurs de travailler de façon productive sur le même document sans empiéter sur le travail d'un autre utilisateur ni verrouiller les autres utilisateurs. Cette fonctionnalité ne nécessite aucune configuration supplémentaire au niveau du serveur et est mise en œuvre par défaut pour les documents stockés dans SharePoint Foundation 2010. La fonctionnalité de co-création est gérée par le biais des mêmes outils et technologies que ceux utilisés pour gérer SharePoint Foundation, ce qui contribue à réduire la charge de travail imposée aux administrateurs.

Dans cet article :

  • Fonctionnalité de co-création dans SharePoint Foundation 2010

  • Présentation de l'expérience de l'utilisateur final

  • Remarques importantes

  • Blocs-notes OneNote

  • Versions de logiciels requises

  • Co-création dans un environnement Office mixte

  • Performances et évolutivité

Fonctionnalité de co-création dans SharePoint Foundation 2010

Traditionnellement, la collaboration s'effectue par échange de documents sous forme de pièces jointes aux courriers électroniques. Le suivi des versions et des modifications réalisées par plusieurs auteurs est difficile et fastidieux pour les utilisateurs. En outre, les systèmes de messagerie doivent stocker plusieurs copies du même document et le trafic réseau lié à l'envoi répété des documents est particulièrement élevé.

L'utilisation de SharePoint Foundation pour le stockage de documents à des fins de collaboration a permis de réduire ces problèmes en fournissant un accès permanent aux versions mises à jour des documents, en offrant la possibilité de suivre les versions précédentes et en centralisant la gestion des documents. Le fait de ne stocker qu'un seul document, là où plusieurs pièces jointes devaient auparavant être stockées, réduit également les coûts liés au réseau et au stockage.

Cependant, cette solution n'est pas parfaite. Lorsqu'un auteur a ouvert un document, les autres auteurs ne peuvent pas travailler sur ce document. Si quelqu'un oublie de fermer un document ou de l'archiver, les autres utilisateurs risquent d'être exclus indéfiniment et cette situation nécessite bien souvent d'appeler le service informatique pour résoudre le problème.

La co-création dans SharePoint Foundation 2010 résout cette problématique en permettant à plusieurs utilisateurs de travailler à tout moment sur un document sans interférer avec les modifications des autres utilisateurs. Cette approche rationalise de nombreux scénarios courants de collaboration sur des documents. Exemples :

  • Au moins deux auteurs travaillent sur différentes sections d'un document composite. Pendant qu'un auteur travaille sur sa section du document, un autre auteur peut travailler sur sa section sans que ni l'un ni l'autre n'ait à interrompre leur travail.

  • Plusieurs auteurs travaillent sur un diaporama composite. Chaque auteur peut ajouter des diapositives à la présentation et les modifier, plutôt que de travailler de son côté et d'essayer de fusionner plusieurs documents en tentant de respecter une certaine cohérence.

  • Un document est transmis à plusieurs experts et parties prenantes et chacun d'entre eux apporte quelques modifications ou ajoute des informations. Aucune modification n'est perdue, car tous les utilisateurs travaillent sur un document central stocké sur serveur.

Présentation de l'expérience de l'utilisateur final

Pour les utilisateurs finaux, la co-création est très simple d'utilisation. Lorsqu'un utilisateur souhaite travailler sur un document dans Word 2010, PowerPoint 2010 ou OneNote 2010, il lui suffit de l'ouvrir à partir de SharePoint Foundation, comme il le fait habituellement. Si un autre utilisateur a déjà ouvert le document, les deux utilisateurs sont en mesure de modifier simultanément ; l'accès au document n'est pas bloqué et aucune erreur ne s'affiche.

Dans Word 2010 et PowerPoint 2010, le fait d'enregistrer un document signale aux autres utilisateurs affichant le document que de nouvelles modifications ont été réalisées. Ces utilisateurs peuvent actualiser immédiatement l'affichage pour voir ces modifications ou poursuivre leur travail et actualiser le document ultérieurement pour voir les modifications. Les auteurs peuvent également voir le travail des autres auteurs et tous les utilisateurs savent à chaque instant qui travaille sur le document. Les outils de contrôle de version et de suivi de SharePoint Foundation 2010 protègent le document pour permettre aux auteurs d'annuler les modifications indésirables. Si un serveur Office Communications Server est disponible, les utilisateurs peuvent voir le statut de connexion des autres co-auteurs et lancer des conversations par messagerie instantanée sans quitter le document.

Avec OneNote 2010, les blocs-notes partagés permettent aux utilisateurs de partager des notes en toute transparence. Lorsqu'un utilisateur modifie une page du bloc-notes, ces modifications sont automatiquement synchronisées avec les autres utilisateurs de ce bloc-notes, de sorte que chacun d'entre eux dispose de toutes les notes. Les modifications réalisées par plusieurs utilisateurs sur la même page s'affichent automatiquement et permettent une collaboration en temps réel ou presque. Le contrôle de version et les autres fonctions partagées dans OneNote permettent aux utilisateurs d'annuler des modifications, d'afficher les modifications récentes et de déterminer qui a réalisé telle ou telle modification.

L'application cliente Excel 2010 ne prend pas en charge la co-création de classeurs dans SharePoint Foundation 2010. En revanche, l'application cliente Excel prend en charge la co-création en différé de classeurs stockés localement ou dans des chemins d'accès réseau (UNC), par le biais de la fonction Classeur partagé. La co-création de classeurs dans SharePoint Foundation est prise en charge par le biais de Microsoft Excel Web App, qui est fourni avec Office Web Apps. Office Web Apps est disponible pour les utilisateurs par le biais de Windows Live et pour les clients professionnels disposant de solutions de licence en volume et de gestion de documents Microsoft Office 2010 basées sur les Produits Microsoft SharePoint 2010. Pour plus d'informations, voir Office Web Apps (Installed on SharePoint 2010 Products).

Remarques importantes

Les administrateurs doivent prendre en compte plusieurs paramètres lors de la planification de l'utilisation de la co-création dans leur environnement.

La fonctionnalité de co-création de SharePoint Foundation est conçue pour faciliter la configuration et limiter le travail de gestion. Vous devez cependant prendre en compte les remarques suivantes lorsque vous configurez et gérez la co-création :

  • Autorisations : pour pouvoir éditer le même document, les utilisateurs doivent disposer d'autorisations de modification pour la bibliothèque de documents dans laquelle le document est stocké. Pour ce faire, la solution la plus simple consiste à accorder à tous les utilisateurs un accès au site SharePoint dans lequel tous les documents sont stockés. Dans les cas où seul un sous-ensemble d'utilisateurs doit avoir l'autorisation de procéder à la co-création de documents dans une bibliothèque spécifique, les autorisations SharePoint peuvent être utilisées pour gérer l'accès.

  • Contrôle de version : le contrôle de version de SharePoint Foundation assure le suivi des modifications apportées aux documents lorsqu'ils sont édités et stocke les versions précédentes à des fins de référence. Par défaut, cette fonction est désactivée dans SharePoint Foundation 2010. SharePoint Foundation 2010 prend en charge deux types de contrôle de version : le contrôle de version principale et le contrôle de version mineure. Il est recommandé de ne pas activer le contrôle de version mineure pour les bibliothèques de documents utilisées pour la co-création dans OneNote, car cela risque d'interférer avec les fonctions de synchronisation et de contrôle de version intégrées au produit. Cette limitation s'applique uniquement au contrôle de version mineure : le contrôle de version principale peut être utilisé avec OneNote.

  • Nombre de versions : le nombre de versions de documents conservées influe sur les besoins en stockage au niveau du serveur. Ce nombre peut être défini dans les paramètres de la bibliothèque de documents, afin de limiter le nombre de versions conservées. Les blocs-notes OneNote qui sont fréquemment mis à jour peuvent conduire au stockage de nombreuses versions sur le serveur. Pour éviter d'occuper inutilement de l'espace disque, nous conseillons aux administrateurs d'affecter une valeur raisonnable au nombre maximal de versions conservées pour les bibliothèques de documents utilisées pour stocker des blocs-notes OneNote.

  • Période de contrôle de version : la période de contrôle de version détermine à quelle fréquence SharePoint Foundation crée une nouvelle version d'un document Word ou PowerPoint faisant l'objet d'une co-création. Plus la valeur de la période est faible, plus la fréquence d'enregistrement des versions est courte. Si cela permet un suivi plus détaillé, en contrepartie, l'espace occupé sur le serveur peut être plus important. La période de contrôle de version n'a pas d'incidence sur les blocs-notes OneNote. Cette valeur peut-être modifiée en configurant la propriété coAuthoringVersionPeriod sur le serveur. Pour plus d'informations sur le réglage de ce paramètre, voir Configurer la période du contrôle de version pendant la co-création (SharePoint Foundation 2010).

  • Extraction : lorsqu'un utilisateur extrait un document afin de le modifier, cette opération verrouille le document de sorte que seul cet utilisateur puisse le modifier, ce qui empêche la co-création. L'option Exiger l'extraction ne doit pas être activée dans les bibliothèques de documents dans lesquelles la co-création est utilisée. Par défaut, l'option Exiger l'extraction n'est pas activée dans SharePoint Foundation 2010. Les utilisateurs ne doivent pas extraire manuellement des documents lorsque la co-création est utilisée.

Blocs-notes OneNote

Contrairement à Microsoft Word et Microsoft PowerPoint, Microsoft OneNote stocke les informations de version dans le fichier proprement dit. Pour cette raison, les administrateurs doivent respecter les recommandations suivantes lors du stockage de blocs-notes OneNote dans une bibliothèque de documents SharePoint Foundation :

  • N'activez pas le contrôle de version mineure. Par défaut, le contrôle de version mineure n'est pas activé dans SharePoint Foundation 2010.

  • Si le contrôle de version principale est activé, spécifiez un nombre raisonnable de versions à stocker. Par défaut, le contrôle de version principale n'est pas activé dans SharePoint Foundation 2010.

Versions de logiciels requises

Pour que les utilisateurs puissent procéder à la co-création de documents à l'aide d'Office 2010, ces documents doivent être stockés dans SharePoint Server 2010 ou SharePoint Foundation 2010. Pour exploiter au mieux la fonctionnalité de co-création, les utilisateurs doivent disposer de Word 2010, PowerPoint 2010 ou OneNote 2010.

Remarque :
La fonctionnalité de co-création dans Office 2010 peut également être utilisée dans SharePoint Server 2010 ou SharePoint Foundation 2010 si les utilisateurs possèdent des comptes Windows Live SkyDrive. L'utilisation de la co-création sans SharePoint Server 2010 ou SharePoint Foundation 2010 n'est pas traitée dans cet article.

Co-création dans un environnement Office mixte

Certaines entreprises souhaitent utiliser la co-création dans un environnement dans lequel les utilisateurs disposent de différentes versions d'Office.

Environnement mixte comprenant Microsoft Office PowerPoint et Word 2007

Les utilisateurs de versions antérieures de PowerPoint et Word peuvent partager et modifier des documents stockés dans SharePoint Foundation 2010 exactement comme dans les versions précédentes de SharePoint Foundation. En revanche, ils ne peuvent pas utiliser la co-création pour travailler simultanément sur ces documents. Pour exploiter au mieux la collaboration dans PowerPoint et Word, nous recommandons à tous les utilisateurs d'utiliser Office 2010. Les utilisateurs d'Office PowerPoint et de Word 2007 ne constateront aucune différence significative entre le fonctionnement actuel et le fonctionnement dans Office 2010. Par exemple, si des utilisateurs d'Office 2007 ouvrent un document stocké dans Office 2010 qui est en cours d'édition par un autre utilisateur, un message s'affiche pour leur signaler que le document est en cours d'utilisation et qu'ils ne peuvent pas le modifier. Si aucun autre utilisateur ne modifie le document, les utilisateurs d'Office 2007 peuvent l'ouvrir normalement. Lorsqu'un utilisateur d'Office 2007 ouvre un document, celui-ci est verrouillé pour empêcher les utilisateurs d'Office 2010 de recourir à la co-création pour modifier le document. Ce comportement correspond à celui des versions antérieures de SharePoint Foundation.

Environnement mixte comprenant Microsoft Office OneNote 2007

OneNote 2010 offre une compatibilité descendante avec le format de fichier Office OneNote 2007 et prend en charge la co-création avec les utilisateurs de OneNote 2007. Dans les environnements mixtes, les blocs-notes doivent être enregistrés au format de fichier OneNote 2007, de sorte que les utilisateurs de OneNote 2007 et de OneNote 2010 puissent travailler ensemble sur les blocs-notes. Toutefois, en effectuant la mise à niveau vers le format de fichier OneNote 2010, les utilisateurs peuvent accéder à plusieurs fonctionnalités importantes telles que la compatibilité avec Microsoft OneNote Web App, qui permet aux utilisateurs n'ayant pas installé OneNote de modifier et de co-créer des blocs-notes.

OneNote 2010 offre la possibilité de mettre à niveau les fichiers OneNote 2007 vers OneNote 2010 à tout moment, afin de faciliter la mise à niveau pour les entreprises passant d'un environnement mixte à un environnement unifié sur Office 2010.

Performances et évolutivité

Les applications SharePoint Foundation 2010 et Office 2010 ont été conçues pour limiter l'incidence de la co-création sur les performances et l'évolutivité de votre environnement. Les clients Office n'envoient pas d'informations de co-création vers le serveur et ne téléchargent pas d'informations vers le serveur si un seul auteur modifie le document. Lorsqu'un seul utilisateur modifie un document, l'incidence sur les performances est identique à celle constatée dans les versions précédentes de SharePoint Foundation.

Les clients Office sont configurés de façon à limiter l'incidence sur le serveur, en réduisant la fréquence des opérations de synchronisation liées à la co-création lorsque le serveur est soumis à une charge importante ou lorsqu'un utilisateur ne modifie pas de façon active le document, ce qui contribue à réduire l'incidence sur les performances globales.

Voir aussi

Concepts

Administration de la co-création (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Planification de données métier et de processus (SharePoint Foundation)

Les rubriques de cette section vous aideront à planifier et créer des solutions qui intègrent des processus d'entreprise au niveau des données de l'organisation.

Dans cette section :

  • Planifier Business Connectivity Services (SharePoint Foundation 2010)

  • Planifier les flux de travail (SharePoint Foundation 2010)

Historique des modifications


Planifier Business Connectivity Services (SharePoint Foundation 2010)

Cette section décrit comment planifier Business Connectivity Services au sein d'un environnement Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Vue d'ensemble de Business Connectivity Services (SharePoint Foundation 2010)

  • Vue d'ensemble de la sécurité de Business Connectivity Services (SharePoint Foundation 2010)

  • Journalisation des diagnostics dans la vue d'ensemble de services Business Connectivity (SharePoint Foundation 2010)

Historique des modifications


Vue d'ensemble de Business Connectivity Services (SharePoint Foundation 2010)

Microsoft SharePoint Foundation 2010 comprend les Services Microsoft Business Connectivity, un ensemble de services et de fonctions qui fournissent un moyen de connecter les solutions SharePoint aux sources de données externes et de définir les types de contenus externes qui sont basés sur ces données externes. Les types de contenus externes ressemblent aux types de contenus et permettent la présentation de données externes et l'interaction avec ces données externes dans des listes SharePoint (qualifiées de listes externes) et de composants WebPart. Les systèmes externes auxquels les Services Microsoft Business Connectivity peuvent se connecter comprennent les bases de données SQL Server, les applications SAP, les services Web (y compris les services Windows Workflow Foundation), les applications personnalisées et les sites Web basés sur SharePoint. Avec les Services Microsoft Business Connectivity, vous pouvez concevoir et construire des solutions qui étendent les capacités de collaboration SharePoint de sorte d'inclure des données métiers externes ainsi que les processus associés à ces données.

Les solutions Services Microsoft Business Connectivity utilisent un jeu d'interfaces standardisées pour donner accès aux données métiers. En conséquence, les développeurs de solutions n'ont pas besoin d'apprendre des méthodes de programmation s'appliquant à un système ou à un adaptateur particulier pour chaque source de données externe. Les Services Microsoft Business Connectivity fournissent également l'environnement d'exécution dans lequel les solutions qui incluent les données externes sont chargées, intégrées et exécutées.

Solutions types reposant sur Business Connectivity Services

Les travailleurs de l'information effectuent l'essentiel de leur travail en dehors des processus formels d'un système d'entreprise. Par exemple, ils collaborent par téléphone ou courrier électronique, utilisent des documents et des feuilles de calcul provenant de diverses sources, et alternent entre travail en ligne ou hors connexion. Les solutions reposant sur les Services Microsoft Business Connectivity peuvent être conçues pour s'insérer dans ces processus informels que les travailleurs de l'information utilisent :

  • Elles peuvent être construites par combinaison de plusieurs services et fonctions à partir de systèmes de données externes afin de développer des solutions qui visent des rôles spécifiques.

  • Elles prennent en charge les interactions informelles et ciblent les activités et les processus qui se produisent pour la plupart en dehors des systèmes d'entreprise formels. Dans la mesure où elles reposent sur l'utilisation des produits SharePoint 2010, les solutions reposant sur les Services Microsoft Business Connectivity favorisent la collaboration.

  • Elles aident les utilisateurs à effectuer des tâches dans l'environnement d'utilisation familier des produits SharePoint 2010.

Ci-dessous quelques exemples de solutions reposant sur les Services Microsoft Business Connectivity :

  • Service d'assistance Une entreprise met en place son service d'assistance, qui procure une assistance technique interne, en tant que solution basée sur les Services Microsoft Business Connectivity. Les demandes d'assistance et la base de connaissance du service d'assistance technique sont stockées dans des bases de données externes et intégrées dans la solution à l'aide de service Connexion de données métiers. La solution affiche à la fois les demandes d'assistance et la base de connaissances dans le navigateur Web. Les travailleurs de l'information peuvent ainsi consulter les demandes courantes tout comme les spécialistes du service d'assistance peuvent consulter les demandes qui leur sont assignées. Les flux de travail assurent la transition des problèmes d'assistance d'une étape à la suivante. Les gestionnaires de l'équipe d'assistance technique peuvent consulter les rapports d'assistance dans des tableaux de bord. Ces rapports indiquent généralement le nombre de problèmes d'assistance assignés à chaque spécialiste du service d'assistance, les problèmes les plus critiques actuellement traités ainsi que le nombre d'incidents traités par chaque spécialiste au cours d'une période donnée.

  • Tableau de bord des ventes Une application de tableau de bord des ventes aide les commerciaux d'une organisation à trouver rapidement les informations dont ils ont besoin et à entrer de nouvelles données. Les commandes et les informations sur les clients sont gérées dans une base de données externe et intégrées dans la solution à l'aide des Services Microsoft Business Connectivity. Suivant leurs rôles, les membres d'une équipe peuvent consulter les analyses commerciales, les performances individuelles de chacun, les prospects ainsi que les coordonnées et les commandes des clients. Les employés du service commercial peuvent consulter leur calendrier du jour, découvrir les tâches qui leur sont assignées par leurs responsables, collaborer avec leurs équipiers et lire la presse spécialisée.

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Vue d'ensemble de la sécurité de Business Connectivity Services (SharePoint Foundation 2010)

Cet article décrit l'architecture de sécurité du serveur et du client Services Microsoft Business Connectivity, les environnements de sécurité pris en charge, les modes d'authentification disponibles pour connecter les types de contenu externe aux systèmes externes, les options d'autorisation disponibles sur les objets stockés et les techniques générales pour la configuration de la sécurité des Services Microsoft Business Connectivity.

Dans cet article :

  • À propos de cet article

  • Architecture de sécurité de Business Connectivity Services

  • Vue d'ensemble de l'authentification de Business Connectivity Services

  • Vue d'ensemble des autorisations de Business Connectivity Services

  • Sécurisation de Business Connectivity Services

À propos de cet article

Les Services Microsoft Business Connectivity incluent des fonctionnalités de sécurité permettant l'authentification des utilisateurs pour accéder aux systèmes externes et pour configurer les autorisations sur les données des systèmes externes. Les Services Microsoft Business Connectivity sont hautement flexibles et peuvent gérer une large panoplie de méthodes de sécurité à partir des applications Microsoft Office 2010 prises en charge et du navigateur Web.

Architecture de sécurité de Business Connectivity Services

Cette section décrit l'architecture de sécurité des Services Microsoft Business Connectivity.

Sécurité Remarque :
Nous vous recommandons d'utiliser le protocole SSL (Secure Sockets Layer) sur tous les canaux entre les ordinateurs clients et les serveurs frontaux et d'utiliser le protocole SSL ou la sécurité IPSec (Internet Protocol Security) entre les serveurs Microsoft SharePoint Foundation 2010 et les systèmes externes. Notez toutefois l'exception suivante : vous ne pouvez pas utiliser le protocole SSL lors de la transmission de messages vers des systèmes externes à l'aide du protocole SOAP 1.1 ou lors de la connexion à une base de données SQL Server. Cependant, dans ces cas-là il est possible d'utiliser la sécurité IPSec pour protéger l'échange de données.

Accès aux données externes

Lorsqu'un utilisateur accède aux données externes à partir d'un navigateur Web, trois systèmes sont impliqués : l'ordinateur client de l'utilisateur connecté, la batterie de serveurs Web et le système externe.

Architecture de sécurité BCS d'un navigateur Web
  1. À partir des navigateurs Web, les utilisateurs interagissent généralement avec les données externes dans des listes externes ou en utilisant des composants WebPart.

  2. Le runtime serveur BDC sur les serveurs frontaux utilise le service Connexion de données métiers pour se connecter aux systèmes externes et y exécuter des opérations.

  3. Le service Banque d'informations sécurisé stocke de manière sécurisée les jeux d'informations d'identification pour les systèmes externes et associe ces jeux d'informations d'identification à des identités d'individus ou de groupes.

    Important :
    Le service Banque d'informations sécurisé n'est pas fourni avec SharePoint Foundation 2010. Si vous avez besoin d'un magasin sécurisé dans SharePoint Foundation 2010, vous devez fournir un fournisseur de magasin sécurisé.

  4. Le service d'émission de jeton de sécurité est un service Web qui répond aux demandes d'authentification en émettant des jetons de sécurité composés de revendications d'identité basées sur les informations de comptes d'utilisateur stockées.

  5. Les Services Microsoft Business Connectivity peuvent transmettre les informations d'identification aux bases de données et services Web configurés pour utiliser l'authentification basée sur les revendications. Pour une vue d'ensemble de l'authentification basée sur les revendications, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010).

Vue d'ensemble de l'authentification de Business Connectivity Services

Les Services Microsoft Business Connectivity peuvent être configurés pour transmettre les demandes d'authentification aux systèmes externes en utilisant les types de méthodes suivants :

  • Informations d'identification Il s'agit généralement de la paire nom/mot de passe. Certains systèmes externes peuvent également nécessiter des informations d'identification supplémentaires, par exemple une valeur de code PIN (Personal Identification Number).

  • Revendications Les tickets SAML (Security Assertion Markup Language) peuvent être transmis aux services prenant en charge les revendications qui fournissent les données externes.

Configuration de Business Connectivity Services pour l'authentification des informations d'identification

Les Services Microsoft Business Connectivity peuvent utiliser des informations d'identification qu'un utilisateur fournit pour authentifier des demandes pour des données externes. Les méthodes suivantes permettant aux utilisateurs de fournir des informations d'identification d'accès aux données externes sont prises en charge :

  • Authentification Windows

    • Stimulation/Réponse de Windows (NTLM)

    • Microsoft Negotiate

  • Authentification autre que Windows

    • Basée sur les formulaires

    • Digest

    • De base

Lors de la configuration des Services Microsoft Business Connectivity pour la transmission d'informations d'identification, le concepteur de la solution ajoute des informations sur le mode d'authentification aux types de contenu externe. Le mode d'authentification transmet aux Services Microsoft Business Connectivity des informations sur la façon de traiter une demande d'authentification entrante émanant d'un utilisateur et de mapper cette demande à un jeu d'informations d'identification pouvant être transmises au système de contenu externe. Par exemple, un mode d'authentification peut spécifier la transmission des informations d'identification directement au système de données externe. Sinon, il peut spécifier que les informations d'identification de l'utilisateur soient mappées à un compte stocké dans un service Banque d'informations sécurisé qui doit ensuite être transmis au système externe.

Vous associez un mode d'authentification à un type de contenu externe des façons suivantes :

  • Lorsque vous créez un type de contenu externe dans Microsoft SharePoint Designer.

  • Si le système externe est un service Web, vous pouvez utiliser les pages d'administration des Services Microsoft Business Connectivity pour spécifier le mode d'authentification.

  • Vous pouvez spécifier le mode d'authentification en éditant directement le fichier .XML qui définit le type de contenu externe.

Le tableau suivant décrit les modes d'authentification des Services Microsoft Business Connectivity :

Mode d'authentification Description

PassThrough

Transmet les informations d'identification d'un utilisateur connecté au système externe. Cela nécessite que les informations d'identification de l'utilisateur soient connues du système externe.

Remarque :
Si l'application Web n'est pas configurée pour l'authentification avec des informations d'identification Windows, le compte Autorité NT/Ouverture de session anonyme (plutôt que les informations d'identification de l'utilisateur) est passé au système externe.

Ce mode est appelé Identité de l'utilisateur dans les pages d'administration des Services Microsoft Business Connectivity et dans SharePoint Designer 2010.

RevertToSelf

Lorsque l'utilisateur accède aux données externes à partir d'un navigateur Web, ce mode ignore les informations d'identification de l'utilisateur et envoie le compte d'identité du pool d'applications sous lequel le runtime BCS s'exécute sur le serveur Web au système externe. Lorsque l'utilisateur accède aux données externes à partir d'une application cliente Office, ce mode est l'équivalent du mode relais (PassThrough), car les Services Microsoft Business Connectivity s'exécutant sur le client s'exécutent selon les informations d'identification de l'utilisateur.

Ce mode est appelé Identité BDC dans les pages d'administration des Services Microsoft Business Connectivity et dans SharePoint Designer 2010.

Remarque :
Par défaut, le mode RevertToSelf n'est pas activé. Vous devez utiliser Windows PowerShell pour activer le mode RevertToSelf afin de pouvoir créer ou importer des modèles qui utilisent RevertToSelf. Pour plus d'informations, voir RevertToSelf authentication mode. Le mode RevertToSelf n'est pas pris en charge dans les environnements hébergés.

WindowsCredentials

Pour les bases de données ou les services Web externes, ce mode utilise un service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur à un jeu d'informations d'identification Windows sur le système externe.

Ce mode est appelé Emprunter l'identité Windows dans les pages d'administration des Services Microsoft Business Connectivity et dans SharePoint Designer 2010.

Credentials

Pour un service Web externe, ce mode utilise un service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur à un jeu d'informations d'identification fournies par une source autre que Windows et qui sont utilisées pour accéder aux données externes. Le service Web doit utiliser une authentification de base ou Digest quand ce mode est utilisé.

Important :
Pour mieux préserver la sécurité dans ce mode, nous recommandons que la connexion entre les Services Microsoft Business Connectivity et le système externe soit sécurisée via l'utilisation de SSL (Secure Sockets Layer) ou IPSec (Internet Protocol Security).

Ce mode est appelé Emprunter l'identité personnalisée dans les pages d'administration des Services Microsoft Business Connectivity et dans Office SharePoint Designer.

RDBCredentials

Pour une base de données externe, ce mode utilise un service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur à un jeu d'informations d'identification fournies par une source autre que Windows. Pour mieux préserver la sécurité dans ce mode, nous recommandons que la connexion entre les Services Microsoft Business Connectivity et le système externe soit sécurisée par le protocole SSL ou par la sécurité IPSec.

Ce mode est appelé Emprunter l'identité personnalisée dans les pages d'administration des Services Microsoft Business Connectivity et dans Office SharePoint Designer.

DigestCredentials

Pour un service Web WCF, ce mode utilise un service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur à un ensemble d'informations d'identification à l'aide de l'authentification Digest.

Ce mode est appelé Emprunter l'identité personnalisée - Digest dans les pages d'administration des Services Microsoft Business Connectivity et dans SharePoint Designer 2010.

L'illustration suivante représente les modes d'authentification des Services Microsoft Business Connectivity lors de l'utilisation des informations d'identification.

Authentification des services Business Connectivity
  • En mode PassThrough (Identité de l'utilisateur) (A), les informations d'identification de l'utilisateur connecté sont transmises directement au système externe.

  • En mode RevertToSelf (Identité BDC) (B), les informations d'identification de connexion de l'utilisateur sont remplacées par les informations d'identification du compte de processus sous lequel s'exécutent les Services Microsoft Business Connectivity et ces informations d'identification sont transmises au système externe.

  • Trois modes utilisent le service Banque d'informations sécurisé : WindowsCredentials (Emprunter l'identité Windows), RdbCredentials (Emprunter l'identité personnalisée) et Credentials. Dans ces modes, les informations d'identification de l'utilisateur sont mappées à un jeu d'informations d'identification pour le système externe et les Services Microsoft Business Connectivity transmettent ces informations d'identification au système externe. Les administrateurs de solutions peuvent soit mapper les informations d'identification de chaque utilisateur à un compte unique, soit mapper un jeu d'utilisateurs authentifiés à un compte de groupe unique.

Configuration de Business Connectivity Services pour l'authentification basée sur les revendications

Les Services Microsoft Business Connectivity peuvent fournir l'accès aux données externes sur la base de jetons de sécurité entrants et transmettre les jetons de sécurité à des systèmes externes. Un jeton de sécurité est constitué d'un jeu de revendications d'identité concernant un utilisateur, et l'utilisation de jetons de sécurité pour l'authentification est appelée « authentification basée sur les revendications ». SharePoint Foundation inclut un service d'émission de jeton de sécurité qui émet des jetons de sécurité.

L'illustration suivante montre comment le service d'émission de jeton de sécurité et le service Banque d'informations sécurisé collaborent dans l'authentification basée sur les revendications :

Authentification par revendications dans BCS
  1. Un utilisateur tente une opération sur une liste externe qui est configurée pour l'authentification basée sur les revendications.

  2. L'application cliente demande un jeton de sécurité au service d'émission de jeton de sécurité.

  3. Selon l'identité de l'utilisateur demandeur, le service d'émission de jeton de sécurité émet un jeton de sécurité qui contient un jeu de revendications et un identificateur d'application. Le service d'émission de jeton de sécurité retourne le jeton de sécurité à l'application cliente.

  4. Le client transmet le jeton de sécurité au service Banque d'informations sécurisé.

  5. Le service Banque d'informations sécurisé évalue le jeton de sécurité et utilise l'identificateur de l'application cible pour retourner un jeu d'informations d'identification qui s'appliquent au système externe.

  6. Le client reçoit les informations d'identification et les transmet au système externe de façon qu'une opération (telle que l'extraction ou la mise à jour de données externes) puisse avoir lieu.

Vue d'ensemble des autorisations de Business Connectivity Services

Dans les Services Microsoft Business Connectivity, les autorisations associent un compte individuel, un compte de groupe ou une revendication à un ou plusieurs niveaux d'autorisation sur un objet dans un magasin de métadonnées. En définissant correctement les autorisations sur des objets dans les Services Microsoft Business Connectivity, les solutions sont mieux à même d'incorporer sans risque les données externes. Lors de la planification d'une stratégie d'autorisations, nous vous recommandons d'accorder des autorisations spécifiques à chaque utilisateur ou groupe qui en a besoin, de façon que les informations d'identification fournissent le minimum de privilèges nécessaires pour réaliser les tâches requises.

Attention :
Définir correctement les autorisations dans les Services Microsoft Business Connectivity fait partie d'une stratégie de sécurité globale. Un autre facteur tout aussi important est la sécurisation des données dans les systèmes externes. La façon dont vous procédez dépend du modèle de sécurité et des fonctionnalités du système externe, mais ce sujet dépasse le cadre de cet article.

Remarque :
Les services Business Connectivity Services utilisent les autorisations sur les objets de métadonnées et les autorisations sur le système externe pour déterminer les règles d'autorisation. Par exemple, un découpage de sécurité peut empêcher l'affichage des données externes dans les résultats de recherche des utilisateurs. Toutefois, si les utilisateurs découvrent par un moyen quelconque l'URL des données externes découpées, ils peuvent accéder à ces données s'ils disposent des autorisations suffisantes sur l'objet de métadonnées et sur le système externe. La méthode correcte pour empêcher les utilisateurs d'accéder à des données externes consiste à définir les autorisations appropriées à la fois dans les services Business Connectivity et dans le système externe.

Sur quoi peut-on définir des autorisations ?

Chaque instance du service Connexion de données métiers (ou, dans le cas de l'hébergement, chaque partition) contient un magasin de métadonnées qui inclut tous les modèles, les systèmes externes, les types de contenu externe, les méthodes et les instances de méthodes qui ont été définis pour les besoins de ce magasin. Ces objets existent dans une hiérarchie comme le montre l'illustration suivante :

Hiérarchie du magasin de métadonnées
Remarque :
Dans le graphique hiérarchique précédent, les libellés entre parenthèses correspondent aux noms des objets définis dans le schéma de métadonnées des Services Microsoft Business Connectivity. Les libellés qui ne figurent pas entre parenthèses sont les noms de chaque objet tel qu'il apparaît dans l'interface utilisateur du service Connexion de données métiers. Pour une description complète du schéma de métadonnées des Services Microsoft Business Connectivity, ainsi que des procédures pas à pas de nombreuses tâches de développement, voir le Kit de développement logiciel SDK Microsoft SharePoint 2010 (http://go.microsoft.com/fwlink/?linkid=166117&clcid=0x40C).

La hiérarchie des objets dans un magasin de métadonnées détermine les objets qui peuvent propager leurs autorisations à d'autres objets. Dans l'illustration, chaque objet sur lequel des autorisations peuvent être définis, et le cas échéant propagées, est représenté par une ligne continue ; chaque objet qui prend ses autorisations de son objet parent est illustré avec une ligne discontinue. Par exemple, l'illustration montre qu'il est possible de sécuriser un système externe (LobSystem) en lui affectant des autorisations, mais une action ne peut pas recevoir d'autorisations directement. Les objets auxquels il n'est pas possible d'affecter des autorisations prennent leurs autorisations de leur objet parent. Par exemple, une action prend les autorisations de son type de contenu externe (entité) parent.

Sécurité Remarque :
Quand les autorisations s'appliquant à un objet dans un magasin de métadonnées sont propagées, les paramètres des autorisations pour tous les enfants de cet élément sont remplacés par les autorisations de l'objet propagateur. Par exemple, si des autorisations sont propagées à partir d'un type de contenu externe, toutes les méthodes et les instances de méthodes de ce type de contenu externe reçoivent les nouvelles autorisations.

Il est possible de définir quatre niveaux d'autorisation sur le magasin de métadonnées et les objets qu'il contient :

  • Modifier

    Sécurité Remarque :
    L'autorisation Modifier doit être considérée comme hautement privilégiée. Avec cette autorisation, un utilisateur malveillant peut dérober des informations d'identification ou endommager une batterie de serveurs. Nous vous recommandons, dans un système de production, d'accorder l'autorisation Modifier uniquement aux utilisateurs dont vous savez qu'ils possèdent des autorisations de niveau administrateur.

  • Exécuter

  • Sélectionnable dans les clients

  • Définir les autorisations

Le tableau suivant indique la signification de ces autorisations sur les divers objets pour lesquels elles peuvent être définies.

Objet | Définition | Autorisations de modification | Autorisations d'exécution | Autorisations Sélectionnable dans les clients | Autorisations Définir des autorisations
Magasin de métadonnées | La collection de fichiers XML, stockés dans le service Connexion de données métiers, chacun contenant des définitions de modèles, de types de contenu externe et de systèmes externes. | L'utilisateur peut créer de nouveaux systèmes externes. | En dépit de l'absence d'une autorisation « Exécuter » sur le magasin de métadonnées proprement dit, ce paramètre peut être utilisé pour propager des autorisations d'exécution à des objets enfants dans le magasin de métadonnées. | En dépit de l'absence d'une autorisation « Sélectionnable dans les clients » sur le magasin de métadonnées même, ce paramètre peut être utilisé pour propager des autorisations d'exécution à des objets enfants dans le magasin de métadonnées. | L'utilisateur peut définir des autorisations sur n'importe quel objet du magasin de métadonnées en les propageant à partir du magasin de métadonnées.
Modèle | Un fichier XML qui contient des jeux de descriptions d'un ou plusieurs types de contenu externe, leurs systèmes externes connexes et des informations spécifiques à l'environnement, telles que les propriétés d'authentification. | L'utilisateur peut modifier le fichier de modèle. | L'autorisation « Exécuter » n'est pas applicable aux modèles. | L'autorisation « Sélectionnable dans les clients » n'est pas applicable aux modèles. | L'utilisateur peut définir des autorisations sur le modèle.
Système externe | La définition de métadonnées d'une source de données prise en charge pouvant être modélisée, par exemple une base de données, un service Web ou un assembly de connectivité .NET. | L'utilisateur peut éditer le système externe. Le fait de définir cette autorisation permet de rendre le système externe et toute instance de système externe qu'il contient visibles dans SharePoint Designer. | En dépit de l'absence d'une autorisation « Exécuter » sur un système externe même, ce paramètre peut être utilisé pour propager des autorisations d'exécution à des objets enfants dans le magasin de métadonnées. | En dépit de l'absence d'une autorisation « Sélectionnable dans les clients » sur un système externe même, ce paramètre peut être utilisé pour propager des autorisations d'exécution à des objets enfants dans le magasin de métadonnées. | L'utilisateur peut définir des autorisations sur le système externe.
Type de contenu externe | Collection de métadonnées réutilisable qui définit un jeu de données à partir d'un ou plusieurs systèmes externes, les opérations disponibles sur ces données et les informations de connectivité liées à ces données. | En dépit de l'absence d'une autorisation « Modifier » sur un type de contenu externe même, ce paramètre peut être utilisé pour propager ces autorisations à des objets enfants dans le magasin de métadonnées. | L'utilisateur peut exécuter des opérations sur le type de contenu externe. | L'utilisateur peut créer des listes externes du type de contenu externe. | L'utilisateur peut définir des autorisations sur le type de contenu externe.
Méthode | Une opération liée à un type de contenu externe | L'utilisateur peut modifier la méthode. | En dépit de l'absence d'une autorisation « Exécuter » sur une méthode même, ce paramètre peut être utilisé pour propager des autorisations d'exécution à des objets enfants dans le magasin de métadonnées. | Il n'existe pas d'autorisation « Sélectionnable dans les clients » sur une méthode. | L'utilisateur peut définir des autorisations sur la méthode.
Instance de méthode | Pour une méthode particulière, décrit la façon d'utiliser une méthode en utilisant un jeu spécifique de valeurs par défaut. | L'utilisateur peut modifier l'instance de méthode. | L'utilisateur peut exécuter l'instance de méthode. | Il n'existe pas d'autorisation « Sélectionnable dans les clients » sur une instance de méthode. | L'utilisateur peut définir des autorisations sur l'instance de méthode.

Autorisations spéciales sur le service BDC

Outre les fonctionnalités générales de définition d'autorisations décrites plus haut, il existe un jeu d'autorisations spéciales pour le service Connexion de données métiers :

  • Les administrateurs de batterie ont toutes les autorisations sur le service Connexion de données métiers. Ceci est nécessaire par exemple pour gérer ou réparer une instance du service. Cependant, sachez que l'administrateur de batterie ne possède d'autorisation d'exécution sur aucun objet du magasin de métadonnées et que ce droit doit être accordé explicitement par un administrateur d'une instance du service Connexion de données métiers, si cela est nécessaire.

  • Les utilisateurs de Windows PowerShell sont des administrateurs de batterie et peuvent exécuter des commandes sur le service Connexion de données métiers.

  • Les comptes du pool d'applications sur les serveurs frontaux ont les mêmes autorisations sur le service Connexion de données métiers que les administrateurs de batterie. Cette autorisation est nécessaire pour générer des packages de déploiement basés sur les Services Microsoft Business Connectivity.

  • Les utilisateurs de SharePoint Designer doivent, dans la plupart des cas, recevoir les autorisations suivantes sur l'ensemble du magasin de métadonnées : Modifier, Exécuter et Sélectionnable dans les clients. Les utilisateurs de SharePoint Designer ne doivent pas recevoir les autorisations Définir les autorisations. Au besoin, vous pouvez limiter les autorisations de l'utilisateur de SharePoint Designer à un sous-ensemble du magasin de métadonnées.

    Attention :
    Pour mieux garantir une solution sécurisée, SharePoint Designer doit être utilisé pour créer des types de contenu externe dans un environnement de test dans lequel les autorisations de modification peuvent être accordées librement. Lors du déploiement de la solution testée dans un environnement de production, retirez les autorisations de modification afin de mieux protéger l'intégrité des données externes.

Tâches courantes et leurs autorisations correspondantes

Cette section décrit les tâches courantes dans le service Connexion de données métiers et les autorisations nécessaires pour les exécuter.

Tâche | Autorisations
Créer un nouvel objet dans le magasin de métadonnées | Pour créer un nouvel objet de métadonnées, l'utilisateur doit disposer d'autorisations d'exécution sur l'objet de métadonnées parent. Par exemple, pour créer une nouvelle méthode dans un type de contenu externe, l'utilisateur doit disposer d'autorisations sur le type de contenu externe. Consultez l'illustration plus haut dans cet article pour la relation enfant/parent entre les objets dans le magasin de métadonnées.
Supprimer un objet du magasin de métadonnées | Pour supprimer un objet de métadonnées, l'utilisateur doit avoir des autorisations de modification sur cet objet. Pour supprimer un objet et tous ses objets enfants (comme la suppression d'un type de contenu externe et toutes ses méthodes), l'autorisation de modification est également nécessaire pour tous les objets enfants.
Ajout d'un type de contenu externe à un modèle | Pour ajouter un type de contenu externe à un modèle, l'utilisateur doit disposer d'autorisations de modification sur le modèle.
Importation de modèles | Pour importer un modèle dans le magasin de métadonnées, l'utilisateur doit disposer des autorisations de modification sur le magasin de métadonnées. Si des autorisations explicites ne sont pas affectées au modèle, l'utilisateur l'ayant importé recevra les autorisations de modification sur ce modèle.
Exportation de modèles | Pour exporter un modèle à partir du magasin de métadonnées, l'utilisateur doit disposer d'autorisations de modification sur ce modèle et sur tous les systèmes externes contenus dans le modèle.
Génération d'un package de déploiement | Les packages de déploiement sont générés par le compte du pool d'applications utilisé par le serveur frontal. Ce compte possède les autorisations maximales sur le magasin de métadonnées, ce qui lui permet de réaliser cette tâche.
Définition des autorisations initiales sur le magasin des métadonnées. | Lors de la première création d'une instance du service Connexion de données métiers, son magasin de métadonnées est vide. L'administrateur de batterie a les autorisations maximales sur le magasin et peut définir les autorisations initiales.

Sécurisation de Business Connectivity Services

Cette section traite des mesures supplémentaires susceptibles d'aider à sécuriser les services Business Connectivity

Compte de service

À des fins d'isolation de sécurité, l'application de service Connexion de données métiers et le serveur frontal ne doivent pas utiliser le même compte de service.

Communication de serveur à serveur

La sécurisation des communications entre l'application de service Connexion de données métiers et les systèmes externes aide à éviter que les données confidentielles ne soient compromises. Vous devez utiliser un canal de communication chiffré afin de protéger les données envoyées entre des serveurs exécutant SharePoint Foundation 2010 et des systèmes externes. La sécurité IPSec (Internet Protocol Security) est l'une des méthodes susceptible d'aider à protéger les communications. Le choix de la méthode à utiliser dépend des canaux de communication spécifiques que vous sécurisez et des avantages et compromis le mieux adaptés à votre organisation.

Applications qui utilisent FileBackedMetadataCatalog

Pour des raisons de sécurité, le mode d'authentification RevertToSelf est désactivé sur SharePoint Foundation 2010 par défaut. Toutefois, cela n'empêche pas les applications qui utilisent la classe FileBackedMetadataCatalog d'importer des modèles et d'exécuter des appels qui utilisent l'authentification RevertToSelf. Cela peut provoquer une élévation des privilèges des utilisateurs suite à l'accord de privilèges au compte du pool d'applications. Il convient d'examiner toutes les applications afin de s'assurer qu'elles n'utilisent pas la classe FileBackedMetadataCatalog et l'authentification RevertToSelf avant de les installer sur un système de production.

Historique des modifications

Date | Description | Raison
9 septembre 2010 | 2010/09/06 | Mise à jour du contenu
8 juillet 2010 | 2010/07/05 | Mise à jour du contenu
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Journalisation des diagnostics dans la vue d'ensemble de services Business Connectivity (SharePoint Foundation 2010)
Voir aussi

Vous pouvez résoudre les problèmes liés à Services Microsoft Business Connectivity sur les serveurs qui exécutent Microsoft SharePoint Foundation 2010 à l'aide de journaux des événements et de journaux de suivi sur le client ou le serveur. En outre, chaque entrée dans le journal des événements ou le journal de suivi possède un ID d'activité associé qui peut être utilisé pour suivre un problème à partir du serveur jusqu'à la source de données externe.

Remarque :
Avec les méthodes de journalisation présentées dans cette rubrique, vous pouvez utiliser Pack d'administration de Microsoft System Center Operations Manager pour contrôler une solution basée sur Services Microsoft Business Connectivity. Pour plus d'informations sur la façon de configurer le Pack d'administration de System Center Operations Manager, consultez le guide inclus avec le téléchargement du pack d'administration à l'adresse Pack d'administration de Microsoft SharePoint 2010 produits (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=184971&clcid=0x40C).

Dans cet article :

  • Journalisation des diagnostics dans les services Business Connectivity

  • À propos des ID d'activité

  • Journalisation des diagnostics sur les serveurs

  • Exemple : utilisation de la journalisation des diagnostics

Journalisation des diagnostics dans les services Business Connectivity

Pour les solutions qui reposent sur Services Microsoft Business Connectivity, la journalisation des diagnostics s'effectue sur les serveurs qui exécutent Microsoft SharePoint Foundation. Il existe deux journaux : le journal des événements et le journal de suivi. Ils enregistrent tous deux les informations de diagnostics que Services Microsoft Business Connectivity génère. Les journaux des événements permettent d'enregistrer des messages d'erreur. Les journaux de suivi contiennent plus d'informations détaillées, telles que les traces de pile et les messages d'information. En règle générale, les journaux de suivi fournissent plus de détails que les journaux des événements.

Chaque élément d'information consigné inclut un ID d'activité, qui est une valeur GUID unique. Les valeurs d'ID d'activité peuvent également être envoyées à des systèmes externes lorsqu'un élément fait l'objet d'une opération de création, de mise à jour ou de suppression. En utilisant des identificateurs de l'activité, il est possible de suivre une action à partir du serveur ou du client jusqu'à la source de données externe. Pour plus d'informations sur les ID d'activité, consultez À propos des ID d'activité .

Vous pouvez définir le niveau de journalisation des diagnostics pour le journal des événements et du journal de suivi. Cela limite les types et la quantité d'informations qui sont écrites dans chaque journal. Les tableaux ci-dessous définissent les niveaux de journalisation disponibles pour le journal des événements et le journal de suivi :

Niveaux du journal des événements

Niveau | Définition
Aucune | Aucune journalisation n'a lieu.
Critique | Ce type de message indique une erreur grave qui a provoqué une défaillance majeure dans la solution.
Erreur | Ce type de message indique un état d'urgence. Tous les événements d'erreur doivent être analysés.
Avertissement | Ce type de message indique un problème potentiel ou un problème qui peut nécessiter une attention particulière. Les messages d'avertissement doivent faire l'objet d'un examen et d'un suivi pour les tendances à long terme.
Informations | Les messages d'information ne nécessitent pas tous une action, mais ils peuvent fournir des données précieuses pour surveiller l'état de votre solution.
Commentaires | Ce niveau de journal des événements correspond à des messages ou des événements longs.

Niveaux de journal de suivi

Niveau | Définition
Aucune | Aucun journal de suivi n'est écrit.
Inattendu | Ce niveau permet de consigner des messages sur les événements qui provoquent l'arrêt du traitement effectué par les solutions. Lorsqu'il est configuré pour journaliser à ce niveau, le journal comprend uniquement les événements de ce niveau.
Suivi | Ce niveau permet de consigner les messages sur n'importe quels événements irrécupérables qui limitent le fonctionnement de la solution, mais n'arrêtent pas l'application. Lorsqu'il configuré pour journaliser à ce niveau, le journal inclut également les erreurs critiques (niveau inattendu).
Élevé | Ce niveau est utilisé pour consigner tous les événements inattendus, mais qui n'interrompent pas le traitement d'une solution. Lorsqu'il configuré pour journaliser à ce niveau, le journal contient des avertissements, des erreurs (niveau Suivi) et les erreurs critiques (niveau Inattendu).
Moyen | Lorsqu'il configuré pour journaliser à ce niveau, le journal de suivi inclut tout, à l'exception des messages commentés. Ce niveau est utilisé pour toutes les informations de haut niveau sur les opérations qui ont été effectuées. À ce niveau, les détails consignés sont suffisants pour reconstituer le flux de données et la séquence des opérations. Ce niveau de journalisation peut être utilisé par les administrateurs ou les techniciens du support technique pour résoudre les problèmes.
Commentaires | Lorsqu'il configuré pour journaliser à ce niveau, le journal inclut les messages tous les autres niveaux. Presque toutes les actions effectuées sont consignées lorsque vous utilisez ce niveau. Le suivi avec commentaires génère de nombreux messages de journalisation. Ce niveau est généralement utilisé uniquement pour le débogage dans un environnement de développement.

Les journaux de diagnostic sont utiles à la fois dans les environnements de développement et de production, mais les besoins en termes de niveau de journalisation vont probablement différer en fonction du type d'environnement. Lors de la planification pour la journalisation des diagnostics Services Microsoft Business Connectivity, réfléchissez aux besoins et à l'étape de cycle de vie de l'environnement avant de définir le niveau de journalisation.

Par exemple, au cours de la conception d'une solution, vous pouvez, à des fins de débogage, définir les deux niveaux de journalisation sur Commentaires pour capturer tous les messages qui sont générés sur l'état du système. À l'inverse, dans un environnement de production, vous pouvez souhaiter capturer les messages uniquement dans les catégories Élevé, Suivi et Inattendu pour les journaux de suivi et les catégories Critique et Erreur pour les journaux des événements. Cette opération permet d'économiser l'espace disque de journalisation et de limiter les effets négatifs sur les performances dus à l'exécution de la journalisation.

À propos des ID d'activité

Une valeur GUID unique appelée ID d'activité est générée pour chaque opération de création (Create), de mise à jour (Update) ou de suppression (Delete) appliquée aux données externes dans une solution basée sur Services Microsoft Business Connectivity. Tout ce qui est lié à l'opération qui est consignée dans le journal de suivi ou le journal des événements inclut sa valeur d'ID d'activité.

Important :
Dans les journaux des événements et de suivi présent sur le serveur, des valeurs d'ID d'activité sont étiquetées en tant que valeurs « CorrelationId ».

La valeur d'ID d'activité générée pour une opération Create, Update ou Delete est envoyée au système externe ainsi que d'autres informations liées à cette opération. Si le système externe possède un mécanisme de journalisation, cette valeur peut être capturée et consignée sur ce système. Par conséquent, une opération entraîne des entrées dans les journaux SharePoint, la même opération peut être suivie jusqu'au système externe par le biais de sa valeur d'ID d'activité. Cela facilite le dépannage de bout en bout des problèmes.

Souvent, une opération telle que Create entraîne l'écriture de plusieurs événements dans les journaux. Dans ce cas, la même valeur d'ID d'activité est utilisée pour tous les événements qui sont journalisés pour l'opération. Cette option est utile pour la résolution des problèmes, car la valeur récurrente de l'ID de l'activité facilite la recherche de tous les événements d'une opération particulière. Inversement, lorsque le même type d'opération se produit à plusieurs reprises, une valeur d'ID d'activité unique est générée pour chaque instance d'opération. Par exemple, si un élément d'un type de contenu externe est mis à jour deux fois, chaque opération de mise à jour est associée à une valeur d'ID d'activité unique.

Conseil :
Dans certaines circonstances, le service Connexion de données métiers va réessayer une opération s'il n'a pas pu atteindre le système externe. Dans ce cas, le même ID d'activité est utilisé pour l'opération retentée.

Journalisation des diagnostics sur les serveurs

Par défaut, la journalisation Services Microsoft Business Connectivity est activée sur les serveurs SharePoint Foundation. Les niveaux de journalisation par défaut sont comme suit :

  • Pour le journal des événements : Critique et Erreur

  • Pour le journal de suivi : Moyen

La journalisation des diagnostics de Services Microsoft Business Connectivity est alors désactivée ; activez-la en sélectionnant Services Business Connectivity sur la page Journalisation des diagnostics dans l'administration centrale SharePoint Foundation. Vous pouvez également utiliser Windows PowerShell pour configurer les journaux des événements et les journaux de suivi sur le serveur. Par exemple, vous pouvez modifier le lecteur d'écriture utilisé pour la journalisation et définir le niveau de détail de la journalisation.

Pour plus d'informations sur la journalisation dans SharePoint Foundation 2010, comme par exemple comment définir l'emplacement des fichiers journaux, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

Vous pouvez utiliser Windows PowerShell pour consulter les journaux des événements sur le serveur et vous pouvez ensuite exporter les journaux, par exemple vers une feuille de calcul. Pour plus d'informations, voir Afficher les journaux de diagnostic (SharePoint Foundation 2010).

Services Microsoft Business Connectivity sort deux catégories dans le journal de suivi sur les serveurs Web frontaux SharePoint Foundation : BDC_Shared_Services et SS_Shared_Service. Vous pouvez utiliser l'Observateur d'événements pour ouvrir le journal de suivi et filtrer sur les entrées pertinentes du journal en recherchant « SPS_BusinessData » (pour les sorties Services Microsoft Business Connectivity) et « SPS_SecureStoreService ».

Exemple : utilisation de la journalisation des diagnostics

Ce scénario court et simplifié illustre l'utilisation de la journalisation des diagnostics dans un environnement de production. Une entreprise a déployé une nouvelle solution de soumission de fiche de pointage fondée sur Services Microsoft Business Connectivity. Cette solution utilise un système externe pour stocker les informations de la carte de pointage des employés, telles que le temps des vacances et des congés de maladie, et pour interagir avec les employés et le système de paie lorsque des employés signalent une absence au travail. Les employés utilisent un composant WebPart pour interagir avec le système.

Dans la batterie de serveurs, les niveaux de journalisation sont définis selon les valeurs par défaut pour Services Microsoft Business Connectivity :

  • Pour le journal des événements : Critique et Erreur

  • Pour le journal de suivi : Moyen

Dans ce scénario, un employé envoie une valeur correspondant au nombre d'heures de congé-maladie, mais ni l'employé, ni son responsable ne reçoit un message électronique de confirmation signalant que le temps de congé-maladie a été envoyé avec succès. L'employé appelle le service de support technique interne et signale le problème.

Le technicien reconnaît que l'application de la fiche de pointage est basée sur Services Microsoft Business Connectivity. Il vérifie le journal des événements mais ne trouve aucune erreur associée à l'identité de l'utilisateur au moment où celui-ci a soumis la demande de fiche de pointage. Il vérifie ensuite le journal de suivi, où il constate la preuve de l'activité : une opération de mise à jour associée à l'utilisateur au moment approprié. L'opération de mise à jour dans le journal de suivi inclut un ID d'activité que relève le technicien de support.

Le technicien sait que la journalisation est également prise en charge sur le système externe. À l'aide de l'ID de l'activité, il localise l'élément journalisé sur le système externe et détecte la preuve d'une erreur écrite dans le journal à la fin de l'opération de mise à jour : la mise à jour a échoué parce que l'employé avait utilisé tout son temps imparti aux congés-maladie. Il note également qu'il n'existe dans le journal aucune entrée confirmant qu'un message électronique a été généré sur le système externe immédiatement après l'opération de mise à jour. Le technicien du support technique conclut qu'il existe une erreur dans la logique de l'application de la fiche de pointage. Bien que l'application n'ait pas alloué pas le salaire correspondant aux jours de maladie lorsque l'employé a dépassé son nombre d'heures alloué, elle n'a pas généré un message électronique informant celui-ci du problème. Le technicien signale le problème à l'équipe de développement qui a créé l'application et l'équipe de développement met alors à jour l'application.

Voir aussi

Concepts

Vue d'ensemble de la surveillance (SharePoint Foundation 2010)
Configurer la journalisation des diagnostics (SharePoint Foundation 2010)
Vue d'ensemble de Business Connectivity Services (SharePoint Foundation 2010)

Historique des modifications


Planifier les flux de travail (SharePoint Foundation 2010)
Voir aussi

Un flux de travail est une fonctionnalité de Microsoft SharePoint Foundation 2010 qui applique à des documents ou des éléments de liste une séquence spécifique d'actions ou de tâches liées à un processus d'entreprise. Les flux de travail peuvent servir à gérer des processus d'entreprise courants comme la révision ou l'approbation de documents.

Dans cette section :

  • Vue d'ensemble des flux de travail (SharePoint Foundation 2010)

    Cet article présente les types de processus d'entreprise que les flux de travail peuvent faciliter et décrit les flux de travail inclus dans SharePoint Foundation 2010.

  • Choisir un outil de création de flux de travail (SharePoint Foundation)

    Cet article décrit les différents outils de création de flux de travail Microsoft pris en charge et la façon de les utiliser ensemble pour accélérer la création de flux de travail.

  • Planifier la gestion de la sécurité et des utilisateurs des flux de travail (SharePoint Foundation 2010)

    Cet article souligne certains aspects du comportement des flux de travail relatifs à la sécurité et présente d'autres problèmes que les administrateurs et les développeurs de flux de travail doivent considérer lorsqu'ils prévoient de configurer et de développer des flux de travail.

  • Flux de travail d'approbation : un scénario (SharePoint Foundation 2010)

    Cet article montre à quoi peut ressembler un flux de travail de type approbation créé dans Microsoft SharePoint Designer 2010 ou Workflow Designer dans Visual Studio 2010, puis hébergé à l'aide de SharePoint Foundation 2010.

Voir aussi

Concepts

Administration de flux de travail (SharePoint Foundation 2010)

Historique des modifications


Vue d'ensemble des flux de travail (SharePoint Foundation 2010)

Le flux de travail est une fonctionnalité de Microsoft SharePoint Foundation 2010 qui permet aux architectes, concepteurs et administrateurs de solutions d'améliorer les processus métiers. Il se compose essentiellement de deux éléments : les formulaires utilisés pour interagir avec les utilisateurs et la logique définissant le comportement du flux de travail. Pour comprendre la façon dont les flux de travail sont créés, il faut connaître ces deux éléments.

Dans cet article :

  • Présentation des flux de travail

  • Avantages de l'utilisation des flux de travail

  • Flux de travail prédéfinis

  • Exemple de scénario de flux de travail

  • Types de flux de travail : déclaratifs et compilés

  • Modèles de flux de travail

  • Associations de flux de travail

Présentation des flux de travail

Les flux de travail dans SharePoint Foundation 2010 permettent aux entreprises de réduire la quantité d'interactions superflues entre les personnes à mesure qu'elles réalisent des processus métiers. Par exemple, pour prendre une décision, les groupes suivent généralement une série d'étapes. Ces étapes peuvent être formelles, conformes à une procédure de fonctionnement standard ou un mode de fonctionnement implicitement admis informel. Ensemble, les étapes forment un processus métier. Le nombre d'interactions humaines qui se produisent dans les processus métiers peut porter préjudice à la rapidité et à la qualité des décisions. Les logiciels qui simplifient et gèrent ce « flux de travail humain » permettent l'automatisation des interactions entre les groupes qui participent au processus. Cette automatisation aboutit à davantage de rapidité, à une meilleure efficacité globale des interactions et, souvent, à une diminution des erreurs.

Vous pouvez modéliser des processus métiers à l'aide de diagrammes de flux, tels que ceux créés à l'aide de Microsoft Visio 2010, et les représenter à l'aide de la terminologie des flux de travail. Vous pouvez automatiser les processus métiers, tels que l'approbation de document, en associant un flux de travail à des données dans SharePoint Foundation 2010. Par exemple, vous pouvez créer un flux de travail pour router un document pour révision, effectuer le suivi d'un problème à travers ses différents stades de résolution ou guider un contrat à travers un processus d'approbation.

L'un des problèmes majeurs auxquels sont confrontés de nombreux services informatiques lors de l'implémentation de processus métiers nécessitant la participation des personnes en charge du traitement de l'information est que ces processus ne s'intègrent pas à la façon dont les personnes travaillent réellement. Pour qu'un processus métier soit efficace, il doit être intégré aux outils et aux applications utilisés quotidiennement dans l'entreprise, de façon à faire partie des habitudes quotidiennes des utilisateurs. Dans un environnement informatique, cela inclut l'intégration à la messagerie, aux calendriers, aux listes de tâches et aux sites Web de collaboration.

Avantages de l'utilisation des flux de travail

Les principaux avantages de l'utilisation de flux de travail sont la facilitation des processus métiers et l'amélioration de la collaboration.

Les processus métiers utilisés par les entreprises dépendent du flux d'informations ou de documents. Ces processus requièrent la participation active des personnes chargées du traitement des informations pour effectuer les tâches qui contribuent aux décisions ou aux éléments livrables de leur groupe de travail. Dans SharePoint Foundation 2010, ces types de processus métiers sont implémentés et gérés à l'aide de flux de travail.

Voici des exemples de processus d'entreprise qui pourraient être facilités par les flux de travail :

  • Approbation de contrat Supervision d'un contrat entre les différents membres d'une organisation qui doivent l'approuver ou le refuser.

  • Note de frais Gestion de l'envoi d'une note de frais et des reçus associés, incluant son examen, son approbation et le remboursement au demandeur.

  • Support technique Supervision de la progression d'un incident de support technique (ouverture par un client, analyse par un technicien du support technique, acheminement vers des experts techniques, résolution et ajout à une base de connaissances).

  • Entretiens Gestion du processus d'entretien en vue de l'embauche d'un candidat à un poste. Ceci inclut la planification et le suivi des différents entretiens, la collecte des commentaires sur les entretiens, la mise à disposition des commentaires pour les personnes qui conduisent les entretiens suivants et l'aide à la décision d'embaucher ou non.

Automatisation des processus d'entreprise

Les entreprises sont tributaires des processus d'entreprise. Bien que ces processus impliquent souvent du logiciel, les processus les plus importants dans de nombreuses organisations dépendent des personnes. Les flux de travail peuvent automatiser les interactions entre les personnes participant à un processus pour améliorer le fonctionnement du processus, accroître son efficacité et réduire son taux d'erreurs.

De nombreux processus peuvent bénéficier de la prise en charge automatisée des interactions humaines. Voici quelques exemples :

  • Approbation Un aspect courant des processus d'entreprise orientés vers l'humain est la nécessité d'obtenir l'approbation de plusieurs participants. Ce qui est approuvé peut varier considérablement, allant d'un document Microsoft Word qui contient la stratégie commerciale de l'année suivante à une note de frais de la présence à une conférence. Dans chaque cas, un certain nombre d'utilisateurs doit réviser les informations, éventuellement ajouter des commentaires, puis indiquer l'approbation ou le rejet.

  • Coordination des efforts du groupe Qu'il s'agisse de préparer une réponse à un appel d'offres, de gérer la traduction d'un document dans une ou plusieurs langues ou d'effectuer une autre tâche, de nombreux processus requièrent une collaboration des utilisateurs de manière organisée. La définition des étapes du processus par le biais d'un flux de travail automatisé permet de renforcer l'efficacité du travail du groupe et le caractère prévisible du processus proprement dit.

  • Suivi des problèmes De nombreux processus d'entreprise génèrent une liste de problèmes en suspens. Un flux de travail automatisé permet de tenir cette liste à jour, d'affecter les problèmes aux personnes pouvant les résoudre et d'effectuer le suivi de l'état de cette résolution.

Pour prendre en charge ces types de processus d'entreprise automatisés, SharePoint Foundation 2010 peut exécuter des applications de flux de travail. Basées sur Windows Workflow Foundation 3.5, ces applications interagissent avec les personnes par l'intermédiaire d'un navigateur Web. Pour plus d'informations sur Windows Workflow Foundation 3.5, voir Windows Workflow Foundation (http://go.microsoft.com/fwlink/?linkid=127778&clcid=0x40C).

Les flux de travail améliorent la collaboration

Les flux de travail aident les individus à collaborer sur des documents et à gérer les tâches des projets en implémentant des processus métiers sur des documents et des éléments sur une collection de sites ou un site SharePoint. Les flux de travail aident les organisations à suivre des pratiques de processus métier cohérentes. Ils améliorent l'efficacité et la productivité de l'organisation à travers la gestion des tâches et des étapes impliquées dans ces processus métiers. Ils accélèrent la prise de décision en garantissant la disponibilité des informations appropriées pour les personnes appropriées au moment où elles en ont besoin. Ils permettent également de s'assurer que les tâches individuelles des flux de travail ont été effectuées par la personne appropriée et selon la séquence appropriée. Ceci permet aux personnes qui effectuent ces tâches de se concentrer sur le travail lui-même et non pas sur les processus de ce travail.

Par exemple, sur un site SharePoint Foundation 2010, vous pouvez créer un flux de travail à utiliser avec une bibliothèque de documents pour router un document vers un groupe de personnes pour approbation. Lorsque l'auteur démarre ce flux de travail, celui-ci crée une tâche d'approbation de document, affecte ces tâches aux participants du flux de travail, puis envoie des alertes de messagerie aux participants.

Lorsque le flux de travail est en cours, le propriétaire du flux de travail ou les participants du flux de travail peuvent vérifier l'avancement sur la page État du flux de travail. Lorsque les participants du flux de travail achèvent leurs tâches, le flux de travail se termine et le propriétaire du flux de travail est averti automatiquement que ce flux de travail est terminé.

Flux de travail prédéfinis

Pour les sites et les collections de sites créés dans Microsoft SharePoint Foundation 2010, un flux de travail à trois états prédéfini est inclus par défaut et représente le seul flux de travail prédéfini disponible dans SharePoint Foundation 2010. Le flux de travail à trois états peut être utilisé pour gérer les processus d'entreprise qui nécessitent le suivi de grands volumes d'informations ou d'éléments de liste, tels que les questions liées au support client, aux pistes commerciales ou aux tâches projet.

Le flux de travail à trois états doit son nom au fait qu'il suit l'état d'un problème ou d'un élément au cours de trois états différents et de deux transitions entre les états. Par exemple, lorsqu'un flux de travail à trois états est initié pour un problème figurant dans une liste de problèmes, SharePoint Foundation 2010 crée une tâche pour l'utilisateur concerné. Lorsque l'utilisateur termine la tâche, le flux de travail passe de l'état initial (Actif) à l'état moyen (Résolu) et crée une tâche pour l'utilisateur concerné. Lorsque l'utilisateur termine la tâche, le flux de travail passe de l'état moyen (Résolu) à l'état final (Fermé) et crée une autre tâche pour l'utilisateur auquel le flux de travail est affecté à ce moment-là. Notez que lorsque vous associez le flux de travail à trois états à une liste, vous pouvez choisir de spécifier différents noms d'état, autres que les noms Actif, Résolu et Fermé. Notez également que le flux de travail à trois états n'est pas utilisable avec des bibliothèques.

Vous pouvez également créer une copie du flux de travail prédéfini sur laquelle baser la création d'un flux de travail personnalisé.

Exemple de scénario de flux de travail

Imaginez que vous travaillez pour Adventure Works, une franchise de magasins de sports qui vend des vélos dans le monde entier. Cette société a des représentants commerciaux qui visitent différents pays pour aider les nouveaux franchisés à ouvrir de nouveaux magasins de sports.

Le scénario décrit dans cette section illustre la soumission d'une note de frais pour approbation. Si la note de frais est inférieure à 5 000 euros, un responsable doit l'approuver, la désapprouver ou la transmettre. Si la note de frais est supérieure ou égale à 5 000 euros, un responsable doit l'examiner et la commenter, puis, s'il recommande son approbation, elle est transmise à un vice-président, qui doit l'approuver ou la désapprouver.

Dans ce scénario, le formulaire de note de frais est un formulaire ASPX affiché à l'utilisateur dans une page Web SharePoint. Le flux de travail est un projet de flux de travail de type séquentiel créé dans Microsoft SharePoint Designer 2010 et est composé de tâches automatisées et de tâches requérant une action humaine. Le flux de travail s'exécute sur SharePoint Foundation 2010.

  1. Le représentant commercial (premier participant du flux de travail) accède à un portail self-service intranet et sélectionne le formulaire Note de frais. Une page d'entrée de données s'ouvre. Le représentant commercial remplit d'abord un formulaire de note de frais simple qui contient des entrées pour le nom de la personne, l'objet des dépenses, le total des dépenses, ainsi que le nom et l'adresse de messagerie du responsable direct de la personne. Il clique ensuite sur Envoyer pour envoyer le formulaire.

    Après l'envoi du formulaire, les données sont enregistrées à un emplacement centralisé, le flux de travail est initié et la tâche d'examen est affectée à l'approbateur (dans ce cas, le responsable du représentant commercial).

  2. Le flux de travail envoie une notification au responsable du représentant commercial. La notification est un message de courrier électronique contenant des instructions pour effectuer la tâche et fournissant un lien vers un site Web qui affiche le formulaire Note de frais.

  3. Le responsable (deuxième participant du flux de travail) accède au site Web et examine la note de frais. L'élément de tâche de flux de travail fournit les trois actions Approuver, Désapprouver ou Transmettre, qui peuvent être effectuées par le responsable :

    • Si le montant de la note de frais est inférieur à 5 000,00 euros, le responsable voit des options pour Approuver ou Désapprouver la note de frais.

    • Si le montant de la note de frais est supérieur à 5 000,00€, le responsable voit des options pour Transférer la note de frais à un vice-président de la société ou pour Désapprouver la note de frais à son niveau.

  4. Le responsable choisit d'approuver, de désapprouver ou de transférer, puis le flux de travail continue :

    • Si les dépenses sont approuvées par le responsable, l'achèvement de la tâche envoie un message au flux de travail indiquant que la tâche est terminée, le flux de travail envoie une notification au représentant commercial via un message électronique, puis le flux de travail ajoute les données des frais au système de comptabilité métier.

    • Si les dépenses ne sont pas approuvées par le responsable, celui-ci entre une explication de sa décision. L'achèvement de la tâche envoie un message au flux de travail indiquant que la tâche est terminée, puis le flux de travail envoie une notification au représentant commercial via un message électronique.

    • Si le responsable sélectionne l'option de transfert de la note de frais à un vice-président de la société, le responsable ajoute les commentaires appropriés dans le formulaire, puis clique sur Transférer. Le flux de travail envoie ensuite une notification au vice-président via un message électronique contenant des instructions pour effectuer la tâche et fournissant un lien vers un site Web qui affiche le formulaire Note de frais.

  5. Le vice-président (troisième participant du flux de travail) a comme options d' Approuver ou de Désapprouver la note de frais. Lorsque le vice-président effectue l'action nécessaire pour approuver ou désapprouver la note de frais, le flux de travail continue.

    • Si le vice-président approuve les frais, les données correspondant à ces frais sont ajoutées au système de comptabilité, le flux de travail envoie une notification au représentant commercial et au responsable via un message électronique, puis le flux de travail notifie à SharePoint que la tâche est terminée.

    • Si le vice-président n'approuve pas les frais, il entre une explication de la décision dans le formulaire. Le flux de travail envoie une notification au représentant commercial et au responsable par courrier électronique, puis notifie à SharePoint que la tâche est terminée.

Comme vous pouvez l'imaginer, il existe de nombreux moyens de développer les fonctionnalités de ce flux de travail dans le cadre de ce scénario. Par exemple, vous pouvez configurer le flux de travail de telle façon que si le vice-président désapprouve la note de frais, le rapport soit renvoyé au responsable du représentant commercial. Le responsable peut alors justifier la note de frais et la renvoyer pour approbation au vice-président, peut faire suivre la désapprobation au représentant commercial ou entreprendre une autre action.

Dans cet exemple de scénario de note de frais, les règles métiers sont toujours les mêmes. Cette solution de flux de travail définit comme approbateurs le responsable et le vice-président, définit la logique métier pour le routage du flux de travail, et prédéfinit le contenu des notifications. Cependant, beaucoup d'applications du monde réel ont des règles métiers complexes. Le routage pour l'approbation peut dépendre de plusieurs variables métiers. Les notifications peuvent également changer en fonction d'autres variables.

Par exemple, imaginez que, dans la même solution pour les notes de frais, vous ayez à router la note de frais à jusqu'à dix responsables, en fonction de la raison des frais, du total des frais et de la date d'envoi. En outre, en fonction de la raison des frais, le contenu des notifications envoyées par le flux de travail présente de petites différences. Cela signifie qu'il peut y avoir plusieurs solutions de flux de travail avec différents niveaux de routage et différentes notifications.

Microsoft SharePoint Foundation 2010 vous permet de créer et d'implémenter des solutions de flux de travail pour répondre aux besoins métiers de votre organisation. À cette fin, il s'appuie sur les fonctionnalités de conception et de personnalisation de flux de travail de SharePoint Designer 2010 et de Microsoft Visual Studio.

Types de flux de travail : déclaratifs et compilés

Une distinction importante à faire au sujet d'un flux de travail concerne sa nature : s'agit-il d'un flux de travail déclaratif, tel que ceux créés à l'aide de Microsoft SharePoint Designer 2010, ou d'un flux de travail compilé, tel que ceux créés à l'aide de Visual Studio 2010. Un flux de travail déclaratif est un flux de travail qui est créé à partir de conditions et d'actions assemblées en règles et en étapes, et qui définit les paramètres pour le flux de travail sans écrire de code.

Un flux de travail compilé, tel que les flux de travail déclaratifs, peut également être créé à partir de conditions et d'actions sans que son auteur ait véritablement besoin d'écrire de code, mais se différencie par le fait que ce dernier peut l'enrichir de code personnalisé. Qu'un auteur de flux de travail ajoute ou non du code à un flux de travail basé sur du code, la distinction la plus importante à faire concerne la façon dont les flux de travail déclaratifs et compilés sont exécutés sur le serveur. Un flux de travail compilé est stocké sur un serveur exécutant SharePoint Foundation 2010 sous la forme d'un fichier dll précompilé, tandis qu'un flux de travail déclaratif est déployé sur un serveur exécutant SharePoint Foundation 2010 sous la forme d'un fichier XOML (Extensible Object Markup Language) et compilé dans la base de données de contenu chaque fois qu'une instance du flux de travail est démarrée.

Pour plus d'informations sur les outils Microsoft pris en charge pour la création de flux de travail, voir Choisir un outil de création de flux de travail (SharePoint Foundation).

Modèles de flux de travail

Lorsque vous créez un flux de travail personnalisé à l'aide de SharePoint Designer 2010, vous pouvez choisir de créer un flux de travail qui ne sera utilisé qu'avec une liste, une bibliothèque, un type de contenu ou un site spécifique. Vous pouvez aussi choisir de créer un modèle de flux de travail réutilisable, pouvant être associé à plusieurs listes, bibliothèques, types de contenu ou sites.

Remarque :
SharePoint Designer 2010 ne prend pas en charge la création de flux de travail réutilisables pour les sites. En revanche, vous pouvez utiliser Visual Studio 2010 pour les créer.

Lorsque vous créez un flux de travail, vous pouvez également le définir comme étant global, auquel cas, une fois activé sur un site, il sera également actif pour tous les sous-sites situés sous ce site. Toutefois, vous ne pouvez pas utiliser SharePoint Designer 2010 pour créer un flux de travail global, puis enregistrer celui-ci en tant que fichier WSP.

Associations de flux de travail

SharePoint Foundation 2010 tire parti du runtime de Workflow Foundation. Un ou plusieurs modèles de flux de travail, chacun contenant le code qui définit un flux de travail particulier, peuvent être installés sur un serveur. Une fois cette opération effectuée, une association peut être créée entre un modèle spécifique et une bibliothèque de documents, une liste, un type de contenu ou un site. Ce modèle peut ensuite être chargé et exécuté par le runtime de Workflow Foundation hébergé par SharePoint Foundation 2010, créant une instance de flux de travail.

À l'image de tous les flux de travail Workflow Foundation, les flux de travail basés sur SharePoint Foundation 2010 reposent sur les services d'exécution de Workflow Foundation. Le service de persistance standard de Workflow Foundation permet la liaison de l'état d'un flux de travail persistant avec le document ou l'élément et autorise les processus d'entreprise dont l'exécution peut durée des jours, des mois ou des années.

Les flux de travail SharePoint peuvent être associés à des listes, des bibliothèques et des types de contenu. Les flux de travail réutilisables créés à l'aide de Visual Studio 2010 peuvent également être associés à des sites. Le tableau suivant décrit les autorisations minimales dont vous devez bénéficier pour associer un flux de travail.

Entité à laquelle associer le flux de travail | Autorisations minimales requises
Liste ou bibliothèque | Niveau d'autorisation Contrôle total sur la liste ou la bibliothèque
Type de contenu de bibliothèque ou liste | Membre du groupe des propriétaires de site sur le site SharePoint
Type de contenu de site | Membre du groupe des propriétaires de site sur le site SharePoint
Site | Membre du groupe des propriétaires de site sur le site SharePoint

Pour plus d'informations sur les associations de flux de travail, voir Ajouter une association de flux de travail (SharePoint Foundation 2010).

Historique des modifications


Choisir un outil de création de flux de travail (SharePoint Foundation)

Qu'est-ce qu'un flux de travail ? Il se compose essentiellement de deux éléments : les formulaires qu'un flux de travail utilise pour interagir avec ses utilisateurs et la logique qui définit le comportement du flux de travail. Pour comprendre comment les flux de travail sont créés, il faut connaître ces deux éléments.

Comme il communique avec les utilisateurs par l'intermédiaire d'un navigateur Web, un flux de travail repose sur ASP.NET pour afficher ses formulaires. Par conséquent, ces formulaires sont définis en tant que pages .aspx. Un flux de travail peut éventuellement afficher ses propres formulaires à quatre stades dans son cycle de vie :

  • Association : lorsqu'un administrateur associe un modèle de flux de travail à une bibliothèque ou liste de documents particulière, il pourrait être en mesure de définir des options qui s'appliqueront à chaque instance de flux de travail créée à partir de cette association. Si un auteur de flux de travail choisit de l'autoriser, il doit fournir un formulaire qui permet à l'administrateur de spécifier ces informations.

  • Lancement : l'initiateur d'un flux de travail peut être autorisé à spécifier des options lorsqu'il démarre une instance d'exécution. Dans le scénario d'approbation venant d'être décrit, par exemple, les options permettent notamment de spécifier la liste des participants du flux de travail et de définir de combien de temps chacun d'eux dispose pour effectuer sa tâche. Si un flux de travail le permet, son auteur doit fournir un formulaire pour permettre à l'initiateur de définir ces options.

  • Fin de tâche : l'instance du flux de travail en cours d'exécution doit afficher un formulaire aux participants du flux de travail pour leur permettre d'effectuer leur tâche. Ce formulaire a autorisé les approbateurs du scénario antérieur à apporter des commentaires sur le document et à indiquer leur approbation ou leur rejet.

  • Modification : le créateur d'un flux de travail peut permettre qu'il soit modifié en cours d'exécution. Par exemple, un flux de travail peut autoriser l'ajout de nouveaux participants après le début de son exécution ou l'extension de sa date d'échéance pour l'exécution des tâches. Si cette option est utilisée, le flux de travail doit afficher un formulaire à ce stade pour permettre à un participant de spécifier les modifications à apporter.

Les flux de travail reposant uniquement sur Microsoft SharePoint Foundation 2010 définissent leurs formulaires en tant que pages .aspx. La logique d'un flux de travail est toujours définie comme un groupe d'activités, comme avec tout flux de travail basé sur Windows Workflow Foundation (WF). Pour spécifier la logique et les formulaires d'un flux de travail, Microsoft fournit deux outils spécifiques, chacun ciblant un public différent. Les développeurs de logiciels peuvent utiliser la fonctionnalité Workflow Designer de Windows Workflow Foundation. Cet outil s'intègre dans Visual Studio 2010 Professional Edition et fournit un environnement graphique pour organiser les activités en flux de travail. Les travailleurs de l'information, formant un groupe moins technique, peuvent utiliser Microsoft SharePoint Designer 2010 pour créer des flux de travail sans écrire de code. Les deux sections suivantes examinent comment des flux de travail peuvent être créés à l'aide de chacun de ces outils.

Création de flux de travail avec Visual Studio 2010 et Windows Workflow Foundation Workflow Designer

À de nombreux égards, un flux de travail s'apparente à un diagramme de flux. Il est donc logique de fournir un outil graphique qui permet aux développeurs de spécifier les actions d'un flux de travail. Il s'agit des outils de flux de travail SharePoint dans Visual Studio 2010 Professional, type de projet qui utilise Windows Workflow Foundation (WF) Designer et ajoute la prise en charge du déploiement et des formulaires pour les flux de travail SharePoint. Les développeurs peuvent utiliser WF Workflow Designer pour définir graphiquement les activités d'un flux de travail et leur ordre d'exécution. L'écran ci-dessous en présente l'aspect général dans Microsoft Visual Studio.

Flux de travail Recueillir les commentaires

Exemple de flux de travail Windows SharePoint Services

Les activités utilisables apparaissent dans la boîte à outils sur le côté gauche de l'écran. Un développeur peut faire glisser ces activités sur l'aire de conception pour définir les étapes d'un flux de travail. Les propriétés de chaque activité peuvent ensuite être définies dans la fenêtre Propriétés qui s'affiche dans le coin inférieur droit.

La bibliothèque BAL (Base Activity Library) de Windows Workflow Foundation fournit un groupe d'activités fondamentales, comme décrit plus haut. Microsoft SharePoint Foundation fournit également un ensemble d'activités expressément conçues pour créer des flux de travail. Parmi les plus importantes, citons notamment celles-ci :

  • OnWorkflowActivated : fournit un point de départ standard pour un flux de travail. Entre autres choses, cette activité peut accepter des informations fournies par un administrateur SharePoint à l'aide du formulaire d'association lorsque le flux de travail est associé à une bibliothèque de documents, une liste, un type de contenu ou un site. Elle peut également accepter des informations fournies par le formulaire de lancement au démarrage du flux de travail. Chaque flux de travail doit commencer par cette activité.

  • CreateTask : crée une tâche affectée à un utilisateur particulier dans une liste de tâches. Par exemple, le flux de travail d'approbation dans le scénario décrit précédemment a utilisé cette activité pour ajouter une tâche à la liste des tâches utilisée par chacun des participants. Cette activité a également une propriété SendEmailNotification qui, lorsqu'elle a la valeur True, envoie automatiquement un message électronique à la personne pour laquelle cette tâche a été créée.

  • OnTaskChanged : accepte des informations provenant du formulaire d'achèvement des tâches. Le flux de travail d'approbation dans le scénario antérieur a utilisé cette activité pour accepter l'entrée de chaque participant lorsque le document a été approuvé.

  • CompleteTask : marque une tâche comme étant terminée.

  • DeleteTask : retire une tâche d'une liste des tâches.

  • OnWorkflowModified : accepte des informations du formulaire Modification, pouvant alors être utilisées pour modifier le comportement de cette instance du flux de travail. Si le créateur du flux de travail n'inclut pas d'instance de cette activité dans le flux de travail, ce flux de travail ne peut pas être modifié en cours d'exécution.

  • SendEmail : envoie un courrier électronique à la personne ou groupe de personnes spécifié.

  • LogToHistoryList : écrit des informations sur l'exécution du flux de travail dans une liste d'historique. Les informations dans cette liste permettent aux utilisateurs de voir où en est l'exécution d'un flux de travail, d'examiner l'historique d'un flux de travail après son exécution, etc. Pour permettre ce type de contrôle, l'auteur du flux de travail doit écrire des informations dans une liste d'historique à des points stratégiques de l'exécution du flux de travail. Comme il fournit son propre mécanisme de suivi des flux de travail, Microsoft SharePoint Foundation ne prend pas en charge le service de suivi standard de WF.

Un modèle classique de flux de travail relativement simple commence par une activité OnWorkflowActivated, puis utilise une activité CreateTask pour affecter une tâche à un participant dans le flux de travail. L'activité While standard de la bibliothèque BAL pourrait alors être utilisée pour attendre l'achèvement de la tâche par l'utilisateur. Pour savoir quand cela s'est produit (l'utilisateur effectue éventuellement plusieurs modifications à la tâche, puis active une case dans le formulaire d'achèvement de la tâche une fois qu'il a terminé), une activité OnTaskChanged s'exécute dans l'activité While, extrayant les informations que l'utilisateur a éventuellement entrées sur ce formulaire. Lorsque l'utilisateur a terminé la tâche, une activité CompleteTask pourrait s'exécuter, suivie d'une activité DeleteTask. Le flux de travail peut alors passer au participant suivant, en utilisant CreateTask pour lui affecter une tâche, etc. Évidemment, d'autres activités peuvent se produire, telles que l'envoi d'un courrier électronique, la consignation d'informations dans la liste d'historique, ou même l'inclusion d'une activité de code de bibliothèque BAL, ce qui autorise l'exécution d'un code arbitraire.

Toutes les activités fournies par SharePoint Foundation prévoient le fonctionnement des flux de travail dans l'environnement SharePoint. La logique métier implémentée par un flux de travail relève entièrement du créateur de ce flux de travail. En fait, un développeur créant un flux de travail est libre de créer et d'utiliser ses propres activités personnalisées : il ne doit pas nécessairement utiliser celles fournies par SharePoint Foundation et WF.

Comme il a été précisé plus haut, Windows Workflow Foundation prend en charge les flux de travail séquentiels, parallèles et de machine à état. Un flux de travail créé avec WF Workflow Designer peut également utiliser n'importe laquelle de ces options. Pour le permettre, SharePoint Foundation ajoute des types de projets à Visual Studio, un pour chacun de ces styles de flux de travail.

Quel que soit le style choisi, le développeur ne doit pas simplement définir la logique du flux de travail ; il doit également spécifier le formulaire .aspx qu'il doit utiliser. Pour cela, le développeur s'appuie sur un fichier nommé element.xml. Ce fichier fournit un modèle que le développeur remplit pour spécifier quel formulaire, le cas échéant, doit être affiché à chacun des quatre points auxquels un flux de travail est autorisé à le faire.

Un développeur doit effectuer un travail pour passer des informations entre un flux de travail et les formulaires .aspx qu'il utilise. L'espace de noms Microsoft.Windows.SharePoint.Workflow expose un modèle objet pour les développeurs. À l'aide des types dans cet espace de noms, le créateur d'un flux de travail Windows SharePoint Services peut passer des informations d'un formulaire .aspx au flux de travail et vice-versa.

Une fois qu'un flux de travail et ses formulaires ont été créés, le développeur doit les conditionner en une entité appelée composant fonctionnel. Un administrateur SharePoint doit alors installer ce composant fonctionnel, ce qui implique l'installation des assemblys du flux de travail dans le Global Assembly Cache du système cible. Le nouveau flux de travail sera alors visible par l'administrateur comme un modèle de flux de travail pouvant être associé à une bibliothèque de documents, une liste, un type de contenu ou un site.

Pour un développeur de logiciels, la création d'un flux de travail à l'aide de Visual Studio et de WF Workflow Designer n'est pas particulièrement difficile. Le développeur doit comprendre les spécificités d'un travail dans cet environnement, mais la plupart des activités lui sont déjà familières. Mais les développeurs de logiciels ne seront pas les seuls à souhaiter créer des flux de travail. Comme nous le précisons ci-dessous, même les personnes n'étant pas des développeurs professionnels peuvent créer des flux de travail à l'aide de Microsoft SharePoint Designer 2010

Création de flux de travail avec Microsoft SharePoint Designer 2010

Microsoft SharePoint Designer 2010 est une application distincte que vous pouvez télécharger gratuitement. Microsoft SharePoint Designer permet aux travailleurs de l'information et à d'autres personnes d'ajouter une logique d'application (implémentée sous forme de flux de travail) à des sites SharePoint. Cela constitue en soi un objectif très utile, mais Microsoft SharePoint Designer résout également un autre problème important. Si un développeur crée un flux de travail à l'aide de Visual Studio, ce flux de travail doit être déployé sur un serveur exécutant SharePoint Foundation comme toute autre fonctionnalité. Mais de nombreux administrateurs SharePoint n'autoriseront pas le déploiement d'un code arbitraire sur leurs serveurs, estimant que le risque de déstabilisation du système est trop grand. Cependant, la possibilité de créer une logique métier relativement simple liée à des documents et à des éléments de liste reste très utile, et c'est ce que recherchent de nombreux utilisateurs de SharePoint. En plus de permettre à des individus sans compétence technique de créer des flux de travail, Microsoft SharePoint Designer répond à ce problème en fournissant une méthode sécurisée pour définir et déployer une logique métier sur des serveurs exécutant SharePoint Foundation.

Les scénarios de flux de travail que Microsoft SharePoint Designer est destiné à gérer sont relativement différents de ceux traités par Visual Studio et WF Workflow Designer. Bien qu'il soit possible de créer des applications complexes, Microsoft SharePoint Designer permet surtout aux utilisateurs d'ajouter une logique métier à des sites SharePoint. Par exemple, supposons qu'un site contienne une liste qui permet à ses utilisateurs de soumettre des demandes de modification. Microsoft SharePoint Designer pourrait être utilisé pour créer un flux de travail qui informe automatiquement l'émetteur lorsque sa demande de modification est acceptée ou refusée. De même, un flux de travail personnalisé pourrait informer un groupe particulier d'utilisateurs lorsqu'un nouveau document est ajouté à une bibliothèque de documents particulière. L'exécution de ce type de notification personnalisée n'est pas compliquée (la création de flux de travail est facile), mais cela constitue quand même un défi avec les versions antérieures de SharePoint Foundation en raison de la résistance de l'administrateur à installer du code écrit par l'utilisateur.

Une question évidente : pourquoi une logique créée avec Microsoft SharePoint Designer est-elle traitée différemment ? Pourquoi les administrateurs SharePoint accepteront-ils de déployer sur les systèmes dont ils sont responsables des flux de travail construits avec cet outil ? La réponse est que les flux de travail construits avec Microsoft SharePoint Designer peuvent uniquement utiliser des activités provenant d'une liste contrôlée par un administrateur. En plus des activités fournies par SharePoint Foundation, un administrateur de sites peut décider s'il convient d'inclure dans cette liste des activités personnalisées créées par un développeur. En définissant exactement ce que les flux de travail sont autorisés à faire, un administrateur SharePoint craindra moins que le déploiement d'une logique créée à l'aide de Microsoft SharePoint Designer ne déstabilise son système.

Comme il est destiné aux travailleurs de l'information et non aux développeurs et puisqu'il implique des scénarios plus simples, Microsoft SharePoint Designer utilise un modèle différent pour la création de flux de travail que celui de WF Workflow Designer, hébergé dans Visual Studio. Au lieu d'une approche graphique, Microsoft SharePoint Designer utilise une approche basée sur des règles. Il s'apparente à l'Assistant Règles dans Microsoft Outlook, outil bien connu par de nombreuses personnes. L'écran ci-dessous illustre la définition d'une étape d'un flux de travail par un utilisateur de Microsoft SharePoint Designer. Comme vous pouvez le constater, ce flux de travail exécute certaines actions en parallèle, d'autres en série. Les versions antérieures de SharePoint Foundation prenaient en charge l'exécution des actions uniquement en série ; les actions étaient uniquement exécutées les unes après les autres.

Flux de travail Traiter la commande

Chaque étape peut avoir une condition et une action. La condition détermine si l'action de cette étape doit être exécutée, comme dans l'instruction If présentée ci-dessus. Les choix d'actions incluent notamment l'affectation d'un animateur à un événement, la collecte d'une approbation, etc. Chacune de ces actions est exécutée par une activité SharePoint Foundation et les activités utilisées ici sont les mêmes qu'avec Visual Studio et WF Workflow Designer. La liste d'actions peut également inclure toute autre activité autorisée par l'administrateur SharePoint pour ce site, notamment des activités personnalisées créées par des développeurs.

Bien que son interface utilisateur soit assez différente de l'approche graphique employée avec Visual Studio et WF Workflow Designer, Microsoft SharePoint Designer crée un flux de travail WF standard. Cela produit en fait un flux de travail séquentiel et/ou parallèle avec des conditions exprimées à l'aide du moteur de règles WF. Les flux de travail créés avec cet outil présentent toutefois certaines restrictions. Par exemple, ils ne peuvent pas être modifiés en cours d'exécution, contrairement à ceux construits à l'aide de Visual Studio et WF Workflow Designer, et seuls des flux de travail séquentiels et parallèles peuvent être créés, les flux de travail de machine à état ne sont pas pris en charge. En outre, les flux de travail construits avec cet outil peuvent être créés par rapport à une bibliothèque de documents, une liste ou un site spécifique lors de leur conception. Les créateurs de flux de travail peuvent également créer un modèle de flux de travail général pouvant être ultérieurement associé à toute bibliothèque, toute liste ou tout type de contenu. Bien que cela entraîne des restrictions sur les possibilités d'utilisation d'un flux de travail, cela simplifie considérablement son déploiement. En fait, lorsqu'un utilisateur termine la création d'un flux de travail avec Microsoft SharePoint Designer, l'outil permet de déployer le flux de travail sur le site cible d'un simple clic, ce qui inclut l'activation du flux de travail. Cela est considérablement moins complexe que le processus de déploiement à étapes multiples requis pour les flux de travail créés à l'aide de Visual Studio et WF Workflow Designer.

Les flux de travail créés à l'aide de Microsoft SharePoint Designer peuvent également afficher des formulaires personnalisés. Toutefois, au lieu d'imposer aux auteurs la création de pages .aspx directement, l'outil génère ces pages. L'auteur spécifie l'aspect détaillé des pages générées, par exemple le contenu des différents champs, et Microsoft SharePoint Designer se charge du reste. Parmi les quatre points du cycle de vie d'un flux de travail où des formulaires peuvent être utilisés, seulement deux sont toutefois utilisés avec les flux de travail créés à l'aide de Microsoft SharePoint Designer : Lancement et Achèvement de tâche. Comme chaque flux de travail créé avec cet outil doit être associé à une bibliothèque de documents, une liste, un type de contenu ou un site spécifique, aucune étape d'association n'est donc nécessaire, ni aucun formulaire d'association. Et comme ces flux de travail ne peuvent pas être modifiés en cours d'exécution aucun formulaire Modification n'est nécessaire.

Microsoft SharePoint Designer offre également la possibilité d'importer les flux de travail créés à l'aide de Microsoft Visio 2010. Cela permet aux business managers ou aux auteurs de flux de travail de créer la logique du flux de travail à l'aide d'un environnement graphique familier. Un auteur de flux de travail peut ensuite importer la logique du flux de travail dans Microsoft SharePoint Designer, la modifier au besoin, puis la publier sur un site SharePoint.

SharePoint Foundation fournit beaucoup de fonctionnalités pour la création de flux de travail orientés documents. Il constitue également une plateforme de développement et d'exécution. Il ne fournit intrinsèquement aucune fonctionnalité de flux de travail directement utilisable par des utilisateurs finaux. Les flux de travail exécutés sur SharePoint Foundation présentent également d'autres restrictions, comme l'incapacité d'interagir avec des participants à l'aide d'applications clientes Office.

Comparaison des outils de création

Le tableau suivant montre les différences importantes entre les outils que Microsoft prend en charge pour la création de flux de travail dans SharePoint Foundation à l'aide de SharePoint Designer et WF Workflow Designer dans Visual Studio 2010 Professional Edition.

Fonctionnalité/contrainte | SharePoint Designer | WF Workflow Designer dans Visual Studio
Les flux de travail ne peuvent-ils être créés qu'à l'aide d'actions approuvées par les administrateurs de sites ? | Oui | Non
Les flux de travail sont-ils accessibles dans les applications clientes (autres que le navigateur) ? | Oui | Oui
Est-il possible d'utiliser Microsoft Visio Professional pour créer une logique de flux de travail ? | Oui | Non
Est-il nécessaire d'écrire du code ? | Non | Oui
Des activités supplémentaires (autres que celles fournies par SharePoint Foundation) sont-elles fournies ? | Non | Oui
Est-il possible de créer des activités personnalisées ? | Non | Oui
Le flux de travail peut-il être modifié en cours d'exécution ? | Non | Oui
Est-il possible de publier les flux de travail d'un simple clic ? | Oui | Oui
Les flux de travail peuvent-ils être déployés à distance ? | Oui | Non
Est-il possible de rendre les flux de travail disponibles dans l'ensemble de la batterie de serveurs ? | Non | Oui
Leur étendue peut-elle être définie au niveau d'une collection de sites ? | Oui | Oui

Historique des modifications


Planifier la gestion de la sécurité et des utilisateurs des flux de travail (SharePoint Foundation 2010)

Avant de déployer des flux de travail dans Microsoft SharePoint Foundation 2010 pour des utilisateurs, les administrateurs peuvent avoir des craintes concernant les problèmes de sécurité, tels que la divulgation d'informations ou l'élévation de privilège. Cet article souligne certains aspects du comportement des flux de travail relatifs à la sécurité et présente d'autres problèmes que les administrateurs et les développeurs de flux de travail doivent considérer lorsqu'ils prévoient de configurer et de développer des flux de travail.

Dans cet article :

  • Rôles et responsabilités des gestionnaires de listes, des administrateurs et des développeurs

  • Exécution de flux de travail en tant qu'administrateur

  • Paramètres de configuration des flux de travail

  • Divulgation d'informations dans les historiques de tâches et de flux de travail

  • Attaques d'usurpation d'identité et de falsification dans les historiques des tâches et des flux de travail

  • Type Étape d'emprunt d'identité d'utilisateur pour les flux de travail déclaratifs

Rôles et responsabilités des gestionnaires de listes, des administrateurs et des développeurs

Voici quelques actions de flux de travail courantes et les responsabilités associées, qui expliquent le rôle des administrateurs et des développeurs dans l'exécution des flux de travail.

Développeurs de flux de travail

Développer la planification et le modèle des flux de travail Les développeurs de flux de travail sont responsables de la codage de l'assembly contenant la logique métier qui s'exécute sur un élément SharePoint. Cet assembly est appelé planification de flux de travail. Ils sont également responsables du conditionnement en package des formulaires et de l'assembly du flux de travail en fonctionnalité de flux de travail ou en modèle de flux de travail.

Administrateurs de site

Gérer les paramètres des flux de travail de l'administration centrale Les administrateurs de site peuvent contrôler les paramètres généraux des flux de travail, tels que les résultats des alertes de tâche et les paramètres des participants externes sur le site Web d'administration centrale de SharePoint.

Déployer des fonctionnalités de flux de travail Les administrateurs de site peuvent installer des fonctionnalités de flux de travail sur une collection de sites de façon à les rendre disponibles pour des associations.

Administrateurs de liste (toute personne disposant des autorisations Gérer les listes ou Concepteur Web)

Ajouter des flux de travail Les administrateurs de liste doivent associer (ajouter) un modèle de flux de travail à un type de liste ou de contenu, en fonction des besoins métiers du type de liste ou de contenu. Cette association rend le modèle de flux de travail disponible pour les utilisateurs, qui peuvent alors sélectionner des valeurs par défaut et des paramètres.

Supprimer des flux de travail Les administrateurs de liste peuvent supprimer des associations de flux de travail d'un type de liste ou de contenu, ou empêcher l'exécution de nouvelles instances.

Mettre fin à un flux de travail Si une instance de flux de travail échoue, les administrateurs de liste peuvent arrêter une instance de flux de travail en cours d'exécution, par exemple quand une instance de flux de travail produit une erreur ou ne démarre pas, à l'aide du lien Interrompre ce flux de travail sur la page État du flux de travail. Cette action est réservée aux administrateurs.

Exécution de flux de travail en tant qu'administrateur

Le concept de sécurité le plus important à connaître est que les flux de travail s'exécutent dans le cadre du compte système dans SharePoint Foundation 2010, via les paramètres de pool d'applications d'identité sur l'ordinateur et le domaine du serveur. Cela signifie que dans SharePoint Foundation 2010, les flux de travail ont des autorisations d'administrateur. Sur le serveur, les flux de travail ont les mêmes autorisations que le pool d'applications, qui a souvent des autorisations d'administrateur. Ces autorisations permettent aux flux de travail d'effectuer des actions que les utilisateurs ordinaires ne peuvent pas réaliser, telles que le routage d'un document vers un emplacement ou un centre des enregistrements spécifique, ou encore l'ajout d'un compte d'utilisateur au système.

Le fait que les flux de travail ont des autorisations d'administrateur ne peut pas être changé. C'est la responsabilité de la planification du flux de travail (c'est-à-dire le code du flux de travail) de détecter les actions des utilisateurs et, en fonction de ces actions, de continuer ou d'annuler les modifications, ou d'emprunter l'identité d'un utilisateur de façon à imiter les autorisations de cet utilisateur.

Lorsqu'ils déploient des flux de travail, les administrateurs doivent comprendre les actions qui seront effectuées par ces flux de travail, de façon à pouvoir évaluer les risques potentiels associés à l'élévation d'autorisation dans un flux de travail et à aider le développeur à réduire les risques de sécurité.

Paramètres de configuration des flux de travail

Certains paramètres de configuration de SharePoint Foundation 2010 doivent être définis par les administrateurs en fonction de leurs besoins en matière de sécurité.

Autorisations requises pour démarrer un flux de travail

En plus d'empêcher l'élévation des autorisations dans le code, les administrateurs de liste peuvent limiter le niveau d'autorisation requis pour démarrer un flux de travail lors du processus d'association. Les administrateurs peuvent choisir entre deux niveaux d'autorisation pour démarrer une association de flux de travail spécifique : Modifier l'élément ou Gérer les listes.

Le paramètre par défaut pour l'association d'un flux de travail est de permettre aux utilisateurs ayant les autorisations Modifier l'élément de démarrer manuellement un flux de travail. Cela signifie que tout utilisateur SharePoint Foundation 2010 authentifié sur la liste qui a des autorisations Modifier l'élément peut démarrer une instance de cette association de flux de travail. Si, lors de la création du flux de travail, l'administrateur choisit l'option de requérir que l'utilisateur dispose des autorisations Gérer les listes pour pouvoir démarrer le flux de travail, seuls les administrateurs de liste peuvent démarrer une instance de cette association.

Les flux de travail étant conçus pour être utilisés par des contributeurs standard, la plupart des flux de travail ne nécessitent pas la limitation à des autorisations Gérer les listes. Cependant, les administrateurs peuvent utiliser cette option pour des flux de travail tels qu'un flux de travail de suppression de documents, où l'administrateur veut que seules certaines personnes exécutent les actions de suppression.

Paramètres de l'administration centrale

Les paramètres suivants sont accessibles à partir de la page Administration centrale en cliquant sur Gestion des applications, puis en cliquant sur Gérer les applications Web dans la section Applications Web. Dans la page Applications Web, sélectionnez l'application Web à configurer, puis, dans le groupe GestionGérer du Ruban, cliquez sur Paramètres généraux et sélectionnez Flux de travail. La page Paramètres du flux de travail s'ouvre et affiche les paramètres suivants :

  • Flux de travail définis par l'utilisateur

  • Notifications des tâches du flux de travail

Activation des flux de travail définis par l'utilisateur

Par défaut, les flux de travail définis par l'utilisateur sont activés pour tous les sites sur l'application Web, comme l'indique la section Flux de travail définis par l'utilisateur de la page Paramètres du flux de travail. Lorsque cette option est sélectionnée, les utilisateurs peuvent définir des flux de travail dans un éditeur de flux de travail tel que l'éditeur de flux de travail de SharePoint Designer 2010. Les utilisateurs qui définissent ces flux de travail doivent avoir les autorisations Gérer les listes pour le site sur lequel ils déploient le flux de travail.

Notification de tâche pour les utilisateurs sans accès au site

Sur la page Paramètres du flux de travail, dans la section Notifications des tâches du flux de travail, vous pouvez définir des options pour l'envoi de notifications à propos des tâches de flux de travail en attente aux utilisateurs qui n'ont pas accès au site.

  • Utilisateurs internes

    Dans SharePoint Foundation 2010, il est possible de résoudre les noms des utilisateurs internes du service d'annuaire qui ne sont pas membres du site ou qui n'ont pas accès à cette tâche. Dans ce cas, un administrateur peut sélectionner l'option Voulez-vous que les utilisateurs internes sans accès au site reçoivent une alerte lorsqu'une tâche du flux de travail leur est attribuée ? dans la section Notifications des tâches du flux de travail pour spécifier si ces utilisateurs reçoivent une notification par courrier électronique. Cette option signifie que les utilisateurs sont alertés lorsqu'une tâche de flux de travail leur est affectée. Cette option est activée par défaut, et le message électronique reçu par les utilisateurs contient un lien sur lequel ils peuvent cliquer pour demander à accéder au site (les administrateurs doivent néanmoins leur accorder ce droit d'accès). Ce message peut également contenir des informations sur le document. Ces informations peuvent comprendre le titre du document et des instructions provenant du propriétaire du flux de travail. S'il existe des problèmes de divulgation d'informations liés à des utilisateurs internes qui ne sont pas membres du site, les administrateurs peuvent désactiver l'option Voulez-vous que les utilisateurs internes sans accès au site reçoivent une alerte lorsqu'une tâche du flux de travail leur est attribuée ?.

  • Utilisateurs externes

    Les utilisateurs externes qui ne sont pas dans le service d'annuaire, mais auxquels une adresse de messagerie SMTP correctement formée est attribuée peuvent néanmoins se voir affecter des tâches de flux de travail. Comme les utilisateurs externes accéderont difficilement au document, SharePoint Foundation 2010 comporte un paramètre, Voulez-vous autoriser les utilisateurs externes à participer au flux de travail en leur envoyant une copie de ce document ?, qui rend possible l'envoi par courrier électronique d'une notification de tâche aux utilisateurs externes, avec le document en pièce jointe. Lorsque cette option est activée, la tâche est attribuée au propriétaire du flux de travail, et l'utilisateur externe peut achever la réalisation de la tâche en envoyant un courrier électronique au propriétaire.

    Par défaut, l'option Voulez-vous autoriser les utilisateurs externes à participer au flux de travail en leur envoyant une copie de ce document ? est désactivée. Ce paramètre peut cependant être utile dans des situations qui nécessitent une participation externe, telle que l'approbation de documents commerciaux impliquant des clients externes. Les administrateurs qui activent ce paramètre (en sélectionnant Oui) doivent vérifier que la planification du flux de travail prend en charge ce paramètre relatif aux participants externes. Par exemple, lorsqu'une tâche est créée pour un utilisateur externe, le flux de travail personnalisé doit spécifier une adresse de messagerie dans la propriété OnBehalfEmail de l'objet SPWorkflowTaskProperties qui a été utilisé pour initialiser la tâche. Plusieurs flux de travail intégrés dans SharePoint Foundation 2010 prennent en charge ce paramètre.

    Les développeurs de flux de travail personnalisés qui veulent activer cette fonctionnalité doivent consulter les administrateurs pour déterminer s'il existe des risques de divulgation d'informations liés à l'envoi du document réel en pièce jointe d'un message électronique externe. Les administrateurs doivent évaluer les avantages et les risques lors de l'activation de ce paramètre.

Divulgation d'informations dans les historiques de tâches et de flux de travail

Les tâches et les éléments d'historique pouvant contenir des données sur les utilisateurs et les actions qu'ils effectuent sur des documents, les éléments sont susceptibles de divulguer des informations confidentielles. Par exemple, un flux de travail Approbation pour une promotion peut contenir des commentaires sur ces tâches, dont l'organisation veut que seuls le propriétaire du flux de travail et chaque participant de la tâche puisse les voir.

Les listes de tâches et les historiques sont des listes courantes dans un site. Par défaut, tous les lecteurs peuvent donc voir les éléments des tâches et des historiques. Les administrateurs et les développeurs doivent déterminer les informations qui ne peuvent pas être divulguées et décider s'il faut sécuriser les éléments des tâches et des historiques qui sont créés par le flux de travail.

La sécurisation de ces éléments peut être effectuée de plusieurs façons. Par exemple, les administrateurs peuvent définir des autorisations au niveau des listes. Si la divulgation doit être privée, c'est-à-dire non publique mais disponible pour un groupe de personnes spécifique, les administrateurs peuvent créer une nouvelle tâche ou un nouvel historique, et définir des autorisations pour la liste spécifiques à ce groupe. Si les administrateurs veulent que personne ne voie les événements des historiques sur une page d'état du flux de travail, ils peuvent supprimer les autorisations d'affichage de l'historique du flux de travail duquel une page d'état extrait ses informations. Les utilisateurs qui n'ont pas les autorisations pour afficher l'historique lui-même ou un élément de cet historique reçoivent une erreur d'accès refusé lorsqu'ils ouvrent une page d'état qui extrait des données de cet historique.

Si des restrictions plus fines sont requises, les développeurs de flux de travail peuvent définir des autorisations au niveau des éléments lorsqu'ils créent des tâches ou des éléments d'historique. L'activité CreateTask a une propriété SpecialPermissions qui ne donne que des autorisations spécifiées pour accéder à la tâche nouvellement créée. L'activité LogToHistoryList n'a pas de propriété semblable : pour définir des autorisations au niveau des éléments sur des éléments d'historique, les administrateurs doivent utiliser le modèle objet de SharePoint Foundation 2010. Les autorisations au niveau des éléments peuvent affecter négativement les performances et ne doivent être utilisées que lorsqu'elles sont nécessaires.

Les tâches et les éléments d'historique ne doivent pas être gérés de la même manière. Les administrateurs peuvent combiner et faire correspondre des autorisations au niveau des listes et des autorisations au niveau des éléments.

Attaques d'usurpation d'identité et de falsification dans les historiques des tâches et des flux de travail

Tout contributeur peut modifier des tâches ou des éléments d'historique s'il n'existe pas de restrictions sur ces listes. Cela signifie que des utilisateurs malveillants peuvent modifier des descriptions de tâche pour donner aux participants des instructions incorrectes ou pour leur demander de cliquer sur des liens malveillants. Pour modifier les résultats perçus d'un processus, des utilisateurs malveillants peuvent aussi ajouter des événements d'historique faux ou incorrects, ou ils peuvent modifier des événements d'historique existants pour les rendre faux ou incorrects.

Comme expliqué plus haut, les listes de tâches et les historiques sont des listes normales dans un site. Par défaut, il n'y a pas de restrictions d'autorisation sur les listes de tâches ou les historiques. Pour éviter les attaques d'usurpation d'identité et de falsification, les administrateurs doivent déterminer les vulnérabilités qui existent et choisir entre limiter l'accès aux colonnes d'une liste (par exemple, mettre en lecture seule les colonnes vulnérables, telles que les descriptions des tâches, de sorte que seul le flux de travail puisse les définir lors de la création de l'élément), définir des autorisations spéciales sur la liste ou définir des autorisations au niveau des éléments d'une liste.

Problèmes de sécurité dans l'historique des flux de travail

Un avantage important des flux de travail est la possibilité de faire le suivi des informations des processus, de façon à offrir une visibilité dans les processus. L'historique du flux de travail est un référentiel pour ces informations, où une page d'état de flux de travail peut rechercher des données relatives à une instance de flux de travail et peut rendre ces informations disponibles pour les utilisateurs. Les utilisateurs peuvent voir tous les éléments auxquels ils ont accès dans l'historique.

Cependant, l'historique de flux de travail effectuant un suivi des informations, les utilisateurs peuvent supposer qu'il peut être utilisé en tant que piste d'audit pour les événements. Ce n'est pas le cas : l'historique de flux de travail n'est pas une fonctionnalité de sécurité. Les historiques sont des listes SharePoint standard utilisées pour stocker des événements qui sont visibles par tous les utilisateurs et auxquelles aucune autorisation spéciale n'est associée. Par défaut, les utilisateurs peuvent modifier et ajouter des événements s'ils ont des autorisations de modification et d'ajout sur le site. Pour auditer les événements, utilisez la fonctionnalité Journal d'audit de SharePoint. Seuls les administrateurs peuvent accéder à ce journal, qui ne requiert pas de travail supplémentaire pour être protégé des attaques de falsification.

Pour mieux protéger l'historique, les administrateurs peuvent limiter les autorisations de modification et d'ajout à la liste, de sorte que seuls les administrateurs du compte système (par exemple des administrateurs de flux de travail) et des administrateurs de liste puissent ajouter des éléments. Les administrateurs de liste doivent avoir des autorisations d'ajout pour consigner des événements « Interrompre ce flux de travail ». Si les autorisations de modification et d'ajout sont limitées sur l'historique, les utilisateurs doivent recevoir des autorisations d'affichage pour pouvoir afficher les informations d'état.

Type Étape d'emprunt d'identité d'utilisateur pour les flux de travail déclaratifs

Le type Étape d'emprunt d'identité d'utilisateur peut être utilisé pour exécuter des sections de flux de travail déclaratifs par la personne qui a créé le flux de travail plutôt que par l'initiateur du flux de travail. Déclaratif signifie un modèle que vous utilisez pour créer le flux de travail et définir les paramètres pour le flux de travail sans écrire de code.

Dans SharePoint Foundation 2010, les flux de travail déclaratifs s'exécutent toujours dans le contexte utilisateur de l'initiateur du flux de travail, sauf si une étape d'emprunt d'identité est rencontrée. Dans ce cas, le flux de travail déclaratif est exécuté dans le contexte de l'associateur du flux de travail. Les tâches de flux de travail par défaut respectent les autorisations SharePoint en empruntant l'identité de l'utilisateur qui a démarré un flux de travail lorsque le flux de travail est exécuté. Cette implémentation permet de conserver un bon niveau de sécurité dans SharePoint Foundation 2010, mais bloque certains scénarios où un concepteur de flux de travail avec des autorisations élevées veut créer un flux de travail puissant qui peut être effectué avec succès par des utilisateurs qui ont des autorisations d'un niveau moins élevé.

Grâce une forme sécurisée et étendue d'élévation de privilège, les actions de site peuvent être automatisées à travers le flux de travail. Ceci réduit la charge d'un administrateur de site SharePoint. L'automatisation d'un processus de haute sécurité est utile dans les scénarios de publication et d'approbation dans lesquels des actions existantes sont autorisées à emprunter l'identité de quelqu'un d'autre que l'initiateur du flux de travail.

Voici des exemples de scénarios qui montrent le type Étape d'emprunt d'identité d'utilisateur :

  • Publier vers une liste sécurisée

    Jacqueline a verrouillé la bibliothèque de documents Pages pour la partie publique de son site SharePoint. Elle a configuré un flux de travail Approbation qui, en utilisant Microsoft SharePoint Designer 2010, envoie pour approbation du contenu provenant de contributeurs du site. Jacqueline place les actions de son flux de travail dans une étape d'emprunt d'identité pour que ces actions empruntent toujours sa propre identité (administrateur du site) en tant qu'auteur du flux de travail.

    Lorsque Corine (une contributrice) envoie le brouillon d'un contenu dans la bibliothèque de documents Pages du site et tente de publier son article, cette action provoque le démarrage du flux de travail Approbation de Jacqueline, qui permet la relecture et l'approbation de l'envoi. Les tâches sont envoyées aux approbateurs du flux de travail pour le compte de Corine. Après relecture et approbation par les approbateurs, le système donne la valeur « Approuvé » à l'état de modération de l'envoi, même si Corine n'a pas l'autorisation d'approuver des pages.

  • Accorder des autorisations à des utilisateurs

    Joëlle a configuré un flux de travail dans SharePoint Designer 2010, qui utilise une action d'emprunt d'identité d'utilisateur « Ajouter un utilisateur au groupe » pour accorder des autorisations de conception pour son site. Le flux de travail utilisant une possibilité d'emprunt d'identité, l'action d'ajout d'un utilisateur au groupe sera toujours effectuée pour le compte de Joëlle.

    Le reste du flux de travail permet aux contributeurs de visiter le site et de remplir un formulaire pour enregistrer leur demande d'accès à une liste.

    Par exemple, un utilisateur distinct, Olivier, reçoit une tâche lorsque Corine, une utilisatrice, enregistre une demande et, lorsqu'il approuve la tâche, Corine est ajoutée au groupe Concepteur pour le site, même si ni Olivier ni Corine n'ont les autorisations Gérer les listes sur le site de Joëlle.

  • Modèles et acquisition de propriété

    William a créé plusieurs flux de travail dans SharePoint Designer 2010 et les a enregistrés en tant que modèles pour qu'ils puissent être réutilisés dans toute la société, mais il quitte peu après la société. Son compte est supprimé, son statut d'administrateur est révoqué et maintenant, l'exécution des flux de travail SharePoint Designer 2010 que William a créés échoue en raison de la perte des autorisations de William.

    Un administrateur du site SharePoint parent, Jean, peut intervenir pour chaque flux de travail, sans avoir à recréer les flux de travail dans SharePoint Designer 2010. Jean prend la propriété des éléments relevant de l'administration dans chaque modèle concerné. Après cela, la publication sécurisée et l'attribution des autorisations d'accès se font sous le nom de Jean au lieu de celui de William ; rien d'autre n'a changé.

Voici des actions de flux de travail qui peuvent faire l'objet d'emprunts d'identité :

  • Définir le statut d'approbation du contenu (en tant que propriétaire)

  • Créer un élément dans la liste (en tant que propriétaire)

  • Mettre à jour l'élément de la liste (en tant que propriétaire)

  • Supprimer les éléments d'une liste (en tant que propriétaire)

  • Ajouter/supprimer/définir/hériter des autorisations pour un élément d'une liste (en tant que propriétaire)

En tant qu'administrateur SharePoint, vous devez considérer les effets possibles sur la sécurité de l'incorporation de l'emprunt d'identité dans des flux de travail sur le site SharePoint. Ceci s'applique non seulement aux nouvelles actions mais aussi aux actions existantes, telles que la mise à jour des éléments d'une liste.

Par exemple, considérez un modèle dans lequel des actions d'emprunt d'identité d'utilisateur du flux de travail peuvent encore s'exécuter en tant qu'initiateur. Si un utilisateur a des autorisations d'administrateur sur un seul des sites de la collection de sites, cet utilisateur, s'il était malveillant, pourrait créer un flux de travail pour obtenir des droits sur le site Web parent du site. Tout ce qu'il aurait à faire serait de persuader l'administrateur de charger un fichier dans une bibliothèque de documents sur le site de l'utilisateur malveillant pour commencer une attaque du flux de travail et compromettre tout le site Web parent du site.

Ce risque a incité à développer la restriction selon laquelle « les actions d'emprunt d'identité d'utilisateur empruntent toujours l'identité de leur associateur » dans SharePoint Designer 2010. L'associateur est la personne qui associe un flux de travail à une liste ou un site Web particulier. Dans les flux de travail déclaratifs de SharePoint Foundation 2010, l'associateur est la même personne que l'auteur du flux de travail, c'est-à-dire l'utilisateur qui a créé le flux de travail dans SharePoint Designer 2010. Cependant, l'associateur peut aussi être quelqu'un qui associe un modèle de flux de travail déclaratif. Le problème est maintenant que l'auteur/associateur est forcé d'accepter la responsabilité pour tout ce qui peut se produire à cause d'un type Étape d'emprunt d'identité d'utilisateur, car les informations d'identification de l'auteur/associateur seront utilisées dans l'élévation. Ceci requiert que les auteurs/associateurs comprennent les flux de travail qu'ils conçoivent ou qu'ils associent. Lors de la création d'un flux de travail, SharePoint Designer 2010 affiche donc, sur la page de création du flux de travail, un message de mise en garde destiné à l'auteur/associateur à propos du type Étape d'emprunt d'identité d'utilisateur.

Historique des modifications


Flux de travail d'approbation : un scénario (SharePoint Foundation 2010)

Dans la plupart des organisations, l'exemple le plus courant de flux de travail humain est une variante d'approbation : un groupe de personnes doit approuver ou rejeter un certain document, en ajoutant peut-être des commentaires justifiant leur décision. Cet article explique comment un flux de travail de type approbation qui est créé dans SharePoint Designer 2010 ou dans Concepteur de flux de travail de Visual Studio 2010 et qui est ensuite hébergé à l'aide de SharePoint Foundation 2010 peut se présenter. Avant de lire cet exemple, il est utile de définir les rôles des différentes personnes.

  • Auteur du flux de travail Développeur ou travailleur de l'information qui crée un modèle de flux de travail.

  • Administrateur SharePoint Foundation 2010 Personne qui installe un modèle de flux de travail et l'associe à une bibliothèque de documents ou à une liste.

  • Initiateur du flux de travail Personne qui démarre un flux de travail, entraînant la création d'une instance de flux de travail à partir d'une association de flux de travail particulière.

  • Participants au flux de travail Personnes qui interagissent avec une instance de flux de travail pour effectuer le processus métier qu'elle prend en charge.

Comme le décrit la section suivante, chacune de ces personnes a son propre rôle à jouer dans la création, l'installation, le démarrage et l'utilisation d'un flux de travail.

Création d'un flux de travail

Microsoft fournit deux options de création de flux de travail dans SharePoint Foundation 2010. Les développeurs utilisent Visual Studio 2010 et Concepteur de flux de travail, tandis que les travailleurs de l'information utilisent une approche basée sur des règles fournie par SharePoint Designer 2010. Dans les deux cas, le résultat est un modèle de flux de travail qui doit être déployé sur un serveur exécutant SharePoint Foundation 2010. Ce scénario suppose qu'un modèle de flux de travail a déjà été créé.

Association d'un flux de travail

Pour pouvoir utiliser un flux de travail, vous devez d'abord installer un modèle de flux de travail sur un serveur qui exécute SharePoint Foundation 2010, puis associer le flux de travail à une bibliothèque de documents, une liste ou un type de contenu particulier ou (dans le cas d'un flux de travail de site) à un site. Vous pouvez ensuite démarrer le flux de travail à partir d'un document ou d'un élément quelconque de cette bibliothèque ou de cette liste. Bien qu'il soit impossible de démarrer explicitement un flux de travail à partir des types de contenu, un flux de travail associé à un type de contenu peut être démarré à partir d'un document ou d'un élément de liste auquel ce type de contenu est associé. Comme les flux de travail fonctionnent de la même manière sur les éléments et sur les documents, un modèle de flux de travail peut généralement être associé à une liste, à une bibliothèque ou à un type de contenu. Vous pouvez également créer un modèle qui peut être associé uniquement à une liste ou à une bibliothèque particulière.

L'installation et l'association des flux de travail déployés avec SharePoint Designer 2010 sont toutes les deux automatiques. Cependant, si vous utilisez Visual Studio pour déployer des flux de travail, un administrateur de serveur doit installer explicitement le modèle de flux de travail. De plus, un utilisateur doit associer le modèle à une bibliothèque, à une liste, à un type de contenu ou à un site. Quiconque crée cette association lui attribue également un nom unique afin que d'autres utilisateurs puissent la référencer. L'auteur du flux de travail peut également permettre au créateur de l'association de définir des options de comportement pour le flux de travail, comme spécifier une liste par défaut des personnes susceptibles de participer au processus à tout moment. Le même modèle peut être associé à plusieurs bibliothèques, listes ou types de contenu, et chaque association peut être personnalisée en fonction des besoins. Une fois l'association créée et les options définies, l'initiateur du flux de travail peut créer une instance de flux de travail à partir de cette association, comme décrit dans la section suivante.

Association d'un flux de travail à un site

Les flux de travail de site sont associés au site lui-même. Il n'est pas nécessaire de démarrer un élément pour exécuter le flux de travail.

Vous pouvez utiliser des flux de travail de site pour les processus dépourvus d'un contexte d'élément de liste. Par exemple, vous pouvez créer un flux de travail pour demander des autorisations pour le site, un flux de travail pour demander et mettre en service un nouveau site ou un flux de travail qui utilise le contexte stocké en dehors du site SharePoint, sans avoir à créer un élément de liste SharePoint correspondant à partir duquel démarrer le flux de travail.

Les flux de travail de site peuvent être associés à un site par le biais des paramètres du site et peuvent être démarrés sur le site proprement dit. SharePoint Designer 2010 peut également déployer les flux de travail de site directement sur un site.

Les flux de travail de site fonctionnent de la même manière que les éléments de liste, comme décrit plus haut dans cet article, à la différence que les flux de travail de site ne peuvent pas être démarrés à partir d'un document ou d'un élément dans une bibliothèque ou une liste.

Pour plus d'informations, voir Ajouter une association de flux de travail (SharePoint Foundation 2010).

Démarrer un flux de travail

SharePoint Foundation 2010 fournit trois options pour démarrer une instance d'un flux de travail. Les trois options exécutent toutes à chaque fois le flux de travail depuis le début. (Si une instance d'un flux de travail créée à partir d'une association particulière est déjà en cours d'exécution sur un document ou un élément de liste particulier, il n'est pas possible de démarrer une autre instance du flux de travail sur le même document ou élément.) Voici les options de démarrage d'un flux de travail :

  • Un utilisateur de SharePoint Foundation 2010 peut démarrer manuellement un flux de travail.

  • Vous pouvez configurer un flux de travail pour qu'il s'exécute automatiquement lorsqu'un utilisateur crée un document ou un élément.

  • Vous pouvez configurer un flux de travail pour qu'il s'exécute automatiquement lorsqu'un utilisateur modifie un document ou un élément.

Par exemple, un utilisateur Microsoft Word peut télécharger un nouveau document dans une bibliothèque de documents d'un site. Cette opération entraîne le démarrage d'une instance d'un flux de travail qui est associé à cette bibliothèque.

Ce scénario utilise la première de ces trois options : le démarrage manuel d'un flux de travail Approbation pour un document. Pour démarrer une instance de flux de travail à partir d'un document dans une bibliothèque de documents, un utilisateur SharePoint Foundation 2010 procède comme suit :

  1. Il pointe sur le document et sélectionne Flux de travail dans le menu déroulant.

  2. Il sélectionne le flux de travail à démarrer.

    Cet exemple suppose qu'un flux de travail qui achemine le document pour approbation a été créé.

Lorsqu'un flux de travail démarre (autrement dit, à la création d'une instance de flux de travail), il peut afficher un écran permettant à un utilisateur de spécifier des informations. Pour un flux de travail qui achemine un document pour approbation, ces informations peuvent inclure le nom de chaque personne qui doit approuver le document, une indication d'échéance pour chaque approbation et la liste des personnes à avertir. Une fois ces informations fournies, l'utilisateur clique sur Démarrer. Le flux de travail commence à s'exécuter et demande à chacun des participants de réviser le document, dans l'ordre où ceux-ci ont été entrés sur cet écran.

Lorsqu'un flux de travail démarre, il peut également envoyer un message électronique à la personne l'ayant démarré. De la même manière, un flux de travail peut avertir son créateur par courrier électronique lorsqu'il est terminé. Vous pouvez également configurer le flux de travail de manière à avertir par courrier électronique les participants — dans cet exemple, les personnes qui approuvent le document — que le flux de travail comporte une tâche à leur intention.

Interaction avec un flux de travail

Le concept des tâches modélise l'interaction entre une personne et un flux de travail en cours d'exécution. Une tâche est une unité de travail affectée à un individu. Par exemple, à chaque personne de la liste d'approbation de ce flux de travail sera affectée une tâche demandant d'approuver le document. SharePoint Foundation 2010 peut avoir une liste de tâches pour chaque site, et un flux de travail en cours d'exécution peut y ajouter des tâches et préciser la ou les personnes affectées à chaque tâche. Les utilisateurs de ce site peuvent consulter le travail qui les attend en accédant à leur liste de tâches via un navigateur Web. Éventuellement, vous pouvez disposer d'une liste de tâches personnalisée limitée aux tâches du flux de travail qui vous sont destinées.

Pour un utilisateur SharePoint Foundation 2010, la liste des tâches en attente est simplement une autre liste. Dans cet exemple, l'utilisateur accède au site SharePoint d'équipe et sélectionne l'option permettant d'afficher la liste des tâches qui lui sont affectées. Pour travailler sur une tâche, dans cet exemple, l'utilisateur clique sur le nom de la tâche.

La façon dont un flux de travail interagit avec les participants pouvant varier, le flux de travail définit l'écran qui s'affiche à l'utilisateur. Dans cet exemple, le flux de travail fournit des options pour approuver ou rejeter le document et une zone de texte dans laquelle les participants peuvent taper des commentaires.

D'autres options sont disponibles, permettant aux utilisateurs de réaffecter la tâche à une autre personne ou de demander une modification. Ici, l'utilisateur peut entrer un commentaire, puis cliquer sur Approuver. Le flux de travail crée ensuite une tâche dans la liste des tâches de la personne suivante de la liste des approbateurs. Une fois que tous les participants ont répondu, le flux de travail est terminé.

En outre, les flux de travail SharePoint Foundation 2010 offrent d'autres options, notamment les suivantes:

  • L'initiateur d'un flux de travail peut vérifier le statut de celui-ci.

    Par exemple, dans le scénario décrit ici, l'initiateur peut vérifier la progression du processus d'approbation.

  • Un flux de travail peut être modifié pendant son exécution.

    L'auteur du flux de travail détermine les modifications autorisées, le cas échéant. Par exemple, un flux de travail Approbation peut autoriser l'ajout d'un nouvel approbateur alors que le flux de travail a démarré. La possibilité de modifier les flux de travail en cours est importante, car elle reflète la manière dont les gens travaillent en réalité. Les changements spontanés des processus métiers faisant partie de la vie au sein de toute entreprise, les flux de travail SharePoint Foundation 2010 ont été conçus pour permettre aux utilisateurs de gérer ces situations.

Synthèse du processus

Lorsqu'un modèle de flux de travail est installé sur un site et associé à une bibliothèque de documents, à une liste, à un site ou à un type de contenu, un utilisateur du site peut démarrer une instance d'un flux de travail.

  1. Le processus démarre lorsque l'initiateur du flux de travail sélectionne un document et démarre une instance d'un flux de travail.

  2. L'initiateur crée une instance de flux de travail à partir de cette association.

  3. L'utilisateur personnalise cette nouvelle instance et la démarre.

  4. L'instance de flux de travail en cours d'exécution ajoute une tâche à la liste des tâches d'un participant.

    Le flux de travail d'approbation utilisé dans ce scénario affecte ces tâches de manière séquentielle. Toutefois, vous pouvez affecter des tâches à un grand nombre de participants en même temps, ce qui permet leur exécution en parallèle.

  5. Les participants au flux de travail peuvent prendre connaissance des tâches que le flux de travail leur a affectées en consultant leur liste de tâches.

  6. Chaque participant interagit avec l'instance de flux de travail en cours d'exécution pour effectuer les tâches affectées.

    Dans l'exemple décrit ici, cette interaction consistait à approuver un document, mais elle peut consister en toute autre chose, en fonction du souhait de l'auteur du flux de travail.

Il est important de noter que le document sur lequel un flux de travail est exécuté n'est pas lui-même envoyé d'une personne à l'autre. Il reste sur le site et chaque participant au flux de travail reçoit un lien vers le document. En fait, il n'est pas indispensable que le flux de travail utilise le document ou l'élément auquel il est associé. Par ailleurs, il est également important de noter que ce qui est affiché à l'initiateur du flux de travail et aux participants à celui-ci aux étapes 1, 2 et 5 est défini par SharePoint Foundation 2010. Les pages Web ASPX utilisées aux étapes 3 et 6, en revanche, sont définies par l'auteur du flux de travail. Ceci lui permet de contrôler comment les utilisateurs personnalisent le flux de travail et interagissent avec celui-ci.

Historique des modifications


Création et maintenance du plan de site (SharePoint Foundation 2010)

Si vous envisagez plusieurs collections de sites dans votre environnement Microsoft SharePoint Foundation 2010, vous devez vous assurer de disposer d'un plan pour la création et la maintenance des sites. Sans ce plan, il est difficile de contrôler ou suivre la date de création des sites SharePoint, si les sites sont toujours actifs, et le moment où vous pouvez supprimer en toute sécurité des sites inactifs. Avant de déployer les sites et de les rendre accessibles aux utilisateurs, répondez aux questions suivantes :

  • Voulez-vous contrôler étroitement la création de sites ou laisser de nombreux utilisateurs créer des sites ?

  • À quel niveau de la hiérarchie du site des sites supplémentaires doivent-ils être créés ?

  • Comment rechercher et supprimer les sites inutilisés dans votre environnement ?

Les articles et feuilles suivants vous aident à concevoir et à enregistrer un plan de création et de maintenance de sites. Ceci vous permettra d'être prêt à gérer la croissance de votre environnement.

Dans cette section :

  • Planification du processus de création des sites (SharePoint Foundation 2010)

    Explique comment déterminer le type de processus de création de sites adapté à votre organisation et la méthode à utiliser pour implémenter ce processus.

  • Gestion et maintenance du plan de site (SharePoint Foundation 2010)

    Explique comment planifier la maintenance de vos sites SharePoint dès le départ pour vous assurer que vos sites restent à jour, utiles et exploitables.

  • Planifier la gestion des quotas (SharePoint Foundation 2010)

    Fournit des informations qui vous aident à déterminer les paramètres des modèles de quota et des corbeilles, ainsi qu'à décider de l'opportunité ou du calendrier de la suppression des sites Web inutilisés.

Historique des modifications

Date | Description | Raison
4 juin 2010 | Publication initiale |


Planification du processus de création des sites (SharePoint Foundation 2010)

Certaines organisations doivent contrôler étroitement les utilisateurs autorisés à créer des sites ou le moment auquel les sites sont créés. D'autres organisations peuvent accorder aux utilisateurs plus d'accès et de liberté en matière de création de sites. Cet article vous aide à déterminer le type de processus de création de sites adapté à votre organisation et la méthode à utiliser pour implémenter ce processus.

Dans cet article :

  • Déterminer qui peut créer des sites et une méthode de création de sites

  • Planifier la gestion de sites libre-service

  • Planifier des processus de création de sites personnalisés

  • Feuille

Déterminer qui peut créer des sites et une méthode de création de sites

Par défaut, les nouvelles collections de sites (et par conséquent les nouveaux sites Web de niveau supérieur) peuvent uniquement être créées à l'aide de l'Administration centrale, ce qui signifie qu'elles peuvent uniquement être créées par les membres du groupe Administrateurs de batterie. Ce comportement peut convenir à votre organisation si vous souhaitez mettre en place un environnement étroitement contrôlé et géré ; dans ce cas, seules quelques personnes sont autorisées à ajouter des sites de niveau supérieur. Toutefois, la méthode de création de sites de niveau supérieur par défaut peut ne pas être adaptée à votre organisation si l'une des conditions suivantes se vérifie :

  • Vous souhaitez que les utilisateurs puissent créer facilement des sites de niveau supérieur informels voire ponctuels (par exemple pour des projets à court terme).

  • Vous souhaitez créer un espace informel pour l'interaction de l'équipe, du groupe ou de la communauté.

  • Vous hébergez des sites de niveau supérieur (en interne ou en externe) et vous souhaitez que le processus de demande et réception d'un site de niveau supérieur soit aussi rapide et économique que possible.

Vous disposez de plusieurs méthodes pour autoriser les utilisateurs à créer leurs propres sites tout en conservant un certain contrôle sur votre environnement. Parmi les méthodes suivantes, déterminez celle qui est la mieux adaptée à votre organisation.

  • Gestion de sites libre-service Dans l'Administration centrale, vous pouvez activer la Gestion de sites libre-service pour permettre aux utilisateurs de créer des collections de sites sous le chemin d'accès /sites (ou un autre chemin d'accès que vous spécifiez) dans une application Web particulière. Cette méthode est communément utilisée pour autoriser des groupes ou des communautés à créer des sites. Elle fonctionne également bien si vous hébergez des sites et que vous souhaitez permettre aux utilisateurs de créer des sites sans attendre un processus complexe. La page d'abonnement à la Gestion de sites libre-service peut être personnalisée ou remplacée par une page qui inclut l'ensemble des informations dont vous pouvez avoir besoin pour intégrer un système de facturation ou pour effectuer le suivi des métadonnées personnalisées sur le site au moment de la création. Cette méthode ne fonctionne pas correctement lorsqu'un grand nombre d'utilisateurs doit accéder à plusieurs sites. Dans la mesure où la Gestion de sites libre-service crée des collections de sites qui ont des autorisations distinctes, les utilisateurs doivent être ajoutés de manière unique à des collections de sites différentes. Si vous utilisez des sous-sites à la place, les utilisateurs peuvent être hérités du site parent dans la collection de sites. La recherche fonctionne dans une collection de sites spécifique. Par conséquent, si vous voulez que les utilisateurs puissent rechercher du contenu dans plusieurs sites, transformez les sites en sous-sites dans une collection de sites.

  • Sous-sites de sites existants Limitez les utilisateurs à la création de sous-sites de sites existants, plutôt qu'à de nouvelles collections de sites et des sites de niveau supérieur. Les utilisateurs possédant le niveau d'autorisation Contrôle total ou Gérer la hiérarchie sur un site existant peuvent créer un sous-site. Cette méthode est la plus limitée, car vous contrôlez encore le nombre de collections de sites. Étant donné que les sites sont toujours des sous-sites d'autres sites, ils peuvent être faciles à organiser (s'il en existe peu) ou très difficiles à organiser et à parcourir (par exemple, si tous les membres de votre organisation souhaitent un sous-site et le créent à différents niveaux de hiérarchie de la collection de sites, la collection de sites peut rapidement devenir très difficile à explorer).

    Remarque :
    Si vous ne souhaitez pas que les utilisateurs disposent de cette fonctionnalité, vous pouvez supprimer le droit Créer des sous-sites des niveaux d'autorisation Contrôle total et Gérer la hiérarchie, au niveau de la collection de sites ou de l'application Web.

Remarque :
Gardez à l'esprit qu'aucune de ces méthodes ne peut contrôler l'espace utilisé par chaque site dans vos bases de données de contenu. Pour contrôler la taille des sites, vous devez utiliser des quotas et définir une limite de taille pour les collections de sites. Vous ne pouvez pas définir de limites de taille individuelles pour des sous-sites. Pour plus d'informations, voir Gestion et maintenance du plan de site (SharePoint Foundation 2010).

Planifier la gestion de sites libre-service

La Gestion de sites libre-service permet aux utilisateurs de créer et de gérer automatiquement leurs propres sites Web de niveau supérieur. Lorsque vous activez la Gestion de sites libre-service pour une application Web, les utilisateurs peuvent créer leurs propres sites Web de niveau supérieur sous un chemin d'accès spécifique (par défaut, le chemin d'accès /sites). Lorsqu'elle est activée, cette fonctionnalité se publie elle-même avec une annonce ajoutée au site de niveau supérieur dans le chemin d'accès racine de l'application Web. Par conséquent, les utilisateurs qui disposent de l'autorisation nécessaire pour afficher cette annonce peuvent suivre le lien.

Remarque :
Si vous souhaitez utiliser un chemin d'accès autre que /sites pour la Gestion de sites libre-service, vous devez ajouter le chemin d'accès en tant qu'inclusion générique. Pour plus d'informations, voir Planification des sites de collaboration (SharePoint Foundation 2010).

Cette fonctionnalité peut évidemment affecter la sécurité de votre serveur Web. La Gestion de sites libre-service est désactivée par défaut ; vous devez l'activer pour l'utiliser. Vous activez la Gestion de sites libre-service pour une seule application Web à la fois. Si vous souhaitez l'utiliser sur toutes les applications Web de votre batterie, vous devez l'activer pour chaque application Web individuellement.

Si vous activez la Gestion de sites libre-service, vous devez prendre en compte les éléments suivants :

  • En règle générale, vous devez exiger un administrateur de collection de sites secondaire. Les alertes administratives, telles que celles indiquant que des quotas sont dépassés, ou de vérification des sites Web inutilisés, sont passées aux administrateurs principal et secondaire. Le recours à plusieurs contacts réduit l'implication des administrateurs dans ces sites, car le contact secondaire peut effectuer les tâches requises même si le contact primaire n'est pas disponible.

  • Définissez un quota de stockage en tant que quota par défaut pour l'application Web.

  • Passez en revue le nombre de sites autorisés par base de données de contenu. Combiné avec les quotas, ceci vous aidera à limiter la taille des bases de données dans votre système.

  • Activez les notifications de sites Web inutilisés, de sorte que les sites qui sont oubliés ou n'ont plus de valeur puissent être identifiés.

Dans la mesure où la Gestion de sites libre-service crée de nouveaux sites Web de niveau supérieur dans une application Web existante, les nouveaux sites se conforment automatiquement aux paramètres de quota par défaut de l'application Web, aux paramètres de notification de sites Web inutilisés et autres stratégies d'administration.

Planifier des processus de création de sites personnalisés

Vous pouvez bien entendu créer votre propre processus de création de sites à l'aide d'un formulaire personnalisé pour demander à un site qui s'intègre avec un système de facturation principal de débiter la carte de crédit d'un client ou un centre de coût de l'entreprise. Si vous disposez d'un système ou processus complexe que vous souhaitez inclure dans la création de sites, vous devez créer une application personnalisée pour appeler l'interface de création de sites et effectuer toute autre tâche dont vous avez besoin. Toutefois, si vous souhaitez simplement ajouter quelques champs personnalisés à la page de création de sites (par exemple, pour suivre le service de votre société qui demande un site particulier), vous devez utilisez la Gestion de sites libre-service et personnaliser la page d'abonnement pour inclure les informations dont vous avez besoin. Vous pouvez personnaliser la page Scsignup.aspx dans la définition de site pour inclure les métadonnées nécessaires sans avoir à développer une application entière.

Pour plus d'informations sur la création d'applications personnalisées ou la modification de pages dans une définition de site, voir le Portail pour développeurs SharePoint 2010 sur MSDN (http://go.microsoft.com/fwlink/?linkid=178818&clcid=0x40C).

Feuille

Utilisez la feuille suivante pour planifier le processus de création de sites :

  • Feuille relative à la création et à la maintenance de site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=193521&clcid=0x40C)

Historique des modifications

Date | Description | Raison
4 juin 2010 | Publication initiale |


Gestion et maintenance du plan de site (SharePoint Foundation 2010)

Au fil du temps, les sites Web deviennent encombrés, plus particulièrement lorsque ceux-ci ont plusieurs auteurs. Un examen et un nettoyage réguliers peuvent contribuer au bon fonctionnement de votre site, quelle que soit sa taille. Si, dès le début, vous élaborez un plan de maintenance pour votre ou vos sites, vous serez assuré qu'ils demeurent à jour, utiles et utilisables.

Dans cet article :

  • Planifier la maintenance des sites

  • Planifier la gestion des collections de sites

  • Feuille de calcul

Planifier la maintenance des sites

Votre plan de maintenance de sites sera différent de celui de n'importe quel autre environnement, et il sera constitué d'éléments différents. La maintenance de sites varie selon que les sites sont gérés par un service informatique ou qu'ils sont créés et gérés par des utilisateurs. Toutefois, il existe des meilleures pratiques en matière de maintenance de sites, à savoir :

  • Recueillir les desiderata des utilisateurs quant au contenu des sites gérés par le service informatique. Effectuer des enquêtes régulières pour savoir ce dont les utilisateurs ont besoin d'y trouver.

  • Utiliser des journaux et des rapports d'utilisation pour identifier les parties du site les plus utilisées, et rapprocher ces informations des enquêtes utilisateur pour déterminer ce qui peut être amélioré.

  • Archiver le contenu ou les sites obsolètes. Cependant, si vous prévoyez d'archiver ou de supprimer du contenu ou des sites obsolètes, assurez-vous que les utilisateurs ont compris votre intention et que vous effectuez ces opérations uniquement à des moments prévisibles. Par exemple, publiez un planning qui indique à quel moment vous allez archiver du contenu ou supprimer des sites non utilisés.

  • Examiner régulièrement les autorisations de site. Par exemple, procédez à un examen trimestriel afin de retirer les autorisations aux utilisateurs qui ont quitté le groupe ou le projet.

  • Choisir un laps de temps raisonnable pour les activités de maintenance. Par exemple, si vous prévoyez de mener des enquêtes périodiques auprès des utilisateurs, n'en prévoyez pas plus de deux par an (et de préférence, pas plus d'une par an).

  • Prévoir des sauvegardes régulières du contenu du ou des sites. Cherchez à déterminer à quelle fréquence les sauvegardes et la restauration de contenu doivent être effectuées. Pour plus d'informations sur la planification de sauvegardes et de restaurations, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

Commencez par créer un plan de maintenance de site dès le début de la phase de planification. Enregistrez votre plan, y compris la fréquence de révision du site et d'archivage du contenu. Soumettez le plan aux membres de votre équipe et à des représentants de votre base d'utilisateurs. Vous pourrez ainsi identifier les problèmes éventuels rencontrés par les utilisateurs, trouver le meilleur moyen de résoudre ces problèmes, et mettre en place un plan de maintenance de site avant la mise en ligne de votre site.

Vous pouvez enregistrer ces informations dans la feuille de calcul de création et de maintenance de site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=193521&clcid=0x40C).

Planifier la gestion des collections de sites

Votre plan de maintenance de site doit prévoir la façon dont la taille et le nombre de collections de sites seront gérés dans votre environnement. Il s'agit du point le plus important si vous autorisez la Gestion de sites libre-service. La plupart des organisations souhaitent pouvoir prédire et contrôler la croissance attendue des sites du fait de son impact sur les ressources de base de données. Par exemple, si une base de données de contenu déterminée contient 100 sites et que l'un de ces sites occupe plus de 50 % de l'espace, il pourra s'avérer judicieux de placer ce site dans sa propre base de données de contenu. Dans ce cas, vous serez assuré de pouvoir faire face à sa croissance en termes d'espace tout en conservant la possibilité de sauvegarder et restaurer les bases de données.

Les deux méthodes de gestion des collections de sites sont les suivantes :

  • Quotas de collections de sites Utilisez cette méthode pour contrôler la taille maximale potentielle des collections de sites.

  • Confirmation et suppression de l'utilisation de sites Utilisez cette méthode pour surveiller et supprimer les collections de sites non utilisées.

Planifier les quotas de collection de sites

Les quotas permettent de suivre et limiter le stockage de site. Vous pouvez envoyer un message électronique d'avertissement aux administrateurs de collections de sites dès que le stockage de site atteint une taille déterminée (en mégaoctets), puis empêcher l'ajout de tout contenu supplémentaire à un site dès que le stockage de site atteint une taille maximale. Au moment de planifier la capacité des bases de données et des serveurs, déterminez quelles tailles limites (le cas échéant) vous souhaitez imposer. La liste suivante explique comment exploiter au mieux les quotas :

  • Créez différents modèles de quotas pour différents types de sites. Par exemple, vous pouvez appliquer différents quotas aux différentes divisions, aux différents types de clients ou aux différents chemins d'accès (ainsi, les sites situés sous le chemin d'accès /sites obtiendront-ils uniquement 100 Mo par collection de sites, quand les situes situés sous /vip bénéficieront d'une capacité de 300 Mo par collection de sites). Chaque fois que vous créez une collection de sites à partir de l'Administration centrale, vous pouvez indiquer le modèle de quota sur lequel elle est basée. Notez que les sites créés à l'aide de la Gestion de sites libre-service utilisent le quota par défaut de l'application Web. Pour plus d'informations, voir Créer, modifier et supprimer des modèles de quota (SharePoint Foundation 2010).

  • Prévoyez suffisamment d'espace pour les sites afin de parer à leur croissance (dans les limites du raisonnable). Les besoins en espace de stockage peuvent varier considérablement selon la fonction de chaque site. Par nature, les sites croissent au fil du temps à mesure qu'ils sont utilisés. Il est peu plausible qu'une limite de quota de 50 Mo puisse constituer un espace de stockage de départ suffisant pour la plupart des sites, surtout s'ils sont destinés à durer dans le temps.

  • Prévoyez une marge raisonnable entre le moment où le message électronique d'avertissement est envoyé et où le site est verrouillé pour dépassement de son quota. Par exemple, ne fixez pas la limite d'avertissement à 80 Mo et la limite de stockage de site à 85 Mo. Les utilisateurs n'apprécieront guère d'être interrompus au beau milieu du téléchargement de plusieurs fichiers volumineux s'ils ne disposent pas d'une marge suffisante.

Planifier la confirmation et suppression de l'utilisation de sites

Vous devez prévoir la façon dont seront traités les sites qui deviennent inactifs à la fin d'un projet, ou les sites que des utilisateurs ont créés à des fins expérimentales, puis abandonnés. La confirmation et suppression de l'utilisation de sites contribuent à préserver la propreté d'un environnement en aidant à déterminer le moment où les sites ne sont plus utiles. Cette fonctionnalité envoie automatiquement un message électronique au propriétaire d'un site pour déterminer s'il le considère comme actif. Si le propriétaire ne répond pas au message électronique (après un nombre de messages et un délai spécifiés), le site peut être supprimé.

Pour planifier la confirmation et suppression de l'utilisation de sites, décidez-vous quant aux points suivants :

  • Délai d'attente avant vérification de l'activité d'un site. Le délai par défaut pour les sites d'équipe ou de projet est de 90 jours à compter de leur création, mais vous devrez probablement accorder un délai plus long aux propriétaires. Pour un site de test ou un site personnel, un délai de 90 jours est probablement trop long. En règle générale, entre le moment où un site est créé, où il est utilisé activement et où il est prêt à être supprimé ou archivé, il s'écoule au moins six mois et probablement quelques années avant de boucler ce cycle de vie. Des rappels semestriels s'avèrent très utiles en pareilles situations.

  • Fréquence d'envoi de messages électroniques aux propriétaires de sites inactifs. Si l'administrateur d'un site ne répond pas au premier message électronique, vous pouvez poursuivre l'envoi d'avis supplémentaires à intervalles réguliers (jour, semaine ou mois).

  • Suppression automatique des sites non utilisés. Si l'administrateur d'un site ne répond pas aux divers messages électroniques, le site doit-il être supprimé automatiquement ? Il est recommandé dans un premier temps d'en créer une sauvegarde. Pour ce faire, vous devez vous assurer que des sauvegardes régulières sont effectuées. Vous pouvez vous reporter au portail pour développeurs SharePoint 2010 sur MSDN (http://go.microsoft.com/fwlink/?linkid=178818&clcid=0x40C) pour savoir comment personnaliser cette fonctionnalité de sorte qu'elle crée automatiquement une sauvegarde du site avant sa suppression, mais il ne s'agit pas du comportement par défaut.

  • Si vous optez pour la suppression automatique des sites non utilisés, combien de messages électroniques envisagez-vous d'envoyer aux propriétaires de sites avant la suppression ? Par défaut, quatre avis hebdomadaires sont envoyés avant la suppression d'un site, mais vous pouvez augmenter ou diminuer ce nombre en fonction de vos besoins.

Pour plus d'informations, voir Gérer les sites Web inutilisés (SharePoint Foundation 2010).

Feuille de calcul

Utilisez la feuille de calcul suivante pour planifier la maintenance et la gestion de site :

  • Feuille de calcul de création et de maintenance de site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=193521&clcid=0x40C)

Historique des modifications

Date | Description | Raison
4 juin 2010 | Publication initiale |


Planifier la gestion des quotas (SharePoint Foundation 2010)

Un quota spécifie les valeurs limites de stockage pour la quantité maximale de données pouvant être stockée dans une collection de sites. Le quota spécifie également la taille de stockage qui, lorsqu'elle est atteinte, déclenche une alerte par courrier électronique à l'administrateur de la collection de sites. Les modèles de quota appliquent ces paramètres à toute collection de sites dans une batterie SharePoint.

Par défaut, un quota contient 300 points. Un point est une mesure relative de l'utilisation des ressources, par exemple, cycles de processeur, mémoire, ou défauts de pages. Les points permettent d'établir des comparaisons entre des mesures d'utilisation de ressources ne pouvant pas être comparées autrement. Par exemple, il faut des millions de cycles de processeur pour produire un point, mais chaque fois qu'une solution en mode bac à sable celle de fonctionner, un point est comptabilisé. Pour plus d'informations sur les solutions en mode bac à sable, voir Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010).

Les quotas sont particulièrement utiles lorsque vous utilisez Microsoft SharePoint Foundation 2010 dans des environnements d'entreprise, par exemple un intranet à l'échelle d'une entreprise ou à un fournisseur de services Internet. Vous devez utiliser des quotas dans ces environnements pour vous assurer qu'une collection de sites ne peut pas monopoliser les ressources et compromettre le fonctionnement des autres collections de sites. Vous pouvez affecter un modèle de quota à une collection de sites lors de la création de la collection, ou vous pouvez affecter un modèle de quota ultérieurement. Vous pouvez également annuler la décision d'utiliser des quotas à tout endroit dans la hiérarchie de collections de sites.

Dans cet article :

  • À propos de la planification de la gestion des quotas

  • Déterminer les paramètres de modèle de quota

  • Déterminer les paramètres de la Corbeille

  • Supprimer les sites Web inutilisés

À propos de la planification de la gestion des quotas

Les étapes de base pour planifier la gestion des quotas sont les suivantes :

  1. Déterminer les paramètres de modèle de quota

  2. Déterminer les paramètres de la Corbeille

  3. Supprimer les sites Web inutilisés

Cet article indique comment déterminer les paramètres de quota pour les collections de sites dans une entreprise. Cet article n'inclut pas d'informations prérequises telles que les instructions sur la configuration de la messagerie sortante, le démarrage du travail de minuteur de l'avertissement du quota de disque ou la planification des performances et de la capacité.

Déterminer les paramètres de modèle de quota

Il n'y a pas de modèle de quota par défaut pour les collections de sites dans un environnement SharePoint Foundation 2010. Par exemple, un quota pour une collection de sites pourrait utiliser les paramètres suivants comme point de départ :

  1. Un message électronique est envoyé automatiquement à un administrateur de collections de sites lorsque la taille du site atteint 450 mégaoctets (Mo).

  2. Les utilisateurs ne peuvent pas télécharger de documents supplémentaires lorsque la taille d'une collection de sites atteint 500 Mo.

Vous devez évaluer la taille et le nombre d'éléments que les utilisateurs devraient stocker dans leurs sites. Vous devez aussi régler ces paramètres pour garantir que les sites sont utilisés conformément aux meilleures pratiques établies dans une organisation. Par exemple, si une équipe ou un groupe spécifique dans une organisation a besoin de stocker un plus grand volume de contenu sur son site, vous pouvez régler les limites de quota de cette collection de sites.

La taille des données indiquée par les quotas ne correspond pas nécessairement à la taille du stockage dans la base de données. Cela est dû au fait que la fonctionnalité de quota effectue des estimations de valeurs de stockage pour des sites vides (c'est-à-dire, des sites qui ne comportent pas de contenu d'utilisateur) et inclut ces valeurs dans le quota, en plus du stockage réel de la base de données. La taille estimée d'un site vide inclut la taille réelle des pages du modèle pour SharePoint Foundation 2010, par exemple, les pages de formulaires et les pages du répertoire _layouts.

Si vous modifiez les valeurs d'un modèle de quota, ces modifications s'appliquent uniquement aux nouvelles collections de sites auxquelles vous appliquez le modèle. SharePoint Foundation 2010 n'applique pas les valeurs de quota modifiées à des collections de sites existantes sauf si vous utilisez le modèle objet pour mettre à jour les valeurs de quota dans la base de données.

Déterminer les paramètres de la Corbeille

La Corbeille permet d'éviter la suppression permanente de contenu. La Corbeille permet aux propriétaires de sites de récupérer des éléments que les utilisateurs ont supprimés, sans nécessiter l'intervention d'un administrateur, notamment la restauration de fichiers à partir de bandes de sauvegarde. Les considérations de planification clés incluent l'éventuelle utilisation de la corbeille secondaire et l'espace à allouer.

La Corbeille est activée et désactivée au niveau de l'application Web. Par défaut, la Corbeille est activée dans toutes les collections de sites d'une application Web.

La Corbeille a deux niveaux. Lorsqu'un utilisateur supprime un élément, ce dernier est automatiquement envoyé à la Corbeille primaire. Par défaut, lorsqu'un élément est supprimé de la Corbeille primaire, il est envoyé à la Corbeille secondaire. La Corbeille secondaire stocke les éléments que les utilisateurs ont supprimés de leur Corbeille. Seuls les administrateurs de collections de sites peuvent restaurer les éléments à partir de la Corbeille secondaire. La taille spécifiée pour la Corbeille secondaire augmente la taille totale du site. Vous devez planifier la capacité des données en conséquence.

Il convient d'allouer un petit espace, par exemple 10 pour cent, à la corbeille secondaire pour prévoir le cas où un utilisateur supprime par erreur un document important, un dossier dans une bibliothèque de documents ou une colonne dans une liste.

Les éléments dans les corbeilles primaire et secondaire sont automatiquement supprimés lorsque la période spécifiée pour les éléments supprimés expire (par défaut, 30 jours). Cependant, lorsque la limite de taille de la corbeille secondaire est atteinte, les éléments sont automatiquement supprimés en commençant par les plus anciens. Les administrateurs de la collection de sites peuvent également vider la corbeille secondaire manuellement. Pour plus d'informations, voir Configurer les paramètres de la Corbeille (SharePoint Foundation 2010).

Supprimer les sites Web inutilisés

Vous pouvez supprimer un modèle de quota si vous changez vos structures de quotas. Cependant, la suppression d'un modèle de quota ne supprime pas les valeurs de quota des collections de sites auxquelles un modèle de quota a été appliqué. Si vous souhaitez supprimer les quotas de toutes les collections de sites qui utilisent un modèle de quota spécifique, vous devez utiliser le modèle objet ou effectuer une requête SQL Server.

La suppression automatique de sites Web inutilisés peut vous aider à réduire les risques de suppression de données cruciales pour les opérations de l'entreprise. Vous devez inclure les tâches suivantes dans votre processus de planification :

  • Exigez un contact secondaire pour tous les sites. Si le propriétaire du site n'est pas disponible ou quitte l'organisation, le contact secondaire peut confirmer l'utilisation du site. Si vous ne disposez pas d'un contact secondaire et que vous réduisez le nombre de jours ou le nombre d'avis émis avant la suppression d'un site inutilisé, vous risquez de supprimer accidentellement un site nécessaire.

  • Archivez les sites avant leur suppression automatique. Vous pourrez restaurer les sites qui contiennent des informations stratégiques pour l'entreprise ou planifier de stocker les bases de données de contenu pour une plus longue durée, afin qu'un site supprimé puisse être restauré.

Historique des modifications


Planifier l'intégration de la messagerie (SharePoint Foundation 2010)

Pour créer des applications Web permettant aux membres d'un groupe d'interagir entre eux et de suivre les modifications apportées aux informations par le biais d'alertes, la communication est un composant critique. Plusieurs fonctionnalités de collection de sites dépendent d'une configuration adéquate des communications, en particulier :

  • les alertes qui avertissent les membres d'un groupe de la modification d'éléments ;

  • les messages administratifs liés aux demandes d'accès au site et à d'autres problèmes d'administration du site.

  • Groupes de discussion.

Pour tirer le meilleur parti des fonctionnalités de communication, la phase de planification doit inclure l'analyse des logiciels requis et des considérations en termes de maintenance.

Pour planifier la communication, voir les articles suivants :

  • Planification du courrier électronique entrant (SharePoint Foundation 2010), qui fournit des informations sur la configuration de la messagerie pour les groupes de discussion.

  • Plan outgoing e-mail (SharePoint Foundation 2010) (en anglais), qui fournit des informations sur l'utilisation des alertes et des messages administratifs.

Historique des modifications

Date | Description | Raison
17 juin 2010 | Publication initiale |


Planification du courrier électronique entrant (SharePoint Foundation 2010)
Voir aussi

La fonctionnalité de courrier électronique entrant de Microsoft SharePoint Foundation 2010 permet aux sites SharePoint de recevoir et de stocker des messages électroniques et des pièces jointes dans des listes et des bibliothèques. Cet article aide les administrateurs de serveur et de batterie à comprendre les choix qu'ils doivent faire avant de déployer la fonctionnalité de courrier électronique entrant pour leur organisation.

Dans cet article :

  • À propos du courrier électronique entrant

  • Décisions clés relatives à la planification du courrier électronique entrant

  • Options de configuration et modes Paramètres

À propos du courrier électronique entrant

La fonctionnalité de courrier électronique entrant permet aux équipes de stocker les messages électroniques qu'ils envoient à d'autres membres de l'équipe sans ouvrir le site SharePoint ni télécharger le contenu qui a été envoyé par courrier électronique. Ceci est possible en raison du fait qu'une adresse de messagerie unique peut être affectée à la plupart des types de listes et bibliothèques.

Avant de configurer le courrier électronique entrant, vous devez effectuer les tâches suivantes :

  • Si vous utilisez le scénario de base, chaque serveur Web frontal SharePoint doit exécuter le service SMTP (Simple Mail Transfer Protocol) et le service Application Web Microsoft SharePoint Foundation.

  • Si vous utilisez le scénario avancé, vous pouvez utiliser un ou plusieurs serveurs de la batterie de serveurs pour exécuter le service SMTP et disposer d'une adresse de serveur SMTP valide. Autrement, vous devez connaître le nom d'un serveur hors de la batterie exécutant le service SMTP et l'emplacement du dossier de dépôt des messages électroniques.

Pour plus d'informations sur l'installation du service SMTP, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

Décisions clés relatives à la planification du courrier électronique entrant

Lorsque vous planifiez l'implémentation du courrier électronique entrant, vous avez le choix entre un scénario de base et un scénario avancé, comme décrit ci-dessous.

Utilisation d'un scénario de base

Vous pouvez activer un scénario de courrier électronique entrant de base en installant le service SMTP (Simple Mail Transfer Protocol) sur le serveur qui exécute SharePoint Foundation 2010 et en activant le courrier électronique entrant en utilisant le mode Paramètres automatiques avec tous les paramètres par défaut. Dans ce scénario, le courrier électronique est envoyé directement à votre serveur SMTP, et SharePoint Foundation 2010 recherche périodiquement les messages électroniques dans le dossier de dépôt des messages électroniques par défaut qui est automatiquement configuré par le service SMTP.

Sélectionner le mode Paramètres automatiques et accepter tous les paramètres par défaut constitue la façon la plus simple d'activer le courrier entrant dans la mesure où tous les paramètres de configuration sont créés pour vous : peu de connaissances sont par conséquent nécessaires. Pour la plupart des entreprises, cette configuration suffit.

Pour activer un scénario de courrier électronique entrant de base, procédez comme suit :

  1. L'administrateur du serveur utilise l'Assistant Composants Windows pour installer le composant Services de messagerie sur le serveur sur lequel vous souhaitez recevoir le courrier électronique entrant. Ceci installe et démarre le service SMTP sur ce serveur.

  2. L'administrateur de la batterie active le courrier électronique entrant à l'aide du mode Paramètres automatiques et accepte toutes les valeurs par défaut.

  3. L'administrateur de la collection de sites active la fonctionnalité de courrier électronique entrant sur les bibliothèques et les listes dans lesquelles il souhaite stocker le courrier électronique entrant et attribue à chaque bibliothèque et à chaque liste une adresse électronique unique sous la forme adresse@SMTPserveraddress. Par exemple, sharedfiles@SMTPserver.contoso.com.

Lorsque les utilisateurs envoient un message électronique à l'adresse d'une liste ou d'une bibliothèque, SharePoint Foundation 2010 détecte que le nouveau courrier a été remis et l'envoie à la liste ou à la bibliothèque appropriée en fonction de l'adresse de messagerie.

Remarque :
Vous pouvez aussi utiliser l'option Paramètres automatiques dans un scénario avancé avec, au choix, le service de gestion d'annuaire Microsoft SharePoint, un serveur de messagerie fiable ou l'adresse complète d'un serveur de courrier entrant. Ces options sont traitées dans la section « Utilisation du scénario avancé » plus loin dans cet article.

Si ce scénario de base répond à vos besoins, vous pouvez ignorer le reste de cet article. Pour plus d'informations, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

Utilisation d'un scénario avancé

Pour les administrateurs plus avertis, des choix supplémentaires sont disponibles, certains d'entre eux requérant davantage d'expertise pour le déploiement que le scénario de base avec toutes les options par défaut. Cette section décrit les options de configuration suivantes :

  • Service de gestion d'annuaire SharePoint

  • Adresse complète du serveur de courrier entrant

  • Serveur de messagerie fiable

  • Dossier de dépôt des messages électroniques

Si vous utilisez le scénario avancé pour configurer le courrier électronique entrant, vous devrez effectuer des procédures supplémentaires. Pour plus d'informations, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

Service de gestion d'annuaire SharePoint

Le service de gestion d'annuaire SharePoint connecte les sites SharePoint à l'annuaire des utilisateurs de votre entreprise afin d'offrir des fonctionnalités avancées au niveau du courrier électronique. Ce service prend en charge la création et la gestion des groupes de distribution de courrier électronique à partir de sites SharePoint. Il crée également des contacts dans l'annuaire des utilisateurs de votre entreprise pour permettre aux utilisateurs de retrouver dans leur carnet d'adresses les listes SharePoint activées pour le courrier électronique. Toutefois, le service de gestion d'annuaire SharePoint communiquant avec les services de domaine Active Directory (AD DS), sont utilisation nécessite davantage d'efforts de gestion.

Remarque :
Nous vous recommandons d'utiliser Microsoft Exchange Server conjointement avec le service de gestion d'annuaire SharePoint. Si vous ne le faites pas, vous devez personnaliser votre propre service de gestion d'annuaire.

Vous pouvez configurer le service de gestion d'annuaire SharePoint en utilisant le mode Paramètres automatiques ou Paramètres avancés. Vous pouvez choisir d'activer le service de gestion d'annuaire SharePoint sur votre batterie de serveurs SharePoint, ou utiliser le service de gestion d'annuaire SharePoint d'une autre batterie. Un des avantages de l'utilisation du service qui s'exécute sur une autre batterie de serveurs est que les autorisations Active Directory sont gérées dans un emplacement centralisé (c'est-à-dire sur l'autre batterie).

Pour activer ce service sur un serveur ou une batterie de serveurs exécutant SharePoint Foundation 2010, le compte du pool d'applications Administration centrale de SharePoint utilisé par SharePoint Foundation 2010 doit disposer d'un accès en écriture au conteneur que vous spécifiez dans Active Directory. Ceci nécessite un administrateur Active Directory pour configurer l'unité d'organisation et les autorisations sur celle-ci. L'avantage de l'utilisation du service de gestion d'annuaire Microsoft SharePoint dans une batterie de serveurs à distance est que vous n'avez pas besoin de l'aide d'un administrateur Active Directory pour créer et configurer l'unité d'organisation si celle-ci existe déjà.

Remarque :
Si vous planifiez d'utiliser le service de gestion d'annuaire SharePoint, vous devez effectuer un certain nombre de procédures. Pour plus d'informations, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

Un scénario standard de gestion d'annuaire standard se compose des étapes suivantes :

  1. L'administrateur d'une collection de sites crée un groupe SharePoint.

  2. L'administrateur choisit de créer une liste de distribution à associer à ce groupe SharePoint et attribue une adresse de messagerie à cette liste de distribution.

  3. Au fil du temps, l'administrateur ajoute et supprime des utilisateurs dans ce groupe SharePoint. À mesure que des utilisateurs sont ajoutés et supprimés dans le groupe, le service de gestion d'annuaire SharePoint les ajoute et les supprime automatiquement dans la liste de distribution, qui est stockée dans le service d'annuaire Active Directory. Dans la mesure où les listes de distribution sont associées à un groupe SharePoint spécifique, cette liste de distribution est disponible pour tous les membres de ce groupe SharePoint.

  4. Par défaut, les adresses de messagerie sont générées automatiquement par défaut pour les forums de discussion et les calendriers sur les sites d'équipe, et ajoutées à la liste de distribution de l'équipe. Les adresses de messagerie pour ces deux listes se présentent par défaut sous la forme suivante : AdresseGroupe.discussions et AdresseGroupe.calendar.

  5. Lorsque vous incluez des adresses de messagerie pour les forums de discussion et les calendriers dans la liste de distribution, les courriers électroniques et les invitations aux réunions envoyés à cette liste de distribution sont archivés sur le site d'équipe.

Pour plus d'informations sur le service de gestion d'annuaire SharePoint, voir Au cœur de SharePoint : Intégration de l'annuaire SharePoint (http://go.microsoft.com/fwlink/?linkid=151766&clcid=0x40C).

Options de configuration du service de gestion d'annuaire SharePoint

Lorsque vous configurez le service de gestion d'annuaire Microsoft SharePoint pour créer des groupes de distribution et des contacts dans Active Directory, vous devez fournir les informations suivantes :

  • Nom du conteneur Active Directory dans lequel les nouveaux groupes de distribution et contacts seront créés. Il doit être fourni sous la forme suivante :

    OU=NomConteneur, DC=NomDomaine, DC=NomDomaineNiveauSupérieur

    Exemple

    OU=SharePointContacts,DC=Contoso,DC=com

  • Nom du serveur SMTP à utiliser pour le courrier entrant (ou acceptez le serveur SMTP par défaut s'il en existe un). Il doit être fourni sous la forme suivante :

    Serveur.sous_domaine.domaine.domaine_niveau_supérieur

    Par exemple, SharePointServer.support.contoso.com

  • S'il faut accepter les messages provenant uniquement d'utilisateurs authentifiés.

  • S'il faut autoriser les utilisateurs à créer des groupes de distribution à partir de sites SharePoint. Si vous choisissez Oui pour cette option, vous pouvez également choisir si les utilisateurs peuvent effectuer une combinaison quelconque des actions suivantes :

    • Créer un groupe de distribution

    • Modifier l'adresse électronique d'un groupe de distribution

    • Modifier le titre et la description d'un groupe de distribution

    • Supprimer un groupe de distribution

Lorsque vous configurez le service de gestion d'annuaire Microsoft SharePoint pour créer des groupes de distribution et des contacts à l'aide d'un service de gestion d'annuaire SharePoint à distance, vous devez fournir les informations suivantes :

  • URL du service de gestion d'annuaire distant. Par exemple, http://server:adminport/_vti_bin/SharePointEmailWS.asmx.

  • Nom du serveur SMTP à utiliser pour le courrier entrant.

  • S'il faut accepter les messages provenant uniquement d'utilisateurs authentifiés.

  • S'il faut autoriser les utilisateurs à créer des groupes de distribution à partir de sites SharePoint.

Adresse complète du serveur de courrier entrant

Les administrateurs peuvent spécifier l'adresse du serveur de messagerie qui s'affiche dans les pages Web lorsque les utilisateurs créent une adresse de courrier entrant pour un site, une liste ou un groupe. Ce paramètre est souvent utilisé conjointement avec le service de gestion d'annuaire SharePoint pour fournir une adresse de serveur de messagerie plus conviviale à taper pour les utilisateurs (par exemple, maliste@exemple.com).

Serveur de messagerie fiable

Vous pouvez configurer SharePoint Foundation 2010 pour accepter les messages électroniques à partir de n'importe quel serveur de messagerie ou uniquement ceux qui ont été acheminés par l'intermédiaire d'une application serveur de messagerie fiable.

Vous pouvez bénéficier des avantages suivants en acheminant les messages par l'intermédiaire d'un serveur de messagerie fiable :

  • Authentification des utilisateurs : le service SMTP ne peut pas authentifier les utilisateurs qui envoient du courrier électronique à votre site, contrairement à Exchange Server. L'administrateur du serveur peut utiliser le site Web Administration centrale de SharePoint pour spécifier que le système accepte le courrier en provenance des utilisateurs authentifiés uniquement si le message électronique est envoyé par le biais d'Exchange Server.

  • Filtrage du courrier indésirable : Exchange Server permet de filtrer le courrier indésirable afin d'éliminer le courrier électronique non sollicité avant son transfert vers sa destination, dans ce cas le serveur SharePoint Foundation 2010. Une autre technique permettant de réduire le courrier indésirable consiste à autoriser les membres du site d'équipe à archiver du courrier électronique uniquement dans des listes sur lesquelles vous avez accordé des autorisations d'accès en écriture aux membres.

  • Protection contre les virus : Exchange Server fournit une protection antivirus des messages acheminés par son intermédiaire.

Remarque :
Cette option étant uniquement disponible en mode automatique, vous ne pouvez pas spécifier un ou plusieurs serveurs de messagerie fiables et spécifier également un dossier de dépôt des messages électroniques.

Dossier de dépôt des messages électroniques

Si le service SMTP s'exécute sur un autre serveur que le serveur SharePoint, vous devez spécifier l'emplacement où SharePoint Foundation 2010 récupère le courrier entrant. Vous spécifiez le dossier de dépôt des messages électroniques pour que SharePoint Foundation 2010 sache où récupérer le courrier entrant. Toutefois, si vous spécifiez un dossier de dépôt des messages électroniques spécifique, SharePoint Foundation 2010 ne peut pas détecter les modifications de configuration sur le serveur de messagerie distant qui remet les messages électroniques dans votre dossier de dépôt. Cela signifie que si un administrateur configure le serveur de messagerie de façon à ne plus remettre les messages électroniques dans ce dossier, SharePoint Foundation 2010 ne peut pas détecter que la configuration a été modifiée et, par conséquent, ne peut pas récupérer les fichiers à partir du nouvel emplacement.

Remarque :
Lorsque les paramètres de courrier entrant sont définis en mode avancé, vous devez vous assurer que vous disposez des autorisations appropriées sur le dossier de dépôt des messages électroniques. Pour plus d'informations, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

Remarque :
Dans la mesure où cette option est uniquement disponible en mode avancé, vous ne pouvez pas spécifier un dossier de dépôt des messages électroniques et également spécifier un ou plusieurs serveurs de messagerie fiables.

Options de configuration et modes Paramètres

En tant qu'administrateur de batterie, vous disposez de deux modes Paramètres pour activer le courrier entrant : Paramètres automatiques et Paramètres avancés. Comme décrit dans la section « Utilisation d'un scénario de base », vous pouvez choisir le mode Paramètres automatiques avec les paramètres par défaut. Toutefois, ce mode vous permet de sélectionner d'autres options.

Le tableau suivant décrit les options de configuration et indique si elles sont configurées dans la page Configurer les paramètres du courrier entrant dans l'Administration centrale à l'aide du mode Paramètres automatiques ou Paramètres avancés.

Option de configuration | Mode Paramètres automatiques | Mode Paramètres avancés
Serveurs de messagerie fiables | Oui | Non
Dossier de dépôt des messages électroniques | Non | Oui
Service de gestion d'annuaire SharePoint | Oui | Oui
Adresse complète du serveur de courrier entrant | Oui | Oui

Les modes Paramètres avancés et Paramètres automatiques sont similaires car ils permettent aux administrateurs de batteries de serveurs de configurer le service de gestion d'annuaire Microsoft SharePoint et l'adresse de serveur de messagerie à afficher dans les pages Web. Ces modes Paramètres diffèrent car le mode Paramètres automatiques remplace la capacité de choisir les serveurs de messagerie pour accepter le courrier par la possibilité de spécifier le dossier dans lequel les messages sont déposés. SharePoint Foundation 2010 utilise ce dossier de dépôt des messages électroniques pour détecter les nouveaux messages électroniques.

Remarque :
Le paramètre Dossier de dépôt des messages électroniques n'est pas disponible en mode automatique. En effet, ce mode définit automatiquement le dossier de dépôt des messages dans le dossier qui est spécifié par le service SMTP.

Voir aussi

Concepts

Configurer le courrier électronique entrant (SharePoint Foundation 2010)
Plan outgoing e-mail (SharePoint Foundation 2010) (en anglais)
Configurer le courrier électronique sortant (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
27 août 2010 | 2010/08/23 | Mise à jour du contenu
17 juin 2010 | Publication initiale |


Plan outgoing e-mail (SharePoint Foundation 2010) (en anglais)
Voir aussi

Outgoing e-mail is the foundation on which site administrators can implement several e-mail notification features. These features help end users track changes and updates to individual site collections and allow site administrators to deliver status messages.

This article helps site administrators understand both the uses for integrating outgoing e-mail and the requirements for integrating it into their site collections.

In this article:

  • About outgoing e-mail

  • Key planning phases of outgoing e-mail

About outgoing e-mail

Properly configuring outgoing e-mail is a requirement for implementing e-mail alerts and notifications. The outgoing e-mail feature uses an outbound Simple Mail Transfer Protocol (SMTP) service to relay e-mail alerts and notifications. These e-mail features include the following:

  • Alerts

    In a large and growing site collection, users need an efficient way to keep up with updates to lists, libraries, and discussions. Setting up alerts provides an effective means to stay on top of changes. For example, if many users work on the same document, the owner of the document can set up alerts to be notified whenever there are changes to this document. Users can specify which areas of the site collection or which documents they want to track and decide how often they want to receive alerts.

    Remarque :
    Users must have at least View permissions to set up alerts.

  • Administrative messages

    Site administrators might want to receive notices when users request access to a site or when site owners have exceeded their specified storage space. Setting up outgoing e-mail enables site administrators to receive automatic notifications for site administration issues.

Outgoing e-mail support can be enabled at both the server farm level (available in the System Settings section of the Central Administration Web site) and at the Web application level (available in the Application Management section of the Central Administration Web site). Therefore, you can specify different settings for a specific Web application. Outgoing e-mail settings at the Web application level override those set up at the server farm level.

Key planning phases of outgoing e-mail

Before you configure outgoing e-mail, you must have an SMTP service to relay e-mail alerts and notifications.

The outgoing e-mail settings include several components that must be considered when planning for this feature:

  • An SMTP service to relay e-mail alerts and notifications. You will need the DNS name or IP address of the SMTP mail server to use.

  • An address to use in the header of an alert message that identifies the sender of the message.

  • A Reply-to address that is displayed in the To field of a message when a user replies to an alert or notification.

  • A character set to use in the body of alert messages.

Outbound SMPT server

The SMTP service is a component of Internet Information Services (IIS); however, it is not enabled by default with IIS. It can be enabled by using Add or Remove Programs in Control Panel.

After determining which SMTP server to use, the SMTP server must be configured to allow anonymous access and to allow e-mail messages to be relayed. Additionally, the SMTP server must have Internet access if you want the ability to send messages to external e-mail addresses.

For more information about installing, configuring, and managing the SMTP service, see Help for Internet Information Services (IIS) Manager (http://go.microsoft.com/fwlink/?LinkId=72343).

Remarque :
Only a member of the Farm Administrators group can configure an SMTP server. The user must also be a member of the local Administrators group on the server.

From and Reply-to addresses

When configuring outgoing e-mail, you can configure the following two addresses:

  • From address

    Alerts and notifications are sent from an administrative account on the server farm. This account is probably not the one you want to be displayed in the From field of an e-mail message. The address that you use does not need to correspond to an actual e-mail account; it can be a simple friendly address that is recognizable to an end user. For example, "Site administrator" might be an appropriate From address.

  • Reply-to address

    This is the address that will be displayed in the To field of a message if a user replies to an alert or notification. The Reply-to address should also be a monitored account to ensure that end users receive prompt feedback for issues they might have. For example, a help desk alias might be an appropriate Reply-to address.

Character set

When you configure outgoing e-mail, you will need to specify the character set to use in the body of e-mail messages. A character set is a mapping of characters to their identifying code values. The default character set for outgoing e-mail is Unicode UTF-8, which allows most combination of characters (including bidirectional text) to co-exist in a single document. In most cases, the default setting of UTF-8 works well, although East Asian languages are best rendered with their own character set.

Be aware that if you select a specific language code, the text is less likely to appear correctly in mail readers configured for other languages.

Voir aussi

Concepts

Configurer le courrier électronique sortant (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
10 juin 2010 | Publication initiale |


Planification de batterie de serveurs et de l'environnement (SharePoint Foundation 2010)

Cette section décrit comment planifier des batteries de serveurs et des environnements.

Dans cette section :

  • Configuration système requise (SharePoint Foundation 2010)

  • Planification de l'architecture des services (SharePoint Foundation 2010)

  • Planifier l'authentification (SharePoint Foundation 2010)

  • Planifier le renforcement de la sécurité (SharePoint Foundation 2010)

  • Planifier la modification automatique des mots de passe (SharePoint Foundation)

  • Planifier la gestion de la continuité des opérations (SharePoint Foundation 2010)

  • Planification de la virtualisation (SharePoint Foundation 2010)

Historique des modifications


Configuration système requise (SharePoint Foundation 2010)

Avant d'installer Microsoft SharePoint Foundation 2010, vous devez vérifier que vous avez installé tout le matériel et tous les logiciels requis. Pour planifier efficacement votre déploiement, vous devez assimiler le niveau de prise en charge fourni pour les navigateurs Web que vous utiliserez dans votre environnement et la façon dont la prise en charge des versions 4 et 6 du protocole IP est implémentée dans SharePoint Foundation 2010. Vous devez également comprendre les restrictions applicables aux longueurs de chemins d'accès et d'URL dans SharePoint Foundation 2010.

Les articles de cette section vous aident à préparer l'installation de SharePoint Foundation 2010 en fournissant des informations relatives aux composants prérequis nécessaires à l'exécution de SharePoint Foundation 2010.

  • Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

    Cet article décrit les configurations matérielle et logicielle requises pour installer correctement SharePoint Foundation 2010.

  • Planifier la prise en charge des navigateurs (SharePoint Foundation 2010)

    Cet article décrit les niveaux de prise en charge pour les navigateurs Web à utiliser avec SharePoint Foundation 2010.

  • Restrictions de longueurs de chemins d'accès d'URL (SharePoint Foundation 2010)

    Cet article traite des restrictions spécifiques liées aux caractères et à la longueur des chemins d'accès d'URL dans SharePoint Foundation 2010, Internet Explorer 7 et Internet Explorer 8 dont vous devez avoir connaissance lors de la planification des sites, de la navigation et de la structure.

  • Prise en charge IP (SharePoint Foundation 2010)

    Cet article décrit la prise en charge des protocoles IPv4 (IP version 4) et IPv6 (IP version 6) dans SharePoint Foundation 2010.

Historique des modifications


Restrictions de longueurs de chemins d'accès d'URL (SharePoint Foundation 2010)

Cet article traite des restrictions spécifiques liées aux caractères et à la longueur des chemins d'accès d'URL dans Microsoft SharePoint Foundation 2010, Internet Explorer 7 et Internet Explorer 8 dont vous devez avoir connaissance lors de la planification des sites, de la navigation et de la structure. Il ne traite pas des limitations de longueur d'URL dans d'autres navigateurs. Pour plus d'informations à ce sujet, voir la documentation du navigateur.

Dans cet article :

  • Présentation des longueurs de chemins d'accès et d'URL

  • Limitations applicables aux longueurs de chemins d'accès d'URL

  • Résolution des problèmes liés aux longueurs d'URL

Présentation des longueurs de chemins d'accès et d'URL

Cette section traite de la composition d'URL, de la façon dont SharePoint Foundation 2010 génère les URL, de la façon dont les URL sont codées, allongées et passées comme paramètres dans d'autres URL.

Composition d'URL SharePoint

La longueur totale d'une URL SharePoint est égale à la longueur du chemin d'accès au dossier ou fichier, y compris le protocole, le nom de serveur et le nom du dossier ou fichier, plus tout paramètre inclus dans le cadre de l'URL. La formule est la suivante :

  • URL = protocole + nom de serveur + chemin d'accès au dossier ou fichier + nom de dossier ou fichier + paramètres

Voici par exemple un chemin d'accès d'URL standard vers un fichier stocké dans SharePoint Foundation 2010 :

http://www.contoso.com/sites/marketing/documents/Shared%20Documents/Promotion/Some%20File.xlsx

Où les parties du chemin d'accès d'URL sont répertoriés dans le tableau suivant.

Partie d'URL | Exemple
Protocole | http://
Nom de serveur | www.contoso.com/
Chemin d'accès au dossier ou fichier | sites/marketing/documents/Shared%20Documents/Promotion/
Nom de fichier | Some%20File.xlsx

Codage d'URL

Le codage d'URL permet de s'assurer que tous les navigateurs transmettent correctement le texte dans les chaînes d'URL. Les caractères tels que le point d'interrogation (?), le et commercial (&), la barre oblique (/) et l'espace peuvent être tronqués ou endommagés par certains navigateurs. SharePoint Foundation 2010 adhère aux normes de codage d'URL définis dans la RFC 3986 de l'Internet Engineering Task Force (IETF) (http://go.microsoft.com/fwlink/?linkid=195564&clcid=0x40C).

Si l'URL SharePoint contient des caractères ASCII non standard, tels que des caractères ASCII élevés ou des caractères Unicode codés sur deux octets, chacun de ces caractères est encodé URL en plusieurs caractères ASCII lorsqu'il est passé au navigateur Web. Par conséquent, une URL comportant de nombreux caractères ASCII élevés ou caractères Unicode codés sur deux octets peut être plus longue que l'URL d'origine non codée. La liste ci-dessous fournit des exemples des facteurs de multiplication :

  • Caractères ASCII élevé — par exemple (!, ", #, $, %, &, [Espace]) : facteur de multiplication = 3

  • Caractères Unicode codés sur deux octets — par exemple japonais, chinois, coréen, hindi : facteur de multiplication = 9

Par exemple, lorsque vous traduisez les noms de sites, bibliothèque, dossier et fichier dans le chemin d'accès d'URL http://www.contoso.com/sites/marketing/documents/Shared%20Documents/Promotion/Some%20File.xlsx en japonais, le chemin d'accès d'URL codé résultant ressemblera à ceci :

http://www.contoso.com/sites/%E3%83%9E%E3%83%BC%E3%82%B1%E3%83%86%E3%82%A3%E3%83%B3%E3%82%B0/%E6%96%87%E6%9B%B8/DocLib/%E3%83%97%E3%83%AD%E3%83%A2%E3%83%BC%E3%82%B7%E3%83%A7%E3%83%B3/%E3%83%95%E3%82%A1%E3%82%A4%E3%83%AB.xlsx. Ce chemin d'accès fait 224 caractères, alors que le chemin d'accès d'origine ne fait que 94 caractères.

Important :
Les caractères suivants ne peuvent pas être utilisés dans une URL non codée : (~, #, %, &, *, {}, \, :, <>, /, +, |, ").

Paramètres d'URL

Les paramètres d'URL sont des données fournies dans le cadre de l'URL et traitées. Ces paramètres sont également encodés URL et peuvent être codés à plusieurs reprises, ce qui génère de très longues URL.

Par exemple, si vous naviguez jusqu'à une liste, l'URL peut ressembler à ce qui suit :http://www.contoso.com/sites/marketing/documents/Shared%20Documents/Forms/AllItemA.aspx?RootFolder=%2Fsites%2Fmarketing%2Fdocuments%2FShared%20Documents%2FPFPromoti&FolderCTID=0x012000F2A09653197F4F4F919923797C42ADEC&View={CD527605-9A7A-448D-9A35-67A33EF9F766}. Cette URL fait 260 caractères.

Si vous cliquez ensuite sur Créer un affichage sous l'onglet Bibliothèque, l'URL entière est incluse dans l'URL résultante comme paramètre source et est codée sous une forme beaucoup plus longue — par exemple, http://www.contoso.com/sites/marketing/documents/_layouts/ViewType.aspx?List=%7BED6E21E0%2DDF28%2D4165%2DBC3E%2D5371987CC2D2%7D&Source=http%3A%2F%2Fwww%2Econtoso%2Ecom%2Fsites%2Fmarketing%2Fdocuments%2FShared%2520Documents%2FForms%2FAllItems%2Easpx%3FRootFolder%3D%252Fsites%252Fmarketing%252Fdocuments%252FShared%2520Documents%252FPromotion%26FolderCTID%3D0x012000F2A09653197F4F4F919923797C42ADEC%26View%3D%7BCD527605%2D9A7A%2D448D%2D9A35%2D67A33EF9F766%7D. Cette URL fait 457 caractères.

Important :
SharePoint Foundation 2010 tronque le paramètre source d'URL si la longueur totale de l'URL à passer à Internet Explorer est supérieure à 1950 octets. Le paramètre source est une référence à une page visitée précédemment. La conséquence de la troncation du paramètre source est que l'utilisateur sera renvoyé à l'emplacement par défaut plutôt qu'à l'emplacement spécifié dans le paramètre source.

D'autres paramètres, tels que les ordres de tri, les paramètres de dossiers racines et les affichages, ne sont pas tronqués.

Limitations applicables aux longueurs de chemins d'accès d'URL

Cette section traite des différentes limitations applicables aux longueurs d'URL dans SharePoint Foundation 2010 et Internet Explorer et explique comment planifier les longueurs de chemins d'accès d'URL.

Limitations applicables aux longueurs de chemins d'accès d'URL SharePoint

Les limitations mentionnées dans cette section s'appliquent à la longueur totale du chemin d'accès d'URL à un dossier ou un fichier dans SharePoint Foundation 2010, mais pas à la longueur des paramètres. Par ailleurs, elles s'appliquent uniquement aux URL non codées, et non aux URL codées. Aucune limitation ne s'applique aux URL codées dans SharePoint Foundation 2010. Les limitations sont les suivantes :

  • 260 unités de code Unicode (UTF-16) - caractères dans un chemin d'accès de fichier complet, nom de serveur/domaine non compris.

  • 256 unités de code Unicode (UTF-16) - caractères dans un chemin d'accès de dossier complet, nom de serveur/domaine et nom de fichier non compris.

  • 128 unités de code Unicode (UTF-16) - caractères dans un composant de chemin d'accès, autrement dit un nom de dossier ou de fichier.

  • 260 unités de code Unicode (UTF-16) - caractères dans un chemin d'accès complet, y compris un nom de serveur/domaine, pour utilisation avec des clients Office.

  • 256 unités de code Unicode (UTF-16) - caractères dans un chemin d'accès complet, y compris le nom de serveur/domaine, pour utilisation avec des contrôles Active X.

Pour plus d'informations, voir l'article 894630 de la base de connaissances Microsoft intitulé Vous recevez un message d'erreur « Le nom du fichier ou dossier spécifié est trop long » (http://go.microsoft.com/fwlink/?linkid=195567&clcid=0x40C).

Remarque :
Présentation des unités de code - Dans la plupart des cas, un caractère UTF-16 équivaut à une unité de code UTF-16. Toutefois, les caractères qui utilisent des points de code Unicode supérieurs à U+10000 équivalent à deux unités de code UTF-16. Il s'agit notamment des caractères de paire de substitution japonais ou chinois. Si vos chemins d'accès comprennent ces caractères, la longueur d'URL dépassera la limitation de longueur d'URL avec moins de 256 ou 260 caractères.

Limitations de longueurs d'URL Internet Explorer

Internet Explorer possède également des limitations distinctes de celles de SharePoint Foundation 2010. Même si vous faites en sorte que le chemin d'accès d'URL SharePoint Foundation 2010 soit inférieur aux limitations, vous pouvez faire face à une limitation de longueur d'URL Internet Explorer à cause des paramètres ajoutés et du codage de l'URL. Vous devez respecter la limitation la plus restrictive lors de la planification des longueurs d'URL.

Internet Explorer 7 et Internet Explorer 8 ont une longueur d'URL maximale de 2 083 caractères UTF-8 et une longueur de chemin d'accès maximale de 2 048 caractères UTF-8. Toutefois, dans Internet Explorer 7, dans certaines circonstances, la limitation de longueur d'URL effective est de 1 024 caractères UTF-8, et non de 2 083 caractères UTF-8. Pour plus d'informations sur les limitations de longueurs d'URL dans Internet Explorer, voir l'article 208427 de la Base de connaissances Microsoft, intitulé La longueur maximale d'une URL est de 2 083 caractères dans Internet Explorer (http://go.microsoft.com/fwlink/?linkid=195568&clcid=0x40C).

Important :
À moins qu'Internet Explorer 8 ne soit l'unique navigateur utilisé dans votre environnement, utilisez la limite effective de 1 024 caractères UTF-8.

Résolution des problèmes liés aux longueurs d'URL

Il existe plusieurs manières de résoudre ou d'atténuer les problèmes liés aux longueurs d'URL dans l'environnement SharePoint Foundation 2010. Vous trouverez quelques suggestions dans la liste suivante :

  • Effectuez la mise à niveau de tous les navigateurs des utilisateurs finaux vers Internet Explorer 8, qui présente une limitation de longueur d'URL supérieure.

  • Utilisez des noms plus courts pour les sites, dossiers et documents et contrôlez la profondeur des structures de sites et de dossiers afin de réduire la longueur des URL.

  • Dans la mesure du possible, utilisez des noms ASCII pour les sites, dossiers et documents. Cela vous permettra d'éviter les situations dans lesquelles l'URL sera allongée suite au codage.

  • Pour éviter que les utilisateurs finaux de SharePoint Foundation 2010 ne rencontrent des problèmes dus aux limitations de longueurs d'URL, nous vous recommandons d'appliquer les limites effectives suivantes dans le déploiement :

    • 256 unités de code Unicode (UTF-16) - limitation de longueur de chemin d'accès de fichier effective, y compris un nom de domaine/serveur

    • 128 unités de code Unicode (UTF-16) - limitation de longueur de composant de chemin d'accès

Historique des modifications

Date | Description | Raison
5 août 2010 | Publication initiale |


Logical architecture planning (SharePoint Foundation 2010)

This section contains articles to help you learn about and plan logical architectures for Microsoft SharePoint Foundation 2010.

In this section:

  • Planification de l'architecture des services (SharePoint Foundation 2010)

  • Planifier les collections de sites nommées par l'hôte (SharePoint Foundation 2010)


Planification de l'architecture des services (SharePoint Foundation 2010)

Cet article décrit l'architecture des services pour partager des applications de service et fournit des exemples d'architecture pour Microsoft SharePoint Foundation 2010.

Dans cet article :

  • À propos des applications de service

  • Infrastructure des services et principes de conception

Les modèles au format affiche suivants sont également disponibles pour une utilisation avec cet article. Vous pouvez modifier les diagrammes dans les modèles pour représenter vos propres projets d'entreprise.

  • Services dans Produits Microsoft SharePoint 2010

    • Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167090&clcid=0x40C)

    • PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167092&clcid=0x40C)

    • XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167091&clcid=0x40C)

  • Services inter-batteries dans Produits SharePoint 2010

    • Visio (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167093&clcid=0x40C)

    • PDF (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167095&clcid=0x40C)

    • XPS (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167094&clcid=0x40C)

À propos des applications de service

SharePoint Foundation 2010 comprend un jeu de services qui peuvent être partagés par plusieurs applications Web. Ces services sont appelés applications de service. Certaines applications de service peuvent être partagées par plusieurs batteries de serveurs. Le partage d'applications de service entre plusieurs applications Web et batteries de serveurs réduit considérablement les ressources nécessaires pour fournir ces services sur plusieurs sites.

Les applications de service suivantes sont fournies avec SharePoint Foundation 2010 :

  • Service BDC (Business Data Connectivity) — Donne accès aux systèmes de données métier.

  • Service de collecte de données relatives à l'utilisation et à l'état — Collecte des données relatives à l'utilisation et à l'état à l'échelle de la batterie de serveurs, et permet d'afficher différents rapports d'utilisation et d'état.

  • Service de paramètres d'abonnement Microsoft SharePoint Foundation — Fournit une fonctionnalité de partage au sein d'une architecture mutualisée pour les applications de service. Effectue le suivi des ID et des paramètres d'abonnement pour les services qui sont déployés en mode partitionné. Déployé via Windows PowerShell uniquement.

Certaines applications de service sont fournies par d'autres produits Microsoft, y compris Microsoft Office Web Apps. Compagnon en ligne des applications Microsoft Word, Excel, PowerPoint et OneNote, Office Web Apps permet aux utilisateurs d'accéder à des documents Office, de les modifier légèrement ou de les partager où qu'ils se trouvent. Les clients professionnels disposant d'une licence Microsoft Office 2010 dans le cadre d'un programme de licence en volume peuvent exécuter Office Web Apps dans leurs locaux sur un serveur exécutant SharePoint Foundation 2010.

L'infrastructure des services est extensible, et des entreprises tierces peuvent créer des applications de service supplémentaire qui peuvent être utilisées avec SharePoint Foundation 2010.

Les applications de service sont différentes des services qui sont démarrés et arrêtés sur des serveurs spécifiques et répertoriés sur la page Services sur le serveur du site Web Administration centrale de SharePoint. Certains des services répertoriés sur cette page sont associés à des applications de service, mais les applications de service représentent des instances spécifiques de services qui peuvent être configurées et partagées de manière spécifique.

Infrastructure des services et principes de conception

Produits SharePoint 2010 améliore l'infrastructure des services qui a été introduite dans la version précédente. Dans Produits SharePoint 2010, l'infrastructure des services d'hébergement est déplacée dans SharePoint Foundation 2010, et la configuration des offres de services est beaucoup plus souple. Les services individuels peuvent être configurés indépendamment, et des sociétés tierces peuvent ajouter des services à la plateforme.

Déploiement de services

Pour déployer des applications de service au sein d'une batterie de serveurs, utilisez l'une des méthodes suivantes :

  • Sélection des services lorsque vous exécutez l'Assistant Configuration des produits SharePoint

  • Ajout des services un par un dans la page Gérer les applications de service sur le site Web Administration centrale

  • Utilisation de Windows PowerShell

Configuration plus granulaire des services

L'infrastructure des applications de service vous offre un meilleur contrôle sur les services qui sont déployés et le mode de partage des applications de service :

  1. Vous pouvez déployer seulement les applications de service qui sont nécessaires à une batterie de serveurs.

  2. Les applications Web peuvent être configurées pour utiliser uniquement les applications de service qui sont nécessaires, et non pas l'ensemble des services qui ont été déployés.

  3. Vous pouvez déployer plusieurs instances du même service dans une batterie de serveurs et affecter des noms uniques aux applications de service qui en résultent.

  4. Vous pouvez partager des applications de service entre plusieurs applications Web au sein de la même batterie de serveurs.

Vous pouvez choisir les applications de service pour une application Web lorsque vous créez l'application Web. Vous pouvez aussi modifier par la suite les applications de service qui sont associées à une application Web.

Groupes d'applications de service

Par défaut, toutes les applications de service sont incluses dans un groupe par défaut, sauf si vous modifiez ce paramètre pour une application de service lors de sa création. Vous pouvez ajouter et supprimer à tout moment des applications de service dans le groupe par défaut.

Le diagramme suivant illustre un déploiement type avec toutes les applications de service contenues dans le groupe de services par défaut.

Applications de service dans le groupe par défaut

Lorsque vous créez une application Web, vous pouvez sélectionner le groupe par défaut ou créer un groupe personnalisé d'applications de service. Vous créez un groupe personnalisé d'applications de service en sélectionnant uniquement les applications de service que vous souhaitez que l'application Web utilise.

Les groupes personnalisés qui sont créés dans l'Administration centrale ne sont pas réutilisables dans plusieurs applications Web. Chaque fois que vous sélectionnez personnalisé lors de la création d'une application Web, vous sélectionnez les applications de service uniquement pour l'application Web que vous créez.

Architecture logique

Les applications de service sont déployées au sein d'un même site Web IIS (Internet Information Services). Il s'agit du comportement par défaut et celui-ci ne peut pas être modifié. Toutefois, vous pouvez personnaliser la configuration des groupes d'applications de service et l'association des applications Web aux groupes d'applications de service.

Le diagramme suivant illustre l'architecture logique pour un déploiement plus complexe.

Déploiement d'application de service plus complexe

Notez les caractéristiques suivantes de la batterie de serveurs dans le diagramme :

  • Toutes les applications de service sont contenues dans le même site Web IIS.

  • Il existe deux groupes d'applications de service : le groupe par défaut et un groupe personnalisé. Toutes les applications de service ne doivent pas forcément être incluses dans le groupe par défaut. Dans le diagramme, une instance supplémentaire du service BDC est ajoutée à la batterie de serveurs, mais elle n'est pas incluse dans le groupe par défaut. Elle peut uniquement être utilisée par une application Web.

  • Les applications Web se connectent soit au groupe par défaut, soit à un groupe personnalisé d'applications de service. Le diagramme contient un groupe personnalisé.

Il est possible de déployer les applications de service dans différents pools d'applications pour isoler les processus. Toutefois, si vous souhaitez optimiser les performances de votre batterie de serveurs, nous vous recommandons de déployer des applications de service dans un pool d'applications.

Pour parvenir à isoler physiquement une application de service, choisissez ou créez un autre pool d'applications pour l'application de service.

Connexions pour les applications de service

Lorsque vous créez une application de service, une connexion pour l'application de service est créée en même temps. Une connexion est une entité virtuelle qui connecte les applications Web aux applications de service. Dans Windows PowerShell, ces connexions sont appelées proxys. « Proxy » est indiqué à la fin de la description du type pour les connexions sur la page Gérer les applications de service dans l'Administration centrale.

Administration des applications de service

Les applications de service sont gérées directement dans l'Administration centrale, et non par l'intermédiaire d'un site d'administration distinct. Si nécessaire, vous pouvez surveiller et gérer à distance. Les applications de service peuvent également être gérées et scriptées à l'aide de Windows PowerShell.

Historique des modifications

Date | Description | Raison
2011/01/24 | 2011/01/24 | Mise à jour du contenu


Planifier les collections de sites nommées par l'hôte (SharePoint Foundation 2010)

Dans cet article :

  • À propos des collections de sites nommées par l'hôte

  • À propos des en-têtes d'hôte

  • Créer une collection de sites nommée par l'hôte

  • Créer par programme une collection de sites nommée par l'hôte

  • Utiliser des chemins d'accès gérés avec des collections de sites nommées par l'hôte

  • Exposer des sites nommés par l'hôte sur HTTP ou SSL

  • Configurer le protocole SSL pour des collections de sites nommées par l'hôte

  • Utiliser des collections de sites nommées par l'hôte avec une terminaison SSL hors zone

Microsoft SharePoint Foundation 2010 prend en charge aussi bien les collections de sites nommées par l'hôte que les collections de sites basées sur des chemins. La différence principale entre ces deux collections est que, dans une application Web, toutes les collections de site basées sur des chemins partagent le même nom d'hôte (nom DNS) alors que les collections de sites nommées par l'hôte ont chacune un nom DNS unique.

Les collections de sites basées sur des chemins fournissent une solution d'hébergement d'entreprise où toutes les collections de site partagent le même nom d'hôte de l'application Web. Dans un déploiement basé sur des chemins, vous pouvez disposer d'une collection de sites unique à la racine de l'application Web et des collections de site supplémentaires sous les chemins d'accès gérés au sein de l'application Web.

Les collections de sites nommées par l'hôte fournissent une solution d'hébergement Web modulable où chaque collection de sites est affectée à un nom DNS unique. Dans un déploiement d'hébergement Web, chaque collection de sites nommée par l'hôte possède sa propre URL de nom d'hôte vanity, telle que http://customer1.contoso.com, http://customer2.contoso.com, ou http://www.customer3.com.

SharePoint Foundation 2010 apporte deux améliorations notables aux collections de site nommées par l'hôte : la possibilité d'utiliser des chemins d'accès gérés avec des collections de sites nommées par l'hôte et la possibilité d'utiliser la terminaison SSL hors zone avec des collections de sites nommées par l'hôte.

À propos des collections de sites nommées par l'hôte

Les hébergeurs Web fournissent aux clients un espace de serveur Web pour héberger leurs propres sites Web. Dans un environnement SharePoint Foundation 2010 basé sur le chemin, ces sites sont généralement affectés à http://www.contoso.com/sites/customer1, http://www.contoso.com/sites/customer2, etc. Cependant, les clients d'hébergement Web souhaitent généralement que leurs sites Web soient disponibles sur un nom de domaine vanity, par exemple http://customer1.contoso.com, http://customer2.contoso.com, etc.

Une des méthodes de prise en charge de cette demande des clients est de fournir à chaque client sa propre application Web et d'attribuer le nom DNS unique du client à l'application Web. Cependant, les applications Web SharePoint Foundation 2010 ne s'adaptent pas aussi bien que les collections de sites SharePoint Foundation 2010. SharePoint Foundation 2010 prend en charge des collections de sites nommées par l'hôte comme alternative à la création d'une application Web unique. Les collections de sites nommées par l'hôte peuvent s'adapter à des milliers de collections de sites, car elles peuvent toutes figurer au sein d'une seule application Web tout en offrant la possibilité de créer des noms vanity.

Comme les collections de sites nommées par l'hôte possèdent une seule URL, elles ne prennent pas en charge les mappages des accès de substitution et sont toujours considérées comme appartenant à la zone par défaut. Si vous devez prendre en charge des collections de sites qui répondent à plusieurs URL nommées par l'hôte, vous pouvez envisager d'utiliser des collections de sites basées sur des chemins d'accès avec mappages des accès de substitution au lieu des collections de sites nommées par l'hôte. Vous devez prendre en compte plusieurs options de configuration lorsque vous mettez en service un nouveau site SharePoint Foundation 2010. Définir le modèle de site approprié permet de déterminer quels composants WebPart et autres éléments de l'interface utilisateur sont disponibles sur le nouveau site. Dans un scénario d'hébergement, vous sélectionnerez sans doute un modèle de site d'équipe (valeur « STS#0 » à la création du site) ou un site vide sans composant WebPart ou des listes préexistantes (valeur « STS#1 »). Vous pouvez aussi envisager des quotas de site sur chaque collection de sites récemment mise en service.

À propos des en-têtes d'hôte

Les en-têtes d'hôte renvoient à la portion du protocole HTTP qui indique au serveur Web le nom DNS du site auquel le client se connecte. Vous pouvez appliquer des en-têtes d'hôte à deux niveaux différents dans SharePoint Foundation 2010 :

  • Le niveau de l'application Web (site Web IIS)

  • Le niveau de la collection de sites

Il est important de distinguer les deux niveaux. Les en-têtes d'hôte au niveau de la collection de sites sont réservés aux collections de sites nommées par l'hôte. Dans la plupart des cas, l'application d'une liaison d'en-tête d'hôte au niveau du site Web IIS rend l'accès impossible aux collections de sites nommées par l'hôte via le site Web IIS. En effet, IIS ne répond pas aux demandes de noms d'hôte qui sont différentes de la liaison d'en-tête d'hôte.

Les collections de sites nommées par l'hôte et les collections de sites basés sur des chemins peuvent coexister dans la même application Web et peuvent exister dans plusieurs applications Web. Pour s'assurer que les deux types de collections de site sont accessibles aux utilisateurs, il est recommandé de ne pas insérer de liaisons d'en-têtes d'hôte sur le site Web IIS affectées à la zone par défaut de votre applications Web, si vous avez des collections de sites nommées par l'hôte dans cette application Web. Vous pouvez appliquer des liaisons d'en-têtes d'hôte aux sites Web IIS dans les autres zones de votre application Web. Cela vous permet à la fois d'utiliser la zone par défaut avec des collections de sites nommées par l'hôte et d'utiliser la fonction de mappage des accès de substitution dans les autres zones pour les collections de sites basées sur les chemins.

Vous pouvez modifier manuellement les liaisons d'en-têtes d'hôte sur le site Web IIS depuis le Gestionnaire IIS mais cette procédure n'est pas recommandée. Toutes les modifications apportées depuis le Gestionnaire IIS ne seront pas enregistrées dans SharePoint Foundation 2010. Si SharePoint Foundation 2010 tente de configurer un site Web IIS sur un autre ordinateur dans la batterie de la même zone et de l'application Web, c'est la liaison de l'en-tête d'hôte d'origine qui est utilisée à la place de la liaison modifiée. Pour modifier une liaison existante pour un site Web IIS, supprimez l'application Web de la zone puis étendez de nouveau l'application Web dans la zone avec la liaison que vous souhaitez utiliser.

Créer une collection de sites nommée par l'hôte

Vous devez utiliser Windows PowerShell pour créer une collection de sites nommée par l'hôte. Vous ne pouvez pas utiliser l'application Web Administration Centrale de SharePoint Foundation 2010 pour créer une collection de sites nommée par l'hôte, mais vous pouvez utiliser l'Administration Centrale pour gérer la collection de sites après l'avoir créée.

Vous pouvez créer une collection de sites nommée par l'hôte à l'aide de l'applet de commande Windows PowerShell New-SPSite et du paramètre -HostHeaderWebApplication, comme illustré dans l'exemple suivant :

  1. Pour créer une collection de sites nommée par l'hôte à l'aide de Windows PowerShell, vérifiez que vous répondez à la configuration minimale suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez ce qui suit :

Code de copie
New-SPSite http://host.header.site.url -OwnerAlias DOMAIN\username -
HostHeaderWebApplication http://servername

Cette opération crée une collection de sites nommée par l'hôte avec l'URL http://host.header.site.url dans l'application Web SharePoint Foundation 2010 avec l'URL http://servername.

Créer par programme une collection de sites nommée par l'hôte

Outre l'utilisation de Windows PowerShell pour créer des sites nommés par l'hôte, vous pouvez utiliser le modèle objet SharePoint Foundation 2010. L'exemple de code suivant crée la collection de sites nommée par l'hôte à l'aide de l'URL http://host.header.site.url dans l'application Web SharePoint Foundation 2010 avec l'URL http://servername:

Code de copie
SPWebApplication webApp = SPWebApplication.Lookup(new
Uri("http://www.contoso.com"));
SPSiteCollection sites = webApp.Sites;
SPSite Site = null;
Site = sites.Add("http://hoster.contoso.com", "Site_Title",
"Site_Description", 1033, "STS#0", "contoso\owner",
"Owner_Display_Name", "Owner_Email", "contoso\secondaryowner,
"Secondary_Owner_Display_Name", "Secondary_Owner_Email", true);

SharePoint Foundation 2010 accompagne un jeu de services Web destiné à diverses tâches utilisateur et administratives. Une de ces tâches administratives est de créer une nouvelle collection de sites. La méthode de service Web CreateSite ne prend pas en charge la création de collections de sites nommées par l'hôte. Une solution à ce problème consiste à développer un service Web qui englobe l'exemple de code API.

Utiliser des chemins d'accès gérés avec des collections de sites nommées par l'hôte

SharePoint Foundation 2010 ajoute une prise en charge au niveau des chemins d'accès gérés avec des collections de sites nommées par l'hôte. En effet, les hébergeurs peuvent fournir plusieurs collections de sites nommées par l'hôte au même client où chaque collection de sites partage le nom d'hôte unique du client mais que distingue le chemin d'accès d'URL après le nom d'hôte.

Les chemins d'accès gérés destinés aux collections de sites nommées par l'hôte sont différents des chemins d'accès gérés destinés aux collections de sites basées sur des chemins. Les chemins d'accès destinés aux collections de sites nommées par l'hôte ne s'appliquent pas aux collections de sites basées sur des chemins d'accès, et inversement. Les chemins d'accès créés pour les collections de sites nommées par l'hôte sont disponibles pour toutes les collections de sites nommées par l'hôte au sein de la batterie, indépendamment de l'application Web qui contient la collection de sites nommée par l'hôte. Vous devez créer une collection de sites nommée par l'hôte racine pour un nom d'hôte avant de pouvoir créer une collection de sites nommée par l'hôte de chemin d'accès géré pour ce même nom d'hôte.

Vous pouvez créer un chemin d'accès géré destiné à des collections de sites nommées par l'hôte à l'aide de l'applet de commandes Windows PowerShell New-SPManagedPath et du paramètre -HostHeader, comme illustré dans l'exemple suivant :

Code de copie
New-SPManagedPath pathname -HostHeader

L'exemple suivant montre une collection de sites nommée par l'hôte créée à un chemin d'accès géré :

Code de copie
New-SPSite http://host.header.site.url/pathname/sitename -OwnerAlias DOMAIN\username -HostHeaderWebApplication http://servername

Exposer des sites nommés par l'hôte sur HTTP ou SSL

Les collections de sites nommées par l'hôte utilisent le même schéma de protocole que l'URL publique dans la zone par défaut de leur application Web. Si vous souhaitez fournir des collections de sites nommées par l'hôte dans votre application Web sur HTTP, vérifiez que l'URL publique dans la zone par défaut de votre application Web est une URL HTTP. Si vous souhaitez fournir des collections de sites nommées par l'hôte dans votre application Web sur SSL, vérifiez que l'URL publique dans la zone par défaut de votre application Web est une URL HTTPS.

Contrairement à une version antérieure, SharePoint Foundation 2010 ne prend pas en charge une collection de sites nommée par l'hôte qui utilise des URL HTTP et SSL simultanément. Si certaines collections de sites nommées par l'hôte doivent être disponibles sur HTTP et d'autres collections de sites nommées par l'hôte disponibles sur SSL, répartissez les collections de sites nommées par l'hôte dans deux applications Web séparées pour ce type d'accès. Dans ce scénario, les collections de sites nommées par l'hôte HTTP doivent appartenir à une application Web dédiée à un accès HTTP et les collections de sites nommées par l'hôte SSL doivent appartenir à une application Web dédiée à un accès SSL.

Configurer le protocole SSL pour des collections de sites nommées par l'hôte

Dans les scénarios d'hébergement, les hébergeurs peuvent configurer une seule application Web à l'aide du protocole SSL puis créer plusieurs collections de sites nommées par l'hôte au sein de cette application Web. Pour parcourir un site à l'aide du protocole SSL, un certificat de serveur doit être installé et affecté au site Web IIS. Chaque collection de sites nommée par l'hôte dans une application Web partagera le certificat de serveur unique affecté au site Web IIS.

Les hébergeurs doivent se procurer une certificat générique ou un certificat d'un autre nom d'objet puis utiliser une stratégie URL de collection de sites nommée par l'hôte qui correspond à ce certificat. Par exemple, si un hébergeur acquiert un certificat générique *.contoso.com, il doit générer des URL de collection de sites nommée par l'hôte telles que https://site1.contoso.com, https://site2.contoso.com, etc, pour permettre à ces sites d'être validés par le protocole SSL. Cependant, si des clients nécessitent des noms de domaine de niveau secondaire uniques pour leurs sites, l'hébergeur doit créer plusieurs applications Web au lieu de plusieurs collections de sites nommées par l'hôte.

Pour configurer le protocole SSL pour les collections de sites nommées par l'hôte, activez-le lors de la création de l'application Web. Cette opération va créer un site Web IIS avec une liaison SSL au lieu d'une liaison HTTP. Une fois l'application Web créée, ouvrez le Gestionnaire IIS et affectez un certificat à cette liaison SSL. Vous pouvez ensuite créer des collections de sites dans cette application Web.

Utiliser des collections de sites nommées par l'hôte avec une terminaison SSL hors zone

Comme SharePoint Foundation 2010 fait appel à l'URL publique dans la zone par défaut de l'application Web pour déterminer si des collections de sites nommées par l'hôte seront rendues par le protocole HTTP ou SSL, vous pouvez désormais utiliser des collections de sites nommées par l'hôte avec une terminaison SSL hors zone. L'utilisation de la terminaison SSL avec des collections de sites nommées par l'hôte est soumise à 3 conditions :

  • L'URL publique dans la zone par défaut de l'application Web doit être une URL HTTPS.

  • La terminaison SSL ou le proxy inversé doit conserver l'en-tête d'hôte HTTP d'origine du client.

  • Si la demande SSL du client est envoyée au port SSL par défaut (443), la terminaison ou le proxy inversé doit transmettre la demande HTTP déchiffrée au serveur Web frontal sur le port HTTP par défaut (80). Si la demande SSL du client est envoyée à un port SSL qui n'est pas le port par défaut, la terminaison SSL ou le proxy inversé doit transmettre la demande HTTP déchiffrée au serveur Web frontal sur ce même port.

Pour utiliser les collections de sites nommées par l'hôte avec une terminaison SSL hors zone, configurez votre application Web comme pour une terminaison SSL et vérifiez qu'elle répond aux critères précités. Dans ce scénario, SharePoint Foundation 2010 va rendre les liaisons de ses collections de sites nommées par l'hôte de cette application Web à l'aide du protocole HTTPS au lieu du protocole HTTP.

Historique des modifications

Date | Description | Raison
17 juin 2010 | Publication initiale |


Planifier l'authentification (SharePoint Foundation 2010)

Cette section décrit comment planifier l'authentification.

Dans cette section :

  • Planifier des méthodes d'authentification (SharePoint Foundation 2010)

  • Planifier l'authentification par revendications (SharePoint Foundation 2010)

Historique des modifications


Planifier des méthodes d'authentification (SharePoint Foundation 2010)

Cet article décrit les modes et méthodes d'authentification pris en charge par Microsoft SharePoint Foundation 2010. L'authentification est le processus de validation de l'identité d'un utilisateur. Une fois l'identité d'un utilisateur validée, le processus d'autorisation détermine à quels sites, contenus et autres fonctionnalités l'utilisateur peut accéder. Les modes d'authentification déterminent la façon dont les comptes sont utilisés en interne par SharePoint Foundation 2010.

Dans cet article :

  • Méthodes d'authentification prises en charge

  • Modes d'authentification — classique ou basée sur les revendications

  • Implémentation de l'authentification Windows

  • Implémentation de l'authentification basée sur les formulaires

  • Implémentation de l'authentification basée sur les jetons SAML

  • Choix de l'authentification pour les environnements LDAP

  • Planification des zones pour les applications Web

  • Architecture des fournisseurs basés sur jetons SAML

Méthodes d'authentification prises en charge

SharePoint Foundation 2010 prend en charge les méthodes d'authentification qui étaient fournies avec les versions précédentes et introduit également l'authentification basée sur les jetons et sur le langage SAML (Security Assertion Markup Language) en guise d'option. Le tableau suivant répertorie les méthodes d'authentification prises en charge.

Méthode Exemples Remarques

Authentification Windows
  • NTLM

  • Kerberos

  • Anonyme

  • De base

  • Digest

À l'heure actuelle, l'authentification par certificat Windows n'est pas prise en charge.

Authentification basée sur les formulaires

  • LDAP (Lightweight Directory Access Protocol)

  • Base de données SQL ou autre

  • Fournisseurs d'appartenances et de rôles personnalisés ou tiers

Authentification par jeton SAML
  • Services AD FS (Active Directory Federation Services) 2.0

  • Fournisseur d'identités tiers

  • Protocole LDAP (Lightweight Directory Access Protocol)

Prise en charge uniquement avec SAML 1.1 qui utilise le profil WS-Federation Passive.

Modes d'authentification — classique ou basée sur les revendications

SharePoint Foundation 2010 introduit l'authentification basée sur les revendications, qui repose sur Windows Identity Foundation (WIF). Vous pouvez utiliser n'importe laquelle des méthodes d'authentification prises en charge avec l'authentification basée sur les revendications ou utiliser le mode d'authentification classique, qui prend en charge l'authentification Windows.

Lorsque vous créez une application Web, vous sélectionnez l'un des deux modes d'authentification disponibles pour l'application Web (mode classique ou basé sur les revendications).

Authentification par revendication ou authentification en mode classique

Si vous sélectionnez le mode classique, vous pouvez implémenter l'authentification Windows ; dans ce cas, les comptes d'utilisateurs sont traités par SharePoint Foundation 2010 comme des comptes AD DS (Active Directory Domain Services).

Si vous sélectionnez l'authentification basée sur les revendications, SharePoint Foundation 2010 modifie automatiquement tous les comptes d'utilisateurs en identités de revendications, ce qui génère un jeton de revendication pour chaque utilisateur. Le jeton de revendication contient les revendications liées à l'utilisateur. Les comptes Windows sont convertis en revendications Windows. Les utilisateurs d'appartenance (membership users) basée sur formulaires sont convertis en revendications d'authentification basée sur formulaires. Les revendications incluses dans les jetons SAML peuvent être utilisées par SharePoint Foundation 2010. Par ailleurs, les développeurs et administrateurs SharePoint peuvent augmenter les jetons utilisateur avec des revendications supplémentaires. Par exemple, les comptes d'utilisateurs Windows et les comptes d'utilisateurs basés sur formulaires peuvent être augmentés avec des revendications supplémentaires utilisées par SharePoint Foundation 2010.

Le graphique suivant résume la prise en charge des types d'authentification pour chaque mode d'authentification.

Type Mode d'authentification classique Authentification basée sur les revendications

Authentification Windows

  • NTLM

  • Kerberos

  • Anonyme

  • De base

  • Digest

Oui

Oui

Authentification basée sur les formulaires

  • LDAP

  • Base de données SQL ou autre

  • Fournisseurs d'appartenances et de rôles personnalisés ou tiers

Non

Oui

Authentification basée sur les jetons SAML

  • Services AD FS 2.0

  • Windows Live ID

  • Fournisseur d'identités tiers

  • LDAP

Non

Oui

Une batterie SharePoint Foundation 2010 peut inclure une combinaison d'applications Web qui utilisent les deux modes. Les services ne font pas de distinction entre les comptes d'utilisateurs qui sont des comptes Windows traditionnels et les comptes de revendications Windows. Par conséquent, un utilisateur qui appartient à des sites configurés de façon à utiliser une combinaison de modes d'authentification recevra des résultats de recherche incluant des résultats provenant de tous les sites auquel l'utilisateur a accès, quel que soit le mode configuré pour les applications Web. L'utilisateur n'est pas interprété comme étant deux comptes d'utilisateurs différents car les services et applications de service utilisent des identités de revendications pour les communications inter-batterie, quel que soit le mode sélectionné pour les applications Web et les utilisateurs.

En revanche, les utilisateurs qui appartiennent à plusieurs référentiels d'utilisateurs reconnus par des applications Web SharePoint Server sont traités comme des comptes d'utilisateurs distincts, selon l'identité utilisée pour ouvrir la session.

Les conseils suivants vous aideront à décider du mode à sélectionner :

  • Pour les nouvelles implémentations de SharePoint Foundation 2010, utilisez l'authentification basée sur les revendications. Avec cette option, tous les types d'authentification pris en charge sont disponibles pour les applications Web. Il n'existe aucune raison concrète de sélectionner le mode d'authentification classique pour les nouveaux déploiements, même si votre environnement comprend uniquement des comptes Windows. L'authentification Windows est implémentée de la même manière, quel que soit le mode sélectionné. Aucune étape supplémentaire n'est nécessaire à l'implémentation de l'authentification Windows lorsque vous utilisez le mode d'authentification basée sur les revendications.

  • Si vous mettez à niveau une solution de version antérieure vers SharePoint Foundation 2010 et que la solution comprend uniquement des comptes Windows, vous pouvez utiliser le mode d'authentification classique. Cela vous permet d'utiliser la même conception pour les zones et les URL.

  • Si vous mettez à niveau une solution qui requiert l'authentification basée sur les formulaires, la seule option consiste à effectuer une mise à niveau vers l'authentification basée sur les revendications.

Si vous effectuez une mise à niveau à partir d'une version antérieure vers SharePoint Foundation 2010 et que vous sélectionnez l'authentification basée sur les revendications, prenez note des considérations suivantes :

  • Vous devrez peut-être modifier le code personnalisé. Les composants WebPart ou autre code personnalisé qui utilisent ou reposent sur des identités Windows devront être mis à jour. Si le code personnalisé utilise des identités Windows, utilisez le mode d'authentification classique jusqu'à ce que le code ait été mis à jour.

  • La migration de nombreux utilisateurs Windows vers les identités de revendications prend du temps. Lorsque vous modifiez une application Web du mode classique au mode basé sur les revendications durant le processus de mise à niveau, vous devez utiliser Windows PowerShell pour convertir les identités Windows en identités de revendications. Ce processus peut être long. Assurez-vous de disposer de suffisamment de temps lors du processus de mise à niveau pour effectuer cette tâche.

  • Les alertes de recherche ne sont pas prises en charge actuellement avec l'authentification basée sur les revendications.

L'authentification basée sur les revendications repose sur WIF. WIF est un ensemble de classes .NET Framework servant à implémenter l'identité basée sur les revendications. L'authentification basée sur les revendications repose sur des normes telles que WS-Federation et WS-Trust et sur des protocoles tels que SAML. Pour plus d'informations sur l'authentification basée sur les revendications, voir les ressources suivantes :

  • Identité basée sur les revendications pour Windows : Introduction à Active Directory Federation Services 2.0, Windows CardSpace 2.0 et Windows Identity Foundation (livre blanc) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198942&clcid=0x40C)

  • Page d'accueil de Windows Identity Foundation (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198943&clcid=0x40C)

Il n'est pas nécessaire d'être architecte de revendications pour utiliser l'authentification basée sur les revendications dans SharePoint Foundation 2010. Toutefois, l'implémentation de l'authentification basée sur les jetons SAML requiert une coordination avec les administrateurs de votre environnement basé sur les revendications, comme décrit plus loin dans cet article.

Implémentation de l'authentification Windows

Le processus d'implémentation des méthodes d'authentification Windows est similaire pour les deux modes d'authentification (classique et basé sur les revendications). Le fait de choisir l'authentification basée sur les revendications pour une application Web n'accroît pas la complexité de l'implémentation des méthodes d'authentification Windows. Cette section résume le processus pour chaque méthode.

Authentification Windows intégrée — Kerberos et NTLM

Le protocole Kerberos et NTLM sont des méthodes d'authentification Windows intégrée qui permettent aux clients de s'authentifier de façon transparente sans être invités à fournir d'informations d'identification. Les utilisateurs qui accèdent à des sites SharePoint à partir de l'Explorateur Windows s'authentifieront à l'aide des informations d'identification sous lesquelles s'exécute le processus Internet Explorer. Par défaut, il s'agit des informations d'identification employées par l'utilisateur pour ouvrir une session sur l'ordinateur. Les services ou applications qui accèdent à SharePoint Server en mode d'authentification Windows intégrée tenteront de s'authentifier à l'aide des informations d'identification du thread en cours d'exécution, qui correspondent à l'identité du processus par défaut.

NTLM est la forme d'authentification Windows la plus simple à implémenter. Il vous suffit de sélectionner cette option lors de la création d'une application Web.

Le protocole Kerberos est un protocole sécurisé qui prend en charge l'authentification par ticket. Son utilisation nécessite une configuration supplémentaire de l'environnement. Pour activer l'authentification Kerberos, les ordinateurs client et serveur doivent disposer d'une connexion approuvée au centre de distribution de clés du domaine. Pour configurer le protocole Kerberos, vous devez configurer des noms de principaux du service dans les services AD DS avant d'installer SharePoint Foundation 2010.

Les étapes suivantes récapitulent le processus de configuration de l'authentification Kerberos :

  1. Configurer l'authentification Kerberos pour les communications SQL en créant des noms de principaux du service dans les services AD DS pour le compte de service SQL Server.

  2. Créez des noms de principaux du service pour les applications Web qui utiliseront l'authentification Kerberos.

  3. Installez la batterie SharePoint Foundation 2010.

  4. Configurez des services spécifiques dans la batterie de façon à utiliser des comptes spécifiques.

  5. Créez les applications Web qui utiliseront l'authentification Kerberos.

Pour plus d'informations, voir Configure Kerberos authentication (SharePoint Server 2010).

De plus, pour les applications Web à authentification basée sur les revendications, le service d'émission de jetons Revendications vers Windows doit être configuré pour la délégation contrainte. Celle-ci est nécessaire pour convertir les revendications en jetons Windows. Pour les environnements qui comprennent plusieurs forêts, une approbation bidirectionnelle entre les forêts est nécessaire pour utiliser le service d'émission de jetons Revendications vers Windows. Pour plus d'informations sur la façon de configurer ce service, voir Configure Kerberos authentication for the claims to Windows token service (SharePoint Server 2010).

L'authentification Kerberos autorise la délégation des informations d'identification clientes afin d'accéder aux systèmes de données principaux, ce qui nécessite une configuration supplémentaire en fonction du scénario. Des exemples sont fournis dans le tableau suivant.

Scénario | Configuration supplémentaire
Délégation de l'identité d'un client à un serveur principal. Affichage de flux RSS à du contenu authentifié. | Configurer la délégation contrainte Kerberos pour des ordinateurs et des comptes de service.
Délégation d'identité pour Microsoft SQL Server Reporting Services (SSRS) | Configurer des noms de principaux du service pour des comptes SQL Server Reporting Services. Configurer la délégation pour SQL Server Reporting Services.
Délégation d'identité pour Excel Services dans SharePoint | Configurer la délégation contrainte pour des serveurs Excel Services. Configurer la délégation contrainte pour le compte de service Excel Services.

Pour plus d'informations sur la façon de configurer l'authentification Kerberos, notamment sur les étapes de configuration pour les scénarios courants, voir Configuration de l'authentification Kerberos pour les produits et technologies Microsoft SharePoint 2010 (livre blanc) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=197178&clcid=0x40C).

Digest et De base

L'implémentation de l'authentification Digest et De base nécessite de configurer ces méthodes d'authentification directement dans les services Internet (IIS, Internet Information Services).

Implémentation de l'authentification basée sur les formulaires

L'authentification basée sur les formulaires est un système de gestion des identités basée sur l'authentification par fournisseur de rôles et d'appartenances ASP.NET. Dans SharePoint Foundation 2010, l'authentification basée sur les formulaires est disponible uniquement lorsque vous utilisez l'authentification basée sur les revendications.

L'authentification basée sur les formulaires peut être utilisée contre des informations d'identification stockées dans les services AD DS, dans une base de données telle qu'une base de données SQL Server ou dans un magasin de données LDAP (Lightweight Directory Access Protocol) tel que Novell eDirectory, NDS (Novell Directory Services) ou Sun ONE. L'authentification basée sur les formulaires autorise l'authentification de l'utilisateur en fonction de la validation de l'entrée des informations d'identification à partir d'un formulaire d'ouverture de session. Les demandes non authentifiées sont redirigées vers une page d'ouverture de session, dans laquelle l'utilisateur doit fournir des informations d'identification valides et envoyer le formulaire. Si la demande peut être authentifiée, le système émet un cookie contenant une clé pour rétablir l'identité pour les demandes suivantes.

Pour utiliser l'authentification basée sur les formulaires pour authentifier des utilisateurs par rapport à un système de gestion des identités qui n'est pas basé sur Windows ou qui est externe, vous devez inscrire le fournisseur d'appartenances et le gestionnaire de rôles dans le fichier Web.config. L'inscription du gestionnaire de rôles est une nouvelle exigence dans SharePoint Foundation 2010. Dans la version précédente, elle était facultative. SharePoint Foundation 2010 utilise l'interface standard du gestionnaire de rôles ASP.NET pour recueillir des informations de groupe concernant l'utilisateur actuel. Chaque rôle ASP.NET est traité comme un groupe de domaines par le processus d'autorisation dans SharePoint Foundation 2010. L'inscription des gestionnaires de rôles dans le fichier Web.config s'effectue de la même manière que celle des fournisseurs d'appartenances pour l'authentification.

Si vous souhaitez gérer les utilisateurs d'appartenances (membership users) ou les rôles à partir du site Web Administration centrale de SharePoint, vous devez inscrire le fournisseur d'appartenances et le gestionnaire de rôles dans le fichier web.config du site Web Administration centrale. Vous devez également inscrire le fournisseur d'appartenances et le gestionnaire de rôles dans le fichier web.config de l'application Web qui héberge le contenu.

Pour plus d'informations sur la façon de configurer l'authentification basée sur les formulaires, voir les ressources suivantes :

  • Article TechNet : Configure forms-based authentication for a claims-based Web application (SharePoint Server 2010)

  • Article de blog MSDN : Fiche d'aide pour l'authentification basée sur les revendications - Partie 1 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198944&clcid=0x40C)

  • Article MSDN : Authentification par formulaire dans les produits et technologies SharePoint (Partie 2) : exemples de fournisseurs de rôles et d'appartenances (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198945&clcid=0x40C)

Implémentation de l'authentification basée sur les jetons SAML

L'authentification basée sur les jetons SAML nécessite une coordination avec les administrateurs d'un environnement basé sur les revendications, qu'il s'agisse de votre propre environnement interne ou d'un environnement partenaire. AD FS 2.0 est un exemple d'environnement basé sur les revendications.

Un environnement basé sur les revendications comprend un service de jetons de sécurité de fournisseur d'identité (IP-STS, Identity Provider Security Token Service). Le service IP-STS émet des jetons SAML pour le compte des utilisateurs qui sont inclus dans l'annuaire d'utilisateurs associé. Les jetons peuvent inclure une quantité quelconque de revendications relatives à un utilisateur, telles qu'un nom d'utilisateur et les groupes auxquels l'utilisateur appartient.

SharePoint Foundation 2010 tire parti des revendications incluses dans les jetons fournis par un service IP-STS pour autoriser les utilisateurs. Dans les environnements à revendications, une application qui accepte des jetons SAML porte le nom de partie de confiance STS (RP-STS, Relying Party STS). Une application partie de confiance reçoit le jeton SAML et utilise les revendications qui s'y trouvent pour décider s'il faut accorder au client l'accès à la ressource demandée. Dans Produits SharePoint 2010, chaque application Web configurée de façon à utiliser un fournisseur SAML est ajoutée au serveur IP-STS en tant qu'entrée RP-STS distincte. Une batterie SharePoint peut comprendre plusieurs entrées RP-STS.

L'implémentation de l'authentification basée sur les jetons SAML avec Produits SharePoint 2010 implique les processus suivants qui requièrent une planification approfondie :

  1. Exportez le certificat de signature de jetons à partir du service IP-STS. Ce certificat porte le nom d'ImportTrustCertificate. Copiez le certificat sur un ordinateur serveur dans la batterie SharePoint Foundation 2010.

  2. Définissez la revendication qui sera utilisée comme identificateur unique de l'utilisateur. Elle porte le nom de revendication d'identité. De nombreux exemples de ce processus utilisent le nom de courrier électronique de l'utilisateur en guise d'identificateur utilisateur. Collaborez avec l'administrateur du service IP-STS afin de déterminer l'identificateur correct, car seul le propriétaire du service IP-STS sait quelle valeur dans le jeton sera toujours unique à chaque utilisateur. L'identification de l'identificateur unique de l'utilisateur fait partie du processus de mappage de revendications. La création des mappages de revendications s'effectue à l'aide de Windows PowerShell.

  3. Définissez les mappages de revendications supplémentaires. Définissez les revendications supplémentaires du jeton entrant qui seront utilisées par la batterie SharePoint Foundation 2010. Les rôles des utilisateurs sont un exemple de revendication pouvant être utilisée pour accorder des autorisations aux ressources dans la batterie SharePoint Foundation 2010. Toutes les revendications d'un jeton entrant qui ne possèdent pas de mappage sont rejetées.

  4. Créez un fournisseur d'authentification à l'aide de Windows PowerShell afin d'importer le certificat de signature de jetons. Ce processus crée le SPTrustedIdentityTokenIssuer. Durant ce processus, vous spécifiez la revendication d'identité et les revendications supplémentaires que vous avez mappées. Vous devez également créer et spécifier un domaine associé aux premières applications Web SharePoint que vous configurez pour l'authentification basée sur les jetons SAML. Une fois le SPTrustedIdentityTokenIssuer créé, vous pouvez créer et ajouter davantage de domaines pour des applications Web SharePoint supplémentaires. C'est ainsi que vous configurez plusieurs applications Web de façon à utiliser le même SPTrustedIdentityTokenIssuer.

  5. Pour chaque domaine ajouté au SPTrustedIdentityTokenIssuer, vous devez créer une entrée RP-STS sur le service IP-STS. Cette opération peut s'effectuer avant la création de l'application Web SharePoint. Quoi qu'il en soit, vous devez planifier l'URL avant de créer les applications Web.

  6. Créez une application Web SharePoint et configurez-la de façon à utiliser le fournisseur d'authentification nouvellement créé. Celui-ci apparaît comme une option dans l'Administration centrale lorsque le mode de revendications est sélectionné pour l'application Web.

Vous pouvez configurer plusieurs fournisseurs d'authentification basée sur les jetons SAML. Cependant, vous ne pouvez utiliser un certificat de signature de jetons qu'une seule fois dans une batterie. Tous les fournisseurs configurés apparaissent comme des options dans l'Administration centrale. Les revendications issues de différents environnements STS approuvés n'entrent pas en conflit.

Si vous implémentez l'authentification basée sur les jetons SAML avec une société partenaire et que votre propre environnement comprend un service IP-STS, nous vous recommandons de collaborer avec l'administrateur de votre environnement de revendications interne afin d'établir une relation d'approbation de votre service IP-STS interne vers le service STS partenaire. Cette approche ne nécessite pas l'ajout d'un fournisseur d'authentification supplémentaire à votre batterie SharePoint Foundation 2010. Elle permet également à votre administrateur de revendications de gérer l'ensemble de l'environnement de revendications.

Remarque :
Si vous utilisez l'authentification basée sur les jetons SAML avec les services AD FS sur une batterie SharePoint Foundation 2010 qui possède plusieurs serveurs Web dans une configuration à équilibrage de la charge, il se peut que vous constatiez un impact sur les performances et la fonctionnalité des visualisations de pages Web clientes. Lorsque les services AD FS fournissent le jeton d'authentification au client, ce jeton est soumis à SharePoint Foundation 2010 pour chaque élément de page à l'autorisation restreinte. Si la solution d'équilibrage de la charge n'utilise pas l'affinité, chaque élément sécurisé est authentifié auprès de plusieurs serveurs SharePoint Foundation 2010, ce qui peut entraîner un rejet du jeton. Une fois le jeton rejeté, SharePoint Foundation 2010 redirige le client afin qu'il se réauthentifie auprès du serveur AD FS. Après cela, un serveur AD FS peut rejeter plusieurs demandes effectuées durant un court laps de temps. Ce comportement est inhérent au produit et destiné à assurer une protection contre les attaques par déni de service. Si vous observez une dégradation des performances ou si des pages ne se chargent pas complètement, configurez l'équilibrage de la charge réseau avec l'affinité unique, de manière à isoler les demandes de jetons SAML sur un serveur Web unique.

Pour plus d'informations sur la façon de configurer l'authentification basée sur les jetons SAML, voir les ressources suivantes :

  • Article TechNet : Configure authentication using a SAML security token (SharePoint Server 2010)

  • Article de blog MSDN : Fiche d'aide pour l'authentification basée sur les revendications - Partie 2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198946&clcid=0x40C)

  • Article de blog TechNet : Considérations relatives à la planification de l'authentification basée sur les revendications dans SharePoint 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198947&clcid=0x40C)

  • Article de blog TechNet : Création d'une revendication d'identité et de rôle pour une application SharePoint 2010 à authentification basée sur les revendications (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198948&clcid=0x40C)

  • Article de blog TechNet : Comment créer plusieurs applications Web à authentification basée sur les formulaires dans une même batterie Single SharePoint 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=198949&clcid=0x40C)

Choix de l'authentification pour les environnements LDAP

Il est possible d'implémenter des environnements LDAP avec l'authentification basée sur des formulaires ou l'authentification basée sur les jetons SAML. Nous vous recommandons d'utiliser l'authentification basée sur des formulaires car elle est mois complexe. Néanmoins, si l'environnement prend en charge WS-Federation 1.1 et SAML Token 1.1, il est conseillé de recourir à l'authentification basée sur les jetons SAML La synchronisation des profils n'est pas prise en charge avec les fournisseurs LDAP qui ne sont pas associés à ADFS 2.0.

Planification des zones pour les applications Web

Les zones représentent différents itinéraires logiques permettant d'accéder aux mêmes sites dans une applications Web. Chaque application Web peut inclure jusqu'à cinq zones. Lors de la création d'une application Web, la zone par défaut est créée. Il est possible de créer des zones supplémentaires en étendant l'application Web et en sélectionnant l'un des noms de zones restants : intranet, extranet, Internet ou personnalisé.

Dans les versions précédentes, les zones servaient à implémenter différents types d'authentification pour les utilisateurs provenant de différents réseaux ou fournisseurs d'authentification. Dans la version actuelle, l'authentification par revendications permet d'implémenter plusieurs types d'authentification sur la même zone.

Le plan des zones dépendra du mode sélectionné pour une application Web, parmi les suivants :

  • Mode classique — Semblable aux versions précédentes ; un seul type d'authentification peut être implémenté par zone. Toutefois, dans la version actuelle, seule l'authentification Windows peut être implémentée lorsque le mode classique est sélectionné. Par conséquent, il est possible d'utiliser plusieurs zones uniquement pour implémenter plusieurs types d'authentification Windows ou pour implémenter le même type d'authentification Windows contre différents magasins Active Directory.

  • Authentification basée sur les revendications — Plusieurs fournisseurs d'authentification peuvent être implémentés sur une même zone. Il est également possible d'utiliser plusieurs zones.

Implémentation de plusieurs types d'authentification sur une même zone

Si vous utilisez l'authentification basée sur les revendications et que vous implémentez plus d'un type d'authentification, nous vous recommandons d'implémenter plusieurs types d'authentification sur la zone par défaut. Cela génère la même URL pour tous les utilisateurs.

Lorsque vous implémentez plusieurs types d'authentification sur la même zone, les restrictions suivantes sont applicables :

  • Une seule instance d'authentification basée sur les formulaires peut être implémentée sur une zone.

  • L'Administration centrale vous permet d'utiliser l'authentification Windows intégrée et l'authentification de base simultanément. Autrement, il est impossible d'implémenter plusieurs types d'authentification Windows sur une zone.

Si plusieurs fournisseurs d'authentification basée sur les jetons SAML sont configurés pour une batterie, ils apparaîtront comme options lors de la création d'une application Web ou d'une zone. Il est possible de configurer plusieurs fournisseurs SAML sur la même zone.

Le diagramme suivant illustre plusieurs types d'authentification implémentés sur la zone par défaut pour un site de collaboration partenaire.

Types d'authentification multiples sur une zone

Sur le diagramme, les utilisateurs de différents magasins d'annuaires accèdent au site Web partenaire à l'aide de la même URL. Une case en pointillé entourant les sociétés partenaires indique la relation entre l'annuaire d'utilisateurs et le type d'authentification configuré dans la zone par défaut. Pour plus d'informations sur cet exemple de conception, voir Design sample: Corporate deployment (SharePoint Server 2010).

Planification de l'analyse du contenu

Le composant d'analyse requiert l'accès au contenu avec NTLM. Au moins une zone doit être configurée de façon à utiliser l'authentification NTLM. Si l'authentification NTLM n'est pas configurée sur la zone par défaut, le composant d'analyse peut utiliser une zone différente configurée de façon à utiliser l'authentification NTLM.

Implémentation de plusieurs zones

Si vous prévoyez d'implémenter plusieurs zones pour des applications Web, utilisez les instructions suivantes :

  • Utilisez la zone par défaut pour implémenter les paramètres d'authentification les plus sécurisés. Si une demande ne peut pas être associée à une zone spécifique, les paramètres d'authentification et autres stratégies de sécurité de la zone par défaut sont appliqués. La zone par défaut est la zone créée lorsque vous créez initialement une application Web. En règle générale, les paramètres d'authentification les plus sécurisés sont conçus pour l'accès de l'utilisateur final. Par conséquent, les utilisateurs finaux sont susceptibles d'accéder à la zone par défaut.

  • Utilisez le nombre minimal de zones nécessaires pour fournir l'accès aux utilisateurs. Chaque zone est associée à un nouveau site IIS et domaine pour accéder à l'application Web. Ajoutez uniquement de nouveaux points d'accès lorsqu'ils sont nécessaires.

  • Vérifiez qu'au moins une zone est configurée pour utiliser l'authentification NTLM pour le composant d'analyse. Ne créez pas de zone dédiée pour le composant d'index, sauf si cela est nécessaire.

Le diagramme suivant montre plusieurs zones implémentées de façon à gérer plusieurs types d'authentification pour un site de collaboration partenaire.

Une zone pour chaque type d'authentification

Sur le diagramme, la zone par défaut est utilisée pour les employés distants. Chaque zone est associée à une URL différente. Les employés utilisent une zone différente selon qu'ils travaillent au bureau ou à distance. Pour plus d'informations sur cet exemple de conception, voir Design sample: Corporate deployment (SharePoint Server 2010).

Architecture des fournisseurs basés sur jetons SAML

L'architecture d'implémentation des fournisseurs basés sur jetons SAML comprend les composants suivants :

Service d'émission de jeton de sécurité SharePoint Ce service crée les jetons SAML utilisés par la batterie. Il est créé et démarré automatiquement sur tous les serveurs d'une batterie de serveurs. On l'utilise pour les communications entre les batteries car toutes les communications entre les batteries utilisent l'authentification par revendications. On l'utilise également pour les méthodes d'authentification implémentées pour des applications Web qui utilisent l'authentification par revendications, y compris l'authentification Windows, l'authentification basée sur les formulaires et l'authentification basée sur les jetons SAML. Vous devez configurer le service d'émission de jeton de sécurité lors du processus de déploiement. Pour plus d'informations, voir Configure the security token service (SharePoint Server 2010).

Certificat de signature de jetons (ImportTrustCertificate) Il s'agit du certificat exporté à partir d'un service IP-STS. Le certificat est copié sur un serveur de la batterie. Une fois que vous avez utilisé ce certificat pour créer un SPTrustedIdentityTokenIssuer, vous ne pouvez plus l'utiliser pour en créer un autre. Si vous souhaitez utiliser le certificat pour créer un SPTrustedIdentityTokenIssuer différent, vous devez tout d'abord supprimer le SPTrustedIdentityTokenIssuer existant. Avant cela, vous devez le dissocier de toute application Web susceptible de l'utiliser.

Revendication d'identité La revendication d'identité est la revendication tirée d'un jeton SAML qui constitue l'identificateur unique de l'utilisateur. Seul le propriétaire du service IP-STS connaît la valeur dans le jeton qui est unique à chaque utilisateur. La revendication d'identité est créée en tant que mappage de revendications ordinaire lors du processus de mappage de toutes les revendications souhaitées. La revendication qui sert de revendication d'identité est déclarée lors de la création du SPTrustedIdentityTokenIssuer.

Autres revendications Il s'agit de revendications supplémentaires tirées d'un ticket SAML qui décrivent les utilisateurs. Il peut s'agir de rôles des utilisateurs, de groupes d'utilisateurs ou d'autres types de revendications telles que l'âge. Tous les mappages de revendications sont créés en tant qu'objets répliqués sur les serveurs d'une batterie SharePoint Foundation.

Domaine Dans l'architecture de revendications de SharePoint, l'URI ou URL associée à une application Web SharePoint configurée de façon à utiliser un fournisseur basé sur les jetons SAML représente un domaine. Lorsque vous créez un fournisseur basé sur les jetons SAML dans la batterie, vous spécifiez un à la fois les domaines, ou URL d'applications Web, que vous souhaitez que le service IP-STS reconnaisse. Vous spécifiez le premier domaine lors de la création du SPTrustedIdentityTokenIssuer. Des revendications supplémentaires peuvent être ajoutées après la création du SPTrustedIdentityTokenIssuer. Vous devez spécifier les domaines à l'aide d'une syntaxe semblable à la suivante : $realm = "urn:sharepoint:mysites". Après avoir ajouté le domaine au SPTrustedIdentityTokenIssuer, vous devez créer une approbation RP-STS avec le domaine sur le serveur IP-STS. Ce processus nécessite de spécifier l'URL de l'application Web.

SPTrustedIdentityTokenIssuer Il s'agit de l'objet créé dans la batterie SharePoint qui inclut les valeurs nécessaires pour communiquer avec le service IP-STS et recevoir des jetons à partir de ce service. Lors de la création du SPTrustedIdentityTokenIssuer, vous spécifiez le certificat de signature de jetons à utiliser, le premier domaine, la revendication qui représente la revendication d'identité et les éventuelles revendications supplémentaire. Vous ne pouvez associer un certificat de signature de jetons d'un service STS qu'à un seul SPTrustedIdentityTokenIssuer. Toutefois, après avoir créé le SPTrustedIdentityTokenIssuer, vous pouvez ajouter des domaines supplémentaires pour d'autres applications Web. Une fois le domaine ajouté au SPTrustedIdentityTokenIssuer, vous devez également l'ajouter au service IP-STS en tant que partie de confiance. L'objet SPTrustedIdentityTokenIssuer est répliqué sur les serveurs de la batterie SharePoint Foundation.

RP-STS (Relying Party Security Token Service) Dans SharePoint Foundation 2010, chaque application Web configurée de façon à utiliser un fournisseur SAML est ajouté au serveur IP-STS comme entrée RP-STS. Une batterie SharePoint Foundation peut comprendre plusieurs entrées RP-STS.

Service IP-STS (Identity Provider Security Token Service) Il s'agit du service d'émission de jetons de sécurité dans l'environnement de revendications qui émet les jetons SAML pour le compte des utilisateurs figurant dans l'annuaire d'utilisateurs associé.

Le diagramme suivant illustre l'architecture de revendications de Produits SharePoint 2010.

Composants d'authentification par revendication de SharePoint

La création de l'objet SPTrustedIdentityTokenIssuer s'effectue avec plusieurs paramètres. Le diagramme suivant illustre les principaux paramètres.

Comme indiqué dans le diagramme, un SPTrustedIdentityTokenIssuer ne peut inclure qu'une seule revendication d'identité, un paramètre SignInURL et un paramètre Wreply. Toutefois, il peut inclure plusieurs domaines et plusieurs mappages de revendications. Le paramètre SignInURL spécifie l'URL vers laquelle rediriger une demande d'utilisateur afin de s'authentifier auprès du service IP-STS. Certains serveurs IP-STS requièrent le paramètre Wreply, qui prend la valeur true ou false et est false par défaut. Utilisez le paramètre Wreply uniquement si le service IP-STS l'exige.

Historique des modifications

Date | Description | Raison
2 septembre 2010 | 2010/08/30 | Mise à jour du contenu
5 août 2010 | 2010/08/02 | Mise à jour du contenu


People Picker and claims provider planning (SharePoint Foundation 2010)
Voir aussi

People Picker is a Web control used to find and select users, groups, and claims to grant permission to items such as lists, libraries, or sites in Microsoft SharePoint Foundation 2010. When a Web application uses claims authentication mode, the People Picker control uses a claims provider to list, resolve, search, and determine the "friendly" display of users, groups, and claims. A claims provider in SharePoint Foundation 2010 issues claims, which SharePoint Foundation 2010 then packages into security tokens for users. Although People Picker is used by site, list, and library owners to assign permissions to sites and content in SharePoint Foundation 2010, its behavior is heavily dependent on how authentication has been configured for the whole Web application. It is important to plan for People Picker and claims providers when you plan authentication methods for your SharePoint Foundation 2010 solution.

The articles in this section are designed to help you understand and plan for using People Picker and custom claims providers in SharePoint Foundation 2010:

  • People Picker overview (SharePoint Foundation 2010) (en anglais)

    This article describes the People Picker control and how it works, its relationship to authentication and claims providers, and includes considerations for planning for People Picker.

  • Custom claims providers for People Picker (SharePoint Foundation 2010) (en anglais)

    This article describes the use and benefits of claims providers, their architecture, special considerations for custom claims providers, and considerations for planning for them.

Voir aussi

Concepts

Planifier l'authentification (SharePoint Foundation 2010)
Configure People Picker (SharePoint Foundation 2010) (en anglais)

Historique des modifications

Date | Description | Raison
2011/01/31 | Publication initiale |


People Picker overview (SharePoint Foundation 2010) (en anglais)
Voir aussi

The People Picker control is used to find and select people, groups, and claims when a site, list, or library owner assigns permissions in Microsoft SharePoint Foundation 2010. This article describes the People Picker control and how it works, its relationship to authentication and claims providers, and how to plan for People Picker. For information about how to configure People Picker, see Configure People Picker (SharePoint Foundation 2010) (en anglais).

Before reading this article, you should understand the concepts described in Planifier des méthodes d'authentification (SharePoint Foundation 2010)and in The Role of Claims (http://go.microsoft.com/fwlink/?LinkID=208326). For additional information about claims-based authentication, see SharePoint Claims-Based Identity (http://go.microsoft.com/fwlink/?LinkID=196647).

In this article:

  • Uses and benefits

  • Architecture

  • About the People Picker control

  • People Picker and authentication

  • People Picker and claims providers

  • Configuring People Picker

  • Using People Picker with multiple forests or domains

  • Considerations for People Picker

Uses and benefits

The People Picker control is used to select users, groups, and claims to grant permission to items such as lists, libraries, and sites. For example, your site has a document library that you want to restrict to a certain list of users. When you use the library permissions page to give users permission levels for the library, you use the People Picker control either to type user names and verify that the user accounts are valid, or to search for a name or partial string and return a list of users, groups, or claims that match the value you entered. For more information about permissions, see Planifier les autorisations des sites (SharePoint Foundation 2010).

Architecture

The People Picker control is a central component of SharePoint Foundation 2010. The control provides basic functionality for finding and selecting users, groups, and claims to assign permissions in a site. The exact sources of those users, groups, and claims depend on the authentication method used by the Web application that contains the site collection. For more information about authentication methods, see People Picker and authentication later in this article.

People Picker is configured at the zone level for a farm by using the Stsadm setproperty operation. By configuring the settings for the control, you can filter and restrict the results that are displayed when a user searches for a user, group, or claim. Those settings will apply to every site within a specific site collection. For more information about configuring People Picker, see Configure People Picker (SharePoint Foundation 2010) (en anglais).

Remarque :
There are no Windows PowerShell commands to configure People Picker.

When a Web application is configured to use claims-based authentication, People Picker uses claims providers to resolve and display users, groups, and claims in the Select People and Groups dialog box. The information that is displayed in the Select People and Groups dialog box depends on the claims provider used by the authentication method that was configured for the Web application. For more information about claims providers, see Custom claims providers for People Picker (SharePoint Foundation 2010) (en anglais).

About the People Picker control

The People Picker control consists of a text box and two buttons: the Check Names button and the Browse button. The following illustration shows an example of the People Picker control.

The user types a user name, group name, or claim (such as an e-mail address) into the text box, and then clicks the Check Names button to resolve the search item exactly as it was entered. If People Picker is able to resolve the search item, the name is replaced with a resolved identity. If the search item cannot be resolved exactly as entered, People Picker performs a search. If no match is found, or if more than one match is found, a red underline is displayed under the search item and the following error message appears: No exact match found. Click the item(s) that did not resolve for more options. When the item is clicked, a pop-up menu displays a list of available users, groups, or claims that match the query, if applicable. The menu also contains a Remove button to remove the resolved user, group, or claim from the text box, and a More Names button, which opens the Select People and Groups dialog box.

If the user clicks the Browse button, the Select People and Groups dialog box is displayed. The user types a full or partial user name, group name, or claim into the text box, and then presses Enter. The results of the query are displayed in the dialog box. The claims providers that People Picker interacts with determine the query results and the way those results are displayed in the dialog box. The user selects a resolved identity, clicks Add, and then clicks OK. The selected user, group, or claim is then added to the text box in the People Picker control.

When a Web application is configured to use Windows authentication, you can limit the results that are displayed to users in the Select People and Groups dialog box by using the Stsadm setproperty operation to change the settings for the People Picker control. For example, you can configure People Picker to return only users, groups, and claims that belong to a certain Active Directory domain or are members of a specific site collection. For more information about configuring the People Picker control, see Configure People Picker (SharePoint Foundation 2010) (en anglais).

People Picker and authentication

People Picker relies on the authentication method used by the Web application that contains the site collection from which it is queried to determine what results to display to a user. If the Web application is configured to use Windows authentication in classic mode, SharePoint Foundation 2010 treats user accounts as Active Directory Domain Services (AD DS) accounts. If the Web application is configured to use claims-based authentication, you can specify whether to use Windows authentication, forms-based authentication (FBA), or Security Assertion Markup Language (SAML) token-based authentication. In claims mode, People Picker searches and resolves queries based on the claims provider that is specified for the authentication method used by the Web application and zone. The following sections describe People Picker behavior for both classic-mode authentication and claims-based authentication. For more information about zones and authentication, see Planifier des méthodes d'authentification (SharePoint Foundation 2010).

Classic-mode authentication

When Windows classic-mode authentication is used, the People Picker control queries Active Directory to retrieve a list of users, groups, or claims that match the search item typed in the text box. You can configure People Picker to query Active Directory by using Lightweight Directory Access Protocol (LDAP) queries, which enables you to apply custom Active Directory filters, limit the scope of search queries, and search across forests and domains.

By default, when the Browse button is clicked, the Select People and Groups dialog box displays the following fields:

  • Display Name

  • Title

  • Department

  • E-mail

  • Mobile Number

  • Account Name

The following image shows the Select People and Groups dialog box when Windows authentication is used in classic mode for the Web application.

For more information about classic-mode authentication, see Planifier des méthodes d'authentification (SharePoint Foundation 2010). For information about how to create a Web application that uses classic-mode authentication, see Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010).

Claims-based authentication

When claims-based authentication is used, People Picker uses the claims provider that is specified for the authentication method used by the Web application and zone to retrieve a list of users, groups, or claims that match the search item typed in the text box. For more information about claims mode authentication and zones, see Planifier des méthodes d'authentification (SharePoint Foundation 2010).

By default, when the Browse button is clicked, the Select People and Groups dialog box displays a tree view on the left that lists the claims providers that People Picker will query. The right side of the dialog box is where query results are displayed. When claims-based authentication is used, the results are displayed in one of two views: Detailed View or List View. By default, Detailed View is displayed.

The following illustration shows the Select People and Groups dialog box when Windows authentication is used in claims mode for a Web application.

In Detailed View, the query results are grouped by the sources where the query results were found. For example, if a search item is found in a SharePoint group and in Active Directory, the results are organized into a list of SharePoint groups followed by a list of Active Directory users and groups.

In List View, the query results are returned in a list that contains the following fields:

  • Display Name

  • E-mail Address

  • Title

  • Department

  • Presence

  • Work Phone

  • Location

You can write a custom claims provider to control what information is displayed and what results are returned in response to a query from the People Picker control. When a custom claims provider is registered on the server, you can also configure it for use in a specific Web application and zone. This means that a custom claims provider that is configured for only one zone will only be displayed in the Select People and Groups dialog box for Web sites in that zone. For more information about custom claims providers, see Custom claims providers for People Picker (SharePoint Foundation 2010) (en anglais).

Remarque :
In the Central Administration Web site, People Picker will return users, groups, and claims from all claims providers used in all Web applications in the farm, regardless of the Web application or zone in which the claims providers are configured.

By default, when you use SAML token-based authentication, all queries entered in the text box are automatically displayed as if they had been resolved, regardless of whether they are valid users or groups. If your SharePoint Foundation 2010 solution will use SAML token-based authentication, you should plan to create a custom claims provider that will implement custom search, name resolution, and list features. For more information about custom claims providers, see Custom claims providers for People Picker (SharePoint Foundation 2010) (en anglais).

For information about how to create a Web application that uses claims-mode authentication, see Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010). For information about configuring claims-based authentication for Web applications, see Configurer l'authentification par revendications (SharePoint Foundation 2010).

People Picker and claims providers

A claims provider lists, resolves, searches, and determines the "friendly" display of users, groups, and claims in the People Picker when claims-based authentication is used. If your Web application uses claims-based authentication, you must decide whether to use one of the default claims providers or create a custom claims provider that will meet the business needs of your organization.

For more information about how claims providers are related to the People Picker control, see Custom claims providers for People Picker (SharePoint Foundation 2010) (en anglais).

Configuring People Picker

The information in this section applies only to Web applications that use Windows authentication in either classic mode or claims mode.

You can configure People Picker to filter query results and to restrict the directories that People Picker uses as a source of those results by using property names for the Stsadm setproperty operation. To see what property settings have been configured, use the Stsadm getproperty operation. For more information, see Peoplepicker: Stsadm properties (Office SharePoint Server 2007). The settings for People Picker are applied to each URL zone for a Web application.

Remarque :
There are no Windows PowerShell commands to configure People Picker.

The following table describes the properties that can be used to configure People Picker.

Property name | Description
Peoplepicker-activedirectorysearchtimeout | Configures the timeout when a query is issued to Active Directory. The default timeout value is 30 seconds. For more information, see Peoplepicker-activedirectorysearchtimeout.
Peoplepicker-distributionlistsearchdomains | Restricts the search of a distribution list to a specific subset of domains. For more information, see Peoplepicker-distributionlistsearchdomains.
Peoplepicker-nowindowsaccountsfornonwindowsauthenticationmode | Specifies not to search Active Directory when the current port is using forms-based authentication. For more information, see Peoplepicker-nowindowsaccountsfornonwindowsauthenticationmode.
Peoplepicker-onlysearchwithinsitecollection | Displays only users who are members of the site collection when the Select People and Groups dialog box is used. For more information, see Peoplepicker-onlysearchwithinsitecollection.
Peoplepicker-peopleeditoronlyresolvewithinsitecollection | Displays only users who are members of the current site collection when the Check Names button is clicked. For more information, see. Peoplepicker-peopleeditoronlyresolvewithinsitecollection: Stsadm property (SharePoint Foundation 2010) (en anglais).
Peoplepicker-searchadcustomfilter | Enables a farm administrator to specify a unique search query. For more information, see Peoplepicker-searchadcustomfilter.
Peoplepicker-searchadcustomquery | Permits the administrator to set the custom query that is sent to Active Directory. For more information, see Peoplepicker-searchadcustomquery.
Peoplepicker-searchadforests | Permits a user to search from a second one-way trusted forest or domain. For more information, see Peoplepicker-searchadforests.
Peoplepicker-serviceaccountdirectorypaths | Enables a farm administrator to manage the site collection that has a specific organizational unit (OU) setting as defined in the Setsiteuseraccountdirectorypath setting. For more information, see Peoplepicker-serviceaccountdirectorypaths.

For more information about configuring People Picker, see Configure People Picker (SharePoint Foundation 2010) (en anglais).

Using People Picker with multiple forests or domains

By default, People Picker will only return users, groups, and claims from the domain on which SharePoint Foundation 2010 is installed. If you want People Picker to return query results from more than one forest or domain, you must either have a two-way trust between the forests or domains, or you must configure People Picker to use an encrypted account and password for a one-way trust between forests and domains. For more information about trusts, see Managing Trusts (http://go.microsoft.com/fwlink/?LinkId=207573).

To configure People Picker for a one-way trust, you must first use the Stsadm setapppassword operation to set the password for use on the trusted forest or domain, and then use the Peoplepicker-searchadforests property for the setproperty operation to specify the forest or domain to search. Remember that the settings for People Picker are configured per zone for a Web application, so if you have more than one forest or domain in your farm, you must combine the accounts and passwords into a single command for the setproperty operation. For more information, see Peoplepicker-searchadforests: Stsadm property (Office SharePoint Server).

Considerations for People Picker

Planning for People Picker largely depends on what forests and domains you want users to be able to query, and what users, groups, and claims you want to display in query results. As you plan for the forests and domains you want users to query, consider the following questions:

  • Do users need to query across a forest or a domain?

  • What is the DNS name for each forest or domain you want users to query?

  • Will your forest or domain have a one-way or two-way trust with other forests or domains?

  • If you will be using a one-way trust, what credentials will be used to query the other farms or domains

Planning for the users, groups, and claims you want to display in the query results in People Picker will help you determine how to configure People Picker to return and display results from claims providers. As you plan for the users, groups, and claims you want to display in query results, consider the following questions:

  • Are there certain LDAP filters you want to apply to query results?

  • Do you want to restrict the query results to users, groups, or claims in a specific site collection?

  • Do you want to restrict the query results to users, groups, or claims in a certain Active Directory organizational unit (OU)

Voir aussi

Concepts

Planifier des méthodes d'authentification (SharePoint Foundation 2010)
Custom claims providers for People Picker (SharePoint Foundation 2010) (en anglais)

Historique des modifications

Date | Description | Raison
2011/01/31 | Publication initiale |


Custom claims providers for People Picker (SharePoint Foundation 2010) (en anglais)
Voir aussi

A claim consists of information about the identity of a user, such as a name, e-mail address, or group membership. A claims provider in Microsoft SharePoint Foundation 2010 issues claims, which SharePoint Foundation 2010 then packages into security tokens for users. When a user signs in to SharePoint Foundation 2010, the user's token is validated and then used to sign in to SharePoint Foundation 2010. Claims providers are displayed in the user interface of the Select People and Groups dialog box in the People Picker control. They provide the functionality used to find and select users, groups, and claims when permissions are assigned to items such as lists, libraries, and sites in SharePoint Foundation 2010. For information about the People Picker control, see People Picker overview (SharePoint Foundation 2010) (en anglais).

This article describes the use and benefits of claims providers, their architecture, special considerations for custom claims providers, and how to plan for them. It does not explain how to create or configure custom claims providers. For information about how to create a custom claims provider, see Claims How Tos (http://go.microsoft.com/fwlink/?LinkId=207578) and Creating Custom Claims Providers in SharePoint 2010 (http://go.microsoft.com/fwlink/?LinkId=211324).

Before reading this article, you should understand the concepts described in Planifier des méthodes d'authentification (SharePoint Foundation 2010) and The Role of Claims (http://go.microsoft.com/fwlink/?LinkID=208326). For additional information about claims-based authentication, see SharePoint Claims-Based Identity (http://go.microsoft.com/fwlink/?LinkID=196647) and A Guide to Claims-based Identity and Access Control (http://go.microsoft.com/fwlink/?LinkID=187911).

In this article:

  • Uses and benefits

  • Architecture

  • About custom claims providers

  • Deploying and configuring custom claims providers

  • Using custom claims on more than one farm

  • Considerations for custom claims providers

Uses and benefits

A claims provider in SharePoint Foundation 2010 is used primarily for two reasons:

  • To augment claims

  • To provide name resolution

In the augmentation role, a claims provider augments a user token with additional claims during sign-in. For more information about claims augmentation, see Claims Provider (http://go.microsoft.com/fwlink/?LinkID=207579).

In the picking role, a claims provider lists, resolves, searches, and determines the "friendly" display of users, groups, and claims in the People Picker. Claims picking enables an application to surface claims in the People Picker, for example when configuring the security of a SharePoint site or SharePoint service. For more information about People Picker, see People Picker overview (SharePoint Foundation 2010) (en anglais).

You can use the claims providers that are included with SharePoint Foundation 2010, or you can create your own custom claims providers to provide additional claims in the security token for a user or to connect to additional sources of claims. For example, if you have a CRM application that contains roles that are not found in the user repository in Active Directory, you can create a custom claims provider to connect to that database and add CRM role data to a user's original claims token. For more information about claims provider usage scenarios, see Claims Provider (http://go.microsoft.com/fwlink/?LinkID=207579).

Architecture

When a Web application is configured to use claims-based authentication, SharePoint Foundation 2010 automatically uses two default claims providers:

  • The SPSystemClaimProvider (http://go.microsoft.com/fwlink/?LinkId=210011) class provides claims information related to the server farm where SharePoint Foundation 2010 is installed.

  • The SPAllUserClaimProvider (http://go.microsoft.com/fwlink/?LinkId=210012) class provides an All Users claim that is displayed in the Select People and Groups dialog box for People Picker.

Depending on the authentication method selected for a zone of a Web application, SharePoint Foundation 2010 also uses one or more of the default claims providers listed in the following table.

Authentication method | Claims provider
Windows authentication | SPActiveDirectoryClaimProvider (http://go.microsoft.com/fwlink/?LinkID=208325)
Forms-based authentication | SPFormsClaimProvider (http://go.microsoft.com/fwlink/?LinkId=210013)
Security Assertion Markup Language (SAML) token-based authentication | SPTrustedClaimProvider (http://go.microsoft.com/fwlink/?LinkId=210014)

These claims providers are displayed in the Select People and Groups dialog box for People Picker. You can see a list of claims providers for a farm by using the Get-SPClaimProviderWindows PowerShell cmdlet.

Remarque :
When a Web application is configured to use SAML token-based authentication, the SPTrustedClaimProvider class does not provide search functionality to the People Picker control. Any text entered in the People Picker control will automatically be displayed as if it had been resolved, regardless of whether it is a valid user, group, or claim. If your SharePoint Foundation 2010 solution will use SAML token-based authentication, you should plan to create a custom claims provider to implement custom search and name resolution.

Claims providers are registered on a server farm as features that are deployed to the farm. They are scoped at the farm level. Each claims provider object uses the SPClaimProviderDefinition class to include information about the claims provider, such as display name, description, assembly, and type. Two important properties of the SPClaimProviderDefinition class are IsEnabled and IsUsedByDefault. These properties determine whether a registered claims provider is enabled for use in the farm, and whether the claims provider is used by default in a particular zone. By default, all claims providers are enabled when they are deployed to a server farm. For information about the SPClaimProviderDefinition class, see SPClaimProviderDefinition Class (http://go.microsoft.com/fwlink/?LinkId=207595).

For more information about zones and authentication, see Planifier des méthodes d'authentification (SharePoint Foundation 2010).

For information about how to write a custom claims provider, see Creating Custom Claims Providers in SharePoint 2010 (http://go.microsoft.com/fwlink/?LinkID=211324) and Claims Walkthrough: Writing Claims Providers for SharePoint 2010 (http://go.microsoft.com/fwlink/?LinkId=207589). For information about how to override the default claims provider, see How to Override the Default Name Resolution and Claims Provider for SharePoint 2010 (http://go.microsoft.com/fwlink/?LinkId=207591).

About custom claims providers

By default, the information that is resolved in People Picker when a query is performed depends on the information supplied by the claims provider. You cannot change what information is supplied and how it is displayed when you use an out-of-box claims provider. To do this, you must have a developer create a custom claims provider that will meet the needs of your solution for finding and selecting users, groups, and claims when a user assigns permissions to items such as a site, list, or library.

For example, if your Web application uses SAML authentication and you also want to resolve users from Active Directory, you will need to create a custom claims provider. For additional examples of claims provider use scenarios, see Claims Provider (http://go.microsoft.com/fwlink/?LinkID=207579).

When you create a custom claims provider, you can control what information is displayed and what results are returned in response to a query from the People Picker control. By default, you configure the Web application to use claims authentication, and then register the claims provider on the server.

Remarque :
You cannot control the order in which claims providers are displayed in the Select People and Groups dialog box in People Picker.

For information about how to write a custom claims provider, see How to: Create a Claims Provider (http://go.microsoft.com/fwlink/?LinkId=207588) and Claims Walkthrough: Writing Claims Providers for SharePoint 2010 (http://go.microsoft.com/fwlink/?LinkId=207589). For information about how to override the default claims provider, see How to Override the Default Name Resolution and Claims Provider for SharePoint 2010 (http://go.microsoft.com/fwlink/?LinkId=207591).

Deploying and configuring custom claims providers

By default, when you register a custom claims provider on the farm, the IsEnabled and IsUsedByDefault properties are both set to True. Unless the IsUsedByDefault property is set to False, the custom claims provider is displayed in the Select People and Groups dialog box in People Picker for all zones. Depending on the number of zones needed for your SharePoint Foundation 2010 solution, the authentication methods used by each zone, and the users for each zone, you may want to limit the zones in which your custom claims provider is displayed in People Picker.

Because claims providers are scoped at the farm level and enabled at the zone level, you must carefully plan the zones in which you want the custom claims provider to be displayed. In general, you should make sure that the IsUsedByDefault property is set to False, and then configure the SPIisSettings class for each zone in which you want to use the custom claims provider. To configure a custom claims provider for select zones, you can create a Windows PowerShell script that sets the claims provider for a zone by using the SPIisSettings.ClaimsProviders property, or you can create a custom application to allow you to enable a custom claims provider for select zones. For information about the SPIisSettings.ClaimsProvider property, see SPIisSettings.ClaimsProvider Property (http://go.microsoft.com/fwlink/?LinkId=207597). For information about how to create a custom application to configure claims providers for select zones, see the TechNet blog post, Configuring a Custom Claims Provider to be Used only on Select Zones in SharePoint 2010 (http://go.microsoft.com/fwlink/?LinkId=207592).

For example, consider a scenario where there are two Web applications: The first Web application, PartnerWeb, has two zones — one intranet that uses Windows claims-based authentication and one extranet that uses forms-based authentication — and is used for collaboration among employees and partners. The second Web application, PublishingWeb, has only one zone that uses forms-based authentication and is an Internet publishing site for employees, business partners, and customer partners. Now, suppose that for the extranet zone on PartnerWeb, you want employees to be able to collaborate with business partners but not customer partners. To do this, you write a custom claims provider that determines whether the current user is a business partner or customer partner, based on the user's identity. In this example, users from fabrikam.com are business partners, while users from contoso.com are customer partners. When a user who is a business partner is authenticated in the PartnerWeb Web application, a claim for a role called BusinessPartner is added to the claim token; when a customer partner is authenticated, a claim for a role called CustomerPartner is added to the claim token. To make sure that customer partners are never added to the extranet collaboration site, you add a Web application policy on the PartnerWeb Web application for the extranet zone that explicitly denies access to any user who has a claim for a role called CustomerPartner. The custom claims provider would also need to implement search and type-in support for the Web application policy to resolve the CustomerPartner role claim so it can be added to the Web application policy. Finally, to enable this functionality on the extranet zone, you configure the SPIisSettings class for that zone to use the custom claims provider. The following diagram illustrates the authentication methods and claims provider settings for each Web application and zone.

Remarque :
On the Central Administration Web site, all claims providers are displayed in the Select People and Groups dialog box in People Picker, regardless of whether the IsUsedByDefault property is set to True.

You can set the IsUsedByDefault property by configuring it in a feature receiver that you create for your custom claims provider. For information about how to use a feature receiver to deploy a custom claims provider, see Sample: Feature Receiver to Deploy a Claims Provider (http://go.microsoft.com/fwlink/?LinkId=207590).

You can also override the settings of the IsEnabled and IsUsedByDefault properties by using the Set-SPClaimProviderWindows PowerShell cmdlet.

Important :
Changing the IsEnabled property to False will disable the claims provider for the entire server farm. This can be useful if you need to troubleshoot issues that might be caused by a custom claims provider. However, in general, the IsEnabled property should be set to True.

Using custom claims on more than one farm

Claim values are a combination of the claim itself, the claims provider name, and the order in which the claims provider was installed on the server. Therefore, if you want to use a claim across multiple farms or environments, you must install the claims providers in the same order on each farm in which you want to use the claim. Use the following steps when you have installed a custom claims provider on a farm and you want to use the same claim on additional farms.

  1. Register the claims providers on the additional farms in the same order that they were registered on the first farm.

  2. Perform a backup of the first farm. For information about how to back up a farm, see Sauvegarder une batterie de serveurs (SharePoint Foundation 2010).

  3. Use the back up from the first farm to restore the other farms. For information about how to restore a farm, see Restaurer une batterie de serveurs (SharePoint Foundation 2010).

Considerations for custom claims providers

As you plan custom claims providers for use with People Picker in your SharePoint solution, consider the following questions:

  • What zones does your Web application have, and what authentication methods are used in each zone?

  • Are there any custom claims that should be added to users to enable more advanced security scenarios?

  • Will you be using SAML authentication with a trusted identity provider?

  • What will be the source of the values for the users and roles that will be displayed in People Picker query results?

  • What claim data do you want to resolve in the Select People and Groups dialog box?

The SharePoint Foundation 2010 Content Publishing team would like to thank Steve Peschka for contributing to this article. His blog can be found here (http://go.microsoft.com/fwlink/?LinkId=210274).

Voir aussi

Concepts

Planifier des méthodes d'authentification (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
2011/01/31 | Publication initiale |


Planifier le renforcement de la sécurité (SharePoint Foundation 2010)

Cet article décrit le renforcement de la sécurité pour les rôles de serveur de bases de données, de serveur d'applications et de serveur Web Microsoft SharePoint Foundation 2010, et fournit des indications détaillées sur la configuration requise pour sécuriser spécifiquement des ports, des protocoles et des services dans les Produits Microsoft SharePoint 2010.

Dans cet article :

  • Instantanés de serveur sécurisé

  • Instructions spécifiques à propos des ports, des protocoles et des services

Instantanés de serveur sécurisé

Dans un environnement de batterie de serveurs, les différents serveurs jouent des rôles spécifiques. Les recommandations pour renforcer la sécurité de ces serveurs dépendent du rôle joué par chacun d'eux. Cet article contient des instantanés sécurisés pour deux catégories de rôles de serveur :

  • Rôles de serveur Web et de serveur d'applications

  • Rôle de serveur de bases de données

Les instantanés sont divisés en catégories de configuration commune. Les caractéristiques établies pour chaque catégorie représentent l'état de sécurisation optimale pour les Produits Microsoft SharePoint 2010. Cet article ne donne pas d'instructions pour la sécurisation des autres logiciels de l'environnement.

Rôles de serveur Web et de serveur d'applications

Cette section identifie les caractéristiques de renforcement pour les serveurs Web et les serveurs d'applications. Certains conseils s'appliquent à des applications de service spécifiques ; dans ces cas, les caractéristiques correspondantes ne doivent être appliquées qu'aux serveurs qui exécutent les services associés aux applications de service spécifiées.

Catégorie

Caractéristique

Services répertoriés dans le composant logiciel enfichable MMC Services

Activez les services suivants :

  • Partage de fichiers et d'imprimantes

  • Service de publication World Wide Web

Assurez-vous que ces services ne sont pas désactivés :

  • Service d'émission de jetons Revendications vers Windows

  • Administration de SharePoint 2010

  • Minuteur de SharePoint 2010

  • Suivi de SharePoint 2010

  • Enregistreur VSS de SharePoint 2010

Assurez-vous que ces services ne sont pas désactivés sur les serveurs qui hébergent les rôles correspondants :

  • Hôte de code utilisateur SharePoint 2010

  • SharePoint Foundation Search V4

Ports et protocoles
  • TCP 80, TCP 443 (SSL)

  • Service Partage de fichiers et d'imprimantes — l'une ou l'autre des configurations suivantes utilisées par les rôles de recherche :

    • Hébergement direct SMB (TCP/UDP 445) — port recommandé

    • NetBIOS sur TCP/IP (NetBT) (ports TCP/UDP 137, 138, 139) — désactivez ce port si vous ne l'utilisez pas

  • Ports requis pour la communication entre les serveurs Web et les applications de service (la valeur par défaut est HTTP) :

    • Liaison HTTP : 32843

    • Liaison HTTPS : 32844

    • liaison NET.TCP : 32845 (uniquement si un tiers a mis en œuvre cette option pour une application de service)

  • Port UDP 1434 et port TCP 1433 — ports par défaut pour la communication SQL Server. Si ces ports sont bloqués sur l'ordinateur SQL Server (recommandé) et que les bases de données sont installées sur une instance nommée, configurez un alias client SQL Server pour la connexion à l'instance nommée.

  • Port TCP/IP 32846 pour le service de code utilisateur Microsoft SharePoint Foundation (pour les solutions en bac à sable) — ce port doit être ouvert pour les connexions sortantes sur tous les serveurs Web. Il doit être ouvert pour les connexions entrantes sur les serveurs Web ou les serveurs d'applications où ce service est activé.

  • Assurez-vous que les ports restent ouverts pour les applications Web qui sont accessibles aux utilisateurs.

  • Bloquez l'accès externe au port qui est utilisé pour le site Administration centrale.

  • TCP/25 (SMTP pour l'intégration de messagerie)

Registre

Aucune instruction supplémentaire

Audit et journalisation

Si les fichiers journaux sont déplacés, assurez-vous que leurs emplacements sont mis à jour pour correspondre. Mettez à jour également les listes de contrôle d'accès aux répertoires (ACL).

Sécurité d'accès au code

Assurez-vous de disposer d'un ensemble minimal d'autorisations de sécurité d'accès au code activées pour votre application Web. L'élément <trust> dans le fichier Web.config pour chaque application Web doit être défini comme WSS_Minimal (où WSS_Minimal possède ses valeurs par défaut faibles telles qu'elles sont définies dans 14\config\wss_minimaltrust.config ou dans votre propre fichier de stratégie personnalisée, qui est défini de façon minimale).

Web.config

Suivez ces recommandations pour chaque fichier Web.config qui est créé après avoir exécuté le programme d'installation :

  • N'autorisez pas la compilation ou les scripts de pages de bases de données via les éléments PageParserPaths.

  • Assurez-vous que <SafeMode> CallStack=""false"" et que AllowPageLevelTrace=""false"".

  • Assurez-vous que l'attribut MaxZoneParts de la valeur WebPartLimits est défini sur une valeur faible.

  • Assurez-vous que la liste SafeControls est définie sur l'ensemble minimal de contrôles nécessaires pour vos sites.

  • Assurez-vous que votre liste Workflow SafeTypes est définie sur le niveau minimal de SafeTypes nécessaires.

  • Assurez-vous que customErrors est activé (<customErrors mode=""On""/>).

  • Prenez en compte vos paramètres de proxy Web selon vos besoins (<system.net>/<defaultProxy>).

  • Définissez la limite de Upload.aspx à la taille que vous estimez la plus élevée possible pour les téléchargements effectués par les utilisateurs (la valeur par défaut est 2 Go). Les performances peuvent être affectées par des téléchargements supérieurs à 100 Mo.

Rôle de serveur de bases de données

La principale recommandation pour les Produits SharePoint 2010 est de sécuriser la communication entre batteries en bloquant les ports par défaut utilisés pour la communication Microsoft SQL Server et en établissant à la place des ports personnalisés pour cette communication. Pour plus d'informations sur la configuration de ports pour la communication SQL Server, voir Blocage des ports SQL Server standard, plus loin dans cet article.

Catégorie

Caractéristique

Ports
  • Bloquez le port UDP 1434.

  • Envisagez le blocage du port TCP 1433.

Cet article ne décrit pas comment sécuriser SQL Server. Pour savoir comment sécuriser SQL Server, voir Sécurisation de SQL Server (http://go.microsoft.com/fwlink/?linkid=186828&clcid=0x40C).

Instructions spécifiques à propos des ports, des protocoles et des services

Le reste de cet article décrit de manière détaillée les exigences spécifiques pour renforcer la sécurité des Produits SharePoint 2010.

Dans cette section :

  • Blocage des ports SQL Server standard

  • Communication d'application de service

  • Conditions requises par le service de partage de fichiers et d'imprimantes

  • Exigences relatives au renforcement de la sécurité du service Profil utilisateur

  • Connexions aux serveurs externes

  • Services requis pour l'intégration de messagerie

  • Conditions de service requises pour l'état de session

  • Services de produits SharePoint 2010

  • Fichier Web.config

Blocage des ports SQL Server standard

Les ports spécifiques utilisés pour se connecter à SQL Server sont affectés par le fait que les bases de données sont installées soit sur une instance par défaut de SQL Server, soit sur une instance nommé de SQL Server. L'instance par défaut de SQL Server écoute les demandes des clients sur le port TCP 1433, tandis qu'une instance nommée de SQL Server écoute sur un numéro de port affecté de manière aléatoire. En outre, le numéro de port d'une instance nommée peut être réaffecté si l'instance est redémarrée (selon que le numéro de port précédemment affecté est toujours disponible ou non).

Par défaut, les ordinateurs clients qui se connectent à SQL Server se connectent d'abord par l'intermédiaire du port TCP 1433. Si cette communication échoue, ils interrogent le service de résolution SQL Server à l'écoute sur le port UDP 1434 pour déterminer le port sur lequel l'instance de base de données est à l'écoute.

Le comportement par défaut de SQL Server en matière de communication présente plusieurs problèmes qui affectent le renforcement de la protection des serveurs. Tout d'abord, les ports utilisés par SQL Server sont des ports largement ouverts au public et le service de résolution SQL Server a déjà été la cible d'attaques par dépassement de la mémoire tampon et d'attaques par déni de service, y compris du ver informatique « Slammer ». Même si SQL Server a été corrigé pour atténuer les problèmes de sécurité dans le service de résolution SQL Server, les ports largement ouverts au public demeurent une cible. Ensuite, si les bases de données sont installées sur une instance nommée de SQL Server, le port de communication correspondant est affecté de manière aléatoire et peut changer. Ce comportement risque d'empêcher la communication de serveur à serveur dans un environnement où la sécurité est renforcée. La possibilité de contrôler l'ouverture et le blocage des ports TCP est essentielle pour sécuriser votre environnement.

Par conséquent, il est recommandé pour une batterie de serveurs d'affecter des numéros de port statiques aux instances nommées de SQL Server et de bloquer le port UDP 1434 pour empêcher les éventuels pirates d'accéder au service de résolution SQL Server. En outre, songez à réaffecter le port utilisé par l'instance par défaut et à bloquer le port TCP 1433.

Il existe plusieurs méthodes pour bloquer les ports. Vous pouvez le faire à l'aide d'un pare-feu. Toutefois, à moins d'être certain qu'il n'existe aucun autre itinéraire vers le segment réseau et qu'aucun utilisateur malveillant n'a accès au segment réseau, il est recommandé de bloquer ces ports directement sur le serveur qui héberge SQL Server. Pour ce faire, vous pouvez utiliser le Pare-feu Windows dans le Panneau de configuration.

Configuration des instances de base de données SQL Server pour écouter sur un port non standard

SQL Server offre la possibilité de réassigner les ports utilisés par l'instance par défaut et les instances nommées. Dans SQL Server 2005 et SQL Server 2008, vous réaffectez les ports à l'aide du Gestionnaire de configuration SQL Server.

Configuration des alias de clients SQL Server

Dans une batterie de serveurs, tous les serveurs Web frontaux et les serveurs d'applications sont des ordinateurs clients SQL Server. Si vous bloquez le port UDP 1434 sur l'ordinateur SQL Server ou si vous changez le port par défaut de l'instance par défaut, vous devez configurer un alias de client SQL Server sur tous les serveurs qui se connectent à l'ordinateur SQL Server.

Pour se connecter à une instance de SQL Server 2005 ou SQL Server 2008, installez les composants clients SQL Server sur l'ordinateur cible, puis configurez l'alias de client SQL Server à l'aide du Gestionnaire de configuration SQL Server. Pour installer les composants clients SQL Server, exécutez le programme d'installation et sélectionnez uniquement les composants clients suivants à installer :

  • Composants de connectivité

  • Outils de gestion (dont le Gestionnaire de configuration SQL Server)

Pour connaître les étapes de renforcement spécifiques pour le blocage des ports SQL standard, voir Sécuriser SQL Server pour les environnements SharePoint (SharePoint Foundation 2010).

Communication des applications de service

Par défaut, la communication entre les serveurs Web et les applications de service au sein d'une batterie de serveurs utilise HTTP avec une liaison au port 32843. Lorsque vous publiez une application de service, vous pouvez sélectionner HTTP ou bien HTTPS, avec les liaisons suivantes :

  • Liaison HTTP : port 32843

  • Liaison HTTPS : port 32844

En outre, les tiers qui développent des applications de service peuvent implémenter un troisième choix :

  • Liaison NET.TCP : port 32845

Vous pouvez changer le protocole et la liaison de port pour chaque application de service. Dans la page Applications de service de l'Administration centrale, sélectionnez l'application de service, puis cliquez sur Publier.

La communication entre les applications de service et SQL Server s'effectue via les ports SQL Server standard ou les ports que vous configurez pour la communication SQL Server.

Conditions requises par le service de partage de fichiers et d'imprimantes

Plusieurs fonctionnalités de base dépendent du service Partage de fichiers et d'imprimantes et des protocoles et ports correspondants. La liste non exhaustive de ces fonctionnalités est la suivante :

  • Requêtes de recherche Toutes les requêtes de recherche nécessitent le service Partage de fichiers et d'imprimantes.

  • Analyse et indexation de contenu Pour analyser le contenu, les serveurs qui incluent des composants d'analyse envoient les requêtes via le serveur Web frontal. Ce dernier communique directement avec les bases de données de contenu et renvoie les résultats aux serveurs qui incluent les composants d'analyse. Cette communication nécessite le service Partage de fichiers et d'imprimantes.

Le service Partage de fichiers et d'imprimantes requiert l'utilisation de canaux nommés. Les canaux nommés peuvent communiquer en utilisant le protocole SMB hébergé directement ou le protocole NetBT. Pour un environnement sécurisé, le protocole SMB hébergé directement est recommandé plutôt que le protocole NetBT. Les recommandations de renforcement de la sécurité fournies dans cet article supposent l'utilisation du protocole SMB.

Le tableau suivant décrit les conditions requises par le renforcement de la sécurité qui sont générées par la dépendance au service Partage de fichiers et d'imprimantes.

Catégorie

Configuration requise

Remarques

Services

Partage de fichiers et d'imprimantes

Requiert l'utilisation de canaux nommés.

Protocoles

Canaux nommés utilisant le protocole SMB à hébergement direct

Désactiver NetBT

Les canaux nommés peuvent utiliser le protocole NetBT au lieu du protocole SMB hébergé directement. Toutefois, le protocole NetBT n'est pas considéré comme autant sécurisé que le protocole SMB hébergé directement.

Ports

L'un des éléments suivants :

  • SMB hébergé directement (TCP/UDP 445) — recommandé

  • NetBT (ports TCP/UDP 137, 138, 139)

Désactiver NetBT (ports 137, 138 et 139) s'il n'est pas utilisé

Pour plus d'informations sur la désactivation du protocole NetBT, voir l'article 204279 de la Base de connaissances Microsoft : Hébergement direct de SMB sur TCP/IP (http://go.microsoft.com/fwlink/?linkid=76143&clcid=0x40C).

Services requis pour l'intégration de messagerie

L'intégration de messagerie nécessite l'utilisation de deux services :

  • Service SMTP

  • Service de gestion d'annuaire Microsoft SharePoint

Service SMTP

L'intégration de la messagerie nécessite l'utilisation du service SMTP (Simple Mail Transfer Protocol) sur au moins l'un des serveurs Web frontaux de la batterie de serveurs. Le service SMTP est requis pour le courrier électronique entrant. Pour le courrier électronique sortant, vous pouvez soit utiliser le service SMTP soit acheminer le courrier via un serveur de messagerie dédié de votre organisation, tel qu'un ordinateur Microsoft Exchange Server.

Service de gestion d'annuaire Microsoft SharePoint

Produits SharePoint 2010 inclut un service interne, le service de gestion d'annuaire Microsoft SharePoint, pour la création des groupes de distribution de courrier. Lorsque vous configurez l'intégration de messagerie, vous avez la possibilité d'activer la fonctionnalité Service de gestion d'annuaire qui permet aux utilisateurs de créer des listes de distribution. Lorsque les utilisateurs créent un groupe SharePoint et sélectionnent l'option permettant de créer une liste de distribution, le service de gestion d'annuaire Microsoft SharePoint crée la liste de distribution Active Directory correspondante dans l'environnement Active Directory.

Dans les environnements où la sécurité est renforcée, il est recommandé de restreindre l'accès au service de gestion d'annuaire Microsoft SharePoint en sécurisant le fichier associé à ce service, SharePointEmailws.asmx. Par exemple, autorisez l'accès à ce fichier uniquement au compte de batterie de serveurs.

En outre, ce service nécessite des autorisations dans l'environnement Active Directory pour créer des objets liste de distribution Active Directory. Il est recommandé de configurer une unité d'organisation séparée dans Active Directory pour les objets des Produits SharePoint 2010. Seule cette unité d'organisation doit autoriser l'accès en écriture au compte utilisé par le service de gestion d'annuaire Microsoft SharePoint.

Services des produits SharePoint 2010

Ne désactivez pas les services qui sont installés par les Produits SharePoint 2010 (répertoriés dans l'instantané précédent).

Si votre environnement n'autorise pas les services qui s'exécutent en tant que système local, vous pouvez désactiver le service Administration de SharePoint 2010 uniquement si vous en connaissez les conséquences et êtes en mesure de les contourner. Il s'agit d'un service Win32 qui s'exécute en tant que système local.

Ce service est utilisé par le service du minuteur SharePoint 2010 pour effectuer des actions qui nécessitent des autorisations d'administration sur le serveur, telles que la création de sites Web IIS (Internet Information Services), le déploiement de code, et l'arrêt et le redémarrage de services. Si vous désactivez ce service, vous ne pourrez pas terminer les tâches liées au déploiement à partir du site Administration centrale. Vous devez utiliser Windows PowerShell pour exécuter l'applet de commande Start-SPAdminJob (ou utiliser l'outil en ligne de commande Stsadm.exe pour exécuter l'opération execadmsvcjobs) pour effectuer des déploiements sur plusieurs serveurs pour les Produits SharePoint 2010 et pour effectuer d'autres tâches liées au déploiement.

Fichier Web.config

.NET Framework, et ASP.NET en particulier, utilisent des fichiers de configuration au format XML pour configurer les applications. .NET Framework se base sur les fichiers de configuration pour définir les options de configuration. Ce sont des fichiers texte XML. En règle générale, plusieurs fichiers de configuration existent sur un seul système.

Les paramètres de configuration à l'échelle du système pour .NET Framework sont définis dans le fichier Machine.config. Ce fichier est situé dans le dossier %SystemRoot%\Microsoft.NET\Framework\%NuméroVersion%\CONFIG\. Les paramètres par défaut contenus dans le fichier Machine.config peuvent être modifiés pour affecter le comportement des applications qui utilisent .NET Framework sur l'ensemble du système.

Vous pouvez modifier les paramètres de configuration ASP.NET pour une application si vous créez un fichier web.config dans le dossier racine de l'application. Lorsque vous procédez ainsi, les paramètres du fichier web.config remplacent les paramètres du fichier Machine.config.

Lorsque vous étendez une application Web en utilisant l'Administration centrale, les Produits SharePoint 2010 créent automatiquement un fichier Web.config pour l'application Web.

L'instantané de serveur Web et de serveur d'applications présenté plus haut dans cet article répertorie les recommandations pour la configuration des fichiers Web.config. Ces recommandations sont destinées à être appliquées à chaque fichier Web.config créé, y compris le fichier Web.config du site Administration centrale.

Pour plus d'informations sur les fichiers de configuration ASP.NET et sur la modification d'un fichier Web.config, voir Configuration d'ASP.NET (http://go.microsoft.com/fwlink/?linkid=73257&clcid=0x40C).

Historique des modifications


Planifier la modification automatique des mots de passe (SharePoint Foundation)
Voir aussi

Pour simplifier la gestion des mots de passe, la fonctionnalité de modification automatique des mots de passe vous permet de mettre à jour et de déployer les mots de passe sans mettre à jour les mots de passe manuellement dans différents comptes, services et applications Web. Vous pouvez configurer la fonctionnalité de modification automatique des mots de passe pour déterminer si un mot de passe est sur le point d'être obsolète et pour le redéfinir à l'aide d'une chaîne aléatoire longue au chiffrement puissant. Pour implémenter la fonctionnalité de modification automatique des mots de passe, vous devez configurer des comptes gérés.

Dans cet article :

  • Configuration de comptes gérés

  • Redéfinition automatique des mots de passe selon une planification

  • Détection de l'expiration des mots de passe

  • Redéfinition immédiate du mot de passe des comptes

  • Synchronisation des mots de passe des comptes SharePoint Foundation avec les services de domaine Active Directory

  • Redéfinition immédiate de tous les mots de passe

  • Processus de modification des informations d'identification

Configuration de comptes gérés

Microsoft SharePoint Foundation 2010 prend en charge la création de comptes gérés pour améliorer la sécurité et garantir l'isolation des applications. À l'aide de comptes gérés, vous pouvez configurer la fonctionnalité de modification automatique des mots de passe pour déployer les mots de passe dans tous les services de la batterie de serveurs. Vous pouvez configurer les services et applications Web SharePoint, en cours d'exécution sur des serveurs d'applications dans une batterie de serveurs SharePoint, de manière à ce qu'ils utilisent différents comptes de domaine. Vous pouvez créer plusieurs comptes dans les services de domaine Active Directory, puis enregistrer ces comptes dans SharePoint Foundation 2010. Vous pouvez mapper les comptes gérés sur différents services et applications Web dans la batterie de serveurs.

Redéfinition automatique des mots de passe selon une planification

Avant l'implémentation de la fonctionnalité de modification automatique des mots de passe, la mise à jour des mots de passe nécessitait de redéfinir chaque mot de passe de compte dans les services de domaine Active Directory, puis de mettre à jour manuellement les mots de passe des comptes sur tous les services s'exécutant sur tous les ordinateurs de la batterie de serveurs. Pour ce faire, il fallait exécuter l'outil en ligne de commande Stsadm ou utiliser l'application Web Administration centrale de SharePoint. Grâce à la fonctionnalité de modification automatique des mots de passe, vous pouvez désormais enregistrer des comptes gérés et permettre à SharePoint Foundation 2010 de contrôler les mots de passe des comptes. Les utilisateurs doivent être informés des modifications de mots de passe planifiées et des interruptions de services qu'elles peuvent engendrer, mais les comptes utilisés par une batterie de serveurs SharePoint, des applications Web et divers services peuvent au besoin être automatiquement redéfinis et déployés dans la batterie de serveurs, sur la base de planifications de redéfinition des mots de passe configurées séparément.

Détection de l'expiration des mots de passe

En règle générale, les services informatiques imposent une stratégie suivant laquelle tous les mots de passe de comptes de domaine doivent être redéfinis régulièrement, par exemple, tous les 60 jours. SharePoint Foundation 2010 peut être configuré de manière à détecter l'expiration imminente des mots de passe et à envoyer une notification par courrier électronique à un administrateur désigné. Même sans l'intervention d'un administrateur, SharePoint Foundation 2010 peut être configuré de manière à générer et à redéfinir les mots de passe automatiquement. Il est également possible de configurer la planification de la redéfinition automatique des mots de passe afin de réduire au minimum l'impact des interruptions de service éventuelles pendant une redéfinition de mots de passe.

Redéfinition immédiate du mot de passe des comptes

Vous pouvez toujours remplacer une planification de redéfinition automatique des mots de passe par une redéfinition des mots de passe de comptes de service immédiate, en utilisant une valeur de mot de passe spécifique. Dans ce scénario, le mot de passe du compte de service peut également être modifié dans les services de domaine Active Directory par SharePoint Foundation 2010. Le nouveau mot de passe est ensuite immédiatement propagé aux autres serveurs de la batterie.

Synchronisation des mots de passe des comptes SharePoint Foundation avec les services de domaine Active Directory

Si les mots de passe des comptes des services de domaine Active Directory et de SharePoint Foundation 2010 ne sont pas synchronisés, les services dans la batterie de serveurs SharePoint ne démarrent pas. Si un administrateur Active Directory modifie le mot de passe d'un compte Active Directory sans coordonner cette modification avec un administrateur SharePoint, il existe un risque d'interruptions de services. Dans ce scénario, un administrateur SharePoint peut redéfinir immédiatement le mot de passe à partir de la page Gestion des comptes en utilisant la valeur du mot de passe préalablement modifié dans les services de domaine Active Directory. Le mot de passe est mis à jour et immédiatement propagé aux autres serveurs de la batterie SharePoint.

Redéfinition immédiate de tous les mots de passe

Si un administrateur quitte soudainement votre organisation ou que les mots de passe des comptes de service doivent être immédiatement redéfinis pour une autre raison, vous pouvez créer rapidement un script Windows PowerShell qui appelle les applets de commande de modification des mots de passe. Vous pouvez utiliser le script pour générer de nouveaux mots de passe aléatoires et déployer ceux-ci immédiatement.

Processus de modification des informations d'identification

Quand SharePoint Foundation 2010 modifie les informations d'identification d'un compte géré, ce processus se produit sur un seul serveur de la batterie de serveurs. Chaque serveur de la batterie de serveurs est informé que les informations d'identification sont sur le point d'être modifiées et peut, au préalable, effectuer des actions critiques. Si le mot de passe de compte n'a pas encore été modifié, SharePoint Foundation 2010 essaie de modifier le mot de passe à l'aide d'un mot de passe entré manuellement ou d'une chaîne aléatoire longue au chiffrement puissant. Les paramètres de complexité sont récupérés à partir de la stratégie appropriée (réseau ou locale) et le mot de passe généré sera conforme aux paramètres détectés. SharePoint Foundation 2010 essaie de valider une modification de mot de passe. Si la validation échoue, il renouvelle l'opération, en utilisant une nouvelle séquence, un nombre de fois spécifié. Si le processus de mise à jour des mots de passe de comptes réussit, il passe au service dépendant suivant, en renouvelant la tentative de validation de modification d'un mot de passe. Si l'opération n'est pas couronnée de succès, chaque service dépendant est informé qu'il peut reprendre son activité normale. Que la validation de la modification d'un mot de passe réussisse ou échoue, une notification d'état de modification de mot de passe automatisée est générée et envoyée par courrier électronique aux administrateurs de batteries de serveurs.

Voir aussi

Concepts

Configurer la modification automatique des mots de passe (SharePoint Foundation 2010)

Historique des modifications


SQL Server et stockage (SharePoint Foundation 2010)

Cette section explique comment planifier la configuration de Microsoft SQL Server et du stockage pour Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Vue d'ensemble de SQL Server dans un environnement SharePoint (SharePoint Foundation 2010)

    Cet article décrit la relation entre SharePoint Foundation 2010 et les versions prises en charge de SQL Server. Il explique également comment interagir avec les bases de données et utiliser les fonctionnalités de création de rapports et d'Aide à la décision de SQL Server avec SharePoint Foundation 2010.

  • Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010)

    Cet article explique comment SharePoint Foundation 2010 fonctionne avec le stockage étendu des objets BLOB.

  • Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010)

    Cet article décrit les facteurs à prendre en compte lorsque vous adoptez une solution de stockage étendu des objets BLOB.

Historique des modifications


Vue d'ensemble de SQL Server dans un environnement SharePoint (SharePoint Foundation 2010)

Cet article décrit la relation entre Microsoft SharePoint Foundation 2010 et les versions prises en charge de Microsoft SQL Server. Il explique également comment interagir avec les bases de données et utiliser les fonctionnalités de création de rapports et d'Aide à la décision de SQL Server avec SharePoint Foundation 2010.

Pour plus d'informations sur les versions de SQL Server prises en charge, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

Dans cet article :

  • Produits SharePoint 2010 et le moteur de base de données SQL Server

  • SQL Server comme plateforme de données pour l'Aide à la décision dans les Produits SharePoint 2010

Produits SharePoint 2010 et le moteur de base de données SQL Server

SharePoint Foundation 2010 est une application qui repose sur le moteur de base de données SQL Server. La plupart du contenu et des paramètres dans SharePoint Foundation 2010 sont stockés dans des bases de données relationnelles. SharePoint Foundation 2010 fait appel aux types de bases de données suivants :

  • Configuration La base de données Configuration et la base de données de contenu Administration centrale portent le nom de bases de données de configuration. Elles contiennent des données sur les paramètres de batterie, tels que les bases de données utilisées, les applications Web ou les sites Web des services Internet (IIS, Internet Information Services), les solutions, les packages de composants WebPart, les modèles de sites, les quotas par défaut et les types de fichiers bloqués. Une batterie ne peut avoir qu'un seul ensemble de bases de données de configuration.

  • Contenu Les bases de données de contenu stockent tout le contenu des sites : les documents de sites (tels que les fichiers dans les bibliothèques de documents), les données de listes, les propriétés de composants WebPart, ainsi que les noms et droits des utilisateurs. Toutes les données relatives à un site spécifique résident dans une même base de données de contenu. Chaque application Web peut contenir de nombreuses bases de données de contenu. Chaque collection de sites peut être associée à une seule base de données de contenu, bien qu'une base de données de contenu puisse être associée à de nombreuses collections de sites.

  • Application de service Les bases de donnée d'applications de service stockent les données utilisables par une application de service. Leur utilisation varie sensiblement selon l'application de service.

Pour obtenir une liste complète de toutes les bases de données qui prennent en charge SharePoint Foundation 2010, voir Database types and descriptions (SharePoint Server 2010) Types et descriptions de base de données (SharePoint Foundation 2010).

Utilisation des bases de données SQL Server qui prennent en charge les Produits SharePoint 2010

Les bases de données SQL Server qui prennent en charge SharePoint Foundation 2010 peuvent être créées à l'aide de SharePoint Foundation 2010 ou par un administrateur de base de données. Pour plus d'informations, voir Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010).

Microsoft ne prend pas en charge l'interrogation ou la modification directe des bases de données qui prennent en charge SharePoint Foundation 2010, à l'exception de la base de données de l'application de service Collection des données d'utilisation et d'intégrité, qui peut être interrogée directement et dont le schéma peut être étendu.

Les bases de données SQL Server qui prennent en charge SharePoint Foundation 2010 sont soumises à des limitations de taille et à des recommandations de configuration qui ne sont pas standard pour SQL Server.

SQL Server comme plateforme de données pour l'Aide à la décision dans les Produits SharePoint 2010

SharePoint Foundation 2010 peut être utilisé avec les outils d'Aide à la décision de SQL Server pour analyser et afficher des données d'Aide à la décision de manière significative. SQL Server fournit l'infrastructure de données et la plateforme d'Aide à la décision principales qui mettent à disposition des auteurs de rapports et des utilisateurs d'entreprise des données approuvées, évolutives et sécurisées.

Les sections suivantes décrivent les technologies et fonctionnalités de SQL Server qui prennent en charge les fonctionnalités d'Aide à la décision dans SharePoint Foundation 2010.

Moteur de base de données SQL Server

Le moteur de base de données SQL Server est le service principal responsable du stockage, du traitement et de la sécurisation des données. Les données d'Aide à la décision peuvent être recueillies à partir du moteur de base de données SQL Server. Pour plus d'informations, voir Moteur de base de données SQL Server (http://go.microsoft.com/fwlink/?linkid=199540&clcid=0x40C).

SQL Server Analysis Services (SSAS) : données multidimensionnelles

Les données multidimensionnelles Microsoft SQL Server Analysis Services (SSAS) vous permettent de concevoir, créer et gérer des structures multidimensionnelles qui contiennent des données détaillées et agrégées issues de sources de données multiples. Un Assistant Cube est disponible dans SQL Server 2008 R2 afin de simplifier la création des cubes. Les données dimensionnelles ou données de cube sont une source de données prototype pour les types d'analyses qui peuvent être effectuées à l'aide des applications de service liées à l'Aide à la décision dans SharePoint Foundation 2010. Pour plus d'informations, voir SQL Server (Analysis Services - Données multidimensionnelles) (http://go.microsoft.com/fwlink/?linkid=199541&clcid=0x40C).

SQL Server Analysis Services : exploration de données

Les outils d'exploration de données de SQL Server Analysis Services fournissent un ensemble d'algorithmes d'exploration de données de norme industrielle et autres outils qui aident à identifier les tendances et modèles dans vos données. Les compléments Excel suivants vous aident à effectuer des analyses prédictives :

  • Les Outils d'analyse de table pour Excel sont des outils simples d'utilisation qui tirent parti de l'Exploration de données Analysis Services pour effectuer de puissantes analyses sur des données de feuilles de calcul. Pour plus d'informations, voir SQL Server Analysis Services - Exploration de données (http://go.microsoft.com/fwlink/?linkid=199543&clcid=0x40C).

  • Le Client d'exploration de données pour Excel permet aux utilisateurs de générer, tester et interroger des modèles d'exploration de données dans Microsoft Office Excel 2007 au moyen de données de feuilles de calcul ou de données externes disponibles par le biais de Analysis Services.

Remarque :
Pour activer des compléments, vous devez disposer d'une connexion au serveur.

SQL Server Reporting Services (SSRS)

Microsoft SQL Server Reporting Services (SSRS) et SharePoint Foundation 2010 s'intègrent facilement. SQL Server Reporting Services propose une gamme complète d'outils avec lesquels vous pouvez créer, déployer et gérer des rapports pour votre organisation, ainsi que des fonctionnalités qui vous permettent d'étendre et de personnaliser vos fonctionnalités de création de rapports.

Voici quelques-unes des fonctionnalités disponibles :

  • Création de rapports avec le Générateurs de rapports version 3, l'un des outils de création de SQL Server Reporting Services, que vous pouvez lancer directement à partir de SharePoint Foundation 2010.

  • Publication de rapports SSRS dans SharePoint Foundation 2010.

    Il est possible de publier des types de contenu de serveur de rapports dans une bibliothèque SharePoint, puis d'afficher et de gérer ces documents à partir d'un site SharePoint.

Pour plus d'informations sur SSRS, voir SQL Server Reporting Services (http://go.microsoft.com/fwlink/?linkid=199545&clcid=0x40C). Pour plus d'informations sur la façon d'installer les différents modes d'intégration, voir Overview of SQL Server Reporting Services reports in SharePoint.

SQL Server Integration Services (SSIS)

Microsoft SQL Server Integration Services (SSIS) procure des solutions d'intégration et de transformation de données enrichies. Il est possible de créer un processus d'extraction, transformation et chargement renouvelable afin d'automatiser le déplacement de données à partie de sources telles que des fichiers de données XML, des fichiers plats ou des sources de données relationnelles vers une ou plusieurs destinations. Si les données proviennent de sources disparates et ne sont pas explorées ou analysées pour les avantages offerts dans les applications d'Aide à la décision, SQL Server Integration Services aide à préparer les données. Pour plus d'informations, voir SQL Server Integration Services (http://go.microsoft.com/fwlink/?linkid=199546&clcid=0x40C).

Business Intelligence Development Studio (BIDS)

Microsoft Business Intelligence Development Studio (BIDS) fournit des Assistants intuitifs pour la création de solutions d'intégration, d'analyse et de génération de rapports dans un environnement unifié. BIDS prend en charge l'intégralité du cycle de vie de développement, à savoir le développement, le test et le déploiement de solutions et de rapports. BIDS repose sur l'environnement de développement Visual Studio 2005 mais le personnalise avec les extensions spécifiques aux services SQL Server et les types de projets pour les rapports, flux de données d'extraction/transformation/chargement, cubes OLAP et structure d'exploration de données.

PowerPivot pour Excel et PowerPivot pour SharePoint

PowerPivot est un complément qui permet aux utilisateurs de créer des solutions d'Aide à la décision en libre-service. Il facilite également le partage et la collaboration sur ces solutions dans un environnement SharePoint Foundation 2010. PowerPivot permet également aux organisations informatiques d'augmenter l'efficacité opérationnelle grâce à des outils de gestion Microsoft SQL Server 2008. Voici quelques-uns des composants de PowerPivot :

  • PowerPivot pour Excel 2010 est un complément d'analyse de données qui permet à Microsoft Excel 2010 de disposer d'une puissance de calcul intégrée. PowerPivot pour Excel (anciennement nommé « Gemini ») permet aux utilisateurs d'analyser de grandes quantités de données et son intégration à SharePoint Foundation 2010 aide les services Informatique à analyser et gérer le mode de collaboration des utilisateurs. Ce complément supprime la limite d'un million de lignes pour les feuilles de calcul et procure des calculs rapides pour les jeux de données volumineux. Pour plus d'informations, voir PowerPivot pour SharePoint (http://go.microsoft.com/fwlink/?linkid=199547&clcid=0x40C).

  • PowerPivot pour SharePoint 2010 étend SharePoint Foundation 2010 et Excel Services de manière à ajouter la prise en charge de la gestion des documents, de la collaboration et du traitement côté serveur pour les classeurs PowerPivot que vous publiez sur des sites SharePoint. Pour plus d'informations, voir PowerPivot pour SharePoint (http://go.microsoft.com/fwlink/?linkid=199547&clcid=0x40C).

Master Data Services

SQL Server Master Data Services vous permet de gérer de manière centralisée vos données importantes à l'échelle de l'entreprise et parmi divers systèmes afin de procurer des données plus approuvées à vos applications d'Aide à la décision. Master Data Services vous aide à créer un concentrateur de données maître qui comprend une application de gestion de données à client léger pour les Responsables de données. L'application peut également appliquer un flux de travail aux propriétaires assignés, appliquer des règles métier extensibles afin de garantir la qualité des données et appliquer des stratégies de gestion d'attributs et de hiérarchies. Pour plus d'informations, voir Master Data Services (http://go.microsoft.com/fwlink/?linkid=199548&clcid=0x40C).

StreamInsight et traitement d'événements complexes

Microsoft StreamInsight est une nouvelle fonctionnalité dans SQL Server 2008 R2 qui fournit une plateforme puissante pour le développement et le déploiement d'applications de traitement d'événements complexes (CEP, Complex Event Processing). CEP est une technologie destinée au traitement des flux, avec un débit élevé et un temps de latence réduit. StreamInsight vous permet d'analyser des données sans avoir à les stocker et vous aide à surveiller les données en provenance de plusieurs sources afin d'y détecter des tendances et des exceptions quasi-instantanément. Vous pouvez plus rapidement prendre la bonne décision, grâce à cette capacité de surveillance et d'analyse de données en mouvement dans le cadre d'événements. Pour plus d'informations, voir Microsoft StreamInsight (http://go.microsoft.com/fwlink/?linkid=199549&clcid=0x40C).

Contenu associé

Centre de ressources

Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais)

Le décisionnel dans SharePoint Server 2010 (http://go.microsoft.com/fwlink/?linkid=199757&clcid=0x40C)

Microsoft Business Intelligence (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=199758&clcid=0x40C)

TechCenter SQL Server (http://go.microsoft.com/fwlink/?linkid=199760&clcid=0x40C)

Données multidimensionnelles SQL Server Analysis Services (SSAS) (http://go.microsoft.com/fwlink/?linkid=199761&clcid=0x40C)

Exploration de données SQL Server Analysis Services (SSAS) (http://go.microsoft.com/fwlink/?linkid=199762&clcid=0x40C)

Contenu pour développeurs

Centre pour développeurs SharePoint (http://go.microsoft.com/fwlink/?linkid=159918&clcid=0x40C)

Centre de développement SQL Server (http://go.microsoft.com/fwlink/?linkid=199764&clcid=0x40C)

Moteur de base de données SQL Server (http://go.microsoft.com/fwlink/?linkid=199765&clcid=0x40C)

SQL Server Reporting Services (SSRS) (http://go.microsoft.com/fwlink/?linkid=199766&clcid=0x40C)

SQL Server StreamInsight (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=199767&clcid=0x40C)

Historique des modifications

Date | Description | Raison
27 août 2010 | Publication initiale |


Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010)

Cet article décrit le stockage BLOB distant (RBS, Remote BLOB Storage) et présente son implémentation avec Microsoft SharePoint Foundation 2010.

Les objets BLOB sont des éléments de données présentant l'une des deux caractéristiques suivantes :

  • données non structurées dépourvues de schéma (à l'image d'une donnée chiffrée ;

  • quantité élevée de données binaires (de nombreux mégaoctets ou gigaoctets) disposant d'un schéma très simple, telles que des fichiers image, un flux vidéo ou des clips audio.

Par défaut, Microsoft SQL Server stocke les données BLOB dans ses bases de données. Au fur et à mesure que l'utilisation d'une base de données croît, la taille totale de ses données BLOB peut augmenter rapidement et dépasser la taille totale des métadonnées de documents et autres données structurées qui sont stockées dans la base de données. Cette activité consomme de grandes quantités d'espace de fichiers et utilise des ressources serveur qui sont en fait optimisées pour des modèles d'accès de base de données.

Le stockage BLOB distant (RBS) est un ensemble d'API de bibliothèque incorporé en tant que module fonctionnel complémentaire pour Microsoft SQL Server 2008 et Microsoft SQL Server 2008 Express. RBS est conçu pour déplacer le stockage des objets BLOB des serveurs de bases de données vers des solutions de stockage de produits. RBS économise une grande quantité d'espace, préserve les ressources serveur coûteuses et fournit un modèle normalisé pour que les applications puissent accéder aux données BLOB.

RBS utilise un fournisseur pour se connecter à un magasin d'objets BLOB dédié qui implémente les API RBS. RBS accompagne le fournisseur RBS FILESTREAM. Le fournisseur FILESTREAM est pris en charge sur les bases de données locales uniquement dans SharePoint Foundation 2010. Des fournisseurs RBS tiers peuvent également être utilisés avec les API RBS pour la création d'une solution de stockage BLOB. Microsoft SharePoint Foundation 2010 prend en charge une implémentation de stockage BLOB qui accède aux API RBS par le biais d'un fournisseur.

Remarque :
Outre le fournisseur FILESTREAM, SQL Server 2008 comporte la fonctionnalité FILESTREAM, qui n'utilise pas d'API RBS. La fonctionnalité FILESTREAM gère les objets BLOB dans une base de données SQL à l'aide du système de fichiers NTFS sous-jacent. SharePoint Foundation 2010 ne prend pas en charge les implémentations de stockage BLOB distant qui utilisent la fonctionnalité FILESTREAM.

Remarque :
Dans une installation autonome de Windows SharePoint Services 3.0, les bases de données de contenu sont stockées dans la base de données interne Windows et ne sont soumises à aucune limitation de taille. À l'inverse, dans SharePoint Foundation 2010, les bases de données de contenu sont stockées dans SQL Server 2008 Express et leur taille est limitée à 4 Go chacune. Si vous effectuez une mise à niveau depuis Windows SharePoint Services 3.0 et que certaines bases de données de contenu présentent une taille supérieure ou égale à 4 Go, vous devez utiliser Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3 ou recourir à RBS.

Microsoft SQL Server Express 2008 R2 prend en charge les bases de données dont la taille est inférieure ou égale à 10 Go. Si votre installation comprend des bases de données dont la taille est comprise entre 4 Go et 10 Go, vous pouvez effectuer une mise à niveau vers Microsoft SQL Server Express 2008 R2 pour votre solution de stockage de base de données de contenu.

Pour plus d'informations et des recommandations sur la mise à niveau avec RBS, voir Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant).

Vous pouvez utiliser RBS avec SharePoint Foundation 2010 et SQL Server 2008 avec SP1 et mise à jour cumulative 2 pour optimiser les ressources de stockage de base de données. Pour plus d'informations sur la façon d'installer RBS sur une nouvelle installation de SharePoint Foundation 2010, voir Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010).

Historique des modifications


Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010)

Par défaut, Microsoft SQL Server stocke des objets BLOB (binary large object) dans ses bases de données. Au fur et à mesure de l'utilisation de la base de données, la taille totale des données BLOB qu'elle contient peut croître rapidement et dépasser la taille totale des métadonnées de document et d'autres données de structure contenues dans la base de données. Les données BLOB nécessitent une grande quantité d'espace fichier et utilisent à la place des ressources serveur optimisées pour les modèles d'accès aux bases de données afin de stocker des fichiers volumineux.

Le stockage étendu des objets BLOB (RBS) est un ensemble d'API de bibliothèque incorporé comme module fonctionnel complémentaire à Microsoft SQL Server. Il est possible de l'exécuter sur le serveur local qui exécute Microsoft SQL Server 2008 R2, SQL Server 2008 ou SQL Server 2008 R2 Express. Pour exécuter RBS sur un serveur distant, vous devez exécuter SQL Server 2008 R2 Enterprise Edition. RBS est conçu pour déplacer le stockage des objets BLOB depuis des serveurs de base de données vers des solutions de stockage de produits. RBS économise une grande quantité d'espace, préserve les ressources serveur coûteuses et fournit un modèle normalisé pour que les applications puissent accéder aux données BLOB. Dans Microsoft SharePoint Foundation 2010, RBS est réservé aux bases de données de contenu.

Pour plus d'informations d'arrière-plan sur RBS, notamment une présentation du fournisseur FILESTREAM, voir Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010).

RBS peut offrir les avantages suivants :

  • Les données BLOB peuvent être stockées sur des périphériques de stockage moins chers configurés pour gérer un stockage simple.

  • L'administration du stockage BLOB est contrôlée par un système conçu spécifiquement pour fonctionner avec les données BLOB.

  • Les ressources serveur de base de données sont libérées pour des opérations de base de données.

Ces avantages ne sont pas gratuits. Avant d'implémenter RBS à l'aide de SharePoint Foundation 2010, vous devez déterminer si ces avantages potentiels justifient les coûts et les limitations associés à l'implémentation et la maintenance de RBS.

Dans cet article :

  • Analyser l'environnement

  • Consulter les options du fournisseur

Analyser l'environnement

Pour démarrer votre analyse de RBS, consultez la taille des bases de données de contenu. Si cette taille répond aux critères d'une recommandation RBS, envisagez le type de contenu en cours d'accès et son utilisation.

Tailles de la base de données de contenu

Vous pouvez tirer profit de RBS dans les cas suivants :

  • Les bases de données de contenu sont supérieures à 500 gigaoctets (Go).

  • Les fichiers de données BLOB sont supérieurs à 256 kilo-octets (Ko).

  • Les fichiers de données BLOB font au moins 80 Ko et le serveur de base de données bloque les performances. Dans ce cas, RBS réduit la charge de traitement et les E/S sur le serveur de base de données.

Même si la présence de nombreux petits objets BLOB peut réduire les performances, le coût de stockage est souvent la considération la plus importante à prendre en compte dans l'évaluation de RBS.

Dans le cas de SharePoint Foundation 2010, envisagez d'implémenter RBS si vous souhaitez conserver une version gratuite de Microsoft SQL Server et si vous estimez que la base de données sera supérieure à 4 Go. Dans le cas contraire, nous vous recommandons de ne pas implémenter RBS.

Remarque :
Si vous procédez à une mise à niveau de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010, vous devez consulter Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant) pour obtenir des informations de mise à niveau supplémentaires.

Par défaut, Microsoft SharePoint Foundation 2010 est installé en même temps que Microsoft SQL Server 2008 Express. SQL Server 2008 Express possède une limite de taille de 4 Go pour une base de données. Vous pouvez immédiatement étendre la taille prise en charge des bases de données de contenu en installant Microsoft SQL Server 2008 R2 Express qui prend en charge des bases de données jusqu'à 10 Go. SQL Server 2008 R2 Express peut être téléchargé gratuitement depuis http://go.microsoft.com/fwlink/?linkid=189418&clcid=0x40C.

Le reste de cette section suppose que vous allez installer SQL Server 2008 R2 Express pour prendre en charge les bases de données SharePoint Foundation 2010. Dans ce cas, si vous anticipez que les bases de données de contenu seront de 10 Go ou plus, envisagez les options suivantes :

  • Si les bases de données de contenu font 16 Go et qu'elles ne contiennent pas plus de 10 Go de métadonnées, vous devez implémenter RBS. Dans ce cas, RBS vous permet de continuer à utiliser une version gratuite de SQL Server. Dans le cadre de cette recommandation, nous supposons que lors de la migration d'une base de données de contenu de 16 Go vers RBS, les métadonnées ne dépassent pas 10 Go.

  • Si les bases de données de contenu dépassent 16 Go, vous devez acheter Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3 pour prendre en charge les bases de données au lieu de continuer avec une version gratuite de SQL Server.

Utilisation et type de contenu

RBS est particulièrement bénéfique pour les systèmes qui stockent des fichiers volumineux, tels que les supports numériques. RBS est généralement implémenté dans des environnements où des fichiers volumineux stockés sont rarement accessibles, par exemple une archive. Si ce scénario correspond à votre environnement, vous devez envisager d'implémenter RBS.

Si vous stockez de nombreux petits fichiers (inférieurs à 256 Ko) auxquels accèdent fréquemment de nombreux utilisateurs, les sites contenant de nombreux petits fichiers peuvent connaître une augmentation de la latence. L'augmentation de la latence est un facteur de coût à prendre en compte lorsque vous évaluez RBS comme solution de stockage. Cependant, il est peu probable que cette considération soit primordiale. La plus grande quantité de latence est aussi liée à votre fournisseur RBS.

Consulter les options du fournisseur

RBS requiert un fournisseur qui connecte les API RBS et SQL Server. Microsoft SQL Server 2008 Express et Microsoft SQL Server 2008 R2 Express incluent le fournisseur FILESTREAM.

Important :
RBS peut s'exécuter sur le serveur local qui exécute Microsoft SQL Server 2008 R2, SQL Server 2008 ou SQL Server 2008 R2 Express. Pour exécuter RBS sur un serveur distant, vous devez exécuter SQL Server 2008 R2 Enterprise Edition. SharePoint Foundation 2010 requiert la version de RBS incluse dans Package d'installation SQL Server Remote BLOB Store du Feature Pack pour Microsoft SQL Server 2008 R2. Les versions antérieures de RBS ne fonctionnent pas avec SharePoint Foundation 2010. De plus, RBS n'est pas pris en charge dans SQL Server 2005.

Les objets BLOB peuvent être conservés sur le stockage de produits, tel que le stockage à connexion directe (DAS) ou le stockage connecté au réseau (NAS), selon la prise en charge qu'offre le fournisseur. Le fournisseur FILESTREAM est pris en charge par SharePoint Foundation 2010 lorsqu'il est utilisé sur des lecteurs de disque dur locaux uniquement. Vous ne pouvez pas utiliser RBS avec FILESTREAM sur des supports de stockage distants, tels que NAS.

Le tableau suivant résume les avantages et les limitations associés à FILESTREAM.

Critères fonctionnels | RBS avec FILESTREAM | RBS sans FILESTREAM
Sauvegarde et récupération intégrées SQL Server du magasin d'objets BLOB | Oui | Oui
Migration sur script vers des objets BLOB | Oui | Oui
Prend en charge la mise en miroir | Non | Non
Copie des journaux de transaction | Oui | Oui avec une implémentation du fournisseur
Instantanés de base de données | Non1 | Non1
Réplication géo | Oui | Non
Chiffrement | NTFS seulement | Non
Stockage connecté au réseau (NAS) | Non pris en charge par Produits SharePoint 2010 | Oui avec une implémentation du fournisseur

1Si le fournisseur RBS que vous utilisez ne prend pas en charge les instantanés, vous ne pouvez pas utiliser d'instantanés pour le déploiement ou les sauvegardes de contenu. Par exemple, le fournisseur FILESTREAM SQL ne prend pas en charge les instantanés.

Si FILESTREAM n'est pas un fournisseur pratique pour votre environnement, vous pouvez acheter un fournisseur tiers qui est pris en charge. Dans ce cas, vous devez déterminer les critères suivants pour choisir un fournisseur :

  • Fonction de sauvegarde et de restauration

  • Récupération d'urgence testée

  • Déploiement et migration des données

  • Impact sur les performances

  • Coûts administratifs à long terme

Important :
Il n'est pas recommandé de développer votre propre fournisseur sauf si vous êtes un éditeur de logiciels indépendant ayant une expérience solide dans la conception de solutions de stockage.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | 2010/07/05 | Mise à jour du contenu


Planifier la gestion de la continuité des opérations (SharePoint Foundation 2010)

La gestion de la continuité des opérations recouvre les prises de décision, les processus et les outils métiers que vous mettez en place à l'avance afin de gérer des situations de crise. Une crise peut affecter seulement votre activité ou faire partie d'un événement local, régional ou national.

Les fonctionnalités de Microsoft SharePoint Foundation 2010 font probablement partie de votre stratégie de gestion de la continuité des opérations ; votre plan global doit cependant être beaucoup plus étendu et doit inclure les éléments suivants :

  • procédures clairement documentées ;

  • stockage hors site des données professionnelles vitales ;

  • contacts clairement désignés ;

  • formation continue du personnel, y compris des ateliers pratiques et des exercices ;

  • mécanismes de récupération hors site.

Dans cet article :

  • Capacités de gestion de la continuité des opérations

  • Contrats de niveau de service

Capacités de gestion de la continuité des opérations

Microsoft SharePoint Foundation 2010 inclut les capacités suivantes qui prennent en charge la gestion de la continuité des opérations.

  • Gestion des versions Les utilisateurs peuvent perdre des données en remplaçant un document. Grâce à la gestion des versions, les utilisateurs peuvent conserver plusieurs versions d'un même document dans une bibliothèque de documents. Dans l'éventualité d'une modification non sollicitée, d'un document remplacé ou d'une altération de document, une version précédente peut facilement être restaurée par un utilisateur final. Lorsque la fonctionnalité de gestion des versions est activée, les utilisateurs peuvent récupérer leurs données eux-mêmes.

    Pour plus d'informations, voir Planifier la protection du contenu à l'aide de corbeilles et du contrôle de version (SharePoint Foundation 2010).

  • Corbeille SharePoint Foundation 2010 inclut deux Corbeilles. Les utilisateurs disposant des autorisations appropriées peuvent utiliser la Corbeille principale pour récupérer les documents, éléments de liste, listes et bibliothèques de documents supprimés d'un site. Les administrateurs de collections de sites peuvent utiliser la Corbeille secondaire, également appelée Corbeille de la collection de sites, pour récupérer des éléments qui ont été supprimés dans la Corbeille principale. Lorsque la Corbeille principale est activée, les utilisateurs peuvent récupérer leurs données eux-mêmes

    Pour plus d'informations, voir Planifier la protection du contenu à l'aide de corbeilles et du contrôle de version (SharePoint Foundation 2010).

  • Sauvegarde et récupération Vous pouvez utiliser les applets de commande Windows PowerShell ou le site Web Administration centrale de SharePoint pour sauvegarder et restaurer des batteries de serveurs, des bases de données, des applications Web et des collections de sites. Il existe également de nombreux outils externes tiers que vous pouvez utiliser pour sauvegarder et récupérer des données. Pour plus d'informations, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

  • Disponibilité Aucun composant fonctionnel unique ne fournit la disponibilité dans un environnement SharePoint Foundation 2010. Vous pouvez choisir parmi plusieurs approches pour améliorer la disponibilité, notamment les suivantes :

    • tolérance aux pannes des composants et du réseau ;

    • redondance des rôles de serveurs et des serveurs au sein d'une batterie de serveurs.

    Pour plus d'informations sur la disponibilité, voir Planifier la disponibilité (SharePoint Foundation 2010).

  • Récupération d'urgence Aucun composant fonctionnel unique ne fournit la récupération d'urgence dans un environnement SharePoint Foundation 2010. Vous pouvez choisir parmi plusieurs approches pour améliorer la disponibilité lorsqu'un centre de données est déconnecté, notamment les suivantes :

    • stockage hors site des sauvegardes, localement et hors de votre région ;

    • envoi d'images de serveurs à des emplacements hors site ;

    • fonctionnement avec plusieurs centres de données, mais le traitement de données via un seul de ces centres, en conservant les autres disponibles comme centres de secours.

    Pour plus d'informations sur la récupération d'urgence, voir Planifier la récupération d'urgence (SharePoint Foundation 2010).

Contrats de niveau de service

La gestion de la continuité des opérations est un domaine essentiel dans lequel les groupes informatiques proposent des contrats de niveau de service pour définir les attentes avec les groupes de clients. De nombreuses organisations informatiques offrent différents contrats de niveau de service associés à différents niveaux de facturation.

La liste suivante décrit les fonctionnalités communes des contrats de niveau de service de gestion de la continuité des opérations :

  • Gestion des versions

    • Si elle est proposée.

    • Quantité d'espace alloué.

  • Corbeilles

    • Si elle est proposée.

    • Quantité d'espace alloué pour la Corbeille principale et la Corbeille secondaire.

    • Durée de conservation des éléments avant leur suppression définitive dans chaque Corbeille.

    • Frais supplémentaires pour la récupération des éléments qui ont été définitivement supprimés de la Corbeille secondaire.

  • Sauvegarde et récupération

    Les contrats de niveau de service en matière de sauvegarde et de récupération identifient généralement les objets et les services qui peuvent être sauvegardés et récupérés et, pour chacun d'eux, l'objectif de temps de récupération, l'objectif de point de récupération et l'objectif de niveau de récupération. Le contrat de niveau de service peut également identifier la période de sauvegarde disponible pour chaque objet. Pour plus d'informations sur les contrats de niveau de service en matière de sauvegarde et de récupération, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

    • L'objectif en termes de temps de récupération (RTO, Recovery Time Objective) est l'objectif relatif à la durée maximale que prendra un processus de récupération de données. Il est déterminé par le délai d'indisponibilité que l'entreprise peut accepter pour le site ou le service.

    • L'objectif de point de récupération (RPO, Recovery Point Objective) est l'objectif en termes de durée maximale entre la dernière sauvegarde disponible et un point de défaillance potentielle quelconque. Il est déterminé par le volume de données que l'entreprise peut se permettre de perdre en cas de panne.

    • L'objectif de niveau de récupération (RLO) est l'objectif qui définit la granularité avec laquelle vous devez pouvoir récupérer des données, c'est-à-dire si vous devez pouvoir récupérer toute la batterie de serveurs, l'application Web, la collection de sites, le site, la liste ou la bibliothèque, ou encore l'élément.

  • Disponibilité

    Pour chaque composant d'une batterie de serveurs couvert par un plan de disponibilité, un contrat de niveau de service de disponibilité peut identifier la disponibilité en tant que pourcentage de temps de fonctionnement, souvent exprimé sous forme de plusieurs neufs, c'est-à-dire le pourcentage de temps pendant lequel un système donné est actif et en fonctionnement. Par exemple, un système avec un pourcentage de temps de fonctionnement de 99,999 correspond à une disponibilité de cinq neufs.

    Remarque :
    Lors du calcul de disponibilité, la plupart des entreprises ajoutent ou retirent des heures pour les activités de maintenance prévues.

    Pour plus d'informations, voir Planifier la disponibilité (SharePoint Foundation 2010).

  • Récupération d'urgence

    Pour chaque composant d'une batterie de serveurs couvert par un plan de récupération d'urgence, un contrat de niveau de service peut identifier l'objectif de point de récupération et l'objectif de temps de récupération. Il est souvent défini différents objectifs de temps de récupération pour différentes circonstances, par exemple pour une urgence locale et pour une urgence régionale.

    Pour plus d'informations, voir Planifier la récupération d'urgence (SharePoint Foundation 2010).

Contenu connexe

Centre de ressources | Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201997&clcid=0x40C)
Contenu IT Pro | Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) Vue d'ensemble de la sauvegarde et de la récupération (SharePoint Foundation 2010) Sauvegarde et récupération (SharePoint Foundation 2010) Planifier la protection du contenu à l'aide de corbeilles et du contrôle de version (SharePoint Foundation 2010) Planifier la disponibilité (SharePoint Foundation 2010) Configuration de la disponibilité (SharePoint Foundation 2010) Planifier la récupération d'urgence (SharePoint Foundation 2010)
Contenu de développement | Protection et récupération des données (http://go.microsoft.com/fwlink/?linkid=199237&clcid=0x40C)

Historique des modifications


Planifier la protection du contenu à l'aide de corbeilles et du contrôle de version (SharePoint Foundation 2010)

Prévoyez d'utiliser des corbeilles et la gestion des versions dans un environnement pour aider les utilisateurs à protéger et à récupérer leurs données. Les corbeilles et la gestion des versions sont des composants importants dans une stratégie de continuité des opérations.

Corbeilles Les utilisateurs peuvent utiliser les Corbeilles pour récupérer des objets supprimés. Microsoft SharePoint Foundation 2010 prend en charge deux niveaux de Corbeilles : la Corbeille principale et la Corbeille de la collection de sites, également appelée Corbeille secondaire. Lorsque les Corbeilles sont utilisées, les utilisateurs peuvent restaurer les éléments qui s'y trouvent, tels que des fichiers, des documents, des éléments de liste, des listes et des bibliothèques de documents qui ont été supprimés.

Gestion des versions Les utilisateurs peuvent utiliser la gestion des versions pour prévenir la perte de données due à l'écrasement d'un document. Lorsque le propriétaire d'un site active la gestion des versions dans une bibliothèque de documents ou une liste, celles-ci conservent plusieurs copies d'un document, d'un élément ou d'un fichier. Dans l'éventualité d'une modification non sollicitée, d'un fichier écrasé ou d'une altération de document, la version précédente peut facilement être restaurée par un utilisateur.

Dans cet article :

  • Protection du contenu à l'aide de Corbeilles

  • Protection du contenu à l'aide de la gestion des versions

Protection du contenu à l'aide de Corbeilles

SharePoint Foundation 2010 prend en charge deux niveaux de Corbeilles : la Corbeille principale et la Corbeille de la collection de sites, également appelée Corbeille secondaire. Les Corbeilles sont activées et configurées au niveau de l'application Web. Elles collectent les documents et les éléments de liste supprimés. Lorsqu'un élément de liste est supprimé, tous les éléments qui lui sont associés sont également supprimés et peuvent être restaurés à partir de la Corbeille.

Les Corbeilles peuvent contenir plusieurs copies d'un document ayant chacune le même nom de fichier et la même source. Ces documents ne peuvent pas être restaurés sur une copie existante d'un document. Les Corbeilles ne peuvent pas être utilisées pour récupérer des versions antérieures ou des remplacements accidentels de documents : vous devez utiliser la gestion des versions pour activer cette fonctionnalité.

Le tableau suivant explique comment un élément est supprimé et récupéré à partir de la Corbeille principale et de la Corbeille secondaire.

Quand un utilisateur effectue cette action | L'élément est | L'élément peut être restauré par
Supprime un élément | Conservé dans la Corbeille principale jusqu'à ce qu'il en soit supprimé ou qu'il y soit plus longtemps que l'intervalle de temps autorisé qui a été configuré pour sa conservation. | Des utilisateurs ou les administrateurs de la collection de sites
Supprime un élément de la Corbeille | Conservé dans la Corbeille secondaire | Administrateurs de collections de sites

La désactivation de la Corbeille pour une application Web vide toutes les Corbeilles et supprime définitivement tous les éléments qui s'y trouvent.

Corbeille principale

La Corbeille principale se trouve au niveau du site et est disponible pour les utilisateurs qui ont des autorisations Collaboration, Création ou Contrôle total sur un site. Lorsqu'un utilisateur supprime un élément d'un site Web, l'élément est envoyé vers la Corbeille principale du site. Les éléments qui se trouvent dans la Corbeille principale comptent pour le quota du site. Les éléments restent dans une des Corbeilles principales du site jusqu'à ce qu'une période de temps spécifiée ait été atteinte (la valeur par défaut est 30 jours).

Lorsqu'un élément est supprimé de la Corbeille, il est envoyé dans la Corbeille secondaire.

Remarque :
La limite de temps pour les Corbeilles s'applique au temps total qui s'écoule après que l'élément a été initialement supprimé et non pas au temps passé dans chacun des niveaux de Corbeille.

Corbeille secondaire (de la collection de sites)

La Corbeille secondaire se trouve au niveau des administrateurs de collections de sites. Elle comporte deux vues : les objets des Corbeilles principales de tous les sites de la collection de sites et les objets de la Corbeille secondaire. Lorsqu'un élément est supprimé de la Corbeille principale, il ne peut être récupéré que par un administrateur de collections de sites à partir de la Corbeille secondaire.

Les éléments restent dans la Corbeille secondaire jusqu'à ce qu'une période de temps spécifiée ait été atteinte (la valeur par défaut est 30 jours) ou jusqu'à ce que la Corbeille secondaire atteigne sa taille limite, à laquelle les éléments les plus anciens sont supprimés. La limite de temps pour les Corbeilles s'applique au temps total qui s'écoule après que l'élément a été initialement supprimé et non pas au temps passé dans chacun des niveaux de Corbeille.

Lorsqu'une Corbeille secondaire est activée pour une application Web, il est recommandé d'indiquer la quantité d'espace disque disponible pour cette Corbeille sous la forme d'un pourcentage du quota alloué à l'application Web. Les éléments stockés dans la Corbeille secondaire ne comptent pas dans le quota du site ; cependant, la taille qui est spécifiée pour la Corbeille secondaire augmente la taille totale du site et la base de données de contenu qui l'héberge. Si aucun quota de site n'a été défini, il n'existe pas de limite pour la taille de la Corbeille secondaire.

Par exemple, si vous avez alloué 100 Mo d'espace à l'application Web, l'allocation de 50 pour cent du quota pour la Corbeille secondaire alloue 50 Mo à la Corbeille secondaire et 150 Mo à l'application Web dans sa totalité. Vous pouvez allouer jusqu'à 100 pour cent pour le quota de la Corbeille secondaire.

Pour plus d'informations sur la définition de quotas, voir

  • Planifier la maintenance et la gestion des sites (SharePoint Foundation 2010)

  • Créer des modèles de quota (SharePoint Foundation 2010)

Pour plus d'informations sur la façon dont les utilisateurs peuvent utiliser la Corbeille dans SharePoint Foundation 2010, voir Afficher, restaurer ou supprimer des éléments dans la Corbeille (http://go.microsoft.com/fwlink/?linkid=90917&clcid=0x40C)

Pour plus d'informations sur la configuration des Corbeilles, voir la rubrique Configurer la Corbeille (SharePoint Foundation 2010).

Protection du contenu à l'aide de la gestion des versions

La gestion des versions est destinée à résoudre le problème de la perte de données par remplacement d'un document. Il permet à la bibliothèque de documents de conserver plusieurs copies du même document. Dans le cas d'une modification non souhaitée, du remplacement ou de l'endommagement d'un document, la version antérieure peut facilement être restaurée par l'utilisateur. La gestion des versions peut être activée au niveau des bibliothèques ou des listes. La gestion des versions peut s'appliquer aux éléments et aux fichiers.

Avant de configurer la gestion des versions, veillez à lire la rubrique Planifier la maintenance et la gestion des sites (SharePoint Foundation 2010).

Pour plus d'informations sur la configuration de la gestion des versions, consultez la rubrique Activer et configurer la gestion des versions (SharePoint Foundation 2010).

Les administrateurs doivent gérer attentivement les versions, car si des sites disposent de nombreuses versions des fichiers et des documents, ils peuvent devenir très volumineux. Si vous ne limitez pas la taille des sites, ils peuvent dépasser votre capacité de stockage. Les administrateurs de batteries de serveurs peuvent gérer ce problème en établissant des contrats de niveau service avec les propriétaires de sites et en définissant la taille des quotas sur les sites. Pour plus d'informations sur la gestion des versions, voir la rubrique Gérer le contrôle de version à l'aide des quotas (SharePoint Foundation 2010).

Historique des modifications


Planifier la sauvegarde et la récupération (SharePoint Foundation 2010)

Cet article décrit les différentes étapes de la planification de la sauvegarde et de la récupération, qui inclut la détermination des stratégies de sauvegarde et de récupération pour un environnement Microsoft SharePoint Foundation et le choix des outils à utiliser. Il n'est pas nécessaire d'exécuter les étapes dans l'ordre indiqué, et le processus peut être itératif.

Lorsque vous planifiez l'utilisation de la sauvegarde et de la récupération pour la récupération d'urgence, prenez en compte les événements, les échecs et les erreurs courants ; les urgences locales ; et les urgences régionales.

Pour plus d'informations sur la sauvegarde et la récupération de Microsoft SharePoint Foundation, voir Vue d'ensemble de la sauvegarde et de la récupération (SharePoint Foundation 2010).

Dans cet article :

  • Définir les impératifs de l'entreprise

  • Choisir quoi protéger et quoi récupérer au sein de votre environnement

  • Choisir les outils

  • Déterminer les stratégies

  • Planifier l'amélioration de la sauvegarde et de la récupération

Définir les impératifs de l'entreprise

Pour définir les impératifs de l'entreprise, déterminez ce qui suit pour chaque batterie et service de l'environnement :

  • L'objectif en termes de point de récupération (RPO, Recovery Point Objective) correspond à l'objectif en termes de durée maximale entre la dernière sauvegarde disponible et un point d'échec potentiel quelconque. Il est déterminé par le volume de données que l'entreprise peut se permettre de perdre en cas d'échec.

  • L'objectif en termes de temps de récupération (RTO, Recovery Time Objective) est l'objectif relatif à la durée maximale que prendra un processus de récupération de données. Il est déterminé par le délai d'indisponibilité que l'entreprise peut accepter pour le site ou le service.

  • L'objectif de niveau de récupération (RLO) est l'objectif qui définit la granularité avec laquelle vous devez pouvoir récupérer des données, c'est-à-dire si vous devez pouvoir récupérer toute la batterie de serveurs, l'application Web, la collection de sites, le site, la liste ou la bibliothèque, ou encore l'élément.

Des objectifs RPO et RTO plus courts, et une plus grande granularité de l'objectif RLO, ont tendance à être plus coûteux.

Une feuille de travail facilitant la planification des stratégies de sauvegarde et de récupération de l'environnement SharePoint Foundation 2010 est disponible dans le Classeur de planification de la sauvegarde et de la récupération des produits SharePoint 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=184385&clcid=0x40C).

Choisir quoi protéger et quoi récupérer au sein de votre environnement

Vos impératifs d'entreprise vous aideront à déterminer les composants de votre environnement que vous devez protéger, et la granularité nécessaire pour pouvoir les récupérer.

Le tableau suivant répertorie les composants d'un environnement SharePoint que vous pourriez choisir de protéger, et les outils que vous pouvez utiliser pour sauvegarder et récupérer chaque composant.

Composant | Sauvegarde SharePoint | SQL Server 2008 avec SP1 et mise à jour cumulative 2 | System Center Data Protection Manager (DPM) 2010 | Sauvegarde du système de fichiers
Batterie de serveurs | Oui |  | Oui6 |
Applications de service | Oui |  |  |
Application Web | Oui |  |  |
Bases de données de contenu | Oui | Oui | Oui |
Collection de sites | Oui1, 2 | Oui1, 2 | Oui1, 2 |
Site | Oui2 | Oui2 | Oui |
Bibliothèque ou liste de documents | Oui2 | Oui2 | Oui |
Élément de liste ou document |  |  | Oui |
Contenu stocké dans des magasins d'objets blob distants | Oui3 | Oui3 | Oui3 |
Personnalisations déployées en tant que packages de solutions | Oui7 | Oui7 | Oui6, 7 |
Modifications apportées à Web.config par le biais de l'Administration centrale ou d'une API | Oui | Oui | Oui4 |
Paramètres de configuration (SharePoint) | Oui2, 8 | Oui2, 8 | Oui 2, 9 |
Personnalisations non déployées en tant que packages de solutions |  |  | Oui. Les fichiers peuvent être récupérés s'ils sont protégés en tant que fichiers.4, 5 | Oui
Modifications dans Web.config non effectuées par le biais de l'Administration centrale ou d'une API |  |  | Oui4 | Oui
Configurations IIS non définies via SharePoint |  |  | Oui5 | Oui
Bases de données SQL Server Reporting Services |  | Oui | Oui |

1La sauvegarde et la restauration au niveau de la batterie de serveurs et de la base de données peuvent être utilisées pour la récupération de la collection de sites si une seule collection de sites est stockée dans une base de données.

2Les sauvegardes au niveau de la batterie de serveurs et de la base de données peuvent être utilisées avec la récupération de base de données non attachée à SharePoint Foundation pour restaurer des collections de sites, des sites, des listes et des configurations.

3Le contenu stocké dans des magasins d'objets blob distants est sauvegardé et restauré avec d'autres types de contenu, du moment que le fournisseur de stockage étendu des objets blob (RBS, Remote BLOB Storage) utilisé le permet.

4Les modifications apportées à Web.config peuvent être sauvegardées en utilisant la sauvegarde du système de fichiers à partir de DPM 2010.

5Les configurations IIS peuvent être récupérées par le biais d'une sauvegarde complète à partir de DPM 2010.

6 DPM 2010 peut récupérer cet élément en associant une sauvegarde complète et une sauvegarde de SharePoint Foundation. Il ne peut pas être sauvegardé et récupéré comme un objet.

7Les packages de solutions entièrement fiables sont stockés dans la base de données de configuration et les solutions en mode bac à sable dans les bases de données de contenu. Ils peuvent être récupérés dans le cadre de la récupération de la batterie de serveurs ou de la base de données de contenu.

8Les paramètres de configuration peuvent être récupérés à partir des sauvegardes réalisées au niveau de la batterie de serveurs. Pour plus d'informations, voir Restaurer une batterie de serveurs (SharePoint Foundation 2010).

9La base de données de contenu de l'Administration centrale et la base de données de configuration database d'une batterie de serveurs SharePoint Foundation 2010 peut être récupérée uniquement dans le cadre d'une récupération complète de la batterie de serveurs sur la même batterie, avec les mêmes ordinateurs.

Remarque :
Vous pouvez enregistrer SharePoint Foundation 2010 avec l'utilitaire de sauvegarde de Windows Server, en utilisant l'opération stsadm.exe -o -registerwsswriter pour configurer l'enregistreur VSS (Volume Shadow Copy Service) de SharePoint Foundation. L'utilitaire de sauvegarde de Windows Server inclut alors SharePoint Foundation 2010 dans les sauvegardes à l'échelle du serveur. Lorsque vous effectuez une restauration à partir d'une sauvegarde Windows Server, vous pouvez sélectionner Microsoft SharePoint Foundation (quelle que soit la version de Produits SharePoint 2010 installée) pour que tous les composants signalés par l'enregistreur VSS pour SharePoint Foundation 2010 sur ce serveur au moment de la sauvegarde soient restaurés.

L'utilitaire de sauvegarde de Windows Server doit être utilisé uniquement avec les déploiements comprenant un seul serveur.

Choisir quoi récupérer à partir des bases de données de contenu SharePoint

Dans une base de données de contenu, vous pouvez récupérer des collections de sites, des sites, des listes et des bibliothèques.

Les outils de sauvegarde et de récupération offrent des niveaux différents de récupération du contenu dans une base de données de contenu. La récupération d'un objet dans une base de données de contenu est toujours plus complexe que la récupération d'une base de données de contenu complète.

Protection des personnalisations

Les personnalisations sur les sites SharePoint peuvent inclure :

  • Les pages maîtres, les mises en page et les feuilles de style en cascade. Ces objets sont stockés dans la base de données de contenu pour une application Web.

  • Les composants WebPart, les définitions de site ou liste, les colonnes personnalisées, de nouveaux types de contenu, les champs personnalisés, les actions personnalisées, les flux de travail codés, ou les activités et conditions de flux de travail.

  • Les solutions tierces et les fichiers binaires associés et les clés de Registre, par exemple IFilters.

  • Les modifications des fichiers XML standard.

  • Les définitions de site personnalisé (Webtemp.xml).

  • Modifications apportées au fichier Web.config.

La façon dont les personnalisations sont déployées et les modifications sont effectuées dans le fichier Web.config a une incidence significative sur les outils qui peuvent être utilisés pour sauvegarder et récupérer les personnalisations. Pour laisser le maximum de chances à la récupération, nous vous recommandons de déployer les personnalisations en utilisant des packages de solutions et en effectuant des modifications dans le fichier Web.config à l'aide de l'administration centrale ou d'un modèle objet et d'API SharePoint.

Protection des flux de travail

Les flux de travail constituent un cas particulier de personnalisation que vous pouvez sauvegarder et restaurer. Assurez-vous que votre plan de sauvegarde et de récupération gère les scénarios suivants qui s'appliquent à votre environnement :

  • Les flux de travail déclaratifs, tels que ceux créés dans Microsoft SharePoint Designer 2010, sont stockés dans la base de données de contenu de la collection de sites sur laquelle ils sont déployés. La sauvegarde de la base de données de contenu protège ces flux de travail.

  • Les actions de flux de travail déclaratifs personnalisés ont des composants aux trois emplacements suivants :

    1. Les assemblys Visual Studio pour les activités sont stockés dans le Global Assembly Cache.

    2. Les fichiers de définition XML (fichiers .ACTIONS) sont stockés dans le répertoire 14\TEMPLATE\{LCID}\Workflow.

    3. Une entrée XML marquant l'activité comme type autorisé est stockée dans le fichier web.config des applications Web dans lesquelles elle est utilisée.

    Si vos flux de travail de batterie utilisent des actions personnalisées, vous devez recourir à un système de sauvegarde de fichiers pour protéger ces fichiers et les entrées XML. S'apparentant à des fonctionnalités SharePoint Foundation telles que les composants WebPart et les récepteurs d'événements, ces fichiers doivent être réappliqués à la batterie selon les besoins après la récupération.

  • Les flux de travail qui dépendent de code personnalisé, tels que ceux créés à l'aide de Visual Studio, sont stockés à deux emplacements. Les assemblys Visual Studio pour le flux de travail sont stockés dans le Global Assembly Cache et les fichiers de définition XML sont stockés dans le répertoire Features. Ceci est identique à d'autres types de fonctionnalités SharePoint Foundation telles que les composants WebPart et les récepteurs d'événements. Si le flux de travail a été installé dans le cadre d'un package de solution, la sauvegarde de la base de données de contenu protège ces flux de travail.

  • Si vous créez un flux de travail personnalisé qui interagit avec une collection de sites autre que celle dans laquelle le flux de travail est déployé, vous devez sauvegarder les deux collections de sites afin de protéger le flux de travail. Cela comprend les flux de travail qui écrivent dans un historique ou autre liste personnalisée dans une autre collection de sites. Une sauvegarde de batterie suffit à sauvegarder toutes les collections de site de la batterie et tous les flux de travail qui y sont associés.

  • Les flux de travail qui ne sont pas encore déployés doivent être sauvegardés et restaurés séparément, comme tout autre fichier de données. Lorsque vous développez un nouveau flux de travail et que vous ne l'avez pas encore déployé dans la batterie SharePoint Foundation, assurez-vous de sauvegarder le dossier dans lequel vous stockez vos fichiers de projet de flux de travail à l'aide de Sauvegarde Windows ou d'une autre application de sauvegarde de système de fichiers.

Protection des applications de services

Les applications de services dans un environnement SharePoint Foundation peuvent être composées de paramètres de services et, éventuellement, d'une ou plusieurs bases de données. Vous ne pouvez pas restaurer une application de service complète en restaurant la base de données uniquement ; toutefois, vous pouvez restaurer les bases de données pour une application de service, puis redéployer celle-ci. Pour plus d'informations, voir Restaurer une application de service (SharePoint Foundation 2010).

Protection des bases de données SQL Server Reporting Services

La sauvegarde et la récupération de SharePoint Foundation n'incluent pas les bases de données SQL Server Reporting Services. Vous devez utiliser les outils SQL Server. Pour plus d'informations, voir Opérations de sauvegarde et de restauration pour une installation Reporting Services (http://go.microsoft.com/fwlink/?linkid=186642&clcid=0x40C).

Choisir les outils

Pour choisir les outils appropriés pour la sauvegarde et la récupération, vous devez déterminer si vous pouvez respecter les impératifs de continuité que vous avez définis pour votre entreprise dans le cadre de votre budget et de vos ressources.

Les facteurs clés à prendre en considération lors du choix des outils incluent ce qui suit :

  • Rapidité de la sauvegarde : l'outil peut-il s'exécuter pendant la période de maintenance de vos bases de données ? Il est conseillé de tester préalablement tout système de sauvegarde pour vérifier qu'il répond à vos besoins sur votre matériel.

  • Intégralité de la récupération.

  • Granularité des objets récupérables.

  • Type de la sauvegarde prise en charge (complète, différentielle ou incrémentielle).

  • Complexité de la gestion de l'outil.

Le tableau suivant compare le type de sauvegarde et la taille de la batterie pouvant être récupérée en l'espace de six heures, compte tenu des outils de sauvegarde et de récupération disponibles auprès de Microsoft.

Outil | Type de sauvegarde | Taille de la sauvegarde effectuée en six heures1
Sauvegarde et récupération de la batterie de serveurs SharePoint | Complète, différentielle | 600 Go
SQL Server | Complète, différentielle | 600 Go
System Center Data Protection Manager | Incrémentielle | Téraoctets

1La taille de la sauvegarde a été déterminée par la sauvegarde d'un système qui totalise la taille spécifiée sur le matériel de test répertorié dans la section suivante.

Remarque :
Les sauvegardes de SharePoint Foundation et SQL Server ont été réalisées avec la compression de sauvegarde activée.

Matériel de test

Le tableau suivant répertorie les composants matériels utilisés dans les tests qui déterminent la taille de la sauvegarde pouvant être réalisée en l'espace de six heures.

Composant | Description
Processeur | Double processeur 64 bits, 3 GHz
RAM | 8 Go
Disque | Partition NTFS 2 téraoctets
Réseau | Connexion 100 mégabits par seconde (Mbit/s) ou plus rapide entre les ordinateurs clients et le serveur
Partage réseau | Partage réseau avec 1,25 téraoctet d'espace libre

Remarque :
La limite maximale des sauvegardes de collection de sites SharePoint Foundation 2010 est de 85 Go.

Pour obtenir des informations détaillées sur les systèmes de sauvegarde et de récupération pouvant être utilisés avec Microsoft SharePoint Foundation, voir les ressources suivantes :

  • Vue d'ensemble de la sauvegarde et de la récupération (SharePoint Foundation 2010)

  • Sauvegarde et restauration de bases de données dans SQL Server (http://go.microsoft.com/fwlink/?linkid=186643&clcid=0x40C)

  • Vue d'ensemble de Data Protection Manager 2010 Release Candidate (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=186655&clcid=0x40C).

Déterminer les stratégies

Sur la base de vos impératifs d'entreprise, les besoins de récupération et les outils choisis, déterminez et documentez les stratégies de sauvegarde et de récupération de votre environnement.

Il n'est pas inhabituel pour les départements informatiques qui prennent en charge les environnements SharePoint Foundation de décider d'utiliser plusieurs outils pour protéger l'environnement, quand ils déterminent les stratégies à utiliser.

Par exemple, dans un environnement comprenant des bases de données gérées par des administrateurs de bases de données, il est possible d'appliquer les stratégies de la liste suivante :

  • Toutes les bases de données sont sauvegardées par SQL Server. L'intervalle de sauvegarde est défini pour chaque base de données selon les facteurs suivants :

    • L'impact au niveau de l'entreprise du contenu ou du service.

    • La fréquence de changement standard de la base de données.

    • L'impact de la sauvegarde sur les performances de l'environnement.

  • Les petites bases de données de contenu extrêmement importantes pour l'entreprise et qui évoluent rapidement sont également protégées par les captures instantanées de base de données SQL Server stockées sur un disque physique séparé. Une seule capture par base de données est stockée et les captures sont effacées régulièrement, de façon à limiter l'incidence sur les performances. L'intervalle des captures d'instantané définies pour chaque base de données dépend des facteurs suivants :

    • L'impact au niveau de l'entreprise du contenu ou du service.

    • La fréquence de changement standard de la base de données.

    • L'impact de la capture instantanée sur les performances de l'environnement.

    • La quantité d'espace requis pour stocker la capture instantanée.

    La récupération d'une capture instantanée est plus rapide qu'une récupération standard, car une capture instantanée et la base de données sous-jacente peuvent être traitées par SharePoint Foundation sous forme de base de données non attachée. Cependant, le processus de création de captures instantanées peut réduire les performances de la base de données sous-jacente. Nous vous recommandons de tester l'incidence des captures instantanées sur les performances du système avant leur mise en œuvre et d'effacer régulièrement les captures instantanées pour réduire l'espace nécessaire.

    Remarque :
    Si vous utilisez RBS et que le fournisseur RBS que vous utilisez ne prend pas en charge les captures instantanées, vous ne pouvez pas utiliser de captures instantanées pour la sauvegarde. Par exemple, le fournisseur SQL FILESTREAM ne prend pas en charge les captures instantanées.

  • La sauvegarde SharePoint Foundation permet de protéger les applications de service. L'intervalle de sauvegarde dépend des facteurs suivants :

    • L'impact du service au niveau de l'entreprise.

    • La fréquence de changement standard de la base de données.

    • L'impact de la sauvegarde sur les performances de la base de données.

  • Toutes les opérations de restauration sont effectuées via SharePoint Foundation. Le choix du système de restauration à utiliser est déterminé par le type de sauvegarde disponible et de l'objet restauré.

D'autres outils devraient faire partie de votre stratégie de continuité des activités de l'entreprise. Examinez la façon dont vous utiliserez les Corbeilles et la gestion des versions dans les collections de sites dans tout l'environnement. Pour plus d'informations, voir Planifier la gestion de la continuité des opérations (SharePoint Foundation 2010).

Planifier l'amélioration de la sauvegarde et de la récupération

Lorsque vous planifiez votre stratégie de sauvegarde et de récupération, tenez compte des recommandations suivantes pour réduire l'effet de la sauvegarde et de la récupération sur les performances du système.

De par leur nature, la plupart des opérations de sauvegarde consomment autant de ressources d'E/S que possible pour terminer la tâche dans le temps disponible à des fins de maintenance. Par conséquent, il se peut que vous constatiez une mise en file d'attente sur le disque et un retour de toutes les demandes d'E/S plus lent que d'habitude. Ceci est normal et ne doit pas être considéré comme un problème.

Suivre les recommandations de configuration de SQL Server et du stockage

Suivez les recommandations générales relatives à la configuration de SQL Server et au stockage pour un environnement SharePoint Foundation. Pour plus d'informations, voir SQL Server et stockage (SharePoint Foundation 2010).

Réduire la latence entre SQL Server et l'emplacement de sauvegarde

En général, il est préférable d'utiliser un disque local, et non un lecteur réseau, pour les sauvegardes. Si vous sauvegardez plusieurs serveurs, vous pouvez recourir à un ordinateur directement connecté accessible en écriture aux deux serveurs. Les lecteurs réseau présentant une latence inférieure ou égale à 1 milliseconde entre eux-mêmes et les ordinateurs qui exécutent SQL Server se prêtent à ce dispositif. Si votre batterie comprend plusieurs serveurs (notamment l'ordinateur exécutant SQL Server), vous devez utiliser les chemins d'accès réseau UNC pour l'emplacement de sauvegarde de la batterie SharePoint.

Éviter les conflits de traitement

N'exécutez pas d'opérations de sauvegarde pendant les périodes au cours desquelles les utilisateurs ont besoin d'accéder au système.

Pour éviter les goulots d'étranglement d'E/S, effectuez dans un premier temps la sauvegarde principale sur un disque distinct, puis réalisez une copie sur bande.

Envisagez des sauvegardes échelonnées afin que toutes les bases de données ne soient pas sauvegardées en même temps.

Les sauvegardes SharePoint Foundation utilisent des sauvegardes SQL Server. Lorsque vous utilisez la compression avec vos sauvegardes, veillez à ne pas surcharger SQL Server. Par exemple, certains outils de sauvegarde tiers compressent les données pendant la sauvegarde, ce qui peut gêner les performances de SQL Server. Il existe des outils permettant de limiter les processus de compression et de contrôler l'impact sur SQL Server.

Suivre les recommandations permettant d'optimiser les sauvegardes et les restaurations SQL Server

Si vous exécutez SQL Server 2008 Enterprise, nous vous recommandons d'utiliser la compression des sauvegardes. Pour plus d'informations, voir Compression de sauvegardes (SQL Server) (http://go.microsoft.com/fwlink/?linkid=179525&clcid=0x40C).

Si vous utilisez des sauvegardes SQL Server, afin de réduire au minimum le temps de récupération, combinez des sauvegardes complètes, différentielles et du journal des transactions pour le mode de récupération complète ou de journalisation en bloc. Les sauvegardes différentielles de la base de données sont généralement plus rapides à créer que les sauvegardes complètes de la base de données et réduisent la quantité du journal des transactions requise pour la récupération de la base de données.

Si vous utilisez le mode de récupération complète dans SQL Server 2008, il est recommandé d'utiliser l'option de troncation lors de la sauvegarde pour éviter les problèmes de maintenance.

Pour obtenir des recommandations détaillées sur la façon d'optimiser les performances de sauvegarde et de restauration dans SQL Server, voir Optimisation des performances de sauvegarde et de restauration dans SQL Server (http://go.microsoft.com/fwlink/?linkid=126630&clcid=0x40C).

Garantir des performances d'écriture suffisantes sur le lecteur de sauvegarde

Réfléchissez bien avant de décider s'il faut utiliser un dispositif RAID (Redundant Array of Independent Disks) sur votre unité de sauvegarde sur disque. Par exemple, un dispositif RAID 5 présente des performances d'écriture faibles, avec une vitesse approximativement identique à celle obtenue dans le cas d'un seul disque. (En effet, le niveau RAID 5 gère les informations de parité.) L'utilisation d'un dispositif RAID 10 pour une unité de sauvegarde peut procurer des sauvegardes plus rapides. Pour plus d'informations sur la façon d'utiliser la technologie RAID dans le cadre des sauvegardes, voir Configurer RAID afin d'optimiser les opérations d'écriture et de lecture SQL Server (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=126632&clcid=0x40C).

Contenu connexe

Centre de ressources | Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais)(http://go.microsoft.com/fwlink/?linkid=199235&clcid=0x40C)
Contenu IT Pro | Vue d'ensemble de la sauvegarde et de la récupération (SharePoint Foundation 2010) Sauvegarde et récupération (SharePoint Foundation 2010) Planifier la disponibilité (SharePoint Foundation 2010) Configuration de la disponibilité (SharePoint Foundation 2010) Planifier la récupération d'urgence (SharePoint Foundation 2010)
Contenu de développement | Protection et récupération des données (http://go.microsoft.com/fwlink/?linkid=199237&clcid=0x40C)

Historique des modifications

Date | Description | Raison
8 juillet 2010 | 2010/07/05 | Mise à jour du contenu


Vue d'ensemble de la sauvegarde et de la récupération (SharePoint Foundation 2010)

Cet article décrit l'architecture de sauvegarde et les processus de récupération disponibles dans Microsoft SharePoint Foundation 2010, y compris la sauvegarde et la récupération granulaire et de batterie de serveurs, ainsi que la récupération à partir d'une base de données de contenu non attachée. Les opérations de sauvegarde et de récupération peuvent être réalisées par le biais de l'interface utilisateur ou d'applets de commande Windows PowerShell. Il est possible que les outils de sauvegarde et de récupération intégrés ne satisfassent pas à tous les besoins de votre organisation.

Dans cet article :

  • Scénarios de sauvegarde et de récupération

  • Architecture de sauvegarde

  • Processus de récupération

Scénarios de sauvegarde et de récupération

La sauvegarde et la récupération de données prennent en charge de nombreux scénarios d'entreprise, notamment :

  • Récupération de contenu supprimé par inadvertance et non protégé par la corbeille ou le contrôle de version.

  • Déplacement de données entre des installations dans le cadre d'une mise à niveau matérielle ou logicielle.

  • Récupération d'une panne imprévue.

Architecture de sauvegarde

SharePoint Foundation 2010 fournit deux systèmes de sauvegarde : sauvegarde de batterie de serveurs et sauvegarde précise.

Architecture de la sauvegarde de batterie de serveurs

L'architecture de la sauvegarde de batterie de serveurs dans SharePoint Foundation 2010 lance une sauvegarde des bases de données de contenu et d'applications de service Microsoft SQL Server et enregistre le contenu de la configuration dans des fichiers.

L'illustration suivante représente le système de sauvegarde de batterie de serveurs.

Architecture de la sauvegarde (SharePoint Foundation)

La sauvegarde complète et la sauvegarde différentielle sont toutes deux prises en charge. Les sauvegardes complètes créent une nouvelle sauvegarde de la totalité du système. Les sauvegardes différentielles créent une sauvegarde de toutes les données stockées dans les bases de données et ayant changé depuis la dernière sauvegarde complète.

Le système de sauvegarde de batterie de serveurs est organisé de manière hiérarchique. Les composants d'une batterie de serveurs qui peuvent être sélectionnés pour la sauvegarde sont les suivants :

  • Batterie de serveurs La batterie est l'objet de niveau supérieur. Vous disposez des options suivantes lorsque vous sauvegardez une batterie de serveurs :

    • Données de contenu et de configuration (par défaut)

      La batterie de serveurs entière est sauvegardée, y compris les paramètres stockés dans la base de données de configuration.

    • Configuration seulement

      Les paramètres de la base de données de configuration sont sauvegardés, pour vous permettre d'appliquer des configurations à différentes batteries de serveurs. Pour plus d'informations, voir Utilisation et avantages d'une sauvegarde limitée à la configuration plus loin dans cet article.

  • Application Web Vous pouvez sélectionner une ou plusieurs bases de données de contenu à sauvegarder dans une application Web.

    Une sauvegarde d'application Web inclut les éléments suivants :

    • Nom et compte du pool d'applications

    • Paramètres d'authentification

    • Paramètres d'applications Web généraux, tels que les alertes et chemins d'accès gérés

    • Informations de liaison IIS (Internet Information Services), notamment le type de protocole, l'en-tête de l'hôte et le numéro de port

    • Modifications apportées au fichier Web.config par le biais du modèle objet ou de l'Administration centrale

      Remarque :
      Les modifications apportées à un fichier Web.config en vue de prendre en charge l'application basée sur les revendications ne sont pas incluses dans les sauvegardes, car ces modifications sont effectuées manuellement. Pour plus d'informations, voir Observations sur l'utilisation des sauvegardes de batteries de serveurs plus loin dans cet article.

    • Solutions mode bac à sable (sandbox)

    Pour plus de conseils sur la protection de ces paramètres, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

  • Important :
    Les sauvegardes d'applications de service n'incluent pas le proxy associé. Pour sauvegarder l'application de service et le proxy d'application de service, vous devez sauvegarder la batterie de serveurs ou effectuer deux sauvegardes consécutives, en sélectionnant l'application de service dans une sauvegarde, puis le proxy d'application de service associé dans la seconde.

    Bon nombre de bases de données d'application de service ne peuvent pas être sauvegardées individuellement à partir de SharePoint Foundation 2010. Pour sauvegarder uniquement les bases de données d'application de service, vous devez utiliser la fonction de sauvegarde de SQL Server.

  • Proxys des applications de service qui ne sont pas partagées.

  • Services partagés Leur exécution nécessite à la fois une application de service et un proxy d'application de service. Si vous sélectionnez le nœud Services partagés, toutes les applications de service et les proxys d'applications de service associés sur la batterie sont sauvegardés.

    Remarque :
    La hiérarchie de sauvegarde vous permet de sélectionner certaines applications de service et proxys d'applications de service à sauvegarder. Toutefois, lorsque vous sélectionnez une ou toutes les applications de service, ou un ou tous les proxys, les objets associés ne sont pas sauvegardés par défaut. Pour sauvegarder les deux parties d'un service spécifique, vous devez sélectionner le nœud Services partagés ou effectuer deux sauvegardes consécutives, en prenant soin de sélectionner l'application de service dans la première sauvegarde et le proxy d'application de service associé dans la seconde sauvegarde.

Remarque :
Certains paramètres de l'environnement SharePoint Foundation ne sont pas inclus dans une sauvegarde de batterie de serveurs. Il s'agit des paramètres suivants stockés sur les serveurs Web :

  • les mots de passe des comptes de pool d'applications ;

  • les paramètres de compression HTTP ;

  • les paramètres de délai d'expiration ;

  • des filtres personnalisés ISAPI (Internet Server Application Programming Interface) ;

  • l'appartenance à un domaine d'ordinateur ;

  • les paramètres de sécurité du protocole Internet (IPsec) ;

  • les paramètres d'équilibrage de charge réseau ;

  • les certificats SSL (Secure Sockets Layer) ;

  • les paramètres d'adresses IP dédiées.

Utilisation et avantages d'une sauvegarde limitée à la configuration

Une sauvegarde limitée à la configuration extrait et sauvegarde les paramètres de configuration stockés dans une base de données de configuration. À l'aide des outils intégrés, vous pouvez sauvegarder la configuration de n'importe quelle base de données de configuration, que celle-ci soit ou non actuellement attachée à une batterie de serveurs. Pour plus d'informations sur la sauvegarde d'une configuration, voir Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010).

Une sauvegarde de la configuration peut être restaurée sur la même batterie de serveurs ou sur n'importe quelle autre batterie de serveurs. Lorsqu'une configuration est restaurée, elle remplace tous les paramètres présents dans la batterie de serveurs par les valeurs correspondantes définies dans la sauvegarde de la configuration. Si des paramètres présents dans la batterie de serveurs sont absents de la sauvegarde de la configuration, ils ne sont pas modifiés. Pour plus d'informations sur la restauration d'une configuration de batterie de serveurs, voir Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010).

Remarque :
Les paramètres des applications de service et des applications Web ne sont pas inclus dans les sauvegardes de configuration. Vous pouvez utiliser les applets de commande de Windows PowerShell pour documenter et copier les paramètres des applications de service. Pour plus d'informations, voir Documenter les paramètres de configuration de batteries (SharePoint Foundation 2010) et Copier des paramètres de configuration d'une batterie à l'autre (SharePoint Foundation 2010).

Les situations dans lesquelles il peut être nécessaire de restaurer la configuration d'une batterie de serveurs vers une autre batterie de serveurs sont les suivantes :

  • Réplication d'une configuration de batterie de serveurs normalisée à utiliser dans l'ensemble de l'environnement.

  • Déplacement de configurations depuis un environnement de développement ou de test vers un environnement de production.

  • Déplacement de configurations depuis une installation autonome vers un environnement de batterie de serveurs.

  • Configuration d'une batterie de serveurs dans le cadre d'un environnement de secours.

SharePoint Foundation stocke les genres de paramètres suivants dans une sauvegarde limitée à la configuration.

  • Antivirus

  • Gestion des droits relatifs à l'information (IRM)

  • Paramètres de courrier électronique sortant (restaurés uniquement lors d'une opération de remplacement).

  • Personnalisations déployées en tant que solutions fiables

  • Journalisation des diagnostics

Observations sur l'utilisation des sauvegardes de batteries de serveurs

Gardez à l'esprit les points suivants avant d'utiliser des sauvegardes de batteries de serveurs :

  • Il n'existe pas de système de planification intégré pour les sauvegardes. Pour planifier une sauvegarde, il est recommandé de créer un script de sauvegarde à l'aide de Windows PowerShell, puis d'utiliser le Planificateur de tâches de Windows pour exécuter le script de sauvegarde régulièrement.

  • Il n'est pas recommandé d'utiliser la sauvegarde de métabase IIS pour protéger les paramètres IIS. Au lieu de cela, documentez toutes les configurations IIS pour chaque serveur Web à l'aide d'un outil offrant l'analyse de configuration souhaitée, tel que Microsoft System Center Configuration Manager 2010.

  • Les opérations de sauvegarde et de récupération de SharePoint Foundation 2010 peuvent être exécutées aux côtés de fonctionnalités de SQL Server Enterprise, notamment la compression des sauvegardes et le chiffrement transparent des données.

    Si vous exécutez SQL Server Enterprise, nous vous recommandons vivement d'utiliser la compression des sauvegardes. Pour plus d'informations sur la compression des sauvegardes, voir Compression de sauvegardes (SQL Server) (http://go.microsoft.com/fwlink/?linkid=129381&clcid=0x40C).

    Si vous décidez d'exécuter des bases de données avec le chiffrement transparent des données, vous devez sauvegarder et restaurer manuellement la clé ; les fonctions de sauvegarde et de récupération de SharePoint Foundation 2010 ne vous rappelleront pas de sauvegarder la clé. Pour plus d'informations sur le chiffrement transparent des données, voir Présentation du chiffrement transparent des données (TDE) (http://go.microsoft.com/fwlink/?linkid=129384&clcid=0x40C).

  • Si une base de données de contenu est configurée pour utiliser le fournisseur de stockage BLOB distant SQL FILESTREAM, ce fournisseur doit être installé sur le serveur de bases de données sauvegardé, mais aussi sur le serveur de bases de données sur lequel il est récupéré.

  • La fonction de sauvegarde de SharePoint Foundation 2010 ne protège pas les éléments suivants :

    • Modifications du fichier Web.config sur les serveurs Web qui ne sont pas apportées par le biais de l'Administration centrale ou du modèle objet.

    • Personnalisations d'un site qui ne sont pas déployées dans le cadre d'une solution en mode bac à sable ou d'une solution fiable.

  • Si vous partagez des applications de service parmi des batteries, sachez que les certificats d'approbation ayant été échangés ne sont pas compris dans les sauvegardes de batteries. Vous devez sauvegarder le magasin de certificats séparément ou conserver les certificats à un emplacement distinct. Lorsque vous restaurez une batterie qui partage une application de service, vous devez importer et redéployer les certificats, puis rétablir toute approbation inter-batterie.

    Pour plus d'informations, voir Échanger des certificats d'approbation entre batteries de serveurs (SharePoint Foundation 2010).

  • Lorsque vous restaurez une batterie ou une application Web configurée de façon à utiliser un genre quelconque d'authentification basée sur les revendications, des fournisseurs dupliqués ou supplémentaires peuvent sembler être activés. Si des doublons apparaissent, vous devez enregistrer manuellement chaque zone d'application Web afin de les supprimer.

  • Des étapes supplémentaires sont requises lorsque vous restaurez une batterie qui contient une application Web configurée de façon à utiliser l'authentification basée sur les formulaires. Vous devez réinscrire les fournisseurs d'appartenances et de rôles dans le fichier web.config, puis redéployer les fournisseurs. Ces étapes sont nécessaires que vous effectuiez une restauration au niveau de l'application Web ou au niveau de la batterie.

    Pour plus d'informations, voir Sauvegarder une application Web (SharePoint Foundation 2010), Planifier des méthodes d'authentification (SharePoint Foundation 2010) et Configurer l'authentification par revendications (SharePoint Foundation 2010).

Architecture de sauvegarde précise et d'exportation

L'architecture de sauvegarde précise et d'exportation utilise des requêtes Transact-SQL et des appels d'exportation. La sauvegarde précise et l'exportation constituent une opération qui implique des phases de lecture et de traitement plus intenses que la sauvegarde de batterie de serveurs.

À partir du système de sauvegarde précise, un utilisateur peut sauvegarder une collection de sites ou exporter un site ou une liste.

Remarque :
Les flux de travail ne sont pas inclus dans les exportations de sites ou de listes.

Si vous exécutez SQL Server Enterprise, le système de sauvegarde granulaire peut éventuellement utiliser des captures instantanées de base de données SQL Server pour que les données demeurent cohérentes pendant que la sauvegarde ou l'exportation est en cours. Lorsqu'une capture instantanée est demandée, une capture instantanée de base de données SQL Server de la base de données de contenu appropriée est effectuée et SharePoint Foundation l'utilise pour créer le package de sauvegarde ou d'exportation, puis la capture instantanée est supprimée. Les captures instantanées de base de données sont liées à la base de données source. Si celle-ci bascule hors connexion pour une raison quelconque, la capture instantanée ne sera pas disponible. Pour plus d'informations sur les captures instantanées de base de données, voirCaptures instantanées de base de données (http://go.microsoft.com/fwlink/?linkid=166158&clcid=0x40C).

Les avantages offerts par la sauvegarde d'une collection de sites à l'aide d'une capture instantanée sont les suivants :

  • La capture instantanée garantit que les données lues restent cohérentes pendant toute la durée de l'opération.

  • Les utilisateurs peuvent continuer à utiliser la collection de sites pendant qu'elle est sauvegardée à partir de la capture instantanée de base de données. Ils peuvent notamment ajouter, modifier et supprimer du contenu. Cependant, les modifications apportées par les utilisateurs au site actif ne seront pas incluses dans la sauvegarde de la collection de sites, car la sauvegarde est basée sur la capture instantanée de la base de données.

Toutefois, les captures instantanées de base de données peuvent avoir un impact négatif sur les performances. Pour plus d'informations sur les captures instantanées de base de données et sur les performances, voir Limitations relatives aux captures instantanées de base de données (http://go.microsoft.com/fwlink/?linkid=166159&clcid=0x40C).

Vous pouvez utiliser la sauvegarde précise et l'exportation pour le contenu stocké dans une base de données configurée pour utiliser le fournisseur de stockage BLOB distant SQL FILESTREAM.

Remarque :
Si le fournisseur RBS que vous utilisez ne prend pas en charge les captures instantanées, vous ne pouvez pas utiliser de captures instantanées pour le déploiement ou la sauvegarde de contenu. Par exemple, le fournisseur SQL FILESTREAM ne prend pas en charge les captures instantanées.

Remarque :
Nous vous recommandons de ne pas utiliser la fonction de sauvegarde de collection de sites de SharePoint Foundation 2010 pour les collections de sites dont la taille est supérieure à 85 Go.

L'illustration suivante montre le système de sauvegarde précise et d'exportation.

Processus de récupération

SharePoint Foundation 2010 prend en charge les principales options de récupération intégrées ci-dessous :

  • Restauration à partir d'une sauvegarde de batterie de serveurs créée à l'aide d'outils intégrés ou restauration à partir de la sauvegarde d'un composant à l'aide du système de sauvegarde de batterie de serveurs.

  • Restauration à partir d'une sauvegarde de collection de sites.

  • Connexion à une base de données de contenu à l'aide de la fonctionnalité de base de données de contenu non attachée, sauvegarde ou exportation de données depuis celle-ci, puis restauration ou importation des données.

Restauration à partir d'une sauvegarde de batterie de serveurs

Les éléments pouvant être récupérés à partir d'une sauvegarde de batterie de serveurs sont les suivants :

  • Batterie de serveurs

    • Données de contenu et de configuration (par défaut)

      La batterie de serveurs entière est restaurée, y compris les paramètres stockés dans la base de données de configuration et les packages de solutions approuvées.

    • Configuration seulement

      Seules les données de configuration sont restaurées, opération au cours de laquelle tous les paramètres de la batterie de serveurs sont remplacés par les valeurs correspondantes définies dans la sauvegarde limitée à la configuration.

  • Applications Web

    Restaure les applications Web.

  • Applications de service

    Restaure les applications de service. La récupération d'application de service peut être complexe car SharePoint Foundation 2010 ne peut pas reconfigurer totalement les proxys d'applications de service durant le processus de restauration. Ceux-ci sont restaurés mais ne sont pas placés dans des groupes de proxys et ne sont par conséquent associés à aucune application Web. Pour obtenir des informations spécifiques sur les opérations nécessaires à la restauration d'applications de service spécifiques, voir Restaurer une application de service (SharePoint Foundation 2010).

  • Bases de données de contenu

    Lorsque les bases de données de contenu sont restaurées, les solutions en mode bac à sable ainsi que les collections de sites associées sont également restaurées.

Restauration comme nouvelle instance ou restauration avec remplacement

Par défaut, la récupération SharePoint Foundation 2010 restaure un objet en tant que nouvelle instance de l'objet, au lieu de remplacer toutes les instances existantes portant le même nom.

Lorsque vous restaurez une batterie de serveurs ou un objet sous une forme nouvelle, les objets suivants ne fonctionnent pas sans quelques ajustements, car tous les GUID des objets se voient affecter de nouvelles valeurs :

  • Batterie de serveurs. Lorsque vous restaurez une batterie comme nouvelle instance, vous devez effectuer les opérations suivantes :

    • recréer les paramètres de mappage des accès de substitution. La récupération SharePoint Foundation 2010 restaure uniquement la zone par défaut de l'application Web ;

    • réassocier les proxys d'applications de service à des groupes de proxys, car ils ne sont pas affectés à des groupes de proxys lorsqu'ils sont restaurés. Toutes les applications Web seront associées au groupe de proxys par défaut. Vous devez associer les applications Web à d'autres groupes de proxys si vous souhaitez procéder ainsi.

  • Application Web.

    • Si le nom et l'URL d'application Web que vous fournissez correspondent à un nom et à une URL d'application Web qui existent déjà dans la batterie de serveurs, la récupération SharePoint Foundation 2010 les combine.

    • Si vous ne souhaitez pas combiner les applications Web, vous devez renommer l'application Web lorsque vous la restaurez en tant que nouvelle application Web.

    • Lorsque vous restaurez une application Web en tant que nouvelle application Web dans le même environnement, mais que vous ne combinez pas les applications Web, de nombreux autres paramètres et objets doivent également être modifiés. Par exemple, vous pouvez être amené à indiquer différents chemins d'accès de fichiers de base de données et différents noms de bases de données.

  • Applications de service et proxys d'applications de service

    • Si vous récupérez une application de service, ainsi que le proxy d'application de service associé, vous devez associer celui-ci à un groupe de proxys.

    • Si vous récupérez une application de service sans récupérer le proxy d'application de service associé, vous devez recréer le proxy d'application de service.

    Remarque :
    Il est impossible de restaurer une application de service comme nouvelle instance dans la même batterie, mais il est possible de restaurer une application de service comme nouvelle instance dans une autre batterie.

Lorsque vous restaurez un objet et que vous remplacez l'objet existant, aucune modification n'est nécessaire.

Restauration à partir d'une sauvegarde de collection de sites

Seules les collections de sites peuvent être récupérées à partir d'une sauvegarde de collection de sites.

Récupération à partir d'une base de données de contenu non attachée

SharePoint Foundation 2010 permet de se connecter à une base de données de contenu liée à une instance SQL Server et d'effectuer des sauvegardes à partir de cette base de données de contenu, mais n'est pas associé à une application Web SharePoint locale. Les bases de données non liées auxquelles vous pouvez vous connecter sont les bases de données de contenu en lecture seule restaurées à partir d'une technologie de sauvegarde prise en charge et les captures instantanées SQL Server de bases de données de contenu.

La récupération est un processus en deux étapes :

  1. sauvegarde ou exportation de l'objet à partir de la base de données de contenu non attachée ;

  2. restauration ou importation de la sortie de l'étape précédente dans SharePoint Foundation 2010.

Les éléments suivants peuvent être sauvegardés ou exportés à partir d'une base de données non attachée à l'aide d'une opération de sauvegarde et d'exportation granulaire, puis restaurés :

  • Collection de sites

    Sauvegarde par le biais d'une sauvegarde de collection de sites, puis récupération par le biais d'une restauration de collection de sites.

  • Site

    Exportation, puis importation.

  • Listes et bibliothèques

    Exportation, puis importation.

Vous pouvez utiliser les opérations d'importation pour récupérer du contenu que vous avez sauvegardé à partir d'une base de données configurée pour utiliser le fournisseur RBS SQL FILESTREAM. Le contenu récupéré est stocké par SharePoint Foundation 2010 à l'aide du fournisseur de stockage actuellement défini pour cette base de données de contenu ; en d'autres termes, si la base de données de contenu n'est pas configurée de manière à utiliser RBS, les données sont stockées dans la base de données de contenu ; dans le cas contraire, elles sont stockées dans RBS.

Contenu connexe

Centre de ressources | Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201997&clcid=0x40C)
Contenu IT Pro | Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) Sauvegarde et récupération (SharePoint Foundation 2010)
Contenu de développement | Protection et récupération des données (http://go.microsoft.com/fwlink/?linkid=199237&clcid=0x40C)

Historique des modifications

Date | Description | Raison
21 octobre 2010 | 2010/10/18 | Mise à jour du contenu
15 juillet 2010 | 2010/07/12 | Mise à jour du contenu
8 juillet 2010 | 2010/07/05 | Mise à jour du contenu


Planifier la disponibilité (SharePoint Foundation 2010)

Cet article décrit les décisions fondamentales qui interviennent dans le choix de stratégies de disponibilité pour un environnement Microsoft SharePoint Foundation 2010.

Lorsque vous passez en revue vos besoins en matière de disponibilité, sachez que plus le niveau de disponibilité est élevé et plus le nombre de systèmes que vous devez protéger est important, plus la solution de disponibilité sera probablement complexe et coûteuse.

Toutes les solutions au sein d'une organisation n'exigent probablement pas le même niveau de disponibilité. Vous pouvez proposer différents niveaux de disponibilité pour différents sites, différents services ou différentes batteries.

Dans cet article :

  • Vue d'ensemble de la disponibilité

  • Choix d'une stratégie et d'un niveau de disponibilité

  • Redondance et basculement entre centres de données proches configurés comme batterie unique (batterie « étirée »)

Vue d'ensemble de la disponibilité

La disponibilité est le degré de perception de la disponibilité par les utilisateurs d'un environnement SharePoint Foundation. Un système disponible est un système résilient, c'est-à-dire que les incidents affectant le service se produisent rarement et qu'une action immédiate et efficace est effectuée lorsqu'ils se produisent.

La disponibilité fait partie de la gestion de la continuité des opérations ; elle est liée à la sauvegarde, à la récupération et à la récupération d'urgence. Pour plus d'informations sur ces processus associés, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) et Planifier la récupération d'urgence (SharePoint Foundation 2010).

Remarque :
Lors du calcul de la disponibilité, la plupart des entreprises ajoutent ou retirent des heures pour les activités de maintenance planifiées.

L'une des mesures les plus courantes de la disponibilité est le pourcentage de temps de fonctionnement exprimé sous forme d'un nombre de neufs : il s'agit du pourcentage de temps pendant lequel un système donné est en service et fonctionne. Par exemple, un système avec un pourcentage de temps de fonctionnement égal à 99,999 correspond à une disponibilité de cinq neufs.

Le tableau suivant met en corrélation les pourcentages de temps de fonctionnement et leur équivalent en durées calendaires.

Pourcentage de temps d'activité acceptable | Temps d'immobilisation par jour | Temps d'immobilisation par mois | Temps d'immobilisation par an
95 | 72,00 minutes | 36 heures | 18,26 jours
99 (deux neufs) | 14,40 minutes | 7 heures | 3,65 jours
99,9 (trois neufs) | 86,40 secondes | 43 minutes | 8,77 heures
99,99 (quatre neufs) | 8,64 secondes | 4 minutes | 52,60 minutes
99,999 (cinq neufs) | 0,86 secondes | 26 secondes | 5,26 minutes

Si vous pouvez établir une estimation censée du nombre total probable d'heures d'indisponibilité que vous pouvez rencontrer, vous pouvez utiliser les formules ci-dessous pour calculer le pourcentage de temps de fonctionnement par an, par mois et par semaine :

% temps de fonctionnement/an = 100 - (8760 - nombre total d'heures d'indisponibilité par an)/8760

% temps de fonctionnement/mois = 100 - ((24 × nombre de jours dans le mois) - nombre total d'heures d'indisponibilité dans ce mois)/(24 × nombre de jours dans le mois)

% temps de fonctionnement/semaine = 100 - (168 - nombre total d'heures d'indisponibilité dans cette semaine/168

Coûts de la disponibilité

La disponibilité est une des conditions les plus onéreuses d'un système. Plus le niveau de disponibilité est élevé et plus le nombre de systèmes que vous devez protéger est important, plus la solution de disponibilité sera probablement complexe et coûteuse. Lorsque vous investissez dans la disponibilité, les frais comprennent :

  • le matériel et les logiciels supplémentaires, impliquant souvent des opérations complexes entre les logiciels et les paramètres ;

  • la complexité opérationnelle supplémentaire.

Les coûts de la disponibilité doivent être évalués en fonction des besoins de votre entreprise : toutes les solutions au sein d'une organisation n'exigent probablement pas le même niveau de disponibilité. Vous pouvez proposer différents niveaux de disponibilité pour différents sites, différents services ou différentes batteries.

La disponibilité constitue un élément essentiel pour lequel les groupes informatiques proposent des contrats de niveau de service pour définir les attentes avec les groupes de clients. De nombreuses entreprises informatiques proposent divers contrats de niveau de service correspondant à différents niveaux de facturation.

Détermination des besoins en matière de disponibilité

Pour évaluer la tolérance de l'organisation sur les temps d'immobilisation d'un site, d'un service ou d'une batterie, répondez aux questions suivantes :

  • Si le site, le service ou la batterie n'est pas disponible, les employés de votre organisation seront-ils dans l'impossibilité d'exercer raisonnablement leurs fonctions ?

  • Si le site, le service ou la batterie n'est pas disponible, les transactions de l'entreprise et des clients seront-elles interrompues, entraînant une perte d'activité et de clients ?

Si vous avez répondu oui à l'une de ces questions, vous devez investir dans une solution de disponibilité.

Choix d'une stratégie et d'un niveau de disponibilité

Vous pouvez choisir l'une des approches permettant d'améliorer la disponibilité dans un environnement SharePoint Foundation, notamment :

  • améliorer la tolérance de panne des composants matériels du serveur ;

  • accroître la redondance des rôles de serveur d'une batterie ;

Tolérance de panne des composants matériels

La tolérance de panne des composants matériels est la redondance des composants matériels et des systèmes d'infrastructure, par exemple les alimentations au niveau du serveur. Lors de la planification de la tolérance de panne des composants matériels, tenez compte des points suivants :

  • La redondance totale de chaque composant d'un serveur n'est peut-être pas possible ou peut être difficile. Utilisez des serveurs supplémentaires pour une meilleure redondance.

  • Vérifiez que les serveurs sont équipés de plusieurs alimentations connectées à des sources différentes pour une redondance maximale.

Dans n'importe quel système, il est recommandé de travailler avec les fabricants de matériel pour bénéficier de la tolérance de panne adaptée au système, y compris des contrôleurs RAID (Redundant Array of Independent Disks).

Redondance dans une batterie

SharePoint Foundation 2010 prend en charge les rôles serveur en cours d'exécution sur des ordinateurs redondants (c'est-à-dire l'évolution) dans une batterie pour augmenter la capacité et procurer une disponibilité standard.

La capacité désirée détermine à la fois le nombre et la taille des serveurs d'une batterie. Lorsque les conditions de base sont remplies, vous voudrez peut-être ajouter des serveurs supplémentaires pour augmenter la disponibilité globale. L'illustration suivante montre comment assurer la redondance pour chaque rôle serveur.

Disponibilité dans une batterie de serveurs

Disponibilité d'une batterie de serveurs unique

Le tableau ci-dessous décrit les serveurs et les rôles de serveur dans un environnement SharePoint Foundation 2010 et les stratégies de redondance standard utilisables pour chacun d'entre eux dans une batterie.

Rôle serveur | Stratégie préférable de redondance dans une batterie
Serveur Web frontal | Déploiement de plusieurs serveurs Web frontaux dans une batterie et utilisation de l'équilibrage de la charge réseau
Serveur d'applications | Déploiement de plusieurs serveurs d'applications dans une batterie
Serveur de bases de données | Déploiement de serveurs de bases de données via clustering ou mise en miroir de bases de données à haute disponibilité

Stratégies de disponibilité de base de données

Vous pouvez utiliser le clustering avec basculement Microsoft SQL Server ou la mise en miroir de bases de données à haute disponibilité SQL Server pour prendre en charge la disponibilité des bases de données dans un environnement SharePoint Foundation.

Clustering avec basculement SQL Server

Le clustering avec basculement peut assurer la disponibilité d'une instance de SQL Server. Un cluster de basculement est une combinaison d'un ou plusieurs nœuds ou serveurs et de deux disques partagés ou plus. Une instance de cluster de basculement apparaît comme un ordinateur unique, mais possède des fonctionnalités qui assure le basculement d'un nœud vers un autre si le nœud actuel devient indisponible. SharePoint Foundation peut exécuter n'importe quelle combinaison de nœuds actifs et passifs dans un cluster pris en charge par SQL Server.

SharePoint Foundation fait référence au cluster dans sa globalité ; par conséquent, le basculement est automatique et transparent du point de vue de SharePoint Foundation.

Pour des informations détaillées sur le clustering avec basculement, voir Mise en route avec le clustering avec basculement de SQL Server 2008 (http://go.microsoft.com/fwlink/?linkid=102837&clcid=0x40C) et Configurer la disponibilité à l'aide de la mise en cluster SQL Server (SharePoint Foundation 2010).

Mise en miroir à haute disponibilité SQL Server

La mise en miroir de base de données est une technologie SQL Server qui peut assurer la redondance de base de données, une base de données à la fois. Dans le cadre de la mise en miroir de base de données, des transactions sont envoyées directement d'une base de données principale sur un serveur principal à une base de données miroir sur un serveur miroir lorsque le tampon du journal des transactions de la base de données principale est écrit sur disque. Cette technique peut permettre d'obtenir une base de données miroir quasiment à jour avec la base de données principale. SQL Server Enterprise Edition fournit des fonctionnalités supplémentaires qui améliorent les performances de mise en miroir des bases de données.

Pour effectuer une mise en miroir dans une batterie SharePoint Foundation, vous devez utiliser une mise en miroir à haute disponibilité, aussi appelée « Haute sécurité avec basculement automatique ».La mise en miroir de base de données à haute disponibilité implique trois instances de serveur : un serveur principal, un serveur miroir et un serveur témoin. Le serveur témoin permet à SQL Server de basculer automatiquement du serveur principal sur le serveur miroir. Le basculement de la base de données principale sur la base de données miroir prend généralement plusieurs secondes.

Contrairement aux versions précédentes, SharePoint Foundation prend en charge la mise en miroir. Après avoir configuré une instance de miroir de base de données de SQL Server, utilisez l'Administration centrale de SharePoint ou les applet de commande Windows PowerShell pour identifier l'emplacement du serveur de bases de données de basculement (miroir) pour une base de données de configuration, une base de données de contenu ou une base de données d'application de service. Le fait de définir un emplacement de base de données de basculement ajoute un paramètre à la chaîne de connexion utilisée par SharePoint Foundation pour se connecter à SQL Server. En cas de délai d'attente SQL Server, les événements suivants se produisent :

  1. Le serveur témoin qui est configuré pour la mise en miroir SQL Server échange automatiquement les rôles des bases de données primaire et miroir.

  2. SharePoint Foundation tente automatiquement de contacter le serveur spécifié comme base de données de basculement.

Pour plus d'informations sur la configuration de la mise en miroir de bases de données, voir Configurer la disponibilité à l'aide de la mise en miroir de base de données SQL Server (SharePoint Foundation 2010).

Pour obtenir des informations générales sur la mise en miroir de bases de données, voir Mise en miroir de bases de données (http://go.microsoft.com/fwlink/?linkid=180597&clcid=0x40C).

Remarque :
Les bases de données qui ont été configurées de manière à utiliser le fournisseur de magasin d'objets BLOB à distance FILESTREAM SQL Server ne peuvent pas être mises en miroir.

Comparaison des stratégies de disponibilité des bases de données pour une batterie unique : clustering avec basculement SQL Server et mise en miroir à haute disponibilité SQL Server

Le tableau ci-dessous compare le clustering avec basculement et la mise en miroir à haute disponibilité SQL Server synchrone.

 | Clustering avec basculement SQL Server | Mise en miroir à haute disponibilité SQL Server
Temps de basculement | Le membre du cluster entre immédiatement en service en cas de défaillance. | Le miroir entre immédiatement en service en cas de défaillance.
Cohérence des transactions ? | Oui | Oui
Concurrence des transactions ? | Oui | Oui
Temps de récupération | Temps de récupération plus court (quelques millisecondes). | Temps de récupération légèrement plus long (quelques millisecondes).
Étapes requises pour le basculement ? | La défaillance est automatiquement détectée par les nœuds de la base de données. SharePoint Foundation 2010 fait référence au cluster ; le basculement est donc transparent et automatique. | La défaillance est automatiquement détectée par la base de données. SharePoint Foundation 2010 a connaissance de l'emplacement du miroir s'il a été configuré correctement ; le basculement est donc automatique.
Protection contre les défaillances de stockage ? | Ne protège pas contre les défaillances de stockage, car le stockage est partagé entre les nœuds du cluster. | Protège contre les défaillances de stockage, car les serveurs des bases de données principale et miroir écrivent sur des disques locaux.
Types de stockage pris en charge | Stockage partagé (plus coûteux). | Peut utiliser le stockage à connexion directe (DAS) moins coûteux.
Besoins en termes d'emplacement | Les membres du cluster doivent être sur le même sous-réseau. | Les serveurs principal, miroir et témoin doivent être sur le même LAN (jusqu'à 1 ms de latence aller-retour).
Modèle de récupération | mode de récupération complète SQL Server recommandé. Vous pouvez utiliser le mode de récupération simple SQL Server, bien que le seul point de récupération disponible, si le cluster est perdu, soit la dernière sauvegarde complète. | Nécessite le mode de récupération complète SQL Server.
Surcharge des performances | Il est possible que les performances soient réduites lorsqu'un basculement se produit. | La mise en miroir à haute disponibilité introduit une latence des transactions, car elle est synchrone. Elle requiert également plus de mémoire supplémentaire et une surcharge du processeur.
Charge opérationnelle | Configurée et maintenue au niveau du serveur. | La charge opérationnelle est supérieure au clustering. Elle doit être configurée et maintenue pour toutes les bases de données. La reconfiguration après le basculement est manuelle.

Stratégies de redondance des applications de service

La stratégie de redondance que vous appliquez pour protéger des applications de service qui s'exécutent dans une batterie varie selon l'emplacement où l'application de service stocke les données.

Applications de service qui stockent des données dans des bases de données

Pour protéger les applications de service qui stockent des données dans des bases de données, procédez comme suit :

  1. Installez le service sur plusieurs serveurs d'applications afin d'assurer la redondance dans l'environnement.

  2. Configurez le clustering ou la mise en miroir SQL Server pour protéger les données.

Les applications de service suivantes stockent des données dans des bases de données :

  • Application de service Connexion de données métiers

  • Application de service Registre d'application

    Il est déconseillé de mettre en miroir la base de données Registre d'application, car elle est uniquement utilisée lors de la mise à niveau des informations de catalogue de données métiers Windows SharePoint Services 3.0 vers SharePoint Foundation 2010.

  • Application de service de collecte de données relatives à l'utilisation et à l'état

    Remarque :
    Il est déconseillé de mettre en miroir la base de données de journalisation de l'application de service de collecte de données relatives à l'utilisation et à l'état.

  • Service de paramètres d'abonnement Microsoft SharePoint Foundation

Redondance et basculement entre centres de données proches configurés comme batterie unique (batterie « étirée »)

Certaines entreprises ont des centres de données proches avec des connexions à bande passante élevée, ce qui permet de les configurer sous forme d'une batterie unique. On parle dans ce cas de « batterie étirée ». Pour qu'une batterie étirée fonctionne, la latence entre SQL Server et les serveurs Web frontaux doit être inférieure à 1 ms dans un sens avec une bande passante minimale égale à 1 Gbit/s.

Dans ce scénario, vous pouvez assurer la tolérance de panne en suivant l'aide standard pour rendre les bases de données et les applications de service redondantes.

L'illustration suivante montre une batterie étirée.

Batterie étirée

Batterie de serveurs « étirée »

Historique des modifications

Date | Description | Raison
17 juin 2010 | 2010/06/14 | Mise à jour du contenu


Planifier la récupération d'urgence (SharePoint Foundation 2010)

Cet article décrit les décisions clés à prendre lorsqu'il s'agit de choisir des stratégies de récupération d'urgence pour un environnement Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Vue d'ensemble de la récupération d'urgence

  • Choisir une stratégie de récupération d'urgence

  • Planification pour un secours à froid

  • Planification pour un secours semi-automatique

  • Planification pour des centres de données de secours à chaud

  • Configuration requise pour la récupération d'urgence

Vue d'ensemble de la récupération d'urgence

Pour les besoins du présent article, nous définirons la récupération d'urgence comment étant la capacité à récupérer d'une situation où un centre de données qui héberge SharePoint Foundation devient indisponible.

La stratégie de récupération d'urgence que vous utilisez pour SharePoint Foundation doit être coordonnée avec celle qui s'applique à l'infrastructure associée, notamment les domaines Active Directory, Exchange Server et Microsoft SQL Server. Collaborez avec les administrateurs de l'infrastructure sur laquelle vous reposez pour concevoir une stratégie et un plan de récupération d'urgence coordonnés.

Le temps et les efforts immédiats nécessaires à la mise en service d'une autre batterie de serveurs sur un site différent ont un nom. Ils sont souvent appelés secours à chaud, secours semi-automatique ou secours à froid. Nos définitions de ces termes sont les suivantes :

Secours à chaud Second centre de données capable d'assurer une disponibilité en quelques minutes ou secondes.

Secours semi-automatique Second centre de données capable d'assurer une disponibilité en quelques minutes ou heures.

Secours à froid Second centre de données capable d'assurer une disponibilité en quelques heures ou jours.

La récupération d'urgence peut être l'une des exigences les plus coûteuses à l'échelle d'un système. Plus le délai qui s'écoule entre la panne et le rétablissement de la disponibilité est bref et plus les systèmes que vous protégez sont nombreux, plus il y a de chances pour que la solution de récupération d'urgence soit complexe et coûteuse. Lorsque vous investissez dans des centres de données de secours à chaud ou semi-automatique, les coûts englobent :

  • les éléments matériels et logiciels supplémentaires, qui accentuent souvent la complexité des opérations entre les applications logicielles, telles que les scripts personnalisés pour le basculement et la récupération ;

  • une complexité opérationnelle supplémentaire.

Les coûts de maintenance des centres de données de secours à chaud ou semi-automatique doivent être évalués en fonction des besoins de votre entreprise. Les solutions au sein d'une organisation ne sont pas toutes susceptibles de demander le même niveau de disponibilité après un incident. Vous pouvez proposer différents niveaux de récupération d'urgence en fonction du contenu, des services ou des batteries de serveurs (p.ex., contenu ayant le plus fort impact sur votre activité, services de recherche ou batterie de serveurs de publication sur Internet).

La récupération d'urgence est un domaine clé dans lequel les groupes informatiques proposent des contrats de niveau de service (SLA) pour fixer les attentes avec les groupes clients. De nombreuses organisations informatiques offrent différents contrats de niveau de service associés à différents niveaux de facturation.

Si vous envisagez d'implémenter le basculement entre différentes batteries de serveurs, nous vous recommandons dans un premier temps de déployer et configurer la solution de base dans une batterie de serveurs, puis d'implémenter et tester la récupération d'urgence.

Choisir une stratégie de récupération d'urgence

En matière de récupération d'urgence pour un environnement SharePoint Foundation, vous avez le choix entre diverses approches qui dépendent des besoins de votre entreprise. Les exemples suivants exposent les raisons qui peuvent amener les sociétés à opter pour des stratégies de récupération d'urgence reposant de secours à froid, à chaud ou semi-automatique.

  • Stratégie de récupération d'urgence de secours à froid : une entreprise expédie régulièrement des sauvegardes pour permettre une récupération complète à des emplacements de stockage hors site locaux et régionaux, et a souscrit des contrats de location de serveurs d'urgence dans une autre région.

    Avantages :

    • Souvent la solution la plus économique sur le plan de la maintenance opérationnelle.

    • Souvent une solution coûteuse en matière de récupération, car elle exige que les serveurs physiques soient correctement configurés après un incident.

    Inconvénients : la solution de récupération la plus lente.

  • Stratégie de récupération d'urgence de secours semi-automatique : une entreprise expédie des images de serveurs virtuels à destination de batteries de serveurs de récupération d'urgence locales et régionales.

    Avantages : récupération souvent relativement peu coûteuse, car une batterie de serveurs virtuels ne demande pas nécessairement une configuration importante après récupération.

    Inconvénients : maintenance potentiellement très coûteuse et fastidieuse.

  • Stratégie de récupération d'urgence de secours à chaud : une entreprise utilise plusieurs centres de données, mais délivre le contenu et les services par le biais d'un seul et même centre de données.

    Avantages : récupération souvent relativement rapide.

    Inconvénients : configuration et maintenance potentiellement coûteuses.

Important :
Quelle que soit la solution de récupération d'urgence que vous décidez d'implémenter pour votre environnement, vous risquez de perdre des données.

Planification pour des centres de données de secours à froid

Dans un scénario de récupération d'urgence de secours à froid, vous pouvez effectuer une récupération en configurant une nouvelle batterie de serveurs sur un nouveau site (de préférence, en recourant à un déploiement à base de script), puis en restaurant les sauvegardes. Une autre solution consiste à restaurer une batterie de serveurs à partir d'une solution de sauvegarde, telle que Microsoft System Center Data Protection Manager 2007, qui protège vos données au niveau de l'ordinateur et vous permet de restaurer chaque serveur séparément. Cet article ne fournit pas d'instructions de création et de récupération détaillées dans les scénarios de secours à froid. Pour plus d'informations, voir :

  • Restaurer une batterie de serveurs (SharePoint Foundation 2010)

  • Restaurer les personnalisations (SharePoint Foundation 2010)

Planification pour des centres de données de secours semi-automatique

Dans un scénario de récupération d'urgence de secours semi-automatique, vous pouvez créer une solution de secours semi-automatique en veillant à créer de façon systématique et fréquente des images virtuelles des serveurs de votre batterie que vous expédiez à destination d'un site secondaire. Sur ce site, vous devez disposer d'un environnement qui permette de configurer et connecter facilement les images afin de recréer votre environnement de batterie de serveurs.

Cet article ne contient pas d'instructions détaillées expliquant comment créer des solutions de secours semi-automatique. Pour plus d'informations sur la planification de déploiements de batteries de serveurs à l'aide de solutions virtuelles, voir Planifier la virtualisation (SharePoint Foundation 2010).

Planification pour des centres de données de secours à chaud

Dans un scénario de récupération d'urgence de secours à chaud, vous pouvez configurer une batterie de serveurs de basculement pour assurer une récupération d'urgence dans un centre de données distinct à partir de la batterie principale. Un environnement qui comporte une batterie de serveurs de basculement distincte présente les caractéristiques suivantes :

  • une base de données de configuration et une base de données de contenu Administration centrale distinctes doivent être maintenues dans la batterie de serveurs de basculement ;

  • toutes les personnalisations doivent être déployées dans les deux batteries de serveurs.

    Remarque :
    Il est recommandé d'utiliser un déploiement à base de script pour créer la batterie de serveurs principale et la batterie de serveurs de déploiement avec les mêmes paramètres de configuration et les mêmes personnalisations.

  • Les mises à jour doivent être appliquées aux deux batteries de serveurs, séparément.

  • Les bases de données de contenu SharePoint Foundation peuvent être mises en miroir de façon asynchrone ou faire l'objet d'une copie des journaux de transaction dans la batterie de serveurs de basculement.

    Remarque :
    La mise en miroir SQL Server peut être utilisée uniquement pour copier des bases de données sur un serveur miroir unique, mais vous pouvez copier les journaux de transaction sur plusieurs serveurs secondaires.

  • Dans le cas des applications de service, la copie des journaux de transactions sur une batterie de serveurs n'est pas toujours possible. Pour plus d'informations, voir Redondance des applications de service dans les centres de données plus loin dans cet article.

Cette topologie peut être reproduite dans de nombreux centres de données si vous configurez la copie des journaux de transaction SQL Server dans un ou plusieurs centres de données supplémentaires.

Consultez votre fournisseur SAN pour déterminer si vous pouvez utiliser la réplication SAN ou un autre mécanisme pris en charge pour assurer la disponibilité dans les centres de données.

La figure suivante illustre une batterie de serveurs principale et une batterie de serveurs de basculement avant basculement.

Batterie de serveurs principale et batterie de serveurs de basculement avant basculement

Batteries de serveurs principale et de basculement avant le basculement

Redondance des applications de service dans les centres de données

Pour assurer la disponibilité des applications de service dans les centres de données, il est recommandé pour les services qui peuvent être exécutés sur les différents centres de données d'exécuter une batterie de services distincte qui soit accessible à partir des centres de données principal et secondaire(s).

Pour les services qui ne peuvent pas être exécutés sur les différentes batteries de serveurs, et pour fournir une disponibilité à la batterie de services proprement dite, les stratégies visant à assurer une redondance dans les centres de données pour un service varient selon que :

  • il existe un intérêt économique à ce que l'application de service soit exécutée dans la batterie de serveurs de récupération d'urgence lorsqu'elle n'est pas utilisée ;

  • les bases de données associées à l'application de service peuvent fait l'objet d'une copie des journaux de transaction ou d'une mise en miroir asynchrone ;

  • l'application de service peut s'exécuter sur des bases de données en lecture seule.

Les sections suivantes décrivent les stratégies de récupération d'urgence que nous recommandons pour chaque application de service. Les applications de service sont regroupées par stratégie.

Bases de données pouvant faire l'objet d'une copie des journaux de transaction ou d'une mise en miroir asynchrone

Après qu'une application de service a été initialement déployée dans une batterie de serveurs secondaire, les bases de données qui prennent en charge les applications de service suivantes peuvent faire l'objet d'une mise en miroir asynchrone ou d'une copie des journaux de transaction dans les batteries de serveurs :

  • Application de service Registre d'application

    Bases de données : service Registre d'application

  • Application de service Business Data Connectivity

    Bases de données : Business Data Connectivity

  • Application de service de collecte de données relatives à l'utilisation et à l'état

    Bases de données : journalisation

    Remarque :
    La base de données de journalisation peut faire l'objet d'une copie des journaux de transaction ou d'une mise en miroir. Toutefois, il est déconseillé d'exécuter le service de collecte de données relatives à l'utilisation et à l'état dans la batterie de serveurs de récupération d'urgence, de procéder à une mise en miroir ou à la copie des journaux de transaction pour la base de données de journalisation.

Applications de service et bases de données ne pouvant pas faire l'objet d'une copie des journaux de transaction ou d'une mise en miroir asynchrone

Les applications de service suivantes doivent être déployées à la fois dans la batterie de serveurs principale et dans la batterie de serveurs de basculement, et elles ne peuvent pas faire l'objet d'une copie des journaux de transaction ou d'une mise en miroir asynchrone. Pour la plupart de ces applications de service, il est recommandé de les déployer puis de vérifier que les paramètres de configuration de la batterie de serveurs de basculement sont identiques à ceux de la batterie de serveurs principale. Si la configuration de la batterie de serveurs principale est modifiée et que ces modifications affectent le service, vous devez mettre à jour la batterie de serveurs de basculement.

  • Application de service de paramètres d'abonnement Microsoft SharePoint Foundation

    Base de données : paramètres d'abonnement

    Remarque :
    La copie des journaux de transaction n'est pas prise en charge dans le cas de la base de données des paramètres d'abonnement.

Configuration requise pour la récupération d'urgence

Dans l'idéal, les composants et les systèmes de basculement doivent correspondre en tous points aux composants et aux systèmes principaux : plateforme, matériel et nombre de serveurs. Au minimum, l'environnement de basculement doit être en mesure de gérer le trafic attendu lors d'un basculement. Ne perdez pas de vue que seul un sous-ensemble d'utilisateurs pourra être desservi par le site de basculement. Les systèmes doivent au moins correspondre sur les points suivants :

  • version du système d'exploitation et toutes les mises à jour ;

  • versions de SQL Server et toutes les mises à jour ;

  • versions de Produits SharePoint 2010 et toutes les mises à jour.

Bien que cet article porte enssentiellement sur la disponibilité de Produits SharePoint 2010, la durée active du système sera également affectée par les autres composants du système. En particulier, veillez à effectuer les opérations suivantes :

  • Assurez-vous que les dépendances d'infrastructure, telles que l'alimentation, le refroidissement, le réseau, l'annuaire et le service SMTP sont entièrement redondants.

  • Choisissez un mécanisme de basculement (équilibrage de charge matérielle ou DNS) qui réponde à vos besoins.

Historique des modifications


Planification de la virtualisation (SharePoint Foundation 2010)

Cette section contient des articles visant à vous aider à planifier et implémenter une solution de virtualisation de serveurs pour des batteries de serveurs Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Licence et prise en charge de la virtualisation (SharePoint Foundation 2010)

  • Exigences en matière de virtualisation Hyper-V (SharePoint Foundation 2010)

  • Planifier la virtualisation (SharePoint Foundation 2010)

  • Hyper-V performance tests (SharePoint Foundation 2010) (en anglais)

Historique des modifications

Date | Description | Raison
18 novembre 2010 | 2010/11/15 | Mise à jour du contenu


Licence et prise en charge de la virtualisation (SharePoint Foundation 2010)

Cet article contient des informations sur la prise en charge et les licences relatives à l'utilisation des technologies de virtualisation de serveur dans le cadre du déploiement des produits SharePoint 2010 dans un environnement virtuel.

Prise en charge des produits SharePoint 2010 pour la virtualisation

Tous les éléments de Microsoft SharePoint Foundation 2010 sont entièrement pris en charge lorsqu'ils sont déployés dans un environnement Technologie Hyper-V de Windows Server 2008. En outre, toutes les technologies de prise en charge associées ou requises sont prises en charge.

Remarque :
La virtualisation SharePoint Foundation 2010 prend notamment en charge les technologies de virtualisation tierces, soit hébergées soit basées sur le matériel, qui sont certifiées par Microsoft. Pour plus d'informations sur la certification et les fournisseurs participants, voir le Programme SVVP (Server Virtualization Validation Program) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=125649&clcid=0x40C).

Virtualisation de serveur à l'aide de la technologie Hyper-V

À compter de Windows Server 2008, la virtualisation de serveur avec Hyper-V fait partie intégrante du système d'exploitation. Hyper-V est disponible dans toutes les éditions du système d'exploitation, ainsi que dans Microsoft Hyper-V Server 2008.

Nous vous recommandons d'utiliser Windows Server 2008 R2 ou Microsoft Hyper-V Server 2008 R2 comme serveurs de virtualisation pour le déploiement de produits SharePoint 2010. Ces versions offrent :

  • de nouvelles fonctionnalités, telles qu'une meilleure prise en charge des processeurs virtuels et de la mémoire pour les ordinateurs virtuels ;

  • des performances accrues, notamment au niveau des disques durs virtuels et des cartes réseau.

Pour plus d'informations, voir Nouveautés de Hyper-V dans Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?linkid=155234&clcid=0x40C).

Gestion des licences dans l'environnement du système d'exploitation

Avant de planifier la virtualisation, vous devez déterminer les spécifications en termes de licences pour votre environnement de virtualisation. Il existe deux types d'environnements de système d'exploitation :

  • Un environnement de système d'exploitation physique

  • Un ou plusieurs environnements de système d'exploitation virtuels

Un environnement de système d'exploitation virtuel est configuré pour s'exécuter sur un système matériel virtuel (ou émulé). L'utilisation de technologies qui créent des environnements de système d'exploitation virtuels ne modifie pas les spécifications en termes de licence pour le système d'exploitation et les applications s'exécutant dans l'environnement de système d'exploitation.

Le modèle de licence du système d'exploitation Windows Server pour les systèmes à processeurs multicœur physiques est basé sur le nombre de processeurs physiques installés dans le matériel. Ce modèle s'étend aux processeurs virtuels configurés pour un ordinateur virtuel s'exécutant sur un serveur de virtualisation. Dans le cadre de la gestion des licences, un processeur virtuel est considéré comme ayant le même nombre de threads et de cœurs que chaque processeur physique dans le système matériel physique sous-jacent.

Pour plus d'informations sur les spécifications en termes de licence, voir :

  • Gestion des licences des produits serveur Microsoft dans des environnements virtuels (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187741&clcid=0x40C)

    Ce livre blanc vous donne un aperçu des modèles de licences Microsoft disponibles pour le système d'exploitation serveur et les applications serveur dans des environnements virtuels.

  • Calculatrice de virtualisation Windows Server (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187742&clcid=0x40C)

    Les calculatrices de virtualisation Windows Server vous proposent deux méthodes pour estimer le nombre et le coût des licences Windows Server Standard Edition, Enterprise Edition et Datacenter Edition requises pour vos scénarios de virtualisation. Elles vous aident également à déterminer l'édition de Windows Server la plus rentable.

Remarque :
Bien que Microsoft Hyper-V Server 2008 R2 ne nécessite pas de licence pour le serveur de virtualisation, les environnements de système d'exploitation virtuels doivent respecter les spécifications en termes de licence.

Gestion des licences des produits SharePoint 2010

Chaque élément d'une batterie SharePoint qui est installé sur un ordinateur virtuel doit être conforme aux spécifications en termes de licence pour SharePoint Foundation 2010 ainsi qu'aux technologies associées et de prise en charge.

Historique des modifications


Exigences en matière de virtualisation Hyper-V (SharePoint Foundation 2010)
Voir aussi

Cet article présente la configuration matérielle et logicielle requise pour utiliser la virtualisation matérielle. Même si Technologie Hyper-V de Windows Server 2008 est le point de mire de ce document, la configuration matérielle de base nécessaire à la prise en charge de la virtualisation matérielle vaut également pour les technologies de virtualisation tierces certifiées par Microsoft.

Configuration matérielle

La configuration requise pour la virtualisation matérielle est la suivante :

  • virtualisation assistée par matériel, qui est disponible dans les processeurs qui intègrent une option de virtualisation, (en particulier, les processeurs intégrant la technologie Intel VT (Virtualization Technology) ou AMD-V (AMD Virtualization) ;

  • la prévention d'exécution des données (PED) imposée par le matériel est disponible et activée.

Vous pouvez utiliser l'un des outils suivants pour déterminer si le processeur équipant un serveur existant prend en charge Hyper-V :

  • AMD Hyper-V Compatibility Check Utility (fichier .zip) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=150561&clcid=0x40C)

  • Utilitaire d'identification des processeurs Intel (version Windows) (http://go.microsoft.com/fwlink/?linkid=150562&clcid=0x40C)

Configuration logicielle

L'un des produits Microsoft suivants est requis pour Hyper-V :

  • Windows Server 2008 (toutes les éditions de Windows Server 2008, sauf pour Windows Server 2008 pour les systèmes basés sur Itanium, Windows Web Server 2008 et Windows Server 2008 Foundation) ;

  • Microsoft Hyper-V Server 2008

  • Windows Server 2008 R2 (toutes les éditions de Windows Server 2008 R2, sauf pour Windows Server 2008 R2 pour les systèmes basés sur Itanium, Windows Web Server 2008 R2 et Windows Server 2008 R2 Foundation) ;

  • Hyper-V Server R2.

Nous recommandons Windows Server 2008 R2 pour les serveurs de virtualisation en raison des nombreuses améliorations introduites pour Hyper-V, telles que :

  • la migration dynamique pour déplacer un ordinateur virtuel en cours d'exécution d'un nœud de cluster vers un autre ;

  • des performances et une évolutivité en net progrès ;

  • une prise en charge améliorée des processeurs ;

  • un stockage d'ordinateur virtuel amélioré ;

  • une prise en charge améliorée de gestion de réseau.

Pour plus d'informations, voir Nouveautés de Hyper-V dans Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?linkid=155234&clcid=0x40C).

Voir aussi

Concepts

Licence et prise en charge de la virtualisation (SharePoint Foundation 2010)

Historique des modifications


Planifier la virtualisation (SharePoint Foundation 2010)

Cet article décrit la procédure de planification à suivre pour déployer correctement Microsoft SharePoint Foundation 2010 dans un environnement virtuel. Chaque étape du processus de planification contient des liens vers la documentation adéquate. Nous supposons dans ce document que vous avez déterminé au préalable la solution SharePoint Foundation 2010 à déployer dans un environnement virtuel. De prime abord, le déploiement d'une batterie de serveurs SharePoint Foundation 2010 sur des ordinateurs virtuels est identique au déploiement d'une batterie de serveurs sur des serveurs physiques. Cependant, le déploiement dans un environnement virtuel nécessite un travail de planification supplémentaire prenant en compte les caractéristiques de la Technologie Hyper-V de Windows Server 2008 ainsi que la manière dont les ordinateurs virtuels, les cartes réseau virtuelles et les disques durs virtuels sont implémentés sur un serveur de virtualisation.

Avant d'entreprendre le développement de votre plan de virtualisation, nous vous recommandons de lire le Guide de planification et de déploiement d'Hyper-V (http://go.microsoft.com/fwlink/?linkid=187964&clcid=0x40C).

Cet article n'aborde pas de façon approfondie les thèmes suivants, mais ils sont abordés plus en détail dans d'autres articles :

  • Gestion de la capacité

  • Haute disponibilité

  • Utilisation de l'environnement virtuel

  • Conditions requises pour la sécurité

  • Récupération d'urgence

    Planification de la continuité des opérations

Un environnement virtuel se compose de deux couches interdépendantes : une couche physique et une couche virtuelle. Toute modification apportée à la configuration d'une couche a une incidence sur les serveurs de l'autre couche. Cette relation d'interdépendance devient évidente lorsque vous planifiez, déployez et utilisez SharePoint Foundation 2010 dans un environnement virtuel.

Création d'un plan pour le déploiement de SharePoint Foundation 2010 dans un environnement virtuel

La méthodologie de planification d'une batterie de serveurs virtuelle est similaire à celle recommandée pour une batterie de serveurs physique. La quasi-totalité des éléments requis et des problèmes relatifs au déploiement de SharePoint Foundation 2010 sur des serveurs physiques s'applique également aux ordinateurs virtuels. Toutes les décisions que vous prenez, par exemple en termes de configuration minimale de processeurs ou de mémoire, ont une incidence directe sur le nombre d'hôtes de virtualisation requis ainsi que sur leur capacité à prendre correctement en charge les ordinateurs virtuels identifiés pour la batterie de serveurs.

Une fois que la planification d'une batterie de serveurs physique est terminée, vous disposez de toutes les informations nécessaires pour concevoir l'architecture de virtualisation. Dans l'idéal, cette architecture doit être aussi proche que possible de la solution de virtualisation finale que vous avez l'intention de mettre en production. Dans les faits, l'architecture sera probablement modifiée au cours de la phase de déploiement du cycle de vie du système. Vous réaliserez peut-être que certains rôles de serveur de batterie ne sont pas adaptés à la virtualisation.

Les principales étapes, tâches et références de planification sont résumées dans la procédure ci-dessous.

Pour créer un plan de virtualisation

  1. Déterminer l'étendue de la virtualisation

    La détermination de l'étendue de la virtualisation joue un rôle crucial dans la réussite de l'implémentation, de la gestion et de l'évaluation de votre projet de virtualisation. Prenez en compte le fait que la plupart des solutions comprennent plusieurs composants de batterie de serveurs. Par exemple, un portail Web accessible sur Internet comprend généralement une batterie de publication, une batterie de création et une batterie de test ou d'assurance qualité. Pour déterminer l'étendue de la virtualisation, vous devez décider si vous comptez virtualiser l'ensemble de l'infrastructure de la solution ou seulement une partie de cette infrastructure.

    Utilisez la liste de tâches suivante pour déterminer l'étendue de la virtualisation.

    • Tâche : identifiez toutes les batteries de serveurs requises pour implémenter votre solution.

    • Tâche 2 : pour chaque batterie de serveurs, déterminez le nombre de serveurs requis ainsi que le rôle de chaque serveur dans la batterie de serveurs.

    • Tâche 3 : identifiez les batteries de serveurs que vous souhaitez déployer dans un environnement virtuel.

    En déterminant ainsi l'étendue de la solution, vous affinez le plan de déploiement, qui facilite l'implémentation et la gestion de la solution. Pour plus d'informations, voir Planification de sites et de solutions (SharePoint Foundation 2010). Bien que les solutions partagent certains éléments, les conditions requises pour chacune d'entre elles sont différentes. Pour plus d'informations, voir Planification de site fondamentale (SharePoint Foundation 2010). Cet article illustre l'une des solutions les plus courantes.

    Affinez l'étendue en fonction des buts et objectifs de la solution, des conditions requises ou de la division.

  2. Identifier les serveurs à virtualiser

    Identifiez les serveurs adaptés à la virtualisation. Tant techniquement que du point de vue du support Microsoft, tous les serveurs SharePoint peuvent être virtualisés. Pour déterminer si un serveur de batterie spécifique se prête ou non à la virtualisation, prenez en compte les facteurs suivants :

    • Stratégies de conformité de l'entreprise (aspects juridiques et techniques).

    • Avantages offerts par la consolidation des serveurs, notamment en termes de réduction de la consommation électrique et de l'encombrement. Pour plus d'informations, voir Virtualisation des serveurs (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187965&clcid=0x40C).

    • Capacité requise (voir l'étape de planification suivante).

  3. Identifier la capacité requise par chaque serveur de batterie

    Déterminez les ressources requises par chaque serveur de batterie, comme s'il s'agissait d'un serveur physique. Prenez en compte les rôles de serveur spécialisés, par exemple l'hébergement de composants de recherche de contenu d'entreprise. Vous devez spécifier la quantité de ressources nécessaires pour chacun des composants de serveur suivants :

    • Mémoire

    • Nombre de processeurs et fréquence d'horloge minimale

    • Nombre et taille des disques durs

    • Nombre de cartes réseau et débit requis

    Remarque :
    Pour les serveurs physiques et les ordinateurs virtuels, planifiez la charge maximale et déterminez la manière dont les pics de charge momentanés seront gérés.

  4. Déterminer si l'ordinateur virtuel répond aux besoins physiques

    Vous devez déterminer si chacun des ordinateurs virtuels identifiés à l'étape 3 est capable de répondre aux besoins d'un serveur physique correspondant en termes de capacité. Réalisez au moins les tâches suivantes :

    • Tâche 1 : évaluez les besoins en termes de mémoire dans le contexte de la capacité disponible sur l'hôte de virtualisation.

    • Tâche 2 : évaluez les besoins en termes de processeur. Hyper-V présente une limite matérielle de quatre processeurs virtuels par ordinateur virtuel. Si un serveur de batterie physique nécessite huit processeurs, déterminez s'il est possible de répondre à ce besoin en augmentant le nombre d'ordinateurs virtuels par batterie de serveurs.

    • Tâche 3 : évaluez les besoins en termes de stockage des ordinateurs virtuels, dans le contexte d'un stockage physique local ou d'un SAN.

  5. Déterminer les conditions requises pour l'hôte de virtualisation

    Déterminez la configuration minimale requise par l'hôte (mémoire, nombre de cœurs, nombre et taille des disques durs locaux, nombre de cartes réseau). Prenez également en compte les facteurs suivants et planifiez-les :

    • Évolutivité : déterminez si vous pouvez ajouter des processeurs supplémentaires, de la mémoire, des disques durs et des cartes réseau à l'ordinateur hôte.

      Important :
      Selon le fabricant et le modèle de l'ordinateur, vous ne pourrez peut-être pas augmenter la capacité. Vous devez disposer de ces informations avant d'utiliser ou d'acquérir un serveur.

    • Capacité supplémentaire de l'hôte : déterminez si l'hôte dispose ou non d'une capacité suffisante permettant d'étendre les ordinateurs virtuels existants ou d'ajouter d'autres ordinateurs virtuels. Ce point est particulièrement important si vous prévoyez d'utiliser les fonctions de clustering avec basculement, de migration rapide ou de migration en direct de Hyper-V.

    Important :
    Planifiez la charge maximale et déterminez la manière dont les pics de charge momentanés seront gérés.

  6. Concevoir l'architecture de virtualisation

    Pour que la solution fonctionne correctement, l'architecture doit être parfaitement conçue. Pour SharePoint Foundation 2010, une topologie à trois niveaux constitue une bonne base pour toutes les solutions. Les éléments suivants permettent de concevoir une architecture adéquate exploitant la topologie de base recommandée :

    • Bonnes performances globales

    • Facilité de maintenance et de mise à niveau

    • Flexibilité

    • Évolutivité

    • Haute disponibilité

    Un modèle d'architecture de virtualisation se compose des hôtes de virtualisation et des ordinateurs virtuels constituant la topologie de la batterie de serveurs. Ce modèle permet de visualiser l'environnement virtuel que vous prévoyez de déployer.

    Remarque :
    Attendez-vous à devoir affiner l'architecture au cours du processus de planification. Les étapes suivantes peuvent nécessiter d'apporter des modifications à l'architecture.

  7. Identifier les besoins en termes de stockage

    Déterminez la quantité d'espace de stockage physique local ou d'espace de stockage SAN requise pour le stockage des éléments relatifs à Hyper-V, notamment les fichiers de configuration, les disques durs virtuels et les captures instantanées.

  8. Identifier les besoins en termes de sauvegarde et de récupération

    En plus des serveurs de batterie, vous devez planifier la sauvegarde et la récupération pour tout ou partie d'une batterie de serveurs. Pour plus d'informations, voir Sauvegarde et récupération (SharePoint Foundation 2010).

  9. Déterminer les besoins en termes de haute disponibilité et concevoir une solution

    Identifiez les approches permettant d'atteindre une haute disponibilité pour les serveurs Web, les serveurs d'applications et les bases de données. Voici quelques-unes des stratégies courantes :

    • Matériel et serveurs redondants.

    • Composants remplaçables à chaud.

    • Clustering avec basculement pour les serveurs virtuels et physiques. Pour plus d'informations, voir Hyper-V : utilisation d'Hyper-V et du clustering avec basculement (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187967&clcid=0x40C).

    • Clustering ou mise en miroir des serveurs de base de données.

  10. Identifier les indicateurs d'intégrité et de capacité permettant de surveiller l'environnement virtuel

    Associez les différents indicateurs clés déterminés au cours des étapes précédentes à la planification réalisée pour SharePoint Foundation 2010. Pour plus d'informations, voir Planification de batterie de serveurs et de l'environnement (SharePoint Foundation 2010). Vous devez déterminer l'ensemble des indicateurs d'intégrité et de capacité pour collecter des mesures concernant les objets suivants dans l'environnement virtuel :

    • Ordinateurs virtuels sur lesquels SharePoint Foundation 2010 est installé

    • Ordinateurs virtuels ne faisant pas partie de la batterie de serveurs, par exemple les serveurs pare-feu

    • Hôtes de virtualisation

    • Composants réseau

    Une fois que vous avez commencé à collecter des données sur l'environnement virtuel, vous pouvez créer une planification initiale, que vous pourrez utiliser pour accéder à l'environnement virtuel et le configurer plus précisément pendant le déploiement et après la mise en production de la batterie de serveurs.

  11. Créer un plan de déploiement pour la phase de déploiement du cycle de vie du système

    Pour plus d'informations, voir le modèle Déploiement des produits SharePoint 2010, disponible dans l'article Diagrammes techniques (SharePoint Foundation 2010).

  12. Créer un plan de maintenance

    Créez un plan de maintenance permettant d'implémenter les changements de mot de passe et d'appliquer les mises à jour logicielles, les Service Packs et les correctifs logiciels. Ce plan doit inclure les ordinateurs virtuels et les hôtes de virtualisation.

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Hyper-V performance tests (SharePoint Foundation 2010) (en anglais)

This article describes the results of Microsoft SharePoint Foundation 2010 performance testing in a virtualized computing environment that uses Technologie Hyper-V de Windows Server 2008.

In this article:

  • Test goals and description

  • Hardware platform

  • Software platform

  • Test farm topology

  • Test methodology

  • Results of tests

  • Conclusions and recommendations

Test goals and description

In addition to the broad goal of determining how Microsoft SharePoint Foundation performs when virtualized in a Hyper-V environment, we wanted to identify the following issues:

  • Performance bottlenecks.

  • Performance gains when servers that are running SharePoint Foundation are virtualized on host servers that support new technologies such as hyper-threading (HT) and Second Level Address Translation (SLAT).

  • Issues or limitations that have to be considered when virtualizing SharePoint Foundation 2010.

The following four groups of tests, which are documented in this article, are designed to meet the test goals:

  • Comparison of virtual machine and physical computer performance

    These tests show the performance results when the same load is applied to a physical computer and a virtual machine configuration.

  • Virtual machine memory scale up

    These tests show how performance is affected by increasing the memory allocation on a virtual machine (VM).

  • Single host scale out

    These tests show how performance is affected when the number of VMs that are deployed on a single host is increased.

  • Virtual machine scale out

    These tests show how performance is affected when the number of virtual machines that are deployed on one or more hosts is increased.

Important :
When you interpret the results of the previous tests and apply them to your own environment, remember that our tests were conducted on specific hardware that used a specific farm topology and a specific workload.

Hardware platform

Most groups of tests used the following two sets of Hewlett Packard (HP) hardware to host our virtual machines:

  • HP BL680c-G5 (blade server)

  • HP ProLiant SE326M1 (Mach 1 server)

Blade server tests were run for the benefit of customers who are considering repurposing existing server technology for hosting VMs instead of buying new servers.

The Mach 1 server was used to show the performance characteristics of an Intel chipset that supports hyper-threading (Intel Hyper-Threading (HT)). The Mach 1 chipset also supports Intel VT Extended Page Tables (NPT) technology, which Windows Server 2008 R2 Hyper-V can use to implement Second Level Address Translation (SLAT). For more information, see What's New in Hyper-V in Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=155234).

HP blade servers

The following table provides a summary of the hardware which tested SharePoint Foundation on HP blade servers.

Quantity | Manufacturer and model | Role | CPU | Memory | Network adapter | Storage
4 | HP BL680c-G5 | SQL Server database server, Hyper-V host, physical server | Intel X7450 with 24 cores, 2.24 GHz CPU | 128 GB | Dual GbE | SAN
8 | Dell PE R710 | Workload controller, workload client, virtual domain controller | Intel X5550 with 8 cores, 2.66 GHz CPU | 72 GB | Dual GbE | SAS (multiple RAID levels)
1 | F5 BigIP 6800 | Load balancing |  |  |  |

HP Mach 1 servers

The following table provides a summary of the hardware which tested SharePoint Foundation on HP Mach 1 servers.

Quantity | Manufacturer and model | Role | CPU | Memory | Network adapter | Storage
5 | HP ProLiant SE326M1 | SQL Server database server, Hyper-V host, virtual domain controller, physical server | Intel L5520 with 8 cores, 2.26 GHz CPU, HT capable | 48 GB | Dual GbE | SAS (RAID 10)
5 | HP ProLiant DL 380 G5 | Workload controller, workload client | Intel 5150 with 4 cores, 2.66 GHz CPU | 32 GB | Dual GbE | SAS (RAID 10)
1 | F5 BigIP | Load balancing |  |  |  |

Software platform

The 64-bit versions of the following products were used for the performance tests:

  • Windows Server 2008 R2 Enterprise

  • SQL Server 2008 R2 Enterprise

  • Microsoft SharePoint Foundation 2010

  • Microsoft Visual Studio 2008 Team System (VSTS)

  • Microsoft Visual Studio Team System 2008 Test Edition

Test farm topology

The same three-tier farm topology was used on both sets of HP server hardware. This topology was selected because it supports the following general Microsoft SharePoint Foundation roles: front-end Web servers, an application server, and a database server.

Remarque :
The database was hosted on a physical server for all the tests.

Test methodology

The test mix, which is derived from the usage pattern identified on Microsoft internal SharePoint Foundation servers, consisted of the following tasks:

  • Create, use, update, and delete

  • Page views such as list views and document libraries

  • Browser-based views of Word, Excel, and PowerPoint by using Microsoft Office Web Apps

  • Simulated traffic between the server and rich clients such as Microsoft Word 2010, Microsoft Excel 2010, and Microsoft PowerPoint 2010 as an application.

The previous tasks were tested by using 84 separate actions that ranged from .02% of the test mix to 80% of the test mix. Loads were stepped (1 to 10) for different groups of tests and the number of simulated users ranged from 1 to 1000 within a connection-per-user model.

After a warm-up time of 10 minutes, the tests ran for 10 minutes and collected data every 10 seconds.

Two key performance indicators were used for each of the four groups of tests: maximum passed request per second (Max. passed RPS) and the time taken for each request, expressed as milliseconds.

Results of tests

The results of our testing are specific to the hardware and workload that was described previously, and results are not indicative of product performance in all cases. The test results show the potential tradeoffs when you are deciding to virtualize a SharePoint Foundation 2010 configuration with a particular usage pattern. It is very important to interpret our test results in the context of your infrastructure and your implementation of SharePoint Foundation.

Comparison of virtual machine and physical computer performance

These tests show the performance results when the same load is applied to a physical computer and a range of virtual machines.

This group of tests had the following goals:

  • To determine the decrease in performance or gain when virtualizing a physical server

  • To determine the virtual configuration that is required to achieve the same performance level as a physical computer

  • To determine the amount of resource overhead or degree of decreased performance when the workload that is applied to a physical server is tested on a virtual machine.

HP blade server

The physical server is used as a front-end Web server that has 24 cores and 24,576 MB of memory. For the virtual environment, six VMs are used as Web servers on two hosts. Each VM has four virtual processors and 15,000 MB of memory.

Performances de l'ordinateur virtuel et du serveur physique

Notice that the following results on the previous graph:

  • The Max. passed RPS is approximately 20% higher on the physical computer.

  • The Avg. response time (ms) is approximately 15% lower on the physical computer.

  • The Web server CPU usage (%) for the virtual machines is approximately 9% lower than on the physical server.

HP Mach 1 server

The physical server is used as a front-end Web server that has eight cores and 49,152 MB of memory. For the virtual environment, four VMs are used as Web servers on two hosts. Each VM has the configuration shown in the following list.

  • Four virtual processors

  • 8,192 MB of memory

  • Two volumes using fixed size VHD files

The following graph shows performance results for VMs with hyper-threading enabled (HT on), VMs with hyper-threading disabled (HT off), and a physical computer.

Performances de l'ordinateur virtuel et du serveur physique

Notice that the following results on the previous graph:

  • When hyper-threading is enabled (HT on):

    • The Max. passed RPS is approximately 18% higher on the physical computer

    • The Avg. response time (ms) is approximately 15% lower on the physical computer.

    • The Web server CPU usage (%) is approximately 46% lower than a VM with hyper-threading disabled, and approximately 36% lower than the physical computer.

  • When hyper-threading is disabled (HT off):

    • The Max. passed RPS is approximately 29% higher on the physical computer.

    • The Avg. response time (ms) is approximately 20% lower on the physical computer.

Virtual machine memory scale up

In this group of tests, the front-end Web servers are configured to use different amounts of memory to determine how scaling up memory on the VMs affects performance. The test uses four front-end Web servers on two host servers (HP blade server). Each VM is configured to use four virtual processors and two volumes using pass-through disks.

The following graph shows the average response time and requests per second (RPS) for VMs that have a starting configuration of 2,048 megabytes (MB) of RAM and are scaled up to 15,000 MB of RAM.

Résultats des performances de montée en puissance par unité de l'ordinateur virtuel sur des serveurs Blade

The previous graph shows that there is very little variation in CPU usage for the hosts, SQL Server, and the VSTS agent.

From a scale-up perspective, there is a minimal performance gain when scaling from 2 GB of memory to 4 GB of memory. Beyond the 4 GB memory allocation on the virtual machines there is no significant performance gain for the test workload.

Single host scale out

These tests show how performance is affected when the number of VMs is increased on a single host. The tests also show the effect on performance when the host cores are oversubscribed.

HP blade server

This test uses up to eight VMs and each VM has the configuration shown in the following list.

  • Four virtual processors

  • 15,000 MB of memory

  • Two volumes using pass-through disks

The following graph shows that optimal throughput is achieved by using six front-end Web servers, which is a 1:1 mapping of logical processors to virtual processors. When more VMs are added, performance decreases. The only observed bottleneck is CPU contention when the CPU is oversubscribed.

Résultats des performances de montée en puissance parallèle d'un seul hôte

The test mix used on the HP blade servers was then run two times on the Mach 1 servers. On the first run hyper-threading was enabled, and on the second run hyper-threading was disabled.

HP Mach 1 server

The test uses up to four VMs and each VM has the configuration shown in the following list.

  • Four virtual processors

  • 8,192 MB of memory

  • Two volumes using fixed size VHD files

The following graph shows performance results when hyper-threading is enabled on the host.

Résultats des performances de montée en puissance parallèle pour un seul hôte

The following graph shows performance results when hyper-threading is disabled.

Résultats des performances de montée en puissance parallèle pour un seul hôte

The two previous graphs indicate that there is no need to oversubscribe the host CPU because there is no significant performance gain or loss.

Another key outcome of these tests is the increase in compute headroom, which is indicated by "Web server host logical CPU usage". By comparing this value in both graphs you can see that the increase in compute capacity ranges from 10% to 25% depending on the level of CPU oversubscription.

Virtual machine scale out

This group of tests shows the effect on performance when the number of virtual machines is scaled out across hosts and bottlenecks are identified. In addition, virtual machine roles are mixed to determine the effect on performance.

Résultats des performances de montée en charge parallèle de l'ordinateur virtuel

The test uses a range of host servers (2-3) and a range of virtual machines (6-12) deployed across the hosts. Each VM has the configuration shown in the following list.

  • Two virtual processors

  • 15,000 MB of memory

  • Two volumes using pass-through disks

The following graph shows performance when virtual machines are scaled out.

Résultats des performances de montée en charge parallèle de l'ordinateur virtuel

Notice that the following results on the previous graphs:

  • With dedicated roles for the virtual machines, the performance gain is noticeable when the number of hosts and the number of VMs is scaled up to three hosts with 12 VMs. Using Max. passed RPS as a benchmark, performance is approximately 2.5 times better. However, the average response time per request degrades as indicated by the approximately 26% increase in response time.

  • With mixed roles for the virtual machines and using the number of hosts and the same number of VMs, Max. passed RPS improves by approximately 31%. Additionally, the Avg. response time (ms) is improved, as indicated by the drop of approximately 25%. Typically there is a lower duty cycle on an application server, which enables Hyper-V to use the additional resources for other VMs that are running on the host.

An additional performance observation is that there was a significant increase in SQL Server CPU usage when the tests were run with mixed virtual machine roles. This increase was approximately 35%.

HP Mach 1 server

The test uses a range of host servers (2-4) and a range of virtual machines (3-9) deployed across the hosts. Each VM has the configuration shown in the following list.

  • Four virtual processors

  • 8,192 MB of memory

  • Two volumes using fixed size VHD files

The following graph shows performance with hyper-threading enabled on the host.

Résultats des performances de montée en charge parallèle de l'ordinateur virtuel

Notice the following results on the previous graph:

  • With dedicated virtual machine roles, the performance gain is noticeable when the number of hosts and the number of VMs are scaled up to three hosts with six VMs. Using Max. passed RPS as a benchmark, performance is approximately 42% better and the average response time per request decreases by approximately 21%.

  • When the number of hosts and number of virtual machines is scaled up again to four hosts and nine virtual machines, Max. passed RPS improves by approximately 57% compared to the three host and six VM configuration. Compared to the HP blade servers the Avg. response time (ms) only increases by approximately 4%.

  • SQL Server CPU usage (%) follows the same pattern as on the HP blade servers, increasing linearly to 41%.

Conclusions and recommendations

The following table summarizes the conclusions drawn from our tests which are based on a specific workload, the hardware that was used, and the virtual machines used.

Group of tests | Host hardware | Conclusions
Comparison of virtual machine and physical computer performance | HP blade server | The performance gain on a physical computer is 15% (RPS) and 42% (response time per request).
 | HP Mach 1 server | The performance gain on a physical computer is approximately 15% (RPS) and 18% (response time per request).
Virtual machine memory scale up | HP blade server | There is no benefit to additional memory allocation beyond 4 GB for a virtual machine.
Single host scale out | HP blade server | A 1:1 ratio of logical processors to virtual processors produces the maximum throughput. Oversubscribing the CPU deteriorates performance.
 | HP Mach 1 server | This hardware can support oversubscribing the CPU without a significant performance penalty. The amount of compute headroom is determined by the level of CPU oversubscription.
Virtual machine scale out | HP blade server | Microsoft SharePoint Foundation 2010 scales linearly to at least three hosts and 12 virtual front-end Web servers. Maximum throughput is achieved by mixing Microsoft SharePoint Foundation roles on each host.
 | HP Mach 1 server | Microsoft SharePoint Foundation 2010 scales linearly to at least four hosts and nine virtual front-end Web servers.

In our test environment we observed a decline in performance when SharePoint Foundation roles are virtualized. This is the result of Hyper-V overhead as well as operating system overhead on each virtual machine.

The amount of virtualization overhead and reduced performance (relative to a similarly configured physical computer) depends on the size (for example, the amount of memory, and the number of cores) as well as the features of the host hardware chipset (for example, support for Second Level Address Translation and hyper-threading.)

We recommend that you clearly understand what you hope to gain by virtualizing all or some of a SharePoint farm. After the decision to virtualize is made, thorough planning and testing is required to fully understand all performance options and implications.

You can use the results of tests in this article as a guide. However, results are not definitive and the results are for a specific workload in a specific physical environment.

Historique des modifications

Date | Description | Raison
18 novembre 2010 | Publication initiale |


Résultats des tests de performances et de capacité et recommandations (SharePoint Foundation 2010)
Voir aussi

Cette section contient une série de livres blancs qui décrivent l'impact des jeux de fonctionnalités spécifiques inclus dans Microsoft SharePoint Foundation 2010 sur les performances et la capacité. Ces livres blancs comprennent des informations sur les caractéristiques de la fonctionnalité en termes de performances et de capacité et sur la façon dont la fonctionnalité a été testée par Microsoft. Ces informations abordent les points suivants :

  • caractéristiques de la batterie de serveurs de test ;

  • résultats des tests ;

  • recommandations ;

  • résolution des problèmes de performances et d'évolutivité.

Le tableau suivant décrit le livre blanc disponible. Vous pouvez télécharger le livre blanc sous la forme d'un document Microsoft Word (.doc) (éventuellement en anglais).

Titre | Description
Planification de la capacité de la recherche dans SharePoint Foundation 2010 | Fournit de l'aide sur la planification de la recherche dans SharePoint Foundation 2010.

Voir aussi

Autres ressources

Capacity management and sizing for SharePoint Server 2010

Historique des modifications

Date | Description | Raison
2011/01/31 | Publication initiale |


Forefront UAG integration (SharePoint Foundation 2010)

Information technology (IT) professionals who manage websites that use Microsoft SharePoint Foundation 2010 may want to make them available to users who are outside of their corporate network. This concept is referred to as publishing, and this is made possible by using edge protection software such as Microsoft Forefront Unified Access Gateway 2010 (UAG).

Publishing SharePoint Sites with UAG

The following articles contain procedures that are required to publish SharePoint websites through Forefront UAG.

  • SharePoint publishing solution guide (http://go.microsoft.com/fwlink/?LinkId=206256)

    Intended for system administrators who are responsible for publishing SharePoint websites for extranet users.

  • Publishing SharePoint Workspace Mobile on Forefront UAG (http://go.microsoft.com/fwlink/?LinkId=206257)

    Describes how to publish the SharePoint 2010 mobile workspace for extranet users.

Historique des modifications

Date | Description | Raison
2011/01/31 | Publication initiale |


Feuilles de planification pour SharePoint Foundation 2010

Dans cet article :

  • Feuilles de planification par tâche

  • Feuilles de planification par titre

Cet article fournit des liens vers des feuilles que vous pouvez utiliser pour enregistrer les informations que vous rassemblez et les décisions que vous prenez lorsque vous planifiez votre déploiement de Microsoft SharePoint Foundation 2010. Utilisez ces feuilles conjointement avec (et non en remplacement de) Planification et architecture pour SharePoint Foundation 2010.

Feuilles de planification par tâche

Pour cette tâche | Utilisez cette feuille | Pour effectuer cette action
Planifier les sites et les collections de sites (SharePoint Foundation 2010) | Feuille relative aux données sur la planification du site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167838&clcid=0x40C) | Planifiez des collections de sites et des sites de niveau supérieur. Enregistrez des décisions sur les thèmes et la navigation des sites.
Planifier la navigation sur les sites (SharePoint Foundation 2010) | Feuille relative aux données sur la planification du site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167838&clcid=0x40C) | Planifiez des collections de sites et des sites de niveau supérieur. Enregistrez des décisions sur les thèmes et la navigation des sites.
Planifier l'utilisation des thèmes (SharePoint Foundation 2010) | Feuille relative aux données sur la planification du site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167838&clcid=0x40C) | Planifiez les sites et collections de sites de niveau supérieur et enregistrez les décisions relatives à la navigation et aux thèmes de site.
Planification du courrier électronique entrant (SharePoint Foundation 2010) | Feuille de travail de planification de courrier entrant (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=200542&clcid=0x40C) | Planifiez le courrier entrant afin de permettre aux sites SharePoint de recevoir et de stocker des messages électroniques et des pièces jointes dans des listes et des bibliothèques.
Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) | Classeur de planification de sauvegarde et de récupération (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=184385&clcid=0x40C) | Vous aide à planifier des stratégies de sauvegarde et de récupération pour l'environnement SharePoint Foundation 2010.
Planifier et préparer la mise à niveau (SharePoint Foundation 2010) | Feuille relative à la mise à niveau (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C) | Enregistrez des informations sur votre environnement lors de la préparation de la mise à niveau.

Feuilles de planification par titre

Utilisez cette feuille | Pour cette tâche | Pour effectuer cette action
Classeur de planification de sauvegarde et de récupération (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=184385&clcid=0x40C) | Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) | Vous aide à planifier des stratégies de sauvegarde et de récupération pour l'environnement SharePoint Foundation 2010.
Feuille de travail de planification de courrier entrant (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=200542&clcid=0x40C) | Planification du courrier électronique entrant (SharePoint Foundation 2010) | Planifiez le courrier entrant afin de permettre aux sites SharePoint de recevoir et de stocker des messages électroniques et des pièces jointes dans des listes et des bibliothèques.
Feuille relative aux données sur la planification du site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167838&clcid=0x40C) | Planifier les sites et les collections de sites (SharePoint Foundation 2010) Planifier la navigation sur les sites (SharePoint Foundation 2010) Planifier l'utilisation des thèmes (SharePoint Foundation 2010) | Planifiez des collections de sites et des sites de niveau supérieur. Enregistrez des décisions sur les thèmes et la navigation des sites.
Feuille relative à la mise à niveau (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C) | Planifier et préparer la mise à niveau (SharePoint Foundation 2010) | Enregistrez des informations sur votre environnement lors de la préparation de la mise à niveau.

Historique des modifications

Date | Description | Raison
27 août 2010 | 2010/08/23 | Mise à jour du contenu


Développement pour SharePoint Foundation 2010

Cet article fournit des liens vers du contenu pour les développeurs dans le Centre des développeurs MSDN.

Voir le Centre des développeurs pour Microsoft SharePoint Foundation 2010 à l'adresse http://go.microsoft.com/fwlink/?linkid=159918&clcid=0x40C (éventuellement en anglais).

Historique des modifications


Déploiement pour SharePoint Foundation 2010

Bienvenue dans le guide de déploiement de Microsoft SharePoint Foundation 2010. Les articles de ce guide vous aident à préparer l'installation de SharePoint Foundation 2010, ainsi qu'à installer et à configurer celui-ci. Le guide de déploiement comprend des informations sur les scénarios de déploiement, des instructions d'installation pas à pas et des étapes de configuration post-installation. En outre, il explique comment effectuer une mise à niveau vers SharePoint Foundation 2010.

Avant d'installer SharePoint Foundation 2010, veillez à consulter les informations disponibles dans la rubrique Planification et architecture pour SharePoint Foundation 2010.

Pour une représentation graphique du processus de déploiement, téléchargez le modèle de déploiement des produits SharePoint 2010 à partir de l'article Diagrammes techniques (SharePoint Foundation 2010).

Dans cette section :

  • Vue d'ensemble du déploiement (SharePoint Foundation 2010)

    Cet article fournit des informations sur le déploiement de SharePoint Foundation 2010. Cet article a pour objectif de vous donner les informations dont vous avez besoin pour prendre les décisions essentielles avec votre équipe concernant le déploiement des solutions basées sur SharePoint Foundation 2010 dans votre organisation.

  • Éléments prérequis à l'installation depuis un partage réseau (SharePoint Foundation 2010)

    Cet article explique comment utiliser le fichier PrerequisiteInstaller.exe pour installer des éléments prérequis à partir d'un partage réseau, de manière à bénéficier d'un déploiement plus cohérent.

  • Préparer le déploiement (SharePoint Foundation 2010)

    Cette section fournit les étapes essentielles à effectuer avant de déployer Microsoft SharePoint Foundation 2010.

  • Scénarios de déploiement (SharePoint Foundation 2010)

    Suivez les étapes de cette section pour déployer un serveur unique ou une batterie de serveurs avec SharePoint Foundation 2010 ou pour déployer Office Web Apps pour une utilisation avec SharePoint Foundation 2010.

  • Configuration initiale (SharePoint Foundation 2010)

    Suivez les étapes de cette section pour installer des modules linguistiques, configurer des paramètres et des services de batterie de serveurs et créer des collections de sites.

  • Déployer des personnalisations - Vue d'ensemble (SharePoint Foundation 2010)

    Les articles de cette section décrivent comment déployer des éléments de site qui ont été personnalisés par des développeurs ou des concepteurs de sites Web dans un environnement SharePoint Foundation 2010.

  • Deploy software updates for SharePoint Foundation 2010 (en anglais)

    Microsoft publie régulièrement des mises à jour logicielles pour SharePoint Foundation 2010. Suivez les étapes fournies dans cette section pour appliquer ces mises à jour à vos serveurs SharePoint Foundation.

  • Mise à niveau vers SharePoint Foundation 2010

    Suivez les étapes du guide de mise à niveau pour planifier, préparer et effectuer une mise à niveau vers SharePoint Foundation 2010.

Remarque :
Si vous prévoyez d'utiliser Office Web Apps, vous devez l'installer et le configurer de façon à opérer avec Produits SharePoint 2010. Pour plus d'informations, voir Déployer Office Web Apps (installé sur les produits SharePoint 2010).

Historique des modifications


Vue d'ensemble du déploiement (SharePoint Foundation 2010)

Cet article fournit une vue d'ensemble du déploiement de batterie Microsoft SharePoint Foundation 2010. Bien que les batteries Microsoft SharePoint Foundation varient en termes de complexité et de taille, une planification soignée alliée à un déploiement par phase incluant une évaluation et des tests continus réduit sensiblement le risque de rencontrer des résultats inattendus.

Remarque :
Pour plus d'informations sur la planification de site et de solution, qui ne constitue pas le sujet de cet article, voir Planification de sites et de solutions (SharePoint Foundation 2010).

Pour une représentation visuelle des informations fournies dans cet article, voir le modèle de déploiement des Produits SharePoint 2010 dans la rubrique Diagrammes techniques (SharePoint Foundation 2010).

Dans cet article :

  • Concepts

  • Architecture physique

  • Installation et configuration

  • Phases de déploiement

Concepts

Le résultat logique de la flexibilité et de la richesse de SharePoint Foundation est le haut degré de complexité lié à l'installation et à la configuration correctes de SharePoint Foundation. Une compréhension fondamentale des éléments structurels clés suivants dans un environnement SharePoint Foundation est nécessaire afin de déployer et prendre en charge correctement les produits SharePoint Foundation 2010 :

  • Batterie de serveurs : élément de niveau supérieur d'une conception d'architecture logique pour SharePoint Foundation.

  • Application Web : site Web IIS créé et utilisé par SharePoint Foundation 2010.

  • Base de données de contenu : fournit le stockage du contenu des applications Web. Vous pouvez séparer le contenu en plusieurs bases de données de contenu au niveau de la collection de sites.

  • Collection de sites : ensemble de sites Web qui ont le même propriétaire et partagent des paramètres d'administration.

  • Site : une ou plusieurs pages Web associées et autres éléments (tels que des listes, bibliothèques et documents) hébergés dans une collection de sites.

En plus de la compréhension des éléments d'un environnement SharePoint Foundation et de la façon dont il faut les configurer pour votre solution, vous devez prendre en compte les facteurs suivants : architecture physique, installation et configuration, ainsi que les différentes phases du déploiement.

Architecture physique

L'architecture physique, qui se compose d'un ou plusieurs serveurs et de l'infrastructure réseau, vous permet d'implémenter l'architecture logique d'une solution SharePoint Foundation. On décrit généralement l'architecture physique selon deux critères : sa taille et sa topologie. La taille, qui peut être mesurée de plusieurs manières (par exemple d'après le nombre d'utilisateurs ou de documents) sert à catégoriser une batterie comme petite, moyenne ou grande. La topologie utilise la notion de couche ou de groupe de serveurs pour définir une organisation logique de batterie de serveurs.

Taille

La taille utilise le nombre d'utilisateurs et le nombre d'éléments de contenu en guise de mesure fondamentale pour indiquer si une batterie de serveurs est petite, moyenne ou grande, de la manière suivante :

  • Une batterie de serveurs de petite taille se compose généralement d'au moins deux serveurs Web et d'un serveur de bases de données. L'un des serveurs Web héberge le site Administration centrale et les autres gèrent les tâches supplémentaires liées à la batterie de serveurs, telles que la fourniture du contenu aux utilisateurs.

    La petite batterie peut être étendue à trois couches à l'aide d'un serveur d'applications dédié en réponse au nombre d'utilisateurs, au nombre d'éléments de contenu et au nombre de service requis.

  • Une batterie de serveurs moyenne est généralement constituée de plusieurs serveurs Web, de deux serveurs d'applications et de plusieurs serveurs de bases de données. Nous vous recommandons de commencer par la configuration précédente, puis de monter en puissance en fonction de la charge de travail placée sur les serveurs.

    Dans les scénarios dans lesquels des services utilisent une quantité de ressources disproportionnée, vous pouvez faire monter en puissance la couche d'application. Les données de performances indiqueront les services dont la charge doit être transférée vers un serveur dédié.

  • Une grande batterie de serveurs peut être la conséquence logique de la montée en puissance d'une batterie moyenne visant à répondre à des exigences de capacité et de performances ou peut être voulue par la conception avant qu'une solution SharePoint Foundation soit implémentée. Un environnement à topologie en trois couches utilise généralement des serveurs dédiés sur toutes les couches. De plus, ces serveurs sont souvent groupés en fonction de leur rôle dans la batterie. Par exemple, tous les services liés aux clients peuvent être groupés sur un ou deux serveurs, puis étendus grâce à l'ajout de serveurs à ce groupe en réponse à la demande des utilisateurs.

    Remarque :
    La recommandation en ce qui concerne la montée en puissance d'une batterie consiste à grouper les services ou bases de données ayant des caractéristiques de performances similaires sur des serveurs dédiés, puis à faire monter les serveurs en puissance en tant que groupe. Dans les environnements à grande échelle, les groupes spécifiques qui évoluent pour une batterie varient en fonction des demandes spécifiques pour chaque service de la batterie.

Pour plus d'informations sur les chiffres spécifiques liés aux petites, moyennes et grandes batteries, voir Performance and capacity management (SharePoint Server 2010).

Topologie

La topologie utilise des niveaux comme modèle d'organisation logique des serveurs de la batterie en fonction des composants qu'ils hébergent ou de leurs rôles dans une batterie. Une batterie SharePoint Foundation est déployée sur un, deux ou trois niveaux :

  • Dans un déploiement sur un seul niveau, SharePoint Foundation et le serveur de bases de données sont installés sur un seul ordinateur.

  • Dans un déploiement sur deux niveaux, les composants SharePoint Foundation et la base de données sont installés sur des serveurs distincts. Ce type de déploiement correspond à ce que l'on appelle une petite batterie de serveurs. Les serveurs Web frontaux sont sur le premier niveau et le serveur de bases de données sur le deuxième niveau. Dans l'industrie informatique, le premier niveau est communément appelé niveau Web. Le serveur de bases de données est appelé niveau base de données ou système dorsal de base de données.

  • Dans un déploiement sur trois niveaux, les serveurs Web frontaux sont sur le premier niveau, les serveurs d'applications sur le deuxième niveau, qui est communément appelé niveau application, et le serveur de bases de données se trouve sur le troisième niveau. Un déploiement sur trois niveaux est utilisé pour les moyennes et grandes batteries de serveurs.

Installation et configuration

Une fois la planification de votre solution SharePoint Foundation terminée, vous pouvez créer une batterie SharePoint Foundation pour héberger la solution. La première étape consiste à installer SharePoint Foundation 2010 et à créer la batterie requise pour la solution. Le processus de préparation de l'environnement comporte les phases suivantes :

  1. préparer les serveurs ;

  2. créer la batterie ;

  3. configurer les paramètres, les services, les solutions et les sites.

Remarque :
La batterie que vous créez et déployez subira d'importantes modifications en termes de taille, de topologie et de complexité au fil des différentes phases de déploiement illustrées dans le modèle Déploiement de produits SharePoint 2010. Ceci est tout à fait normal et la conséquence attendue d'un déploiement par phases. C'est pourquoi nous vous recommandons de respecter toutes les phases décrites dans la section « Phases de déploiement » de cet article.

Préparer les serveurs

Durant cette phase, vous préparez vos serveurs à héberger le produit. Cela comprend les serveurs de prise en charge et ceux sur lesquels SharePoint Foundation sera installé. Les serveurs suivants doivent être configurés de façon à prendre en charge et à héberger une batterie :

  • Contrôleur de domaine : les comptes de batterie requis doivent être configurés pour le domaine et la synchronisation d'annuaires doit être configurée.

    Important :
    SharePoint Foundation 2010 ne prend pas en charge les noms SLD (Single Label Domain). L'utilisation de noms SLD n'étant pas une pratique recommandée, les Produits SharePoint 2010 ne sont pas testés de manière approfondie dans ce scénario. Par conséquent, il peut y avoir des problèmes d'incompatibilité lorsque les Produits SharePoint 2010 sont implémentés dans un environnement SLD. Pour plus d'informations, voir Informations sur la configuration des domaines Active Directory à l'aide de noms DNS en une seule partie (http://go.microsoft.com/fwlink/?linkid=193849&clcid=0x40C) and the Centre de solutions pour la planification de l'espace de noms DNS (http://go.microsoft.com/fwlink/?linkid=198010&clcid=0x40C).

    Pour plus d'informations sur les comptes requis, voir :

    • Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010)

    • À propos de la synchronisation d'annuaires (http://go.microsoft.com/fwlink/?linkid=193169&clcid=0x40C)

  • Serveur de bases de données : la version requise de SQL Server, y compris les Service Packs et mises à jour cumulatives, doit être installée sur le serveur de bases de données. L'installation doit comprendre les éventuelles fonctionnalités supplémentaires, telles que SQL Analysis Services, et les connexions SharePoint Foundation appropriées doivent être ajoutées et configurées. Le serveur de bases de données doit être endurci et, si nécessaire, les bases de données doivent être créées par l'Administrateur de base de données. Pour plus d'informations, voir :

    • Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

    • Sécuriser SQL Server pour les environnements SharePoint (SharePoint Foundation 2010)

    • Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010)

  • Serveurs d'applications et serveurs Web frontaux : les serveurs de batterie sur lesquels SharePoint Foundation sera installé doivent être préparés comme suit : vérifiez qu'ils disposent de la configuration matérielle requise, que leur système d'exploitation est renforcé, que les protocoles de mise en réseau et de sécurité requis sont configurés, que les composants logiciels requis SharePoint Foundation 2010 sont installés et renforcés et que l'authentification est configurée. Pour plus d'informations, voir :

    • Configuration système requise (SharePoint Foundation 2010)

    • « Installation des logiciels prérequis » dans Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

    • Planifier le renforcement de la sécurité (SharePoint Foundation 2010)

    • Planifier l'authentification (SharePoint Foundation 2010)

Créer la batterie

Durant cette phase, vous installez le produit et vous configurez chaque serveur de sorte qu'il prenne en charge son rôle dans la batterie. Vous créez également la base de données de configuration et le site Web Administration centrale de SharePoint. Les serveurs suivants sont nécessaires pour une batterie SharePoint Foundation :

  • Serveur de bases de données : à moins que vous n'envisagiez d'utiliser des bases de données créées par l'Administrateur de base de données, la base de données de configuration, la base de données de contenu et d'autres bases de données requises sont créées lorsque vous exécutez l'Assistant Configuration des produits SharePoint.

  • Serveur d'applications : après avoir préparé le serveur d'applications, installez les éventuels composants supplémentaires nécessaires à la prise en charge de fonctions telles que la Gestion des droits relatifs à l'information et l'aide à la décision. Installez SharePoint Foundation sur le serveur qui hébergera le site Web Administration centrale de SharePoint, puis exécutez l'Assistant Configuration des produits SharePoint pour créer et configurer la batterie.

  • Serveur Web frontal : installez SharePoint Foundation sur chaque serveur Web, installez les modules linguistiques, puis exécutez l'Assistant Configuration des produits SharePoint pour ajouter les serveurs Web à la batterie.

    Remarque :
    Après avoir ajouté et configuré tous les serveurs Web frontaux, vous pouvez ajouter des serveurs d'applications supplémentaires qui font partie de votre conception de topologie à la batterie.

Pour plus d'informations sur les scénarios de déploiement pris en charge, voir Scénarios de déploiement (SharePoint Foundation 2010).

Configurer les paramètres, les services, les solutions et les sites

Durant cette phase, vous préparez la batterie à héberger votre contenu de site en effectuant les tâches suivantes :

  • Configurer les paramètres globaux. Pour plus d'informations, voir Configurer les paramètres de la batterie de serveurs (SharePoint Foundation 2010)

  • Configurer les services. Pour plus d'informations, voir Configurer les services (SharePoint Foundation 2010)

  • Déployer les solutions et les personnalisations. Pour plus d'informations, voir Déployer des personnalisations - Vue d'ensemble (SharePoint Foundation 2010)

  • Créer et remplir les sites. Pour plus d'informations, voir Préparer l'hébergement de sites (SharePoint Foundation 2010)

Remarque :
Les étapes de configuration de la batterie ne sont pas spécifiques à une couche particulière dans l'infrastructure de serveur.

Phases de déploiement

Le déploiement d'une solution SharePoint Foundation 2010 par phases vous permet de bénéficier des avantages offerts par une approche systématique, tels que la collecte de données d'utilisation et de performances qui peuvent vous servir à évaluer votre solution, la vérification de vos suppositions en matière de gestion de la capacité et l'identification des problèmes avant la mise en production de la batterie.

Nous vous recommandons de déployer votre batterie selon les phases suivantes :

  • Planification

  • Développement

  • Preuve de concept (POC, Proof of concept)

  • Pilote

  • Test d'acceptation des utilisateurs (UAT, User Acceptance Test)

  • Production

Planification

Avant de pouvoir déployer une batterie, vous devez planifier la solution que vous souhaitez déployer et déterminer les exigences d'infrastructure, telles que les ressources de serveur et la topologie de batterie. À l'issue de la phase de planification, vous devez avoir documenté les éléments suivants :

  • Une conception de l'infrastructure pour la prise en charge de votre solution

  • Une description détaillée de la manière dont vous allez implémenter la batterie et la solution

  • Un plan pour tester et valider la solution

  • Une architecture de site et de solution

  • Une bonne compréhension des exigences techniques constantes et de la surveillance pour la prise en charge de la solution

  • Un dossier sur la façon dont la solution sera administrée

  • Une bonne compréhension de la façon de communiquer la solution auprès des utilisateurs afin de favoriser son adoption

Nous vous recommandons d'utiliser les articles et ressources de planification décrits dans Planification et architecture pour SharePoint Foundation 2010.

Important :
Des problèmes de ressources et de temps peuvent vous inciter à moins de rigueur durant la phase de planification. Il est recommandé d'être aussi méthodique que possible dans la mesure où des éléments de planification manquants ou abordés à la légère peuvent devenir des problèmes importants durant la phase de production. Ces problèmes peuvent provoquer beaucoup de travail supplémentaire, consommer des ressources non prévues au budget et nuire à la réussite de votre solution SharePoint Foundation.

À l'issue de la phase de planification, vous passez aux phases de déploiement suivantes, en mettant à jour et en réévaluant vos plans, configurations et topologies à mesure que vous effectuez des tests.

Développement

Durant la phase de développement, vous allez déployer SharePoint Foundation sur un ou plusieurs serveurs afin de développer, tester, évaluer et affiner la solution que vous prévoyez d'implémenter. L'étendue de cet environnement est adaptée à vos besoins durant le développement de solution et vous pouvez le conserver en guise d'environnement réduit à des fins de développement et de test ultérieurs. Cet environnement n'est pas stable et n'inclut aucun contrat de niveau de service.

Preuve de concept (POC, Proof of concept)

Pendant la phase de preuve de concept, l'objectif est double : comprendre SharePoint Foundation et évaluer SharePoint Foundation dans sa façon de répondre aux besoins de votre entreprise. Le premier niveau d'évaluation du produit peut être réalisé en installant tous les composants du produit sur un seul serveur. Votre évaluation du produit sera davantage poussée avec un déploiement probatoire.

Un déploiement probatoire sur un seul serveur ou sur une petite batterie de serveurs vous permet d'élargir la portée de votre évaluation. Dans ce déploiement, du personnel non informatique vient compléter l'équipe d'évaluation, ce qui donne une vision élargie de la façon dont les fonctionnalités de SharePoint Foundation pourraient être utilisées dans l'organisation. L'avantage d'un tel déploiement est la collecte de données qui peuvent servir à affiner votre plan initial. Ces données, comme les affichages de page, les modèles de comportement utilisateur et la consommation des ressources serveur, vous permettent par ailleurs de commencer à élaborer un test de performances en vue de dimensionner votre batterie de serveurs. Un déploiement probatoire permet également d'évaluer les applications de service et de déterminer les jeux de fonctionnalités à offrir à vos utilisateurs finaux.

Au cours de la phase de preuve de concept, il est important que vous compreniez les caractéristiques et les fonctionnalités uniques de ces fonctions, car cela vous permettra de définir votre topologie générale. Gardez à l'esprit qu'un déploiement preuve de concept nécessite des ressources supplémentaires et allonge le temps nécessaire à la mise en production de SharePoint Foundation.

Conseil :
La virtualisation offre une bonne plateforme pour évaluer SharePoint Foundation car un environnement virtuel offre davantage de souplesse, une capacité de déploiement rapide et la possibilité de revenir aux états précédents des ordinateurs virtuels.

Pilote

Un pilote sert à tester votre solution à petite échelle. L'utilisation d'un déploiement pilote peut s'effectuer selon deux approches. La première met l'accent sur les tests fonctionnels sans utilisation de données réelles. Avec la seconde approche, vous testez des caractéristiques de production à l'aide de données réelles et vous faites en sorte que vos utilisateurs pilotes testent différents types de tâches. Nous vous recommandons d'adopter la seconde approche, du fait de sa plus grande portée et des données du monde réel que vous pouvez recueillir et utiliser en vue d'affiner la conception de votre solution.

Un déploiement pilote offre de nombreux avantages. Il vous permet de recueillir des données afin de valider les aspects suivants de la conception de votre batterie :

  • conception de l'infrastructure ;

  • suppositions en matière de gestion de la capacité ;

  • architecture de site et de solution ;

  • suppositions en matière d'utilisation de la solution.

La phase pilote vous permet également de déterminer les données supplémentaires qui doivent être recueillies afin d'accroître l'étendue et la profondeur de vos bancs d'essai. Ceci est important si vous souhaitez évaluer l'impact potentiel de services ou fonctionnalités supplémentaires que vous souhaitez ajouter à la batterie avant le test d'acceptation des utilisateurs.

À l'issue du déploiement pilote, vous pouvez utiliser les données recueillies pour ajuster les différents composants de la solution et son infrastructure sous-jacente.

Test d'acceptation des utilisateurs (UAT, User Acceptance Test)

Les organisations font appel à un déploiement de test d'acceptation des utilisateurs (également appelé environnement de préproduction) en guise d'étape de transition entre le déploiement pilote et le déploiement de production. Ce sont les processus d'entreprise de l'organisation qui déterminent l'étendue, la portée et la durée des tests d'acceptation des utilisateurs.

La topologie de l'environnement de préproduction doit être identique (ou presque) à la topologie de production planifiée. Durant les tests d'acceptation des utilisateurs, la solution SharePoint Foundation est testée par rapport à un sous-ensemble ou à une copie complète des données de production. Cette phase de déploiement fournit une dernière opportunité d'affiner les performances et de valider les procédures opérationnelles telles que sauvegardes et restaurations.

Production

L'étape finale consiste à déployer votre batterie dans un environnement de production. À ce stade, vous aurez incorporé les réglages d'infrastructure et de solution nécessaires identifiés lors de la phase de test d'acceptation des utilisateurs.

La mise en production de la batterie nécessite d'effectuer les tâches suivantes :

  • déployer la batterie ;

  • déployer la solution ;

  • implémenter le plan des opérations ;

  • si nécessaire, déployer des environnements supplémentaires tels que des batteries intermédiaires et de création, ainsi que des batteries de services.

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Éléments prérequis à l'installation depuis un partage réseau (SharePoint Foundation 2010)

Cet article explique comment installer les composants requis pour Microsoft SharePoint Foundation 2010 à partir d'un emplacement réseau partagé hors connexion à l'aide de l'outil d'installation des composants requis (PrerequisiteInstaller.exe).

L'installation des composants requis à partir d'un emplacement hors connexion est généralement nécessaire lorsque les serveurs sur lesquels Microsoft SharePoint Foundation doit être installé sont isolés d'Internet. Même si ce n'est pas le cas, l'installation des composants requis à partir d'un emplacement central hors connexion est pour vous une assurance de cohérence au niveau de la batterie de serveurs du fait de l'installation d'un jeu d'images parfaitement connu et contrôlé.

Remarque :
L'Outil de préparation des produits Microsoft SharePoint est une interface utilisateur qui repose sur PrerequisiteInstaller.exe. L'Outil de préparation des produits Microsoft SharePoint n'accepte aucune entrée utilisateur.

Dans cet article :

  • Commutateurs et arguments du programme d'installation

  • Télécharger et regrouper les composants requis sur un partage de fichiers

  • Installer les composants requis depuis la ligne de commande

  • Installer les composants requis à l'aide d'un fichier d'arguments

  • Problèmes connus

Commutateurs et arguments du programme d'installation

En utilisant PrerequisiteInstaller.exe avec des commutateurs et des arguments, vous pouvez savoir quelles versions des logiciels requis sont installées, ainsi que l'emplacement à partir duquel elles le sont.

PrequisiteInstaller.exe accepte une ou plusieurs paires de commutateur et d'argument. Si le commutateur identifie le composant requis, l'argument en spécifie l'action et l'emplacement.

Une paire de commutateur et d'argument se présente sous la forme suivante :

/switch: <chemin_accès>

Où :

  • /switch représente un commutateur valide destiné à identifier un composant requis. Par exemple, /NETFX35SP1: est le commutateur qui représente .NET Framework 3.5 Service Pack 1.

  • <chemin_accès> représente le chemin d'accès à un fichier local ou à un partage de fichiers, par exemple, « C:\nom_dossier\dotnetfx35.exe » ou « \\<nom_serveur>\<nom_partage>\dotnetfx35.exe ».

Chaque commutateur et son argument sont séparés par un signe deux-points et un espace. L'argument est mis entre guillemets droits.

Les paires de commutateur et d'argument peuvent être transmises à l'outil PrerequisiteInstaller.exe à l'invite de commandes ou lu à partir d'un fichier texte d'arguments.

Télécharger et regrouper les composants requis sur un partage de fichiers

Le processus de téléchargement et de regroupement des composants requis consiste dans les étapes décrites dans les procédures suivantes.

Pour identifier les composants requis

  1. Reportez-vous à l'article Configuration matérielle et logicielle requise (SharePoint Foundation 2010), qui dresse la liste de tous les logiciels obligatoires et facultatifs pour SharePoint Foundation 2010. En outre, ce document indique l'adresse de téléchargement de chaque composant requis disponible en téléchargement sur Internet.

  2. À l'invite de commandes, accédez à la racine du support d'installation ou à l'emplacement du dossier de SharePoint Foundation 2010.

  3. À l'invite de commandes, tapez PrerequisiteInstaller.exe /?. Vous obtenez la liste des options de ligne de commande, des commutateurs et des arguments correspondants pour installer un composant requis depuis la ligne de commande.

    Conseil :
    Pour copier le contenu de la fenêtre À propos de active dans le Presse-papiers, appuyez sur Ctrl+C.

  4. Assurez-vous de la précision de la liste des logiciels requis. Comparez la sortie du programme d'installation des composants requis à la liste des composants requis de l'étape 1.

  5. Téléchargez les composants requis sur un ordinateur ayant accès à Internet.

Ensuite, exécutez la procédure suivante pour créer un emplacement central que vous utiliserez pour installer les composant requis pour SharePoint Foundation sur tous les serveurs de la batterie.

Pour regrouper les composants requis

  1. Créez un dossier partagé sur un ordinateur accessible aux serveurs sur lesquels les composants requis seront installés.

  2. Copiez les fichiers que vous avez téléchargés sur Internet dans le dossier partagé.

Après avoir créé un emplacement réseau accessible pour les composants requis, exécutez la procédure décrite dans la section suivante pour installer les composants requis pour SharePoint Foundation 2010 sur un serveur.

Installer les composants requis depuis la ligne de commande

Vous pouvez installer un ou tous les composants requis depuis la ligne de commande en exécutant la procédure suivante.

Pour installer depuis la ligne de commande

  1. À partir du menu Démarrer, ouvrez la fenêtre d'invite de commandes en utilisant l'option Exécuter en tant qu'administrateur.

  2. Accédez au répertoire source de SharePoint Foundation.

  3. Tapez le commutateur et l'argument correspondant du programme requis que vous voulez installer, puis appuyez sur Entrée. Par exemple :

    PrerequisiteInstaller.exe /SQLNCli: "\\o14-sf-admin\SP_prereqs\sqlncli.msi"

    Remarque :
    Pour installer plusieurs composants requis, tapez chaque paire de commutateur et d'argument en veillant à séparer chaque paire d'un espace. Par exemple :

    PrerequisiteInstaller.exe /SQLNCli: "\\o14-sf-admin\SP_prereqs\sqlncli.msi" /ChartControl: "\\o14-sf-admin\SP_prereqs\MSChart.exe" /W2K8SP2: "\\o14-sf-admin\SP_prereqs\Windows6.0-KB948465-X64.exe" /NETFX35SP1: "\\o14-sf-admin\SP_prereqs\dotnetfx35setup.exe"

Installer les composants requis à l'aide d'un fichier d'arguments

Vous pouvez installer les composants requis à partir du partage de fichiers en utilisant un fichier d'arguments constitué de commutateurs et des instructions de chemin d'accès correspondantes pour les programmes à installer.

Lorsque vous exécutez PrerequisiteInstaller.exe avec un fichier d'arguments, voici comment se déroule le processus :

  1. PrerequisiteInstaller.exe lit le fichier d'arguments pour vérifier que chaque commutateur est valide et que le programme identifié dans l'instruction de chemin d'accès existe.

    Remarque :
    Si vous spécifiez un argument, PrerequisiteInstaller.exe ignore le fichier d'arguments et traite uniquement l'argument de ligne de commande.

  2. PrerequisiteInstaller.exe analyse le système local pour déterminer si les composants requis sont déjà installés.

  3. PrerequisiteInstaller.exe installe les programmes spécifiés dans le fichier d'arguments et renvoie l'un des codes de sortie suivants :

    • 0 - Réussite

    • 1 - Une autre instance de cette application est déjà en cours d'exécution

    • 2 - Paramètre de ligne de commande non valide

    • 1001 - Un redémarrage en attente bloque l'installation

    • 3010 - Un redémarrage est nécessaire

  4. Si un composant requis nécessite un redémarrage, un code 3010 est généré et vous êtes invité à cliquer sur Terminer pour redémarrer le système. Le comportement du programme d'installation après un code 3010 dépend des conditions qui prévalent sur l'ordinateur, à savoir :

    • Si Windows Server 2008 Service Pack 2 (SP2) est déjà installé sur le système, le code 3010 est généré et les composants requis restants sont installés. Une fois le dernier composant requis installé, vous êtes invité à redémarrer le système.

    • Si Windows Server 2008 SP2 est installé sur le système par l'outil PrerequisiteInstaller.exe, le programme d'installation génère le code 3010 et l'installation des composants requis restants est ignorée. Vous êtes invité à redémarrer le système.

      À l'issue du redémarrage du système, PrerequisiteInstaller.exe s'exécute à nouveau, car le fichier de démarrage créé avant le redémarrage contient un indicateur /continue.

      Après un redémarrage, PrerequisiteInstaller.exe ignore le fichier d'arguments et tente de télécharger et installer les composants requis restants via Internet. Pour plus d'informations, voir Problèmes connus.

Utilisez la procédure suivante pour créer un fichier d'arguments.

Pour créer un fichier d'arguments

  1. À l'aide d'un éditeur de texte, créez un document texte nommé PrerequisiteInstaller.Arguments.txt. Enregistrez ce fichier au même emplacement que PrerequisiteInstaller.exe. Ce fichier doit contenir les commutateurs et les arguments utilisés lorsque vous exécutez l'Outil de préparation des produits Microsoft SharePoint.

  2. À l'aide d'un éditeur de texte, modifiez PrerequisiteInstaller.Arguments.txt et indiquez les chemins d'accès aux fichiers dans la source d'installation pour chaque commutateur de composant requis en utilisant la syntaxe suivante :

    /switch: <chemin_accès>

    Où /switch représente un commutateur valide et <chemin_accès> correspond à un chemin d'accès à la source d'installation.

    L'exemple suivant présente un fichier d'arguments complet qui utilise un partage de fichiers comme point d'installation courant.

    /SQLNCli: "\\o14-sf-admin\SP_prereqs\sqlncli.msi"
    /ChartControl: "\\o14-sf-admin\SP_prereqs\MSChart.exe"
    /W2K8SP2: "\\o14-sf-admin\SP_prereqs\Windows6.0-KB948465-X64.exe"
    /NETFX35SP1: "\\o14-sf-admin\SP_prereqs\dotnetfx35setup.exe"
    /PowerShell: "\\o14-sf-admin\SP_prereqs\Windows6.0-KB968930-x64.msu"
    /KB976394: "\\o14-sf-admin\SP_prereqs\Windows6.0-KB976394-x64.msu"
    /KB976462: "\\o14-sf-admin\SP_prereqs\Windows6.1-KB976462-v2-x64.msu"
    /IDFX: "\\o14-sf-admin\SP_prereqs\Windows6.0-KB974405-x64.msu"
    /Sync: "\\o14-sf-admin\SP_prereqs\Synchronization.msi"
    /FilterPack: "\\o14-sf-admin\SP_prereqs\FilterPackx64.exe"
    /ADOMD: "\\o14-sf-admin\SP_prereqs\SQLSERVER2008_ASADOMD10.msi"
    /ReportingServices: "\\o14-sf-admin\SP_prereqs\rsSharePoint.msi"
    /Speech: "\\o14-sf-admin\SP_prereqs\SpeechPlatformRuntime.msi"
    /SpeechLPK: "\\o14-sf-admin\SP_prereqs\MSSpeech_SR_en-US_TELE.msi"

    Important :
    Pour une meilleure lisibilité, les commutateurs et les instructions de chemin d'accès dans l'exemple précédent sont présentés sur des lignes distinctes. Lorsque vous créerez réellement un fichier PrerequisitesInstaller.Arguments.txt, au lieu d'utiliser des sauts de ligne, séparez chaque commutateur et instruction de chemin d'accès d'un espace. Pour plus d'informations, voir Problèmes connus.

  3. Après avoir modifié PrerequisiteInstaller.Arguments.txt, enregistrez vos modifications, puis vérifiez que ce fichier se trouve dans le même répertoire que PrerequisiteInstaller.exe.

Utilisez la procédure suivante pour installer les composants requis.

Pour installer les composants requis à l'aide d'un fichier d'arguments

  1. Exécutez PrerequisiteInstaller.exe à partir de l'invite de commandes afin d'installer les composants requis.

    Attention :
    Ne cliquez pas sur Terminer pour redémarrer le système si vous y êtes invité. Cliquez sur Annuler. Pour plus d'informations, voir Problèmes connus avant de passer à l'étape suivante.

  2. Redémarrez le système manuellement.

  3. Exécutez PrerequisiteInstaller.exe à partir de l'invite de commandes.

Problèmes connus

Deux problèmes connus peuvent contrarier l'utilisation d'un fichier d'arguments :

  • Utilisation de sauts de ligne dans le fichier d'arguments

    Si vous créez un fichier d'arguments et que vous utilisez des sauts de ligne pour placer chaque commutateur et argument sur une ligne distincte, le programme d'installation des composants requis échoue. La solution de contournement consiste à entrer toutes les paires de commutateur et d'argument sur une même ligne.

  • Après le rédémarrage d'un ordinateur, le fichier d'arguments n'est pas utilisé

    Après un redémarrage, l'outil PrerequisiteInstaller.exe exécute le fichier de commandes de démarrage, qui contient un indicateur /continue. Cet indicateur contraint le programme d'installation à ignorer le fichier d'arguments.

    Vous devez empêcher tout redémarrage en supprimant la tâche de démarrage dans ce fichier de commandes en utilisant l'une des options suivantes :

    Option 1

    1. Exécutez PrerequisiteInstaller.exe en double-cliquant dessus. Le programme affiche le premier écran avec la liste des composants requis.

    2. Cliquez sur Annuler. PrerequisiteInstaller.exe supprime la tâche de démarrage.

    Option 2

    1. Dans le menu Démarrer, choisissez Exécuter, puis tapez regedit pour ouvrir le Registre.

    2. Ouvrez la clé HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders.

    3. Vérifiez la valeur de « Common Startup ». Celle-ci indique le répertoire dans lequel les tâches de démarrage sont répertoriées.

    4. Fermez l'Éditeur du Registre sans apporter de modifications.

    5. Accédez au répertoire de démarrage, qui est généralement <systemdir>\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup.

    6. Supprimez la tâche de démarrage en supprimant « SharePointServerPreparationToolStartup_0FF1CE14-0000-0000-0000-000000000000.cmd ».

Historique des modifications


Préparer le déploiement (SharePoint Foundation 2010)
Voir aussi

Cette section décrit les étapes essentielles à suivre avant de déployer Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

    Cet article décrit la configuration matérielle et logicielle minimale requise pour l'installation de SharePoint Foundation 2010.

  • Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010)

    Cet article fournit des informations sur les comptes d'administration et de service requis pour le déploiement initial de SharePoint Foundation 2010. Des autorisations et des comptes supplémentaires sont nécessaires pour implémenter entièrement tous les aspects d'une batterie de serveurs de production.

  • Sécuriser SQL Server pour les environnements SharePoint (SharePoint Foundation 2010)

    Cet article décrit comment renforcer la sécurité de Microsoft SQL Server dans les environnements SharePoint Foundation 2010.

Voir aussi

Concepts

Vue d'ensemble du déploiement (SharePoint Foundation 2010)
Scénarios de déploiement (SharePoint Foundation 2010)

Historique des modifications


Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010)

Cet article fournit des informations sur les comptes d'administration et de service qui sont requis pour le déploiement initial Microsoft SharePoint Foundation 2010. Des autorisations et des comptes supplémentaires sont nécessaires pour implémenter totalement tous les aspects d'une batterie de serveurs de production.

Autorisations requises

Pour déployer SharePoint Foundation 2010 sur une batterie de serveurs, vous devez fournir les informations d'identification de plusieurs comptes différents.

Le tableau suivant décrit les comptes utilisés pour installer et configurer SharePoint Foundation 2010.

Compte Objectif Conditions requises

Compte de service SQL Server

Le compte de service SQL Server utilisé pour exécuter SQL Server. Il s'agit du compte pour les services SQL Server suivants :

  • MSSQLSERVER

  • SQLSERVERAGENT

Si vous n'utilisez pas l'instance SQL Server par défaut, dans la console Windows Services, ces services apparaîtront comme :

  • MSSQL$Nom_instance

  • SQLAgent$Nom_instance

Utiliser un compte système local ou un compte utilisateur de domaine.

Si vous prévoyez d'effectuer une sauvegarde ou une restauration à partir d'une ressource externe, des autorisations pour la ressource externe doivent être accordées au compte approprié. Si vous utilisez un compte utilisateur de domaine pour le compte de service SQL Server, accordez des autorisations à ce compte utilisateur de domaine. En revanche, si vous utilisez le compte Service réseau ou le compte système local, accordez des autorisations à la ressource externe sur le compte de l'ordinateur (nom_domaine\SQL_hostname$).

Le nom de l'instance est arbitraire et a été créé lors de l'installation de Microsoft SQL Server.

Compte utilisateur du programme d'installation

Le compte utilisateur du programme d'installation est utilisé pour exécuter :

  • Configuration

  • Assistant Configuration des produits SharePoint

  • Compte utilisateur de domaine.

  • Membre du groupe Administrateurs sur chaque serveur sur lequel le programme d'installation est exécuté.

  • Connexion SQL Server sur l'ordinateur qui exécute SQL Server.

  • Membre des rôles de sécurité SQL Server suivants :

    • Rôle serveur fixe securityadmin

    • Rôle serveur fixe dbcreator

Si vous exécutez des applets de commande Windows PowerShell qui affectent une base de données, ce compte doit être membre du rôle de base de données fixe db_owner pour la base de données.

Compte de la batterie de serveurs ou compte d'accès à la base de données

Le compte de la batterie de serveurs est utilisé pour effectuer les tâches suivantes :

  • Configurer et gérer la batterie de serveurs.

  • Agir comme l'identité du pool d'applications pour le site Web Administration centrale de SharePoint.

  • Exécuter le Service Minuteur de flux de travail Microsoft SharePoint Foundation.
  • Compte utilisateur de domaine.

Des autorisations supplémentaires sont automatiquement accordées au compte de la batterie de serveurs sur les serveurs Web et les serveurs d'applications qui sont joints à une batterie de serveurs.

Le compte de la batterie de serveurs est automatiquement ajouté en tant que connexion SQL Server sur l'ordinateur qui exécute SQL Server et ajouté aux rôles de sécurité SQL Server suivants :

  • Rôle serveur fixe dbcreator

  • Rôle serveur fixe securityadmin

  • Rôle de base de données fixe db_owner pour toutes les bases de données SharePoint de la batterie de serveurs

Historique des modifications


Sécuriser SQL Server pour les environnements SharePoint (SharePoint Foundation 2010)

Cet article explique comment sécuriser Microsoft SQL Server pour les environnements Produits Microsoft SharePoint 2010.

Dans cet article :

  • Résumé des recommandations en matière de sécurisation

  • Configurer une instance de SQL Server pour être à l'écoute sur un autre port que celui par défaut

  • Configurer le Pare-feu Windows pour bloquer les ports d'écoute SQL Server par défaut

  • Configurer le Pare-feu Windows pour ouvrir les ports attribués manuellement

  • Configurer un alias client SQL

  • Tester l'alias client SQL

Résumé des recommandations en matière de sécurisation

Pour sécuriser des environnements de batterie de serveurs, il est recommandé de procéder comme suit :

  • Bloquez le port UDP 1434.

  • Configurez les instances nommées de SQL Server pour être à l'écoute sur un port non standard (autre que le port TCP 1433 ou le port UDP 1434).

  • Pour plus de sécurité, bloquez le port TCP 1433 et réattribuez le port utilisé par l'instance par défaut à un autre port.

  • Configurez les alias clients SQL Server sur tous les serveurs Web frontaux et les serveurs d'applications de la batterie de serveurs. Une fois bloqué le port TCP 1433 ou le port UDP 1434, les alias clients SQL Server sont nécessaires sur tous les ordinateurs qui communiquent avec l'ordinateur exécutant SQL Server.

Pour plus d'informations sur ces recommandations, voir Planifier le renforcement de la sécurité (SharePoint Foundation 2010).

Configurer une instance de SQL Server pour être à l'écoute sur un autre port que celui par défaut

Servez-vous du Gestionnaire de configuration SQL Server pour modifier le port TCP utilisé par une instance de SQL Server.

  1. Sur l'ordinateur exécutant SQL Server, ouvrez le Gestionnaire de configuration SQL Server.

  2. Dans le volet gauche, développez Configuration réseau SQL Server.

  3. Cliquez sur l'entrée correspondant à l'instance que vous configurez. L'instance par défaut est répertoriée en tant que Protocoles pour MSSQLSERVER. Les instances nommées seront désignées comme Protocoles pour instance_nommée.

  4. Dans le volet droit, cliquez avec le bouton droit sur TCP/IP, puis sur Propriétés.

  5. Cliquez sur l'onglet Adresses IP. Pour chaque adresse IP attribuée à l'ordinateur exécutant SQL Server, il existe une entrée correspondante sous cet onglet. Par défaut, SQL Server écoute toutes les adresses IP attribuées à l'ordinateur.

  6. Pour modifier globalement le port que l'instance par défaut écoute, procédez comme suit :

    1. Pour chaque adresse IP, à l'exception de la section IPAll, effacez toutes les valeurs dans les champs Ports TCP dynamiques et Port TCP.

    2. Pour la section IPAll, effacez la valeur du champ Ports TCP dynamiques. Dans le champ Port TCP, entrez le port que vous voulez que l'instance de SQL Server écoute. Par exemple, entrez 40000.

  7. Pour modifier globalement le port qu'une instance nommée écoute, procédez comme suit :

    1. Pour chaque adresse IP, y compris pour IPAll, effacez toutes les valeurs du champ Ports TCP dynamiques. Une valeur égale à 0 pour ce champ indique que SQL Server utilise un port TCP dynamique pour l'adresse IP. Une entrée vierge pour cette valeur signifie que SQL Server n'utilisera pas de port TCP dynamique pour l'adresse IP.

    2. Pour chaque adresse IP, à l'exception de IPAll, effacez toutes les valeurs du champ Port TCP.

    3. Pour la section IPAll, effacez la valeur du champ Ports TCP dynamiques. Dans le champ Port TCP, entrez le port que vous voulez que l'instance de SQL Server écoute. Par exemple, entrez 40000.

  8. Cliquez sur OK. Vous recevez un message indiquant que la modification ne prendra effet qu'après le redémarrage du service SQL Server. Cliquez sur OK.

  9. Fermez le Gestionnaire de configuration SQL Server.

  10. Redémarrez le service SQL Server et vérifiez que l'ordinateur exécutant SQL Server est à l'écoute sur le port que vous avez sélectionné. Vous pouvez le vérifier en recherchant les indications correspondantes dans le journal de l'Observateur d'événements après avoir redémarré le service SQL Server. Recherchez un événement d'information semblable à l'événement suivant :

    Type d'événement : information

    Source d'événement : MSSQL$MSSQLSERVER

    Catégorie d'événement : (2)

    ID d'événement : 26022

    Date : 3/6/2008

    Heure : 13:46:11

    Utilisateur : N/A

    Ordinateur : nom_ordinateur

    Description :

    Le serveur est à l'écoute sur [ 'any' <ipv4>50000]

Configurer le Pare-feu Windows pour bloquer les ports d'écoute SQL Server par défaut

  1. Dans le Panneau de configuration, ouvrez Pare-feu Windows. Cliquez sur Modifier les paramètres pour ouvrir la boîte de dialogue Paramètres du Pare-feu Windows

  2. Sous l'onglet Général, cliquez sur Activer. Assurez-vous que la case à cocher Ne pas autoriser les exceptions est désactivée.

  3. Sous l'onglet Exceptions, cliquez sur Ajouter un port.

  4. Dans la boîte de dialogue Ajouter un port, entrez un nom pour le port. Par exemple, entrez UDP-1434. Entrez ensuite le numéro de port. Par exemple, entrez 1434.

  5. Cliquez sur l'option appropriée : UDP ou TCP. Par exemple, pour bloquer le port 1434, cliquez sur UDP. Pour bloquer le port 1433, cliquez sur TCP.

  6. Cliquez sur Modifier l'étendue et assurez-vous que l'étendue pour cette exception est définie sur N'importe quel ordinateur (y compris ceux présents sur Internet).

  7. Cliquez sur OK.

  8. Sous l'onglet Exceptions, recherchez l'exception que vous avez créée. Pour bloquer le port, désactivez la case à cocher correspondant à cette exception. Par défaut, cette case à cocher est activée, ce qui signifie que le port est ouvert.

Configurer le Pare-feu Windows pour ouvrir les ports attribués manuellement

  1. Effectuez les étapes 1 à 7 de la procédure précédente pour créer une exception pour le port que vous avez attribué manuellement à une instance de SQL Server. Par exemple, créez une exception pour le port TCP 40000.

  2. Sous l'onglet Exceptions, recherchez l'exception que vous avez créée. Assurez-vous que la case à cocher correspondant à l'exception est activée. Par défaut, cette case à cocher est activée, ce qui signifie que le port est ouvert.

    Remarque :
    Pour plus d'informations sur l'utilisation du protocole IPsec (Internet Protocol security) afin de sécuriser les communications à destination et en provenance de votre ordinateur SQL Server, voir l'article de la Base de connaissances Microsoft 233256 : Comment faire pour activer le trafic IPSec par le biais d'un pare-feu (http://go.microsoft.com/fwlink/?linkid=76142&clcid=0x40C).

Configurer un alias client SQL

Si vous bloquez le port UDP 1434 ou le port TCP 1433 sur l'ordinateur exécutant SQL Server, vous devez créer un alias client SQL Server sur tous les autres ordinateurs de la batterie de serveurs. Vous pouvez utiliser les composants clients SQL Server afin de créer un alias client SQL Server pour les ordinateurs qui se connectent à SQL Server.

  1. Exécutez le programme d'installation de SQL Server sur l'ordinateur cible, puis sélectionnez les composants client suivants à installer :

    1. Composants de connectivité

    2. Outils de gestion

  2. Ouvrez le Gestionnaire de configuration SQL Server.

  3. Dans le volet gauche, cliquez sur Configuration de SQL Native Client.

  4. Dans le volet droit, cliquez avec le bouton droit sur Alias et sélectionnez Nouvel alias.

  5. Dans la boîte de dialogue Alias, entrez un nom pour l'alias, puis entrez le numéro de port pour l'instance de base de données. Par exemple, entrez SharePoint _alias.

  6. Dans le champ Numéro de port, entrez le numéro de port pour l'instance de base de données. Par exemple, entrez 40000. Assurez-vous que le protocole est défini sur TCP/IP.

  7. Dans le champ Serveur, entrez le nom de l'ordinateur exécutant SQL Server.

  8. Cliquez sur Appliquer, puis sur OK.

Tester l'alias client SQL

Testez la connectivité à l'ordinateur exécutant SQL Server à l'aide de Microsoft SQL Server Management Studio, qui est disponible via l'installation des composants clients SQL Server.

  1. Ouvrez SQL Server Management Studio.

  2. Lorsque vous êtes invité à entrer un nom de serveur, entrez le nom de l'alias que vous avez créé, puis cliquez sur Connexion. Si la connexion est réussie, SQL Server Management Studio est rempli avec des objets qui correspondent à la base de données distante.

    Remarque :
    Pour vérifier la connectivité à des instances de base de données supplémentaires dans SQL Server Management Studio, cliquez sur Connexion, puis sur Moteur de base de données.

Historique des modifications


Scénarios de déploiement (SharePoint Foundation 2010)

Cette section explique comment déployer Microsoft SharePoint Foundation 2010 sur un ou plusieurs serveurs pour créer différentes topologies permettant de tester et d'implémenter des solutions Microsoft SharePoint Foundation 2010 à différentes étapes du cycle de vie du déploiement.

Dans cette section :

  • Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010)

    Cet article explique comment installer SharePoint Foundation 2010 sur un serveur donné. Ce déploiement utilise Microsoft SQL Server et peut facilement faire l'objet d'une montée en puissance parallèle en vue de la création de topologies de batterie de serveurs à deux et trois niveaux.

  • Déployer un serveur unique avec une base de données intégrée (SharePoint Foundation 2010)

    Cet article explique comment installer SharePoint Foundation 2010 sur un serveur donné. Ce déploiement utilise SQL Server Express et est généralement utilisé pour l'évaluation de SharePoint Foundation 2010.

  • Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010)

    Cet article explique comment installer SharePoint Foundation 2010 sur plusieurs serveurs. Ce déploiement utilise Microsoft SQL Server et la topologie à trois niveaux obtenue permet d'échafauder l'implémentation de n'importe quelle solution.

  • Démarrage rapide : déployer un serveur unique dans un environnement Hyper-V isolé (SharePoint Foundation 2010)

    Cet article explique comment utiliser Windows PowerShell pour installer SharePoint Foundation 2010 sur un serveur donné qui utilise SQL Server Express ou Microsoft SQL Server. Utilisez le code Windows PowerShell inclus pour installer rapidement SharePoint Foundation 2010 dans un environnement Hyper-V isolé permettant d'évaluer SharePoint Foundation 2010.

  • Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010)

    Cet article explique comment déployer Microsoft SharePoint Foundation 2010 dans un environnement de batterie de serveurs qui utilise des bases de données créées par l'administrateur de base de données.

  • Déploiement dans un environnement virtuel (SharePoint Foundation 2010)

    Cet article fournit des instructions de déploiement d'un environnement virtuel.

Historique des modifications


Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010)

Cet article explique comment effectuer une nouvelle installation de Microsoft SharePoint Foundation 2010 sur une seule batterie de serveurs.

Dans cet article :

  • Présentation

  • Avant de commencer

  • Installer SharePoint Foundation 2010

  • Étapes postérieures à l'installation

Présentation

Lorsque vous installez SharePoint Foundation 2010 sur une seule batterie de serveurs, vous pouvez configurer SharePoint Foundation 2010 en fonction de vos besoins. À la fin du programme d'installation et de l'Assistant Configuration des produits SharePoint, vous aurez installé des fichiers binaires, configuré des autorisations de sécurité, des paramètres de registre, la base de données de configuration et la base de données de contenu, ainsi qu'installé le site Web Administration centrale de SharePoint. Ensuite, vous pouvez exécuter l'Assistant Configuration de batterie de serveurs afin de configurer la batterie de serveurs, de sélectionner les services à utiliser dans la batterie de serveurs et de créer la première collection de sites ou effectuer manuellement la configuration de la batterie de serveurs à votre propre rythme.

En règle générale, une batterie de serveurs unique se compose d'un serveur qui exécute Microsoft SQL Server et SharePoint Foundation 2010. Vous pouvez déployer SharePoint Foundation 2010 dans un environnement à batterie de serveurs unique si vous n'hébergez que quelques sites pour un nombre d'utilisateurs limité. Cette configuration est également utile si vous souhaitez configurer une batterie de serveurs en fonction de vos besoins dans un premier temps, puis ajouter des serveurs à la batterie de serveurs lors d'une étape ultérieure.

Remarque :
Ce guide n'explique pas comment installer SharePoint Foundation 2010 dans un environnement à plusieurs batteries de serveurs ou comment effectuer une mise à niveau depuis des versions antérieures de SharePoint Foundation. Pour plus d'informations, voir Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010). Pour plus d'informations sur la mise à niveau, voir Mise à niveau vers SharePoint Foundation 2010.

Avant de commencer

Avant de commencer le déploiement, procédez aux vérifications suivantes :

  • Assurez-vous que vous êtes familiarisé avec les instructions liées au système d'exploitation décrites dans Instructions pour régler les performances de Windows Server 2008 (éventuellement en anglais) et Instructions pour régler les performances de Windows Server 2008 R2 (éventuellement en anglais).

  • Assurez-vous que vous respectez en totalité les configurations matérielle et logicielle requises. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  • Veillez à effectuer une nouvelle installation de SharePoint Foundation 2010. Vous ne pouvez pas installer la version RTM de SharePoint Foundation 2010 sans supprimer au préalable la version bêta de SharePoint Foundation 2010.

  • Assurez-vous que vous êtes prêt à configurer les comptes requis avec les autorisations appropriées, comme indiqué dans Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

    Remarque :
    Pour des raisons de sécurité, il est recommandé d'installer SharePoint Foundation 2010 en utilisant l'administration selon le principe des privilèges minimum.

  • Veillez à décider des services à utiliser pour votre application Web, comme indiqué dans Configurer les services (SharePoint Foundation 2010).

Installer SharePoint Foundation 2010

Pour installer et configurer SharePoint Foundation 2010, suivez les étapes suivantes :

  1. Exécutez l'Outil de préparation des produits Microsoft SharePoint, qui installe tous les éléments prérequis nécessaires à l'utilisation de SharePoint Foundation 2010.

  2. Exécutez le programme d'installation, qui installe les fichiers binaires, configure les autorisations de sécurité et définit les paramètres de registre pour Microsoft SharePoint Foundation.

  3. Exécutez l'Assistant Configuration des produits SharePoint, qui installe et configure la base de données de configuration, la base de données de contenu, et installe le site Web Administration centrale de SharePoint.

  4. Configurez les paramètres du navigateur.

  5. Exécutez l'Assistant Configuration de batterie de serveurs, qui configure la batterie de serveurs, crée la première collection de sites et sélectionne les services à utiliser dans la batterie de serveurs.

  6. Effectuez les étapes postérieures à l'installation.

Important :
Pour effectuer les procédures suivantes, vous devez être membre du groupe Administrateurs sur l'ordinateur local.

Exécuter l'Outil de préparation des produits Microsoft SharePoint

Utilisez la procédure suivante pour installer les éléments logiciels requis pour SharePoint Foundation 2010.

Pour exécuter l'Outil de préparation des produits Microsoft SharePoint

  1. Insérez votre disque d'installation de SharePoint Foundation 2010.

  2. Dans la page de démarrage de SharePoint Foundation 2010, cliquez sur Installer les éléments logiciels requis.

    Remarque :
    Étant donné que l'Outil de préparation télécharge les composants à partir du Centre de téléchargement Microsoft, l'ordinateur sur lequel vous effectuez l'installation de Microsoft SharePoint Foundation doit avoir accès à Internet.

  3. Dans la page d'accueil de l'Outil de préparation des produits Microsoft SharePoint, cliquez sur Suivant.

  4. Dans la page Contrat de licence de produit logiciel, activez la case à cocher J'accepte les termes du ou des contrats de licence, puis cliquez sur Suivant.

  5. Dans la page indiquant que l'installation est terminée, cliquez sur Terminer.

Exécuter le programme d'installation

La procédure suivante installe les fichiers binaires, configure les autorisations de sécurité et définit les paramètres de registre pour SharePoint Foundation 2010.

Pour exécuter le programme d'installation

  1. Dans la page de démarrage de SharePoint Foundation 2010, cliquez sur Installer SharePoint Foundation.

  2. Dans la page Lire les termes du contrat de licence logiciel Microsoft, consultez les termes, activez la case à cocher J'accepte les termes de ce contrat, puis cliquez sur Continuer.

  3. Dans la page Choisir l'installation voulue, cliquez sur Batterie de serveurs.

  4. Sous l'onglet Type de serveur, cliquez sur Complète.

  5. Facultatif : pour installer SharePoint Foundation 2010 à l'emplacement de votre choix, cliquez sur l'onglet Emplacement de données, puis tapez le nom de l'emplacement ou cliquez sur Parcourir pour rechercher celui-ci.

  6. Cliquez sur Installer maintenant.

  7. Lorsque l'installation est terminée, cliquez sur Fermer.

Remarque :
Si l'installation échoue, vérifiez le dossier TEMP de l'utilisateur qui a exécuté le programme d'installation. Vérifiez que vous avez ouvert une session sous le compte de l'utilisateur qui a exécuté le programme d'installation, puis tapez %temp% dans la barre d'emplacement de l'Explorateur Windows. Si le chemin d'accès %temp% conduit à un emplacement qui se termine par un « 1 » ou un « 2 », vous devrez accéder au niveau supérieur pour afficher les fichiers journaux. Le nom du fichier journal est Installation de Microsoft SharePoint Foundation 2010 (<timestamp>).

Conseil :
Pour accéder à l'Assistant Configuration des produits SharePoint, cliquez sur Démarrer, pointez sur Tous les programmes, puis cliquez sur Produits Microsoft SharePoint 2010. Si la boîte de dialogue Contrôle de compte d'utilisateur apparaît, cliquez sur Continuer.

Exécuter l'Assistant Configuration des produits SharePoint

La procédure suivante installe et configure la base de données de configuration, la base de données de contenu, et installe le site Web Administration centrale de SharePoint.

Pour exécuter l'Assistant Configuration des produits SharePoint

  1. Dans la page d'accueil des produits SharePoint, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Se connecter à une batterie de serveurs, cliquez sur Créer une batterie de serveurs, puis cliquez sur Suivant.

  4. Dans la page Spécifier les paramètres de la base de données de configuration, effectuez les opérations suivantes :

    1. Dans la zone Serveur de base de données, tapez le nom de l'ordinateur exécutant SQL Server.

    2. Dans la zone Nom de la base de données, tapez un nom pour votre base de données de configuration, ou utilisez le nom de base de données par défaut. Le nom par défaut est SharePoint_Config.

    3. Dans la zone Nom d'utilisateur, tapez le nom d'utilisateur du compte de batterie de serveurs. Veillez à taper le nom d'utilisateur sous la forme DOMAINE\nom_utilisateur.

      Important :
      La batterie de serveurs sert à créer votre base de données de configuration et à y accéder. Elle sert également d'identité de pool d'applications pour le compte de pool d'applications de l'Administration centrale de SharePoint, et elle correspond au compte sous lequel s'exécute le service Minuteur de flux de travail Microsoft SharePoint Foundation. L'Assistant Configuration des produits SharePoint ajoute ce compte aux comptes de connexions SQL Server, au rôle serveur dbcreator SQL Server et au rôle serveur securityadmin SQL Server. Le compte d'utilisateur que vous spécifiez en tant que compte de service doit être un compte d'utilisateur de domaine, mais ne doit pas obligatoirement être membre d'un groupe de sécurité spécifique sur vos serveurs Web frontaux ou vos serveurs de base de données. Nous vous recommandons de suivre le principe du moindre privilège et de spécifier un compte d'utilisateur qui n'est pas membre du groupe Administrateurs sur vos serveurs Web frontaux ou vos serveurs de base de données.

    4. Dans la zone Mot de passe, tapez le mot de passe de l'utilisateur.

  5. Cliquez sur Suivant.

  6. Dans la page Spécifier les paramètres de sécurité de la batterie de serveurs, tapez un mot de passe, puis cliquez sur Suivant.

    Assurez-vous que le mot de passe satisfait aux critères suivants :

    • Il contient au moins huit caractères.

    • Il contient au moins trois des quatre groupes de caractères suivants :

      • Il utilise des majuscules non accentuées (A à Z).

      • Il utilise des minuscules non accentuées (a à z).

      • Il utilise des chiffres (0 à 9).

      • Il utilise des caractères non alphabétiques (comme !, $, #, %).

      Remarque :
      Bien qu'une phrase secrète soit similaire à un mot de passe, elle est généralement plus longue afin que la sécurité s'en trouve renforcée. Elle permet de chiffrer les informations d'identification des comptes inscrits dans Microsoft SharePoint Foundation, tels que le compte système Microsoft SharePoint Foundation que vous fournissez lorsque vous exécutez l'Assistant Configuration des produits SharePoint. Veillez à vous souvenir du mot de passe choisi, car vous devez l'utiliser chaque fois que vous ajoutez un serveur à la batterie de serveurs.

  7. Dans la page Configurer l'application Web Administration centrale de SharePoint, procédez comme suit :

    1. Activez la case à cocher Spécifiez le numéro de port et tapez le numéro de port que doit utiliser l'application Web Administration centrale de SharePoint ou laissez la case à cocher Spécifiez le numéro de port désactivée si vous souhaitez utiliser le numéro de port par défaut.

    2. Cliquez sur NTLM ou Négocier (Kerberos).

  8. Cliquez sur Suivant.

  9. Dans la page Fin de l' Assistant Configuration des produits SharePoint, passez en revue vos paramètres de configuration pour vérifier qu'ils sont corrects, puis cliquez sur Suivant.

    Remarque :
    Si vous souhaitez créer automatiquement des comptes uniques pour les utilisateurs dans le service d'annuaire Active Directory, cliquez sur Paramètres avancés, puis activez la création de compte Active Directory.

  10. Dans la page Configuration réussie, cliquez sur Terminer.

    Remarque :
    Si l'Assistant Configuration des produits SharePoint échoue, vérifiez les fichiers journaux PSCDiagnostics, qui sont situés sur le lecteur sur lequel SharePoint Foundation est installé, dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\LOGS.

    Remarque :
    Si vous êtes invité à entrer votre nom d'utilisateur et votre mot de passe, vous devrez peut-être ajouter le site Web Administration centrale de SharePoint à la liste des sites de confiance et configurer les paramètres d'authentification utilisateur dans Internet Explorer. Vous souhaitez peut-être également désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer. Les instructions de configuration ou de désactivation de ces paramètres sont fournies dans la section suivante.

    Remarque :
    Si un message d'erreur du serveur proxy s'affiche, vous devrez peut-être configurer les paramètres du serveur proxy afin que les adresses locales contournent celui-ci. La section suivante indique plus loin comment configurer les paramètres du serveur proxy.

Configurer les paramètres du navigateur

Après avoir exécuté l'Assistant Configuration des produits SharePoint, assurez-vous que SharePoint Foundation 2010 fonctionne correctement pour les administrateurs locaux de votre environnement, en configurant des paramètres supplémentaires dans Internet Explorer.

Remarque :
Si les administrateurs locaux n'utilisent pas Internet Explorer, vous devez configurer des paramètres supplémentaires. Pour plus d'informations sur les navigateurs pris en charge, voir Planifier la prise en charge des navigateurs (SharePoint Foundation 2010).

Effectuez les procédures suivantes si vous êtes invité à entrer votre nom d'utilisateur et votre mot de passe :

  • Ajouter le site Web Administration centrale de SharePoint à la liste des sites de confiance

  • Désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer

Effectuez la procédure suivante si vous recevez un message d'erreur du serveur proxy :

  • Configurer les paramètres du serveur proxy de manière à ne pas utiliser de serveur proxy pour les adresses locales

Pour plus d'informations, voir Prise en main d'IEAK 8 (http://go.microsoft.com/fwlink/?linkid=151359&clcid=0x40C).

Pour ajouter le site Web Administration centrale de SharePoint à la liste des sites de confiance

  1. Dans Internet Explorer, dans le menu Outils, cliquez sur Options Internet.

  2. Dans l'onglet Sécurité, dans la zone Cliquez sur une zone pour afficher ou modifier les paramètres de sécurité, cliquez sur Sites de confiance, puis sur Sites.

  3. Désactivez la case à cocher Exiger un serveur sécurisé (https:) pour tous les sites de cette zone.

  4. Dans la zone Ajouter ce site Web à la zone, tapez l'URL de votre site, puis cliquez sur Ajouter.

  5. Cliquez sur Fermer pour fermer la boîte de dialogue Sites de confiance.

  6. Cliquez sur OK pour fermer la boîte de dialogue Options Internet.

Pour désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Outils d'administration, puis cliquez sur Gestionnaire de serveur.

  2. Dans Gestionnaire de serveur, sélectionnez la racine de Gestionnaire de serveur.

  3. Dans la section Informations sur la sécurité, cliquez sur Paramétrer la Configuration de sécurité renforcée d'Internet Explorer.

    La boîte de dialogue Configuration de sécurité renforcée d'Internet Explorer s'ouvre.

  4. Dans la section Administrateurs, cliquez sur Désactivé pour désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer, puis cliquez sur OK.

Pour configurer les paramètres du serveur proxy de manière à ne pas utiliser de serveur proxy pour les adresses locales

  1. Dans Internet Explorer, dans le menu Outils, cliquez sur Options Internet.

  2. Sous l'onglet Connexions, dans la zone Paramètres du réseau local, cliquez sur Paramètres réseau.

  3. Dans la zone Configuration automatique, désactivez la case à cocher Détecter automatiquement les paramètres de connexion.

  4. Dans la zone Serveur proxy, activez la case à cocher Utiliser un serveur proxy pour votre réseau local.

  5. Tapez l'adresse du serveur proxy dans la zone Adresse.

  6. Tapez le numéro de port du serveur proxy dans la zone Port.

  7. Activez la case à cocher Ne pas utiliser de serveur proxy pour les adresses locales.

  8. Cliquez sur OK pour fermer la boîte de dialogue Paramètres du réseau local.

  9. Cliquez sur OK pour fermer la boîte de dialogue Options Internet.

Exécuter l'Assistant Configuration de batterie de serveurs

L'installation et la configuration initiale de SharePoint Foundation 2010 sont maintenant terminées. Vous avez créé le site Web Administration centrale de SharePoint. Vous pouvez maintenant créer vos batterie de serveurs et sites, ainsi que sélectionner des services à l'aide de l'Assistant Configuration de batterie de serveurs.

Pour Exécuter l'Assistant Configuration de batterie de serveurs

  1. Sur le site Web Administration centrale de SharePoint, dans la page Assistants de configuration, cliquez sur Exécuter l'Assistant Configuration de batterie de serveurs.

  2. Dans la page Contribuer à l'amélioration de SharePoint, cliquez sur l'une des options suivantes, puis cliquez sur OK :

    • Oui, j'accepte de participer (recommandé).

    • Non, je ne souhaite pas participer.

  3. Dans la page Configuration de votre batterie SharePoint, cliquez sur Passer en revue les paramètres à l'aide de cet Assistant, puis cliquez sur Suivant.

  4. Dans la section Compte de service, cliquez sur le compte de service que vous souhaitez utiliser pour configurer vos services.

    Remarque :
    Pour des raisons de sécurité, il est recommandé d'utiliser un compte différent du compte d'administrateur de batterie de serveurs pour configurer des services dans la batterie de serveurs.

    Si vous décidez d'utiliser un compte géré existant, c'est-à-dire un compte dont a connaissance SharePoint Foundation, veillez à cliquer sur cette option avant de poursuivre.

  5. Sélectionnez les services à utiliser dans la batterie de serveurs, puis cliquez sur Suivant.

  6. Dans la page Créer une collection de sites, procédez comme suit :

    1. Dans la section Titre et description, dans la zone Titre, tapez le nom de votre nouveau site.

    2. Facultatif : dans la zone Description, tapez une description du contenu du site.

    3. Dans la section Adresse du site Web, sélectionnez un chemin d'URL pour le site.

    4. Dans la section Sélection du modèle, dans la liste Sélectionner un modèle , sélectionnez le modèle que vous souhaitez utiliser pour le site de niveau supérieur de la collection de sites.

      Remarque :
      Pour afficher un modèle ou une description d'un modèle, cliquez sur le modèle de votre choix dans la liste Sélectionner un modèle.

  7. Cliquez sur OK.

  8. Dans la page Configuration de votre batterie SharePoint, révisez le récapitulatif de la configuration de la batterie de serveurs, puis cliquez sur Terminer.

Étapes postérieures à l'installation

Une fois que vous avez installé et configuré SharePoint Foundation 2010, la fenêtre du navigateur s'ouvre sur le site Web Administration centrale de SharePoint de votre nouveau site SharePoint. Bien qu'il soit possible d'ajouter du contenu ou de personnaliser le site, il est recommandé d'effectuer tout d'abord les tâches administratives suivantes dans le site Web Administration centrale de SharePoint.

  • Configurer la collecte de données d'utilisation et d'intégrité Vous pouvez configurer la collecte de données d'utilisation et d'intégrité dans votre batterie de serveurs. Le système écrit les données d'utilisation et d'intégrité dans le dossier de journalisation et dans la base de données de journalisation. Pour plus d'informations, voir Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010).

  • Configurer la journalisation des diagnostics Vous pouvez configurer la journalisation des diagnostics, qui est éventuellement nécessaire après un déploiement ou une mise à niveau initiale. Les paramètres par défaut suffisent pour la plupart des situations, mais en fonction des besoins et du cycle de vie de la batterie de serveurs, vous pouvez modifier ces paramètres. Pour plus d'informations, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

  • Configurer le courrier électronique entrant Vous pouvez configurer le courrier électronique entrant afin que les sites SharePoint acceptent et archivent le courrier électronique entrant. Vous pouvez également configurer le courrier électronique de sorte que les sites SharePoint puissent archiver les discussions électroniques en simultané, enregistrer des documents envoyés par messagerie électronique et afficher sur les calendriers du site les réunions notifiées par courrier électronique. De plus, vous pouvez configurer le service de gestion d'annuaire SharePoint pour qu'il prenne en charge la création et la gestion de listes de distribution électronique. Pour plus d'informations, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

  • Configurer le courrier électronique sortant Vous pouvez configurer le courrier électronique sortant de façon à ce que votre serveur SMTP (Simple Mail Transfer Protocol) envoie des alertes par courrier électronique aux utilisateurs du site et des notifications aux administrateurs. L'adresse de l'émetteur du message et l'adresse de réponse qui apparaissent dans les alertes sortantes peuvent toutes deux être personnalisées. Pour plus d'informations, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010).

  • Configurer un compte mobile Vous pouvez configurer un compte mobile de telle sorte que SharePoint envoie des alertes sous la forme de messages texte (SMS) vers votre téléphone mobile ou vers celui des utilisateurs du site. Pour plus d'informations, voir Configurer un compte mobile (SharePoint Foundation 2010).

  • Installer et configurer le stockage BLOB distant Vous pouvez installer et configurer le stockage BLOB distant d'une instance de SQL Server 2008 qui prend en charge une batterie de serveurs SharePoint. Pour plus d'informations, voir Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010).

    ***DÉBUT MOSS UNIQUEMENT***

Historique des modifications

Date | Description | Raison
10 juin 2010 | 2010/06/07 | Mise à jour du contenu


Déployer un serveur unique avec une base de données intégrée (SharePoint Foundation 2010)

Cet article explique comment effectuer une nouvelle installation de Microsoft SharePoint Foundation 2010 sur un serveur unique avec une base de données intégrée.

Dans cet article :

  • Présentation

  • Avant de commencer

  • Installer SharePoint Foundation 2010

  • Étapes postérieures à l'installation

  • Configurer l'utilitaire de sauvegarde de Windows Server

Présentation

Vous pouvez publier rapidement un site SharePoint en déployant SharePoint Foundation 2010 sur un serveur unique avec une base de données intégrée. Cette configuration est utile si vous souhaitez évaluer les fonctionnalités et les capacités de SharePoint Foundation 2010, telles que la collaboration, la gestion des documents et la recherche. Cette configuration est également utile si vous déployez un petit nombre de sites Web et que vous souhaitez réduire les tâches d'administration au minimum. Lorsque vous déployez SharePoint Foundation 2010 sur un serveur unique avec une base de données intégrée en utilisant les paramètres par défaut, le programme d'installation installe Microsoft SQL Server 2008 Express et le produit SharePoint, puis l'Assistant Configuration des produits SharePoint crée la base de données de configuration et la base de données de contenu pour vos sites SharePoint. En outre, l'Assistant Configuration des produits SharePoint installe le site Web Administration centrale de SharePoint et crée votre première collection de sites SharePoint.

Remarque :
Cet article n'explique pas comment installer SharePoint Foundation 2010 dans un environnement de batterie de serveurs, ni comment effectuer une mise à niveau à partir de versions précédentes de SharePoint Foundation. Pour plus d'informations sur l'installation de SharePoint Foundation 2010 dans une seule batterie de serveurs, voir Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010). Pour plus d'informations sur l'installation de SharePoint Foundation 2010 dans plusieurs batteries de serveurs, voir Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010). Pour plus d'informations sur la mise à niveau, voir Mise à niveau vers SharePoint Foundation 2010.

Prenez en considération les restrictions suivantes concernant cette méthode d'installation :

  • Vous ne pouvez pas installer la version serveur unique avec base de données intégrée de SharePoint Foundation sur un contrôleur de domaine.

  • La taille d'une base de données SQL Server 2008 Express ne doit pas dépasser 4 Go.

Avant de commencer

Avant de commencer le déploiement, assurez-vous que vous possédez la configuration matérielle et logicielle requise. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010). Veillez également à effectuer une nouvelle installation de SharePoint Foundation 2010. Vous ne pouvez pas installer la version RTM de SharePoint Foundation 2010 sans supprimer au préalable la version bêta de SharePoint Foundation 2010

Installer SharePoint Foundation 2010

Pour installer et configurer SharePoint Foundation 2010, suivez les étapes suivantes :

  1. Exécutez l' Outil de préparation des produits Microsoft SharePoint, qui installe tous les logiciels requis pour utiliser SharePoint Foundation 2010.

  2. Exécutez le programme d'installation, qui installe SQL Server 2008 Express et le produit SharePoint.

  3. Exécutez l'Assistant Configuration des produits SharePoint, qui installe le site Web Administration centrale de SharePoint et crée votre première collection de sites SharePoint.

  4. Configurez les paramètres du navigateur.

  5. Effectuez les étapes postérieures à l'installation.

Important :
Pour effectuer les procédures suivantes, vous devez être membre du groupe Administrateurs sur l'ordinateur local.

Exécuter l'Outil de préparation des produits Microsoft SharePoint

Utilisez la procédure suivante pour installer les éléments logiciels requis pour SharePoint Foundation 2010.

Pour exécuter l'Outil de préparation des produits Microsoft SharePoint

  1. Insérez votre disque d'installation de SharePoint Foundation 2010.

  2. Dans la page de démarrage de SharePoint Foundation 2010, cliquez sur Installer les éléments logiciels requis.

    Remarque :
    Étant donné que l'Outil de préparation télécharge les composants à partir du Centre de téléchargement Microsoft, l'ordinateur sur lequel vous effectuez l'installation de SharePoint Foundation doit avoir accès à Internet.

  3. Dans la page d'accueil de l'Outil de préparation des produits Microsoft SharePoint, cliquez sur Suivant.

  4. Dans la page indiquant que l'installation est terminée, cliquez sur Terminer.

Exécuter le programme d'installation

La procédure suivante installe SQL Server 2008 Express et le produit SharePoint. À la fin de l'installation, vous pouvez choisir de démarrer l'Assistant Configuration des produits SharePoint, qui est décrit plus loin dans cette section.

Pour exécuter le programme d'installation

  1. Dans la page de démarrage de SharePoint Foundation 2010, cliquez sur Installer SharePoint Foundation.

  2. Dans la page Lire les termes du contrat de licence logiciel Microsoft, passez en revue les termes du contrat, activez la case à cocher J'accepte les termes de ce contrat, puis cliquez sur Continuer.

  3. Dans la page Choisir l'installation voulue, cliquez sur Autonome.

  4. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Assurez-vous que la case à cocher Exécuter l'Assistant Configuration des produits SharePoint est activée.

  5. Cliquez sur Fermer pour démarrer l'Assistant Configuration.

Remarque :
Si l'installation échoue, vérifiez le dossier TEMP de l'utilisateur qui a exécuté le programme d'installation. Vérifiez que vous avez ouvert une session sous le compte de l'utilisateur qui a exécuté le programme d'installation, puis tapez %temp% dans la barre d'emplacement de l'Explorateur Windows. Si le chemin d'accès %temp% conduit à un emplacement qui se termine par un « 1 » ou un « 2 », vous devrez accéder au niveau supérieur pour afficher les fichiers journaux. Le nom du fichier journal est Installation de Microsoft SharePoint Foundation 2010 (<timestamp>).

Conseil :
Pour accéder à l'Assistant Configuration des produits SharePoint, cliquez sur Démarrer, pointez sur Tous les programmes, puis cliquez sur Produits Microsoft SharePoint 2010. Si la boîte de dialogue Contrôle de compte d'utilisateur apparaît, cliquez sur Continuer.

Exécuter l'Assistant Configuration des produits SharePoint

La procédure suivante installe et configure la base de données de configuration, la base de données de contenu, et installe le site Web Administration centrale de SharePoint. Elle crée également votre première collection de sites SharePoint.

Pour exécuter l'Assistant Configuration des produits SharePoint

  1. Dans la page d'accueil des produits SharePoint, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront peut-être être redémarrés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Configuration réussie, cliquez sur Terminer.

    Remarque :
    Si l'Assistant Configuration des produits SharePoint échoue, vérifiez les fichiers journaux PSCDiagnostics, qui sont situés sur le lecteur sur lequel SharePoint Foundation est installé, dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\LOGS.

    Remarque :
    Si vous êtes invité à entrer votre nom d'utilisateur et votre mot de passe, vous devrez peut-être ajouter le site Web Administration centrale de SharePoint à la liste des sites de confiance et configurer les paramètres d'authentification utilisateur dans Internet Explorer. Vous souhaitez peut-être également désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer. Les instructions de configuration ou de désactivation de ces paramètres sont fournies dans la section suivante.

    Remarque :
    Si un message d'erreur du serveur proxy s'affiche, vous devrez peut-être configurer les paramètres du serveur proxy afin que les adresses locales contournent celui-ci. La section suivante indique plus loin comment configurer les paramètres du serveur proxy.

Configurer les paramètres du navigateur

Après avoir exécuté l'Assistant Configuration des produits SharePoint, assurez-vous que SharePoint Foundation fonctionne correctement pour les administrateurs locaux de votre environnement, en configurant des paramètres supplémentaires dans Internet Explorer.

Remarque :
Si les administrateurs locaux n'utilisent pas Internet Explorer, vous devez configurer des paramètres supplémentaires. Pour plus d'informations sur les navigateurs pris en charge, voir Planifier la prise en charge des navigateurs (SharePoint Foundation 2010).

Effectuez les procédures suivantes si vous êtes invité à entrer votre nom d'utilisateur et votre mot de passe :

  • Ajouter le site Web Administration centrale de SharePoint à la liste des sites de confiance

  • Désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer

Effectuez la procédure suivante si vous recevez un message d'erreur du serveur proxy :

  • Configurer les paramètres du serveur proxy de manière à ne pas utiliser de serveur proxy pour les adresses locales

Pour plus d'informations, voir Prise en main d'IEAK 8 (http://go.microsoft.com/fwlink/?linkid=151359&clcid=0x40C).

Pour ajouter le site Web Administration centrale de SharePoint à la liste des sites de confiance

  1. Dans Internet Explorer, dans le menu Outils, cliquez sur Options Internet.

  2. Dans l'onglet Sécurité, dans la zone Sélectionner une zone pour afficher ou modifier les paramètres de sécurité, cliquez sur Sites de confiance, puis sur Sites.

  3. Désactivez la case à cocher Exiger un serveur sécurisé (https:) pour tous les sites de cette zone.

  4. Dans la zone Ajouter ce site Web à la zone, tapez l'URL de votre site, puis cliquez sur Ajouter.

  5. Cliquez sur Fermer pour fermer la boîte de dialogue Sites de confiance.

  6. Cliquez sur OK pour fermer la boîte de dialogue Options Internet.

    Si vous utilisez un serveur proxy dans votre organisation, procédez comme suit pour configurer Internet Explorer de manière à ne pas utiliser de serveur proxy pour les adresses locales.

Pour désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Outils d'administration, puis cliquez sur Gestionnaire de serveur.

  2. Dans Gestionnaire de serveur, sélectionnez la racine de Gestionnaire de serveur.

  3. Dans la section Informations sur la sécurité, cliquez sur Paramétrer la Configuration de sécurité renforcée d'Internet Explorer.

    La boîte de dialogue Configuration de sécurité renforcée d'Internet Explorer s'ouvre.

  4. Dans la section Administrateurs, cliquez sur Désactivé pour désactiver les paramètres de configuration de sécurité renforcée d'Internet Explorer, puis cliquez sur OK.

Pour configurer les paramètres du serveur proxy de manière à ne pas utiliser de serveur proxy pour les adresses locales

  1. Dans Internet Explorer, dans le menu Outils, cliquez sur Options Internet.

  2. Sous l'onglet Connexions, dans la zone Paramètres du réseau local, cliquez sur Paramètres réseau.

  3. Dans la zone Configuration automatique, désactivez la case à cocher Détecter automatiquement les paramètres de connexion.

  4. Dans la zone Serveur proxy, activez la case à cocher Utiliser un serveur proxy pour votre réseau local.

  5. Tapez l'adresse du serveur proxy dans la zone Adresse.

  6. Tapez le numéro de port du serveur proxy dans la zone Port.

  7. Activez la case à cocher Ne pas utiliser de serveur proxy pour les adresses locales.

  8. Cliquez sur OK pour fermer la boîte de dialogue Paramètres du réseau local.

  9. Cliquez sur OK pour fermer la boîte de dialogue Options Internet.

Étapes postérieures à l'installation

Une fois l'installation de SharePoint Foundation 2010 terminée, la fenêtre du navigateur s'ouvre sur le site Web Administration centrale de SharePoint de votre nouveau site SharePoint. Bien qu'il soit possible d'ajouter du contenu ou de personnaliser le site, il est recommandé d'effectuer tout d'abord les tâches administratives suivantes dans le site Web Administration centrale de SharePoint.

  • Configurer la collecte de données d'utilisation et d'intégrité Vous pouvez configurer la collecte de données d'utilisation et d'intégrité dans votre batterie de serveurs. Le système écrit les données d'utilisation et d'intégrité dans le dossier de journalisation et dans la base de données de journalisation. Pour plus d'informations, voir Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010).

  • Configurer la journalisation des diagnostics Vous pouvez configurer la journalisation des diagnostics, qui est éventuellement nécessaire après un déploiement ou une mise à niveau initiale. Les paramètres par défaut suffisent pour la plupart des situations, mais en fonction des besoins et du cycle de vie de la batterie de serveurs, vous pouvez modifier ces paramètres. Pour plus d'informations, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

  • Configurer le courrier électronique entrant Vous pouvez configurer le courrier électronique entrant afin que les sites SharePoint acceptent et archivent le courrier électronique entrant. Vous pouvez également configurer le courrier électronique de sorte que les sites SharePoint puissent archiver les discussions électroniques en simultané, enregistrer des documents envoyés par messagerie électronique et afficher sur les calendriers du site les réunions notifiées par courrier électronique. De plus, vous pouvez configurer le service de gestion d'annuaire SharePoint pour qu'il prenne en charge la création et la gestion de listes de distribution électroniques. Pour plus d'informations, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

  • Configurer le courrier électronique sortant Vous pouvez configurer le courrier électronique sortant de façon à ce que votre serveur SMTP (Simple Mail Transfer Protocol) envoie des alertes par courrier électronique aux utilisateurs du site et des notifications aux administrateurs. L'adresse de l'émetteur du message et l'adresse de réponse qui apparaissent dans les alertes sortantes peuvent toutes deux être personnalisées. Pour plus d'informations, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010).

  • Configurer un compte mobile Vous pouvez configurer un compte mobile de telle sorte que SharePoint envoie des alertes sous la forme de messages texte (SMS) vers votre téléphone mobile ou vers celui des utilisateurs du site. Pour plus d'informations, voir Configurer un compte mobile (SharePoint Foundation 2010).

  • Installer et configurer le stockage BLOB distant Vous pouvez installer et configurer le stockage BLOB distant d'une instance de SQL Server 2008 qui prend en charge une batterie de serveurs SharePoint. Pour plus d'informations, voir Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010).

Configurer l'utilitaire de sauvegarde de Windows Server

Pour employer l'utilitaire de sauvegarde de Windows Server avec SharePoint Foundation 2010, vous devez inscrire l'enregistreur VSS de SharePoint 2010 auprès de l'utilitaire de sauvegarde de Windows Server en exécutant la commande stsadm -o registerwsswriter. Pour plus d'informations, voir Registerwsswriter : opération Stsadm (Windows SharePoint Services).

Historique des modifications


Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010)

Cet article explique comment installer Microsoft SharePoint Foundation 2010 sur plusieurs serveurs pour créer une batterie de serveurs Microsoft SharePoint Foundation déployée sur trois niveaux. La batterie de serveurs se compose de deux serveurs Web frontaux, d'un serveur d'applications et d'un serveur de base de données. La séquence de déploiement et les configurations décrites dans cet article reposent sur des meilleures pratiques recommandées. La configuration de batterie de serveurs obtenue n'est pas complexe, mais elle fournit une infrastructure fondamentale pour l'implémentation d'une solution SharePoint Foundation dans des batteries de serveurs similaires ou plus complexes.

La batterie de serveurs est déployée avec le service Recherche de SharePoint Foundation ; ce service est configuré de manière à analyser le contenu créé dans le cadre de ce déploiement.

Dans cet article :

  • Présentation

  • Préparer les serveurs de la batterie de serveurs

  • Installer SharePoint Foundation 2010 sur les serveurs de la batterie de serveurs

  • Créer et configurer la batterie de serveurs

  • Ajouter des serveurs Web à la batterie de serveurs

  • Configurer la journalisation des diagnostics et la collection des données d'utilisation et d'intégrité

  • Configurer le service Recherche de SharePoint Foundation

  • Créer un site

  • Étapes postérieures à l'installation

Présentation

Les étapes de base de ce déploiement sont les suivantes :

  • Assurez-vous que vous êtes familiarisé avec le concept d'une topologie à trois niveaux.

  • Assurez-vous que vous avez réalisé la totalité des tâches de planification et de préparation, telles que la vérification des configurations matérielle et logicielle requises.

  • Installez les mises à jour logicielles requises sur tous les serveurs destinés à faire partie de la batterie de serveurs.

  • Installez les éléments prérequis pour SharePoint Foundation sur les serveurs des niveaux application et Web.

  • Installez SharePoint Foundation sur le serveur d'applications et sur les serveurs Web.

  • Créez et configurez la batterie de serveurs SharePoint.

  • Déployez les services.

  • Effectuez les tâches postérieures au déploiement, le cas échéant.

Présentation de la topologie

Cette topologie est généralement utilisée pour les batteries de serveurs de tailles moyenne et grande décrites dans Vue d'ensemble du déploiement (SharePoint Foundation 2010). En termes de performances, de capacité et d'évolutivité, une topologie à trois niveaux est préférable à une topologie à deux niveaux. Une topologie à trois niveaux fournit la configuration physique et logique la plus efficace pour la prise en charge de la montée en puissance parallèle ou de la montée en puissance par unité et offre une meilleure répartition des services parmi les serveurs membres de la batterie de serveurs. L'illustration suivante montre le déploiement sur trois niveaux décrit dans cet article.

SharePoint Foundation 2010 : Batterie de serveurs à trois niveaux

En vous référant à l'illustration précédente, notez ce qui suit :

  • Vous pouvez ajouter des serveurs Web à la couche Web. Ces serveurs peuvent être configurés en tant que serveurs Web conventionnels pour la gestion des requêtes des utilisateurs.

  • Vous pouvez ajouter des serveurs de batterie de serveurs à la couche Application et les configurer en tant que serveurs dédiés qui hébergeront le site Web Administration centrale ou d'autres services de la batterie de serveurs qui nécessitent des ressources dédiées ou une isolation par rapport à la couche Web (par exemple, des travaux de minuteur et des services bac à sable (sandbox)).

  • Vous pouvez ajouter des serveurs de base de données au niveau base de données pour implémenter une instance autonome, la mise en miroir de base de données ou un cluster de basculement. Si vous configurez la batterie de serveurs afin qu'elle offre un haut niveau de disponibilité, la mise en miroir de base de données ou un cluster de basculement est nécessaire au niveau base de données.

Avant de commencer

Avant de commencer le déploiement, procédez aux vérifications suivantes :

  • Assurez-vous que vous êtes familiarisé avec les instructions liées au système d'exploitation décrites dans Instructions pour régler les performances de Windows Server 2008 (éventuellement en anglais) et Instructions pour régler les performances de Windows Server 2008 R2 (éventuellement en anglais).

  • Assurez-vous que vous respectez en totalité les configurations matérielle et logicielle requises. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

  • Assurez-vous que vous êtes prêt à configurer les comptes requis avec les autorisations appropriées, comme décrit dans Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010)

    Remarque :
    Pour des raisons de sécurité, il est recommandé d'installer SharePoint Foundation en utilisant l'administration selon le principe des privilèges minimum.

Utilisation de l'outil de préparation des produits Microsoft SharePoint 2010

L'Outil de préparation des produits Microsoft SharePoint vérifie l'existence d'éléments prérequis, puis installe et configure tous les programmes nécessaires. L'Outil de préparation des produits Microsoft SharePoint requiert une connexion Internet pour télécharger et configurer les éléments prérequis pour SharePoint Foundation. Si vous ne disposez pas d'une connexion Internet pour les serveurs de la batterie de serveurs, vous devez obtenir des images installables pour les logiciels requis. Pour connaître les emplacements d'installation, voir Configuration logicielle requise dans « Déterminer les configurations matérielle et logicielle requises (SharePoint Foundation 2010) ».

Si vous décidez d'obtenir des images installables, il est recommandé de créer un point d'installation que vous pouvez utiliser pour le stockage de ces images. Vous pourrez utiliser ce point d'installation pour installer les mises à jour logicielles futures.

Serveur de base de données

Assurez-vous que SQL Server 2005 ou SQL Server 2008 est mis à jour vers le niveau requis et configuré comme suit :

  • SQL Server 2005 : les connexions locales et distantes sont activées et sont configurées de manière à utiliser le protocole TCP/IP.

  • SQL Server 2008 : le protocole TCP/IP est activé pour la configuration du réseau.

Dans les organisations dont les administrateurs de base de données opèrent indépendamment des administrateurs SharePoint, vous devez vous assurer que la version adéquate de SQL Server est disponible et mise à jour vers le niveau requis. En outre, vous devez demander une base de données créée par l'administrateur de base de données qui soit configurée pour votre batterie de serveurs.

Remarque :
Les procédures indiquées dans cet article n'utilisent pas une base de données créée par l'administrateur de base de données ; ces procédures sont différentes dans un déploiement de base de données créée par l'administrateur de base de données. Pour plus d'informations, voir Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010).

Mises à jour publiques et correctifs logiciels

Assurez-vous que les mises à jour publiques et les correctifs logiciels requis sont installés pour le système d'exploitation, SQL Server et SharePoint Foundation. Il est recommandé de mettre à jour tous les serveurs vers la même version logicielle avant d'appliquer les mises à jour publiques. Les correctifs logiciels doivent être appliqués pour cette version de SharePoint Foundation :

  • SQL Server 2008 : installez cette mise à jour avant de déployer la batterie de serveurs. Package de mise à jour cumulative 2 pour SQL Server 2008 Service Pack 1

  • Après avoir installé les éléments prérequis sur chaque serveur de la batterie de serveurs, vous devez installer le correctif Message d'erreur lorsque vous utilisez la méthode « IMSAdminBase::CopyKey » en tant qu'élément des composants IIS 6.0 Compatibility dans IIS 7.0 : « Exception de HRESULT : 0x80070003 » d'abord sur le serveur d'applications, puis sur les deux serveurs Web.

Préparer les serveurs de la batterie de serveurs

Avant d'installer SharePoint Foundation, vous devez rechercher tous les éléments prérequis et les installer sur le serveur d'applications et sur les serveurs Web à l'aide de l'Outil de préparation des produits Microsoft SharePoint.

Conseil :
Si vous décidez d'installer les éléments prérequis manuellement, vous pouvez quand même exécuter l'Outil de préparation des produits Microsoft SharePoint pour déterminer les éléments prérequis nécessaires sur chaque serveur.

Utilisez la procédure suivante pour installer les éléments prérequis sur chaque serveur de la batterie de serveurs.

Pour exécuter l'outil de préparation

  1. Téléchargez SharePoint Foundation 2010 (http://go.microsoft.com/fwlink/?linkid=168781&clcid=0x40C) à partir de l'emplacement d'installation du produit, puis double-cliquez sur le fichier exécutable approprié.

  2. Si vous effectuez l'installation à partir d'une image de démarrage, cliquez sur Installer les éléments logiciels requis dans l'écran de démarrage.

  3. Si vous effectuez l'installation à partir d'une collection de fichiers, double-cliquez sur PrerequisiteInstaller.exe.

  4. Dans la page d'accueil de l'Outil de préparation des produits Microsoft SharePoint, cliquez sur Suivant.

    Remarque :
    L'outil de préparation peut avoir besoin de redémarrer le serveur local pour terminer l'installation des éléments prérequis. Le programme d'installation continue de s'exécuter une fois le serveur redémarré et aucune intervention manuelle n'est requise. Toutefois, vous devrez vous reconnecter au serveur.

  5. Dans la page indiquant que l'installation est terminée, cliquez sur Terminer.

    Remarque :
    Au terme de l'exécution de l'Outil de préparation des produits Microsoft SharePoint, vous devez installer le correctif 949516 de la Base de connaissances (http://go.microsoft.com/fwlink/?linkid=148917&clcid=0x40C) et le correctif 971831 de la Base de connaissances (http://support.microsoft.com/kb/971831/fr/fr/fr/fr). Vous pouvez également être amené à redémarrer le serveur après avoir installé ce correctif logiciel.

    Remarque :
    Si le message d'erreur « Le chargement de cet assembly produirait un jeu accordé différent des autres instances. (Exception à partir de HRESULT : 0x80131401) » est affiché lorsque vous démarrez le processus de travail IIS (w3wp.exe), un autre service ou une application gérée sur un serveur qui exécute également SharePoint Foundation 2010, vous devez installer KB963676 (http://go.microsoft.com/fwlink/?linkid=151358&clcid=0x40C). Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Installer SharePoint Foundation 2010 sur les serveurs de la batterie de serveurs

Après avoir installé les éléments prérequis, utilisez la procédure suivante pour installer SharePoint Foundation sur chaque serveur de la batterie de serveurs.

Pour exécuter le programme d'installation

  1. Dans la page de démarrage, cliquez sur Installer SharePoint Foundation.

  2. Dans la page Lire les termes du contrat de licence logiciel Microsoft, passez en revue les termes, activez la case à cocher J'accepte les termes de ce contrat, puis cliquez sur Continuer.

  3. Dans la page Choisir l'installation voulue, cliquez sur Batterie de serveurs.

  4. Sous l'onglet Type de serveur, cliquez sur Complète.

  5. Sous l'onglet Emplacement du fichier, acceptez l'emplacement par défaut ou modifiez le chemin d'accès d'installation, puis cliquez sur Installer maintenant.

    Remarque :
    En guise de meilleure pratique, il est recommandé d'installer SharePoint Foundation sur un lecteur non-système.

  6. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Désactivez la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint.

    Remarque :
    À des fins de cohérence méthodologique, il est recommandé de n'exécuter l'Assistant de configuration qu'une fois SharePoint Foundation installé sur la totalité des serveurs d'applications et des serveurs Web frontaux qui feront partie de la batterie de serveurs.

  7. Cliquez sur Fermer pour terminer l'installation.

Créer et configurer la batterie de serveurs

Pour créer et configurer la batterie de serveurs, vous exécutez l'Assistant Configuration des produits SharePoint. Cet Assistant automatise plusieurs tâches de configuration, dont la création de la base de données de configuration, l'installation des services et la création du site Web Administration centrale. Il est recommandé d'exécuter l'Assistant Configuration des produits SharePoint sur le serveur destiné à héberger le site Web Administration centrale avant de l'exécuter sur les autres serveurs de la batterie de serveurs.

Pour exécuter l'Assistant de configuration et configurer la batterie de serveurs

  1. Sur le serveur destiné à héberger l'Administration centrale (serveur d'applications), cliquez sur Démarrer, pointez sur Tous les programmes, puis cliquez sur Produits Microsoft SharePoint 2010.

  2. Dans la liste des options disponibles, cliquez sur Assistant Configuration des produits et technologies SharePoint.

  3. Dans la page Bienvenue dans les produits SharePoint, cliquez sur Suivant.

  4. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés au cours de la configuration, cliquez sur Oui.

  5. Dans la page Se connecter à une batterie de serveurs, cliquez sur Créer une batterie de serveurs, puis cliquez sur Suivant.

  6. Dans la page Spécifier les paramètres de la base de données de configuration, effectuez les opérations suivantes :

    1. Dans la zone Serveur de base de données, tapez le nom de l'ordinateur exécutant SQL Server.

    2. Dans la zone Nom de la base de données, tapez un nom pour votre base de données de configuration, ou utilisez le nom de base de données par défaut. Le nom par défaut est SharePoint_Config.

    3. Dans la zone Nom d'utilisateur, tapez le nom d'utilisateur du compte de batterie de serveurs sous la forme DOMAINE\nom_utilisateur.

      Important :
      La batterie de serveurs sert à créer votre base de données de configuration et à y accéder. Elle sert également d'identité de pool d'applications pour le compte de pool d'applications de l'Administration centrale de SharePoint, et elle correspond au compte sous lequel s'exécute le service Minuteur Windows SharePoint Services. L'Assistant Configuration des produits SharePoint ajoute ce compte aux comptes de connexions SQL Server, au rôle serveur dbcreator SQL Server et au rôle serveur securityadmin SQL Server. Le compte d'utilisateur que vous spécifiez en tant que compte de service doit être un compte d'utilisateur de domaine, mais ne doit pas obligatoirement être membre d'un groupe de sécurité spécifique sur vos serveurs Web ou vos serveurs de base de données. Nous vous recommandons de suivre le principe du moindre privilège et de spécifier un compte d'utilisateur qui n'est pas membre du groupe Administrateurs sur vos serveurs Web ou vos serveurs de base de données.

    4. Dans la zone Mot de passe, tapez le mot de passe de l'utilisateur.

  7. Cliquez sur Suivant.

  8. Dans la page Spécifier les paramètres de sécurité de la batterie de serveurs, tapez un mot de passe, puis cliquez sur Suivant.

    Assurez-vous que le mot de passe satisfait aux critères suivants :

    • Il contient au moins huit caractères.

    • Il contient au moins trois des quatre groupes de caractères suivants :

      • Il utilise des majuscules non accentuées (A à Z).

      • Il utilise des minuscules non accentuées (a à z).

      • Il utilise des chiffres (0 à 9).

      • Il utilise des caractères non alphabétiques (comme !, $, #, %).

      Remarque :
      Bien qu'une phrase secrète soit similaire à un mot de passe, elle est généralement plus longue afin que la sécurité s'en trouve renforcée. Elle permet de chiffrer les informations d'identification des comptes inscrits dans SharePoint Foundation 2010, tels que le compte système SharePoint Foundation 2010 que vous fournissez lorsque vous exécutez l'Assistant Configuration des produits SharePoint. Veillez à vous souvenir du mot de passe choisi, car vous devez l'utiliser chaque fois que vous ajoutez un serveur à la batterie de serveurs.

  9. Dans la page Configurer l'application Web Administration centrale de SharePoint, procédez comme suit :

    1. Activez la case à cocher Spécifiez le numéro de port et tapez un numéro de port si vous souhaitez que l'application Web Administration centrale de SharePoint utilise un numéro de port spécifique ou laissez la case à cocher Spécifiez le numéro de port désactivée si vous souhaitez utiliser le numéro de port par défaut.

      Remarque :
      Pour accéder au site Web Administration centrale de SharePoint à partir d'un ordinateur distant, assurez-vous que vous autorisez l'accès au numéro de port que vous configurez à cette étape. Pour ce faire, configurez la règle de trafic entrant pour Administration centrale SharePoint v4 dans Pare-feu Windows avec fonctions avancées de sécurité.

    2. Cliquez sur NTLM ou Négocier (Kerberos).

  10. Cliquez sur Suivant.

  11. Dans la page Configuration réussie, cliquez sur Terminer.

    Remarque :
    Si l'Assistant Configuration des produits SharePoint échoue, vérifiez les fichiers journaux sur le lecteur sur lequel SharePoint Foundation 2010 est installé, dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\LOGS.

  12. Le site Web Administration centrale s'ouvre dans une nouvelle fenêtre de navigateur.

    Dans la page Contribuer à l'amélioration de SharePoint, cliquez sur l'une des options suivantes, puis cliquez sur OK.

    1. Oui, j'accepte de participer (recommandé).

    2. Non, je ne souhaite pas participer.

  13. Dans la page Configuration de votre batterie SharePoint, vous avez la possibilité d'utiliser un Assistant pour configurer les services ou vous pouvez configurer ceux-ci manuellement. Dans le cadre de cet article, nous utilisons l'option de configuration manuelle. Cliquez sur Annuler.

    Le choix que vous opérez ici relève de vos préférences personnelles. L'Assistant Configuration de batterie de serveurs configure certains services automatiquement lorsqu'il est exécuté ; toutefois, la configuration manuelle des services offre beaucoup plus de souplesse pour la conception de l'architecture logique.

    Pour plus d'informations sur l'utilisation de l'Assistant pour configurer les services, voir Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010).

    Important :
    Si vous utilisez une base de données créée par l'administrateur de base de données, vous ne pouvez pas utiliser l'Assistant Configuration de batterie de serveurs ; vous devez utiliser l'Assistant Configuration des produits SharePoint.

Ajouter des serveurs Web à la batterie de serveurs

Après avoir créé la batterie de serveurs sur le serveur d'applications, vous pouvez ajouter les serveurs de la couche Web en suivant le processus décrit plus haut dans cette rubrique pour l'installation de SharePoint Foundation sur le serveur qui héberge l'Administration centrale. La seule différence est que durant l'installation, vous êtes invité à rejoindre une batterie de serveurs existante. Suivez les étapes de l'Assistant pour rejoindre la batterie de serveurs.

Pour plus d'informations sur l'ajout de serveurs à une batterie de serveurs, voir Ajouter un serveur Web ou un serveur d'applications à la batterie (SharePoint Foundation 2010). Cet article fournit également des informations détaillées sur les étapes de la procédure suivante.

Configurer la journalisation des diagnostics et la collection des données d'utilisation et d'intégrité

Après avoir ajouté les serveurs Web frontaux, configurez la journalisation des diagnostics et la collection des données d'utilisation et d'intégrité initiales pour la batterie de serveurs.

La journalisation des diagnostics permet d'identifier et d'isoler les problèmes à mesure qu'ils se produisent dans votre batterie de serveurs. Acceptez les valeurs par défaut lorsque vous configurez la journalisation des diagnostics sur de nouvelles installations. Ensuite, lorsque des problèmes se produisent dans votre batterie de serveurs, vous pouvez revenir sur ces valeurs et ajuster leurs niveaux en conséquence. Ainsi, vous pouvez identifier la cause et isoler les problèmes. La création de rapports sur l'utilisation et l'intégrité permet de pointer les écarts entre les paramètres de journalisation des diagnostics et les valeurs par défaut.

Pour plus d'informations sur l'utilisation des diagnostics et des données d'intégrité, voir :

  • Configurer la journalisation des diagnostics (SharePoint Foundation 2010)

  • Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010)

Utilisez les procédures suivantes pour accomplir la configuration initiale de la journalisation des diagnostics et de la collection des données d'utilisation et d'intégrité.

Remarque :
Étant donné qu'il s'agit d'un déploiement de batterie de serveurs initial sans données de référence, les valeurs par défaut sont acceptées, sauf indication contraire.

Pour configurer la journalisation des diagnostics

  1. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  2. Dans la section Rapports, cliquez sur Configurer la journalisation des diagnostics.

  3. Dans la page Journalisation des diagnostics, vérifiez que l'option Activer la protection de flux du journal des événements est sélectionnée. Si ce n'est pas le cas, cliquez sur la case à cocher correspondante pour activer cette fonctionnalité.

  4. Par défaut, le journal de suivi se trouve sur le lecteur sur lequel vous avez installé SharePoint Foundation. En guise de meilleure pratique, il est recommandé de stocker le journal de suivi sur un lecteur non-système.

    Important :
    Si vous modifiez le chemin d'accès du journal de suivi en faveur d'un lecteur non-système, cet emplacement doit exister sur tous les serveurs de la batterie de serveurs. Les serveurs existants ou nouveaux ne peuvent pas journaliser des données si l'emplacement n'existe pas. En outre, vous ne pourrez ajouter de nouveaux serveurs que si le chemin d'accès que vous spécifiez existe sur ceux-ci. Vous ne pouvez pas utiliser un partage réseau à des fins de journalisation.

  5. Cliquez sur OK pour enregistrer vos modifications.

Après avoir configuré la journalisation des diagnostics, configurez la collection des données d'utilisation et d'intégrité.

Pour configurer la collection des données d'utilisation et d'intégrité

  • Dans la page Analyse de l'Administration centrale, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  • Activez la case à cocher Collection des données d'utilisation.

  • Activez la case à cocher Collecte des données d'intégrité.

  • Cliquez sur OK.

Configurer le service Recherche de SharePoint Foundation

Le service Recherche de SharePoint Foundation est automatiquement installé lorsque vous installez SharePoint Foundation. Toutefois, le service de recherche n'est pas démarré et certaines tâches de configuration sont nécessaires.

Utilisez la procédure suivante pour configurer et démarrer la recherche pour la batterie de serveurs SharePoint Foundation.

Pour configurer le service Recherche de SharePoint Foundation

  1. Dans la page d'accueil de l'Administration centrale, cliquez sur Gérer les services sur le serveur.

  2. Dans la page Services sur le serveur, cliquez sur Recherche SharePoint Foundation. Cette opération ouvre la page Configurer les paramètres du service Recherche de Microsoft SharePoint Foundation, qui vous permet de configurer les paramètres suivants.

  3. Dans la section Compte de service, tapez un nom d'utilisateur et un mot de passe.

  4. Dans la section Compte d'accès au contenu, tapez un nom d'utilisateur et un mot de passe pour un compte qui disposera d'un accès en lecture seule à la totalité du contenu.

    Sécurité Remarque :
    N'utilisez pas de compte doté de privilèges élevés ou pouvant modifier le contenu.

  5. Cliquez sur OK pour enregistrer les modifications que vous avez apportées à la configuration.

  6. Dans la page Services sur le serveur, cliquez sur Démarrer pour démarrer le service Recherche de SharePoint Foundation.

Créer un site

Pour créer un site pendant cette phase du déploiement, vous devez créer une application Web et une collection de sites. Utilisez les procédures suivantes pour créer une application Web à l'aide de l'Administration centrale, puis créez un site Web de niveau supérieur associé à l'application Web.

Pour créer une application Web

  1. Dans la page d'accueil de l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  2. Dans le Ruban, cliquez sur Nouveau.

  3. Dans la section Authentification de la page Créer une application Web, activez la case à cocher Authentification en mode classique

  4. Dans la section Site Web IIS, cliquez sur Créer un nouveau site Web IIS.

  5. Conservez la valeur par défaut pour Port ou tapez un nouveau numéro de port.

  6. Ne modifiez pas la valeur par défaut de la zone Chemin d'accès.

  7. Dans la section Configuration de la sécurité, cliquez sur NTLM en guise de fournisseur d'authentification.

  8. Dans la section Pool d'applications, cliquez sur Créer un nouveau pool d'applications.

  9. Cliquez sur Configurable.

  10. Sélectionnez un compte géré dans la liste déroulante ou cliquez sur Enregistrer le nouveau compte géré.

  11. Pour Nom de la base de données et authentification, cliquez sur Authentification Windows (recommandée).

  12. Pour Connexions aux applications de service, ouvrez la liste déroulante Modifier le groupe de connexions suivant, cliquez sur [personnalisé], puis cliquez sur Application de service de recherche.

  13. Pour Programme d'amélioration du produit, cliquez sur Oui.

  14. Cliquez sur OK.

Pour créer une collection de sites

  1. Dans la page d'accueil de l'Administration centrale, dans la section Gestion des applications, cliquez sur Créer des collections de sites.

  2. Dans la section Application Web, vérifiez que le nom affiché est celui de l'application Web que vous avez créée pendant la procédure précédente. Si ce n'est pas le cas, cliquez sur la flèche en regard de la liste déroulante, puis cliquez sur Modifier Application Web dans le menu qui apparaît.

  3. Dans la page Sélectionner une application Web, cliquez sur le nom de l'application Web que vous avez créée, puis cliquez sur OK.

  4. Dans la section Titre et description, entrez le titre et la description de votre collection de sites :

  5. Dans la section Adresse du site Web, dans la liste déroulante URL, tapez une barre oblique (/), puis sélectionnez /sites/.

  6. Dans la section Sélection du modèle, cliquez sur l'onglet Collaboration, puis cliquez sur Site d'équipe.

  7. Dans la section Administrateur principal de la collection de sites, tapez la connexion utilisateur sous la forme DOMAINE\nom d'utilisateur.

  8. Dans la section Administrateur secondaire de la collection de sites, tapez la connexion utilisateur sous la forme DOMAINE\nom d'utilisateur.

  9. Dans la section Modèle de quota, conservez la valeur par défaut.

  10. Cliquez sur OK.

Une fois la collection de sites créée, la page Site Web de niveau supérieur créé avec succès apparaît. Cliquez sur le lien pointant vers le nouveau site. Si une boîte de dialogue d'authentification apparaît, entrez les informations de connexion de l'administrateur de site sous la forme DOMAINE\nom d'utilisateur.

Remarque :
Ce nouveau site est automatiquement déployé sur les serveurs du niveau Web.

Étapes postérieures à l'installation

Une fois que vous avez installé et configuré SharePoint Foundation 2010, la fenêtre du navigateur s'ouvre sur le site Web Administration centrale de SharePoint de votre nouveau site SharePoint. Bien qu'il soit possible d'ajouter du contenu ou de personnaliser le site, il est recommandé d'effectuer tout d'abord les tâches administratives suivantes dans le site Web Administration centrale de SharePoint.

  • Configurer le courrier électronique sortant Vous pouvez configurer le courrier électronique sortant de façon à ce que votre serveur SMTP (Simple Mail Transfer Protocol) envoie des alertes par courrier électronique aux utilisateurs du site et des notifications aux administrateurs. L'adresse de l'émetteur du message et l'adresse de réponse qui apparaissent dans les alertes sortantes peuvent toutes deux être personnalisées. Pour plus d'informations, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010).

    Remarque :
    Vous pouvez configurer la réception du courrier électronique de façon à ce que les sites SharePoint acceptent et archivent le courrier entrant. Toutefois, il est recommandé de réaliser cette tâche après avoir effectué le déploiement et la configuration initiaux de la batterie de serveurs. Pour plus d'informations, voir Configurer le courrier électronique entrant (SharePoint Foundation 2010).

  • Configurer un compte mobile Vous pouvez configurer un compte mobile de telle sorte que SharePoint envoie des alertes sous la forme de messages texte (SMS) vers votre téléphone mobile ou vers celui des utilisateurs du site. Pour plus d'informations, voir Configurer un compte mobile (SharePoint Foundation 2010).

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Démarrage rapide : déployer un serveur unique dans un environnement Hyper-V isolé (SharePoint Foundation 2010)

Vous pouvez utiliser un ordinateur virtuel Hyper-V isolé et sécurisé pour tester les fonctionnalités et le comportement de SharePoint Foundation 2010. Cette méthode utilise des ressources matérielles minimes et vous permet d'isoler le système de test SharePoint Foundation 2010 d'un environnement de production. Cette isolation est recommandée pour éliminer les menaces de sécurité pouvant peser sur un environnement serveur ou de réseau d'entreprise.

En utilisant les étapes manuelles ou les commandes Windows PowerShell 2.0 fournies dans cet article, vous pouvez rapidement déployer SharePoint Foundation 2010 sur un serveur spécifique qui utilise l'une des bases de données suivantes :

  • Base de données SQL Server 2008 Express et SQL Server 2008 R2 Express intégrée fournie avec SharePoint Foundation

  • Microsoft SQL Server 2005 avec Service Pack 3 (SP3) et mise à jour cumulative 3 installés

  • SQL Server 2008 avec SP1 et mise à jour cumulative 2

Important :
Le déploiement de SharePoint Foundation sur un serveur unique décrit dans cet article est uniquement destiné à être utilisé à des fins d'évaluation et de test, et ne doit pas être utilisé dans un environnement de production.

Dans cet article :

  • Configuration requise et recommandations

  • Autorisations requises

  • Tâches de prédéploiement

  • Déployer SharePoint Foundation 2010 manuellement

  • Déployer SharePoint Foundation 2010 à l'aide de scripts Windows PowerShell

Configuration requise et recommandations

La configuration requise et les recommandations suivantes pour le serveur de virtualisation Hyper-V, l'ordinateur virtuel et l'environnement de déploiement ne s'appliquent qu'au scénario de déploiement à serveur unique décrit dans cet article.

Configuration du serveur de virtualisation et de l'ordinateur virtuel

Le tableau suivant fournit la configuration minimale et celle recommandée pour le serveur de virtualisation et les ordinateurs virtuels. Ces configurations prennent en charge les options de base de données disponibles pour un déploiement à serveur unique.

Ressource Configuration minimale Configuration recommandée

Processeur

Biprocesseur, 2 gigahertz (GHz)

Biprocesseur, 2 GHz

Mémoire

4 gigaoctets (Go)

8 Go

Disque dur

Disque dur virtuel de taille fixe, ayant une capacité de 40 Go

Conseil :
Pour accélérer la création d'un disque dur virtuel de taille fixe, configurez initialement le disque dur en disque avec extension dynamique. Après avoir installé tous les logiciels requis (y compris SharePoint Foundation), convertissez le disque dur virtuel en un disque dur de taille fixe.

Disque dur virtuel de taille fixe, ayant une capacité de 80 Go

Type de carte réseau

Synthétique

Synthétique

Type de réseau

Interne pour garantir l'isolation de l'ordinateur virtuel et activer les communications serveur de virtualisation-ordinateur virtuel.

Conseil :
Pour simplifier l'accès aux logiciels requis et recommandés, ainsi que leur installation, utilisez un réseau externe. Lorsque vous êtes prêt à installer SharePoint Foundation, configurez les ordinateurs virtuels pour qu'ils utilisent un réseau interne.

Interne pour garantir l'isolation de l'ordinateur virtuel et activer les communications serveur de virtualisation-ordinateur virtuel.

Les indications suivantes concernent la configuration du serveur de virtualisation :

  • Le ratio processeur logique/virtuel (cœur) doit être aussi faible que possible, 1:1 constituant le taux optimal.

  • En utilisant le ratio processeur logique/virtuel 1:1, vous devez configurer le serveur de virtualisation de manière à ce que le nombre total de processeurs sur les ordinateurs virtuels soit inférieur au nombre total de cœurs physiques. Par exemple, si vous utilisez un serveur de virtualisation à quatre cœurs, la meilleure pratique consiste à créer trois ordinateurs virtuels qui utilisent un seul processeur, ou un ordinateur virtuel doté de deux processeurs et un ordinateur virtuel utilisant un processeur. Ces deux configurations permettent de dédier un cœur aux processus du serveur de virtualisation.

En plus des configurations requises précédentes concernant l'environnement virtuel, consultez l'article Configuration matérielle et logicielle requise (SharePoint Foundation 2010) avant de déployer SharePoint Foundation 2010 sur l'ordinateur virtuel.

Environnement du déploiement

Un domaine est requis pour le déploiement de SharePoint Foundation 2010.

Si vous n'avez pas de domaine virtuel isolé disponible pour déployer SharePoint Foundation 2010, vous devez créer un domaine virtuel sur un serveur Hyper-V configuré de manière à utiliser les éléments suivants :

  • un contrôleur de domaine avec les services de domaine Active Directory (AD DS) ;

  • un contrôleur de domaine avec un serveur DNS.

Vous pouvez déployer SharePoint Foundation sur un contrôleur de domaine. Toutefois, une configuration est nécessaire. Démarrez Windows PowerShell en utilisant l'option Exécuter en tant qu'administrateur, puis exécutez les commandes suivantes pour activer le déploiement sur un contrôleur de domaine :

Code de copie
$acl = Get-Acl HKLM:\System\CurrentControlSet\Control\ComputerName
$person = [System.Security.Principal.NTAccount]"Users"
$access = [System.Security.AccessControl.RegistryRights]::FullControl
$inheritance = [System.Security.AccessControl.InheritanceFlags]"ContainerInherit, ObjectInherit"
$propagation = [System.Security.AccessControl.PropagationFlags]::None
$type = [System.Security.AccessControl.AccessControlType]::Allow
$rule = New-Object System.Security.AccessControl.RegistryAccessRule($person, $access, $inheritance, $propagation, $type)
$acl.AddAccessRule($rule)
Set-Acl HKLM:\System\CurrentControlSet\Control\ComputerName $acl

Autorisations requises

Pour installer SharePoint Foundation 2010, il est nécessaire que le compte de connexion que vous utilisez sur l'ordinateur virtuel soit membre :

  • du groupe Administrateurs local sur l'ordinateur virtuel ;

  • du rôle de serveur fixe dbcreator SQL Server ;

  • du rôle de serveur securityadmin SQL Server.

Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

Tâches de prédéploiement

Effectuez les tâches suivantes avant de déployer SharePoint Foundation 2010 :

  • Sur le serveur de virtualisation, créez un point d'installation qui contient le logiciel SharePoint Foundation ou fournissez un support, tel qu'une image ISO, accessible à partir de l'ordinateur virtuel.

  • Créez un ordinateur virtuel qui satisfait aux conditions requises décrites dans la section « Configuration requise et recommandations » plus haut dans cet article.

  • Sur l'ordinateur virtuel :

    • Installez le système d'exploitation et les mises à jour de sécurité obligatoires et recommandées.

    • Installez l'édition de SQL Server que vous souhaitez utiliser si vous ne recourez pas à la version intégrée fournie avec SharePoint Foundation.

    • Installez les mises à jour obligatoires et recommandées pour l'édition de SQL Server que vous installez.

    • Configurez le pare-feu Windows Server pour autoriser l'accès à SQL Server. Pour plus d'informations, voir Configuration du Pare-feu Windows pour autoriser l'accès à SQL Server (http://go.microsoft.com/fwlink/?linkid=134724&clcid=0x40C).

    • Consultez l'article Configuration matérielle et logicielle requise (SharePoint Foundation 2010) pour déterminer les programmes et les correctifs à se procurer et à installer avant d'installer SharePoint Foundation 2010.

Déployer SharePoint Foundation 2010 manuellement

Pour plus d'informations sur le déploiement manuel de SharePoint Foundation 2010 sur un seul serveur, voir Déployer un serveur unique avec une base de données intégrée (SharePoint Foundation 2010) ou Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010).

Déployer SharePoint Foundation 2010 à l'aide de scripts Windows PowerShell

Vous pouvez utiliser des scripts Windows PowerShell pour déployer SharePoint Foundation 2010 sur un seul serveur.

Sécurité Remarque :
Il est fortement recommandé de ne pas exécuter de scripts non signés.

Pour plus d'informations sur la signature des scripts Windows PowerShell, voir Windows PowerShell : signez ici, s'il vous plaît (http://go.microsoft.com/fwlink/?linkid=160357&clcid=0x40C) dans TechNet Magazine. Pour plus d'informations sur la signature de code en général, voir Présentation de la signature de code (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=59273&clcid=0x40C) sur MSDN. Pour plus d'informations sur la configuration de votre propre autorité de certification, voir Services de certificat Active Directory (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=136444&clcid=0x40C) dans la bibliothèque TechNet.

Créez et utilisez l'un des fichiers de script Windows PowerShell suivants pour déployer SharePoint Foundation sur un seul serveur.

  • simplesingleserver.ps1 : installe SharePoint Foundation 2010 en utilisant la base de données intégrée pour stocker les documents et les informations sur la configuration.

  • simplefarm.ps1 : installe SharePoint Foundation 2010 en utilisant SQL Server 2005 ou SQL Server 2008 pour stocker les documents et les informations sur la configuration.

simplesingleserver.ps1

Ce script déploie SharePoint Foundation 2010 sur un serveur unique qui utilise la base de données intégrée.

Copiez le code suivant dans un éditeur de texte et enregistrez-le sous le nom de fichier simplesingleserver.ps1 dans le répertoire de votre choix :

Code de copie

$SetupPath         = Read-Host -Prompt "Please specify the path to the install media (D:)"

## Here is the script to install SharePoint Foundation 2010 with SQL Express and create Central Admin ##
& $SetupPath\PrerequisiteInstaller.exe /unattended | Write-Host
if( $lastexitcode -eq 0 ) {
    & $SetupPath\setup.exe /config $SetupPath\Files\SetupSilent\config.xml | Write-Host
    if( $lastexitcode -eq 0 ) {
        Write-Host "Install successful..."
    } else { Write-Error "ERROR: $lastexitcode" }
} else { Write-Error "ERROR: $lastexitcode" }

Pour exécuter simplesingleserver.ps1

  1. Démarrez Windows PowerShell 2.0 en utilisant l'option Exécuter en tant qu'administrateur.

  2. Accédez au répertoire dans lequel vous avez enregistré simplesingleserver.ps1.

  3. Exécutez .\simplesingleserver.ps1 depuis l'invite de commandes Windows PowerShell.

simplefarm.ps1

Ce script déploie SharePoint Foundation 2010 sur un serveur unique qui utilise une base de données SQL Server. Copiez le code suivant dans un éditeur de texte et enregistrez-le sous le nom de fichier simplefarm.ps1 dans le répertoire de votre choix :

Code de copie

## Settings you may want to change ##
$err = $null
$SetupPath         = Read-Host -Prompt "Please specify the path to the install media (D:)"
Write-Host "Please specify the Farm Administrator credentials"
$FarmCredential    = Get-Credential "DOMAIN\<Farm Admin>"
$DBServer          = Read-Host -Prompt "Please enter the name of your database server"
$Passphrase        = Read-Host -Prompt "Please enter the farm passphrase (optional)" -AsSecureString
$FarmName          = Read-Host -Prompt "Please enter a farm name (optional)"
$CAPort            = Read-Host -Prompt "Please enter the Central Administration port number (optional)"

if ([String]::IsNullOrEmpty($SetupPath))
{
    Write-Error "You must enter the install media path"
    return
}
if ([String]::IsNullOrEmpty($FarmCredential))
{
    Write-Error "You must enter a Farm Administrator's user name and password"
    return
}
if ([String]::IsNullOrEmpty($DBServer))
{
    Write-Error "You must enter a database server"
    return
}
if ($Passphrase.Length -eq 0)
{
    Write-Warning "You didn't enter a farm passphrase, using the Farm Administrator's password instead"
    $Passphrase = $FarmCredential.Password
}
if ([String]::IsNullOrEmpty($FarmName))
{
    Write-Warning "You didn't enter a farm name, using the machine name instead"
    $FarmName = $env:COMPUTERNAME
}
if ([String]::IsNullOrEmpty($CAPort))
{
    Write-Warning "You didn't enter a Central Administration port number, using 5000 instead"
    $CAPort = 5000
}

## Here is the script to install SharePoint Foundation 2010 and create Central Admin ##
Write-Host "[1/15] Running prerequisite installer..."
& $SetupPath\PrerequisiteInstaller.exe /unattended | Write-Host
if( $lastexitcode -eq 0 ) {
    Write-Host "[2/15] Running silent farm binary installation... (this will take some time)"
    & $SetupPath\setup.exe /config $SetupPath\Files\SetupFarmSilent\config.xml | Write-Host
    Write-Host "[3/15] Completed silent farm binary installation."
    if( $lastexitcode -eq 0 ) {
        Add-PSSnapin Microsoft.SharePoint.PowerShell -erroraction SilentlyContinue
        Write-Host "[4/15] Creating new configuration database..."
        New-SPConfigurationDatabase -DatabaseName ("{0}_SharePoint_Configuration_DB" -f $FarmName) -DatabaseServer $DBServer -AdministrationContentDatabaseName ("{0}_AdminContent_DB" -f $FarmName) -FarmCredentials $FarmCredential -Passphrase $Passphrase -ErrorVariable err
        Write-Host "[5/15] Verifying farm creation..."
        $spfarm = get-spfarm
            if ($spfarm -ne $null) {
            Write-Host "[6/15] ACLing SharePoint Resources..."
            Initialize-SPResourceSecurity -ErrorVariable err
            if ([String]::IsNullOrEmpty($err) -eq $true) {
                Write-Host "[7/15] Installing Services..."
                Install-SPService -ErrorVariable err
                    if ([String]::IsNullOrEmpty($err) -eq $true) {
                    Write-Host "[8/15] Installing Features..."
                    Install-SPFeature -AllExistingFeatures -ErrorVariable err
                    if ([String]::IsNullOrEmpty($err) -eq $true) {
                        Write-Host "[9/15] Provisioning Central Administration..."
                        New-SPCentralAdministration -Port $CAPort -WindowsAuthProvider "NTLM" -ErrorVariable err
                        if ([String]::IsNullOrEmpty($err) -eq $true) {
                            Write-Host "[10/15] Installing Help..."
                            Install-SPHelpCollection -All -ErrorVariable err
                            if ([String]::IsNullOrEmpty($err) -eq $true) {
                                Write-Host "[11/15] Installing Application Content..."
                                Install-SPApplicationContent -ErrorVariable err
                                if ([String]::IsNullOrEmpty($err) -eq $true) {
                                    Write-Host "[12/15] Basic configuration completed."
                                    $SPManagedAccount = Get-SPManagedAccount $FarmCredential.UserName
                                    Write-Host "[13/15] Creating Web Application and Application Pool..."
                                    $webApp = New-SPWebApplication -Name "SharePoint - 80" -ApplicationPool "SharePoint - 80" -ApplicationPoolAccount $SPManagedAccount -DatabaseServer $DBServer -DatabaseName ("{0}_Content_DB" -f $FarmName) -Url "http://localhost" -ErrorVariable err
                                    if ([String]::IsNullOrEmpty($err) -eq $true) {
                                        Write-Host "[14/15] Creating site collection..."
                                        $SPSite = New-SPSite -url "http://localhost" -OwnerAlias $FarmCredential.UserName -ErrorVariable err
                                        if ([String]::IsNullOrEmpty($err) -eq $true) {
                                            Write-Host "[15/15] Port 80 Web application and site collect created.  Browse to http://localhost to pick a template for the Web..."
                                        } else { Write-Error "ERROR: $err" }
                                    } else { Write-Error "ERROR: $err" }
                                } else { Write-Error "ERROR: $err" }
                            } else { Write-Error "ERROR: $err" }
                        } else { Write-Error "ERROR: $err" }
                    } else { Write-Error "ERROR: $err" }
                } else { Write-Error "ERROR: $err" }
            } else { Write-Error "ERROR: $err" }
        } else { Write-Error "ERROR: $err" }
    } else { Write-Error "ERROR: $lastexitcode" }
} else { Write-Error "ERROR: $lastexitcode" }

$exitprompt = Read-Host -Prompt "Press Enter to exit..."

Pour exécuter simplefarm.ps1

  1. Démarrez Windows PowerShell 2.0 en utilisant l'option Exécuter en tant qu'administrateur.

  2. Accédez au répertoire dans lequel vous avez enregistré simplefarm.ps1.

  3. Exécutez .\simplefarm.ps1 depuis l'invite de commandes Windows PowerShell.

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010)

Cet article explique comment déployer Microsoft SharePoint Foundation 2010 dans un environnement de batterie de serveurs qui utilise des bases de données créées par l'administrateur de base de données. Dans les organisations où les administrateurs de bases de données opèrent indépendamment des administrateurs SharePoint, les administrateurs de base de données créent et gèrent toutes les bases de données. Cela est courant dans les environnements informatiques où les besoins en matière de sécurité et de stratégies d'entreprise nécessitent une séparation des rôles d'administrateur. L'administrateur de batterie de serveurs indique la configuration requise pour les bases de données Microsoft SharePoint Foundation 2010 à l'administrateur de base de données qui, à son tour, crée les bases de données Microsoft SharePoint Foundation nécessaires et configure les connexions requises pour la batterie de serveurs.

Dans cet article :

  • Avant de commencer

  • À propos de la configuration des bases de données créées par l'administrateur de base de données

  • Créer et configurer des bases de données pour l'Administration centrale

  • Créer et configurer des bases de données supplémentaires

Avant de commencer

Avant de commencer ce déploiement, assurez-vous d'avoir toutes les informations nécessaires pour déployer et configurer correctement SharePoint Foundation sur tous les serveurs de la batterie. Les sections suivantes indiquent les informations nécessaires à la réussite du déploiement de SharePoint Foundation.

Conditions requises pour les serveurs de la batterie

Assurez-vous que tous les serveurs de la batterie et le serveur de base de données remplissent les conditions indiquées dans les articles suivants.

  • Configuration matérielle et logicielle requise : Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

  • Comptes d'administration et de service : Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010)

Conditions requises pour les bases de données

Le déploiement de SharePoint Foundation 2010 sur des bases de données créées par l'administrateur de base de données implique une collaboration avec ce dernier afin que toutes les bases de données SharePoint Foundation dont vous avez besoin soient créées et correctement configurées avant que vous ne créiez et configuriez la batterie de serveurs.

La liste suivante présente certaines, mais pas nécessairement la totalité, des informations dont un administrateur de base de données a besoin pour créer des bases de données pour la batterie de serveurs. Des informations supplémentaires peuvent être requises par l'administrateur de base de données dans votre organisation :

  • Informations sur la version de SQL Server, ainsi que le niveau du Service Pack et de la mise à jour cumulative. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  • Les comptes de connexion requis avec les rôles et les autorisations associés. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

  • Le nombre de bases de données requises, ainsi que les spécificités de la configuration de SharePoint. Ces informations peuvent être obtenues en déployant SharePoint Foundation.

  • Les besoins de stockage de données SharePoint, tels que le type de données, le volume de données, le type d'activité de base de données (lecture ou écriture) et les opérations d'entrée/sortie par seconde.

  • L'administrateur de base de données doit configurer les paramètres de surface d'exposition de sorte que les connexions locales et distantes utilisent uniquement TCP/IP ou des canaux nommés.

  • Toutes les bases de données requises par SharePoint Foundation utilisent le classement Latin1_General_CI_AS_KS_WS.

  • Toutes les bases de données SharePoint Foundation nécessitent que le compte d'utilisateur du programme d'installation de la batterie de serveurs soit attribué en tant que propriétaire de base de données (dbo).

  • Considérations relatives au contrat de niveau de service de l'utilisateur SharePoint.

À propos de la configuration des bases de données créées par l'administrateur de base de données

Utilisez les procédures de cet article comme un guide de déploiement d'une batterie de serveurs qui utilise des bases de données créées par l'administrateur de base de données. Ce déploiement comprend toutes les bases de données requises pour la batterie de serveurs.

Remarque :
Cet article s'applique uniquement aux versions de base de données SQL Server prises en charge par SharePoint Foundation 2010.

Pour chaque procédure, vous devez utiliser les outils en ligne de commande Windows PowerShell 2.0 ou SharePoint Foundation pour configurer la batterie de serveurs.

Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Remarque :
Psconfig est situé dans le dossier suivant : Program Files\Common Files\Microsoft Shared\web server extensions\14\BIN.

Pour utiliser Windows PowerShell pour configurer la batterie de serveurs :

  1. Vérifiez que le compte d'utilisateur a accès à un des serveurs sur lequel Windows PowerShell 2.0 est en cours d'exécution et qu'il est administrateur de batterie et membre du rôle SharePoint_Shell_Access pour la base de données de contenu source SQL Server, la base de données de contenu d'administration, la base de données de contenu de destination et la base de données de configuration.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande appropriée, puis appuyez sur Entrée.

Aux fins d'illustration des procédures requises, la batterie de serveurs de base à configurer est constituée des éléments suivants :

  1. Administration centrale

  2. Un portail Web

  3. Journalisation des diagnostics et collecte des données d'utilisation et d'intégrité

  4. Recherche

Les bases de données suivantes sont nécessaires et sont généralement utilisées par l'administrateur de batterie de serveurs dans la séquence suivante lorsque la batterie de serveurs est créée. Les bases de données dans la liste suivante utilisent les noms par défaut fournis lorsque vous utilisez l'Assistant Configuration des produits SharePoint pour configurer une batterie de serveurs. Vous pouvez, bien sûr, utiliser les noms de base de données de votre choix.

  • La base de données de configuration (SharePoint_Config)

  • La base de données de contenu de l'Administration centrale (SharePoint_AdminContent_GUID)

  • La base de données de contenu de site Web, qui est créée automatiquement par le programme d'installation de SharePoint Foundation (WSS_Content_GUID)

  • La base de données de journalisation des diagnostics (WSS_Logging_GUID)

  • La base de données de recherche (nom d'ordinateur WSS_SEARCH_localhost)

Créer et configurer des bases de données pour l'Administration centrale

Utilisez les procédures de cette section pour créer les bases de données requises et attribuer aux comptes une appartenance aux rôles de groupe de sécurité et de base de données des utilisateurs de base de données.

Les procédures nécessitent une action de l'administrateur de base de données et du compte d'utilisateur du programme d'installation. La mention [DBA] (administrateur de base de données) ou [Programme d'installation] est utilisée pour chaque étape pour indiquer quel rôle exécute l'action.

La procédure suivante ne doit être effectuée qu'une fois pour la batterie de serveurs, sur le serveur devant exécuter le site Web Administration centrale. La batterie de serveurs a une base de données de configuration et une base de données de contenu pour l'Administration centrale.

Pour créer et configurer la base de données de configuration, la base de données de contenu de l'Administration centrale et l'application Web Administration centrale

  1. [DBA] Créez la base de données de configuration et la base de données de contenu de l'Administration centrale à l'aide de la séquence de classement LATIN1_General_CI_AS_KS_WS et définissez le propriétaire de base de données (dbo) comme étant le compte d'utilisateur du programme d'installation.

  2. [Programme d'installation] Exécutez le programme d'installation sur chaque serveur de la batterie de serveurs. Vous devez exécuter le programme d'installation sur au moins l'un de ces ordinateurs à l'aide de l'option d'installation Complète. Les étapes à suivre pour cette option sont décrites dans Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010).

  3. [Programme d'installation] Une fois l'installation terminée, n'exécutez pas l'Assistant Configuration des produits SharePoint.

    À partir de SharePoint 2010 Management Shell, utilisez la commande New-SPConfigurationDatabase pour créer une base de données de configuration, par exemple :

    Code de copie
    New-SPConfigurationDatabase -DatabaseName "SharePointConfigDB1" -DatabaseServer "SQL-01" -Passphrase (ConvertTo-SecureString "MyPassword" -AsPlainText -force) -FarmCredentials (Get-Credential)

    Pour plus d'informations, voir New-SPConfigurationDatabase.

  4. [Programme d'installation] Une fois la commande terminée, exécutez l'Assistant Configuration des produits SharePoint et effectuez le reste de la configuration pour le serveur. Cela crée l'application Web Administration centrale et effectue d'autres tâches d'installation et de configuration.

  5. [DBA] Lorsque l'Assistant Configuration des produits SharePoint est terminé, effectuez les actions suivantes pour la base de données de configuration et la base de données de contenu de l'Administration centrale :

    • Ajoutez le compte de recherche SharePoint Foundation, le compte d'accès au contenu par défaut et le compte de services au groupe Utilisateurs.

    • Ajoutez le compte de service de recherche SharePoint Foundation, le compte d'accès au contenu par défaut et le compte de services au rôle WSS_Content_Application_Pools.

  6. [Programme d'installation] Pour vous assurer que les bases de données ont été correctement créées et configurées, vérifiez que la page d'accueil du site Web Administration centrale est accessible. Toutefois, ne configurez rien à l'aide de l'Administration centrale à ce stade. Si la page Administration centrale ne s'affiche pas, vérifiez les comptes utilisés dans cette procédure et assurez-vous qu'ils sont correctement affectés.

Le reste des batteries de serveurs sera configuré une fois que les procédures décrites dans l'article sont terminées et que la batterie de serveurs est établie. Vous allez exécuter l'Assistant Configuration des produits SharePoint sur ces serveurs en sélectionnant l'option Oui, je veux me connecter à une batterie de serveurs existante, au lieu d'employer les commandes utilisées dans cette procédure.

La procédure suivante ne devra être effectuée qu'une seule fois sur la batterie de serveurs. La batterie de serveurs ne dispose que d'une seule base de données de recherche SharePoint Foundation.

Créer et configurer la base de données de recherche SharePoint Foundation et démarrer le service de recherche

  1. [DBA] Créez la base de données de recherche SharePoint Foundation à l'aide de la séquence de classement LATIN1_General_CI_AS_KS_WS et définissez le propriétaire de la base de données (dbo) comme étant le compte d'utilisateur du programme d'installation.

  2. [Programme d'installation] Ouvrez la ligne de commande, puis utilisez les applets de commande Get-SPSearchService, Set-SPSearchService, Get-SPSearchServiceInstance et Set-SPSearchServiceInstance pour configurer la base de données et démarrer le service de recherche. Utilisez l'exemple suivant comme guide.

    Code de copie
    $searchService = Get-SPSearchService
Set-SPSearchService -MaxBackupDuration 120
Get-SPSearchServiceInstance -Local
Get-SPSearchServiceInstance -Local | Set-SPSearchServiceInstance -ProxyType proxy

    Pour plus d'informations, reportez-vous aux rubriques suivantes :

    • Get-SPSearchService

    • Set-SPSearchService

    • Get-SPSearchServiceInstance

    • Set-SPSearchServiceInstance

Créer et configurer des bases de données supplémentaires

Après avoir configuré les bases de données requises pour l'Administration centrale, terminez votre déploiement de la batterie de serveurs en créant et en configurant les bases de données requises pour le contenu Web et les applications de service à utiliser.

La procédure suivante doit être effectuée une fois pour chaque site portail dans la batterie de serveurs.

Créer et configurer la base de données de contenu d'application Web du site portail

  1. [DBA] Créez la base de données de contenu d'application Web du site portail à l'aide de la séquence de classement LATIN1_General_CI_AS_KS_WS et définissez le propriétaire de la base de données (dbo) comme étant le compte d'utilisateur du programme d'installation.

  2. [DBA] À l'aide de Microsoft SQL ServerManagement Studio, ajoutez le compte de processus du pool d'applications au groupe Utilisateurs et au rôle db_owner pour la base de données de contenu d'application Web.

  3. [Programme d'installation] Ouvrez la ligne de commande, puis exécutez les applets de commande New-SPWebApplication et Get-SPWebApplication pour configurer la base de données de contenu d'application Web du site portail. Utilisez l'exemple suivant comme guide.

    Code de copie
    New-SPWebApplication -Name "Contoso Internet Site" -Port 80 -URL "https://www.contoso.com" -ApplicationPool "ContosoAppPool" -ApplicationPoolAccount (Get-SPManagedAccount "DOMAIN\jdoe")
Get-SPWebApplication http://sitename | New-SPWebApplicationExtension -Name "ExtranetSite" -SecureSocketsLayer -Zone "Extranet"

    Pour plus d'informations, voir New-SPWebApplication et Get-SPWebApplication.

    Important :
    L'applet de commande Get-SPWebApplication doit être exécutée sur l'ordinateur qui exécute l'application Web. La combinaison de nom d'hôte et de port ne doit pas décrire une application Web qui existe déjà, sinon une erreur se produit et l'application Web n'est pas créée.

Utilisez la procédure suivante pour créer et configurer l'application Web du site portail et sa base de données de contenu.

Pour créer et configurer l'application Web du site portail

  1. [DBA] Créez la base de données de contenu d'application Web du site portail à l'aide de la séquence de classement LATIN1_General_CI_AS_KS_WS et définissez le propriétaire de la base de données (dbo) comme étant le compte d'utilisateur du programme d'installation.

  2. [DBA] À l'aide de SQL ServerManagement Studio, ajoutez le compte de service de l'application de service au groupe Utilisateurs, puis au rôle db_owner pour la base de données de contenu d'application Web du site portail.

  3. [Programme d'installation] À partir de SharePoint 2010 Management Shell, utilisez les applets de commande New-SPWebApplication et Get-SPWebApplication pour configurer la base de données de contenu d'application Web du site portail. Utilisez l'exemple suivant comme guide.

    Code de copie
    New-SPWebApplication -Name "Contoso Internet Site" -Port 80 -HostHeader "http://sharepoint.contoso.com" -URL "https://www.contoso.com" -ApplicationPool "ContosoAppPool" -ApplicationPoolAccount (Get-SPManagedAccount "DOMAIN\jdoe")
Get-SPWebApplication http://somesite | Set-SPWebApplication -Zone "Extranet" -HostHeader "http://www.contoso.com" - AllowAnonymousAccess

    Pour plus d'informations, voir New-SPWebApplication et Get-SPWebApplication.

    Important :
    Cette commande doit être exécutée sur l'ordinateur qui exécute l'application Web. La combinaison de nom d'hôte et de port ne doit pas décrire une application Web qui existe déjà, sinon une erreur se produit et l'application Web n'est pas créée.

  4. [Programme d'installation] Depuis une invite de commandes, exécutez la commande suivante pour redémarrer les services Internet (IIS) : iisreset /noforce.

Historique des modifications


Déploiement dans un environnement virtuel (SharePoint Foundation 2010)

Cette section contient des articles qui fournissent des informations relatives à la configuration des machines virtuelles pour les serveurs Microsoft SharePoint Foundation 2010 dans un environnement virtuel.

Dans cette section :

  • Guide de la machine virtuelle (SharePoint Foundation 2010)

Historique des modifications


Guide de la machine virtuelle (SharePoint Foundation 2010)

Cet article fournit des informations sur la configuration d'un ordinateur virtuel reposant sur la Technologie Hyper-V de Windows Server 2008 et utilisé dans une batterie Microsoft SharePoint Foundation 2010. Il s'agit notamment de serveurs de la batterie situés au niveau du serveur Web, au niveau du serveur d'applications et au niveau du serveur de bases de données. Avant la configuration d'un ordinateur virtuel pour une batterie SharePoint, nous vous recommandons de lire le Guide de démarrage de Hyper-V (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187754&clcid=0x40C). Chacune de vos décisions relatives à la configuration d'un ordinateur virtuel ou de son infrastructure ayant une incidence sur les performances ou les fonctionnalités (SharePoint Foundation 2010 et Hyper-V), il est important de bien comprendre chaque option de configuration.

Dans un environnement Hyper-V, vous avez la possibilité de spécifier la configuration de la mise en réseau virtuelle et la configuration de chaque ordinateur virtuel. En outre, vous pouvez configurer le mode d'interaction de l'ordinateur virtuel avec l'hôte de virtualisation, ainsi que le comportement d'arrêt et de redémarrage de l'ordinateur virtuel si l'état en cours d'exécution de l'ordinateur virtuel est interrompu.

Dans cet article :

  • Mise en réseau

  • Cartes réseau

  • Configuration de l'ordinateur virtuel

  • Services d'intégration

  • Utilisation de captures instantanées

Mise en réseau

Vous pouvez configurer la mise de réseau Hyper-V avant de créer des ordinateurs virtuels ou après avoir créé un ou plusieurs ordinateurs virtuels. Vous pouvez également créer plusieurs réseaux virtuels pour un hôte Hyper-V.

Le Gestionnaire de réseau virtuel (accessible à partir du Gestionnaire Hyper-V) vous permet de choisir entre trois types de réseaux virtuels. Le tableau suivant présente un résumé des différents types de réseau et leurs caractéristiques.

Type | Description
Externe | Utilisez ce type lorsque vous voulez autoriser des ordinateurs virtuels à communiquer avec des serveurs situés à l'extérieur et le système d'exploitation de gestion (aussi appelé partition parente). Ce type permet aussi aux ordinateurs virtuels situés sur le même serveur physique de communiquer entre eux.
Interne | Utilisez ce type lorsque vous voulez autoriser la communication entre ordinateurs virtuels sur le même serveur physique et les ordinateurs virtuels et le système d'exploitation de gestion. Un réseau virtuel interne est un réseau virtuel qui n'est pas lié à une carte réseau physique. Il est couramment utilisé pour générer un environnement de test dans lequel vous devez vous connecter aux ordinateurs virtuels à partir du système d'exploitation de gestion.
Privé | Utilisez ce type lorsque vous voulez uniquement autoriser la communication entre ordinateurs virtuels situés sur le même serveur physique. Un réseau virtuel privé est un réseau virtuel sans carte réseau virtuelle dans le système d'exploitation de gestion. Les réseaux virtuels privés sont couramment utilisés lorsqu'il est nécessaire d'isoler des ordinateurs virtuels du trafic réseau dans le système d'exploitation de gestion et dans les réseaux externes.

Utilisez les spécifications de la batterie SharePoint Foundation pour déterminer la configuration de mise en réseau que vous voulez utiliser sur un hôte de virtualisation. Par exemple, dans l'article Démarrage rapide : déployer un serveur unique dans un environnement Hyper-V isolé (SharePoint Foundation 2010), nous avons utilisé un réseau interne pour isoler l'environnement de test d'un environnement de production.

Après avoir déterminé le type de réseau que vous voulez utiliser, vous pouvez spécifier la plage d'adresses de la sous-couche MAC (Media Access Control) qui sont automatiquement attribuées aux cartes virtuelles. La version R2 de Microsoft Hyper-V Server 2008 vous permet de fournir des adresses MAC statiques à une carte afin d'éviter les collisions sur un réseau.

Du point de vue des performances de la mise en réseau, le fait de pouvoir créer des réseaux locaux virtuels (VLAN) peut générer des gains de performances. Des ordinateurs virtuels sur le même VLAN peuvent communiquer par le biais du commutateur virtuel, ce qui signifie que le trafic réseau circule plus rapidement puisqu'il n'est pas contraint d'utiliser la carte réseau physique. Par ailleurs, de par la nature logicielle d'une configuration VLAN, vous pouvez facilement déplacer les ordinateurs tout en conservant leur configuration réseau.

Les liens suivants fournissent des informations supplémentaires sur les concepts de mise en réseau virtuelle et la configuration de réseaux virtuels.

  • Fonctionnement de la mise en réseau de base dans Hyper-V ? (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=128228&clcid=0x40C)

  • Hyper-V : usages des différents types de réseaux virtuels (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=128085&clcid=0x40C)

  • Présentation des VLAN Hyper-V (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=180709&clcid=0x40C)

  • VLAN Hyper-V (deuxième partie) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=18775&clcid=0x40C)

  • Configuration de réseaux virtuels (http://go.microsoft.com/fwlink/?linkid=158767&clcid=0x40C)

Cartes réseau

Vous pouvez attacher deux types de cartes réseau à un ordinateur virtuel : une carte réseau et une carte héritée. Une carte réseau offre de meilleures performances qu'une carte réseau héritée. La carte héritée émule une carte Fast Ethernet PCI à base de Intel 21140, ce qui se traduit par un transfert de données inférieur à celui de la carte réseau. Une carte réseau héritée prend également en charge les installations basées sur le réseau, car elle inclut la possibilité de démarrer dans l'environnement PXE (Pre-Boot Execution Environment).

Sauf dans les cas où vous avez besoin d'effectuer un démarrage réseau ou d'utiliser une carte héritée avant de pouvoir installer le pilote de l'ordinateur virtuel, nous vous recommandons de configurer l'ordinateur virtuel avec une carte réseau.

Remarque :
Au départ, vous pouvez utiliser la carte héritée pour effectuer un démarrage réseau. Lorsqu'elle n'est plus nécessaire, ajoutez une carte réseau et supprimez la carte héritée.

Comme pour les serveurs physiques, vous pouvez installer plusieurs cartes sur un ordinateur virtuel.

Configuration de l'ordinateur virtuel

Hyper-V vous offre plusieurs options pour configurer un ordinateur virtuel. Vous pouvez modifier ces options une fois l'ordinateur virtuel démarré et Microsoft SharePoint Foundation installé. Vous devez arrêter l'ordinateur virtuel pour pouvoir modifier la configuration. Pour chaque ordinateur virtuel, configurez les éléments suivants :

  • Séquence de démarrage (carte réseau héritée, CD, IDE ou à disquette)

  • Quantité de mémoire

  • Nombre de processeurs virtuels (quatre au maximum)

  • Type et nombre de contrôleurs

  • Type et nombre de disques

  • Type et nombre de cartes réseau

Outre les configurations précédentes, vous pouvez également configurer des ports COM et une disquette virtuelle.

Du point de vue de SharePoint Foundation, les principales considérations en matière de configuration sont la mémoire, le processeur et le type et le nombre de contrôleurs et de disques durs.

Mémoire

Après avoir réservé 2 Go de mémoire RAM pour l'hôte de virtualisation, vous pouvez configurer un ordinateur virtuel avec la quantité de mémoire restante de votre choix. Vous devez bien entendu tenir compte de la quantité de mémoire que vous désirez attribuer aux autres ordinateurs virtuels s'exécutant sur le même hôte de virtualisation.

Remarque :
La réserve de 2 Go de mémoire RAM pour l'hôte de virtualisation est donnée à titre indicatif ; cette quantité de mémoire n'est ni requise ni imposée. En général, la quantité réelle de RAM dédiée au serveur physique est inférieure à cela.

La surcharge de mémoire réelle sur Hyper-V est relativement faible. Pour illustrer ceci, téléchargez le fichier Hyper-V RAM Calculator.xls (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187756&clcid=0x40C) et calculez l'utilisation de la mémoire RAM sur un hôte d'une taille donnée avec plusieurs ordinateurs virtuels.

Processeur

Vous pouvez configurer plusieurs processeurs virtuels pour un ordinateur virtuel (quatre au maximum).Le nombre de processeurs que vous configurez par ordinateur virtuel ne peut pas dépasser le nombre de processeurs logiques (cœurs) sur l'hôte de virtualisation. Par exemple, pour un serveur physique double cœur donné, vous ne pouvez pas configurer plus de deux processeurs virtuels par ordinateur virtuel. Bien qu'Hyper-V prenne en charge jusqu'à huit processeurs virtuels par cœur, une configuration qui utilise ce ratio (1 processeur logique pour 8 processeurs virtuels, soit 1:8) est qualifiée de « surabonnée ». Pour tout ordinateur virtuel utilisé dans une batterie SharePoint, nous vous recommandons d'utiliser un ratio de 1:1. Il est possible de surabonner l'UC sur l'hôte de virtualisation, mais les performances diminuent en fonction de la quantité de surabonnement.

Contrôleur et disque dur

Vous pouvez sélectionner des périphériques IDE ou SCSI pour des ordinateurs virtuels, comme suit :

  • Périphériques IDE : Hyper-V utilise des périphériques émulés avec des contrôleurs IDE. Vous pouvez avoir jusqu'à deux contrôleurs IDE avec deux disques sur chaque contrôleur. Le disque de démarrage doit être attaché à l'un des périphériques IDE. Le disque de démarrage peut être un disque dur virtuel ou un disque physique. Bien qu'un ordinateur virtuel doive utiliser un périphérique IDE comme disque de démarrage pour démarrer le système d'exploitation invité, vous disposez de nombreuses options au moment de la sélection du périphérique physique qui fournira le stockage pour le périphérique IDE.

  • Périphériques SCSI : chaque ordinateur virtuel prend en charge jusqu'à 256 disques SCSI (quatre contrôleurs SCSI, chacun d'entre eux prenant en charge jusqu'à 64 disques). Les contrôleurs SCSI utilisent un type de périphérique développé spécifiquement pour les ordinateurs virtuels et font appel au bus de l'ordinateur virtuel pour communiquer. Le bus de l'ordinateur virtuel doit être disponible lors du démarrage du système d'exploitation invité. Par conséquent, les disques durs virtuels attachés aux contrôleurs SCSI ne peuvent pas être utilisés comme disques de démarrage.

    Remarque :
    Bien que les performances E/S des périphériques SCSI et IDE physiques puissent différer de manière significative, il n'en va pas de même pour les périphériques SCSI et IDE virtualisés dans Hyper-V. Les périphériques IDE et SCSI offrent des performances E/S tout aussi rapides lorsque des services d'intégration sont installés dans le système d'exploitation invité. La prise en charge des disques durs échangeables à chaud, qui est rendue possible par l'implémentation Hyper-V de SCSI, justifie davantage la sélection des lecteurs SCSI que les gains en termes de performances.

La version d'Hyper-V publiée avec Windows Server 2008 R2 offre des améliorations spectaculaires en matière de performances des disques durs virtuels. Pour plus d'informations, voir Performances des disques durs virtuels : Windows Server 2008 / Windows Server 2008 R2 / Windows 7 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=186519&clcid=0x40C). Pour obtenir un résumé des options relatives aux lecteurs d'ordinateur virtuel, voir la section traitant de la sélection du conteneur de stockage Hyper-V et sur disque dur virtuel de ce livre blanc. En outre, suivez bien le conseil des auteurs, à savoir la prise en compte des performances d'accès et des besoins de stockage au moment de choisir le disque dur virtuel pour votre environnement. Lorsque vous utilisez Windows Server 2008 R2, la vitesse d'accès devient secondaire par rapport à la quantité de mémoire utilisée en raison de la mise en cache avancée.

Important :
Il n'y a pas de solution de stockage générique pour chaque environnement virtuel. La sélection d'un lecteur d'ordinateur virtuel optimal pour vos serveurs SharePoint Foundation nécessite des efforts de recherche et des tests approfondis pour implémenter la meilleure solution de stockage pour votre environnement virtuel.

Services d'intégration

Hyper-V inclut un package logiciel pour les systèmes d'exploitation invités pris en charge qui améliore l'intégration entre l'ordinateur physique et l'ordinateur virtuel. Ce package désigné par le terme « services d'intégration ». Vous devez vérifier que le système d'exploitation de gestion (qui exécute le rôle Hyper-V) et que les ordinateurs virtuels exécutent la même version des services d'intégration. Pour plus d'informations, voir Compatibilité des versions pour les services d'intégration (http://go.microsoft.com/fwlink/?linkid=188011&clcid=0x40C).

Pour chaque ordinateur virtuel, vous pouvez configurer les éléments d'intégration suivants entre l'ordinateur virtuel et l'hôte de virtualisation :

  • Arrêt du système d'exploitation

  • Synchronisation date/heure

  • Échange de données

  • Pulsation

  • Sauvegarde (capture instantanée de volume)

Important :
Désactivez la synchronisation date/heure pour chaque ordinateur virtuel SharePoint Foundation. SharePoint Foundation 2010 implémente des travaux du minuteur de manière intensive, et la latence pendant la synchronisation date/heure provoquera des résultats imprévisibles dans l'environnement SharePoint Foundation.

Arrêt et démarrage automatiques

Pour chaque ordinateur virtuel, vous pouvez configurer un comportement automatisé d'arrêt et de démarrage au cas où un ordinateur physique viendrait à s'arrêter. Les options d'arrêt sont les suivantes :

  • Mettre en mémoire l'état de l'ordinateur virtuel. L'état actuel de l'ordinateur virtuel est enregistré et, lorsque l'ordinateur virtuel est démarré, Hyper-V tente de rétablir l'état dans lequel se trouvait l'ordinateur virtuel.

  • Éteindre l'ordinateur virtuel. Ceci revient à débrancher un serveur.

  • Arrêter le système d'exploitation (ordinateur virtuel) invité. Ceci revient à arrêter l'ordinateur à l'aide de l'option Arrêter de Windows.

Pour un ordinateur virtuel SharePoint Foundation, ne configurez pas la mise en mémoire de l'état. Les ordinateurs virtuels dont l'état mis en mémoire est rétabli ne sont plus synchronisés avec les autres serveurs de la batterie. Nous vous recommandons de configurer l'ordinateur virtuel de telle sorte qu'il utilise un arrêt, car il s'agit de la méthode la plus sûre pour ne pas endommager l'ordinateur virtuel. Lorsqu'un arrêt se produit, tous les travaux du minuteur en cours d'exécution sont autorisés à se terminer, et aucun problème de synchronisation ne se présente lorsque l'ordinateur virtuel redémarre.

L'opposé d'un arrêt automatique est un démarrage automatique. Hyper-V fournit les options de démarrage suivantes lorsque le serveur physique redémarre :

  • Ne rien faire. Vous devez démarrer l'ordinateur virtuel manuellement, quel que soit son état lors de l'arrêt du serveur physique arrêté.

  • Démarrer automatiquement s'il était en cours d'exécution au moment où le service a été arrêté.

  • Toujours démarrer cet ordinateur virtuel automatiquement. Hyper-V démarre l'ordinateur quel que soit son état lors de l'arrêt du serveur physique arrêté.

Nous vous recommandons de sélectionner la première ou la deuxième option. Toutes les options sont valides, mais la décision finale revient à l'équipe informatique en charge de la gestion et de la maintenance de l'environnement virtuel.

En plus des options de démarrage précédentes, vous pouvez configurer un démarrage retardé pour un ordinateur virtuel. Nous vous recommandons de procéder ainsi afin de réduire les conflits de ressources sur un hôte de virtualisation. Cependant, si votre option de démarrage est de ne rien faire, il n'y a pas de problème.

Utilisation de captures instantanées

Les captures instantanées sont très utiles pour capturer l'état actuel d'un ordinateur virtuel en cours d'exécution, en pause ou arrêté. La fonctionnalité de capture instantanée vous permet de rétablir rapidement et facilement la configuration précédente d'un ordinateur virtuel. Cette fonctionnalité est particulièrement adaptée à un environnement de développement ou de test.

En guise de meilleure pratique, nous vous recommandons de ne pas utiliser la fonctionnalité de capture instantanée sur des ordinateurs virtuels dans un environnement de production, et ce pour les raisons suivantes :

  • Synchronisation de l'horloge : lorsque vous effectuez une capture instantanée d'un ordinateur virtuel en cours d'exécution, une latence existe entre le moment où la capture instantanée est démarrée et le moment où elle est terminée. Cette latence affecte les travaux du minuteur SharePoint Foundation et, en conséquence, la synchronisation entre les serveurs de la batterie.

    Important :
    Si vous choisissez de créer une capture instantanée d'un ordinateur virtuel, arrêtez l'ordinateur pour permettre aux travaux en cours d'exécution de se terminer avant de créer la capture instantanée. Nous vous recommandons d'analyser attentivement l'ordinateur virtuel et les autres serveurs de la batterie après le redémarrage de l'ordinateur virtuel afin de vous assurer qu'il n'y a aucun problème de synchronisation date/heure.

  • Performances : lorsque vous créez une capture instantanée pour un ordinateur virtuel, vous créez en fait un disque de différenciation. Un échange continu de données de configuration se produit entre l'ordinateur virtuel et la capture instantanée, ce qui affecte les performances.

Historique des modifications


Installer SharePoint Foundation 2010 à l'aide de Windows PowerShell

Cet article explique comment effectuer une nouvelle installation de Microsoft SharePoint Foundation 2010 sur un serveur autonome ou sur une batterie de serveurs à l'aide de Windows PowerShell.

Dans cet article :

  • Exigences relatives aux serveurs de la batterie

  • Préparer SPModule

  • Installer SharePoint Foundation 2010 en exécutant Install-SharePoint

  • Configurer la batterie à l'aide de New-SharePointFarm

  • Créer une application Web à l'aide de Windows PowerShell

  • Déployer des services à l'aide de l'Assistant Configuration de batterie la SharePoint 2010

  • Créer une collection de sites à l'aide de Windows PowerShell

  • Effectuer des tâches de configuration supplémentaires

  • Ajouter des serveurs à la batterie à l'aide de Join-SharePointFarm

  • Configurer le journal de suivi

Vous pouvez simplifier le déploiement en faisant appel à Windows PowerShell pour installer Microsoft SharePoint Foundation 2010 et à d'autres outils administrateur pour automatiser des installations sans assistance et configurer la batterie.

Exigences relatives aux serveurs de la batterie

Avant d'installer SharePoint Foundation 2010, passez en revue les informations suivantes qui décrivent les autorisations, les configurations matérielle et logicielle requises et les étapes à effectuer avant de démarrer le processus.

  1. Assurez-vous que toutes les conditions requises pour le matériel et les logiciels sont satisfaites. Vous devez avoir une version 64 bits de Windows Server 2008 ou de Windows Server 2008 R2. Pour les batteries de serveurs, vous devez aussi avoir une version 64 bits de SQL Server 2005 ou de SQL Server 2008. Pour plus d'informations sur ces conditions requises (telles que les mises à jour spécifiques à installer), voir Déterminer la configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  2. Assurez-vous que vous êtes prêt à configurer les comptes requis avec les autorisations appropriées. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

Préparer SPModule

Le fichier SPModule.zip est un module Windows PowerShell écrit par les membres du Groupe de produit SharePoint qui installe une batterie SharePoint.

Pour utiliser le fichier SPModule.zip, procédez comme suit :

  1. Téléchargez le fichier SPModule.zip et le fichier texte depuis la page suivante du Centre de téléchargement (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187924&clcid=0x40C).

  2. Extrayez les fichiers dans un dossier nommé SPModule, puis ajoutez ce dossier à votre chemin d'accès d'environnement. La variable d'environnement PSModulePath sert à stocker les chemins d'accès aux emplacements des modules qui sont installés sur disque. Pour afficher les chemins d'accès spécifiés dans la variable PSModulePath, depuis une invite de commandes Windows PowerShell, tapez $env:PSModulePath. Pour plus d'informations, voir Variable d'environnement PSModule (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187757&clcid=0x40C). Après l'extraction, le dossier SPModule doit contenir deux fichiers : SPModule.misc et SPModule.setup.

    Remarque :
    Si le dossier SPModule n'est pas ajouté à la variable PSModulePath, vous devez spécifier un chemin d'accès complet pour charger SPModule.

  3. Déterminez le type de signature à fournir.

    Remarque :
    Les fichiers de téléchargement ne sont pas signés. Pour fournir des scripts auto-signés, voir AllSigned : signature de vos scripts PowerShell (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187758&clcid=0x40C).

    Par défaut, la stratégie d'exécution Windows PowerShell a la valeur Restreinte, ce qui signifie qu'aucun script ne peut être exécuté. Pour modifier une stratégie d'exécution, exécutez l'applet de commande Set-ExecutionPolicy. Pour plus d'informations sur l'exécution de stratégies, voir About_Signing (http://go.microsoft.com/fwlink/?linkid=187759&clcid=0x40C).

  4. Chargez les fichiers SPModule.misc et SPModule.setup dans Windows PowerShell.

    1. Cliquez sur Démarrer, pointez sur Tous les programmes, puis cliquez sur Windows PowerShell V2. Une fois la fenêtre d'invite de commandes Windows PowerShell ouverte, la première chose à faire est d'ajouter le chemin d'accès au module à votre chemin d'accès de module Windows PowerShell (en supposant que vous avez créé un dossier nommé « SPModule » sur votre serveur) :

    2. Cliquez avec le bouton droit sur Windows PowerShell V2, puis cliquez sur Exécuter en tant qu'administrateur.

      Remarque :
      Si Microsoft SharePoint Foundation 2010 est déjà installé, vous pouvez ouvrir SharePoint 2010 Management Shell à la place.

    3. Une fois la fenêtre Invite de commandes affichée, il faut importer le module dans la session Windows PowerShell actuelle et l'ajouter à un chemin d'accès en tapant la syntaxe suivante depuis une invite de commandes Windows PowerShell :

      Code de copie
      Import-Module SPModule.misc
      Code de copie
      Import-Module SPModule.setup

Lors de l'importation du module SPModule.misc, vous appellerez une vérification de mise à jour. Dans la version 1.0, cette vérification examine un fichier texte pour déterminer si une nouvelle version est disponible. Si c'est le cas, vous pouvez la télécharger. Une fois les commandes Import-Module exécutées avec succès, vous êtes prêt à utiliser SPModule.

Important :
Les commandes suivantes doivent être utilisées uniquement dans le contexte de SPModule et de la procédure de cet article :

  1. Install-SharePoint : installe tous les fichiers binaires pour SharePoint Foundation 2010. Pour plus d'informations, voir Référence de déploiement par script (SharePoint Foundation 2010).

  2. New-SharePointFarm : crée une batterie SharePoint et effectue les tâches associées suivantes :

    • configuration de la sécurité ;

    • création d'une application Web de services partagés que vous pouvez remplir avec des applications de service ;

    • création et configuration du site Web Administration centrale ;

    • installation de tous les fichiers d'aide du produit ;

    • installation de toutes les fonctionnalités de batterie.

  3. Join-SharePointFarm : ajoute des serveurs à la batterie, puis les configure. Pour plus d'informations, voir Référence de déploiement par script (SharePoint Foundation 2010).

Une fois Windows PowerShell version 2.0 installé, vous pouvez utiliser une nouvelle fonctionnalité de Windows PowerShell appelée Communication à distance (Remoting). Grâce à cette fonctionnalité et à quelques lignes de code Windows PowerShell, un administrateur peut installer à distance plusieurs serveurs dans une batterie. Pour plus d'informations sur la Communication à distance et SPModule, voir Installation à distance avec SPModule (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187923&clcid=0x40C).

Installer SharePoint Foundation 2010 en exécutant Install-SharePoint

Une fois que vous avez déterminé les comptes requis pour l'installation, vous pouvez installer SharePoint Foundation 2010. Le DVD du produit contient des exemples de fichiers de configuration (Config.xml). Ces exemples sont stockés dans le dossier \Files du répertoire racine du DVD, dans des dossiers qui correspondent aux différents scénarios. Ils sont décrits dans le tableau suivant.

Fichier de configuration | Description
Setup\Config.xml | Installation d'un serveur autonome à l'aide de Microsoft SQL Server 2005 Express Edition
SetupFarm\Config.xml | Installation d'une batterie de serveurs
SetupFarmSilent\Config.xml | Installation d'une batterie de serveurs en mode silencieux
SetupFarmUpgrade\Config.xml | Mise à niveau sur place d'une batterie existante
SetupSilent\Config.xml | Installation d'un serveur autonome à l'aide de SQL Server 2005 Express Edition en mode silencieux
SetupSingleUpgrade\Config.xml | Mise à niveau sur place d'une installation mono-serveur existante

Pour exécuter Install-SharePoint avec un fichier Config.xml à une invite de commandes Windows PowerShell

  1. Sur le lecteur où se trouve le DVD du produit SharePoint Foundation 2010, accédez au répertoire racine pour rechercher le fichier Setup.exe.

  2. Exécutez SPModule.Setup Install-SharePoint avec le fichier Config.xml sélectionné, comme suit :

    Install-SharePoint -SetupExePath <chemin d'accès et nom du fichier> -ConfigXml <chemin d'accès et nom du fichier>

    Remarque :
    Vous pouvez sélectionner un des fichiers d'exemples ou personnaliser votre propre fichier de configuration.

  3. Appuyez sur Entrée.

L'installation est alors terminée.

L'exemple suivant illustre le fichier de configuration pour installer un seul serveur en mode silencieux (SetupSilent).

Code de copie
<Configuration><Package Id="sts">  <Setting Id="LAUNCHEDFROMSETUPSTS" Value="Yes" />  </Package><Package Id="spswfe">  <Setting Id="SETUPCALLED" Value="1" />  </Package>  <Logging Type="verbose" Path="%temp%" Template="SharePoint Server Setup(*).log" />- <!--<PIDKEY Value="Enter Product Key Here" />  -->  <Display Level="none" CompletionNotice="no" />  <Setting Id="SERVERROLE" Value="APPLICATION" />  <Setting Id="USINGUIINSTALLMODE" Value="0" />  <Setting Id="SETUP_REBOOT" Value="Never" />  <Setting Id="SETUPTYPE" Value="CLEAN_INSTALL" />  </Configuration>

Vous pouvez également personnaliser votre propre fichier de configuration. Pour contrôler les options d'installation, commencez par modifier le fichier Config.xml dans un éditeur de texte afin d'y inclure les éléments souhaités ainsi que leurs paramètres. Exécutez ensuite Install-SharePoint -SetupExePath -ConfigXML pour exécuter Setup.exe en utilisant les options définies dans Config.xml.

Options de configuration typiques :

  • Ignorez l'invite qui demande la clé du produit en fournissant celle-ci comme une valeur, <PIDKEY Value="Enter PID Key Here" />, dans le fichier Config.xml.

  • Ajoutez un emplacement pour un fichier journal, <Logging Type="off" | "standard"(default) | "verbose" Path="path" Template="file name.log"/>, que vous pouvez afficher en cas d'échec de l'installation depuis la ligne de commande.

Important :
Utilisez un éditeur de texte, tel que le Bloc-notes, pour modifier le fichier Config.xml. N'utilisez pas un éditeur XML à usage général tel que Microsoft Office Word 2007. Pour vérifier que votre fichier XML est bien formé, utilisez un navigateur pris en charge quelconque.

Exécuter Install-SharePoint à l'aide d'une clé PID

Pour exécuter le programme d'installation en mode silencieux sans utiliser de fichier de configuration, tapez l'une des commandes suivantes à une invite de commandes Windows PowerShell :

  • Pour un serveur autonome : Install-SharePoint -SetupExePath "<drive letter>:\SharePoint 2010\Setup\setup.exe" -ServerRole "SINGLESERVER"

  • Pour un déploiement de batterie : Install-SharePoint -SetupExePath "<drive letter>:\SharePoint 2010\Setup\setup.exe"

Pour exécuter le programme d'installation en mode silencieux à l'aide d'un fichier de configuration, tapez l'une des commandes suivantes à une invite de commandes Windows PowerShell :

  • Pour un serveur autonome : Install-SharePoint -SetupExePath "G:\SharePoint 2010\Setup\setup.exe" -ConfigXML "G:\SharePoint 2010\Setup\Config\singleserver_config.xml" -ServerRole "SINGLESERVER"

  • Pour un déploiement de batterie : Install-SharePoint -SetupExePath "G:\SharePoint 2010\Setup\setup.exe" -ConfigXML "G:\SharePoint 2010\Setup\Config\appserver_config.xml"

Remarque :
Pour Microsoft SharePoint Foundation 2010, le paramètre PIDKey n'a pas besoin d'être spécifié.

Configurer la batterie à l'aide de New-SharePointFarm

Vous utilisez la commande New-SharePointFarm pour configurer SharePoint Foundation 2010 après l'exécution de la commande Install-SharePoint. Les options de configuration sont différentes selon que vous installez SharePoint Foundation 2010 sur un serveur autonome ou sur une batterie de serveurs.

Configurer SharePoint Foundation 2010 sur un serveur autonome

Dans les déploiements de serveur autonome, vous pouvez exécuter New-SharePointFarm. Après vous être connecté à l'aide du compte d'utilisateur du programme d'installation que vous avez créé et configuré auparavant, vous configurez SharePoint Foundation 2010.

Pour configurer SharePoint Foundation 2010 sur un serveur autonome à l'aide de New-SharePointFarm

  • À l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    New-SharePointFarm -DatabaseServer <String> -DatabaseAccessAccount <(Get-Credential domain\account)> -FarmName <string>

    Où :

    • <String> est le nom du serveur de bases de données. Par exemple, « SQL01 ».

    • <PSCredential> est le DOMAIN\password du compte d'utilisateur qui effectue l'installation.

    • <String> est le nom de la batterie. Par exemple, « Batterie1 »

La commande New-SharePointFarm décrit les étapes de configuration au fur et à mesure de leur déroulement et signale si la configuration est réussie. Pour une installation de serveur autonome, il s'agit de l'étape finale de l'installation en ligne de commande.

Nous recommandons vivement d'installer et de configurer SharePoint Foundation 2010 sur tous les serveurs de la batterie avant de créer des sites.

Attention :
N'exécutez pas les commandes New-SharePointFarm et Join-SharePointFarm simultanément sur plusieurs ordinateurs, car des conflits et des comportements imprévisibles peuvent se produire.

Remarque :
Si l'une de ces commandes échoue, consultez les fichiers journaux de configuration après l'installation. Ces fichiers se trouvent dans %COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\14\Logs et peuvent être identifiés grâce à leur nom qui commence par PowerShell_ConfigurationDiagnostics et par l'extension du nom de fichier .log.

Remarque :
Les applets de commande Windows PowerShell mentionnées dans cette section doivent être exécutées depuis SharePoint 2010 Management Shell.

Pour établir une connexion à une base de données de configuration existante et joindre le serveur à une batterie de serveurs existante, l'applet de commande Connect-SPConfigurationDatabase doit être exécutée avec les applets de commandeWindows PowerShell suivantes, dans cet ordre :

  • Install-SPHelpCollection

  • Initialize-SPResourceSecurity

  • Install-SPService

  • Install-SPFeature -AllExistingFeatures

  • Install-SPApplicationContent

Créer une application Web à l'aide de Windows PowerShell

Utilisez l'applet de commande New-SPWebApplication pour créer l'application Web et une nouvelle base de données de contenu.

Pour créer une application Web

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    New-SPWebApplication -ApplicationPool <String> -Name
<InternetSite>
 -ApplicationPoolAccount (Get-SPManagedAccount
<DOMAIN\UserName>

    Où :

    • <String> est le nom du pool d'applications. Par exemple, « SharePoint -80 ».

    • <InternetSite> est le nom de l'application Web.

    • Domain\UserName est le nom du compte de pool d'applications.

Pour plus d'informations, voir New-SPWebApplication.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Déployer des services à l'aide de l'Assistant Configuration de batterie la SharePoint 2010

Utilisez l'Assistant Configuration des produits SharePoint pour déployer des services sur votre installation. Pour plus d'informations sur les services et les applications de service, voir Gérer les applications de service et les services (SharePoint Foundation 2010).

Créer une collection de sites à l'aide de Windows PowerShell

Vous pouvez créer une collection de sites de niveau supérieur à l'aide de l'applet de commande New-SPSite. L'applet de commande New-SPSite crée une collection de sites à une URL spécifique avec un utilisateur spécifié comme propriétaire de site.

Pour créer une collection de sites

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    New-SPSite
<SiteURL>
 -OwnerAlias
<DOMAIN\UserName>

    Où :

    • <SiteURL> est l'URL du nouveau site.

    • <DOMAIN\UserName> est le nom de connexion d'utilisateur du propriétaire de site.

Pour plus d'informations, voir New-SPSite.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Si vous ne spécifiez pas le modèle de site à utiliser, les propriétaires de sites peuvent choisir le modèle lors de leur première navigation vers le site. Vous pouvez utiliser l'applet de commande Get-SPWebTemplate pour afficher une liste de modèles.

Pour obtenir la liste complète des modèles courants dans SharePoint Foundation 2010, voir Référence de déploiement par script (SharePoint Foundation 2010)

Si vous souhaitez créer des collections de sites supplémentaires à l'aide de Windows PowerShell, vous pouvez utiliser l'applet de commande New-SPSite.

Remarque :
Si vous souhaitez créer une base de données de contenu avec le nouveau site, utilisez l'applet de commande New-SPContentDatabase ou l'applet de commande New-SPSite avec le paramètre ContentDatabase.

Après avoir créé des sites, vous pouvez configurer des mappages des accès de substitution. Ceux-ci dirigent les utilisateurs vers l'URL correcte lorsqu'ils interagissent avec SharePoint Foundation 2010 (lors de l'accès à la page d'accueil d'un site SharePoint, par exemple). Les mappages des accès de substitution permettent à SharePoint Foundation 2010 de mapper les requêtes Web aux applications et sites Web corrects et permettent à SharePoint Foundation 2010 de restituer le contenu approprié à l'utilisateur. Pour plus d'informations, voir Set-SPAlternateUrl.

Effectuer des tâches de configuration supplémentaires

Une fois que vous avez installé SharePoint Foundation 2010, nous vous recommandons d'effectuer les tâches administratives suivantes :

  • configurer les paramètres de courrier électronique sortant ;

  • configurer les paramètres de flux de travail ;

  • configurer les paramètres de journalisation des diagnostics ;

  • configurer les paramètres antivirus.

Ajouter des serveurs à la batterie à l'aide de Join-SharePointFarm

Vous devez exécuter la commande Join-SharePointFarm sur tous les serveurs que vous souhaitez ajouter à la batterie. Pour établir une connexion à une base de données de configuration existante et joindre le serveur à une batterie de serveur existante, tapez la commande suivante sur le serveur (après avoir installé SharePoint Foundation 2010) :

Code de copie
Join-SharePointFarm -DatabaseServer
<String>
 -ConfigurationDatabaseName
<String>
 -Passphrase
<SecureString>

Où :

  • <String> est le nom du serveur de bases de données, par exemple SQL01.

  • <SecureString> est le mot de passe du compte d'utilisateur au format DOMAINE\mot_de_passe.

Configurer le journal de suivi

Le journal de suivi peut être utile pour l'analyse des problèmes susceptibles de se produire. Vous pouvez utiliser les événements qui sont écrits dans le journal de suivi pour déterminer quelles modifications de configuration ont été apportées dans SharePoint Foundation 2010 avant que le problème ne se produise.

Par défaut, SharePoint Foundation 2010 enregistre 14 jours d'événements dans les fichiers journaux de suivi. Cela signifie que les fichiers journaux de suivi qui contiennent des événements antérieurs à 14 jours sont supprimés. Vous pouvez utiliser l'applet de commande Set-SPLogLevel pour configurer toute la journalisation des diagnostics.

Vous pouvez utiliser la page Journalisation des diagnostics dans l'Administration centrale pour configurer le nombre maximal de fichiers journaux de suivi à gérer et la durée (en minutes) de capture des événements dans chaque fichier journal.

Vous pouvez également spécifier l'emplacement où les fichiers journaux sont enregistrés ou accepter le chemin d'accès par défaut à l'aide de l'applet de commande Set-SPLogLevel.

Les fichiers journaux de suivi peuvent vous aider à résoudre les problèmes liés aux modifications de la configuration du service Recherche de Microsoft SharePoint Foundation. Comme ce type de problème n'est pas toujours détecté immédiatement, il est recommandé d'enregistrer tous les fichiers journaux de suivi créés par le système le jour où vous apportez des modifications de configuration. Stockez ces fichiers journaux pendant un certain temps dans un emplacement sûr qui ne sera pas remplacé. Il est conseillé de stocker ces fichiers sur une partition de disque dur dédiée exclusivement au stockage des fichiers journaux.

Pour plus d'informations sur la journalisation des diagnostics, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

Historique des modifications


Configuration initiale (SharePoint Foundation 2010)

Après l'installation de Microsoft SharePoint Foundation 2010, vous devez effectuer une configuration initiale. Si vous utilisez différentes langues dans la batterie de serveurs, veillez à installer les modules linguistiques adéquats sur vos serveurs Web. Ensuite, vous pouvez commencer à configurer les paramètres de la batterie de serveurs. Bien que la configuration des paramètres supplémentaires soit facultative, sachez que de nombreuses fonctionnalités clés ne seront pas disponibles si ces paramètres ne sont pas configurés. Une fois que vous avez créé une application Web et configuré les services à utiliser pour celle-ci, vous pouvez commencer à créer des collections de sites.

Les articles de cette section vous aident à effectuer la configuration initiale de SharePoint Foundation 2010.

  • Déployer des modules linguistiques (SharePoint Foundation 2010)

    Les modules linguistiques permettent aux propriétaires de sites et aux administrateurs de collections de sites de créer des sites SharePoint et des collections de sites dans plusieurs langues sans nécessiter des installations séparées de SharePoint Foundation 2010. Cet article explique comment installer les modules linguistiques sur les serveurs Web.

  • Configurer les paramètres de la batterie de serveurs (SharePoint Foundation 2010)

    Cet article explique comment configurer des paramètres supplémentaires dans la batterie de serveurs, tels que le courrier électronique sortant et entrant, le compte mobile et la journalisation des diagnostics.

  • Configurer les services (SharePoint Foundation 2010)

    Des services individuels peuvent être configurés indépendamment et vous pouvez implémenter uniquement les services nécessaires à votre organisation. Les services déployés sont nommés applications de service. Une application de service fournit une ressource qui peut être partagée entre les sites au sein d'une batterie de serveurs ou parfois sur plusieurs batteries de serveurs et qui peut être accessible aux utilisateurs via une application Web d'hébergement. Cet article aborde le démarrage, l'arrêt et la configuration des services, ainsi que la gestion et la publication des applications de service.

  • Préparer l'hébergement de sites (SharePoint Foundation 2010)

    Après avoir installé SharePoint Foundation 2010 et effectué la configuration initiale, vous pouvez commencer à créer des sites SharePoint. Cet article explique comment créer une application Web et une collection de sites, sur lesquelles reposera la création des sites SharePoint.

Historique des modifications


Déployer des modules linguistiques (SharePoint Foundation 2010)

Dans cet article :

  • À propos des ID de langue et modules linguistiques

  • Téléchargement des modules linguistiques

  • Préparation des serveurs Web pour les modules linguistiques

  • Installation des modules linguistiques sur les serveurs Web

  • Désinstallation des modules linguistiques

Les modules linguistiques permettent aux propriétaires de sites et aux administrateurs de collections de sites de créer des sites SharePoint et des collections de sites dans plusieurs langues sans nécessiter des installations séparées de Microsoft SharePoint Foundation 2010. Vous installez les modules linguistiques, qui contiennent des modèles de sites spécifiques à la langue, sur les serveurs Web. Lorsqu'un administrateur crée un site ou une collection de sites reposant sur un modèle de site spécifique de la langue, le texte qui s'affiche sur le site ou la collection de sites est dans la langue du modèle de site. Les modules linguistiques sont généralement utilisés dans les déploiements multinationaux où une batterie de serveurs unique prend en charge des utilisateurs dans différents emplacements ou lorsque des sites et des pages Web doivent être dupliqués dans une ou plusieurs langues.

Remarque :
Vous ne pouvez pas remplacer la langue d'un site, d'une collection de sites ou d'une page Web qui existent déjà par une autre langue en appliquant différents modèles de sites spécifiques à la langue. Une fois que vous avez utilisé un modèle de site spécifique de la langue, pour un site ou une collection de sites, le site ou la collection de sites affiche toujours le contenu dans la langue du modèle de site d'origine.

Les séparateurs de mots et les analyseurs morphologiques permettent de rechercher efficacement du contenu sur des sites SharePoint et des collections de sites dans plusieurs langues sans nécessiter des installations séparées de SharePoint Foundation 2010. Ils sont automatiquement installés sur les serveurs Web par le programme d'installation.

Important :
Si vous désinstallez SharePoint Foundation 2010, vous devez désinstaller tous les modules linguistiques avant de désinstaller SharePoint Foundation 2010.

À propos des ID de langue et modules linguistiques

Lorsque les propriétaires de sites ou administrateurs de collections de sites créent des sites ou des collections de sites, ils peuvent choisir une langue pour chaque site ou collection de sites.

La langue qu'ils choisissent possède un identificateur de langue (ID). L'ID de langue détermine la langue qui sert à afficher et interpréter le texte qui est placé sur le site ou la collection de sites. Par exemple, lorsqu'un propriétaire de site crée un site en français, les barres d'outils, les barres de navigation, les listes et les en-têtes de colonne du site apparaissent en français. De même, si un propriétaire de site crée un site en arabe, les barres d'outils, les barres de navigation, les listes et les en-têtes de colonne du site s'affichent en arabe. En outre, l'orientation de gauche à droite par défaut du site est changée en orientation de droite à gauche pour afficher correctement le texte en arabe.

La liste des langues disponibles pour la création d'un site ou d'une collection de sites est générée par les modules linguistiques installés sur les serveurs Web. Par défaut, les sites et les collections de sites sont créés dans la langue dans laquelle SharePoint Foundation 2010 a été installé. Par exemple, si vous installez la version espagnole de SharePoint Foundation 2010, la langue par défaut pour les sites, les collections de sites et les pages Web est l'espagnol. Si quelqu'un doit créer des sites, des collections de sites ou des pages Web dans une langue autre que la langue de SharePoint Foundation 2010 par défaut, vous devez installer le module linguistique pour cette langue sur les serveurs Web. Par exemple, si vous exécutez la version française de SharePoint Foundation 2010 et qu'un propriétaire de site souhaite créer des sites en français, anglais et espagnol, vous devez installer les modules linguistiques pour l'anglais et l'espagnol sur les serveurs Web.

Remarque :
Par défaut, lorsqu'un propriétaire de site crée une nouvelle page Web dans un site, le site affiche le texte dans la langue spécifiée par l'ID de langue.

Les modules linguistiques ne sont pas regroupés dans des packages d'installation multilingues. Vous devez installer un module linguistique spécifique pour chaque langue que vous souhaitez prendre en charge. En outre, les modules linguistiques doivent être installés sur chacun des serveurs Web afin que chaque serveur Web puisse afficher le contenu dans la langue spécifiée.

Important :
Vous ne pouvez pas remplacer la langue d'un site, d'une collection de sites ou d'une page Web qui existent déjà par une autre langue en appliquant différents modèles de sites spécifiques à la langue. Une fois que vous avez utilisé un modèle de site spécifique de la langue, pour un site ou une collection de sites, le site ou la collection de sites affiche toujours le contenu dans la langue du modèle de site d'origine.

Pour la liste de tous les modules linguistiques disponibles, avec des liens de téléchargement, voir Modules linguistiques (SharePoint Foundation 2010).

Bien qu'un propriétaire de site indique un ID de langue pour un site, certains éléments de l'interface utilisateur tels que les messages d'erreur, les notifications et les boîtes de dialogue ne s'affichent pas dans la langue qui a été spécifiée. Cela est dû au fait que SharePoint Foundation 2010 repose sur plusieurs technologies de prise en charge, par exemple, Microsoft .NET Framework, Microsoft Windows Workflow Foundation, Microsoft ASP.NET et Microsoft SQL Server 2005, certaines d'entre elles étant traduites uniquement dans un nombre limité de langues. Si un élément d'interface utilisateur est généré par l'une des technologies de prise en charge qui n'est pas localisée dans la langue que le propriétaire du site a spécifiée pour le site, l'élément d'interface utilisateur apparaît en anglais. Par exemple, si un propriétaire de site crée un site en hébreu, et que le composant .NET Framework affiche un message de notification, ce dernier n'apparaît pas en hébreu car le .NET Framework n'est pas localisé dans cette langue. Cela peut se produire lorsque des sites sont créés dans n'importe quelle langue à l'exception des langues suivantes : chinois, français, allemand, italien, japonais, coréen et espagnol.

Important :
Chaque module linguistique que vous installez crée à l'emplacement %COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\14\LAYOUTS\Locale_ID un dossier qui contient des données spécifiques de la culture. Chaque dossier locale_ID doit contenir un seul fichier d'erreurs HTML renfermant les informations d'erreurs utilisées lorsqu'un fichier est introuvable. Chaque fois qu'un fichier est introuvable pour un site dans la culture concernée, ce fichier est utilisé. Vous pouvez spécifier le fichier à utiliser en définissant la propriété SPWebApplication.FileNotFoundPage pour chaque application Web. Pour plus d'informations, voir SPWebApplication.FileNotFoundPage, propriété (Microsoft.SharePoint.Administration) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=169319&clcid=0x40C).

Dans certains cas, du texte peut provenir de la langue d'installation d'origine, ce qui peut créer une interface en plusieurs langues. En règle générale, ce mélange de langues apparaît uniquement pour les créateurs de contenu ou les propriétaires de site et n'est pas visible par les utilisateurs du site.

Téléchargement des modules linguistiques

Vous devez répéter la procédure suivante pour chaque langue que vous voulez prendre en charge. Si vous souhaitez télécharger plusieurs langues, sachez qu'un fichier unique portant un nom commun est téléchargé pour chaque langue. Par conséquent, veillez à télécharger le module linguistique dans un dossier distinct du disque dur de façon à ne pas remplacer le module linguistique d'une autre langue.

Important :
Les fichiers d'aide de Windows PowerShell sont installés en anglais (en-us) par défaut. Pour afficher ces fichiers dans la même langue que le système d'exportation, vous devez installer le module linguistique de cette langue.

Important :
Si vous effectuez une mise à niveau à partir d'une version antérieure de Microsoft SharePoint Foundation et que vous utilisez les fonctionnalités Group Approval (eApproval), vous devez installer tous les modules linguistiques suivants avant d'exécuter l'Assistant Configuration des produits SharePoint :

  • Chinois (simplifié) - 2025

  • Chinois (traditionnel) - 1028

  • Japonais - 1041

  • Coréen - 1042

Une fois que vous avez installé les modules linguistiques, exécutez la commande suivante dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14 :

psconfig.exe -cmd upgrade -inplace v2v

Télécharger le module linguistique

  1. Téléchargez la version 64 bits du module linguistique à l'aide d'un des liens.

  2. Dans la page de téléchargement, sélectionnez la langue de votre choix dans la liste Choisir une autre langue, puis cliquez sur Modifier.

  3. Cliquez sur Télécharger sur la page Web.

  4. Dans la boîte de dialogue qui apparaît, cliquez sur Enregistrer pour télécharger un exemplaire du fichier sur l'ordinateur local.
Remarque :
Si vous désinstallez SharePoint Foundation 2010, vous devez désinstaller tous les modules linguistiques avant de désinstaller SharePoint Foundation 2010.

Préparation des serveurs Web pour les modules linguistiques

Avant d'installer des modules linguistiques sur les serveurs Web, procédez comme suit :

  • Installez les fichiers de langues nécessaires sur les serveurs Web.

  • Installez SharePoint Foundation 2010 sur chacun des serveurs Web.

  • Exécutez l'Assistant Configuration des produits SharePoint sur chacun des serveurs Web.

Les fichiers de langue sont utilisés par le système d'exploitation et fournissent la prise en charge pour l'affichage et la saisie de texte dans plusieurs langues. Les fichiers de langue comprennent les fichiers suivants :

  • Les fichiers du clavier

  • Les éditeurs de méthode d'entrée

  • Les fichiers de police TrueType

  • Les fichiers de police bitmap

  • Les tables de conversion des pages de codes

  • Les fichiers de prise en charge des langues nationales (.nls)

  • Les moteurs de script pour le rendu des scripts complexes

Par défaut, la plupart des fichiers de langue sont installés sur le système d'exploitation Windows Server 2008. Toutefois, vous devez installer des fichiers de langue supplémentaires pour les langues d'Extrême-Orient et les langues à script complexe ou s'écrivant de droite à gauche. Les langues d'Extrême-Orient incluent le chinois, le japonais et le coréen. Les langues à script complexe et s'écrivant de droite à gauche comprennent l'arabe, l'arménien, le géorgien, l'hébreu, les langues indiennes, le thaï et le vietnamien. Les instructions d'installation de ces fichiers de langues supplémentaires sont fournies dans la procédure suivante.

Nous vous recommandons d'installer ces fichiers de langue uniquement si vous devez les posséder. Les fichiers pour l'Extrême Orient requièrent environ 230 Mo d'espace sur le disque dur. Les langues à script complexe et s'écrivant de droite à gauche n'utilisent pas beaucoup d'espace disque, mais installer un jeu de fichiers peut réduire les performances lorsque vous entrez du texte.

Remarque :
Vous avez besoin de votre CD-ROM de produit Windows Server 2008 pour effectuer cette procédure, ou vous devez connaître l'emplacement d'un dossier partagé qui contient les fichiers d'installation du système d'exploitation.

Vous devez redémarrer l'ordinateur une fois que vous avez installé des fichiers de langues supplémentaires.

Installer les fichiers de langues supplémentaires sur Windows Server 2008

  1. Vous devez être un membre du groupe Administrateurs sur l'ordinateur pour installer ces fichiers de langue. Une fois les fichiers de langue installés, les langues sont disponibles pour tous les utilisateurs de l'ordinateur.

  2. Sur le serveur Web, cliquez sur Démarrer, pointez sur Paramètres, puis sur Panneau de configuration, puis cliquez sur Options régionales et linguistiques.

  3. Dans la boîte de dialogue Options régionales et linguistiques, dans l'onglet Claviers et langues, dans la section Langue d'affichage, cliquez sur Installer ou désinstaller des langues.

  4. Dans la boîte de dialogue Installer ou désinstaller des langues, cliquez sur Installer des langues.

  5. Dans la page Sélectionnez les langues à installer, sélectionnez la langue à installer dans la liste des langues disponibles. Si la langue n'apparaît pas, cliquez sur Parcourir le dossier pour accéder à l'emplacement auquel vous avez téléchargé le fichier de langue. Ce dernier est un fichier .cab.

  6. Sélectionnez toutes les langues à installer, puis cliquez sur Suivant.

  7. Acceptez les termes, puis cliquez sur Suivant.

  8. Cliquez sur Installer.

Une fois que vous avez installé les fichiers de langues nécessaires sur les serveurs Web, vous devez installer SharePoint Foundation 2010 et exécuter l'Assistant Configuration des produits SharePoint. L'Assistant crée et configure la base de données de configuration et effectue d'autres tâches de configuration devant être effectuées avant que vous n'installiez les modules linguistiques. Pour plus d'informations sur l'installation de SharePoint Foundation 2010 et l'exécution de Assistant Configuration des produits SharePoint, voir Vue d'ensemble du déploiement (SharePoint Foundation 2010).

Installation des modules linguistiques sur les serveurs Web

Une fois que vous avez installé les fichiers de langues nécessaires sur les serveurs Web, vous pouvez installer les modules linguistiques. Les modules linguistiques sont disponibles en tant que téléchargements individuels (un téléchargement pour chaque langue prise en charge). Si vous avez un environnement de batterie de serveurs, et que vous installez des modules multilingues, vous devez installer ces modules sur chacun des serveurs Web.

Important :
Le module linguistique est installé dans sa langue native. Par exemple, le fichier exécutable du module linguistique russe est en russe. La procédure suivante est celle du module linguistique anglais.

Installer un module linguistique

  1. Exécutez setup.exe.

  2. Sur la page Lire les termes du contrat de licence logiciel Microsoft, lisez les termes du contrat, sélectionnez la case à cocher J'accepte les termes de ce contrat, puis cliquez sur Continuer.

  3. L'Assistant Installation s'exécute et installe le module linguistique.

  4. Réexécutez l'Assistant Configuration des produits SharePoint, à l'aide des paramètres par défaut. Si vous n'exécutez pas l'Assistant Configuration des produits SharePoint après avoir installé un module linguistique, celui-ci ne sera pas installé correctement.

Réexécuter l'Assistant Configuration des produits SharePoint 2010

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, cliquez sur Produits Microsoft SharePoint 2010, puis cliquez sur Assistant Configuration des produits SharePoint 2010.

  2. Dans la page Bienvenue dans les produits SharePoint, cliquez sur Suivant.

  3. Cliquez sur Oui dans la boîte de dialogue qui vous avertit que vous devrez peut-être redémarrer certains services au cours de la configuration.

  4. Sur la page Modifier les paramètres de la batterie de serveurs, cliquez sur Ne pas se déconnecter de cette batterie de serveurs, puis cliquez sur Suivant.

  5. Si la page Modifier les paramètres de l'application Web Administration centrale de SharePoint apparaît, ne modifiez pas les paramètres par défaut et cliquez sur Suivant.

  6. Dans la page Fin de l'Assistant Configuration des produits et technologies SharePoint, cliquez sur Suivant.

  7. Sur la page Configuration réussie, cliquez sur Terminer.

Lorsque vous installez des modules linguistiques, les modèles de sites spécifiques à la langue sont installés dans le répertoire %COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\14\template\nombre, où nombre représente l'ID de la langue que vous installez. Par exemple, le module linguistique de l'anglais (États-Unis) est installé dans le répertoire %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\template\1033. Après avoir installé un module linguistique, les propriétaires de sites et administrateurs de collections de sites peuvent créer des sites et des collections de sites basés sur des modèles de sites spécifiques à la langue, en spécifiant une langue lors de la création d'un site SharePoint ou d'une collection de sites.

Désinstallation des modules linguistiques

Si vous n'avez plus besoin d'une langue pour laquelle vous avez installé un module linguistique, vous pouvez supprimer ce module linguistique à l'aide du Panneau de configuration. Supprimer un module linguistique supprime les modèles de sites spécifiques de cette langue sur l'ordinateur. Tous les sites précédemment créés auxquels sont associés ces modèles de sites spécifiques pour cette langue ne fonctionneront plus (l'URL génèrera une erreur HTTP 500 - page d'erreur du serveur interne). Réinstaller le module linguistique rendra le site fonctionnel.

Remarque :
Vous ne pouvez pas supprimer le module linguistique pour la version de SharePoint Foundation 2010 que vous avez installée sur le serveur. Par exemple, si vous utilisez la version japonaise de SharePoint Foundation 2010, vous ne pouvez pas désinstaller le module linguistique du japonais pour SharePoint Foundation 2010.

Historique des modifications

Date | Description | Raison
2010/12/13 | 2010/12/13 | Mise à jour du contenu


Configurer les paramètres de la batterie de serveurs (SharePoint Foundation 2010)

Après l'installation initiale de Microsoft SharePoint Foundation 2010, vous pouvez configurer plusieurs paramètres supplémentaires. Certains de ces paramètres comprennent la configuration de la collecte des données d'utilisation et d'intégrité, afin que les données collectées à analyser soient pertinentes, la configuration de plusieurs paramètres de journalisation des diagnostics, afin de faciliter la résolution des problèmes, et la configuration d'un compte mobile, afin que les utilisateurs puissent recevoir des alertes par SMS (Short Message Service) lorsque des modifications sont apportées dans une liste ou dans un élément SharePoint. Bien que la configuration des paramètres supplémentaires soit facultative, sachez que de nombreux composants fonctionnels clés ne seront pas disponibles si ces paramètres ne sont pas configurés.

Les articles de cette section expliquent comment configurer la batterie de serveurs.

  • Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010)

    Cet article explique comment configurer la collecte des données d'utilisation et d'intégrité dans SharePoint Foundation 2010.

  • Configurer la journalisation des diagnostics (SharePoint Foundation 2010)

    Cet article explique comment configurer la journalisation des diagnostics éventuellement nécessaire après le déploiement initial ou la mise à niveau et tout au long du cycle de vie du système.

  • Intégration de la messagerie (SharePoint Foundation 2010)

    Cet article explique comment configurer le courrier électronique entrant et le courrier électronique sortant dans la batterie de serveurs.

  • Configurer un compte mobile (SharePoint Foundation 2010)

    Cet article explique comment configurer et gérer un compte mobile pour que SharePoint Foundation 2010 permette aux utilisateurs de s'abonner à des alertes envoyées par SMS (Short Message Service).

  • Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010)

    Cet article décrit comment installer et configurer le stockage BLOB distant (RBS, Remote BLOB Storage) pour un serveur de base de données Microsoft SQL Server 2008 qui prend en charge une batterie de serveurs Microsoft SharePoint Foundation 2010.

Historique des modifications


Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010)
Voir aussi

Cet article contient des informations sur la configuration de la collecte des données d'utilisation et d'intégrité dans Microsoft SharePoint Foundation 2010.

Le système écrit les données d'utilisation et d'intégrité dans le dossier de journalisation et dans la base de données de journalisation. Pour configurer les paramètres de la base de données de journalisation, vous devez utiliser Windows PowerShell.

Dans cet article :

  • Configurer la collecte des données d'utilisation et d'intégrité à l'aide de l'Administration centrale

  • Configurer la collecte des données d'utilisation à l'aide de Windows PowerShell

  • Pour configurer la collecte des données d'utilisation pour un type d'événement spécifique à l'aide de Windows PowerShell

  • Journaliser les données d'utilisation dans une base de données de journalisation différente à l'aide de Windows PowerShell

Remarque :
Vous ne pouvez pas configurer les paramètres de collecte des données d'intégrité à l'aide de Windows PowerShell.

Configurer la collecte des données d'utilisation et d'intégrité à l'aide de l'Administration centrale

Seule l'Administration centrale vous permet de configurer la collecte des données d'utilisation et d'intégrité.

Pour configurer la collecte des données d'utilisation et d'intégrité à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

    Remarque :
    Les paramètres des données d'utilisation et d'intégrité sont définis à l'échelle de la batterie de serveurs ; vous ne pouvez pas les définir pour des serveurs particuliers de la batterie.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  4. Sur la page Configurer la collection des données d'utilisation et d'intégrité, dans la section Collection des données d'utilisation, activez la collecte en sélectionnant Activer la collection des données d'utilisation.

  5. Dans la section Sélection d'événement, sélectionnez les événements à journaliser en activant la case à cocher en regard de ceux-ci dans la liste Événements à enregistrer.

    Remarque :
    La journalisation consomme les ressources système et peut avoir un impact sur les performances et l'utilisation des disques. Ne journalisez que les événements sur lesquels vous souhaitez des rapports réguliers. Pour des rapports ou des investigations ad hoc, activez la journalisation des événements pertinents, puis désactivez la journalisation de ces événements une fois le rapport ou l'investigation effectué.

  6. Dans la section Paramètres de la collection des données d'utilisation, tapez le chemin d'accès au dossier où écrire les données d'utilisation et d'intégrité dans la zone Emplacement du fichier journal. Le chemin d'accès spécifié doit exister sur tous les serveurs de la batterie.

    Remarque :
    Ces paramètres sont appliqués à tous les événements. Pour définir les paramètres de collecte d'événements de types particuliers, vous devez utiliser Windows PowerShell.

  7. Tapez l'espace disque maximum pour les fichiers journaux en gigaoctets (de 1 à 20 Go) dans la zone Taille maximale du fichier journal.

  8. Dans la section Collection des données d'intégrité, activez la case à cocher Activer la collection des données d'intégrité. Pour modifier la planification de collecte, cliquez sur Planification de la journalisation d'intégrité. La liste des travaux du minuteur qui collectent les données d'intégrité est affichée. Cliquez sur les travaux dont vous souhaitez modifier la planification ; vous pouvez aussi désactiver certains travaux.

  9. Dans la section Journalisation du serveur de bases de données, pour changer l'authentification utilisée, sélectionnez l'option Authentification Windows ou Authentification SQL.

    Remarque :
    Pour modifier les valeurs Serveur de bases de données et Nom de la base de données, vous devez utiliser Windows PowerShell.

Configurer la collecte des données d'utilisation à l'aide de Windows PowerShell

Remarque :
À l'aide de Windows PowerShell, vous pouvez configurer la collecte des données d'utilisation, mais pas celle des données d'intégrité.

Pour configurer la collecte des données d'utilisation à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Microsoft SharePoint 2010 Products.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Set-SPUsageService [-LoggingEnabled {1 | 0}] [-UsageLogLocation <Path>] [-UsageLogMaxSpaceGB <1-20>] [-Verbose]

    Important :
    Vous devez spécifier pour UsageLogLocation un chemin d'accès qui existe sur tous les serveurs de la batterie.

    Activez la journalisation des données d'utilisation en tapant -LoggingEnabled 1. Spécifiez l'espace disque maximum utilisé pour la journalisation avec le paramètre UsageLogMaxSpaceGB.

Pour plus d'informations, voir Set-SPUsageService.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour configurer la collecte des données d'utilisation pour un type d'événement spécifique à l'aide de Windows PowerShell

Les types d'événements répertoriés sur la page Configurer la collection des données d'utilisation et d'intégrité dans l'Administration centrale sont identiques à ceux des Définitions d'utilisation dans Windows PowerShell. Seul Windows PowerShell vous permet de configurer des définitions d'utilisation particulières. De plus, vous pouvez uniquement configurer le paramètre DaysRetained.

Pour configurer la journalisation des données d'utilisation pour un type d'événement spécifique à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Microsoft SharePoint 2010 Products.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Set-SPUsageDefinition -Identity <GUID> [-Enable] [-DaysRetained <1-30>] [-Verbose]

    Utilisez le commutateur Enabled pour activer la journalisation des données d'utilisation pour cette définition d'utilisation. Utilisez DaysRetained pour spécifier la durée de conservation des données d'utilisation dans le journal avant leur suppression. La plage va de 1 à 30 jours. Pour afficher la progression de la commande, utilisez le paramètre Verbose.

Pour plus d'informations, voir Set-SPUsageDefinition.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Journaliser les données d'utilisation dans une base de données de journalisation différente à l'aide de Windows PowerShell

Remarque :
Seul Windows PowerShell vous permet de modifier ce paramètre.

Pour journaliser les données d'utilisation dans une base de données de journalisation différente à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Microsoft SharePoint 2010 Products.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Set-SPUsageApplication -DatabaseServer <Database server name> -DatabaseName <Database name> [-DatabaseUsername <User name>] [-DatabasePassword <Password>] [-Verbose]

    Vous devez spécifier la valeur du paramètre DatabaseServer, même si la nouvelle base de données se trouve sur le même serveur de bases de données que l'ancienne. Vous devez utiliser les deux paramètres DatabaseUsername et DatabasePassword si le propriétaire de la base de données est différent du compte d'utilisateur sous lequel vous avez ouvert une session. Pour afficher la progression de la commande, utilisez le paramètre Verbose.

Pour plus d'informations, voir Set-SPUsageApplication.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

Historique des modifications


Configurer la journalisation des diagnostics (SharePoint Foundation 2010)
Voir aussi

Cet article fournit des informations sur la configuration de la journalisation des diagnostics dans Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Meilleures pratiques

  • Configurer la journalisation diagnostics à l'aide de l'administration centrale

  • Configurer la journalisation des diagnostics à l'aide de Windows PowerShell

Meilleures pratiques

L'environnement SharePoint Foundation 2010 peut nécessiter la configuration des paramètres de journalisation des diagnostics après le déploiement initial ou une mise à niveau, et éventuellement au cours du cycle de vie du système. Les instructions de la liste suivante peuvent vous aider à élaborer de meilleures pratiques pour votre environnement particulier.

  • Changer le lecteur où écrire la journalisation. Par défaut, la journalisation des diagnostics est configurée pour écrire les journaux sur le lecteur et la partition où SharePoint Foundation 2010 a été installé. Étant donné que cette journalisation peut consommer beaucoup d'espace du lecteur et que l'écriture dans les journaux peut affecter les performances du lecteur, il est recommandé de configurer la journalisation de sorte qu'elle écrive sur un lecteur différent de celui sur lequel SharePoint Foundation 2010 a été installé. Il vous faut également tenir compte de la vitesse de connexion au lecteur sur lequel les journaux sont écrits. Si la journalisation détaillée est configurée, beaucoup de données sont enregistrées. Par conséquent, une connexion lente peut entraîner de faibles performances d'enregistrement.

  • Restreindre l'utilisation de l'espace disque. Par défaut, la quantité d'espace disque que la journalisation des diagnostics peut occuper n'est pas limitée. Par conséquent, limitez l'espace disque de journalisation pour éviter la saturation du disque, surtout si vous configurez la journalisation détaillée des événements. Lorsque la restriction d'espace disque est atteinte, les journaux les plus anciens sont supprimés et les nouvelles informations de journalisation sont enregistrées.

  • Utiliser le paramètre Détaillé avec parcimonie. Vous pouvez configurer la journalisation des diagnostics pour enregistrer les événements de façon détaillée. Cela signifie que le système consignera chaque action que SharePoint Foundation 2010 prend. La journalisation détaillée peut rapidement consommer l'espace disque et affecter les performances du lecteur et du serveur. Vous pouvez recourir à la journalisation détaillée pour enregistrer un niveau supérieur de détails lorsque vous effectuez des changements critiques, puis reconfigurer la journalisation pour enregistrer uniquement les événements plus importants après le changement.

  • Sauvegarder régulièrement les journaux. Les journaux de diagnostics contiennent des données importantes. Par conséquent, sauvegardez-les régulièrement pour vous assurer que ces données sont conservées. Lorsque vous limitez l'espace disque de journalisation, si vous conservez les journaux seulement sur une période de quelques jours, les fichiers journaux sont automatiquement supprimés, en commençant par les plus anciens, dès que le seuil est atteint.

  • Activer la protection de flux du journal des événements. L'activation de ce paramètre configure le système afin de détecter les événements périodiques dans le journal des événements Windows. Lorsque le même événement est enregistré à plusieurs reprises, les événements répétés sont détectés et supprimés tant que les conditions ne reviennent pas à l'état normal.

Configurer la journalisation diagnostics à l'aide de l'administration centrale

Vous pouvez utiliser l'administration centrale pour configurer la journalisation des diagnostics.

Pour configurer la journalisation des diagnostics à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie SharePoint.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configurer la journalisation des diagnostics.

  4. Sur la page Journalisation des diagnostics, dans la section Limitation des événements, vous pouvez configurer la limitation des événements de la manière suivante :

    Pour configurer la limitation des événements de toutes catégories :

    1. Activez la case à cocher Toutes les catégories.

    2. Sélectionnez le niveau de journalisation des événements dans la liste Événement le moins critique à enregistrer dans le journal d'événements.

    3. Sélectionnez le niveau de journalisation du suivi dans la liste Événement le moins critique à enregistrer dans le journal de suivi.

    Pour configurer la limitation des événements d'une ou plusieurs catégories :

    1. Activez les cases à cocher en regard des catégories voulues.

    2. Sélectionnez le niveau de journalisation des événements dans la liste Événement le moins critique à enregistrer dans le journal d'événements.

    3. Sélectionnez le niveau de journalisation du suivi dans la liste Événement le moins critique à enregistrer dans le journal de suivi.

    Pour configurer la limitation des événements d'une ou plusieurs sous-catégories (vous pouvez développer une ou plusieurs catégories et sélectionner n'importe quelle sous-catégorie) :

    1. Cliquez sur (+) en regard de la catégorie pour la développer.

    2. Activez la case à cocher en regard de la sous-catégorie.

    3. Sélectionnez le niveau de journalisation des événements dans la liste Événement le moins critique à enregistrer dans le journal d'événements.

    4. Sélectionnez le niveau de journalisation du suivi dans la liste Événement le moins critique à enregistrer dans le journal de suivi.

    Pour rétablir la limitation des événements de toutes les catégories aux valeurs par défaut :

    1. Activez la case à cocher Toutes les catégories.

    2. Sélectionnez Valeurs par défaut dans la liste Événement le moins critique à enregistrer dans le journal d'événements.

    3. Sélectionnez Valeurs par défaut dans la liste Événement le moins critique à enregistrer dans le journal de suivi.

  5. Dans la section Protection de flux du journal des événements, activez la case à cocher Activer la protection de flux du journal des événements.

  6. Dans la section Journal de suivi, dans la zone Chemin d'accès, tapez le chemin d'accès au dossier où les journaux doivent être enregistrés.

  7. Dans la zone Nombre de jours de conservation des fichiers journaux, tapez le nombre de jours (1 à 366) de conservation des fichiers journaux. Au bout de cette période, les journaux seront automatiquement supprimés.

  8. Pour restreindre la quantité d'espace occupé par les journaux, activez la case à cocher Limiter l'utilisation de l'espace disque pour les journaux de suivi, puis tapez le nombre de gigaoctets (Go) auquel les journaux devront se limiter. Lorsque les journaux atteindront cette taille, les journaux les plus anciens seront automatiquement supprimés.

  9. Après avoir apporté les modifications souhaitées sur la page Journalisation des diagnostics, cliquez sur OK.

Configurer la journalisation des diagnostics à l'aide de Windows PowerShell

Windows PowerShell vous permet de configurer la journalisation des diagnostics.

Pour configurer la journalisation des diagnostics à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez la commande suivante et appuyez sur la touche ENTRÉE :

    Set-SPLogLevel -TraceSeverity {None | Unexpected | Monitorable | Medium | High | Verbose} -EventSeverity {None | Information | Warning | Error | Critical | Verbose} [-Identity <Category name…>]  -Verbose

    Vous pouvez utiliser le paramètre Identity pour spécifier une ou plusieurs catégories à changer, par exemple, Administration. Si vous ne spécifiez pas la valeur du paramètre Identity, toutes les catégories seront changées.

    Pour afficher les paramètres actuels, tapez Get-SPLogLevel, puis appuyez sur Entrée.

    Pour rétablir toutes les catégories aux niveaux par défaut, tapez Clear-SPLogLevel, puis appuyez sur Entrée.

Pour plus d'informations, voir Set-SPLogLevel.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Intégration de la messagerie (SharePoint Foundation 2010)

Après l'installation initiale de Microsoft SharePoint Foundation 2010, vous pouvez configurer le courrier électronique entrant et le courrier électronique sortant. Ces paramètres supplémentaires sont facultatifs, mais peuvent s'avérer utiles si vous souhaitez recourir au courrier électronique dans la batterie de serveurs.

  • Configurer le courrier électronique entrant (SharePoint Foundation 2010)

    Cet article explique comment configurer la réception du courrier électronique de façon à ce que vos sites SharePoint acceptent et archivent le courrier entrant. Il explique également comment configurer la réception du courrier électronique de sorte que les sites SharePoint puissent archiver les discussions électroniques en simultané, enregistrer des documents envoyés par messagerie électronique et afficher sur les calendriers du site les réunions notifiées par courrier électronique. De plus, il explique comment configurer le service de gestion d'annuaire SharePoint pour qu'il prenne en charge la création et la gestion de listes de distribution de courrier électronique.

  • Configurer le courrier électronique sortant (SharePoint Foundation 2010)

    Cet article explique comment configurer l'envoi du courrier électronique de façon à ce que votre serveur SMTP (Simple Mail Transfer Protocol) envoie des alertes aux utilisateurs du site et des notifications aux administrateurs du site.

Historique des modifications


Configurer le courrier électronique entrant (SharePoint Foundation 2010)

Cet article explique comment configurer le courrier électronique entrant pour Microsoft SharePoint Foundation 2010.

Procédures décrites dans cette tâche :

  • Installer et configurer le service SMTP

  • Configurer le courrier électronique entrant dans un scénario de base

  • Configurer le Gestionnaire DNS

  • Ajouter un connecteur SMTP dans Microsoft Exchange Server 2007

  • Configurer AD DS afin de l'utiliser avec le service de gestion d'annuaire

  • Configurer des autorisations sur le dossier de dépôt des messages électroniques

  • Configurer le courrier électronique entrant dans un scénario avancé

  • Manque-t-il des pièces jointes aux messages électroniques envoyés à une bibliothèque de documents SharePoint ?

Présentation

Lorsque le courrier entrant est activé, les sites SharePoint peuvent recevoir et stocker des messages électroniques et des pièces jointes dans des listes et des bibliothèques. Cet article décrit deux scénarios (un scénario de base et un scénario avancé). Le scénario avancé propose plusieurs options possibles.

Scénario de base

Dans le scénario de base, vous installez le service SMTP (Simple Mail Transfer Protocol) sur le serveur qui exécute SharePoint Foundation 2010. Vous pouvez également utiliser un service SMTP qui s'exécute sur un autre serveur SMTP, puis activer le courrier électronique entrant en utilisant le mode de paramètres automatiques avec tous les paramètres par défaut. Dans ce scénario, le courrier électronique est envoyé directement sur le serveur SMTP et SharePoint Foundation 2010 recherche périodiquement les messages électroniques dans le dossier de dépôt des messages électroniques par défaut qui est automatiquement configuré par le service SMTP. Le scénario de base s'applique à un environnement dont la batterie comprend un seul serveur.

Scénario avancé

Dans le scénario avancé, vous disposez de plusieurs options pour optimiser la fonctionnalité du courrier électronique entrant. L'une des options consiste à indiquer si vous souhaitez utiliser le service de gestion d'annuaire Microsoft SharePoint. L'avantage de l'utilisation du service de gestion d'annuaire Microsoft SharePoint est que les adresses des contacts créées pour les bibliothèques de documents apparaissent automatiquement dans Utilisateurs et ordinateurs Active Directory dans l'unité d'organisation pour SharePoint Foundation 2010. Ce service permet également aux utilisateurs de créer et de gérer des groupes de distribution de courrier électronique à partir de sites SharePoint. En outre, il crée des contacts dans l'annuaire des utilisateurs de votre organisation et les utilisateurs peuvent rechercher des listes SharePoint activées pour la messagerie électronique dans leurs carnets d'adresses. Toutefois, l'utilisation du service de gestion d'annuaire requiert un effort de gestion, car il communique avec les services de domaine Active Directory (AD DS, Active Directory Domain Services). Lorsque vous n'utilisez pas le service de gestion d'annuaire, les tâches d'administration s'en trouvent réduites. Par contre, vous devez ajouter manuellement chaque nouvelle adresse de contact.

Si vous utilisez le scénario avancé, vous pouvez configurer le courrier électronique entrant pour une batterie comprenant un seul serveur ou pour une batterie comportant plusieurs serveurs. Si vous disposez d'au moins deux serveurs Web frontaux dans une batterie de serveurs SharePoint, vous pouvez les utiliser pour router le courrier électronique entrant vers la batterie de serveurs. Le tableau suivant décrit les actions que vous devez effectuer et les options disponibles pour configurer le courrier électronique entrant pour une batterie de serveurs.

Action Commentaires

Configurer le Gestionnaire DNS en ajoutant un enregistrement de ressource (A) d'hôte

Vous devez ajouter un enregistrement de ressource (A) d'hôte pour associer les noms de domaines DNS des ordinateurs (ou hôtes) à leurs adresses IP.

Ajouter un connecteur SMTP

Vous devez ajouter un connecteur SMTP afin que l'ordinateur Microsoft Exchange Server 2007 route le courrier électronique entrant vers le serveur adéquat.

Utiliser le service de gestion d'annuaire (facultatif)

Utilisez le service de gestion d'annuaire afin que les utilisateurs puissent créer et gérer des groupes de distribution de courrier électronique à partir des sites SharePoint. Les adresses de contacts créées pour les bibliothèques de documents apparaissent automatiquement dans AD DS.

Remarque :
Si vous n'utilisez pas Exchange Server, vous devez personnaliser votre propre service de gestion d'annuaire.

Utiliser un dossier de dépôt des messages électroniques spécifique (facultatif)

Utilisez un dossier de dépôt des messages électroniques spécifique pour permettre à SharePoint Foundation 2010 de rechercher le courrier électronique entrant en provenance du service SMTP.

Pour plus d'informations sur le service de gestion d'annuaire, voir Au cœur de SharePoint : intégration de l'annuaire SharePoint (http://go.microsoft.com/fwlink/?linkid=151766&clcid=0x40C).

Avant de configurer le courrier électronique entrant dans SharePoint Foundation 2010, lisez l'article suivant :

  • Planifier le courrier électronique entrant (Windows SharePoint Services)

Conditions requises pour la tâche

Les conditions suivantes sont requises pour effectuer les procédures de cette tâche :

  • SharePoint Foundation 2010 doit être installé.

  • Un ou plusieurs serveurs de la batterie doivent exécuter le service SMTP et utiliser une adresse de serveur SMTP valide. À défaut, vous devez connaître le nom d'un autre serveur qui exécute le service SMTP.

  • Chaque serveur Web frontal SharePoint doit exécuter le service SMTP et le service Application Web de Windows SharePoint Services.

  • Le compte d'identité du pool d'applications de l'Administration centrale, le compte d'ouverture de session du service du minuteur Windows SharePoint Services et les comptes d'identité de pool d'applications de vos applications Web doivent être membres du groupe Administrateurs sur l'ordinateur local qui contient le dossier de dépôt des messages électroniques.

Installer et configurer le service SMTP

Le courrier électronique entrant pour SharePoint Foundation 2010 utilise le service SMTP. Vous pouvez utiliser le service SMTP de deux façons. Vous pouvez l'installer sur un ou plusieurs serveurs de la batterie ou les administrateurs peuvent fournir un dossier de dépôt des messages électroniques pour le courrier électronique transféré à partir du service sur un autre serveur.

Remarque :
Soyez attentif quant à la décision d'utiliser ou non l'option du dossier de dépôt des messages électroniques. En effet, vous devez prendre deux facteurs en considération : les administrateurs de l'autre serveur peuvent affecter la disponibilité du courrier électronique entrant s'ils modifient la configuration de SMTP et cette option suppose la configuration d'autorisations sur le dossier de dépôt des messages électroniques.

Installer le service SMTP

Si vous n'utilisez pas un dossier de dépôt pour le courrier électronique, le service SMTP doit être installé sur chaque serveur Web frontal de la batterie de serveurs à configurer pour le courrier électronique entrant. Pour installer le service SMTP, utilisez l'Assistant Ajout de fonctionnalités dans le Gestionnaire de serveur. Au terme de la procédure, une configuration SMTP par défaut aura été créée. Vous pouvez personnaliser cette configuration SMTP par défaut en fonction des besoins de votre environnement.

Pour installer le service SMTP

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Gestionnaire de serveur.

  3. Dans Gestionnaire de serveur, cliquez sur Fonctionnalités.

  4. Dans Résumé des fonctionnalités, cliquez sur Ajouter des fonctionnalités pour ouvrir l'Assistant Ajout de fonctionnalités.

  5. Dans la page Sélectionner des fonctionnalités, sélectionnez Serveur SMTP.

  6. Dans la boîte de dialogue Assistant Ajout de fonctionnalités , cliquez sur Ajouter les fonctionnalités requises, puis cliquez sur Suivant.

  7. Dans la page Confirmer les sélections pour l'installation, cliquez sur Installer.

  8. Dans la page Résultats de l'installation, vérifiez que l'installation s'est correctement déroulée, puis cliquez sur Fermer.

Installer les outils de gestion d'IIS 6.0

Pour gérer le service SMTP sur Windows Server 2008, vous devez utiliser Internet Information Services (IIS) 6.0 Manager.

Pour installer IIS 6.0 Manager

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Gestionnaire de serveur.

  3. Dans Gestionnaire de serveur, cliquez sur Rôles.

  4. Dans Services de rôle, cliquez sur Ajouter des services de rôle.

  5. Dans la page Sélectionner les services de rôle, sélectionnez Outils de gestion et IIS 6 Management Compatibility, puis cliquez sur Installer.

Configurer le service SMTP

Après avoir installé le service SMTP, vous le configurez afin qu'il accepte le courrier provenant du serveur de messagerie pour le domaine. Vous pouvez décider d'accepter le courrier électronique relayé en provenance de tous les serveurs à l'exception de ceux que vous excluez spécifiquement. Ou bien, vous pouvez bloquer le courrier en provenance de tous les serveurs à l'exception de ceux que vous incluez spécifiquement. Vous pouvez inclure des serveurs individuellement, ou en groupes par sous-réseau ou domaine.

Après avoir configuré le service, définissez-le de manière à ce qu'il démarre automatiquement.

Pour configurer le service SMTP

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Internet Information Services (IIS) 6.0 Manager.

  3. Dans le Gestionnaire des services Internet, développez le nom du serveur qui contient le serveur SMTP que vous souhaitez configurer.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP que vous souhaitez configurer, puis cliquez sur Démarrer.

  5. Cliquez avec le bouton droit sur le serveur virtuel SMTP que vous souhaitez configurer, puis cliquez sur Propriétés.

  6. Sous l'onglet Accès, dans la zone Contrôle d'accès, cliquez sur Authentification.

  7. Dans la boîte de dialogue Authentification, vérifiez que l'option Accès anonyme est activée.

  8. Cliquez sur OK.

  9. Sous l'onglet Accès, dans la zone Restrictions de relais, cliquez sur Relais.

  10. Pour autoriser le relais depuis n'importe quel serveur, sélectionnez Tous sauf la liste ci-dessous.

  11. Pour accepter le relais depuis un ou plusieurs serveurs spécifiques, procédez comme suit :

    1. Cliquez sur Uniquement la liste ci-dessous.

    2. Cliquez sur Ajouter, puis ajoutez les serveurs un à un par adresse IP ou dans des groupes par le biais d'un sous-réseau ou d'un domaine.

    3. Cliquez sur OK pour fermer la boîte de dialogue Ordinateur.

  12. Cliquez sur OK pour fermer la boîte de dialogue Restrictions de relais.

  13. Cliquez sur OK pour fermer la boîte de dialogue Propriétés.

Pour configurer le service SMTP de manière à ce qu'il démarre automatiquement

  1. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Services.

  2. Dans Services, cliquez avec le bouton droit sur SMTP (Simple Mail Transfer Protocol), puis sélectionnez Propriétés.

  3. Dans la boîte de dialogue Simple Mail Transfer Protocol (SMTP) Properties, sous l'onglet Général, dans la liste Type de démarrage, sélectionnez Automatique.

  4. Cliquez sur OK.

Configurer le courrier électronique entrant dans un scénario de base

Avant d'activer le courrier électronique entrant sur le serveur qui exécute SharePoint Foundation 2010, vous devez sélectionner le service SMTP à utiliser.

Vous pouvez utiliser la procédure suivante pour configurer le courrier électronique entrant. Au terme de cette procédure, vous aurez configuré tout ce qui est nécessaire pour un scénario de base. Les utilisateurs pourront alors envoyer du courrier électronique aux listes et aux bibliothèques.

Pour configurer le courrier électronique entrant dans un scénario de base

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur exécutant le site Web Administration centrale de SharePoint.

  2. Dans l'Administration centrale, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer les paramètres du courrier entrant.

  4. Si vous souhaitez autoriser les sites sur ce serveur à recevoir du courrier électronique, dans la page Configurer les paramètres du courrier entrant, dans la section Activer le courrier entrant, cliquez sur Oui.

  5. Sélectionnez le mode de paramètres Automatique.

  6. Dans la section Adresse complète du serveur de courrier entrant, dans la zone Adresse complète du serveur de messagerie, tapez un nom complet pour le serveur de messagerie (par exemple, mail.fabrikam.com).

  7. Utilisez les paramètres par défaut pour toutes les autres sections, puis cliquez sur OK.

Une fois que vous avez configuré le courrier électronique entrant, les utilisateurs habilités à gérer les listes peuvent configurer des listes et des bibliothèques de documents activées pour la messagerie électronique. Pour plus d'informations sur les bibliothèques de documents activées pour la messagerie électronique, voir Activer et configurer la prise en charge des courriers électroniques pour une liste ou une bibliothèque (http://go.microsoft.com/fwlink/?linkid=120164&clcid=0x40C).

Configurer le Gestionnaire DNS

Si vous utilisez Exchange Server et que vous routez le courrier électronique de manière interne dans votre organisation, vous devez créer un enregistrement de ressource (A) d'hôte dans le Gestionnaire DNS pour associer les noms de domaines DNS des ordinateurs (ou hôtes) à leurs adresses IP. Il est possible que votre organisation ait déjà configuré le Gestionnaire DNS et créé un enregistrement de ressource A. Si tel n'est pas le cas, utilisez la procédure suivante.

Pour créer un enregistrement de ressource A pour un sous-domaine

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Dans le Gestionnaire DNS, sélectionnez la zone de recherche directe du domaine qui contient le sous-domaine de SharePoint Foundation 2010.

  3. Cliquez avec le bouton droit sur la zone, puis cliquez sur Nouvel hôte (A ou AAAA).

  4. Dans la boîte de dialogue Nouvel hôte, dans la zone de texte Nom, tapez le nom d'hôte ou de sous-domaine pour SharePoint Foundation 2010.

  5. Dans la zone de texte Nom de domaine pleinement qualifié (FQDN), tapez le nom de domaine pleinement qualifié pour le serveur qui exécute SharePoint Foundation 2010. Ce nom se présente généralement sous la forme sous-domaine.domaine.com.

    Remarque :
    Vérifiez que les domaines répertoriés sous le serveur SMTP dans IIS correspondent au nom de domaine pleinement qualifié du serveur qui reçoit le courrier électronique. Si tel n'est pas le cas, vous devez créer un domaine local, en effectuant la procédure suivante.

  6. Dans la zone de texte Adresse IP, tapez l'adresse IP sur laquelle vous souhaitez que le nom de domaine pleinement qualifié soit résolu.

  7. Cliquez sur Ajouter un hôte.

  8. Dans le message de confirmation de la création de l'enregistrement d'hôte, cliquez sur OK.

  9. Dans la boîte de dialogue Nouvel hôte, cliquez sur Terminé.

    L'enregistrement de ressource A apparaît maintenant dans le Gestionnaire DNS.

Pour créer un domaine local

  1. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Internet Information Services (IIS) 6.0 Manager.

  2. Dans le Gestionnaire des services Internet, développez le serveur SMTP.

  3. Cliquez avec le bouton droit sur Domaines, puis, dans le menu Action, pointez sur Nouveau et cliquez sur Domaine.

  4. Dans la boîte de dialogue Assistant Nouveau domaine SMTP, sélectionnez Alias, puis cliquez sur Suivant.

  5. Dans la section Nom de domaine, dans la zone Nom, tapez l'adresse du courrier électronique que doit recevoir ce domaine.

    Cette adresse doit être la même que celle que vous avez spécifiée à l'étape 4 de la procédure Pour créer un enregistrement de ressource A pour le sous-domaine et à l'étape 6b de la procédure Pour configurer le courrier électronique entrant dans un scénario avancé.

  6. Cliquez sur Terminer.

  7. Dans le message de confirmation de la création de l'enregistrement d'hôte, cliquez sur OK.
Remarque :
Redémarrez le serveur SMTP afin que tous les messages électroniques se trouvant encore dans le dossier de file d'attente soient déplacés vers le dossier de dépôt. Les messages sont ensuite envoyés par le service du minuteur Windows SharePoint Services vers leur liste ou bibliothèque de destination.

Remarque :
Si vous routez le courrier électronique provenant de l'extérieur de votre organisation vers un serveur SMTP, vous devez utiliser un enregistrement MX. Pour plus d'informations, voir Ajouter un enregistrement de ressource de serveur de messagerie (MX) à une zone (http://go.microsoft.com/fwlink/?linkid=150827&clcid=0x40C).

Ajouter un connecteur SMTP dans Microsoft Exchange Server 2007

Un connecteur SMTP vous permet de contrôler davantage le flux de messages dans votre organisation. Il vous permet également de définir des restrictions de remise ou de spécifier un espace d'adressage spécifique. Si vous utilisez Exchange Server pour router le courrier électronique entrant vers des listes et des bibliothèques SharePoint, vous devez disposer d'un connecteur SMTP afin que la totalité du courrier électronique envoyé au domaine SharePoint Foundation 2010 utilise les serveurs SharePoint Foundation 2010 exécutant le service SMTP.

Utilisez la procédure suivante pour ajouter un connecteur SMTP dans Exchange Server. Au terme de la procédure, le connecteur SMTP garantit l'envoi des messages électroniques entrants à la liste et à la bibliothèque adéquates dans la batterie de serveurs.

Pour ajouter un connecteur SMTP dans Exchange Server

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur qui exécute Exchange Server.

  2. Dans le Gestionnaire du système Exchange, développez le groupe de routage, cliquez avec le bouton droit sur Connecteurs, pointez sur Nouveau, puis cliquez sur SMTP Connector.

    La boîte de dialogue Propriétés pour le nouveau connecteur apparaît.

    Remarque :
    Si le dossier Administrative Groups n'apparaît pas, sous l'onglet Organisation Exchange, cliquez avec le bouton droit sur Propriétés, puis activez les cases à cocher Display Administrative Groups et Display Routing Groups. Cliquez sur OK. Vous devez ensuite redémarrer le Gestionnaire du système Exchange.

  3. Sous l'onglet Général, tapez un nom pour le connecteur SMTP.

  4. Sous l'onglet Général, sélectionnez l'une des options suivantes :

    • Pour utiliser les paramètres DNS configurés sur le serveur virtuel SMTP qui héberge le connecteur, sélectionnez Utiliser DNS pour rediriger vers chaque espace d'adresse sur ce connecteur. DNS est la configuration recommandée pour Exchange Server.

    • Pour router le courrier électronique vers un serveur SMTP Windows ou vers un autre serveur dans votre réseau de périmètre (également appelé sous-réseau filtré), sélectionnez Transférer tout le courrier via ce connecteur vers le serveur de messagerie spécifié chez votre fournisseur de services Internet (hôte intelligent). Tapez le nom d'hôte ou l'adresse IP de l'hôte actif entre crochets pour empêcher Exchange Server de résoudre l'adresse IP en utilisant DNS. Le connecteur SMTP route ensuite le courrier électronique vers le serveur sélectionné, qui gère la résolution DNS et remet le courrier électronique.

  5. Sous l'onglet Général, cliquez sur Ajouter, puis ajoutez au moins un serveur pont et un serveur virtuel SMTP.

    Les serveurs que vous ajoutez apparaissent dans la liste Serveurs tête de pont locaux sous l'onglet Général.

  6. Cliquez sur l'onglet Espace d'adressage, puis cliquez sur Ajouter.

  7. Dans la boîte de dialogue Ajouter un espace d'adressage, dans la liste Sélectionner un type d'adresse, cliquez sur SMTP, puis cliquez sur OK.

  8. Dans la boîte de dialogue Propriétés de l'espace d'adressage Internet, sélectionnez les options suivantes :

    1. Dans la zone Domaine de messagerie, tapez un domaine de messagerie pour le connecteur.

      Important :
      Dans la zone Domaine de messagerie, la valeur par défaut * représente toutes les adresses. Au moins un connecteur dans votre organisation doit posséder cet espace d'adressage afin que tous les domaines externes soient routés vers Internet.

    2. Dans la zone Coût, affectez un coût approprié. Par défaut, le coût a pour valeur 1.

  9. Cliquez sur OK pour revenir à l'onglet Espace d'adressage.

  10. Sous l'onglet Espace d'adressage, dans la section Portée du connecteur, sélectionnez l'une des options suivantes, puis cliquez sur OK:

    • Pour autoriser tous les serveurs de l'organisation Exchange Server à utiliser ce connecteur pour envoyer du courrier électronique via Internet, cliquez sur Toute l'organisation.

    • Pour autoriser uniquement les serveurs du groupe de routage à utiliser ce connecteur pour envoyer du courrier électronique via Internet, cliquez sur Groupe de routage.

    Remarque :
    Si vous sélectionnez Groupe de routage, assurez-vous que les serveurs appartenant à différents groupes de routage peuvent envoyer du courrier électronique via Internet selon une autre procédure.

Pour plus d'informations, voir Gestion des connecteurs (http://go.microsoft.com/fwlink/?linkid=150840&clcid=0x40C).

Configurer AD DS afin de l'utiliser avec le service de gestion d'annuaire

Si vous envisagez d'utiliser le service de gestion d'annuaire, vous devez d'abord créer une unité d'organisation et effectuer les configurations nécessaires dans AD DS.

Pour utiliser le service de gestion d'annuaire sur une batterie de serveurs SharePoint ou sur une batterie de serveurs distante, vous devez configurer le compte d'identité du pool d'applications du site Web Administration centrale de SharePoint afin qu'il détienne le droit d'utilisateur Créer, supprimer et gérer les comptes d'utilisateurs sur le conteneur que vous spécifiez dans AD DS. Pour ce faire, la meilleure méthode consiste à affecter le droit au compte d'identité du pool d'applications du site Web Administration centrale de SharePoint. Un administrateur AD DS doit configurer l'unité d'organisation et affecter le droit Créer, supprimer et gérer les comptes d'utilisateurs au conteneur. Lorsque vous utilisez le service de gestion d'annuaire sur une batterie de serveurs distante, vous n'avez pas besoin d'affecter des droits à l'unité d'organisation pour plusieurs comptes de service de batterie de serveurs.

Les procédures suivantes sont réalisées sur un contrôleur de domaine qui exécute Windows Server 2008 avec le Gestionnaire DNS. Dans certains déploiements, ces applications peuvent s'exécuter sur plusieurs serveurs dans le même domaine.

Pour créer une unité d'organisation dans AD DS

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de domaine ou l'autorité déléguée pour l'administration de domaine sur le contrôleur de domaine qui exécute le Gestionnaire DNS.

  2. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Utilisateurs et ordinateurs Active Directory.

  3. Dans Utilisateurs et ordinateurs Active Directory, cliquez avec le bouton droit sur le dossier du domaine de second niveau qui contient votre batterie de serveurs, pointez sur Nouveau, puis cliquez sur Unité d'organisation.

  4. Tapez le nom de l'unité d'organisation, puis cliquez sur OK.

    Après avoir créé l'unité d'organisation, vous devez déléguer le droit Créer, supprimer et gérer les comptes d'utilisateurs au conteneur de l'unité d'organisation pour gérer les comptes d'utilisateur.

Pour déléguer le droit au compte d'identité du pool d'applications de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de domaine ou Administrateurs d'entreprise dans AD DS ou bien l'autorité déléguée pour l'administration de domaine.

  2. Dans Utilisateurs et ordinateurs Active Directory, recherchez l'unité d'organisation que vous avez créée.

  3. Cliquez avec le bouton droit sur l'unité d'organisation, puis cliquez sur Délégation de contrôle.

  4. Dans la page Bienvenue de l'Assistant Délégation de contrôle, cliquez sur Suivant.

  5. Dans la page Utilisateurs et groupes, cliquez sur Ajouter, puis tapez le nom du compte d'identité du pool d'applications que l'Administration centrale utilise.

  6. Dans la boîte de dialogue Sélectionner des utilisateurs, des ordinateurs et des groupes, cliquez sur OK.

  7. Dans la page Utilisateurs ou groupes de l'Assistant Délégation de contrôle, cliquez sur Suivant.

  8. Dans la page Tâches à déléguer de l'Assistant Délégation de contrôle, activez la case à cocher Créer, supprimer et gérer les comptes d'utilisateurs, puis cliquez sur Suivant.

  9. Dans la dernière page de l'Assistant Délégation de contrôle, cliquez sur Terminer pour quitter l'Assistant.

Pour créer et supprimer des objets enfants, vous devez également déléguer les contrôles Créer tous les objets enfants et Supprimer tous les objets enfants de l'unité d'organisation au compte d'identité du pool d'applications de l'Administration centrale. Au terme de cette procédure, le compte d'identité du pool d'applications de l'Administration centrale possède les contrôles Créer tous les objets enfants et Supprimer tous les objets enfants sur l'unité d'organisation et vous pouvez activer le courrier électronique entrant.

Pour déléguer les contrôles Créer tous les objets enfants et Supprimer tous les objets enfants de l'unité d'organisation au compte d'identité du pool d'applications de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de domaine ou Administrateurs d'entreprise dans AD DS ou bien l'autorité déléguée pour l'administration de domaine.

  2. Cliquez avec le bouton droit sur l'unité d'organisation, puis cliquez sur Délégation de contrôle.

  3. Dans l'Assistant Délégation de contrôle, cliquez sur Suivant.

  4. Cliquez sur Ajouter et tapez le nom du compte d'identité du pool d'applications de l'Administration centrale.

  5. Cliquez sur OK.

  6. Cliquez sur Suivant.

  7. Dans la page Tâches à déléguer de l'Assistant Délégation de contrôle, sélectionnez Créer une tâche personnalisée à déléguer, puis cliquez sur Suivant.

  8. Sélectionnez Ce dossier, les objets de ce dossier et la création d'objets dans ce dossier, puis cliquez sur Suivant.

  9. Dans la section Autorisations, sélectionnez Créer tous les objets enfants et Supprimer tous les objets enfants.

  10. Cliquez sur Suivant.

  11. Dans la dernière page de l'Assistant Délégation de contrôle, cliquez sur Terminer pour quitter l'Assistant.

En déléguant les contrôles Créer tous les objets enfants et Supprimer tous les objets enfants de l'unité d'organisation au compte d'identité du pool d'applications de l'Administration centrale, les administrateurs peuvent activer le courrier électronique pour une liste. Une fois ces contrôles délégués, les administrateurs ne peuvent pas désactiver le courrier électronique pour une liste ou une bibliothèque de documents, car le compte de l'Administration centrale essaie de supprimer le contact de l'unité d'organisation tout entière au lieu de le supprimer de la liste.

Pour éviter ce problème, vous devez ajouter des autorisations Supprimer la sous-arborescence pour le compte d'identité du pool d'applications de l'Administration centrale. Utilisez la procédure suivante pour ajouter ces autorisations. Au terme de cette procédure, vous pouvez désactiver le courrier électronique entrant pour une liste.

Pour ajouter des autorisations Supprimer la sous-arborescence pour le compte d'identité du pool d'applications de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de domaine ou Administrateurs d'entreprise dans AD DS ou bien l'autorité déléguée pour l'administration de domaine.

  2. Dans Utilisateurs et ordinateurs Active Directory, cliquez sur le menu Affichage, puis cliquez sur Fonctionnalités avancées.

  3. Cliquez avec le bouton droit sur l'unité d'organisation, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés, cliquez sur l'onglet Sécurité, puis cliquez sur Paramètres avancés.

  5. Dans la zone Entrées d'autorisations, double-cliquez sur le compte d'identité du pool d'applications de l'Administration centrale.

  6. Dans la zone Autorisations, sélectionnez Autoriser, pour Supprimer la sous-arborescence.

  7. Cliquez sur OK pour fermer la boîte de dialogue Autorisations.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés.

  9. Cliquez sur OK pour fermer Utilisateurs et ordinateurs Active Directory.

Après avoir ajouté ces autorisations, vous devez redémarrer les services Internet (IIS) pour la batterie de serveurs.

Pour plus d'informations, voir Utilisateurs, ordinateurs et groupes Active Directory (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=151331&clcid=0x40C).

Configurer des autorisations sur le dossier de dépôt des messages électroniques

Vous pouvez spécifier un dossier de dépôt des messages électroniques particulier, ce qui permet à SharePoint Foundation 2010 de récupérer le courrier électronique entrant à partir d'un partage réseau sur un autre serveur. Vous pouvez utiliser cette option si vous ne souhaitez pas recourir à un service SMTP. Toutefois, l'inconvénient de cette option est que SharePoint Foundation 2010 ne peut pas détecter les modifications de configuration sur le serveur de messagerie distant qui remet les messages électroniques au dossier de dépôt. Par voie de conséquence, SharePoint Foundation 2010 ne peut pas récupérer le courrier électronique si l'emplacement des messages électroniques a changé. Toutefois, cette fonctionnalité est utile si le dossier de dépôt des messages électroniques par défaut est plein ou pratiquement plein.

Si vous avez spécifié un dossier de dépôt des messages électroniques, vous devez vérifier que les comptes d'identité du pool d'applications de l'Administration centrale et de l'application Web disposent des autorisations requises sur le dossier de dépôt des messages électroniques.

Configurer le dossier de dépôt des messages électroniques pour le compte d'identité de pool d'applications d'une application Web

Si votre déploiement utilise différents comptes d'identité de pool d'applications pour l'Administration centrale et une ou plusieurs applications Web, chaque compte d'identité de pool d'applications doit disposer d'autorisations sur le dossier de dépôt des messages électroniques. Si le compte d'identité de pool d'applications de l'application Web ne dispose pas des autorisations requises, le courrier électronique n'est pas remis aux bibliothèques de documents dans cette application Web.

Dans la plupart des cas, lorsque vous configurez le courrier électronique entrant et que vous sélectionnez un dossier de dépôt des messages électroniques, les autorisations sont ajoutées pour les groupes de processus de traitement suivants :

  • WSS_Admin_WPG, qui inclut le compte d'identité de pool d'applications de l'Administration centrale et le compte d'ouverture de session du service du minuteur Windows SharePoint Services et dispose des autorisations Contrôle total.

  • WSS_WPG, qui inclut les comptes de pool d'applications des applications Web et dispose des autorisations Lecture et exécution, Affichage du contenu du dossier et Lecture.

Dans certains cas, ces groupes ne sont peut-être pas configurés automatiquement pour le dossier de dépôt des messages électroniques. Par exemple, si l'Administration centrale est exécutée en tant que compte Service réseau, les groupes ou les comptes nécessaires au courrier électronique entrant ne sont pas ajoutés lorsque le dossier de dépôt des messages électroniques est créé. Vérifiez si ces groupes ont été ajoutés automatiquement au dossier de dépôt des messages électroniques. Si les groupes n'ont pas été ajoutés automatiquement, vous pouvez les ajouter ou ajouter les comptes spécifiques nécessaires.

Pour configurer le dossier de dépôt des messages électroniques pour le compte d'identité de pool d'applications d'une application Web

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur qui contient le dossier de dépôt des messages électroniques.

  2. Dans l'Explorateur Windows, cliquez avec le bouton droit sur le dossier de dépôt, cliquez sur Propriétés, puis cliquez sur l'onglet Sécurité.

  3. Sous l'onglet Sécurité, dans la zone Groupes ou noms d'utilisateurs, cliquez sur le bouton Modifier.

  4. Dans la boîte de dialogue Autorisations pour Windows Explorer, cliquez sur le bouton Ajouter.

  5. Dans la boîte de dialogue Sélectionner les utilisateurs, les ordinateurs ou les groupes, dans la zone Entrez les noms des objets à sélectionner, tapez le nom du groupe de processus de traitement ou du compte d'identité de pool d'applications de l'application Web, puis cliquez sur OK.

    Remarque :
    Ce compte est répertorié dans l'onglet Identité de la boîte de dialogue Propriétés du pool d'applications dans IIS.

  6. Dans la zone Autorisations pour utilisateur ou groupe, en regard de Modification, sélectionnez Autoriser.

  7. Cliquez sur OK.

Configurer les autorisations sur le dossier de dépôt des messages électroniques pour le compte d'ouverture de session du service du minuteur Windows SharePoint Services

Assurez-vous que le compte d'ouverture de session du service du minuteur Windows SharePoint Services dispose d'autorisations Modifier sur le dossier de dépôt des messages électroniques. Si le compte d'ouverture de session du service ne dispose pas d'autorisations Modifier, les bibliothèques de documents activées pour le courrier électronique reçoivent les messages électroniques en double.

Pour configurer les autorisations sur le dossier de dépôt des messages électroniques pour le compte d'ouverture de session du service du minuteur Windows SharePoint Services

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur qui contient le dossier de dépôt des messages électroniques.

  2. Dans l'Explorateur Windows, cliquez avec le bouton droit sur le dossier de dépôt, cliquez sur Propriétés, puis cliquez sur l'onglet Sécurité.

  3. Sous l'onglet Sécurité, dans la zone Groupes ou noms d'utilisateurs, cliquez sur le bouton Modifier.

  4. Dans la boîte de dialogue Autorisations pour Windows Explorer, cliquez sur le bouton Ajouter.

  5. Dans la boîte de dialogue Sélectionner les utilisateurs, les ordinateurs ou les groupes, dans la zone Entrez les noms des objets à sélectionner, tapez le nom du compte d'ouverture de session du service du minuteur Windows SharePoint Services, puis cliquez sur OK.

    Remarque :
    Ce compte est répertorié dans l'onglet Connexion de la boîte de dialogue Propriétés du service dans la console Services.

  6. Dans la zone Autorisations pour utilisateur ou groupe, en regard de Modification, sélectionnez Autoriser.

  7. Cliquez sur OK.

Configurer le courrier électronique entrant dans un scénario avancé

La procédure suivante configure le courrier électronique entrant. Vous pouvez également sélectionner Service de gestion d'annuaire, configurer les options des serveurs de messagerie fiables ou spécifier un dossier de dépôt des messages électroniques et spécifier l'adresse complète du courrier électronique entrant. Au terme de cette procédure, les utilisateurs peuvent envoyer du courrier électronique aux listes et aux bibliothèques.

Pour configurer le courrier électronique entrant dans un scénario avancé

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs sur l'ordinateur exécutant le site Web Administration centrale de SharePoint.

  2. Dans l'Administration centrale, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer les paramètres du courrier entrant.

  4. Si vous souhaitez autoriser les sites sur ce serveur à recevoir du courrier électronique, dans la page Configurer les paramètres du courrier entrant, dans la section Activer le courrier entrant, cliquez sur Oui.

  5. Sélectionnez le mode Paramètres Automatique ou Avancé.

    Si vous sélectionnez Automatique, vous pouvez indiquer s'il faut accepter le courrier électronique provenant de tous les serveurs de messagerie ou de certains serveurs de messagerie spécifiés.

    Si vous choisissez Avancé, vous pouvez spécifier un dossier de dépôt plutôt qu'utiliser un serveur SMTP.

  6. Si vous souhaitez vous connecter au service de gestion d'annuaire, dans la section Service de gestion d'annuaire, cliquez sur Oui.

    1. Dans la zone Conteneur Active Directory dans lequel les nouveaux groupes de distribution et contacts seront créés, tapez le nom du conteneur au format OU=NomConteneur, DC=domaine, DC=com, où NomConteneur est le nom de l'unité d'organisation dans AD DS, domaine le domaine de second niveau et com le domaine de niveau supérieur.

      Remarque :
      La tâche Créer, supprimer et gérer les comptes d'utilisateurs associée au conteneur doit être déléguée au compte d'identité de pool d'applications de l'Administration centrale. L'accès est configuré dans les propriétés de l'unité d'organisation dans AD DS.

    2. Dans la zone Serveur de messagerie SMTP pour le courrier entrant, tapez le nom du serveur de messagerie SMTP. Le nom du serveur doit correspondre au nom de domaine pleinement qualifié dans l'entrée d'enregistrement de ressource A du serveur de messagerie dans le Gestionnaire DNS.

    3. Pour accepter uniquement les messages d'utilisateurs authentifiés, cliquez sur Oui pour l'option Accepter uniquement les messages provenant d'utilisateurs authentifiés. Dans le cas contraire, cliquez sur Non.

    4. Pour autoriser les utilisateurs à créer des groupes de distribution à partir de sites SharePoint, cliquez sur Oui pour l'option Voulez-vous autoriser la création de groupes de distribution à partir de sites SharePoint ?. Dans le cas contraire, cliquez sur Non.

    5. Sous Paramètres d'approbation de demande de groupe de distribution, sélectionnez les actions qui nécessitent une approbation. Les actions sont les suivantes :

    • Créer un nouveau groupe de distribution

    • Modifier l'adresse de messagerie du groupe de distribution

    • Modifier le titre et la description du groupe de distribution

    • Supprimer le groupe de distribution

  7. Si vous souhaitez utiliser un service de gestion d'annuaire distant, sélectionnez Utiliser à distance.

    1. Dans la zone URL du service de gestion d'annuaire, tapez l'URL du service de gestion d'annuaire à utiliser. Le format de l'URL est généralement le suivant : http://serveur:port_admin/_vti_bin/SharePointEmailWS.asmx.

    2. Dans la zone Serveur de messagerie SMTP pour le courrier entrant, tapez le nom du serveur de messagerie SMTP. Le nom du serveur doit correspondre au nom de domaine pleinement qualifié dans l'entrée d'enregistrement de ressource A du serveur de messagerie dans le Gestionnaire DNS sur le serveur de domaine.

    3. Pour accepter les messages d'utilisateurs authentifiés uniquement, cliquez sur Oui pour l'option Accepter uniquement les messages provenant d'utilisateurs authentifiés. Dans le cas contraire, cliquez sur Non.

    4. Pour autoriser la création de groupes de distribution à partir de sites SharePoint, cliquez sur Oui pour l'option Voulez-vous autoriser la création de groupes de distribution à partir de sites SharePoint ?. Dans le cas contraire, cliquez sur Non.

  8. Si vous ne souhaitez pas utiliser le service de gestion d'annuaire, cliquez sur Non.

  9. Dans la section Adresse complète du serveur de courrier entrant, dans la zone Adresse complète du serveur de messagerie, tapez un nom complet pour le serveur de messagerie (par exemple, mail.fabrikam.com).

    Conseil :
    Vous pouvez spécifier l'adresse du serveur de messagerie qui s'affiche lorsque les utilisateurs créent une adresse de messagerie entrante pour une liste ou un groupe. Utilisez ce paramètre avec le service de gestion d'annuaire pour fournir une adresse de serveur de messagerie plus conviviale.

  10. Dans la section Dossier de dépôt des messages électroniques, dans la zone Dossier de dépôt des messages électroniques, tapez le nom du dossier dans lequel SharePoint Foundation recherche le courrier entrant en provenance du service SMTP.

    Il est utile de recourir à un dossier de dépôt des messages électroniques dédié si le dossier de dépôt des messages électroniques par défaut est plein ou pratiquement plein.

    Assurez-vous que le compte d'ouverture de session du service du minuteur SharePoint Foundation dispose d'autorisations Modifier sur le dossier de dépôt des messages électroniques. Pour plus d'informations, voir « Pour configurer les autorisations sur le dossier de dépôt des messages électroniques pour le compte d'ouverture de session du service du minuteur Windows SharePoint Services », plus haut dans cet article.

    Remarque :
    Cette option n'est disponible que si vous avez sélectionné le mode avancé.

  11. Dans la section Serveurs de messagerie fiables, indiquez si vous souhaitez accepter le courrier électronique en provenance de tous les serveurs de messagerie ou de certains serveurs de messagerie spécifiés.

    Remarque :
    Cette option n'est disponible que si vous avez sélectionné le mode automatique.

  12. Cliquez sur OK.

Une fois que vous avez configuré le courrier électronique entrant, les administrateurs de site peuvent configurer des listes et des bibliothèques de documents activées pour la messagerie électronique. Pour plus d'informations sur les bibliothèques de documents activées pour la messagerie électronique, voir Activer et configurer la prise en charge des courriers électroniques pour une liste ou une bibliothèque (http://go.microsoft.com/fwlink/?linkid=120164&clcid=0x40C).

Si vous avez sélectionné Service de gestion d'annuaire, les adresses de contacts créées pour les bibliothèques de documents s'affichent automatiquement dans Utilisateurs et ordinateurs Active Directory. Les adresses apparaissent dans l'unité d'organisation d'AD DS pour SharePoint Foundation 2010 et doivent être gérées par l'administrateur d'AD DS. Celui-ci peut ajouter d'autres adresses de messagerie pour chaque contact. Pour plus d'informations sur AD DS, voir Utilisation du service Active Directory (éventuellement en anglais)(http://go.microsoft.com/fwlink/?linkid=151348&clcid=0x40C).

Une autre possibilité consiste à configurer l'ordinateur Exchange Server en ajoutant une nouvelle stratégie de destinataire globale Exchange Server. La stratégie ajoute automatiquement les adresses externes qui utilisent le nom de domaine de second niveau et non pas le nom de sous-domaine ou d'hôte pour SharePoint Foundation 2010. Pour plus d'informations sur la façon de gérer Exchange Server, voir Microsoft Exchange Server 2007 (http://go.microsoft.com/fwlink/?linkid=83249&clcid=0x40C).

Manque-t-il des pièces jointes aux messages électroniques envoyés à une bibliothèque de documents SharePoint ?

Si des pièces jointes sont manquantes dans les messages électroniques envoyés à une bibliothèque de documents SharePoint Foundation 2010, il est possible que vous ayez associé la bibliothèque de documents à une adresse de messagerie. Lorsque vous effectuez cette opération, le service de gestion d'annuaire risque de ne pas ajouter les deux attributs suivants :

  • internet Encoding = 1310720

  • mAPIRecipient = false

Vous devez utiliser des interfaces ADSI (Active Directory Service Interface) pour ajouter manuellement ces deux attributs manquants.

Remarque :
Sur les serveurs qui exécutent Windows Server 2008 ou Windows Server 2008 R2, l'éditeur d'interface ADSI est installé lorsque vous installez le rôle AD DS pour convertir un serveur en un contrôleur de domaine. Vous pouvez également installer les outils d'administration de serveur distant Windows Server 2008 sur des serveurs membres du domaine ou sur des serveurs autonomes. Pour plus d'informations, voir Installation ou suppression du pack des outils d'administration de serveur distant(http://go.microsoft.com/fwlink/?linkid=143345&clcid=0x40C).

Pour ajouter des attributs à l'aide de l'outil ADSI

  1. Cliquez sur Démarrer, puis sur Exécuter.

  2. Dans la boîte de dialogue Exécuter, tapez Adsiedit.msc, puis cliquez sur OK.

  3. Dans la fenêtre Modification ADSI, développez Modification ADSI, Domaine [nom_domaine], DC=nom_domaine, DC=com, puis CN=utilisateurs.

  4. Cliquez avec le bouton droit sur le nom d'utilisateur auquel vous souhaitez ajouter les attributs manquants, puis cliquez sur Propriétés.

  5. Dans la boîte de dialogue Propriétés, double-cliquez sur internet Encoding sous l'onglet Éditeur d'attributs.

  6. Dans la boîte de dialogue Éditeur d'attributs de type Entier, tapez 1310720 dans la zone Valeur, puis cliquez sur OK.

  7. Dans la boîte de dialogue Propriétés, double-cliquez sur mAPIRecipient sous l'onglet Éditeur d'attributs.

  8. Dans la boîte de dialogue Éditeurs d'attributs booléens, cliquez sur Faux, puis cliquez sur OK deux fois.

Historique des modifications

Date | Description | Raison
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Configurer le courrier électronique sortant (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment configurer le courrier électronique sortant pour une batterie de serveurs ou pour une application Web spécifique pour Microsoft SharePoint Foundation 2010. Il explique également comment installer et configurer le service SMTP que vous devez utiliser pour activer le courrier électronique sortant.

Dans cet article :

  • Pour installer le service SMTP

  • Pour installer les outils de gestion d'IIS 6.0

  • Pour configurer le service SMTP

  • Pour configurer le service SMTP de manière à ce qu'il démarre automatiquement

  • Pour configurer le courrier électronique sortant pour une batterie de serveurs à l'aide de l'Administration centrale

  • Pour configurer le courrier électronique sortant pour une batterie de serveurs à l'aide de l'outil en ligne de commande Stsadm

  • Pour configurer le courrier électronique sortant pour une application Web spécifique à l'aide de l'Administration centrale

  • Pour configurer le courrier électronique sortant pour une application Web spécifique à l'aide de l'outil en ligne de commande Stsadm

Une fois que vous avez installé SharePoint Foundation 2010 et effectué la configuration initiale de votre batterie de serveurs, vous pouvez configurer le courrier électronique. Ceci permet aux utilisateurs de créer des alertes pour effectuer le suivi des éléments d'un site, tels que les listes, les bibliothèques et les documents. En outre, les administrateurs de site peuvent recevoir des messages d'administration liés aux problèmes d'administrateur de site, tels que des notifications signalant que des propriétaires de site ont dépassé leur limite d'espace de stockage spécifiée. Pour plus d'informations, voir Plan outgoing e-mail (SharePoint Foundation 2010) (en anglais).

Si vous souhaitez configurer le courrier électronique sortant pour une application Web spécifique, vous devez d'abord configurer le courrier électronique sortant par défaut pour toutes les applications Web dans la batterie de serveurs. Si vous configurez le courrier électronique sortant pour une application Web spécifique, cette configuration se substitue à la configuration par défaut pour toutes les applications Web dans la batterie de serveurs.

Remarque :
Il est impossible de configurer le courrier électronique sortant à l'aide de Windows PowerShell.

Avant d'effectuer ces procédures, vérifiez que :

  • Votre système exécute SharePoint Foundation 2010.

  • Un ou plusieurs serveurs de la batterie de serveurs exécutent le service SMTP (Simple Mail Transfer Protocol) et possèdent une adresse de serveur SMTP valide. Autrement, vous devez connaître le nom d'un serveur hors de la batterie exécutant le service SMTP.

Si vous n'avez pas installé et configuré le service SMTP, vous devez effectuer les procédures suivantes avant de configurer le courrier électronique sortant :

  • installer et configurer le service SMTP.

Installer et configurer le service SMTP

Avant d'activer le courrier électronique sortant, vous devez déterminer le serveur SMTP à utiliser. Ce serveur SMTP doit être configuré pour autoriser les envois de courrier électronique SMTP anonymes. Le serveur SMTP peut être un serveur appartenant à la batterie de serveurs ou externe à celle-ci.

Remarque :
Si votre organisation n'autorise pas l'envoi de messages électroniques SMTP anonymes à l'aide de Microsoft Exchange Server, vous pouvez utiliser dans la batterie de serveurs SharePoint un serveur SMTP local qui accepte les messages électroniques anonymes. Le serveur SMTP local authentifie automatiquement les messages, puis les transfère vers l'ordinateur Exchange Server.

Installer le service SMTP

Pour installer le service SMTP, utilisez l'Assistant Ajout de fonctionnalités dans le Gestionnaire de serveur. À la fin de l'assistant, une configuration SMTP par défaut aura été créée. Vous pouvez personnaliser cette configuration SMTP par défaut en fonction des besoins de votre organisation.

Remarque :
Si le service SMTP est déjà installé sur un serveur, vous pouvez ignorer la procédure suivante.

Pour installer le service SMTP

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes : vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Gestionnaire de serveur.

  3. Dans le Gestionnaire de serveur, cliquez sur Fonctionnalités.

  4. Dans Résumé des fonctionnalités, cliquez sur Ajouter des fonctionnalités pour ouvrir l'Assistant Ajout de fonctionnalités.

  5. Dans la page Sélectionner des fonctionnalités, sélectionnez Serveur SMTP.

  6. Dans la boîte de dialogue Assistant Ajout de fonctionnalités , cliquez sur Ajouter les fonctionnalités requises, puis cliquez sur Suivant.

  7. Dans la page Confirmer les sélections pour l'installation, cliquez sur Installer.

  8. Dans la page Résultats de l'installation, vérifiez que l'installation est terminée, puis cliquez sur Fermer.

Configurer le service SMTP

Après avoir installé le service SMTP, vous devez configurer le service pour qu'il accepte les messages électroniques en provenance des serveurs de la batterie de serveurs.

Vous pouvez décider d'accepter les messages électroniques relayés en provenance de tous les serveurs à l'exception de ceux que vous excluez spécifiquement. Ou bien, vous pouvez bloquer les messages en provenance de tous les serveurs à l'exception de ceux que vous incluez spécifiquement. Vous pouvez inclure des serveurs individuellement, ou en groupes par sous-réseau ou domaine.

Si vous activez l'accès anonyme et les messages électroniques relayés, vous augmentez le risque que le serveur soit utilisé pour relayer des messages électroniques publicitaires non sollicités (courrier indésirable). Il est important de limiter cette possibilité en configurant soigneusement les serveurs de messagerie afin de les protéger contre le courrier indésirable. L'une des méthodes que vous pouvez utiliser pour cela consiste à limiter les messages électroniques relayés à une liste de serveurs spécifiques ou à un domaine et à bloquer les messages électroniques relayés en provenance de tous les autres serveurs.

Remarque :
Pour gérer le service SMTP sur Windows Server 2008, vous devez utiliser Internet Information Services (IIS) 6.0 Manager. Veillez à installer les outils de gestion d'IIS 6.0 dans le Gestionnaire de serveur.

Pour installer les outils de gestion d'IIS 6.0

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes : vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Gestionnaire de serveur.

  3. Dans Gestionnaire de serveur, cliquez sur Rôles.

  4. Dans la section Services de rôle, cliquez sur Ajouter des services de rôle.

  5. Dans la page Sélectionner les services de rôle, sélectionnez Outils de gestion et IIS 6 Management Compatibility, puis cliquez sur Installer.

Pour configurer le service SMTP

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes : vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Internet Information Services (IIS) 6.0 Manager.

  3. Dans le Gestionnaire des services Internet (IIS), développez le nom du serveur contenant le serveur SMTP que vous souhaitez configurer.

  4. Cliquez avec le bouton droit sur le serveur virtuel SMTP que vous souhaitez configurer, puis cliquez sur Démarrer.

  5. Cliquez avec le bouton droit sur le serveur virtuel SMTP que vous souhaitez configurer, puis cliquez sur Propriétés.

  6. Sous l'onglet Accès, dans la zone Contrôle d'accès, cliquez sur Authentification.

  7. Dans la boîte de dialogue Authentification, vérifiez que l'option Accès anonyme est activée.

  8. Cliquez sur OK.

  9. Sous l'onglet Accès, dans la zone Restrictions de relais, cliquez sur Relais.

  10. Pour autoriser les messages électroniques relayés à partir de n'importe quel serveur, sélectionnez Tous sauf la liste ci-dessous.

  11. Pour accepter les messages électroniques relayés à partir d'un ou plusieurs serveurs spécifiques, procédez comme suit :

    1. Cliquez sur Uniquement la liste ci-dessous.

    2. Cliquez sur Ajouter, puis ajoutez les serveurs un par un par adresse IP, ou en groupes à l'aide d'un sous-réseau ou d'un domaine.

    3. Cliquez sur OK pour fermer la boîte de dialogue Ordinateur.

  12. Cliquez sur OK pour fermer la boîte de dialogue Restrictions de relais.

  13. Cliquez sur OK pour fermer la boîte de dialogue Propriétés.
Remarque :
Vérifiez que le service SMTP est en cours d'exécution et qu'il est configuré de manière à démarrer automatiquement. Pour ce faire, effectuez la procédure suivante.

Pour configurer le service SMTP de manière à ce qu'il démarre automatiquement

  1. Cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Services.

  2. Dans Services, cliquez avec le bouton droit sur SMTP (Simple Mail Transfer Protocol), puis sélectionnez Propriétés.

  3. Dans la boîte de dialogue Simple Mail Transfer Protocol (SMTP) Properties, sous l'onglet Général, dans la liste Type de démarrage, sélectionnez Automatique.

  4. Cliquez sur OK.

Configurer le courrier électronique sortant pour une batterie de serveurs

Vous pouvez configurer le courrier électronique sortant pour une batterie de serveurs à l'aide du site Web Administration centrale de SharePoint ou de l'outil en ligne de commande Stsadm. Utilisez les procédures suivantes pour configurer le courrier électronique sortant. Une fois les procédures réalisées, les utilisateurs finaux peuvent effectuer le suivi des modifications et des mises à jour apportées aux différentes collections de sites. En outre, les administrateurs de site peuvent, par exemple, recevoir des notifications lorsqu'un utilisateur demande l'accès à un site.

Pour configurer le courrier électronique sortant pour une batterie de serveurs à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes : vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans l'Administration centrale, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer les paramètres du courrier électronique sortant.

  4. Dans la page Paramètres du courrier électronique sortant, dans la section Paramètres de messagerie, tapez le nom du serveur SMTP pour le courrier sortant (par exemple, courrier.exemple.com) dans la zone Serveur SMTP sortant.

  5. Dans la zone Adresse de provenance, tapez l'adresse électronique qui doit apparaître aux destinataires des messages.

  6. Dans la zone Adresse de réponse, tapez l'adresse de messagerie à laquelle vous souhaitez que les destinataires du courrier répondent.

  7. Dans la liste Jeu de caractères, sélectionnez le jeu de caractères correspondant à votre langue.

  8. Cliquez sur OK.

Pour configurer le courrier électronique sortant pour une batterie de serveurs à l'aide de l'outil en ligne de commande Stsadm

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes : vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Sur le lecteur où sont installés les produits et technologies SharePoint, accédez au répertoire suivant : %COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\14\Bin.

  3. Tapez la commande suivante, puis appuyez sur Entrée :

    stsadm -o email

    -outsmtpserver <nom du serveur SMTP>

    -fromaddress <adresse électronique valide>

    -replytoaddress <adresse électronique valide>

    -codepage <page de code valide>

Exemple

stsadm -o email -outsmtpserver mail.example.com -fromaddress xyz@example.com -replytoaddress xyz@example.com -codepage 65001

Pour plus d'informations, voir Email : opération Stsadm (Windows SharePoint Services) (http://go.microsoft.com/fwlink/?linkid=150046&clcid=0x40C).

Configurer le courrier électronique sortant pour une application Web spécifique

Vous pouvez configurer le courrier électronique sortant pour une application Web spécifique à l'aide du site Web Administration centrale ou de l'outil en ligne de commande Stsadm. Utilisez les procédures suivantes pour configurer le courrier électronique sortant. Une fois les procédures réalisées, les utilisateurs finaux peuvent effectuer le suivi des modifications et des mises à jour apportées aux différentes collections de sites. En outre, les administrateurs de site peuvent, par exemple, recevoir des notifications lorsqu'un utilisateur demande l'accès à un site.

Remarque :
Si vous souhaitez configurer le courrier électronique sortant pour une application Web spécifique, vous devez d'abord configurer le courrier électronique sortant par défaut pour toutes les applications Web dans la batterie de serveurs. Si vous configurez le courrier électronique sortant pour une application Web spécifique, cette configuration se substitue à la configuration par défaut pour toutes les applications Web dans la batterie de serveurs.

Pour configurer le courrier électronique sortant pour une application Web spécifique à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes : vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Dans la page Gestion des applications Web, sélectionnez une application Web, puis, dans le groupe Paramètres généraux du ruban, cliquez sur Courrier électronique sortant.

  4. Dans la page Paramètres de courrier sortant de l'application Web, dans la section Paramètres de messagerie, tapez le nom du serveur SMTP pour le courrier sortant (par exemple, courrier.fabrikam.com) dans la zone Serveur SMTP sortant.

  5. Dans la zone Adresse de provenance, tapez l'adresse électronique qui doit apparaître aux destinataires des messages (par exemple, l'alias de l'administrateur du site).

  6. Dans la zone Adresse de réponse, tapez l'adresse de messagerie à laquelle vous souhaitez que les destinataires du courrier répondent (par exemple, un alias du support technique).

  7. Dans la liste Jeu de caractères, cliquez sur le jeu de caractères correspondant à votre langue.

  8. Cliquez sur OK.

Pour configurer le courrier électronique sortant pour une application Web spécifique à l'aide de l'outil en ligne de commande Stsadm

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes : vous devez être membre du groupe Administrateurs sur l'ordinateur local.

  2. Sur le lecteur où sont installés les produits et technologies SharePoint, accédez au répertoire suivant : %COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\14\Bin.

  3. Tapez la commande suivante, puis appuyez sur Entrée :

    stsadm -o email

    -outsmtpserver <nom du serveur SMTP>

    -fromaddress <adresse électronique valide>

    -replytoaddress <adresse électronique valide>

    -codepage <page de code valide>

    [-url <nom d'URL> ]

Exemple

stsadm -o email -outsmtpserver mail.example.com -fromaddress xyz@example.com -replytoaddress xyz@example.com -codepage 65001 -url http://nom_serveur

Pour plus d'informations, voir Email : opération Stsadm (Windows SharePoint Services) (http://go.microsoft.com/fwlink/?linkid=150046&clcid=0x40C).

Voir aussi

Concepts

Plan outgoing e-mail (SharePoint Foundation 2010) (en anglais)
Configurer les paramètres d'alerte d'une application Web (SharePoint Foundation 2010)

Historique des modifications


Configurer un compte mobile (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment configurer et gérer un compte mobile pour que Microsoft SharePoint Foundation 2010 permette aux utilisateurs de s'abonner à des alertes envoyées via SMS (Short Message Service). Les alertes sont envoyées aux téléphones mobiles des utilisateurs lorsque des modifications sont apportées à une liste ou à un élément SharePoint.

La fonctionnalité d'alerte mobile ressemble à une fonctionnalité existant déjà dans SharePoint Foundation 2010 et qui permet l'envoi d'alertes par courrier électronique. Cependant, au lieu de recevoir des alertes par courrier électronique lorsque des modifications sont apportées à une liste ou un élément SharePoint, les utilisateurs reçoivent les alertes sur leur téléphone mobile. Pour plus d'informations sur les alertes par courrier électronique, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010).

Un site SharePoint se trouve généralement sur un intranet. Par conséquent, l'accès au site SharePoint peut être difficile pour les utilisateurs qui ne sont pas à leur bureau, par exemple, lorsqu'ils sont en déplacement ou participent à un dîner d'affaires. La fonctionnalité d'alerte mobile permet aux utilisateurs de réagir rapidement lorsqu'ils reçoivent une alerte SMS indiquant qu'un élément d'une liste SharePoint a été modifié.

Vous pouvez configurer un compte mobile pour toutes les applications Web dans une batterie de serveurs ou vous pouvez configurer le compte mobile pour une application Web spécifique ; toutefois, vous ne pouvez configurer qu'un seul compte mobile dans la batterie de serveurs. L'échelle de votre implémentation peut déterminer si vous configurez le compte mobile pour la batterie de serveurs ou pour une application Web spécifique. Si vous configurez le compte mobile pour une batterie de serveurs, toute personne au sein de l'organisation peut s'abonner aux alertes. Cela est utile, par exemple, au sein d'une petite organisation dont l'équipe dirigeante souhaite que tous les utilisateurs reçoivent certaines alertes. Si, dans le cadre de vos différentes applications Web, votre organisation est divisée en groupes, vous pouvez configurer un compte mobile pour un seul de ces groupes ; par exemple, vous souhaiterez configurer un compte mobile pour permettre à toute personne au sein du groupe des ventes de s'abonner aux alertes.

Avant d'effectuer ces procédures, vérifiez que :

  • Le compte de la batterie de serveurs est autorisé à accéder à Internet pour envoyer des alertes.

  • Vous avez obtenu le certificat racine correspondant à l'adresse Web HTTPS du fournisseur de services. Vous pouvez obtenir le certificat racine de la part de votre fournisseur de services ou via votre navigateur Web.

Procédures décrites dans cet article :

  • Importer un certificat racine et créer une autorité racine approuvée

  • Configurer un compte mobile

  • Récupérer les informations du compte mobile

  • Supprimer un compte mobile

Importer un certificat racine et créer une autorité racine approuvée

Avant de configurer un compte mobile, vous devez d'abord importer le certificat racine de l'adresse Web HTTPS du fournisseur de services, puis créer une autorité racine approuvée. Cette étape ne peut être effectuée que manuellement à l'aide de Windows PowerShell.

Pour importer un certificat racine et créer une autorité racine approuvée à l'aide de Windows PowerShell

  1. Vérifiez que les exigences minimales suivantes sont satisfaites : Voir Add-SPShellAdmin. En outre, vous devez être membre du groupe Administrateurs de batterie de serveurs et membre du groupe Administrateurs local sur l'ordinateur qui exécute Windows PowerShell.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Pour obtenir le certificat racine, à l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $cert = Get-PfxCertificate <ObtainedCertificatePath>

    Pour créer une autorité racine approuvée, à l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    New-SPTrustedRootAuthority -Name <Name> -Certificate $cert

    Où :

    • <Name> est le nom de l'autorité racine approuvée que vous souhaitez créer.

    • <ObtainedCertificatePath> est l'emplacement du fichier de certificat racine.

    Remarque :
    Dans la fenêtre Certificat, sous l'onglet Chemin d'accès de certification, assurez-vous d'utiliser uniquement le certificat racine et non les autres certificats listés. La liste des autorités racines approuvées SharePoint ne doit répertorier que les certificats racines.

Pour plus d'informations, voir New-SPTrustedRootAuthority.

Configurer un compte mobile

Vous pouvez configurer un compte mobile pour une batterie de serveurs ou pour une application Web spécifique, soit en utilisant l'Administration centrale, soit via Windows PowerShell.

Remarque :
Si vous ne pouvez pas configurer un compte mobile, cela signifie peut-être que vous disposez d'un certificat erroné. Dans ce cas, contactez votre fournisseur de services.

Pour configurer ou modifier un compte mobile pour une batterie de serveurs à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour configurer un compte mobile pour une batterie de serveurs, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer le compte mobile.

  4. Dans la page Paramètres de compte mobile, dans la section Paramètres du service de message texte (SMS), cliquez sur le lien Microsoft Office Online pour accéder à une liste de fournisseurs de services.

  5. Dans la page Rechercher un fournisseur de services mobiles Office 2010, dans la liste Choisir le pays/la région du fournisseur de services sans fil, sélectionnez le pays ou la région où se trouve votre fournisseur de services sans fil.

  6. Dans la page Find an Office 2010 Mobile Service Provider, dans la liste Choose your current wireless service provider, sélectionnez le fournisseur de services sans fil à utiliser.

    Après avoir effectué cette sélection, vous êtes dirigé vers le site Web du fournisseur de services que vous avez sélectionné. Sur le site Web, vous souscrivez au service SMS. Lorsque vous recevez les informations requises du fournisseur de services, retournez à la page Paramètres de compte mobile.

  7. Dans la zone URL du service de message texte (SMS), tapez l'URL du service SMS.

    Remarque :
    Assurez-vous que l'URL de service que vous entrez est une URL HTTPS.

  8. Dans les zones Nom d'utilisateur et Mot de passe, tapez le nom d'utilisateur et le mot de passe que vous a fournis le fournisseur de services SMS.

  9. Pour confirmer que l'URL et les informations d'identification utilisateur sont correctes, cliquez sur Tester le service.

  10. Cliquez sur OK.

Pour configurer ou modifier un compte mobile pour une batterie de serveurs à l'aide de Windows PowerShell

  1. Vérifiez que les exigences minimales suivantes sont satisfaites : Voir Add-SPShellAdmin. En outre, vous devez être membre du groupe Administrateurs de batterie de serveurs et membre du groupe Administrateurs local sur l'ordinateur qui exécute Windows PowerShell.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPMobileMessagingAccount -Identity sms -WebApplication <WebApplicationUrl> [-ServiceUrl <ServiceUrl>] [-UserId <UserId>] [-Password <Password>]

    Où :

    • <WebApplicationUrl> est l'URL de l'Administration centrale.

    • <ServiceUrl> est l'URL du serveur où se trouve le service SMS.

    • <UserId> est le nom d'utilisateur que vous avez reçu de la part du fournisseur de services SMS.

    • <Password> est le mot de passe d'utilisateur que vous avez reçu de la part du fournisseur de services SMS.

    Exemple :

    Code de copie
    Set-SPMobileMessagingAccount -Identity sms -WebApplication http://myserver:8080 -ServiceUrl https://www.example.com/omsservice.asmx -UserId someone@example.com -Password password1

    Si vous utilisez l'opérateur de pipeline, tapez la commande suivante :

    Code de copie
    Get-SPWebApplication -Identity http://myserver:8080 | Set-SPMobileMessagingAccount -Identity sms -ServiceUrl https://www.example.com/omsservice.asmx -UserId someone@example.com -Password password1
    Remarque :
    Assurez-vous que l'URL de service que vous entrez est une URL HTTPS.

Pour plus d'informations, voir Set-SPMobileMessagingAccount et Get-SPWebApplication.

Pour configurer ou modifier un compte mobile pour une application Web à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour configurer un compte mobile pour une batterie de serveurs, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web d'administration centrale de SharePoint.

  2. Sur la page d'accueil Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Dans la page Applications Web, sélectionnez l'application Web pour laquelle vous souhaitez configurer un compte mobile. Dans le Ruban, dans Paramètres généraux, cliquez sur Compte mobile.

  4. Dans la page Paramètres du service de message texte (SMS) de l'application Web, dans la section Paramètres du service de message texte (SMS), cliquez sur le lien Microsoft Office Online pour accéder à une liste de fournisseurs de services.

  5. Dans la page Find an Office 2010 Mobile Service Provider, dans la liste Choose your wireless service provider's country/region, sélectionnez le pays ou la région dans lequel se trouve votre fournisseur de services sans fil.

  6. Dans la page Find an Office 2010 Mobile Service Provider, dans la liste Choose your current wireless service provider, sélectionnez le fournisseur de services sans fil à utiliser.

    Après avoir effectué cette sélection, vous êtes dirigé vers le site Web du fournisseur de services que vous avez sélectionné. Sur le site Web, vous souscrivez au service SMS. Lorsque vous recevez les informations requises du fournisseur de services, retournez à la page Paramètres de compte mobile et entrez les informations.

  7. Dans la zone URL du service de message texte (SMS), tapez l'URL du service SMS.

    Remarque :
    Assurez-vous que l'URL de service que vous entrez est une URL HTTPS.

  8. Dans les zones Nom d'utilisateur et Mot de passe, tapez le nom d'utilisateur et le mot de passe que vous a fournis le fournisseur de services SMS.

  9. Pour confirmer que l'URL et les informations d'identification utilisateur sont correctes, cliquez sur Tester le service.

  10. Cliquez sur OK.

Pour configurer ou modifier un compte mobile pour une application Web à l'aide de Windows PowerShell

  1. Vérifiez que les exigences minimales suivantes sont satisfaites : Voir Add-SPShellAdmin. En outre, vous devez être membre du groupe Administrateurs de batterie de serveurs et membre du groupe Administrateurs local sur l'ordinateur qui exécute Windows PowerShell.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (c'est-à-dire PS C:\>), tapez la commande suivante :

    Code de copie
    Set-SPMobileMessagingAccount -Identity sms -WebApplication <WebApplicationUrl> [-ServiceUrl <ServiceUrl>] [-UserId <UserId>] [-Password <Password>]

    Où :

    • <WebApplicationUrl> est l'URL de l'application Web.

    • <ServiceUrl> est l'URL du serveur où se trouve le service SMS.

    • <UserId> est le nom d'utilisateur que vous avez reçu de la part du fournisseur de services SMS.

    • <Password> est le mot de passe d'utilisateur que vous avez reçu de la part du fournisseur de services SMS.

    Exemple :

    Code de copie
    Set-SPMobileMessagingAccount -Identity sms -WebApplication http://localhost -ServiceUrl https://www.example.com/omsservice.asmx -UserId someone@example.com -Password password1

    Si vous utilisez l'opérateur de pipeline, tapez la commande suivante :

    Code de copie
    Get-SPWebapplication -Identity http://localhost | Set-SPMobileMessagingAccount -Identity sms -ServiceUrl https://www.example.com/omsservice.asmx -UserId someone@example.com -Password password1
    Remarque :
    Assurez-vous que l'URL de service que vous entrez est une URL HTTPS.

Pour plus d'informations, voir Set-SPMobileMessagingAccount et Get-SPWebApplication.

Récupérer les informations du compte mobile

Vous pouvez récupérer des informations de compte mobile pour une batterie de serveurs ou une application Web à l'aide de Windows PowerShell. Cela vous permet de consulter les informations de compte mobile ou, par exemple, de vérifier que l'applet de commande set fonctionne correctement.

Pour récupérer des informations de compte mobile pour une batterie de serveurs à l'aide de Windows PowerShell

  1. Vérifiez que les exigences minimales suivantes sont satisfaites : Voir Add-SPShellAdmin. En outre, vous devez être membre du groupe Administrateurs de batterie de serveurs et membre du groupe Administrateurs local sur l'ordinateur qui exécute Windows PowerShell.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPMobileMessagingAccount -WebApplication <WebApplicationUrl>

    Où <WebApplicationUrl> est l'URL de l'Administration centrale.

    Exemple

    Code de copie
    Get-SPMobileMessagingAccount -WebApplication http://myserver

    Si vous utilisez l'opérateur de pipeline, tapez la commande suivante :

    Code de copie
    Get-SPWebApplication -Identity http://myserver | Get-SPMobileMessagingAccount -AccountType sms

Pour plus d'informations, voir Get-SPMobileMessagingAccount et Get-SPWebApplication.

Pour récupérer des informations de compte mobile pour une application Web à l'aide de Windows PowerShell

  1. Vérifiez que les exigences minimales suivantes sont satisfaites : Voir Add-SPShellAdmin. En outre, vous devez être membre du groupe Administrateurs de batterie de serveurs et membre du groupe Administrateurs local sur l'ordinateur qui exécute Windows PowerShell.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPMobileMessagingAccount -WebApplication <WebApplicationUrl>

    Où <WebApplicationUrl> est l'URL de l'application Web.

    Exemple

    Code de copie
    Get-SPMobileMessagingAccount -WebApplication http://localhost

    Si vous utilisez l'opérateur de pipeline, tapez la commande suivante :

    Code de copie
    Get-SPWebApplication -Identity http://localhost | Get-SPMobileMessagingAccount -AccountType sms

Pour plus d'informations, voir Get-SPMobileMessagingAccount et Get-SPWebApplication.

Supprimer un compte mobile

Vous pouvez supprimer un compte mobile pour une batterie de serveurs ou pour une application Web. Cette opération rend le compte non disponible, ce qui empêche les utilisateurs de s'abonner aux alertes SMS, mais elle ne supprime pas le compte que vous avez configuré avec le fournisseur de services. Vous pouvez supprimer un compte mobile, par exemple si l'organisation décide que l'envoi d'alertes SMS aux utilisateurs n'a pas de valeur ajoutée.

Remarque :
Il n'existe pas de fonctionnalité Windows PowerShell équivalente.

Pour supprimer un compte mobile pour une batterie de serveurs

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour supprimer un compte mobile pour une batterie de serveurs, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer le compte mobile.

  4. Dans la page Paramètres de compte mobile, effacez les entrées de toutes les zones, puis cliquez sur OK.

Pour supprimer un compte mobile pour une application Web

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour supprimer un compte mobile pour une batterie de serveurs, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur la page d'accueil Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Dans le Ruban, dans Paramètres généraux, cliquez sur Compte mobile.

  4. Dans la page Paramètres du service de message texte (SMS) de l'application Web, effacez les entrées de toutes les zones, puis cliquez sur OK.

Voir aussi

Concepts

Configurer le courrier électronique sortant (SharePoint Foundation 2010)

Historique des modifications


Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010)

Cet article décrit comment installer et configurer le stockage BLOB distant (RBS, Remote BLOB Storage) et le fournisseur FILESTREAM sur un serveur de base de données Microsoft SQL Server 2008 qui prend en charge un système Microsoft SharePoint Foundation 2010.

RBS est un ensemble d'API de bibliothèque incorporé en tant que module complémentaire pour Microsoft SQL Server 2008 et Microsoft SQL Server 2008 Express. RBS est conçu pour déplacer le stockage des objets BLOB (Binary Large Objects) depuis des serveurs de bases de données vers des solutions de stockage de produits. RBS accompagne le fournisseur RBS FILESTREAM, qui utilise les API RBS pour stocker les objets BLOB. Pour plus d'informations sur RBS, voir Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010).

Dans cet article :

  • Activer FILESTREAM et mettre en service le magasin de données RBS

  • Installer RBS

  • Activer et tester RBS

Le compte d'utilisateur que vous utilisez pour effectuer les procédures décrites dans cet article doit appartenir :

  • au groupe Administrateurs sur les serveurs Web et les serveurs d'applications ;

  • aux rôles serveur fixes dbcreator et securityadmin SQL Server sur l'ordinateur exécutant SQL Server 2008 Express ou SQL Server 2008.

Activer FILESTREAM et mettre en service le magasin de données RBS

Vous devez activer et configurer FILESTREAM sur l'ordinateur qui exécute SQL Server 2008 et qui héberge les bases de données SharePoint Foundation 2010. Pour activer et configurer FILESTREAM, suivez les instructions indiquées dans Procédure : activer FILESTREAM (http://go.microsoft.com/fwlink/?linkid=166110&clcid=0x40C). Après avoir activé et configuré FILESTREAM, mettez en service un magasin BLOB comme indiqué ici.

Mettre en service un magasin BLOB

  1. Cliquez sur Démarrer, sur Tous les programmes, sur Microsoft SQL Server 2008, puis sur SQL Server Management Studio.

  2. Développez Bases de données.

  3. Sélectionnez la base de données de contenu pour laquelle vous souhaitez créer un magasin BLOB, puis cliquez sur Nouvelle requête.

  4. Dans le volet Requête, copiez et exécutez chacune des requêtes SQL suivantes, dans l'ordre indiqué. Dans chaque cas, remplacez [WSS_Content] par le nom de la base de données de contenu, et c:\BLOBStore par le volume\répertoire dans lequel vous voulez créer le magasin BLOB. Sachez que vous ne pouvez mettre en service un magasin BLOB qu'une seule fois. Si vous essayez de mettre en service le même magasin BLOB plusieurs fois, vous recevez un message d'erreur.

    Conseil :
    Pour optimiser les performances, simplifier la résolution des problèmes et suivre une meilleure pratique générale, il est recommandé de créer le magasin BLOB sur un volume qui ne contient pas le système d'exploitation, les fichiers d'échange, les données de base de données, les fichiers journaux ou le fichier tempdb.

    Code de copie
    use [WSS_Content]
if not exists (select * from sys.symmetric_keys where name = N'##MS_DatabaseMasterKey##')create master key encryption by password = N'Admin Key Password !2#4'
    Code de copie
    use [WSS_Content]
if not exists (select groupname from sysfilegroups where groupname=N'RBSFilestreamProvider')alter database [WSS_Content]
 add filegroup RBSFilestreamProvider contains filestream
    Code de copie
    use [WSS_Content]
alter database [WSS_Content] add file (name = RBSFilestreamFile, filename = 'c:\Blobstore') to filegroup RBSFilestreamProvider

Installer RBS

Vous devez installer RBS sur la totalité des serveurs Web et des serveurs d'applications de la batterie de serveurs SharePoint. RBS est configuré séparément pour chaque base de données de contenu associée.

Avertissement :
N'installez pas RBS en exécutant le fichier RBS_X64.msi et en lançant l'Assistant Installation du stockage étendu des objets blob SQL. L'Assistant définit certaines valeurs par défaut qui ne sont pas recommandées pour SharePoint Foundation 2010.

Installer RBS sur le serveur de bases de données et sur le premier serveur Web

  1. Sur un serveur Web, accédez à la page http://go.microsoft.com/fwlink/?linkid=165839&clcid=0x40C (http://go.microsoft.com/fwlink/?linkid=165839&clcid=0x40C) et téléchargez le fichier RBS_X64.msi.

  2. Cliquez sur Démarrer, puis tapez invite de commandes dans la zone de texte. Dans la liste des résultats, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu'administrateur. Cliquez sur OK.

  3. Copiez la commande suivante, puis collez-la dans la fenêtre d'invite de commandes. Vous ne devez exécuter cette commande avec les noms de base de données et d'instance SQL Server spécifiques qu'une seule fois. L'opération doit se terminer dans un délai d'une minute environnement.

    Code de copie
    msiexec /qn /lvx* rbs_install_log.txt /i RBS_X64.msi TRUSTSERVERCERTIFICATE=true FILEGROUP=PRIMARY DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" FILESTREAMFILEGROUP=RBSFilestreamProvider FILESTREAMSTORENAME=FilestreamProvider_1

    Où :

    • WSS_Content représente le nom de la base de données ;

    • DBInstanceName représente le nom de l'instance SQL Server.

Installer RBS sur tous les serveurs Web et d'applications supplémentaires

  1. Sur un serveur Web, accédez à la page http://go.microsoft.com/fwlink/?linkid=165839&clcid=0x40C (http://go.microsoft.com/fwlink/?linkid=165839&clcid=0x40C) et téléchargez le fichier RBS_X64.msi.

  2. Cliquez sur Démarrer, puis tapez invite de commandes dans la zone de texte. Dans la liste des résultats, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu'administrateur. Cliquez sur OK.

  3. Copiez la commande suivante puis collez-la dans la fenêtre d'invite de commandes. Remplacez WSS_Content par le nom de la base de données et DBInstanceName par le nom de l'instance SQL Server. L'opération doit se terminer dans un délai d'une minute environnement.

    Code de copie
    msiexec /qn /lvx* rbs_install_log.txt /i RBS_X64.msi DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" ADDLOCAL="Client,Docs,Maintainer,ServerScript,FilestreamClient,FilestreamServer"

  4. Répétez cette procédure pour la totalité des serveurs Web et des serveurs d'applications.

Vérifier l'installation de RBS

  1. Le fichier journal log.txt est créé au même emplacement que le fichier RBS_X64.msi. Ouvrez le fichier journal rbs_install_log.txt avec un éditeur de texte et faites-le défiler vers le bas. Dans les 20 dernières lignes de la fin du fichier, une entrée doit se présenter comme suit : « Produit : Stockage étendu des objets blob SQL - L'installation s'est terminée correctement ».

  2. Sur l'ordinateur exécutant SQL Server 2008, vérifiez que les tables RBS ont été créées dans la base de données de contenu. Plusieurs tables doivent résider sous la base de données de contenu et porter des noms précédés des lettres « mssqlrbs ».

Activer et tester RBS

Vous devez activer RBS sur un seul serveur Web de la batterie de serveurs SharePoint. Peu importe le serveur Web que vous choisissez à cette fin, à condition que RBS y ait été installé à l'aide de la procédure précédente.

Activer RBS

  1. Dans le menu Démarrer, cliquez successivement sur Programmes, Microsoft SharePoint 2010 Products et SharePoint 2010 Management Shell.

  2. Depuis l'invite de commandes Windows PowerShell, tapez chacune des commandes suivantes. Remplacez http://nomsite par l'application Web connectée à la base de données de contenu.

    $cdb = Get-SPContentDatabase -WebApplication http://nomsite

    $rbss = $cdb.RemoteBlobStorageSettings

    $rbss.Installed()

    $rbss.Enable()

    $rbss.SetActiveProviderName($rbss.GetProviderNames()[0])

    $rbss

Tester le magasin de données RBS

  1. Cliquez successivement sur Démarrer, Tous les programmes, Microsoft SQL Server 2008 et SQL Server Management Studio.

  2. Développez Bases de données.

  3. Sélectionnez la base de données de contenu pour laquelle vous avez activé RBS, puis cliquez sur Nouvelle requête.

  4. Accédez au répertoire du magasin de données RBS.

  5. Accédez à la liste des fichiers, puis ouvrez le dossier portant la date de modification la plus récente (autre que $FSLOG). Dans ce dossier, ouvrez le fichier portant la date de modification la plus récente. Il doit s'agir du fichier que vous avez téléchargé.

Pour autoriser des bases de données supplémentaires à utiliser RBS, voir Définir une base de données de contenu de manière à utiliser le stockage BLOB distant (RBS) (SharePoint Foundation 2010).

Historique des modifications


Configurer les services (SharePoint Foundation 2010)

Dans Microsoft SharePoint Foundation 2010, vous pouvez configurer des services individuels indépendamment et implémenter uniquement les services nécessaires à votre organisation. Pour plus d'informations sur la façon de démarrer, arrêter et configurer les services, voir Gérer les services sur le serveur (SharePoint Foundation 2010).

Les services déployés sont nommés applications de service. Une application de service fournit une ressource qui peut être partagée entre les sites au sein d'une batterie de serveurs ou parfois de plusieurs batteries de serveurs, et accessibles aux utilisateurs via une application d'hébergement Web. Les applications de service sont associées aux applications Web par des connexions d'application de service. Pour plus d'informations sur la gestion et la publication des applications de service, voir Gérer les applications de service et les services (SharePoint Foundation 2010).

Pour plus d'informations sur les services et les applications de service, voir Diagrammes techniques (SharePoint Foundation 2010).

Cette section contient les articles suivants :

  • Gérer les applications de service et les services (SharePoint Foundation 2010)

    Cet article présente les structures des applications de services et des services dans Microsoft SharePoint Foundation 2010, et explique comment gérer les applications de services et les services.

  • Configurer le service de jeton de sécurité (SharePoint Foundation 2010)

    Cet article vous aide à configurer le service d'émission de jeton de sécurité Microsoft SharePoint Foundation 2010. Il s'agit d'un service Web spécialisé conçu pour répondre aux demandes portant sur les jetons de sécurité et fournir la gestion des identités.

Historique des modifications


Gérer les applications de service et les services (SharePoint Foundation 2010)
Voir aussi

Les articles de cette section traitent des structures des applications de service et des services dans Microsoft SharePoint Foundation 2010 et expliquent comment les applications de service et les services peuvent être gérés. Ces articles sont destinés aux administrateurs de batterie de serveurs et aux administrateurs d'applications de service qui exécuteront SharePoint Foundation 2010.

Dans cette section

  • About service applications and services

    Fournit une introduction à l'infrastructure logique des applications de service et des services.

  • Gérer les applications de service et les services (SharePoint Foundation 2010)

    Décrit comment gérer, créer, configurer et partager des applications de service.

  • Gérer les services sur le serveur (SharePoint Foundation 2010)

    Décrit comment les services peuvent être démarrés, arrêtés et configurés.

Voir aussi

Concepts

Gérer des applications Web (SharePoint Foundation 2010)
Diagrammes techniques (SharePoint Foundation 2010)

Historique des modifications


Configurer le service de jeton de sécurité (SharePoint Foundation 2010)

Cet article fournit des instructions pour vous aider à configurer le service de jeton de sécurité (STS) de Microsoft SharePoint Foundation 2010. Ce service Web spécialisé est conçu pour répondre aux demandes de jeton de sécurité et fournir une gestion des identités. La fonctionnalité principale de chaque service STS est la même, mais la nature des tâches effectuées par chacun dépend du rôle que le service STS joue en relation avec les autres services Web STS de votre conception.

Dans cet article :

  • Comment fonctionnent les applications Web qui utilisent un service STS

  • Configurer une application Web basée sur les revendications SharePoint à l'aide de Windows PowerShell

  • Modifier les liaisons

  • Configurer une application Web qui utilise un service STS

Comment fonctionnent les applications Web qui utilisent un service STS

Les applications Web qui utilisent un service d'émission de jeton de sécurité gèrent les demandes d'émission, de gestion et de validation de jetons de sécurité. Les jetons de sécurité sont composés d'une collection de revendications d'identité (par exemple, un nom d'utilisateur, un rôle ou un identificateur anonyme). Les jetons peuvent être émis dans différents formats, par exemple des jetons SAML (Security Assertion Markup Language). Les jetons de sécurité peuvent être protégés par un certificat X.509 afin de protéger leur contenu dans les transits et permettre la validation des émetteurs approuvés. Pour des informations supplémentaires sur le service d'émission de jeton de sécurité, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010).

Un fournisseur d'identités avec service d'émission de jeton de sécurité (IP-STS) est un service Web qui gère les demandes de revendications d'identité approuvée. Il utilise une base de données nommée magasin d'identités pour stocker et gérer les identités et les attributs qui leur sont associés. Le magasin d'identités d'un fournisseur d'identités peut être une simple table de base de données SQL. Un service IP-STS peut également utiliser un magasin d'identités complexe, comme les services de domaine Active Directory (AD DS) ou les services d'annuaire Active Directory Lightweight Directory Service (AD LDS).

Un service IP-STS est disponible pour les clients qui souhaitent créer et gérer des identités, et pour les applications de partie de confiance qui doivent valider les identités que les clients leur présentent. Chaque service IP-STS a une relation d'approbation fédérée avec les applications Web STS de partie de confiance de partenaire de fédération (RP-STS) pour lesquelles il émet des jetons. Les clients peuvent créer ou fournir des cartes d'informations gérées (à l'aide d'un sélecteur de carte tel qu'un CardSpace) qui représentent les identités enregistrées avec le service IP-STS. Les clients interagissent avec le service IP-STS lorsqu'ils demandent des jetons de sécurité qui représentent une identité contenue dans le magasin d'identités du service IP-STS. Après authentification, le service IP-STS émet un jeton de sécurité approuvé que le client peut présenter à une application de partie de confiance. Les applications de partie de confiance peuvent établir des relations d'approbation avec un service IP-STS. Cela leur permet de valider les jetons de sécurité émis par un service IP-STS. Une fois la relation d'approbation établie, les applications de partie de confiance peuvent examiner les jetons de sécurité présentés par des clients et déterminer la validité des revendications d'identité qu'ils contiennent.

Un service RP-STS est service STS de partie de confiance qui reçoit des jetons de sécurité provenant d'un partenaire de fédération approuvé IP-STS. À son tour, le service RP-STS émet de nouveaux jetons de sécurité qui sont utilisés par une application de partie de confiance locale. L'utilisation d'applications Web RP-STS en fédération avec des applications Web IP-STS permet aux organisations d'offrir l'authentification Web unique (SSO) aux utilisateurs d'organisations partenaires. Chaque organisation continue à gérer ses propres magasins d'identités.

Configurer une application Web basée sur les revendications SharePoint à l'aide de Windows PowerShell

Pour configurer une application Web basée sur les revendications SharePoint à l'aide de Windows PowerShell, procédez comme suit.

Pour configurer une application Web basée sur les revendications SharePoint à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), créez un objet x509Certificate2, comme dans l'exemple suivant :

    Code de copie
    $cert = New-Object
System.Security.Cryptography.X509Certificates.X509Certificate2("path to cert file")

  6. Créez un mappage de type revendication à utiliser dans votre fournisseur d'authentification approuvé, comme dans l'exemple suivant :

    Code de copie
    New-SPClaimTypeMapping "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress"
-IncomingClaimTypeDisplayName "EmailAddress" -SameAsIncoming

  7. Créez un fournisseur de connexion approuvé en créant d'abord une valeur pour le paramètre de domaine, comme dans l'exemple suivant :

    Code de copie
    $realm = "urn:" + $env:ComputerName + ":domain-int"

  8. Créez une valeur pour le paramètre signinurl qui pointe vers l'application Web de service d'émission de jeton de sécurité, comme dans l'exemple suivant :

    Code de copie
    $signinurl = "https://test-2/FederationPassive/"

  9. Créez le fournisseur de connexion approuvé, en utilisant la même valeur IdentifierClaim dans un mappage de revendication ($map1.InputClaimType), comme dans l'exemple suivant :

    Code de copie
    $ap = New-SPTrustedIdentityTokenIssuer -Name
"WIF" -Description "Windows® Identity Foundation" -Realm
$realm -ImportTrustCertificate $cert
-ClaimsMappings $map1[,$map2..] -SignInUrl
$signinurl -IdentifierClaim $map1.InputClaimType

  10. Créez une application Web en créant d'abord une valeur pour le compte du pool d'applications (pour l'utilisateur actuel), comme dans l'exemple suivant :

    Code de copie
    $account = "DOMAIN\" + $env:UserName
    Remarque :
    Le compte du pool d'applications doit être un compte géré. Pour créer un compte géré, utilisez New-SPManagedAccount.

  11. Créez une valeur pour l'URL de l'application Web ($webappurl = "https://" + $env:ComputerName), comme dans l'exemple suivant :

    Code de copie
    $wa = New-SPWebApplication -name "Claims WIF"
-SecureSocketsLayer -ApplicationPool "SharePoint SSL"
-ApplicationPoolAccount $account -Url $webappurl -Port 443
-AuthenticationProvider $ap

  12. Créez un site en créant d'abord un objet revendication, comme dans l'exemple suivant :

    Code de copie
    $claim = New-SPClaimsPrincipal
-TrustedIdentityTokenIssuerr $ap -Identity
$env:UserName

  13. Créez un site, comme dans l'exemple suivant :

    Code de copie
    $site = New-SPSite $webappurl -OwnerAlias
$claim.ToEncodedString() -template "STS#0"

Modifier les liaisons

Après avoir configuré une application Web SharePoint basée sur les revendications, modifiez les liaisons.

Pour modifier les liaisons

  1. Lancez le gestionnaire IIS en tapant INETMGR dans une invite de commandes.

  2. Accédez au site Application Web basée sur les revendications dans IIS.

  3. Dans le volet gauche, cliquez avec le bouton droit sur Application Web basée sur les revendications, puis sélectionnez Modifier les liaisons.

  4. Sélectionnez https et cliquez sur Modifier.

  5. Sous Certificat SSL, sélectionnez un certificat dans la liste.

Configurer une application Web qui utilise un service STS

Après avoir configuré une application Web basée sur des revendications SharePoint Foundation 2010, modifié les liaisons et configuré le fichier Web.Config, vous pouvez utiliser la procédure de cette section pour configurer une application Web de service d'émission de jeton de sécurité.

Pour configurer une application Web qui utilise un service STS

  1. Ouvrez la la console de gestion Active Directory Federation Services (AD FS) s2.0.

  2. Dans le volet gauche, développez Stratégie et sélectionnez Parties de confiance.

  3. Dans le volet droit, cliquez sur Ajouter une partie de confiance. Cela ouvre l'Assistant de configuration d'Active Directory Federation Services (AD FS) 2.0.

  4. Sur la première page de l'assistant, cliquez sur Démarrer.

  5. Sélectionnez Entrer la configuration de la partie de confiance manuellement, puis cliquez sur Suivant.

  6. Tapez un nom de partie de confiance, puis cliquez sur Suivant.

  7. Assurez-vous que Active Directory Federation Services (AD FS) 2.0 Server Profile est sélectionné, puis cliquez sur Suivant.

  8. Si vous ne comptez pas utiliser un certificat de chiffrement, cliquez sur Suivant.

  9. Sélectionnez Activer la prise en charge de la fédération d'identité basée sur navigateur Web.

  10. Tapez l'URL de l'application Web et ajoutez-y /_trust/ (par exemple : https://servername/_trust/). Cliquez sur Suivant.

  11. Tapez un identificateur et cliquez sur Ajouter. Cliquez sur Suivant.

  12. Sur la page de synthèse, cliquez sur Suivant, puis cliquez sur Fermer. Cela ouvre la console de gestion d'édition des règles. Utilisez cette console pour configurer le mappage des revendications d'une application Web LDAP vers SharePoint.

  13. Dans le volet gauche, développez Nouvelle règle et sélectionnez Règle prédéfinie.

  14. Sélectionnez Créer les revendications à partir du magasin d'attributs LDAP.

  15. Dans le volet droit, dans la liste déroulante Magasin d'attributs, sélectionnez Magasin de comptes utilisateur Enterprise Active Directory.

  16. Sous Attribut LDAP, sélectionnez sAMAccountName.

  17. Sous Type de revendication sortante, sélectionnez Adresse de messagerie.

  18. Dans le volet de gauche, cliquez sur Enregistrer.

Historique des modifications


Préparer l'hébergement de sites (SharePoint Foundation 2010)

Après avoir installé Microsoft SharePoint Foundation 2010 et effectué la configuration initiale, vous pouvez commencer à créer des sites SharePoint. Avant de créer une collection de sites, vous devez créer une application Web dans laquelle créer la collection de sites. Si vous souhaitez utiliser l'authentification Kerberos ou l'authentification basée sur les revendications, vous devez également configurer l'authentification de l'application Web.

Les articles de cette section vous aident à déterminer la hiérarchie de vos sites SharePoint.

  • Créer une application Web (SharePoint Foundation 2010)

    Les sites SharePoint étant hébergés par des applications Web, vous devez créer une ou plusieurs applications Web avant de créer des sites. Cet article indique comment créer une application Web à partir du site Web Administration centrale ou à l'aide de Windows PowerShell 2.0.

  • Configurer l'authentification par revendications (SharePoint Foundation 2010)

    Cet article explique comment configurer une application Web basée sur les revendications SharePoint Foundation 2010 qui fournira une connexion basée sur les revendications et une infrastructure de services pour votre batterie de serveurs. L'article explique également comment configurer un accès anonyme pour votre application Web basée sur des revendications et configurer les zones de votre application Web pour l'authentification par formulaire ou pour l'authentification unique Web, selon le cas.

  • Configurer l'authentification Kerberos (SharePoint Foundation 2010)

    Pour déployer une batterie de serveurs exécutant SharePoint Foundation 2010 et utilisant l'authentification Kerberos, vous devez installer et configurer plusieurs applications différentes sur vos ordinateurs. Cet article décrit un exemple de batterie de serveurs exécutant SharePoint Foundation 2010 et fournit des conseils pour le déploiement et la configuration de la batterie afin d'utiliser l'authentification Kerberos pour travailler dans une batterie de serveurs SharePoint :

  • Créer une collection de sites (SharePoint Foundation 2010)

    Après avoir créé une application Web, vous pouvez créer une collection de sites. Cet article vous aide à créer une collection de sites à partir du site Web Administration centrale ou à l'aide de Windows PowerShell 2.0. Pour que les utilisateurs puissent créer leurs propres sites, vous devez configurer la gestion de sites libre-service pour l'application Web.

Historique des modifications


Créer une application Web (SharePoint Foundation 2010)
Voir aussi

Une application Web se compose d'un site Web IIS (Internet Information Services) qui agit comme une unité logique pour les collections de sites que vous créez. Avant de pouvoir créer une collection de sites, vous devez d'abord créer une application Web.

Chaque application Web est représentée par un site Web IIS différent avec un pool d'applications unique ou partagé. Vous pouvez affecter à chaque application Web un nom de domaine unique, ce qui facilite la prévention des attaques de script entre sites.

Les applications Web vous permettent d'isoler le contenu. Lorsque vous créez une application Web, vous créez également une base de données de contenu et définissez la méthode d'authentification utilisée pour la connexion à la base de données. En outre, vous définissez une méthode d'authentification que devra utiliser le site Web IIS dans SharePoint Foundation 2010.

SharePoint Foundation 2010 offre deux modes d'authentification des utilisateurs :

  • l'authentification en mode classique, dans laquelle les utilisateurs se connectent à une application Web à l'aide de l'authentification Windows. Pour plus d'informations, voir Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)

  • l'authentification basée sur les revendications, avec laquelle les utilisateurs se connectent à une application Web à l'aide de l'authentification Windows, l'authentification basée sur les formulaires ou un fournisseur d'identité approuvé (SAML). Si vous utilisez l'authentification basée sur les formulaires ou un fournisseur d'identité approuvé, vous devez effectuer des étapes de configuration supplémentaires. Pour plus d'informations sur l'authentification basée sur les revendications, voir Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010).

Pour plus d'informations sur les deux types d'authentification, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010).

SharePoint Foundation 2010 fournit un ensemble d'applications de service qui sont disponibles pour chaque application Web. Vous pouvez sélectionner les applications de service que vous souhaitez utiliser pour chaque application Web que vous créez. Pour plus d'informations, voir Diagrammes techniques (SharePoint Foundation 2010), Définir des chemins d'accès gérés (SharePoint Foundation 2010) et Gérer les applications de service et les services (SharePoint Foundation 2010).

Dans cette section :

  • Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)

  • Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)

Voir aussi

Concepts

Étendre une application Web (SharePoint Foundation 2010)
Créer une collection de sites (SharePoint Foundation 2010)

Autres ressources

Configurer la sécurité du serveur Web (IIS 7)

Historique des modifications

Date | Description | Raison
7 octobre 2010 | 2010/10/04 | Mise à jour du contenu


Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment créer une application Web qui utilise l'authentification classique Windows.

Conseil :
Si vous préférez utiliser l'authentification basée sur les revendications Windows, voir Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010).

Avant d'effectuer cette procédure, assurez-vous que :

  • Votre système exécute Microsoft SharePoint Foundation 2010.

  • Votre conception d'architecture logique est en place.

  • Vous avez planifié l'authentification pour votre application Web. Pour plus d'informations, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010), Configurer l'authentification Kerberos (SharePoint Foundation 2010) et Choisir les groupes de sécurité (SharePoint Foundation 2010).

  • Vous avez sélectionné les applications de service que vous souhaitez utiliser pour votre application Web. Pour plus d'informations, voir Gérer les applications de service et les services (SharePoint Foundation 2010).

  • Si vous utilisez SSL (Secure Sockets Layer), vous devez associer le certificat SSL avec le site Web IIS de l'application Web après la création du site Web IIS. Pour plus d'informations sur la configuration de SSL, voir Comment configurer SSL sur IIS 7.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187887&clcid=0x40C).

  • Vous avez lu des informations sur le mappage des accès de substitution.

  • Si UAC (User Account Control) est activé dans Windows et que vous utilisez Windows PowerShell 2.0 pour créer une application Web, vous devez cliquer avec le bouton droit sur SharePoint 2010 Management Shell et sélectionner Exécuter en tant qu'administrateur.

Vous pouvez créer une application Web à l'aide du site Web Administration centrale de SharePoint ou de Windows PowerShell. Vous utilisez en général l'Administration centrale pour créer une application Web. Si vous souhaitez automatiser la tâche de création d'une application Web, ce qui est courant dans les entreprises, utilisez Windows PowerShell. Une fois la procédure terminée, vous pouvez créer une collection de sites sur l'application Web que vous avez créée.

Pour créer une application Web qui utilise l'authentification classique Windows à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour créer une application Web, vous devez être membre du groupe SharePoint Administrateurs de batterie et membre du groupe Administrateurs local sur l'ordinateur exécutant l'Administration centrale..

  2. Dans la page d'accueil de l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Sur le ruban, cliquez sur Nouveau.

  4. Dans la page Créer une Application Web, dans la section Authentification, cliquez sur Authentification en mode classique.

  5. Dans la section Site Web IIS, vous pouvez configurer les paramètres de votre nouvelle application Web en sélectionnant l'une des deux options suivantes :

    • Cliquez sur Utiliser un site Web existant, puis sélectionnez le site Web sur lequel installer votre nouvelle application Web.

    • Cliquez sur Créer un nouveau site Web IIS, puis tapez le nom du site Web dans la zone Nom.

  6. Dans la section Site Web IIS, dans la zone Port, tapez le numéro de port que vous souhaitez utiliser pour accéder à l'application Web. Si vous créez un nouveau site Web, ce champ est rempli avec un numéro de port aléatoire. Si vous utilisez un site Web existant, ce champ est rempli avec le numéro de port actuel.

    Remarque :
    Le numéro de port par défaut pour l'accès HTTP est 80, et le numéro de port par défaut pour l'accès HTTPS est 443. Si vous souhaitez que les utilisateurs accèdent à l'application Web sans taper de numéro de port, ils doivent utiliser le numéro de port par défaut approprié.

  7. Facultatif : dans la section Site Web IIS, dans la zone En-tête de l'hôte, tapez le nom de l'hôte (par exemple, www.contoso.com) que vous souhaitez utiliser pour accéder à l'application Web.

    Remarque :
    En règle générale, ce champ n'est pas défini, sauf si vous souhaitez configurer plusieurs sites Web IIS qui partagent le même numéro de port sur le même serveur, et DNS a été configuré pour acheminer les demandes au même serveur.

  8. Dans la section Site Web IIS, dans la zone Chemin d'accès, tapez le chemin d'accès du répertoire du répertoire de base du site Web IIS sur le serveur. Si vous créez un nouveau site Web, ce champ est rempli avec le chemin d'accès suggéré. Si vous utilisez un site Web existant, ce champ est rempli avec le chemin d'accès actuel de ce site Web.

  9. Dans la section Configuration de la sécurité, configurez l'authentification et le chiffrement pour votre application Web.

    1. Dans la section Fournisseur d'authentification, cliquez sur Négocier (Kerberos) ou NTLM.

      Remarque :
      Pour activer l'authentification Kerberos, vous devez effectuer une configuration supplémentaire. Pour plus d'informations, voir Configurer l'authentification Kerberos (SharePoint Foundation 2010).

    2. Dans la section Autoriser l'accès anonyme, cliquez sur Oui ou Non. Si vous choisissez d'autoriser l'accès anonyme, cela permet l'accès anonyme au site Web à l'aide du compte d'accès anonyme spécifique à l'ordinateur (en l'occurrence, IUSR).

      Remarque :
      Si vous souhaitez que les utilisateurs puissent accéder au contenu de tout site de façon anonyme, vous devez autoriser l'accès anonyme pour toute la zone d'application Web avant d'activer l'accès anonyme au niveau du site SharePoint ; plus tard, les propriétaires de sites peuvent configurer le mode d'utilisation de l'accès anonyme dans leurs sites. Si vous ne permettez pas l'accès anonyme au niveau de l'application Web, vous ne pouvez pas permettre l'accès anonyme ultérieurement, au niveau du site. Pour plus d'informations, voir Choisir les groupes de sécurité (SharePoint Foundation 2010).

    3. Dans la section Utiliser SSL (Secure Sockets Layer), cliquez sur Oui ou sur Non. Si vous choisissez d'activer SSL pour le site Web, vous devez configurer SSL en demandant et en installant un certificat SSL. Pour plus d'informations sur la configuration de SSL, voir Comment configurer SSL sur IIS 7.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187887&clcid=0x40C).

  10. Dans la section URL publique, tapez l'URL pour le nom de domaine de tous les sites auxquels les utilisateurs auront accès dans cette application Web. Cette URL sera utilisée comme URL de base dans les liens apparaissant sur les pages dans cette zone d'application Web. L'URL par défaut est le nom et le port du serveur actuel, et est automatiquement actualisée pour refléter les paramètres SSL, d'en-tête d'hôte et de numéro de port actuels sur la page. Si vous déployez SharePoint Foundation 2010 derrière un équilibreur de charge ou un serveur proxy, cette URL peut devoir différer des paramètres SSL, d'en-tête d'hôte et de port sur cette page.

    La valeur Zone est automatiquement définie sur Par défaut pour une nouvelle application Web.

    Remarque :
    Vous pouvez également changer la zone lorsque vous étendez une application Web. Pour plus d'informations, voir Étendre une application Web (SharePoint Foundation 2010).

  11. Dans la section Pool d'applications, exécutez l'une des actions suivantes :

    • Cliquez sur Utiliser le pool d'applications existant, puis sélectionnez le pool d'applications que vous souhaitez utiliser dans le menu déroulant.

    • Cliquez sur Créer un nouveau pool d'applications, puis tapez le nom du nouveau pool d'applications ou conservez le nom par défaut.

  12. Sous Sélectionnez un compte de sécurité pour ce pool d'applications, effectuez l'une des opérations suivantes :

    • Cliquez sur Prédéfini pour utiliser un compte de sécurité prédéfini, puis sélectionnez le compte de sécurité dans le menu déroulant.

    • Cliquez sur Configurable pour spécifier un nouveau compte de sécurité à utiliser pour un pool d'applications existant.

    Remarque :
    Vous pouvez créer un nouveau compte en cliquant sur le lien Enregistrer le nouveau compte géré.

  13. Dans la section Nom de la base de données et authentification, choisissez le serveur de bases de données, le nom de base de données et la méthode d'authentification pour votre nouvelle application Web, comme décrit dans le tableau suivant.

    Élément Action

    Serveur de base de données

    Tapez le nom du serveur de la base de données et l'instance Microsoft SQL Server que vous souhaitez utiliser sous la forme <NOM_SERVEUR\instance>. Vous pouvez également utiliser l'entrée par défaut.

    Nom de la base de données

    Tapez le nom de la base de données ou utilisez l'entrée par défaut.

    Authentification de la base de données

    Pour sélectionner l'authentification de base de données à utiliser, effectuer l'une des opérations suivantes :

    • Si vous souhaitez utiliser l'authentification Windows, laissez cette option activée. Nous recommandons cette option car l'authentification Windows chiffre automatiquement le mot de passe lors de la connexion à SQL Server.

    • Pour utiliser l'authentification SQL, cliquez sur Authentification SQL. Dans la zone Compte, tapez le nom du compte que l'application Web doit utiliser pour s'authentifier auprès de la base de données SQL Server, puis tapez le mot de passe dans la zone Mot de passe.

      Remarque :
      L'authentification SQL envoie le mot de passe d'authentification SQL au serveur SQL non chiffré. Nous recommandons d'utiliser uniquement l'authentification SQL si vous forcez le chiffrement de protocole sur SQL Server ou chiffrez le trafic réseau en utilisant IPsec.

  14. Si vous utilisez la mise en miroir de base de données, dans la section Serveur de basculement, dans la zone Serveur de bases de données de basculement, tapez le nom d'un serveur de bases de données de basculement spécifique que vous souhaitez associer à une base de données de contenu.

  15. Dans la section Serveur de recherche, sous Sélectionnez le serveur de recherche Microsoft SharePoint Foundation, vous associez une base de données de contenu à un serveur qui exécute le service Recherche Microsoft SharePoint Foundation

  16. Dans la section Connexions aux applications de service, sélectionnez les connexions aux applications de service qui seront disponibles pour l'application Web. Dans le menu déroulant, cliquez sur Par défaut ou Personnalisé. L'option Personnalisé permet de choisir les connexions aux application de service que vous souhaitez utiliser pour l'application Web.

  17. Dans la section Programme d'amélioration du produit, cliquez sur Oui ou Non.

  18. Cliquez sur OK pour créer la nouvelle application Web.

Pour créer une application Web qui utilise l'authentification classique Windows à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration requise suivante : Voir Add-SPShellAdmin. Vous devez aussi être membre du groupe Administrateurs local sur l'ordinateur exécutant Windows PowerShell. En outre, certaines procédures nécessitent l'appartenance aux rôles serveur fixes SQL Server dbcreator et securityadmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    New-SPWebApplication -Name <Name> -ApplicationPool <ApplicationPool> -ApplicationPoolAccount <ApplicationPoolAccount> -Port <Port> -URL <URL>

    Où :

    • <Name> est le nom de la nouvelle application Web.

    • <ApplicationPool> est le nom du pool d'applications.

    • <ApplicationPoolAccount> est le compte d'utilisateur sous lequel ce pool d'applications s'exécutera.

    • <Port> est le port sur lequel l'application Web sera créée dans IIS.

    • <URL> est l'URL publique pour l'application Web.

      Exemple

      Code de copie
      New-SPWebApplication -Name "Contoso Internet Site" -ApplicationPool "ContosoAppPool" -ApplicationPoolAccount (Get-SPManagedAccount "DOMAIN\jdoe") -Port 80 -URL "http://www.contoso.com"

Pour plus d'informations, voir New-SPWebApplication.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Étendre une application Web (SharePoint Foundation 2010)
Créer une collection de sites (SharePoint Foundation 2010)
Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)

Autres ressources

Configurer la sécurité du serveur Web (IIS 7)

Historique des modifications

Date | Description | Raison
7 octobre 2010 | 2010/10/04 | Mise à jour du contenu
7 octobre 2010 | Publication initiale |


Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment créer une application Web qui utilise l'authentification basée sur les revendications Windows.

Conseil :
Si vous préférez utiliser l'authentification classique Windows, voir Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010).

Avant d'effectuer cette procédure, assurez-vous que :

  • Votre système exécute Microsoft SharePoint Foundation 2010.

  • Votre conception d'architecture logique est en place.

  • Vous avez planifié l'authentification pour votre application Web. Pour plus d'informations, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010), Configurer l'authentification Kerberos (SharePoint Foundation 2010) et Choisir les groupes de sécurité (SharePoint Foundation 2010).

  • Vous avez sélectionné les applications de service que vous souhaitez utiliser pour votre application Web. Pour plus d'informations, voir Gérer les applications de service et les services (SharePoint Foundation 2010).

  • Si vous utilisez SSL (Secure Sockets Layer), vous devez associer le certificat SSL avec le site Web IIS de l'application Web après la création du site Web IIS. Pour plus d'informations sur la configuration de SSL, voir Comment configurer SSL sur IIS 7.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187887&clcid=0x40C).

  • Vous avez lu la documentation sur le mappage des accès de substitution.

  • Si UAC (User Account Control) est activé dans Windows et que vous utilisez Windows PowerShell 2.0 pour créer une application Web, vous devez cliquer avec le bouton droit sur SharePoint 2010 Management Shell et sélectionner Exécuter en tant qu'administrateur.

Vous pouvez créer une application Web à l'aide du site Web Administration centrale de SharePoint ou de Windows PowerShell. Vous utilisez en général l'Administration centrale pour créer une application Web. Si vous souhaitez automatiser la tâche de création d'une application Web, ce qui est courant dans les entreprises, utilisez Windows PowerShell. Une fois la procédure terminée, vous pouvez créer une collection de sites sur l'application Web que vous avez créée.

Pour créer une application Web avec l'authentification par revendications Windows à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour créer une application Web, vous devez être membre du groupe SharePoint Administrateurs de batterie et membre du groupe Administrateurs local sur l'ordinateur exécutant l'Administration centrale.

  2. Dans la page d'accueil de l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Sur le ruban, cliquez sur Nouveau.

  4. Dans la page Créer une Application Web, dans la section Authentification, cliquez sur Authentification par revendications.

  5. Dans la section Site Web IIS, vous pouvez configurer les paramètres de votre nouvelle application Web en sélectionnant l'une des deux options suivantes :

    • Cliquez sur Utiliser un site Web existant, puis sélectionnez le site Web sur lequel installer votre nouvelle application Web.

    • Cliquez sur Créer un nouveau site Web IIS, puis tapez le nom du site Web dans la zone Nom.

  6. Dans la section Site Web IIS, dans la zone Port, tapez le numéro de port que vous souhaitez utiliser pour accéder à l'application Web. Si vous créez un nouveau site Web, ce champ est rempli avec un numéro de port aléatoire. Si vous utilisez un site Web existant, ce champ est rempli avec le numéro de port actuel.

    Remarque :
    Le numéro de port par défaut pour l'accès HTTP est 80, et le numéro de port par défaut pour l'accès HTTPS est 443. Si vous souhaitez que les utilisateurs accèdent à l'application Web sans taper de numéro de port, ils doivent utiliser le numéro de port par défaut approprié.

  7. Facultatif : dans la section Site Web IIS, dans la zone En-tête de l'hôte, tapez le nom de l'hôte (par exemple, www.contoso.com) que vous souhaitez utiliser pour accéder à l'application Web.

    Remarque :
    En règle générale, ce champ n'est pas défini, sauf si vous souhaitez configurer plusieurs sites Web IIS qui partagent le même numéro de port sur le même serveur, et DNS a été configuré pour acheminer les demandes au même serveur.

  8. Dans la section Site Web IIS, dans la zone Chemin d'accès, tapez le chemin d'accès du répertoire du répertoire de base du site Web IIS sur le serveur. Si vous créez un nouveau site Web, ce champ est rempli avec le chemin d'accès suggéré. Si vous utilisez un site Web existant, ce champ est rempli avec le chemin d'accès actuel de ce site Web.

  9. Dans la section Configuration de la sécurité, choisissez d'utiliser ou non autoriser l'accès anonyme et d'utiliser SSL (Secure Sockets Layer).

    1. Sous Autoriser l'accès anonyme, cliquez sur Oui ou Non. Si vous choisissez d'autoriser l'accès anonyme, cela permet l'accès anonyme au site Web à l'aide du compte d'accès anonyme spécifique à l'ordinateur (en l'occurrence, IUSR).

      Remarque :
      Si vous souhaitez que les utilisateurs puissent accéder au contenu de tout site de façon anonyme, vous devez autoriser l'accès anonyme pour toute la zone d'application Web avant d'activer l'accès anonyme au niveau du site SharePoint ; plus tard, les propriétaires de sites peuvent configurer le mode d'utilisation de l'accès anonyme dans leurs sites. Si vous ne permettez pas l'accès anonyme au niveau de l'application Web, vous ne pouvez pas permettre l'accès anonyme ultérieurement, au niveau du site. Pour plus d'informations, voir Choisir les groupes de sécurité (SharePoint Foundation 2010).

    2. Sous Utiliser le protocole SSL, cliquez sur Oui ou Non. Si vous choisissez d'activer le protocole SSL pour le site Web, vous devez configurer le protocole SSL en demandant et en installant un certificat SSL. Pour plus d'informations sur la configuration de SSL, voir Configuration de SSL sur IIS 7.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187887&clcid=0x40C).

  10. Dans la section Types d'authentification basée sur les revendications, sélectionnez l'authentification que vous souhaitez utiliser pour l'application Web.

    1. Si vous souhaitez activer l'authentification Windows, sélectionnez Activer l'authentification Windows et, dans le menu déroulant, sélectionnez Négocier (Kerberos) ou NTLM. Pour plus d'informations, voir Configurer l'authentification Kerberos (SharePoint Foundation 2010).

      Si vous ne souhaitez pas utiliser l'authentification Windows intégrée, désactivez Authentification Windows intégrée.

      Si vous souhaitez que les informations d'identification des utilisateurs soient envoyées sur le réseau sous une forme non chiffrée, sélectionnez Authentification de base (le mot de passe est envoyé en texte clair).

      Remarque :
      Vous pouvez sélectionner l'authentification de base ou l'authentification Windows intégrée, ou les deux. Si vous sélectionnez les deux, SharePoint Foundation 2010 offre les deux types d'authentification au navigateur Web client. Ce dernier détermine ensuite quel type d'authentification utiliser. Si vous sélectionnez l'authentification de base, assurez-vous que le protocole SSL est activé ; dans le cas contraire, les informations d'identification peuvent être interceptées par un utilisateur malveillant.

    2. Si vous souhaitez activer l'authentification par formulaire, sélectionnez Activer l'authentification par formulaire, puis entrez le nom du fournisseur d'appartenances et le nom du gestionnaire de rôles dans les zones.

      Pour plus d'informations, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

      Remarque :
      Si vous sélectionnez cette option, assurez-vous que le protocole SSL est activé ; dans le cas contraire, les informations d'identification peuvent être interceptées par un utilisateur malveillant.

    3. Si vous avez configuré l'authentification Fournisseur d'identité approuvé dans Windows PowerShell, la case à cocher Fournisseur d'identité approuvé est activée.

      Pour plus d'informations, voir Configurer l'authentification à l'aide d'un jeton de sécurité SAML (SharePoint Foundation 2010).

    Vous pouvez utiliser un ou plusieurs types d'authentification par revendications. Pour plus d'informations, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010).

  11. Dans la section URL de page de connexion, choisissez l'une des options suivantes pour vous connecter à SharePoint Foundation 2010.

    • Sélectionnez Utiliser l'URL de la page de connexion par défaut si vous souhaitez que les utilisateurs soient redirigés vers un site Web de connexion par défaut pour l'authentification basée sur les revendications.

    • Sélectionnez Utiliser une URL de page de connexion personnalisée, puis tapez l'URL de connexion si vous souhaitez que les utilisateurs soient redirigés vers un site Web de connexion personnalisé pour l'authentification par revendications.

  12. Dans la section URL publique, tapez l'URL pour le nom de domaine de tous les sites auxquels les utilisateurs auront accès dans cette application Web. Cette URL sera utilisée comme URL de base dans les liens apparaissant sur les pages dans cette zone d'application Web. L'URL par défaut est le nom et le port du serveur actuel, et est automatiquement actualisée pour refléter les paramètres SSL, d'en-tête d'hôte et de numéro de port actuels sur la page. Si vous déployez SharePoint Foundation 2010 derrière un équilibreur de charge ou un serveur proxy, cette URL peut devoir différer des paramètres SSL, d'en-tête d'hôte et de port sur cette page.

    La valeur Zone est automatiquement définie sur Par défaut pour une nouvelle application Web.

    Remarque :
    Vous pouvez également changer la zone lorsque vous étendez une application Web. Pour plus d'informations, voir Étendre une application Web (SharePoint Foundation 2010).

  13. Dans la section Pool d'applications, exécutez l'une des actions suivantes :

    • Cliquez sur Utiliser le pool d'applications existant, puis sélectionnez le pool d'applications que vous souhaitez utiliser dans le menu déroulant.

    • Cliquez sur Créer un nouveau pool d'applications, puis tapez le nom du nouveau pool d'applications ou conservez le nom par défaut.

  14. Sous Sélectionnez un compte de sécurité pour ce pool d'applications, effectuez l'une des opérations suivantes :

    • Cliquez sur Prédéfini pour utiliser un compte de sécurité prédéfini, puis sélectionnez le compte de sécurité dans le menu déroulant.

    • Cliquez sur Configurable pour spécifier un nouveau compte de sécurité à utiliser pour un pool d'applications existant.

    Remarque :
    Vous pouvez créer un nouveau compte en cliquant sur le lien Enregistrer le nouveau compte géré.

  15. Dans la section Nom de la base de données et authentification, choisissez le serveur de base de données, le nom de base de données et la méthode d'authentification pour votre nouvelle application Web, comme décrit dans le tableau suivant.

    Élément Action

    Serveur de bases de données

    Tapez le nom du serveur de la base de données et l'instance Microsoft SQL Server que vous souhaitez utiliser sous la forme <NOM_SERVEUR\instance>. Vous pouvez également utiliser l'entrée par défaut.

    Nom de la base de données

    Tapez le nom de la base de données ou utilisez l'entrée par défaut.

    Authentification de la base de données

    Pour sélectionner l'authentification de base de données à utiliser, effectuer l'une des opérations suivantes :

    • Si vous souhaitez utiliser l'authentification Windows, laissez cette option activée. Nous recommandons cette option car l'authentification Windows chiffre automatiquement le mot de passe lors de la connexion à SQL Server.

    • Pour utiliser l'authentification SQL, cliquez sur Authentification SQL. Dans la zone Compte, tapez le nom du compte que l'application Web doit utiliser pour s'authentifier auprès de la base de données SQL Server, puis tapez le mot de passe dans la zone Mot de passe.

      Remarque :
      L'authentification SQL envoie le mot de passe d'authentification SQL au serveur SQL non chiffré. Nous recommandons d'utiliser uniquement l'authentification SQL si vous forcez le chiffrement de protocole sur SQL Server ou chiffrez le trafic réseau en utilisant IPsec.

  16. Si vous utilisez la mise en miroir de base de données, dans la section Serveur de basculement, dans la zone Serveur de bases de données de basculement, tapez le nom d'un serveur de bases de données de basculement spécifique que vous souhaitez associer à une base de données de contenu.

  17. Dans la section Serveur de recherche, sous Sélectionnez le serveur de recherche Microsoft SharePoint Foundation, vous associez une base de données de contenu à un serveur qui exécute le service Recherche Microsoft SharePoint Foundation

  18. Dans la section Connexions aux applications de service, sélectionnez les connexions aux applications de service qui seront disponibles pour l'application Web. Dans le menu déroulant, cliquez sur Par défaut ou Personnalisé. L'option Personnalisé permet de choisir les connexions aux application de service que vous souhaitez utiliser pour l'application Web.

  19. Dans la section Programme d'amélioration du produit, cliquez sur Oui ou Non.

  20. Cliquez sur OK pour créer la nouvelle application Web.

Pour créer une application Web qui utilise l'authentification par revendications Windows à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration requise suivante : Voir Add-SPShellAdmin. Vous devez aussi être membre du groupe Administrateurs local sur l'ordinateur exécutant Windows PowerShell. En outre, certaines procédures nécessitent l'appartenance aux rôles serveur fixes SQL Server dbcreator et securityadmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Pour créer un fournisseur d'authentification par revendications Windows, à l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $ap = New-SPAuthenticationProvider

    Pour créer une application Web qui utilise l'authentification par revendications Windows, à l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $wa = New-SPWebApplication -Name <ClaimsWindowsWebApplication> -ApplicationPool <ClaimsApplicationPool> -ApplicationPoolAccount <ClaimsApplicationPoolAccount> -URL <URL> -Port <Port> -AuthenticationProvider $ap
    Remarque :
    Nous recommandons que le compte du pool d'applications soit un compte géré sur la batterie de serveurs.

    Où :

    • <Name> est le nom de la nouvelle application Web qui utilise l'authentification par revendications Windows.

    • <ApplicationPool> est le nom du pool d'applications.

    • <ApplicationPoolAccount> est le compte d'utilisateur sous lequel ce pool d'applications s'exécutera.

    • <URL> est l'URL publique pour l'application Web.

    • <Port> est le port sur lequel l'application Web sera créée dans les services Internet (IIS).

      Exemple

      Code de copie
      $ap = New-SPAuthenticationProvider
      Code de copie
      $wa = New-SPWebApplication -Name "Contoso Internet Site" -ApplicationPool "ContosoAppPool" -ApplicationPoolAccount (Get-SPManagedAccount "DOMAIN\jdoe") -URL "http://www.contoso.com" -Port 80 -AuthenticationProvider $ap

Pour plus d'informations, voir New-SPWebApplication et New-SPAuthenticationProvider.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Étendre une application Web (SharePoint Foundation 2010)
Créer une collection de sites (SharePoint Foundation 2010)
Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010)
Configurer l'authentification à l'aide d'un jeton de sécurité SAML (SharePoint Foundation 2010)
Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)

Autres ressources

Configurer la sécurité du serveur Web (IIS 7)

Historique des modifications

Date | Description | Raison
7 octobre 2010 | 2010/10/04 | Mise à jour du contenu


Configure Digest authentication for a classic-mode Web application (SharePoint Foundation 2010)
Voir aussi

This article describes how to configure digest authentication for one or more zones within a Microsoft SharePoint Foundation 2010 classic-mode Web application. A Web application is an IIS Web site that SharePoint Foundation 2010 creates and uses. Zones represent different logical paths for gaining access to the same Web application. Within each Web application, you can create up to five zones. A different Web site in IIS represents each zone. Use zones to enforce different access and policy conditions for large groups of users. To configure digest authentication for one or more zones in a SharePoint Foundation 2010 Web application, use the IIS Management Console to directly configure IIS.

Although digest authentication provides the same functionality as basic authentication, digest authentication encrypts user credentials to increase security. User credentials are sent as an MD5 message digest in which the original user name and password cannot be deciphered. Digest authentication uses a challenge/response protocol that requires the authentication requestor to present valid credentials in response to a challenge from the server. To authenticate against the server, the client has to supply an MD5 message digest in a response that contains a shared secret password string. The MD5 Message-Digest Algorithm is described in detail in RFC 1321. For access to RFC 1321, see The Internet Engineering Task Force (http://go.microsoft.com/fwlink/?LinkId=209085).

To use digest authentication, note the following requirements:

  • The user and IIS server must be members of, or trusted by, the same domain.

  • Users must have a valid Windows user account stored in Active Directory Domain Services (AD DS) on the domain controller.

  • The domain must use a Microsoft Windows Server 2008 domain controller.

Configure IIS to enable digest authentication

Use the IIS Management Console to configure IIS to enable digest authentication for one or more of the following zones for a classic-mode Web application:

Remarque :
The Default zone is the zone that is first created when a Web application is created. The other zones are created by extending a Web application.

  • Default

  • Intranet

  • Extranet

To configure IIS to enable digest authentication

  1. Verify that you have one of the following administrative credentials:

    • You must be a member of the Administrators group on the server on which you are configuring IIS.

  2. On the Start menu, point to All Programs, click Administrative Tools, and then click Internet Information Services (IIS) Manager to start the IIS Management Console.

  3. Expand Sites on the console tree, right-click the IIS Web site that corresponds to the Web application zone on which you want to configure digest authentication, and then click Properties.

  4. On the Web Site Properties page, click the Directory Security tab.

  5. In the Anonymous access and authentication control section, click Edit.

  6. In the Authenticated access section of the Authentication Methods dialog box, select Digest authentication for Windows domain servers.

    A dialog box informs you that digest authentication only works with AD DS domain accounts, and asking you if you want to continue. Click Yes.

  7. In the Realm section of the of the Authentication Methods dialog box, click Select.

  8. Select the appropriate realm and click OK. On the other open dialog boxes, click OK.

At this point, the Web site is configured to use digest authentication.

Voir aussi

Autres ressources

What is Digest Authentication? (http://go.microsoft.com/fwlink/?LinkId=209085)

Historique des modifications

Date | Description | Raison
2011/01/17 | Publication initiale |


Configure Basic authentication for a classic-mode Web application (SharePoint Foundation 2010)
Voir aussi

This article describes how to configure Basic authentication for one or more zones within a Microsoft SharePoint Foundation 2010 classic-mode Web application. A Web application is an Internet Information Services (IIS) Web site that SharePoint Foundation 2010 creates and uses. Zones represent different logical paths for gaining access to the network services that are available within the same Web application. Within each Web application, you can create up to five zones. A different Web site in IIS represents each zone. Use zones to enforce different access and policy conditions for large groups of users. To configure Basic authentication for one or more zones in a SharePoint Foundation 2010 Web application, use the IIS Management Console to directly configure IIS.

Basic authentication requires previously assigned Windows account credentials for user access. Basic authentication enables a Web browser to provide credentials when the browser makes a request during an HTTP transaction. Because user credentials are not encrypted for network transmission but are sent over the network in plaintext, we recommend that you do not use Basic authentication over an unsecured HTTP connection. To use Basic authentication, you should enable Secure Sockets Layer (SSL) encryption.

Configure IIS to enable Basic authentication

Use the IIS Management Console to configure IIS to enable Basic authentication for one or more of the following zones for a claims-based Web application:

Remarque :
The Default zone is the zone that is first created when a Web application is created. The other zones are created by extending a Web application.

  • Default

  • Intranet

  • Extranet

To configure IIS to enable Basic authentication

  1. Verify that you have one of the following administrative credentials:

    • You must be a member of the Administrators group on the server on which you are configuring IIS.

  2. On the Start menu, point to All Programs, click Administrative Tools , and then click Internet Information Services (IIS) Manager to start the IIS Management Console.

  3. Expand Sites on the console tree, right-click the IIS Web site that corresponds to the Web application zone on which you want to configure Basic authentication, and then click Properties.

  4. On the Web Site Properties page, click the Directory Security tab.

  5. In the Anonymous access and authentication control section, click Edit.

  6. In the Authenticated access section of the Authentication Methods dialog box, select Basic authentication (password is sent in clear text).

  7. In the Realm section of the of the Authentication Methods dialog box, click Select.

  8. Select the appropriate realm and click OK. On the other open dialog boxes, click OK.

At this point, the Web site is configured to use Basic authentication.

Download this book

This topic is included in the following downloadable book for easier reading and printing:

  • Deployment for Windows SharePoint Services 3.0 technology

See the full list of available books at Downloadable books for Windows SharePoint Services.

Voir aussi

Concepts

Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
2011/01/24 | Publication initiale |


Configurer l'authentification par revendications (SharePoint Foundation 2010)

Dans cette section :

  • Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)

  • Configurer un accès anonyme pour une application Web basée sur des revendications (SharePoint Foundation 2010)

  • Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010)

  • Configurer l'authentification Kerberos pour le service d'émission de jetons Revendications vers Windows (SharePoint Foundation 2010)

  • Configurer l'authentification à l'aide d'un jeton de sécurité SAML (SharePoint Foundation 2010)

  • Configurer l'authentification par revendications (SharePoint Foundation 2010)

Historique des modifications


Configurer un accès anonyme pour une application Web basée sur des revendications (SharePoint Foundation 2010)

Après avoir configuré une application Web basée sur des revendications Microsoft SharePoint Foundation 2010, vous pouvez utiliser la procédure indiquée dans cet article pour configurer un accès anonyme pour cette application Web. Pour plus d'informations, voir Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010).

Configurer un accès anonyme pour une application Web basée sur des revendications

Pour configurer un accès anonyme pour une application Web basée sur des revendications

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est administrateur de collection de sites.

  2. Dans l'Administration centrale, accédez à la section Sécurité.

  3. Sous Accès anonyme, sélectionnez Activer l'accès anonyme.

  4. Cliquez sur Enregistrer.

  5. Accédez au site de l'application Web appropriée.

  6. Sélectionnez Actions du site.

  7. Sélectionnez Autorisations de site.

  8. Dans le Ruban, sélectionnez Accès anonyme.

  9. Sélectionnez Intégralité du site Web ou Listes et bibliothèques, suivant l'étendue d'accès anonyme souhaitée pour ce site.

Historique des modifications


Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010)

Les procédures indiquées dans cet article vous aident à :

  • configurer l'authentification par formulaires pour une application Web Microsoft SharePoint Foundation 2010 basée sur des revendications ;

  • mettre à niveau des applications Web Windows SharePoint Services 3.0 existantes qui ont été configurées pour utiliser l'authentification par formulaire afin qu'elles fonctionnent avec SharePoint Foundation 2010.

Après une mise à niveau vers SharePoint Foundation 2010, vos applications Web Windows SharePoint Services 3.0 seront configurées pour l'ancienne connexion. Pour vos applications Web Windows SharePoint Services 3.0 qui étaient configurées pour utiliser l'authentification Windows, aucune étape supplémentaire n'est requise pour la mise à niveau. Cependant, pour les applications Windows SharePoint Services 3.0 dont la configuration prévoit l'utilisation d'une authentification par formulaires ou l'authentification unique Web, vous devez d'abord convertir les authentifications par revendications avant que les applications Web Windows SharePoint Services 3.0 puissent être utilisées dans SharePoint Foundation 2010. Une fois que vous avez converti les applications Web Windows SharePoint Services 3.0 à l'authentification par revendications, configurez vos zones d'applications Web pour l'authentification par formulaires (ou l'authentification Web unique, si elle convient). Notez que les noms de fournisseur d'appartenance et de fournisseur de rôle que vous utilisez dans SharePoint Foundation 2010 doivent correspondre aux noms de fournisseur d'appartenance et de fournisseur de rôle que vous avez utilisés dans Windows SharePoint Services 3.0. L'étape finale consiste à migrer les utilisateurs et les autorisations vers SharePoint Foundation 2010.

Dans cet article :

  • Convertir des applications Web en authentification par revendications

  • Configurer une application Web basée sur des formulaires afin qu'elle utilise un fournisseur LDAP à l'aide de l'Administration centrale

  • Configurer les fichiers Web.Config LDAP

  • Configurer une application Web basée sur des formulaires afin qu'elle utilise un fournisseur LDAP à l'aide de Windows PowerShell

  • Migrer les utilisateurs et les autorisations depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010

Convertir des applications Web en authentification par revendications

Effectuez les étapes de la procédure suivante pour convertir des applications Web existantes en authentification par revendications à l'aide de Windows PowerShell.

Pour convertir des applications Web en authentification par revendications

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $w = Get-SPWebApplication "http://<server>/"
$w.UseClaimsAuthentication = "True";
$w.Update()

$w.ProvisionGlobally()
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Configurer une application Web basée sur des formulaires afin qu'elle utilise un fournisseur LDAP à l'aide de l'Administration centrale

Effectuez les étapes de la procédure suivante afin de configurer l'authentification par formulaire pour une application Web basée sur des revendications à l'aide de l'Administration centrale.

Pour configurer l'authentification par formulaire pour une application Web basée sur des revendications à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est administrateur de collection de sites.

  2. Dans l'Administration centrale, sous Gestion des applications, sélectionnez Gérer les applications Web.

  3. Dans le Ruban, sélectionnez Nouveau.

  4. Dans la section Authentification de la boîte de dialogue Nouvelle application Web, sélectionnez Authentification par revendications.

  5. Dans la section Type d'authentification, sélectionnez Activer le fournisseur d'appartenances et de rôles ASP.NET.

  6. Tapez un nom de fournisseur d'appartenances et un nom de gestionnaire de rôles. Dans l'exemple de fichier Web.Config décrit dans cet article, le nom du fournisseur d'appartenances est membership, tandis que le nom du gestionnaire de rôles est rolemanager.

  7. Cliquez sur OK pour créer l'application Web.

Configurer les fichiers Web.Config LDAP

Après avoir correctement créé l'application Web (comme décrit dans la procédure précédente), modifiez les fichiers Web.Config suivants :

  • Le fichier Web.Config de l'application Web Administration centrale

  • Le fichier Web.Config du service d'émission de jeton de sécurité

  • Le fichier Web.Config de l'application Web basée sur des revendications pour l'authentification par formulaire

Pour configurer le fichier Web.Config de l'Administration centrale

  1. Ouvrez le Gestionnaire IIS en tapant INETMGR depuis une invite de commandes.

  2. Accédez au site Administration centrale de SharePoint dans IIS.

  3. Cliquez avec le bouton droit sur Administration centrale de SharePoint, puis sélectionnez Explorer.

  4. Ouvrez le fichier Web.Config.

  5. Recherchez la section <Configuration> <system.web>, puis ajoutez l'entrée suivante :
Code de copie
<membership defaultProvider="AspNetSqlMembershipProvider">
      <providers>
        <add name="membership"
             type="Microsoft.Office.Server.Security.LdapMembershipProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
             server="yourserver.com"
             port="389"
             useSSL="false"
             userDNAttribute="distinguishedName"
             userNameAttribute="sAMAccountName"
             userContainer="OU=UserAccounts,DC=internal,DC=yourcompany,DC= distinguishedName (of your userContainer)"
             userObjectClass="person"
             userFilter="(ObjectClass=person)"
             scope="Subtree"
             otherRequiredUserAttributes="sn,givenname,cn" />
      </providers>
    </membership>
    <roleManager enabled="true" defaultProvider="AspNetWindowsTokenRoleProvider" >
      <providers>
        <add name="roleManager"
             type="Microsoft.Office.Server.Security.LdapRoleProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
             server="yourserver.com"
             port="389"
             useSSL="false"
             groupContainer="DC=internal,DC=yourcompany,DC= distinguishedName (of your groupContainer)"
             groupNameAttribute="cn"
             groupNameAlternateSearchAttribute="samAccountName"
             groupMemberAttribute="member"
             userNameAttribute="sAMAccountName"
             dnAttribute="distinguishedName"
             groupFilter="((ObjectClass=group)"
             userFilter="((ObjectClass=person)"
             scope="Subtree" />
      </providers>
 </roleManager>
Important :
Après avoir ajouté l'entrée précédente, enregistrez et fermez le fichier Web.Config.

Pour configurer le fichier Web.Config du service d'émission de jeton de sécurité

  1. Ouvrez le Gestionnaire IIS en tapant INETMGR depuis une invite de commandes.

  2. Accédez au site Services Web SharePoint.

  3. Accédez au sous-site Application de service d'émission de jeton de sécurité.

  4. Cliquez avec le bouton droit sur Administration centrale de SharePoint, puis sélectionnez Explorer.

  5. Ouvrez le fichier Web.Config.

  6. Recherchez la section <Configuration> <system.web>, puis ajoutez l'entrée suivante :
Code de copie
<membership>
      <providers>
        <add name="membership"
             type="Microsoft.Office.Server.Security.LdapMembershipProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
             server="yourserver.com"
             port="389"
             useSSL="false"
             userDNAttribute="distinguishedName"
             userNameAttribute="sAMAccountName"
             userContainer="OU=UserAccounts,DC=internal,DC=yourcompany,DC=com"
             userObjectClass="person"
             userFilter="(&amp;(ObjectClass=person))"
             scope="Subtree"
             otherRequiredUserAttributes="sn,givenname,cn" />
      </providers>
    </membership>
    <roleManager enabled="true" >
      <providers>
        <add name="rolemanager"
             type="Microsoft.Office.Server.Security.LdapRoleProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
             server="yourserver.com"
             port="389"
             useSSL="false"
             groupContainer="DC=internal,DC=yourcompany,DC=com"
             groupNameAttribute="cn"
             groupNameAlternateSearchAttribute="samAccountName"
             groupMemberAttribute="member"
             userNameAttribute="sAMAccountName"
             dnAttribute="distinguishedName"
             groupFilter="(&amp;(ObjectClass=group))"
             userFilter="(&amp;(ObjectClass=person))"
             scope="Subtree" />
      </providers>
    </roleManager>
Important :
Après avoir ajouté l'entrée précédente, enregistrez et fermez le fichier Web.Config.

Pour configurer le fichier Web.Config de l'application Web basée sur des revendications pour l'authentification par formulaire

  1. Ouvrez le Gestionnaire IIS en tapant INETMGR depuis une invite de commandes.

  2. Accédez au site Formulaires basés sur les revendications.

  3. Cliquez avec le bouton droit sur Formulaires basés sur les revendications, puis sélectionnez Explorer.

  4. Ouvrez le fichier Web.Config.

  5. Recherchez la section <Configuration> <system.web>.

  6. Recherchez la section <membership defaultProvider="i">, puis ajoutez l'entrée suivante :
Code de copie
<add name="membership"
             type="Microsoft.Office.Server.Security.LdapMembershipProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
             server="yourserver.com"
             port="389"
             useSSL="false"
             userDNAttribute="distinguishedName"
             userNameAttribute="sAMAccountName"
             userContainer="OU=UserAccounts,DC=internal,DC=yourcompany,DC=com"
             userObjectClass="person"
             userFilter="(&amp;(ObjectClass=person))"
             scope="Subtree"
             otherRequiredUserAttributes="sn,givenname,cn" />

Recherchez la section <roleManager defaultProvider="c" enabled="true" cacheRolesInCookie="false">, puis ajoutez l'entrée suivante :

Code de copie
<add name="roleManager"
             type="Microsoft.Office.Server.Security.LdapRoleProvider, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
             server="yourserver.com"
             port="389"
             useSSL="false"
             groupContainer="DC=internal,DC=yourcompany,DC=com"
             groupNameAttribute="cn"
             groupNameAlternateSearchAttribute="samAccountName"
             groupMemberAttribute="member"
             userNameAttribute="sAMAccountName"
             dnAttribute="distinguishedName"
             groupFilter="(&amp;(ObjectClass=group))"
             userFilter="(&amp;(ObjectClass=person))"
             scope="Subtree" />
Important :
Après avoir ajouté l'entrée précédente, enregistrez et fermez le fichier Web.Config.

Avertissement :
Ne remplacez aucune entrée existante dans ce fichier Web.Config.

Configurer une application Web basée sur des formulaires afin qu'elle utilise un fournisseur LDAP à l'aide de Windows PowerShell

Effectuez les étapes de la procédure suivante afin de configurer l'authentification par formulaire pour une application Web basée sur des revendications à l'aide de Windows PowerShell.

Pour configurer une application Web basée sur des formulaires afin qu'elle utilise un fournisseur LDAP à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $ap = New-SPAuthenticationProvider -Name "ClaimsForms" -ASPNETMembershipProvider "membership" -ASPNETRoleProviderName "rolemanager"
$wa = New-SPWebApplication -Name "Claims Windows Web App" -ApplicationPool "Claims App Pool" -ApplicationPoolAccount "internal\appool"
  -Url http://servername -Port 80 -AuthenticationProvider $ap
    Remarque :
    La valeur du paramètre ApplicationPoolAccount doit correspondre à un compte géré dans la batterie de serveurs.

  6. Après avoir correctement créé un fournisseur d'authentification et une application Web, modifiez les fichiers Web.Config suivants à l'aide des exemples d'entrées fournis dans la section « Configurer les fichiers Web.Config LDAP » de cet article :

    • Le fichier Web.Config de l'application Web Administration centrale

    • Le fichier Web.Config du service d'émission de jeton de sécurité

    • Le fichier Web.Config de l'application Web basée sur des revendications pour l'authentification par formulaire

  7. Après avoir modifié les fichiers Web.Config, créez un SPClaimsPrinciple et une collection de sites, comme illustré dans l'exemple suivant :

    Code de copie
    $cp = New-SPClaimsPrincipal -Identity "membership:SiteOwner" -IdentityType FormsUser
$sp = New-SPSite http://servername:port -OwnerAlias $cp.Encode() -Template "STS#0"
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Migrer les utilisateurs et les autorisations depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010

Effectuez les étapes de la procédure suivante pour migrer les utilisateurs et les autorisations à l'aide de Windows PowerShell.

Pour migrer les utilisateurs et les autorisations depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $w = Get-SPWebApplication "http://<server>/"
$w.MigrateUsers(True)
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications

Date | Description | Raison
23 septembre 2010 | 2010/09/20 | Mise à jour du contenu


Configurer l'authentification Kerberos pour le service d'émission de jetons Revendications vers Windows (SharePoint Foundation 2010)

Cet article fournit un exemple d'environnement de batterie de serveurs comprenant trois ordinateurs afin d'illustrer la configuration de l'authentification Kerberos pour le service d'émission de jetons Revendications vers Windows dans Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Avant de commencer

  • Configurer une source de données externe

  • Configurer une délégation contrainte pour le compte de pool d'applications de service partagé

  • Configurer une délégation contrainte pour le compte de service d'émission de jetons Revendications vers Windows

  • Configurer le service d'émission de jetons Revendications vers Windows sur le serveur d'applications

Avant de commencer

Avant d'ajouter des entrées de nom principal de service (SPN) à un domaine Active Directory, vérifiez les points suivants :

  • Vous ne dupliquerez aucune entrée de nom principal de service existante dans le domaine.

  • Aucune entrée de nom principal de service que vous ajoutez n'est en cours d'utilisation par d'autres services ou comptes d'ordinateur.

Pour plus d'informations sur la recherche des comptes d'ordinateur avec entrées de nom principal de service en double, voir l'article 321044 de la Base de connaissances, ID d'événement 11 dans le journal système des contrôleurs de domaine (http://go.microsoft.com/fwlink/?linkid=166609&clcid=0x40C).

Important :
Pour créer des noms principaux de service dans un domaine Active Directory, vous devez disposer d'autorisations d'administration sur le domaine.

Topologie d'une batterie de serveurs

Cet article traite de la topologie de batterie de serveurs SharePoint Foundation 2010 suivante :

  • un ordinateur exécutant Windows Server 2008 et faisant office de serveur Web frontal ;

  • un ordinateur (Claims1) exécutant Windows Server 2008 et faisant office de serveur d'applications ;

  • un ordinateur (Claims2) exécutant Windows Server 2008 et SQL Server pour la batterie de serveurs qui exécute SharePoint Foundation 2010 ;

  • un ordinateur (Claims3) faisant office de source de données SQL externe.

Configurer une source de données externe

Pour configurer une source de données externe, installez le serveur SQL sur l'ordinateur Claims3. Assurez-vous que le service SQL Server est en cours d'exécution en tant que compte peopletest\osspool9.

Créez un nom principal de service en exécutant l'outil SETSPN.EXE sur le contrôleur de domaine, comme indiqué dans l'exemple suivant :

Code de copie
setspn -A MSSQLSvc/claims3:1433
peopletest\osspool9
setspn -A
MSSQLSvc/claims3.peopletest.extest.mydomain.net:1433 peopletest\osspool9

Configurer une délégation contrainte pour le compte de pool d'applications de service partagé

Effectuez les étapes suivantes pour configurer une délégation contrainte pour le compte de pool d'applications de service partagé :

  1. Ouvrez une session sur le contrôleur de domaine, puis cliquez successivement sur Démarrer, Outils d'administration et Utilisateurs et ordinateurs Active Directory.

  2. Développez le nœud du domaine, puis cliquez sur Utilisateurs.

  3. Cliquez avec le bouton droit sur le compte d'utilisateur d'identité du pool d'applications (peopletest\osspool8), puis sélectionnez Propriétés.

  4. Sous l'onglet Délégation, vérifiez que l'option N'approuver cet utilisateur que pour la délégation aux services spécifiés est sélectionnée.

  5. Cliquez sur Utiliser tout protocole d'authentification.

  6. Cliquez sur Ajouter, puis sur Utilisateurs ou ordinateurs.

  7. Tapez le domaine et le nom d'utilisateur du compte exécutant le service qui doit accepter les informations d'identification Kerberos. Dans cet exemple, tapez le nom du compte de service SQL sur l'ordinateur claims3 (peopletest\osspool9), puis cliquez sur OK.

  8. Les valeurs de services disponibles pour le compte que vous avez sélectionné apparaissent. Sélectionnez MSSQLSvc sur l'ordinateur Claims3, puis cliquez sur OK.

  9. Cliquez sur OK pour fermer la boîte de dialogue des propriétés du compte.

Remarque :
L'onglet Délégation ne s'affiche pas, sauf s'il existe un nom principal de service inscrit pour ce compte. Par conséquent, vous pouvez créer un nom principal de service non destiné à être utilisé, juste pour forcer l'affichage de l'onglet Délégation.

Vous pouvez créer un nom principal de service en exécutant l'outil SETSPN.EXE sur le contrôleur de domaine, comme indiqué dans l'exemple suivant :

Code de copie
setspn -A http/uniquespn1
peopletest\osspool8

Configurer une délégation contrainte pour le compte de service d'émission de jetons Revendications vers Windows

Effectuez les étapes suivantes pour configurer une délégation contrainte pour le compte de service d'émission de jetons Revendications vers Windows :

  1. Ouvrez une session sur le contrôleur de domaine, puis cliquez successivement sur Démarrer, Outils d'administration et Utilisateurs et ordinateurs Active Directory.

  2. Développez le nœud du domaine, puis cliquez sur Ordinateurs.

  3. Cliquez avec le bouton droit sur le compte d'identité du pool d'applications. Par défaut, le service d'émission de jetons Revendications vers Windows s'exécute sous le compte système local (Claims1, dans cet exemple). Cliquez ensuite sur Propriétés.

  4. Sous l'onglet Délégation, vérifiez que l'option N'approuver cet utilisateur que pour la délégation aux services spécifiés est sélectionnée.

  5. Cliquez sur Utiliser tout protocole d'authentification.

  6. Cliquez sur Ajouter, puis sur Utilisateurs ou ordinateurs.

  7. Tapez le domaine et le nom d'utilisateur du compte exécutant le service qui doit accepter les informations d'identification Kerberos. Dans cet exemple, tapez le nom du compte de service SQL sur l'ordinateur Claims3 (peopletest\osspool9), puis cliquez sur OK.

  8. Les valeurs de services disponibles pour le compte que vous avez sélectionné apparaissent. Sélectionnez MSSQLSvc sur l'ordinateur Claims3, puis cliquez sur OK.

  9. Cliquez sur OK pour fermer la boîte de dialogue des propriétés du compte.

Configurer le service d'émission de jetons Revendications vers Windows sur le serveur d'applications

Accordez au groupe WSS_SPG des autorisations permettant de convertir des revendications en identité Windows et effectuez les étapes suivantes pour configurer le service d'émission de jetons Revendications vers Windows sur l'ordinateur Claims1 :

  1. Dans le Bloc-notes, ouvrez le fichier wtshost.exe.config.

  2. Ajoutez <add value="WSS_WPG" /> à l'élément <allowedCallers> de la section <windowsTokenService>.

Le fichier doit ressembler à l'exemple suivant :

Code de copie
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="windowsTokenService" type="yourcompany.IdentityModel.WindowsTokenService.Configuration.WindowsTokenServiceSection, yourcompany.IdentityModel.WindowsTokenService, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
  </configSections>
  <windowsTokenService>
    <allowedCallers>
      <clear/>
      <add value="WSS_WPG" />
    </allowedCallers>
  </windowsTokenService>
</configuration>

Démarrez le service d'émission de jetons Revendications vers Windows à partir de la ligne de commande, comme indiqué dans l'exemple suivant :

Code de copie
net start c2wts
sc config c2wts start= auto

Historique des modifications

Date | Description | Raison
2 décembre 2010 | 2010/11/29 | Mise à jour du contenu


Configurer l'authentification à l'aide d'un jeton de sécurité SAML (SharePoint Foundation 2010)

Les procédures dans cet article expliquent comment configurer l'authentification à l'aide d'un jeton de sécurité SAML (Security Assertion Markup Language) pour une application Web Microsoft SharePoint Foundation 2010 à base de revendications.

La connexion SAML s'utilise généralement dans les scénarios de fédération d'entreprise, par exemple pour accorder l'accès à un partenaire commercial. On la déploie également pour accorder l'accès aux utilisateurs internes dont les comptes résident dans un domaine ne faisant pas partie de la forêt qui contient SharePoint Foundation 2010.

Avant de configurer l'authentification à l'aide d'un jeton de sécurité SAML pour une application Web SharePoint Foundation 2010 basée sur les revendications, vous devez configurer un serveur exécutant les services ADFS (Active Directory Federation Services) 2.0. Pour plus d'informations sur la configuration d'un serveur pour l'exécution des services AD FS 2.0, voir le Guide de déploiement des services AD FS 2.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=191723&clcid=0x40C).

Dans cet article :

  • Configurer une application Web IP-STS (Identity Provider STS) à l'aide de Windows PowerShell

  • Configurer une application Web RP-STS (Relying Party STS)

  • Établir une relation d'approbation avec une IP-STS à l'aide de Windows PowerShell

  • Exporter le certificat de confiance IP-STS à l'aide de Windows PowerShell

  • Définir un identificateur unique pour le mappage des revendications à l'aide de Windows PowerShell

  • Créer une application Web SharePoint et la configurer de façon à utiliser la connexion SAML

Configurer une application Web IP-STS (Identity Provider STS) à l'aide de Windows PowerShell

Exécutez les procédures suivantes pour utiliser Windows PowerShell afin de configurer une application Web SharePoint à base de revendications.

Pour configurer une application Web IP-STS à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, créez un objet x509Certificate2, comme illustré dans l'exemple suivant :

    Code de copie
    $cert = New-Object
System.Security.Cryptography.X509Certificates.X509Certificate2("path to cert file")

  6. Créez un mappage de type de revendication à utiliser dans votre fournisseur d'authentifications approuvé, comme illustré dans l'exemple suivant :

    Code de copie
    New-SPClaimTypeMapping "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress"
-IncomingClaimTypeDisplayName "EmailAddress" -SameAsIncoming

  7. Créez un fournisseur de connexions approuvé en créant d'abord une valeur pour le paramètre realm, comme illustré dans l'exemple suivant :

    Code de copie
    $realm = "urn:" + $env:ComputerName + ":domain-int"

  8. Créez une valeur pour le paramètre signinurl qui pointe vers l'application Web de service d'émission de jeton de sécurité, comme dans l'exemple suivant :

    Code de copie
    $signinurl = "https://test-2/FederationPassive/"

  9. Créez le fournisseur de connexions approuvé, en utilisant la même valeur IdentifierClaim que dans le mappage de revendications ($map1.InputClaimType), comme dans l'exemple suivant :

    Code de copie
    $ap = New-SPTrustedIdentityTokenIssuer -Name
"WIF" -Description "Windows® Identity Foundation" -Realm
$realm -ImportTrustCertificate $cert
-ClaimsMappings $map1[,$map2..] -SignInUrl
$signinurl -IdentifierClaim $map1.InputClaimType

  10. Créez une application Web en créant d'abord une valeur pour le compte du pool d'applications (pour l'utilisateur actuel), comme dans l'exemple suivant :

    Code de copie
    $account = "DOMAIN\" + $env:UserName
    Remarque :
    Le compte du pool d'applications doit être un compte géré. Pour créer un compte géré, utilisez New-SPManagedAccount.

  11. Créez une valeur pour l'URL de l'application Web ($webappurl = "https://" + $env:ComputerName), comme dans l'exemple suivant :

    Code de copie
    $wa = New-SPWebApplication -name "Claims WIF"
-SecureSocketsLayer -ApplicationPool "SharePoint SSL"
-ApplicationPoolAccount $account -Url $webappurl -Port 443
-AuthenticationProvider $ap

  12. Créez un site en commençant par créer un objet de revendication, comme dans l'exemple suivant :

    Code de copie
    $claim = New-SPClaimsPrincipal
-TrustedIdentityTokenIssuerr $ap -Identity
$env:UserName

  13. Créez un site, comme dans l'exemple suivant :

    Code de copie
    $site = New-SPSite $webappurl -OwnerAlias
$claim.ToEncodedString() -template "STS#0"

Configurer une application Web RP-STS (Relying Party STS)

Appliquez la procédure de cette section pour configurer une application Web RP-STS

Pour configurer une application Web RP-STS

  1. Ouvrez la console de gestion Active Directory Federation Services (AD FS) 2.0.

  2. Dans le volet gauche, développez Policy et sélectionnez l'option Relying Parties.

  3. Dans le volet droit, cliquez sur Add Relying Party. Cela ouvre l'Assistant de configuration AD FS (Active Directory Federation Services) 2.0.

  4. Dans la première page de l'Assistant, cliquez sur Start.

  5. Sélectionnez Enter relying party configuration manually, puis cliquez sur Next.

  6. Tapez le nom d'un partenaire de confiance et cliquez sur Next.

  7. Assurez-vous que Active Directory Federation Services (AD FS) 2.0 Server Profile est sélectionné, puis cliquez sur Next.

  8. N'utilisez pas de certificat de chiffrement. Cliquez sur Next.

  9. Sélectionnez Enable support for Web-browser-based identity federation.

  10. Tapez le nom de l'URL de l'application Web, puis ajoutez /_trust/ (par exemple : https://nomserveur/_trust/). Cliquez sur Next.

  11. Tapez le nom d'un identificateur (par exemple : urn:NOMORDINATEUR:Geneva), puis cliquez sur Add. Cliquez sur Next.

  12. Dans la page de synthèse, cliquez sur Next, puis cliquez sur Close. Cela ouvre la console de gestion de l'éditeur de règles. Utilisez cette console pour configurer le mappage des revendications entre une application Web LDAP et SharePoint.

  13. Dans le volet gauche, développez New rule et sélectionnez Predefined Rule.

  14. Sélectionnez Create Claims from LDAP Attribute Store.

  15. Dans le volet droit, dans la liste déroulante Attribute Store, sélectionnez Enterprise Active Directory User Account Store.

  16. Sous LDAP Attribute, sélectionnez sAMAccountName.

  17. Sous Outgoing Claim Type, sélectionnez E-Mail Address.

  18. Dans le volet gauche, cliquez sur Save.

Établir une relation d'approbation avec une IP-STS à l'aide de Windows PowerShell

Appliquez la procédure de cette section pour établir une relation d'approbation avec une application IP-STS.

Pour établir une relation d'approbation avec une IP-STS à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, établissez une relation d'approbation, comme illustré dans l'exemple suivant :

    Code de copie
    $waurl = "https://" + $env:ComputerName
$title = "SAML-Claims"

Exporter le certificat de confiance IP-STS à l'aide de Windows PowerShell

Appliquez la procédure de cette section pour exporter le certificat de l'IP-STS avec laquelle vous souhaitez établir une relation d'approbation, puis copier le certificat à un emplacement accessible par Microsoft SharePoint Foundation 2010.

Pour exporter le certificat de confiance IP-STS à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, exportez le certificat de confiance IP-STS, comme illustré dans l'exemple suivant :

    Code de copie
    $cert = New-Object System.Security.Cryptography.X509Certificates.X509Certificate2("c:\geneva.cer")

Définir un identificateur unique pour le mappage des revendications à l'aide de Windows PowerShell

Appliquez la procédure de cette section pour définir une adresse de messagerie qui servira d'identificateur unique pour le mappage des revendications. En général, l'administrateur de la STS approuvée devra fournir ces informations car seul le propriétaire de la STS sait quelle valeur dans le jeton sera toujours unique pour chaque utilisateur. Notez que l'administrateur de la STS approuvée peut créer un URI pour représenter l'adresse de messagerie.

Pour définir un identificateur unique pour le mappage des revendications à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, créez un mappage, comme illustré dans l'exemple suivant :

    Code de copie
    $map = New-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress" -IncomingClaimTypeDisplayName "EmailAddress" -SameAsIncoming

Créer un fournisseur d'authentification

Appliquez la procédure de cette section pour créer un fournisseur d'authentification qui sera utilisé par l'application Web.

Pour créer un fournisseur d'authentification à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, créez un fournisseur d'authentification, comme illustré dans l'exemple suivant. Notez que le domaine est le paramètre utilisé par la STS approuvée pour identifier une batterie SharePoint spécifique.

    Code de copie
    $realm = "urn:" + $env:ComputerName + ":Geneva"
$ap = New-SPTrustedIdentityTokenIssuer -Name "Geneva" -Description "Geneva" -Realm $realm -ImportTrustCertificate $cert -ClaimsMappings $map -SignInUrl "https://test-2/FederationPassive/" -IdentifierClaim "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress"

Créer une application Web SharePoint et la configurer de façon à utiliser la connexion SAML

Lors de cette étape, vous allez créer et configurer l'application Web.

Pour créer une application Web SharePoint et la configurer de façon à utiliser la connexion SAML à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, créez une application Web SharePoint et configurez-la de façon à utiliser la connexion SAML. Notez que vous devez remplacer "WebAppUrl" et "domain\admin" par les valeurs valides.

    Code de copie
    $wa = New-SPWebApplication -Name "SAML Sign-In" -SecureSocketsLayer -ApplicationPool "SAML Sign-In" -ApplicationPoolAccount "domain\admin" -
Url "WebAppUrl" -Port 443 -AuthenticationProvider $ap
    Remarque :
    Vous activez le protocole SSL car avec la connexion SAML les cookies sont utilisés comme ticket d'authentification unique pour l'utilisateur. Cela permet aux administrateurs d'accorder l'accès aux ressources SharePoint pendant toute la durée du jeton sans avoir à réauthentifier l'utilisateur. Sans le protocole SSL, ces cookies peuvent facilement être détournés par un utilisateur malveillant et servir à emprunter l'identité de l'utilisateur d'origine.

Une fois ces procédures terminées, créez un site SharePoint et assignez un propriétaire. Pour plus d'informations sur la création d'un site SharePoint, voir Créer une collection de sites (SharePoint Foundation 2010).

Historique des modifications


Configurer l'authentification basée sur les revendications à l'aide de Windows Live ID (SharePoint Foundation 2010)
Voir aussi

L'authentification basée sur les revendications dans Microsoft SharePoint Foundation 2010 peut déléguer l'authentification au service d'émission de jeton de sécurité (STS, Security Token Service) Windows Live ID. Ceci est important si vous souhaitez implémenter un scénario dans lequel vous utilisez Windows Live ID pour la gestion des mots de passe. Le service Windows Live ID est configuré comme fournisseur d'identité pour SharePoint Foundation 2010. Une relation d'approbation unidirectionnelle basée sur certificat est établie entre SharePoint Foundation 2010 et le service Windows Live ID. Lorsqu'un utilisateur fournit des informations d'identification Windows Live ID, le service Windows Live ID renvoie un PUID (Passport Unique Identity) et des informations de messagerie électronique encapsulés dans un jeton de revendications SAML (Security Assertion Markup Language) version 1.1. La clé publique Windows Live ID, qui fait partie du XML de métadonnées Windows Live ID, chiffre ce jeton de revendications.

Pour plus d'informations sur Windows Live ID, voir les ressources suivantes :

  • Introduction à Windows Live ID (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201477&clcid=0x40C)

  • Passerelle de fédération Microsoft (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=150843&clcid=0x40C)

  • Centre de développement Windows Live (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=191075&clcid=0x40C)

Le cookie Windows Live ID est mis en cache sur l'ordinateur client et envoyé à SharePoint Foundation 2010 au moyen d'une réponse POST à une demande d'authentification réussie. SharePoint Foundation 2010 convertit le jeton SAML Windows Live ID en jeton SAML SharePoint Foundation 2010. Le PUID de l'utilisateur est généré en fonction de la revendication UPN (User Principal Name) renvoyée dans le jeton SAML. Cette valeur est utilisée dans tout SharePoint Foundation 2010 afin d'identifier de manière unique l'utilisateur et d'effectuer le contrôle d'accès. SharePoint Foundation 2010 peut augmenter les jetons utilisateur à l'aide de revendications supplémentaires en faisant appel à un fournisseur de revendications personnalisé, qui est configuré dans l'applications Web SharePoint Foundation 2010. Le cookie SharePoint Foundation 2010 est également renvoyé à l'ordinateur client et mis en cache pour les demandes ultérieures. À l'expiration du cookie Windows Live ID ou SharePoint Foundation 2010, l'utilisateur est redirigé vers un serveur Windows Live ID.

Dans cet article :

  • Configurer le service d'émission de jeton de sécurité Windows Live ID

  • Configurer SharePoint pour l'authentification Windows Live ID

  • Convertir un environnement interne Windows Live ID en environnement de production

  • Créer différents types d'applications Web SharePoint basées sur les revendications

  • Accorder des autorisations à tous les utilisateurs authentifiés Windows Live ID

Configurer le service d'émission de jeton de sécurité Windows Live ID

Le protocole WS-Federation est implémenté par le service Windows Live ID et fournit l'infrastructure du service STS Live ID désigné comme fournisseur d'identité approuvé. Vous pouvez extraire un certificat public Windows Live ID à partir d'un nœud X509Certificate XML de métadonnées et l'enregistrer dans un certificat de sécurité Internet avec une extension de fichier .cer. Si le XML de métadonnées contient plusieurs nœuds X509Certificate, vous pouvez utiliser celui de votre choix. Accordez un accès en lecture au compte du pool d'applications de batterie SharePoint Foundation 2010 dans le certificat de sécurité Internet (fichier .cer).

Configurez Microsoft Services Manager (MSM) avec les valeurs suivantes :

Valeur | Description
Nom de domaine | Nom de domaine pour lequel les demandes d'authentification au service STS Live ID seront générées. Utilisez un nom de domaine complet.
URL de retour par défaut | URL vers laquelle le service STS Windows Live ID redirigera un utilisateur une fois l'authentification réussie, par exemple : https://username.global.corp.contoso.com/_trust/default.aspx.
Nom DNS | Identificateur unique fourni dans une demande d'authentification au service STS Windows Live ID. Cet identificateur unique active la fonctionnalité de recherche pour l'URL de retour par défaut. Le nom DNS doit correspondre à la valeur du domaine spécifiée dans la demande d'authentification Windows Live ID.
Paramètre WRealm | Le paramètre WRealm doit correspondre au champ DNS dans la configuration du site MSM. Ce paramètre doit être créé dans l'un des formats suivants :sub.domain.top ou Urn:domain:name.
Stratégie d'authentification de substitution | Configurez la Stratégie d'authentification de substitution avec la valeur suivante : MBI_FED_SSL.

Configurer SharePoint pour l'authentification Windows Live ID

Appliquez les procédures de cette section pour configurer SharePoint Foundation 2010 pour l'authentification Windows Live ID.

Pour configurer SharePoint pour l'authentification Windows Live ID à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell (autrement dit, PS C:\>), définissez la valeur du domaine de sorte qu'elle corresponde à la valeur Nom DNS spécifiée dans Microsoft Services Manager. La valeur du domaine dans l'intégration Windows Live ID doit correspondre au nom DNS correct, comme indiqué dans l'exemple suivant :

    Code de copie
    $realm = "urn:" + $env:ComputerName + ":ServerName"

  6. Obtenez la valeur PUID du compte que vous utiliserez comme compte Administrateur de batterie de serveurs en vous connectant tout d'abord au site Web suivant :Windows Live ID(https://accountservices.passport.net), puis en recherchant le champ Unique ID dans la page Informations d'identification.

  7. Spécifiez la valeur PUID au format suivant : PUID@live.com.

  8. Recherchez l'un des nœuds <X509Certificate> dans la source suivante : URL XML de métadonnées (https://nexus.passport-int.com/federationmetadata2/2007-06/federationmetadata.xml).

  9. Copiez le contenu de l'un des deux nœuds X509Certificate, comme indiqué dans l'exemple suivant :

    Code de copie
    MIICWzCCAcSgAwIBAgIJAJEzHoaEodSoMA0GCSqGSIb3DQEBBQUAMCkxJzAlBgNV
BAMTHkxpdmUgSUQgU1RTIFNpZ25pbmcgUHVibGljIEtleTAeFw0wODEwMzAyMjA5
MjNaFw0xMzEwMjkyMjA5MjNaMCkxJzAlBgNVBAMTHkxpdmUgSUQgU1RTIFNpZ25p
bmcgUHVibGljIEtleTCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEArz97XPae
GNAC4UnKl5zReyhgk3Bzf08U+CgD0R9+GZOahmpakJXFpI213gQWiHrUGaMN9nsK
4kzSfDPiquAMsV6vBYyWuPLZ0XrMzTAOV/WHSK3bCsYWWQZeH9Xn8G1Hkz+gQSC/
92lBbq9oBCZfLv3OlkobOmT8d+ldRKGU4pUCAwEAAaOBijCBhzAdBgNVHQ4EFgQU
VbJyIcGL0AjB4/Wm4DqUZux6uUkwWQYDVR0jBFIwUIAUVbJyIcGL0AjB4/Wm4DqU
Zux6uUmhLaQrMCkxJzAlBgNVBAMTHkxpdmUgSUQgU1RTIFNpZ25pbmcgUHVibGlj
IEtleYIJAJEzHoaEodSoMAsGA1UdDwQEAwIBxjANBgkqhkiG9w0BAQUFAAOBgQAO
/5vGfu+Vg1TKBuxsAIMqjqKXX7aRrANNZM/5ACdwAUtMDG/n8INoXgOKr851fbF6
4yBesmFjg2TbR8y0/ITAD+d+iyEpR7IO3/is9rWAj4ggbw8yqaDWn26eh3bAdoa+
p38qtqJHkUGF5vApeHiu6zO573bKs+nXcKVM8mNbjA==

  10. Collez le contenu de l'un des nœuds X509Certificate dans un fichier Bloc-notes et enregistrez ce fichier sous le nom suivant : LiveID-INT.cer.

  11. Configurez le certificat Windows Live ID (extrait à partir du XML de métadonnées), comme indiqué dans l'exemple suivant :

    Code de copie
    $certloc = "C:\LiveIDWithSAML\LiveID-INT.cer"

  12. Définissez une nouvelle autorité racine de confiance dans SharePoint Foundation 2010, comme indiqué dans l'exemple suivant :

    Code de copie
    $rootcert = Get-PfxCertificate $certloc
New-SPTrustedRootAuthority "NewRootAuthority" -Certificate $rootcert | Out-Null

  13. Créez un objet avec un certificat Windows Live ID, comme indiqué dans l'exemple suivant :

    Code de copie
    $cert = New-Object System.Security.Cryptography.X509Certificates.X509Certificate2($certloc)

  14. Définissez la revendication que vous utiliserez comme identificateur unique de l'utilisateur. Mappez la revendication UPN au nom de revendication réservé Identifier. La revendication d'adresse de messagerie électronique peut également être mappée, comme indiqué dans l'exemple suivant :

    Code de copie
    $map1 = New-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/claims/EmailAddress" -IncomingClaimTypeDisplayName "http://schemas.xmlsoap.org/claims/EmailAddress" -SameAsIncoming
$map2 = New-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier" -IncomingClaimTypeDisplayName "UPN" -LocalClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/upn"

  15. Créez un fournisseur d'authentification SharePoint Foundation 2010 pour une nouvelle application Web, comme indiqué dans l'exemple suivant :

    Code de copie
    $apSAML = New-SPTrustedIdentityTokenIssuer -Name "LiveID" -Description "LiveID" -Realm $realm -ImportTrustCertificate $cert -ClaimsMappings $map1,$map2 -SignInUrl "https://login.live-int.com/login.srf" -IdentifierClaim "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier"

  16. Créez une application Web SharePoint Foundation 2010 à utiliser avec le fournisseur d'authentification créé à l'étape précédente, comme indiqué dans l'exemple suivant :

    Code de copie
    $waurl = https://" + $env:ComputerName - You might use FQDN url of your site here.
$title = "Site Title"
$waexe = New-SPWebApplication -Name $title -ApplicationPool $title -ApplicationPoolAccount $owner -Url $waurl -AuthenticationProvider
$scexe = New-SPSite $siteurl -Name $title -Description $title -Template 'STS#1' -OwnerAlias

  17. Démarrez le Gestionnaire des services Internet en tapant INETMGR à une invite de commandes.

  18. Accédez au site Application Web des revendications dans les services Internet (IIS).

  19. Dans le volet gauche, cliquez avec le bouton droit sur Application Web des revendicationset sélectionnez Modifier les liaisons.

  20. Sélectionnez https et cliquez sur Modifier.

  21. Sous Certificat SSL, sélectionnez un certificat dans la liste. Il est préférable d'utiliser un certificat signé automatiquement.

  22. Importez le certificat public Windows Live ID dans les dossiers Ordinateur local, SharePoint Foundation 2010 et Personnes autorisées.

Convertir un environnement interne Windows Live ID en environnement de production

Appliquez les procédures de cette section pour convertir un environnement interne Windows Live ID en environnement de production.

Pour convertir un environnement interne Windows Live ID en environnement de production

  1. Assurez-vous que le site est migré vers un environnement de production dans MSM et que la conformité est satisfaite. Un examen de conformité n'est pas nécessaire si l'environnement Windows Live ID dans MSM est interne.

  2. Assurez-vous que la stratégie d'authentification de l'environnement de production Windows Live ID est configurée avec la valeur suivante : MBI_FED_SSL.

  3. Assurez-vous que l'environnement de production Windows Live ID utilise des URL HTTPS car la stratégie d'authentification d'environnement de production est configurée pour le transport SSL. Les sites de l'environnement de production envoient des demandes POST sur SSL à https://login.live.com. Dans le SPTrustedIdentityTokenIssuer figure un URI de fournisseur qui doit correspondre à l'URI de connexion Live. Assurez-vous que l'URI d'ouverture de session Live est basée sur le protocole HTTPS.

  4. Si le fournisseur de revendications Windows Live ID est configuré de façon à utiliser une adresse de messagerie plutôt qu'un PUID, le site d'environnement de production doit figurer dans le groupe de stratégies Microsoft. Sachez que ce groupe de stratégies est approuvé automatiquement pour les partenaires internes et qu'une approbation explicite est requise pour les partenaires externes.

Créer différents types d'applications Web SharePoint basées sur les revendications

Appliquez les procédures de cette section pour exécuter un script Windows PowerShell afin de créer différents types d'applications SharePoint Foundation 2010 basées sur les revendications.

Pour créer différents types d'applications Web SharePoint basées sur les revendications à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, exécutez le script DeployLiveIdWithSAML, comme indiqué dans l'exemple suivant :

    Code de copie
    #.SYNOPSIS
#    Script for creating different types of claims web applications from the Windows PowerShell command line.
#.DESCRIPTION
#    Script will create ANON, WIN, FBA, MULTI, MIXED, SAML and combinations of these web applications.
#.NOTES
#    Script: ClaimsWA.ps1
#    Remark: The script will load/unload additional snap-ins depending on where it's being executed from.
#    Update: 1/15/2010 (v2.0)
#.PARAMETER type
#   Indicates the type of claims web app to create (see examples for full list of valid supported types)
#If not specified, this will default to ALL and each of the supported types of claims web apps will be created
#.PARAMETER port
#   Indicates the port number to create the web app on (See reserved ports at http://support.microsoft.com/kb/832017)
#If not specified, this will default to port 201 and will be incremented in sequence for multiple web apps
#.PARAMETER owner
#   Indicates the domain account that will be used for App Pool (should be registered as a SharePoint Server managed account)
#If not specified, this will default to logged on user and will use USERDOMAIN & USERNAME environment values
#.EXAMPLE
#   claimswa.ps1 WIN (create WIN-claims web app at port# 201 and use logged on user for app pool account)
#
#   Here are some more examples of HOWTO use the script:
#      claimswa.ps1 ANON (create ANON web app at port# 201)
#      claimswa.ps1 ANON/FBA 701 (create ANON/FBA web app at port# 701)
#      claimswa.ps1 FBA (create FBA web app at port# 201 using LDAP provider; default is REDMOND instance)
#      claimswa.ps1 FBA/IBM (create FBA web app at port# 201 using LDAP provider pointing to the IBM instance)
#      claimswa.ps1 FBA/SQL 851 (create forms-based authentication web app at port# 851 using SQL provider)
#      claimswa.ps1 WIN/FBA/MIXED 501 (create Windows/forms-based authentication mixed-mode web apps at port# 501)
#      claimswa.ps1 WIN/SAML/MULTI 901 (create Windows/SAML multi-auth web apps at port# 901)
#
#   Here is the full list of all the support TYPEs (combine options delimited with slash for your config):
#
#   Basic auth types:
#      WIN   : create Windows claims web application on the port# specified on command line
#      FBA   : create forms-based authentication claims web apps with the specified membership provider (SQL Server/LDAP listed below)
#      SAML  : create SAML-claims web application on the default HTTPS port# 443
#      ANON  : indicator switch for creating the web application to allow ANON mode
#   Complex auth types:
#      MULTI : create claims web application with multiple auth types using a single URL to access
#      MIXED : create claims web application with multiple auth types using multiple URLs to access
#   FBA membership/rolemanager providers
#      RED   : use the REDMOND domain LDAP provider; this is the default setting if a provider is not specified
#      SQL   : use the SQL Server provider for connecting to forms-based authentication web apps (connects to the ASPNETDB instance on ZADANG)
#      PPL   : use the PEOPLEDC domain LDAP provider that is a private domain used for testing PEOPLE features
#      SUN   : use the SUNOne LDAP provider in the PEOPLEDC domain which is used for profile import/sync testing
#      IBM   : use the IBM LDAP provider in the PEOPLEDC domain which is used for profile import/sync testing
#      NVL   : use the Novell LDAP provider in the PEOPLEDC domain which is used for profile import/sync testing

# TODO (no specific ETA for these updates):
#    1. Set the default IIS cert bindings for SAML web
#    2. Use IIS CMDlets instead of updating XML object
#    3. We should be able to define MixedMode base auth
#    4. Use the domain for logged on user for LDAP string
#    5. Do not attempt to write to CA/STS if running on WFE

# Define the args list that we will accept & work with
param ([string]$type, [int]$port, [string]$owner)

function main() {
    # Valid options list
    $auths  = @("WIN", "FBA", "SAML", "ANON")
    $extnd  = @("MULTI", "MIXED")
    $provs  = @("SQL", "RED", "PPL", "SUN", "IBM", "NVL")
    $optns  = @("APP", "FIX")
    $typeOK = $true

    # Do we have the minimum args data before we can proceed
    # I'm not doing extensive validation but at least minimum
    foreach ($arg in $type.split("/")) {
        if (($auths+$extnd+$optns+$provs) -notcontains $arg) {
            write-host -Fore Red "`nInvalid TYPE argument was specified; execution aborted!`nTo see a list of valid TYPEs, execute with -examples option`n"
            $typeOK=$false; break
        }
    }

    if ($typeOK) {
        $type = @($type.toupper().split("/") | Sort | Get-Unique)
        switch ($type.count) {
            1 {
                foreach ($arg in $type) {
                    if (($auths+$extnd+$optns) -notcontains $arg) {
                        write-host -Fore Red "`nInvalid AUTH argument was specified; execution aborted!`nTo see a list of valid AUTHs, execute with -examples option`n"
                        $typeOK=$false; break
                    }
                }
                if (($type -eq "MULTI") -or ($type -eq "MIXED")) {
                    $type += @("WIN", "FBA"); write-host -Fore Yellow "MULTI/MIXED auth combo not specified; defaulting to $type"
                }
                if ($type -eq "ANON") {
                    $type += @("WIN"); write-host -Fore Yellow "ANON auth combo not specified; defaulting to $type"
                }
            }

            2 {
                if ($type -contains "ANON") {
                    foreach ($arg in $type) {
                        if ($auths -notcontains $arg) {
                            write-host -Fore Red "`nInvalid ANON combo was specified; execution aborted!`nTo see a list of valid PROVIDERs, execute with -examples option`n"
                            $typeOK=$false; break
                        }
                    }
                }
                else {
                    $multiOK=$true
                    foreach ($arg in $type) {
                        if ($auth -notcontains $arg) {
                            $multiOK=$false; break
                        }
                    }
                    if ($multiOK) {$type += @("MULTI"); write-host -Fore Yellow "Multiple auth types specified; defaulting to $type"}
                }
            }
        }

        if (($type -contains "MULTI") -or ($type -contains "MIXED") -and ($type.count -lt 3)) {
            write-host -Fore Red "`nMULTI/MIXED option requires 2 base auth types be specified!`nTo see a list of valid TYPEs, execute with -examples option`n"
            $typeOK=$false
        }
    }

    if ($typeOK) {
        # We seem to have the TYPE argument, let's check the others

        if (-not $port) {
            if ($type -contains "SAML") {$port=443} else {$port=201}
            write-host -Fore Yellow "PORT not specified; defaulting to $port"
        }

        if (-not $owner) {
            $owner = $env:UserDomain + "\" + $env:UserName.tolower()
            write-host -Fore Yellow "OWNER not specified; defaulting to $owner"
        }

        #In case somebody attempts to execute this script in the regular PS/ISE console,
        #let's load the IIS/SP snap-in to ensure we have everything we need to work with
        Manage-SnapIns (1)

        # check what flavor of SERVER we're running
        $product = Get-SPProduct | Where-Object {$_.ProductName.contains("SharePoint Server 2010")};
        if ($product.ProductName.contains("Debug")) {$flavor="DEBUG"} else {$flavor="SHIP"}
        write-host -Fore Green "Detected $flavor flavor of MOSS installed on this farm!"

        if ($type -contains "APP") {
            Write-WEBConfigs 0 "APP"
        }
        elseif ($type -contains "FIX") {
            Fix-Environment
        }
        else {
            Create-WebApp $type $port
        }

        # We're done with the snap-ins, so let's unload them
        Manage-SnapIns (0)
    }
}

function Fix-Environment {
    # This is just a series of steps to clean up
    # Not recommended to use unless you know why!
    Remove-SPTrustedRootAuthority NewRootAuthority
    Remove-SPTrustedIdentityTokenIssuer ServerName

    # I need to add the other clean up stuff here...
}

# This is the core script block that creates the different web apps
function Create-WebApp ([string]$type, [int]$port) {
    $waurl = http://" + $env:ComputerName

    if ($type.contains("SAML")) { $waurl = $waurl.replace("http", "https") }
    $siteurl = $waurl + ":" + $port
    $title = "ClaimsWA-$port-" + $type.replace(" ","-")

    # Let's construct the WA/SC CMDlet call that we'll invoke later
    $waexe = "New-SPWebApplication -Name $title -ApplicationPool $title -ApplicationPoolAccount $owner -Url $waurl -AuthenticationProvider"
    $scexe = "New-SPSite $siteurl -Name $title -Description $title -Template 'STS#1' -OwnerAlias"

    write-host -Fore Cyan "`nSetting up $title on port $port now:"

    if ($type.contains("WIN")) {
        $apWIN = New-SPAuthenticationProvider -DisableKerberos:$true
        $cpWIN = New-SPClaimsPrincipal -Identity $owner -IdentityType 1
    }

    if ($type.contains("FBA")) {
        if ($type.contains("SQL")) {
            $membership="SQLms"; $rolemanager="SQLrm"; $identity = "sqlms:user1"
        }
        elseif ($type.contains("PPL")) {
            $membership="PPLms"; $rolemanager="PPLrm"; $identity = "pplms:fbauser1"
        }
        elseif ($type.contains("SUN")) {
            $membership="SUNms"; $rolemanager="SUNrm"; $identity = "sunms:fbauser1"
        }
        elseif ($type.contains("IBM")) {
            $membership="IBMms"; $rolemanager="IBMrm"; $identity = "ibmms:fbauser1"
        }
        elseif ($type.contains("NVL")) {
            $membership="NVLms"; $rolemanager="NVLrm"; $identity = "nvlms:fbauser1"
        }
        else {
            $membership="REDms"; $rolemanager="REDrm"; $identity = ("redms:$env:UserName").tolower()
        }

        $apFBA = New-SPAuthenticationProvider -ASPNETMembershipProvider $membership -ASPNETRoleProviderName $rolemanager;
        $cpFBA = New-SPClaimsPrincipal -Identity $identity -IdentityType 4
    }

    if ($type.contains("SAML")) {
        $realm = "urn:" + $env:ComputerName + ":ServerName"
        $user  = "000300008448E34D@live.com"
        $certloc = "C:\LiveIDWithSAML\LiveID-INT.cer"

        $rootcert = Get-PfxCertificate $certloc
        New-SPTrustedRootAuthority "NewRootAuthority" -Certificate $rootcert | Out-Null

       $cert = New-Object System.Security.Cryptography.X509Certificates.X509Certificate2($certloc)
       $map1 = New-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/claims/EmailAddress" -IncomingClaimTypeDisplayName "http://schemas.xmlsoap.org/claims/EmailAddress" -SameAsIncoming
       $map2 = New-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier" -IncomingClaimTypeDisplayName "UPN" -LocalClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/upn"

       $apSAML = New-SPTrustedIdentityTokenIssuer -Name "LiveID" -Description "LiveID" -Realm $realm -ImportTrustCertificate $cert -ClaimsMappings $map1,$map2 -SignInUrl "https://login.live-int.com/login.srf" -IdentifierClaim "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier"
       $cpSAML = New-SPClaimsPrincipal -TrustedIdentityTokenIssuer $apSAML -Identity $user.tolower()
    }

    if ($type.contains("WIN")) {
        $waexe += " `$apWIN"; $scexe += " `$cpWIN.ToEncodedString()"
    }
    elseif ($type.contains("FBA")) {
        $waexe += " `$apFBA"; $scexe += " `$cpFBA.ToEncodedString()"
    }
    else {
        $waexe += " `$apSAML -SecureSocketsLayer"; $scexe += " `$cpSAML.ToEncodedString()"
    }

    if ($type.contains("MULTI")) {
        if ($type.contains("WIN")) {
            if ($type.contains("FBA")) {
                $waexe += ",`$apFBA"; $scexe += " -SecondaryOwnerAlias `$cpFBA.ToEncodedString()"
            }
            if ($type.contains("SAML")) {
                $waexe += ",`$apSAML -SecureSocketsLayer"; if (!$scexe.contains("Secondary")) { $scexe += " -SecondaryOwnerAlias `$cpSAML.ToEncodedString()" }
            }
        }
        else {
            $waexe += ",`$apSAML -SecureSocketsLayer"; $scexe += " -SecondaryOwnerAlias `$cpSAML.ToEncodedString()"
        }
    }

    # Check if we're creating the ANON web apps
    if ($type.contains("ANON")) { $waexe += " -AllowAnonymousAccess" }

    $waexe += " -Port $port | Out-Null"; $scexe += " | Out-Null"

    write-host -Fore Cyan "Deploying app..." -noNewLine
    Invoke-Expression $waexe

    # We could do this with a simple if/else but there may be other auth types too
    if ($type.contains("WIN"))  { Create-UserPolicy $siteurl $cpWIN.ToEncodedString()  }
    if ($type.contains("FBA"))  { Create-UserPolicy $siteurl $cpFBA.ToEncodedString()  }
    if ($type.contains("SAML")) { Create-UserPolicy $siteurl $cpSAML.ToEncodedString() }

    write-host -Fore Cyan "Creating site..." -noNewLine
    Invoke-Expression $scexe

    # If this is the ANON web app, then set the root site access to entire web
    if ($type.contains("ANON")) { $web = Get-SPWeb $siteurl; $web.AnonymousState="On"; $web.Update() }

    # At this time, let's also check if it's going to be a MixedMode web app
    if ($type.contains("MIXED")) {
        # If it's a Mixed-Mode web app we need to extend the base app to another auth type too
        $port++; write-host -Fore Cyan "Extending port $port..." -noNewLine
        $waurl = $waurl.replace("https", "http")
        $waexe = "Get-SPWebApplication $siteurl | New-SPWebApplicationExtension -Name $title-Ext -Zone `"Intranet`" -URL $waurl -Port $port -AuthenticationProvider"
        if ($type.contains("WIN")) {
            if ($type.contains("FBA")) { $waexe += " `$apFBA" } else { $waexe += " `$apSAML" }
        }
        else {
            $waexe += " `$apSAML"
        }
        Invoke-Expression $waexe
    }

    # If we've created a FBA web app, then it's time to update the CA/STS/FBA web.config files
    if ($type.contains("FBA")) { Write-WEBConfigs 0 $port.tostring() }; write-host -Fore Cyan "done!"
}

function Create-UserPolicy ([string]$weburl, [string]$encodeduser) {
    $webapp = Get-SPWebApplication $weburl
    $policy = $webapp.Policies.Add($encodeduser, "ClaimsWA.ps1 User")
    $role = $webapp.PolicyRoles.GetSpecialRole([Microsoft.SharePoint.Administration.SPPolicyRoleType]::FullControl)
    $policy.PolicyRoleBindings.Add($role)
    $webapp.Update()
}

function Write-WEBConfigs ([int]$begin, [string]$vroot) {
    # For now I'm using the XML object to load/save the config files
    # Eventually we should use the IIS:CMDlets from WebAdministration

    write-host -Fore Cyan "Writing WEBConfig..." -noNewLine
    #$filei = "\\back\scratch\suntoshs\backup\webconfigs.xml"
    $filei = "\\back\scratch\suntoshs\scripts\oobinstall\webconfigs.xml"

    $xmli = [xml](get-content $filei)
    $root = $xmli.get_DocumentElement()

    for ($j=$begin; $j -le 2; $j++) {
        if ($j -eq 0) {
            [void][reflection.assembly]::LoadWithPartialName("Microsoft.SharePoint")
            $fileo = [Microsoft.SharePoint.Administration.SPAdministrationWebApplication]::Local.IisSettings.get_Item(0).Path.FullName + "\web.config"
        }
        elseif ($j -eq 1) {
            $fileo = $env:CommonProgramFiles + "\Microsoft Shared\Web Server Extensions\14\WebServices\SecurityToken\web.config"
            if ($flavor -eq "DEBUG") { $fileo = $fileo.replace("Shared", "Shared Debug") }
        }
        else {
            if ($vroot -ne "APP") { $fileo = $env:HomeDrive + "\inetpub\wwwroot\wss\VirtualDirectories\$vroot\web.config" }
        }

        $xmlo = [xml](get-content $fileo)
        $perf = $xmlo.CreateElement("clear")

        if ($flavor -eq "DEBUG") {
            $ship = $root.config[1].tokens.token[0].value
            $debug = $root.config[1].tokens.token[1].value
            $token = $root.config[0]["system.web"].membership.providers.add[0].type
            $root.config[0]["system.web"].membership.providers.add[0].SetAttribute("type", $token.replace($ship,$debug)) | Out-Null
            $token = $root.config[0]["system.web"].rolemanager.providers.add[0].type
            $root.config[0]["system.web"].rolemanager.providers.add[0].SetAttribute("type", $token.replace($ship,$debug)) | Out-Null
        }

        if ($j -eq 0) {
            # Update the CA web config
            if (-not $xmlo.SelectSingleNode("/configuration/connectionStrings")) {
                $xmlo.configuration["system.web"].membership.ParentNode.RemoveChild($xmlo.configuration["system.web"].membership) | Out-Null
                $xmlo.configuration["system.web"].roleManager.ParentNode.RemoveChild($xmlo.configuration["system.web"].roleManager) | Out-Null
                $xmlo.SelectSingleNode("/configuration").AppendChild($xmlo.ImportNode($root.config[0]["connectionStrings"], $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web").AppendChild($xmlo.ImportNode($root.config[0]["system.web"].membership, $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web/membership/providers").PrependChild($xmlo.ImportNode($perf, $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web").AppendChild($xmlo.ImportNode($root.config[0]["system.web"].rolemanager, $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web/roleManager/providers").PrependChild($xmlo.ImportNode($perf, $true)) | Out-Null
            }
        }
        elseif ($j -eq 1) {
            # Update the STS web config
            if (-not $xmlo.SelectSingleNode("/configuration/system.web")) {
                $xmlo.SelectSingleNode("/configuration").AppendChild($xmlo.ImportNode($root.config[0]["connectionStrings"], $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration").AppendChild($xmlo.ImportNode($root.config[0]["system.web"], $true)) | Out-Null
            }
        }
        else {
            # Update the FBA web config
            if ($vroot -ne "APP") {
                if ($type.contains("PPL")) {$provider=1} elseif ($type.contains("SUN")) {$provider=2} elseif ($type.contains("IBM")) {$provider=3} elseif ($type.contains("NVL")) {$provider=4} elseif ($type.contains("SQL")) {$provider=5} else {$provider=0}
                $xmlo.SelectSingleNode("/configuration").AppendChild($xmlo.ImportNode($root.config[0]["connectionStrings"], $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web/membership/providers").PrependChild($xmlo.ImportNode($root.config[0]["system.web"].membership.providers.add[$provider], $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web/membership/providers").PrependChild($xmlo.ImportNode($perf, $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web/roleManager/providers").PrependChild($xmlo.ImportNode($root.config[0]["system.web"].rolemanager.providers.add[$provider], $true)) | Out-Null
                $xmlo.SelectSingleNode("/configuration/system.web/roleManager/providers").PrependChild($xmlo.ImportNode($perf, $true)) | Out-Null
            }
        }
        $xmlo.Save($fileo)
    }
}

function Manage-SnapIns ([int]$action) {
    #The OWSTimer process always causes an update conflict (known bug) while
    #creating multiple web apps; let's temporarily shut it down until we're done

    if ($action -eq 1) { Stop-Service "SPTimerV4" }

    # We need to do this only if we're running on ISE so check it
    if ($host.name.contains("ISE")) {
        if ($action -eq 1) {
            write-host -Fore Yellow "Detecting host and loading dependent snap-ins..."
            # Add-PSSnapIn WebAdministration (later!)
            Add-PSSnapIn Microsoft.Sharepoint.PowerShell
        }
        else {
            write-host -Fore Yellow "Unloading dependent snap-ins loaded earlier on..."
            # Remove-PSSnapIn WebAdministration (later!)
            Remove-PSSnapIn Microsoft.Sharepoint.PowerShell
        }
    }
    if ($action -eq 0) {Start-Service "SPTimerV4"; write-host -Fore Yellow "`nAll done; if there were errors please research PS database for known issues!`n"}
}

main

  6. Démarrez le Gestionnaire des services Internet en tapant INETMGR à une invite de commandes.

  7. Accédez au site Application Web des revendications dans les services Internet (IIS).

  8. Dans le volet gauche, cliquez avec le bouton droit sur Application Web des revendicationset sélectionnez Modifier les liaisons.

  9. Sélectionnez https et cliquez sur Modifier.

  10. Sous Certificat SSL, sélectionnez un certificat dans la liste. Il est préférable d'utiliser un certificat signé automatiquement.

  11. Importez le certificat public Windows Live ID dans les dossiers Ordinateur local, SharePoint Foundation 2010 et Personnes autorisées.

  12. Réinitialisez les services Internet (IIS) et accédez à l'URL du site.

Accorder des autorisations à tous les utilisateurs authentifiés Windows Live ID

Appliquez les procédures de cette section pour accorder des autorisations à tous les utilisateurs authentifiés Windows Live ID.

Pour accorder des autorisations à tous les utilisateurs authentifiés Windows Live ID

  1. Naviguez jusqu'au site SharePoint Foundation 2010 que vous avez créé et ouvrez une session à l'aide du compte d'administrateur.

  2. Dans le menu Actions du site, cliquez sur Paramètres du site.

  3. Dans la section Utilisateurs et autorisations, cliquez sur Autorisations de site.

  4. Cliquez sur le groupe Visiteurs de nom_site, où nom_site est le nom du site.

  5. Cliquez sur Nouveau, puis sur Ajouter des utilisateurs.

  6. Dans la fenêtre Accorder des autorisations, cliquez sur l'icône de navigation.

  7. Dans la fenêtre Sélectionner des personnes et des groupes, cliquez sur Tous les utilisateurs, puis cliquez sur Tous les utilisateurs (LiveIDSTS) dans le volet droit.

  8. Cliquez sur Ajouter.

  9. Cliquez sur OK.

  10. Vérifiez que Tous les utilisateurs (LiveIDSTS) fait maintenant partie du groupe du visiteur. Vous devriez maintenant être en mesure d'ouvrir une session sur le site SharePoint Foundation 2010 avec les informations d'identification de n'importe quel autre utilisateur Live ID.

À propos de l'auteur

Birendra Acharya est Ingénieur en conception logicielle pour MSIT chez Microsoft.

Voir aussi

Autres ressources

Présentation de WS-Federation (http://go.microsoft.com/fwlink/?linkid=192377&clcid=0x40C) (éventuellement en anglais)

Historique des modifications

Date | Description | Raison
9 septembre 2010 | Publication initiale |


Configure Digest authentication for a claims-based Web application (SharePoint Foundation 2010)
Voir aussi

This article describes how to configure digest authentication for one or more zones within a Microsoft SharePoint Foundation 2010 claims-based Web application. A Web application is an IIS Web site thatSharePoint Foundation 2010 creates and uses. Zones represent different logical paths for gaining access to the same Web application. Within each Web application, you can create up to five zones. A different Web site in IIS represents each zone. Use zones to enforce different access and policy conditions for large groups of users. To configure digest authentication for one or more zones in a SharePoint Foundation 2010 Web application, use the IIS Management Console to directly configure IIS.

Although digest authentication provides the same functionality as basic authentication, digest authentication encrypts user credentials to increase security. User credentials are sent as an MD5 message digest in which the original user name and password cannot be deciphered. Digest authentication uses a challenge/response protocol that requires the authentication requestor to present valid credentials in response to a challenge from the server. To authenticate against the server, the client has to supply an MD5 message digest in a response that contains a shared secret password string. The MD5 Message-Digest Algorithm is described in detail in RFC 1321. For access to RFC 1321, see The Internet Engineering Task Force (http://go.microsoft.com/fwlink/?LinkId=209085).

To use digest authentication, note the following requirements:

  • The user and IIS server must be members of, or trusted by, the same domain.

  • Users must have a valid Windows user account stored in Active Directory Domain Services (AD DS) on the domain controller.

  • The domain must use a Microsoft Windows Server 2008 domain controller.

Configure IIS to enable digest authentication

Use the IIS Management Console to configure IIS to enable digest authentication for one or more of the following zones for a claims-based Web application:

Remarque :
The Default zone is the zone that is first created when a Web application is created. The other zones are created by extending a Web application.

  • Default

  • Intranet

  • Extranet

To configure IIS to enable digest authentication

  1. Verify that you have one of the following administrative credentials:

    • You must be a member of the Administrators group on the server on which you are configuring IIS.

  2. On the Start menu, point to All Programs, click Administrative Tools , and then click Internet Information Services (IIS) Manager to start the IIS Management Console.

  3. Expand Sites on the console tree, right-click the IIS Web site that corresponds to the Web application zone on which you want to configure digest authentication, and then click Properties.

  4. On the Web Site Properties page, click the Directory Security tab.

  5. In the Anonymous access and authentication control section, click Edit.

  6. In the Authenticated access section of the Authentication Methods dialog box, select Digest authentication for Windows domain servers.

    A dialog box informs you that digest authentication only works with AD DS domain accounts, and asking you if you want to continue. Click Yes.

  7. In the Realm section of the of the Authentication Methods dialog box, click Select.

  8. Select the appropriate realm and click OK. On the other open dialog boxes, click OK.

At this point, the Web site is configured to use digest authentication.

Voir aussi

Autres ressources

What is Digest Authentication? (http://go.microsoft.com/fwlink/?LinkId=209085)

Historique des modifications

Date | Description | Raison
2011/01/17 | Publication initiale |


Configure Basic authentication for a claims-based Web application (SharePoint Foundation 2010)

This article describes how to configure basic authentication for one or more zones within a Microsoft SharePoint Foundation 2010 claims-based Web application. A Web application is an Internet Information Services (IIS) Web site that SharePoint Foundation 2010 creates and uses. Zones represent different logical paths for gaining access to the network services that are available within the same Web application. Within each Web application, you can create up to five zones. A different Web site in IIS represents each zone. Use zones to enforce different access and policy conditions for large groups of users. To configure basic authentication for one or more zones in a SharePoint Foundation 2010 Web application, use the IIS Management Console to directly configure IIS.

Basic authentication requires previously assigned Windows account credentials for user access. Basic authentication enables a Web browser to provide credentials when the browser makes a request during an HTTP transaction. Because user credentials are not encrypted for network transmission but are sent over the network in plaintext, we do not recommend using basic authentication over an unsecured HTTP connection. To use basic authentication, you should enable Secure Sockets Layer (SSL) encryption.

Configure IIS to enable basic authentication

Use the IIS Management Console to configure IIS to enable basic authentication for one or more of the following zones for a claims-based Web application:

Remarque :
The Default zone is the zone that is first created when a Web application is created. The other zones are created by extending a Web application.

  • Default

  • Intranet

  • Extranet

To configure IIS to enable basic authentication

  1. Verify that you have one of the following administrative credentials:

    • You must be a member of the Administrators group on the server on which you are configuring IIS.

  2. On the Start menu, point to All Programs, click Administrative Tools , and then click Internet Information Services (IIS) Manager to start the IIS Management Console.

  3. Expand Sites on the console tree, right-click the IIS Web site that corresponds to the Web application zone on which you want to configure basic authentication, and then click Properties.

  4. On the Web Site Properties page, click the Directory Security tab.

  5. In the Anonymous access and authentication control section, click Edit.

  6. In the Authenticated access section of the Authentication Methods dialog box, select Basic authentication for Windows domain servers.

  7. In the Realm section of the of the Authentication Methods dialog box, click Select.

  8. Select the appropriate realm and click OK. On the other open dialog boxes, click OK.

At this point, the Web site is configured to use basic authentication.

For information about creating a claims-based Web application in SharePoint Foundation 2010, see Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010).

If you want credentials of users to be sent over a network in a form that is not encrypted, select Basic authentication (password is sent in clear text).

Sécurité Remarque :
You can select basic authentication or integrated Windows authentication, or both. If you select both, SharePoint Foundation 2010 will offer both authentication types to the client Web browser. The client Web browser then determines the type of authentication to use. If you only select basic authentication, ensure that SSL is enabled; otherwise, the credentials can be intercepted by a malicious user.

Historique des modifications

Date | Description | Raison
2011/01/17 | Publication initiale |


Configurer l'authentification Kerberos (SharePoint Foundation 2010)

Dans cet article :

  • À propos de l'authentification Kerberos

  • Avant de commencer

  • Configurer l'authentification Kerberos pour les communications SQL

  • Créer des noms principaux de service pour vos applications Web utilisant l'authentification Kerberos

  • Déployer la batterie de serveurs

  • Configurer les services sur les serveurs de la batterie

  • Créer des applications Web utilisant l'authentification Kerberos

  • Créer une collection de sites à l'aide du modèle Portail de collaboration sur l'application Web du site portail

  • Vérifier l'accès aux applications Web utilisant l'authentification Kerberos

  • Vérifier les fonctionnalités d'indexation de la recherche

  • Vérifier les fonctionnalités des requêtes de recherche

  • Limites de configuration

  • Ressources supplémentaires et conseils de résolution des problèmes

À propos de l'authentification Kerberos

Kerberos est un protocole sécurisé qui prend en charge l'authentification par ticket. Un serveur d'authentification Kerberos accorde un ticket en réponse à une requête d'authentification d'un ordinateur client, si la requête contient des informations d'identification utilisateur et un nom principal de service valides. L'ordinateur client utilise ensuite ce ticket pour accéder aux ressources du réseau. Pour activer l'authentification Kerberos, les ordinateurs client et serveur doivent disposer d'une connexion approuvée au centre de distribution de clés du domaine. Ce centre distribue les clés secrètes partagées pour permettre le chiffrement. Les ordinateurs client et serveur doivent également pouvoir accéder aux services de domaine Active Directory (AD DS, Active Directory Domain Services). Pour AD DS, le domaine racine de la forêt est le centre des références d'authentification Kerberos.

Pour déployer une batterie de serveurs exécutant Microsoft SharePoint Foundation 2010 et utilisant l'authentification Kerberos, vous devez installer et configurer plusieurs applications différentes sur vos ordinateurs. Cet article décrit un exemple de batterie de serveurs exécutant SharePoint Foundation 2010 et fournit des conseils pour le déploiement et la configuration de la batterie afin d'utiliser l'authentification Kerberos pour prendre en charge les fonctionnalités suivantes :

  • Communication entre SharePoint Foundation 2010 et le logiciel de gestion de bases de données Microsoft SQL Server

  • Accès à l'application Web Administration centrale de SharePoint

  • Accès à d'autres applications Web, y compris une application Web de site portail et une application Web Mon site

Avant de commencer

Cet article est destiné au personnel administratif qui possède des connaissances dans les technologies suivantes :

  • Windows Server 2008

  • Active Directory

  • Internet Information Services (IIS) 6.0 (ou IIS 7.0)

  • SharePoint Foundation 2010

  • Windows Internet Explorer

  • Authentification Kerberos, telle qu'implémentée dans Active Directory Domain Services (AD DS) pour Windows Server 2008

  • Équilibrage de la charge réseau dans Windows Server 2008

  • Comptes d'ordinateur dans un domaine Active Directory

  • Comptes d'utilisateurs dans un domaine Active Directory

  • Sites Web IIS, leurs liaisons et leurs paramètres d'authentification

  • Identités des pools d'applications IIS pour les sites Web IIS

  • Assistant Configuration des produits SharePoint

  • Applications Web SharePoint Foundation 2010

  • Pages de l'Administration centrale

  • Noms principaux de service et leur configuration dans un domaine Active Directory

Important :
Pour créer des noms principaux de service dans un domaine Active Directory, vous devez disposer d'autorisations d'administration sur le domaine.

Cet article n'est pas une étude approfondie de l'authentification Kerberos. Kerberos est une méthode d'authentification standard du marché qui est implémentée dans AD DS.

Cet article ne fournit pas d'instructions pas à pas pour installer SharePoint Foundation 2010 ou utiliser l'Assistant Configuration des produits SharePoint.

Cet article ne fournit pas d'instructions pas à pas pour utiliser l'Administration centrale afin de créer des applications Web SharePoint Foundation 2010.

Versions de logiciels requises

Les instructions fournies dans cet article et les tests de vérification reposent sur des systèmes exécutant Windows Server 2008 et Internet Explorer avec les mises à jour les plus récentes appliquées à partir du site Windows Update (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=101614&clcid=0x40C). Les versions suivantes de logiciels ont été installées :

  • Windows Server 2008, avec les mises à jour les plus récentes du site Windows Update (éventuellement en anglais) site (http://go.microsoft.com/fwlink/?linkid=101614&clcid=0x40C)

  • Internet Explorer

  • Version finale de SharePoint Foundation 2010

Vous devez également vérifier que les contrôleurs de domaine Active Directory exécutent Windows Server 2008 avec les mises à jour les plus récentes appliquées à partir du site Windows Update (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=101614&clcid=0x40C).

Problèmes connus

SharePoint Foundation 2010 peut analyser les applications Web configurées de manière à utiliser l'authentification Kerberos si celles-ci sont hébergées sur des serveurs virtuels IIS qui sont liés à des ports par défaut (le port TCP 80 et le port SSL 443). Toutefois, SharePoint Foundation 2010 Search ne peut pas analyser les applications Web SharePoint Foundation 2010 qui sont configurées pour utiliser l'authentification Kerberos si celles-ci sont hébergées sur des serveurs virtuels IIS qui sont liés à des ports non définis par défaut (autres que le port TCP 80 ou SSL 443). Actuellement, SharePoint Foundation 2010 Search peut analyser uniquement les applications Web SharePoint Foundation 2010 hébergées sur des serveurs virtuels IIS liés à des ports non définis par défaut et qui sont configurées pour utiliser l'authentification NTLM ou l'authentification de base.

Pour l'accès des utilisateurs finaux à l'aide de l'authentification Kerberos, si vous devez déployer des applications Web qui ne peuvent être hébergées que sur des serveurs virtuels IIS qui sont liés à des ports non définis par défaut et si vous souhaitez que ces utilisateurs puissent obtenir des résultats aux requêtes de recherche, alors :

  • Les mêmes applications Web doivent être hébergées sur d'autres serveurs virtuels IIS sur des ports non définis par défaut.

  • Les applications Web doivent être configurées pour utiliser l'authentification NTLM ou l'authentification de base.

  • L'indexation de la recherche doit analyser les applications Web en utilisant l'authentification NTLM ou l'authentification de base.

Cet article fournit des instructions pour :

  • configurer l'application Web Administration centrale en utilisant l'authentification Kerberos hébergée sur un serveur virtuel IIS lié à des ports non définis par défaut ;

  • configurer les applications Portail et Mon site en utilisant l'authentification Kerberos hébergée sur des serveurs virtuels IIS liés à des ports par défaut, avec une liaison d'en-tête d'hôte IIS ;

  • vérifier que l'indexation de recherche analyse correctement les applications Web SharePoint Foundation 2010 utilisant l'authentification Kerberos ;

  • vérifier que les utilisateurs qui accèdent à des applications Web utilisant l'authentification Kerberos peuvent obtenir des résultats aux requêtes de recherche pour ces applications.

Contexte supplémentaire

Il est important de comprendre que lorsque vous utilisez l'authentification Kerberos, la précision de la fonctionnalité d'authentification dépend en partie du comportement du client qui essaie de s'authentifier à l'aide de Kerberos. Dans un déploiement de batterie de serveurs SharePoint Foundation 2010 utilisant l'authentification Kerberos, SharePoint Foundation 2010 n'est pas le client. Avant de déployer une batterie de serveurs qui exécute SharePoint Foundation 2010 avec l'authentification Kerberos, vous devez comprendre le comportement des clients suivants :

  • Navigateur (dans cet article, le navigateur est toujours Internet Explorer)

  • Microsoft .NET Framework

Le navigateur est le client utilisé pour accéder à une page Web dans une application Web SharePoint Foundation 2010. Lorsque SharePoint Foundation 2010 effectue des tâches telles que l'analyse des sources de contenu SharePoint Foundation 2010 locales, le .NET Framework fait office de client.

Pour que l'authentification Kerberos fonctionne correctement, vous devez créer des noms principaux de service dans AD DS. Si les services auxquels ces noms correspondent sont à l'écoute de ports non définis par défaut, les noms doivent inclure les numéros de port afin de garantir leur signification et d'empêcher la création de noms principaux dupliqués.

Lorsqu'un client tente d'accéder à une ressource à l'aide de l'authentification Kerberos, le client doit construire un nom principal de service pour le processus d'authentification Kerberos. Si le client ne construit pas de nom qui corresponde au nom principal de service configuré dans AD DS, l'authentification Kerberos échoue, généralement avec une erreur « Accès refusé ».

Certaines versions d'Internet Explorer ne construisent pas les noms principaux de service avec les numéros de port. Si vous utilisez des applications Web SharePoint Foundation 2010 qui sont liées à des numéros de port non définis par défaut dans IIS, il est possible que vous deviez configurer Internet Explorer afin d'inclure les numéros de port dans les noms principaux de service qu'il construit. Dans une batterie de serveurs exécutant SharePoint Foundation 2010, l'application Web Administration centrale est hébergée, par défaut, sur un serveur virtuel IIS qui est lié à un port non défini par défaut. Par conséquent, cet article aborde aussi bien les sites Web IIS liés à des ports que ceux liés à des en-têtes d'hôte.

Par défaut, dans une batterie de serveurs exécutant SharePoint Foundation 2010, le .NET Framework ne construit pas de noms principaux de service qui contiennent des numéros de port. C'est la raison pour laquelle Search ne peut pas analyser les applications Web utilisant l'authentification Kerberos si elles sont hébergées sur des serveurs virtuels IIS liés à des ports non définis par défaut.

Topologie d'une batterie de serveurs

Cet article traite de la topologie de batterie de serveurs SharePoint Foundation 2010 suivante :

  • Deux ordinateurs exécutant Windows Server 2008 qui agissent comme des serveurs Web frontaux, avec l'équilibrage de la charge réseau Windows configuré.

  • Trois ordinateurs exécutant Windows Server 2008 qui jouent le rôle de serveurs d'applications. L'un des serveurs d'applications héberge l'application Web Administration centrale. Le deuxième exécute les requêtes de recherche et le troisième exécute l'indexation de la recherche.

  • Un ordinateur exécutant Windows Server 2008 qui fait office d'hôte SQL pour la batterie de serveurs exécutant SharePoint Foundation 2010. Dans le cadre du scénario décrit dans cet article, vous pouvez utiliser Microsoft SQL Server 2008.

Services de domaine Active Directory, attribution des noms d'ordinateurs et équilibrage de la charge réseau

Le scénario décrit dans cet article utilise les conventions Active Directory et les conventions d'attribution de noms d'ordinateurs et d'équilibrage de la charge réseau suivantes :

Rôle de serveur | Nom de domaine
Services de domaine Active Directory | mydomain.net
Serveur Web frontal exécutant SharePoint Foundation 2010 | wssfe1.mydomain.net
Serveur Web frontal exécutant SharePoint Foundation 2010 | wssfe2.mydomain.net
Administration centrale de SharePoint Foundation 2010 | wssadmin.mydomain.net
Indexation de recherche exécutant SharePoint Foundation 2010 | wsscrawl.mydomain.net
Requêtes de recherche exécutant SharePoint Foundation 2010 | wssquery.mydomain.net
Hôte SQL Server exécutant SharePoint Foundation 2010 | wsssql.mydomain.net

Une adresse IP virtuelle d'équilibrage de la charge réseau est affectée à wssfe1.mydomain.net et à wssfe2.mydomain.net, suite à la configuration de l'équilibrage de la charge réseau sur ces systèmes. Un ensemble de noms d'hôtes DNS qui pointent vers cette adresse est inscrit dans votre système DNS. Par exemple, si votre adresse IP virtuelle d'équilibrage de la charge réseau est 192.168.100.200, vous disposez d'un jeu d'enregistrements DNS qui résout les noms DNS suivants avec cette adresse (192.168.100.200) :

  • kerbportal.mydomain.net

  • kerbmysite.mydomain.net

Conventions des comptes de domaine Active Directory

L'exemple de cet article utilise les conventions d'affectation de noms répertoriées dans le tableau ci-après pour les comptes de service et les identités de pools d'applications utilisés dans la batterie de serveurs exécutant SharePoint Foundation 2010.

Compte de domaine ou identité du pool d'applications Nom

Compte d'administrateur local

  • Sur tous les serveurs exécutant SharePoint Foundation 2010 (mais pas sur l'ordinateur hôte exécutant SQL Server)

  • Pour la configuration de SharePoint Foundation 2010 et pour l'utilisateur sous le nom duquel est exécuté l'Assistant Configuration des produits SharePoint

mydomain\pscexec

Compte d'administrateur local sur l'ordinateur hôte SQL Server

mydomain\sqladmin

Compte de service SQL Server utilisé pour exécuter le service SQL Server

mydomain\wsssqlsvc

Compte d'administrateur de la batterie de serveurs SharePoint Foundation 2010

mydomain\wssfarmadmin

Utilisé en tant qu'identité du pool d'applications pour l'Administration centrale et en tant que compte de service pour le service du minuteur SharePoint.

Identité du pool d'applications SharePoint Foundation 2010 pour l'application Web du site portail

mydomain\portalpool

Identité du pool d'applications SharePoint Foundation 2010 pour l'application Web Mon site

mydomain\mysitepool

Compte de service de recherche SharePoint Foundation 2010

mydomain\wsssearch

Compte d'accès au contenu de recherche SharePoint Foundation 2010

mydomain\wsscrawl

Compte de service de recherche SharePoint Foundation 2010

mydomain\wsssearch

Compte d'accès au contenu SharePoint Foundation 2010

mydomain\wsscrawl

Configuration préliminaire requise

Avant d'installer SharePoint Foundation 2010 sur les ordinateurs de votre batterie de serveurs, vérifiez que les procédures suivantes ont été effectuées :

  • Tous les serveurs utilisés dans la batterie, notamment l'hôte SQL, sont configurés avec Windows Server 2008, y compris les mises à jour les plus récentes appliquées à partir du site Windows Update (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=101614&clcid=0x40C).

  • Tous les serveurs de la batterie ont Internet Explorer (avec ses mises à jour les plus récentes) installé à partir du site Windows Update (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=101614&clcid=0x40C).

  • SQL Server 2008 est installé et s'exécute sur l'ordinateur hôte SQL. Le service SQL Server s'exécute en tant que compte mydomain\sqlsvc. Une instance par défaut de SQL Server est installée et à l'écoute sur le port TCP 1433.

  • L'utilisateur sous le nom duquel est exécuté l'Assistant Configuration des produits SharePoint a été ajouté :

    • en tant que connexion SQL sur votre hôte SQL ;

    • au rôle SQL Server DBCreators sur votre hôte SQL ;

    • au rôle Administrateurs de sécurité SQL Server sur votre hôte SQL.

Configurer l'authentification Kerberos pour les communications SQL

Configurez l'authentification Kerberos pour les communications SQL avant d'installer et de configurer SharePoint Foundation 2010 sur vos serveurs exécutant SharePoint Foundation 2010. Cette configuration est nécessaire, car l'authentification Kerberos pour les communications SQL doit être configurée et vérifiée pour que les ordinateurs exécutant SharePoint Foundation 2010 puissent se connecter à votre serveur SQL.

Le processus de configuration de l'authentification Kerberos pour tout service installé sur un ordinateur hôte exécutant Windows Server 2008 comprend la création d'un nom principal de service pour le compte de domaine utilisé pour exécuter le service sur l'hôte. Les noms principaux de service sont constitués des parties suivantes :

  • un nom de service (par exemple, MSSQLSvc ou HTTP) ;

  • un nom d'hôte (réel ou virtuel) ;

  • un numéro de port.

La liste suivante contient des exemples de noms principaux de service pour une instance par défaut de SQL Server s'exécutant sur un ordinateur nommé wsssql, à l'écoute sur le port 1433 :

  • MSSQLSvc/wsssql:1433

  • MSSQLSvc/wsssql.mydomain.com:1433

Ce sont les noms principaux de service que vous allez créer pour l'instance de SQL Server sur l'hôte SQL qui sera utilisé par la batterie de serveurs décrite dans cet article. Vous devez toujours créer des noms principaux de service qui ont à la fois un nom NetBIOS et un nom DNS complet pour un hôte de votre réseau.

Il existe différentes méthodes pour définir un nom principal de service pour un compte dans un domaine Active Directory. Une méthode consiste à utiliser l'utilitaire SETSPN.EXE qui fait partie des outils du Kit de ressources pour Windows Server 2008. Une autre méthode consiste à utiliser le composant logiciel enfichable ADSIEDIT.MSC sur votre contrôleur de domaine Active Directory. Cet article décrit l'utilisation du composant ADSIEDIT.MSC.

Vous devez effectuer deux étapes principales pour configurer l'authentification Kerberos pour SQL Server :

  • Créer des noms principaux de service pour votre compte de service SQL Server

  • Vérifier que l'authentification Kerberos est utilisée pour connecter des serveurs exécutant SharePoint Foundation 2010 à des serveurs exécutant SQL Server

Créer des noms principaux de service pour votre compte de service SQL Server

  1. Ouvrez une session sur votre contrôleur de domaine Active Directory à l'aide des informations d'identification d'un utilisateur ayant des autorisations d'administration sur le domaine.

  2. Dans la boîte de dialogue Exécuter, tapez ADSIEDIT.MSC.

  3. Dans la boîte de dialogue de la console de gestion, développez le dossier conteneur de domaine.

  4. Développez le dossier contenant les comptes d'utilisateurs, par exemple CN=Users.

  5. Recherchez le conteneur du compte de service SQL Server, par exemple CN=wsssqlsvc.

  6. Cliquez avec le bouton droit sur ce compte, puis cliquez sur Propriétés.

  7. Faites défiler la liste des propriétés dans la boîte de dialogue compte de service SQL Server jusqu'à servicePrincipalName.

  8. Sélectionnez la propriété servicePrincipalName et cliquez sur Modifier.

  9. Dans le champ Valeur à ajouter de la boîte de dialogue Éditeur de chaînes à valeurs multiples, tapez le nom principal de service MSSQLSvc/wsssql:1433, puis cliquez sur Ajouter. Ensuite, tapez le nom principal de service MSSQLSvc/wsssql.mydomain.com:1433 dans ce champ et cliquez sur Ajouter.

  10. Cliquez sur OK dans la boîte de dialogue Éditeur de chaînes à valeurs multiples, puis cliquez sur OK dans la boîte de dialogue Propriétés du compte de service SQL Server.

Vérifier que l'authentification Kerberos est utilisée pour connecter des serveurs exécutant SharePoint Foundation 2010 à SQL Server

Installez les outils clients SQL sur l'un de vos serveurs exécutant SharePoint Foundation 2010 et utilisez-les pour vous connecter depuis le serveur exécutant SharePoint Foundation 2010 aux serveurs exécutant SQL Server. Cet article n'aborde pas la procédure à suivre pour installer les outils clients SQL sur un serveur exécutant SharePoint Foundation 2010. Les procédures de vérification reposent sur les hypothèses suivantes :

  • Vous utilisez SQL Server 2008 sur votre hôte SQL.

  • Vous avez ouvert une session sur l'un de vos serveurs exécutant SharePoint Foundation 2010, à l'aide du compte mydomain\pscexec, et vous avez installé les outils clients SQL 2005 sur ce serveur SharePoint Foundation 2010.

  1. Exécutez SQL Server 2005 Management Studio.

  2. Lorsque la boîte de dialogue Connexion au serveur s'affiche, tapez le nom de l'ordinateur hôte SQL (dans cet exemple, cet ordinateur est wsssql), puis cliquez sur Connexion pour vous connecter à ce dernier.

  3. Pour vérifier que l'authentification Kerberos a été utilisée pour cette connexion, exécutez l'Observateur d'événements sur l'ordinateur hôte SQL et examinez le journal des événements de sécurité. Le journal doit contenir un enregistrement Audit des succès pour un événement de la catégorie Ouverture/Fermeture de session dont les données sont similaires à celles des tableaux suivants :

    Type d'événement

    Audit des succès

    Source de l'événement

    Sécurité

    Catégorie de l'événement

    Ouverture/Fermeture de session

    ID d'événement

    540

    Date

    31/10/2007

    Heure

    16:12:24

    Utilisateur

    MYDOMAIN\pscexec

    Ordinateur

    WSSQL

    Description

    Un exemple d'ouverture de session réseau réussie est illustré dans le tableau suivant.

    Nom de l'utilisateur

    pscexec

    Domaine

    MYDOMAIN

    ID d'ouv. de session

    (0x0,0x6F1AC9)

    Type d'ouv. de session

    3

    Processus d'ouv. de session

    Kerberos

    Nom de la station de travail

    GUID d'ouv. de session

    {36d6fbe0-2cb8-916c-4fee-4b02b0d3f0fb}

    Nom d'utilisateur de l'appelant

    Domaine de l'appelant

    ID d'ouv. de session de l'appelant

    ID du processus de l'appelant

    Services en transit

    Adresse réseau source

    192.168.100.100

    Port source

    2465

Examinez l'entrée du journal pour vérifier les points suivants :

  1. Le nom de l'utilisateur est correct. Le compte mydomain\pscexec a ouvert une session via le réseau sur l'hôte SQL.

  2. Le type d'ouverture de session est 3, ce qui correspond à une ouverture de session réseau.

  3. Le processus d'ouverture de session et le package d'authentification utilisent tous deux l'authentification Kerberos. Cela confirme que votre serveur exécutant SharePoint Foundation 2010 utilise l'authentification Kerberos pour communiquer avec l'hôte SQL.

  4. L'adresse réseau source correspond à l'adresse IP de l'ordinateur à partir duquel la connexion a été établie.

Si la connexion à l'hôte SQL échoue avec un message d'erreur du type Impossible de générer le contexte SSPI, cela signifie qu'il existe probablement un problème avec le nom principal de service utilisé pour votre instance de SQL Server. Pour diagnostiquer et corriger le problème, consultez l'article COMMENT FAIRE : Résoudre le message d'erreur « Impossible de générer un contexte SSPI » (http://go.microsoft.com/fwlink/?linkid=76621&clcid=0x40C) de la Base de connaissances Microsoft.

Créer des noms principaux de service pour vos applications Web utilisant l'authentification Kerberos

En ce qui concerne l'authentification Kerberos, il n'existe aucune particularité quant aux applications Web SharePoint Foundation 2010 basées sur IIS ; l'authentification Kerberos les traite simplement comme tout autre site Web IIS.

Ce processus nécessite une connaissance des éléments suivants :

  • Classe de service pour le nom principal de service (dans le contexte de cet article, pour les applications Web SharePoint Foundation 2010, il s'agit toujours de HTTP)

  • URL de toutes vos applications Web SharePoint Foundation 2010 qui utilisent l'authentification Kerberos

  • Partie nom d'hôte du nom principal de service (réel ou virtuel ; cet article aborde les deux)

  • Partie numéro de port du nom principal de service (le scénario décrit dans cet article utilise des applications Web SharePoint Foundation 2010 basées sur des ports IIS ou sur des en-têtes d'hôte IIS).

  • Comptes Windows Active Directory pour lesquels des noms principaux de service doivent être créés

Le tableau suivant répertorie les informations pour le scénario décrit dans cet article :

URL Compte Active Directory Nom principal de service

http://wssadmin.mydomain.net:10000

wssfarmadmin
  • HTTP/wssadmin.mydomain.net:10000

  • HTTP/wssadmin.mydomain.net:10000

http://kerbportal.mydomain.net

portalpool
  • HTTP/kerbportal.mydomain.net

  • HTTP/kerbportal

http://kerbmysite.mydomain.net

mysitepool
  • HTTP/kerbmysite.mydomain.net

  • HTTP/kerbmysite

Remarques à propos de ce tableau :

  • La première URL répertoriée ci-dessus est pour l'administration centrale : elle utilise un numéro de port. Vous n'êtes pas obligé d'utiliser le port 10000. Il s'agit juste d'un exemple utilisé tout au long de cet article pour assurer la cohérence.

  • Les deux URL suivantes concernent respectivement le site portail et le site Mon site.

Suivez les conseils ci-dessus pour créer les noms principaux de service dont vous avez besoin dans AD DS afin de prendre en charge l'authentification Kerberos pour vos applications Web SharePoint Foundation 2010. Vous devez ouvrir une session sur un contrôleur de domaine de votre environnement à l'aide d'un compte disposant d'autorisations d'administration sur le domaine. Pour créer les noms principaux de service, vous pouvez utiliser soit l'utilitaire SETSPN.EXE, soit le composant logiciel enfichable ADSIEDIT.MSC, précédemment mentionnés. Si vous utilisez ADSIEDIT.MSC, reportez-vous aux instructions fournies plus haut dans cet article pour créer les noms principaux de service. Veillez à créer des noms principaux de service corrects pour les comptes adéquats dans AD DS.

Déployer la batterie de serveurs

Le déploiement de la batterie de serveurs comprend les étapes suivantes :

  1. Configurez SharePoint Foundation 2010 sur tous les serveurs exécutant SharePoint Foundation 2010.

  2. Exécutez l'Assistant Configuration des produits SharePoint et créez une batterie de serveurs. Cette étape comprend la création d'une application Web Administration centrale SharePoint Foundation 2010 qui sera hébergée sur un serveur virtuel IIS lié à un port non défini par défaut et utilisera l'authentification Kerberos.

  3. Exécutez l'Assistant Configuration des produits SharePoint et joignez les autres serveurs à la batterie de serveurs.

  4. Configurez les services suivants sur les serveurs de votre batterie :

    • service de recherche SharePoint Foundation 2010 ;

    • indexation de recherche de SharePoint Foundation 2010 ;

    • requête de recherche de SharePoint Foundation 2010.

  5. Créez des applications Web utilisées pour le site portail et le site Mon site, utilisant l'authentification Kerberos.

  6. Créez une collection de sites à l'aide du modèle Portail de collaboration sur l'application Web du site portail.

  7. Vérifiez l'accès aux applications Web utilisant l'authentification Kerberos.

  8. Vérifiez les fonctionnalités d'indexation de recherche.

  9. Vérifiez les fonctionnalités de requête de recherche.

Installer SharePoint Foundation 2010 sur tous vos serveurs

Ce processus simple consiste à exécuter le programme d'installation de SharePoint Foundation 2010 pour installer les fichiers binaires de SharePoint Foundation 2010 sur vos serveurs exécutant SharePoint Foundation 2010. Ouvrez une session sur chacun de vos ordinateurs exécutant SharePoint Foundation 2010 à l'aide du compte mydomain\pscexec. Aucune instruction détaillée n'est fournie pour cette étape. Pour le scénario décrit dans cet article, effectuez une installation Complète de SharePoint Foundation 2010 sur tous les serveurs qui nécessitent SharePoint Foundation 2010.

Créer une batterie

Dans le cadre du scénario décrit dans cet article, commencez par exécuter l'Assistant Configuration des produits SharePoint à partir du serveur d'indexation de recherche WSSADMIN, afin que WSSADMIN héberge l'application Web Administration centrale de SharePoint Foundation 2010.

Sur le serveur nommé WSSCRAWL, une fois l'installation effectuée, une boîte de dialogue Installation terminée apparaît, dans laquelle est activée une case à cocher permettant d'exécuter l'Assistant Configuration des produits SharePoint. Laissez cette case à cocher activée et fermez cette boîte de dialogue pour exécuter l'Assistant Configuration des produits SharePoint.

Lors de l'exécution de l'Assistant Configuration des produits SharePoint sur cet ordinateur, créez une batterie de serveurs en utilisant les paramètres suivants :

  • Spécifiez le nom du serveur de bases de données (dans cet article, il s'agit du serveur appelé WSSSQL).

  • Spécifiez le nom de la base de données de configuration (vous pouvez utiliser la valeur par défaut ou attribuer le nom de votre choix).

  • Fournissez les informations du compte d'accès à la base de données (administrateur de la batterie de serveurs). Dans le scénario de cet article, il s'agit du compte mydomain\wssfarmadmin.

  • Fournissez les informations requises pour l'application Web Administration centrale de SharePoint Foundation 2010. Dans le scénario de cet article, ces informations sont les suivantes :

    • Numéro de port de l'application Web Administration centrale : 10000

    • Méthode d'authentification : Négocier

Si vous avez spécifié toutes les informations requises, l'exécution de l'Assistant Configuration des produits SharePoint doit correctement se terminer. Si c'est le cas, vérifiez que vous pouvez accéder à la page d'accueil de l'application Web Administration centrale de SharePoint Foundation 2010 en utilisant l'authentification Kerberos. Pour ce faire, procédez comme suit :

  1. Ouvrez une session sur un autre serveur qui exécute SharePoint Foundation 2010 ou sur un autre ordinateur du domaine mydomain en tant que mydomain\pscexec. Ne vérifiez pas si le comportement d'authentification Kerberos est correct directement sur l'ordinateur qui héberge l'application Web Administration centrale de SharePoint Foundation 2010. Cette opération doit être effectuée à partir d'un autre ordinateur du domaine.

  2. Démarrez Internet Explorer sur ce serveur et essayez d'accéder à l'URL suivante : http://wssadmin.mydomain.net:10000. La page d'accueil de l'Administration centrale doit s'afficher.

  3. Pour vérifier que l'authentification Kerberos a été utilisée pour accéder à l'Administration centrale, retournez sur l'ordinateur nommé WSSADMIN, lancez l'Observateur d'événements et consultez le journal de sécurité. Le journal doit contenir un enregistrement Audit des succès comportant des informations similaires à celles du tableau suivant :

    Type d'événement

    Audit des succès

    Source de l'événement

    Sécurité

    Catégorie de l'événement

    Ouverture/Fermeture de session

    ID d'événement

    540

    Date

    01/11/2007

    Heure

    14:22:20

    Utilisateur

    MYDOMAIN\pscexec

    Ordinateur

    WSSADMIN

    Description

    Un exemple d'ouverture de session réseau réussie est illustré dans le tableau suivant.

    Nom de l'utilisateur

    pscexec

    Domaine

    MYDOMAIN

    ID d'ouv. de session

    (0x0,0x1D339D3)

    Type d'ouv. de session

    3

    Processus d'ouv. de session

    Kerberos

    Package d'authentification

    Kerberos

    Nom de la station de travail

    GUID d'ouv. de session

    {fad7cb69-21f8-171b-851b-3e0dbf1bdc79}

    Nom d'utilisateur de l'appelant

    Domaine de l'appelant

    ID d'ouv. de session de l'appelant

    ID du processus de l'appelant

    Services en transit

    Adresse réseau source

    192.168.100.100

    Port source

    2505

Cet enregistrement du journal affiche le même type d'informations que l'entrée de journal précédente :

  • Vérifiez que le nom de l'utilisateur est correct ; il s'agit du compte mydomain\pscexec qui a ouvert une session via le réseau sur le serveur exécutant SharePoint Foundation 2010 qui héberge l'Administration centrale.

  • Vérifiez que le type d'ouverture de session est 3, c'est-à-dire une ouverture de session réseau.

  • Vérifiez que le processus d'ouverture de session et le package d'authentification utilisent tous deux l'authentification Kerberos. Cela confirme que l'authentification Kerberos est utilisée pour accéder à votre application Web Administration centrale.

  • Vérifiez que l'adresse réseau source correspond à l'adresse IP de l'ordinateur à partir duquel la connexion a été établie.

Si la page d'accueil Administration centrale ne s'affiche pas et qu'un message d'erreur non autorisé apparaît, cela signifie que l'authentification Kerberos a échoué. En règle générale, deux causes seulement peuvent provoquer cet échec :

  • Le nom principal de service dans AD DS n'a pas été inscrit pour le compte approprié, c'est-à-dire pour mydomain\wssfarmadmin.

  • Le nom principal de service dans AD DS ne correspond pas au nom construit par Internet Explorer ou n'est pas valide. Vous pouvez avoir omis le numéro de port dans le nom principal de service que vous avez inscrit dans AD DS. Avant de continuer, assurez-vous que ce problème est résolu et que l'Administration centrale fonctionne en utilisant l'authentification Kerberos.

Remarque :
Comme outil de diagnostic, vous pouvez utiliser un espion réseau, tel que le Moniteur réseau Microsoft, pour examiner ce qui se passe sur le réseau grâce au suivi généré durant l'accès à l'Administration centrale. Après l'échec, examinez le suivi et recherchez les paquets du protocole KerberosV5. Trouvez un paquet avec un nom principal de service construit par Internet Explorer. Si ce nom semble correct, soit le nom principal de service dans AD DS n'est pas valide, soit il a été inscrit pour un compte incorrect.

Joindre les autres serveurs à la batterie de serveurs

Maintenant que votre batterie de serveurs est créée et que vous pouvez accéder à l'Administration centrale en utilisant l'authentification Kerberos, vous devez exécuter l'Assistant Configuration des produits SharePoint et joindre les autres serveurs à la batterie.

Sur chacun des quatre autres serveurs exécutant SharePoint Foundation 2010 (wssfe1, wssfe2, wssquery et wsscrawl), l'installation de SharePoint Foundation 2010 doit être terminée et la boîte de dialogue de fin d'installation doit s'afficher avec la case à cocher Assistant Configuration des produits SharePoint activée. Laissez cette case à cocher activée et fermez la boîte de dialogue pour exécuter l'Assistant Configuration des produits SharePoint. Effectuez la procédure pour joindre chacun de ces serveurs à la batterie.

À la fin de l'exécution de l'Assistant Configuration des produits SharePoint sur chaque serveur que vous ajoutez à la batterie, vérifiez que chacun d'entre eux peut afficher l'Administration centrale qui s'exécute sur le serveur WSSADMIN. Si l'un des serveurs ne parvient pas à afficher l'Administration centrale, prenez les mesures adéquates pour résoudre le problème avant de poursuivre.

Configurer les services sur les serveurs de la batterie

Configurez les services propres à SharePoint Foundation 2010 pour qu'ils s'exécutent sur des serveurs spécifiques de la batterie exécutant SharePoint Foundation 2010, en utilisant les comptes indiqués dans les sections suivantes.

Remarque :
Cette section ne fournit pas de description détaillée de l'interface utilisateur. Seules des instructions générales sont fournies. Vous devez maîtriser l'Administration centrale et savoir effectuer les étapes nécessaires avant de poursuivre.

Accédez à l'Administration centrale, puis effectuez la procédure ci-après pour configurer les services sur les serveurs indiqués, en utilisant les comptes indiqués.

Recherche Windows SharePoint Services

Dans la page Services sur le serveur de l'Administration centrale :

  1. Sélectionnez le serveur WSSQUERY.

  2. Dans la liste des services qui s'affiche, près du milieu de la page, localisez le service de recherche SharePoint Foundation 2010, puis cliquez sur Démarrer dans la colonne Action.

  3. Dans la page suivante, indiquez les informations d'identification pour le compte du service de recherche SharePoint Foundation 2010 et pour le compte d'accès au contenu SharePoint Foundation 2010. Dans le scénario de cet article, le compte du service de recherche SharePoint Foundation 2010 est mydomain\wsssearch et le compte d'accès au contenu SharePoint Foundation 2010, mydomain\wsscrawl. Tapez les noms et les mots de passe des comptes dans les champs réservés à cet effet, puis cliquez sur Démarrer.

Serveur d'index

Dans la page Services sur le serveur de l'Administration centrale :

  1. Sélectionnez le serveur WSSCRAWL.

  2. Dans la liste des services qui s'affiche, près du milieu de la page, localisez le service de recherche SharePoint Foundation 2010, puis cliquez sur Démarrer dans la colonne Action.

Dans la page suivante, activez la case à cocher Utiliser ce serveur pour l'indexation de contenu et fournissez les informations d'identification pour le compte du service de recherche SharePoint Foundation 2010. Dans le scénario de cet article, le compte du service de recherche SharePoint Foundation 2010 est mydomain\wsssearch. Tapez les noms et les mots de passe des comptes dans les champs réservés à cet effet, puis cliquez sur Démarrer.

Serveur de requêtes

Dans la page Services sur le serveur de l'Administration centrale :

  1. Sélectionnez le serveur WSSQUERY.

  2. Dans la liste des services qui s'affiche, près du milieu de la page, localisez le service de recherche SharePoint Foundation 2010, puis cliquez sur le nom du service dans la colonne Service.

Dans la page suivante, activez la case à cocher Utiliser ce serveur pour traiter les requêtes de recherche, puis cliquez sur OK.

Créer des applications Web utilisant l'authentification Kerberos

Dans cette section, vous allez créer des applications Web utilisées pour le site portail et un site Mon site dans votre batterie de serveurs.

Remarque :
Cette section ne fournit pas de description détaillée de l'interface utilisateur. Seules des instructions générales sont fournies. Vous devez maîtriser l'Administration centrale et savoir effectuer les étapes nécessaires avant de poursuivre.

Créer l'application Web du site portail

  1. Dans la page Gestion des applications de l'Administration centrale, cliquez sur Créer ou étendre une application Web.

  2. Dans la page suivante, cliquez sur Créer une application Web.

  3. Dans la page suivante, vérifiez que Créer un nouveau site Web IIS est sélectionné.

    • Dans le champ Description, tapez SitePortail.

    • Dans le champ Port, tapez 80.

    • Dans le champ En-tête de l'hôte, tapez kerbportal.mydomain.net.

  4. Vérifiez que Négocier est sélectionné comme fournisseur d'authentification pour cette application Web.

  5. Créez cette application Web dans la zone par défaut. Ne modifiez pas la zone pour cette application Web.

  6. Vérifiez que l'option Créer un nouveau pool d'applications est activée.

    • Dans le champ Nom du pool d'applications, tapez PoolAppPortail.

    • Vérifiez que l'option Configurable est activée. Dans le champ Nom d'utilisateur, tapez le compte mydomain\portalpool.

  7. Cliquez sur OK.

  8. Vérifiez que l'application Web a été créée.

Remarque :
Si vous souhaitez utiliser une connexion SSL et lier l'application Web au port 443, tapez 443 dans le champ Port et sélectionnez Utiliser SSL dans la page Créer une application Web. Vous devez en outre installer un certificat générique SSL. Si vous utilisez une liaison d'en-tête d'hôte IIS sur un site Web IIS configuré pour SSL, vous devez utiliser un certificat générique SSL. Pour plus d'informations sur les en-têtes d'hôte SSL dans IIS, voir Configuration des en-têtes d'hôte SSL (IIS 6.0) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=111285&clcid=0x40C).

Créer l'application Web Mon site

  1. Dans la page Gestion des applications de l'Administration centrale, cliquez sur Créer ou étendre une application Web.

  2. Dans la page suivante, cliquez sur Créer une application Web.

  3. Dans la page suivante, vérifiez que Créer un nouveau site Web IIS est sélectionné.

    • Dans le champ Description, tapez MonSite.

    • Dans le champ Port, tapez 80.

    • Dans le champ En-tête de l'hôte, tapez kerbmysite.mydomain.net.

  4. Vérifiez que Négocier est sélectionné comme fournisseur d'authentification pour cette application Web.

  5. Créez cette application Web dans la zone par défaut. Ne modifiez pas la zone pour cette application Web.

  6. Vérifiez que l'option Créer un nouveau pool d'applications est activée.

    • Dans le champ Nom du pool d'applications, tapez PoolAppMonSite.

    • Vérifiez que l'option Configurable est activée. Dans le champ Nom d'utilisateur, tapez le compte mydomain\mysitepool.

  7. Cliquez sur OK.

  8. Vérifiez que l'application Web a été créée.

Remarque :
Si vous souhaitez utiliser une connexion SSL et lier l'application Web au port 443, tapez 443 dans le champ Port et sélectionnez Utiliser SSL dans la page Créer une application Web. Vous devez en outre installer un certificat générique SSL. Si vous utilisez une liaison d'en-tête d'hôte IIS sur un site Web IIS configuré pour SSL, vous devez utiliser un certificat générique SSL. Pour plus d'informations sur les en-têtes d'hôte SSL dans IIS, voir Configuration des en-têtes d'hôte SSL (IIS 6.0) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=111285&clcid=0x40C).

Créer une collection de sites à l'aide du modèle Portail de collaboration sur l'application Web du site portail

Dans cette section, vous allez créer une collection de sites sur le site portail dans l'application Web que vous avez créée à cet effet.

Remarque :
Cette section ne fournit pas de description détaillée de l'interface utilisateur. Seules des instructions générales sont fournies. Vous devez maîtriser l'Administration centrale et savoir effectuer les étapes nécessaires avant de poursuivre.

  1. Dans la page Gestion des applications de l'Administration centrale, cliquez sur Créer une collection de sites.

  2. Dans la page suivante, vérifiez que vous avez sélectionné l'application Web correcte. Pour l'exemple de cet article, sélectionnez http://kerbportal.mydomain.net.

  3. Indiquez le titre et la description que vous souhaitez utiliser pour cette collection de sites.

  4. Conservez l'adresse du site Web telle quelle.

  5. Dans la section Sélection du modèle, sous Sélectionner un modèle, cliquez sur l'onglet Publication et sélectionnez le modèle Portail de collaboration.

  6. Dans la section Administrateur principal de la collection de sites, tapez mydomain\pscexec.

  7. Spécifiez l'administrateur secondaire de la collection de sites que vous souhaitez utiliser.

  8. Cliquez sur OK.

  9. Vérifiez que la collection de sites du portail a été créée.

Vérifier l'accès aux applications Web utilisant l'authentification Kerberos

Vérifiez que l'authentification Kerberos fonctionne pour les applications Web récemment créées. Commencez par le site portail.

Pour ce faire, procédez comme suit :

  1. Ouvrez une session sur un serveur exécutant SharePoint Foundation 2010, plutôt que sur l'un des deux serveurs Web frontaux qui sont configurés pour l'équilibrage de la charge réseau, en tant que mydomain\pscexec. Ne vérifiez pas si le comportement de l'authentification Kerberos est correct directement sur l'un des ordinateurs qui hébergent les sites Web à charge équilibrée utilisant l'authentification Kerberos. Cette opération doit être effectuée à partir d'un ordinateur distinct du domaine.

  2. Démarrez Internet Explorer sur cet autre système et essayez d'accéder à l'URL suivante : http://www.mydomain.com/

La page d'accueil du site portail authentifié avec Kerberos doit s'afficher.

Pour vérifier que l'authentification Kerberos a été utilisée pour accéder au site portail, passez sur l'un des serveurs Web frontaux à charge équilibrée, lancez l'Observateur d'événements et consultez le journal de sécurité. Le journal doit contenir un enregistrement Audit des succès comportant des informations similaires à celles du tableau ci-après, sur l'un des serveurs Web frontaux. Notez que vous devrez peut-être le rechercher sur les deux serveurs Web frontaux pour le trouver, selon le système ayant traité la requête à charge équilibrée.

Type d'événement | Audit des succès
Source de l'événement | Sécurité
Catégorie de l'événement | Ouverture/Fermeture de session
ID d'événement | 540
Date | 01/11/2007
Heure | 17:08:20
Utilisateur | MYDOMAIN\pscexec
Ordinateur | wssfe1
Description |

Un exemple d'ouverture de session réseau réussie est illustré dans le tableau suivant.

Nom de l'utilisateur | pscexec
Domaine | MYDOMAIN
ID d'ouv. de session | (0x0,0x1D339D3)
Type d'ouv. de session | 3
Processus d'ouv. de session | Authentification Kerberos
Nom de la station de travail |
GUID d'ouv. de session | {fad7cb69-21f8-171b-851b-3e0dbf1bdc79}
Nom d'utilisateur de l'appelant |
Domaine de l'appelant |
ID d'ouv. de session de l'appelant |
ID du processus de l'appelant |
Services en transit |
Adresse réseau source | 192.168.100.100
Port source | 2505

Cet enregistrement du journal affiche le même type d'informations que l'entrée de journal précédente :

  • Vérifiez que le nom de l'utilisateur est correct ; il s'agit du compte mydomain\pscexec qui a ouvert une session via le réseau sur le serveur Web frontal exécutant SharePoint Foundation 2010 qui héberge le site portail.

  • Vérifiez que le type d'ouverture de session est 3, c'est-à-dire une ouverture de session réseau.

  • Vérifiez que le processus d'ouverture de session et le package d'authentification utilisent tous deux l'authentification Kerberos. Cela confirme que l'authentification Kerberos est utilisée pour accéder à votre site portail.

  • Vérifiez que l'adresse réseau source correspond à l'adresse IP de l'ordinateur à partir duquel la connexion a été établie.

Si la page d'accueil du site portail ne parvient pas à s'afficher et qu'un message d'erreur « non autorisé » apparaît, cela signifie que l'authentification Kerberos a échoué. En règle générale, deux causes seulement peuvent provoquer cet échec :

  • Le nom principal de service dans AD DS n'a pas été inscrit pour le compte approprié, c'est-à-dire pour mydomain\portalpool, pour l'application Web du site portail.

  • Le nom principal de service dans AD DS ne correspond pas au nom principal de service construit par Internet Explorer ou n'est pas valide. Dans ce cas, étant donné que vous utilisez des en-têtes d'hôte IIS sans numéros de port explicites, le nom principal de service inscrit dans AD DS diffère de l'en-tête d'hôte IIS spécifié lorsque vous avez étendu l'application Web. Vous devez corriger ce problème pour que l'authentification Kerberos puisse fonctionner.

Remarque :
Comme outil de diagnostic, vous pouvez utiliser un espion réseau, tel que le Moniteur réseau Microsoft, pour examiner ce qui se passe sur le réseau grâce au suivi généré durant l'accès à l'Administration centrale. Après l'échec, examinez le suivi et recherchez les paquets du protocole KerberosV5. Vous devez trouver un paquet avec un nom principal de service construit par Internet Explorer. Si ce nom semble correct, soit le nom principal de service dans AD DS n'est pas valide, soit il a été inscrit pour un compte incorrect.

Une fois que l'authentification Kerberos fonctionne pour votre site portail, accédez à votre site Mon site authentifié avec Kerberos, à l'aide les URL suivantes :

  • http://kerbmysite.mydomain.net

Remarque :
La première fois que vous accédez à l'URL de Mon site, SharePoint Foundation 2010 prendra du temps pour créer un site Mon site pour l'utilisateur ayant ouvert la session. Finalement, la page Mon site s'affichera pour cet utilisateur.

Cette procédure doit fonctionner. Si tel n'est pas le cas, reportez-vous aux étapes de dépannage précédentes.

Vérifier les fonctionnalités d'indexation de la recherche

Vérifiez que l'indexation de la recherche analyse correctement le contenu hébergé sur cette batterie de serveurs. Vous devez effectuer cette étape avant de vérifier les résultats des requêtes de recherche des utilisateurs qui accèdent aux sites à l'aide de l'authentification Kerberos.

Remarque :
Cette section ne fournit pas de description détaillée de l'interface utilisateur. Seules des instructions générales sont fournies. Vous devez maîtriser l'Administration centrale et savoir effectuer les étapes nécessaires avant de poursuivre.

Pour vérifier les fonctionnalités d'indexation de la recherche, accédez à une application Web et démarrez une analyse complète. Attendez la fin de l'analyse. Si l'analyse échoue, vous devez diagnostiquer le problème et le corriger, puis exécuter une analyse complète. Si l'analyse échoue avec des erreurs du type « Accès refusé », cela est dû soit au compte d'analyse qui ne peut pas accéder aux sources de contenu, soit à l'authentification Kerberos qui échoue. Quelle que soit la cause, cette erreur doit être corrigée avant de passer aux étapes suivantes.

Vous devez effectuer une analyse complète des applications Web authentifiées avec Kerberos avant de continuer.

Vérifier les fonctionnalités des requêtes de recherche

Pour vérifier que les requêtes de recherche retournent des résultats aux utilisateurs qui accèdent au site portail utilisant l'authentification Kerberos :

  1. Démarrez Internet Explorer sur un système dans mydomain.net et accédez à l'adresse http://kerbportal.mydomain.net.

  2. Lorsque la page d'accueil du site portail s'affiche, tapez un mot clé de recherche dans le champ Recherche et appuyez sur Entrée.

  3. Vérifiez que la requête de recherche retourne des résultats. Si ce n'est pas le cas, vérifiez que le mot clé que vous avez entré est valide dans votre déploiement, que l'indexation de recherche fonctionne correctement, que le service de recherche est en cours d'exécution sur votre serveur d'indexation de recherche et votre serveur de requêtes de recherche, et qu'il n'y a aucun problème avec la propagation de la recherche à partir de votre serveur d'indexation de recherche vers votre serveur de requêtes de recherche.

Limites de configuration

La partie nom d'hôte des noms principaux de service au nouveau format qui sont créés représente le nom NetBIOS de l'hôte exécutant le service, par exemple : MSSP/kerbtest4:56738/SSP1. En effet, les noms d'hôtes sont extraits de la base de données de configuration de SharePoint Foundation 2010 : seuls les noms d'ordinateurs NetBIOS sont stockés dans la base de données de configuration de SharePoint Foundation 2010. Cela peut être ambigu dans certains scénarios.

Ressources supplémentaires et conseils de résolution des problèmes

Produit/Technologie | Ressource
SQL Server | Comment s'assurer que vous utilisez l'authentification Kerberos lorsque vous créez une connexion à distance à une instance de SQL Server 2005 (http://go.microsoft.com/fwlink/?linkid=85942&clcid=0x40C)
SQL Server | COMMENT FAIRE : Résoudre le message d'erreur « Impossible de générer un contexte SSPI » (http://go.microsoft.com/fwlink/?linkid=82932&clcid=0x40C)
.NET Framework | AuthenticationManager.CustomTargetNameDictionary, propriété (http://go.microsoft.com/fwlink/?linkid=120460&clcid=0x40C)
Internet Explorer | Message d'erreur dans Internet Explorer lorsque vous essayez d'accéder à un site Web qui requiert une authentification Kerberos sur un ordinateur basé sur Windows XP : « Erreur HTTP 401 - Non autorisé : Accès refusé en raison d'informations d'identification non valides » (http://go.microsoft.com/fwlink/?linkid=120462&clcid=0x40C)
Authentification Kerberos | Référence technique de l'authentification Kerberos (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=78646&clcid=0x40C)
Authentification Kerberos | Dépannage des erreurs Kerberos (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=93730&clcid=0x40C)
Authentification Kerberos | Transition et délégation avec contraintes du protocole Kerberos (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=100941&clcid=0x40C)
IIS | Configuration des en-têtes d'hôte SSL (IIS 6.0) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=120463&clcid=0x40C)

Historique des modifications


Créer une collection de sites (SharePoint Foundation 2010)

Une collection de sites est un groupe de sites Web qui ont le même propriétaire et partagent des paramètres d'administration, par exemple des autorisations. Lorsque vous créez une collection de sites, un site de niveau supérieur est automatiquement créé dans la collection. Vous pouvez ensuite créer un ou plusieurs sous-sites sous le site de niveau supérieur.

Une collection de sites doit exister au sein d'une application Web. Vous pouvez créer une collection de sites basée sur une application Web existante, ou créer une application Web puis une collection de sites dans cette application. Pour plus d'informations, voir Créer une application Web (SharePoint Foundation 2010).

Si votre application Web est destinée à être utilisée dans le cadre d'un seul projet ou par une seule équipe, vous devez utiliser une seule collection de sites afin d'éviter la charge de traitement liée à la gestion de plusieurs sites. Toutefois, les solutions complexes ont avantage à utiliser plusieurs collections de sites, car il est plus facile d'organiser le contenu et de gérer les autorisations pour chaque collection de sites. Par exemple, étant donné qu'il n'existe pas de navigation intégrée depuis une collection de sites vers une autre, le recours à plusieurs collections de sites peut fournir une couche supplémentaire de sécurité pour le contenu de site.

SharePoint fournit des modèles de site dans les catégories suivantes : collaboration, réunions et personnalisé. Lorsque vous créez une collection de sites, vous sélectionnez le modèle correspondant à la fonction prévue pour le site. Par exemple, choisissez le modèle Espace de travail de document pour créer des documents de façon coopérative.

Avant de créer une collection de sites, vérifiez que la configuration suivante est disponible :

  • Une application Web dans laquelle créer la collection de sites.

  • Un modèle de quota, si vous envisagez de définir des valeurs spécifiant la quantité de données pouvant être stockée dans une collection de sites et la taille de stockage qui déclenche une alerte de messagerie en direction de l'administrateur de la collection de sites.

  • Un chemin d'accès générique géré personnalisé, si vous envisagez de créer la collection de sites ailleurs que sous le répertoire racine (/) ou le répertoire /sites/.

Dans cet article :

Créer une collection de sites à l'aide de l'Administration centrale

Créer une collection de sites à l'aide de Windows PowerShell

Créer une collection de sites à l'aide de l'Administration centrale

En règle générale, vous utilisez le site Web Administration centrale pour créer une collection de sites dans un déploiement autonome.

Pour créer une collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour créer une collection de sites, vous devez être membre du groupe SharePoint Administrateurs de batterie sur l'ordinateur exécutant le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Créer des collections de sites.

  3. Dans la page Créer une collection de sites, dans la section Application Web, si l'application Web dans laquelle vous souhaitez créer la collection de sites n'est pas sélectionnée, cliquez sur Modifier application Web dans le menu Application Web, puis cliquez sur l'application Web dans laquelle vous souhaitez créer la collection de sites.

  4. Dans la section Titre et description, entrez le titre et la description de la collection de sites.

  5. Dans la section Adresse du site Web, sélectionnez le chemin d'accès à utiliser pour votre URL, par exemple, un chemin d'inclusion générique comme /sites/ ou le répertoire racine (/).

    Si vous sélectionnez un chemin d'inclusion générique, vous devez également taper le nom du site à utiliser dans votre URL de site.

  6. Dans la section Sélection du modèle, dans la liste Sélectionner un modèle, sélectionnez le modèle que vous souhaitez utiliser pour le site de niveau supérieur de la collection de sites, ou cliquez sur l'onglet Personnaliser pour créer un site vide et appliquer un modèle ultérieurement.

  7. Dans la section Administrateur principal de la collection de sites, entrez le nom de l'utilisateur (sous la forme DOMAINE\nom_utilisateur) qui sera administrateur de la collection de sites.

  8. Dans la section Administrateur secondaire de la collection de sites, tapez le nom d'utilisateur de l'administrateur secondaire de la collection de sites.

    Il est recommandé de désigner un administrateur secondaire de la collection de sites afin que quelqu'un puisse gérer celle-ci en l'absence de l'administrateur principal de la collection.

  9. Si vous utilisez des quotas pour gérer le stockage des collections de sites, dans la section Modèle de quota, cliquez sur un modèle dans la liste Sélectionnez un modèle de quota.

  10. Cliquez sur OK.

Créer une collection de sites à l'aide de Windows PowerShell

Généralement, pour créer une collection de sites, vous utilisez Windows PowerShell si vous souhaitez automatiser la tâche, ce qui est souvent le cas en entreprise.

Pour créer une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire, PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    Get-SPWebTemplate
$template = Get-SPWebTemplate "STS#0"
New-SPSite -Url "<URL for the new site collection>" -OwnerAlias "<domain\user>" -Template $template

    Cet exemple récupère la liste de tous les modèles de sites disponibles, puis crée une collection de sites à l'aide du modèle Site d'équipe. Pour plus d'informations, voir New-SPSite et Get-SPWebTemplate.

    Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Déployer des personnalisations - Vue d'ensemble (SharePoint Foundation 2010)
Voir aussi

Les articles de ce chapitre expliquent comment déployer des éléments de site qui ont été personnalisés par les développeurs ou les concepteurs Web dans un environnement Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Vue d'ensemble du processus

  • Avant de commencer

  • À propos des deux types d'éléments de site personnalisables

  • Déploiement d'éléments de site développés

  • Déploiement d'éléments de site créés

Vue d'ensemble du processus

Le déploiement de personnalisations peut être relativement complexe, en raison notamment des nombreuses méthodes de déploiement disponibles dans SharePoint Foundation 2010 ; par ailleurs, les avantages liés à l'utilisation d'une méthode plutôt qu'une autre ne sont pas toujours évidents.

Vous déployez ces différents types d'éléments de site, ou artefacts, à l'aide de différentes méthodes. Vous ne pouvez pas déployer la gamme complète des éléments de site personnalisables avec une seule méthode de déploiement. D'autres considérations uniques en matière de déploiement s'appliquent à chaque type d'élément, car ces derniers proviennent généralement de différents groupes de concepteurs et font appel à des concepts de mise à niveau différents. Les différents types d'éléments de site sont décrits dans À propos des deux types d'éléments de site personnalisables, plus loin dans cet article.

Pour plus d'informations sur les tâches de déploiement spécifiques et les considérations qui s'y rapportent, voir les articles suivants :

  • Déployer des packages de solution (SharePoint Foundation 2010)

  • Déployer des éléments de site créés (SharePoint Foundation 2010)

  • Déployer des éléments de sites à l'aide de composants fonctionnels (SharePoint Foundation 2010)

  • Déployer des modèles (SharePoint Foundation 2010)

  • Processus de déploiement de flux de travail (SharePoint Foundation 2010)

Avant de commencer

Avant de déployer du code personnalisé dans l'environnement, vous devez définir une ligne de base pour les performances de l'environnement afin de pouvoir analyser la manière dont les personnalisations affectent les performances. Une fois que vous avez défini une ligne de base pour les performances, testez soigneusement le code personnalisé dans le cadre d'un environnement de test ou d'intégration, puis comparez les résultats à la ligne de base. Veillez à tester soigneusement toutes les personnalisations avant de les déployer dans l'environnement de production.

Vous devez également tester le code provenant de tiers avant de le déployer dans l'environnement de production, même s'il provient d'une source approuvée.

Les descriptions et conseils fournis dans ces articles s'appliquent à un environnement SharePoint Foundation déployé et configuré pour répondre aux exigences décrites dans Planification de batterie de serveurs et de l'environnement (SharePoint Foundation 2010).

À propos des deux types d'éléments de site personnalisables

Les éléments de site développés sont des artefacts de solution et sont généralement créés par les développeurs. Une solution peut inclure des assemblys, qui sont des composants SharePoint écrits dans des langages basés sur Microsoft .NET Framework et compilés avant d'être déployés. En règle générale, les éléments de site développés, à l'exception des assemblys de travaux du minuteur et des définitions de site, sont regroupés en fonctionnalités et déployés dans le cadre d'un package de solution. Les éléments de site développés rassemblent ce qui suit :

  • Composants WebPart

  • Flux de travail

  • Définitions de site et de liste

  • Convertisseurs de documents

  • Récepteurs d'événements

  • Travaux du minuteur

  • Assemblys

Les éléments de site créés, qui sont généralement créés par les concepteurs Web, ne sont pas explicitement compilés et résident dans une base de données de contenu. Les éléments de site créés rassemblent ce qui suit :

  • Pages maîtres

  • Feuilles de style en cascade

  • Formulaires

  • Pages de disposition

Ces deux types d'éléments de site personnalisables sont différenciés via les critères suivants :

  • emplacement où les fichiers sont stockés dans une batterie de serveurs SharePoint Foundation 2010 ;

  • équipe de l'organisation chargée de l'administration de l'élément de site ;

  • mécanisme de déploiement dont a besoin l'élément de site.

Certains éléments peuvent être des artefacts de solution ou des artefacts créés. Par exemple, un type de contenu peut être défini dans un fichier XML sous forme d'artefact de solution développé, ou être créé via un navigateur en tant qu'artefact créé. Les éléments de site susceptibles d'être des artefacts de solution ou des artefacts créés rassemblent les colonnes de site et les instances de listes. En outre, les artefacts de solution peuvent être utilisés pour mettre en service des fichiers dans des sites Web et être mis en cache en mémoire sur le serveur Web frontal.

Déploiement d'éléments de site développés

Les éléments de site développés peuvent généralement être définis comme des éléments de site créés dans un environnement de développement de code et déployés directement sur des serveurs Web et des serveurs d'applications frontaux. En règle générale, ces éléments de site sont personnalisés par des développeurs à l'aide de Microsoft Visual Studio 2010 Tools pour SharePoint 2010, Microsoft Office SharePoint Designer ou les outils d'édition XML. Pour plus d'informations, voir Outils de développement SharePoint Foundation (http://go.microsoft.com/fwlink/?linkid=183360&clcid=0x40C).

Remarque :
Cet article ne traite pas du déploiement des éléments de site développés qui sont déployés en tant que solutions en mode bac à sable. Ces dernières sont des solutions qui peuvent accéder à un sous-ensemble du modèle objet serveur et à un sous-ensemble des éléments de fonctionnalités que les administrateurs de collection de sites peuvent déployer. Pour plus d'informations, voir Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010).

Il est recommandé d'utiliser des packages de solution et Windows PowerShell pour déployer les éléments de site développés. La structure de solution SharePoint Foundation simplifie et normalise le processus de déploiement des éléments de site nouveaux ou mis à niveau dans la batterie de serveurs, ainsi que la synchronisation d'un serveur Web frontal de sorte que son état soit cohérent par rapport à l'état des autres serveurs de la batterie. Par exemple, les packages de solution simplifient le processus de reconstruction d'une batterie de serveurs. Le déploiement d'éléments de site par la gestion manuelle du code et des fichiers peut mener à des incohérences dans le processus de mise à niveau et entraîner une désynchronisation des serveurs par rapport à d'autres serveurs. Les packages de solution vous permettent de déployer des éléments de site développés à partir des environnements de développement vers des batteries de serveurs d'intégration, puis vers des batteries de serveurs intermédiaires, pilotes et de production.

Vous pouvez utiliser des applets de commande Windows PowerShell pour créer, importer, exporter et mettre en service des packages de solution, qui tirent parti de la structure de solution pour distribuer les personnalisations d'éléments de site développés. Les applets de commande Windows PowerShell sont utiles pour le déploiement des personnalisations de site dans la plupart des environnements, car elles sont incluses dans SharePoint Server 2010 et SharePoint Foundation 2010 ; par ailleurs, vous pouvez les utiliser de manière autonome ou conjointement avec d'autres méthodes. Les applets de commande Windows PowerShell vous permettent de déployer à la fois des artefacts et des éléments de site développés. Vous pouvez également utiliser les applets de commande pour activer des fonctionnalités déployées dans un package de solution.

Déploiement d'éléments de site créés

Les éléments de site créés se distinguent des éléments de site développés, car ils sont stockés dans la base de données de contenu, bien qu'ils puissent dépendre de ressources présentes dans le système de fichiers des serveurs Web ou (moins fréquemment) des serveurs d'applications. Dans certains cas, les éléments de site créés ne fonctionnent pas, car ils nécessitent que les éléments de site développés soient déployés en premier.

Dans des environnements où les déploiements de personnalisation sont entièrement automatisés, l'ordre de déploiement requis peut être appliqué par le système afin d'éliminer les problèmes de synchronisation. Toutefois, si le déploiement de personnalisation est partiellement ou totalement manuel, vous devez vous assurer que toutes les ressources nécessaires sont en place sur les serveurs Web et les serveurs d'applications avant de déployer du contenu basé sur ces ressources.

Vous déployez les éléments de site créés à partir d'environnements de création vers des batteries de serveurs intermédiaires, pilotes et de production en utilisant un ou plusieurs des différents systèmes possibles. Le tableau suivant décrit ces systèmes et leurs interfaces et les scénarios d'utilisation.

Système de déploiement Scénario d'utilisation

Site Web d'administration centrale de SharePoint

Dans des environnements où les batteries de serveurs source et de destination sont connectées par un réseau, vous pouvez utiliser les fonctionnalités de déploiement de contenu de l'administration centrale pour créer un package de déploiement de contenu sur la batterie de serveurs source et l'exporter vers une autre batterie de serveurs.

Cette méthode est facile à configurer et à utiliser, et peut servir à automatiser le déploiement des éléments de site créés, avec peu de temps de configuration et de maintenance.

Modèle objet de migration de contenu

En fonction de la méthode que vous utilisez (programmation à l'aide d'API d'espace de noms de déploiement, à l'aide d'appels SOAP (Simple Object Access Protocol) à un service Web ou déplacement d'un site entier à l'aide d'applets de commande Windows PowerShell), vous pouvez contrôler le contenu migré et son mode de migration. L'utilisation de l'API pour importer et exporter le contenu est la seule méthode prise en charge qui préserve les identificateurs globaux uniques (GUID).

Pour plus d'informations, voir Migration de contenu (http://go.microsoft.com/fwlink/?linkid=183372&clcid=0x40C).

Windows PowerShell

Vous pouvez utiliser les applets de commande Windows PowerShell pour effectuer des opérations d'importation et d'exportation sur un site entier, en préservant les horodatages, les informations de sécurité et les informations des utilisateurs. Les applets de commande Windows PowerShell sont essentiellement utiles lorsque vous souhaitez déplacer le contenu de base d'un site Web tout entier.

Windows PowerShell est utile pour le déploiement de personnalisations de site dans la plupart des environnements, car il est inclus dans Produits SharePoint 2010 ; par ailleurs, vous pouvez l'utiliser de manière autonome ou conjointement avec d'autres méthodes. Les applets de commande Windows PowerShell vous permettent de déployer à la fois des artefacts et des éléments de site développés.

Pour plus d'informations, voir Administration des produits SharePoint 2010 à l'aide de Windows PowerShell.

Service Web personnalisé

Vous pouvez créer un service Web personnalisé qui automatise la migration de contenu et le déploiement. Vous pouvez écrire des applications Windows et des scripts personnalisés pour exécuter des tâches spécifiques dans le cadre de ce processus.

Pour plus d'informations sur les méthodes de programmation relatives à l'écriture d'un service Web personnalisé, voir les ressources suivantes dans le kit de développement logiciel (SDK) de Microsoft SharePoint 2010 :

  • Méthodes liées aux sites (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183373&clcid=0x40C)

  • Sites.ExportWeb, méthode (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183377&clcid=0x40C)

  • Sites.ImportWeb, méthode (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183378&clcid=0x40C)

Gestion manuelle du code

Dans des environnements déconnectés plus petits, ou dans des environnements dans lesquels les éléments de site créés ne sont pas personnalisés, vous pouvez déployer manuellement des éléments de site et les ressources apparentées. Dans des environnements connectés plus petits, pensez à utiliser les fonctionnalités de déploiement de contenu de l'administration centrale pour déployer les personnalisations d'éléments de site créés.

Packages de solution et fonctionnalités

Les éléments tels que les mises en page, pages maîtres, formulaires et feuilles de style peuvent être regroupés et déployés en tant que fonctionnalités dans le cadre d'un package de solution. Les fonctionnalités déployées à partir d'un package de solution peuvent être activées pour les étendues où les éléments créés doivent être mis en service.

Pour plus d'informations, voir Déployer des éléments de sites à l'aide de composants fonctionnels (SharePoint Foundation 2010).

Modèles personnalisés

Un utilisateur peut enregistrer un site existant, avec ou sans son contenu spécifique, en tant que modèle personnalisé. Cela permet de réutiliser les sites personnalisés. Un modèle de site personnalisé est stocké en tant que fichier .wsp. Les modèles de sites sont enregistrés dans la galerie de solutions du site de niveau supérieur d'une collection de sites, où ils sont disponibles pour la création de sous-sites de l'ensemble des sites Web de la collection de sites. Les modèles de sites peuvent être téléchargés et déplacés vers d'autres galeries de collections de sites.

Voir aussi

Concepts

Déployer des packages de solution (SharePoint Foundation 2010)
Déployer des éléments de site créés (SharePoint Foundation 2010)
Déployer des éléments de sites à l'aide de composants fonctionnels (SharePoint Foundation 2010)
Déployer des modèles (SharePoint Foundation 2010)

Historique des modifications


Déployer des packages de solution (SharePoint Foundation 2010)

Cet article décrit les packages de solution et le rôle qu'ils jouent dans le déploiement de personnalisations créées et développées dans Microsoft SharePoint Foundation 2010. Il inclut des procédures pour importer et déployer des packages de solution et un exemple pour construire et déployer un package de solution à l'aide de Microsoft Visual Studio 2010.

Dans cet article :

  • Qu'est-ce qu'un package de solution ?

  • Déploiement d'éléments de sites en utilisant des packages de solution

  • Création et déploiement d'un package de solution de composant WebPart personnalisé à l'aide de Visual Studio 2010

Qu'est-ce qu'un package de solution ?

Un package de solution est un package de distribution qui transmet vos développements SharePoint Foundation 2010 personnalisés aux serveurs Web ou aux serveurs d'applications de votre batterie de serveurs. Utilisez des solutions pour empaqueter et déployer des fonctionnalités, des définitions de site, des modèles, des pages de disposition, des composants WebPart, des feuilles de style en cascade et des assemblys personnalisés.

Cet article n'aborde pas le déploiement des solutions en bac à sable. Vous pouvez déployer une solution Microsoft SharePoint Foundation 2010 directement sur votre batterie de serveurs SharePoint Foundation ou dans un bac à sable. Un bac à sable est un environnement d'exécution restreint qui permet aux programmes d'accéder à certaines ressources uniquement et qui empêche les problèmes survenant dans le bac à sable d'affecter le reste de l'environnement serveur. Pour plus d'informations, voir Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010).

Un package de solution est un fichier CAB, dont le nom de fichier porte l'extension .wsp, et un fichier manifeste. Il est recommandé d'utiliser les outils Visual Studio 2010 pour SharePoint 2010 pour développer et empaqueter des solutions SharePoint. Vous pouvez également créer manuellement des packages de solution à l'aide d'outils tels que Makecab.exe et SharePoint Packman.

Composants pouvant être empaquetés dans une solution :

  • Assemblys .NET Framework, généralement des assemblys de composants WebPart et des assemblys récepteurs d'événements.

  • Fichiers de déploiement tels que fichiers de ressources, pages ou fichiers d'aide.

  • Fonctionnalités, qui permettent d'activer ou de désactiver du code dans un site Web et fournissent des fonctionnalités incluant des éléments tels que listes personnalisées, bibliothèques, champs et types de contenu.

  • Nouveaux modèles et nouvelles définitions de site.

  • Configurations qui doivent être effectuées au niveau du serveur Web, par exemple, les fichiers Web.config pour l'inscription des composants WebPart. Vous pouvez également modifier ces configurations avec une fonction qui est distribuée avec une fonctionnalité.

  • Contenu Web tel que pages Web et images qui sont appelées par les pages Web. Si vous devez déployer le contenu Web dans un environnement déconnecté, vous devez utiliser un package de déploiement de contenu.

Déploiement d'éléments de sites en utilisant des packages de solution

Dans cette section :

  • Quand utiliser des packages de solution ?

  • Déploiement de solutions de batterie de serveurs

  • Ajout d'un package de solution

  • Déploiement d'un package de solution

  • À propos de la création d'un package de solution

Quand utiliser des packages de solution ?

Pour le déploiement des personnalisations, il est recommandé d'utiliser des packages de solution dans le cadre d'un processus de gestion du cycle de vie des applications simple, sécurisé et homogène. Les packages de solution facilitent la modification des fonctionnalités et des caractéristiques des sites Web après la création de ces derniers.

Vous pouvez utiliser les packages de solution pour déployer de nouvelles solutions ou pour mettre à niveau des solutions existantes sur la batterie de serveurs. Vous pouvez empaqueter toutes vos entités SharePoint Foundation en un seul fichier, ajouter ce fichier dans le magasin de solutions et le déployer sur les serveurs Web frontaux de la batterie. Les packages de solution permettent de synchroniser un serveur Web frontal afin que son état soit cohérent avec celui des autres serveurs Web de la batterie.

Les packages de solution vous permettent de déployer des personnalisations d'éléments de site créées à partir d'une batterie de serveurs d'intégration vers une batterie de serveurs de création, pilote ou de production. Dans SharePoint Foundation, les utilisateurs peuvent enregistrer un site personnalisé sous la forme d'un modèle. Cette option crée un package de solution avec une extension de nom de fichier .wsp, qui peut être déployée sur une autre batterie de serveurs.

Vous pouvez utiliser des packages de solution pour déployer des personnalisations entre ces environnements :

  • À partir de stations de travail de développeurs, vers une batterie de serveurs d'intégration ou un système de gestion de configuration logicielle

  • À partir d'une batterie de serveurs d'intégration et de stations de travail clientes de création, vers une batterie de serveurs pilote ou de production

Déploiement de solutions de batterie de serveurs

Les solutions de batterie de serveurs sont déployées localement ou à l'aide d'un service du minuteur. Les déploiements locaux ou basés sur le minuteur peuvent être déclenchés soit par des instructions de ligne de commande, soit par programmation du modèle objet.

Déploiement local

Dans un déploiement local, les fichiers de solution sont déployés uniquement sur l'ordinateur à partir duquel l'opération de déploiement a été lancée. La solution n'est pas marquée comme « déployée » dans la base de données de configuration tant que les fichiers de solution ne sont pas déployés sur tous les serveurs applicables de la batterie de serveurs. Ensuite, les fonctionnalités de la solution sont installées et les fichiers de schéma et de définition sont consignés dans le magasin de configuration.

Déploiements par service du minuteur

Dans les déploiements qui utilisent le service du minuteur, le déploiement crée un travail de minuteur. Ce travail de minuteur est sélectionné par le service du minuteur sur chaque serveur Web de la batterie de serveurs. Initialement, le manifeste et les manifestes de fonctionnalité sont analysés pour rechercher les fichiers d'assembly et _layouts, qui sont copiés vers les emplacements appropriés. Tous les autres fichiers contenus dans un répertoire de fonctionnalité sont copiés dans le répertoire approprié. Une fois que les fichiers de solution sont copiés vers les ordinateurs cibles, une réinitialisation de la configuration est planifiée pour tous les serveurs Web frontaux. Puis les fonctionnalités de la solution sont inscrites et les fichiers de schéma et de définition sont consignés dans le magasin de configuration.

Pour plus d'informations sur le magasin de solutions, le déploiement et la synchronisation, voir Déploiement d'une solution (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=186995&clcid=0x40C) dans le Kit de développement logiciel SDK de Microsoft SharePoint 2010.

Ajout d'un package de solution

Avant de déployer un package de solution, vous devez l'ajouter à la base de données de solution d'une batterie de serveurs SharePoint Foundation.

Important :
Vous devez être membre du groupe Administrateurs sur un ordinateur exécutant Windows PowerShell.

Pour importer un package de solution à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Add-SPSolution -LiteralPath <SolutionPath>

La solution est ajoutée au magasin de solutions de la batterie de serveurs. Pour utiliser la solution, suivez la procédure de la section suivante de cet article. Pour plus d'informations, voir Add-SPSolution.

Déploiement d'un package de solution

Vous pouvez déployer des solutions importées en utilisant le site Web Administration centrale ou Windows PowerShell. Après qu'une solution a été ajoutée au magasin de solutions à l'aide de l'applet de commande Windows PowerShellAdd-SPSolution, elle doit être déployée sur un site pour devenir accessible.

Remarque :
Vous ne pouvez pas ajouter une solution au magasin de solutions à l'aide de la page Gestion des solutions de l'Administration centrale.

Les procédures suivantes montrent comment déployer une solution importée sur un site dans la batterie de serveurs à l'aide du site Web Administration centrale ou de Windows PowerShell.

Pour déployer une solution à l'aide de l'Administration centrale

  1. Dans la page d'accueil de l'Administration centrale, cliquez sur Paramètres système.

  2. Dans la section Gestion de la batterie, cliquez sur Gérer les solutions de la batterie.

  3. Dans la page Gestion des solutions, cliquez sur la solution que vous souhaitez déployer.

  4. Dans la page Propriétés de la solution, cliquez sur Déployer la solution.

  5. Dans la page Déployer la solution, dans la section Déployer quand ?, sélectionnez l'une des options suivantes :

    • Maintenant

    • À une heure spécifiée. Si vous sélectionnez cette option, spécifiez une heure dans les zones de date et d'heure. Choisissez de préférence une heure à laquelle la charge est faible sur les serveurs de destination.

  6. Dans la section Destination du déploiement, dans la liste Application Web spécifique, cliquez sur Toutes les applications Web ou sélectionnez une application Web spécifique.

  7. Cliquez sur OK.

Pour déployer un package de solution pour une seule application Web à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Install-SPSolution -Identity <SolutionName> -WebApplication <URLname>

    Où :

    • <SolutionName> est le nom de la solution.

    • <URLname> est l'URL de l'application Web à laquelle vous souhaitez déployer la solution importée.

    Par défaut, la solution est déployée immédiatement. Vous pouvez également planifier le déploiement à l'aide du paramètre time. Pour plus d'informations, voir Install-SPSolution.

Pour déployer un package de solution pour toutes les applications Web à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Install-SPSolution -Identity <SolutionName> -AllWebApplications -time <TimeToDeploy> -GACDeployment -CASPolicies

    Où :

    • GACDeployment est le paramètre qui permet à SharePoint Foundation 2010 de déployer les assemblys dans le GAC (Global Assembly Cache).

    • CASPolicies permet la création d'un fichier de stratégie de sécurité d'accès du code et son activation dans le fichier Web.config de la collection de sites ciblée.

    Par défaut, la solution est déployée immédiatement, mais vous pouvez également planifier son déploiement au moyen du paramètre time.

À propos de la création d'un package de solution

SharePoint Foundation 2010 n'inclut pas d'outil permettant de créer des packages de solution. Cette section décrit les méthodes de création des packages de solution contenant des éléments de sites développés et des artefacts.

Visual Studio 2010

Vous pouvez utiliser Visual Studio 2010 pour grouper des éléments SharePoint connexes en une fonctionnalité, puis empaqueter plusieurs fonctionnalités, définitions de site, assemblys et autres fichiers dans un package unique (fichier .wsp) afin de les déployer sur des serveurs SharePoint Foundation 2010. Vous pouvez utiliser Visual Studio 2010 pour déboguer et tester le fichier .wsp sur le serveur SharePoint Foundation 2010 sur l'ordinateur de développement. Vous pouvez également personnaliser les étapes de déploiement sur l'ordinateur de développement.

Les développeurs peuvent créer leurs solutions SharePoint dans Visual Studio 2010 et produire des fichiers .wsp à l'aide du processus de génération automatisée. Le code source du projet Visual Studio SharePoint qui est utilisé pour générer le fichier .wsp peut également être ajouté au système de contrôle de code source en utilisant l'intégration Visual Studio 2010. Visual Studio 2010 peut importer des fichiers .wsp et créer des projets pour les étendre davantage et créer de nouveaux fichiers .wsp. La source principale des fichiers .wsp qui sont importés dans Visual Studio 2010 provient des modèles enregistrés à l'aide de la commande Enregistrer comme modèle à partir des sites SharePoint Foundation 2010. Ces modèles peuvent être utilisés pour enregistrer la totalité des personnalisations du site dans une solution SharePoint.

Pour plus d'informations, voir Développement SharePoint dans Visual Studio (http://go.microsoft.com/fwlink/?linkid=187000&clcid=0x40C).

Makecab

Les packages de solutions peuvent être créés manuellement à l'aide d'outils tels que Makecab.exe. L'outil Makecab.exe accepte un pointeur vers un fichier .ddf, qui décrit la structure du fichier CAB. Le format d'un fichier .ddf est similaire à celui d'un fichier .inf, c'est-à-dire que vous déclarez un en-tête standard puis énumérez, en citant un fichier par ligne, l'ensemble des fichiers en fonction de leur emplacement sur le disque et de leur emplacement dans le fichier CAB.

Il est possible de télécharger l'outil Makecab.exe à partir du Kit de développement logiciel (SDK) Microsoft Cabinet (http://go.microsoft.com/fwlink/?linkid=107292&clcid=0x40C).

À propos de la personnalisation des packages de solution

Si vous avez besoin d'apporter les personnalisations suivantes à des solutions SharePoint Foundation 2010, il est recommandé d'utiliser Visual Studio 2010 pour personnaliser les packages de solution. Vous pouvez également effectuer ces personnalisations en créant manuellement les packages de solution SharePoint.

  • Déployer des assemblys .NET Framework dans le dossier d'application privé au lieu de les déployer dans le Global Assembly Cache.

  • Ajouter des autorisations de sécurité d'accès du code pour la solution à appliquer au cours du déploiement.

  • Modifier les noms utilisés par défaut pour les dossiers des fonctionnalités.

  • Localiser la solution.

  • Associer des gestionnaires d'événements de fonctionnalité à certains types de solutions SharePoint Foundation 2010, telles que les solutions de composants WebPart.

  • Ajouter des ressources (fichiers XML, images, fichiers .dll et assemblys) au package de solution.

Créer manuellement un fichier de solution

Dans la plupart des scénarios de développement SharePoint Foundation 2010, nous vous recommandons d'utiliser les outils Visual Studio 2010 pour SharePoint 2010 pour développer et empaqueter les solutions SharePoint. Dans Visual Studio 2010, le processus de déploiement copie le fichier .wsp sur le serveur exécutant SharePoint Foundation 2010, installe la solution, puis active les fonctionnalités.

Vous pouvez aussi créer manuellement un fichier de solution. Voici les principales étapes de la création d'un fichier de solution :

  1. Rassemblez tous les fichiers de solution dans un dossier. Il n'existe pas de consigne particulière pour cette opération, mais il est conseillé de séparer les différents types de fichiers de solution et de les placer dans des sous-dossiers qui leur sont propres.

  2. Créez un fichier manifest.xml qui liste les composants de la solution.

  3. Créez un fichier .ddf qui définit la structure du fichier de solution. Ce fichier contient la liste des fichiers de solution, qui détermine le fichier de sortie .wsp.

  4. Exécutez Makecab.exe avec le fichier .ddf en entrée et le fichier .wsp en sortie.

À propos du fichier manifeste de la solution

Le fichier manifeste de la solution (toujours nommé manifest.xml) est stocké à la racine du fichier de solution. Ce fichier définit la liste des fonctionnalités, des définitions de sites, des fichiers de ressources, des fichiers de composants WebPart et des assemblys à traiter. Il ne définit pas la structure du fichier — si les fichiers sont inclus dans une solution mais qu'ils ne sont pas listés dans le fichier manifest.xml, ils ne sont pas traités.

L'exemple qui suit montre la structure d'un fichier manifest.xml au format XML.

<?xml version="1.0" encoding="utf-8" ?>

<Solution xmlns="http://schemas.microsoft.com/sharepoint/"

SolutionId="{79d1a62e-3627-11db-963e-00e08161165f}"

ResetWebServer="TRUE">

    <Assemblies>

        <Assembly DeploymentTarget="GlobalAssemblyCache"

Location="Example.Sharepoint.Webparts\

Example.SharePoint.WebParts.dll">

            <SafeControls>

                <SafeControl Assembly="Example.Sharepoint.Webparts,

Version=1.0.0.0, Culture=Neutral, PublicKeyToken=63cce650e8605f5d"

Namespace="Example.Sharepoint.Webparts" TypeName="*"/>

            </SafeControls>

        </Assembly>

        <Assembly DeploymentTarget="GlobalAssemblyCache"

Location="Example.Sharepoint.Timer/Example.Sharepoint.Timer.dll"/>

    </Assemblies>

    <FeatureManifests>

        <FeatureManifest Location="Example.Sharepoint.Timer\Feature.xml"/>

        <FeatureManifest Location="Example.CustomType\Feature.xml"/>

        <FeatureManifest Location="Example.ExampleLibrary\Feature.xml"/>

        <FeatureManifest Location="Example.Columns\Feature.xml"/>

        <FeatureManifest Location="Example.Workflow.ProcessExample\Feature.xml"/>

        <FeatureManifest Location="Example.Workflow.ProvisionExample\Feature.xml"/>

    </FeatureManifests>

    <SiteDefinitionManifests>

        <SiteDefinitionManifest Location="EXAMPLE">

            <WebTempFile Location="1033\XML\WEBTEMPExample.XML"/>

        </SiteDefinitionManifest>

    </SiteDefinitionManifests>

</Solution>

Par ailleurs, vous pouvez ajouter un élément DwpFiles pour spécifier des fichiers .webpart ou .dwp, ou un élément ResourceFiles pour spécifier des fichiers de ressources, des définitions de site, des ressources d'application et des stratégies de sécurité d'accès du code.

Annotez éventuellement vos fichiers Feature.xml avec des balises <ElementFile>.

Si votre solution contient des fonctionnalités, dans la balise <ElementManifests> de votre fichier Feature.XML, ajoutez <ElementFile Location="..."/> pour tous les fichiers supplémentaires de votre fonctionnalité, comme les pages ASP.NET (par exemple, allitems.aspx) ou les pages maîtres, etc.

Pour plus d'informations sur les fichiers manifeste de la solution qui définissent les éléments constitutifs de celle-ci, voir Schéma de la solution (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183466&clcid=0x40C).

Création et déploiement d'un package de solution de composant WebPart personnalisé à l'aide de Visual Studio 2010

Pour un exemple qui montre comment utiliser Visual Studio 2010 pour créer, personnaliser, déboguer et déployer une définition de liste SharePoint pour le suivi des tâches de projet, voir Procédure pas à pas : déploiement d'une définition de liste de tâches de projet (http://go.microsoft.com/fwlink/?LinkId=189612&clcid=0x40C) dans la bibliothèque MSDN.

Cette procédure pas à pas illustre les tâches suivantes :

  • Création d'un projet de définition de liste SharePoint qui contient des tâches.

  • Ajout de la définition de liste à une fonctionnalité SharePoint.

  • Ajout d'un récepteur d'événements à la liste.

  • Création et personnalisation d'un package SharePoint pour déployer votre fonctionnalité.

  • Génération et déploiement de votre solution SharePoint.

Lorsque vous générez l'exemple de projet décrit dans cette procédure, Visual Studio 2010 déploie automatiquement la solution sur le serveur SharePoint Foundation 2010 sur votre ordinateur de développement à des fins de test et de débogage. Vous pouvez également créer un fichier de package de solution qui peut être ajouté et déployé sur un autre ordinateur. Pour plus d'informations, voir Comment : déployer une solution SharePoint (http://go.microsoft.com/fwlink/?linkid=187004&clcid=0x40C). Vous pouvez utiliser l'applet de commande Add-SPSolutionWindows PowerShell pour importer la solution sur un autre ordinateur.

Vous pouvez utiliser la page Gestion des solutions dans l'Administration centrale pour déployer le package de solution. Ou bien, vous pouvez utiliser l'applet de commande Install-SPSolutionWindows PowerShell pour déployer le package de solution.

Dans la procédure pas à pas, la portée de la fonctionnalité de liste du projet est Web. Pour activer la fonctionnalité sur le site Web, développez le menu Actions du site, puis cliquez sur Paramètres du site. Sous Actions du site, cliquez sur Gérer les fonctionnalités du site. Dans la page Fonctionnalités, à côté du nom de la fonctionnalité, cliquez sur Activer.

Historique des modifications


Déployer des éléments de site créés (SharePoint Foundation 2010)

Cet article décrit le déploiement des personnalisations d'éléments de site créés dans Microsoft SharePoint Foundation 2010, notamment des procédures de déploiement, des considérations d'ordre général, ainsi que les meilleures pratiques concernant le déploiement du contenu personnalisé.

Dans cet article :

  • À propos du déploiement d'éléments de site créés

  • Avant de commencer

  • Déployer le contenu à l'aide de l'API de migration de contenu

  • Créer un package de déploiement de contenu à l'aide de Windows PowerShell

À propos du déploiement d'éléments de site créés

Les éléments de site créés correspondent en fait au « contenu » dans vos sites. Il s'agit des pages Web, des images, des pages de disposition, des feuilles de style en cascade et d'autres ressources qui composent votre site Web SharePoint Foundation 2010. Les éléments de site créés sont les suivants :

  • Artefacts Il s'agit des éléments de site, généralement conçus à l'aide d'un outil tel que Microsoft SharePoint Designer 2010, qui composent la structure dans laquelle le contenu de votre site apparaît. Parmi les exemples d'artefacts, citons les pages maîtres et les mises en page.

  • Contenu Web Il s'agit des éléments de site, généralement créés directement dans le navigateur Web ou dans un programme de création client tel que Word 2010, qui fournissent le contenu de votre site. Parmi les exemples de contenu Web, citons les pages Web et les images.

Cet article ne couvre pas le déploiement des éléments de site développés tels que les composants WebPart et d'autres éléments de code. Pour plus d'informations, voir Déployer des packages de solution (SharePoint Foundation 2010) et Déployer des éléments de sites à l'aide de composants fonctionnels (SharePoint Foundation 2010).

Les éléments de site créés peuvent être déployés selon différentes méthodes :

  • Utilisez le modèle objet pour gérer des scénarios tels que l'écriture de scripts pour automatiser des tâches courantes et la définition de propriétés personnalisées pour des opérations d'exportation et d'importation adaptées au déploiement. Le modèle objet vous offre le plus de contrôle sur vos scénarios de migration de données.

  • Les packages de déploiement de contenu sont conçus pour un déplacement ou une migration unique de contenu dans une collection de sites de destination. Les packages de déploiement de contenu sont des fichiers CAB qui contiennent une partie ou l'ensemble des éléments de site créés dans un site Web et qui peuvent être déployés dans un environnement déconnecté. Les applets de commande Windows PowerShell sont utilisées pour créer des packages de déploiement de contenu.

Remarque :
Cet article ne couvre pas l'utilisation de packages de solutions pour transmettre votre travail de développement SharePoint Foundation 2010 personnalisé aux serveurs Web frontaux ou les serveurs d'applications de votre batterie de serveurs. En utilisant des packages de solutions, vous pouvez déployer des artefacts dans un environnement déconnecté, et vous pouvez déployer des artefacts et des éléments de site développés dans le même package. Pour plus d'informations, voir Déployer des packages de solution (SharePoint Foundation 2010).

Quand utiliser un package de déploiement de contenu

Vous pouvez utiliser des packages de déploiement de contenu pour déployer des éléments de site créés dans un ou plusieurs des scénarios suivants :

  • Migration de contenu unique Utilisez un package de déploiement de contenu pour déplacer une seule fois le contenu dans une collection de sites de destination. Si vous envisagez de mettre à jour régulièrement le contenu sur une collection de sites de destination, utilisez la fonctionnalité de déploiement de contenu ou l'API de migration de contenu.

  • Environnements déconnectés Si les batteries de serveurs ne sont pas connectées, vous pouvez créer un package de déploiement de contenu pour le transfert asynchrone dans la batterie de serveurs d'intégration.

  • Exemple de contenu Si des personnalisations d'éléments de site créés doivent être déployées de l'environnement de création vers l'environnement d'intégration en vue d'être utilisées comme des exemples à des fins de développement, vous pouvez utiliser un package de déploiement de contenu pour simplifier ce processus.

Avant de commencer

Afin d'éliminer les problèmes potentiels de synchronisation, vous devez souvent déployer les éléments de site développés avant les éléments de site créés. Les solutions de batterie de serveurs et les solutions d'application Web doivent être installées et déployées sur la batterie de serveurs de destination avant le déploiement de contenu. Sachez également que vous devez installer tous les modules linguistiques qui sont utilisés sur le serveur source sur le serveur de destination ; si les modules linguistiques requis ne sont pas installés, le déploiement de contenu échouera.

Avant d'effectuer les procédures dans cet article, familiarisez-vous avec les concepts propres au déploiement de personnalisations d'éléments de site. Pour plus d'informations sur la planification et la conception de sites et de collections de sites, voir Planification de site fondamentale (SharePoint Foundation 2010). Par ailleurs, téléchargez une version Excel de la feuille de planification de déploiement de contenu (éventuellement en anglais) (http://go.microsoft.com/fwlink/?LinkID=167835&clcid=0x40C).

Déployer le contenu à l'aide de l'API de migration de contenu

Vous pouvez traiter la plupart des scénarios de déploiement à l'aide de l'Administration centrale sans recourir à des scripts. Toutefois, vous pouvez utiliser le modèle objet pour gérer d'autres scénarios, tels que l'écriture de scripts pour automatiser des tâches courantes et la définition des propriétés personnalisées pour les opérations d'exportation et d'importation que vous ne pouvez pas configurer à l'aide du site Administration centrale de SharePoint. Vous pouvez également créer du code qui exporte et importe un package de contenu dans les situations où la connectivité entre une batterie de serveurs source et une batterie de destination peut être limitée ou indisponible.

Pour plus d'informations sur la migration de contenu et les API de migration de contenu, voir Vue d'ensemble de la migration de contenu (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187033&clcid=0x40C). Pour obtenir une vue d'ensemble de la fonctionnalité de déploiement de contenu, ainsi que le contexte et les ressources nécessaires pour générer et mettre en œuvre des solutions de déploiement personnalisées, voir Déploiement de contenu entre serveurs (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=181466&clcid=0x40C). Pour obtenir un exemple de code qui montre comment utiliser le modèle objet pour créer des chemins d'accès et des travaux qui déploient du contenu entre les collections de sites, voir Procédure : déploiement de contenu entre serveurs (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187034&clcid=0x40C). Pour obtenir un exemple de code et des informations sur la façon d'exporter et d'importer un package de contenu à l'aide de l'API de migration de contenu, voir Procédure : personnaliser le déploiement dans des scénarios déconnectés (http://go.microsoft.com/fwlink/?linkid=181076&clcid=0x40C).

Créer un package de déploiement de contenu à l'aide de Windows PowerShell

Vous pouvez utiliser Windows PowerShell pour créer un package de déploiement de contenu qui contient les éléments de site créés pour un site entier (y compris tout le contenu du site) ou une liste ou une bibliothèque de documents.

Remarque :
Utilisez des packages de déploiement de contenu pour une migration de contenu unique vers une collection de sites de destination. Utilisez la fonctionnalité de déploiement de contenu ou l'API de migration de contenu pour déplacer périodiquement le contenu d'une collection de sites source vers une collection de sites de destination.

Les packages de déploiement de contenu sont implémentés sous forme de fichiers CMP (Content Migration Package ). Vous exportez ce package à partir du serveur source, puis vous l'importez dans le serveur de destination. Vous pouvez utiliser cette méthode de déploiement de contenu dans les environnements connectés et déconnectés.

Si vous utilisez un système de gestion de la configuration logicielle, suivez les étapes pour exporter le package de déploiement de contenu, puis utilisez la procédure correspondant à votre système de gestion de la configuration logicielle pour enregistrer le fichier exporté.

Pour créer un package de déploiement de contenu à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commande Windows PowerShell, tapez la commande suivante :

    Code de copie
    Export-SPWeb -Identity <URLname> -path <ExportFileName> -IncludeUserSecurity -IncludeVersions 4 -NoFileCompression

    Où :

    • <URLname> est le site à exporter. Ce site est écrit dans le package de déploiement de contenu avec tous les sous-sites.

    • IncludeUserSecurity octroie au nouveau site des autorisations identiques à celles du site d'origine..

    • IncludeVersions a la valeur 4 pour spécifier que toutes les versions doivent être incluses.

    • NoFileCompression signifie que le package de migration de contenu est créé dans un dossier non compressé, et non dans un fichier CAB unique. Cela complique le déploiement du package de migration sur un autre serveur, mais facilite la modification des fichiers.

Pour plus d'informations, voir Export-SPWeb.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour importer un package de déploiement de contenu à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commande Windows PowerShell, tapez la commande suivante :

    Code de copie
    Import-SPWeb -Identity <URLname> -path <ImportFileName> -IncludeUserSecurity

    Où :

    • <URLname> est le site qui sera importé avec tous les sous-sites.

Pour plus d'informations, voir Import-SPWeb.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Déployer des éléments de sites à l'aide de composants fonctionnels (SharePoint Foundation 2010)

Cet article décrit le déploiement de personnalisations d'éléments de sites développés au moyen de composants fonctionnels. Au moyen de composants fonctionnels, vous pouvez contrôler le cadre d'activation et de désactivation de la personnalisation de site, et facilement déployer les personnalisations sur plusieurs batteries de serveurs.

Dans cette section :

  • Qu'est-ce qu'un composant fonctionnel ?

  • Quand utiliser des composants fonctionnels

  • Créer un composant fonctionnel

  • Installer et activer un composant fonctionnel à l'aide de Windows PowerShell

Qu'est-ce qu'un composant fonctionnel ?

Un composant fonctionnel est un conteneur de différentes extensions définies pour SharePoint Foundation 2010, et est composé d'un ensemble de fichiers XML déployés sur des serveurs Web frontaux et des serveurs d'applications. Vous pouvez déployer un composant fonctionnel dans le cadre d'un package de solution, et vous pouvez activer individuellement un composant fonctionnel dans des sites SharePoint Foundation.

Les composants fonctionnels réduisent la complexité liée à la création de personnalisations de sites simples. Les composants fonctionnels éliminent la nécessité de devoir copier de vastes sections de code pour modifier une fonctionnalité simple et, par conséquent, ils réduisent les problèmes de contrôle de versions et d'incohérence qui peuvent se produire entre serveurs Web frontaux.

Les composants fonctionnels facilitent l'activation ou la désactivation de la fonctionnalité au cours d'un déploiement, et les administrateurs peuvent facilement transformer le modèle ou la définition d'un site en activant ou désactivant un composant fonctionnel particulier sur l'interface utilisateur.

Un élément est une unité atomique d'un composant fonctionnel. L'élément Feature est utilisé dans un fichier Feature.xml file pour définir un composant fonctionnel et spécifier l'emplacement des assemblys, des fichiers, des dépendances ou des propriétés qui prennent en charge le composant fonctionnel. Un composant fonctionnel inclut un fichier Feature.xml et un nombre illimité de fichiers décrivant des éléments individuels. Un autre élément Feature d'un schéma différent est utilisé dans un fichier Onet.xml pour indiquer qu'un composant fonctionnel doit être activé lors de la création d'un site à partir de la définition de site.

Un fichier Feature.xml pointe généralement vers un ou plusieurs fichiers XML dont la balise de niveau supérieur <Elements> contient des définitions pour les éléments qui prennent en charge le composant fonctionnel. Les éléments dans SharePoint Foundation 2010 correspondent souvent aux anciens nœuds discrets du fichier Onet.xml ou Schema.xml de Microsoft Office SharePoint Portal Server 2003 Il existe plusieurs types d'éléments, par exemple, un élément de menu personnalisé ou un gestionnaire d'événements.

  • Pour plus d'informations sur les possibilités des composants fonctionnels, voir Utilisation de composants fonctionnels (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183450&clcid=0x40C).

  • Pour des informations spécifiques sur le format de fichier et les éléments XML utilisés dans le fichier Feature.xml, voir Fichiers Feature.xml (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183451&clcid=0x40C).

  • Pour plus d'informations sur la façon dont les composants fonctionnels affectent le format du fichier Onet.xml dans une définition de site, voir Fichiers de définition de site (Onet.xml) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183454&clcid=0x40C).

  • Pour plus d'informations sur les types d'éléments des composants fonctionnels, voir Types d'éléments (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183455&clcid=0x40C).

Quand utiliser des composants fonctionnels

Les composants fonctionnels représentent la méthode recommandée pour le déploiement d'éléments de fonctionnalité, de personnalisations ou de modifications de configuration sur des serveurs Web frontaux. Le composant fonctionnel constitue un moyen flexible de gérer une fonctionnalité tout au long de son cycle de vie, notamment lors de l'activation, de la mise à niveau et éventuellement de la désactivation.

Vous pouvez utiliser des composants fonctionnels pour déployer des éléments de site développés dans un ou plusieurs des scénarios suivants :

  • Besoin d'activation et de désactivation Lorsque vous déployez des personnalisations d'éléments de site dans un composant fonctionnel, vous pouvez installer, activer et désactiver le composant fonctionnel avec Windows PowerShell ou au moyen du modèle objet. Vous pouvez également activer et désactiver un composant fonctionnel à l'aide du site Web Administration centrale.

  • Flexibilité d'étendue Vous pouvez activer un composant fonctionnel pour une étendue unique, notamment une batterie de serveurs, une application Web, une collection de sites ou un site Web.

  • Simplicité de distribution des déploiements Un composant fonctionnel est facile à déployer sur plusieurs batteries de serveurs dans le cadre d'une solution.

  • Contrôle approfondi via le modèle objet Composant fonctionnel Le modèle objet Composant fonctionnel permet de spécifier la liste des composants fonctionnels installés dans une étendue donnée et de contrôler si les composants fonctionnels sont activés aux niveaux de la batterie de serveurs et des sites.

Utilisez les packages de solution pour créer des packages de composants fonctionnels à déployer dans différents environnements. Par exemple, utilisez un package de solution pour déployer des personnalisations entre des stations de travail de développeurs et une batterie de serveurs d'intégration, et entre une batterie d'intégration ou des stations de travail clientes de création, et des batteries de serveurs pilotes ou de production.

Créer un composant fonctionnel

Lorsque vous créez une page Web personnalisée dans SharePoint Foundation 2010 à l'aide du navigateur ou de SharePoint Designer, la page ASPX peut uniquement appartenir à la collection de sites racine du serveur qui exécute SharePoint Foundation 2010. Pour créer une page sous une collection de sites qui est disponible à toute la batterie de serveurs et dans toutes les collections de sites, utilisez une solution pour déployer la page sous le dossier \14\Template\Layouts (en utilisant l'élément TemplateFiles dans le fichier de manifeste de solution).

Sur une batterie de serveurs, il est recommandé de déployer des composants fonctionnels en utilisant un package de solution. Si un serveur doit être reconstruit ou qu'un autre serveur est ajouté à la batterie, le composant fonctionnel ne devra pas être manuellement ajouté à chaque serveur Web frontal. En utilisant des packages de solution, vous pouvez déployer des composants fonctionnels nouveaux et mis à niveau dans la batterie de serveurs et synchroniser un serveur Web frontal afin que son état soit cohérent avec celui d'autres serveurs dans la batterie.

Pour contrôler la disponibilité d'une page personnalisée dans une collection de sites ou un site Web, déployez la page Web personnalisée en tant que composant fonctionnel SharePoint dans le cadre d'une solution. Utilisez l'élément de module dans le fichier Feature.xml pour déployer une page Web en utilisant une étendue d'une collection de sites et d'un site Web. Les modules sont fréquemment utilisés pour mettre en œuvre un composant WebPart dans le site.

Un composant fonctionnel qui est déployé dans le cadre d'une solution est installé automatiquement. Si vous déployez manuellement un composant fonctionnel, vous devez l'installer et l'activer. Voir Installer et accéder à un composant fonctionnel avec Windows PowerShell, plus loin dans cet article.

Pour créer et déployer un composant fonctionnel personnalisé

  1. Créez un fichier Feature.xml. L'exemple qui suit montre un fichier Feature.xml qui permet d'attribuer un ID unique au composant fonctionnel et de pointer vers le fichier Module.xml.

    Code de copie
    <?xml version="1.0"?>
<Feature Id="8C4DD0CB-5A94-44da-9B7F-E9ED49C2B2DC" Title=
"Custom Web page"
Description="This simple example feature adds an ASPX page
with a hosted XmlFormView control"
Version="1.0.0.0" Scope="Web"
xmlns="http://schemas.microsoft.com/sharepoint/">
<ElementManifests>
    <ElementManifest Location="Module.xml"/>
</ElementManifests>
</Feature>

  2. Créez un fichier Module.xml. L'exemple qui suit est un fichier Module.xml contenant des informations sur la ou les pages qui font partie de la solution.

    Code de copie
    <?xml version="1.0"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
    <module name="file" url="" path="">
        <file url="XmlFormViewPage.aspx" type="ghostable"> </file>
    </module>
</Elements>

  3. Changez la valeur de l'url du fichier au nom de votre page ASPX.

  4. Ajoutez un sous-dossier pour la définition du composant fonctionnel dans le répertoire d'installation des composants fonctionnels sur l'ordinateur serveur, généralement %COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\14\TEMPLATE\FEATURES.

    Important :
    Une meilleure pratique consiste à utiliser des noms détaillés, qualifiés pour les sous-dossiers que vous créez pour les définitions de composants fonctionnels. Cette pratique minimise le risque d'ajouter des composants fonctionnels multiples ayant le même nom et d'écraser le fichier Feature.xml pour un autre composant fonctionnel. Par exemple, utilisez HR_Contract et Finance_Contract et non Contract.

  5. Ajoutez votre page .aspx personnalisée à ce sous-dossier pour la définition du composant fonctionnel.

  6. Ajoutez les fichiers Feature.xml et Module.xml au même emplacement.

  7. Ajoutez le composant fonctionnel à un package de solution.

    Vous pouvez utiliser Visual Studio 2010 pour ajouter le composant fonctionnel à une solution, ou vous pouvez manuellement ajouter un élément FeatureManifests au fichier Manifest.xml de la solution.

  8. Créez le package de solution.

    Vous pouvez utiliser Visual Studio 2010 pour construire le package de la solution. Vous pouvez également utiliser l'outil Makecab.exe pour créer le package de solution.

  9. Importez et déployez le package de solution.

    Ajoutez la solution au magasin de solutions à l'aide de l'applet de commande Windows PowerShellAdd-SPSolution, puis déployez la solution à partir du magasin de solutions en utilisant le site Web Administration centrale ou au moyen de Windows PowerShell.

Pour plus d'informations sur l'utilisation de Visual Studio 2010 pour ajouter des composants fonctionnels à des packages de solution, voir Création de packages de solution SharePoint (http://go.microsoft.com/fwlink/?linkid=187035&clcid=0x40C). Pour plus d'informations sur la création manuelle d'un package de solution ou l'utilisation de l'outil Makecab.exe pour créer le package, voir Création d'une solution (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187036&clcid=0x40C). Pour plus d'informations sur le déploiement de solutions, voir Déployer des packages de solution (SharePoint Foundation 2010).

Installer et activer un composant fonctionnel à l'aide de Windows PowerShell

Vous pouvez installer et activer un composant fonctionnel à l'aide de Windows PowerShell ou du modèle objet. Vous pouvez également activer un composant fonctionnel à l'aide de la page Gérer les fonctionnalités des applications Web ou la page Composants fonctionnels de la collection de sites ou du site où vous souhaitez activer le composant fonctionnel. L'installation d'un composant fonctionnel rend sa définition et ses éléments connus dans l'ensemble d'une batterie de serveurs, et l'activation du composant fonctionnel rend ce dernier disponible à une étendue particulière.

Remarque :
Les composants fonctionnels qui sont déployés dans le cadre d'un package de solution sont installés par le déploiement et une installation manuelle n'est pas requise.

Vous installez des composants fonctionnels dans le dossier 14\Template\Features, chaque composant fonctionnel occupant son propre sous-dossier. À la racine de ce dossier, un fichier Feature.xml définit le contenu du composant fonctionnel. Vous devez installer des composants fonctionnels individuels avant de pouvoir les utiliser, et, sauf si le composant fonctionnel est étendu à l'échelle de la batterie de serveurs, vous devez les désactiver après leur installation. Si un composant fonctionnel est étendu à l'échelle de la batterie de serveurs ou de l'application Web, il est activé automatiquement.

Pour désinstaller un composant fonctionnel afin que sa définition ne soit plus disponible dans une batterie de serveurs, vous devez d'abord désactiver le composant fonctionnel à l'aide de l'applet de commande Windows PowerShellDisable-SPFeature, sauf si l'étendue du composant fonctionnel couvre les applications Web ou les batteries de serveurs. Après la désactivation du composant fonctionnel, vous pouvez utiliser l'applet de commande Uninstall-SPFeature pour le désinstaller. Pour plus d'informations, voir Uninstall-SPFeature. Après la désinstallation d'un composant fonctionnel, réinitialisez IIS afin que les modifications puissent être appliquées.

Pour désactiver un composant fonctionnel afin qu'il devienne inactif comme son étendue affectée d'origine sans le désinstaller, vous pouvez utiliser l'applet de commande Disable-SPFeature. Pour plus d'informations, voir Disable-SPFeature.

Utilisez les procédures suivantes pour installer et activer un composant fonctionnel.

Pour installer un composant fonctionnel à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    Install-SPFeature -path <Path> [-force]

    Où :

    • <Path> est un chemin de fichier valide ; par exemple, MyFeature. Le chemin d'accès au composant fonctionnel doit être un chemin littéral au nom de dossier 14\Template\Features. Le nom de fichier Feature.xml est implicite et n'a pas besoin d'être fourni.

Pour plus d'informations, voir Install-SPFeature.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour activer un composant fonctionnel à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    Enable-SPFeature -Identity <FeatureID> [-url] <URLname> [-force]

    Où :

    • <FeatureID> est le nom du dossier du composant fonctionnel se trouvant dans le dossier 14\Template\Features. Ce doit être un chemin d'accès de fichier valide ; par exemple, MyCustom.

    • <URLname> est l'URL parent du composant fonctionnel de l'application Web, de la collection de sites ou du site Web pour lequel le composant fonctionnel est activé ; par exemple, http://somesite.

Pour plus d'informations, voir Enable-SPFeature.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Déployer des modèles (SharePoint Foundation 2010)

Cet article explique comment créer une définition de site personnalisé et la déployer à l'aide d'un package de solution.

Dans cet article :

  • Que sont les définitions de site ?

  • Configurations et définitions de site

  • Créer une configuration et une définition de site personnalisée

  • Déployer une définition de site en utilisant un package de solution

Que sont les définitions de site ?

Dans Microsoft SharePoint Foundation 2010, un utilisateur crée un site via l'interface utilisateur (IU) en sélectionnant une configuration de définition de site ou un modèle de site personnalisé qui définit comment instancier le site. Une définition de site est un modèle qui détermine par exemple les listes, les fichiers, les composants WebPart, les fonctionnalités ou les paramètres permettant de mettre en service un nouveau site SharePoint.

Une définition de site est une famille de configurations de définitions de site. Chaque définition de site spécifie un nom et contient une liste des configurations de définitions de site. Dans SharePoint Foundation 2010, une définition de site se compose d'un ensemble de fichiers XML qui peut être appliqué pour mettre en service de nouveaux sites. Les fichiers sont situés sur des serveurs Web.

Les définitions de site se composent principalement de plusieurs fichiers XML et ASPX stockés sur un serveur Web frontal dans des dossiers sous le dossier %ProgramFiles%\Common Files\Microsoft Shared\Web serveur extensions\14\TEMPLATE\SiteTemplates.

Un site créé à partir d'une définition de site enrichit les informations structurelles et de contenu, sans les répéter, à partir de la définition du site d'origine. Tout au long de leur cycle de vie, les sites continuent à dépendre de la définition de site qui est leur fondement ultime. Pour cette raison, Microsoft ne prend pas en charge la modification ou la suppression d'une définition de site une fois que des sites ont été créés à partir de celle-ci. Ces modifications peuvent faire en sorte que des sites créés à partir de la définition cessent de fonctionner correctement ou peuvent empêcher la création de nouveaux sites basés directement, ou indirectement, sur la définition du site. Pour personnaliser une définition de site, les développeurs peuvent ajouter une fonction qui inclut les modifications apportées à la définition du site. La définition du site elle-même n'est pas modifiée.

Pour plus d'informations sur les types de personnalisations de définitions de site qui sont pris en charge par Microsoft, consultez Scénarios pris en charge et non pris en charge pour utiliser les définitions de site personnalisées et les définitions de zone personnalisées dans Windows SharePoint Services, dans SharePoint Portal Server 2003 et Office SharePoint Server 2007 (http://go.microsoft.com/fwlink/?linkid=187678&clcid=0x40C).

Dans le modèle d'objet, un SPWebTemplate représente une définition de site (et la configuration).Pour plus d'informations sur les modèles de site et les définitions de site, voir Définitions et modèles de site (http://go.microsoft.com/fwlink/?linkid=184756&clcid=0x40C).

Remarque :
Le format STP d'un modèle de site personnalisé (fichier .stp) est abandonné dans SharePoint Foundation 2010 et remplacé par des modèles de site au format WSP. Dans Windows SharePoint Services 3.0, les utilisateurs peuvent enregistrer un site existant comme modèle. Le modèle de site est stocké dans la base de données en tant que modèle et les utilisateurs peuvent sélectionner le modèle de site comme base définissant comment instancier le site. Dans SharePoint Foundation 2010, les utilisateurs peuvent enregistrer un site existant comme modèle. Le modèle est enregistré sous un format de fichier .wsp dans la galerie de solutions du site de haut niveau dans une collection de sites, où il devient disponible pour la création de sous-sites sur tous les sites Web dans la collection de sites.

Pour plus d'informations sur les définitions de site, voir Configurations et définitions de site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183458&clcid=0x40C).

Configurations et définitions de site

Une définition de site définit un site SharePoint spécifique. Il existe cinq définitions de site installées en mode natif dans SharePoint Foundation 2010. Une définition de site peut inclure plusieurs configurations de définition de site. Les sites Web SharePoint sont basées sur des configurations de définitions de site spécifiques, qui sont les suivantes :

  • SharePoint Team Services inclut les configurations de définitions de site pour les sites d'équipe, les sites vides et les espace de travail de document.

  • MPS inclut les configurations de définitions de site pour l'espace de travail de réunion de base, l'espace de travail de réunion vide, l'espace de travail de réunion pour la prise de décision, l'espace de travail de réunion informelle et l'espace de travail de réunion multipage.

  • CENTRALADMIN fournit la configuration de définition de site pour les sites Web d'administration centrale.

  • WIKI fournit la configuration de définition de site pour les sites Web qui prennent en charge de contenu de la communauté à l'aide de la technologie wiki.

  • BLOG fournit la configuration de définition de site pour les blogs.

Chaque définition de site se compose des fichiers qui sont placés dans les sous-dossiers \\Program Files\Common Files\Microsoft Shared\web serveur extensions\14\TEMPLATE\SiteTemplates des serveurs Web frontaux lors de l'installation de SharePoint Foundation 2010. Les fichiers de définition de site incluent les fichiers .xml, .aspx, .ascx et les fichiers de page .master, en plus des fichiers de modèle de document — comme .dot et .htm — et des fichiers de contenu, tels que .gif et. doc.

Pages non personnalisées et personnalisation de pages

Les fichiers de définitions de site sont mis en cache dans la mémoire sur le serveur au démarrage du processus Microsoft Internet Information Services (IIS). Ainsi, les pages non personnalisées peuvent être réutilisées sur les sites. Les informations contenues dans ces fichiers sont extraites du cache au moment de l'exécution. Les pages et les schémas de liste sont lus à partir des fichiers de définition du site mais semblent être des fichiers réels au sein d'un site. Les nouvelles pages WebPart sont également considérées comme étant non personnalisées.

Lorsque des pages de site sont personnalisées — à l'exclusion des personnalisations basées sur la navigateur, telles que les modifications apportées aux composants WebPart — leur contenu est stocké dans la base de données de contenu et la page de site personnalisée est utilisée à la place de la page d'origine de la définition du site. Les fichiers .aspx téléchargés sont automatiquement considérés comme étant personnalisés.

Pour plus d'informations sur le dédoublement et la personnalisation des pages, voir Configurations et définitions de site (http://go.microsoft.com/fwlink/?linkid=183458&clcid=0x40C).

Fichiers de schéma de base

Le tableau suivant répertorie les fichiers XML principaux qui peuvent être modifiés pour une définition de site et affiche leur emplacement dans le système de fichiers.

WebTemp.xml | Identifie les définitions de site et fournit des informations sur leurs configurations. Se trouve dans : \TEMPLATE\1033\XML
Onet.xml | Définit les zones de navigation, spécifie les définitions de liste disponibles, spécifie les modèles de document et leurs fichiers, définit les types de base pour les listes et définit les configurations et les modules pour les définitions de site. Se trouve dans : \TEMPLATE\SiteDefinitions\type_site\XML
Schema.xml | Définit les vues, les formulaires, les barre d'outils et les champs spéciaux dans une définition de liste. Chaque définition possède son propre fichier Schema.Xml. Se trouve dans : \TEMPLATE\FEATURES\List_Definition_Name
DocIcon.xml | Chaque serveur Web frontal dans un déploiement SharePoint Foundation contient un fichier DocIcon.xml qui mappe le fichier des identifiants programmatiques (ProgID) et les extensions de nom de fichier des types de documents à des icônes spécifiques et aux contrôles pour l'ouverture de chaque type. Les modifications apportées à DocIcon.xml sont globales pour un déploiement SharePoint Foundation et affectent toutes les définitions de site sur le serveur Web frontal. Se trouve dans : \TEMPLATE\XML

Ces fichiers XML utilisent Collaborative Application Markup Language (CAML) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183464&clcid=0x40C) pour définir les aspects d'un site. Pour plus d'informations sur ces fichiers XML de base que vous pouvez utiliser pour personnaliser des définitions de site, voir Configurations et définitions de site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183458&clcid=0x40C).

Créer une configuration et une définition de site personnalisée

Vous pouvez créer des définitions de site personnalisées en copiant manuellement une définition de site existante ou en important un fichier .wsp dans Visual Studio 2010.

Importer des éléments à partir d'un de site SharePoint existant

Cette méthode nécessite d'enregistrer un site sous la forme d'un modèle à partir de SharePoint Foundation pour générer un fichier .wsp et puis à importer le fichier .wsp dans Visual Studio 2010 à l'aide du modèle de projet d'importation de solution. Le modèle de projet d'importation du package de solution SharePoint permet de réutiliser des éléments comme les types de contenu, les définitions de liste et les champs à partir de sites SharePoint existants dans une nouvelle solution Visual Studio SharePoint. Pour plus d'informations sur l'importation des éléments d'un site SharePoint existant dans un projet Visual Studio SharePoint, voir Importation d'éléments d'un site SharePoint existant (http://go.microsoft.com/fwlink/?linkid=187040&clcid=0x40C). Ce chapitre contient une procédure pas à pas qui illustre les tâches suivantes :

  1. Personnalisation d'un site SharePoint en lui ajoutant une colonne de site personnalisée.

  2. Exportation d'un site SharePoint vers un fichier .wsp.

  3. Important du fichier .wsp dans un projet Visual Studio SharePoint en utilisant le projet d'importation .wsp.

Copier un site SharePoint existant

Cette méthode implique de copier une définition de site existante, de modifier cette copie et de changer deux fichiers de schéma : la copie d'un fichier WebTemp.xml et la copie d'un fichier ONET.Xml.

Avertissement :
Ne modifiez pas le fichier WebTemp.xml initialement installé.

  1. Copiez un dossier de définition de site existant situé dans le répertoire Local_Drive:\Program Files\Common Files\Microsoft Shared\web serveur extensions\14\TEMPLATE\SiteTemplates\. Votre copie doit être l'homologue de l'original et vous pouvez lui attribuer n'importe quel nom dépourvu d'espaces.

    Par exemple, pour créer une définition de site personnalisée qui dérive de la définition de site d'équipe pour Microsoft SharePoint Foundation, copiez le dossier \sts.

  2. Faites une copie du fichier WebTemp.xml. Ce fichier se trouve dans Local_Drive:\Program Files\Common Files\Microsoft Shared\web serveur extensions\14\TEMPLATE\1033\XML.

    Attribuez au fichier un nom unique en ajoutant une chaîne au nom du fichier d'origine ; par exemple, WebTempAction.xml. Au moment de l'exécution, le compilateur fusionne les informations contenues dans ce fichier avec les informations contenues dans le fichier d'origine pour spécifier les configurations de définitions de site qui sont sont disponibles pour la création de nouveaux sites.

  3. Personnaliser le contenu du nouveau fichier WebTemp.

    Chaque fichier WebTemp.xml contient une collection d'éléments Template et de sous-éléments Configuration, permettant au compilateur d'identifier toutes les configurations de définition de site qui peuvent être instanciées. L'élément de Configuration définit par exemple, un titre, une description, l'URL de l'image affichée dans l'interface utilisateur (UI) et une catégorie d'affichage qui spécifie l'onglet sous lequel afficher le modèle dans la section Template Selection de la page Créer une collection de sites.

    Important :
    Dans chaque élément de Template défini dans le fichier WebTemp, l'attribut Name doit contenir le même nom qui est affecté au nouveau dossier. Pour éviter tout conflit avec les ID déjà utilisés dans SharePoint Foundation 2010, utilisez uniquement des valeurs supérieures à 10 000 pour l'attribut ID .

L'exemple suivant utilise deux éléments de Configuration dans le fichier WebTemp.xml pour définir différentes configurations de définition de site pour l'instanciation d'un site, un pour le site de collaboration de recherche et l'autre pour un site d'espace de travail de document de recherche. Cet exemple utilise seulement deux configurations au sein d'une définition de site unique, mais vous pouvez inclure plusieurs définitions de site, chacune avec plusieurs configurations, dans un seul fichier WebTemp.xml. Chaque définition de site fait référence à un dossier de définition de site différent et son fichier ONET.Xml.

Code de copie
<?xml version="1.0" encoding="utf-8" ?>
<Templates xmlns:ows="Microsoft SharePoint">
  <Template Name="RESEARCH" ID="10001">
    <Configuration ID="0" Title="Research Collaboration site"
      Hidden="FALSE" ImageUrl="_layouts/images/stsprev.jpg"
      Description="This definition creates a site for the Research
      team to create, organize, and share general information."
      DisplayCategory="Collaboration">
    </Configuration>
    <Configuration ID="1" Title="Research Workspace" Hidden="FALSE"
      ImageUrl="_layouts/images/dwsprev.jpg" Description="This
      definition creates a site for Research team colleagues to
      work together on specific documents."
      DisplayCategory="Collaboration">
    </Configuration>
  </Template>
</Templates>

Comme indiqué par la valeur de l'attribut de Name dans l'élément Template, cet exemple suppose qu'un répertoire de définitions de site nommé « RESEARCH » existe. Si un fichier WebTemp*.xml spécifie plusieurs définitions de site, les définitions se distinguent par leurs valeurs ID uniques.

Chaque élément Configuration contient également un attribut ID. La combinaison de cet ID et de la valeur de l'attribut Name dans l'élément Template fournit une référence au contenu d'un élément Configuration spécifique dans un fichier Onet.xml spécifique. Dans l'exemple, l'attribut Name contient RESEARCH et les attributs ID contiennent 0 et 1, qui référencent la définition de site RESEARCH et les configurations avec leurs ID 0 ou 1 dans Onet.xml.

Il se peut que vous deviez réinitialiser IIS pour que la nouvelle configuration de définition apparaisse sous la forme d'une option dans l'interface utilisateur. Pour ce faire, entrez iisreset à l'invite de commandes.

Pour plus d'informations sur la définition de chaque configuration de définition de site dans Onet.xml, voir Comment faire : utiliser des configurations de définitions de site (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183465&clcid=0x40C).

Déployer une définition de site en utilisant un package de solution

Pour déployer une définition de site personnalisée à l'aide d'un package de solution, ajoutez un élément SiteDefinitionManifest dans le fichier de manifeste du package de solution. Ajoutez l'élément TemplateFiles pour définir les fichiers de modèle qui doivent être déployés dans un sous-dossier du dossier \14\Template

Ajouter un élément SiteDefinitionManifest

L'élément dSiteDefinitionManifest possède un attribut Location qui récupère tous les fichiers dans le dossier spécifié et crée le dossier requis dans le dossier \14\Template\SiteTemplates. L'élément enfant WebTempFile déploie le fichier webtemp*.xml pour faire connaître le modèle à Produits SharePoint 2010, comme le montre l'exemple suivant :

Code de copie
  <SiteDefinitionManifests>
    <SiteDefinitionManifest Location="LitwareSiteTemplate">
      <WebTempFile Location="1033\xml\webtempLitware.xml" />
    </SiteDefinitionManifest>
  </SiteDefinitionManifests>

Ajouter un élément TemplateFile

L'élément TemplateFile dans un fichier manifeste de la solution est utilisé pour définir les fichiers modèles qui doivent être déployés dans un sous-dossier du dossier \14\Template. Le fichier fldtypes*.xml, qui définit les détails d'un type de champ personnalisé est un exemple du type de fichier que vous pouvez déployer de cette manière. Utilisez l'attribut Location pour spécifier le chemin d'accès relatif du fichier, qui est indiqué par la chaîne « Text » dans l'exemple suivant :

Code de copie
  <TemplateFiles
    <TemplateFile
      Location="Text"/>
      ...
  </TemplateFiles>

Pour plus d'informations sur la façon de déployer des solutions, voir Déployer des packages de solution (SharePoint Foundation 2010).

Historique des modifications


Processus de déploiement de flux de travail (SharePoint Foundation 2010)

Une fois qu'un flux de travail a été préparé pour être utilisé dans Microsoft SharePoint Foundation 2010, son déploiement dépend de ce que vous utilisez : un flux de travail prédéfini, un flux de travail Microsoft Office SharePoint Designer ou un flux de travail personnalisé Microsoft Visual Studio.

Cet article contient des informations et des procédures pour le déploiement de flux de travail dans SharePoint Foundation 2010.

Dans cet article :

  • Présentation

  • Avant de commencer

  • Déploiement de flux de travail

  • Vérification

Présentation

SharePoint Foundation 2010 fournit un modèle de flux de travail prédéfini unique, pour le flux de travail à trois états. Le modèle de flux de travail à trois états vous permet de créer des flux de travail spécifiques à exécuter dans des sites SharePoint. Vous pouvez également utiliser Office SharePoint Designer pour définir vos propres flux de travail ou vous pouvez utiliser Visual Studio pour créer des flux de travail personnalisés basés sur du code. Les flux de travail reposent sur Windows Workflow Foundation et s'exécutent dans des sites SharePoint, comme suit :

  • SharePoint Foundation 2010 : utilisé pour héberger des flux de travail. Une fois qu'un flux de travail est déployé sur l'hôte, vous pouvez activer, configurer, démarrer, participer à et effectuer le suivi du flux de travail.

  • SharePoint Designer 2010 : permet de créer des flux de travail définis par l'utilisateur ;

  • Microsoft Visio 2010 : utilisé avec SharePoint Designer 2010 pour créer des flux de travail définis par l'utilisateur ;

  • Visual Studio : utilisé par les développeurs pour créer des flux de travail.

Avant de commencer

Avant de suivre les procédures de déploiement indiquées dans cet article, vérifiez que le serveur exécute SharePoint Foundation 2010.

Déploiement de flux de travail

Le flux de travail à trois états prédéfini est déjà installé en tant que composant fonctionnel SharePoint dans SharePoint Foundation 2010.

Les flux de travail sur un site Web SharePoint sont stockés en tant que modèles de flux de travail. Au lieu d'utiliser le flux de travail prédéfini, vous pouvez créer des modèles de flux de travail SharePoint dans Office SharePoint Designer et Visual Studio, puis les déployer sur un site Web SharePoint Foundation 2010. Vous pouvez recourir aux outils d'administration SharePoint pour ajouter le modèle à des bibliothèques ou à des listes sur un site Web SharePoint Foundation 2010.

Pour déployer un flux de travail prédéfini, vous l'activez pour le site, vous l'associez à une liste, une bibliothèque, un type de contenu ou un site, puis vous le démarrez.

Pour déployer des flux de travail dans SharePoint Foundation 2010, utilisez la procédure appropriée parmi les suivantes :

  • Déployer des flux de travail prédéfinis

  • Déployer des flux de travail SharePoint Designer

  • Déployer des flux de travail Visual Studio

Déployer des flux de travail prédéfinis

Activer le flux de travail

Comme décrit plus haut dans cet article, vous ne pouvez utiliser un flux de travail que s'il est actif dans le site ou la collection de sites. Seuls les flux de travail actifs peuvent être associés aux listes et aux bibliothèques sur le site ou la collection de sites.

Le flux de travail à trois états prédéfini est actif par défaut lorsqu'un site ou une collection de sites sont créés. Étant donné que le flux de travail peut être désactivé, vous pouvez vérifier le site ou la collection de sites pour déterminer si le flux de travail à trois états est actif. Utilisez la procédure suivante pour déterminer si le flux de travail défini à trois états est actif, puis, si ce n'est pas le cas, activez-le.

Pour activer un flux de travail déployé en tant que composant fonctionnel, tel que le flux de travail à trois états prédéfini, voir Activer ou désactiver un flux de travail (SharePoint Foundation 2010).

Ajouter l'association de flux de travail à une liste, une bibliothèque, un type de contenu ou un site

Lorsque vous ajoutez un flux de travail, vous associez ce flux à une liste, une bibliothèque, un type de contenu ou un site. Vous configurez le flux de travail en spécifiant des paramètres tels que le nom, les options de démarrage, les participants et les options d'exécution du flux de travail.

Pour ajouter une association de flux de travail, voir Ajouter une association de flux de travail (SharePoint Foundation 2010).

Démarrer le flux de travail

Une fois qu'un flux de travail a été activé, puis ajouté à une liste, une bibliothèque, un type de contenu ou un site, un utilisateur authentifié peut l'exécuter sur un élément de la liste, sur un document de la bibliothèque ou sur un site dans le cas d'un flux de travail de site. Lorsque vous ajoutez le flux de travail, vous indiquez si vous souhaitez qu'il s'exécute automatiquement ou manuellement. Si le flux de travail est configuré pour démarrer automatiquement, les paramètres par défaut sont toujours utilisés au démarrage du flux de travail. Si le flux de travail est configuré pour démarrer manuellement, l'utilisateur peut modifier les paramètres par défaut, par exemple en spécifiant les participants au flux de travail ou une date d'échéance. Le flux de travail s'exécute sur les éléments de la liste ou des documents de la bibliothèque auxquels le flux de travail est associé.

La procédure de démarrage d'un flux de travail varie selon que celui-ci a été configuré pour être démarré manuellement ou automatiquement.

Pour plus d'informations, voir Démarrer une instance de flux de travail (SharePoint Foundation 2010).

Déployer des flux de travail SharePoint Designer

Lorsque des flux de travail définis par l'utilisateur sont activés, les utilisateurs peuvent déployer des flux de travail Office SharePoint Designer sur leurs sites.

Activer les flux de travail définis par l'utilisateur

Pour permettre aux utilisateurs de créer et d'exécuter des flux de travail SharePoint Designer 2010, vous devez vous assurer que les flux de travail définis par l'utilisateur sont activés pour la collection de sites. Par défaut, ce paramètre est activé. Lorsque ce paramètre est activé, les utilisateurs peuvent définir des flux de travail dans un éditeur de flux de travail déclaratifs, tel que l'éditeur de flux de travail de SharePoint Designer 2010. Un flux de travail déclaratif est un flux de travail qui est créé à partir de conditions et d'actions assemblées en règles et en étapes, et qui définit les paramètres pour le flux de travail sans écrire de code. À l'inverse des flux de travail basés sur du code, tels que ceux créés à l'aide de Visual Studio, les flux de travail déclaratifs ne sont pas déployés vers SharePoint Foundation 2010 en tant que code compilé. Au lieu de cela, ils sont compilés au moment de l'exécution.

La capacité à utiliser des flux de travail déclaratifs sur l'application Web pouvant être désactivée, vous pouvez vérifier l'application Web pour déterminer si les flux de travail déclaratifs sont actifs.

Pour plus d'informations, voir Activer ou désactiver les flux de travail déclaratifs (SharePoint Foundation 2010).

Créer un flux de travail SharePoint Designer

À l'aide de l'Assistant Concepteur de flux de travail disponible dans SharePoint Designer 2010, vous pouvez créer des flux de travail qui ajoutent la logique d'application au site ou à la collection de sites sans écrire de code personnalisé. Le Concepteur de flux de travail prend en charge la création du flux de travail, son activation et son ajout à la liste, à la bibliothèque ou au site. Vous n'avez pas besoin d'effectuer des tâches de configuration manuelle en dehors du concepteur pour déployer le flux de travail. Toutefois, si vous publiez un modèle de flux de travail pour une collection de sites SharePoint, vous pouvez télécharger ce modèle en tant que fichier WSP, puis le déployer vers d'autres collections de sites. Pour plus d'informations, voir Déployer un flux de travail sous forme de fichier WSP (SharePoint Foundation 2010).

Démarrer le flux de travail

Comme SharePoint Designer 2010 peut activer automatiquement le flux de travail et l'ajouter à une liste, une bibliothèque ou un site, un utilisateur authentifié peut ensuite exécuter le flux de travail sur un élément de la liste, sur un document de la bibliothèque, ou sur un site dans le cas d'un flux de travail de site. Lorsque vous créez le flux de travail dans SharePoint Designer 2010, vous spécifiez si le flux de travail doit s'exécuter automatiquement ou manuellement. Si le flux de travail est configuré pour démarrer automatiquement, les paramètres par défaut sont toujours utilisés lorsque le flux de travail commence. Si le flux de travail est configuré pour démarrer manuellement, un utilisateur peut modifier les paramètres par défaut, par exemple spécifier des participants au flux de travail et une date d'échéance, selon ce qui est autorisé par le modèle de flux de travail. Lorsqu'il est démarré, le flux de travail s'exécute sur des éléments de la liste, sur des documents de la bibliothèque ou sur le site auquel le flux de travail est associé.

Pour plus d'informations, voir Démarrer une instance de flux de travail (SharePoint Foundation 2010).

Déployer des flux de travail Visual Studio

Une fois qu'un flux de travail personnalisé Visual Studio est créé et installé, le processus pour le déployer ressemble à celui d'un flux de travail prédéfini.

Créer un flux de travail personnalisé

Lorsqu'un flux de travail personnalisé est créé à l'aide de Visual Studio, il est organisé en package en tant que composant fonctionnel SharePoint. L'organisation des composants fonctionnels en packages permet d'encapsuler les solutions et les fonctionnalités SharePoint, ce qui facilite leur déploiement. Une fois que l'équipe de développement a créé un flux de travail et l'a organisé en package en tant que composant fonctionnel, déployez le flux de travail à l'aide de la commande Install-SPFeatureWindows PowerShell comme l'explique la section suivante.

Installer le flux de travail personnalisé

Vous installez les composants fonctionnels dans le répertoire \Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Template\Features. Chacun d'eux se trouve dans son propre sous-répertoire. À la racine de ce dossier, un fichier Feature.xml définit le contenu du composant fonctionnel. Utilisez l'applet de commande Windows PowerShellInstall-SPFeature pour installer le composant fonctionnel. Pour plus d'informations, voir Install-SPFeature.

Important :
Pour exécuter Windows PowerShell, vous devez être membre du groupe Administrateurs sur l'ordinateur local. En outre, Windows PowerShell doit être activé en tant que composant fonctionnel sur le serveur où vous installez un flux de travail.

Activer le flux de travail

Avant de pouvoir utiliser un flux de travail Visual Studio qui a été déployé en tant que composant fonctionnel, vous devez l'activer pour le site ou la collection de sites. Seuls les flux de travail actifs peuvent être associés aux listes, aux bibliothèques, aux types de contenus et aux sites.

Pour activer un flux de travail qui est déployé en tant que composant fonctionnel, voir Activer ou désactiver un flux de travail (SharePoint Foundation 2010).

Ajouter le flux de travail à une liste, une bibliothèque, un type de contenu ou un site

Lorsque vous ajoutez un flux de travail, vous associez ce flux à une liste, une bibliothèque, un type de contenu ou un site, et vous configurez le flux de travail en spécifiant des paramètres tels que le nom, les options de démarrage, les participants et les options d'exécution du flux de travail.

Pour ajouter une association de flux de travail, voir Ajouter une association de flux de travail (SharePoint Foundation 2010).

Démarrer le flux de travail

Une fois qu'un flux de travail a été activé, puis ajouté à une liste, une bibliothèque, un type de contenu ou un site, un utilisateur authentifié peut l'exécuter sur un élément de la liste, sur un document de la bibliothèque ou, dans le cas d'un flux de travail de site, sur un site. Lorsque vous ajoutez le flux de travail, vous indiquez si vous souhaitez qu'il s'exécute automatiquement ou manuellement. Si le flux de travail est configuré pour démarrer automatiquement, les paramètres par défaut sont toujours utilisés au démarrage du flux de travail. Si le flux de travail est configuré pour démarrer manuellement, l'utilisateur peut modifier les paramètres par défaut, par exemple en spécifiant les participants au flux de travail ou une date d'échéance. Le flux de travail s'exécute sur les éléments de la liste ou des documents de la bibliothèque auxquels le flux de travail est associé.

La procédure de démarrage d'un flux de travail varie selon que celui-ci a été configuré pour être démarré manuellement ou automatiquement. Pour plus d'informations, voir Démarrer une instance de flux de travail (SharePoint Foundation 2010).

Vérification

Une fois un flux de travail déployé, il est recommandé de le tester pour s'assurer qu'il fonctionne correctement, qu'il envoie des notifications par courrier électronique aux participants au flux de travail corrects aux étapes correctes, et qu'il fournit les résultats attendus.

Historique des modifications


Deploy software updates for SharePoint Foundation 2010 (en anglais)

Microsoft periodically releases software updates for Microsoft SharePoint Foundation 2010. It is important to understand what these updates are and how to deploy them to servers or server farms. This section describes the software update process for SharePoint Foundation.

In this section:

  • Software updates overview (SharePoint Foundation 2010) (en anglais)

    This article provides an overview of the software update process for SharePoint Foundation.

  • Prepare to deploy a software update (SharePoint Foundation 2010) (en anglais)

    This article helps you determine which approach to use to update the servers or server farms in your environment, and lists the steps that you must take before you can start to install the update.

  • Install a software update (SharePoint Foundation 2010) (en anglais)

    This article contains instructions for installing a software update and upgrading your content to that level.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Software updates overview (SharePoint Foundation 2010) (en anglais)

This article provides an overview of deploying software updates on a Microsoft SharePoint Foundation 2010 farm.

In this article:

  • Improvements and new features

  • Intended audience and scope

  • Software update process

  • Software update strategy

  • Software update deployment cycle

Improvements and new features

SharePoint Foundation 2010 introduces improvements and new features that facilitate a better end-to-end software update experience. Some of these features are as follows:

  • There is support for backward compatibility between update versions on different servers, which enables you to install the update binary files and postpone update completion to a later time.

  • You can update multiple Microsoft SharePoint Foundation servers concurrently to shift the workload to the database servers.

  • There is full support for automatic updates that use Windows Server Update Services (WSUS), Windows Update, and Microsoft Update.

    Remarque :
    An automatic update will install the binary files on the farm servers, but you must complete the software update by running the upgrade on the servers.

  • Administrators can monitor the status of the update by using the Central Administration Web site or Windows PowerShell.

For more information about SharePoint Foundation improvements and new features, see Nouveautés de la mise à niveau (SharePoint Foundation 2010).

Intended audience and scope

The information that is provided about the software update process is intended for all IT professionals who maintain SharePoint Foundation 2010. However, the specific instructions for installing a software update are intended for IT professionals who have to deploy software updates on a SharePoint Foundation server farm.

The information in this article applies to the following products:

  • SharePoint Foundation 2010

  • SharePoint Foundation 2010 language pack

  • Microsoft Filter Pack

Remarque :
The process for installing software updates in stand-alone environments of SharePoint Foundation is a simpler process than the process for installing software updates in a server farm and does not require all the steps that are required for a server farm.

Software update process

It is important to understand that deploying updates in a SharePoint Foundation 2010 environment is a two-phase process: patching and upgrading. The term patch is used in this article to differentiate between updating the software and upgrading the software.

Each phase has specific steps and results. It is possible to postpone the upgrade phase.

Attention :
Inconsistent farm behavior may result from postponing the upgrade for more than several days. The longer the postponement, the larger the risk is that farm behavior issues will occur.

Update phase

The patch phase has two steps, the patching step and the deployment step. During the patching step, new binary files are copied to the Central Administration server. Any services that are using files that have to be replaced are temporarily stopped. Stopping services reduces the requirement to restart the server to replace files that are being used. However, there are some instances when you must restart the server.

The second step in the patch phase is the deployment step. In this step, the installer copies support files to the appropriate directories on the server that is running SharePoint Foundation. This step ensures that all the Web applications are running the correct binary files and will function correctly after the update is installed. The update phase is complete after the deployment step.

The next and final phase to deploy software updates is the upgrade phase.

Upgrade phase

After you finish the patch phase, you must complete the update installation by starting the upgrade phase. The upgrade phase is task intensive and, therefore, takes the most time to finish. The first action is to upgrade all the SharePoint Foundation processes that are running. After the processes are upgraded, the databases are crawled and upgraded. Because the upgrade process can run on a single server, the other servers in the farm can continue to serve requests.

For more information about upgrades, see Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Software update strategy

The update strategy that you select will be based primarily on one of the following factors:

  • The amount of downtime that is acceptable for installing the update.

  • The additional staff and computing resources that are available to reduce downtime.

When you are determining your update strategy, consider how the strategy enables you to manage and control the update.

In terms of downtime reduction, the following options, ordered from most to least downtime, are available:

  • Install the update and do not postpone the upgrade phase.

  • Install the update and postpone the upgrade phase.

  • Install the update with the shortest possible downtime and postpone the upgrade phase.

Software update deployment cycle

The cycle that is used for upgrading SharePoint Foundation farms and servers also applies to deploying software updates, which are a subset of an upgrade. We recommend that you use the update cycle that is shown in the following illustration as a guide to deploy software updates.

Cycle de déploiement de la mise à jour logicielle

Learn

During this phase of the cycle the purpose is to learn what is required to install the update. This information also affects new servers that you want to update and then add to the farm.

Requirements and prerequisites

First, ensure that the system can be provisioned as a farm server. For more information, see Configuration matérielle et logicielle requise (SharePoint Foundation 2010). Ensure that any server that you plan to update is running the same version of the operating system as the other farm servers. This includes updates, service packs, and security hotfixes.

Update strategy

Determine which strategy you want to use to update the farm. Depending on your requirements, you can use one of the following strategies:

  • In-place

  • Database attach

You can use either of the previous strategies to create a hybrid approach that is tailored to your environment. For more information, see Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Downtime reduction

Research and assess the options that are available for reducing downtime. The first thing to check for is missing dependencies, which may extend the amount of downtime. Identify all the dependencies for the update and either address these dependencies before you start to deploy the update, or factor the time cost into your schedule. Consider using read-only content databases and doing parallel upgrades to reduce downtime.

Important :
We strongly advise against using alternate access mapping URL redirection (AAM) with database attach as an option for downtime reduction. AAM was not designed to deploy software updates. For more information, see Utilisation de redirection d'URL AAM dans le processus de mise à niveau (SharePoint Foundation 2010) (livre blanc).

Common issues

Identify and address common issues such as missing or out-of-date dependencies and lack of space on the servers where the update will be installed.

Prepare

Prepare for the software update by documenting the environment and planning an update strategy to ensure that the update will go as planned in the expected downtime window.

Document the environment

The purpose of documenting the environment is to determine what is unique in your farm. You can use several techniques to gather information about your farm, such as manual inspection, comparisons by using WinDiff, and Windows PowerShell commands.

Document, as appropriate, the following elements of the environment:

  • Farm topology and site hierarchy

  • Language packs and filter packs that are installed

  • Customizations that could be affected by the update

Manage customizations

Customizations are typically one of the top issues during a farm upgrade or software update. Identify your farm customizations and determine whether they might be affected by the update. If in doubt, err on the side of caution and determine how you will manage the customizations. You must ensure that customizations will work after the software update. You can use the Stsadm command, ExportIPFSAdminObjects, to collect and export customizations.

For more information, see Déterminer comment gérer les personnalisations (SharePoint Foundation 2010).

Plan the update strategy

During the Learn phase of the update cycle, you should have determined an update strategy and the required downtime minimization. In addition to determining hardware, space, and software requirements, you must include the following in your update strategy:

  • The update sequence for the farm servers

  • The order of operations

  • The downtime limits and how you plan to reduce downtime

  • A rollback process if there is a major problem

Conseil :
Clean up the farm environment before you deploy the update. The benefits of a cleanup are improved update installation performance and the elimination of potential issues during and after the software update. For more information, see Nettoyage de votre environnement avant la mise à niveau (SharePoint Foundation 2010).

The two final requirements for the update strategy are a communication plan and an update schedule.

It is very important to communicate with site owners and users about what to expect during an upgrade. The administrator should inform them about downtime and the risk that the upgrade may take longer than expected or that some sites may need some rework after upgrade. For more information, see Créer un plan de communication (SharePoint Foundation 2010).

Create a benchmark update operations schedule that contains the start times of operations related to the update deployment. At a minimum, the plan should include the following operations:

  • Back up the farm.

  • Start the update of the farm servers.

  • Start the upgrade of the farm databases.

  • Start a rollback of the environment, if it is required.

  • Resume the upgrade, if it is required.

  • Verify that the environment is completely working, either as the original version if you rolled back or the new version if you completed the upgrade.

Make farm items update-ready

Ensure that farm items are ready for the update. Farm items are ready if they are backed up, documented, or updated to ensure that the update can be installed. Verify that the following aspects of a farm are update-ready:

  • Solutions

  • Features

  • Site definitions

  • Web Parts

Test

The rigor, thoroughness, and detail of your tests determine the success or failure of the software update deployment. In a production computer environment there are no safe shortcuts, and there are consequences from insufficient testing. For more information, see Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010).

Build a test farm

Build a test farm that is representative of the production environment. We recommend that you use a copy of the production data to determine potential problem areas and monitor overview system performance during the upgrade. The key indicator is the length of time it takes from the beginning to the end of the deployment process. This should include backup and validation. You can incorporate this information into the update schedule.

If possible, use hardware in the test environment that has equivalent performance capabilities to the production servers.

Conseil :
Consider the use of a test farm in a virtual environment. After you finish the tests, you can shut down the virtual farm and use it later for future updates.

Evaluate techniques

A test farm also enables you to evaluate the techniques that you plan to use to update the production environment. In addition to testing and assessing your downtime reduction strategy, you can refine update monitoring. This is especially important in the areas of validating and troubleshooting the software update.

Implement

The update strategy that you use will determine whether you have to build a new farm or deploy the update on the current farm servers.

Build or update farms

Whether you build a new farm or do an in-place update, the most important farm elements to consider are as follows:

  • Content

  • Services

  • Service applications

Deploy customizations

Use solutions whenever possible so that you can quickly deploy any customizations.

Reduce downtime

Reduce downtime by using techniques such as read-only databases and update parallelism. For more information, see Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Monitor progress

The refined techniques that you use to monitor the software update in the test environment carry over to deploying the update in the production environment. Use the Upgrade and Migration page in Central Administration to monitor the status indicators that are available. This feature enables live monitoring and provides a single location to view the patch status for all farm servers. Additionally, you can use the Upgrade and Migration page to view the update status for individual servers and the status and type of farm databases. Finally, a valuable aspect of monitoring by using Central Administration is identifying farm servers that must be updated.

The following tables describe the status information that is available in Central Administration.

Status value | Description | Hyperlink
No action required | Farm server does not currently require any action to be taken by the administrator. | No hyperlink
Installation required | Farm server is missing an .msi file that is set to mandatory for all farm servers, or has a patch level below the individual farm-wide effective patch version. | Hyperlink to the Patch Deployment State page
Upgrade in progress | Farm server is currently undergoing an upgrade operation. | Hyperlink to the Upgrade Status page
Upgrade available | Farm server is running in backward-compatibility mode. | Hyperlink to the Upgrade and Migration page
Upgrade required | Farm server is outside the backward-compatibility mode range with one or more databases. | Hyperlink to the Upgrade and Migration page
Upgrade blocked | If an upgrade is available and any farm server requires installation, the remaining servers that do not require installation will be set to this status unless they are currently undergoing an upgrade. | Hyperlink to the Patch Deployment State page

Status value | Description
Installed | Indicates that no action is required
Missing/Required | Displayed if a product is required on each server or if a patch for a specific .msi file is located on one server but not on the server for which this status is shown
Missing/Optional | Displayed if a product is not required on each server
Superseded | Displayed if an update is no longer required on a server because a newer patch supersedes it

Other tools to monitor the update process are log files and Windows PowerShell commands.

Important :
Remember to monitor the length of time that the update is taking. Compare current update processes against the benchmark schedule to determine whether the update will meet the downtime window. If not, you should communicate this information to the farm users.

Validate

You can start to validate the success of the update during the implementation phase and continue validation after the update is implemented.

Logged event failures

Review the event logs to discover any issues that occurred during the deployment. Resolve these issues and then resume or restart the update as appropriate.

User interface or experience issues

Any user interface or user experience issues will surface on site pages. Look for the following issues:

  • Ghosting

  • User interface version mismatch

  • HTML and XHTML compliance

Additional issues may include missing templates, user identifiers, and content issues such as large lists.

Data issues

Data issues result from the condition of the farm databases and can include all or some of the following:

  • Connectivity issues to data sources

  • Database corruption

  • Orphaned items

  • Hidden column data

In some cases there may be minor issues that you can troubleshoot and then resume or restart the update. Be prepared to roll back the update as soon as there are issues that cannot be easily resolved.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Prepare to deploy a software update (SharePoint Foundation 2010) (en anglais)

This article describes the required and recommended tasks that have to be completed before you install software updates on servers in a Microsoft SharePoint Foundation 2010 farm.

In this article:

  • Verify account permissions and security settings

  • Determine the update approach

  • Back up the environment

  • Document the environment

  • Determine whether related items need to be updated

  • Obtain the software update and prepare the installation source (optional)

Verify account permissions and security settings

Verify that you have the required account permissions and know which security settings are in place on the farm. For more information, see Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

Determine the update approach

There are two basic options for deploying a software update on a farm: in-place and database attach. Additionally, these options can be combined to use one of the hybrid approaches that are described in Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Remarque :
Because installing a software update is a subset of a software upgrade, documentation about software upgrades applies to deploying software updates.

The differences between the two update approaches are as follows:

  • In-place update: This approach is the easiest to do. With this method, the amount of downtime required is directly related to the size and complexity of the farm. You have two choices for an in-place update:

    • In-place without backward compatibility - The update is installed on all the farm servers at the same time and the content is upgraded without using backward compatibility. No downtime reduction is available for this method.

    • In-place with backward compatibility to reduce downtime - The update is installed in stages and uses postponed upgrade with backward compatibility to reduce downtime.

  • Database attach: This approach is more complex than an in-place update, and it costs more in person time and hardware resources. This update method uses two farms to provide high availability for existing content.

When you use either the in-place with backward compatibility method or the database attach method, you can use a postponed upgrade so that you can choose to upgrade the content first and then the farm and servers afterward.

We recommend that you use the following flowchart, which presents the key decision points and subsequent actions, for determining which update approach to use.

Organigramme de décision pour déterminer la stratégie de mise à jour

Whichever method you choose to use for updating your servers, you can use either the Assistant Configuration des produits SharePoint or Windows PowerShell cmdlets to upgrade your content.

Back up the environment

To ensure that you can recover the existing environment in case something goes wrong during the update deployment process, we recommend that you back up the SharePoint Foundation 2010 environment before you start to install the update. A failed software update can be caused by factors other than the update process, such as the following:

  • Media failure

  • User errors (such as deleting a file by mistake)

  • Hardware failures (such as a damaged hard disk or permanent loss of a server)

  • Power failures

  • Natural disaster

You can back up all or part of a farm. The following list summarizes the farm components that can be backed up individually:

  • Configuration settings

  • Web applications

  • Service applications

  • Site collections

  • Logs

For more information about how to determine what you need to back up and which method to use to do so, see Planifier la sauvegarde et la récupération (SharePoint Foundation 2010). After you determine which farm elements you will back up, refer to the articles listed in Sauvegarde (SharePoint Foundation 2010). These articles provide detailed instructions and guidance for backing up all or part of a farm.

Important :
Test the farm backups before you start to deploy the software update. You have to be sure that these backups are valid so that you can recover if there is a hardware failure or data corruption during the update process.

Document the environment

Be sure to document the farm, including any custom components in the farm, in case you need to rebuild. For more information about creating an inventory of customizations, see Identifier et installer les personnalisations in the Upgrade guide. In addition, document unique things about your farm, such as the following:

  • Any large lists

  • Any sites with large access control lists (ACLs)

  • Any sites that are critical to your organization

Having a list of these items will help you more quickly validate your environment after you apply an update.

Determine whether related items need to be updated

Consider whether the following related items need to be updated when you update your farm:

  • Filter packs

  • Office Web applications

  • Language packs

All these items are updated separately from SharePoint Foundation 2010. Check to see if any updates to these items are available, and evaluate whether you want to apply the updates to your farm when you apply the updates for SharePoint Foundation 2010. Language packs are usually only updated when service packs (SP1, SP2, and so on) are released.

Obtain the software update and prepare the installation source (optional)

If the servers on which you want to install SharePoint Foundation 2010 are isolated from the Internet, it is usually necessary to install software updates from an offline location. Even if the servers are not isolated, if you install software updates from an offline central location, you can ensure farm server consistency by installing a well-known and controlled set of images. Use the following procedure to prepare a software update for installation on a farm server.

You do not need to perform this procedure if you are downloading and installing the update directly to your servers.

To prepare an installation source

  1. Download the software update that you want to install.

  2. Extract the software update to a shared location by using the following command:

    <package> /extract:<path>

    The /extract switch prompts you to provide a folder name for the files. An example of a folder name for x64 systems is as follows:

    sps-kb999999-x64-fullfile-en-us.exe /extract:<\\computername\updateshare\Updates>

  3. Copy the extracted files from the shared location to an Updates folder that you create on the computer where you want to start to install the update.

    Remarque :
    You must use the name Updates for this updates folder. If you use the SupdateLocation="path-list" property to specify a different location, Setup stops responding.

You can now use this location as an installation point, or you can create an image of this source that you can burn to physical media or save as an ISO file.

Slipstream package

In server farm deployments, all the Web servers must have the same software update version applied. This means that, before you add a new Web server to an existing server farm, the new Web server must have the same software updates as the rest of the Web servers in your server farm. Likewise, when you create a farm, all servers in the farm must have the same software updates. To make sure that all new servers have the same software updates applied, we recommend that you create an installation source that contains a copy of the release version of the software, together with software updates that match those installed on your server farm (also known as a slipstreamed installation source). When you run Setup from this updated installation source, the new Web server will have the same software update version as the rest of the Web servers in your server farm. For more information, see Create an installation source that includes software updates (Office SharePoint Server 2007) [http://technet.microsoft.com/en-us/library/cc261890(office.12).aspx].

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Install a software update (SharePoint Foundation 2010) (en anglais)

This article describes how to install a software update on servers in a Microsoft SharePoint Foundation 2010 farm. Additionally, three example scenarios are discussed and an update procedure is provided for each scenario.

In this article:

  • Verify the update strategy

  • Monitor installation progress

  • Handle update failures

  • Review update scenarios

  • Use the in-place method without backward compatibility

  • Use the in-place method with backward compatibility

  • Use the database attach method for high availability of existing content

  • Verify update completion and success

Verify the update strategy

Before you start to deploy the software update, verify that the update strategy that you plan to use is optimal for your Microsoft SharePoint Foundation environment. There are several factors, such as downtime reduction, cost, and complexity that determine which strategy to use to deploy a software update. Use the flowchart in the "Determine Update Strategy" section of Prepare to deploy a software update (SharePoint Foundation 2010) (en anglais) to verify the update strategy that you want to use: in-place, database attach, or a hybrid.

Monitor installation progress

Monitor the update deployment process during the update to verify that the update is proceeding as planned. There may be issues that will block the update or that will result in an updated farm that has elements that do not work as expected. Pay extra attention to database synchronization and customizations.

We recommend that you use the Upgrade and Migration view in Central Administration as the primary tool for viewing product and patch installation status, data status, and upgrade status in real time.

After Setup runs, you can also view the log files and use Windows PowerShell to obtain the current results of the installation progress.

Handle update failures

SharePoint Foundation 2010 provides an improved approach to handling upgrade failures after the patching phase finishes. If an update fails and you are running in backward compatibility mode, you can restore the SharePoint Foundation database and continue to run in backward compatibility mode. After the update issue is resolved for the site, you can resume the upgrade. Any tasks that were completed are not run again. For more information, see Test de la mise à niveau et résolution des problèmes liés à celle-ci (SharePoint Foundation 2010).

If an update failed in earlier SharePoint Products and Technologies environments, you usually had to uninstall the product, install the older version, and then restore from a backup.

Review update scenarios

The following software update scenarios are discussed in this article:

  • In-place without backward compatibility - The update is installed on all the farm servers at the same time and the content is upgraded without using backward compatibility.

  • In-place with backward compatibility to reduce downtime - The update is installed in stages and uses deferred upgrade with backward compatibility to reduce downtime.

  • Database attach for high content availability - This update uses two farms to provide high availability for existing content.

For more information about how the in-place and database attach processes work, see the diagrams in the following article: Présentation du processus de mise à niveau (SharePoint Foundation 2010). Note that these articles are about how to upgrade across software versions, not how to install software updates. However, the general process is very similar.

The following illustration shows the farm topology that is used as an example for each patching scenario that is described in this article.

Exemple de batterie de serveurs pour installation de mises à jour logicielles

Initial state and required conditions

The preceding illustration shows the initial state of the farm before you install the update. Verify that the following conditions are true:

  • All the front-end Web servers are load balanced together and are in rotation with the load balancer.

  • All the farm servers are operating correctly.

  • All the databases are active and operating correctly.

Do not start the software if any of the preceding conditions are not true. Resolve all issues before you continue.

Use the in-place method without backward compatibility

In this scenario the complete farm is shut down by disabling incoming requests to the front-end Web servers and then installing the update on all the farm servers. This strategy combines the update and the upgrade phase described in the "Software Update Process" section in Software updates overview (SharePoint Foundation 2010) (en anglais).

The following illustration shows the sequence of steps to follow to install the update on the farm.

Applications de mises à jour sur place, sans compatibilité descendante

Use the preceding illustration as a guide for using the recommended steps in the following procedure.

To install an update without backward compatibility

  1. Remove the Web servers (WEB-1 to WEB-4) from rotation in the load balancer, or pause the load balancer to stop incoming requests to the servers.

  2. Run the executable file to install the update on the Web server that hosts Central Administration (WEB-4).

  3. Verify that the server was updated successfully.

  4. Log on to the first Web server (WEB-1).

  5. Run the executable file to install the update on the Web server.

  6. Run the executable file to install the update on the remaining Web servers (WEB-2 and WEB-3).

  7. Verify that all the servers were updated successfully.

  8. Run the Assistant Configuration des produits SharePoint on the Central Administration server (WEB-4) to upgrade the configuration database and upgrade each content database serially.

  9. Run the Assistant Configuration des produits SharePoint on the first Web server (WEB-1).

    Remarque :
    Run the configuration wizard to ensure that if the update fails for a specific server, the error is not propagated to the other Web servers. For example, a failed upgrade for one server could make the upgrade fail for one or more site collections.

  10. Repeat the preceding step for each remaining Web server.

  11. Verify update completion and success. For more information, see Verify update completion and success.

  12. Add the Web servers (WEB-1 to WEB-4) to the rotation in the load balancer, or start the load balancer to enable incoming requests to the servers.

Use the in-place method with backward compatibility

This scenario takes advantage of the backward compatibility of SharePoint Foundation 2010 and the deferred upgrade feature to reduce the downtime that is required to deploy a software update. However, downtime is not completely eliminated. The sites and services will not be available while the content is being upgraded.

This software update scenario uses two phases to install the update on farm servers. These phases are as follows:

  • Update to install the update on the farm servers.

  • Upgrade to complete the patching process.

During the update phase, the farm can continue to be in production with minimal to no downtime. However, during the upgrade phase, the farm will be unavailable. If you attempt to access content while the farm is upgrading, the result could be failed upgrades or excessive slowdowns in the upgrade process because of resource contention and locking. Such an attempt is unsupported and untested.

For more information about the software update process, see "The Software Update Process" section in Software updates overview (SharePoint Foundation 2010) (en anglais).

Update phase

The following illustration shows the sequence of steps that are required to install the update on the farm.

Mise à jour sur place avec compatibilité descendante

Use the preceding illustration as a guide for using the recommended steps in the following procedure.

To install the update on farm servers

  1. Remove half of the Web servers (WEB-1 and WEB-2) from rotation in the load balancer, or pause the load balancer to stop incoming requests to the servers.

  2. Run the executable file to install the update on each Web server that is out of the load-balancing rotation (WEB-1 and WEB-2). Do not run the Assistant Configuration des produits SharePoint on either of these servers. Verify that both of the Web servers were updated successfully.

  3. Remove the remaining Web servers (WEB-3 and WEB-4) from rotation in the load balancer, or pause the load balancer to stop incoming requests to the servers. At this point none of the front-end Web servers are receiving requests for the farm.

  4. Add the updated Web servers (WEB-1 and WEB-2) back into the load-balancing rotation.

  5. Run the executable file to install the update on each Web server that is still out of the load-balancing rotation. Do not run the Assistant Configuration des produits SharePoint on either of these servers. Verify that both of the Web servers were updated successfully.

  6. Add the updated Web servers (WEB-3 and WEB-4) back into the load-balancing rotation.

  7. Verify update completion and success. For more information, see Verify update completion and success.

At this point in the process, the databases and other components such as settings, features, and site-level data must still be upgraded because the Assistant Configuration des produits SharePoint was not run on any of the farm servers. However, the farm should be capable of running in backward compatibility mode.

Upgrade phase

The following illustration shows the sequence of steps that are required to finish the patching process by upgrading the farm servers. During this process, the sites that are being upgraded will not be available to users.

Phase de mise à niveau

Use the preceding illustration as a guide for using the recommended steps in the following procedure.

Important :
Monitor the status of the upgrade on each server before you upgrade the next server in the sequence. It is highly recommended that you create a backup of the farm before beginning upgrade.

The following procedure shows all the steps to upgrade the farm. You can upgrade all components within the same outage window, or you can take some smaller outage windows and upgrade separate parts of the farm at different times. If you want to break up the upgrade stage, you can upgrade the following components in separate outage windows:

  • Services

    If the software update contains updates to services that must be applied, you can upgrade the service, and then resume operating the farm (steps 6 and 7 in the procedure) until it is possible to take a longer farm outage to complete the content and farm upgrade.

  • Content databases

    You can take a short farm outage to upgrade only a few content databases (steps 1 through 3 in the procedure) each time and then resume farm operation (steps 6 and 7). You can repeat the process over successive outage windows until all content is upgraded and the farm servers are ready to be upgraded.

    You can also upgrade individual content databases in parallel for a very small number of content databases at the same time. However, do not attempt to upgrade too many content databases in parallel because it will slow down the overall upgrade process and extend the outage time. We recommend that you do not upgrade more than two content databases on the same Microsoft SQL Server volume at a time and that you stage the starting time of the upgrade for each content database that will occur in parallel by several minutes to prevent lock contention as the upgrade process starts. In addition, limit the number of content databases that are being upgraded on a single Web or application server because each additional upgrade process will consume a relatively large amount of resources. The typical number of content databases that can be upgraded per Web or application server is four databases. However, be sure not to exceed the number of databases that are being upgraded per SQL Server volume, no matter which Web or application server originates the upgrade.

To upgrade the farm

  1. Remove the Web servers (WEB-1 to WEB-4) from rotation in the load balancer, or pause the load balancer to stop incoming requests to the servers.

    Important :
    The sites and services will not be available until upgrade is complete and the servers are returned to an active load-balancing state.

  2. Upgrade specific services, as needed.

    Some updates might also require you to run additional Windows PowerShell cmdlets to upgrade specific service applications. If the notes for the software update indicate that a specific service must be upgraded so that it will continue to operate after patching, as in the case in which a service cannot operate in backward compatibility mode, a short farm outage can be taken so that the service can be upgraded without having to upgrade the complete farm. The additional Windows PowerShell cmdlets to upgrade specific service applications should be indicated in the notes if this is required.

  3. Use the Windows PowerShell Upgrade-SPContentDatabase cmdlet to upgrade each content database.

    This is an optional step, but it will help ensure that all content databases are upgraded first. It has the advantage of enabling some parallelism to reduce the outage time. If it is not performed, all remaining non-upgraded content databases will be upgraded serially when you run the Assistant Configuration des produits SharePoint to upgrade the farm servers.

    Important :
    Run the Upgrade-SPContentDatabase cmdlet for each database. You can run this cmdlet from any of the upgraded Web servers or application servers. Note that the content for each database will be unavailable while this process is running on that database.

  4. Run the Assistant Configuration des produits SharePoint on the Central Administration server (WEB-4).

    Important :
    The Assistant Configuration des produits SharePoint also starts an immediate upgrade of the configuration database and any other databases that are not already upgraded. Because it is likely that the content databases are the only databases that have already been upgraded, as described in the previous step, all the service application databases are also upgraded in this step. Your sites will not be available while this process runs.

  5. Run the Assistant Configuration des produits SharePoint on the remaining Web servers (WEB-1 to WEB-3).

  6. Verify update completion and success. For more information, see Verify update completion and success.

  7. Add the upgraded Web servers (WEB-1 to WEB-4) back into rotation in the load balancer.

Use the database attach method for high availability of existing content

To ensure high availability for existing content, this scenario uses read-only databases on the existing farm. The update is installed on a new farm and user traffic is rerouted to this farm.

The following illustration shows the sequence of steps to follow to install the update on a new farm by using the database attach method. For more information, see Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010.

Application de mises à jour avec temps d'arrêt minimal

Use the preceding illustration as a guide for using the recommended steps in the following procedure.

To install the update by using database attach

  1. Create a new farm where you will install the software update. This farm does not require front-end Web servers. For more information, see Préparer le nouvel environnement SharePoint Foundation.

    Remarque :
    If the original farm uses a database mirror, you must configure mirroring after you finish deploying the software update on the new farm.

  2. Configure the databases on the existing farm so that they are in a read-only state.

    Remarque :
    If the existing farm is mirrored, you must pause mirroring before setting the databases to read-only.

    For more information about how to configure read-only databases, see the "Set the Previous Version Databases to Be Read-Only (Database Attach with Read-Only Databases)" section in Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010 and Faire fonctionner une batterie qui utilise des bases de données en lecture seule (SharePoint Foundation 2010).

  3. Configure the service application databases on the existing farm so that they are in a read-only state. This prevents unexpected changes to service applications.

  4. Back up the content databases on the existing farm. For more information, see Sauvegarde et récupération (SharePoint Foundation 2010).

  5. Restore the content databases to the new database server.

  6. Create service applications on the new farm for each existing service application in the old farm.

    You must duplicate all the settings from your existing farm.

  7. Use database attach to create the databases on the new farm. For more information, see Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010 and Attacher et restaurer une base de données de contenu en lecture seule (SharePoint Foundation 2010).

  8. Verify that there are no issues with the new farm.

  9. Enable the new farm as the production farm by configuring DNS to point to the new farm or by making sure that the new farm is load balanced. Verify that users can access the new farm.

  10. Allow time for users to switch from cached DNS, and then decommission the old farm.

  11. Verify update completion and success. For more information, see Verify update completion and success.

Verify update completion and success

Regardless of the update strategy that you use and the monitoring that you do during the software update, you must verify update completion and success. For more information, see Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Historique des modifications

Date | Description | Raison
2011/01/17 | 2011/01/17 | Mise à jour du contenu
8 juillet 2010 | Publication initiale |


Mise à niveau vers SharePoint Foundation 2010
Voir aussi

Bienvenue dans le guide de mise à niveau pour Microsoft SharePoint Foundation 2010. Les articles de ce guide vous aident à planifier et à effectuer une mise à niveau depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010.

Pour une vue d'ensemble graphique du processus de mise à niveau et des informations sur la planification et le test de la mise à niveau, voir les modèles de mise à niveau suivants :

  • Planification de la mise à niveau (éventuellement en anglais)

  • Approches de mise à niveau (éventuellement en anglais)

  • Test du processus de mise à niveau (éventuellement en anglais)

Dans ce guide :

  • À propos du processus de mise à niveau (SharePoint Foundation 2010)

    Découvrez les nouvelles fonctionnalités de mise à niveau et le fonctionnement du processus de mise à niveau.

  • Planifier et préparer la mise à niveau (SharePoint Foundation 2010)

    Déterminez l'approche à adopter pour effectuer une mise à niveau vers SharePoint Foundation 2010 et planifier votre processus de mise à niveau.

  • Test de la mise à niveau et résolution des problèmes liés à celle-ci (SharePoint Foundation 2010)

    Découvrez comment tester votre processus de mise à niveau à l'avance pour comprendre quels sont les problèmes susceptibles d'affecter votre mise à niveau réelle et déterminer la durée et l'espace nécessaires pour la mise à niveau. En outre, découvrez comment résoudre les problèmes qui se produisent pendant la mise à niveau réelle.

  • Effectuer les étapes préalables à la mise à niveau (SharePoint Foundation 2010)

    Découvrez les étapes à suivre avant la mise à niveau, notamment les informations relatives à l'exécution de l'outil de vérification de pré-mise à niveau.

  • Effectuer une mise à niveau sur place (SharePoint Foundation 2010)

    Suivez les étapes indiquées dans cette section si vous effectuez une mise à niveau sur place vers SharePoint Foundation 2010. Lorsque vous effectuez une mise à niveau sur place, vous installez SharePoint Foundation 2010 sur le même matériel, puis vous mettez à niveau le contenu et les paramètres sur le serveur ou la batterie de serveurs dans le cadre d'un même processus.

  • Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant)

    Suivez les étapes de cette section si vous disposez d'une installation autonome dont les bases de données de contenu ont une taille proche de 4 Go.

  • Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010

    Suivez les étapes indiquées dans cette section si vous utilisez la méthode de mise à niveau avec liaison des bases de données pour effectuer une mise à niveau vers SharePoint Foundation 2010. Lorsque vous utilisez la méthode de mise à niveau avec liaison des bases de données, vous mettez à niveau le contenu pour l'environnement sur une batterie de serveurs distincte.

  • Effectuer les étapes postérieures à la mise à niveau (SharePoint Foundation 2010)

    Découvrez comment savoir si la mise à niveau a réussi et les étapes à effectuer après la mise à niveau pour que les utilisateurs puissent à nouveau profiter de votre environnement.

  • Migrer de l'authentification basée sur les formulaires à l'authentification basée sur les revendications (SharePoint Foundation 2010)

    Cet article fournit des instructions pour vous aider à migrer des applications Web Windows SharePoint Services 3.0 existantes qui ont été configurées de façon à utiliser l'authentification basée sur les formulaires de sorte qu'elles fonctionnent dans un environnement Microsoft SharePoint Foundation 2010 comme applications Web basées sur les revendications.

  • Migrer de l'authentification en mode classique à l'authentification basée sur les revendications (SharePoint Foundation 2010)

    Les procédures de cet article ont pour but de vous aider à migrer des applications Web Microsoft SharePoint Server 2010 existantes qui ont été configurées de façon à utiliser l'authentification en mode classique de sorte qu'elles utilisent l'authentification basées sur les revendications.

Voir aussi

Concepts

Utilisation de redirection d'URL AAM dans le processus de mise à niveau (SharePoint Foundation 2010) (livre blanc)

Historique des modifications


À propos du processus de mise à niveau (SharePoint Foundation 2010)

La première étape de tout processus de mise à niveau consiste à étudier le processus proprement dit afin de pouvoir effectuer correctement les phases de planification et de préparation. Cette section du guide de mise à niveau contient des articles qui vous aident à assimiler le fonctionnement de la mise à niveau.

Dans cette section :

  • Nouveautés de la mise à niveau (SharePoint Foundation 2010)

    Découvrez les nouvelles contraintes, approches et fonctionnalités pouvant entrer en jeu dans une mise à niveau vers Microsoft SharePoint Foundation 2010.

  • Présentation du processus de mise à niveau (SharePoint Foundation 2010)

    Ayez un aperçu visuel des étapes à suivre dans chaque approche de mise à niveau.

  • Mise à niveau depuis Windows SharePoint Services 2.0 vers SharePoint Foundation 2010

    Assimilez l'utilisation de mises à niveau avec liaison des bases de données pour mettre à niveau votre contenu depuis Windows SharePoint Services 2.0 vers Microsoft SharePoint Foundation 2010.

Historique des modifications


Nouveautés de la mise à niveau (SharePoint Foundation 2010)

Microsoft SharePoint Foundation 2010 a été conçu dans une optique d'évolutivité et de performance ; par conséquent, il requiert un matériel récent et une configuration logicielle conforme à la description fournie dans cet article. Ces exigences s'appliquent à la fois aux approches de mise à niveau sur place et de mise à niveau avec attachement des bases de données. Pour plus d'informations, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Pour faciliter une mise à niveau conforme aux attentes et réduire l'impact des problèmes de personnalisation et d'environnement susceptibles de provoquer l'échec de la mise à niveau, vous pouvez utiliser l'applet de commande Windows PowerShelltest-spcontentdatabase, la nouvelle option de mise à niveau visuelle ou l'opération Stsadm preupgradecheck.

Dans cet article :

  • Configuration requise pour la mise à niveau

  • Outil de vérification préalable à la mise à niveau

  • Commande Windows PowerShell pour vérifier des bases de données avant la connexion

  • Mise à niveau visuelle

  • Mise à niveau de composants fonctionnels

  • Nouvelles options de réduction du temps d'interruption lors d'une mise à niveau

  • Modifications des fonctionnalités clés entre les versions

Configuration requise pour la mise à niveau

Avant de pouvoir effectuer une mise à niveau sur place ou une mise à niveau avec attachement des bases de données vers SharePoint Foundation 2010, votre environnement Windows SharePoint Services 3.0 existant ou votre nouvel environnement SharePoint Foundation 2010 doit répondre aux conditions minimales requises suivantes.

Remarque :
Pour plus d'informations sur la configuration requise de manière générale pour SharePoint Foundation 2010, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010). Pour plus d'informations sur les conditions préalables à la mise à niveau, voir Examiner la configuration requise pour la mise à niveau (SharePoint Foundation 2010).

Configuration matérielle requise : 64 bits

SharePoint Foundation 2010 ne peut s'exécuter que sur une édition 64 bits du système d'exploitation Windows Server 2008 R2 ou Windows Server 2008 avec SP2. Si vous envisagez d'effectuer une mise à niveau sur place, votre installation Windows SharePoint Services 3.0 doit s'exécuter dans un environnement Windows Server 2008 64 bits. Si votre installation Windows SharePoint Services 3.0 s'exécute actuellement dans un environnement 32 bits, vous ne pouvez pas effectuer de mise à niveau sur place sur le serveur ou la batterie de serveurs existants. Vous devez installer SharePoint Foundation 2010 sur un serveur ou une batterie de serveurs différents, prenant en charge les applications 64 bits, puis migrer vos données vers ce serveur ou cette batterie de serveurs en utilisant une mise à niveau avec attachement des bases de données.

Pour détecter et gérer plus facilement les problèmes au cours des processus de migration et de mise à niveau, il est recommandé de ne pas combiner la migration d'un environnement 64 bits et la mise à niveau sur place vers SharePoint Foundation 2010. Dans la mesure où vous devez disposer d'un environnement 64 bits pour pouvoir effectuer la mise à niveau sur place vers SharePoint Foundation 2010, vous devez migrer vers un système d'exploitation 64 bits avant d'effectuer une mise à niveau sur place. Si vous utilisez une mise à niveau de connexion de base de données, vous pouvez migrer vers un environnement 64 bits dans le cadre du processus de mise à niveau.

Avant de migrer vers un environnement 64 bits :

  • Mettez Windows SharePoint Services 3.0 à niveau vers le même Service Pack ou le même niveau de mise à jour de logiciels sur tous les ordinateurs de la batterie de serveurs.

  • Déterminez si vous devez recompiler les applications et assemblys 32 bits existants (par exemple, les composants WebPart et les récepteurs d'événements) à exécuter dans l'environnement 64 bits. (Certaines applications peuvent être exécutées dans les deux environnements et n'ont pas besoin d'être recompilées.) Si les applications existantes sont des applications tierces, vérifiez les versions 64 bits et leur compatibilité auprès du fournisseur des applications en question.

Pour plus d'informations sur la planification et la réalisation d'une migration vers un environnement 64 bits, voir l'article Migration d'une batterie de serveurs existante vers un environnement 64 bits (Windows SharePoint Services 3.0) sur TechNet (http://go.microsoft.com/fwlink/?linkid=161120&clcid=0x40C).

Configuration requise en matière de système d'exploitation : Windows Server 2008 ou Windows Server 2008 R2

SharePoint Foundation 2010 doit s'exécuter sur une édition 64 bits de Windows Server 2008 R2 ou Windows Server 2008 avec Service Pack 2 (SP2). Si actuellement Windows SharePoint Services 3.0 s'exécute sur Windows Server 2003 et si vous comptez le mettre à niveau vers SharePoint Foundation 2010, vous devez planifier un nombre suffisant de licences Windows Server pour le déploiement sur le système d'exploitation plus récent.

Pour détecter et gérer plus facilement les problèmes au cours des processus de migration et de mise à niveau, il est recommandé de ne pas combiner la mise à niveau ou la migration vers Windows Server 2008 ou Windows Server 2008 R2 à la mise à niveau vers SharePoint Foundation 2010. Vous pouvez combiner la migration vers du matériel 64 bits à la migration vers Windows Server 2008 ou Windows Server 2008 R2.

  • Si vous fonctionnez déjà sur du matériel 64 bits, vous pouvez mettre à niveau de Windows Server 2003 vers Windows Server 2008 ou Windows Server 2008 R2. Pour plus d'informations sur la mise à niveau sur place vers Windows Server 2008, voir l'article Mise à niveau vers Windows Server 2008 pour Windows SharePoint Services 3.0 avec Service Pack 1 sur TechNet (http://go.microsoft.com/fwlink/?linkid=155575&clcid=0x40C).

  • Si vous migrez vers du matériel 64 bits, profitez-en pour migrer également vers Windows Server 2008 ou Windows Server 2008 R2. Pour plus d'informations sur l'installation de Windows SharePoint Services 3.0 sur Windows Server 2008, voir l'article Déployer une batterie de serveurs simple sur le système d'exploitation Windows Server 2008 (Windows SharePoint Services) sur TechNet (http://go.microsoft.com/fwlink/?linkid=95859&clcid=0x40C).

Base de données requise : SQL Server 2005 SP3 ou SQL Server 2008 SP1

SharePoint Foundation 2010 nécessite que son serveur de bases de données soit une version 64 bits de : Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3. Si l'installation Windows SharePoint Services 3.0 actuelle utilise SQL Server 2000, vous devez la mettre à niveau vers l'une de ces versions avant de pouvoir mettre à niveau vers SharePoint Foundation 2010.

Pour détecter et gérer plus facilement les problèmes au cours des processus de migration et de mise à niveau, il est recommandé de ne pas combiner la migration vers la version 64 bits de SQL Server à la mise à niveau vers SharePoint Foundation 2010. Vous pouvez combiner la migration vers SQL Server 64 bits au processus global de migration vers le matériel 64 bits.

  • Si vous combinez la migration vers SQL Server 2005 SP3 ou SQL Server 2008 sur du matériel 64 bits, avec une migration globale vers un environnement 64 bits, suivez les instructions de migration vers un environnement 64 bits au début de cet article.

    Pour plus d'informations sur la migration de toutes les bases de données, voir l'article Déplacer toutes les bases de données (Windows SharePoint Services 3.0) sur TechNet (http://go.microsoft.com/fwlink/?linkid=161208&clcid=0x40C).

  • Si vous utilisez déjà du matériel 64 bits, mais que vous devez effectuer une mise à niveau vers SQL Server 2005 SP3 ou SQL Server 2008, suivez les instructions de la documentation SQL Server.

Outil de vérification préalable à la mise à niveau

L'outil de vérification préalable à la mise à niveau est un outil en ligne de commande qui s'exécute dans un environnement Windows SharePoint Services 3.0 pour détecter les problèmes potentiels de mise à niveau et examiner les meilleures pratiques et les recommandations.

STSADM.exe -o preupgradecheck

L'outil de vérification préalable à la mise à niveau vous fournit les informations suivantes :

  • Liste de tous les serveurs et composants d'une batterie de serveurs et nécessité pour les serveurs de répondre à une configuration requise : matériel 64 bits et système d'exploitation Windows Server 2008.

  • URL des mappages des accès de substitution utilisées dans la batterie de serveurs.

  • Liste de l'ensemble des définitions de site, de modèles de site, de fonctionnalités et de modules linguistiques installés dans la batterie de serveurs.

  • Présence de personnalisations dans la batterie de serveurs qui ne sont pas prises en charge (modifications du schéma de base de données, par exemple).

  • Présence de bases de données ou d'orphelins de site dans la batterie de serveurs.

  • S'il existe des paramètres de configuration manquants ou non valides dans la batterie de serveurs (comme un fichier Web.config manquant, des noms d'hôtes non valides ou des comptes de service non valides).

  • Conformité des bases de données à la configuration requise pour la mise à niveau. Par exemple, les bases de données sont définies comme étant en lecture/écriture, et les bases de données et les collections de sites stockées dans Base de données interne Windows ne sont pas supérieures à 4 Go.

L'outil de vérification préalable à la mise à niveau est disponible avec Windows SharePoint Services 3.0 Service Pack 2 et a été mis à jour dans la mise à jour cumulative d'octobre 2009 pour Windows SharePoint Services 3.0. Vous pouvez télécharger et installer cette mise à jour à partir de la page Les packages de mise à jour cumulative d'octobre 2009 pour SharePoint Server 2007 et Windows SharePoint Services 3.0 sont publiés (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=169179&clcid=0x40C). Pour plus d'informations sur l'utilisation de l'outil de vérification préalable à la mise à niveau, voir les articles suivants sur TechNet :

  • Preupgradecheck : opération Stsadm (Windows SharePoint Services) (http://go.microsoft.com/fwlink/?linkid=161232&clcid=0x40C)

  • Analyse et rapport préalables à la mise à niveau vers des versions ultérieures (Windows SharePoint Services) (http://go.microsoft.com/fwlink/?linkid=152468&clcid=0x40C)

  • Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010)

Commande Windows PowerShell pour vérifier des bases de données avant la connexion

Vous pouvez utiliser l'applet de commande Windows PowerShelltest-spcontentdatabase avant d'attacher une base de données de contenu à SharePoint Foundation 2010 afin de déterminer si des personnalisations côté serveur manquent dans l'environnement. Pour plus d'informations, voir Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010 et Test-SPContentDatabase.

Mise à niveau visuelle

Une nouvelle fonctionnalité disponible avec la mise à niveau permet à l'administrateur ou au propriétaire du site de déterminer quand utiliser la nouvelle apparence pour SharePoint Foundation 2010, et si elle doit être utilisée, pour une collection de sites spécifique. L'administrateur du serveur peut choisir d'adopter la nouvelle apparence pour tous les sites lors d'une mise à niveau, de permettre aux propriétaires de sites de faire leur choix après la mise à niveau ou de conserver l'ancienne apparence pour tous les sites.

Si l'administrateur du serveur permet aux propriétaires de sites de faire leur choix après la mise à niveau d'un site à l'aide d'une mise à niveau sur place, une option d'aperçu est disponible dans l'interface utilisateur du site. Elle permet d'afficher un aperçu de l'apparence de SharePoint Foundation 2010 pour le site :

  • Si le propriétaire est satisfait de l'apparence et des fonctions du site, il peut accepter la mise à niveau visuelle.

  • Si le propriétaire souhaite que le site conserve l'ancienne apparence, il peut revenir à l'apparence Windows SharePoint Services 3.0.

Par défaut, l'aspect de Windows SharePoint Services 3.0 est conservé. Pour plus d'informations, voir Planifier une mise à niveau visuelle (SharePoint Foundation 2010).

Mise à niveau de composants fonctionnels

SharePoint Foundation 2010 fournit de nouveaux membres et types vous permettant de mettre à niveau des composants fonctionnels personnalisés par l'intermédiaire du contrôle de version et d'actions de mise à niveau déclaratives. Vous pouvez mettre à jour les composants créés pour que Windows SharePoint Services 3.0 fonctionne avec SharePoint Foundation 2010 à l'aide de ces membres. Pour plus d'informations, voir Mise à niveau de composants fonctionnels (éventuellement en anglais).

Nouvelles options de réduction du temps d'interruption lors d'une mise à niveau

En fonction de l'environnement, de la complexité et du nombre de sites SharePoint, la mise à niveau peut prendre du temps. Pour réduire le temps d'interruption au cours de ce processus, SharePoint Foundation 2010 prend en charge les options suivantes :

  • Mettre à niveau plusieurs bases de données en même temps (mise à niveau en parallèle) Lorsque vous procédez à la mise à niveau vers SharePoint Foundation 2010, vous pouvez lancer manuellement la mise à niveau de plusieurs bases de données en même temps en optant pour une approche de mise à niveau hybride avec détachement des bases de données. Dans Windows SharePoint Services 3.0, un seul processus de mise à niveau pouvait s'exécuter à la fois, de sorte que chaque base de données devait être traitée séquentiellement. Il y a un impact sur les performances lorsque vous procédez à la mise à niveau sur plusieurs bases de données plutôt que sur une seule, mais il est plus rapide de les mettre à niveau parallèlement que séquentiellement. Le nombre de bases de données qui peuvent être mises à niveau parallèlement dépend du matériel de votre environnement et de la structure du contenu des bases de données. Pour plus d'informations, voir Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010).

  • Utiliser des bases de données en lecture seule pour fournir un accès continu aux données Si vous utilisez une mise à niveau avec attachement des bases de données, et si vous définissez les bases de données d'origine en lecture seule, l'ancienne batterie de serveurs peut continuer à fournir le contenu aux utilisateurs pendant que vous mettez à niveau une copie des bases de données sur une nouvelle batterie de serveurs. De cette façon, les utilisateurs peuvent continuer à accéder aux données, mais ne peuvent ni ajouter ni mettre à jour des données. Lorsque la nouvelle batterie de serveurs est prête et que tout le contenu a été correctement mis à niveau, les utilisateurs peuvent basculer vers la nouvelle batterie.

    Pour plus d'informations sur les bases de données en lecture seule, voir l'article Faire fonctionner une batterie qui utilise des bases de données en lecture seule (Windows SharePoint Services).

Pour plus d'informations sur ces techniques de réduction du temps d'interruption, voir l'article Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Modifications des fonctionnalités clés entre les versions

SharePoint Foundation 2010 a une nouvelle architecture et inclut de nombreuses nouvelles fonctionnalités. Les tableaux suivants récapitulent certaines modifications clés de la terminologie et des fonctionnalités qui affectent directement l'administration et la gestion des sites après la mise à niveau.

Concept, terme ou fonctionnalité Nouveau ou modifié Commentaires

Outil de vérification préalable à la mise à niveau

Nouveau

L'outil de vérification préalable à la mise à niveau est une opération en ligne de commande Stsadm que vous exécutez dans un environnement Windows SharePoint Services 3.0 pour détecter les éventuels problèmes de mise à niveau, ainsi que pour revoir les recommandations et les meilleures pratiques.

Contrairement à l'outil d'analyse préalable à la mise à niveau (Prescan.exe) qui était utilisé lors de la mise à niveau vers Windows SharePoint Services 3.0, l'outil de vérification préalable à la mise à niveau n'apporte aucune modification à votre environnement. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

Site Web d'administration centrale de SharePoint

Modifié

Le site Web Administration centrale a été repensé afin de proposer les nouvelles options et fonctionnalités suivantes :

  • Le ruban vous permet d'afficher ou de modifier plus facilement les détails relatifs à une application Web en fournissant l'ensemble des options sur la même page. Pour plus d'informations sur les applications Web, voir Gérer des applications Web (SharePoint Foundation 2010).

  • Des Assistants Configuration ont été ajoutés afin de simplifier le processus de configuration en vous guidant tout au long des étapes qui permettent de configurer la batterie de serveurs. Pour plus d'informations, voir Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010).

  • Vous pouvez désormais effectuer une sauvegarde à partir de la page Sauvegarde et restauration. Pour plus d'informations, voir Sauvegarde (SharePoint Foundation 2010).

Ruban

Nouveau

L'interface utilisateur du ruban a été introduite pour garantir la cohérence de l'expérience utilisateur, ainsi que pour simplifier votre utilisation des sites SharePoint. Le ruban est contextuel ; par conséquent, vous ne voyez que les options correspondant aux tâches que vous souhaitez effectuer. Le ruban est également personnalisable.

Applications de service

Nouveau

La nouvelle architecture des services vous permet de gérer et de centraliser efficacement les services. Les services individuels peuvent être configurés indépendamment, et les sociétés tierces peuvent ajouter des services à la plateforme. Pour plus d'informations, voir Configurer les services (SharePoint Foundation 2010).

Pages maîtres

Modifié

Un propriétaire de site peut désormais appliquer une personnalisation à son site, indépendamment des autres sites ; par ailleurs, les administrateurs peuvent spécifier si les pages système du dossier _Layouts sont rendues à l'aide des pages maîtres du site fournies par les propriétaires de sites ou à l'aide des pages maîtres par défaut disponibles sur le système. En outre, il est possible d'utiliser Windows PowerShell pour spécifier une page maître de client aux pages d'erreurs système, pages de connexion, pages de confirmation et autres pages non spécifiques au site.

Thèmes

Modifié

SharePoint Foundation 2010 a changé le mode de fonctionnement des thèmes, en simplifiant leur personnalisation. Vous pouvez importer des thèmes Microsoft PowerPoint 2010 directement dans SharePoint Foundation 2010. En outre, les thèmes peuvent désormais être appliqués à tous les sous-sites à partir de cette interface. Pour plus d'informations, voir Planifier l'utilisation des thèmes (SharePoint Foundation 2010).

Services de connectivité d'entreprise

Nouveau

Business Connectivity Services repose sur la fonctionnalité du catalogue de données métiers disponible dans la précédente version du produit pour fournir l'accès aux systèmes externes à partir de solutions SharePoint. BCS prend en charge l'interaction avec les systèmes externes à l'aide de listes SharePoint et de composants WebPart ; en outre, il prend en charge l'interaction avec les données provenant des clients Office complets. Pour plus d'informations, voir Vue d'ensemble de Business Connectivity Services (SharePoint Foundation 2010).

Authentification basée sur les revendications

Nouveau

L'authentification basée sur les revendications est un nouveau modèle d'authentification plus puissant et plus souple qui fonctionne avec tous les systèmes d'identité d'entreprise, notamment les services de domaine Active Directory (AD DS), les annuaires LDAP, les bases de données spécifiques aux applications, ainsi que les nouveaux modèles d'identité centrés sur l'utilisateur tels que LiveID. Pour plus d'informations, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

Limitation et contrôles de listes

Nouveau

Il s'agit de deux nouveaux contrôles de performances. La limitation permet de contrôler les ressources du serveur et est conçue de sorte que ce dernier soit protégé contre les surcharges qui surviennent aux heures de forte activité. SharePoint Foundation 2010 fournit également plusieurs paramètres différents qui restreignent les requêtes pouvant être exécutées sur une grande liste. Ces paramètres sont configurables pour chaque application Web.

SharePoint Designer

Modifié

SharePoint Foundation 2010 fournit aux administrateurs un contrôle supplémentaire sur l'utilisation de SharePoint Designer dans chaque application Web ; par exemple, les administrateurs peuvent contrôler si les administrateurs de sites sont autorisés à personnaliser les pages maîtres et les pages de disposition, et s'ils peuvent gérer la structure des URL de leur site.

Tableau de bord du développeur

Nouveau

Il s'agit d'un nouvel ajout aux diagnostics du serveur. Il permet d'afficher des informations détaillées sur chaque chargement de page et de résoudre, par conséquent, les problèmes de performance.

Solutions en mode bac à sable

Nouveau

Vous pouvez désormais permettre aux administrateurs de sites de télécharger du code utilisateur personnalisé à l'aide des solutions en mode bac à sable. Pour plus d'informations, voir Planification de solutions en mode bac à sable (SharePoint Foundation 2010).

Historique des modifications


Présentation du processus de mise à niveau (SharePoint Foundation 2010)

Pour effectuer une mise à niveau de Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, vous avez le choix entre deux méthodes de mise à niveau de base : la mise à niveau sur place et la mise à niveau avec liaison des bases de données. La mise à niveau sur place est utilisée pour mettre à niveau tous les sites Microsoft SharePoint sur le même matériel. La mise à niveau avec liaison des bases de données permet de déplacer votre contenu vers une nouvelle batterie de serveurs ou un nouveau matériel. Vous pouvez également combiner ces deux types de mise à niveau dans une approche hybride pour réduire les temps d'arrêt durant la mise à niveau.

Pour plus d'informations sur ces méthodes, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Cet article vous aide à comprendre les étapes des processus de mise à niveau à l'aide de ces méthodes afin que vous puissiez planifier la mise à niveau. Pour des informations détaillées sur ces différents processus, voir les rubriques suivantes :

  • Mise à niveau sur place de SharePoint Foundation 2010

  • Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010

Dans cet article :

  • Mise à niveau sur place

  • Mise à niveau avec liaison des bases de données

  • Approche hybride 1 : bases de données en lecture seule

  • Approche hybride 2 : détacher les bases de données

Important :
Il est important que l'administrateur de serveur communique avec les propriétaires et les utilisateurs des sites pour les informer des événements pouvant se produire au cours d'une mise à niveau. L'administrateur doit les informer du temps d'indisponibilité et du risque que la mise à niveau soit plus longue que prévu ou que certains sites nécessitent des travaux supplémentaires après la mise à niveau. Pour plus d'informations, voir Créer un plan de communication (SharePoint Foundation 2010).

Mise à niveau sur place

Une mise à niveau sur place s'effectue sur le matériel où votre version antérieure est installée. Lorsque vous exécutez une mise à niveau sur place, le processus met à niveau l'installation complète dans un ordre prédéfini.

Les étapes suivantes expliquent le déroulement de l'exécution du processus de mise à niveau sur place :

  1. Après avoir effectué toutes les étapes préalables à la mise à niveau, l'administrateur de serveur exécute le programme d'installation de SharePoint Foundation 2010 sur le serveur qui héberge le site Web Administration centrale de SharePoint. Comme la version précédente y est installée, une mise à niveau sur place est automatiquement choisie.

  2. Après l'exécution de l'installation sur le serveur qui héberge le site Web Administration centrale, l'administrateur de serveur exécute le programme d'installation sur les serveurs Web frontaux restants et sur les serveurs d'applications de la batterie.

  3. L'administrateur de serveur exécute l'Assistant Configuration des produits SharePoint sur le serveur qui héberge le site Web Administration centrale. Ce serveur, la base de données de configuration, les services et les bases de données de contenu sont mis à niveau séquentiellement.

    Lorsque l'assistant de configuration a terminé, le site Web Administration centrale s'ouvre. Un travail de minuteur planifie l'exécution de la mise à niveau pour chaque collection de sites. Le travail de minuteur effectue la mise à niveau de chaque collection de sites. Une fois tous les sites mis à niveau, le processus de mise à niveau se termine.

  4. L'administrateur de serveur exécute l'Assistant Configuration des produits SharePoint sur tous les autres serveurs de la batterie.

    Processus de mise à niveau sur place
  5. L'administrateur du serveur confirme que la mise à niveau est terminée et réussie.

  6. Si la mise à niveau visuelle est utilisée, l'administrateur du serveur ou le propriétaire du site a un aperçu des sites dans l'apparence Microsoft SharePoint Foundation 2010. Lorsque l'administrateur du serveur ou le propriétaire du site est prêt, il termine les changements dans l'apparence SharePoint Foundation 2010.

Mise à niveau avec liaison des bases de données

La mise à niveau avec liaison des bases de données vous permet de migrer vers une nouvelle batterie de serveurs ou un nouveau matériel. Durant ce type de mise à niveau, vous détachez toutes les bases de données de contenu d'une batterie de serveurs existante et les attachez à une nouvelle installation de batterie. Lorsque vous attachez les bases de données à la nouvelle batterie de serveurs, le processus de mise à niveau s'exécute et met à niveau les données sur place.

Les étapes suivantes expliquent le déroulement du processus de mise à niveau avec liaison des bases de données :

  1. L'administrateur du serveur installe et configure une nouvelle batterie de serveurs SharePoint Foundation 2010. Il transfère toutes les personnalisations vers la nouvelle batterie et teste l'environnement.

    Pour plus d'informations sur la configuration du nouvel environnement, voir Préparer le nouvel environnement SharePoint Foundation.

  2. L'administrateur de serveur détache les bases de données de contenu de l'ancienne batterie de serveurs Windows SharePoint Services 3.0 et met cette batterie hors connexion (par exemple, en changeant l'équilibrage de charge ou les applications Web IIS pour arrêter les demandes de service, ou en désactivant tous les composants et les services sur chaque serveur de la batterie).

  3. L'administrateur de serveur attache les bases de données de contenu à la nouvelle batterie de serveurs et effectue la mise à niveau du contenu.

    Processus de mise à niveau de la migration des bases de données
  4. L'administrateur de serveur confirme que la mise à niveau est terminée et réussie, puis configure la nouvelle batterie de serveurs pour qu'elle prenne en charge le traitement des demandes sur la nouvelle URL.

Approche hybride 1 : bases de données en lecture seule

Cette approche confère aux utilisateurs l'accès en lecture seule ininterrompu à leurs données pendant la mise à niveau. Les bases de données de contenu de la batterie de serveurs d'origine sont mises en lecture seule et les copies des bases de données sont mises à niveau sur une nouvelle batterie.

Les étapes suivantes expliquent le déroulement du processus de mise à niveau avec liaison et lecture seule des bases de données :

  1. L'administrateur du serveur installe et configure une nouvelle batterie de serveurs SharePoint Foundation 2010. Il transfère toutes les personnalisations vers la nouvelle batterie et teste l'environnement.

  2. L'administrateur de serveur passe les bases de données de contenu en lecture seule. Il utilise ensuite SQL Server pour les sauvegarder sur la batterie de serveurs Windows SharePoint Services 3.0 et les restaurer sur la nouvelle batterie.

    Processus de mise à niveau des bases de données en lecture seule (partie 1)
  3. L'administrateur de serveur attache les nouvelles copies des bases de données de contenu ; le processus de mise à niveau s'exécute et met à niveau le contenu.

    Processus de mise à niveau des bases de données en lecture seule (partie 2)
  4. À la fin de la mise à niveau, l'administrateur de serveur vérifie que la mise à niveau s'est déroulée correctement. Il configure ensuite la nouvelle batterie de serveurs afin qu'elle prenne en charge le traitement des demandes sur la nouvelle URL et met la batterie d'origine hors connexion (par exemple, en changeant l'équilibrage de charge ou les applications Web IIS pour arrêter les demandes de service, ou en désactivant tous les composants et les services sur chaque serveur de la batterie).

Approche hybride 2 : détacher les bases de données

Cette approche vous permet d'accélérer le processus de mise à niveau en détachant, puis rattachant les bases de données afin de les mettre à niveau simultanément. Il s'agit d'une mise à niveau sur place, car vous mettez à niveau la batterie de serveurs d'origine ; cependant, vous pouvez également utiliser une autre batterie pour effectuer la mise à niveau, puis attacher les bases de données mises à niveau à la batterie de serveurs d'origine. Notez que la batterie d'origine ne peut pas traiter les demandes durant le processus de mise à niveau. Comme dans une mise à niveau sur place standard, les utilisateurs ne peuvent pas accéder à leur contenu pendant la mise à niveau.

Les étapes suivantes expliquent le déroulement d'une mise à niveau sur place avec les bases de données détachées :

  1. L'administrateur de serveur passe la batterie de serveurs d'origine hors connexion (par exemple, en changeant l'équilibrage de charge ou les applications Web IIS pour arrêter les demandes de service, ou en désactivant tous les composants et les services sur chaque serveur de la batterie).

  2. L'administrateur du serveur détache les bases de données de contenu de la batterie de serveurs d'origine.

  3. L'administrateur de serveur exécute une mise à niveau sur place des serveurs, des services et de la base de données de configuration de la batterie d'origine.

  4. L'administrateur de serveur attache les bases de données de contenu à la batterie de serveurs d'origine et effectue la mise à niveau du contenu.

    Processus de mise à niveau : détacher les bases de données (partie 1)

Sinon, vous pouvez utiliser une petite batterie de serveurs distincte temporaire pour effectuer la mise à niveau. Dans cette approche, vous attachez les bases de données à la batterie de serveurs d'origine après les avoir mises à niveau.

Les étapes suivantes expliquent le déroulement d'une mise à niveau sur place avec les bases de données détachées et une petite batterie de serveurs temporaire pour mettre à niveau les bases de données de contenu :

  1. L'administrateur de serveur installe une petite batterie de serveurs temporaire qui exécute la nouvelle version, puis il met la batterie de serveurs d'origine hors connexion (par exemple, en changeant l'équilibrage de charge ou les applications Web IIS pour arrêter les demandes de service, ou en désactivant tous les composants et les services sur chaque serveur de la batterie).

  2. L'administrateur du serveur détache les bases de données de contenu de la batterie de serveurs d'origine.

  3. L'administrateur de serveur exécute une mise à niveau sur place de la batterie d'origine pour mettre à niveau les serveurs, les services et la base de données de configuration.

  4. L'administrateur de serveur attache les bases de données de contenu à la batterie de serveurs temporaire et effectue la mise à niveau de celles-ci en parallèle.

  5. L'administrateur de serveur rattache les bases de données de contenu à la batterie de serveurs d'origine.

    Processus de mise à niveau : détacher les bases de données (partie 2)
  6. L'administrateur du serveur confirme que la mise à niveau est terminée et réussie.

  7. Si la mise à niveau visuelle est utilisée, l'administrateur du serveur ou le propriétaire du site a un aperçu des sites dans l'apparence Microsoft SharePoint Foundation 2010. Lorsque l'administrateur du serveur ou le propriétaire du site est prêt, il termine les changements dans l'apparence Microsoft SharePoint Foundation 2010.

Historique des modifications


Mise à niveau depuis Windows SharePoint Services 2.0 vers SharePoint Foundation 2010

Vous ne pouvez pas mettre à niveau Windows SharePoint Services 2.0 directement à Microsoft SharePoint Foundation 2010.

Les différences entre les versions sont trop importantes et la configuration matérielle requise varie tellement d'une version à l'autre qu'une mise à niveau directe et sur place n'est pas possible et n'est pas prise en charge. Cependant, vous pouvez effectuer plusieurs mises à niveau de la liaison de base de données pour mettre d'abord votre contenu à niveau vers Windows SharePoint Services 3.0 puis vers SharePoint Foundation 2010. Cet article vous explique comment effectuer cette double mise à niveau de la liaison de base de données.

Remarque :
Votre ancien environnement doit être hors connexion pendant la totalité du processus, afin que les utilisateurs ne puissent pas y effectuer des modifications alors même que vous êtes en train d'effectuer la mise à niveau. Une fois la mise à niveau terminée et validée, vous pouvez de nouveau accorder l'accès aux utilisateurs dans l'environnement SharePoint Foundation 2010.

Dans cet article :

  • Vue d'ensemble du processus

  • Avant de commencer

  • Préparer la mise à niveau

  • Préparer les batteries de serveurs

  • Effectuer la première mise à niveau

  • Effectuer la seconde mise à niveau

Vue d'ensemble du processus

Cette approche de la mise à niveau combinant deux processus de mise à jour qui ont déjà été documentés, cet article décrit comment les différentes étapes de chaque processus s'assemblent dans l'ensemble du processus. Il ne fournit pas de détails sur chaque étape du processus, car ces étapes sont décrites dans les articles suivants :

  • Déployer une nouvelle batterie de serveurs, puis migrer les bases de données de contenu

  • Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010

Ces articles, combinés à cette feuille de route, fournissent les informations dont vous avez besoin pour réaliser cette double mise à niveau de la liaison de base de données.

Important :
Veillez à d'abord mettre à l'essai le processus entier dans un environnement de test avant d'essayer de mettre à niveau votre contenu réel en direct. Pour plus d'informations sur les tests des processus de mise à niveau, voir le contenu suivant :

  • Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (Windows SharePoint Services)

  • Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010) et le modèle Test du processus de mise à niveau (éventuellement en anglais) sur TechNet.

Séquence de mise à niveau

Pour mettre à niveau le contenu dans les deux versions, procédez comme suit :

  1. Préparer la mise à niveau

    1. Préparez la batterie de serveurs d'origine en exécutant l'outil d'analyse de pré-mise à niveau et en faisant un inventaire des personnalisations que vous avez effectuées.

    2. Configurez une petite batterie de serveurs temporaire exécutant Windows SharePoint Services 3.0.

    3. Configurez une batterie de serveurs complète SharePoint Foundation 2010 et vérifiez qu'elle est configurée et qu'elle fonctionne correctement.

  2. Première mise à niveau : mettre à niveau le contenu vers Windows SharePoint Services 3.0

    1. Détachez les bases de données de contenu de l'ancienne batterie de serveurs, puis mettez cette dernière hors connexion.

      Sinon, vous pouvez également laisser les bases de données liées et en faire une copie si vous voulez vous assurer que la batterie de serveurs d'origine puisse être de nouveau utilisable rapidement.

    2. Liez les bases de données de contenu à la batterie de serveurs de Windows SharePoint Services 3.0 et mettez-les à niveau.

    3. Vérifiez que le contenu a bien été mis à niveau et que la batterie de serveurs de Windows SharePoint Services 3.0 fonctionne correctement.

  3. Seconde mise à niveau : mettez le contenu à niveau vers SharePoint Foundation 2010

    1. Détachez les bases de données de contenu depuis la batterie de serveurs de Windows SharePoint Services 3.0.

    2. Liez les bases de données de contenu à la batterie de serveurs de SharePoint Foundation 2010 et mettez-les à niveau (vous pouvez également les mettre à niveau en parallèle).

    3. Vérifiez que le contenu a bien été mis à niveau et que la batterie de serveurs de SharePoint Foundation 2010 fonctionne correctement.

  4. Commencez la prise en charge des demandes sur la batterie de serveurs SharePoint Foundation 2010.

Les diagrammes suivants illustrent ce processus :

Mise à niveau de la liaison de base de données vers Windows SharePoint Services 3.0.

Attachement de base de données à Windows SharePoint Services 3.0

Mise à niveau de la liaison de base de données vers SharePoint Foundation 2010.

Attachement de base de données à SharePoint Foundation 2010

Avant de commencer

Avant de commencer la mise à niveau, lisez les informations suivantes sur les autorisations, ainsi que sur les configurations matérielle et logicielle requises. Suivez les étapes spécifiées pour installer ou configurer les logiciels prérequis ou pour modifier les paramètres.

Examiner les autorisations requises

  • Quand vous créez un environnement temporaire pour Windows SharePoint Services 3.0, vous devez posséder les autorisations appropriées. Pour plus d'informations, voir Prévoir les comptes d'administration et de service (Windows SharePoint Services).

  • Quand vous créez et configurez votre batterie de serveurs SharePoint Foundation 2010 de destination, vous devez posséder les autorisations appropriées. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

Examiner la configuration matérielle et logicielle requise

  • Quand vous créez un environnement temporaire pour Windows SharePoint Services 3.0, vous devez répondre à certaines exigences concernant la configuration matérielle et logicielle. Pour plus d'informations, voir Déterminer la configuration matérielle et logicielle requise (Windows SharePoint Services).

  • Quand vous créez et configurez votre batterie de serveurs de destination SharePoint Foundation 2010, vous devez répondre à d'autres exigences concernant la configuration matérielle et logicielle. Pour plus d'information, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

Dans certains environnements, vous devez coordonner les procédures avec l'administrateur des bases de données pour déplacer les bases de données vers une batterie de serveurs distincte. Suivez bien les stratégies en vigueur et les directives pour la gestion des bases de données.

Préparer la mise à niveau

Comme vous effectuez deux mises à niveau, vous devez comprendre toutes les étapes comprises dans la mise à niveau vers Windows SharePoint Services 3.0 et vers SharePoint Foundation 2010. Le contenu suivant peut vous aider à comprendre ces processus de mise à niveau :

Préparation à la mise à niveau vers Windows SharePoint Services 3.0

  • Lisez le chapitre Planifier et préparer la mise à niveau sur TechNet. Veillez à lire les articles suivants :

    • Fonctionnement du processus de mise à niveau (Windows SharePoint Services)

    • Déterminer comment gérer des personnalisations (Windows SharePoint Services)

    • Développer de nouvelles définitions de site personnalisées et créer les fichiers de définition de mise à niveau (Windows SharePoint Services)

  • Lisez le chapitre Effectuer les étapes préalables à la mise à niveau (Windows SharePoint Services) sur TechNet. Vous devez suivre les étapes suivantes pour effectuer une mise à niveau de la liaison de base de données (nommée migration de base de données dans cette version) :

    • Installer le Service Pack 2 pour Windows SharePoint Services 2.0

    • Exécuter l'outil d'analyse préalable à la mise à niveau (Windows SharePoint Services)

    Important :
    Vous suivez ces étapes dans votre batterie de serveurs Windows SharePoint Services 2.0 existante.

Préparation à la mise à niveau vers SharePoint Foundation 2010

  • Planifier et préparer la mise à niveau. Lisez l'article suivant sur TechNet :

    • Présentation du processus de mise à niveau (SharePoint Foundation 2010)

  • Effectuer les étapes préalables à la mise à niveau. Lisez l'article suivant sur TechNet :

    • Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010)

    Important :
    Vous suivez ces étapes dans votre batterie de serveurs Windows SharePoint Services 3.0 temporaire.

Préparer les batteries de serveurs

Cette étape consiste à suivre les étapes préalables à la mise à niveau sur votre batterie de serveurs existante, créer votre batterie de serveurs temporaire vers Windows SharePoint Services 3.0 et créer votre batterie de serveurs de destination SharePoint Foundation 2010Suivez les étapes suivantes et le contenu concerné lors de la préparation de votre batterie de serveurs aux mises à niveau.

Créer la batterie de serveurs Windows SharePoint Services 3.0 temporaire

Dans un environnement virtuel ou physique, créez une petite batterie de serveurs temporaire exécutant Windows SharePoint Services 3.0 avec le Service Pack 2 (SP2) et la mise à jour cumulée d'octobre 2009. Vous utiliserez cette batterie de serveurs pour mettre à niveau le contenu vers Windows SharePoint Services 3.0 puis vers SharePoint Foundation 2010.

Conseil :
Pour de meilleurs résultats, nous vous recommandons d'appliquer les dernières mises à niveau à l'environnement. La mise à jour cumulée d'octobre 2009 comprend des modifications du l'outil de vérification de pré-mise à niveau pouvant aider à identifier les problèmes avant la mise à niveau. Pour une liste des mises à jour, voir centre des mises à jour pour Microsoft Office, les produits Office Server et les produits connexes (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=181115&clcid=0x40C). Pour plus d'information sur l'application des mises à jour, voir Centre des ressources de mise à jour des Produits et technologies SharePoint (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=181116&clcid=0x40C).

  1. Téléchargez le logiciel pour la batterie de serveurs temporaire.

    Téléchargez Windows SharePoint Services 3.0 avec SP2 à partir de l'un des liens suivants :

    • Version x86 : Windows SharePoint Services 3.0 avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=148403&clcid=0x40C)

    • Version x64 : Windows SharePoint Services 3.0 x64 avec Service Pack 2 (http://go.microsoft.com/fwlink/?linkid=181113&clcid=0x40C)

  2. Installez les packs de modèles linguistiques requis pour vos sites. Pour plus d'informations, voir Installer les packs de modèles linguistiques disponibles (Windows SharePoint Services).

  3. Configurez la batterie de serveurs en utilisant les paramètres de batterie de serveurs qui conviennent à votre environnement et en réappliquant toutes les personnalisations nécessaires pour votre contenu. Assurez-vous de déployer les personnalisations et les fichiers de définition de mise à niveau nécessaires pour toutes les définitions de site personnalisées existant dans votre environnement. Vous devez créer des applications Web sur la batterie de serveurs temporaire pour chaque serveur virtuel que vous aviez dans la batterie de serveurs d'origine. L'URL des nouvelles applications Web doit correspondre aux URL sources de la batterie de serveurs ou aux URL de destination de la batterie de serveurs, sinon vous risquez d'ajouter des références aux URL temporaires supplémentaires au contenu. Dans l'idéal, vous devez utiliser les mêmes URL pour les batterie de serveurs source et de destination, afin que les URL de la batterie de serveurs temporaire soient totalement identiques, notamment les numéros de port utilisés.

    Pour plus d'information sur la configuration de la batterie de serveurs, voir Préparer le nouvel environnement Windows SharePoint Services 3.0. Pour plus d'informations sur le déploiement des définitions de site personnalisées et des définitions de mise à niveau, voir Déployer des fichiers de définition de mise à niveau et de nouvelles définitions de site (Windows SharePoint Services).

Configurez votre batterie de serveurs SharePoint Foundation 2010 complète

Il s'agit de la batterie de serveurs que vous utiliserez finalement pour votre environnement de production, donc assurez-vous de planifier votre infrastructure de manière appropriée pour prendre en charge la solution que vous hébergez. POur plus d'information sur la planification de votre batterie de serveurs, voir Planification de batterie de serveurs et de l'environnement (SharePoint Foundation 2010).

  1. Créez votre batterie de serveurs sur de l'équipement 64 bits avec des serveurs de base de données exécutant une version 64 bits de SQL Server 2008 avec SP1 et mise à jour cumulative 2. Pour plus d'information, voir Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010).

  2. Installez les modules de modèles linguistiques pour vos sites. Pour plus d'informations, voir Installer les packs de modèles linguistiques disponibles (SharePoint Foundation 2010).

  3. Configurez la batterie de serveurs en utilisant les paramètres de batterie de serveur adaptés à votre environnement et en ré-appliquant toutes les personnalisations requises par votre contenu. Vous devez créer des applications Web sur la batterie de serveurs de destination pour chaque serveur virtuel que vous aviez dans la batterie de serveurs d'origine.

    Pour plus d'information sur la création et la configuration d'une batterie de serveurs pour une mise à niveau de liaison de base de données, voir Préparer le nouvel environnement SharePoint Foundation.

Effectuer la première mise à niveau

Dès que vous avez terminé l'installation et la configuration des batteries de serveur, vous êtes prêt à mettre à niveau les bases de données de contenu vers Windows SharePoint Services 3.0.

Important :
Vérifiez que vous avez bien exécuté l'outil d'analyse de pré-mise à niveau sur votre batterie de serveurs d'origine avant de détacher les bases de données. Le processus de mise à niveau n'est pas exécuté si vous n'avez pas analysé les bases de données. Pour plus d'information, voir Exécuter l'outil d'analyse préalable à la mise à niveau (Windows SharePoint Services).

Pour effectuer une mise à niveau de la liaison de base de données (nommée migration de la base de données pour cette version), suivez les étapes suivantes :

  1. Sauvegardez les bases de données de contenu.

  2. Restaurez les copies sauvegardées sur votre batterie de serveurs temporaire.

  3. Ajoutez les bases de données aux applications Web pour démarrer le processus de mise à niveau.

Pour obtenir des informations complètes et connaître les étapes à suivre, voir Migrer les bases de données de contenu.

Vérifier la première mise à niveau

Pour vérifier la mise à niveau, procédez comme suit :

  • Consultez le journal de mise à niveau. Pour plus d'informations, voir Migrer les bases de données de contenu.

  • Vérifiez les sites mis à niveau pour vous assurer qu'ils fonctionnent toujours comme prévu et que vos composants WebPart et les autres éléments personnalisés fonctionnent correctement.

Effectuer la seconde mise à niveau

Une fois que vous avez vérifié que vos sites fonctionnent correctement, vous pouvez commencer la mise à niveau vers SharePoint Foundation 2010.

Important :
Exécutez l'outil de vérification préalable à la mise à niveau et vérifiez le rapport afin de répondre à des problèmes potentiels sur votre batterie de serveurs temporaire avant de mettre à niveau le contenu. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

Pour effectuer la mise à niveau de liaison de base de données, effectuez les étapes suivantes :

  1. Sauvegardez les bases de données de contenu.

  2. Restaurez les copies sauvegardées sur votre batterie de serveurs de destination.

  3. Ajoutez les bases de données aux applications Web pour démarrer le processus de mise à niveau. Dans SharePoint Foundation 2010, vous pouvez lier des bases de données en parallèle afin d'accélérer le processus de mise à niveau.

Pour obtenir des informations complètes et connaître les étapes à suivre, voir Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010.

Vérifier la seconde mise à niveau

Pour vérifier la mise à niveau, procédez comme suit :

  • Consultez le journal de mise à niveau.

  • Vérifiez les sites mis à niveau pour vous assurer qu'ils fonctionnent toujours comme prévu et que vos composants WebPart et les autres éléments personnalisés fonctionnent correctement.

Pour plus d'informations, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Historique des modifications


Planifier et préparer la mise à niveau (SharePoint Foundation 2010)

Maintenant que vous avez étudié le fonctionnement du processus de mise à niveau en consultant les articles dans À propos du processus de mise à niveau (SharePoint Foundation 2010), vous pouvez commencer la planification de la mise à niveau. Cette section contient des articles qui vous aident à planifier et à préparer la mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Déterminer l'approche de mise à niveau (SharePoint Foundation 2010)

    Découvrez les différentes méthodes de mise à niveau et choisissez la mieux adaptée à votre environnement.

  • Consulter les méthodes conseillées de mise à niveau (SharePoint Foundation 2010)

    Évitez les problèmes pendant le processus de mise à niveau en suivant ces meilleures pratiques.

  • Passer en revue les chemins de mise à niveau pris en charge et non pris en charge (SharePoint Foundation 2010)

    Identifiez les types et topologies d'installation pouvant être mis à niveau vers SharePoint Foundation 2010.

  • Examiner la configuration requise pour la mise à niveau (SharePoint Foundation 2010)

    Passez en revue la configuration requise pour vous assurer que votre environnement peut être mis à niveau vers SharePoint Foundation 2010.

  • Déterminer comment gérer les personnalisations (SharePoint Foundation 2010)

    Découvrez comment identifier et évaluer les personnalisations dans votre environnement, puis déterminez si vous allez les mettre à niveau et selon quelle procédure.

  • Créer un plan de communication (SharePoint Foundation 2010)

    Créez un plan pour coordonner l'équipe de mise à niveau, les propriétaires et utilisateurs de site et les parties prenantes, ainsi que pour communiquer avec ces groupes.

  • Planifier une mise à niveau visuelle (SharePoint Foundation 2010)

    Découvrez les différentes options de mise à niveau visuelles et comment choisir l'option la mieux adaptée aux besoins de votre entreprise.

Une feuille de calcul est à votre disposition, dans laquelle vous pouvez enregistrer les informations sur votre environnement pendant que vous préparez la mise à niveau. Téléchargez la feuille de calcul à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C (éventuellement en anglais).

Historique des modifications


Déterminer l'approche de mise à niveau (SharePoint Foundation 2010)

Avant d'exécuter un processus de mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, vous devez déterminer quelle approche de mise à niveau adopter. Utilisez les informations de cet article pour comparer les avantages et les inconvénients de chaque approche et pour consulter les informations relatives aux cas particuliers qui peuvent influer sur votre approche. En plus des informations contenues dans cet article, lisez l'article Passer en revue les chemins de mise à niveau pris en charge et non pris en charge (SharePoint Foundation 2010) afin de comprendre exactement quelles sont les situations dans lesquelles la mise à niveau est valide et sera couronnée de succès.

Remarque :
Pour effectuer une mise à niveau, vous devez avoir installé Windows SharePoint Services 3.0 avec Service Pack 2 (SP2).

Dans cet article :

  • Choisir une approche de mise à niveau

  • Cas particuliers

Choisir une approche de mise à niveau

Il existe deux approches de base en matière de mise à niveau : sur place et avec liaison des bases de données. En outre, vous pouvez combiner les aspects de ces approches de base de différentes manières pour limiter les temps morts ou éventuellement améliorer les performances.

Le tableau suivant compare les approches de mise à niveau sur place et avec liaison des bases de données.

Approche | Description | Avantages | Inconvénients
Mise à niveau sur place | Vous pouvez installer SharePoint Foundation 2010 sur la même configuration matérielle. Vous pouvez également mettre à niveau le contenu et les paramètres dans la batterie de serveurs au cours d'un seul processus. | Les paramètres de taille de batterie de serveurs sont conservés et mis à niveau. Les personnalisations sont disponibles dans l'environnement après la mise à niveau, bien que des étapes manuelles puissent être nécessaires pour les mettre à niveau ou les modifier. | Les serveurs et les batteries de serveurs sont hors connexion pendant l'opération de mise à niveau. La mise à niveau se déroule de façon continue. Par conséquent, vous devez allouer suffisamment de temps pour que la totalité du contenu soit mise à niveau séquentiellement.
Mise à niveau par attachement de base de données | Vous pouvez mettre à niveau le contenu de l'environnement sur une batterie de serveurs séparée. Aucun des services ou des paramètres de la batterie n'est alors mis à niveau. Vous pouvez mettre à niveau les bases de données dans n'importe quel ordre et mettre à niveau plusieurs bases de données simultanément. Pendant la mise à niveau de chaque base de données, le contenu de celle-ci est inaccessible aux utilisateurs. | Vous pouvez mettre à niveau plusieurs bases de données de contenu en même temps, les mises à niveau se font plus rapidement que s'il s'agit d'une mise à niveau sur place. Vous pouvez utiliser une mise à niveau par attachement de base de données pour unir plusieurs batteries en une seule batterie de serveurs. | Les paramètres de serveur et de batterie de serveurs ne sont pas mis à niveau. Vous devez transférer manuellement les paramètres à conserver depuis l'ancienne batterie de serveurs vers la nouvelle. Toutes les personnalisations doivent également être transférées vers la nouvelle batterie de serveurs manuellement. Toute personnalisation manquante peut entraîner une perte de fonctionnalité ou des problèmes d'expérience utilisateur involontaires. La copie de bases de données sur un réseau consomme du temps et de la bande passante. Vous devez planifier cette opération. Un accès direct aux serveurs de bases de données est nécessaire.

Pour plus d'informations sur le fonctionnement de la mise à niveau sur place et de la mise à niveau avec liaison des bases de données, voir Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Le tableau suivant répertorie les techniques de limitation de temps morts que vous pouvez utiliser pendant la mise à niveau pour réduire l'intervalle de temps pendant lequel les utilisateurs ne peuvent pas accéder à leur contenu ou pour accroître éventuellement les performances de la mise à niveau.

Technique Description Avantages Inconvénients

Mise à niveau parallèle

Vous pouvez attacher et mettre à niveau plusieurs bases de données à la fois pour accélérer le processus de mise à niveau global. Le nombre maximal de mises à niveau parallèles dépend de votre configuration matérielle. Cette technique fonctionne pour les mises à niveau sur place ou avec liaison des bases de données.

Processus de mise à niveau plus rapides pour l'environnement global.

Il s'agit d'un processus manuel qui requiert des étapes et une surveillance supplémentaires.

Approche hybride 1 : liaison des bases de données avec bases de données en lecture seule

Permet de continuer à fournir un accès en lecture seule au contenu pendant le processus de mise à niveau. Pour cette approche, vous définissez les bases de données sur lecture seule pendant que la mise à niveau s'exécute sur une autre batterie de serveurs. Cette méthode réduit le temps mort perçu par les utilisateurs.

La batterie de serveurs existante peut continuer à héberger des sites non mis à niveau (en mode lecture seule) pendant que vous mettez à niveau le contenu. Par conséquent, les temps morts sont minimes pour les utilisateurs.

Vous pouvez mettre à niveau plusieurs bases de données de contenu en même temps, ce qui, globalement, permet d'effectuer une mise à niveau plus rapide qu'une mise à niveau sur place.

Vous pouvez mettre à niveau la configuration matérielle en plus de la configuration logicielle.

Les paramètres de serveur et de batterie de serveurs ne sont pas mis à niveau. Vous devez transférer manuellement les paramètres à conserver depuis l'ancienne batterie de serveurs vers la nouvelle.

Toutes les personnalisations doivent également être transférées et mises à niveau manuellement. Toute personnalisation manquante peut entraîner une perte de fonctionnalité ou des problèmes d'expérience utilisateur involontaires.

La copie de bases de données sur un réseau consomme du temps et de la bande passante. Vous devez planifier cette opération.

Un accès direct aux serveurs de bases de données est nécessaire.

Approche hybride 2 : mise à niveau sur place avec bases de données détachées

Permet de tirer parti de la possibilité d'une mise à niveau sur place pour mettre à niveau le contenu et les paramètres, en y ajoutant la rapidité d'une mise à niveau par attachement de base de données. Pour cette approche, vous utilisez une mise à niveau sur place pour mettre à niveau la batterie et les paramètres, et pour détacher, ainsi que mettre à niveau plusieurs bases de données en parallèle (dans la même batterie ou sur une batterie séparée).

Les paramètres à l'échelle de la batterie peuvent être conservés et mis à niveau.

Les personnalisations sont disponibles dans l'environnement après la mise à niveau, bien que des étapes manuelles puissent être nécessaires pour les mettre à niveau ou les affiner.

Vous pouvez mettre à niveau plusieurs bases de données de contenu en même temps, ce qui, globalement, permet d'effectuer une mise à niveau plus rapide qu'une mise à niveau sur place.

La copie de bases de données sur un réseau consomme du temps et de la bande passante. Vous devez planifier cette opération.

Un accès direct aux serveurs de bases de données est nécessaire.

Gardez à l'esprit que vous pouvez également combiner ces techniques. Par exemple, vous pouvez définir votre batterie de serveurs d'origine en mode lecture seule, créer une copie de la batterie de serveurs et la mettre à niveau sans les bases de données de contenu, utiliser une mise à niveau parallèle pour mettre rapidement à niveau la totalité du contenu utilisateur, puis basculer les utilisateurs vers la nouvelle batterie de serveurs une fois la mise à niveau achevée. Pour plus d'informations sur le fonctionnement de ces techniques de limitation de temps mort, voir Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Une autre option à envisager si vous êtes confronté à une plage d'indisponibilité excessivement étendue consiste à utiliser la redirection d'URL avec mappage des accès de substitution dans le cadre d'une approche de mise à niveau avec liaison des bases de données, afin de rediriger provisoirement les utilisateurs vers une batterie de serveurs existante pendant que vous mettez à niveau le contenu sur une nouvelle batterie de serveurs. Il s'agit d'une méthode avancée, qui ne doit être utilisée que si les autres techniques de limitation de temps mort s'avèrent insuffisantes. Pour plus d'informations, voir Utilisation de redirection d'URL AAM dans le processus de mise à niveau (SharePoint Foundation 2010) (livre blanc).

Cas particuliers

Vous pouvez avoir d'autres exigences ou des objectifs supplémentaires à atteindre lorsque vous effectuez une mise à niveau. Le tableau suivant répertorie des cas particuliers et décrit l'approche de mise à niveau appropriée pour chaque cas.

Cas Approche de mise à niveau

Mise à niveau d'une installation autonome avec la base de données interne Windows ?

Si vous exécutez Windows SharePoint Services 3.0 sur un serveur autonome avec la base de données interne Windows, votre base de données sera migrée vers SQL Server Express dans le cadre du processus de mise à niveau sur place. Si la taille de votre base de données est supérieure à 4 Go, vous devez configurer le stockage BLOB distant afin qu'il stocke une partie des données. Pour plus d'informations, voir Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec stockage BLOB distant.

Mise à niveau d'une édition 32 bits vers une édition 64 bits de SQL Server ?

Si vous exécutez une édition 32 bits de SQL Server, vous devez effectuer une migration vers une édition 64 bits. Il est recommandé d'effectuer cette migration avant de procéder à la mise à niveau vers SharePoint Foundation 2010 afin d'optimiser les performances. Veillez à n'effectuer qu'un seul type de mise à niveau ou migration à la fois pour éviter tout échec de mise à niveau. Pour plus d'informations, voir Migrer une batterie de serveurs existante vers un environnement 64 bits (Windows SharePoint Services 3.0).

Les deux options suivantes permettent d'effectuer une mise à niveau depuis une édition 32 bits vers une édition 64 bits de SQL Server :

  • Vous pouvez sauvegarder le jeu entier de bases de données pour la batterie de serveurs, effectuer la mise à niveau, puis restaurer les bases de données (cette option est prise en charge et recommandée puisque vous disposez d'une sauvegarde complète et qu'après avoir restauré les bases de données, aucune modification n'est requise dans SharePoint Foundation 2010).

  • Vous pouvez déplacer les bases de données SQL Server que vous souhaitez mettre à niveau vers une autre édition 64 bits de SQL Server. Vous devez ajouter l'autre édition 64 bits, puis exécuter une commande sur les ordinateurs exécutant SharePoint Foundation 2010 pour les faire pointer vers la nouvelle édition 64 bits SQL Server (cette option est prise en charge, mais non recommandée, car cela demande plus de travail dans SharePoint Foundation 2010 lorsque, par exemple, l'emplacement des bases de données change).

Remarque :
Vous pouvez mettre à niveau une version de SQL Server, par exemple de SQL Server 2005 SP2 vers SQL Server 2008, avant, pendant ou après la mise à niveau d'une édition 32 bits vers une édition 64 bits de SQL Server.

Mise à niveau de Windows Server 2003 vers Windows Server 2008 ?

Mettez à niveau le système d'exploitation avant de tenter une mise à niveau vers SharePoint Foundation 2010.

Si vous exécutez Windows SharePoint Services 3.0, vous devez suivre des étapes spécifiques pour effectuer une mise à niveau vers Windows Server 2008. Pour plus d'informations, voir Mise à niveau vers Windows Server 2008 pour Windows SharePoint Services 3.0 avec Service Pack 1.

Mise à niveau d'un système d'exploitation 32 bits vers un système d'exploitation 64 bits ?

Si vous utilisez un système d'exploitation 32 bits, vous devez migrer vers un système d'exploitation 64 bits avant d'effectuer la mise à niveau. Pour plus d'informations, voir Migrer une batterie de serveurs existante vers un environnement 64 bits (Windows SharePoint Services 3.0).

Mise à niveau d'un environnement qui utilise l'authentification par formulaire ?

La mise à niveau requiert des étapes supplémentaires lorsque vous utilisez l'authentification par formulaire. Pour plus d'informations, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

Mise à niveau de bases de données très volumineuses ?

En général, la mise à niveau des bases de données très volumineuses, notamment les bases de données qui comportent des versions de document dont le nombre ou la taille sont élevés, prend plus de temps que celle des bases de données plus petites. Toutefois, c'est la complexité des données qui détermine la durée de la mise à niveau, et non la taille de la base de données proprement dite. Si le processus de mise à niveau arrive à expiration, cela est généralement dû à des problèmes de connexion. Dans Windows SharePoint Services 3.0, le processus de mise à niveau arrivait souvent à expiration en raison de la durée nécessaire à l'exécution d'un processus, mais cela est rarement le cas avec SharePoint Foundation 2010. Pour plus d'informations sur la durée possible de la mise à niveau pour votre environnement, voir Estimer la durée du processus de mise à niveau et l'espace dont vous avez besoin (SharePoint Foundation 2010).

Mise à niveau depuis Windows SharePoint Services 2.0 ?

Utilisez une méthode de mise à niveau avec liaison des bases de données pour effectuer une mise à niveau vers Windows SharePoint Services 3.0, puis réalisez une mise à niveau vers SharePoint Foundation 2010. Pour plus d'informations sur ce processus de mise à niveau, voir Mise à niveau depuis Windows SharePoint Services 2.0 vers SharePoint Foundation 2010.

Utilisation de noms de domaine internationaux ?

Bien que Windows SharePoint Services 3.0 prenne en charge les noms de domaine internationaux, ce n'est pas le cas de SharePoint Foundation 2010. Si vous utilisez actuellement des noms de domaine internationaux avec Windows SharePoint Services 3.0 et si vous envisagez d'effectuer une mise à niveau ou une migration vers SharePoint Foundation 2010, vous devez au préalable cesser d'utiliser des noms de domaine internationaux, supprimer les paramètres relatifs aux noms de domaine internationaux, puis configurer un environnement non basé sur les noms de domaine internationaux. Pour plus d'informations, voir Planifier des sites multilingues (SharePoint Foundation 2010).

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Consulter les méthodes conseillées de mise à niveau (SharePoint Foundation 2010)

Pour garantir un processus de mise à niveau cohérent depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, suivez ces meilleures pratiques :

  1. Mettez à jour vos serveurs vers le Service Pack 2 (SP2) de Windows SharePoint Services 3.0 ou version ultérieure.

    Votre environnement doit être mis à jour vers le Service Pack 2 d'Windows SharePoint Services 3.0 pour que vous puissiez exécuter le processus de mise à niveau, qu'il s'agisse d'une mise à niveau sur place ou d'une mise à niveau avec liaison des bases de données. Il est recommandé d'installer la mise à jour cumulative d'octobre 2009, car elle comprend des améliorations apportées à l'outil de vérification de pré-mise à niveau. Pour plus d'informations sur l'installation des Service Packs et des mises à jour, voir le centre de ressource des mises à jour pour les produits et technologies SharePoint (éventuellement en anglais). Pour la liste de toutes les mises à jour disponibles, voir le centre des mises à jour pour Microsoft Office, les produits Office Server et les produits connexes (éventuellement en anglais).

  2. Vérifiez que l'environnement est entièrement opérationnel avant d'effectuer une mise à niveau.

    Une mise à niveau ne résout pas les problèmes qui existent éventuellement déjà dans votre environnement. Par conséquent, vérifiez que l'environnement est entièrement opérationnel avant d'effectuer une mise à niveau. Par exemple, si certaines applications Web ne sont plus utilisées, annulez leur extension avant de procéder à la mise à niveau. Si vous souhaitez supprimer une application Web dans ISS, annulez son extension avant de la supprimer ; sinon, SharePoint Foundation 2010 essaiera de mettre à niveau l'application Web même si elle n'existe pas, ce qui se traduira par l'échec de la mise à niveau. En outre, la recherche et la résolution préalables des problèmes permettent de respecter plus facilement la planification initiale de la mise à niveau.

  3. Avant d'effectuer une mise à niveau sur place, opérez une migration vers des serveurs 64 bits. Mettez à niveau votre système d'exploitation vers une version 64 bits de Windows Server 2008 R2 ou Windows Server 2008 avec Service Pack 2 (SP2). Si vous utilisez SQL Server, effectuez une mise à niveau ou une migration vers une version 64 bits de Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3.

    N'essayez pas de combiner ces opérations avec votre processus de mise à niveau. Vous ne pouvez effectuer une mise à niveau sur place que si votre système s'exécute déjà sur un système d'exploitation et une plateforme pris en charge. Pour plus d'informations, voir Nouveautés de la mise à niveau (SharePoint Foundation 2010).

  4. Exécutez l'outil de vérification de pré-mise à niveau pour rechercher les problèmes éventuels.

    L'outil de vérification de pré-mise à niveau signale, entre autres, les personnalisations manquantes et les problèmes liés aux sites orphelins, de sorte que vous pouvez résoudre ces problèmes avant d'effectuer votre mise à niveau. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

  5. Effectuez une mise à niveau d'essai sur une batterie de serveurs de test.

    Sauvegardez la batterie de serveurs utilisée, restaurez-la sur des serveurs de test, puis effectuez la mise à niveau. Examinez les résultats pour définir ce à quoi les sites mis à niveau doivent ressembler, pour déterminer le niveau de personnalisation nécessaire après la mise à niveau et pour estimer le temps nécessaire à la mise à niveau. Essayez de lancer une analyse de l'indexation de recherche en texte intégral. Pour plus d'informations, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010).

  6. Planifiez la capacité.

    Assurez-vous de disposer de suffisamment d'espace disque, de ressources processeur et de capacité mémoire pour répondre aux conditions requises par les mises à niveau. Pour plus d'informations sur la configuration requise, voir Examiner la configuration requise pour la mise à niveau (SharePoint Foundation 2010). Pour plus d'informations sur la planification de l'espace disque requis pour la mise à niveau, voir Estimer la durée du processus de mise à niveau et l'espace dont vous avez besoin (SharePoint Foundation 2010).

  7. Sauvegardez votre environnement.

    Effectuez une sauvegarde complète de votre environnement avant de procéder à la mise à niveau. Cela vous permet de récupérer votre environnement si vous devez effectuer une restauration à partir d'une mise à niveau. Pour plus d'informations, voir Sauvegarder l'intégralité de l'environnement avant une mise à niveau sur place (SharePoint Foundation 2010).

  8. (Facultatif) Si vous utilisez la méthode de mise à niveau avec liaison des bases de données, configurez les bases de données d'origine en lecture seule.

    Si vous envisagez une plage d'indisponibilité étendue pendant une mise à niveau avec liaison des bases de données, vous pouvez configurer en lecture seule les bases de données dans l'environnement d'origine afin que les utilisateurs puissent continuer à accéder à leurs données sans les modifier. Pour plus d'informations, voir Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010.

  9. N'ajoutez aucun serveur à votre batterie de serveurs après avoir lancé le processus de mise à niveau.

    L'exécution de l'Assistant Configuration des produits SharePoint met à niveau la base de données de configuration. Cette base de données contient la liste des serveurs de la batterie. Les serveurs ajoutés à la batterie après l'exécution de l'Assistant de configuration ne sont pas inclus à la base de données. Par conséquent, les serveurs ajoutés après son exécution n'apparaissent pas dans la topologie de la version mise à niveau. Si vous devez ajouter des serveurs à votre batterie, faites-le avant de démarrer la mise à niveau ou après avoir terminé le processus de mise à niveau.

  10. Après la mise à niveau, examinez la page État de la mise à niveau et les journaux de mise à niveau pour déterminer si des problèmes doivent être résolus. Ensuite, passez en revue les sites mis à niveau.

    La page État de la mise à niveau contient des informations détaillées sur le processus de mise à niveau, tandis que les journaux de mise à niveau répertorient les erreurs ou avertissements qui se sont éventuellement produits pendant ce processus. Vous devez vérifier tous les sites et les tester avant de considérer que la mise à niveau est terminée. Pour plus d'informations, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Passer en revue les chemins de mise à niveau pris en charge et non pris en charge (SharePoint Foundation 2010)

Lorsque vous planifiez votre processus de mise à niveau, vérifiez que le chemin de mise à niveau à suivre est pris en charge. Cet article décrit les chemins de mise à niveau pris en charge et non pris en charge pour une mise à niveau sur place et indique les topologies pouvant être mises à niveau sur place vers Microsoft SharePoint Foundation 2010.

Passer en revue les topologies prises en charge pour la mise à niveau

Lorsque vous effectuez une mise à niveau, vous devez la réaliser vers le même type d'installation : serveur autonome vers serveur autonome ou batterie de serveurs vers batterie de serveurs. Vous ne pouvez pas effectuer une migration depuis un serveur autonome vers une batterie de serveurs ou vice versa pendant un processus de mise à niveau sur place. Toutefois, avant ou après la mise à niveau, vous pouvez modifier la taille et l'échelle d'une batterie de serveurs en fonction de vos besoins. Par ailleurs, si vous effectuez une mise à niveau avec liaison des bases de données, vous pouvez attacher les bases de données à un type d'installation différent.

Aide sur la topologie physique

La topologie Microsoft SQL Server, en plus du réseau, du stockage physique et de la mise en cache, peut avoir une incidence significative sur les performances du système. Lorsque vous planifiez la configuration matérielle, gardez à l'esprit que pour une mise à niveau sur place, le serveur ou la batterie de serveurs que vous mettez à niveau doit exécuter une version 64 bits de Windows Server 2008 R2 ou Windows Server 2008 avec Service Pack 2 (SP2). Dans le cas des batteries de serveurs, vous devez également exécuter une version 64 bits de Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3. Pour plus d'informations sur les contraintes liées à la mise à niveau, voir Examiner la configuration requise pour la mise à niveau (SharePoint Foundation 2010).

Topologies prises en charge

Le tableau suivant répertorie les topologies de début prises en charge dans Windows SharePoint Services 3.0, ainsi que les topologies de fin prises en charge et non prises en charge lors d'une mise à niveau sur place vers SharePoint Foundation 2010.

Topologie de début (Windows SharePoint Services 3.0) | Topologie de fin prise en charge (SharePoint Foundation 2010) | Topologie de fin non prise en charge (SharePoint Foundation 2010)
Serveur autonome avec base de données interne Windows | Serveur autonome avec Microsoft SQL Server 2008 Express | Toute batterie de serveurs
Serveur unique avec SQL Server | Serveur unique avec SQL Server | Serveur autonome avec Microsoft SQL Server 2008 Express
Batterie de serveurs de n'importe quelle taille | Batterie de serveurs de n'importe quelle taille | Serveur autonome avec Microsoft SQL Server 2008 Express

Migration depuis un serveur autonome vers une batterie de serveurs

Si vous souhaitez passer d'un serveur autonome à une batterie de serveurs, vous pouvez effectuer cette opération avant de procéder à la mise à niveau. Pour réaliser une migration depuis un serveur autonome vers une configuration de batterie de serveurs, vous devez créer une batterie de serveurs, puis déplacer les bases de données depuis le serveur autonome vers la batterie de serveurs. Pour plus d'informations, voir Migrer des bases de données de contenu entre la base de données interne de Windows et une instance de SQL Server (Windows SharePoint Services 3.0). Une fois la migration effectuée, vous pouvez procéder à la mise à niveau vers SharePoint Foundation 2010.

Migration à partir d'une configuration matérielle 32 bits

Vous ne pouvez pas effectuer une mise à niveau sur place depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 si votre configuration matérielle repose sur une architecture 32 bits. Dans ce cas, vous devez d'abord effectuer une migration vers une configuration matérielle 64 bits. Pour plus d'informations, voir Migrer une batterie de serveurs existante vers un environnement 64 bits (Windows SharePoint Services 3.0) (éventuellement en anglais).

Historique des modifications


Examiner la configuration requise pour la mise à niveau (SharePoint Foundation 2010)

Pour que vous puissiez mettre à niveau votre environnement depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, vos serveurs doivent présenter la configuration minimale requise suivante :

  • Pour exécuter la nouvelle version, le matériel et les logiciels doivent satisfaire ou dépasser la configuration système minimale requise.

    Cela implique l'utilisation d'un matériel 64 bits et de versions 64 bits du système d'exploitation et de Microsoft SQL Server. Avant de commencer le processus de mise à niveau, assurez-vous que votre système satisfait ou dépasse la configuration minimale requise indiquée dans Configuration matérielle et logicielle requise (SharePoint Foundation 2010). Avant de procéder à la mise à niveau, déterminez la capacité de production que devra offrir votre environnement mis à niveau, puis, à partir de ces informations, identifiez le matériel nécessaire pour votre mise à niveau.

  • Windows SharePoint Services 3.0 doit être mis à jour vers Service Pack 2.

    Votre environnement doit être mis à jour vers au moins le Service Pack 2 de Windows SharePoint Services 3.0 pour que vous puissiez exécuter le processus de mise à niveau, qu'il s'agisse d'une mise à niveau sur place ou d'une mise à niveau avec liaison des bases de données. Il est recommandé d'installer la mise à jour cumulative d'octobre 2009, car elle comprend des améliorations apportées à l'outil de vérification de pré-mise à niveau. Pour plus d'informations sur l'installation des Service Packs et des mises à jour, voir le centre de ressource des mises à jour pour les produits et technologies SharePoint (éventuellement en anglais). Pour la liste de toutes les mises à jour disponibles, voir le centre des mises à jour pour Microsoft Office, les produits Office Server et les produits connexes (éventuellement en anglais).

À propos de ces configurations requises

Il est important que votre matériel respecte les configurations minimales requises répertoriées dans l'article Configuration matérielle et logicielle requise (SharePoint Foundation 2010) ; sinon, vous pourriez rencontrer des problèmes au cours du processus de mise à niveau. Par exemple, si votre serveur de bases de données n'a pas suffisamment de mémoire ou de puissance de processeur, il sera peut-être dans l'impossibilité de prendre en charge toutes les transactions qui se produisent pendant le processus de mise à niveau, et la mise à niveau peut échouer.

Il est recommandé d'utiliser une mise à niveau d'évaluation pour déterminer exactement la capacité matérielle nécessaire pour une expérience de mise à niveau acceptable. Pour plus d'informations, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010). Si vous rencontrez des problèmes de capacité liés au matériel pendant la mise à niveau d'évaluation, vous pouvez accroître la capacité et répéter la mise à niveau jusqu'à ce que vous ayez obtenu le niveau de performance de mise à niveau optimal.

Important :
Il est important de suivre les trois composants de ressources suivants d'un serveur exécutant SQL Server : le processeur, la mémoire et le sous-système d'E/S. Lorsqu'un ou plusieurs de ces composants semblent utilisés au maximum de leur capacité, analysez la stratégie appropriée en fonction de la charge de travail actuelle et prévisionnelle. Ensuite, déterminez s'il faut ajouter des ressources ou procéder à une montée en puissance vers un nouveau serveur exécutant SQL Server. En règle générale, il est recommandé d'envisager une montée en puissance en plus de l'ajout de ressources supplémentaires.

Historique des modifications


Déterminer comment gérer les personnalisations (SharePoint Foundation 2010)

Si vous avez effectué de nombreuses personnalisations dans vos sites basés sur Windows SharePoint Services 3.0, vous devez déterminer la façon dont vous souhaitez gérer vos sites personnalisés lors de la mise à niveau vers Microsoft SharePoint Foundation 2010. Votre approche dépendra de l'étendue des personnalisations, du type de personnalisation, de la complexité de votre site et de vos objectifs en termes de mise à niveau. Avant d'effectuer une mise à niveau, vous devez identifier, puis évaluer les personnalisations dans votre environnement et déterminer si vous allez les mettre à niveau et selon quelles modalités.

Dans cet article :

  • Identifier les personnalisations dans votre environnement

  • Évaluer les personnalisations

  • Considérations pour des personnalisations spécifiques

  • Veiller à ce que les personnalisations futures suivent les meilleures pratiques

Identifier les personnalisations dans votre environnement

Dans le cadre du processus de test de la mise à niveau, vous devez créer un inventaire des personnalisations côté serveur dans votre environnement (solutions, fonctionnalités, composants WebPart, gestionnaires d'événements, pages maîtres, mises en page, fichiers CSS, etc.). Pour plus d'informations sur l'identification des personnalisations, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010). Vous pouvez utiliser la feuille de calcul relative à la planification de la mise à niveau pour répertorier les personnalisations spécifiques, puis enregistrer les résultats de votre évaluation dans la section suivante. Téléchargez la feuille de calcul à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C (éventuellement en anglais).

Évaluer les personnalisations

Après avoir identifié les personnalisations, vous pouvez décider de ce que vous souhaitez en faire. Les questions suivantes vous permettent d'évaluer les personnalisations :

  • La personnalisation est-elle toujours importante ?

    • Répond-elle à un besoin d'entreprise utile ?

    • Est-elle largement déployée et utilisée ?

  • La personnalisation est-elle correctement conçue ?

    • Repose-t-elle sur des définitions de site prédéfinies prises en charge ?

    • Suit-elle les meilleures pratiques pour les personnalisations ?

    • S'agit-il d'un type de personnalisation pris en charge ou représente-t-elle un risque pour votre environnement ?

Lorsque vous évaluez chaque personnalisation individuelle, vous pouvez également vous pencher sur votre approche globale des personnalisations. Les options suivantes sont à votre disposition :

  1. Conserver les personnalisations Utilisez la mise à niveau visuelle pour continuer à utiliser l'expérience utilisateur de la version précédente pour des sites spécifiques. Bien que vous puissiez utiliser cette approche pour conserver les mêmes fonctionnalités, vous ne pourrez pas tirer parti des nouveaux effets visuels, tels que l'interface utilisateur Fluent, également appelée le Ruban, et des fonctionnalités disponibles dans la nouvelle version.

  2. Remplacer ou rétablir les personnalisations Si vous souhaitez utiliser de nouvelles fonctionnalités, envisagez de refondre vos sites ou modifiez de manière significative l'architecture des informations, la mise à niveau offre une occasion d'apporter de nouvelles fonctionnalités, d'offrir un nouvel aspect ou de définir une nouvelle organisation. Lorsque vous remplacez ou rétablissez des personnalisations, vous pouvez tirer parti des nouvelles fonctionnalités, modifier légèrement la conception ou opter pour une conception plus facile à gérer.

    Pour plus d'informations sur le rétablissement et le redéploiement des solutions, voir Redéploiement des personnalisations et des solutions dans SharePoint Foundation 2010 et SharePoint Server 2010 (http://go.microsoft.com/fwlink/?linkid=182335&clcid=0x40C).

  3. Abandonner les personnalisations Remplacez les personnalisations en utilisant des fonctionnalités par défaut. Vous pouvez redéfinir les pages sur les définitions de site par défaut et supprimer les composants WebPart ou les fonctionnalités que vous ne souhaitez plus prendre en charge. Si vous décidez d'abandonner des personnalisations, vous devez résoudre les problèmes engendrés par cette suppression dans les sites qui utilisaient ces personnalisations. Vous pouvez utiliser l'inventaire de vos personnalisations pour déterminer les sites qui requièrent ce type d'attention avant ou après la mise à niveau.

Considérations pour des personnalisations spécifiques

Outre prendre une décision globale quant à la façon dont les personnalisations doivent être traitées dans votre environnement pendant la mise à niveau, vous devez examiner les types spécifiques de personnalisations pour déterminer si vous devez effectuer des actions supplémentaires afin qu'elles fonctionnent dans l'environnement mis à niveau.

Le tableau suivant répertorie certaines personnalisations courantes et indique une recommandation pour le traitement du type de personnalisation concerné.

Type de personnalisation Recommandation

Modèles de sites (fichiers .stp)

Les fichiers de modèles de sites (.stp) constituent une fonctionnalité obsolète dans SharePoint Foundation 2010. Les nouveaux modèles de sites dans SharePoint Foundation 2010 sont enregistrés en tant que fichiers .wsp (packages de solutions).

Un site qui a été mis en service à l'aide d'un modèle de site sera mis à niveau, mais vous ne pourrez pas créer de sites basés sur ce modèle. Pour créer des sites, vous pouvez créer et déployer un package de solution. Pour plus d'informations, voir Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010).

Définition de site

Migrez les sites vers une définition de site prédéfinie prise en charge, puis appliquez les fonctionnalités personnalisées à l'aide d'un déploiement de solution.

Vous pouvez également continuer à utiliser une définition de site personnalisée. Vous n'avez pas besoin de créer une définition de site basée sur SharePoint Foundation 2010.

Toutefois, si vous devez effectuer des opérations de mise à niveau personnalisées pour la définition, vous pouvez être amené à créer un fichier de définition de mise à niveau pour cette définition de site. Pour plus d'informations, voir Fichiers de définition de mise à niveau (http://go.microsoft.com/fwlink/?linkid=182339&clcid=0x40C) sur MSDN.

Modèles d'applications « Fabulous 40 »

Microsoft ne crée pas de nouvelles versions de ces modèles. Les sites basés sur ces modèles peuvent être mis à niveau, mais assurez-vous de tester chaque site avant de mettre à niveau l'environnement de production. Pour plus d'informations, voir Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010).

Fonctionnalité

Effectuez une évaluation, puis, si nécessaire, une remise à plat ou un redéploiement.

Flux de travail et contrôles serveur

Dépend de la solution. Contactez le fournisseur pour déterminer s'il existe une solution mise à jour. Si un flux de travail est compatible avec la nouvelle version, effectuez un redéploiement.

Gestionnaire d'événements

Effectuez une réécriture et un redéploiement en tant que fonctionnalité.

Chemins d'accès gérés (inclusions/exclusions)

Recréez les inclusions pour une mise à niveau avec liaison des bases de données. Les exclusions sont prises en compte et n'ont pas besoin d'être recréées.

Thèmes

En raison des nombreuses modifications apportées à l'interface utilisateur, les thèmes personnalisés basés sur Windows SharePoint Services 3.0 ne fonctionneront pas dans SharePoint Foundation 2010. Utilisez la mise à niveau visuelle pour continuer à utiliser les sites dans l'ancienne expérience utilisateur jusqu'à ce que vous puissiez créer et appliquer un nouveau thème basé sur SharePoint Foundation 2010.

Actions liées à la barre d'outils

Déplacer vers le Ruban (interface utilisateur Fluent).

Pages maîtres et fichiers CSS

Modifier la conception de manière à prendre en charge la nouvelle expérience utilisateur.

JavaScript

Effectuez un test pour déterminer si des actions sont requises. Dans certains cas, vous pouvez être amené à ajuster les scripts afin qu'ils fonctionnent avec le nouveau modèle de page. Vérifiez le fonctionnement sur un site mis à niveau, puis dans les deux modes de mise à niveau visuelle.

Fournisseur de recherche ou découpage de sécurité

Effectuez un test pour déterminer si des actions sont requises.

Composants WebPart

Effectuez un test pour déterminer si des actions sont requises. Vous pouvez être amené à ajuster les composants WebPart afin qu'ils fonctionnent avec le mode XHMTL strict.

Si un composant WebPart se trouve sur une page, mais pas dans une zone de composant WebPart (de sorte qu'il s'agisse schématiquement de code HTML directement incorporé dans une page), il ne fonctionnera pas si vous redéfinissez la page sur le modèle par défaut.

Services

Effectuez un test pour déterminer si des actions sont requises. Recréez ou ajustez le code, selon vos besoins.

Fournisseurs d'authentification

Effectuez un test pour déterminer si des actions sont requises. Redéployez le fournisseur sur une batterie de serveurs de test et vérifiez qu'il fonctionne correctement avec l'authentification par revendications.

Les types de personnalisations suivants ne sont pas pris en charge. Si votre environnement en comporte, vous devez les remplacer par un type de personnalisation pris en charge avant d'effectuer la mise à niveau. Sinon, vous risquez de rencontrer des problèmes de mise à niveau insolubles :

  • Définitions de site, fonctionnalités ou fichiers prédéfinis ayant été modifiés.

    Avertissement :
    Certains types de fichiers prédéfinis, tels que les actions ou les icônes de document, peuvent être modifiés et, bien qu'ils ne soient pas mis à niveau, ces modifications peuvent être répercutées de manière à ce qu'elles soient prises en charge. Les modifications apportées aux autres fichiers prédéfinis, tels que les pages ASPX côté serveur, seront perdues pendant la mise à niveau si vous réappliquez le modèle de site. Suivant les fichiers modifiés et l'étendue de ces modifications, l'expérience de mise à niveau peut varier sensiblement. Il est fortement recommandé de rétablir toutes les modifications dans tous les fichiers sur le disque.

  • Bases de données SharePoint ayant été modifiées, par modification directe des données ou par modification du schéma, au moyen d'opérations telles que l'ajout ou la suppression de déclencheurs, de tables, de vues ou d'index.

Si vous possédez des personnalisations de ces types, supprimez-les et remplacez-les par des personnalisations prises en charge avant de procéder à la mise à niveau. Cette meilleure pratique garantit le bon fonctionnement de votre mise à niveau actuelle et une meilleure souplesse des mises à niveau futures. La modification des fichiers et des bases de données prédéfinis demeurera non prise en charge.

Veiller à ce que les personnalisations futures suivent les meilleures pratiques

Vérifiez que votre environnement fonctionne correctement et qu'il suit les meilleures pratiques. Déployez uniquement les personnalisations qui suivent les meilleures pratiques décrites dans les articles suivants sur MSDN et TechNet :

  • Méthodes recommandées : utilisation des objets disponibles de Windows SharePoint Services (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=105945&clcid=0x40C).

  • Outils et techniques de développement pour l'utilisation du code dans Windows SharePoint Services 3.0 (partie 1 sur 2) (http://go.microsoft.com/fwlink/?linkid=101494&clcid=0x40C).

  • Méthodes recommandées : Problèmes de codage courants rencontrés avec le modèle d'objet SharePoint (http://go.microsoft.com/fwlink/?linkid=105946&clcid=0x40C).

  • Stratégie de personnalisation de produits et technologies SharePoint (livre blanc) (http://go.microsoft.com/fwlink/?linkid=105947&clcid=0x40C).

Historique des modifications

Date | Description | Raison
23 septembre 2010 | 2010/09/20 | Mise à jour du contenu


Créer un plan de communication (SharePoint Foundation 2010)

Il est important de communiquer avec les utilisateurs pendant le processus de mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010. Les utilisateurs de sites doivent savoir à quoi s'attendre lorsqu'ils visiteront de nouveau leurs sites après la mise à niveau, tandis que les propriétaires de sites doivent savoir comment préparer la mise à niveau et ce qu'ils devront faire après celle-ci. Les utilisateurs de sites comme les propriétaires de sites doivent savoir à quel moment la mise à niveau aura lieu. Dans le cadre du processus de planification, déterminez les points suivants :

  • Quels sont les membres de votre équipe de mise à niveau, quelles sont les autres parties prenantes impliquées et qui sera concerné par la mise à niveau.

  • Quelles sont les informations que l'équipe de mise à niveau doit détenir et à quel moment doit-elle être en leur possession.

  • Quelles sont les informations que les utilisateurs de sites et les autres parties prenantes doivent détenir et à quel moment doivent-ils être en leur possession.

Cet article explique comment créer votre plan de communication afin que l'équipe de mise à niveau, les parties prenantes et les utilisateurs sachent à quoi s'attendre avant, pendant et après la mise à niveau.

Dans cet article :

  • Qui est membre de l'équipe de mise à niveau ?

  • Quand et comment communiquer avec l'équipe de mise à niveau ?

  • Quand et comment communiquer avec les utilisateurs de sites ?

Qui est membre de l'équipe de mise à niveau ?

Pour les petits déploiements dans lesquels les sites n'ont subi qu'une petite part de personnalisation, l'équipe de mise à niveau peut être composée d'une seule personne. Pour les déploiements de plus grande taille, en revanche, plusieurs personnes avec différents rôles peuvent être nécessaires, comme décrit dans la liste suivante :

  • Administrateurs du serveur L'administrateur du serveur effectue la plupart des tâches de mise à niveau. Il doit y avoir au moins un administrateur du serveur dans l'équipe de mise à niveau, car l'exécution de l'Assistant Installation exige la présence d'une personne qui soit membre du groupe Administrateurs local sur chaque serveur Web frontal.

    Remarque :
    Les administrateurs de la batterie peuvent ne pas être administrateurs locaux du serveur.

  • Administrateurs de base de données Si vous disposez d'une équipe d'administration de base de données spécifique, vous devez planifier et effectuer la mise à niveau en coordination avec celle-ci, notamment si vous envisagez d'utiliser la méthode de mise à niveau avec liaison des bases de données.

  • Équipes de la sécurité du serveur Vous devez collaborer avec vos équipes de sécurité, telles que l'équipe des services d'annuaire Active Directory, pour vérifier les comptes et les autorisations ou pour tirer parti des nouveaux paramètres de stratégie applicables pour SharePoint Foundation 2010.

  • Équipe du déploiement du client Communiquez avec les équipes de déploiement du client pour coordonner les déploiements des nouvelles applications clientes et serveur. Le déploiement du client devra peut-être avoir lieu avant que vous n'effectuiez la mise à niveau ou, à l'initiative des utilisateurs, après la mise à niveau de leurs sites.

  • Propriétaires de collection de sites Vous devez avertir les propriétaires de collection de sites lorsque le processus de mise à niveau est sur le point d'être exécuté et les prévenir de tous les problèmes que vous détectez lorsque vous exécutez l'outil de vérification de pré-mise à niveau ou mettez à niveau leurs sites. Si vous utilisez la mise à niveau visuelle, vous devez également communiquer avec les propriétaires de collection de sites au sujet de l'adoption de la nouvelle interface utilisateur et indiquer si les administrateurs de batterie ou les administrateurs de collection de sites accompliront cette modification.

  • Concepteurs et développeurs de sites Si vous disposez de modèles personnalisés, composants WebPart, services Web ou autres éléments personnalisés associés à vos sites, vous devez collaborer avec les personnes chargées du développement ou de la personnalisation de ces éléments pour vous assurer que vous pouvez créer de nouvelles versions de ces éléments personnalisés ou vérifier que ces derniers ont été correctement mis à niveau. Pour plus d'informations sur les problèmes potentiels liés aux éléments personnalisés, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010).

  • Utilisateurs des sites Bien que vous n'ayez pas besoin d'inclure les utilisateurs des sites dans la prise de décision concernant le processus de mise à niveau, vous devez les informer de la date et du déroulement de l'opération.

  • Commanditaires et autres parties prenantes Il est possible que d'autres personnes de votre organisation soient impliquées dans le processus de planification de mise à niveau. N'oubliez pas de les inclure à votre plan de communication de manière appropriée.

    Remarque :
    Une équipe de mise à niveau peut comporter un ou plusieurs membres de chaque rôle en fonction de votre organisation.

Quand et comment communiquer avec l'équipe de mise à niveau ?

En règle générale, les administrateurs du serveur et les administrateurs des services partagés définissent la chronologie de la mise à niveau, et les propriétaires de sites sont uniquement avertis lorsque le processus est sur le point de commencer. Toutefois, étant donné que les membres de l'équipe ont leurs propres tâches à effectuer à des stades particuliers du processus global de mise à niveau, il est essentiel que vous disposiez d'un solide plan de communication pour communiquer la progression de la mise à niveau à tous les membres de l'équipe afin qu'ils sachent à quel moment effectuer ces tâches particulières.

L'ensemble de l'équipe de mise à niveau doit collaborer pour déterminer les éléments suivants :

  • La méthode de mise à niveau à utiliser L'article Déterminer l'approche de mise à niveau (SharePoint Foundation 2010) contient des informations pour vous aider à déterminer le type de mise à niveau à effectuer. Le rapport généré par l'outil de vérification de pré-mise à niveau est également important à prendre en compte lorsque vous prenez cette décision.

  • Les dates et heures auxquelles effectuer la mise à niveau Nous vous recommandons (notamment pour une mise à niveau sur place) d'effectuer une mise à niveau dans une période de faible utilisation du site. Pour les déploiements de serveur unique de petite taille, la mise à niveau peut prendre moins d'une journée. Pour les déploiements de plus grande importance, tels que les batteries de serveur comportant une grande quantité de données, la méthode de mise à niveau avec liaison des bases de données ou la méthode de mise à niveau sur place avec bases de données détachées peut être utilisée pour répartir le processus de mise à niveau sur plusieurs messagesplages d'indisponibilité. Aucune méthode ne permet de déterminer la durée exacte requise par la mise à niveau d'une collection de sites particulière. De ce fait, il est très important de communiquer avec les autres membres de l'équipe impliqués dans le processus de mise à niveau, en plus des utilisateurs finaux. La ou les dates que vous choisissez pour la mise à niveau doivent être décidées suffisamment à l'avance pour donner à l'équipe de mise à niveau le temps d'effectuer toutes les étapes préliminaires. Lorsque vous planifiez la chronologie, veillez à planifier une période pour valider les sites mis à jour et une période pour implémenter toutes les modifications ou effectuer le travail de repersonnalisation des sites.

Il est important de communiquer avec les propriétaires, les concepteurs et les développeurs de sites aux stades suivants du processus de mise à niveau :

  • Avant le démarrage du processus, de sorte qu'ils connaissent la chronologie générale et sachent quel sera leurs rôles dans le processus.

  • Après l'exécution de l'outil de vérification de pré-mise à niveau, pour leur permettre de résoudre tous les problèmes identifiés par l'outil. Pour plus d'informations sur l'outil de vérification de pré-mise à niveau, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010). Par exemple, des problèmes tels que des modèles de sites personnalisés ou des composants WebPart personnalisés doivent être signalés au propriétaire, concepteur ou développeur de site approprié avant que vous ne planifiiez la mise à niveau pour lui laisser le temps d'étudier les problèmes et de prendre les mesures préliminaires. De même, un développeur peut décider qu'il serait plus prudent de reconstruire un composant WebPart avant la mise à niveau. Ou encore, des propriétaires de sites peuvent souhaiter noter toutes les personnalisations qui ont été effectuées sur leurs sites, notamment les modèles de sites et les modifications apportées aux fichiers ASPX (Active Server Page Extension) principaux.

  • Après la mise à niveau de leurs sites, afin qu'ils puissent consulter les sites et effectuer toutes les modifications nécessaires.

Quand et comment communiquer avec les utilisateurs de sites ?

Il est tout aussi important communiquer avec les utilisateurs des sites pour les informer des points suivants :

  • Quand leurs sites seront mis à niveau Dans le cas d'une mise à niveau sur place, ils doivent également être informés que leurs sites seront indisponibles au cours de la mise à niveau.

  • Quand leurs sites mis à niveau seront prêts Ceci signifie que l'équipe de mise à niveau aura non seulement effectué la mise à niveau, mais également vérifié la fonctionnalité des sites mis à niveau.

  • Comment la mise à niveau les affecte et ce qu'ils doivent savoir à propos du nouvel environnement Par exemple, le site aura un aspect différent ou fonctionnera légèrement différemment avec la nouvelle interface utilisateur. Si vous utilisez la mise à niveau visuelle, indiquez aux utilisateurs s'ils bénéficieront de la nouvelle ou de l'ancienne expérience utilisateur, et ce à quoi ils peuvent s'attendre. Vous pouvez aussi les faire pointer vers du contenu disponible, tel que des articles intitulés Nouveautés ou des documents de formation, pour en savoir plus sur la nouvelle version. Pour plus d'informations sur les modifications des fonctionnalités et la mise à niveau visuelle, voir Planifier une mise à niveau visuelle (SharePoint Foundation 2010) et Modifications des fonctionnalités clés entre les versions dans l'article « Nouveautés dans la mise à niveau ».

  • Comment obtenir de l'aide S'ils rencontrent un problème avec leur site après la mise à niveau, quelle procédure doivent-ils suivre pour le résoudre ?

Historique des modifications


Planifier une mise à niveau visuelle (SharePoint Foundation 2010)
Voir aussi

Cet article traite de la nouvelle fonctionnalité de mise à niveau visuelle dans Microsoft SharePoint Foundation 2010. Si votre organisation envisage d'effectuer une mise à niveau de Windows SharePoint Services 3.0, vous pouvez tirer parti de cette nouvelle fonctionnalité. Par défaut, l'apparence des sites est conservée durant une mise à niveau à partir de Windows SharePoint Services 3.0. Les propriétaires de sites peuvent soit basculer vers la nouvelle interface utilisateur de manière définitive, soit afficher un aperçu de la nouvelle interface utilisateur pour leurs sites SharePoint. En utilisant la fonctionnalité de mise à niveau visuelle, vous pouvez déplacer tous les sites vers la nouvelle interface utilisateur. Si vous choisissez cette dernière option, vous remplacez l'interface utilisateur des propriétaires de collections de sites et des propriétaires de sites. Vous avez également la possibilité de conserver des pages personnalisées ou de réinitialiser l'ensemble des pages personnalisées. Les deux choix entraînent une mise à jour de l'apparence des pages de modèles ; toutefois, la réinitialisation entraîne la suppression des modifications apportées aux pages personnalisées et ne peut pas être annulée.

Remarque :
La fonctionnalité de mise à niveau visuelle n'est pas disponible si vous effectuez une mise à niveau sur un seul serveur avec une base de données intégrée via l'Assistant Configuration des produits SharePoint. Cependant, la fonctionnalité de mise à niveau visuelle est toujours disponible si vous utilisez l'outil en ligne de commande PSConfig pour la mise à niveau.

Cet article répertorie les considérations les plus importantes en matière de planification de la mise à niveau visuelle ; en outre, il décrit les problèmes connus. Pour plus d'informations, voir Gérer une mise à niveau visuelle (SharePoint Foundation 2010).

Dans cet article :

  • Phase de planification clé de la mise à niveau visuelle

  • Formation des propriétaires de collections de sites et des propriétaires de sites

  • Problèmes connus

Phase de planification clé de la mise à niveau visuelle

La mise à niveau visuelle est une fonctionnalité qui fait partie du processus de mise à niveau. Avant d'effectuer la mise à niveau, assurez-vous de prendre en considération les conséquences liées aux deux choix distincts offerts par la mise à niveau visuelle.

Conservation de l'interface utilisateur existante

Si vous choisissez de conserver l'apparence des sites SharePoint existants, vous donnez aux propriétaires de collections de sites le contrôle sur leurs collections de sites et aux propriétaires de sites le contrôle sur leurs sites. L'ensemble des données et paramètres des sites d'origine est conservé ; en outre, la disposition, l'organisation des commandes et les styles conservent l'interface utilisateur antérieure. Quel que soit le type de mise à niveau de batterie de serveurs sélectionné, vous tirez parti de tous les avantages en matière d'infrastructure de Microsoft SharePoint Foundation 2010, notamment l'amélioration de la fiabilité, de l'évolutivité et de la simplicité de gestion. La conservation de l'interface utilisateur antérieure réduit la probabilité qu'un contenu personnalisé cesse de fonctionner. Par conséquent, vous et les autres utilisateurs êtes assurés de pouvoir continuer à utiliser les sites SharePoint existants jusqu'à la fin du travail de mise à niveau (y compris le dépannage et la mise à jour des personnalisations).

Mise à niveau vers la nouvelle interface utilisateur

Si vous choisissez de modifier tous les sites SharePoint existants en les mettant à niveau vers la nouvelle interface utilisateur, les propriétaires de collections de sites et les propriétaires de sites n'ont aucun contrôle sur la mise à niveau. L'ensemble des données et paramètres des sites SharePoint existants est mis à niveau vers la nouvelle interface utilisateur. Vous pouvez choisir cette option s'il n'existe aucune personnalisation, ou si vous avez testé les personnalisations dont vous avez besoin avant la mise à niveau. Même si vous choisissez cette option, vous avez toujours la possibilité de conserver les pages personnalisées ou de réinitialiser ces dernières. Si vous devez conserver des personnalisations, ou si vous ignorez s'il convient de le faire, il est recommandé de conserver les pages personnalisées. La réinitialisation des pages personnalisées entraîne la suppression des personnalisations et ne peut pas être annulée. Choisissez cette option si vous n'avez plus besoin des personnalisations et si vous savez qu'aucune donnée importante ne sera perdue. Pour plus d'informations, voir Déterminer comment gérer les personnalisations (SharePoint Foundation 2010), Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010) et Redéploiement de personnalisations et de solutions dans SharePoint Foundation 2010 et SharePoint Server 2010 (http://go.microsoft.com/fwlink/?linkid=186372&clcid=0x40C).

Formation des propriétaires de collections de sites et des propriétaires de sites

Il est important que vous formiez les utilisateurs afin qu'ils comprennent les effets liés à la conservation de l'apparence des sites SharePoint existants ou à la mise à niveau de l'ensemble des sites vers la nouvelle interface utilisateur. Grâce à cette formation, les utilisateurs sont préparés et savent à quoi s'attendre, ce qui contribue à réduire les efforts et les frustrations du support technique.

Si vous mettez à niveau tous les sites vers la nouvelle interface utilisateur, informez les utilisateurs sur les modifications et les nouvelles fonctionnalités, par exemple le ruban, la nouvelle interface de modification des pages et les calendriers interactifs. En outre, décrivez aux utilisateurs les problèmes éventuels auxquels ils peuvent être confrontés. Par exemple, ils peuvent rencontrer des problèmes au niveau des personnalisations, à savoir des pages qui ne s'affichent pas correctement. Pour plus d'informations sur les problèmes généraux de mise à niveau, voir Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010).

Si vous décidez de conserver l'apparence des sites SharePoint existants, expliquez aux propriétaires de collections de sites et aux propriétaires de sites que l'interface utilisateur ne changera pas durant la mise à niveau. Par ailleurs, informez ces personnes sur les choix dont elles disposent.

Par défaut, les propriétaires de sites ont le contrôle de leurs sites. Ils peuvent utiliser l'option Afficher un aperçu des nouveaux effets visuels (sous Paramètres du site) pour afficher l'aperçu de la nouvelle interface utilisateur, et basculer ensuite entre l'ancienne et la nouvelle interface utilisateur. Cela leur donne le temps de s'assurer que tout fonctionne correctement et de corriger les problèmes qui surviennent dans leurs pages à l'issue de la mise à niveau. Lorsque les propriétaires de sites sont prêts, ils peuvent mettre à jour leurs sites vers la nouvelle interface utilisateur. Cependant, les propriétaires de collections de sites ont la possibilité de finaliser la nouvelle interface utilisateur, ce qui remplace le contrôle dont les propriétaires de sites disposent sur la mise à niveau visuelle de leurs sites. Si les propriétaires de collections de sites veulent garder la précédente interface utilisateur pour leur collection de sites, ils ont également la possibilité de masquer les paramètres de mise à niveau visuelle des propriétaires de sites.

Les propriétaires de sites doivent également savoir que s'ils apportent des modifications à la nouvelle interface utilisateur en mode Aperçu et s'ils reviennent ensuite à la précédente interface utilisateur, ces informations risquent de ne pas s'afficher correctement.

Il est recommandé de planifier et de définir un délai maximal d'utilisation de la précédente interface utilisateur dans votre déploiement SharePoint. Par exemple, chaque administrateur de la collection de sites peut disposer de 90 jours pour travailler avec ses propriétaires de sites à la transition entre la précédente et la nouvelle interface utilisateur. Veillez à communiquer ce délai maximal aux utilisateurs. Ces derniers ont ainsi la garantie de disposer d'un délai raisonnable pour se familiariser avec la nouvelle interface utilisateur et résoudre les problèmes susceptibles de se produire au cours de la mise à niveau. Si vous définissez un délai maximal pour les utilisateurs, informez-les également qu'à l'expiration de ce délai, vous pourrez forcer la mise à niveau de tous les sites. Pour plus d'informations, voir Gérer une mise à niveau visuelle (SharePoint Foundation 2010).

Si les propriétaires de collections de sites décident d'utiliser la nouvelle interface utilisateur pour tous les sites de leur collection de sites, ils ne peuvent pas changer d'avis. Cependant, en tant qu'administrateur de batterie de serveurs, vous pouvez modifier ces paramètres en restaurant la précédente interface utilisateur de ces sites à l'aide de Windows PowerShell ou du modèle objet SharePoint. Pour plus d'informations, voir Gérer une mise à niveau visuelle (SharePoint Foundation 2010).

Il est important de dire aux propriétaires de collections de sites et aux propriétaires de sites que tant que les sites utilisent la précédente interface utilisateur, les nouvelles fonctionnalités (par exemple le ruban, la modification sur place des pages Wiki, les calendriers interactifs et les relations de liste) ne sont pas disponibles. Cependant, une fois que les sites ont basculé vers la nouvelle interface utilisateur, les fonctionnalités de l'application apparaissent automatiquement. En outre, il est essentiel de noter que tous les nouveaux sites créés après la mise à niveau utilisent par défaut la nouvelle interface utilisateur.

Problèmes connus

Il existe quelques problèmes connus à prendre en considération :

  • Si vous utilisez SharePoint Foundation 2010, veillez à vous servir de la même version et du même Service Pack que SharePoint Designer.

Voir aussi

Concepts

Mise à niveau sur place de SharePoint Foundation 2010
Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010
Mise à niveau vers SharePoint Foundation 2010

Historique des modifications

Date | Description | Raison
10 juin 2010 | 2010/06/07 | Mise à jour du contenu


Test de la mise à niveau et résolution des problèmes liés à celle-ci (SharePoint Foundation 2010)

Avant d'effectuer une mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, vous devez prendre le temps de tester votre processus de mise à niveau et déterminer les problèmes susceptibles d'affecter la mise à niveau proprement dite. Cette section indique la procédure à suivre pour tester la mise à niveau et utiliser les informations de ce test afin d'évaluer le temps et l'espace qui seront nécessaires pour la mise à niveau, ainsi que les étapes que vous pouvez suivre pour nettoyer votre environnement avant d'effectuer la mise à niveau proprement dite.

Pendant et après la mise à niveau, appuyez-vous sur les articles de cette section pour résoudre les problèmes éventuels et reprendre le processus de mise à niveau.

Dans cette section :

  • Meilleures pratiques pour tester la mise à niveau (SharePoint Foundation 2010)

    Suivez ces meilleures pratiques pour tirer le meilleur parti du test de la mise à niveau.

  • Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010)

    Découvrez comment planifier une mise à niveau réussie en la testant avec vos données réelles dans un environnement physique ou virtuel.

  • Estimer la durée du processus de mise à niveau et l'espace dont vous avez besoin (SharePoint Foundation 2010)

    Utilisez les informations du test pour évaluer le temps que prendra votre mise à niveau.

  • Nettoyage de votre environnement avant la mise à niveau (SharePoint Foundation 2010)

    La mise à niveau s'exécute de manière plus souple lorsque vous préparez votre environnement en supprimant les sites ou les données en trop. Cet article répertorie les éléments courants dont vous devez envisager le nettoyage avant de démarrer le processus de mise à niveau.

  • Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010)

    Suivez ces recommandations pour résoudre les problèmes susceptibles de se produire pendant la mise à niveau. Vous pouvez également rechercher les problèmes courants et déterminer comment les résoudre.

  • Récupération après un échec de mise à niveau (SharePoint Foundation 2010)

    Si vous avez créé une sauvegarde de votre environnement et de vos bases de données avant de commencer une mise à niveau sur place, ou si vous avez défini votre environnement en lecture seule avant de commencer une mise à niveau par attachement de base de données, vous pouvez récupérer votre environnement en cas d'échec du processus de mise à niveau.

  • Reprendre la mise à niveau (SharePoint Foundation 2010)

    Si vous rencontrez des erreurs pendant la mise à niveau, vous pouvez les résoudre à l'aide de l'article de résolution des problèmes, puis utiliser cet article pour redémarrer ou reprendre la mise à niveau.

En outre, les ressources suivantes peuvent être utiles lorsque vous testez votre processus de mise à niveau :

  • Feuille de calcul relative à la mise à niveau des produits SharePoint 2010

    Utilisez cette feuille de calcul pour enregistrer les informations sur votre environnement pendant que vous testez votre mise à niveau. Téléchargez la feuille de calcul à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C (éventuellement en anglais).

  • Modèle de test de votre processus de mise à niveau pour les produits Microsoft SharePoint 2010

    Ce poster présente de façon visuelle les informations relatives au test de votre processus de mise à niveau. Téléchargez le poster à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=166303&clcid=0x40C (éventuellement en anglais).

Historique des modifications


Meilleures pratiques pour tester la mise à niveau (SharePoint Foundation 2010)

Pour comprendre votre environnement avant d'effectuer une mise à niveau et pour planifier avec précision la durée nécessaire à celle-ci, vous devez effectuer une ou plusieurs mises à niveau d'évaluation. L'objectif du test d'une mise à niveau est de rechercher les problèmes à l'avance et de les résoudre afin que vous puissiez avoir confiance en votre processus et en son issue lorsque vous effectuez la mise à niveau réelle. Pour effectuer un test précis et utile du processus de mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, suivez les meilleures pratiques suivantes :

  1. Faites en sorte que l'environnement de test ressemble le plus possible à l'environnement réel.

    Dans la mesure du possible, utilisez le même type de matériel et configurez-le à l'aide des mêmes paramètres, des mêmes URL, etc. Pour obtenir une configuration optimale, réduisez au minimum les différences entre l'environnement de test et l'environnement réel. Plus vous introduisez de différences, plus vous êtes susceptible de consacrer du temps à la détection de problèmes disparates afin qu'ils ne se produisent pas pendant la mise à niveau réelle.

  2. Déterminez le contenu de votre environnement. Procédez au préalable à une enquête complète.

    Prenez le temps de documenter le matériel et les logiciels présents dans votre environnement, les personnalisations côté serveur installées et utilisées, leur emplacement et les paramètres requis. Cela vous permettra de réaliser une planification plus complète et d'effectuer une récupération en cas d'échec de la mise à niveau. Une feuille de calcul est à votre disposition, dans laquelle vous pouvez enregistrer les informations relatives à votre environnement lorsque vous préparez la mise à niveau. Téléchargez la feuille de calcul à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C (éventuellement en anglais).

  3. Utilisez des données réelles.

    Utilisez des copies de vos bases de données réelles pour exécuter les tests. Lorsque vous effectuez un test à l'aide de données réelles, vous pouvez identifier les zones problématiques et déterminer les performances de la mise à niveau. En outre, vous pouvez évaluer la durée de différentes actions et séquences de mise à niveau sur différents types de données. Si vous ne pouvez pas tester toutes les données, testez un sous-ensemble de données représentatif afin de vous assurer d'avoir détecté les problèmes susceptibles d'affecter les différents types et tailles de sites, de listes, de bibliothèques et de personnalisations présents dans votre environnement.

  4. Exécutez plusieurs tests.

    Un simple test peut vous indiquer si vous allez rencontrer des problèmes sérieux, mais plusieurs tests garantissent que vous avez détecté tous les problèmes susceptibles de se présenter et peuvent également vous fournir une chronologie plus précise du processus. En exécutant plusieurs tests, vous pouvez déterminer les approches de mise à niveau les plus appropriées pour votre environnement, les techniques de limitation de temps morts à utiliser et l'incidence possible sur le processus ou les performances de la résolution des problèmes détectés dans vos premiers tests. Le résultat du test final indique si vous avez résolu toutes les erreurs et si vous êtes prêt à mettre à niveau votre environnement de production.

  5. N'ignorez pas les avertissements.

    Même s'il ne constitue pas une erreur, un avertissement peut aboutir à des problèmes ultérieurement dans le processus de mise à niveau. En plus de passer les erreurs en revue, analysez tout avertissement pour mesurer son incidence éventuelle.

  6. Testez l'environnement mis à niveau, pas seulement le processus de mise à niveau.

    Vérifiez les applications de services et les services. Exécutez une analyse de recherche et passez en revue les fichiers journaux. Vérifiez que les sites Web Mon site fonctionnent.

  7. Vérifiez les sites dans les deux modes de mise à niveau visuelle.

    Ne partez pas du principe que le site fonctionnera correctement dans un mode dès lors qu'il peut être correctement prévisualisé dans l'autre mode. Vérifiez l'expérience utilisateur dans sa version précédente et dans sa nouvelle version.

  8. Envisagez un environnement de prévisualisation.

    Vous pouvez créer un environnement de prévisualisation dans lequel les utilisateurs peuvent vérifier leurs sites après une mise à niveau de test, vous aidant ainsi à vérifier la mise à niveau et à rechercher les problèmes. Vous pouvez utiliser un environnement en lecture seule ou vous pouvez autoriser les utilisateurs à apporter des modifications, auquel cas vous devez indiquer à ceux-ci qu'aucune modification apportée ne sera enregistrée. Envisagez de limiter cet environnement de prévisualisation à un ensemble réduit de sites représentatifs et de limiter l'accès à des parties intéressées uniquement, afin de réduire la durée pendant laquelle l'environnement de prévisualisation devra être hébergé et la quantité de commentaires reçue.

Pour plus d'informations sur le test de la mise à niveau, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010) et le poster relatif au test du processus de mise à niveau disponible à l'adresse http://go.microsoft.com/fwlink/?linkid=166303&clcid=0x40C (éventuellement en anglais).

Historique des modifications


Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010)

Avant de commencer la mise à niveau entre Windows SharePoint Services 3.0 et Microsoft SharePoint Foundation 2010, il est conseillé de la tester pour vous assurer que vous savez exactement ce qu'il faut à une mise à niveau réussie. Une mise à niveau d'essai vous permet de déterminer :

  • les personnalisations dont vous disposez dans votre environnement, afin de pouvoir planifier leur prise en compte au cours de la mise à niveau ;

  • l'opportunité de mettre à niveau votre matériel afin de faciliter et d'accélérer la mise à niveau ;

  • le moment le plus opportun pour votre mise à niveau, ou la durée que prendra la mise à niveau compte tenu de votre environnement ;

  • les éléments que vous devez planifier, par exemple les ressources requises.

Par ailleurs, vous pouvez utiliser cette mise à niveau d'essai pour vous familiariser avec les outils de mise à niveau et le processus lui-même, de sorte que vous sachiez à quoi vous attendre lorsque vous procéderez à la véritable mise à niveau. Ce test vous permet de déterminer :

  • quels critères particuliers s'appliquent à votre environnement et quelle approche sera la plus efficace pour votre mise à niveau ;

  • à quoi ressemblera l'interface utilisateur de la mise à niveau et comment savoir quand passer d'une phase à la suivante ;

  • où se trouvent les fichiers journaux, comment les lire et quelles informations ils contiennent ;

  • quelles techniques vous pouvez utiliser pour réduire les temps morts.

Cet article fournit les étapes de base du test de la mise à niveau, ainsi que des recommandations pour interpréter les résultats et ajuster vos plans de mise à niveau en fonction de ces résultats.

Dans cet article :

  • Configurer un environnement de test

  • Identifier et installer les personnalisations

  • Copier les données réelles dans l'environnement de test et tester la mise à niveau

  • Passer en revue vos résultats

  • Ajuster les planifications et tester à nouveau

En outre, les ressources suivantes peuvent être utiles lorsque vous testez votre processus de mise à niveau :

  • Feuille de calcul relative à la mise à niveau des produits SharePoint 2010

    Utilisez cette feuille de calcul pour enregistrer les informations sur votre environnement pendant que vous testez votre mise à niveau. Téléchargez la feuille de calcul à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C (éventuellement en anglais).

  • Modèle de test de votre processus de mise à niveau pour les produits Microsoft SharePoint 2010

    Ce poster présente de façon visuelle les informations relatives au test de votre processus de mise à niveau. Téléchargez le poster à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=166303&clcid=0x40C (éventuellement en anglais).

Configurer un environnement de test

Vous pouvez tester le processus de mise à niveau sur un matériel virtuel ou physique. Chaque environnement étant particulier, il est difficile de se prononcer sur la durée de la mise à niveau ou la difficulté que posera une personnalisation particulière. La meilleure manière d'évaluer votre processus de mise à niveau consiste à effectuer une série d'essais.

Lorsque vous créez votre environnement de test :

  • Créez une batterie de test aussi proche que possible de votre batterie réelle, en termes de matériel, de logiciel et d'espace disponible.

  • Utilisez dans votre batterie de test les URL de votre batterie réelle. (Sans cela, vous allez perdre du temps à diagnostiquer des problèmes d'URL qui ne se poseront pas au cours de la véritable mise à niveau.)

  • Veillez à transférer tous vos paramètres et toutes vos personnalisations à l'environnement de test. La section Identifier et installer les personnalisations fournit des informations sur la collecte de ces informations.

Utilisation d'un environnement de test virtuel

Lorsque vous testez sur un environnement virtualisé, vous n'avez pas besoin d'une grande quantité de matériel. Vous pouvez répliquer votre environnement en utilisant deux serveurs qui exécutent Hyper-V. Un serveur possède les images destinées aux serveurs Web frontaux et aux serveurs d'applications ; les autres serveurs contiennent les images destinées aux serveurs de base de données.

Environnement de test virtuel pour une mise à niveau d'évaluation

Utilisation d'un environnement de test physique

Lorsque vous testez sur un environnement physique, vous devez répliquer aussi fidèlement que possible l'ensemble de votre environnement de batterie de serveurs. Si vous simplifiez trop le nombre de serveurs Web frontaux, de serveurs d'applications ou de serveurs de base de données, vous ne serez pas en mesure d'anticiper avec précision le temps nécessaire au processus de mise à niveau et ne vous donnerez pas la possibilité de découvrir des complications liées aux interactions entre des serveurs du même rôle (telles que les interactions SQL Server). Si vous avez plusieurs serveurs appartenant au même rôle dans votre batterie d'origine, utilisez au moins deux serveurs pour ce rôle afin de tester les problèmes susceptibles de se produire.

Batterie de serveurs de test physique pour une mise à niveau d'évaluation

Environnements de test supplémentaires pour la mise à niveau par liaison de base de données

Si vous avez adopté l'approche de mise à niveau par liaison de base de données, vous devrez peut-être créer un environnement de test supplémentaire : une batterie de serveurs exécutant Windows SharePoint Services 3.0 que vous pouvez utiliser pour exécuter l'outil de vérification préalable à la mise à niveau avant de procéder à la mise à niveau des données.

Vous pouvez faire l'économie de cette étape en exécutant l'outil de vérification préalable à la mise à niveau sur votre batterie de production existante.

Identifier et installer les personnalisations

Pour un processus de test précis, vous devez identifier toutes les personnalisations au sein de votre environnement actuel et les copier dans l'environnement de test. Pour plus d'informations sur les types de personnalisations à identifier, voir Déterminer comment gérer les personnalisations (SharePoint Foundation 2010).

  • Utilisez l'outil de vérification préalable à la mise à niveau pour identifier les définitions de site, les modèles de site et les fonctionnalités de votre environnement.

    L'outil de vérification préalable à la mise à niveau parcourt chaque collection de sites et génère un rapport sur l'état de chaque site. Il enregistre également les informations de définition de liste pour chaque liste. Vous pouvez consulter les rapports pour rechercher les problèmes et les résoudre avant de commencer le processus de mise à niveau. À la différence de l'outil d'analyse préalable à la mise à niveau d'Windows SharePoint Services 3.0, l'outil de vérification préalable à la mise à niveau est un outil en lecture seule qui ne modifie pas vos sites. Pour plus d'informations sur cet outil et la procédure à suivre pour l'exécuter, voir Analyse et rapport préalables à la mise à niveau vers des versions ultérieures (Windows SharePoint Services) et Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

  • Utilisez l'opération Stsadm -o enumallwebs sur toutes les bases de données de contenu dans votre environnement Windows SharePoint Services 3.0 pour identifier des personnalisations spécifiques dans des sous-sites. Cette opération répertorie un ID pour chaque collection de sites et sous-site dans votre environnement et les modèles sur lesquels repose le site. Cette opération a été introduite pour la première fois dans Windows SharePoint Services 3.0 avec Service Pack 2 (SP2). Pour plus d'informations, voir Enumallwebs : opération Stsadm (Windows SharePoint Services).

  • Utilisez un outil tel que WinDiff (fourni avec la plupart des systèmes d'exploitation Microsoft) pour comparer les serveurs de votre environnement de production avec les serveurs de votre batterie de test. Vous pouvez utiliser cet outil pour vérifier quels fichiers existent sur vos serveurs et quelles différences existent entre ces fichiers.

  • Vérifiez si les fichiers web.config comportent des modifications, puis déterminez si l'élément SafeControls contient des contrôles personnalisés.

  • Utilisez l'outil de diagnostics SharePoint (SPDiag) pour rechercher les solutions déployées. Pour plus d'informations, voir Outil de diagnostics SharePoint (SPDiag).

  • Créez la liste de toutes les personnalisations que vous trouvez. Identifiez si possible la source des personnalisations. Déterminez par exemple si des compléments logiciels ou des modèles tiers ont été personnalisés en interne. Après en avoir identifié la source, vous pouvez ensuite rechercher des versions mises à jour ou à niveau des personnalisations. Une feuille de calcul est à votre disposition, dans laquelle vous pouvez enregistrer les informations relatives à votre environnement, suivant les données issues de l'outil de vérification préalable à la mise à niveau et de votre recherche sur les personnalisations. Téléchargez la feuille de calcul à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C (éventuellement en anglais), puis personnalisez-la en fonction de vos besoins.

Conseil :
Qui devez-vous contacter à propos des personnalisations que vous n'avez pas créées ?

  • Contactez Microsoft pour tout problème lié à un modèle que vous avez téléchargé depuis le site Web Microsoft (tel que les modèles d'application Windows SharePoint Services 3.0).

  • Contactez votre fournisseur de solution tiers pour tout problème lié à un modèle ou à un composant qu'il vous a fourni pour la version antérieure. Il peut disposer d'une version à niveau de cet élément.

Lorsque vous avez identifié toutes les personnalisations, copiez-les sur les serveurs appropriés au sein de votre batterie de test. Vous pouvez utiliser l'applet de commande Windows PowerShelltest-spcontentdatabase avant d'attacher une base de données à SharePoint Foundation 2010 pour déterminer si des personnalisations manquent dans l'environnement. Exécutez cette commande pour chaque base de données lorsque vous avez restauré les bases de données sur votre serveur de bases de données, mais avant de procéder à la mise à niveau. Notez que cette applet de commande s'exécute automatiquement, et qu'elle ne génère pas de message tant qu'aucune erreur n'est détectée.

Copier les données réelles dans l'environnement de test et tester la mise à niveau

Vous n'atteindrez pas vos objectifs de test si vous n'utilisez pas vos données réelles. Vous pouvez utiliser les méthodes suivantes pour créer une copie de vos données :

  • Pour une mise à niveau sur place, créez une sauvegarde de batterie de serveurs, puis restaurez-la dans l'environnement de test. Pour plus d'informations, voir Administration de la sauvegarde et de la récupération pour la technologie Windows SharePoint Services 3.0.

  • Pour une mise à niveau par liaison de base de données, vous devez utiliser les outils de sauvegarde et de restauration de Microsoft SQL Server afin de créer une copie de vos bases de données de contenu et de toute autre base de données que vous souhaitez mettre à niveau. Pour plus d'informations, voir Sauvegarder et restaurer des bases de données de contenu (Windows SharePoint Services 3.0).

Il n'existe pas de meilleur moyen d'anticiper ce qui se produira au cours d'une mise à niveau que d'effectuer le test sur une copie de toutes vos données. Toutefois, cette option peut s'avérer irréaliste pour un test initial. Vous pouvez échelonner votre test, en testant une base de données à la fois par exemple (si les bases de données sont volumineuses) de sorte de passer en revue toutes les particularités de vos données, ou en assemblant un sous-ensemble de données provenant de sites représentatifs de votre environnement. Si vous souhaitez commencer par tester un sous-ensemble de vos données, veillez à ce que le sous-ensemble présente les caractéristiques suivantes :

  • Le sous-ensemble des données contient des sites qui sont typiques de ceux que vous entretenez dans votre environnement.

  • La taille et la complexité des sous-ensembles de données sont très proches de la taille et de la complexité réelles de votre environnement.

Important :
Le test d'un sous-ensemble de vos données ne constitue pas un banc d'essai valide quant à la durée que prendra le traitement du volume entier des données de votre environnement.

Après avoir copié les données, lancez un premier processus de mise à niveau pour voir ce qui se produit. Il ne s'agit que d'une étape préliminaire.

Essayer la mise à niveau sur place

Si vous souhaitez essayer l'approche de mise à niveau sur place, suivez les étapes suivantes pour essayer le processus de mise à niveau :

  1. Créez une sauvegarde de votre batterie de serveurs.

  2. Restaurez la sauvegarde sur votre batterie de test.

    Pour plus d'informations, voir Administration de la sauvegarde et de la récupération pour la technologie Windows SharePoint Services 3.0.

  3. Exécutez l'outil d'analyse préalable à la mise à niveau. Prenez note de tous les problèmes qu'il détecte. Vous devrez traiter ces problèmes dans votre environnement d'origine avant de procéder à la mise à niveau sur votre batterie de serveurs de production. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

  4. Suivez les étapes décrites dans Effectuer une mise à niveau sur place (SharePoint Foundation 2010) pour tester la procédure de mise à niveau.

  5. Passez en revue les résultats.

Essayer une mise à niveau par liaison de base de données

  1. Créez une sauvegarde SQL Server de vos bases de données de contenu.

  2. Utilisez SQL Server pour restaurer les sauvegardes sur votre batterie de test à un seul serveur et attachez les bases de données de contenu à cet environnement.

    Pour plus d'informations, voir Sauvegarder et restaurer des bases de données de contenu (Windows SharePoint Services 3.0).

  3. Exécutez l'outil d'analyse préalable à la mise à niveau. Prenez note de tous les problèmes qu'il détecte. Vous devrez traiter et corriger ces problèmes dans votre environnement d'origine avant de procéder à la mise à niveau sur votre batterie de production. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

  4. Suivez les étapes décrites dans Préparer le nouvel environnement SharePoint Foundation pour configurer l'environnement de test pour une mise à niveau par liaison de base de données.

  5. Suivez les étapes décrites dans Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010 pour essayer la mise à niveau par liaison de base de données.

Passer en revue vos résultats

Lorsque la mise à niveau de test a été réalisée, vous pouvez passer en revue les résultats et revisiter vos plans. Consultez les fichiers journaux, observez les sites mis à niveau et vérifiez vos personnalisations. Comment la mise à niveau a-t-elle fonctionné dans votre environnement ? Qu'avez-vous trouvé ? Que devez-vous repenser à propos de votre plan de mise à niveau ?

Passer en revue les fichiers journaux

Passez en revue les fichiers journaux suivants :

  • Le fichier journal de l'outil de vérification préalable à la mise à niveau.

    Les fichiers journaux de l'outil de vérification préalable à la mise à niveau (stsadm -o preupgradecheck) sont situés dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\12\LOGS. Leur nom respecte la syntaxe suivante : PreUpgradeCheck_AAAAMMJJ-HHMMSS-SSS-nombre-aléatoire.log, où AAAAMMJJ est la date et HHMMSS-SSS est l'heure (heures au format horaire de 24 heures, minutes, secondes et millisecondes) et le nombre aléatoire permet de distinguer d'éventuelles tentatives simultanées d'exécution de l'outil de vérification préalable à la mise à niveau.

  • Le fichier journal Assistant Configuration des produits SharePoint (Psconfig.exe) (généré lorsque vous exécutez cet assistant dans le cadre de votre mise à niveau sur place de test).

    Les fichiers journaux de PSCDiagnostics sont situés dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\14\LOGS.

  • Le fichier journal de mise à niveau et le fichier journal des erreurs de mise à niveau (générés lors de l'exécution de la mise à niveau).

    Le fichier journal de mise à niveau (.log) et le fichier journal des erreurs de mise à niveau (.err) sont disponibles à l'emplacement %COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\14\LOGS. Ils sont nommés selon le format suivant : Upgrade-AAAAMMJJ-HHMMSS-SSS.log, où AAAAMMJJ est la date et HHMMSS-SSS est l'heure (heures au format 24 heures, minutes, secondes et millisecondes).

Pour passer en revue les fichiers journaux afin d'identifier et de corriger les problèmes, démarrez en haut des fichiers. Les erreurs ou les avertissements peuvent être répétés s'ils se produisent dans plusieurs collections de sites au sein de l'environnement, ou s'ils bloquent le processus de mise à niveau. Par exemple, si vous ne pouvez pas vous connecter à la base de données de configuration, le processus de mise à niveau essaiera (et échouera) plusieurs fois et ces tentatives seront listées dans le fichier journal.

Recherchez ou analysez les entrées suivantes :

  • Finished upgrading SPFarm Name= <Nom de la base de données de configuration>

  • Fin de la mise à niveau sur place. Root object = SPFarm= <Nom de la base de données de configuration> , recursive = True. 0 erreur et 0 avertissement se sont produits.

Si vous trouvez ces entrées, l'installation a réussi.

Si vous ne trouvez pas les entrées de l'étape précédente, vous pouvez identifier les problèmes spécifiques qui ont contribué à l'échec en recherchant, ou en analysant visuellement dans le fichier Upgrade.log, les termes suivants :

  • Recherchez ERROR dans les fichiers journaux pour détecter les éventuels problèmes (tels que les composants défaillants ou les connexions de base de données défectueuses).

  • Recherchez WARNING pour détecter les problèmes tels que des fonctionnalités ou des composants manquants.

Pour détecter les problèmes de mise à niveau, un analyseur de fichier journal peut vous être utile afin d'exécuter des requêtes sur les fichiers journaux.

Redémarrer la mise à niveau, si nécessaire

Durant une mise à niveau avec liaison des bases de données, les sites qui ne peuvent pas être mis à niveau seront ignorés. Durant une mise à niveau sur place, si le serveur redémarre ou si la mise à niveau échoue, vous devez relancer le processus de mise à niveau pour mettre à niveau les sites restants.

Pour déterminer si des sites ont été manqués ou ignorés pendant la mise à niveau, exécutez l'opération Stsadm suivante stsadm -o localupgradestatus sur chaque serveur Web frontal dans votre batterie de serveurs SharePoint Foundation 2010. Pour plus d'informations sur cette opération, voir Localupgradestatus : opération Stsadm (Windows SharePoint Services).

Si la mise à niveau a ignoré une collection de sites, vous pouvez redémarrer le processus de mise à niveau pour la base de données qui contient cette collection à l'aide de l'applet de commande Windows PowerShell suivante : upgrade-spcontentdatabase -id <GUID>. Pour plus d'informations sur cette applet de commande, voir Upgrade-SPContentDatabase.

Pour plus d'informations, voir Reprendre la mise à niveau (SharePoint Foundation 2010).

Examiner les sites mis à niveau

Examinez les sites mis à niveau pour identifier les problèmes à résoudre avant d'exécuter le processus de mise à niveau sur votre environnement de production. Pour plus d'informations sur les points spécifiques à vérifier, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Ajuster les planifications et tester à nouveau

Répétez le processus de test tant que vous n'êtes pas certain d'avoir détecté tous les problèmes auxquels vous risquez d'être confronté et de savoir comment les résoudre. Votre objectif est de définir votre plan alors qu'il est 16 h 00 un dimanche, que vous devez rétablir la connexion le lundi matin, et que cela ne fonctionne pas encore. Y-a-t'il un point de non-retour ? Testez votre plan de restauration et assurez-vous qu'il fonctionne avant de vous lancer dans la mise à niveau réelle.

Historique des modifications


Estimer la durée du processus de mise à niveau et l'espace dont vous avez besoin (SharePoint Foundation 2010)

Une partie importante de la planification de la mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010 consiste à déterminer la durée du processus de mise à niveau et la quantité d'espace de stockage nécessaire. Chaque environnement est unique et présente des possibilités matérielles et des caractéristiques de site spécifiques. L'espace et la durée dont vous avez besoin pour exécuter une mise à niveau varient considérablement en fonction de votre environnement. La meilleure approche pour estimer ces facteurs consiste à effectuer une mise à niveau de test, puis à passer en revue l'espace et la durée qui ont été nécessaires. Pour plus d'informations sur la façon d'exécuter une mise à niveau de test, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010).

Dans cet article :

  • Estimer l'espace dont vous avez besoin pour la mise à niveau

  • Estimer la durée de la mise à niveau

Estimer l'espace dont vous avez besoin pour la mise à niveau

Pendant une mise à niveau sur place et une mise à niveau avec liaison des bases de données, les bases de données sont susceptibles de croître. En outre, de nombreuses transactions ayant lieu pendant le processus de mise à niveau, vous devez vous assurer que les fichiers journaux disposent de suffisamment de place pour prendre en charge les modifications qui se produisent. Vous devez envisager un accroissement des bases de données et des fichiers journaux.

Lorsque vous planifiez votre mise à niveau, vérifiez que votre environnement actuel suit les meilleures pratiques en termes de stockage pour Windows SharePoint Services 3.0 de manière à optimiser le déroulement et les performances de la mise à niveau. Pour plus d'informations, voir Recommandations pour le stockage physique (Office SharePoint Server). Vous devez également passer en revue les meilleures pratiques pour SharePoint Foundation 2010 et apporter tout ajustement nécessaire à votre environnement mis à niveau.

En raison des modifications apportées aux structures des tables dans la nouvelle version, la taille des bases de données augmente provisoirement pendant que les données sont réorganisées. Cet espace peut être récupéré après la mise à niveau, mais vous devez vous assurer que la place disponible permet aux bases de données d'atteindre une taille pouvant représenter jusqu'à 50 % de leurs tailles actuelles pendant une mise à niveau sur place ou une mise à niveau avec liaison des bases de données (gardez à l'esprit qu'après la mise à niveau, vous pouvez de nouveau réduire la base de données pour récupérer la majeure partie de cet espace). Vous devez également vous assurer que l'espace disponible sur vos serveurs de bases de données permet à celles-ci de grandir au fil du temps dans le cadre d'une utilisation normale. Pour déterminer la taille actuelle de vos bases de données, utilisez Enterprise Manager dans Microsoft SQL Server. En plus d'espace pour les bases de données, vous devez disposer de place pour les éléments suivants :

  • Les bases de données temporaires. Vérifiez que vous disposez de suffisamment d'espace pour permettre la croissance rapide des bases de données temporaires. Si l'espace est insuffisant, il se peut que le processus de mise à niveau arrive à expiration et que la mise à niveau échoue.

  • les fichiers journaux de mise à niveau ;

  • les fichiers journaux de transactions des bases de données. Ces fichiers journaux doivent croître rapidement pour prendre en charge toutes les modifications qui se produisent dans les bases de données.

    Remarque :
    Dans les environnements très volumineux, il est possible que le taux de croissance par défaut des fichiers journaux de transactions (10 %) ne soit pas suffisant pour prendre en charge le processus de mise à niveau ; cela peut entraîner un délai d'attente. Là encore, une mise à niveau de test est le meilleur moyen pour déterminer si les fichiers journaux des transactions peuvent prendre en charge le processus de mise à niveau. Si votre environnement est très volumineux ou que le processus a expiré au cours d'une mise à niveau de test, envisagez d'accroître la taille des fichiers journaux de transactions SQL Server afin qu'il y ait suffisamment d'espace pour toutes les transactions à traiter. Pour plus d'informations sur la façon d'accroître la taille des journaux des transactions SQL Server, voir Développement d'une base de données (SQL Server 2005) (http://go.microsoft.com/fwlink/?linkid=182619&clcid=0x40C) ou Développement d'une base de données (SQL Server 2008) (http://go.microsoft.com/fwlink/?linkid=182620&clcid=0x40C).

Estimer la durée de la mise à niveau

À partir des estimations d'espace disque et de tests déjà menés, vous pouvez évaluer la durée approximative du processus de mise à niveau proprement dit. Les durées de mise à niveau varient considérablement suivant les environnements. Les performances d'une mise à niveau dépendent considérablement du matériel utilisé, de la complexité des sites et des caractéristiques de votre implémentation. Par exemple, si vous disposez d'un nombre élevé de bibliothèques de documents volumineuses, leur mise à niveau peut prendre plus de temps que celle d'un site plus simple.

Les facteurs qui influent sur les performances sont décrits dans le tableau suivant.

Facteurs liés au contenu Facteurs liés au matériel

Le nombre de :

  • Collections de sites

  • Sous-sites Web

  • Listes

  • Versions du document (nombre et taille)

  • Documents

  • Liens

Plus la taille de la base de données globale proprement dite.
  • Entrée/sortie disque SQL Server par seconde

  • Base de données SQL Server vers la disposition du disque

  • Optimisations des bases de données temporaires SQL Server

  • Caractéristiques de la mémoire et du processeur SQL Server

  • Caractéristiques de la mémoire et du processeur du serveur Web

  • Latence et bande passante du réseau

La façon dont vos données sont structurées peut avoir une incidence sur la durée de leur mise à niveau. Par exemple, la mise à niveau de 10 000 listes de 10 éléments chacune sera plus longue que celle de 10 listes de 10 000 éléments. Les actions requises pour mettre à niveau l'infrastructure des listes doivent être réalisées pour chaque liste, indépendamment du nombre d'éléments ; par conséquent, un nombre élevé de listes signifie un nombre élevé d'actions. Il en va de même pour la plupart des éléments de la colonne des facteurs liés au contenu dans le tableau ci-dessus.

La structure de votre matériel peut également avoir une forte incidence sur les performances. Généralement, les performances des serveurs de bases de données sont plus importantes que celles des serveurs Web, mais un matériel insuffisamment puissant ou des problèmes de connectivité à l'un ou l'autre des niveaux peuvent affecter sensiblement les performances de la mise à niveau.

L'approche de mise à niveau que vous avez choisie aura également un impact important sur la durée du processus. La réalisation d'une mise à niveau avec liaison des bases de données est la méthode la plus rapide (cependant, les étapes antérieures et postérieures à la mise à niveau dans cette approche durent plus longtemps que dans une mise à niveau sur place). Une mise à niveau sur place dure un peu moins longtemps, car bien que vous mettiez à niveau l'environnement en plus des sites, vous n'avez pas besoin d'autant d'étapes antérieures et postérieures à la mise à niveau dans cette approche.

La meilleure façon d'estimer la durée globale consiste à effectuer une mise à niveau de test d'une petite partie de toutes les données, puis à consulter les fichiers journaux de mise à niveau. Les fichiers journaux indiquent la durée de la mise à niveau : recherchez la durée totale écoulée en bas du fichier journal de mise à niveau. À partir de cette durée, extrapolez une durée pour la totalité du contenu. Vous pouvez également utiliser les fichiers journaux pour vérifier votre progression au fil du processus de mise à niveau. Le fichier upgrade.log est situé à l'emplacement %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\14\LOGS.

L'estimation que vous obtenez à partir de votre mise à niveau de test concerne le processus de mise à niveau des données proprement dit ; elle n'inclut pas l'ensemble des étapes que vous devez suivre avant et après cette étape, qui peuvent prendre plus de temps que la mise à niveau des données elles-mêmes. Lors de l'évaluation de la durée de la mise à niveau, outre la durée nécessaire au traitement des données, vous devez estimer la durée des activités qui ont lieu au cours des étapes antérieures et postérieures à la mise à niveau.

Pour les étapes préalables à la mise à niveau, prenez en considération les facteurs suivants :

  • Création des éléments personnalisés La mise à niveau de composants WebPart ou le rétablissement de modèles personnalisés pour tirer parti de nouvelles fonctionnalités prennent un certain temps. Le processus de création des éléments personnalisés doit commencer tôt, pendant la phase d'évaluation de votre projet.

  • Sauvegarde des bases de données Dans le cas d'une mise à niveau sur place, vous devez effectuer une sauvegarde complète, pas une sauvegarde différentielle, de la totalité de l'environnement pour être certain de pouvoir effectuer une récupération dans l'hypothèse peu probable où la mise à niveau échouerait et où vous devriez régénérer votre batterie de serveurs. Pour les environnements volumineux, cette étape peut prendre beaucoup de temps. En particulier, si vous effectuez la sauvegarde sur un emplacement réseau, des problèmes de temps de réponse du réseau peuvent ralentir ce processus.

Pour les étapes postérieures à la mise à niveau, prenez en considération les facteurs suivants :

  • Vérification des sites et réalisation de modifications Accordez suffisamment de temps aux utilisateurs pour qu'ils puissent valider leurs sites après la mise à niveau. Cette opération peut prendre plusieurs jours. Pour plus d'informations, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

D'autres facteurs dans votre environnement peuvent également favoriser un allongement de la durée des mises à niveau, tels que les suivants :

  • Bibliothèques de documents très volumineuses La mise à niveau d'une bibliothèque de documents contenant plus de 250 000 documents uniquement à sa racine (et non dans des dossiers) prend beaucoup de temps et peut ne pas être couronnée de succès. Vous pouvez gérer la taille des bibliothèques en vous appuyant sur les recommandations Windows SharePoint Services 3.0 relatives à l'utilisation de dossiers pour scinder les bibliothèques de documents volumineuses. Par exemple, si vous réorganisez la même bibliothèque de documents afin que les 250 000 documents soient répartis en 125 dossiers, sa mise à niveau devrait être plus facile.

  • Bases de données très volumineuses La mise à niveau des bases de données supérieures à 100 Go peut prendre beaucoup de temps.

    Remarque :
    Si vous possédez des bases de données de contenu dont la taille est supérieure à 100 Go, vous pouvez les scinder en bases de données plus petites avant d'exécuter la mise à niveau. Non seulement la mise à niveau des bases de données volumineuses peut prendre plus de temps, mais celles-ci peuvent compliquer une opération de récupération si la mise à niveau n'est pas couronnée de succès.

    Vous pouvez utiliser l'opération mergecontentdbs ou les opérations backup et restore dans Stsadm.exe pour déplacer des sites entre des bases de données. Pour plus d'informations, voir Mergecontentdbs : opération Stsadm (Windows SharePoint Services) et Sauvegarde et restauration : opérations Stsadm (Windows SharePoint Services).

    En outre, si vous disposez d'une base de données très volumineuse (supérieure à 100 Go) que vous ne pouvez pas scinder parce que la majeure partie du contenu se trouve dans une seule collection de sites, vous pouvez reconsidérer votre approche de mise à niveau. Une approche de mise à niveau avec liaison des bases de données est plus difficile dans le cas des bases de données très volumineuses, du fait que la sauvegarde et la restauration de ces bases de données sont problématiques.

    Attention :
    Veillez à respecter les recommandations sur la planification de la capacité spécifiques aux versions précédentes et nouvelles avant de procéder à la mise à niveau. Si vous êtes allé au-delà des recommandations afin d'obtenir de meilleures performances, le processus de mise à niveau peut prendre plus de temps ou il peut échouer (par exemple, le processus peut expirer à plusieurs reprises sur la même bibliothèque de documents volumineuse). Si votre déploiement ne satisfait pas aux recommandations sur la capacité, déterminez si, avant de procéder à la mise à niveau, vous devez effectuer certaines opérations afin de pallier cette situation. Là encore, une mise à niveau de test peut vous aider à prendre une décision.

  • Contraintes de communications

    Vous devez informer vos utilisateurs et votre équipe de la planification de la mise à niveau et leur laisser le temps d'effectuer leurs tâches. Pour plus d'informations, voir Créer un plan de communication (SharePoint Foundation 2010).

  • Gestion des alertes et des alarmes de System Center

    Vous devez surveiller les performances système pendant la mise à niveau, mais vous n'avez pas besoin de surveiller de fonctionnalités spécifiques. Suspendez toutes les alarmes et alertes superflues dans Microsoft Systems Center Operations Manager ou Microsoft Operations Manager, puis réactivez-les après la mise à niveau.

  • Activation/désactivation de la mise en miroir et de la copie des journaux de transaction SQL

    Vous devez désactiver la mise en miroir et la copie des journaux de transaction avant d'effectuer la mise à niveau, puis les réactiver une fois que vous êtes sûr que votre environnement fonctionne correctement après la mise à niveau. Il est recommandé de ne pas exécuter la mise en miroir ou la copie des journaux de transaction pendant la mise à niveau, car cela crée une charge supplémentaire sur les serveurs exécutant SQL Server et se traduit par le gaspillage de ressources dans la mise en miroir ou la copie de données temporaires.

Testez votre processus de mise à niveau pour évaluer le temps qu'il peut prendre, puis créez une planification pour vos opérations de mise à niveau et testez-la afin de déterminer la chronologie. Vous devez inclure dans la chronologie des opérations la durée nécessaire à la réalisation des étapes préalables et postérieures à la mise à niveau : si, avant le démarrage de la mise à niveau, la sauvegarde de votre environnement prend 5 heures, vous devez inclure cette durée dans la plage d'indisponibilité. En outre, incluez la durée de la mise en mémoire tampon liée à une restauration ou récupération éventuelle : vous devez déterminer les chronologies d'arrêt planifié (cas réaliste) et d'arrêt d'urgence (cas le plus défavorable).

Historique des modifications


Nettoyage de votre environnement avant la mise à niveau (SharePoint Foundation 2010)

Avant de commencer la mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, vous devez vous assurer que votre environnement est sain et veiller à supprimer tout contenu qui n'a pas lieu d'être mis à niveau. Vous pouvez également prendre le temps nécessaire pour supprimer ou réorganiser du contenu de manière à disposer de la structure souhaitée au terme de la mise à niveau.

Dans cet article :

  • Éléments à nettoyer

  • Réalisation de modifications structurelles

Éléments à nettoyer

De nombreux de ces éléments peuvent être supprimés ou réparés à l'aide de commandes Stsadm.exe.

Important :
Pour exécuter l'outil en ligne de commande Stsadm, vous devez être membre du groupe Administrateurs sur l'ordinateur local.

Supprimez les collections de sites et les sous-sites Web inutilisés ou sous-utilisés

Vous ne souhaitez pas mettre à niveau le contenu que vous n'avez pas besoin de conserver. S'il est demeuré inutilisé pendant longtemps et qu'il ne s'avère pas nécessaire, sauvegardez-le, puis supprimez-le pour libérer des ressources de stockage et administratives, améliorer les performances de mise à niveau et réduire le risque lié à la mise à niveau. Veillez à vous entretenir avec les propriétaires de site ou les contacts de l'organisation au sujet du statut du site afin de vous assurer que celui-ci n'est pas requis avant de le supprimer (par exemple, il n'est pas souhaitable de supprimer les sites requis pour la conformité, à l'image des procédures d'urgence, même s'ils ne sont pas fréquemment mis à jour).

Pour plus d'informations sur la suppression des collections de sites et des sous-sites Web, voir :

  • Deletesite : opération Stsadm (Windows SharePoint Services)

  • Deleteweb : opération Stsadm (Windows SharePoint Services)

Traiter les grandes listes

Par défaut, la limitation de requête de grande liste est appliquée après une mise à niveau vers SharePoint Foundation 2010. Si une liste est très grande et que les utilisateurs recourent à une vue ou exécutent une requête qui dépasse la limite ou le seuil de limitation, la vue ou requête ne sera pas autorisée. Vérifiez toutes les grandes listes dans votre environnement et invitez le propriétaire de site ou le propriétaire de liste à résoudre le problème avant de procéder à la mise à niveau. Par exemple, ils peuvent créer des colonnes indexées à l'aide de vues filtrées, organiser les éléments en dossiers, définir une limite d'éléments sur la page pour une grande vue ou utiliser une liste externe. Pour plus d'informations sur la résolution des problèmes liés aux grandes listes, voir Gérer les listes et les bibliothèques comportant de nombreux éléments (http://go.microsoft.com/fwlink/?linkid=182370&clcid=0x40C) sur Office Online.

Traiter les grandes listes de contrôle d'accès

L'utilisation d'autorisations au niveau de l'élément peut fréquemment aboutir à de grandes entrées de liste de contrôle d'accès, qui peuvent à leur tour engendrer des problèmes de performances sur vos serveurs. Pour plus d'informations sur ce problème et pour des conseils sur la prise en charge de nombreux utilisateurs, voir l'article 953132 de la Base de connaissances, « Comment ajouter beaucoup d'utilisateurs à un site, une liste ou une bibliothèque de documents dans Windows SharePoint Services 3.0 et SharePoint Server 2007 » (http://go.microsoft.com/fwlink/?linkid=182327&clcid=0x40C).

Supprimer les versions de document en trop

L'existence d'un nombre élevé de versions de document peut sensiblement ralentir une mise à niveau. Si vous n'avez pas besoin de conserver plusieurs versions, vous pouvez demander aux utilisateurs de les supprimer manuellement ou utiliser le modèle objet pour les rechercher et les supprimer. Pour plus d'informations sur la suppression par programme de versions en trop, voir Service Web Versions (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=182330&clcid=0x40C) sur MSDN.

Supprimer les modèles, fonctionnalités et composants WebPart inutilisés

Dans un premier temps, vérifiez qu'aucun site n'utilise le modèle, la fonctionnalité ou le composant WebPart. Vous pouvez utiliser l'outil de vérification de pré-mise à niveau (Stsadm -o preupgradecheck) et l'opération Stsadm -o EnumAllWebs pour identifier ces personnalisations dans votre environnement. Ces deux opérations ont été mises à jour dans la mise à jour cumulative d'octobre 2009 et identifient désormais les composants WebPart, les fonctionnalités, les gestionnaires d'événements et les fichiers de configuration en cours d'utilisation dans votre environnement. L'outil de vérification de pré-mise à niveau indique les fichiers côté serveur qui existent dans votre environnement et combien de fois ils sont utilisés. La commande EnumAllWebs indique les fichiers utilisés par les différents sites.

Pour plus d'informations sur l'identification des personnalisations dans votre environnement, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010). Si des personnalisations ne sont pas en cours d'utilisation, supprimez-les. Pour plus d'informations sur la gestion de ces types de personnalisations, voir Fonctionnalités et modèles (http://go.microsoft.com/fwlink/?linkid=182338&clcid=0x40C) et Solutions et packages de composants WebPart (http://go.microsoft.com/fwlink/?linkid=182332&clcid=0x40C) sur MSDN.

Résoudre les problèmes liés aux données

Nettoyez vos bases de données pour supprimer tous les sites orphelins ou autres données endommagées, telles qu'une liste altérée. Envisagez une défragmentation si vous avez supprimé des sites ou des sous-sites de la base de données. Pour plus d'informations, voir :

  • Databaserepair : opération Stsadm (Windows SharePoint Services)

  • Forcedeletelist : opération Stsadm (Windows SharePoint Services)

Réalisation de modifications structurelles

Si vous souhaitez apporter des modifications structurelles à votre environnement, telles que le déplacement de collections de sites ou le mode d'allocation de vos bases de données, vous pouvez utiliser les méthodes suivantes :

  • Stsadm -o mergecontentdbs Cette opération vous permet de déplacer des collections de sites entre des bases de données. La mise à niveau est d'autant plus efficace que les bases de données contiennent des données similaires. Par conséquent, il est préférable que les collections de sites qui partagent une base de données de contenu soient de types similaires. Vous pouvez également utiliser cette opération pour fractionner les bases de données volumineuses si elles contiennent plusieurs collections de sites. Cela permet également d'accroître l'efficacité de la mise à niveau.

    Pour plus d'informations, voir Mergecontentdbs: opération Stsadm (Windows SharePoint Services).

  • Exporter et importer des sites Utilisez cette méthode pour déplacer des sous-sites Web ou des collections de sites dans une batterie de serveurs ou entre des batteries de serveurs. Pour plus d'informations, voir Importer et exporter : opérations Stsadm (Windows SharePoint Services).

Historique des modifications

Date | Description | Raison
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010)
Voir aussi

Même après avoir testé le processus de mise à niveau pour identifier les problèmes potentiels, vous risquez de rencontrer des problèmes inattendus pendant une mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010. Si vous rencontrez des problèmes après la mise à niveau, plus vite vous les détecterez et les résoudrez, meilleure sera l'expérience de l'utilisateur final.

Cet article décrit les principes généraux de l'identification et de la résolution des problèmes de mise à niveau et recense les problèmes courants. Après avoir identifié et résolu les problèmes, vous pouvez reprendre la mise à niveau. Pour plus d'informations sur la reprise de la mise à niveau, voir Reprendre la mise à niveau (SharePoint Foundation 2010).

Dans cet article :

  • Principes généraux de l'identification des problèmes

  • Problèmes courants

    • Personnalisations ou fichiers côté serveur manquants ou désapprouvés

    • Paramètres manquants ou incorrectement configurés pour la batterie de serveurs, l'application Web ou les services

    • Niveaux de mise à jour incohérents ou incorrects

    • Navigation globale manquante pour les blogs

    • Problèmes liés aux données

    • Modifications apportées à l'interface utilisateur

    • Manque d'espace

    • Authentification par formulaire

    • Sécurité et autorisations

    • Les fichiers .stp ne fonctionnent pas après la mise à niveau

    • Impossible de trouver les nouvelles versions des modèles d'applications Fabulous 40

Principes généraux de l'identification des problèmes

Commencez par vérifier l'état de la mise à niveau pour déterminer à quel stade celle-ci s'est arrêtée le cas échéant et consultez les fichiers journaux pour savoir s'ils comportent des erreurs ou des avertissements. Ensuite, avant de reprendre la mise à niveau, résolvez les problèmes détectés.

Première phase : vérifier l'état de la mise à niveau et les fichiers journaux

Les indicateurs d'état de mise à niveau et les fichiers journaux doivent vous donner une idée du dysfonctionnement qui s'est produit pendant le processus de mise à niveau. Il est recommandé de passer attentivement en revue toutes les erreurs consignées dans les fichiers journaux de mise à niveau. Les avertissements ne sont pas nécessairement révélateurs d'un problème, mais vous devez tous les passer en revue pour déterminer si ce que signale l'un d'eux est susceptible d'engendrer des problèmes supplémentaires.

  1. Vérifiez l'état de la mise à niveau en effectuant l'une et/ou l'autre des opérations suivantes :

    • Passez en revue la page État de la mise à niveau dans le site Web Administration centrale de SharePoint.

    • Utilisez l'opération Stsadm.exe localupgradestatus pour vérifier l'état de la mise à niveau.

    Pour plus d'informations sur la vérification de l'état de la mise à niveau, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

  2. Passez en revue les fichiers journaux suivants :

    • Le fichier journal Setup.exe.

    • Le fichier journal de l'Assistant Configuration des produits SharePoint (Psconfig.exe).

    • Le fichier journal des erreurs de mise à niveau et le fichier journal de mise à niveau (dont le contenu est plus détaillé que le fichier journal des erreurs de mise à niveau).

    • Les fichiers journaux ULS ou de suivi.

      Ces fichiers sont stockés dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\LOGS et sont nommés nomserveur_AAAAMMJJ-MMSS.log.

    • Le fichier journal des événements de l'application.

      Ce fichier peut être visualisé à l'aide de l'Observateur d'événements.

    Pour plus d'informations sur les fichiers Setup.exe, PSconfig.exe et sur les fichiers journaux de mise à niveau, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010). Pour plus d'informations sur le fichier journal de suivi, voir Journaux de suivi (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=182380&clcid=0x40C) sur MSDN.

Seconde phase : résolution des problèmes dans l'ordre

Certains problèmes ont plus d'incidence que d'autres. Par exemple, l'absence d'un fichier côté serveur peut entraîner de nombreuses erreurs apparemment disparates au niveau du site.

Résolvez les problèmes dans l'ordre suivant :

  1. Personnalisations ou fichiers côté serveur manquants, tels que des fonctionnalités ou des composants WebPart.

  2. Problèmes de configuration dans la batterie de serveurs, l'application Web ou les services, tels que les chemins d'accès gérés ou les services qui ne sont pas démarrés.

  3. Problèmes supplémentaires que vous détectez site par site, en commençant par les sites au profil élevé à fort impact.

Lorsque vous identifiez et résolvez les problèmes de niveau supérieur, vous pouvez essayer de réexécuter la mise à niveau pour déterminer si les autres problèmes plus en aval dans le processus de mise à niveau ont également été résolus.

Problèmes courants

Vérifiez si les problèmes suivants engendrent une erreur ou un avertissement de mise à niveau.

Personnalisations ou fichiers côté serveur manquants ou désapprouvés

L'une des erreurs couramment rencontrées lors d'une mise à niveau est l'absence de fichiers côté serveur, en l'occurrence de fichiers installés avec Windows SharePoint Services 3.0 ou de fichiers personnalisés. Lorsque vous avez préparé la mise à niveau, vous devez avoir créé un inventaire des personnalisations côté serveur requises par vos sites (telles que les définitions de site, les modèles, les fonctionnalités, les composants WebPart et les assemblys). L'outil de vérification préalable à la mise à niveau permet d'identifier ces éléments. Consultez cet inventaire pour vérifier que tous les fichiers requis par vos personnalisations sont installés dans votre environnement de mise à niveau.

Si vous effectuez une mise à niveau avec liaison des bases de données, vous pouvez utiliser l'applet de commande Windows PowerShell test-spcontentdatabase avant de mettre à niveau la base de données pour identifier les fichiers éventuellement manquants. Vous pouvez également utiliser l'opération enumallwebs dans Stsadm.exe pour identifier les personnalisations côté serveur en cours d'utilisation.

Les fichiers journaux de mise à niveau peuvent signaler des erreurs telles que les suivantes :

  • ERREUR Détection de nombre web(s) utilisant modèle web manquant identificateur modèle de site (lcid : code de langue du modèle de site) dans base de données de contenu nom base de données de contenu.

  • ERREUR Une fonctionnalité manquante trouvée Id = [identificateur de la fonctionnalité]

  • ERREUR Le fichier [chemin d'accès relatif du fichier] est référencé [nombre] fois dans la base de données, mais il n'est pas installé dans la batterie de serveurs actuelle.

  • AVERTISSEMENT La classe du composant WebPart [identificateur du composant WebPart] est référencée [nombre] fois dans la base de données, mais elle n'est pas installée sur la batterie de serveurs actuelle.

  • AVERTISSEMENT L'assembly [chemin d'accès de l'assembly] est référencé dans la base de données, mais il n'est pas installé dans la batterie de serveurs actuelle.

  • AVERTISSEMENT Impossible de mettre à niveau la fonctionnalité. Exception : ID de définition de fonctionnalité « identificateur de la fonctionnalité » introuvable.

Si vous pouvez obtenir une dépendance ou un fichier côté serveur manquant, installez-le, puis réexécutez la mise à niveau pour les sites affectés. Si le fichier ou la dépendance (tel qu'un composant WebPart) a été désapprouvé, vous devez déterminer si vous souhaitez recréer le site, la page ou le composant WebPart pour utiliser un modèle, une fonctionnalité ou un composant WebPart différent. Si vous pouvez rétablir la personnalisation à l'aide de dépendances qui n'ont pas été désapprouvées, vous pouvez réexécuter la mise à niveau pour les sites affectés. Si vous ne pouvez pas supprimer la dépendance, vous ne pouvez pas mettre à niveau le site.

Après avoir installé la dépendance ou le fichier manquant, utilisez l'applet de commande Windows PowerShelltest-SPContentDatabase sur un serveur de test pour déterminer si d'autres fichiers sont manquants pour cette base de données. Si vous exécutez uniquement l'outil de vérification préalable à la mise à niveau ou que vous réexécutez la mise à niveau, il est possible que l'erreur n'apparaisse pas dans les fichiers journaux.

Paramètres manquants ou incorrectement configurés pour la batterie de serveurs, l'application Web ou les services

Vérifiez les paramètres de la batterie de serveurs et de l'application Web, puis créez et démarrez tous les services manquants.

Vérifiez que tous les chemins d'accès gérés (chemins d'accès inclus ou exclus) sont correctement configurés pour chaque application Web.

Les fichiers journaux de mise à niveau peuvent signaler des erreurs telles que les suivantes :

  • ERREUR Modèle Id modèle: Id Site SP=Id site est inaccessible en raison d'une exception. Abandon Id Web SP=Id Web pour la mise à niveau du modèle. Exception: System.IO.FileNotFoundException: Impossible de trouver le site avec l'ID Id de site.

    Cette erreur indique qu'un chemin d'accès géré est manquant. Ajoutez à l'application Web le chemin d'accès géré pour la collection de sites et redémarrez la mise à niveau pour la base de données de contenu hébergeant cette collection de sites.

Niveaux de mise à jour incohérents ou incorrects

Vous devez exécuter Windows SharePoint Services 3.0 avec Service Pack 2 pour exécuter la mise à niveau. Si cette configuration minimale requise n'est pas satisfaite, une erreur apparaît et la mise à niveau n'est pas exécutée.

Navigation globale manquante pour les blogs

L'une des autres erreurs courantes est l'absence de la navigation globale pour les blogs mis à niveau. Cela est dû au fait que la fonctionnalité MySiteNavigation (6adff05c-d581-4c05-a6b9-920f15ec6fd9) n'est pas activée durant la mise à niveau. Pour activer cette fonctionnalité, exécutez l'applet de commande Enable-SPFeatureWindows PowerShell 2.0.

Pour plus d'informations, voir Enable-SPFeature.

Problèmes liés aux données

Les problèmes liés aux données suivants peuvent engendrer des erreurs ou des avertissements pendant la mise à niveau :

  • Connectivité aux sources de données. Si vos serveurs ne peuvent pas se connecter aux bases de données, ils ne peuvent pas être mis à niveau.

  • Listes ou sites orphelins, ou autres endommagements de base de données. Pour plus d'informations, voir Nettoyage de votre environnement avant la mise à niveau (SharePoint Foundation 2010).

  • Données de colonnes masquées. Si le processus de mise à niveau ajoute une colonne à une liste et qu'une colonne personnalisée portant le même nom existe déjà dans la liste, la colonne personnalisée est renommée. Après la mise à niveau, vous devrez peut-être réajuster vos vues afin qu'elles comportent la colonne renommée.

Les fichiers journaux de mise à niveau peuvent signaler des erreurs telles que les suivantes :

  • AVERTISSEMENT Les sites orphelins peuvent engendrer des échecs de mise à niveau.

  • ERREUR La base de données [nom de la base de données de contenu] contient un site (ID = [identificateur de la collection de sites], URL = [URL de la collection de sites]) qui ne figure pas dans le plan du site.

Corrigez la totalité des éléments orphelins ou des endommagements de base de données, puis réexécutez la mise à niveau.

Modifications apportées à l'interface utilisateur

Les modifications apportées à l'interface utilisateur, telles que l'ajout de l'interface utilisateur Fluent UI (également appelée Ruban) ou l'adhésion aux standards XHTML, peuvent engendrer des problèmes dans les sites. Parfois, des éléments personnalisés (tels qu'un type de contenu) peuvent porter un nom qui entre en conflit avec un nom dans la nouvelle version. Il peut également être nécessaire de redéfinir des pages sur la définition de site standard ou de créer des affichages pour des grandes listes.

Pour plus d'informations sur l'examen des problèmes d'interface utilisateur dans les sites, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Les fichiers journaux de mise à niveau peuvent signaler des erreurs telles que les suivantes :

  • Échec de l'activation des fonctionnalités étendues aux collections de sites sur le site Url du site. Exception : Un nom de type de contenu nom en double a été trouvé.

    Cette erreur indique qu'un type de contenu « Résumé » tiers a été ajouté au site spécifié dans o12, et pendant la mise à niveau vers o14 son nom entre en conflit le type de contenu intégré « Résumé » prêt à l'emploi. Supprimez le type de contenu tiers dans le site spécifié ou attribuez-lui un nom différent de « Résumé », puis réexécutez la mise à niveau.

Manque d'espace

Si vous manquez d'espace (par exemple, pour les fichiers journaux de transactions des serveurs de bases de données), la mise à niveau ne peut pas se poursuivre. Libérez de l'espace ou augmentez la taille du fichier journal des transactions avant de reprendre la mise à niveau. Pour plus d'informations, voir Gestion de la taille du fichier journal des transactions (http://go.microsoft.com/fwlink/?linkid=124882&clcid=0x40C).

Authentification par formulaire

Des étapes supplémentaires sont nécessaires si vous mettez à niveau un environnement qui utilise l'authentification par formulaire. Suivez les étapes indiquées dans Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010) pour mettre à niveau des fournisseurs d'authentification par formulaire.

Sécurité et autorisations

Si une erreur signalant un compte inconnu s'affiche ou si une base de données n'est pas mise à niveau, vérifiez les éléments suivants :

  • Pour une mise à niveau sur place, vérifiez que le compte que vous utilisez pour exécuter l'Assistant Configuration des produits SharePoint est membre du rôle de base de données fixe db_ownerpour toutes les bases de données que vous souhaitez mettre à niveau. S'il n'est pas membre de ce rôle, une erreur signalant un compte d'utilisateur inconnu risque de s'afficher lorsque l'Assistant démarre pour mettre à niveau les bases de données.

  • Pour une mise à niveau avec liaison des bases de données, si vous déplacez des bases de données entre des instances de SQL Server, vérifiez que la sécurité est correctement configurée. Vérifiez que les comptes utilisés disposent des rôles fixes et autorisations adéquats sur les bases de données et qu'ils resteront valides en cas de mise à niveau d'un domaine à un autre.

Les fichiers .stp ne fonctionnent pas après la mise à niveau

Les modèles de sites (fichiers .stp) sont obsolètes dans SharePoint Foundation 2010 et ne peuvent pas être utilisés pour créer de nouveaux sites. Les sites existants basés sur des fichiers .stp continueront de fonctionner comme prévu. Les packages de solutions (fichiers .wsp) constituent la méthode prise en charge pour la création de sites basés sur un modèle dans SharePoint Foundation 2010. Vous pouvez convertir un fichier .stp en fichier .wsp pour continuer à utiliser le modèle après la mise à niveau.

Pour convertir un fichier .stp en fichier .wsp

  1. Dans Windows SharePoint Services 3.0, créez un site basé sur le modèle, puis effectuez la mise à niveau du site vers SharePoint Foundation 2010.

  2. Dans SharePoint Foundation 2010, dans le menu Actions du site dans le site mis à niveau, cliquez sur Paramètres du site.

  3. Dans la page Paramètres du site, sous Actions du site, cliquez sur Enregistrer le site en tant que modèle.

  4. Dans la page Enregistrer comme modèle, entrez un Nom de fichier et un Nom de modèle, puis cliquez sur OK.

    Le modèle de site est enregistré en tant que fichier .wsp dans la galerie de solutions de cette collection de sites et vous pouvez créer des sites basés sur cette solution.

Impossible de trouver les nouvelles versions des modèles d'applications Fabulous 40

De nombreuses personnes utilisaient les modèles « Fabulous 40 » créés pour Windows SharePoint Services 3.0. Certains de ces modèles ont été créés en tant que modèles d'administration de site (fichiers .stp), tandis que d'autres ont été créés en tant que modèles d'administration de serveur (fichiers .wsp). Microsoft ne publie plus de nouvelles versions de ces modèles pour Produits SharePoint 2010. Par ailleurs, les fichiers .stp sont obsolètes et ne peuvent pas être utilisés pour créer des sites lorsque vous effectuez une mise à niveau vers SharePoint Foundation 2010.

Il est possible de mettre à niveau les sites basés sur ces modèles. Toutefois, vous devez essayer de mettre à niveau ces sites dans un environnement de test avant de mettre à niveau l'environnement de production, de manière à détecter tout problème potentiel. Utilisez l'outil de vérification de pré-mise à niveau afin de détecter les problèmes. (Certaines personnes ont constaté des problèmes au niveau des flux de travail personnalisés ou des affichages CAML dans les modèles.) Notez qu'à l'issue de la mise à niveau, vous ne pourrez plus utiliser de fichiers .stp pour créer des modèles.

Le tableau suivant explique comment les modèles peuvent être utilisés

Type de modèle | Puis-je mettre à niveau les sites basés sur ce modèle ? | Puis-je utiliser le modèle après la mise à niveau ?
Administration de site (modèle de site ou fichier .stp) | Oui | Non
Administration de serveur (package de solution ou fichier .wsp) | Oui* | Oui*

*Il existe des problèmes au niveau de certains fichiers .wsp après la mise à niveau. Plus spécifiquement, après la mise à niveau, certains utilisateurs sont dans l'impossibilité de créer des sites basés sur les modèles suivants : Demande de congé et Planning des absences et congés, Centre d'appels, Assistance, Espace de travail de l'équipe informatique, Base de connaissances et Gestion et suivi des biens physiques. Si vous rencontrez des problèmes lors de l'utilisation de ces modèles, vous pouvez publier un message de problème sur le Forum TechNet SharePoint 2010 - Installation, mise à niveau, administration et fonctionnement (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201600&clcid=0x40C) ou contacter le Support clientèle Microsoft.

Si vous souhaitez continuer à créer des sites basés sur les modèles d'administration de site (fichiers .stp) dans SharePoint Foundation 2010, vous devez les convertir en packages de solutions (fichiers .wsp). Pour plus d'informations, voir la section Les fichiers .stp ne fonctionnent pas après la mise à niveau plus haut dans cet article.

Voir aussi

Concepts

Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010)
Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010)
Reprendre la mise à niveau (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
23 septembre 2010 | 2010/09/20 | Mise à jour du contenu


Récupération après un échec de mise à niveau (SharePoint Foundation 2010)

Si la mise à niveau vers Microsoft SharePoint Foundation 2010 a échoué et si vous n'avez pas le temps de poursuivre la résolution des problèmes ou de reprendre le processus de mise à niveau, vous devez récupérer votre environnement Windows SharePoint Services 3.0. Les étapes diffèrent selon le type de sauvegarde dont vous disposez. Si vous étiez en train d'effectuer une mise à niveau avec attachement des bases de données et si vous avez conservé votre environnement d'origine (soit en utilisant des bases de données en lecture seule, soit en mettant l'environnement hors connexion), vous pouvez récupérer facilement votre environnement. Si vous étiez en train d'effectuer une mise à niveau sur place, vous devez récupérer l'intégralité de votre environnement et restaurer les données.

Si vous avez le temps, résolvez les problèmes et reprenez la mise à niveau. Pour plus d'informations, voir Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010) et Reprendre la mise à niveau (SharePoint Foundation 2010).

Dans cet article :

  • Récupération avec des bases de données en lecture seule dans un environnement de secours (mise à niveau avec attachement des bases de données)

  • Récupération avec une sauvegarde d'environnement complète (mise à niveau sur place)

  • Récupération avec des sauvegardes de bases de données (mise à niveau sur place)

Récupération avec des bases de données en lecture seule dans un environnement de secours (mise à niveau avec attachement des bases de données)

Lorsque vous effectuez une mise à niveau avec attachement des bases de données, vous avez la possibilité de quitter l'environnement existant disponible, à condition que les bases de données soient définies en lecture seule. Dans cet état, cette méthode de récupération est la plus simple, car votre environnement d'origine est toujours disponible, il est simplement défini en lecture seule. Si vous devez récupérer votre environnement, il vous suffit de redéfinir les bases de données en lecture-écriture et de reprendre le traitement des requêtes. L'article Faire fonctionner une batterie qui utilise des bases de données en lecture seule (Windows SharePoint Services) décrit les étapes à entreprendre pour qu'une batterie de serveurs utilise des bases de données en lecture seule. Pour rendre à nouveau opérationnelle une batterie de serveurs en lecture seule, vous devez réaffecter la valeur False à l'entrée Base de données en lecture seule, puis réactiver les travaux du minuteur répertoriés dans cet article.

Récupération avec une sauvegarde d'environnement complète (mise à niveau sur place)

Si vous avez créé une sauvegarde complète de votre environnement avant de démarrer le processus de mise à niveau, vous pouvez restaurer cette sauvegarde complète afin de récupérer votre environnement. Pour plus d'informations sur la restauration d'une sauvegarde complète, voir Restaurer Windows SharePoint Services 3.0 à l'aide des outils intégrés.

Récupération avec des sauvegardes de bases de données (mise à niveau sur place)

Si vous avez uniquement créé des sauvegardes de vos bases de données de contenu, vous pouvez toujours récupérer votre environnement, mais cela prendra plus de temps et nécessitera davantage d'étapes. Vous devez essentiellement recréer votre environnement, puis restaurer les sauvegardes de bases de données. Pour plus d'informations sur la récupération d'un environnement et la restauration des bases de données de contenu sauvegardées, voir Restaurer une batterie de serveurs après un problème de base de données de configuration (Windows SharePoint Services).

Historique des modifications


Reprendre la mise à niveau (SharePoint Foundation 2010)

Dans certains cas, vous pouvez être amené à redémarrer la mise à niveau pour finir de mettre à niveau vos sites depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010. Par exemple :

  • Durant une mise à niveau sur place, si le serveur redémarre ou si la mise à niveau échoue, vous devez relancer le processus de mise à niveau à l'aide de Psconfig.exe pour mettre à niveau les sites restants.

  • Durant une mise à niveau avec liaison des bases de données, les sites qui ne peuvent pas être mis à niveau seront ignorés. Après avoir résolu tous les problèmes affectant les sites (tels que l'absence d'un modèle ou d'un module linguistique ou le fait que le site est configuré pour être accessible en lecture seule ou qu'il a dépassé son quota), vous pouvez redémarrer la mise à niveau à l'aide d'une commande Windows PowerShell pour ne mettre à niveau que les sites ignorés.

Remarque :
Une cause fréquente des échecs de mise à niveau est le manque d'éléments personnalisés dans l'environnement, tels que des fonctionnalités ou des solutions personnalisées. Avant de commencer le processus de mise à niveau, vérifiez que tous les éléments personnalisés requis sont installés sur les serveurs Web frontaux. Vous pouvez utiliser l'outil de vérification de pré-mise à niveau et, dans le cas d'une mise à niveau avec liaison des bases de données, l'applet de commande Windows PowerShelltest-spcontentdatabase, pour identifier tous les éléments personnalisés éventuellement utilisés par vos sites. Pour plus d'informations, voir Identifier et installer les personnalisations dans l'article « Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels ».

Dans cet article :

  • Redémarrer la mise à niveau pour une batterie de serveurs à l'aide de Psconfig.exe

  • Redémarrer la mise à niveau pour une base de données à l'aide de Windows PowerShell

Redémarrer la mise à niveau pour une batterie de serveurs à l'aide de Psconfig.exe

Si vous déterminez que la mise à niveau s'est arrêtée ou a échoué avant la fin de l'Assistant Configuration des produits SharePoint, vous pouvez la redémarrer à partir de ce point en réexécutant l'Assistant Configuration des produits SharePoint ou en utilisant une opération de ligne de commande. Ce processus est également appelé application d'une mise à niveau logicielle. Avant de redémarrer la mise à niveau, veillez à rechercher et à résoudre le problème à l'origine de son échec ou de son arrêt.

Pour redémarrer la mise à niveau pour la batterie de serveurs

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour utiliser Psconfig.exe, vous devez être membre du groupe Administrateurs local sur le serveur.

  2. Ouvrez une fenêtre d'invite de commandes et accédez au répertoire suivant :

    %COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\14\Bin\

  3. Tapez la commande suivante :

    psconfig -cmd upgrade -inplace v2v -passphrase < phrase secrète > -wait

    Il existe un paramètre facultatif, -force, qui impose la poursuite de la mise à niveau si la commande ne fonctionne pas. Ajoutez -force à la fin de la chaîne de commande pour imposer la poursuite du processus de mise à niveau.
Remarque :
Vous pouvez activer l'enregistrement de Windows Installer avant de recommencer l'installation de la mise à niveau logicielle. Pour ce faire, voir l'article de la Base de connaissances Microsoft : Comment faire pour activer l'enregistrement de Windows Installer (http://go.microsoft.com/fwlink/?linkid=99206&clcid=0x40C).

Redémarrer la mise à niveau pour une base de données à l'aide de Windows PowerShell

Si le processus de mise à niveau a ignoré une collection de sites pendant la mise à niveau sur place ou la mise à niveau avec liaison des bases de données, vous pouvez le redémarrer pour la base de données qui contient cette collection de sites à l'aide d'une applet de commande Windows PowerShell.

Pour redémarrer la mise à niveau pour une base de données à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante :

    upgrade-spcontentdatabase -id <GUID>

    Où GUID représente l'identificateur de la base de données. Vous pouvez exécuter l'applet de commande suivante pour rechercher le GUID d'une base de données de contenu :

    Get-SPContentDatabase -Identity <nom_base_de_données_de_contenu>

Pour plus d'informations, voir Upgrade-SPContentDatabase.

Historique des modifications


Effectuer les étapes préalables à la mise à niveau (SharePoint Foundation 2010)

Après avoir planifié votre processus de mise à niveau vers Microsoft SharePoint Foundation 2010, vous pouvez le démarrer en suivant les étapes préalables à la mise à niveau requises.

Dans cette section :

  • Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010)

    L'outil de vérification de pré-mise à niveau identifie les problèmes potentiels de mise à niveau dans votre environnement. Exécutez cet outil lorsque vous planifiez la mise à niveau, avant de l'effectuer, afin de pouvoir résoudre ces problèmes.

  • Sauvegarder l'intégralité de l'environnement avant une mise à niveau sur place (SharePoint Foundation 2010)

    Créez une sauvegarde complète de votre environnement pour vous assurer que vous pouvez le récupérer si la mise à niveau ne se passe pas comme prévu.

Historique des modifications


Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010)

Vous pouvez utiliser l'outil de vérification préalable à la mise à niveau pour créer un rapport sur l'état de votre environnement et des sites SharePoint avant d'effectuer la mise à niveau vers Microsoft SharePoint Foundation 2010. Il est vivement recommandé que l'administrateur du serveur exécute l'outil de vérification préalable à la mise à niveau avant d'effectuer la mise à niveau et qu'il résolve tous les problèmes possibles avant de planifier celle-ci.

L'outil de vérification préalable à la mise à niveau est une opération Stsadm que vous lancez dans un environnement Windows SharePoint Services 3.0 pour détecter les problèmes potentiels de mise à niveau et consulter les recommandations et méthodes conseillées. L'opération est disponible avec Windows SharePoint Services 3.0 Service Pack 2 et a été mise à jour dans la mise à jour cumulative d'octobre 2009 pour Windows SharePoint Services 3.0. Vous pouvez télécharger et installer cette mise à jour à partir de la page Les packages de mise à jour cumulative d'octobre 2009 pour SharePoint Server 2007 et Windows SharePoint Services 3.0 sont publiés (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=169179&clcid=0x40C).

Remarque :
Vous devrez peut-être exécuter l'outil de vérification préalable à la mise à niveau plusieurs fois. Par exemple, si vous l'exécutez pour évaluer votre batterie de serveurs, mais que vous n'effectuez pas la mise à niveau avant plusieurs semaines, vous pouvez le réexécuter avant d'effectuer la mise à niveau pour analyser les nouveaux sites et pour vous assurer qu'aucun problème supplémentaire n'est apparu entre-temps.

Dans cet article :

  • À propos du rapport de l'outil de vérification préalable à la mise à niveau

  • Exécuter l'outil de vérification préalable à la mise à niveau

Remarque :
Une cause fréquente de défaillances au cours d'une mise à niveau est due à des fonctionnalités, des solutions ou d'autres éléments personnalisés manquants dans l'environnement. Vérifiez que les éléments personnalisés dont vous avez besoin sont installés sur vos serveurs Web frontaux avant de commencer le processus de mise à niveau. Vous pouvez utiliser l'outil de vérification préalable à la mise à niveau et, pour une mise à niveau avec liaison des bases de données, l'applet de commande test-spcontentdatabaseWindows PowerShell afin d'identifier les éléments personnalisés que vos sites pourraient utiliser. Pour plus d'informations, voir Identifier et installer les personnalisations dans l'article « Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels ».

À propos du rapport de l'outil de vérification préalable à la mise à niveau

L'outil de vérification préalable à la mise à niveau fournit des informations sur l'état de votre environnement et des sites SharePoint dans cet environnement, notamment :

  • Disponibilité pour la mise à niveau et chemins d'accès pris en charge : renvoie la liste de tous les serveurs et composants de la batterie de serveurs et des informations indiquant si les serveurs remplissent les conditions requises pour la mise à niveau.

  • Paramètres de mappage des accès de substitution : renvoie la liste des URL de mappage des accès de substitution qui sont utilisées dans la batterie de serveurs.

  • Éléments installés : renvoie la liste de l'ensemble des définitions de sites, des modèles de sites, des composants fonctionnels et des modules linguistiques installés dans la batterie de serveurs. Vous devez savoir quels modèles de sites ont été installés ou utilisés afin de pouvoir vérifier s'ils sont disponibles après une mise à niveau ou une liaison des bases de données. Vous devez savoir également quels éléments ont été personnalisés afin de pouvoir vérifier les personnalisations après la mise à niveau. Par exemple, vous devez savoir si un site dépend d'un module linguistique pour Windows SharePoint Services 3.0 qui n'existait pas encore pour SharePoint Foundation 2010, afin de pouvoir planifier comment traiter ce site durant la mise à niveau.

  • Personnalisations non prises en charge : signale si des personnalisations côté serveur qui ne sont pas prises en charge (telles que les modifications de schéma de base de données) existent dans la batterie de serveurs.

  • Objets orphelins : dresse la liste des orphelins de base de données ou de site dans la batterie de serveurs. Des éléments de liste, des listes, des documents, des sites Web et des collections de sites peuvent être orphelins, c'est-à-dire que les objets existent, mais ne sont pas associés à un site particulier. Étant donné que les objets orphelins ne fonctionnent pas dans la version précédente, ils ne fonctionneront pas après la mise à niveau. Si vous effectuez une mise à niveau sur place, les éléments orphelins existent toujours, mais ne fonctionnent pas. Il est recommandé de réparer les objets orphelins avant la mise à niveau.

    Conseil :
    Les membres du groupe Administrateurs sur les serveurs Web frontaux peuvent réparer les éléments orphelins avant la mise à niveau en suivant les étapes décrites dans l'article 918744 de la Base de connaissances, Description d'une nouvelle opération de ligne de commande que vous pouvez utiliser pour réparer des bases de données de contenu dans Windows SharePoint Services (http://go.microsoft.com/fwlink/?linkid=69958&clcid=0x40C).

  • Paramètres de configuration valides : signale les paramètres de configuration manquants ou non valides (comme un fichier Web.config manquant, des noms d'hôte non valides ou des comptes de service non valide) qui existent dans la batterie de serveurs.

  • Conditions requises pour les bases de données : signale si les bases des données remplissent les conditions requises pour la mise à niveau, par exemple si elles sont en lecture/écriture et si la taille de chaque base de données ou collection de sites stockée dans la base de données interne Windows ne dépasse pas 4 Go.

Utilisez les informations collectées par l'outil de vérification préalable à la mise à niveau pour déterminer :

  • S'il convient d'effectuer une mise à niveau sur place ou une mise à niveau avec liaison des bases de données.

    Déterminer l'approche de mise à niveau (SharePoint Foundation 2010) fournit des informations qui vous aident à déterminer le type de mise à niveau à effectuer. Il est important de tenir compte du rapport généré par l'outil de vérification préalable à la mise à niveau pour prendre cette décision. Si vos serveurs ne respectent pas la configuration requise pour une mise à niveau sur place, vous devez envisager de procéder à une mise à niveau avec liaison des bases de données.

  • S'il convient de mettre à niveau une partie ou la totalité des collections de sites qui contiennent des sites personnalisés.

  • Les sites dont la personnalisation doit être appliquée de nouveau ou renouvelée après la mise à niveau et qui, par conséquent, peuvent prendre plus de temps que d'autres au cours de l'étape de révision.

Une feuille de calcul est à votre disposition, dans laquelle vous pouvez enregistrer les informations sur votre environnement pendant que vous préparez la mise à niveau. Téléchargez la feuille de calcul à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=179928&clcid=0x40C (éventuellement en anglais).

Exécuter l'outil de vérification préalable à la mise à niveau

Avant d'effectuer cette procédure, assurez-vous que :

  • Votre système exécute Windows SharePoint Services 3.0 avec Service Pack 2

Pour exécuter l'outil de vérification préalable à la mise à niveau

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour utiliser Stsadm, vous devez appartenir au groupe Administrateurs locaux du serveur.

  2. Cliquez sur Démarrer, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu'administrateur.

  3. Dans la fenêtre d'invite de commandes, accédez au répertoire suivant :

    %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\12\bin

  4. Tapez la commande suivante, puis appuyez sur Entrée :

    STSADM.EXE -o preupgradecheck

    Cette commande vérifie le serveur local et vos paramètres au niveau de la batterie de serveurs. Pour obtenir la liste des autres paramètres que vous pouvez utiliser avec cette opération, voir Preupgradecheck : opération Stsadm (Windows SharePoint Services). Pour obtenir la liste des règles incluses dans l'outil de vérification préalable à la mise à niveau, voir la rubrique Analyse et rapport préalables à la mise à niveau vers des versions ultérieures (Windows SharePoint Services).

Après avoir exécuté l'outil de vérification préalable à la mise à niveau, le rapport s'ouvre automatiquement dans votre navigateur par défaut. Vous pouvez également afficher le rapport en l'ouvrant à partir de son emplacement dans le répertoire %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\12\LOGS. Le rapport est nommé selon le format suivant : PreUpgradeCheck_AAAAMMJJ-HHMMSS-SSS-nombre aléatoire.htm, où AAAAMMJJ est la date, HHMMSS-SSS est l'heure (heures au format 24 heures, minutes, secondes et millisecondes), et le nombre aléatoire est utilisé pour la distinction entre deux tentatives simultanées possibles d'exécution de l'outil de vérification préalable à la mise à niveau. Il existe également des versions TXT et XML du rapport au même emplacement.

Utilisez le rapport pour détecter et résoudre les problèmes. Vous pouvez également partager les résultats pertinents avec d'autres membres de l'équipe de mise à niveau. Par exemple, vous pouvez signaler des problèmes tels que des modèles de site personnalisés ou des composants WebPart personnalisés au propriétaire du site, au concepteur Web ou au développeur approprié avant de planifier la mise à niveau, pour leur donner le temps de résoudre les problèmes.

Historique des modifications


Sauvegarder l'intégralité de l'environnement avant une mise à niveau sur place (SharePoint Foundation 2010)
Voir aussi

Pour être assuré de pouvoir récupérer l'environnement existant en cas de problème pendant la mise à niveau, vous devez sauvegarder l'environnement Windows SharePoint Services 3.0 avant d'exécuter le processus de mise à niveau.

Si vous exécutez Windows SharePoint Services 3.0 dans un environnement virtuel Hyper-V, voir Utilisation des produits et technologies SharePoint dans un environnement virtuel Hyper-V (http://go.microsoft.com/fwlink/?linkid=125834&clcid=0x40C).

Sauvegarder l'environnement

Vous pouvez effectuer une sauvegarde complète de l'environnement Windows SharePoint Services 3.0. Il est recommandé d'effectuer une sauvegarde complète de la batterie de serveurs avant d'effectuer la mise à niveau.

Pour sauvegarder l'environnement Windows SharePoint Services 3.0, utilisez les procédures décrites dans Sauvegarder une batterie de serveurs à l'aide des outils intégrés (Windows SharePoint Services 3.0) (http://go.microsoft.com/fwlink/?linkid=105988&clcid=0x40C).

Si vous avez déployé des personnalisations, vous devez également les sauvegarder. Pour plus d'informations, voir Sauvegarder et restaurer les personnalisations (Windows SharePoint Services) (http://go.microsoft.com/fwlink/?linkid=186627&clcid=0x40C).

Tester les sauvegardes

Vous devez vous assurer que ces sauvegardes sont valides, afin de pouvoir effectuer une récupération en cas de défaillance matérielle ou d'altération des données au cours de la mise à niveau. Pour tester les sauvegardes, configurez une batterie de serveurs Windows SharePoint Services 3.0 non utilisée en production, restaurez les sauvegardes, installez toutes les personnalisations (définitions de site, composants WebPart, etc.), puis vérifiez que la sauvegarde restaurée est opérationnelle.

Pour ce faire, utilisez les procédures décrites dans Restaurer Windows SharePoint Services 3.0 à l'aide des outils intégrés (http://go.microsoft.com/fwlink/?linkid=105989&clcid=0x40C).

Voir aussi

Autres ressources

Sauvegarder et restaurer la batterie de serveurs (Windows SharePoint Services 3.0)

Historique des modifications


Effectuer une mise à niveau sur place (SharePoint Foundation 2010)

Maintenant que vous avez étudié le processus de mise à niveau en consultant les articles dans À propos du processus de mise à niveau (SharePoint Foundation 2010) et planifié votre mise à niveau en suivant les étapes indiquées dans les articles dans Planifier et préparer la mise à niveau (SharePoint Foundation 2010), vous êtes en mesure d'effectuer la mise à niveau sur place vers Microsoft SharePoint Foundation 2010. Vous pouvez suivre les étapes indiquées dans cette section pour une mise à niveau d'évaluation et pour votre mise à niveau sur place réelle sur votre batterie de serveurs de production.

Dans cette section :

  • Liste de vérification pour une mise à niveau sur place (SharePoint Foundation 2010)

    Utilisez cette liste de vérification pour vérifier que vous suivez toutes les étapes nécessaires (étapes de préparation, étapes d'exécution et étapes postérieures à l'exécution) de la mise à niveau.

  • Mise à niveau sur place de SharePoint Foundation 2010

    Découvrez toutes les étapes nécessaires pour une mise à niveau sur place, depuis l'installation des composants obligatoires jusqu'à la mise à niveau des sites.

  • Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec stockage BLOB distant

    Prenez connaissance des étapes requises pour la mise à niveau vers SharePoint Foundation 2010 depuis un système Windows SharePoint Services 3.0 autonome dont les bases de données de contenu sont supérieures à 4 gigaoctets (Go).

  • Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010)

    Comprenez comment utiliser l'approche hybride de détachement des bases de données. Cette approche combine une mise à niveau sur place avec l'efficacité et la vitesse d'une mise à niveau simultanée de plusieurs bases de données en même temps.

  • Installer les packs de modèles linguistiques disponibles (SharePoint Foundation 2010)

    Installez tous les modules linguistiques nécessaires pour votre environnement, après avoir exécuté le programme d'installation et avant d'exécuter l'Assistant Configuration des produits SharePoint.

Historique des modifications


Liste de vérification pour une mise à niveau sur place (SharePoint Foundation 2010)
Voir aussi

Cet article contient une liste de vérification qui vous permet de vérifier que vous avez suivi toutes les étapes nécessaires (étapes de préparation, étapes d'exécution et étapes postérieures à l'exécution) de la mise à niveau.

Dans cet article :

  • Préparer la mise à niveau

  • Effectuer la mise à niveau

  • Effectuer les étapes postérieures à la mise à niveau

Certaines étapes comportent des remarques sur leur durée. Il s'agit uniquement d'estimations destinées à vous donner une idée relative de la durée d'une étape. Pour déterminer la durée de chaque étape pour votre environnement, il est recommandé d'effectuer des mises à niveau d'évaluation dans un environnement de test. Pour plus d'informations, voir Estimer la durée du processus de mise à niveau et l'espace dont vous avez besoin (SharePoint Foundation 2010) et Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010).

Préparer la mise à niveau

Suivez ces étapes dans l'ordre avant de commencer une mise à niveau sur place :

Étapes préalables à la mise à niveau pour une mise à niveau sur place Remarques

[ ]

Exécuter l'outil de vérification préalable à la mise à niveau

Exécutez l'outil de vérification préalable à la mise à niveau et résolvez les problèmes. Utilisez le rapport généré par l'outil pour remplir la feuille de calcul relative à la planification de la mise à niveau.

Étapes détaillées : Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

Effectuez cette étape à plusieurs reprises lorsque vous nettoyez votre environnement et que vous testez votre processus de mise à niveau.

L'exécution de l'outil de vérification ne prend que quelques minutes, mais la résolution des problèmes peut durer des jours ou des semaines.

[ ]

Nettoyer votre environnement

Avant de commencer la mise à niveau, vérifiez l'intégrité de votre environnement et veillez à nettoyer tout contenu qui n'a pas lieu d'être conservé. Supprimez ou réparez les données ou sites orphelins, traitez les listes de grande taille ou les listes de contrôle d'accès volumineuses, supprimez les versions de documents non pertinentes, ainsi que les modèles, fonctionnalités ou composants WebPart non utilisés.

Étapes détaillées : Nettoyage de votre environnement avant la mise à niveau (SharePoint Foundation 2010).

Effectuez cette étape une seule fois pour l'ensemble de l'environnement.

Ce processus peut durer des jours, voire des semaines.

[ ]

Enregistrer les types de fichiers bloqués

Les types de fichiers bloqués ne sont pas conservés durant la mise à niveau. Copiez la liste des types de fichiers bloqués et enregistrez-la dans la feuille de calcul relative à la mise à niveau afin de pouvoir réappliquer les paramètres après la mise à niveau.

Effectuez cette étape une seule fois pour l'ensemble de l'environnement.

[ ]

Sauvegarder votre environnement

Sauvegardez l'intégralité de votre environnement pour avoir la garantie de pouvoir récupérer l'environnement existant en cas de problème durant le processus de mise à niveau.

Étapes détaillées : Sauvegarder l'intégralité de l'environnement avant une mise à niveau sur place (SharePoint Foundation 2010).

Effectuez cette étape une seule fois pour l'ensemble de l'environnement.

Cette étape peut durer une heure, plusieurs heures, voire davantage, en fonction de votre jeu de données et de votre environnement.

Effectuer la mise à niveau

Suivez ces étapes dans l'ordre durant une mise à niveau sur place. Les étapes requises pour une mise à niveau sur place avec bases de données détachées sont également incluses.

Avertissement :
Lorsque vous effectuez une mise à niveau sur place à partir d'une installation de Windows SharePoint Services 3.0 qui utilise la base de données interne de Windows et que la taille de la base de données est proche de 4 Go, vous devez effectuer des étapes supplémentaires. Pour plus d'informations sur ces étapes, voir Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant).

Effectuer la mise à niveau sur place Remarques

[ ]

Exécuter l'outil de vérification préalable à la mise à niveau

Réexécutez l'outil de vérification préalable à la mise à niveau pour identifier les nouveaux problèmes ou ceux qui sont encore en suspens, avant de démarrer la mise à niveau.

Étapes détaillées : Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

L'exécution de l'outil de vérification ne prend que quelques minutes, mais la résolution des problèmes peut durer plus longtemps.

[ ]

Installer les éléments requis sur tous les serveurs

Avant de pouvoir effectuer la mise à niveau, vous devez exécuter le programme d'installation des éléments requis sur chaque serveur Web où Windows SharePoint Services 3.0 est installé.

Étapes détaillées : Configuration requise pour l'installation dans l'article « Mise à niveau sur place de SharePoint Foundation 2010 ».

Effectuez cette étape pour chaque serveur Web de votre environnement.

[ ]

Détacher les bases de données (mise à niveau sur place avec bases de données détachées uniquement)

Si vous effectuez une mise à niveau sur place avec bases de données détachées, détachez ces dernières avant d'exécuter le programme d'installation.

Étapes détaillées : Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010).

Effectuez cette étape pour chaque base de données de contenu de votre environnement.

[ ]

Déconnecter des utilisateurs

Si vous procédez à la mise à niveau d'une batterie de serveurs, déconnectez tous les utilisateurs de la batterie de serveurs en arrêtant le service de publication World Wide Web (W3SVC) sur tous les serveurs Web.

Effectuez cette étape sur chaque serveur Web de votre environnement.

[ ]

Exécuter le programme d'installation sur tous les serveurs

Exécutez le programme d'installation sur tous les serveurs pour mettre à niveau le logiciel.

Étapes détaillées : Exécuter le programme d'installation sur tous les serveurs dans l'article « Mise à niveau sur place de SharePoint Foundation 2010 ».

Effectuez cette étape pour chaque serveur Web de votre environnement.

Cette étape peut durer quelques minutes ou plus d'une heure, en fonction du nombre de serveurs de votre environnement.

[ ]

Installer des modules linguistiques

Installez les modules linguistiques dont vous avez besoin avant d'exécuter l'Assistant Configuration des produits SharePoint.

Étapes détaillées : Installer les packs de modèles linguistiques disponibles (SharePoint Foundation 2010).

Effectuez cette étape sur chaque serveur Web de votre environnement.

Cette étape ne doit prendre que quelques minutes par serveur Web.

[ ]

Exécuter l'Assistant Configuration des produits SharePoint.

Si vous mettez à niveau une batterie de serveurs, exécutez d'abord l'Assistant Configuration des produits SharePoint sur le serveur qui exécute l'Administration centrale de SharePoint, effectuez une pause et lancez l'Assistant sur les autres serveurs de la batterie, puis revenez au premier serveur pour terminer le déroulement de l'Assistant.

Important :
Vous devez mettre à niveau l'Administration centrale de SharePoint avant de procéder à la mise à niveau de tout autre contenu dans la batterie de serveurs. C'est la raison pour laquelle il faut terminer le déroulement de l'Assistant sur le serveur qui exécute l'Administration centrale de SharePoint.

Étapes détaillées : Exécuter l'Assistant Configuration des produits SharePoint dans l'article « Mise à niveau sur place de SharePoint Foundation 2010 ».

Effectuez cette étape pour chaque serveur Web de votre environnement.

Cette étape peut durer au moins une heure.

[ ]

Configurer l'authentification par formulaire pour une application Web basée sur les revendications (mise à niveau sur place avec bases de données détachées uniquement)

Pour les applications Web configurées pour utiliser l'authentification par formulaire ou l'authentification unique Web, vous devez effectuer des étapes supplémentaires avant d'attacher et de mettre à niveau les bases de données. En premier lieu, convertissez les applications Web Windows SharePoint Services 3.0 pour utiliser l'authentification basée sur les revendications. Après avoir converti vos applications Web de sorte qu'elles utilisent l'authentification basée sur les revendications, configurez vos zones d'application Web pour l'authentification par formulaire (ou l'authentification unique Web, selon le cas). Vous pourrez ensuite faire migrer les utilisateurs et les autorisations vers SharePoint Foundation 2010.

Étapes détaillées : Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

Effectuez cette étape maintenant si vous suivez l'approche de la mise à niveau sur place avec bases de données détachées. Si vous suivez l'approche standard de la mise à niveau sur place, effectuez cette étape une fois la mise à niveau terminée.

Effectuez cette étape pour les applications Web qui utilisaient l'authentification par formulaire dans Windows SharePoint Services 3.0.

[ ]

Attacher les bases de données (mise à niveau sur place avec bases de données détachées uniquement)

Si vous effectuez une mise à niveau sur place avec bases de données détachées, attachez ces dernières, puis effectuez la mise à niveau des données.

Étapes détaillées : Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010).

Effectuez cette étape pour chaque base de données de contenu de votre environnement.

Cette étape peut durer une heure, plusieurs heures, voire plusieurs jours, en fonction de votre jeu de données, selon que vous effectuez la mise à niveau de plusieurs bases de données en parallèle, mais aussi en fonction du matériel des serveurs Web, des serveurs de bases de données et du sous-système de stockage.

[ ]

Surveiller la progression de la mise à niveau

Utilisez la page État de la mise à niveau dans l'Administration centrale de SharePoint pour surveiller la progression de la mise à niveau de vos sites.

Étapes détaillées : Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Effectuez cette étape une seule fois pour l'ensemble de l'environnement.

Cette étape peut durer une heure, plusieurs heures ou plusieurs jours, en fonction de votre jeu de données.

Effectuer les étapes postérieures à la mise à niveau

Effectuez les étapes suivantes dans l'ordre après une mise à niveau sur place.

Étapes postérieures à la mise à niveau pour une mise à niveau sur place Remarques

[ ]

Configurer l'authentification basée sur les formulaires pour une application Web basée sur les revendications

Pour les applications Web configurées pour utiliser l'authentification par formulaire ou l'authentification unique Web, vous devez effectuer des étapes supplémentaires après la mise à niveau. En premier lieu, convertissez les applications Web Windows SharePoint Services 3.0 pour utiliser l'authentification basée sur les revendications. Après avoir converti vos applications Web de sorte qu'elles utilisent l'authentification basée sur les revendications, configurez vos zones d'application Web pour l'authentification par formulaire (ou l'authentification unique Web, selon le cas). Vous pourrez ensuite faire migrer les utilisateurs et les autorisations vers SharePoint Foundation 2010.

Étapes détaillées : Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

Effectuez cette étape pour les applications Web qui utilisaient l'authentification par formulaire dans Windows SharePoint Services 3.0.

[ ]

Vérifier la mise à niveau et passer en revue les sites mis à niveau

Passez en revue les sites pour vous assurer qu'ils ont été mis à niveau correctement et qu'ils sont prêts à être montrés aux utilisateurs.

Étapes détaillées : Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Effectuez cette étape pour chaque application Web et collection de sites ayant fait l'objet d'une mise à niveau dans votre environnement.

Cette étape peut durer une heure, plusieurs heures ou plusieurs jours, en fonction de votre contenu.

Demandez également aux propriétaires de sites de passer en revue leurs sites et de signaler les problèmes éventuels.

Voir aussi

Autres ressources

Feuille de calcul relative à la mise à niveau des produits SharePoint 2010 (éventuellement en anglais)

Historique des modifications


Mise à niveau sur place de SharePoint Foundation 2010
Voir aussi

Lorsque vous effectuez une mise à niveau sur place de Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, les données de configuration de la batterie de serveurs et le contenu de la batterie de serveurs sont mis à niveau sur le matériel existant, dans un ordre fixe. Lorsque vous démarrez la mise à niveau sur place, le programme d'installation place le serveur Web en mode hors connexion et rend les sites Web indisponibles jusqu'à la fin de l'installation de la mise à niveau, puis il redémarre le serveur Web. Lorsque vous effectuez une mise à niveau sur place, vous ne pouvez ni suspendre la version précédente, ni la restaurer.

Remarque :
Une cause fréquente de défaillance lors des mises à niveau vient du fait que l'environnement ne dispose pas de fonctionnalités personnalisées, de solutions ou d'autres éléments. Assurez-vous que tous les éléments personnalisés requis sont installés sur vos serveurs Web frontaux avant de lancer le processus de mise à niveau. Vous pouvez utiliser l'outil de vérification préalable à la mise à niveau pour identifier les éléments personnalisés susceptibles d'être utilisés par vos sites. Pour plus d'informations, voir Identifier et installer les personnalisations dans l'article « Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels ».

La mise à niveau sur place d'une installation de Windows SharePoint Services 3.0 utilisant la base de données interne Windows dont la taille dépasse 4 Go nécessite des étapes supplémentaires. Pour plus d'informations, voir Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant).

Vous pouvez également utiliser les nombreuses procédures décrites dans cet article pour effectuer la mise à niveau par une approche hybride avec détachement des bases de données, dans laquelle vous mettez à niveau le serveur et l'infrastructure en place, puis pour mettre à niveau les bases de données de contenu, vous les détachez puis les rattachez en parallèle. Pour plus d'informations sur le détachement des bases de données, voir Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010). Pour plus d'informations sur le choix de la méthode de mise à niveau, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010) et Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Important :
Vous devez exécuter Windows SharePoint Services 3.0 avec Service Pack 2 (SP2) dans un environnement Windows Server 2008 64 bits pour pouvoir effectuer une mise à niveau sur place vers SharePoint Foundation 2010. Si vous vous trouvez dans un environnement de batterie de serveurs, vous devez également exécuter une version 64 bits de Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3.

Dans cet article :

  • Vue d'ensemble du processus

  • Avant de commencer

  • Configuration requise pour l'installation

  • Exécuter le programme d'installation sur tous les serveurs

  • Exécuter l'Assistant Configuration des produits SharePoint

  • Vérifier l'état de la mise à niveau pour les sites

  • Vérification

Vue d'ensemble du processus

Les procédures décrites dans cet article vous permettent d'installer SharePoint Foundation 2010 et de mettre à niveau tous les sites SharePoint de l'environnement. Il est recommandé de faire un essai du processus de mise à niveau dans un environnement de test avant de mettre à niveau votre environnement de production. Pour plus d'informations, voir Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010).

Lorsque vous mettez à niveau une batterie de serveurs, installez et configurez la nouvelle version sur les serveurs en procédant dans l'ordre suivant :

  1. Installez SharePoint Foundation 2010 sur tous les serveurs de la batterie de serveurs.

  2. Installez les modules linguistiques pour SharePoint Foundation 2010 dont vous avez besoin. Pour plus d'informations, voir Installer les packs de modèles linguistiques disponibles (SharePoint Foundation 2010).

  3. Exécutez l'Assistant Configuration des produits SharePoint sur le serveur Web frontal où se trouve le site Web Administration centrale de SharePoint.

    Pour déterminer quel serveur exécute l'Administration centrale de SharePoint, ouvrez la page Serveurs de la batterie (http://nom_serveur: port_admin/_admin/farmservers.aspx) et notez les serveurs sur lesquels les services Administration centrale sont en cours d'exécution. Effectuez cette étape avant d'installer SharePoint Foundation 2010, tant que l'Administration centrale de SharePoint pour Windows SharePoint Services 3.0 est encore disponible.

    Remarque :
    Si plusieurs serveurs exécutent l'Administration centrale de SharePoint, sélectionnez-en un et utilisez le serveur initial sur lequel exécuter la mise à niveau. Une fois le processus terminé sur ce serveur, vous pouvez continuer avec les autres serveurs exécutant l'Administration centrale de SharePoint.

  4. Exécutez l'Assistant Configuration des produits SharePoint sur les serveurs Web frontaux et les serveurs d'applications restants de la batterie, dans n'importe quel ordre.

Pour une vue d'ensemble et des schémas de chaque approche de la mise à niveau, voir Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Remarque :
Si vous utilisez une approche de mise à niveau hybride avec détachement des bases de données, le processus est similaire, mais vous détachez toutes les bases de données de contenu avant d'exécuter le programme d'installation, puis les rattachez après l'exécution de l'Assistant Configuration des produits SharePoint. Pour plus d'informations sur la méthode de mise à niveau avec détachement des bases de données, voir Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010).

Avant de commencer

Avant de commencer la mise à niveau sur place, passez en revue les informations suivantes relatives aux autorisations, aux configurations matérielle et logicielle requises et aux étapes à effectuer avant de démarrer le processus.

  • Pensez à exécuter l'outil de vérification préalable à la mise à niveau (stsadm -o preupgradecheck, disponible dans Windows SharePoint Services 3.0 Service Pack 2 et mis à jour par le biais de la Mise à jour cumulative d'octobre 2009) et à régler les éventuels problèmes avant de commencer le processus de mise à niveau. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

  • Il est recommandé de sauvegarder votre environnement avant de lancer la mise à niveau. Pour plus d'informations, voir Sauvegarder l'intégralité de l'environnement avant une mise à niveau sur place (SharePoint Foundation 2010).

  • Assurez-vous que toutes les conditions requises pour le matériel et les logiciels sont satisfaites. Vous devez avoir une version 64 bits de Windows Server 2008 ou de Windows Server 2008 R2. Pour les batteries de serveurs, vous devez aussi avoir une version 64 bits de SQL Server 2005 ou de SQL Server 2008. Pour plus d'informations sur ces conditions requises (telles que les mises à jour spécifiques à installer), voir Déterminer la configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  • Assurez-vous que vous êtes prêt à configurer les comptes requis avec les autorisations appropriées. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

  • Vérifiez que le compte que vous utilisez pour exécuter l'Assistant Configuration des produits SharePoint est membre du rôle de base de données fixe db_ownerpour toutes les bases de données que vous souhaitez mettre à niveau.

Configuration requise pour l'installation

Avant de pouvoir mettre à niveau, vous devez exécuter le programme d'installation de la configuration requise sur chaque serveur Web sur lequel Windows SharePoint Services 3.0 est installé. Un programme d'installation de la configuration requise est disponible pour installer les logiciels nécessaires à la prise en charge de SharePoint Foundation 2010.

Pour exécuter le programme d'installation de la configuration requise

  1. Sur le CD-ROM du produit, ouvrez le dossier d'installation et exécutez PrerequisiteInstaller.exe.

    L'Outil de préparation des produits Microsoft SharePoint s'ouvre.

  2. Cliquez sur Suivant.

  3. Dans la page Termes du contrat de licence, activez la case à cocher J'accepte les termes du contrat de licence, puis cliquez sur Suivant.

    L'outil est exécuté. Il installe et configure les logiciels requis.

  4. Cliquez sur Suivant.

  5. Dans l'écran Installation terminée, vérifiez que chaque élément prérequis est répertorié comme étant installé ou existant.

  6. Cliquez sur Terminer pour fermer l'Assistant.

Exécuter le programme d'installation sur tous les serveurs

Une fois que tous les éléments prérequis sont installés, vous pouvez exécuter le fichier Setup.exe sur tous les serveurs Web de la batterie de serveurs.

Remarque :
Si vous utilisez une approche de mise à niveau hybride avec détachement des bases de données, vous devez détacher vos bases de données de contenu avant d'exécuter le programme d'installation. Pour plus d'informations sur le détachement des bases de données, voir Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010).

Important :
Si vous procédez à la mise à niveau sur place d'une batterie de serveurs, déconnectez tous les utilisateurs de la batterie de serveurs en arrêtant le service de publication World Wide Web (W3SVC) sur tous les serveurs Web frontaux. Si vous autorisez les utilisateurs d'une batterie de serveurs à se connecter après la mise à jour des fichiers et des bases de données d'un serveur Web, mais avant que les autres serveurs Web soient mis à jour, les utilisateurs ne peuvent pas naviguer sur les sites Web.

Pour installer la nouvelle version

  1. Exécuter Setup.exe.

  2. Dans la page Lire les termes du contrat de licence logiciel Microsoft, passez en revue les termes, activez la case à cocher J'accepte les termes de ce contrat, puis cliquez sur Continuer.

  3. Dans la page des versions antérieures de mise à niveau, cliquez sur Installer maintenant.

  4. Le programme d'installation s'exécute et installe SharePoint Foundation 2010.

    Dans la dernière page, désactivez la case à cocher Exécuter l'Assistant Configuration des produits SharePoint, puis cliquez sur Fermer.

Avant d'exécuter l'Assistant Configuration des produits SharePoint, installez les packs de modèles linguistiques pour SharePoint Foundation 2010. Pour plus d'informations, voir Installer les packs de modèles linguistiques disponibles (SharePoint Foundation 2010).

Exécuter l'Assistant Configuration des produits SharePoint

Si vous mettez à niveau un seul serveur, vous pouvez exécuter l'Assistant Configuration des produits SharePoint sur ce serveur uniquement, puis commencer à mettre à niveau le contenu. Si vous mettez à niveau une batterie de serveurs, exécutez d'abord l'Assistant Configuration des produits SharePoint sur le serveur exécutant l'Administration centrale de SharePoint, mettez-le une pause et lancez l'Assistant sur les autres serveurs de la batterie, puis revenez au premier serveur pour terminer l'exécution de l'Assistant. Il est important de mettre à niveau l'Administration centrale de SharePoint avant de procéder à la mise à niveau de tout autre contenu dans la batterie de serveurs ; c'est la raison pour laquelle il faut terminer l'exécution de l'Assistant sur le serveur qui exécute l'Administration centrale de SharePoint.

Important :
Vérifiez que le compte que vous utilisez pour exécuter l'Assistant Configuration des produits SharePoint est membre du rôle de base de données fixe db_ownerpour toutes les bases de données que vous souhaitez mettre à niveau. Si cela n'est pas le cas, une erreur signalant un compte d'utilisateur inconnu risque de s'afficher lorsque l'Assistant démarre pour mettre à niveau les bases de données.

Assurez-vous que vous avez bien installé les packs de modèles linguistiques avant d'exécuter l'Assistant Configuration des produits SharePoint.

Attention :
Une fois que vous avez exécuté l'Assistant Configuration des produits SharePoint, Windows SharePoint Services 3.0 n'est plus disponible. Vous ne pouvez pas suspendre ou annuler le processus de configuration et de mise à niveau. Assurez-vous de disposer d'une sauvegarde actuelle et valide de l'environnement avant de poursuivre l'installation de SharePoint Foundation 2010.

Pour exécuter l'Assistant Configuration des produits SharePoint

  1. Cliquez sur Démarrer, pointez sur Tous les programmes puis sur Outils d'administration et cliquez sur Assistant Configuration des produits SharePoint.

  2. Dans l'Assistant Configuration des produits SharePoint, sur la page Bienvenue dans les produits SharePoint, cliquez sur Suivant.

    Un message s'affiche pour vous avertir qu'il est possible que vous deviez redémarrer ou réinitialiser les services Internet (IIS), les services d'administration SharePoint v4 et le service du minuteur SharePoint v4 au cours de la configuration.

  3. Cliquez sur Oui pour poursuivre l'exécution de l'Assistant.

  4. Dans la page qui permet de spécifier les paramètres de la batterie de serveurs, dans la zone Phrase secrète, tapez une phrase secrète et dans la zone Confirmer la phrase secrète, tapez la même phrase secrète.

    La phrase secrète doit comporter au moins huit caractères et inclure des caractères figurant dans au moins trois des quatre groupes de caractères suivants :

    • Majuscules (A à Z) de l'alphabet utilisé pour l'anglais

    • Minuscules (a à z) de l'alphabet utilisé pour l'anglais

    • Nombres (0 à 9)

    • Caractères non alphabétiques (!, $, #, %)

  5. Dans la page Mise à niveau visuelle, sélectionnez l'une des options suivantes :

    • Modifier les sites SharePoint existants pour profiter des derniers progrès réalisés dans le confort d'utilisation. Les administrateurs contrôlent le confort d'utilisation des utilisateurs

      Cette option permet de profiter de la nouvelle expérience utilisateur dans tous les sites, sans afficher d'aperçu de cette nouvelle expérience utilisateur. Si vous sélectionnez cette option, vous pouvez également choisir l'une des deux options suivantes :

      • Conserver les pages personnalisées, mais mettre à jour le modèle et les pages d'application pour utiliser la nouvelle interface utilisateur.

      • Restaurer toutes les pages personnalisées en fonction de leurs modèles d'origine. Cette option supprimera les modifications de pages personnalisées et ne peut pas être annulée.

    • Conserver l'apparence des sites SharePoint existants et permettre aux utilisateurs de mettre à jour leur expérience utilisateur de ces sites.

      Il s'agit de l'option par défaut. Cette option permet aux propriétaires de sites d'afficher un aperçu de leurs sites dans la nouvelle expérience utilisateur et de déterminer quand ils sont prêts à basculer définitivement les sites vers la nouvelle expérience utilisateur.

  6. Dans la page Fin de l'Assistant Configuration des produits SharePoint, vérifiez les paramètres, puis cliquez sur Suivant.

    L'Assistant Configuration des produits SharePoint s'exécute et configure la base de données de configuration et l'Administration centrale de SharePoint pour SharePoint Foundation 2010

  7. Un message s'affiche pour vous avertir que si vous disposez d'une batterie comportant plusieurs serveurs, vous devez exécuter le programme d'installation sur chacun d'entre eux pour installer de nouveaux fichiers binaires avant de poursuivre l'exécution de l'Assistant Configuration des produits SharePoint.

    • S'il s'agit de l'unique serveur de la batterie ou si vous avez déjà exécuté le programme d'installation sur tous les serveurs de la batterie, cliquez sur OK pour poursuivre l'exécution de l'Assistant.

    • Si vous n'avez pas encore exécuté le programme d'installation sur tous les serveurs de la batterie, exécutez-le sur les autres serveurs, puis revenez à ce serveur et cliquez sur OK pour poursuivre l'exécution de l'Assistant.

    L'Assistant Configuration des produits SharePoint continue le processus de mise à niveau en configurant la base de données de configuration et en installant l'Administration centrale de SharePoint.

  8. Dans la page Configuration réussie - Mise à niveau en cours, examinez les paramètres configurés, puis cliquez sur Terminer.

    L'Assistant Configuration des produits SharePoint se ferme et la page État de la mise à niveau s'ouvre. Vous pouvez être invité à entrer votre nom d'utilisateur et votre mot de passe avant l'ouverture de cette page. Le processus de mise à niveau peut prendre un certain temps, en fonction de la quantité de données stockées dans votre batterie de serveurs.

    Remarque :
    Si vous utilisez l'approche de mise à niveau hybride avec détachement des bases de données, vous pouvez maintenant commencer à attacher les bases de données de contenu afin de les mettre à niveau. Pour plus d'informations, voir Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010).

  9. Si vous mettez à niveau une batterie de serveurs, vous pouvez maintenant poursuivre l'exécution de l'Assistant Configuration des produits SharePoint sur les autres serveurs de la batterie.

Vérifier l'état de la mise à niveau pour les sites

Après la fin de l'Assistant Configuration des produits SharePoint, vous pouvez analyser la mise à niveau sur chaque site à partir de la page État de la mise à niveau dans l'Administration centrale de SharePoint ou en utilisant l'opération localupgradestatus dans Stsadm.exe. Pour plus d'informations, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010)

Une fois la mise à niveau effectuée pour tous les sites, si vous avez arrêté le service de publication World Wide Web (W3SVC) sur tous les serveurs Web frontaux avant la mise à niveau, démarrez manuellement le service de publication World Wide Web sur les serveurs Web frontaux pour que les serveurs Web soient disponibles pour tous les utilisateurs.

Remarque :
Les résultats de recherche risquent d'être incomplets ou ne pas être renvoyés pendant les quelques minutes qui suivent la mise à niveau. Ceci est dû au fait que le travail du minuteur de synchronisation de la recherche doit être exécuté après la mise à niveau : les résultats de recherche ne sont pas disponibles tant que ce travail n'est pas terminé.

Vérification

Si la mise à niveau échoue ou signale des problèmes, vous pouvez vous référer aux fichiers journaux et d'erreurs pour plus d'informations. Pour plus d'informations sur la consultation des fichiers journaux et sur le redémarrage de la mise à niveau après un incident, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010). Si vous utilisez la mise à niveau visuelle, pour plus d'informations sur l'aperçu des sites et la modification de la nouvelle interface utilisateur, voir Gérer une mise à niveau visuelle (SharePoint Foundation 2010).

Voir aussi

Concepts

Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010)

Historique des modifications


Introduction à la mise à niveau sur place avec bases de données détachées (SharePoint Foundation 2010)

Lorsque vous effectuez une mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, vous pouvez réaliser une mise à niveau sur place ou une mise à niveau avec liaison des bases de données, ou vous pouvez combiner certains aspects des deux méthodes pour accroître la disponibilité ou le débit pendant le processus de mise à niveau. Cet article explique comment utiliser une méthode hybride qui combine une mise à niveau sur place et le détachement et l'attachement de bases de données pour mettre à niveau plusieurs bases de données en même temps, éventuellement sur des supports matériels distincts. Vous pouvez utiliser cette méthode pour mettre à niveau deux bases de données de contenu ou plus à la fois, ce qui vous permet d'effectuer une mise à niveau plus rapidement que si vous recouriez à une mise à niveau sur place standard (qui met à niveau des bases de données de contenu et des collections de sites individuels en série). Cette méthode repose sur les techniques hybrides suivantes :

  • utilisation d'une mise à niveau sur place pour mettre à niveau la batterie de serveurs et les paramètres ;

  • détachement et mise à niveau de plusieurs bases de données en parallèle ;

  • autre séquence de mise à niveau possible : mise à niveau des bases de données sur une petite batterie de serveurs temporaire.

Notez que si vous décidez d'utiliser une petite batterie de serveurs temporaire pour effectuer la mise à niveau proprement dite, vous devez disposer d'un accès direct aux serveurs de base de données à partir desquels vous puissiez copier les bases de données. La copie des bases de données via le réseau est gourmande en temps et en bande passante : veillez à tester ce processus pour déterminer si vous disposez des ressources nécessaires à l'utilisation d'une petite batterie de serveurs temporaire.

Pour plus d'informations sur les avantages et les inconvénients des différentes méthodes de mise à niveau, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010). Pour une brève présentation et une description graphique des étapes de chaque méthode, voir Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Remarque :
Une cause fréquente des échecs de mise à niveau est le manque d'éléments personnalisés dans l'environnement, tels que des fonctionnalités ou des solutions personnalisées. Avant de commencer le processus de mise à niveau, vérifiez que tous les éléments personnalisés requis sont installés sur les serveurs Web frontaux. Vous pouvez utiliser l'outil d'analyse préalable à la mise à niveau et, dans le cas d'une mise à niveau avec liaison des bases de données, l'applet de commande Windows PowerShelltest-spcontentdatabase, pour identifier tous les éléments personnalisés éventuellement utilisés par vos sites. Pour plus d'informations, voir Identifier et installer les personnalisations dans l'article « Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels ».

Dans cet article :

  • Vue d'ensemble du processus

  • Avant de commencer

  • Pour détacher des bases de données et les mettre à niveau en parallèle sur la même batterie de serveurs

  • Pour détacher des bases de données et les mettre à niveau en parallèle sur une petite batterie de serveurs temporaire

  • Vérification

Important :
Vous devez exécuter Windows SharePoint Services 3.0 Service Pack 2 (SP2) dans un environnement Windows Server 2008 64 bits pour effectuer une mise à niveau sur place vers SharePoint Foundation 2010. Dans le cas d'un environnement de batterie de serveurs, vous devez également exécuter une version 64 bits d'un des produits suivants : Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3.

Vue d'ensemble du processus

Étant donné que cette méthode de mise à niveau est une combinaison des techniques utilisées dans la mise à niveau sur place et dans la mise à niveau avec liaison des bases de données, cet article explique comment les étapes de chaque méthode s'articulent pour former le processus hybride. Il ne fournit pas de détails sur chaque étape du processus, car ces étapes sont décrites dans les articles suivants :

  • Mise à niveau sur place de SharePoint Foundation 2010

  • Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010

Ces articles, combinés à cette feuille de route, fournissent les informations dont vous avez besoin pour réaliser cette mise à niveau hybride.

Vous pouvez effectuer ce type de mise à niveau hybride de deux façons : en utilisant une seule batterie de serveurs pendant toute la durée de l'opération ou en utilisant une petite batterie de serveurs temporaire pour effectuer la mise à niveau proprement dite. Les sections ci-après indiquent les étapes à suivre pour effectuer la mise à niveau à l'aide de chacune de ces méthodes.

Avant de commencer

Avant de commencer la mise à niveau sur place, passez en revue les informations suivantes relatives aux autorisations, aux configurations matérielle et logicielle requises et aux étapes à effectuer avant de démarrer le processus.

  • Veillez à exécuter l'outil de vérification de pré-mise à niveau (stsadm -o preupgradecheck, disponible dans Windows SharePoint Services 3.0 Service Pack 2 et mis à jour dans la mise à jour cumulative d'octobre 2009) et à régler les éventuels problèmes avant de commencer le processus de mise à niveau. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

  • Il est recommandé de sauvegarder votre environnement avant de lancer la mise à niveau. Pour plus d'informations, voir Sauvegarder l'intégralité de l'environnement avant une mise à niveau sur place (SharePoint Foundation 2010).

  • Assurez-vous que toutes les conditions requises pour le matériel et les logiciels sont satisfaites. Vous devez avoir une version 64 bits de Windows Server 2008 ou de Windows Server 2008 R2. Pour les batteries de serveurs, vous devez aussi avoir une version 64 bits de SQL Server 2005 ou de SQL Server 2008. Pour plus d'informations sur ces conditions requises (telles que les mises à jour spécifiques à installer), voir Déterminer la configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  • Assurez-vous que vous êtes prêt à configurer les comptes requis avec les autorisations appropriées. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

Pour détacher des bases de données et les mettre à niveau en parallèle sur la même batterie de serveurs

Cette section décrit les étapes à suivre pour utiliser la méthode de mise à niveau avec détachement des bases de données sur une même batterie de serveurs.

Processus de mise à niveau sur place avec bases de données détachées (même batterie de serveurs)

Détacher des bases de données

  1. Utilisez l'opération suivante pour détacher les bases de données de contenu :

    Stsadm.exe -o deletecontentdb -url http://servername -nom_base_de_données ContentDatabaseName

    Pour plus d'informations sur cette opération, voir Deletecontentdb : opération Stsadm (Windows SharePoint Services).

Mettre à niveau la batterie de serveurs sur place

  1. Installer tous les éléments prérequis sur tous les serveurs de la batterie.

  2. Exécutez le programme d'installation sur tous les serveurs de la batterie.

  3. Exécutez l'Assistant Configuration des produits SharePoint sur tous les serveurs de la batterie.

Pour les procédures détaillées décrivant ces étapes, voir Mise à niveau sur place de SharePoint Foundation 2010.

Attacher les bases de données et mettre à niveau le contenu

  1. Ajoutez les bases de données de contenu aux applications Web.

    Utilisez l'applet de commande Windows PowerShell suivant pour ajouter et mettre à jour les bases de données de contenu :

    Code de copie
    Mount-SPContentDatabase -Name <DatabaseName> -DatabaseServer <ServerName> -WebApplication <URL> [-Updateuserexperience]
  2. Vérifiez la mise à niveau pour la première base de données.

  3. Répétez les procédures de restauration et d'ajout de base de données pour les autres bases de données en parallèle.

Pour les procédures détaillées décrivant ces étapes, voir Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010.

Pour détacher des bases de données et les mettre à niveau en parallèle sur une petite batterie de serveurs temporaire

Cette section décrit les étapes à suivre pour utiliser la méthode de mise à niveau avec détachement des bases de données sur deux batteries de serveurs : la batterie de serveurs d'origine et une petite batterie de serveurs temporaire.

Processus de mise à niveau sur place avec bases de données détachées (petite batterie de serveurs temporaire)

Configurer une petite batterie de serveurs temporaire à utiliser dans le cadre de la mise à niveau des bases de données

Pour connaître en détail les procédures décrivant ces étapes, voir Préparer le nouvel environnement SharePoint Foundation.

2 : détacher les bases de données de la batterie de serveurs d'origine

  1. Sauvegardez les bases de données disponibles dans la version précédente à l'aide des outils SQL Server.

    Pour des procédures détaillées sur la sauvegarde des bases de données, voir Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010.

  2. Utilisez l'opération suivante pour détacher les bases de données de contenu :

    Stsadm.exe -o deletecontentdb -url http://servername -nom_base_de_données ContentDatabaseName

    Pour plus d'informations sur cette opération, voir Deletecontentdb : opération Stsadm (Windows SharePoint Services).

Mettre à niveau la batterie de serveurs d'origine sur place

  1. Installez tous les éléments prérequis sur tous les serveurs de la batterie.

  2. Exécutez le programme d'installation sur tous les serveurs de la batterie.

  3. Exécutez l'Assistant Configuration des produits SharePoint sur tous les serveurs de la batterie.

Pour les procédures détaillées décrivant ces étapes, voir Effectuer une mise à niveau sur place (SharePoint Foundation 2010).

Attacher les bases de données à la petite batterie de serveurs temporaire et mettre à niveau le contenu

  1. Restaurez la copie de sauvegarde dans la nouvelle batterie de serveurs.

  2. Ajoutez les bases de données de contenu aux applications Web.

    Utilisez l'opération Windows PowerShell cmdlet pour ajouter et mettre à jour les bases de données de contenu :

    Code de copie
    Mount-SPContentDatabase -Name <DatabaseName> -DatabaseServer <ServerName> -WebApplication <URL> [-Updateuserexperience]
  3. Vérifiez la mise à niveau pour la première base de données.

  4. Répétez les procédures de restauration et d'ajout de base de données pour les autres bases de données en parallèle.

Pour les procédures détaillées décrivant ces étapes, voir Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010.

Sauvegarder les bases de données à partir de la petite batterie de serveurs temporaire et les attacher à la batterie de serveurs d'origine

  1. Sauvegardez les bases de données mises à niveau à l'aide des outils SQL Server.

  2. Restaurez la copie de sauvegarde dans la batterie de serveurs d'origine.

  3. Ajoutez les bases de données de contenu mises à niveau aux applications Web d'origine.

Il s'agit fondamentalement du même processus que celui de l'étape précédente ; toutefois, vous déplacez les bases de données depuis la petite batterie de serveurs temporaire vers la batterie de serveurs d'origine. Il est fait appel aux mêmes procédures qu'aux étapes précédentes.

Vérification

Si la mise à niveau échoue ou signale des problèmes, vous pouvez vous référer aux fichiers journaux et d'erreurs pour plus d'informations. Pour plus d'informations sur la consultation des fichiers journaux, et sur le redémarrage de la mise à niveau après un échec, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Historique des modifications


Installer les packs de modèles linguistiques disponibles (SharePoint Foundation 2010)
Voir aussi

Avant de mettre à niveau tous les sites basés sur un module linguistique pour la version précédente, vous devez installer le module linguistique pour la nouvelle version.

Dans cet article :

  • À propos de l'installation des modules linguistiques et de la mise à niveau des sites

  • À propos du changement de langue

  • Passage d'un produit totalement localisé à un module linguistique

  • Changement de langue par le biais d'un nouveau module linguistique

À propos de l'installation des modules linguistiques et de la mise à niveau des sites

Si vous souhaitez installer un module linguistique pour Microsoft SharePoint Foundation 2010, effectuez l'opération après avoir exécuté le programme d'installation et avant d'exécuter l'Assistant Configuration des produits SharePoint. De cette manière, vous pouvez effectuer une mise à niveau de tous les sites basés sur un module linguistique pour une version précédente ainsi que des autres sites au cours du processus de mise à niveau. Pour plus d'informations sur l'installation des modules linguistiques, voir Déployer des modules linguistiques (SharePoint Foundation 2010) dans le Guide de déploiement.

Vous pouvez également installer un module linguistique après avoir exécuté l'Assistant Configuration des produits SharePoint et après avoir mis à niveau les sites de votre environnement qui ne sont pas basés sur un module linguistique. Si vous choisissez cette option, vous devez utiliser l'outil en ligne de commande PSConfig pour mettre à niveau les sites basés sur le module linguistique nouvellement installé.

À propos du changement de langue

En règle générale, la mise à niveau avec changement de langue n'est pas prise en charge. Vous devez effectuer la mise à niveau depuis et vers la même langue. Par exemple, si la langue utilisée est Anglais (États-Unis) dans la version antérieure, vous devez effectuer la mise à niveau vers Anglais (États-Unis) dans la nouvelle version. Si vous souhaitez changer de langue, vous devez d'abord effectuer la mise à niveau, puis changer la langue associée au site.

Toutefois, ce processus est complexe dans certains cas, par exemple lorsque la version précédente d'un produit était entièrement localisée dans une langue particulière alors que la nouvelle version ne bénéficie que d'un module linguistique, ou lorsque la nouvelle version bénéficie d'un module linguistique pour une nouvelle langue qui n'était pas disponible dans la version antérieure.

Passage d'un produit totalement localisé à un module linguistique

Utilisez la procédure suivante pour effectuer sur chaque serveur une mise à niveau depuis une langue qui était prise en charge avec un produit totalement localisé dans la version précédente, mais qui n'est prise en charge que par un module linguistique dans la nouvelle version :

Pour passer d'un produit totalement localisé à un module linguistique

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Choisissez la langue d'installation de la nouvelle version (par exemple le français). Il s'agit de la langue que le site Web Administration centrale de SharePoint utilisera.

  3. Dans l'Assistant Configuration des produits SharePoint, lorsque vous êtes invité à installer les modules linguistiques, arrêtez l'Assistant et installez le module linguistique approprié.

    Si des modules linguistiques de version antérieure étaient déjà installés, installez les modules linguistiques SharePoint Foundation 2010 correspondants maintenant en annulant l'Assistant, puis en exécutant les programmes d'installation appropriés.

    Remarque :
    Vous devez être membre du groupe Administrateurs sur l'ordinateur local pour effectuer cette étape.

    Pour plus d'informations sur l'installation des modules linguistiques, voir Déployer des modules linguistiques (SharePoint Foundation 2010) dans le Guide de déploiement.

  4. Démarrez l'Assistant Configuration pour terminer la mise à niveau.

Changement de langue par le biais d'un nouveau module linguistique

Utilisez la procédure suivante pour effectuer une mise à niveau depuis une langue dans la version antérieure vers une autre langue dans la nouvelle version (par exemple, si la langue souhaitée n'était pas disponible dans la version précédente, mais qu'elle est maintenant disponible sous la forme d'un module linguistique dans la nouvelle version).

Pour changer de langue par le biais d'un nouveau module linguistique

  1. Vérifiez que le compte d'utilisateur qui exécute les deux étapes suivantes est membre du groupe Administrateurs sur l'ordinateur local.

  2. Effectuez la mise à niveau vers la nouvelle version dans la langue que vous avez utilisée pour la version précédente.

  3. Lorsque la mise à niveau est terminée, installez le nouveau module linguistique.

  4. Vérifiez que le compte d'utilisateur qui exécute les deux étapes suivantes est membre du groupe Administrateurs de batterie SharePoint.

  5. Créez de nouveaux sites basés sur le nouveau module linguistique.

  6. Déplacez manuellement le contenu vers les nouveaux sites.

Voir aussi

Concepts

Déployer des modules linguistiques (SharePoint Foundation 2010)

Historique des modifications


Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant)
Voir aussi

Cet article décrit les circonstances dans lesquelles vous pouvez effectuer une mise à niveau depuis un système Windows SharePoint Services 3.0 autonome vers SharePoint Foundation 2010 avec le stockage BLOB distant (RBS, Remote BLOB Storage).

Lorsque vous effectuez une mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, le processus de mise à niveau diffère suivant la taille des bases de données.

Dans une installation autonome de Windows SharePoint Services 3.0, les bases de données de contenu sont stockées dans la base de données interne Windows et ne sont soumises à aucune limitation de taille. À l'inverse, dans SharePoint Foundation 2010, les bases de données de contenu sont stockées dans Microsoft SQL Server 2008 Express et leur taille est limitée à 4 gigaoctets (Go) chacune. Si des bases de données présentent une taille supérieure à 4 Go, vous devez utiliser Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3 ou installer le stockage BLOB distant.

Remarque :
Microsoft SQL Server 2008 R2 Express prend en charge les bases de données dont la taille ne dépasse pas 10 Go. Si l'installation inclut des bases de données dont la taille est supérieure à 4 Go mais inférieure à 10 Go, vous pouvez effectuer une mise à niveau vers SQL Server 2008 R2 Express pour votre solution de stockage de base de données de contenu au lieu d'implémenter RBS. SQL Server 2008 R2 Express peut être téléchargé et installé à partir de l'adresse http://go.microsoft.com/fwlink/?linkid=168472&clcid=0x40C.

RBS est conçu pour déplacer le stockage des objets BLOB (Binary Large Objects) depuis des serveurs de bases de données vers des solutions de stockage de produits. RBS est un complément applicable à SQL Server 2008 Express et à SQL Server 2008. Pour plus d'informations sur RBS, voir Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010).

Si vous effectuez une mise à niveau depuis Windows SharePoint Services 3.0 et que toutes les bases de données présentent une taille inférieure à 4 Go, vous pouvez suivre le processus de mise à niveau sur place standard. Pour plus d'informations, voir Mise à niveau sur place de SharePoint Foundation 2010.

Si vous effectuez une mise à niveau de Windows SharePoint Services 3.0 et que la base de données de recherche fait plus de 4 Go, vous ne pouvez pas migrer cette base de données. Pour effectuer la mise à niveau, vous devez supprimer l'instance de recherche existante avant la migration et la mise à niveau. Après la mise à niveau, vous pouvez créer une nouvelle instance de recherche. La base de données de recherche est limitée à 4 Go si la nouvelle installation est hébergée sur SQL Server 2008 Express.

Si vous effectuez une mise à niveau depuis Windows SharePoint Services 3.0 et que la taille de la base de données de configuration est supérieure à 4 Go, vous ne pouvez pas migrer la base de données de configuration. À la place, vous devez créer un nouveau système SharePoint Foundation qui utilise SQL Server 2008 Express (si la base de données de configuration n'est pas censée croître au-delà de 4 Go) ou créer une nouvelle installation qui utilise SQL Server 2008 Standard ou SQL Server 2008 Enterprise. Vous pouvez également migrer le système existant vers SQL Server 2008 Standard ou SQL Server 2008 Enterprise, puis le mettre à niveau.

Si vous ne mettez pas à niveau un système Windows SharePoint Services 3.0 existant et que vous souhaitez installer et configurer RBS dans SharePoint Foundation 2010, voir Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010).

Remarque :
Si, après le déplacement du contenu dans le stockage BLOB distant, une base de données de contenu présente une taille supérieure à 4 Go, l'opération de migration échoue. En règle générale, cet échec ne se produit qu'avec des bases de données très volumineuses (20 Go ou plus), mais il peut également se produire en présence d'une base de données plus petite contenant une trop grande quantité de métadonnées.

Si la configuration comprend des bases de données SharePoint dont la taille est supérieure à 16 Go, il est peu probable que RBS offre une solution complète aux limitations de SQL Server 2008 Express et SQL Server 2008 R2 Express. Dans ce cas, vous devez envisager le recours à SQL Server 2008 Standard ou SQL Server 2008 Enterprise pour la prise en charge des bases de données SharePoint.

Avant de commencer le processus de mise à niveau, vérifiez que la configuration matérielle prend en charge SharePoint Foundation 2010. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

Dans cette section

  • Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec stockage BLOB distant

    Cet article explique comment effectuer une mise à niveau depuis un système Windows SharePoint Services 3.0 autonome comportant des bases de données de contenu dont la taille est supérieure à 4 Go vers SharePoint Foundation 2010.

  • Mettre à niveau une installation autonome sur un contrôleur de domaine à l'aide de RBS (Remote BLOB Storage) (liaison de bases de données)

    Cet article explique comment effectuer une mise à niveau depuis un système Windows SharePoint Services 3.0 autonome comportant des bases de données de contenu dont la taille est supérieure à 4 Go vers un système SharePoint Foundation 2010 qui s'exécute sur un contrôleur de domaine.

  • Mettre à niveau une installation autonome vers une nouvelle configuration matérielle à l'aide du stockage BLOB distant (attachement de base de données)

    Cet article explique comment effectuer une mise à niveau depuis un système Windows SharePoint Services 3.0 autonome comportant des bases de données de contenu dont la taille est supérieure à 4 Go vers SharePoint Foundation 2010, qui est installé sur un nouveau matériel.

Voir aussi

Concepts

Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010)


Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec stockage BLOB distant
Voir aussi

Cet article explique comment effectuer une mise à niveau depuis un système Windows SharePoint Services 3.0 autonome comportant des bases de données de contenu dont la taille est comprise entre 4 et 16 gigaoctets (Go) vers Microsoft SharePoint Foundation 2010 avec le stockage BLOB distant (RBS, Remote BLOB Storage).

Remarque :
Microsoft SQL Server 2008 R2 Express prend en charge les bases de données dont la taille est inférieure ou égale à 10 Go. Si l'installation comprend des bases de données de contenu dont la taille est comprise entre 4 Go et 10 Go, vous pouvez effectuer une mise à niveau vers SQL Server 2008 R2 Express pour votre solution de stockage de base de données de contenu au lieu d'implémenter le stockage RBS. Pour plus d'informations, voir Microsoft SQL Server 2008 R2 Express Edition (http://go.microsoft.com/fwlink/?linkid=189418&clcid=0x40C).

Avant d'effectuer les opérations décrites dans cet article, nous vous recommandons vivement de lire les articles suivants pour vous assurer de suivre le meilleur itinéraire de mise à niveau :

  • Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010)

  • Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010)

  • Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant)

Pour effectuer une mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec RBS

  1. Vérifiez que le compte d'utilisateur utilisé pour la mise à niveau et l'installation est membre du groupe Administrateurs sur l'ordinateur exécutant Windows SharePoint Services 3.0 sur lequel la mise à niveau est en cours de réalisation et RBS est en cours d'installation.

  2. Vérifiez que la configuration matérielle prend en charge SharePoint Foundation 2010. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  3. Vérifiez que l'espace disque disponible satisfait aux conditions suivantes :

    • Sa taille est au moins le double de celle de la base de données de contenu la plus volumineuse.

    • Sa taille est supérieure ou égale à la somme des tailles de toutes les bases de données de contenu.

  4. Téléchargez les mises à jour logicielles SharePoint Foundation 2010 à partir du site de mise à niveau.

  5. Ouvrez le dossier local qui contient le téléchargement de logiciels, puis double-cliquez sur PrerequisiteInstaller. Acceptez les valeurs par défaut, puis exécutez l'Assistant d'installation des éléments prérequis.

  6. Double-cliquez sur Installation, acceptez les valeurs par défaut, puis exécutez l'Assistant Installation.

    Au terme de l'installation, l'Assistant Configuration des produits SharePoint s'exécute automatiquement. S'il détecte une base de données SharePoint dont la taille est supérieure à 4 Go, un message apparaît pour vous signaler que vous devez migrer les bases de données vers le stockage RBS.

    Remarque :
    Si une base de données SharePoint présente une taille supérieure à 4 Go, toutes les bases de données SharePoint doivent être migrées vers RBS, même si certaines ont une taille inférieure à 4 Go.

  7. Si vous n'avez pas déjà installé RBS sur le serveur, l'Assistant Configuration des produits SharePoint échoue, puis affiche un message d'erreur qui explique que des bases de données dont la taille est supérieure à 4 Go ont été détectées et que RBS doit être installé. Si vous devez installer RBS, passez aux étapes suivantes. Si vous avez déjà installé RBS sur le serveur, l'Assistant prend fin correctement sans afficher le message d'erreur.

  8. Accédez à la page http://go.microsoft.com/fwlink/?linkid=177388&clcid=0x40C pour télécharger le fichier RBS_X64.msi.

    Important :
    Vous devez installer la version du stockage RBS fournie avec le Package d'installation SQL Server Remote BLOB Store du Feature Pack pour Microsoft SQL Server 2008 R2. La version du stockage RBS doit être 10.50.xxx. Aucune version antérieure du stockage RBS n'est prise en charge pour SharePoint Foundation 2010.

  9. Ouvrez le dossier qui contient le fichier, puis double-cliquez sur RBS_X64.msi pour démarrer l'Assistant d'installation du stockage BLOB distant SQL.

  10. Dans l'Assistant d'installation du stockage BLOB distant SQL, dans la page Sélection de fonctionnalité, développez Serveur, cliquez sur la flèche vers le bas en regard de l'option Exécuter les scripts, puis cliquez sur La fonctionnalité entière ne sera pas disponibleCe composant ne sera pas disponible en totalitéCette fonctionnalité ne sera pas disponible en totalitéCe composant ne sera pas disponible.

  11. Développez FILESTREAM Provider, développez Serveur, cliquez sur la flèche vers le bas en regard de l'option Exécuter les scripts, puis cliquez sur La fonctionnalité entière ne sera pas disponibleCe composant ne sera pas disponible en totalitéCette fonctionnalité ne sera pas disponible en totalitéCe composant ne sera pas disponible.

  12. Terminez l'Assistant en utilisant les valeurs par défaut.

  13. Cliquez successivement sur Démarrer, Tous les programmes, Microsoft SharePoint 2010 Products, puis Assistant Configuration des produits SharePoint 2010.

  14. L'Assistant termine la mise à niveau.

Voir aussi

Concepts

Nouveautés de la mise à niveau (SharePoint Foundation 2010)
Présentation du processus de mise à niveau (SharePoint Foundation 2010)

Historique des modifications


Mettre à niveau une installation autonome sur un contrôleur de domaine à l'aide de RBS (Remote BLOB Storage) (liaison de bases de données)
Voir aussi

Cet article explique les procédures de mise à niveau requises pour procéder à une mise à niveau d'un système Windows SharePoint Services 3.0 autonome qui s'exécute sur un contrôleur de domaine vers Microsoft SharePoint Foundation 2010 avec RBS (Remote BLOB Storage). Nous recommandons généralement d'utiliser RBS si les bases de données de contenu ont une taille de 4 giga-octets (Go) ou plus.

Important :
Nous recommandons instamment la lecture de l'article Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant) qui contient des informations et des recommandations importantes sur la procédure de mise à niveau de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec RBS.

Vous pouvez utiliser RBS pour déplacer le stockage des objets BLOB (Binary Large Objects) depuis des serveurs de bases de données vers des solutions de stockage de produits. RBS est un complément pouvant être appliqué à SQL Server 2008 Express et à SQL Server 2008.

L'implémentation de RBS qui est expliquée dans cet article utilise le fournisseur FILESTREAM de SQL Server. Pour plus d'informations sur RBS et le fournisseur FILESTREAM, voir Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010).

Dans SharePoint Foundation 2010, les bases de données de contenu sont stockées dans SQL Server 2008 Express et ont une taille maximale de 4 Go par base de données. Comme Microsoft SQL Server 2008 R2 Express prend en charge les bases de données de contenu pouvant atteindre une taille de 10 Go, nous recommandons d'installer SQL Server 2008 R2 Express pour prendre en charge les bases de données de contenu.

Cet article ne constitue pas un guide complet de la mise à niveau vers SharePoint Foundation 2010. Il fait plutôt référence aux articles qu'il convient de lire pour effectuer cette mise à niveau. Cet article contient les étapes supplémentaires qui sont requises pour installer et implémenter RBS sur une installation de contrôleur de domaine de SharePoint Foundation 2010.

Avant de commencer le processus de mise à niveau, lisez les articles suivants et créez un plan de mise à niveau :

  • À propos du processus de mise à niveau (SharePoint Foundation 2010)

  • Planifier et préparer la mise à niveau (SharePoint Foundation 2010)

  • Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant)

Procédures dans cet article :

  • Pour préparer la mise à niveau vers SharePoint Foundation 2010 avec RBS sur un contrôleur de domaine

  • Pour installer SQL Server 2008 Express R2

  • Pour installer RBS

  • Pour installer SharePoint Foundation 2010

  • Pour installer SharePoint Foundation 2010

Pour préparer la mise à niveau vers SharePoint Foundation 2010 avec RBS sur un contrôleur de domaine

  1. Vérifiez que le compte d'utilisateur qui est employé pour effectuer la mise à niveau et l'installation est doté de la configuration requise indiquée dans Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

  2. Vérifiez que le compte d'utilisateur est membre du groupe Administrateur sur l'ordinateur local.

  3. Confirmez que la configuration matérielle prend en charge SharePoint Foundation 2010. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  4. Vérifiez que l'espace disque disponible remplit les conditions suivantes :

    • Sa taille est au moins le double de celle de la base de données de contenu la plus volumineuse.

    • Sa taille est supérieure ou égale à la somme des tailles de toutes les bases de données de contenu.

  5. Effectuez les tâches préalables à la mise à niveau décrites dans l'article Effectuer les étapes préalables à la mise à niveau (SharePoint Foundation 2010). Elle comprennent notamment :

    • Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010)

      Le rapport de l'outil de vérification préalable à la mise à niveau inclut les noms de toutes les bases de données de contenu. Vous aurez besoin de cette liste pour activer RBS pour les bases de données de contenu.

      Si vous avez plusieurs applications Web, vous devez compiler une liste indiquant quelles bases de données de contenu sont attachées aux diverses applications Web. Vous aurez besoin de ces informations après la mise à niveau.

    • Sauvegarder l'intégralité de l'environnement avant une mise à niveau sur place (SharePoint Foundation 2010)

Pour installer SQL Server 2008 Express R2

  1. Téléchargez SQL Server 2008 R2 Express à partir du site.

  2. Suivez les instructions affichées pour installer SQL Server 2008 R2 Express sur le contrôleur de domaine.

    Pour plus d'informations sur l'installation de SQL Server 2008 R2 Express, voir Procédure : installer SQL Server 2008 (installation) (http://go.microsoft.com/fwlink/?linkid=186119&clcid=0x40C).

    Acceptez les paramètres par défaut pour la plupart des options d'installation. Vous devez spécifiquement accepter les options suivantes :

    1. Dans la page Sélection de fonctionnalités, vous pouvez sélectionner les composants pour l'installation. Veillez à sélectionner SQL Server Management Studio comme fonctionnalité à installer.

    2. Dans la page Configuration de l'instance, spécifiez s'il convient d'installer une instance par défaut ou une instance nommée. Si vous créez une instance nommée, notez le nom de l'instance nommée car vous aurez besoin de ce nom dans une procédure ultérieure dans cet article.

    3. Dans la page Configuration du serveur — Comptes de service, vous devez spécifier les comptes de connexion pour les services SQL Server. Vous pouvez affecter le même compte de connexion à tous les services SQL Server, ou vous pouvez configurer chaque compte de service individuellement. Vous pouvez utiliser un compte de domaine comme compte de connexion pour le moteur de base de données SQL Server.

    4. Dans la page Configuration du moteur de base de données, vérifiez que le compte de domaine qui est utilisé pour cette installation est indiqué comme administrateur SQL Server.

Pour installer RBS

  1. Accédez à la page http://go.microsoft.com/fwlink/?linkid=168472&clcid=0x40C et téléchargez le fichier RBS_X64.msi.

    Important :
    Vous devez installer la version de RBS qui êtes incluse dans le Package d'installation SQL Server Remote BLOB Store du Feature Pack pour Microsoft SQL Server 2008 R2. La version de RBS doit être 10.50.xxx. Aucune version antérieure de RBS n'est prise en charge pour SharePoint Foundation 2010.

  2. Ouvrez le dossier qui contient le fichier, puis double-cliquez sur RBS_X64.msi pour démarrer l'Assistant d'installation du stockage BLOB distant SQL.

  3. Dans l'Assistant d'installation du stockage BLOB distant SQL, dans la page Sélection de fonctionnalité, développez Serveur, cliquez sur la flèche vers le bas en regard de l'option Exécuter les scripts, puis cliquez sur Ce composant ne sera pas disponible en totalité.

  4. Développez Fournisseur FILESTREAM, développez Serveur, cliquez sur la flèche bas en regard de Exécuter les scripts, puis cliquez sur Ce composant ne sera pas disponible en totalité.

    Remarque :
    La base de données qui hébergera les scripts n'existe pas car elle sera créée pendant le processus de mise à niveau de la base de données. L'option Exécuter les scripts sera installée automatiquement pendant l'installation de SharePoint Foundation 2010.

  5. Terminez l'Assistant en utilisant les valeurs par défaut.

    Pendant l'installation, une boîte de dialogue apparaît et décrit une tâche de gestion RBS. Cliquez sur OK dans cette boîte de dialogue pour poursuivre l'installation.

Pour installer SharePoint Foundation 2010

  1. Désinstallez toutes les versions précédentes des produits et technologies SharePoint qui existaient sur le contrôleur de domaine en utilisant le Panneau de configuration.

  2. Installez SharePoint Foundation 2010 en suivant les instructions dans Installer SharePoint Foundation 2010 sur les serveurs de la batterie de serveurs. Pendant l'installation, vous devez utiliser le nom de l'instance de base de données que vous avez créée à l'étape 2 de la procédure Pour installer SQL Server 2008 Express R2. Si vous avez utilisé l'instance nommée par défaut dans cette étape, vous devez l'entrer dans cette étape sous la forme « SQLExpress ». Si vous avez utilisé l'instance par défaut, vous devez taper « » ici au lieu d'utiliser l'instance nommée par défaut SQLExpress.

    Notez que vous créez une nouvelle installation de SharePoint Foundation 2010. Vous effectuez une mise à niveau par liaison de bases de données et non une mise à niveau sur place.

    Remarque :
    Une fois que vous avez installé SharePoint Foundation 2010, ne créez pas d'application Web avant d'y être invité ultérieurement dans cet article.

Pour migrer la base de données de contenu vers RBS et terminer l'installation

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est le même que celui qui a servi à installer la batterie de serveurs qui exécute SharePoint Foundation 2010 et RBS.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour migrer la base de données de contenu vers RBS :

    Code de copie
    Move-SPBlobStorageLocation -SourceDatabase "<ContentDbName>" -DestinationDataSourceInstance "<InstanceName>"

    Où :

    • <ContentDbName> est le nom de la base de données de contenu.

    • <InstanceName> est le nom de l'instance de base de données SQL Server que vous avez créée à l'étape 2 de la procédure Pour installer SQL Server 2008 Express R2. Si vous avez utilisé l'instance nommée par défaut dans cette étape, vous devez l'entrer ici sous la forme "SQLExpress". Si vous avez utilisé l'instance par défaut, vous devez taper " " ici au lieu d'utiliser le nom d'instance par défaut "SQLExpress".

    Vous devez répéter cette commande pour chaque base de données de contenu. Reportez-vous à la liste de bases de données de contenu qui a été générée par l'outil de vérification préalable à la mise à niveau à l'étape 5 de la procédure Pour préparer la mise à niveau vers SharePoint Foundation 2010 avec RBS sur un contrôleur de domaine plus haut dans cet article.

  6. Créez les applications Web auxquelles les bases de données de contenu seront liées. Pour plus d'informations sur la création d'une application Web dans SharePoint Foundation 2010, voir Créer une application Web (SharePoint Foundation 2010) ou Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010).

  7. Pour mettre à jour et mettre à niveau la base de données de contenu vers une application Web SharePoint Foundation 2010, tapez la commande suivante :

    Code de copie
    Mount-SPContentDatabase "<ContentDbName>" -DatabaseServer "<DbServer>" -WebApplication <http://SiteName>

    Où :

    • <ContentDbName> est le nom de la base de données.

    • <DbServer> est le nom du serveur de bases de données.

    • <http://SiteName> est l'URL de l'application Web.

    Pour plus d'informations, voir Move-SPBlobStorageLocation et Mount-SPContentDatabase.

  8. Créez ou restaurez les personnalisations requises sur le nouveau système. Pour des étapes postérieures à la mise à niveau, voir Effectuer les étapes postérieures à la mise à niveau (SharePoint Foundation 2010).

Voir aussi

Concepts

Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010)
Nouveautés de la mise à niveau (SharePoint Foundation 2010)

Historique des modifications


Mettre à niveau une installation autonome vers une nouvelle configuration matérielle à l'aide du stockage BLOB distant (attachement de base de données)
Voir aussi

Cet article présente les procédures de mise à niveau requises pour effectuer une mise à niveau depuis un système Windows SharePoint Services 3.0 autonome vers une installation de SharePoint Foundation 2010 avec RBS (Remote BLOB Storage, stockage BLOB distant) sur une nouvelle plateforme matérielle.

Important :
Il est vivement recommandé de lire l'article Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant) pour prendre connaissance d'informations et de recommandations importantes relatives à la mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010 avec RBS.

RBS est conçu pour déplacer le stockage des objets BLOB (Binary Large Objects) depuis des serveurs de bases de données vers des solutions de stockage de produits. RBS est un module complémentaire applicable à Microsoft SQL Server 2008 Express et Microsoft SQL Server 2008 R2 Express. Cette implémentation de RBS utilise le fournisseur SQL FILESTREAM. Pour plus d'informations sur RBS et sur le fournisseur FILESTREAM, voir Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010).

En raison des limites de taille des bases de données dans SQL Server 2008 Express, installez la base de données interne Windows et restaurez les bases de données Windows SharePoint Services 3.0 dans la base de données interne Windows. Ensuite, installez RBS, déplacez la base de données de contenu depuis la base de données interne Windows vers SQL Server, puis déplacez les objets BLOB vers une base de données de contenu configurée pour utiliser RBS.

Par défaut, les bases de données de contenu dans SharePoint Foundation 2010 sont stockées dans SQL Server 2008 Express, qui autorise une taille maximale de 4 gigaoctets (Go) par base de données de contenu. Étant donné que SQL Server 2008 R2 Express prend en charge les bases de données de contenu dont la taille est inférieure ou égale à 10 Go, il est recommandé d'installer SQL Server 2008 R2 Express pour que les bases de données de contenu soient prises en charge. SQL Server 2008 R2 Express est une mise à niveau gratuite que vous pouvez télécharger et installer à partir de Microsoft SQL Server 2008 R2 Express Edition (http://go.microsoft.com/fwlink/?LinkID=189418&clcid=0x40C).

Remarque :
Cet article suppose que vous avez installé SQL Server Management Studio sur le serveur de bases de données dans la batterie de serveurs Windows SharePoint Services 3.0. Si ce logiciel n'est pas installé, vous pouvez le télécharger et l'installer à partir de la page Microsoft® SQL Server® 2008 Management Studio Express (http://go.microsoft.com/fwlink/?linkid=186132&clcid=0x40C).

Cet article n'est pas un guide complet de mise à niveau vers SharePoint Foundation 2010. Avant de commencer le processus de mise à niveau, lisez les articles suivants et créez un plan de mise à niveau :

  • À propos du processus de mise à niveau (SharePoint Foundation 2010)

  • Planifier et préparer la mise à niveau (SharePoint Foundation 2010)

  • Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant)

Dans cet article :

  • Pour préparer la mise à niveau vers SharePoint Foundation 2010 sur le serveur d'origine

  • Pour préparer la mise à niveau vers SharePoint Foundation 2010 sur le nouveau serveur

  • Pour installer et configurer la base de données interne Windows sur le nouveau serveur

  • Pour déplacer les bases de données de contenu vers le nouveau serveur

  • Pour installer SQL Server Express 2008 R2 sur le nouveau serveur

  • Pour installer RBS sur le nouveau serveur

  • Pour installer SharePoint Foundation 2010 sur le nouveau serveur

  • Pour migrer la base de données de contenu vers RBS et terminer l'installation

Pour préparer la mise à niveau vers SharePoint Foundation 2010 sur le serveur d'origine

  1. Vérifiez que le compte d'utilisateur utilisé pour la réalisation de cette procédure satisfait aux conditions indiquées dans Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010) et qu'il est membre du groupe Administrateurs sur l'ordinateur local.

  2. Vérifiez que Management Studio est installé sur le serveur d'origine.

  3. Sauvegardez les bases de données de contenu à l'aide de la procédure décrites dans Procédure : sauvegarder une base de données (SQL Server Management Studio) (http://go.microsoft.com/fwlink/?linkid=187768&clcid=0x40C). Vous pouvez utiliser les paramètres par défaut pour la plupart des options, mais vous devez utiliser les paramètres suivants :

    • À l'étape 1, vous devez définir le nom d'instance de la base de données interne Windows sur \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query.

    • À l'étape 12, sélectionnez l'option Destination. Vérifiez que le support de destination dispose de suffisamment d'espace pour la sauvegarde.

  4. Exécutez l'outil de vérification de pré-mise à niveau présenté dans l'article Effectuer les étapes préalables à la mise à niveau (SharePoint Foundation 2010).

    Le rapport de l'outil de vérification de pré-mise à niveau indique les noms de toutes les bases de données de contenu. Vous devez détenir cette liste pour migrer les bases de données de contenu vers RBS. Si vous disposez de plusieurs applications Web, vous devez également noter les bases de données de contenu attachées à chacune d'elles.

Pour préparer la mise à niveau vers SharePoint Foundation 2010 sur le nouveau serveur

  1. Vérifiez que le compte d'utilisateur utilisé pour la réalisation de la mise à niveau et de l'installation satisfait aux conditions indiquées dans Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010) et qu'il est membre du groupe Administrateurs sur l'ordinateur local.

  2. Vérifiez que la configuration matérielle prend en charge SharePoint Foundation 2010. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  3. Vérifiez que l'espace disque disponible satisfait aux conditions suivantes :

    • Sa taille est au moins le double de celle de la base de données de contenu la plus volumineuse.

    • Sa taille est supérieure ou égale à la somme des tailles de toutes les bases de données de contenu.

Pour installer et configurer la base de données interne Windows sur le nouveau serveur

  1. Cliquez sur Démarrer, puis sur Gestionnaire de serveur.

  2. Dans le Gestionnaire de serveur, cliquez sur Fonctionnalités, puis cliquez sur Ajouter des fonctionnalités.

  3. Dans l'Assistant Ajout de fonctionnalités, faites défiler la liste des fonctionnalités vers le bas, puis sélectionnez Base de données interne Windows.

  4. Cliquez sur Installer.

  5. Quittez le Gestionnaire de serveur.

  6. Cliquez sur Démarrer, cliquez sur Outils d'administration, puis cliquez sur Gestion de l'ordinateur.

  7. Développez Services et applications.

  8. Cliquez sur Services.

  9. Dans le volet Services, cliquez avec le bouton droit sur Base de données interne Windows, puis cliquez sur Propriétés.

  10. Utilisez le menu déroulant pour définir le paramètre Type de démarrage sur Automatique.

  11. Cliquez sur Démarrer pour démarrer le service.

  12. Cliquez sur OK, puis quittez la Gestion de l'ordinateur.

Pour déplacer les bases de données de contenu vers le nouveau serveur

  1. Copiez vers le nouveau serveur les fichiers de sauvegarde des bases de données de contenu que vous avez créés dans la procédure Pour préparer la mise à niveau vers SharePoint Foundation 2010 sur le serveur d'origine .

  2. Sur le nouveau serveur, téléchargez et installez Management Studio à partir de la page Microsoft® SQL Server® 2008 Management Studio Express (http://go.microsoft.com/fwlink/?linkid=186132&clcid=0x40C).

  3. Utilisez les instructions indiquées dans la page Procédure : restaurer une sauvegarde de base de données (SQL Server Management Studio) (http://go.microsoft.com/fwlink/?linkid=187769&clcid=0x40C) pour restaurer les bases de données à l'aide de Management Studio. Utilisez les paramètres suivants pour la procédure de restauration :

    • À l'étape 1, utilisez le nom suivant pour l'instance de la base de données interne Windows : \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query.

    • À l'étape 5, entrez le nom de la base de données à restaurer. Il est recommandé d'utiliser le même nom que celui utilisé lors de la sauvegarde de la base de données.

    • À l'étape 7, sélectionnez le fichier de base de données que vous avez copié à l'étape 1.

    • Acceptez toutes les autres options par défaut et terminez la restauration.

Pour installer SQL Server Express 2008 R2 sur le nouveau serveur

  1. Téléchargez SQL Server 2008 R2 Express à partir de Microsoft SQL Server 2008 R2 Express Edition (http://go.microsoft.com/fwlink/?LinkID=189418&clcid=0x40C).

  2. Suivez les instructions à l'écran pour installer SQL Server 2008 R2 Express.

    Pour plus d'informations, voir Procédure : installer SQL Server 2008 (programme d'installation) (http://go.microsoft.com/fwlink/?linkid=187771&clcid=0x40C).

    Notez particulièrement les paramètres suivants :

    • Dans la page Configuration de l'instance, indiquez si vous souhaitez installer une instance par défaut ou une instance nommée. Si vous créez une instance nommée, notez le nom de l'instance. Vous devrez indiquer ce nom dans une procédure ultérieure.

    • Dans la page Configuration du serveur — Comptes de service, vous devez spécifier les comptes de connexion des services SQL Server. Vous pouvez affecter le même compte de connexion à tous les services SQL Server ou configurer chaque compte de service séparément.

    • Dans la page Configuration du moteur de base de données, assurez-vous que le compte de domaine en cours d'utilisation pour cette installation est répertorié en tant qu'administrateur SQL Server.

Pour installer RBS sur le nouveau serveur

  1. Accédez à la page http://go.microsoft.com/fwlink/?linkid=168472&clcid=0x40C (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=168472&clcid=0x40C) et téléchargez le fichier RBS_X64.msi.

    Important :
    Vous devez installer la version de RBS incluse dans le Package d'installation SQL Server Remote BLOB Store du Feature Pack pour Microsoft SQL Server 2008 R2. La version de RBS doit être 10.50.xxx. Aucune version antérieure de RBS n'est prise en charge pour SharePoint Foundation 2010.

  2. Ouvrez le dossier qui contient le fichier .msi, puis double-cliquez sur RBS_X64.msi pour démarrer l'Assistant d'installation du stockage BLOB distant SQL.

  3. Dans l'Assistant d'installation du stockage BLOB distant SQL, dans la page Sélection de fonctionnalité, développez Serveur, cliquez sur la flèche vers le bas en regard de l'option Exécuter le script, puis cliquez sur Ce composant ne sera pas disponible.

  4. Développez FILESTREAM Provider, développez Serveur, cliquez sur la flèche vers le bas en regard de l'option Exécuter le script, puis cliquez sur Ce composant ne sera pas disponible.

    Remarque :
    La base de données qui hébergera les scripts n'existe pas encore. Elle est créée pendant le processus de mise à niveau de base de données. L'option Exécuter les scripts sera installée automatiquement pendant l'installation de SharePoint Foundation 2010.

  5. Terminez l'Assistant en utilisant les valeurs par défaut.

    Pendant l'installation, une boîte de dialogue apparaît au sujet d'une tâche du chargé de maintenance RBS. Cliquez sur OK dans cette boîte de dialogue pour poursuivre l'installation.

Pour installer SharePoint Foundation 2010 sur le nouveau serveur

  1. Installez SharePoint Foundation 2010 en suivant les instructions indiquées dans Installer SharePoint Foundation 2010 sur les serveurs de la batterie de serveurs. Vous devez utiliser le nom d'instance de base de données que vous avez créé à l'étape 2 de la procédure Pour installer SQL Server Express 2008 R2 sur le nouveau serveur présentée plus haut dans cet article. Si vous avez utilisé l'instance nommée par défaut à cette étape, vous devez l'entrer ici sous la forme "SQLExpress". Si vous avez utilisé l'instance par défaut, vous devez entrer " " ici au lieu d'utiliser l'instance nommée SQLExpress par défaut.

    Notez que vous créez une installation de SharePoint Foundation 2010. Vous effectuez une mise à niveau avec liaison des bases de données, non une mise à niveau sur place.

    Remarque :
    Après avoir installé SharePoint Foundation 2010, ne créez pas d'applications Web avant d'avoir atteint les instructions en ce sens indiquées plus loin dans cet article.

Pour migrer la base de données de contenu vers RBS et terminer l'installation

  1. Vérifiez que le compte d'utilisateur utilisé pour l'installation de SharePoint Foundation 2010 et de RBS est le compte d'utilisateur qui effectue cette procédure.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante pour migrer la base de données de contenu vers RBS. Vous devez répéter cette commande pour chaque base de données de contenu. Consultez la liste des bases de données de contenu générée par l'outil de vérification de pré-mise à niveau à l'étape 4 de la procédure Pour préparer la mise à niveau vers SharePoint Foundation 2010 sur le serveur d'origine plus haut dans cet article.

    Code de copie
    Move-SPBlobStorageLocation -SourceDatabase "<DbName>" -DestinationDataSourceInstance "<InstanceName>"

    Où :

    • <DbName> représente le nom de la base de données de contenu que vous avez restaurée dans la base de données interne Windows.

    • <InstanceName> représente le nom de l'instance de base de données SQL Server que vous avez créée dans la procédure Pour installer SQL Server Express 2008 R2 sur le nouveau serveur plus haut dans cet article. Si vous avez utilisé l'instance nommée par défaut à cette étape, vous devez l'entrer ici sous la forme "SQLExpress". Si vous avez utilisé l'instance par défaut, vous devez entrer " " ici au lieu d'utiliser l'instance nommée SQLExpress par défaut.

  6. Créez les applications Web à attacher à la base de données de contenu. Pour plus d'informations sur la création d'une application Web dans SharePoint Foundation 2010, voir Créer une application Web (SharePoint Foundation 2010) ou Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010).

  7. Tapez la commande suivante pour attacher et mettre à niveau une base de données de contenu vers une application Web :

    Code de copie
    Mount-SPContentDatabase "<DbName>" -WebApplication <http://SiteName>

    Où :

    • <DbName> représente le nom de la base de données.

    • <http://SiteName> représente le nom de l'application Web.

    Répétez cette commande pour chaque base de données de contenu.

    Pour plus d'informations, voir Move-SPBlobStorageLocation et Mount-SPContentDatabase.

  8. Créez ou restaurez les personnalisations requises sur le nouveau système. Pour connaître les étapes postérieures à la mise à niveau recommandées, voir Effectuer les étapes postérieures à la mise à niveau (SharePoint Foundation 2010).

Voir aussi

Concepts

Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010)

Historique des modifications


Effectuer une mise à niveau avec liaison des bases de données vers SharePoint Foundation 2010

Maintenant que vous avez étudié le processus de mise à niveau en consultant les articles dans À propos du processus de mise à niveau (SharePoint Foundation 2010) et planifié votre mise à niveau en suivant les étapes indiquées dans les articles dans Planifier et préparer la mise à niveau (SharePoint Foundation 2010), vous êtes en mesure d'effectuer la mise à niveau avec liaison des bases de données vers Microsoft SharePoint Foundation 2010. Vous pouvez suivre les étapes indiquées dans cette section pour une mise à niveau d'évaluation et pour votre mise à niveau sur place réelle sur votre batterie de serveurs de production.

Dans cette section :

  • Liste de vérification pour la mise à niveau par attachement de base de données (SharePoint Foundation 2010)

    Utilisez cette liste de contrôle pour vous assurer que vous effectuez toutes les étapes nécessaires lors de la préparation d'une mise à niveau, de l'exécution de la mise à niveau et des opérations à effectuer après la mise à niveau.

  • Préparer le nouvel environnement SharePoint Foundation

    Avant d'attacher et de mettre à niveau vos bases de données, vous devez configurer complètement votre nouvel environnement.

  • Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010

    Une fois le nouvel environnement entièrement configuré, suivez ces étapes pour attacher les bases de données et mettre à niveau vos sites SharePoint.

Historique des modifications


Liste de vérification pour la mise à niveau par attachement de base de données (SharePoint Foundation 2010)
Voir aussi

Cet article contient une liste de vérification qui vous permet de vérifier que toutes les étapes nécessaires ont été effectuées lors de la préparation de la mise à niveau, lors de la mise à niveau à proprement parler et lors des étapes de post-mise à niveau.

Dans cet article :

  • Préparer la mise à niveau

  • Effectuer la mise à niveau

  • Effectuer les étapes de post-mise à niveau

Certaines étapes incluent des annotations relatives à la durée de l'étape. Notez qu'il s'agit d'approximations qui sont fournies pour vous donner un ordre d'idée de la durée de l'étape. Pour déterminer le temps nécessaire à chaque étape dans votre environnement, nous vous recommandons d'effectuer des mises à niveau d'évaluation dans un environnement de test. Pour plus d'informations, voir Estimer la durée du processus de mise à niveau et l'espace dont vous avez besoin (SharePoint Foundation 2010) et Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels (SharePoint Foundation 2010).

Préparer la mise à niveau

Avant de commencer une mise à niveau par attachement de base de données, suivez ces étapes dans l'ordre indiqué :

Étapes de pré-mise à niveau pour une mise à niveau par attachement de base de données Remarques

Préparer la mise à niveau

[ ]

Exécuter l'outil de vérification de pré-mise à niveau

Exécutez l'outil de vérification de pré-mise à niveau et résolvez les problèmes éventuels. Utilisez le rapport généré par l'outil pour remplir la feuille de calcul relative à la planification de la mise à niveau.

Étapes détaillées : Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

Effectuez cette étape plusieurs fois à mesure que vous nettoyez votre environnement et testez le processus de mise à niveau.

L'exécution de l'outil de vérification nécessite seulement quelques minutes, mais la résolution des problèmes peut prendre plusieurs jours ou plusieurs semaines.

[ ]

Créer un inventaire des personnalisations côté serveur dans l'environnement

Créez un inventaire des personnalisations côté serveur dans votre environnement (solutions, fonctionnalités, composants WebPart, gestionnaires d'événements, pages maîtres, mises en page, fichiers CSS, etc.). La plupart de ces informations sont signalées lorsque vous exécutez l'outil de vérification de pré-mise à niveau. Enregistrez toutes les personnalisations nécessaires à votre environnement dans la feuille de calcul de mise à niveau.

Étapes détaillées : Identifier et installer les personnalisations dans l'article « Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels ».

Effectuez cette étape pour tout l'environnement. Vérifiez chaque serveur Web pour vous assurer que vous n'avez oublié aucune personnalisation. Maintenez l'inventaire à jour lorsque vous préparez la mise à niveau.

[ ]

Nettoyer votre environnement

Avant de commencer la mise à niveau, vous devez vous assurer que votre environnement est sain et veiller à nettoyer tout contenu qui n'a pas lieu d'être mis à niveau. Nettoyez les sites ou données orphelins, traitez les grandes listes et les grandes listes de contrôle d'accès, supprimez les versions de document en trop et supprimez les modèles, fonctionnalités et composants WebPart inutilisés.

Étapes détaillées : Nettoyage de votre environnement avant la mise à niveau (SharePoint Foundation 2010).

Effectuez cette étape une fois pour tout l'environnement.

Ce processus peut prendre plusieurs jours ou plusieurs semaines.

Préparer le nouvel environnement

Voir aussi Préparer le nouvel environnement SharePoint Foundation.

[ ]

Installer et configurer SharePoint Foundation 2010 et tous les modules linguistiques

Installez les logiciels requis, puis installez et configurez SharePoint Foundation 2010.

Effectuez ces étapes sur chaque serveur de votre batterie de serveurs.

Cette étape peut prendre une ou plusieurs heures selon le nombre de serveurs dans votre environnement.

[ ]

Configurer les paramètres généraux de la batterie de serveurs

Réappliquez les paramètres généraux de votre batterie de serveurs précédente, notamment les types de fichiers et les paramètres de messagerie et de quota, puis ajoutez des utilisateurs ou des groupes au groupe Administrateurs de batterie. Configurez de nouveaux paramètres tels que la collecte de données relatives à l'utilisation et à l'état, l'enregistrement des diagnostics et les comptes mobiles.

Effectuez cette étape une fois pour tout l'environnement.

[ ]

Créer et configurer des applications Web

Créez une application Web pour chaque application Web présente dans l'ancien environnement.

Effectuez cette étape une fois pour tout l'environnement.

[ ]

Réappliquer les personnalisations côté serveur

Transférez manuellement toutes les personnalisations côté serveur dans votre nouvelle batterie de serveurs. Reportez-vous à l'inventaire que vous avez créé dans la feuille de calcul de mise à niveau pour vous assurer d'installer tous les composants dont vos sites dépendent pour fonctionner correctement.

Veillez à réappliquer les personnalisations à tous les serveurs Web de la batterie de serveurs.

[ ]

Vérifier le nouvel environnement

Après avoir configuré le nouvel environnement, vous pouvez effectuer des tests pour vérifier qu'il contient tous les composants nécessaires avant de procéder à la mise à niveau de vos données.

Effectuez cette étape une fois pour tout l'environnement.

Effectuer la mise à niveau

Suivez ces étapes dans l'ordre pour effectuer une mise à niveau par attachement de base de données. Les étapes requises pour l'attachement de base de données avec des bases de données en lecture seule sont également fournies.

Étapes détaillées : Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010.

Avertissement :
Lorsque vous effectuez une mise à niveau à partir d'une installation de Windows SharePoint Services 3.0 qui utilise la base de données interne Windows et que la taille de la base de données dépasse 4 Go, vous devez effectuer des étapes supplémentaires. Pour plus d'informations sur ces étapes, voir Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant).

Effectuer la mise à niveau par attachement de base de données Remarques

[ ]

Exécuter l'outil de vérification de pré-mise à niveau

Exécutez de nouveau l'outil de vérification de pré-mise à niveau pour identifier de nouveaux problèmes ou les problèmes restants avant de définir les bases de données en lecture seule ou de sauvegarder les bases de données.

Étapes détaillées : Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

L'exécution de l'outil de vérification nécessite seulement quelques minutes, mais la résolution des problèmes peut prendre plus de temps.

[ ]

Définir les bases de données d'une version précédente en lecture seule (attachement de base de données avec des bases de données en lecture seule)

Si vous voulez que votre environnement d'origine soit accessible aux utilisateurs dans un état en lecture seule, définissez les bases de données en lecture seule avant de les sauvegarder.

Effectuez cette étape pour chaque base de données de contenu dans votre environnement.

Selon votre organisation, vous devrez peut-être faire appel à un administrateur de base de données pour effectuer cette tâche.

[ ]

Sauvegarder les bases de données

Sauvegardez toutes vos bases de données de contenu avant de commencer le processus de mise à niveau par attachement de base de données.

Effectuez cette étape pour chaque base de données de contenu dans votre environnement.

Cette étape peut prendre une heure, plusieurs heures, voire plus en fonction de votre jeu de données et de votre environnement.

Selon votre organisation, vous devrez peut-être faire appel à un administrateur de base de données pour effectuer cette tâche.

[ ]

Détacher les bases de données d'une version précédente (attachement de base de données standard)

Si vous envisagez de mettre à niveau les bases de données d'origine (et non une copie de sauvegarde), détachez les bases de données d'origine de l'instance de Microsoft SQL Server de manière à pouvoir les déplacer vers le nouvel environnement.

Effectuez cette étape pour chaque base de données de contenu dans votre environnement.

Selon votre organisation, vous devrez peut-être faire appel à un administrateur de base de données pour effectuer cette tâche.

[ ]

Restaurer une copie de sauvegarde de la base de données (attachement de base de données avec des bases de données en lecture seule)

Si vous envisagez de mettre à niveau une copie des bases de données, restaurez les bases de données à partir de la sauvegarde.

Effectuez cette étape pour chaque base de données de contenu dans votre environnement.

Cette étape peut prendre une heure, voire plus en fonction de votre jeu de données et de votre environnement.

Selon votre organisation, vous devrez peut-être faire appel à un administrateur de base de données pour effectuer cette tâche.

[ ]

Vérifier les composants personnalisés

Utilisez l'applet de commande Test-SPContentDatabaseWindows PowerShell pour vérifier que vous disposez de tous les composants personnalisés pour cette base de données.

Effectuez cette étape pour chaque base de données de contenu dans votre environnement.

L'exécution de l'applet de commande nécessite seulement quelques minutes, mais la résolution des problèmes peut prendre plus de temps.

[ ]

Vérifier les autorisations

Assurez-vous que le compte que vous utilisez pour attacher les bases de données est membre du rôle de base de données fixe db_owner pour les bases de données de contenu à mettre à niveau.

[ ]

Attacher une base de données contenu à une application Web

Attachez la première base de données de contenu que vous voulez mettre à niveau. Vous devez effectuer cette opération à partir de la ligne de commande. Vous pouvez utiliser l'applet de commande Mount-SPContentDatabaseWindows PowerShell ou l'opération Stsadm AddContentDB.

Effectuez cette étape pour une base de données de contenu dans votre environnement.

Cette étape peut prendre une heure, plusieurs heures, voire plus en fonction de votre jeu de données et du matériel sur les serveurs Web, les serveurs de base de données et le sous-système de stockage.

[ ]

Vérifier la mise à niveau pour la première base de données

Vérifiez que la mise à niveau a réussi pour la première base de données, puis passez en revue le site à la recherche de problèmes éventuels.

Étapes détaillées : Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Effectuez cette étape pour la base de données de contenu que vous venez d'attacher.

[ ]

Attacher les bases de données restantes

Attachez et mettez à niveau les bases de données de contenu restantes dans votre environnement. Vous devez effectuer cette opération à partir de la ligne de commande.

Effectuez cette étape pour toutes les bases de données de contenu restantes dans votre environnement.

Cette étape peut prendre une heure, plusieurs heures, voire plus en fonction de votre jeu de données, du matériel sur les serveurs Web, les serveurs de base de données et le sous-système de stockage, et selon que vous mettez à niveau plusieurs bases de données en parallèle.

[ ]

Surveiller la progression de la mise à niveau

Utilisez la page État de la mise à niveau dans l'Administration centrale de SharePoint pour surveiller la progression de la mise à niveau de vos sites.

Étapes détaillées : Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Effectuez cette étape pour chaque base de données de contenu que vous mettez à niveau.

Cette étape peut prendre une heure, plusieurs heures ou plusieurs jours en fonction de votre jeu de données.

[ ]

Vérifier la mise à niveau pour les bases de données restantes

Vérifiez que la mise à niveau a réussi pour les bases de données restantes, puis passez en revue les sites à la recherche de problèmes éventuels.

Étapes détaillées : Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Effectuez cette étape pour toutes les bases de données de contenu restantes dans votre environnement.

Cette étape peut prendre une heure, plusieurs heures ou plusieurs jours en fonction de votre contenu.

Effectuer les étapes de post-mise à niveau

Après une mise à niveau par attachement de base de données, suivez ces étapes dans l'ordre indiqué :

Étapes de post-mise à niveau pour une mise à niveau par attachement de base de données Remarques

[ ]

Vérifier la mise à niveau et passer en revue les sites mis à niveau

Passez en revue les sites pour vous assurer qu'ils ont été correctement mis à niveau et qu'ils peuvent être affichés par les utilisateurs.

Étapes détaillées : Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Effectuez cette étape pour toutes les bases de données et collections de sites mises à niveau dans votre environnement.

Cette étape peut prendre une heure, plusieurs heures ou plusieurs jours en fonction de votre contenu.

Vous devez également demander aux propriétaires de sites de passer en revue leurs sites et de signaler les éventuels problèmes.

Voir aussi

Autres ressources

Feuille de calcul de mise en niveau pour les produits SharePoint 2010 (éventuellement en anglais)

Historique des modifications


Préparer le nouvel environnement SharePoint Foundation

Lorsque vous effectuez une mise à niveau de Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010 en utilisant la méthode de mise à niveau par attachement des bases de données, vous mettez à niveau uniquement le contenu de votre environnement, et non les paramètres de configuration. Cette méthode est utile lorsque vous changez de matériel ou que vous souhaitez reconfigurer la topologie de la batterie de serveurs dans le cadre du processus de mise à niveau. Pour plus d'informations sur le choix d'une méthode de mise à niveau, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Pour pouvoir mettre à niveau les données, vous devez configurer un nouveau serveur ou une nouvelle batterie de serveurs en utilisant SharePoint Foundation 2010. Cet article explique les éléments que vous devez configurer pour créer ce nouvel environnement. Pour plus d'informations sur le processus général de mise à niveau à l'aide de la méthode de mise à niveau par attachement de base de données, voir Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Important :
Pour réaliser les procédures décrites dans cet article, vous devez disposer des droits d'administrateur sur le serveur local. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

Dans cet article :

  • Avant de commencer

  • Créer et configurer le nouvel environnement

  • Vérifier le nouvel environnement

  • Effectuer la mise à niveau

Avant de commencer

Avant d'entreprendre la création du nouvel environnement pour la mise à niveau d'une liaison de base de données, lisez les informations suivantes concernant les autorisations et les configurations matérielle et logicielle requises.

  • Assurez-vous que toutes les conditions requises pour le matériel et les logiciels sont satisfaites. Vous devez avoir une version 64 bits de Windows Server 2008 ou de Windows Server 2008 R2. Pour les batteries de serveurs, vous devez aussi avoir une version 64 bits de SQL Server 2005 ou de SQL Server 2008. Pour plus d'informations sur ces conditions requises (telles que les mises à jour spécifiques à installer), voir Déterminer la configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  • Assurez-vous que vous êtes prêt à configurer les comptes requis avec les autorisations appropriées. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

  • Exécutez l'outil de vérification préalable à la mise à niveau sur votre environnement d'origine. Cet outil identifie les problèmes potentiels de mise à niveau de votre environnement et vous permet ainsi de les résoudre avant de procéder à la mise à niveau. Il facilite également l'identification des paramètres requis dans votre environnement. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

Créer et configurer le nouvel environnement

Le processus de création et de configuration du nouvel environnement se compose de plusieurs étapes, qui doivent être réalisées dans l'ordre indiqué. Voici la procédure à suivre :

  1. Installez SharePoint Foundation 2010 sur le ou les serveurs.

  2. Configurez les applications de service.

  3. Configurez les paramètres généraux de la batterie de serveurs.

  4. Créez et configurez les applications Web.

  5. Réappliquez les personnalisations.

La suite de cette section décrit ces étapes et fournit des liens vers d'autres articles contenant des instructions pas à pas. Une fois que toutes les étapes ont été accomplies, vous pouvez vérifier l'environnement et procéder à la mise à niveau.

Installation

La première étape de la création du nouvel environnement consiste à installer SharePoint Foundation 2010 et à configurer votre nouveau serveur ou votre nouvelle batterie de serveurs. Procédez comme suit :

  1. Exécutez l'Outil de préparation des produits Microsoft SharePoint pour installer l'ensemble des logiciels requis.

  2. Exécutez le programme d'installation pour installer le produit.

  3. Installez les modules linguistiques dont vous avez besoin dans cet environnement.

  4. Exécutez l'Assistant Configuration des produits SharePoint pour configurer le ou les serveurs.

Les articles suivants offre ntdes instructions pas à pas permettant de réaliser ces tâches.

  • Installez et configurez le produit

    Suivez les étapes décrites dans l'un des articles suivants pour installer et configurer SharePoint Foundation 2010 sur un serveur unique ou une batterie de serveurs :

    • Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010)

    • Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010)

    Pour découvrir d'autres scénarios de déploiement (installation dans un environnement autonome avec SQL Express), voir Scénarios de déploiement (SharePoint Foundation 2010).

  • Installez et configurez les modules linguistiques.

    Suivez les étapes décrites dans Déployer des modules linguistiques (SharePoint Foundation 2010) pour installer et configurer les modules linguistiques requis pour les sites de votre environnement.

Configurez les applications de service

Vous devez configurer les services que vous souhaitez utiliser dans votre nouvel environnement, par exemple le service BDC (Business Data Connectivity). Les étapes des scénarios de déploiement mentionnés ci-dessus expliquent comment utiliser l'Assistant Configuration de batterie de serveurs initiale pour activer tous les services. Vous pouvez cependant configurer les services manuellement si vous le souhaitez. Pour plus d'informations sur la configuration manuelle des services, voir Configurer les services (SharePoint Foundation 2010).

Configurez les paramètres généraux de la batterie de serveurs

L'étape suivante de création du nouvel environnement consiste à appliquer les paramètres généraux de la batterie de serveurs. Vous devez réappliquer manuellement les paramètres de configuration de la version précédente de votre batterie de serveurs, notamment les paramètres suivants :

  • Paramètres du courrier électronique entrant et sortant

  • Paramètres de sécurité et d'autorisation définis au niveau de la batterie de serveurs, concernant par exemple l'ajout de comptes d'utilisateurs ou de groupes au groupe Administrateurs de batterie

  • Types de fichiers bloqués

  • Modèles de quotas

Vous devez en outre configurer les nouveaux paramètres de batterie de serveurs que vous souhaitez utiliser, par exemple les paramètres suivants :

  • Collecte des données d'utilisation et d'intégrité

  • Journalisation des diagnostics

  • Comptes mobiles

Pour plus d'informations sur la configuration de ces paramètres, voir Configurer les paramètres de la batterie de serveurs (SharePoint Foundation 2010).

Créez et configurez les applications Web

Créez une application Web pour chaque application Web figurant dans l'ancien environnement. Pour chaque application Web, procédez comme suit :

  • Utilisez la même URL et configurez les éventuels paramètres de mappage des accès de substitution.

    Remarque :
    Si vous utilisez une autre URL, les applications Microsoft Office risquent de ne pas être correctement redirigées vers les nouvelles URL et les signets pointant vers les anciennes URL ne fonctionneront pas.

  • Utilisez la même méthode d'authentification.

    Important :
    Si vous utilisiez précédemment l'authentification par formulaire, vous devez opter pour une authentification basée sur des revendications. Vous devez également créer une stratégie d'application Web pour accorder un contrôle total au compte d'utilisateur qui procédera à la mise à niveau par liaison de base de données.

    Pour plus d'informations, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

  • Recréez les chemins d'accès inclus (par exemple, /Sites).

  • Activez la création de sites libre-service pour les applications Web qui utilisaient cette fonction dans l'environnement précédent.

Pour plus d'informations sur la configuration des applications Web et l'authentification, voir les articles suivants :

  • Pour l'authentification classique : Créer une application Web (SharePoint Foundation 2010)

  • Pour l'authentification basée sur des revendications : Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010) et Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010)

Réappliquez les personnalisations

Une des causes fréquentes de défaillance lors des mises à niveau vient du fait que l'environnement ne dispose pas de fonctionnalités personnalisées, de solutions ou d'autres éléments. Vérifiez que tous les éléments personnalisés requis sont installés sur vos serveurs Web frontaux avant de lancer le processus de mise à niveau. Vous pouvez utiliser l'outil de vérification préalable à la mise à niveau pour compiler une liste des personnalisations côté serveur de votre environnement. Pour plus d'informations, voir Identifier et installer les personnalisations dans l'article « Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels ».

Au cours de cette étape, vous devez transférer manuellement toutes les personnalisations dans votre nouvelle batterie de serveurs. Pensez à installer les composants nécessaires au bon fonctionnement de vos sites, notamment les composants suivants :

  • Définitions de site personnalisées

    Remarque :
    Si la définition de site a été créée dans Windows SharePoint Services 3.0, vous pouvez la copier telle quelle dans le nouvel environnement. En revanche, si elle a été créée dans Windows SharePoint Services version 2.0, vous devrez peut-être créer un fichier de définition de mise à niveau pour mapper la définition de site aux nouvelles fonctionnalités de Windows SharePoint Services 3.0. Pour plus d'informations, voir Développer de nouvelles définitions de site personnalisées et créer les fichiers de définition de mise à niveau (Windows SharePoint Services) et Déployer des fichiers de définition de mise à niveau et de nouvelles définitions de site (Windows SharePoint Services).

  • Feuilles de style personnalisées (notamment les feuilles de style en cascade) et images

  • Composants WebPart personnalisés

  • Services Web personnalisés

  • Fonctionnalités et solutions personnalisées

  • Assemblys personnalisés

  • Modifications apportées à Web.config (sécurité, par exemple)

    N'oubliez pas de transférer les éventuels paramètres spécifiques du fichier Web.config de chaque application Web sur les nouveaux serveurs.

  • Autres composants ou fichiers dont vos sites dépendent

Pour plus d'informations sur la mise à jour des personnalisations à utiliser dans SharePoint Foundation 2010, voir : Redéploiement de personnalisations et de solutions dans SharePoint Foundation 2010 et SharePoint Server 2010. Pour plus d'informations sur le déploiement de personnalisations dans votre environnement, voir Déployer des personnalisations - Vue d'ensemble (SharePoint Foundation 2010).

Vérifier le nouvel environnement

Après avoir configuré le nouvel environnement, vous pouvez effectuer des tests pour vérifier qu'il contient tous les composants nécessaires avant de procéder à la mise à niveau de vos données. Différentes méthodes permettent de tester le nouvel environnement :

  • Créez une nouvelle application Web, puis utilisez l'applet de commande Windows PowerShellTest-SPContentDatabase pour vérifier que toutes les personnalisations côté serveur nécessaires pour cette base de données de contenu sont présentes dans le nouvel environnement. N'attachez pas et ne mettez pas à niveau la base de données. Pour plus d'informations, voir Test-SPContentDatabase.

    Remarque :
    Vous pouvez aussi exécuter cette commande sur la base de données de contenu d'origine, à condition qu'elle ne soit pas en cours d'utilisation.

  • Utilisez l'opération Stsadm enumallwebs dans votre environnement Windows SharePoint Services 3.0 pour déterminer à quel modèle chaque site est associé, puis vérifiez si le modèle est installé dans votre environnement SharePoint Foundation 2010. La Mise à jour cumulative d'octobre inclut des améliorations apportées à l'opération enumallwebs, qui facilitent la recherche des personnalisations en cours d'utilisation. Pour plus d'informations sur cette opération, voir Enumallwebs : opération Stsadm (Windows SharePoint Services).

Effectuer la mise à niveau

Lorsque vous avez terminé la préparation du nouvel environnement, vous pouvez attacher et mettre à niveau les bases de données.

Suivez les étapes décrites dans Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010 pour attacher et mettre à niveau les bases de données du serveur ou de la batterie de serveurs Windows SharePoint Services 3.0 vers le nouveau serveur ou la nouvelle batterie de serveurs SharePoint Foundation 2010.

Important :
Si vous effectuez une mise à niveau à partir d'une installation de Windows SharePoint Services 3.0 utilisant la base de données interne Windows et que la taille de la base de données est supérieure à 4 Go, vous devez réaliser des étapes supplémentaires. Pour plus d'informations, voir Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant).

Historique des modifications


Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010
Voir aussi

Lorsque vous effectuez une mise à niveau depuis Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010 à l'aide du processus de mise à niveau avec liaison des bases de données, vous migrez seulement le contenu de votre environnement et non pas les paramètres de configuration. L'utilisation d'un processus de mise à niveau avec liaison des bases de données pour effectuer la mise à niveau est utile lorsque vous modifiez la configuration matérielle ou que vous souhaitez reconfigurer la topologie de la batterie de serveurs dans le cadre du processus de mise à niveau. Pour plus d'informations sur le choix d'une méthode de mise à niveau, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

La première étape du processus consiste à configurer un nouvel environnement destiné à héberger le contenu mis à niveau. Si vous n'avez pas encore configuré le nouvel environnement, suivez les étapes indiquées dans Préparer le nouvel environnement SharePoint Foundation

Une fois que vous avez défini le nouvel environnement, vous pouvez suivre les procédures indiquées dans cet article pour détacher, puis reconnecter les bases de données pour effectuer la mise à niveau proprement dite.

Dans cet article :

  • Vue d'ensemble du processus

  • Avant de commencer

  • Définir les bases de données de la version précédente en lecture seule (facultatif)

  • Sauvegarder les bases de données disponibles dans la version précédente à l'aide des outils SQL Server

  • Détacher les bases de données de version précédente (attachement de base de données standard)

  • Restaurer une copie de sauvegarde de la base de données (attachement de base de données avec bases de données en lecture seule)

  • Vérifier les composants personnalisés

  • Attacher une base de données de contenu à une application Web

  • Vérification : contrôler la mise à niveau pour la première base de données

  • Attacher les bases de données restantes

  • Vérification : contrôler la mise à niveau pour les bases de données supplémentaires

Remarque :
Une cause fréquente de défaillances au cours d'une mise à niveau est due à des fonctionnalités, des solutions ou d'autres éléments personnalisés manquants dans l'environnement. Vérifiez que les éléments personnalisés dont vous avez besoin sont installés sur vos serveurs Web frontaux avant de commencer le processus de mise à niveau. Vous pouvez utiliser l'outil de vérification préalable à la mise à niveau et, pour une mise à niveau avec liaison des bases de données, l'applet de commande test-spcontentdatabaseWindows PowerShell afin d'identifier les éléments personnalisés que vos sites pourraient utiliser. Pour plus d'informations, voir Identifier et installer les personnalisations dans l'article « Utiliser une mise à niveau d'évaluation pour rechercher les problèmes potentiels ».

Pour plus d'informations sur le processus général de mise à niveau à l'aide de la méthode de mise à niveau avec liaison des bases de données, voir Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Vue d'ensemble du processus

Lorsque vous effectuez une mise à niveau à l'aide d'une mise à niveau avec liaison des bases de données, vous effectuez essentiellement une sauvegarde et une restauration des bases de données. Autrement dit, vous les sauvegardez sur l'ancienne batterie, puis vous les restaurez dans la nouvelle batterie. Lorsque vous restaurez une base de données et que vous l'ajoutez à la nouvelle batterie, le processus de mise à niveau s'exécute et met à niveau la totalité de la base de données. Le processus de mise à niveau avec liaison des bases de données est similaire au processus de mise à niveau sur place. La différence est qu'il est effectué manuellement et que l'environnement d'origine reste intact.

Si vous souhaitez conserver votre batterie initiale et autoriser les utilisateurs à continuer d'accéder à leurs données, vous devez rendre la base de données accessible en lecture seule, puis attacher une copie de sauvegarde des bases de données.

Remarque :
La partie du processus décrit dans cet article qui est spécifique au déplacement d'une base de données d'un ordinateur exécutant Microsoft SQL Server vers un autre ordinateur exécutant aussi SQL Server s'intitule repositionnement planifié. Pour plus d'informations sur le repositionnement planifié, voir Déplacement des bases de données utilisateur (http://go.microsoft.com/fwlink/?linkid=148425&clcid=0x40C).

Pour une présentation générale du processus de mise à niveau, voir Présentation du processus de mise à niveau (SharePoint Foundation 2010).

Avant de commencer

Avant de commencer la mise à niveau par attachement de base de données, lisez les informations suivantes sur les autorisations, ainsi que sur les configurations matérielle et logicielle requises. Suivez les étapes spécifiées pour installer ou configurer les logiciels prérequis ou pour modifier les paramètres.

  • Assurez-vous que toutes les conditions requises pour le matériel et les logiciels sont satisfaites. Vous devez avoir une version 64 bits de Windows Server 2008 ou de Windows Server 2008 R2. Pour les batteries de serveurs, vous devez aussi avoir une version 64 bits de SQL Server 2005 ou de SQL Server 2008. Pour plus d'informations sur ces conditions requises (telles que les mises à jour spécifiques à installer), voir Déterminer la configuration matérielle et logicielle requise (SharePoint Foundation 2010).

  • Assurez-vous que vous êtes prêt à configurer les comptes requis avec les autorisations appropriées. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

  • Assurez-vous que le compte que vous utilisez pour attacher les bases de données est membre du rôle de base de données fixe db_owner pour les bases de données de contenu que vous souhaitez mettre à niveau.

  • Exécutez l'outil de vérification de pré-mise à niveau sur les sites stockés dans les bases de données. Cet outil identifie les problèmes potentiels de mise à niveau de votre environnement et vous permet ainsi de les résoudre avant de procéder à la mise à niveau. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

  • Créez un nouvel environnement de batterie de serveurs. Pour plus d'informations sur la création du nouvel environnement, voir Préparer le nouvel environnement SharePoint Foundation.

  • Recherchez et corrigez toutes les erreurs de cohérence de base de données. Pour plus d'informations, voir Livre blanc : Maintenance des bases de données pour Windows SharePoint Services 3.0.

Définir les bases de données de la version précédente en lecture seule (facultatif)

Si vous utilisez l'approche hybride des bases de données en lecture seule pour effectuer la mise à niveau, définissez les bases de données de la version précédente en lecture seule avant de sauvegarder les bases de données. Quel que soit le type de mise à niveau par attachement de base de données, vous pouvez aussi définir les bases de données en lecture seule pour être sûr de capturer toutes les données dans la sauvegarde, de façon à restaurer et mettre à niveau l'état actuel de l'environnement. Si les bases de données sont définies en lecture seule, les utilisateurs peuvent continuer à afficher du contenu, mais ils ne pourront pas en ajouter ou en modifier.

Important :
Il est impossible de mettre à niveau une base de données accessible en lecture seule. Si vous utilisez un attachement de base de données avec des bases de données en lecture seule, vous devez restaurer une copie de la base de données, puis effectuer la mise à niveau sur la copie. Si vous n'utilisez pas cette méthode mais que vous souhaitez rendre momentanément les bases de données de contenu accessibles en lecture seule pendant que vous sauvegardez les données actuelles, assurez-vous de rendre les bases de données accessibles en lecture-écriture avant de les attacher et de les mettre à niveau.

Important :
Vérifiez que vous avez exécuté l'outil de vérification de pré-mise à niveau avant d'effectuer cette procédure. Pour plus d'informations, voir Exécuter l'outil de vérification préalable à la mise à niveau (SharePoint Foundation 2010).

Pour définir une base de données en lecture seule dans SQL Server 2008

  1. Dans SQL Server Enterprise Manager, cliquez avec le bouton droit sur le nom de la base de données que vous voulez définir en lecture seule, puis cliquez sur Propriétés.

  2. Dans la boîte de dialogue Propriétés, cliquez sur l'onglet Options.

  3. Sous Accès, activez la case à cocher Lecture seule, puis cliquez sur OK.

Pour définir une base de données en lecture seule dans SQL Server 2005

  1. Dans SQL Server Management Studio, cliquez avec le bouton droit sur le nom de la base de données que vous voulez définir en lecture seule, puis cliquez sur Propriétés.

  2. Dans la section Sélectionner une page, cliquez sur Options.

  3. Dans le volet droit, sous Autres options, dans la section État, en regard de Base de données en lecture seule, cliquez sur la flèche, puis sélectionnez Vrai.

Pour définir une base de données en lecture seule dans SQL Server 2008

  1. Dans SQL Server Management Studio, dans l'Explorateur d'objets, connectez-vous à une instance du moteur de base de données, développez le serveur, puis développez Bases de données.

  2. Sélectionnez la base de données que vous voulez configurer en lecture seule, cliquez avec le bouton droit sur la base de données, puis cliquez sur Propriétés.

  3. Dans la boîte de dialogue Propriétés de la base de données, dans la section Sélectionner une page, cliquez sur Options.

  4. Dans le volet droit, sous Autres options, dans la section État, en regard de Base de données en lecture seule, cliquez sur la flèche, puis sélectionnez Vrai.

Vous pouvez configurer l'option de disponibilité de base de données READ_ONLY à l'aide de Transact-SQL. Pour plus d'informations sur l'utilisation de la clause SET de l'instruction ALTER DATABASE, voir Définition des options de base de données (http://go.microsoft.com/fwlink/?linkid=148362&clcid=0x40C).

Sauvegarder les bases de données disponibles dans la version précédente à l'aide des outils SQL Server

Suivez la procédure appropriée pour sauvegarder les bases de données dans SQL Server 2000, SQL Server 2005 ou SQL Server 2008. Répétez ces étapes pour chaque base de données de contenu dans votre batterie de serveurs.

Il est inutile de sauvegarder les bases de données de configuration ou de contenu d'administration, car vous allez recréer ces bases de données dans la nouvelle batterie de serveurs. Pour plus d'informations sur les types de bases de données pouvant se trouver dans une batterie de serveurs Windows SharePoint Services 3.0, voir Types de bases de données et descriptions (Windows SharePoint Services 3.0).

À la fin de cette procédure, vous aurez dupliqué les bases de données de contenu en lecture seule.

Pour sauvegarder une base de données dans SQL Server 2008

  1. Sur le serveur de bases de données, cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Dans SQL Server Enterprise Manager, développez Serveurs Microsoft SQL.

  3. Développez Groupe SQL Server.

  4. Développez (local) (Windows NT).

  5. Développez Bases de données.

  6. Cliquez avec le bouton droit sur la base de données que vous voulez sauvegarder, pointez sur Toutes les tâches, puis cliquez sur Sauvegarder la base de données.

  7. Dans la boîte de dialogue Sauvegarde SQL Server, dans la zone Nom, spécifiez un nom pour la sauvegarde, puis dans la zone Sauvegarde, sélectionnez Bases de données - complète.

  8. Dans la zone Destination, sélectionnez une destination existante ou effectuez l'opération suivante :

    1. Cliquez sur Ajouter.

    2. Dans la zone Sélectionner la destination de la sauvegarde, sélectionnez Nom de fichier, puis en regard de la zone Nom de fichier, cliquez sur Parcourir.

    3. Dans la boîte de dialogue Emplacement de l'unité de sauvegarde - (local), dans la zone Nom de fichier, tapez un nom de fichier, puis cliquez sur OK.

    4. Cliquez sur OK à nouveau pour fermer la boîte de dialogue Sélectionner la destination de la sauvegarde.

  9. Cliquez sur OK pour démarrer le processus de sauvegarde.

  10. Cliquez sur OK pour confirmer que le processus de sauvegarde est terminé.

Répétez la procédure précédente pour sauvegarder toutes les autres bases de données de contenu utilisées par Windows SharePoint Services 3.0 dans votre environnement.

Pour sauvegarder une base de données dans SQL Server 2005

  1. Sur le serveur de bases de données, cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2005, puis cliquez sur SQL Server Management Studio.

  2. Dans la zone Se connecter au serveur, renseignez les informations de connexion, puis cliquez sur Se connecter.

  3. Une fois établie la connexion à l'instance appropriée du moteur de base de données SQL Server 2005, dans l'Explorateur d'objets, développez l'arborescence du serveur en développant le nom du serveur.

  4. Développez Bases de données, cliquez avec le bouton droit sur la base de données que vous souhaitez sauvegarder, pointez sur Tâches, puis cliquez sur Sauvegarder. La boîte de dialogue Sauvegarder la base de données s'affiche.

  5. Dans la partie Source, dans la zone Base de données, vérifiez le nom de la base de données.

  6. Dans la zone Type de sauvegarde, sélectionnez Complète.

  7. Sous Composant de sauvegarde, sélectionnez Base de données.

  8. Dans la partie Jeu de sauvegarde, dans la zone de texte Nom, acceptez le nom de jeu de sauvegarde par défaut qui est suggéré ou entrez un nom différent pour le jeu de sauvegarde.

  9. Dans la partie Destination, spécifiez le type de destination de sauvegarde en sélectionnant Disque ou Bande, puis spécifiez une destination. Pour créer une autre destination, cliquez sur Ajouter.

  10. Cliquez sur OK pour démarrer le processus de sauvegarde.

Répétez la procédure précédente pour sauvegarder toutes les autres bases de données de contenu utilisées par Windows SharePoint Services 3.0 dans votre environnement.

Pour sauvegarder une base de données dans SQL Server 2008

  1. Sur le serveur de bases de données, cliquez sur Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008, puis cliquez sur SQL Server Management Studio.

  2. Dans la zone Se connecter au serveur, renseignez les informations de connexion, puis cliquez sur Se connecter.

  3. Une fois établie la connexion à l'instance appropriée du moteur de base de données SQL Server 2008, dans l'Explorateur d'objets, développez le nom du serveur.

  4. Développez Bases de données, cliquez avec le bouton droit sur la base de données que vous souhaitez sauvegarder, pointez sur Tâches, puis cliquez sur Sauvegarder. La boîte de dialogue Sauvegarder la base de données s'affiche.

  5. Dans la partie Source, dans la zone Base de données, vérifiez le nom de la base de données.

  6. Dans la zone Type de sauvegarde, sélectionnez Complète.

  7. Sous Composant de sauvegarde, sélectionnez Base de données.

  8. Dans la partie Jeu de sauvegarde, dans la zone de texte Nom, acceptez le nom de jeu de sauvegarde par défaut ou entrez un nom nouveau nom.

  9. Dans la partie Destination, spécifiez le type de destination de sauvegarde en sélectionnant Disque ou Bande, puis spécifiez une destination. Pour créer une autre destination, cliquez sur Ajouter.

  10. Cliquez sur OK pour démarrer le processus de sauvegarde.

Répétez la procédure précédente pour sauvegarder toutes les autres bases de données de contenu utilisées par Windows SharePoint Services 3.0 dans votre environnement.

Détacher les bases de données de version précédente (attachement de base de données standard)

Avant de pouvoir attacher vos bases de données au nouvel environnement et de mettre à niveau les données, vous devez les détacher de l'environnement actuel. Après cela, vous pouvez les déplacer vers un nouveau serveur de base de données ou les laisser sur le serveur de base de données existant et les attacher à des applications Web.

Important :
N'appliquez pas la procédure suivante si vous effectuez une mise à niveau d'attachement de base de données avec des bases de données en lecture seule. Pour continuer à fournir à vos utilisateurs un accès à leur contenu, vous devez laisser les bases de données attachées et suivre les étapes de la section Restaurer une copie de sauvegarde de la base de données (attachement de base de données avec bases de données en lecture seule) plus loin dans cet article afin de créer une copie des bases de données.

Ajouter une base de données de contenu à une application Web à l'aide de l'outil en ligne de commande Stsadm

  1. Dans l'Administration centrale, dans la page Gestion des applications, dans la section Gestion des applications Web SharePoint, cliquez sur Bases de données de contenu.

  2. Dans la page Gérer les bases de données de contenu, cliquez sur la base de données de contenu que vous souhaitez détacher.

    Remarque :
    Si la base de données de contenu n'est pas répertoriée, il se peut qu'elle soit associée à une autre application Web. Pour sélectionner une autre application Web, dans le menu Application Web, cliquez sur Modifier l'application Web.

  3. Dans la page Gérer les paramètres de la base de données de contenu, dans la section Supprimer la base de données de contenu, activez la case à cocher Supprimer la base de données de contenu, puis cliquez sur OK.

    Remarque :
    La suppression de la base de données de contenu n'entraîne pas la suppression de la base de données ; cela ne fait que supprimer l'association de la base de données avec l'application Web.

  4. Répétez les étapes 2 et 3 pour chaque base de données de contenu à détacher.

Vous pouvez également utiliser l'opération Stsadm deletecontentdb pour détacher une base de données de contenu d'une application Web. Pour plus d'informations, voir Deletecontentdb : opération Stsadm (Windows SharePoint Services).

Si vous déplacez les bases de données vers un serveur de base de données différent, vous devez également détacher les bases de données de l'instance de SQL Server avant de les déplacer et les attacher à la nouvelle instance de SQL Server après les avoir déplacées.

Important :
Si vous déplacez vos bases de données sur une instance différente de SQL Server, vérifiez que la sécurité est configurée correctement. Vérifiez que les comptes que vous utilisez disposent des rôles fixes et des autorisations appropriés sur les bases de données, et qu'il s'agira toujours de comptes valides si vous passez d'un domaine à un autre.

Pour détacher une base de données d'une instance de SQL Server et la déplacer vers une autre instance de SQL Server

  1. Dans SQL Server 2005 Management Studio, ouvrez l'instance source de SQL Server, puis développez le nœud Bases de données.

  2. Cliquez avec le bouton droit sur la base de données de contenu, pointez sur Tâches, puis cliquez sur Détacher. Répétez cette étape pour chaque base de données de contenu que vous souhaitez détacher et déplacer.

    Remarque :
    Appliquez cette procédure pour déplacer uniquement des bases de données de contenu. Ne détachez aucune autre base de données.

  3. Dans l'Explorateur Windows, naviguez jusqu'à l'emplacement des fichiers .mdf et .ldf des bases de données de contenu.

  4. Sélectionnez les fichiers .mdf et .ldf de la base de données que vous souhaitez déplacer et copiez ou déplacez-les vers le répertoire de destination.

  5. Dans SQL Server 2005 Management Studio, ouvrez l'instance source de SQL Server.

  6. Cliquez avec le bouton droit sur le nœud Bases de données, pointez sur Tâches, puis cliquez sur Attacher.

  7. Dans la boîte de dialogue Attacher la base de données, naviguez jusqu'à l'emplacement auquel vous avez transféré les fichiers .mdf et .ldf, sélectionnez le fichier .mdf de la base de données à attacher, puis cliquez sur OK.

  8. Répétez les étapes 6 et 7 pour chaque base de données de contenu à déplacer.

Restaurer une copie de sauvegarde de la base de données (attachement de base de données avec bases de données en lecture seule)

Une fois que vous avez configuré la nouvelle batterie de serveurs, vous pouvez restaurer les copies de sauvegarde des bases de données sur l'un des produits suivants : Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3. Notez que vous devez restaurer une version 64 bits de SQL Server 2008 R2, SQL Server 2008 avec SP1 et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3. Démarrez avec une base de données, puis vérifiez que la restauration a fonctionné avant de restaurer les autres bases de données.

La section suivante contient des procédures pour la restauration des sauvegardes.

Pour restaurer une copie de sauvegarde d'une base de données dans SQL Server 2005 Enterprise Edition

  1. Dans SQL Server Management Studio, cliquez avec le bouton droit sur Base de données puis cliquez sur Restaurer la base de données. La boîte de dialogue Restaurer la base de données s'affiche.

  2. Dans la boîte de dialogue Restaurer la base de données, sur la page Général, dans la zone Vers la base de données, entrez le nom de la base de données que vous restaurez.

  3. Dans la zone de texte Vers une limite dans le temps, conservez la valeur par défaut (Le plus récent possible).

  4. Pour spécifier la source et l'emplacement des jeux de sauvegarde à restaurer, cliquez sur À partir de l'unité, puis cliquez sur Parcourir pour sélectionner le fichier de sauvegarde.

  5. Dans la boîte de dialogue Spécifier la sauvegarde, dans la zone Support de sauvegarde, vérifiez que l'option Fichier est sélectionnée.

  6. Dans la zone Emplacement de sauvegarde, cliquez sur Ajouter.

  7. Dans la boîte de dialogue Localiser le fichier de sauvegarde, sélectionnez le fichier à restaurer, puis cliquez sur OK.

  8. Dans la grille Sélectionnez les jeux de sauvegarde à restaurer, activez la case à cocher Restaurer en regard de la sauvegarde complète la plus récente.

  9. Dans la boîte de dialogue Restaurer la base de données, sur la page Options, sous Options de restauration, activez la case à cocher Remplacer la base de données existante.

  10. Cliquez sur OK pour démarrer le processus de restauration.

Pour restaurer une copie de sauvegarde d'une base de données dans SQL Server 2008 Enterprise

  1. Une fois établie la connexion à l'instance appropriée du moteur de base de données SQL Server 2008, dans l'Explorateur d'objets, développez le nom du serveur.

  2. Cliquez avec le bouton droit sur Bases de données, puis cliquez sur Restaurer la base de données. La boîte de dialogue Restaurer la base de données s'affiche.

  3. Dans la boîte de dialogue Restaurer la base de données, dans la page Général, entrez le nom de la base de données à restaurer dans la liste Vers la base de données.

  4. Dans la zone de texte Vers une limite dans le temps, conservez la valeur par défaut (Le plus récent possible).

  5. Pour spécifier la source et l'emplacement des jeux de sauvegarde à restaurer, cliquez sur À partir de l'unité, puis cliquez sur Parcourir pour sélectionner le fichier de sauvegarde.

  6. Dans la boîte de dialogue Spécifier la sauvegarde, dans la zone Support de sauvegarde, vérifiez que l'option Fichier est sélectionnée.

  7. Dans la zone Emplacement de sauvegarde, cliquez sur Ajouter.

  8. Dans la boîte de dialogue Localiser le fichier de sauvegarde, sélectionnez le fichier à restaurer, cliquez sur OK puis, dans la boîte de dialogue Spécifier la sauvegarde, cliquez sur OK.

  9. Dans la boîte de dialogue Restaurer la base de données, sous la grille Sélectionnez les jeux de sauvegarde à restaurer, activez la case à cocher Restaurer en regard de la sauvegarde complète la plus récente.

  10. Dans la boîte de dialogue Restaurer la base de données, sur la page Options, sous Options de restauration, activez la case à cocher Remplacer la base de données existante.

  11. Cliquez sur OK pour démarrer le processus de restauration.

Vérifier les composants personnalisés

Avant d'attacher les bases de données de contenu aux applications Web, utilisez l'applet de commande Windows PowerShellTest-SPContentDatabase pour vérifier que vous avez tous les composants personnalisés nécessaires pour cette base de données.

Pour vérifier la disponibilité des composants personnalisés à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Test-SPContentDatabase -Name <DatabaseName> -WebApplication <URL>

    Où :

    • <DatabaseName> est le nom de la base de données à tester.

    • <URL> est l'URL de l'application Web qui hébergera les sites.

Pour plus d'informations, voir Test-SPContentDatabase.

Attacher une base de données de contenu à une application Web

Lorsque vous ajoutez les bases de données de contenu, veillez à ce que le site racine de l'application Web soit inclus dans la première base de données de contenu que vous ajoutez. En d'autres termes, avant de continuer, examinez la racine de l'application Web dans la batterie de serveurs d'origine pour déterminer la première collection de sites. Une fois que vous avez ajouté la base de données qui contient le site racine, vous pouvez ajouter les autres bases de données de contenu pour l'application Web dans n'importe quel ordre. Vous n'avez pas besoin de créer de collections de sites pour le stockage du contenu avant d'ajouter la base de données ; ce processus crée les collections de sites automatiquement. Assurez-vous de ne pas ajouter de nouvelles collections de sites tant que vous n'avez pas restauré toutes les bases de données de contenu.

Important :
Si vous déplacez les bases de données de contenu d'un domaine à un autre, d'une forêt à une autre ou dans un autre environnement qui a des comptes de service différents, vérifiez que les comptes de service sont toujours corrects avant d'attacher les bases de données.

Vous pouvez utiliser l'applet de commande Mount-SPContentDatabase dans Windows PowerShell ou la commande Stsadm addcontentdb pour attacher une base de données de contenu à une application Web. Il est impossible d'utiliser les pages de l'Administration centrale SharePoint pour attacher une base de données de contenu dans le cadre d'une mise à niveau.

Assurez-vous que le compte que vous utilisez pour attacher les bases de données est membre du rôle de base de données fixe db_owner pour les bases de données de contenu que vous souhaitez mettre à niveau.

Important :
Si vous utilisiez l'authentification basée sur les formulaires, vous devrez configurer l'authentification par revendications pour votre application Web avant d'attacher des bases de données. Vous devez également créer une stratégie afin d'accorder un Contrôle total à l'application Web au compte d'utilisateur qui effectue la mise à niveau d'attachement de base de données.

Pour plus d'informations, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

Conseil :
Vous ne pouvez pas ajouter la même base de données de contenu plusieurs fois à une batterie de serveurs, même sur différentes applications Web. Chaque collection de sites dans une base de données de contenu a un GUID qui lui est associé et qui est inscrit dans la base de données de configuration. Par conséquent, vous ne pouvez pas ajouter la même collection de sites à deux reprises à la batterie de serveurs, même dans des applications Web distinctes. Bien que vous puissiez correctement attacher la base de données dans ce cas, vous ne pourrez pas démarrer la collection de sites.

Si vous avez besoin d'une copie dupliquée d'une collection de sites dans la même batterie de serveurs, attachez d'abord la base de données qui contient la collection de sites à une batterie de serveurs distincte, puis utilisez les opérations de sauvegarde et restauration de Stsadm pour copier la collection de sites vers l'autre batterie de serveurs. Le processus de sauvegarde et de restauration de Stsadm crée un nouveau GUID pour la collection de sites.

Pour attacher une base de données de contenu à une application Web à l'aide de Windows PowerShell

  1. Vérifiez que la configuration minimale requise suivante est satisfaite : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur Environnement de gestion SharePoint 2010.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Mount-SPContentDatabase -Name <DatabaseName> -DatabaseServer <ServerName> -WebApplication <URL> [-Updateuserexperience]

    Où :

    • <DatabaseName> est le nom de la base de données à mettre à niveau.

    • <ServerName> est le serveur sur lequel la base de données est stockée.

    • <URL> est l'URL de l'application Web qui hébergera les sites.

    • Updateuserexperience est le paramètre qui permet d'effectuer la mise à jour vers la nouvelle expérience utilisateur ou de conserver l'ancienne expérience utilisateur (dans le cadre de la mise à niveau visuelle). Lorsque vous incluez ce paramètre, le site est configuré de façon à fournir un aperçu de la nouvelle expérience utilisateur. Omettez-le si vous souhaitez que le site conserve l'ancienne expérience utilisateur après la mise à niveau. Pour plus d'informations, voir Planifier une mise à niveau visuelle (SharePoint Foundation 2010).

Pour plus d'informations, voir Mount-SPContentDatabase.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour attacher une base de données de contenu à une application Web à l'aide de l'outil en ligne de commande Stsadm

  1. Sur le lecteur sur lequel les Produits et technologies SharePoint sont installés, naviguez jusqu'au répertoire suivant : %COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\12\Bin.

  2. Tapez la commande suivante, puis appuyez sur Entrée :

    stsadm -o addcontentdb -url <URL> -databasename <nom_base_de_données>

    [-databaseserver <nom_serveur>] [-databaseuser <nom_utilisateur>]

    [-databasepassword <mot de passe>] [-sitewarning <nombre de sites avant avertissement>]

    [-preserveolduserexperience true/false ]

    [-sitemax <nombre maximal de sites>]

    [-assignnewdatabaseid] [-clearchangelog]

    Remarque :
    Lorsque vous affectez la valeur true au paramètre preserveolduserexperience, les sites de la base de données de contenu conservent le même aspect que dans la version antérieure après la mise à niveau. Lorsque vous lui affectez la valeur false, les sites sont mis à niveau avec le nouvel aspect. La valeur par défaut pour ce paramètre est true, qui préserve l'ancien aspect.

    Ce paramètre fait partie de la fonctionnalité de mise à niveau visuelle. Pour plus d'informations, voir Planifier une mise à niveau visuelle (SharePoint Foundation 2010).

    Pour plus d'informations sur cette opération, voir Addcontentdb : opération Stsadm (Windows SharePoint Services).

Vérification : contrôler la mise à niveau pour la première base de données

Après avoir attaché une base de données, vous pouvez utiliser la page État de la mise à niveau dans l'Administration centrale pour vérifier l'état de la mise à niveau de vos collections de sites. Une fois le processus de mise à niveau terminé, vous pouvez consulter le fichier journal de mise à niveau pour voir si des problèmes se sont produits lors de la mise à niveau. Examinez aussi chaque site mis à niveau pour rechercher et traiter les problèmes susceptibles d'affecter l'affichage du contenu. Pour plus d'informations, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010).

Pour afficher la page État de la mise à niveau

  • Dans l'Administration centrale, cliquez sur Mise à niveau et migration, puis cliquez sur Vérifier l'état de la mise à niveau.

Pour ouvrir le fichier journal de mise à niveau

  • Le fichier journal des erreurs de mise à niveau et le fichier journal de mise à niveau sont disponibles à l'emplacement %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\14\LOGS. Les fichiers sont nommés selon le format suivant : Upgrade-AAAAMMJJ-HHMMSS-SSS-error.log et Upgrade-AAAAMMJJ-HHMMSS-SSS.log, où AAAAMMJJ est la date et HHMMSS-SSS est l'heure (heures au format 24 heures, minutes, secondes et millisecondes). « Upgrade-20090415-132126-374-error.log » est un exemple de fichier journal d'erreurs de mise à niveau et « Upgrade-20090415-132126-374.log » est un exemple de fichier journal de mise à niveau.

    Remarque :
    Le fichier journal de mise à niveau inclut le nom de la base de données de contenu mise à niveau.

Attacher les bases de données restantes

Une fois que vous avez restauré la première base de données de contenu et vérifié la mise à niveau en consultant le fichier journal de mise à niveau, vous pouvez continuer en restaurant et en mettant à niveau la ou les bases de données suivantes. Vous pouvez attacher plusieurs bases de données en même temps dans des fenêtres d'invite de commandes distinctes pour exécuter plusieurs mises à niveau en même temps. Une fois que vous avez correctement restauré et mis à niveau toutes les bases de données de contenu, vous pouvez consulter les sites afin de vous assurer qu'ils ont été mis à niveau.

Vérification : contrôler la mise à niveau pour les bases de données supplémentaires

Après avoir mis à niveau les bases de données supplémentaires éventuelles, affichez la page État de la mise à niveau pour surveiller la progression et vérifier que le processus de mise à niveau est terminé. Examinez le fichier journal pour identifier les problèmes éventuels, puis examinez chaque site mis à niveau pour rechercher et traiter les problèmes susceptibles d'affecter l'affichage du contenu. Pour plus d'informations, voir Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010) et Gérer une mise à niveau visuelle (SharePoint Foundation 2010).

Voir aussi

Concepts

Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010)

Historique des modifications


Effectuer les étapes postérieures à la mise à niveau (SharePoint Foundation 2010)

Après avoir effectué une mise à niveau sur place ou une mise à niveau avec liaison des bases de données vers Microsoft SharePoint Foundation 2010, vous pouvez vérifier votre mise à niveau et suivre les étapes de configuration nécessaires pour mettre de nouveau votre environnement à la disposition de vos utilisateurs.

Dans cette section :

  • Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010)

    Mettez à niveau les applications Web Windows SharePoint Services 3.0 existantes qui étaient configurées pour utiliser l'authentification par formulaire afin qu'elles fonctionnent avec SharePoint Foundation 2010.

  • Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010)

    Découvrez comment vous assurer que la mise à niveau s'est déroulée correctement (aussi bien du point de vue logiciel que d'une observation de vos sites) ou s'il reste des problèmes à résoudre. Si vous devez redémarrer la mise à niveau à la suite d'un problème, vous trouverez les explications nécessaires dans cet article.

  • Récupération après un échec de mise à niveau (SharePoint Foundation 2010)

    Si la mise à niveau vers Microsoft SharePoint Foundation 2010 a échoué et que vous n'avez pas le temps de continuer à résoudre les problèmes ou de reprendre le processus de mise à niveau, procédez comme suit.

Historique des modifications


Vérifier la mise à niveau et passer en revue les sites mis à niveau (SharePoint Foundation 2010)
Voir aussi

Après avoir réalisé une mise à niveau sur place ou une mise à niveau avec attachement des bases de données vers Microsoft SharePoint Foundation 2010, vous devez vérifier que le contenu a été correctement mis à niveau vers la nouvelle version. Vous pouvez vérifier l'état de la mise à niveau (est-elle en cours de réalisation, ou bien s'est-elle déroulée correctement ou s'est-elle terminée sur des erreurs ou des échecs ?), puis également réviser les sites mis à niveau pour déterminer s'il reste des problèmes à résoudre. Lorsque vous suivez ces étapes dans le cadre d'une mise à niveau d'évaluation, vous pouvez en profiter pour identifier les personnalisations à modifier avant de procéder à la mise à niveau de l'environnement de production. Lorsque vous mettez à niveau votre environnement de production, il est d'autant plus primordial de savoir à quel moment la mise à niveau a été achevée, quels sites ont été correctement mis à niveau et quels sites doivent être retravaillés avant de les rendre de nouveau accessibles aux utilisateurs.

Dans certains cas, vous pouvez être amené à redémarrer la mise à niveau pour finir de mettre vos sites à niveau. Pour plus d'informations sur le redémarrage de la mise à niveau, voir Reprendre la mise à niveau (SharePoint Foundation 2010).

Dans cet article :

  • Vérifier l'état de la mise à niveau

  • Examiner les sites mis à niveau

Vérifier l'état de la mise à niveau

Le processus de mise à niveau se compose de plusieurs phases. Dans le cas d'une mise à niveau sur place, vous exécutez Setup.exe pour installer les nouveaux logiciels, puis vous exécutez l'Assistant Configuration des produits SharePoint pour mettre à niveau la base de données de configuration et la base de données de contenu d'administration ; ces opérations se traduisent par l'ouverture du site Web Administration centrale de SharePoint. À ce stade, le processus de mise à niveau de contenu démarre. Vous pouvez vérifier l'état du processus de mise à niveau pendant chacune de ces phases de différentes façons : vous pouvez consulter les fichiers journaux liés à Setup.exe, à l'Assistant Configuration des produits SharePoint et à la mise à niveau de contenu. Dans l'Administration centrale de SharePoint, vous pouvez afficher le numéro de version afin de vous assurer qu'il est correct pour la version vers laquelle vous avez effectué la mise à niveau. En outre, vous pouvez utiliser la page État de la mise à niveau de l'Administration centrale de SharePoint ou l'opération localupgradestatus dans Stsadm pour déterminer les sites qui ont été, ou qui sont en train d'être, mis à niveau. Si la mise à niveau ne s'est pas déroulée correctement, vous pouvez afficher les fichiers journaux pour rechercher les problèmes, les résoudre, puis redémarrer le processus de mise à niveau.

Passer en revue les fichiers journaux

Pour vérifier si la mise à niveau a réussi, vous pouvez consulter les fichiers journaux et des erreurs suivants :

  • Le fichier journal Setup.exe de SharePoint Foundation 2010.

    Le fichier journal de l'installation est stocké dans le répertoire temporaire du compte d'utilisateur qui exécute le programme d'installation (%USERTEMP% ou %WINDIR%\Users\user account\AppData\Local\Temp). Il est nommé SharePoint Foundation Setup(AAAAMMDD-HHMMSS-SSS).log, où AAAAMMDD est la date et HHMMSS-SSS est l'heure (heures au format 24 heures, minutes, secondes et millisecondes).

  • Le fichier journal de l'Assistant Configuration des produits SharePoint (Psconfig.exe).

    Le fichiers journaux Psconfig.exe se trouvent dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\14\LOGS. Leur nom respecte la syntaxe suivante : PSCDiagnostics_MM_JJ_AAAA_HH_MM_SS_SSS_nombre_aléatoire.log, où MM_JJ_AAAA correspond à la date, HH_MM_SS_SSS à l'heure (heures au format horaire de 24 heures, minutes, secondes et millisecondes) et nombre_aléatoire au nombre aléatoire permettant de distinguer d'éventuelles tentatives simultanées d'exécution du programme Psconfig.exe.

  • Le fichier journal de mise à niveau et le fichier journal des erreurs de mise à niveau.

    Le fichier journal de mise à niveau et le fichier journal des erreurs de mise à niveau sont situés à l'emplacement %COMMONPROGRAMFILES%\Microsoft Shared\Web server extensions\14\LOGS. Les fichiers sont nommés selon le format suivant : Upgrade-AAAAMMJJ-HHMMSS-SSS-error.log et Upgrade-AAAAMMJJ-HHMMSS-SSS.log, où AAAAMMJJ est la date et HHMMSS-SSS est l'heure (heures au format 24 heures, minutes, secondes et millisecondes). Le fichier journal des erreurs de mise à niveau combine la totalité des erreurs et des avertissements dans un fichier de taille plus petite et se nomme Upgrade-AAAAMMJJ-HHMMSS-SSS-error.log.

Pour passer en revue les fichiers journaux afin d'identifier et de corriger les problèmes, démarrez en haut des fichiers. Les erreurs ou les avertissements peuvent être répétés s'ils se produisent dans plusieurs collections de sites au sein de l'environnement, ou s'ils bloquent complètement le processus de mise à niveau. Par exemple, si vous ne pouvez pas vous connecter à la base de données de configuration, le processus de mise à niveau essaiera (et échouera) plusieurs fois et ces tentatives seront listées dans le fichier journal.

Pour passer en revue les fichiers journaux

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour afficher les fichiers journaux, vous devez appartenir au groupe Administrateurs local du serveur.

  2. Dans l'Explorateur Windows, accédez au répertoire qui contient le fichier journal à afficher.

  3. Ouvrez le fichier journal dans un éditeur de texte.

  4. Dans le fichier journal de mise à niveau, recherchez ou analysez visuellement, l'entrée suivante :

    Upgrade session finished successfully!

    Si vous trouvez cette entrée, l'installation a réussi.

  5. Si vous ne trouvez pas les entrées de l'étape précédente dans le fichier journal de mise à niveau ou si vous consultez l'un des autres fichiers journaux, vous pouvez identifier les problèmes spécifiques qui ont contribué à un échec en recherchant, ou en analysant visuellement dans le fichier, les termes suivants :

    • Recherchez Erreur dans les fichiers journaux pour détecter les éventuels problèmes (tels que des composants défectueux et des connexions de base de données défectueuses).

    • Recherchez Avertissement pour détecter les problèmes comme des fonctionnalités ou des composants manquants.

Pour détecter les problèmes, un analyseur de fichier journal peut vous être utile afin d'exécuter des requêtes sur les fichiers journaux.

Si vous détectez des problèmes bloquants dans le fichier journal, vous pouvez les résoudre, puis redémarrer la mise à niveau pour poursuivre le processus.

Vérifier le numéro de version

Outre afficher le fichier journal de mise à niveau, vous pouvez vous assurer que la mise à niveau a réussi en affichant le numéro de version sur la page Serveurs de la batterie par le biais du site Web Administration centrale de SharePoint.

Pour vérifier le numéro de version sur la page Serveurs de la batterie

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour utiliser l'Administration centrale de SharePoint, vous devez être membre du groupe Administrateurs de batterie.

  2. Sur la page d'accueil Administration centrale, sous Paramètres système, cliquez sur Gérer les serveurs de cette batterie.

  3. Sous Informations sur la batterie de serveurs, en regard de Version de la base de données de configuration, vérifiez que le numéro commence par « 14 ».

Vérifier l'état de la mise à jour sur les sites

Pour déterminer les sites qui ont été mis à niveau ou qui sont en train de l'être, vous pouvez utiliser la page État de la mise à niveau dans l'Administration centrale de SharePoint ou l'opération localupgradestatus dans Stsadm.exe.

La page État de la mise à niveau répertorie les sessions de mise à niveau et fournit des détails sur l'état de chaque session : issue de celle-ci (réussite ou échec) et nombre d'erreurs ou d'avertissements qui se sont produits pour chaque serveur. En outre, la page État de la mise à niveau comprend des informations sur les fichiers journaux et des erreurs pour le processus de mise à niveau et suggère des solutions aux problèmes qui ont pu se produire.

Pour déterminer les sites qui ont été manqués ou ignorés pendant la mise à niveau, vous pouvez utiliser l'opération localupgradestatus dans Stsadm.exe. Vous devez exécuter la commande sur chaque serveur Web frontal d'une batterie de serveurs.

Pour afficher l'état de la mise à niveau dans l'Administration centrale de SharePoint

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour utiliser l'Administration centrale de SharePoint, vous devez être membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil Administration centrale, sous Mise à niveau et migration, cliquez sur Vérifier l'état de la mise à niveau.

Pour afficher l'état de la mise à niveau à partir de la ligne de commande

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour utiliser Stsadm, vous devez appartenir au groupe Administrateurs locaux du serveur.

  2. Cliquez sur Démarrer, cliquez avec le bouton droit sur Invite de commandes, puis cliquez sur Exécuter en tant qu'administrateur.

  3. Dans la fenêtre Invite de commandes, accédez au répertoire suivant :

    %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\bin

  4. Tapez la commande suivante, puis appuyez sur Entrée :

    Stsadm -o localupgradestatus

Pour plus d'informations sur l'opération localupgradestatus, voir Localupgradestatus : opération Stsadm (Windows SharePoint Services).

Examiner les sites mis à niveau

Examinez les sites mis à niveau pour identifier les problèmes à résoudre avant d'exécuter le processus de mise à niveau sur votre environnement de production. Si vous avez effectué une mise à niveau sur place et opté pour une mise à niveau visuelle, vous pouvez utiliser la fonctionnalité Mise à niveau visuelle pour avoir un aperçu des sites avec la nouvelle interface utilisateur. Pour plus d'informations sur l'aperçu des sites à l'aide de la mise à niveau visuelle, voir Gérer une mise à niveau visuelle (SharePoint Foundation 2010).

Pour vérifier les fonctionnalités de base, vous pouvez créer une collection de sites en utilisant un jeu représentatif de listes, de bibliothèques, de composants WebPart, etc. Passez en revue le nouveau site pour vérifier le bon fonctionnement des éléments de base communs à vos sites.

Si des pages ne s'affichent pas, vous pouvez vérifier les paramètres du site en accédant directement à l'URL (http:// url_site/_layouts/settings.aspx). Si la page des paramètres du site fonctionne et que la mise à niveau s'effectue correctement, il se peut qu'il y ait des problèmes avec la page maître ou la page d'accueil. Si la page des paramètres du site ne fonctionne pas, accédez au fichier journal pour obtenir plus d'informations sur le problème.

Commencez par valider les sites au profil élevé et à fort impact, puis passez aux sites de moindre importance. Dans le cadre du processus de planification, vous devez avoir identifié les sites au profil élevé et à fort impact qui requièrent une attention immédiate, ainsi que les sites qui peuvent être mis en attente.

Utilisez les listes de vérification suivantes pour passer en revue vos sites mis à niveau et rechercher les problèmes.

Composants WebPart

Le tableau suivant répertorie les problèmes de composants WebPart qui peuvent survenir après une mise à niveau, ainsi que leur mode de résolution.

Conseil :
Pour tester rapidement vos composants WebPart, vous pouvez créer une page de composants WebPart qui contient tous vos composants WebPart personnalisés avant de tester votre mise à niveau, puis vérifier si des composants WebPart font défaut ou sont rompus dans la page après la mise à niveau d'évaluation.

Éléments à vérifier Procédure à suivre en cas de problème

Tous les composants WebPart de votre site d'origine s'affichent-ils dans votre site mis à niveau ?

S'il existe une zone de composants WebPart dans une page personnalisée (incarnée), mais pas dans la définition de site, les composants WebPart de cette zone ont peut-être été déplacés vers la zone inférieure de la page au cours de la mise à niveau.

En mode Édition de la page dans le navigateur ou dans Microsoft SharePoint Designer 2010, recherchez les composants WebPart manquants dans la zone inférieure ou dans les autres zones, ou bien vérifiez si les composants WebPart ont été fermés. Pour plus d'informations sur l'utilisation des composants WebPart et des zones de composants WebPart dans SharePoint Designer 2010, voir le système d'aide de SharePoint Designer.

Les composants WebPart sont-ils affichés correctement (dans la zone correcte, à l'emplacement approprié et dans la taille adéquate) ?

En mode Édition de la page dans le navigateur ou dans SharePoint Designer 2010, faites glisser le composant WebPart vers la zone adéquate ou modifiez ses propriétés afin de corriger les problèmes de dimensionnement ou de positionnement.

Y a-t-il un nombre excessif ou insuffisant de composants WebPart ?

Ouvrez la page en mode Édition dans le navigateur ou dans SharePoint Designer 2010. Si vous constatez la présence de composants WebPart supplémentaires dans la page, recherchez les composants WebPart fermés ou inactifs dans la version d'origine de la page. Ces composants ont-ils été ouverts par le processus de mise à niveau ? Si tel est le cas, vous pouvez modifier les propriétés des composants WebPart pour fermer ces composants.

Si des composants WebPart sont manquants, recherchez les erreurs dans SharePoint Designer 2010, par exemple « Erreur de rendu du contrôle » ou « Assembly manquant ». Ces erreurs indiquent que le composant WebPart n'a pas été installé ou configuré correctement pour le nouvel environnement et qu'il doit être réinstallé ou reconfiguré.

Les composants WebPart fonctionnent-ils correctement ?

Ouvrez la page en mode Édition dans le navigateur ou dans SharePoint Designer 2010, puis recherchez les erreurs indiquant qu'un composant ou service est manquant. Vérifiez que tous les composants ou services sur lesquels reposent les composants WebPart existent dans le site mis à niveau. Dans le cadre d'une mise à niveau avec attachement des bases de données, vous devez notamment vous assurer que vous avez installé tous les composants ou services nécessaires pour vos composants WebPart et que vous les avez configurés correctement (par exemple, la liste des contrôles sécurisés dans le fichier Web.config).

Mettez à jour et redéployez les composants WebPart qui existent mais qui ne fonctionnent plus correctement.

Conseil :
Si vous avez des problèmes avec un composant WebPart, ajoutez contents=1 à la fin de la syntaxe de l'URL (http:// siteurl/default.aspx?contents=1), puis appuyez sur Entrée. Vous accédez ainsi à la page de maintenance des composants WebPart dans laquelle vous pouvez supprimer ou réparer le composant WebPart.

Grandes listes

Par défaut, la limitation de requête de grande liste est appliquée après une mise à niveau vers SharePoint Foundation 2010. Si une liste est très grande et que les utilisateurs recourent à une vue ou exécutent une requête qui dépasse la limite ou le seuil de limitation, la vue ou requête ne sera pas autorisée. Vérifiez toutes les grandes listes dans votre environnement et invitez le propriétaire de site ou le propriétaire de liste à résoudre le problème. Par exemple, ils peuvent créer des colonnes indexées à l'aide de vues filtrées, organiser les éléments en dossiers, définir une limite d'éléments sur la page pour une grande vue ou utiliser une liste externe.

Styles et apparence

Le tableau suivant répertorie les problèmes usuels relatifs au style et à l'apparence de votre site Web après une mise à niveau, ainsi que leur mode de résolution.

Conseil :
Vous pouvez résoudre la plupart des problèmes abordés dans cette section en corrigeant les liens vers un élément.

Éléments à vérifier | Procédure à suivre en cas de problème
Toutes les images de vos pages sont-elles affichées correctement ? | Vérifiez ou corrigez les liens vers les images.
Les couleurs et styles de feuilles de style en cascade adéquats sont-ils utilisés aux emplacements appropriés ? | Vérifiez ou corrigez les liens vers le fichier de feuilles de style en cascade. Vérifiez le lien sur la page maître.
Le thème que vous avez appliqué à votre site présente-t-il la même apparence ? | La page d'accueil ou d'autres pages de votre site peuvent présenter un aspect différent après la mise à niveau du site. Vous devrez peut-être recréer ou modifier un thème, et le réappliquer.
Existe-t-il des contrôles de script qui ne fonctionnent pas ? | Vérifiez ou corrigez les liens vers les contrôles.
Vos pages sont-elles affichées correctement dans Windows Internet Explorer 8 ? | Assurez-vous que le contenu HTML de la page est strictement en mode XHTML.
Des erreurs de script apparaissent-elles dans des pages ? | Vérifiez les scripts et les liens, puis assurez-vous que le contenu HTML est strictement en mode XHTML.

Autorisations

Les personnes et les groupes appropriés disposent-ils toujours du niveau d'autorisations adéquat sur les sites, les pages, les listes et les éléments ?

Vous pouvez utiliser le bouton Vérifier les autorisations de la section Outils d'autorisation du Ruban pour déterminer qui dispose de quelles autorisations sur quels éléments dans un site ou sous-site.

Pages personnalisées (incarnées)

Les pages personnalisées (incarnées) sont des pages qui ont été modifiées et qui sont maintenant des versions uniques des pages au lieu de pages de modèles par défaut.

Éléments à vérifier Procédure à suivre en cas de problème

Vos personnalisations sont-elles toujours aux emplacements appropriés ?

Déterminez si vous n'avez qu'un seul problème ou un problème plus important pour l'ensemble de la page.

Si vous avez ajouté une toute nouvelle page à votre site d'origine (par exemple, si vous avez remplacé Default.aspx par un autre fichier au lieu de modifier le fichier Default.aspx existant), cette page ne comporte aucune association à la définition de site. Par conséquent, elle risque de ne pas ressembler aux autres pages du site mis à niveau ni être réinitialisée à cette fin. Pour donner à votre page personnalisée le même aspect que les autres pages de votre site, créez une page basée sur la définition du site et transférez-y vos personnalisations.

Pouvez-vous toujours accéder aux contrôles d'édition dans les pages ?

Si vous avez personnalisé les contrôles d'édition (par exemple le lien Actions du site ou Modifier la page), vérifiez s'ils s'affichent toujours. Si tel est le cas, remplacez-les par les contrôles d'édition de la nouvelle version en rétablissant la page à la version par défaut.

Utilisez la commande Rétablir le modèle de SharePoint Designer pour rétablir la page à la version par défaut (opération également appelée réinitialisation). Après avoir restauré la page par défaut, vous pouvez réappliquer vos personnalisations dans le navigateur en appliquant une autre page maître ou en réappliquant les personnalisations dans SharePoint Designer.

Vos personnalisations sont-elles toujours appropriées dans le nouvel environnement ou souhaitez-vous effectuer une mise à niveau vers les nouvelles fonctionnalités et la nouvelle apparence ?

Si vous souhaitez bénéficier des nouvelles fonctionnalités, vous devez rétablir toutes les pages personnalisées afin d'utiliser le modèle. À la base, le rétablissement d'une page ignore les personnalisations et attache votre page à la page maître appropriée. Toutes les personnalisations souhaitées peuvent ensuite être transférées vers la page maître au lieu d'être stockées dans des pages individuelles.

Utilisez la commande Rétablir le modèle de SharePoint Designer pour rétablir la page à la version par défaut (c'est-à-dire la réinitialiser). Après avoir restauré la page par défaut, vous pouvez réappliquer vos personnalisations dans le navigateur en appliquant une autre page maître ou en réappliquant les personnalisations dans SharePoint Designer.

Des pages sont-elles toujours extraites ?

Si vous extrayez une page pour effectuer des modifications, veillez à l'archiver à nouveau.

Voir aussi

Concepts

Reprendre la mise à niveau (SharePoint Foundation 2010)
Résoudre les problèmes de mise à niveau (SharePoint Foundation 2010)

Historique des modifications


Gérer une mise à niveau visuelle (SharePoint Foundation 2010)
Voir aussi

Cet article présente les procédures relatives à la fonctionnalité de mise à niveau visuelle. Lorsque vous procédez à une mise à niveau de Windows SharePoint Services 3.0 vers Microsoft SharePoint Foundation 2010, vous pouvez choisir d'utiliser la fonctionnalité de mise à niveau visuelle pour donner la possibilité aux propriétaires de collections de sites et de sites de conserver provisoirement l'interface utilisateur précédente. Cela leur permet de mettre à jour les personnalisations pour qu'elles fonctionnent dans la nouvelle interface utilisateur. Pour obtenir une description complète de la mise à niveau visuelle et des choix associés, voir Planifier une mise à niveau visuelle (SharePoint Foundation 2010).

Dans cet article :

  • À propos de la mise à niveau visuelle

  • Consulter l'état de l'interface utilisateur active

  • Rétablir l'interface utilisateur précédente des sites

  • Forcer une mise à niveau vers la nouvelle interface utilisateur

  • Options de mise à niveau visuelle à la disposition des propriétaires de sites

À propos de la mise à niveau visuelle

Lorsque vous effectuez une mise à niveau, que ce soit à l'aide de la méthode de mise à niveau sur place ou de la méthode de mise à niveau par attachement de base de données, vous pouvez choisir d'utiliser la mise à niveau visuelle.

Lors d'une mise à niveau sur place, vous faites le choix d'utiliser la mise à niveau visuelle dans une étape de l'Assistant Configuration des produits SharePoint. La fonctionnalité de mise à niveau visuelle n'est pas disponible dans l'Assistant Configuration des produits SharePoint si vous effectuez une mise à niveau sur un serveur autonome à l'aide de la base de données intégrée. En revanche, cette même fonctionnalité est disponible dans le même cas via l'outil de ligne de commande Psconfig. Vous pouvez donc utiliser la syntaxe suivante : psconfig.exe -cmd upgrade [-preserveolduserexperience <true|false>].

Lors d'une mise à niveau par attachement de base de données, le choix de passer à la nouvelle expérience utilisateur ou de conserver l'ancienne se fait en utilisant soit :

  • le paramètre Updateuserexperience de l'applet de commande Mount-SPContentDatabase de Windows PowerShell,

  • soit le paramètre preserveolduserexperience de l'opération addcontentdatabase de l'outil Stsadm.

Pour plus d'informations sur l'utilisation de ces paramètres lors d'une mise à niveau, voir Attacher les bases de données et effectuer une mise à niveau vers SharePoint Foundation 2010.

Consulter l'état de l'interface utilisateur active

Vous pouvez consulter l'état de l'interface utilisateur active en générant une liste de tous les sites Web d'une collection de sites et leurs données de mise à niveau visuelle correspondantes. Cela s'avère utile si vous avez fixé un délai limite aux propriétaires de sites pour préparer leurs sites à la nouvelle interface utilisateur et que vous souhaitez contrôler leur progression. La procédure suivante montre comment consulter l'état de l'interface utilisateur active.

Pour consulter l'état de l'interface utilisateur active à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    $sc = Get-SPSite http://machinename/sites/collectionname; $sc.GetVisualReport() | Format-Table

Pour plus d'informations, voir Get-SPSite.

Rétablir l'interface utilisateur précédente des sites

Si le propriétaire d'une collection de sites ou d'un site finalise la nouvelle interface utilisateur par erreur, ou s'il ne parvient pas à solutionner un problème, vous pouvez rétablir l'interface utilisateur précédente via Windows PowerShell. Cette procédure montre comment rétablir l'interface utilisateur précédente d'un ou de tous les sites d'une collection de sites.

Pour rétablir l'interface utilisateur précédente de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Pour rétablir l'interface utilisateur précédente d'un site spécifique, à l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPSite http://machinename/sites/V3UI | Get-SPWeb "webname" | Foreach{$_.UIVersionConfigurationEnabled=1;$_.UIVersion=3;$_.Update();}

    Pour rétablir l'interface utilisateur précédente de tous les sites d'une collection de sites, à l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPSite http://machinename/sites/V3UI | Foreach{$_. UIVersionConfigurationEnabled=1;$_.UIVersion=3;$_.Update();}

Pour plus d'informations, voir Get-SPSite.

Forcer une mise à niveau vers la nouvelle interface utilisateur

Si vous souhaitez imposer la nouvelle interface utilisateur à la suite d'une mise à niveau, vous avez tout intérêt à accorder un certain laps de temps aux propriétaires de collections de sites ou de sites pour qu'ils examinent la nouvelle interface utilisateur et qu'ils corrigent les problèmes éventuels. Lorsque vous imposez une mise à niveau vers la nouvelle interface utilisateur, vous pouvez utiliser un script ou utiliser l'Assistant Configuration des produits SharePoint lors de la mise à niveau initiale. Pour plus d'informations sur la mise à niveau et l'Assistant Configuration des produits SharePoint, voir Exécuter l'Assistant Configuration des produits SharePoint. La procédure suivante montre comment mettre à niveau par programme l'ensemble des collections de sites et des sites vers la nouvelle interface utilisateur.

Pour forcer une mise à niveau vers la nouvelle interface utilisateur à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    $webapp = Get-SPWebApplication http://sitename
    Code de copie
    foreach ($s in $webapp.sites)
    Code de copie
    {$s.VisualUpgradeWebs() }

Pour plus d'informations, voir Get-SPWebApplication

Pour mettre à niveau une collection de sites donnée vers la nouvelle interface utilisateur, tapez les commandes suivantes à l'invite de commandes Windows PowerShell :

Code de copie
$site = Get-SPSite http://server
Code de copie
$site.VisualUpgradeWebs()

Pour mettre à niveau un site donné vers la nouvelle interface utilisateur, tapez les commandes suivantes à l'invite de commandes Windows PowerShell :

Code de copie
$web = Get-SPWeb http://server/site
Code de copie
$web.UIVersion = 4
Code de copie
$web.UIVersionConfigurationEnabled = 0
Code de copie
$web.Update()

Options de mise à niveau visuelle à la disposition des propriétaires de sites

Le propriétaire d'un site peut utiliser l'interface utilisateur Paramètres du site pour basculer entre les options Utiliser l'interface utilisateur précédente et Aperçu de l'interface utilisateur mise à jour. Dès lors que le propriétaire de site est satisfait de l'aspect du site, il peut finaliser la nouvelle interface utilisateur en sélectionnant l'option Mettre à jour l'interface utilisateur.

Le tableau suivant décrit les différentes options de mise à niveau qu'un propriétaire de site peut choisir pour son ou ses sites. Les modes de mise à niveau sont disponibles dans la page Paramètres du site, dans la section Titre, description et icône.

Type de mode | Description
Utiliser l'interface utilisateur précédente | Les propriétaires de sites utilisent ce mode pour que tous leurs sites utilisent l'interface de Windows SharePoint Services 3.0.
Aperçu de l'interface utilisateur mise à jour | Les propriétaires de sites utilisent ce mode pour examiner la façon dont leurs sites se présenteraient et fonctionneraient dans la nouvelle interface. Lorsque ce mode est choisi, les fonctionnalités de la version précédente de l'interface ne sont plus disponibles.
Mettre à jour l'interface utilisateur | Les propriétaires de sites utilisent cette option lorsqu'ils sont satisfaits des changements et sont disposés à adopter la nouvelle interface utilisateur. Si nécessaire, un administrateur peut rétablir la version précédente de l'interface utilisateur.

Voir aussi

Concepts

Planifier une mise à niveau visuelle (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
10 juin 2010 | 2010/06/07 | Mise à jour du contenu


Utilisation de redirection d'URL AAM dans le processus de mise à niveau (SharePoint Foundation 2010) (livre blanc)

Ce livre blanc décrit les activités de planification dont vous avez besoin pour correctement déployer et utiliser la fonctionnalité de redirection des URL de mappage des accès de substitution (AAM) dans Microsoft SharePoint Foundation 2010 pour réduire les temps d'arrêt au cours de la mise à niveau d'un ordinateur serveur ou d'une batterie de serveurs. Il décrit également les procédures nécessaires pour effectuer la configuration de cette fonctionnalité en modifiant les ordinateurs serveurs Windows SharePoint Services 3.0 existants.

Important :
Le processus décrit dans ce livre blanc est une technique avancée pour éviter les temps d'arrêt au cours des mises à niveau. Il doit être utilisé uniquement si d'autres techniques, telles que les bases de données en lecture seule et la mise à niveau sur place avec bases de données détachées, risquent d'entraîner une trop longue période d'indisponibilité pour vos utilisateurs. N'envisagez l'utilisation de cette technique que si vous savez votre processus de mise à niveau prendra plus d'un long week-end. Si la mise à niveau n'est pas susceptible de prendre tout ce temps, les procédures décrites dans ce document ne vous feront pas gagner du temps. Pour plus d'informations sur d'autres approches de mise à niveau, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Télécharger ce livre blanc au format Microsoft Word document (.doc). (http://go.microsoft.com/fwlink/?linkid=168857&clcid=0x40C)

Télécharger ce livre blanc au format fichier PDF. (http://go.microsoft.com/fwlink/?linkid=168858&clcid=0x40C)

Historique des modifications


Migrer de l'authentification basée sur les formulaires à l'authentification basée sur les revendications (SharePoint Foundation 2010)
Voir aussi

Les procédures de cet article fournissent des instructions pour vous aider à migrer des applications Web Windows SharePoint Services 3.0 existantes qui ont été configurées de façon à utiliser l'authentification basée sur les formulaires de sorte qu'elles fonctionnent dans un environnement Microsoft SharePoint Foundation 2010 comme applications Web basées sur les revendications.

Après la mise à niveau vers SharePoint Foundation 2010, les applications Web mises à niveau conservent la méthode d'ouverture de session qui étaient utilisées par les applications Windows SharePoint Services 3.0. Les applications Web Windows SharePoint Services 3.0 qui étaient configurées de façon à utiliser l'authentification Windows ne nécessitent aucune étape supplémentaire pour la mise à jour. Néanmoins, vous devez convertir les applications Windows SharePoint Services 3.0 qui étaient configurées de façon à utiliser l'authentification basée sur les formulaires de sorte qu'elles utilisent l'authentification basée sur les revendications pour que les applications Web Windows SharePoint Services 3.0 puissent être utilisées dans SharePoint Foundation 2010. Après avoir converti les applications Web Windows SharePoint Services 3.0 en authentification basée sur les revendications, configurez les zones d'applications Web pour l'authentification basée sur les formulaires. La dernière étape consiste à migrer les utilisateurs et les autorisations vers SharePoint Foundation 2010. Cet article fournit les procédures suivantes pour effectuer la migration des applications Web :

  • Convertir des applications Web Windows SharePoint Services 3.0 qui utilisent l'authentification basée sur les formulaires de sorte qu'elles utilisent l'authentification basée sur les revendications

  • Migrer les utilisateurs et les autorisations depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010

Convertir des applications Web Windows SharePoint Services 3.0 qui utilisent l'authentification basée sur les formulaires de sorte qu'elles utilisent l'authentification basée sur les revendications

Effectuez les étapes de la procédure suivante pour convertir des applications Web existantes en authentification basée sur les revendications à l'aide de Windows PowerShell.

Pour convertir des applications Web en authentification par revendications

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez le texte suivant :

    Code de copie
    $w = Get-SPWebApplication "http://<server>/"
$w.UseClaimsAuthentication = 1
$w.Update()

$w.ProvisionGlobally()
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Migrer les utilisateurs et les autorisations depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010

Effectuez les étapes de la procédure suivante pour migrer les utilisateurs et les autorisations à l'aide de Windows PowerShell.

Pour migrer les utilisateurs et les autorisations depuis Windows SharePoint Services 3.0 vers SharePoint Foundation 2010

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez le texte suivant :

    Code de copie
    $w = Get-SPWebApplication "http://<server>/"
$w.MigrateUsers(True)
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
23 septembre 2010 | Publication initiale |


Migrer de l'authentification en mode classique à l'authentification basée sur les revendications (SharePoint Foundation 2010)

Les procédures de cet article ont pour but de vous aider à migrer des applications Web Microsoft SharePoint Foundation 2010 existantes qui ont été configurées de façon à utiliser l'authentification en mode classique de sorte qu'elles utilisent l'authentification basées sur les revendications. Ceci peut être nécessaire si vous souhaitez implémenter une méthode d'authentification autre que l'authentification Windows (par exemple si vous voulez créer une application Web qui prend en charge l'authentification basée sur les formulaires). Pour plus d'informations, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010).

Avertissement :
Après avoir migré une application Web vers l'authentification basée sur les revendications, il est impossible de revenir à l'authentification en mode classique.

Convertir des applications Web SharePoint Foundation 2010 qui utilisent l'authentification en mode classique de sorte qu'elles utilisent l'authentification basées sur les revendications

Effectuez les étapes de la procédure suivante pour convertir des applications Web existantes en authentification basée sur les revendications à l'aide de Windows PowerShell.

Pour convertir des applications Web en authentification par revendications

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez le texte suivant :

    Code de copie
    $WebAppName = "http:// yourWebAppUrl"
$account = "yourDomain\yourUser"
$wa = get-SPWebApplication $WebAppName

Set-SPwebApplication $wa -AuthenticationProvider (New-SPAuthenticationProvider) -Zone Default

  6. À l'invite Migration, cliquez sur Oui pour continuer.

  7. À l'invite de commandes Windows PowerShell, tapez ce qui suit pour définir l'utilisateur comme administrateur du site :

    Code de copie
    $wa = get-SPWebApplication $WebAppName
$account = (New-SPClaimsPrincipal -identity $account -identitytype 1).ToEncodedString()

  8. À l'invite de commandes Windows PowerShell, tapez ce qui suit pour configurer la stratégie de façon à accorder un accès total à l'utilisateur :

    Code de copie
    $zp = $wa.ZonePolicies("Default")
$p = $zp.Add($account,"PSPolicy")
$fc=$wa.PolicyRoles.GetSpecialRole("FullControl")
$p.PolicyRoleBindings.Add($fc)
$wa.Update()

  9. À l'invite de commandes Windows PowerShell, tapez ce qui suit pour effectuer la migration des utilisateurs :

    Code de copie
    $wa = get-SPWebApplication $WebAppName
$wa.MigrateUsers($true)
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Instructions supplémentaires relatives à la migration

Après avoir effectué les étapes des procédures précédentes, il se peut que vous rencontriez un ou plusieurs des problèmes suivants :

  • Il est possible que des utilisateurs qui soumettent des informations d'identification valides soient informés du fait qu'ils ne disposent pas d'autorisations. Si cela se produit, il est probable que les propriétés portalsuperuseraccount et portalsuperreaderaccount de l'application Web ont été configurées avant la migration. Dans ce cas, vous devez mettre à jour les propriétés portalsuperuseraccount et portalsuperreaderaccount de façon à utiliser le nouveau nom de compte basé sur les revendications. Après la migration, ce nom figure dans la stratégie d'application Web de l'application Web migrée.

  • Si les alertes existantes ne sont pas invoquées après la migration, vous devrez peut-être supprimer et recréer les alertes.

  • Si l'analyse de recherche ne fonctionne pas après la migration, assurez-vous que le compte d'analyse de recherche mentionne le nouveau nom de compte converti. Si ce nom n'est pas répertorié, vous devez créer manuellement une stratégie pour le compte d'analyse.

Historique des modifications

Date | Description | Raison
14 octobre 2010 | Publication initiale |


Déployer Office Web Apps (installé sur les produits SharePoint 2010)

Cet article explique comment déployer Microsoft Office Web Apps. Office Web Apps est le compagnon en ligne des applications Office Word, Excel, PowerPoint et OneNote ; il permet aux utilisateurs d'accéder aux documents à partir de n'importe quel emplacement. Les utilisateurs peuvent afficher, partager et utiliser des documents avec d'autres utilisateurs en ligne, par le biais d'ordinateurs personnels, de téléphones mobiles et sur le Web. Office Web Apps est disponible pour les utilisateurs par le biais de Windows Live et pour les clients professionnels disposant de solutions de licence en volume et de gestion de documents Microsoft Office 2010 basées sur Produits Microsoft SharePoint 2010.

Remarque :
Un périphérique approprié, une connexion Internet et un navigateur Internet Explorer, Firefox ou Safari pris en charge sont requis. Certaines fonctionnalités mobiles requièrent Office Mobile 2010, qui n'est pas inclus dans les applications Office 2010, des suites ou Office Web Apps. Il existe certaines différences entre les fonctionnalités des applications Office Web Apps, Office Mobile 2010 et Office 2010.

Les informations fournies dans cet article sont destinées aux professionnels de l'informatique qui envisagent de déployer Office Web Apps sur Produits SharePoint 2010 dans les locaux de leur organisation. Produits SharePoint 2010 dans cet article fait référence à Microsoft SharePoint Server 2010 et Microsoft SharePoint Foundation 2010 sauf indication contraire. Cet article ne fournit pas de conseils ou d'instructions sur la manière de déployer Produits SharePoint 2010. Les contenus nouveaux ou mis à jour sont publiés sur une base régulière.

Il recommandé de commencer par la lecture de Understanding Office Web Apps (Installed on SharePoint 2010 Products) et Planning Office Web Apps (Installed on SharePoint 2010 Products) disponibles sur Microsoft TechNet avant de déployer Office Web Apps au sein de votre organisation.

Vous pouvez télécharger Office Web Apps depuis le Centre de gestion des licences en volume Microsoft (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=191841&clcid=0x40C) sur le site dédié à Office Professionnel Plus 2010 32 bits ou Office Standard 2010 32 bits.

Dans cet article :

  • Présentation du déploiement d'Office Web Apps

  • Configuration supplémentaire (facultatif)

  • Résolution des problèmes

Outre les sections précédentes, l'une des sections suivantes va s'appliquer à votre déploiement Office Web Apps spécifique :

  • Installer et configurer Office Web Apps sur un serveur SharePoint autonome existant

  • Installer et configurer Office Web Apps sur un nouveau serveur SharePoint autonome

  • Installer et configurer Office Web Apps sur une batterie de serveurs SharePoint existante

  • Installer et configurer Office Web Apps sur une nouvelle batterie de serveurs SharePoint

Présentation du déploiement d'Office Web Apps

Pour les serveurs SharePoint autonomes et batteries de serveurs SharePoint, le déploiement d'Office Web Apps implique trois phases principales :

Exécution du programme d'installation et PSConfig Les tâches incluent l'exécution de Setup.exe et l'Assistant Post-installation et configuration (PSConfig) des produits et technologies Microsoft SharePoint sur un serveur SharePoint autonome ou chaque serveur dans une batterie de serveurs SharePoint. L'exécution de Setup.exe installe les fichiers et les composants Office Web Apps sur un serveur. L'exécution de PSConfig est obligatoire dans le cadre de l'installation d'Office Web Apps afin d'inscrire les services Office Web Apps et, selon le type d'installation SharePoint, démarrer les instances des services, créer les applications des services et les serveurs proxy d'applications des services, et activer la fonctionnalité Office Web Apps.

Activation des services Office Web Apps Inclut le démarrage des instances de service ainsi que la création des applications de service et de leurs serveurs proxy. La nécessité d'activer les services dépend de l'état de SharePoint et du fait d'avoir précédemment exécuté PSconfig et l'Assistant de configuration de la batterie de serveurs SharePoint.

Activation de la fonctionnalité Office Web Apps Inclut l'activation de la fonctionnalité Office Web Apps sur toutes les collections de sites SharePoint où Office Web Apps doit être disponible. Si PSconfig ou l'Assistant de configuration de batterie SharePoint a été exécuté avant l'installation de Office Web Apps, au moins une collection de sites existe. La fonctionnalité est activée automatiquement pour les nouvelles collections de site créées après que Office Web Apps a été installé.

Remarque :
Certaines procédures de cet article requièrent l'utilisation de Windows PowerShell ou de SharePoint 2010 Management Shell pour l'exécution des applets de commande. Pour exécuter des applets de commande SharePoint 2010 dans Windows PowerShell, vous devez ajouter le composant logiciel enfichable Microsoft.SharePoint.PowerShell à l'aide de l'applet de commande Add-PSSnapin, ou vous pouvez exécuter les applets de commande SharePoint 2010 à l'aide de SharePoint 2010 Management Shell. Par défaut, le composant logiciel enfichable Microsoft.SharePoint.PowerShell est déjà inscrit et il est ajouté à SharePoint 2010 Management Shell. Pour exécuter les applets de commande SharePoint 2010, vous devez être membre du rôle SharePoint_Shell_Access sur la base de données de configuration et membre du groupe local WSS_ADMIN_WPG sur l'ordinateur où les Produits SharePoint 2010 sont installés. Pour exécuter des scripts dans Windows PowerShell ou SharePoint 2010 Management Shell, vous devez définir la stratégie d'exécution à l'aide de l'applet de commande set-executionpolicy, en utilisant le paramètre unrestricted. Pour plus d'informations sur l'applet de commande Add-PSSnapin, voir Add-PSSnapin. Pour plus d'informations sur la manière d'utiliser Windows PowerShell avec les Produits SharePoint 2010, voir Administration des produits SharePoint 2010 à l'aide de Windows PowerShell.

Installer et configurer Office Web Apps sur un serveur SharePoint autonome existant

Cette section s'applique uniquement si vous installez Office Web Apps sur un serveur SharePoint existant et si PSConfig a été précédemment exécuté dans le cadre du programme d'installation de SharePoint.

Attention :
Lorsque vous exécutez Setup.exe, le programme d'installation d'Office Web Apps configure le comportement d'ouverture par défaut pour les documents activés pour le navigateur dans SharePoint pour ouvrir des documents dans le navigateur. Si le programme d'installation d'Office Web Apps a été exécuté, mais que les services et la fonctionnalité Office Web Apps n'ont pas encore été activés, un utilisateur peut obtenir un lien rompu à l'ouverture d'un document dans le navigateur. Lors du déploiement de Office Web Apps sur une batterie de serveurs de production en direct, pour empêcher les liens rompus vers des documents lors de l'exécution de tâches de déploiement supplémentaires après avoir exécuté le programme d'installation, nous vous recommandons d'activer la fonctionnalité OpenInClient sur des collections de sites existantes avant d'exécuter le programme d'installation. Pour plus d'informations, voir Configuration supplémentaire (facultatif).

Exécution du programme d'installation d'Office Web Apps

Effectuez cette tâche pour installer des composants et des fichiers Office Web Apps sur un serveur.

Pour exécuter le programme d'installation d'Office Web Apps

  1. À partir du dossier racine, exécutez Setup.exe.

  2. Dans la page Tapez la clé de produit, entrez votre clé de produit, puis cliquez sur Continuer.

  3. Dans la page Choisir un emplacement pour les fichiers, cliquez sur Installer maintenant pour effectuer l'installation à l'emplacement par défaut. Pour effectuer l'installation à un autre emplacement, spécifiez cet emplacement, puis cliquez sur Installer maintenant.

  4. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Assurez-vous que la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint est activée, puis cliquez sur Fermer pour démarrer PSConfig.

Exécution de PSConfig pour enregistrer les services

Effectuez cette tâche pour inscrire les services Office Web Apps sur le serveur SharePoint.

Pour exécuter PSConfig en vue d'inscrire les services

  1. Si vous avez laissé la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint activée à l'étape précédente, dans la page Bienvenue dans les produits SharePoint de PSconfig, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés ou réinitialisés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Configuration réussie, cliquez sur Terminer. Votre nouveau site SharePoint s'ouvre.

Démarrer les instances de service

Une instance de service fournit l'emplacement physique d'une application de service. Vous devez démarrer les instances de service avant de créer les applications de service et les serveurs proxy d'applications de service. Vous pouvez démarrer les instances de service à l'aide de l'administration centrale de SharePoint ou à l'aide de Windows PowerShell.

Les procédures de cette tâche permettent de démarrer les instances de service sur le serveur spécifié.

Pour démarrer les instances de service à l'aide de l'administration centrale

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Produits Microsoft SharePoint 2010, puis Administration centrale de SharePoint 2010.

  2. Dans la page d'accueil Administration centrale de SharePoint, dans Paramètres système, cliquez sur Gérer les services sur le serveur.

  3. Sur les services sur le serveur :<servername>page, démarrez Services de calcul Excel, Service d'affichage Word et Service PowerPoint. OneNote Web App n'utilise pas un service SharePoint.

Pour démarrer les instances de service à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $machinesToActivate = @("<servername>")
$serviceInstanceNames = @("Word Viewing Service", "PowerPoint Service", "Excel Calculation Services")
foreach ($machine in $machinesToActivate)
{
  foreach ($serviceInstance in $serviceInstanceNames)
  {
     $serviceID = $(Get-SPServiceInstance | where {$_.TypeName -match $serviceInstance} | where {$_.Server -match "SPServer Name="+$machine}).ID
     Start-SPServiceInstance -Identity $serviceID
  }
}

  2. Spécifiez les paramètres suivants :

    Paramètre Valeur

    $machinesToActivate

    Nom du serveur

  3. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  4. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire, PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Création des applications de service et des proxys d'applications de service

Après le démarrage des instances de service, il faut créer les applications de service et les serveurs proxy d'applications de service qui connectent les sites Web frontaux Sharepoint aux applications de service. Vous pouvez créer les applications de service et les serveurs proxy d'application de service pour les applications Word, PowerPoint et Excel Web apps à l'aide de l'administration centrale ou à l'aide de Windows PowerShell. OneNote Web App ne nécessite pas une application de service. Une fois créées, les applications de service s'exécutent sur les instances de service démarrées automatiquement.

Les procédures de cette tâche créent les applications de service et les serveurs proxy d'applications de service Office Web Apps pour les applications Web Word, PowerPoint et Excel Web apps. Cette tâche peut uniquement être réalisée après avoir démarré les instances de service.

Pour créer les applications de service et les serveurs proxy d'applications de service à l'aide de l'administration centrale

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Produits Microsoft SharePoint 2010, puis Administration centrale de SharePoint 2010.

  2. Sur la page d'accueil Administration centrale SharePoint, dans Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la page Applications de service, cliquez sur Nouveau, puis sur service d'affichage Word .

  4. Dans la boîte de dialogue Application Service d'affichage Word, dans Nom, tapez Application Service d'affichage Word. Dans Pool d'applications, sélectionnez Utiliser le pool d'applications existant, puis dans la zone de liste, sélectionnez Services Web par défaut SharePoint. Dans Ajouter à la liste des proxys par défaut, vérifiez que l'option Ajouter le proxy de cette application de service à la liste des proxys par défaut de la batterie de serveurs est sélectionnée (valeur par défaut), puis cliquez sur OK.

  5. Dans la page Applications de service, cliquez sur Nouveau, puis sur Application de service PowerPoint.

  6. Dans la boîte de dialogue Application de service PowerPoint, dans Nom, tapez Application de service PowerPoint. Dans Pool d'applications, sélectionnez Utiliser le pool d'applications existant, puis dans la zone de liste, sélectionnez Services Web par défaut SharePoint. Dans Ajouter à la liste des proxys par défaut, vérifiez que l'option Ajouter le proxy de cette application de service à la liste des proxys par défaut de la batterie de serveurs est sélectionnée (valeur par défaut), puis cliquez sur OK.

  7. Dans la page Applications de service, cliquez sur Nouveau, puis sur Application Excel Services.

  8. Dans la boîte de dialogue Application Excel Services, dans Nom, tapez Application Excel Services. Dans Pool d'applications, sélectionnez Utiliser le pool d'applications existant, puis dans la zone de liste, sélectionnez Services Web par défaut SharePoint. Dans Ajouter à la liste des proxys par défaut, vérifiez que l'option Ajouter le proxy de cette application de service à la liste des proxys par défaut de la batterie de serveurs est sélectionnée (valeur par défaut), puis cliquez sur OK.

    Remarque :
    Vous pouvez choisir de créer un nouveau pool d'applications à utiliser avec une application de service. Lorsque vous créez un nouveau pool d'applications, vous pouvez spécifier le compte de sécurité utilisé par le pool d'applications comme étant un compte de service réseau prédéfini ou vous pouvez spécifier un compte géré. Le compte doit disposer de privilèges en lecture\écriture pour la base de données SPContent et la base de données SPConfig. Pour plus d'informations sur les autorisations des comptes de service dans SharePoint, voir Account permissions and security settings (SharePoint Server 2010).

Pour créer les applications de service et les proxys d'applications de service à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $appPool = Get-SPServiceApplicationPool -Name "SharePoint Web Services Default"
New-SPWordViewingServiceApplication -Name "WdView" -ApplicationPool $appPool | New-SPWordViewingServiceApplicationProxy -Name "WdProxy"
New-SPPowerPointServiceApplication -Name "PPT" -ApplicationPool $appPool | New-SPPowerPointServiceApplicationProxy -Name "PPTProxy"
New-SPExcelServiceApplication -Name "Excel" -ApplicationPool $appPool

  2. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  3. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire, PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Activer la fonctionnalité Office Web Apps

Une fois que les instances de service ont été lancées et que les applications de service et les proxys d'applications de service ont été créés, il faut pour utiliser Office Web Apps que la fonctionnalité Office Web Apps soit activée sur les collections de sites existantes. Vous pouvez activer la fonctionnalité sur une seule collection de sites dans un navigateur via la page Fonctionnalités de la collection de sites ou à l'aide de Windows PowerShell. Si vous avez un grand nombre de collections de sites, vous pouvez activer la fonctionnalité sur toutes les collections de sites en même temps à l'aide de Windows PowerShell.

Les procédures de cette tâche permettent d'activer la fonctionnalité Office Web Apps sur une ou plusieurs collections de sites existantes. Cette tâche ne doit être exécutée qu'après que les applications de service et les proxys d'applications de service ont été créés. S'il existe plusieurs collections de sites, et que vous activez la fonctionnalité sur une collection de sites à la fois, vous devrez répéter la procédure pour chacune d'elles.

Remarque :
Cette tâche ne doit pas être réalisée pour les nouvelles collections de sites créées après l'installation d'Office Web Apps.

Pour activer la fonctionnalité Office Web Apps sur une collection de sites sur la page Fonctionnalités de la collection de sites

  1. Dans un navigateur, sur le site SharePoint, cliquez sur Actions du site, puis sur Paramètres du site.

  2. Dans la page Paramètres du site, dans Administration de la collection de sites, cliquez sur Fonctionnalités de la collection de sites.

  3. Dans la page de fonctionnalités, pour Office Web Apps, cliquez sur activer .

Pour activer la fonctionnalité Office Web Apps sur une collection de sites à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $webAppsFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OfficeWebApps"}).Id
$singleSiteCollection = Get-SPSite -Identity http://<site_name> Enable-SPFeature $webAppsFeatureId -Url $singleSiteCollection.URL

  2. Spécifiez les paramètres suivants :

    Paramètre Valeur

    -Identity

    URL

  3. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  4. Dans la console Windows PowerShell, depuis l'invite de commandes (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Pour activer la fonctionnalité Office Web Apps sur toutes les collections de sites à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $webAppsFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OfficeWebApps"}).Id
Get-SPSite -limit ALL |foreach{Enable-SPFeature $webAppsFeatureId -url $_.URL }

  2. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  3. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire, PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Installer et configurer Office Web Apps sur un nouveau serveur SharePoint autonome

Cette section s'applique uniquement si vous installez Office Web Apps sur une nouvelle installation SharePoint où PSConfig n'a pas été exécuté auparavant dans le cadre du programme installation de SharePoint.

Exécution du programme d'installation d'Office Web Apps

Effectuez cette tâche pour installer des composants et des fichiers Office Web Apps sur un serveur.

Pour exécuter le programme d'installation d'Office Web Apps

  1. À partir du dossier racine, exécutez Setup.exe.

  2. Dans la page Tapez la clé de produit, entrez votre clé de produit, puis cliquez sur Continuer.

  3. Dans la page Choisir un emplacement pour les fichiers, cliquez sur Installer maintenant pour effectuer l'installation à l'emplacement par défaut. Pour effectuer l'installation à un autre emplacement, spécifiez cet emplacement, puis cliquez sur Installer maintenant.

  4. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Assurez-vous que la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint est activée, puis cliquez sur Fermer pour démarrer PSConfig.

Exécuter PSConfig pour inscrire les services, démarrer les instances de service, créer les applications de service et les serveurs proxys et activer la fonctionnalité Office Web Apps

Effectuez cette tâche pour inscrire les services, démarrer les instances de service, créer les applications de service et les proxys d'applications de service et activer la fonctionnalité Office Web Apps.

Pour exécuter PSConfig pour inscrire les services, démarrer les instances de service, créer les applications de service et les serveurs proxys et activer la fonctionnalité Office Web Apps

  1. Si vous avez laissé la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint activée dans la tâche précédente, dans la page Bienvenue dans les produits SharePoint de PSconfig, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés ou réinitialisés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Configuration réussie, cliquez sur Terminer. Votre nouveau site SharePoint s'ouvre.

Installer et configurer Office Web Apps sur une batterie de serveurs SharePoint existante

Effectuez les tâches dans cette section uniquement si vous installez Office Web Apps sur une batterie de serveurs SharePoint existante où l'Assistant de configuration de batterie a été exécuté auparavant.

Attention :
Lorsque vous exécutez Setup.exe, le programme d'installation d'Office Web Apps configure le comportement d'ouverture par défaut pour les documents activés pour le navigateur dans SharePoint pour ouvrir des documents dans le navigateur. Si le programme d'installation d'Office Web Apps a été exécuté, mais que les services et la fonctionnalité Office Web Apps n'ont pas encore été activés, un utilisateur peut obtenir un lien rompu à l'ouverture d'un document dans le navigateur. Lors du déploiement de Office Web Apps sur une batterie de serveurs de production en direct, pour empêcher les liens rompus vers des documents lors de l'exécution de tâches de déploiement supplémentaires après avoir exécuté le programme d'installation, il est recommandé d'activer la fonctionnalité OpenInClient sur des collections de sites existantes avant d'exécuter le programme d'installation. Pour plus d'informations, voir Configuration supplémentaire (facultatif).

Exécution du programme d'installation d'Office Web Apps

Effectuez cette tâche pour installer Office Web Apps sur un serveur SharePoint unique. Cette tâche doit être effectuée sur chaque serveur de la batterie de serveurs.

Pour exécuter le programme d'installation d'Office Web Apps

  1. À partir du dossier racine, exécutez Setup.exe.

  2. Dans la page Tapez la clé de produit, entrez votre clé de produit, puis cliquez sur Continuer.

  3. Dans la page Choisir un emplacement pour les fichiers, cliquez sur Installer maintenant pour effectuer l'installation à l'emplacement par défaut. Pour effectuer l'installation à un autre emplacement, spécifiez cet emplacement, puis cliquez sur Installer maintenant.

  4. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Assurez-vous que la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint est activée.

  5. Cliquez sur Fermer pour démarrer l'Assistant Configuration.

Exécution de PSConfig pour enregistrer des services

Effectuez cette tâche pour installer Office Web Apps sur un serveur SharePoint unique. Cette tâche doit être effectuée sur chaque serveur de la batterie de serveurs.

Pour exécuter PSConfig en vue d'inscrire les services

  1. Dans la page Bienvenue dans les produits SharePoint, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés ou réinitialisés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Modifier les paramètres de la batterie de serveurs, sélectionnez Ne pas se déconnecter de cette batterie de serveurs, puis cliquez sur Suivant.

  4. Dans la page Configuration réussie, cliquez sur Terminer. Votre nouveau site SharePoint s'ouvre.

Démarrer les instances de service

Une instance de service fournit l'emplacement physique pour une application de service. Pour chaque serveur que vous souhaitez voir exécuter des applications de service Office Web Apps, vous devez démarrer les instances de service. Vous pouvez démarrer les instances de service à l'aide de l'administration centrale de SharePoint ou à l'aide de Windows PowerShell.

Les procédures de cette tâche vont démarrer les instances de service sur les serveurs spécifiés. Il convient d'effectuer cette tâche une fois que vous avez exécuté WCSetup et PSConfig sur chaque serveur de la batterie de serveurs.

Pour démarrer les instances de service à l'aide de l'administration centrale

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Produits Microsoft SharePoint 2010, puis Administration centrale de SharePoint 2010.

  2. Dans la page d'accueil Administration centrale de SharePoint, dans Paramètres système, cliquez sur Gérer les services sur le serveur.

  3. Sur les services d'un serveur :<servername>page, dans Serveur, sélectionnez un serveur, puis démarrez Services de calcul Excel, Service d'affichage Word et PowerPoint Service. Répétez cette étape pour chaque serveur dans la batterie de serveurs devant exécuter les services de Office Web Apps. OneNote Web App ne prend pas en charge un service SharePoint.

Pour démarrer les instances de service à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $machinesToActivate = @("<servername1>", "<servername2>")
$serviceInstanceNames = @("Word Viewing Service","PowerPoint Service","Excel Calculation Services")
foreach ($machine in $machinesToActivate)
{
  foreach ($serviceInstance in $serviceInstanceNames)
  {
     $serviceID = $(Get-SPServiceInstance | where {$_.TypeName -match $serviceInstance} | where {$_.Server -match "SPServer Name="+$machine}).ID
     Start-SPServiceInstance -Identity $serviceID
  }
}

  2. Spécifiez les paramètres suivants :

    Paramètre Valeur

    $machinesToActivate

    Nom du serveur

  3. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  4. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire, PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Création des applications de service et des proxys d'applications de service

Après le démarrage des instances de service, il faut créer les applications de service et les proxys d'applications de service qui connectent les sites Web frontaux Sharepoint aux applications de service. Vous pouvez créer les applications de service et les proxys d'application de service pour les applications Word, PowerPoint et Excel Web à l'aide de l'administration centrale ou à l'aide de Windows PowerShell. L'application Web de OneNote ne nécessite pas une application de service. Une fois créées, les applications de service s'exécutent sur les instances de service démarrées automatiquement.

Dans cette tâche, vous créez les applications de service et les proxys d'applications de service Office Web Apps pour les applications Word, PowerPoint et Excel Web apps. Cette tâche peut uniquement être réalisée après avoir démarré les instances de service.

Pour créer les applications de service et les proxys d'applications de service à l'aide de l'administration centrale

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Produits Microsoft SharePoint 2010, puis Administration centrale de SharePoint 2010.

  2. Sur la page d'accueil Administration centrale SharePoint, dans Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la page applications de service, cliquez sur Nouveau, puis sur service d'affichage Word .

  4. Dans la boîte de dialogue Application Service d'affichage Word, dans Nom, tapez Application Service d'affichage Word. Dans Pool d'applications, sélectionnez Utiliser le pool d'applications existant, puis dans la zone de liste, sélectionnez Services Web par défaut SharePoint. Dans Ajouter à la liste des proxys par défaut, vérifiez que l'option Ajouter le proxy de cette application de service à la liste des proxys par défaut de la batterie de serveurs est sélectionnée (valeur par défaut), puis cliquez sur OK.

  5. Dans la page applications de service, cliquez sur Nouveau, puis sur Application de service PowerPoint.

  6. Dans la boîte de dialogue Application de service PowerPoint, dans Nom, tapez Application de service PowerPoint. Dans Pool d'applications, sélectionnez Utiliser le pool d'applications existant, puis dans la zone de liste, sélectionnez Services Web par défaut SharePoint. Dans Ajouter à la liste des proxys par défaut, vérifiez que l'option Ajouter le proxy de cette application de service à la liste des proxys par défaut de la batterie de serveurs est sélectionnée (valeur par défaut), puis cliquez sur OK.

  7. Dans la page Applications de service, cliquez sur Nouveau, puis sur Application Excel Services.

  8. Dans la boîte de dialogue Application Excel Services, dans Nom, tapez Application Excel Services. Dans Pool d'applications, sélectionnez Utiliser le pool d'applications existant, puis dans la zone de liste, sélectionnez Services Web par défaut SharePoint. Dans Ajouter à la liste des proxys par défaut, vérifiez que l'option Ajouter le proxy de cette application de service à la liste des proxys par défaut de la batterie de serveurs est sélectionnée (valeur par défaut), puis cliquez sur OK.

    Remarque :
    Vous pouvez choisir de créer un nouveau pool d'applications à utiliser avec une application de service. Lorsque vous créez un nouveau pool d'applications, vous pouvez spécifier le compte de sécurité utilisé par le pool d'applications comme étant un compte de service réseau prédéfini ou vous pouvez spécifier un compte géré. Le compte doit disposer de privilèges en lecture\écriture pour la base de données SPContent et la base de données SPConfig. Pour plus d'informations sur les autorisations des comptes de service dans SharePoint, voir Account permissions and security settings (SharePoint Server 2010).

Pour créer les applications de service et les proxys d'applications de service à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $appPool = Get-SPServiceApplicationPool -Name "SharePoint Web Services Default"
New-SPWordViewingServiceApplication -Name "WdView" -ApplicationPool $appPool | New-SPWordViewingServiceApplicationProxy -Name "WdProxy"
New-SPPowerPointServiceApplication -Name "PPT" -ApplicationPool $appPool | New-SPPowerPointServiceApplicationProxy -Name "PPTProxy"
New-SPExcelServiceApplication -Name "Excel" -ApplicationPool $appPool

  2. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  3. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire, PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Activer la fonctionnalité Office Web Apps

Une fois que les instances de service ont été lancées et que les applications de service et les proxys d'applications de service ont été créés, l'utilisation d'Office Web Apps requiert que la fonctionnalité Office Web Apps soit activée sur les collections de sites existantes. Vous pouvez activer la fonctionnalité sur une seule collection de sites dans un navigateur via la page Fonctionnalités de la collection de sites ou à l'aide de Windows PowerShell. Si vous avez un grand nombre de collections de sites, vous pouvez activer la fonctionnalité sur toutes les collections de sites en même temps à l'aide de Windows PowerShell.

Les procédures de cette tâche permettent d'activer la fonctionnalité Office Web Apps sur une ou plusieurs collections de site existantes. Cette tâche doit être exécutée une seule fois après que les applications de service et les proxys d'applications de service ont été créés. S'il existe plusieurs collections de sites, et que vous activez la fonctionnalité sur une collection de sites à la fois, vous devrez répéter la procédure pour chacune d'elles.

Remarque :
Cette tâche ne doit pas être réalisée pour les nouvelles collections de sites créées après l'installation d'Office Web Apps.

Pour activer la fonctionnalité Office Web Apps sur une collection de sites sur la page Fonctionnalités de la collection de sites

  1. Dans un navigateur, sur le site SharePoint, cliquez sur Actions du site, puis sur Paramètres du site.

  2. Dans la page Paramètres du site, dans Administration de la collection de sites, cliquez sur Fonctionnalités de la collection de sites.

  3. Dans la page de fonctionnalités, pour Office Web Apps, cliquez sur activer .

Pour activer la fonctionnalité Office Web Apps sur une collection de sites à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $webAppsFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OfficeWebApps"}).Id
$singleSiteCollection = Get-SPSite -Identity http://<site_name> Enable-SPFeature $webAppsFeatureId -Url $singleSiteCollection.URL

  2. Spécifiez les paramètres suivants :

    Paramètre Valeur

    -Identity

    URL

  3. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  4. Dans la console Windows PowerShell, depuis l'invite de commandes (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Pour activer la fonctionnalité Office Web Apps sur toutes les collections de sites à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $webAppsFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OfficeWebApps"}).Id
Get-SPSite -limit ALL |foreach{Enable-SPFeature $webAppsFeatureId -url $_.URL }

  2. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  3. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire, PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Installer et configurer Office Web Apps sur une nouvelle batterie de serveurs SharePoint

Effectuez les tâches dans cette section uniquement si vous installez Office Web Apps sur une nouvelle batterie de serveurs SharePoint où l'Assistant de configuration de batterie n'a pas été exécuté auparavant.

Exécution du programme d'installation d'Office Web Apps

Dans cette tâche, vous allez installer des fichiers et des composants Office Web Apps sur un seul serveur de SharePoint dans une nouvelle batterie de serveurs où l'Assistant de configuration de batterie n'a pas été exécuté auparavant. Il convient d'effectuer cette tâche sur chaque serveur de la batterie de serveurs.

Pour exécuter le programme d'installation d'Office Web Apps

  1. À partir du dossier racine, exécutez Setup.exe.

  2. Dans la page Tapez la clé de produit, entrez votre clé de produit, puis cliquez sur Continuer.

  3. Dans la page Choisir un emplacement pour les fichiers, cliquez sur Installer maintenant pour effectuer l'installation à l'emplacement par défaut. Pour effectuer l'installation à un autre emplacement, spécifiez cet emplacement, puis cliquez sur Installer maintenant.

  4. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Assurez-vous que la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint est activée.

  5. Cliquez sur Fermer pour démarrer l'Assistant Configuration de batterie de serveurs.

Exécution de PSConfig pour enregistrer des services

Dans cette tâche, vous allez installer Office Web Apps sur un serveur SharePoint unique. Cette tâche doit être effectuée sur chaque serveur de la batterie de serveurs.

Pour exécuter PSConfig en vue d'inscrire les services

  1. Dans la page Bienvenue dans les produits SharePoint, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés ou réinitialisés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Modifier les paramètres de la batterie de serveurs, sélectionnez Ne pas se déconnecter de cette batterie de serveurs, puis cliquez sur Suivant.

  4. Dans la page Configuration réussie, cliquez sur Terminer. Votre nouveau site SharePoint s'ouvre.

Exécutez l'Assistant Configuration de batterie SharePoint pour démarrer les instances de service, créer les applications de service et les serveurs proxy et activer la fonctionnalité Office Web Apps

Dans cette tâche, vous allez démarrer les instances de service sur tous les serveurs de la batterie de serveurs, les applications de service et les proxys d'applications de service, puis activer la fonctionnalité Office Web Appssur toutes les collections de sites existantes. Cette tâche doit être effectuée après l'exécution de Setup.exe et PSConfig sur chaque serveur de la batterie de serveurs.

Pour exécuter l'Assistant Configuration de batterie SharePoint afin de démarrer les instances de service, créer les applications de service et les serveurs proxy et activer la fonctionnalité Office Web Apps

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Produits Microsoft SharePoint 2010, puis Administration centrale de SharePoint 2010.

  2. Dans la page d'accueil Administration centrale de SharePoint, cliquez sur Assistants de configuration.

  3. Dans la page Assistants de configuration, cliquez sur Exécuter l'Assistant Configuration de batterie de serveurs.

  4. Dans la page d'accueil Assistant Configuration de batterie de serveurs, choisissez Passer en revue les paramètres à l'aide de cet Assistant, puis cliquez sur Suivant.

  5. Dans la page Configuration de votre batterie SharePoint, dans Compte de service, tapez un nom pour le compte d'administration de la batterie de serveurs.

  6. Dans Services, sélectionnez les services Office Web Apps que vous souhaitez activer, puis cliquez sur Suivant.

  7. Créez un nouveau site de niveau supérieur en option. Dans la page Créer une collection de sites, suivez les étapes de l'Assistant pour créer un nouveau site de niveau supérieur.

  8. Dans la page Configuration de votre batterie SharePoint, cliquez sur Terminer.

Configuration supplémentaire (facultatif)

Cette section traite des configurations supplémentaires qui sont facultatives.

Configurer le comportement d'ouverture par défaut SharePoint pour les documents activés pour le navigateur

Dans SharePoint, vous pouvez configurer si les de documents activés pour le navigateur sont ouverts dans une application cliente ou dans le navigateur. Par défaut, lors de l'installation d'Office Web Apps, les documents Office s'ouvrent dans le navigateur. Vous pouvez remplacer ce paramètre à l'aide de la fonctionnalité SharePoint OpenInClient. La fonctionnalité OpenInClient peut être configurée dans l'administration centrale ou à l'aide de l'applet de commande SPFeature dans Windows PowerShell.

La façon dont les documents s'ouvrent dans SharePoint varie, selon que la fonction OpenInClient est présente ou non et qu'elle est activée ou désactivée :

  • Si la fonctionnalité OpenInClient n'est pas présente et que Office Web Apps n'est pas installé, les documents s'ouvrent dans l'application cliente (SharePoint par défaut).

  • Si la fonctionnalité OpenInClient n'est pas présente, que Office Web Apps est installé et que applications de service Office Web Apps sont activées, les documents s'ouvrent dans le navigateur ( Office Web Apps par défaut).

  • Si la fonctionnalité OpenInClient est présente et activée, et que les applications de service Office Web Apps sont activées, les documents s'ouvrent dans l'application cliente.

  • Si la fonctionnalité OpenInClient est présente et désactivée, et que les applications de service Office Web Apps sont activées, les documents dans s'ouvrent dans le navigateur.

Attention :
Lorsque vous exécutez Setup.exe pour installer Office Web Apps, le programme d'installation prend le contrôle du comportement d'ouverture par défaut dans SharePoint pour enregistrer les documents Word, PowerPoint, Excel et OneNote comme devant s'ouvrir dans leur application Web associée. Si un utilisateur clique sur un document dans SharePoint après que Setup.exe a été exécuté, mais avant l'activation des services et fonctionnalité Office Web Apps, l'utilisateur peut obtenir un lien rompu dans le navigateur. Lors de l'installation de Office Web Apps dans un environnement de production en direct, il est fortement recommandé d'activer la fonctionnalité OpenInClient avant d'exécuter le programme d'installation de Office Web Apps.

Pour définir le comportement d'ouverture par défaut pour les collections de sites à l'aide de l'administration centrale

  1. Dans l'administration centrale SharePoint, cliquez sur Actions du site, puis sur Paramètres du site.

  2. Dans la page Paramètres du site, sous Administration de la collection de sites, cliquez sur Fonctionnalités de la collection de sites.

  3. Dans la page de fonctionnalités, pour la fonctionnalité Ouvrir par défaut des documents dans des applications clientes, cliquez sur Activer (la fonction OpenInClient est activée) pour ouvrir des documents dans l'application cliente. Cliquez sur Désactivé (la fonction OpenInClient est désactivée) pour ouvrir des documents dans le navigateur.

Pour définir le comportement d'ouverture SharePoint par défaut pour les documents activés pour le navigateur afin que l'ouverture s'effectue dans le navigateur à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Cet exemple désactive le comportement d'ouverture par défaut dans SharePoint.

    Code de copie
    $defaultOpenBehaviorFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OpenInClient"}).Id
Get-SPSite -limit ALL |foreach{ Disable-SPFeature $defaultOpenBehaviorFeatureId -url $_.URL }

  2. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  3. Dans la console Windows PowerShell, depuis l'invite de commandes (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Pour définir le comportement d'ouverture SharePoint par défaut pour les documents activés pour le navigateur afin que l'ouverture s'effectue dans le navigateur à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Cet exemple définit le comportement d'ouverture par défaut de tous les documents dans tous les sites de manière à ce que les documents s'ouvrent dans l'application cliente (sous réserve qu'elle soit disponible).

    Code de copie
    $defaultOpenBehaviorFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OpenInClient"}).Id
Get-SPSite -limit ALL |foreach{ Enable-SPFeature $defaultOpenBehaviorFeatureId -url $_.URL }

  2. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  3. Dans la console Windows PowerShell, depuis l'invite de commandes (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<path>\<filename>.ps1

Résolution des problèmes

Problème Office Web Apps est installé, mais les documents n'ouvrent pas leur application Web associée dans le navigateur.

Solution Vérifiez que la fonctionnalité Office Web Apps a été activée pour la collection de sites dans laquelle se trouve le document. Pour plus d'informations, voir Activer la fonctionnalité Office Web Apps.

Solution Vérifiez que les instances de service ont été démarrées. Pour plus d'informations, voir Démarrer les instances de service.

Solution Vérifiez que les applications de service et proxy ont été créées. Dans l'Administration centrale de SharePoint, dans Gestion des applications, cliquez sur Gérer les applications de service. Vérifiez que application de service d'affichage Word, application de service PowerPoint et application Excel Services sont démarrés. Si ce n'est pas le cas, vérifiez que les instances de service ont été démarrées.

Solution Vérifiez que la fonctionnalité OpenInClient SharePoint n'est pas activée. Pour plus d'informations, voir Configuration supplémentaire (facultatif).

Problème Office Web Apps s'ouvre correctement en mode affichage, mais lorsqu'un utilisateur clique sur le bouton Modifier dans Word, Modifier dans PowerPoint ou Modifier dans Excel sur de la barre d'outils, une erreur s'affiche.

Solution Vérifiez que la fonctionnalité Office Web Apps est activée et que le service d'affichage de Word, le Service PowerPoint et les services de calcul Excel sont démarrés.

Problème Lors de l'exécution du programme d'installation, la clé de produit n'est pas validée.

Solution Vérifiez que vous installez une version d'Office Web Apps compatible avec votre version de Produits SharePoint 2010. Office Web Apps Édition d'évaluation ne peut pas être installé sur un serveur avec des produits sous licence SharePoint 2010.

Solution Vérifiez que vous disposez d'une licence de volume valide Microsoft Office 2010.

Historique des modifications

Date | Description | Raison
2011/01/31 | 2011/01/31 | Mise à jour du contenu
16 septembre 2010 | 2010/09/13 | Mise à jour du contenu
10 juin 2010 | 2010/06/07 | Mise à jour du contenu


Opérations pour SharePoint Foundation 2010

Bienvenue dans le guide des opérations pour Microsoft SharePoint Foundation 2010. Les articles de ce guide ont pour but de vous aider à utiliser et maintenir vos serveurs, batteries de serveurs, sites et solutions.

Dans cette section :

  • Administration de serveur et de batterie de serveurs (SharePoint Foundation 2010)

    Cette section explique comment gérer des serveurs et des batteries de serveurs dans un environnement SharePoint Foundation 2010. Elle comprend des articles sur la sauvegarde, la récupération, la gestion de bases de données, la gestion d'applications Web, la gestion d'applications de service, le suivi d'intégrité et la surveillance, ainsi que sur l'administration de la sécurité et des autorisations.

  • Administration de sites et de solutions (SharePoint Foundation 2010)

    Cette section explique comment gérer des sites et des solutions au sein d'un environnement SharePoint Foundation 2010. Elle comprend des articles sur la gestion des collections de sites, des applications de service et des services, ainsi que sur les fonctionnalités telles que les flux de travail et les solutions en mode bac à sable (sandbox).

Historique des modifications


Administration de serveur et de batterie de serveurs (SharePoint Foundation 2010)

Cette section explique comment configurer les paramètres d'administration pour les serveurs et les batteries de serveurs dans un environnement Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Sauvegarde et récupération (SharePoint Foundation 2010)

  • Gestion des base de données (SharePoint Foundation 2010)

  • Administration de la sécurité et des autorisations (SharePoint Foundation 2010)

  • Gérer les applications de service et les services (SharePoint Foundation 2010)

  • Gérer des applications Web (SharePoint Foundation 2010)

  • Analyse d'intégrité (SharePoint Foundation 2010)

  • Gestion de la topologie de batteries (SharePoint Foundation 2010)

Historique des modifications


Sauvegarde et récupération (SharePoint Foundation 2010)

Cet ensemble de documents vise à répondre aux besoins des informaticiens chargés de la planification, de la conception, du déploiement et de l'exploitation de solutions de sauvegarde et de récupération dans les environnements d'entreprise et de succursales. Les lecteurs de cet ensemble de documents sont censés avoir une connaissance de ses détails techniques. Toutefois, une expertise de niveau service n'est pas nécessaire pour comprendre les arguments et les décisions prises au niveau entreprise.

Une sauvegarde est une copie de données utilisée pour restaurer et récupérer ces données après une défaillance du système. Les sauvegardes permettent de restaurer des données après un échec. La récupération permet de rapidement restaurer la batterie de serveurs en cas de problème. Vous pouvez récupérer la batterie de serveurs intégralement ou seulement un ou plusieurs composants de cette batterie de serveurs à partir d'une sauvegarde.

Dans cette section :

  • Préparer la sauvegarde et la récupération (SharePoint Foundation 2010)

  • Meilleures pratiques de sauvegarde et récupération (SharePoint Foundation 2010)

  • Configuration des autorisations pour la sauvegarde et la récupération (SharePoint Foundation 2010)

  • Sauvegarde (SharePoint Foundation 2010)

  • Récupération (SharePoint Foundation 2010)

Historique des modifications


Préparer la sauvegarde et la récupération (SharePoint Foundation 2010)
Voir aussi

Il convient de s'assurer que vous avez sauvegardé les données nécessaires et que vous pouvez les récupérer en cas de défaillance. Prenez en compte les informations, procédures et précautions décrites dans cet article avant de sauvegarder et de restaurer l'environnement. Cet article traite des restrictions et des exigences relatives à la sauvegarde et à la récupération et explique comment créer un dossier partagé sur le réseau susceptible de recevoir les données sauvegardées.

Dans cet article :

  • Restrictions

  • Conditions requises

  • Comment créer un dossier partagé

Restrictions

Il existe certaines restrictions quant aux éléments pouvant être sauvegardés ou restaurés. Pour plus d'informations sur l'architecture de sauvegarde et de restauration et sur ce qui peut ou ne peut pas être sauvegardé ou restauré, voir Vue d'ensemble de la sauvegarde et de la récupération (SharePoint Foundation 2010).

Vous ne pouvez pas utiliser une sauvegarde effectuée à partir d'une version pour restaurer sur une autre version. Pour cela, vous devez utiliser le processus de mise à niveau. Vous ne pouvez pas effectuer une restauration dans une batterie ayant un niveau de mise à jour inférieur à celui de la batterie que vous avez sauvegardée. La batterie de destination doit avoir un niveau de mise à jour identique ou supérieur. Pour plus d'informations sur la façon d'effectuer une mise à niveau, voir Mise à niveau vers SharePoint Foundation 2010.

Si vous effectuez une sauvegarde alors que d'autres tâches qui créent ou suppriment des bases de données sont en cours d'exécution, ces modifications peuvent ne pas être incluses dans la sauvegarde.

Ne modifiez pas le fichier spbackup.xml. Il est utilisé par SharePoint Foundation 2010 et sa modification pourrait rendre les sauvegardes inutilisables.

Conditions requises

Avant de sauvegarder les données, vous devez créer un dossier partagé dans lequel les données seront stockées. Pour de meilleures performances, vous devez créer ce dossier sur le serveur de bases de données. Si vous souhaitez archiver les sauvegardes sur un autre serveur, vous pouvez copier tout le dossier de sauvegarde sur ce serveur une fois la sauvegarde terminée. Assurez-vous de copier et de déplacer tout le dossier de sauvegarde, et non simplement les différents dossiers de sauvegarde qui se trouvent sous ce dossier.

Le service Enregistreur VSS de SQL Server, disponible avec le logiciel de base de données Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3, doit être démarré pour que le service Enregistreur VSS de SharePoint 2010 fonctionne correctement. Par défaut, le service Enregistreur VSS de SharePoint 2010 n'est pas démarré automatiquement.

Vous devez vous assurer que le service Administration de SharePoint 2010 est démarré sur tous les serveurs de la batterie avant d'effectuer une sauvegarde. Par défaut, ce service n'est pas démarré sur les installations autonomes.

Vous devez vous assurer que les comptes d'utilisateurs dont vous souhaitez effectuer une sauvegarde ont accès au dossier de sauvegarde partagé.

Si vous effectuez la sauvegarde à l'aide de l'Administration centrale, le compte de service SQL du serveur de bases de données, le compte de service du minuteur et le compte d'identité du pool d'applications de l'Administration centrale doivent disposer de l'autorisation Contrôle total sur les emplacements de sauvegarde.

Le serveur de bases de données et le serveur de la batterie à sauvegarder doivent pouvoir se connecter l'un à l'autre.

Si vous avez modifié le compte de la batterie, avant de sauvegarder, vous devez accorder au nouveau compte les autorisations appropriées sur le dossier partagé qui contiendra les données de sauvegarde.

Si vous utilisez SQL Server avec le chiffrement TDE (Transparent Data Encryption) et que vous sauvegardez votre environnement à l'aide d'outils SharePoint ou SQL Server, la clé de chiffrement TDE n'est ni sauvegardée ni restaurée. Vous devez la sauvegarder manuellement. Lors de la restauration, vous devez restaurer la clé manuellement avant de restaurer les données. Pour plus d'informations, voir Présentation du chiffrement TDE (http://go.microsoft.com/fwlink/?linkid=196394&clcid=0x40C).

Comment créer un dossier partagé

Appliquez cette procédure pour créer un dossier partagé sur le réseau susceptible de recevoir et de contenir les données sauvegardées. Vous pouvez également utiliser ce dossier partagé lors de la restauration des données. Si vous avez déjà un dossier partagé qui remplit cette fonction, vous n'avez pas besoin d'appliquer cette procédure. En l'appliquant, vous vous assurez de pouvoir accéder au dossier partagé à partir de l'ordinateur qui exécute le logiciel de base de données Microsoft SQL Server et à partir de l'ordinateur qui héberge le site Web Administration centrale de SharePoint.

Si vous effectuez une sauvegarde à l'aide de l'Administration centrale et que SQL Server n'est pas en cours d'exécution sur le même serveur, le dossier de sauvegarde doit se trouver sur le même réseau ou le même serveur de bases de données que SharePoint Foundation 2010. Si vous avez une installation autonome dans laquelle SQL Server et SharePoint Foundation 2010 s'exécutent sur le même serveur, vous pouvez utiliser un chemin d'accès de lecteur local comme emplacement du dossier de sauvegarde. Si vous utilisez SQL Server pour sauvegarder une base de données directement, par exemple à l'aide de SQL Server Management Studio, le dossier de sauvegarde peut être local ou sur le réseau. Pour de meilleures performances, nous vous recommandons de sauvegarder dans un dossier local sur le serveur de bases de données, puis de déplacer ou copier les fichiers de sauvegarde dans un dossier réseau.

Pour créer un dossier partagé

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe Administrateurs sur l'ordinateur sur lequel vous souhaitez créer le dossier partagé.

  2. Si vous créez le dossier partagé sur un ordinateur autre que celui qui exécute SQL Server, assurez-vous que le compte de service pour SQL Server (MSSQLSERVER) utilise un compte d'utilisateur de domaine et qu'il dispose de l'autorisation Contrôle total sur le dossier partagé.

  3. Sur le serveur où vous souhaitez stocker les données de sauvegarde, créez un dossier partagé.

  4. Sous l'onglet Partage de la boîte de dialogue Propriétés, cliquez sur Partager puis, dans la boîte de dialogue Partage de fichier, ajoutez les comptes suivants et affectez-leur le rôle Copropriétaire :

    • Compte de service SQL Server (MSSQLSERVER)

    • Le compte d'identité du pool d'applications de l'Administration centrale de SharePoint

    • Le compte de service du Minuteur SharePoint 2010 (si vous utilisez SharePoint Foundation 2010 pour effectuer des sauvegardes)

Voir aussi

Autres ressources

Dossiers partagés

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Meilleures pratiques de sauvegarde et récupération (SharePoint Foundation 2010)

Cet article décrit les meilleures pratiques à respecter afin d'aider à garantir le succès des opérations de sauvegarde et de restauration dans Microsoft SharePoint Foundation 2010 et la protection de l'environnement contre toute perte de données ou intervalle de continuité. Il décrit les meilleures pratiques en matière de performances, d'assurance de la qualité, de sécurité et d'excellence opérationnelle.

Dans cet article :

  • Meilleures pratiques pour les performances

  • Meilleures pratiques pour l'assurance de la qualité

  • Meilleures pratiques procédurales

Meilleures pratiques pour les performances

Les opérations de sauvegarde et de restauration peuvent consommer des ressources de serveurs et limiter les performances des serveurs lors de l'exécution des opérations. Ces meilleures pratiques vous aideront à réduire l'utilisation des ressources et à accroître les performances des serveurs et des opérations de sauvegarde et de restauration.

Réduire la latence entre SQL Server et l'emplacement de sauvegarde

En règle générale, il est préférable d'utiliser un disque local sur le serveur de bases de données, et non un lecteur réseau, pour les sauvegardes, puis de copier ultérieurement les données dans un dossier partagé sur le réseau. Les lecteurs réseau ayant une latence d'1 milliseconde ou moins entre eux et le serveur de bases de données offriront de bonnes performances.

Pour éviter les goulets d'étranglement d'E/S, effectuez la sauvegarde principale sur un disque distinct de celui qui exécute SQL Server 2008 avec SP1 et mise à jour cumulative 2.

De par leur conception même, la plupart des travaux de sauvegarde consomment toutes les ressources d'E/S disponibles pour effectuer le travail. Par conséquent, il se peut que vous constatiez une mise en file d'attente sur disque, qui peut entraîner une latence des demandes d'E/S supérieure à la moyenne.

Éviter les conflits de traitement

N'exécutez pas de travaux de sauvegarde pendant les périodes au cours desquelles les utilisateurs ont besoin d'accéder au système. Envisagez des sauvegardes échelonnées afin que toutes les bases de données ne soient pas sauvegardées en même temps.

Limiter la taille des bases de données afin de réduire les durées de récupération

Limitez la taille des bases de données afin d'accélérer la sauvegarde et la récupération. Vous pouvez pour cela utiliser plusieurs bases de données de contenu pour une application Web, au lieu d'une seule grande base de données de contenu.

Utiliser des sauvegardes incrémentielles pour les grandes bases de données

Utilisez des sauvegardes incrémentielles pour les grandes bases de données telles que celles disponibles avec DPM 2010. Les sauvegardes incrémentielles peuvent être restaurées plus rapidement et plus efficacement que les sauvegardes complètes pour les grandes bases de données. Pour plus d'informations sur les types de sauvegardes, voir Vue d'ensemble de la sauvegarde (SQL Server) (http://go.microsoft.com/fwlink/?linkid=203863&clcid=0x40C).

Utiliser la compression durant la sauvegarde

Dans certaines circonstances, vous pouvez recourir à la compression pour améliorer la taille (réduction de 30 %) et la durée (éduction de 25 %) des sauvegardes. La compression des sauvegardes a été introduite dans SQL Server 2008 Enterprise. Pour plus d'informations sur l'impact de la compression des sauvegardes sur les performances dans SQL Server, voir Compression de sauvegardes (SQL Server) (http://go.microsoft.com/fwlink/?linkid=129381&clcid=0x40C).

Suivre les recommandations permettant d'optimiser les sauvegardes et les restaurations SQL Server

Si vous utilisez des sauvegardes SQL Server, afin de réduire au minimum le temps de récupération, combinez des sauvegardes complètes, différentielles et du journal des transactions (pour le mode de récupération complète ou utilisant les journaux de transactions). Les sauvegardes différentielles de la base de données sont généralement plus rapides à créer que les sauvegardes complètes et réduisent la quantité du journal des transactions requise pour la récupération de la base de données.

Si vous utilisez le mode de récupération complète, nous vous recommandons de tronquer régulièrement les fichiers journaux de transactions afin d'éviter tout problème de maintenance.

Pour obtenir des recommandations détaillées sur l'optimisation des performances de sauvegarde et de restauration dans SQL Server, voir Optimisation des performances de sauvegarde et de restauration dans SQL Server (http://go.microsoft.com/fwlink/?linkid=126630&clcid=0x40C).

Utiliser un dispositif RAID 10 en cas d'utilisation de la technologie RAID

Réfléchissez bien avant de décider s'il faut utiliser un dispositif RAID (Redundant Array of Independent Disks) sur l'unité de sauvegarde sur disque. Par exemple, un dispositif RAID 5 présente des performances d'écriture faibles, avec une vitesse approximativement identique à celle obtenue dans le cas d'un seul disque. (En effet, le niveau RAID 5 doit gérer les informations de parité.) L'utilisation d'un dispositif RAID 10 pour une unité de sauvegarde peut procurer des sauvegardes plus rapides. Pour plus d'informations sur la façon d'utiliser la technologie RAID dans le cadre des sauvegardes, voir Configurer RAID afin d'optimiser les opérations d'écriture et de lecture SQL Server (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=126632&clcid=0x40C).

Configurer les paramètres SharePoint afin d'améliorer les performances de sauvegarde ou de restauration

Vous pouvez configurer des paramètres dans l'Administration centrale et dans Windows PowerShell de façon à augmenter l'efficacité et les performances de sauvegarde et de restauration.

Si vous utilisez l'applet de commande Windows PowerShell Export-SPWeb, vous pouvez utiliser le paramètre NoFileCompression. Par défaut, SharePoint Foundation 2010 utilise la compression de fichier lors de l'exportation d'applications Web, de collections de sites, de listes ou de bibliothèques de documents. Vous pouvez utiliser ce paramètre pour annuler la compression de fichier lors de l'exportation et de l'importation. La compression de fichier peut utiliser jusqu'à 30 % de ressources en plus, mais le fichier exporté utilisera environ 25 % d'espace disque en moins. Si vous utilisez le paramètre NoFileCompression lors de l'exportation, vous devez l'utiliser également lorsque vous importez le même contenu.

Vous pouvez également utiliser le paramètre NoLogFile. Par défaut, SharePoint Foundation 2010 crée toujours un fichier journal lorsque vous exportez du contenu. Vous pouvez utiliser ce paramètre pour éviter la création de fichier journal et économiser les ressources. Cependant, il est recommandé de toujours créer des journaux, car ceux-ci peuvent être utiles lors des opérations de dépannage. De plus, la création de journal n'utilise pas beaucoup de ressources.

Remarque :
Ces paramètres ne sont pas disponibles par le biais de l'Administration centrale.

Si vous utilisez l'applet de commande Backup-SPFarm, vous pouvez utiliser le paramètre BackupThreads pour spécifier le nombre de threads utilisées par SharePoint Foundation 2010 durant le processus de sauvegarde. Plus le nombre de threads est élevé, plus cette opération de sauvegarde consommera de ressources, mais moins elle prendra de temps (si les ressources suffisantes sont disponibles). Toutefois, chaque thread étant signalé individuellement dans les fichiers journaux, l'utilisation d'un nombre restreint de threads facilite l'interprétation des fichiers journaux. Par défaut, trois threads sont utilisés. La quantité maximale de threads disponibles est 10.

Remarque :
Ce paramètre est également disponible par le biais de l'Administration centrale dans la page Paramètres de sauvegarde et de restauration par défaut, dans la section Sauvegarde et restauration.

Prendre en compte la taille de la collection de sites lors de la détermination des outils à utiliser

Si des sauvegardes de la collection de sites sont nécessaires, en plus des sauvegardes au niveau de la base de données ou de la batterie, sélectionnez les outils que vous utiliserez en fonction de la taille de la collection de sites.

  • Moins de 15 gigaoctets (Go) : utilisez la commande Windows PowerShell Backup-SPSite. Pour plus d'informations, voir Sauvegarder une collection de sites (SharePoint Foundation 2010).

  • 15-100 Go : utiliser un outils des Produits et technologies SharePoint, un outil SQL Server ou autre outil de sauvegarde de base de données afin de protéger la base de données de contenu qui contient la collection de sites. Pour plus d'informations, voir Sauvegarder une collection de sites (SharePoint Foundation 2010).

  • Plus de 100 Go : utilisez une solution de sauvegarde différentielle, telle que Microsoft SQL Server 2005 ou DPM 2010, au lieu des outils de sauvegarde et restauration intégrés.

Meilleures pratiques pour l'assurance de la qualité

Vous pouvez adhérer à ces meilleures pratiques afin d'aider à garantir la qualité des sauvegardes de l'environnement de batterie et réduire les risques de perte de données.

S'assurer de disposer d'un espace de stockage adéquat

Assurez-vous que le système dispose de suffisamment d'espace disque pour prendre en charge la sauvegarde.

Tester de manière régulière la qualité des sauvegardes

Testez régulièrement les sauvegardes et vérifiez leur cohérence. Effectuez des exercices de récupération afin de valider le contenu de la sauvegarde et de vous assurer qu'il est possible de restaurer l'environnement entier. Pour les environnements distribués géographiquement, préparez la récupération d'urgence en configurant une batterie distante. Vous pouvez ensuite restaurer l'environnement en exécutant la commande d'attachement de base de données pour télécharger une copie de la base de données sur la batterie distante et rediriger les utilisateurs. Effectuez régulièrement un essai de récupération de données pour vérifier que les fichiers sont sauvegardés correctement. Un essai de restauration peut exposer des problèmes matériels non détectés lors des vérifications logicielles.

Sauvegarder les journaux de suivi ULS

Les outils SharePoint Foundation 2010 n'effectuent pas de sauvegarde des journaux de suivi ULS. Les données contenues dans les journaux ULS peuvent s'avérer utiles pour l'analyse des performances, le dépannage, l'analyse de la conformité aux contrats de niveau de service et pour des raisons légales, réglementaires ou professionnelles. Il convient donc de protéger ces données dans le cadre de la maintenance de routine. Pour plus d'informations sur la sauvegarde des journaux ULS, voir Sauvegarder ou archiver des journaux (SharePoint Foundation 2010).

Stocker une copie des fichiers de sauvegarde hors site

Pour prévenir les pertes provoquées par une catastrophe, telle qu'un incendie ou un tremblement de terre, conservez des copies en double des sauvegardes ailleurs que sur les serveurs. Procéder ainsi peut vous éviter la perte de données critiques. Une pratique recommandée consiste à conserver trois copies du support de sauvegarde et au moins une copie hors site dans un environnement contrôlé. Cette copie doit inclure tous les documents et fichiers de sauvegarde et récupération, les sauvegardes des journaux de transactions et de bases de données, ainsi que les sauvegardes des journaux de suivi et d'utilisation.

Meilleures pratiques procédurales

Vous pouvez appliquer ces meilleures pratiques procédurales afin d'aider à planifier et effectuer les opérations de sauvegarde et restauration avec davantage de facilité et d'assurance et une meilleure documentation.

Utiliser des noms de serveurs complets

Lorsque vous faites référence à des serveurs dans un domaine différent, utilisez toujours des noms de domaine complets.

Conserver des archives rigoureuses

Lorsque vous déployez SharePoint Foundation 2010, conservez un enregistrement des comptes que vous créez, ainsi que des noms d'ordinateurs, des mots de passe et des options de configuration retenues. Conservez ces informations en lieu sûr.

Conserver un environnement de récupération à portée de main

Préparez-vous à une récupération d'urgence et à des tests de restauration en configurant une batterie distante. Vous pouvez ensuite restaurer l'environnement en exécutant la commande d'attachement de base de données pour télécharger une copie de la base de données sur la batterie distante et rediriger les utilisateurs. De même, vous pouvez configurer un environnement de secours exécutant la même version des logiciels que l'environnement de production, de manière à pouvoir restaurer les bases de données et récupérer les documents rapidement.

Planifier les opérations de sauvegarde

Si vous voulez planifier des sauvegardes, vous pouvez utiliser le Planificateur de tâches de Windows pour les exécuter à l'aide d'un fichier de script Windows PowerShell (*.ps1).

Utiliser le fournisseur SQL FILESTREAM avec le stockage BLOB

Si vous utilisez le stockage BLOB à l'aide du fournisseur SQL FILESTREAM et que vous sauvegardez la base de données de contenu avec ce magasin d'objets blob distants défini, le magasin d'objets blob distants et la base de données de contenu seront tous deux sauvegardés et restaurés en cas d'utilisation d'outils SharePoint ou SQL Server. Nous déconseillons l'utilisation du magasin d'objets blob distants avec d'autres méthodes de restauration.

Historique des modifications

Date | Description | Raison
14 octobre 2010 | Publication initiale |


Configuration des autorisations pour la sauvegarde et la récupération (SharePoint Foundation 2010)

Avant de sauvegarder ou restaurer Microsoft SharePoint Foundation 2010, vous devez vous assurer que le compte de service de minuterie, le compte de service SQL Server et les utilisateurs qui exécutent les opérations de sauvegarde ou restauration ont les autorisations correctes ou sont membres des groupes de sécurité Windows ou des groupes SharePoint appropriés. Ces autorisations et appartenances aux groupes doivent être configurées initialement. Ensuite, elles doivent être mises à jour lorsque de nouveaux composants de batterie de serveurs sont ajoutés à l'environnement et si vous souhaitez ajouter des utilisateurs susceptibles d'effectuer des opérations de sauvegarde et de restauration.

Dans cet article :

  • Autorisations pour le service du minuteur SPTimerV4 et le compte SQL Server

  • Appartenances aux groupes nécessaires pour exécuter des opérations de sauvegarde et restauration dans l'administration centrale

  • Définition des autorisations pour l'exécution d'opérations de sauvegarde et de restauration à l'aide de Windows PowerShell

Autorisations pour le service du minuteur SPTimerV4 et le compte SQL Server

Le service du minuteur Windows SharePoint Services Timer V4 (SPTimerV4) et le compte de service SQL Server dans SharePoint Foundation 2010 effectuent des opérations de sauvegarde et restauration au nom de l'utilisateur. Ces comptes de service requièrent des autorisations de type contrôle total sur tous les dossiers de sauvegarde.

Appartenances aux groupes nécessaires pour exécuter des opérations de sauvegarde et restauration dans l'administration centrale

Vous devez vous assurer que tous les comptes d'utilisateurs qui exécuteront des opérations de sauvegarde ou de restauration de votre batterie de serveurs et des composants de la batterie de serveurs à l'aide de l'administration centrale disposent des appartenances aux groupes qui sont décrites dans le tableau suivant.

Appartenances aux groupes nécessaires

Composant de la batterie de serveurs | Membre du groupe Administrateurs sur l'ordinateur local | Membre du groupe SharePoint des administrateurs de batterie de serveurs
Batterie de serveurs | Oui | Non
Base de données de contenu | Oui | Non
Collections de sites | Non | Oui
Site, liste, bibliothèque de documents | Non | Oui

Définition des autorisations pour l'exécution d'opérations de sauvegarde et de restauration à l'aide de Windows PowerShell

Vous devez vous assurer que tous les comptes d'utilisateurs qui exécuteront la sauvegarde ou la restauration de votre batterie de serveurs et les composants de la batterie de serveurs à l'aide de Windows PowerShell sont ajoutés au rôle de SharePoint_Shell_Access pour une base de données spécifiée et ont les autorisations décrites dans le tableau figurant plus loin dans cette section.

Vous pouvez exécuter l'applet de commande Add-SPShellAdmin pour ajouter un compte d'utilisateur à ce rôle. Vous devez exécuter la commande pour chaque compte d'utilisateur. En outre, vous devez exécuter la commande pour toutes les bases de données auxquelles vous souhaitez accorder l'accès.

Remarque :
Vous devez accorder à un compte d'utilisateur uniquement l'accès pour la sauvegarde et la restauration d'un composant de batterie de serveurs spécifique à la fois. Vous devrez peut-être effectuer cette tâche à nouveau uniquement lorsque de nouveaux composants de batterie de serveurs sont ajoutées à votre environnement ou lorsque vous souhaitez ajouter des utilisateurs devant effectuer des opérations de sauvegarde et de restauration.

Pour ajouter un utilisateur au rôle SharePoint_Shell_Access ou en supprimer un de celui-ci à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Add-SPShellAdmin -Username <User account> -Database <Database ID>

    Pour ajouter un compte d'utilisateur à toutes les bases de données de la batterie de serveurs, tapez la commande suivante et appuyez sur ENTRÉE :

    ForEach ($db in Get-SPDatabase) {Add-SPShellAdmin -Username <User account> -Database $db}

    Pour supprimer un compte d'utilisateur de toutes les bases de données de la batterie de serveurs, tapez la commande suivante et appuyez sur ENTRÉE :

    ForEach ($db in Get-SPDatabase) {Remove-SPShellAdmin -Username <User account> -Database $db}

    Pour afficher les comptes d'utilisateurs actuellement ajoutés aux bases de données de la batterie de serveurs, tapez la commande suivante et appuyez sur ENTRÉE :

    ForEach ($db in Get-SPDatabase) {Get-SPShellAdmin -Database $db}

Pour plus d\rquote informations, voir Add-SPShellAdmin.

Vous devrez peut-être également accorder des autorisations supplémentaires aux utilisateurs exécutant la sauvegarde ou restauration à l'aide de Windows PowerShell. Le tableau suivant indique les autorisations qui sont nécessaires.

Autorisations requises pour Windows PowerShell

Composant de la batterie de serveurs | Membre du groupe Administrateurs sur l'ordinateur local | Membre du groupe SharePoint des administrateurs de batterie de serveurs | Contrôle total sur le dossier de sauvegarde
Batterie de serveurs | Oui | Non | Oui
Base de données de contenu | Oui | Non | Oui
Collection de sites | Non | Oui | Oui
Site, liste, bibliothèque de documents | Oui | Non | Oui

Historique des modifications


Sauvegarde (SharePoint Foundation 2010)
Voir aussi

Les articles de cette section visent à répondre aux besoins des informaticiens chargés de la planification, de la conception, du déploiement et de l'exploitation de solutions de sauvegarde et de récupération. Ces solutions peuvent se trouver dans les environnements d'entreprise ou de succursales. Les informaticiens responsables des solutions de sauvegarde et de récupération sont supposés comprendre les détails techniques contenus dans cette section.

Une sauvegarde est une copie de données utilisée pour restaurer et récupérer ces données après une défaillance du système. Les sauvegardes permettent de restaurer des données après un échec. Si vous effectuez les sauvegardes appropriées, vous pouvez récupérer de nombreuses défaillances système, notamment les suivantes :

  • Défaillance d'un support

  • Erreurs d'utilisateur (telles que la suppression d'un fichier par inadvertance)

  • Défaillances matérielles (telles qu'un disque dur endommagé ou la perte définitive d'un serveur)

  • Catastrophes naturelles

En outre, il est utile de conserver les sauvegardes de données pour des opérations de routine. Ces opérations peuvent être la copie d'une base de données d'un serveur à un autre, la mise en miroir d'une base de données et l'archivage à des fins administratives.

Sauvegarder tout ou partie d'une batterie de serveurs

Les tâches suivantes de sauvegarde et de récupération sont effectuées sur la batterie complète, des bases de données de batterie, des sites, des sous-sites ou des fichiers :

  • Sauvegarder une batterie de serveurs (SharePoint Foundation 2010)

    Cet article explique les procédures à utiliser pour sauvegarder toute la batterie.

  • Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder les paramètres de configuration d'une batterie.

  • Copier des paramètres de configuration d'une batterie à l'autre (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour copier les paramètres de configuration d'une batterie à une autre, notamment comment sauvegarder et récupérer une batterie sans les bases de données de contenu, comment sauvegarder et récupérer uniquement les configurations et comment créer un script de déploiement.

  • Sauvegarder une application Web (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder une application Web associée à la batterie, notamment les bases de données de configuration et de contenu.

  • Sauvegarder une application de service (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder une application de service associée à la batterie, notamment les bases de données de configuration et de contenu.

  • Sauvegarder une collection de sites (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder une collection de sites qui est associée à la batterie.

  • Sauvegarder une base de données de contenu (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder une base de données de contenu qui est associée à la batterie.

  • Sauvegarder des bases de données par capture instantanée (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder une base de données de contenu qui est associée à la batterie en sauvegardant la base de données dans une capture instantanée.

  • Sauvegarder les personnalisations (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder les personnalisations associées à la batterie.

  • Exporter un site, une liste ou une bibliothèque de documents (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour exporter une liste, un site ou une bibliothèque de documents associé à la batterie. Vous pouvez ensuite importer les éléments dans une autre batterie ou les transférer ailleurs dans cette batterie.

  • Sauvegarder ou archiver des journaux (SharePoint Foundation 2010)

    Cet article explique les procédures que vous pouvez utiliser pour sauvegarder ou archivé les fichiers journaux associés à la batterie.

Voir aussi

Concepts

Récupération (SharePoint Foundation 2010)

Historique des modifications


Sauvegarder une batterie de serveurs (SharePoint Foundation 2010)

Cette rubrique explique comment sauvegarder une batterie de serveurs entière.

Procédures décrites dans cette tâche :

  • Utiliser Windows PowerShell pour sauvegarder une batterie de serveurs

  • Utiliser l'Administration centrale pour sauvegarder une batterie de serveurs

  • Utiliser les outils SQL Server pour sauvegarder une batterie de serveurs

Pour plus d'informations sur l'outil à utiliser pour les sauvegardes, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

Il est recommandé de sauvegarder régulièrement la batterie de serveurs entière en sauvegardant la configuration et le contenu. La sauvegarde régulière de la batterie de serveurs réduit les pertes de données susceptibles de se produire lors de défaillances matérielles, de pannes d'alimentation ou d'autres problèmes. Il s'agit d'un processus simple grâce auquel il est possible de récupérer toutes les données et configurations de la batterie de serveurs en cas de besoin.

Considérations relatives à la sauvegarde de batterie

Il convient de prendre en compte les points suivants lors de la préparation à la sauvegarde d'une batterie.

  • La réalisation d'une sauvegarde n'a pas d'impact sur l'état de la batterie de serveurs. Toutefois, elle requiert des ressources et peut légèrement affecter les performances de la batterie de serveurs pendant le déroulement de l'opération. Vous pouvez éviter les problèmes de performances en sauvegardant la batterie de serveurs pendant les tranches horaires où elle est faiblement utilisée, par exemple en dehors des heures d'ouverture des bureaux.

  • Le processus de sauvegarde de la batterie ne sauvegarde pas les certificats que vous avez utilisés pour former des relations d'approbation. Assurez-vous de disposer de copies de ces certificats avant de sauvegarder la batterie. Vous devez rétablir ces relations d'approbation après avoir restauré la batterie.

  • La sauvegarde de la batterie entraîne la sauvegarde des bases de données de contenu de configuration et d'Administration centrale, mais celles-ci ne peuvent pas être restaurées à l'aide des outils Microsoft SharePoint Foundation 2010. Pour plus d'informations sur la sauvegarde et la restauration de toutes les bases de données de la batterie, voir Déplacer toutes les bases de données (SharePoint Foundation 2010).

  • Lorsque vous sauvegardez une batterie qui contient une application Web configurée de façon à utiliser l'authentification basée sur les formulaires, vous devez également utiliser un système de sauvegarde de fichiers afin de protéger les fichiers Web.config car ceux-ci doivent être mis à jour manuellement de façon à inscrire les fournisseurs d'appartenances et de rôles, et les modifications apportées manuellement aux fichiers Web.config ne sont pas sauvegardées. De plus, les fichiers Web.config ne sont pas restaurés lorsque vous restaurez une application Web. À l'issue de la récupération, vous devez mettre à jour les fichiers Web.config et redéployer les fournisseurs. Pour plus d'informations, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010) et Configurer l'authentification par revendications (SharePoint Foundation 2010).

  • La sauvegarde de SharePoint Foundation 2010 permet de sauvegarder les définitions des types de contenu externe du service Business Data Connectivity mais pas de sauvegarder la source de données proprement dite. Pour protéger les données, vous devez sauvegarder la source de données lors de la sauvegarde du service Business Data Connectivity ou de la batterie de serveurs.

    Si vous restaurez le service Business Data Connectivity ou la batterie de serveurs, et si vous restaurez ensuite le service de données à un autre emplacement, vous devez changer les informations d'emplacement dans la définition du type de contenu externe. Dans le cas contraire, le service Business Data Connectivity risque de ne pas pouvoir localiser la source de données.

  • La sauvegarde de SharePoint Foundation 2010 permet de sauvegarder les magasins d'objets BLOB distants mais uniquement si vous utilisez le fournisseur de magasins d'objets BLOB distants FILESTREAM pour placer les données dans des magasins d'objets BLOB distants.

    Si vous utilisez un autre fournisseur, vous devez sauvegarder manuellement les magasins d'objets BLOB distants.

  • Si vous utilisez SQL Server avec le chiffrement TDE (Transparent Data Encryption) et que vous sauvegardez votre environnement à l'aide d'outils SharePoint ou SQL Server, la clé de chiffrement TDE n'est ni sauvegardée ni restaurée. Vous devez la sauvegarder manuellement. Lors de la restauration, vous devez restaurer la clé manuellement avant de restaurer les données. Pour plus d'informations, voir Présentation du chiffrement TDE (http://go.microsoft.com/fwlink/?linkid=196394&clcid=0x40C).

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier sur l'ordinateur local ou sur le réseau où stocker les sauvegardes. Pour de meilleures performances, il est recommandé d'effectuer les sauvegardes vers l'ordinateur local puis de déplacer les fichiers de sauvegarde vers un dossier réseau. Pour plus d'informations sur la façon de créer un dossier de sauvegarde, voir Préparer la sauvegarde et la récupération (SharePoint Foundation 2010).

Utiliser Windows PowerShell pour sauvegarder une batterie de serveurs

Vous pouvez utiliser Windows PowerShell pour sauvegarder la batterie de serveurs manuellement ou dans le cadre d'un script exécutable à intervalles planifiés.

Pour sauvegarder une batterie de serveurs à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Backup-SPFarm -Directory <BackupFolder> -BackupMethod {Full | Differential} [-Verbose]

    Où <BackUpFolder> est le chemin d'accès au dossier sur l'ordinateur local ou le réseau dans lequel vous souhaitez stocker les sauvegardes.

    Remarque :
    Si vous sauvegardez la batterie de serveurs pour la première fois, vous devez utiliser l'option Full. Vous devez effectuer une sauvegarde complète avant de pouvoir effectuer une sauvegarde différentielle.

Pour plus d'informations, voir Backup-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour sauvegarder une batterie de serveurs

Vous pouvez utiliser l'Administration centrale pour sauvegarder la batterie de serveurs.

Pour sauvegarder une batterie de serveurs à l'aide de l'Administration centrale

  1. Pour effectuer cette procédure, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute l'Administration centrale.

  2. Dans l'Administration centrale, dans la page Accueil, dans la section Sauvegarde et restauration, cliquez sur Effectuer une sauvegarde.

  3. Dans la page Effectuer une sauvegarde - Étape 1 de 2 : sélectionner un composant à sauvegarder, sélectionnez la batterie de serveurs dans la liste des composants, puis cliquez sur Suivant.

  4. Dans la page Effectuer une sauvegarde - Étape 2 sur 2 : sélectionner les options de sauvegarde, dans la section Type de sauvegarde, sélectionnez Complète ou Différentielle.

    Remarque :
    Si vous sauvegardez la batterie de serveurs pour la première fois, vous devez utiliser l'option Complète. Vous devez effectuer une sauvegarde complète avant de pouvoir effectuer une sauvegarde différentielle.

  5. Dans la section Sauvegarder uniquement les paramètres de configuration, cliquez sur Sauvegarder le contenu et les paramètres de configuration.

  6. Dans la section Emplacement des fichiers de sauvegarde, tapez le chemin d'accès UNC du dossier de sauvegarde, puis cliquez sur Lancer la sauvegarde.

  7. Vous pouvez afficher l'état général de tous les travaux de sauvegarde en haut de la page État de la sauvegarde et de la restauration dans la section État. Vous pouvez afficher l'état du travail de sauvegarde en cours dans la partie inférieure de la page dans la section Sauvegarde. La page de l'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez actualiser manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la sauvegarde peut prendre plusieurs secondes.

    Si vous obtenez des erreurs, vous pouvez les examiner dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous pouvez également obtenir des détails supplémentaires dans le fichier Spbackup.log stocké sur le chemin d'accès UNC que vous avez spécifié à l'étape 5.

Utiliser les outils SQL Server pour sauvegarder une batterie de serveurs

Si vous souhaitez sauvegarder la batterie de serveurs entière, vous devez utiliser Windows PowerShell ou l'Administration centrale. Vous ne pouvez pas sauvegarder la batterie de serveurs entière à l'aide des outils SQL Server, car vous ne pouvez pas utiliser ceux-ci pour sauvegarder la configuration de la batterie de serveurs. Toutefois, vous pouvez sauvegarder toutes les bases de données associées à la batterie de serveurs.

Pour sauvegarder les bases de données associées à une batterie de serveurs à l'aide des outils SQL Server

  1. Pour que vous puissiez sauvegarder des bases de données SharePoint Foundation 2010 à l'aide des outils SQL Server, le compte utilisé pour la sauvegarde des bases de données doit être membre du rôle de base de données fixe db_backupoperator SQL Server sur le serveur de bases de données qui héberge chaque base de données.

  2. Ouvrez SQL Server Management Studio et connectez-vous au serveur de bases de données.

  3. Dans l'Explorateur d'objets, développez Bases de données.

  4. Cliquez avec le bouton droit sur la base de données à sauvegarder, pointez sur Tâches, puis cliquez sur Sauvegarder.

  5. Dans la boîte de dialogue Sauvegarder la base de données, dans la zone Source, sélectionnez le type de sauvegarde que vous souhaitez effectuer dans la liste Type de sauvegarde. Pour plus d'informations sur le type de sauvegarde à utiliser, voir Vue d'ensemble du mode de récupération (http://go.microsoft.com/fwlink/?linkid=114396&clcid=0x40C).

  6. Dans la zone Composant de sauvegarde, cliquez sur Base de données.

  7. Utilisez le nom fourni par défaut ou spécifiez un nom pour le jeu de sauvegarde dans la zone de texte Nom.

  8. Spécifiez la date d'expiration du jeu de sauvegarde. Cette date détermine pendant combien de temps, ou quand, le jeu de sauvegarde peut être remplacé par les sauvegardes suivantes effectuées sous le même nom. Par défaut, le jeu de sauvegarde est défini pour ne jamais expirer (0 jour).

  9. Dans la zone Destination, indiquez où vous souhaitez stocker la sauvegarde.

  10. Cliquez sur OK pour sauvegarder la base de données.

  11. Répétez les étapes 1 à 10 pour chaque base de données de la batterie de serveurs.

Contenu connexe

Centre de ressources | Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201997&clcid=0x40C)
Contenu IT Pro | Restaurer une batterie de serveurs (SharePoint Foundation 2010) Restaurer une application Web (SharePoint Foundation 2010) Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) Sauvegarde et récupération (SharePoint Foundation 2010)
Contenu de développement | Protection et récupération des données (http://go.microsoft.com/fwlink/?linkid=199237&clcid=0x40C)

Historique des modifications

Date | Description | Raison
16 septembre 2010 | 2010/09/13 | Mise à jour du contenu
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment sauvegarder la configuration d'une batterie de serveurs.

Dans les versions antérieures de Microsoft SharePoint Foundation, vous ne pouviez pas sauvegarder ou restaurer la base de données de configuration. Dans Microsoft SharePoint Foundation 2010, vous pouvez effectuer l'opération équivalente en sauvegardant ou en restaurant la configuration de la batterie de serveurs.

Il est recommandé de sauvegarder régulièrement la batterie de serveurs entière, en sauvegardant la configuration et le contenu. Vous pouvez cependant souhaiter des sauvegardes de type « configuration uniquement » dans des environnements de test ou de développement. De même, si vous utilisez des outils Microsoft SQL Server pour sauvegarder les bases de données de votre batterie, vous souhaiterez sans doute sauvegarder la configuration. La sauvegarde régulière de la batterie de serveurs réduit le risque de pertes de données susceptibles de se produire suite à des défaillances matérielles, pannes d'alimentation ou autres problèmes. Cela contribue à garantir la disponibilité de toutes les données et configurations de la batterie de serveurs pour une opération de récupération. Pour plus d'informations sur les éléments à sauvegarder, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

La sauvegarde de la configuration extrait et sauvegarde les paramètres de configuration à partir d'une base de données de configuration SharePoint Foundation 2010. Vous pouvez sauvegarder la configuration à partir de n'importe quelle base de données de configuration, notamment la base de données de configuration de la batterie de serveurs actuelle ou la base de données de configuration d'une autre batterie de serveurs ou une base de données de configuration qui n'est associée à aucune batterie de serveurs.

Pour plus d'informations sur l'outil à utiliser pour les sauvegardes, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

Procédures décrites dans cette tâche :

  • Exigences relatives à la tâche

  • Utiliser Windows PowerShell pour sauvegarder la configuration d'une batterie de serveurs

Remarque :
Vous ne pouvez utiliser ni les outils SQL Server ni Data Protection Manager pour sauvegarder la configuration d'une batterie de serveurs.

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier sur l'ordinateur local ou sur le réseau où stocker les sauvegardes. Pour de meilleures performances, il est recommandé d'effectuer les sauvegardes sur l'ordinateur local puis de déplacer les fichiers de sauvegarde vers un dossier réseau. Pour plus d'informations sur la façon de créer un dossier de sauvegarde, voir Préparer la sauvegarde et la récupération (SharePoint Foundation 2010).

Important :
La sauvegarde de la configuration de la batterie de serveurs ne sauvegarde pas les informations nécessairres à la restauration des applications de service. Pour restaurer une application de service, il vous faut une sauvegarde de la configuration et du contenu de la batterie de serveurs. Pour plus d'informations sur la sauvegarde des applications de service, voir Sauvegarder une application de service (SharePoint Foundation 2010).

Utiliser Windows PowerShell pour sauvegarder la configuration d'une batterie de serveurs

Vous pouvez utiliser Windows PowerShell pour sauvegarder la configuration de n'importe quelle base de données de configuration de la batterie de serveurs actuelle, d'une autre batterie de serveurs ou encore une base de données de configuration qui n'est associée à aucune batterie de serveurs. Vous pouvez sauvegarder la configuration d'une batterie manuellement ou dans le cadre d'un script qui peut être exécuté à intervalles planifiés.

Pour sauvegarder la configuration d'une base de données de configuration à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    Backup-SPConfigurationDatabase -Directory <BackupFolder> -DatabaseServer <DatabaseServerName> -DatabaseName <DatabaseName> -DatabaseCredentials <WindowsPowerShellCredentialObject> [-Verbose]

    Où :

    • <BackupFolder> est le chemin d'accès au dossier contenant les fichiers de sauvegarde corrects.

    • <DatabaseServerName> est le nom du serveur de bases de données pour la batterie que vous sauvegardez.

    • <DatabaseName> est le nom de la base de données de configuration de batterie.

    • Si vous n'avez pas ouvert de session avec un compte doté du rôle de base de données fixe db_backupoperator sur le serveur de bases de données où est stockée la base de données de configuration, vous devez spécifier la valeur pour le paramètre DatabaseCredentials.

Pour plus d'informations, voir Backup-SPConfigurationDatabase.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utilisation de l'administration centrale pour sauvegarder la configuration d'une batterie

Vous pouvez utiliser l'Administration centrale pour sauvegarder la configuration de la batterie sur laquelle l'Administration centrale s'exécute. Pour sauvegarder la configuration d'une batterie distante, vous devez utiliser le site Web Administration centrale qui s'exécute sur la batterie distante. Vous ne pouvez pas utiliser l'Administration centrale pour sauvegarder une base de données de configuration non attachée.

Pour sauvegarder la configuration d'une batterie à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil Administration centrale, dans la section Sauvegarde et restauration, cliquez sur Effectuer une sauvegarde.

  3. Dans la page Effectuer une sauvegarde - Étape 1 de 2 : sélectionner un composant à sauvegarder, sélectionnez la batterie de serveurs dans la liste des composants, puis cliquez sur Suivant.

    Remarque :
    Vous pouvez sauvegarder la configuration de n'importe quel service ou application. Toutefois, une pratique courante consiste à sauvegarder la configuration au niveau de la batterie de serveurs.

  4. Dans la page Effectuer une sauvegarde - Étape 2 sur 2 : sélectionner les options de sauvegarde, dans la section Type de sauvegarde, sélectionnez Complète.

  5. Dans la section Sauvegarder uniquement les paramètres de configuration, sélectionnez l'option Sauvegarder uniquement les paramètres de configuration.

  6. Dans la section Emplacement des fichiers de sauvegarde, tapez le chemin d'accès UNC (Universal Naming Convention) du dossier de sauvegarde, puis cliquez sur Lancer la sauvegarde.

  7. Vous pouvez afficher l'état général de tous les travaux de sauvegarde en haut de la page État des opérations de sauvegarde et de restauration dans la section Disponibilité. Vous pouvez afficher l'état du travail de sauvegarde en cours dans la partie inférieure de la page dans la section Sauvegarde. La page de l'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez actualiser manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la sauvegarde peut prendre plusieurs secondes.

    Si vous voyez apparaître des erreurs, vous pouvez les examiner dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous pouvez également obtenir des détails supplémentaires dans le fichier Spbackup.log stocké sur le chemin d'accès UNC que vous avez spécifié à l'étape 5.

Voir aussi

Concepts

Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010)

Historique des modifications


Sauvegarder une application Web (SharePoint Foundation 2010)

Cet article explique comment sauvegarder une application Web. La sauvegarde régulière d'une application Web réduit les risques de pertes de données qui peuvent se produire suite à des défaillances matérielles, des coupures de courant ou d'autres problèmes. Il s'agit d'un processus simple qui peut vous aider à vous assurer que toutes les données liées à l'application Web et les configurations sont disponibles pour la récupération, si nécessaire. Nous vous recommandons de créer des sauvegardes d'applications Web en plus des sauvegardes ordinaires au niveau de la batterie de serveurs.

Cette rubrique explique comment sauvegarder une application Web spécifique.

Dans cette rubrique :

  • Considérations relatives à la sauvegarde des applications Web

  • Exigences relatives à la tâche

  • Utiliser Windows PowerShell pour sauvegarder une application Web

  • Utiliser l'Administration centrale pour sauvegarder une application Web

  • Utiliser les outils SQL Server pour sauvegarder une application Web

Considérations relatives à la sauvegarde des applications Web

Il convient de prendre en compte les points suivants lors de la préparation à la sauvegarde d'une application Web.

  • Vous ne pouvez sauvegarder qu'une seule application Web à la fois à l'aide des procédures décrites dans cet article. Toutefois, vous pouvez sauvegarder simultanément toutes les applications Web en sauvegardant toute la batterie de serveurs.

  • La sauvegarde d'une application Web n'a pas d'impact sur l'état de la batterie de serveurs. Toutefois, elle requiert des ressources et peut légèrement affecter les performances de la batterie de serveurs au cours du déroulement de l'opération. Vous pouvez éviter les problèmes de performances en sauvegardant l'application Web pendant les tranches horaires où la batterie de serveurs est peu utilisée, par exemple en dehors des heures ouvrables

  • Si l'application Web utilise le cache d'objets, vous devez configurer manuellement deux comptes d'utilisateurs spéciaux pour l'application Web après l'avoir restaurée. Pour plus d'informations sur le cache d'objets et sur la façon de configurer ces comptes d'utilisateurs, voir Configure object cache user accounts.

  • Lorsque vous sauvegardez une application Web, les paramètres IIS (Internet Information Services) et toutes les bases de données de contenu associées à l'application Web sont également sauvegardés.

  • Lorsque vous sauvegardez une application Web configurée de façon à utiliser l'authentification basée sur les formulaires, vous devez également utiliser un système de sauvegarde de fichiers afin de protéger les fichiers Web.config car ceux-ci doivent être mis à jour manuellement de façon à inscrire les fournisseurs d'appartenances et de rôles, et les modifications apportées manuellement aux fichiers Web.config ne sont pas sauvegardées. De plus, les fichiers Web.config ne sont pas restaurés lorsque vous restaurez une application Web. À l'issue de la récupération, vous devez mettre à jour les fichiers Web.config et redéployer les fournisseurs. Pour plus d'informations, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010) et Configurer l'authentification par revendications (SharePoint Foundation 2010).

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier réseau dans lequel stocker les sauvegardes. Le compte de service Minuteur V4 Windows SharePoint Services et le compte d'utilisateur de la batterie de serveurs doivent avoir des autorisations de type Contrôle total sur ce dossier. Pour plus d'informations sur la façon de créer un dossier de sauvegarde, voir Préparer la sauvegarde et la récupération (SharePoint Foundation 2010).

Utiliser Windows PowerShell pour sauvegarder une application Web

Vous pouvez utiliser Windows PowerShell pour sauvegarder une application Web manuellement ou en tant que partie d'un script qui peut être exécuté à intervalles planifiés.

Pour sauvegarder une application Web à l'aide de Windows PowerShell

  1. Vérifiez que vous répondez à la configuration minimale suivante : Voir Add-SPShellAdmin. En outre, le compte d'utilisateur effectuant cette procédure doit être membre du rôle fixe de base de données SQL Server db_backupoperator sur le serveur de base de données où chaque base de données est stockée.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Code de copie
    Backup-SPFarm -Directory <BackupFolder> -BackupMethod {Full | Differential} -Item <WebApplicationName> [-Verbose]

    Où :

    • <BackupFolder> est le chemin d'accès au dossier que vous utilisez pour stocker les fichiers de sauvegarde.

    • <WebApplicationName> est le nom de l'application Web.

    Remarque :
    Si vous sauvegardez l'application Web pour la première fois, vous devez utiliser l'option Full. Vous devez effectuer une sauvegarde complète avant d'effectuer une sauvegarde différentielle.

Pour plus d\rquote informations, voir Backup-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour sauvegarder une application Web

Vous pouvez utiliser l'Administration centrale pour sauvegarder une application Web.

Pour sauvegarder une application Web à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans l'Administration centrale, sur la page d'accueil, à la section Sauvegarde et restauration, cliquez sur Effectuer une sauvegarde.

  3. Dans la page Effectuer une sauvegarde - Étape 1 sur 2 : sélectionnez un composant à sauvegarder, sélectionnez l'application Web dans la liste des composants, puis cliquez sur Suivant.

    Remarque :
    L'application Web peut comprendre plusieurs composants. Dans ce cas, vous devez sélectionner le composant de niveau supérieur.

  4. Sur la page Démarrer la sauvegarde - Étape 2 sur 2 : sélectionnez des options de sauvegarde, à la section Type de sauvegarde, sélectionnez Complet ou Différentiel.

    Remarque :
    Si vous sauvegardez l'application Web pour la première fois, vous devez utiliser l'option Complète. Vous devez effectuer une sauvegarde complète avant de pouvoir effectuer une sauvegarde différentielle.

  5. Dans la section Sauvegarder uniquement les paramètres de configuration, cliquez sur Sauvegarder le contenu et les paramètres de configuration.

  6. À la section Emplacement des fichiers de sauvegarde, tapez le chemin d'accès UNC (Universal Naming Convention) du dossier de sauvegarde, puis cliquez sur Démarrer la sauvegarde.

  7. Vous pouvez afficher l'état général de tous les travaux de sauvegarde en haut de la page État des opérations de sauvegarde et de restauration, dans la section Disponibilité. Vous pouvez afficher l'état du travail de sauvegarde en cours dans la partie inférieure de la page, dans la section Sauvegarde. La page d'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la sauvegarde peut prendre plusieurs secondes.

    Si vous recevez des erreurs, vous pouvez les consulter dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous pouvez aussi trouver davantage de détails dans le fichier Spbackup.log qui se trouve dans le chemin d'accès UNC que vous avez spécifié à l'étape 6.

Utiliser les outils SQL Server pour sauvegarder une application Web

Vous ne pouvez pas sauvegarder l'application Web entière à l'aide des outils SQL Server. Toutefois, vous pouvez sauvegarder toutes les bases de données associées à l'application Web. Pour sauvegarder l'application Web entière, utilisez Windows PowerShell ou l'Administration centrale.

Pour sauvegarder une application Web à l'aide des outils SQL Server

  1. Vérifiez que le compte d'utilisateur qui est utilisé pour sauvegarder les bases de données est membre du rôle fixe de base de données SQL Server db_backupoperator sur le serveur de base de données où chaque base de données est stockée. En outre, vérifiez que le compte d'utilisateur dispose des autorisations de type Contrôle complet sur le dossier de sauvegarde.

  2. Ouvrez SQL Server Management Studio et connectez-vous au serveur de bases de données.

  3. Dans l'Explorateur d'objets, développez Bases de données.

  4. Cliquez avec le bouton droit sur la base de données à sauvegarder, pointez sur Tâches, puis cliquez sur Sauvegarder.

  5. Dans la boîte de dialogue Sauvegarder la base de données, dans la zone Source, sélectionnez le type de sauvegarde que vous souhaitez effectuer dans la liste Type de sauvegarde. Pour plus d'informations sur le type de sauvegarde à utiliser, voir Vue d'ensemble du mode de récupération (http://go.microsoft.com/fwlink/?linkid=114396&clcid=0x40C).

  6. Dans la zone Sauvegarder un composant, cliquez sur Base de données.

  7. Utilisez le nom par défaut fourni ou indiquez un nom pour le jeu de sauvegarde dans la zone de texte Nom.

  8. Spécifiez la date d'expiration du jeu de sauvegarde. Elle détermine pendant combien de temps ou quand le jeu de sauvegarde peut être remplacé par les sauvegardes suivantes effectuées sous le même nom. Par défaut, le jeu de sauvegarde est défini pour ne jamais expirer (0 jour).

  9. Dans la zone Destination, indiquez où vous voulez stocker la sauvegarde.

  10. Cliquez sur OK pour sauvegarder la base de données.

  11. Répétez les étapes 1 à 10 pour chaque base de données associée à l'application Web.

Contenu connexe

Centre de ressources | Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201997&clcid=0x40C)
Contenu IT Pro | Restaurer une application Web (SharePoint Foundation 2010) Sauvegarder une batterie de serveurs (SharePoint Foundation 2010). Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) Sauvegarde et récupération (SharePoint Foundation 2010)
Contenu de développement | Protection et récupération des données (http://go.microsoft.com/fwlink/?linkid=199237&clcid=0x40C)

Historique des modifications

Date | Description | Raison
16 septembre 2010 | 2010/09/13 | Mise à jour du contenu


Sauvegarder une application de service (SharePoint Foundation 2010)
Voir aussi

Il est recommandé d'effectuer une sauvegarde régulière au niveau de la batterie de serveurs. Toutefois, il est possible que des contraintes de gestion ou d'ordre informatique vous amènent à sauvegarder une application de service. La sauvegarde régulière d'une application de service réduit le risque de pertes de données susceptibles de se produire lors de défaillances matérielles, de pannes d'alimentation ou d'autres problèmes. Il s'agit d'un processus simple qui garantit la possibilité de récupérer toutes les données et configurations liées à l'application de service en cas de nécessité. Vous ne pouvez sauvegarder qu'une seule application de service à la fois. Pour plus d'informations sur ce qui doit être sauvegardé et sur les outils à utiliser, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010). Vous pouvez sauvegarder toutes les applications de services de la batterie de serveurs en sauvegardant la batterie de serveurs entière. Pour plus d'informations, voir Sauvegarder une batterie de serveurs (SharePoint Foundation 2010).

La sauvegarde d'une application de service n'a pas d'impact sur l'état de la batterie de serveurs. Toutefois, elle requiert des ressources et peut légèrement affecter les performances de la batterie de serveurs pendant son déroulement. Vous pouvez éviter ces problèmes de performances en sauvegardant l'application de service pendant les tranches horaires où la batterie de serveurs est faiblement utilisée.

Remarque :
La sauvegarde de SharePoint Foundation 2010 permet de sauvegarder les magasins d'objets BLOB distants mais uniquement si vous utilisez le fournisseur de magasins d'objets BLOB distants FILESTREAM pour placer les données dans des magasins d'objets BLOB distants.

Si vous utilisez un autre fournisseur, vous devez sauvegarder manuellement les magasins d'objets BLOB distants.

Procédures décrites dans cette rubrique :

  • Utiliser Windows PowerShell pour sauvegarder une application de service

  • Utiliser l'Administration centrale pour sauvegarder une application de service

Remarque :
Vous ne pouvez pas utiliser les outils SQL Server ni Data Protection Manager pour sauvegarder une application de service.

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier sur l'ordinateur local ou sur le réseau dans lequel stocker les sauvegardes. Pour améliorer les performances, nous vous recommandons de sauvegarder vers l'ordinateur local puis de déplacer les fichiers de sauvegarde vers un dossier du réseau.

Remarque :
La sauvegarde de Microsoft SharePoint Foundation 2010 permet de sauvegarder les définitions des types de contenu externes du service Business Data Connectivity mais pas de sauvegarder la source de données proprement dite. Pour protéger les données, vous devez sauvegarder la source de données lors de la sauvegarde du service Business Data Connectivity ou de la batterie de serveurs.

Si vous sauvegardez le service Business Data Connectivity ou la batterie de serveurs, et si vous restaurez ensuite la source de données à un autre emplacement, vous devez changer les informations d'emplacement dans la définition du type de contenu externe. Dans le cas contraire, le service Business Data Connectivity risque de ne pas pouvoir localiser la source de données.

Utiliser Windows PowerShell pour sauvegarder une application de service

Vous pouvez utiliser Windows PowerShell pour sauvegarder une ou plusieurs applications de service manuellement ou dans le cadre d'un script exécutable à intervalles planifiés.

Pour sauvegarder une application de service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez la commande suivante et appuyez sur la touche Entrée :

    Backup-SPFarm -Directory <Backup folder> -BackupMethod {Full | Differential} -Item <Service application name> [-Verbose]

    Remarque :
    Si vous sauvegardez l'application de service pour la première fois, vous devez utiliser l'option Full. Vous devez effectuer une sauvegarde complète avant de pouvoir effectuer une sauvegarde différentielle.

    Certaines applications de service nécessitent systématiquement une sauvegarde complète. Pour ces applications-là, même si vous sélectionnez l'option Differential, le système effectue une sauvegarde complète.

Pour plus d'informations, voir Backup-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour sauvegarder une application de service

Vous pouvez utiliser l'Administration centrale pour sauvegarder une application de service.

Pour sauvegarder une application de service à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans l'Administration centrale, sur la page d'accueil, à la section Sauvegarde et restauration, cliquez sur Effectuer une sauvegarde.

  3. Dans la page Effectuer une sauvegarde - Étape 1 de 2 : sélectionner un composant à sauvegarder, sélectionnez l'application de service dans la liste des composants, puis cliquez sur Suivant.

    Remarque :
    L'application de service peut comprendre plusieurs composants. Dans ce cas, vous devez sélectionner le composant de niveau supérieur.

  4. Sur la page Démarrer la sauvegarde - Étape 2 sur 2 : sélectionner des options de sauvegarde, à la section Type de sauvegarde, sélectionnez Complète ou Différentielle.

    Remarque :
    Si vous sauvegardez le service pour la première fois, vous devez utiliser l'option Complète. Vous devez effectuer une sauvegarde complète avant de pouvoir effectuer une sauvegarde différentielle.

    Certaines applications de service nécessitent systématiquement une sauvegarde complète. Pour ces applications-là, même si vous sélectionnez l'option Différentielle, le système effectue une sauvegarde complète.

  5. Dans la section Emplacement des fichiers de sauvegarde, dans la zone Emplacement de sauvegarde, tapez le chemin d'accès du dossier de sauvegarde, puis cliquez sur Lancer la sauvegarde.

  6. Vous pouvez afficher l'état général de tous les travaux de sauvegarde en haut de la page État des opérations de sauvegarde et de restauration, dans la section Disponibilité. Vous pouvez afficher l'état du travail de sauvegarde en cours dans la partie inférieure de la page, dans la section Sauvegarde. La page d'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la sauvegarde peut prendre plusieurs secondes.

    Si vous recevez des erreurs, vous pouvez les consulter dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous pouvez aussi trouver davantage de détails dans le fichier Spbackup.log qui se trouve dans le chemin d'accès UNC que vous avez spécifié à l'étape 6.

Voir aussi

Concepts

Restaurer une application de service (SharePoint Foundation 2010)

Historique des modifications


Sauvegarder une collection de sites (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment sauvegarder une collection de sites. Il est recommandé de sauvegarder régulièrement la batterie de serveurs entière. Cependant, les pratiques informatiques peuvent nécessiter de sauvegarder également une collection de sites. Pour plus d'informations sur les éléments à sauvegarder, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

Remarque :
Si l'État de verrouillage de la collection de sites est défini sur Non verrouillé ou Ajout de contenu interdit, Microsoft SharePoint Foundation 2010 définit temporairement le site en Lecture seule pendant l'opération de sauvegarde. SharePoint Foundation 2010 procède ainsi pour réduire les possibilités que des utilisateurs modifient la collection de sites pendant sa sauvegarde. Une fois la sauvegarde terminée, le paramètre est rétabli dans son état normal.

L'opération de sauvegarde d'une collection de sites peut nécessiter des ressources et affecter légèrement les performances de la batterie de serveurs pendant son exécution. Vous pouvez éviter les problèmes de performances en sauvegardant la batterie de serveurs pendant les tranches horaires où elle est peu utilisée, par exemple en dehors des heures d'ouverture des bureaux.

Procédures de cette tâche :

  • Utiliser Windows PowerShell pour sauvegarder une collection de sites

  • Utiliser l'Administration centrale pour sauvegarder une collection de sites

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier sur l'ordinateur local ou sur le réseau où stocker les sauvegardes. Pour de meilleures performances, il est recommandé d'effectuer les sauvegardes sur l'ordinateur local puis de déplacer les fichiers de sauvegarde vers un dossier réseau. Pour plus d'informations sur la façon de créer un dossier de sauvegarde, voir Préparer la sauvegarde et la récupération (SharePoint Foundation 2010).

Utiliser Windows PowerShell pour sauvegarder une collection de sites

Vous pouvez utiliser Windows PowerShell pour sauvegarder une collection de sites manuellement ou dans le cadre d'un script exécutable à intervalles planifiés.

Pour sauvegarder une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Backup-SPSite -Identity <Site collection name> -Path <backup file> [-Force] [-NoSiteLock] [-UseSqlSnapshot] [-Verbose]

    Si vous souhaitez remplacer un fichier de sauvegarde utilisé précédemment, utilisez le paramètre Force. Vous pouvez utiliser le paramètre NoSiteLock pour éviter l'application du verrou en lecture seule à la collection de sites pendant qu'elle est sauvegardée. Toutefois, l'utilisation de ce paramètre peut permettre aux utilisateurs de modifier la collection de sites pendant sa sauvegarde et peut entraîner un endommagement possible des données pendant la sauvegarde.

    Si le serveur de bases de données exécute une édition Enterprise de Microsoft SQL Server, nous vous recommandons d'utiliser également le paramètre UseSqlSnapshot pour des sauvegardes plus cohérentes.

    Important :
    Lorsque vous effectuez une sauvegarde qui utilise le paramètre UseSqlSnapshot, la sauvegarde réussit mais une erreur semblable à la suivante s'affiche :

    Backup-SPSite : L'opération n'est pas valide en raison de l'état actuel de l'objet.

    à la ligne :1 caractère :14+ Backup-SPSite <<<< http://site -Path + CategoryInfo : NotSpecified: (:) [Backup-SPSite], InvalidOperationException + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.SharePoint.PowerShell.SPCmdletBackupSite\\votre_chemin_accès

    Remarque :
    Si le fournisseur RBS que vous utilisez ne prend pas en charge les captures instantanées, vous ne pouvez pas utiliser de captures instantanées pour le déploiement ou la sauvegarde de contenu. Par exemple, le fournisseur SQL FILESTREAM ne prend pas en charge les captures instantanées.

    Pour plus d'informations sur l'utilisation de captures instantanées SQL, voir Sauvegarder des bases de données par capture instantanée (SharePoint Foundation 2010).

Pour plus d'informations, voir Backup-SPSite.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour sauvegarder une collection de sites

Vous pouvez utiliser l'Administration centrale pour sauvegarder une collection de sites.

Pour sauvegarder une collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie. En outre, vérifiez que le service Windows SharePoint Services Timer V4 dispose des autorisations Contrôle total sur le dossier de sauvegarde.

  2. Sur la page d'accueil de l'Administration centrale, dans la section Sauvegarde et restauration, cliquez sur Effectuer une sauvegarde d'une collection de sites.

  3. Dans la page Sauvegarde de la collection de sites, sélectionnez la collection de sites dans la liste Collection de sites.

  4. Tapez le chemin d'accès local au fichier de sauvegarde dans la zone Nom de fichier.

    Remarque :
    Si vous souhaitez réutiliser un fichier, activez la case à cocher Remplacer le fichier existant.

  5. Cliquez sur Lancer la sauvegarde.

  6. Vous pouvez consulter l'état général de l'ensemble des travaux de sauvegarde en haut de la page État précis du travail de sauvegarde, dans la section Disponibilité. Vous pouvez consulter l'état du travail de sauvegarde en cours dans la partie inférieure de la page, dans la section Sauvegarde. La page d'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez actualiser manuellement les détails d'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service Minuteur. Par conséquent, le démarrage de la sauvegarde peut prendre plusieurs secondes.

    Si des messages d'erreur sont générés, vous pouvez les consulter dans la colonne Message d'échec de la page État précis du travail de sauvegarde.

Voir aussi

Concepts

Restaurer une collection de sites (SharePoint Foundation 2010)

Historique des modifications


Sauvegarder les personnalisations (SharePoint Foundation 2010)

Cet article explique comment sauvegarder des personnalisations qui ont été apportées à des sites Microsoft SharePoint Foundation 2010.

Les types de personnalisations suivants peuvent être appliqués à des sites :

  • Personnalisations empaquetées en tant que solutions (fichiers .wsp). Les solutions contiennent des éléments de sites développés et sont généralement créées par des développeurs. Parmi les éléments de sites développés, citons :

    • les composants WebPart ;

    • les flux de travail ;

    • les définitions de site et de liste ;

    • les convertisseurs de documents ;

    • les récepteurs d'événements ;

    • les travaux du minuteur ,

    • les assemblys.

  • Les éléments de sites créés, qui sont généralement créés par des concepteurs Web, ne sont pas compilés de manière explicite et résident dans une base de données de contenu. Parmi ces éléments, citons :

    • les pages maîtres ;

    • les feuilles de style en cascade ,

    • les formulaires ;

    • les pages de disposition.

  • Modifications apportées au fichier Web.config

  • Les solutions tierces et leurs fichiers binaires et clés de Registre associés, par exemple les IFilters.

  • Modifications de sites apportées directement par le biais d'un navigateur

  • Personnalisations développées qui ne sont pas empaquetées en tant que solutions

Chacun de ces types de personnalisations requiert un type de sauvegarde différent.

Dans cet article :

  • Sauvegarde de packages de solutions

  • Sauvegarde d'éléments de sites créés

  • Sauvegarde de flux de travail

  • Sauvegarde des modifications apportées au fichier Web.config

  • Sauvegarde de produits tiers

  • Sauvegarde de modifications apportées directement

  • Sauvegarde de personnalisations développées qui ne sont pas empaquetées en tant que solutions

Sauvegarde de packages de solutions

Les packages de solutions peuvent être créés à l'aide de Microsoft SharePoint Designer 2010 ou Microsoft Visual Studio 2010. Il est vivement recommandé de déployer toutes les personnalisations en tant que packages de solutions.

Un package de solution est un fichier déployable et réutilisable qui peut contenir un ensemble de fonctionnalités, de définitions de sites et d'assemblys qui s'appliquent à des sites et que vous pouvez activer ou désactiver individuellement. Les packages de solutions peuvent inclure des composants WebPart, des définitions de sites ou de listes, des colonnes personnalisées, de nouveaux types de contenu, des champs personnalisés, des actions personnalisées, des flux de travail codés, ou des activités et conditions de flux de travail.

La méthode qui vous permet de sauvegarder des packages de solutions varie selon que les personnalisations sont déployées en tant que solutions approuvées ou solutions bac à sable (sandbox).

Les solutions approuvées sont des packages de solutions déployés par des administrateurs de batterie. Elles sont déployées dans la batterie entière et peuvent être utilisées sur n'importe quel site de la batterie. Elles sont stockées dans la base de données de configuration. Elles sont sauvegardées lorsqu'une batterie est sauvegardée à l'aide de la sauvegarde SharePoint Foundation 2010 et sont comprises dans les sauvegardes de type configuration-uniquement. Vous pouvez également sauvegarder des solutions approuvées individuellement ou en tant que groupe. Les solutions sont visibles dans la hiérarchie de sauvegarde.

Les solutions bac à sable (sandbox) sont des packages de solutions que les administrateurs de collections de sites peuvent déployer sur une collection de sites unique. Elles sont stockées dans la base de données de contenu associée à la collection de sites dans laquelle les packages de solutions sont déployés. Elles sont incluses dans les sauvegardes de batterie SharePoint Foundation 2010, d'application Web, de base de données de contenu et de collection de site, mais elles ne sont pas visibles dans la hiérarchie de sauvegarde et ne peuvent pas être sélectionnées ou sauvegardées individuellement.

Nous vous recommandons de conserver une sauvegarde du fichier .wsp d'origine et du code source servant à générer le fichier .wsp pour les solutions approuvées et les solutions bac à sable (sandbox).

Pour sauvegarder des solutions approuvées à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans l'Administration centrale, dans la page d'accueil, dans la section Sauvegarde et restauration, cliquez sur Effectuer une sauvegarde.

  3. Dans la page Effectuer une sauvegarde - Étape 1 de 2 : sélectionner un composant à sauvegarder, sélectionnez Solutions, puis cliquez sur Suivant.

    Vous pouvez également sélectionner une solution spécifique, si vous ne souhaitez en sauvegarder qu'une seule.

  4. Dans la page Démarrer la sauvegarde - Étape 2 sur 2 : sélectionner des options de sauvegarde, dans la section Type de sauvegarde, sélectionnez Complète ou Différentielle.

    Remarque :
    Si vous sauvegardez la solution pour la première fois, vous devez utiliser l'option Complète. Vous devez effectuer une sauvegarde complète pour pouvoir effectuer une sauvegarde différentielle.

  5. Dans la section Emplacement des fichiers de sauvegarde , tapez le chemin d'accès UNC (Universal Naming Convention) du dossier de sauvegarde, puis cliquez sur Démarrer la sauvegarde.

  6. Vous pouvez afficher l'état général de toutes les tâches de sauvegarde dans la partie supérieure de la page État des opérations de sauvegarde et de restauration, dans la section Préparation. Vous pouvez afficher l'état de la tâche de sauvegarde actuelle dans la partie inférieure de la page, dans la section Sauvegarde. La page d'état se met à jour automatiquement toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des tâches de service du minuteur. Par conséquent, il se peut que la sauvegarde démarre après plusieurs secondes.

    Si des messages d'erreur s'affichent, examinez la colonne Message d'erreur de la page d'état des tâches de restauration et de sauvegarde. Vous trouverez également des détails supplémentaires dans le fichier Spbackup.log situé à l'emplacement indiqué à l'étape 4.

Pour sauvegarder des solutions approuvées à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour sauvegarder toutes les solutions de la batterie. Pour sauvegarder une seule solution, ajoutez son nom au chemin d'accès de l'élément « farm\solutions ».

    Code de copie
    Backup-SPFarm -backupmethod full -directory <UNC location> -item "farm\solutions"

    Où :

    • <UNC location> est l'emplacement UNC du répertoire vers lequel effectuer la sauvegarde.

Pour plus d'informations, voir Backup-SPFarm.

Sauvegarde de solutions bac à sable (sandbox)

Il est impossible de sauvegarder uniquement les solutions bac à sable (sandbox). Au lieu de cela, vous devez sauvegarder la batterie, l'application Web ou la base de données de contenu à laquelle est associée la solution bac à sable (sandbox). Pour plus d'informations sur ces méthodes de sauvegarde, voir Contenu associé.

Sauvegarde d'éléments de sites créés

Il est impossible de sauvegarder uniquement les éléments de sites créés. Au lieu de cela, vous devez sauvegarder la batterie, l'application Web ou la base de données de contenu à laquelle est associé l'élément de sites créé. Pour plus d'informations sur ces méthodes de sauvegarde, voir Contenu associé.

Sauvegarde de flux de travail

Les flux de travail constituent un cas particulier de personnalisation que vous pouvez sauvegarder. Assurez-vous que votre plan de sauvegarde et de récupération gère les scénarios suivants qui s'appliquent à votre environnement :

  • Les flux de travail déclaratifs, tels que ceux créés dans Microsoft SharePoint Designer 2010, sont stockés dans la base de données de contenu de la collection de sites sur laquelle ils sont déployés. La sauvegarde de la base de données de contenu protège ces flux de travail.

  • Les actions de flux de travail déclaratifs personnalisés ont des composants aux trois emplacements suivants :

    1. Les assemblys Visual Studio 2010 pour les actions sont stockés dans le Global Assembly Cache.

    2. Les fichiers de définition XML (fichiers .ACTIONS) sont stockés dans le répertoire 14\TEMPLATE\<LCID>\Workflow.

    3. Une entrée XML marquant l'action comme type autorisé est stockée dans le fichier web.config des applications Web dans lesquelles elle est utilisée.

    Si les flux de travail de batterie utilisent des actions personnalisées, vous devez recourir à un système de sauvegarde de fichiers pour protéger ces fichiers et les entrées XML. S'apparentant à des fonctionnalités SharePoint Foundation telles que les composants WebPart et les récepteurs d'événements, ces fichiers doivent être réappliqués à la batterie selon les besoins après la récupération.

  • Les flux de travail qui dépendent de code personnalisé, tels que ceux créés à l'aide de Visual Studio 2010, sont stockés à deux emplacements. Les assemblys Visual Studio 2010 pour le flux de travail sont stockés dans le Global Assembly Cache et les fichiers de définition XML sont stockés dans le répertoire Features. Ceci est identique à d'autres types de fonctionnalités SharePoint Foundation telles que les composants WebPart et les récepteurs d'événements. Si le flux de travail a été installé dans le cadre d'un package de solution, la sauvegarde de la batterie, de l'application Web, de la base de données de contenu ou de la collection de sites protège ce flux de travail.

  • Si vous créez un flux de travail personnalisé qui interagit avec une collection de sites autre que celle dans laquelle le flux de travail est déployé, vous devez sauvegarder les deux collections de sites afin de protéger le flux de travail. Cela comprend les flux de travail qui écrivent dans un historique ou autre liste personnalisée dans une autre collection de sites. Une sauvegarde de batterie suffit à sauvegarder toutes les collections de site de la batterie et tous les flux de travail qui y sont associés.

  • Les flux de travail qui ne sont pas encore déployés doivent être sauvegardés et restaurés séparément. Lorsque vous développez un nouveau flux de travail et que vous ne l'avez pas encore déployé dans la batterie SharePoint Foundation, assurez-vous de sauvegarder le dossier dans lequel vous stockez les fichiers de projet de flux de travail à l'aide d'une application de sauvegarde de système de fichiers.

Sauvegarde des modifications apportées au fichier Web.config

L'une des personnalisations courantes de SharePoint Foundation 2010 consiste à modifier le fichier Web.config. Il est vivement recommandé de modifier ce fichier à l'aide de l'Administration centrale ou des API et du modèle objet SharePoint Foundation 2010. Ces modifications étant stockées dans la base de données de configuration, elles peuvent être récupérées à partir d'une sauvegarde de batterie ou de type configuration-uniquement.

Les modifications du fichier Web.config qui ne sont pas effectuées par le biais de l'Administration centrale ou des API et du modèle objet SharePoint Foundation 2010 doivent être protégées à l'aide d'une sauvegarde de système de fichiers.

Remarque :
Si vous utilisez l'authentification à base de formulaires, l'inscription du fournisseur dans le fichier Web.config est manuel et n'est pas protégé par la sauvegarde SharePoint Foundation 2010. Dans ce cas, assurez-vous de sauvegarder le fichier Web.config à l'aide d'une sauvegarde de système de fichiers.

Sauvegarde de produits tiers

Si des produits tiers sont déployés en tant que packages de solutions, ils sont protégés par la sauvegarde SharePoint Foundation 2010. Nous vous recommandons de conserver tous les fichiers d'origine, supports de distribution, documentation et clés de produits et de licence nécessaires à l'installation.

Sauvegarde de modifications apportées directement

Les modifications apportées directement à un site par le biais du navigateur peuvent être difficiles à sauvegarder. Le tableau suivant décrit les stratégies de sauvegarde pour des objets spécifiques.

Objet modifié | Stratégie de sauvegarde
Liste | Utilisez SharePoint Designer 2010 et enregistrez en tant que modèle. Pour plus d'informations, voir Enregistrer un site SharePoint en tant que modèle (http://go.microsoft.com/fwlink/?linkid=199515&clcid=0x40C).
Site | Utilisez SharePoint Designer 2010 et enregistrez en tant que modèle. Pour plus d'informations, voir Enregistrer un site SharePoint en tant que modèle (http://go.microsoft.com/fwlink/?linkid=199515&clcid=0x40C).
Collection de sites | Utilisez la sauvegarde de collection de sites. Pour plus d'informations, voir Sauvegarder une collection de sites (SharePoint Foundation 2010).

Sauvegarde de personnalisations développées qui ne sont pas empaquetées en tant que solutions

La sauvegarde de personnalisations qui ne sont pas déployées en tant que packages de solutions peut être un processus complexe car les emplacements des fichiers de personnalisation ne sont pas normalisés et SharePoint Foundation 2010 ne les sauvegarde pas automatiquement.

Contactez l'équipe de développement ou le fournisseur de personnalisation afin de déterminer si les personnalisations impliquent des logiciels complémentaires ou des fichiers à d'autres emplacements. Nous vous recommandons de sauvegarder ces répertoires avec une solution de sauvegarde de système de fichiers. Le tableau suivant répertorie les emplacements où les personnalisations développées sont généralement stockées sur des serveurs Web.

Emplacement | Description
%COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14 | Fichiers fréquemment mis à jour, assemblys personnalisés, modèles personnalisés, définitions de site personnalisé
Inetpub | Emplacement des répertoires virtuels IIS
%WINDIR%\Assembly | Global Assembly Cache (GAC) : emplacement protégé du système d'exploitation où les assemblys de code .NET Framework sont installés pour fournir l'accès système complet.

Contenu associé

Centre de ressources | Gestion de la continuité des activités professionnelles pour SharePoint Server 2010 : sauvegarde, récupération, disponibilité et récupération d'urgence (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=199235&clcid=0x40C)
Contenu IT Pro | Déployer des personnalisations - Vue d'ensemble (SharePoint Foundation 2010) Restaurer les personnalisations (SharePoint Foundation 2010) Sauvegarder une batterie de serveurs (SharePoint Foundation 2010) Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010) Sauvegarder une application Web (SharePoint Foundation 2010) Sauvegarder une base de données de contenu (SharePoint Foundation 2010) Sauvegarder une collection de sites (SharePoint Foundation 2010)
Contenu pour développeurs | Utilisation de solutions (MSDN) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=156638&clcid=0x40C) Solutions bac à sable (MSDN) (http://go.microsoft.com/fwlink/?linkid=199517&clcid=0x40C)

Historique des modifications

Date | Description | Raison
12 août 2010 | 2010/08/09 | Mise à jour du contenu


Sauvegarder une base de données de contenu (SharePoint Foundation 2010)
Voir aussi

Les bases de données de contenu Microsoft SharePoint Foundation 2010 peuvent atteindre des tailles très volumineuses. Par conséquent, il est conseillé de les sauvegarder séparément des sauvegardes de la batterie de serveurs. La sauvegarde régulière des bases de données de contenu réduit les pertes de données qui peuvent se produire lors de défaillances matérielles, coupures de courant ou autres problèmes. Il s'agit d'un processus simple grâce auquel toutes les données sont disponibles pour la récupération, si nécessaire. Vous ne pouvez sauvegarder qu'une seule base de données de contenu à la fois.

Cette rubrique explique comment sauvegarder une base de données de contenu unique.

Procédures de cette tâche :

  • Sauvegarder une base de données de contenu à l'aide de Windows PowerShell

  • Utiliser l'Administration centrale pour sauvegarder une base de données de contenu

  • Sauvegarder une base de données de contenu à l'aide des outils SQL Server

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier sur l'ordinateur local ou sur le réseau où stocker les sauvegardes. Pour de meilleures performances, il est recommandé d'effectuer les sauvegardes vers l'ordinateur local puis de déplacer les fichiers de sauvegarde vers un dossier réseau.

Sauvegarder une base de données de contenu à l'aide de Windows PowerShell

Vous pouvez utiliser Windows PowerShell pour sauvegarder une base de données de contenu manuellement ou dans le cadre d'un script exécutable à intervalles planifiés.

Pour sauvegarder une base de données de contenu à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Microsoft SharePoint 2010 Products.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Backup-SPFarm -Directory <Backup folder> -BackupMethod {Full | Differential} -Item <Content database name> [-Verbose]

    Remarque :
    Si vous sauvegardez la base de données de contenu pour la première fois, vous devez utiliser l'option Full. Vous devez effectuer une sauvegarde complète avant d'effectuer une sauvegarde différentielle.

Pour plus d'informations, voir Backup-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour sauvegarder une base de données de contenu

Vous pouvez utiliser l'Administration centrale pour sauvegarder une base de données de contenu.

Pour sauvegarder une base de données de contenu à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans l'Administration centrale, sur la page d'accueil, à la section Sauvegarde et restauration, cliquez sur Effectuer une sauvegarde.

  3. À la page Effectuer une sauvegarde - Étape 1 sur 2 : sélectionner le composant à sauvegarder, sélectionnez la base de données de contenu que vous voulez sauvegarder à partir de la liste de composants, puis cliquez sur Suivant.

    Remarque :
    Certaines bases de données de contenu ne peuvent pas être sélectionnées dans la liste. En cas de base de données non sélectionnable, utilisez Windows PowerShell pour sauvegarder la base de données de contenu.

  4. Sur la page Démarrer la sauvegarde - Étape 2 sur 2 : sélectionner des options de sauvegarde, à la section Type de sauvegarde, sélectionnez Complet ou Différentiel.

    Remarque :
    Si vous sauvegardez la base de données de contenu pour la première fois, vous devez utiliser l'option Complet. Vous devez effectuer une sauvegarde complète avant d'effectuer une sauvegarde différentielle.

  5. À la section Emplacement des fichiers de sauvegarde , tapez le chemin d'accès UNC (Universal Naming Convention) du dossier de sauvegarde, puis cliquez sur Démarrer la sauvegarde.

  6. Vous pouvez afficher l'état général de toutes les tâches de sauvegarde dans la partie supérieure de la page État des opérations de sauvegarde et de restauration, à la section Préparation. Vous pouvez afficher l'état de la tâche de sauvegarde actuelle dans la partie inférieure de la page, à la section Sauvegarde. La page d'état se met à jour automatiquement toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des tâches de service du minuteur. Par conséquent, il se peut que la sauvegarde tarde quelque peu à démarrer.

    Si des messages d'erreur s'affichent, traitez-les dans la colonne Message d'erreur de la page d'état des tâches de restauration et de sauvegarde. Vous trouverez également des détails supplémentaires dans le fichier Spbackup.log situé à l'emplacement indiqué à l'étape 4.

Sauvegarder une base de données de contenu à l'aide des outils SQL Server

Vous pouvez sauvegarder une base de données de contenu à l'aide des outils SQL Server.

Pour sauvegarder une base de données de contenu à l'aide des outils SQL Server

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du rôle de base de données fixe de SQL Server db_backupoperator sur le serveur de bases de données où chaque base de données est stockée.

  2. Ouvrez SQL Server Management Studio et connectez-vous au serveur de bases de données.

  3. Dans l'Explorateur d'objets, développez Bases de données.

  4. Cliquez avec le bouton droit sur la base de données à sauvegarder, pointez sur Tâches, puis cliquez sur Sauvegarder.

  5. Dans la boîte de dialogue Sauvegarder la base de données, dans la zone Source, sélectionnez le type de sauvegarde que vous souhaitez effectuer dans la liste Type de sauvegarde. Pour plus d'informations sur le type de sauvegarde à utiliser, voir Vue d'ensemble du mode de récupération (http://go.microsoft.com/fwlink/?linkid=114396&clcid=0x40C) dans la documentation en ligne de SQL Server.

  6. Dans la zone Composant de sauvegarde, cliquez sur Base de données.

  7. Utilisez le nom fourni par défaut ou spécifiez un nom pour le jeu de sauvegarde dans la zone de texte Nom.

  8. Spécifiez la date d'expiration du jeu de sauvegarde. Cette date détermine pendant combien de temps, ou quand, le jeu de sauvegarde peut être remplacé par les sauvegardes suivantes effectuées sous le même nom. Par défaut, le jeu de sauvegarde est défini pour ne jamais expirer (0 jour).

  9. Dans la zone Destination, indiquez où vous souhaitez stocker la sauvegarde.

  10. Cliquez sur OK pour sauvegarder la base de données.

  11. Répétez les étapes 1 à 9 pour chaque base de données de contenu à sauvegarder.

Voir aussi

Concepts

Restaurer une base de données de contenu (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Sauvegarder des bases de données par capture instantanée (SharePoint Foundation 2010)
Voir aussi

Cette rubrique décrit comment sauvegarder une base de données de batterie de serveurs dans une capture instantanée.

Vous ne pouvez utiliser que des outils SQL Server pour sauvegarder une base de données de batterie de serveurs dans une capture instantanée.

Important :
Vous devez exécuter SQL Server 2008 avec SP1 et mise à jour cumulative 2 Édition entreprise pour capturer des instantanés de base de données.

Il est recommandé de sauvegarder régulièrement la batterie de serveurs entière. Des sauvegardes régulières de la batterie réduisent les pertes de données qui peuvent se produire en cas de défaillance matérielle, de coupures de courant ou d'autres problèmes. Il s'agit d'un processus simple qui garantit la possibilité de récupérer toutes les données et configurations de la batterie de serveurs en cas de nécessité. Pour plus d'informations, voir Sauvegarder une batterie de serveurs (SharePoint Foundation 2010). Toutefois, il est possible que des contraintes d'ordre informatique vous amènent à sauvegarder les bases de données dans des captures instantanées. Bien que vous puissiez sauvegarder n'importe quelle base de données de la batterie de serveurs dans un instantané, généralement vous sauvegardez les bases de données de contenu.

Une capture instantanée de base de données fournit une vue statique en lecture seule d'une base de données source telle qu'elle existait lors de la création de la capture instantanée, sans les transactions non validées.Les transactions non validées sont annulées dans la capture instantanée nouvellement créée d'une base de données, car le moteur de base de données exécute une récupération après la création de la capture instantanée (les transactions dans la base de données ne sont pas affectées). Pour plus d'informations sur les instantanés de base de données, voir Captures instantanées de base de données (http://go.microsoft.com/fwlink/?linkid=163950&clcid=0x40C).

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier sur le serveur de bases de données. Si vous souhaitez stocker les captures instantanées à un autre emplacement, vous pouvez déplacer les fichiers de sauvegarde dans un dossier de sauvegarde sur le réseau une fois l'opération terminée.

Utiliser les outils SQL Server pour sauvegarder une base de données dans une capture instantanée

Pour sauvegarder des bases de données dans des captures instantanées, vous devez utiliser les outils SQL Server. Les bases de données qui sont associées à la batterie de serveurs sont déterminées par les composants que vous avez installés sur la batterie de serveurs.

Pour sauvegarder une base de données dans une capture instantanée à l'aide des outils SQL Server

  1. Vérifiez que le compte utilisé pour sauvegarder les bases de données est membre du rôle fixe de base de données SQL Server db_owner.

  2. Ouvrez SQL Server Management Studio et connectez-vous au serveur de bases de données.

  3. Dans l'Explorateur d'objets, développez Bases de données.

  4. Sélectionnez la base de données que vous souhaitez sauvegarder, puis cliquez sur Nouvelle requête.

  5. Copiez le texte suivant et collez-le dans le volet de requête.

    Code de copie
    CREATE DATABASE <snapshot name>
ON
(
NAME=<logical name of the database file>,
FILENAME = 'c:\WSS_Backup1.ss')
AS SNAPSHOT OF <database name>;

Voir aussi

Autres ressources

Captures instantanées de base de données

Historique des modifications


Exporter un site, une liste ou une bibliothèque de documents (SharePoint Foundation 2010)
Voir aussi

Il est recommandé de sauvegarder régulièrement la batterie de serveurs entière. Toutefois, il est possible que des impératifs de gestion ou d'ordre informatique vous amènent à exporter un site, une liste ou une bibliothèque de documents. L'exportation régulière des sites, des listes et des bibliothèques de documents réduit les pertes de données susceptibles de se produire lors de défaillances matérielles, de pannes d'alimentation ou d'autres problèmes. Il s'agit d'un processus simple qui permet de récupérer des données en cas de nécessité. Vous ne pouvez exporter qu'un site, une liste ou une bibliothèque de documents à la fois.

Pour plus d'informations sur ce qui doit être sauvegardé et sur les outils à utiliser, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

Procédures de cette tâche :

  • Utiliser Windows PowerShell pour exporter un site, une liste ou une bibliothèque de documents

  • Utiliser l'Administration centrale pour exporter un site, une liste ou une bibliothèque de documents

Remarque :
Vous ne pouvez pas utiliser les outils SQL Server ou Data Protection Manager pour exporter un site, une liste ou une bibliothèque de documents.

Exigences relatives à la tâche

Avant de commencer, vous devez créer un dossier sur l'ordinateur local ou sur le réseau dans lequel stocker le fichier d'exportation. Pour améliorer les performances, nous vous recommandons d'exporter vers l'ordinateur local puis de déplacer le fichier d'exportation vers un dossier du réseau.

Utiliser Windows PowerShell pour exporter un site, une liste ou une bibliothèque de documents

Vous pouvez utiliser Windows PowerShell pour exporter un site, une liste ou une bibliothèque de documents manuellement ou dans le cadre d'un script exécutable à intervalles planifiés.

Pour exporter un site, une liste ou une bibliothèque de documents à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Microsoft SharePoint 2010 Products.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Export-SPWeb -Identity <Site URL> -Path <Path and file name> [-ItemUrl <URL of site, list, or library>] [-IncludeUserSecurity] [-IncludeVersions] [-NoFileCompression] [-GradualDelete] [-Verbose]

    Si vous exportez un site, une liste ou une bibliothèque de documents de grande taille, vous pouvez utiliser le paramètre GradualDelete. Lorsque ce paramètre est utilisé, la collection de sites est marquée comme supprimée, ce qui empêche immédiatement tout accès ultérieur à son contenu. Les données de la collection de sites supprimée sont ensuite supprimées progressivement par un travail du minuteur au lieu de l'être immédiatement, ce qui réduit l'impact sur les performances des serveurs de la batterie et de SQL Server.

    Pour indiquer la version du site, de la liste ou de la bibliothèque de documents à inclure, utilisez le paramètre IncludeVersions et spécifiez « LastMajor » (valeur par défaut), « CurrentVersion », « LastMajorandMinor » ou « All ». Pour inclure les paramètres de sécurité utilisateur avec la liste ou la bibliothèque de documents, utilisez le paramètre IncludeUserSecurity. Si vous souhaitez remplacer le fichier que vous avez spécifié, utilisez le paramètre Force. Pour afficher la progression de l'opération de sauvegarde, utilisez le paramètre Verbose.

    Le paramètre NoFileCompression permet de spécifier une exportation sans compression de fichier, ce qui peut réduire l'utilisation des ressources jusqu'à 30 % durant l'exportation. L'usage de ce paramètre entraîne la création d'un dossier de sauvegarde au lieu d'un fichier compressé. Si vous utilisez le paramètre NoFileCompression dans la commande Export-SPWeb, vous devez aussi l'utiliser lorsque vous importez le contenu à l'aide de la commande Import-SPWeb.

Pour plus d'informations, voir Export-SPWeb.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour exporter un site, une liste ou une bibliothèque de documents

Vous pouvez utiliser l'Administration centrale pour exporter un site, une liste ou une bibliothèque de documents. Vous ne pouvez exporter qu'un site, une liste ou une bibliothèque de documents à la fois.

Pour exporter un site, une liste ou une bibliothèque de documents à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans l'Administration centrale, dans la page Accueil, cliquez sur Sauvegarde et restauration.

  3. Dans la page Sauvegarde et restauration, dans la section Sauvegarde précise, cliquez sur Exporter un site ou une liste.

  4. Dans la page Exportation d'un site ou d'une liste, dans la section Collection de sites, sélectionnez la collection de sites dans la liste Collection de sites, puis sélectionnez le site dans la liste Site.

  5. Si vous exportez un site, ignorez cette étape, sélectionnez la liste ou la bibliothèque de documents dans Liste.

  6. Dans la section Emplacement du fichier, dans la zone Nom de fichier, tapez le chemin d'accès UNC du dossier partagé et du fichier vers lequel vous souhaitez exporter la liste ou la bibliothèque de documents. Le nom du fichier doit utiliser l'extension .cmp.

  7. Si le fichier existe déjà et que vous souhaitez l'utiliser, activez la case à cocher Remplacer les fichiers existants. Sinon, spécifiez un nom de fichier différent.

  8. Si vous souhaitez exporter tous les paramètres de sécurité et d'autorisations avec la liste ou la bibliothèque, dans la section Exporter la sécurité totale, activez la case à cocher Exporter la sécurité totale.

  9. Si vous souhaitez spécifier la version de la liste ou bibliothèque à exporter, sélectionnez l'une des versions suivantes dans la liste Exporter les versions :

    • Toutes les versions

    • Dernière version principale

    • Version actuelle

    • Dernière version principale et dernière version mineure

  10. Une fois que vous avez spécifié les paramètres de votre choix, cliquez sur Démarrer l'exportation.

  11. Vous pouvez afficher l'état de tous les travaux de sauvegarde en haut de la page État précis du travail de sauvegarde. Vous pouvez afficher l'état du travail de sauvegarde en cours dans la section Exportation de contenu de la page. La page de l'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la sauvegarde peut prendre plusieurs secondes.

    Si vous recevez des erreurs, vous pouvez les consulter dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous pouvez aussi trouver davantage de détails dans le fichier <nom fichier>.export.log qui se trouve dans le chemin d'accès UNC que vous avez spécifié à l'étape 6.

Voir aussi

Concepts

Préparer la sauvegarde et la récupération (SharePoint Foundation 2010)

Historique des modifications


Sauvegarder ou archiver des journaux (SharePoint Foundation 2010)

Une stratégie de niveau système pour la protection des données doit inclure la sauvegarde ou l'archivage des journaux, dans lesquels les données liées à Microsoft SharePoint Foundation 2010 sont enregistrées. Ces données peuvent s'avérer utiles pour l'analyse des performances, le dépannage, la surveillance de la conformité aux contrats de niveau de service et pour des raisons légales, réglementaires ou professionnelles. Par conséquent, protégez ces données dans le cadre de la maintenance de routine en sauvegardant ou en archivant les journaux.

Les sections suivantes sont étiquetées comme suit pour indiquer l'importance de la sauvegarde ou de l'archivage de ce type de journal :

  • [Essentiel] signifie que le journal contient des données essentielles à l'environnement. Les données sont perdues en cas d'échec du disque ou si un autre problème se produit.

  • [Recommandé] signifie que le journal contient des données utiles dans la plupart des environnements pour des besoins de dépannage, de fonctionnement, juridiques ou autres.

Dans cet article :

  • [Essentiel] Sauvegarder les journaux de transactions

  • [Recommandé] Collecter les données d'utilisation

  • [Recommandé] Archiver les journaux de diagnostic

[Essentiel] Sauvegarder les journaux de transactions

Les journaux de transactions Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3 enregistrent toutes les modifications apportées à une base de données depuis le dernier point de contrôle ou la dernière sauvegarde complète. Ces journaux contiennent les données nécessaires à la restauration de la batterie de serveurs.

Il est recommandé de sauvegarder ces journaux toutes les 5 à 10 minutes. Lorsque vous sauvegardez ces journaux, ils sont automatiquement tronqués. Vous pouvez utiliser les outils de Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3 pour sauvegarder les journaux de transactions. Pour plus d'informations, voir Création de sauvegardes des journaux de transactions (http://go.microsoft.com/fwlink/?linkid=124881&clcid=0x40C) dans la documentation Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3.

Les journaux de transactions sont également sauvegardés automatiquement lorsque vous sauvegardez la batterie de serveurs, l'application Web ou les bases de données à l'aide du site Web Administration centrale de SharePoint ou de Windows PowerShell. Pour plus d'informations, voir Sauvegarder une batterie de serveurs (SharePoint Foundation 2010).

Impact de la taille du journal de transactions sur la durée des sauvegardes de batterie

Lorsque vous sauvegardez SharePoint Foundation 2010, la taille du journal de transactions peut affecter la durée de l'opération de sauvegarde. Comme le journal de transaction enregistre toutes les modifications apportées à une base de données depuis le dernier point de contrôle ou la dernière sauvegarde complète, le journal peut devenir très important avec le temps. Si le journal de transactions est devenu très important, les sauvegardes peuvent prendre beaucoup de temps. Pour plus d'informations, voir Comment empêcher le journal de transactions d'une base de donnes SQL Server d'augmenter de manière inattendue (http://go.microsoft.com/fwlink/?linkid=111458&clcid=0x40C).

Pour tronquer le journal de transactions si vous utilisez un modèle de récupération complète, il est recommandé de sauvegarder le journal. Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 et SQL Server 2005 avec SP3 et mise à jour cumulative 3 tronque automatiquement les parties inactives du journal de transactions lorsque vous sauvegardez le journal. Il est également recommandé d'augmenter au préalable la taille du journal de transactions pour éviter l'augmentation automatique du journal. Pour plus d'informations, voir Gestion de la taille du fichier journal de transactions (http://go.microsoft.com/fwlink/?linkid=124882&clcid=0x40C). Pour plus d'informations sur l'utilisation d'un mode de récupération complète, voir Sauvegarde en mode de récupération complète (http://go.microsoft.com/fwlink/?linkid=127985&clcid=0x40C). Pour plus d'informations sur l'utilisation d'un mode de récupération simple, voir Sauvegarde selon le mode de récupération simple (http://go.microsoft.com/fwlink/?linkid=127987&clcid=0x40C).

Il n'est pas recommandé de réduire manuellement la taille du journal de transactions ou de tronquer manuellement le journal en utilisant la méthode Truncate.

[Recommandé] Collecter les données d'utilisation

L'analyse de l'utilisation vous permet d'assurer le suivi des sites Web utilisés. Des fichiers journaux quotidiens assurent le suivi de l'utilisation. Vous pouvez configurer les paramètres de la collecte des données d'utilisation. L'un des paramètres les plus importants est l'emplacement des fichiers journaux. Par défaut, le dossier de journalisation est configuré pour être situé sur la même partition que l'installation de SharePoint Foundation 2010. Pour être assuré que la taille des fichiers journaux n'excède pas la taille du lecteur, placez le dossier de journalisation sur un lecteur distinct.

L'emplacement du répertoire des journaux est un paramètre au niveau de la batterie de serveurs ; par ailleurs, le répertoire spécifié dans ce paramètre doit être disponible sur tous les serveurs de la batterie. Ces journaux sont automatiquement sauvegardés lorsque vous sauvegardez la batterie de serveurs.

Pour la plupart des environnements, les paramètres par défaut sont appropriés. Pour plus d'informations sur la configuration des paramètres de collecte des données d'utilisation, voir Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010)

[Recommandé] Archiver les journaux de diagnostic

Les journaux de diagnostic fournissent des informations détaillées sur le fonctionnement de la batterie de serveurs. Vous pouvez configurer le niveau de détail journalisé. Il est recommandé d'archiver ces journaux lorsque vous archivez la batterie de serveurs. Vous pouvez archiver les journaux pour l'ensemble de la batterie de serveurs ou pour un serveur spécifique. Vous pouvez archiver ces fichiers en les copiant manuellement dans un dossier partagé, ou en utilisant l'applet de commande Windows PowerShell Merge-SPlogFile. Vous pouvez utiliser l'applet de commande Merge-SPLogFile pour archiver en une seule fois les fichiers journaux de l'ensemble des serveurs de la batterie. Vous pouvez utiliser l'applet de commande Windows PowerShell Copy-Item pour archiver les fichiers journaux d'un seul serveur. L'applet de commande Copy-Item ne fournit pas de filtrage ; en outre, vous devez copier l'intégralité du fichier journal.

Pour plus d'informations sur la configuration de la journalisation des diagnostics, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

Pour archiver les journaux de diagnostic de tous les serveurs de la batterie via Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Merge-SPLogFile -Path "<path to merged log file>.log" -Overwrite

    Par exemple, Merge-SPLogFile -Path "C:\Logs\MergedFiles\AllFarm_merged_12.20.2009.log" -Overwrite

    Important :
    La fusion de toutes les entrées de journal pour l'ensemble des serveurs de la batterie peut durer longtemps et nécessiter de nombreuses ressources. Il est recommandé de filtrer les entrées en fonction d'un jeu spécifique de critères avant d'effectuer la fusion.

    Pour fusionner les entrées de journal qui correspondent à un jeu spécifique de critères, tapez la commande suivante :

    Merge-SPLogFile -Path "<path to merged log file>.log" -Area "<Area>" -Category "<Category>"

    Vous pouvez effectuer un filtrage en fonction d'un ou de plusieurs des éléments ci-après :

    • Area (un ou plus, caractère générique)

    • Category (un ou plus, caractère générique)

    • Level

    • Correlation (un ou plus)

    • EventID (un ou plus, caractère générique)

    • Message (caractère générique)

    • StartTime

    • EndTime

    • Process (un ou plus, caractère générique)

    • ThreadID (un ou plus)

    Conseil :
    Vous pouvez nommer le fichier journal fusionné comme bon vous semble. Il est recommandé d'utiliser une convention d'affectation des noms qui facilite l'identification du contenu du fichier journal, par exemple <date fusion>_<nom batterie>_<critères filtrage>. Par exemple, pour indiquer toutes les entrées de journal des serveurs de la batterie SharePoint Foundation 2010 qui incluent la catégorie Base de données et sont marquées comme « Importantes », « Déc_2009_BaseDeDonnées_ContosoInternet_Foundation_Important.log ».

Pour plus d'informations, voir Merge-SPLogFile.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour archiver les journaux de diagnostic d'un serveur spécifique de la batterie via Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Copy-Item <Log folder path> -Destination <Archive folder path> -Recurse

Pour plus d'informations, taper Get-Help Copy-Item -Full.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Récupération (SharePoint Foundation 2010)
Voir aussi

Les articles de cette section visent à répondre aux besoins des informaticiens chargés de la planification, de la conception, du déploiement et de l'exploitation de solutions de sauvegarde et de récupération. Ces solutions peuvent se trouver dans les environnements d'entreprise ou de succursales. Les informaticiens responsables des solutions de sauvegarde et de récupération sont censés comprendre les détails techniques contenus dans cette section. Toutefois, une expertise de niveau de service n'est pas nécessaire pour comprendre les discussions et les décisions de niveau entreprise.

Avant de restaurer une batterie de serveurs, assurez-vous que les conditions répertoriées ci-dessous sont remplies :

  • Pour restaurer une batterie de serveurs à l'aide du site Web Administration centrale de SharePoint, vous devez être membre du groupe Administrateurs de batterie de serveurs.

  • Pour restaurer une batterie de serveurs à l'aide de Windows PowerShell, les exigences minimales suivantes doivent être remplies : Voir Add-SPShellAdmin.

  • Le compte SQL Server du serveur de bases de données, le compte de service du minuteur et le compte du pool d'applications de l'Administration centrale doivent avoir des autorisations Lecture sur les emplacements de sauvegarde. (Le compte de service du minuteur et le compte du pool d'applications de l'Administration centrale sont généralement les mêmes.) Le compte SQL Server du serveur de bases de données doit être membre du rôle de serveur fixe sysadmin.

  • Votre compte d'ouverture de session doit avoir des autorisations Lecture pour les emplacements de sauvegarde.

  • Vérifiez que le service d'administration SharePoint Foundation est démarré sur tous les serveurs de la batterie de serveurs. Par défaut, ce service n'est pas démarré sur les installations autonomes.

Prenez note de ce qui suit avant de restaurer une batterie de serveurs :

  • La restauration depuis une version des produits et technologies SharePoint vers une autre version n'est pas prise en charge.

  • Après la récupération, la recherche risque de n'être de nouveau disponible qu'au bout de 15 minutes, voir plus si le système de rechercher doit analyser de nouveau tout le contenu. Si vous sauvegardez et restaurez le service entier, le système n'aura pas besoin de réaliser une réanalyse complète.

  • Vous ne pouvez effectuer qu'une seule opération de récupération ou de sauvegarde à la fois.

Récupérer tout ou partie d'une batterie de serveurs

Les tâches de récupération suivantes sont effectuées sur l'intégralité de la batterie de serveurs, des bases de données de batterie de serveurs, des sites, des sous-sites ou des listes :

  • Restaurer une batterie de serveurs (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer l'intégralité de la batterie de serveurs à partir d'une sauvegarde.

  • Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer la configuration de la batterie de serveurs vers la même batterie de serveurs à partir d'une sauvegarde.

  • Copier des paramètres de configuration d'une batterie à l'autre (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de copier les paramètres de configuration d'une batterie de serveurs à une autre, notamment la sauvegarde et la récupération d'une batterie de serveurs sans les bases de données de contenu, la sauvegarde et la récupération des configurations uniquement, ainsi que la création d'un script de déploiement.

  • Restaurer une application Web (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer une application Web associée à la batterie de serveurs, y compris la configuration et les bases de données de contenu, à partir d'une sauvegarde.

  • Restaurer une application de service (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer une application de service associée à la batterie de serveurs, y compris la configuration et les bases de données de contenu, à partir d'une sauvegarde.

  • Restaurer une base de données de contenu (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer une base de données de contenu à partir d'une sauvegarde.

  • Restaurer une collection de sites (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer une collection de sites à partir d'une sauvegarde.

  • Restaurer les personnalisations (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer les personnalisations associées à la batterie de serveurs à partir des sauvegardes.

  • Attacher et restaurer une base de données de contenu en lecture seule (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent d'attacher une base de données de contenu en lecture seule à la batterie de serveurs.

  • Importer une liste ou une bibliothèque de documents (SharePoint Foundation 2010)

    Cet article décrit les procédures qui permettent de restaurer un site, une liste ou une bibliothèque de documents à partir d'une sauvegarde.

Voir aussi

Concepts

Sauvegarde (SharePoint Foundation 2010)

Historique des modifications


Restaurer une batterie de serveurs (SharePoint Foundation 2010)

Cet article explique comment restaurer une batterie de serveurs Microsoft SharePoint Foundation 2010. La récupération au niveau de la batterie est généralement réalisée uniquement après une défaillance qui implique la batterie entière ou lorsque la récupération partielle d'une partie de la batterie est impossible. Si vous devez restaurer uniquement une partie de la batterie, une base de données spécifique, une application de service, une liste, une bibliothèque de documents ou un document particulier, utilisez une autre méthode de récupération. Pour plus d'informations sur les autres formes de récupération, voir Contenu connexe.

La récupération de la batterie de serveurs est généralement réalisée pour l'une des raisons suivantes :

  • restauration d'une batterie de serveurs après un incendie, un incident, une défaillance matérielle ou un autre événement ayant engendré une perte de données ;

  • restauration des données et des paramètres de configuration de la batterie de serveurs à une date et heure antérieures spécifiques ;

  • déplacement d'un déploiement SharePoint Foundation 2010 d'une batterie de serveurs vers une autre.

Dans cet article :

  • Considérations relatives à la récupération d'une batterie de serveurs

  • Utiliser Windows PowerShell pour restaurer une batterie de serveurs

  • Utiliser l'Administration centrale pour restaurer une batterie de serveurs

  • Utiliser les outils SQL Server pour restaurer une batterie de serveurs

Considérations relatives à la récupération d'une batterie de serveurs

Il convient de prendre en compte les éléments suivants lors de la préparation à la récupération d'une batterie de serveurs :

  • Vous ne pouvez pas restaurer une batterie composée de plusieurs serveurs vers une batterie à serveur unique, ni une batterie à serveur unique vers une batterie composée de plusieurs serveurs.

  • Vous ne pouvez pas effectuer une sauvegarde depuis une version de Microsoft SharePoint Foundation et une restauration vers une autre version de SharePoint Foundation.

  • La sauvegarde de la batterie entraîne la sauvegarde des bases de données de contenu de configuration et d'Administration centrale, mais celles-ci ne peuvent pas être restaurées à l'aide des outils Microsoft SharePoint Foundation 2010. Pour plus d'informations sur la sauvegarde et la restauration de toutes les bases de données de la batterie, voir Déplacer toutes les bases de données (SharePoint Foundation 2010).

  • Lorsque vous restaurez la batterie à l'aide de Microsoft SharePoint Foundation 2010, le processus de restauration ne redémarre pas automatiquement toutes les applications de service. Vous devez les redémarrer manuellement à l'aide de l'Administration centrale ou de Windows PowerShell. N'utilisez pas l'Assistant Configuration des produits SharePoint pour démarrer les services, car cette opération remettrait en service les services et proxys de services.

  • L'identificateur (ID) de chaque base de données de contenu est conservé lorsque vous restaurez ou rattachez une base de données à l'aide des outils intégrés. Le comportement de rétention par défaut du journal des modifications est le suivant lorsque vous utilisez les outils intégrés :

    1. Les journaux des modifications de toutes les bases de données sont conservés lorsque vous restaurez une batterie de serveurs.

    2. Le journal des modifications des bases de données de contenu est conservé lorsque vous rattachez ou restaurez une base de données.

      Lorsqu'un ID de base de données et un journal des modifications sont conservés, le système de recherche continue l'analyse selon le calendrier normal défini par les règles d'analyse.

      Lorsque vous restaurez une base de données existante et n'utilisez pas l'option de remplacement, un nouvel ID est affecté à la base de données restaurée, et le journal des modifications de la base de données n'est pas conservé. L'analyse suivante de la base de données ajoutera des données de la base de données de contenu à l'index.

      Si une restauration est effectuée et que l'ID du package de sauvegarde est utilisé dans la batterie de serveurs, un nouvel ID est attribué à la base de données restaurée et un avertissement est ajouté au journal de restauration. Si l'ID de la base de données de contenu n'a pas changé et que le jeton de journal des modifications utilisé par le système de recherche est valide pour le journal des modifications actuel de la base de données de contenu, vous pouvez réaliser une analyse incrémentielle au lieu d'une analyse complète. Si le journal des modifications n'est pas conservé, le jeton n'est pas valide et le système de recherche doit procéder à une analyse complète.

  • La sauvegarde de SharePoint Foundation 2010 sauvegarde les définitions de types de contenus externes du service Connexion de données métiers mais ne sauvegarde pas la source de données proprement dite. Pour protéger les données, vous devez sauvegarder la source de données lorsque vous sauvegardez le service Connexion de données métiers ou la batterie.

    Si vous restaurez le service Connexion de données métiers ou la batterie puis restaurez la source de données à un autre emplacement, vous devez modifier les informations d'emplacement dans la définition de type de contenu externe. Si vous ne le faites pas, le service Connexion de données métiers risque de ne pas pouvoir localiser la source de données.

  • SharePoint Foundation 2010 restaure les magasins BLOB (Binary Large Objects) uniquement si vous utilisez le fournisseur de magasins BLOB distants FILESTREAM pour mettre les données dans des magasins BLOB distants.

    Si vous utilisez un autre fournisseur, vous devez restaurer manuellement les magasins BLOB distants.

  • Si un utilisateur a placé des copies de contenu hors connexion afin de les modifier dans Microsoft SharePoint Workspace 2010 et que le contenu est restauré à partir d'une sauvegarde sur le serveur, lorsque l'utilisateur se reconnecte, le serveur synchronise automatiquement le contenu hors connexion avec le contenu restauré. Cela peut entraîner une perte de données sur les copies de l'utilisateur.

  • Si vous partagez des applications de service parmi des batteries, sachez que les certificats d'approbation ayant été échangés ne sont pas compris dans les sauvegardes de batteries. Vous devez sauvegarder votre magasin de certificats séparément ou conserver les certificats à un emplacement distinct. Lorsque vous restaurez une batterie qui partage une application de service, vous devez importer et redéployer les certificats, puis rétablir toute approbation inter-batterie.

    Pour plus d'informations, voir Échanger des certificats d'approbation entre batteries de serveurs (SharePoint Foundation 2010).

  • À l'issue de la restauration d'une application Web configurée de façon à utiliser l'authentification basée sur les revendications, des fournisseurs de revendications supplémentaires ou en double sont souvent visibles. Si des doublons apparaissent, vous devez enregistrer manuellement chaque zone d'application Web afin de les supprimer. Pour plus d'informations, voir Restaurer une application Web (SharePoint Foundation 2010).

  • Des étapes supplémentaires sont requises lorsque vous restaurez une batterie qui contient une application Web configurée de façon à utiliser l'authentification basée sur les formulaires. Pour plus d'informations, voir Restaurer une application Web (SharePoint Foundation 2010).

Utiliser Windows PowerShell pour restaurer une batterie de serveurs

Vous pouvez utiliser Windows PowerShell pour restaurer une batterie de serveurs.

Pour restaurer une batterie de serveurs à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    Restore-SPFarm -Directory <BackupFolder> -RestoreMethod Overwrite [-BackupId <GUID>]

    Où :

    • <BackupFolder> est le chemin d'accès au dossier que vous utilisez pour stocker les fichiers de sauvegarde.

    • <GUID> est l'identificateur de la sauvegarde à partir de laquelle effectuer la restauration.

    Remarque :
    Si vous n'avez pas ouvert la session sous le compte de la batterie de serveurs, vous êtes invité à fournir les informations d'identification du compte de la batterie de serveurs.

    Si vous ne spécifiez pas le BackupId, c'est la sauvegarde la plus récente qui est utilisée. Pour afficher les sauvegardes de la batterie, tapez la commande suivante et appuyez sur Entrée :

    Code de copie
    Get-SPBackupHistory -Directory <BackupFolder> -ShowBackup [-Verbose]

    Vous ne pouvez pas utiliser une sauvegarde de type configuration-uniquement pour restaurer les bases de données de contenu avec la configuration.

  6. Pour redémarrer des applications de service, tapez la commande suivante et appuyez sur Entrée :

    Code de copie
    Start-SPServiceInstance -Identity <ServiceApplicationID>

    Où <ServiceApplicationID> est le GUID de l'application de service.

    Pour redémarrer toutes les applications de service, utilisez Start-SPServiceInstance sans paramètre. Pour plus d'informations sur le redémarrage d'applications de service à l'aide de Windows PowerShell, voir Start-SPServiceInstance.

Pour plus d'informations sur la restauration de la batterie de serveurs à l'aide de Windows PowerShell, voir Restore-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour restaurer une batterie de serveurs

Vous pouvez utiliser le site Web Administration centrale pour restaurer une batterie de serveurs.

Pour restaurer une batterie de serveurs à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans l'Administration centrale, dans la page Accueil, dans la section Sauvegarde et restauration, cliquez sur Restaurer à partir d'une sauvegarde.

  3. Dans la page Restauration à partir d'une sauvegarde - Étape 1 sur 3 : sélectionner la sauvegarde à restaurer, sélectionnez, dans la liste des sauvegardes, le travail de sauvegarde qui contient la sauvegarde de la batterie de serveurs, puis cliquez sur Suivant. Vous pouvez afficher plus de détails sur chaque sauvegarde en cliquant sur le signe (+) à côté de la sauvegarde.

    Remarque :
    Si le travail de sauvegarde adéquat n'apparaît pas, dans la zone de texte Emplacement de l'historique de sauvegarde, entrez le chemin d'accès UNC du dossier de sauvegarde adéquat, puis cliquez sur Actualiser.

    Vous ne pouvez pas utiliser une sauvegarde de configuration uniquement pour restaurer la batterie de serveurs.

  4. Dans la page Restaurer à partir d'une sauvegarde - Étape 2 sur 3 : sélectionner un composant à restaurer, activez la case à cocher en regard de la batterie de serveurs, puis cliquez sur Suivant.

  5. Sur la page Restaurer à partir d'une sauvegarde - Étape 3 sur 3 : sélectionner les options de restauration, dans la section Restaurer un composant, vérifiez que Batterie de serveurs apparaît dans la liste Restaurer le contenu suivant.

    Dans la section Restaurer uniquement les paramètres de configuration, vérifiez que l'option Restaurer le contenu et les paramètres de configuration est sélectionnée.

    Dans la section Options de restauration, sous Type de restauration, sélectionnez l'option Configuration existante. Une boîte de dialogue apparaît, vous invitant à confirmer l'opération. Cliquez sur OK.

    Remarque :
    Si la section Restaurer uniquement les paramètres de configuration n'apparaît pas, la sauvegarde que vous avez sélectionnée est une sauvegarde de configuration uniquement. Vous devez sélectionner une autre sauvegarde.

    Cliquez sur Lancer la restauration.

  6. Vous pouvez voir l'état général de tous les travaux de récupération en haut de la page État des opérations de sauvegarde et de restauration, dans la section Disponibilité. Vous pouvez voir l'état du travail de sauvegarde en cours dans la partie inférieure de la page, dans la section Restauration. La page de l'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service Minuteur. Par conséquent, le démarrage de la récupération peut prendre plusieurs secondes.

    Si vous obtenez des erreurs, vous pouvez les consulter dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous trouverez également des détails supplémentaires dans le fichier Sprestore.log situé à l'emplacement indiqué à l'étape 3.

  7. Une fois le processus de restauration terminé, vous devrez peut-être redémarrer une ou plusieurs applications de service. Dans l'Administration centrale, dans la page Accueil, dans la section Gestion des applications, cliquez sur Gérer les services sur le serveur.

  8. Dans la page Services sur le serveur, démarrez les services liés aux applications de service que vous souhaitez exécuter en cliquant sur Démarrer dans la colonne Actions en regard de l'application de service.

  9. Rétablissez les éventuelles relations d'approbation. Pour plus d'informations, voir Échanger des certificats d'approbation entre batteries de serveurs (SharePoint Foundation 2010).

Utiliser les outils SQL Server pour restaurer une batterie de serveurs

Bien que vous ne puissiez pas restaurer la batterie de serveurs entière à l'aide des outils SQL Server, vous pouvez restaurer la plupart des bases de données de la batterie de serveurs. Si vous restaurez les bases de données à l'aide des outils SQL Server, vous devez restaurer la configuration de la batterie de serveurs à l'aide de l'Administration centrale ou de Windows PowerShell. Pour plus d'informations sur la restauration des paramètres de configuration de la batterie de serveurs, voir Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010).

Remarque :
L'index de recherche n'est pas stocké dans SQL Server. Si vous utilisez les outils SQL Server pour sauvegarder et restaurer la recherche, vous devez effectuer une analyse complète après avoir restauré la base de données de contenu.

Avant de restaurer SharePoint Foundation 2010, il est recommandé de configurer une batterie de serveurs de récupération pour la récupération du site et des éléments.

Pour restaurer les bases de données, procédez comme suit :

  1. Dans la mesure du possible, sauvegardez le journal des transactions en direct de la base de données actuelle pour protéger les modifications qui ont été apportées après la dernière sauvegarde complète.

  2. Restaurez la dernière sauvegarde complète de la base de données.

  3. Restaurez la sauvegarde de base de données différentielle la plus récente qui s'est produite après la sauvegarde de base de données complète la plus récente.

  4. Restaurez toutes les sauvegardes de journal des transactions qui se sont produites après la sauvegarde de base de données complète ou différentielle la plus récente.

Pour restaurer une batterie de serveurs à l'aide des outils SQL Server

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du rôle de serveur fixe sysadmin.

  2. Si le service du minuteur Windows SharePoint Services est en cours d'exécution, arrêtez-le et patientez jusqu'à ce que les procédures stockées en cours d'exécution soient terminées. Ne redémarrez pas le service tant que vous n'avez pas restauré les bases de données nécessaires.

  3. Démarrez SQL Server Management Studio et connectez-vous au serveur de bases de données.

  4. Dans l'Explorateur d'objets, développez Bases de données.

  5. Cliquez avec le bouton droit sur les bases de données à restaurer, pointez sur Tâches, pointez sur Restaurer, puis cliquez sur Base de données.

    La base de données est automatiquement mise hors connexion pendant l'opération de récupération et n'est pas accessible par d'autres processus.

  6. Dans la boîte de dialogue Restaurer la base de données, spécifiez la destination et la source, puis sélectionnez le jeu ou les jeux de sauvegarde à restaurer.

    Les valeurs par défaut pour la destination et la source conviennent pour la plupart des scénarios de récupération.

  7. Dans le volet Sélectionner une page, cliquez sur Options.

  8. Dans la section Options de restauration, sélectionnez uniquement Remplacer la base de données existante. À moins que votre environnement ou vos stratégies ne le nécessitent, ne sélectionnez aucune autre option dans cette section.

  9. Dans la section État de récupération :

    • Si vous avez inclus tous les journaux des transactions à restaurer, sélectionnez RECOVER WITH RECOVERY.

    • Si vous devez restaurer d'autres journaux des transactions, sélectionnez RECOVER WITH NORECOVERY.

    • La troisième option, RECOVER WITH STANDBY n'est pas utilisée dans ce scénario.

      Remarque :
      Pour plus d'informations sur ces options de récupération, voir Restaurer la base de données (page Options) (http://go.microsoft.com/fwlink/?linkid=114420&clcid=0x40C).

  10. Cliquez sur OK pour terminer l'opération de récupération.

  11. Sauf pour la base de données de configuration, répétez les étapes 4 à 9 pour chaque base de données à restaurer.

  12. Pour restaurer les paramètres de configuration, vous devez utiliser la base de données de configuration existante ou créer manuellement une nouvelle base de données et restaurer la configuration dans cette base de données. Pour plus d'informations sur la restauration de la configuration d'une batterie de serveurs, voir Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010).

  13. Démarrez le service du minuteur Windows SharePoint Services.

Contenu connexe

Centre de ressources | Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201997&clcid=0x40C)
Contenu IT Pro | Sauvegarder une batterie de serveurs (SharePoint Foundation 2010) Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010) Restaurer une application Web (SharePoint Foundation 2010) Restaurer une base de données de contenu (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
16 septembre 2010 | 2010/09/13 | Mise à jour du contenu
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010)
Voir aussi

Cette rubrique explique comment restaurer la configuration d'une batterie de serveurs.

Remarque :
Dans les versions antérieures de Microsoft SharePoint Foundation 2010, vous ne pouviez pas restaurer la base de données de configuration et, par conséquent, vous ne pouviez pas restaurer la configuration d'une batterie de serveurs. Dans cette version de SharePoint Foundation 2010, vous n'avez pas besoin de restaurer la base de données de configuration, car vous pouvez restaurer la configuration de la batterie de serveurs directement.

Procédures décrites dans cette tâche :

  • Utiliser Windows PowerShell pour restaurer la configuration d'une batterie de serveurs

  • Utiliser l'Administration centrale pour restaurer la configuration d'une batterie de serveurs

Présentation

La récupération de configuration au niveau de la batterie de serveurs s'effectue uniquement après une défaillance impliquant la base de données de configuration mais non les autres données de la batterie, telles qu'une base de données de contenu ou une application Web. Si la restauration de la configuration de la batterie de serveurs ne résout pas les problèmes, vous devez restaurer l'intégralité de la batterie. Pour plus d'informations sur la restauration de l'ensemble de la batterie de serveurs, voir Restaurer une batterie de serveurs (SharePoint Foundation 2010). Vous pouvez restaurer la configuration à partir de la sauvegarde d'une batterie de serveurs ayant utilisé l'option Sauvegarder les paramètres de contenu et de configuration ou Sauvegarder uniquement les paramètres de configuration.

Utiliser Windows PowerShell pour restaurer la configuration d'une batterie de serveurs

Vous pouvez utiliser Windows PowerShell pour restaurer la configuration d'une batterie de serveurs.

Pour restaurer la configuration d'une batterie de serveurs à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Restore-SPFarm -Directory <RestoreShare> -RestoreMethod Overwrite -ConfigurationOnly

    Vous devez utiliser le paramètre ConfigurationOnly. Pour afficher la progression de l'opération, utilisez le paramètre Verbose.

Pour plus d'informations, voir Restore-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour restaurer la configuration d'une batterie de serveurs

Vous pouvez utiliser l'Administration centrale pour restaurer la configuration d'une batterie de serveurs.

Pour restaurer la configuration d'une batterie de serveurs à l'aide de l'Administration centrale

  1. Assurez-vous que vous êtes membre du groupe Administrateurs de batterie SharePoint sur l'ordinateur qui exécute l'Administration centrale et membre du rôle de serveur fixe sysadmin sur le serveur de bases de données où chaque base de données est stockée.

  2. Dans l'Administration centrale, dans la page Accueil, dans la section Sauvegarde et restauration, cliquez sur Restaurer à partir d'une sauvegarde.

  3. Dans la page Restauration à partir d'une sauvegarde - Étape 1 sur 3 : sélectionner la sauvegarde à restaurer, sélectionnez, dans la liste des sauvegardes, le travail de sauvegarde qui contient la sauvegarde de batterie de serveurs, puis cliquez sur Suivant.

    Remarque :
    Vous pouvez afficher des informations supplémentaires sur une sauvegarde spécifique en développant la ligne qui contient la sauvegarde.

    Remarque :
    Si le travail de sauvegarde adéquat n'apparaît pas, dans la zone de texte Emplacement de l'historique de sauvegarde, entrez le chemin d'accès UNC du dossier de sauvegarde adéquat, puis cliquez sur Actualiser.

  4. Dans la page Restaurer à partir d'une sauvegarde - Étape 2 sur 3 : sélectionner un composant à restaurer, activez la case à cocher en regard de la batterie de serveurs, puis cliquez sur Suivant.

  5. Dans la page Restaurer à partir d'une sauvegarde - Étape 3 sur 3 : sélectionner les options de restauration, dans la section Restaurer un composant, vérifiez que la mention « Batterie de serveurs » apparaît dans la liste Restaurer le contenu suivant.

    Dans la section Restaurer uniquement les paramètres de configuration, vérifiez que l'option Restaurer le contenu et les paramètres de configuration est sélectionnée.

    Dans la section Options de restauration, sélectionnez l'option Type de restauration. Utilisez le paramètre Configuration existante. Une boîte de dialogue apparaît, dont le message vous invite à confirmer l'opération. Cliquez sur OK.

    Remarque :
    Si la section Restaurer uniquement les paramètres de configuration n'apparaît pas, la sauvegarde que vous avez sélectionnée est une sauvegarde de configuration uniquement.

    Cliquez sur Lancer la restauration.

  6. Vous pouvez afficher l'état général de tous les travaux de récupération en haut de la page État de la sauvegarde et de la restauration dans la section Disponibilité. Vous pouvez afficher l'état du travail de sauvegarde en cours dans la partie inférieure de la page dans la section Restauration. La page de l'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la récupération peut prendre plusieurs secondes.

    Si vous obtenez des erreurs, vous pouvez les examiner dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous pouvez également obtenir des détails supplémentaires dans le fichier Sprestore.log stocké sur le chemin d'accès UNC que vous avez spécifié à l'étape 2.

Utiliser SQL Server pour restaurer la configuration d'une batterie de serveurs

Vous ne pouvez pas restaurer la configuration d'une batterie de serveurs à l'aide des outils SQL Server.

Voir aussi

Concepts

Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010)

Historique des modifications


Documenter les paramètres de configuration de batteries (SharePoint Foundation 2010)

Cet article décrit comment utiliser Windows PowerShell 2.0 pour documenter les paramètres de configuration de votre batterie. Documenter les paramètres de configuration est important pour créer des déploiements par script pour votre environnement et pour recréer rapidement un jeu de configurations en cas de panne.

Pour documenter les paramètres de configuration à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'aide du Bloc-notes, créez un fichier texte, puis copiez et collez le script suivant dans le fichier. Les commandes de cet exemple créent des fichiers XML qui documentent les configurations des applications Web et des applications de service dans la batterie en cours. Choisissez uniquement les commandes utiles à votre environnement.

    Code de copie
    ##
## Common SharePoint configuration settings
##
#Retrieve Web Application information. The default depth of 2 does not return much detail--we recommend that you use a depth of 4 for this cmdlet.
Get-SPWebApplication | Export-Clixml .\ WebAppFilename.xml -depth 4

#Retrieve custom layout information.
Get-SPWebApplication | Get-SPCustomLayoutsPage | Export-Clixml .\Get-SPCustomLayoutsPage.xml

#Determine how SharePoint designer access is configured
Get-SPWebApplication | Get-SPDesignerSettings  | Export-Clixml .\Get-SPDesignerSettings.xml

#Retrieve information about alternate access mapping
Get-SPAlternateURL  | Export-Clixml .\Get-SPAlternateURL.xml

#Retrieve information about content databases
Get-SPContentDatabase  | Export-Clixml .\Get-SPContentDatabase.xml

#Retrieve database properties for each database
Get-SPDatabase  | Export-Clixml .\Get-SPDatabase.xml

#Retrieve information about all SharePoint Products installed in the farm, and the versions of all updates installed for each product.
Get-SPProduct  | Export-Clixml .\Get-SPProduct.xml

#Retrieve farm information
Get-SPFarm  | Export-Clixml .\Get-SPFarm.xml
Get-SPFarmConfig  | Export-Clixml .\Get-SPFarmConfig.xml

#Retrieve information about the servers in the farm
Get-SPServer  | Export-Clixml .\Get-SPServer.xml

#Retrieve information about installed features
Get-SPFeature  | Export-Clixml .\Get-SPFeature.xml

#Retrieve information about globally-installed site templates
Get-SPWebTemplate  | Export-Clixml .\Get-SPWebTemplate.xml

#Retrieve information about deployed solutions
Get-SPSolution  | Export-Clixml .\Get-SPSolution.xml

#Retrieve information about sandboxed solutions deployed in a site collection
Get-SPSite | Get-SPUserSolution  | Export-Clixml .\Get-SPUserSolution.xml

#Retrieve information about installed Help
Get-SPHelpCollection  | Export-Clixml .\Get-SPHelpCollection.xml

#Retrieve information about the logging levels that have been set
Get-SPLogLevel  | Export-Clixml .\Get-SPLogLevel.xml

#Retrieve information about the sites in the farm
Get-SPSite  | Export-Clixml .\Get-SPSite.xml
Get-SPSiteAdministration  | Export-Clixml .\Get-SPSiteAdministration.xml
Get-SPSiteSubscription  | Export-Clixml .\Get-SPSiteSubscription.xml

#Retrieve ULS logging information
Get-SPDiagnosticConfig  | Export-Clixml .\Get-SPDiagnosticConfig.xml
Get-SPDiagnosticsPerformanceCounter  | Export-Clixml .\Get-SPDiagnosticsPerformanceCounter.xml
Get-SPDiagnosticsProvider  | Export-Clixml .\Get-SPDiagnosticsProvider.xml

#Retrieve information about accounts registered in the configuration database
Get-SPManagedAccount  | Export-Clixml .\Get-SPManagedAccount.xml
Get-SPProcessAccount  | Export-Clixml .\Get-SPProcessAccount.xml
Get-SPShellAdmin  | Export-Clixml .\Get-SPShellAdmin.xml

#Retrieve information about the Mobile Messaging account.
Get-SPWebApplication | Get-SPMobileMessagingAccount  | Export-Clixml .\Get-SPMobileMessagingAccount.xml

##
##Common service infrastructure settings
##
#Retrieve information about the service applications in the farm
Get-SPServiceApplication  | Export-Clixml .\Get-SPServiceApplication.xml
Get-SPServiceApplicationPool  | Export-Clixml .\Get-SPServiceApplicationPool.xml
Get-SPServiceApplicationProxy  | Export-Clixml .\Get-SPServiceApplicationProxy.xml
Get-SPServiceApplicationProxyGroup  | Export-Clixml .\Get-SPServiceApplicationProxyGroup.xml
Get-SPServiceApplication | Get-SPServiceApplicationEndpoint  | Export-Clixml .\Get-SPServiceApplicationEndpoint.xml

#Retrieve information about the services running in the farm
Get-SPServiceInstance  | Export-Clixml .\Get-SPServiceInstance.xml

#Retrieve information about common Web service settings
Get-SPServiceHostConfig  | Export-Clixml .\Get-SPServiceHostConfig.xml

##
## Common service application configurations
##

#Application Discovery and Load Balancer Service Application
Get-SPTopologyServiceApplication  | Export-Clixml .\Get-SPTopologyServiceApplication.xml
Get-SPTopologyServiceApplicationProxy  | Export-Clixml .\Get-SPTopologyServiceApplicationProxy.xml

#Business Data Connectivity Service
#Retrieve information about data connection files. ###WARNING: The following cmdlet requires  run as administrator rights
Get-SPDataConnectionFile | Export-Clixml .\Get-SPDataConnectionFile.xml
###WARNING: The following cmdlet requires  run as administrator rights
Get-SPDataConnectionFile | Get-SPDataConnectionFileDependent  | Export-Clixml .\Get-SPDataConnectionFileDependent.xml

#Security Token Service Application
#Retrieve information about the security token service used for incoming SOAP messages.
Get-SPSecurityTokenServiceConfig  | Export-Clixml .\Get-SPSecurityTokenServiceConfig.xml

#Usage and Health data collection
#Retrieve information about the Usage and Health Data Collection service application.
Get-SPUsageApplication  | Export-Clixml .\Get-SPUsageApplication.xml
Get-SPUsageDefinition  | Export-Clixml .\Get-SPUsageDefinition.xml
Get-SPUsageService  | Export-Clixml .\Get-SPUsageService.xml

###Note: These cmdlets are commented out because you are unlikely to want to run them. ###
#Get-SPSite | %{$web=Get-SPWeb $_.Url;$webid=$web.Id;$web | Get-SPUser | Export-Clixml .\Get-SPUser-$webid.xml}

# Get-SPSite | %{$web=Get-SPWeb $_.Url;$webid=$web.Id;$web | Export-Clixml .\Get-SPWeb-$webid.xml}

  6. Pour exécuter le script, dans la console Windows PowerShell, depuis l'invite de commandes (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :C:\<path>\<filename>.ps1

Pour plus d'informations, voir Export-Clixml, Get-SPWebApplication, Get-SPServiceApplication.

Exemple d'utilisation d'une applet de commande

Cette section illustre l'utilisation d'une des applets de commande recommandées.

L'applet de commande Get-SPAlternateURL fournit des informations sur le mappage d'accès de substitution. La canalisation de l'applet de commande vers l'applet de commande Export-Clixml écrit les informations dans un fichier XML.

Code de copie
Get-SPAlternateURL | Export-Clixml .\Get-SPAlternateURL.xml

La section suivante répertorie le contenu du fichier Get-SPAlternateURL.xml. Certaines sections sont réduites.

Code de copie
- <Objs Version="1.1.0.1" xmlns="http://schemas.microsoft.com/powershell/2004/04">
+ <Obj RefId="0">
- <Obj RefId="7">
  <TNRef RefId="0" />
  <ToString>Microsoft.SharePoint.Administration.SPAlternateUrl</ToString>
- <Props>
  <S N="IncomingUrl">http://servername</S>
  <URI N="Uri">http://servername/</URI>
+ <Obj N="UrlZone" RefId="8">
- <Obj N="Collection" RefId="9">
  <TNRef RefId="2" />
- <IE>
- <Obj RefId="10">
  <TNRef RefId="0" />
  <ToString>Microsoft.SharePoint.Administration.SPAlternateUrl</ToString>
+ <Props>
- <MS>
  <S N="Zone">Default</S>
  <S N="PublicUrl">http://servername</S>
  </MS>
  </Obj>
  </IE>
- <Props>
  <I32 N="Count">1</I32>
  <B N="IsReadOnly">false</B>
  <S N="TypeName">Alternate Access Mapping Collection</S>
  <S N="DisplayName">SharePoint - 80</S>
  <U64 N="DiskSizeRequired">0</U64>
  <B N="CanSelectForBackup">false</B>
  <B N="CanRenameOnRestore">false</B>
  <B N="CanSelectForRestore">false</B>
  <S N="Name">SharePoint - 80</S>
  <G N="Id">5b65a69a-222d-4fe0-904b-0fb928bc7a89</G>
  <S N="Status">Online</S>
  <S N="Parent">SPFarm Name=SERVERNAME_SharePoint_Configuration_Database</S>
  <I64 N="Version">3661</I64>
+ <Obj N="Properties" RefId="12">
  <TNRef RefId="3" />
  <DCT />
  </Obj>
  <S N="Farm">SPFarm Name=SERVERNAME_SharePoint_Configuration_Database</S>
  <Ref N="UpgradedPersistedProperties" RefId="11" />
  </Props>
  </Obj>
  <Ref N="UpgradedPersistedProperties" RefId="11" />
  </Props>
+ <MS>
+ <Obj N="Zone" RefId="13">
  <TNRef RefId="1" />
  <ToString>Default</ToString>
  <I32>0</I32>
  </Obj>
  <S N="PublicUrl">http://servername</S>
  </MS>
  </Obj>
  </Objs>

Cet exemple importe la sortie du fichier XML pour mieux en afficher le contenu.

Code de copie
Import-Clixml .\Get-SPAlternateURL.xml

Une fois un fichier XML importé, vous pouvez utiliser les objets dans le pipeline comme s'il s'agissait d'objets véritable d'un type donné.

Code de copie
Import-Clixml .\Get-SPAlternateURL.xml | %{$_.Uri}

Vous pouvez aussi canaliser les objets dans l'applet de commande et consulter toutes les propriétés, méthodes et TypeNames attendus. L'exemple suivant canalise les URI.

Code de copie
Import-Clixml .\Get-SPAlternateURL.xml | %{$_.Uri | Get-Member}

Pour plus d'informations, voir Export-Clixml, Import-Clixml, Get-SPAlternateURL, ForEach-Object, Get-Member.

Historique des modifications


Copier des paramètres de configuration d'une batterie à l'autre (SharePoint Foundation 2010)

Cet article explique comment copier les paramètres de configuration d'une batterie de serveurs Microsoft SharePoint Foundation 2010 vers une autre batterie de serveurs SharePoint Foundation 2010. La copie des paramètres de configuration d'une batterie de serveurs vers une autre peut s'avérer utile dans les cas suivants :

  • configuration d'environnements de développement, de test et de production similaires ;

  • établissement d'une norme d'organisation pour les paramètres de configuration de batterie de serveurs ;

  • configuration d'un environnement de récupération d'urgence.

Dans cet article :

  • Sauvegarder et récupérer une batterie de serveurs sans bases de données de contenu pour copier les paramètres de configuration

  • Sauvegarder et récupérer uniquement les paramètres de configuration

  • Créer un déploiement à base de script pour copier les paramètres de configuration

Il existe divers moyens de copier les configurations d'une batterie de serveurs vers une autre. Choisissez la méthode à employer en fonction des paramètres de configuration que vous voulez copier et de la fréquence à laquelle vous devez les copier.

  • Sauvegarde et récupération d'une batterie de serveurs sans les bases de données de contenu attachées. Outre les paramètres des applications de service que vous sélectionnez, cette méthode vous fournit les paramètres de batterie de serveurs et d'application Web.

  • Sauvegarde et récupération des configurations uniquement. Cette méthode fournit uniquement les paramètres de base de SharePoint Foundation 2010.

    Remarque :
    Cette méthode n'inclut pas les paramètres d'application Web ou d'application de service. Si les paramètres d'application Web sont requis dans la batterie de serveurs récupérée, employez l'une des autres méthodes.

  • Création d'un script de déploiement en fonction de la configuration de référence. Si cette méthode demande davantage de travail en amont, elle est facile à utiliser et permet de maintenir la normalisation.

Sauvegarder et récupérer une batterie de serveurs sans bases de données de contenu pour copier les paramètres de configuration

Pour copier les paramètres de configuration à l'aide d'une sauvegarde de batterie de serveurs, il est recommandé de détacher au préalable les bases de données de contenu de la batterie. En revanche, cette opération est déconseillée avec une batterie de serveurs de production en ligne.

Remarque :
Les applications de service sont sauvegardées dans le cadre de la création d'une sauvegarde de batterie de serveurs sans bases de données de contenu.

Pour sauvegarder et récupérer une batterie de serveurs sans bases de données de contenu à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante pour documenter les URL d'applications Web actives et les mappages de base de données de contenu.

    Code de copie
    Get-SPWebApplication | %{$_.Name;$_.Url;%{$_.ContentDatabases|%{$_.Name};Write-Host ""}}

  6. Première possibilité : démontez toutes les bases de données de contenu, comme dans l'exemple suivant :

    Code de copie
    Get-SPContentDatabase | Dismount-SPContentDatabase

    Deuxième possibilité : démontez une base de données de contenu spécifique, comme dans l'exemple suivant :

    Code de copie
    Get-SPContentDatabase WSS_Content | Dismount-SPContentDatabase

  7. Sauvegardez la batterie de serveurs.

    Code de copie
    Backup-SPFarm -Directory \\servername\share -BackupMethod Full
    Remarque :
    Vous pouvez examiner la progression de la sauvegarde en consultant le fichier \\servername\share\spbr####\spbackup.log.

  8. Une fois la sauvegarde terminée, remontez les bases de données de contenu. Remplacez <WSS_Content> et <http://servername> par chacun des mappages documentés à l'étape 5.

    Code de copie
    Mount-SPContentDatabase -Name <WSS_Content> -WebApplication <http://servername>

Sauvegarder et récupérer uniquement les paramètres de configuration

Dans le cadre de la sauvegarde d'une batterie de serveurs, vous pouvez choisir de sauvegarder uniquement les paramètres de configuration. Une sauvegarde limitée à la configuration extrait et sauvegarde la plupart des paramètres de configuration à partir d'une base de données de configuration, mais pas tous. À l'aide des outils intégrés, vous pouvez sauvegarder la configuration de n'importe quelle base de données de configuration, que celle-ci soit ou non actuellement liée à une batterie de serveurs. Pour obtenir des informations détaillées sur la procédure de sauvegarde d'une configuration, voir Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010). Une sauvegarde de configuration peut être restaurée dans la même batterie de serveurs (ou dans n'importe quelle autre). Lorsqu'une configuration est restaurée, elle remplace tous les paramètres présents dans la batterie de serveurs par les valeurs correspondantes définies dans la sauvegarde de la configuration. Si des paramètres présents dans la batterie de serveurs sont absents de la sauvegarde de la configuration, ils ne sont pas remplacés. Pour obtenir des informations détaillées sur la procédure de restauration d'une configuration de batterie de serveurs, voir Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010).

Créer un déploiement à base de script pour copier les paramètres de configuration

Lorsque vous créez un déploiement à base de script de SharePoint Foundation 2010, vous créez des copies de paramètres de configuration.

Historique des modifications


Restaurer une application Web (SharePoint Foundation 2010)

Cet article explique comment restaurer une application Web. Lorsque vous restaurez une application Web, vous restaurez également les paramètres IIS (Internet Information Services) et toutes les bases de données de contenu associées à l'application Web.

Dans cet article :

  • Considérations relatives à la sauvegarde des applications Web

  • Utiliser Windows PowerShell pour restaurer une application Web

  • Utiliser l'administration centrale pour restaurer une application Web

  • Étapes supplémentaires pour restaurer une application Web qui utilise l'authentification basée sur les formulaires

Considérations relatives à la sauvegarde des applications Web

Il convient de prendre en compte les éléments suivants lors de la préparation à la restauration d'une application Web.

  • Les procédures de cet article permettent de ne restaurer qu'une seule application Web à la fois. Toutefois, vous pouvez restaurer simultanément toutes les applications Web dans la batterie de serveurs en restaurant la batterie complète.

  • Vous ne pouvez pas utiliser les outils SQL Server pour restaurer une application Web.

  • Lors de la restauration d'une application Web configurée de façon à utiliser l'authentification basée sur les revendications, vous devez effectuer certaines étapes supplémentaires après avoir restauré l'application Web afin de restaurer l'authentification basée sur les revendications.

Utiliser Windows PowerShell pour restaurer une application Web

Vous pouvez utiliser Windows PowerShell pour restaurer une application Web manuellement ou en tant que partie d'un script qui peut être exécuté à intervalles planifiés.

Pour restaurer une application Web à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Code de copie
    Restore-SPFarm -Directory <BackupFolderName> -RestoreMethod Overwrite -Item  <WebApplicationName> [-BackupId <GUID>] [-Verbose]

    Où :

    • <BackupFolderName> est le chemin d'accès complet au dossier que vous utilisez pour les fichiers de sauvegarde.

    • <WebApplicationName> est le nom de l'application Web qui a été sauvegardée.

    • <GUID> est l'identificateur de la sauvegarde à utiliser pour l'opération de restauration.

    Si vous ne spécifiez pas la valeur du paramètre BackupID, la sauvegarde la plus récente est utilisée. Vous ne pouvez pas restaurer une application Web en utilisant une sauvegarde de type configuration-uniquement. Vous pouvez afficher les sauvegardes pour la batterie de serveurs en tapant la commande suivante :

    Code de copie
    Get-SPBackupHistory -Directory <BackupFolderName> -ShowBackup

Pour plus d'informations, voir Restore-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'administration centrale pour restaurer une application Web

Vous pouvez utiliser l'administration centrale pour restaurer une application Web.

Pour restaurer une application Web à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie. En outre, vérifiez que le service Minuteur Windows SharePoint Services V4 et le compte d'accès aux bases de données de la batterie de serveurs disposent des autorisations Contrôle total sur le dossier de sauvegarde.

  2. Dans la page d'accueil de l'Administration centrale, à la section Sauvegarde et restauration, cliquez sur Restaurer à partir d'une sauvegarde.

  3. Dans la page Restaurer à partir d'une sauvegarde - étape 1 sur 3 : sélectionnez la sauvegarde à restaurer, dans la liste des sauvegardes, sélectionnez le travail de sauvegarde qui contient la batterie de serveurs ou la sauvegarde d'application Web, puis cliquez sur Suivant. Vous pouvez afficher plus de détails sur chaque sauvegarde en cliquant sur le signe (+) à côté de la sauvegarde.

    Remarque :
    Si la tâche de sauvegarde correcte ne s'affiche pas, dans la zone de liste Emplacement du répertoire actuel, tapez le chemin d'accès UNC (Universal Naming Convention) du dossier de sauvegarde approprié, puis cliquez sur Actualiser.

    Vous ne pouvez pas utiliser une sauvegarde de configuration uniquement pour restaurer l'application Web.

  4. Dans la page Restaurer à partir d'une sauvegarde - Étape 2 sur 3 : sélectionnez un composant à restaurer, activez la case à cocher en regard de l'application Web, puis cliquez sur Suivant.

  5. Dans la page Restaurer à partir d'une sauvegarde - Étape 3 sur 3 : sélectionnez les options de restauration, à la section Restaurer un composant, vérifiez que Batterie\<application Web> apparaît dans la liste Restaurer le contenu suivant.

    À la section Restaurer uniquement les paramètres de configuration, assurez-vous que l'option Restaurer les paramètres de contenu et de configuration est sélectionnée.

    À la section Options de restauration, sous Type de restauration, sélectionnez l'option Même configuration. Une boîte de dialogue s'affiche pour confirmer l'opération. Cliquez sur OK.

    Remarque :
    Si la section Restaurer uniquement les paramètres de configuration n'apparaît pas, la sauvegarde que vous avez sélectionnée est une sauvegarde de configuration uniquement. Vous devez sélectionner une autre sauvegarde.

    Cliquez sur Démarrer la restauration.

  6. Vous pouvez afficher l'état général de tous les travaux de récupération en haut de la page État de la sauvegarde et de la restauration dans la section Disponibilité. Vous pouvez afficher l'état du travail de sauvegarde en cours dans la partie inférieure de la page dans la section Restauration. La page de l'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la récupération peut prendre plusieurs secondes.

    Si des messages d'erreur s'affichent, vous pouvez les traiter dans la colonne Message d'erreur de la page d'état des tâches de restauration et de sauvegarde. Vous trouverez également des détails supplémentaires dans le fichier Sprestore.log situé à l'emplacement indiqué.

Étapes supplémentaires pour restaurer une application Web qui utilise l'authentification basée sur les formulaires

Après avoir restauré une application Web qui utilise l'authentification basée sur les formulaires, vous devez effectuer les étapes suivantes afin de reconfigurer l'application Web de sorte qu'elle utilise l'authentification basée sur les formulaires.

  1. réinscrire les fournisseurs d'appartenances et de rôles dans le fichier Web.config ;

  2. redéployer les fournisseurs.

Pour plus d'informations, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

Étapes supplémentaires à effectuer pour supprimer les doublons de fournisseurs de revendications après avoir restauré une application Web qui utilise l'authentification basée sur les revendications.

À l'issue de la restauration d'une application Web configurée de façon à utiliser l'authentification basée sur les revendications, des fournisseurs de revendications supplémentaires ou en double sont souvent visibles. Pour supprimer ces doublons, procédez comme suit :

  1. Dans l'Administration centrale, cliquez sur Gérer les applications Web, sélectionnez une application Web qui utilise l'authentification basée sur les revendications, puis cliquez sur Fournisseurs d'authentification.

  2. Sélectionnez une zone avec laquelle l'application Web est associée afin d'ouvrir la page Modifier l'authentification, puis cliquez sur Enregistrer.

  3. Répétez l'opération pour chaque zone, puis pour chaque application Web qui utilise l'authentification basée sur les revendications.

Contenu connexe

Centre de ressources | Gestion de la continuité des opérations pour SharePoint Server 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=201997&clcid=0x40C)
Contenu IT Pro | Sauvegarder une application Web (SharePoint Foundation 2010) Planifier la sauvegarde et la récupération (SharePoint Foundation 2010) Sauvegarde et récupération (SharePoint Foundation 2010)
Contenu de développement | Protection et récupération des données (http://go.microsoft.com/fwlink/?linkid=199237&clcid=0x40C)

Historique des modifications

Date | Description | Raison
2011/01/17 | 2011/01/17 | Mise à jour du contenu
16 septembre 2010 | 2010/09/13 | Mise à jour du contenu


Restaurer une application de service (SharePoint Foundation 2010)

Il y a des situations dans lesquelles vous devez restaurer une application de service spécifique plutôt que la batterie de serveurs complète. Certaines applications de service, par exemple l'application du service Business Data Connectivity, fournissent des données à d'autres services et sites. Par conséquent, les utilisateurs peuvent être confrontés à des interruptions de service tant que le processus de récupération n'est pas terminé.

Pour plus d'informations sur la façon de restaurer simultanément toutes les applications de service dans une batterie de serveurs, voir Restaurer une batterie de serveurs (SharePoint Foundation 2010).

Important :
Vous ne pouvez pas effectuer une sauvegarde depuis une version de Microsoft SharePoint Foundation et la restaurer vers une autre version de SharePoint Foundation.

Remarque :
SharePoint Foundation 2010 sauvegarde le magasin de métadonnées du service BDC (Business Data Connectivity), qui inclut les types de contenu externe, les systèmes externes et les modèles BDC. Pour plus d'informations, voir Administration du service Connexion de données métiers (SharePoint Foundation 2010). Notez que cela ne permet pas de sauvegarder les sources de données externes. Pour protéger les données, vous devez sauvegarder les sources de données externes.

Si vous restaurez l'application de service ou la batterie de serveurs, et si vous restaurez ensuite la source de données à un autre emplacement, vous devez changer les informations d'emplacement dans la définition du type de contenu externe. Dans le cas contraire, le service Business Data Connectivity risque de ne pas pouvoir localiser la source de données.

Remarque :
SharePoint Foundation 2010 restaure les magasins d'objets BLOB, mais seulement si vous utilisez le fournisseur FILESTREAM pour mettre les données dans des magasins d'objets BLOB distants.

Si vous utilisez un autre fournisseur, vous devez restaurer manuellement les magasins d'objets BLOB distants.

Procédures décrites dans cet article :

  • Utiliser Windows PowerShell pour restaurer une application de service

  • Utiliser l'administration centrale pour restaurer une application de service

  • Utiliser des outils SQL Server pour restaurer les bases de données d'une application de service

    Remarque :
    Vous ne pouvez pas restaurer l'application de service complète, mais vous pouvez restaurer les bases de données qui y sont associées.

Utiliser Windows PowerShell pour restaurer une application de service

Vous pouvez utiliser Windows PowerShell pour restaurer une application de service.

Pour restaurer une application de service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Restore-SPFarm -Directory <BackupFolder> -Item <ServiceApplicationName> -RecoveryMethod Overwrite [-BackupId <GUID>] [-Verbose]

    Pour spécifier quelle sauvegarde utiliser, utilisez le paramètre BackupId. Vous pouvez afficher les sauvegardes de la batterie de serveurs en tapant le texte suivant : Get-SPBackupHistory -Directory <Backup folder> -ShowBackup. Si vous ne spécifiez pas le paramètre BackupId, la sauvegarde la plus récente sera utilisée. Vous ne pouvez pas restaurer une application de service à partir d'une sauvegarde de configuration uniquement.

Pour plus d'informations, voir Restore-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'administration centrale pour restaurer une application de service

Utilisez la procédure suivante pour restaurer une application de service par le biais du site Web Administration centrale de SharePoint.

Pour restaurer une application de service à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, à la section Sauvegarde et restauration, cliquez sur Restaurer à partir d'une sauvegarde.

  3. Dans la page Restauration à partir d'une sauvegarde - Étape 1 sur 3 : sélectionner la sauvegarde à restaurer, sélectionnez, dans la liste des sauvegardes, le travail de sauvegarde qui contient la sauvegarde de l'application de service ou une sauvegarde au niveau de la batterie de serveurs, puis cliquez sur Suivant. Vous pouvez afficher plus de détails sur chaque sauvegarde en cliquant sur le signe (+) à côté de la sauvegarde.

    Remarque :
    Lorsque la tâche de sauvegarde correcte ne s'affiche pas, entrez le chemin d'accès du dossier de sauvegarde approprié dans la zone de texte Emplacement de l'historique de sauvegarde, puis cliquez sur Actualiser.

    Vous ne pouvez pas utiliser une sauvegarde de configuration uniquement pour restaurer la batterie de serveurs.

  4. Dans la page Restaurer à partir d'une sauvegarde - Étape 2 sur 3 : sélectionner un composant à restaurer, développez Applications de services partagées, activez la case à cocher en regard de l'application de service, puis cliquez sur Suivant.

  5. Dans la page Restaurer à partir d'une sauvegarde - Étape 3 sur 3 : sélectionner les options de restauration, à la section Restaurer un composant, vérifiez que Batterie de serveurs\Applications de services partagées\<application de service> apparaît dans la liste Restaurer le contenu suivant.

    Dans la section Options de restauration, sous Type de restauration, sélectionnez l'option Configuration existante. Une boîte de dialogue s'affiche vous invitant à confirmer l'opération. Cliquez sur OK.

    Cliquez sur Lancer la restauration.

  6. Vous pouvez voir l'état général de tous les travaux de récupération en haut de la page État des opérations de sauvegarde et de restauration, dans la section Disponibilité. Vous pouvez voir l'état de la sauvegarde en cours dans la partie inférieure de la page, dans la section Restauration. La page d'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez actualiser manuellement les détails d'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service Minuteur. Par conséquent, le démarrage de la récupération peut prendre plusieurs secondes.

    Si vous obtenez des erreurs, vous pouvez les consulter dans la colonne Message d'échec de la page État des opérations de sauvegarde et de restauration. Vous trouverez également des détails supplémentaires dans le fichier Sprestore.log situé à l'emplacement indiqué à l'étape 3.

Utiliser des outils SQL Server pour restaurer les bases de données d'une application de service

Vous ne pouvez pas restaurer l'application de service complète à l'aide des outils SQL Server. Toutefois, vous pouvez utiliser ces outils pour restaurer les bases de données qui sont associées à l'application de service. Pour restaurer l'application de service complète, utilisez Windows PowerShell ou l'Administration centrale.

Pour restaurer les bases de données d'une application de service à l'aide d'outils SQL Server

  1. Vérifiez que le compte d'utilisateur que vous utilisez pour restaurer les bases de données est membre du rôle serveur fixe sysadmin SQL Server sur le serveur de bases de données qui héberge chaque base de données.

  2. Ouvrez SQL Server Management Studio et connectez-vous au serveur de bases de données.

  3. Dans l'Explorateur d'objets, développez Bases de données.

  4. Cliquez avec le bouton droit sur les bases de données à restaurer, pointez sur Tâches, sur Restaurer, puis cliquez sur Base de données.

  5. Dans la boîte de dialogue Restaurer la base de données, dans la page Général, sélectionnez la base de données à partir de laquelle effectuer la restauration dans la liste Vers la base de données.

  6. Sélectionnez la source de restauration dans la liste déroulante De la base de données.

  7. Dans la zone Sélectionnez les jeux de sauvegarde à restaurer, activez la case à cocher en regard de la base de données.

  8. Sous l'onglet Options, sélectionnez l'état de récupération dans la section État de récupération.

    Pour plus d'informations sur le type de récupération à utiliser, voir Vue d'ensemble du mode de récupération (http://go.microsoft.com/fwlink/?linkid=114396&clcid=0x40C) dans la documentation en ligne de SQL Server.

  9. Cliquez sur OK pour restaurer la base de données.

  10. Répétez les étapes 1 à 9 pour chaque base de données associée à l'application de service.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | 2010/07/05 | Mise à jour du contenu


Restaurer une collection de sites (SharePoint Foundation 2010)
Voir aussi

Vous pouvez utiliser uniquement Windows PowerShell pour restaurer une collection de sites.

Utiliser Windows PowerShell pour restaurer une collection de sites

Vous pouvez utiliser Windows PowerShell pour restaurer une collection de sites manuellement ou en tant que partie d'un script qui peut être exécuté à intervalles planifiés.

Pour restaurer une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale suivante : Voir Add-SPShellAdmin. En outre, vérifiez que le compte d'utilisateur exécutant cette procédure possède les autorisations de lecture sur le dossier de sauvegarde et est membre du rôle de base de données fixe db_owner à la fois dans la base de données de configuration de la batterie de serveurs et la base de données de contenu où la collection de sites est restaurée.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Restore-SPSite -Identity <Site collection URL> -Path <Backup file> [-DatabaseServer <Database server name>] [-DatabaseName <Content database name>] [-HostHeader <Host header>] [-Force] [-GradualDelete] [-Verbose]

    Si vous souhaitez restaurer la collection de sites dans une base de données de contenu spécifique, utilisez les paramètres DatabaseServer et DatabaseName pour spécifier la base de données de contenu. Si vous ne spécifiez pas une base de données de contenu, la collection de sites sera restaurée dans une base de données de contenu choisie par Microsoft SharePoint Foundation 2010.

    Si vous restaurez une collection de sites nommée par l'hôte, utilisez le paramètre Identity pour spécifier l'URL de la collection de sites nommée par l'hôte et utilisez le paramètre HostHeader pour spécifier l'URL de l'application Web qui contiendra la collection de sites nommée par l'hôte.

    Si vous souhaitez remplacer une collection de sites existante, utilisez le paramètre Force.

    Remarque :
    Si la collection de sites que vous restaurez fait un gigaoctet ou plus, vous pouvez utiliser le paramètre GradualDelete pour obtenir de meilleures performances au cours du processus de restauration. Lorsque ce paramètre est utilisé, la collection de sites remplacée est marquée comme étant supprimée, ce qui empêche immédiatement tout accès supplémentaire à son contenu. Les données dans la collection de sites marquée sont ensuite supprimées progressivement au fil du temps par un travail de minuteur et non pas toutes en même temps, ce qui réduit l'impact sur les performances du serveur.

Pour plus d\rquote informations, voir Restore-SPSite.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Sauvegarder une collection de sites (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Restaurer les personnalisations (SharePoint Foundation 2010)

Cet article explique comment restaurer des personnalisations qui ont été apportées à des sites dans une batterie de serveurs Microsoft SharePoint Foundation.

Cet article suppose que vous connaissez les concepts et procédures présentés dans Sauvegarder les personnalisations (SharePoint Foundation 2010).

Dans cet article :

  • Restauration de packages de solutions

  • Restauration d'éléments de site créés

  • Restauration de flux de travail

  • Restauration de modifications apportées au fichier Web.config

  • Récupération de modifications apportées directement

  • Restauration de personnalisations développées qui ne sont pas empaquetées en tant que solutions

Restauration de packages de solutions

La méthode qui vous permet de restaurer des packages de solutions varie selon que les personnalisations sont déployées en tant que solutions approuvées ou solutions bac à sable (sandbox).

Les solutions approuvées sont des solutions déployées par des administrateurs de batterie. Elles sont déployées dans la batterie entière et peuvent être utilisées sur n'importe quel site de la batterie. Elles sont stockées dans la base de données de configuration. Elles sont sauvegardées lorsqu'une batterie est sauvegardée à l'aide de la sauvegarde SharePoint Foundation 2010, sont comprises dans les sauvegardes de type configuration-uniquement et peuvent également être sauvegardées individuellement ou en tant que groupe. Elles sont visibles dans la hiérarchie de restauration.

Les solutions bac à sable (sandbox) sont des solutions que les administrateurs de collections de sites peuvent déployer sur une collection de sites unique. Elles sont stockées dans la base de données de contenu associée à la collection de sites dans laquelle elles sont déployées. Elles sont incluses dans les sauvegardes de batterie SharePoint Foundation 2010, d'application Web, de base de données de contenu et de collection de site, mais elles ne sont pas visibles dans la hiérarchie de restauration et ne peuvent pas être sélectionnées ou restaurées individuellement.

Nous vous recommandons de conserver une sauvegarde du fichier .wsp d'origine et du code source servant à générer le fichier .wsp pour les solutions approuvées et bac à sable (sandbox).

Pour restaurer une solution approuvée à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, dans la section Sauvegarde et restauration, cliquez sur Restaurer à partir d'une sauvegarde.

  3. Dans la page Restauration à partir d'une sauvegarde - Étape 1 sur 3 : sélectionner la sauvegarde à restaurer, sélectionnez, dans la liste des sauvegardes, le travail de sauvegarde qui contient le package de solution, puis cliquez sur Suivant. Vous pouvez afficher plus de détails sur chaque sauvegarde en cliquant sur le signe (+) à côté de la sauvegarde.

    Remarque :
    Si la tâche de sauvegarde correcte ne s'affiche pas, tapez le chemin UNC (Universal Naming Convention) du dossier de sauvegarde correct dans la zone de texte Emplacement de l'historique de sauvegarde, puis cliquez sur Actualiser.

  4. Dans la page Restaurer à partir d'une sauvegarde - Étape 2 sur 3 : sélectionner un composant à restaurer, activez la case à cocher en regard de la solution, puis cliquez sur Suivant.

  5. Sur la page Restaurer à partir d'une sauvegarde - Étape 3 sur 3 : sélectionner les options de restauration, dans la section Restaurer un composant, vérifiez que Solution apparaît dans la liste Restaurer le composant suivant.

    Dans la section Restaurer uniquement les paramètres de configuration, vérifiez que l'option Restaurer le contenu et les paramètres de configuration est sélectionnée.

    Dans la section Options de restauration, sous Type de restauration, sélectionnez l'option Configuration existante. Une boîte de dialogue s'affiche pour confirmer l'opération. Cliquez sur OK.

    Cliquez sur Lancer la restauration.

  6. Vous pouvez afficher l'état général de tous les travaux de récupération en haut de la page État de la sauvegarde et de la restauration dans la section État. Vous pouvez afficher l'état du travail de récupération en cours dans la partie inférieure de la page, dans la section Restauration. La page d'état est actualisée automatiquement toutes les 30 secondes. Vous pouvez mettre à jour les détails de l'état manuellement en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service du minuteur. Par conséquent, le démarrage de la récupération peut prendre plusieurs secondes.

    Si des messages d'erreur s'affichent, vous pouvez les examiner dans la colonne Message d'erreur de la page État des opérations de sauvegarde et de restauration. Vous trouverez également des détails supplémentaires dans le fichier Sprestore.log situé à l'emplacement indiqué à l'étape 2.

Pour restaurer une solution approuvée à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Restore-SPFarm -Directory <BackupFolder> -RestoreMethod Overwrite -BackupId <GUID> -Item <SolutionPath>

    Où :

    • <BackupFolder> est l'emplacement UNC du répertoire à partir duquel effectuer la restauration.

    • <GUID> est le GUID de l'ID de sauvegarde à partir duquel vous souhaitez effectuer la restauration. Si vous ne spécifiez aucune sauvegarde, la plus récente est utilisée.

    • <SolutionPath> est le chemin d'accès à la solution dans l'arborescence de sauvegarde (généralement farm\solutions\nom_solution).

Pour plus d'informations, voir Restore-SPFarm.

Restauration d'une solution bac à sable (sandbox)

Il est impossible de restaurer uniquement les personnalisations qui ont été déployées en tant que solutions bac à sable (sandbox). Au lieu de cela, vous devez restaurer la batterie, l'application Web, la base de données de contenu ou la collection de sites à laquelle la personnalisation est associée. Pour plus d'informations sur ces méthodes de restauration, voir Contenu associé plus loin dans cet article.

Restauration d'éléments de site créés

Il est impossible de restaurer uniquement les éléments de sites créés. Au lieu de cela, vous devez restaurer la batterie, l'application Web ou la base de données de contenu à laquelle est associé l'élément de sites créé. Pour plus d'informations sur ces méthodes de sauvegarde, voir Contenu associé.

Restauration de flux de travail

Les flux de travail constituent un cas particulier de personnalisation que vous pouvez restaurer. Assurez-vous que le plan de sauvegarde et de récupération gère les scénarios suivants qui s'appliquent à l'environnement :

  • Les flux de travail déclaratifs, tels que ceux créés dans Microsoft SharePoint Designer 2010, sont stockés dans la base de données de contenu de la collection de sites sur laquelle ils sont déployés. La restauration de la base de données de contenu ou de la collection de sites restaure ces flux de travail.

  • Les actions de flux de travail déclaratifs personnalisés ont des composants aux trois emplacements suivants :

    1. Les assemblys Microsoft Visual Studio 2010 pour les actions sont stockés dans le Global Assembly Cache.

    2. Les fichiers de définition XML (fichiers .actions) sont stockés dans le répertoire 14\TEMPLATE\<LCID>\Workflow.

    3. Une entrée XML marquant l'action comme type autorisé est stockée dans le fichier web.config des applications Web dans lesquelles elle est utilisée.

    Si les flux de travail de batterie utilisent des actions personnalisées, vous devez recourir à un système de restauration de fichiers pour restaurer ces fichiers et les entrées XML. Vous pouvez réappliquer les fichiers selon les besoins après la récupération.

  • Les flux de travail qui dépendent de code personnalisé, tels que ceux créés à l'aide de Visual Studio 2010, sont stockés à deux emplacements. Les assemblys Visual Studio 2010 pour le flux de travail sont stockés dans le Global Assembly Cache et les fichiers de définition XML sont stockés dans le répertoire Features. Ceci est identique à d'autres types de fonctionnalités SharePoint Foundation telles que les composants WebPart et les récepteurs d'événements. Si le flux de travail a été installé dans le cadre d'un package de solution, suivez les instructions de restauration de packages de solutions.

  • Si vous créez un flux de travail personnalisé qui interagit avec une collection de sites autre que celle dans laquelle le flux de travail est déployé, vous devez restaurer les deux collections de sites afin de restaurer le flux de travail. Une restauration de batterie suffit à restaurer toutes les collections de site de la batterie et tous les flux de travail qui y sont associés.

  • Les flux de travail qui n'ont pas été déployés doivent être restaurés séparément à l'aide d'une application de sauvegarde de système de fichiers.

Restauration de modifications apportées au fichier Web.config

Vous pouvez récupérer les modifications apportées au fichier Web.config à l'aide de l'Administration centrale ou de l'API et du modèle objet SharePoint Foundation 2010 en effectuant une restauration de batterie ou de type configuration-uniquement.

Vous devez utiliser une sauvegarde de système de fichiers pour protéger les modifications apportées au fichier Web.config par un moyen autre que l'Administration centrale ou l'API et le modèle objet SharePoint. Vous pouvez récupérer la sauvegarde par le biais d'une restauration du système de fichiers.

Récupération de modifications apportées directement

Les modifications apportées directement à un site par le biais du navigateur peuvent être difficiles à récupérer. Le tableau suivant décrit les stratégies de récupération pour des objets spécifiques.

Objet modifié | Stratégie de sauvegarde
Liste | Si vous avez utilisé SharePoint Designer 2010 pour enregistrer en tant que modèle, vous pouvez déployer et activer le modèle. Pour plus d'informations, voir Enregistrer un site SharePoint en tant que modèle (http://go.microsoft.com/fwlink/?linkid=199515&clcid=0x40C).
Site | Si vous avez utilisé SharePoint Designer 2010 pour enregistrer en tant que modèle, vous pouvez déployer et activer le modèle. Pour plus d'informations, voir Enregistrer un site SharePoint en tant que modèle (http://go.microsoft.com/fwlink/?linkid=199515&clcid=0x40C).
Collection de sites | Utilisez la récupération de collection de sites. Pour plus d'informations, voir Restaurer une collection de sites (SharePoint Foundation 2010).

Restauration de personnalisations développées qui ne sont pas empaquetées en tant que solutions

La restauration de personnalisations développées qui ne sont pas empaquetées en tant que solutions peut s'avérer complexe car les emplacements des fichiers de personnalisation ne sont pas normalisés.

Contactez l'équipe de développement ou le fournisseur de personnalisation afin de déterminer si les personnalisations impliquent des logiciels complémentaires ou des fichiers à d'autres emplacements. Nous vous recommandons de restaurer les répertoires avec une solution de restauration de système de fichiers. Le tableau suivant répertorie les emplacements où les personnalisations sont généralement stockées sur des serveurs Web.

Emplacement | Description
%COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14 | Fichiers fréquemment mis à jour, assemblys personnalisés, modèles personnalisés, définitions de site personnalisé
Inetpub | Emplacement des répertoires virtuels IIS
%WINDIR%\Assembly | Global Assembly Cache (GAC) : emplacement protégé du système d'exploitation où les assemblys de code .NET Framework sont installés pour fournir l'accès système complet.

Contenu associé

Centre de ressources | Gestion de la continuité des activités professionnelles pour SharePoint Server 2010 : sauvegarde, récupération, disponibilité et récupération d'urgence (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=199235&clcid=0x40C)
Contenu IT Pro | Déployer des personnalisations - Vue d'ensemble (SharePoint Foundation 2010) Sauvegarder les personnalisations (SharePoint Foundation 2010) Restaurer une batterie de serveurs (SharePoint Foundation 2010) Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010) Restaurer une application Web (SharePoint Foundation 2010) Restaurer une base de données de contenu (SharePoint Foundation 2010) Restaurer une collection de sites (SharePoint Foundation 2010)
Contenu pour développeurs | Utilisation de solutions (MSDN) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=156638&clcid=0x40C) Solutions bac à sable (MSDN) (http://go.microsoft.com/fwlink/?linkid=199517&clcid=0x40C)

Historique des modifications

Date | Description | Raison
12 août 2010 | 2010/08/09 | Mise à jour du contenu


Restaurer une base de données de contenu (SharePoint Foundation 2010)
Voir aussi

Vous pouvez restaurer n'importe quelle base de données de contenu ou plusieurs bases de données de contenu à la fois. Pour plus d'informations sur la façon de sauvegarder en même temps toutes les bases de données contenues dans une batterie de serveurs, voir Sauvegarder une batterie de serveurs (SharePoint Foundation 2010).

Procédures de cette tâche :

  • Utiliser Windows PowerShell pour restaurer une base de données de contenu

  • Utiliser l'Administration centrale pour restaurer une base de données de contenu

  • Utiliser les outils SQL Server pour restaurer une base de données de contenu

Utiliser Windows PowerShell pour restaurer une base de données de contenu

Vous pouvez utiliser Windows PowerShell pour restaurer une base de données de contenu.

Pour restaurer une base de données de contenu à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez la commande suivante et appuyez sur la touche Entrée :

    Restore-SPFarm -Directory <Backup folder name> -RestoreMethod Overwrite -Item <Content database name> [-BackupId <GUID>] [-Verbose]

    Remarque :
    Si vous n'avez pas ouvert la session sous le compte de la batterie de serveurs, vous êtes invité à fournir les informations d'identification du compte de la batterie de serveurs.

    Si vous n'utilisez pas le paramètre BackupId, la sauvegarde la plus récente sera utilisée. Pour afficher la liste des sauvegardes, y compris leur ID de sauvegarde, tapez la commande suivante et appuyez sur Entrée :

    Get-SPBackupHistory -Directory <Backup folder>

Pour plus d'informations, voir Restore-SPFarm.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Utiliser l'Administration centrale pour restaurer une base de données de contenu

Vous pouvez utiliser l'Administration centrale pour restaurer une batterie de serveurs ou des composants d'une batterie de serveurs.

Pour restaurer une base de données de contenu à l'aide de l'Administration centrale

  1. Vérifiez que vous avez ouvert une session en tant que membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, à la section Sauvegarde et restauration, cliquez sur Restaurer à partir d'une sauvegarde.

  3. Dans la page Restauration à partir d'une sauvegarde - Étape 1 sur 3 : sélectionner la sauvegarde à restaurer, sélectionnez, dans la liste des sauvegardes, le travail de sauvegarde qui contient la sauvegarde de la base de données de contenu, puis cliquez sur Suivant.

    Remarque :
    Lorsque la tâche de sauvegarde correcte ne s'affiche pas, entrez le chemin d'accès du dossier de sauvegarde approprié dans la zone de texte Emplacement de sauvegarde actuel, puis cliquez sur Actualiser.

  4. Dans la page Restaurer à partir d'une sauvegarde - Étape 2 sur 3 : sélectionner le composant à restaurer, activez la case à cocher en regard de la base de données de contenu, puis cliquez sur Suivant.

    Remarque :
    Si la base de données de contenu n'est pas sélectionnable, vous devez utiliser Windows PowerShell ou les outils SQL Server pour restaurer la base de données de contenu.

  5. Sur la page Restaurer à partir de la sauvegarde : étape 3 sur 3 : sélectionner les options de restauration, dans la section Options de restauration, sous Type de restauration, cliquez sur l'option Configuration existante. Une boîte de dialogue apparaît, vous invitant à confirmer l'opération. Cliquez sur OK.

    Cliquez sur Lancer la restauration.

  6. Vous pouvez voir l'état général de tous les travaux de récupération en haut de la page État des opérations de sauvegarde et de restauration, dans la section Disponibilité. Vous pouvez voir l'état du travail de sauvegarde en cours dans la partie inférieure de la page, dans la section Restauration. La page de l'état est automatiquement actualisée toutes les 30 secondes. Vous pouvez mettre à jour manuellement les détails de l'état en cliquant sur Actualiser. La sauvegarde et la récupération sont des travaux du service Minuteur. Par conséquent, le démarrage de la récupération peut prendre plusieurs secondes.

    Si des messages d'erreur s'affichent, vous pouvez les traiter dans la colonne Message d'erreur de la page d'état des tâches de restauration et de sauvegarde. Vous trouverez également des détails supplémentaires dans le fichier Sprestore.log situé à l'emplacement indiqué à l'étape 3.

Utiliser les outils SQL Server pour restaurer une base de données de contenu

Vous pouvez utiliser les outils SQL Server pour restaurer une base de données de contenu en procédant comme suit :

  1. Dans la mesure du possible, sauvegardez le journal des transactions actif de la base de données de contenu pour protéger les modifications qui ont été apportées depuis la dernière sauvegarde complète.

  2. Restaurez la dernière sauvegarde complète de la base de données.

  3. Restaurez la sauvegarde de base de données différentielle la plus récente qui s'est produite après la sauvegarde de base de données complète la plus récente.

  4. Restaurez toutes les sauvegardes de journal des transactions qui se sont produites après la sauvegarde de base de données complète ou différentielle la plus récente.

Pour restaurer une base de données de contenu à l'aide des outils SQL Server

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du rôle de serveur fixe sysadmin.

  2. Si le service minuteur de Windows SharePoint Services est en cours d'exécution, arrêtez-le et patientez quelques minutes pour que les procédures stockées en cours d'exécution se terminent. Ne redémarrez pas le service tant que vous n'avez pas restauré les bases de données de contenu.

  3. Démarrez SQL Server Management Studio et connectez-vous au serveur de base de données.

  4. Dans l'Explorateur d'objets, développez Bases de données.

  5. Cliquez avec le bouton droit sur la base de données à restaurer, pointez sur Tâches, pointez sur Restaurer, puis cliquez sur Base de données.

    La base de données est automatiquement mise hors connexion pendant l'opération de récupération et n'est pas accessible par d'autres processus.

  6. Dans la boîte de dialogue Restaurer la base de données, spécifiez la destination et la source, puis sélectionnez le jeu ou les jeux de sauvegarde à restaurer.

    Les valeurs par défaut pour la destination et la source conviennent pour la plupart des scénarios de récupération.

  7. Dans le volet Sélectionner une page, cliquez sur Options.

  8. Dans la section Options de restauration, sélectionnez uniquement Remplacer la base de données existante. Ne sélectionnez aucune autre option de cette section si ce n'est pas nécessaire.

  9. Dans la section État de récupération :

    • Si vous avez inclus tous les journaux des transactions à restaurer, sélectionnez RECOVER WITH RECOVERY.

    • Si vous devez restaurer d'autres journaux des transactions, sélectionnez RECOVER WITH NORECOVERY.

    • La troisième option, RECOVER WITH STANDBY n'est pas utilisée dans ce scénario.

      Remarque :
      Pour plus d'informations sur ces options de récupération, voir Restaurer la base de données (page Options) (http://go.microsoft.com/fwlink/?linkid=114420&clcid=0x40C).

  10. Cliquez sur OK pour terminer l'opération de récupération.

  11. Répétez les étapes 4 à 10 pour chaque base de données à restaurer.

  12. Démarrer le service minuteur de Windows SharePoint Services

Voir aussi

Concepts

Sauvegarder une base de données de contenu (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Attacher et restaurer une base de données de contenu en lecture seule (SharePoint Foundation 2010)
Voir aussi

Une batterie de serveurs Microsoft SharePoint Foundation 2010 dans laquelle les bases de données de contenu ont été définies pour être en lecture seule peut faire partie d'un environnement de récupération de défaillance qui s'exécute sur des bases de données de contenu mises en miroir ou copiées dans un journal de transactions ou d'un environnement de gestion de correctifs ou de maintenance à haute disponibilité qui fournit l'accès utilisateur lorsqu'une autre version de la batterie est en cours de mise à jour. Lorsque vous rattachez les bases de données en lecture seule, elles deviennent accessibles en lecture-écriture.

Pour plus d'informations sur la façon d'utiliser des bases de données en lecture seule, consultez Faire fonctionner une batterie qui utilise des bases de données en lecture seule (SharePoint Foundation 2010).

Utiliser Windows PowerShell pour attacher et restaurer une base de données de contenu en lecture seule

Vous pouvez utiliser Windows PowerShell uniquement pour attacher et restaurer une base de données de contenu en lecture seule.

Pour attacher et restaurer une base de données de contenu en lecture seule à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Mount-SPContentDatabase -Name <Database name> -WebApplication <Web application ID> [-Verbose]

    Remarque :
    Attacher une base de données de contenu à l'aide de l'applet de commande Mount-SPContentDatabase diffère de l'attachement d'une base de données dans SQL Server à l'aide des outils SQL Server. Mount-SPContentDatabase associe la base de données de contenu à une application Web afin que son contenu puisse être lu.

Pour plus d\rquote informations, voir Mount-SPContentDatabase.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Récupération (SharePoint Foundation 2010)

Historique des modifications


Importer une liste ou une bibliothèque de documents (SharePoint Foundation 2010)
Voir aussi

Alors que vous pouvez utiliser Windows PowerShell ou l'administration centrale pour exporter un site, une liste ou une bibliothèque de documents, seul Windows PowerShell vous permet d'importer un site, une liste ou une bibliothèque de documents. Pour plus d'informations sur l'exportation de listes ou de bibliothèques, voir Exporter un site, une liste ou une bibliothèque de documents (SharePoint Foundation 2010).

Vous pouvez utiliser l'importation comme méthode de restauration des éléments, ou comme méthode de déplacement ou de copie des éléments d'une batterie à une autre. Vous pouvez importer un site, une liste ou une bibliothèque de documents à partir d'une sauvegarde de la batterie actuelle, à partir d'une sauvegarde d'une autre batterie ou à partir d'une base de données de contenu en lecture seule. Pour importer depuis une base de données de contenu en lecture seule, vous devez d'abord attacher la base de données en lecture seule. Pour plus d'informations, voir Attacher et restaurer une base de données de contenu en lecture seule (SharePoint Foundation 2010).

Important :
Vous ne pouvez pas importer de site, de liste ou de bibliothèque de documents exportée depuis une version de Microsoft SharePoint Foundation vers une autre version de SharePoint Foundation.

Importer un site, une liste ou une bibliothèque de documents

Vous pouvez utiliser Windows PowerShell pour importer un site, une liste ou une bibliothèque de documents manuellement ou dans le cadre d'un script exécutable à intervalles réguliers.

Pour importer un site, une liste ou une bibliothèque de documents à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Microsoft SharePoint 2010 Products.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Import-SPWeb -Identity <Site URL> -Path <Export file name> [-Force] [-NoFileCompression] [-Verbose]

    Important :
    Le site ou sous-site que vous importez doit disposer d'un modèle correspondant au modèle du site spécifié par Identity.

    Vous pouvez également utiliser l'applet de commande Get-SPWeb et transmettre l'ID à Import-SPWeb à l'aide de la barre verticale Windows PowerShell. La valeur du paramètre Path spécifie le chemin d'accès et le nom du fichier à partir duquel importer la liste ou la bibliothèque. Pour inclure les paramètres de sécurité utilisateur avec la liste ou la bibliothèque de documents, utilisez le paramètre IncludeUserSecurity. Pour remplacer la liste ou la bibliothèque que vous avez spécifiée, utilisez le paramètre Force. Vous pouvez utiliser le paramètre UpdateVersions pour spécifier la façon dont les conflits de versions doivent être gérés. Pour afficher la progression de l'opération, utilisez le paramètre Verbose.

    Le paramètre NoFileCompression vous permet de spécifier l'importation sans compression de fichier. L'utilisation de ce paramètre peut réduire l'usage des ressources de 30% au cours des opérations d'exportation et d'importation. Si vous importez un site, une liste ou une bibliothèque de documents que vous avez exportés depuis l'Administration centrale, ou si vous avez exporté un site, une liste ou une bibliothèque de documents à l'aide de Windows PowerShell sans utiliser le paramètre NoFileCompression dans l'applet de commande Export-SPWeb, vous ne pouvez pas utiliser ce paramètre dans l'applet de commande Import-SPWeb.

    Remarque :
    L'applet de commande Import-SPWeb ne dispose pas d'une option permettant d'importer un sous-ensemble du fichier d'exportation. Par conséquent, l'opération d'importation importe tout le contenu du fichier.

Pour plus d'informations, voir Import-SPWeb.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Exporter un site, une liste ou une bibliothèque de documents (SharePoint Foundation 2010)

Historique des modifications


Gestion des base de données (SharePoint Foundation 2010)
Voir aussi

Cette section décrit des techniques permettant de gérer les bases de données associées à Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Ajouter une base de données de contenu (SharePoint Foundation 2010)

    L'ajout d'une base de données de contenu à une application Web existante est une tâche courante. Cet article décrit comment ajouter une base de données de contenu à une implémentation existante de SharePoint Foundation 2010.

  • Attacher ou détacher des bases de données de contenu (SharePoint Foundation 2010)

    Certaines opérations, telles que l'application de mises à jour ou la création de copies des paramètres de configuration, vous obligent à détacher puis à attacher des bases de données. Cet article décrit comment effectuer ces procédures.

  • Déplacer des collections de sites entre des bases de données (SharePoint Foundation 2010)

    Dans certaines circonstances, vous pouvez être amené à déplacer une ou plusieurs collections de sites vers une autre base de données de contenu. Par exemple, une collection de sites peut devenir trop volumineuse pour la base de données de contenu sur laquelle elle réside, et vous devez la déplacer vers une base de données de contenu plus grande. À l'inverse, si les collections de sites n'atteignent pas la taille escomptée, vous pouvez, pour des raisons pratiques, combiner plusieurs collections de sites sur une même base de données de contenu. Cet article explique comment déplacer des collections de sites entre bases de données.

  • Déplacer des bases de données de contenu (SharePoint Foundation 2010).

    Cet article explique comment déplacer des bases de données de contenu parmi des serveurs qui exécutent Microsoft SQL Server, parmi des instances de SQL Server ou d'une application Web Microsoft SharePoint Foundation 2010 à une autre. Vous pouvez également déplacer une base de données de contenu afin d'équilibrer la charge d'un serveur de bases de données ou d'une application Web.

  • Renommer ou déplacer des bases de données d'applications de service (SharePoint Foundation 2010)

    Cet article explique comment renommer ou déplacer des bases de données d'application de service à l'aide de SQL Server, puis comment pointer l'application de service vers la base de données renommée ou déplacée. Ce processus peut être complexe car différents types d'applications de service requièrent différentes méthodes de pointage vers le nouveau nom ou nouvel emplacement de base de données. Cet article présente la méthode prise en charge pour pointer vers une base de données renommée ou déplacée pour chaque application de service.

  • Déplacer toutes les bases de données (SharePoint Foundation 2010)

    Cet article explique comment déplacer toutes les bases de données associées à SharePoint Foundation 2010 depuis un serveur de base de données vers un autre serveur de base de données. Si vos bases de données sont hébergées sur différents serveurs, cette procédure s'applique au serveur de base de données qui héberge la base de données de configuration.

  • Faire fonctionner une batterie qui utilise des bases de données en lecture seule (SharePoint Foundation 2010)

    Une batterie de serveurs en lecture seule peut faire partie d'un environnement de récupération d'urgence. Elle peut également faire partie d'un environnement de maintenance, de correction ou de mise à niveau à haute disponibilité qui fournit l'accès aux utilisateurs pendant la mise à jour d'une autre version de la batterie de serveurs. Cet article explique comment faire fonctionner une batterie de serveurs SharePoint Foundation 2010 dans laquelle les bases de données de contenu sont définies comme étant en lecture seule (batterie de serveurs en lecture seule).

  • Gérer le stockage à distance BLOB (SharePoint Foundation 2010)

    Le stockage étendu des objets BLOB (RBS, Remote BLOB Storage) est un module complémentaire pour Microsoft SQL Server 2008. RBS est conçu pour déplacer le stockage des objets BLOB depuis des serveurs de bases de données vers des solutions de stockage de produits. Si les bases de données de contenu de SharePoint Foundation 2010 sont de 4 gigaoctets (Go) ou plus, envisagez l'utilisation de RBS en tant que partie intégrante de votre solution de stockage de données. Cet article présente RBS.

Voir aussi

Concepts

Types et descriptions de base de données (SharePoint Foundation 2010)

Historique des modifications


Ajouter une base de données de contenu (SharePoint Foundation 2010)
Voir aussi

Vous pouvez utiliser les procédures décrites dans cet article pour créer une base de données de contenu et l'attacher à une application Web.

Dans cet article :

  • Pour ajouter une base de données de contenu à une application Web à l'aide de l'Administration centrale

  • Pour ajouter une base de données de contenu à une application Web à l'aide de Windows PowerShell

Pour ajouter une base de données de contenu à une application Web à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui est utilisé pour effectuer cette opération est membre du groupe SharePoint Administrateurs de batterie.Si vous utilisez l'authentification Windows pour vous connecter à SQL Server, le compte d'utilisateur doit aussi être membre du rôle de serveur fixe dbcreator de SQL Server sur l'instance de SQL Server où la base de données sera créée. Si vous utilisez l'authentification SQL pour vous connecter à SQL Server, le compte d'authentification SQL que vous spécifiez lorsque vous créez la base de données de contenu doit disposer de l'autorisation de dbcreator sur l'instance de SQL Server où la base de données sera créée.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la section Bases de données, cliquez sur Gérer les bases de données de contenu.

  4. Dans la page Gérer les bases de données de contenu, cliquez sur Ajouter une base de données de contenu.

  5. Dans la page Ajouter une base de données de contenu :

    1. Spécifiez une application Web pour la nouvelle base de données.

    2. Spécifiez un serveur de base de données destiné à héberger la nouvelle base de données.

    3. Spécifiez la méthode d'authentification que la nouvelle base de données utilisera et indiquez un nom de compte et un mot de passe, si ceux-ci sont nécessaires.

      Important :
      Le nom de compte et le mot de passe doivent déjà exister en tant que compte de connexion SQL Server.

    4. Spécifiez le nom du serveur de base de données de basculement, le cas échéant.

    5. Spécifiez le nombre de sites de niveau supérieur pouvant être créés avant qu'un avertissement ne soit émis. Par défaut, ce nombre est de 9 000.

    6. Spécifiez le nombre total de sites de niveau supérieur pouvant être créés dans la base de données. Par défaut, ce nombre est de 15 000.

    7. Cliquez sur OK.

Pour ajouter une base de données de contenu à une application Web à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.. Si vous utilisez l'authentification Windows pour vous connecter à SQL Server, le compte d'utilisateur doit aussi être membre du rôle de serveur fixe dbcreator de SQL Server sur l'instance de SQL Server où la base de données sera créée. Si vous utilisez l'authentification SQL pour vous connecter à SQL Server, le compte d'authentification SQL que vous spécifiez lorsque vous créez la base de données de contenu doit disposer de l'autorisation de dbcreator sur l'instance de SQL Server où la base de données sera créée.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commande Windows PowerShell, tapez la commande suivante :

    Code de copie
    New-SPContentDatabase -Name <ContentDbName> -WebApplication <WebApplicationName>

    Où <ContentDbName> est le nom de la base de données de contenu à créer et <WebApplicationName> est le nom de l'application Web à laquelle la nouvelle base de données est attachée.

    Pour plus d'informations, voir New-SPContentDatabase.
Remarque :
Pour attacher une base de données de contenu existante à une application Web, utilisez l'applet de commande Windows PowerShellMount-SPContentDatabase. Pour plus d'informations, voir Mount-SPContentDatabase.

Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Attacher ou détacher des bases de données de contenu (SharePoint Foundation 2010)
Déplacer des collections de sites entre des bases de données (SharePoint Foundation 2010)

Historique des modifications


Attacher ou détacher des bases de données de contenu (SharePoint Foundation 2010)
Voir aussi

Cet article décrit comment attacher ou détacher des bases de données de contenu Microsoft SharePoint Foundation 2010 à l'aide du site Web Administration centrale de SharePoint ou à l'aide de Windows PowerShell 2.0.

Vous pouvez choisir d'attacher ou de détacher des bases de données de contenu dans les situations suivantes :

  • Vous voulez ajouter une nouvelle base de données de contenu pour les nouvelles collections de sites afin de maintenir les bases de données de contenu à une taille gérable.

  • Vous avez restauré une base de données de contenu à partir d'une autre batterie et vous voulez que les sites qu'elle contient soient accessibles à partir d'une application Web.

  • Vous avez archivé des collections de sites et vous n'avez plus besoin d'autant de bases de données de contenu. Vous pouvez déplacer les collections de sites restantes hors d'une base de données de contenu, puis détacher la base de données de contenu de l'application Web. Pour plus d'informations, voir Déplacer des collections de sites entre des bases de données (SharePoint Foundation 2010).

Les étapes à suivre pour ajouter une base de données et pour attacher une base de données sont pratiquement identiques. Pour plus d'informations sur l'ajout d'une base de données, voir Ajouter une base de données de contenu (SharePoint Foundation 2010).

Pour attacher une base de données de contenu à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui est utilisé pour effectuer cette opération est membre du groupe SharePoint Administrateurs de la batterie.

    Si vous voulez créer une nouvelle base de données de contenu en même temps que vous l'attachez, le compte de service de la batterie SharePoint doit être membre du rôle serveur fixe dbcreator SQL Server. Pour attacher une base de données de contenu à une application Web, le compte de service de la batterie SharePoint doit disposer de l'autorisation db_owner sur la base de données de contenu.

    Conseil :
    Si la base de données existe déjà, sa version doit être identique à celle de la batterie Produits Microsoft SharePoint 2010 ; sinon, l'opération échoue. Pour attacher une base de données de contenu dont la version est différente de celle de la batterie, utilisez la commande Windows PowerShell 2.0 dans la section suivante.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Bases de données, cliquez sur Gérer les bases de données de contenu.

  4. Dans la page Gérer les bases de données de contenu, cliquez sur Ajouter une base de données de contenu.

  5. Dans la page Ajouter une base de données de contenu :

    1. Utilisez le menu déroulant Application Web pour sélectionner l'application Web à laquelle vous voulez attacher une base de données de contenu.

    2. Spécifiez le serveur de bases de données qui héberge la base de données.

    3. Spécifiez le nom de la base de données. Si la base de données n'existe pas, elle est créée.

    4. Spécifiez la méthode d'authentification pour la base de données, et indiquez un nom de compte et un mot de passe si vous utilisez l'authentification SQL.

      Important :
      Le nom de compte et le mot de passe doivent déjà exister en tant que compte de connexion SQL Server. Nous vous recommandons d'utiliser l'authentification Windows à la place de l'authentification SQL, cette dernière envoyant par défaut un mot de passe non chiffré à l'ordinateur SQL Server. Si vous utilisez l'authentification SQL, le compte SQL requiert les mêmes autorisations SQL que le compte de service de la batterie SharePoint.

    5. Cliquez sur OK.

Pour détacher une base de données de contenu à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, à la section Bases de données, cliquez sur Gérer les bases de données de contenu.

  4. Sélectionnez l'application Web dont vous voulez détacher une base de données de contenu.

  5. Cliquez sur la base de données de contenu que vous voulez détacher.

  6. Dans la page Gérer les paramètres de la base de données de contenu, activez la case à cocher Supprimer la base de données de contenu.

    Si la base de données de contenu contient des données, un avertissement s'affiche. Cliquez sur OK pour continuer l'opération.

  7. Cliquez sur OK pour confirmer le détachement ou sur Annuler pour arrêter l'opération sans détacher la base de données.

    Lorsque vous détachez une base de données de contenu dans l'Administration centrale, la base de données de contenu existe toujours dans SQL Server. Pour supprimer définitivement la base de données de contenu, vous devez exécuter une procédure SQL Server.

Pour attacher ou détacher une base de données de contenu à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin. Le compte d'utilisateur doit également être membre du rôle serveur fixe dbcreatorSQL Server sur l'instance SQL Server où la base de données de contenu réside.

  2. Si vous utilisez l'applet de commande Remove-SPContentDatabase pour supprimer la base de données de contenu de SQL Server en même temps que vous la détachez, vous devez aussi être membre du rôle SharePoint_Shell_Access sur la base de données de contenu.

  3. Dans le menu Démarrer, cliquez sur Tous les programmes.

  4. Cliquez sur Produits Microsoft SharePoint 2010.

  5. Cliquez sur SharePoint 2010 Management Shell.

  6. À l'invite de commandes de Windows PowerShell, tapez la commande appropriée :

    • Pour attacher une base de données de contenu existante :

      Code de copie
      Mount-SPContentDatabase "<ContentDb>" -DatabaseServer "<DbServer>" -WebApplication http://SiteName
      Où :

      • <ContentDb> est la base de données de contenu à attacher.

      • <DbServer> est le nom du serveur de bases de données.

      • http://SiteName est le nom de l'application Web à laquelle la base de données de contenu est attachée.

    • Pour détacher une base de données de contenu :

    Code de copie
    Dismount-SPContentDatabase "<ContentdBName>"

    Où <ContentdBName> est le nom de la base de données de contenu.

    Important :
    Si plusieurs bases de données de contenu ont le même nom, vous devez utiliser le GUID de la base de données de contenu dans cette commande au lieu du nom de la base de données de contenu. Pour récupérer le GUID de la base de données de contenu, exécutez l'applet de commande Get-SPContentDatabase sans arguments.

    L'applet de commande Dismount-SPContentDatabase détache la base de données de contenu de l'application Web, mais elle ne supprime pas la base de données de contenu de SQL Server. Une fois qu'une base de données de contenu est détachée, vous ne pouvez pas la supprimer à l'aide de Windows PowerShell 2.0. Vous pouvez uniquement la supprimer à l'aide des outils SQL Server. Si vous voulez supprimer la base de données de contenu SQL Server en même temps que vous la détachez, utilisez l'applet de commande Remove-SPContentDatabase à la place.

Pour plus d'informations, voir Mount-SPContentDatabase et Dismount-SPContentDatabase.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Référence

Get-SPContentDatabase
New-SPContentDatabase
Remove-SPContentDatabase

Historique des modifications


Déplacer des collections de sites entre des bases de données (SharePoint Foundation 2010)
Voir aussi

Dans certaines circonstances, vous pouvez déplacer une ou plusieurs collections de sites vers une autre base de données de contenu. Par exemple, une collection de sites peut atteindre une taille trop importante pour la base de données de contenu qui l'héberge et vous devez la déplacer vers une base de données de contenu plus grande. Dans Windows SharePoint Services 3.0, ce processus était également appelé fractionnement d'une base de données de contenu, en raison du nom de la commande Stsadm qui était utilisée pour la réalisation de la procédure. Dans Microsoft SharePoint Foundation 2010, cette procédure s'apparente davantage au déplacement de la collection de sites vers une base de données plus grande.

D'un autre côté, si les collections de sites n'atteignent pas leur taille escomptée, vous pouvez, pour des raisons pratiques, combiner plusieurs collections de sites sur une même base de données de contenu. Dans Windows SharePoint Services 3.0, ce processus était également appelé fusion de bases de données de contenu. Pendant ce processus, aucune base de données de contenu n'est en fait fusionnée : les collections de sites sont déplacées vers une nouvelle base de données et consolidées sur celle-ci.

Cet article explique comment préparer des collections de sites et les déplacer entre des bases de données de contenu.

Vous pouvez déplacer des collections de sites entre des bases de données de contenu à l'aide de l'outil en ligne de commande Stsadm ou des commandes Windows PowerShell 2.0. Il n'existe pas d'interface utilisateur graphique pour cette tâche.

Conseil :
Vous pouvez également déplacer des collections de sites à l'aide des procédures de sauvegarde et de restauration. Pour plus d'informations sur ces procédures, voir Sauvegarder une collection de sites (SharePoint Foundation 2010) et Restaurer une collection de sites (SharePoint Foundation 2010).

Pour effectuer les procédures décrites dans cet article, vérifiez que le compte d'utilisateur a accès à l'un des serveurs sur lesquels Windows PowerShell 2.0 est en cours d'exécution et qu'il est membre des groupes suivants :

  • le rôle de base de données fixe db_owner et le rôle SharePoint_Shell_Access dans la base de données de contenu source SQL Server, la base de données de contenu d'administration, la base de données de contenu de destination et la base de données de configuration ;

  • le groupe WSS_ADMIN_WPG sur l'ordinateur local.

Ces procédures ne fonctionnent que si les conditions suivantes sont vraies :

  • La base de données de contenu de destination doit déjà exister.

  • La base de données de contenu source et la base de données de contenu de destination doivent se trouver sur la même instance de SQL Server.

  • La base de données de contenu source et la base de données de contenu de destination doivent être attachées à la même application Web. Pour plus d'informations sur l'ajout d'une base de données de contenu à une application Web, voir Ajouter une base de données de contenu (SharePoint Foundation 2010).

Dans cet article :

  • Détermination de la taille de la collection de sites source

  • Déplacement des collections de sites entre les bases de données de contenu

Détermination de la taille de la collection de sites source

Quel que soit le motif du déplacement d'une collection de sites, vous devez toujours commencer par déterminer la taille de la collection de sites à déplacer. Cette opération vous permet de vous assurer que la capacité du disque dur de destination sera suffisante pour héberger le contenu de la collection de sites. Vérifiez que l'espace disponible sur le disque dur de destination est au moins égal à trois fois l'espace requis pour la collection de sites.

Conseil :
Vous pouvez vous tenir régulièrement informé de l'espace utilisé par les collections de sites en créant des quotas de site et des alertes par courrier électronique.

Pour déterminer la taille de la collection de sites

  1. Dans le menu Démarrer, cliquez sur Tous les programmes.

  2. Cliquez sur Produits SharePoint 2010.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commande Windows PowerShell 2.0, tapez les commandes suivantes :

    Code de copie
    $used = (Get-SPSiteAdministration -Identity <http://ServerName/Sites/SiteName>).DiskUsed
    Code de copie
    $used

    Où <http://ServerName/Sites/SiteName> est le nom de la collection de sites. La quantité d'espace disque en cours d'utilisation par la collection de sites identifiée est stockée dans la variable $used et apparaît à l'invite de commandes lors de l'exécution de la seconde commande.

Pour plus d'informations, voir Get-SPSiteAdministration.

Déplacement des collections de sites entre les bases de données de contenu

Vous pouvez utiliser la commande Windows PowerShellMove-SPSite pour déplacer des collections de sites entre des bases de données de contenu. Deux procédures sont fournies ici. La première procédure déplace une collection de sites spécifique vers une nouvelle base de données de contenu, tandis que la seconde procédure déplace plusieurs collections de sites vers une nouvelle base de données de contenu.

Pour déplacer une collection de sites spécifique

  • À l'invite de commande Windows PowerShell, tapez la commande suivante :

    Code de copie
    Move-SPSite <http://ServerName/Sites/SiteName> -DestinationDatabase <DestinationContentDb>

    Où <http://ServerName/Sites/SiteName> est le nom de la collection de sites et <DestinationContentDb> est le nom de la base de données de contenu de destination.

Pour déplacer plusieurs collections de sites

  • À l'invite de commande Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPSite -ContentDatabase <SourceContentDb> | Move-SPSite -DestinationDatabase <DestinationContentDb>

    Où <SourceContentDb> est le nom de la base de données de contenu d'origine et <DestinationContentDb> est le nom de la base de données de contenu de destination. Cette commande déplace toutes les collections de sites depuis la base de données de contenu source vers la base de données de contenu de destination.

Pour plus d'informations, voir Move-SPSite.
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Ajouter une base de données de contenu (SharePoint Foundation 2010)

Historique des modifications


Déplacer des bases de données de contenu (SharePoint Foundation 2010)

Cet article explique comment déplacer des bases de données de contenu parmi des serveurs qui exécutent Microsoft SQL Server, parmi des instances de SQL Server ou d'une application Web Microsoft SharePoint Foundation 2010 à une autre. Vous pouvez déplacer une base de données de contenu afin d'équilibrer la charge d'un serveur de bases de données ou d'une application Web.

Important :
Cet article explique uniquement comment déplacer des bases de données de contenu. Pour plus d'informations sur la façon de déplacer d'autres types de bases de données associés à SharePoint Foundation 2010, voir Déplacer toutes les bases de données (SharePoint Foundation 2010).

Vue d'ensemble du déplacement de bases de données de contenu

Lorsque vous déplacez des bases de données de contenu, vous devez utiliser à la fois les outils SharePoint Foundation 2010 et les outils SQL Server. Vous pouvez utiliser soit le site Web Administration centrale de SharePoint Foundation, soit Windows PowerShell 2.0. La liste suivante récapitule comment déplacer des bases de données de contenu :

  • Prenez note du nom de la base de données de contenu et de l'application Web à laquelle elle est associée. Pour plus d'informations, voir Pour prendre note des associations entre les différentes bases de données de contenu et les différentes applications Web.

  • Suspendez tous les services et applications de service susceptibles de tenter de s'exécuter contre la base de données, y compris les travaux du minuteur et les analyses de recherche. Pour plus d'informations, voir Pour suspendre des travaux du minuteur à l'aide de Windows PowerShell (option 1) ou Pour suspendre des travaux du minuteur à l'aide de l'Administration centrale (option 2).

  • Dans SharePoint Foundation, supprimez la base de données de contenu de l'application Web. Cette action peut être effectuée à l'aide de l'Administration centrale ou de Windows PowerShell 2.0. En général, si vous travaillez uniquement avec plusieurs bases de données, il peut être plus rapide de rédiger un script Windows PowerShell 2.0. Pour plus d'informations, voir Pour détacher les bases de données de contenu d'une application Web à l'aide de l'Administration centrale (option 1) ou Pour détacher des bases de données de contenu d'une application Web à l'aide de Windows PowerShell (option 2).

  • Dans SQL Server, détachez la base de données de l'instance actuelle. Pour plus d'informations, voir Pour détacher les bases de données de contenu de SQL Server.

  • À l'aide de l'Explorateur Windows, copiez ou déplacez les fichiers .mdf, .ndf et .ldf associés à la base de données depuis l'emplacement source vers l'emplacement de destination. Pour plus d'informations, voir Pour déplacer les bases de données de contenu vers un nouvel emplacement.

    Remarque :
    Vous pouvez également sauvegarder et restaurer des bases de données afin de les déplacer, mais les procédures de sauvegarde et de restauration ne sont pas décrites dans cet article. Pour plus d'informations, voir Sauvegarde et récupération (SharePoint Foundation 2010).

  • Dans SQL Server, attachez la base de données à la nouvelle instance. Pour plus d'informations, voir Pour attacher les bases de données de contenu à la nouvelle instance de SQL Server.

  • Dans SharePoint Foundation, ajoutez la base de données de contenu à l'application Web de destination. Assurez-vous d'utiliser exactement le même nom lorsque vous rattachez la base de données de contenu, sinon SharePoint Foundation crée une nouvelle base de données de contenu. Vous pouvez utiliser l'Administration centrale ou Windows PowerShell 2.0 pour effectuer cette action. Pour plus d'informations, voir Pour attacher les bases de données de contenu à l'application Web à l'aide de l'Administration centrale (option 1) ou Pour attacher des bases de données de contenu à une application Web à l'aide de Windows PowerShell (option 2).

  • Redémarrez tous les services et applications de service qui doivent s'exécuter contre la base de données, y compris les travaux du minuteur et les analyses de recherche. Pour plus d'informations, voir Pour redémarrer des travaux du minuteur à l'aide de Windows PowerShell (option 1) ou Pour redémarrer des travaux du minuteur à l'aide de l'Administration centrale (option 2).

Déplacement de bases de données de contenu

Remarque :
L'appartenance au groupe Administrateurs local sur les ordinateurs locaux est obligatoire pour effectuer les procédures suivantes. Si vous exécutez SharePoint Foundation 2010 dans un environnement à moindres privilèges et que vous effectuez des procédures depuis l'Administration centrale, vous devez vous assurer de disposer des rôles suivants dans SQL Server :

  • Le rôle de base de données fixe dbowner pour la base de données de configuration et la base de données de contenu sur le serveur source, afin de détacher la base de données de contenu.

  • Les rôles de serveur fixes dbcreator et securityadmin sur le serveur de destination, afin d'attacher la base de données et de configurer des connexions SQL Server.

Remarque :
Si vous déplacez une base de données de contenu vers une autre batterie, vous devez faire du compte de batterie de serveurs un membre du groupe Administrateurs sur le serveur de bases de données durant le processus de restauration. Cela permet au compte de répliquer le paramètre de sécurité pour les bases de données. Ce niveau d'accès peut être supprimé une fois la base de données de contenu déplacée.

La batterie de destination doit être au même niveau de version SharePoint Foundation 2010 (ou à un niveau de version supérieur) que la batterie source.

Pour prendre note des associations entre les différentes bases de données de contenu et les différentes applications Web

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPContentDatabase -WebApplication <http://sitename>

    Où <http://sitename > représente l'URL de l'application Web.

  6. Répétez l'opération pour chaque application Web.

Pour plus d'informations, voir Get-SPContentDatabase.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour suspendre des travaux du minuteur à l'aide de Windows PowerShell (option 1)

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPTimerJob -webapplication <http://WebApplicationURL> | select name | Out-File <c:\timerjobfile.txt> -Append -Encoding ascii

ForEach($tmrjob in (Get-Content <c:\timerjobfile.txt>)) { Get-SPTimerJob -Identity $tmrjob | Disable-SPTimerjob }

    Où :

    • <http://WebApplicationURL> est l'application Web associée à la base de données de contenu que vous déplacez.

    • <c:\timerjobfile.txt> est l'emplacement du fichier que vous créez qui répertorie tous les travaux du minuteur associés à l'application Web.

Pour plus d'informations, voir Get-SPTimerJob, Out-File, ForEach-Object, Get-Content et Disable-SPTimerJob.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour suspendre des travaux du minuteur à l'aide de l'Administration centrale (option 2)

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe Administrateurs de batterie SharePoint.

  2. Dans l'Administration centrale, dans la section Analyse, cliquez sur Vérifier l'état du travail.

  3. Pour chaque travail planifié qui s'exécute contre la base de données de contenu que vous déplacez, cliquez sur le travail pour ouvrir la page Modifier le travail du minuteur, cliquez sur Désactiver, puis sur OK.

Pour détacher les bases de données de contenu d'une application Web à l'aide de l'Administration centrale (option 1)

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe Administrateurs de batterie SharePoint.

  2. Dans l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les bases de données de contenu.

  3. Dans la page Gérer les bases de données de contenu, cliquez sur la base de données de contenu que vous souhaitez déplacer.

    La page Gérer les paramètres de la base de données de contenu apparaît.

    Remarque :
    Si la base de données de contenu n'est pas répertoriée dans la liste, il se peut qu'elle soit associée à une autre application Web. Pour sélectionner une autre application Web, dans le menu Application Web, cliquez sur Modifier l'application Web.

  4. Dans la page Gérer les paramètres de la base de données de contenu, dans la section Supprimer la base de données de contenu, activez la case à cocher Supprimer la base de données de contenu, puis cliquez sur OK.

    Remarque :
    La suppression de la base de données de contenu n'entraîne pas la suppression de la base de données ; cela ne fait que supprimer l'association de la base de données avec l'application Web.

  5. Répétez les étapes 3 et 4 pour chaque base de données de contenu à déplacer.

Pour détacher des bases de données de contenu d'une application Web à l'aide de Windows PowerShell (option 2)

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Dismount-SPContentDatabase "<ContentDB>"

    Où <ContentDB> est le nom de la base de données de contenu.

    Remarque :
    Si plusieurs bases de données de contenu portent le même nom, vous devez utiliser dans cette commande le GUID de la base de données de contenu au lieu de son nom. Pour récupérer le GUID de la base de données de contenu, exécutez l'applet de commande Get-SPContentDatabase sans argument.

Pour plus d'informations, voir Dismount-SPContentDatabase et Get-SPContentDatabase.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour détacher les bases de données de contenu de SQL Server

  1. Dans SQL Server Management Studio, ouvrez l'instance de SQL Server source, puis développez le nœud Bases de données.

  2. Cliquez avec le bouton droit sur la base de données de contenu, pointez sur Tâches, puis cliquez sur Détacher. Répétez cette étape pour chaque base de données de contenu que vous souhaitez déplacer.

    Remarque :
    Appliquez cette procédure pour déplacer uniquement des bases de données de contenu. Ne détachez aucun autre type de base de données.

Pour déplacer les bases de données de contenu vers un nouvel emplacement

  1. À l'aide de l'Explorateur Windows, recherchez les fichiers .mdf, .ldf et .ndf des bases de données de contenu.

  2. Sélectionnez les fichiers .mdf, .ldf et .ndf de la base de données que vous souhaitez déplacer et copiez ou déplacez-les vers le répertoire de destination.

Pour attacher les bases de données de contenu à la nouvelle instance de SQL Server

  1. Dans Management Studio, ouvrez l'instance de SQL Server de destination.

  2. Cliquez avec le bouton droit sur le nœud Bases de données, pointez sur Tâches, puis cliquez sur Attacher.

  3. Dans la boîte de dialogue Attacher la base de données, naviguez jusqu'à l'emplacement où vous avez transféré les fichiers .mdf, .ldf et .ndf, sélectionnez le fichier .mdf de la base de données à attacher, puis cliquez sur OK.

  4. Répétez l'opération pour chaque base de données de contenu que vous déplacez.

Pour attacher les bases de données de contenu à l'application Web à l'aide de l'Administration centrale (option 1)

  1. Dans l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les bases de données de contenu.

  2. Dans la page Gérer les bases de données de contenu, cliquez sur Ajouter une base de données de contenu.

  3. Dans la page Ajouter une base de données de contenu, vérifiez que le menu Application Web affiche l'application Web correcte.

  4. Dans la zone Serveur, spécifiez le serveur de bases de données qui héberge la base de données.

  5. Dans la zone Nom de la base de données, tapez le nom exact de la base de données de contenu transféré.

    Remarque :
    Vérifiez que le nom est correct, car si ce n'est pas le cas une nouvelle base de données sera créée.

  6. Spécifiez le mode d'authentification pour la base de données, puis cliquez sur OK.

  7. Répétez ces étapes pour chaque base de données que vous ajoutez. Assurez-vous de sélectionner l'application Web correcte dans le menu Application Web pour chaque base de données.

Pour attacher des bases de données de contenu à une application Web à l'aide de Windows PowerShell (option 2)

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Mount-SPContentDatabase "<ContentDB>" -DatabaseServer "<DBServer>" -WebApplication <http://sitename>

    Où :

    • <ContentDB> est la base de données de contenu à attacher ;

    • <DBServer> est le nom du serveur de bases de données ;

    • <http://sitename> est l'URL de l'application Web à laquelle la base de données de contenu est attachée.

For more information, see Mount-SPContentDatabase.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour redémarrer des travaux du minuteur à l'aide de Windows PowerShell (option 1)

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    ForEach($tmrjob in (Get-Content <c:\timerjobfile.txt>)) {Get-SPTimerJob -Identity $tmrjob | Enable-SPTimerjob}

    Où :

    • <c:\timerjobfile.txt> est l'emplacement du fichier que vous avez créé qui répertorie tous les travaux du minuteur associés à l'application Web.

Pour plus d'informations, voir Get-SPTimerJob, ForEach-Object, Get-Content et Enable-SPTimerJob.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour redémarrer des travaux du minuteur à l'aide de l'Administration centrale (option 2)

  1. Dans l'Administration centrale, dans la section Analyse, cliquez sur Vérifier l'état du travail.

  2. Pour chaque travail planifié que vous avez précédemment désactivé, cliquez sur le travail pour ouvrir la page Modifier le travail du minuteur, cliquez sur Activer, puis sur OK.

Historique des modifications

Date | Description | Raison
15 juillet 2010 | Publication initiale |


Renommer ou déplacer des bases de données d'applications de service (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment renommer ou déplacer des bases de données d'application de service Microsoft SharePoint Foundation 2010. On attribue en général un nouveau nom à une base de données d'application de service afin de supprimer le GUID du nom de la base de données après que celle-ci a été créée par l'Assistant Configuration des produits SharePoint ou afin d'aligner la base de données avec les conventions d'affectation de noms en vigueur au sein de votre organisation. Le déplacement de bases de données d'application de service peut s'effectuer afin d'équilibrer la charge sur un système.

Le processus général de changement de nom ou de déplacement d'une base de données d'application de service est le suivant :

  1. Renommer ou déplacer la base de données à l'aide d'outils SQL Server.

  2. Pointer l'application de service vers la base de données renommée ou déplacée.

    Pointer une application de service vers une base de données d'application de service renommée ou déplacée peut être un processus complexe, en particulier si vous devez renommer ou déplacer les bases de données de plusieurs applications de service. Ceci est dû au fait que différents types d'applications de service requièrent différentes méthodes de pointage vers le nouveau nom ou nouvel emplacement de base de données. En fonction de la base de données d'application de service que vous renommez ou déplacez, vous utiliserez l'une des méthodes suivantes pour pointer l'application de service vers la base de données renommée ou déplacée :

    • Supprimer l'application de service, recréer l'application de service, puis pointer l'application de service vers la base de données déplacée ou renommée existante.

      Vous pouvez appliquer cette méthode pour la plupart des bases de données d'application de service, mais elle peut être complexe pour certaines applications de service, telles que Recherche.

    • Utiliser Windows PowerShell pour pointer l'application de service vers la base de données modifiée déplacée ou renommée.

      Vous pouvez également utiliser l'Administration centrale pour un sous-ensemble des bases de données d'application de service pour lesquelles vous pouvez utiliser Windows PowerShell pour le pointage. Dans la mesure du possible, nous vous recommandons d'utiliser l'Administration centrale pour renommer ou déplacer des bases de données, car il s'agit du moyen le plus simple d'effectuer cette opération. Windows PowerShell est disponible uniquement pour certaines bases de données d'application de service et l'Administration est disponible pour un sous-ensemble de ces applications de service.

Le tableau suivant répertorie les méthodes disponibles pour pointer chaque application de service vers une base de données renommée ou déplacée.

Méthodes disponibles pour pointer vers des bases de données d'application de service renommées ou déplacées.

Application de service ou base de données | Supprimer puis recréer l'application de service | Utiliser Windows PowerShell | Utiliser l'Administration centrale
Collecte de données relatives à l'état et à l'utilisation | Possible | Possible | Préférée
Business Data Connectivity | Préférée | Non disponible | Non disponible1
Registre d'application2 | Non disponible | Non disponible | Non disponible
Paramètres d'abonnement | Possible | Préférée | Non disponible

1Il peut sembler possible de renommer la base de données Business Data Connectivity dans l'Administration centrale ou à l'aide de l'applet de commande Set-SPBusinessDataCatalogServiceApplication de Windows PowerShell. Toutefois, l'utilisation de l'Administration centrale ou de Set-SPBusinessDataCatalogServiceApplication crée une base de données. Cela ne renomme pas la base de données existante.

2Étant donné qu'il n'existe aucune applet de commande Windows PowerShell pour créer l'application de service Registre d'application, elle ne peut pas être renommée. Elle peut être déplacée à l'aide du processus de sauvegarde et récupération Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Attribution d'un nouveau nom ou déplacement de bases de données d'application de service à l'aide de SQL Server

    Cette méthode comprend les procédures suivantes :

    • Pour arrêter une application de service

    • Pour renommer une base de données à l'aide de SQL Server Management Studio

    • Déplacer une base de données à l'aide de SQL Server Management Studio et de l'Explorateur Windows

  • Méthode général pour pointer une application de service vers une base de données renommée ou déplacée

    Cette méthode comprend les procédures suivantes :

    • Pour documenter des paramètres d'application de service

    • Pour supprimer une application de service

    • Pour recréer une application de service

    • Pour redémarrer une application de service

    Remarque :
    Cette méthode ne s'applique pas à toutes les bases de données d'application de service. Pour déterminer la méthode à appliquer, voir les instructions spécifiques à l'application de service.

  • Instructions d'attribution de nouveau nom ou de déplacement de bases de données spécifiques aux applications de service

    • Pointage de l'application de service Collecte de données relatives à l'état et à l'utilisation vers une base de données renommée ou déplacée

    • Pointage de l'application de service Business Data Connectivity vers une base de données renommée ou déplacée

    • Pointage de l'application de service Registre d'application vers une base de données renommée ou déplacée

    • Pointage de l'application de service Paramètres d'abonnement vers une base de données renommée ou déplacée

Attribution d'un nouveau nom ou déplacement de bases de données d'application de service à l'aide de SQL Server

Pour renommer une base de données d'application de service, vous devez utiliser SQL Server. Pour déplacer une base de données d'application de service, vous devez utiliser SQL Server et l'Explorateur Windows. Nous vous recommandons d'arrêter les services associés à l'application de service avant de renommer ou de déplacer la base de données associée. Il est supposé que vous renommerez ou déplacerez une base de données, mais que vous n'effectuerez pas ces deux opérations simultanément.

Les instructions fournis dans cet article supposent que vous avez installé SQL Server Management Studio sur le serveur de bases de données. Si ce n'est pas le cas, vous pouvez télécharger et installer Management Studio à l'adresse Microsoft SQL Server 2008 Management Studio Express (http://go.microsoft.com/fwlink/?linkid=186132&clcid=0x40C).

Important :
Sur les serveurs de bases de données sur lesquels les opérations sont effectuées, vous devez être membre :

  • du groupe Administrateurs sur le serveur local ;

  • du rôle fixe de base de données db_owner.

Dans certains environnements, vous devez coordonner les procédures de déplacement et d'attribution de nouveau nom avec l'administrateur des bases de données. Respectez bien les stratégies et les directives en vigueur pour la gestion des bases de données.

Pour arrêter une application de service

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe Administrateurs de batterie SharePoint.

  2. Pour chaque application de service pour laquelle vous prévoyez de modifier la base de données, vous devez arrêter le service ou désactiver l'application de service en appliquant la procédure appropriée à l'application de service avec laquelle vous travaillez. Pour plus d'informations, voir Gérer les applications de service (SharePoint Foundation 2010) .

Pour renommer une base de données à l'aide de SQL Server Management Studio

  1. Dans SQL Server Management Studio, connectez-vous à l'instance de SQL Server source, puis développez le nœud Bases de données.

  2. Cliquez avec le bouton droit sur la base de données à renommer, cliquez sur Renommer, puis tapez un nouveau nom. Répétez cette étape pour chaque base de données que vous souhaitez renommer.

Déplacer une base de données à l'aide de SQL Server Management Studio et de l'Explorateur Windows

Pour déplacer une base de données, vous devez la détacher de SQL Server, déplacer les fichiers vers le nouvel emplacement à l'aide de l'Explorateur Windows, puis attacher la base de données à la nouvelle instance de SQL Server.

Pour détacher une base de données de SQL Server

  1. Dans SQL Server Management Studio, ouvrez l'instance de SQL Server source, puis développez le nœud Bases de données.

  2. Cliquez avec le bouton droit sur la base de données, pointez sur Tâches, puis cliquez sur Détacher. Répétez cette étape pour chaque base de données à déplacer.

Pour déplacer des fichiers de base de données vers un nouvel emplacement à l'aide de l'Explorateur Windows

  1. Dans l'Explorateur Windows, recherchez les fichiers .mdf, .ndf et .ldf des bases de données d'application de service.

  2. Sélectionnez les fichiers .mdf, .ndf et .ldf des bases de données que vous souhaitez déplacer, puis copiez-les ou déplacez-les vers le répertoire de destination.

Pour attacher une base de données à une nouvelle instance de SQL Server

  1. Dans Management Studio, ouvrez l'instance de SQL Server de destination.

  2. Cliquez avec le bouton droit sur le nœud Bases de données, pointez sur Tâches, puis cliquez sur Attacher.

  3. Dans la boîte de dialogue Attacher la base de données, naviguez jusqu'à l'emplacement où vous avez transféré les fichiers .mdf, .ndf et .ldf, sélectionnez le fichier .mdf de la base de données à attacher, puis cliquez sur OK.

  4. Répétez l'opération pour chaque base de données que vous déplacez.

Méthode général pour pointer une application de service vers une base de données renommée ou déplacée

La méthode de pointage d'une application de service vers une base de données renommée ou déplacée qui fonctionne avec la plupart des applications de service consiste à supprimer l'application de service puis à la recréer. Lors de la recréation de l'application de service, utilisez le nouveau nom ou le nouvel emplacement.

Il s'agit de la seule méthode permettant de pointer vers des bases de données déplacées ou renommées pour l'application de service Business Data Connectivity.

Cette méthode comprend les étapes suivantes :

  1. Pour documenter des paramètres d'application de service

  2. Pour supprimer une application de service

  3. Pour recréer une application de service

  4. Pour redémarrer une application de service

Pour documenter des paramètres d'application de service

  • Avant de supprimer ou de recréer une application de service, documentez ses paramètres. Pour cela, utilisez les applets de commande Windows PowerShell recommandées décrites dans l'article Documenter les paramètres de configuration de batteries (SharePoint Foundation 2010) .

Pour supprimer une application de service

  • Pour supprimer une application de service, appliquez la procédure fournie dans Supprimer une application de service (SharePoint Foundation 2010), mais ne supprimez pas la base de données d'application de service.

Pour recréer une application de service

  • Recréez l'application de service en la faisant pointer vers la base de données renommée et en réutilisant tous les autres paramètres de configuration initiaux. Pour plus d'informations, voir les articles suivants :

    • Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010)

    • Activation de la prise en charge multiclient dans SharePoint 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=197114&clcid=0x40C)

    • Administration du service Connexion de données métiers (SharePoint Foundation 2010)

  • Selon l'application de service, il se peut que vous deviez démarrer manuellement le service associé.

Pour redémarrer une application de service

  1. Dans l'Administration centrale, sous Paramètres système, cliquez sur Gérer les services sur le serveur.

  2. Dans la liste Service, en regard des services qui prennent en charge l'application de service que vous redémarrez, cliquez sur Démarrer.

Instructions d'attribution de nouveau nom ou de déplacement de bases de données spécifiques aux applications de service

Cette section fournit des instructions spécifiques à chaque type d'application de service.

Pointage de l'application de service Collecte de données relatives à l'état et à l'utilisation vers une base de données renommée ou déplacée

Vous pouvez utiliser l'Administration centrale ou Windows PowerShell pour pointer l'application de service de collecte de données relatives à l'état et à l'utilisation vers une base de données renommée ou déplacée.

Pour pointer l'application de service de collecte de données relatives à l'état et à l'utilisation vers une base de données renommée ou déplacée à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue la procédure est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans l'Administration centrale, cliquez sur Analyse puis, dans la page Analyse, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

    La page Configurer Web Analytics et la collection des données d'intégrité s'affiche.

  3. Désactivez la case à cocher Activer la collecte des données d'intégrité, puis cliquez sur OK.

    Vous revenez à la page Analyse.

  4. Cliquez sur Configurer la collection des données d'utilisation et d'intégrité pour revenir à la page Configurer Web Analytics et la collection des données d'intégrité.

  5. Activez la case à cocher Activer la collecte des données d'intégrité.

  6. Dans la section Journalisation - Serveur de bases de données, spécifiez le nom de base de données et le serveur de bases de données mis à jour, puis cliquez sur OK.

Pour pointer l'application de service de collecte de données relatives à l'état et à l'utilisation vers une base de données renommée ou déplacée à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPUsageApplication -Identity "<ServiceApplicationName>" -DatabaseName "<DbName>" -DatabaseServer "<SQLServerName>"

    Où :

    • <ServiceApplicationName> est le nom de l'application de service de collecte de données relatives à l'état et à l'utilisation.

    • <DbName> est le nom de la base de données.

    • <SQLServerName> est le nom du serveur de bases de données.

Pour plus d'informations, voir Set-SPUsageApplication.

Pointage de l'application de service Business Data Connectivity vers une base de données renommée ou déplacée

Vous devez supprimer l'application service Connexion de données métiers, renommer ou déplacer la base de données, puis recréer l'application de service de sorte qu'elle pointe vers une base de données renommée ou déplacée. Pour plus d'informations, voir Méthode général pour pointer une application de service vers une base de données renommée ou déplacée.

Pointage de l'application de service Registre d'application vers une base de données renommée ou déplacée

Étant donné qu'il n'existe aucune applet de commande Windows PowerShell pour créer l'application de service Registre d'application, la base de données associée ne peut pas être renommée. Vous pouvez déplacer la base de données à l'aide de la sauvegarde et restauration SharePoint Foundation 2010. Pour plus d'informations, voir Back up a service application (SharePoint Server 2010) et Restore a service application (SharePoint Server 2010) Sauvegarder une application de service (SharePoint Foundation 2010) et Restaurer une application de service (SharePoint Foundation 2010).

Pointage de l'application de service Paramètres d'abonnement vers une base de données renommée ou déplacée

Vous pouvez pointer l'application de service Paramètres d'abonnement vers une base de données renommée ou déplacée à l'aide de Windows PowerShell.

Pour pointer l'application de service Paramètres d'abonnement vers une base de données renommée ou déplacée à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Prenez note du nom de l'application de service Paramètres d'abonnement et du nom de la base de données que vous prévoyez de configurer.

  3. Dans le menu Démarrer, cliquez sur Tous les programmes.

  4. Cliquez sur Produits Microsoft SharePoint 2010.

  5. Cliquez sur SharePoint 2010 Management Shell.

  6. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPSubscriptionSettingsServiceApplication -Identity "<ServiceApplicationName>" -DatabaseName "<DatabaseName>" -DatabaseServer "<DatabaseServer>"

    Où :

    • <ServiceApplicationName> est le nom de l'application de service Paramètres d'abonnement.

    • <DatabaseName> est le nom de la base de données renommée ou déplacée.

    • <DatabaseServer> est l'emplacement de la base de données renommée ou déplacée. N'incluez pas ce paramètre si vous renommez simplement la base de données au même emplacement.

    Pour plus d'informations, voir Set-SPSubscriptionSettingsServiceApplication.

Voir aussi

Concepts

Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010)
Types et descriptions de base de données (SharePoint Foundation 2010)
Gérer les applications de service (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
22 juillet 2010 | Publication initiale |


Déplacer toutes les bases de données (SharePoint Foundation 2010)

Cet article explique comment déplacer toutes les bases de données associées à Microsoft SharePoint Foundation 2010 depuis un serveur de base de données vers un autre serveur de base de données. Si vos bases de données sont hébergées sur différents serveurs, cette procédure s'applique au serveur de base de données qui héberge la base de données de configuration. Pour plus d'informations sur le déplacement de bases de données de contenu, voir Déplacer des bases de données de contenu (SharePoint Foundation 2010). Pour plus d'informations sur le déplacement de bases de données d'application de service uniquement, voir Renommer ou déplacer des bases de données d'applications de service (SharePoint Foundation 2010).

Important :
L'ensemble des sites et des ressources de batterie de serveurs restent indisponibles tant que le processus de déplacement de bases de données n'est pas terminé.

Les procédures décrites dans cet article permettent de déplacer différentes types de bases de données hébergées sur un même serveur de base de données, à savoir :

  • Base de données de configuration

  • Base de données de contenu de l'Administration centrale

  • Bases de données de contenu

  • Bases de données d'applications de service

Déplacement de toutes les bases de données

Le processus qui consiste à déplacer toutes les bases de données d'un serveur de base de données à un autre nécessite de travailler à la fois dans SharePoint Foundation 2010 et dans SQL Server. La liste suivante synthétise le processus de déplacement de toutes les bases de données, les étapes détaillées étant présentées dans les procédures ci-après :

  1. Préparez le nouveau serveur de base de données. Pour plus d'informations, voir Pour préparer le nouveau serveur de base de données.

  2. Fermez les fenêtres Windows PowerShell Management Shell et les fenêtres d'invite de commandes Stsadm éventuellement ouvertes. Pour plus d'informations, voir Pour fermer les sessions de gestion ouvertes.

  3. Dans le composant logiciel enfichable Services (services.mcs), arrêtez tous les services liés à SharePoint Foundation 2010 et à IIS (Internet Information Services). Pour plus d'informations, voir Pour arrêter la batterie de serveurs.

  4. Dans SQL Server, détachez les bases de données de l'instance actuelle. Pour plus d'informations, voir Pour détacher des bases de données.

  5. À l'aide de l'Explorateur Windows, copiez ou déplacez les fichiers .mdf, .ldf et .ndf associés à la base de données du serveur source vers le serveur de destination. Pour plus d'informations, voir Pour déplacer des fichiers de base de données vers le nouveau serveur.

    Remarque :
    Vous pouvez également sauvegarder toutes les bases de données et les restaurer sur le nouveau serveur. Les procédures de sauvegarde et de restauration de toutes les bases de données sont incluses dans cet article. Pour plus d'informations, voir Procédure : sauvegarder une base de données (SQL Server Management Studio) (http://go.microsoft.com/fwlink/?linkid=179208&clcid=0x40C) et Procédure : restaurer une sauvegarde de base de données (SQL Server Management Studio) (http://go.microsoft.com/fwlink/?linkid=183032&clcid=0x40C).

  6. Dans SQL Server, assurez-vous que tous les noms d'accès SQL Server, les rôles de serveur et de base de données fixes, ainsi que les autorisations pour les bases de données du serveur source ont également été correctement configurés sur le serveur de destination. Pour plus d'informations, voir Pour définir des autorisations sur le nouveau serveur.

  7. Dans SQL Server, attachez la base de données à la nouvelle instance. Pour plus d'informations, voir Pour attacher des bases de données à la nouvelle instance de SQL Server.

  8. Utilisez des alias de connexion SQL Server pour pointer vers le nouveau serveur de bases de données, puis utilisez l'alias de connexion pour mettre à jour tous les serveurs Web. Un alias de connexion est un nom de substitution défini qui peut être utilisé pour se connecter à une instance de SQL Server. Vous devez configurer l'alias sur tous les serveurs Web et serveurs d'applications de la batterie. Pour plus d'informations, voir Pour faire pointer l'application Web vers le nouveau serveur de base de données en configurant des alias de connexion SQL Server.

    Remarque :
    Il est recommandé d'utiliser des alias clients SQL Server dans le cadre de la sécurisation de SQL Server pour les environnements SharePoint. Pour plus d'informations, voir Sécuriser SQL Server pour les environnements SharePoint (SharePoint Foundation 2010).

  9. Redémarrez les services. Pour plus d'informations, voir Pour redémarrer les services dans la batterie de serveurs.

Les autorisations minimales requises pour exécuter ce processus sont les suivantes :

  • Vous devez être membre du groupe SharePoint Administrateurs de batterie de serveurs.

  • Sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint, vous devez être membre du groupe Administrateurs.

  • Sur le serveur de base de données à partir duquel les bases de données sont déplacées, vous devez être membre :

    • du groupe Administrateurs,

    • du rôle de base de données fixe db_backupoperator.

  • Sur le serveur de base de données vers lequel les bases de données sont déplacées, vous devez être membre :

    • du groupe Administrateurs,

    • du rôle de base de données fixe db_owner.

Dans certains environnements, vous devez coordonner les procédures de déplacement avec l'administrateur de base de données. Veillez à respecter les stratégies et les directives en vigueur pour la gestion des bases de données.

Pour préparer le nouveau serveur de base de données

  • Configurez le nouveau serveur de base de données en utilisant les procédures décrites dans l'article Sécuriser SQL Server pour les environnements SharePoint (SharePoint Foundation 2010).

    Remarque :
    Le nouveau serveur de base de données doit exécuter la même version de Windows Server et de Microsoft SQL Server que le serveur de base de données existant.

Pour fermer les sessions de gestion ouvertes

  • Fermez les fenêtres Windows PowerShell Management Shell et les fenêtre d'invite de commandes éventuellement ouvertes si vous utilisez l'outil de ligne de commande Stsadm.

Pour arrêter la batterie de serveurs

  1. Sur le serveur qui exécute le site Web Administration centrale, dans le composant logiciel enfichable Services, arrêtez les services suivants :

    • Administration SharePoint 2010

    • Minuteur SharePoint 2010

    • Suivi SharePoint 2010

    • Hôte de code utilisateur SharePoint 2010

    • Enregistreur VSS SharePoint 2010

    • Recherche SharePoint Foundation V4

    • Service de publication World Wide Web

  2. Sur le serveur qui exécute le site Web Administration centrale, à l'invite de commandes, tapez iisreset /stop.

Pour détacher des bases de données

  • Dans SQL Server Management Studio, sur le serveur de base de données d'origine, détachez les bases de données que vous voulez déplacer de l'instance à laquelle elles sont attachées. Si vous exécutez un grand nombre de bases de données, vous pouvez exécuter un script Transact-SQL pour les détacher.

    Remarque :
    Une base de données ne peut pas être détachée si l'une des conditions suivantes est vraie :

    • La base de données fait l'objet d'une mise en miroir.

    • Il existe une capture instantanée de base de données dans la base de données.

    Pour plus d'informations, voir :

    • Attachement et détachement des bases de données (http://go.microsoft.com/fwlink/?linkid=194806&clcid=0x40C)

    • Procédure : détachement d'une base de données (SQL Server Management Studio) (http://go.microsoft.com/fwlink/?linkid=194807&clcid=0x40C)

    • sp_detach_db (Transact-SQL) (http://go.microsoft.com/fwlink/?linkid=194808&clcid=0x40C)

Pour déplacer des fichiers de base de données vers le nouveau serveur

  • Par le biais de l'Explorateur Windows, repérez les fichiers .mdf, .ldf et .ndf associés à chaque base de données que vous déplacez, puis copiez ou déplacez-les vers le répertoire de destination sur le nouvel ordinateur qui exécute SQL Server.

Pour définir des autorisations sur le nouveau serveur

  • Sur le serveur de base de données de destination, ouvrez SQL Server Management Studio et transférez vos noms d'accès et autorisations de l'instance d'origine vers l'instance de destination. Il est conseillé de transférer les autorisations en exécutant un script. Un exemple de script est disponible dans l'article n° 918992 de la base de connaissances : Comment faire pour transférer des noms d'accès et des mots de passe entre instances de SQL Server 2005 (http://go.microsoft.com/fwlink/?linkid=122053&clcid=0x40C).

    Pour plus d'informations sur le transfert de métadonnées SQL Server entre des instances, voir dans la documentation en ligne SQL Server l'article Gestion des métadonnées lors de la mise à disposition d'une base de données sur une autre instance de serveur (http://go.microsoft.com/fwlink/?linkid=122055&clcid=0x40C).

Pour attacher des bases de données à la nouvelle instance de SQL Server

  • Sur le serveur de base de données de destination, attachez les bases de données à la nouvelle instance. Pour plus d'informations, voir Procédure : attacher une base de données (SQL Server Management Studio) (http://go.microsoft.com/fwlink/?linkid=194809&clcid=0x40C) et sp_attach_db (Transact-SQL) (http://go.microsoft.com/fwlink/?linkid=194810&clcid=0x40C).

Pour faire pointer l'application Web vers le nouveau serveur de base de données en configurant des alias de connexion SQL Server

  1. Démarrez le Gestionnaire de configuration SQL Server. Dans le menu Démarrer, pointez sur Tous les programmes, sur Microsoft SQL Server 2008, sur Outils de configuration, puis cliquez sur Gestionnaire de configuration SQL Server.

    Remarque :
    Si le Gestionnaire de configuration SQL Server n'est pas installé, vous devez exécuter le programme d'installation de SQL Server pour l'installer.

  2. Développez Configuration de SQL Native Client, cliquez avec le bouton droit sur Alias, puis cliquez sur Nouvel alias.

  3. Dans le champ Nom de l'alias, entrez le nom de l'instance SQL Server d'origine. Pour Protocole, vérifiez que TCP/IP est sélectionné. Pour Serveur, entrez le nom du nouveau serveur qui héberge les bases de données SharePoint Foundation 2010, puis cliquez sur OK.

  4. Répétez cette procédure sur chaque serveur Web et chaque serveur d'application.

  5. Facultatif. Si votre environnement repose sur System Center Data Protection Manager (DPM) 2010 ou sur une application tierce qui a recours à l'infrastructure Service VSS pour la sauvegarde et la récupération, vous devez installer les composants de connectivité SQL Server sur chaque serveur Web ou serveur d'application en exécutant le programme d'installation SQL Server. Pour plus d'informations, voir Procédure : installer SQL Server 2008 R2 (programme d'installation) (http://go.microsoft.com/fwlink/?linkid=186119&clcid=0x40C).

Pour reconfigurer les emplacements des bases de données Web Analytics

  1. Remarque :
    Cette procédure n'est requise que si vous exécutez une application de service Web Analytics et que vous avez renommé votre serveur au lieu d'utiliser des alias de connexion SQL Server.

    Sur le site Web Administration centrale de SharePoint, sous Gestion des applications, cliquez sur Gérer les applications de service.

  2. Sélectionnez l'application de service Web Analytics, puis cliquez sur Propriétés.

    L'Assistant Modifier une application de service Web Analytics apparaît.

  3. Cliquez sur Suivant.

  4. Dans la deuxième page de l'Assistant, mettez à jour l'emplacement de chaque base de données Web Analytics vers la nouvelle instance SQL Server, puis cliquez sur Suivant.

  5. Dans l'Administration centrale, sous Paramètres système, cliquez sur Gérer les services sur le serveur.

  6. Arrêtez et redémarrez le service de traitement des données Web Analytics et le service Web de Web Analytics.

    Remarque :
    La fonctionnalité Web Analytics SharePoint repose sur SQL Server Service Broker. SQL Server Service Broker ne peut pas être démarré manuellement. Un travail du minuteur SharePoint s'exécute une fois par jour pour que SQL Server Service Broker soit activé sur les bases de données nécessaires.

  7. Après avoir déplacé les bases de données, vous devez exécuter manuellement la règle d'intégrité « Web Analytics : vérifie que SQL Server Service Broker est activé pour les bases de données de la zone de transit Web Analytics ». Pour exécuter manuellement la règle d'intégrité, procédez comme suit :

    • Dans l'Administration centrale, cliquez sur Analyse.

    • Dans la section Analyseur d'intégrité, cliquez sur Vérifier les définitions de règles.

      La page Toutes les règles apparaît.

    • Sous Catégorie : Configuration, cliquez sur la règle d'intégrité Web Analytics : vérifie que SQL Server Service Broker est activé pour les bases de données de la zone de transit Web Analytics.

      La boîte de dialogue Définition de règle de l'Analyseur d'intégrité s'ouvre.

      Remarque :
      Pour afficher la règle d'intégrité, vous devrez peut-être cliquer sur la flèche droite en bas de la page Toutes les règles.

    • Dans le Ruban de la boîte de dialogue Définitions de règle de l'analyseur d'intégrité, cliquez sur Exécuter maintenant.

Pour redémarrer les services dans la batterie de serveurs

  1. Sur le serveur qui exécute le site Web Administration centrale, à l'invite de commandes, tapez iisreset /start.

  2. Dans le composant logiciel enfichable Services (services.msc), démarrez tous les services liés à SharePoint et à IIS (Internet Information Services), notamment :

    • Administration SharePoint 2010

    • Minuteur SharePoint 2010

    • Suivi SharePoint 2010

    • Hôte de code utilisateur SharePoint 2010

    • Enregistreur VSS SharePoint 2010

    • Recherche SharePoint Foundation V4

    • Service de publication World Wide Web

Historique des modifications

Date | Description | Raison
17 juin 2010 | Publication initiale |


Faire fonctionner une batterie qui utilise des bases de données en lecture seule (SharePoint Foundation 2010)

Cet article explique comment exécuter une batterie Microsoft SharePoint Foundation 2010 dans laquelle certaines bases de données ou toutes les bases de données sont configurées en lecture seule (une batterie en lecture seule).

Une batterie est considérée en lecture seule si l'une des conditions suivantes est vraie :

  • Toutes les bases de données de contenu sont configurées en lecture seule.

  • Les bases de données d'application de service sont configurées en lecture seule.

La fonctionnalité et l'expérience utilisateur dans une batterie en lecture seule varient selon les bases de données qui sont configurées en lecture seule.

Une batterie qui utilise des bases de données de contenu et d'application de service en lecture seule est susceptible de faire partie d'un environnement de récupération d'urgence ou d'un environnement de maintenance, de mise à jour ou de mise à niveau hautement disponible.

Procédures de cette tâche :

  • Préparer les utilisateurs à une utilisation en lecture seule

  • Définir des bases de données de contenu comme étant en lecture seule

  • Configurer des bases de données d'application de service en lecture seule

Préparer les utilisateurs à une utilisation en lecture seule

Si vous envisagez d'accorder aux utilisateurs l'accès en lecture seule à un site ou à une batterie de serveurs, vous devez penser aux opérations qu'ils pourront effectuer sur le site ou sur la batterie de serveurs et les variantes de l'interface utilisateur.

Sites qui utilisent des bases de données de contenu en lecture seule

L'expérience utilisateur d'un site qui utilise une base de données de contenu configurée en lecture seule présente les caractéristiques suivantes :

  • Les tâches courantes ne nécessitant pas d'écrire dans la base de données de contenu sont totalement disponibles.

  • La plupart des tâches courantes nécessitant d'écrire dans la base de données de contenu ne sont pas disponibles, car elles ont été désactivées dans l'interface utilisateur ou parce que l'utilisateur n'est plus autorisé à appliquer des modifications.

  • Certaines tâches courantes nécessitant d'écrire dans la base de données de contenu sont disponibles, mais renvoient des erreurs.

Pour plus d'informations sur l'expérience utilisateur sur un site en lecture seule, voir Expérience utilisateur sur les sites en lecture seule (SharePoint Foundation 2010).

Batteries de serveurs qui utilisent des bases de données d'application de service en lecture seule

L'expérience utilisateur d'une batterie qui utilise des bases de données d'application de service configurées en lecture seule présente les caractéristiques suivantes :

  • Les tâches courantes ne nécessitant pas d'écrire dans les bases de données de service sont totalement disponibles.

  • Toutes les tâches courantes nécessitant d'écrire dans les bases de données de service semblent disponibles, mais retournent des erreurs.

Définir des bases de données de contenu comme étant en lecture seule

Avant de définir des bases de données de contenu comme étant en lecture seule, vous devez déterminer la base de données de contenu associée à une collection de sites spécifique.

Pour déterminer la base de données de contenu associée à une collection de sites

  1. Vérifiez que vous répondez à la configuration minimale requise : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur ENTRÉE :

    Get-SPContentDatabase -Site <Site URL>

    -Site spécifie la collection de sites dont vous souhaitez connaître la base de données de contenu associée.

    La commande renvoie la base de données de contenu associée à ce site.

Pour plus d'informations, voir Get-SPContentDatabase

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Vous pouvez utiliser la procédure ci-dessous pour définir des bases de données de contenu comme étant en lecture/écriture en utilisant SQL Server Management Studio. Vous pouvez également utiliser l'instruction Transact-SQL ALTER DATABASE pour définir les bases de données de contenu comme étant en lecture seule. Pour plus d'informations, voir ALTER DATABASE (Transact-SQL) (http://go.microsoft.com/fwlink/?linkid=148619&clcid=0x40C).

Important :
N'effectuez pas cette procédure sur des bases de données d'un environnement de basculement mises en miroir ou copiées dans les journaux de transactions.

Pour définir des bases de données de contenu comme étant en lecture seule

  1. Vérifiez que vous disposez des informations d'identification suivantes : vous devez posséder le rôle de base de données fixe db_owner dans chaque base de données.

  2. Ouvrez SQL Server Management Studio.

  3. Cliquez avec le bouton droit sur la base de données de contenu que vous voulez définir comme étant en lecture seule, puis cliquez sur Propriétés.

  4. Sélectionnez la page Options et, dans la liste Autres options, faites défiler jusqu'à la section État.

  5. Dans la ligne Base de données en lecture seule, cliquez sur la flèche en regard de Faux, sélectionnez Vrai, puis cliquez sur OK.

  6. Répétez l'opération pour toutes les autres bases de données de contenu.

    Remarque :
    Lorsqu'une base de données est définie comme étant en lecture seule, toutes les connexions, à l'exception de celle comportant l'indicateur de lecture seule, sont arrêtées. Une fois que l'indicateur de lecture seule est défini, les autres connexions sont activées.

La collection de sites associée à une base de données de contenu en lecture seule est automatiquement définie en lecture seule si son statut de verrouillage avait auparavant la valeur Aucun, Aucun ajout ou Lecture seule. Si le statut de verrouillage de la collection de sites avait la valeur Aucun accès, celui-ci reste inchangé en cas de changement du statut de verrouillage de la base de données.

Configurer des bases de données d'application de service en lecture seule

Il est possible de configurer toute base de données d'application de service en lecture seule. Cependant, certaines applications de service ne fonctionnent pas lorsque leurs bases de données sont configurées en lecture seules.

Pour configurer des bases de données d'application de service en lecture seule

  1. Vérifiez que vous disposez des informations d'identification suivantes : vous devez posséder le rôle de base de données fixe db_owner dans chaque base de données.

  2. Ouvrez SQL Server Management Studio.

  3. Cliquez avec le bouton droit sur la base de données à mettre en lecture seule , puis cliquez sur Propriétés.

  4. Sélectionnez la page Options et, dans la liste Autres options, faites défiler jusqu'à la section État.

  5. Dans la ligne Base de données en lecture seule, cliquez sur la flèche en regard de Faux, sélectionnez Vrai, puis cliquez sur OK.

  6. Recommencez pour toute autre base de données d'application de service.

    Remarque :
    Lorsqu'une base de données est définie comme étant en lecture seule, toutes les connexions, à l'exception de celle comportant l'indicateur de lecture seule, sont arrêtées. Une fois que l'indicateur de lecture seule est défini, les autres connexions sont activées.

Historique des modifications


Gérer le stockage à distance BLOB (SharePoint Foundation 2010)
Voir aussi

Le stockage BLOB distant (RBS) est un module complémentaire pour Microsoft SQL Server 2008. RBS est conçu pour déplacer le stockage des objets BLOB (Binary Large Objects) des serveurs de bases de données vers des solutions de stockage de produits. Si les bases de données de contenu de Microsoft SharePoint Foundation 2010 sont de 4 gigaoctets (Go) ou plus, envisagez l'utilisation de RBS comme partie intégrante de votre solution de stockage de données.

Dans cette section

  • Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010)

    Cet article fournit une vue d'ensemble conceptuelle du fonctionnement de RBS avec SQL Server 2008.

  • Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010)

    Cet article décrit comment installer et configurer RBS pour une utilisation avec SharePoint Foundation 2010.

  • Définir une base de données de contenu de manière à utiliser le stockage BLOB distant (RBS) (SharePoint Foundation 2010)

    Cet article décrit comment activer une base de données de contenu dans SharePoint Foundation 2010 pour utiliser RBS. RBS doit être déjà installé pour effectuer ces procédures.

Voir aussi

Concepts

Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec stockage BLOB distant


Installer et configurer le stockage étendu des objets BLOB sans le fournisseur FILESTREAM (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment installer et configurer le stockage étendu des objets BLOB ( RBS, Remote BLOB Storage) sur un serveur de base de données Microsoft SQL Server 2008 qui prend en charge un système Microsoft SharePoint Foundation 2010. Il est généralement recommandé d'utiliser RBS si la base de données de contenu est de 4 gigaoctets (4 Go) ou plus.

Dans SharePoint Foundation 2010, les bases de données de contenu sont stockées dans Microsoft SQL Server 2008 Express et possèdent une taille maximale de 4 Go chacune. Comme Microsoft SQL Server 2008 R2 Express prend en charge des bases de données de contenu jusqu'à 10 Go, nous recommandons d'installer SQL Server 2008 R2 Express pour prendre en charge ces bases. Pour plus d'informations, voir Microsoft SQL Server 2008 R2 Express Edition (http://go.microsoft.com/fwlink/?linkid=189418&clcid=0x40C).

Le stockage étendu des objets BLOB est un ensemble d'API de bibliothèque incorporé comme module fonctionnel complémentaire à Microsoft SQL Server 2008 et Microsoft SQL Server 2008 Express. Il est conçu pour déplacer le stockage des objets BLOB des serveurs de bases de données vers des solutions de stockage de produits.

Le stockage étendu des objets BLOB (RBS) utilise un fournisseur pour se connecter à un magasin d'objets BLOB dédié qui implémente les API RBS. Il accompagne le fournisseur RBS FILESTREAM. Des fournisseurs RBS tiers peuvent aussi être utilisés avec les API RBS pour créer une solution de stockage BLOB.

Si vous décidez d'implémenter RBS via un fournisseur tiers au lieu de FILESTREAM, vous pouvez utiliser les informations dans cet article pour installer RBS sans installer le fournisseur FILESTREAM. Avant de pouvoir utiliser RBS, vous devez installer le fournisseur tiers à l'aide de la documentation fournie avec ce fournisseur.

Pour installer et configurer RBS avec le fournisseur FILESTREAM, voir Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010).

Avant d'installer et d'implémenter RBS, nous vous recommandons fortement de lire les articles Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010) et Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010).

Dans cet article :

  • Installer RBS

  • Activer et tester RBS

Le compte d'utilisateur qui vous permet d'effectuer les procédures décrites dans cet article doit être membre :

  • du groupe Administrateurs sur les serveurs Web et les serveurs d'applications ;

  • des rôles serveur fixes dbcreator et securityadmin SQL Server sur l'ordinateur exécutant SQL Server 2008 Express ou SQL Server 2008.

Installer RBS

Vous devez installer RBS sur le serveur de base de données et sur tous les serveurs Web et les serveurs d'application dans la batterie SharePoint. Vous devez configurer RBS séparément pour chaque base de données de contenu associée.

Avertissement :
Nous vous recommandons de ne pas installer RBS en exécutant le fichier RBS_X64.msi et en lançant l'Assistant d'installation du stockage étendu des objets BLOB SQL. L'Assistant configure la maintenance RBS pour qu'elle exécute une tâche planifiée tous les 30 jours. Ce paramètre peut ne pas être optimal pour votre environnement. Pour plus d'informations sur la maintenance RBS, voir la documentation de l'aide de SQL Server incluse dans Package d'installation SQL Server Remote BLOB Store du Feature Pack pour Microsoft SQL Server 2008 R2.

Pour installer RBS sur un serveur Web

  1. Sur un serveur Web, accédez à http://go.microsoft.com/fwlink/?linkid=177388&clcid=0x40C (http://go.microsoft.com/fwlink/?linkid=177388&clcid=0x40C) pour télécharger le fichier RBS_X64.msi. Lorsque le système vous demande d'Exécuter ou d'Enregistrer le fichier, cliquez sur Enregistrer.

    Important :
    Vous devez installer la version de RBS incluse dans Package d'installation SQL Server Remote BLOB Store du Feature Pack pour Microsoft SQL Server 2008 R2. La version de RBS doit être 10.50.xxx. Aucune version antérieure de RBS n'est prise en charge pour SharePoint Foundation 2010.

  2. Cliquez sur Démarrer, puis tapez cmd dans la zone de texte. Dans la liste des résultats, cliquez avec le bouton droit sur cmd, puis cliquez sur Exécuter en tant qu'administrateur. Cliquez sur OK.

  3. Copiez et collez la commande suivante à l'invite de commandes :

    Code de copie
    msiexec /lvx* rbs_install.log /q /i rbs.msi ADDLOCAL=ServerScript,Client,Maintainer

    L'opération doit se terminer dans un délai d'une minute environ.

    Répétez cette procédure sur chaque serveur Web et serveur d'application dans la batterie. Si vous n'installez pas RBS sur chaque serveur d'application et Web, les utilisateurs rencontreront des erreurs en essayant d'écrire dans les bases de données de contenu.

Pour installer RBS sur le serveur de base de données et définir une base de données de contenu pour utiliser RBS

  1. Sur le serveur de base de données, accédez à http://go.microsoft.com/fwlink/?linkid=177388&clcid=0x40C (http://go.microsoft.com/fwlink/?linkid=177388&clcid=0x40C) pour télécharger le fichier RBS_X64.msi.

    Important :
    Vous devez installer la version de RBS incluse dans Package d'installation SQL Server Remote BLOB Store du Feature Pack pour Microsoft SQL Server 2008 R2. La version de RBS doit être 10.50.xxx. Aucune version antérieure de RBS n'est prise en charge pour SharePoint Foundation 2010.

  2. Cliquez sur Démarrer, puis tapez cmd dans la zone de texte. Dans la liste des résultats, cliquez avec le bouton droit sur cmd, puis cliquez sur Exécuter en tant qu'administrateur. Cliquez sur OK.

  3. Copiez et collez la commande suivante à l'invite de commandes :

    Code de copie
    msiexec /lvx* rbs_enable_WSS_Content.log /q /i rbs.msi ADDLOCAL=EnableRBS DBINSTANCE="<DBInstanceName>" DBNAME="<ContentDbName>"

    Où :

    • <DBInstanceName> est le nom de l'instance SQL Server.

    • <ContentDbName> est le nom de la base de données de contenu.

    L'opération doit se terminer au bout d'une minute environ.

    Pour définir des bases de données de contenu supplémentaires pour utiliser RBS, voir Définir une base de données de contenu de manière à utiliser le stockage BLOB distant (RBS) (SharePoint Foundation 2010).

Pour confirmer l'installation de RBS

  1. Le fichier journal rbs_intall_log.txt est créé au même emplacement que le fichier RBS_X64.msi. Ouvrez ce fichier journal avec un éditeur de texte et faites-le défiler vers le bas. Dans les 20 dernières lignes de la fin du fichier, une entrée doit se présenter comme suit : « Produit : Stockage étendu des objets BLOB SQL - L'installation s'est terminée correctement ».

  2. Sur l'ordinateur qui exécute SQL Server 2008, vérifiez que les tables RBS ont été créées dans la base de données de contenu. Plusieurs tables dont les noms sont précédés par les lettres « mssqlrbs » doivent résider dans la base de données de contenu.

Activer et tester RBS

Vous devez activer RBS sur un serveur Web dans la batterie de serveurs SharePoint. Vous pouvez choisir n'importe quel serveur Web pour cette activité, l'essentiel étant que vous ayez installé RBS au moyen de la procédure précédente.

Pour activer RBS

  1. Dans le menu Démarrer, cliquez successivement sur Programmes, Produits Microsoft SharePoint 2010, puis SharePoint 2010 Management Shell.

  2. À l'invite de commandes Windows PowerShell, tapez les commandes suivantes :

    Code de copie
    $cdb = Get-SPContentDatabase -WebApplication <http://SiteName>

    où <http://SiteName> est l'application Web qui est jointe à la base de données de contenu.

    Code de copie
    $rbss = $cdb.RemoteBlobStorageSettings
$rbss.Installed()
$rbss.Enable()
$rbss

Pour tester le magasin de données RBS

  1. Connectez-vous à une bibliothèque de documents sur n'importe quel serveur Web.

  2. Téléchargez un fichier d'au moins 100 kilo-octets (Ko) vers la bibliothèque de documents.

  3. Sur l'ordinateur qui contient le magasin de données RBS, cliquez sur Démarrer , puis cliquez sur Ordinateur .

  4. Accédez au répertoire du magasin de données RBS.

  5. Accédez à la liste des fichiers, puis ouvrez le dossier portant la date de modification la plus récente (autre que $FSLOG). Vérifiez que la taille et le contenu de ce fichier sont identiques à ceux du fichier que vous avez téléchargé. Si ce n'est pas le cas, vérifiez que le stockage RBS est installé et activé correctement.

Voir aussi

Concepts

Migrer du contenu vers ou hors du stockage BLOB distant (SharePoint Foundation 2010)
Désactiver RBS (Remote BLOB Storage) sur une base de données de contenu (SharePoint Foundation 2010)

Historique des modifications


Définir une base de données de contenu de manière à utiliser le stockage BLOB distant (RBS) (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment définir une base de données de contenu pour utiliser le stockage BLOB distant. Ses instructions supposent que vous avez déjà installé le stockage BLOB distant à utiliser avec Microsoft SharePoint Foundation 2010. Pour installer et configurer le stockage BLOB distant, voir Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010) ou Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant).

Définir une base de données de contenu pour l'utilisation du stockage BLOB distant

Pour définir une base de données de contenu pour l'utilisation du stockage BLOB distant, vous devez mettre en service un magasin d'objets BLOB dans SQL Server, ajouter les informations de la base de données de contenu à la configuration du stockage BLOB distant sur un serveur Web, puis tester le magasin de données BLOB.

Ces instructions supposent que vous avez installé SQL Server Management Studio sur le serveur de bases de données. Si ce n'est pas le cas, vous pouvez télécharger et installer Management Studio à partir de la page dédiée à Microsoft SQL Server 2008 Management Studio Express (http://go.microsoft.com/fwlink/?linkid=186132&clcid=0x40C).

Remarque :
Ces instructions supposent que vous utilisez le fournisseur de flux de fichier du stockage BLOB distant. Si vous utilisez un autre fournisseur de stockage BLOB distant, reportez-vous aux instructions de ce fournisseur pour effectuer les opérations.

Pour configurer une base de données de contenu de sorte qu'elle utilise le stockage RBS

  1. Vérifiez que le compte d'utilisateur que vous utilisez pour effectuer ces étapes est membre du groupe Administrateurs sur le serveur Web et membre des rôles serveur fixes SQL Server dbcreator et securityadmin sur l'ordinateur qui exécute Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3.

  2. Cliquez sur Démarrer, Tous les programmes, Microsoft SQL Server 2008, puis sur SQL Server Management Studio.

  3. Dans la boîte de dialogue Se connecter au serveur, spécifiez le type du serveur, le nom du serveur et la méthode d'authentification du serveur de base de données auquel vous souhaitez vous connecter, puis cliquez sur Se connecter.

  4. Développez Bases de données.

  5. Cliquez avec le bouton droit sur la base de données de contenu pour laquelle vous souhaitez créer un magasin d'objets BLOB, puis cliquez sur Nouvelle requête.

  6. Dans le volet Requête, copiez et exécutez les requêtes SQL suivantes, dans l'ordre indiqué.

    Code de copie
    use [ContentDbName]
if not exists (select * from sys.symmetric_keys where name = N'##MS_DatabaseMasterKey##')
create master key encryption by password = N'Admin Key Password !2#4'
    Code de copie
    use [ContentDbName]
if not exists (select groupname from sysfilegroups where groupname=N'RBSFilestreamProvider')
alter database [ContentDbName] add filegroup RBSFilestreamProvider contains filestream
    Code de copie
    use [ContentDbName]
alter database [ContentDbName] add file (name = RBSFilestreamFile, filename = 'c:\BLOBStore') to filegroup RBSFilestreamProvider

    Où [ContentDbName] est le nom de la base de données de contenu et où c:\BLOBStore est le volume\répertoire qui contient le magasin d'objets BLOB. Sachez que vous ne pouvez mettre en service un magasin d'objets BLOB qu'une seule fois. Si vous essayez de mettre en service le même magasin d'objets BLOB plusieurs fois, vous obtiendrez un message d'erreur.

    Conseil :
    Pour de meilleures performances, un dépannage simplifié et en règle générale une pratique optimisée, il est recommandé de créer le magasin BLOB sur un volume qui ne contient pas le système d'exploitation, les fichiers d'échange, les données de base de données, les fichiers journaux ou le fichier de tempdb.

  7. Cliquez sur Démarrer, sur Exécuter, tapez cmd dans la zone de texte Exécuter, puis cliquez sur OK.

  8. Copiez et collez la commande suivante à l'invite de commandes.

    Code de copie
    msiexec /qn /i rbs.msi REMOTEBLOBENABLE=1 FILESTREAMPROVIDERENABLE=1 DBNAME=<ContentDbName> FILESTREAMSTORENAME=FilestreamProvider_1 ADDLOCAL=EnableRBS,FilestreamRunScript DBINSTANCE=<DBInstanceName>>

    Où <ContentDbName> est le nom de la base de données de contenu, et où <DBInstanceName> est le nom de l'instance de SQL Server. L'opération doit se terminer au bout d'une minute environ.

Pour tester le magasin de données RBS

  1. Connectez-vous à une bibliothèque de documents sur n'importe quel serveur Web.

  2. Téléchargez un fichier d'au moins 100 kilo-octets (Ko) dans la bibliothèque de documents.

  3. Sur l'ordinateur qui contient le magasin de données RBS, cliquez sur Démarrer, puis cliquez sur Ordinateur.

  4. Accédez au répertoire du magasin de données RBS.

  5. Recherchez le dossier dont la date de modification est la plus récente, autre que le dossier $FSLOG. Ouvrez ce dossier et recherchez le fichier dont la date de modification est la plus récente. Vérifiez que la taille et le contenu de ce fichier sont identiques à ceux du fichier que vous avez téléchargé. Si ce n'est pas le cas, vérifiez que le stockage RBS est installé et activé correctement.

Voir aussi

Concepts

Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010)
Migrer du contenu vers ou hors du stockage BLOB distant (SharePoint Foundation 2010)

Historique des modifications


Migrer du contenu vers ou hors du stockage BLOB distant (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment migrer du contenu à destination ou en provenance du stockage BLOB distant, ou d'un autre fournisseur de stockage BLOB distant.

Après l'installation du stockage BLOB distant et la définition d'une base de données de contenu pour l'utilisation du stockage BLOB distant, l'ensemble du contenu existant de cette base de données peut être migré vers le fournisseur actif de la base de données. Vous devez utiliser la même commande Windows PowerShell 2.0 pour migrer du contenu à destination ou en provenance du stockage BLOB distant, ou vers un autre fournisseur de stockage BLOB distant. Une fois le stockage BLOB distant implémenté, SQL Server lui-même est considéré comme un fournisseur de stockage BLOB distant.

Vous pouvez migrer les bases de données de contenu à tout moment ; toutefois, il est recommandé d'effectuer les migrations durant les périodes de faible activité afin que les utilisateurs ne soient pas affectés par une dégradation des performances. La migration entraîne le déplacement du contenu de la base de données de contenu spécifiée vers le mécanisme de stockage du nouveau fournisseur désigné.

Cette opération peut être effectuée sur n'importe quel serveur Web de la batterie de serveurs. Vous ne devez effectuer l'opération qu'une seule fois sur un seul serveur Web pour chaque base de données de contenu à migrer.

Pour migrer une base de données de contenu à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez les commandes des étapes suivantes.

  6. Pour obtenir l'objet des paramètres de stockage BLOB distant de la base de données de contenu :

    Code de copie
    $cdb=Get-SPContentDatabase <ContentDbName>
$rbs=$cdb.RemoteBlobStorageSettings

    Où <ContentDbName> est le nom de la base de données de contenu.

  7. Pour afficher une liste de tous les fournisseurs de stockage BLOB distant installés sur le serveur Web :

    Code de copie
    $rbs.GetProviderNames()

  8. Pour définir le fournisseur de stockage BLOB distant actif :

    Code de copie
    $rbs.SetActiveProviderName(<NewProvider>)

    Où <NewProvider> est le nom du fournisseur à rendre actif pour cette base de données de contenu. Pour migrer la base de données de contenu hors du stockage BLOB distant vers le stockage en ligne SQL Server, affectez () à cette valeur.

  9. Pour migrer les données du stockage BLOB distant vers le nouveau fournisseur ou vers SQL Server :

    Code de copie
    $rbs.Migrate()

Voir aussi

Concepts

Définir une base de données de contenu de manière à utiliser le stockage BLOB distant (RBS) (SharePoint Foundation 2010)

Historique des modifications


Assurer la maintenance du stockage BLOB distant (SharePoint Foundation 2010)
Voir aussi

Les tâches de maintenance associées au stockage BLOB distant (RBS, Remote BLOB Storage) sont effectuées principalement par le biais de RBS Maintainer. Celui-ci effectue un nettoyage de la mémoire (garbage collection) périodique et d'autres tâches de maintenance pour un déploiement RBS. Vous pouvez planifier ces tâches pour chaque base de données qui utilise le stockage BLOB distant à l'aide du Planificateur de tâches Windows ou de Microsoft SQL Server Agent. RBS Maintainer doit être mis en service par le biais de paramètres de ligne de commande ou par le biais d'un fichier XML. Dans le cas des bases de données répliquées ou en miroir, Maintainer doit être exécuté contre une instance unique.

Dans cet article :

  • Garbage collection

  • Vérifications de cohérence du stockage BLOB distant et du magasin d'objets BLOB

  • Exécution de RBS Maintainer

Garbage collection

Le garbage collection est le processus selon lequel les données supprimées ou non référencées sont supprimées du magasin d'objets BLOB distant. Avec le stockage BLOB distant, ce processus s'effectue de manière passive. Les références aux objets BLOB sont comptabilisées en observant la liste d'ID d'objets BLOB stockée par l'application dans ses colonnes de table RBS au moment du garbage collection.

Toute référence à un objet BLOB présente dans les tables auxiliaires RBS mais absente dans une colonne RBS dans les tables d'application est supposée avoir été supprimée par l'application et sera recueillie comme données parasites. Les objets BLOB qui ne sont présents dans aucune colonne RBS et qui ont été créés avant la plage de nettoyage orphelin, décrite plus loin dans cet article, sont également supposés avoir été supprimés par l'application et seront recueillis comme données parasites.

Étant donné que le garbage collection passif classifie les références d'objets BLOB à partir des colonnes RBS des tables d'une application, chaque colonne RBS doit avoir un index valide pour pouvoir être inscrite dans RBS.

Ce processus de garbage collection est effectué par l'outil RBS Maintainer. Son exécution doit être planifiée durant les heures creuses, afin de réduire l'impact sur les opérations de base de données ordinaires.

Le garbage collection RBS est effectué lors des trois étapes suivantes :

  • Analyse de référence. La première étape permet de comparer le contenu des tables RBS de l'application aux tables internes propres à RBS et d'identifier les objets BLOB qui ne sont plus référencés. Tout objet BLOB non référencé est marqué pour la suppression.

  • Supprimer la propagation. L'étape suivante permet d'identifier les objets BLOB qui ont été marqués pour la suppression pour une période supérieure à la valeur garbage_collection_time_window et de les supprimer du magasin d'objets BLOB.

  • Nettoyage orphelin. La dernière étape permet de déterminer si des objets BLOB sont présents dans le magasin d'objets BLOB mais absents des tables RBS. Ces objets BLOB orphelins sont ensuite supprimés.

Configuration du garbage collection RBS

Le garbage collection peut être configuré en ajustant plusieurs paramètres de base de données et de l'outil Maintainer. Les paramètres de Maintainer sont les suivants :

  • Planification Maintainer. Ce paramètre détermine la fréquence d'exécution de Maintainer.

  • Durée de la tâche. Ce paramètre détermine la durée maximale d'une exécution de Maintainer. La valeur par défaut est de deux heures.

Ces paramètres de Maintainer doivent être configurés de sorte que l'activité de Maintainer ait un impact minimal sur l'activité ordinaire. Les paramètres de garbage collection de base de données sont décrits dans Exécution de RBS Maintainer (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=199638&clcid=0x40C).

Vérifications de cohérence du stockage BLOB distant et du magasin d'objets BLOB

RBS Maintainer vérifie l'intégrité des références aux objets BLOB RBS et corrige les erreurs détectées. Il effectue plusieurs vérifications de cohérence pour la base de données, vérifiant notamment qu'il existe des index pour les colonnes RBS et que tous les objets BLOB référencés par les tables d'application existent dans le stockage BLOB distant.

La vérification de cohérence de table auxiliaire permet de vérifier que les tables auxiliaires RBS sont dans un état cohérent grâce aux contrôles suivants :

  • vérification que chaque colonne de table RBS a un index valide ;

  • vérification qu'il existe des colonnes de tables RBS d'applications inscrites, qu'elles ont des index activés et valides et qu'elles sont du type de colonne correct.

Les vérifications de cohérence suivantes sont facultatives et peuvent être omises :

  • vérification que tous les objets BLOB référencés dans les tables d'applications sont présents dans les tables RBS ;

  • vérification qu'aucun objet BLOB n'est marqué à la fois comme utilisé et comme supprimé.

Tout problème découvert est consigné dans le journal et RBS Maintainer tente de le résoudre en créant les entrées d'index manquantes, en désinscrivant les colonnes manquantes ou en marquant comme non supprimés les objets en cours d'utilisation.

Exécution de RBS Maintainer

Le stockage BLOB distant nécessite de définir une chaîne de connexion à chaque base de données qui l'utilise avant d'exécuter Maintainer. Cette chaîne est stockée dans un fichier de configuration dans le dossier <chemin_accès_installation>\Microsoft SQL Remote Blob Storage 10.50\Maintainer créé normalement durant l'installation. Maintainer peut être exécuté manuellement en exécutant le programme Microsoft.Data.SqlRemoteBlobs.Maintainer.exe avec les paramètres suivants :

Nom du paramètre | Description | Valeurs | Obligatoire
ConnectionStringName <nom_chaîne> | Nom de la chaîne de connexion pour le fichier de configuration. | RBSMaintainerConnection est le nom par défaut créé durant l'installation du stockage BLOB distant. | Oui.
Operation <liste d'opérations à effectuer séparées par un espace> | Opération de garbage collection à effectuer. Ce paramètre prend de un à quatre arguments. La valeur de ForceFinalize ne peut pas être utilisée conjointement avec une autre opération. | ConsistencyCheck GarbageCollection Maintenance ConsistencyCheckForStores ForceFinalize | Oui.
GarbageCollectionPhases <phases> | Phases de garbage collection à effectuer. Ce paramètre sert à exécuter ou achever le garbage collection. La valeur doit être une ou plusieurs lettres sans espace. | r — Analyse de référence. d — Supprimer la propagation. o — Nettoyage orphelin. | Oui, si le garbage collection doit être effectué.
ConsistencyCheckMode <c, r ou b> | Spécifie le type de vérification de cohérence à effectuer. | c — Seule une vérification est effectuée. r — Une vérification est effectuée et tout problème détecté est réparé. b — Une vérification, réparation et reconstruction des structures de données internes sont effectuées. | Oui, si une vérification de cohérence doit être effectuée.
ConsistencyCheckExtent <m ou c> | Spécifie l'étendue de la vérification de cohérence. | m — Seules les métadonnées sont vérifiées ; les objets BLOB proprement dits ne sont pas vérifiés. Il s'agit du paramètre par défaut. c — Une vérification complète est effectuée. | Si aucune valeur n'est fournie, m est utilisé par défaut.
ConsistencyCheckForStores <liste de noms de magasins d'objets BLOB séparés par un espace> | Répertorie les noms des magasins d'objets BLOB dont la cohérence sera vérifiée. | Par défaut, tous les magasins d'objets BLOB sont vérifiés. | Non.
TimeLimit <durée en minutes> | Spécifie la durée allouée à Maintainer pour exécuter ses tâches. L'argument doit être un entier positif. |  | Non.

Une tâche RBS Maintainer distincte doit être planifiée pour chaque base de données qui utilise le stockage BLOB distant. Les étapes suivantes décrivent comment planifier une tâche Maintainer.

Pour planifier une tâche Maintainer

  1. Ajoutez une chaîne de connexion au fichier <répertoire_installation_RBS>\Maintainer\Microsoft.Data.SqlRemoteBlobs.Maintainer.exe.config pour la tâche Maintainer à exécuter. Le programme d'installation RBS crée une chaîne de connexion nommée RBSMaintainerConnection à l'aide des informations de connexion qui ont été fournies durant l'installation. Toutefois, de nouvelles chaînes de connexions doivent être ajoutées pour chaque base de données supplémentaire.

    Les chaînes de connexions RBS Maintainer sont stockées dans un format chiffré. Par conséquent, pour ajouter des chaînes de connexions, les nouvelles chaînes doivent être chiffrées ou toutes les chaînes de connexions doivent être déchiffrées. Les chaînes chiffrées doivent être ajoutées une par une, mais toutes les chaînes de connexions peuvent être déchiffrées en même temps à l'aide de l'outil %windir%\Microsoft.net\Framework\<version>\Aspnet_regiis.exe, qui est distribué dans le cadre du Microsoft .NET Framework.

    Lorsque vous exécutez les commandes suivantes, les chaînes de connexions sont déchiffrées et les résultats sont stockés dans un fichier Web.config.

    rename Microsoft.Data.SqlRemoteBlobs.Maintainer.exe.config web.config
    aspnet_regiis -pdf connectionStrings

    Les chaînes peuvent être ajoutées au format déchiffré et le fichier peut être chiffré et renommé Microsoft.Data.SqlRemoteBlobs.Maintainer.exe.config à l'aide des commandes suivantes :

    aspnet_regiis -pef connectionStrings . -prov DataProtectionConfigurationProvider
    rename web.config Microsoft.Data.SqlRemoteBlobs.Maintainer.exe.config

  2. Créez une tâche de planificateur Windows afin d'exécuter la tâche Maintainer pour chaque base de données concernée. Si le programme d'installation RBS a été exécuté en mode d'interface utilisateur graphique, il crée automatiquement une tâche Maintainer. En revanche, s'il a été exécuté en mode de ligne de commande, vous devez effectuer les étapes suivantes chaque fois qu'une nouvelle tâche Maintainer est planifiée :

    1. Exécutez le Planificateur de tâche dans les Outils d'administration.

    2. Dans le menu Action, cliquez sur Créer une tâche.

    3. Sous l'onglet Actions, cliquez sur Nouveau puis, dans la liste déroulante Action, sélectionnez Démarrer un programme.

    4. Sous Paramètres, dans la zone Program/script, naviguez jusqu'au fichier binaire Maintainer <répertoire_installation_RBS>\Maintainer\Microsoft.Data.SqlRemoteBlobs.Maintainer.exe puis, dans la zone de texte Ajouter des arguments (facultatif), ajoutez les arguments facultatifs de votre choix. Les valeurs par défaut suivantes sont créées par le programme d'installation :
      <-ConnectionStringName RBSMaintainerConnection>
      <-Operation GarbageCollection ConsistencyCheck ConsistencyCheckForStores>
      <-GarbageCollectionPhases rdo>
      <-ConsistencyCheckMode r>
      <-TimeLimit 120>

    5. Sous l'onglet Déclencheurs, cliquez sur Nouveau, puis planifiez la tâche. Nous vous recommandons de planifier la tâche durant les périodes de faible activité du système.

    6. Sous l'onglet Général, sous Sécurité, assurez-vous de disposer de l'autorisation nécessaire pour exécuter la tâche. Cliquez sur Utilisateur ou groupe si vous devez modifier votre autorisation.

    7. Sous l'onglet Général, cliquez sur Exécuter même si aucun utilisateur n'a ouvert de session, puis sur OK.

Voir aussi

Concepts

Vue d'ensemble du stockage BLOB distant (SharePoint Foundation 2010)
Planifier le stockage étendu des objets BLOB (SharePoint Foundation 2010)
Installer et configurer le stockage BLOB distant ou le stockage BLOB externe (SharePoint Foundation 2010)
Installer et configurer le stockage étendu des objets BLOB sans le fournisseur FILESTREAM (SharePoint Foundation 2010)
Définir une base de données de contenu de manière à utiliser le stockage BLOB distant (RBS) (SharePoint Foundation 2010)
Migrer du contenu vers ou hors du stockage BLOB distant (SharePoint Foundation 2010)
Désactiver RBS (Remote BLOB Storage) sur une base de données de contenu (SharePoint Foundation 2010)

Autres ressources

Mise à niveau depuis une installation autonome de Windows SharePoint Services 3.0 vers SharePoint Foundation 2010 avec des bases de données de contenu dépassant 4 Go (stockage BLOB distant)

Historique des modifications

Date | Description | Raison
27 août 2010 | Publication initiale |


Désactiver RBS (Remote BLOB Storage) sur une base de données de contenu (SharePoint Foundation 2010)

Vous pouvez désactiver le stockage BLOB distant (RBS, Remote BLOB Storage) sur toute base de données de contenu. Une fois que vous avez désactivé RBS sur une base de données de contenu, les objets BLOB (Binary Large Objects) sont stockés en ligne dans SQL Server pour toutes les écritures suivantes dans la base de données de contenu. Cet article explique comment désactiver RBS sur une base de données de contenu.

Vous pouvez désactiver RBS sur une base de données de contenu en définissant le nom du fournisseur actif sur une chaîne vide dans Windows PowerShell. Chaque base de données de contenu a une propriété RemoteBlobStorageSettings qui peut être utilisée pour invoquer la méthode SetActiveProviderName.

Cette action ne change pas l'emplacement de stockage des BLOB précédemment stockés dans RBS ou un stockage en ligne. La désactivation de RBS ne désinstalle pas RBS. Nous ne recommandons pas de désinstaller RBS.

Cette opération peut être effectuée sur tout serveur Web dans la batterie. Vous ne devez effectuer l'opération qu'une seule fois sur le serveur Web pour chaque base de données de contenu pour laquelle vous souhaitez désactiver RBS.

Attention :
N'utilisez pas la méthode Disable() sur l'objet RemoteBlobStorageSettings. Cette méthode sert uniquement à désinstaller RBS, elle n'est pas recommandée pour simplement désactiver l'écriture de nouveaux BLOB dans RBS.

Vous devez utiliser les applets de commande Windows PowerShell 2.0 pour désactiver RBS. Il n'y a pas d'option d'interface utilisateur pour cette tâche.

Pour désactiver RBS à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $site=Get-SPSite "<http://yourSiteURL>"
$rbss=$site.ContentDatabase.RemoteBlobStorageSettings
$rbss.SetActiveProviderName("")

    Où <http://yourSiteURL> est l'application Web qui est liée à la base de données de contenu qui est désactivée pour RBS.

    Pour plus d'informations, voir Get-SPSite.

Historique des modifications


Administration de la sécurité et des autorisations (SharePoint Foundation 2010)

Cette section décrit comment gérer la sécurité et les autorisations pour Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Configurer des autorisations personnalisées (SharePoint Foundation 2010)

Historique des modifications


Configurer des autorisations personnalisées (SharePoint Foundation 2010)

Pour obtenir davantage de contrôle sur le niveau d'accès à un site, une collection de sites ou un contenu de site, vous pouvez définir des niveaux d'autorisation personnalisés. Pour plus d'informations, voir Déterminer les niveaux d'autorisation et les groupes (SharePoint Foundation) et Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010).

Dans cette procédure :

  • Personnaliser un niveau d'autorisation existant

  • Copier un niveau d'autorisation existant

  • Créer un niveau d'autorisation

Personnaliser un niveau d'autorisation existant

Si le niveau d'autorisation personnalisé que vous souhaitez est presque identique à un niveau d'autorisation par défaut existant et que vous n'avez pas besoin d'utiliser le niveau d'autorisation par défaut, vous pouvez personnaliser le niveau d'autorisation par défaut.

Pour personnaliser un niveau d'autorisation existant

  1. Vérifiez que vous disposez de l'une des informations d'identification d'administration suivantes :

    • Vous êtes membre du groupe Administrateurs de la collection de sites.

    • Vous êtes membre du groupe Propriétaires du site.

    • Vous disposez de l'autorisation Gérer les autorisations.

  2. Dans la page Paramètres du site, sous Utilisateurs et autorisations, cliquez sur Autorisations de site.

  3. Dans la section Gérer du ruban, cliquez sur Niveaux d'autorisation.

  4. Dans la liste des niveaux d'autorisation, cliquez sur le nom du niveau d'autorisation que vous souhaitez personnaliser.

  5. Dans la liste des autorisations, activez ou désactivez les cases à cocher pour ajouter des autorisations au niveau d'autorisation ou pour en supprimer de ce dernier.

  6. Cliquez sur Envoyer.

Copier un niveau d'autorisation existant

Si le niveau d'autorisation personnalisé que vous souhaitez est similaire à un niveau d'autorisation par défaut existant et que vous devez utiliser à la fois le niveau d'autorisation par défaut et votre niveau d'autorisation personnalisé, vous pouvez copier le niveau d'autorisation par défaut, puis modifier la copie et l'enregistrer en tant que nouveau niveau d'autorisation.

Pour copier un niveau d'autorisation existant

  1. Vérifiez que vous disposez de l'une des informations d'identification d'administration suivantes :

    • Vous êtes membre du groupe Administrateurs de la collection de sites.

    • Vous êtes membre du groupe Propriétaires du site.

    • Vous disposez de l'autorisation Gérer les autorisations.

  2. Dans la page Paramètres du site, sous Utilisateurs et autorisations, cliquez sur Autorisations de site.

  3. Dans la section Gérer du ruban, cliquez sur Niveaux d'autorisation.

  4. Dans la liste des niveaux d'autorisation, cliquez sur le nom du niveau d'autorisation que vous souhaitez copier.

  5. En bas de la page, cliquez sur Copier niveau d'autorisation.

  6. Dans la page Copier niveau d'autorisation, dans le champ Nom, tapez le nom du nouveau niveau d'autorisation.

  7. Dans le champ Description, tapez une description pour le nouveau niveau d'autorisation.

  8. Dans la liste des autorisations, activez ou désactivez les cases à cocher pour ajouter des autorisations au niveau d'autorisation ou pour en supprimer de ce dernier.

  9. Cliquez sur Créer.

Créer un niveau d'autorisation

Si aucun niveau d'autorisation n'est similaire à celui dont vous avez besoin, vous pouvez en créer un.

Pour créer un niveau d'autorisation

  1. Vérifiez que vous disposez de l'une des informations d'identification d'administration suivantes :

    • Vous êtes membre du groupe Administrateurs de la collection de sites.

    • Vous êtes membre du groupe Propriétaires du site.

    • Vous disposez de l'autorisation Gérer les autorisations.

  2. Dans la page Paramètres du site, sous Utilisateurs et autorisations, cliquez sur Autorisations de site.

  3. Dans la section Gérer du ruban, cliquez sur Niveaux d'autorisation.

  4. Dans la barre d'outils, cliquez sur Ajouter un niveau d'autorisation.

  5. Dans la page Ajouter un niveau d'autorisation, dans le champ Nom, tapez le nom du nouveau niveau d'autorisation.

  6. Dans le champ Description, tapez une description pour le nouveau niveau d'autorisation.

  7. Dans la liste des autorisations, activez les cases à cocher pour ajouter les autorisations au niveau d'autorisation.

  8. Cliquez sur Créer.

Historique des modifications


Modifier les mots de passe utilisés pour les comptes d'administration (SharePoint Foundation 2010)
Voir aussi

Certains services et fonctionnalités de Microsoft SharePoint Foundation doivent être associés à un compte Windows pour s'exécuter. Si le compte possède un mot de passe (c'est-à-dire que le compte est différent du compte Système local, Service local ou Service réseau), le mot de passe dans SharePoint Foundation doit alors être mis à jour chaque fois que le mot de passe du compte est modifié.

Deux méthodes s'offrent à vous pour synchroniser des mots de passe entre Windows et SharePoint Foundation : la synchronisation automatique et la synchronisation manuelle. Pour synchroniser des mots de passe automatiquement, vous pouvez inscrire des comptes gérés et configurer SharePoint Foundation de manière à modifier les mots de passe des comptes gérés selon une planification donnée. SharePoint Foundation génère automatiquement un nouveau mot de passe, met à jour le mot de passe dans les services de domaine Active Directory (AD DS) et propage les modifications aux autres serveurs de la batterie. Pour plus d'informations sur les comptes gérés, voir Planifier la modification automatique des mots de passe (SharePoint Foundation).

Avertissement :
Windows Server 2008 R2 inclut des comptes gérés au niveau du système d'exploitation. N'utilisez pas les comptes gérés Windows Server 2008 R2, car ils ne sont pas compatibles avec les comptes gérés SharePoint Foundation.

Nous vous recommandons d'utiliser des comptes gérés SharePoint Foundation dès que possible. Vous pouvez utiliser des comptes gérés pour contrôler les mots de passe des éléments suivants :

  • Administration centrale

  • Service du minuteur

  • Applications de service

  • Pools d'applications

Lorsque l'utilisation de comptes gérés n'est pas adaptée, vous devez modifier manuellement les mots de passe dans SharePoint Foundation lorsque les mots de passe sont modifiés dans AD DS. Les mots de passe doivent être modifiés manuellement pour les éléments suivants :

  • Services SQL Server

  • Compte d'accès au contenu par défaut

Les articles de cette section contiennent des procédures pour modifier les mots de passe des comptes utilisés par SharePoint Foundation. Dans cette section :

  • Configurer la modification automatique des mots de passe (SharePoint Foundation 2010)

  • Modifier les mots de passe pour les services SQL Server (SharePoint Foundation 2010)

  • Modifier le mot de passe du compte d'accès au contenu par défaut (SharePoint Foundation 2010).

Voir aussi

Concepts

Planifier la modification automatique des mots de passe (SharePoint Foundation)

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Configurer la modification automatique des mots de passe (SharePoint Foundation 2010)

La modification automatique des mots de passe permet à Microsoft SharePoint Foundation 2010 de générer automatiquement des mots de passe longs et forts du point de vue du chiffrement selon un calendrier que vous pouvez déterminer.

Dans cet article :

  • Configurer les comptes gérés

  • Configurer les paramètres de modification automatique du mot de passe

  • Résolution des problèmes liés à la modification automatique du mot de passe

Configurer les comptes gérés

Vous devez enregistrer des comptes gérés auprès de la batterie afin de les rendre accessibles à plusieurs services. Vous pouvez enregistrer un compte géré par le biais de la page Enregistrer le compte géré dans l'Administration centrale. Cette page ne propose aucune option permettant de créer un compte dans les services de domaine Active Directory ou sur l'ordinateur local. Les options disponibles peuvent servir à enregistrer un compte existant dans la batterie SharePoint Foundation 2010. Effectuez les étapes de la procédure suivante pour configurer les paramètres des comptes gérés à l'aide de l'Administration centrale.

Pour configurer les paramètres des comptes gérés à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est administrateur de collection de sites.

  2. Dans le site Web Administration centrale, sélectionnez Sécurité.

  3. Sous Sécurité générale, cliquez sur Configurer les comptes gérés.

  4. Dans la page Comptes gérés, cliquez sur Enregistrer le compte géré.

  5. Dans la section Enregistrement de compte de la page Enregistrer le compte géré, entrez les informations d'identification du compte de service.

  6. Dans la section Modification automatique du mot de passe, activez la case à cocher Activer la modification automatique du mot de passe pour autoriser SharePoint Foundation 2010 à gérer le mot de passe du compte sélectionné. Ensuite, entrez une valeur numérique qui indique combien de jours avant l'expiration du mot de passe le processus de modification automatique du mot de passe sera initié.

  7. Dans la section Modification automatique du mot de passe, activez la case à cocher Commencer la notification par messagerie, puis entrez une valeur numérique qui indique combien de jours avant l'initiation du processus de modification automatique de mot de passe une notification par courrier électronique sera envoyée. Vous pouvez ensuite configurer un calendrier de notification par courrier électronique mensuel ou hebdomadaire.

  8. Cliquez sur OK.

Configurer les paramètres de modification automatique du mot de passe

Utilisez la page Paramètres de gestion des mots de passe de l'Administration centrale pour configurer les paramètres de modification automatique du mot de passe à l'échelle de la batterie. Les administrateurs de la batterie peuvent configurer l'adresse de messagerie qui sera utilisée pour envoyer tous les messages de notification de modification de mot de passe, ainsi que les options d'analyse et de planification. Effectuez les étapes de la procédure suivante pour configurer les paramètres de modification automatique de mot de passe à l'aide de l'Administration centrale.

Pour configurer les paramètres de modification automatique de mot de passe à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est administrateur de collection de sites.

  2. Dans le site Web Administration centrale, cliquez sur Sécurité.

  3. Sous Sécurité générale, cliquez sur Configurer les paramètres de modification de mot de passe.

  4. Dans la section Adresse de messagerie pour les notifications de la page Paramètres de gestion des mots de passe, entrez l'adresse de messagerie d'une personne ou d'un groupe qui doit être informé(e) de tout événement d'expiration ou de modification de mot de passe imminent.

  5. Si la modification automatique du mot de passe n'est pas configurée pour un compte géré, entrez une valeur numérique dans la section Paramètres du processus d'analyse de compte qui indique combien de jours avant l'expiration du mot de passe une notification sera envoyée à l'adresse de messagerie configurée dans la section Adresse de messagerie pour les notifications.

  6. Dans la section Paramètres de modification automatique du mot de passe, entrez une valeur qui indique le nombre de secondes pendant lesquelles la modification automatique du mot de passe patientera (après avoir informé les services d'une modification de mot de passe en attente) avant d'initier la modification. Entrez une valeur qui indique le nombre de tentatives de modification du mot de passe effectuées avant l'arrêt du processus.

  7. Cliquez sur OK.

Résolution des problèmes liés à la modification automatique du mot de passe

Utilisez les conseils suivants pour éviter les problèmes les plus courants qui peuvent se produire lorsque vous configurez la modification automatique du mot de passe.

Non-correspondance des mots de passe

En cas d'échec de la modification automatique du mot de passe en raison d'une non-correspondance entre les services de domaine Active Directory (AD DS) et SharePoint Foundation 2010, le processus de modification du mot de passe peut provoquer un refus d'accès lors de la connexion, un verrouillage de compte ou des erreurs de lecture AD DS. Si l'un de ces problèmes se produit, vérifiez que vos mots de passe AD DS sont configurés correctement et que le compte AD DS dispose d'un accès en lecture pour l'installation. Utilisez Windows PowerShell pour corriger tout problème lié à la non-correspondance des mots de passe, puis poursuivez le processus de modification de mot de passe.

Pour corriger un problème de non-correspondance des mots de passe

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes. Cliquez sur Produits Microsoft SharePoint 2010.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> -ExistingPassword <SecureString> -UseExistingPassword $true

    Pour plus d'informations, voir Set-SPManagedAccount.

Échec de mise en service de compte de service

Si la (re)mise en service de compte échoue sur un ou plusieurs serveurs de la batterie, vérifiez l'état du service du minuteur. Si celui-ci est arrêté, redémarrez-le. Vous pouvez utiliser la commande Stsadm suivante pour démarrer immédiatement les travaux d'administration du service du minuteur : stsadm -o execadmsvcjobs

Si le redémarrage du service du minuteur ne résout pas le problème, utilisez Windows PowerShell pour réparer le compte géré sur chaque serveur de la batterie ayant subi un échec de mise en service.

Pour résoudre un problème d'échec de mise en service de compte de service

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes. Cliquez sur Produits Microsoft SharePoint 2010.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Repair-SPManagedAccountDeployment

    Pour plus d'informations, voir Repair-SPManagedAccountDeployment.

Si la procédure précédente ne résout pas le problème d'échec de mise en service de compte de service, il est probable que la clé de chiffrement de batterie ne puisse pas être déchiffrée. Si ceci est bien la cause du problème, utilisez Windows PowerShell pour mettre à jour la phrase secrète du serveur local de sorte qu'elle corresponde à celle de la batterie.

Pour mettre à jour la phrase secrète du serveur local

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes. Cliquez sur Produits Microsoft SharePoint 2010.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPPassPhrase -PassPhrase <SecureString> -ConfirmPassPhrase <SecureString> -LocalServerOnly $true

    Pour plus d'informations, voir Set-SPPassPhrase.

Expiration imminente de mots de passe

Si le mot de passe est sur le point d'expirer mais que la modification automatique du mot de passe n'a pas été configurée pour ce compte, utilisez Windows PowerShell pour mettre à jour le mot de passe du compte avec une nouvelle valeur qui peut être choisie par l'administrateur ou générée automatiquement. Après la mise à jour du mot de passe du compte, vérifiez que le service du minuteur est démarré et que le service Administrateur est activé sur tous les serveurs de la batterie. Ensuite, la modification de mot de passe peut être propagée à tous les serveurs de la batterie.

Pour mettre à jour le mot de passe du compte

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes. Cliquez sur Produits Microsoft SharePoint 2010.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. Pour mettre à jour le mot de passe du compte avec une nouvelle valeur choisie par l'administrateur, depuis l'invite de commandes Windows PowerShell, tapez ce qui suit :

    Code de copie
    Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> -Password <SecureString>

  5. Pour mettre à jour le mot de passe du compte avec une nouvelle valeur générée automatiquement, depuis l'invite de commandes Windows PowerShell, tapez ce qui suit :

    Code de copie
    Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> -AutoGeneratePassword $true

    Pour plus d'informations, voir Set-SPManagedAccount.

Nécessité de modifier le compte de batterie en un autre compte

Si vous devez modifier le compte de batterie en un autre compte, utilisez la commande Stsadm suivante : stsadm.exe -o updatefarmcredentials -userlogin DOMAIN\username -password password

Historique des modifications


Modifier les mots de passe pour les services SQL Server (SharePoint Foundation 2010)

Le service SQL Server et le service SQL Server Agent doivent être associés à des comptes Windows pour s'exécuter. Si les comptes ont des mots de passe, c'est à dire s'ils sont différents du compte Système local, du compte Service local ou du compte Service réseau, vous devez mettre à jour le mot de passe pour le service lorsque le mot de passe de compte change.

Important :
Effectuez ces procédures au cours d'une période de maintenance planifiée. Lorsque vous modifierez le mot de passe, vous devrez redémarrer le service. SharePoint Foundation ne pourra pas se connecter à la base de données pendant la durée d'indisponibilité du service.

Important :
Ne modifiez pas les mots de passe des comptes de service lorsqu'un nœud de cluster de basculement est hors connexion. Sinon, vous devrez réinitialiser le mot de passe une nouvelle fois lorsque les nœuds seront à nouveau en ligne.

Dans cet article :

  • Modifier le mot de passe du service SQL Server

  • Modifier le mot de passe du service SQL Server Agent

Modifier le mot de passe du service SQL Server

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour modifier le mot de passe du service SQL Server, vous devez être membre du groupe Administrateurs sur l'ordinateur qui exécute SQL Server.

  2. Cliquez sur Démarrer, puis sur Gestionnaire de serveur.

  3. Dans le volet de navigation de la fenêtre Gestionnaire de serveur, développez Configuration, puis cliquez sur Services.

  4. Dans le volet du milieu, cliquez avec le bouton droit sur le service intitulé SQL Server (MSSQLSERVER), puis cliquez sur Propriétés.

  5. Dans la boîte de dialogue Propriétés, sous l'onglet Connexion, tapez le nouveau mot de passe dans les zones Mot de passe et Confirmer le mot de passe.

  6. Vous devez redémarrer le service pour enregistrer les modifications. Sous l'onglet Général, sous État du service, cliquez sur Arrêter pour arrêter le service.

  7. Si une boîte de dialogue s'affiche pour vous indiquer que d'autres services vont aussi s'arrêter, cliquez sur Oui pour arrêter les services dépendants.

  8. Lorsque le service s'est arrêté, cliquez sur Démarrer pour démarrer le service.

  9. Cliquez sur OK pour enregistrer les modifications.

Modifier le mot de passe du service SQL Server Agent

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour modifier le mot de passe du service SQL Server Agent, vous devez appartenir au groupe Administrateurs sur l'ordinateur qui exécute SQL Server.

  2. Cliquez sur Démarrer, puis sur Gestionnaire de serveur.

  3. Dans le volet de navigation de la fenêtre Gestionnaire de serveur, développez Configuration, puis cliquez sur Services.

  4. Dans le volet du milieu, cliquez avec le bouton droit sur le service intitulé SQL Server Agent (MSSQLSERVER), puis cliquez sur Propriétés.

  5. Dans la boîte de dialogue Propriétés, sous l'onglet Connexion, tapez le nouveau mot de passe dans les zones Mot de passe et Confirmer le mot de passe.

  6. Vous devez redémarrer le service pour enregistrer les modifications. Sous l'onglet Général, sous État du service, cliquez sur Arrêter pour arrêter le service.

  7. Si une boîte de dialogue s'affiche pour vous indiquer que d'autres services vont aussi s'arrêter, cliquez sur Oui pour arrêter les services dépendants.

  8. Lorsque le service s'est arrêté, cliquez sur Démarrer pour démarrer le service.

  9. Cliquez sur OK pour enregistrer les modifications.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Modifier le mot de passe du compte d'accès au contenu par défaut (SharePoint Foundation 2010).

Cette procédure vous permet de modifier le mot de passe du compte d'accès au contenu par défaut. Ce compte est le compte utilisé pour analyser du contenu. Il peut être remplacé en spécifiant un autre compte au moyen d'une règle d'analyse. Ce compte doit avoir l'autorisation en lecture pour le contenu analysé par le compte. Il est recommandé de limiter l'accès au contenu du compte en lecture seule. Si le mot de passe du compte expire et n'est pas mis à jour, la fonctionnalité de recherche ne pourra pas analyser le contenu.

Vous ne devez modifier le mot de passe du compte d'accès au contenu que s'il a été changé dans Active Directory. Les informations d'identification entrées sont vérifiées par rapport à celles du contrôleur de domaine. Si vous entrez le nouveau mot de passe avant que le mot de passe ne soit modifié sur le contrôleur de domaine, une erreur se produit et les paramètres ne sont pas modifiés.

Remarque :
Cette procédure modifie uniquement le mot de passe du compte d'accès au contenu par défaut. Si vous avez spécifié un autre compte dans une règle d'analyse, et si vous souhaitez modifier le mot de passe de ce compte, vous devez changer la règle d'analyse.

Modifier le mot de passe du compte d'accès au contenu par défaut

Suivez ces étapes pour configurer le mot de passe du compte d'accès au contenu par défaut sur l'ordinateur qui exécute l'Administration Centrale SharePoint.

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour modifier le mot de passe du compte d'accès au contenu par défaut, vous devez appartenir au groupe Administrateurs de batterie (groupe de sécurité Windows WSS_RESTRICTED_WPG).

  2. Vérifiez que le service SPAdmin s'exécute sur tous les serveurs de la batterie.

  3. Dans la page d'accueil du site Web Administration Centrale de SharePoint, sous Paramètres système, sélectionnez Gérer les services sur le serveur.

  4. Cliquez sur Recherche de SharePoint Foundation.

  5. Dans la page Configurer les paramètres du service Recherche de Microsoft SharePoint Foundation, dans la section Compte d'accès au contenu, tapez le nouveau mot de passe dans la zone Mot de passe.

  6. Cliquez sur OK pour enregistrer les modifications.

  7. Vous pouvez aussi désactiver le service SPAdmn sur les serveurs de la batterie où vous ne souhaitez pas exécuter le service.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Configure People Picker (SharePoint Foundation 2010) (en anglais)

People Picker is configured at the zone level for a farm by using the Stsadm setproperty operation. By configuring the settings for the control, you can filter and restrict the results that are displayed when a user searches for a user, group, or claim. Those settings will apply to every site within the site collection.

The information in this article applies only to Web applications that use Windows authentication in either classic mode or claims mode.

The People Picker control is used to find and select users, groups, and claims when a site, list, or library owner assigns permissions in Microsoft SharePoint Foundation 2010. People Picker is configured at the zone level for a farm by using the Stsadm setproperty operation. By configuring the settings for the control, you can filter and restrict the results that are displayed when a user searches for a user, group or claim. Those settings will apply to every site within the site collection. For more information about the People Picker properties, see Peoplepicker: Stsadm properties.

Remarque :
There are no Windows PowerShell commands to configure People Picker.

This article contains information about how to configure People Picker for specific scenarios. For more information about the People Picker control and how it works, its relationship to authentication and claim providers, and how to plan for People Picker, see People Picker overview (SharePoint Foundation 2010) (en anglais).

Before you perform the procedures in this article, you must do the following:

  • Verify that the account you use to run Stsadm is a member of the local Administrators group on the server on which SharePoint Foundation 2010 is installed.

  • Open the command prompt window as an administrator to perform the procedures in this article.

  • In the command prompt on the driver where SharePoint Foundation 2010 is installed, change to the following directory: %COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\14\Bin.

In this article:

  • Check the setting value for any property

  • Clear a property value from People Picker

  • Set an encryption key for use with a one-way trust

  • Enable cross-forest or cross-domain queries when using a one-way trust

  • Restrict People Picker to a certain group in Active Directory

  • Define the location of administrator accounts

  • Force People Picker to pick only from users in the site collection

  • Filter Active Directory accounts by using LDAP queries

  • Return only non-Active Directory user accounts

Check the setting value for any property

To check the setting for any People Picker property, type the following command:

stsadm.exe -o getproperty -pn <Property Name> -url <Web application URL>

For more information, see Peoplepicker: Stsadm properties (http://technet.microsoft.com/en-us/library/cc263318(office.12).aspx).

Clear a property value from People Picker

You can remove the setting for a People Picker property by specifying the property name you want to clear, and using empty quotation marks for the property value.

To remove a property setting from People Picker, type the following command:

stsadm.exe -o setproperty -pn <Property Name> -pv "" -url <Web application URL>

For more information, see Peoplepicker-searchadforests: Stsadm property (http://technet.microsoft.com/en-us/library/cc263460(office.12).aspx).

Set an encryption key for use with a one-way trust

If the forest or domain on which SharePoint Foundation 2010 is installed has a one-way trust with another forest or domain, you must first set the credentials for an account that is allowed to authenticate with the forest or domain to be queried before you can use the Stsadm peoplepicker-searchadforests property.

Remarque :
The encryption key must be set on every front-end Web server in the farm on which SharePoint Foundation 2010 is installed.

To set an encryption key, type the following command:

stsadm.exe -o setapppassword -password <key>

For more information about querying additional forests or domains, see All you want to know about People Picker in SharePoint ( Functionality | Configuration | Troubleshooting ) Part-2 (http://go.microsoft.com/fwlink/?LinkId=207666).

Enable cross-forest or cross-domain queries when using a one-way trust

If the forest or domain on which SharePoint Foundation 2010 is installed has a one-way trust with another forest or domain, you must specify the credentials to be used to query the forest or domain, in addition to the names of the forests or domains to be queried. People Picker will only query the forests or domains that you specify in the peoplepicker-searchadforests property setting.

To specify the forests or domains to be queried along with the credentials, type the following command:

stsadm.exe -o setproperty -pn peoplepicker-searchadforests -pv <Valid list of forests or domains, Login name, Password> -url <Web application URL>

Remarque :
You do not need to include the encryption key password that you assigned to the account when you use the peoplepicker-searchadforests property. However, if you have not already set an encryption key for the account, en error message will be displayed.

The following example configures People Picker for use with a forest named Contoso.com and a domain named Fabrikam.com, and includes the credentials for each:

Code de copie
STSADM.exe -o setproperty -pn peoplepicker-searchadforests -pv "forest:Contoso.com,Contoso\User1,Password1; domain:Fabrikam.com,Fabrikam\User2,Password2" -url http://ServerName

For more information, see Peoplepicker-searchadforests: Stsadm property (http://technet.microsoft.com/en-us/library/cc263460(office.12).aspx).

Restrict People Picker to a certain group in Active Directory

If a Web application is using Windows authentication and the site user directory path is not set, the People Picker control searches the entire Active Directory to resolve users' names or find users, instead of searching only users within a particular organizational unit (OU). The Stsadm setsiteuseraccountdirectorypath operation allows the user's directory path to be set to a specific OU in the same domain. After the directory path is set to a site collection, the People Picker control will only search under that particular OU.

To restrict People Picker to a certain OU in Active Directory, type the following command:

stsadm -o setsiteuseraccountdirectorypath -path <Valid OU name> -url <Web application URL>

The following example configures People Picker to only return users and groups in the OU named "Sales":

Code de copie
stsadm -o setsiteuseraccountdirectorypath -path "OU=Sales,DC=ContosoCorp,DC=local" -url http://ServerName
Remarque :
Because this property specifies only one OU at a time, you should only run the Stsadm setsiteuseraccountdirectorypath operation once per site collection. To set multiple OUs at one time, use the Stsadm Peoplepicker-serviceaccountdirectorypaths property.

For more information, see Setsiteuseraccountdirectorypath: Stsadm operation (http://technet.microsoft.com/en-us/library/cc263328(office.12).aspx).

Define the location of administrator accounts

Administrative user accounts are often located in a different OU from regular site users. If you have used the Stsadm setsiteuseraccountdirectorypath operation to force People Picker to only return query results from a specific OU, you must also set the Stsadm peoplepicker-serviceaccountdirectorypaths property so the administrator can manage the site collection.

Remarque :
Before the peoplepicker-serviceaccountdirectorypaths property will work, the Setsiteuseraccountdirectorypath operation must be set and contain a value.

To define the location of administrator accounts, type the following command:

Stsadm -o setproperty -pn peoplepicker-serviceaccountdirectorypaths -pv <A list of OU names> -url <Web application URL>

The following example configures People Picker to allow users that are in the OU "FarmAdmin":

Code de copie
stsadm -o setproperty -pn peoplepicker-serviceaccountdirectorypaths -pv "OU=FarmAdmin,DC=Contoso,DC=local" -url http://ServerName

For more information, see Peoplepicker-serviceaccountdirectorypaths: Stsadm property (http://technet.microsoft.com/en-us/library/cc263012(office.12).aspx).

Force People Picker to pick only from users in the site collection

The People Picker control consists of a text box, and two buttons; the Check Names button and the Browse button. The Check Names button is used to resolve a user name, group name or e-mail address exactly as it was typed into the text box. The Browse button opens the Select People and Groups dialog box, which can be used to submit a query for a full or partial string. The important difference between the two is that the Check Names button only resolves exactly what is in the text box, whereas the Select People and Groups dialog box searches for the query string. You can force People Picker to only return users who have permissions in the site collection by using either the PeoplePicker-Peopleeditoronlyresolvewithinsitecollection property or the PeoplePicker-Onlysearchwithinsitecollection property. However, the property you use to configure this restriction will depend on whether you want to set the restriction for the text box (People editor) and Check Names button, or for the Select People and Groups dialog box.

To force People Picker to only return users who have permissions in the site collection when the Check Names button is clicked, type the following command:

stsadm -o setproperty -pn peoplepicker-Peopleeditoronlyresolvewithinsitecollection -pv yes -url <Web application URL>

To force People Picker to only return users who have permissions in the site collection when the Select People and Groups dialog box is used, type the following command:

stsadm -o setproperty -pn peoplepicker-onlysearchwithinsitecollection -pv yes -url <Web application URL>

For more information, see Peoplepicker-onlysearchwithinsitecollection: Stsadm property (http://technet.microsoft.com/en-us/library/cc261988(office.12).aspx) and Peoplepicker-peopleeditoronlyresolvewithinsitecollection: Stsadm property (SharePoint Foundation 2010) (en anglais).

Filter Active Directory accounts by using LDAP queries

You can use a Lightweight Directory Access Protocol (LDAP) query to create a custom filter for displaying query results. For more information about LDAP queries, see LDAP Query Basics (http://go.microsoft.com/fwlink/?LinkId=207670).

To use a custom LDAP query, type the following command:

Stsadm -o setproperty -pn peoplepicker-searchadcustomfilter -pv <LDAP query filter> -url <Web application URL>

The following example filters out user accounts that do not have e-mail addresses, or that are disabled. Because security groups do not always have e-mail addresses associated with them, an OR statement is used to ensure that security groups are still included in the query results:

Code de copie
stsadm -o setproperty -pn peoplepicker-searchadcustomfilter -pv "(|(&(mail=*)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))(objectcategory=group))" -url http://ServerName

The following example only returns active users, and not groups:

Code de copie
stsadm -o setproperty -pn peoplepicker-searchadcustomfilter -pv "(&(objectCategory=person)(objectClass=user)(!userAccountControl:1.2.840.113556.1.4.803:=2))" -url http://ServerName

For an explanation of the user account control string used in this query, see Search Filter Syntax (http://go.microsoft.com/fwlink/?LinkId=210020).

The following example returns a list of Active Directory users with the title "Manager":

Code de copie
stsadm -o setproperty -pn peoplepicker-searchadcustomfilter -pv "((Title=Manager))" -url http://ServerName
Important :
Remember that every time you run the setproperty command for a specific property, that property's current values will be overwritten by the new values you specify. If you need to filter query results based on multiple criteria, you will need to build a compound LDAP query that includes all the values for which you want to filter.

For more information, see Peoplepicker-searchadcustomfilter: Stsadm property (http://technet.microsoft.com/en-us/library/cc263452(office.12).aspx).

Return only non-Active Directory user accounts

If your Web application uses forms-based authentication, you can prevent People Picker from returning Active Directory accounts in the query results.

To return only non-Active Directory user accounts, type the following command:

stsadm -o setproperty -pn peoplepicker-nowindowsaccountsfornonwindowsauthenticationmode -pv yes -url <Web application URL>

For more information, see Peoplepicker-nowindowsaccountsfornonwindowsauthenticationmode: Stsadm property (http://technet.microsoft.com/en-us/library/cc263264(office.12).aspx).

Historique des modifications

Date | Description | Raison
2011/01/31 | Publication initiale |


À propos des applications de service et des services (SharePoint Foundation 2010)

Dans Microsoft SharePoint Foundation 2010, les services individuels peuvent être configurés indépendamment, et des sociétés tierces peuvent ajouter des services à la plateforme. L'infrastructure des services vous permet de contrôler quels services sont déployés et comment ces derniers sont partagés.

Les services déployés sont nommés applications de service. Une application de service fournit une ressource qui peut être partagée entre les sites au sein d'une batterie de serveurs ou parfois sur plusieurs batteries de serveurs et qui peut être accessible aux utilisateurs via une application Web d'hébergement. Les applications de service sont associées aux applications Web par des connexions aux applications de service. Certains services peuvent être partagés entre batteries.

Pour plus d'informations sur la structure logique des services et des applications de service, voir Planification de l'architecture des services (SharePoint Foundation 2010).

Pour plus d'informations sur la gestion des applications de service, notamment des instructions pour la publication des applications de service entre batteries, voir Gérer les applications de service (SharePoint Foundation 2010) and Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010).

Pour plus d'informations sur le démarrage, l'arrêt et la configuration de services, Gérer les services sur le serveur (SharePoint Foundation 2010).

Historique des modifications


Gérer les applications de service (SharePoint Foundation 2010)
Voir aussi

Microsoft SharePoint Foundation 2010 inclut un ensemble d'applications de service qui vous permettent de partager des services entre les applications Web. Dans certains cas, vous pouvez également partager des applications de service entre les batteries de serveurs. Vous pouvez gérer les applications de service à l'aide de l'Administration centrale ou via Windows PowerShell 2.0.

Les articles suivants de cette section fournissent des instructions générales pour les applications de service :

  • Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010)

    Dans SharePoint Foundation 2010, vous pouvez partager des applications de service entre des batteries de serveurs. Cet article explique comment établir une relation d'approbation entre des batteries de serveurs, publier une application de service et se connecter à une application de service publiée dans une batterie de serveurs distante.

  • Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010)

    Cet article explique comment configurer une connexion d'application de service, ou proxy, à une application Web. Une application de service est accessible aux utilisateurs uniquement par le biais de sa connexion à une application Web. Par défaut, toutes les applications de service font partie du groupe de connexions par défaut.

  • Restreindre ou autoriser l'accès à une application de service (SharePoint Foundation 2010)

    Par défaut, toutes les applications de service de la batterie de serveurs locale sont accessibles à l'ensemble des applications Web de la batterie de serveurs locale. Toutefois, vous pouvez restreindre l'accès à une application de service de sorte qu'elle soit disponible uniquement pour les applications Web spécifiées. Cet article explique comment restreindre ou activer l'accès à une application de service.

  • Affecter ou supprimer les administrateurs d'une application de service (SharePoint Foundation 2010)

    Dans SharePoint Foundation 2010, vous pouvez affecter des administrateurs supplémentaires à une application de service. Cet article explique comment procéder.

  • Supprimer une application de service (SharePoint Foundation 2010)

    Vous pouvez supprimer une application de service qui n'est plus utilisée. Cet article contient des instructions pour réaliser cette opération.

Vous pouvez créer, configurer et gérer l'application du service Business Data Connectivity. Pour plus d'informations, voir Administration du service Connexion de données métiers (SharePoint Foundation 2010).

Voir aussi

Concepts

À propos des applications de service et des services (SharePoint Foundation 2010)
Planification de l'architecture des services (SharePoint Foundation 2010)

Historique des modifications


Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010)
Voir aussi

Dans Microsoft SharePoint Foundation 2010, certaines applications de service peuvent être partagées entre les batteries de serveurs. Cet article décrit le processus et les avertissements relatifs au partage des applications de service.

En publiant une application de service, vous pouvez optimiser les ressources, éviter la redondance et fournir des services à l'échelle de l'entreprise sans installer une batterie de serveurs de services d'entreprise dédiée. Vous pouvez publier l'application de service Business Data Connectivity dans une batterie de serveurs SharePoint Foundation 2010.

La batterie de serveurs qui contient et publie l'application de service de sorte que les autres batteries de serveurs puissent utiliser l'application de service s'appelle une batterie de serveurs de publication. La batterie de serveurs qui se connecte à un emplacement distant pour utiliser une application de service hébergée à l'emplacement distant s'appelle une batterie de serveurs consommatrice.

Remarque :
Si vous êtes habitué à Microsoft Office SharePoint Server 2007, il peut s'avérer pertinent de considérer la batterie de serveurs de publication comme la batterie de serveurs parente et la batterie de serveurs consommatrice comme une batterie de serveurs enfant.

Cet article décrit les étapes requises pour la publication et l'utilisation des applications de service au sein des batteries de serveurs. Ces étapes doivent être effectuées dans l'ordre indiqué.

  1. Échangez les certificats d'approbation entre les batteries de serveurs.

    Pour commencer, un administrateur de la batterie de serveurs consommatrice doit fournir deux certificats d'approbation à l'administrateur de la batterie de serveurs de publication : un certificat racine et un certificat de service d'émission de jeton de sécurité (STS). En outre, un administrateur de la batterie de serveurs de publication doit fournir un certificat racine à l'administrateur de la batterie de serveurs consommatrice. En échangeant les certificats, chaque batterie de serveurs reconnaît que l'autre batterie de serveurs est fiable.

    Pour plus d'informations, voir Échanger des certificats d'approbation entre batteries de serveurs (SharePoint Foundation 2010).

  2. Dans la batterie de serveurs de publication, publiez l'application de service.

    Dans la batterie de serveurs où se trouve l'application de service, un administrateur doit publier explicitement l'application de service. Les applications de service qui ne sont pas publiées explicitement ne sont disponibles que pour la batterie de serveurs locale.

    Pour plus d'informations, voir Publier une application de service (SharePoint Foundation 2010).

  3. Dans la batterie de serveurs consommatrice, connectez-vous à l'application de service distante.

    Une fois que la batterie de serveurs de publication a publié l'application de service, un administrateur de la batterie de serveurs consommatrice peut se connecter à cette application de service à partir de la batterie de serveurs consommatrice, si l'adresse de l'application de service spécifique est connue.

    Pour plus d'informations, voir Se connecter à une application de service sur une batterie de serveurs distante (SharePoint Foundation 2010).

    Important :
    Vous ne pouvez pas partager une application de service de profil utilisateur entre des batteries de serveurs qui résident dans des domaines distincts, sauf si vous établissez au préalable une relation d'approbation au niveau du domaine entre les deux domaines.

  4. Ajoutez l'application de service partagée à un groupe de proxys d'application Web dans la batterie de serveurs consommatrice.

    Un administrateur doit associer la nouvelle connexion de l'application de service à une application Web locale dans la batterie de serveurs consommatrice. Seules les applications Web configurées pour tirer parti de cette association peuvent utiliser l'application de service distante.

    Pour plus d'informations sur la configuration d'une connexion de groupe de proxys d'application Web, voir Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010).

    Remarque :
    Il est important de planifier la structure du groupe de proxys avant d'ajouter des applications de service à des groupes de proxys. Pour plus d'informations sur la planification de l'architecture de l'application de service, voir Design logical architecture (Windows SharePoint Services) et Planification de l'architecture des services (SharePoint Foundation 2010).

Voir aussi

Concepts

Diagrammes techniques (SharePoint Foundation 2010)

Historique des modifications


Échanger des certificats d'approbation entre batteries de serveurs (SharePoint Foundation 2010)
Voir aussi

Dans Microsoft SharePoint Foundation 2010, une batterie de serveurs SharePoint peut se connecter à une application de service qui est publiée sur une autre batterie de serveurs SharePoint Foundation 2010, et l'utiliser. Pour ce faire, les batteries de serveurs doivent échanger des certificats d'approbation.

Cet article décrit comment échanger des certificats d'approbation entre la batterie de serveurs de publication et la batterie de serveurs consommatrice. Notez que les deux batteries doivent participer à cet échange pour que le partage de l'application de service fonctionne.

Important :
Avant que vous ne commenciez à partager des applications de service, il est fortement recommandé de lire les articles Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010) et Planification de l'architecture des services (SharePoint Foundation 2010).

Vous devez utiliser les commandes Windows PowerShell 2.0 pour exporter et copier les certificats entre les batteries de serveurs. Une fois les certificats exportés et copiés, vous pouvez utiliser les commandes Windows PowerShell 2.0 ou l'Administration centrale pour gérer les relations d'approbation au sein de la batterie de serveurs.

Les instructions fournies ici supposent les critères suivants :

  • Que les serveurs qui sont utilisés pour ces procédures exécutent Windows PowerShell 2.0.

  • Que l'administrateur sélectionne et utilise le même serveur dans chaque batterie de serveurs pour toutes les étapes du processus.

  • Si le contrôle de compte d'utilisateur est activé, vous devez exécuter les commandes Windows PowerShell 2.0 avec des privilèges élevés.

Dans cet article :

  • Exportation et copie de certificats

  • Gestion des certificats d'approbation à l'aide de Windows PowerShell

  • Gestion des certificats d'approbation à l'aide de l'Administration centrale

Exportation et copie de certificats

Un administrateur de la batterie de serveurs consommatrice doit fournir deux certificats d'approbation à la batterie de serveurs de publication : un certificat racine et un certificat du service de jeton de sécurité (STS). Un administrateur de la batterie de serveurs de publication doit fournir un certificat racine à la batterie de serveurs consommatrice.

Vous ne pouvez qu'exporter et copier des certificats à l'aide de Windows PowerShell 2.0.

Pour exporter le certificat racine de la batterie de serveurs consommatrice

  1. Sur un serveur qui exécute SharePoint Foundation 2010 sur la batterie de serveurs consommatrice, vérifiez que vous remplissez les conditions minimales suivantes : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. Depuis l'invite de commandes Windows PowerShell, tapez chacune des commandes suivantes :

    Code de copie
    $rootCert = (Get-SPCertificateAuthority).RootCertificate
    Code de copie
    $rootCert.Export("Cert") | Set-Content <C:\ConsumingFarmRoot.cer> -Encoding byte

    Où <C:\ConsumingFarmRoot.cer> est le chemin d'accès du certificat racine.

Pour exporter le certificat STS de la batterie de serveurs consommatrice

  1. Depuis l'invite de commandes Windows PowerShell, tapez les commandes suivantes :

    Code de copie
    $stsCert = (Get-SPSecurityTokenServiceConfig).LocalLoginProvider.SigningCertificate
    Code de copie
    $stsCert.Export("Cert") | Set-Content <C:\ConsumingFarmSTS.cer> -Encoding byte

    Où <C:\ConsumingFarmSTS.cer> est le chemin d'accès du certificat STS.

Pour exporter le certificat racine de la batterie de serveurs de publication

  1. Sur un serveur qui exécute SharePoint Foundation 2010 sur la batterie de serveurs de publication, vérifiez que vous remplissez les conditions minimales suivantes : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. Depuis l'invite de commandes Windows PowerShell, tapez les commandes suivantes :

    Code de copie
    $rootCert = (Get-SPCertificateAuthority).RootCertificate
    Code de copie
    $rootCert.Export("Cert") | Set-Content <C:\PublishingFarmRoot.cer> -Encoding byte

    Où <C:\PublishingFarmRoot.cer> est le chemin d'accès du certificat racine.

Pour copier les certificats

  1. Copiez le certificat racine et le certificat STS du serveur de la batterie consommatrice sur le serveur de la batterie de publication.

  2. Copiez le certificat racine du serveur dans la batterie de serveurs de publication vers l'un des serveurs de la batterie de serveurs consommatrice.

Gestion des certificats d'approbation à l'aide de Windows PowerShell

La gestion des certificats d'approbation dans une batterie de serveurs implique l'établissement d'une relation d'approbation. Cette section explique comment établir une relation d'approbation pour les batteries de serveurs consommatrice et de publication à l'aide des commandes Windows PowerShell 2.0.

Établir l'approbation sur la batterie de serveurs consommatrice

Pour établir l'approbation sur la batterie consommatrice, vous devez importer le certificat racine qui a été copié à partir de la batterie de serveurs de publication et créer une autorité racine approuvée.

Pour importer le certificat racine et créer une autorité racine approuvée sur la batterie consommatrice

  1. Depuis l'invite de commandes Windows PowerShell d'un serveur de la batterie de serveurs consommatrice, tapez les commandes suivantes :

    Code de copie
    $trustCert = Get-PfxCertificate <C:\PublishingFarmRoot.cer>
    Code de copie
    New-SPTrustedRootAuthority <PublishingFarm> -Certificate $trustCert

Où :

  • <C:\PublishingFarmRoot.cer> est le chemin d'accès du certificat racine que vous avez copié sur la batterie de serveurs consommatrice à partir de la batterie de serveurs de publication.

  • <PublishingFarm> est un nom unique identifiant la batterie de serveurs de publication. Chaque autorité racine approuvée doit avoir un nom unique.

Établir l'approbation sur la batterie de serveurs de publication

Pour établir l'approbation sur la batterie de serveurs de publication, vous devez importer le certificat racine qui a été copié à partir de la batterie de serveurs consommatrice et créer une autorité racine approuvée. Vous devez ensuite importer le certificat STS qui été copié à partir de la batterie consommatrice et créer un émetteur de jeton de service approuvé.

Pour importer le certificat racine et créer une autorité racine approuvée sur la batterie de publication

  1. Depuis l'invite de commandes Windows PowerShell d'un serveur de la batterie de serveurs de publication, tapez les commandes suivantes :

    Code de copie
    $trustCert = Get-PfxCertificate <C:\ConsumingFarmRoot.cer>
    Code de copie
    New-SPTrustedRootAuthority <ConsumingFarm> -Certificate $trustCert

Où :

  • <C:\ConsumingFarmRoot.cer> est le nom et l'emplacement du certificat racine que vous avez copié sur la batterie de serveurs de publication à partir de la batterie de serveurs consommatrice.

  • <ConsumingFarm> est un nom unique identifiant la batterie de serveurs consommatrice. Chaque autorité racine approuvée doit avoir un nom unique.

Pour importer le certificat STS et créer un émetteur de jeton de service approuvé sur la batterie de publication

  1. Depuis l'invite de commandes Windows PowerShell d'un serveur de la batterie de serveurs de publication, tapez les commandes suivantes :

    Code de copie
    $stsCert = Get-PfxCertificate <c:\ConsumingFarmSTS.cer>
    Code de copie
    New-SPTrustedServiceTokenIssuer <ConsumingFarm> -Certificate $stsCert

Où :

  1. <C:\ConsumingFarmSTS.cer> est le chemin d'accès du certificat STS que vous avez copié sur la batterie de serveurs de publication à partir de la batterie de serveurs consommatrice.

  2. <ConsumingFarm> est un nom unique identifiant la batterie de serveurs consommatrice. Chaque émetteur de jeton de service approuvé doit avoir un nom unique.

Pour plus d'informations sur ces applets de commande Windows PowerShell 2.0, voir les articles suivants :

  • Get-SPCertificateAuthority

  • Get-SPSecurityTokenServiceConfig

  • New-SPTrustedRootAuthority

  • New-SPTrustedServiceTokenIssuer

  • Get-PfxCertificate (http://go.microsoft.com/fwlink/?linkid=178943&clcid=0x40C)

Gestion des certificats d'approbation à l'aide de l'Administration centrale

Vous pouvez gérer les relations d'approbation d'une batterie de serveurs uniquement après que les certificats appropriés ont été exportés et copiés vers la batterie.

Pour établir une relation d'approbation à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Sécurité.

  3. Dans la page Sécurité, dans la section Sécurité générale, cliquez sur Gérer la relation d'approbation.

  4. Dans la page Relation d'approbation, dans le ruban, cliquez sur Nouveau.

  5. Dans la page Établir une relation d'approbation :

    1. Indiquez un nom qui décrit la finalité de la relation d'approbation.

    2. Accédez au certificat d'autorité racine et sélectionnez ce dernier pour la relation d'approbation. Il doit s'agir du certificat d'autorité racine exporté à partir de l'autre batterie de serveurs à l'aide de Windows PowerShell, comme indiqué dans Exportation et copie de certificats.

    3. Si vous effectuez cette tâche sur la batterie de serveurs de publication, activez la case à cocher correspondant à Fournir la relation d'approbation. Tapez un nom descriptif pour l'émetteur de jeton, puis recherchez et sélectionnez le certificat STS copié à partir de la batterie de serveurs consommatrice, comme indiqué dans Exportation et copie de certificats.

    4. Cliquez sur OK.

    Une fois la relation d'approbation établie, vous pouvez modifier la description de l'émetteur de jeton ou les certificats utilisés en cliquant sur la relation d'approbation, puis sur Modifier. Vous pouvez supprimer une relation d'approbation en cliquant sur cette dernière, puis sur Supprimer.

Voir aussi

Concepts

Configurer l'authentification par revendications (SharePoint Foundation 2010)
Configurer le service de jeton de sécurité (SharePoint Foundation 2010)

Autres ressources

Planifier l'authentification par revendications (SharePoint Foundation 2010)

Historique des modifications


Publier une application de service (SharePoint Foundation 2010)
Voir aussi

Dans Microsoft SharePoint Foundation 2010, certaines applications de service peuvent être publiées sur des batteries de serveurs et ainsi être rendues disponibles via des connexions à distance. Cet article explique comment publier une application de service.

Important :
Avant que vous ne commenciez à partager des applications de service, il est fortement recommandé de lire les articles Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010) et Planification de l'architecture des services (SharePoint Foundation 2010).

Dans cet article :

  • Pour publier une application de service à l'aide de l'Administration centrale

  • Pour publier une application de service à l'aide de Windows PowerShell

Pour publier une application de service à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie SharePoint.

  2. Sur le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications, puis sur Gérer les applications de service.

  3. Cliquez sur la ligne qui contient l'application de service que vous souhaitez publier. Les commandes du ruban deviennent disponibles.

  4. Sur le ruban, cliquez sur Publier.

  5. Dans la boîte de dialogue Publier une application de service :

    1. Sélectionnez le Type de connexion souhaité dans la liste déroulante.

    2. Si vous souhaitez que l'application de service soit disponible pour les batteries de serveurs distantes, activez la case à cocher Publier cette application de service sur d'autres batteries de serveurs.

    3. Il est recommandé de suivre les instructions fournies dans Échanger des certificats d'approbation entre batteries de serveurs (SharePoint Foundation 2010) pour établir une relation d'approbation entre les deux batteries de serveurs.

    4. Copiez l'URL publiée dans le Bloc-notes ou un autre éditeur de texte. Vous devez fournir cette URL aux batteries de serveurs à distance pour connecter les batteries de serveurs à distance à l'application de service publiée. L'URL doit être similaire à ce qui suit : urn:schemas-microsoft-com:sharepoint:service:9c1870b7ee97445888d9e846519cfa27#authority=urn:uuid:02a493b92a5547828e21386e28056cba&authority=https://ua_powershell:32844/Topology/topology.svc.

  6. Vous pouvez éventuellement fournir un texte descriptif et un lien vers une page Web qui sera visible aux administrateurs des batteries de serveurs distantes. Après avoir spécifié les options de publication souhaitées, cliquez sur OK pour publier l'application de service.

Pour publier une application de service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Publish-SPServiceApplication -Identity <ServiceApplicationGUID>

    Si vous ignorez quel est le GUID de l'application de service, vous pouvez utiliser l'applet de commande Windows PowerShell 2.0 suivante pour lister toutes les applications de service de la batterie de serveurs, conjointement avec leurs GUID :

    Code de copie
    Get-SPServiceApplication

  5. Pour afficher l'URL d'équilibrage de charge de l'application de service publiée, tapez la commande suivante et enregistrez la sortie :

    Code de copie
    Get-SPTopologyServiceApplication

    Les batteries de serveurs à distance qui se connectent auront besoin des informations générées par cette commande.

Voir aussi

Référence

Publish-SPServiceApplication
Get-SPServiceApplication
Get-SPTopologyServiceApplication

Concepts

Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010)

Historique des modifications


Définir les autorisations à une application de service publiée (SharePoint Foundation 2010)

Dans Microsoft SharePoint Foundation 2010, vous devez établir une relation entre la batterie de serveurs de publication et la batterie de serveurs consommatrice en accordant à celle-ci des autorisations sur l'application de service d'équilibrage de charge et de détection d'application sur la batterie de serveurs de publication. Une fois que vous avez effectué cette opération, la batterie de serveurs consommatrice peut recevoir des autorisations sur les autres applications de service. Cet article explique comment configurer des autorisations sur l'application de service d'équilibrage de charge et de détection d'application et sur les applications de service publiées pour la batterie de serveurs consommatrice.

Important :
Avant de commencer à configurer les batteries de serveurs de publication et de consommation, il est fortement recommandé de consulter les articles Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010) et Planification de l'architecture des services (SharePoint Foundation 2010).

Dans cet article :

  • Définir des autorisations sur l'application de service d'équilibrage de charge et de détection d'application et sur n'importe quelle autre application de service pour une batterie de serveurs consommatrice à l'aide de Windows PowerShell

  • Définir des autorisations sur l'application de service d'équilibrage de charge et de détection d'application et sur n'importe quelle autre application de service publiée pour une batterie de serveurs consommatrice à l'aide de l'Administration centrale

Important :
Vous devez effectuer les étapes de 1 à 5 dans la procédure Windows PowerShell pour obtenir l'ID de batterie de serveurs de consommation nécessaire pour effectuer les procédures relatives à Windows PowerShell ou Administration Centrale.

Définir des autorisations sur l'application de service d'équilibrage de charge et de détection d'application et sur n'importe quelle autre application de service pour une batterie de serveurs consommatrice à l'aide de Windows PowerShell

La première procédure explique comment définir des autorisations sur l'application de service d'équilibrage de charge et de détection d'application, tandis que la seconde explique comment définir des autorisations sur n'importe quelle autre application de service.

Pour définir des autorisations sur l'application de service d'équilibrage de charge et de détection d'application pour une batterie de serveurs consommatrice à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Sur un serveur de la batterie de serveurs de consommation, dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante :

    Code de copie
    Get-SPFarm | Select Id

    Pour plus d'informations, voir Get-SPFarm.

  6. Sur un serveur de la batterie de serveurs de publication, accédez au SharePoint 2010 Management Shell et à l'invite de commandes Windows PowerShell, tapez les commandes suivantes :

    Code de copie
    $security=Get-SPTopologyServiceApplication | Get-SPServiceApplicationSecurity
    Code de copie
    $claimprovider=(Get-SPClaimProvider System).ClaimProvider
    Code de copie
    $principal=New-SPClaimsPrincipal -ClaimType "http://schemas.microsoft.com/sharepoint/2009/08/claims/farmid" -ClaimProvider $claimprovider -ClaimValue <consumingfarmid>
    Code de copie
    Grant-SPObjectSecurity -Identity $security -Principal $principal -Rights "Full Control"
    Code de copie
    Get-SPTopologyServiceApplication | Set-SPServiceApplicationSecurity -ObjectSecurity $security

    Où :

    Consumingfarmid est la valeur GUID de la batterie de serveurs de consommation

    Pour plus d'informations, voir les informations suivantes :

    • Get-SPTopologyServiceApplication

    • Set-SPServiceApplicationSecurity

    • Get-SPServiceApplicationSecurity

    • New-SPClaimsPrincipal

    • Get-SPClaimProvider

    • Grant-SPObjectSecurity

Pour définir une autorisation à une application de service publiée pour une batterie de serveurs de consommation au moyen de Windows PowerShell

  1. À l'invite de commandes Windows PowerShell, tapez les commandes suivantes :

    Code de copie
    $security=Get-SPServiceApplication <GUID>| Get-SPServiceApplicationSecurity
    Code de copie
    $claimprovider=(Get-SPClaimProvider System).ClaimProvider
    Code de copie
    $principal=New-SPClaimsPrincipal -ClaimType "http://schemas.microsoft.com/sharepoint/2009/08/claims/farmid" -ClaimProvider $claimprovider -ClaimValue <consumingfarmid>
    Code de copie
    Grant-SPObjectSecurity -Identity $security -Principal $principal -Rights <NamedAccessRights>
    Code de copie
    Set-SPServiceApplicationSecurity <GUID> -ObjectSecurity $security

    Où :

    Consumingfarmid est la valeur GUID de la batterie de serveurs de consommation

    <GUID> est l'ID de l'application de service publiée.

    <NamedAccessRights> est le nom du droit d'accès depuis Get-SPServiceApplicationSecurity <GUID>.NamedRights.

Pour plus d'informations, voir les informations suivantes :

  • Get-SPServiceApplication

  • New-SPClaimsPrincipal

  • Get-SPServiceApplication

  • Get-SPServiceApplicationSecurity

  • Grant-SPObjectSecurity

  • Set-SPServiceApplicationSecurity

Définir des autorisations sur l'application de service d'équilibrage de charge et de détection d'application et sur n'importe quelle autre application de service publiée pour une batterie de serveurs consommatrice à l'aide de l'Administration centrale

Cette procédure explique comment définir des autorisations sur n'importe quelle application de service, mais plus spécifiquement sur l'application de service d'équilibrage de charge et de détection d'application.

Important :
Vous devez effectuer des étapes de 1 à 5 dans la procédure Windows PowerShell pour obtenir l'ID de batterie de serveurs de consommation nécessaire pour effectuer cette procédure.

Pour définir des autorisations sur l'application de service d'équilibrage de charge et de détection d'application et sur n'importe quelle autre application de service publiée pour une batterie de serveurs consommatrice à l'aide de l'Administration centrale

  1. Sur le serveur qui héberge le site Web de l'Administration Centrale pour la batterie de serveurs de publication, vérifiez que le compte d'utilisateur chargé d'effectuer cette procédure appartient au groupe SharePoint Administrateurs de batterie.

  2. Sur le site Web Administration centrale SharePoint, cliquez sur Gestion des applications, puis sur Gérer les applications de service.

  3. Cliquez sur la ligne qui contient la mention Application de service d'équilibrage de charge et de détection d'application.

  4. Sur le Ruban, cliquez sur Autorisations.

  5. Dans la boîte de dialogue Autorisations de connexion, procédez comme suit :

    1. Collez manuellement l'ID de la batterie de serveurs de consommation de l'étape 5 de la section Windows PowerShell.

    2. Cliquez sur Ajouter.

    3. Sélectionnez l'ID de batterie de serveurs de consommation, puis activez la case à cocher Contrôle total.

    4. Cliquez sur OK.

  6. Répétez les étapes de 2 à 5 pour des applications de service publiées dont vous souhaitez activer l'accès depuis la batterie de serveurs de consommation et affecter l'autorisation nécessaire.

Historique des modifications

Date | Description | Raison
20 mai 2010 | Publication initiale |


Se connecter à une application de service sur une batterie de serveurs distante (SharePoint Foundation 2010)
Voir aussi

Dans Microsoft SharePoint Foundation 2010, vous pouvez publier certaines applications de service afin de les rendre disponibles via des connexions à distance. En publiant une application de service, vous pouvez optimiser les ressources et éviter la redondance tout en fournissant des services à l'échelle de l'entreprise sans installer une batterie de serveurs de services d'entreprise dédiée. Cet article explique comment se connecter à une application de service publiée et la consommer.

Important :
Avant que vous ne commenciez à partager des applications de service, il est fortement recommandé de lire les articles Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010) et Planification de l'architecture des services (SharePoint Foundation 2010).

Vous pouvez vous connecter à une application de service qui a été partagée par une autre batterie si vous connaissez l'adresse du service de découverte de la batterie de serveurs ou l'adresse de l'application de service. Sachez que vous pouvez vous connecter uniquement à une application de service sur une batterie de serveurs à distance si l'administrateur de batterie de serveurs pour la batterie de serveurs à distance a publié l'application de service.

Dans cet article :

  • Pour vous connecter à une application de service sur une batterie de serveurs à distance à l'aide de l'administration centrale

  • Pour vous connecter à une application de service sur une batterie de serveurs à distance à l'aide Windows PowerShell

Pour vous connecter à une application de service sur une batterie de serveurs à distance à l'aide de l'administration centrale

  1. Vérifiez que vous êtes membre du groupe SharePoint des administrateurs de batterie de serveurs.

  2. Sur le site Web Administration centrale SharePoint, cliquez sur Gestion des applications, puis sur Gérer les applications de service.

  3. Sur le ruban, cliquez sur Connexion.

  4. Dans la liste déroulante du menu Connexion , cliquez sur le type d'application de service auquel vous souhaitez vous connecter.

  5. Dans la page Se connecter à une application de service distante, tapez l'URL appropriée dans la zone de texte Adresse de la batterie de serveurs ou de l'application de service, puis cliquez sur OK.

    Remarque :
    Vous pouvez obtenir l'URL à partir de l'administrateur de la batterie de serveurs de publication. Pour plus d'informations, voir Publier une application de service (SharePoint Foundation 2010). Il existe deux types d'URL que vous pouvez utiliser dans cette étape : l'URL de l'application de service ou l'URL d'application de service de topologie de la batterie à distance. Si vous utilisez l'URL de l'application de service, seule l'application de service correspondante apparaîtra à l'étape 6 de cette procédure. Si vous utilisez l'URL du service de topologie, toutes les applications de service dans la batterie de serveurs seront affichées à l'étape 6 de cette procédure.

  6. La nouvelle boîte de dialogue Se connecter à une application de service distante affiche les applications de service qui correspondent à l'URL que vous avez tapée à l'étape 5. Cliquez sur la ligne qui contient le nom de l'application de service, puis activez la case à cocher appropriée pour ajouter la connexion de l'application de service à la liste des connexions d'application de service (c'est-à-dire le groupe de proxys par défaut) de la batterie. Cliquez sur OK.

  7. Vous êtes invité à modifier le nom de connexion. Tapez un nouveau nom dans la zone de texte Nom de la connexion ou conservez le nom par défaut, puis cliquez sur OK.

  8. Il est recommandé de suivre les instructions fournies dans Échanger des certificats d'approbation entre batteries de serveurs (SharePoint Foundation 2010) pour établir une relation d'approbation entre les deux batteries de serveurs.

  9. Une fois la nouvelle connexion créée, vous devez cliquer sur OK pour terminer la procédure.

  10. Associez la nouvelle connexion de l'application de service à une application Web locale. Pour plus d'informations sur la façon de procéder, voir Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010).

Pour vous connecter à une application de service sur une batterie de serveurs à distance à l'aide Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Receive-SPSharedServiceApplicationInfo -FarmUrl <PublishingFarmTopologyURL>

    Où <PublishingFarmTopologyURL> représente les informations récupérées via l'exécution de l'applet de commande Get-SPTopologyServiceApplication dans la batterie de serveurs de publication. Pour plus d'informations, voir Publier une application de service (SharePoint Foundation 2010).

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
                      New-SP*ServiceApplicationProxy -Name " <ServiceApplicationProxyName>" -Url "<PublishingFarmTopologyURL>"

    Où :

    • <ServiceApplicationProxyName> est un nom unique pour une connexion à une application de service dans la batterie de serveurs consommatrice.

    • <PublishingFarmTopologyURL> est l'URL de topologie d'application de service qui a été également utilisée dans la commande précédente.

    Chaque type d'application de service a une applet de commande Windows PowerShell 2.0 spécifique qui doit être utilisée à la place de New-SP*ServiceApplicationProxy. (Ces applets de commande sont listées dans la section Voir aussi.) Par exemple, la commande suivante crée un proxy d'application de service de métadonnées gérées nommé « MetadataServiceProxy1 » qui se connecte à l'application de service située à l'URL indiquée.

    Code de copie
    New-SPMetadataServiceApplicationProxy -Name "MetadataServiceProxy1" -URL "
urn:schemas-microsoft-com:sharepoint:service:9c1870b7ee97445888d9e846519cfa27#authority=urn:uuid:02a493b92a5547828e21386e28056cba&authority=https://ua_powershell:32844/Topology/topology.svc  "

  6. Vous devez associer la nouvelle connexion de l'application de service à une application Web locale. Pour plus d'informations sur la façon de procéder, voir Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010).

Voir aussi

Référence

New-SPBusinessDataCatalogServiceApplicationProxy

Autres ressources

New-SPEnterpriseSearchServiceApplicationProxy
New-SPMetadataServiceApplicationProxy
New-SPProfileServiceApplicationProxy
New-SPSecureStoreServiceApplicationProxy
New-SPWebAnalyticsServiceApplicationProxy

Historique des modifications


Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010)

Lorsque vous créez une application de service Microsoft SharePoint Foundation 2010, une connexion de l'application de service est créée. Une connexion de l'application de service est également désignée par le terme proxy d'application. Une connexion de l'application de service associe l'application de service aux applications Web par l'appartenance à un groupe de connexions d'applications de service (appelé aussi groupe proxy d'application).

Cet article décrit comment ajouter ou supprimer des connexions d'application de service dans un groupe de connexions d'application de service.

Important :
Si vous créez une connexion d'application de service à une application de service dans une batterie de serveurs distante, lisez l'article Partager des applications de service entre les batteries de serveurs (SharePoint Foundation 2010) pour bien comprendre les exigences nécessaires au partage des applications de service entre des batteries de serveurs.

Par défaut, une nouvelle connexion d'application de service est ajoutée au groupe par défaut de connexions d'application de service de la batterie lorsque vous créez l'application de service à l'aide de l'administration centrale.Vous pouvez substituer cette appartenance par défaut. Si une nouvelle application de service est créée à l'aide de Windows PowerShell 2.0 et non pas de l'administration centrale, la nouvelle application de service ne devient pas automatiquement membre du groupe de connexions d'application de service par défaut à moins que le paramètre -default par défaut ne soit fourni.

Remarque :
Pour plus d'informations sur la façon de créer et configurer des applications de service, voir Gérer les applications de service (SharePoint Foundation 2010).

Par défaut, toutes les applications Web sont associées au groupe par défaut des connexions d'application de service de la batterie, mais vous pouvez modifier ce paramètre.Vous pouvez également créer un groupe de connexion personnalisé pour chaque application Web dans la batterie de serveurs. Vous pouvez modifier les applications du service avec lequel une application Web est associée à tout moment et vous pouvez modifier les applications de service qui sont incluses dans le groupe de connexions d'application de service par défaut.

Pour plus d'informations sur la façon de créer et de configurer des applications Web, voir Gérer des applications Web (SharePoint Foundation 2010).

Modification d'un groupe de connexions de service

Vous pouvez ajouter ou supprimer des connexions d'application de service dans un groupe de connexions d'application de service à l'aide de l'administration centrale ou à l'aide d'applets de commande Windows PowerShell 2.0.

Pour modifier un groupe de connexion de service à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Applications de service, cliquez sur Configurer les associations des applications de service.

  4. Dans la page des associations des applications de service, sélectionnez Applications Web dans le menu de liste déroulante Affichage.

  5. Dans la liste des applications Web, dans la colonne de Groupe de proxys d'application, cliquez sur le nom du groupe de connexions d'applications de service que vous souhaitez modifier.

  6. Pour ajouter une connexion de service au groupe, activez la case à cocher située en regard de l'application de service que vous souhaitez ajouter au groupe de connexion. Pour supprimer une connexion de service d'application du groupe de connexion, désactivez la case à cocher en regard de l'application de service que vous souhaitez supprimer du groupe de connexion. Lorsque vous avez apporté les modifications voulues, cliquez sur OK.

    Remarque :
    Vous pouvez également modifier des groupes de connexion d'application de service personnalisés en cliquant sur Gérer les applications Web dans la page d'accueil de l'administration centrale en sélectionnant une application Web répertoriée, puis sur connexions aux services sur le ruban. Mais vous ne pouvez pas modifier le groupe de connexions d'applications de service par défaut à l'aide de cette page.

Pour ajouter une connexion d'application de service à un groupe de connexions d'application de service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Add-SPServiceApplicationProxyGroupMember [-Identity <le groupe de proxys d'application de service>] [-Member <membres à ajouter au groupe de proxys d'application de service>]

Pour plus d\rquote informations, voir Add-SPServiceApplicationProxyGroupMember.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Pour supprimer une connexion d'application de service à un groupe de connexions d'application de service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Remove-SPServiceApplicationProxyGroupMember [-Identity <SPServiceApplicationProxyGroupPipeBind>] [-Member <SPServiceApplicationProxyPipeBind[]>]

Pour plus d\rquote informations, voir Remove-SPServiceApplicationProxyGroupMember.

Historique des modifications


Restreindre ou autoriser l'accès à une application de service (SharePoint Foundation 2010)
Voir aussi

Dans Microsoft SharePoint Foundation 2010, il est possible de restreindre l'accès à une application de service de sorte qu'elle soit accessible uniquement à des applications Web spécifiées.

Par défaut, toutes les applications de service sur la batterie locale sont accessibles à toutes les applications Web sur la batterie locale. Cependant, il est possible de restreindre l'accès à une application de service de sorte qu'elle soit accessible uniquement à des applications Web spécifiées. Cela peut être une stratégie utile si vous hébergez plusieurs clients sur la même batterie et que vous souhaitez isoler les applications de service d'un client de l'application Web d'un autre client.

Si vous limitez l'accès à une application de service et décidez ultérieurement de la mettre à disposition de toute la batterie, vous pouvez supprimer la restriction.

Cet article décrit comment restreindre l'accès à une application de service en ajoutant et en supprimant des comptes de service. Il décrit également comment rétablir l'accès à une application de service à l'échelle de la batterie.

Important :
Nous vous recommandons vivement de planifier l'infrastructure de sécurité et de services avant de restreindre l'accès à des applications de service.

Pour plus d'informations sur la façon de planifier l'architecture des services dans SharePoint Foundation 2010, voir les articles suivants :

  • Planification de l'architecture des services (SharePoint Foundation 2010)

  • Diagrammes techniques (SharePoint Foundation 2010)

Dans cet article :

  • Restriction de l'accès à une application de service

  • Restaurer l'accès à l'échelle de la batterie à une application de service

  • Exemples de code Windows PowerShell

Restriction de l'accès à une application de service

Il est possible de restreindre l'accès à une application de service en supprimant des comptes de service de l'application de service. À l'inverse, il est possible d'autoriser l'accès à une application de service en ajoutant des comptes de service à l'application de service. Vous pouvez effectuer ces tâches à l'aide de l'Administration centrale ou à l'aide de Windows PowerShell 2.0.

Pour restreindre l'accès à une application de service, vous devez effectuer les tâches suivantes :

  1. ajouter un compte de service spécifique à l'application de service ;

  2. supprimer l'ID de batterie locale de l'application de service.

Remarque :
Les procédures fournies dans cet article décrivent comment restreindre ou restaurer l'accès à une application de service. Toutefois, vous pouvez également appliquer ces procédures afin d'ajouter tout compte de service à toute application de service, ou de supprimer tout compte de service de toute application de service

Par exemple, la procédure intitulée Pour restaurer l'accès à l'échelle de la batterie locale à une application de service à l'aide de l'Administration centrale décrit explicitement comment ajouter l'ID de batterie locale à une application de service. Cependant, vous pouvez appliquer la même procédure pour ajouter tout autre compte de service à une application de service. Pour cela, vous devez spécifier le compte de service approprié au lieu de l'ID de batterie locale.

Étant donné que l'ID de batterie locale procure un accès à l'échelle de la batterie locale à l'application de service par défaut, il est redondant d'accorder également des autorisations explicites à l'application Web locale à une application de service, à moins que vous ne supprimiez également l'ID de batterie locale.

Pour accorder des autorisations à une application de service, vous devez extraire et spécifier le compte de service approprié. Pour une application Web, ce compte porte également le nom de compte d'identité de pool d'applications.

Une fois que vous avez accordé des autorisations à un compte de service et supprimé l'ID de batterie locale d'une application de service, seules les applications Web gérées par le compte de service assigné peuvent accéder à l'application de service. Vous pouvez assigner plusieurs applications Web (qui ont différents comptes de service de gestion) à la même application de service en répétant ces procédures et en ajoutant les divers comptes de service d'application Web à l'application de service.

Avertissement :
Si vous supprimez l'ID de batterie locale d'une application de service et que vous n'affectez pas d'autre compte de service à cette application de service, cette dernière devient inaccessible à toutes les applications Web.

Dans cette section :

  • Restreindre l'accès à une application de service à l'aide de l'Administration centrale

  • Restriction de l'accès à une application de service à l'aide de Windows PowerShell

Restreindre l'accès à une application de service à l'aide de l'Administration centrale

Pour limiter l'accès à une application de service à partir de l'Administration centrale, vous devez effectuer les étapes suivantes :

  1. extraire le compte de service d'application Web ;

  2. ajouter le compte de service d'application Web à l'application de service ;

  3. supprimer l'ID de batterie locale de l'application de service.

Procédures dans cette section :

  • Pour extraire un compte de service d'application Web à l'aide de l'Administration centrale

  • Pour accorder et supprimer des autorisations pour des comptes de service pour l'accès à une application de service à l'aide de l'Administration centrale

Pour extraire un compte de service d'application Web à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans la page d'accueil d'Administration centrale, dans la section Sécurité, cliquez sur Configurer les comptes de service.

  3. Dans la page Comptes de service, sélectionnez le nom de l'application Web dans la première liste déroulante.

    Le compte de service est affiché dans la liste Sélectionnez un compte pour ce composant. Prenez note du nom du compte de service car vous l'utiliserez dans la procédure suivante.

  4. Cliquez sur Annuler pour quitter la page Comptes de service sans apporter de modification.

Pour accorder et supprimer des autorisations pour des comptes de service pour l'accès à une application de service à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans la page d'accueil d'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la page Gérer les applications de service, cliquez sur la ligne qui contient l'application de service pour laquelle vous souhaitez assigner des autorisations. Le Ruban devient disponible.

  4. Sur le ruban, cliquez sur Autorisations.

  5. Dans la boîte de dialogue Autorisations de connexion, tapez le nom du compte de service que vous avez extrait lors de la procédure précédente, puis cliquez sur Ajouter.

  6. Assurez-vous que le nom du compte de service nouvellement ajouté est sélectionné dans le volet du milieu, puis cliquez sur la case à cocher appropriée dans le volet inférieur pour fournir le niveau d'autorisation requis.

  7. Dans le volet du milieu, cliquez sur Batterie locale, puis sur Supprimer.

  8. Vérifiez que la page Autorisations de connexion mentionne maintenant uniquement le compte de service auquel vous souhaitez accorder l'accès à l'application de service, et que le compte de service possède les autorisations requises sur l'application de service. Cliquez sur OK pour modifier les autorisations ou sur Annuler pour terminer l'opération sans apporter de modification.

Vous pouvez accorder et supprimer des autorisations pour tout compte de service à l'aide de cette procédure.

Remarque :
La restauration de l'ID de batterie locale à l'application de service à l'aide de l'Administration centrale requiert une étape supplémentaire qui ne s'applique pas aux autres comptes de service. Pour plus d'informations sur la manière de procéder, voir Restaurer l'accès à l'échelle de la batterie à une application de service plus loin dans cet article.

Restriction de l'accès à une application de service à l'aide de Windows PowerShell

Toutes les procédures de cette section supposent que vous disposez des autorisations appropriées et que vous avez ouvert la fenêtre d'invite de commandes Windows PowerShell 2.0, comme décrit dans la procédure Pour initier une session Windows PowerShell plus loin dans cet article.

Le processus de restriction de l'accès à une application de service à l'aide de Windows PowerShell 2.0 est plus complexe qu'à l'aide de l'Administration centrale. Dans Windows PowerShell 2.0, vous utiliserez certaines procédures afin de recueillir et stocker des informations utilisées comme entrées pour des procédures ultérieures.

Après le démarrage de Windows PowerShell 2.0, les étapes permettant de restreindre l'accès à une application de service sont les suivantes :

  1. extraire l'ID de batterie locale ;

  2. extraire le compte de service d'application Web ;

  3. créer une nouvelle entité de revendications qui contient le compte de service d'application Web ;

  4. extraire l'objet de sécurité de l'application de service ;

  5. ajouter le compte de service d'application Web à l'objet de sécurité de l'application de service ;

  6. supprimer l'ID de batterie locale de l'objet de sécurité de l'application de service ;

  7. assigner l'objet de sécurité mis à jour à l'application de service ;

  8. afficher et examiner les autorisations mises à jour.

Dans cette section :

  • Pour initier une session Windows PowerShell

  • Pour extraire l'ID de batterie locale à l'aide de Windows PowerShell

  • Pour extraire un compte de service d'application Web et créer une entité de revendications à l'aide de Windows PowerShell

  • Pour extraire l'objet de sécurité de l'application de service

  • Pour mettre à jour l'objet de sécurité de l'application de service avec les autorisations préférées

Pour initier une session Windows PowerShell

  1. Vérifiez que les conditions préalables suivantes sont remplies : vous êtes membre du rôle SharePoint_Shell_Access sur la base de données de configuration et membre du groupe local WSS_ADMIN_WPG sur l'ordinateur où les SharePoint Foundation 2010 sont installés.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

Pour extraire un compte de service d'application Web et créer une entité de revendications à l'aide de Windows PowerShell

  1. À l'invite de commandes Windows PowerShell 2.0, tapez la commande suivante pour extraire le compte de service (autrement dit, le compte d'identité de pool d'applications) d'une application Web :

    Code de copie
    $webapp = Get-SPWebApplication <http://WebApplication>
$webApp.ApplicationPool.UserName

    Où <http://WebApplication> est l'URL de l'application Web.

    Le nom du compte de service d'application Web s'affiche à l'invite de commandes.

  2. Pour créer une entité de revendications, tapez la commande suivante :

    Code de copie
    $principal = New-SPClaimsPrincipal <ServiceAccount> -IdentityType WindowsSamAccountName

    Où <ServiceAccount> est le nom d'utilisateur (au format jane@contoso.com ou contoso\jane) qui a été extrait en exécutant la commande précédente. La variable $principal contiendra la nouvelle entité de revendications.

Pour extraire l'objet de sécurité de l'application de service

  1. Pour extraire l'objet de sécurité de l'application de service, tapez les commandes suivantes. La variable $security contiendra l'objet de sécurité de l'application de service.

    Code de copie
    $spapp = Get-SPServiceApplication -Name "<ServiceApplicationDisplayName>"
$spguid = $spapp.id
$security = Get-SPServiceApplicationSecurity $spguid

    Où <ServiceApplicationDisplayName> est le nom d'affichage de l'application de service.

    Important :
    Vous devez placer le nom d'affichage entre guillemets et il doit correspondre exactement au nom d'affichage de l'application de service (avec respect de la casse). Si plusieurs applications de service ont exactement le même nom d'affichage (ce qui est déconseillé), vous pouvez exécuter l'applet de commande Get-SPServiceApplication sans argument pour afficher toutes les applications de service. Vous pouvez ensuite identifier l'application de service directement d'après son GUID. Par exemple :

    Get-SpServiceApplication

    Toutes les applications de service sont répertoriées.

    $spapp = Get-SpserviceApplication -Identity <GUID>

    $spguid = $spapp.id

    Où <GUID> est le GUID de l'application de service pour laquelle vous souhaitez mettre à jour les autorisations.

Pour mettre à jour l'objet de sécurité de l'application de service avec les autorisations préférées

  1. La première étape dans la mise à jour de l'objet de sécurité de l'application de service consiste à ajouter la nouvelle entité de revendications $principal à l'objet de sécurité de l'application de service $security. Pour ce faire, tapez la commande suivante :

    Code de copie
    Grant-SPObjectSecurity $security $principal -Rights "<Rights>"

    Où <Rights> correspond aux autorisations que vous souhaitez accorder. En général, il s'agit de Contrôle total. Les autorisations disponibles peuvent varier selon l'application de service.

    Conseil :
    Si vous ne souhaitez pas accorder d'autorisations Contrôle total et que vous ignorez les autorisations qui peuvent être accordées à l'application de service, vous pouvez exécuter les commandes suivantes afin de retourner les chaînes d'autorisations disponibles :

    $rightslist = Get-SPServiceApplicationSecurity $spapp

    $rightslist.NamedAccessRights

  2. Pour supprimer l'ID de batterie locale (qui est stocké dans la variable $farmID) de l'objet de sécurité de l'application de service $security, tapez la commande suivante :

    Code de copie
    Revoke-SPObjectSecurity $security $farmID

  3. Pour assigner l'objet de sécurité $security mis à jour à l'application de service et confirmer que l'objet de sécurité pour l'application de service est mis à jour correctement, tapez les commandes suivantes :

    Code de copie
    Set-SPServiceApplicationSecurity $spapp -ObjectSecurity $security
(Get-SPServiceApplicationSecurity $spapp).AccessRules

Vous pouvez ajouter ou supprimer tout compte de service à une application de service à l'aide de ces procédures.

Restaurer l'accès à l'échelle de la batterie à une application de service

Vous pouvez restaurer l'accès à l'échelle de la batterie à une application de service en ajoutant l'ID de batterie locale à l'application de service. Cette opération peut s'effectuer à l'aide de l'Administration centrale ou de commandes Windows PowerShell 2.0. Toutefois, vous devez utiliser Windows PowerShell 2.0 pour obtenir l'ID de batterie locale.

Dans cette section :

  • Pour extraire l'ID de batterie locale à l'aide de Windows PowerShell

  • Pour restaurer l'accès à l'échelle de la batterie locale à une application de service à l'aide de l'Administration centrale

  • Pour restaurer l'accès à l'échelle de la batterie locale à une application de service à l'aide de Windows PowerShell

Pour extraire l'ID de batterie locale à l'aide de Windows PowerShell

  1. Cette procédure débute après l'étape 4 de la procédure Pour initier une session Windows PowerShell .

  2. La commande suivante extrait l'ID de batterie locale, le stocke dans la variable $farmID et l'affiche à l'invite de commandes :

    Code de copie
    $farmID = Get-SPFarm | select id

    Si vous souhaitez restaurer l'accès à l'échelle de la batterie à l'aide de l'Administration centrale, copiez cette valeur dans le Presse-papiers afin de l'utiliser dans la procédure suivante.

    Si vous souhaitez restaurer l'accès à l'échelle de la batterie à l'application de service à l'aide de Windows PowerShell 2.0, tapez les commandes supplémentaires suivantes à l'invite de commandes Windows PowerShell 2.0. Vous utiliserez les informations extraites dans la procédure suivante.

    Code de copie
    $claimProvider = (Get-SPClaimProvider System).ClaimProvider
$principal = New-SPClaimsPrincipal -ClaimType "http://schemas.microsoft.com/sharepoint/2009/08/claims/farmid" -ClaimProvider $claimProvider -ClaimValue $farmid

Pour restaurer l'accès à l'échelle de la batterie locale à une application de service à l'aide de l'Administration centrale

  1. Effectuez les étapes 1 à 3 de la procédure Pour accorder et supprimer des autorisations pour des comptes de service pour l'accès à une application de service à l'aide de l'Administration centrale.

  2. Dans la boîte de dialogue Autorisations de connexion, copiez l'ID de batterie locale que vous avez extrait lors de la procédure précédente, puis cliquez sur Ajouter.

  3. Assurez-vous que l'ID de batterie locale est sélectionné dans le volet du milieu. Cliquez sur la case à cocher Contrôle total dans le volet inférieur.

  4. Cliquez sur OK pour restaurer l'accès à l'échelle de la batterie à l'application de service ou sur Annuler pour terminer l'opération sans apporter de modification.

Pour restaurer l'accès à l'échelle de la batterie locale à une application de service à l'aide de Windows PowerShell

  1. Cette procédure débute après l'étape 2 de la procédure Pour extraire l'ID de batterie locale à l'aide de Windows PowerShell .

  2. Pour restaurer l'ID de batterie locale extrait dans l'objet de sécurité d'application de service $security, tapez les commandes suivantes :

    Code de copie
    $spapp = Get-SPServiceApplication -Name "<ServiceApplicationDisplayName>"
$spguid = $spapp.id
$security = Get-SPServiceApplicationSecurity $spguid
Grant-SPObjectSecurity -Identity $security -Principal $farmID -Rights "Full Control"
Set-SPServiceApplicationSecurity $spguid -ObjectSecurity $security

    Où <ServiceApplicationDisplayName> est le nom d'affichage de l'application de service.

    Important :
    Vous devez placer le nom d'affichage entre guillemets, lequel doit correspondre exactement au nom d'affichage de l'application de service (avec respect de la casse). Si plusieurs applications de service ont exactement le même nom d'affichage (ce qui est déconseillé), vous pouvez exécuter l'applet de commande Get-SPServiceApplication sans argument pour afficher toutes les applications de service. Vous pouvez ensuite identifier l'application de service directement d'après son GUID.

Exemples de code Windows PowerShell

Dans l'exemple suivant, l'administrateur souhaite restreindre l'accès à l'application de service « Contoso BDC » à l'application Web http://contoso/hawaii, qui est gérée par le compte de service « contoso\jane ». En ajoutant « contoso\jane » et en supprimant le compte de service de batterie locale de l'application de service, vous faites en sorte que « Contoso BDC » soit restreinte aux seules applications Web qui sont gérées par le compte de service «contoso\jane », à savoir dans le cas présent http://contoso/hawaii.

Code de copie
$farmid = Get-SPFarm | select id
$claimProvider = (Get-SPClaimProvider System).ClaimProvider
$principal = New-SPClaimsPrincipal -ClaimType "http://schemas.microsoft.com/sharepoint/2009/08/claims/farmid" -ClaimProvider $claimProvider -ClaimValue $farmid
webapp = get-spwebapplication http://contoso
$webapp.applicationpool
$principal = New-SPClaimsPrincipal contoso/jane -IdentityType WindowsSamAccountName
$spapp = Get-SPServiceApplication -Name "Contoso BDC"
$spguid = $spapp.id
$security = Get-SPServiceApplicationSecurity $spguid
Grant-SPObjectSecurity $security $principal -Rights "Full Control"
Revoke-SPObjectSecurity $security $farmaccount
Set-SPServiceApplicationSecurity $spguid -ObjectSecurity $security
(Get-SPServiceApplicationSecurity $spguid).AccessRules

Dans l'exemple suivant, l'accès à l'application de service « Contoso BDC » est restauré à toutes les applications Web dans la batterie locale.

Code de copie
$farmid = Get-SPFarm | select id
$claimProvider = (Get-SPClaimProvider System).ClaimProvider
$principal = New-SPClaimsPrincipal -ClaimType "http://schemas.microsoft.com/sharepoint/2009/08/claims/farmid" -ClaimProvider $claimProvider -ClaimValue $farmid
$spapp = Get-SPServiceApplication -Name "Contoso BDC"
$spguid = $spapp.id
$security = Get-SPServiceApplicationSecurity $spguid
Grant-SPObjectSecurity -Identity $security -Principal $farmaccount -Rights "Full Control"
Set-SPServiceApplicationSecurity $spguid -ObjectSecurity $security
(Get-SPServiceApplicationSecurity $spguid).AccessRules

Voir aussi

Référence

Get-SPWebApplication
New-SPClaimsPrincipal
Get-SPServiceApplication
Get-SPServiceApplicationSecurity
Grant-SPObjectSecurity
Revoke-SPObjectSecurity
Set-SPServiceApplicationSecurity
Get-SPFarm
Get-SPClaimProvider

Concepts

Configurer l'authentification par revendications (SharePoint Foundation 2010)
Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010)

Historique des modifications


Affecter ou supprimer les administrateurs d'une application de service (SharePoint Foundation 2010)

Un administrateur d'une application de service Microsoft SharePoint Foundation 2010 peut affecter des administrateurs supplémentaires à l'application de service. Ces utilisateurs bénéficient d'un accès de sécurité au site Web Administration centrale de SharePoint et peuvent gérer les paramètres relatifs à l'application de service. De même, il est possible de supprimer des administrateurs d'une application de service.

Remarque :
Par défaut, les membres du groupe Administrateurs de batterie de serveurs disposent des autorisations nécessaires pour gérer toutes les applications de service.

Vous pouvez affecter ou supprimer des administrateurs d'application de service à l'aide de l'Administration centrale ou de Windows PowerShell 2.0.

Dans cet article :

  • Pour affecter ou supprimer les administrateurs d'une application de service à l'aide de l'Administration centrale

  • Pour affecter ou supprimer les administrateurs d'une application de service à l'aide de Windows PowerShell

Pour affecter ou supprimer les administrateurs d'une application de service à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la page Gérer les applications de service, cliquez sur la ligne qui contient l'application de service pour laquelle vous souhaitez ajouter ou supprimer des administrateurs. Le ruban devient disponible.

  4. Sur le ruban, cliquez sur Administrateurs.

  5. Pour ajouter un administrateur :

    1. Dans la première zone de texte de la page, tapez les comptes d'utilisateurs ou groupes d'utilisateurs à ajouter. Vous pouvez cliquer sur l'icône Personnes pour valider un nom. Vous pouvez cliquer sur l'icône Carnet d'adresses pour rechercher des utilisateurs à ajouter. Vous pouvez ajouter plusieurs administrateurs dans la zone de texte.

    2. Après avoir ajouté les administrateurs, cliquez sur OK.

  6. Pour supprimer un administrateur :

    1. Dans la seconde zone de texte de la page, sélectionnez l'administrateur à supprimer. Notez que cette étape n'entraîne pas la suppression de l'utilisateur au sein du système ; elle révoque simplement les autorisations d'administration de l'utilisateur pour l'application de service sélectionnée.

    2. Cliquez sur Supprimer.

    3. Une fois que vous avez terminé de supprimer les administrateurs, cliquez sur OK.

Pour affecter ou supprimer les administrateurs d'une application de service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez les commandes suivantes.

  6. Pour créer une entité de sécurité prenant en charge les revendications, tapez la commande suivante :

    Code de copie
    $principal = New-SPClaimsPrincipal "<contoso\jane>" -IdentityType WindowsSamAccountName

    Où <contoso\jane> est le nom de l'utilisateur auquel vous voulez affecter des autorisations d'administration. Le nom d'utilisateur doit être entré sous la forme suivante : jane@contoso.com ou contoso\jane. La nouvelle entité de sécurité prenant en charge les revendications est stockée dans la variable $principal.

  7. Pour récupérer l'application de service, tapez la commande suivante :

    Code de copie
    $spapp = Get-SPServiceApplication -Name "<ServiceApplicationDisplayName>"

    Où <ServiceApplicationDisplayName> est le nom d'affichage de l'application de service. L'identification de l'application de service est stockée dans la variable $spapp.

    Important :
    Le nom d'affichage doit être placé entre guillemets et doit correspondre exactement au nom d'affichage de l'application de service. Cela concerne également l'utilisation des majuscules. Si vous disposez de plusieurs applications de service ayant le même nom d'affichage (cela est déconseillé), vous pouvez utiliser l'applet de commande Get-SPServiceApplication pour voir l'ensemble des applications de service. Vous pouvez ensuite identifier l'application de service par son GUID. Pour plus d'informations, voir Get-SPServiceApplication.

  8. Pour récupérer l'objet de sécurité des administrateurs de l'application de service, tapez la commande suivante :

    Code de copie
    $security = Get-SPServiceApplicationSecurity $spapp -Admin

    L'objet de sécurité des administrateurs qui a été récupéré est stocké dans la variable $security.

    Avertissement :
    Il est important d'utiliser l'argument -Admin lorsque vous utilisez cette commande.

  9. Pour affecter ou révoquer les autorisations d'administration de l'utilisateur identifié par la nouvelle entité de sécurité prenant en charge les revendications $principal (créée à l'étape 6 de cette procédure) dans l'objet de sécurité des administrateurs de l'application de service $security (obtenu à l'étape 8 de cette procédure) utilisez la commande appropriée comme suit.

    1. Pour affecter des autorisations d'administration, tapez la commande suivante :

      Code de copie
      Grant-SPObjectSecurity $security $principal "Full Control"
    2. Pour révoquer des autorisations d'administration, tapez la commande suivante :

      Code de copie
      Revoke-SPObjectSecurity $security $principal

  10. Pour affecter l'objet de sécurité $security mis à jour à l'application de service, tapez la commande suivante :

    Code de copie
    Set-SPServiceApplicationSecurity $spapp $security -Admin
    Avertissement :
    Il est important d'utiliser l'argument -Admin lorsque vous utilisez cette commande.

  11. Pour vérifier que l'objet de sécurité de l'application de service est mis à jour de façon appropriée, tapez la commande suivante :

    Code de copie
    (Get-SPServiceApplicationSecurity $spapp -Admin).AccessRules

Exemples

Dans l'exemple suivant, l'utilisateur du compte de service « contoso\jane » est ajouté à l'objet de sécurité des administrateurs de l'application de service nommée « Contoso Visio Graphics ».

Code de copie
$principal = New-SPClaimsPrincipal "contoso\jane" -IdentityType WindowsSamAccountName
$spapp = Get-SPServiceApplication -Name "Contoso Visio Graphics"
$security = Get-SPServiceApplicationSecurity $spapp -Admin
Grant-SPObjectSecurity $security $principal "Full Control"
Set-SPServiceApplicationSecurity $spapp $security -Admin
(Get-SPServiceApplicationSecurity $spapp -Admin).AccessRules

Dans l'exemple suivant, l'utilisateur du compte de service « contoso\jane » est supprimé de l'objet de sécurité des administrateurs de l'application de service nommée « Contoso Visio Graphics ».

Code de copie
$principal = New-SPClaimsPrincipal "contoso\jane" -IdentityType WindowsSamAccountName
$spapp = Get-SPServiceApplication -Name "Contoso Visio Graphics"
$security = Get-SPServiceApplicationSecurity $spapp -Admin
Revoke-SPObjectSecurity $security $principal "Full Control"
Set-SPServiceApplicationSecurity $spapp $security -Admin
(Get-SPServiceApplicationSecurity $spapp -Admin).AccessRules

Pour plus d'informations, voir les articles suivants relatifs à Windows PowerShell :

  • New-SPClaimsPrincipal

  • Get-SPServiceApplication

  • Get-SPServiceApplicationSecurity

  • Grant-SPObjectSecurity

  • Revoke-SPObjectSecurity

  • Set-SPServiceApplicationSecurity

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Supprimer une application de service (SharePoint Foundation 2010)
Voir aussi

Vous pouvez supprimer une application de service à l'aide de l'Administration centrale de SharePoint ou à l'aide d'applets de commande Windows PowerShell 2.0. Gardez à l'esprit que le fait de supprimer une application de service est définitif : vous ne pouvez pas annuler cette opération.

Avant de supprimer une application de service, vérifiez que cette opération n'affectera pas les utilisateurs. En guise de meilleure pratique, vous devez vous assurer qu'aucune application Web ne consomme actuellement l'application de service à supprimer. Pour plus d'informations sur la déconnexion d'une application de service d'une application Web, voir Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010).

Lorsque vous supprimez une application de service, vous pouvez également supprimer la base de données correspondante (toutes les applications de services ne possèdent pas de bases de données). Si l'application de service est appelée à être recréée, ne supprimez pas sa base de données. En revanche, si l'application de service est temporaire, vous pouvez à juste titre supprimer la base de données pendant cette opération.

Pour que l'application de service soit réutilisable à l'avenir, pensez à la sauvegarder avant de la supprimer. Pour plus d'informations, voir Sauvegarder une application de service (SharePoint Foundation 2010) et Restaurer une application de service (SharePoint Foundation 2010).

Dans cet article :

  • Pour supprimer une application de service à l'aide de l'administration centrale

  • Pour supprimer une application de service à l'aide de Windows PowerShell

Pour supprimer une application de service à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est un membre du groupe SharePoint des administrateurs de batterie de serveurs.

  2. Sur le site Web Administration centrale SharePoint, cliquez sur Gestion des applications, puis sur Gérer les applications de service.

  3. Dans la page Gérer les applications de service, cliquez sur la ligne qui contient l'application de service à supprimer. Le Ruban devient disponible.

  4. Sur le ruban, cliquez sur Supprimer.

  5. Dans la boîte de dialogue de confirmation, activez la case à cocher en regard de Supprimer les données associées aux applications de service si vous souhaitez supprimer la base de données de l'application de service. Si vous souhaitez conserver la base de données, laissez cette case à cocher désactivée.

  6. Cliquez sur OK pour supprimer l'application de service ou cliquez sur Annuler pour arrêter l'opération.

Pour supprimer une application de service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez les commandes suivantes.

  6. Pour récupérer l'application de service que vous souhaitez supprimer, tapez la commande suivante :

    Code de copie
    $spapp = Get-SPServiceApplication -Name "<Service application display name>"

    Où <Service application display name> est le nom complet de l'application de service à supprimer.

    Les informations relatives à l'application de service seront stockées dans la variable $spapp.

    Important :
    Vous devez taper le nom complet entre guillemets et la chaîne que vous entrez doit correspondre exactement au nom complet de l'application de service, y compris en ce que concerne la casse. Il est vivement recommandé de ne pas créer plusieurs applications de services portant le même nom complet : si vous vous trouvez dans cette situation, vous pouvez utiliser l'applet de commande Get-SPServiceApplication pour répertorier toutes les applications de services. Vous pouvez ensuite utiliser le GUID d'application de service avec le paramètre -Identity pour spécifier l'application de service à supprimer. Pour plus d'informations, voir Get-SPServiceApplication.

  7. Pour supprimer l'application de service sélectionnée, exécutez l'une des commandes suivantes. Dans les deux cas, vous êtes invité à confirmer la suppression.

    • Pour supprimer l'application de service sélectionnée sans supprimer la base de données correspondante, tapez la commande suivante :

      Code de copie
      Remove-SPServiceApplication $spapp
    • Pour supprimer l'application de service sélectionnée, ainsi que la base de données correspondante, tapez la commande suivante :

      Code de copie
      Remove-SPServiceApplication $spapp -RemoveData

Exemple

Code de copie
$spapp = Get-SPServiceApplication -Name "Contoso BDC Service"
Remove-SPServiceApplication $spapp -RemoveData
ConfirmerÊtes-vous sûr de vouloir effectuer cette action ? Opération « Remove-SPServiceApplication » en cours sur la cible

Dans cet exemple, les informations relatives à l'application de service « Contoso BDC Service » sont stockées dans la variable $spapp. Une fois l'action confirmée, l'application de service et sa base de données sont définitivement supprimées.

Pour plus d'informations, voir Get-SPServiceApplication et Remove-SPServiceApplication.

Voir aussi

Référence

Remove-SPServiceApplicationProxyGroup

Historique des modifications


Administration du service Connexion de données métiers (SharePoint Foundation 2010)

Les Services Microsoft Business Connectivity sont administrés principalement à l'aide du service Connexion de données métiers. Cette rubrique décrit les opérations générales d'administration du service Connexion de données métiers. Reportez-vous aux rubriques suivantes pour les opérations service Connexion de données métiers liées à des éléments stockés et gérés à l'aide du service :

  • Gérer les systèmes externes (SharePoint Foundation 2010)

  • Gestion des types de contenus externes (SharePoint Foundation 2010)

  • Gérer les modèles BDC (SharePoint Foundation 2010)

  • Business Connectivity Services security operations (SharePoint Foundation 2010) (en anglais)

Historique des modifications


Gérer les systèmes externes (SharePoint Foundation 2010)

Un système externe est une source de données, telle qu'un service Web, une base de données SQL Server, une autre base de données relationnelle ou un connecteur personnalisé, qui peut être utilisée dans une solution. Une instance d'un système externe comprend les informations de connexion et d'authentification d'une instance spécifique d'un système externe. Il peut exister plusieurs instances d'un système externe pour tout système externe. En configurant plusieurs instances de systèmes externes, le concepteur de solution peut définir différents paramètres de sécurité sur les connexions de données externes afin qu'il soit possible de se connecter de différentes manières au même système externe. Toutefois, dans de nombreuses applications, une seule instance de système externe suffit amplement.

Dans cet article :

  • Définir des autorisations sur un système externe

  • Afficher tous les systèmes externes pour une instance d'application du service de connectivité de données métiers

  • Supprimer un système externe

  • Afficher les types de contenu externe d'un système externe

  • Configurer un système externe

  • Configurer une instance d'un système externe

Définir des autorisations sur un système externe

Vous définissez des autorisations sur un système externe pour spécifier qui peut le modifier, qui peut exécuter des opérations (telles que des opérations de lecture ou de mise à jour) sur les types de contenu externe stockés sur le système externe, qui peut créer des listes externes à l'aide des données stockées sur le système externe et qui peut définir une autorisation sur celui-ci.

Nous vous recommandons d'affecter des autorisations spécifiques à chaque utilisateur ou groupe qui en a besoin, de telle manière que les informations d'identification fournissent le moindre privilège nécessaire à l'exécution des tâches requises. Pour plus d'informations sur la définition des autorisations, voir Vue d'ensemble des autorisations de Business Connectivity Services dans « Vue d'ensemble de la sécurité des Services Business Connectivity (SharePoint Foundation 2010) ».

Pour définir des autorisations sur un système externe

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et disposer de l'autorisation Définir les autorisations sur le système externe.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Systèmes externes.

  6. Activez la case à cocher du système externe pour lequel vous souhaitez définir des autorisations.

  7. Dans le groupe Autorisations, cliquez sur Définir les autorisations de l'objet.

  8. Dans le cadre, entrez les comptes d'utilisateur, les groupes ou les revendications auxquels des autorisations seront accordées, puis cliquez sur Ajouter.

    Remarque :
    Le nom du compte d'utilisateur, du groupe ou de la revendication ne doit pas contenir de barre verticale (|).

  9. Définissez les autorisations pour le compte, le groupe ou la revendication :

    Remarque :
    Au moins un utilisateur, groupe ou revendication dans la liste de contrôle d'accès de l'objet de métadonnées doit avoir l'autorisation Définir les autorisations.

    • Cliquez sur Modifier pour autoriser l'utilisateur, le groupe ou la revendication à modifier le système externe.

      Sécurité Remarque :
      L'autorisation Modifier doit être considérée comme hautement privilégiée. Avec cette autorisation, un utilisateur malveillant peut dérober des informations d'identification ou endommager une batterie de serveurs. Afin d'assurer la sécurité de la solution, nous vous recommandons d'utiliser un environnement de test dans lequel l'autorisation Modifier peut être assignée librement aux développeurs ou aux concepteurs de solutions. Lors du déploiement de la solution testée dans un environnement de production, supprimez les autorisations Modifier.

    • Cliquez sur Exécuter pour autoriser l'utilisateur, le groupe ou la revendication à exécuter des opérations (créer, lire, mettre à jour, supprimer ou interroger) sur les types de contenu externe stockés sur le système externe.

      Conseil :
      L'autorisation Exécuter ne s'applique pas au système externe proprement dit. Ce paramètre s'utilise lorsque vous souhaitez propager l'autorisation Exécuter à des objets enfants (tels que des types de contenu externe) dans le système externe.

    • Cliquez sur Sélectionnable dans les clients pour autoriser l'utilisateur, le groupe ou la revendication à créer des listes externes de tous les types de contenu externe dont les données sont stockées sur le système externe et à afficher les types de contenu externe dans le sélecteur d'éléments externes.

      Conseil :
      L'autorisation Sélectionnable dans les clients ne s'applique pas au système externe proprement dit. Ce paramètre s'utilise lorsque vous souhaitez propager l'autorisation Sélectionnable dans les clients à des objets enfants (tels que des types de contenu externe) dans le système externe.

    • Cliquez sur Définir les autorisations pour autoriser l'utilisateur, le groupe ou la revendication à définir des autorisations sur le système externe.

      Sécurité Remarque :
      L'autorisation Définir les autorisations doit être considérée comme hautement privilégiée. Avec cette autorisation, un utilisateur peut accorder l'autorisation Modifier sur le système externe.

  10. Pour propager les autorisations à tous les éléments imbriqués dans le système externe, cliquez sur Propager les autorisations à tous les types de contenu externe qui appartiennent à ce système externe. Cette opération remplace les autorisations existantes..

Afficher tous les systèmes externes pour une instance d'application du service de connectivité de données métiers

Affichez les systèmes externes dans l'application de service Connexion de données métiers pour choisir un système externe avant de le configurer ou pour effectuer une autre opération.

Pour afficher tous les systèmes externes pour une instance d'application du service de connectivité de données métiers

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Systèmes externes.

Supprimer un système externe

Supprimez un système externe pour le retirer du magasin de métadonnées.

Remarque :
Vous ne pouvez pas supprimer un système externe qui contient des types de contenu externe dans le magasin de métadonnées. Pour supprimer le système externe, vous devez d'abord supprimer tous les types de contenu externe qu'il contient.

Pour supprimer un système externe

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et posséder l'autorisation Modifier sur le système externe.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Systèmes externes.

  6. Pointez sur le système externe, cliquez sur la flèche qui apparaît, puis cliquez sur Supprimer.

Afficher les types de contenu externe d'un système externe

Les systèmes externes mettent les données externes à votre disposition par le biais de types de contenu externe. Vous pouvez afficher tous les types de contenu externe associés à un système externe.

Pour afficher les types de contenu externe d'un système externe

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Systèmes externes.

  6. Pointez sur le système externe, cliquez sur la flèche qui apparaît, puis cliquez sur Types de contenu externe.

Configurer un système externe

Vous pouvez configurer certains paramètres d'un système externe à l'aide du service Connexion de données métiers.

Pour configurer un système externe

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et posséder l'autorisation Modifier sur le système externe.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Systèmes externes.

    Conseil :
    Les seuls systèmes externes configurables dans le service Connexion de données métiers sont les services Web WCF (Windows Communication Foundation).

  6. Pointez sur le système externe, cliquez sur la flèche qui apparaît, puis cliquez sur Paramètres.

  7. Modifiez ou affichez les paramètres.

    Si le système externe est un service Web WCF, les paramètres suivants sont disponibles :

    Champ Remarque

    URL d'échange de métadonnées

    Adresse Web complète du fichier .wsdl (Web Service Description Language) du service Web.

    Mode de découverte d'échange de métadonnées

    Protocole à utiliser pour découvrir les métadonnées de service Web :

    • Disco : le service Connexion de données métiers utilise DiscoveryClientProtocol (équivalent à wsdl.exe ) pour télécharger les métadonnées.

    • MetadataExchange : le service Connexion de données métiers utilise WS-Transfer (équivalent à svcutil /mex) pour télécharger les métadonnées.

    • CustomProxy : le service Connexion de données métiers ne tente pas de découvrir le service. Lorsque cette option est sélectionnée, l'utilisateur doit spécifier l'adresse, la liaison et le contact pour le service.

    Mode d'authentification WSDL

    La façon dont les informations d'identification entrantes sont transmises par défaut au service Web.

    Cinq choix sont disponibles :

    Mode Description

    Identité de l'utilisateur

    Utilise les informations d'identification de l'utilisateur ayant ouvert une session pour authentifier celui-ci auprès du service Web.

    Ce mode est appelé PassThrough dans le fichier de modèle BDC.

    Identité BDC

    Utilise le compte de pool d'applications sous lequel le service Connexion de données métiers s'exécute pour authentifier l'utilisateur ayant ouvert une session auprès du service Web.

    Ce mode est appelé RevertToSelf dans le fichier de modèle BDC.

    Emprunter l'identité personnalisée

    Destiné aux services Web qui utilisent l'authentification de base au lieu de l'authentification Windows.

    Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par le service Web.

    Ce mode est appelé Credentials dans le fichier de modèle BDC.

    Emprunter l'identité Windows

    Destiné aux services Web qui utilisent l'authentification Windows.

    Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par le service Web.

    Ce mode est appelé WindowsCredentials dans le fichier de modèle BDC.

    Emprunter l'identité personnalisée - Digest

    Destiné aux services Web qui utilisent l'authentification Digest au lieu de l'authentification Windows. Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par le service Web.

    Ce mode est appelé DigestCredentials dans le fichier de modèle BDC.

    ID de l'application cible de stockage d'informations de sécurité WSDL

    Pour l'authentification Emprunter l'identité personnalisée - Digest, Emprunter l'identité Windows et Emprunter l'identité personnalisée, il s'agit de l'identificateur d'application cible pour ce service Web, tel que configuré dans le service Banque d'informations sécurisé.

    Implémentation du stockage d'informations de sécurité

    Si vous spécifiez un fournisseur de banque d'informations personnalisé, indiquez le nom d'assembly complet du fournisseur. Dans le cas contraire, laissez ce champ vide.

  8. Cliquez sur OK.

Configurer une instance d'un système externe

Il peut y avoir une ou plusieurs instances de système externe pour un système externe. En configurant plusieurs instances d'un système externe, le concepteur de solution peut définir différents paramètres de sécurité sur les connexions de données externes afin de prendre en charge plusieurs modes de connexion au même système externe.

Pour configurer une instance d'un système externe

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et posséder l'autorisation Modifier sur le système externe.

  2. Dans le service Connexion de données métiers, cliquez sur l'onglet Modifier.

  3. Dans le groupe Affichage, cliquez sur Systèmes externes.

  4. Cliquez sur le système externe pour afficher ses instances.

    Conseil :
    Les seules instances de types de systèmes externes configurables par défaut sont les bases de données et les services Web WCF.

  5. Pointez sur l'instance de système externe, cliquez sur la flèche qui apparaît, puis cliquez sur Paramètres.

  6. Modifiez ou affichez les paramètres.

    Si le système externe est un service Web WCF, les paramètres suivants sont disponibles :

    Champ Description

    Mode d'authentification

    La façon dont les informations d'identification entrantes sont transmises au service Web.

    Cinq choix sont disponibles :

    Mode Description

    Identité de l'utilisateur

    Utilise les informations d'identification de l'utilisateur ayant ouvert une session pour authentifier celui-ci auprès du service Web.

    Ce mode est appelé PassThrough dans le fichier de modèle BDC.

    Identité BDC

    Utilise le compte de pool d'applications sous lequel le service Connexion de données métiers s'exécute pour authentifier l'utilisateur ayant ouvert une session auprès du service Web.

    Ce mode est appelé RevertToSelf dans le fichier de modèle BDC.

    Emprunter l'identité personnalisée

    Destiné aux services Web qui utilisent l'authentification de base au lieu de l'authentification Windows.

    Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par le service Web.

    Ce mode est appelé Credentials dans le fichier de modèle BDC.

    Emprunter l'identité Windows

    Destiné aux services Web qui utilisent l'authentification Windows.

    Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par le service Web.

    Ce mode est appelé WindowsCredentials dans le fichier de modèle BDC.

    Emprunter l'identité personnalisée - Digest

    Destiné aux services Web qui utilisent l'authentification Digest au lieu de l'authentification Windows. Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par le service Web.

    Ce mode est appelé DigestCredentials dans le fichier de modèle BDC.

    Adresse du point de terminaison de service

    Adresse Web complète du fichier .wsdl du service Web.

    Niveau d'emprunt d'identité

    Degré auquel le service Connexion de données métiers peut agir pour le compte de l'utilisateur lors de la connexion à un service Web externe. Les valeurs possibles sont les suivantes :

    • Aucun : aucun niveau d'emprunt d'identité n'est assigné.

    • Anonyme : le processus serveur ne peut pas obtenir d'informations d'identification concernant le client et ne peut pas emprunter son identité.

    • Identification : le processus serveur peut obtenir des informations concernant le client, tels que les identificateurs de sécurité et les privilèges, mais il ne peut pas emprunter son identité. Ceci est utile pour les serveurs qui exportent leurs propres objets, par exemple les produits de base de données qui exportent des tables et des affichages. Grâce aux informations de sécurité sur le client extraites, le serveur peut prendre des décisions en matière de validation d'accès sans pouvoir utiliser d'autres services qui utilisent le contexte de sécurité du client.

    • Emprunt d'identité : le processus serveur peut emprunter l'identité du contexte de sécurité du client sur son système local, mais il ne peut pas emprunter l'identité du client sur les systèmes distants.

    • Délégation : le processus serveur peut emprunter l'identité du contexte de sécurité du client sur son système local, mais il ne peut pas emprunter l'identité du client sur les systèmes distants.

    ID de l'application cible de stockage d'informations de sécurité

    Pour l'authentification Emprunter l'identité personnalisée et Emprunter l'identité Windows, il s'agit de l'identificateur d'application cible pour ce service Web, tel que configuré dans le service Banque d'informations sécurisé.

    ID de l'application cible de stockage d'informations de sécurité secondaire

    Ce champ sert à fournir l'identificateur de l'application cible du filtre facultatif qui sera utilisée pour capturer les valeurs d'entrée fournies par l'utilisateur pour les champs liés à la banque d'informations sécurisée. Pour plus d'informations sur les types de filtres pris en charge et sur l'implémentation des filtres, voir le Kit de développement logiciel (SDK) Microsoft SharePoint 2010 (http://go.microsoft.com/fwlink/?linkid=166117&clcid=0x40C).

    Implémentation du stockage d'informations de sécurité

    Si vous spécifiez un fournisseur de banque d'informations personnalisé, indiquez le nom d'assembly complet du fournisseur. Dans le cas contraire, laissez ce champ vide.

    Si le système externe est une base de données, les paramètres suivants sont disponibles :

    Champ Description

    Fournisseur d'accès

    Type de base de données.

    Mode d'authentification

    Manière dont les informations d'identification entrantes sont transmises à la base de données

    Quatre choix sont disponibles :

    Mode Description

    Identité de l'utilisateur

    Utilise les informations d'identification de l'utilisateur ayant ouvert une session pour authentifier celui-ci auprès de la base de données.

    Ce mode est appelé PassThrough dans le fichier de modèle BDC.

    Identité BDC

    Utilise le compte de pool d'applications sous lequel les service Connexion de données métiers s'exécutent pour authentifier l'utilisateur ayant ouvert une session auprès de la base de données.

    Ce mode est appelé RevertToSelf dans le fichier de modèle BDC.

    Emprunter l'identité personnalisée

    Destiné aux bases de données qui n'utilisent pas l'authentification Windows.

    Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par la base de données.

    Ce mode est appelé RdbCredentials dans le fichier de modèle BDC.

    Emprunter l'identité Windows

    Destiné aux bases de données qui utilisent l'authentification Windows.

    Utilise le service Banque d'informations sécurisé pour mapper les informations d'identification de l'utilisateur aux informations d'identification individuelles ou de groupes utilisées par la base de données.

    Ce mode est appelé WindowsCredentials dans le fichier de modèle BDC.

    Serveur de base de données

    Nom du serveur de base de données.

    Nom de la base de données initiale

    Nom de la base de données.

    Sécurité intégrée

    Si vous utilisez la sécurité intégrée, tapez la chaîne « SSPI » et les service Connexion de données métiers utiliseront les informations d'identification Windows de l'utilisateur pour se connecter au système externe. Si vous n'utilisez pas la sécurité intégrée, laissez ce champ vide et les service Connexion de données métiers se connecteront à l'aide des informations d'identification uniques du serveur de bases de données.

    Regroupement de connexions

    Si ce champ est sélectionné, le service Connexion de données métiers conservera la propriété des connexions au système externe dans un pool en tant qu'optimisation.

    ID cible de l'application cible de stockage d'informations de sécurité

    Pour l'authentification Emprunter l'identité personnalisée et Emprunter l'identité Windows, il s'agit de l'identificateur d'application cible pour cette base de données, tel que configuré dans le service Banque d'informations sécurisé.

    ID cible de l'application cible de stockage d'informations de sécurité secondaire

    Ce champ sert à fournir l'identificateur de l'application cible du filtre facultatif qui sera utilisée pour capturer les valeurs d'entrée fournies par l'utilisateur pour les champs liés à la banque d'informations sécurisée. Pour plus d'informations sur les types de filtres pris en charge et sur l'implémentation des filtres, voir le Kit de développement logiciel (SDK) Microsoft SharePoint 2010 (http://go.microsoft.com/fwlink/?linkid=166117&clcid=0x40C).

    Implémentation du stockage d'informations de sécurité

    Si vous spécifiez un fournisseur de banque d'informations personnalisé, indiquez le nom d'assembly complet du fournisseur. Dans le cas contraire, laissez ce champ vide.

  7. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
9 septembre 2010 | 2010/09/06 | Mise à jour du contenu
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Gérer les modèles BDC (SharePoint Foundation 2010)

Un modèle BDC est un fichier XML qui contient des jeux de descriptions d'un ou plusieurs types de contenu externe, leurs systèmes externes connexes et des informations spécifiques à l'environnement, telles que les propriétés d'authentification. Les métadonnées dans un modèle définissent les champs de données dans chaque type de contenu externe, les opérations qui sont prises en charge sur le système externe (telles que les tâches de lecture, d'écriture et d'interrogation du système externe) et les informations de connectivité.

Le service Connexion de données métiers fournit un jeu d'opérations qui prennent en charge l'importation et l'exportation des modèles, la définition d'autorisations sur ceux-ci et l'affichage des types de contenu externe qu'ils contiennent. Par exemple, vous pouvez exporter un modèle BDC pour le déployer depuis un environnement de développement vers un environnement de production.

Un fichier de ressources contient les noms localisés, les propriétés et les autorisations d'un ou plusieurs types de contenu externe. Pour importer et exporter des fichiers de ressources, vous pouvez recourir au même procédé que celui que vous utilisez pour les modèles BDC. Par exemple, vous pouvez importer un fichier de ressources pour fournir un nouveau jeu de chaînes localisées pour une langue supplémentaire dans laquelle une solution sera utilisée.

Dans cet article :

  • Importer un modèle BDC

  • Exporter un fichier de modèle BDC ou de ressources

  • Définir des autorisations sur un modèle BDC

  • Afficher tous les modèles

  • Supprimer un modèle BDC

  • Afficher les types de contenu externe d'un modèle

Importer un modèle BDC

L'importation d'un modèle est le moyen principal utilisé pour l'ajouter, ainsi que les types de contenu externe et les systèmes externes, dans un magasin de métadonnées.

Chaque type de contenu externe possède un nom, un espace de noms et un numéro de version, qui servent à identifier le type de contenu externe. Il peut exister plusieurs versions d'un type de contenu externe dans le magasin de métadonnées à tout moment. À mesure que vous importez, ajoutez ou supprimez des modèles, que vous activez ou désactivez des types de contenu externe et que vous ajoutez ou supprimez des types de contenu externe, vous pouvez vous retrouver avec de nombreuses versions d'un type de contenu externe. S'il existe plusieurs versions d'un type de contenu externe dans le magasin de métadonnées, le runtime Business Data Connectivity utilise la version qui est active, quel que soit le numéro de version du type de contenu externe. Le type de contenu externe actif peut être la dernière version qui a été importée ou la version qui a été activée à l'aide de l'applet de commande Enable-SPBusinessDataCatalogEntity.

Attention :
Si le modèle ne spécifie pas de mode d'authentification, le mode d'authentification PassThrough est utilisé. Ce mode peut ne pas convenir à tous les scénarios. Il est destiné principalement aux environnement de test avec une configuration de type « ordinateur unique » (autrement dit, le serveur de bases de données et SharePoint Foundation s'exécutent sur le même ordinateur). Pour plus d'informations sur les modes d'authentification, voir Vue d'ensemble de l'authentification de Business Connectivity Services.

Conseil :
Vous pouvez également importer un fichier de ressources ou de modèle à l'aide de Windows PowerShell. Pour plus d'informations, voir Import-SPBusinessDataCatalogModel.

Pour importer un fichier de modèle BDC ou de ressources

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et posséder l'autorisation Modifier sur le magasin de métadonnées.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Modèles BDC, cliquez sur Importer.

  6. Dans la page Importer un modèle BDC, dans le champ Fichier de modèle BDC, cliquez sur Parcourir pour rechercher le fichier de modèle BDC ou de ressources.

    Important :
    Le nom d'un modèle BDC ne doit pas contenir les caractères suivants : ~"#%&*:<>?\{|} ou le caractère 0x7f.

  7. Dans le champ Type de fichier, sélectionnez le type de fichier de modèle BDC à importer : Modèle ou Ressource.

  8. Dans la zone Paramètres avancés, sélectionnez un ou plusieurs types de ressources à importer :

    • Cliquez sur Noms localisés pour exporter les noms localisés des types de contenu externe dans une langue correspondant à des paramètres régionaux spécifiques.

      Les noms localisés importés sont fusionnés avec les noms localisés existants dans la base de données service Connexion de données métiers.

    • Cliquez sur Propriétés pour importer les propriétés des types de contenu externe.

      Les propriétés importées sont fusionnées avec les descriptions de propriétés existantes dans la base de données service Connexion de données métiers.

    • Cliquez sur Autorisations pour importer les autorisations des types de contenu externe et autres objets sécurisables dans le modèle.

      Attention :
      Les autorisations sont stockées avec les informations des autorisations existantes dans le service Connexion de données métiers. Si une entrée pour un objet existe déjà dans la liste de contrôle d'accès, sa valeur est remplacée par les informations d'autorisations provenant du fichier importé. Par exemple, supposez que les autorisations pour le type de contenu externe X permettent à l'utilisateur A d'accéder à ce type de contenu externe. Si vous importez des autorisations qui spécifient que seul l'utilisateur B a accès au type de contenu externe X, les autorisations antérieures pour le type de contenu externe X sont supprimées et de nouvelles autorisations contenant uniquement les autorisations pour l'utilisateur B sont stockées.

  9. Pour enregistrer le groupe de paramètres de ressources importés dans un fichier qui pourra être ultérieurement exporté en vue de son utilisation dans un environnement particulier, dans le champ Utiliser les paramètres d'environnement personnalisés, tapez un nom unique pour le jeu de paramètres spécifiques à l'environnement.

Exporter un fichier de modèle BDC ou de ressources

Après l'exportation d'un fichier de ressources ou de modèle BDC, vous pouvez utiliser le fichier exporté pour déployer le modèle BDC sur un système différent. Vous pouvez utiliser l'une des méthodes suivantes pour exporter un fichier de ressources ou de modèle BDC :

  • utiliser l'Administration centrale pour exporter un fichier de ressources ou de modèle BDC ;

  • utiliser l'applet de commande Export-SPBusinessDataCatalogModel pour exporter un fichier de ressources ou de modèle BDC ;

  • utiliser Microsoft SharePoint Designer 2010 pour exporter un modèle BDC.

    Remarque :
    Si un modèle BDC a été créé à l'aide de SharePoint Designer 2010, vous devez utiliser SharePoint Designer pour l'exporter. Si un modèle créé à l'aide de SharePoint Designer est exporté par le biais de l'Administration centrale ou de l'applet de commande Export-SPBusinessDataCatalogModel, le fichier de modèle exporté inclut uniquement des espaces réservés pour les types de contenu externe. Pour plus d'informations sur SharePoint Designer, voir Aide et procédures SharePoint Designer (http://go.microsoft.com/fwlink/?linkid=198249&clcid=0x40C).

Pour exporter un fichier de modèle BDC ou de ressources

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application service Connexion de données métiers et posséder l'autorisation Modifier sur le modèle et sur tous les systèmes externes contenus dans le modèle.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Modèles BDC.

  6. Dans la page Modèles Business Data Connectivity Model, sélectionnez le fichier de modèle ou de ressources à exporter.

  7. Dans le groupe Modèles BDC, cliquez sur Exporter.

  8. Dans la page Exporter, dans le champ Type de fichier, sélectionnez le type de fichier que vous exportez (Modèle ou Ressource) et, dans la zone Paramètres avancés, sélectionnez un ou plusieurs types de ressources à exporter :

    • Cliquez sur Noms localisés pour exporter les noms localisés des types de contenu externe dans une langue correspondant à des paramètres régionaux spécifiques.

    • Cliquez sur Propriétés pour exporter les propriétés des types de contenu externe.

    • Cliquez sur Autorisations pour exporter les autorisations des types de contenu externe.

    • Cliquez sur Serveur proxy pour exporter un proxy spécifique à l'implémentation grâce auquel il est possible de se connecter au système externe.

  9. Si vous avez enregistré un jeu de ressources qui pourra être exporté ultérieurement en vue de son utilisation dans un environnement particulier, dans le champ Utiliser les paramètres d'environnement personnalisés, tapez le nom unique associé aux paramètres à exporter spécifiques à l'environnement.

  10. Cliquez sur Exporter.

    L'interface permettant d'enregistrer le fichier de modèle BDC ou de ressources à un emplacement de votre réseau apparaît sur votre écran.

Définir des autorisations sur un modèle BDC

Vous définissez des autorisations sur un modèle BDC pour spécifier qui peut le modifier et définir des autorisations sur ce modèle.

Nous vous recommandons d'affecter des autorisations spécifiques à chaque utilisateur ou groupe qui en a besoin, de telle manière que les informations d'identification fournissent le moindre privilège nécessaire à l'exécution des tâches requises. Pour plus d'informations sur la définition des autorisations, voir Vue d'ensemble des autorisations de Business Connectivity Services dans « Vue d'ensemble de la sécurité des Services Business Connectivity (SharePoint Foundation 2010) ».

Pour définir des autorisations sur un modèle BDC

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et posséder l'autorisation Définir les autorisations sur le modèle.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Modèles BDC.

  6. Activez la case à cocher de chaque modèle BDC pour lequel vous souhaitez définir des autorisations.

  7. Dans le groupe Autorisations, cliquez sur Définir les autorisations de l'objet.

  8. Dans le cadre, entrez les comptes d'utilisateur, les groupes ou les revendications auxquels des autorisations seront accordées, puis cliquez sur Ajouter.

    Remarque :
    Le nom du compte d'utilisateur, du groupe ou de la revendication ne doit pas contenir de barre verticale (|).

  9. Définissez les autorisations pour le compte, le groupe ou la revendication.

    Remarque :
    Au moins un utilisateur, groupe ou revendication dans la liste de contrôle d'accès de l'objet de métadonnées doit avoir l'autorisation Définir les autorisations.

    • Cliquez sur Modifier pour autoriser l'utilisateur, le groupe ou la revendication à modifier le modèle BDC.

      Sécurité Remarque :
      L'autorisation Modifier doit être considérée comme hautement privilégiée. Avec cette autorisation, un utilisateur malveillant peut dérober des informations d'identification ou endommager une batterie de serveurs. Afin d'assurer la sécurité de la solution, nous vous recommandons d'utiliser un environnement de test dans lequel l'autorisation Modifier peut être assignée librement aux développeurs ou aux concepteurs de solutions. Lors du déploiement de la solution testée dans un environnement de production, supprimez les autorisations Modifier.

    • Cliquez sur Définir les autorisations pour autoriser l'utilisateur, le groupe ou la revendication à définir des autorisations sur le modèle BDC.

      Sécurité Remarque :
      L'autorisation Définir les autorisations doit être considérée comme hautement privilégiée. Avec cette autorisation, un utilisateur peut accorder l'autorisation Modifier sur le modèle BDC.

      Important :
      Les deux autres autorisations répertoriées, Sélectionnable dans les clients et Exécuter, ne sont pas applicables aux modèles BDC.

Afficher tous les modèles

Vous pouvez afficher tous les modèles dans une application du service Connexion de données métiers.

Pour afficher tous les modèles

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Modèles BDC.

Supprimer un modèle BDC

Lorsque vous supprimez un modèle BDC, tous les types de contenu externe et les systèmes externes qui se trouvent dans ce modèle et exclusivement dans celui-ci sont supprimés en même temps que lui.

Pour supprimer un modèle BDC

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et posséder l'autorisation Modifier sur le modèle.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Modèles BDC.

  6. Dans la page Modèles BDC, sélectionnez le modèle à supprimer.

  7. Dans le groupe Modèles BDC, cliquez sur Supprimer puis, à l'invite, cliquez sur OK.

Afficher les types de contenu externe d'un modèle

Affichez les types de contenu externe d'un modèle pour en savoir plus sur le modèle ou bien choisissez un type de contenu externe pour une tâche ultérieure.

Pour afficher les types de contenu externe d'un modèle

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Modèles BDC.

  6. Pointez sur le modèle, cliquez sur la flèche qui apparaît, puis cliquez sur Types de contenu externe.

Historique des modifications

Date | Description | Raison
9 septembre 2010 | 2010/09/06 | Mise à jour du contenu
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Gestion des types de contenus externes (SharePoint Foundation 2010)

Un type de contenu externe est un fichier XML qui définit un objet, tel que « Client », « Commande » ou « Contact », qui peut être utilisé dans une application métier. La définition peut inclure les informations suivantes :

  • les champs de données contenus dans l'objet ;

  • les méthodes pour créer, lire, mettre à jour, supprimer ou effectuer une requête sur cet objet ;

  • les actions que les utilisateurs peuvent effectuer sur l'objet ;

  • les informations permettant la connexion à la source de données externe qui fournit les données de l'objet.

Les types de contenu externe définissent les données qui sont stockées dans un système externe pris en charge, par exemple une base de données SQL Server ou une autre base de données relationnelle, un site SharePoint, un service Web ou un connecteur de données personnalisé.

Il est possible d'ajouter un type de contenu externe au service Connexion de données métiers des façons suivantes :

  • Utilisez Microsoft SharePoint Designer 2010 pour créer un nouveau type de contenu externe.

  • Importez un modèle d'application dans l'application du service Connexion de données métiers qui contient un ou plusieurs types de contenu externe.

    Les types de contenu externe sont ajoutés à l'application du service Connexion de données métiers.

Après l'ajout d'un type de contenu externe à l'application du service Connexion de données métiers, les administrateurs de cette application de service peuvent modifier ses autorisations ou ajouter des fonctionnalités supplémentaires, telles que des actions et des pages de profils.

Contenu de cet article :

  • Définir des autorisations sur un type de contenu externe

  • Afficher tous les types de contenu externe pour une instance d'une application de service Business Data Connectivity

  • Afficher tous les types de contenu externe contenus dans un modèle

  • Afficher les détails d'un type de contenu externe

  • Suppression d'un type de contenu externe

  • Ajout d'une action à un type de contenu externe

  • Spécifier l'hôte des pages de profil pour une instance d'une application de service Business Data Connectivity

  • Création ou mise à jour d'une page de profil pour un type de contenu externe

Définir des autorisations sur un type de contenu externe

Vous définissez des autorisations sur un type de contenu externe pour spécifier qui peut modifier le type de contenu, qui peut effectuer des opérations (telles que lire ou mettre à jour) sur celui-ci, qui peut l'utiliser pour créer des listes externes, et qui peut définir des autorisations sur ce type.

Nous vous recommandons d'affecter des autorisations spécifiques à chaque utilisateur ou groupe qui en a besoin, de telle manière que les informations d'identification fournissent le moindre privilège nécessaire à l'exécution des tâches requises. Pour plus d'informations sur la définition des autorisations, voir Vue d'ensemble des autorisations de Business Connectivity Services dans « Vue d'ensemble de la sécurité des Services Business Connectivity (SharePoint Foundation 2010) ».

Pour définir des autorisations sur un type de contenu externe

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et disposer de l'autorisation Définir les autorisations sur le type de contenu externe.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Types de contenu externe.

  6. Activez la case à cocher de chaque type de contenu externe pour lequel vous voulez définir des autorisations.

  7. Dans le groupe Autorisations, cliquez sur Définir les autorisations de l'objet.

  8. Dans le cadre, entrez les comptes d'utilisateur, les groupes ou les revendications auxquels des autorisations seront accordées, puis cliquez sur Ajouter.

    Remarque :
    Le nom du compte d'utilisateur, du groupe ou de la revendication ne doit pas contenir de barre verticale (|).

  9. Définissez les autorisations pour le compte, le groupe ou la revendication :

    Remarque :
    Au moins un utilisateur, groupe ou revendication dans la liste de contrôle d'accès de l'objet de métadonnées doit avoir l'autorisation Définir les autorisations.

    • Cliquez sur Modifier pour autoriser l'utilisateur, le groupe ou la revendication à modifier le type de contenu externe.

      Sécurité Remarque :
      L'autorisation Modifier doit être considérée comme hautement privilégiée. Avec cette autorisation, un utilisateur malveillant peut dérober des informations d'identification ou endommager une batterie de serveurs. Afin d'assurer la sécurité de la solution, nous vous recommandons d'utiliser un environnement de test dans lequel l'autorisation Modifier peut être assignée librement aux développeurs ou aux concepteurs de solutions. Lors du déploiement de la solution testée dans un environnement de production, supprimez les autorisations Modifier.

    • Cliquez sur Exécuter pour autoriser l'utilisateur, le groupe ou la revendication à exécuter des opérations (créer, lire, mettre à jour, supprimer ou interroger) sur le type de contenu externe.

    • Cliquez sur Sélectionnable dans les clients pour autoriser l'utilisateur, le groupe ou la revendication à créer des listes externes du type de contenu externe et à afficher le type de contenu externe dans le sélecteur d'éléments externes.

    • Cliquez sur Définir les autorisations pour autoriser l'utilisateur, le groupe ou la revendication à définir des autorisations sur le type de contenu externe.

      L'autorisation Définir les autorisations doit être considérée comme hautement privilégiée. Avec cette autorisation, un utilisateur peut accorder l'autorisation Modifier sur le type de contenu externe.

  10. Pour propager les autorisations à toutes les méthodes imbriquées dans le type de contenu externe, cliquez sur Propager les autorisations à toutes les méthodes de ce type de contenu externe. Elles remplaceront ainsi les autorisations existantes.

Afficher tous les types de contenu externe pour une instance d'une application de service Business Data Connectivity

Vous pouvez utiliser des commandes dans le groupe Affichage du Ruban pour afficher tous les types de contenu externe dans l'application du service Connexion de données métiers.

Pour afficher tous les types de contenu externe pour une instance d'une application de service Business Data Connectivity

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Types de contenu externe.

Afficher tous les types de contenu externe contenus dans un modèle

Affichez tous les types de contenu externe d'un modèle pour en savoir plus sur le modèle ou bien sélectionnez un type de contenu externe pour d'autres opérations.

Pour afficher tous les types de contenu externe contenus dans un modèle

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Modèles BDC.

  6. Pointez sur le modèle BDC, cliquez sur la flèche qui apparaît, puis cliquez sur Types de contenu externe.

Afficher les détails d'un type de contenu externe

Vous pouvez afficher un type de contenu externe pour obtenir des informations sur celui-ci : ses champs, ses relations avec d'autres entités et les actions ou les filtres qui y sont associés. Vous pouvez afficher une liste de tous les types de contenu externe pour une application du service Connexion de données métiers ou afficher seulement les entités qui sont associées à un modèle particulier.

Pour afficher les détails d'un type de contenu externe

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Pointez sur le type de contenu externe que vous souhaitez afficher, cliquez sur la flèche qui apparaît, puis cliquez sur Type de contenu externe.

Suppression d'un type de contenu externe

Supprimez un type de contenu externe pour le supprimer du magasin de métadonnées. S'il existe plusieurs versions d'un type de contenu externe, la suppression du type de contenu entraînera la suppression de toutes les versions.

Pour supprimer un type de contenu externe

  1. Vérifiez que vous disposez d'une des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie.

    • Vous devez être administrateur de l'application du service Connexion de données métiers et disposer de l'autorisation Modifier sur le type de contenu externe.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Types de contenu externe.

  6. Sélectionnez chaque type de contenu externe à supprimer.

  7. Sous l'onglet Modifier, dans le groupe Gérer, cliquez sur Supprimer.

Ajout d'une action à un type de contenu externe

Vous pouvez ajouter une action personnalisée à un type de contenu externe. Une action personnalisée peut être un programme ou une page Web qui est accessible à l'aide de son URL. Lorsque vous associez une action à un type de contenu externe, vous pouvez passer des paramètres à cette action, en fonction du contenu d'un ou plusieurs champs du type de contenu externe. Par exemple, vous pouvez associer l'URL d'une page de recherche à un type de contenu externe et fournir des données provenant d'un élément de ce type de contenu externe pour paramétrer la recherche.

Remarque :
Lorsque vous ajoutez une nouvelle action à un type de contenu externe, cette action n'est pas disponible dans les listes externes existantes de ce type de contenu externe. Seules les nouvelles listes externes du type de contenu externe approprié affichent l'action dans le menu contextuel.

Pour ajouter une action à un type de contenu externe

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sur la page Types de contenu externe, sélectionnez le type de contenu externe auquel vous voulez ajouter une action.

  6. Pointez sur le type de contenu externe, cliquez sur la flèche qui apparaît, puis cliquez sur Ajouter une action.

  7. Dans la page Ajouter une action, dans la zone de texte Nom de l'action, entrez le nom de l'action.

    Ce peut être n'importe quelle chaîne de texte. Il s'agit du nom de commande que l'utilisateur voit dans le menu contextuel lorsqu'il pointe sur un élément du type de contenu externe et clique sur la flèche qui apparaît.

  8. Dans le champ Accéder à l'URL suivante, entrez l'URL complète de la commande à laquelle l'utilisateur accède lorsqu'il clique sur l'action.

    Une commande peut inclure des paramètres qui reçoivent la valeur du contenu d'un ou plusieurs champs du type de contenu externe. Dans l'URL que vous entrez dans ce champ, vous pouvez inclure des espaces réservés pour chaque paramètre à utiliser. Les espaces réservés doivent être numérotés avec des entiers en commençant par zéro (0, 1, 2, etc.) et doivent avoir le format {numéro}. Par exemple, l'URL suivante fournit deux paramètres, « p0 » et « p1 » :

    http://www.microsoft.com/en/us/default.aspx{0}&p1={1}

    Attention :
    Les paramètres peuvent contenir des informations d'identification personnelles telles que des noms et des numéros de Sécurité sociale. Lors de la conception d'actions, prenez soin de ne pas utiliser de champs qui affichent de telles informations par inadvertance ou, en cas de nécessité, assurez-vous que vos serveurs Web utilisent le protocole SSL (Secure Sockets Layer) sur tous les points de connexion.

  9. Si votre action est disponible depuis un composant WebPart, cliquez sur Oui sous Lancer l'action dans une nouvelle fenêtre de navigateur Web (s'applique uniquement aux composants WebPart de données externes) pour faire en sorte que l'action ouvre une nouvelle fenêtre de navigateur. Cela évitera à l'utilisateur de perdre le contexte actuel lors de l'utilisation de l'action. Pour que l'action s'exécute dans la fenêtre de navigation active, cliquez sur Non.

  10. Si votre action inclut des paramètres, dans le champ Propriété de paramètre, pour chaque espace réservé de paramètre de votre URL, en commençant par le paramètre {0}, cliquez sur Ajouter un paramètre et, dans la liste des champs disponibles, dans le type de contenu externe, cliquez sur le champ dont vous voulez passer le contenu à ce paramètre.

    Répétez cette étape pour chaque paramètre de l'URL de la commande. Vous pouvez supprimer un paramètre en cliquant sur le bouton Supprimer en regard du paramètre.

  11. Pour associer une icône à l'action personnalisée, dans la section Icône, cliquez sur Icône standard et choisissez une icône dans la liste ou bien, dans le champ L'image à cette URL, entrez l'URL complète d'une image à utiliser comme icône de l'action.

  12. L'action par défaut est celle qui est effectuée lorsque l'utilisateur clique sur l'élément au lieu de sélectionner une action dans un menu. Pour que l'action devienne l'action par défaut, cliquez sur Action par défaut.

  13. Cliquez sur OK pour ajouter l'action.

Spécifier l'hôte des pages de profil pour une instance d'une application de service Business Data Connectivity

Une page de profil affiche les données pour un élément d'un type de contenu externe. Les pages de profil pour une application du service Connexion de données métiers sont stockées dans un site de la batterie qui héberge le service Connexion de données métiers. Vous pouvez spécifier le site où les pages de profil sont hébergées.

Pour spécifier l'hôte des pages de profil pour une instance d'une application de service Business Data Connectivity

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sous l'onglet Modifier, dans le groupe Pages de profil, cliquez sur Configurer.

  6. Dans la page Hôte des pages de profil d'entités, dans le champ URL du site SharePoint hôte, spécifiez l'URL d'un site où les pages de profil des types de contenu externe doivent être créées et stockées. Ce site doit être dans la même batterie de serveurs que l'instance de l'application du service Connexion de données métiers.

    Important :
    Le site où les pages de profil d'un type de contenu externe sont créées et stockées doit accorder des droits de conception à tout utilisateur créant ou mettant à jour des pages de profil, ainsi qu'une autorisation en lecture seule à tous les utilisateurs qui affichent les pages de profil. Si vous devez créer ce site dans une nouvelle application Web, associez cette dernière à l'application du service Connexion de données métiers.

  7. Pour verrouiller le site afin d'empêcher la création de pages de profil, désélectionnez Activer la création de page de profil.

  8. Cliquez sur OK.

Création ou mise à jour d'une page de profil pour un type de contenu externe

Vous pouvez créer une page de profil pour un type de contenu externe ou mettre à jour une page existante. Par exemple, lorsque vous ajoutez ou supprimez une colonne de données externes dans un type de contenu externe, vous pourriez mettre à jour la page de profil de façon à refléter les modifications apportées au type de contenu externe.

Attention :
La mise à jour d'une page de profil existante risque de provoquer le remplacement de la page de profil actuelle. Toute personnalisation de la page actuelle pourrait être perdue sur la page mise à jour.

Pour créer ou mettre à jour une page de profil pour un type de contenu externe

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur de batterie de serveurs ou administrateur de l'application de service.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications de service.

  3. Dans la liste des applications de service, cliquez sur la liste qui contient l'application du service Connexion de données métiers.

  4. Sous l'onglet Applications de service, dans la section Opérations, cliquez sur Gérer.

  5. Sur la page Types de contenu externe, sélectionnez le type de contenu externe pour lequel vous voulez créer ou mettre à jour une page de profil.

  6. Pointez sur le type de contenu externe, cliquez sur la flèche qui apparaît, puis cliquez sur Créer/mettre à niveau une page de profil.

  7. Dans la page Créer/mettre à niveau des pages de profil, cliquez sur OK.

    Conseil :
    Pour créer ou mettre à jour plusieurs pages de profil de types de contenu externe, sélectionnez un ensemble de types de contenu externe, cliquez sur l'onglet Modifier puis, dans le groupe Pages de profil, cliquez sur Créer/mettre à niveau.

Historique des modifications

Date | Description | Raison
9 septembre 2010 | 2010/09/06 | Mise à jour du contenu
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Gérer les services sur le serveur (SharePoint Foundation 2010)
Voir aussi

Microsoft SharePoint Foundation 2010 inclut des services qui résident sur des serveurs individuels de la batterie de serveurs. Dans certains cas, vous pouvez configurer les paramètres des services globaux, et démarrer ou arrêter un service. Les services sont gérés directement dans l'Administration centrale et non via un site d'administration distinct. Vous pouvez également surveiller et gérer à distance les services. En outre, vous pouvez gérer les services à l'aide de Windows PowerShell 2.0.

Pour plus d'informations sur les services et les applications de service, voir À propos des applications de service et des services (SharePoint Foundation 2010) et Planification de l'architecture des services (SharePoint Foundation 2010).

Dans cet article :

  • Configuration des paramètres globaux

  • Démarrage ou arrêt d'un service

Configuration des paramètres globaux

Certains services ont des paramètres que vous pouvez configurer de manière globale. Pour plus d'informations sur la configuration de ces paramètres, voir l'article répertorié dans le tableau suivant.

Service | Article
Service Minuteur de flux de travail Microsoft SharePoint Foundation | Configurer les paramètres globaux des flux de travail (SharePoint Foundation 2010)

Démarrage ou arrêt d'un service

Vous pouvez gérer les services à l'aide du site Web Administration centrale ou via Windows PowerShell 2.0.

Pour démarrer ou arrêter un service à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Serveurs, cliquez sur Gérer les services sur le serveur.

  4. Pour changer le serveur sur lequel démarrer ou arrêter le service, dans le menu Serveur, cliquez sur Remplacer, puis cliquez sur le nom du serveur voulu.

  5. Par défaut, seuls les services configurables sont affichés. Pour afficher tous les services, dans le menu Affichage, cliquez sur Tous.

  6. Pour démarrer ou arrêter un service, cliquez sur Démarrer ou Arrêter dans la colonne Action du service approprié.

  7. Cliquez sur OK pour démarrer ou arrêter le service.

Pour démarrer un service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Start-SPServiceInstance -Identity <ServiceGUID>

    Où <ServiceGUID> est le GUID du service. Si vous ignorez quel est le GUID du service, vous pouvez récupérer une liste de tous les services de la batterie de serveurs avec leurs GUID correspondants via l'applet de commande Get-SPServiceInstance.

Pour plus d'informations, voir Start-SPServiceInstance.

Pour arrêter un service à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Stop-SPServiceInstance -Identity <ServiceGUID>

    Où <ServiceGUID> est le GUID du service. Si vous ignorez quel est le GUID du service, vous pouvez récupérer une liste de tous les services de la batterie de serveurs avec leurs GUID correspondants via l'applet de commande Get-SPServiceInstance.

Pour plus d'informations, voir Stop-SPServiceInstance.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Référence

Get-SPServiceInstance

Historique des modifications


Configurer les paramètres globaux des flux de travail (SharePoint Foundation 2010)

Les paramètres de flux de travail que vous configurez globalement s'appliquent à tous les sites d'une application Web. Vous pouvez activer le déploiement des flux de travail Microsoft SharePoint Designer définis par l'utilisateur, autoriser les utilisateurs non authentifiés à participer aux flux de travail et désactiver le nettoyage automatique de l'historique des flux de travail antérieur à 60 jours.

Dans cette section :

  • Activer ou désactiver les flux de travail déclaratifs (SharePoint Foundation 2010)

    Utilisez cette procédure pour activer ou désactiver des flux de travail créés et déployés à l'aide de Microsoft SharePoint Designer ou d'une application tierce.

  • Autoriser les utilisateurs non authentifiés à participer aux flux de travail (SharePoint Foundation 2010)

    Utilisez cette procédure pour permettre aux utilisateurs qui n'ont pas été authentifiés de recevoir des messages électroniques en provenance de flux de travail et de tâches.

  • Désactiver la conservation de l'historique des flux de travail (SharePoint Foundation 2010)

    Utilisez cette procédure pour désactiver le travail de nettoyage automatique des flux de travail qui supprime par défaut les flux de travail et les entrées de flux de travail 60 jours après l'achèvement ou l'annulation du flux.

Historique des modifications


Activer ou désactiver les flux de travail déclaratifs (SharePoint Foundation 2010)

Vous pouvez indiquer si vous souhaitez que les utilisateurs soient en mesure de déployer des flux de travail déclaratifs, tels que ceux créés à l'aide de Microsoft SharePoint Designer 2010, sur des sites dans une application Web particulière. Par défaut, le déploiement de flux de travail déclaratifs est autorisé. Dans ce cas, les utilisateurs bénéficiant du niveau d'autorisation minimale de création sur le site peuvent créer et déployer des flux de travail à l'aide de l'éditeur de flux de travail dans Microsoft SharePoint Designer 2010.

Pour activer ou désactiver les flux de travail déclaratifs pour une application Web

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Pour activer ou désactiver les flux de travail déclaratifs, vous devez être membre du groupe SharePoint Administrateurs de batterie.

  2. Depuis le site Web Administration centrale, dans la section de lancement rapide, cliquez sur Gestion des applications.

  3. Dans la section Applications Web, cliquez sur Gérer les applications Web.

  4. Sur la page Gestion des applications Web, cliquez sur l'application Web que vous voulez configurer.

  5. Sur le Ruban, dans le groupe Gérer, cliquez sur Paramètres généraux, puis cliquez sur Flux de travail dans la liste qui s'affiche.

  6. Dans la boîte de dialogue Paramètres du flux de travail, dans la section Flux de travail définis par l'utilisateur, effectuez l'une des opérations suivantes :

    • Pour activer les flux de travail déclaratifs pour des sites dans cette application Web, cliquez sur Oui.

    • Pour désactiver les flux de travail déclaratifs pour cette application Web, cliquez sur Non.

  7. Cliquez sur OK pour fermer la boîte de dialogue Paramètres du flux de travail.

Historique des modifications


Autoriser les utilisateurs non authentifiés à participer aux flux de travail (SharePoint Foundation 2010)

Vous pouvez autoriser l'un et/ou l'autre des types d'utilisateurs non authentifiés suivants à participer aux flux de travail : les utilisateurs internes qui n'ont pas accès au site et les utilisateurs externes qui n'ont pas accès aux ressources réseau internes. Pour les utilisateurs internes, un message électronique est envoyé et explique comment demander l'accès au site (sous réserve de l'approbation de l'administrateur). Pour les utilisateurs externes, un message électronique est envoyé, auquel est joint un document ou un élément de liste que le participant doit réviser ou signer.

Attention :
Lorsque vous autorisez des utilisateurs non authentifiés à participer aux flux de travail, vous ne leur octroyez pas l'accès au site. Cependant, le message électronique et la pièce jointe peuvent contenir des informations confidentielles. Avant d'activer ces paramètres, envisagez les risques éventuels de divulgation des informations quant aux utilisateurs n'ayant pas accès au site.

Autoriser les utilisateurs non authentifiés à participer aux flux de travail

Pour autoriser les utilisateurs internes sans accès au site à participer aux flux de travail

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Pour autoriser les utilisateurs internes sans accès au site à participer aux flux de travail, vous devez être membre du groupe Administrateurs de batterie SharePoint.

  2. Depuis le site Web Administration centrale, dans la section de lancement rapide, cliquez sur Gestion des applications.

  3. Dans la section Applications Web, cliquez sur Gérer les applications Web.

  4. Sur la page Gestion des applications Web, dans la colonne Nom, cliquez sur l'application Web que vous souhaitez configurer.

  5. Sur le Ruban, dans le groupe Gérer, cliquez sur Paramètres généraux, puis cliquez sur Flux de travail dans la liste qui s'affiche.

  6. Dans la boîte de dialogue Paramètres du flux de travail, dans la section Notifications des tâches du flux de travail, pour l'option Voulez-vous que les utilisateurs internes sans accès au site reçoivent une alerte lorsqu'une tâche du flux de travail leur est attribuée ?, cliquez sur Oui pour envoyer un message électronique aux utilisateurs internes dans ces cas-là. Par défaut, ce paramètre est sélectionné.

    Conseil :
    Vous devez également accorder à chaque utilisateur qui n'est pas membre du site, le niveau d'autorisation Collaboration au moins pour la liste des tâches utilisée par le flux de travail auquel cet utilisateur doit participer.

  7. Cliquez sur OK pour fermer la boîte de dialogue Paramètres du flux de travail.

Pour autoriser des utilisateurs externes à participer aux flux de travail

  1. Depuis le site Web Administration centrale, dans la section de lancement rapide, cliquez sur Gestion des applications.

  2. Dans la section Applications Web, cliquez sur Gérer les applications Web.

  3. Sur la page Gestion des applications Web, cliquez sur l'application Web que vous souhaitez configurer.

  4. Sur le Ruban, dans le groupe Gérer, cliquez sur Paramètres généraux, puis cliquez sur Flux de travail dans la liste qui s'affiche.

  5. Dans la boîte de dialogue Paramètres du flux de travail, dans la section Notifications des tâches du flux de travail, pour l'option Voulez-vous autoriser les utilisateurs externes à participer au flux de travail en leur envoyant une copie de ce document ?, cliquez sur Oui pour autoriser les utilisateurs externes à participer au flux de travail. Par défaut, ce paramètre est désactivé.

  6. Cliquez sur OK pour fermer la boîte de dialogue Paramètres du flux de travail.
Remarque :
Si vous décidez par la suite que les utilisateurs non authentifiés ne peuvent pas participer aux flux de travail, accédez de nouveau à cette page et cliquez sur Non pour désactiver l'une de ces options ou les deux.

Historique des modifications


Désactiver la conservation de l'historique des flux de travail (SharePoint Foundation 2010)

Un flux de travail est composé d'une séquence d'événements tels que l'initiation du flux de travail, la création de tâche et la réalisation de tâche. Lorsque vous ajoutez un flux de travail, vous spécifiez une liste de tâches et un historique que les instances de cette association de flux de travail utiliseront pour le suivi des événements du flux de travail. L'historique du flux de travail contient des informations clés sur chaque événement, telles que la date, l'état, le nom du participant et la description.

Pour plus d'informations sur les rapports d'état de flux de travail, voir Surveiller des flux de travail (SharePoint Foundation 2010).

Désactiver le nettoyage automatique de flux de travail

Microsoft SharePoint Foundation 2010 exécute un travail quotidien de nettoyage automatique du flux de travail afin de supprimer les instances de flux de travail et les entrées de tâches associées 60 jours après la réalisation ou l'annulation d'un flux de travail. Vous pouvez désactiver le travail Nettoyage automatique du flux de travail si vous souhaitez conserver ces données plus longtemps. Toutefois, comme pour toute liste SharePoint, les performances du site peuvent être affectées par la croissance en taille de vos listes d'historique et de tâches de flux de travail. Si vous vous inquiétez de la taille de ces listes, vous pouvez activer le travail Nettoyage automatique du flux de travail. Alternativement, vous pouvez créer un historique et une liste de tâches distincte pour chaque association de flux de travail.

Pour plus d'informations, voir Ajouter une association de flux de travail (SharePoint Foundation 2010).

Remarque :
L'historique du flux de travail n'a pas vocation à être utilisé pour auditer des événements de flux de travail et n'est pas nécessairement sûr puisqu'un utilisateur disposant d'autorisations de modification sur le site peut mettre à jour des éléments de l'historique, par défaut.

Pour désactiver le nettoyage automatique du flux de travail

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour désactiver le nettoyage automatique de flux de travail, vous devez être membre du groupe SharePoint Administrateurs de batterie.

  2. Depuis le site Web d'administration centrale, dans le menu de lancement rapide, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Travaux du minuteur, cliquez sur Examiner les définitions de travail.

  4. Dans la page Définitions de travail, dans la colonne Titre, cliquez sur le lien Nettoyage automatique du flux de travail qui est associé à l'application Web pour laquelle vous souhaitez désactiver le nettoyage automatique du flux de travail.

    Conseil :
    Dans la page Définitions des travaux, la colonne Application Web contient le nom de l'application Web à laquelle chaque travail du minuteur est associé.

  5. Dans la page Modifier le travail du minuteur, cliquez sur Désactiver pour désactiver la fonctionnalité Nettoyage automatique du flux de travail.
Remarque :
Si vous décidez ultérieurement d'activer le nettoyage automatique du flux de travail, accédez de nouveau à cette page, puis cliquez sur Activer pour activer le nettoyage automatique du flux de travail.

Historique des modifications


Gérer des applications Web (SharePoint Foundation 2010)
Voir aussi

Les articles de cette section décrivent comment créer et gérer des applications Web dans une batterie de serveurs Microsoft SharePoint Foundation 2010. Ils sont destinés aux administrateurs de batterie de serveurs qui exécuteront SharePoint Foundation 2010. Ils décrivent également comment configurer les paramètres de cache et comment gérer les autorisations et les stratégies d'autorisations pour une application Web.

Dans cette section :

  • Créer une application Web (SharePoint Foundation 2010)

    Cet article explique comment créer une application Web.

  • Configurer les paramètres d'une application Web (SharePoint Foundation)

    Après avoir créé une application Web, vous souhaiterez sans doute la personnaliser. Cet article décrit les paramètres configurables pour une application Web.

  • Étendre une application Web (SharePoint Foundation 2010)

    Si vous souhaitez utiliser des sites Web IIS distincts pour exposer le même contenu aux utilisateurs, vous pouvez étendre une application Web existante. Cet article explique comment étendre une application Web.

  • Annuler l'extension d'une application Web (SharePoint Foundation 2010)

    Cet article explique comment annuler l'extension d'une application Web.

  • Supprimer une application Web (SharePoint Foundation 2010)

    Cet article explique comment supprimer une application Web.

  • Afficher les collections de sites dans une application Web (SharePoint Foundation 2010)

    Vous pouvez afficher une liste de collections de sites dans une application Web afin de rechercher des informations sur l'URL, le titre, la description, l'administrateur de collection de sites principal et d'autres données pour chaque collection de sites dans l'application Web. Cet article explique comment afficher des collections de sites.

  • Gérer les autorisations pour une application Web (SharePoint Foundation 2010)

    Cet article explique comment gérer les autorisations pour une application Web.

  • Gérer les stratégies d'autorisation pour une application Web (SharePoint Foundation 2010)

    Cet article explique comment gérer les stratégies d'autorisations pour une application Web.

Voir aussi

Concepts

Configurer l'authentification par revendications (SharePoint Foundation 2010)
Créer une collection de sites (SharePoint Foundation 2010)
Gérer des types de fichiers bloqués (SharePoint Foundation 2010)
Planifier les autorisations des sites (SharePoint Foundation 2010)

Historique des modifications


Configurer les paramètres d'une application Web (SharePoint Foundation)
Voir aussi

Une fois que vous avez créé une application Web, vous pouvez utiliser l'Administration centrale, les applets de commande Windows PowerShell 2.0 ou l'outil de ligne de commande Stsadm pour configurer les paramètres d'application Web. Les paramètres d'application Web affectent toutes les collections de sites dans l'application Web.

Cet article décrit les paramètres généraux que vous pouvez configurer pour une application Web et présente d'autres articles décrivant des paramètres d'application Web supplémentaires.

Paramètres généraux de l'application Web

En général, vous configurez les paramètres de l'application Web lorsque vous créez une nouvelle application Web. Vous pouvez accéder aux paramètres généraux de l'administration centrale en cliquant sur Gérer les applications Web dans la section Gestion des applications, en cliquant sur l'application Web que vous voulez configurer, puis en cliquant sur Paramètres généraux sur le ruban.

Remarque :
Vous devez être membre du groupe SharePoint des administrateurs de batterie pour utiliser l'administration centrale.

La plupart de ces paramètres peuvent également être configurés à l'aide d'applets de commande Windows PowerShell 2.0. Pour savoir comment utiliser les applets de commande Windows PowerShell 2.0 pour les tâches administratives de Microsoft SharePoint Foundation 2010, voir Windows PowerShell pour SharePoint Foundation 2010 et les différents articles qui sont référencés dans cet article pour des paramètres spécifiques.

La liste suivante décrit les paramètres généraux d'une application Web :

  • Limitation de ressources

    Les paramètres de limitation des ressources vous permettent d'affiner l'application Web pour améliorer les performances. Nous vous déconseillons de régler les paramètres par défaut, à mouns d'avoir testé la configuration du serveur et si vous savez que ces modifications vont sans aucun doute améliorer les performances.

  • Flux de travail

    SharePoint Foundation 2010 fournit un ensemble de flux de travail prédéfinis que vous pouvez utiliser pour guider et suivre des tâches courantes telles que l'examen ou l'approbation de documents. En plus de l'utilisation de flux de travail prédéfinis, vous pouvez définir vos propres flux de travail à l'aide de Microsoft Office SharePoint Designer 2007 ; ou créer des flux de travail personnalisés basés sur le code à l'aide de Visual Studio. Vous pouvez configurer les paramètres de flux de travail qui s'appliquent à tous les sites dans une application Web. Pour plus d'informations sur l'utilisation et la configuration des flux de travail, voir Administration de flux de travail (SharePoint Foundation 2010).

  • Courrier électronique sortant

    Vous pouvez configurer le courrier électronique sortant pour une application Web spécifique de façon à ce que les utilisateurs puissent suivre les modifications et les mises à jour apportées à des collections de sites. Pour plus d'informations, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010).

  • Compte mobile

    Vous pouvez configurer et gérer un compte mobile pour permettre aux utilisateurs de s'abonner aux alertes qui sont envoyées via SMS (Short Message Service). Les alertes sont envoyées aux téléphones mobiles des utilisateurs lorsque des modifications sont apportées à une liste ou un élément SharePoint. Pour plus d'informations, voir Configurer un compte mobile (SharePoint Foundation 2010).

  • SharePoint Designer

    Vous pouvez décider de permettre aux utilisateurs de modifier des sites à l'aide de Microsoft SharePoint Designer 2010. Par défaut, ce paramètre est Actif . Les paramètres supplémentaires de SharePoint Designer 2010 sont les suivants :

    • Autoriser les administrateurs de collection de sites à dissocier des pages du modèle de site.

      Vous pouvez spécifier s'il faut autoriser les administrateurs de collection de sites à dissocier des pages à partir de la définition du site d'origine à l'aide de SharePoint Designer 2010. Par défaut, ce paramètre est Actif.

    • Autoriser les administrateurs de collection de sites à personnaliser les pages maîtres et les pages de disposition.

      Vous pouvez spécifier s'il faut autoriser les administrateurs de collection de sites à personnaliser les pages maîtres et les pages de disposition à l'aide de SharePoint Designer 2010. Par défaut, ce paramètre est Actif .

    • Autoriser les administrateurs de collection de sites à voir la structure d'URL de leur site Web.

      Vous pouvez spécifier s'il faut autoriser les administrateurs de collection de sites à gérer la structure d'URL d'un site Web à l'aide de SharePoint Designer 2010. Par défaut, ce paramètre est Actif.

  • Paramètres généraux

    L'option Paramètres généraux du menu déroulant Paramètres généraux vous permet d'afficher et de modifier les paramètres suivants pour une application Web.

    • Fuseau horaire par défaut

      Vous pouvez définir le fuseau horaire par défaut qui est utilisé pour tous les sites de l'application Web.

    • Modèle de quota par défaut

      Un modèle de quota se compose de valeurs de limite de stockage qui spécifient la quantité de données pouvant être stockées dans une collection de sites et la taille limite de stockage qui déclenche une alerte par courrier électronique destinée à l'administrateur de collection de sites. Ce paramètre permet de sélectionner un modèle de quota par défaut pour toutes les collections de sites dans l'application Web. Pour plus d'informations, voir Planifier la gestion des quotas (SharePoint Foundation 2010).

    • Paramètres de présence et de balise active des noms de personnes

      Lorsque la balise Nom de personne et l'état En ligne est activée, les informations de présence en ligne sont affichées à côté des noms des membres et la balise active Nom de personne apparaît lorsque les utilisateurs placent le pointeur sur un nom de membre n'importe où sur le site Web. Ce paramètre est activé par défaut.

    • Alertes

      Vous pouvez spécifier des paramètres d'alertes pour l'application Web. Par défaut, les alertes sont activées, et chaque utilisateur est limité à 500 alertes. Pour plus d'informations, voir Configurer les paramètres d'alerte d'une application Web (SharePoint Foundation 2010).

    • Paramètres RSS

      Vous pouvez activer les flux RSS (Really Simple Syndication flux RSS) pour l'affichage des flux RSS à partir de blogs, de sources d'actualités et autres emplacements. Par défaut, les flux RSS sont activés.

    • Paramètres de l'API de blog

      Vous pouvez choisir d'activer l'API MetaWeblog pour l'application Web. Par défaut, l'API MetaWebLog est activée et le paramètre pour accepter un nom d'utilisateur et un mot de passe de l'API est défini sur N°.

    • Gestion des fichiers par les navigateurs

      Vous pouvez spécifier si des en-têtes de sécurité supplémentaires sont ajoutés aux documents qui sont servis aux navigateurs Web. Ces en-têtes de sécurité spécifient qu'un navigateur affiche une invite de téléchargement pour certains types de fichiers (par exemple, .html) et utilise le serveur spécifié de type MIME (Multipurpose Internet Mail Extensions) pour les autres types de fichiers.

      Le paramètre Permissif spécifie qu'aucun en-tête n'est ajouté. Le paramètre Strict ajoute des en-têtes qui forcent le navigateur à télécharger certains types de fichiers. Le transfert forcé améliore la sécurité du serveur en interdisant l'exécution automatique du contenu Web. Par défaut, le paramètre est Strict.

    • Validation de la sécurité des pages

      Le paramètre de validation de la sécurité des pages Web établit un laps de temps après lequel un utilisateur est tenu de recommencer la dernière l'opération. Par défaut, la validation de la sécurité est définie à Actif avec un délai d'expiration de 30 minutes.

    • Envoi du nom d'utilisateur et du mot de passe dans un courrier électronique

      Cette option vous permet aux utilisateurs de récupérer leur nom d'utilisateur et le mot de passe par courrier électronique. Si cette option est désactivée, un nouvel utilisateur ne peut pas accéder au site tant qu'un administrateur n'a pas modifié son mot de passe et ne lui a pas notifié son nouveau mot de passe. Par défaut, ce paramètre est Actif .

    • Paramètre de la page maître pour les pages _Layouts d'application

      Vous pouvez autoriser les pages contenues dans le dossier _Layouts à référencer des pages maîtres de site. Les pages dans le dossier de Application _Layouts sont disponibles à tous les sites de la batterie de serveurs. Si ce paramètre a la valeurOui, la plupart des pages dans le dossier _Layouts font référence à la page maître de site et affichent les personnalisations qui ont été apportées à cette page maître. Par défaut, ce paramètre a la valeur Oui.

    • Corbeille

      Vous pouvez spécifier si les corbeilles dans l'application Web sont activées. Pour plus d'informations, voir Configurer les paramètres de la Corbeille (SharePoint Foundation 2010).

    • Taille maximale du téléchargement

      Vous pouvez spécifier la taille maximale autorisée pour un seul téléchargement à n'importe quel site. Par défaut, la taille maximale du téléchargement ascendant est limitée à 50 mégaoctets (Mo).

    • Programme d'amélioration du produit

      Vous pouvez collecter des analyses de site Web sur l'utilisation de la page Web sur l'application Web. Par défaut, ce paramètre a la valeur Oui .

Dans cette section :

La liste suivante renvoie à d'autres articles qui décrivent comment configurer les paramètres pour une application Web :

  • Gérer les stratégies d'autorisation pour une application Web (SharePoint Foundation 2010)

    Les administrateurs peuvent définir des stratégies pour établir différents niveaux d'accès aux sites au sein des applications Web pour différents utilisateurs. Cet article décrit comment créer et gérer des stratégies d'autorisations.

  • Gérer les autorisations pour une application Web (SharePoint Foundation 2010)

    Les administrateurs peuvent contrôler les actions de l'utilisateur en activant ou désactivant l'autorisation associée à l'application Web. Cet article décrit comment établir des autorisations sur une application Web.

  • Activer ou désactiver la création de sites libre-service (SharePoint Foundation 2010)

    La création de sites de type libre-service permet aux utilisateurs désignés créer des sites dans des espaces de noms d'URL définis. Cet article décrit comment configurer cette fonctionnalité pour une application Web.

  • Configurer les paramètres de la Corbeille (SharePoint Foundation 2010)

    Les corbeilles permettent aux utilisateurs et aux administrateurs de collections de sites de récupérer des données. Cet article décrit comment configurer des corbeilles pour une application Web.

  • Configurer les paramètres d'alerte d'une application Web (SharePoint Foundation 2010)

    La fonctionnalité alertes permet aux utilisateurs de conserver une trace des modifications qui ont été apportées à un site Web. La fonction y parvient par l'intermédiaire d'un service de notification par courrier électronique. Cet article décrit comment configurer des alertes.

  • Définir des chemins d'accès gérés (SharePoint Foundation 2010)

    En définissant des chemins d'accès gérés, vous pouvez spécifier quels chemins d'accès dans l'espace de noms d'URL d'une application Web sont utilisés pour les collections de sites. Cet article décrit comment configurer des chemins d'accès gérés pour une application Web.

  • Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010)

    Une connexion d'application de service associe l'application de service aux applications Web via l'appartenance à un groupe de connexion d'application service (également appelé groupe de proxy d'application). Cet article explique comment ajouter ou supprimer des connexions d'application de service à un groupe de connexions d'application de service.

Voir aussi

Concepts

Afficher les collections de sites dans une application Web (SharePoint Foundation 2010)
Créer une application Web (SharePoint Foundation 2010)
Étendre une application Web (SharePoint Foundation 2010)
Ajouter ou supprimer une connexion d'application de service à une application Web (SharePoint Foundation 2010)

Historique des modifications


Configurer les paramètres d'alerte d'une application Web (SharePoint Foundation 2010)

Pour aider les utilisateurs à assurer le suivi des modifications apportées à un site Web, Microsoft SharePoint Foundation 2010 comprend une fonctionnalité d'alerte qui est un service de notification par courrier électronique. Les utilisateurs peuvent configurer les alertes qu'ils souhaitent recevoir ou envoyer afin de communiquer et de suivre les modifications apportées aux éléments d'un site Web.

Les utilisateurs peuvent créer des alertes pour les éléments suivants d'un site :

  • Listes

    Les utilisateurs sont avertis des modifications apportées à la liste, par exemple lorsqu'un élément est ajouté, supprimé ou modifié dans une liste.

  • Éléments de liste

    Les utilisateurs sont avertis des modifications apportées à un élément particulier d'une liste.

  • Bibliothèques de documents

    Les utilisateurs sont avertis des modifications apportées à la bibliothèque de documents, par exemple quand un document est ajouté, supprimé ou modifié dans une bibliothèque de documents, ou quand des discussions sur le Web sont ajoutées, modifiées, supprimées, fermées ou démarrées pour un document.

  • Documents

    Les utilisateurs sont avertis des modifications apportées à un document particulier, par exemple quand un document est modifié, ajouté, supprimé ou fermé.

Remarque :
Les utilisateurs doivent disposer au moins des autorisations Afficher les éléments pour utiliser les alertes. Pour plus d'informations sur l'affectation des autorisations des utilisateurs pour une application Web, voir Planifier les autorisations des sites (SharePoint Foundation 2010).

Vous pouvez utiliser l'Administration centrale ou les applets de commande Windows PowerShell 2.0 pour configurer des alertes. Vous pouvez activer ou désactiver les alertes, et vous pouvez spécifier le nombre d'alertes que les utilisateurs peuvent créer.

Pour que les alertes puissent fonctionner pour un site Web, le courrier électronique sortant doit être activé pour le serveur. Pour plus d'informations sur l'utilisation des alertes et des messages d'administration, ainsi que sur la configuration du courrier électronique sortant, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010).

Dans cet article :

  • Pour configurer les paramètres d'alerte d'une application Web à l'aide de l'administration centrale

  • Pour configurer les paramètres d'alerte d'une application Web à l'aide de Windows PowerShell

Pour configurer les paramètres d'alerte d'une application Web à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette tâche est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, cliquez sur Gérer les applications Web.

  4. Cliquez sur l'application Web dont vous souhaitez configurer les alertes. Le ruban devient actif.

  5. Dans le ruban, cliquez sur le menu déroulant Paramètres généraux, puis sur Paramètres généraux.

  6. Dans la page Paramètres généraux de l'application Web, dans la section Alertes, configurez les paramètres suivants :

    • Spécifiez si les alertes sont Activées ou Désactivées. Par défaut, les alertes sont Activées.

    • Spécifiez le Nombre maximal d'alertes qu'un utilisateur peut créer dans un site Web SharePoint. Cette valeur peut être un entier compris entre 1 et 2 000 000 000 ; par ailleurs, vous pouvez spécifier que le nombre des alertes est illimité. La valeur par défaut est de 500 alertes.

  7. Une fois que vous avez terminé de configurer les alertes, cliquez sur OK.

Pour configurer les paramètres d'alerte d'une application Web à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Pour configurer des alertes à l'aide de Windows PowerShell 2.0, vous devez d'abord récupérer l'objet SPWebApplication pour l'application Web à l'aide de l'applet de commande Get-SPWebApplication conjointement avec l'URL de l'application Web. Vous devez ensuite définir les propriétés d'alerte appropriées pour l'objet, puis enregistrer les modifications à l'aide de la méthode Update() de l'objet SPWebApplication. Chacune de ces étapes est effectuée dans l'exemple de code suivant.

    Depuis l'invite de commandes Windows PowerShell, tapez les commandes suivantes :

    Code de copie
    $webappurl="<http://ServerName:WebApplicationName>"
$webapp=Get-SPWebApplication $webappurl
# to query the settings you can use the following properties
# Gets a value that specifies whether alerts are allowed in the Web application.
$webapp.AlertsEnabled

# Gets a value specifying whether there is a limit to the number of
# lists, document libraries, documents and list items for which a user can create alerts.
$webapp.AlertsLimited

# Gets the maximum number of lists, document libraries, documents and list items
# for which a single user can create alerts in a SharePoint web site.
$webapp.AlertsMaximum

# Sets a value that specifies whether alerts are allowed in the Web application.
# to enable alerts in this Web application
$webapp.AlertsEnabled = $true
$webapp.Update()

# to disable alerts in this Web application
$webapp.AlertsEnabled = $false
$webapp.Update()

# Sets a value specifying whether there is a limit to the number of
# lists, document libraries, documents and list items for which a user can create alerts.
# to enable limited number of alerts and use of AlertsMaximum setting
$webapp.AlertsLimited = $true
$webapp.Update()

# to enable unlimited number of alerts
$webapp.AlertsLimited = $false
$webapp.Update()

# Sets the maximum number of lists, document libraries, documents and list items
# for which a single user can create alerts in a SharePoint web site.
$webapp.AlertsMaximum=<MaxAlertsNumber>
$webapp.Update()

    Où :

    • <http://ServerName:WebApplicationName> est l'URL de l'application Web.

    • <MaxAlertsNumber> est le nombre maximal d'alertes qu'un utilisateur individuel peut créer.

Pour plus d'informations, voir Get-SPWebApplication.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Configurer les paramètres de la Corbeille (SharePoint Foundation 2010)
Voir aussi

Les Corbeilles permettent aux utilisateurs de protéger et de récupérer des données.Microsoft SharePoint Foundation 2010 prend en charge deux étapes pour les corbeilles : la Corbeille primaire et la Corbeille secondaire.

Lorsqu'un utilisateur supprime un élément, ce dernier est automatiquement envoyé vers la Corbeille primaire. Par défaut, lorsqu'un élément est supprimé de la Corbeille primaire, l'élément est envoyé vers la Corbeille secondaire. Un administrateur de collection de sites peut restaurer les éléments de la Corbeille secondaire.

Vous activez et configurez les Corbeilles au niveau de l'application Web. Par défaut, les Corbeilles sont activées dans l'ensemble des collections de sites d'une application Web. Cet article explique comment configurer les paramètres de la Corbeille pour une application Web.

Pour plus d'informations et pour des conseils d'utilisation sur les Corbeilles Microsoft SharePoint Foundation 2010, voir Planifier la protection du contenu à l'aide de corbeilles et du contrôle de version (SharePoint Foundation 2010).

Remarque :
Vous ne pouvez pas effectuer cette tâche à l'aide d'applets de commande Windows PowerShell. Vous devez utiliser l'outil en ligne de commande Stsadm ou le site Web Administration centrale de SharePoint à la place. Pour plus d'informations sur la configuration des paramètres de la Corbeille à l'aide de l'outil en ligne de commande Stsadm, voir Corbeille : propriétés Stsadm (Windows SharePoint Services).

Pour configurer les paramètres de la Corbeille à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, cliquez sur Gérer les applications Web.

  4. Cliquez sur l'application Web dont vous souhaitez configurer les paramètres de la Corbeille. Le ruban devient actif.

  5. Dans le ruban, cliquez sur le menu déroulant Paramètres généraux, puis sur Paramètres généraux.

  6. Dans la page Paramètres généraux de l'application Web, dans la section Corbeille, vous pouvez configurer les paramètres suivants :

    • Vous pouvez définir les Corbeilles de l'application Web à l'état Actif ou Inactif. Par défaut, les Corbeilles sont activées.

      Remarque :
      Si vous désactivez les Corbeilles, tous les éléments existants de la Corbeille primaire et de la Corbeille secondaire sont supprimés. En fonction de la quantité de données contenue dans les Corbeilles, la suppression de ces éléments peut durer longtemps.

    • Vous pouvez spécifier un délai au-delà duquel les éléments des Corbeilles sont supprimés, ou vous pouvez spécifier que ces éléments ne doivent jamais être supprimés. Par défaut, les éléments sont supprimés après 30 jours.

    • Vous pouvez spécifier un pourcentage de quota de site actif pour les éléments supprimés de la Corbeille secondaire. Le paramètre par défaut est de 50 pour cent. Vous pouvez également désactiver les Corbeilles secondaires. Si vous sélectionnez Inactif, les administrateurs de la collection de sites ne pourront pas récupérer les éléments supprimés des Corbeilles des utilisateurs finaux. Le pourcentage de quota de la Corbeille secondaire doit être une valeur comprise entre 1 et 500.

  7. Une fois que vous avez terminé de configurer les Corbeilles, cliquez sur OK.

Voir aussi

Autres ressources

Afficher, restaurer ou supprimer des éléments dans la Corbeille

Historique des modifications


Définir des chemins d'accès gérés (SharePoint Foundation 2010)
Voir aussi

Par la définition de chemins d'accès gérés, vous pouvez spécifier quels chemins d'accès dans l'espace de noms URL d'une application Web sont utilisés pour les collections de sites. Vous pouvez indiquer qu'une ou plusieurs collections de sites existent à un chemin d'accès spécifié. Cela peut constituer une méthode pratique pour consolider l'accès à plusieurs sites pour des utilisateurs dans divers services.

Un chemin d'accès explicitement nommé (par exemple, http://server/sites/team) est utilisé pour une collection de sites spécifique. Un chemin d'accès générique « sites » (par exemple, http://server/sites/) indique que les URL enfants du chemin d'accès sont des collections de sites.

Important :
N'utilisez pas « /* » pour indiquer des sites gérés génériques à la racine de la collection de sites. L'utilisation de cette spécification générique empêche la création d'un site à la racine de l'application Web, qui est indispensable pour permettre le fonctionnement de certaines fonctionnalités de Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Définir des chemins gérés pour une application Web à l'aide de l'Administration centrale

  • Définir des chemins gérés pour une application Web à l'aide de Windows Powershell

Définir des chemins gérés pour une application Web à l'aide de l'Administration centrale

Utilisez les procédures présentées ici pour ajouter ou supprimer des chemins d'accès gérés d'une application Web à l'aide de l'Administration centrale

Pour ajouter un chemin d'accès géré à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette tâche est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, cliquez sur Gérer les applications Web.

  4. Cliquez sur l'application Web pour laquelle vous souhaitez gérer les chemins d'accès. Le ruban devient actif.

  5. Sur le ruban, cliquez surChemins d'accès gérés.

  6. Dans la page Définir les chemins d'accès gérés, dans la section Ajouter un chemin d'accès, tapez le chemin d'accès à inclure.

  7. Cliquez sur Vérifier l'URL pour confirmer le nom du chemin d'accès.

  8. Utilisez le menu déroulant Type pour identifier le chemin d'accès comme étant de type Inclusion générique ou Inclusion explicite. Le type Inclusion générique inclut tous les chemins d'accès qui sont subordonnés au chemin d'accès spécifié. Le type Inclusion explicite inclut uniquement le site qui est indiqué par le chemin d'accès spécifié. Les sites subordonnés au chemin d'accès spécifié ne sont pas inclus.

  9. Cliquez sur Ajouter un chemin d'accès.

  10. Lorsque vous avez terminé d'ajouter des chemins d'accès, cliquez sur OK.

Pour supprimer un chemin d'accès géré à l'aide de l'Administration centrale :

  1. Vérifiez que le compte d'utilisateur qui effectue cette tâche est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, cliquez sur Gérer les applications Web.

  4. Cliquez sur l'application Web pour laquelle vous souhaitez gérer les chemins d'accès. Le ruban devient actif.

  5. Sur le ruban, cliquez surChemins d'accès gérés.

  6. Dans la page Définir les chemins d'accès gérés, dans la section Chemin d'accès inclus, cliquez sur la case à cocher en regard du chemin d'accès que vous souhaitez supprimer.

  7. Cliquez sur Supprimer le chemin d'accès sélectionnés.

    Avertissement :
    Vérifiez que vous voulez vraiment supprimer le chemin d'accès sélectionné avant d'exécuter cette action. Vous n'aurez pas d'autres opportunités de confirmation. La suppression est immédiate.

  8. Lorsque vous avez terminé de supprimer des chemins d'accès, cliquez sur OK.

Définir des chemins gérés pour une application Web à l'aide de Windows Powershell

Vous pouvez utiliser l'applet de commande New-SPManagedPath pour ajouter des chemins d'accès gérés pour une application Web. Vous pouvez utiliser l'applet de commande Remove-SPManagedPath pour supprimer des chemins d'accès gérés d'une application Web.

L'applet de commande New-SPManagedPath ajoute un chemin d'accès géré à une application Web donnée ou pour une utilisation avec toutes les collections de sites d'en-tête d'hôte. Si le commutateur HostHeader est fourni, le chemin d'accès géré est partagé entre toutes les collections de sites d'en-tête d'hôte ; sinon, vous devez spécifier une application Web dans laquelle il convient de créer ce chemin d'accès géré. L'adresse URL relative est une adresse URL partielle qui représente le chemin d'accès géré. Lorsque la barre oblique est utilisée, la racine est définie. Si le paramètre Explicite n'est pas fourni, le nouveau chemin d'accès géré est un chemin d'accès générique.

Pour ajouter un chemin d'accès géré à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    New-SPManagedPath [-RelativeURL] "</RelativeURL>" -WebApplication <WebApplication>

    Où :

    • </RelativeURL> est l'adresse URL relative du nouveau chemin d'accès géré. Le type doit être une URL partielle valide, telle que site ou sites/teams/.

    • <WebApplication> est le groupe d'applications Web pour l'ajout de ce chemin d'accès.

Pour plus d'informations, voir New-SPManagedPath.

Pour supprimer un chemin d'accès géré à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    Remove-SPManagedPath [-Identity] <ManagedPathName> -WebApplication <WebApplication>

    Où :

    • <ManagedPathName> est le nom du chemin d'accès géré à supprimer.

    • <WebApplication> est l'identité de l'application Web qui héberge le chemin d'accès géré à supprimer.

    Un message vous demande de confirmer la suppression.

Pour plus d'informations, voir Remove-SPManagedPath.

Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Référence

Get-SPManagedPath

Concepts

Planification des sites de collaboration (SharePoint Foundation 2010)

Historique des modifications


Activer ou désactiver la création de sites libre-service (SharePoint Foundation 2010)

La fonctionnalité de création de sites libre-service dans Microsoft SharePoint Foundation 2010 permet aux utilisateurs disposant de l'autorisation Utiliser la création de sites libre-service de créer des sites dans des espaces de noms d'URL définis. Pour plus d'informations sur les autorisations relatives aux utilisateurs et aux sites, voir Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010). Pour déterminer si la création de sites libre-service est une pratique intéressante pour les sites Web de votre organisation, voir Planifier les sites et les collections de sites (SharePoint Foundation 2010).

Remarque :
Vous ne pouvez pas effectuer cette tâche à l'aide d'applets de commande Windows PowerShell. Vous devez utiliser l'outil en ligne de commande Stsadm ou le site Web Administration centrale de SharePoint à la place.

Dans cet article :

  • Pour activer ou désactiver la création de sites libre-service à l'aide de l'Administration centrale

  • Pour activer ou désactiver la création de sites libre-service à l'aide de l'outil en ligne de commande Stsadm

Pour activer ou désactiver la création de sites libre-service à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette tâche est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans le site Web Administration centrale de SharePoint, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, cliquez sur Gérer les applications Web.

  4. Cliquez sur l'application Web pour laquelle vous souhaitez activer ou désactiver la création de sites libre-service. Le ruban devient actif.

  5. Dans le ruban, cliquez sur Création de sites libre-service.

  6. Dans la page Gestion de collections de sites libre-service, configurez les paramètres suivants :

    • Spécifiez si la valeur correspondant à la création de sites libre-service est Actif (activée) ou Inactif (désactivée) pour l'application Web. La valeur par défaut est Actif.

    • Pour exiger que les utilisateurs de la création de sites libre-service fournissent un nom de contact secondaire sur la page d'inscription, sélectionnez Exiger un contact secondaire.

  7. Cliquez sur OK pour terminer l'opération.

    Remarque :
    Lorsque vous activez la création de sites libre-service, une annonce est ajoutée à la liste Annonces dans la page d'accueil du site Web de niveau supérieur dans la collection de sites racine de l'application Web. Cette annonce fournit un lien vers la page de création de sites.

Pour activer ou désactiver la création de sites libre-service à l'aide de l'outil en ligne de commande Stsadm

  1. Assurez-vous que le compte d'utilisateur employé pour l'exécution de l'outil en ligne de commande Stsadm est membre du groupe Administrateurs de l'ordinateur local et du groupe Administrateurs de batterie de serveurs.

  2. Sur le lecteur où SharePoint Foundation 2010 est installé, cliquez sur Démarrer, puis tapez invite de commandes dans la zone de texte. Dans la liste des résultats, cliquez avec le bouton droit sur Invite de commandes, cliquez sur Exécuter en tant qu'administrateur, puis cliquez sur OK.

  3. À l'invite de commandes, tapez la commande suivante :

    cd %CommonProgramFiles%\Microsoft Shared\Web server extensions\14\bin

    • Pour activer la création de sites libre-service, tapez la commande suivante :

      stsadm.exe -o enablessc -url <url> -requiresecondarycontact

      Où <url> est l'URL de l'application Web.

      Cette commande active la création de sites libre-service et requiert un contact secondaire.

    • Pour désactiver la création de sites libre-service, tapez la commande suivante :

      stsadm -o disablessc -url <url>

      Où <url> est l'URL de l'application Web.

Pour plus d'informations, voir Enablessc : opération Stsadm (Windows SharePoint Services) et Disablessc : opération Stsadm (Windows SharePoint Services).

Historique des modifications


Étendre une application Web (SharePoint Foundation 2010)

Si vous souhaitez exposer le même contenu dans une application Web à différents types d'utilisateurs via des méthodes d'authentification ou des URL supplémentaires, vous pouvez étendre une application Web existante sur une nouvelle zone. Lorsque vous étendez l'application Web sur une nouvelle zone, vous créez un site de Web IIS distinct pour servir le même contenu, mais avec une URL et un type d'authentification uniques.

Une application Web étendue peut utiliser jusqu'à cinq zones réseau (zone par défaut, zone personnalisée, zone intranet, zone extranet, zone Internet). Par exemple, si vous souhaitez étendre une application Web de sorte que les clients puissent accéder au contenu à partir d'Internet, vous sélectionnez la zone Internet, autorisez l'accès anonyme et accordez aux utilisateurs des autorisations en lecture seule. Les clients peuvent ensuite accéder à la même application Web que les utilisateurs internes, mais par le biais de différentes URL et de différents paramètres d'authentification. Pour plus d'informations, voir Configurer un accès anonyme pour une application Web basée sur des revendications (SharePoint Foundation 2010) et Planifier des méthodes d'authentification (SharePoint Foundation 2010).

Dans cette section :

  • Étendre une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)

  • Étendre une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
7 octobre 2010 | 2010/10/04 | Mise à jour du contenu


Étendre une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment étendre une application Web qui utilise l'authentification classique Windows.

Conseil :
Si vous préférez utiliser l'authentification basée sur les revendications Windows, voir Étendre une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010).

Avant d'effectuer cette procédure, vérifiez les éléments suivants :

  • Votre système exécute Microsoft SharePoint Foundation 2010.

  • Vous avez déjà une application Web à étendre.

  • Vous avez lu Planifier des méthodes d'authentification (SharePoint Foundation 2010) et connaissez la méthode d'authentification à utiliser.

  • Vous avez lu la documentation sur les zones, l'accès anonyme et les autorisations.

  • Si UAC (User Account Control) est activé dans Windows et que vous utilisez Windows PowerShell pour étendre une application Web, vous devez cliquer avec le bouton droit sur SharePoint 2010 Management Shell et sélectionner Exécuter en tant qu'administrateur.

Vous pouvez étendre une application Web qui utilise l'authentification classique Windows à l'aide de l'Administration centrale ou de Windows PowerShell. Utilisez l'une des procédures suivantes pour étendre une application Web. En règle générale, vous utilisez l'Administration centrale pour étendre une application Web. Si vous souhaitez automatiser la tâche d'extension d'une application Web, ce qui est courant au sein des entreprises, utilisez Windows PowerShell. Au terme de la procédure, vous disposez de deux sites Web IIS distincts qui exposent le même contenu aux utilisateurs.

Pour étendre une application Web qui utilise l'authentification classique Windows à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour étendre une application Web, vous devez être membre du groupe SharePoint Administrateurs de batterie et du groupe Administrateur local sur l'ordinateur exécutant l'Administration centrale.

  2. Dans la page d'accueil de l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Sur la page Application Web, sélectionnez l'application Web que vous souhaitez étendre.

  4. Sur le Ruban, cliquez sur Étendre.

  5. Dans la page Étendre une application Web à un autre site Web IIS, dans la section Site Web IIS, vous pouvez configurer les paramètres de votre application Web en sélectionnant l'une des deux options suivantes :

    • Cliquez sur Utiliser un site Web IIS existant, puis sélectionnez le site Web auquel vous souhaitez étendre votre application Web existante.

    • Cliquez sur Créer un nouveau site Web IIS, puis tapez le nom du site Web dans la zone Nom.

  6. Dans la section Site Web IIS, dans la zone Port, tapez le numéro de port que vous souhaitez utiliser pour accéder à l'application Web. Si vous créez un nouveau site Web, ce champ est rempli avec un numéro de port aléatoire. Si vous utilisez un site Web existant, ce champ est rempli avec le numéro de port actuel.

    Remarque :
    Le numéro de port par défaut pour l'accès HTTP est 80, et le numéro de port par défaut pour l'accès HTTPS est 443. Si vous souhaitez que les utilisateurs accèdent à l'application Web sans taper de numéro de port, ils doivent utiliser le numéro de port par défaut approprié.

  7. Facultatif : dans la section Site Web IIS, dans la zone En-tête de l'hôte, tapez le nom de l'hôte (par exemple, www.contoso.com) que vous souhaitez utiliser pour accéder à l'application Web.

    Remarque :
    En règle générale, ce champ n'est pas défini, sauf si vous souhaitez configurer plusieurs sites Web IIS qui partagent le même numéro de port sur le même serveur, et DNS a été configuré pour faire pointer plusieurs noms de serveur vers le même serveur.

  8. Dans la section Site Web IIS, dans la zone Chemin d'accès, tapez le chemin d'accès de l'annuaire de sites sur le serveur. Si vous créez un nouveau site Web, ce champ est rempli avec le chemin d'accès suggéré. Si vous utilisez un site Web existant, ce champ est rempli avec le chemin d'accès actuel de ce site Web.

  9. Dans la section Configuration de la sécurité, configurez l'authentification et le chiffrement pour votre application Web étendue.

    1. Dans la section Fournisseur d'authentification, cliquez sur Négocier (Kerberos) ou NTLM.

      Remarque :
      Pour activer l'authentification Kerberos, vous devez effectuer une configuration supplémentaire. Pour plus d'informations, voir Configurer l'authentification Kerberos (SharePoint Foundation 2010).

    2. Dans la section Autoriser l'accès anonyme, cliquez sur Oui ou Non. Si vous choisissez d'autoriser l'accès anonyme, cela permet l'accès anonyme au site Web à l'aide du compte d'accès anonyme spécifique à l'ordinateur (en l'occurrence, IUSR).

      Remarque :
      Si vous souhaitez que les utilisateurs puissent accéder au contenu de tout site de façon anonyme, vous devez autoriser l'accès anonyme pour toute la zone d'application Web avant d'activer l'accès anonyme au niveau du site SharePoint ; plus tard, les propriétaires de sites peuvent configurer le mode d'utilisation de l'accès anonyme dans leurs sites. Si vous ne permettez pas l'accès anonyme au niveau de l'application Web, vous ne pouvez pas permettre l'accès anonyme ultérieurement, au niveau du site. Pour plus d'informations, voir Choisir les groupes de sécurité (SharePoint Foundation 2010).

    3. Dans la section Utiliser SSL (Secure Sockets Layer), cliquez sur Oui ou sur Non. Si vous choisissez d'activer SSL pour le site Web, vous devez configurer SSL en demandant et en installant un certificat SSL. Pour plus d'informations sur la configuration de SSL, voir Comment configurer SSL sur IIS 7.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187887&clcid=0x40C).

  10. Dans la section URL publique, tapez l'URL pour le nom de domaine de tous les sites auxquels les utilisateurs auront accès dans cette application Web. Cette URL sera utilisée comme URL de base dans les liens apparaissant sur les pages dans cette zone d'application Web. L'URL par défaut est le nom et le port du serveur actuel, et est automatiquement actualisée pour refléter les paramètres SSL, d'en-tête d'hôte et de numéro de port actuels sur la page. Si vous déployez SharePoint Foundation 2010 derrière un équilibreur de charge ou un serveur proxy, cette URL peut devoir différer des paramètres SSL, d'en-tête d'hôte et de port sur cette page.

  11. Dans la section URL publique, sélectionnez la zone à utiliser pour l'application Web dans le menu déroulant.

    Remarque :
    Vous pouvez créer jusqu'à cinq zones au sein d'une application Web.

  12. Cliquez sur OK pour étendre votre application Web existante.

Pour étendre une application Web existante qui utilise l'authentification classique Windows à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale suivante : Voir Add-SPShellAdmin. Vous devez également être administrateur local sur l'ordinateur qui exécute Windows PowerShell.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Pour étendre une application Web au même port, mais avec un en-tête d'hôte différent, à l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPWebApplication -Identity <Identity> | New-SPWebApplicationExtension -Name <Name> -HostHeader <HostHeader> -Port <Port> -Zone <Zone> -URL <URL>

    Où :

    • <Identity> est l'application Web que vous voulez étendre.

    • <Name> est le nom du nouveau site Web IIS dans l'application Web.

    • <HostHeader> est le nom d'hôte affecté à cette zone de l'application Web.

    • <Port> est le port sur lequel cette zone de l'application Web est accessible.

    • <Zone> est la zone à laquelle cette nouvelle extension doit être associée.

    • <URL> est l'URL publique de cette zone d'application Web.

    Exemple

    Code de copie
    Get-SPWebApplication -Identity http://sitename | New-SPWebApplicationExtension -Name ExtranetSite -HostHeader www.contoso.com -Port 80 -Zone Extranet -URL http://extranet.sitename.com

Pour plus d'informations, voir New-SPWebApplicationExtension.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Créer une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)
Étendre une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
7 octobre 2010 | Publication initiale |


Étendre une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment étendre une application Web qui utilise l'authentification basée sur les revendications Windows.

Conseil :
Si vous préférez utiliser l'authentification classique Windows, voir Étendre une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010).

Avant d'effectuer ces procédures, vérifiez les points suivants :

  • Votre système exécute Microsoft SharePoint Foundation 2010.

  • Vous avez déjà une application Web à étendre.

  • Vous avez lu Planifier des méthodes d'authentification (SharePoint Foundation 2010) et connaissez la méthode d'authentification à utiliser.

  • Vous avez lu la documentation sur les zones, l'accès anonyme et les autorisations.

  • Si UAC (User Account Control) est activé dans Windows et que vous utilisez Windows PowerShell pour étendre une application Web, vous devez cliquer avec le bouton droit sur SharePoint 2010 Management Shell et sélectionner Exécuter en tant qu'administrateur.

Vous pouvez étendre une application Web qui utilise l'authentification basée sur les revendications Windows à l'aide de l'Administration centrale ou de Windows PowerShell. Utilisez l'une des procédures suivantes pour étendre une application Web. En règle générale, vous utilisez l'Administration centrale pour étendre une application Web. Si vous souhaitez automatiser la tâche d'extension d'une application Web, ce qui est courant au sein des entreprises, utilisez Windows PowerShell. Au terme de la procédure, vous disposez de deux sites Web IIS distincts qui exposent le même contenu aux utilisateurs.

Pour étendre une application Web qui utilise l'authentification par revendications de Windows à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour créer une application Web, vous devez être membre du groupe SharePoint Administrateurs de batterie et membre du groupe Administrateurs local sur l'ordinateur exécutant l'Administration centrale.

  2. Dans la page d'accueil de l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Sur le Ruban, cliquez sur Étendre.

  4. Dans la page Étendre une application Web à un autre site Web IIS, dans la section Site Web IIS, vous pouvez configurer les paramètres de votre application Web étendue en sélectionnant l'une des deux options suivantes :

    • Cliquez sur Utiliser un site Web IIS existant, puis sélectionnez le site Web auquel vous souhaitez étendre votre application Web existante.

    • Cliquez sur Créer un nouveau site Web IIS, puis tapez le nom du site Web dans la zone Nom.

  5. Dans la section Site Web IIS, dans la zone Port, tapez le numéro de port que vous souhaitez utiliser pour accéder à l'application Web. Si vous créez un nouveau site Web, ce champ est rempli avec un numéro de port suggéré. Si vous utilisez un site Web existant, ce champ est rempli avec le numéro de port actuel.

    Remarque :
    Le numéro de port par défaut pour l'accès HTTP est 80, et le numéro de port par défaut pour l'accès HTTPS est 443. Si vous souhaitez que les utilisateurs accèdent à l'application Web sans taper de numéro de port, ils doivent utiliser le numéro de port par défaut approprié.

  6. Facultatif : dans la section Site Web IIS, dans la zone En-tête de l'hôte, tapez le nom de l'hôte (par exemple, www.contoso.com) que vous souhaitez utiliser pour accéder à l'application Web.

    Remarque :
    En règle générale, ce champ n'est pas défini, sauf si vous souhaitez configurer plusieurs sites Web IIS afin qu'ils utilisent le port 80 sur le même serveur, et DNS a été configuré pour faire pointer plusieurs noms de serveur vers le même serveur.

  7. Dans la section Site Web IIS, dans la zone Chemin d'accès, tapez le chemin d'accès de l'annuaire de sites sur le serveur. Si vous créez un nouveau site Web, ce champ est rempli avec le chemin d'accès suggéré. Si vous utilisez un site Web existant, ce champ est rempli avec le chemin d'accès actuel de ce site Web.

  8. Dans la section Configuration de la sécurité, indiquez s'il faut autoriser l'accès anonyme et utiliser le protocole SSL (Secure Sockets Layer).

    1. Sous Autoriser l'accès anonyme, cliquez sur Oui ou Non. Si vous choisissez d'autoriser l'accès anonyme, cela permet l'accès anonyme au site Web à l'aide du compte d'accès anonyme spécifique à l'ordinateur (en l'occurrence, IUSR).

      Remarque :
      Si vous souhaitez que les utilisateurs puissent accéder au contenu de tout site de façon anonyme, vous devez autoriser l'accès anonyme pour toute la zone d'application Web avant d'activer l'accès anonyme au niveau du site SharePoint ; plus tard, les propriétaires de sites peuvent configurer le mode d'utilisation de l'accès anonyme dans leurs sites. Si vous ne permettez pas l'accès anonyme au niveau de l'application Web, vous ne pouvez pas permettre l'accès anonyme ultérieurement, au niveau du site. Pour plus d'informations, voir Choisir les groupes de sécurité (SharePoint Foundation 2010).

    2. Sous Utiliser le protocole SSL, cliquez sur Oui ou Non. Si vous choisissez d'activer le protocole SSL pour le site Web, vous devez configurer le protocole SSL en demandant et en installant un certificat SSL. Pour plus d'informations sur la configuration de SSL, voir Configuration de SSL sur IIS 7.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187887&clcid=0x40C).

  9. Dans la section Types d'authentification basée sur les revendications, sélectionnez l'authentification que vous souhaitez utiliser pour l'application Web.

    1. Si vous souhaitez activer l'authentification Windows, sélectionnez Activer l'authentification Windows et, dans le menu déroulant, sélectionnez Négocier (Kerberos) ou NTLM. Pour plus d'informations, voir Configurer l'authentification Kerberos (SharePoint Foundation 2010).

      Si vous ne souhaitez pas utiliser l'authentification Windows intégrée, désactivez Authentification Windows intégrée.

      Si vous souhaitez que les informations d'identification des utilisateurs soient envoyées sur le réseau sous une forme non chiffrée, sélectionnez Authentification de base (le mot de passe est envoyé en texte clair).

      Remarque :
      Vous pouvez sélectionner l'authentification de base ou l'authentification Windows intégrée, ou les deux. Si vous sélectionnez les deux, SharePoint Foundation 2010 offre les deux types d'authentification au navigateur Web client. Ce dernier détermine ensuite quel type d'authentification utiliser. Si vous sélectionnez l'authentification de base, assurez-vous que le protocole SSL est activé ; dans le cas contraire, les informations d'identification peuvent être interceptées par un utilisateur malveillant.

    2. Si vous souhaitez activer l'authentification par formulaire, sélectionnez Activer l'authentification par formulaire, puis entrez le nom du fournisseur d'appartenances et le nom du gestionnaire de rôles dans les zones.

      Pour plus d'informations, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

      Remarque :
      Si vous sélectionnez cette option, assurez-vous que le protocole SSL est activé ; dans le cas contraire, les informations d'identification peuvent être interceptées par un utilisateur malveillant.

    3. Si vous avez configuré l'authentification Fournisseur d'identité approuvé dans Windows PowerShell, la case à cocher Fournisseur d'identité approuvé est activée.

      Pour plus d'informations, voir Configurer l'authentification à l'aide d'un jeton de sécurité SAML (SharePoint Foundation 2010).

    Vous pouvez utiliser un ou plusieurs types d'authentification par revendications. Pour plus d'informations, voir Planifier des méthodes d'authentification (SharePoint Foundation 2010).

  10. Dans la section URL de page de connexion, choisissez l'une des options suivantes pour vous connecter à SharePoint Foundation 2010.

    • Sélectionnez Utiliser l'URL de la page de connexion par défaut si vous souhaitez que les utilisateurs soient redirigés vers un site Web de connexion par défaut pour l'authentification par revendications.

    • Sélectionnez Utiliser une URL de page de connexion personnalisée, puis tapez l'URL de connexion si vous souhaitez que les utilisateurs soient redirigés vers un site Web de connexion personnalisé pour l'authentification par revendications.

  11. Dans la section URL publique, tapez l'URL du nom de domaine pour tous les sites accessibles aux utilisateurs dans cette application Web. Cette URL sera utilisée dans tous les liens affichés sur les pages de l'application Web. L'URL par défaut est constituée du nom de serveur et du port actuels.

  12. Dans la section URL publique, sélectionnez la zone à utiliser pour l'application Web dans le menu déroulant.

    Remarque :
    Vous pouvez créer jusqu'à cinq zones au sein d'une application Web.

  13. Cliquez sur OK pour étendre l'application Web existante.

Pour étendre une application Web existante qui utilise l'authentification Windows par revendications à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale suivante : Voir Add-SPShellAdmin. Vous devez également être administrateur local sur l'ordinateur qui exécute Windows PowerShell.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Pour changer l'authentification de l'authentification par revendications Windows à l'authentification par formulaires, à l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    $ap = New-SPAuthenticationProvider -ASPNETRoleProviderName <RoleProviderName> -ASPNETMembershipProvider <MembershipProviderName>

    Pour étendre une application Web au même port, mais avec un en-tête d'hôte différent, à l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPWebApplication -Identity http://sitename | New-SPWebApplicationExtension -Name <Name> -HostHeader <HostHeader> -Zone <Zone> -URL <URL> -Port <Port> -AuthenticationProvider $ap

    Où :

    • <RoleProviderName> est le nom du fournisseur de rôles.

    • <MembershipProviderName> est le nom du fournisseur d'appartenances.

    • <Identity> est l'application Web que vous voulez étendre.

    • <Name> est le nom du nouveau site Web IIS dans l'application Web.

    • <HostHeader> est le nom d'hôte affecté à cette zone de l'application Web.

    • <Zone> est la zone à laquelle cette nouvelle extension doit être associée.

    • <URL> est l'URL publique de cette zone d'application Web.

    • <Port> est le port sur lequel cette zone de l'application Web est accessible.

    Exemple

    Code de copie
    $ap = New-SPAuthenticationProvider -ASPNETRoleProviderName roleprovidername -ASPNETMembershipProvider membershipprovidername
    Code de copie
    Get-SPWebApplication -Identity http://sitename | New-SPWebApplicationExtension -Name IntranetSite -HostHeader www.contoso.com -Zone Intranet -URL http://intranet.sitename.com -Port 9876 -AuthenticationProvider $ap

Pour plus d'informations, voir New-SPWebApplicationExtension.

Remarque :
Une fois que vous avez étendu une application Web existante qui utilise l'authentification Windows par revendications à une application Web qui utilise l'authentification par formulaires, vous devez effectuer une configuration supplémentaire. Pour plus d'informations sur l'authentification par formulaires, voir Configurer l'authentification par formulaires pour une application Web basée sur les revendications (SharePoint Foundation 2010).

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Créer une application Web qui utilise l'authentification basée sur les revendications Windows (SharePoint Foundation 2010)
Étendre une application Web qui utilise l'authentification classique Windows (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
7 octobre 2010 | Publication initiale |


Annuler l'extension d'une application Web (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment annuler l'extension d'une application Web. Lorsque vous annulez l'extension d'une application Web, vous supprimez l'association entre l'application Web d'une part et le site Web IIS et la zone d'autre part. Vous annulez généralement l'extension d'une application Web lorsque vous souhaitez pouvoir utiliser l'application Web ultérieurement, sans souhaiter qu'elle soit disponible sur ce site Web IIS particulier. Cela vous permet de préserver les bases de données de contenu et les paramètres d'application Web associés à l'application Web pour une réutilisation ultérieure.

Si vous mettez un jour les URL de mappage d'accès de substitution d'une application Web, SharePoint Foundation 2010 ne met pas automatiquement à jour les liaisons IIS. Pour résoudre ce problème, vous devez annuler l'extension de l'application Web de la zone associée, puis étendre de nouveau l'application Web avec les liaisons IIS mises à jour.

Vous pouvez également supprimer le site Web IIS s'il héberge uniquement du contenu SharePoint et si vous n'avez plus besoin du site Web IIS.

Avant d'effectuer ces procédures, vérifiez que :

  • Personne n'utilise la zone d'application Web dont vous souhaitez annuler l'extension.

  • Si UAC (User Account Control) est activé dans Windows et que vous utilisez Windows PowerShell pour annuler l'extension d'une application Web, vous devez cliquer avec le bouton droit sur SharePoint 2010 Management Shell et sélectionner Exécuter en tant qu'administrateur.

Vous pouvez annuler l'extension de l'application Web en utilisant le site Web Administration centrale de SharePoint ou Windows PowerShell. Vous utilisez généralement l'Administration centrale pour annuler l'extension d'une application Web dans un serveur unique avec un déploiement de base de données intégrée. Si vous souhaitez automatiser la tâche de l'annulation d'extension d'une application Web, ce qui est fréquent dans les entreprises, utilisez Windows PowerShell.

Pour annuler l'extension d'une application Web à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour annuler l'extension d'une application Web, vous devez être membre du groupe SharePoint Administrateurs de batterie et membre du groupe local Administrateurs sur l'ordinateur exécutant l'Administration centrale.

  2. Dans la page d'accueil d'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Sélectionnez l'application Web dont vous souhaitez annuler l'extension, puis dans le ruban, sélectionnez Supprimer, puis cliquez sur Supprimer SharePoint d'un site Web IIS.

  4. Dans la page Supprimer SharePoint d'un site Web IIS, dans la section Options de suppression, dans la liste Sélectionnez le site Web IIS et la zone à supprimer, cliquez sur le nom de l'application Web dont vous souhaitez annuler l'extension du site Web IIS et de la zone.

  5. Sous Supprimer le site Web IIS, effectuez l'une des actions suivantes :

    • Sélectionnez Oui si vous souhaitez supprimer le site Web IIS.

    • Sélectionnez Non si vous ne souhaitez pas supprimer le site Web IIS.

  6. Cliquez sur OK.

Pour annuler l'extension d'une application Web à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin. Vous devez également être membre du groupe local Administrateurs sur l'ordinateur exécutant l'Administration centrale.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante :

    Code de copie
    Remove-SPWebApplication -identity http://sitename -Zone {Default | Intranet | Internet | Internet | Custom | Extranet} -Confirm

    Cette commande supprime la zone que vous avez spécifiée pour l'extension d'application Web sur http://sitename. Cette commande ne supprime pas les bases de données de contenu ni le site Web IIS.

    Remarque :
    Sachez que cette applet de commande peut être utilisée pour supprimer l'application Web, veillez donc à utiliser les paramètres appropriés.

Pour plus d'informations, voir Remove-SPWebApplication.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Étendre une application Web (SharePoint Foundation 2010)

Historique des modifications


Supprimer une application Web (SharePoint Foundation 2010)

Cet article explique comment supprimer une application Web. Lorsque vous supprimez une application Web, vous pouvez éventuellement supprimer les bases de données de contenu et les sites Web IIS. Si vous supprimez les bases de données de contenu, l'ensemble du contenu de site présent dans ces bases de données est supprimé. Si vous supprimez les sites Web IIS, toutes les entrées de la métabase IIS qui font référence à l'application Web sont également supprimées. Si vous supprimez uniquement l'application Web mais pas les bases de données de contenu et les sites Web IIS, ces derniers peuvent être réutilisés par une autre application Web.

En règle générale, vous supprimez une application Web à des fins de maintenance ou pour recréer l'architecture de la batterie de serveurs.

Si vous hébergez du contenu ou des applications autres que du contenu SharePoint sur le site Web IIS hébergeant l'application Web, vous devrez peut-être supprimer les sites Web IIS. Par ailleurs, si vous effectuez des travaux de maintenance, vous pouvez garder les sites Web IIS. Toutefois, si vous hébergez uniquement du contenu SharePoint sur le site Web IIS ou si vous envisagez d'effectuer une restructuration complète, vous pouvez supprimer le site Web IIS.

Si vous voulez supprimer l'application Web temporairement, par exemple, pour créer l'application Web dans un autre pool d'applications, évitez de supprimer les bases de données de contenu. Vous pourrez ensuite recréer l'application Web avec les paramètres souhaités et attacher à nouveau les bases de données de contenu existantes. Si vous supprimez les bases de données de contenu, votre contenu sera définitivement perdu, à moins que vous ne disposiez d'une sauvegarde permettant de restaurer les bases de données de contenu.

Avant d'effectuer ces procédures, vérifiez que :

  • si vous choisissez cette option, vous connaissez les implications liées à la suppression du site Web IIS et des bases de données de contenu ;

  • vous avez effectué une sauvegarde de l'application Web à supprimer si, pour une raison quelconque, vous voulez restaurer l'application Web supprimée. Pour plus d'informations, voir Sauvegarder une application Web (SharePoint Foundation 2010) ;

  • si le contrôle de compte d'utilisateur est activé dans Windows, et si vous utilisez Windows PowerShell pour supprimer une application Web, vous devez cliquer avec le bouton droit sur SharePoint 2010 Management Shell et sélectionner Exécuter en tant qu'administrateur.

Vous pouvez supprimer une application Web à l'aide du site Web Administration centrale de SharePoint ou de Windows PowerShell. En règle générale, vous devez utiliser l'Administration centrale pour supprimer une application Web sur un seul serveur avec déploiement de base de données intégrée. Pour automatiser la tâche de suppression d'une application Web, ce qui est courant en entreprise, utilisez Windows PowerShell.

Pour supprimer une application Web à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Pour supprimer une application Web, vous devez être membre du groupe SharePoint Administrateurs de batterie de serveurs et du groupe Administrateurs local sur l'ordinateur exécutant l'Administration centrale.

  2. Dans la page d'accueil de l'Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Sélectionnez l'application Web à supprimer, cliquez ensuite dans le ruban sur Supprimer, puis sur Supprimer une application Web.

  4. Dans la page Supprimer une application Web, dans la section Options de suppression, sous Supprimer les bases de données de contenu, sélectionnez Oui pour supprimer les bases de données de contenu associées à l'application Web. Sinon, sélectionnez Non pour conserver les bases de données de contenu.

  5. Sous Supprimer les sites Web IIS, sélectionnez Oui pour supprimer l'application Web et le site Web IIS associé. Sinon, sélectionnez Non pour supprimer uniquement l'association du site Web IIS avec l'application Web.
Important :
Si votre environnement informatique nécessite l'intervention d'un administrateur de base de données pour la création et la gestion des bases de données, vous devrez peut-être contacter votre administrateur de base de données pour supprimer les bases de données de contenu associées à l'application Web. Pour plus d'informations sur le déploiement dans un environnement qui utilise des bases de données créées par l'administrateur de base de données, voir Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010).

Pour supprimer une application Web à l'aide de Windows PowerShell

  1. Vérifiez que les exigences minimales requises suivantes sont respectées : Voir Add-SPShellAdmin. Vous devez également être membre du groupe Administrateurs local sur l'ordinateur exécutant l'Administration centrale. Pour supprimer les bases de données de contenu associées à cette application Web, vous devez également disposer du rôle SharePoint_Shell_Access au sein de ces bases de données de contenu.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Remove-SPWebApplication -identity http://sitename -Confirm

    Cette commande permet de supprimer définitivement l'application Web à l'adresse http://sitename. Cette commande n'entraîne pas la suppression des bases de données de contenu ou du site Web IIS.

Pour plus d'informations, voir Remove-SPWebApplication.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Afficher les collections de sites dans une application Web (SharePoint Foundation 2010)
Voir aussi

Lorsque vous consultez une liste de collections de sites via le site Web Administration centrale, la page affiche l'URL, le titre, la description, l'administrateur principal de la collection de sites, l'adresse de messagerie de contact, ainsi que le nom de la base de données de contenu pour chaque collection de sites. Lorsque vous utilisez des commandes Windows PowerShell 2.0 pour afficher les collections de sites, vous pouvez voir des informations supplémentaires, par exemple le nom de l'administrateur secondaire de la collection de sites, la limite maximale de stockage de la base de données de contenu, et bien d'autres détails.

Dans cet article :

  • Pour afficher les collections de sites à l'aide de l'Administration centrale

  • Pour afficher les collections de sites à l'aide de Windows PowerShell

Pour afficher les collections de sites à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Afficher toutes les collections de sites. La page répertorie les collections de sites de l'application Web affichée dans le menu déroulant Application Web.

  4. Si l'application Web pour laquelle vous souhaitez afficher les collections de sites n'est pas listée, cliquez sur la flèche vers le bas dans le menu Application Web, puis cliquez sur Modifier Application Web. Dans la boîte de dialogue Sélectionner une application Web, cliquez sur le nom de l'application Web de votre choix.

    Une liste de toutes les collections de sites associées à l'application Web s'affiche. Les collections de sites sont listées dans l'ordre alphabétique et sont réparties en groupes de 10 collections de sites par page.

  5. Pour afficher les détails d'une collection de sites listée, cliquez sur l'URL de la collection de sites dans la colonne URL de la page (par exemple /mysites ou /sites/team).

  6. Une fois que vous avez fini d'afficher les collections de sites, cliquez sur OK.

Pour afficher les collections de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Exécutez la commande Get-SPWebApplication pour retourner toutes les collections de sites d'une application Web.

    Code de copie
    Get-SPWebApplication <http://WebApplicationURL> | Get-SPSiteAdministration -Limit ALL | Select URL

    Où <http://WebApplicationURL> est l'URL de l'application Web.

    Exécutez la commande Get-SPSite pour stocker l'identité de la collection de sites souhaitée dans la variable $site. Cela permet de récupérer et de stocker le GUID de la base de données de contenu correspondant à la collection de sites dans la variable $dbguid.

    Code de copie
    $site = Get-SPSite <http://SiteName>
$dbguid = $site.contentdatabase.id

    Où <http://SiteName> est le nom de la collection de sites.

    Exécutez la commande Get-SPSite en utilisant la variable $dbguid pour afficher les propriétés des sites présents dans cette base de données de contenu. Dans l'exemple suivant, l'URL, les propriétés relatives au propriétaire principal, au propriétaire secondaire et au quota sont affichées dans un format tabulaire. Vous pouvez afficher des propriétés supplémentaires en les ajoutant à la commande.

    Code de copie
    Get-SPSite -ContentDatabase $dbguid | Format-Table -Property Url, Owner, SecondaryOwner, Quota

Pour plus d'informations, voir Get-SPWebApplication et Get-SPSite.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Référence

Get-SPSiteAdministration

Historique des modifications


Gérer les autorisations pour une application Web (SharePoint Foundation 2010)

Une application Web se compose d'un site Web IIS (Internet Information Services) qui agit comme une unité logique pour les collections de sites que vous créez. Avant de pouvoir créer une collection de sites, vous devez créer une application Web.

Toutes les applications Web ont des autorisations spécifiques aux listes, des autorisations relatives aux sites et des autorisations personnelles. Les autorisations d'une application Web sont des paramètres exhaustifs qui s'appliquent à l'ensemble des utilisateurs et des groupes de toutes les collections de sites dans une application Web. Vous pouvez contrôler les actions des utilisateurs en activant ou en désactivant l'autorisation associée à l'application Web. Par exemple, pour empêcher les utilisateurs d'ajouter des pages à un site Web, vous pouvez désactiver l'autorisation Ajouter et personnaliser des pages, qui correspond à l'une des autorisations relatives aux sites. Pour plus d'informations, voir Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010).

Important :
Une fois qu'une autorisation spécifique est désactivée pour une application Web, elle ne peut plus être accordée aux utilisateurs d'un site de l'application Web.

Pour définir les autorisations des utilisateurs ou groupes spécifiques d'une application Web, vous pouvez créer une stratégie d'autorisation pour l'application Web. Pour plus d'informations, voir Gérer les stratégies d'autorisation pour une application Web (SharePoint Foundation 2010).

Gérer les autorisations pour une application Web

Vous pouvez configurer un jeu d'autorisations pour contrôler les interactions des utilisateurs avec les sites et le contenu d'une application Web.

Pour gérer les autorisations d'une application Web

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Sous l'onglet Applications Web du ruban, cliquez sur l'application Web pour laquelle vous souhaitez gérer des autorisations.

  4. Dans le groupe Sécurité du ruban, cliquez sur Autorisations des utilisateurs .

  5. Dans la boîte de dialogue Autorisations des utilisateurs de l'application Web, activez les cases à cocher situées en regard des autorisations à activer et désactivez les cases à cocher situées en regard des autorisations à désactiver.

    Vous pouvez sélectionner toutes les autorisations en activant la case à cocher Sélectionner tout. Pour désactiver toutes les autorisations, désactivez la case à cocher Sélectionner tout.

  6. Cliquez sur Enregistrer.

Historique des modifications


Gérer les stratégies d'autorisation pour une application Web (SharePoint Foundation 2010)

Une application Web se compose d'un site Web IIS (Internet Information Services) qui agit comme conteneur logique pour les collections de sites que vous créez. Avant de créer une collection de sites, vous devez d'abord créer une application Web.

Une application Web peut contenir jusqu'à 500 000 collections de sites. La gestion des autorisations pour de si nombreuses collections de sites peut être complexe et sujette aux erreurs, en particulier si certains utilisateurs ou groupes nécessitent des autorisations autres que celles qui s'appliquent à l'ensemble de l'application Web.

Les stratégies d'autorisation offrent un moyen centralisé de configurer et gérer un ensemble d'autorisations qui ne concernent qu'un sous-ensemble d'utilisateurs ou de groupes dans une application Web. Pour plus d'informations, voir Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010).

Les différences entre spécifier des autorisations utilisateur pour une application Web et créer une stratégie d'autorisation pour une application Web sont d'un côté les utilisateurs auxquels s'appliquent les autorisations et de l'autre, l'étendue à laquelle s'appliquent les autorisations. Il existe également une différence dans les listes d'autorisations où des autorisations individuelles sont sélectionnées.

  • Les autorisations pour une application Web sont des paramètres étendus qui s'appliquent à tous les utilisateurs et les groupes pour toutes les collections de sites au sein d'une application Web. La liste des autorisations contient une seule colonne, et toutes les autorisations sont activées par défaut. Vous devez désactiver individuellement des autorisations spécifiques. Pour plus d'informations, voir Gérer les autorisations pour une application Web (SharePoint Foundation 2010).

  • Un niveau de stratégie d'autorisation pour une application Web contient des autorisations qui permettent à un sous-ensemble d'utilisateurs ou de groupes de travailler avec des collections de site de manière spécifique. Par exemple, vous pourriez créer un niveau de stratégie d'autorisation pour les utilisateurs d'une collection de sites autorisés à ajouter, modifier ou supprimer des éléments dans une liste, ouvrir une liste ou afficher des éléments, des listes ou des pages. Toutefois, vous pouvez empêcher ces mêmes utilisateurs de créer ou ou de supprimer des listes, ce qui nécessite l'autorisation Gérer les listes.

    La liste des autorisations contient une colonne Tout accorder et une colonne Refuser tout. Vous pouvez accorder ou refuser toutes les autorisations dans le cadre d'un niveau de stratégie d'autorisation. Vous pouvez également accorder ou refuser des autorisations individuelles. Aucune autorisation n'est activée par défaut. Si une autorisation individuelle n'est ni accordée ni refusée, elle peut être définie à la discrétion de l'administrateur de la collection de sites ou de l'administrateur de site.

Avertissement :
Une stratégie d'autorisation diffère d'une stratégie de gestion des informations. Une stratégie d'autorisation permet de centraliser la gestion des autorisations pour une application Web. Les stratégies de gestion des informations permettent de contrôler quels utilisateurs ont la possibilité d'accéder aux informations, ce qu'ils peuvent faire avec ces informations et la durée de conservation des informations. Une stratégie d'autorisation est également différente d'une stratégie de groupe, qui fournit une infrastructure de gestion centralisée pour la configuration d'un système d'exploitation et des applications qui s'exécutent sur celui-ci.

Dans cet article :

  1. Gérer la stratégie d'autorisation des utilisateurs

  2. Gérer la stratégie d'autorisation pour les utilisateurs anonymes

  3. Gérer les niveaux de stratégie d'autorisation

Gérer la stratégie d'autorisation des utilisateurs

Vous pouvez ajouter des utilisateurs à une stratégie d'autorisation, modifier les paramètres d'une stratégie et supprimer des utilisateurs d'une stratégie d'autorisation. Les paramètres suivants peuvent être spécifiés ou modifiés :

  • Zone : si une application Web dispose de plusieurs zones, vous pouvez spécifier la zone à laquelle la stratégie d'autorisation doit s'appliquer. La valeur par défaut Toutes les zones ne peut être spécifiée que pour les utilisateurs de Windows.

  • Autorisations : vous pouvez spécifier les autorisations Contrôle total, Lecture totale, Refuser l'écriture et Refuser tout, ou spécifier un niveau d'autorisation personnalisé.

  • Système : ce paramètre autorise SharePoint à afficher SHAREPOINT\System pour une activité liée au système indépendamment des comptes d'utilisateur Windows qui ont été configurés pour le pool d'applications d'hébergement et le compte de service de batterie de serveurs SharePoint. Vous pouvez spécifier ce paramètre pour éviter la divulgation d'informations inutiles auprès des utilisateurs finals et des pirates potentiels qui pourraient chercher à en savoir plus sur la façon dont SharePoint est déployé dans votre entreprise.

Ajouter des utilisateurs à une stratégie d'autorisation

Vous pouvez ajouter des utilisateurs à une stratégie d'autorisation pour vous assurer que tous les utilisateurs accèdent au contenu avec le même jeu d'autorisations.

Pour ajouter des utilisateurs à une stratégie d'autorisation

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Cliquez pour mettre en surbrillance la ligne de l'application Web dont vous souhaitez gérer la stratégie d'autorisation.

  4. Dans le groupe Stratégie du ruban, cliquez sur Stratégie de l'utilisateur.

  5. Dans la boîte de dialogue Stratégie de l'application Web, activez la case à cocher en regard de l'utilisateur ou du groupe que vous souhaitez gérer et cliquez sur Ajouter des utilisateurs.

  6. Dans la boîte de dialogue Ajouter des utilisateurs, dans la liste Zone, cliquez sur la zone à laquelle appliquer la stratégie d'autorisation.

  7. Dans la section Choisir les utilisateurs, tapez les noms d'utilisateur, les noms de groupe ou les adresses de messagerie que vous souhaitez ajouter à la stratégie d'autorisation. Vous pouvez également cliquer sur l'icône applicable pour vérifier un nom ou rechercher les noms voulus.

  8. Dans la section Choisir les autorisations, sélectionnez les autorisations à accorder aux utilisateurs.

  9. Dans la section Choisir les paramètres système, cochez Le compte opère en tant que système pour spécifier si un compte d'utilisateur doit être affiché en tant que SHAREPOINT\System au lieu des comptes réels qui effectuent des tâches spécifiques dans l'environnement SharePoint.

  10. Cliquez sur Terminer.

Modifier une stratégie d'autorisation utilisateur

Vous pouvez modifier une stratégie d'autorisation utilisateur pour modifier le niveau d'autorisation ou pour spécifier si un compte d'utilisateur doit être affiché en tant que SHAREPOINT\System au lieu des comptes réels qui effectuent des tâches spécifiques dans l'environnement SharePoint.

Pour modifier une stratégie d'autorisation utilisateur

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Cliquez pour mettre en surbrillance la ligne de l'application Web dont vous souhaitez modifier la stratégie d'autorisation.

  4. Dans le groupe Stratégie du ruban, cliquez sur Stratégie de l'utilisateur.

  5. Dans la boîte de dialogue Stratégie de l'application Web, activez la case à cocher en regard de l'utilisateur ou du groupe que vous souhaitez gérer et cliquez sur Modifier les autorisations des utilisateurs sélectionnés.

  6. Dans la boîte de dialogue Modifier les utilisateurs, dans la section Niveaux de stratégies d'autorisation, sélectionnez les autorisations à accorder aux utilisateurs.

  7. Dans la section Choisir les paramètres système, activez Le compte opère en tant que système pour spécifier si un compte d'utilisateur doit être affiché en tant que SHAREPOINT\System au lieu des comptes réels qui effectuent des tâches spécifiques dans l'environnement SharePoint.

  8. Cliquez sur Enregistrer.

Supprimer des utilisateurs d'une stratégie d'autorisation

Vous pouvez supprimer des utilisateurs d'une stratégie d'autorisation lorsqu'ils ne sont plus membres de l'organisation ou du groupe auquel s'applique la stratégie. Par exemple, lorsqu'un employé quitte la société, le compte d'utilisateur de cette personne doit être retiré de toutes les stratégies d'autorisation.

Pour supprimer des utilisateurs d'une stratégie d'autorisation

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Cliquez pour mettre en surbrillance la ligne de l'application Web dont vous souhaitez gérer la stratégie d'autorisation.

  4. Dans le groupe Stratégie du ruban, cliquez sur Stratégie de l'utilisateur.

  5. Dans la boîte de dialogue Stratégie de l'application Web, activez la case à cocher en regard de l'utilisateur ou du groupe que vous souhaitez gérer, cliquez sur Supprimer les utilisateurs sélectionnés, puis cliquez sur OK.

Gérer la stratégie d'autorisation pour les utilisateurs anonymes

Vous pouvez activer ou désactiver l'accès anonyme pour une application Web. Si vous activez l'accès anonyme pour une application Web, les administrateurs de site peuvent ensuite accorder ou refuser l'accès anonyme au niveau de la collection de sites, d'un site ou d'un élément. Si l'accès anonyme est désactivé pour une application Web, aucun site au sein de cette application Web n'est accessible par les utilisateurs anonymes.

Les stratégies d'autorisation suivantes peuvent être spécifiées pour les utilisateurs anonymes :

  1. Aucune : aucune stratégie n'est spécifiée. Ce paramètre accorde aux utilisateurs anonymes les mêmes autorisations par défaut disponibles aux utilisateurs authentifiés par une autorité NT ou à tous les utilisateurs authentifiés.

  2. Refuser l'écriture : ce paramètre autorise les utilisateurs anonymes à lire tout le contenu des collections de sites dans une application Web. Vous pouvez ensuite limiter l'accès en lecture par collection de sites, par site ou par élément.

  3. Refuser tout : les utilisateurs anonymes n'ont accès à aucune partie de l'application Web.

Pour gérer la stratégie d'autorisation des utilisateurs anonymes

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Cliquez pour mettre en surbrillance la ligne de l'application Web dont vous souhaitez gérer la stratégie d'autorisation.

  4. Dans le groupe Stratégie du ruban, cliquez sur Stratégie anonyme.

  5. Dans la boîte de dialogue Restrictions d'accès anonyme, dans la liste Zone, cliquez sur la zone à laquelle appliquer la stratégie.

  6. Dans la section Autorisations, sélectionnez la stratégie d'autorisation à accorder aux utilisateurs anonymes, puis cliquez sur Enregistrer.

Gérer les niveaux de stratégie d'autorisation

Les niveaux de stratégie d'autorisation contiennent des autorisations qui s'appliquent à des utilisateurs ou des groupes spécifiques. Vous pouvez spécifier une combinaison d'autorisations de liste, de site ou personnelles. Vous pouvez également spécifier un des niveaux d'autorisation de collection de sites suivants :

  • Administrateur de collection de sites : dispose de l'autorisation Contrôle total sur la collection de sites entière et peut exécuter toute action sur n'importe quel objet.

  • Auditeur de collection de sites : dispose de l'autorisation Lecture totale sur l'intégralité de la collection de sites et des données associées, telles que les autorisations et les informations de configuration.

Si vous spécifiez l'un de ces niveaux d'autorisation ou les deux, vous ne pouvez pas spécifier des autorisations individuelles.

Ajouter un niveau de stratégie d'autorisation

Vous pouvez créer un niveau de stratégie d'autorisation afin de personnaliser un jeu d'autorisations pour une organisation ou un groupe spécifique.

Pour ajouter un niveau de stratégie d'autorisation

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Cliquez pour mettre en surbrillance la ligne de l'application Web dont vous souhaitez gérer la stratégie d'autorisation.

  4. Dans le groupe Stratégie du ruban, cliquez sur Stratégie d'autorisation.

  5. Dans la boîte de dialogue Gérer les niveaux de stratégies d'autorisation, cliquez sur Ajouter un niveau de stratégie d'autorisation.

  6. Dans la boîte de dialogue Ajouter un niveau de stratégie d'autorisation, dans la section Nom et description, tapez le nom et la description de la stratégie que vous souhaitez créer.

  7. Dans la section Autorisations de la collection de sites, sélectionnez les autorisations de collection de sites pour cette stratégie.

  8. Dans la section Autorisations, sélectionnez les autorisations que vous souhaitez accorder ou refuser à ce niveau d'autorisation.

    • Activez la case à cocher Tout accorder pour inclure toutes les autorisations disponibles dans cette stratégie.

    • Activez la case à cocher Refuser tout pour refuser toutes les autorisations disponibles à cette stratégie.

    • Activez les cases à cocher Accorder ou Refuser pour inclure ou exclure des autorisations individuelles de liste, de site ou personnelles dans cette stratégie.

      N'activez pas Accorder ni Refuser si vous souhaitez autoriser les propriétaires de site ou de collection de sites à configurer cette autorisation.

  9. Cliquez sur Enregistrer.

Modifier un niveau de stratégie d'autorisation

Vous pouvez modifier un niveau de stratégie d'autorisation pour ajouter ou supprimer des autorisations individuelles en fonction des besoins de l'utilisateur ou du groupe qui utilise ce niveau de stratégie.

Pour modifier un niveau de stratégie d'autorisation

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Cliquez pour mettre en surbrillance la ligne de l'application Web dont vous souhaitez gérer la stratégie d'autorisation.

  4. Dans le groupe Stratégie du ruban, cliquez sur Stratégie d'autorisation.

  5. Dans la boîte de dialogue Gérer les niveaux de stratégies d'autorisation, cliquez sur le lien du niveau de stratégie d'autorisation à modifier.

  6. Dans la page Modifier le niveau de stratégie d'autorisation, modifiez les paramètres, puis cliquez sur Enregistrer.

Supprimer un niveau de stratégie d'autorisation

Vous pouvez supprimer un niveau de stratégie d'autorisation si l'organisation ou le groupe pour lequel vous l'avez créé n'en a plus besoin. Il est recommandé de passer en revue tous les niveaux de stratégie d'autorisation existants pour vérifier s'ils sont toujours nécessaires.

Pour supprimer un niveau de stratégie d'autorisation

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Sur le site Web Administration centrale, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  3. Cliquez pour mettre en surbrillance la ligne de l'application Web dont vous souhaitez gérer la stratégie d'autorisation.

  4. Dans le groupe Stratégie du ruban, cliquez sur Stratégie d'autorisation.

  5. Dans la boîte de dialogue Gérer les niveaux de stratégies d'autorisation, activez la case à cocher d'un niveau de stratégie d'autorisation, cliquez sur Supprimer les niveaux de stratégies d'autorisation sélectionnés, puis cliquez sur OK.

Historique des modifications


Analyse d'intégrité (SharePoint Foundation 2010)

Les articles de cette section visent à répondre aux besoins des informaticiens chargés de la planification, de la conception, du déploiement et de la surveillance des solutions. Ces solutions peuvent se trouver dans les environnements d'entreprise ou de succursales. Les informaticiens responsables de la surveillance des solutions sont censés comprendre les détails techniques contenus dans cette section. Toutefois, une expertise de niveau service n'est pas nécessaire pour comprendre les problématiques et les décisions au niveau entreprise.

Les fonctionnalités de surveillance dans Microsoft SharePoint Foundation 2010 vous permettent de comprendre le fonctionnement du système SharePoint Foundation 2010, d'analyser et résoudre les problèmes et d'afficher des mesures concernant les sites. La surveillance de l'environnement SharePoint Foundation 2010 comprend les tâches suivantes :

  1. Configuration des divers aspects de la surveillance en fonction des besoins de l'entreprise.

  2. Surveillance de l'environnement et résolution des problèmes qui peuvent survenir.

  3. Consultation des rapports et des journaux sur l'activité de l'environnement.

Surveillance

Dans cette section :

  • Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

  • Configuration de la surveillance (SharePoint Foundation 2010)

  • Affichage des rapports et des journaux (SharePoint Foundation 2010)

  • Résolution des problèmes et dépannage (SharePoint Foundation 2010)

  • Surveiller l'intégrité et les performances d'un environnement virtuel (SharePoint Foundation 2010)

Historique des modifications


Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

Les fonctionnalités d'analyse et de surveillance dans Microsoft SharePoint Foundation 2010 vous aident à comprendre comment le système SharePoint Foundation 2010 fonctionne, à analyser et réparer les problèmes et à afficher les mesures des sites. L'analyse de l'environnement de SharePoint Foundation 2010 comprend les tâches suivantes :

  1. Configuration des divers aspects de l'analyse en fonction des besoins de l'entreprise.

  2. Analyse de l'environnement et résolution des problèmes qui peuvent survenir.

  3. Consultation des rapports et des journaux de l'activité de l'environnement.

Dans cet article :

  • Configuration de l'analyse

  • Analyse de la batterie de serveurs et résolution des problèmes à l'aide de l'Analyseur d'intégrité SharePoint

  • Afficher et utiliser les rapports

Configuration de l'analyse

SharePoint Foundation 2010 est installé avec les paramètres par défaut pour ses fonctionnalités d'analyse. Toutefois, vous souhaiterez peut-être modifier certains de ces paramètres afin de mieux répondre aux besoins de l'entreprise. Les aspects pour lesquels vous pouvez souhaiter modifier les paramètres de configuration incluent la journalisation des diagnostics et la collecte de données d'utilisation et d'intégrité.

Journalisation des diagnostics

SharePoint Foundation 2010 collecte dans le journal des diagnostics des données qui peuvent être utiles pour la résolution des problèmes. Les paramètres par défaut suffisent dans la plupart des cas, mais en fonction des besoins de l'entreprise et du cycle de vie de la batterie de serveurs, vous pouvez souhaiter modifier ces paramètres. Par exemple, si vous déployez une nouvelle fonctionnalité ou apportez des modification à grande échelle à l'environnement, vous pouvez vouloir modifier le niveau de journalisation pour définir un niveau plus détaillé, afin de recueillir autant de données que possible sur l'état du système lors des modifications, ou un niveau inférieur afin de réduire la taille du journal et des ressources nécessaires pour consigner les données. Pour plus d'informations et les pratiques recommandées, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

Collecte de données d'utilisation et d'intégrité

Les fonctionnalités d'analyse dans SharePoint Foundation 2010 utilisent des travaux de minuteur spécifiques pour effectuer des tâches d'analyse et collecter des données d'analyse. Les données d'utilisation et d'intégrité peuvent comprendre des données du compteur de performances, des données du journal des événements, des données de service de minuterie, des mesures de collections de sites et de sites, des données sur l'utilisation des recherches ou différents aspects des performances des serveurs Web. Le système utilise ces données pour créer des rapports d'intégrité, des rapports d'analyse Web et des rapports d'administration. Le système écrit les données d'utilisation et d'intégrité dans le dossier de journalisation et dans la base de données de journalisation.

Un travail de minuteur déclenche l'exécution d'un service Windows spécifique pour l'un des produits SharePoint 2010. Il contient une définition du service à exécuter et spécifie la fréquence de démarrage de celui-ci. Le service minuteur de Windows SharePoint Services Timer v4 (SPTimerV4) effectue les travaux de minuteur. De nombreuses fonctionnalités dans les produits SharePoint 2010 dépendent de travaux de minuteur pour exécuter des services selon un calendrier.

Vous pouvez souhaiter modifier l'exécution des travaux de minuteur pour la collecte des données de manière à la rendre plus ou moins fréquente. Vous pouvez même, si vous le souhaitez, désactiver les travaux qui collectent les données qui ne vous intéressent pas. Vous pouvez effectuer les tâches suivantes sur les travaux de minuteur :

  • Modifier la planification d'exécution du travail de minuteur.

  • Exécuter les travaux de minuteur immédiatement.

  • Activer ou désactiver les travaux de minuteur.

  • Afficher l'état de travail de minuteur. Vous pouvez afficher les travaux actuellement planifiés, les travaux non réussis, les travaux en cours d'exécution et un historique complet des travaux de minuteur.

Pour plus d'informations sur la configuration de ces paramètres, voir Configurer des travaux de minuteur Analyseur d'intégrité SharePoint (SharePoint Foundation 2010).

Analyse de la batterie de serveurs et résolution des problèmes à l'aide de l'Analyseur d'intégrité SharePoint

SharePoint Foundation 2010 inclut un nouvel outil appelé Analyseur d'intégrité SharePoint qui permet de diagnostiquer les problèmes d'utilisation, de performances et de configuration. L'Analyseur d'intégrité SharePoint exécute des règles d'intégrité prédéfinies sur les serveurs de la batterie. Une règle d'intégrité exécute un test et génère un état qui vous informe sur le résultat du test. En cas d'échec d'une règle, l'état est écrit dans la liste Rapports d'intégrité dans SharePoint Foundation 2010 et dans le journal des événements Windows. L'Analyseur d'intégrité SharePoint crée également une alerte dans la liste Rapports de l'Analyseur d'intégrité dans la page Examiner les problèmes et solutions de l'admisration centrale. Vous pouvez cliquer sur une alerte plus obtenir plus d'informations sur le problème et afficher les étapes conduisant à sa résolution. Vous pouvez aussi ouvrir la règle à l'origine de l'alerte et modifier ses paramètres.

Comme toutes les listes de SharePoint Foundation 2010, vous pouvez modifier les éléments de la liste Rapports de l'Analyseur d'intégrité, créer des affichages personnalisés, exporter des éléments de liste dans Microsoft Excel, vous abonner au flux RSS pour la liste et effectuer de nombreuses autres tâches. Chaque règle d'intégrité se situe dans l'une des catégories suivantes : sécurité, de performances, de configuration ou disponibilité.

Une règle d'intégrité peut être exécutée selon un programme défini ou improvisé. Toutes les règles d'intégrité sont disponibles via l'administration centrale, dans la page de contrôle, pour une exécution immédiate ou planifiée.

Les administrateurs de batterie de serveurs peuvent configurer des règles d'intégrité spécifiques pour effectuer les opérations suivantes :

  • Activer ou désactiver des règles.

  • Configurer des règles à exécuter selon une planification prédéfinie.

  • Définir l'étendue d'exécution des règles.

  • Recevoir des alertes par courrier électronique lorsque des problèmes sont détectés.

  • Exécuter des règles de manière impromptue.

Pour plus d'informations sur la configuration de ces paramètres, voir Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010).

Afficher et utiliser les rapports

SharePoint Foundation 2010 peut être configuré pour collecter des données et créer des rapports sur l'état du serveur et l'utilisation du site, tels que des rapports désignant notamment les pages les plus lentes et les pages les plus actives

Historique des modifications


Configuration de la surveillance (SharePoint Foundation 2010)
Voir aussi

Les articles de cette section visent à répondre aux besoins des informaticiens chargés de la planification, de la conception, du déploiement et de l'exploitation de solutions d'analyse et de surveillance. Ces solutions peuvent se trouver dans les environnements d'entreprise ou de succursales. Les informaticiens responsables des solutions d'analyse et de surveillance sont supposés comprendre les détails techniques contenus dans cette section. Toutefois, une expertise de niveau de service n'est pas nécessaire pour comprendre les discussions et les décisions de niveau entreprise.

L'environnement de Microsoft SharePoint Foundation 2010 peut nécessiter que vous configuriez des paramètres d'analyse après le déploiement initial ou une mise à niveau. Vous devrez peut-être modifier les informations collectées pour l'analyse, quand et à quelle fréquence ces données sont collectées ou d'autres paramètres de journalisation qui répondent mieux aux exigences professionnelles et d'environnement.

Configurer l'analyse

Inclus dans cette section

  • Configurer la journalisation des diagnostics (SharePoint Foundation 2010)

  • Configurer la collecte de données d'utilisation et d'intégrité (SharePoint Foundation 2010)

  • Configurer les règles de l'analyseur d'intégrité SharePoint (SharePoint Foundation 2010)

  • Configurer des travaux de minuteur Analyseur d'intégrité SharePoint (SharePoint Foundation 2010)

Voir aussi

Concepts

Analyse d'intégrité (SharePoint Foundation 2010)

Historique des modifications


Configurer des travaux de minuteur Analyseur d'intégrité SharePoint (SharePoint Foundation 2010)
Voir aussi

L'Analyseur d'intégrité SharePoint dans SharePoint Foundation 2010 utilise des travaux de minuteur pour collecter les données d'intégrité et puis écrit ces données dans le dossier de journalisation et la base de données de journalisation. Ces données sont utilisées dans les rapports pour afficher l'état d'intégrité des serveurs de batterie. Vous pouvez replanifier ces travaux de minuteur, les exécuter immédiatement, ou les activer ou les désactiver.

Dans cet article :

  • Utiliser l'administration centrale pour configurer des travaux de minuteur de collection de données d'intégrité

  • Utiliser Windows PowerShell pour configurer des travaux de minuteur de la collection de données d'intégrité

Utiliser l'administration centrale pour configurer des travaux de minuteur de collection de données d'intégrité

Vous pouvez utiliser l'administration centrale pour configurer des travaux de minuteur de collection de données d'intégrité.

Pour configurer des travaux de minuteur de collection de données d'intégrité à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

    Remarque :
    Les paramètres de travail de minuteur de collection de données d'intégrité s'appliquent à l'échelle de la batterie de serveurs et ne peuvent pas être définis pour des serveurs individuels de la batterie de serveurs.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  4. Dans la page de configuration de la collection des données d'utilisation et d'intégrité, effectuez l'une des opérations suivantes :

    • Pour activer le travail de minuteur, cliquez sur activer .

    • Pour désactiver le travail de minuteur, cliquez sur Désactiver .

    1. Dans la section Journalisation d'intégrité, cliquez sur Planification de la journalisation d'intégrité. Une page s'ouvre en répertoriant tous les travaux de minuteur qui collectent des données d'intégrité.

    2. Dans la page Définitions des travaux , cliquez sur le travail de minuteur que vous voulez configurer.

    3. Dans la page Modifier le travail du minuteur, dans la section Planification périodique, modifiez la planification de travail de minuteur, puis cliquez sur OK .

Utiliser Windows PowerShell pour configurer des travaux de minuteur de la collection de données d'intégrité

Vous pouvez configurer la planification de travail de minuteur de la collection de données d'intégrité à l'aide de Windows PowerShell.

Pour configurer des travaux de minuteur de données d'intégrité à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Set-SPTimerJob [-Identity <name>] [-Schedule <Schedule string>]

    La valeur du paramètre Identity spécifie le travail de minuteur. Si vous n'utilisez pas le paramètre Identity, tous les travaux de minuteur sont configurés. Pour afficher une liste de tous les travaux de minuteur, tapez la commande suivante et appuyez sur ENTRÉE :

    Get-SPTimerJob | Format-Table -property id,title

    Utilisez la valeur du paramètre Schedule pour spécifier la planification, où < planifier chaîne > est une des opérations suivantes :

    • every <1-60> seconds

    • every <1-60> minutes at <1-60>

    • every <1-60> minutes between <1-60> and <1-60>

    • hourly between <1-59> minutes past the hour and <1-59> minutes past the hour

    • daily between starting from <hh:mm:ss> and starting no later than <hh:mm:ss>

    • weekly between starting on <day of the week hh:mm:ss> and starting no later than <day of the week hh:mm:ss>

    • monthly between starting on < day number hh:mm:ss> and starting no later than < day number hh:mm:ss>

    • monthly by <hh:mm:ss> on <week number> <day of week>

    Pour afficher des exemples de planifications de travail de minuteur, tapez la commande suivante et appuyez sur ENTRÉE :

    Get-SPTimerJob | Format-Table -property id,title,schedule

    Pour plus d'informations, voir Get-SPTimerJob et Set-SPTimerJob.
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

Historique des modifications


Configurer les règles de l'analyseur d'intégrité SharePoint (SharePoint Foundation 2010)

Cette rubrique décrit la configuration des règles de l'analyseur d'intégrité SharePoint.

Remarque :
Vous pouvez utiliser uniquement l'Administration centrale pour configurer les règles de l'analyseur d'intégrité SharePoint.

Configuration des règles d'intégrité

Vous pouvez accepter les paramètres par défaut de chaque règle d'intégrité ou vous pouvez modifier les paramètres d'une règle d'intégrité à l'aide de l'Administration centrale.

Pour configurer les règles d'intégrité à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, sous Analyseur d'intégrité, cliquez sur Définitions de règles de révision.

  4. Dans la page Définitions de règle de l'analyseur d'intégrité, cliquez sur la règle à configurer.

  5. Dans la boîte de dialogue Définitions de règle de l'analyseur d'intégrité, cliquez sur Modifier l'élément.

  6. Modifiez les champs de règle de votre choix, puis cliquez sur Enregistrer.

    Pour laisser la règle inchangée, fermez la boîte de dialogue ou cliquez sur Annuler.

Chaque règle d'intégrité a des champs configurables qui sont décrits dans le tableau ci-après.

Champ configurable Valeurs possibles

Titre

Nom de la règle d'intégrité. Vous pouvez renommer une règle d'intégrité pour clarifier sa fonctionnalité. Le titre correspond au nom de la règle tel qu'il apparaît dans la liste Définitions de règle de l'analyseur d'intégrité dans l'Administration centrale.

La modification du titre n'a pas d'incidence sur l'exécution de la règle.

Étendue

Vous pouvez définir une règle d'intégrité de sorte qu'elle s'exécute sur tous les serveurs ou sur un serveur quelconque. Si elle est définie sur un serveur quelconque, la règle s'exécute sur le premier serveur disponible trouvé par le système.

Planification

Vous pouvez planifier une règle d'intégrité de manière à ce qu'elle s'exécute chaque heure, jour, semaine, mois ou à la demande.

Activé

Vous pouvez utiliser cette option pour activer ou désactiver une règle d'intégrité.

Réparation automatique

Vous pouvez définir si une règle d'intégrité tente automatiquement ou non de résoudre chaque condition d'erreur rencontrée. Si cette option est sélectionnée, SharePoint Foundation 2010 réparer les erreurs dès qu'elles sont détectées, conformément à la règle.

Remarque :
Si aucune réparation n'est spécifiée par la règle, le système n'essaie pas de résoudre le problème.

Version

L'historique des versions permet de suivre les modifications apportées à chaque règle. Le numéro de la version est mis à jour à chaque enregistrement de la règle. Il n'a pas d'incidence sur le comportement de la règle.

Chaque règle d'intégrité a des champs en lecture seule qui sont décrits dans le tableau ci-après.

Champ en lecture seule | Signification
Version | Numéro de version actuel de la règle.
Créée le | Date et heure auxquelles la règle a été initialement créée et compte d'utilisateur à l'origine de la création de la règle.
Dernière modification le | Date et heure de la dernière modification de la règle et compte d'utilisateur à l'origine de la création de la règle.

Historique des modifications


Affichage des rapports et des journaux (SharePoint Foundation 2010)
Voir aussi

Les articles de cette section visent à répondre aux besoins des informaticiens chargés de la planification, de la conception, du déploiement et de la surveillance des solutions. Ces solutions peuvent se trouver dans les environnements d'entreprise ou de succursales. Les informaticiens responsables de la surveillance des solutions sont censés comprendre les détails techniques contenus dans cette section. Toutefois, une expertise au niveau service n'est pas nécessaire pour comprendre les arguments et les décisions au niveau entreprise.

Vous pouvez surveiller l'environnement de Microsoft SharePoint Foundation 2010 en consultant les rapports sur l'état d'intégrité du système et des sites, et les journaux de diagnostic qui fournissent des informations détaillées sur les problèmes qui peuvent survenir.

Dans cette section :

  • Afficher les rapports d'intégrité (SharePoint Foundation 2010)

  • Afficher les journaux de diagnostic (SharePoint Foundation 2010)

  • Afficher l'état des travaux du minuteur (SharePoint Foundation 2010)

Voir aussi

Concepts

Analyse d'intégrité (SharePoint Foundation 2010)

Historique des modifications


Afficher les rapports d'intégrité (SharePoint Foundation 2010)
Voir aussi

Cet article contient des informations sur la façon d'afficher des rapports d'intégrité.

Les rapports d'intégrité sont des rapports préconfigurés dans Microsoft SharePoint Foundation 2010 qui, à partir de données d'utilisation, analysent différents aspects des sites et des collections de sites, tels que les pages les plus lentes et les utilisateurs les plus actifs.

Remarque :
Vous ne pouvez pas utiliser Windows PowerShell pour afficher les données des rapports d'intégrité.

Afficher les rapports d'intégrité à l'aide de l'Administration centrale

Vous pouvez afficher les rapports d'intégrité uniquement à l'aide de l'Administration centrale.

Pour afficher les rapports d'intégrité à l'aide de l'Administration centrale

  1. Ouvrez une session en tant que membre du groupe SharePoint Administrateurs de batterie.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Afficher les rapports d'intégrité.

  4. Dans la page des rapports, dans la section de lancement rapide, cliquez sur le nom du rapport à afficher.

  5. Pour afficher les données du rapport, sélectionnez les critères de données, puis cliquez sur OK.

  6. Pour trier les lignes de données, cliquez sur le nom de la colonne.

Voir aussi

Concepts

Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

Historique des modifications


Afficher les journaux de diagnostic (SharePoint Foundation 2010)
Voir aussi

Vous pouvez utiliser les données des journaux ULS (Universal Logging System) de Microsoft SharePoint Foundation 2010 pour résoudre les problèmes de la batterie de serveurs. Le journal ULS peut collecter les données à divers niveaux en fonction des paramètres de journalisation. Vous pouvez utiliser Windows PowerShell pour filtrer les données, les afficher de différentes manières et les placer dans une grille de données à des fins de filtrage, de tri, de regroupement et d'exportation vers Microsoft Excel 2010.

Pour plus d'informations, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

Afficher et filtrer les événements de journal à l'aide de Windows PowerShell

Vous pouvez utiliser Windows PowerShell pour afficher et filtrer les événements de journal. Vous ne pouvez pas afficher ou filtrer les événements de journal à l'aide de l'Administration centrale.

Pour afficher et filtrer les événements de journal à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez l'une des commandes suivantes :

    • Tous les événements de suivi :

      Get-SPLogEvent

    • Par niveau :

      Get-SPLogEvent | Where-Object {$_.Level -eq [Information | Warning | Error | Critical | Verbose | Unexpected | Monitorable | High | Medium]}

    • Par zone :

      Get-SPLogEvent | Where-Object {$_.Area -eq <Area>}

      Où <Area> représente la valeur de la propriété Area.

    • Par catégorie :

      Get-SPLogEvent | Where-Object {$_.Category -eq <Category>

      Où <Category > représente la valeur de la propriété Category.

    • Par ID d'événement :

      Get-SPLogEvent | Where-Object {$_.EventID -eq <EventID>}

      Où <EventID> représente la valeur de la propriété EventID.

    • Par texte de message :

      Get-SPLogEvent | Where-Object {$_.Message -like "*<string>*"}

      Où <string> représente la chaîne trouvée dans le message de l'événement.

    • Par processus :

      Get-SPLogEvent | Where-Object {$_.Process -like "*<Process>*"}

      Où <Process > représente la valeur de la propriété Process.

    Conseil :
    Par défaut, la commande récupère les données à partir du dossier de journalisation ULS par défaut. Pour afficher et filtrer les événements de suivi qui se trouvent dans un dossier partagé sur un réseau, utilisez le paramètre Directory de l'applet de commande Get-SPLogEvent.

    Pour afficher davantage de détails sur chaque événement de suivi, utilisez Format-List à la fin de la commande. Par exemple, Get-SPLogEvent | Where-Object {$_.Area -eq "SharePoint Foundation"} | Format-List.

Pour plus d'informations, voir Get-SPLogEvent.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Afficher et exporter des journaux de diagnostic à l'aide de l'applet de commande Windows PowerShell Out-GridView

Windows PowerShell dispose d'une fonctionnalité puissante et simple d'emploi, qui affiche les données tabulaires résultant de commandes Windows PowerShell dans une grille de données filtrable et interrogeable, au sein d'une fenêtre distincte. Vous pouvez utiliser cette grille pour afficher les événements de journal et pour effectuer les opérations suivantes sur les données :

  • Trier les données en fonction de n'importe quelle colonne.

  • Afficher les données par groupes.

  • Filtrer les données par niveau, zone, catégorie, message, ID d'événement ou horodatage.

  • Rechercher les données d'une chaîne.

  • Exporter des données brutes, triées ou filtrées vers une feuille de calcul.

Remarque :
L'applet de commande Out-GridView ne peut pas être utilisée avec les applets de commande qui emploient le verbe Format. L'applet de commande Out-GridView reçoit des objets alors que les applets de commande qui emploient le verbe Format renvoient uniquement du texte mis en forme. Toutefois, vous pouvez appliquer un filtre préliminaire aux données envoyées vers l'affichage de grille à l'aide du pipeline Where-Object (par exemple, Get-SPLogEvent | Where-Object {$_.Area -eq "SharePoint Foundation"} | Out-GridView.

Si la grille affiche plusieurs centaines de lignes, son exécution peut être lente, en particulier lors d'opérations de filtrage complexes. Pour de meilleures performances en termes de rapidité, exportez les données vers Excel 2010.

Pour plus d'informations, voir Out-GridView (http://go.microsoft.com/fwlink/?linkid=181248&clcid=0x40C) et Out-GridView revisité (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=181249&clcid=0x40C).

Pour afficher et filtrer les journaux de diagnostic à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Get-SPLogEvent | Out-GridView

  6. Pour afficher les résultats sous forme de groupes :

    1. Cliquez avec le bouton droit sur l'en-tête de colonne, cliquez sur Afficher dans des groupes, puis sur l'en-tête de colonne correspondant à la valeur de regroupement des résultats.

    2. Pour développer ou réduire un groupe spécifique, cliquez sur la flèche en regard du nom de groupe.

    3. Pour supprimer un regroupement, cliquez avec le bouton droit sur l'en-tête de colonne, puis cliquez sur Afficher dans des groupes.

  7. Pour trier des colonnes, cliquez sur l'en-tête de colonne.

  8. Pour rechercher une chaîne spécifique, tapez cette dernière dans la zone de Recherche. La recherche est effectuée sur l'ensemble des colonnes et des lignes. Pour effacer la recherche, cliquez sur Effacer tout.

  9. Pour filtrer les données en fonction d'un seul critère, tapez ce qui suit dans la zone de Recherche : <nom de propriété>:<valeur>. Par exemple, pour rechercher toutes les entrées de journal générées par SharePoint Foundation 2010, tapez ce qui suit : Area:SharePoint Foundation. Pour effacer le filtre, cliquez sur Effacer tout.

  10. Pour filtrer les données en utilisant plusieurs critères ou en utilisant des critères tels que « contient, commence par, se termine par », ou à l'aide d'autres méthodes :

    1. Cliquez sur Requête.

    2. Cliquez sur Ajouter.

    3. Cliquez sur la case à cocher relative aux propriétés à filtrer, puis cliquez sur OK.

    4. Cliquez sur contient pour changer de méthode de filtrage. Les méthodes disponibles sont contient, ne contient pas, commence par, est égal à, est différent de, se termine par, est vide et n'est pas vide.

    5. Tapez une valeur dans la zone de texte.

    6. Répétez les étapes « e » et « f » pour chaque propriété sélectionnée à l'étape « c ».

    7. Une fois tous les critères de filtrage spécifiés, cliquez sur le bouton de recherche pour filtrer la grille de données.

    8. Pour effacer un filtre spécifique, cliquez sur le bouton X.

    9. Pour effacer tous les filtres, développez la vue des requêtes, puis cliquez sur le bouton Effacer tout.

Pour exporter les données de la grille vers une feuille de calcul

  1. Sélectionnez les lignes à exporter. Vous pouvez sélectionner plusieurs lignes en maintenant enfoncée la touche Maj tout en faisant glisser la souris pour sélectionner un bloc de lignes, ou en maintenant enfoncée la touche Ctrl tout en cliquant sur une ligne pour sélectionner des lignes spécifiques, ou en appuyant sur Ctrl+A pour sélectionner l'ensemble des lignes.

    Vous pouvez également filtrer et trier les résultats avant de copier les données dans une feuille de calcul. Lorsque vous filtrez ou triez les données, seules les données visibles résultantes sont copiées.

  2. Copiez les lignes sélectionnées à l'aide de Ctrl+C.

  3. Ouvrez la page du classeur de la feuille de calcul, puis collez les lignes copiées à l'aide de Ctrl+V.

Voir aussi

Concepts

Configurer la journalisation des diagnostics (SharePoint Foundation 2010)
Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

Historique des modifications


Afficher l'état des travaux du minuteur (SharePoint Foundation 2010)
Voir aussi

Un travail de minuteur s'exécute un service Windows spécifique pour Microsoft SharePoint Foundation 2010. Le travail de minuteur contient une définition du service à exécuter et spécifie la fréquence à laquelle le service est démarré. Le service de minuteur Windows SharePoint Services Timer v4 (SPTimerV4) exécute des travaux de minuteur. De nombreuses fonctionnalités dans SharePoint Foundation 2010 dépendent de travaux de minuteur pour exécuter les services selon la planification établie. Vous pouvez afficher l'état des travaux de minuteur qui ont été exécutés via le site Web Administration centrale ou Windows PowerShell.

Dans cet article :

  • Afficher l'état de travail de minuteur à l'aide de l'administration centrale

  • Afficher l'état de travail de minuteur à l'aide de Windows PowerShell

Afficher l'état de travail de minuteur à l'aide de l'administration centrale

Vous pouvez afficher l'état de travail de minuteur à l'aide de l'administration centrale.

Afficher l'état de travail de minuteur à l'aide de l'administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe SharePoint Administrateurs de la batterie de serveurs.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Travaux du minuteur, cliquez sur Vérifier l'état du travail.

  4. L'état de travail de minuteur est divisé en trois groupes : Planifié , En cours d'exécution et Historique. Pour parcourir les lignes de données de l'état du travail de minuterie, cliquez sur les flèches de pagination en bas de ces groupes.

  5. Pour afficher l'état du travail de minuterie d'un groupe spécifique, cliquez sur le titre du groupe en question. Autrement, dans la barre de lancement rapide, cliquez sur Travaux planifiés, Travaux en cours d'exécution ou Historique des travaux.

Afficher l'état de travail de minuteur à l'aide de Windows PowerShell

Vous pouvez afficher l'état de travail de minuteur à l'aide de Windows PowerShell.

Pour afficher l'état de travail de minuteur à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Outils d'administration.

  3. Cliquez sur SharePoint 2010 Management Shell.

  4. À l'invite de commandes de Windows PowerShell (PS C:\>), entrez l'applet de commande suivante et appuyez sur la touche ENTRÉE :

    Get-SPTimerJob [-Identity <Timer job name…>] | Format-Table -Property DisplayName,Id,LastRunTime,Status

    Vous pouvez utiliser la valeur du paramètre Identity pour spécifier un travail de minuteur. Si vous n'utilisez pas le paramètre Identity, tous les travaux de minuteur sont renvoyés.

    Pour afficher l'historique d'un travail de minuteur spécifique, tapez la commande suivante et appuyez sur ENTRÉE :

    (Get-SPTimerJob [-Identity <Timer job name…>]).HistoryEntries | Format-Table -Property Status,StartTime,EndTime,ErrorMessage

Pour plus d\rquote informations, voir Get-SPTimerJob.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Vue d'ensemble de la surveillance (SharePoint Foundation 2010)

Historique des modifications


Résolution des problèmes et dépannage (SharePoint Foundation 2010)
Voir aussi

Les articles de cette section visent à répondre aux besoins des informaticiens chargés de la planification, de la conception, du déploiement et de l'exploitation de solutions d'analyse et de surveillance. Ces solutions peuvent se trouver dans les environnements d'entreprise ou de succursales. Les informaticiens responsables des solutions d'analyse et de surveillance sont supposés comprendre les détails techniques contenus dans cette section. Toutefois, une expertise de niveau de service n'est pas nécessaire pour comprendre les discussions et les décisions de niveau entreprise.

Microsoft SharePoint Foundation 2010 inclut un nouvel outil appelé Analyseur d'intégrité SharePoint, qui vous permet de diagnostiquer et de résoudre des problèmes de configuration, de performance et d'utilisation. L'Analyseur d'intégrité SharePoint exécute des règles d'intégrité prédéfinies sur les serveurs de la batterie. Une règle d'intégrité exécute un test et renvoie une alerte qui vous informe sur le résultat du test. Vous pouvez utiliser l'Administration centrale pour afficher les alertes et résoudre les problèmes.

Dans cette section :

  • Affichage et résolution des alertes de l'analyseur d'intégrité SharePoint (SharePoint Foundation 2010) - Cet article décrit comment utiliser l'Analyseur d'intégrité SharePoint pour afficher les alertes et résoudre les problèmes.

  • Mettre à jour les alertes à l'aide de Windows PowerShell (SharePoint Foundation 2010) - Cet article explique comment ajouter une fonction avancée qui vous permet de mettre à jour des alertes lorsque l'URL d'une application Web change.

Voir aussi

Concepts

Analyse d'intégrité (SharePoint Foundation 2010)

Historique des modifications


Affichage et résolution des alertes de l'analyseur d'intégrité SharePoint (SharePoint Foundation 2010)

SharePoint Foundation 2010 inclut un nouvel outil appelé Analyseur d'intégrité SharePoint, qui vous permet de diagnostiquer et de résoudre des problèmes de configuration, de performance et d'utilisation. L'Analyseur d'intégrité SharePoint exécute des règles d'intégrité prédéfinies sur les serveurs de la batterie. Une règle d'intégrité exécute un test et renvoie une alerte qui vous informe sur le résultat du test. Vous pouvez utiliser l'Administration centrale pour afficher les alertes et résoudre les problèmes.

Affichage et résolution des alertes de l'analyseur d'intégrité SharePoint

Vous pouvez utiliser l'Administration centrale pour afficher et résoudre les alertes d'intégrité.

Pour afficher et résoudre les alertes de l'analyseur d'intégrité SharePoint à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Analyseur d'intégrité, cliquez sur Examiner les problèmes et solutions.

  4. Dans la page Examiner les problèmes et solutions, cliquez sur l'alerte à afficher et à résoudre.

  5. Pour résoudre le problème, suivez l'aide fournie dans la section Solution de la boîte de dialogue Examiner les problèmes et solutions. Gardez la boîte de dialogue ouverte afin de pouvoir réexécuter la règle pour vérifier la résolution.

  6. Après avoir suivi l'aide fournie dans la section Solution, dans la boîte de dialogue Examiner les problèmes et solutions associée à l'alerte, cliquez sur Réanalyser maintenant pour vérifier la résolution. Si le problème est résolu, le statut de l'alerte passe à 4-Réussite.

Champs des alertes d'intégrité

Les champs des alertes sont décrits dans le tableau suivant.

Champ | Signification
Titre | Nom de l'alerte. Par défaut, il s'agit du nom de la règle d'intégrité qui a généré l'alerte.
Gravité | Les valeurs possibles sont les suivantes : 1-Erreur, 2-Avertissement, 3-Informations, 4-Réussite, 0-Échec de l'exécution de la règle.
Catégorie | Les valeurs prédéfinies sont les suivantes : Configuration, Sécurité, Performances et Disponibilité. Vous pouvez également taper une valeur dans la zone Spécifiez votre valeur.
Explication | Explication détaillée de la cause de l'alerte. Cette explication peut inclure des informations sur une exception ou sur un suivi.
Solution | Détails sur la procédure à suivre pour résoudre le problème à l'origine de l'alerte. Cette procédure peut inclure des étapes précises ou un lien vers des informations complémentaires.
Échec des serveurs | Serveur sur lequel l'échec s'est produit.
Échec des services | Service sur lequel l'échec s'est produit.
Paramètres de règle | Lien vers la règle d'intégrité qui a généré l'alerte. Les informations dans la règle peuvent s'avérer utiles pour l'analyse du problème, mais vous pouvez aussi modifier la planification ou désactiver la règle.
Version [lecture seule] | Ce numéro est automatiquement incrémenté à chaque modification de l'alerte.
Créé le (heure) [lecture seule] | Date et heure auxquelles l'alerte a été générée et compte de sécurité de domaine ou local sous lequel l'alerte a été générée.
Dernière modification le (heure) [lecture seule] | Date et heure de la dernière modification de l'alerte et compte de sécurité de domaine ou local sous lequel l'alerte a été modifiée. Ces informations peuvent s'avérer utiles pour le suivi des modifications apportées à l'alerte, par exemple pendant la résolution du problème

Historique des modifications


Mettre à jour les alertes à l'aide de Windows PowerShell (SharePoint Foundation 2010)
Voir aussi

Cet article décrit Invoke-AlertFixup, une fonction Windows PowerShell avancée servant à mettre à jour l'URL (Uniform Resource Locator) d'une application Web utilisée dans les messages électroniques d'alerte après qu'une application Web a changé d'adresse. Elle remplace l'opération Stsadm updatealert qui était disponible dans la version d'avril 2008 de la Boîte à outils d'administration SharePoint. Le chargement de cette fonction avancée s'effectue en exécutant un script du même nom.

Pour plus d'informations sur les fonctions avancées, voir about_Functions_Advanced (http://go.microsoft.com/fwlink/?linkid=196720&clcid=0x40C).

Pour mettre à jour des URL à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante :

    • Voir Add-SPShellAdmin.

    • Vous devez consulter la page about_Execution_Policies (http://go.microsoft.com/fwlink/?linkid=193050&clcid=0x40C).

  2. Copiez le code à partir du Centre de script (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=196687&clcid=0x40C), puis collez-le dans un éditeur de texte, tel que le Bloc-notes.

  3. Enregistrez le fichier et nommez-le Invoke-AlertFixup.ps1.

    Remarque :
    Vous devez utiliser le nom fourni, sinon le script échouera, et vous devez enregistrer le fichier en tant que fichier texte codé au format ANSI.

  4. Dans le menu Démarrer, cliquez sur Tous les programmes.

  5. Cliquez sur Produits Microsoft SharePoint 2010.

  6. Cliquez sur SharePoint 2010 Management Shell.

  7. Accédez au répertoire où vous avez enregistré le fichier.

  8. Depuis l'invite de commandes Windows PowerShell, tapez le texte suivant :

    Code de copie
    ./Invoke-AlertFixup.ps1

    Ce script contient la fonction avancée Invoke-AlertFixup. Une fois le script chargé en mémoire pour la session Windows PowerShell en cours, Invoke-AlertFixup peut être utilisée comme une applet de commande Windows PowerShell, par exemple de la manière suivante :

    Code de copie
    Invoke-AlertFixup -site <NewURL> -oldurl <OldURL>
    Remarque :
    Pour que Invoke-AlertFixup fonctionne correctement, les URL spécifiées avec les paramètres site et oldurl doivent résider dans la même collection de sites. Ceci est nécessaire afin de permettre la mise à jour correcte des alertes dans une zone spécifique. Les alertes de chaque zone doivent être mises à jour individuellement à l'aide de l'URL de nouvelle zone correcte.

  9. Pour afficher toutes les alertes qui seraient mises à jour à l'aide de la commande Invoke-AlertFixup, à l'invite de commandes Windows PowerShell, tapez la syntaxe suivante :

    Code de copie
    Invoke-AlertFixup -site <NewURL> -Oldurl <OldURL> -whatif

Exemple

Votre société possède une application Web configurée avec trois zones, comme indiqué dans le tableau suivant.

Mappage de zones de Coho Winery

Description | URL | Zone
Intranet | http://cohowinery | Par défaut
Extranet | http://extranet.cohowinery.com | Extranet
Fournisseur | http://vendors.cohowinery.com | Personnalisée

Votre société fusionne avec Coho Vineyard et adopte le nom Coho Winery and Vineyard. Le personnel de direction souhaite modifier les zones Intranet et Extranet de façon à refléter ce changement de nom. Le tableau suivant montre la nouvelle configuration des zones.

Mappage de zones de Coho Winery and Vineyard

Description | URL | Zone
Intranet | http://cohovineyardandwinery | Par défaut
Extranet | http://extranet.cohovineyardandwinery.com | Extranet

Une fois le nom de l'application Web modifiée et les mappages des accès de substitution mis à jour, vous devez exécuter Invoke-AlertFixup afin de mettre à jour les alertes par courrier électronique associées aux sites intranet et extranet de la manière suivante :

Code de copie
Invoke-AlertFixup -site http://cohovineyardandwinery -oldurl http://cohowinery
Code de copie
Invoke-AlertFixup -site http://extranet.cohovineyardandwinery.com -oldurl http://extranet.cohowinery.com
Remarque :
Aucune modification n'est apportée au site de fournisseur, car Coho Winery a décidé de ne pas modifier le nom du portail de fournisseur.

Voir aussi

Autres ressources

Exécution de scripts Windows PowerShell (éventuellement en anglais)

Historique des modifications

Date | Description | Raison
15 juillet 2010 | Publication initiale |


Surveiller l'intégrité et les performances d'un environnement virtuel (SharePoint Foundation 2010)

Cet article décrit l'analyse requise pour un environnement virtuel. Il est nécessaire d'analyser les ordinateurs virtuels dans la batterie et les serveurs de virtualisation afin de s'assurer que les niveaux d'intégrité et de performances répondent aux normes opérationnelles et aux contrats de niveau de service en vigueur.

Analyser l'intégrité et les performances de SharePoint

Les articles suivants fournissent des informations concernant l'analyse de l'intégrité et des performances de Microsoft SharePoint Foundation 2010 :

  • Analyse d'intégrité (SharePoint Foundation 2010)

Analyser l'intégrité et les performances d'Hyper-V

Vous pouvez analyser l'intégrité et les performances des serveurs Technologie Hyper-V de Windows Server 2008 à l'aide de produits Microsoft ou de scripts Windows PowerShell. Les produits suivants peuvent servir à l'analyse d'un environnement virtuel.

Microsoft System Center Operations Manager 2007 R2 fournit un système d'analyse et de création de rapport de bout en bout auquel vous pouvez faire appel pour l'analyse de Microsoft SharePoint Foundation 2010 et des versions prises en charge de Windows Server 2008 et SQL Server. Pour plus d'informations, voir System Center Operations Manager (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187743&clcid=0x40C).

Si vous utilisez System Center Operations Manager, nous vous recommandons d'obtenir et d'installer les packs de gestion suivants en fonction de votre environnement :

  • Pack d'administration de Windows Server Hyper-V pour System Center Operations Manager 2007 (http://go.microsoft.com/fwlink/?linkid=187744&clcid=0x40C)

  • Pack d'administration de clustering avec basculement Microsoft Windows Server pour Operations Manager 2007 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=147087&clcid=0x40C)

  • Pack d'administration de System Center Virtual Machine Manager 2008 pour System Center Operations Manager 2007 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=156500&clcid=0x40C)

Microsoft System Center Virtual Machine Manager 2008 R (SCVMM) est un outil robuste pour la gestion de tous les aspects d'un environnement virtuel Hyper-V. Outre l'approvisionnement virtuel, PRO (Performance and Resource Optimization) autorise la gestion dynamique des ressources virtuelles par le biais de Packs d'administration compatibles avec PRO. SCVMM peut tirer parti des fonctionnalités d'analyse offertes par System Center Operations Manager 2007, ce qui permet aux administrateurs d'établir des actions correctives pouvant être exécutées par VMM en cas d'identification de médiocres performances ou de défaillances matérielles imminentes au niveau du matériel, du système d'exploitation ou des applications. Il est également possible d'obtenir l'intégrité et l'état actuels des ordinateurs virtuels, ainsi qu'un affichage en temps réel de la consommation de processeur, de mémoire et de stockage sur les serveurs de virtualisation.

Remarque :
System Center Virtual Machine Manager prend totalement en charge les scripts Windows PowerShell.

Ressources d'intégrité et de performances

De nombreux articles et messages de blogs fournissent des conseils détaillés pour l'analyse de l'intégrité et des performances d'Hyper-V. Nous vous recommandons de consulter les ressources suivantes :

  • FAQ R2 sur les performances d'Hyper-V (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187745&clcid=0x40C)

  • Analyse des performances d'Hyper-V (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187746&clcid=0x40C)

  • Comparaison des performances d'Hyper-V : Microsoft Windows Server 2008 SP2 et R2 avec serveurs basés sur les processeurs Intel Xeon X5570 et E5450 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187747&clcid=0x40C)

  • Livre blanc sur les performances de disques durs virtuels de Windows Server 2008 R2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187749&clcid=0x40C)

  • Blog de l'équipe de performances Windows Server : Accroître les tailles des tampons VMBus afin d'augmenter le débit réseau vers les ordinateurs virtuels invités (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187750&clcid=0x40C)

  • Comparaison des performances IDE et SCSI dans Microsoft Hyper-V 2008 R2 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187751&clcid=0x40C)

  • Banc d'essaie d'Hyper-V sur Windows Server 2008 R2 x64 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187752&clcid=0x40C)

  • Blog technique de Henk : Archive pour la catégorie « SQL 2008 R2 » (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187753&clcid=0x40C)

Historique des modifications


Gérer les paramètres d'administration de batterie de serveurs (SharePoint Foundation 2010)

Après l'installation initiale de Microsoft SharePoint Foundation 2010, vous pouvez configurer les paramètres de batterie de serveurs par défaut. Bien que la configuration de ces paramètres soit facultative, certaines fonctionnalités clés ne sont pas disponibles tant que ces paramètres ne sont pas configurés.

Dans cette section :

  • Configurer la journalisation des diagnostics (SharePoint Foundation 2010)

    Cet article explique comment configurer des paramètres de journalisation des diagnostics après le déploiement ou la mise à niveau initiale, puis répertorie des conseils de mise en œuvre des meilleures pratiques pour l'environnement spécifique.

  • Intégration de la messagerie (SharePoint Foundation 2010)

    Cet article explique comment configurer les paramètres relatifs au courrier électronique entrant et sortant.

  • Configurer un compte mobile (SharePoint Foundation 2010)

    Cet article explique comment configurer et gérer un compte mobile pour permettre aux utilisateurs de s'abonner aux alertes envoyées via le protocole SMS (Short Message Service).

  • Modifier le numéro de port du site Web Administration centrale (SharePoint Foundation 2010)

    Durant l'installation de Microsoft SharePoint Foundation 2010, le site Web Administration centrale est établi sur un port TCP affecté de manière aléatoire, ou sur un port que vous avez sélectionné lors de la création de la batterie de serveurs. Cet article explique comment modifier le numéro de port du site Web Administration centrale.

Historique des modifications


Modifier le numéro de port du site Web Administration centrale (SharePoint Foundation 2010)
Voir aussi

Durant l'installation de Microsoft SharePoint Foundation 2010, le site Web Administration centrale est établi sur un port TCP affecté de manière aléatoire, ou sur un port que vous avez sélectionné lors de la création de la batterie de serveurs. Les stratégies de sécurité de votre organisation peuvent vous obliger à modifier le numéro de port.

Cette procédure explique comment modifier le numéro de port du site Web Administration centrale à l'aide d'une applet de commande Windows PowerShell 2.0. Vous ne pouvez pas vous servir de l'interface utilisateur pour effectuer cette tâche.

Pour modifier le numéro de port du site Web Administration centrale à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin. En outre, vérifiez que vous êtes membre du groupe SharePoint Administrateurs de batterie de serveurs.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPCentralAdministration -Port <PortNumber>

    Où <PortNumber> est le numéro de port que vous voulez utiliser. Vous êtes invité à confirmer la modification du numéro de port, sauf si vous utilisez le paramètre Confirm:$false avec la commande.

    Remarque :
    L'applet de commande Set-SPCentralAdministration bloque les ports suivants :

    • Avant le port 1023

    • Au-delà du port 32767

    • 443 (SSL)

    Si vous devez utiliser un port bloqué, vous pouvez le faire à l'aide de la commande Stsadm stsadm -o setadminport. Pour plus d'informations, voir Setadminport : opération Stsadm (Windows SharePoint Services).

Pour plus d'informations sur l'applet de commande Windows PowerShell, voir Set-SPCentralAdministration.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Référence

New-SPCentralAdministration

Historique des modifications


Gestion de la topologie de batteries (SharePoint Foundation 2010)

Ce chapitre explique comment ajouter des serveurs à une batterie de serveurs, comment renommer des serveurs et comment supprimer des serveurs d'une batterie.

Il existe des exemples de topologie que vous pouvez utiliser comme modèle pour créer une batterie de serveurs. Pour plus d'informations, voir le modèle Topologies pour SharePoint Server 2010 dans l'article Diagrammes techniques (SharePoint Foundation 2010).

La gestion de la topologie d'une batterie de serveurs comprend les tâches suivantes :

  1. Ajouter un serveur Web ou un serveur d'applications à la batterie (SharePoint Foundation 2010)

    Cet article explique comment ajouter des serveurs Web à une batterie de serveurs.

  2. Ajouter un serveur de bases de données à une batterie existante (SharePoint Foundation 2010)

    Cet article explique comment ajouter un serveur de base de données à une batterie de serveurs.

  3. Renommer un serveur autonome (SharePoint Foundation 2010)

    Cet article explique comment renommer un serveur autonome.

  4. Supprimer un serveur de la batterie (SharePoint Foundation 2010)

    Cet article explique comment retirer un serveur d'une batterie de serveurs.

Historique des modifications


Ajouter un serveur Web ou un serveur d'applications à la batterie (SharePoint Foundation 2010)

Cet article indique comment ajouter un serveur à une batterie de serveurs Microsoft SharePoint Foundation 2010 existante de telle sorte que le serveur puisse ultérieurement être configuré pour être utilisé comme serveur Web frontal ou comme serveur d'applications. Les procédures présentées dans cet article s'appliquent à une batterie de serveurs SharePoint Foundation 2010 comportant au moins deux couches ; elles ne sont pas destinées à la conversion d'un déploiement à serveur unique en une batterie de plusieurs serveurs.

Dans cet article :

  • Préparation

  • Logiciels nécessaires à l'installation

  • Installer le logiciel SharePoint

  • Ajouter le serveur à la batterie

  • Configurer le nouveau serveur

Préparation

Une planification et une préparation sont requises avant l'ajout d'un serveur à la batterie. Plusieurs tâches font partie de la planification et de la préparation. La première tâche consiste à déterminer le rôle qu'aura le nouveau serveur dans la batterie. Une fois cette tâche effectuée, vous devrez exécuter plusieurs autres tâches avant de commencer l'installation du logiciel sur le nouveau serveur.

Déterminer le rôle du serveur

Pour ajouter un nouveau serveur à la batterie de serveurs, vous devez connaître son rôle prévu afin de planifier une configuration supplémentaire ou spécialisée mais aussi pour évaluer l'impact potentiel de l'ajout du serveur dans un environnement de production.

Remarque :
Une batterie classique à trois couches comporte des serveurs Web frontaux, un serveur d'applications qui héberge également l'Administration centrale et un serveur de bases de données. Le cadre de cet article se limite aux rôles de serveur Web frontal et de serveur d'applications.

Une fois que vous avez déterminé le rôle que prendra le serveur dans votre topologie de batterie, vous devez identifier les services et les fonctionnalités devant être configurés pour que le serveur remplisse ce rôle. Cette information déterminera comment SharePoint Foundation 2010 est configuré pour mettre en service le serveur pour son rôle dans la couche Web ou la couche applications. Pour plus d'informations, voir Gérer les applications de service et les services (SharePoint Foundation 2010).

L'illustration suivante montre une batterie SharePoint Foundation 2010 comportant deux serveurs Web frontaux (Web-1 et Web-2) qui servent du contenu. Le seul et unique serveur d'applications (App-1) héberge l'Administration centrale pour la batterie.

Options pour l'ajout d'un serveur à une batterie

Batterie de serveurs SharePoint Foundation 2010 : Ajouter un serveur

Les sections suivantes fournissent des informations sur les caractéristiques générales des rôles de serveur Web frontal et de serveur d'applications.

Rôle du serveur Web frontal

Le rôle fondamental d'un serveur Web frontal est d'héberger les pages Web, les services Web et les composants WebPart nécessaires pour traiter les demandes reçues des utilisateurs. Le serveur Web dirige ces demandes au serveur d'applications, lequel renvoie les résultats au serveur Web frontal.

Selon les exigences de la batterie de serveurs, le serveur Web frontal peut également être configuré pour prendre en charge la recherche en l'absence de serveurs de recherche dédiés.

Remarque :
La distribution de la recherche n'est pas possible pour SharePoint Foundation 2010, où une seule instance de recherche est autorisée pour chaque base de données de contenu.

Dans une batterie SharePoint Foundation 2010 vous pouvez étendre la couche Web en ajoutant un serveur Web frontal ; correspondant à l'option A dans l'illustration précédente. L'ajout d'un troisième serveur améliore l'équilibre de charge et augmente la disponibilité du serveur Web frontal. Un déploiement à trois serveurs sur la couche Web est qualifié de batterie étirée.

Rôle de serveur d'applications

Dans une batterie de serveurs à trois niveaux, le serveur qui héberge l'Administration centrale est un serveur d'applications par défaut. Vous pouvez ajouter des serveurs Web pour héberger des services pouvant être déployés sur un serveur unique et employés par tous les serveurs d'une batterie.

Dans l'illustration de la batterie SharePoint Foundation 2010, l'option B consiste à configurer le nouveau serveur avec Administration centrale de façon à pouvoir ajouter de la redondance à la batterie. L'option C montre des options supplémentaires, comme l'hébergement de travaux de minuteur ou du service de code en mode bac à sable.

Tâches supplémentaires

Avant de commencer à installer les logiciels requis sur le serveur, prenez les mesures suivantes :

  • Vérifiez que le serveur dispose de la configuration matérielle et logicielle requise décrite dans Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

    Remarque :
    En guise de meilleure pratique, nous recommandons que le système d'exploitation sur le nouveau serveur soit au même niveau de Service Pack et dispose des mêmes mises à jour de sécurité et autres correctifs que les serveurs existants de la batterie de batterie.

  • Vérifiez que vous avez le niveau minimal d'autorisation requis pour installer et configurer sur le nouveau serveur. Vous devez être membre du groupe SharePoint Administrateurs de batterie et du groupe Administrateurs sur l'ordinateur serveur local pour exécuter des procédures dans cet article. Pour plus d'informations, voir Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010).

  • Vérifiez que vous connaissez le nom du serveur de bases de données que la batterie à laquelle vous vous connectez utilise, ainsi que le nom de la base de données de configuration si vous ajoutez le serveur à l'aide de des commandes Windows PowerShell.

  • Si vous prévoyez d'utiliser des commandes Windows PowerShell pour ajouter le serveur, vérifiez que vous disposez de la configuration minimale suivante : vous êtes membre du rôle SharePoint_Shell_Access sur la base de données de configuration et membre du groupe local WSS_ADMIN_WPG sur l'ordinateur où les produits SharePoint 2010 sont installés.

  • Documentez l'emplacement des fichiers binaires et journaux de SharePoint Foundation 2010 sur les serveurs de batterie existants. Nous recommandons que l'emplacement de ces fichiers sur le nouveau serveur corresponde à celui utilisé sur les autres serveurs de la batterie. Pour plus d'informations, voir Configurer la journalisation des diagnostics (SharePoint Foundation 2010).

    Important :
    Si vous modifiez le chemin d'accès du journal de suivi en faveur d'un lecteur non-système, cet emplacement doit exister sur tous les serveurs de la batterie de serveurs. Les serveurs existants ou nouveaux ne peuvent pas journaliser des données si l'emplacement n'existe pas. En outre, vous ne pourrez ajouter de nouveaux serveurs que si le chemin d'accès que vous spécifiez existe sur ceux-ci. Vous ne pouvez pas utiliser un partage réseau à des fins de journalisation.

Installer le logiciel requis

Avant que vous puissiez installer SharePoint Foundation 2010 et ajouter un serveur à la batterie de serveurs, vous devez vérifier et installer tous les logiciels requis sur le nouveau serveur. Cette opération s'effectue à l'aide de l'Outil de préparation de SharePoint Foundation 2010, qui nécessite une connexion Internet pour télécharger et configurer la configuration requise de SharePoint Foundation 2010. Si vous n'avez pas de connexion Internet pour les serveurs de la batterie, vous pouvez quand même utiliser l'outil pour déterminer quel logiciel est requis. Vous devrez obtenir des images installables pour le logiciel requis. Pour les emplacements d'installation, voir Configuration logicielle requise dans « Déterminer la configuration matérielle et logicielle requise (SharePoint Foundation 2010) ».

Conseil :
Une fois que vous avez obtenu une copie du logiciel requis, nous vous recommandons de créer un point d'installation que vous pouvez utiliser pour stocker les images. Vous pouvez utiliser ce point d'installation pour l'installation de futures mises à jour de logiciels.

Pour des instructions détaillées sur l'installation des composants requis, voir « Préparer les serveurs de batterie » dans l'article Plusieurs serveurs en batterie à trois niveaux (SharePoint Foundation 2010).

Installer le logiciel des produits SharePoint

Une fois que tous les composants requis ont été installés, procédez comme suit pour installer SharePoint Foundation 2010 sur le nouveau serveur. Pour des instructions détaillées sur l'installation de SharePoint Foundation 2010, voir Déployer un serveur unique avec SQL Server (SharePoint Foundation 2010).

Pour installer SharePoint

  1. À partir du média du produit ou d'un partage de fichiers contenant les fichiers d'installation des produits SharePoint Foundation 2010, exécutez Setup.exe.

  2. Dans la page de démarrage, cliquez sur le lien pour installer SharePoint Foundation 2010.

  3. Vérifiez et acceptez les termes du contrat de licence Microsoft.

  4. Sélectionnez une installation de batterie de serveurs, puis sélectionnez une installation complète.

    Remarque :
    Vous pouvez choisir d'installer uniquement les composants requis pour un serveur Web frontal. Cependant, avec une installation complète vous disposez d'une plus grande flexibilité pour éventuellement modifier ultérieurement le rôle du serveur dans la batterie.

  5. Acceptez l'emplacement par défaut où SharePoint Foundation 2010 sera installé ou modifiez le chemin d'installation en fonction de vos besoins.

    Remarque :
    En guise de meilleure pratique, il est recommandé d'installer SharePoint Foundation 2010 sur un lecteur non-système.

  6. Lorsque l'installation se termine, une boîte de dialogue vous invite à effectuer la configuration de votre serveur en exécutant l'Assistant Configuration des produits SharePoint. Vous pouvez démarrer l'assistant immédiatement ou ultérieurement à partir de l'invite de commandes de Windows.

Ajouter le serveur à la batterie

Vous pouvez ajouter un serveur à la batterie à l'aide de l'interface utilisateur de SharePoint Foundation 2010 ou avec Windows PowerShell. Les deux approches sont décrites dans les procédures suivantes :

  • Ajouter un serveur à l'aide de l'interface utilisateur

  • Ajouter un serveur à l'aide de Windows PowerShell

Pour ajouter le serveur à la batterie à l'aide de l'Assistant Configuration, procédez comme suit.

Pour ajouter un serveur à l'aide de l'interface utilisateur

  1. Sur le nouveau serveur, cliquez sur Démarrer, pointez sur Tous les programmes, puis cliquez sur Assistant Configuration des produits Microsoft SharePoint 2010.

  2. Dans la page d'accueil des produits SharePoint, cliquez sur Suivant.

  3. Dans la page Se connecter à une batterie de serveurs, cliquez sur Se connecter à une batterie de serveurs existante.

  4. Cliquez sur Suivant.

  5. Dans la page Spécifier les paramètres de la base de données de configuration, tapez le nom de l'instance de SQL Server dans la zone Serveur de bases de données, puis cliquez sur Récupérer les noms de bases de données.

  6. Sélectionnez le nom de la base de données de configuration dans la liste Nom de la base de données, puis cliquez sur Suivant.

  7. Dans la page Spécifier les paramètres de sécurité de la batterie de serveurs, tapez le mot de passe de la batterie de serveurs dans la zone Mot de passe, puis cliquez sur Suivant.

  8. Dans la page Fin de l'Assistant Configuration des produits SharePoint, cliquez sur Suivant.

  9. Sur le serveur qui héberge l'Administration centrale, cliquez sur Gérer les serveurs de cette batterie pour vérifier que le nouveau serveur fait partie de la batterie.

    Remarque :
    Vous pouvez également vérifier que l'ajout du serveur a réussi, ou dépanner un échec d'ajout en examinant les fichiers journaux. Ces fichiers journaux se trouvent sur les lecteurs où SharePoint Foundation 2010 est installé, dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\LOGS. Pour plus d'informations, voir Analyse d'intégrité (SharePoint Foundation 2010).

  10. Dans la page Serveurs de la batterie, cliquez sur le nom du nouveau serveur. Utilisez la liste des services disponibles dans la page Services sur le serveur pour démarrer les services que vous souhaitez exécuter sur le nouveau serveur.

  11. Configurez SharePoint Foundation 2010 de telle sorte que le nouveau serveur puisse remplir le rôle qui lui est destiné. Pour plus d'informations, voir Configurer le nouveau serveur.

Avant de commencer à ajouter le serveur à l'aide de la procédure Windows PowerShell suivante, installez SharePoint Foundation 2010 à l'aide du programme d'installation.

Pour ajouter un serveur à l'aide de Windows PowerShell

  1. Dans le menu Démarrer, cliquez sur Tous les programmes.

  2. Cliquez sur SharePoint 2010 Management Shell. À ce stade, vous pouvez soumettre les commandes suivantes pour ajouter le serveur à la batterie.

  3. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour connecter le serveur à une base de données de configuration :

    Code de copie
    ConnectSPConfigurationDatabase -DatabaseServer "<$DatabaseServer>" -DatabaseName "<$RunSettings.ConfigurationDatabaseName>" -Passphrase "<$Passphrase>"

    Où :

    • <$DatabaseServer> est le nom du serveur qui héberge la base de données de configuration

    • <$RunSettings.ConfigurationDatabaseName> est le nom de la base de données de configuration

    • <$Passphrase> est la phrase secrète pour la batterie

  4. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour installer les collections de fichiers d'aide :

    Code de copie
    Install-SPHelpCollection -All

  5. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour installer la ressource de sécurité pour SharePoint :

    Code de copie
    Initialize-SPResourceSecurity

  6. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour installer les services de base :

    Code de copie
    Install-SPService

  7. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour installer toutes les fonctionnalités :

    Code de copie
    Install-SPFeature -AllExistingFeatures

  8. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour installer le contenu de l'application :

    Code de copie
    Install-SPApplicationContent

  9. À l'invite de commandes de Windows PowerShell, tapez la commande suivante pour obtenir la liste des serveurs de la batterie.

    Code de copie
    Get-SPFarm | select Servers
    Remarque :
    Vous pouvez également vérifier que l'ajout du serveur a réussi, ou dépanner un échec d'ajout en examinant les fichiers journaux. Ces fichiers journaux se trouvent sur les lecteurs où SharePoint Foundation 2010 est installé, dans le dossier %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14\LOGS. Pour plus d'informations, voir Analyse d'intégrité (SharePoint Foundation 2010).

  10. Configurez SharePoint Foundation 2010 de telle sorte que le nouveau serveur puisse remplir le rôle qui lui est destiné. Pour plus d'informations, voir Configurer le nouveau serveur.

Configurer le nouveau serveur

Le nouveau serveur n'a aucune fonctionnalité réelle dans la batterie tant que vous n'avez pas configuré les services qui sont requis pour prendre en charge le rôle que vous avez planifié pour le nouveau serveur. Pour plus d'informations, voir Configurer les services (SharePoint Foundation 2010).

Historique des modifications


Ajouter un serveur de bases de données à une batterie existante (SharePoint Foundation 2010)

Cet article fournit des informations sur l'ajout d'un nouveau serveur de bases de données à une batterie Microsoft SharePoint Foundation 2010 existante. Vous pouvez ajouter des serveurs de bases de données à tout moment en réponse à des conditions métiers ou d'exploitation. Comme le serveur de bases de données contient le contenu de la batterie qui peut être composé de divers types de données et regrouper une collection de documents à croissance rapide, la taille des bases de données de batterie peut augmenter rapidement. Bien que la capacité de stockage constitue un facteur clé créant la nécessité d'ajouter des serveurs de bases de données supplémentaires, d'autres facteurs ajoutent de nouvelles fonctionnalités, des performances et la haute disponibilité.

Remarque :
Dans le cas de la haute disponibilité, la procédure est généralement intégrée dans la conception et le déploiement initial de la topologie de la batterie et n'est pas couverte dans cet article. Pour plus d'informations sur la haute disponibilité pour Microsoft SQL Server 2008, voir Vue d'ensemble des solutions à haute disponibilité (http://go.microsoft.com/fwlink/?linkid=188016&clcid=0x40C).

Dans la plupart des cas, pour ajouter un serveur de bases de données à une batterie SharePoint Foundation 2010 existante il suffit d'installer et de configurer un nouveau serveur de bases de données, et de le joindre à la batterie en faisant référence au nouveau serveur lorsque vous ajoutez une fonctionnalité ou transférez un contenu de base de données de l'ancien serveur au nouveau. SharePoint Foundation 2010 alloue et affecte automatiquement de nouvelles ressources de base de données en fonction des besoins.

Dans cet article :

  • Préparer le nouveau serveur de bases de données

  • Configurer et utiliser le nouveau serveur de bases de données

Préparer le nouveau serveur de bases de données

Avant que vous puissiez utiliser le nouveau serveur de bases de données, vous devez le préparer afin qu'il puisse être utilisé dans une batterie Microsoft SharePoint Foundation. Pour mettre en service le nouveau serveur, procédez comme suit.

Important :
La stratégie informatique peut imposer l'exécution de la totalité ou d'une partie des étapes indiquées dans ces procédures par un administrateur de base de données. Avant de commencer une des procédures suivantes, assurez-vous que vous respectez les exigences définies par la stratégie informatique de votre société.

Pour mettre en service le serveur de bases de données

  1. Révisez Configuration matérielle et logicielle requise (SharePoint Foundation 2010)

  2. Installez le système d'exploitation, en vous assurant que :

    • La configuration des lecteurs est la même que celle du serveur existant.

    • Le système d'exploitation est mis à jour au même Service Pack ou niveau de correctif que le serveur existant.

  3. Installez la même version de SQL Server que celle qui est installée sur le serveur de bases de données de batterie existant. Les procédures dans cet article visent à vous montrer comment configurer un nouveau serveur de bases de données pour une tâche spécifique dans SharePoint Foundation 2010.

    Pour plus d'informations sur l'installation et la configuration de SQL Server avant de l'ajouter à une batterie de serveurs existante, voir la documentation d'installation de SQL Server.

  4. Configurez SQL Server, en vérifiant les points suivants :

    • Le classement de base de données est LATIN1_General_CI_AS_KS_WS.

    • Il faut au minimum être membre du rôle de serveur fixe de base de données SQL Serverdbcreator et du groupe SharePoint Administrateurs de batterie pour exécuter les procédures de cet article.

    • Un compte de connexion est créé pour le compte d'utilisateur du programme d'installation de SharePoint Foundation. Ce compte sera le propriétaire de la nouvelle base de données.

  5. Installez le même Service Packs et correctifs SQL Server que ceux installés sur le serveur de bases de données existant.

Configurer et utiliser le nouveau serveur de bases de données

Utilisez les procédures suivantes comme guide pour la configuration d'un nouveau serveur de bases de données devant héberger des bases de données SharePoint Foundation 2010 spécifiques. Cela inclut notamment :

  • Création d'une nouvelle application Web

  • Transfert d'une collection de sites sur le nouveau serveur

Vous pouvez utiliser l'Administration centrale ou Windows PowerShell pour créer une nouvelle application Web ; cependant, vous devez utiliser Windows PowerShell pour transférer une collection de sites.

Pour créer une nouvelle application Web

  1. Vérifiez que vous avez les informations d'identification appropriées sur la batterie de serveurs SharePoint Foundation et sur SQL Server.

  2. Utilisez la page Gestion des applications du site Web Administration centrale pour créer un nouveau site Web.

  3. Configurez l'authentification en mode classique (authentification Windows) ou l'authentification par revendications.

  4. Configurez IIS pour utiliser le site Web existant ou pour créer un nouveau site Web et configurez les paramètres suivants :

    • Spécifiez le numéro de port que vous souhaitez utiliser pour accéder à l'application Web.

    • Fournissez l'URL que vous souhaitez utiliser pour accéder à l'application Web (facultatif).

    • Fournissez le chemin d'accès à l'annuaire de sites sur le serveur où le site Web est hébergé.

  5. Configurez l'authentification et le chiffrement pour votre site Web en utilisant les options suivantes.

    • Authentification Négocier (Kerberos) ou NTLM.

    • Accès anonyme au site Web

    • SSL (Secure Sockets Layer)

  6. Fournissez une adresse URL pour le nom de domaine de tous les sites auxquels les utilisateurs auront accès dans cette application Web.

  7. Utilisez le pool d'applications existant ou créez-en un.

  8. Configurez la sécurité du pool d'applications (prédéfinie ou configurable).

  9. Identifiez le serveur de bases de données, le nom de la base de données et la méthode d'authentification pour votre nouvelle application Web.

Pour des instructions détaillées, voir Créer une application Web (SharePoint Foundation 2010).

Pour déplacer une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.Vérifiez également que le compte de l'utilisateur a accès à l'un des serveurs sur lesquels Windows PowerShell 2.0 s'exécute, et que le compte d'utilisateur est un Administrateur de batterie et est membre du rôle SharePoint_Shell_Access pour la base de données de contenu source de SQL Server, la base de données de contenu d'administration, la base de données de contenu de destination et la base de données de configuration.

  2. Vérifiez que les conditions suivantes sont vraies :

    • La base de données de contenu de destination existe.

    • La base de données de contenu source et la base de données de contenu de destination résident sur la même instance de SQL Server.

    • La base de données de contenu source et la base de données de contenu de destination sont liées à la même application Web.

  3. Déterminez la taille de la collection de sites source et vérifiez que le disque dur de destination dispose d'un espace libre équivalant à au moins trois fois la capacité requise pour la collection de sites.

    Utilisez l'applet de commande Get-SPSiteAdministration pour déterminer la taille d'une collection de sites. Pour plus d'informations, voir Get-SPSiteAdministration.

  4. Utilisez les applets de commande Move-SPSite pour déplacer une collection de sites de la base de données de contenu source à la nouvelle base de données de contenu. Pour plus d'informations, voir Move-SPSite.

Pour des instructions détaillées, voir Déplacer des collections de sites entre des bases de données (SharePoint Foundation 2010).

Historique des modifications


Renommer un serveur autonome (SharePoint Foundation 2010)

Cet article décrit comment renommer un serveur autonome dans Microsoft SharePoint Foundation 2010. Si le serveur a été configuré de manière à utiliser des mappages des accès de substitution et d'autres personnalisations, vous devrez peut-être effectuer des étapes supplémentaires pour rendre tous les sites sur le serveur accessibles aux utilisateurs une fois le serveur renommé.

Par exemple, certaines images de pages Web peuvent utiliser des chemins d'accès ou des URL de fichier qui ne sont plus valides une fois le serveur renommé. Vous devez renommer ces chemins d'accès de fichier pour fournir un accès continu au contenu. Si vous avez configuré des alertes sur des applications Web qui utilisent des URL publiques, vérifiez ces alertes et modifiez les URL publiques de manière à ce qu'elles correspondent aux nouvelles URL publiques. Pour plus d'informations, voir Définir des chemins d'accès gérés (SharePoint Foundation 2010).

Pour renommer un serveur SharePoint Foundation 2010, procédez comme suit :

  1. Renommez le serveur au niveau du système d'exploitation en utilisant la boîte de dialogue Propriétés système du Panneau de configuration.

    Cet article ne fournit pas d'informations sur l'attribution d'un nouveau nom à l'ordinateur réel. Pour plus d'informations sur l'attribution d'un nouveau nom à l'ordinateur, voir la documentation de Windows Server.

  2. Redémarrez le serveur.

  3. Utilisez la procédure décrite dans cet article pour renommer le serveur dans SharePoint Foundation 2010.

  4. Exécutez iisreset.

  5. Mettez à jour les mappages de site Web selon les besoins pour assurer un accès continu à tous les sites.

Dans cet article :

  • Renommer un serveur autonome à l'aide de Windows PowerShell

  • Mettre à jour les mappages des accès aux sites

Renommer un serveur autonome à l'aide de Windows PowerShell

Pour renommer un serveur autonome SharePoint Foundation 2010, vous devez utiliser une applet de commande Windows PowerShell 2.0. Aucune option d'interface utilisateur n'est disponible pour cette action.

Pour renommer un serveur autonome à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Rename-SPServer [-Identity] <OriginalServerName> -Name <NewServerName>

    Où :

    • <OriginalServerName> est le nom d'origine du serveur autonome.

    • <NewServerName> est le nouveau nom du serveur autonome.

  6. Pour vous assurer que l'opération d'attribution d'un nouveau nom a réussi, exécutez iisreset /noforce à une invite de commandes Windows. Pour plus d'informations, voir Redémarrage des services Internet (IIS 6.0) (éventuellement en anglais).

Pour plus d'informations, voir Rename-SPServer.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Mettre à jour les mappages des accès aux sites

Pour vérifier que les URL publiques et internes fonctionnent avec le nouveau nom de serveur, vous devez examiner les paramètres de mappage des accès pour chaque application Web hébergée sur le serveur. Si des URL publiques ou internes utilisent le nom d'origine du serveur, vous devez les mettre à jour en conséquence. Si vous ne modifiez pas ces URL, les demandes de contenu des utilisateurs ne seront pas dirigées vers le serveur et les utilisateurs recevront une erreur « 404 » ou similaire.

Si l'URL de l'Administration centrale est affectée par l'attribution d'un nouveau nom au serveur, le site devient indisponible une fois le serveur renommé. Dans ce cas, vous devez modifier le mappage de l'Administration centrale à l'aide de Windows PowerShell 2.0. Pour plus d'informations, voir New-SPAlternateUrl.

Après avoir mis à jour l'URL du site Web Administration centrale, vous pouvez remapper d'autres applications Web à l'aide de l'applet de commande New-SPAlternateUrlWindows PowerShell 2.0 ou à l'aide de l'Administration centrale.

Si vous utilisez des mappages des accès de substitution pour des sites Web autres que l'Administration centrale, y compris des proxys inverses ou des équilibreurs de charge qui dépendent de ces URL, assurez-vous que ceux-ci sont également mis à jour avec le nouveau nom de serveur.

Historique des modifications


Supprimer un serveur de la batterie (SharePoint Foundation 2010)
Voir aussi

Il existe trois types de serveurs dans une batterie de serveurs Microsoft SharePoint Foundation 2010 : les serveurs Web, les serveurs d'applications et les serveurs de bases de données.

Vous pouvez supprimer un serveur Web ou un serveur d'applications de la batterie de serveurs en désinstallant SharePoint Foundation 2010 du serveur par le biais du Panneau de configuration.

Si un serveur Web ou un serveur d'applications n'est plus disponible, ou que vous êtes dans l'impossibilité de désinstaller SharePoint Foundation 2010 à partir du Panneau de configuration, vous pouvez supprimer le serveur Web ou le serveur d'applications de la batterie par l'intermédiaire du site Web Administration centrale de SharePoint. Nous vous recommandons fortement de suivre la procédure décrite dans Supprimer un serveur Web ou un serveur d'applications d'une batterie à l'aide du Panneau de configuration pour désinstaller SharePoint Foundation 2010 au lieu d'utiliser l'Administration centrale. Le fait de supprimer un serveur de la batterie de serveurs à l'aide de l'Administration centrale ne désinstalle pas SharePoint Foundation 2010 de ce serveur et ne rend pas les des sites de ce serveur inaccessibles. À l'inverse, lorsque vous désinstallez SharePoint Foundation 2010 à l'aide du Panneau de configuration, vous supprimez les fichiers programmes et d'autres informations du serveur. Le fait de supprimer le serveur de la batterie à l'aide de l'Administration centrale ne supprime pas ces informations du serveur. Utilisez uniquement la procédure associée à l'Administration centrale pour supprimer des serveurs de bases de données, ou pour supprimer un serveur Web ou un serveur d'applications de la batterie de serveurs lorsque le serveur ne peut plus être désinstallé par le biais du Panneau de configuration.

Pour supprimer un serveur de bases de données d'une batterie, vous devez d'abord déplacer toutes les bases de données hébergées par ce serveur vers un autre serveur de bases de données dans la batterie. Vous pouvez alors utiliser l'Administration centrale pour supprimer le serveur de bases de données.

Avant de supprimer un serveur de bases de données d'une batterie de serveurs, assurez-vous que vous avez bien déplacé toutes les bases de données stockées sur ce serveur vers un autre serveur de bases de données dans votre batterie.

Important :
Vous ne pouvez pas supprimer un serveur de bases de données s'il s'agit du seul serveur de bases de données disponible dans la batterie ou s'il héberge la base de données de configuration.

Vous devez au minimum être membre des groupes Administrateurs de batterie et Administrateurs sur l'ordinateur serveur local afin d'exécuter les procédures décrites dans cet article.

Dans cet article :

  • Supprimer un serveur Web ou un serveur d'applications d'une batterie à l'aide du Panneau de configuration

  • Supprimer n'importe quel type de serveur d'une batterie à l'aide de l'Administration centrale

Supprimer un serveur Web ou un serveur d'applications d'une batterie à l'aide du Panneau de configuration

Nous vous recommandons de suivre cette procédure pour supprimer les serveurs Web et les serveurs d'applications d'une batterie au lieu d'utiliser l'Administration centrale.

Attention :
Si vous désinstallez SharePoint Foundation 2010 du serveur exécutant l'Administration centrale, vous ne pourrez pas administrer la batterie de serveurs tant que vous n'aurez pas configuré un autre serveur dans la batterie pour héberger le site Administration centrale.

Assurez-vous que le serveur que vous voulez supprimer n'exécute aucun composant de site important. Si des services ou des composants importants (comme un composant WebPart personnalisé) s'exécutent sur le serveur et ne sont pas disponibles sur un autre serveur dans la batterie, le fait de supprimer le serveur peut endommager des sites dans la batterie. Par exemple, si le serveur que vous voulez supprimer est le seul serveur d'applications dans la batterie qui exécute le service Business Data Connectivity, la suppression du serveur peut entraver le bon fonctionnement des sites qui reposent sur ce service.

Avant de désinstaller un serveur, vous devez arrêter les services qui s'exécutent sur celui-ci. Pour plus d'informations sur l'identification des services qui s'exécutent sur un serveur spécifique et l'arrêt de services, voir Gérer les services sur le serveur (SharePoint Foundation 2010).

Pour supprimer un serveur Web ou un serveur d'applications d'une batterie à l'aide du Panneau de configuration

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe Administrateurs sur l'ordinateur serveur local.

  2. Sur le serveur que vous voulez supprimer de la batterie, cliquez sur Démarrer, sur Panneau de configuration, puis double-cliquez sur Programmes et fonctionnalités.

  3. Dans la liste des programmes actuellement installés, cliquez sur SharePoint Foundation 2010, puis sur Désinstaller.

  4. Cliquez sur Continuer à la demande de confirmation pour désinstaller le programme.

Supprimer n'importe quel type de serveur d'une batterie à l'aide de l'Administration centrale

Vous pouvez utiliser cette procédure pour supprimer un serveur Web, un serveur d'applications ou un serveur de bases de données de la batterie.

Pour supprimer n'importe quel type de serveur d'une batterie de serveurs à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Sur le site Web Administration centrale de SharePoint, dans la section Paramètres système, cliquez sur Gérer les serveurs de cette batterie.

  3. Dans la page Serveurs de la batterie, recherchez la ligne contenant le nom du serveur à supprimer, puis cliquez sur Supprimer le serveur.

  4. Dans l'avertissement qui apparaît, cliquez sur OK pour supprimer le serveur ou sur Annuler pour arrêter l'opération.

    La page est actualisée et le serveur que vous avez supprimé n'apparaît plus dans la liste des serveurs.

Voir aussi

Concepts

Administration de serveur et de batterie de serveurs (SharePoint Foundation 2010)
Gestion de la topologie de batteries (SharePoint Foundation 2010)

Historique des modifications


Migrate a farm deployed on a failover cluster environment (SharePoint Foundation 2010)

This article provides information that you can use for the migration of a Windows SharePoint Services 3.0 farm or a Microsoft SharePoint Foundation 2010 farm that is deployed in a failover cluster environment to another cluster.

Although SharePoint Foundation is not cluster-aware and we do not support clusters running SharePoint Foundation, we recognize that some organizations do implement failover clusters at the operating system or database levels.

In this article:

  • Migration strategy

  • Migration resources

Migration strategy

If the environment uses failover clustering at the operating system level or the database server level (or both), you must develop a migration strategy that ensures that the SharePoint Foundation 2010 farm is highly available and not compromised in any way (for example, lost data and corrupted configurations).

Remarque :
Because SharePoint Foundation 2010 only supports a 64-bit operating system and 64-bit database environment, any migration strategy has to include this requirement.

Migration is typically done in order to upgrade the following cluster elements:

  • Windows Server 2003 or Windows Server 2008 to Windows Server 2008 R2

  • Microsoft SQL Server 2005 to Microsoft SQL Server 2008

The migration strategy will be based on the cluster elements that you want to work with. If your farm environment uses an operating system cluster and a database server cluster, we recommend that you complete the operating system migration first.

clusters

In a failover cluster environment, the cluster exists as a named server in the farm. When you migrate to a new cluster, you have to complete the following tasks:

  1. Add the new cluster as a different registered name.

  2. Move all the services to the new server cluster.

  3. Remove the existing server cluster as a named farm server.

In a scenario where SQL Server is hosted on a cluster, database migration is fairly easy because you do not have to configure SQL Server connection strings.

clusters expose one or more virtual server names, WINS entries, and DNS entries. The new cluster can use a virtual server name, WINS entry, or DNS entry that is available after the identifier is no longer registered with the existing cluster. Services are migrated as described in the Migrate an existing server farm to a 64-bit environment (Office SharePoint Server 2007) (http://go.microsoft.com/fwlink/?LinkId=207555) article, which also applies to SharePoint Foundation 2010.

SQL Server clusters

In a SQL Server failover cluster environment, cluster migration is complex and involves more downtime than the migration of the operating system cluster. The challenges that a database server migration poses exist because SharePoint Foundation uses server names to reference SQL Server, other farm servers, and itself. This differs from a cluster, which uses virtual server names, WINS entries, and DNS entries.

Migration resources

The following resources are available to assist you with all aspects of cluster migration:

  • Migrating Clustered Services and Applications to Windows Server 2008 R2 Step-by-Step Guide (http://go.microsoft.com/fwlink/?LinkId=182155)

    This guide describes how to migrate clustered services and applications (formerly known as resource groups) to a failover cluster running Windows Server 2008 R2.

    Remarque :
    In a scenario where you are migrating from the 64-bit version of Windows Server 2003, you can use an in-place migration to upgrade the operating system to Windows Server 2008 R2. For more information, see In-Place Migration for a Two-Node Cluster (http://go.microsoft.com/fwlink/?LinkId=207557).

  • Migration Paths for Migrating to a Failover Cluster Running Windows Server 2008 R2 (http://go.microsoft.com/fwlink/?LinkId=182156)

    This article describes how to migrate or upgrade specific clustered services or applications to a cluster running Windows Server 2008 R2.

  • How to: Upgrade a SQL Server Failover Cluster Instance (Setup) (http://go.microsoft.com/fwlink/?LinkId=169111)

    This article describes how to upgrade an instance of a SQL Server failover cluster.

Historique des modifications

Date | Description | Raison
2010/12/13 | Publication initiale |


Configuration de la disponibilité (SharePoint Foundation 2010)
Voir aussi

Cette section explique comment configurer la disponibilité de Microsoft SharePoint Foundation 2010. Les articles ci-après supposent que vous soyez familier avec les concepts et termes présentés dans Planifier la disponibilité (SharePoint Foundation 2010).

Dans cette section :

  • Configurer la disponibilité à l'aide de la mise en cluster SQL Server (SharePoint Foundation 2010)

    Cet article explique comment utiliser la mise en cluster SQL Server avec SharePoint Foundation 2010.

  • Configurer la disponibilité à l'aide de la mise en miroir de base de données SQL Server (SharePoint Foundation 2010)

    Cet article explique comment configurer la mise en miroir de la base de données SQL pour être utilisée avec SharePoint Foundation 2010.

  • Exemple de script pour la configuration de la mise en miroir SQL Server (SharePoint Foundation 2010)

    Cet article fournit un script permettant de configurer la mise en miroir de la base de données SQL Server pour être utilisée avec SharePoint Foundation 2010 dans un environnement de test. Dans un environnement de production, nous recommandons de confier la mise en miroir à un spécialiste de base de données.

Voir aussi

Concepts

Planifier la disponibilité (SharePoint Foundation 2010)

Historique des modifications


Configurer la disponibilité à l'aide de la mise en cluster SQL Server (SharePoint Foundation 2010)

Le clustering avec basculement SQL Server 2008 avec SP1 et mise à jour cumulative 2 permet de configurer la disponibilité au sein d'une batterie de serveurs pour Microsoft SharePoint Foundation 2010. Cet article suppose que les concepts et les termes présentés dans Planifier la disponibilité (SharePoint Foundation 2010) vous sont familiers.

Le clustering avec basculement permet de gérer la disponibilité pour une instance de Microsoft SQL Server 2008 avec le Service Pack 1 (SP1) et mise à jour cumulative 2. Un cluster de basculement est une combinaison d'un ou plusieurs nœuds ou serveurs et d'au moins deux disques partagés. Si une instance de cluster de basculement se présente sous la forme d'un ordinateur unique, ses fonctionnalités assurent le basculement d'un nœud vers un autre si le nœud actif devient indisponible.

SharePoint Foundation 2010 fait référence au cluster dans son ensemble ; par conséquent, le basculement est automatique et transparent du point de vue de SharePoint Foundation 2010.

Pour plus d'informations sur le clustering avec basculement, voir Mise en route avec le clustering avec basculement de SQL Server 2008 (http://go.microsoft.com/fwlink/?linkid=102837&clcid=0x40C).

Il n'existe pas d'instructions spécifiques de configuration du clustering pour SharePoint Foundation 2010. Pour obtenir des instructions sur la configuration du clustering avec basculement, voir Installation d'un cluster de basculement SQL Server 2008 (http://go.microsoft.com/fwlink/?linkid=132112&clcid=0x40C).

Historique des modifications


Configurer la disponibilité à l'aide de la mise en miroir de base de données SQL Server (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment utiliser la mise en miroir de bases de données à haute disponibilité afin de configurer la disponibilité au sein d'une batterie de serveurs pour Microsoft SharePoint Foundation 2010. Vous êtes supposé connaître les concepts et les termes présentés dans Planifier la disponibilité (SharePoint Foundation 2010).

La mise en miroir de bases de données Microsoft SQL Server permet de gérer la disponibilité en envoyant les transactions directement d'une base de données et d'un serveur principaux vers une base de données et un serveur miroir lorsque la mémoire tampon du journal des transactions de la base de données principale est écrite sur disque. Pour la disponibilité au sein d'une batterie de serveurs Microsoft SharePoint Foundation 2010, vous utilisez la mise en miroir de bases de données à haute disponibilité, également connue sous le nom de mode haute sécurité avec basculement automatique. La mise en miroir de bases de données à haute disponibilité fait intervenir trois instances de serveurs : un principal, un miroir et un témoin. Le serveur témoin permet à SQL Server de basculer automatiquement du serveur principal vers le serveur miroir. Le basculement de la base de données principale vers la base de données miroir prend généralement plusieurs secondes.

Dans une batterie de serveurs SharePoint Foundation 2010, la mise en miroir permet d'assurer la redondance des bases de données de contenu et de configuration, ainsi que celle de nombreuses bases de données de service. Même si vos bases de données sont mises en miroir sur le même serveur, le basculement de chaque base de données intervient individuellement. La figure suivante illustre la façon dont la mise en miroir est configurée afin d'assurer la disponibilité au sein d'une batterie de serveurs SharePoint Foundation 2010.

Diagramme de mise en miroir de toutes les bases de données au sein d'une batterie de serveurs

SharePoint Foundation 2010 prend en charge la mise en miroir. Pour utiliser la mise en miroir dans votre environnement, commencez par configurer la mise en miroir, puis définissez la valeur de la base de données de basculement dans SharePoint Foundation.

Dans cet article :

  • Avant de commencer

  • Sécurité associée à la mise en miroir de bases de données

  • Configurer les produits SharePoint 2010 de sorte qu'ils prennent en charge les bases de données mises en miroir

  • Expérience utilisateur lors d'un basculement

Avant de commencer

Avant de commencer à configurer la mise en miroir, assurez-vous que votre administrateur de base de données a connaissance de la configuration requise et des topologies prises en charge.

Configuration requise pour la mise en miroir de bases de données

Prenez connaissance des recommandations dans la liste ci-dessous et vérifiez que vos bases de données et votre système sont conformes à la configuration requise avant de configurer la mise en miroir de bases de données pour un environnement SharePoint Foundation :

  • Nous vous recommandons de définir sur votre système une latence inférieure ou égale à 1 milliseconde.

  • La bande passante du système doit être, de préférence, égale à 1 gigaoctet (Go) par seconde.

  • Les journaux sont copiés en temps réel entre le serveur principal et le serveur miroir, opération qui peut nuire aux performances. Assurez-vous que le serveur principal et le serveur miroir disposent d'une quantité de mémoire et de bande passante suffisantes.

  • Le serveur principal et le serveur miroir doivent exécuter la même version et la même édition de SQL Server, et ils doivent utiliser la même langue. La mise en miroir de bases de données est disponible uniquement dans les éditions Standard, Développeur et Entreprise. Le serveur témoin peut exécuter n'importe quelle version de SQL Server, y compris SQL Server 2008 Express.

  • La mise en miroir fonctionne uniquement avec les bases de données qui utilisent le modèle de récupération complète.

    Par défaut, les bases de données SharePoint Foundation 2010 sont configurées pour utiliser le modèle de récupération simple. Pour configurer la mise en miroir de bases de données, le modèle de récupération de la base de données doit être défini à Complète. Pour plus d'informations sur la définition du modèle de récupération d'une base de données, voir Procédure : affichage ou modification du mode de récupération d'une base de données (SQL Server Management Studio) (http://go.microsoft.com/fwlink/?linkid=132075&clcid=0x40C).

  • Si vous prévoyez de mettre en miroir des bases de données, sachez que les journaux des transactions de ces bases de données peuvent devenir très volumineux. Pour éviter cela, vous pouvez établir un plan de récupération qui tronque les journaux des transactions, selon les besoins. Pour plus d'informations, voir l'article suivant dans la base de connaissances Microsoft : Comment faire pour empêcher le journal des transactions d'une base de données SQL Server de grandir de façon inattendue (http://go.microsoft.com/fwlink/?linkid=111458&clcid=0x40C).

  • Chaque session de mise en miroir de bases de données crée au moins deux threads pour chaque base de données. Assurez-vous que le nombre de threads que votre serveur de base de données peut allouer est suffisant pour la mise en miroir de toutes les bases de données prises en charge. Dans le cas contraire, les performances risquent de diminuer à mesure que d'autres bases de données sont ajoutées à une session.

Pour plus d'informations sur les performances liées à la mise en miroir de bases de données, voir Meilleures pratiques en matière de mise en miroir de bases de données et considérations sur les performances (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=185119&clcid=0x40C).

Sécurité associée à la mise en miroir de bases de données

La mise en miroir de bases de données fait appel à des sessions TCP pour transporter le journal des transactions d'un serveur à un autre et pour surveiller l'intégrité du système pour les basculements automatiques. L'authentification est assurée au niveau de la session lors de l'ouverture d'un port pour la connexion. La mise en miroir de bases de données prend en charge l'authentification (NTLM ou Kerberos) et les certificats Windows.

À moins que le réseau soit sécurisé, il est conseillé de chiffrer les données transmises pendant la session. La mise en miroir de bases de données prend en charge les algorithmes de chiffrement AES (Advanced Encryption Standard) et RC4. Pour plus d'informations sur la sécurité associée à la mise en miroir de bases de données, voir Sécurité du transport de la mise en miroir de bases de données (http://go.microsoft.com/fwlink/?linkid=83569&clcid=0x40C).

Sécurité des produits SharePoint 2010 et serveurs mis en miroir

Lorsque vous configurez une base de données mise en miroir, les noms d'accès et les autorisations SQL Server pour la base de données à utiliser avec une batterie de serveurs SharePoint ne sont pas automatiquement configurés dans les bases de données master et msdb du serveur miroir. De ce fait, vous devez configurer les autorisations pour les noms d'accès requis. Cela comprend notamment :

  • le compte de pool d'applications de l'Administration centrale doit être membre des rôles serveur fixes dbcreator et securityadmin ;

  • tous les comptes de pool d'applications, les comptes d'accès au contenu par défaut, ainsi que les comptes requis pour les applications de service doivent avoir des noms d'accès SQL Server, même si les rôles de serveur ou de base de données fixes SQL Server ne leur sont pas nécessairement attribués ;

  • les membres du groupe Administrateurs de batterie de serveurs SharePoint doivent également disposer de noms d'accès SQL Server et doivent être membres des mêmes rôles SQL Server que le compte de pool d'applications Administration centrale.

Nous vous recommandons de transférer vos noms d'accès et vos autorisations du serveur principal vers le serveur miroir en exécutant un script. Un exemple de script est disponible dans l'article n° 918992 de la base de connaissances intitulé « Comment faire pour transférer des noms d'accès et des mots de passe entre instances de SQL Server 2005 » (http://go.microsoft.com/fwlink/?linkid=122053&clcid=0x40C). Pour plus d'informations sur le transfert de métadonnées SQL Server entre les instances, voir dans la documentation en ligne SQL Server l'article Gestion des métadonnées lors de la mise à disposition d'une base de données sur une autre instance de serveur (http://go.microsoft.com/fwlink/?linkid=122055&clcid=0x40C).

Topologies prises en charge

Il est recommandé de maintenir un mappage un-à-un entre l'instance de serveur et de base de données principale et l'instance de serveur et de base de données miroir pour assurer une compatibilité avec SharePoint Foundation 2010.

Parmi les topologies prises en charge figurent notamment la mise en miroir de toutes les bases de données de contenu, de la base de données de configuration, de la base de données de contenu Administration centrale et des bases de données d'applications de service, à l'exception de la base de données de la zone de transit Web Analytics et de la base de données de synchronisation des profils utilisateur.

Remarque :
Il est déconseillé de mettre en miroir la base de données de collecte de données relatives à l'utilisation et à l'état. Un environnement SharePoint peut continuer à s'exécuter en cas de défaillance de cette base de données, et ces données peuvent être vite régénérées.

Évitez les topologies dépourvues d'instances de serveur et de base de données principales et d'instances de serveur et de base de données miroir correspondantes. De même, maintenez la base de données de configuration et la base de données de contenu d'administration sur le même serveur.

Configurer la mise en miroir de bases de données à haute disponibilité

Il est recommandé de charger un administrateur de base de données SQL Server de configurer la mise en miroir à haute disponibilité pour un environnement de production. Pour un environnement de test, nous avons mis à disposition des scripts Transact-SQL que vous pouvez utiliser pour configurer votre environnement. Pour plus d'informations, voir Exemple de script pour la configuration de la mise en miroir SQL Server (SharePoint Foundation 2010).

Configurer les produits SharePoint 2010 de sorte qu'ils prennent en charge les bases de données mises en miroir

Pour que SharePoint Foundation 2010 prenne en charge les bases de données de basculement mises en miroir, exécutez la procédure suivante pour toutes les bases de données de configuration et de contenu.

Remarque :
Il est recommandé d'utiliser les applets de commande Windows PowerShell pour définir les valeurs de base de données de basculement. Bien que vous puissiez utiliser le site Web Administration centrale pour définir certaines valeurs de base de données de basculement, vous ne pouvez pas l'utiliser pour toutes les bases de données.

Pour configurer les produits SharePoint 2010 de sorte qu'ils prennent en charge les bases de données mises en miroir à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante, puis appuyez sur Entrée :

    $db = get-spdatabase | where {$_.Name -eq " nom de base de données "}

    $db.AddFailoverServiceInstance(" nom de base de données mise en miroir ")

    $db.Update()

Pour plus d'informations, voir Get-SPDatabase.

Expérience utilisateur lors d'un basculement

Pendant que SQL Server opère un basculement en vue d'utiliser une base de données mise en miroir, les utilisateurs d'un site SharePoint qui s'exécute sur la base de données peuvent rencontrer des problèmes de connectivité et une perte de données momentanés.

Surveillance de la mise en miroir et résolution des problèmes associés

Pour surveiller l'état et les performances de la mise en miroir au sein d'une batterie de serveurs, les administrateurs de base de données peuvent utiliser le Moniteur de mise en miroir de bases de données. La surveillance permet de vérifier si et comment les données circulent dans la session de mise en miroir de bases de données. Le Moniteur de mise en miroir de bases de données s'avère également utile pour identifier la cause d'une réduction du flux de données. Pour plus d'informations, voir Vue d'ensemble du moniteur de mise en miroir de bases de données (http://go.microsoft.com/fwlink/?linkid=185068&clcid=0x40C). Une autre ressource de dépannage à votre disposition dans la documentation en ligne SQL Server Online, avec l'article Dépannage de l'établissement d'une mise en miroir de bases de données (http://go.microsoft.com/fwlink/?linkid=185069&clcid=0x40C).

Voir aussi

Autres ressources

Mise en miroir de bases de données

Historique des modifications


Exemple de script pour la configuration de la mise en miroir SQL Server (SharePoint Foundation 2010)

Cet article propose une série d'exemples de script que vous pouvez utiliser pour configurer la mise en miroir Microsoft SQL Server pour un environnement de test Microsoft SharePoint Foundation 2010. Il est recommandé de confier la mise en miroir pour un environnement de production à un administrateur de base de données SQL Server.

Pour configurer la mise en miroir de bases de données avec SharePoint Foundation 2010, vous devez travailler individuellement sur chaque base de données à mettre en miroir.

Dans cet article :

  • Configurer la mise en miroir de bases de données avec des certificats et la récupération complète

  • Configurer un serveur témoin

  • Transférer les autorisations sur le serveur miroir

Les étapes décrites ci-dessous s'appliquent à la topologie de batterie de serveurs suivante :

  • Un ou plusieurs serveurs Web frontaux

  • Trois serveurs exécutant SQL Server 2008 : un serveur principal, un serveur miroir et un serveur témoin

  • Une base de données de configuration

  • Plusieurs bases de données de contenu

  • Une ou plusieurs bases de données d'applications de service

Configurer la mise en miroir de bases de données avec des certificats et la récupération complète

Chaque étape indique le serveur sur lequel elle doit être exécutée. Utilisez Transact-SQL pour envoyer ces commandes à SQL Server. Les informations d'espaces réservés sont indiquées par des crochets angulaires (<>) ; remplacez ces espaces réservés par des informations spécifiques à votre déploiement.

Pour configurer le serveur principal pour les connexions sortantes

  1. Sur le serveur principal, créez un certificat et ouvrez un port pour la mise en miroir.

    Code de copie
    --On the master database, create the database master key, if needed
CREATE MASTER KEY ENCRYPTION BY PASSWORD = '<test1234->';
GO
-- Make a certificate for this server instance.
USE master;
CREATE CERTIFICATE <MASTER_HostA_cert>
   WITH SUBJECT = '<Master_HostA certificate>';
GO
--Create a mirroring endpoint for server instance by using the certificate
CREATE ENDPOINT Endpoint_Mirroring
   STATE = STARTED
   AS TCP (
      LISTENER_PORT=5024
      , LISTENER_IP = ALL
   )
   FOR DATABASE_MIRRORING (
      AUTHENTICATION = CERTIFICATE <MASTER_HostA_cert>
      , ENCRYPTION = REQUIRED ALGORITHM RC4
      , ROLE = ALL
   );
GO

  2. Sur le serveur principal, sauvegardez le certificat.

    Code de copie
    --Back up the HOST_A certificate.
BACKUP CERTIFICATE MASTER_HostA_cert TO FILE = '<c:\MASTER_HostA_cert.cer>';
GO

  3. Sur le serveur principal, sauvegardez la base de données. Cet exemple utilise la base de données de configuration. Répétez cette opération pour toutes les bases de données.

    Code de copie
    USE master;
--Ensure that SharePoint_Config uses the full recovery model.
ALTER DATABASE SharePoint_Config
   SET RECOVERY FULL;
GO
USE SharePoint_Config
BACKUP DATABASE SharePoint_Config
    TO DISK = '<c:\SharePoint_Config.bak>'
    WITH FORMAT
GO
BACKUP Log SharePoint_Config
    TO DISK = '<c:\SharePoint_Config_log.bak>'
    WITH FORMAT
GO

  4. Copiez le fichier de sauvegarde sur le serveur miroir. Répétez cette opération pour toutes les bases de données.

  5. À l'aide d'une méthode de copie sécurisée, copiez le fichier de certificat sauvegardé (C:\HOST_HostA_cert.cer, par exemple) sur le serveur miroir.

  6. Sur le serveur principal, créez un nom d'accès et un utilisateur pour le serveur miroir, associez le certificat à l'utilisateur et accordez les autorisations de connexion pour le partenariat.

    Code de copie
    --Create a login on HOST_A for HOST_B
USE master;
CREATE LOGIN <HOST_HostB_login> WITH PASSWORD = '<1234-test>';
GO
--Create a user for that login.
CREATE USER <HOST_HostB_user> FOR LOGIN <HOST_HostB_login>;
GO
--Associate the certificate with the user
CREATE CERTIFICATE <HOST_HostB_cert>
   AUTHORIZATION <HOST_HostB_user>
   FROM FILE = '<c:\HOST_HostB_cert.cer>' --do not use a network path, SQL Server will give an error about the key not being valid
GO
--Grant CONNECT permission on the login for the remote mirroring endpoint.
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [<HOST_HostB_login>];
GO

Pour configurer le serveur miroir pour les connexions sortantes

  1. Sur le serveur miroir, créez un certificat et ouvrez un port pour la mise en miroir.

    Code de copie
    --On the master database, create the database master key, if needed.
USE master;
CREATE MASTER KEY ENCRYPTION BY PASSWORD = '<1234-test>';
GO
-- Make a certificate on the HOST_B server instance.
CREATE CERTIFICATE <HOST_HostB>
   WITH SUBJECT = '<HOST_HostB certificate for database mirroring>';
GO
--Create a mirroring endpoint for the server instance on HOST_B.
CREATE ENDPOINT Endpoint_Mirroring
   STATE = STARTED
   AS TCP (
      LISTENER_PORT=5024
      , LISTENER_IP = ALL
   )
   FOR DATABASE_MIRRORING (
      AUTHENTICATION = CERTIFICATE <HOST_HostB>
      , ENCRYPTION = REQUIRED ALGORITHM RC4
      , ROLE = ALL
   );
GO

  2. Sur le serveur miroir, sauvegardez le certificat.

    Code de copie
    --Back up the HOST_B certificate.
BACKUP CERTIFICATE <HOST_HostB> TO FILE = '<C:\HOST_HostB_cert.cer>';
GO

  3. À l'aide d'une méthode de copie sécurisée, copiez le fichier de certificat sauvegardé (C:\HOST_HostB_cert.cer, par exemple) sur le serveur principal.

  4. Sur le serveur miroir, restaurez la base de données à partir des fichiers de sauvegarde. Cet exemple utilise la base de données de configuration. Répétez cette opération pour toutes les bases de données.

    Code de copie
    RESTORE DATABASE SharePoint_Config
    FROM DISK = '<c:\SharePoint_Config.bak>'
    WITH NORECOVERY
GO
RESTORE log SharePoint_Config
    FROM DISK = '<c:\SharePoint_Config_log.bak>'
    WITH NORECOVERY
GO

Pour configurer le serveur miroir pour les connexions entrantes

  1. Sur le serveur miroir, créez un nom d'accès et un utilisateur pour le serveur principal, associez le certificat à l'utilisateur et accordez les autorisations de connexion pour le partenariat.

    Code de copie
    --Create a login on HOST_B for HOST_A
USE master;
CREATE LOGIN <MASTER_HostA_login> WITH PASSWORD = '<test1234->';
GO
--Create a user for that login.
CREATE USER <MASTER_HostA_user> FOR LOGIN <MASTER_HostA_login>;
GO
--Associate the certificate with the user
CREATE CERTIFICATE <MASTER_HostA_cert>
   AUTHORIZATION <MASTER_HostA_user>
   FROM FILE = '<c:\MASTER_HostA_cert.cer>' --do not use a network path, SQL Server will give an error about the key not being valid
GO
--Grant CONNECT permission on the login for the remote mirroring endpoint.
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [<MASTER_HostA_login>];
GO

Pour configurer le serveur principal pour les connexions entrantes

  1. Sur le serveur principal, créez un nom d'accès et un utilisateur pour le serveur miroir, associez le certificat à l'utilisateur et accordez les autorisations de connexion pour le partenariat.

    Code de copie
    --Create a login on HOST_A for HOST_B
USE master;
CREATE LOGIN <HOST_HostB_login> WITH PASSWORD = '<1234-test>';
GO
--Create a user for that login.
CREATE USER <HOST_HostB_user> FOR LOGIN <HOST_HostB_login>;
GO
--Associate the certificate with the user
CREATE CERTIFICATE <HOST_HostB_cert>
   AUTHORIZATION <HOST_HostB_user>
   FROM FILE = '<c:\HOST_HostB_cert.cer>' --do not use a network path, SQL Server will give an error about the key not being valid
GO
--Grant CONNECT permission on the login for the remote mirroring endpoint.
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [<HOST_HostB_login>];
GO

Pour configurer les partenaires de mise en miroir

  1. Sur le serveur principal, configurez le partenariat de mise en miroir. Cet exemple utilise la base de données de configuration. Répétez cette opération pour toutes les bases de données.

    Code de copie
    --At HOST_A, set the server instance on HOST_B as a partner (mirror server).
ALTER DATABASE SharePoint_Config
    SET PARTNER = '<TCP://databasemirror.adatum.com:5024>';
GO

  2. Sur le serveur miroir, configurez le partenariat de mise en miroir. Cet exemple utilise la base de données de configuration. Répétez cette opération pour toutes les bases de données.

    Code de copie
    --At HOST_B, set the server instance on HOST_A as a partner (principal server):
ALTER DATABASE SharePoint_Config
    SET PARTNER = '<TCP://databasemaster.adatum.com:5024>';
GO

Configurer un serveur témoin

Chaque étape indique le serveur sur lequel elle doit être exécutée. Utilisez Transact-SQL pour envoyer ces commandes à SQL Server. Les informations d'espaces réservés sont indiquées par des crochets angulaires (<>) ; remplacez ces espaces réservés par des informations spécifiques à votre déploiement.

  1. Sur le serveur témoin, configurez le certificat et ouvrez le port.

    Code de copie
    --On the master database, create the database master key, if needed
CREATE MASTER KEY ENCRYPTION BY PASSWORD = '<1234test->';
GO
-- Make a certificate for this server instance.
USE master;
CREATE CERTIFICATE <WITNESS_HostC_cert>
   WITH SUBJECT = '<Witness_HostC certificate>';
GO
--Create a mirroring endpoint for server instance by using the certificate
CREATE ENDPOINT Endpoint_Mirroring
   STATE = STARTED
   AS TCP (
      LISTENER_PORT=5024
      , LISTENER_IP = ALL
   )
   FOR DATABASE_MIRRORING (
      AUTHENTICATION = CERTIFICATE <WITNESS_HostC_cert
      , ENCRYPTION = REQUIRED ALGORITHM RC4
      , ROLE = ALL
   );
GO

  2. Sur le serveur témoin, sauvegardez le certificat.

    Code de copie
    --Back up the HOST_C certificate
BACKUP CERTIFICATE <WITNESS_HostC_cert> TO FILE = '<c:\ WITNESS_HostC_cert.cer>';
GO

  3. À l'aide d'une méthode de copie sécurisée, copiez le fichier de certificat sauvegardé (C:\WITNESS_HOSTC_cert.cer, par exemple) sur le serveur principal et le serveur miroir.

  4. Sur le serveur témoin, créez des nom d'accès et des utilisateurs pour les serveurs principal et miroir, associez les certificats aux utilisateurs et accordez les autorisations de connexion pour le partenariat.

    Code de copie
    --Create a login on witness HOST_C for principal HOST_A
USE master;
CREATE LOGIN <MASTER_HostA_login> WITH PASSWORD = '<test1234->';
GO
--Create a user for that login.
CREATE USER <MASTER_HostA_user> FOR LOGIN <MASTER_HostA_login>;
GO
--Associate the certificate with the user
CREATE CERTIFICATE <MASTER_HostA_cert>
   AUTHORIZATION <MASTER_HostA_user>
   FROM FILE = '<c:\MASTER_HostA_cert.cer>' --do not use a network path, SQL Server will give an error about the key not being valid
GO
--Grant CONNECT permission on the login for the remote mirroring endpoint.
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [<MASTER_HostA_login>];
GO
--Create a login for the mirror Host_B
CREATE LOGIN <HOST_HostB_login> WITH PASSWORD = '<1234-test>';
GO
--Create a user for that login.
CREATE USER <HOST_HostB_user> FOR LOGIN <HOST_HostB_login>;
GO
--Associate the certificate with the user
CREATE CERTIFICATE <HOST_HostB_cert>
   AUTHORIZATION <HOST_HostB_user>
   FROM FILE = '<c:\HOST_HostB_cert.cer>' --do not use a network path, SQL Server will give an error about the key not being valid
GO
--Grant CONNECT permission on the login for the remote mirroring endpoint.
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [<HOST_HostB_login>];
GO

  5. Sur le serveur principal, créez un nom d'accès et un utilisateur pour le serveur témoin, associez le certificat à l'utilisateur et accordez les autorisations de connexion pour le partenariat. Répétez cette procédure pour le serveur miroir.

    Code de copie
    --Create a login on master HostA for witness HostC
USE master;
CREATE LOGIN <WITNESS_HostC_login> WITH PASSWORD = '<1234test->';
GO
--Create a user for that login.
CREATE USER <WITNESS_HostC_user> FOR LOGIN <WITNESS_HostC_login>;
GO
--Associate the certificate with the user
CREATE CERTIFICATE <WITNESS_HostC_cert>
   AUTHORIZATION <WITNESS_HostC_user>
   FROM FILE = '<c:\WITNESS_HostC_cert.cer>' --do not use a network path, SQL Server will give an error about the key not being valid
GO
--Grant CONNECT permission on the login for the remote mirroring endpoint.
GRANT CONNECT ON ENDPOINT::Endpoint_Mirroring TO [<WITNESS_HostC_login>];
GO

  6. Sur le serveur principal, attachez le serveur témoin. Cet exemple utilise la base de données de configuration. Répétez cette opération pour toutes les bases de données.

    Code de copie
    --Set up the witness server
ALTER DATABASE SharePoint_Config
    SET WITNESS =
    '<TCP://databasewitness.adatum.com:5024>'
GO

Transférer les autorisations sur le serveur miroir

Lorsque vous configurez une base de données mise en miroir, les noms d'accès et les autorisations SQL Server pour la base de données appelée à être utilisée avec une batterie de serveurs SharePoint ne sont pas automatiquement configurés dans les bases de données master et msdb du serveur miroir. De ce fait, vous devez configurer les autorisations pour les noms d'accès requis.

Nous vous recommandons de transférer vos noms d'accès et vos autorisations du serveur principal vers le serveur miroir en exécutant un script. Le script que nous vous recommandons d'utiliser est disponible dans l'article n° 918992 de la base de connaissances : Comment faire pour transférer des noms d'accès et des mots de passe entre instances de SQL Server 2005 (http://go.microsoft.com/fwlink/?linkid=122053&clcid=0x40C).

Suppression de la mise en miroir d'un serveur

Pour supprimer la mise en miroir d'un serveur, voir Procédure : supprimer une mise en miroir de bases de données (Transact-SQL) (http://go.microsoft.com/fwlink/?linkid=185070&clcid=0x40C).

Historique des modifications


Suivre ou bloquer les installations SharePoint Foundation 2010

Les déploiements de Produits Microsoft SharePoint 2010 étant gérés au niveau de la batterie de serveurs, un même déploiement SharePoint ne comporte pas d'informations sur les autres déploiements SharePoint qui peuvent exister dans la même entreprise. Les administrateurs ont besoin de ces informations pour gérer et contrôler tous les déploiements dans l'entreprise. Par exemple, les administrateurs ont besoin de savoir si un déploiement a été configuré selon des impératifs organisationnels ou de connaître le nombre de déploiements non autorisés qu'il existe dans l'entreprise. Produits SharePoint 2010 permet de verrouiller, de suivre et même d'empêcher les installations aléatoires de Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Empêcher les installations

  • Suivre les installations

Empêcher les installations

Si vous voulez empêcher les utilisateurs d'installer SharePoint Foundation 2010 et des produits associés, définissez la clé de Registre suivante en utilisant la stratégie de groupe des services d'annuaire Active Directory :

HKLM\Software\Policies\Microsoft\Shared Tools\Web Server Extensions\14.0\ SharePoint\DWORD DisableInstall

Pour empêcher les installations, définissez DWORD DisableInstall=00000001.

Lorsque cette clé de Registre est définie, les utilisateurs qui essaient d'installer SharePoint Foundation 2010 obtiennent le message d'erreur suivant :

L'installation de SharePoint est bloquée dans votre organisation. Pour plus d'informations, contactez l'administrateur réseau.

Pour définir une valeur de Registre en utilisant la stratégie de groupe, vous pouvez utiliser un fichier .admx dans Windows Server 2008 ou une applet de commande Windows PowerShell dans Windows Server 2008 R2. Pour plus d'informations sur la définition des valeurs de Registre en utilisant des stratégies de groupe dans Windows Server 2008, voir Guide de référence de la syntaxe ADMX de stratégie de groupe (http://go.microsoft.com/fwlink/?linkid=194348&clcid=0x40C). Pour plus d'informations sur la définition des valeurs de Registre en utilisant des stratégies de groupe dans Windows Server 2008 R2, voir Définir une valeur de clé de Registre depuis la ligne de commande en utilisant les applets de commande PowerShell pour les stratégies de groupe (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=194345&clcid=0x40C). Pour obtenir des informations générales sur les stratégies de groupe, voir Stratégie de groupe (http://go.microsoft.com/fwlink/?linkid=177635&clcid=0x40C) sur TechNet.

Suivre les installations

Un marqueur AD DS (services de domaine Active Directory) appelé Point de connexion de service permet d'identifier les serveurs Produits SharePoint 2010 présents dans une organisation. Pour utiliser ce marqueur, créez un conteneur dans AD DS et définissez les autorisations pour le conteneur avant d'installer des Produits SharePoint 2010 dans l'environnement. Ensuite, une fois que vous ou un autre utilisateur de votre domaine exécutez l'Assistant Configuration des produits SharePoint dans le cadre de l'installation de SharePoint Foundation 2010, ce marqueur est défini et peut être suivi à l'aide d'AD DS. Vous devez définir ce marqueur pour chaque domaine présent dans votre organisation, dans la mesure où vous souhaitez suivre les installations dans tous les domaines. Ce marqueur est supprimé d'AD DS à partir du moment où le dernier serveur est supprimé d'une batterie de serveurs. Vous pouvez également définir la marqueur à l'aide de Windows PowerShell. Le marqueur contient l'URL du Service de détection d'applications et d'équilibrage de charge (également appelé application du service de topologie) de la batterie de serveurs.

Vous devez accorder une autorisation d'écriture dans ce conteneur aux comptes d'utilisateurs ou de domaine habilités à exécuter l'Assistant Configuration des produits SharePoint. Si le compte n'est pas autorisé à écrire dans ce conteneur, l'avertissement suivant s'affiche dans le fichier journal pour l'Assistant Configuration des produits SharePoint :

Échec de l'ajout du point de connexion de service pour cette batterie de serveurs

Impossible de créer un point de connexion de service dans le domaine Active Directory actuel. Vérifiez que le conteneur SharePoint existe dans le domaine actuel et que vous disposez des droits en écriture sur ce conteneur.

Pour créer le conteneur dans Active Directory et définir les autorisations, vous pouvez utiliser l'Éditeur ADSI (Active Directory Service Interfaces).

Pour créer un conteneur de point de connexion de service pour suivre les installations

  1. Sur le contrôleur de domaine, cliquez sur Démarrer, pointez sur Outils d'administration, puis cliquez sur Éditeur ADSI. Vous pouvez également utiliser un outil d'administration à distance pour vous connecter à l'Éditeur ADSI à partir d'un autre ordinateur.

  2. Dans le menu Action, cliquez sur Connexion à, puis connectez-vous au domaine que vous souhaitez utiliser.

  3. Dans l'arborescence de la console, développez la connexion, développez le nom de domaine, puis cliquez sur CN=System.

  4. Dans le volet Détails, cliquez avec le bouton droit dans la zone blanche, cliquez sur Nouveau, puis sur Objet.

  5. Dans la boîte de dialogue Créer un objet, dans la zone Sélectionnez une classe, cliquez sur conteneur, puis sur Suivant.

  6. Dans la zone Valeur, tapez Produits Microsoft SharePoint comme nom de conteneur, puis cliquez sur Suivant.

    Il s'agit du nom par défaut.

    Remarque :
    Vous pouvez utiliser d'autres noms. Toutefois, dans ce cas, vous devez créer une stratégie de groupe pour les ordinateurs du domaine afin de définir une valeur de chaîne ContainerDistinguishedName sous la clé de Registre suivante : HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\SharePoint. Cela permet à Assistant Configuration des produits SharePoint de détecter le nouveau nom.

  7. Cliquez sur Terminer.

    Le conteneur est créé.

  8. Cliquez avec le bouton droit sur le conteneur (CN=Produits Microsoft SharePoint), puis cliquez sur Propriétés.

  9. Sous l'onglet Sécurité, cliquez sur Ajouter.

  10. Dans la zone Sélectionner les utilisateurs, les ordinateurs ou les groupes, ajoutez les utilisateurs appelés à écrire dans ce conteneur, puis cliquez sur OK.

    Notez que si un utilisateur non autorisé à écrire dans ce conteneur installe SharePoint Foundation 2010, aucune entrée nouvelle ne sera créée. Envisagez d'attribuer l'autorisation à tous les utilisateurs authentifiés de façon à vous permettre de suivre tous les objets.

  11. Dans la zone Groupes ou noms d'utilisateurs, sélectionnez les noms que vous avez ajoutés précédemment puis, sous la zone Autorisations, cliquez sur Avancé.

  12. Dans la zone Entrées d'autorisations, sélectionnez les noms que vous avez ajoutés précédemment, puis cliquez sur Modifier.

  13. Dans la boîte de dialogue Entrée d'autorisation pour Produits Microsoft SharePoint, dans la zone Autorisations, activez la case à cocher Autoriser pour Créer des objets serviceConnectionPoint, puis cliquez sur OK.

Pour valider ce processus, installez et configurez une nouvelle batterie de serveurs SharePoint dans l'environnement, puis vérifiez si le point de connexion de service a bien été créé. Si tout fonctionne correctement, un nouvel objet GUID se trouve sous le conteneur Produit Microsoft SharePoint. Cliquez avec le bouton droit sur l'objet, puis cliquez sur Propriétés. L'URL du Service de détection d'applications et d'équilibrage de charge de la batterie de serveurs figure à cet endroit.

Il existe un script qui permet de répertorier tous les noms de serveurs Produits SharePoint 2010 présents dans un domaine. Pour obtenir ce script, voir Répertorier tous les serveurs SharePoint 2010 d'un domaine en contrôlant le marqueur AD dans le Centre de scripts.

Utilisez la procédure suivante pour ajouter ou mettre à jour le point de connexion de service de la batterie de serveurs actuelle dans AD DS.

Pour définir un point de connexion de service dans AD DS à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante.

    Code de copie
    Set-SPFarmConfig -ServiceConnectionPointBindingInformation StringwithBindingInformation

    Où :

    • StringwithBindingInformation représente généralement l'URL du Service de détection d'applications et d'équilibrage de charge. Notez que cette variable peut être remplacée par n'importe quelle chaîne valide de votre choix, telle que l'URL de l'Administration centrale.

      Pour obtenir l'URL du Service de détection d'applications et d'équilibrage de charge, exécutez la commande suivante.

      Code de copie
      Get-SPTopologyServiceApplication | select URI
      Celle-ci renvoie l'URL du Service de détection d'applications et d'équilibrage de charge. Pour plus d'informations, voir Get-SPTopologyServiceApplication.

  6. À l'invite de confirmation, tapez O.

Pour plus d'informations, voir Set-SPFarmConfig.

Utilisez la procédure suivante pour supprimer le point de connexion de service de la batterie de serveurs actuelle dans AD DS.

Pour supprimer un point de connexion de service dans AD DS à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante.

    Code de copie
    Set-SPFarmConfig -ServiceConnectionPointDelete

  6. À l'invite de confirmation, tapez O.

Pour plus d'informations, voir Set-SPFarmConfig.

Utilisez la procédure suivante pour déterminer les informations de point de connexion de service pour la batterie de serveurs actuelle dans AD DS.

Pour rechercher le point de connexion de service d'une batterie de serveurs à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante.

    Code de copie
    Get-SPFarmConfig -ServiceConnectionPoint

Pour plus d'informations, voir Get-SPFarmConfig.

Historique des modifications

Date | Description | Raison
10 juin 2010 | Publication initiale |


Administration de sites et de solutions (SharePoint Foundation 2010)
Voir aussi

Cette section explique comment configurer les paramètres d'administration des sites et des solutions au sein d'un environnement Microsoft SharePoint Foundation 2010.

  • Administration de sites et de collections de sites (SharePoint Foundation 2010)

    Les rubriques de cette section expliquent comment créer et supprimer des collections de sites, comment gérer des administrateurs de collection de sites, comment utiliser des modèles de quotas dans le cadre des limites de stockage et du verrouillage des sites, et comment supprimer les sites Web inutilisés. Les rubriques de cette section expliquent également comment configurer la sécurité des pages et contrôles de composants WebPart.

  • Administration de solutions en mode bac à sable (SharePoint Foundation 2010)

    Les articles de cette section fournissent des instructions sur la gestion des solutions en mode bac à sable qui s'exécutent dans des environnements d'exécution restreints au sein de votre entreprise.

  • Administration du service Connexion de données métiers (SharePoint Foundation 2010)

    Les articles de cette section fournissent des descriptions des opérations d'administration générales du service Connexion de données métiers et des opérations relatives aux éléments stockés et gérés à l'aide de ce service.

  • Administration de flux de travail (SharePoint Foundation 2010)

    Les articles de cette section expliquent comment effectuer des tâches d'administration de flux de travail courantes.

Voir aussi

Concepts

Administration de serveur et de batterie de serveurs (SharePoint Foundation 2010)

Historique des modifications


Administration de sites et de collections de sites (SharePoint Foundation 2010)
Voir aussi

Une collection de sites Microsoft SharePoint Foundation 2010 est une structure de site hiérarchique composée d'un site de niveau supérieur et de sous-sites. Ce site Web de niveau supérieur peut avoir plusieurs sous-sites, et chaque sous-site peut avoir plusieurs sous-sites, selon autant de niveaux que nécessaire. Les sites Web de niveau supérieur et les sous-sites autorisent différents niveaux de contrôle des fonctionnalités et des paramètres des sites.

Dans cette section :

  • Créer une collection de sites (SharePoint Foundation 2010)

    Cet article explique comment créer une collection de sites basée sur une application Web existante, ou créer une application Web, puis une collection de sites dans cette application.

  • Supprimer une collection de sites (SharePoint Foundation 2010)

    Cet article explique comment supprimer le contenu, les informations des utilisateurs et la hiérarchie de site qui constituent une collection de sites.

Voir aussi

Concepts

Opérations pour SharePoint Foundation 2010

Historique des modifications


Gérer les collections de sites (SharePoint Foundation 2010)
Voir aussi

Cette section explique comment créer et supprimer des collections de sites, comment gérer les administrateurs de collections de sites et comment utiliser des modèles de quotas pour gérer des limites de stockage de collections de sites.

  • Créer une collection de sites (SharePoint Foundation 2010)

    Cet article explique comment créer une collection de sites basée sur une application Web existante ou comment créer une application Web puis une collection de sites dans cette application.

  • Supprimer une collection de sites (SharePoint Foundation 2010)

    Cet article explique comment supprimer le contenu, les informations utilisateur et la hiérarchie de sites qui composent une collection de sites.

  • Configurer une connexion à un site portail (SharePoint Foundation 2010)

    Cet article explique comment configurer une connexion à un site portail. Le site portail est ajouté à l'exploration globale à l'aide de la barre de navigation de la collection de sites.

  • Afficher toutes les collections de sites (SharePoint Foundation 2010)

    Cet article explique comment afficher la liste de collections de sites.

  • Ajouter ou supprimer des administrateurs de collection de sites (SharePoint Foundation 2010)

    Cet article explique comment changer d'administrateurs de collections de sites principaux et secondaires.

  • Créer, modifier et supprimer des modèles de quota (SharePoint Foundation 2010)

    Cet article explique comment configurer les valeurs de limite de stockage qui spécifient la quantité maximale de données qui peut être stockée dans une collection de sites, ainsi que la taille de stockage qui, une fois atteinte, déclenche une alerte par courrier électronique à destination de l'administrateur de la collection de sites.

  • Gérer les limites de stockage de collection de sites (SharePoint Foundation 2010)

    Cet article explique comment mettre à jour les limites d'avertissement et de stockage d'une collection de sites en remplaçant le modèle de quota affecté à la collection de sites.

  • Gérer des types de fichiers bloqués (SharePoint Foundation 2010)

    Cet article explique comment limiter le téléchargement de fichiers en fonction de leur extension de nom de fichier.

  • Verrouiller ou déverrouiller les collections de sites (SharePoint Foundation 2010)

    Cet article explique comment ajouter ou supprimer un verrou au niveau d'une collection de sites.

Voir aussi

Concepts

Opérations pour SharePoint Foundation 2010

Historique des modifications


Supprimer une collection de sites (SharePoint Foundation 2010)
Voir aussi

Vous pouvez supprimer une collection de sites si elle n'est plus nécessaire. Par exemple, si vous avez créé un site d'équipe pour suivre la progression d'un projet spécifique, et si le projet est terminé, vous pouvez décider de supprimer la collection de sites après un certain délai.

Lorsque vous supprimez une collection de sites, vous supprimez une hiérarchie de sites qui renferment la collection. En outre, vous détruisez définitivement la totalité du contenu et des informations utilisateur, telles que les données suivantes :

  • les documents et bibliothèques de documents ;

  • les listes et leurs données, notamment les enquêtes, les discussions, les annonces et les événements ;

  • les paramètres de configuration du site ;

  • les informations de rôle et de sécurité liées au site Web ;

  • les sous-sites du site Web de niveau supérieur, leur contenu et les informations utilisateur.

Remarque :
Vous devez sauvegarder une collection de sites avant de la supprimer. Pour plus d'informations sur la façon de sauvegarder une collection de sites, voir Planifier la sauvegarde et la récupération (SharePoint Foundation 2010).

Avant de supprimer une collection de sites, vérifiez que la configuration suivante est disponible :

  • Une copie de sauvegarde de la collection de sites et de tout son contenu existe.

Dans cet article :

  • Supprimer une collection de sites à l'aide de l'Administration centrale

  • Supprimer une collection de sites à l'aide de Windows PowerShell

Supprimer une collection de sites à l'aide de l'Administration centrale

Une fois cette procédure effectuée, la collection de sites ainsi que l'ensemble de son contenu et des informations relatives aux utilisateurs sont définitivement supprimés.

Pour supprimer une collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour supprimer une collection de sites, le compte d'utilisateur qui effectue cette procédure doit être membre du groupe SharePoint Administrateurs de batterie.

  2. Sur le site Web Administration centrale, dans la barre de lancement rapide, cliquez sur Gestion des applications

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Supprimer une collection de sites.

  4. Dans la page Supprimer une collection de sites, dans la liste déroulante Collection de sites, cliquez sur la flèche vers le bas, puis cliquez sur Supprimer une collection de sites.

    La boîte de dialogue Sélectionner la collection de sites s'affiche.

  5. Dans la liste déroulante Application Web, cliquez sur la flèche vers le bas, puis cliquez sur Supprimer une application Web.

    La boîte de dialogue Sélectionner une application Web apparaît.

  6. Cliquez sur le nom de l'application Web qui contient la collection de sites à supprimer. Les URL relatives de sites dans les collections de sites de l'application Web que vous avez sélectionnée apparaissent dans la boîte de dialogue Sélectionner la collection de sites.

  7. Cliquez sur l'URL relative de la collection de sites à supprimer, puis cliquez sur OK.

  8. Lisez la section Avertissement et vérifiez que les informations sur la collection de sites sont correctes.

  9. Dans la page Supprimer une collection de sites, cliquez sur Supprimer.

    La collection de sites que vous avez sélectionnée est supprimée.

Supprimer une collection de sites à l'aide de Windows PowerShell

Une fois cette procédure effectuée, la collection de sites ainsi que l'ensemble de son contenu et des informations relatives aux utilisateurs sont définitivement supprimés.

Pour supprimer une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Dans la fenêtre d'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    Remove-SPSite -Identity "<URL>" -GradualDelete

    Où :

    1. <URL> est l'URL de la collection de sites à supprimer.

    Cette commande supprime la collection de sites spécifiée et tous les sous-sites. Une suppression progressive réduit la charge sur le système pendant l'opération.

    La procédure précédente illustre une méthode courante d'utilisation de l'applet de commande Remove-SPSite pour supprimer une collection de sites. Vous pouvez spécifier d'autres paramètres pour configurer cette commande de manière différente. Pour plus d'informations, voir Remove-SPSite.

    Remarque :
    Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Voir aussi

Concepts

Créer une collection de sites (SharePoint Foundation 2010)

Historique des modifications


Configurer une connexion à un site portail (SharePoint Foundation 2010)

Une connexion de site portail peut être utilisée pour lier une collection de sites à une autre. Par exemple, si vous avez une collection de sites principale vers laquelle vous souhaitez fournir un lien, vous pouvez configurer une connexion de site portail qui pointe vers la collection de sites principale. Le site portail est ajouté à l'exploration globale à l'aide de la barre de navigation de la collection de sites active. Lorsque des utilisateurs de collection de sites cliquent sur le dossier Haut, le site portail est répertorié comme parent de la collection de sites, ce qui permet aux utilisateurs de naviguer jusqu'au site portail plus facilement.

Configurer une connexion à un site portail

Une connexion de site portail aide les utilisateurs de collection de sites à naviguer jusqu'au site portail plus facilement. Celui-ci s'affiche lorsqu'ils cliquent sur le dossier Haut.

Pour configurer une connexion à un site portail

  1. Vérifiez que vous disposez de la configuration minimale requise suivante :

    • Vous devez être l'administrateur de la collection de sites.

  2. Naviguez jusqu'à la collection de sites où vous souhaitez créer une connexion à un site portail.

  3. Dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, dans la section Administration de la collection de sites, cliquez sur Connexion au site portail.

  5. Dans la page Connexion au site portail, sélectionnez Se connecter au site portail.

  6. Dans la zone Adresse Web du site portail, tapez l'URL du site portail.

    Conseil :
    Le site portail est la collection de sites vers laquelle vous souhaitez créer un lien. Il sera ajouté à l'exploration globale à l'aide de la barre de navigation de la collection de sites active.

  7. Dans la zone Nom du portail, tapez le nom du site portail.

  8. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
7 octobre 2010 | Publication initiale |


Afficher toutes les collections de sites (SharePoint Foundation 2010)

Une collection de sites est un groupe de sites Web ayant le même propriétaire et des paramètres d'administration en commun, par exemple, les autorisations. Les collections de sites sont créées dans une application Web. Lorsque vous créez une collection de sites, un site de niveau supérieur est automatiquement créé dans la collection. Vous pouvez ensuite créer un ou plusieurs sous-sites en dessous du site de niveau supérieur. La structure entière constituée du site de niveau supérieur et de tous ses sous-sites est appelée « collection de sites ».

Afficher les collections de sites dans une application Web

Utilisez les procédures suivantes pour afficher toutes les collections de sites dans une application Web.

Pour afficher toutes les collections de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Pour afficher toutes les collections de sites, vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur exécutant le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Afficher toutes les collections de sites.

    La page Liste de collections de sites répertorie toutes les collections de sites dans l'application Web.

  4. Pour afficher des informations supplémentaires sur une collection de sites, dans la colonne URL, cliquez sur la collection de sites.

    Les informations ci-dessous se rapportant à la collection de sites s'affichent dans un tableau dans le côté droit de la page.

    Élément Description

    URL

    URL de la collection de sites.

    Titre

    Titre attribué à la collection de sites lors de sa création.

    Description

    Description fournie lors de la création de la collection de sites.

    Administrateur principal

    Administrateur principal de la collection de sites.

    Adresse de messagerie

    Adresse de messagerie de l'administrateur principal.

    Nom de la base de données

    Base de données de contenu utilisée par la collection de sites.

  5. Si vous voulez modifier l'application Web sélectionnée, cliquez dans la zone Application Web, puis sur Modifier l'application Web. Utilisez la page Sélectionner une application Web pour sélectionner une autre application Web.

Pour afficher toutes les collections de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPWebApplication "<WebApplicationURL>" | Get-SPSite | Format-Table -Property URL,ContentDatabase

    Où <WebApplicationURL> représente l'URL de l'application Web dont vous voulez afficher les collections de sites.

Pour plus d'informations, voir Get-SPWebApplication et Get-SPSite.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Ajouter ou supprimer des administrateurs de collection de sites (SharePoint Foundation 2010)

Cet article explique comment ajouter et supprimer des administrateurs de collections de sites. Un administrateur de collection de sites peut configurer l'aspect et le comportement du site, configurer les paramètres de recherche et d'annuaire de sites et allouer de l'espace de stockage. Une collection de sites peut avoir un ou deux administrateurs.

Dans cet article :

  • Ajouter un administrateur de collection de sites

  • Supprimer un administrateur de collection de sites

Ajouter un administrateur de collection de sites

Utilisez cette procédure lorsque vous voulez faire d'un utilisateur l'un des administrateurs d'une collection de sites spécifique.

Attention :
Une collection de sites ne peut avoir que deux administrateurs. Les étapes de cette procédure indiquent comment remplacer l'administrateur secondaire d'une collection de sites. Elles permettent de supprimer l'administrateur secondaire de la collection de sites, dans le cas où il en existe un, mais elles laissent l'administrateur principal de la collection de sites inchangé.

Pour ajouter un administrateur de collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Pour ajouter un administrateur de collection de sites, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil du site Web Administration centrale de SharePoint, sélectionnez Gestion des applications.

  3. Dans la page Gestion des applications, sous Collections de sites, sélectionnez Changer les administrateurs de collection de sites.

  4. Dans la page Administrateurs de collections de site, cliquez sur la flèche en regard du nom de la collection de sites et sélectionnez Changer les administrateurs de collection de sites.

  5. Si la collection de sites à laquelle vous souhaitez ajouter un administrateur figure dans la liste, sélectionnez-en l'URL, puis cliquez sur OK. Si la collection de sites ne se trouve pas dans la liste, cliquez sur la flèche en regard du nom de l'application Web ; cliquez sur Modifier l'application Web ; sélectionnez le nom de l'application Web qui contient la collection de sites ; sélectionnez l'URL de la collection de sites ; puis cliquez sur OK.

  6. Dans la zone Administrateur secondaire de la collection de sites, tapez le nom de l'utilisateur à ajouter sous la forme <domaine>\<nom_utilisateur> ou sélectionnez l'utilisateur dans le carnet d'adresses.

  7. Cliquez sur OK.

Pour ajouter un administrateur de collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell, tapez la commande suivante pour remplacer l'administrateur secondaire d'une collection de sites :

    Code de copie
    Set-SPSite -Identity "<SiteCollection>" -SecondaryOwnerAlias "<User>"

    Où :

    • <SiteCollection> représente l'URL de la collection de sites à laquelle vous souhaitez ajouter un administrateur de collection de sites.

    • <User> représente le nom de l'utilisateur à ajouter sous la forme <domaine>\<nom_utilisateur>.

La procédure précédente illustre un mode d'utilisation courant de l'applet de commande Set-SPSite pour ajouter un administrateur de collection de sites. Vous pouvez spécifier différents paramètres en fonction de la configuration souhaitée de la collection de sites. Pour plus d'informations, voir Set-SPSite.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Supprimer un administrateur de collection de sites

Utilisez cette procédure pour spécifier l'utilisateur à supprimer de la liste des administrateurs de collections de sites. Cette procédure ne supprime pas l'utilisateur des services AD DS (services de domaine Active Directory).

Pour supprimer un administrateur de collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Pour supprimer un administrateur de collection de sites, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil du site Web Administration centrale de SharePoint, sélectionnez Gestion des applications.

  3. Dans la page Gestion des applications, sous Collections de sites, sélectionnez Changer les administrateurs de collection de sites.

  4. Dans la page Administrateurs de collections de site, cliquez sur la flèche en regard du nom de la collection de sites et sélectionnez Changer les administrateurs de collection de sites.

  5. Si la collection de sites dont vous souhaitez supprimer un administrateur figure dans la liste, sélectionnez-en l'URL, puis cliquez sur OK. Si la collection de sites ne se trouve pas dans la liste, cliquez sur la flèche en regard du nom de l'application Web ; cliquez sur Modifier l'application Web ; sélectionnez le nom de l'application Web qui contient la collection de sites ; sélectionnez l'URL de la collection de sites ; puis cliquez sur OK.

  6. Chaque collection de sites doit disposer d'un administrateur de collection de sites principal. Si vous souhaitez supprimer l'administrateur de collection de sites principal, vous devez le remplacer par un autre. Pour ce faire, sélectionnez le nom de l'administrateur actuel ; appuyez sur la touche Suppr ; puis tapez le nom de l'administrateur de collection de sites de remplacement sous la forme <domaine>\<nom_utilisateur> ou sélectionnez-en un dans le carnet d'adresses.

  7. Pour supprimer l'administrateur de collection de sites secondaire, sélectionnez son nom, puis appuyez sur la touche Suppr.

  8. Cliquez sur OK.

Historique des modifications


Créer, modifier et supprimer des modèles de quota (SharePoint Foundation 2010)

Un modèle de quota est constitué de valeurs de limite de stockage qui spécifient la quantité maximale de données qui peut être stockée dans une collection de sites. Lorsque la limite de stockage est atteinte, le modèle de quota peut également déclencher une alerte par courrier électronique à destination de l'administrateur de la collection de sites. Vous pouvez créer un modèle de quota applicable à n'importe quelle collection de sites de la batterie de serveurs.

Remarque :
Lorsque vous appliquez un modèle de quota à une collection de sites, la limite de stockage s'applique à la collection de sites dans son ensemble. En d'autres termes, elle s'applique à la somme des tailles de contenu du site de niveau supérieur et de tous les sous-sites de la collection de sites.

Pour plus d'informations, voir Créer une collection de sites (SharePoint Foundation 2010) et Gérer les limites de stockage de collection de sites (SharePoint Foundation 2010).

Vous pouvez également appliquer des modèles de quotas à une collection de sites qui contient des solutions en mode bac à sable. Un bac à sable est un environnement d'exécution restreint qui permet aux programmes d'accéder uniquement à certaines ressources et qui empêche les problèmes qui se produisent dans le bac à sable d'affecter le reste de l'environnement serveur. Vous pouvez limiter l'utilisation maximale quotidienne et envoyer un message électronique d'avertissement à l'approche de la limite d'utilisation. Si la limite d'utilisation maximale est atteinte, la solution en mode bac à sable est désactivée pour le reste de la journée et un message électronique est envoyé à l'administrateur de la collection de sites.

Vous pouvez également modifier les modèles de quotas existants. Cela vous permet de modifier les limites de stockage de toutes les collections de sites qui utilisent le même modèle de quota. Lorsque vous modifiez un modèle de quota, vous devez le réappliquer aux collections de sites existantes avant que les nouvelles limites de stockage soient appliquées.

Vous pouvez supprimer un modèle de quota, si nécessaire. Toutefois, cette opération n'aura pas pour effet de supprimer les valeurs de quota des sites qui ont été créés à l'aide de ce modèle de quota. Si vous souhaitez supprimer les quotas de tous les sites à l'aide d'un modèle de quota spécifique, vous devez utiliser le modèle objet ou effectuer une requête SQL.

Configuration requise pour la tâche

Avant d'effectuer cette procédure, vérifiez les points suivants :

  • votre système exécute la version « Standard » ou « Entreprise » de Microsoft SharePoint Foundation 2010 ;

  • le courrier électronique sortant est configuré.

    Pour plus d'informations, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010) ;

  • le travail de minuteur Avertissement du quota de disque est en cours d'exécution.

Dans cet article :

  • Créer un modèle de quota

  • Modifier un modèle de quota

  • Supprimer un modèle de quota

Créer un modèle de quota

Vous pouvez créer un modèle de quota dans le but de l'appliquer à des sites dont les contraintes de stockage et de performances sont différentes de celles de la plupart des autres sites de la collection de sites.

Pour créer un modèle de quota

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Spécifier les modèles de quotas.

  4. Dans la page Modèles de quotas, dans la section Nom du modèle, cliquez sur Créer un nouveau modèle de quota.

  5. Dans la zone Nom du nouveau modèle, tapez le nom du nouveau modèle.

    Si vous voulez baser votre nouveau modèle sur un modèle de quota existant, développez la liste Modèle de départ, puis cliquez sur le modèle souhaité.

  6. Dans la section Valeurs de limite de stockage, spécifiez les valeurs à appliquer au modèle.

    • Si vous souhaitez limiter la capacité de stockage de données, cliquez sur la case à cocher Limiter le stockage du site à une valeur maximale de, puis tapez la limite de stockage, en mégaoctets, dans la zone.

    • Si vous voulez qu'un message électronique soit envoyé à l'administrateur de la collection de sites lorsqu'un certain seuil de stockage est atteint, cliquez sur la case à cocher Envoyer un avertissement par courrier électronique lorsque le stockage sur la collection de sites atteint, puis tapez le seuil, en mégaoctets, dans la zone.

  7. Dans la section Solutions en mode bac à sable avec limites de code, définissez les valeurs d'un modèle pour solutions en mode bloc.

    1. Dans la zone Limiter l'utilisation maximale quotidienne à, tapez l'utilisation quotidienne en points.

    2. Dans la zone Envoyer un avertissement par courrier électronique lorsque l'utilisation quotidienne atteint, tapez la limite d'avertissement d'utilisation quotidienne en points.

      Un point est une mesure relative d'utilisation des ressources, par exemple, les cycles de processeur, la mémoire ou les défauts de page. Les points permettent de comparer des mesures d'utilisation des ressources qui ne pourraient pas être comparées autrement.

      Pour plus d'informations, voir Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010).

      Si vous ne voulez pas envoyer de message électronique d'avertissement, désactivez la case à cocher Envoyer un avertissement par courrier électronique lorsque l'utilisation quotidienne atteint.

  8. Cliquez sur OK.

Modifier un modèle de quota

Vous pouvez modifier un modèle de quota pour augmenter la limite de stockage si vous constatez que les sites dépassent régulièrement la limite de stockage actuelle.

Pour modifier un modèle de quota

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Spécifier les modèles de quotas.

  4. Dans la page Modèles de quotas, dans la section Nom du modèle, développez la liste Modèle à modifier, puis cliquez sur le modèle que vous souhaitez modifier.

  5. Modifier les paramètres nécessaires, puis cliquez sur OK.

Supprimer un modèle de quota

Vous pouvez supprimer un modèle de quota dès lors que la collection de sites qui avait besoin de ces paramètres spécifiques est supprimée.

Pour supprimer un modèle de quota

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Spécifier les modèles de quotas.

  4. Dans la section Nom du modèle, développez la liste Modèle à modifier, puis cliquez sur le modèle que vous souhaitez supprimer.

  5. Au bas de la page Modèles de quotas, cliquez sur Supprimer, puis sur OK.

Historique des modifications


Gérer les limites de stockage de collection de sites (SharePoint Foundation 2010)
Voir aussi

Un quota spécifie les valeurs de limite de stockage pour la quantité maximale de données pouvant être stockées dans une collection de sites. Les quotas spécifient également la taille de stockage qui, lorsqu'elle est atteinte, déclenche une alerte par courrier électronique à destination de l'administrateur de la collection de sites. Les quotas peuvent être enregistrés sous forme de modèles de quotas qui peuvent ensuite être appliqués à une collection de sites dans une batterie de serveurs SharePoint. Utiliser des modèles de quotas plutôt que des quotas individuels permet de simplifier la définition des limites de stockage dans les nouvelles collections de sites.

Remarque :
La limite de stockage s'applique à la collection de sites dans son ensemble. En d'autres termes, elle s'applique à la somme des tailles de contenu du site de niveau supérieur et de tous les sous-sites de la collection de sites. Si le contrôle de version est activé, les versions présentes dans un site et le contenu des Corbeilles sont comptabilisés dans le calcul des limites de stockage. Vous pouvez également spécifier un pourcentage de limite de stockage pour la Corbeille secondaire. Pour plus d'informations sur les paramètres de la Corbeille, voir Configurer les paramètres de la Corbeille (SharePoint Foundation 2010).

Lorsque la collection de sites atteint le niveau de stockage maximal, un message électronique contenant des informations sur le problème est envoyé à l'administrateur de la collection de sites. Celui-ci peut alors soit supprimer du contenu non utilisé, soit demander à un membre du groupe Administrateurs de batterie d'augmenter les limites. Un administrateur de batterie peut modifier les limites en procédant de l'une des façons suivantes :

  • Modifier la limite de stockage dans le modèle de quota utilisé par la collection de sites.

    Important :
    Le modèle de quota modifié n'est pas appliqué automatiquement aux collections de sites existantes qui utilisent le modèle de quota. Un membre du groupe Administrateurs de batterie doit appliquer manuellement toutes les valeurs modifiées à tous les sites existants qui utilisent le modèle de quota.

  • Désigner un nouveau modèle de quota qui offre une limite de stockage supérieure à la collection de sites. Les limites de la collection de sites deviennent automatiquement celles du modèle de quota nouvellement désigné. Il s'agit de la méthode préférée, car les paramètres du nouveau modèle de quota sont automatiquement appliqués à la collection de sites, sans qu'aucune autre action ne soit nécessaire de la part de l'utilisateur.

  • Modifier manuellement la limite de stockage de la collection de sites. Les limites définies dans le modèle de quota actuellement appliqué à la collection de sites sont ainsi remplacées.

Dans cet article :

  • Modifier les paramètres d'un modèle de quota

  • Modifier le modèle de quota d'une collection de sites

  • Modifier les limites de stockage d'une collection de sites

Modifier les paramètres d'un modèle de quota

Pour que ces options soient disponibles dans l'Administration centrale, vous devez avoir déjà créé un ou plusieurs modèles. La première fois que vous utilisez cette page, il vous est uniquement proposé de créer un nouveau modèle.

Remarque :
Le modèle de quota modifié n'est pas appliqué automatiquement aux collections de sites existantes qui utilisent le modèle de quota. Un membre du groupe Administrateurs de batterie doit appliquer manuellement toutes les valeurs modifiées à tous les sites existants qui utilisent le modèle de quota.

Pour modifier les paramètres d'un modèle de quota à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Spécifier les modèles de quotas.

  4. Dans la page Modèles de quotas, dans la section Nom du modèle, dans la liste Modèle à modifier, sélectionnez le modèle que vous souhaitez modifier.

  5. Dans la section Valeurs de limite de stockage, spécifiez les valeurs à appliquer au modèle.

    • Si vous voulez modifier la quantité de données qui peut être stockée dans la base de données, laissez la case à cocher Limiter le stockage du site à une valeur maximale activée, puis tapez la nouvelle limite de stockage, en mégaoctets, dans la zone de texte.

    • Si vous voulez qu'un message électronique soit envoyé à l'administrateur de la collection de sites lorsqu'un seuil de stockage est atteint, activez la case à cocher Envoyer un avertissement par courrier électronique lorsque le stockage sur le site atteint, puis tapez le seuil, en mégaoctets, dans la zone.

  6. Cliquez sur OK.

Modifier le modèle de quota d'une collection de sites

Si une collection de sites est sur le point de dépasser les limites de stockage et que vous souhaitez augmenter sa taille, vous pouvez remplacer le modèle de quota appliqué à la collection de sites par un autre, qui possède des limites plus élevées. Les limites d'avertissement et de stockage sont alors mises à jour automatiquement pour la collection de sites, qui reste synchronisée avec les valeurs spécifiées dans un modèle de quota. Pour modifier le modèle de quota d'une collection de sites, utilisez les procédures suivantes.

Pour modifier le modèle de quota d'une collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Configurer les quotas et les verrous.

    La page Quotas et verrous de collection de sites s'ouvre.

  4. Si vous souhaitez modifier la collection de sites sélectionnée, dans la section Collection de sites, développez la liste Collection de sites, puis cliquez sur Changer de collection de sites. Utilisez la page Sélectionner la collection de sites pour sélectionner une collection de sites.

  5. Dans la page Quotas et verrous de collection de sites, dans la section Informations sur les quotas du site, développez la liste Modèle de quota actuel, puis sélectionnez le nouveau modèle de quota à appliquer.

  6. Cliquez sur OK.

Pour modifier le modèle de quota d'une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    Set-SPSite -Identity "<Site>" -QuotaTemplate "<Template>"

    Où :

    • <Site> correspond à l'URL ou au GUID de la collection de sites dont vous voulez modifier le modèle de quota.

    • <Template> correspond au nom ou au GUID du modèle de remplacement.

Pour plus d'informations, voir Set-SPSite.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Modifier les limites de stockage d'une collection de sites

Pour modifier les limites de stockage d'une collection de sites, utilisez les procédures suivantes.

Pour modifier les limites de stockage d'une collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Configurer les quotas et les verrous.

    La page Quotas et verrous de collection de sites s'ouvre.

  4. Si vous souhaitez modifier la collection de sites sélectionnée, dans la section Collection de sites, développez la liste Collection de sites, puis cliquez sur Changer de collection de sites. Utilisez la page Sélectionner la collection de sites pour sélectionner une collection de sites.

  5. Si la collection de sites utilise actuellement un modèle de quota, spécifiez un quota individuel comme suit :

    • Dans la page Quotas et verrous de collection de sites, dans la section Informations sur les quotas du site, développez la liste Modèle de quota actuel, puis sélectionnez Quota individuel.

  6. Laissez la case à cocher Limiter le stockage du site à une valeur maximale de activée, puis tapez la nouvelle valeur maximale en mégaoctets.

  7. Si vous souhaitez envoyer des messages électroniques de notification à l'administrateur de la collection de sites à propos du stockage de site, activez la case à cocher Envoyer un avertissement par courrier électronique lorsque le stockage sur le site atteint, puis tapez la valeur d'avertissement en mégaoctets.

  8. Cliquez sur OK.

Pour modifier les limites de stockage d'une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    Set-SPSite -Identity "<Site>" -MaxSize <Limit>

    Où :

    • <Site> correspond à l'URL de la collection de sites dont vous voulez modifier les limites de stockage.

    • <Limit> est la nouvelle limite de stockage de la collection de sites, en mégaoctets.

      Remarque :
      La nouvelle limite de stockage remplace celle définie dans le modèle de quota actuellement appliqué à la collection de sites.

Pour plus d'informations sur l'applet de commande Set-SPSite, voir Set-SPSite.

Voir aussi

Concepts

Créer, modifier et supprimer des modèles de quota (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
24 juin 2010 | 2010/06/21 | Mise à jour du contenu


Gérer des types de fichiers bloqués (SharePoint Foundation 2010)

Vous pouvez empêcher certains types de fichiers d'être chargés ou téléchargés. Chaque application Web conserve une liste de types de fichiers bloqués en fonction de leur extension de nom de fichier. Par exemple, vous pouvez bloquer les fichiers ayant pour extension .exe, car ces fichiers peuvent être exécutés sur l'ordinateur client et renfermer du code malveillant.

Par défaut, de nombreux types de fichiers sont bloqués, y compris les types de fichiers considérés comme des exécutables par Internet Explorer. Les fichiers avec accolades (par exemple nom_fichier.{doc}) sont également bloqués par défaut.

Le tableau suivant présente les types de fichiers bloqués par défaut et leurs extensions de nom de fichier correspondantes.

Extension de nom de fichier | Type de fichier
.ade | Extension de projet Microsoft Access
.adp | Projet Microsoft Access
.app | Fichier d'application
.asa | Fichier de déclarations ASP
.ashx | Fichier de gestionnaire Web ASP.NET. Les gestionnaires Web sont des modules logiciels qui traitent les requêtes HTTP brutes reçues par ASP.NET.
.asmx | Fichier source des services Web ASP.NET
.asp | Pages ASP
.bas | Module de classe Microsoft Visual Basic
.bat | Fichier de commandes
.cdx | Index composé
.cer | Fichier de certificat
.chm | Fichier HTML compilé
.class | Fichier de classe Java
.cmd | Script de commande Microsoft Windows NT
.com | Programme Microsoft MS-DOS
.config | Fichier de configuration
.cpl | Extension du Panneau de configuration
.crt | Certificat de sécurité
.csh | Fichier de script
.dll | Bibliothèque de liens dynamiques Windows
.exe | Programme
.fxp | Programme compilé Microsoft Visual FoxPro
.hlp | Fichier d'aide
.hta | Programme HTML
.htr | Fichier de script
.htw | Document HTML
.ida | Fichier IIS (Internet Information Services)
.idc | Fichier de connexion de base de données Internet
.idq | Fichier de requête de données Internet
.ins | Internet Naming Service
.isp | Paramètres de communication Internet
.its | Fichier d'ensemble de documents Internet
.jse | Fichier de script encodé JScript
.ksh | Fichier de script Korn Shell
.lnk | Raccourci
.mad | Raccourci
.maf | Raccourci
.mag | Raccourci
.mam | Raccourci
.maq | Raccourci
.mar | Raccourci
.mas | Procédure stockée Microsoft Access
.mat | Raccourci
.mau | Raccourci
.mav | Raccourci
.maw | Raccourci
.mda | Programme complémentaire Microsoft Access
.mdb | Programme Microsoft Access
.mde | Base de données MDE Microsoft Access
.mdt | Fichier de données Microsoft Access
.mdw | Groupe de travail Microsoft Access
.mdz | Programme Assistant Microsoft Access
.msc | Document de la console commune Microsoft
.msh | Assistance de script Microsoft Agent
.msh1 | Assistance de script Microsoft Agent
.msh1xml | Assistance de script Microsoft Agent
.msh2 | Assistance de script Microsoft Agent
.msh2xml | Assistance de script Microsoft Agent
.mshxml | Assistance de script Microsoft Agent
.msi | Package Microsoft Windows Installer
.msp | Fichier de package correctif Windows Installer
.mst | Fichiers sources Visual Test
.ops | Fichier de paramètres de profil Microsoft Office
.pcd | Image Photo CD ou script Microsoft Visual compilé Test
.pif | Raccourci vers le programme MS-DOS
.prf | Fichier système
.prg | Fichier source de programme
.printer | Fichier d'imprimante
.pst | Fichier de dossier personnel Microsoft Outlook
.reg | Entrées d'inscription
.rem | Fichier de maintenance de base de données ACT!
.scf | Fichier de commande Explorateur Windows
.scr | Écran de veille
.sct | Fichier de script
.shb | Raccourci Windows
.shs | Objet Bribes
.shtm | Fichier HTML qui contient des directives côté serveur
.shtml | Fichier HTML qui contient des directives côté serveur
.soap | Fichier SOAP (Simple Object Access Protocol)
.stm | Fichier HTML qui contient des directives côté serveur
.url | Uniform Resource Locator (raccourci Internet)
.vb | Fichier Microsoft Visual Basic Scripting Edition
.vbe | Fichier de script encodé VBScript
.vbs | Fichier VBScript
.ws | Fichier de script Windows
.wsc | Composant de script Windows
.wsf | Fichier de script Windows
.wsh | Fichier de paramètres Windows Script Host

Ajouter ou supprimer des types de fichiers bloqués

Utilisez cette procédure lorsque vous souhaitez interdire l'enregistrement de fichiers d'un certain type ou leur extraction d'une application Web sur un serveur.

Pour ajouter ou supprimer des types de fichiers bloqués à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes.

    • Vous devez être administrateur de batterie sur le serveur.

  2. Dans l'Administration centrale, cliquez sur Sécurité.

  3. Dans la page Sécurité, dans la section Sécurité générale, cliquez sur Définir les types de fichiers bloqués.

  4. Dans la page Types de fichiers bloqués, si vous souhaitez modifier l'application Web sélectionnée, dans le menu Application Web, cliquez sur Modifier l'application Web. Utilisez la page Sélectionner une application Web pour sélectionner une application Web.

  5. Effectuez l'une des opérations suivantes :

    • Pour bloquer un type de fichier supplémentaire, accédez au bas de la zone de texte Tapez chaque extension de fichier sur une ligne distincte, tapez l'extension de fichier à bloquer, puis cliquez sur OK.

      Remarque :
      Vous n'avez pas besoin de respecter l'ordre alphabétique pour taper l'extension de fichier dans la liste. La prochaine fois que vous ouvrirez la liste, l'extension de fichier que vous avez ajoutée sera correctement classée par ordre alphabétique.

    • Pour faire cesser le blocage d'un type de fichier, sélectionnez le type de fichier dans la liste, appuyez sur la touche Suppr, puis cliquez sur OK.

Historique des modifications


Verrouiller ou déverrouiller les collections de sites (SharePoint Foundation 2010)

Vous pouvez appliquer des verrous afin d'empêcher les utilisateurs d'accéder à une collection de sites. Vous pouvez juger cela utile lorsqu'une collection de sites dépasse sa limite de stockage. La collection de sites peut rester verrouillée tant que la limite (ou quota) de stockage n'a pas été augmentée ou que du contenu n'a pas été supprimé.

Le tableau suivant décrit les options de verrouillage disponibles dans Microsoft SharePoint Foundation 2010.

Option | Description
Non verrouillé | Déverrouille la collection de sites et la rend accessible aux utilisateurs.
Ajout de contenu interdit | Empêche les utilisateurs d'ajouter du nouveau contenu à la collection de sites. Les mises à jour et les suppressions restent autorisées.
Lecture seule (ajouts de blocs, mises à jour et suppressions) | Empêche les utilisateurs d'ajouter, mettre à jour ou supprimer du contenu.
Aucun accès | Empêche tout accès au contenu. Les utilisateurs qui tentent d'accéder au site obtiennent un message indiquant que l'accès a été refusé.
Avertissement :
Si vous voulez limiter la quantité de contenu qui peut être stockée dans une collection de sites, vous pouvez utiliser des quotas plutôt que des verrous. Pour plus d'informations, voir Créer, modifier et supprimer des modèles de quota (SharePoint Foundation 2010).

Vous pouvez décider de verrouiller une collection de sites pour empêcher les mises à jour du contenu, voire pour interdire momentanément tout accès à la collection de sites. Vous pouvez également exécuter cette procédure pour supprimer un verrou d'une collection de sites.

Pour verrouiller ou déverrouiller une collection de sites à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez bien des informations d'identification administratives suivantes.

    • Vous devez être membre du groupe Administrateurs de collections de sites pour la collection de sites.

  2. Dans l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Configurer les quotas et les verrous.

  4. Si vous souhaitez modifier la collection de sites sélectionnée, dans la section Collection de sites, dans le menu Collection de sites, cliquez sur Changer de collection de sites. Utilisez la page Sélectionner la collection de sites pour sélectionner une collection de sites.

  5. Dans la page Quotas et verrous de collection de sites, dans la section Informations sur le verrouillage du site, sélectionnez l'une des options suivantes :

    • Non verrouillé : pour déverrouiller la collection de sites et la rendre accessible aux utilisateurs.

    • Ajout de contenu interdit : pour empêcher les utilisateurs d'ajouter du nouveau contenu à la collection de sites. Les mises à jour et les suppressions restent autorisées.

    • Lecture seule (ajouts de blocs, mises à jour et suppressions) : pour empêcher les utilisateurs d'ajouter, mettre à jour ou supprimer du contenu.

    • Aucun accès : pour empêcher tout accès au contenu. Les utilisateurs qui tentent d'accéder au site obtiennent un message indiquant que l'accès a été refusé.

  6. Si vous sélectionnez Ajout de contenu interdit, Lecture seule (ajouts de blocs, mises à jour et suppressions) ou Aucun accès, tapez le motif du verrouillage dans la zone Information supplémentaires sur le verrouillage.

  7. Cliquez sur OK.

Pour verrouiller ou déverrouiller une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À l'invite de commandes Windows PowerShell 2.0 (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    Set-SPSite -Identity "<SiteCollection>" -LockState "<State>"

    Où :

    • <SiteCollection> représente l'URL de la collection de sites que vous souhaitez verrouiller ou déverrouiller.

    • <State> est l'une des valeurs suivantes :

      • Unlock : pour déverrouiller la collection de sites et la rendre accessible aux utilisateurs.

      • NoAdditions : pour empêcher les utilisateurs d'ajouter du nouveau contenu à la collection de sites. Les mises à jour et les suppressions restent autorisées.

      • ReadOnly : pour empêcher les utilisateurs d'ajouter, mettre à jour ou supprimer du contenu.

      • NoAccess : pour empêcher tout accès au contenu. Les utilisateurs qui tentent d'accéder au site obtiennent un message indiquant que l'accès a été refusé.
Remarque :
Pour plus d'informations sur l'utilisation de l'applet de commande Set-SPSite, voir Set-SPSite.

Historique des modifications


Gérer les sites (SharePoint Foundation 2010)

Cette section explique comment gérer les sites Web dans Microsoft SharePoint Foundation 2010.

  • Gérer les sites Web inutilisés (SharePoint Foundation 2010)

    Cet article explique comment libérer l'espace de stockage alloué aux sites inactifs, que ce soit automatiquement ou en réponse à une notification d'un administrateur de collection de sites.

Historique des modifications


Gérer les sites Web inutilisés (SharePoint Foundation 2010)

La confirmation de l'utilisation et de la suppression de sites peuvent vous aider à libérer des ressources qui sont utilisées par des sites obsolètes. Les collections de sites peuvent être supprimées automatiquement au terme d'une période d'inactivité donnée ou en fonction de la réponse à une notification par le propriétaire de la collection de sites.

Remarque :
Pour envoyer des notifications par courrier électronique, vous devez configurer les paramètres de courrier électronique sortant. Pour plus d'informations, voir Configurer le courrier électronique sortant (SharePoint Foundation 2010).

Avant d'achever la procédure dans cette rubrique, vous devez déterminer les informations suivantes :

  • La durée d'attente avant de vérifier si un site est inactif.

    La période par défaut pour les sites d'équipe ou pour les sites de projet est 90 jours après la création du site. Vous pouvez aussi définir la période accordée aux propriétaires de collection de sites. Vous pouvez accorder aux propriétaires de collection de sites un minimum de 30 jours et un maximum de 365 jours de délai.

  • La fréquence d'envoi des notifications par courrier électronique aux propriétaires de site pour déterminer si leurs sites sont inactifs.

    Après l'envoi de la première notification par courrier électronique, si le propriétaire ne répond pas, vous pouvez continuer à envoyer d'autres notifications tous les jours, toutes les semaines ou tous les mois.

  • La suppression automatique de sites non utilisés ou la suppression d'un site si le propriétaire du site ne répond pas à plusieurs notifications par courrier électronique.

    Si vous supprimez des sites sans l'approbation du propriétaire, nous vous recommandons de commencer par une sauvegarde du site. Vous pouvez personnaliser cette fonctionnalité pour sauvegarder automatiquement un site avant sa suppression au moyen du Kit de développement logiciel SharePoint 2010 (SDK) (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=166675&clcid=0x40C).

  • Si vous envisagez de supprimer automatiquement des sites non utilisés, combien de notifications par courrier électronique allez-vous envoyer au propriétaire du site au préalable ?

    Par défaut, 28 notifications quotidiennes sont envoyées avant la suppression du site. Vous pouvez configurer ce nombre et choisir d'envoyer un minimum de 28 notifications et un maximum de 168. Pour des notifications hebdomadaires, vous pouvez envoyer un minimum de quatre notifications et un maximum de 24 notifications. Pour des notifications mensuelles, vous pouvez envoyer un minimum de deux notifications et un maximum de six notifications aux propriétaires de site.

    Les notifications par courrier électronique contiennent des liens pour confirmer si une collection de sites est active ou inactive. Après l'envoi d'une notification par courrier électronique au propriétaire de collection de sites, trois scénarios sont possibles :

    • Si le propriétaire confirme que la collection de sites est active en cliquant sur le lien de confirmation dans la notification reçue par courrier électronique, la date de certification du site est renouvelée.

    • Le propriétaire de la collection de sites continue de recevoir des notifications périodiques par courrier électronique selon l'intervalle de temps spécifié par un membre du groupe Administrateurs de batterie tant qu'il n'a pas confirmé que la collection de sites est active ou qu'il a supprimé la collection.

    • Si la collection de sites n'est pas active et qu'un membre du groupe Administrateurs de batterie a activé la fonctionnalité de suppression automatique, les notifications par courrier électronique sont envoyées au propriétaire de la collection de sites pour le nombre de fois spécifiées. Si le propriétaire ne confirme pas le statut de la collection de sites, la collection est supprimée automatiquement.

Nous recommandons les méthodes suivantes pour éviter la suppression automatique d'un site :

  • Exiger un deuxième propriétaire de collection de sites lorsque les utilisateurs créent des collections de site.

    Par défaut, le créateur de la collection de sites est répertorié en tant que propriétaire principal de la collection de sites. Un propriétaire de collection de sites peut aussi spécifier un deuxième propriétaire de collection de sites. Les notifications de confirmation sont envoyées automatiquement aux propriétaires principal et secondaire de la collection de sites.

  • Tenir l'organisation informée des congés et prévoir un plan de rechange.

    Par exemple, si un propriétaire de la collection de sites s'absente pendant quatre semaines et qu'un membre du groupe Administrateurs de batterie a défini la stratégie de suppression et la collection de sites, après quatre confirmations hebdomadaires sans réponse, le site peut être supprimé sans que le propriétaire ne puisse confirmer l'utilisation du site.

  • Vérifiez qu'il existe un planning pour sauvegarder les collections de sites régulièrement afin de restaurer une copie récente si une collection de sites est supprimée.

    Remarque :
    La suppression automatique supprime de manière permanente l'ensemble du contenu et des informations de la collection de sites et des sites contenus dans cette collection.

Gérer les sites Web inutilisés

Utilisez cette procédure pour gérer les sites Web inutilisés. Ces étapes vous permettent de déterminer la planification des notifications que recevront les propriétaires pour les prévenir de l'inactivité des sites avant la suppression des sites inutilisés.

Pour gérer les sites Web inutilisés

  1. Vérifiez que vous disposez de la configuration minimale requise suivante :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs.

  2. Dans la page d'accueil de l'Administration Centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Confirmer l'utilisation et la suppression du site.

  4. Dans la page Confirmer l'utilisation et la suppression du site, dans la section Application Web, si l'application Web que vous souhaitez configurer n'est pas répertoriée, développez la liste Application Web, puis cliquez sur Modifier l'application Web.

    Dans la boîte de dialogue Sélectionner l'application Web, cliquez sur l'application Web que vous souhaitez configurer.

  5. Dans la section Paramètres de suppression et de confirmation automatique :

    • Activez ou désactivez la case à cocher Envoyer des notifications par courrier électronique aux propriétaires de collections de sites inutilisées.

      Si vous activez cette case à cocher, tapez le nombre de jours, après confirmation de la création du site ou de son utilisation, pour commencer l'envoi des notifications. Le nombre minimal de jours est 30 et le nombre maximal 365.

    • Spécifiez un planning journalier, hebdomadaire ou mensuel pour les notifications par courrier électronique. Le planning par défaut est journalier. Vous pouvez aussi spécifier l'heure exacte à laquelle exécuter la vérification de l'utilisation du site. L'heure par défaut est minuit.

    • Activez ou désactivez la case à cocher Supprimer automatiquement la collection de sites si son utilisation n'est pas confirmée.

      Si vous activez cette case à cocher, tapez le nombre de notifications à envoyer avant la suppression de la collection de sites. Le paramètre par défaut est 28 notifications.

  6. Cliquez sur OK.

Historique des modifications


Gérer des composants WebPart (SharePoint Foundation 2010)

Les composants WebPart sont des éléments modulaires qui présentent les informations sur des pages de sites SharePoint. Pour plus d'informations sur les composants WebPart, lisez la section relative aux composants WebPart dans Windows SharePoint Services (http://go.microsoft.com/fwlink/?linkid=184240&clcid=0x40C) au sein du Kit de développement logiciel (SDK) SharePoint Foundation 2010.

Cet article vous aide à préparer la gestion de la sécurité pour les pages et contrôles WebPart qui sont utilisés avec SharePoint Foundation 2010.

Dans Microsoft SharePoint Foundation, une page de composants WebPart est une collection de composants WebPart qui associe des données de liste, des informations mises à jour ou des graphismes utiles dans une page Web dynamique. La disposition et le contenu d'une page de composants WebPart peuvent être définis pour tous les utilisateurs et éventuellement personnalisés pour chaque utilisateur. Le propriétaire d'un site ou un membre de site ayant les autorisations appropriées peut créer et personnaliser des pages de composants WebPart à l'aide d'un navigateur pour ajouter, reconfigurer ou supprimer des composants WebPart.

L'utilisation des composants WebPart ne se limite pas aux pages de composants WebPart. Vous pouvez ajouter ces derniers directement à des pages Wiki, des pages de contenu et des pages de publication.

Vous pouvez configurer les composants WebPart dans SharePoint Foundation pour qu'ils s'exécutent dans des solutions en mode bac à sable (sandbox). Ces dernières empêchent les composants WebPart d'accéder à certaines ressources locales ou réseau, ce qui permet de protéger les autres contenus et solutions de la batterie de serveurs SharePoint Foundation. En implémentant des solutions en mode bac à sable (sandbox), les utilisateurs peuvent ajouter leurs propres composants WebPart dans un environnement hébergé. Par ailleurs, les développeurs peuvent ajouter des composants WebPart qui n'ont pas encore été complètement testés dans un environnement de production.

Pour plus d'informations sur les solutions bac à sable (sandbox), voir Planification de solutions en mode bac à sable (SharePoint Foundation 2010).

L'infrastructure des composants WebPart dans SharePoint Foundation figure sur une couche située au-dessus de l'infrastructure des composants WebPart ASP.NET. Pour protéger efficacement les sites SharePoint, les administrateurs de serveur doivent connaître les consignes de sécurité et les meilleures pratiques relatives à ASP.NET. Pour plus d'informations, voir Consignes de sécurité dans ASP.NET 2.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=103423&clcid=0x40C) dans MSDN Library Online.

Sécurité pour les pages de composants WebPart et les contrôles

La protection des pages et des contrôles WebPart est un effort collectif. Les développeurs, les administrateurs de site et les administrateurs de serveur doivent collaborer pour améliorer la sécurité des composants WebPart et des pages de composants WebPart. Les développeurs doivent valider l'entrée des composants WebPart afin de protéger les serveurs contre les attaques. Les administrateurs de serveur doivent configurer les services Internet (IIS) afin d'utiliser une méthode d'authentification appropriée.

Les administrateurs de serveur configurent et déploient également des solutions de composants WebPart sur un serveur Web ou une batterie de serveurs Web. Une fois la solution déployée, les administrateurs de site ou administrateurs de serveur définissent les niveaux d'autorisation et les autorisations qui permettent d'accéder aux pages de composants WebPart.

Le tableau suivant présente les rôles de sécurité responsables de la configuration des autorisations pour les pages de composants WebPart et les composants WebPart.

Rôle Catégorie S'applique à Description Recommandations

Développeur

Validation d'entrée

Code de composant WebPart

La validation d'entrée fait référence à la manière dont votre application filtre, nettoie ou rejette l'entrée avant de poursuivre le traitement. Cela inclut la vérification de l'entrée que votre application reçoit afin de s'assurer qu'elle est valide et sûre.

Création de pages et de contrôles ASP.NET sûrs (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=103423&clcid=0x40C) (Bibliothèque en ligne MSDN)

Procédure pas à pas : création d'un composant WebPart SharePoint de base (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=103425&clcid=0x40C) (Bibliothèque en ligne MSDN)

Administrateur de serveur

Authentification

IIS

L'authentification est le processus selon lequel une entité valide l'identité d'une autre entité, généralement par le biais d'informations d'identification telles qu'un nom d'utilisateur et un mot de passe.

Planifier l'authentification (SharePoint Foundation 2010)

Administrateur de site/administrateur de serveur

Autorisation

Collections de sites

L'autorisation est le processus qui fournit des contrôles d'accès pour les sites Web, les listes, les dossiers ou les éléments en déterminant quels utilisateurs peuvent effectuer des actions spécifiques sur un objet donné. Le processus d'autorisation suppose que l'utilisateur a déjà été authentifié.

Autorisation et authentification (http://go.microsoft.com/fwlink/?linkid=103428&clcid=0x40C) (Bibliothèque en ligne MSDN)

Administrateur de serveur

Gestion de la configuration

Configuration de .NET Framework

La gestion de la configuration englobe un vaste éventail de paramètres qui permettent à l'administrateur de gérer l'application Web et son environnement. Ces paramètres sont stockés dans des fichiers de configuration XML, dont certains contrôlent des paramètres au niveau de l'ordinateur, tandis que d'autres contrôlent des configurations spécifiques à l'application. Vous pouvez définir des contraintes de sécurité spéciales dans les fichiers de configuration et des autorisations de sécurité d'accès au code au niveau de l'ordinateur.

« Sécurité d'accès au code » dans « Sécurisation de votre serveur Web » (http://go.microsoft.com/fwlink/?linkid=103431&clcid=0x40C) (Bibliothèque en ligne MSDN)

Microsoft Windows SharePoint Services et la sécurité d'accès au code (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=103436&clcid=0x40C) (Bibliothèque en ligne MSDN)

Utilisation de la sécurité d'accès au code avec ASP.NET (http://go.microsoft.com/fwlink/?linkid=103438&clcid=0x40C) (Bibliothèque en ligne MSDN)

Contenu de cette section

Configurer et déployer des composants WebPart (SharePoint Foundation 2010)

Historique des modifications


Configurer et déployer des composants WebPart (SharePoint Foundation 2010)

Cet article fournit les informations et procédures nécessaires pour configurer et déployer des composants WebPart sécurisés dans le répertoire Bin ou le GAC (Global Assembly Cache) du .NET Framework sur votre serveur.

Dans cet article :

  • Options de configuration

  • Définition des attributs de sécurité

  • Liste des contrôles fiables

  • Déployer et configurer un composant WebPart

  • Ajouter un composant à la galerie de composants WebPart

Microsoft SharePoint Foundation comprend un ensemble de composants WebPart que les utilisateurs peuvent ajouter aux pages après l'installation du produit. Si une organisation a besoin de composants WebPart personnalisés, un développeur peut écrire des composants WebPart ASP.NET personnalisés et vous inviter à les installer dans un déploiement de SharePoint Foundation. Ce processus exige généralement le test et l'approbation du code avant que le composant WebPart ne puisse être déployé dans un environnement de confiance totale. Un développeur qui utilise Visual Studio 2010 peut déployer un composant WebPart sur SharePoint Foundation en cliquant avec le bouton droit sur le projet, puis en sélectionnant Déployer . La destination du composant WebPart est déterminée par le niveau de confiance établi avec le serveur exécutant SharePoint lorsque le développeur a créé le projet dans Visual Studio 2010.

Microsoft SharePoint Foundation 2010 vous permet de configurer un environnement en mode bac à sable (sandbox) dans lequel les administrateurs de collection de sites, les administrateurs de site ou les travailleurs de l'information peuvent déployer et exécuter des composants WebPart et des solutions partiellement approuvés dans un processus de travail en mode bac à sable (sandbox). Les composants WebPart et les solutions qui s'exécutent dans un environnement en mode bac à sable (sandbox) disposent d'autorisations limitées pour accéder au système d'exploitation et au matériel du serveur ; par ailleurs, ils sont isolés des autres composants de l'application Web.

Pour plus d'informations sur l'utilisation de solutions en mode bac à sable (sandbox), voir Administration de solutions en mode bac à sable (SharePoint Foundation 2010).

SharePoint Foundation utilise certains des paramètres de gestion de configuration fournis par Microsoft .NET Framework. Certains de ces paramètres sont stockés dans les fichiers de configuration XML et fournissent un large éventail de paramètres qui permettent aux administrateurs de serveur de gérer l'application Web et son environnement. Pour plus d'informations sur les fichiers de configuration ASP.NET, voir Description de Machine.Config et de Web.Config (http://go.microsoft.com/fwlink/?linkid=103450&clcid=0x40C) dans « Sécurisation de votre application ASP.NET et de vos services Web » sur MSDN Library Online.

Options de configuration

Les administrateurs système peuvent déployer des composants WebPart ASP.NET dans un déploiement de SharePoint Foundation à deux emplacements au choix :

  • Répertoire Bin Stockage dans le dossier bin sous le répertoire racine de votre application Web.

  • GAC (Global Assembly Cache) Tous les composants WebPart standard sont automatiquement installés dans le GAC, où se trouve le Common Language Runtime du .NET Framework, à l'emplacement %windir%\assembly. Les composants WebPart stockés dans le GAC peuvent être partagés entre les applications.

Le tableau suivant décrit les avantages et inconvénients de chaque emplacement.

Emplacement de déploiement Avantages Inconvénients

Répertoire Bin

Emplacement de confiance partielle. Par défaut, le code qui s'exécute à partir de ce répertoire a un faible niveau d'autorisations en matière de sécurité d'accès du code. Si le composant WebPart requiert un accès entre des applications ou un accès plus important par rapport aux autorisations par défaut, l'administrateur doit élever explicitement les autorisations accordées à un composant WebPart, de sorte qu'il puisse fonctionner correctement. Les administrateurs peuvent préférer que les assemblys s'exécutent dans le répertoire Bin, avec un ensemble minimal connu d'autorisations obligatoires en matière de sécurité d'accès du code.

Dans la mesure où le répertoire Bin est spécifique à une application Web, vous pouvez utiliser cette méthode afin d'isoler le code pour une seule application Web.

Pour exécuter votre composant WebPart n'importe où, vous devez déployer votre assembly dans le répertoire Bin de chaque serveur.

GAC

Emplacement global où vous pouvez déployer des assemblys signés qui peuvent s'exécuter par défaut avec une confiance totale. Dans la mesure où les assemblys sont installés globalement, ils fonctionnent dans n'importe quelle application Web.

En règle générale, il n'existe pas de restrictions de sécurité d'accès du code sur le code installé dans le GAC ; par conséquent, vous perdez l'avantage de la sécurité avec protection renforcée.

En outre, il peut être difficile de déployer vos fichiers de base de données de programme (.pdb) dans des assemblys du GAC.

Définition des attributs de sécurité

Les composants WebPart ASP. NET stockés dans le répertoire Bin ont des attributs de sécurité supplémentaires. Vous pouvez définir ou non ces attributs pour vos composants WebPart ; cela dépend de la manière dont vous souhaitez les utiliser.

Le répertoire Bin est un emplacement de confiance partielle. Par conséquent, votre composant WebPart ne reçoit pas automatiquement des autorisations de confiance totale pour le code lors de son exécution. Étant donné que le code appelant de votre composant WebPart bénéficie simplement d'autorisations de confiance partielle, le développeur doit définir l'attribut AllowPartiallyTrustedCallers pour votre composant WebPart ASP.NET.

Le fait de déclarer un composant comme étant fiable avec l'attribut AllowPartiallyTrustedCallers engage la responsabilité de l'équipe de développement pour une mise en œuvre sécurisée.

Par défaut, les autorisations de sécurité d'accès du code pour le répertoire Bin sont très faibles. Testez vos composants WebPart avec soin afin de déterminer le niveau approprié des autorisations à attribuer, et de vérifier que les composants WebPart ne présentent pas de risques de sécurité pour votre environnement.

Il existe deux façons d'élever des autorisations :

  • (Méthode recommandée) Créez un fichier de stratégie d'approbation et faites pointer votre fichier Web.config vers ce nouveau fichier. Cette méthode est plus complexe, mais elle vous permet de définir plus précisément les autorisations de vos composants WebPart. Pour plus d'informations sur les fichiers de stratégie d'approbation, voir la page relative à Microsoft Windows SharePoint Services et la sécurité d'accès du code (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=103436&clcid=0x40C) dans MSDN Library Online.

  • Élevez le niveau de confiance global du répertoire Bin. Dans le fichier Web.config du répertoire racine de votre application Web, trouvez l'élément trust. La valeur par défaut de l'attribut level de l'élément trust est WSS_Minimal. Vous pouvez élever ce niveau à WSS_Medium. Cette méthode est plus simple, mais elle accorde arbitrairement de nouvelles autorisations dont vous n'avez peut-être pas besoin ; en outre, elle est moins fiable que l'autre méthode, qui consiste à créer un fichier de stratégie d'approbation.

Liste des contrôles fiables

Un des principes fondamentaux des produits SharePoint veut que les utilisateurs non approuvés puissent télécharger et créer des pages .aspx dans le système sur lequel s'exécute SharePoint Foundation. Il faut empêcher ces utilisateurs d'ajouter du code côté serveur dans les pages .aspx, mais les laisser utiliser une liste de contrôles approuvés. SharePoint Foundation fournit cette liste.

La liste des contrôles fiables contient les noms des contrôles et des composants WebPart spécifiques à votre site SharePoint, que les administrateurs de serveur peuvent désigner comme étant suffisamment fiables pour être appelés sur n'importe quelle page .aspx d'un site. Cette liste fait partie du fichier Web.config situé à la racine de votre application Web.

Déployer et configurer un composant WebPart

La méthode que vous utilisez pour déployer un nouveau composant WebPart dépend du package fini fourni par le développeur. Si le développeur vous a fourni le composant WebPart sous forme de fichier de bibliothèque de liens dynamiques (DLL), vous pouvez déployer manuellement la DLL en la copiant vers le dossier Bin de votre application Web. Si le développeur vous a fourni un fichier CAB qui contient le composant WebPart, vous pouvez utiliser Windows PowerShell pour déployer le composant WebPart.

Pour déployer et configurer manuellement un composant WebPart

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs local sur le serveur qui héberge SharePoint Foundation.

  2. Copiez l'assembly <YourWebPartName>.dll du répertoire Bin du projet dans le répertoire Bin du répertoire racine de votre application Web. Par exemple : C:\inetpub\wwwroot\wss\VirtualDirectories\80\.

  3. Localisez le fichier Web.config dans le répertoire racine de votre application et ouvrez-le afin de le modifier.

  4. Ajoutez l'entrée de contrôle sécurisé suivante dans le fichier Web.config pour votre assembly personnalisé :

    Code de copie
    <SafeControl Assembly="<YourWebPartName>, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null" Namespace="<YourWebPartNamespace>" TypeName="*" Safe="True" AllowRemoteDesigner="True"/>

    Où :

    1. <YourWebPartName> représente le nom du composant WebPart déployé.

    2. <YourWebPartNamespace> représente l'espace de noms associé à votre composant WebPart.

Comme alternative à l'installation manuelle d'un composant WebPart dans le dossier Bin ou la modification manuelle du fichier Web.config, vous pouvez utiliser Windows PowerShell pour installer le package de composants WebPart. Pour que ce processus fonctionne, un développeur ou un administrateur système doit créer un package de solution CAB pour le composant WebPart. Pour plus d'informations sur la création d'un package CAB, voir la documentation relative à Solutions et packages de composants WebPart (http://go.microsoft.com/fwlink/?linkid=95855&clcid=0x40C) dans MSDN Library Online. Une fois que vous avez créé un fichier CAB, procédez comme suit pour déployer le composant WebPart.

Pour déployer le composant WebPart à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell (PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    Code de copie
    Install-SPWebPartPack -LiteralPath "<PathToCabFile>" -Name "<WebPartName>"

    Où :

    • <PathToCabFile> représente le chemin d'accès complet du fichier CAB en cours de déploiement.

    • <WebPartName> représente le nom du composant WebPart déployé.
Remarque :
La procédure précédente montre une façon usuelle d'utiliser Install-SPWebPartPack pour déployer un composant WebPart. Vous pouvez spécifier des paramètres supplémentaires afin de modifier la façon dont le composant WebPart est déployé. Pour plus d'informations, voir Install-SPWebPartPack.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Ajouter un composant à la galerie de composants WebPart

Tous les composants WebPart ont en principe un fichier .webpart, qui est un fichier XML destiné à les décrire. C'est également grâce à ce fichier .webpart que votre composant WebPart figure dans la galerie des composants WebPart. La procédure suivante représente le meilleur moyen de créer un fichier .webpart après avoir déployé le composant WebPart, et de l'inscrire dans la liste des contrôles fiables.

Pour ajouter un composant à la galerie de composants WebPart

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs.

  2. Pour créer un fichier .webpart, accédez à http://<MonServeur>/_layouts/newdwp.aspx, où <MonServeur> est le nom du serveur sur lequel votre site SharePoint est déployé.

  3. Activez la case à cocher à côté de <YourWebPartNamespace>.<YourWebPartName>.

  4. Cliquez sur Compléter la galerie pour ajouter le composant WebPart YourWebPartName à la galerie Site d'équipe.

  5. Dans la galerie de composants WebPart, sélectionnez Modifier pour modifier le composant WebPart, puis cliquez sur Importer.

    Vous êtes invité à spécifier un emplacement pour le fichier .webpart. Vous pouvez également exporter les composants WebPart ASP.NET et les importer dans des sites SharePoint.

Historique des modifications


Business Connectivity Services security operations (SharePoint Foundation 2010) (en anglais)
Voir aussi

This article describes security-related administrative tasks for your Business Data Connectivity service application.

In this article:

  • Assign administrators to a Business Data Connectivity service application

  • Set permissions on a metadata store

  • RevertToSelf authentication mode

  • Workflows and external lists

Assign administrators to a Business Data Connectivity service application

Farm administrators can delegate administration of a specific service Connexion de données métiers application to a service application administrator. The delegated administrator is given access to the Central Administration Web site and can perform administrative tasks that are related to that service Connexion de données métiers application.

Conseil :
The delegated administrator is not given permissions to the metadata store.

To assign administrators to a Business Data Connectivity service application

  1. Verify that you have the following administrative credentials:

    • You must be a farm administrator.

  2. On the Central Administration Web site, in the Application Management section, click Manage service applications.

  3. In the list of service applications, click the row that contains the service Connexion de données métiers application.

  4. On the Service Applications tab, in the Operations section, click Administrators.

  5. In the text box, type or select a user account or a group account, and then click Add.

  6. In the Permissions box, click Full Control, and then click OK.

Set permissions on a metadata store

Each service Connexion de données métiers application has a metadata store that includes all the models, external systems, external content types, methods, and method instances that have been defined for that store's purpose. You set permissions on a metadata store to specify who can edit items in the metadata store and who can set permissions on the metadata store.

We recommend that you give specific permissions to each user or group that needs it, in such a way that the credentials provide the least privilege that is necessary to perform the needed tasks. For more information about setting permissions, see Vue d'ensemble des autorisations de Business Connectivity Services in "Business Connectivity Services security overview (SharePoint Foundation 2010)".

To set permissions on a metadata store

  1. Verify that you have one of the following administrative credentials:

    • You must be a farm administrator.

    • You must be the service Connexion de données métiers application administrator and have Set Permissions permission to the metadata store.

  2. On the Central Administration Web site, in the Application Management section, click Manage service applications.

  3. In the list of service applications, click the row that contains the service Connexion de données métiers application.

  4. On the Service Applications tab, in the Operations section, click Manage.

  5. On the Edit tab, in the Permissions group, click Set Metadata Store Permissions.

  6. In the text box, type the user accounts, groups, or claims for which permissions will be granted, and then click Add.

    Remarque :
    The user account, group, or claim cannot have a vertical bar (|) in its name.

  7. Set the permissions for the account, group, or claim:

    Remarque :
    At least one user, group, or claim in the metadata object's access control list must have the Set Permissions permission.

    • Click Edit to allow the user, group, or claim to create external systems, to create models, to import models, and to export models.

      Sécurité Remarque :
      The Edit permission should be considered highly privileged. With the Edit permission, a malicious user can steal credentials or corrupt a server farm. To help ensure a secure solution, we recommend that you use a test environment where the Edit permission can be assigned freely to developers and solution designers. When you deploy the tested solution to a production environment, remove the Edit permissions.

    • Click Execute to allow the user, group, or claim to execute operations (create, read, update, delete, or query) on external content types.

      Conseil :
      The Execute permission is not applicable to the metadata store itself. This setting is used when you want to propagate the Execute permission to child objects in the metadata store.

    • Click Selectable In Clients to allow the user, group, or claim to create external lists of any external content types and to view the external content types in the external item picker.

      Conseil :
      The Selectable In Clients permission is not applicable to the metadata store itself. This setting is used when you want to propagate the Selectable In Clients permission to child objects in the metadata store.

    • Click Set Permissions to allow the user, group, or claim to set permissions on the metadata store.

      Sécurité Remarque :
      The Set Permissions permission should be considered highly privileged. With the Set Permissions permission, a user can grant Edit permission to the metadata store.

  8. To propagate permissions to all items in the metadata store, click Propagate permissions to all BDC Models, External Systems and External Content Types in the BDC Metadata Store. Doing so will overwrite existing permissions.

RevertToSelf authentication mode

Each external content type has an associated authentication mode. The authentication mode gives Business Connectivity Services information about how to process an incoming authentication request from a user and maps that request to a set of credentials that can be passed to the external system. By default, the RevertToSelf authentication mode (also called BDC Identity authentication mode) is not enabled. You cannot create or import models that use RevertToSelf when RevertToSelf authentication mode is not enabled.

RevertToSelf authentication mode uses the application pool account where the Business Connectivity Services is running to authenticate the logged-on user to the external system. For example, when a user opens an external list, the application pool account of the front-end Web server where the external list resides is used for authentication. The application pool account is a highly privileged account. By default, the application pool account has write permission to the farm configuration database. By using RevertToSelf mode, anyone who can create or edit a model that uses RevertToSelf mode has the power to make themselves an administrator of the SharePoint farm.

RevertToSelf authentication mode is not recommended for production environments. We recommend that you develop a custom, single sign-on provider.

If you must use RevertToSelf authentication mode in a production environment, consider the following:

  • Any users who can create or edit models, including SharePoint Designer users, should be considered equal to a farm administrator from a security perspective. You must be able to trust them as you would a farm administrator.

  • You must lock down the use of the application pool account as much as possible. Doing so can help to limit the damage a malicious user can do to the SharePoint farm and external systems.

Enable RevertToSelf authentication mode

After you enable RevertToSelf authentication mode, new models that use RevertToSelf can be created and imported.

Sécurité Remarque :
We do not recommend RevertToSelf authentication mode for production environments. Before enabling RevertToSelf authentication mode, make sure that you have read and understood the implications of enabling RevertToSelf authentication mode.

Remarque :
RevertToSelf is not allowed in hosted environments.

To enable RevertToSelf authentication mode

  1. Verify that you meet the following minimum requirements: Voir Add-SPShellAdmin.

  2. On the Start menu, click All Programs.

  3. Click Microsoft SharePoint 2010 Products.

  4. Click SharePoint 2010 Management Shell.

  5. At the Windows PowerShell command prompt, type the following commands:

    1. To create a variable that contains the service Connexion de données métiers application object, type the following command:

      Code de copie
      $bdc = Get-SPServiceApplication | where {$_ -match "<ServiceName>"}

      Where <ServiceName> is the name of the service Connexion de données métiers application. This can also be a regular expression (for example, "BDC").

      Remarque :
      If the service Connexion de données métiers application is a shared service application, this command must be run on the farm where the service application is published.

    2. To enable RevertToSelf authentication mode, type the following command:

      Code de copie
      $bdc.RevertToSelfAllowed = $true

Disable RevertToSelf authentication mode

When RevertToSelf is disabled, new models that use RevertToSelf cannot be created or imported.

Remarque :
If you have existing models that use RevertToSelf, they will continue to work. You must delete the existing models if you want to remove all instances of RevertToSelf authentication from your farm.

To disable RevertToSelf authentication mode

  1. Verify that you meet the following minimum requirements: Voir Add-SPShellAdmin.

  2. On the Start menu, click All Programs.

  3. Click Microsoft SharePoint 2010 Products.

  4. Click SharePoint 2010 Management Shell.

  5. At the Windows PowerShell command prompt, type the following commands:

    1. To create a variable that contains the service Connexion de données métiers application, type the following command:

      Code de copie
      $bdc = Get-SPServiceApplication | where {$_ -match "<ServiceName>"}

      Where <ServiceName> is the name of the service Connexion de données métiers application. This can also be a regular expression (for example, "BDC").

      Remarque :
      If the service Connexion de données métiers application is a shared service application, this command must be run on the farm where the service application is published.

    2. To disable RevertToSelf authentication mode, type the following command:

      Code de copie
      $bdc.RevertToSelfAllowed = $false

Workflows and external lists

Additional configuration is required when you want to develop workflows that interact with external lists. The following sections describe requirements that can affect workflow behavior.

Remarque :
Workflows cannot interact with external lists in a hosted environment.

Workflows cannot be associated directly with an external list

Because the external data is not stored in SharePoint Foundation, the workflow cannot be notified when an item in the external list changes. Instead, you can create a site workflow or a list workflow, and then have the workflow read or update an external list. You can also use an external list item as a destination for a task process in SharePoint Designer; however, the link to the task will not display a title for the external list item.

Workflows sometimes run as the service account

Workflows run as the service account (typically, the application pool account) in the following scenarios:

  • Visual Studio workflows.

  • Declarative workflows that interact with external lists and are started automatically. This is true even when you use an impersonation step in your workflow.

In this case, you must give the service account Execute permission to the external content type that the external list is associated with and verify that the service account has the necessary permissions to access the external system.

Workflows and authentication

To support workflow activities, the external content type that the external list is associated with must use RevertToSelf or Secure Store Service for authentication.

Remarque :
These authentication mode restrictions do not apply if you are using a .NET Assembly connector or a custom connector.

  • Authenticate by using RevertToSelf

    RevertToSelf authentication mode (also known as BDC identity authentication mode) authenticates to the external system by using the application pool account of the front-end Web server where the external list resides. This means that the application pool account must have permission to access the external system. By default, RevertToSelf authentication is not enabled. You must enable RevertToSelf authentication mode before you can create or import models that use RevertToSelf authentication.

    Sécurité Remarque :
    RevertToSelf authentication is not recommended for production environments.

    For more information about RevertToSelf authentication, see RevertToSelf authentication mode.

  • Authenticate by using a custom secure store provider

For more information about authentication modes, see Vue d'ensemble de l'authentification de Business Connectivity Services in "Business Connectivity Services security overview (SharePoint Foundation 2010)."

Voir aussi

Concepts

Vue d'ensemble de la sécurité de Business Connectivity Services (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
28 octobre 2010 | 2010/10/25 | Mise à jour du contenu
9 septembre 2010 | Publication initiale |


Administration de flux de travail (SharePoint Foundation 2010)
Voir aussi

Cette section explique comment effectuer des tâches d'administration de flux de travail courantes.

Dans cette section :

  • Configurer les paramètres globaux des flux de travail (SharePoint Foundation 2010)

  • Gérer les flux de travail (SharePoint Foundation 2010)

  • Surveiller des flux de travail (SharePoint Foundation 2010)

Voir aussi

Concepts

Processus de déploiement de flux de travail (SharePoint Foundation 2010)

Historique des modifications


Gérer les flux de travail (SharePoint Foundation 2010)

Vous pouvez modifier les paramètres de configuration des associations de flux de travail existantes, annuler des flux de travail en cours d'exécution, supprimer des associations de flux de travail et désinstaller ou supprimer des flux de travail de votre site.

Dans cette section :

  • Activer ou désactiver un flux de travail (SharePoint Foundation 2010)

    Les flux de travail déployés en tant que package fonctionnel doivent être activés pour être utilisables dans les listes, les bibliothèques, les types de contenu ou les sites. Cet article explique comment activer ou désactiver un flux de travail déployé en tant que package fonctionnel.

  • Ajouter une association de flux de travail (SharePoint Foundation 2010)

    Pour pouvoir exécuter un flux de travail, il faut préalablement l'associer à une liste, une bibliothèque, un type de contenu ou un site. Cet article explique comment associer un modèle du flux de travail à une liste, une bibliothèque, un type de contenu ou un site.

  • Modifier une association de flux de travail (SharePoint Foundation 2010)

    Cet article explique comment modifier les options configurables disponibles pour la plupart des associations de flux de travail.

  • Supprimer une association de flux de travail (SharePoint Foundation 2010)

    Pour pouvoir exécuter un flux de travail, il faut d'abord associer des modèles de flux de travail à une liste, une bibliothèque, un type de contenu ou un site. Cet article explique comment dissocier un modèle du flux de travail d'une liste, d'une bibliothèque, d'un type de contenu ou d'un site.

  • Démarrer une instance de flux de travail (SharePoint Foundation 2010)

    Les flux de travail peuvent être configurés pour démarrer lorsqu'un événement donné se produit ; ils peuvent aussi être démarrés manuellement par un utilisateur. Cet article explique comment démarrer manuellement un flux de travail.

  • Annuler ou terminer une instance de flux de travail (SharePoint Foundation 2010)

    Si vous souhaitez interrompre une instance de flux de travail, vous pouvez annuler le flux. Vous pouvez arrêter un flux de travail qu'il est impossible d'annuler soit parce qu'il ne prend pas en charge l'annulation, soit parce qu'il ne répond plus. Cet article explique comment annuler ou arrêter un flux de travail.

  • Désinstaller un flux de travail (SharePoint Foundation 2010)

    Cet article explique comment désinstaller un flux de travail déployé en tant que composant fonctionnel.

  • Supprimer un flux de travail SharePoint Designer (SharePoint Foundation 2010)

    Cet article explique comment supprimer un flux de travail déployé à l'aide de SharePoint Designer.

Historique des modifications


Activer ou désactiver un flux de travail (SharePoint Foundation 2010)

Par défaut, beaucoup des flux de travail prédéfinis inclus dans Microsoft SharePoint Foundation 2010 en tant que composants fonctionnels sont actifs lorsque vous créez un site ou une collection de sites. De plus, les flux de travail personnalisés que vous créez à l'aide de Microsoft SharePoint Designer 2010 ou de Visual Studio 2010 et déployez en utilisant la méthode de publication par simple clic sont automatiquement activés sur les sites où ils sont déployés. Comme les composants fonctionnels qui contiennent les modèles de flux de travail, tels que les flux de travail prédéfinis, peuvent être désactivés, vous pouvez vérifier que celui qui contient le modèle de flux de travail à utiliser est actif sur le site ou la collection de sites. Utilisez les procédures suivantes pour déterminer si le flux de travail à utiliser est actif, et au besoin pour l'activer.

Par défaut, Microsoft SharePoint Foundation 2010 n'a qu'un seul flux de travail prédéfini, le flux de travail à trois états, qui est actif lorsque vous créez un site ou une collection de sites dans SharePoint Foundation 2010.

Conseil :
Seuls les flux de travail activés peuvent être associés à une liste, une bibliothèque, un type de contenu ou un site.

Activer un flux de travail sur une collection de sites

Utilisez la procédure suivante pour déterminer si le composant fonctionnel du flux de travail que vous souhaitez utiliser est actif et au besoin pour l'activer.

Remarque :
Les flux de travail activés au niveau d'une collection de sites sont disponibles sur tous les sites de la collection.

Pour activer un flux de travail sur une collection de sites

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de collection de sites sur la collection que vous configurez.

  2. Depuis le niveau supérieur de la collection de sites, dans le menu Actions du site, cliquez sur Paramètres du site.

  3. Dans la page Paramètres du site, dans la section Administration de la collection de sites, cliquez sur Fonctionnalités de la collection de sites.

  4. Dans la page Composants, cliquez sur Activer à côté de la fonctionnalité de flux de travail que vous souhaitez activer.

    La colonne État affiche Actif pour signaler que le composant fonctionnel est maintenant actif.
Remarque :
Si par la suite, vous décidez de désactiver une fonctionnalité de flux de travail, ouvrez à nouveau la page Fonctionnalités du site, cliquez sur Désactiver en regard de la fonctionnalité à désactiver, puis cliquez sur Désactiver la fonctionnalité.

Historique des modifications


Ajouter une association de flux de travail (SharePoint Foundation 2010)

Vous ajoutez un flux de travail en l'associant à une liste, une bibliothèque de documents, un type de contenu de site ou un site.

Dans cet article :

  • Associer un flux de travail à une bibliothèque de documents ou une liste

  • Associer un flux de travail à un type de contenu de liste ou de bibliothèque

  • Associer un flux de travail à un type de contenu de site

  • Associer à un site un flux de travail provenant d'un Feature Package

Avant de commencer

En ajoutant une association de flux de travail, vous affectez une liste de tâches et d'historique à utiliser avec le flux de travail sélectionné. Vous pouvez utiliser la liste de tâches par défaut, sélectionner une autre liste de tâches existante ou en créer une nouvelle. Les participants du flux de travail peuvent facilement trouver et afficher leurs tâches dans le flux de travail à l'aide de l'affichage Mes tâches de la liste Tâches, dans la barre de lancement rapide de la collection de sites.

Sécurité Remarque :
Si les tâches de ce flux de travail sont susceptibles de révéler des données sensibles ou confidentielles qui ne doivent pas figurer dans la liste des tâches générale, vous devez créer une nouvelle liste de tâches.

À mesure que les listes SharePoint grandissent, la performance du site peut être négativement affectée. Si une organisation possède de nombreux flux de travail, envisagez la création de listes de tâches et d'historique distinctes pour chaque flux de travail afin d'éviter les problèmes de performances éventuels.

Associer un flux de travail à une bibliothèque de documents ou une liste

Suivez les étapes suivantes pour associer un flux de travail à une liste ou une bibliothèque de documents. Notez que certains flux de travail, tels que le flux de travail Trois états, nécessitent que vous créiez une colonne dans votre liste dans laquelle sera affiché l'état du flux de travail. Par exemple, avant d'ajouter le flux de travail Trois états à une liste, nous vous recommandons de créer d'abord une colonne du type de « Choice » et d'affecter trois choix à la colonne.

Pour associer un flux de travail à une bibliothèque de documents ou une liste

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez disposer du niveau d'autorisation Contrôle total sur la liste ou la bibliothèque que vous configurez.

  2. Naviguez jusqu'à la liste ou la bibliothèque à laquelle vous souhaitez ajouter un flux de travail.

  3. Effectuez l'une des actions suivantes :

    • Pour une liste, sous l'onglet Outils de liste, cliquez sur Liste.

    • Dans le groupe Paramètres, cliquez sur Paramètres du flux de travail, puis sur Ajouter un flux de travail.

    • Pour une bibliothèque, sous l'onglet Outils de bibliothèque, cliquez sur Bibliothèque.

    • Dans le groupe Paramètres, cliquez sur Paramètres du flux de travail, puis sur Ajouter un flux de travail.

  4. Dans la page Ajouter un flux de travail, dans la section Flux de travail, sélectionnez le modèle de flux de travail que vous voulez associer à la liste ou à la bibliothèque.

  5. Dans la section Nom, tapez le nom que vous voulez utiliser pour identifier ce flux de travail pour les utilisateurs de cette liste ou de cette bibliothèque.

  6. Dans la section Liste des tâches, spécifiez une liste de tâches à utiliser avec ce flux de travail.

  7. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente les événements qui se produisent au cours de chaque instance du flux de travail.

    Important :
    Vous pouvez utiliser l'historique par défaut, sélectionner un autre historique existant ou en créer un. Lorsque les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation possède de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque association de flux de travail afin d'éviter les problèmes de performances éventuels.

  8. Dans la section Options de démarrage, spécifiez comment (automatiquement ou manuellement), quand (mise à jour, création d'article ou les deux) ou par qui un flux de travail peut être démarré.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous spécifiez que les autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les utilisateurs possédant les autorisations de gestion de liste ou de conception de sites Web peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches réservées à certains utilisateurs, telles que la suppression des documents.

  9. Si le flux de travail que vous avez sélectionné dispose d'options de configuration supplémentaires, cliquez sur Suivant pour personnaliser les paramètres qui sont spécifiques aux flux de travail, si nécessaire. Autrement, passez à l'étape suivante.

  10. Lorsque vous avez terminé de spécifier vos options de configuration, cliquez sur OK pour appliquer vos modifications à l'association de flux de travail.

Associer un flux de travail à un type de contenu de liste ou de bibliothèque

Suivez les étapes suivantes pour associer un flux de travail à un type de contenu de liste ou de bibliothèque.

Avant de pouvoir effectuer les étapes suivantes, la liste ou la bibliothèque que vous configurez doit l'être de sorte d'autoriser la gestion des types de contenu.

Pour associer un flux de travail à un type de contenu de liste ou de bibliothèque

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site sur le site SharePoint que vous configurez.

  2. Ouvrez la liste ou la bibliothèque qui contient le type de contenu auquel vous souhaitez associer un flux de travail.

  3. Effectuez l'une des actions suivantes :

    • Pour une liste, sous l'onglet Outils de liste, cliquez sur Liste.

    • Dans le groupe Paramètres du Ruban, cliquez sur Paramètres de la liste.

    • Pour une bibliothèque, sous l'onglet Outils de bibliothèque, cliquez sur Bibliothèque.

    • Dans le groupe Paramètres du Ruban, cliquez sur Paramètres de la bibliothèque.

  4. Dans la section Types de contenu, dans la colonne Type de contenu, cliquez sur le nom du type de contenu auquel vous voulez associer un flux de travail.

    Remarque :
    Si la liste ou la bibliothèque n'est pas configurée pour permettre la gestion de plusieurs types de contenu, la section Types de contenu n'est pas affichée. Pour plus d'informations, voir Utiliser les types de contenu pour gérer le contenu d'un site SharePoint (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=184651&clcid=0x40C).

  5. Dans la page Paramètres de la liste ou Paramètres de la bibliothèque de documents, dans la section Paramètres, cliquez sur Paramètres du flux de travail.

  6. Dans la page Paramètres du flux de travail, cliquez sur Ajouter un flux de travail.

  7. Dans la page Ajouter un flux de travail, dans la section Flux de travail, sélectionnez le modèle de flux de travail que vous voulez associer à ce type de contenu.

  8. Dans la section Nom, tapez le nom que vous voulez utiliser pour identifier ce flux de travail pour les utilisateurs du site.

  9. Dans la section Liste des tâches, spécifiez une liste de tâches à utiliser avec ce flux de travail.

  10. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente tous les événements qui se produisent au cours de chaque instance du flux de travail.

    Important :
    Vous pouvez utiliser l'historique par défaut ou en créer un. À mesure que les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation possède de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque flux de travail afin d'éviter les problèmes de performances éventuels.

  11. Dans la section Options de démarrage, spécifiez comment (automatiquement ou manuellement), quand (mise à jour, création d'article ou les deux) ou par qui un flux de travail peut être démarré.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous spécifiez que les autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les utilisateurs possédant les autorisations de gestion de liste ou de conception de sites Web peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches réservées à certains utilisateurs, telles que la suppression des documents.

  12. Si le flux de travail que vous avez sélectionné dispose d'options de configuration supplémentaires, cliquez sur Suivant pour personnaliser les paramètres qui sont spécifiques aux flux de travail, si nécessaire. Autrement, passez à l'étape suivante.

  13. Lorsque vous avez terminé de spécifier vos options de configuration, cliquez sur OK ou sur Enregistrer (suivant le flux de travail) pour appliquer vos modifications à l'association de flux de travail.

Associer un flux de travail à un type de contenu de site

Suivez les étapes suivantes pour associer un flux de travail à un type de contenu de site.

Pour associer un flux de travail à un type de contenu de site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site sur le site sur lequel vous effectuez cette procédure.

  2. Accédez au site où vous souhaitez associer un flux de travail à un type de contenu de site.

    Remarque :
    Les types de contenu de site qui sont hérités d'un autre site, par exemple, le site de niveau supérieur d'une collection de sites, doivent être associés depuis le site d'où ils sont hérités. Dans ce cas, accédez au site d'où est hérité le type du contenu du site pour ajouter l'association de flux de travail.

  3. Dans la page d'accueil du site, dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, dans la section Galeries, cliquez sur Types de contenu de site.

  5. Dans la page Types de contenu de site, dans la colonne Type de contenu de site, cliquez sur le type de contenu auquel vous souhaitez ajouter une association de flux de travail.

  6. Dans la page Types de contenu de site, dans la section Paramètres, cliquez sur Paramètres du flux de travail.

  7. Dans la page Paramètres du flux de travail, cliquez sur Ajouter un flux de travail.

  8. Dans la page Ajouter un flux de travail, dans la section Flux de travail, sélectionnez le flux de travail que vous voulez ajouter.

  9. Dans la section Nom, tapez le nom que vous voulez utiliser pour identifier ce flux de travail pour les utilisateurs du site.

  10. Dans la section Liste des tâches, spécifiez une liste de tâches à utiliser avec ce flux de travail.

  11. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente tous les événements qui se produisent au cours de chaque instance du flux de travail.

    Remarque :
    Vous pouvez utiliser l'historique par défaut ou en créer un. À mesure que les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation possède de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque flux de travail afin d'éviter les problèmes de performances éventuels.

  12. Dans la section Options de démarrage, spécifiez comment (automatiquement ou manuellement), quand (mise à jour, création d'article ou les deux) ou par qui un flux de travail peut être démarré.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous spécifiez que les autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les utilisateurs possédant les autorisations de gestion de liste ou de conception de sites Web peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches réservées à certains utilisateurs, telles que la suppression des documents.

  13. Si le flux de travail que vous avez sélectionné dispose d'options de configuration supplémentaires, cliquez sur Suivant pour personnaliser les paramètres qui sont spécifiques aux flux de travail, si nécessaire. Autrement, passez à l'étape suivante.

  14. Lorsque vous avez terminé de spécifier vos options de configuration, cliquez sur OK pour appliquer vos modifications à l'association de flux de travail.

Associer à un site un flux de travail provenant d'un Feature Package

Suivez les étapes suivantes pour associer un flux de travail (qui fait partie d'un Feature Package) à un site.

Pour associer un flux de travail à un site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site sur le site sur lequel vous effectuez cette procédure.

  2. Naviguez jusqu'au site à partir duquel vous voulez ajouter une association de flux de travail.

  3. Dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, à la section Administration du site, cliquez sur Paramètres du flux de travail.

  5. Dans la page Paramètres de flux de travail, cliquez sur Ajouter un flux de travail.

  6. Dans la page Ajouter un flux de travail, dans la section Flux de travail, sélectionnez le modèle de flux de travail que vous voulez associer à ce site.

  7. Dans la section Nom, tapez le nom que vous voulez utiliser pour identifier ce flux de travail pour les utilisateurs du site.

  8. Dans la section Liste des tâches, spécifiez une liste de tâches à utiliser avec ce flux de travail.

  9. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente tous les événements qui se produisent au cours de chaque instance du flux de travail.

    Remarque :
    Vous pouvez utiliser l'historique par défaut ou en créer un. À mesure que les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation possède de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque flux de travail afin d'éviter les problèmes de performances éventuels.

  10. Dans la section Options de démarrage, spécifiez si le flux de travail peut être démarré manuellement par un utilisateur authentifié disposant des autorisations de collaboration, et si les autorisations de collaboration sont également requises pour démarrer le flux de travail.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous spécifiez que les autorisations de gestion sont requises pour démarrer le flux de travail, seuls les utilisateurs possédant au moins le niveau d'autorisation Concepteur peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches réservées à certains utilisateurs, telles que la suppression des documents.

  11. Si le flux de travail que vous avez sélectionné dispose d'options de configuration supplémentaires, cliquez sur Suivant pour personnaliser les paramètres qui sont spécifiques aux flux de travail, si nécessaire. Autrement, passez à l'étape suivante.

  12. Lorsque vous avez terminé de spécifier vos options de configuration, cliquez sur OK pour appliquer vos modifications à l'association de flux de travail.

Historique des modifications


Modifier une association de flux de travail (SharePoint Foundation 2010)

Une fois que vous avez associé (ajouté) un flux de travail à une liste, à une bibliothèque, à un type de contenu ou à un site, vous pouvez modifier ses paramètres de configuration à tout moment. Les paramètres de configuration comprennent le nom de l'association de flux de travail, les options de démarrage, les participants, les messages de notification des tâches, le choix des listes à utiliser pour le suivi de l'historique et des tâches du flux de travail (par défaut ou nouvelles) et les options d'achèvement.

Dans cet article :

  • Modifier un flux de travail associé à une liste ou à une bibliothèque

  • Modifier un flux de travail associé à un type de contenu de liste ou de bibliothèque

  • Modifier un flux de travail associé à un type de contenu de site

  • Modifier un flux de travail de site

Avant de commencer

Lorsque vous ajoutez une association de flux de travail, vous affectez une liste de tâches à utiliser avec le flux de travail sélectionné. Vous pouvez utiliser la liste de tâches par défaut, sélectionner une autre liste de tâches existante ou en créer une nouvelle. Si vous utilisez la liste de tâches par défaut, les participants du flux de travail peuvent facilement trouver et afficher leurs tâches dans le flux de travail à l'aide de l'affichage Mes tâches de la liste Tâches.

Sécurité Remarque :
Si les tâches de ce flux de travail sont susceptibles de révéler des données sensibles ou confidentielles qui ne doivent pas figurer dans la liste des tâches générale, vous devez créer une nouvelle liste de tâches.

Modifier un flux de travail associé à une liste ou à une bibliothèque

Utilisez les étapes suivantes pour modifier les paramètres de configuration d'un flux de travail associé à une liste ou à une bibliothèque de documents. Les modifications apportées aux paramètres de configuration sont uniquement appliquées aux instances de flux de travail qui démarrent une fois l'association de flux de travail modifiée.

Pour modifier un flux de travail associé à une liste ou à une bibliothèque

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Propriétaires de site sur la liste ou la bibliothèque que vous configurez.

  2. Accédez à la liste ou à la bibliothèque de documents dans laquelle se trouve le flux de travail.

  3. Effectuez l'une des actions suivantes :

    • Pour une liste, sous l'onglet Outils de liste, cliquez sur Liste.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la liste.

    • Pour une bibliothèque, sous l'onglet Outils de bibliothèque, cliquez sur Bibliothèque.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la bibliothèque.

  4. Sur la page Paramètres de la liste ou Paramètres de la bibliothèque, dans la section Autorisations et gestion, cliquez sur Paramètres du flux de travail.

  5. Dans la page Paramètres du flux de travail, dans la section Flux de travail, sélectionnez le nom du flux de travail que vous souhaitez modifier.

  6. Dans la section Nom, vous pouvez taper un nouveau nom pour le flux de travail.

    Ce nom permettra d'identifier le flux de travail auprès des utilisateurs du site.

  7. Dans la section Liste des tâches, spécifiez une liste de tâches à utiliser avec ce flux de travail.

  8. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente tous les événements qui se produisent au cours de chaque instance du flux de travail.

    Remarque :
    Vous pouvez utiliser l'historique par défaut ou en créer un. Lorsque les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation a de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque association de flux de travail afin d'éviter les problèmes de performances éventuels.

  9. Dans la section Options de démarrage, spécifiez comment (automatiquement ou manuellement), quand (mise à jour, création d'élément ou les deux) ou par qui un flux de travail peut être démarré.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous spécifiez que les autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les utilisateurs possédant les autorisations de gestion de liste ou de conception de sites Web peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches réservées à certains utilisateurs, telles que la suppression des documents.

  10. Cliquez sur Suivant pour personnaliser les paramètres spécifiques des flux de travail en fonction de vos besoins.

  11. Après avoir configuré les paramètres qui sont spécifiques à des flux de travail, cliquez sur OK ou sur Enregistrer (suivant le flux de travail) pour appliquer vos modifications à l'association de flux de travail.

Modifier un flux de travail associé à un type de contenu de liste ou de bibliothèque

Utilisez cette procédure pour modifier une association de flux de travail avec un type de contenu de liste ou de bibliothèque.

Remarque :
Cette procédure suppose que l'option Autoriser la gestion de types de contenu a la valeur Oui sur la liste ou la bibliothèque.

Pour modifier un flux de travail associé à un type de contenu de liste ou de bibliothèque

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Propriétaires de site sur le site SharePoint que vous configurez.

  2. Accédez à la bibliothèque ou à la liste de documents à laquelle est associé le flux de travail.

  3. Effectuez l'une des actions suivantes :

    • Pour une liste, sous l'onglet Outils de liste, cliquez sur Liste.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la liste.

    • Pour une bibliothèque, sous l'onglet Outils de bibliothèque, cliquez sur Bibliothèque.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la bibliothèque.

  4. Dans la section Types de contenu, dans la colonne Type de contenu, cliquez sur le nom du type de contenu auquel le flux de travail que vous voulez modifier est associé.

    Remarque :
    Si la liste ou la bibliothèque n'est pas configurée pour autoriser plusieurs types de contenu, la section Types de contenu n'est pas affichée. Pour plus d'informations, voir Activer la prise en charge de plusieurs types de contenu dans une liste ou une bibliothèque (http://go.microsoft.com/fwlink/?linkid=120710&clcid=0x40C).

  5. Dans la page Paramètres de la liste ou Paramètres de la bibliothèque, dans la section Paramètres, cliquez sur Paramètres de flux de travail.

  6. Dans la page Paramètres du flux de travail, cliquez sur le nom du flux de travail que vous souhaitez modifier.

  7. Dans la page Modifier un flux de travail, dans la section Nom, vous pouvez taper un nouveau nom pour le flux de travail.

    Ce nom identifie le flux de travail pour les utilisateurs du site.

  8. Dans la section Liste de tâches, définissez une liste de tâches à utiliser avec ce flux de travail.

  9. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente tous les événements qui se produisent au cours de chaque instance du flux de travail.

    Remarque :
    Vous pouvez utiliser l'historique par défaut ou en créer un. Lorsque les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation a de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque flux de travail afin d'éviter les problèmes de performances éventuels.

  10. Dans la section Options de démarrage, spécifiez comment (automatiquement ou manuellement), quand (mise à jour, création d'élément ou les deux) ou par qui un flux de travail peut être démarré.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous spécifiez que les autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les administrateurs de listes (c'est-à-dire toute personne ayant des autorisations de gestion de liste ou de conception de sites Web) peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches, telles que la suppression des documents, que seuls certains utilisateurs peuvent effectuer.

  11. Si les options personnalisées sont disponibles pour un flux de travail, cliquez sur Suivant pour configurer les paramètres spécifiques à un flux de travail, ou cliquez sur OK pour enregistrer les modifications.

  12. Après avoir configuré des paramètres spécifiques à un flux de travail, si ceux-ci s'appliquent au flux de travail que vous modifiez, cliquez sur OK pour appliquer les modifications à l'association de flux de travail.

  13. Dans la page Personnaliser le flux de travail, spécifiez les modifications que vous voulez apporter au flux de travail, puis cliquez sur Enregistrer.

Modifier un flux de travail associé à un type de contenu de site

Utilisez cette procédure pour modifier l'association d'un flux de travail à un type de contenu de site. Lorsque vous modifiez un flux de travail associé à un type de contenu de site, vous pouvez indiquer s'il est nécessaire d'appliquer les changements aux types de contenu hérités.

Pour modifier un flux de travail associé à un type de contenu de site

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Propriétaires de site sur le site SharePoint que vous configurez.

  2. Accédez au site où vous souhaitez modifier un flux de travail qui est associé à un type de contenu.

    Remarque :
    Les types de contenu de site qui sont hérités d'un autre site, par exemple le site de plus haut niveau d'une collection de sites, doivent être modifiés sur le site dont ils sont hérités.

  3. Sur le site de plus haut niveau de la collection de sites, dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, dans la section Galeries, cliquez sur Types de contenu de site.

  5. Dans la page Galerie des types de contenu de site, dans la colonne Type de contenu de site, cliquez sur le type de contenu pour lequel vous souhaitez modifier une association de flux de travail.

  6. Dans la page Types de contenu de site, dans la section Paramètres, cliquez sur Paramètres du flux de travail.

  7. Dans la page Paramètres du flux de travail, cliquez sur le nom du flux de travail que vous souhaitez modifier.

  8. Dans la page Modifier un flux de travail, dans la section Nom, vous pouvez taper un nouveau nom pour le flux de travail.

    Ce nom permettra d'identifier le flux de travail auprès des utilisateurs du site.

  9. Dans la section Liste des tâches, spécifiez une liste de tâches à utiliser avec ce flux de travail.

  10. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente tous les événements qui se produisent au cours de chaque instance du flux de travail.

    Remarque :
    Vous pouvez utiliser l'historique par défaut ou en créer un. Lorsque les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation a de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque association de flux de travail afin d'éviter les problèmes de performances éventuels.

  11. Dans la section Options de démarrage, spécifiez comment (automatiquement ou manuellement), quand (mise à jour, création d'élément ou les deux) ou par qui un flux de travail peut être démarré.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous spécifiez que les autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les administrateurs de listes (c'est-à-dire toute personne ayant des autorisations de gestion de liste ou de conception de sites Web) peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches, telles que la suppression des documents, que seuls certains utilisateurs peuvent effectuer.

  12. Dans la section Mettre à jour les listes et les types de contenu du site, indiquez si vous souhaitez ajouter ce flux de travail à tous les types de contenu qui héritent de ce type de contenu.

  13. Si les options personnalisées sont disponibles pour un flux de travail, cliquez sur Suivant pour configurer des paramètres spécifiques à un flux de travail. Après avoir configuré des paramètres spécifiques à un flux de travail, si ceux-ci s'appliquent à celui que vous modifiez, cliquez sur OK ou sur Enregistrer (suivant le flux de travail) pour appliquer vos modifications à l'association de flux de travail.

Modifier un flux de travail de site

Utilisez cette procédure pour modifier l'association d'un flux de travail à un type de contenu de site. Lorsque vous modifiez un flux de travail associé à un type de contenu de site, vous pouvez indiquer s'il est nécessaire d'appliquer les changements aux types de contenu hérités.

Pour modifier un flux de travail de site

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Propriétaires de site sur le site SharePoint que vous configurez.

  2. Accédez au site où vous voulez modifier une association de flux de travail.

    Remarque :
    Les flux de travail de site qui sont hérités d'un autre site, par exemple le site de plus haut niveau d'une collection de sites, doivent être modifiés sur le site dont ils sont hérités.

  3. Sur le site de plus haut niveau de la collection de sites, dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, à la section Administration du site, cliquez sur Paramètres de flux de travail.

  5. Dans la page Paramètres du flux de travail, cliquez sur le flux de travail que vous voulez modifier.

  6. Dans la page Modifier un flux de travail, dans la section Nom, vous pouvez taper un nouveau nom pour le flux de travail.

    Ce nom identifie le flux de travail pour les utilisateurs du site.

  7. Dans la section Liste des tâches, spécifiez une liste de tâches à utiliser avec ce flux de travail.

  8. Dans la section Historique, sélectionnez une liste d'historique à utiliser avec ce flux de travail.

    La liste d'historique présente tous les événements qui se produisent au cours de chaque instance du flux de travail.

    Remarque :
    Vous pouvez utiliser l'historique par défaut ou en créer un. Lorsque les listes SharePoint augmentent en taille, les performances du site peuvent être affectées. Si une organisation a de nombreux flux de travail, envisagez la création d'un historique distinct pour chaque association de flux de travail afin d'éviter les problèmes de performances éventuels.

  9. Dans la section Options de démarrage, spécifiez comment (automatiquement ou manuellement), quand (mise à jour, création d'élément ou les deux) ou par qui un flux de travail peut être démarré.

    Notez que les options de démarrage disponibles dépendent du modèle de flux de travail et varient d'un flux de travail à l'autre.

    Remarque :
    Par défaut, les utilisateurs qui disposent des autorisations Modifier un élément peuvent démarrer un flux de travail. Si vous sélectionnez Les autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les administrateurs de listes (c'est-à-dire, toute personne possédant les autorisations de gestion de liste ou de conception de sites Web) peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Toutefois, vous pouvez utiliser ce paramètre pour les flux de travail qui comportent des tâches réservées à certains utilisateurs, telles que la suppression des documents.

  10. Si les options personnalisées sont disponibles pour votre flux de travail, cliquez sur Suivant pour configurer des paramètres spécifiques à un flux de travail. Après avoir configuré des paramètres spécifiques à un flux de travail, si ceux-ci s'appliquent à celui que vous modifiez, cliquez sur OK ou sur Terminer (suivant le flux de travail) pour appliquer vos modifications à l'association de flux de travail.

Historique des modifications


Supprimer une association de flux de travail (SharePoint Foundation 2010)

Vous pouvez ajouter un flux de travail en l'associant à une liste, à une bibliothèque de documents, à un type de contenu ou à un site. Vous supprimez un flux de travail en le dissociant d'une liste, d'une bibliothèque de documents, d'un type de contenu ou d'un site. Si vous le souhaitez, vous pouvez empêcher le démarrage de nouvelles instances d'un flux de travail, tout en autorisant toutes les instances de flux de travail en cours d'exécution à se dérouler jusqu'à leur terme.

Dans cet article :

  • Supprimer une association de flux de travail d'une liste ou d'une bibliothèque de documents

  • Supprimer une association de flux de travail d'un type de contenu de liste ou de bibliothèque

  • Supprimer une association de flux de travail d'un type de contenu de site

  • Supprimer une association de flux de travail d'un site

Supprimer une association de flux de travail d'une liste ou d'une bibliothèque de documents

Suivez la procédure ci-après pour supprimer une association de flux de travail d'une liste ou d'une bibliothèque de documents.

Pour supprimer une association de flux de travail d'une liste ou d'une bibliothèque de documents

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site sur le site SharePoint que vous configurez.

  2. Accédez à la liste ou à la bibliothèque de laquelle vous souhaitez supprimer un flux de travail.

  3. Effectuez l'une des actions suivantes :

    • Pour une liste, sous l'onglet Outils de liste, cliquez sur Liste.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la liste.

    • Pour une bibliothèque, sous l'onglet Outils de bibliothèque, cliquez sur Bibliothèque.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la bibliothèque.

  4. Sur la page Paramètres de la liste ou Paramètres de la bibliothèque, dans la section Autorisations et gestion, cliquez sur Paramètres du flux de travail.

  5. Dans la page Paramètres du flux de travail, cliquez sur Supprimer un flux de travail.

    Remarque :
    Le lien Supprimer un flux de travail n'est pas affiché si aucun flux de travail n'est associé à la liste ou à la bibliothèque.

  6. Dans la page Supprimer des flux de travail, recherchez le flux de travail que vous souhaitez supprimer et choisissez l'une des options suivantes :

    • Sélectionnez Aucune nouvelle instance pour empêcher l'exécution de toute nouvelle instance de ce flux de travail, tout en autorisant les instances en cours d'exécution à se dérouler jusqu'à leur terme.

      Une fois que tous les flux de travail en cours d'exécution sont terminés, vous pouvez retourner à cette page pour supprimer complètement l'association de flux de travail.

    • Sélectionnez Supprimer pour empêcher l'exécution de toute nouvelle instance de ce flux de travail et supprimer toutes les instances de ce flux de travail, y compris celles en cours d'exécution.

  7. Cliquez sur OK.

Supprimer une association de flux de travail d'un type de contenu de liste ou de bibliothèque

Suivez la procédure ci-après pour supprimer un flux de travail d'un type de contenu de liste ou de bibliothèque.

Pour supprimer une association de flux de travail d'un type de contenu de liste ou de bibliothèque

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site sur le site SharePoint que vous configurez.

  2. Ouvrez la liste ou la bibliothèque qui contient le type de contenu duquel vous souhaitez supprimer une association de flux de travail.

  3. Effectuez l'une des actions suivantes :

    • Pour une liste, sous l'onglet Outils de liste, cliquez sur Liste.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la liste.

    • Pour une bibliothèque, sous l'onglet Outils de bibliothèque, cliquez sur Bibliothèque.

    • Dans le groupe Paramètres, cliquez sur Paramètres de la bibliothèque.

  4. Dans la page Paramètres de la liste ou Paramètres de la bibliothèque, dans la section Types de contenu, cliquez sur le nom du type de contenu pour lequel vous souhaitez supprimer un flux de travail.

    Remarque :
    Si la liste ou la bibliothèque n'est pas configurée pour autoriser plusieurs types de contenu, la section Types de contenu n'est pas affichée. Pour plus d'informations, voir Utiliser les types de contenu pour gérer le contenu d'un site SharePoint (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=184651&clcid=0x40C).

  5. Dans la page Paramètres de la liste ou Paramètres de la bibliothèque, dans la section Paramètres, cliquez sur Paramètres du flux de travail.

  6. Dans la page Paramètres du flux de travail, cliquez sur Supprimer un flux de travail.

    Remarque :
    Le lien Supprimer un flux de travail n'est pas affiché si aucun flux de travail n'est associé au type de contenu sélectionné.

  7. Dans la page Supprimer des flux de travail, recherchez le flux de travail que vous souhaitez supprimer et choisissez l'une des options suivantes :

    • Sélectionnez Aucune nouvelle instance pour empêcher l'exécution de toute nouvelle instance de ce flux de travail, tout en autorisant les instances en cours d'exécution à se dérouler jusqu'à leur terme.

      Une fois que tous les flux de travail en cours d'exécution sont terminés, vous pouvez retourner à cette page pour supprimer complètement l'association de flux de travail.

    • Sélectionnez Supprimer pour empêcher l'exécution de toute nouvelle instance de ce flux de travail et supprimer toutes les instances de ce flux de travail, y compris celles en cours d'exécution.

  8. Cliquez sur OK.

Supprimer une association de flux de travail d'un type de contenu de site

Suivez la procédure ci-après pour supprimer un flux de travail d'un type de contenu de site.

Pour supprimer une association de flux de travail d'un type de contenu de site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site sur le site SharePoint que vous configurez.

  2. Accédez au site où vous souhaitez modifier un flux de travail qui est associé à un type de contenu de site.

    Remarque :
    Les types de contenu de site hérités d'un autre site, par exemple, du site de niveau supérieur dans une collection de sites, doivent être supprimés du site duquel ils sont hérités.

  3. Dans la page d'accueil du site, dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, dans la section Galeries, cliquez sur Types de contenu de site.

  5. Dans la page Types de contenu de site, dans la colonne Type de contenu de site, cliquez sur le type de contenu duquel vous souhaitez supprimer une association de flux de travail.

    Remarque :
    Vous ne pouvez pas modifier les types de contenu de site hérités d'un autre site, par exemple du site de niveau supérieur dans une collection de sites. Dans ce cas, accédez au site duquel le type de contenu de site est hérité pour supprimer l'association de flux de travail.

  6. Dans la page Types de contenu de site, dans la section Paramètres, cliquez sur Paramètres du flux de travail.

  7. Dans la page Paramètres du flux de travail, cliquez sur Supprimer un flux de travail.

    Remarque :
    Le lien Supprimer un flux de travail n'est pas affiché si aucun flux de travail n'est associé au type de contenu de site sélectionné.

  8. Dans la page Supprimer des flux de travail, recherchez le flux de travail que vous souhaitez supprimer et choisissez l'une des options suivantes :

    • Sélectionnez Aucune nouvelle instance pour empêcher toute nouvelle instance de ce flux de travail, tout en autorisant les instances en cours d'exécution à se dérouler jusqu'à leur terme.

      Une fois que tous les flux de travail en cours d'exécution sont terminés, vous pouvez retourner à cette page pour supprimer complètement l'association de flux de travail.

    • Sélectionnez Supprimer pour supprimer toutes les instances de ce flux de travail, y compris celles en cours d'exécution.

  9. Cliquez sur OK.

  10. Si le message Appliquer les modifications à tous les types de contenu qui héritent de ce type s'affiche, cliquez sur OK.

Supprimer une association de flux de travail d'un site

Suivez la procédure ci-après pour supprimer un flux de travail d'un site.

Pour supprimer une association de flux de travail d'un site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site sur le site SharePoint que vous configurez.

  2. Accédez au site duquel vous voulez supprimer un flux de travail.

  3. Dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, à la section Administration du site, cliquez sur Paramètres du flux de travail.

  5. Dans la page Paramètres du flux de travail, cliquez sur Supprimer un flux de travail.

    Remarque :
    Le lien Supprimer un flux de travail est affiché uniquement si un flux de travail de site est actuellement associé au site.

  6. Dans la page Supprimer des flux de travail, recherchez le flux de travail que vous souhaitez supprimer et choisissez l'une des options suivantes :

    • Sélectionnez Aucune nouvelle instance pour empêcher toute nouvelle instance de ce flux de travail, tout en autorisant les instances en cours d'exécution à se dérouler jusqu'à leur terme.

      Une fois que tous les flux de travail en cours d'exécution sont terminés, vous pouvez retourner à cette page pour supprimer complètement l'association de flux de travail.

    • Sélectionnez Supprimer pour supprimer toutes les instances de ce flux de travail, y compris celles en cours d'exécution.

  7. Cliquez sur OK.

Historique des modifications


Démarrer une instance de flux de travail (SharePoint Foundation 2010)

Une fois qu'un flux de travail a été activé, puis ajouté à une liste, une bibliothèque de documents ou un type de contenu, un utilisateur authentifié peut l'exécuter sur un élément de la liste ou sur un document de la bibliothèque. Après l'activation d'un flux de travail de site sur un site, les utilisateurs peuvent exécuter ce flux de travail sur le site. Lorsque vous ajoutez un flux de travail, vous spécifiez si vous voulez qu'il s'exécute automatiquement ou manuellement. Si un flux de travail est configuré pour démarrer automatiquement, les paramètres spécifiés dans l'association du flux de travail sont toujours utilisés au démarrage du flux de travail. Un utilisateur peut modifier les paramètres par défaut d'un flux de travail configuré pour démarrer manuellement si ce flux de travail spécifie des paramètres tels que les participants au flux de travail et une date d'échéance, selon ce qui est autorisé par le modèle de flux de travail. Les flux de travail qui sont associés à une liste, une bibliothèque ou un type de contenu s'exécutent sur des éléments de la liste ou sur des documents de la bibliothèque auxquels le flux de travail est associé. Les flux de travail de site s'exécutent sur le site auquel ils sont associés.

Autorisations requises pour démarrer un flux de travail Par défaut, les utilisateurs qui ont l'autorisation Modifier des éléments peuvent démarrer un flux de travail. Si vous spécifiez que des autorisations Gérer les listes sont requises pour démarrer le flux de travail, seuls les administrateurs de liste (c'est-à-dire tout utilisateur ayant l'autorisation Gérer les listes ou le niveau d'autorisation Créer) peuvent démarrer une instance du flux de travail. La plupart des flux de travail ne requièrent pas cette restriction. Cependant, vous pouvez utiliser l'option Gérer les listes pour des flux de travail contenant des tâches, tels que des flux de travail qui suppriment des documents, dont vous voulez que seules certaines personnes puissent les effectuer.

La procédure de démarrage d'un flux de travail varie selon que celui-ci a été configuré pour être démarré manuellement ou automatiquement. Choisissez l'une des procédures suivantes pour démarrer votre flux de travail en fonction de sa configuration et de la façon dont vous souhaitez le démarrer.

Dans cet article :

  • Démarrer un flux de travail automatiquement

  • Démarrer un flux de travail de site

  • Démarrer un flux de travail manuellement dans une liste ou une bibliothèque

Démarrer un flux de travail automatiquement

Si un flux de travail est défini pour démarrer automatiquement, il commence à s'exécuter immédiatement lorsqu'un événement déclencheur, tel que l'ajout d'un document à une bibliothèque, se produit.

Démarrer un flux de travail de site

Procédez comme suit pour démarrer un flux de travail de site.

Pour démarrer un flux de travail de site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site SharePoint sur le site que vous configurez.

  2. Accédez à la page d'accueil du site auquel un flux de travail de site est associé.

  3. Dans le menu Actions du site, cliquez sur Flux de travail d'un site.

  4. Dans la page Flux de travail, dans la section Démarrer un nouveau flux de travail, cliquez sur le nom du flux de travail à démarrer.

    Remarque :
    Si des flux de travail n'apparaissent pas dans la section Démarrer un nouveau flux de travail, c'est qu'aucun flux de travail n'a été associé au site.

  5. Si un bouton Démarrer apparaît, cliquez sur Démarrer.

Démarrer un flux de travail manuellement dans une liste ou une bibliothèque

Utilisez cette procédure pour démarrer manuellement un flux de travail qui est associé à une liste ou à une bibliothèque.

Pour démarrer manuellement un flux de travail dans une liste ou une bibliothèque

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site SharePoint sur le site que vous configurez.

  2. Accédez au site où vous voulez démarrer un flux de travail qui est associé à une liste ou à une bibliothèque.

  3. Accédez à la bibliothèque de documents ou à la liste où vous voulez démarrer le flux de travail.

  4. Dans la bibliothèque de documents ou la liste SharePoint, pointez l'élément sur lequel vous voulez démarrer le flux de travail, cliquez sur la flèche qui apparaît, puis sur Flux de travail.

  5. Dans la page Flux de travail, dans la section Démarrer un nouveau flux de travail, cliquez sur le flux de travail à démarrer.

  6. Si le bouton Démarrer apparaît, spécifiez les informations requises, telles que les participants et la date d'échéance. Configurez de façon appropriée les autres paramètres spécifiques au flux de travail, puis cliquez sur Démarrer pour démarrer le flux de travail.

Historique des modifications


Annuler ou terminer une instance de flux de travail (SharePoint Foundation 2010)

Il existe deux façons d'arrêter une instance de flux de travail :

  • Annuler un flux de travail

  • Arrêter un flux de travail

Remarque :
Vous ne pouvez pas redémarrer une instance d'un flux de travail qui a été annulée ou arrêtée. Pour réutiliser le flux de travail avec la même liste ou bibliothèque, vous devez démarrer une nouvelle instance du flux de travail. Pour plus d'informations, voir Démarrer une instance de flux de travail (SharePoint Foundation 2010).

Important :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer ces procédures.

Annuler un flux de travail

Lorsque vous annulez un flux de travail, l'état de ce dernier est défini sur Annulé et toutes les tâches qu'il a créées sont annulées. Les participants reçoivent un message électronique indiquant que le flux de travail a été annulé.

Remarque :
L'option d'annulation d'un flux de travail en cours est disponible uniquement si le modèle du flux de travail prend en charge l'annulation.

Pour annuler un flux de travail sur une liste ou une bibliothèque

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site SharePoint sur le site que vous configurez.

  2. Accédez à la liste ou à la bibliothèque pour laquelle vous souhaitez annuler un flux de travail.

    Si le nom de la liste ou de la bibliothèque n'est pas visible, cliquez sur Afficher tout le contenu du site, puis cliquez sur le nom de la liste ou de la bibliothèque.

  3. Pointez sur le document ou l'élément impliqué dans le flux de travail, cliquez sur la flèche qui s'affiche, puis sur Flux de travail.

  4. Dans la page Flux de travail, dans la section Flux de travail en cours d'exécution, cliquez sur le nom du flux de travail à annuler.

  5. Dans la page État du flux de travail, dans la section Informations sur le flux de travail, cliquez sur Annuler toutes les tâches de <nom du flux de travail>, où <nom du flux de travail> est le nom du flux de travail que vous annulez.

    Remarque :
    Le lien Annuler toutes les tâches de <nom du flux de travail> n'est pas disponible pour les flux de travail qui ne prennent pas en charge l'annulation. Dans ce cas, vous pouvez permettre l'achèvement du flux de travail ou arrêter le flux de travail comme décrit plus loin dans cet article.

  6. Dans la page Modifier le flux de travail, cliquez sur Oui.

Pour annuler un flux de travail de site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site SharePoint sur le site que vous configurez.

  2. Accédez à la page d'accueil du site pour lequel vous voulez annuler un flux de travail de site.

  3. Dans le menu Actions du site, cliquez sur Flux de travail d'un site.

  4. Dans la page Flux de travail, dans la section Mes flux de travail en cours d'exécution, cliquez sur le nom du flux de travail à annuler.

  5. Dans la page État du flux de travail, dans la section Informations sur le flux de travail, cliquez sur Annuler.

    Remarque :
    Le lien Annuler toutes les tâches de <nom du flux de travail> n'est pas disponible pour les flux de travail qui ne prennent pas en charge l'annulation. Dans ce cas, vous pouvez permettre l'achèvement du flux de travail ou arrêter le flux de travail comme décrit plus loin dans cet article.

  6. Dans la page Modifier le flux de travail, cliquez sur Oui.

Arrêter un flux de travail

Si une erreur de flux de travail se produit, ou si un flux de travail ne répond plus, vous pouvez arrêter celui-ci. Vous pouvez également souhaiter arrêter un flux de travail dont l'annulation est impossible. L'arrêt d'un flux de travail lui attribue l'état Annulé et supprime toutes les tâches créées par celui-ci, mais ne notifie pas les participants.

Pour arrêter un flux de travail dans une liste ou une bibliothèque

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site SharePoint sur le site que vous configurez.

  2. Accédez à la liste ou à la bibliothèque pour laquelle vous souhaitez annuler un flux de travail.

    Si le nom de la liste ou de la bibliothèque n'est pas visible, cliquez sur Afficher tout le contenu du site, puis cliquez sur le nom de la liste ou de la bibliothèque.

  3. Pointez sur le document ou l'élément impliqué dans le flux de travail, cliquez sur la flèche qui s'affiche, puis sur Flux de travail.

  4. Dans la page Flux de travail, dans la section Flux de travail en cours d'exécution, cliquez sur le nom du flux de travail à arrêter.

  5. Dans la page État du flux de travail, dans la section Informations sur le flux de travail, cliquez sur Interrompre ce flux de travail.

  6. Dans la boîte de dialogue qui s'affiche, cliquez sur OK.

Pour arrêter un flux de travail de site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Propriétaires du site SharePoint sur le site que vous configurez.

  2. Accédez à la page d'accueil du site pour lequel vous voulez arrêter un flux de travail de site.

  3. Dans le menu Actions du site, cliquez sur Flux de travail d'un site.

  4. Dans la page Flux de travail, dans la section Mes flux de travail en cours d'exécution, cliquez sur le nom du flux de travail à annuler.

  5. Dans la page État du flux de travail, dans la section Informations sur le flux de travail, cliquez sur Interrompre ce flux de travail.

  6. Dans la boîte de dialogue qui s'affiche, cliquez sur OK.

Historique des modifications


Désinstaller un flux de travail (SharePoint Foundation 2010)
Voir aussi

Lorsqu'un flux de travail qui a été installé en tant que composant fonctionnel n'est plus nécessaire, vous pouvez le désinstaller à l'aide de l'applet de commande Uninstall-SPFeature dans SharePoint 2010 Management Shell de la même façon que vous désinstallez n'importe quel autre composant fonctionnel SharePoint. Pour plus d'informations, voir Uninstall-SPFeature.

Important :
Pour exécuter Windows PowerShell, vérifiez que vous avez satisfait aux conditions requises minimales :

  • Voir Add-SPShellAdmin.

Les flux de travail Visual Studio sont toujours installés en tant que composants fonctionnels et les flux de travail déclaratifs qui ont été empaquetés dans des fichiers wsp peuvent être déployés en tant que composant ou solutions dans la galerie de solutions. Il est à noter que les flux de travail qui sont déployés directement à partir de Microsoft SharePoint Designer 2010 ne sont pas déployés en tant que composants fonctionnels. Pour désinstaller un flux de travail déclaratif, publié directement à partir de SharePoint Designer, vous supprimez les fichiers sources du flux de travail de la collection de sites sur laquelle il est installé. Pour plus d'informations, voir Supprimer un flux de travail SharePoint Designer (SharePoint Foundation 2010).

Avant d'utiliser l'applet de commande Uninstall-SPFeature pour désinstaller un composant fonctionnel, toutes les instances de flux de travail doivent être terminées, annulées ou interrompues et le flux de travail doit être désactivé. Après la désinstallation d'un composant fonctionnel, le flux de travail figurant dans ce composant fonctionnel n'est plus disponible depuis l'interface utilisateur, pour l'associer à des listes, à des bibliothèques, etc. Les fichiers sources sont toujours sur le serveur pour permettre de réinstaller plus tard le flux de travail. Utilisez l'applet de commande Windows PowerShellInstall-SPFeature pour réinstaller le composant fonctionnel. Pour plus d'informations, voir Install-SPFeature.

Voir aussi

Concepts

Annuler ou terminer une instance de flux de travail (SharePoint Foundation 2010)
Activer ou désactiver un flux de travail (SharePoint Foundation 2010)

Historique des modifications


Supprimer un flux de travail SharePoint Designer (SharePoint Foundation 2010)

Lorsqu'un flux de travail Microsoft SharePoint Designer 2010 n'est plus nécessaire, vous pouvez le supprimer. La suppression d'un flux de travail SharePoint Designer supprime définitivement du site les fichiers sources du flux de travail et rend celui-ci indisponible aux utilisateurs sur le site. Le flux de travail supprimé est automatiquement retiré de la liste ou de la bibliothèque à laquelle il avait été associé lors de sa création.

Supprimer un flux de travail SharePoint Designer

Suivez la procédure ci-après pour supprimer un flux de travail SharePoint Designer.

Remarque :
La suppression d'un flux de travail SharePoint Designer supprime également les données d'historique de ce flux de travail.

Pour supprimer un flux de travail SharePoint Designer

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Pour supprimer un flux de travail d'un serveur, vous devez disposer du niveau d'autorisation Concepteur sur le site duquel vous supprimez le flux de travail. Vous devez également disposer de l'accès à SharePoint Designer 2010.

  2. Démarrez SharePoint Designer 2010.

  3. Dans le volet Navigation, cliquez sur Sites, puis sur Ouvrir le site.

  4. Dans la boîte de dialogue Ouvrir le site, dans la zone Nom du site, tapez l'URL du site SharePoint qui contient le flux de travail que vous souhaitez supprimer, puis cliquez sur Ouvrir.

  5. Dans le volet Navigation, cliquez sur Flux de travail.

  6. Dans l'onglet Flux de travail, dans la colonne Nom, cliquez avec le bouton droit sur le flux de travail que vous souhaitez supprimer, puis cliquez sur Supprimer.

  7. Dans la boîte de dialogue Confirmer la suppression, cliquez sur Oui pour confirmer votre souhait de supprimer le flux de travail.

Historique des modifications


Surveiller des flux de travail (SharePoint Foundation 2010)

Après le démarrage d'un flux de travail, vous pouvez vérifier son état général dans la liste ou la bibliothèque de documents associée. Pour plus d'informations, voir Vérifier l'état des flux de travail.

Vous pouvez également afficher des rapports détaillés qui indiquent l'heure de début du flux de travail, la tâche en cours, la personne responsable de la réalisation de cette tâche, la durée de chaque tâche au sein d'un flux de travail, et la durée de toutes les activités du flux de travail. Pour plus d'informations, voir Afficher les rapports de flux de travail.

Pour une aide au diagnostic des erreurs associées à un flux de travail, voir Résoudre les erreurs de flux de travail.

Historique des modifications


Vérifier l'état des flux de travail (SharePoint Foundation 2010)

Vous pouvez vérifier l'état général d'une instance de flux de travail en affichant les informations d'état dans la liste ou la bibliothèque de documents à laquelle le flux de travail est associé. Vous pouvez obtenir des informations détaillées sur l'état du flux de travail en affichant la page État du flux de travail qui est automatiquement créée et conservée pour tous les flux de travail en cours d'exécution.

Important :
Vous devez être un utilisateur bénéficiant des autorisations Modifier les éléments pour effectuer ces procédures.

Dans cet article :

  • Vérifier l'état général d'un flux de travail

  • Vérifier l'état détaillé d'un flux de travail relativement aux éléments d'une liste ou d'une bibliothèque

  • Vérifier l'état détaillé d'un flux de travail de site

Vérifier l'état général d'un flux de travail

Procédez comme suit pour vérifier l'état général d'un flux de travail.

Pour vérifier l'état général d'un flux de travail

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être un utilisateur doté des autorisations Modifier des éléments sur la liste ou la bibliothèque.

  2. Accédez à la liste ou à la bibliothèque de documents qui contient le flux de travail dont vous souhaitez vérifier l'état.

  3. Recherchez l'élément dont vous souhaitez vérifier l'état et afficher les informations relatives à l'état dans la colonne d'état du flux de travail.

    Remarque :
    La colonne d'état du flux de travail porte le nom du flux de travail.

Vérifier l'état détaillé d'un flux de travail relativement aux éléments d'une liste ou d'une bibliothèque

Procédez comme suit pour vérifier l'état détaillé d'un flux de travail relativement aux éléments d'une liste ou d'une bibliothèque.

Pour vérifier l'état détaillé d'un flux de travail relativement aux éléments d'une liste ou d'une bibliothèque

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être un utilisateur doté des autorisations Modifier des éléments sur la liste ou la bibliothèque.

  2. Accédez à la liste ou à la bibliothèque de documents qui contient le flux de travail dont vous souhaitez vérifier l'état.

  3. Dans la ligne de l'élément dont vous souhaitez vérifier l'état, cliquez sur le lien dans la colonne de l'état du flux de travail.

    Remarque :
    La colonne d'état du flux de travail porte le nom du flux de travail.

  4. La page État du flux de travail contient les informations suivantes sur le flux de travail :

    • Nom de la personne qui a lancé le flux de travail

    • Date et heure du démarrage du flux de travail

    • Date et heure de la dernière exécution ou reprise du flux de travail

    • Nom et lien vers le document ou l'élément concerné par le flux de travail

    • État actuel du flux de travail

    • S'il s'agit d'un flux de travail SharePoint Designer et qu'une visualisation de flux de travail a été publiée avec le flux de travail, une visualisation de type de diagramme Visio du flux de travail apparaît.

    • Liste des tâches affectées aux participants du flux de travail

    • Liste de tous les événements qui ont eu lieu jusqu'à présent dans l'historique de cette instance du flux de travail (par exemple, démarrage du flux de travail, création de tâche, exécution de tâche)

Suivant le type de flux de travail que vous consultez, la page État du flux de travail peut également contenir des liens permettant de modifier, d'annuler et de mettre fin au flux de travail. Pour plus d'informations, voir Gérer les flux de travail (SharePoint Foundation 2010).

Vérifier l'état détaillé d'un flux de travail de site

Procédez comme suit pour vérifier l'état détaillé d'un flux de travail de site.

Pour vérifier l'état détaillé d'un flux de travail de site

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe SharePoint des propriétaires du site.

  2. Accédez au site dont vous souhaitez vérifier l'état de flux de travail.

  3. Dans le menu Actions du site, cliquez sur Flux de travail d'un site.

  4. Dans la page Flux de travail, effectuez l'une des opérations suivantes :

    • Pour afficher l'état des flux de travail en cours, dans la section Mes flux de travail en cours d'exécution, cliquez sur le nom du flux de travail dont vous souhaitez vérifier l'état.

    • Pour afficher l'état des flux de travail terminés, dans la section Mes flux de travail terminés, cliquez sur le nom du flux de travail dont vous souhaitez vérifier l'état.

  5. La page État du flux de travail contient les informations suivantes sur le flux de travail :

    • Nom de la personne qui a lancé le flux de travail

    • Date et heure du démarrage du flux de travail

    • Date et heure de la dernière exécution ou reprise du flux de travail

    • État actuel du flux de travail

    • Liste des tâches affectées aux participants du flux de travail.

    • La liste de tous les événements qui ont eu lieu jusqu'à présent dans l'historique de cette instance du flux de travail (par exemple, démarrage du flux de travail, création de tâche, exécution de tâche) apparaît dans la section Historique des flux de travail.

Historique des modifications


Afficher les rapports de flux de travail (SharePoint Foundation 2010)

Microsoft SharePoint Foundation 2010 fournit des rapports de flux de travail individuels et consolidés qui vous permettent d'évaluer l'efficacité de vos flux de travail et des processus de gestion associés. Vous pouvez utiliser ces rapports pour localiser les problèmes qui affectent les processus ou pour déterminer si un groupe ou une personne atteint les performances cibles pour un processus de gestion particulier.

Cet article comprend les rubriques suivantes :

  • Afficher le résumé de l'utilisation du flux de travail de la collection de sites

  • Afficher des rapports de flux de travail spécifiques

Afficher le résumé de l'utilisation du flux de travail de la collection de sites

Vous pouvez afficher la liste des flux de travail disponibles pour la collection de sites, le résumé de leur utilisation (actif ou inactif), le nombre d'associations de ces flux de travail et le nombre d'instances en cours d'exécution pour chaque flux de travail actif.

Pour afficher le résumé de l'utilisation du flux de travail de la collection de sites

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être membre du groupe Administrateurs de collection de sites sur la collection que vous configurez.

  2. Accédez au site de niveau supérieur de la collection de sites pour laquelle afficher les rapports sur le flux de travail.

  3. Dans le menu Actions du site, cliquez sur Paramètres du site.

  4. Dans la page Paramètres du site, dans la section Administration du site, cliquez sur Flux de travail pour afficher le rapport relatif aux flux de travail de la collection de sites.

Afficher des rapports de flux de travail spécifiques

SharePoint Foundation 2010 met à votre disposition deux rapports Microsoft Excel prédéfinis qui fournissent une analyse unifiée de l'historique de flux de travail pour chaque instance de flux de travail : le rapport de durée d'activité et le rapport des annulations et erreurs. Le rapport de durée d'activité indique la durée d'exécution de chaque activité et de toutes les tâches au sein d'un flux de travail. Le rapport des annulations et erreurs indique les flux de travail qui ont été annulés ou qui ont généré des erreurs avant leur achèvement. Chacun de ces rapports se présente sous la forme d'un fichier Microsoft Excel.

Remarque :
Si vous utilisez des flux de travail personnalisés, vous devez spécifier les paramètres appropriés dans le modèle de flux de travail pour générer les données de ces rapports. Pour plus d'informations, voir Développement de solutions de flux de travail avec SharePoint Server 2007 et Windows Workflow Foundation (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=120912&clcid=0x40C).

Pour afficher des rapports de flux de travail spécifiques

  1. Vérifiez que vous disposez des informations d'identification suivantes :

    • Pour afficher des rapports de flux de travail spécifiques, vous devez être un utilisateur doté des autorisations Modifier l'élément.

  2. Accédez à la liste ou à la bibliothèque de documents qui contient le flux de travail pour lequel vous souhaitez afficher des rapports.

  3. Pointez sur l'élément ou le document impliqué dans le flux de travail, cliquez sur la flèche qui apparaît, puis cliquez sur Flux de travail.

  4. Dans la page Flux de travail, dans la section Flux de travail en cours d'exécution, cliquez sur le nom du flux de travail dont l'état vous intéresse. Si aucun flux de travail n'est répertorié dans cette section, aucun flux de travail n'est en cours d'exécution sur l'élément sélectionné.

  5. Sur la page État du flux de travail, dans la section Historique des flux de travail, cliquez sur Afficher les rapports de flux de travail.

  6. Dans la page Afficher les rapports de flux de travail, recherchez l'association de flux de travail dont vous souhaitez afficher les rapports, puis effectuez l'une des opérations suivantes :

    • Pour connaître la durée d'exécution de chaque activité d'un flux de travail et de chaque instance du flux de travail, cliquez sur Rapport de durée d'activité.

    • Pour identifier les flux de travail qui ont été annulés ou ont généré des erreurs avant leur achèvement, cliquez sur Rapport des annulations et erreurs.

    Remarque :
    Les rapports sont répertoriés par ordre alphabétique des noms d'association de flux de travail. Les rapports de durée d'activité retournent uniquement les données d'historique qui contiennent des informations de durée. Les rapports des annulations et erreurs retournent uniquement les données d'historique qui contiennent des erreurs ou des événements de type annulation.

  7. Dans la section Emplacement du fichier, cliquez sur Parcourir, spécifiez l'emplacement où enregistrer le rapport, puis cliquez sur OK.

Historique des modifications


Résoudre les erreurs de flux de travail (SharePoint Foundation 2010)

Les flux de travail peuvent rencontrer des problèmes dans l'environnement de l'utilisateur, en particulier l'état des éléments de liste dont dépend le flux de travail et les paramètres du serveur qui régissent les flux de travail. Lorsqu'un problème est détecté, les flux de travail cessent de fonctionner. Les raisons d'échec de flux de travail sont le plus souvent dues à un défaut de conception du flux de travail, des problèmes de réseau ou des autorisations utilisateur limitées. En raison de la forte influence de tous ces facteurs et de la complexité de création des flux de travail, la résolution des problèmes de flux de travail peut être difficile.

Afficher les erreurs de flux de travail dans le navigateur

Plusieurs raisons peuvent provoquer l'échec d'un flux de travail. Par exemple, un flux de travail peut être conçu pour créer un élément dans une bibliothèque, mais celle-ci pourrait avoir été supprimée. Ou bien, les autorisations utilisateur pourraient avoir été modifiées après le démarrage du flux de travail. Il est alors impossible pour l'utilisateur d'accéder au site afin d'effectuer une tâche du flux de travail. Lorsque le flux de travail ne fonctionne pas correctement, son état final s'affiche dans la colonne contenant le nom de ce flux, dans la liste à laquelle le flux de travail est associé.

Outre Terminé, l'état final que vous pouvez voir dans cette colonne est Une erreur s'est produite, Arrêté, Échec au démarrage (nouvelle tentative en cours) ou Échec au démarrage.

Résoudre les erreurs de flux de travail courantes

Si l'état final d'un flux de travail est Une erreur s'est produite, la première étape de dépannage du flux de travail consiste à déterminer la cause de l'erreur. La méthode de dépannage utilisée dépend du type de flux de travail dans lequel l'erreur s'est produite : un flux de travail prédéfini, un flux de travail Microsoft SharePoint Designer ou un flux de travail Visual Studio personnalisé.

Pour les flux de travail prédéfinis, l'historique des flux de travail est un outil efficace de dépannage. Cet historique affiche l'état actuel et l'ensemble des états précédents d'un flux de travail en cours d'exécution. Lorsqu'une erreur se produit dans un flux de travail, le dernier événement de la liste de l'historique du flux de travail s'intitule Erreur. La liste indique le moment où l'erreur s'est produite mais ne fournit généralement pas de description du problème pour éviter de divulguer des informations sensibles ce qui pourrait engendrer un problème de sécurité. Les erreurs les plus courantes sont dues à des problèmes de connectivité, des paramètres de messagerie électronique incorrects ou à des autorisations utilisateur limitées.

Pour plus d'informations sur l'accès à l'historique des flux de travail, voir Afficher les rapports de flux de travail (SharePoint Foundation 2010).

Pour les flux de travail Microsoft SharePoint Designer, à la création du flux, vous pouvez y insérer des actions qui écrivent dans l'historique à tout moment dans le flux de travail. Cela permet de déterminer la dernière étape réussie effectuée par le flux de travail avant la survenue de l'erreur, ainsi que l'étape où l'erreur s'est produite.

Pour les flux de travail Visual Studio personnalisés, vous pouvez utiliser toutes les fonctionnalités de débogage disponibles dans Visual Studio, ainsi que les options de dépannage pour les flux de travail prédéfinis.

Remarque :
Pour plus d'informations sur le débogage des flux de travail, voir Étape 5 : déboguer votre flux de travail (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=107820&clcid=0x40C) sur le blog de l'équipe Microsoft SharePoint.

Historique des modifications


Déployer un flux de travail sous forme de fichier WSP (SharePoint Foundation 2010)

Lorsque vous utilisez Microsoft SharePoint Designer 2010 pour créer des flux de travail, vous pouvez les enregistrer sous forme de modèles de flux de travail (fichiers .wsp). Le fichier .wsp peut ensuite être utilisé pour déployer le flux de travail sur plusieurs sites et plusieurs collections de sites.

Déploiement d'un flux de travail sous forme de fichier WSP Lire une vidéo (éventuellement en anglais) qui illustre comment utiliser l'interface utilisateur pour déployer un flux de travail comme fichier WSP.

Cliquez avec le bouton droit sur le lien pour télécharger et enregistrer la vidéo.

Pour déployer un flux de travail sous forme de fichier .wsp, procédez comme suit :

  • Télécharger le fichier WSP

  • Transférer le fichier WSP dans une collection de sites

  • Activer la fonctionnalité du flux de travail sur un site

Télécharger le fichier WSP

Utilisez la procédure suivante pour ouvrir la bibliothèque de documents Éléments de site sur le site de niveau supérieur de la collection de sites où le modèle de flux de travail a été enregistré, puis téléchargez le flux de travail sous forme de fichier .wsp dans un dossier local sur le serveur qui exécute Microsoft SharePoint Foundation 2010 ou un partage réseau. Le fichier téléchargé peut ensuite être transféré dans la Galerie de solutions de toute collection de sites.

Pour télécharger le fichier WSP dans un emplacement de fichier

  1. Dans le site de niveau supérieur, dans le Lancement rapide, cliquez sur Tout le contenu du site.

  2. Dans la page Tout le contenu du site, dans la section Bibliothèques de documents, cliquez sur Éléments de site.

  3. Pointez sur le nom du flux de travail que vous souhaitez modifier, puis cliquez sur la flèche qui apparaît.

  4. Pointez sur Envoyer vers, puis cliquez sur Télécharger une copie.

  5. Dans la boîte de dialogue Téléchargement de fichiers, cliquez sur Enregistrer.

  6. Dans la zone Enregistrer sous, tapez l'emplacement où vous souhaitez enregistrer le fichier, puis cliquez sur Enregistrer.

  7. Dans la boîte de dialogue Téléchargement terminé, cliquez sur Fermer.

Transférer le fichier WSP dans une collection de sites

Utilisez l'une des procédures suivantes pour télécharger le fichier .wsp dans la Galerie de solutions d'une collection de sites. Le modèle de flux de travail devient alors disponible comme fonctionnalité que vous activerez ensuite sur la collection de sites. Cette disponibilité concerne tous les sites de la collection de sites. Cependant, ceci n'active pas la fonctionnalité sur tous les sites de la collection de sites.

Dans cette section :

  • Pour télécharger le fichier WSP sur une collection de sites à l'aide de l'interface utilisateur

  • Pour télécharger le fichier WSP sur une collection de sites à l'aide de Windows PowerShell

Pour télécharger le fichier WSP sur une collection de sites à l'aide de l'interface utilisateur

  1. Sur le site de niveau supérieur de la collection de sites, dans le menu Actions du site, cliquez sur Paramètres du site.

  2. Dans la page Paramètres du site, dans la section Galeries, cliquez sur Solutions.

  3. Dans l'onglet Solutions du ruban, dans le groupe Nouveau, cliquez sur Télécharger la solution.

  4. Dans la boîte de dialogue Galerie Solutions - Télécharger la solution, cliquez sur Explorer.

  5. Dans la boîte de dialogue Choisir un fichier à télécharger, sélectionnez le partage de fichiers, sélectionnez le fichier WSP, puis cliquez sur Ouvrir.

  6. Dans la boîte de dialogue Galerie Solutions - Télécharger la solution, cliquez sur OK.

    La boîte de dialogue Galerie Solutions - Activer la solution apparaît.

  7. Dans la boîte de dialogue Galerie Solutions - Activer la solution, cliquez sur Activer.

    Le flux de travail devient alors disponible en tant que fonctionnalité dans tous les sites dans cette collection de sites. Le nom du flux de travail apparaît maintenant dans la Galerie Solutions, et État est défini sur Activé.

Pour télécharger le fichier WSP sur une collection de sites à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin. Vous devez aussi être membre du rôle SharePoint_Shell_Access sur la base de données de contenu. Pour plus d'information, voir Add-SPShellAdmin et Get-SPContentDatabase.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Add-SPUserSolution -LiteralPath <LiteralPath> -Site <SiteURL>

    Où :

    • <LiteralPath> est le chemin d'accès complet qui inclut le nom du fichier WSP.

    • <SiteURL> est l'URL de la collection de sites.

    Le flux de travail est maintenant déployé en tant que fonctionnalité. Cependant, avant que vous puissiez utiliser le flux de travail, vous devez l'activer pour la collection de sites.

  6. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Install-SPUserSolution -Identity <Solution> -Site <SiteURL>

    Où :

    • <Solution> est le nom de la solution à activer.

    • <SiteURL> est l'URL de la collection de sites.

Pour plus d'informations sur les applets de commande Add-SPUserSolution et Install-SPUserSolution, voir Install-SPUserSolution et Add-SPUserSolution.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Activer la fonctionnalité du flux de travail sur un site

Utilisez l'une des procédures suivantes pour activer la fonctionnalité sur tout site où vous souhaitez utiliser le flux de travail.

Dans cette section :

  • Pour activer la fonctionnalité de flux de travail sur un site à l'aide de l'interface utilisateur

  • Pour activer la fonctionnalité sur un site à l'aide de Windows PowerShell

Pour activer la fonctionnalité de flux de travail sur un site à l'aide de l'interface utilisateur

  1. Accédez au site ou vous souhaitez activer la fonctionnalité, puis dans le menu Actions du site, cliquez sur Paramètres du site.

  2. Dans la page Paramètres du site, dans la section Actions du site, cliquez sur Gérer les fonctionnalités du site.

    Dans la page Fonctionnalités du site, vous pouvez voir que le modèle de flux de travail est disponible mais n'est pas actif.

  3. Cliquez sur Activer.

    Dans la page Fonctionnalités, l'état du modèle de flux de travail apparaît maintenant comme étant Actif.

Pour activer la fonctionnalité sur un site à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin. Vous devez aussi être membre du rôle SharePoint_Shell_Access sur la base de données de contenu. Pour plus d'information, voir Add-SPShellAdmin et Get-SPContentDatabase.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Enable-SPFeature -Identity <Feature> -Url <URL>

    Où :

    • <Feature> est le nom de la fonctionnalité à activer.

      Remarque :
      Le nom de la fonctionnalité ne correspond pas au nom que vous avez donné au flux de travail. Le nom de la fonctionnalité est plutôt généralement le nom du flux de travail auquel est ajouté le suffixe « ListInstances ».

      En cas de doute sur le nom de la fonctionnalité à activer, vous pouvez vérifier ce nom en procédant comme suit.

      1. Faites une copie du fichier .wsp et changez l'extension du nom de fichier du fichier copié en .cab.

      2. Dans l'Explorateur Windows, cliquez avec le bouton droit sur le fichier .cab, puis cliquez sur Ouvrir.

      3. Sélectionnez feature.xml.

        Le nom de la fonctionnalité est indiqué dans la colonne Chemin d'accès.

    • <URL> est l'URL du site.

Pour plus d'informations sur l'applet de commande Enable-SPFeature, voir Enable-SPFeature.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Administration mobile (SharePoint Foundation 2010)

Les affichages mobiles sont activés par défaut pour la plupart des sites et bibliothèques SharePoint. Les utilisateurs peuvent accéder aux bibliothèques de documents, listes, Wikis, blogs, pages de composants WebPart, données métiers principales et sites à partir de leurs appareils mobiles. Voici quelques-unes des autres fonctionnalités mobiles disponibles :

  • Les utilisateurs peuvent tirer parti de l'expérience de recherche mobile pour rechercher des personnes, des informations de contact et du contenu sur des sites SharePoint.

  • Les utilisateurs peuvent s'abonner à des alertes SMS (Short Message Service). Les alertes sont envoyées aux appareils mobiles des utilisateurs lorsque des modifications sont apportées à une liste ou à un élément SharePoint.

  • Avec Microsoft Office Web Apps, les utilisateurs peuvent afficher des documents Word, Excel et PowerPoint dans des navigateurs mobiles.

    Remarque :
    Pour plus d'informations sur Office Web Apps, voir Office Web Apps (Installed on SharePoint 2010 Products).

    Conseil :
    Les documents protégés par la Gestion des droits relatifs à l'information (IRM) ne peuvent pas être ouverts par Windows Phone 7. Ne définissez pas de stratégies IRM sur des bibliothèques de documents que vous souhaitez rendre accessibles à des utilisateurs de Windows Phone 7.

Dans cette section :

  • Configurer un compte mobile (SharePoint Foundation 2010)

    Cet article explique comment configurer et gérer un compte mobile pour permettre aux utilisateurs de s'abonner à des alertes envoyées par SMS.

  • Configure mobile views (SharePoint Foundation 2010) (en anglais)

    Cet article explique comment les administrateurs peuvent configurer des affichages mobiles pour des bibliothèques et listes personnalisées.

  • Configurer l'accès externe pour les appareils mobiles (SharePoint Foundation 2010)

    Cet article décrit les options de configuration de l'accès externe aux sites SharePoint pour les appareils mobiles.

Historique des modifications


Configure mobile views (SharePoint Foundation 2010) (en anglais)

A mobile view is a version of the SharePoint site that has been optimized for mobile devices. In Microsoft SharePoint Foundation, mobile views are enabled by default for most lists or libraries that were created by using default templates. Mobile views are not enabled by default for custom lists, custom libraries, or for lists or libraries that were created in previous versions of SharePoint that have been upgraded to SharePoint Foundation. Mobile views are not available for Datasheet and Gantt view types.

The browser definition file lists the mobile browsers and devices that are supported by SharePoint Foundation and is used to redirect mobile browsers to the mobile views. You can modify the browser definition file to change the redirect behavior of a mobile browser, or to add or delete entries from the list of supported mobile devices.

In this article:

  • Configure mobile views

  • Modify the browser definition file (compat.browser)

Configure mobile views

This section describes how to configure mobile views for custom lists, custom libraries, or for lists or libraries that were created in previous versions of SharePoint.

Remarque :
Mobile views are not available for Datasheet and Gantt view types.

To configure the mobile view for a list

  1. In the list for which you want to configure the mobile view, in List Tools, click the List tab on the ribbon.

  2. On the ribbon, in the Manage Views group, click Modify View.

  3. On the Edit <list type> View page, expand Mobile, and then configure the following settings according to your preferences:

    Remarque :
    Not all settings are available for all views.

    Enable this view for mobile access

    Make this view the default view for mobile access

    Number of items to display in list view web part for this view

    Field to display in mobile list simple view

To configure the mobile view for a library

  1. In the library for which you want to configure the mobile view, in Library Tools, click the Library tab on the ribbon.

  2. On the ribbon, in the Manage Views group, click Modify View.

  3. On the Edit View page, expand Mobile, and then configure the following settings according to your preferences:

    Remarque :
    Not all settings are available for all views.

    Enable this view for mobile access

    Make this view the default view for mobile access

    Number of items to display in list view web part for this view

    Field to display in mobile list simple view

Modify the browser definition file (compat.browser)

The browser definition file contains a list of the mobile browsers and devices that can access mobile views in SharePoint Foundation. When a user browses a SharePoint site from a mobile device, the mobile browser submits to the site an HTTP GET request that includes a user agent string. If the mobile browser and device model in the user agent string are listed in the browser definition file and the isMobileDevice setting for the mobile browser is set to true, SharePoint Foundation redirects the mobile browser to the mobile view of the site. Otherwise, a standard view of the site is shown in the mobile browser. You can modify the file to change the redirect behavior of a mobile browser.

The browser definition file lists the mobile browsers and devices that are supported by SharePoint Foundation. The file can be updated when product updates to SharePoint Foundation are released. You can also modify the file to add a mobile browser or device to the list.

Remarque :
There is a compat.browser file for each Internet Information Services (IIS) Web site.

To change the redirect behavior of a mobile browser

  1. Start Gestionnaire des services Internet (IIS) by typing INETMGR at a command prompt.

  2. Right-click the IIS Web site where the SharePoint Web application is installed, and then click Explore.

  3. In Windows Explorer, double-click the App_Browsers folder.

  4. Open the compat.browser file in a text editor.

  5. Find the <browser> node that corresponds to the mobile browser or device that you want to modify.

  6. Find the <capability name="isMobileDevice" value="true" /> element.

  7. Set the value attribute to false to display a standard view of the site in the mobile browser.

To add a mobile browser or device, you create a <browser> node that identifies the mobile browser or device and defines its capabilities. For more information about what can be entered in the <browser> node, see Browser Definition File Schema (browsers Element) (http://go.microsoft.com/fwlink/?LinkID=146162).

To add a mobile browser and device model

  1. Start Gestionnaire des services Internet (IIS) by typing INETMGR at a command prompt.

  2. Right-click the IIS Web site where the SharePoint Web application is installed, and then click Explore.

  3. In Windows Explorer, double-click the App_Browsers folder.

  4. Open the compat.browser file in a text editor.

  5. Find the <browsers> node.

  6. Add a new <browser> node to the end of the list of browsers.

Historique des modifications

Date | Description | Raison
2011/01/17 | 2011/01/17 | Mise à jour du contenu


Configurer l'accès externe pour les appareils mobiles (SharePoint Foundation 2010)

Cet article explique comment rendre des sites SharePoint accessibles de manière externe pour des appareils mobiles. L'activation de l'accès externe peut s'effectuer de trois manières.

  • Serveur de réseau privé virtuel Un serveur de réseau privé virtuel (VPN) qui prend en charge le protocole SSL (Secure Sockets Layer), tel que Microsoft Forefront Unified Access Gateway (UAG), vous permet de publier des sites SharePoint à travers le pare-feu d'entreprise. Après cela, vous devez configurer un mappage des accès de substitution. Le site SharePoint doit également appartenir à une zone autorisant l'accès à travers le pare-feu. Pour plus d'informations sur l'accès à travers le pare-feu, voir Configurer l'accès à travers le pare-feu.

    Remarque :
    Si vous utilisez un serveur UAG, vous devez effectuer une configuration supplémentaire afin de prendre en charge Microsoft Office Mobile. Pour plus d'informations, voir Configurer Forefront Unified Access Gateway pour Office Mobile.

  • Serveur proxy mobile Les serveurs proxys mobiles, tels que Microsoft System Center Mobile Device Center et Blackberry Enterprise Server, aident les appareils mobiles à opérer au sein de l'infrastructure informatique d'une entreprise. Pour accéder à un site SharePoint depuis l'extérieur du pare-feu d'entreprise, le serveur proxy mobile doit transmettre les en-têtes HTTP du navigateur mobile directement à SharePoint Foundation.

  • Accès Internet direct Le site SharePoint peut être placé sur l'extranet. Cette option prend en charge uniquement l'authentification de base. Nous recommandons l'utilisation d'une combinaison de mécanismes de sécurité faisant appel à des technologies et à des stratégies (tel que le protocole SSL) avec tout serveur exposé à Internet.

Dans cet article :

  • Configurer l'accès à travers le pare-feu

  • Configurer Forefront Unified Access Gateway pour Office Mobile

Configurer l'accès à travers le pare-feu

Après la publication du site SharePoint en dehors du pare-feu, vous devez ajouter le site à une zone qui autorise l'accès à travers le pare-feu. Cette zone sert à générer les URL mobiles et de PC externes dans les messages d'alerte mobiles et permet aux utilisateurs d'envoyer une URL accessible en externe lorsqu'ils cliquent sur le bouton Envoyer un lien par messagerie dans le Ruban.

Pour configurer une zone d'accès à travers le pare-feu

  1. Dans l'Administration centrale, cliquez sur Paramètres système.

  2. Dans la page Paramètres système, sous Gestion de la batterie, cliquez sur Configurer la zone d'accès à travers le pare-feu.

  3. Dans la page Zone d'accès à travers le pare-feu, dans Application Web, dans la zone de liste Application Web, sélectionnez l'application Web qui est publiée à travers le pare-feu.

  4. Dans Zone d'accès à travers le pare-feu, dans la zone de liste Sélection d'une zone d'accès à travers le pare-feu, sélectionnez la zone qui est publiée à travers le pare-feu.

Configurer Forefront Unified Access Gateway pour Office Mobile

Forefront Unified Access Gateway (UAG) fournit une passerelle permettant aux employés distants, travailleurs mobiles, partenaires et autres tierces parties d'accéder à des applications et des ressources d'entreprise. Pour plus d'informations sur UAG, voir Forefront Unified Access Gateway (UAG) (éventuellement en anglais) et Guide des solutions de publication SharePoint (éventuellement en anglais).

Les procédures suivantes décrivent les paramètres spécifiques nécessaires à la prise en charge de Microsoft Office Mobile sur Windows Phone 7 et Windows Phone 6.5.

Pour ignorer l'analyse des corps de réponse

  1. Sur le serveur UAG, démarrez l'application Forefront UAG Management.

  2. Dans le volet de navigation, cliquez sur Connexions HTTPS, puis cliquez sur le nom du segment.

  3. Sous l'onglet Portail, cliquez sur le bouton Modifier qui se trouve à droite du texte Ne pas analyser les corps de réponse à ces demandes.

  4. Dans la boîte de dialogue URL sans analyse du corps, sous Serveurs, cliquez sur Ajouter.

  5. Entrez le nom du serveur exécutant SharePoint Foundation. Par exemple, si l'URL du serveur est https://contoso, tapez contoso comme nom de serveur.

  6. Dans la boîte de dialogue URL sans analyse du corps, sous URL, cliquez sur Ajouter.

  7. Dans la boîte de dialogue Ajouter une URL, ajoutez les URL suivantes :

    • .*/_vti_bin/webs\.asmx

    • .*/_vti_bin/lists\.asmx

  8. Cliquez sur OK.

Pour permettre aux applications clientes enrichies de contourner l'authentification de segment

  1. Sur le serveur UAG, démarrez l'application Forefront UAG Management.

  2. Dans le volet de navigation, cliquez sur Connexions HTTPS, puis cliquez sur le nom du segment.

  3. Dans la liste Applications, sélectionnez l'application SharePoint Foundation, puis cliquez sur Modifier.

  4. Sous l'onglet Lien du portail, activez la case à cocher Autoriser les clients enrichis à contourner l'authentification de segment.

Les utilisateurs peuvent accéder à des sites SharePoint à l'aide d'un navigateur mobile ou de Microsoft SharePoint Workspace Mobile 2010. Ils doivent au préalable configurer une adresse Forefront UAG sur leur appareil mobile pour que SharePoint Workspace Mobile 2010 puisse être utilisé pour accéder à un site SharePoint. Par ailleurs, ils doivent savoir comment configurer leur appareil mobile et connaître l'URL du segment UAG.

Pour configurer les paramètres UAG sur l'appareil Windows Phone (utilisateurs finaux)

  1. Sur l'appareil mobile, démarrez SharePoint Workspace Mobile.

  2. Cliquez sur Menu, Paramètres, puis Configurer Forefront UAG Server.

  3. Dans la zone Adresse Forefront UAG, tapez l'URL du segment UAG.

  4. Entrez le nom d'utilisateur de domaine et le mot de passe.

  5. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
2011/01/17 | 2011/01/17 | Mise à jour du contenu
28 octobre 2010 | 2010/10/25 | Mise à jour du contenu


Administration de solutions en mode bac à sable (SharePoint Foundation 2010)

Un bac à sable est un environnement d'exécution restreint qui permet aux programmes d'accéder à certaines ressources uniquement et qui empêche les problèmes qui se produisent dans le bac à sable d'affecter le reste de l'environnement serveur. Les solutions que vous déployez dans un bac à sable, qui sont appelées solutions en mode bac à sable, ne peuvent pas utiliser certains ordinateurs et ressources réseau et ne peuvent pas accéder au contenu en dehors de la collection de sites dans laquelle elles sont déployées.

Dans cette section :

  • Activer des solutions en mode bac à sable dans la batterie de serveurs (SharePoint Foundation 2010)

    Fournit des instructions sur le démarrage du service de code en mode bac à sable Microsoft SharePoint Foundation.

  • Configurer l'équilibrage de charge pour les solutions bac à sable (sandbox) (SharePoint Foundation 2010)

    Fournit des instructions sur la sélection du modèle d'équilibrage de charge pour les solutions en mode bac à sable.

  • Bloquer ou débloquer une solution en mode bac à sable (SharePoint Foundation 2010)

    Fournit des instructions sur le blocage de l'exécution d'une solution en mode bac à sable.

Historique des modifications


Activer des solutions en mode bac à sable dans la batterie de serveurs (SharePoint Foundation 2010)
Voir aussi

Un bac à sable est un environnement d'exécution restreint qui permet aux programmes d'accéder à certaines ressources uniquement et qui empêche les problèmes qui se produisent dans le bac à sable d'affecter le reste de l'environnement serveur. Les solutions que vous déployez dans un bac à sable, qui sont appelées solutions en mode bac à sable, ne peuvent pas utiliser certains ordinateurs et ressources réseau et ne peuvent pas accéder au contenu en dehors de la collection de sites dans laquelle elles sont déployées. Dans la mesure où les solutions en mode bac à sable ne peuvent pas affecter l'ensemble de la batterie de serveurs, elles n'ont pas besoin d'être déployées par un administrateur de batterie de serveurs. Si des solutions en mode bac à sable ont été activées sur un serveur de la batterie de serveurs, un administrateur de collection de sites peut déployer les solutions pour qu'elles s'exécutent en mode bac à sable.

La possibilité d'exécuter des solutions en mode bac à sable est désactivée par défaut. Activez les solutions en mode bac à sable sur chaque serveur d'applications destiné à exécuter des solutions en mode bac à sable.

Activer des solutions en mode bac à sable

Vous pouvez utiliser les étapes suivantes pour activer les solutions en mode bac à sable sur chaque serveur d'applications de votre batterie de serveurs.

Pour activer des solutions en mode bac à sable via l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil du site Web Administration centrale de SharePoint, sous Paramètres système, sélectionnez Gérer les services sur le serveur.

  3. Dans la zone Serveur, sélectionnez le serveur sur lequel vous voulez activer les solutions en mode bac à sable.

  4. Dans la ligne Service de code en mode bac à sable Microsoft SharePoint Foundation, dans la colonne Action, cliquez sur Démarrer.

  5. Répétez les deux étapes précédentes pour chaque serveur sur lequel vous voulez activer les solutions en mode bac à sable.

Pour activer des solutions en mode bac à sable via Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Start-Service -Name SPUserCodeV4

Répétez cette procédure sur chaque serveur sur lequel vous voulez activer les solutions en mode bac à sable.

Voir aussi

Concepts

Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010)

Historique des modifications


Configurer l'équilibrage de charge pour les solutions bac à sable (sandbox) (SharePoint Foundation 2010)
Voir aussi

Un bac à sable (sandbox) est un environnement d'exécution restreint qui permet aux programmes d'accéder uniquement à certaines ressources, et qui permet d'éviter que les problèmes se produisant dans le bac à sable n'affecte le reste de l'environnement serveur. Les solutions que vous déployez dans un bac à sable, appelées solutions bac à sable, ne peuvent pas utiliser certaines ressources informatiques et réseau, et ne peuvent pas accéder au contenu en dehors de la collection de sites dans laquelle ils sont déployés.

Vous pouvez sélectionner l'un des deux schémas d'équilibrage de charge disponibles pour les solutions bac à sable. En fonction de votre choix, Microsoft SharePoint Server 2010 détermine le serveur sur lequel exécuter la solution. Si l'équilibrage de charge est local, la solution s'exécute sur le même serveur que celui qui traite la demande. Si l'équilibrage de charge est distant, le serveur sur lequel s'exécute la solution est sélectionné selon l'affinité de solution. Dans les deux cas, le serveur doit exécuter le service de mise en bac à sable.

Plus vous isolez les solutions bac à sable, plus vous serez en mesure de protéger la partie principale de votre site SharePoint Server contre du code pouvant consommer trop de ressources. Vous pouvez augmenter l'isolation en utilisant l'équilibrage de charge distant et en exécutant le service de mise en bac à sable uniquement sur des serveurs spécifiques.

Par défaut, équilibrage de charge est distant.

Configurer l'équilibrage de charge

L'équilibrage de charge affecte directement le temps de réponse des solutions bac à sable. La procédure suivante permet de modifier le modèle d'équilibrage de charge utilisé dans votre batterie de serveurs.

Pour configurer l'équilibrage de charge à l'aide de l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Pour configurer l'équilibrage de charge pour les solutions bac à sable, vous devez être membre du groupe Administrateurs de batterie sur l'ordinateur exécutant le site Web Administration centrale de SharePoint Server.

  2. Dans la page d'accueil du site Web Administration centrale de SharePoint, cliquez sur Paramètres système.

  3. Sous Gestion de la batterie, cliquez sur Gérer les solutions utilisateur.

  4. Dans la section Équilibrage de la charge de la page Gestion des solutions en mode bac à sable , sélectionnez l'une des options suivantes :

    • Tout le code des solutions en mode bac à sable est exécuté sur le même ordinateur comme demande. Ce schéma d'équilibrage de charge exécute le code en mode bac à sable sur le même serveur que celui qui traite le reste de la demande.

    • Les demandes d'exécution du code en mode bac à sable sont acheminées par affinité de solution. Ce schéma d'équilibrage de charge sélectionne le serveur sur lequel exécuter le code en mode bac à sable basé sur l'affinité de solution.

  5. Cliquez sur OK.

Voir aussi

Concepts

Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010)

Historique des modifications


Bloquer ou débloquer une solution en mode bac à sable (SharePoint Foundation 2010)
Voir aussi

Un bac à sable est un environnement d'exécution restreint qui permet aux programmes d'accéder à certaines ressources uniquement et qui empêche les problèmes qui se produisent dans le bac à sable d'affecter le reste de l'environnement serveur. Les solutions que vous déployez dans un bac à sable, qui sont appelées solutions en mode bac à sable, ne peuvent pas utiliser certains ordinateurs et ressources réseau et ne peuvent pas accéder au contenu en dehors de la collection de sites dans laquelle elles sont déployées.

Un administrateur de batterie de serveurs peut bloquer une solution en mode bac à sable. Une solution bloquée ne peut pas s'exécuter. Chaque solution en mode bac à sable est identifiée par un résultat de hachage du code de solution. Si le code de solution est modifié et redéployé, il est visible en tant que nouvelle solution en mode bac à sable et est autorisé à s'exécuter même si la solution d'origine est toujours bloquée.

Dans cet article :

  • Bloquer une solution en mode bac à sable

  • Débloquer une solution en mode bac à sable

Bloquer une solution en mode bac à sable

Vous pouvez bloquer une solution en mode bac à sable si elle dépasse son taux normal d'utilisation des ressources ou si elle présente un risque en matière de sécurité. Pour bloquer une solution en mode bac à sable, procédez comme suit.

Pour bloquer une solution en mode bac à sable via l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil du site Web Administration centrale de SharePoint, cliquez sur Paramètres système.

  3. Sous Gestion de la batterie, cliquez sur Gérer les solutions utilisateur.

  4. Dans la zone Fichier de la section Restrictions de solution de la page Gestion des solutions en mode bac à sable, tapez le chemin d'accès complet du fichier qui contient la solution à bloquer, ou cliquez sur le bouton Parcourir pour rechercher le fichier à bloquer.

  5. Vous pouvez éventuellement taper un message dans la zone Message. Ce message s'affiche lorsqu'un utilisateur tente d'utiliser la solution.

  6. Cliquez sur Bloquer.

    La solution est ajoutée à la liste de la zone Solutions bloquées.

  7. Pour bloquer des solutions supplémentaires, répétez les trois étapes précédentes.

  8. Cliquez sur OK.

Débloquer une solution en mode bac à sable

Si la situation qui a nécessité le blocage d'une solution en mode bac à sable a changé et si vous souhaitez débloquer la solution, procédez comme suit.

Pour débloquer une solution en mode bac à sable via l'Administration centrale

  1. Vérifiez que vous disposez des informations d'identification d'administration suivantes :

    • Vous devez être membre du groupe Administrateurs de batterie de serveurs sur l'ordinateur qui exécute le site Web Administration centrale de SharePoint.

  2. Dans la page d'accueil du site Web Administration centrale de SharePoint, cliquez sur Paramètres système.

  3. Sous Gestion de la batterie, cliquez sur Gérer les solutions utilisateur.

  4. Sélectionnez la solution à débloquer dans la zone Solutions bloquées de la section Restrictions de solution au sein de la page Gestion des solutions en mode bac à sable, puis cliquez sur Supprimer.

  5. Pour débloquer des solutions supplémentaires, répétez l'étape précédente.

  6. Cliquez sur OK.

Voir aussi

Concepts

Vue d'ensemble des solutions en bac à sable (SharePoint Foundation 2010)

Historique des modifications


Administration de la gestion des documents (SharePoint Foundation 2010)

Cette section comprend des rubriques sur lesquelles les administrateurs peuvent s'appuyer pour configurer des solutions de gestion de documents dans Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Administration de la co-création (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Administration de la co-création (SharePoint Foundation 2010)
Voir aussi

La co-création simplifie la collaboration en permettant à plusieurs utilisateurs de travailler de façon productive sur le même document sans empiéter sur le travail d'un autre utilisateur ni verrouiller les autres utilisateurs. Par défaut, la fonctionnalité de co-création est activée dans Microsoft SharePoint Foundation 2010 et ne requiert aucune étape de configuration supplémentaire. Les articles de cette section décrivent des tâches que les administrateurs peuvent utiliser lors de la configuration de la co-création pour leur propre organisation. Les administrateurs peuvent également choisir de désactiver la co-création, soit côté serveur à l'aide de propriétés de serveur, soit côté client à l'aide d'une stratégie de groupe.

Dans cette section :

  • Configure versioning for co-authoring (SharePoint Foundation 2010)

  • Configure the co-authoring versioning period (SharePoint Foundation 2010)

  • Configure the maximum number of co-authoring authors (SharePoint Foundation 2010)

  • Disable co-authoring (SharePoint Foundation 2010)

Voir aussi

Concepts

Vue d'ensemble de la co-création (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Configurer le contrôle de version pour la co-création (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment configurer les paramètres de contrôle de version des bibliothèques de documents pour la fonctionnalité de co-création dans Microsoft SharePoint Foundation 2010.

Dans cet article :

  • Configurer le contrôle de version pour la co-création

  • Configurer le paramètre Exiger l'extraction

Configurer le contrôle de version pour la co-création

Par défaut, dans SharePoint Foundation 2010, le contrôle de version des bibliothèques de documents est désactivé. Il est recommandé que cette fonctionnalité soit activée pour les bibliothèques de documents dans lesquelles les utilisateurs sont appelés à co-créer des documents à l'aide de PowerPoint 2010 et de Word 2010. Dans le cas des bibliothèques de documents comportant des blocs-notes OneNote, les versions mineures ne doivent pas être activées. Le contrôle de versions mineures peut aboutir à des erreurs de synchronisation qui empêchent l'enregistrement des modifications.

Lorsque plusieurs auteurs travaillent sur le même document, les modifications sont conservées sur le serveur sous la forme de versions du document. Les administrateurs peuvent limiter le nombre de versions conservées afin de restreindre l'utilisation de l'espace de stockage sur le serveur. Si le contrôle de version principale est activé dans une bibliothèque de documents comportant des blocs-notes OneNote, il est recommandé de spécifier le nombre maximal de versions afin d'optimiser l'utilisation de l'espace disque.

Pour activer le contrôle de version

  1. Accédez à la bibliothèque de documents que vous souhaitez configurer.

  2. Dans la barre d'outils, sous Outils de bibliothèque, cliquez sur Bibliothèque.

  3. Dans la barre d'outils, cliquez sur Paramètres de la bibliothèque.

  4. Dans Paramètres généraux, cliquez sur Paramètres de contrôle de version.

  5. Dans Document - Historique des versions, sélectionnez Créer des versions principales.

  6. Pour spécifier le nombre maximal de versions à conserver, sélectionnez Conserver le nombre suivant de versions principales et, dans la zone de texte, tapez le nombre de versions.

Configurer le paramètre Exiger l'extraction

Lorsqu'un document est extrait d'une bibliothèque de documents, il est verrouillé, ce qui le rend inaccessible pour la co-création. Le paramètre Exiger l'extraction ne doit pas être activé dans les bibliothèques de documents utilisées pour la co-création. Par défaut, pour les bibliothèques de documents SharePoint Foundation, ce paramètre n'est pas activé.

Pour désactiver le paramètre Exiger l'extraction

  1. Accédez à la bibliothèque de documents que vous souhaitez configurer.

  2. Dans la barre d'outils, sous Outils de bibliothèque, cliquez sur Bibliothèque.

  3. Dans la barre d'outils, cliquez sur Paramètres de la bibliothèque.

  4. Dans Paramètres généraux, cliquez sur Paramètres de contrôle de version.

  5. Dans Exiger l'extraction, sélectionnez Non (valeur par défaut).

Voir aussi

Concepts

Configurer la période du contrôle de version pendant la co-création (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Configurer la période du contrôle de version pendant la co-création (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment configurer la période du contrôle de version pendant la co-création dans Microsoft SharePoint Foundation 2010 à l'aide de Windows PowerShell 2.0.

Configurer la période du contrôle de version pendant la co-création

Lorsque le contrôle de version est activé, SharePoint Foundation crée des captures instantanées périodiques des documents et les enregistre pour référence ultérieure. Ces informations peuvent fournir une trace de modification qui permet de déterminer qui a modifié un document, de revenir à une version antérieure ou de s'adapter à des impératifs de conformité.

La propriété coAuthoringVersionPeriod spécifie, en minutes, la fréquence à laquelle SharePoint stocke une version d'un document en cours de modification. Vous pouvez configurer cette propriété à l'aide de Windows PowerShell. Si la valeur 0 est définie, SharePoint Foundation capture chaque modification apportée par un nouvel utilisateur dans une version différente du document. Si une valeur très élevée est définie, SharePoint Foundation crée une seule version pour la totalité de la session de modification. Ce dernier comportement correspond au comportement des fichiers qui ne sont pas co-créés et des fichiers dans les versions antérieures de SharePoint Foundation.

Remarque :
Certaines procédures de cette tâche requièrent l'utilisation de Windows PowerShell ou de SharePoint 2010 Management Shell pour l'exécution des applets de commande. Pour exécuter des applets de commande SharePoint 2010 dans Windows PowerShell, vous devez ajouter le composant logiciel enfichable Microsoft.SharePoint.PowerShell à l'aide de l'applet de commande Add-PSSnapin ou vous pouvez exécuter les applets de commande SharePoint 2010 à l'aide de SharePoint 2010 Management Shell. Par défaut, le composant logiciel enfichable Microsoft.SharePoint.PowerShell est déjà inscrit et il est ajouté à SharePoint 2010 Management Shell. Pour exécuter les applets de commande SharePoint 2010, vous devez être membre du rôle SharePoint_Shell_Access sur la base de données de configuration et membre du groupe local WSS_ADMIN_WPG sur l'ordinateur où les Produits SharePoint 2010 sont installés.

Pour plus d'informations sur l'applet de commande Add-PSSnapin, voir Add-PSSnapin. Pour plus d'informations sur la façon d'utiliser Windows PowerShell avec les Produits SharePoint 2010, voir Administration des produits SharePoint 2010 à l'aide de Windows PowerShell.

Pour configurer la période du contrôle de version pendant la co-création à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $siteurl ="<ServerName>"
$mysite=new-object Microsoft.SharePoint.SPSite($siteurl)
$mysite.WebApplication.WebService.CoauthoringVersionPeriod = minutes
$mysite.WebApplication.WebService.Update()

  2. Spécifiez les paramètres suivants :

    Paramètre Valeur

    $siteurl

    Nom du serveur

    CoauthoringVersionPeriod

    Nombre, exprimé en minutes

  3. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  4. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<chemin d'accès>\<nom de fichier>.ps1

Voir aussi

Concepts

Configurer le contrôle de version pour la co-création (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Configurer le nombre maximal d'auteurs de co-création (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment configurer le nombre maximal d'utilisateurs qui peuvent co-créer un document simultanément dans Microsoft SharePoint Foundation 2010.

Configurer le nombre maximal d'utilisateurs de co-création

Les administrateurs peuvent limiter le nombre d'utilisateurs pouvant co-créer un document simultanément en définissant la propriété CoauthoringMaxAuthors. Cette propriété s'applique uniquement aux présentations Microsoft PowerPoint 2010 et aux documents Microsoft Word 2010. Il n'existe pas de limite supérieure au nombre d'utilisateurs pouvant co-créer des blocs-notes Microsoft OneNote.

Pour configurer le nombre maximal d'utilisateurs de co-création pour les documents Word et les présentations PowerPoint à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante :

    • Voir Add-SPShellAdmin.

    • Vous devez consulter la page about_Execution_Policies (http://go.microsoft.com/fwlink/?linkid=193050&clcid=0x40C).

  2. Copiez le code suivant et collez-le dans un éditeur de texte, tel que le Bloc-notes :

    Code de copie
    $siteurl = "<ServerName>"
$mysite=new-object Microsoft.SharePoint.SPSite($siteurl)
$mysite.WebApplication.WebService.CoauthoringMaxAuthors = <MaxAuthors>
$mysite.WebApplication.WebService.Update()

  3. Remplacez :

    • <ServerName> par le nom du serveur.

    • <MaxAuthors> par le nombre maximal d'auteurs à autoriser.

  4. Enregistrez le fichier et nommez-le SetMaxCoAuthors.ps1.

    Remarque :
    Vous pouvez utiliser un autre nom de fichier, mais vous devez enregistrer le fichier en tant que fichier texte ANSI portant l'extension .ps1.

  5. Dans le menu Démarrer, cliquez sur Tous les programmes.

  6. Cliquez sur Produits Microsoft SharePoint 2010.

  7. Cliquez sur SharePoint 2010 Management Shell.

  8. Accédez au répertoire où vous avez enregistré le fichier.

  9. À l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    ./SetMaxCoAuthors.ps1

Voir aussi

Concepts

Vue d'ensemble de la co-création (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Désactiver la co-création (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment désactiver la fonctionnalité de co-création dans Microsoft SharePoint Foundation 2010 à l'aide de la stratégie de groupe ou à l'aide de Windows PowerShell 2.0.

Désactiver la co-création

Lorsqu'un document est extrait d'une bibliothèque de documents, il devient indisponible pour la co-création. Les utilisateurs peuvent extraire des documents individuellement afin de les verrouiller et que d'autres utilisateurs ne puissent pas les co-créer avec eux. La co-création nécessite que l'extraction ne soit imposée sur aucune des bibliothèques de documents utilisées pour la co-création de documents. Le fait d'imposer l'extraction dans une bibliothèque de documents est un moyen de désactiver la co-création pour toute la bibliothèque. La fonctionnalité de co-création peut également être désactivée côté client à l'aide de la stratégie de groupe.

Procédures de cette tâche :

  • Pour désactiver la co-création à l'aide de la stratégie de groupe

  • Pour désactiver la co-création pour les documents Word et les présentations PowerPoint au niveau du service Web à l'aide de Windows PowerShell

  • Pour désactiver la co-création pour les documents Word et les présentations PowerPoint au niveau de l'application Web à l'aide de Windows PowerShell

Pour désactiver la co-création à l'aide de la stratégie de groupe

  1. Sur le serveur, cliquez sur Démarrer, sur Outils d'administration puis sur Gestion des stratégies de groupe.

  2. Dans Gestion des stratégies de groupe, développez les nœuds Forêt et Domaine pour le domaine où vous voulez définir la stratégie, puis développez Objets de stratégie de groupe.

  3. Cliquez avec le bouton droit sur l'objet de stratégie de groupe où vos paramètres de co-création sont configurés, puis cliquez sur Modifier.

  4. Pour Word 2010, développez Configuration utilisateur, Modèles d'administration, Microsoft Word 2010, Paramètres de collaboration, Co-création, puis double-cliquez sur Empêcher la co-création.

    Pour PowerPoint 2010, développez Configuration utilisateur, Modèles d'administration, Microsoft PowerPoint 2010, Paramètres de collaboration, Co-création, puis double-cliquez sur Empêcher la co-création.

  5. Dans la boîte de dialogue Empêcher la co-création - Propriétés, sélectionnez Activé, puis cliquez sur OK.

Vous pouvez également désactiver la co-création pour les documents Word et PowerPoint sur le serveur en définissant la propriété de serveur DisableCoauthoring à l'aide de Windows PowerShell.

Remarque :
Certaines procédures de cette tâche nécessitent l'utilisation de Windows PowerShell ou de SharePoint 2010 Management Shell pour l'exécution des applets de commande. Pour exécuter des applets de commande SharePoint 2010 dans Windows PowerShell, vous devez ajouter le composant logiciel enfichable Microsoft.SharePoint.PowerShell à l'aide de l'applet de commande Add-PSSnapin ou vous pouvez exécuter les applets de commande SharePoint 2010 à l'aide de SharePoint 2010 Management Shell. Par défaut, le composant logiciel enfichable Microsoft.SharePoint.PowerShell est déjà inscrit et il est ajouté à SharePoint 2010 Management Shell. Pour exécuter les applets de commande SharePoint 2010, vous devez être membre du rôle SharePoint_Shell_Access sur la base de données de configuration et membre du groupe local WSS_ADMIN_WPG sur l'ordinateur où les Produits SharePoint 2010 sont installés.

Pour plus d'informations sur l'applet de commande Add-PSSnapin, voir Add-PSSnapin. Pour plus d'informations sur la façon d'utiliser Windows PowerShell avec les Produits SharePoint 2010, voir Administration des produits SharePoint 2010 à l'aide de Windows PowerShell.

Pour désactiver la co-création pour les documents Word et les présentations PowerPoint au niveau du service Web à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $siteurl = "<servername>" $mysite=new-object Microsoft.SharePoint.SPSite($siteurl)
$mysite.WebApplication.WebService.DisableCoauthoring = $true;
$mysite.WebApplication.WebService.Update();

  2. Spécifiez les paramètres suivants :

    Paramètre Valeur

    $siteurl

    Nom du serveur

  3. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  4. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<chemin d'accès>\<nom de fichier>.ps1

Pour désactiver la co-création pour les documents Word et les présentations PowerPoint au niveau de l'application Web à l'aide de Windows PowerShell

  1. À l'aide du Bloc-notes, ouvrez un nouveau fichier texte, puis copiez et collez le script suivant dans le fichier.

    Code de copie
    $siteurl = "<servername>" $mysite=new-object Microsoft.SharePoint.SPSite($siteurl)
$mysite.WebApplication.DisableCoauthoring = $true;
$mysite.WebApplication.Update();

  2. Spécifiez les paramètres suivants :

    Paramètre Valeur

    $siteurl

    Nom du serveur

  3. Enregistrez le fichier avec l'extension de nom de fichier .ps1 dans un dossier où vous exécutez des scripts (généralement, C:\scripts).

  4. À partir de l'invite de commandes Windows PowerShell (c'est-à-dire PS C:\>), tapez la commande suivante, puis appuyez sur Entrée :

    C:\<chemin d'accès>\<nom de fichier>.ps1

Voir aussi

Concepts

Administration de la co-création (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Sécurité et protection pour SharePoint Foundation 2010

Cette section fournit des informations et des recommandations sur la façon de sécuriser le système Microsoft SharePoint Foundation 2010 de protéger les données.

Dans cette section :

  • Planification de la sécurité pour les sites et le contenu (SharePoint Foundation 2010)

  • Planifier l'authentification par revendications (SharePoint Foundation 2010)

  • Comptes d'administration et de service requis pour le déploiement initial (SharePoint Foundation 2010)

  • Administration de la sécurité et des autorisations (SharePoint Foundation 2010)

  • Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010)

Historique des modifications


Référence technique de SharePoint Foundation 2010
Voir aussi

La référence technique comprend des informations sur Windows PowerShell pour Microsoft SharePoint Foundation 2010 et d'autres informations de référence utiles sur les paramètres généraux, la sécurité et les outils.

Dans cette section :

  • Windows PowerShell pour SharePoint Foundation 2010

  • Articles de la Base de connaissances System Center Operations Manager (SharePoint Foundation 2010)

  • Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010)

  • Types et descriptions de base de données (SharePoint Foundation 2010)

  • Expérience utilisateur sur les sites en lecture seule (SharePoint Foundation 2010)

  • Modules linguistiques (SharePoint Foundation 2010)

  • Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)

Voir aussi

Autres ressources

Stsadm, outil de ligne de commande (Windows SharePoint Services)

Historique des modifications


Windows PowerShell pour SharePoint Foundation 2010

Windows PowerShell peut être utilisé avec Microsoft SharePoint Foundation 2010 pour effectuer des tâches administratives à la fois simples et complexes. Des informations sur les applets de commande (cmdlets) dans SharePoint Foundation 2010 sont actuellement accessibles via l'aide de la ligne de commande. Pour plus d'informations sur Windows PowerShell en général, visitez le Centre de technologie de Windows PowerShell (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=167152&clcid=0x40C).

Dans cette section :

  • Administration des produits SharePoint 2010 à l'aide de Windows PowerShell

  • Référence pour Windows PowerShell pour SharePoint Foundation 2010

  • Mises à jour des applets de commande Windows PowerShell (SharePoint Foundation 2010)

  • Stsadm to Windows PowerShell mapping (SharePoint Foundation 2010) (en anglais)

Historique des modifications


Administration des produits SharePoint 2010 à l'aide de Windows PowerShell

Cet article décrit comment utiliser Windows PowerShell avec Produits Microsoft SharePoint 2010 et fournit une vue d'ensemble des concepts et applets de commande Windows PowerShell de base nécessaires pour tirer le meilleur parti de cette puissante fonctionnalité.

Dans cet article :

  • Présentation

  • Accès à Windows PowerShell pour les produits SharePoint 2010 à l'aide de SharePoint 2010 Management Shell

  • Autorisations

  • Formation à Windows PowerShell.

Présentation

Windows PowerShell est un outil d'écriture de scripts en ligne de commande qui offre aux administrateurs un accès complet aux interfaces de programmation d'applications (API) applicables, ainsi que la possibilité de déverrouiller la capacité à interagir directement avec les Produits SharePoint 2010 pour manipuler des applications Web, des collections de sites, des sites, des listes, et ainsi de suite. De plus, l'administrateur a la possibilité d'écrire des scripts d'applets de commande, ce qui améliore l'expérience par rapport aux versions précédentes du produit.

Windows PowerShell 2.0 est une condition préalable à l'installation des Produits SharePoint 2010. Il est installé si nécessaire lorsque vous exécutez l'Outil de préparation des produits Microsoft SharePoint. Par défaut, Windows PowerShell se trouve à l'emplacement suivant : <%SystemRoot%>\System32\WindowsPowerShell\v1.0\PowerShell.exe.

Remarque :
Windows PowerShell 2.0 offre une compatibilité descendante avec Windows PowerShell 1.0 et s'installe par conséquent dans le dossier v1.0.

Pour obtenir une liste des nouvelles fonctionnalités pour Windows PowerShell version 2.0, voir À propos de Windows PowerShell 2.0 (http://go.microsoft.com/fwlink/?linkid=113247&clcid=0x40C).

Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Accès à Windows PowerShell pour les produits SharePoint 2010 à l'aide de SharePoint 2010 Management Shell

Une fois les produits SharePoint 2010 installés, les applets de commande Windows PowerShell applicables sont accessibles à l'aide de SharePoint 2010 Management Shell ou de la console Windows PowerShell. Avec Management Shell, il est possible de gérer tous les aspects des Produits SharePoint 2010. Vous pouvez créer des collections de sites, des applications Web, des comptes d'utilisateurs, des applications de service, des proxys, et bien d'autres choses encore. Les commandes de Management Shell génèrent des objets SharePoint basés sur la plateforme Microsoft .NET. Ces objets peuvent être appliqués comme entrées de commandes ultérieures ou stockés dans des variables locales pour une utilisation ultérieure.

Avec Management Shell, il n'est pas nécessaire d'enregistrer le composant logiciel enfichable qui contient les applets de commande. L'enregistrement du module Microsoft.SharePoint.PowerShell.dll pour les applets de commande SharePoint 2010 s'effectue automatiquement à cause de la ligne Add-PSSnapin Microsoft.SharePoint.PowerShell dans le fichier SharePoint.ps1 situé dans %CommonProgramFiles%\Microsoft Shared\Web Server Extensions\14\Config\PowerShell\Registration. Si vous choisissez d'utiliser la console Windows PowerShell, vous devez enregistrer ce composant logiciel enfichable manuellement.

Que vous ayez recours à Management Shell ou à la console Windows PowerShell, vous pouvez également charger des composants logiciels enfichables supplémentaires. Pour plus d'informations, voir La puissance des profils (http://go.microsoft.com/fwlink/?linkid=183166&clcid=0x40C).

Pour accéder à SharePoint 2010 Management Shell

  1. Dans le menu Démarrer, cliquez sur Tous les programmes.

  2. Cliquez sur Produits Microsoft SharePoint 2010.

  3. Cliquez sur SharePoint 2010 Management Shell.
Remarque :
SharePoint 2010 Management Shell et la console Windows PowerShell diffèrent également dans l'utilisation de l'option ReuseThread, qui définit le mode d'utilisation du modèle de threading. L'utilisation de Management Shell est définie par cette ligne, {Host.Runspace.ThreadOptions = "ReuseThread"}, qui figure dans le fichier SharePoint.ps1. Pour plus d'informations, voir Énumération PSThreadOptions (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=183145&clcid=0x40C).

Autorisations

Pour pouvoir utiliser Management Shell set les applets de commande Windows PowerShell, vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

Si vous n'êtes pas membre du rôle SharePoint_Shell_Access ou du groupe local WSS_Admin_WPG, utilisez l'applet de commande Add-SPShellAdmin. Lorsque l'applet de commande Add-SPShellAdmin est utilisée, l'utilisateur est ajouté au groupe WSS_Admin_WPG dans tous les serveurs Web frontaux et ajouté au rôle SharePoint_Shell_Access. Si la base de données cible ne dispose pas d'un rôle SharePoint_Shell_Access, le rôle est créé automatiquement. Après l'exécution de l'applet de commande Add-SPShellAdmin, l'utilisateur peut exécuter des applets de commande Windows PowerShell SharePoint 2010 dans un environnement de batterie à serveurs multiples.

Lorsque vous exécutez l'applet de commande Add-SPShellAdmin pour ajouter un utilisateur au rôle SharePoint_Shell_Access, vous devez disposer des autorisations de sécurité suivantes :

  • Accès au rôle de serveur Securityadmin sur l'instance SQL et rôle db_owner dans une base de données.

  • Autorisation administrative sur l'ordinateur local.

Remarque :
En général, la personne qui utilisera l'applet de commande Add-SPShellAdmin doit être associée au compte d'utilisateur qui a servi à exécuter le programme d'installation.

Vous devez exécuter l'applet de commande Add-SPShellAdmin pour toutes les bases de données auxquelles vous voulez accorder l'accès. Si aucune base de données n'est spécifiée, la base de données de configuration de la batterie de serveurs est utilisée. Si vous spécifiez une base de données, la base de données de contenu de la batterie sera incluse en plus de la base de données de configuration de la batterie que vous spécifiez.

Pour consulter la liste de toutes les applets de commande *SPShellAdmin, à partir d'une invite de commandes Windows PowerShell, tapez Get-Command -Noun SPShellAdmin.

Formation à Windows PowerShell.

Il existe plusieurs ressources de formation à Windows PowerShell destinées aux professionnels de l'informatique SharePoint qui désirent se familiariser avec Windows PowerShell.

Centre de scripts TechNet

Le Centre de scripts TechNet contient de nombreuses ressources pour l'apprentissage des notions de base de Windows PowerShell. Il contient également des référentiels de scripts avec des exemples de scripts couramment utilisés avec différents produits Microsoft. Le tableau suivant indique les principales ressources de formation.

Page | Description
Documentation Windows PowerShell sur TechNet (http://go.microsoft.com/fwlink/?linkid=187813&clcid=0x40C) | Cette section de la bibliothèque TechNet contient des copies Web des rubriques principales Get-Help de Windows PowerShell. Elle propose également des copies Web du document de Mise en route avec Windows PowerShell, de l'aide de PowerShell.exe, ainsi qu'un document de présentation de Windows PowerShell.
Génération de scripts avec Windows PowerShell (http://go.microsoft.com/fwlink/?linkid=187815&clcid=0x40C) | Page d'accueil des ressources de formation à l'écriture de scripts Windows PowerShell.
Manuel de l'utilisation de Windows PowerShell (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187817&clcid=0x40C) | Guide de démarrage de Windows PowerShell basé sur le Web.
Référence rapide de Windows PowerShell (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187819&clcid=0x40C) | Copie téléchargeable du document Référence rapide installé avec Windows PowerShell.

Documents Windows PowerShell

Windows PowerShell installe les documents suivants dans le groupe de programmes Windows PowerShell 1.0. Ils peuvent également être installés après le téléchargement du Pack de documentation de Windows PowerShell 1.0 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187822&clcid=0x40C).

Fichier | Description
GettingStarted.rtf | Décrit comment commencer à utiliser Windows PowerShell.
UsersGuide.rtf | Introduction à l'environnement et au langage Windows PowerShell.
QuadFold.rtf | Document de référence rapide imprimable relatif à la syntaxe et aux commandes Windows PowerShell courantes. Également disponible en tant que téléchargement à partir du Centre de scripts TechNet.

Lors de la consultation de ces ressources, sachez qu'il est préférable de se familiariser avec les concepts et applets de commande suivants avant d'utiliser Windows PowerShell pour les produits SharePoint 2010 :

  • Get-Command (http://go.microsoft.com/fwlink/?linkid=171069&clcid=0x40C)

  • Get-Member (http://go.microsoft.com/fwlink/?linkid=171070&clcid=0x40C)

  • Get-Help (http://go.microsoft.com/fwlink/?linkid=171068&clcid=0x40C).

  • À propos des alias (http://go.microsoft.com/fwlink/?linkid=113207&clcid=0x40C)

  • Canalisations dans Windows PowerShell (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187808&clcid=0x40C)

  • Jeu de paramètres d'applet de commande (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187810&clcid=0x40C)

  • Utilisation de l'applet de commande Foreach-Object (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187812&clcid=0x40C)

  • Utilisation de l'applet de commande Where-Object (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187811&clcid=0x40C)

Historique des modifications


Référence pour Windows PowerShell pour SharePoint Foundation 2010

Les articles suivants répertorient les applets de commande Windows PowerShell pour Microsoft SharePoint Foundation 2010, par fonctionnalité.

Article de catégorie

Applets de commande pour la sauvegarde et la récupération (SharePoint Foundation 2010)

Applets de commande pour les bases de données (SharePoint Foundation 2010)

Applets de commande pour les fonctionnalités et les solutions (SharePoint Foundation 2010)

Applets de commande générales (SharePoint Foundation 2010)

Applets de commande pour l'importation et l'exportation (SharePoint Foundation 2010)

Applets de commande pour la journalisation et les événements (SharePoint Foundation 2010)

Applets de commande pour la sécurité (SharePoint Foundation 2010)

Applets de commande pour les applications de service (SharePoint Foundation 2010)

Applets de commande pour la gestion des sites (SharePoint Foundation 2010)

Applets de commande pour les performances (SharePoint Foundation 2010)

Applets de commande pour la gestion des flux de travail (SharePoint Foundation 2010)

Applets de commande pour les travaux du minuteur (SharePoint Foundation 2010)

Applets de commande pour la mise à niveau et la migration (SharePoint Foundation 2010)

Applets de commande pour le service Recherche de SharePoint Foundation 2010

Historique des modifications


Applets de commande pour la sauvegarde et la récupération (SharePoint Foundation 2010)

Une sauvegarde est une copie de données utilisée pour restaurer et récupérer ces données après une défaillance du système. Les sauvegardes de données sont utiles pour des opérations de routine, telles que la copie d'une base de données d'un serveur à un autre, la mise en miroir d'une base de données, l'archivage à des fins administratives et la récupération d'urgence.

Dans Microsoft SharePoint Foundation 2010, vous pouvez utiliser les fonctionnalités Windows PowerShell pour effectuer un processus de sauvegarde ou de restauration pour les éléments suivants :

  • Batterie de serveurs

  • Collection de sites

  • Base de données de configuration

  • Services

  • Liste ou document

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Backup-SPConfigurationDatabase

Backup-SPFarm

Restore-SPFarm

Backup-SPSite

Restore-SPSite

Get-SPBackuphistory

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Backup-SPConfigurationDatabase
Voir aussi Exemple
[image]

Effectue une sauvegarde de la configuration au niveau de la batterie de serveurs.

Backup-SPConfigurationDatabase -Directory <String> [-AssignmentCollection <SPAssignmentCollection>] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabaseServer <String>] [-Item <String>]
Backup-SPConfigurationDatabase -ShowTree <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabaseServer <String>] [-Item <String>]

Paramètres

1

Paramètre

Requis

Type

Description

Directory

Requis

System.String

Spécifie le chemin d'accès où les produits SharePoint 2010 stockent le package de sauvegarde qu'il génère. Si vous disposez d'un ordinateur sur lequel sont installés Microsoft SQL Server 2008 et une instance des produits SharePoint 2010, vous pouvez utiliser des chemins d'accès de lecteurs locaux. Ceci implique une installation de base. Cependant, si SQL Server 2008 et les produits SharePoint 2010 sont installés sur plusieurs ordinateurs ou si vous avez plusieurs serveurs qui exécutent les produits SharePoint 2010, vous devez utiliser les chemins de partage UNC (Universal Naming Convention) afin que la base de données SQL et les composants de recherche soient écrits au même emplacement, par exemple, \\nom_ordinateur\volume\Backup).

Plusieurs packages de sauvegarde peuvent être stockés au même emplacement. Il s'agit du chemin d'accès que vous passez au paramètre Directory de l'applet de commande Restore-SPFarm.

Le type doit être l'un des chemins d'accès valides suivants :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

Remarque :
Les dossiers spbr* sont créés automatiquement.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'ID et le mot de passe correspondant au nom d'utilisateur de l'administrateur de la base de données SQL Server.

Ce paramètre ne doit être spécifié que si la connexion à la base de données repose sur l'authentification SQL. En revanche, si elle repose sur l'authentification Windows, ce paramètre ne doit pas être spécifié.

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données de configuration.

DatabaseServer

Facultatif

System.String

Spécifie le serveur de bases de données SQL qui contient la base de données de configuration. Il s'agit par défaut du nom de l'ordinateur local.

Le type doit être un serveur de bases de données valide, par exemple DS.

Item

Facultatif

System.String

Indique la partie de la batterie de serveurs à sauvegarder. Vous pouvez utiliser la notation du chemin d'accès complet à la batterie de serveurs, tel qu'il est affiché par le paramètre ShowTree, ou le nom du composant cible dans le chemin d'accès, si son nom est unique. Si plusieurs éléments ont le même nom, le chemin d'accès complet doit être spécifié. Placez l'élément ou le chemin d'accès entre guillemets s'il contient un espace.

Si le paramètre Item n'est pas spécifié, la configuration de la batterie de serveurs entière est sauvegardée.

2

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'ID et le mot de passe correspondant au nom d'utilisateur de l'administrateur de la base de données SQL Server.

Ce paramètre ne doit être spécifié que si la connexion à la base de données repose sur l'authentification SQL. En revanche, si elle repose sur l'authentification Windows, ce paramètre ne doit pas être spécifié.

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données de configuration.

DatabaseServer

Facultatif

System.String

Spécifie le serveur de bases de données SQL qui contient la base de données de configuration. Il s'agit par défaut du nom de l'ordinateur local.

Le type doit être un serveur de bases de données valide, par exemple DS.

Item

Facultatif

System.String

Indique la partie de la batterie de serveurs à sauvegarder. Vous pouvez utiliser la notation du chemin d'accès complet à la batterie de serveurs, tel qu'il est affiché par le paramètre ShowTree, ou le nom du composant cible dans le chemin d'accès, si son nom est unique. Si plusieurs éléments ont le même nom, le chemin d'accès complet doit être spécifié. Placez l'élément ou le chemin d'accès entre guillemets s'il contient un espace.

Si le paramètre Item n'est pas spécifié, la configuration de la batterie de serveurs entière est sauvegardée.

ShowTree

Facultatif

System.Management.Automation.SwitchParameter

Indique les objets de la batterie de serveurs qui seront sauvegardés en fonction des autres paramètres passés à l'applet de commande de sauvegarde, à savoir le paramètre Item. Les éléments qui seront exclus de la sauvegarde en fonction des autres paramètres passés à l'applet de commande Backup-SPConfigurationDatabase seront précédés d'un astérisque (*). Les éléments qui ne peuvent pas être sauvegardés seront placés entre crochets ([ ]). La sauvegarde n'a pas lieu si le paramètre ShowTree est spécifié.

Description détaillée

L'applet de commande Backup-SPConfigurationDatabase effectue une sauvegarde de la configuration seulement de la batterie de serveurs actuelle ou une sauvegarde de la configuration seulement d'une base de données de configuration distincte qui n'est pas attachée à la batterie de serveurs actuelle. Pour effectuer une sauvegarde de la configuration seulement de la batterie de serveurs actuelle, vous ne devez pas spécifier les paramètres DatabaseServer et DatabaseName. Dans ce cas, il est toutefois recommandé d'utiliser l'applet de commande Backup-SPFarm avec le paramètre ConfigurationOnly.

Exemple de sauvegarde de la configuration : un administrateur crée un modèle de configuration de batterie de serveurs qu'il peut ensuite appliquer à d'autres batteries de serveurs SharePoint en effectuant une restauration via l'applet de commande Restore-SPFarm.

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE 1--------------------
Code de copie
Backup-SPConfigurationDatabase -DatabaseName SharePoint_Config -DatabaseServer SqlServer1 -Directory \\server\share\Backup -ShowTree

Cet exemple affiche les composants pouvant être inclus dans une sauvegarde de la configuration.

-------------------EXEMPLE 2--------------------
Code de copie
Backup-SPConfigurationDatabase -DatabaseName SharePoint_Config -DatabaseServer SqlServer1 -Directory \\server\share\Backup -Verbose

Cet exemple effectue une sauvegarde de la configuration avec commentaires.

Voir aussi

Référence

Connect-SPConfigurationDatabase
Disconnect-SPConfigurationDatabase
New-SPConfigurationDatabase
Remove-SPConfigurationDatabase
Restore-SPFarm

Historique des modifications


Backup-SPFarm
Voir aussi Exemple
[image]

Crée une sauvegarde d'une base de données individuelle, d'une application Web ou de la batterie de serveurs entière.

Backup-SPFarm -BackupMethod <String> -Directory <String> [-AssignmentCollection <SPAssignmentCollection>] [-BackupThreads <Int32>] [-ConfigurationOnly <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-Item <String>] [-Percentage <Int32>] [-WhatIf [<SwitchParameter>]]
Backup-SPFarm -ShowTree <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-ConfigurationOnly <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-Item <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

BackupMethod

Requis

System.String

Spécifie le type de fichier de sauvegarde à créer.

Si une sauvegarde a lieu avec le paramètre -ShowTree, alors le paramètre BackupMethod n'est pas utilisé.

Une sauvegarde complète est une sauvegarde de toutes les données sélectionnées. Une sauvegarde différentielle est une sauvegarde de toutes les données sélectionnées ayant changé depuis la dernière sauvegarde complète. Si un élément ne prend pas en charge la sauvegarde différentielle, une sauvegarde complète est alors exécutée sur cet élément.

Le type doit être l'une des valeurs suivantes :

- Complète

- Différentielle

Directory

Requis

System.String

Spécifie le chemin d'accès où SharePoint 2010 Products stocke le package de sauvegarde qu'il génère. Si vous disposez d'un ordinateur sur lequel sont installés Microsoft SQL Server 2008 et une instance de SharePoint 2010 Products, vous pouvez utiliser des chemins d'accès de lecteurs locaux. Ceci implique une installation de base. Cependant, si SQL Server 2008 et SharePoint 2010 Products sont installés sur plusieurs ordinateurs ou si vous avez plusieurs serveurs qui exécutent SharePoint 2010 Products, vous devez utiliser les chemins de partage UNC (Universal Naming Convention) afin que la base de données SQL et les composants de recherche soient écrits au même emplacement, par exemple, \\nom_ordinateur\volume\Backup).

Plusieurs packages de sauvegarde peuvent être stockés au même emplacement. Il s'agit du chemin d'accès que vous passez au paramètre Directory de l'applet de commande Restore-SPFarm.

Le type doit être l'un des chemins d'accès valides suivants :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

Remarque :
Les dossiers spbr* sont créés automatiquement.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

BackupThreads

Facultatif

System.Int32

Spécifie le nombre de threads à utiliser lors de la sauvegarde. Moins il y a de threads, plus le fichier journal de la sauvegarde est facile à lire et à comprendre. Plus il y a de threads, plus vous pouvez sauvegarder de composants en parallèle, ce qui peut entraîner une sauvegarde plus rapide. La valeur minimale est 1 et la valeur maximale est 10.

La valeur par défaut est 3.

Si une sauvegarde a lieu avec le paramètre -ShowTree, alors le paramètre BackupMethod n'est pas utilisé.

ConfigurationOnly

Facultatif

System.Management.Automation.SwitchParameter

Lorsque ce paramètre est spécifié, la sauvegarde contient uniquement des paramètres de configuration (aucune donnée) pour chacun des objets à sauvegarder.

Force

Facultatif

System.Management.Automation.SwitchParameter

Spécifie la poursuite de l'opération de sauvegarde même si l'estimation indique que le répertoire de sauvegarde ne dispose pas de l'espace suffisant pour contenir la sauvegarde entière.

Si une sauvegarde a lieu avec le paramètre ShowTree, alors le paramètre Force n'est pas utilisé.

Item

Facultatif

System.String

Indique la partie de la batterie de serveurs à sauvegarder. Vous pouvez utiliser la notation du chemin d'accès complet à la batterie de serveurs, tel qu'il est affiché par le paramètre ShowTree, ou le nom du composant cible dans le chemin d'accès si le composant a un nom unique. S'il existe plusieurs éléments correspondants, le chemin d'accès complet doit être spécifié. Par défaut, le nœud supérieur est sélectionné. Placez l'élément ou le chemin d'accès entre guillemets s'il contient un espace. Si ce paramètre n'est pas spécifié, toute la batterie de serveurs est sauvegardée.

Le type doit être un élément valide, par exemple Farm\Microsoft Windows SharePoint Foundation Web Application\SharePoint - 80.

Percentage

Facultatif

System.Int32

Demande l'affichage des mises à jour de l'avancement de l'opération de sauvegarde en incréments égaux à ce pourcentage, par exemple la valeur 5 affiche l'avancement de la sauvegarde par palier de 5 %, et la valeur 10, l'avancement de la sauvegarde par palier de 10 %. Pour afficher les résultats, vous devez spécifier le paramètre Verbose.

Remarque :
Ce pourcentage n'est pas précis et l'avancement réel de l'opération peut être supérieur ou inférieur aux valeurs définies.

La valeur du pourcentage n'est pas précise et l'avancement réel de l'opération peut être supérieur ou inférieur aux valeurs définies.

La valeur par défaut est 5. Pour une base de données très volumineuse, 1 est la valeur recommandée.

Les valeurs valides sont un nombre entier compris entre 1 et 100.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

ShowTree

Requis

System.Management.Automation.SwitchParameter

Indique les objets de la batterie de serveurs qui seront sauvegardés en fonction des autres paramètres passés à l'applet de commande Backup-SPFarm, à savoir le paramètre Item. Les éléments qui seront exclus de la sauvegarde en fonction des autres paramètres passés à l'applet de commande Backup-SPFarm seront précédés d'un astérisque (*). Les éléments qui ne peuvent pas être sauvegardés seront placés entre crochets ([]). La sauvegarde ne sera pas effectuée si le paramètre ShowTree est spécifié.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ConfigurationOnly

Facultatif

System.Management.Automation.SwitchParameter

Lorsque ce paramètre est spécifié, la sauvegarde contient uniquement des paramètres de configuration (aucune donnée) pour chacun des objets à sauvegarder.

Item

Facultatif

System.String

Indique la partie de la batterie de serveurs à sauvegarder. Vous pouvez utiliser la notation du chemin d'accès complet à la batterie de serveurs, tel qu'il est affiché par le paramètre ShowTree, ou le nom du composant cible dans le chemin d'accès si le composant a un nom unique. S'il existe plusieurs éléments correspondants, le chemin d'accès complet doit être spécifié. Par défaut, le nœud supérieur est sélectionné. Placez l'élément ou le chemin d'accès entre guillemets s'il contient un espace. Si ce paramètre n'est pas spécifié, toute la batterie de serveurs est sauvegardée.

Le type doit être un élément valide, par exemple Farm\Microsoft Windows SharePoint Foundation Web Application\SharePoint - 80.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Backup-SPFarm crée une sauvegarde de la batterie de serveurs entière ou de composants individuels de la batterie de serveurs. Elle permet également de sauvegarder uniquement les paramètres de configuration d'une batterie de serveurs à utiliser comme modèle de batterie de serveurs pour d'autres batteries de serveurs SharePoint. Pour sauvegarder une seule collection de sites, utilisez l'applet de commande Backup-SPSite.

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE 1---------------------
Code de copie
Backup-SPFarm -Directory \\file_server\share\Backup -BackupMethod full -ConfigurationOnly

Cet exemple sauvegarde les paramètres de configuration de la batterie de serveurs dans le répertoire \\serveur_fichiers\share\Backup.

--------------------EXEMPLE 2---------------------
Code de copie
Backup-SPFarm -ShowTree -Item "Microsoft SharePoint Foundation Web Application" -Verbose

Cet exemple montre quels composants de la batterie de serveurs seraient sauvegardés sous le nœud « Microsoft SharePoint Foundation Web Application », sans toutefois les sauvegarder.

--------------------EXEMPLE 3---------------------
Code de copie
Backup-SPFarm -Directory C:\Backup -BackupMethod full -BackupThreads 10 -Force

Cet exemple effectue une sauvegarde d'une batterie de serveurs en utilisant 10 threads et forcer l'enregistrement de la sauvegarde dans le répertoire C:\Backup même si SharePoint estime que l'espace disponible est insuffisant.

Voir aussi

Référence

Backup-SPConfigurationDatabase
Get-SPBackupHistory
Restore-SPFarm

Historique des modifications


Backup-SPSite
Voir aussi Exemple
[image]

Effectue une sauvegarde d'une collection de sites.

Backup-SPSite [-Identity] <SPSitePipeBind> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-NoSiteLock <SwitchParameter>] [-UseSqlSnapshot <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie l'URL ou le GUID de la collection de sites à sauvegarder.

Par exemple, une URL valide telle que http://server_name/sites/nom_site ou un GUID tel que 01234567-89ab-cdef-0123-456789abcdef.

Path

Requis

System.String

Spécifie le chemin d'accès complet au fichier de sauvegarde (C:\Backup\nom_site.bak).

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Spécifie le remplacement d'un fichier de sauvegarde s'il existe déjà.

NoSiteLock

Facultatif

System.Management.Automation.SwitchParameter

Spécifie la collection de sites à laisser en lecture/écriture pendant la sauvegarde.

Si le paramètre NoSiteLock n'est pas spécifié, une collection de sites dont le paramètre de verrouillage est « Aucun » ou « Aucun ajout » sera temporairement définie sur « Lecture seule » pendant l'opération de sauvegarde. Une fois la sauvegarde terminée, le verrou de la collection de sites revient à son état d'origine. Le package de sauvegarde enregistre l'état d'origine du verrou de la collection de sites de manière à le restaurer dans cet état.

Si des utilisateurs sont occupés à écrire dans la collection de sites pendant sa sauvegarde, il est recommandé de ne pas utiliser le paramètre NoSiteLock afin d'éviter de porter atteinte à l'intégrité de la sauvegarde.

UseSqlSnapshot

Facultatif

System.Management.Automation.SwitchParameter

Spécifie qu'un instantané de la base de données SQL sera créé au début de la sauvegarde et que toutes les données de la collection de sites seront récupérées directement depuis l'instantané de la base de données. Cet instantané sera automatiquement supprimé au terme de la sauvegarde.

Il est recommandé d'utiliser le paramètre UseSqlSnapshot si le serveur de bases de données qui héberge votre base de données de contenu prend en charge les instantanés de base de données tels que SQL Server Enterprise Edition et SQL Server Developer Edition. Ceci permet de s'assurer de l'intégrité de la sauvegarde tout en permettant aux utilisateurs de continuer à lire et à écrire dans la collection de sites pendant la sauvegarde. Il n'est pas nécessaire de spécifier le paramètre NoSiteLock lorsque vous spécifiez le paramètre UseSqlSnapshot.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Backup-SPSite effectue une sauvegarde de la collection de sites lorsque le paramètre Identity est utilisé.

Par défaut, la collection de sites sera définie en lecture seule pour la durée de la sauvegarde afin de réduire le risque que l'activité utilisateur endommage la sauvegarde en cours d'opération. Si vous avez SQL Server Enterprise Edition, nous vous recommandons d'utiliser le paramètre UseSqlSnapshot qui assure une sauvegarde valide tout en permettant aux utilisateurs de continuer à lire ou à écrire dans la collection de sites pendant la sauvegarde.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE 1--------------------
Code de copie
Backup-SPSite http://server_name/sites/site_name -Path C:\Backup\site_name.bak

Cet exemple sauvegarde une collection de sites située à l'adresse http://server_name/sites/nom_site dans le fichier C:\Backup\nom_site.bak.

-------------------EXEMPLE 2--------------------
Code de copie
Get-SPSiteAdministration http://server_name/sites/site_name | Backup-SPSite -Path C:\Backup\site_name.bak

Cet exemple sauvegarde une collection de sites située à l'adresse http://server_name/sites/nom_site dans le fichier C:\Backup\nom_site.bak. Le résultat est identique à l'exemple 1, mais l'opération se déroule différemment.

-------------------EXEMPLE 3--------------------
Code de copie
Backup-SPSite http://server_name/sites/site_name -Path C:\Backup\site_name.bak -UseSqlSnapshot

Cet exemple sauvegarde une collection de sites à l'aide d'instantanés de base de données afin de s'assurer de l'intégrité de la sauvegarde.

Voir aussi

Référence

Get-SPSite
Move-SPSite
Restore-SPSite
Set-SPSite
Get-SPSiteAdministration

Historique des modifications


Get-SPBackupHistory
Voir aussi Exemple
[image]

Renvoie un historique des opérations de sauvegarde et restauration.

Get-SPBackupHistory -Directory <String> [-AssignmentCollection <SPAssignmentCollection>] [-ShowBackup <SwitchParameter>] [-ShowRestore <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Directory

Requis

System.String

Spécifie le chemin où les packages de sauvegarde SharePoint 2010 Products générés à partir d'une sauvegarde de batterie ont été stockés.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ShowBackup

Facultatif

System.Management.Automation.SwitchParameter

Filtre la sortie afin que l'historique des opérations de sauvegarde seulement soit affiché. Si les deux paramètres ShowBackup et ShowRestore ne sont pas spécifiés, l'historique des opérations de sauvegarde et de restauration s'affiche.

ShowRestore

Facultatif

System.Management.Automation.SwitchParameter

Filtre la sortie afin que l'historique des opérations de restauration seulement soit affiché. Si les deux paramètres ShowBackup et ShowRestore sont absents, l'historique des opérations de sauvegarde et de restauration s'affiche.

Description détaillée

L'applet de commande Get-SPBackupHistory lit un historique des opérations de sauvegarde et restauration exécutées. Il spécifie si vous voulez afficher uniquement l'historique des sauvegardes, uniquement celui des restaurations, ou l'historique dans son ensemble.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE 1-----------------
Code de copie
Get-SPBackupHistory -Directory \\file_server\share\Backup

Cet exemple renvoie toutes les opérations de sauvegarde et restauration de batterie exécutées pour le répertoire \\serveur_fichiers\partage\Backup.

------------------EXEMPLE 2-----------------
Code de copie
Get-SPBackupHistory -Directory C:\Backup -ShowBackup

Cet exemple renvoie toutes les opérations de batterie exécutées pour le répertoire C:\Backup.

------------------EXEMPLE 3-----------------
Code de copie
(Get-SPBackupHistory -Directory C:\Backup -ShowBackup)[0].SelfId | Restore-SPFarm -Directory C:\Backup -RestoreMethod overwrite

Cet exemple obtient toutes les opérations de sauvegarde de batterie exécutées pour le répertoire C:\Backup, recherche la sauvegarde la plus récente, puis transfère son GUID de sauvegarde à l'applet de commande Restore-SPFarm. L'applet de commande Restore-SPFarm effectue ensuite une restauration à partir de ce package de sauvegarde, en écrasant les données existantes.

Voir aussi

Référence

Backup-SPFarm
Backup-SPConfigurationDatabase
Restore-SPFarm

Historique des modifications


Restore-SPFarm
Voir aussi Exemple
[image]

Restaure un ou plusieurs éléments d'une sauvegarde.

Restore-SPFarm -Directory <String> -RestoreMethod <String> [-AssignmentCollection <SPAssignmentCollection>] [-BackupId <Guid>] [-ConfigurationOnly <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-FarmCredentials <PSCredential>] [-Force <SwitchParameter>] [-Item <String>] [-NewDatabaseServer <String>] [-Percentage <Int32>] [-RestoreThreads <Int32>] [-WhatIf [<SwitchParameter>]]
Restore-SPFarm -Directory <String> -ShowTree <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-BackupId <Guid>] [-ConfigurationOnly <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-Item <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Directory

Facultatif

System.String

Spécifie le chemin d'accès où SharePoint 2010 Products a stocké le package de sauvegarde. Si vous possédez un ordinateur sur lequel Microsoft SQL Server 2008 et une instance de SharePoint 2010 Products sont installés, vous pouvez utiliser des chemins d'accès au disque locaux. Cela inclut une installation de base. Cependant, si SQL Server 2008 et SharePoint 2010 Products sont installés sur plusieurs ordinateurs, vous devez utiliser des chemins de partage UNC afin que SQL Server 2008 et SharePoint 2010 Products puissent lire à partir d'un même emplacement (par exemple, \\nom_ordinateur \volume\Backup).

Le type doit être l'un des chemins d'accès valides suivants :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

Remarque :
Les dossiers spbr* sont créés automatiquement.

RestoreMethod

Facultatif

System.String

Spécifie la méthode de restauration à effectuer.

Les valeurs valides sont :

- New; spécifie un nouvel emplacement pour restaurer le contenu et doit être utilisé lorsque vous restaurez vers une autre batterie. Des invites supplémentaires apparaissent pour spécifier les nouveaux paramètres.

- Overwrite; restaure le contenu et les paramètres à leurs emplacements d'origine et doit être utilisé lorsque vous restaurez sur la batterie à partir de laquelle la sauvegarde a eu lieu. Si vous utilisez le paramètre Overwrite, une invite de confirmation s'affiche. Pour supprimer cette invite, utilisez le paramètre Force.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

BackupId

Facultatif

System.Guid

Spécifie le GUID du package de sauvegarde à restaurer. Chaque package de sauvegarde est associé à un GUID unique. Pour le consulter, utilisez l'applet de commande Get-SPBackupHistory pour afficher l'historique de sauvegarde. Si ce paramètre n'est pas spécifié, le package de sauvegarde le plus récent du chemin d'accès spécifié avec le paramètre Directory est utilisé.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890abcdef.

ConfigurationOnly

Facultatif

System.Management.Automation.SwitchParameter

Spécifie uniquement les paramètres (pas les données) qui seront restaurés à partir du package de sauvegarde et appliqués aux objets de la batterie de serveurs de destination.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

FarmCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie les informations d'identification utilisées pour tous les composants en cours de restauration. Par exemple, les informations d'identification du pool d'applications des applications Web en cours de restauration. Si un pool d'applications restauré existe déjà dans la batterie, les informations d'identification spécifiées par le paramètre FarmCredentials sont ignorées lors de la restauration de ce pool d'applications.

Force

Facultatif

System.Management.Automation.SwitchParameter

Supprime l'avertissement indiquant que les composants seront remplacés si vous effectuez une opération de restauration avec remplacement.

Item

Facultatif

System.String

Indique quelle partie du package de sauvegarde doit être restaurée. Vous pouvez utiliser la notation du chemin d'accès complet à la batterie de serveurs, tel qu'il est affiché par le paramètre ShowTree, ou le nom du composant cible dans le chemin d'accès, si son nom est unique. Si plusieurs éléments correspondent au nom, le chemin d'accès complet doit être spécifié. Placez l'élément ou le chemin d'accès entre guillemets doubles s'il contient un espace. Si ce paramètre n'est pas spécifié, tout le package de sauvegarde est restauré.

Le type doit être un élément valide, tel que :

Farm\Microsoft SharePoint Foundation Web Application\SharePoint - 80

NewDatabaseServer

Facultatif

System.String

Spécifie un nom de serveur de bases de données SQL valide. Si vous spécifiez ce paramètre, ce nom sera utilisé comme nom de serveur de bases de données par défaut pour toutes les bases de données impliquées dans l'opération de restauration.

Ce paramètre n'est valide que pour la restauration d'éléments nouveaux, pas pour les restaurations avec remplacement.

Percentage

Facultatif

System.Int32

Provoque l'affichage des mises à jour de l'avancement de l'opération de restauration par incréments du pourcentage. Par exemple, la valeur 5 provoque la mise à jour de l'avancement affiché chaque fois que l'avancement augmente de 5 % et la valeur 10 provoque la mise à jour chaque fois que l'avancement augmente de 10 %.

Remarque : l'avancement s'affiche dans le résultat uniquement si le paramètre -Verbose est spécifié. Sinon, vous pouvez consulter l'avancement dans le fichier journal de la restauration.

Ce pourcentage n'est pas précis et l'avancement réel de l'opération peut être supérieur ou inférieur aux valeurs définies.

Pour une base de données très volumineuse, 1 est la valeur recommandée.

Le type doit être un nombre entier compris entre 1 et 100.

La valeur par défaut est 5.

RestoreThreads

Facultatif

System.Int32

Nombre de threads à utiliser pendant la restauration.

Moins il y a de threads, plus le journal de restauration est facile à comprendre. Toutefois, plus il y a de threads de restauration, plus le nombre de composants pouvant être restaurés en parallèle est élevé, entraînant potentiellement une restauration plus rapide.

La plage valide est comprise entre 1 et 10. La valeur par défaut est 3.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Directory

Facultatif

System.String

Spécifie le chemin d'accès où SharePoint 2010 Products a stocké le package de sauvegarde. Si vous possédez un ordinateur sur lequel Microsoft SQL Server 2008 et une instance de SharePoint 2010 Products sont installés, vous pouvez utiliser des chemins d'accès au disque locaux. Cela inclut une installation de base. Cependant, si SQL Server 2008 et SharePoint 2010 Products sont installés sur plusieurs ordinateurs, vous devez utiliser des chemins de partage UNC afin que SQL Server 2008 et SharePoint 2010 Products puissent lire à partir d'un même emplacement (par exemple, \\nom_ordinateur \volume\Backup).

Le type doit être l'un des chemins d'accès valides suivants :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

Remarque :
Les dossiers spbr* sont créés automatiquement.

ShowTree

Facultatif

System.Management.Automation.SwitchParameter

Indique les objets de la batterie de serveurs qui seront restaurés en fonction des autres paramètres passés à l'applet de commande Restore-SPFarm, à savoir les paramètres Item et ConfigurationOnly. Les éléments qui seront exclus de la restauration en fonction des autres paramètres passés à l'applet de commande Restore-SPFarm seront précédés d'un astérisque (*). Les éléments qui ne peuvent pas être restaurés seront placés entre crochets ([ ]). L'opération de restauration n'a pas lieu si le paramètre ShowTree est spécifié.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

BackupId

Facultatif

System.Guid

Spécifie le GUID du package de sauvegarde à restaurer. Chaque package de sauvegarde est associé à un GUID unique. Pour le consulter, utilisez l'applet de commande Get-SPBackupHistory pour afficher l'historique de sauvegarde. Si ce paramètre n'est pas spécifié, le package de sauvegarde le plus récent du chemin d'accès spécifié avec le paramètre Directory est utilisé.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890abcdef.

ConfigurationOnly

Facultatif

System.Management.Automation.SwitchParameter

Spécifie uniquement les paramètres (pas les données) qui seront restaurés à partir du package de sauvegarde et appliqués aux objets de la batterie de serveurs de destination.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Item

Facultatif

System.String

Indique quelle partie du package de sauvegarde doit être restaurée. Vous pouvez utiliser la notation du chemin d'accès complet à la batterie de serveurs, tel qu'il est affiché par le paramètre ShowTree, ou le nom du composant cible dans le chemin d'accès, si son nom est unique. Si plusieurs éléments correspondent au nom, le chemin d'accès complet doit être spécifié. Placez l'élément ou le chemin d'accès entre guillemets doubles s'il contient un espace. Si ce paramètre n'est pas spécifié, tout le package de sauvegarde est restauré.

Le type doit être un élément valide, tel que :

Farm\Microsoft SharePoint Foundation Web Application\SharePoint - 80

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Restore-SPFarm restaure un ou plusieurs éléments d'une sauvegarde tels qu'une base de données individuelle, une application Web ou la batterie de serveurs entière. Vous pouvez également utiliser cette applet de commande pour appliquer un modèle de batterie de serveurs à la batterie de serveurs entière.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------

Code de copie
Restore-SPFarm -Directory \\file_server\share\Backup -BackupId 12345678-90ab-cdef-1234-567890abcdef -RestoreMethod new -ConfigurationOnly

Cet exemple restaure les paramètres de configuration depuis le package de sauvegarde du répertoire \\serveur_fichiers\share\Backup vers la batterie de serveurs.

------------------EXEMPLE 2-----------------------

Code de copie
Restore-SPFarm -ShowTree -Directory \\file_server\share\Backup -BackupId 12345678-90ab-cdef-1234-567890abcdef -Item "Microsoft SharePoint Foundation Web Application" -Verbose

Cet exemple indique quels composants de la batterie de serveurs seraient restaurés sous le nœud Microsoft SharePoint Foundation Web Application, sans toutefois les restaurer.

------------------EXEMPLE 3-----------------------

Code de copie
Restore-SPFarm -Directory C:\Backup -BackupId 12345678-90ab-cdef-1234-567890abcdef  -RestoreMethod overwrite -RestoreThreads 10 -Force

Cet exemple restaure une batterie de serveurs en utilisant 10 threads et supprime l'avertissement overwrite.

Voir aussi

Référence

Backup-SPFarm
Backup-SPConfigurationDatabase
Get-SPBackupHistory

Historique des modifications


Restore-SPSite
Voir aussi Exemple
[image]

Restaure une collection de sites.

Restore-SPSite [-Identity] <String> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ContentDatabase <SPContentDatabasePipeBind>] [-Force <SwitchParameter>] [-GradualDelete <SwitchParameter>] [-HostHeaderWebApplication <String>] [-WhatIf [<SwitchParameter>]]
Restore-SPSite [-Identity] <String> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseName <String>] [-DatabaseServer <String>] [-Force <SwitchParameter>] [-GradualDelete <SwitchParameter>] [-HostHeaderWebApplication <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

System.String

Spécifie l'URL sur laquelle la collection de sites est restaurée.

Il n'est pas nécessaire que la collection de sites existe déjà sur l'URL pour effectuer la restauration. Toutefois, vous devez spécifier une URL valide dans laquelle la collection de sites peut être créée. Si une collection de sites existe déjà à l'URL spécifiée, vous devez spécifier le paramètre Force pour l'écraser.

Le type doit être une URL valide au format http://server_name/sites/nom_site.

Path

Requis

System.String

Spécifie un chemin d'accès valide vers l'emplacement de la sauvegarde. Par exemple, C:\Backup\nom_site.bak.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

ContentDatabase

Facultatif

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie la base de données de contenu SQL Server dans laquelle les données de la collection de sites seront stockées. Si aucune base de données de contenu n'est spécifiée, la base de données de contenu la plus disponible et dont le statut est prêt est utilisée.

Force

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que la collection de sites existante à l'URL doit être écrasée par cette restauration.

GradualDelete

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que la collection de sites écrasée par le paramètre Force doit être graduellement supprimée dans le temps par un travail du minuteur plutôt qu'en une seule fois, ce qui réduit son impact sur la performance de SharePoint 2010 Products et SQL Server. Cette option est recommandée pour les collections de sites volumineuses.

HostHeaderWebApplication

Facultatif

System.String

URL valide associée à l'application Web par le biais d'un mappage des accès de substitution tel que http://nom_serveur.

Restaure une collection de sites sous la forme d'une collection de sites nommée par l'hôte, et non sous la forme d'une collection reposant sur des chemins d'accès. Lorsque le paramètre HostHeaderWebApplication est spécifié, la valeur du paramètre Identity correspond à l'URL de la collection de sites nommée par l'hôte et la valeur du paramètre HostHeaderWebApplication correspond à l'URL de l'application Web qui contiendra la collection de sites nommée par l'hôte.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

System.String

Spécifie l'URL sur laquelle la collection de sites est restaurée.

Il n'est pas nécessaire que la collection de sites existe déjà sur l'URL pour effectuer la restauration. Toutefois, vous devez spécifier une URL valide dans laquelle la collection de sites peut être créée. Si une collection de sites existe déjà à l'URL spécifiée, vous devez spécifier le paramètre Force pour l'écraser.

Le type doit être une URL valide au format http://server_name/sites/nom_site.

Path

Requis

System.String

Spécifie un chemin d'accès valide vers l'emplacement de la sauvegarde. Par exemple, C:\Backup\nom_site.bak.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseName

Facultatif

System.String

Spécifie la base de données de contenu SQL Server dans laquelle les données de la collection de sites seront stockées. Si aucune base de données de contenu n'est spécifiée, la base de données de contenu la plus disponible et dont le statut est prêt est utilisée.

Le type doit être un nom de base de données valide au format SQLDB1.

DatabaseServer

Facultatif

System.String

Spécifie le nom du serveur SQL Server contenant la base de données de contenu spécifiée par le paramètre DatabaseName.

Le type doit être un nom de serveur de bases de données valide au format SQLBE1 et doit être utilisé avec le paramètre DatabaseName.

Force

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que la collection de sites existante à l'URL doit être écrasée par cette restauration.

GradualDelete

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que la collection de sites écrasée par le paramètre Force doit être graduellement supprimée dans le temps par un travail du minuteur plutôt qu'en une seule fois, ce qui réduit son impact sur la performance de SharePoint 2010 Products et SQL Server. Cette option est recommandée pour les collections de sites volumineuses.

HostHeaderWebApplication

Facultatif

System.String

URL valide associée à l'application Web par le biais d'un mappage des accès de substitution tel que http://nom_serveur.

Restaure une collection de sites sous la forme d'une collection de sites nommée par l'hôte, et non sous la forme d'une collection reposant sur des chemins d'accès. Lorsque le paramètre HostHeaderWebApplication est spécifié, la valeur du paramètre Identity correspond à l'URL de la collection de sites nommée par l'hôte et la valeur du paramètre HostHeaderWebApplication correspond à l'URL de l'application Web qui contiendra la collection de sites nommée par l'hôte.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Restore-SPSite restaure la collection de sites à l'emplacement spécifié par le paramètre Identity. Une base de données de contenu ne peut contenir qu'une seule copie d'une collection de sites. Si une collection de sites est sauvegardée et restaurée sur une URL différente au sein de la même application Web, une base de données de contenu supplémentaire doit être disponible pour contenir la copie restaurée de la collection de sites.

Types retournés

Exemple

------------------EXEMPLE 1-----------------------

Code de copie
Restore-SPSite http://server_name/sites/site_name -Path C:\Backup\site_name.bak

Cet exemple restaure une collection de sites à partir du fichier de sauvegarde C:\Backup\site_name.bak vers l'URL de la collection de sites http://server_name/sites/site_name.

------------------EXEMPLE 2-----------------------

Code de copie
Restore-SPSite http://server_name/sites/site_name -Path C:\Backup\site_name.bak -Force -DatabaseServer SQLBE1 -DatabaseName SQLDB1

Cet exemple restaure une sauvegarde d'une collection de sites à partir du fichier de sauvegarde C:\Backup\site_name.bak, mais remplace la collection de sites existante à l'adresse http://server_name/sites/site_name en spécifiant qu'elle doit être restaurée dans une base de données de contenu spécifique.

------------------EXEMPLE 3-----------------------

Code de copie
Restore-SPSite http://www.example.com -Path \\file_server\share\site_name.bak -HostHeaderWebApplication http://server_name

Cet exemple restaure une sauvegarde d'une collection de sites à partir du fichier de sauvegarde \\file_server\share\site_name.bak vers la collection de sites nommée par l'hôte http://www.example.com sur l'application Web http://server_name.

Voir aussi

Référence

Backup-SPSite
Get-SPSite
Move-SPSite
New-SPSite
Remove-SPSite
Set-SPSite

Historique des modifications


Applets de commande Business Connectivity Services (SharePoint Foundation 2010)

Vous pouvez utiliser les applets de commande Windows PowerShell pour administrer les services Business Connectivity dans une batterie de serveurs Microsoft SharePoint Foundation 2010.

Nom de l'applet de commande | Description
Clear-SPSiteSubscriptionBusinessDataCatalogConfig | Supprime toutes les données du magasin de métadonnées Business Data Connectivity pour une partition spécifiée.
Copy-SPBusinessDataCatalogAclToChildren | Copie un ensemble d'autorisations d'un objet de métadonnées du magasin de métadonnées Business Data Connectivity dans ses objets enfants.
Disable-SPBusinessDataCatalogEntity | Désactive un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.
Enable-SPBusinessDataCatalogEntity | Active un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.
Export-SPBusinessDataCatalogModel | Exporte un modèle Business Data Connectivity.
Export-SPSiteSubscriptionBusinessDataCatalogConfig | Exporte toutes les données du magasin de métadonnées Business Data Connectivity associé à une partition.
Get-SPBusinessDataCatalogMetadataObject | Renvoie un objet de métadonnées de magasin de métadonnées Business Data Connectivity.
Grant-SPBusinessDataCatalogMetadataObject | Accorde un droit à une entité pour l'objet de métadonnées de magasin de métadonnées Business Data Connectivity spécifié.
Import-SPSiteSubscriptionBusinessDataCatalogDotNetAssembly | Importe des données associées au magasin de métadonnées Business Data Connectivity pour une partition.
Import-SPBusinessDataCatalogModel | Importe un modèle Business Data Connectivity.
New-SPBusinessDataCatalogServiceApplication | Crée une application de service Business Data Connectivity dans la batterie.
New-SPBusinessDataCatalogServiceApplicationProxy | Crée un proxy d'application de service Business Data Connectivity dans la batterie.
Remove-SPBusinessDataCatalogModel | Supprime un modèle Business Data Connectivity.
Revoke-SPBusinessDataCatalogMetadataObject | Révoque un droit à une entité dans l'objet de métadonnées de magasin de métadonnées Business Data Connectivity spécifié.
Set-SPBusinessDataCatalogMetadataObject | Définit la valeur d'une propriété ou d'un attribut d'un objet de métadonnées de magasin de métadonnées Business Data Connectivity.
Set-SPBusinessDataCatalogServiceApplication | Définit les propriétés globales pour une application de service Business Data Connectivity dans la batterie.
Import-SPSiteSubscriptionBusinessDataCatalogConfig | Importe les données associées à un fichier exporté qui contient toutes les données associées au magasin de métadonnées Business Data Connectivity pour une partition donnée.
Remove-SPSiteSubscriptionBusinessDataCatalogConfig | Supprime le magasin de métadonnées Business Data Connectivity pour une partition.

Historique des modifications

Date | Description | Raison
24 juin 2010 | Publication initiale |


Clear-SPSiteSubscriptionBusinessDataCatalogConfig
Voir aussi Exemple
[image]

Supprime toutes les données du magasin de métadonnées de connectivité de données métiers pour une partition spécifiée.

Clear-SPSiteSubscriptionBusinessDataCatalogConfig -ServiceContext <SPServiceContextPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

ServiceContext

Requis

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Spécifie le contexte de service pour lequel les modèles de connectivité de données métiers sont supprimés.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Clear-SPSiteSubscriptionBusinessDataCatalogConfig supprime tous les modèles et toutes les données du magasin de métadonnées de connectivité de données métiers pour une partition de service spécifiée.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Clear-SPSiteSubscriptionBusinessDataCatalogConfig -ServiceContext http://contoso

Cet exemple supprime toutes les données du magasin de métadonnées de connectivité de données métiers pour le site spécifié.

Voir aussi

Référence

Export-SPSiteSubscriptionBusinessDataCatalogConfig
Import-SPSiteSubscriptionBusinessDataCatalogConfig

Historique des modifications


Copy-SPBusinessDataCatalogAclToChildren
Voir aussi Exemple
[image]

Copie un ensemble d'autorisations d'un objet de métadonnées du magasin de métadonnées de connectivité de données métiers sur ses objets enfants.

Copy-SPBusinessDataCatalogAclToChildren -MetadataObject <MetadataObject> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

MetadataObject

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées de connectivité de données métiers.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Copy-SPBusinessDataCatalogAclToChildren copie un ensemble d'autorisations d'un objet de métadonnées Business Data Connectivity sur ses objets enfants.

Tous les principaux ainsi que leurs droits seront perdus dans les objets de métadonnées enfants. Vérifiez que l'objet de métadonnées parent comprend les autorisations définitives souhaitées, ou assurez-vous de les rajouter à l'objet enfant après avoir exécuté cette applet de commande.

L'exécution de cette applet de commande sur un BdcObjectType BdcCatalog (magasin de métadonnées Business Data Connectivity) se propagera sur les éléments suivants :

- Modèles BDC

- Systèmes externes

- Types de contenu externe

- Méthodes

- Instances de méthode

L'exécution de cette applet de commande sur un modèle BdcObjectType (modèle Business Data Connectivity) se propagera sur les éléments suivants :

- Rien ; ce type ne comporte aucun objet de métadonnées enfant

L'exécution de cette applet de commande sur un système externe BdcObjectType LobSystem se propagera sur les :

- Types de contenu externe

- Méthodes

- Instances de méthode

L'exécution de cette applet de commande sur un type de contenu externe BdcObjectType Entity se propagera sur les :

- Méthodes

- Instances de méthode

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$ExternalSystem = Get-SPBusinessDataCatalogMetadataObject -BdcObjectType "LobSystem" -ServiceContext http://contoso -Name "ContosoDatabase"

Cet exemple recherche les principaux (utilisateurs) et leurs droits correspondants données pour l'objet de métadonnées External System, et remplace les autorisations de ses objets de métadonnées enfants avec les mêmes principaux et droits.

Tous les principaux ainsi que leurs droits seront perdus dans les objets de métadonnées enfants. Vérifiez que l'objet de métadonnées parent comprend les autorisations définitives souhaitées, ou assurez-vous de les rajouter à l'objet enfant après avoir exécuté cette applet de commande.

Voir aussi

Référence

Get-SPBusinessDataCatalogMetadataObject
Grant-SPBusinessDataCatalogMetadataObject

Historique des modifications


Disable-SPBusinessDataCatalogEntity
Voir aussi Exemple
[image]

Désactive un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.

Disable-SPBusinessDataCatalogEntity -Identity <Entity> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.Entity

Spécifie le type de contenu externe du magasin de métadonnées Business Data Connectivity à désactiver.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Disable-SPBusinessDataCatalogEntity désactive un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$entityToDisable = Get-SPBusinessDataCatalogMetadataObject -Namespace "Contoso" -Name "Customer" -BdcObjectType "Entity" -ServiceContext http://contoso

Cet exemple désactive le type de contenu externe portant le nom Customer dans Contoso. Notez que les termes Type de contenu externe et Entity se rapportent au même type d'objet et le terme Disable se rapporte à la même action que le terme Business Data Connectivity Deactivate.

Voir aussi

Référence

Enable-SPBusinessDataCatalogEntity

Historique des modifications


Enable-SPBusinessDataCatalogEntity
Voir aussi Exemple
[image]

Active un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.

Enable-SPBusinessDataCatalogEntity -Identity <Entity> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.Entity

Spécifie le type de contenu externe du magasin de métadonnées Business Data Connectivity à activer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Enable-SPBusinessDataCatalogEntity active un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$entityToEnable = Get-SPBusinessDataCatalogMetadataObject -Namespace "Contoso" -Name "Customer" -BdcObjectType "Entity" -ServiceContext http://contoso
Enable-SPBusinessDataCatalogEntity -Identity $entityToEnable

Cet exemple active le type de contenu externe appelé Customer dans l'espace de noms Contoso sur le site http://contoso. Notez que les expressions Type de contenu externe et Entity se rapportent au même type d'objet.

Voir aussi

Référence

Disable-SPBusinessDataCatalogEntity

Historique des modifications


Export-SPBusinessDataCatalogModel
Voir aussi Exemple
[image]

Exporte un modèle Business Data Connectivity.

Export-SPBusinessDataCatalogModel -Identity <MetadataObject> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-Force <SwitchParameter>] [-LocalizedNamesIncluded <SwitchParameter>] [-ModelsIncluded <SwitchParameter>] [-PermissionsIncluded <SwitchParameter>] [-PropertiesIncluded <SwitchParameter>] [-ProxiesIncluded <SwitchParameter>] [-SettingId <String>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées du magasin de métadonnées Business Data Connectivity à partir duquel exporter le modèle Business Data Connectivity.

Chemin d'accès

Requis

System.String

Spécifie le chemin d'accès et le nom à utiliser pour créer le fichier d'exportation.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier \file.bdcm

- \\nom_serveur\nom_dossier \file.bdcm

- …\nom_dossier\file.bdcm

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Force

Facultatif

System.Management.Automation.SwitchParameter

Remplace le fichier de sortie, s'il existe.

LocalizedNamesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les noms des champs de données métiers dans plusieurs langues sont exportés.

ModelsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les modèles sont compris dans le fichier de modèle Business Data Connectivity. Un modèle contient les métadonnées XML de base d'un système.

PermissionsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les autorisations du modèle Business Data Connectivity sont exportées.

PropertiesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que des propriétés de la définition de l'application sont exportées.

ProxiesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les proxys des applications de service Business Data Connectivity sont exportées.

SettingId

Facultatif

System.String

Spécifie la partie du modèle des paramètres d'environnement personnalisés à exporter.

Le type doit être une chaîne valide qui identifie une partie du modèle, par exemple ModelSlice1.

Description détaillée

L'applet de commande Export-SPBusinessDataCatalogModel exporte un modèle Business Data Connectivity. Il existe deux types de modèles Business Data Connectivity : Model (.bdcm) et Resource (.bdcr). Le type Model contient des métadonnées XML de base et peut également comprendre des propriétés de ressource. Le type Resource ne comprend que des propriétés de ressource.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$Model = Get-SPBusinessDataCatalogMetadataObject -BdcObjectType "Model" -Name "ContosoModel" -ServiceConext http://contoso
Code de copie
Export-SPBusinessDataCatalogModel -Identity $Model -Path "C:\folder\model.bdcm"

Cet exemple obtient un modèle Business Data Connectivity dans le magasin de métadonnées Business Data Connectivity et l'exporte à l'emplacement spécifié portant le nom model, en utilisant l'extension de fichier bdcm.

Voir aussi

Référence

Import-SPBusinessDataCatalogModel
Remove-SPBusinessDataCatalogModel

Historique des modifications


Export-SPSiteSubscriptionBusinessDataCatalogConfig
Voir aussi Exemple
[image]

Exporte toutes les données du magasin de métadonnées Business Data Connectivity associées à une partition.

Export-SPSiteSubscriptionBusinessDataCatalogConfig -Path <String> -ServiceContext <SPServiceContextPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-LocalizedNamesIncluded <SwitchParameter>] [-ModelsIncluded <SwitchParameter>] [-PermissionsIncluded <SwitchParameter>] [-PropertiesIncluded <SwitchParameter>] [-ProxiesIncluded <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Chemin d'accès

Requis

System.String

Spécifie le chemin d'accès et le nom à utiliser pour créer le fichier d'exportation.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier\file.xml

- \\nom_serveur\nom_dossier\file.xml

- …\nom_dossier\file.xml

ServiceContext

Requis

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Spécifie le contexte de service des données à exporter.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de contexte de service valide (par exemple, http://ServiceContext1) ou une instance d'un objet SPServiceContext valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Remplace le fichier de sortie, s'il existe.

LocalizedNamesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les noms des champs de données métiers dans plusieurs langues sont exportés.

ModelsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les modèles Business Data Connectivity sont inclus dans le fichier exporté.

PermissionsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les autorisations des modèles Business Data Connectivity sont exportées.

PropertiesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les propriétés des modèles Business Data Connectivity sont exportées.

ProxiesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les applications de service Business Data Connectivity sont exportées.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande SPSiteSubscriptionBusinessDataCatalogConfig exporte toutes les données du magasin de métadonnées Business Data Connectivity associées à une partition spécifiée.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Export-SPSiteSubscriptionBusinessDataCatalogConfig -ServiceContext http://contoso -Path "C:\folder\exportedFile.xml"

Cet exemple exporte le fichier de données appelé exportedFile.xml.

Voir aussi

Référence

Clear-SPSiteSubscriptionBusinessDataCatalogConfig

Autres ressources

Import-SPSiteSubscriptionBusinessDataCatalogConfig

Historique des modifications


Get-SPBusinessDataCatalogMetadataObject
Voir aussi Exemple
[image]

Renvoie un objet de métadonnée du magasin de métadonnées Connexion de données métiers.

Get-SPBusinessDataCatalogMetadataObject -BdcObjectType <Catalog | Model | LobSystem | LobSystemInstance | Entity> -ServiceContext <SPServiceContextPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-ContainingLobSystem <String>] [-Name <String>] [-Namespace <String>]

Paramètres

Paramètre Requis Type Description

BdcObjectType

Requis

Microsoft.SharePoint.BusinessData.SharedService.SPGetSPBusinessDataCatalogMetadataObjectCmdlet+PSBdcObjectType

Spécifie le type de l'objet de métadonnées à renvoyer.

Le type doit être un des types d'objet de métadonnées valides suivants : BdcCatalog, Model, LobSystem, LobSystemInstance ou Entity.

ServiceContext

Requis

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Spécifie le contexte de service de l'objet de métadonnées Magasin de métadonnées Connexion de données métiers à renvoyer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Name

Facultatif

System.String

Spécifie le nom de l'objet de métadonnées.

Namespace

Facultatif

System.String

Spécifie l'espace de noms de l'objet de métadonnées.

Description détaillée

L'applet de commande Get-SPBusinessDataCatalogMetadataObject lit un objet de métadonnée du magasin de métadonnées Connexion de données métiers d'une application de service Connexion de données métiers. La sortie de cette applet de commande peut être une série d'objets. Par exemple, vous pouvez spécifier un caractère générique (*) pour que le paramètre BdcObjectType renvoie tous les objets de métadonnées sauf Catalog et LobSystemInstance.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$Model = Get-SPBusinessDataCatalogMetadataObject -BdcObjectType "Model" -Name "ContosoModel" -ServiceConext http://contoso

Cet exemple obtient un objet de métadonnées du type Model nommé ContosoModel à partir du Magasin de métadonnées Connexion de données métiers sur le site donné.

Voir aussi

Référence

Set-SPBusinessDataCatalogMetadataObject
Grant-SPBusinessDataCatalogMetadataObject
Revoke-SPBusinessDataCatalogMetadataObject

Historique des modifications


Grant-SPBusinessDataCatalogMetadataObject
Voir aussi Exemple
[image]

Octroie un droit à un utilisateur principal pour l'objet de métadonnée du magasin Connexion de données métiers spécifié.

Grant-SPBusinessDataCatalogMetadataObject -Identity <MetadataObject> -Principal <SPClaim> -Right <Execute | Edit | SetPermissions | SelectableInClients> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SettingId <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnée du magasin Connexion de données métiers contenant le principal.

Principal

Requis

System.String

Spécifie le principal auquel les droits s'appliquent.

Le type doit être une déclaration.

Right

Requis

Microsoft.SharePoint.BusinessData.SharedService.SPGrantSPBusinessDataCatalogMetadataObjectCmdlet+PSBdcRight

Spécifie le droit à octroyer au principal.

Le type doit être un des types d'objets PSBdcRight valides suivants : All, Execute, Edit, SetPermissions ou SelectableInClients.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

SettingId

Facultatif

System.String

Spécifie le secteur de modèle pour lequel octroyer le droit.

Le type doit être une chaîne valide qui identifie un secteur du modèle, par exemple ModelSlice1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Grant-SPBusinessDataCatalogMetadataObject octroie le droit à un utilisateur principal spécifié pour un objet de métadonnée du magasin Connexion de données métiers. Cette applet de commande vérifie que le paramètre Identity est un objet IndividuallySecurableMetadata valide.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$claimJohn = New-SPClaimsPrincipal -Identity "CONTOSO\johndoe" -IdentityType WindowsSamAccountName
Code de copie
$Model = Get-SPBusinessDataCatalogMetadataObject -BdcObjectType "Model" -ServiceContext http://contoso -Name "ContosoModel"
Code de copie
Grant-SPBusinessDataCatalogMetadataObject -Identity $Model -Principal $claimJohn -Right Edit

Cet exemple donne les autorisations Edit à l'utilisateur avec l'identité johndoe sur le domaine CONTOSO pour l'objet de métadonnée de modèle appelé ContosoModel.

Voir aussi

Référence

Set-SPBusinessDataCatalogMetadataObject
Get-SPBusinessDataCatalogMetadataObject
Revoke-SPBusinessDataCatalogMetadataObject

Historique des modifications


Import-SPSiteSubscriptionBusinessDataCatalogDotNetAssembly
Exemple
[image]

Importe un .NET Connectivity Assembly.

Import-SPBusinessDataCatalogDotNetAssembly -LobSystem <LobSystem> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DependentAssemblyPaths <String[]>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

LobSystem

Requis

Microsoft.SharePoint.BusinessData.Administration.LobSystem

Spécifie le LobSystem auquel l'assembly correspond.

Chemin d'accès

Requis

System.String

Spécifie le chemin d'accès à l'assembly primaire.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DependentAssemblyPaths

Facultatif

System.String[]

Spécifie une liste de chemins d'accès aux assemblys dépendants.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Import-SPBusinessDataCatalogDotNetAssembly importe un .NET Connectivity Assembly qui correspond à un .NET Assembly Connector et un LobSystem dans le magasin de métadonnées.

Pour connaître les autorisations et les informations les plus récentes sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-----------------EXEMPLE 1---------------
Code de copie
Import-SPBusinessDataCatalogDotNetAssembly -LobSystem $ContosoDB -Path "c:\Folder\Assembly.dll"

Cet exemple importe l'assembly Assembly.

-----------------EXEMPLE 2---------------
Code de copie
Import-SPBusinessDataCatalogDotNetAssembly -LobSystem $ContosoDB -Path "c:\Folder\Assembly.dll" -DependentAssemblyPaths "c:\Folder\Assembly2.dll","c:\Folder\Assembly3.dll"

Cet exemple importe l'assembly Assembly, ainsi que les assemblys Assembly2 et Assembly3 dépendants.

Historique des modifications


Import-SPBusinessDataCatalogModel
Voir aussi Exemple
[image]

Importe un modèle Connexion de données métiers.

Import-SPBusinessDataCatalogModel -Identity <MetadataObject> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-LocalizedNamesIncluded <SwitchParameter>] [-ModelsIncluded <SwitchParameter>] [-PermissionsIncluded <SwitchParameter>] [-PropertiesIncluded <SwitchParameter>] [-SettingId <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées du Magasin de métadonnées Connexion de données métiers dans lequel importer.

Path

Requis

System.String

Spécifie le chemin d'accès et le nom à utiliser.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier\fichier.bdcm

- \\nom_serveur\nom_dossier\fichier.bdcm

- …\nom_dossier\fichier.bdcm

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Écrase le modèle Connexion de données métiers si le fichier existe.

LocalizedNamesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les noms des champs de données métiers en plusieurs langues sont importés.

ModelsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les modèles sont inclus dans le fichier Modèle de connexion de données métiers importé. Un modèle contient les métadonnées XML de base d'un système.

PermissionsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les autorisations du modèle Connexion de données métiers sont importées.

PropertiesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les propriétés du modèle Connexion de données métiers sont importées.

SettingId

Facultatif

System.String

Spécifie le secteur du modèle des paramètres d'environnement personnalisés à importer.

Le type doit être une chaîne valide qui identifie un secteur du modèle, par exemple ModelSlice1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Import-SPBusinessDataCatalogModel importe un modèle Connexion de données métiers. Il existe deux types de modèles Connexion de données métiers : le type Model (.bdcm) et le type Resource (.bdcr). Le type Model contient les métadonnées XML de base et peut également inclure des propriétés de ressource. Le type Resource inclut uniquement les propriétés de ressource.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$MetadataStore = Get-SPBusinessDataCatalogMetadataObject -BdcObjectType "Catalog" -ServiceConext http://contoso
Code de copie
Import-SPBusinessDataCatalogModel -Path "C:\folder\model.bdcm" -Identity $MetadataStore

Cet exemple obtient le magasin de métadonnées Connexion de données métiers, puis importe un modèle Connexion de données métiers de type Model à partir du chemin d'accès spécifié avec le nom model.

Voir aussi

Référence

Export-SPBusinessDataCatalogModel
Remove-SPBusinessDataCatalogModel

Historique des modifications


New-SPBusinessDataCatalogServiceApplication
Voir aussi Exemple
[image]

Crée une nouvelle application de service de connectivité de données métiers dans la batterie de serveurs.

New-SPBusinessDataCatalogServiceApplication -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabasePassword <SecureString>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-Name <String>] [-PartitionMode <SwitchParameter>] [-Sharing <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

ApplicationPool

Requis

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Spécifie que le pool d'applications IIS utilise la nouvelle application de service de connectivité des données métiers.

DatabaseName

Requis

System.String

Spécifie le nom de la base de données de connectivité de données métiers.

DatabaseServer

Requis

System.String

Spécifie le nom du serveur hôte pour la base de données spécifiée dans DatabaseName.

Le type doit être un nom d'hôte SQL Server valide, par exemple SERVER\Database.

Name

Requis

System.String

Spécifie un nom d'affichage pour la nouvelle application de service de connectivité de données métiers.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom d'utilisateur et le mot de passe à utiliser pour l'authentification SQL Server de la base de données.

Le type doit être un objet PSCredential valide.

DatabasePassword

Facultatif

System.Security.SecureString

Spécifie le mot de passe de l'utilisateur spécifié dans DatabaseUserName. Utilisez ce paramètre uniquement si vous accédez à la base de données de connectivité de données métiers via l'authentification SQL Server.

Le type doit être un mot de passe valide.

DatabaseUsername

Facultatif

System.String

Spécifie le nom d'utilisateur à utiliser pour se connecter à la base de données. Utilisez ce paramètre uniquement si vous accédez à la base de données de connectivité de données métiers via l'authentification SQL Server.

FailoverDatabaseServer

Facultatif

System.String

Spécifie le nom du serveur hôte pour le serveur de bases de données de basculement.

PartitionMode

Requis

System.Management.Automation.SwitchParameter

Spécifie que l'application de service limite les données par ID d'abonnement. Cette propriété ne peut plus être modifiée une fois l'application de service créée.

Sharing

Requis

System.Management.Automation.SwitchParameter

Spécifie que l'application de connectivité de données métiers est publiée et partagée dans la batterie de serveurs.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPBusinessDataCatalogServiceApplication crée une nouvelle application de service de connectivité de données métiers dans la batterie de serveurs.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
New-SPBusinessDataCatalogServiceApplication -ApplicationPool "SharePoint Web Services Default" -DatabaseName "ContosoBdcDB" -DatabaseServer "CONTOSO\SharePoint" -Name "ContosoServiceApp"

Cet exemple crée une application de service de connectivité de données métiers nommée ContosoServiceApp. Pour cela, il utilise le pool d'applications SharePoint Web Services Default et crée une base de données nommée ContosoBdcDB.

Voir aussi

Référence

Set-SPBusinessDataCatalogServiceApplication
New-SPBusinessDataCatalogServiceApplicationProxy

Historique des modifications


New-SPBusinessDataCatalogServiceApplicationProxy
Voir aussi Exemple
[image]

Crée un nouveau proxy d'application du service Connexion de données métiers dans la batterie.

New-SPBusinessDataCatalogServiceApplicationProxy -Uri <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultProxyGroup <SwitchParameter>] [-Name <String>] [-PartitionMode <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
New-SPBusinessDataCatalogServiceApplicationProxy -ServiceApplication <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultProxyGroup <SwitchParameter>] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Name

Requis

System.String

Spécifie le nom complet du nouveau proxy d'application du service Connexion de données métiers.

Uri

Requis

System.Uri

Spécifie l'URI d'une application de service distante à laquelle se connecter.

Le type doit être un URI valide, au format file:\\nom_serveur\docssite.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DefaultProxyGroup

Requis

System.Management.Automation.SwitchParameter

Spécifie que le proxy de cette application de service est ajouté au groupe de proxies par défaut de la batterie.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Name

Requis

System.String

Spécifie le nom complet du nouveau proxy d'application du service Connexion de données métiers.

ServiceApplication

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application du service Connexion de données métiers associée au nouveau proxy.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DefaultProxyGroup

Requis

System.Management.Automation.SwitchParameter

Spécifie que le proxy de cette application de service est ajouté au groupe de proxies par défaut de la batterie.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPBusinessDataCatalogServiceApplicationProxy crée un nouveau proxy d'application du service Connexion de données métiers pour une application de ce même service dans la batterie.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
New-SPBusinessDataCatalogServiceApplicationProxy -Name "ContosoServiceAppProxy" -ServiceApplication $serviceApplication

Cet exemple crée un nouveau proxy d'application du service Connexion de données métiers appelé ContosoServiceAppProxy pour l'application de service donnée.

Voir aussi

Référence

New-SPBusinessDataCatalogServiceApplication
Set-SPBusinessDataCatalogServiceApplication

Historique des modifications


Remove-SPBusinessDataCatalogModel
Voir aussi Exemple
[image]

Supprime un modèle Business Data Connectivity.

Remove-SPBusinessDataCatalogModel -Identity <MetadataObject> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées du magasin de métadonnées Business Data Connectivity à supprimer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPBusinessDataCatalogModel supprime un modèle Business Data Connectivity.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$modelFile = Get-SPBusinessDataCatalogMetadataObject -Name "ContosoModel" -BdcObjectType Model -ServiceContext http://contoso
Remove-SPBusinessDataCatalogModel -Identity $modelFile

Cet exemple supprime le fichier de modèle Business Data Connectivity appelé ContosoModel.

Voir aussi

Référence

Import-SPBusinessDataCatalogModel
Export-SPBusinessDataCatalogModel

Historique des modifications


Revoke-SPBusinessDataCatalogMetadataObject
Voir aussi Exemple
[image]

Révoque un droit à un principal dans l'objet de métadonnées du magasin de métadonnées Business Data Connectivity spécifié.

Revoke-SPBusinessDataCatalogMetadataObject -Identity <MetadataObject> -Principal <SPClaim> -Right <Execute | Edit | SetPermissions | SelectableInClients> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SettingId <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées du magasin de métadonnées Business Data Connectivity qui contient le principal.

Principal

Requis

System.String

Spécifie le principal de sécurité auquel s'appliquent les droits.

Le type doit être une revendication.

Right

Requis

Microsoft.SharePoint.BusinessData.SharedService.SPGrantSPBusinessDataCatalogMetadataObjectCmdlet+PSBdcRight

Spécifie le droit de révoquer le principal.

Le type doit être l'un des types d'objets PSBdcRight valides suivants : All, Execute, Edit, SetPermissions ou SelectableInClients.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

SettingId

Facultatif

System.String

Spécifie la partie du modèle des paramètres d'environnement personnalisés pour laquelle révoquer le droit.

Le type doit être une chaîne valide qui identifie une partie du modèle, par exemple ModelSlice1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Revoke-SPBusinessDataCatalogMetadataObject révoque un droit accordé à un utilisateur principal dans l'objet de métadonnées du magasin de métadonnées Business Data Connectivity spécifié.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$claimJohn = New-SPClaimsPrincipal -Identity "CONTOSO\johndoe" -IdentityType WindowsSamAccountName
Code de copie
$MetadataObject = Get-SPBusinessDataCatalogMetadataObject -BdcObjectType "LobSystem" -ServiceContext http://contoso -Name "ContosoDatabase"
Code de copie
Revoke-SPBusinessDataCatalogMetadataObject -Identity $MetadataObject -Principal $claimJohn -Right "Execute"

Cet exemple supprime le droit execute du système externe portant le nom ContosoDatabase pour l'utilisateur dont l'identité est johndoe sur le domaine CONTOSO.

Voir aussi

Référence

Set-SPBusinessDataCatalogMetadataObject
Get-SPBusinessDataCatalogMetadataObject
Grant-SPBusinessDataCatalogMetadataObject

Historique des modifications


Set-SPBusinessDataCatalogMetadataObject
Voir aussi Exemple
[image]

Définit la valeur d'une propriété ou d'un attribut d'un objet de métadonnées Magasin de métadonnées de connectivité de données métiers.

Set-SPBusinessDataCatalogMetadataObject -Identity <MetadataObject> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-PropertyName <String>] [-PropertyValue <PSObject>] [-Remove <SwitchParameter>] [-SettingId <String>] [-WhatIf [<SwitchParameter>]]
Set-SPBusinessDataCatalogMetadataObject -Identity <MetadataObject> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DisplayName <String>] [-Remove <SwitchParameter>] [-SettingId <String>] [-WhatIf [<SwitchParameter>]]
Set-SPBusinessDataCatalogMetadataObject -Identity <MetadataObject> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-PropertyName <String>] [-Remove <SwitchParameter>] [-Remove <SwitchParameter>] [-SettingId <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées Magasin de métadonnées de connectivité de données métiers à mettre à jour.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

PropertyName

Facultatif

System.String

Spécifie le nom de la propriété à mettre à jour.

PropertyValue

Facultatif

System.Management.Automation.PSObject

Définit la nouvelle valeur de la propriété spécifiée dans le paramètre PropertyName.

Remove

Facultatif

System.Management.Automation.SwitchParameter

Supprime la propriété spécifiée dans le paramètre PropertyName.

SettingId

Facultatif

System.String

Spécifie le secteur du modèle de paramètres d'environnement personnalisé auquel s'applique la propriété.

Le type doit être une chaîne valide qui identifie un secteur du modèle, par exemple ModelSlice1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées Magasin de métadonnées de connectivité de données métiers à mettre à jour.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DisplayName

Facultatif

System.String

Spécifie le nom d'affichage de l'objet de métadonnées Magasin de métadonnées de connectivité de données métiers.

Remove

Facultatif

System.Management.Automation.SwitchParameter

Supprime la propriété spécifiée dans le paramètre PropertyName.

SettingId

Facultatif

System.String

Spécifie le secteur du modèle de paramètres d'environnement personnalisé auquel s'applique la propriété.

Le type doit être une chaîne valide qui identifie un secteur du modèle, par exemple ModelSlice1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.BusinessData.Administration.MetadataObject

Spécifie l'objet de métadonnées Magasin de métadonnées de connectivité de données métiers à mettre à jour.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

PropertyName

Facultatif

System.String

Spécifie le nom de la propriété à mettre à jour.

Remove

Facultatif

System.Management.Automation.SwitchParameter

Supprime la propriété spécifiée dans le paramètre PropertyName.

SettingId

Facultatif

System.String

Spécifie le secteur du modèle de paramètres d'environnement personnalisé auquel s'applique la propriété.

Le type doit être une chaîne valide qui identifie un secteur du modèle, par exemple ModelSlice1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPBusinessDataCatalogMetadataObject définit la valeur d'une propriété ou d'un attribut d'un objet de métadonnées Magasin de métadonnées de connectivité de données métiers.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
$objectToSetOn = Get-SPBusinessDataCatalogMetadataObject -Namespace "ContosoDatabase" -Name "ContosoDatabase" -BdcObjectType "LobSystemInstance" -ServiceContext http://contoso
Code de copie
Set-SPBusinessDataCatalogMetadataObject -Identity $objectToSetOn -PropertyName "ShowInSearchUI" -PropertyValue "True"

Cet exemple crée une propriété sur LobSystemInstance (instance de système externe) nommée ContosoDatabase. La propriété a pour nom ShowInSearchUI et pour valeur True.

Voir aussi

Référence

Get-SPBusinessDataCatalogMetadataObject
Revoke-SPBusinessDataCatalogMetadataObject
Grant-SPBusinessDataCatalogMetadataObject

Historique des modifications


Set-SPBusinessDataCatalogServiceApplication
Voir aussi Exemple
[image]

Définit les propriétés globales d'une application de service de connectivité de données métiers dans la batterie de serveurs.

Set-SPBusinessDataCatalogServiceApplication -Identity <SPServiceApplicationPipeBind> [-ApplicationPool <SPIisWebServiceApplicationPool>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabasePassword <SecureString>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-Name <String>] [-Sharing <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

ApplicationPool

Facultatif

Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool

Spécifie que le pool d'applications IIS utilise la nouvelle application de service de connectivité des données métiers.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom d'utilisateur et le mot de passe à utiliser pour l'authentification SQL Server de la base de données.

Le type doit être un objet PSCredential valide.

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données de connectivité de données métiers.

Le type doit être un nom valide de base de données SQL Server, par exemple UsageLogDB1.

DatabasePassword

Facultatif

System.Security.SecureString

Spécifie le mot de passe de l'utilisateur spécifié dans DatabaseUserName. Utilisez ce paramètre uniquement si vous accédez à la base de données de connectivité de données métiers via l'authentification SQL Server.

Le type doit être un mot de passe valide.

DatabaseServer

Facultatif

System.String

Spécifie le nom de la base de données de connectivité de données métiers.

Le type doit être un nom valide de base de données SQL Server, par exemple UsageLogDB1.

DatabaseUsername

Facultatif

System.String

Spécifie le nom d'utilisateur à utiliser pour se connecter à la base de données du catalogue. Utilisez ce paramètre uniquement si vous accédez à la base de données de connectivité de données métiers via l'authentification SQL Server.

Le type doit être un nom d'utilisateur valide, par exemple UserName1.

FailoverDatabaseServer

Facultatif

System.String

Spécifie le nom du serveur hôte pour le serveur de bases de données de basculement.

Le type doit être un nom d'hôte SQL Server valide, par exemple SQLServerHost1.

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service de connectivité de données métiers associée au nouveau proxy.

Name

Facultatif

System.String

Spécifie un nom d'affichage pour le nouveau proxy de l'application de service de connectivité de données métiers.

Sharing

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que l'application de service de connectivité de données métiers est publiée et partagée dans la batterie de serveurs.

AssignmentColletion

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPBusinessDataCatalogServiceApplication définit les propriétés globales d'une application de service de connectivité de données métiers dans la batterie de serveurs.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Set-SPBusinessDataCatalogServiceApplication -Identity $serviceApplication -FailoverDatabaseServer "CONTOSO\Backup"

Cet exemple définit le serveur de bases de données de basculement sur CONTOSO\Backup pour l'application de service donnée.

Voir aussi

Référence

New-SPBusinessDataCatalogServiceApplication
New-SPBusinessDataCatalogServiceApplicationProxy

Historique des modifications


Import-SPSiteSubscriptionBusinessDataCatalogConfig
Voir aussi Exemple
[image]

Importe les données associées à un fichier exporté qui contient toutes les données associées au magasin de métadonnées Business Data Connectivity pour une partition donnée.

Import-SPSiteSubscriptionBusinessDataCatalogConfig -Path <String> -ServiceContext <SPServiceContextPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-LocalizedNamesIncluded <SwitchParameter>] [-ModelsIncluded <SwitchParameter>] [-PermissionsIncluded <SwitchParameter>] [-PropertiesIncluded <SwitchParameter>] [-ProxiesIncluded <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Obligatoire Type Description

Chemin d'accès

Obligatoire

System.String

Spécifie le chemin et le nom à utiliser pour créer le fichier d'exportation. Le type doit être un chemin d'accès valide dans une des formes suivantes :

C:\nom_dossier

\\nom_serveur\nom_dossier

..\nom_dossier\fichier.xml

ServiceContext

Obligatoire

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Spécifie le contexte de service des données à exporter.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de contexte de service valide (par exemple, http://ServiceContext1) ou une instance d'un objet SPServiceContext valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirmer

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

LocalizedNamesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les noms des champs de données métiers en plusieurs langues sont importés.

ModelsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les modèles Business Data Connectivity sont inclus dans le fichier importé.

PermissionsIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les autorisations du modèle Business Data Connectivity sont exportées.

PropertiesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les propriétés des modèles Business Data Connectivity sont importées.

ProxiesIncluded

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les proxys des applications de service Business Data Connectivity sont exportées.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Import-SPSiteSubscriptionBusinessDataCatalogConfig pour importer les données d'un fichier de données contenant des modèles Business Data Connectivity et toutes les données associées au magasin de métadonnées pour une partition spécifiée.

Types d'entrée

Types de retour

Exemple

---------------------EXEMPLE---------------------------

Code de copie
Import-SPSiteSubscriptionBusinessDataCatalogConfig -Path "C:\folder\importFile.xml" -ServiceContext http://contoso

Cet exemple importe le fichier de données appelé importFile.xml.

Voir aussi

Référence

Clear-SPSiteSubscriptionBusinessDataCatalogConfig
Export-SPSiteSubscriptionBusinessDataCatalogConfig
Remove-SPSiteSubscriptionBusinessDataCatalogConfig

Historique des modifications


Remove-SPSiteSubscriptionBusinessDataCatalogConfig
Voir aussi Exemple
[image]

Supprime le Magasin de métadonnées Connexion de données métiers d'une partition.

Remove-SPSiteSubscriptionBusinessDataCatalogConfig -ServiceContext <SPServiceContextPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

ServiceContext

Requis

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Spécifie le contexte de service du Magasin de métadonnées Connexion de données métiers à supprimer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de contexte de service valide (par exemple, http://ServiceContext1) ou une instance d'un objet SPServiceContext valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPBusinessDataCatalogSiteSubscriptionConfig supprime le Magasin de métadonnées Connexion de données métiers et toutes les données associées d'une partition spécifiée. Pour supprimer entièrement une partition et les données qu'elle contient, exécutez l'applet de commande Clear-SPSiteSubscriptionBusinessDataCatalogConfig pour supprimer les données du Magasin de métadonnées Connexion de données métiers, puis exécutez l'applet de commande Remove-SPBusinessDataCatalogSiteSubscriptionConfig.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Remove-SPBusinessDataCatalogSiteSubscriptionConfig -ServiceContext http://contoso

Cet exemple supprime le Magasin de métadonnées Connexion de données métiers de la partition http://contoso.

Voir aussi

Référence

Export-SPSiteSubscriptionBusinessDataCatalogConfig

Autres ressources

Import-SPSiteSubscriptionBusinessDataCatalogConfig

Historique des modifications


Applets de commande pour les bases de données (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour gérer les bases de données dans une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Connect-SPConfigurationDatabase

Disconnect-SPConfigurationDatabase

New-SPConfigurationDatabase

Remove-SPConfigurationDatabase

Dismount-SPContentDatabase

Get-SPContentDatabase

Mount-SPContentDatabase

New-SPContentDatabase

Remove-SPContentDatabase

Set-SPContentDatabase

Test-SPContentDatabase

Get-SPDatabase

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Connect-SPConfigurationDatabase
Voir aussi Exemple
[image]

Connecte l'ordinateur serveur local à une batterie de serveurs.

Connect-SPConfigurationDatabase [-DatabaseName] <String> [-Passphrase] <SecureString> -DatabaseServer <String> [-AssignmentCollection <SPAssignmentCollection>] [-DatabaseCredentials <PSCredential>]

Paramètres

Paramètre Requis Type Description

DatabaseName

Requis

System.String

Spécifie le nom de la base de données de configuration à laquelle connecter le serveur.

Le type doit être un nom de base de données valide, par exemple DB1.

DatabaseServer

Requis

Serveur de base de données valide, tel que « SB ».

Spécifie le serveur sur lequel créer la base de données de configuration. La valeur par défaut est le nom de l'ordinateur local.

Passphrase

Requis

System.Security.SecureString

Spécifie la phrase de mot de passe sécurisé pour connecter le serveur actuel à la base de données de configuration.

Le type doit être une chaîne sécurisée valide, par exemple MyBDCApp1serverkey.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom et le mot de passe d'utilisateur à utiliser pour l'authentification SQL de la base de données. Si ce paramètre n'est pas spécifié, l'utilisateur actuel est utilisé.

Le type doit être un objet PSCredential valide.

Description détaillée

L'applet de commande Connect-SPConfigurationDatabase connecte le serveur actuel à la base de données de configuration spécifiée.

Cette applet de commande connecte essentiellement le serveur à la batterie. S'il est impossible de connecter l'ordinateur actuel à une batterie, le message d'erreur suivant est affiché :

« Cet ordinateur est déjà connecté à une batterie de serveurs SharePoint. Voir : Dismount-SPConfigurationDatabase. »

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Connect-SPConfigurationDatabase -DatabaseServer "ServerName\InstanceName" -DatabaseName "SharePointConfigurationDatabaseName" -Passphrase (ConvertTo-SecureString "MyP@ssw0rd" -AsPlainText -Force
Code de copie
Start-Service SPTimerv4

Cet exemple associe l'ordinateur serveur local à une batterie de serveurs configurée pour utiliser la base de données SharePointConfigurationDatabase sur une instance SQL Server en utilisant le nom ServerName\InstanceName avec le mot de passe MyP@ssw0rd.

Voir aussi

Référence

Backup-SPConfigurationDatabase
Disconnect-SPConfigurationDatabase
Dismount-SPContentDatabase
New-SPConfigurationDatabase
Remove-SPConfigurationDatabase

Historique des modifications


Disconnect-SPConfigurationDatabase
Voir aussi Exemple
[image]

Déconnecte l'ordinateur serveur local de la batterie de serveurs.

Disconnect-SPConfigurationDatabase [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Disconnect-SPConfigurationDatabase déconnecte l'ordinateur serveur actif de la base de données de configuration SharePoint. Cette opération supprime l'ordinateur serveur de la batterie de serveurs. Pour pouvoir supprimer la base de données, la base de données de configuration doit être déconnectée.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Disconnect-SPConfigurationDatabase -Confirm:$false

Cet exemple supprime l'ordinateur serveur local d'une batterie de serveurs sans demander confirmation à l'utilisateur.

Voir aussi

Référence

New-SPConfigurationDatabase
Remove-SPConfigurationDatabase
Connect-SPConfigurationDatabase
Backup-SPConfigurationDatabase

Historique des modifications


New-SPConfigurationDatabase
Voir aussi Exemple
[image]

Crée une nouvelle base de données de configuration.

New-SPConfigurationDatabase [-DatabaseName] <String> [-DatabaseServer] <String> [[-DirectoryDomain] <String>] [[-DirectoryOrganizationUnit] <String>] [[-AdministrationContentDatabaseName] <String>] [[-DatabaseCredentials] <PSCredential>] [-FarmCredentials] <PSCredential> [-Passphrase] <SecureString> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

DatabaseName

Requis

System.String

Spécifie le nom de la nouvelle base de données de configuration.

DatabaseServer

Requis

System.String

Spécifie le serveur de bases de données sur lequel vous souhaitez créer la base de données de configuration. Si aucune valeur n'est spécifiée, c'est la valeur par défaut qui est utilisée.

DirectoryDomain

Facultatif

System.String

Spécifie le domaine du répertoire de la nouvelle batterie de serveurs. Si aucun domaine n'est spécifié, c'est le domaine dans lequel l'ordinateur local se trouve qui est utilisé.

DirectoryOrganizationUnit

Facultatif

System.String

Spécifie l'unité d'organisation du répertoire de la nouvelle base de données de configuration. Si aucune unité d'organisation n'est spécifiée, c'est l'unité d'organisation dans laquelle l'ordinateur local se trouve qui est utilisée.

AdministrationContentDatabaseName

Requis

System.String

Spécifie le nom de la base de données de contenu de l'Administration centrale de la nouvelle batterie de serveurs. Si aucun nom n'est spécifié, c'est le nom par défaut qui est utilisé.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet Credential pour l'utilisateur de la base de données. Choisissez ce paramètre si vous utilisez l'authentification SQL Server. Si les informations d'identification de la base de données ne sont pas spécifiées, c'est l'authentification Windows qui est utilisée.

FarmCredentials

Requis

System.Management.Automation.PSCredential

Spécifie les informations d'identification du compte Administrateur de batterie.

Passphrase

Requis

System.Security.SecureString

Spécifie la phrase relative au mot de passe sécurisé de la nouvelle batterie de serveurs. Cette phrase relative au mot de passe permet d'associer d'autres machines à cette batterie de serveurs.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPConfigurationDatabase crée une nouvelle base de données de configuration sur le serveur de bases de données spécifié. Il s'agit de la base de données centrale d'une nouvelle batterie de serveurs SharePoint.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
New-SPConfigurationDatabase -DatabaseName "SharePointConfigDB1" -DatabaseServer "SQL-01" -Passphrase (ConvertTo-SecureString "MyPassword" -AsPlainText -force) -FarmCredentials (Get-Credential)

Cet exemple invite l'utilisateur à fournir des informations d'identification utilisateur pour le compte Administrateur de batterie par défaut.

Voir aussi

Référence

Backup-SPConfigurationDatabase
Disconnect-SPConfigurationDatabase
Connect-SPConfigurationDatabase
Remove-SPConfigurationDatabase

Autres ressources

Dismount-SPConfigurationDatabase

Historique des modifications


Remove-SPConfigurationDatabase
Voir aussi Exemple
[image]

Supprime définitivement une base de données de configuration.

Remove-SPConfigurationDatabase [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPConfigurationDatabase supprime définitivement la base de données de configuration de la batterie. La base de données de configuration doit déjà être démontée de toute batterie associée.

Pour en savoir plus sur les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Remove-SPConfigurationDatabase

Cet exemple supprime définitivement une base de données de configuration d'une batterie.

Voir aussi

Référence

Backup-SPConfigurationDatabase
Disconnect-SPConfigurationDatabase
Connect-SPConfigurationDatabase
New-SPConfigurationDatabase

Autres ressources

Dismount-SPConfigurationDatabase

Historique des modifications


Dismount-SPContentDatabase
Voir aussi Exemple
[image]

Détache une base de données de contenu de son application Web actuellement associée.

Dismount-SPContentDatabase [-Identity] <SPContentDatabasePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie la base de données de contenu à détacher.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de base de données de contenu SharePoint valide (par exemple, SPContentDB1) ou une instance d'un objet SPContentDatabase valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Dismount-SPContentDatabase pour détacher la base de données de contenu donnée de son application Web actuellement associée. Cette applet de commande ne supprimera pas la base de données de contenu. Utilisez l'applet de commande Remove-SPContentDatabase pour supprimer une base de données de contenu.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

--------------EXEMPLE 1------------
Code de copie
Dismount-SPContentDatabase 12345678-90ab-cdef-1234-567890abcdef

Cet exemple détache la base de données de contenu avec le GUID 12345678-90ab-cdef-1234-567890abcdef de son application Web parente.

--------------EXEMPLE 2------------
Code de copie
Get-SPContentDatabase -WebApplication http://sitename | Dismount-SPContentDatabase -WhatIf

Cet exemple détache toutes les bases de données de contenu de l'application Web sur le port 80 de l'ordinateur local. Supprimez le paramètre WhatIf pour effectuer l'opération.

Voir aussi

Référence

Get-SPContentDatabase
Set-SPContentDatabase
New-SPContentDatabase
Remove-SPContentDatabase
Mount-SPContentDatabase
Test-SPContentDatabase

Historique des modifications


Get-SPContentDatabase
Voir aussi Exemple
[image]

Renvoie une ou plusieurs bases de données de contenu.

Get-SPContentDatabase [[-Identity] <SPContentDatabasePipeBind>] [-AssignmentCollection <SPAssignmentCollection>]
Get-SPContentDatabase -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPContentDatabase -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPContentDatabase -ConnectAsUnattachedDatabase <SwitchParameter> -DatabaseName <String> -DatabaseServer <String> [-AssignmentCollection <SPAssignmentCollection>] [-DatabaseCredentials <PSCredential>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie une base de données de contenu spécifique à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de base de données de contenu SharePoint valide (par exemple, BDContenuSP1) ou une instance d'un objet SPContentDatabase valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Renvoie les bases de données de contenu pour l'application Web spécifiée.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MonAppOffice1) ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

3

Paramètre

Requis

Type

Description

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Renvoie la base de données de contenu pour la collection de sites spécifiée.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide, au format http://server_name, ou une instance d'un objet SPSite valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

4

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ConnectAsUnattachedDatabase

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que seules les bases de données non attachées de la batterie sont renvoyées.

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Get-SPContentDatabase renvoie les bases de données de contenu spécifiées.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

----------------EXEMPLE 1------------
Code de copie
Get-SPContentDatabase -webapplication http://sitename

Cet exemple renvoie toutes les bases de données de contenu utilisées par l'application Web sitename.

----------------EXEMPLE 2------------
Code de copie
Get-SPContentDatabase -site http://contoso.com

Cet exemple renvoie la base de données de contenu qui renferme la collection de sites à l'adresse http://contoso.com.

Voir aussi

Référence

Set-SPContentDatabase
New-SPContentDatabase
Remove-SPContentDatabase
Mount-SPContentDatabase
Test-SPContentDatabase
Upgrade-SPContentDatabase

Historique des modifications


Mount-SPContentDatabase
Voir aussi Exemple
[image]

Attache une base de données de contenu existante à la batterie.

Mount-SPContentDatabase [-Name] <String> [-WebApplication] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-AssignNewDatabaseId <SwitchParameter>] [-ClearChangeLog <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseServer <String>] [-MaxSiteCount <Int32>] [-UpdateUserExperience <SwitchParameter>] [-WarningSiteCount <Int32>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Name

Requis

System.String

Spécifie la base de données de contenu existante à attacher à la batterie.

Le type doit être un nom de base de données de contenu SharePoint valide, par exemple SPContentDB1.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Attache la base de données de contenu à l'application Web SharePoint spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeAppr1) ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AssignNewDatabaseId

Facultatif

System.Management.Automation.SwitchParameter

Crée un nouvel ID de base de données automatiquement quand la base de données de contenu est attachée.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

ClearChangeLog

Facultatif

System.Management.Automation.SwitchParameter

Efface toutes les modifications en attente du journal des modifications dans la base de données de contenu.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifies l'objet PSCredential contenant le nom et le mot de passe d'utilisateur à utiliser pour l'authentification SQL de la base de données.

Le type doit être un objet PSCredential valide.

DatabaseServer

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Indique le nom du serveur hôte pour la base de données de contenu spécifiée dans le paramètre Name.

Le type doit être un nom d'hôte SQL Server valide, par exemple SQLServerHost1.

MaxSiteCount

Facultatif

System.Int32

Spécifie le nombre maximal de sites Web pouvant utiliser la base de données de contenu.

Le type doit être un entier positif.

UpdateUserExperience

Facultatif

System.Management.Automation.SwitchParameter

Détermine si les bases de données de contenu doivent adopter l'interface utilisateur la plus récente. Par défaut, l'interface utilisateur restera la même pendant la mise à niveau.

WarningSiteCount

Facultatif

System.Int32

Spécifie le nombre de sites pouvant être créés avant qu'un événement d'avertissement ne soit généré et que le propriétaire de la collection de sites ne soit prévenu.

Le type doit être un entier positif.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Mount-SPContentDatabase attache une base de données de contenu existante à la batterie de serveurs. Si la base de données montée nécessite une mise à niveau, cette applet de commande entraînera la mise à niveau de la base de données.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

-----------------EXEMPLE---------------------
Code de copie
Mount-SPContentDatabase "MyDatabase" -DatabaseServer "MyServer" -WebApplication http://sitename

Cet exemple monte une base de données déjà existante sur l'application Web sitename.

Voir aussi

Référence

Get-SPContentDatabase
Set-SPContentDatabase
Remove-SPContentDatabase
Upgrade-SPContentDatabase
Dismount-SPContentDatabase
Get-SPServer

Historique des modifications


New-SPContentDatabase
Exemple
[image]

Crée une nouvelle base de données de contenu et l'attache à l'application Web spécifiée.

New-SPContentDatabase [-Name] <String> [-WebApplication] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-AssignNewDatabaseId <SwitchParameter>] [-ClearChangeLog <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseServer <String>] [-MaxSiteCount <Int32>] [-WarningSiteCount <Int32>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Name

Requis

System.String

Spécifie la nouvelle base de données de contenu à créer dans la batterie.

Le type doit être un nom de base de données de contenu SharePoint valide, par exemple SPContentDB1.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Attache la base de données de contenu à l'application Web SharePoint spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeAppr1) ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AssignNewDatabaseId

Facultatif

System.Management.Automation.SwitchParameter

Crée un nouvel ID de base de données automatiquement quand la base de données de contenu est attachée.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

ClearChangeLog

Facultatif

System.Management.Automation.SwitchParameter

Efface toutes les modifications en attente du journal des modifications dans la base de données de contenu.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom et le mot de passe d'utilisateur à utiliser pour l'authentification SQL Server de la base de données.

Le type doit être un objet PSCredential valide.

DatabaseServer

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Indique le nom du serveur hôte pour la base de données de contenu spécifiée dans le paramètre Name.

Le type doit être un nom d'hôte SQL Server valide, par exemple SQLServerHost1.

MaxSiteCount

Facultatif

System.Int32

Spécifie le nombre maximal de sites Web pouvant utiliser la base de données de contenu.

Le type doit être un entier positif.

WarningSiteCount

Facultatif

System.Int32

Spécifie le nombre de sites pouvant être créés avant qu'un événement d'avertissement ne soit généré et que le propriétaire de la collection de sites ne soit prévenu.

Le type doit être un entier positif.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPContentDatabase crée une nouvelle base de données de contenu et l'attache à l'application Web spécifiée.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

--------------EXEMPLE--------------------
Code de copie
New-SPContentDatabase "MyDatabase" -DatabaseServer "MyServer" -WebApplication http://sitename

Cet exemple crée une nouvelle base de données de contenu pour l'application Web sitename.

Historique des modifications


Remove-SPContentDatabase
Voir aussi Exemple
[image]

Supprime une base de données de contenu.

Remove-SPContentDatabase [-Identity] <SPContentDatabasePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie la base de données de contenu à supprimer.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de base de données de contenu SharePoint valide (par exemple, BDContenuSP1) ou une instance d'un objet SPContentDatabase valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPContentDatabase supprime définitivement une base de données de contenu de Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3. Dans les situations où les données doivent être conservées, utilisez l'applet de commande Dismount-SPContentDatabase. Cette dernière supprime la base de données de contenu de SharePoint 2010 Products mais pas de SQL Server 2008 R2, SQL Server 2008 avec SP1 et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

-----------------EXEMPLE---------------------
Code de copie
Get-SPContentDatabase 12345678-90ab-cdef-1234-567890abcdef | Remove-SPContentDatabase

Cet exemple supprime la base de données de contenu spécifiée.

Voir aussi

Référence

Get-SPContentDatabase
New-SPContentDatabase
Set-SPContentDatabase
Upgrade-SPContentDatabase
Test-SPContentDatabase

Historique des modifications


Set-SPContentDatabase
Voir aussi Exemple
[image]

Définit les propriétés globales d'une base de données de contenu SharePoint.

Set-SPContentDatabase [-Identity] <SPContentDatabasePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MaxSiteCount <Int32>] [-Status <Online | Disabled | Offline | Unprovisioning | Provisioning | Upgrading>] [-WarningSiteCount <Int32>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie la base de données de contenu à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de base de données de contenu SharePoint valide (par exemple, BDContenuSP1) ou une instance d'un objet SPContentDatabase valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

MaxSiteCount

Facultatif

System.Int32

Spécifie le nombre maximal de collections de sites que cette base de données peut héberger.

Le type doit être un entier positif. Définissez-le sur $null pour effacer cette valeur.

Status

Facultatif

Microsoft.SharePoint.Administration.SPObjectStatus

Spécifie le statut de la base de données SQL Server. Définissez ce paramètre sur Ready pour que la base de données soit disponible pour héberger de nouveaux sites. Définissez-le sur Offline pour que la base de données ne soit pas disponible pour héberger de nouveaux sites.

Le type doit être un des suivants : Ready ou Offline

WarningSiteCount

Facultatif

System.Int32

Spécifie le nombre de collections de sites pouvant être créées avant qu'un événement d'avertissement ne soit généré et le propriétaire de la collection de sites averti.

Le type doit être un entier positif. Définissez-le sur $null pour effacer cette valeur.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPContentDatabase définit les propriétés globales d'une base de données de contenu SharePoint.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

---------------EXEMPLE 1---------------
Code de copie
Get-SPContentDatabase http://contoso.com | Set-SPContentDatabase -MaxSiteCount 1

Cet exemple définit le MaxSiteCount pour la base de données de contenu qui renferme contoso.com sur 1.

---------------EXEMPLE 2---------------
Code de copie
Get-SPContentDatabase -WebApplication http://sitename | Set-SPContentDatabase -WarningSiteCount $null

Cet exemple efface le WarningSiteCount pour toutes les bases de données de l'application Web sitename.

Voir aussi

Référence

Get-SPContentDatabase
New-SPContentDatabase
Remove-SPContentDatabase
Upgrade-SPContentDatabase
Dismount-SPContentDatabase
Test-SPContentDatabase

Historique des modifications


Test-SPContentDatabase
Voir aussi Exemple
[image]

Teste une base de données de contenu.

Test-SPContentDatabase [-Identity] <SPContentDatabasePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-DatabaseCredentials <PSCredential>] [-ServerInstance <SPDatabaseServiceInstancePipeBind>] [-ShowRowCounts <SwitchParameter>]
Test-SPContentDatabase -Name <String> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-DatabaseCredentials <PSCredential>] [-ServerInstance <SPDatabaseServiceInstancePipeBind>] [-ShowRowCounts <SwitchParameter>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie une base de données de contenu Produits Microsoft SharePoint 2010 pour un des jeux de paramètres sous forme de GUID ou de nom de base de données s'il est unique.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom d'utilisateur et le mot de passe à utiliser pour l'authentification SQL Server de la base de données.

Le type doit être un objet PSCredential valide.

ServerInstance

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabaseServiceInstancePipeBind

Spécifie l'instance du service de base de données à utiliser pour tester la base de données de contenu spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'instance SQL Server (par exemple, DBSvrInstance1), ou une instance d'un objet SPDatabaseServiceInstance valide.

ShowRowCounts

Facultatif

System.Management.Automation.SwitchParameter

Retourne les statistiques de base de données, qui sont les compteurs de lignes pour les tables de la base de données de contenu.

2

Paramètre

Requis

Type

Description

Name

Requis

System.String

Spécifie la base de données de contenu existante à tester.

Le type doit être un nom valide de base de données de contenu SharePoint, par exemple SPContentDB1.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web SharePoint à utiliser pour tester la base de données de contenu.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'application Web SharePoint (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom d'utilisateur et le mot de passe à utiliser pour l'authentification SQL Server de la base de données.

Le type doit être un objet PSCredential valide.

ServerInstance

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabaseServiceInstancePipeBind

Spécifie l'instance du service de base de données à utiliser pour tester la base de données de contenu spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'instance SQL Server (par exemple, DBSvrInstance1), ou une instance d'un objet SPDatabaseServiceInstance valide.

ShowRowCounts

Facultatif

System.Management.Automation.SwitchParameter

Retourne les statistiques de base de données, qui sont les compteurs de lignes pour les tables de la base de données de contenu.

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

Utilisez l'applet de commande Test-SPContentDatabase pour tester une base de données de contenu avec une application Web afin de vérifier que toutes les personnalisations référencées dans la base de données de contenu sont également installées dans l'application Web. Cette applet de commande peut être émise sur une base de données de contenu attachée à la batterie de serveurs, ou sur une base de données de contenu qui n'est pas connectée à la batterie de serveurs. Elle peut également être utilisée pour tester des bases de données de contenu de SharePoint 2010 Products et de SharePoint Products and Technologies.

Remarque :
L'applet de commande Test-SPContentDatabase ne modifie ni les données, ni la structure de la base de données de contenu, mais peut occasionner une charge sur la base de données pendant les vérifications, pouvant empêcher momentanément son utilisation. Cette applet de commande ne peut être utilisée que sur une base de données de contenu présentant une utilisation faible ou nulle.

Types d'entrée

Types retournés

Exemple

----------------------------EXEMPLE 1-----------------------
Code de copie
Test-SPContentDatabase -name WSS_Content_DB -webapplication http://sitename

Cet exemple teste la base de données de contenu WSS_Content_DB avec l'application Web sitename et renvoie une liste de problèmes.

----------------------------EXEMPLE 2-----------------------
Code de copie
$DB = Get-SPContentDatabase -site http://contoso.com
Code de copie
Test-SPContentDatabase $DB -showrowcounts

Cet exemple obtient la base de données de contenu contenant la collection de sites à l'adresse http://contoso.com et la teste ensuite avec l'application Web qui l'héberge afin de déterminer les problèmes. Il affiche donc la liste des problèmes, spécifie le paramètre ShowRowCounts et renvoie les mesures de taille du tableau de la base de données de contenu.

Voir aussi

Référence

Get-SPContentDatabase
New-SPContentDatabase
Set-SPContentDatabase
Remove-SPContentDatabase
Mount-SPContentDatabase
Upgrade-SPContentDatabase

Historique des modifications


Get-SPDatabase
Voir aussi Exemple
[image]

Extrait toutes les propriétés d'une base de données.

Get-SPDatabase [[-Identity] <SPDatabasePipeBind>] [-AssignmentCollection <SPAssignmentCollection>]
Get-SPDatabase -ServerInstance <SPDatabaseServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabasePipeBind

Spécifie le nom de la base de données dont les propriétés publiques doivent être affichées.

Le type doit être un GUID valide, au format 1234-3456-567kg.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

ServerInstance

Requis

Microsoft.SharePoint.PowerShell.SPDatabaseServiceInstancePipeBind

Spécifie le nom de l'instance SQL qui contient la base de données, au format « Serveur » pour une base de données SQL par défaut ou « Serveur\Instance » pour une instance SQL nommée.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPDatabase affiche toutes les propriétés publiques d'une base de données dans la fenêtre active. Si le paramètre Identity est spécifié, seules les propriétés de cet identifiant sont affichées.

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE---------------------
Code de copie
Get-SPDatabase -ServerInstance "ServerA\SharePoint"

Cet exemple renvoie toutes les bases de données d'une instance SQL Server Express nommée spécifique.

Voir aussi

Référence

Get-SPContentDatabase
New-SPContentDatabase
Set-SPContentDatabase

Historique des modifications


Applets de commande de batterie (SharePoint Foundation 2010)

Vous pouvez utiliser les applets de commande Windows PowerShell pour administrer une batterie de serveurs Microsoft SharePoint Foundation 2010.

Nom de l'applet de commande | Description
Get-SPFarmConfig | Renvoie une propriété globale ou une collection de propriétés globales pour la batterie locale.
Get-SPProcessAccount | Renvoie un compte système ou un compte géré.
Get-SPWebTemplate | Affiche tous les modèles de sites installés globalement qui correspondent à l'identité donnée.
Install-SPWebTemplate | Installe le modèle de site donné.
New-SPCentralAdministration | Crée une application Web Administration centrale de SharePoint.
Set-SPCentralAdministration | Définit le port du site Web Administration centrale de SharePoint.
Set-SPFarmConfig | Définit une propriété globale ou une collection de propriétés globales pour la batterie locale.
Set-SPPassPhrase | Affecte une nouvelle valeur à la phrase secrète.
Set-SPWebTemplate | Modifie le titre et la description d'un modèle de site installé.
Start-SPAdminJob | Démarre immédiatement tout travail administratif en attente sur l'ordinateur local.
Uninstall-SPWebTemplate | Désinstalle le modèle de site donné.

Historique des modifications

Date | Description | Raison
24 juin 2010 | Publication initiale |


Get-SPFarmConfig
Voir aussi Exemple
[image]

Renvoie une propriété globale ou une collection de propriétés globales pour la batterie de serveurs locale.

Get-SPFarmConfig [-AssignmentCollection <SPAssignmentCollection>] [-ServiceConnectionPoint <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ServiceConnectionPoint

Facultatif

System.Management.Automation.SwitchParameter

Obtient les informations stockées dans le point de connexion de service de la batterie de serveurs actuelle dans Active Directory.

Description détaillée

L'applet de commande Get-SPFarmConfig récupère les paramètres globaux pour la batterie de serveurs qui ne sont pas membres de l'objet SPFarm. Cette applet de commande crée un nouvel objet PSCustomObject à partir de la collection de propriétés renvoyée depuis la batterie de serveurs locale, puis ajoute cet objet au pipeline. L'objet PSCustomObject peut être lu ou modifié, puis passé à l'applet de commande Set-SPFarmConfig pour modifier les valeurs des paramètres.

Les propriétés recueillies dans l'objet PSCustomObject doivent être des paramètres à l'échelle de la batterie. Elles doivent également être configurables une seule fois pour la batterie entière. Le nom du paramètre ajouté à l'objet PSCustomObject doit correspondre exactement au nom du paramètre d'entrée de l'applet de commande Set-SPFarmConfig.

Types d'entrée

Types retournés

Exemple

-------------EXEMPLE----------------
Code de copie
$a = Get-SPFarmConfig
Code de copie
$a.AjaxTimeout = 200
Code de copie
$a | Set-SPFarmConfig

Cet exemple utilise l'applet de commande Get-SPFarmConfig pour ajouter le paramètre Ajax Timeout à l'objet PSCustomObject, définit la valeur de Ajax Timeout, puis passe PSCustomObject à l'applet de commande Set-SPFarmConfig pour modifier le paramètre Ajax Timeout. Ajax Timeout, un paramètre à l'échelle de la batterie, est membre de l'objet SPWebService et n'est pas accessible au moyen d'une applet de commande Windows PowerShell.

Vous pouvez effectuer les mêmes opérations avec l'une des commandes suivantes.

Code de copie
Set-SPFarmConfig -AjaxTimeout 200
Code de copie
Get-SPFarmConfig | Select AjaxTimeout 200

Voir aussi

Référence

Set-SPFarmConfig

Historique des modifications


Get-SPProcessAccount
Exemple
[image]

Renvoie un compte système d'un compte géré.

Get-SPProcessAccount [-AssignmentCollection <SPAssignmentCollection>] [-NetworkService <SwitchParameter>]
Get-SPProcessAccount [-AssignmentCollection <SPAssignmentCollection>] [-LocalSystem <SwitchParameter>]
Get-SPProcessAccount [-AssignmentCollection <SPAssignmentCollection>] [-LocalService <SwitchParameter>]

Paramètres

1

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

NetworkService

Facultatif

System.Management.Automation.SwitchParameter

Renvoie le compte NetworkService.

2

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

LocalSystem

Facultatif

System.Management.Automation.SwitchParameter

Renvoie le compte LocalSystem.

3

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

LocalService

Facultatif

System.Management.Automation.SwitchParameter

Renvoie le compte LocalService.

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Get-SPProcessAccount renvoie un compte système ou un compte géré et crée l'objet SPProcessAccountPipeBind. Toutes les opérations pouvant accepter un compte peuvent accepter l'objet SPProcessAccountPipeBind au lieu de l'objet SPManagedAccountPipeBind.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Get-SPProcessAccount -NetworkService

Cet exemple crée le type SPProcessAccountPipeBind à l'aide du compte NetworkService.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPProcessAccount -NetworkService | New-SPServiceApplicationPool -Account $_

Cet exemple crée un compte SPServiceApplicationPool à l'aide du compte NetworkService renvoyé par l'applet de commande Get-SPProcessAccount.

Historique des modifications


Get-SPWebTemplate
Voir aussi Exemple
[image]

Affiche tous les modèles de sites installés globalement qui correspondent à l'identité donnée.

Get-SPWebTemplate [[-Identity] <SPWebTemplatePipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom du modèle Web à afficher.

Le type doit être l'ID ou le nom complet ou partiel du modèle Web.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPWebTemplate affiche tous les modèles de sites installés qui correspondent à l'identité partielle ou complète donnée.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
$template = Get-SPWebTemplate "STS#0"
Code de copie
New-SPSite http://contoso.com -OwnerAlias "DOMAIN\JDOE" -Template $template

Cet exemple crée une collection de sites à l'aide du modèle de site Web d'équipe (ID =STS#0).

--------------EXEMPLE 2-----------------
Code de copie
Get-SPWebTemplate "STS*"

Cet exemple affiche les informations de base concernant tous les modèles STS.

Voir aussi

Référence

Set-SPWebTemplate
Install-SPWebTemplate
Uninstall-SPWebTemplate

Historique des modifications


Install-SPWebTemplate
Voir aussi Exemple
[image]

Installe le modèle de site donné.

Install-SPWebTemplate [-Path] <String> -Name <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Path

Requis

System.String

Spécifie le chemin d'accès au package de modèles de site.

Le type doit être un chemin d'accès valide, par exemple <exemple de chemin d'accès>.

Name

Requis

System.String

Spécifie le nom du modèle.

Le type doit être un nom valide, par exemple MyTemplate.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description

Facultatif

System.String

Spécifie la description du modèle.

Le type doit être une description valide, par exemple Joe's Template.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Install-SPWebTemplate installe le modèle de site donné à l'aide du nom fourni (titre) en tant qu'ID unique.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Install-SPSiteTemplate -path "mytemplate.cab" -name "My Template" -description "TestFarm"

Cet exemple installe le fichier mytemplate.cab en tant que My Template avec la description "TestFarm" sur la batterie.

Voir aussi

Référence

Get-SPWebTemplate
Set-SPWebTemplate
Uninstall-SPWebTemplate

Historique des modifications


New-SPCentralAdministration
Voir aussi Exemple
[image]

Crée une nouvelle application Web Administration centrale SharePoint.

New-SPCentralAdministration [[-Port] <Int32>] [[-WindowsAuthProvider] <String>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Port

Facultatif

System.Int32

Spécifie le numéro de port de l'Administration centrale. Si aucun port n'est spécifié, un numéro de port non conflictuel est automatiquement généré.

Le type doit être un numéro de port valide.

Important :
Si vous spécifiez un numéro de port qui a déjà été attribué, IIS ne démarre pas le nouveau site tant que vous n'avez pas changé le numéro de port du nouveau site ou celui de l'ancien site.

WindowsAuthProvider

Facultatif

System.String

Spécifie le fournisseur d'authentification de cette application Web. Si aucun fournisseur n'est spécifié, la valeur par défaut NTLM est utilisée.

Le type doit être une des deux valeurs suivantes : Kerberos ou NTLM.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPCentralAdministration crée une nouvelle application Web Administration centrale et démarre le service d'administration centrale sur l'ordinateur local. L'administration centrale est disponible uniquement sur les ordinateurs exécutant ce service.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Aucun

Exemple

------------------EXEMPLE-----------------------
Code de copie
New-SPCentralAdministration -Port 3000

Cet exemple crée le site Central Administration au port 3000 sur la batterie locale.

Voir aussi

Référence

Set-SPCentralAdministration

Historique des modifications


Set-SPCentralAdministration
Voir aussi Exemple
[image]

Définit le port du site Web Administration centrale SharePoint.

Set-SPCentralAdministration -Port <Int32> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Port

Requis

System.Int32

Spécifie le port d'administration du site Administration centrale.

Le type doit être un numéro de port valide, par exemple 8080.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPCentralAdministration définit le port du site Administration centrale.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Set-SPCentralAdministration -Port 8282

Cet exemple définit le port de l'application Web Administration centrale de la batterie locale sur 8282.

Voir aussi

Référence

New-SPCentralAdministration

Historique des modifications


Set-SPFarmConfig
Voir aussi Exemple
[image]

Définit une propriété globale ou une collection de propriétés globales pour la batterie locale.

Set-SPFarmConfig [-ASPScriptOptimizationEnabled <$true | $false>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DataFormWebPartAutoRefreshEnabled <$true | $false>] [-Force <SwitchParameter>] [-InstalledProductsRefresh <SwitchParameter>] [-ServiceConnectionPointBindingInformation <String>] [-ServiceConnectionPointDelete <SwitchParameter>] [-WhatIf [<SwitchParameter>]] [-WorkflowBatchSize <Int32>] [-WorkflowEventDeliveryTimeout <Int32>] [-WorkflowPostponeThreshold <Int32>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DataFormWebPartAutoRefreshEnabled

Facultatif

System.Boolean

Spécifie si les composants DataFormWebPart de n'importe quelle page de la batterie sont autorisés à actualiser régulièrement leur contenu de manière asynchrone (une fois que la page est entièrement rendue). Défini sur false, tous les composants DataFormWebParts ignorent l'intervalle d'actualisation automatique fourni dans les propriétés des composants WebPart.

Force

Facultatif

System.Management.Automation.SwitchParameter

Force la suppression ou la mise à jour du point de connexion du service.

InstalledProductsRefresh

Facultatif

System.Management.Automation.SwitchParameter

Met à jour l'état de la licence de l'ordinateur actuel avec la liste des produits installés sur la batterie.

ServiceConnectionPointBindingInformation

Facultatif

System.String

Ajoute ou met à jour le point de connexion du service pour la batterie actuelle dans AD DS (Active Directory Domain Service).

Le type doit être un tableau de chaînes correspondant à des paires de valeurs clés qui seront ajoutées au point de connexion du service.

ServiceConnectionPointDelete

Facultatif

System.Management.Automation.SwitchParameter

Supprime le point de connexion du service pour la batterie actuelle dans AD DS.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WorkflowBatchSize

Facultatif

System.Int32

Spécifie la taille de pagination pour les événements remis à une même instance de flux de travail. Pour chaque demande, les événements sont transférés en continu, par 100 à la fois.

La taille de lot est le nombre d'événements traités pour une même instance de flux de travail, qui peut avoir de nombreux événements mis en file d'attente en même temps. Throttle a priorité sur la taille de lot : si l'instance de flux de travail ne peut pas être démarrée ou redémarrée en raison d'un trop grand nombre d'instances en cours d'exécution sur tous les serveurs Web frontaux, aucun des événements ne sera extrait, indépendamment de la taille de lot.

WorkflowEventDeliveryTimeout

Facultatif

System.Int32

Spécifie le délai en tant qu'entier dans lequel un travail de flux de travail doit s'exécuter sans que le travail dépasse le délai d'expiration. Si le travail de flux de travail dépasse le délai d'expiration, il est replacé dans la file d'attente pour être exécuté à nouveau.

Par exemple, si la valeur définie est 5, le travail de flux de travail doit s'exécuter dans les 5 minutes, sans quoi il dépassera le délai d'expiration. Tout travail de flux de travail qui dépasse le délai d'expiration est replacé dans la file d'attente pour s'exécuter à nouveau. La valeur par défaut est 5.

WorkflowPostponeThreshold

Facultatif

System.Int32

Spécifie le nombre de flux de travail pouvant être exécutés simultanément dans IIS sur une base de données avant que les nouvelles instances de flux de travail ne soient ajournées dans une file d'attente.

Description détaillée

L'applet de commande Set-SPFarmConfig met à jour une collection de paramètres globaux pour la batterie locale qui ne sont pas membres de l'objet SPFarm. Utilisez l'applet de commande Get-SPFarmConfig pour lire les paramètres globaux de la batterie locale et créer un nouvel objet PSCustomObject à partir de la collection de propriétés renvoyées par la batterie locale, puis ajoutez cet objet au pipeline. Modifiez l'objet PSCustomObject et transférez-le à l'applet de commande Set-SPFarmConfig pour changer les valeurs du paramètre.

Les propriétés recueillies dans l'objet PSCustomObject doivent être des paramètres à l'échelle de la batterie. Elles doivent également être configurables une seule fois pour la batterie entière. Le nom du paramètre ajouté à l'objet PSCustomObject doit correspondre exactement au nom du paramètre d'entrée de l'applet de commande Set-SPFarmConfig.

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE--------------------------
Code de copie
$a = Get-SPFarmConfig
Code de copie
$a.AjaxTimeout = 200
Code de copie
$a | Set-SPFarmConfig

Cet exemple utilise l'applet de commande Get-SPFarmConfig pour ajouter le paramètre Ajax Timeout à l'objet PSCustomObject, définit la valeur de Ajax Timeout, puis transmet PSCustomObject à l'applet de commande Set-SPFarmConfig pour changer le paramètre Ajax Timeout. Ajax Timeout, un paramètre à l'échelle de la batterie, est membre de l'objet SPWebService et n'est pas accessible via un applet de commande Windows PowerShell.

Vous pouvez effectuer les mêmes opérations avec n'importe laquelle des commandes suivantes.

Code de copie
Set-SPFarmConfig -AjaxTimeout 200

Voir aussi

Référence

Get-SPFarmConfig

Historique des modifications


Set-SPPassPhrase
Exemple
[image]

Définit la phrase secrète sur une nouvelle valeur.

Set-SPPassPhrase -ConfirmPassPhrase <SecureString> -PassPhrase <SecureString> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Set-SPPassPhrase -PassPhrase <SecureString> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-LocalServerOnly <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

LocalServerOnly

Facultatif

System.Management.Automation.SwitchParameter

Étend la modification de la phrase secrète au serveur local uniquement. Si le paramètre n'est pas utilisé, la modification de la phrase secrète est effectuée à l'échelle de la batterie.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPPassPhrase définit la phrase secrète sur une nouvelle valeur. Si le paramètre LocalServerOnly n'est pas utilisé, la clé de chiffrement de la batterie est rechiffrée avec la nouvelle valeur et tente de propager cette valeur à tous les autres serveurs dans la batterie. Si le paramètre LocalServerOnly est utilisé, la modification n'a lieu que sur l'ordinateur local, et la clé de chiffrement de la batterie reste inchangée. La valeur de la phrase secrète doit être identique sur tous les serveurs de la batterie pour que cette dernière fonctionne correctement. Par conséquent, si la propagation de phrase secrète sur tous les serveurs échoue, le paramètre LocalServerOnly peut être utilisé afin de définir manuellement les serveurs restants avec la nouvelle valeur de la phrase secrète.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
$passphrase = ConvertTo-SecureString -asPlainText -Force
Code de copie
Set-SPPassPhrase -PassPhrase $passphrase -Confirm

Cet exemple recherche une chaîne à utiliser comme passphrase, et définit la phrase secrète de la batterie avec une nouvelle valeur.

Historique des modifications


Set-SPWebTemplate
Voir aussi Exemple
[image]

Change le titre et la description d'un modèle de site installé.

Set-SPWebTemplate [-Identity] <SPWebTemplatePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebTemplatePipeBind

Spécifie le nom du modèle Web à modifier.

Le type doit être l'ID ou le nom complet du modèle Web.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description

Facultatif

System.String

Spécifie la nouvelle description.

Le type doit être une description valide, par exemple, Ceci est un modèle.

Name

Facultatif

System.String

Spécifie le nouveau nom du modèle.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPWebTemplate change le titre et la description d'un modèle de site installé.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Get-SPSiteTemplate "ATH#0" | Set-SPSiteTemplate -name "Athletics Site"
Code de copie
Set-SPSiteTemplate "ATH#0" -name "Athletics Site"

Cet exemple remplace le titre du modèle ATH#0 par Athletics Site.

Voir aussi

Référence

Get-SPWebTemplate
Install-SPWebTemplate
Uninstall-SPWebTemplate

Historique des modifications


Start-SPAdminJob
Voir aussi Exemple
[image]

Démarre immédiatement tout travail administratif en attente sur l'ordinateur local.

Start-SPAdminJob [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Start-SPAdminJob pour exécuter tous les travaux du minuteur administratifs immédiatement plutôt qu'attendre leur exécution.

Lorsque le compte de processus du service d'administration SharePoint 2010 (SPAdminV4) est désactivé (nécessaire dans certaines installations pour des raisons de sécurité), l'applet de commande Start-SPAdminJob doit être exécuté sur tous les ordinateurs pour effectuer la mise en service ou toute autre tâche administrative que SPAdmin gère habituellement.

Lorsque vous exécutez cet applet de commande en personne (pas dans un script), utilisez le paramètre Verbose pour afficher chaque opération administrative exécutée.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

aucun

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE-----------------------
Code de copie
Start-SPAdminJob -Verbose

Cet exemple exécute tous les travaux administratifs en attente et affiche la sortie détaillée à l'administrateur.

Voir aussi

Référence

Get-SPTimerJob
Set-SPTimerJob
Enable-SPTimerJob
Disable-SPTimerJob

Historique des modifications


Uninstall-SPWebTemplate
Voir aussi Exemple
[image]

Désinstalle le modèle de site donné.

Uninstall-SPWebTemplate [-Identity] <SPWebTemplatePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Language <UInt32>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebTemplatePipeBind

Spécifie l'ID ou le nom complet du modèle de site à supprimer.

Un modèle de site valide, par exemple, MYTEMP#0.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Language

Non

System.Int32

Spécifie la langue du fichier à supprimer. Si ce paramètre n'est pas fourni, toutes les langues du modèle donné sont supprimées. La valeur par défaut est ALL.

Le type doit être un ID de paramètre régional linguistique valide. Pour Anglais, utilisez 1033 .

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Uninstall-SPWebTemplate désinstalle le modèle de site donné en fournissant une identité complète.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Aucun

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE-----------------------
Code de copie
Uninstall-SPWebTemplate "mytemplate"
Code de copie
Get-SPWebTemplate "mytemplate" | Uninstall-SPWebTemplate

Cet exemple supprime un modèle de site appelé mytemplate.

Voir aussi

Référence

Get-SPWebTemplate
Install-SPWebTemplate
Set-SPWebTemplate

Historique des modifications


Applets de commande pour les fonctionnalités et les solutions (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour gérer les fonctionnalités et les solutions dans une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Add-SPSolution

Add-SPUserSolution

Disable-SPFeature

Enable-SPFeature

Get-SPFeature

Get-SPSolution

Get-SPUserSolution

Install-SPFeature

Install-SPSolution

Install-SPUserSolution

Remove-SPSolution

Remove-SPUserSolution

Remove-SPSolutionDeploymentLock

Uninstall-SPFeature

Uninstall-SPUserSolution

Uninstall-SPSolution

Update-SPSolution

Update-SPUserSolution

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Add-SPSiteSubscriptionFeaturePackMember
Voir aussi Exemple
[image]

Ajoute un composant fonctionnel à un ensemble de composants fonctionnels SharePoint.

Add-SPSiteSubscriptionFeaturePackMember [-Identity] <SPSiteSubscriptionFeaturePackPipeBind> -FeatureDefinition <SPFeatureDefinitionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPFeatureSetPipeBind

Spécifie l'objet d'ensemble de composants fonctionnels ou le GUID auquel le composant fonctionnel SharePoint donné est ajouté.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'ensemble de composants fonctionnels valide (par exemple, EnsembleComposantFonctionnel1) ou une instance d'un objet SPFeatureSet valide.

FeatureDefinition

Requis

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie la définition, le nom ou le GUID du composant fonctionnel à ajouter à l'ensemble.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Add- SPSiteSubscriptionFeaturePackMember ajoute des composants fonctionnels à l'ensemble de composants fonctionnels SharePoint fourni. Les ensembles de composants fonctionnels sont une liste autorisée de composants fonctionnels SharePoint pouvant être associés à tout abonnement au site. Si un ensemble de composants fonctionnels est affecté à un abonnement au site, seul l'objet SPFeatures de cet ensemble peut être utilisé sur les collections de sites et les sites Web membres de l'abonnement au site. Les ensembles de composants fonctionnels contiennent une liste des GUID de chaque composant fonctionnel de la liste autorisée pour les abonnements au site associés.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------EXEMPLE----------------
Code de copie
$fs = New-SPFeatureSet
Code de copie
Get-SPFeature -limit all | Where{ $_.Scope -eq "WEB" } | Add-SPFeatureSetMember -id $fs
Code de copie
$fs = Get-SPFeatureSet $fs

Cet exemple crée un ensemble de composants fonctionnels et y ajoute tous les composants fonctionnels à étendue de site Web.

L'ensemble de composants fonctionnels est actualisé dans la dernière ligne afin que l'objet local dispose des valeurs correctes.

Voir aussi

Référence

Remove-SPSiteSubscriptionFeaturePackMember

Historique des modifications

Date | Description | Raison
2011/01/24 | 2011/01/24 | Mise à jour du contenu


Add-SPSolution
Voir aussi Exemple
[image]

Télécharge un package de solution SharePoint dans la batterie de serveurs.

Add-SPSolution [-LiteralPath] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Language <UInt32>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

LiteralPath

Requis

System.String

Spécifie le chemin d'accès au package de solution.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Language

Facultatif

System.UInt32

Spécifie le pack de langue à installer avec le package de solution.

Le type doit être un identificateur de langue valide, par exemple 1033.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Add-SPSolution ajoute un package de solution SharePoint dans la batterie de serveurs. Cette applet de commande ne déploie pas la solution SharePoint téléchargée. Utilisez l'applet de commande Install-SPSolution pour déployer la solution SharePoint dans la batterie de serveurs.

Pour en savoir plus sur les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Add-SPSolution -LiteralPath c:\contoso_solution.wsp

Cet exemple ajoute la solution SharePoint au fichier contoso_solution.wsp de la batterie de serveurs.

Voir aussi

Référence

Get-SPSolution
Update-SPSolution
Uninstall-SPSolution
Remove-SPSolution
Install-SPSolution
Remove-SPSolutionDeploymentLock

Historique des modifications


Add-SPUserSolution
Voir aussi Exemple
[image]

Télécharge une nouvelle solution en bac à sable dans la galerie de solutions.

Add-SPUserSolution [-LiteralPath] <String> -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

LiteralPath

Requis

System.String

Spécifie le chemin d'accès au package de solution en bac à sable.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie la collection de sites à laquelle la solution en bac à sable doit être ajoutée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide au format http://server_name, ou une instance d'un objet SPSite valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Add-SPUserSolution télécharge un nouveau package de solution en bac à sable dans la galerie de solutions. Cette applet de commande n'active pas la solution en bac à sable téléchargée. Pour activer la solution dans la collection de sites, utilisez l'applet de commande Install-SPUserSolution.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

-------------------EXEMPLE---------------------
Code de copie
Add-SPUserSolution -LiteralPath c:\contoso_solution.wsp -Site http://sitename

Cet exemple ajoute la solution en bac à sable c:\contoso_solution.wsp au site http://sitename.

Voir aussi

Référence

Update-SPUserSolution
Install-SPUserSolution
Uninstall-SPUserSolution
Remove-SPUserSolution
Get-SPUserSolution

Historique des modifications


Disable-SPFeature
Voir aussi Exemple
[image]

Désactive un composant fonctionnel SharePoint installé sur une étendue donnée.

Disable-SPFeature [-Identity] <SPFeatureDefinitionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-Url <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom du composant fonctionnel ou le GUID à désactiver.

Le type doit être le nom du dossier Feature situé dans le dossier 14\Template\Features ou un GUID, au format 21d186e1-7036-4092-a825-0eb6709e9281.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force la désactivation d'un composant fonctionnel.

Url

Facultatif

System.String

Spécifie l'URL de l'application Web, de la collection de sites ou du site Web sur lequel le composant fonctionnel est désactivé.

Le type doit être une URL valide, comme http://server_name.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Disable-SPFeature désactive un composant fonctionnel SharePoint sur une étendue donnée. Si l'étendue du composant fonctionnel est la batterie, l'URL n'est pas nécessaire. Sinon, fournissez l'URL à laquelle ce composant fonctionnel doit être désactivé (aucune étendue explicite n'est nécessaire).

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

aucun

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Disable-SPFeature -identity "MyCustom" -URL http://somesite

Cet exemple désactive le composant fonctionnel sur l'étendue de site Web "MyCustom" à http://somesite.

--------------EXEMPLE 2-----------------
Code de copie
$w = Get-SPWeb http://somesite/myweb | ForEach{ $_.URL }
Code de copie
Get-SPFeature -Web $w |%{ Disable-SPFeature -Identity $_ -URL $w}

Cet exemple désactive tous les composants fonctionnels du sous-site à http://somesite/myweb.

Il n'est pas nécessaire d'utiliser les applets de commande SPAssignment dans ce cas car l'objet Web n'est pas enregistré, seule la valeur de chaîne pour l'URL l'est.

Voir aussi

Référence

Install-SPFeature
Enable-SPFeature
Get-SPFeature
Uninstall-SPFeature

Historique des modifications


Enable-SPFeature
Voir aussi Exemple
[image]

Active une fonctionnalité SharePoint installée au moment défini.

Enable-SPFeature [-Identity] <SPFeatureDefinitionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-PassThru <SwitchParameter>] [-Url <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom de la fonctionnalité ou le GUID à désinstaller.

Le type doit être le nom du dossier de la fonctionnalité situé dans le dossier 14\Template\Features ou le GUID au format 21d186e1-7036-4092-a825-0eb6709e9281.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force l'activation de la fonctionnalité. Ceci entraîne la réexécution du code personnalisé associé à la fonctionnalité.

PassThru

Facultatif

System.Management.Automation.SwitchParameter

Si ce paramètre est spécifié, l'applet de commande renvoie l'objet FeatureDefinition après son activation.

Url

Facultatif

System.String

Spécifie l'URL de l'application Web, de la collection de sites ou du site Web pour lequel la fonctionnalité est activée.

Le type doit être une URL valide, par exemple http://server_name.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Enable-SPFeature active une fonctionnalité installée au moment défini. S'il s'agit d'une fonctionnalité de batterie de serveurs, aucune URL n'est nécessaire. Sinon, spécifiez l'URL à laquelle la fonctionnalité doit être activée ; celle-ci sera activée au moment défini d'après sa définition.

Cette applet de commande ne renvoie pas de résultat sauf si le paramètre PassThru est spécifié. Dans ce cas, l'objet SPFeatureDefinition du nouveau composant logiciel activé est renvoyé.

Remarque :
Si vous tentez d'utiliser le paramètre Url sur un composant logiciel à l'échelle de la batterie, vous recevez le message d'erreur suivant :

Le composant logiciel <nom composant logiciel> s'applique à toute la batterie ; le paramètre Url ne peut pas être utilisé avec des composants logiciels à l'échelle de la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Enable-SPFeature -identity "MyCustom" -URL http://somesite

Cet exemple active la fonctionnalité SharePoint dont l'étendue est un site "MyCustom" sur http://somesite.

--------------EXEMPLE 2-----------------
Code de copie
$w = Get-SPWeb http://somesite/myweb | ForEach{ $_.URL }
Code de copie
Get-SPFeature -Web $w |%{ Enable-SPFeature -Identity $_ -URL $w}

Cet exemple active toutes les fonctionnalités SharePoint dans le sous-site à l'adresse http://somesite/myweb.

Voir aussi

Référence

Disable-SPFeature
Install-SPFeature
Uninstall-SPFeature
Get-SPFeature

Historique des modifications


Get-SPFeature
Voir aussi Exemple
[image]

Renvoie les fonctionnalités SharePoint sur la base d'une étendue donnée.

Get-SPFeature [[-Identity] <SPFeatureDefinitionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Limit <String>]
Get-SPFeature [[-Identity] <SPFeatureDefinitionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Farm <SwitchParameter>] [-Limit <String>]
Get-SPFeature [[-Identity] <SPFeatureDefinitionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Limit <String>] [-Sandboxed <SwitchParameter>] [-Site <SPSitePipeBind>]
Get-SPFeature [[-Identity] <SPFeatureDefinitionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Limit <String>] [-Web <SPWebPipeBind>]
Get-SPFeature [[-Identity] <SPFeatureDefinitionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Limit <String>] [-WebApplication <SPWebApplicationPipeBind>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom de la fonctionnalité à récupérer.

Le type doit être le nom complet ou partiel au format Feature1, ou un GUID au format 1234-4567-9879, de la fonctionnalité à obtenir.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Limit

Facultatif

System.String

Limite les résultats affichés. Si « Tous » est spécifié, toutes les fonctionnalités s'affichent.

Le type doit être un nombre valide supérieur à 0. La valeur par défaut est 200.

2

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom de la fonctionnalité à récupérer.

Le type doit être le nom complet ou partiel au format Feature1, ou un GUID au format 1234-4567-9879, de la fonctionnalité à obtenir.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Farm

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que si ce paramètre est utilisé, seules les fonctionnalités activées de la batterie de serveurs s'affichent.

Limit

Facultatif

System.String

Limite les résultats affichés. Si « Tous » est spécifié, toutes les fonctionnalités s'affichent.

Le type doit être un nombre valide supérieur à 0. La valeur par défaut est 200.

3

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom de la fonctionnalité à récupérer.

Le type doit être le nom complet ou partiel au format Feature1, ou un GUID au format 1234-4567-9879, de la fonctionnalité à obtenir.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Limit

Facultatif

System.String

Limite les résultats affichés. Si « Tous » est spécifié, toutes les fonctionnalités s'affichent.

Le type doit être un nombre valide supérieur à 0. La valeur par défaut est 200.

Site

Facultatif

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie le nom de la collection de sites à partir de laquelle obtenir les fonctionnalités activées.

Le type doit être une URL valide d'une collection de sites au format http://server_name.

4

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom de la fonctionnalité à récupérer.

Le type doit être le nom complet ou partiel au format Feature1, ou un GUID au format 1234-4567-9879, de la fonctionnalité à obtenir.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Limit

Facultatif

System.String

Limite les résultats affichés. Si « Tous » est spécifié, toutes les fonctionnalités s'affichent.

Le type doit être un nombre valide supérieur à 0. La valeur par défaut est 200.

Web

Facultatif

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie l'URL ou le GUID du site Web.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-5678-9876-0987.

5

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom de la fonctionnalité à récupérer.

Le type doit être le nom complet ou partiel au format Feature1, ou un GUID au format 1234-4567-9879, de la fonctionnalité à obtenir.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Limit

Facultatif

System.String

Limite les résultats affichés. Si « Tous » est spécifié, toutes les fonctionnalités s'affichent.

Le type doit être un nombre valide supérieur à 0. La valeur par défaut est 200.

Web

Facultatif

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie l'URL ou le GUID du site Web.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-5678-9876-0987.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom de l'application Web à partir de laquelle obtenir les fonctionnalités activées.

Le type doit être une URL valide vers l'application Web au format http://server_name.

Description détaillée

L'applet de commande SPFeature fait partie d'un ensemble de paramètres. Tous les paramètres prennent le paramètre Identity, qui peut être le chemin d'accès relatif de la fonctionnalité SharePoint (nom de la fonctionnalité) ou le GUID d'une définition de fonctionnalité. Si le paramètre Identity est spécifié, les applets de commande recherchent l'instance ou la définition de la fonctionnalité donnée pour l'étendue donnée. Si aucun paramètre n'est spécifié, toutes les fonctionnalités installées sont renvoyées.

L'applet de commande Get-SPFeature se comporte différemment dans chaque étendue et renvoie les fonctionnalités activées à chaque niveau. Si aucune étendue n'est spécifiée, toutes les fonctionnalités installées sont renvoyées.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Get-SPFeature -Limit ALL | Where-Object {$_.Scope -eq "SITE"}

Cet exemple renvoie la liste de toutes les fonctionnalités SITE de l'étendue installées.

--------------EXEMPLE 2-----------------
Code de copie
Get-SPSite http://somesite | Get-SPWeb -Limit ALL |%{ Get-SPFeature -Web $_ } | Select DisplayName,ID -Unique

Cet exemple renvoie le nom et l'identifiant (ID) de chaque fonctionnalité activée de manière unique sur chaque objet SPWeb de la collection de sites à l'adresse http://somesite.

Voir aussi

Référence

Install-SPFeature
Enable-SPFeature
Disable-SPFeature
Uninstall-SPFeature

Historique des modifications


Get-SPSiteSubscriptionFeaturePack
Voir aussi Exemple
[image]

Récupère les jeux de fonctions SharePoint disponibles ou le jeu de fonctions attribué à un abonnement au site donné.

Get-SPSiteSubscriptionFeaturePack [[-Identity] <SPSiteSubscriptionFeaturePackPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]
Get-SPSiteSubscriptionFeaturePack [-AssignmentCollection <SPAssignmentCollection>] [-SiteSubscription <SPSiteSubscriptionPipeBind>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPFeatureSetPipeBind

Spécifie un nom ou GUID de jeu de fonctions valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

SiteSubscription

Facultatif

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Garantit, si ce paramètre est fourni, que le jeu de fonctions renvoyé est celui qui est actuellement attribué à l'abonnement au site donné.

Description détaillée

L'applet de commande Get-SPSiteSubscriptionFeaturePack récupère les jeux de fonctions SharePoint disponibles ou le jeu de fonctions attribué à un abonnement au site donné.

Avertissement :
Soyez prudent quand vous attribuez des jeux de fonctions à des variables, car les modifications apportées au jeu de fonctions ne sont pas reflétées tant que la variable n'est pas actualisée.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
Get- SPSiteSubscriptionFeaturePack

Cet exemple renvoie tous les jeux de fonctions définis dans la batterie locale.

------------------EXEMPLE 2------------------
Code de copie
Get-SPSiteSubscriptionFeaturePack -SiteSubscription http://contoso.com | ForEach{ $_.FeatureDefinitions }

Cet exemple renvoie la liste (nom, ID et étendue) de toutes les fonctionnalités autorisées dans le jeu de fonctions actuellement attribué à l'abonnement au site de http://contoso.com.

Voir aussi

Référence

New-SPSiteSubscriptionFeaturePack
Remove-SPSiteSubscriptionFeaturePack
Add-SPSiteSubscriptionFeaturePackMember

Historique des modifications


Get-SPSolution
Voir aussi Exemple
[image]

Renvoie une solution SharePoint spécifiée.

Get-SPSolution [[-Identity] <SPSolutionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de solution SharePoint valide (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPSolution renvoie une solution SharePoint spécifiée. Si le paramètre Identity n'est pas spécifié, cette applet de commande renvoie la collection de toutes les solutions SharePoint installées sur la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPSolution

Cet exemple renvoie la collection de toutes les solutions SharePoint installées sur la batterie.

Voir aussi

Référence

Get-SPSolution
Add-SPSolution
Update-SPSolution
Uninstall-SPSolution
Remove-SPSolution
Install-SPSolution
Remove-SPSolutionDeploymentLock

Historique des modifications


Get-SPUserSolution
Voir aussi Exemple
[image]

Renvoie une solution de type sandbox spécifiée.

Get-SPUserSolution [[-Identity] <SPUserSolutionPipeBind>] -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPUserSolutionPipeBind

Spécifie la solution de type sandbox à obtenir.

Le type doit être un nom valide de solution utilisateur (par exemple, UserSolution1), ou une instance d'un objet SPUserSolution valide.

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie la collection de sites qui contient la solution de type sandbox.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide, au format http://server_name, ou une instance d'un objet SPSite valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPUserSolution renvoie une solution de type sandbox spécifiée. Si le paramètre Identity n'est pas spécifié, cette applet de commande renvoie la collection de solutions de type sandbox de la batterie SharePoint. Une solution d'utilisateur est une solution de type sandbox.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

-----------------EXEMPLE---------------------
Code de copie
Get-SPUserSolution -Site http://sitename

Cet exemple affiche les informations sur les solutions de type sandbox du site http://sitename.

Voir aussi

Référence

Update-SPUserSolution
Install-SPUserSolution
Uninstall-SPUserSolution
Remove-SPUserSolution
Add-SPUserSolution

Historique des modifications


Install-SPFeature
Voir aussi Exemple
[image]

Installe un composant fonctionnel SharePoint à l'aide d'un fichier Feature.xml.

Install-SPFeature [-Path] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Install-SPFeature -AllExistingFeatures <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-SolutionId <String>] [-WhatIf [<SwitchParameter>]]
Install-SPFeature -ScanForFeatures <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-SolutionId <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Path

Requis

System.String

Spécifie un chemin d'accès de fichier valide, par exemple, MonComposantFonctionnel.

Le chemin d'accès au composant fonctionnel doit être un chemin d'accès littéral au répertoire 14\Template\Features.Il peut être constitué de tout caractère standard pris en charge par le système Windows pour un nom de fichier. Le nom de fichier feature.xml est supposé et il est inutile de le fournir.

Si le fichier de la fonctionnalité est introuvable sur le disque, le message d'erreur suivant est affiché : « Le fichier XML est introuvable à l'emplacement « 14\Template\Features\ <chemin d'accès au fichier> » ».

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force l'installation d'un composant fonctionnel déjà installé.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

AllExistingFeatures

Requis

System.Management.Automation.SwitchParameter

Recherche les composants fonctionnels existants, mais non enregistrés, puis les enregistre auprès de la batterie.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force l'installation d'un composant fonctionnel déjà installé.

SolutionId

Facultatif

System.String

Spécifie l'identifiant de solution des composants fonctionnels. Si le paramètre SolutionId n'est pas spécifié, tous les identifiants de solution sont analysés.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

ScanForFeatures

Requis

System.Management.Automation.SwitchParameter

Analyse et affiche un composant fonctionnel. Le paramètre ScanForFeatures n'installe aucun composant fonctionnel.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force l'installation d'un composant fonctionnel déjà installé.

SolutionId

Facultatif

System.String

Spécifie l'identifiant de solution des composants fonctionnels. Si le paramètre SolutionId n'est pas spécifié, tous les identifiants de solution sont analysés.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Install-SPFeature installe un objet SPFeature spécifique en fournissant dans le paramètre Identity le chemin d'accès relatif au composant à partir du dossier "$env:ProgramFiles\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\FEATURES\. Les fichiers du composant SharePoint doivent déjà se trouver dans le répertoire correct, soit par le biais d'une opération manuelle, soit par le biais d'un programme d'installation de solution.

Si le paramètre AllExistingFeatures est fourni, le système de fichiers est analysé et tous les nouveaux composants fonctionnels sont installés. Cette opération a généralement lieu dans le cadre d'un déploiement ou d'une mise à niveau seulement.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Install-SPFeature -path "MyCustomFeature"

Cet exemple installe un nouveau composant fonctionnel au chemin $env:ProgramFiles\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\FEATURES\MyCustomFeature/feature.xml.

--------------EXEMPLE 2-----------------
Code de copie
Install-SPFeature -AllExistingFeatures -Whatif

Cet exemple affiche les composants fonctionnels non enregistrés, disponibles sur le système de fichiers, qui sont installés si cette commande est exécutée sans le paramètre WhatIf. Cette opération est couramment utilisée suite à un processus de mise à niveau.

Voir aussi

Référence

Get-SPFeature
Enable-SPFeature
Disable-SPFeature
Uninstall-SPFeature

Historique des modifications


Install-SPSolution
Voir aussi Exemple
[image]

Déploie une solution SharePoint installée dans la batterie de serveurs.

Install-SPSolution [-Identity] <SPSolutionPipeBind> [-AllWebApplications <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-CASPolicies <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-GACDeployment <SwitchParameter>] [-Language <UInt32>] [-Local <SwitchParameter>] [-Time <String>] [-WebApplication <SPWebApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]
Install-SPSolution [[-Identity] <SPSolutionPipeBind>] -Synchronize <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Language <UInt32>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à déployer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide de solution SharePoint (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

AllWebApplications

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que la nouvelle solution SharePoint est déployée pour toutes les applications Web SharePoint de la batterie de serveurs.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

CASPolicies

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les stratégies de sécurité d'accès du code (CAS) peuvent être déployées pour la nouvelle solution SharePoint.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force le déploiement de la nouvelle solution SharePoint.

GACDeployment

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que le Global Assembly Cache (GAC) peut être déployé pour la nouvelle solution SharePoint.

Language

Facultatif

System.UInt32

Spécifie une langue pour la solution lors du déploiement d'un module de prise en charge linguistique. Si ce paramètre n'est pas spécifié, zéro (« 0 ») est pris par défaut. Utilisez zéro pour les solutions qui sont valides pour toutes les langues.

Local

Facultatif

System.Management.Automation.SwitchParameter

Déploie la solution sur l'ordinateur serveur actif.

Time

Facultatif

System.String

Spécifie quand la solution sera déployée. La valeur par défaut est immédiatement.

Le type doit être une valeur DateTime valide, au format 2010, 5, 1.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Déploie la solution SharePoint pour l'application Web SharePoint spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeApp1) ou une instance d'un objet SPWebApplication valide.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à déployer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide de solution SharePoint (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Language

Facultatif

System.UInt32

Spécifie une langue pour la solution lors du déploiement d'un module de prise en charge linguistique. Si ce paramètre n'est pas spécifié, zéro (« 0 ») est pris par défaut. Utilisez zéro pour les solutions qui sont valides pour toutes les langues.

Synchronize

Facultatif

System.Management.Automation.SwitchParameter

Synchronise toutes les solutions ou la solution spécifiée dans la batterie de serveurs locale.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Install-SPSolution déploie une solution SharePoint installée dans la batterie de serveurs. Utilisez l'applet de commande Add-SPSolution pour installer un package de solution SharePoint dans la batterie de serveurs.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Install-SPSolution -Identity contoso_solution.wsp -GACDeployment

Cet exemple déploie la solution SharePoint contoso_solution.wsp installée dans la batterie de serveurs et spécifie que le GAC peut être déployé pour la nouvelle solution SharePoint.

Voir aussi

Référence

Get-SPSolution
Add-SPSolution
Update-SPSolution
Uninstall-SPSolution
Remove-SPSolution
Remove-SPSolutionDeploymentLock

Historique des modifications


Install-SPUserSolution
Voir aussi Exemple
[image]

Active une solution en bac à sable dans une collection de sites.

Install-SPUserSolution [-Identity] <SPUserSolutionPipeBind> -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUserSolutionPipeBind

Spécifie la solution en mode bac à sable à activer.

Le type doit être un nom valide de solution en mode bac à sable (par exemple, UserSolution1), ou une instance d'un objet SPUserSolution valide.

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Active la solution en bac à sable pour la collection de sites spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide au format http://server_name, ou une instance d'un objet SPSite valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Install-SPUserSolution active une solution en bac à sable dans une collection de sites. Une solution utilisateur est une solution en bac à sable.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

-------------------EXEMPLE---------------------
Code de copie
Install-SPUserSolution -Identity contoso_solution.wsp -Site http://sitename

Cet exemple active la solution en bac à sable contoso_solution.wsp sur le site http://sitename.

Voir aussi

Référence

Update-SPUserSolution
Uninstall-SPUserSolution
Remove-SPUserSolution
Get-SPUserSolution
Add-SPUserSolution

Historique des modifications


New-SPSiteSubscriptionFeaturePack
Voir aussi Exemple
[image]

Crée un nouvel ensemble de composants fonctionnels SharePoint permettant de limiter les composants fonctionnels à la disposition d'un abonnement au site.

New-SPSiteSubscriptionFeaturePack [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande New- SPSiteSubscriptionFeaturePack pour créer un nouvel ensemble de composants fonctionnels SharePoint qui limite les composants fonctionnels à la disposition d'un abonnement au site spécifié.

Les ensembles de composants fonctionnels SharePoint figurent sur une liste autorisée de composants fonctionnels SharePoint qui peuvent être associés à tout abonnement au site. Si un ensemble de composants fonctionnels est attribué à un abonnement au site, seuls les objets SPFeatures de cet ensemble peuvent être utilisés sur les collections de sites et les sites Web membres de l'abonnement au site. Les ensembles de composants fonctionnels contiennent une liste de GUID pour chaque composant fonctionnel figurant sur la liste autorisée pour les abonnements au site associés.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
$fs = New- SPSiteSubscriptionFeaturePack

Cet exemple crée un nouvel ensemble de composants fonctionnels SharePoint et l'enregistre dans une variable.

Voir aussi

Référence

Get-SPSiteSubscriptionFeaturePack
Add-SPSiteSubscriptionFeaturePackMember
New-SPSiteSubscriptionFeaturePack
Add-SPSiteSubscriptionFeaturePackMember

Historique des modifications


Remove-SPSiteSubscriptionFeaturePack
Voir aussi Exemple
[image]

Supprime un jeu de fonctions SharePoint d'un abonnement au site.

Remove-SPSiteSubscriptionFeaturePack [-Identity] <SPSiteSubscriptionFeaturePackPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPFeatureSetPipeBind

Spécifie l'objet du jeu de fonctions à supprimer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de jeu de fonctions valide (par exemple, FeatureSet1) ou une instance d'un objet SPFeatureSet valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove- SPSiteSubscriptionFeaturePack supprime un jeu de fonctions SharePoint en spécifiant l'objet du GUID ou du jeu de fonctions.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-----------------EXEMPLE------------------------
Code de copie
Remove-SPFeatureSet -Identity "30daa535-b0fe-4d10-84b0-fb04029d161a"

Cet exemple supprime un jeu de fonctions SharePoint dont l'ID est 30daa535-b0fe-4d10-84b0-fb04029d161a.

Voir aussi

Référence

Get-SPSiteSubscriptionFeaturePack
New-SPSiteSubscriptionFeaturePack
Remove-SPSiteSubscriptionFeaturePack
Add-SPSiteSubscriptionFeaturePackMember

Historique des modifications


Remove-SPSiteSubscriptionFeaturePackMember
Voir aussi Exemple
[image]

Supprime une définition de fonction du jeu de fonctions SharePoint fourni.

Remove-SPSiteSubscriptionFeaturePackMember [-Identity] <SPSiteSubscriptionFeaturePackPipeBind> -FeatureDefinition <SPFeatureDefinitionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Remove-SPSiteSubscriptionFeaturePackMember [-Identity] <SPSiteSubscriptionFeaturePackPipeBind> -AllFeatureDefinitions <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPFeatureSetPipeBind

Spécifie le jeu de fonctions à partir duquel supprimer une fonction.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de jeu de fonctions valide (par exemple, FeatureSet1) ou une instance d'un objet SPFeatureSet valide.

FeatureDefinition

Requis

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie la définition de fonction à supprimer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPFeatureSetPipeBind

Spécifie le jeu de fonctions à partir duquel supprimer une fonction.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de jeu de fonctions valide (par exemple, FeatureSet1) ou une instance d'un objet SPFeatureSet valide.

AllFeatureDefinitions

Requis

System.Management.Automation.SwitchParameter

Efface toutes les fonctions du jeu de fonctions.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPSiteSubscriptionFeaturePackMember supprime le paramètre FeatureDefintion fourni du jeu de fonctions spécifié par le paramètre Identity. Si l'indicateur AllFeatureDefinitions est fourni, toutes les définitions de fonctions sont supprimées du jeu de fonctions donné.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
$FS = Get-SPSiteSubscriptionFeaturePack "30daa535-b0fe-4d10-84b0-fb04029d161a"
Code de copie
Remove-SPSiteSubscriptionFeaturePackMember -Identity $fs -FeatureDefinition (Get-SPFeature "PublishingSite")

Cet exemple supprime la fonction PublishingSite du jeu de fonctions dont l'ID est 30daa535-b0fe-4d10-84b0-fb04029d161a.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPSiteSubscriptionFeaturePack "30daa535-b0fe-4d10-84b0-fb04029d161a" | Remove-SPSiteSubscriptionFeaturePackMember -AllFeatureDefinitions

Cet exemple supprime toutes les fonctions du jeu de fonctions 30daa535-b0fe-4d10-84b0-fb04029d161a.

Voir aussi

Référence

Add-SPSiteSubscriptionFeaturePackMember
Get-SPSiteSubscriptionFeaturePack
Remove-SPSiteSubscriptionFeaturePack

Historique des modifications


Remove-SPSolution
Voir aussi Exemple
[image]

Supprime une solution SharePoint d'une batterie.

Remove-SPSolution [-Identity] <SPSolutionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-Language <UInt32>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à supprimer.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de solution SharePoint valide (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Oblige la suppression de la solution SharePoint. Vous pouvez utiliser ce paramètre pour supprimer des solutions SharePoint qui ont été ajoutées au serveur, même si elles n'ont pas été déployées à l'aide de l'applet de commande Install-SPSolution.

Language

Facultatif

System.UInt32

Supprime le module linguistique de la langue spécifiée.

Le type doit être un identificateur de langue valide ; par exemple, 1033.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPSolution supprime une solution SharePoint d'une batterie. Avant de l'utiliser, vous devez utiliser l'applet de commande Uninstall-SPSolution pour extraire les fichiers de la solution du serveur Web frontal.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Remove-SPSolution -Identity contoso_solution.wsp

Cet exemple supprime la solution SharePoint contoso_solution.wsp.

Voir aussi

Référence

Get-SPSolution
Add-SPSolution
Update-SPSolution
Uninstall-SPSolution
Install-SPSolution

Historique des modifications


Remove-SPUserSolution
Voir aussi Exemple
[image]

Supprime une solution en bac à sable de la galerie de solutions.

Remove-SPUserSolution [-Identity] <String> -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUserSolutionPipeBind

Spécifie la solution en bac à sable à supprimer.

Le type doit être un nom valide de solution en mode bac à sable (par exemple, UserSolution1), ou une instance d'un objet SPUserSolution valide.

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Supprime la solution en bac à sable de la collection de sites spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide au format http://server_name, ou une instance d'un objet SPSite valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPUserSolution supprime complètement une solution en bac à sable de la galerie de solutions. Avant de supprimer la solution en bac à sable de la galerie de solutions, vous devez la désactiver grâce à l'applet de commande Uninstall-SPUserSolution.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

----------------EXEMPLE----------------------
Code de copie
Remove-SPUserSolution -Identity contoso_solution.wsp -Site http://sitename

Cet exemple supprime la solution en bac à sable contoso_solution.wsp du site http://sitename..

Voir aussi

Référence

Update-SPUserSolution
Install-SPUserSolution
Uninstall-SPUserSolution
Get-SPUserSolution
Add-SPUserSolution

Historique des modifications


Remove-SPSolutionDeploymentLock
Voir aussi Exemple
[image]

Supprime le verrou de déploiement de solution d'un serveur.

Remove-SPSolutionDeploymentLock [[-Identity] <SPServerPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie le serveur duquel le verrou de déploiement de solution doit être supprimé.

Le type doit correspondre à un GUID valide, tel que 12345678-90ab-cdef-1234-567890bcdefgh, l'adresse IP d'un serveur au format 208.77.188.166, un nom valide de service hôte SQL Server (par exemple, SQLServerHost1) ou une instance d'un objet SPServer valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPSolutionDeploymentLock supprime le verrou de déploiement de solution d'un serveur. Si le paramètre Identity n'est pas spécifié, cette applet de commande supprime le verrou de déploiement de solution de tous les serveurs de la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Remove-SPSolutionDeploymentLock

Cet exemple supprime le verrou de déploiement de solution de tous les serveurs de la batterie.

Voir aussi

Référence

Remove-SPSolution
Get-SPSolution
Add-SPSolution
Update-SPSolution
Uninstall-SPSolution
Install-SPSolution

Historique des modifications


Uninstall-SPFeature
Voir aussi Exemple
[image]

Désinstalle une définition de fonctionnalité installée.

Uninstall-SPFeature [-Identity] <SPFeatureDefinitionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Paramètre

Microsoft.SharePoint.PowerShell.SPFeatureDefinitionPipeBind

Spécifie le nom de la fonctionnalité ou le GUID à désinstaller.

Le type doit être le nom du dossier de fonctionnalités se trouvant dans le dossier <drive>:\program files\common files\Microsoft Shared\Web server extensions\14\template\features ou il doit s'agir d'un GUID au format 21d186e1-7036-4092-a825-0eb6709e9281.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Non

System.Management.Automation.SwitchParameter

Force la désinstallation d'une fonctionnalité déjà installée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Uninstall-SPFeature supprime la définition de fonctionnalité spécifiée de la collection de définitions de fonctionnalités dans la batterie de serveurs.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Aucune

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE-----------------------
Code de copie
Uninstall-SPFeature -path "MyCustomFeature"

Cet exemple désinstalle la fonctionnalité du chemin $env:ProgramFiles\Common Files\Microsoft Shared Debug\Web Server Extensions\14\TEMPLATE\FEATURES\MyCustomFeature/feature.xml.

Voir aussi

Référence

Get-SPFeature
Enable-SPFeature
Disable-SPFeature
Install-SPFeature

Historique des modifications


Uninstall-SPUserSolution
Voir aussi Exemple
[image]

Désactive une solution en bac à sable dans une collection de sites.

Uninstall-SPUserSolution [-Identity] <SPUserSolutionPipeBind> -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUserSolutionPipeBind

Spécifie la solution en bac à sable à désactiver.

Le type doit être un nom valide de solution en mode bac à sable (par exemple, UserSolution1), ou une instance d'un objet SPUserSolution valide.

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Désactive la solution en bac à sable pour la collection de sites spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide au format http://server_name, ou une instance d'un objet SPSite valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Uninstall-SPUserSolution désactive une solution en bac à sable dans une collection de sites pour en permettre la suppression grâce à l'applet de commande Remove-SPUserSolution. Une solution utilisateur est une solution en bac à sable.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-------------------

Code de copie
Uninstall-SPUserSolution -Identity contoso_solution.wsp -Site http://sitename

Cet exemple désactive la solution en bac à sable contoso_solution.wsp sur le site http://sitename.

Voir aussi

Référence

Update-SPUserSolution
Install-SPUserSolution
Remove-SPUserSolution
Get-SPUserSolution
Add-SPUserSolution

Historique des modifications


Uninstall-SPSolution
Voir aussi Exemple
[image]

Retire une solution SharePoint déployée.

Uninstall-SPSolution [-Identity] <SPSolutionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Language <UInt32>] [-Local <SwitchParameter>] [-Time <String>] [-WhatIf [<SwitchParameter>]]
Uninstall-SPSolution [-Identity] <SPSolutionPipeBind> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Language <UInt32>] [-Local <SwitchParameter>] [-Time <String>] [-WhatIf [<SwitchParameter>]]
Uninstall-SPSolution [-Identity] <SPSolutionPipeBind> -AllWebApplications <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Language <UInt32>] [-Local <SwitchParameter>] [-Time <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à désinstaller.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de solution SharePoint valide (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Language

Facultatif

System.UInt32

Désinstalle le module linguistique de la langue spécifiée.

Le type doit être un identificateur de langue valide ; par exemple, 1033.

Local

Facultatif

System.Management.Automation.SwitchParameter

Désinstalle la solution du serveur actif.

Time

Facultatif

System.String

Spécifie le moment auquel la solution sera désinstallée. La valeur par défaut est un retrait immédiat.

Le type doit être une valeur DateTime valide, au format 2010,12,05.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à désinstaller.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de solution SharePoint valide (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Désinstalle la solution SharePoint pour l'application Web SharePoint spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'application Web SharePoint (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Language

Facultatif

System.UInt32

Désinstalle le module linguistique de la langue spécifiée.

Le type doit être un identificateur de langue valide ; par exemple, 1033.

Local

Facultatif

System.Management.Automation.SwitchParameter

Désinstalle la solution du serveur actif.

Time

Facultatif

System.String

Spécifie le moment auquel la solution sera désinstallée. La valeur par défaut est un retrait immédiat.

Le type doit être une valeur DateTime valide, au format 2010,12,05.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à désinstaller.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de solution SharePoint valide (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

AllWebApplications

Requis

System.Management.Automation.SwitchParameter

Spécifie que la nouvelle solution SharePoint sera désinstallée pour toutes les applications Web SharePoint de la batterie.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Language

Facultatif

System.UInt32

Désinstalle le module linguistique de la langue spécifiée.

Le type doit être un identificateur de langue valide ; par exemple, 1033.

Local

Facultatif

System.Management.Automation.SwitchParameter

Désinstalle la solution du serveur actif.

Time

Facultatif

System.String

Spécifie le moment auquel la solution sera désinstallée. La valeur par défaut est un retrait immédiat.

Le type doit être une valeur DateTime valide, au format 2010,12,05.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Uninstall-SPSolution retire une solution SharePoint déployée en vue de sa suppression totale de la batterie. Cette applet de commande supprime les fichiers du serveur Web frontal. Utilisez l'applet de commande Remove-SPSolution pour supprimer le package de solution du magasin de solutions de la batterie ; veillez à utiliser l'applet de commande Remove-SPSolution uniquement après avoir exécuté Uninstall-SPSolution.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Uninstall-SPUserSolution -Identity contoso_solution.wsp

Cet exemple retire la solution SharePoint déployée contoso_solution.wsp.

Voir aussi

Référence

Get-SPSolution
Add-SPSolution
Update-SPSolution
Remove-SPSolution
Install-SPSolution
Remove-SPSolutionDeploymentLock

Historique des modifications


Update-SPSolution
Voir aussi Exemple
[image]

Met à niveau une solution SharePoint déployée.

Update-SPSolution [-Identity] <SPSolutionPipeBind> -LiteralPath <String> [-AssignmentCollection <SPAssignmentCollection>] [-CASPolicies <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-GACDeployment <SwitchParameter>] [-Local <SwitchParameter>] [-Time <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSolutionPipeBind

Spécifie la solution SharePoint à déployer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide de solution SharePoint (par exemple, SPSolution1) ou une instance d'un objet SPSolution valide.

LiteralPath

Requis

System.String

Spécifie le chemin d'accès au package de solution.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

CASPolicies

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les stratégies de sécurité d'accès du code (CAS) peuvent être déployées pour la nouvelle solution SharePoint.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force le déploiement de la nouvelle solution SharePoint.

GACDeployment

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que le Global Assembly Cache (GAC) peut être déployé pour la nouvelle solution SharePoint.

Local

Facultatif

System.Management.Automation.SwitchParameter

Déploie la solution sur l'ordinateur local uniquement.

Time

Facultatif

System.String

Spécifie quand la solution sera déployée. La valeur par défaut est immédiatement.

Le type doit être une valeur DateTime valide, au format 2010, 5, 1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Install-SPSolution met à niveau une solution SharePoint déployée dans la batterie de serveurs. Utilisez cette applet de commande uniquement si une nouvelle solution contient le même ensemble de fichiers et de fonctionnalités que la solution déployée. Si les fichiers et fonctionnalités diffèrent, la solution doit être retirée et redéployées via les applets de commande Uninstall-SPSolution et Install-SPSolution, respectivement.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Update-SPSolution -Identity contoso_solution.wsp -LiteralPath c:\contoso_solution_v2.wsp -GACDeployment

Cet exemple met à niveau la solution SharePoint contoso_solution.wsp déployée vers la solution c:\contoso_solution_v2.wsp.

Voir aussi

Référence

Get-SPSolution
Add-SPSolution
Uninstall-SPSolution
Remove-SPSolution
Install-SPSolution
Remove-SPSolutionDeploymentLock

Historique des modifications

Date | Description | Raison
2011/01/24 | 2011/01/24 | Mise à jour du contenu


Update-SPUserSolution
Voir aussi Exemple
[image]

Met à niveau une solution de type sandbox activée dans une batterie.

Update-SPUserSolution [-Identity] <SPUserSolutionPipeBind> -Site <SPSitePipeBind> -ToSolution <SPUserSolutionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUserSolutionPipeBind

Spécifie la solution de type sandbox à mettre à niveau.

Le type doit être un nom valide de solution en mode bac à sable (par exemple, UserSolution1), ou une instance d'un objet SPUserSolution valide.

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Met à niveau la solution de type sandbox de la collection de sites spécifiée.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide, au format http://server_name, ou une instance d'un objet SPSite valide.

ToSolution

Requis

Microsoft.SharePoint.PowerShell.SPUserSolutionPipeBind

Spécifie la solution de type sandbox vers laquelle mettre à niveau.

Le type doit être un nom valide de solution en mode bac à sable (par exemple, UserSolution1), ou une instance d'un objet SPUserSolution valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Update-SPUserSolution met à niveau une solution de type sandbox ayant déjà été activée dans une batterie. Une solution d'utilisateur est une solution de type sandbox. Avant d'utiliser cette applet de commande pour mettre à niveau la solution activée, utilisez l'applet de commande Add-SPUserSolution pour télécharger la solution mise à niveau dans la galerie de solutions.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE---------------------
Code de copie
Update-SPUserSolution -Identity contoso_solution.wsp -Site http://sitename -ToSolution contoso_solution_v2.wsp

Cet exemple met à niveau la solution de type sandbox contoso_solution.wsp du site http://sitename vers la solution contoso_solution_v2.wsp.

Voir aussi

Référence

Install-SPUserSolution
Uninstall-SPUserSolution
Remove-SPUserSolution
Get-SPUserSolution
Add-SPUserSolution

Historique des modifications


Applets de commande générales (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour l'administration générale d'une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Copy-SPBusinessDataCatalogAclToChildren

Disable-SPBusinessDataCatalogEntity

Enable-SPBusinessDataCatalogEntity

Export-SPBusinessDataCatalogModel

Get-SPAlternateURL

Get-SPBrowserCustomerExperienceImprovementProgram

Get-SPBusinessDataCatalogMetadataObject

Get-SPCustomLayoutsPage

Get-SPFarmConfig

Get-SPHelpCollection

Get-SPMobileMessagingAccount

Get-SPProcessAccount

Get-SPWebPartPack

Get-SPWebTemplate

Grant-SPBusinessDataCatalogMetadataObject

Import-SPBusinessDataCatalogModel

Initialize-SPResourceSecurity

Install-SPApplication

Install-SPHelpCollection

Install-SPWebPartPack

Install-SPWebTemplate

Merge-SPLogFile

Move-SPBlobStorageLocation

New-SPAlternateUrl

New-SPBusinessDataCatalogServiceApplication

New-SPBusinessDataCatalogServiceApplicationProxy

New-SPCentralAdministration

New-SPLogFile

New-SPUsageLogFile

Remove-SPAlternateUrl

Remove-SPBusinessDataCatalogModel

Revoke-SPBusinessDataCatalogMetadataObject

Set-SPAlternateUrl

Set-SPBrowserCustomerExperienceImprovementProgram

Set-SPBusinessDataCatalogMetadataObject

Set-SPBusinessDataCatalogServiceApplication

Set-SPBusinessDataCatalogThrottleConfig

Set-SPCentralAdministration

Set-SPCustomLayoutsPage

Set-SPFarmConfig

Set-SPMobileMessagingAccount

Set-SPPassPhrase

Set-SPWebTemplate

Start-SPAdminJob

Start-SPAssignment

Stop-SPAssignment

Uninstall-SPHelpCollection

Uninstall-SPWebPartPack

Uninstall-SPWebTemplate

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Get-SPBrowserCustomerExperienceImprovementProgram
Voir aussi Exemple
[image]

Renvoie l'état de l'abonnement actuel pour le Programme d'amélioration du produit du navigateur.

Get-SPBrowserCustomerExperienceImprovementProgram -Farm <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPBrowserCustomerExperienceImprovementProgram -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPBrowserCustomerExperienceImprovementProgram -SiteSubscription <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Farm

Requis

System.Management.Automation.SwitchParameter

Spécifie que l'état de l'abonnement pour la batterie est renvoyé par cette applet de commande.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Renvoie l'état de l'abonnement pour l'application Web SharePoint spécifiée.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

3

Paramètre

Requis

Type

Description

SiteSubscription

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Renvoie l'état de l'abonnement pour l'abonnement au site spécifié.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'abonnement au site valide (par exemple, SiteSubscription1), ou une instance d'un objet SiteSubscription valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPBrowserCustomerExperienceImprovementProgram lit l'état de l'abonnement actuel pour le Programme d'amélioration du produit du navigateur.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Get-SPBrowserCustomerExperienceImprovementProgram -WebApplication http://WebAppexample1

Cet exemple renvoie l'état de l'abonnement actuel au Programme d'amélioration du produit pour l'application Web WebAppexample1.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPSiteSubscription http://SiteSubscription1 | Get- SPBrowserCustomerExperienceImprovementProgram

L'exemple suivant renvoie l'état de l'abonnement au Programme d'amélioration du produit pour l'abonnement au site SiteSubscription1.

Voir aussi

Référence

Set-SPBrowserCustomerExperienceImprovementProgram

Historique des modifications


Get-SPHelpCollection
Voir aussi Exemple
[image]

Renvoie les fichiers de la collection d'aide.

Get-SPHelpCollection [-AssignmentCollection <SPAssignmentCollection>] [-Name <String>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Name

Facultatif

System.String

Spécifie le nom des fichiers de la collection d'aide à récupérer.

Le type doit être un nom de dossier de collection d'aide valide, par exemple HelpDocs1.

Description détaillée

L'applet de commande Get-SPHelpCollection lit les fichiers de la collection d'aide spécifiés. Si le paramètre Name n'est pas spécifié, l'applet de commande renvoie tous les fichiers de la collection d'aide installés.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPHelpCollection

Cet exemple obtient tous les fichiers de collection d'aide installés.

Voir aussi

Référence

Install-SPHelpCollection
Uninstall-SPHelpCollection

Historique des modifications


Install-SPHelpCollection
Voir aussi Exemple
[image]

Installe les fichiers de la collection de sites de l'aide fournis dans la batterie actuelle.

Install-SPHelpCollection -LiteralPath <String> [-AssignmentCollection <SPAssignmentCollection>]
Install-SPHelpCollection -All <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

LiteralPath

Facultatif

System.String

Spécifie le chemin d'accès exact à un fichier d'aide personnalisé spécifique dans le fichier CAB de la collection de sites de l'aide.

Le type doit être un chemin d'accès valide dans l'un des formats suivants :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

All

Requis

System.Management.Automation.SwitchParameter

Si le paramètre LiteralPath n'est pas spécifié, indique que tous les fichiers CAB de collection d'aide figurant dans le dossier %Program Files%\Common Files\Microsoft Shared\Web Server Extensions\14\HCCab\<LCID> de la collection de sites de l'aide sont installés et que les collections d'aide existantes sont remplacées.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Install-SPHelpCollection installe les fichiers de la collection de sites de l'aide pour les produits SharePoint 2010 dans la batterie de serveurs actuelle. Utilisez le paramètre LiteralPath pour installer des fichiers de collection d'aide personnalisés. Si le paramètre LiteralPath n'est pas spécifié, toute l'aide disponible dans la collection de sites de l'aide est installée et les fichiers de la collection d'aide sont remplacés.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Install-SPHelpCollection -LiteralPath 'C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\HCCab\1033\OSSAdmin.cab'

Cet exemple installe la collection d'aide spécifiée dans la batterie de serveurs actuelle.

Voir aussi

Référence

Get-SPHelpCollection
Uninstall-SPHelpCollection

Historique des modifications


Set-SPBrowserCustomerExperienceImprovementProgram
Voir aussi Exemple
[image]

Active ou désactive le Programme d'amélioration du produit.

Set-SPBrowserCustomerExperienceImprovementProgram -Farm <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Enable <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Set-SPBrowserCustomerExperienceImprovementProgram -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Enable <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Set-SPBrowserCustomerExperienceImprovementProgram -SiteSubscription <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Enable <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Farm

Requis

System.Management.Automation.SwitchParameter

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Enable

Facultatif

System.Management.Automation.SwitchParameter

Active le Programme d'amélioration du produit du navigateur. La valeur par défaut est True.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Définit l'état de l'abonnement au Programme d'amélioration du produit pour l'application Web SharePoint spécifiée.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Enable

Facultatif

System.Management.Automation.SwitchParameter

Active le Programme d'amélioration du produit du navigateur. La valeur par défaut est True.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

SiteSubscription

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Définit l'état de l'abonnement au Programme d'amélioration du produit pour l'abonnement au site spécifié.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'abonnement au site valide (par exemple, SiteSubscription1), ou une instance d'un objet SiteSubscription valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Enable

Facultatif

System.Management.Automation.SwitchParameter

Active le Programme d'amélioration du produit du navigateur. La valeur par défaut est True.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPBrowserCustomerExperienceImprovementProgram active ou désactive le Programme d'amélioration du produit du navigateur pour la collecte des critères qualité pour les logiciels.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Set-SPBrowserCustomerExperienceImprovementProgram -Farm -Enable

Cet exemple active le Programme d'amélioration du produit du navigateur pour la batterie.

------------------EXEMPLE 2-----------------------
Code de copie
Set-SPBrowserCustomerExperienceImprovementProgram -Farm -Enable:$False

Cet exemple désactive le Programme d'amélioration du produit du navigateur pour la batterie.

------------------EXEMPLE 3-----------------------
Code de copie
Set-SPWebApplication http://MyOfficeApp1 | Get- SPBrowserCustomerExperienceImprovementProgram -Enable

Cet exemple active le Programme d'amélioration du produit du navigateur pour l'application Web MyOfficeApp1.

Voir aussi

Référence

Get-SPBrowserCustomerExperienceImprovementProgram

Historique des modifications


Start-SPAssignment
Voir aussi Exemple
[image]

Lance un nouveau stockage d'affectations.

Start-SPAssignment [-AssignmentCollection <SPAssignmentCollection>] [-Global <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Global

Facultatif

System.Management.Automation.SwitchParameter

Si vous utilisez ce paramètre, tous les objets sont affectés à la durée du script et sont éliminés lorsque l'applet de commande Stop-SPAssignment est appelée.

Si vous n'utilisez pas ce paramètre, vous devez affecter le résultat de l'applet de commande à une variable et ensuite éliminer les objets en utilisant le paramètre Identity de l'applet de commande Stop-SPAssignment.

Description détaillée

L'applet de commande Start-SPAssignment élimine les objets utilisés avec des affectations de variables.

L'utilisation d'objets SPWeb, SPSite ou SPSiteAdminsitration nécessite généralement d'importants volumes de mémoire. L'utilisation de ces objets, ou de listes de ces objets, dans les scripts Windows PowerShell requiert dès lors une gestion adéquate de la mémoire. Par défaut, toutes les commandes Get éliminent ces objets immédiatement au terme du pipeline, mais vous pouvez utiliser SPAssignment pour affecter la liste des objets à une variable et éliminer les objets lorsqu'ils sont devenus inutiles. Vous pouvez également vous assurer que les objets restent tant que vous en avez besoin, même pour plusieurs itérations de commandes.

Il existe trois niveaux d'affectation :

-- No assignment : l'objet n'est pas affecté à une variable et est éliminé après chaque itération de la commande.

-- Simple assignment : tous les objets sont affectés au stockage d'affectations global. Pour cela, utilisez le paramètre Global. Lorsque vous utilisez ce niveau, tous les objets sont affectés à un stockage global et sont éliminés à l'appel de la commande Stop-SPAssignment.

-- Advanced assignment : les objets sont affectés à des stockages nommés en vue de leur élimination. Pour éliminer des objets, utilisez le paramètre Identity avec l'applet de commande Stop-SPAssignment.

Remarque :
À la fermeture de l'instance d'exécution de PowerShell, tous les objets sont éliminés indépendamment du niveau d'affectation utilisé.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

SPAssignmentCollection

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Start-SPAssignment -global
Code de copie
$w = Get-SPWeb http://MyWeb
Code de copie
$w | Set-SPWeb -title "Accounting"
Code de copie
Stop-SPAssignment -global

Cet exemple utilise l'affectation simple. Bien que celle-ci soit plus facile à utiliser, il est déconseillé d'exécuter des commandes qui s'itèrent sur plusieurs objets SPSite ou SPWeb avec ce type d'affectation. Assurez-vous que Stop-SPAssignment est exécuté avant de tenter d'autres itérations de plusieurs objets.

------------------EXEMPLE 2-----------------------
Code de copie
$gc = Start-SPAssignment
Code de copie
$web = $gc | Get-SPWeb http://MyWeb
Code de copie
$web | Set-SPWeb -title "Accounting"
Code de copie
Stop-SPAssignment -Identity $gc

Cet exemple définit le titre de l'objet SPWeb dans plusieurs lignes et contrôle la fréquence d'élimination. Il s'agit d'un exemple avancé, préférablement réservé aux développeurs.

Voir aussi

Référence

Stop-SPAssignment

Historique des modifications


Stop-SPAssignment
Voir aussi Exemple
[image]

Élimine les objets de la collection d'attributions fournie.

Stop-SPAssignment [[-SemiGlobal] <SPAssignmentCollection>] [-AssignmentCollection <SPAssignmentCollection>] [-Global <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

SemiGlobal

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentColletion

Fournit le collectionneur d'attributions duquel éliminer les objets.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Global

Facultatif

System.Management.Automation.SwitchParameter

Arrête le stockage des objets par le collectionneur d'attributions global et élimine tout objet que ce dernier contient.

Description détaillée

L'applet de commande Stop-SPAssignment élimine les objets de la collection d'attributions fournie. Utilisez le paramètre Global pour éliminer tous les objets du collectionneur d'attributions global et arrêter la collection d'objets supplémentaires par le magasin global. Fournissez un collectionneur d'attributions SemiGlobal pour éliminer tous les objets contenus.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Start-SPAssignment -global
Code de copie
$w = Get-SPWeb http://MyWeb
Code de copie
$w | Set-SPWeb -title "Accounting"
Code de copie
Stop-SPAssignment -global

Cet exemple utilise l'affectation simple. Bien que celle-ci soit plus facile à utiliser, il est déconseillé d'exécuter des commandes qui s'itèrent sur plusieurs objets SPSite ou SPWeb avec ce type d'affectation. Assurez-vous que Stop-SPAssignment est exécuté avant de tenter d'autres itérations de plusieurs objets.

Voir aussi

Référence

Start-SPAssignment

Historique des modifications


Uninstall-SPHelpCollection
Voir aussi Exemple
[image]

Supprime les fichiers de la collection d'aide.

Uninstall-SPHelpCollection -Name <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Name

Requis

System.String

Spécifie le nom des fichiers de la collection d'aide à désinstaller.

Le type doit être un nom de collection d'aide valide, par exemple HelpDocs1.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Uninstall-SPHelpCollection supprime les fichiers spécifiés de la collection d'aide de la bibliothèque d'aide du produit dans la batterie de serveurs actuelle.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Uninstall-SPHelpCollection - Name "OSSAdmin.1033"

Cet exemple désinstalle une collection d'aide. Le nom de dossier de la collection d'aide à désinstaller est OSSAdmin.1033.

Voir aussi

Référence

Get-SPHelpCollection
Install-SPHelpCollection

Historique des modifications


Applets de commande pour l'importation et l'exportation (SharePoint Foundation 2010)

Vous pouvez utiliser Windows PowerShell pour importer ou exporter une collection de sites, une application Web, une liste ou une bibliothèque.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Import-SPWeb

Export-SPWeb

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Import-SPWeb
Voir aussi Exemple
[image]

Importe une collection de sites, une application Web, une liste ou une bibliothèque.

Import-SPWeb [-Identity] <SPWebPipeBind> -Path <String> [-ActivateSolutions <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-HaltOnError <SwitchParameter>] [-HaltOnWarning <SwitchParameter>] [-IncludeUserCustomAction <None | All>] [-IncludeUserSecurity <SwitchParameter>] [-NoFileCompression <SwitchParameter>] [-NoLogFile <SwitchParameter>] [-UpdateVersions <Append | Overwrite | Ignore>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie l'URL ou le GUID du site Web d'importation.

Le type doit être une URL, un GUID ou un objet valide. Par exemple, une URL valide au format http://server_name, ou un GUID au format 1234-4567-5678a.

Path

Requis

System.String

Indique le nom du fichier d'importation.

Si vous utilisez le paramètre NoFileCompression, vous devez spécifier un répertoire. Dans le cas contraire, tous les formats de fichiers sont valides.

ActivateSolutions

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si des solutions utilisateur sont activées durant l'importation.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force le remplacement du package d'exportation s'il existe déjà.

Le type doit être l'une des valeurs suivantes :

-True

-False

La valeur par défaut est False.

HaltOnError

Facultatif

System.Management.Automation.SwitchParameter

Interrompt le processus d'importation en cas d'erreur.

HaltOnWarning

Facultatif

System.Management.Automation.SwitchParameter

Interrompt le processus d'importation en cas d'avertissement.

IncludeUserCustomAction

Facultatif

Microsoft.SharePoint.Deployment.SPIncludeUserCustomAction

Spécifie si les actions personnalisées de l'utilisateur sont incluses durant l'importation.

IncludeUserSecurity

Facultatif

System.Management.Automation.SwitchParameter

Conserve les paramètres de sécurité de l'utilisateur.

NoFileCompression

Facultatif

System.Management.Automation.SwitchParameter

Active ou désactive la compression des fichiers dans le package d'importation. Le package d'importation est stocké dans le dossier spécifié par le paramètre Path ou Identity. Pour des raisons de performances, il est recommandé d'utiliser ce paramètre. L'activation de la compression peut allonger la durée du processus d'importation d'environ 30 pour cent.

NoLogFile

Facultatif

System.Management.Automation.SwitchParameter

Empêche la génération d'un fichier journal d'importation. Si ce paramètre n'est pas spécifié, l'applet de commande Import-SPWeb génère un fichier journal d'exportation au même emplacement que le package d'exportation. Le fichier journal utilise le service de journalisation unifiée (ULS).

Nous vous recommandons d'utiliser ce paramètre. Cependant, pour des raisons de performances, il peut parfois être utile de ne pas générer de fichier journal.

UpdateVersions

Non

Microsoft.SharePoint.Deployment.SPUpdateVersions

Indique comment résoudre les situations où un fichier à importer dans un site existe déjà dans celui-ci. Si le paramètre UpdateVersions n'est pas spécifié, l'opération d'importation utilise par défaut la valeur 1.

Le type doit être l'un des suivants :

-Ajouter de nouvelles versions au fichier actuel

-Remplacer le fichier et toutes ses versions (supprimer puis insérer)

-Ignorer le fichier s'il existe sur la destination

La valeur par défaut est Add new versions to the current file.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Import-SPWeb importe une collection de sites, une application Web, une liste ou une bibliothèque. L'importation depuis une bibliothèque est une fonctionnalité nouvelle dans les produits SharePoint 2010.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE----------------------

Code de copie
Import-SPWeb http://site -Path export.cmp -UpdateVersions -Overwrite

Cet exemple importe le contenu du fichier export.cmp dans un site à l'adresse http://site et remplace le contenu avec version présent sur le site par le contenu du fichier export.cmp.

Voir aussi

Référence

Export-SPWeb
Get-SPWeb
New-SPWeb
Remove-SPWeb
Set-SPWeb

Historique des modifications


Export-SPWeb
Voir aussi Exemple
[image]

Exporte une collection de sites, une application Web, une liste ou une bibliothèque.

Export-SPWeb [-Identity] <SPWebPipeBind> -Path <String> [-AssignmentCollection <SPAssignmentCollection>] [-CompressionSize <Int32>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-HaltOnError <SwitchParameter>] [-HaltOnWarning <SwitchParameter>] [-IncludeUserSecurity <SwitchParameter>] [-IncludeVersions <LastMajor | CurrentVersion | LastMajorAndMinor | All>] [-ItemUrl <String>] [-NoFileCompression <SwitchParameter>] [-NoLogFile <SwitchParameter>] [-UseSqlSnapshot <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie l'URL ou le GUID du site Web à exporter.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de site Microsoft SharePoint Foundation 2010 valide (par exemple, MySPSite1) ou une instance d'un objet SPWeb valide.

Path

Requis

System.String

Indique le nom du fichier d'exportation.

Si vous utilisez le paramètre NoFileCompression, vous devez spécifier un répertoire. Dans le cas contraire, tous les formats de fichiers sont valides.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

CompressionSize

Facultatif

System.Int32

Définit la taille de fichier maximale des fichiers d'exportation compressés. Si la taille totale du package exporté est supérieure à cette taille, le package exporté sera fractionné en plusieurs fichiers.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force le remplacement du package d'exportation s'il existe déjà.

Le type doit être l'une des valeurs suivantes :

-True

-False

La valeur par défaut est False.

HaltOnError

Facultatif

System.Management.Automation.SwitchParameter

Interrompt le processus d'exportation en cas d'erreur.

HaltOnWarning

Facultatif

System.Management.Automation.SwitchParameter

Interrompt le processus d'exportation en cas d'avertissement.

IncludeUserSecurity

Facultatif

System.Management.Automation.SwitchParameter

Conserve les paramètres de sécurité de l'utilisateur.

IncludeVersions

Facultatif

Microsoft.SharePoint.Deployment.SPIncludeVersions

Indique le type d'historique de versions des fichiers et des éléments de liste à inclure dans l'opération d'exportation. Si le paramètre IncludeVersions n'est pas spécifié, l'applet de commande Export-SPWeb utilise par défaut la valeur 1.

Le type doit être l'une des versions suivantes :

-Dernière version principale des fichiers et des éléments de liste (par défaut)

-Version actuelle, qu'il s'agisse de la dernière version principale ou de la dernière version secondaire

-Dernière version principale et dernière version secondaire des fichiers et des éléments de liste

-Toutes les versions des fichiers et des éléments de liste

ItemUrl

Facultatif

System.string

Spécifie l'URL de l'application Web, le GUID ou l'objet à exporter.

Le type doit être une URL valide, par exemple http://server_name.

NoFileCompression

Facultatif

System.Management.Automation.SwitchParameter

Active ou désactive la compression des fichiers dans le package d'exportation. Le package d'exportation est stocké dans le dossier spécifié par le paramètre Path ou Identity. Pour des raisons de performances, il est recommandé d'utiliser ce paramètre. L'activation de la compression peut allonger la durée du processus d'exportation d'environ 30 pour cent.

NoLogFile

Facultatif

System.Management.Automation.SwitchParameter

Empêche la génération d'un fichier journal d'exportation. Si ce paramètre n'est pas spécifié, l'applet de commande Export-SPWeb génère un fichier journal d'exportation au même emplacement que le package d'exportation. Le fichier journal utilise le service de journalisation unifiée (ULS).

Il est recommandé d'utiliser ce paramètre. Cependant, pour des raisons de performances, il peut parfois être utile de ne pas générer de fichier journal.

UseSqlSnapshot

Facultatif

System.Management.Automation.SwitchParameter

Spécifie qu'un instantané de la base de données SQL sera créé au démarrage du processus d'exportation et que toutes les données exportées seront récupérées directement depuis l'instantané de la base de données. Cet instantané sera automatiquement supprimé au terme de l'exportation.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Export-SPWeb exporte une collection de sites, une application Web, une liste ou une bibliothèque. La possibilité d'exporter depuis une bibliothèque est une fonctionnalité nouvelle dans SharePoint 2010 Products.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE-----------------------.
Code de copie
Export-SPWeb http://site -Path "site export.cmp"

Cet exemple exporte le site de l'adresse http://site/ vers un fichier appelé site export.cmp dans le répertoire actif.

Voir aussi

Référence

Get-SPWeb
New-SPWeb
Set-SPWeb
Import-SPWeb
Remove-SPWeb

Historique des modifications


Applets de commande pour la journalisation et les événements (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour journaliser les événements système et effectuer des diagnostics.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Clear-SPLogLevel

Get-SPLogLevel

Set-SPLogLevel

Get-SPLogEvent

Get-SPDiagnosticConfig

Get-SPDiagnosticsProvider

Set-SPDiagnosticConfig

Set-SPDiagnosticsProvider

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Clear-SPLogLevel
Voir aussi Exemple
[image]

Réinitialise les niveaux d'enregistrement de suivi et des événements Windows à leurs valeurs par défaut.

Clear-SPLogLevel [-AssignmentCollection <SPAssignmentCollection>] [-Identity <String[]>] [-InputObject <PSObject>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Identity

Facultatif

System.String[]

Spécifie le ou les noms de la catégorie ou des ensembles de catégories pour lesquels définir la limite ; par exemple « Unified Logging Service ». Si le paramètre Identity n'est pas spécifié, le paramètre de limitation des événements est appliqué à toutes les catégories de la batterie.

Fournir une catégorie non valide est une erreur sans incidence qui est ignorée.

InputObject

Facultatif

System.Management.Automation.PSObject

Spécifie le résultat du paramètre InputObject à transférer. La valeur peut être une chaîne au format identique au paramètre Identity ou un objet SPDiagnosticsCategory. L'utilisateur peut extraire une ou plusieurs catégories de l'applet de commande Get-SPLogLevel, en modifier les valeurs et les transférer dans l'applet de commande Set-SPLogLevel.

Description détaillée

L'applet de commande Clear-SPLogLevel réinitialise les niveaux d'enregistrement de suivi et des événements Windows des catégories spécifiées à leurs valeurs par défaut. Si le paramètre Identity n'est pas spécifié, toutes les catégories sont affectées.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Clear-SPLogLevel -Identity Cat1

Cet exemple réinitialise les niveaux d'enregistrement d'une seule catégorie.

--------------EXEMPLE 2-----------------
Code de copie
"Cat1", "Cat2", "Cat3" | Clear-SPLogLevel

Cet exemple réinitialise les niveaux d'enregistrement de plusieurs catégories.

--------------EXEMPLE 3-----------------
Code de copie
Get-SPLogLevel | Clear-SPLogLevel

Cet exemple réinitialise les niveaux d'enregistrement de toutes les catégories.

Voir aussi

Référence

Get-SPLogLevel
Set-SPLogLevel

Historique des modifications


Get-SPLogLevel
Voir aussi Exemple
[image]

Renvoie une liste d'objets ou de niveaux de diagnostic.

Get-SPLogLevel [-AssignmentCollection <SPAssignmentCollection>] [-Identity <String[]>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Identity

Facultatif

System.String[]

Spécifie un nom de catégorie valide, par exemple Sauvegarde et restauration, ou Administration.

Description détaillée

L'applet de commande Get-SPLogLevel affiche une liste d'objets ou de niveaux de diagnostic en fonction des critères spécifiés. Si aucun paramètre n'est spécifié, une liste de tous les niveaux de diagnostic pour toutes les catégories est renvoyée.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Get-SPLogLevel

Cet exemple affiche les niveaux de limitation de toutes les catégories.

--------------EXEMPLE 2-----------------
Code de copie
Get-SPLogLevel -Identity "Category1"

Cet exemple affiche le niveau de limitation pour la catégorie Category1.

--------------EXEMPLE 3-----------------
Code de copie
"Cat1", "Cat2", "Cat3" | Get-SpLogLevel

Cet exemple affiche le niveau de limitation pour plusieurs catégories.

--------------EXEMPLE 4-----------------
Code de copie
Get-SPLogLevel -Identity "Area:*"

Cet exemple affiche le niveau de limitation pour toutes les catégories d'un domaine.

Voir aussi

Référence

Set-SPLogLevel
Clear-SPLogLevel

Historique des modifications


Set-SPLogLevel
Voir aussi Exemple
[image]

Définit le niveau de suivi et d'événement d'un ensemble de catégories.

Set-SPLogLevel [-AssignmentCollection <SPAssignmentCollection>] [-EventSeverity <String>] [-Identity <String[]>] [-InputObject <PSObject>] [-TraceSeverity <String>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

EventSeverity

Facultatif

System.String

Spécifie le niveau de catégorie à définir. Le niveau de catégorie peut avoir l'une des valeurs suivantes :

- None

- ErrorCritical

Error

- Warning

- Information

- Verbose

Identity

Facultatif

System.String[]

Spécifie le ou les noms de la catégorie ou de l'ensemble de catégories pour lesquels la limitation doit être définie, par exemple « Service de journalisation unifiée ». Si le paramètre Identity n'est pas spécifié, le paramètre de limitation des événements est appliqué à toutes les catégories de la batterie de serveurs.

InputObject

Facultatif

System.Management.Automation.PSObject

Le paramètre InputObject est mis en pipeline dans l'applet de commande et peut être une chaîne dans un format identique au paramètre Identity, ou un objet SPDiagnosticsCategory. L'utilisateur peut récupérer une ou plusieurs catégories à partir de l'applet de commande Get-SPLogLevel, modifier les valeurs de catégorie et ensuite les mettre en pipeline dans l'applet de commande Set-SPLogLevel.

TraceSeverity

Facultatif

System.String

Spécifie la limitation de trace à définir pour la ou les catégories spécifiées. Les fichiers journaux de suivi sont des fichiers texte écrits dans le chemin du journal de suivi qui est défini dans la page Paramètres de journalisation des diagnostics du site Web Administration centrale de SharePoint. Le type doit être l'une des valeurs suivantes :

- None (aucune trace n'est écrite dans le journal de suivi)

- Unexpected

- Monitorable

- High

- Medium

- Verbose

- VerboseEx

Description détaillée

L'applet de commande Set-SPLogLevel définit les niveaux de journalisation du suivi et des événements Windows pour une ou plusieurs catégories de journalisation de diagnostics inscrites dans la batterie de serveurs. Si une trace ou un événement associé à une catégorie se produit, mais à un niveau de gravité inférieur au niveau d'enregistrement de cette catégorie, il n'est pas inscrit dans le journal des événements ou dans le journal de suivi. Si une trace ou un événement associé à une catégorie se produit et qu'il est au moins aussi grave que le niveau d'enregistrement de cette catégorie, il est inscrit dans le journal des événements ou le journal de suivi.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
set-sploglevel -TraceSeverity Monitorable

Cet exemple définit les valeurs TraceSeverity de toutes les catégories sur Monitorable.

------------------EXEMPLE 2-----------------------
Code de copie
Set-SPLogLevel -TraceSeverity High -EventSeverity Warning -Identity "Cat1"

Cet exemple définit les valeurs EventSeverity et TraceSeverity pour une seule catégorie.

------------------EXEMPLE 3-----------------------
Code de copie
"Cat1", "Cat2", "Cat3" | Set-SPLogLevel -EventSeverity Error

Cet exemple définit les valeurs EventSeverity pour plusieurs catégories.

------------------EXEMPLE 4-----------------------
Code de copie
Set-SPLogLevel -EventSeverity Warning -Identity "AreaName:*"

Cet exemple définit les valeurs EventSeverity pour toutes les catégories de la même zone.

Voir aussi

Référence

Get-SPLogLevel
Clear-SPLogLevel

Historique des modifications


Get-SPLogEvent
Voir aussi Exemple
[image]

Renvoie les résultats d'un journal de suivi ULS (Service de journalisation unifiée).

Get-SPLogEvent [-AssignmentCollection <SPAssignmentCollection>] [-AsString <SwitchParameter>] [-ContextKey <String[]>] [-Directory <String>] [-EndTime <DateTime>] [-MinimumLevel <String>] [-StartTime <DateTime>]
Get-SPLogEvent [-AssignmentCollection <SPAssignmentCollection>] [-AsString <SwitchParameter>] [-ContextKey <String[]>] [-EndTime <DateTime>] [-File <String>] [-MinimumLevel <String>] [-StartTime <DateTime>]

Paramètres

1

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentColletion

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AsString

Facultatif

System.Management.Automation.SwitchParameter

Renvoie chaque enregistrement sous la forme d'une chaîne distincte.

ContextKey

Facultatif

System.String[]

Spécifie que les données de contexte doivent être ajoutées aux résultats pour les clés de contexte spécifiées, par exemple : -ContextKey @("NomUtilisateur", "NomSite").

Directory

Facultatif

System.String

Donne la liste des fichiers journaux d'un autre répertoire (tout répertoire autre que le répertoire LogLocation configuré).

MinimumLevel

Facultatif

System.String

Renvoie les enregistrements équivalents ou supérieurs au niveau spécifié. Les valeurs valides sont Error ou Warning.

EndTime

Facultatif

System.DateTime

Le type doit être un format date et heure valide dépendant de la culture de la langue d'administration. Par exemple 16/02/2007 12:15:12 pour Français-France.

StartTime

Facultatif

System.DateTime

Le type doit être un format date et heure valide dépendant de la culture de la langue d'administration. Par exemple 16/02/2007 12:15:12 pour Français-France.

2

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentColletion

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AsString

Facultatif

System.Management.Automation.SwitchParameter

Renvoie chaque enregistrement sous la forme d'une chaîne distincte.

ContextKey

Facultatif

System.String[]

Spécifie que les données de contexte doivent être ajoutées aux résultats pour les clés de contexte spécifiées, par exemple : -ContextKey @("NomUtilisateur", "NomSite").

MinimumLevel

Facultatif

System.String

Renvoie les enregistrements équivalents ou supérieurs au niveau spécifié. Les valeurs valides sont Error ou Warning.

EndTime

Facultatif

System.DateTime

Le type doit être un format date et heure valide dépendant de la culture de la langue d'administration. Par exemple 16/02/2007 12:15:12 pour Français-France.

File

Facultatif

System.String

Spécifie un fichier spécifique à partir duquel demander des enregistrements.

StartTime

Facultatif

System.DateTime

Le type doit être un format date et heure valide dépendant de la culture de la langue d'administration. Par exemple 16/02/2007 12:15:12 pour Français-France.

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Get-SPLogEvent renvoie les enregistrements d'un fichier journal de suivi ULS correspondants aux critères. Si aucun paramètre n'est spécifié, tous les enregistrements de tous les fichiers journaux sont renvoyés. Utilisez les paramètres StartTime et EndTime pour appliquer un filtre sur un intervalle de temps. Nous recommandons l'utilisation de ces paramètres pour optimiser les performances de cette applet de commande.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Get-SPLogEvent -MinimumLevel "Warning"

Cet exemple renvoie toutes les entrées de journal provenant du répertoire de journaux par défaut correspondant à un avertissement ou à un état plus sévère.

--------------EXEMPLE 2-----------------
Code de copie
Get-SPLogEvent -Directory "C:\Logs" | Where-Object {$_.Level -eq "Warning"}

Cet exemple renvoie toutes les entrées d'avertissement des fichiers journaux du répertoire C:\Logs.

--------------EXEMPLE 3-----------------
Code de copie
Get-SPLogEvent -StartTime "12/04/2007 17:00" -EndTime "12/04/2007 18:00"

Cet exemple renvoie les entrées d'erreur survenues au cours d'un intervalle de temps, et il est propre aux États-Unis.

--------------EXEMPLE 4-----------------
Code de copie
Get-SPLogEvent -ContextKey @("UserName" ,"SiteName")

Cet exemple renvoie le contenu du dernier fichier journal et ajoute les données clés de contexte spécifiées.

--------------EXEMPLE 5-----------------
Code de copie
Get-SPLogEvent | Where-Object {$_.Level -eq "Error" -and {$_.Area -eq "SharePoint Foundation "}

Cet exemple renvoie toutes les entrées d'erreur relatives à SharePoint Foundation.

--------------EXEMPLE 6-----------------
Code de copie
Get-SPLogEvent -ContextKey @("Name") | %{$_.ToString() + "'t" + $_.Context["Name"]}

Cet exemple renvoie le contenu du fichier journal et ajoute des données de contexte.

Voir aussi

Référence

New-SPLogFile
Get-SPLogLevel

Historique des modifications


Get-SPDiagnosticConfig
Voir aussi Exemple
[image]

Récupère les valeurs de configuration des diagnostics ULS de la batterie.

Get-SPDiagnosticConfig [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPDiagnoticConfig récupère les valeurs de configuration des diagnostics ULS de la batterie.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPDiagnosticConfig

Cet exemple renvoie toutes les valeurs de configuration de diagnostics.

Voir aussi

Référence

Set-SPDiagnosticConfig

Historique des modifications


Get-SPDiagnosticsProvider
Voir aussi Exemple
[image]

Renvoie un fournisseur de diagnostics.

Get-SPDiagnosticsProvider [[-Identity] <SPDiagnosticsProviderPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPDiagnosticsProviderPipeBind

Spécifie le fournisseur de diagnostics à récupérer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur de diagnostics valide (par exemple, DiagnosticsProv1) ou une instance d'un objet SPDiagnosticsProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPDiagnosticsProvider lit le fournisseur de diagnostics spécifié. Si le paramètre Identity n'est pas spécifié, cette applet de commande renvoie les fournisseurs de diagnostics de la collection dans la batterie.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Get-SPDiagnosticsProvider

Cet exemple renvoie tous les fournisseurs de diagnostics dans la batterie.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPDiagnosticsProvider job-diagnostics-event-log-provider

Cet exemple renvoie le fournisseur de diagnostics du journal d'événements.

Voir aussi

Référence

Set-SPDiagnosticsProvider

Historique des modifications


Merge-SPLogFile
Voir aussi Exemple
[image]

Regroupe les entrées du journal de suivi de tous les ordinateurs d'une batterie de serveurs dans un seul fichier journal sur l'ordinateur local.

Merge-SPLogFile -Path <String> [-Area <String[]>] [-AssignmentCollection <SPAssignmentCollection>] [-Category <String[]>] [-ContextFilter <String[]>] [-Correlation <Guid[]>] [-EndTime <DateTime>] [-EventID <String[]>] [-ExcludeNestedCorrelation <SwitchParameter>] [-Level <String>] [-Message <String[]>] [-Overwrite <SwitchParameter>] [-Process <String[]>] [-StartTime <DateTime>] [-ThreadID <UInt32[]>]

Paramètres

Paramètre Requis Type Description

Path

Requis

System.String

Spécifie le chemin d'accès et le nom de fichier pour l'écriture du fichier journal fusionné. Les chemins d'accès relatifs sont pris en charge.

Area

Facultatif

System.String[]

Spécifie le nom de la zone à filtrer.

Le type doit être un nom valide, par exemple SharePoint Foundation.

L'utilisation de caractères génériques est prise en charge.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Category

Facultatif

System.String[]

Spécifie l'ID de catégorie sur lequel porte le filtrage.

Le type doit être un nom de catégorie valide, par exemple category1.

L'utilisation de caractères génériques est prise en charge.

ContextFilter

Facultatif

System.String[]

Spécifie un filtre pour les entrées de suivi dans un contexte particulier au format clé=valeur, par exemple user=contoso\joeuser.

Correlation

Facultatif

System.Guid[]

Spécifie l'ID de corrélation sur lequel porte le filtrage. Le type doit être un GUID valide au format F0BB0790-4323-A153-096F-ABCDC80E24D4.

EndTime

Facultatif

System.DateTime

Spécifie l'heure de fin des entrées du journal renvoyées.

Le type doit être un format date et heure valide dépendant de la culture de la langue d'administration. Par exemple 2/16/2007 12:15:12 pour Anglais-US.

EventID

Facultatif

System.String[]

Spécifie l'ID d'événement sur lequel porte le filtrage. L'utilisation de caractères génériques est prise en charge.

ExcludeNestedCorrelation

Facultatif

System.Management.Automation.SwitchParameter

Exclut les valeurs de corrélation imbriquées dans les résultats. Ce paramètre n'est utilisé que pour le filtrage des résultats avec le paramètre ContextFilter.

Par défaut, les enregistrements renvoyés par le paramètre ContextFilter comprennent tous les enregistrements liés ainsi que tous les enregistrements qui correspondent au filtre. Lorsque vous spécifiez cette option, seuls les enregistrements qui correspondent au filtre sont inclus, les enregistrements liés étant exclus.

Level

Facultatif

System.String

Spécifie le nom du niveau sur lequel porte le filtrage.

Les résultats comprennent le niveau spécifié et tout élément de gravité supérieure.

Message

Facultatif

System.String[]

Spécifie le texte du message sur lequel porte le filtrage.

Le type doit être du texte valide. Le texte avec espaces doit être placé entre guillemets, par exemple "Ceci est un test".

L'utilisation de caractères génériques est prise en charge.

Overwrite

Non

System.Management.Automation.SwitchParameter

Remplace le fichier journal s'il existe déjà sous le chemin d'accès spécifié.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $False.

Process

Facultatif

System.String[]

Spécifie le nom du processus sur lequel porte le filtrage.

L'utilisation de caractères génériques est prise en charge.

StartTime

Facultatif

System.DateTime

Spécifie l'heure de début des entrées du journal renvoyées.

Le type doit être un format date et heure valide dépendant de la culture de la langue d'administration. Par exemple 2/16/2007 12:15:12 pour Anglais-US.

La valeur par défaut est une heure avant l'heure actuelle sur l'ordinateur local.

ThreadID

Facultatif

System.UInt32[]

Spécifie l'ID du thread sur lequel porte le filtrage.

Le type doit être un entier valide compris entre 0 et 4 294 967 295.

Description détaillée

L'applet de commande Merge-SPLogFile renvoie les enregistrements des fichiers journaux de suivi ULS (Unified Logging Service) de chaque serveur de la batterie de serveurs correspondant aux critères, et écrit les résultats dans un nouveau fichier journal sur l'ordinateur local. Si aucun résultat n'est renvoyé, un avertissement s'affiche dans la fenêtre de la console Windows PowerShell.

Pour des performances optimales de cette applet de commande, il est recommandé de filtrer sur la plage de temps avec les paramètres StartTime et EndTime. Certains paramètres de filtrage tels que Process, Area, Category, EventID et Message prennent en charge les caractères génériques.

Pour en savoir plus sur les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Merge-SPLogFile -Path "C:\Logs\FarmMergedLog.log" -Overwrite

Cet exemple fusionne la dernière heure des données du journal de tous les ordinateurs de la batterie de serveurs sans filtrage.

--------------EXEMPLE 2-----------------
Code de copie
Merge-SPLogFile -Path "C:\Logs\FarmMergedLog.log" -Overwrite -Area Search

Cet exemple fusionne la dernière heure des données du journal de la zone Search.

--------------EXEMPLE 3-----------------
Code de copie
Merge-SPLogFile -Path "C:\Logs\FarmMergedLog.log" -Overwrite -Area "SharePoint Foundation","Web Analytics Services"

Cet exemple fusionne la dernière heure des données du journal des zones SharePoint Foundation et Web Analytics Services.

--------------EXEMPLE 4-----------------
Code de copie
Merge-SPLogFile -Path "C:\Logs\FarmMergedLog.log" -Overwrite -Level High

Cet exemple fusionne les données du journal de niveau High ou supérieur.

--------------EXEMPLE 5-----------------
Code de copie
Merge-SPLogFile -Path "C:\Logs\FarmMergedLog.log" -Overwrite -StartTime "06/09/2008 16:00" - EndTime "06/09/2008 16:15"

Cet exemple fusionne les données du journal pour les événements d'une plage de temps donnée, qui est spécifique à la culture des États-Unis.

--------------EXEMPLE 6-----------------
Code de copie
Merge-SPLogFile -Path "C:\Logs\FarmMergedLog.log" -Overwrite -Message "*permission changed*"

Cet exemple fusionne les données du journal pour les événements comportant permission changed dans le texte du message.

--------------EXEMPLE 7-----------------
Code de copie
Merge-SPLogFile -Overwrite -Path d:\1.log -ContextFilter "name=timer job*" -Area "*search*"

Cet exemple fusionne les données du journal pour tous les travaux de recherche du minuteur.

--------------EXEMPLE 8-----------------
Code de copie
Merge-SPLogFile -Overwrite -Path d:\2.log -ContextFilter "user=contoso?joeuser"

Cet exemple montre comment fusionner les données du journal pour tous les noms d'utilisateurs qui présentent le format contoso\joeuser ou Contoso/joeuser.

Voir aussi

Référence

New-SPLogFile

Historique des modifications


New-SPLogFile
Voir aussi Exemple
[image]

Crée un nouveau fichier journal.

New-SPLogFile [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPLogFile met fin au fichier journal actuel et en démarre un nouveau.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
New-SPLogFile

Cet exemple met fin au fichier journal actuel et en démarre un nouveau.

Voir aussi

Référence

Merge-SPLogFile

Historique des modifications


New-SPUsageLogFile
Exemple
[image]

Démarre un nouveau fichier journal d'utilisation sur le serveur actif.

New-SPUsageLogFile [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPUsageLogFile démarre un nouveau fichier journal d'utilisation sur le serveur actif. Les données d'utilisation en mémoire sont envoyées au fichier journal d'utilisation actif avant la création du nouveau fichier journal.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE-------------------
Code de copie
New-SPUsageLogFile

Cet exemple termine le fichier journal d'utilisation actif et en crée un nouveau.

Historique des modifications


Set-SPDiagnosticConfig
Voir aussi Exemple
[image]

Définit les paramètres de configuration du diagnostic sur la batterie de serveurs.

Set-SPDiagnosticConfig [-AllowLegacyTraceProviders <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-CustomerExperienceImprovementProgramEnabled <SwitchParameter>] [-DaysToKeepLogs <Int32>] [-DownloadErrorReportingUpdatesEnabled <SwitchParameter>] [-ErrorReportingAutomaticUploadEnabled <SwitchParameter>] [-ErrorReportingEnabled <SwitchParameter>] [-EventLogFloodProtectionEnabled <SwitchParameter>] [-EventLogFloodProtectionNotifyInterval <Int32>] [-EventLogFloodProtectionQuietPeriod <Int32>] [-EventLogFloodProtectionThreshold <Int32>] [-EventLogFloodProtectionTriggerPeriod <Int32>] [-InputObject <PSObject>] [-LogCutInterval <Int32>] [-LogDiskSpaceUsageGB <Int32>] [-LogLocation <String>] [-LogMaxDiskSpaceUsageEnabled <SwitchParameter>] [-ScriptErrorReportingDelay <Int32>] [-ScriptErrorReportingEnabled <SwitchParameter>] [-ScriptErrorReportingRequireAuth <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

AllowLegacyTraceProviders

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que les fournisseurs de trace générés pour les versions antérieures des produits et technologies SharePoint peuvent écrire dans la session de suivi pour les produits SharePoint 2010.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

CustomerExperienceImprovementProgramEnabled

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si la participation au Programme d'amélioration du produit est activée.

Le Programme d'amélioration du produit est conçu pour améliorer la qualité, la fiabilité et les performances des produits et technologies Microsoft. Avec votre autorisation, des informations anonymes concernant votre serveur sont envoyées à Microsoft en vue d'améliorer les produits et technologies SharePoint.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $True.

DaysToKeepLogs

Facultatif

System.Int32

Spécifie le nombre de jours de conservation des fichiers journaux de suivi. Le type doit être un nombre valide compris entre 1 et 366. La valeur par défaut est 14 jours.

DownloadErrorReportingUpdatesEnabled

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si le fichier de contrôle à distance des rapports d'erreur est téléchargé.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $True.

ErrorReportingAutomaticUploadEnabled

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si les rapports d'erreur sont téléchargés automatiquement vers Microsoft.

Les rapports d'erreur incluent les informations suivantes : les informations concernant l'état du serveur au moment où un problème se produit, la version du système d'exploitation et du matériel utilisés, et l'ID de produit numérique (peut être utilisé pour identifier votre licence). L'adresse IP de votre ordinateur est également envoyée, car vous vous connectez à un service en ligne pour envoyer des rapports d'erreurs ; toutefois, l'adresse IP n'est utilisée que pour générer des statistiques d'agrégation.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $True.

ErrorReportingEnabled

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si la collecte des rapports d'erreur est activée.

Des rapports d'erreurs sont créés lorsque votre système rencontre des problèmes matériels ou logiciels. Microsoft et ses partenaires utilisent activement ces rapports pour améliorer la fiabilité des logiciels. Le rapport d'erreurs inclut : des informations concernant l'état du serveur au moment où s'est produit le problème, la version du système d'exploitation et le matériel informatique utilisés, et l'ID du produit permettant d'identifier votre licence. L'adresse IP de votre ordinateur est également envoyée, car vous vous connectez à un service en ligne pour envoyer des rapports d'erreurs ; toutefois, l'adresse IP n'est utilisée que pour générer des statistiques d'agrégation.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $True.

EventLogFloodProtectionEnabled

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si la fonction de protection de flux du journal des événements est activée.

Si le journal des événements contient des événements similaires, Microsoft SharePoint Foundation 2010 supprime les messages en double. Après un certain temps, il crée alors un message résumant le nombre d'événements qui ont été supprimés.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $True.

EventLogFloodProtectionNotifyInterval

Facultatif

System.Int32

Spécifie, en minutes, la fréquence d'écriture d'un événement récapitulatif indiquant le nombre d'événements supprimés en raison de la protection de flux.

La plage d'entiers est comprise entre 1 et 1 440. La valeur par défaut est 5.

EventLogFloodProtectionQuietPeriod

Facultatif

System.Int32

Spécifie, en minutes, le temps qui doit s'écouler sans déclenchement d'un événement pour quitter la protection de flux.

La plage d'entiers est comprise entre 1 et 1 440. La valeur par défaut est 2.

EventLogFloodProtectionThreshold

Facultatif

System.Int32

Spécifie le nombre d'événements autorisés dans une période donnée avant qu'un événement soit considéré comme excédentaire pour le journal des événements.

La plage d'entiers est comprise entre 1 et 100. La valeur par défaut est 5.

EventLogFloodProtectionTriggerPeriod

Facultatif

System.Int32

Spécifie, en minutes, la période à surveiller pour la survenance d'événements potentiellement excédentaires.

La plage d'entiers est comprise entre 1 et 1 440. La valeur par défaut est 2.

InputObject

Facultatif

System.Management.Automation.PSObject

Utilisez le résultat de l'applet de commande Get-SPDiagnosticConfig, effectuez les modifications et ajoutez ensuite l'objet dans l'applet de commande Set-SPDiagnosticConfig pour mettre à jour la base de données Windows SharePoint Services.

LogCutInterval

Facultatif

System.Int32

Spécifie la période devant s'écouler avant de passer au fichier journal suivant.

Le type doit être un nombre valide compris entre 0 et 1 440.

La valeur par défaut est 30.

LogDiskSpaceUsageGB

Facultatif

System.Int32

Spécifie le volume de stockage maximum à utiliser pour les fichiers journaux de suivi, en gigaoctets (Go).

La valeur par défaut est 1 000 et ne prend effet que lorsque l'applet de commande LogMaxDiskSpaceusageEnabled a la valeur True.

Le type doit être un nombre valide compris entre 1 et 1 000.

LogLocation

Facultatif

System.String

Spécifie le chemin d'accès vers l'emplacement où résideront les fichiers journaux.

Le type doit être un chemin d'accès valide au format C:\Journaux.

L'emplacement par défaut est %CommonProgramFiles%\Microsoft Shared\Web Server Extensions\14\Journaux.

LogMaxDiskSpaceUsageEnabled

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si l'espace maximal réservé aux fichiers journaux de suivi doit être limité.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $False.

ScriptErrorReportingDelay

Facultatif

System.Int32

Spécifie le temps (en minutes) entre les rapports d'erreur de script.

Le type doit être un entier valide compris entre 0 et 1 440. La valeur est spécifiée en minutes.

La valeur par défaut est 30.

ScriptErrorReportingEnabled

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si la fonction de création de rapports d'erreur est activée pour les erreurs de script client.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $True.

ScriptErrorReportingRequireAuth

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si la fonction de création de rapports d'erreurs de script requiert l'authentification.

Le type doit être l'une des valeurs suivantes :

- $True

- $False

La valeur par défaut est $True.

Description détaillée

Utilisez l'applet de commande Set-SPDiagnosticConfig pour définir les paramètres de configuration du diagnostic sur la batterie de serveurs entière.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
set-spdiagnosticconfig -errorReportingEnable -DownloadErrorReportingUpdatesEnabled:$false -DaysToKeepLog  60

Cet exemple définit le nombre de jours de conservation du fichier journal sur 60.

------------------EXEMPLE 2-----------------------
Code de copie
$L = get-spdiagnosticconfig
Code de copie
$L.CustomerExperienceImprovementProgramEnabled = $false
Code de copie
$L.LogCutInterval = 60
Code de copie
$L | Set-SPDiagnosticConfig

Cet exemple active ErrorReporting, désactive DownloadErrorReportingUpdates, puis définit DaysToKeepLog sur 60.

Voir aussi

Référence

Get-SPDiagnosticConfig

Historique des modifications


Set-SPDiagnosticsProvider
Voir aussi Exemple
[image]

Active un fournisseur de diagnostics et met à jour sa stratégie de rétention.

Set-SPDiagnosticsProvider [-Identity] <SPDiagnosticsProviderPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DaysRetained <Int32>] [-Enable <SwitchParameter>] [-MaxTotalSizeInBytes <Int64>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPDiagnosticsProviderPipeBind

Spécifie le fournisseur de diagnostics à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur de diagnostics valide (par exemple, DiagnosticProv1) ou une instance d'un objet SPDiagnosticsProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DaysRetained

Facultatif

System.Int32

Spécifie le nombre de jours de rétention des données collectées par un fournisseur de diagnostics.

Le type doit être une valeur entière valide dans la plage de 1 à 14.

Enable

Facultatif

System.Management.Automation.SwitchParameter

Active ou désactive le fournisseur de diagnostics spécifié.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPDiagnosticsProvider active un fournisseur de diagnostics et met à jour sa stratégie de rétention.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Get-SPDiagnosticsProvider job-diagnostics-event-log-provider | Set-SPDiagnosticsProvider -Enable:$false
Code de copie
Get-SPDiagnosticsProvider job-diagnostics-event-log-provider

Cet exemple désactive le fournisseur de diagnostics du journal d'événements.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPDiagnosticsProvider job-diagnostics-event-log-provider | Set-SPDiagnosticsProvider -Enable -DaysRetained 10
Code de copie
Get-SPDiagnosticsProvider job-diagnostics-event-log-provider

Cet exemple active le fournisseur de diagnostics du journal d'événements et modifie sa stratégie de rétention à 10 jours.

Voir aussi

Référence

Get-SPDiagnosticsProvider

Historique des modifications


Applets de commande pour les performances (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour gérer les performances d'une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Disable-SPWebApplicationHttpThrottling

Enable-SPWebApplicationHttpThrottling

Get-SPBusinessDataCatalogThrottleConfig

Remove-SPBusinessDataCatalogThrottleConfig

Set-SPWebApplicationHttpThrottlingMonitor

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Add-SPDiagnosticsPerformanceCounter
Voir aussi Exemple
[image]

Ajoute une nouvelle instance d'un compteur de performances sur un ordinateur Web frontal ou un serveur de bases de données.

Add-SPDiagnosticsPerformanceCounter [-Category] <String> -Counter <String> [-AllInstances <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseServer <SwitchParameter>] [-WebFrontEnd <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Add-SPDiagnosticsPerformanceCounter [-Category] <String> -Instance <String> [-AllInstances <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Counter <String>] [-DatabaseServer <SwitchParameter>] [-WebFrontEnd <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Category

Requis

System.String

Spécifie la catégorie de compteur de performances à ajouter à l'ordinateur frontal Web ou au serveur de bases de données.

Le type doit être un nom valide de catégorie de compteurs de performances comme ASP.NET, PhysicalDisk ou Processor.

Counter

Requis

System.String

Spécifie le type de compteur à ajouter à l'ordinateur frontal Web ou au serveur de bases de données.

Le type doit être un nom valide de type de compteur comme Requests Queued, Avg. Disk Queue Length et % Processor Time.

AllInstances

Facultatif

System.Management.Automation.SwitchParameter

Collecte toutes les instances d'une catégorie et d'un type de compteur sur l'ordinateur Web frontal ou le serveur de bases de données.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseServer

Facultatif

System.Management.Automation.SwitchParameter

Ajoute le compteur de performances spécifié à tous les serveurs de bases de données de la batterie de serveurs.

WebFrontEnd

Facultatif

System.Management.Automation.SwitchParameter

Ajoute le compteur de performances à tous les ordinateurs Web frontaux de la batterie de serveurs.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Category

Requis

System.String

Spécifie la catégorie de compteur de performances à ajouter à l'ordinateur frontal Web ou au serveur de bases de données.

Le type doit être un nom valide de catégorie de compteurs de performances comme ASP.NET, PhysicalDisk ou Processor.

Counter

Requis

System.String

Spécifie le type de compteur à ajouter à l'ordinateur frontal Web ou au serveur de bases de données.

Le type doit être un nom valide de type de compteur comme Requests Queued, Avg. Disk Queue Length et % Processor Time.

Instance

Requis

System.String

Spécifie le nom complet du nouveau compteur de performances.

Le type doit être un nom valide d'instance de compteur de performances comme Total_PerfCounter.

AllInstances

Facultatif

System.Management.Automation.SwitchParameter

Collecte toutes les instances d'une catégorie et d'un type de compteur sur l'ordinateur Web frontal ou le serveur de bases de données.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseServer

Facultatif

System.Management.Automation.SwitchParameter

Ajoute le compteur de performances spécifié à tous les serveurs de bases de données de la batterie de serveurs.

WebFrontEnd

Facultatif

System.Management.Automation.SwitchParameter

Ajoute le compteur de performances à tous les ordinateurs Web frontaux de la batterie de serveurs.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Add-SPDiagnosticsPerformanceCounter ajoute un compteur de performances sur un serveur Web frontal ou un serveur de bases de données. Le compteur de performances est lu et enregistré dans la base de données d'utilisation. Par défaut, le nouveau compteur de performances est ajouté aux serveurs de bases de données de la batterie de serveurs.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
Add-SPDiagnosticsPerformanceCounter -category ASP.NET -Counter "Requests Queued"

Cet exemple ajoute le compteur portant le nom ASP.NET\Requests Queued sur les serveurs Web frontaux.

------------------EXEMPLE 2------------------
Code de copie
Add-SPDiagnosticsPerformanceCounter -category PhysicalDisk -counter "Avg. Disk Queue Length" -allinstances

Cet exemple ajoute toutes les instances du compteur PhysicalDisk de la catégorie Avg. Disk Queue Length sur des serveurs Web frontaux.

------------------EXEMPLE 3------------------
Code de copie
Add-SPDiagnosticsPerformanceCounter -category Processor -counter "% Processor Time" -instance "_Total" -databaseserver

Cet exemple ajoute l'instance _Total du compteur % Processor Time de la catégorie Processor sur des serveurs de bases de données.

Voir aussi

Référence

Get-SPDiagnosticsPerformanceCounter
Remove-SPDiagnosticsPerformanceCounter

Historique des modifications


Get-SPDiagnosticsPerformanceCounter
Voir aussi Exemple
[image]

Renvoie une collection de compteurs de performances.

Get-SPDiagnosticsPerformanceCounter [-AssignmentCollection <SPAssignmentCollection>] [-DatabaseServer <SwitchParameter>] [-WebFrontEnd <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DatabaseServer

Facultatif

System.Management.Automation.SwitchParameter

Renvoie les compteurs de performances collectés pour les serveurs de bases de données de la batterie de serveurs.

WebFrontEnd

Facultatif

System.Management.Automation.SwitchParameter

Renvoie les compteurs de performances collectés pour les ordinateurs Web frontaux de la batterie de serveurs.

Description détaillée

L'applet de commande Get-SPDiagnosticsPerformanceCounter renvoie la collection de compteurs de performances qui sont lus et enregistrés dans la base de données d'utilisation. Si le paramètre DatabaseServer ou WebFrontEnd n'est pas spécifié, cette applet de commande renvoie les compteurs de performances des ordinateurs Web frontaux des serveurs de bases de données d'une batterie de serveurs.

Pour distinguer des compteurs collectés sur des serveurs de bases de données des compteurs collectés sur des ordinateurs Web frontaux, notez que sur les compteurs collectés sur des serveurs de bases de données, le paramètre Provider Name a la valeur job-diagnostics-performance-counter-sql-provider et que pour les compteurs collectés sur des ordinateurs Web frontaux, le paramètre Provider Name a la valeur job-diagnostics-performance-counter-wfe-provider.

Remarque :
L'applet de commande Get-SPDiagnosticsPerformanceCounter n'est disponible que si vous utilisez Windows PowerShell. Il n'existe aucune interface utilisateur.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
Get- SPDiagnosticsPerformanceCounter

Cet exemple obtient les paramètres des compteurs de performances pour des ordinateurs Web frontaux et des serveurs de bases de données.

------------------EXEMPLE 2------------------
Code de copie
Get- SPDiagnosticsPerformanceCounter -WebFrontEnd

Cet exemple obtient les paramètres des compteurs de performances pour des ordinateurs Web frontaux.

------------------EXEMPLE 3------------------
Code de copie
Get- SPDiagnosticsPerformanceCounter -DatabaseServer

Cet exemple obtient les paramètres des compteurs de performances pour des serveurs de bases de données.

Voir aussi

Référence

Add-SPDiagnosticsPerformanceCounter
Remove-SPDiagnosticsPerformanceCounter

Historique des modifications


Remove-SPDiagnosticsPerformanceCounter
Voir aussi Exemple
[image]

Supprime une instance d'un compteur de performances.

Remove-SPDiagnosticsPerformanceCounter [-Category] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Counter <String>] [-DatabaseServer <SwitchParameter>] [-Instance <String>] [-WebFrontEnd <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Category

Requis

System.String

Spécifie la catégorie de compteurs de performances à supprimer.

Le type doit être un nom valide de catégorie de compteurs de performances comme ASP.NET, PhysicalDisk ou Processor.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Counter

Facultatif

System.String

Spécifie le type de compteur à supprimer. Si ce paramètre n'est pas spécifié, cette applet de commande supprime tous les compteurs de performances de la catégorie spécifiée.

Le type doit être un nom valide de type de compteur comme Requests Queued, Avg. Disk Queue Length et % Processor Time.

DatabaseServer

Facultatif

System.Management.Automation.SwitchParameter

Supprime les compteurs de performances spécifiés collectés sur les serveurs de bases de données de la batterie de serveurs.

Instance

Facultatif

System.String

Spécifie le nom de l'instance du compteur de performances à supprimer. Si ce paramètre n'est pas spécifié, cette applet de commande supprime toutes les instances du compteur de performances spécifié.

Le type doit être un nom valide d'instance de compteur de performances comme Total_PerfCounter.

WebFrontEnd

Facultatif

System.Management.Automation.SwitchParameter

Supprime les compteurs de performances collectés sur les ordinateurs Web frontaux de la batterie de serveurs.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPDiagnosticsPerformanceCounter supprime des compteurs de performances de la collection de compteurs de performances qui sont lus et enregistrés dans la base de données d'utilisation. Cette applet de commande permet également de supprimer de la collection des catégories entières et des types de compteurs. Si le paramètre DatabaseServer ou WebFrontEnd n'est pas spécifié, cette applet de commande supprime les compteurs de performances spécifiés des ordinateurs Web frontaux de la batterie de serveurs.

Remarque :
L'applet de commande Remove-SPDiagnosticsPerformanceCounter n'est disponible que si vous utilisez Windows PowerShell. Il n'existe aucune interface utilisateur.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
Remove-SPDiagnosticsPerformanceCounter -category ASP.NET

Cet exemple supprime tous les compteurs de la catégorie ASP.NET des ordinateurs Web frontaux.

------------------EXEMPLE 2------------------
Code de copie
Remove-SPDiagnosticsPerformanceCounter -category ASP.NET -Counter "Requests Queued"

Cet exemple supprime les compteurs de la catégorie ASP.NET qui présentent des demandes en file d'attente sur des ordinateurs Web frontaux.

------------------EXEMPLE 3------------------
Code de copie
Remove-SPDiagnosticsPerformanceCounter -category Processor -counter "% Processor Time" -instance "_Total" -databaseserver

Cet exemple supprime les compteurs de l'instance _Total, avec le compteur % Processor Time dans la catégorie Processor sur des serveurs de bases de données.

Voir aussi

Référence

Add-SPDiagnosticsPerformanceCounter
Get-SPDiagnosticsPerformanceCounter

Historique des modifications


Disable-SPWebApplicationHttpThrottling
Voir aussi Exemple
[image]

Désactive la limitation du réseau pour une application Web.

Disable-SPWebApplicationHttpThrottling [-Identity] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Désactive la limitation du réseau sur l'application Web SharePoint spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'application Web SharePoint (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Disable-SPWebApplicationHttpThrottling désactive la limitation du réseau pour une application Web. Cette opération vous invite à confirmer que vous voulez désactiver la limitation du réseau.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Disable-SPWebApplicationHTTPThrottling http://sitename

Cet exemple désactive la limitation du réseau sur l'application Web http://sitename.

Voir aussi

Référence

Get-SPWebApplicationHttpThrottlingMonitor
Enable-SPWebApplicationHttpThrottling
Set-SPWebApplicationHttpThrottlingMonitor

Historique des modifications


Enable-SPWebApplicationHttpThrottling
Voir aussi Exemple
[image]

Active la limitation du réseau pour une application Web.

Enable-SPWebApplicationHttpThrottling [-Identity] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Active la limitation du réseau sur l'application Web SharePoint spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'application Web SharePoint (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Enable-SPWebApplicationHttpThrottling active la limitation du réseau pour une application Web. Cette opération vous invite à confirmer que vous voulez activer la limitation du réseau.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Enable-SPWebApplicationHttpThrottling http://sitename

Cet exemple active la limitation du réseau sur l'application Web http://sitename.

Voir aussi

Référence

Get-SPWebApplicationHttpThrottlingMonitor
Disable-SPWebApplicationHttpThrottling
Set-SPWebApplicationHttpThrottlingMonitor

Historique des modifications


Get-SPBusinessDataCatalogThrottleConfig
Voir aussi Exemple
[image]

Renvoie la configuration de limitation pour une application de service de connectivité de données métiers.

Get-SPBusinessDataCatalogThrottleConfig -Scope <Global | Database | WebService | Wcf | Custom> -ServiceApplicationProxy <SPServiceApplicationProxyPipeBind> -ThrottleType <None | Items | Size | Connections | Timeout> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPBusinessDataCatalogThrottleConfig -FileBacked <SwitchParameter> -Scope <Global | Database | WebService | Wcf | Custom> -ThrottleType <None | Items | Size | Connections | Timeout> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Scope

Requis

Microsoft.BusinessData.SystemSpecific.ThrottleScope

Renvoie la configuration de limitation pour l'étendue spécifiée.

Le type doit être l'un des suivants : Wcf, WebService, Database, Global ou Custom.

ServiceApplicationProxy

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Spécifie le proxy d'application du service Connexion de données métiers qui contient la configuration de limitation à obtenir.

ThrottleType

Requis

Microsoft.BusinessData.SystemSpecific.ThrottleType

Renvoie la configuration de limitation pour le type de limitation spécifié.

Le type doit être l'un des suivants : None, Items, Size, Connections ou Timeout.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

FileBacked

Requis

System.Management.Automation.SwitchParameter

Demande la configuration de limitation pour les catalogues de métadonnées sauvegardées de fichiers.

Scope

Requis

Microsoft.BusinessData.SystemSpecific.ThrottleScope

Renvoie la configuration de limitation pour l'étendue spécifiée.

Le type doit être l'un des suivants : Wcf, WebService, Database, Global ou Custom.

ThrottleType

Requis

Microsoft.BusinessData.SystemSpecific.ThrottleType

Renvoie la configuration de limitation pour le type de limitation spécifié.

Le type doit être l'un des suivants : None, Items, Size, Connections ou Timeout.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Get-SPBusinessDataCatalogThrottleConfig lit la configuration de limitation pour une application de service de connectivité de données métiers.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPBusinessDataCatalogThrottleConfig -Scope Database -ThrottleType Items -ServiceApplicationProxy $contosoServAppProxy

Cet exemple renvoie les informations de limitation relatives aux éléments de base de données de l'application de service donnée.

Voir aussi

Référence

Set-SPBusinessDataCatalogThrottleConfig

Historique des modifications


Set-SPBusinessDataCatalogThrottleConfig
Voir aussi Exemple
[image]

Définit la configuration de limitation pour une application de service de connectivité de données métiers.

Set-SPBusinessDataCatalogThrottleConfig -Default <Int32> -Identity <ThrottleConfig> -Maximum <Int32> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Set-SPBusinessDataCatalogThrottleConfig -Enforced <SwitchParameter> -Identity <ThrottleConfig> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Default

Requis

System.Int32

Spécifie le paramètre par défaut de la configuration de limitation.

Identity

Requis

Microsoft.SharePoint.BusinessData.SharedService.ThrottleConfig

Spécifie la configuration de limitation à mettre à jour.

Maximum

Requis

System.Int32

Spécifie la valeur maximale du paramètre de configuration de limitation.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Enforced

Requis

System.Management.Automation.SwitchParameter

Indique que le paramètre de configuration de limitation ne peut pas être remplacé.

Identity

Requis

Microsoft.SharePoint.BusinessData.SharedService.ThrottleConfig

Spécifie la configuration de limitation à mettre à jour.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPBusinessDataCatalogThrottleConfig définit la configuration de limitation pour une application de service de connectivité de données métiers.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPBusinessDataCatalogThrottleConfig -Scope Database -ThrottleType Items -ServiceApplicationProxy $contosoServAppProxy | Set-SPBusinessDataCatalogThrottleConfig -Maximum 1000000000 -Default 500000

Cet exemple définit la limitation des éléments de la base de données à des valeurs maximales de 1000000000 et par défaut de 500000 pour l'application de service donnée.

Voir aussi

Référence

Get-SPBusinessDataCatalogThrottleConfig

Historique des modifications


Get-SPWebApplicationHttpThrottlingMonitor
Voir aussi Exemple
[image]

Renvoie tous les compteurs et leurs valeurs de compartiments de score d'intégrité associées pour la limitation du réseau sur une application Web.

Get-SPWebApplicationHttpThrottlingMonitor [-Identity] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Renvoie les paramètres de compteur de performance de limitation pour l'application Web SharePoint spécifiée.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeApp1) ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPWebApplicationHttpThrottlingMonitor lit tous les compteurs de limitation du réseau d'une application Web. Cette applet de commande renvoie une liste contenant tous les compteurs de performance et leurs valeurs de compartiment de score d'intégrité associées.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$s = get-SPWebApplicationHTTPThrottlingMonitors http://sharepoint

Cet exemple obtient tous les compteurs de performance en cours de lecture sur l'écran de limitation du réseau pour l'application Web http://sharepoint.

Voir aussi

Référence

Set-SPWebApplicationHttpThrottlingMonitor
Enable-SPWebApplicationHttpThrottling
Disable-SPWebApplicationHttpThrottling

Historique des modifications


Set-SPWebApplicationHttpThrottlingMonitor
Voir aussi Exemple
[image]

Définit les valeurs de compartiment de score d'intégrité pour un compteur de performance de limitation du réseau existant pour une application Web spécifiée.

Set-SPWebApplicationHttpThrottlingMonitor [-Identity] <SPWebApplicationPipeBind> [-Category] <String> [-Counter] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-HealthScoreBuckets <Double[]>] [-Instance <String>] [-IsDESC <SwitchParameter>] [-LowerLimit <Double>] [-UpperLimit <Double>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web SharePoint à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MonAppOffice1) ou une instance d'un objet SPWebApplication valide.

Category

Requis

System.String

Spécifie le nom de la catégorie de compteur de performance.

Le type doit être une catégorie de compteur de performance valide de l'écran de limitation. Utilisez l'applet de commande Get-SPWebApplicationHttpThrottlingMonitor pour renvoyer une liste des catégories de compteur de performance de l'écran de limitation.

Counter

Requis

System.String

Spécifie le nom du compteur de performance.

Le type doit être une catégorie de compteur de performance valide de l'écran de limitation. Utilisez l'applet de commande Get-SPWebApplicationHttpThrottlingMonitor pour renvoyer une liste des compteurs de performance de l'écran de limitation.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

HealthScoreBuckets

Facultatif

System.Double[]

Spécifie les plages de compartiments à utiliser pour déterminer le calcul du score d'intégrité du serveur pour ce compteur.

Instance

Facultatif

System.String

Spécifie l'instance du compteur de performance. La valeur par défaut est vide. Si la valeur spécifiée est incorrecte, cette applet de commande n'est pas exécutée.

IsDESC

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que ce compteur est interprété dans l'ordre décroissant.

Si ce paramètre est défini, les valeurs de score d'intégrité sont interprétées dans l'ordre décroissant ; par exemple, définissez ce paramètre en utilisant la catégorie Memory et le compteur Available Mbytes pour analyser la mémoire disponible.

LowerLimit

Facultatif

System.Double

Spécifie la limite inférieure du seuil numérique du compte de performance spécifié. Cette limite correspond à la valeur la plus basse des valeurs de compartiment de score d'intégrité.

UpperLimit

Facultatif

System.Double

Spécifie la limite supérieure du seuil numérique du compte de performance spécifié. Cette limite correspond à la valeur la plus élevée des valeurs de compartiment de score d'intégrité.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPWebApplicationHttpThrottlingMonitor définit les valeurs de compartiment de score d'intégrité pour un compteur de performance de limitation du réseau existant pour une application Web spécifiée.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
$buckets=(2000,1000,500,300,200,100,50,30,20,10)
Set-SPWebApplicationHttpThrottlingMonitor http://sharepoint -
Category Memory -Counter 'Available Mbytes' -IsDesc -HealthScoreBuckets $buckets

Cet exemple définit les valeurs de compartiment du score d'intégrité du compteur Memory\Available Mbytes sur le tableau mentionné pour l'application Web http://sharepoint.

------------------EXEMPLE 2------------------
Code de copie
Set-SPWebApplicationHttpThrottlingMonitor http://sharepoint
0 -Category Memory -Counter 'Available Mbytes' -IsDesc -UpperLimit 3000

Cet exemple définit la limite supérieure du compteur Memory\Available Mbytes, la valeur la plus élevée des compartiments de score d'intégrité, à 3000 pour l'application Web the http://sharepoint.

Voir aussi

Référence

Get-SPWebApplicationHttpThrottlingMonitor
Enable-SPWebApplicationHttpThrottling
Disable-SPWebApplicationHttpThrottling

Historique des modifications


Applets de commande pour la sécurité (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour administrer la sécurité pour Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Get-SPClaimProviderManager

Get-SPManagedAccount

Get-SPManagedPath

Get-SPObjectSecurity

New-SPClaimsPrincipal

New-SPManagedAccount

New-SPManagedPath

Remove-SPManagedAccount

Remove-SPManagedPath

Set-SPManagedAccount

Update-SPFarmEncryptionKey

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Add-SPShellAdmin
Voir aussi Exemple
[image]

Ajoute un utilisateur au rôle SharePoint_Shell_Access pour la base de données spécifiée.

Add-SPShellAdmin [-UserName] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-database <SPDatabasePipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

UserName

Requis

System.String

Spécifie le nom de l'utilisateur à ajouter au rôle SharePoint_Shell_Access dans la base de données cible.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

database

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabasePipeBind

Spécifie le GUID de la base de données ou de l'objet Database qui inclut le rôle SharePoint_Shell_Access auquel vous voulez ajouter l'utilisateur. Si le paramètre database n'est pas spécifié, la base de données de configuration est utilisée. La base de données de configuration de la batterie de serveurs est toujours incluse, même si vous spécifiez une autre base de données.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Add-SPShellAdmin pour ajouter un utilisateur au rôle SharePoint_Shell_Access pour une base de données spécifiée. Vous devez exécuter l'applet de commande Add-SPShellAdmin pour toutes les bases de données auxquelles vous souhaitez accorder un accès. Si aucune base de données n'est spécifiée, la base de données de configuration de la batterie de serveurs est utilisée. Si vous spécifiez une base de données, la base de données de contenu Administration centrale et la base de données de configuration de la batterie de serveurs seront ajoutées, en plus de toute autre base de données que vous spécifiez. La méthode recommandée est de spécifier une base de données avec le paramètre de base de données, car la plupart des opérations d'administration nécessitent un accès à la base de données de contenu Administration centrale et qu'elle est automatiquement gérée quand une base de données est spécifiée avec le paramètre base de données.

Lorsque vous exécutez cette applet de commande pour ajouter un utilisateur au rôle SharePoint_Shell_Access, vous devez posséder les autorisations de sécurité suivantes :

- Accès au rôle Security_Admin sur l'instance SQL et le rôle db_owner dans une base de données.

- Autorisation administrative sur l'ordinateur local.

L'utilisateur est ajouté au groupe WSS_Admin_WPG sur tous les serveurs Web frontaux lorsque l'utilisateur est ajouté au rôle SharePoint_Shell_Access. Si la base de données cible ne comporte aucun rôle SharePoint_Shell_Access, ce dernier est automatiquement créé.

Important :
Le résultat de cet applet de commande est que l'utilisateur spécifié par le paramètre UserName dispose de l'accès au rôle dbo_owner sur les bases de données, comme décrit plus haut.

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE 1---------------------
Code de copie
Add-SPShellAdmin -UserName CONTOSO\User1

Cet exemple ajoute un nouvel utilisateur appelé User1 au rôle SharePoint_Shell_Access dans la base de données de configuration de la batterie de serveurs uniquement et garantit l'ajout de l'utilisateur au groupe local WSS_Admin_WPG sur chaque serveur de la batterie de serveurs.

--------------------EXEMPLE 2---------------------
Code de copie
Add-SPShellAdmin -UserName CONTOSO\User1 -database 4251d855-3c15-4501-8dd1-98f960359fa6

Cet exemple ajoute un nouvel utilisateur appelé User1 au rôle SharePoint_Shell_Access dans la base de données de contenu et dans la base de données de configuration spécifiées en transmettant un GUID de base de données à l'applet de commande.

-------------------EXEMPLE 3-------------------------
Code de copie
Get-SPDatabase | Where-Object {$_.WebApplication -like "SPAdministrationWebApplication"} | Add-SPShellAdmin CONTOSO\User1

Cet exemple ajoute un nouvel utilisateur appelé User1 au rôle SharePoint_Shell_Access dans la base de données de contenu Administration centrale spécifiée et la base de données de configuration.

-------------------EXEMPLE 4-------------------------
Code de copie
Get-SPDatabase | ?{$_.Name -eq "WSS_Content"} | Add-SPShellAdmin -Username CONTOSO\User1

Cet exemple ajoute un nouvel utilisateur appelé User1 au rôle SharePoint_Shell_Access dans la base de données de contenu et dans la base de données de configuration spécifiées en transmettant le nom de la base de données à l'applet de commande.

Voir aussi

Référence

Get-SPShellAdmin
Remove-SPShellAdmin

Historique des modifications


Get-SPShellAdmin
Voir aussi Exemple
[image]

Renvoie le nom de tous les utilisateurs dotés du rôle SharePoint_Shell_Access.

Get-SPShellAdmin [[-database] <SPDatabasePipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

database

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabasePipeBind

Spécifie le nom de la base de données qui inclut le rôle SharePoint_Shell_Access dont vous souhaitez afficher les noms d'utilisateurs. Si le paramètre database n'est pas spécifié, la base de données de configuration est utilisée.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

Utilisez l'applet de commande Get-SPShellAdmin pour renvoyer les noms de tous les utilisateurs dotés du rôle SharePoint_Shell_Access dans une base de données.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE----------------------

Code de copie
Get-SPShellAdmin -database WSS_Content

Cet exemple renvoie le nom de chaque utilisateur doté du rôle SharePoint_Shell_Access dans la base de données WSS_Content.

Voir aussi

Référence

Add-SPShellAdmin
Remove-SPShellAdmin

Historique des modifications


Remove-SPShellAdmin
Voir aussi Exemple
[image]

Supprime un utilisateur du rôle SharePoint_Shell_Access.

Remove-SPShellAdmin [-UserName] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-database <SPDatabasePipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

UserName

Requis

System.String

Spécifie le nom de l'utilisateur à supprimer du rôle SharePoint_Shell_Access dans la base de données spécifiée.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

database

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabasePipeBind

Spécifie le nom de la base de données qui inclut le rôle SharePoint_Shell_Access duquel l'utilisateur doit être supprimé. Si le paramètre database n'est pas spécifié, la base de données de configuration est utilisée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Remove-SPShellAdmin pour supprimer un utilisateur du rôle SharePoint_Shell_Access dans une base de données spécifiée.

Lorsque vous utilisez cette applet de commande pour supprimer un utilisateur du rôle, vous ne supprimez pas l'utilisateur du groupe WSS_ADMIN_WPG dans la base de données cible.

Lorsque vous exécutez cette applet de commande pour ajouter un utilisateur au rôle SharePoint_Shell_Access, l'utilisateur doit disposer des autorisations de sécurité suivantes :

- Accès au rôle Security_Admin sur l'instance SQL et au rôle db_owner dans la base de données.

- Droit administratif sur l'ordinateur local.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE------------------------
Code de copie
Remove-SPShellAdmin -UserName CONTOSO\User1 -database WSS_Content

Cet exemple supprime un utilisateur existant appelé User1 du rôle SharePoint_Shell_Access dans la base de données WSS_Content.

Voir aussi

Référence

Add-SPShellAdmin
Get-SPShellAdmin

Historique des modifications


Add-SPClaimTypeMapping
Voir aussi Exemple
[image]

Ajoute un mappage de revendications à un fournisseur d'identité approuvé du service d'émission de jeton de sécurité (STS).

Add-SPClaimTypeMapping [-Identity] <SPClaimMappingPipeBind> [-TrustedIdentityTokenIssuer] <SPTrustedIdentityTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Force <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPClaimMappingPipeBind

Spécifie le service de jeton de sécurité pour la batterie qui émettra le jeton de sécurité pour le fournisseur d'identité.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de règle de mappage des revendications valide (par exemple ClaimMap1) ou une instance d'un objet SPClaimMapping valide.

TrustedIdentityTokenIssuer

Requis

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Spécifie l'émetteur de jeton approuvé de la batterie (fournisseur d'authentification STS).

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'authentification valide (par exemple, MyIDprovider1) ou une instance d'un objet SPTrustedIdentityTokenIssuer valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Force

Facultatif

System.Management.Automation.SwitchParameter

Écrase la règle de mappage de revendications si elle existe.

Description détaillée

L'applet de commande Add-SPClaimTypeMapping ajoute une règle de mappage de type de revendication à un fournisseur d'identité STS approuvé d'un fournisseur d'authentification STS approuvé de batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPTrustedIdentityProvider -Name "LiveIDSTS" | Add-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier" -IncomingClaimTypeDisplayName "PUID" -LocalClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/thumbprint"

Cet exemple ajoute un mappage de revendications à un émetteur de jetons d'identité approuvé.

Voir aussi

Référence

New-SPClaimTypeMapping
Remove-SPClaimTypeMapping

Historique des modifications


Get-SPAuthenticationProvider
Voir aussi Exemple
[image]

Renvoie un fournisseur d'authentification.

Get-SPAuthenticationProvider [[-Identity] <SPAuthenticationProviderPipeBind>] [-WebApplication] <SPWebApplicationPipeBind> [-Zone] <Default | Intranet | Internet | Custom | Extranet> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPAuthenticationProviderPipeBind

Spécifie le fournisseur d'authentification à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'authentification SharePoint valide (par exemple, NTLM) ou une instance d'un objet SPAuthenticationProvider valide.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Renvoie les bases de données de contenu pour l'application Web spécifiée.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MonAppOffice1) ou une instance d'un objet SPWebApplication valide.

Zone

Requis

Microsoft.SharePoint.Administration.SPUrlZone

Spécifie la zone ou les zones de l'application Web pour lesquelles retourner le fournisseur d'authentification.

Le type doit être une des zones valides : Default, Intranet, Internet, Extranet ou Custom.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPAuthenticationProvider renvoie un fournisseur d'authentification sur une zone d'application Web spécifiée. Les fournisseurs suivants sont les fournisseurs d'authentification standard pour SharePoint 2010 Products : NTLM, Classic NTLM, Negotiate et Classic Negotiate.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-----------------EXEMPLE 1-----------------
Code de copie
New-SPWebApplication http://sharepointonline.com -AuthenticationProvider (Get- SPAuthenticationProvider "LiveID STS")

Cet exemple enregistre le fournisseur d'authentification LiveID STS pour la nouvelle application Web.

-----------------EXEMPLE 2-----------------
Code de copie
New-SPWebApplication http://contoso.com -AuthenticationProvider (New- SPAuthenticationProvider -ASPNetMembershipProvider "myMembershipProvider" -ASPNetRoleProvider "myRoleProvider")

Cet exemple enregistre ASPNet pour la nouvelle application Web. Notez que les abonnements ASPNET ne sont pas persistants et doivent être recréés à chaque utilisation.

-----------------EXEMPLE 3-----------------
Code de copie
New-SPWebApplication http://contoso.com -AuthenticationProvider (Get- SPAuthenticationProvider "NTLM")

Cet exemple enregistre le fournisseur d'authentification NTLM pour la nouvelle application Web. Cette commande équivaut à la commande New-SPWebApplication http://contoso.com ; NTLM est le fournisseur d'authentification par défaut.

-----------------EXEMPLE 4-----------------
Code de copie
$ip = @( (Get- SPAuthenticationProvider "LiveID STS"), (New- SPAuthenticationProvider -ASPNetMembershipProvider "myMembershipProvider" -ASPNetRoleProvider "myRoleProvider"), (Get-SPAuthenticationProvider "NTLM")) )
New-SPWebApplication http://contoso.com -AuthenticationProvider $ip

Cet exemple enregistre les fournisseurs d'authentification NTLM, ASPNet et LiveID STS pour la nouvelle application Web.

-----------------EXEMPLE 5-----------------
Code de copie
New-SPWebApplication http://contoso.com -AuthenticationProvider (Get- SPAuthenticationProvider "Legacy NTLM")

Cet exemple enregistre le fournisseur d'authentification Legacy NTLM pour la nouvelle application Web.

Voir aussi

Référence

New-SPAuthenticationProvider

Historique des modifications


Get-SPCertificateAuthority
Exemple
[image]

Renvoie l'autorité de certification (CA) SharePoint.

Get-SPCertificateAuthority [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPCertificateAuthority renvoie l'autorité de certification SharePoint.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$signingCert = (Get-SPServiceApplication | where $_.Name -eq 'SecurityTokenServiceApplication').SigningCertificate

Cet exemple extrait le certificat de signature du fournisseur d'identité STS.

Historique des modifications


Get-SPClaimProvider
Voir aussi Exemple
[image]

Renvoie un fournisseur de revendications.

Get-SPClaimProvider [[-Identity] <SPClaimProviderPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind

Spécifie le fournisseur de revendications à obtenir.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur de revendications valide (par exemple, MyClaimProvider1) ou une instance d'un objet SPClaimProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPClaimProvider renvoie un fournisseur de revendications.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPClaimProvider -Identity "MyClaimProvider" | Set-SPClaimProvider -Enabled $false

Cet exemple désactive le fournisseur de revendications MyClaimProvider.

Voir aussi

Référence

New-SPClaimProvider
Set-SPClaimProvider
Remove-SPClaimProvider
Get-SPClaimProviderManager

Historique des modifications


Get-SPClaimProviderManager
Voir aussi Exemple
[image]

Renvoie un gestionnaire de fournisseurs de revendications.

Get-SPClaimProviderManager [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPClaimProviderManager lit un gestionnaire de fournisseurs de revendications.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

Ajouter exemple de code.

Code de copie

  Voir aussi
Référence
Get-SPClaimProvider
New-SPClaimProvider
Set-SPClaimProvider

Historique des modifications


Get-SPManagedAccount
Voir aussi Exemple
[image]

Extrait les comptes enregistrés dans la base de données de configuration.

Get-SPManagedAccount [[-Identity] <SPManagedAccountPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Service <SPServicePipeBind>]
Get-SPManagedAccount [[-Identity] <SPManagedAccountPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-WebApplication <SPWebApplicationPipeBind>]
Get-SPManagedAccount [[-Identity] <SPManagedAccountPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Server <SPServerPipeBind>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou partiel des comptes gérés à extraire.

Le type doit être un nom de compte valide, au format Domaine\Utilisateur, ou un GUID, au format 1234-3456-09876.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Service

Facultatif

Microsoft.SharePoint.PowerShell.SPServicePipeBind

Spécifie l'étendue à un service.

2

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou partiel des comptes gérés à extraire.

Le type doit être un nom de compte valide, au format Domaine\Utilisateur, ou un GUID, au format 1234-3456-09876.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'étendue à une application Web.

3

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou partiel des comptes gérés à extraire.

Le type doit être un nom de compte valide, au format Domaine\Utilisateur, ou un GUID, au format 1234-3456-09876.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Server

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie l'étendue à un serveur.

Description détaillée

L'applet de commande Get-SPManagedAccount fait partie d'un ensemble de paramètres. Elle renvoie les comptes gérés correspondant à l'étendue donnée. Cette dernière peut être une des valeurs suivantes : Web application, service ou server.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPManagedAccount

Cet exemple affiche tous les comptes gérés de la batterie.

Voir aussi

Référence

New-SPManagedAccount
Set-SPManagedAccount
Remove-SPManagedAccount

Historique des modifications


Get-SPManagedPath
Voir aussi Exemple
[image]

Renvoie tous les chemins d'accès gérés qui répondent aux critères donnés.

Get-SPManagedPath [[-Identity] <SPPrefixPipeBind>] -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPManagedPath [[-Identity] <SPPrefixPipeBind>] -HostHeader <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPPrefixPipeBind

Spécifie l'URL ou le GUID du chemin d'accès géré à renvoyer.

Le type doit être une URL valide, au format http://server_name, ou un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh).

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'URL ou le GUID de l'application Web à partir de laquelle extraire le chemin d'accès géré.

Le type doit être une URL valide, au format http://server_name, ou un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh).

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPPrefixPipeBind

Spécifie l'URL ou le GUID du chemin d'accès géré à renvoyer.

Le type doit être une URL valide, au format http://server_name, ou un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh).

HostHeader

Requis

System.Management.Automation.SwitchParameter

Si ce paramètre est fourni, les chemins d'accès gérés renvoyés proviennent des sites HostHeader de la batterie.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPManagedPath renvoie le chemin d'accès géré SharePoint qui correspond à l'identité fournie pour une application Web, une collection de sites ou toutes les collections de sites HostHeader. Si aucun paramètre Identity n'est fourni, tous les chemins d'accès gérés pour l'étendue donnée sont renvoyés.

Les sites HostHeader (indépendamment de l'application Web dans laquelle ils se trouvent) partagent un ensemble unique de chemins d'accès gérés. Utilisez le paramètre HostHeader pour renvoyer les chemins d'accès gérés d'en-tête d'hôte.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Get-SPManagedPath -WebApplication http://sitename

Cet exemple renvoie tous les chemins d'accès gérés pour l'application Web spécifiée.

--------------EXEMPLE 2-----------------
Code de copie
Get-SPManagedPath -identity "Sites" -HostHeader

Cet exemple extrait le chemin d'accès géré Sites des chemins d'accès gérés HostHeader.

Voir aussi

Référence

New-SPManagedPath
Remove-SPManagedPath

Historique des modifications


Get-SPSecurityTokenServiceConfig
Voir aussi Exemple
[image]

Renvoie le service d'émission de jeton de sécurité (STS) de la batterie de serveurs.

Get-SPSecurityTokenServiceConfig [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPSecurityTokenServiceConfig lit le service d'émission de jeton de sécurité (STS) de la batterie de serveurs. Un STS authentifie les jetons de sécurité dans les messages SOAP entrants.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get - SPSecurityTokenServiceConfig | Set -SPSecurityTokenServiceConfig -ServiceTokenLifetime 1000

Cet exemple obtient le service d'émission de jeton de sécurité (STS) de la batterie de serveurs et définit l'expiration du cache de jeton de service sur 1 000 minutes.

Voir aussi

Référence

Set-SPSecurityTokenServiceConfig

Historique des modifications


Get-SPServiceApplicationSecurity
Voir aussi Exemple
[image]

Renvoie l'objet SPObjectSecurity pour une application de service.

Get-SPServiceApplicationSecurity [-Identity] <SPServiceApplicationPipeBind> [-Admin <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service à obtenir.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application de service valide (par exemple, SearchServiceApp1) ou une instance d'un objet SPServiceApplication valide.

Admin

Facultatif

System.Management.Automation.SwitchParameter

Renvoie la liste de contrôle d'accès (ACL) qui contient la liste des administrateurs de l'application de service.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServiceApplicationSecurity renvoie un objet de sécurité pour l'application de service spécifiée. Utilisez cette applet de commande avec les applets de commande Grant-SPObjectSecurity et Set-SPServiceApplicationSecurity pour gérer la sécurité d'une application de service.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$security = Get-SPServiceApplicationSecurity $serviceApp -Admin
Grant-SPObjectSecurity $security $principal "Full Control"
Set-SPServiceApplicationSecurity $serviceApp -Admin $security

Cet exemple récupère l'objet SPObjectSecurity correspondant à la liste ACL de l'administrateur sur une application de service et ajoute un nouveau principal d'utilisateur à cette liste ACL. Le nouvel utilisateur est un administrateur de l'application de service $serviceApp.

Voir aussi

Référence

Set-SPServiceApplicationSecurity
Grant-SPObjectSecurity
Revoke-SPObjectSecurity

Historique des modifications


Get-SPTrustedIdentityTokenIssuer
Voir aussi Exemple
[image]

Renvoie un fournisseur d'identité.

Get-SPTrustedIdentityTokenIssuer [[-Identity] <SPTrustedIdentityTokenIssuerPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPIdentityProviderPipeBind

Spécifie le fournisseur d'identité à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'identité valide (par exemple, LiveID STS) ou une instance d'objet SPIdentityProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPTrustedIdentityTokenIssuer renvoie un fournisseur d'identité.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------------EXEMPLE 1------------------------
Code de copie
$trustedsts = get - SPTrustedIdentityTokenIssuer "LiveIDSTS"

Cet exemple obtient un émetteur de jetons de sécurité approuvé.

Voir aussi

Référence

Set-SPTrustedIdentityTokenIssuer
New-SPTrustedIdentityTokenIssuer
Remove-SPTrustedIdentityTokenIssuer

Historique des modifications


Get-SPTrustedRootAuthority
Voir aussi Exemple
[image]

Renvoie une autorité racine de confiance.

Get-SPTrustedRootAuthority [[-Identity] <SPTrustedRootAuthorityPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPTrustedRootAuthorityPipeBind

Spécifie l'autorité racine de confiance à récupérer.

Le type doit correspondre à un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, à un nom valide d'autorité racine de confiance (par exemple, WFEFarm1) ou à une instance d'un objet SPTrustedRootAuthority valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPTrustedRootAuthority renvoie une autorité racine de confiance. Si un fichier de certificat est utilisé, il ne doit comprendre qu'un certificat X509 sans clés privées, sinon une exception est émise.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$rootauthority = Get - SPTrustedRootAuthority -Name "WFEFarm1"

Cet exemple crée un autorité racine de confiance WFEFarm1.

Voir aussi

Référence

New-SPTrustedRootAuthority
Set-SPTrustedRootAuthority
Remove-SPTrustedRootAuthority

Historique des modifications


Get-SPTrustedServiceTokenIssuer
Voir aussi Exemple
[image]

Renvoie l'objet qui représente l'approbation de batterie.

Get-SPTrustedServiceTokenIssuer [[-Identity] <SPTrustedServiceTokenIssuerPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPTrustedServiceTokenIssuerPipeBind

Spécifie l'émetteur de jeton de service approuvé à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'émetteur de jeton de service approuvé (par exemple, WFEFarm1) ou une instance d'un objet SPTrustedRootAuthority valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPTrustedServiceTokenIssuer renvoie l'objet qui représente l'approbation de batterie.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get - SPTrustedServiceTokenIssuer "WFEFarm1"

Cet exemple obtient l'émetteur de jeton de services approuvé WFEFarm1.

Voir aussi

Référence

Set-SPTrustedServiceTokenIssuer
New-SPTrustedServiceTokenIssuer
Remove-SPTrustedServiceTokenIssuer

Historique des modifications


Grant-SPObjectSecurity
Voir aussi Exemple
[image]

Ajoute un nouveau principal de sécurité à un objet SPObjectSecurity.

Grant-SPObjectSecurity [-Identity] <SPObjectSecurity> [-Principal] <SPClaim> [-Rights] <String[]> [-AssignmentCollection <SPAssignmentCollection>] [-Replace <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.Administration.AccessControl.SPObjectSecurity

Spécifie l'objet SPObjectSecurity auquel le nouveau principal de sécurité est ajouté. Vous pouvez utiliser l'applet de commande Get-SPServiceApplicationSecurity pour obtenir un objet SPObjectSecurity.

Principal

Requis

Microsoft.SharePoint.Administration.Claims.SPClaim

Spécifie le principal de sécurité auquel s'appliquent les droits.

Le type doit être un nom de principal valide, comme Full Control.

Rights

Requis

System.String[]

Spécifie les droits accordés au principal.

Le type doit être un tableau de chaînes qui représente les droits accordés au principal.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Replace

Facultatif

System.Management.Automation.SwitchParameter

Remplace les droits existants sur l'objet SPObjectSecurity par les nouveaux droits spécifiés. Si ce paramètre n'est pas spécifié, les nouveaux droits sont ajoutés aux droits existants.

Description détaillée

L'applet de commande Grant-SPObjectSecurity ajoute un nouveau principal de sécurité, comme un utilisateur, à un objet SPObjectSecurity. Un objet SPObjectSecurity est un objet commun utilisé pour représenter la liste de contrôle d'accès (ACL) de sécurité d'objets administratifs SharePoint, et en particulier d'applications de service.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$security = Get-SPServiceApplicationSecurity $serviceApp -Admin
Grant-SPObjectSecurity $security $principal "Full Control"
Set-SPServiceApplicationSecurity $serviceApp -Admin $security

Cet exemple récupère l'objet SPObjectSecurity correspondant à la liste ACL de l'administrateur sur une application de service et ajoute un nouveau principal d'utilisateur à cette liste ACL. Le nouvel utilisateur est un administrateur de l'application de service $serviceApp.

Voir aussi

Référence

Revoke-SPObjectSecurity
Get-SPServiceApplicationSecurity

Historique des modifications


Initialize-SPResourceSecurity
Exemple
[image]

Met en place la sécurité des ressources sur le serveur local.

Initialize-SPResourceSecurity [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Initialize-SPResourceSecurity met en place la sécurité des ressources sur le serveur local. Cette applet de commande met en place la sécurité pour toutes les ressources, y compris les fichiers, dossiers et clés de registre.

Pour en savoir plus sur les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Initialize-SPResourceSecurity

Cet exemple met en place la sécurité des ressources sur le serveur local.

Historique des modifications


New-SPAuthenticationProvider
Voir aussi Exemple
[image]

Crée un nouveau fournisseur d'authentification dans la batterie.

New-SPAuthenticationProvider [-AllowAnonymous <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-DisableKerberos <SwitchParameter>] [-UseBasicAuthentication <SwitchParameter>] [-UseWindowsIntegratedAuthentication <SwitchParameter>]
New-SPAuthenticationProvider -ASPNETMembershipProvider <String> -ASPNETRoleProviderName <String> [-AssignmentCollection <SPAssignmentCollection>]
New-SPAuthenticationProvider -TrustedIdentityTokenIssuer <SPTrustedIdentityTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

AllowAnonymous

Facultatif

System.Management.Automation.SwitchParameter

Indique si l'application Web autorise l'accès anonyme.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DisableKerberos

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si l'application Web désactive l'authentification Kerberos.

UseBasicAuthentication

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si l'application Web utilise l'authentification de base.

UseWindowsIntegratedAuthentication

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si l'application Web utilise l'authentification intégrée Windows.

2

Paramètre

Requis

Type

Description

ASPNETMembershipProvider

Requis

System.String

Spécifie le nom du fournisseur d'appartenance.

Le type doit être un nom de fournisseur d'appartenance ASPNet valide, par exemple, myMembershipProvider.

ASPNETRoleProviderName

Requis

System.String

Spécifie le nom du fournisseur de rôles.

Le type doit être un nom de fournisseur de rôles ASPNet valide, par exemple, myRoleProvider.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

3

Paramètre

Requis

Type

Description

TrustedIdentityTokenIssuer

Requis

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Spécifie l'identité du fournisseur d'authentification.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'émetteur de jeton de sécurité approuvé valide (par exemple, myRoleProvider) ou une instance d'un objet SPTrustedIdentityTokenIssuer valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPAuthenticationProvider crée un nouveau fournisseur d'authentification dans la batterie.

NTLM, NTLM classique, Négocier et Négocier classique peuvent être définis uniquement dans une application Web.

Pour le fournisseur d'appartenances et de rôles ASP.NET, aucun objet n'est rendu persistant. L'objet est créé et utilisé pour définir ce type de fournisseur d'authentification dans une application Web.

Pour les fournisseurs d'authentification STS, un objet est créé et maintenu dans l'objet SPFarm.

L'utilisation de NTLM classique avec un type d'authentification basé sur les revendications est interdite.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE1------------------
Code de copie
$ap = New - SPAuthenticationProvider -UseWindowsIntegratedAuthentication
Code de copie
Set-SPWebApplication -Name "Claims Windows Web App" -ApplicationPool "Claims App Pool" -ApplicationPoolAccount "redmond\appool" -Url http://servername -Port 80 -AuthenticationProvider $ap

Cet exemple crée un fournisseur d'authentification de revendications Windows.

---------------------------EXEMPLE2------------------
Code de copie
$ap = New-SPAuthenticationProvider -ASPNETMembershipProvider "membership" -ASPNETRoleProviderName "rolemanager"
Code de copie
Set-SPWebApplication -Name "Claims Windows Web App" -ApplicationPool "Claims App Pool" -ApplicationPoolAccount "redmond\appool" -Url http://servername -Port 80 -AuthenticationProvider $ap

Cet exemple crée un fournisseur d'authentification fournisseur de rôles ASP.net.

---------------------------EXEMPLE3------------------
Code de copie
$ap = New - SPAuthenticationProvider -TrustedIdentityTokenIssuer | Get-SPTrustedIdentityTokenIssuer "LiveIDSTS"
Code de copie
Set-SPWebApplication -Name "Claims Windows Web App" -ApplicationPool "Claims App Pool" -ApplicationPoolAccount "redmond\appool" -Url http://servername -Port 80 -AuthenticationProvider $ap

Cet exemple crée un fournisseur d'authentification émetteur de jetons approuvé.

Voir aussi

Référence

New-SPAuthenticationProvider

Historique des modifications


New-SPClaimProvider
Voir aussi Exemple
[image]

Enregistre un nouveau fournisseur de revendications dans la batterie de serveurs.

New-SPClaimProvider -AssemblyName <String> -Description <String> -DisplayName <String> -Type <String> [-AssignmentCollection <SPAssignmentCollection>] [-Default <SwitchParameter>] [-Enabled <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

AssemblyName

Requis

System.String

Le type doit être un nom valide d'assembly, par exemple ClaimAssembly1.

Spécifie le nom de l'assembly avec le fournisseur de revendications.

Description

Requis

System.String

Donne la description du fournisseur de revendications.

Le type doit être un nom valide d'assembly, par exemple ClaimAssembly1.

DisplayName

Requis

System.String

Spécifie le nom complet du nouveau fournisseur de revendications.

Le type doit être un nom valide de fournisseur de revendications, par exemple, ClaimProvider1.

Type

Requis

System.String

Spécifie le type de revendication.

Le type doit être un nom valide de type de revendication, par exemple MyClaimProvider.Providers.CustomProvider.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Default

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que le fournisseur de revendications s'applique à toutes les zones et applications Web.

Enabled

Facultatif

System.Management.Automation.SwitchParameter

Active le fournisseur de revendications.

Description détaillée

L'applet de commande New-SPClaimProvider enregistre un nouveau fournisseur de revendications dans la batterie de serveurs.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
New-SPClaimProvider -Name "MyClaimProvider" -Type "MyClaimProvider.Providers.CustomProvider" -AllWebApplications

Cet exemple enregistre un fournisseur de revendications dans la batterie de serveurs.

------------------EXEMPLE 2------------------
Code de copie
New-SPClaimProvider -Name "MyClaimProvider" -Type "MyClaimProvider.Providers.CustomProvider" -Scope (Get-SPWebApplication http://test)

Cet exemple enregistre un fournisseur de revendications étendu à une application Web donnée.

Voir aussi

Référence

Get-SPClaimProvider
Set-SPClaimProvider
Remove-SPClaimProvider

Historique des modifications


New-SPClaimsPrincipal
Exemple
[image]

Crée un principal basé sur des revendications.

New-SPClaimsPrincipal [-Identity] <String> [-IdentityType] <WindowsSamAccountName | WindowsSecurityGroupName | WindowsSecurityGroupSid | FormsUser | FormsRole | EncodedClaim> [-AssignmentCollection <SPAssignmentCollection>]
New-SPClaimsPrincipal [-Identity] <String> [-TrustedIdentityTokenIssuer] <SPTrustedIdentityTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>]
New-SPClaimsPrincipal [-ClaimValue] <String> [[-ClaimType] <String>] [-TrustedIdentityTokenIssuer] <SPTrustedIdentityTokenIssuerPipeBind> [[-IdentifierClaim] <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>]
New-SPClaimsPrincipal [-EncodedClaim] <String> [-AssignmentCollection <SPAssignmentCollection>]
New-SPClaimsPrincipal [-ClaimValue] <String> [-ClaimType] <String> [-ClaimProvider] <SPClaimProvider> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

System.String

Spécifie le nom du nouveau principal basé sur des revendications.

Le type doit être un nom valide de principal basé sur des revendications.

IdentityType

Requis

Microsoft.SharePoint.Administration.Claims.SPIdentifierTypes

Spécifie le type du principal basé sur des revendications.

Le type doit être l'un des suivants : WindowsSamAccountName, WindowsSecurityGroupSid, FormsUser, FormsRole ou EncodedClaim.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

Identity

Requis

System.String

Spécifie le nom du nouveau principal basé sur des revendications.

Le type doit être un nom valide de principal basé sur des revendications.

TrustedIdentityTokenIssuer

Requis

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Spécifie l'ID du fournisseur d'authentification.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'authentification valide (par exemple, MyAuthprovider1) ou une instance d'un objet SPTrustedIdentityTokenIssuer valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

3

Paramètre

Requis

Type

Description

ClaimValue

Requis

System.String

Spécifie la valeur de la revendication de l'objet basé sur des revendications. La valeur des revendications spécifie l'utilisateur, le groupe ou l'ordinateur que la revendication authentifie.

Le type doit être une valeur de revendication valide, par exemple john@contoso.com.

ClaimType

Requis

System.String

Spécifie le type de revendication à créer. La valeur I indique une revendication d'identité d'utilisateur unique, et la valeur C indique toutes les autres revendications.

Le type doit être l'une ou l'autre des valeurs : I ou C.

TrustedIdentityTokenIssuer

Requis

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Spécifie l'ID du fournisseur d'authentification.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'authentification valide (par exemple, MyAuthprovider1) ou une instance d'un objet SPTrustedIdentityTokenIssuer valide.

IdentifierClaim

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si la nouvelle revendication est une revendication d'identité.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

4

Paramètre

Requis

Type

Description

EncodedClaim

Requis

System.String

Convertit une revendication simple en revendication codée complète.

Le type doit être une valeur de revendication valide, par exemple i:001w|redmond\user.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

5

Paramètre

Requis

Type

Description

ClaimValue

Requis

System.String

Spécifie la valeur de la revendication de l'objet basé sur des revendications. La valeur des revendications spécifie l'utilisateur, le groupe ou l'ordinateur que la revendication authentifie.

Le type doit être une valeur de revendication valide, par exemple john@contoso.com.

ClaimType

Requis

System.String

Spécifie le type de revendication à créer. La valeur I indique une revendication d'identité d'utilisateur unique, et la valeur C indique toutes les autres revendications.

Le type doit être l'une ou l'autre des valeurs : I ou C.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPClaimsPrincipal crée un principal basé sur des revendications.

Types d'entrée

Types retournés

Exemple

-------------------------EXEMPLE 1-----------------------------
Code de copie
New-SPSite http://sitename/sites/newsite -owner (New-SPClaimsPrincipal contoso\johndoe -TrustedIdentityTokenIssuer "NTLM")

Cet exemple crée un principal basé sur des revendications pour un utilisateur Windows.

-------------------------EXEMPLE 2-----------------------------
Code de copie
New-SPSite http://localhost/sites/newsite -owner (New-SPClaimsPrincipal contoso\allusers -TrustedIdentityTokenIssuer "NTLM")

Cet exemple crée un principal basé sur des revendications pour un groupe Windows.

-------------------------EXEMPLE 3-----------------------------
Code de copie
New-SPSite http://sitename/sites/newsite -owner (New-SPClaimsPrincipal -ClaimValue "john@contoso.com" -ClaimType Email -TrustedIdentityTokenIssuer "LiveID STS" -IdentifierClaim Yes)

Cet exemple crée un principal basé sur des revendications pour une revendication d'émetteur du jeton à l'identité de confiance.

-------------------------EXEMPLE 4-----------------------------
Code de copie
$ip = New-SPIdentityProvider -ASPNetMembershipProvider "myMembershipProvider" -ASPNetRoleProvider "myRoleProvider"
Code de copie
New-SPSite http://sitename/sites/newsite -owner (New-SPClaimsPrincipal "john@contoso.com" -TrustedIdentityTokenIssuer $ip)

Cet exemple crée un principal basé sur des revendications pour un utilisateur d'appartenance ASPNet.

-------------------------EXEMPLE 5-----------------------------
Code de copie
New-SPSite http://sitename/sites/newsite -owner (New-SPClaimsPrincipal "Sales Manager Role" -IdentityProvider "myRoleProvider")

Cet exemple crée un principal basé sur des revendications pour un rôle ASPNet.

-------------------------EXEMPLE 6-----------------------------
Code de copie
 $cp = New-SPClaimsPrincipal -Identity "redmond\SiteOwner" -IdentityType 1
Code de copie
New-SPSite http://servername:port -OwnerAlias $cp.ToEncodedString() -Template "STS#0"

Cet exemple crée un principal basé sur des revendications pour un rôle de revendication de base, également appelé une revendication codée).

Historique des modifications


New-SPClaimTypeMapping
Voir aussi Exemple
[image]

Crée une règle de mappage de revendications pour un fournisseur d'identité du service d'émission de jeton de sécurité (STS).

New-SPClaimTypeMapping [-IncomingClaimType] <String> [-IncomingClaimTypeDisplayName] <String> [[-LocalClaimType] <String>] [-AssignmentCollection <SPAssignmentCollection>] [-SameAsIncoming <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

IncomingClaimType

Requis

System.String

Spécifie l'URI du type de revendication entrante.

Le type doit être un URI valide au format http://schemas.microsoft.com/email.

IncomingClaimTypeDisplayName

Requis

System.String

Spécifie le nom complet du type de revendication entrante.

Le type doit être un nom de type de revendication entrante valide, par exemple Email.

LocalClaimType

Facultatif

System.String

Spécifie l'URI du type de revendication local. Si le paramètre SameAsIncoming a la valeur False, il s'agit d'un paramètre obligatoire.

Le type doit être un URI valide au format http://schemas.microsoft.com/email.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

SameAsIncoming

Facultatif

System.Management.Automation.SwitchParameter

Indique que le type de revendication spécifié dans le paramètre IncomingClaimType est utilisé pour le paramètre LocalClaimType.

Description détaillée

L'applet de commande New-SPClaimTypeMapping crée une règle de mappage de revendications pour un fournisseur d'identité du service d'émission de jeton de sécurité (STS).

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE 1----------------------------

Code de copie
$map1 = New-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress" -IncomingClaimTypeDisplayName "EmailAddress" -SameAsIncoming
Code de copie
$map2 = New-SPClaimTypeMapping -IncomingClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/nameidentifier" -IncomingClaimTypeDisplayName "PUID" -LocalClaimType "http://schemas.xmlsoap.org/ws/2005/05/identity/claims/thumbprint"
Code de copie
New-SPTrustedIdentityTokenIssuer -Name "LiveIDSTS" -Description "LiveID Provider" -Realm "urn:domain.company.com" -ImportTrustCertificate $cert -ClaimsMappings $map1[,$map2..] -SignInUrl "https://login.live.com/login.srf" -IdentifierClaim $map2.InputClaimType

Cet exemple crée un mappage de revendications d'un jeton entrant vers un jeton SharePoint.

Voir aussi

Référence

Add-SPClaimTypeMapping
Remove-SPClaimTypeMapping

Historique des modifications


New-SPManagedAccount
Voir aussi Exemple
[image]

Inscrit un nouveau compte géré.

New-SPManagedAccount [-Credential] <PSCredential> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Credential

Requis

System.Management.Automation.PSCredential

Indique l'objet Credential qui spécifie les informations d'identification du nouveau compte géré. Si vous utilisez Credential, vous ne pouvez pas spécifier Username et Password.

Password

Requis

System.Security.SecureString

Spécifie le mot de passe de l'utilisateur spécifié dans Username. Si vous utilisez Credential, vous ne pouvez pas spécifier Username et Password.

Username

Requis

System.String

Spécifie le nom d'utilisateur du nouveau compte géré. Si vous utilisez Credential, vous ne pouvez pas spécifier Username et Password.

Le type doit être un nom d'utilisateur valide, au format domaine\nomutilisateur.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPManagedAccount inscrit un nouveau compte géré pour les paramètres Credential ou Username et Password spécifiés.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
$cred = Get-Credential
Code de copie
New-SPManagedAccount -Credential $cred

Cet exemple ajoute un nouveau compte géré à la batterie en utilisant les informations d'identification affichées.

Voir aussi

Référence

Get-SPManagedAccount
Set-SPManagedAccount
Remove-SPManagedAccount

Historique des modifications


New-SPManagedPath
Voir aussi Exemple
[image]

Crée un nouveau chemin d'accès géré pour l'application Web donnée pour toutes les collections de sites d'en-tête d'hôte.

New-SPManagedPath [-RelativeURL] <String> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Explicit <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
New-SPManagedPath [-RelativeURL] <String> -HostHeader <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Explicit <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

RelativeURL

Requis

System.String

Spécifie l'URL relative du nouveau chemin d'accès géré.

Le type doit être une URL partielle valide telle que site ou sites/teams/..

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le groupe d'applications Web auquel ce chemin d'accès doit être ajouté.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-5678-0987645a.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Explicit

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si le chemin d'accès géré est explicite ou générique.

Si ce paramètre n'est pas spécifié, le chemin d'accès géré est générique.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

RelativeURL

Requis

System.String

Spécifie l'URL relative du nouveau chemin d'accès géré.

Le type doit être une URL partielle valide telle que site ou sites/teams/..

HostHeader

Requis

System.Management.Automation.SwitchParameter

Si ce paramètre est spécifié, le chemin d'accès géré s'applique à toutes les collections de sites d'en-tête d'hôte.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Explicit

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si le chemin d'accès géré est explicite ou générique.

Si ce paramètre n'est pas spécifié, le chemin d'accès géré est générique.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPManagedPath ajoute un nouveau chemin d'accès géré à une application Web donnée ou à utiliser avec toutes les collections de sites d'en-tête d'hôte. Si le commutateur HostHeader est spécifié, le chemin d'accès géré est partagé entre toutes les collections de sites d'en-tête d'hôte. Sinon, une application Web doit être spécifiée pour la création de ce chemin d'accès. L'URL relative est une URL partielle représentant le chemin d'accès géré. La barre oblique (/) permet de définir la racine. Si le paramètre Explicit n'est pas spécifié, le nouveau chemin d'accès géré est un chemin contenant des caractères génériques.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
New-SPManagedPath "Teams" -WebApplication "http://somesite"

Cet exemple crée un chemin d'accès géré Teams pour une application Web donnée (http://somesite).

Voir aussi

Référence

Get-SPManagedPath
Remove-SPManagedPath

Historique des modifications


New-SPTrustedIdentityTokenIssuer
Voir aussi Exemple
[image]

Crée un fournisseur d'identité dans la batterie.

New-SPTrustedIdentityTokenIssuer -ClaimsMappings <SPClaimMappingPipeBind[]> -Description <String> -IdentifierClaim <String> -Name <String> -Realm <String> -SignInUrl <String> [-AssignmentCollection <SPAssignmentCollection>] [-ClaimProvider <SPClaimProviderPipeBind>] [-ImportTrustCertificate <X509Certificate2>] [-UseWReply <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

ClaimsMappings

Requis

Microsoft.SharePoint.PowerShell.SPClaimMappingPipeBind[]

Spécifie le mappage des revendications du jeton d'origine vers le jeton SharePoint.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de règle de mappage des revendications valide (par exemple Email) ou une instance d'un objet SPClaimMapping valide.

Description

Requis

System.String

Spécifie une description pour le nouveau fournisseur d'identité.

Le type doit être une chaîne valide, par exemple LiveID STS.

IdentifierClaim

Requis

System.String

Indique quel type de revendication provenant du service d'émission de jeton de sécurité approuvé sera utilisé pour le nouveau fournisseur d'identité.

Le type doit être un type de revendication valide provenant du service d'émission de jeton de sécurité approuvé, par exemple http://schemas.microsoft.com/2007/05/Claims/Puid.

Name

Requis

System.String

Spécifie le nom du nouveau fournisseur d'identité.

Le type doit être un nom de fournisseur d'identité valide, par exemple LiveIDSTS.

Realm

Requis

System.String

Spécifie le domaine, ou partition de ressource, associé à cette approbation.

Le type doit être un nom de domaine valide, par exemple MD_REALM.

SignInUrl

Requis

System.String

Spécifie les URL de connexion pour ce fournisseur d'identité STS approuvé.

Le type doit être une URL valide au format http://int.live.com.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ClaimProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind

Spécifie le fournisseur d'identité STS qui peut résoudre et rechercher les demandes pour le sélecteur de personnes basé sur des revendications.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'identité valide (par exemple, MyIDprovider1) ou une instance d'un objet SPIdentityProvider valide.

ImportTrustCertificate

Facultatif

System.Security.Cryptography.X509Certificates.X509Certificate2

Spécifie l'objet certificat X.509 de la batterie de serveurs du fournisseur d'authentification de confiance.

Le type doit être un nom de certificat X.509 valide comme Certificate1.

UseWReply

Facultatif

System.Management.Automation.SwitchParameter

Inclut WReply avec la demande de jeton. WReply est une URL dans la partie de confiance vers laquelle le demandeur est redirigé à l'issue du traitement de la déconnexion.

Description détaillée

L'applet de commande New-SPTrustedIdentityTokenIssuer crée un fournisseur d'identité dans la batterie. Cet objet est créé et utilisé uniquement pour définir ce type de fournisseur d'identité dans une application Web. Le type de revendication spécifié ne peut pas être de type NTLM, Classic NTLM, Negotiate ni Classic Negotiate. Pour le fournisseur d'appartenances et de rôles ASP.NET, aucun objet n'est rendu persistant. Pour les fournisseurs d'identité du service d'émission de jeton de sécurité (STS), cette applet de commande crée et rend l'objet de fournisseur d'identité persistant dans l'objet SPFarm.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

----------------------- EXEMPLE---------------------------
Code de copie
New-SPTrustedIdentityTokenIssuer -Name "LiveIDSTS" - Description "LiveID STS" -Certificate (Get-ChildItem"cert:Certificates (LocalComputer)\Personal\Certificates -Name "LiveID Cert") -SignInUrl http://int.contoso.com/ -IdentifierClaim "http://schemas.contoso.com/2007/05/Claims/Puid"
Code de copie
Set -SPWebApplication http://contoso.com -IdentityProvider (Get-SPTrustedIdentityTokenIssuer "LiveIDSTS")

Cet exemple crée un nouveau fournisseur d'identité dans la batterie nommée LiveIDSTS.

Voir aussi

Référence

Get-SPTrustedIdentityTokenIssuer
Set-SPTrustedIdentityTokenIssuer
Remove-SPTrustedIdentityTokenIssuer

Historique des modifications


New-SPTrustedRootAuthority
Voir aussi Exemple
[image]

Crée une autorité racine de confiance.

New-SPTrustedRootAuthority [-Name] <String> -Certificate <X509Certificate2> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Name

Requis

System.String

Spécifie le nom de l'autorité racine de confiance à créer.

Le type doit être un nom valide d'autorité racine de confiance, comme WFEFarm1.

Certificate

Requis

System.Security.Cryptography.X509Certificates.X509Certificate2

Spécifie le certificat X.509 de l'autorité racine de confiance.

Le type doit être un nom de certificat X.509 valide comme Certificate1.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPTrustedRootAuthority créé une autorité racine de confiance. Si un fichier de certificat est utilisé, il doit comporter uniquement un certificat X509 sans clés privées, sinon une exception est émise.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$cert = Get-PfxCertificate C:\LiveIDSigningCert.pfx
New-SPTrustedRootAuthority -Name "WFEFarm1" -Certificate $cert

Cet exemple crée un autorité racine de confiance WFEFarm1.

Voir aussi

Référence

Get-SPTrustedRootAuthority
Set-SPTrustedRootAuthority
Remove-SPTrustedRootAuthority

Historique des modifications


New-SPTrustedServiceTokenIssuer
Voir aussi Exemple
[image]

Crée une approbation avec la batterie SharePoint.

New-SPTrustedServiceTokenIssuer [-Name] <String> -Certificate <X509Certificate2> [-AssignmentCollection <SPAssignmentCollection>] [-Description <String>]

Paramètres

Paramètre Requis Type Description

Name

Requis

System.String

Spécifie le nom de l'approbation.

Le type doit être un nom valide d'émetteur de service approuvé, par exemple, WFEFarmTrust1.

Certificate

Requis

System.Security.Cryptography.X509Certificates.X509Certificate2

Le type doit être un nom de certificat X.509 valide ; par exemple, Certificate1.

Spécifie l'objet de certificat X.509 de la batterie de fournisseurs d'identité approuvés.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description

Facultatif

System.String

Spécifie une description pour l'approbation.

Le type doit être une chaîne valide, par exemple WFE Farm Trust1.

Description détaillée

L'applet de commande New-SPTrustedServiceTokenIssuer crée une approbation avec une batterie SharePoint. Si un fichier de certificat est utilisé, il doit contenir un seul certificat X509 sans clé privée. Dans le cas contraire, une exception est déclenchée.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
$cert = Get-PfxCertificate C:\LiveIDSigningCert.pfx
New-SPTrustedServiceTokenIssuer -Name "WFEFarm1" -Description "WFE Farm 1" -Certificate $cert

Cet exemple illustre la manière de créer une nouvelle approbation de batterie SharePoint à l'aide du certificat approuvé d'un fichier.

Voir aussi

Référence

Get-SPTrustedServiceTokenIssuer
Set-SPTrustedServiceTokenIssuer
Remove-SPTrustedServiceTokenIssuer

Historique des modifications


Remove-SPClaimProvider
Voir aussi Exemple
[image]

Désinscrit un fournisseur de revendications.

Remove-SPClaimProvider [-Identity] <SPClaimProviderPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind

Spécifie le fournisseur de revendications à désinscrire.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur de revendications valide (par exemple, MyClaimProvider1) ou une instance d'un objet SPClaimProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Remove-SPClaimProvider désinscrit un fournisseur de revendications. Si le fournisseur de revendications désinscrit a été affecté à un émetteur du jeton à l'identité de confiance, l'émetteur du jeton de confiance utilisera le fournisseur de revendications (système) par défaut.

Pour connaître les autorisations et les informations les plus récentes sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Remove - SPClaimProvider -Identity "12345678-90ab-cdef-1234-567890bcdefgh"

Cet exemple supprime un fournisseur de revendications de la batterie de serveurs.

Voir aussi

Référence

Get-SPClaimProvider
New-SPClaimProvider
Set-SPClaimProvider

Historique des modifications


Remove-SPClaimTypeMapping
Voir aussi Exemple
[image]

Supprime une règle de mappage de type de revendications pour un fournisseur d'identité du service d'émission de jeton de sécurité (STS).

Remove-SPClaimTypeMapping [-Identity] <SPClaimMappingPipeBind> [-TrustedIdentityTokenIssuer] <SPTrustedIdentityTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPClaimMappingPipeBind

Spécifie le mappage de revendications à supprimer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de règle de mappage des revendications valide (par exemple Email) ou une instance d'un objet SPClaimMapping valide.

IdentityProvider

Requis

Microsoft.SharePoint.PowerShell.SPIdentityProviderPipeBind

Spécifie le fournisseur d'identité STS approuvé de la batterie contenant la règle de mappage de revendications.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'identité valide (par exemple, LiveIDSTS) ou une instance d'un objet SPIdentityProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Remove-SPClaimMapping supprime une règle de mappage de type de revendications du fournisseur d'identité STS approuvé d'une batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE-------------------------
Code de copie
Remove-SPClaimMapping "Email" | Get-SPIdentityProvider "LiveIDSTS"

Cet exemple supprime le fournisseur d'identité appelé LiveIDSTS.

Voir aussi

Référence

Add-SPClaimTypeMapping
New-SPClaimTypeMapping

Historique des modifications


Remove-SPManagedAccount
Voir aussi Exemple
[image]

Supprime un enregistrement de compte géré de la batterie de serveurs.

Remove-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Remove-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> -NewPassword <SecureString> [-AssignmentCollection <SPAssignmentCollection>] [-ChangePassword <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou partiel des comptes gérés à extraire.

Le type doit être un nom de compte valide au format Domaine\Utilisateur, ou un GUID au format 1234-3456-09876.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou partiel des comptes gérés à extraire.

Le type doit être un nom de compte valide au format Domaine\Utilisateur, ou un GUID au format 1234-3456-09876.

NewPassword

Requis

System.Security.SecureString

Spécifie une chaîne sécurisée pour le nouveau mot de passe (à savoir, $MySecureString). Fonctionne en association avec le paramètre ChangePassword.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ChangePassword

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si un mot de passe doit être modifié. Fonctionne en association avec le paramètre NewPassword. Une fois la valeur du paramètre ChangePassword définie, une valeur de chaîne sécurisée doit être spécifiée pour le paramètre NewPassword (à savoir, $MySecureString).

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPManagedAccount supprime un enregistrement de compte de la base de données de configuration dans la batterie de serveurs.

Types d'entrée

Types retournés

Exemple

----------------------EXEMPLE-------------------
Code de copie
Remove-SPManagedAccount -Identity DOMAIN\ServiceAcct

Cet exemple supprime le compte géré DOMAIN\ServiceAcct de la batterie de serveurs.

Voir aussi

Référence

Get-SPManagedAccount
New-SPManagedAccount
Set-SPManagedAccount

Historique des modifications


Remove-SPManagedPath
Voir aussi Exemple
[image]

Supprime le chemin d'accès géré spécifié de l'en-tête d'hôte ou de l'application Web spécifiée.

Remove-SPManagedPath [-Identity] <SPPrefixPipeBind> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Remove-SPManagedPath [-Identity] <SPPrefixPipeBind> -HostHeader <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPPrefixPipeBind

Spécifie le nom du chemin d'accès géré à supprimer. Par exemple, dans l'URL http://nomdusite/sites/site1, « sites » correspond au nom du chemin d'accès géré.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.WebApplicationPipeBind

Spécifie l'identité de l'application Web qui héberge le chemin d'accès géré à supprimer. Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web valide (par exemple, WebApplication1212), ou un nom valide au format WebApp2423.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPPrefixPipeBind

Spécifie le nom du chemin d'accès géré à supprimer. Par exemple, dans l'URL http://nomdusite/sites/site1, « sites » correspond au nom du chemin d'accès géré.

HostHeader

Requis

System.Management.Automation.SwitchParameter

Spécifie que le paramètre Identity est un chemin d'accès géré d'en-tête d'hôte.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPManagedPath supprime le chemin d'accès géré spécifié de l'en-tête d'hôte ou de l'application Web spécifiée grâce au paramètre Identity. Le paramètre Identity doit être l'URL partielle du chemin d'accès géré à supprimer.

Si vous utilisez des en-têtes d'hôte, spécifiez le paramètre HostHeader. Pour supprimer un chemin d'accès géré d'un en-tête d'hôte, spécifiez le commutateur HostHeader. Sinon, spécifiez l'application Web qui contient le chemin d'accès géré à supprimer.

Types d'entrée

Types retournés

Exemple

----------------------EXEMPLE 1----------------------------
Code de copie
Remove-SPManagedPath "sites" -HostHeader

Cet exemple supprime le chemin d'accès géré sites de la liste des chemins d'accès gérés HostHeader.

Suivant le niveau de confirmation du système local, l'exemple précédent peut afficher une invite de confirmation avant de s'exécuter.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPWebApplication | Remove-SPManagedPath "personal" -confirm:$false

Cet exemple supprime le chemin d'accès géré personal de toutes les applications Web de la batterie de serveurs. Cette commande n'affiche pas d'invite de confirmation.

Voir aussi

Référence

Get-SPManagedPath
New-SPManagedPath

Historique des modifications


Remove-SPTrustedIdentityTokenIssuer
Voir aussi Exemple
[image]

Supprime un fournisseur d'identité de service d'émission de jeton de sécurité (STS) de la batterie de serveurs.

Remove-SPTrustedIdentityTokenIssuer [-Identity] <SPTrustedIdentityTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Spécifie le fournisseur d'identité à supprimer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'identité valide (par exemple, LiveID STS) ou une instance d'objet SPIdentityProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPTrustedIdentityTokenIssuer supprime un fournisseur d'identité de service d'émission de jeton de sécurité (STS) de la batterie de serveurs.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE------------------------
Code de copie
Remove-SPTrustedIdentityTokenIssuer "LiveIDSTS"

Cet exemple supprime un fournisseur d'identité appelé LiveIDSTS de la batterie de serveurs.

Voir aussi

Référence

Get-SPTrustedIdentityTokenIssuer
Set-SPTrustedIdentityTokenIssuer
New-SPTrustedIdentityTokenIssuer

Historique des modifications


Remove-SPTrustedRootAuthority
Voir aussi Exemple
[image]

Supprime une autorité racine de confiance.

Remove-SPTrustedRootAuthority [-Identity] <SPTrustedRootAuthorityPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTrustedRootAuthorityPipeBind

Spécifie l'autorité racine de confiance à supprimer.

Le type doit correspondre à un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, à un nom valide d'autorité racine de confiance (par exemple, WFEFarm1) ou à une instance d'un objet SPTrustedRootAuthority valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Remove-SPTrustedRootAuthority supprime une autorité racine de confiance d'un magasin de certificats de signature.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Remove - SPTrustedRootAuthority -Name "WFEFarm1"

Cet exemple supprime l'autorité racine de confiance WFEFarm1.

Voir aussi

Référence

New-SPTrustedRootAuthority
Get-SPTrustedRootAuthority
Set-SPTrustedRootAuthority

Historique des modifications


Remove-SPTrustedServiceTokenIssuer
Voir aussi Exemple
[image]

Supprime l'objet qui représente l'approbation de la batterie de serveurs.

Remove-SPTrustedServiceTokenIssuer [-Identity] <SPTrustedServiceTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTrustedServiceTokenIssuerPipeBind

Spécifie l'émetteur du jeton du service de confiance à supprimer.

Le type doit correspondre à un GUID valide sous la forme 12345678-90ab-cdef-1234-567890bcdefgh, à un nom valide d'émetteur du jeton du service de confiance (par exemple, WFEFarm1) ou à une instance d'objet SPTrustedRootAuthority valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Remove-SPTrustedServiceTokenIssuer supprime l'objet qui représente l'approbation de la batterie de serveurs.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Remove - SPTrustedServiceTokenIssuer "WFE Farm 2"

Cet exemple supprime l'émetteur du jeton du service de confiance WFE Farm 2.

Voir aussi

Référence

Set-SPTrustedServiceTokenIssuer
New-SPTrustedServiceTokenIssuer
Get-SPTrustedServiceTokenIssuer

Historique des modifications


Repair-SPManagedAccountDeployment
Exemple
[image]

Répare le déploiement local des informations d'identification des comptes gérés.

Repair-SPManagedAccountDeployment [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Repair-SPManagedAccountDeployment pour réparer le déploiement local des informations d'identification des comptes gérés sur un serveur dans les rares cas où les informations d'identification des services de comptes gérés sont dans un état défectueux. Elle permet de redéployer chaque service local et les informations d'identification des applications Web, puis de déterminer si le mot de passe est incorrect sur le serveur. Elle affiche des avertissements en conséquence. L'applet de commande Repair-SPManagedAccountDeployment ne doit pas être utilisée dans le cadre d'un processus de mise à jour de routine d'informations d'identification, mais en tant que première étape de dépannage et ce particulièrement si les services du serveur ne démarrent pas lorsque d'autres services de serveurs fonctionnent correctement.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------

Code de copie
Repair-SPManagedAccountDeployment

Cet exemple répare le déploiement d'informations d'identification sur tous les services et l'application Web associés au(x) compte(s) géré(s) sur le serveur local.

Historique des modifications


Revoke-SPObjectSecurity
Voir aussi Exemple
[image]

Supprime un principal de sécurité d'un objet SPObjectSecurity.

Revoke-SPObjectSecurity [-Identity] <SPObjectSecurity> [-Principal] <SPClaim> [[-Rights] <String[]>] [-AssignmentCollection <SPAssignmentCollection>]
Revoke-SPObjectSecurity [-Identity] <SPObjectSecurity> -All <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.Administration.AccessControl.SPObjectSecurity

Spécifie l'objet SPObjectSecurity duquel le principal de sécurité est supprimé. Vous pouvez utiliser l'applet de commande Get-SPServiceApplicationSecurity pour obtenir un objet SPObjectSecurity.

Principal

Requis

Microsoft.SharePoint.Administration.Claims.SPClaim

Spécifie le principal pour lequel les droits sont supprimés.

Le type doit être un nom de principal valide, comme Full Control.

Rights

Facultatif

System.String[]

Spécifie les droits du principal à révoquer.

Le type doit être un tableau de chaînes valide qui représente les droits du principal à révoquer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.Administration.AccessControl.SPObjectSecurity

Spécifie l'objet SPObjectSecurity duquel le principal de sécurité est supprimé. Vous pouvez utiliser l'applet de commande Get-SPServiceApplicationSecurity pour obtenir un objet SPObjectSecurity.

All

Requis

System.Management.Automation.SwitchParameter

Spécifie que tous les principaux de sécurité sont supprimés de l'objet SPObjectSecurity spécifié.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Revoke-SPObjectSecurity supprime un principal de sécurité, comme un utilisateur, d'un objet SPObjectSecurity. Un objet SPObjectSecurity est un objet commun utilisé pour représenter la liste de contrôle d'accès (ACL) de sécurité d'objets administratifs SharePoint, et en particulier d'applications de service.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$security = Get-SPServiceApplicationSecurity $serviceApp -Admin
Revoke-SPObjectSecurity $security "domain\user"
Set-SPServiceApplicationSecurity $serviceApp -Admin $security

Cet exemple récupère l'objet SPObjectSecurity correspondant à la liste ACL de l'administrateur sur une application de service et supprime un utilisateur de cette liste ACL. Suppression d'un administrateur pour l'application de service $serviceApp.

Voir aussi

Référence

Grant-SPObjectSecurity
Get-SPServiceApplicationSecurity

Historique des modifications


Set-SPClaimProvider
Voir aussi Exemple
[image]

Met à jour l'inscription d'un fournisseur de revendications.

Set-SPClaimProvider [-Identity] <SPClaimProviderPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Default <SwitchParameter>] [-Enabled <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind

Spécifie le fournisseur de revendications à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur de revendications valide (par exemple, MyClaimProvider1) ou une instance d'un objet SPClaimProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Default

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que le fournisseur de revendications s'applique à toutes les applications et zones Web.

Enabled

Facultatif

System.Management.Automation.SwitchParameter

Active le fournisseur de revendications.

Description détaillée

L'applet de commande Set-SPClaimProvider met à jour l'inscription d'un fournisseur de revendications.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Set-SPClaimProvider -Identity "12345678-90ab-cdef-1234-567890bcdefgh"

Cet exemple désactive le fournisseur de revendications spécifié.

Voir aussi

Référence

Get-SPClaimProvider
Remove-SPClaimProvider
New-SPClaimProvider

Historique des modifications


Set-SPManagedAccount
Voir aussi Exemple
[image]

Configure le compte géré.

Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-EmailNotification <Int32>] [-PreExpireDays <Int32>] [-Schedule <String>] [-WhatIf [<SwitchParameter>]]
Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-AutoGeneratePassword <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-EmailNotification <Int32>] [-PreExpireDays <Int32>] [-Schedule <String>] [-WhatIf [<SwitchParameter>]]
Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> -Password <SecureString> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-EmailNotification <Int32>] [-PreExpireDays <Int32>] [-Schedule <String>] [-WhatIf [<SwitchParameter>]]
Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> -ConfirmPassword <SecureString> -NewPassword <SecureString> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-EmailNotification <Int32>] [-PreExpireDays <Int32>] [-Schedule <String>] [-SetNewPassword <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Set-SPManagedAccount [-Identity] <SPManagedAccountPipeBind> -ExistingPassword <SecureString> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-EmailNotification <Int32>] [-PreExpireDays <Int32>] [-Schedule <String>] [-UseExistingPassword <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou le nom partiel des comptes gérés à récupérer.

Le type doit être un nom de compte valide au format Domaine\Utilisateur, ou un GUID au format 1234-3456-09876.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

EmailNotification

Facultatif

System.Int32

Spécifie le nombre de jours avant la modification du mot de passe pour démarrer les notifications par courrier électronique.

La valeur par défaut est 5.

PreExpireDays

Facultatif

System.Int32

Spécifie le nombre de jours avant l'expiration pour planifier la modification du mot de passe.

La valeur par défaut est 2.

Schedule

Facultatif

System.String

Spécifie le nouveau calendrier pour l'exécution de la tâche de modification du mot de passe.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou le nom partiel des comptes gérés à récupérer.

Le type doit être un nom de compte valide au format Domaine\Utilisateur, ou un GUID au format 1234-3456-09876.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AutoGeneratePassword

Facultatif

System.Management.Automation.SwitchParameter

Génère automatiquement un nouveau mot de passe.

Le type doit être l'une des valeurs suivantes :

- True

- False

La valeur par défaut est False.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

EmailNotification

Facultatif

System.Int32

Spécifie le nombre de jours avant la modification du mot de passe pour démarrer les notifications par courrier électronique.

La valeur par défaut est 5.

PreExpireDays

Facultatif

System.Int32

Spécifie le nombre de jours avant l'expiration pour planifier la modification du mot de passe.

La valeur par défaut est 2.

Schedule

Facultatif

System.String

Spécifie le nouveau calendrier pour l'exécution de la tâche de modification du mot de passe.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou le nom partiel des comptes gérés à récupérer.

Le type doit être un nom de compte valide au format Domaine\Utilisateur, ou un GUID au format 1234-3456-09876.

Password

Requis

System.Security.SecureString

Définit un mot de passe pour le compte géré.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

EmailNotification

Facultatif

System.Int32

Spécifie le nombre de jours avant la modification du mot de passe pour démarrer les notifications par courrier électronique.

La valeur par défaut est 5.

PreExpireDays

Facultatif

System.Int32

Spécifie le nombre de jours avant l'expiration pour planifier la modification du mot de passe.

La valeur par défaut est 2.

Schedule

Facultatif

System.String

Spécifie le nouveau calendrier pour l'exécution de la tâche de modification du mot de passe.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

4

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou le nom partiel des comptes gérés à récupérer.

Le type doit être un nom de compte valide au format Domaine\Utilisateur, ou un GUID au format 1234-3456-09876.

ConfirmPassword

Requis

System.Security.SecureString

Confirme le nouveau mot de passe pour ce compte géré.

NewPassword

Requis

System.Security.SecureString

Définit un nouveau mot de passe pour le compte géré.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

EmailNotification

Facultatif

System.Int32

Spécifie le nombre de jours avant la modification du mot de passe pour démarrer les notifications par courrier électronique.

La valeur par défaut est 5.

PreExpireDays

Facultatif

System.Int32

Spécifie le nombre de jours avant l'expiration pour planifier la modification du mot de passe.

La valeur par défaut est 2.

Schedule

Facultatif

System.String

Spécifie le nouveau calendrier pour l'exécution de la tâche de modification du mot de passe.

SetNewPassword

Facultatif

System.Management.Automation.SwitchParameter

Définit le mot de passe sur la nouvelle valeur passée et modifie la valeur dans AD DS.

Le type doit être l'une des valeurs suivantes :

- True

- False

La valeur par défaut est False.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

5

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPManagedAccountPipeBind

Spécifie le nom complet ou le nom partiel des comptes gérés à récupérer.

Le type doit être un nom de compte valide au format Domaine\Utilisateur, ou un GUID au format 1234-3456-09876.

ExistingPassword

Requis

System.Security.SecureString

Définit le mot de passe de ce compte géré sur une valeur existante qui a déjà été modifiée dans Active Directory Domain Services (AD DS).

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

EmailNotification

Facultatif

System.Int32

Spécifie le nombre de jours avant la modification du mot de passe pour démarrer les notifications par courrier électronique.

La valeur par défaut est 5.

PreExpireDays

Facultatif

System.Int32

Spécifie le nombre de jours avant l'expiration pour planifier la modification du mot de passe.

La valeur par défaut est 2.

Schedule

Facultatif

System.String

Spécifie le nouveau calendrier pour l'exécution de la tâche de modification du mot de passe.

UseExistingPassword

Facultatif

System.Management.Automation.SwitchParameter

Définit le mot de passe sur une nouvelle valeur passée et qui a déjà été modifiée dans AD DS.

Le type doit être l'une des valeurs suivantes :

- True

- False

La valeur par défaut est False.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPManagedAccount définit les propriétés du compte géré donné.

Vous pouvez utiliser cette applet de commande pour modifier les paramètres de notification et d'expiration du mot de passe pour le compte géré : utilisez le jeu de paramètres par défaut. Vous pouvez également utiliser cette applet de commande pour modifier le mot de passe du compte géré sur des mots de passe générés automatiquement à un moment défini : utilisez le jeu de paramètres qui comprend le paramètre AutoGeneratePassword. Vous pouvez aussi utiliser cette applet de commande pour modifier le mot de passe du compte géré sur une nouvelle valeur connue de l'administrateur : utilisez le jeu de paramètres comprenant le paramètre SetNewPassword. Enfin, vous pouvez utiliser cette applet de commande pour modifier le mot de passe du compte géré sur une valeur existante qui a déjà été modifiée dans Active Directory Domain Services (AD DS) : utilisez le jeu de paramètres qui comprend le paramètre UseExistingPassword.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
$m = Get-SPManagedAccount -Identity "DOMAINx\UserY"
Code de copie
Set-SPManagedAccount -Identity $m -AutoGeneratePassword true

Cet exemple affiche un compte géré explicite, le cas échéant, et tente ensuite de le mettre à jour pour utiliser des mots de passe générés automatiquement.

Voir aussi

Référence

Get-SPManagedAccount
New-SPManagedAccount
Remove-SPManagedAccount

Historique des modifications


Set-SPSecurityTokenServiceConfig
Voir aussi Exemple
[image]

Met à jour les paramètres du fournisseur d'identité STS SharePoint.

Set-SPSecurityTokenServiceConfig [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-FormsTokenLifetime <Int32>] [-ImportSigningCertificate <X509Certificate2>] [-MaxLogonTokenCacheItems <Int32>] [-MaxServiceTokenCacheItems <Int32>] [-ServiceTokenCacheExpirationWindow <Int32>] [-ServiceTokenLifetime <Int32>] [-WhatIf [<SwitchParameter>]] [-WindowsTokenLifetime <Int32>]
Set-SPSecurityTokenServiceConfig -SigningCertificateThumbprint <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-FormsTokenLifetime <Int32>] [-MaxLogonTokenCacheItems <Int32>] [-MaxServiceTokenCacheItems <Int32>] [-ServiceTokenCacheExpirationWindow <Int32>] [-ServiceTokenLifetime <Int32>] [-SigningCertificateStoreName <String>] [-WhatIf [<SwitchParameter>]] [-WindowsTokenLifetime <Int32>]

Paramètres

1

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

FormsTokenLifetime

Facultatif

System.Int32

Spécifie la durée d'expiration, en minutes, des jetons émis aux fournisseurs de rôles et aux fournisseurs d'appartenances (Membership Provider) ASP.NET. La valeur par défaut est 1380.

Le type doit correspondre à un entier valide.

ImportSigningCertificate

Facultatif

System.Security.Cryptography.X509Certificates.X509Certificate2

Spécifie l'objet de certificat X.509 de la batterie de fournisseurs d'identité approuvés.

Le type doit être un nom de certificat X.509 valide ; par exemple, Certificate1.

MaxLogonTokenCacheItems

Facultatif

System.Int32

Spécifie le nombre maximum d'entrées du cache de jeton de connexion en mémoire. La valeur par défaut est 10 000 entrées.

Le type doit correspondre à un entier valide.

MaxServiceTokenCacheItems

Facultatif

System.Int32

Spécifie le nombre maximum d'entrées du cache de jeton de service en mémoire. La valeur par défaut est 10 000 entrées.

Le type doit correspondre à un entier valide.

ServiceTokenCacheExpirationWindow

Facultatif

System.Int32

Spécifie l'intervalle, en minutes, de renouvellement automatique du jeton dans le cache. La valeur par défaut est 2 minutes.

Le type doit correspondre à un entier valide.

ServiceTokenLifetime

Facultatif

System.Int32

Spécifie la durée d'expiration, en minutes, du cache de service d'émission de jeton de sécurité. La valeur par défaut est 15 minutes.

Le type doit correspondre à un entier valide.

WindowsTokenLifetime

Facultatif

System.Int32

Spécifie la durée d'expiration, en minutes, des jetons émis aux utilisateurs de Windows. La valeur par défaut est 1 380 minutes.

Le type doit correspondre à un entier valide.

2

Paramètre

Requis

Type

Description

SigningCertificateThumbprint

Requis

System.String

Spécifie l'empreinte du certificat de signature.

Le type doit être une identité valide d'un certificat de signature, par exemple, 2796BAE63F1801E277261BA0D77770028F20EEE4.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

FormsTokenLifetime

Facultatif

System.Int32

Spécifie la durée d'expiration, en minutes, des jetons émis aux fournisseurs de rôles et aux fournisseurs d'appartenances (Membership Provider) ASP.NET. La valeur par défaut est 1380.

Le type doit correspondre à un entier valide.

MaxLogonTokenCacheItems

Facultatif

System.Int32

Spécifie le nombre maximum d'entrées du cache de jeton de connexion en mémoire. La valeur par défaut est 10 000 entrées.

Le type doit correspondre à un entier valide.

MaxServiceTokenCacheItems

Facultatif

System.Int32

Spécifie le nombre maximum d'entrées du cache de jeton de service en mémoire. La valeur par défaut est 10 000 entrées.

Le type doit correspondre à un entier valide.

ServiceTokenCacheExpirationWindow

Facultatif

System.Int32

Spécifie l'intervalle, en minutes, de renouvellement automatique du jeton dans le cache. La valeur par défaut est 2 minutes.

Le type doit correspondre à un entier valide.

ServiceTokenLifetime

Facultatif

System.Int32

Spécifie la durée d'expiration, en minutes, du cache de service d'émission de jeton de sécurité. La valeur par défaut est 15 minutes.

Le type doit correspondre à un entier valide.

SigningCertificateStoreName

Facultatif

System.String

Spécifie le magasin de certificats dans lequel le certificat de signature réside. Le magasin d'identités d'un fournisseur d'identités peut être une table de base de données SQL, un AD DS ou un AD LDS.

Le type doit être une identité valide de magasin de certificats de signature, par exemple IdentityStore1.

WindowsTokenLifetime

Facultatif

System.Int32

Spécifie la durée d'expiration, en minutes, des jetons émis aux utilisateurs de Windows. La valeur par défaut est 1 380 minutes.

Le type doit correspondre à un entier valide.

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Set-SPSecurityTokenServiceConfig met à jour les paramètres du fournisseur d'identité STS SharePoint. Si un fichier de certificat est utilisé, le certificat doit être un certificat X509 avec des clés privées. Dans le cas contraire, une exception est déclenchée.

Remarque :
Cette applet de commande fonctionne uniquement avec des certificats pouvant être exportés. Pour créer un certificat utilisable avec cette applet de commande, spécifiez la partie X509KeyStorageFlags.Exportable dans le paramètre keyStorageFlags du constructeur d'objets x509Certificate2.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
Set-SPSecurityTokenServiceConfig -SigningCertificateThumbprint "2796BAE63F1801E277261BA0D77770028F20EEE4"

Cet exemple met à jour le certificat de signature du fournisseur d'identité STS SharePoint avec un certificat ayant été déployé dans un magasin de certificats.

------------------EXEMPLE 2------------------
Code de copie
$stsCert = New-Object System.Security.Cryptography.X509Certificates.X509Certificate2 "c:\sts.pfx","a",20
Code de copie
Set-SPSecurityTokenServiceConfig -ImportSigningCertificate $stsCert

Cet exemple importe le certificat de signature pour le fournisseur d'identités STS SharePoint.

Voir aussi

Référence

Get-SPSecurityTokenServiceConfig

Historique des modifications


Set-SPServiceApplicationSecurity
Voir aussi Exemple
[image]

Met à jour l'objet SPObjectSecurity d'une application de service.

Set-SPServiceApplicationSecurity [-Identity] <SPServiceApplicationPipeBind> [-ObjectSecurity] <SPObjectSecurity> [-Admin <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service contenant l'objet SPObjectSecurity à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application de service valide (par exemple, ServiceApp1) ou une instance d'un objet SPServiceApplication valide.

ObjectSecurity

Requis

Microsoft.SharePoint.Administration.AccessControl.SPObjectSecurity

Spécifie l'objet SPObjectSecurity à mettre à jour.

Admin

Facultatif

System.Management.Automation.SwitchParameter

Met à jour la liste de contrôle d'accès contenant la liste des administrateurs de l'application de service.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Set-SPServiceApplicationSecurity met à jour un objet de sécurité pour l'application de service spécifiée. Utilisez cette applet de commande avec les applets de commande Grant-SPObjectSecurity et Get-SPServiceApplicationSecurity pour gérer la sécurité d'une application de service.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$security = Get-SPServiceApplicationSecurity $serviceApp -Admin
Grant-SPObjectSecurity $security $principal "Full Control"
Set-SPServiceApplicationSecurity $serviceApp -Admin $security

Cet exemple extrait l'objet SPObjectSecurity correspondant à la liste de contrôle d'accès des administrateurs d'une application de service, puis ajoute un nouvel utilisateur principal à cette liste. Le nouvel utilisateur est un administrateur de l'application de service $serviceApp.

Voir aussi

Référence

Get-SPServiceApplicationSecurity
Grant-SPObjectSecurity
Revoke-SPObjectSecurity

Historique des modifications


Set-SPTrustedIdentityTokenIssuer
Voir aussi Exemple
[image]

Définit les fournisseurs d'identité d'une application Web.

Set-SPTrustedIdentityTokenIssuer [-Identity] <SPTrustedIdentityTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-ClaimProvider <SPClaimProviderPipeBind>] [-ClaimsMappings <SPClaimMappingPipeBind[]>] [-Description <String>] [-ImportTrustCertificate <X509Certificate2>] [-Realm <String>] [-SignInUrl <String>] [-UseWReply <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Spécifie le fournisseur d'identité à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur d'identité valide (par exemple, LiveID STS) ou une instance d'un objet SPIdentityProvider valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ClaimProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind

Spécifie le fournisseur d'identité STS qui peut résoudre et rechercher les demandes pour le sélecteur de personnes basé sur des revendications.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de fournisseur de revendications valide (par exemple, MyIDprovider1) ou une instance d'un objet SPClaimProvider valide.

ClaimsMappings

Facultatif

Microsoft.SharePoint.PowerShell.SPClaimMappingPipeBind[]

Spécifie le mappage des revendications du jeton d'origine vers le jeton SharePoint.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de règle de mappage des revendications valide (par exemple Email) ou une instance d'un objet SPClaimMapping valide.

Description

Facultatif

System.String

Spécifie une description pour le nouveau fournisseur d'identité.

Le type doit être une chaîne valide, par exemple LiveID STS.

ImportTrustCertificate

Facultatif

System.Security.Cryptography.X509Certificates.X509Certificate2

Spécifie l'objet de certificat X.509 de la batterie de fournisseurs d'identité approuvés.

Le type doit être un nom de certificat X.509 valide ; par exemple, Certificate1.

Realm

Facultatif

System.String

Spécifie le domaine, ou partition de ressource, associé à cette approbation.

Le type doit être un nom de domaine valide, par exemple MD_REALM.

SignInUrl

Facultatif

System.String

Spécifie les URL de connexion pour ce fournisseur d'identité STS approuvé.

Le type doit être une URL valide au format http://int.live.com.

UseWReply

Facultatif

System.Management.Automation.SwitchParameter

Inclut une WReply avec le jeton de demande. Wreply est une URL à la partie de confiance vers laquelle le demandeur est redirigé une fois le processus de déconnexion terminé.

Description détaillée

L'applet de commande Set-SPTrustedIdentityTokenIssuer définit les fournisseurs d'identité d'une application Web ou d'une application Web étendue. Pour le fournisseur d'appartenances et de rôles ASP.NET, cette applet de commande modifie le fournisseur d'identité uniquement si le résultat est redirigé sur une variable et passé sur une application Web. Pour les fournisseurs d'identité du service d'émission de jeton de sécurité (STS), cette applet de commande modifie l'objet de fournisseur d'identité persistant dans l'objet SPFarm.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------------EXEMPLE 1----------------------

Code de copie
Set-SPTrustedIdentityTokenIssuer "LiveIDSTS" -Certificate (Get-ChildItem"cert:Certificates (LocalComputer)\Personal\Certificates -Name "LiveID Cert")

Cet exemple définit le fournisseur d'identité sur LiveIDSTS.

-------------------------EXEMPLE 2----------------------

Code de copie
$ip = @( (Get-SPTrustedIdentityTokenIssuer "LiveID STS"), (New-SPTrustedIdentityTokenIssuer -ASPNetMembershipProvider "myMembershipProvider" -ASPNetRoleProvider "myRoleProvider"), (Get-SPTrustedIdentityTokenIssuer "NTLM")) )
New-SPWebApplication http://contoso.com -IdentityProvider $ip

Cet exemple définit le fournisseur d'identité à l'aide des paramètres .ASPNetMembership et Role. Lorsque ces paramètres sont utilisés, une variable doit être définie, sinon les valeurs n'ont aucun effet.

Voir aussi

Référence

Get-SPTrustedIdentityTokenIssuer
New-SPTrustedIdentityTokenIssuer
Remove-SPTrustedIdentityTokenIssuer

Historique des modifications


Set-SPTrustedRootAuthority
Voir aussi Exemple
[image]

Crée une autorité racine de confiance.

Set-SPTrustedRootAuthority [-Identity] <SPTrustedRootAuthorityPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Certificate <X509Certificate2>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTrustedRootAuthorityPipeBind

Spécifie l'autorité racine de confiance à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'autorité racine de confiance valide (par exemple, WFEFarm1) ou une instance d'un objet SPTrustedRootAuthority valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Certificate

Facultatif

System.Security.Cryptography.X509Certificates.X509Certificate2

Spécifie le certificat X.509 de l'autorité racine de confiance.

Le type doit être un nom de certificat X.509 valide comme Certificate1.

Description détaillée

L'applet de commande Set-SPTrustedRootAuthority crée une autorité racine de confiance. Si un fichier de certificat est utilisé, le certificat doit être un certificat X509 avec des clés privées, sinon une exception est émise.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$cert = Get-PfxCertificate C:\LiveIDSigningCert.pfx
Get - SPTrustedRootAuthority -Name "WFEFarm1" | Set- SPTrustedRootAuthority -Certificate $cert

Cet exemple met à jour le certificat de l'autorité racine de confiance WFEFarm1.

Voir aussi

Référence

Remove-SPTrustedRootAuthority
New-SPTrustedRootAuthority
Get-SPTrustedRootAuthority

Historique des modifications


Set-SPTrustedServiceTokenIssuer
Voir aussi Exemple
[image]

Met à jour une approbation avec la batterie.

Set-SPTrustedServiceTokenIssuer [-Identity] <SPTrustedServiceTokenIssuerPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Certificate <X509Certificate2>] [-Description <String>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTrustedServiceTokenIssuerPipeBind

Spécifie l'émetteur de jeton de service approuvé à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'émetteur de jeton de service approuvé (par exemple, WFEFarm1) ou une instance d'un objet SPTrustedRootAuthority valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Certificate

Facultatif

System.Security.Cryptography.X509Certificates.X509Certificate2

Spécifie l'objet de certificat X.509 de la batterie de fournisseurs d'identité approuvés.

Le type doit être un nom de certificat X.509 valide ; par exemple, Certificate1.

Description

Facultatif

System.String

Spécifie une description pour l'approbation.

Le type doit être une chaîne valide, par exemple WFE Farm Trust1.

Description détaillée

L'applet de commande Set-SPTrustedServiceTokenIssuer met à jour une approbation avec une batterie SharePoint. Si un fichier de certificat est utilisé, il doit contenir un seul certificat X509 sans clé privée. Dans le cas contraire une exception est déclenchée.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
$cert = Get-PfxCertificate C:\LiveIDSigningCert.pfx
Set - SPTrustedServiceTokenIssuer "WFEFarm1" - Description "WFE Farm 1" - ImportTrustCertificate $cert

Cet exemple met à jour une approbation de batterie SharePoint à l'aide du certificat approuvé d'un fichier.

------------------EXEMPLE 2------------------
Code de copie
Set - SPTrustedServiceTokenIssuer "WFEFarm1" - Description "WFE Farm 1" -FederationMetadataUrl "https://liveid.com/STS/2007/03/fedmetadata.xml"

Cet exemple met à jour une approbation de batterie SharePoint à l'aide du certificat approuvé de l'URL de terminaison de métadonnées de la fédération.

Voir aussi

Référence

Get-SPTrustedServiceTokenIssuer
New-SPTrustedServiceTokenIssuer
Remove-SPTrustedServiceTokenIssuer

Historique des modifications


Update-SPFarmEncryptionKey
Exemple
[image]

Modifie la valeur de la clé de chiffrement de la batterie et rechiffre toutes les données à l'aide de la nouvelle clé.

Update-SPFarmEncryptionKey [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Resume <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Resume

Facultatif

System.Management.Automation.SwitchParameter

Reprend le rechiffrement des données avec la nouvelle clé de chiffrement de la batterie si une précédente tentative a échoué.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Update-SPFarmEncryptionKey modifie la clé de chiffrement de la batterie avec une valeur générée aléatoirement. Lorsque la nouvelle clé est utilisée, toutes les données sont rechiffrées.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE-----------------------
Code de copie
Update-SPFarmEncryptionKey -confirm

Cet exemple modifie la clé de chiffrement de la batterie avec une nouvelle valeur et rechiffre toutes les données.

Historique des modifications


Applets de commande pour les applications de service (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour administrer des applications de service dans une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Add-SPServiceApplicationProxyGroupMember

Get-SPServiceApplicationPool

Get-SPServiceApplication

Get-SPServiceApplicationProxy

Get-SPServiceApplicationProxyGroup

Get-SPServiceContext

Get-SPServiceInstance

Get-SPUsageApplication

Get-SPUsageDefinition

Get-SPUsageService

Grant-SPServiceApplication

New-SPServiceApplicationPool

New-SPServiceApplicationProxyGroup

New-SPSubscriptionSettingsServiceApplicationProxy

New-SPUsageApplication

Publish-SPServiceApplication

Receive-SPSharedServiceApplicationInfo

Remove-SPServiceApplication

Remove-SPServiceApplicationPool

Remove-SPServiceApplicationProxy

Remove-SPServiceApplicationProxyGroup

Remove-SPServiceApplicationProxyGroupMember

Remove-SPUsageApplication

Revoke-SPServiceApplication

Set-SPIisWebServiceApplicationPool

Set-SPServiceApplication

Set-SPUsageApplication

Unpublish-SPServiceApplication

Set-SPUsageService

Start-SPServiceInstance

Stop-SPServiceInstance

Set-SPUsageDefinition

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Add-SPServiceApplicationProxyGroupMember
Voir aussi Exemple
[image]

Ajoute un membre au groupe de proxys d'application de service.

Add-SPServiceApplicationProxyGroupMember [-Identity] <SPServiceApplicationProxyGroupPipeBind> [-Member] <SPServiceApplicationProxyPipeBind[]> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

SPServiceApplicationProxyGroupPipeBind.

Spécifie le groupe de proxys d'application de service sur lequel ajouter le membre.

Member

Requis

SPServiceApplicationProxyPipeBind[]

Spécifie un tableau de membres à ajouter au groupe de proxys d'application de service.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Add-SPServiceApplicationProxyGroupMember ajoute un membre au groupe de proxys d'application de service.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Add-SPServiceApplicationProxyGroupMember RemoteProxyGroup -Member babab30e-8e3a-428b-8ff4-4d5c8f455e6d

Cet exemple ajoute un proxy d'application de service sélectionné au groupe de proxys d'application de service nommé RemoteProxyGroup.

Le GUID du groupe de proxys d'application de service est unique pour chaque batterie de serveurs. Vous pouvez exécuter Get-SPServiceApplicationProxyGroup | Select Name,Id pour voir le GUID des groupes de proxys d'application de service. Servez-vous de ce résultat pour toute autre applet de commande SPServiceApplicationProxyGroup.

Voir aussi

Référence

Remove-SPServiceApplicationProxyGroupMember

Historique des modifications


Get-SPServiceApplication
Voir aussi Exemple
[image]

Renvoie l'application de service spécifiée.

Get-SPServiceApplication [[-Identity] <SPServiceApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Name <String>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie le GUID de l'application de service à récupérer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServiceApplication renvoie l'application de service spécifiée par le paramètre Identity. Si aucun paramètre n'est spécifié, l'applet de commande renvoie toutes les applications de service de la batterie de serveurs.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE----------------------
Code de copie
Get-SPServiceApplication

Cet exemple renvoie toutes les applications de service dans la batterie.

Voir aussi

Référence

Set-SPServiceApplication
Grant-SPServiceApplication
Revoke-SPServiceApplication
Get-SPServiceApplicationProxy

Historique des modifications


Get-SPServiceApplicationEndpoint
Voir aussi Exemple
[image]

Renvoie le point de terminaison d'une application de service.

Get-SPServiceApplicationEndpoint [-Identity] <SPServiceEndpointPipeBind> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPServiceApplicationEndpoint -ServiceApplication <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Name <String>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceEndpointPipeBind

Spécifie le point de terminaison du service à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide d'adresse de point de terminaison, au format http://sitename:8003/exemplemodèleservice/service, ou une instance d'un objet SPServiceEndpoint valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

ServiceApplication

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application de service de paramètres d'abonnement valide (par exemple, SubscriptionSettingsApp1) ou une instance d'un objet SPServiceApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Name

Facultatif

System.String

Spécifie le nom du point de terminaison de l'application de service.

Le type doit être un nom valide de point de terminaison d'application de service comme SvcAppEndpoint1.

Description détaillée

L'applet de commande Get-SPServiceApplicationEndpoint définit l'hôte d'un point de terminaison d'un service. Utilisez le deuxième paramètre défini et ne spécifiez pas le paramètre Name pour renvoyer une collection de tous les points de terminaison de l'application de service spécifiée.

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE--------------------
Code de copie
Get- SPServiceApplicationEndpoint -ServiceApplication "ServiceSubApp1"

Cet exemple renvoie l'objet SPServiceEndpoint basé sur l'application de service spécifiée.

Voir aussi

Référence

Set-SPServiceApplicationEndpoint

Historique des modifications


Get-SPServiceApplicationPool
Voir aussi Exemple
[image]

Renvoie le pool d'applications IIS spécifié.

Get-SPServiceApplicationPool [[-Identity] <SPIisWebServiceApplicationPoolPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Spécifie le nom ou l'identificateur (ID) du pool d'applications à récupérer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServiceApplicationPool renvoie le pool d'applications IIS spécifié par le paramètre Identity, ou renvoie tous les pools d'applications si le paramètre Identity n'est pas spécifié.

Pour connaître les autorisations et les informations les plus récentes concernant Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPServiceApplicationPool

Cet exemple renvoie tous les pools d'application de service dans la batterie.

Voir aussi

Référence

New-SPServiceApplicationPool
Set-SPServiceApplicationPool
Remove-SPServiceApplicationPool

Historique des modifications


Get-SPServiceApplicationProxy
Voir aussi Exemple
[image]

Renvoie une instance du proxy d'application de service spécifié.

Get-SPServiceApplicationProxy [[-Identity] <SPServiceApplicationProxyPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Spécifie le GUID du proxy d'application de service à renvoyer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServiceApplicationProxy renvoie une instance du proxy d'application de service spécifié par le paramètre Identity.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPServiceApplicationProxy

Cet exemple récupère tous les proxys d'application de service dans la batterie.

Voir aussi

Référence

Remove-SPServiceApplicationProxy
New-SPServiceApplicationProxyGroup
Remove-SPServiceApplicationProxyGroup
Get-SPServiceApplicationProxyGroup

Historique des modifications


Get-SPServiceApplicationProxyGroup
Voir aussi Exemple
[image]

Renvoie le groupe de proxys pour l'application de service spécifiée.

Get-SPServiceApplicationProxyGroup [[-Identity] <SPServiceApplicationProxyGroupPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Get-SPServiceApplicationProxyGroup -Default <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyGroupPipeBind

Spécifie le nom ou le GUID du groupe de proxys.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

Default

Requis

System.Management.Automation.SwitchParameter

Renvoie le groupe de proxys de service par défaut pour la batterie de serveurs.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServiceApplicationProxyGroup affiche une liste des groupes de proxys de la batterie de serveurs. Pour afficher un groupe de proxys spécifique, utilisez le paramètre Identity. Sans valeur de paramètre, une liste de tous les groupes de proxys s'affiche.

Pour connaître les autorisations et les informations les plus récentes sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPServiceApplicationProxyGroup

Cet exemple récupère tous les groupes de proxys de l'application de service dans la batterie de serveurs.

Voir aussi

Référence

New-SPServiceApplicationProxyGroup
Remove-SPServiceApplicationProxyGroup
Add-SPServiceApplicationProxyGroupMember

Historique des modifications


Get-SPServiceContext
Exemple
[image]

Renvoie un contexte de service.

Get-SPServiceContext [-Site] <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPServiceContext -SiteSubscription <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Renvoie le contexte de service uniquement pour l'application Web qui contient la collection de sites spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide au format http://server_name, ou une instance d'un objet SPSite valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Renvoie le contexte de service uniquement pour l'application Web qui contient la collection de sites spécifiée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide au format http://server_name, ou une instance d'un objet SPSite valide.

SiteSubscription

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Renvoie tous les contextes de services pour toutes les applications Web dans lesquelles l'abonnement à un site spécifié contient des collections de sites.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'abonnement à un site (par exemple, SiteSubscriptionConfig1) ou une instance d'un objet SiteSubscription valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServiceContext renvoie un contexte de service ou une collection de contextes de services. Spécifiez le paramètre Site pour renvoyer un contexte de service individuel ou spécifiez le paramètre SiteSubscription pour renvoyer une collection de contextes de services.

Types d'entrée

Types retournés

Exemple

-----------------EXEMPLE------------------
Code de copie
$sitesub = Get-SPSiteSubscription http://my.contoso.com/
Code de copie
Get-SPServiceContext $sitesub

Cet exemple renvoie le contexte de service pour un site dans un environnement hébergé.

Historique des modifications


Get-SPServiceHostConfig
Voir aussi Exemple
[image]

Renvoie les paramètres de service Web communs.

Get-SPServiceHostConfig [-AssignmentCollection <SPAssignmentCollection>] [-Default <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Default

Facultatif

System.Management.Automation.SwitchParameter

Ce paramètre n'a aucun effet.

Description détaillée

L'applet de commande Get-SPServiceHostConfig renvoie les paramètres de service Web communs.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-------------------
Code de copie
Get- SPServiceHostConfig

Cet exemple affiche les paramètres de service Web.

Voir aussi

Référence

Set-SPServiceHostConfig

Historique des modifications


Get-SPServiceInstance
Voir aussi Exemple
[image]

Renvoie l'instance des services pour un serveur spécifique ou la batterie complète.

Get-SPServiceInstance [[-Identity] <SPServiceInstancePipeBind>] [-All <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>]
Get-SPServiceInstance -Server <SPServerPipeBind> [-All <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceInstancePipeBind

Spécifie le GUID de l'instance du service.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

Server

Requis

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie le serveur à partir duquel renvoyer l'instance du service.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServiceInstance renvoie l'instance des services spécifiée par le paramètre Identity pour un serveur spécifique. Si le paramètre Server n'est pas spécifié, l'applet de commande Get-SPServiceInstance renvoie les résultats pour la batterie complète.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPServiceInstance -Server ServerA

Cet exemple affiche les instances du service provenant d'un serveur donné.

Voir aussi

Référence

Start-SPServiceInstance
Stop-SPServiceInstance

Historique des modifications


Get-SPTopologyServiceApplication
Voir aussi Exemple
[image]

Affiche les propriétés de l'application de service de topologie pour la batterie actuelle.

Get-SPTopologyServiceApplication [[-Identity] <SPTopologyWebServiceApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPTopologyWebServiceApplicationPipeBind

Spécifie le GUID de l'application.

Le type doit être un GUID valide, au format 1234-4567-098jhj.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPTopologyServiceApplication affiche les propriétés avancées d'une application lorsque le paramètre Identity est utilisé.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPTopologyServiceApplication

Cet exemple affiche les propriétés de l'application de service de topologie pour la batterie actuelle.

Voir aussi

Référence

Set-SPTopologyServiceApplication
Get-SPTopologyServiceApplicationProxy

Historique des modifications


Get-SPTopologyServiceApplicationProxy
Voir aussi Exemple
[image]

Récupère le proxy d'application du service de topologie.

Get-SPTopologyServiceApplicationProxy [[-Identity] <SPTopologyWebServiceProxyPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPTopologyWebServiceProxyPipeBind

Spécifie le GUID du proxy de l'application.

Le type doit être un GUID valide, au format 1234-4567-098jhj.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPTopologyServiceApplicationProxy récupère le proxy d'application du service de topologie local.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPTopologyServiceApplicationProxy

Cet exemple affiche le proxy d'application du service de topologie dans la batterie.

Voir aussi

Référence

Set-SPTopologyServiceApplicationProxy
Set-SPTopologyServiceApplication

Historique des modifications


Get-SPUsageApplication
Voir aussi Exemple
[image]

Renvoie une application d'utilisation spécifiée.

Get-SPUsageApplication [[-Identity] <SPUsageApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-UsageService <SPUsageServicePipeBind>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageApplicationPipeBind

Spécifie l'application d'utilisation à récupérer. Si le paramètre Identity n'est pas spécifié, l'applet de commande renvoie l'application d'utilisation locale.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application d'utilisation valide (par exemple, UsageApplication1) ou une instance d'un objet SPUsageApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

UsageService

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageServicePipeBind

Filtre pour renvoyer l'application d'utilisation avec l'objet parent SPUsageService spécifié.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de service d'utilisation valide (par exemple, UsageService1) ou une instance d'un objet SPUsageService valide.

Description détaillée

L'applet de commande Get-SPUsageApplication renvoie une application d'utilisation spécifiée. Si le paramètre Identity n'est pas spécifié, l'applet de commande renvoie l'application d'utilisation locale.

Pour connaître les autorisations et les informations les plus récentes sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-------------------
Code de copie
Get-SPUsageApplication -Identity "Usage and Health data collection"

Cet exemple renvoie l'application d'utilisation Usage and Health data collection

Voir aussi

Référence

New-SPUsageApplication
Set-SPUsageApplication
Remove-SPUsageApplication

Historique des modifications


Get-SPUsageDefinition
Voir aussi Exemple
[image]

Renvoie un objet de définition d'utilisation.

Get-SPUsageDefinition [[-Identity] <SPUsageDefinitionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageDefinitionPipeBind

Spécifie l'objet de définition d'utilisation à obtenir.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de définition d'utilisation valide (par exemple, SiteSubscriptionConfig1) ou une instance d'un objet SPUsageDefinition valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPUsageDefinition lit un objet de définition d'utilisation. Si le paramètre Identity n'est pas spécifié, cette applet de commande renvoie la collection de définitions d'utilisation dans la batterie de serveurs. Un objet de définition d'utilisation définit un type d'utilisation spécifique.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPUsageDefinition -Identity "Page Requests"

Cet exemple renvoie le fournisseur SPRequestUsage dans la batterie de serveurs locale.

Voir aussi

Référence

Set-SPUsageDefinition

Historique des modifications


Get-SPUsageService
Voir aussi Exemple
[image]

Renvoie un service d'utilisation.

Get-SPUsageService [[-Identity] <SPUsageServicePipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageServicePipeBind

Spécifie le service d'utilisation à obtenir. Si le paramètre Identity n'est pas spécifié, l'applet de commande renvoie le service d'utilisation local.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de service d'utilisation valide (par exemple, ServiceUtilisation1) ou une instance d'un objet SPUsageService valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPUsageService renvoie le service d'utilisation spécifié. Si le paramètre Identity n'est pas spécifié, l'applet de commande renvoie le service d'utilisation local.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE-------------------------
Code de copie
Get-SPUsageService -Identity 57055d99-9914-4af6-a3bf-7b76e3f231c2

Cet exemple renvoie un objet SPUsageService avec l'ID spécifié.

Voir aussi

Référence

Set-SPUsageService

Historique des modifications


Grant-SPServiceApplication
Voir aussi Exemple
[image]

Donne à un compte utilisateur l'accès à une application de service.

Grant-SPServiceApplication -Identity <SPServiceApplicationPipeBind> -UserPrincipal <String> -Rights <String[]> -Type <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie le GUID de l'application de service à laquelle donner accès.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh.

UserPrincipal

Requis

System.String

Spécifie l'identité à laquelle donner accès à l'application de service.

Le type doit être un nom d'utilisateur principal valide, au format DOMAINE\utilisateur, ou une réclamation, au format CA:NTLM:Identité-nomutilisateur:domaine\utilisateur.

Rights

Requis

System.String[]

Spécifie les droits à octroyer à l'utilisateur. Par défaut, le droit suivant existe - « full » pour les types admin et access. Les applications de service peuvent définir leurs propres droits.

Le type doit être un tableau de chaînes contenant des entrées de droits utilisateurs valides.

Type

Requis

System.String

Spécifie si l'utilisateur principal se voit octroyer des droits d'administrateur ou des droits d'accès.

Admin ou Access.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Grant-SPServiceApplication donne aux comptes utilisateurs spécifiés le niveau d'accès spécifié à l'application de service spécifiée avec les autorisations spécifiées.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE---------------------
Code de copie
Grant-SPServiceApplication 053c34be-d251-488c-8e94-644eae94da26 -UserPrincipal testdomin\tester1 -Rights Full Control -Type Admin

Cet exemple octroie un accès administratif Full Control à l'utilisateur principal donné pour l'application de service sélectionnée.

Le GUID d'application de service est unique pour chaque batterie. Vous pouvez exécuter les applets de commande Get-SPServiceApplication pour voir le GUID des applications de service, puis utiliser le résultat de l'applet de commande Get-SPServiceApplication pour les autres applets de commande SPServiceApplication ; par exemple, Grant-SPServiceApplication ou Publish-SPServiceApplication.

Voir aussi

Référence

Set-SPServiceApplication
Get-SPServiceApplication
Publish-SPServiceApplication
Revoke-SPServiceApplication
Remove-SPServiceApplication

Historique des modifications


Install-SPService
Exemple
[image]

Installe et met en service des services dans une batterie de serveurs.

Install-SPService [-AssignmentCollection <SPAssignmentCollection>] [-Provision <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Provision

Facultatif

System.Management.Automation.SwitchParameter

Spécifie les paramètres par défaut lors de l'installation d'une application de service autonome.

Description détaillée

L'applet de commande Install-SPService installe et met éventuellement en service des services dans une batterie de serveurs. Cette applet de commande installe tous les services, les instances de services et les proxys de services spécifiés dans le registre sur l'ordinateur du serveur local. Utilisez cette applet de commande dans un script que vous rédigez pour installer et déployer une batterie de serveurs SharePoint ou pour installer un service développé personnalisé.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Install-SPService

Cet exemple installe tous les services, les instances de services et les proxys de services spécifiés dans le registre sur l'ordinateur serveur local.

Historique des modifications


New-SPServiceApplicationPool
Voir aussi Exemple
[image]

Crée un nouveau pool d'applications de service Web.

New-SPServiceApplicationPool [-Name] <String> [-Account] <SPProcessAccountPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Name

Requis

System.String

Spécifie le nom du nouveau pool d'applications de service Web.

Account

Requis

Microsoft.SharePoint.PowerShell.SPProcessAccountPipeBind

Spécifie les informations d'identification qui représenteront le paramètre Identity du nouveau pool d'applications.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPServiceApplicationPool crée un nouveau pool d'applications de service Web dans IIS.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE-----------------------
Code de copie
New-SPServiceApplicationPool -Name TestServiceWebApplicationPool -Account testdomain\testuser1

Cet exemple crée un nouveau pool d'applications de service Web.

Pour le paramètre Account, le nom d'un compte géré dans la batterie peut être donné. Utilisez l'applet de commande Get-SPManagedAccount pour afficher le compte géré existant dans la batterie. Un compte de processus provenant de la sortie de l'applet de commande Get-SPProcessAccount peut également être utilisé.

Voir aussi

Référence

Get-SPServiceApplicationPool
Set-SPServiceApplicationPool
Remove-SPServiceApplicationPool

Historique des modifications


New-SPServiceApplicationProxyGroup
Voir aussi Exemple
[image]

Crée un nouveau groupe de proxys d'application de service.

New-SPServiceApplicationProxyGroup [-Name] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Name

Requis

System.String

Spécifie le nom du nouveau groupe de proxys d'application de service.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPServiceApplicationProxyGroup crée un nouveau groupe de proxys d'application de service spécifié par le paramètre Name.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
New-SPServiceApplicationProxyGroup -Name RemoteProxyGroup

Cet exemple crée un nouveau proxy d'application de service nommé RemoteProxyGroup.

Voir aussi

Référence

Get-SPServiceApplicationProxyGroup
Add-SPServiceApplicationProxyGroupMember
Remove-SPServiceApplicationProxyGroup

Historique des modifications


New-SPSubscriptionSettingsServiceApplication
Voir aussi Exemple
[image]

Crée une nouvelle application du service des paramètres d'abonnement.

New-SPSubscriptionSettingsServiceApplication -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabaseServer <String>] [-FailoverDatabaseServer <String>] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

ApplicationPool

Requis

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Spécifie le pool d'applications IIS à utiliser pour la nouvelle application de paramètres d'abonnement.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de pool d'applications valide (par exemple, AppPoolName1) ou une instance d'un objet IISWebServiceApplicationPool valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom d'utilisateur et le mot de passe à utiliser pour l'authentification SQL Server de la base de données.

Le type doit être un objet PSCredential valide.

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données des paramètres d'abonnement.

Si ce paramètre n'est pas spécifié, un nom est alors généré.

Le type doit être un nom valide de base de données SQL Server, par exemple SubscriptionSettingsApp1.

DatabaseServer

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie le nom de l'interface SQL Server hôte de la base de données spécifiée dans le paramètre DatabaseName. S'il n'est pas spécifié, c'est le serveur de bases de données par défaut qui est utilisé.

Le type doit être un nom d'instance SQL Server valide, par exemple SQLServerHost1.

Le type doit être un nom valide de base de données SQL Server, par exemple SubscriptionSettingsApp1.

FailoverDatabaseServer

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie le nom de l'instance SQL Server hôte pour le serveur de bases de données de basculement.

Le type doit être un nom d'instance SQL Server valide, par exemple SQLServerHost1.

Name

Facultatif

System.String

Spécifie le nom convivial du nouveau service des paramètres d'abonnement.

Le type doit être un nom valide d'application du service des paramètres d'abonnement, par exemple SubscriptionSettingsApp1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande New-SPSubscriptionSettingsServiceApplication pour créer une application du service des paramètres d'abonnement pouvant servir à stocker des paramètres partagés entre toutes les collections de sites d'un abonnement à un site unique. Cette applet de commande s'utilise uniquement dans un environnement où les abonnements à des sites permettent de déléguer l'administration ou de partitionner les services servant au stockage des paramètres partagés entre toutes les collections de sites d'un abonnement à un site unique. Cette applet de commande est utilisée uniquement dans un environnement où les abonnements à des sites permettent de déléguer l'administration ou de partitionner les services.

Types d'entrée

Types retournés

Exemple

-------------EXEMPLE---------------

Code de copie
$AppPool = New-SPServiceApplicationPool -Name SettingsServiceAppPool -Account (Get-SPManagedAccount DOMAIN\jdoe)
Code de copie
$App = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPool -Name SettingsServiceApp -DatabaseName SettingsServiceDB
Code de copie
$proxy = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $App
Code de copie
Get-SPServiceInstance | where{$_.TypeName -eq "Microsoft SharePoint Foundation Subscription Settings Service"} | Start-SPServiceInstance

Cet exemple crée un pool d'applications, une nouvelle application du service des paramètres d'abonnement, un proxy d'application du service des paramètres d'abonnement, et démarre l'instance du service sur l'ordinateur local. Cet exemple suppose qu'un compte géré existe déjà pour DOMAIN\jdoe.

Voir aussi

Référence

Set-SPSubscriptionSettingsServiceApplication
New-SPSubscriptionSettingsServiceApplicationProxy

Historique des modifications


New-SPSubscriptionSettingsServiceApplicationProxy
Voir aussi Exemple
[image]

Crée un proxy d'application dans une application de service de paramètres d'abonnement.

New-SPSubscriptionSettingsServiceApplicationProxy -Uri <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Uri

Requis

System.String

Spécifie l'adresse de l'application de service de paramètres d'abonnement à associer au nouveau proxy d'application.

Le type doit être un URI valide, au format file:\\nom_serveur\docssite.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

ServiceApplication

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service de paramètres d'abonnement associée au nouveau proxy.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application de service de paramètres d'abonnement valide (par exemple, AppParamètresAbonnement1) ou une instance d'un objet SPServiceApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande New-SPSubscriptionSettingsServiceApplicationProxy pour créer un proxy d'application dans une application de service de paramètres d'abonnement. Cette opération est nécessaire pour que la batterie locale puisse utiliser une telle application.

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE---------------------------
Code de copie
$AppPool = New-SPServiceApplicationPool -Name SettingsServiceAppPool -Account (Get-SPManagedAccount DOMAIN\jdoe)
Code de copie
$App = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPool -Name SettingsServiceApp -DatabaseName SettingsServiceDB
Code de copie
$proxy = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $App
Code de copie
Get-SPServiceInstance | where{$_.TypeName -eq "Microsoft SharePoint Foundation Subscription Settings Service"} | Start-SPServiceInstance

Cet exemple crée un pool d'applications, une nouvelle application de service de paramètres, un proxy d'application de service de paramètre, puis démarre l'instance de service sur l'ordinateur local. Cet exemple suppose qu'un compte géré pour DOMAIN\jdoe existe déjà.

Voir aussi

Référence

New-SPSubscriptionSettingsServiceApplication
Set-SPSubscriptionSettingsServiceApplication

Historique des modifications


New-SPUsageApplication
Exemple
[image]

Crée une application d'utilisation.

New-SPUsageApplication [[-Name] <String>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseName <String>] [-DatabasePassword <SecureString>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-UsageService <SPUsageServicePipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Name

Facultatif

System.String

Spécifie le nom convivial de la nouvelle application d'utilisation.

Le type doit correspondre à un nom valide d'application d'utilisation, comme UsageApplication1.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données de journalisation. Si elle n'existe pas, une base de données de journalisation est automatiquement créée.

Le type doit être un nom valide de base de données SQL Server, par exemple UsageLogDB1.

DatabasePassword

Facultatif

System.Security.SecureString

Spécifie le mot de passe de l'utilisateur spécifié dansDatabaseUserName. Utilisez ce paramètre uniquement si l'authentification SQL Server est utilisée pour accéder à la base de données de journalisation.

Le type doit être un mot de passe valide.

DatabaseServer

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie l'objet SPServer dans lequel la base de données de journalisation est créée.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, l'adresse IP d'un serveur au format 208.77.188.166, un nom valide de service hôte SQL Server (par exemple, SQLServerHost1) ou une instance d'un objet SPServer valide.

DatabaseUsername

Facultatif

System.String

Spécifie le nom d'utilisateur à utiliser pour se connecter à la base de données de journalisation. Utilisez ce paramètre uniquement si vous accédez à la base de données de journalisation via l'authentification SQL Server.

Le type doit être un nom d'utilisateur valide, par exemple UserName1.

FailoverDatabaseServer

Facultatif

System.String

Spécifie le nom de l'instance SQL Server hôte pour le serveur de bases de données de basculement.

Le type doit être un nom d'instance SQL Server valide, par exemple SQLServerHost1.

UsageService

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageServicePipeBind

Filtre pour renvoyer l'application d'utilisation avec l'objet parent SPUsageService spécifié.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de service d'utilisation valide (par exemple, ServiceUtilisation1) ou une instance d'un objet SPUsageService valide.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPUsageApplication crée une application d'utilisation dans la batterie de serveurs locale.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE--------------------

Code de copie
New-SPUsageApplication -Name "Usage Application For Farm ABC"

Cet exemple crée une application d'utilisation pour le nom spécifié.

Historique des modifications


Publish-SPServiceApplication
Voir aussi Exemple
[image]

Partage l'application de service local spécifiée en dehors de la batterie de serveurs.

Publish-SPServiceApplication [-Identity] <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-InfoLink <Uri>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie le GUID de l'application de service à partager en dehors de la batterie de serveurs.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description

Facultatif

System.String

Décrit l'application de service à partager en dehors de la batterie de serveurs. Si aucune valeur n'est spécifiée, la valeur est laissée vide.

InfoLink

Facultatif

System.Uri

Indique le lien vers davantage d'informations concernant l'application de service à partager en dehors de la batterie de serveurs. Si aucun lien n'est spécifié, aucun lien n'est mis à disposition.

Le type doit être une URL valide au format http://server_name/nom_site/nom_page.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Publish-SPServiceApplication publie l'application de service local, spécifiée par le paramètre Identity, en dehors de la batterie de serveurs.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Publish-SPServiceApplication 053c34be-d251-488c-8e94-644eae94da26 -Description "Connect to this TestServiceApplcation of you want to use FeatureA in your farm" -InfoLink http://testurl

Cet exemple publie une application de service sur une autre batterie de serveurs.

Le GUID de l'application de service est unique pour chaque batterie de serveurs. Vous pouvez exécuter l'applet de commande Get-SPServiceApplication pour voir le GUID des applications de service, puis utiliser le résultat provenant de l'applet de commande Get-SPServiceApplication pour d'autres applets de commande SPServiceApplication, par exemple Grant-SPServiceApplication.

Voir aussi

Référence

Get-SPServiceApplication
Set-SPServiceApplication
Remove-SPServiceApplication
Grant-SPServiceApplication

Historique des modifications


Receive-SPSharedServiceApplicationInfo
Exemple
[image]

Configure cette batterie pour recevoir des informations sur les services d'une autre batterie.

Receive-SPSharedServiceApplicationInfo [-FarmUrl] <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Filter <String>]

Paramètres

Paramètre Requis Type Description

FarmUrl

Requis

System.Uri

Spécifie l'URL de la batterie à partir de laquelle recevoir les informations d'application de service.

Le type doit être une URL valide au format http://server_name.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Filter

Facultatif

System.String

Description détaillée

L'applet de commande Receive-SPSharedServiceApplicationInfo récupère la liste des applications de service publiées par une autre batterie.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Receive-SPSharedServiceApplicationInfo -FarmUrl http://FarmB/topology/topology.svc

Cet exemple récupère une liste des applications de service publiées par une batterie donnée.

Le paramètre FarmURL peut être obtenu par l'applet de commande Get-SPTopologyWebServiceApplication.

Historique des modifications


Remove-SPServiceApplication
Voir aussi Exemple
[image]

Supprime l'application de service spécifiée du serveur local.

Remove-SPServiceApplication [-Identity] <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-RemoveData <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie le GUID de l'application de service à supprimer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

RemoveData

Facultatif

SwitchParameter

Supprime toutes les bases de données et autres données associées à l'application de service.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPServiceApplication supprime l'application de service spécifiée de la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE---------------------------
Code de copie
Remove-SPServiceApplication 053c34be-d251-488c-8e94-644eae94da26
-removedata

Cet exemple supprime l'application de service et sa base de données.

Le GUID d'application de service est unique pour chaque batterie. Vous pouvez exécuter les applets de commande Get-SPServiceApplication pour voir le GUID des applications de service, puis utiliser le résultat de l'applet de commande Get-SPServiceApplication pour les autres applets de commande SPServiceApplication ; par exemple, Grant-SPServiceApplication ou Publish-SPServiceApplication.

Voir aussi

Référence

Get-SPServiceApplication
Set-SPServiceApplication
Publish-SPServiceApplication
Grant-SPServiceApplication

Historique des modifications


Remove-SPServiceApplicationPool
Voir aussi Exemple
[image]

Supprime entièrement le pool d'applications de service Web spécifié.

Remove-SPServiceApplicationPool [-Identity] <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Spécifie l'identité du pool d'applications de service Web à supprimer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPServiceApplicationPool supprime entièrement le pool d'applications de service Web spécifié.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Remove-SPServiceApplicationPool TestServiceWebApplicationPool

Cet exemple supprime le pool d'applications de service sélectionné.

Voir aussi

Référence

Get-SPServiceApplicationPool
Set-SPServiceApplicationPool
Remove-SPServiceApplicationPool

Historique des modifications


Remove-SPServiceApplicationProxy
Voir aussi Exemple
[image]

Supprime le proxy d'application de service spécifié.

Remove-SPServiceApplicationProxy [-Identity] <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-RemoveData <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Spécifie le GUID du proxy d'application de service à supprimer.

Le type doit être un GUID, au format 12345678-90ab-cdef-1234-567890bcdefgh.

RemoveData

Facultatif

System.Management.Automation.SwitchParameter

Supprime toutes les bases de données et autres données associées au proxy d'application de service.

AssignmentColletion

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentColletion

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPServiceApplicationProxy supprime le proxy d'application de service spécifié par le paramètre Identity.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Remove-SPServiceApplicationProxy babab30e-8e3a-428b-8ff4-4d5c8f455e6d

Cet exemple supprime le proxy d'application de service donné.

Le GUID d'application de service est unique pour chaque batterie. Vous pouvez exécuter les applets de commande Get-SPServiceApplication pour voir le GUID des applications de service, puis utiliser le résultat de l'applet de commande Get-SPServiceApplication pour les autres applets de commande SPServiceApplication ; par exemple, Grant-SPServiceApplication ou Publish-SPServiceApplication.

Voir aussi

Référence

Get-SPServiceApplicationProxy
New-SPServiceApplicationProxyGroup
Remove-SPServiceApplicationProxy

Historique des modifications


Remove-SPServiceApplicationProxyGroup
Voir aussi Exemple
[image]

Supprime intégralement le groupe de proxys d'application de service.

Remove-SPServiceApplicationProxyGroup [-Identity] <SPServiceApplicationProxyGroupPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyGroupPipeBind

Identité du groupe de proxys d'application de service à supprimer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Supprime intégralement le groupe de proxys d'application de service.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE-------------------------
Code de copie
Remove-SPServiceApplicationProxyGroup RemoteProxyGroup

Cet exemple supprime le groupe de proxys d'application de service nommé RemoteProxyGroup.

Le GUID du groupe de proxys d'application de service est unique pour chaque batterie de serveurs. Vous pouvez exécuter Get-SPServiceApplicationProxyGroup | Select Name,Id pour voir le GUID des groupes de proxys d'application de service. Servez-vous de ce résultat pour toute autre applet de commande SPServiceApplicationProxyGroup.

Voir aussi

Référence

Get-SPServiceApplicationProxyGroup
New-SPServiceApplicationProxyGroup

Historique des modifications


Remove-SPServiceApplicationProxyGroupMember
Voir aussi Exemple
[image]

Supprime un ou plusieurs proxys du groupe de proxys d'application de service spécifié.

Remove-SPServiceApplicationProxyGroupMember [-Identity] <SPServiceApplicationProxyGroupPipeBind> [-Member] <SPServiceApplicationProxyPipeBind[]> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyGroupPipeBind

Spécifie l'identité du groupe de proxys d'application de service à partir duquel supprimer le ou les membres.

Member

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind[]

Spécifie le ou les membres à supprimer du groupe de proxys d'application de service.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPServiceApplicationProxyGroupMember supprime un ou plusieurs proxys du groupe de proxys d'application de service spécifié.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Remove-SPServiceApplicationProxyGroupMember RemoteProxyGroup -Member babab30e-8e3a-428b-8ff4-4d5c8f455e6d

Cet exemple supprime un proxy d'application de service du groupe de proxys d'application de service sélectionné nommé RemoteProxyGroup.

Le GUID du groupe proxy de l'application de service est unique pour chaque batterie de serveurs. Vous pouvez exécuter Get-SPServiceApplicationProxyGroup | Select Name,Id pour voir le GUID des groupes proxy de l'application de service. Servez-vous de ce résultat pour toute autre applet de commande SPServiceApplicationProxyGroup.

Voir aussi

Référence

Add-SPServiceApplicationProxyGroupMember

Historique des modifications


Remove-SPUsageApplication
Voir aussi Exemple
[image]

Supprime une application d'utilisation de la batterie de serveurs locale.

Remove-SPUsageApplication [-Identity] <SPUsageApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-RemoveData <SwitchParameter>] [-UsageService <SPUsageServicePipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUsageApplicationPipeBind

Spécifie l'application d'utilisation à supprimer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application d'utilisation valide (par exemple, UsageApplication1) ou une instance d'un objet SPUsageApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

RemoveData

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que la base de données de journalisation est également supprimée.

UsageService

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageServicePipeBind

Réservé à une utilisation future.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPUsageApplication supprime une application d'utilisation de la batterie de serveurs locale.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE--------------------
Code de copie
Remove-SPUsageApplication -Identity "Usage and Health data collection" -RemoveData

Cet exemple supprime l'application d'utilisation existante et la base de données de journalisation associée.

Voir aussi

Référence

Get-SPUsageApplication
Set-SPUsageApplication
New-SPUsageApplication

Historique des modifications


Revoke-SPServiceApplication
Voir aussi Exemple
[image]

Révoque un accès utilisateur à une application de service.

Revoke-SPServiceApplication -Identity <SPServiceApplicationPipeBind> -UserPrincipal <String> -Type <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie le GUID de l'application de service sur lequel révoquer l'accès.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh.

UserPrincipal

Requis

System.String

Spécifie l'identité pour révoquer l'accès à l'application de service.

Le type doit être un nom d'utilisateur principal au format DOMAINE\utilisateur, ou une revendication au format CA:NTLM:Identity-username:domaine\utilisateur.

Type

Requis

System.String

Spécifie le type de droits à révoquer.

Le type doit être Admin ou Access.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Revoke-SPServiceApplication révoque l'accès utilisateur spécifié sur l'application de service spécifiée.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Revoke-SPServiceAppliaion 053c34be-d251-488c-8e94-644eae94da26 -UserPrincipal testdomin\tester1 -Type Admin

Cet exemple révoque l'accès administratif donné à l'utilisateur spécifié pour l'application de service sélectionnée.

Le GUID de l'application de service est unique pour chaque batterie de serveurs. Vous pouvez exécuter l'applet de commande Get-SPServiceApplication pour voir le GUID des applications de service, puis utiliser le résultat provenant de l'applet de commande Get-SPServiceApplication pour d'autres applets de commande SPServiceApplication, par exemple Grant-SPServiceApplication ou Publish-SPServiceApplication.

Voir aussi

Référence

Get-SPServiceApplication
Set-SPServiceApplication
Publish-SPServiceApplication
Grant-SPServiceApplication

Historique des modifications


Set-SPServiceApplication
Voir aussi Exemple
[image]

Définit les propriétés d'une application de service.

Set-SPServiceApplication [-Identity] <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultEndpoint <SPServiceEndpointPipeBind>] [-IisWebServiceApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-ServiceApplicationProxyGroup <SPServiceApplicationProxyGroupPipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application de service de paramètres d'abonnement valide (par exemple SubSettingsApp1), ou une instance d'un objet SPServiceApplication valide.

DefaultEndpoint

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceEndpointPipeBind

Spécifie l'adresse du point de terminaison par défaut de l'application de service.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

IisWebServiceApplicationPool

Facultatif

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Spécifie le nom ou l'identité du pool d'applications utilisé par l'application de service.

Le paramètre IisWebServiceApplicationPool ne s'applique qu'aux applications de service Web.

ServiceApplicationProxyGroup

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyGroupPipeBind

Spécifie un groupe de proxys personnalisé d'application de service pour l'application Web à utiliser. L'application Web utilisera les proxys de ce groupe de proxys pour se connecter à des applications de service. Si le paramètre ServiceApplicationProxyGroup n'est pas spécifié, le groupe de proxys par défaut de la batterie de serveurs est utilisé.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de service Set-SPServiceApplication pour définir plusieurs propriétés d'une application de service comme le point de terminaison par défaut et le pool d'applications utilisé par l'application de service.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
$serviceapp = Get-SPServiceApplication "My Service App"
Code de copie
Set-SPServiceApplication $serviceapp -DefaultEndpoint https

Cet exemple définit le point de terminaison par défaut de l'application de service sur https.

Voir aussi

Référence

Get-SPServiceApplication
Revoke-SPServiceApplication
Publish-SPServiceApplication
Remove-SPServiceApplication

Historique des modifications


Set-SPServiceApplicationEndpoint
Voir aussi Exemple
[image]

Définit l'hôte d'un point de terminaison pour une application de service.

Set-SPServiceApplicationEndpoint [-Identity] <SPServiceEndpointPipeBind> -HostName <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Set-SPServiceApplicationEndpoint [-Identity] <SPServiceEndpointPipeBind> -ResetHostName <SwitchParameter> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceEndpointPipeBind

Spécifie le point de terminaison du service à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide d'adresse de point de terminaison, au format http://sitename:8003/exemplemodèleservice/service, ou une instance d'un objet SPServiceEndpoint valide.

HostName

Requis

System.String

Spécifie l'hôte par défaut du point de terminaison du service.

Le type doit être une URL entière avec équilibrage de la charge réseau valide, au format http://nom_serveur.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceEndpointPipeBind

Spécifie le point de terminaison du service à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide d'adresse de point de terminaison, au format http://sitename:8003/exemplemodèleservice/service, ou une instance d'un objet SPServiceEndpoint valide.

ResetHostName

Requis

System.Management.Automation.SwitchParameter

Supprime l'hôte actuel du point de terminaison du service et utilise l'hôte par défaut.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPServiceApplicationEndpoint définit l'hôte d'un point de terminaison d'un service. Utilisez le second jeu de paramètres pour réinitialiser l'hôte du point de terminaison du service afin d'utiliser le point de terminaison par défaut.

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE-------------------
Code de copie
Set-SPServiceApplicationEndpoint -Identity "ServiceApp1" -HostName http://sitename -ResetHostName $true

Cet exemple associe l'objet SPServiceEndpoint à l'identité spécifiée et réinitialise le nom d'hôte.

Voir aussi

Référence

Get-SPServiceApplicationEndpoint

Historique des modifications


Set-SPServiceApplicationPool
Voir aussi Exemple
[image]

Change le compte utilisé pour l'identité du pool d'applications spécifié.

Set-SPServiceApplicationPool [-Identity] <SPIisWebServiceApplicationPoolPipeBind> [[-Account] <SPProcessAccountPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Spécifie l'identité du pool d'applications de service Web à configurer.

Account

Facultatif

Microsoft.SharePoint.PowerShell.SPProcessAccountPipeBind

Spécifie les informations d'identification qui seront la nouvelle identité du pool d'applications.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPServiceApplicationPool change le compte utilisé pour l'identité du pool d'applications spécifié.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPServiceApplicationPool  TestServiceWebApplicationPool -Account testdomain\testuser1

Cet exemple change l'identité du pool d'applications de service sélectionné.

Pour le paramètre Account, le nom d'un compte géré de la batterie peut être donné. Utilisez l'applet de commande Get-SPManagedAccount pour afficher le compte géré existant dans la batterie. Par ailleurs, un compte de processus issu de la sortie de l'applet de commande Get-SPProcessAccount peut être utilisé.

Voir aussi

Référence

Get-SPServiceApplicationPool
New-SPServiceApplicationPool
Remove-SPServiceApplicationPool

Historique des modifications


Set-SPServiceHostConfig
Voir aussi Exemple
[image]

Configure un ou plusieurs paramètres communs pour tous les services Web.

Set-SPServiceHostConfig [-Identity] <SPIisWebServiceSettings> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-HttpPort <Int32>] [-HttpsPort <Int32>] [-ImportSslCertificate <X509Certificate2>] [-NetTcpPort <Int32>] [-NoWait <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Set-SPServiceHostConfig [-Identity] <SPIisWebServiceSettings> -SslCertificateThumbprint <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-HttpPort <Int32>] [-HttpsPort <Int32>] [-NetTcpPort <Int32>] [-NoWait <SwitchParameter>] [-SslCertificateStoreName <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.Administration.SPIisWebServiceSettings

Spécifie l'identité de l'application de service Web à configurer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

HttpPort

Facultatif

System.Int32

Spécifie le nouveau port pour le service Web.

HttpsPort

Facultatif

System.Int32

Spécifie le nouveau port sécurisé pour le service Web.

ImportSslCertificate

Facultatif

System.Security.Cryptography.X509Certificates.X509Certificate2

Spécifie le certificat SSL à utiliser pour les protocoles sécurisés.

NetTcpPort

Facultatif

System.Int32

Définit le port TCP pour le service Web.

NoWait

Facultatif

System.Management.Automation.SwitchParameter

Pour plus d'informations, voir TechNet.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.Administration.SPIisWebServiceSettings

Spécifie l'identité de l'application de service Web à configurer.

SslCertificateThumbprint

Requis

System.String

Spécifie l'empreinte du certificat SSL à extraire pour les protocoles sécurisés.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

HttpPort

Facultatif

System.Int32

Spécifie le nouveau port pour le service Web.

HttpsPort

Facultatif

System.Int32

Spécifie le nouveau port sécurisé pour le service Web.

NetTcpPort

Facultatif

System.Int32

Définit le port TCP pour le service Web.

NoWait

Facultatif

System.Management.Automation.SwitchParameter

Pour plus d'informations, voir TechNet.

SslCertificateStoreName

Facultatif

System.String

Spécifie l'empreinte du certificat SSL à extraire pour les protocoles sécurisés.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPServiceHostConfig configure un ou plusieurs paramètres communs pour tous les services Web.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPServiceHostConfig -Port 12345

Cet exemple définit le port HTTP pour les services Web.

Voir aussi

Référence

Get-SPServiceHostConfig

Historique des modifications


Set-SPTopologyServiceApplication
Voir aussi Exemple
[image]

Définit les propriétés de l'application du service de topologie de la batterie locale.

Set-SPTopologyServiceApplication [-Identity] <SPTopologyWebServiceApplicationPipeBind> -LoadBalancerUrl <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTopologyWebServiceApplicationPipeBind

Spécifie le GUID de l'application à définir.

Le type doit être un GUID valide, au format 1234-456-854gh.

LoadBalancerUrl

Requis

System.String

Spécifie un programme d'équilibrage de la charge physique externe.

Le type doit être une URL valide, au format http://search.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPTopologyServiceApplication définit les propriétés avancées d'une application lorsque le paramètre Identity est utilisé.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPTopologyServiceApplication 67877d63-bff4-4521-867a-ef4979ba07ce -LoadBalancedURL "https://testurl"

Cet exemple définit l'URL avec équilibrage de la charge pour l'application du service de topologie.

Le GUID de l'application du service de topologie est unique pour chaque batterie. Vous pouvez exécuter l'applet de commande Get-SPTopologyServiceApplication pour extraire le GUID.

Voir aussi

Référence

Get-SPTopologyServiceApplication
Set-SPTopologyServiceApplicationProxy

Historique des modifications


Set-SPTopologyServiceApplicationProxy
Voir aussi Exemple
[image]

Définit les propriétés de proxy de l'application du service de topologie.

Set-SPTopologyServiceApplicationProxy [-Identity] <SPTopologyWebServiceProxyPipeBind> -BadListPeriod <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTopologyWebServiceProxyPipeBind

Spécifie le GUID du proxy de l'application.

Le type doit être un GUID valide, au format 1234-4567-098jhj.

BadListPeriod

Requis

System.String

Spécifie la durée pendant laquelle un nœud est conservé dans une liste incorrecte.

Le type doit être une valeur valide comprise entre 1 et 480 (en minutes).

La valeur par défaut est 10.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPTopologyServiceApplicationProxy définit les propriétés du proxy de l'application du service de topologie locale et du programme d'équilibrage de charge par défaut.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPTopologyServiceApplicationProxy 67877d63-bff4-4521-867a-ef4979ba07ce -BadListPeriod 1234

Cet exemple définit la durée de liste incorrecte pour le proxy de l'application du service de topologie donné.

Le GUID de l'application du service de topologie est unique pour chaque batterie. Vous pouvez exécuter l'applet de commande Get-SPTopologyServiceApplication pour extraire le GUID.

Voir aussi

Référence

Get-SPTopologyServiceApplicationProxy
Get-SPTopologyServiceApplication

Historique des modifications


Set-SPUsageApplication
Voir aussi Exemple
[image]

Définit les propriétés d'une application d'utilisation.

Set-SPUsageApplication [-Identity] <SPUsageApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseName <String>] [-DatabasePassword <SecureString>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-EnableLogging <SwitchParameter>] [-FailoverDatabaseServer <String>] [-UsageService <SPUsageServicePipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUsageApplicationPipeBind

Spécifie l'application d'utilisation à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application d'utilisation valide (par exemple, UsageApp1) ou une instance d'un objet SPServiceApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données de journalisation.

Le type doit être un nom valide de base de données SQL Server, par exemple UsageLogDB1.

Si la base de données de journalisation n'existe pas, elle sera créée automatiquement.

DatabasePassword

Facultatif

System.Security.SecureString

Spécifie le mot de passe de l'utilisateur spécifié dans DatabaseUserName . Utilisez ce paramètre uniquement si l'authentification SQL Server est utilisée pour accéder à la base de données de journalisation.

Le type doit être un mot de passe valide.

DatabaseServer

Facultatif

System.String

Spécifie le nom du serveur hôte de la base de données spécifiée dans DatabaseName.

Le type doit être un nom d'hôte SQL Server valide (par exemple, SQLServerHost1).

DatabaseUsername

Facultatif

System.String

Spécifie le nom d'utilisateur à utiliser pour se connecter à la base de données de journalisation. Utilisez ce paramètre uniquement si vous accédez à la base de données de journalisation via l'authentification SQL Server.

Le type doit être un nom d'utilisateur valide, par exemple UserName1.

EnableLogging

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que cette application d'utilisation collecte des données d'utilisation.

FailoverDatabaseServer

Facultatif

System.String

UsageService

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageServicePipeBind

Spécifie l'objet SPUsageService parent de l'application d'utilisation.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de service d'utilisation valide (par exemple, ServiceUtilisation1) ou une instance d'un objet SPUsageService valide.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPUsageApplication définit les propriétés d'une application d'utilisation.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE--------------------
Code de copie
Set-SPUsageApplication -Identity "Usage and Health data collection" -DatabaseServer "Server Name" -DatabaseName "New Logging DB

Cet exemple modifie le serveur de bases de données et le nom de la base de données utilisés par le service de journalisation d'utilisation pour stocker les données de journalisation.

Voir aussi

Référence

Get-SPUsageApplication
New-SPUsageApplication
Remove-SPUsageApplication

Historique des modifications


Set-SPUsageDefinition
Voir aussi Exemple
[image]

Définit la période de rétention pour un fournisseur d'utilisation.

Set-SPUsageDefinition [-Identity] <SPUsageDefinitionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DaysRetained <Int32>] [-Enable <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUsageDefinitionPipeBind

Spécifie l'objet de définition d'utilisation à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de définition d'utilisation valide (par exemple, SiteSubscriptionConfig1) ou une instance d'un objet SPUsageDefinition valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DaysRetained

Facultatif

System.Int32

Spécifie le nombre de jours de rétention des données d'utilisation pour le fournisseur d'utilisation dans la base de données du service d'utilisation. La valeur par défaut est 14.

Le type doit être un entier compris entre 0 et 31.

Enable

Facultatif

System.Management.Automation.SwitchParameter

Active le fournisseur d'utilisation spécifié.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPUsageDefinition définit la période de rétention pour un fournisseur d'utilisation spécifié. Un objet de définition d'utilisation définit un type de fournisseur d'utilisation spécifique.

Pour connaître les autorisations et les informations les plus récentes sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Set-SPUsageDefinition -Identity "Page Requests" -DaysRetained 31

Cet exemple définit à 31 le nombre de jours stockant les données d'utilisation des demandes de pages.

Voir aussi

Référence

Get-SPUsageDefinition

Historique des modifications


Set-SPUsageService
Voir aussi Exemple
[image]

Définit les propriétés d'un service d'utilisation.

Set-SPUsageService [[-Identity] <SPUsageServicePipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-LoggingEnabled <Nullable>] [-UsageLogCutTime <UInt32>] [-UsageLogLocation <String>] [-UsageLogMaxSpaceGB <UInt32>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPUsageServicePipeBind

Spécifie le service d'utilisation à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de service d'utilisation valide (par exemple, ServiceUtilisation1) ou une instance d'un objet SPUsageService valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

LoggingEnabled

Facultatif

System.Nullable

Spécifie que des données d'utilisation sont consignées dans des fichiers d'utilisation.

UsageLogCutTime

Facultatif

System.UInt32

Spécifie la durée, en minutes, des données d'utilisation recueillies par fichier journal d'utilisation. La durée par défaut est 5 minutes.

Le type doit être un entier compris entre 1 et 1440.

UsageLogLocation

Facultatif

System.String

Spécifie le chemin d'accès sur chaque ordinateur de la batterie où les fichiers journaux d'utilisation sont créés.

Le type doit être un chemin d'accès valide aux formats suivants (au choix) :

- C:\nom_dossier

- \\nom_serveur\nom_dossier

UsageLogMaxSpaceGB

Facultatif

System.UInt32

Spécifie le volume en mégaoctets (Mo) d'espace pouvant être utilisé par les fichiers journaux d'utilisation. La plage valide est comprise entre 500 et 20 000 Mo.

La valeur par défaut est 5 000.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPUsageService met à jour les propriétés d'un service d'utilisation. Si le paramètre Identity n'est pas spécifié, l'applet de commande applique les changements au service d'utilisation local.

Types d'entrée

Types retournés

Exemple

--------------------EXEMPLE-----------------
Code de copie
Set-SPUsageService -LoggingEnabled $false
Code de copie
Set-SPUsageService -UsageLogLocation "d:\\testusagelogdir
Code de copie
Set-SPUsageService -UsageLogCutTime 5

Ces exemples désactivent la consignation de l'utilisation, modifient le répertoire de stockage des fichiers d'utilisation et créent un nouveau fichier journal d'utilisation toutes les 5 minutes.

Voir aussi

Référence

Get-SPUsageService

Historique des modifications


Start-SPServiceInstance
Voir aussi Exemple
[image]

Démarre l'instance de service d'un service sur un serveur spécifique ou sur la batterie.

Start-SPServiceInstance [-Identity] <SPServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceInstancePipeBind

Spécifie le GUID de l'instance de service à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Start-SPServiceInstance pour démarrer l'instance de service d'un service sur un serveur spécifique ou sur la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE-----------------------
Code de copie
Start-SPServiceInstance 67877d63-bff4-4521-867a-ef4979ba07ce

Cet exemple démarre l'instance de service donnée sur le serveur.

Le GUID de l'instance de service est unique pour chaque batterie. Vous pouvez exécuter l'applet de commande Get-SPServiceInstance pour afficher le GUID des instances de service, puis utiliser le résultat tiré de l'applet de commande SPServiceInstance pour les autres applets de commande.

Voir aussi

Référence

Get-SPServiceInstance

Historique des modifications


Stop-SPServiceInstance
Voir aussi Exemple
[image]

Arrête l'instance de service d'un service.

Stop-SPServiceInstance [-Identity] <SPServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceInstancePipeBind

Spécifie le GUID de l'instance de service à obtenir.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Arrête l'instance de service d'un service sur le serveur spécifié ou pour la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE-----------------------
Code de copie
Stop-SPServiceInstance 67877d63-bff4-4521-867a-ef4979ba07ce

Cet exemple arrête l'instance de service dans le serveur donné.

Le GUID de l'instance de service est unique pour chaque batterie. Vous pouvez exécuter l'applet de commande Get-SPServiceInstance pour afficher le GUID des instances de service, puis utiliser le résultat tiré de l'applet de commande SPServiceInstance pour les autres applets de commande.

Voir aussi

Référence

Get-SPServiceInstance
Start-SPServiceInstance

Historique des modifications


Unpublish-SPServiceApplication
Voir aussi Exemple
[image]

Arrête le partage de l'application de service spécifiée en dehors de la batterie.

Unpublish-SPServiceApplication [-Identity] <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie le GUID de l'application de service dont le partage en dehors de la batterie doit être arrêté.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Unpublish-SPServiceApplication pour arrêter la publication de l'application de service, spécifiée par le paramètre Identity, en dehors de la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE-----------------------
Code de copie
UnPublish-SPServiceApplication 053c34be-d251-488c-8e94-644eae94da26

Cet exemple arrête la publication de l'application de service donnée en dehors de la batterie.

Le GUID d'application de service est unique pour chaque batterie. Vous pouvez exécuter les applets de commande Get-SPServiceApplication pour voir le GUID des applications de service, puis utiliser le résultat de l'applet de commande Get-SPServiceApplication pour les autres applets de commande SPServiceApplication ; par exemple, Grant-SPServiceApplication ou Publish-SPServiceApplication.

Voir aussi

Référence

Get-SPServiceApplication
Set-SPServiceApplication
Publish-SPServiceApplication
Revoke-SPServiceApplication
Grant-SPServiceApplication

Historique des modifications


Applets de commande pour le service Recherche de SharePoint Foundation 2010

La recherche pour Microsoft SharePoint Foundation 2010 permet d'effectuer une recherche portant sur les collections de sites. En règle générale, la recherche pour SharePoint Foundation 2010 est limitée à une collection de sites et n'analyse pas de sources de données externes. La plupart des fonctionnalités de recherche sont configurées automatiquement et les analyses de recherche se produisent automatiquement sans planification et sans contrôle de la part de l'administrateur.

Nom de l'applet de commande | Description
Get-SPSearchService | Retourne un service de recherche.
Set-SPSearchService | Définit les propriétés d'un service de recherche.
Get-SPSearchServiceInstance | Retourne une instance d'un service de recherche.
Set-SPSearchServiceInstance | Définit les propriétés d'une instance de service de recherche.

Historique des modifications


Get-SPSearchService
Voir aussi Exemple
[image]

Renvoie un service de recherche.

Get-SPSearchService [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPSearchService lit l'objet SPSearch lorsqu'elle met à jour le service de recherche.

Pour les autorisations et les informations les plus à jour sur Windows PowerShell pour SharePoint Foundation 2010, voir TechNet (http://go.microsoft.com/fwlink/?linkid=163184&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
$searchService = Get-SPSearchService

Cet exemple obtient une référence à l'objet du service de recherche.

Voir aussi

Référence

Set-SPSearchService
Get-SPSearchServiceInstance
Set-SPSearchServiceInstance

Historique des modifications


Set-SPSearchService
Voir aussi Exemple
[image]

Définit les propriétés d'un service de recherche.

Set-SPSearchService [[-Identity] <SPSearchServicePipeBind>] [-AddStartAddressForNonNTZone <String>] [-AssignmentCollection <SPAssignmentCollection>] [-CrawlAccount <String>] [-CrawlPassword <SecureString>] [-MaxBackupDuration <String>] [-PerformanceLevel <String>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.Search.Cmdlet.SPSearchServicePipeBind

Spécifie l'instance de service de recherche à définir.

Le type doit être un GUID valide, comme 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'instance de service de recherche, comme SearchServiceInstance1 ou une instance d'objet SearchServiceInstance valide.

AddStartAddressForNonNTZone

Facultatif

System.String

Spécifie qu'il convient d'ajouter une adresse de début aux applications Web qui n'ont pas de zone Windows NT.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

CrawlAccount

Facultatif

System.String

Spécifie le compte utilisateur ou le compte de service à utiliser pour l'analyse.

Le type doit être un compte administrateur valide, comme MyAdminAcct1.

CrawlPassword

Facultatif

System.Security.SecureString

Donne le mot de passe du compte de service spécifié dans CrawlAccount.

Le type doit être un mot de passe valide, comme UserIDPassword.

MaxBackupDuration

Facultatif

System.String

Spécifie l'intervalle, en minutes, entre le début de l'opération de sauvegarde du service de recherche dans l'index de contenu Microsoft SharePoint Foundation 2010 et le moment auquel les services de recherche reprennent.

PerformanceLevel

Facultatif

System.String

Spécifie le nombre relatif de threads pour les performances de l'indexeur :

Reduced : nombre total de threads = nombre de processeurs, nombre max. de threads/hôte = nombre de processeurs

PartlyReduced : nombre total de threads = 4 fois le nombre de processeurs, nombre max. de threads/hôte = 16 fois le nombre de processeurs

Maximum : nombre total de threads = nombre de processeurs

Le type doit être une des valeurs suivantes : Reduced, PartlyReduced ou Maximum

Description détaillée

L'applet de commande Set-SPSearchService modifie les propriétés de l'objet SearchService.

Pour les autorisations et les informations les plus à jour sur Windows PowerShell pour SharePoint Foundation 2010, voir TechNet (http://go.microsoft.com/fwlink/?linkid=163184&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Set-SPSearchService -MaxBackupDuration 120

Cet exemple définit la durée maximale, en minutes, entre le début d'une sauvegarde et la reprise des services de recherche.

Voir aussi

Référence

Get-SPSearchService
Get-SPSearchServiceInstance
Set-SPSearchServiceInstance

Historique des modifications


Get-SPSearchServiceInstance
Voir aussi Exemple
[image]

Renvoie une instance d'un service de recherche.

Get-SPSearchServiceInstance [[-Identity] <SPSearchServiceInstancePipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Local <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.Search.Cmdlet.SPSearchServiceInstancePipeBind

Spécifie le service de recherche à mettre à jour.

Le type doit être un GUID valide, comme 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide de service de recherche, comme MySearch1 ou une instance d'objet SearchService valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Local

Facultatif

System.Management.Automation.SwitchParameter

Spécifie qu'il convient de retourner l'instance de service de recherche du serveur de recherche actif.

Description détaillée

L'applet de commande Get-SPSearchServiceInstance lit un objet SPSearchServiceInstance lorsque l'applet de commande met à jour une instance de service de recherche qui est exécutée sur un ou plusieurs serveurs de la batterie de serveurs.

Pour les autorisations et les informations les plus à jour sur Windows PowerShell pour SharePoint Foundation 2010, voir TechNet (http://go.microsoft.com/fwlink/?linkid=163184&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPSearchServiceInstance -Local

Cet exemple obtient une référence à l'objet d'instance de service de recherche qui est exécuté sur l'ordinateur local.

Voir aussi

Référence

Set-SPSearchService
Get-SPSearchService
Set-SPSearchServiceInstance

Historique des modifications


Set-SPSearchServiceInstance
Voir aussi Exemple
[image]

Définit les propriétés d'une instance de service de recherche.

Set-SPSearchServiceInstance [-Identity] <SPSearchServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-ProxyType <String>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.Search.Cmdlet.SPSearchServiceInstancePipeBind

Spécifie l'instance de service de recherche à définir.

Le type doit être un GUID valide, comme 12345678-90ab-cdef-1234-567890bcdefgh ou un nom valide d'instance de service de recherche, comme SearchServiceInstance1 ou une instance d'objet SearchServiceInstance valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ProxyType

Facultatif

System.String

Définit si le robot utilise des paramètres de connexion par défaut, directs ou par proxy. Les valeurs valides sont default, direct et proxy. La valeur par défaut est default.

Le type doit être un nom valide de type de proxy, comme default.

Description détaillée

L'applet de commande Set-SPSearchServiceInstance modifie l'objet SearchServiceInstance.

Pour les autorisations et les informations les plus à jour sur Windows PowerShell pour SharePoint Foundation 2010, voir TechNet (http://go.microsoft.com/fwlink/?linkid=163184&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPSearchServiceInstance -Local | Set-SPSearchServiceInstance -ProxyType proxy

Cet exemple définit le type de proxy d'instance de service de recherche locale sur proxy.

Voir aussi

Référence

Set-SPSearchService
Get-SPSearchService
Get-SPSearchServiceInstance

Historique des modifications


Applets de commande pour la collection de sites (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour l'administration de collections de sites pour Microsoft SharePoint Foundation 2010.

Nom de l'applet de commande | Description
Get-SPWebPartPack | Retourne les packages de composants WebPart qui ont été installés pour l'étendue spécifiée.
Install-SPWebPartPack | Installe le package de composants WebPart spécifié à l'emplacement spécifié.

Historique des modifications

Date | Description | Raison
24 juin 2010 | Publication initiale |


Get-SPWebPartPack
Voir aussi Exemple
[image]

Renvoie les packages de composants WebPart qui ont été installés pour l'étendue spécifiée.

Get-SPWebPartPack [[-Identity] <String>] [-AssignmentCollection <SPAssignmentCollection>] [-GlobalOnly <SwitchParameter>] [-WebApplication <SPWebApplicationPipeBind>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

System.String

Spécifie le nom complet ou partiel du package de composants WebPart à partir de la base de données de configuration.

Le type doit être un nom valide de package de composants WebPart, par exemple, MonPackageComposantWebPart.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

GlobalOnly

Facultatif

System.Management.Automation.SwitchParameter

Renvoie uniquement les packages de composants WebPart installés dans le GAC.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web à partir de laquelle répertorier les packages de composants WebPart. Si aucune application Web n'est spécifiée, les packages de composants WebPart spécifiés sont renvoyés à partir de toutes les applications Web.

Description détaillée

L'applet de commande Get-SPWebPartPack renvoie les packages de composants WebPart installés qui correspondent au paramètre Identity. L'étendue des résultats peut être affinée grâce au paramètre facultatif WebApplication. L'étendue ne comprend pas les packages de composants WebPart installés dans le GAC (Global Assembly Cache) sauf si le paramètre GlobalOnly est utilisé. Dans ce cas, seuls les packages de composants WebPart installés dans le GAC sont renvoyés.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPWebPartPack -WebApplication http://zsharepoint2:80

Cet exemple renvoie tous les packages de composants WebPart ayant été installés sur l'application Web sur le port 80 de la batterie locale.

Voir aussi

Référence

Install-SPWebPartPack
Uninstall-SPWebPartPack

Historique des modifications


Install-SPWebPartPack
Voir aussi Exemple
[image]

Installe le package de composants WebPart spécifié à l'emplacement spécifié.

Install-SPWebPartPack [-LiteralPath] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-GlobalInstall <SwitchParameter>] [-Language <UInt32>] [-WebApplication <SPWebApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]
Install-SPWebPartPack [-Name] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-GlobalInstall <SwitchParameter>] [-Language <UInt32>] [-WebApplication <SPWebApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

LiteralPath

Requis

System.String

Spécifie le chemin d'accès exact vers le package de composants WebPart.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Remplace tout package de composant WebPart existant du même nom ou installé au même emplacement.

GlobalInstall

Facultatif

System.Management.Automation.SwitchParameter

Installe le package de composants WebPart dans le Global Assembly Cache (GAC) plutôt que dans le répertoire /bin de chaque application Web. Cette installation rend le composant WebPart accessible de manière globale sur les serveurs.

Language

Facultatif

System.UInt32

Spécifie l'ID de langue du package de composants WebPart.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web sur laquelle installer le package de composants WebPart. Si aucune application Web n'est spécifiée, le package de composants WebPart est installé dans toutes les applications Web.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Name

Requis

System.String

Spécifie le nom du package de composants WebPart à installer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Remplace tout package de composant WebPart existant du même nom ou installé au même emplacement.

GlobalInstall

Facultatif

System.Management.Automation.SwitchParameter

Installe le package de composants WebPart dans le Global Assembly Cache (GAC) plutôt que dans le répertoire /bin de chaque application Web. Cette installation rend le composant WebPart accessible de manière globale sur les serveurs.

Language

Facultatif

System.UInt32

Spécifie l'ID de langue du package de composants WebPart.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web sur laquelle installer le package de composants WebPart. Si aucune application Web n'est spécifiée, le package de composants WebPart est installé dans toutes les applications Web.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Install-SPWebPartPack installe le package de composants WebPart à l'emplacement du paramètre LiteralPath dans la batterie de serveurs locale. Le package de composants WebPart peut être installé dans une application Web spécifique à l'aide du paramètre WebApplication. Si aucune application Web n'est spécifiée, le package de composants WebPart est installé dans toutes les applications Web.

Utilisez le paramètre Language pour spécifier une langue pour le package.

Utilisez le paramètre GlobalInstall pour installer le package sur le Global Assembly Cache (GAC). Les assemblys du GAC jouissent d'une autorisation FullTrust, qui donne à ce package un accès complet à toutes les ressources du système.

Utilisez le paramètre Force pour installer le package et remplacer tout package de composants WebPart existant du même nom ou installé au même emplacement.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Install-SPWebPartPack "MyCustomWebPartPack" -LiteralPath "c:/mywebpart.wpp" -GlobalInstall

Cet exemple installe le package de composants WebPart nommé MyCustomWebPartPack dans toute la batterie à partir du chemin d'accès c:/mywebpart.wpp.

Voir aussi

Référence

Uninstall-SPWebPartPack
Get-SPWebPartPack

Historique des modifications


Applets de commande pour la gestion des sites (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour gérer des sites dans une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Get-SPUser

Get-SPWeb

Get-SPWebApplication

Get-SPFarm

Get-SPProduct

Get-SPServer

Get-SPSite

Get-SPSiteAdministration

Get-SPSiteSubscription

Get-SPSiteSubscriptionConfig

Move-SPUser

New-SPSite

New-SPSiteSubscription

New-SPSubscriptionSettingsService

New-SPUser

New-SPWeb

New-SPWebApplication

New-SPWebApplicationExtension

Remove-SPSite

Remove-SPSiteSubscription

Remove-SPSiteSubscriptionSettings

Remove-SPUser

Remove-SPWeb

Remove-SPWebApplication

Rename-SPServer

Set-SPSite

Set-SPSiteAdministration

Set-SPSiteSubscriptionConfig

Set-SPSubscriptionSettingsServiceApplication

Set-SPUser

Set-SPWebApplication

Set-SPWeb

Export-SPSiteSubscriptionSettings

Import-SPSiteSubscriptionSettings

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Get-SPCustomLayoutsPage
Exemple
[image]

Renvoie un mappage vers une mise en page personnalisée.

Get-SPCustomLayoutsPage -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Identity <None | AccessDenied | Confirmation | Error | Login | RequestAccess | Signout | WebDeleted>]

Paramètres

Paramètre Requis Type Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web SharePoint contenant la mise en page personnalisée.

Le type doit être une URL valide, au format http://server_name, un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MonAppOffice) ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Identity

Facultatif

Microsoft.SharePoint.Administration.SPWebApplication+SPCustomPage

Spécifie la mise en page personnalisée à obtenir.

Le type doit être un des suivants : None, AccessDenied, Confirmation, Error, Login, RequestAccess, Signout ou WebDeleted.

Description détaillée

L'applet de commande Get-SPCustomLayoutsPagecmdlet renvoie un mappage vers une mise en page personnalisée dans une application Web. Si le paramètre Identity n'est pas spécifié, cet applet de commande renvoie la collection de mappages pour toutes les mises en page personnalisées.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Get-SPCustomLayoutsPage -Identity "_layouts/accessdenied.aspx" -WebApplication "http://server_name/mywebapp"

Cet exemple renvoie le mappage de la mise en page AccessDenied dans l'application Web.

Historique des modifications


Get-SPUser
Voir aussi Exemple
[image]

Renvoie le ou les compte(s) d'utilisateur(s) correspondant à un critère de recherche donné.

Get-SPUser [[-Identity] <SPUserPipeBind>] -Web <SPWebPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Group <SPGroupPipeBind>] [-Limit <String>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPUserPipeBind

Spécifie le GUID ou le nom de connexion de l'utilisateur à renvoyer.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-5678-9807.

Web

Requis

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie le site Web à utiliser en tant qu'étendue.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide de site Web Microsoft SharePoint Foundation 2010 (par exemple, MySPSite1), ou une instance d'un objet SPWeb valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell. SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Group

Facultatif

Microsoft.SharePoint.PowerShell.SPGroupPipeBind

Spécifie le groupe d'utilisateurs auquel appartient le nouvel utilisateur.

Limit

Facultatif

System.String

Spécifie le nombre maximal d'utilisateurs à renvoyer. La valeur par défaut est 500.

Description détaillée

L'applet de commande Get-SPUser renvoie tous les comptes d'utilisateurs SharePoint correspondant à l'étendue indiquée par les paramètres Identity, Web ou Group.

Le paramètre Identity peut utiliser l'alias d'un utilisateur pour renvoyer des correspondances exactes. Toutefois, une étendue doit être spécifiée pour que l'applet de commande Get-SPUser fonctionne.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPUser -Web "http://zsharepoint2" -Group "Viewers"

Cet exemple renvoie tous les membres du groupe Viewers sur le site Web http://zsharepoint2.

Voir aussi

Référence

Move-SPUser
New-SPUser
Set-SPUser
Remove-SPUser

Historique des modifications


Get-SPWeb
Voir aussi Exemple
[image]

Renvoie tous les sous-sites correspondant aux critères donnés.

Get-SPWeb [[-Identity] <SPWebPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-Regex <SwitchParameter>] [-Site <SPSitePipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie le nom ou l'URL complète ou partielle du sous-site. Si vous utilisez un chemin d'accès relatif, vous devez spécifier le paramètre Site.

URL valide au format http://server_name ou chemin d'accès relatif au format /SubSites/MySubSite.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le filtre côté serveur à utiliser pour l'étendue spécifiée.

Le type doit être un filtre valide au format {filterName <operator> "filterValue"}.

Limit

Facultatif

System.String

Limite le nombre maximal de sous-sites à renvoyer. La valeur par défaut est 200. Pour renvoyer tous les sites, entrez TOUS.

Le type doit être un nombre valide supérieur à 0 ou TOUS.

Regex

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si l'URL fournie par le paramètre Identity est traitée comme une expression régulière. .

Site

Facultatif

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie l'URL ou le GUID de la collection de sites à partir de laquelle répertorier les sous-sites.

Le type doit être une URL valide au format http://server_name, un GUID au format 1234-5678-9807 ou un objet SPSite.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Get-SPWeb renvoie tous les sous-sites qui correspondent à l'étendue donnée par le paramètre Identity. Tous les sous-sites répondant à ces critères sont renvoyés.

Le paramètre Identity peut être l'URL complète ou un chemin d'accès relatif. Si vous spécifiez un chemin d'accès relatif, vous devez également spécifier le paramètre Site afin d'identifier la collection de sites à partir de laquelle le sous-site est renvoyé.

Le paramètre Identity prend également en charge la spécification d'une URL partielle qui se termine par un caractère générique (*). Tous les sous-sites qui correspondent à cette URL partielle pour l'étendue spécifiée sont renvoyés. De plus, si le paramètre Regex est spécifié, le paramètre Identity est traité comme une expression régulière, et chaque sous-site Web dont l'URL fait partie de l'étendue donnée et correspond à l'expression est renvoyé.

Le paramètre Filter est un filtre côté serveur pour certaines propriétés de sous-site stockées dans la base de données de contenu. Sans le paramètre Filter, le filtrage sur ces propriétés est lent. Ces propriétés de sous-site sont Template et Title. Le paramètre Filter est un bloc de script qui utilise la même syntaxe qu'une instruction Where-Object, mais qui s'exécute côté serveur pour des résultats plus rapides.

Il est important de noter que chaque collection de sites renvoyée par l'applet de commande Get-SPWeb est automatiquement éliminée au terme du pipeline. Pour stocker les résultats de l'applet de commande Get-SPWeb dans une variable locale, utilisez les applets de commande Start-SPAssignment et Stop-SPAssignment afin d'éviter les fuites de mémoire.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Get-SPWeb -site http://sitename/sites/site1

Cet exemple renvoie tous les sous-sites Web d'une collection de sites donnée.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPWeb -Site http://sitename/sites/site1  -filter {$_.Template -eq "STS#0"}

Cet exemple affiche tous les sous-sites qu'utilise le modèle "STS#0".

------------------EXEMPLE 3-----------------------
Code de copie
Start-SPAssignment -Global
Code de copie
$w = Get-SPWeb http://sitename
Code de copie
$w.set_SiteLogoUrl("http://PathToImage/test.jpg")
Code de copie
$w.Update()
Code de copie
Stop-SPAssignment -Global

Cet exemple montre comment enregistrer un sous-site comme variable et comment appeler des méthodes de modèle d'objet sur l'objet SPAssignment.

Voir aussi

Référence

New-SPWeb
Set-SPWeb
Remove-SPWeb
Import-SPWeb

Historique des modifications


Get-SPWebApplication
Voir aussi Exemple
[image]

Renvoie tous les applications Web correspondant au critère donné.

Get-SPWebApplication [[-Identity] <SPWebApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-IncludeCentralAdministration <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom, l'URL ou le GUID de l'application Web.

Le type doit être une URL valide au format http://server_name, un GUID au format 1234-5678-9876-0987 ou un nom valide au format SPWebApplication - 1212.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

IncludeCentralAdministration

Facultatif

System.Management.Automation.SwitchParameter

Inclut l'application Web Administration centrale dans la collection d'applications Web pouvant être renvoyée. Le paramètre IncludeCentral Administration doit néanmoins répondre à tous les autres filtres fournis.

Description détaillée

L'applet de commande Get-SPWebApplication renvoie toutes les applications Web correspondant à l'étendue donnée par le paramètre Identity. Le nom du paramètre Identity peut être le nom, l'URL ou le GUID de l'application Web. Si aucun paramètre Identity n'est spécifié, toutes les applications Web sont renvoyées.

L'application Web Administration centrale est renvoyée uniquement si son identité exacte est fournie ou que l'indicateur IncludeCentralAdministration est fourni.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1----------------------
Code de copie
$w = Get-SPWebApplication http://sitename

Cet exemple récupère l'application Web pour http://sitename et la stocke dans une variable.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPWebApplication -IncludeCentralAdministration | Where { $_.DefaultServerComment -eq "SharePoint Central Administration v4"} | Format-List *

Cet exemple affiche toutes les propriétés publiques sur l'application Web SharePoint Central Administration au format de liste.

Voir aussi

Référence

Get-SPWebApplicationHttpThrottlingMonitor

Historique des modifications


Get-SPFarm
Voir aussi Exemple
[image]

Renvoie la batterie SharePoint locale.

Get-SPFarm [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPFarm renvoie la batterie SharePoint locale. Aucun paramètre n'est utilisé.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

SPFarm

Exemple
Code de copie
$f = Get-SPFarm

Cet exemple stocke la batterie locale dans une variable.

Voir aussi

Référence

Get-SPFarmConfig
Set-SPFarmConfig
Backup-SPFarm
Restore-SPFarm

Historique des modifications


Get-SPProduct
Exemple
[image]

Renvoie une liste des produits SharePoint installés dans la batterie et les versions de toutes les mises à jour installées de chaque produit.

Get-SPProduct [-AssignmentCollection <SPAssignmentCollection>] [-Local <SwitchParameter>]
Get-SPProduct [-AssignmentCollection <SPAssignmentCollection>] [-Server <SPServerPipeBind>]

Paramètres

1

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Local

Facultatif

System.Management.Automation.SwitchParameter

Renvoie les informations produit et de mise à jour pour l'ordinateur local uniquement. Si vous utilisez le paramètre Local, vous ne pouvez pas utiliser le paramètre Server.

2

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Server

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Renvoie les informations produit et de mise à jour pour un serveur spécifique uniquement. Si vous utilisez le paramètre Server, vous ne pouvez pas utiliser le paramètre Local.

Description détaillée

L'applet de commande Get-SPProduct renvoie une liste des produits SharePoint installés dans la batterie et les versions de toutes les mises à jour installées pour chaque produit. Par défaut, cette applet de commande renvoie la liste des produits SharePoint installés dans la batterie. Utilisez le paramètre Local pour obtenir uniquement les informations concernant le serveur local ou le paramètre Server pour obtenir la liste d'un serveur spécifique.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPProduct -Local

Cet exemple affiche les produits SharePoint installés sur le serveur local.

Historique des modifications


Get-SPServer
Voir aussi Exemple
[image]

Renvoie le ou les serveurs de la batterie correspondant à l'identité donnée.

Get-SPServer [[-Identity] <SPServerPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie l'adresse du serveur à renvoyer.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPServer renvoie l'objet SPServer pour l'identité donnée (si elle existe dans la batterie de serveurs). Si aucun paramètre n'est spécifié, l'applet de commande renvoie tous les serveurs de la batterie de serveurs.

Pour connaître les autorisations et les informations les plus récentes concernant Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Get-SPServer

Cet exemple renvoie tous les serveurs de la batterie locale dans une liste.

--------------EXEMPLE 2-----------------
Code de copie
Get-SPServer | Where{ $_.NeedsUpgrade -eq $TRUE}

Cet exemple renvoie une liste de tous les serveurs de la batterie nécessitant une mise à niveau.

Voir aussi

Référence

Rename-SPServer

Historique des modifications


Get-SPSite
Voir aussi Exemple
[image]

Renvoie toutes les collections de sites correspondant aux critères donnés.

Get-SPSite [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-WebApplication <SPWebApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]
Get-SPSite [-Identity] <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-Regex <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Get-SPSite -ContentDatabase <SPContentDatabasePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-WhatIf [<SwitchParameter>]]
Get-SPSite -SiteSubscription <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom et une valeur de filtre valides au format {$_PropertyName <operator> "filterValue"}.

Les opérateurs valides sont : EQ, NE, LIKE, NOTLIKE.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Spécifiez ALL pour renvoyer toutes les collections de sites de l'étendue donnée.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'URL, le GUID ou le nom de l'application Web à partir de laquelle répertorier les sites.

Le type doit être une URL valide au format http://server_name, un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh) ou le nom de l'application Web (par exemple, WebApplication1212).

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie l'URL ou le GUID de la collection de sites à obtenir.

Le type doit être une URL valide, au format http://server_name ou http://server_name/site_name, ou un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh).

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom et une valeur de filtre valides au format {$_PropertyName <operator> "filterValue"}.

Les opérateurs valides sont : EQ, NE, LIKE, NOTLIKE.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Spécifiez ALL pour renvoyer toutes les collections de sites de l'étendue donnée.

Regex

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si l'URL fournie par le paramètre Identity est traitée comme une expression régulière.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

ContentDatabase

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie le GUID de la base de données de contenu à partir de laquelle répertorier les collections de sites.

Le type doit être un nom de base de données valide, au format SPContentDB01, ou un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh).

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom et une valeur de filtre valides au format {$_PropertyName <operator> "filterValue"}.

Les opérateurs valides sont : EQ, NE, LIKE, NOTLIKE.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Spécifiez ALL pour renvoyer toutes les collections de sites de l'étendue donnée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

4

Paramètre

Requis

Type

Description

SiteSubscription

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie l'inscription de sites à partir de laquelle obtenir les collections de sites.

Le type doit être une URL valide, au format http://server_name, ou un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh).

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom et une valeur de filtre valides au format {$_PropertyName <operator> "filterValue"}.

Les opérateurs valides sont : EQ, NE, LIKE, NOTLIKE.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Spécifiez ALL pour renvoyer toutes les collections de sites de l'étendue donnée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Get-SPSite renvoie soit un seul site correspondant au paramètre Identity, soit tous les sites correspondant au paramètre Filter pour l'étendue spécifiée. Les étendues sont les paramètres WebApplication, ContentDatabase et SiteSubscription. Si aucune de ces étendues n'est fournie, l'étendue est la batterie. Si l'étendue est spécifiée sans paramètre Filter, tous les sites de cette étendue sont renvoyés.

Le paramètre Identity prend également en charge la spécification d'une URL partielle qui se termine par un caractère générique (*). Toutes les collections de sites qui correspondent à cette URL partielle pour l'étendue spécifiée sont renvoyées. De plus, si le paramètre Regex est spécifié, le paramètre Identity est traité comme une expression régulière, et chaque collection de sites dont l'URL fait partie de l'étendue donnée et correspond à l'expression est renvoyée.

Le paramètre Filter est un filtre côté serveur pour certaines propriétés de collection de sites stockées dans la base de données de contenu. Sans le paramètre Filter, le filtrage sur ces propriétés est lent. Ces propriétés de collection de sites sont Owner, SecondaryOwner et LockState. Le paramètre Filter est un bloc de script qui utilise la même syntaxe qu'une instruction Where-Object, mais qui s'exécute côté serveur pour des résultats plus rapides.

Les valeurs valides pour LockState sont Unlock, NoAdditions, ReadOnly, NoAccess.

Il est important de noter que chaque collection de sites renvoyée par l'applet de commande Get-SPSite est automatiquement éliminée au terme du pipeline. Pour stocker les résultats de l'applet de commande Get-SPSite dans une variable locale, utilisez les applets de commande Start-SPAssignment et Stop-SPAssignment afin d'éviter les fuites de mémoire.

Types d'entrée

Aucun

Types retournés

Exemple

------------------EXEMPLE 1---------------------
Code de copie
Get-SPSite 'http://sitename' | Get-SPWeb -Limit All | Select Title

Cet exemple extrait la collection de titres de sous-sites de la collection de sites à l'adresse http://sitename.

------------------EXEMPLE 2---------------------
Code de copie
Get-SPSite -ContentDatabase "b399a366-d899-4cff-8a9b-8c0594ee755f" | Format-Table -Property Url, Owner, SecondaryOwner

Cet exemple extrait un sous-ensemble de données de tous les sites de la base de données b399a366-d899-4cff-8a9b-8c0594ee755f actuelle.

------------------EXEMPLE 3---------------------
Code de copie
Start-SPAssignment -Global
Code de copie
$s = Get-SPSite -Identity http://MyApp/Sites/Site1
Code de copie
$s.Url
Code de copie
Stop-SPAssignment -Global

Cet exemple extrait les sites spécifiés par le paramètre Identity et insère les résultats dans la variable s.

L'exemple précédent utilise la méthode Global d'affectation de collection. La méthode Global est plus simple à utiliser mais le contenu de cet objet croît rapidement. Veillez à ne pas exécuter de commande Get-SPSite qui renvoie un grand nombre de résultats lorsque l'affectation globale est activée.

------------------EXEMPLE 4---------------------
Code de copie
$GC = Start-SPAssignment
Code de copie
$Sites = $GC | Get-SPSite -Filter {$_.Owner -eq "DOMAIN\JDoe"} -Limit 50
Code de copie
Stop-SPAssignment $GC

Cet exemple obtient les 50 premiers sites détenus par l'utilisateur DOMAIN\JDoe via une requête côté serveur et les affecte à une variable locale.

Cet exemple utilise des méthodes avancées d'affectation de collection.

------------------EXEMPLE 5---------------------
Code de copie
Get-SPWebApplication http://sitename | Get-SPSite -Limit All |ForEach-Object {$sum=0}{ $sum+=$_.Usage.Storage }{$sum}

Cet exemple montre une commande qui renvoie la somme de l'espace disque utilisé pour tous les sites d'une application Web donnée.

------------------EXEMPLE 6---------------------
Code de copie
Get-SPSite -Identity "http://localserver/(my|personal)/sites" -Regex

Cet exemple renvoie tous les sites qui correspondent à l'expression régulière donnée.

Les guillemets dans le paramètre Identity sont obligatoires lorsque vous utilisez le paramètre Regex.

------------------EXEMPLE 7---------------------
Code de copie
Get-SPSite http://sitename/sites/teams/* -Limit 100

Cet exemple obtient jusqu'à 100 sites sous l'URL http://sitename/sites/teams.

------------------EXEMPLE 8---------------------
Code de copie
Get-SPSite | select url, @{Expression={$_.Usage.Storage}}

Cet exemple obtient le volume de stockage utilisé par une collection de sites en utilisant le champ de stockage de la propriété .UsageInfo.

Voir aussi

Référence

Backup-SPSite
Move-SPSite
New-SPSite
Remove-SPSite
Restore-SPSite
Set-SPSite

Historique des modifications


Get-SPSiteAdministration
Voir aussi Exemple
[image]

Renvoie un objet d'administration de site qui permet aux administrateurs de batteries de serveurs d'afficher certaines informations sur des collections de sites auxquelles ils n'ont pas accès.

Get-SPSiteAdministration [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-WebApplication <SPWebApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]
Get-SPSiteAdministration [-Identity] <SPSiteAdministrationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-Regex <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Get-SPSiteAdministration -ContentDatabase <SPContentDatabasePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-WhatIf [<SwitchParameter>]]
Get-SPSiteAdministration -SiteSubscription <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom de filtre valide et une valeur au format { $_ PropertyName <operator > "filterValue"}}.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Choisissez TOUS pour renvoyer toutes les collections de sites pour l'étendue donnée.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'URL, le GUID ou le nom de l'application Web à partir de laquelle répertorier les sites.

Le type doit être une URL valide au format http://server_name, un GUID valide (par exemple, 12345678-90ab-cdef-1234-567890bcdefgh) ou le nom de l'application Web (par exemple, WebApplication1212).

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSiteAdministrationPipeBind

Spécifie l'URL (complète ou partielle) ou le GUID de la collection de sites à récupérer.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-456-987fg.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom de filtre valide et une valeur au format { $_ PropertyName <operator > "filterValue"}}.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Choisissez TOUS pour renvoyer toutes les collections de sites pour l'étendue donnée.

Regex

Facultatif

System.Management.Automation.SwitchParameter

Lorsque ce commutateur est activé, l'URL spécifiée pour le paramètre Identity est traitée comme une expression régulière.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

ContentDatabase

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie l'URL (complète ou partielle) ou le GUID de la collection de sites à récupérer.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-456-987fg.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom de filtre valide et une valeur au format { $_ PropertyName <operator > "filterValue"}}.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Choisissez TOUS pour renvoyer toutes les collections de sites pour l'étendue donnée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

4

Paramètre

Requis

Type

Description

SiteSubscription

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie le groupe de sites à partir duquel obtenir les collections de sites.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un site SharePoint (objet ou URL) d'une collection de sites membre de l'abonnement au site ou une instance d'un objet SiteSubscription valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Filter

Facultatif

System.Management.Automation.ScriptBlock

Spécifie le bloc de script du filtre côté serveur à appliquer.

Le type doit être un nom de filtre valide et une valeur au format { $_ PropertyName <operator > "filterValue"}}.

Limit

Facultatif

System.String

Limite le nombre maximal de collections de sites à renvoyer. La valeur par défaut est 200.

Le type doit être un nombre non négatif valide. Choisissez TOUS pour renvoyer toutes les collections de sites pour l'étendue donnée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Get-SPSiteAdminitration renvoie un objet d'administration de site qui permet aux administrateurs de batteries de serveurs d'afficher certaines informations sur des collections de sites auxquelles ils n'ont pas accès.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
Get-SPSiteAdministration | Select -Property Url, OwnerLoginName, @{Name="Storage";Expression={$_.Quota.StorageMaximumLevel}}

Cet exemple obtient un sous-ensemble de données de tous les sites de la base de données de contenu avec l'URL b399a366-d899-4cff-8a9b-8c0594ee755f (l'administrateur de la batterie de serveurs ne nécessite pas l'accès). Cette commande utilise la propriété calculée Storage pour afficher la valeur maximale de stockage de la base de données de contenu.

------------------EXEMPLE 2------------------
Code de copie
Start-SPAssignment -Global
$s = Get-SPSiteAdministration -Identity http://MyApp/Sites/Site1
$s.Url
Stop-SPAssignment -Global

Cet exemple obtient les collections de sites spécifiées par le paramètre Identity et insère les résultats dans la variable s. Cet exemple utilise la méthode Global de nettoyage de la mémoire. Cette méthode est plus facile à utiliser mais grossit rapidement. N'exécutez pas une commande Get-SPSite qui renvoie de nombreux résultats alors que l'affectation globale est activée.

------------------EXEMPLE 3------------------
Code de copie
$GC = Start-SPAssignment
$Sites = $GC | Get-SPSiteAdministration -Filter {$_.Owner -eq "DOMAIN\JDoe"} -Limit 50
Stop-SPAssignment $GC

Cet exemple obtient les 50 premiers sites détenus par l'utilisateur DOMAIN\JDoe via une requête côté serveur et affecte les sites renvoyés à une variable locale. Cette commande utilise des méthodes avancées d'affectation de collection.

------------------EXEMPLE 4------------------
Code de copie
Get-SPWebApplication http://sitename | Get-SPSiteAdministration -Limit All |ForEach-Object {$sum=0}{ $sum+=$_.DiskUsed }{$sum}

Cette commande renvoie la somme de l'utilisation de l'espace disque de tous les sites de l'application Web spécifiée.

------------------EXEMPLE 5------------------
Code de copie
Get-SPWebApplication http://sitename | Get-SPSiteAdministration -Limit ALL | Select URL

Cet exemple obtient les URL de toutes les collections de sites d'une application Web.

------------------EXEMPLE 6------------------
Code de copie
Get-SPSiteAdministration -identity "http://localserver/(my|personal)/sites" -Regex

Cet exemple renvoie tous les sites qui correspondent à l'expression régulière donnée. Les guillemets qui encadrent la valeur spécifiée pour le paramètre Identity sont requis si vous utilisez l'indicateur Regex.

------------------EXEMPLE 7------------------
Code de copie
Get-SPSite "http://sitename/sites/teams/*" -Limit 100

Cet exemple obtient jusqu'à 100 sites sous l'URL http://sitename/sites/teams.

Voir aussi

Référence

Set-SPSiteAdministration

Historique des modifications


Get-SPSiteSubscription
Voir aussi Exemple
[image]

Renvoie l'abonnement au site de l'URL donnée ou tous les abonnements au site de la batterie locale.

Get-SPSiteSubscription [[-Identity] <SPSiteSubscriptionPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie l'ID de l'abonnement.

Le type doit être une URL valide, au format http://server_name.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPSiteSubscription renvoie l'abonnement au site pour l'URL donnée lorsque le paramètre Identity est utilisé. Si aucun paramètre n'est spécifié, tous les abonnements au site uniques de la batterie sont répertoriés.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE----------------------
Code de copie
$SiteSub = Get-SPSiteSubscription http://Contoso.com
Code de copie
$SiteSub = Get-SPSite http://contoso.com | Get-SPSiteSubscription

Cet exemple extrait l'abonnement au site pour http://Contoso.com.

Voir aussi

Référence

New-SPSiteSubscription
Remove-SPSiteSubscription

Historique des modifications


Get-SPSiteSubscriptionConfig
Exemple
[image]

Renvoie les propriétés de configuration d'un abonnement au site.

Get-SPSiteSubscriptionConfig [-Identity] <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie la configuration d'abonnement au site à récupérer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un SPSite (objet ou URL) d'une collection de sites membre de l'abonnement au site, ou une instance d'un objet SiteSubscription valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPSiteSubscriptionConfig renvoie les propriétés de configuration d'un abonnement au site.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

---------------EXEMPLE---------------
Code de copie
Get-SPSiteSubscriptionConfig http://contoso.com | Select FeatureSet

Cet exemple récupère l'ID du jeu de fonctions pour l'abonnement au site qui contient le site Web http://contoso.com.

Historique des modifications


Move-SPSite
Voir aussi Exemple
[image]

Déplace les collections de site d'une base de données de contenu à une autre.

Move-SPSite [-Identity] <SPSitePipeBind> -DestinationDatabase <SPContentDatabasePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie l'identité de la collection de sites à déplacer. Par exemple, http://previous_server_name.

DestinationDatabase

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie la base de données de contenu vers laquelle la collection de sites doit être transférée. Par exemple, ContentDB2.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Move-SPSite déplace les données de la collection de sites spécifiée de sa base de données actuelle à la base de données spécifiée par le paramètre DestinationDatabase. Un verrou en lecture seule est appliqué à la collection de sites afin d'empêcher les utilisateurs d'en modifier les données pendant le transfert. Une fois le transfert terminé, la collection de sites est renvoyée à son état de verrouillage d'origine. La base de données de destination spécifiée doit exister, être attachée au même serveur SQL Server que la base de données de contenu actuelle de la collection de sites et à l'application Web actuelle de la collection de sites.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE 1-----------------------
Code de copie
Move-SPSite http://servername/sites/sitename -DestinationDatabase ContentDb2

Cet exemple déplace la collection de sites http://previous_server_name vers la base de données de contenu ContentDb2.

---------------------EXEMPLE 2-----------------------
Code de copie
Get-SPSite -ContentDatabase ContentDb1 | Move-SPSite -DestinationDatabase ContentDb2

Cet exemple déplace toutes les collections de sites de ContentDb1 vers ContentDb2.

---------------------EXEMPLE 3-----------------------
Code de copie
Get-SPSiteAdministration | where { $_.OwnerLoginName -eq "DOMAIN\username" } | Move-SPSite -DestinationDatabase ContentDb2

Cet exemple déplace toutes les collections de sites dont DOMAINE\nomutilisateur est le propriétaire vers ContentDb2. L'applet de commande Get-SPSiteAdministration est utilisée plutôt que Get-SPSite car vous devez posséder les autorisations d'accès aux propriétés de l'objet SPSite dans la collection de sites. Vous pouvez accéder aux propriétés de l'objet SPSiteAdministration en tant qu'administrateur de batterie SharePoint.

Voir aussi

Référence

Backup-SPSite
Get-SPSite
Restore-SPSite
Get-SPSiteAdministration

Historique des modifications


Move-SPUser
Voir aussi Exemple
[image]

Migre un compte d'utilisateur dans des produits SharePoint 2010.

Move-SPUser [-Identity] <SPUserPipeBind> -NewAlias <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-IgnoreSID <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUserPipeBind

Spécifie le GUID ou le nom de connexion de l'utilisateur à renvoyer.

Le type doit être un GUID de l'utilisateur valide au format 1234-5678-9876-0987.

NewAlias

Requis

System.String

Spécifie le nom de l'URL ou du GUID à utiliser en tant qu'étendue.

Le type doit être une URL et un GUID valides au format http://server_name or 1234-5678-9807.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

IgnoreSID

Facultatif

System.Management.Automation.SwitchParameter

Indique (s'il est présent) qu'Active Directory ne devra pas fournir l'attribut d'historique des SID pour garantir la correspondance du nouveau nom de connexion avec l'ancien.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Move-SPUser migre l'accès utilisateur d'un compte d'utilisateur de domaine à un autre. S'il existe déjà une entrée pour le nouveau nom de connexion, elle est marquée pour être supprimée afin de permettre la migration.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exemple

------------------EXEMPLE------------------
Code de copie
Move-SPUser -Identity "DOMAIN\JaneDoe" -NewAlias "Domain\JaneSmith"

Cet exemple migre DOMAIN\JaneDoe vers le nouveau compte de DOMAIN\JaneSmith.

Voir aussi

Référence

New-SPUser
Set-SPUser
Remove-SPUser
Get-SPUser

Historique des modifications


New-SPSite
Voir aussi Exemple
[image]

Crée une nouvelle collection de sites à l'URL spécifiée.

New-SPSite [-Url] <String> -OwnerAlias <SPUserPipeBind> [-AdministrationSiteType <None | TenantAdministration>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ContentDatabase <SPContentDatabasePipeBind>] [-Description <String>] [-HostHeaderWebApplication <SPWebApplicationPipeBind>] [-Language <UInt32>] [-Name <String>] [-OwnerEmail <String>] [-QuotaTemplate <SPQuotaTemplatePipeBind>] [-SecondaryEmail <String>] [-SecondaryOwnerAlias <SPUserPipeBind>] [-SiteSubscription <SPSiteSubscriptionPipeBind>] [-Template <SPWebTemplatePipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Url

Requis

System.String

Spécifie l'URL qu'utilise la nouvelle collection de sites. S'il ne s'agit pas d'un site d'en-tête d'hôte, l'URL doit commencer par l'URL de l'application Web.

OwnerAlias

Requis

System.String

Spécifie le nom de connexion d'utilisateur du propriétaire du site.

Le type doit être un alias d'utilisateur valide au format Domaine\utilisateur.

AdministrationSiteType

Facultatif

Microsoft.SharePoint.SPAdministrationSiteType

Spécifie le type de site.

Les valeurs valides sont None ou TentantAdministration.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

ContentDatabase

Facultatif

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie le nom ou le GUID de la base de données de contenu dans laquelle le nouveau site doit être créé. Si aucune base de données de contenu n'est spécifiée, la collection de sites est sélectionnée automatiquement.

Le type doit être un nom de base de données valide au format SiteContent1212, ou un GUID au format 1234-5678-9807.

Description

Facultatif

System.String

Décrit le nouveau site. Si aucune valeur n'est spécifiée, la valeur reste vide.

HostHeaderWebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie si l'URL spécifiée est un en-tête d'hôte, le paramètre HostHeaderWebApplication doit correspondre au nom, à l'URL, au GUID ou à l'objet SPWebApplication de l'application Web dans laquelle cette collection de sites est créée. Si aucune valeur n'est spécifiée, la valeur reste vide.

Le type doit être un nom valide au format WebApplication-1212, une URL (par exemple, http://server_name), ou un GUID (par exemple, 1234-5678-9876-0987).

Language

Facultatif

System.Int32

Spécifie l'ID de langue de la nouvelle collection de sites. Si aucune langue n'est spécifiée, la collection de sites est créée avec la même langue que celle qui a été spécifiée lors de l'installation du produit.

Le type doit être un identifiant de langue valide (LCID).

Name

Facultatif

System.String

Spécifie le titre de la nouvelle collection de sites. Si aucun nom n'est spécifié, le nom par défaut s'applique.

OwnerEmail

Facultatif

System.String

Spécifie l'adresse de messagerie du propriétaire du site. Si aucune valeur n'est spécifiée, la valeur reste vide.

Le type doit être une adresse de messagerie valide au format xyz@example.com.

QuotaTemplate

Facultatif

Microsoft.SharePoint.PowerShell.SPQuotaTemplatePipeBind

Spécifie le modèle de quota du nouveau site. Le modèle doit déjà exister. Si aucun modèle n'est spécifié, aucun quota n'est appliqué.

SecondaryEmail

Facultatif

System.String

Spécifie l'adresse de messagerie du propriétaire secondaire du site. Si aucune valeur n'est spécifiée, la valeur reste vide.

Le type doit être une adresse de messagerie valide au format xyz@example.com.

SecondaryOwnerAlias

Facultatif

System.String

Spécifie les informations de connexion utilisateur du propriétaire secondaire du site. Si aucune valeur n'est spécifiée, la valeur reste vide.

Le type doit être un alias d'utilisateur valide au format Domaine\utilisateur.

SiteSubscription

Facultatif

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie le groupe de sites pour l'obtention des collections de sites.

Template

Facultatif

Microsoft.SharePoint.PowerShell.SPWebTemplatePipeBind

Spécifie le modèle Web du site Web racine de la nouvelle collection de sites. Le modèle doit déjà être installé. Si aucun modèle n'est spécifié, aucun modèle n'est mis en service.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPSite crée une collection de sites à l'aide de l'URL et du propriétaire spécifiés par les paramètres Url et OwnerAlias.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
New-SPSite http://sitename/sites/test -OwnerAlias "DOMAIN\JDoe" -Language 1033

Cet exemple crée une collection de sites française à l'adresse http://sitename/sites/test détenue par l'utilisateur DOMAIN\Jdoe.

------------------EXEMPLE 2-----------------------
Code de copie
$w = Get-SPWebApplication http://sitename
Code de copie
New-SPSite http://www.contoso.com -OwnerAlias "DOMAIN\jdoe" -HostHeaderWebApplication $w -Name "Contoso" -Template "STS#0"

Cet exemple crée une collection de sites d'en-tête d'hôte. Le modèle étant spécifié, le site Web racine de la collection de sites sera créé.

------------------EXEMPLE 3-----------------------
Code de copie
Get-SPWebTemplate | Where{ $_.Title -eq "Team Site" } | ForEach-Object{ New-SPSite http://sitename/sites/test -OwnerAlias DOMAIN\jdoe -Template $_ }

Cet exemple crée une collection de sites à l'aide du modèle Web "Team Site".

Voir aussi

Référence

Get-SPSite
Set-SPSite
Backup-SPSite
Move-SPSite
Restore-SPSite

Historique des modifications


New-SPSiteSubscription
Voir aussi Exemple
[image]

Crée un nouvel abonnement au site.

New-SPSiteSubscription [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande New-SPSiteSubscription crée un nouvel abonnement auquel l'objet SPSites peut appartenir. Les sites membres d'un abonnement au site peuvent partager des paramètres et des informations de configuration. Une collection de sites peut être membre d'un seul abonnement au site qui ne peut pas être modifié une fois défini.

Les abonnements au site ne sont pas rendus persistants dans une base de données tant qu'ils ne sont pas utilisés conjointement avec un SPSite ou le service Paramètres d'abonnement au site. Une fois qu'un abonnement au site est appliqué à une quelconque collection de sites dans la batterie, l'abonnement au site peut être récupéré à l'aide de l'applet de commande Get-SPSiteSubscription.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
New-SPSiteSubscription |%{ New-SPSite http://contoso.com/sites/admin -SiteSubscription $_ -Template "TenantAdmin#0"}
Code de copie

Cet exemple crée un nouvel abonnement de site et l'applique à la collection de sites d'administration des clients.

------------------EXEMPLE 2-----------------------

    Code de copie
$s = New-SPSiteSubscription

    Code de copie
Get-SPSite http://sitename | Set-SPSite -SiteSubscription $s

    Code de copie
Set-SPSite http://sitename -SiteSubscription {New-SPSiteSubscription}

Cet exemple ajoute un nouvel abonnement à une collection de sites existante à l'adresse http://sitename.

  Voir aussi
Référence
Get-SPSiteSubscription
Remove-SPSiteSubscription

Historique des modifications


New-SPUser
Voir aussi Exemple
[image]

Ajoute un utilisateur existant à un site SharePoint avec les autorisations désignées.

New-SPUser [-UserAlias] <String> -Web <SPWebPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DisplayName <String>] [-Email <String>] [-Group <SPGroupPipeBind>] [-MobileNumber <String>] [-PermissionLevel <String[]>] [-SiteCollectionAdmin <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

UserAlias

Requis

System.String

Web

Requis

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie l'URL ou le GUID du site Web sur lequel cet utilisateur doit être créé.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-5678-9876-0987.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DisplayName

Facultatif

System.String

Spécifie une chaîne qui contient le nom d'affichage de l'utilisateur.

Le type doit être un nom d'utilisateur valide, par exemple Joe.

Email

Facultatif

System.String

Spécifie l'adresse de messagerie du nouvel utilisateur.

Le type doit être une adresse de messagerie valide au format xyz@example.com.

Group

Facultatif

Microsoft.SharePoint.PowerShell.SPGroupPipeBind

Spécifie le groupe d'utilisateurs auquel appartient le nouvel utilisateur.

MobileNumber

Facultatif

System.String

Spécifie l'adresse de messagerie utilisateur du nouvel utilisateur.

Le type doit être une adresse de messagerie valide au format xyz@example.com.

PermissionLevel

Facultatif

System.String[]

Ajoute un utilisateur à un niveau de stratégie d'autorisation.

Le type doit être un niveau de stratégie d'autorisation valide pour l'utilisateur, par exemple Full, Read, Contribute ou All.

SiteCollectionAdmin

Facultatif

System.Management.Automation.SwitchParameter

Spécifie si l'utilisateur doit être ajouté à la collection de sites en tant qu'administrateur.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPUser ajoute un utilisateur existant à un site Web SharePoint avec les autorisations désignées. Cet utilisateur dispose des autorisations données dans tous les sous-sites qui héritent des autorisations. Le compte d'utilisateur doit déjà exister dans l'annuaire des utilisateurs.

Si votre environnement est en mode Active Directory, l'utilisateur doit déjà exister dans Active Directory Domain Services (AD DS) et seul le paramètre UserAlias est nécessaire, tous les autres champs sont extraits d'AD DS. Si seul un alias est spécifié et que la batterie de serveurs est en mode de création de compte Active Directory, le paramètre Email est également nécessaire.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1----------------------
Code de copie
PS> New-SPUser - UserAlias 'Contoso\Jdoe'-displayname 'John Doe' -web http://contoso.com

Cet exemple ajoute un nouvel utilisateur nommé John Doe au domaine Contoso.

------------------EXEMPLE 2----------------------
Code de copie
Get-SPWeb http://sitename | New-SPUser -UserAlias Contoso\Jdoe

Cet exemple ajoute Contoso\Jdoe à tous les sites Web de la collection de sites http://sitename. Étant donné que cette collection de sites utilise des autorisations héritées, vous ne pouvez toucher qu'au site Web de niveau supérieur.

Voir aussi

Référence

Get-SPUser
Set-SPUser
Move-SPUser
Remove-SPUser

Historique des modifications


New-SPWeb
Voir aussi Exemple
[image]

Crée un nouveau site dans une collection de sites existante.

New-SPWeb [-Url] <String> [-AddToQuickLaunch <SwitchParameter>] [-AddToTopNav <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-Language <UInt32>] [-Name <String>] [-Template <SPWebTemplatePipeBind>] [-UniquePermissions <SwitchParameter>] [-UseParentTopNav <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Url

Requis

System.String

Spécifie l'URL où le nouveau site sera créé. L'URL doit se trouver dans une collection de sites existante. L'URL doit être une URL valide au format http://server_name/site1.

Language

Facultatif

System.UInt32

Spécifie l'identifiant du modèle de langue du nouveau site. Si aucune langue n'est spécifiée, le site est créé avec la même langue que celle qui a été spécifiée lors de l'installation du produit.

Le type doit être un identifiant de langue valide (LCID).

Template

Facultatif

SPWebTemplatePipeBind

Spécifie le modèle Web du nouveau site. Le modèle doit déjà exister. Si aucun modèle n'est spécifié, aucun modèle n'est appliqué ; il est possible d'en sélectionner un ultérieurement.

Name

Facultatif

System.String

Spécifie le titre du nouveau site. Si aucun titre n'est spécifié, le titre par défaut est appliqué. Le titre par défaut est configuré pour chaque modèle.

Description

Facultatif

System.String

Décrit le nouveau site. Si aucune description n'est spécifiée, l'entrée reste vide.

AddToQuickLaunch

Facultatif

System.Management.Automation.SwitchParameter

Ajoute ce site au menu de lancement rapide.

UniquePermissions

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que le site doit être créé avec des autorisations uniques.

AddToTopNav

Facultatif

System.Management.Automation.SwitchParameter

Ajoute le site à la barre de navigation de niveau supérieur.

UseParentTopNav

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que ce site doit utiliser la même barre de navigation de niveau supérieur que son site parent.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPWeb crée un nouveau site dans la collection de sites existante que spécifie le paramètre Url. Vous pouvez créer un site avec une langue par défaut spécifique en spécifiant le paramètre Language. Si aucune langue n'est spécifiée, le site est créé avec la même langue que celle qui a été spécifiée lors de l'installation du produit. Vous pouvez créer un site à partir d'un modèle spécifique en spécifiant le paramètre Template. Si aucun modèle n'est spécifié, le site est créé et le modèle peut être spécifié ultérieurement ou être spécifié par le premier utilisateur qui se connecte.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Aucune

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
New-SPWeb http://somesite/subweb1 -Template "STS#0"

Cet exemple crée un nouveau sous-site à l'aide du modèle Site d'équipe de l'URL spécifiée (http://somesite/subweb1). Le modèle Site d'équipe est une valeur référencée comme la variable STS#0 du paramètre Template.

Voir aussi

Référence

Get-SPWeb
Set-SPWeb
Remove-SPWeb
Import-SPWeb

Historique des modifications


New-SPWebApplication
Voir aussi Exemple
[image]

Crée une nouvelle application Web au sein de la batterie locale.

New-SPWebApplication -ApplicationPool <String> -Name <String> [-AdditionalClaimProvider <SPClaimProviderPipeBind[]>] [-AllowAnonymousAccess <SwitchParameter>] [-ApplicationPoolAccount <SPProcessAccountPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-AuthenticationMethod <String>] [-AuthenticationProvider <SPAuthenticationProviderPipeBind[]>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabaseServer <String>] [-HostHeader <String>] [-Path <String>] [-Port <UInt32>] [-SecureSocketsLayer <SwitchParameter>] [-ServiceApplicationProxyGroup <SPServiceApplicationProxyGroupPipeBind>] [-SignInRedirectProvider <SPTrustedIdentityTokenIssuerPipeBind>] [-SignInRedirectURL <String>] [-Url <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

ApplicationPool

Requis

System.String

Spécifie le nom d'un pool d'applications à utiliser ; par exemple, SharePoint - 1213. Si aucun pool d'applications au nom fourni n'existe, le paramètre ApplicationPoolAccount doit être fourni et un nouveau pool d'applications est créé. Si aucune valeur n'est spécifiée, le pool d'applications par défaut est utilisé.

Name

Requis

System.String

Spécifie le nom de la nouvelle application Web.

AdditionalClaimProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind[]

Ajoute un fournisseur de revendications spécifique à l'application Web définie.

AllowAnonymousAccess

Facultatif

System.Management.Automation.SwitchParameter

Autorise l'accès anonyme à l'application Web.

ApplicationPoolAccount

Facultatif

Microsoft.SharePoint.PowerShell.SPProcessAccountPipeBind

Spécifie le compte d'utilisateur que ce pool d'applications utilise pour son exécution. Utilisez l'applet de commande Get-SPIisWebServicApplicationPool pour utiliser un compte système.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AuthenticationMethod

Facultatif

System.String

Utilise Kerberos ou NTLM pour spécifier la méthode d'authentification. Si aucune valeur n'est spécifiée, la méthode NTLM par défaut est appliquée.

AuthenticationProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPAuthenticationProviderPipeBind[]

Spécifie le ou les fournisseurs d'authentification qui s'appliquent à une application Web.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet Credential Windows PowerShell du compte d'utilisateur de base de données.

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données de contenu d'origine de la nouvelle application Web.

Le type doit être un nom de base de données valide, par exemple, ContentDB1. Si aucune valeur n'est spécifiée, une valeur au format WSS_Content_<GUID> est générée automatiquement.

DatabaseServer

Facultatif

System.String

Spécifie le nom du serveur de base de données. Le type doit être un nom de serveur de bases de données valide, au format SQL1 ; lorsque des instances nommées sont utilisées, le format peut être serveur\serveur. L'instance de serveur SQL par défaut est utilisée si aucune valeur n'est fournie.

HostHeader

Facultatif

System.String

Spécifie une URL valide affectée à l'application Web qui doit correspondre à la configuration de mappage des accès de substitution, au format serveur_nom.

Lorsque le paramètre HostHeader est présent, la valeur de ce champ correspond à l'URL interne de l'application Web. Le paramètre Url sert à spécifier l'URL publique. Si aucune valeur n'est spécifiée, elle est laissée vierge.

Path

Facultatif

System.String

Spécifié le répertoire physique de la nouvelle application Web dans le dossier des répertoires virtuels. Le type est un chemin d'accès valide, au format C:\Inutepub\wwwroot\MyWebApplication. Si aucune valeur n'est spécifiée, la valeur %wwwroot%\wss\VirtualDirectories\<numéroport> est appliquée.

Port

Facultatif

System.UInt32

Spécifie le port sur lequel cette application Web est accessible. Il peut s'agir d'un numéro de port valide. Si aucun port n'est spécifié, un numéro de port non conflictuel est automatiquement généré.

Important :
Si vous spécifiez un numéro de port qui a déjà été attribué, IIS ne démarre pas le nouveau site tant que vous n'avez pas changé le numéro de port du nouveau site ou celui de l'ancien site.

SecureSocketsLayer

Facultatif

System.Management.Automation.SwitchParameter

Autorise le chiffrement SSL (Secure Sockets Layer) pour cette application Web. Si vous choisissez d'utiliser le protocole SSL, vous devez doter chaque serveur du certificat approprié à l'aide des outils d'administration IIS. Tant que les certificats ne sont pas ajoutés, l'application Web reste inaccessible depuis ce site Web IIS.

ServiceApplicationProxyGroup

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyGroupPipeBind

Spécifie le groupe de proxies d'applications de service personnalisés pour l'application Web à utiliser. L'application Web utilise les proxies de ce groupe pour se connecter aux applications de service. Si ce paramètre n'est pas spécifié, le groupe de proxies par défaut pour la batterie est utilisé.

SignInRedirectProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Définit l'URL de redirection d'ouverture de session afin de pointer vers l'URL définie dans le fournisseur d'authentification spécifié.

SignInRedirectURL

Facultatif

System.String

Spécifie l'URL de redirection d'ouverture de session pour l'application Web.

Url

Facultatif

System.String

Spécifie l'URL à charge équilibrée pour l'application Web.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Crée une nouvelle application Web spécifiée par le paramètre Name. L'utilisateur spécifié par le paramètre DatabaseCredentials doit être membre du rôle de serveur fixe dbcreator sur le serveur de bases de données.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
New-SPWebApplication -Name "Contoso Internet Site" -Port 80 -HostHeader sharepoint.contoso.com -URL "https://www.contoso.com" -ApplicationPool "ContosoAppPool" -ApplicationPoolAccount (Get-SPManagedAccount "DOMAIN\jdoe")

Cet exemple crée une nouvelle application Web en utilisant l'en-tête d'hôte interne sharepoint.contoso.com et l'URL publique https://www.contoso.com.

Voir aussi

Référence

Get-SPWebApplication
Set-SPWebApplication
Get-SPWebApplication

Historique des modifications


New-SPWebApplicationExtension
Voir aussi Exemple
[image]

Crée une nouvelle instance de zone pour l'application Web.

New-SPWebApplicationExtension [-Identity] <SPWebApplicationPipeBind> -Name <String> -Zone <Default | Intranet | Internet | Custom | Extranet> [-AdditionalClaimProvider <SPClaimProviderPipeBind[]>] [-AllowAnonymousAccess <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-AuthenticationMethod <String>] [-AuthenticationProvider <SPAuthenticationProviderPipeBind[]>] [-Confirm [<SwitchParameter>]] [-HostHeader <String>] [-Path <String>] [-Port <UInt32>] [-SecureSocketsLayer <SwitchParameter>] [-SignInRedirectProvider <SPTrustedIdentityTokenIssuerPipeBind>] [-SignInRedirectURL <String>] [-Url <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web à étendre.

Name

Requis

System.String

Spécifie le nom du nouveau site Web IIS dans l'application Web.

Zone

Requis

System.String

Spécifie l'une des cinq zones à laquelle doit être associée l'URL interne de cette nouvelle extension. Cette zone ne peut pas déjà être utilisée.

Le type doit être l'une des valeurs suivantes : Default, Intranet, Internet, Extranet ou Custom.

AdditionalClaimProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind[]

Ajoute un fournisseur de revendications spécifique à l'application Web définie.

AllowAnonymousAccess

Facultatif

System.Management.Automation.SwitchParameter

Autorise l'accès anonyme à la zone d'application Web.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AuthenticationMethod

Facultatif

String

Utilise Kerberos ou NTLM pour spécifier la méthode d'authentification.

AuthenticationProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPAuthenticationProviderPipeBind[]

Spécifie le(s) fournisseur(s) d'authentification correspondant à une application Web.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

HostHeader

Facultatif

System.String

Spécifie une URL valide affectée à l'application Web correspondant à la configuration alternative du mappage d'accès, au format http://server_name.

Lorsque le paramètre HostHeader est spécifié, la valeur de ce champ correspond à l'URL interne de l'application Web. Le paramètre Url sert à spécifier l'URL publique.

Path

Facultatif

System.String

Spécifie le répertoire physique du nouveau site Web (dans le dossier des répertoires virtuels). Le type est un chemin d'accès valide au format C:\Inutepub\wwwroot\MyWebApplication.

Port

Facultatif

System.UInt32

Spécifie le port de l'application. Il peut s'agir de tout numéro de port valide.

Si aucun port n'est spécifié, un numéro de port non conflictuel est automatiquement généré.

Important :
Si vous spécifiez un numéro de port qui est déjà affecté, IIS ne démarre pas le nouveau site tant que vous n'avez pas modifié le numéro de port du nouveau site ou celui de l'ancien site.

SecureSocketsLayer

Facultatif

System.Management.Automation.SwitchParameter

Autorise le chiffrement SSL (Secure Sockets Layer) pour cette application Web. Si vous choisissez d'utiliser le protocole SSL, vous devez doter chaque serveur du certificat approprié à l'aide des outils d'administration IIS. Tant que les certificats ne sont pas ajoutés, l'application Web reste inaccessible depuis ce site Web IIS.

SignInRedirectProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Définit l'URL de redirection de connexion de sorte qu'elle pointe vers l'URL définie dans le fournisseur d'authentification spécifié.

SignInRedirectURL

Facultatif

System.String

Spécifie l'URL de redirection de connexion pour l'application Web.

Url

Facultatif

System.String

Spécifie l'URL à charge équilibrée pour la zone d'application Web.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande New-SPWebApplicationExtension crée une nouvelle instance de zone pour l'application Web. Également appelée extension d'une application Web, cette opération permet de configurer différentes autorisations pour le même contenu disponible dans l'application Web existante.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Get-SPWebApplication http://sitename | New-SPWebApplicationExtension -Name "ExtranetSite" -SecureSocketsLayer -Zone "Extranet" -URL "https://extranet.sitename.com"

Cet exemple étend à la zone Extranet l'application Web donnée située à l'adresse http://sitename lors de l'utilisation du protocole SSL.

Voir aussi

Référence

Get-SPWebApplication
Set-SPWebApplication

Historique des modifications


Remove-SPSite
Voir aussi Exemple
[image]

Supprime entièrement une collection de sites existante et tous ses sous-sites.

Remove-SPSite [-Identity] <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DeleteADAccounts <SwitchParameter>] [-GradualDelete <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie l'identité du site à supprimer. ll peut s'agir d'une URL valide, au format http://server_name, d'un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, ou d'un objet SPSite.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DeleteADAccounts

Facultatif

System.Management.Automation.SwitchParameter

Force la suppression des comptes utilisateurs des services AD DS (Active Directory Domain Services). Cela s'applique en mode de création de compte AD DS et lorsque la valeur de ce paramètre est True. Les comptes AD DS associés à la collection de sites sont également supprimés des services AD DS.

GradualDelete

Facultatif

System.Management.Automation.SwitchParameter

Si ce paramètre est fourni, l'opération est exécutée graduellement afin de réduire la charge sur le système. Cette opération est vivement conseillée pour supprimer des sites très volumineux.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPSite supprime entièrement une collection de sites existante et tous ses sous-sites. Cette opération ne peut pas être annulée.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Remove-SPSite -Identity "http://sitename" -GradualDelete -Confirm:$False

Cet exemple supprime la collection de sites donnée et tous ses sites avec le paramètre GradualDelete ; la confirmation a été supprimée.

Voir aussi

Référence

Get-SPSite
Set-SPSite
New-SPSite
Backup-SPSite
Remove-SPSite
Move-SPSite
Restore-SPSite

Historique des modifications


Remove-SPSiteSubscription
Voir aussi Exemple
[image]

Supprime les données stockées dans une application de service de paramètres d'abonnement pour un ensemble d'abonnements aux sites.

Remove-SPSiteSubscription [-Identity] <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Spécifie le nom de l'abonnement au site à supprimer.

Spécifie l'application de service de paramètres d'abonnement au site contenant les données de service à supprimer.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application de service de paramètres d'abonnement valide (par exemple, AppParamètresAbonnement1) ou une instance d'un objet SPSubscriptionSettingsServiceApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force la suppression d'un abonnement au site. Il s'agit de la seule manière d'empêcher cette commande de demander une confirmation.

Le type doit être une des valeurs suivantes :

- True

- False

La valeur par défaut est False .

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPSiteSubscription supprime un abonnement au site et tous les paramètres et collections de sites qu'il contient.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Remove-SPSiteSubscription "http://contoso.com"

Cet exemple supprime toutes les données de l'abonnement au site contoso.com (collections de sites, abonnement au site et paramètres).

Voir aussi

Référence

Get-SPSiteSubscription
New-SPSiteSubscription
Remove-SPSiteSubscription

Historique des modifications


Remove-SPSiteSubscriptionSettings
Voir aussi Exemple
[image]

Supprime les données de service des paramètres pour l'abonnement à un site spécifié, ou recherche et supprime les données orphelines.

Remove-SPSiteSubscriptionSettings [-Identity] <SPServiceApplicationPipeBind> -SiteSubscriptions <Guid[]> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Remove-SPSiteSubscriptionSettings [-Identity] <SPServiceApplicationPipeBind> -FindAllOrphans <SwitchParameter> [-AlternativeSiteSubscriptions <Guid[]>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service des paramètres d'abonnement à des sites contenant les données de service à supprimer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'une application de service d'abonnement à des sites (par exemple, SubscriptionSettingsApp1), ou une instance d'un objet SPSubscriptionSettingsServiceApplication valide.

SiteSubscriptions

Requis

System.Guid[]

Spécifie les abonnements à des sites contenant des données de service de paramètres à supprimer.

Le type doit être un tableau de GUID valides.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service des paramètres d'abonnement à des sites contenant les données de service à supprimer.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide d'une application de service d'abonnement à des sites (par exemple, SubscriptionSettingsApp1), ou une instance d'un objet SPSubscriptionSettingsServiceApplication valide.

FindAllOrphans

Requis

System.Management.Automation.SwitchParameter

Spécifie que les stockages de paramètres orphelins de l'application de service sont supprimés.

AlternativeSiteSubscriptions

Facultatif

System.Guid[]

Spécifie la collection complète ou la liste séparée par des virgules des abonnements à des sites qui doivent exister dans l'application de service des paramètres. Les données qui ne correspondent pas aux éléments de cette liste seront supprimées.

Ce paramètre est important si vous utilisez le paramètre FindAllOrphans. La valeur spécifiée pour le paramètre AlternativeSiteSubscriptions indique que tout abonnement à un site non présent dans la batterie de serveurs locale sera supprimé, à moins qu'une liste alternative d'abonnements à des sites soit spécifiée.

Le type doit être un tableau de GUID valides.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Ignore automatiquement l'avertissement secondaire émis par l'applet de commande avant l'opération.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPSiteSubscriptionSettings supprime les données stockées pour l'abonnement au site spécifié. Si le paramètre FindAllOrphans est spécifié, cette applet de commande localise dans l'application de service les données non présentes dans la liste des abonnements à des sites locaux ou dans la liste alternative d'abonnements.

Le jeu d'abonnements à des sites peut être spécifié directement ou être détecté en comparant les données présentes dans l'application de service au jeu d'abonnements à des sites existants afin de trouver le jeu de données qui correspond à des abonnements à des sites inexistants.

Important :
Si cette applet de commande est exécutée sur une application de service fédérée sans spécifier la liste complète des ID d'abonnement à des sites pour le paramètre AlternativeSiteSubscriptions, vous risquez de perdre des données.

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------EXEMPLE 1--------------
Code de copie
Remove-SPSiteSubscriptionSettings -FindAllOrphans -Whatif

Cet exemple recherche tous les orphelins et les affiche à l'écran. Supprimez le paramètre WhatIf pour supprimer ces paramètres supplémentaires.

------------EXEMPLE 2--------------
Code de copie
Remove-SPSubscriptionSettingsServiceApplication -FindAllOrphans -AlternativeSiteSubscriptions $SubscriptionList

Utilisez cet exemple si l'application de service est utilisée par une batterie de serveurs distante et que vous voulez nettoyer les données orphelines des paramètres d'abonnements à des sites (un tableau de tous les abonnements à des sites dont les données doivent rester dans l'application de service est affecté à la variable $SubscriptionList).

Voir aussi

Référence

Import-SPSiteSubscriptionSettings
Export-SPSiteSubscriptionSettings

Historique des modifications


Remove-SPUser
Voir aussi Exemple
[image]

Supprime un utilisateur d'un site Web.

Remove-SPUser [-Identity] <SPUserPipeBind> -Web <SPWebPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Group <SPGroupPipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUserPipeBind

Spécifie le GUID, le nom d'utilisateur ou l'objet SPUser à supprimer.

Le type doit être un GUID valide de l'utilisateur, au format 1234-5678-9876-0987.

Web

Requis

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie le nom de l'URL ou le GUID duquel l'utilisateur doit être supprimé. Ce paramètre est requis uniquement si l'identité fournie est le nom d'utilisateur.

Le type doit être une URL valide, au format http://server_name, ou un GUID, au format 1234-5678-9807.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Group

Facultatif

Microsoft.SharePoint.PowerShell.SPGroupPipeBind

L'utilisateur est supprimé de ce groupe uniquement. Sinon, il est supprimé du site.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPUser spécifie l'identité et le groupe d'utilisateurs duquel un utilisateur doit être supprimé. L'applet de commande Remove-SPUser ne supprime pas l'utilisateur des services AD DS (Active Directory Domain Services).

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Remove-SPUser "Contoso \jdoe" -web http://test/web1
Code de copie
Get-SPWeb "http://test/web1" | Remove-SPUser "Contoso\jdoe"

Cet exemple supprime l'utilisateur (Contoso\jdoe) de l'application Web http://test/web1.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPSite http://contoso.com |Get-SPWeb |Remove-SPUser "Contoso\jdoe"

Cette syntaxe supprime l'utilisateur (Contoso\Jdoe) de tous les sites Web d'une collection de sites située à l'adresse http://contoso.com.

Voir aussi

Référence

Get-SPUser
Set-SPUser
New-SPUser
Remove-SPUser

Historique des modifications


Remove-SPWeb
Voir aussi Exemple
[image]

Supprime entièrement le site Web spécifié.

Remove-SPWeb [-Identity] <SPWebPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie l'identité du site Web à supprimer.

Le type doit être une URL entière valide, au format http://server_name/site_name, ou un objet SPWeb.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPWeb supprime entièrement le site Web spécifié par le paramètre Identity.

Important :
La suppression du site Web de niveau supérieur d'une collection de sites entraîne la suppression de toute la collection de sites.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Remove-SPWeb http://sitename/subsite

Cet exemple supprime entièrement un subsite.

Voir aussi

Référence

Get-SPWeb
Set-SPWeb
Remove-SPWeb
New-SPWeb
Import-SPWeb

Historique des modifications


Remove-SPWebApplication
Voir aussi Exemple
[image]

Supprime l'application Web spécifiée.

Remove-SPWebApplication [-Identity] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DeleteIISSite <SwitchParameter>] [-RemoveContentDatabases <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Remove-SPWebApplication [-Identity] <SPWebApplicationPipeBind> -Zone <Default | Intranet | Internet | Custom | Extranet> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DeleteIISSite <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'URL ou le nom de l'application Web à supprimer.

Le type doit être une URL valide, au format http://server_name, ou un nom valide, au format ApplicationWeb-1212.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DeleteIISSite

Facultatif

System.Management.Automation.SwitchParameter

Supprime les sites Web IIS associés. Si ce paramètre n'est pas fourni, le site IIS n'est pas supprimé.

RemoveContentDatabases

Facultatif

System.Management.Automation.SwitchParameter

Supprime définitivement toutes les bases de données de contenu associées. Si ce paramètre n'est pas fourni, aucune base de données de contenu n'est supprimée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'URL ou le nom de l'application Web à supprimer.

Le type doit être une URL valide, au format http://server_name, ou un nom valide, au format ApplicationWeb-1212.

Zone

Requis

System.String

Spécifie une des cinq zones à supprimer. Si ce paramètre n'est pas fourni, toutes les zones d'application Web sont supprimées.

Le type doit être une des valeurs suivantes : Default, Intranet, Internet, Extranet ou Custom.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DeleteIISSite

Facultatif

System.Management.Automation.SwitchParameter

Supprime les sites Web IIS associés. Si ce paramètre n'est pas fourni, le site IIS n'est pas supprimé.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Remove-SPWebApplication supprime l'application Web spécifiée par les paramètres Identity et Zone. Si aucune zone n'est fournie, l'application Web entière et toutes les zones sont supprimées.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Get-SPWebApplication http://sitename | Remove-SPWebApplication -Zone "Internet" -Confirm

Cet exemple invite, puis supprime l'extension d'application Web de la zone Internet sur l'application Web à l'adresse http://sitename. Cette commande ne supprime ni les bases de données de contenu ni le site Web IIS.

------------------EXEMPLE 2-----------------------
Code de copie
Remove-SPWebApplication http://sitename -Confirm -DeleteIISSite -RemoveContentDatabases

Cet exemple supprime définitivement l'application Web, toutes les bases de données de contenu, ainsi que le site Web IIS à l'adresse http://sitename

Voir aussi

Référence

Get-SPWebApplication
Set-SPWebApplication
New-SPWebApplication

Historique des modifications


Rename-SPServer
Voir aussi Exemple
[image]

Renomme un serveur actuellement connecté à la batterie.

Rename-SPServer [-Identity] <SPServerPipeBind> -Name <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie le nom d'origine du serveur.

Le type doit être une URL au format http://server_name ou un GUID au format 1234-4567-987gb.

Name

Requis

System.String

Spécifie le nouveau nom du serveur.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Rename-SPServer modifie le nom du serveur pour un usage interne dans les produits Sharepoint 2010. Le serveur proprement dit doit être renommé manuellement.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Rename-SPServer -Identity "wfb1" -Name "WFE1"

Cet exemple modifie le nom du serveur SharePoint wfb1 en WFE1.

Voir aussi

Référence

Get-SPServer

Historique des modifications


Set-SPSite
Voir aussi Exemple
[image]

Configure les sites spécifiés.

Set-SPSite [-Identity] <SPSitePipeBind> [-AdministrationSiteType <None | TenantAdministration>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-LockState <String>] [-MaxSize <Int64>] [-OwnerAlias <SPUserPipeBind>] [-QuotaTemplate <SPQuotaTemplatePipeBind>] [-SecondaryOwnerAlias <SPUserPipeBind>] [-Template <SPWebTemplatePipeBind>] [-Url <String>] [-UserAccountDirectoryPath <String>] [-WarningSize <Int64>] [-WhatIf [<SwitchParameter>]]
Set-SPSite [-Identity] <SPSitePipeBind> [-AdministrationSiteType <None | TenantAdministration>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-SiteSubscription <SPSiteSubscriptionPipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie l'URL ou le GUID de la collection de sites à configurer ou fait référence à un objet SPSite contenant des sites à configurer.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, ou un objet SPSite.

AdministrationSiteType

Facultatif

Microsoft.SharePoint.SPAdministrationSiteType

Spécifie le type de site.

Les valeurs valides sont None ou TentantAdministration.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

LockState

Facultatif

System.String

Définit l'état de verrouillage de la collection de sites. Les états de verrouillage valides sont Unlock, NoAdditions, ReadOnly ou NoAccess.

MaxSize

Facultatif

System.Int32

Définit la taille de stockage maximale de la collection de sites en mégaoctets.

Le nombre entier doit être supérieur à la valeur WarningSize. Vous ne pouvez pas utiliser ce paramètre si la collection de sites utilise un modèle de quota.

OwnerAlias

Facultatif

System.String

Spécifie le nom du propriétaire de la collection de sites.

QuotaTemplate

Facultatif

Microsoft.SharePoint.PowerShell.SPQuotaTemplatePipeBind

Spécifie le nouveau modèle de quota pour la collection de sites.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890abcdef.

SecondaryOwnerAlias

Facultatif

System.String

Définit le propriétaire secondaire.

Le type doit être un alias de messagerie valide au format domaine\utilisateur.

Template

Facultatif

Microsoft.SharePoint.PowerShell.SPWebTemplatePipeBind

Spécifie le modèle pour la collection de sites.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890abcdef.

Url

Facultatif

System.String

Spécifie le nom de l'URL du nouveau site.

UserAccountDirectoryPath

Facultatif

String

Définit une unité d'organisation sur laquelle définir l'étendue des comptes d'utilisateurs.

WarningSize

Facultatif

System.Int32

Définit le niveau d'avertissement de stockage pour la collection de sites.

Le nombre entier doit être compris entre 0 et la valeur MaxSize. Vous ne pouvez pas utiliser ce paramètre si la collection de sites utilise un modèle de quota.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie l'URL ou le GUID de la collection de sites à configurer ou fait référence à un objet SPSite contenant des sites à configurer.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, ou un objet SPSite.

AdministrationSiteType

Facultatif

Microsoft.SharePoint.SPAdministrationSiteType

Spécifie le type de site.

Les valeurs valides sont None ou TentantAdministration.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Supprime les messages de confirmation impliqués dans la définition de l'abonnement de site. Ce paramètre est utilisé avec le paramètre SiteSubscription.

SiteSubscription

Facultatif

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie le groupe de sites pour l'obtention des collections de sites.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPSite configure la collection de sites spécifiée par le paramètre Identity. En l'absence d'un paramètre, la valeur n'est pas modifiée.

Remarque :
Le paramètre QuotaTemplate est mutuellement exclusif avec le paramètre MaxSize et le paramètre WarningSize.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1---------------------
Code de copie
Get-SPSite http://sitename/sites/teams/* | Set-SPSite -SecondaryOwner "DOMAIN\Jdoe"

Cet exemple définit le propriétaire secondaire d'un jeu de collections de sites sur DOMAIN\Jdoe.

------------------EXEMPLE 2---------------------
Code de copie
Set-SPSite -identity "http://sitename" -MaxSize 4000000 -WarningSize 2000000

Cet exemple configure les paramètres de quota de la collection de sites http://sitename.

Voir aussi

Référence

Get-SPSite
New-SPSite
Restore-SPSite
Remove-SPSite
Move-SPSite
Restore-SPSite

Historique des modifications


Set-SPSiteAdministration
Voir aussi Exemple
[image]

Permet aux administrateurs de batteries de serveurs de configurer n'importe quelle collection de sites.

Set-SPSiteAdministration [-Identity] <SPSiteAdministrationPipeBind> [-AdministrationSiteType <None | TenantAdministration>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-LockState <String>] [-MaxSize <Int64>] [-OwnerAlias <SPUserPipeBind>] [-SecondaryOwnerAlias <SPUserPipeBind>] [-Template <SPWebTemplatePipeBind>] [-WarningSize <Int64>] [-WhatIf [<SwitchParameter>]]
Set-SPSiteAdministration [-Identity] <SPSiteAdministrationPipeBind> [-AdministrationSiteType <None | TenantAdministration>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-SiteSubscription <SPSiteSubscriptionPipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSiteAdministrationPipeBind

Spécifie l'URL (complète ou partielle) ou le GUID de la collection de sites.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-456-987fg.

AdministrationSiteType

Facultatif

Microsoft.SharePoint.SPAdministrationSiteType

Spécifie le type de site.

Les valeurs valides sont None ou TentantAdministration.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

LockState

Facultatif

System.String

Spécifie l'état de verrouillage de la collection de sites donnée.

Le type doit être l'une des valeurs suivantes :

- Unlock : définit la collection de sites à déverrouiller.

- Content : aucun nouveau contenu ne peut être ajouté. Les mises à jour et suppressions sont autorisées.

- Readonly : définit la collection de sites en lecture seule.

- Noaccess : définit la collection de sites pour la rendre indisponible pour tous les utilisateurs.

MaxSize

Facultatif

System.Int32

Définit la taille de stockage maximale de la collection de sites.

Le type doit être un nombre valide supérieur ou égal à 0.

Choisissez 0 pour une taille illimitée.

OwnerAlias

Facultatif

System.String

Définit le propriétaire de la collection de sites.

Le type doit être un alias d'utilisateur valide.

SecondaryOwnerAlias

Facultatif

System.String

Définit le propriétaire secondaire de la collection de sites.

Le type doit être un alias d'utilisateur valide.

Template

Facultatif

Microsoft.SharePoint.PowerShell.SPWebTemplatePipeBind

Spécifie le modèle Web pour le site Web de niveau supérieur de cette collection de sites. Pour cela, le modèle ne doit pas encore avoir été configuré.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890abcdef, ou un objet SPWebTemplate.

WarningSize

Facultatif

System.Int64

Spécifie la taille limite d'avertissement pour la collection de sites.

Le type doit être un nombre valide supérieur ou égal à 0. Choisissez 0 pour une taille illimitée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSiteAdministrationPipeBind

Spécifie l'URL (complète ou partielle) ou le GUID de la collection de sites.

Le type doit être une URL valide au format http://server_name, ou un GUID au format 1234-456-987fg.

AdministrationSiteType

Facultatif

Microsoft.SharePoint.SPAdministrationSiteType

Spécifie le type de site.

Les valeurs valides sont None ou TentantAdministration.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Supprime les messages de confirmation impliqués dans la définition de l'abonnement de site. Ce paramètre est utilisé avec le paramètre SiteSubscription.

SiteSubscription

Facultatif

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie le groupe de sites pour l'obtention des collections de sites.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPSiteAdministration permet à un administrateur de batterie de serveurs de configurer des paramètres spécifiques sur une collection de sites même s'il ne dispose pas des autorisations explicites. Les paramètres non spécifiés ne sont pas modifiés.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPSiteAdministration http://sitename -OwnerAlias "DOMAIN\NewOwner"

Cet exemple permet aux administrateurs de batterie de serveurs de modifier l'appartenance d'une collection de sites à laquelle ils n'ont pas accès.

Voir aussi

Référence

Get-SPSiteAdministration
Get-SPSite

Historique des modifications


Set-SPSiteSubscriptionConfig
Exemple
[image]

Définit les propriétés de configuration d'un abonnement au site.

Set-SPSiteSubscriptionConfig [-Identity] <SPSiteSubscriptionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-FeaturePack <SPSiteSubscriptionFeaturePackPipeBind>] [-PassThru <SwitchParameter>] [-UserAccountDirectoryPath <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie la configuration d'abonnement au site à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un SPSite (objet ou URL) d'une collection de sites membre de l'abonnement au site, ou une instance d'un objet SiteSubscription valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

PassThru

Facultatif

System.Management.Automation.SwitchParameter

Indique que l'objet de sortie peut être passé à travers le pipeline.

FeatureSet

Facultatif

Microsoft.SharePoint.PowerShell.SPFeatureSetPipeBind

Spécifie le jeu de fonctions associé à l'abonnement au site.

Spécifie une valeur nulle pour effacer l'association actuelle.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh ou une instance d'un objet SPFeatureSet valide.

UserAccountDirectoryPath

Facultatif

System.String

Définit le chemin d'accès au répertoire du compte d'utilisateur du site à une unité d'organisation spécifique qui se trouve dans le même domaine que l'abonnement au site.

Le type doit être un nom d'unité d'organisation unique, par exemple OU=Contoso1, DC=OSGCorp, DC=local.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPSiteSubscriptionConfig définit les propriétés de configuration d'un abonnement au site.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------EXEMPLE---------------
Code de copie
Set-SPSiteSubscription http://contoso.com -FeatureSet 12345678-90ab-cdef-1234-567890abcdef

Cet exemple définit le jeu de fonctions de l'abonnement complet au site contenant http://contoso.com avec un GUID de jeu de fonctions.

Historique des modifications


Set-SPSubscriptionSettingsServiceApplication
Voir aussi Exemple
[image]

Définit les propriétés d'une application de service de paramètres d'abonnement.

Set-SPSubscriptionSettingsServiceApplication [-Identity] <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabaseServer <String>] [-FailoverDatabaseServer <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Spécifie l'application de service de paramètres à mettre à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application de service de paramètres d'abonnement valide (par exemple SubscriptionSettingsApp1), ou une instance d'un objet SPSubscriptionSettingsServiceApplication valide.

ApplicationPool

Facultatif

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Spécifie le pool d'applications ISS à utiliser pour la nouvelle application de paramètres d'abonnement.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de pool d'applications valide (par exemple, AppPoolName1) ou une instance d'un objet IISWebServiceApplicationPool valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DatabaseCredentials

Facultatif

System.Management.Automation.PSCredential

Spécifie l'objet PSCredential qui contient le nom d'utilisateur et le mot de passe à utiliser pour l'authentification SQL Server de la base de données.

Le type doit être un objet PSCredential valide.

DatabaseName

Facultatif

System.String

Spécifie le nom de la base de données des paramètres d'abonnement.

Le type doit être un nom de base de données SQL Server valide, par exemple SubscriptionSettingsAppDB1.

DatabaseServer

Facultatif

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Spécifie le nom de l'instance SQL Server de l'hôte pour la base de données spécifiée dans le paramètre DatabaseName.

Le type doit être un nom d'instance SQL Server valide, par exemple SQLServerHost1.

FailoverDatabaseServer

Facultatif

System.String

Spécifie le nom de l'instance SQL Server de l'hôte pour le serveur de bases de données de basculement.

Le type doit être un nom d'instance SQL Server valide, par exemple SQLServerHost1.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Set-SPSubscriptionSettingsServiceApplication pour définir les propriétés sur une application de service de paramètres d'abonnement.

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE--------------------------
Code de copie
$applicationPool = GetServiceApplicationPool SettingsApplicationPool
Code de copie
Get-SPServiceApplication -Name SettingsServiceApp | Set-SPSubscriptionSettingsServiceApplication -ApplicationPool $applicationPool

Cet exemple modifie le pool d'applications de l'application de service de paramètres d'abonnement. Cette commande suppose qu'une application de service de paramètres d'abonnement nommée SettingsServiceApp et qu'un pool d'applications nommé SettingsApplicationPool existent.

Voir aussi

Référence

New-SPSubscriptionSettingsServiceApplication
New-SPSubscriptionSettingsServiceApplicationProxy

Historique des modifications


Set-SPUser
Voir aussi Exemple
[image]

Configure les propriétés d'utilisateur existant.

Set-SPUser [-Identity] <SPUserPipeBind> [-AddPermissionLevel <String[]>] [-AssignmentCollection <SPAssignmentCollection>] [-ClearPermissions <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-DisplayName <String>] [-Email <String>] [-Group <SPGroupPipeBind>] [-IsSiteCollectionAdmin <SwitchParameter>] [-MobileNumber <String>] [-PassThru <SwitchParameter>] [-RemovePermissionLevel <String[]>] [-SyncFromAD <SwitchParameter>] [-Web <SPWebPipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPUserPipeBind

Spécifie le GUID, le nom de connexion ou l'objet SPUser de l'utilisateur à renvoyer.

Le type doit être un GUID valide de l'utilisateur, au format 1234-5678-9876-0987.

AddPermissionLevel

Facultatif

System.String[]

Spécifie le niveau d'autorisation à ajouter à l'utilisateur.

Le type doit être l'un des suivants :

-- Contribute - peut consulter, ajouter, mettre à jour et supprimer les éléments de liste et les documents.

-- Design - peut consulter, ajouter, mettre à jour, supprimer, approuver et personnaliser les documents.

-- Full Control - possède un contrôle total sur tous les documents.

-- Limited Access - peut consulter des listes spécifiques, des bibliothèques de documents, des éléments de liste, des dossiers ou des documents avec les autorisations correspondantes.

-- Read - peut consulter les pages et les éléments de liste, et télécharger les documents.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

ClearPermissions

Facultatif

System.Management.Automation.SwitchParameter

Annule toutes les autorisations données à l'utilisateur. Si les valeurs Clear et Add sont données, les autorisations sont d'abord annulées, puis les nouvelles autorisations sont données.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DisplayName

Facultatif

System.String

Spécifie le nouveau nom complet de l'utilisateur.

Le type doit être un nom valide.

Email

Facultatif

System.String

Spécifie la nouvelle adresse de messagerie de l'utilisateur.

Group

Facultatif

Microsoft.SharePoint.PowerShell.SPGroupPipeBind

Ajoute l'utilisateur au groupe nommé spécifié du site donné.

IsSiteCollectionAdmin

Facultatif

Aucune

Spécifie si l'utilisateur est défini comme administrateur de collection de sites.

MobileNumber

Facultatif

System.String

Définit le nouveau numéro de téléphone mobile de l'utilisateur.

PassThru

Facultatif

Aucune

S'il n'est pas fourni, indique que cette applet de commande n'a aucune sortie. S'il est fourni, ce paramètre indique que l'objet SPUser de cet utilisateur doit être renvoyé.

RemovePermissionLevel

Facultatif

System.String[]

Supprime le niveau d'autorisation de l'utilisateur.

SyncFromAD

Facultatif

System.Management.Automation.SwitchParameter

S'il est fourni, spécifie que les informations utilisateur sont synchronisées à partir du magasin d'annuaires.

Web

Facultatif

Microsoft.SharePoint.PowerShell.SPWebPipeBind

Spécifie le nom de l'URL ou du GUID à utiliser en tant qu'étendue. Ce paramètre n'est pas nécessaire si l'objet SPUser est fourni en tant qu'identité.

Le type doit être une URL valide, au format http://server_name, ou un GUID, au format 1234-5678-9807.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPUser configure les propriétés d'un utilisateur existant.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPUser -Identity 'Contoso\jdoe' -Web http://test -AddPermissionLevel "Contributor"

Cet exemple définit un utilisateur (Contoso\jdoe) comme contributeur sur http://test.

Voir aussi

Référence

Get-SPUser
New-SPUser
Remove-SPUser
Move-SPUser

Historique des modifications


Set-SPWebApplication
Voir aussi Exemple
[image]

Configure l'application Web spécifiée.

Set-SPWebApplication [-Identity] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultQuotaTemplate <String>] [-DefaultTimeZone <Int32>] [-Force <SwitchParameter>] [-ServiceApplicationProxyGroup <SPServiceApplicationProxyGroupPipeBind>] [-WhatIf [<SwitchParameter>]]
Set-SPWebApplication [-Identity] <SPWebApplicationPipeBind> -Zone <Default | Intranet | Internet | Custom | Extranet> [-AdditionalClaimProvider <SPClaimProviderPipeBind[]>] [-AssignmentCollection <SPAssignmentCollection>] [-AuthenticationMethod <String>] [-AuthenticationProvider <SPAuthenticationProviderPipeBind[]>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-SignInRedirectProvider <SPTrustedIdentityTokenIssuerPipeBind>] [-SignInRedirectURL <String>] [-WhatIf [<SwitchParameter>]]
Set-SPWebApplication [-Identity] <SPWebApplicationPipeBind> -SMTPServer <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-OutgoingEmailAddress <String>] [-ReplyToEmailAddress <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom ou l'URL de l'application Web.

Le type doit être un nom valide au format WebApplication-1212, ou une URL au format http://server_name/WebApplication-1212.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DefaultQuotaTemplate

Facultatif

System.String

Spécifie le nouveau modèle de quota de site par défaut pour cette application Web.

DefaultTimeZone

Facultatif

System.Int32

Spécifie le fuseau horaire par défaut des nouvelles collections de sites de cette application Web.

Force

Facultatif

System.Management.Automation.SwitchParameter

Force l'application Web à ne pas utiliser de boîtes de dialogue de confirmation.

ServiceApplicationProxyGroup

Facultatif

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyGroupPipeBind

Spécifie un groupe de proxys personnalisé d'application de service pour l'application Web à utiliser. L'application Web utilisera les proxys de ce groupe de proxys pour se connecter à des applications de service. Si ce paramètre n'est pas spécifié, le groupe de proxys par défaut de la batterie de serveurs est utilisé.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom ou l'URL de l'application Web.

Le type doit être un nom valide au format WebApplication-1212, ou une URL au format http://server_name/WebApplication-1212.

Zone

Requis

Microsoft.SharePoint.Administration.SPUrlZone

Lors de la configuration des paramètres spécifiques à la zone, la zone à configurer doit être spécifiée. Cette zone doit déjà exister.

Le type doit être l'une des valeurs suivantes : Default, Intranet, Internet, Extranet ou Custom.

AdditionalClaimProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPClaimProviderPipeBind[]

Ajoute un fournisseur de revendications spécifique à l'application Web définie.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

AuthenticationProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPAuthenticationProviderPipeBind[]

Définit le(s) fournisseur(s) d'authentification correspondant à l'application Web.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force l'application Web à ne pas utiliser de boîtes de dialogue de confirmation.

SignInRedirectProvider

Facultatif

Microsoft.SharePoint.PowerShell.SPTrustedIdentityTokenIssuerPipeBind

Définit l'URL de redirection de connexion de sorte qu'elle pointe vers l'URL définie dans le fournisseur d'authentification spécifié.

SignInRedirectURL

Facultatif

System.String

Spécifie l'URL de redirection de connexion pour l'application Web.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom ou l'URL de l'application Web.

Le type doit être un nom valide au format WebApplication-1212, ou une URL au format http://server_name/WebApplication-1212.

SMTPServer

Requis

System.String

Spécifie le nouveau serveur SMTP sortant qu'utilisera cette application Web.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Facultatif

System.Management.Automation.SwitchParameter

Force l'application Web à ne pas utiliser de boîtes de dialogue de confirmation.

OutgoingEmailAddress

Facultatif

System.String

Spécifie la nouvelle adresse de messagerie sortante pour les messages électroniques envoyés depuis cette application Web. Le type doit être une adresse valide, par exemple xyz@example.com.

ReplyToEmailAddress

Facultatif

System.String

Configure l'adresse de messagerie de réponse.

Le type doit être une adresse valide, par exemple xyz@example.com.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPWebApplication configure l'application Web spécifiée par le paramètre Identity. Pour les paramètres spécifiques à la zone (pour le jeu de paramètres Zone), la zone à configurer doit être spécifiée. La zone spécifiée doit déjà exister.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Get-SPWebApplication http://somesite | Set-SPWebApplication -Zone "Extranet" - AllowAnonymousAccess

Cet exemple définit l'URL pour la zone Extranet de l'application Web donnée située à l'adresse http://www.contoso.com et autorise l'accès anonyme.

Voir aussi

Référence

Get-SPWebApplication
New-SPWebApplication
Remove-SPWebApplication

Historique des modifications


Set-SPWeb
Voir aussi Exemple
[image]

Configure le sous-site spécifié.

Set-SPWeb [-Identity] <SPWebPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-RelativeUrl <String>] [-Template <SPWebTemplatePipeBind>] [-Theme <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPWebPipeBind

URL du site Web ou objet SPWeb représentant le site Web.

Le type doit être une URL valide au format http://server_name ou un objet SPWeb.

Name

Facultatif

Chaîne

Spécifie le nouveau nom du site Web.

Description

Facultatif

System.String

Spécifie la nouvelle description du site Web.

RelativeUrl

Facultatif

System.String

Spécifie la nouvelle URL relative pour le site Web. Il s'agit du chemin de l'URL après l'URL de la collection de sites.

Theme

Facultatif

System.String

Spécifie le nouveau thème à appliquer au site Web.

Template

Facultatif

Microsoft.SharePoint.PowerShell.SPWebTemplatePipeBind

Spécifie le nouveau modèle à appliquer au site Web. Cette opération est impossible si le modèle est déjà appliqué.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPWeb configure le sous-site spécifié par le paramètre Identity. Les paramètres ne sont pas modifiés pour les paramètres non fournis.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

one

Exemple

------------------EXEMPLE-----------------------
Code de copie
Get-SPWeb http://sitename/subweb | Set-SPWeb -Title "My Site Title"

Cet exemple définit le titre d'un sous-site existant.

Voir aussi

Référence

Get-SPWeb
New-SPWeb
Remove-SPWeb
Export-SPWeb
Import-SPWeb

Historique des modifications


Export-SPSiteSubscriptionSettings
Voir aussi Exemple
[image]

Crée un fichier de sauvegarde des données d'abonnement au site.

Export-SPSiteSubscriptionSettings [-Identity] <SPSiteSubscriptionPipeBind> -Path <String> [-AdminProperties <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Force <SwitchParameter>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie l'ID de l'abonnement au site à partir duquel sauvegarder les données.

Le type doit être une URL valide au format http://server_name ou un GUID au format 1234-4567-985tg.

Path

Requis

System.String

Indique l'emplacement du fichier de sortie.

Le type doit être un chemin d'accès valide, par exemple C:/fichier_sauvegarde.back.

AdminProperties

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que seules les propriétés de l'abonnement de l'administrateur sont exportées. Si ce paramètre n'est pas défini, seules les propriétés de l'abonnement non-administrateur sont exportées.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Force

Non

System.Management.Automation.SwitchParameter

Force le fichier de sauvegarde de sortie (s'il est fourni) à remplacer tout fichier existant sur le chemin d'accès donné.

Description détaillée

L'applet de commande Export-SPSiteSubscriptionSettings génère un fichier de sauvegarde de tous les paramètres dans le magasin de données d'abonnement pour l'abonnement au site donné.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPSiteSubscription http://contoso.com | Backup-SPSiteSubscriptionSettings -path "c:/backups"

L'exemple sauvegarde le magasin des paramètres d'abonnement de http://www.contoso.com.

Voir aussi

Référence

Import-SPSiteSubscriptionSettings
Remove-SPSiteSubscriptionSettings

Historique des modifications


Import-SPSiteSubscriptionSettings
Voir aussi Exemple
[image]

Restaure une sauvegarde des paramètres d'abonnement au site sur l'identifiant d'abonnement donné.

Import-SPSiteSubscriptionSettings [-Identity] <SPSiteSubscriptionPipeBind> -Path <String> [-AdminProperties <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPSiteSubscriptionPipeBind

Spécifie l'ID de l'abonnement faisant l'objet de la restauration.

Le type doit être une URL valide, au format http://server_name, ou un GUID, au format 1234-4567-985tg.

Path

Requis

System.String

Spécifie l'emplacement du fichier d'entrée.

Le type doit être un chemin d'accès valide, au format C:\nomfichier.bak.

AdminProperties

Facultatif

System.Management.Automation.SwitchParameter

Spécifie que seules les propriétés de l'abonnement de l'administrateur sont importées. Si ce paramètre n'est pas défini, seules les propriétés de l'abonnement non-administrateur sont importées.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Force

Non

System.Management.Automation.SwitchParameter

Si une clé de paramètre existe déjà, détermine si la valeur doit être écrasée par celle du fichier de sauvegarde.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Import-SPSiteSubscriptionSettings restaure une sauvegarde des paramètres d'abonnement au site sur l'identifiant d'abonnement donné lorsque le paramètre Identity est utilisé. Pour écraser les paramètres existants, utilisez le paramètre Force.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPSiteSubscription http://contoso.com | Import-SPSiteSubscriptionSettings -path "c:/backups/contoso_settings_file.bak" -force

Cet exemple restaure le magasin de paramètres d'abonnement de contoso.com.

Voir aussi

Référence

Export-SPSiteSubscriptionSettings
Remove-SPSiteSubscriptionSettings

Historique des modifications


Applets de commande pour les travaux du minuteur (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour gérer les travaux du minuteur dans une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Disable-SPTimerJob

Enable-SPTimerJob

Get-SPTimerJob

Set-SPTimerJob

Start-SPTimerJob

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Disable-SPTimerJob
Voir aussi Exemple
[image]

Désactive un travail du minuteur.

Disable-SPTimerJob [-Identity] <SPTimerJobPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTimerJobPipeBind

Spécifie le travail du minuteur à désactiver.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de travail du minuteur valide (par exemple, TimerJob1) ou une instance d'un objet SPTimerJob valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Disable-SPTimerJob désactive un travail du minuteur.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

--------------------EXEMPLE-----------------------
Code de copie
Get-SPTimerJob job-ceip-datacollection | Disable-SPTimerJob

Cet exemple désactive le travail du minuteur nommé job-ceip-datacollection.

Voir aussi

Référence

Get-SPTimerJob
Enable-SPTimerJob
Set-SPTimerJob
Start-SPTimerJob

Historique des modifications


Enable-SPTimerJob
Voir aussi Exemple
[image]

Active un travail du minuteur.

Enable-SPTimerJob [-Identity] <SPTimerJobPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTimerJobPipeBind

Spécifie le travail du minuteur à activer.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de travail du minuteur valide (par exemple, TravailMinuteur1) ou une instance d'un objet SPTimerJob valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Enable-SPTimerJob active un travail du minuteur. Un travail du minuteur doit être activé avant d'être démarré.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

-------------------EXEMPLE---------------------
Code de copie
Get-SPTimerJob job-ceip-datacollection | Enable-SPTimerJob

Cet exemple active le travail du minuteur appelé job-ceip-datacollection.

Voir aussi

Référence

Get-SPTimerJob
Set-SPTimerJob
Start-SPTimerJob
Disable-SPTimerJob

Historique des modifications


Get-SPTimerJob
Voir aussi Exemple
[image]

Renvoie des travaux du minuteur.

Get-SPTimerJob [[-Identity] <SPTimerJobPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Type <String>] [-WebApplication <SPWebApplicationPipeBind>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPTimerJobPipeBind

Spécifie le travail du minuteur à obtenir.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de travail du minuteur valide (par exemple, TravailMinuteur1) ou une instance d'un objet SPTimerJob valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Type

Facultatif

System.String

Filtre pour renvoyer les travaux du minuteur d'un type spécifié.

Le type doit être un nom de type de travail du minuteur valide, par exemple, TravailMinuteur1.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Filtre pour renvoyer les travaux du minuteur définis pour l'étendue d'une application Web SharePoint spécifiée.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MonAppOffice1) ou une instance d'un objet SPWebApplication valide.

Description détaillée

L'applet de commande Get-SPTimerJob lit un travail du minuteur spécifié, les travaux du minuteur d'un type spécifié ou les travaux du minuteur définis pour une étendue spécifiée. Si aucun paramètre n'est spécifié, cet applet de commande renvoie toutes les définitions de travaux du minuteur de la batterie.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

---------------------EXEMPLE---------------------

Code de copie
Get-SPTimerJob -WebApplication "http://servername" | select Name, DisplayName

Cet exemple affiche tous les travaux du minuteur pour une application Web spécifiée.

Voir aussi

Référence

Set-SPTimerJob
Start-SPTimerJob
Disable-SPTimerJob
Enable-SPTimerJob

Historique des modifications


Set-SPTimerJob
Voir aussi Exemple
[image]

Définit la planification d'exécution d'un travail du minuteur.

Set-SPTimerJob [-Identity] <SPTimerJobPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Schedule <String>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTimerJobPipeBind

Spécifie le travail du minuteur à mettre à jour.

Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de travail du minuteur valide (par exemple, TravailMinuteur1) ou une instance d'un objet SPTimerJob valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Schedule

Requis

System.String

Spécifie la planification d'exécution du travail du minuteur.

Le type doit être une des planifications de service Minuteur SharePoint (SPTimer) valides suivantes :

- Toutes les 5 minutes entre 0 et 59

- Toutes les heures entre 0 et 59

- Tous les jours à 15:00:00

- Toutes les semaines entre ven 22:00:00 et dim 06:00:00

- Le 15 de chaque mois à 15:00:00

- Le 1er janvier de chaque année à 15:00:00

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPTimerJob définit la planification d'exécution d'un travail du minuteur spécifié.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

-------------------EXEMPLE------------------------

Code de copie
Get-SPTimerJob job-recycle-bin-cleanup | Set-SPTimerJob -Schedule "weekly at sat 5:00"

Cet exemple définit la planification d'exécution du travail du minuteur job-recylce-bin-cleanup à weekly at sat 5:00.

Voir aussi

Référence

Get-SPTimerJob
Start-SPTimerJob
Disable-SPTimerJob
Enable-SPTimerJob

Historique des modifications


Start-SPTimerJob
Voir aussi Exemple
[image]

Exécute un travail du minuteur une fois.

Start-SPTimerJob [-Identity] <SPTimerJobPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPTimerJobPipeBind

Spécifie le travail du minuteur à exécuter.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom de travail du minuteur valide (par exemple, TimerJob1) ou une instance d'un objet SPTimerJob valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Start-SPTimerJob exécute un travail du minuteur une fois sur chaque serveur Web frontal sur lequel le service parent est mis en service.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-----------------EXEMPLE----------------
Code de copie
Get-SPTimerJob job-recycle-bin-cleanup | Start-SPTimerJob

Cet exemple démarre le travail du minuteur nommé job-recycle-bin-cleanup.

Voir aussi

Référence

Get-SPTimerJob
Set-SPTimerJob
Disable-SPTimerJob
Enable-SPTimerJob

Historique des modifications


Applets de commande pour la mise à niveau et la migration (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour effectuer une mise à niveau depuis une version antérieure de Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Test-SPContentDatabase

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Upgrade-SPContentDatabase
Voir aussi Exemple
[image]

Met à niveau une base de données de contenu.

Upgrade-SPContentDatabase [-Identity] <SPContentDatabasePipeBind> [[-ForceDeleteLock] <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ServerInstance <SPDatabaseServiceInstancePipeBind>] [-UpdateUserExperience <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Upgrade-SPContentDatabase [[-ForceDeleteLock] <SwitchParameter>] -Name <String> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ServerInstance <SPDatabaseServiceInstancePipeBind>] [-UpdateUserExperience <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie la base de données de contenu à mettre à niveau.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh ou une instance d'un objet SPContentDatabase valide.

ForceDeleteLock

Facultatif

System.Management.Automation.SwitchParameter

Oblige la suppression des verrous sur la base de données avant de démarrer la mise à niveau.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

ServerInstance

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabaseServiceInstancePipeBind

L'instance SQL Server hébergeant la base de données de contenu associée.

UpdateUserExperience

Facultatif

System.Management.Automation.SwitchParameter

Détermine si les bases de données de contenu doivent adopter l'interface utilisateur la plus récente. Par défaut, l'interface utilisateur restera la même pendant la mise à niveau.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

ForceDeleteLock

Facultatif

System.Management.Automation.SwitchParameter

Oblige la suppression des verrous sur la base de données avant de démarrer la mise à niveau.

Name

Requis

System.String

Spécifie le nom de la base de données de contenu associée.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web hébergeant la base de données de contenu associée.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

ServerInstance

Facultatif

Microsoft.SharePoint.PowerShell.SPDatabaseServiceInstancePipeBind

L'instance SQL Server hébergeant la base de données de contenu associée.

UpdateUserExperience

Facultatif

System.Management.Automation.SwitchParameter

Détermine si les bases de données de contenu doivent adopter l'interface utilisateur la plus récente. Par défaut, l'interface utilisateur restera la même pendant la mise à niveau.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Cet applet de commande contient plus d'un jeu de paramètres. Vous ne pouvez utiliser les paramètres que d'un seul jeu et vous ne pouvez pas combiner les paramètres de différents jeux. Pour plus d'informations sur l'utilisation des jeux de paramètres, voir Jeux de paramètres d'applets de commande (éventuellement en anglais).

L'applet de commande Upgrade-SPContentDatabase met à niveau une base de données de contenu SharePoint. Lorsque l'applet de commande Upgrade-SPContentDatabase est exécutée, une mise à niveau d'une base de données de contenu existante associée à la batterie est initiée. Cette applet de commande commence une nouvelle session de mise à niveau, qui peut être utilisée soit pour reprendre une mise à niveau version-à-version ou build-à-build échouée d'une base de données de contenu ou pour commencer une mise à niveau build-à-build d'une base de données de contenu.

Types d'entrée

Types retournés

Exemple

--------------------------EXEMPLE------------------------------

Code de copie
$contentdb = Get-SPContentDatabase | Where-Object {$_.Name -match "SQLSERVER1\WSS_Content"}
Code de copie
Upgrade-SPContentDatabase -Identity $contentdb

Cet exemple sélectionne une base de données de contenu spécifique actuellement associée à la batterie, puis lance une session de mise à niveau. Ce processus continue jusqu'à la fin de la mise à niveau et peut prendre un certain temps, en fonction du nombre de changements à apporter pendant la mise à niveau.

Voir aussi

Référence

Dismount-SPContentDatabase
Get-SPContentDatabase
Mount-SPContentDatabase
New-SPContentDatabase
Remove-SPContentDatabase
Set-SPContentDatabase
Test-SPContentDatabase

Historique des modifications


Applets de commande pour les applications Web (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour administrer des applications Web dans une batterie Microsoft SharePoint Foundation 2010.

Nom de l'applet de commande | Description
Get-SPAlternateURL | Retourne toutes les URL de substitution qui répondent à un jeu de critères donné.
Get-SPMobileMessagingAccount | Récupère les comptes de messagerie mobile pour l'application Web spécifiée.
Install-SPApplicationContent | Copie des données d'applications partagées dans les dossiers d'applications Web existants.
New-SPAlternateUrl | Crée une nouvelle URL publique ou interne pour la zone ou la ressource d'application Web spécifiée.
Remove-SPAlternateUrl | Supprime entièrement l'URL de substitution spécifiée.
Set-SPAlternateUrl | Configure l'URL de substitution spécifiée.
Set-SPMobileMessagingAccount | Configure le compte de messagerie mobile spécifié.

Historique des modifications

Date | Description | Raison
24 juin 2010 | Publication initiale |


Get-SPAlternateURL
Voir aussi Exemple
[image]

Renvoie toutes les URL de substitution qui correspondent à un ensemble de critères donné.

Get-SPAlternateURL [[-Identity] <SPAlternateUrlPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Zone <Default | Intranet | Internet | Custom | Extranet>]
Get-SPAlternateURL [[-Identity] <SPAlternateUrlPipeBind>] -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Zone <Default | Intranet | Internet | Custom | Extranet>]
Get-SPAlternateURL [[-Identity] <SPAlternateUrlPipeBind>] -ResourceName <String> [-AssignmentCollection <SPAssignmentCollection>] [-Zone <Default | Intranet | Internet | Custom | Extranet>]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPAlternateUrlPipeBind

Spécifie l'URL ou le GUID de l'URL de substitution à obtenir.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, ou une URL valide au format http://server_name.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Zone

Facultatif

System.String

Spécifie une des cinq zones à laquelle l'URL de substitution est associée.

Doit être une zone valide : Default, Intranet, Internet, Extranet ou Custom

2

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPAlternateUrlPipeBind

Spécifie l'URL ou le GUID de l'URL de substitution à obtenir.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, ou une URL valide au format http://server_name.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web à partir de laquelle répertorier les URL de substitution.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Zone

Facultatif

System.String

Spécifie une des cinq zones à laquelle l'URL de substitution est associée.

Doit être une zone valide : Default, Intranet, Internet, Extranet ou Custom

3

Paramètre

Requis

Type

Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPAlternateUrlPipeBind

Spécifie l'URL ou le GUID de l'URL de substitution à obtenir.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, ou une URL valide au format http://server_name.

ResourceName

Requis

System.String

Spécifie le nom de la ressource à partir de laquelle répertorier les URL de substitution.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Zone

Facultatif

System.String

Spécifie une des cinq zones à laquelle l'URL de substitution est associée.

Doit être une zone valide : Default, Intranet, Internet, Extranet ou Custom

Description détaillée

L'applet de commande Get-SPAlternateURL fait partie d'un ensemble de paramètres. Elle renvoie toutes les URL de substitution qui correspondent à l'étendue donnée soit par le paramètre facultatif Identity, soit par la combinaison des paramètres facultatifs WebApplication, Zone ou Resource. Chaque critère ajouté rétrécit l'étendue. Si aucun critère n'est spécifié, toutes les URL de substitution sont renvoyées.

Si le paramètre Identity est spécifié, seule l'URL de substitution spécifique correspondante est renvoyée. S'il n'existe aucune URL de substitution de l'identité donnée dans l'étendue donnée, rien n'est renvoyé.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE 1-----------------
Code de copie
Get-SPAlternateURL -WebApplication http://sitename

Cet exemple affiche toutes les URL de substitution d'une application Web donnée.

--------------EXEMPLE 2-----------------
Code de copie
Get-SPAlternateURL -ResourceName "MyResource"

Cet exemple affiche toutes les URL de substitution d'une ressource donnée.

Voir aussi

Référence

New-SPAlternateUrl
Set-SPAlternateUrl
Remove-SPAlternateUrl

Historique des modifications


Get-SPMobileMessagingAccount
Voir aussi Exemple
[image]

Récupère les comptes de messagerie mobile pour l'application Web spécifiée.

Get-SPMobileMessagingAccount [[-Identity] <SPMobileMessagingAccountPipeBind>] -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

Identity

Facultatif

Microsoft.SharePoint.PowerShell.SPMobileMessagingAccountPipeBind

Spécifie s'il faut renvoyer les informations sur le compte SMS (Short Message Service) ou MMS (Multimedia Messaging Service). Les valeurs valides sont SMS et MMS. Si vous ne spécifiez pas ce paramètre, les informations sur le compte sont renvoyées pour SMS et MMS.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'identité de l'application Web à supprimer. Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web valide (par exemple WebApplication1212) ou un nom valide (par exemple WebApp2423).

Vous devez spécifier le paramètre WebApplication, ou utiliser le commutateur HostHeader et spécifier l'URL complète dans le paramètre Identity.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPMobileMessagingAccount récupère les comptes de messagerie mobile pour l'application Web spécifiée.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types de retours

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPMobileMessagingAccount -WebApplication http://sitename

Cet exemple récupère les informations sur les paramètres du compte mobile actuel de l'application Web http://sitename.

Voir aussi

Référence

Set-SPMobileMessagingAccount

Historique des modifications


Install-SPApplicationContent
Exemple
[image]

Copie des données des applications partagées dans des dossiers d'application Web existants.

Install-SPApplicationContent [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Install-SPApplicationContent copie des données des applications partagées dans des dossiers d'application Web existants.

Cette applet de commande ne requiert aucun paramètre.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE---------------------
Code de copie
Install-SPApplicationContent

Cet exemple copie des données dans une application Web dans les dossiers existants.

Historique des modifications


New-SPAlternateUrl
Voir aussi Exemple
[image]

Crée une nouvelle URL publique ou interne pour la ressource ou la zone d'application Web spécifiée.

New-SPAlternateUrl [-Url] <String> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Internal <SwitchParameter>] [-WhatIf [<SwitchParameter>]] [-Zone <Default | Intranet | Internet | Custom | Extranet>]
New-SPAlternateUrl [-Url] <String> -ResourceName <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Internal <SwitchParameter>] [-WhatIf [<SwitchParameter>]] [-Zone <Default | Intranet | Internet | Custom | Extranet>]

Paramètres

1

Paramètre

Requis

Type

Description

Url

Requis

System.String

Spécifie l'URL publique à laquelle les utilisateurs accèdent pour s'inscrire à l'application Web.

Le type doit être une URL valide au format http://server_name.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom, l'URL ou le GUID de l'application Web pour laquelle le mappage doit être créé.

Le type doit être un nom valide, une URL valide au format WebApplication-1212, http://server_name, ou un GUID valide au format 1234-5678-9876-0987.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Internal

Facultatif

System.Management.Automation.SwitchParameter

Convertit cette URL de substitution en URL interne. Si ce paramètre n'est pas spécifié, l'URL est une URL publique.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Zone

Facultatif

System.String

Spécifie une des cinq zones à laquelle l'URL de substitution est associée.

Le type doit être une zone valide : Default, Intranet, Internet, Extranet ou Custom.

2

Paramètre

Requis

Type

Description

Url

Requis

System.String

Spécifie l'URL publique à laquelle les utilisateurs accèdent pour s'inscrire à l'application Web.

Le type doit être une URL valide au format http://server_name.

ResourceName

Requis

System.String

Spécifie le nom de la ressource si l'URL de substitution porte sur une ressource externe. Si aucune valeur n'est spécifiée, la valeur reste vide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Internal

Facultatif

System.Management.Automation.SwitchParameter

Convertit cette URL de substitution en URL interne. Si ce paramètre n'est pas spécifié, l'URL est une URL publique.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Zone

Facultatif

System.String

Spécifie une des cinq zones à laquelle l'URL de substitution est associée.

Le type doit être une zone valide : Default, Intranet, Internet, Extranet ou Custom.

Description détaillée

L'applet de commande New-SPAlternateUrl crée une nouvelle URL publique ou interne pour la ressource ou la zone d'application Web spécifiée. Utilisez le paramètre ResourceName si l'URL de substitution porte sur une ressource externe.

Chaque application Web peut être associée à une collection de mappages entre URL internes et publiques. Les URL internes et publiques sont constituées des portions protocole et domaine de l'URL complète, par exemple https://www.fabrikam.com. Les utilisateurs tapent une URL publique pour se rendre sur le site SharePoint, et c'est cette URL qui s'affiche dans les liens figurant dans les pages. Les URL internes sont les demandes d'URL envoyées au site SharePoint. De nombreuses URL internes peuvent être associées à une même URL publique dans les batteries multiserveurs, par exemple lorsqu'un équilibreur de charge achemine les demandes vers des adresses IP spécifiques à différents serveurs du cluster d'équilibrage de charge.

Chaque application Web prend en charge cinq collections de mappages par URL ; les cinq collections correspondent aux cinq zones (par défaut, intranet, extranet, Internet et personnalisée). Si l'application Web reçoit une demande d'URL interne dans une zone particulière, les liens figurant dans les pages renvoyées à l'utilisateur comportent l'URL publique de cette zone.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
#create the public URL
New-SPAlternateURL https://www.contoso.com -Zone "Internet"
Code de copie
#create the internal URL
New-SPAlternateURL http://sharepoint.contoso.com -Zone "Internet" -internal

Cet exemple convertit les demandes entrantes pour https://www.contoso.com en http://sharepoint.contoso.com (dans la zone Internet).

Lors de la configuration d'un proxy inverse pour traiter la terminaison SSL de l'URL publique, les mappages des accès de substitution doivent être configurés pour traiter la conversion de l'URL.

Voir aussi

Référence

Set-SPAlternateUrl
Get-SPAlternateURL
Remove-SPAlternateUrl

Historique des modifications


Remove-SPAlternateUrl
Voir aussi Exemple
[image]

Supprime intégralement l'URL de substitution spécifiée.

Remove-SPAlternateUrl [-Identity] <SPAlternateUrlPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPAlternateUrlPipeBind

Spécifie l'identité de l'URL de substitution à supprimer. L'identité peut être une URL valide au format http://server_name ou un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Remove-SPAlternateUrl supprime intégralement l'URL de substitution spécifiée par le paramètre Identity.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Remove-SPAlternateURL -WebApplication http://sitename -Zone Extranet

Cet exemple supprime l'URL extranet pour l'application Web donnée.

------------------EXEMPLE 2-----------------------
Code de copie
Get-SPWebApplication |%{ Get-SPAlternateURL -WebApplication $_ -Zone "Extranet" } | Remove-SPAlternateURL

Cet exemple supprime toutes les URL extranet de substitution dans la batterie.

Voir aussi

Référence

New-SPAlternateUrl
Get-SPAlternateURL
Set-SPAlternateUrl

Historique des modifications


Set-SPAlternateUrl
Voir aussi Exemple
[image]

Configure l'URL de substitution spécifiée.

Set-SPAlternateUrl [-Identity] <SPAlternateUrlPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Url <String>] [-WhatIf [<SwitchParameter>]] [-Zone <Default | Intranet | Internet | Custom | Extranet>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPAlternateUrlPipeBind

Spécifie l'URL ou le GUID de l'URL de substitution à modifier.

Le type doit être une URL valide au format http://server_name/WebApplication/site, ou un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh.

Url

Requis

System.String

Spécifie la nouvelle URL de substitution.

Zone

Requis

System.String

Définit l'URL de substitution fournie comme l'une des cinq zones.

Le type doit être l'une des valeurs suivantes : Default , Intranet , Internet , Extranet ou Custom .

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPAlternateUrl modifie l'URL ou la zone de l'autre URL spécifiée par le paramètre Identity. Cette applet de commande permet de modifier uniquement la zone des URL internes et ne peut pas servir à modifier la zone des URL publiques.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1------------------
Code de copie
Set-SPAlternateURL -Identity https://www.contoso.com -Zone "Internet"

Cet exemple modifie la zone de l'autre URL https://www.contoso.com.

------------------EXEMPLE 2------------------
Code de copie
Set-SPAlternateURL -Identity https://www.contoso.com -Url https://sharepoint.contoso.com -Zone "Default"

Cet exemple modifie l'URL et la zone de l'autre URL https://www.contoso.com.

------------------EXEMPLE 3------------------
Code de copie
Get-SPAlternateURL https://www.contoso.com | Set-SPAlternateURL -Zone "Internet"

Cet exemple modifie la zone de l'autre URL https://www.contoso.com.

------------------EXEMPLE 4------------------
Code de copie
Get-SPWebApplication |%{ Get-SPAlternateURL -WebApplication $_ -Zone "Extranet" } | Set-SPAlternateURL -Zone "Intranet"

Cet exemple change la zone de l'autre URL pour l'application Web spécifiée de Extranet en Intranet.

Voir aussi

Référence

Get-SPAlternateURL
New-SPAlternateUrl
Remove-SPAlternateUrl

Historique des modifications


Set-SPMobileMessagingAccount
Voir aussi Exemple
[image]

Configure le compte de messagerie mobile spécifié.

Set-SPMobileMessagingAccount [-Identity] <SPMobileMessagingAccountPipeBind> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Password <String>] [-ServiceName <String>] [-ServiceUrl <String>] [-UserId <String>]

Paramètres

Paramètre Requis Type Description

Identity

Requis

Microsoft.SharePoint.PowerShell.SPMobileMessagingAccountPipeBind

Spécifie le type d'informations de compte à retourner : SMS (Short Message Service) ou MMS (Multimedia Messaging Service). Les valeurs valides sont SMS et MMS . Si vous ne spécifiez pas ce compte de paramètre, les informations sont renvoyées à la fois pour SMS et MMS.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'identité de l'application Web qui héberge le chemin d'accès géré à supprimer. Le type doit être un GUID valide, au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web valide (par exemple, ApplicationWeb1212) ou un nom valide (par exemple, WebApp2423).

Vous devez soit spécifier WebApplication ou utiliser le commutateur HostHeader et spécifier l'URL entière dans le paramètre Identity.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Password

Facultatif

System.String

Spécifie le mot de passe, si les informations d'identification sont requises pour le compte.

ServiceName

Facultatif

System.String

Spécifie le nom du service SMS.

ServiceUrl

Facultatif

System.String

Spécifie l'URL du service SMS.

UserId

Facultatif

System.String

Spécifie le nom d'utilisateur, si les informations d'identification sont requises pour le compte.

Description détaillée

L'applet de commande Set-SPMobileMessagingAccount configure le compte de messagerie mobile spécifié.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPMobileMessagingAccount -WebApplication http://sitename -Identity SMS -ServiceName SMSLink -ServiceUrl https://www.adatum.com/Service/MessagingService.asmx-UserId someone@example.com -Password password1

Cet exemple remplace les paramètres de compte mobile SMS de l'application Web, http://sitename, par les valeurs suivantes : nom du service : SMSLink; URL du service : https://www.adatum.com/Service/MessagingService.asmx; ID utilisateur : someone@example.com et mot de passe : password1.

Voir aussi

Référence

Get-SPMobileMessagingAccount

Historique des modifications


Applets de commande pour la gestion des flux de travail (SharePoint Foundation 2010)

Vous pouvez utiliser des applets de commande Windows PowerShell pour gérer les flux de travail dans une batterie de serveurs Microsoft SharePoint Foundation 2010.

Les applets de commande suivantes sont disponibles pour la version Bêta.

Nom de l'applet de commande

Get-SPWorkflowConfig

Set-SPWorkflowConfig

Get-SPDesignerSettings

Set-SPDesignerSettings

Pour télécharger le fichier SharePointProductsCmdlets.chm, voir Windows PowerShell pour SharePoint Foundation 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=179125&clcid=0x40C).

Historique des modifications


Get-SPWorkflowConfig
Voir aussi Exemple
[image]

Renvoie les paramètres de flux de travail pour l'application Web spécifiée.

Get-SPWorkflowConfig [-WebApplication] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]
Get-SPWorkflowConfig [-SiteCollection] <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

1

Paramètre

Requis

Type

Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom ou l'URL de l'application Web.

Le type doit être un nom valide au format WebApplication-1212, ou une URL au format http://server_name/WebApplication-1212.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

2

Paramètre

Requis

Type

Description

SiteCollection

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie le nom ou l'URL de la collection de sites.

Le seul autre paramètre utilisé avec le paramètre SiteCollection est le paramètre DeclarativeWorkflowsEnabled. Aucun autre paramètre n'est utilisé.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPWorkflowConfig renvoie les paramètres de flux de travail pour l'application Web spécifiée par le paramètre WebApplication.

Types d'entrée

Types retournés

Exemple

--------------EXEMPLE-----------------
Code de copie
Get-SPWorkFlowConfig -webapplication http://sitename

Cet exemple récupère les paramètres de flux de travail pour l'application Web spécifiée (http://sitename).

Pour obtenir les paramètres de flux de travail au niveau de la batterie pour le délai de remise d'événement, le seuil de report et la taille du lot, utilisez l'applet de commande Get-SPFarmConfig.

Voir aussi

Référence

Set-SPWorkflowConfig

Historique des modifications


Set-SPWorkflowConfig
Voir aussi Exemple
[image]

Configure les paramètres du workflow pour l'application Web spécifiée.

Set-SPWorkflowConfig [-WebApplication] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-DeclarativeWorkflowsEnabled <$true | $false>] [-EmailNoPermissionParticipantsEnabled <$true | $false>] [-SendDocumentToExternalParticipants <$true | $false>]
Set-SPWorkflowConfig [-SiteCollection] <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-DeclarativeWorkflowsEnabled <$true | $false>] [-EmailNoPermissionParticipantsEnabled <$true | $false>] [-SendDocumentToExternalParticipants <$true | $false>]

Paramètres

1

Paramètre

Requis

Type

Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie le nom ou l'URL de l'application Web.

Le type doit être un nom valide, un GUID valide au format WebApplication-1212, ou une URL au format http://server_name/WebApplication-1212.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DeclarativeWorkflowsEnabled

Facultatif

System.Boolean

Indique si les workflows déclaratifs peuvent s'exécuter dans l'application Web.

Le type doit être 1 pour True ou 0 pour False.

EmailNoPermissionParticipantsEnabled

Facultatif

System.Boolean

Indique si les workflows envoient des messages électroniques de tâche aux utilisateurs qui ne disposent pas d'autorisations pour le site dans lequel s'exécutent ces workflows.

Le type doit être 1 pour True ou 0 pour False.

SendDocumentToExternalParticipants

Facultatif

System.Boolean

Indique si les workflows envoient automatiquement une copie du document en pièce jointe aux participants qui n'ont pas accès au site ou qui ne se trouvent dans aucun répertoire associé excepté Active Directory Domain Services (AD DS).

Le type doit être 1 pour True ou 0 pour False.

2

Paramètre

Requis

Type

Description

SiteCollection

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie le nom ou l'URL de la collection de sites.

Le seul autre paramètre utilisé avec le paramètre SiteCollection est le paramètre DeclarativeWorkflowsEnabled. Aucun autre paramètre n'est utilisé.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

DeclarativeWorkflowsEnabled

Facultatif

System.Boolean

Indique si les workflows déclaratifs peuvent s'exécuter dans l'application Web.

Le type doit être 1 pour True ou 0 pour False.

EmailNoPermissionParticipantsEnabled

Facultatif

System.Boolean

Indique si les workflows envoient des messages électroniques de tâche aux utilisateurs qui ne disposent pas d'autorisations pour le site dans lequel s'exécutent ces workflows.

Le type doit être 1 pour True ou 0 pour False.

SendDocumentToExternalParticipants

Facultatif

System.Boolean

Indique si les workflows envoient automatiquement une copie du document en pièce jointe aux participants qui n'ont pas accès au site ou qui ne se trouvent dans aucun répertoire associé excepté Active Directory Domain Services (AD DS).

Le type doit être 1 pour True ou 0 pour False.

Description détaillée

Utilisez l'applet de commande Set-SPWorkflowConfig pour configurer les paramètres du workflow pour l'application Web spécifiée.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPWorkflowConfig -webapplication http://sitename DeclarativeWorkflowsEnabled $true -EmailNoPermissionParticipantsEnabled $true -SendDocumentToExternalParticipants $false

Cet exemple définit les paramètres de workflow de l'application Web spécifiée pour activer les workflows déclaratifs, activer l'envoi de messages électroniques aux participants qui ne disposent pas d'autorisations pour le site, et désactiver la fonctionnalité d'envoi de messages électroniques en pièces jointes aux participants externes.

Aucune valeur n'est renvoyée. Utilisez l'applet de commande Get-SPWorkflowConfig pour afficher les valeurs. Pour définir les paramètres de workflow au niveau de la batterie de serveurs en cas de dépassement du délai de la remise d'événement et postposer le seuil et la taille de lot, utilisez Set-SPFarmConfig.

Voir aussi

Référence

Get-SPWorkflowConfig

Historique des modifications


Get-SPDesignerSettings
Voir aussi Exemple
[image]

Affiche les composants fonctionnels Microsoft SharePoint Designer 2010.

Get-SPDesignerSettings [-WebApplication] <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Paramètres

Paramètre Requis Type Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web à laquelle les paramètres sont appliqués.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Description détaillée

L'applet de commande Get-SPDesignerSettings détermine si les composants fonctionnels SharePoint Designer 2010 sont activés sur l'application Web spécifiée.

Pour les autorisations et les informations les plus récentes concernant Windows PowerShell for SharePoint Products 2010, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

---------------------EXEMPLE------------------------

Code de copie
Get-SPDesignerSettings -webapplication http://contoso

Cet exemple extrait les paramètres SharePoint Designer 2010 de l'application Web http://contoso.

Voir aussi

Référence

Set-SPDesignerSettings

Historique des modifications


Set-SPDesignerSettings
Voir aussi Exemple
[image]

Définit les fonctionnalités Microsoft SharePoint Designer 2010.

Set-SPDesignerSettings [-WebApplication] <SPWebApplicationPipeBind> [-AllowDesigner <$true | $false>] [-AllowMasterPageEditing <$true | $false>] [-AllowRevertFromTemplate <$true | $false>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ShowURLStructure <$true | $false>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifies l'application Web dans laquelle s'appliqueront les paramètres.

AllowDesigner

Facultatif

System.Boolean

Indique si les utilisateurs sont autorisés à modifier les sites dans une application Web en utilisant Microsoft SharePoint Designer 2010. La valeur par défaut est True.

AllowMasterPageEditing

Facultatif

System.Boolean

Indique si les administrateurs de site sont autorisés à personnaliser les pages maîtres et de disposition en utilisant Microsoft SharePoint Designer 2010. La valeur par défaut est True.

AllowRevertFromTemplate

Facultatif

System.Boolean

Indique si les administrateurs de site sont autorisés à détacher les pages de la définition de site d'origine en utilisant Microsoft SharePoint Designer 2010. La valeur par défaut est True.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

ShowURLStructure

Facultatif

System.Boolean

Indique si les administrateurs de site sont autorisés à gérer la structure URL de leurs sites Web en utilisant Microsoft SharePoint Designer 2010. La valeur par défaut est True.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPDesignerSettings définit les fonctionnalités SharePoint Designer 2010 sur une application Web spécifiée quand le paramètre WebApplicaton est utilisé.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

-------------------EXEMPLE--------------------

Code de copie
Set-SPDesignerSettings -WebApplication http://constoso -AllowRevertFromTemplate $False -AllowMasterPageEditing $False

Cet exemple désactive la possibilité de détacher les pages des définitions de site existantes et de modifier les pages maîtres et les dispositions de page.

Voir aussi

Référence

Get-SPDesignerSettings

Historique des modifications


Index des applets de commande SharePoint Foundation 2010 Windows PowerShell

Cet article fournit la liste des applets de commande Windows PowerShell incluses avec Microsoft SharePoint Foundation 2010 par ordre de verbe et de nom.

Dans cet article :

  • Afficher par ordre de verbe.

  • Afficher par ordre de nom.

Applets de commande SharePoint Foundation 2010 par ordre de verbe

Nom de l'applet de commande | Description
Add-SPClaimTypeMapping | Ajoute un mappage de revendications à un fournisseur d'identité de service d'émission de jeton de sécurité (STS) approuvé.
Add-SPDiagnosticsPerformanceCounter | Ajoute une instance d'un compteur de performance.
Add-SPServiceApplicationProxyGroupMember | Ajoute un membre au groupe de proxys d'application de service.
Add-SPShellAdmin | Ajoute un utilisateur au rôle SharePoint_Shell_Access pour la base de données spécifiée.
Add-SPSiteSubscriptionFeaturePackMember | Ajoute une fonctionnalité à un ensemble de fonctionnalités SharePoint.
Add-SPSolution | Télécharge un package de solution SharePoint vers la batterie.
Add-SPUserSolution | Télécharge une nouvelle solution en mode bac à sable vers la galerie de solutions.
Backup-SPConfigurationDatabase | Effectue une sauvegarde configuration-uniquement au niveau de la batterie.
Backup-SPFarm | Crée une sauvegarde d'une batterie, d'une application Web ou de la batterie entière.
Backup-SPSite | Effectue une sauvegarde d'une collection de sites.
Clear-SPLogLevel | Réinitialise les niveaux de journalisation du suivi et de journalisation des événements à leurs valeurs par défaut.
Clear-SPSiteSubscriptionBusinessDataCatalogConfig | Supprime toutes les données du magasin de métadonnées Business Data Connectivity pour une partition spécifiée.
Connect-SPConfigurationDatabase | Connecte l'ordinateur serveur local à une batterie.
Copy-SPBusinessDataCatalogAclToChildren | Copie un ensemble d'autorisations d'un objet de métadonnées du magasin de métadonnées Business Data Connectivity dans ses objets enfants.
Disable-SPBusinessDataCatalogEntity | Désactive un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.
Disable-SPFeature | Désactive une fonctionnalité SharePoint installée à une étendue donnée.
Disable-SPTimerJob | Désactive un travail du minuteur.
Disable-SPWebApplicationHttpThrottling | Désactive la limitation réseau pour une application Web.
Disconnect-SPConfigurationDatabase | Déconnecte l'ordinateur serveur local de la batterie.
Dismount-SPContentDatabase | Détache une base de données de contenu de l'application Web à laquelle elle est associée.
Enable-SPBusinessDataCatalogEntity | Active un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.
Enable-SPFeature | Active une fonctionnalité SharePoint installée à l'étendue donnée.
Enable-SPTimerJob | Active un travail du minuteur.
Enable-SPWebApplicationHttpThrottling | Active la limitation réseau pour une application Web.
Export-SPBusinessDataCatalogModel | Exporte un modèle Business Data Connectivity Model.
Export-SPSiteSubscriptionBusinessDataCatalogConfig | Exporte toutes les données du magasin de métadonnées Business Data Connectivity associé à une partition.
Export-SPSiteSubscriptionSettings | Crée un fichier de sauvegarde de données d'abonnement de site.
Export-SPWeb | Exporte une collection de sites, application Web, liste ou bibliothèque.
Get-SPAlternateURL | Renvoie toutes les URL de substitution qui correspondent à un ensemble de critères donné.
Get-SPAuthenticationProvider | Renvoie un fournisseur d'authentification.
Get-SPBackupHistory | Renvoie un historique des opérations de sauvegarde et de restauration.
Get-SPBrowserCustomerExperienceImprovementProgram | Renvoie l'état d'adhésion actuel pour le Programme d'amélioration du produit du navigateur.
Get-SPBusinessDataCatalogMetadataObject | Renvoie un objet de métadonnées de magasin de métadonnées Business Data Connectivity.
Get-SPBusinessDataCatalogThrottleConfig | Renvoie la configuration de limitation pour une application de service BDC.
Get-SPCertificateAuthority | Renvoie l'autorité de certification SharePoint.
Get-SPClaimProvider | Renvoie un fournisseur de revendications.
Get-SPClaimProviderManager | Renvoie un gestionnaire de fournisseur de revendications.
Get-SPContentDatabase | Renvoie une ou plusieurs bases de données de contenu.
Get-SPCustomLayoutsPage | Renvoie un mappage à une page de disposition personnalisée.
Get-SPDatabase | Extrait toutes les propriétés d'une base de données.
Get-SPDesignerSettings | Affiche les fonctionnalités de Microsoft SharePoint Designer 2010.
Get-SPDiagnosticConfig | Extrait les valeurs de configuration de diagnostic ULS de la batterie.
Get-SPDiagnosticsPerformanceCounter | Renvoie une collection de compteurs de performance.
Get-SPDiagnosticsProvider | Renvoie un fournisseur de diagnostics.
Get-SPFarm | Renvoie la batterie SharePoint locale.
Get-SPFarmConfig | Renvoie une propriété globale ou une collection de propriétés globales pour la batterie locale.
Get-SPFeature | Renvoie les fonctionnalités SharePoint sur la base d'une étendue donnée.
Get-SPHelpCollection | Renvoie des fichiers de collection d'aide.
Get-SPLogEvent | Renvoie des résultats à partir d'un journal de suivi ULS (Unified Logging Service).
Get-SPLogLevel | Renvoie une liste d'objets ou de niveaux de diagnostics.
Get-SPManagedAccount | Extrait des comptes enregistrés dans la base de données de configuration.
Get-SPManagedPath | Renvoie tous les chemins d'accès gérés qui correspondent aux critères donnés.
Get-SPMobileMessagingAccount | Extrait des comptes de messagerie mobile pour l'application Web spécifiée.
Get-SPProcessAccount | Renvoie un compte système ou un compte géré.
Get-SPProduct | Renvoie une liste des produits SharePoint installés dans la batterie et les versions de toutes les mises à jour installées pour chaque produit.
Get-SPSearchService | Retourne un service de recherche.
Get-SPSearchServiceInstance | Retourne une instance d'un service de recherche.
Get-SPSecurityTokenServiceConfig | Renvoie le service d'émission de jeton de sécurité (STS) de la batterie.
Get-SPServer | Renvoie le ou les serveurs de la batterie qui correspondent à l'identité donnée.
Get-SPServiceApplication | Renvoie l'application de service spécifiée.
Get-SPServiceApplicationEndpoint | Renvoie le point de terminaison d'une application de service.
Get-SPServiceApplicationPool | Renvoie le pool d'applications IIS (Internet Information Services) spécifié.
Get-SPServiceApplicationProxy | Renvoie une instance du proxy d'application de service de recherche.
Get-SPServiceApplicationProxyGroup | Renvoie le groupe de proxys pour l'application de service spécifiée.
Get-SPServiceApplicationSecurity | Renvoie l'objet SPObjectSecurity pour une application de service.
Get-SPServiceContext | Renvoie un contexte de service.
Get-SPServiceHostConfig | Renvoie les paramètres de service Web communs.
Get-SPServiceInstance | Renvoie l'instance de services pour un serveur spécifique ou pour la batterie entière.
Get-SPShellAdmin | Renvoie les noms de tous les utilisateurs ayant le rôle SharePoint_Shell_Access.
Get-SPSite | Renvoie toutes les collections de sites qui correspondent aux critères donnés.
Get-SPSiteAdministration | Renvoie un objet d'administration de site utilisable par les administrateurs de batterie pour afficher certaines informations sur les collections de sites auxquelles ils peuvent ne pas avoir accès.
Get-SPSiteSubscription | Renvoie l'abonnement de site pour l'URL donnée ou tous les abonnements de sites dans la batterie locale.
Get-SPSiteSubscriptionConfig | Renvoie les propriétés de configuration d'un abonnement de site.
Get-SPSiteSubscriptionFeaturePack | Extrait les ensembles de fonctionnalités SharePoint disponibles ou l'ensemble de fonctionnalités assigné à un abonnement de site donné.
Get-SPSolution | Renvoie une solution SharePoint spécifiée.
Get-SPTimerJob | Renvoie des travaux du minuteur.
Get-SPTopologyServiceApplication | Affiche les propriétés de l'application de service de topologie pour la batterie actuelle.
Get-SPTopologyServiceApplicationProxy | Extrait le proxy d'application de service de topologie.
Get-SPTrustedIdentityTokenIssuer | Renvoie un fournisseur d'identité.
Get-SPTrustedRootAuthority | Renvoie une autorité racine de confiance.
Get-SPTrustedServiceTokenIssuer | Renvoie l'objet qui représente l'approbation de batterie.
Get-SPUsageApplication | Renvoie une application d'utilisation spécifiée.
Get-SPUsageDefinition | Renvoie un objet de définition d'utilisation.
Get-SPUsageService | Renvoie un service d'utilisation.
Get-SPUser | Renvoie le ou les comptes d'utilisateurs qui correspondent à un critère de recherche donné.
Get-SPUserSolution | Renvoie une solution en mode bac à sable spécifiée.
Get-SPWeb | Renvoie tous les sous-sites qui correspondent aux critères donnés.
Get-SPWebApplication | Renvoie toutes les applications Web qui correspondent aux critères donnés.
Get-SPWebApplicationHttpThrottlingMonitor | Lit tous les compteurs de limitation réseau sur une application Web.
Get-SPWebPartPack | Renvoie les packages de composants WebPart qui ont été installés pour l'étendue spécifiée.
Get-SPWebTemplate | Affiche tous les modèles de sites installés globalement qui correspondent à l'identité donnée.
Get-SPWorkflowConfig | Renvoie les paramètres de flux de travail pour l'application Web spécifiée.
Grant-SPBusinessDataCatalogMetadataObject | Accorde un droit à une entité pour l'objet de métadonnées de magasin de métadonnées Business Data Connectivity spécifié.
Grant-SPObjectSecurity | Ajoute une nouvelle entité de sécurité à un objet SPObjectSecurity.
Grant-SPServiceApplication | Accorde à un compte d'utilisateur l'accès à l'application de service.
Import-SPSiteSubscriptionBusinessDataCatalogDotNetAssembly | Importe des données associées au magasin de métadonnées Business Data Connectivity pour une partition.
Import-SPBusinessDataCatalogModel | Importe un modèle Business Data Connectivity.
Import-SPSiteSubscriptionSettings | Restaure une sauvegarde des paramètres de site d'abonnement à l'identificateur d'abonnement donné.
Import-SPWeb | Importe une collection de sites, application Web, liste ou bibliothèque.
Initialize-SPResourceSecurity | Applique la sécurité des ressources sur le serveur local.
Install-SPApplicationContent | Copie les données d'applications partagées dans les dossiers d'applications Web existants.
Install-SPFeature | Installe une fonctionnalité SharePoint à l'aide du fichier Feature.xml.
Install-SPHelpCollection | Installe les fichiers de collection de sites d'aide fournis dans la batterie actuelle.
Install-SPService | Installe et configure des services dans une batterie.
Install-SPSolution | Déploie une solution SharePoint installée dans la batterie.
Install-SPUserSolution | Active une solution en mode bac à sable dans une collection de sites.
Install-SPWebPartPack | Installe le package de composants WebPart spécifié à l'emplacement spécifié.
Install-SPWebTemplate | Installe le modèle de site donné.
Merge-SPLogFile | Combine les entrées de journaux de suivi de tous les ordinateurs de la batterie en un seul fichier journal sur l'ordinateur local.
Mount-SPContentDatabase | Attache une base de données de contenu existante à la batterie.
Move-SPBlobStorageLocation | Copie une base de donnéesWindows SharePoint Services 3.0 à l'aide du stockage BLOB distant.
Move-SPSite | Déplace des collections de sites d'une base de données de contenu vers une autre.
Move-SPUser | Migre un compte d'utilisateur dans les produits SharePoint 2010.
New-SPAlternateUrl | Crée une URL publique ou interne pour la ressource ou la zone d'application Web spécifiée.
New-SPAuthenticationProvider | Crée un fournisseur d'authentification dans la batterie.
New-SPBusinessDataCatalogServiceApplication | Crée une application de service Business Data Connectivity dans la batterie.
New-SPBusinessDataCatalogServiceApplicationProxy | Crée un proxy d'application de service Business Data Connectivity dans la batterie.
New-SPCentralAdministration | Crée une application Web Administration centrale de SharePoint.
New-SPClaimProvider | Enregistre un nouveau fournisseur de revendications dans la batterie.
New-SPClaimsPrincipal | Crée une entité de revendications.
New-SPClaimTypeMapping | Crée une règle de mappage de revendications pour un fournisseur d'identité de service d'émission de jeton de sécurité (STS).
New-SPConfigurationDatabase | Crée une base de données de configuration.
New-SPContentDatabase | Crée une base de données de contenu et l'attache à l'application Web spécifiée.
New-SPLogFile | Crée un fichier journal.
New-SPManagedAccount | Enregistre un nouveau compte géré.
New-SPManagedPath | Crée un chemin d'accès géré pour l'application Web donnée pour toutes les collections de sites d'en-tête d'hôte.
New-SPServiceApplicationPool | Crée un pool d'applications de service Web.
New-SPServiceApplicationProxyGroup | Crée un groupe de proxys d'application de service.
New-SPSite | Crée une collection de sites à l'URL spécifiée.
New-SPSiteSubscription | Crée un abonnement de site.
New-SPSiteSubscriptionFeaturePack | Crée un ensemble de fonctionnalités SharePoint qui peut être utilisé pour limiter les fonctionnalités accessibles à un abonnement de site.
New-SPSubscriptionSettingsServiceApplication | Crée une application de service de paramètres d'abonnement.
New-SPSubscriptionSettingsServiceApplicationProxy | Crée un proxy d'application dans une application de service de paramètres d'abonnement.
New-SPTrustedIdentityTokenIssuer | Crée un fournisseur d'identité dans la batterie.
New-SPTrustedRootAuthority | Crée une autorité racine de confiance.
New-SPTrustedServiceTokenIssuer | Crée une approbation avec une batterie SharePoint.
New-SPUsageApplication | Crée une application d'utilisation.
New-SPUsageLogFile | Démarre un nouveau fichier journal d'utilisation sur l'ordinateur serveur actuel.
New-SPUser | Ajoute un utilisateur existant à un site SharePoint avec les autorisations désignées.
New-SPWeb | Crée un site dans une collection de sites existante.
New-SPWebApplication | Crée une application Web dans la batterie locale.
New-SPWebApplicationExtension | Crée une instance de zone pour l'application Web.
Publish-SPServiceApplication | Partage l'application de service locale spécifiée en dehors de la batterie.
Receive-SPSharedServiceApplicationInfo | Configure cette batterie de façon à recevoir des informations de service en provenance d'une autre batterie.
Remove-SPAlternateUrl | Supprime entièrement l'URL de substitution spécifiée.
Remove-SPBusinessDataCatalogModel | Supprime un modèle Business Data Connectivity.
Remove-SPClaimProvider | Annule l'enregistrement d'un fournisseur de revendications.
Remove-SPClaimTypeMapping | Supprime une règle de mappage de type de revendication pour un fournisseur d'identité de service d'émission de jeton de sécurité (STS).
Remove-SPConfigurationDatabase | Supprime de manière définitive une base de données de configuration.
Remove-SPContentDatabase | Supprime une base de données de contenu.
Remove-SPDiagnosticsPerformanceCounter | Supprime une instance d'un compteur de performance.
Remove-SPManagedAccount | Supprime un enregistrement de compte géré de la batterie.
Remove-SPManagedPath | Supprime le chemin d'accès géré spécifié de l'en-tête d'hôte ou de l'application Web spécifié(e).
Remove-SPServiceApplication | Supprime l'application de service spécifiée sur le serveur local.
Remove-SPServiceApplicationPool | Supprime entièrement le pool d'applications de service Web spécifié.
Remove-SPServiceApplicationProxy | Supprime le proxy d'application de service spécifié.
Remove-SPServiceApplicationProxyGroup | Supprime entièrement le groupe de proxys d'application de service spécifié.
Remove-SPServiceApplicationProxyGroupMember | Supprime un ou plusieurs proxys du groupe de proxys d'application de service spécifié.
Remove-SPShellAdmin | Supprime un utilisateur du rôle SharePoint_Shell_Access.
Remove-SPSite | Supprime entièrement une collection de sites existante et tous les sous-sites.
Remove-SPSiteSubscription | Supprime les données stockées dans une application de service de paramètres d'abonnement pour un ensemble d'abonnements de site.
Remove-SPSiteSubscriptionBusinessDataCatalogConfig | Supprime le magasin de métadonnées Business Data Connectivity pour une partition.
Remove-SPSiteSubscriptionFeaturePack | Supprime un ensemble de fonctionnalités SharePoint d'un abonnement de site.
Remove-SPSiteSubscriptionFeaturePackMember | Supprime une définition de fonctionnalité de l'ensemble de fonctionnalités SharePoint fourni.
Remove-SPSiteSubscriptionSettings | Supprime les données de service de paramètres pour un abonnement de site spécifié ou recherche et supprime les données orphelines.
Remove-SPSolution | Supprime une solution SharePoint d'une batterie.
Remove-SPSolutionDeploymentLock | Supprime le verrou de déploiement de solution pour un serveur.
Remove-SPTrustedIdentityTokenIssuer | Supprime un fournisseur d'identité de service d'émission de jeton de sécurité (STS) de la batterie.
Remove-SPTrustedRootAuthority | Supprime une autorité racine de confiance.
Remove-SPTrustedServiceTokenIssuer | Supprime l'objet qui représente l'approbation de batterie.
Remove-SPUsageApplication | Supprime l'application d'utilisation de la batterie locale.
Remove-SPUser | Supprime un utilisateur d'un site Web.
Remove-SPUserSolution | Supprime une solution en mode bac à sable de la galerie de solutions.
Remove-SPWeb | Supprime entièrement le Web spécifié.
Remove-SPWebApplication | Supprime l'application Web spécifiée.
Rename-SPServer | Renomme un serveur actuellement connecté à la batterie.
Repair-SPManagedAccountDeployment | Répare le déploiement des informations d'identification de comptes gérés locaux.
Restore-SPFarm | Restaure un ou plusieurs éléments à partir d'une sauvegarde.
Restore-SPSite | Restaure une collection de sites.
Revoke-SPBusinessDataCatalogMetadataObject | Révoque un droit à une entité dans l'objet de métadonnées de magasin de métadonnées Business Data Connectivity spécifié.
Revoke-SPObjectSecurity | Supprime une entité de sécurité d'un objet SPObjectSecurity.
Revoke-SPServiceApplication | Révoque l'accès d'un utilisateur à une application de service.
Set-SPAlternateUrl | Configure l'URL de substitution spécifiée.
Set-SPBrowserCustomerExperienceImprovementProgram | Active ou désactive le Programme d'amélioration du produit du navigateur.
Set-SPBusinessDataCatalogMetadataObject | Définit la valeur d'une propriété ou d'un attribut d'un objet de métadonnées de magasin de métadonnées Business Data Connectivity.
Set-SPBusinessDataCatalogServiceApplication | Définit les propriétés globales pour une application de service Business Data Connectivity dans la batterie.
Set-SPBusinessDataCatalogThrottleConfig | Définit la configuration de limitation pour une application de service BDC.
Set-SPCentralAdministration | Définit le port du site Web Administration centrale de SharePoint.
Set-SPClaimProvider | Met à jour l'enregistrement d'un fournisseur de revendications.
Set-SPContentDatabase | Définit les propriétés globales d'une base de données de contenu SharePoint.
Set-SPCustomLayoutsPage | Mappe un nouveau chemin d'accès pour une page de disposition personnalisée.
Set-SPDesignerSettings | Définit des fonctionnalités Microsoft SharePoint Designer 2010.
Set-SPDiagnosticConfig | Définit des paramètres de configuration de diagnostics sur la batterie.
Set-SPDiagnosticsProvider | Active un fournisseur de diagnostics et met à jour sa stratégie de rétention.
Set-SPFarmConfig | Définit une propriété globale ou une collection de propriétés globales pour la batterie locale.
Set-SPLogLevel | Définit le niveau de trace et d'événement pour un ensemble de catégories.
Set-SPManagedAccount | Configure le compte géré.
Set-SPMobileMessagingAccount | Configure le compte de messagerie mobile spécifié.
Set-SPPassPhrase | Affecte une nouvelle valeur à la phrase secrète.
Set-SPSearchService | Définit les propriétés d'un service de recherche.
Set-SPSearchServiceInstance | Définit les propriétés d'une instance de service de recherche.
Set-SPSecurityTokenServiceConfig | Met à jour les paramètres du fournisseur d'identité de service d'émission de jeton de sécurité (STS).
Set-SPServiceApplication | Définit les propriétés d'une application de service.
Set-SPServiceApplicationEndpoint | Définit l'hôte d'un point de terminaison pour une application de service.
Set-SPServiceApplicationPool | Modifie le compte utilisé comme Identité du pool d'applications spécifié.
Set-SPServiceApplicationSecurity | Met à jour l'objet SPObjectSecurity pour une application de service.
Set-SPServiceHostConfig | Configure un ou plusieurs paramètres communs pour tous les services Web.
Set-SPSite | Configure la collection de sites spécifiée.
Set-SPSiteAdministration | Permet aux administrateurs de batterie de configurer n'importe quelle collection de sites.
Set-SPSiteSubscriptionConfig | Définit les propriétés de configuration d'un abonnement de site.
Set-SPSubscriptionSettingsServiceApplication | Définit les propriétés d'une application de service de paramètres d'abonnement.
Set-SPTimerJob | Définit la planification d'exécution d'un travail du minuteur.
Set-SPTopologyServiceApplication | Définit les propriétés sur l'application de service de topologie de la batterie locale.
Set-SPTopologyServiceApplicationProxy | Définit les propriétés de proxy de l'application de service de topologie.
Set-SPTrustedIdentityTokenIssuer | Définit les fournisseurs d'identités d'une application Web.
Set-SPTrustedRootAuthority | Crée une autorité racine de confiance.
Set-SPTrustedServiceTokenIssuer | Met à jour une approbation avec la batterie.
Set-SPUsageApplication | Définit les propriétés d'une application d'utilisation.
Set-SPUsageDefinition | Définit la période de rétention pour un fournisseur d'utilisation.
Set-SPUsageService | Définit les propriétés d'un service d'utilisation.
Set-SPUser | Configure les propriétés sur un utilisateur existant.
Set-SPWeb | Configure le sous-site spécifié.
Set-SPWebApplication | Configure l'application Web spécifiée.
Set-SPWebApplicationHttpThrottlingMonitor | Définit les valeurs de paquet Score d'intégrité pour un compteur de performance de limitation réseau existant pour une application Web spécifiée.
Set-SPWebTemplate | Modifie le titre et la description d'un modèle de site installé.
Set-SPWorkflowConfig | Configure les paramètres de flux de travail pour l'application Web spécifiée.
Start-SPAdminJob | Démarre immédiatement tout travail administratif en attente sur l'ordinateur local.
Start-SPAssignment | Initie un nouveau magasin d'affectations.
Start-SPServiceInstance | Démarre l'instance de service pour un service sur un serveur spécifique ou sur la batterie.
Start-SPTimerJob | Exécute un travail du minuteur une seule fois.
Stop-SPAssignment | Élimine des objets dans la collection d'affectations fournie.
Stop-SPServiceInstance | Arrête l'instance de service pour un service.
Test-SPContentDatabase | Teste une base de données de contenu.
Uninstall-SPFeature | Désinstalle une définition de fonctionnalité installée.
Uninstall-SPHelpCollection | Supprime des fichiers de collection d'aide.
Uninstall-SPSolution | Retire une solution SharePoint déployée.
Uninstall-SPUserSolution | Désactive une solution en mode bac à sable dans une collection de sites.
Uninstall-SPWebPartPack | Désinstalle le package de composants WebPart spécifié.
Uninstall-SPWebTemplate | Désinstalle le modèle de site donné.
Unpublish-SPServiceApplication | Arrête le partage de l'application de service spécifiée en dehors de la batterie.
Update-SPFarmEncryptionKey | Modifie la valeur de la clé de chiffrement de batterie et, à l'aide de la nouvelle clé, rechiffre toutes les données.
Update-SPInfoPathUrl | Exécute un correctif .xsn/.udc Microsoft InfoPath 2010 sur SharePoint Foundation 2010.
Update-SPSolution | Met à niveau une solution SharePoint déployée.
Update-SPUserSolution | Met à niveau une solution en mode bac à sable activée dans une batterie.
Upgrade-SPContentDatabase | Met à niveau une base de données de contenu.

Applets de commande SharePoint Foundation 2010 par ordre de nom

Nom de l'applet de commande | Description
Start-SPAdminJob | Démarre immédiatement tout travail administratif en attente sur l'ordinateur local.
Get-SPAlternateURL | Renvoie toutes les URL de substitution qui correspondent à un ensemble de critères donné.
New-SPAlternateUrl | Crée une URL publique ou interne pour la ressource ou la zone d'application Web spécifiée.
Remove-SPAlternateUrl | Supprime entièrement l'URL de substitution spécifiée.
Set-SPAlternateUrl | Configure l'URL de substitution spécifiée.
Install-SPApplicationContent | Copie les données d'applications partagées dans les dossiers d'applications Web existants.
Start-SPAssignment | Initie un nouveau magasin d'affectations.
Stop-SPAssignment | Élimine des objets dans la collection d'affectations fournie.
Get-SPAuthenticationProvider | Renvoie un fournisseur d'authentification.
New-SPAuthenticationProvider | Crée un fournisseur d'authentification dans la batterie.
Get-SPBackupHistory | Renvoie un historique des opérations de sauvegarde et de restauration.
Move-SPBlobStorageLocation | Copie une base de donnéesWindows SharePoint Services 3.0 à l'aide du stockage BLOB distant.
Get-SPBrowserCustomerExperienceImprovementProgram | Renvoie l'état d'adhésion actuel pour le Programme d'amélioration du produit du navigateur.
Set-SPBrowserCustomerExperienceImprovementProgram | Active ou désactive le Programme d'amélioration du produit du navigateur.
Copy-SPBusinessDataCatalogAclToChildren | Copie un ensemble d'autorisations d'un objet de métadonnées du magasin de métadonnées Business Data Connectivity dans ses objets enfants.
Import-SPSiteSubscriptionBusinessDataCatalogDotNetAssembly | Importe des données associées au magasin de métadonnées Business Data Connectivity pour une partition.
Disable-SPBusinessDataCatalogEntity | Désactive un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.
Enable-SPBusinessDataCatalogEntity | Active un type de contenu externe dans le magasin de métadonnées Business Data Connectivity.
Get-SPBusinessDataCatalogMetadataObject | Renvoie un objet de métadonnées de magasin de métadonnées Business Data Connectivity.
Grant-SPBusinessDataCatalogMetadataObject | Accorde un droit à une entité pour l'objet de métadonnées de magasin de métadonnées Business Data Connectivity spécifié.
Revoke-SPBusinessDataCatalogMetadataObject | Révoque un droit à une entité dans l'objet de métadonnées de magasin de métadonnées Business Data Connectivity spécifié.
Set-SPBusinessDataCatalogMetadataObject | Définit la valeur d'une propriété ou d'un attribut d'un objet de métadonnées de magasin de métadonnées Business Data Connectivity.
Export-SPBusinessDataCatalogModel | Exporte un modèle Business Data Connectivity Model.
Import-SPBusinessDataCatalogModel | Importe un modèle Business Data Connectivity.
Remove-SPBusinessDataCatalogModel | Supprime un modèle Business Data Connectivity.
New-SPBusinessDataCatalogServiceApplication | Crée une application de service Business Data Connectivity dans la batterie.
Set-SPBusinessDataCatalogServiceApplication | Définit les propriétés globales pour une application de service Business Data Connectivity dans la batterie.
New-SPBusinessDataCatalogServiceApplicationProxy | Crée un proxy d'application de service Business Data Connectivity dans la batterie.
Get-SPBusinessDataCatalogThrottleConfig | Renvoie la configuration de limitation pour une application de service BDC.
Set-SPBusinessDataCatalogThrottleConfig | Définit la configuration de limitation pour une application de service BDC.
New-SPCentralAdministration | Crée une application Web Administration centrale de SharePoint.
Set-SPCentralAdministration | Définit le port du site Web Administration centrale de SharePoint.
Get-SPCertificateAuthority | Renvoie l'autorité de certification SharePoint.
Get-SPClaimProvider | Renvoie un fournisseur de revendications.
New-SPClaimProvider | Enregistre un nouveau fournisseur de revendications dans la batterie.
Remove-SPClaimProvider | Annule l'enregistrement d'un fournisseur de revendications.
Set-SPClaimProvider | Met à jour l'enregistrement d'un fournisseur de revendications.
Get-SPClaimProviderManager | Renvoie un gestionnaire de fournisseur de revendications.
New-SPClaimsPrincipal | Crée une entité de revendications.
Add-SPClaimTypeMapping | Ajoute un mappage de revendications à un fournisseur d'identité de service d'émission de jeton de sécurité (STS) approuvé.
New-SPClaimTypeMapping | Crée une règle de mappage de revendications pour un fournisseur d'identité de service d'émission de jeton de sécurité (STS).
Remove-SPClaimTypeMapping | Supprime une règle de mappage de type de revendication pour un fournisseur d'identité de service d'émission de jeton de sécurité (STS).
Backup-SPConfigurationDatabase | Effectue une sauvegarde configuration-uniquement au niveau de la batterie.
Connect-SPConfigurationDatabase | Connecte l'ordinateur serveur local à une batterie.
Disconnect-SPConfigurationDatabase | Déconnecte l'ordinateur serveur local de la batterie.
New-SPConfigurationDatabase | Crée une base de données de configuration.
Remove-SPConfigurationDatabase | Supprime de manière définitive une base de données de configuration.
Dismount-SPContentDatabase | Détache une base de données de contenu de l'application Web à laquelle elle est associée.
Get-SPContentDatabase | Renvoie une ou plusieurs bases de données de contenu.
Mount-SPContentDatabase | Attache une base de données de contenu existante à la batterie.
New-SPContentDatabase | Crée une base de données de contenu et l'attache à l'application Web spécifiée.
Remove-SPContentDatabase | Supprime une base de données de contenu.
Set-SPContentDatabase | Définit les propriétés globales d'une base de données de contenu SharePoint.
Test-SPContentDatabase | Teste une base de données de contenu.
Upgrade-SPContentDatabase | Met à niveau une base de données de contenu.
Get-SPCustomLayoutsPage | Renvoie un mappage à une page de disposition personnalisée.
Set-SPCustomLayoutsPage | Mappe un nouveau chemin d'accès pour une page de disposition personnalisée.
Get-SPDatabase | Extrait toutes les propriétés d'une base de données.
Get-SPDesignerSettings | Affiche les fonctionnalités de Microsoft SharePoint Designer 2010.
Set-SPDesignerSettings | Définit des fonctionnalités Microsoft SharePoint Designer 2010.
Get-SPDiagnosticConfig | Extrait les valeurs de configuration de diagnostic ULS de la batterie.
Set-SPDiagnosticConfig | Définit des paramètres de configuration de diagnostics sur la batterie.
Add-SPDiagnosticsPerformanceCounter | Ajoute une instance d'un compteur de performance.
Get-SPDiagnosticsPerformanceCounter | Renvoie une collection de compteurs de performance.
Remove-SPDiagnosticsPerformanceCounter | Supprime une instance d'un compteur de performance.
Get-SPDiagnosticsProvider | Renvoie un fournisseur de diagnostics.
Set-SPDiagnosticsProvider | Active un fournisseur de diagnostics et met à jour sa stratégie de rétention.
Backup-SPFarm | Crée une sauvegarde d'une batterie, d'une application Web ou de la batterie entière.
Get-SPFarm | Renvoie la batterie SharePoint locale.
Restore-SPFarm | Restaure un ou plusieurs éléments à partir d'une sauvegarde.
Get-SPFarmConfig | Renvoie une propriété globale ou une collection de propriétés globales pour la batterie locale.
Set-SPFarmConfig | Définit une propriété globale ou une collection de propriétés globales pour la batterie locale.
Update-SPFarmEncryptionKey | Modifie la valeur de la clé de chiffrement de batterie et, à l'aide de la nouvelle clé, rechiffre toutes les données.
Disable-SPFeature | Désactive une fonctionnalité SharePoint installée à une étendue donnée.
Enable-SPFeature | Active une fonctionnalité SharePoint installée à l'étendue donnée.
Get-SPFeature | Renvoie les fonctionnalités SharePoint sur la base d'une étendue donnée.
Install-SPFeature | Installe une fonctionnalité SharePoint à l'aide du fichier Feature.xml.
Uninstall-SPFeature | Désinstalle une définition de fonctionnalité installée.
Get-SPHelpCollection | Renvoie des fichiers de collection d'aide.
Install-SPHelpCollection | Installe les fichiers de collection de sites d'aide fournis dans la batterie actuelle.
Uninstall-SPHelpCollection | Supprime des fichiers de collection d'aide.
Update-SPInfoPathUrl | Exécute un correctif .xsn/.udc Microsoft InfoPath 2010 sur SharePoint Foundation 2010.
Get-SPLogEvent | Renvoie des résultats à partir d'un journal de suivi ULS (Unified Logging Service).
Merge-SPLogFile | Combine les entrées de journaux de suivi de tous les ordinateurs de la batterie en un seul fichier journal sur l'ordinateur local.
New-SPLogFile | Crée un fichier journal.
Clear-SPLogLevel | Réinitialise les niveaux de journalisation du suivi et de journalisation des événements à leurs valeurs par défaut.
Get-SPLogLevel | Renvoie une liste d'objets ou de niveaux de diagnostics.
Set-SPLogLevel | Définit le niveau de trace et d'événement pour un ensemble de catégories.
Get-SPManagedAccount | Extrait des comptes enregistrés dans la base de données de configuration.
New-SPManagedAccount | Enregistre un nouveau compte géré.
Remove-SPManagedAccount | Supprime un enregistrement de compte géré de la batterie.
Set-SPManagedAccount | Configure le compte géré.
Repair-SPManagedAccountDeployment | Répare le déploiement des informations d'identification de comptes gérés locaux.
Get-SPManagedPath | Renvoie tous les chemins d'accès gérés qui correspondent aux critères donnés.
New-SPManagedPath | Crée un chemin d'accès géré pour l'application Web donnée pour toutes les collections de sites d'en-tête d'hôte.
Remove-SPManagedPath | Supprime le chemin d'accès géré spécifié de l'en-tête d'hôte ou de l'application Web spécifié(e).
Get-SPMobileMessagingAccount | Extrait des comptes de messagerie mobile pour l'application Web spécifiée.
Set-SPMobileMessagingAccount | Configure le compte de messagerie mobile spécifié.
Grant-SPObjectSecurity | Ajoute une nouvelle entité de sécurité à un objet SPObjectSecurity.
Revoke-SPObjectSecurity | Supprime une entité de sécurité d'un objet SPObjectSecurity.
Set-SPPassPhrase | Affecte une nouvelle valeur à la phrase secrète.
Get-SPProcessAccount | Renvoie un compte système ou un compte géré.
Get-SPProduct | Renvoie une liste des produits SharePoint installés dans la batterie et les versions de toutes les mises à jour installées pour chaque produit.
Initialize-SPResourceSecurity | Applique la sécurité des ressources sur le serveur local.
Get-SPSearchService | Retourne un service de recherche.
Set-SPSearchService | Définit les propriétés d'un service de recherche.
Get-SPSearchServiceInstance | Retourne une instance d'un service de recherche.
Set-SPSearchServiceInstance | Définit les propriétés d'une instance de service de recherche.
Get-SPSecurityTokenServiceConfig | Renvoie le service d'émission de jeton de sécurité (STS) de la batterie.
Set-SPSecurityTokenServiceConfig | Met à jour les paramètres du fournisseur d'identité de service d'émission de jeton de sécurité (STS).
Get-SPServer | Renvoie le ou les serveurs de la batterie qui correspondent à l'identité donnée.
Rename-SPServer | Renomme un serveur actuellement connecté à la batterie.
Install-SPService | Installe et configure des services dans une batterie.
Get-SPServiceApplication | Renvoie l'application de service spécifiée.
Grant-SPServiceApplication | Accorde à un compte d'utilisateur l'accès à l'application de service.
Publish-SPServiceApplication | Partage l'application de service locale spécifiée en dehors de la batterie.
Remove-SPServiceApplication | Supprime l'application de service spécifiée sur le serveur local.
Revoke-SPServiceApplication | Révoque l'accès d'un utilisateur à une application de service.
Set-SPServiceApplication | Définit les propriétés d'une application de service.
Unpublish-SPServiceApplication | Arrête le partage de l'application de service spécifiée en dehors de la batterie.
Get-SPServiceApplicationEndpoint | Renvoie le point de terminaison d'une application de service.
Set-SPServiceApplicationEndpoint | Définit l'hôte d'un point de terminaison pour une application de service.
Get-SPServiceApplicationPool | Renvoie le pool d'applications IIS (Internet Information Services) spécifié.
New-SPServiceApplicationPool | Crée un pool d'applications de service Web.
Remove-SPServiceApplicationPool | Supprime entièrement le pool d'applications de service Web spécifié.
Set-SPServiceApplicationPool | Modifie le compte utilisé comme Identité du pool d'applications spécifié.
Get-SPServiceApplicationProxy | Renvoie une instance du proxy d'application de service de recherche spécifié.
Remove-SPServiceApplicationProxy | Supprime le proxy d'application de service spécifié.
Get-SPServiceApplicationProxyGroup | Renvoie le groupe de proxys pour l'application de service spécifiée.
New-SPServiceApplicationProxyGroup | Crée un groupe de proxys d'application de service.
Remove-SPServiceApplicationProxyGroup | Supprime entièrement le groupe de proxys d'application de service spécifié.
Add-SPServiceApplicationProxyGroupMember | Ajoute un membre au groupe de proxys d'application de service.
Remove-SPServiceApplicationProxyGroupMember | Supprime un ou plusieurs proxys du groupe de proxys d'application de service spécifié.
Get-SPServiceApplicationSecurity | Renvoie l'objet SPObjectSecurity pour une application de service.
Set-SPServiceApplicationSecurity | Met à jour l'objet SPObjectSecurity pour une application de service.
Get-SPServiceContext | Renvoie un contexte de service.
Get-SPServiceHostConfig | Renvoie les paramètres de service Web communs.
Set-SPServiceHostConfig | Configure un ou plusieurs paramètres communs pour tous les services Web.
Get-SPServiceInstance | Renvoie l'instance de services pour un serveur spécifique ou pour la batterie entière.
Start-SPServiceInstance | Démarre l'instance de service pour un service sur un serveur spécifique ou sur la batterie.
Stop-SPServiceInstance | Arrête l'instance de service pour un service.
Receive-SPSharedServiceApplicationInfo | Configure cette batterie de façon à recevoir des informations de service en provenance d'une autre batterie.
Add-SPShellAdmin | Ajoute un utilisateur au rôle SharePoint_Shell_Access pour la base de données spécifiée.
Get-SPShellAdmin | Renvoie les noms de tous les utilisateurs ayant le rôle SharePoint_Shell_Access.
Remove-SPShellAdmin | Supprime un utilisateur du rôle SharePoint_Shell_Access.
Backup-SPSite | Effectue une sauvegarde d'une collection de sites.
Get-SPSite | Renvoie toutes les collections de sites qui correspondent aux critères donnés.
Move-SPSite | Déplace des collections de sites d'une base de données de contenu vers une autre.
New-SPSite | Crée une collection de sites à l'URL spécifiée.
Remove-SPSite | Supprime entièrement une collection de sites existante et tous les sous-sites.
Restore-SPSite | Restaure une collection de sites
Set-SPSite | Configure la collection de sites spécifiée.
Get-SPSiteAdministration | Renvoie un objet d'administration de site utilisable par les administrateurs de batterie pour afficher certaines informations sur les collections de sites auxquelles ils peuvent ne pas avoir accès.
Set-SPSiteAdministration | Permet aux administrateurs de batterie de configurer n'importe quelle collection de sites.
Get-SPSiteSubscription | Renvoie l'abonnement de site pour l'URL donnée ou tous les abonnements de sites dans la batterie locale.
New-SPSiteSubscription | Crée un abonnement de site.
Remove-SPSiteSubscription | Supprime les données stockées dans une application de service de paramètres d'abonnement pour un ensemble d'abonnements de site.
Clear-SPSiteSubscriptionBusinessDataCatalogConfig | Supprime toutes les données du magasin de métadonnées Business Data Connectivity pour une partition spécifiée.
Export-SPSiteSubscriptionBusinessDataCatalogConfig | Exporte toutes les données du magasin de métadonnées Business Data Connectivity associé à une partition.
Remove-SPSiteSubscriptionBusinessDataCatalogConfig | Supprime le magasin de métadonnées Business Data Connectivity pour une partition.
Get-SPSiteSubscriptionConfig | Renvoie les propriétés de configuration d'un abonnement de site.
Set-SPSiteSubscriptionConfig | Définit les propriétés de configuration d'un abonnement de site.
Get-SPSiteSubscriptionFeaturePack | Extrait les ensembles de fonctionnalités SharePoint disponibles ou l'ensemble de fonctionnalités assigné à un abonnement de site donné.
New-SPSiteSubscriptionFeaturePack | Crée un ensemble de fonctionnalités SharePoint qui peut être utilisé pour limiter les fonctionnalités accessibles à un abonnement de site.
Remove-SPSiteSubscriptionFeaturePack | Supprime un ensemble de fonctionnalités SharePoint d'un abonnement de site.
Add-SPSiteSubscriptionFeaturePackMember | Ajoute une fonctionnalité à un ensemble de fonctionnalités SharePoint.
Remove-SPSiteSubscriptionFeaturePackMember | Supprime une définition de fonctionnalité de l'ensemble de fonctionnalités SharePoint fourni.
Export-SPSiteSubscriptionSettings | Crée un fichier de sauvegarde de données d'abonnement de site.
Import-SPSiteSubscriptionSettings | Restaure une sauvegarde des paramètres de site d'abonnement à l'identificateur d'abonnement donné.
Remove-SPSiteSubscriptionSettings | Supprime les données de service de paramètres pour un abonnement de site spécifié ou recherche et supprime les données orphelines.
Add-SPSolution | Télécharge un package de solution SharePoint vers la batterie.
Get-SPSolution | Renvoie une solution SharePoint spécifiée.
Install-SPSolution | Déploie une solution SharePoint installée dans la batterie.
Remove-SPSolution | Supprime une solution SharePoint d'une batterie.
Uninstall-SPSolution | Retire une solution SharePoint déployée.
Update-SPSolution | Met à niveau une solution SharePoint déployée.
Remove-SPSolutionDeploymentLock | Supprime le verrou de déploiement de solution pour un serveur.
New-SPSubscriptionSettingsServiceApplication | Crée une application de service de paramètres d'abonnement.
Set-SPSubscriptionSettingsServiceApplication | Définit les propriétés d'une application de service de paramètres d'abonnement.
New-SPSubscriptionSettingsServiceApplicationProxy | Crée un proxy d'application dans une application de service de paramètres d'abonnement.
Disable-SPTimerJob | Désactive un travail du minuteur.
Enable-SPTimerJob | Active un travail du minuteur.
Get-SPTimerJob | Renvoie des travaux du minuteur.
Set-SPTimerJob | Définit la planification d'exécution d'un travail du minuteur.
Start-SPTimerJob | Exécute un travail du minuteur une seule fois.
Get-SPTopologyServiceApplication | Affiche les propriétés de l'application de service de topologie pour la batterie actuelle.
Set-SPTopologyServiceApplication | Définit les propriétés sur l'application de service de topologie de la batterie locale.
Get-SPTopologyServiceApplicationProxy | Extrait le proxy d'application de service de topologie.
Set-SPTopologyServiceApplicationProxy | Définit les propriétés de proxy de l'application de service de topologie.
Get-SPTrustedIdentityTokenIssuer | Renvoie un fournisseur d'identité.
New-SPTrustedIdentityTokenIssuer | Crée un fournisseur d'identité dans la batterie.
Remove-SPTrustedIdentityTokenIssuer | Supprime un fournisseur d'identité de service d'émission de jeton de sécurité (STS) de la batterie.
Set-SPTrustedIdentityTokenIssuer | Définit les fournisseurs d'identités d'une application Web.
Get-SPTrustedRootAuthority | Renvoie une autorité racine de confiance.
New-SPTrustedRootAuthority | Crée une autorité racine de confiance.
Remove-SPTrustedRootAuthority | Supprime une autorité racine de confiance.
Set-SPTrustedRootAuthority | Crée une autorité racine de confiance.
Get-SPTrustedServiceTokenIssuer | Renvoie l'objet qui représente l'approbation de batterie.
New-SPTrustedServiceTokenIssuer | Crée une approbation avec une batterie SharePoint.
Remove-SPTrustedServiceTokenIssuer | Supprime l'objet qui représente l'approbation de batterie.
Set-SPTrustedServiceTokenIssuer | Met à jour une approbation avec la batterie.
Get-SPUsageApplication | Renvoie une application d'utilisation spécifiée.
New-SPUsageApplication | Crée une application d'utilisation.
Remove-SPUsageApplication | Supprime l'application d'utilisation de la batterie locale.
Set-SPUsageApplication | Définit les propriétés d'une application d'utilisation.
Get-SPUsageDefinition | Renvoie un objet de définition d'utilisation.
Set-SPUsageDefinition | Définit la période de rétention pour un fournisseur d'utilisation.
New-SPUsageLogFile | Démarre un nouveau fichier journal d'utilisation sur l'ordinateur serveur actuel.
Get-SPUsageService | Renvoie un service d'utilisation.
Set-SPUsageService | Définit les propriétés d'un service d'utilisation.
Get-SPUser | Renvoie le ou les comptes d'utilisateurs qui correspondent à un critère de recherche donné.
Move-SPUser | Migre un compte d'utilisateur dans les produits SharePoint 2010.
New-SPUser | Ajoute un utilisateur existant à un site SharePoint avec les autorisations désignées.
Remove-SPUser | Supprime un utilisateur d'un site Web.
Set-SPUser | Configure les propriétés sur un utilisateur existant.
Add-SPUserSolution | Télécharge une nouvelle solution en mode bac à sable vers la galerie de solutions.
Get-SPUserSolution | Renvoie une solution en mode bac à sable spécifiée.
Install-SPUserSolution | Active une solution en mode bac à sable dans une collection de sites.
Remove-SPUserSolution | Supprime une solution en mode bac à sable de la galerie de solutions.
Uninstall-SPUserSolution | Désactive une solution en mode bac à sable dans une collection de sites.
Update-SPUserSolution | Met à niveau une solution en mode bac à sable activée dans une batterie.
Export-SPWeb | Exporte une collection de sites, application Web, liste ou bibliothèque.
Get-SPWeb | Renvoie tous les sous-sites qui correspondent aux critères donnés.
Import-SPWeb | Importe une collection de sites, application Web, liste ou bibliothèque.
New-SPWeb | Crée un site dans une collection de sites existante.
Remove-SPWeb | Supprime entièrement le Web spécifié.
Set-SPWeb | Configure le sous-site spécifié.
Get-SPWebApplication | Renvoie toutes les applications Web qui correspondent aux critères donnés.
New-SPWebApplication | Crée une application Web dans la batterie locale.
Remove-SPWebApplication | Supprime l'application Web spécifiée.
Set-SPWebApplication | Configure l'application Web spécifiée.
New-SPWebApplicationExtension | Crée une instance de zone pour l'application Web.
Disable-SPWebApplicationHttpThrottling | Désactive la limitation réseau pour une application Web.
Enable-SPWebApplicationHttpThrottling | Active la limitation réseau pour une application Web.
Get-SPWebApplicationHttpThrottlingMonitor | Lit tous les compteurs de limitation réseau sur une application Web.
Set-SPWebApplicationHttpThrottlingMonitor | Définit les valeurs de paquet Score d'intégrité pour un compteur de performance de limitation réseau existant pour une application Web spécifiée.
Get-SPWebPartPack | Renvoie les packages de composants WebPart qui ont été installés pour l'étendue spécifiée.
Install-SPWebPartPack | Installe le package de composants WebPart spécifié à l'emplacement spécifié.
Uninstall-SPWebPartPack | Désinstalle le package de composants WebPart spécifié.
Get-SPWebTemplate | Affiche tous les modèles de sites installés globalement qui correspondent à l'identité donnée.
Install-SPWebTemplate | Installe le modèle de site donné.
Set-SPWebTemplate | Modifie le titre et la description d'un modèle de site installé.
Uninstall-SPWebTemplate | Désinstalle le modèle de site donné.
Get-SPWorkflowConfig | Renvoie les paramètres de flux de travail pour l'application Web spécifiée.
Set-SPWorkflowConfig | Configure les paramètres de flux de travail pour l'application Web spécifiée.

Historique des modifications


Mises à jour des applets de commande Windows PowerShell (SharePoint Foundation 2010)

Cet article répertorie les applets de commande Windows PowerShell qui ont été changées (ou qui ne sont plus disponibles) depuis la version bêta de Microsoft SharePoint Foundation 2010.

Version bêta | Version finale
Get-SPIisWebServiceApplicationPool | Get-SPServiceApplicationPool
New-SPIisWebServiceApplicationPool | New-SPServiceApplicationPool
Remove-SPIisWebServiceApplicationPool | Remove-SPServiceApplicationPool
Set-SPIisWebServiceApplicationPool | Set-SPServiceApplicationPool
Get-SPSecurityTokenServiceManager | Get-SPSecurityTokenServiceConfig
Set-SPSecurityTokenServiceManager | Set-SPSecurityTokenServiceConfig
Get-SPServiceEndpoint | Get-SPServiceApplicationEndpoint
Set-SPServiceEndpoint | Set-SPServiceApplicationEndpoint
Get-SPIisWebServiceSettings | Get-SPServiceHostConfig
Set-SPIisWebServiceSettings | Set-SPServiceHostConfig
Get-SPTopologyWebServiceApplication | Get-SPTopologyServiceApplication
Set-SPTopologyWebServiceApplication | Set-SPTopologyServiceApplication
Get-SPTopologyWebServiceProxy | Get-SPTopologyServiceApplicationProxy
Set-SPTopologyWebServiceProxy | Set-SPTopologyServiceApplicationProxy
Remove-SPBusinessDataCatalogThrottleConfig | Cette applet de commande n'est plus disponible.
Get-SPSecurityTokenService | Get-SPSecurityTokenServiceConfig
Set-SPSecurityTokenService | Set-SPSecurityTokenServiceConfig
Install-SPWebTemplate | Cette applet de commande n'est plus disponible.

Historique des modifications


Stsadm to Windows PowerShell mapping (SharePoint Foundation 2010) (en anglais)

This article lists Stsadm operations and their equivalent Windows PowerShell cmdlets. Where there is no one-to-one mapping between the operations and cmdlets, the table lists the specific Windows PowerShell parameters you must use to get the same functionality.

Stsadm operation

Windows PowerShell cmdlet

Activatefeature

Enable-SPFeature

Addalternatedomain

New-SPAlternateUrl

Addcontentdb

Mount-SPContentDatabase

New-SPContentDatabase

Addpath

New-SPManagedPath

Addpermissionpolicy

None

Addsolution

Add-SPSolution

Addtemplate

Install-SPWebTemplate

Adduser

New-SPUser

Addwppack

Install-SPWebPartPack

Addzoneurl

New-SPAlternateUrl

Authentication

Set-SPWebApplication

Use the AuthenticationMethod or AuthenticationProvider parameters.

Backup

Backup-SPConfigurationDatabase

Backup-SPFarm

Backup-SPSite

Backuphistory

Get-SPBackupHistory

Binddrservice

None

Blockedfilelist

None

Canceldeployment

None

Changepermissionpolicy

None

Copyappbincontent

None

Createadminvs

New-SPCentralAdministration

Creategroup

None

Createsite

New-SPSite

Createsiteinnewdb

New-SPSite Use the ContentDatabase parameter.

New-SPContentDatabase

Createweb

New-SPWeb

Databaserepair

None

Deactivatefeature

Disable-SPFeature

Deleteadminvs

None

Deletealternatedomain

Remove-SPAlternateUrl

Deleteconfigdb

Remove-SPConfigurationDatabase

Deletecontentdb

Dismount-SPContentDatabase

Deletegroup

None

Deletepath

Remove-SPManagedPath

Deletepermissionpolicy

None

Deletesite

Remove-SPSite

Deletesolution

Remove-SPSolution

Deletetemplate

Uninstall-SPWebTemplate

Deleteuser

Remove-SPUser

Deleteweb

Remove-SPWeb

Deletewppack

Uninstall-SPWebPartPack

Deletezoneurl

Remove-SPAlternateUrl

Deploysolution

Install-SPSolution

Deploywppack

Install-SPWebPartPack

Disablessc

None

Displaysolution

Get-SPSolution

Email

None

Enablessc

None

Enumalternatedomains

Get-SPAlternateURL

Enumcontentdbs

Get-SPContentDatabase

Enumdeployments

None

Enumgroups

None

Enumroles

None

Enumservices

Get-SPServiceInstance

Enumsites

Get-SPSiteAdministration (To run this cmdlet, you must be a member of the Farm Administrators group.)

Get-SPSite (To run this cmdlet, you must be a local administrator on the computer where Produits SharePoint 2010 is installed.)

Enumsolutions

Get-SPSolution

Enumsubwebs

Get-SPWeb

Enumtemplates

Get-SPWebTemplate

Enumusers

Get-SPUser

Enumwppacks

Get-SPWebPartPack

Enumzoneurls

Get-SPAlternateURL

Execadmsvcjobs

Start-SPAdminJob

Export

Export-SPWeb

Extendvs

New-SPWebApplication

Extendvsinwebfarm

New-SPWebApplicationExtension

Forcedeletelist

None

Getadminport

Get-SPWebApplication

Use the following syntax:

  • Get-SPWebApplication -IncludeCentralAdministration | ? {$_.IsAdministrationWebApplication -eq $true}

Getproperty

Get-SPFarmConfig

Get-SPTimerJob

Disable-SPTimerJob

Enable-SPTimerJob

Set-SPTimerJob

Start-SPTimerJob

Getsitelock

Get-SPSiteAdministration

Geturlzone

Get-SPAlternateURL

Import

Import-SPWeb

Installfeature

Install-SPFeature

Listlogginglevels

Get-SPLogLevel

Localupgradestatus

None

Managepermissionpolicylevel

None

Mergecontentdbs

Move-SPSite

Migrateuser

Move-SPUser

Provisionservice

Start-SPServiceInstance

Refreshdms

None

Refreshsitedms

None

Registerwsswriter

None

Removedrservice

None

Removesolutiondeploymentlock

None

Renameserver

Rename-SPServer

Renamesite

Set-SPSite

Use the Url parameter.

Renameweb

Set-SPWeb

Use the RelativeUrl parameter.

Restore

Restore-SPFarm

Restore-SPSite

Retractsolution

Uninstall-SPSolution

Retractwppack

None

Scanforfeatures

Install-SPFeature

Use the Scanforfeatures parameter.

Setadminport

Set-SPCentralAdministration

Setapppassword

None

Setconfigdb

Connect-SPConfigurationDatabase

Setlogginglevel

Set-SPLogLevel

Setproperty

Set-SPFarmConfig

Get-SPTimerJob

Disable-SPTimerJob

Enable-SPTimerJob

Set-SPTimerJob

Start-SPTimerJob

Setsitelock

Set-SPSiteAdministration

Use the LockState parameter.

Setworkflowconfig

Set-SPWorkflowConfig

Siteowner

Set-SPSiteAdministration

Spsearch

Get-SPSearchService

Set-SPSearchService

Get-SPSearchServiceInstance

Set-SPSearchServiceInstance

Spsearchdiacriticsensitive

None

Syncsolution

Install-SPSolution

Use the Synchronize parameter.

Unextendvs

Remove-SPWebApplication

Uninstallfeature

Uninstall-SPFeature

Unregisterwsswriter

None

Updateaccountpassword

Set-SPManagedAccount

Updatealerttemplates

None

Updatefarmcredentials

None

Upgrade

None

Upgradesolution

Update-SPSolution

Upgradetargetwebapplication

None

Userrole

Get-SPUser

Move-SPUser

New-SPUser

Remove-SPUser

Set-SPUser

Historique des modifications


Microsoft Press: Using Windows PowerShell to Perform and Automate Farm Administrative Tasks (en anglais)

This book excerpt is from Microsoft SharePoint 2010 Administrator's Companion, Microsoft Press, August 2010.

Buy this book

This excerpt from Microsoft SharePoint 2010 Administrator's Companion explores the SharePoint 2010 Management Shell and how to use Windows PowerShell to accomplish some basic administrative tasks.

Authors

Bill English

Bill English, MCTS, MCT, CTT+, GSEC certified, is a Microsoft® MVP for SharePoint® Server. He runs a leading training and consulting company, has written 10+ books, and speaks at the Microsoft® Office SharePoint® Conference, Comdex, and other events.

Brian Alderman

Brian Alderman has his master's in Computer Information Systems and is currently employed by Mindsharp which is located in the Minneapolis-St. Paul area of Minnesota. Since 1995, he has held several Microsoft certifications that currently include; MCT, MCTS for SharePoint, MCITP for SQL Server®, MCSA and MCSE for Windows Server®, and also his PMP certification. As a Senior Technical Instructor and Consultant he has nearly 15 years of experience in networking, SQL Server databases, SharePoint technologies, and project management. Brian's previous publications include Windows 2000 Professional and SQL Server 2000 Administration. He is an active speaker at SharePoint Industry conferences including SharePoint Saturday's and the SharePoint Best Practices Conference.

Mark Ferraz

Mark Ferraz is the President of SolutionsMark (www.solutionsmark.com), a Houston-based consulting firm specializing in the design, development, and implementation of enterprise platforms, solutions, and services based on Microsoft SharePoint Products and Technologies. As a Senior Information Architect, Enterprise Network/Systems Architect, and Developer, Mark has over ten years of experience designing, managing, and implementing complex projects for some of the world's largest companies. In addition to being a contributing author of Microsoft Office SharePoint Server 2007 Best Practices, Mark is an active speaker at industry conferences such as SharePoint Best Practices Conference and SharePoint Technology Conference.

Book Excerpt -- Chapter 5: Using Windows PowerShell to Perform and Automate Farm Administrative Tasks

Over the last couple of years, some SharePoint administrators have recognized the power of Windows PowerShell and have tried to use it, but with no built-in support, most administrators have found it too difficult. Microsoft SharePoint Foundation 2010 and Microsoft SharePoint 2010 now contain native support for Windows PowerShell with the SharePoint 2010 Management Shell. This chapter explores the SharePoint 2010 Management Shell and how to use Windows PowerShell to accomplish some basic administrative tasks. Chapter 12, "Using Windows PowerShell to Manage Search Services and FAST Search," builds on the information in this chapter, using search administrative tasks and scenarios.

There is an enormous amount of information available about Windows PowerShell on the Internet and published in books. The aim of this chapter is not to teach you Windows PowerShell, but to show you how to become familiar with the new Windows PowerShell cmdlets, pronounced command-lets, introduced in SharePoint 2010. However, for those who are relatively new to Windows PowerShell, this chapter begins by reviewing the basics.

In this excerpt

  • Using Windows PowerShell: The Basics

  • Working with the SharePoint 2010 Management Shell

  • Examples of SharePoint Administrative Tasks

Using Windows PowerShell: The Basics

Traditionally, administrating a server on which Microsoft products are installed has involved learning a number of administrator tools, such as graphical interfaces based on the Microsoft Management Console (MMC), known as MMC snap-ins; many command-line utilities; and perhaps a Windows Management Instrumentation (WMI) provider or Component Object Model (COM) objects that administrators can interface with using VBScript. Until the release of SharePoint 2010, SharePoint Products and Technologies were no different than other Microsoft products in the number of available administrator tools. Administrators needed to rely on the Central Administration website, the SharePoint Products Configuration Wizard, and the command-line tools stsadm and psconfig. No one tool could do everything.

Each Microsoft product also had its own community, which created or extended the built-in tools to make an administrator's life easier. The tools an administrator needed were available, but they were scattered among many sources. This is all changing now that every administrative task can potentially be scripted or automated using Windows PowerShell.

The concept for Windows PowerShell is based on a study commissioned by Microsoft in the early 2000s. Originally based on the POSIX shell as specified in IEEE 1003.2 and influenced by Perl and UNIX shell, Windows PowerShell is a command shell and scripting language that is far more powerful than using the Windows command prompt (cmd.exe). Administrators love command-line tools because they can be batched together to automate repetitive tasks or to ensure that a set of tasks are completed again exactly as they were the last time they were executed. Windows PowerShell cmdlets offer administrators these same benefits. You can still use the traditional tools, but Windows PowerShell adds flexibility and breadth that the traditional tools do not provide.

Conseil :
Community-led initiatives for previous versions of SharePoint include extensions to stsadm, published at http://stsadm.codeplex.com/; Windows PowerShell scripts for Windows SharePoint Services 3.0 and Microsoft Office SharePoint Server 2007 that can be found at http://sharepointpsscripts.codeplex.com/; and the CodePlex project "PowerShell SharePoint Provider" for Windows SharePoint Services 2.0 and Microsoft SharePoint Portal Server 2003, available at http://www.codeplex.com/PSSharePoint.

This section covers the following Windows PowerShell topics.

  • What's new in the Windows PowerShell 2.0 release

  • Architecture

  • Installing Windows PowerShell

  • Remote management

What's New in Windows PowerShell 2.0

Windows PowerShell 2.0 offers a number of new features and improvements from Windows PowerShell 1.0, including

  • New cmdlets

  • Remote Management and background jobs

  • Windows PowerShell Integrated Scripting Environment (ISE)

  • Windows PowerShell debugger

  • Modules

  • Advanced functions

  • Transactions

  • Steppable pipelines

  • Events

  • Script internationalization

  • Online Help

As an IT professional, many of these new features will interest you. For example, you can remotely manage all the servers in your farm from your desktop, and when you become competent in Windows PowerShell, you will be able to create your own advanced functions using the Windows PowerShell scripting language that you can then use as cmdlets. In Windows PowerShell 1.0, the only way to do this was with a developer, using code and deploying files onto your farm.

Conseil :
For more information about what's new in Windows PowerShell 2.0, see What's New in Windows PowerShell and http://en.wikipedia.org/wiki/Windows_PowerShell. Other resources can be found by using your favorite Internet search engine and entering the keywords What's New in Windows PowerShell 2.0 or the feature names listed previously.

Windows PowerShell Architecture

Why is Windows PowerShell so important? Windows PowerShell scripting language is object orientated, built on top of the .NET Framework—.NET Framework 3.5 for Windows PowerShell 2.0—and based on the C# (pronounced C-sharp) programming language. This allows Windows PowerShell to access the underlying object models, to pass objects and their values (properties) from one Windows PowerShell command to another. This means you have almost the power of a developer without having to write, compile, and deploy code. The disadvantage is that it can be all too easy to cause havoc in your installation.

When the Microsoft product teams consider the tools they want to provide to administrators, they build them first on Windows PowerShell. Hence, with the installation of SharePoint 2010, a large number of administrative tasks can be completed natively with Windows PowerShell cmdlets, with no need to install software from community-led initiatives. If any additional cmdlets are required, you can create them using Windows PowerShell scripts and the Advanced Functions feature in Windows PowerShell 2.0, and developers within your organization can create new cmdlets. Using Windows PowerShell to help administer SharePoint is the way of the future, so it's important to start learning to use the built-in cmdlets as soon as possible.

At first, using Windows PowerShell may seem daunting, but if you have used the command prompt (cmd.exe) or have created batch files, you will soon be comfortable with the Windows PowerShell console. In fact, you can even use the Windows PowerShell console instead of the command prompt, because all the commands you currently use, such as dir, cd, and ping, work equally well in the Windows PowerShell console as they do in the command prompt. You may need to enclose command-line parameters in quotation marks to use the commands from within Windows PowerShell, but that is about the only modification you need to make. So there is no need to use two different windows to complete your administrative tasks.

Remarque :
By default, the command prompt has a black background, but this can be changed. Right-click the title bar and then select Properties. A Properties dialog box appears with four tabs: Options, Font, Layout, and Colors. You can change the font, background color, window size, and more. See the sidebar titled "Command-line Shortcuts" later in this chapter for more information about similarities between the two command-line interfaces.

There are two ways of using Windows PowerShell: either through a command-line interface, known as the Windows PowerShell console (powershell.exe), or through the Windows PowerShell Interactive Scripting Environment (ISE) graphical interface (Powershell_ise.exe). This chapter concentrates on using the Windows PowerShell console.

Conseil :
Following are some resources for more information on Windows PowerShell.

  • Windows PowerShell 2.0 Administrator's Pocket Consultant, by William R. Stanek (Microsoft Press, 2009)

  • "Scripting with Windows PowerShell" on the Microsoft TechNet Script Center at http://technet.microsoft.com/en-us/scriptcenter/dd742419.aspx.

  • An aggregation of Windows PowerShell bloggers at http://pipes.yahoo.com/powershell/englishbloggers.

  • A short introduction to Windows PowerShell in a free eBook at http://blogs.msdn.com/mapo/archive/2007/07/17/windows-powershell-free-ebook-at-microsoft.aspx.

  • Mastering PowerShell, by Dr. Tobias Weltner, a free eBook at http://blogs.msdn.com/powershell/archive/2009/07/17/free-powershell-v1-book-from-the-makers-of-powershell-plus.aspx.

Command-line Shortcuts

All the same shortcuts that you use at the command prompt work in the Windows PowerShell console.

  • To pause the display temporarily when a command is writing output, press Ctrl+S, and then press Ctrl+S to resume or press Ctrl+C to terminate execution.

  • By default, up to 50 commands are stored in a buffer. You can move through the buffer by using the up arrow and down arrow keys to scroll through the commands so you can easily execute the next or a previous command.

  • The buffered commands can be displayed from a pop-up window by pressing F7. Select the command you want to execute using the arrow keys, press Enter or F9, type the number of the command you want to execute, and then press Enter.

  • The buffered commands can be displayed from the command line by typing the first few characters of the command you want and then pressing F8. The command-line interface searches though the history buffer for the first command that begins with the characters you typed.

  • Using the auto completion capabilities of the Windows PowerShell command shell, you never need to type the complete name of a command. Type in the first few characters of the command you want and press Tab to cycle through all commands and available file names and folders in alphabetic order, or click Shift+Tab to cycle through the commands in reverse order.

  • To copy and paste text, right-click the command-line interface title, click Mark, highlight the text you want to copy, and then right-click the window title again to copy the selected text automatically into the Clipboard.

  • Commands are case insensitive and can be batched together and placed in a text file. By calling that file in the command-line window, the commands in the file are executed. These text files have an extension of .bat, .cmd, .vbs, or in the case of Windows PowerShell, .ps1. Commands in these files can be executed outside the command window by calling the file from the Run line or by double-clicking the file in Windows Explorer.

  • Arguments can be sent to the command file being called. The arguments passed to your command file are stored in memory and accessed using variables. You can also create variables to store values needed as you complete a task. In Windows PowerShell, you reference variables by preceding the variable name by a dollar sign ($).

  • Output from a command can be directed to a file named to the right of >. This will overwrite the file if it already exists. To redirect the output but append it to the file, use >>. Error messages that result from running a command can be redirected to a file named to the right of 2>, or they can be appended to a file by using 2>> or sent to the same destination as the standard output by using 2>&1.

  • You can execute many commands on the same line. In Windows PowerShell, you separate commands using the semicolon character (;).

  • Redirect the output of one command as input to another command by separating both command with a '|', known as a pipe. For example, dir | sort | more will display a sorted list of files in the current directory one page at a time. The pipe is the symbol located above the backslash on most keyboards.

  • Aliases and shortcuts can be substituted for commonly used commands. For example, the ForEach-Object cmdlet can be replaced with ForEach or even with the percentage character, %. The question mark character, ?, can be used in place of Where or Where-Object. You can also use Get-Alias to return a list of aliases. Note that the use of aliases in scripts can make them difficult to understand.

  • Examples of these shortcuts can be found throughout this book.

Installing Windows PowerShell

Computers running Windows 7 or Windows 2008 R2 or later include Windows PowerShell 2.0 and Windows Remote Management (WinRM) 2.0. If you want to manage computers using earlier operating systems locally or remotely using Windows PowerShell, you will need to install both Windows PowerShell 2.0 and WinRM 2.0.

Installing Windows PowerShell 2.0 and WinRM 2.0

A copy of Windows PowerShell 2.0, together with WinRM 2.0, can be downloaded from http://support.microsoft.com/default.aspx/kb/968929. Ensure that you obtain the correct version; for example, if you install SharePoint on the 64-bit version of Windows Server 2008, you need to download and install the Windows 2008 x64 version of Windows PowerShell 2.0 and WinRM 2.0. After they are installed, you will find the executable for the Windows PowerShell ISE in the folder %SystemRoot%\System32\WindowsPowerShell\v1.0.

Remarque :
If you going to be a heavy user of ISE, consider placing a shortcut for this program on your taskbar. On the Start menu, right-click Powershell_ise.exe and then select either Pin To Taskbar or Pin To Start Menu.

To use Windows PowerShell ISE on Windows 2008 R2, you need to add the Windows PowerShell ISE feature. This feature can be added using Windows PowerShell commands or the Server Manager. After you have installed SharePoint 2010 or SharePoint Foundation 2010, perform the following steps.

  • Using Windows PowerShell, enter the following commands.

    Import-Module Servermanager; Add-WindowsFeature "PowerShell-ISE"

  • Using Server Manager, complete the following procedure.

    1. Start the Server Manager, click Features, and then select Add Features.

    2. In the middle pane of the Add Features Wizard, select the check box for Windows PowerShell Integrated Scripting Environment (ISE) as shown in Figure 5-1 and then click Next.

Figure 5-1 Install the Windows PowerShell Integrated Scripting Environment (ISE) feature

  1. On the Confirmation Installation Selection screen, click Install.

  2. On the Installation Results screen, click Close.

Working Within Your Execution Policy

Windows PowerShell is a powerful tool, and as with any other scripting language, it is all too easy to borrow someone else's code or download snippets from the Internet. Also, because the code files are just text files, it is easy for anyone to modify them and inject malicious code. Therefore, Windows PowerShell has a built-in security feature called execution policy that you can set on a per-user basis, and these settings are saved in the registry. To view your execution policy, type the following command in the Microsoft SharePoint 2010 Management Shell.

If you are running the Management Shell on a SharePoint server, it is likely that the output from such a command is RemoteSigned, which means that you can run any commands interactively and you can use any scripts that are stored on the computer where you are logged in. However, if you want to run configuration files or scripts from remote sources, they need to be signed. You can change the execution policy if you start the Windows PowerShell console as an administrator and use the Set-ExecutionPolicy cmdlet, or you can change the registry key as follows.

HKLM\Software\Microsoft\PowerShell\1\ShellIds\Microsoft.PowerShell

Sécurité Remarque :
The registry key is useful in conjunction with an Active Directory Group Policy. Manual modifications to the registry should be avoided, especially when Microsoft provides a cmdlet to configure Windows PowerShell execution policy.

To sign scripts, use the Set-AuthenticodeSignature cmdlet, which can be used to add an Authenticode signature to a Windows PowerShell script or other file.

In an organization that has multiple environments, such as development, system integration, user acceptance test (UAT), pre-production, and production, consider the need to sign code on your production and UAT farms at minimum. You should also review the execution policy settings for these farms. You can set the execution policy in a Group Policy Object that targets either users or computers so that it cannot be overridden when someone logs on to your SharePoint servers.

Conseil :
For more information on Windows PowerShell execution policies and signing scripts, see the TechNet article "Heading Off Malicious Code" at http://technet.microsoft.com/en-us/magazine/2008.01.powershell.aspx, or type Get-Help about_Execution_Policies at a Windows PowerShell command-line interface. There is also a blog post that explains the process in detail. It is "ALLSigned: Signing Your PowerShell Scripts" and can be found at http://sharepoint.microsoft.com/blogs/zach/Lists/Posts/Post.aspx?ID=53.

Remarque :
If you are using Windows 7 as your desktop and you want to remotely manage Windows Server 2008 R2 for your SharePoint servers, you need the Remote Server Administration Tools (RSAT), which is required for the new Group Policy features and supports Windows PowerShell. RSAT is available from the Microsoft Download Center at http://www.microsoft.com/downloads. For more information, go to http://technet.microsoft.com/en-us/library/dd367853.aspx and http://trycatch.be/blogs/roggenk/archive/2009/06/08/installing-windows-7-rsat-unattended.aspx.

Managing Systems Remotely with WinRM

Windows PowerShell 2.0 introduces a new capability to manage your systems remotely from your desktop by using either WinRM or Internet Information Server (IIS). WinRM is often the mechanism used by administrators and the subject of this section. Remote Management involves not just the ability to run Windows PowerShell locally on your machine using the few commands that allow you to specify a computer name as an optional parameter; it also includes methods known as fan-in and fan-out remoting and background jobs.

  • Fan-in remoting This allows many administrators to connect to an instance of Windows PowerShell running on the same remote servers—this is not supported out of the box in SharePoint 2010.

  • Fan-out remoting This allows you to send a single Windows PowerShell command to run multiple remote instances of Windows PowerShell in parallel, and the results of those commands will be returned to your desktop. You would use this if you need to complete the same task on multiple servers. You no longer need to establish a Remote Desktop connection to each server in turn and then execute the commands locally on that server. You can create a set of Windows PowerShell commands and pass the server names to those commands, which then completes the same commands sequentially for each server whose name you provide.

  • Background jobs Windows PowerShell 2.0 supports both local and remote background jobs. These are commands that execute asynchronously in the background with no interaction. When you execute a command in the background, the command prompt is returned immediately so that you can continue to execute other commands.

Configuring for WinRM

The WinRM Windows service must be started and configured for remoting on both your local computer and the server on which you want to remotely run commands. To find out if your server is running WinRM, type

Get-service winrm

To check if it is running on a remote server, type

Get-service winrm -computername $server_name

On your SharePoint server, this service should be running; however, if your local computer is running Windows 7 (or Windows Vista with Windows PowerShell 2.0 and WinRM 2.0 installed), you may need to start this service and enable remoting. You can do this by typing one command, Enable-PSRemoting, which executes two additional commands, Set-WSManQuickConfig and Start-Service WinRM.

Important :
If one of the network connection types is Public, the Set-WSManQuickConfig command will raise an Invalid Operation Exception. You will need to change the network connections to the network type of either Domain or Private to proceed.

The output to the Enable-PSRemoting command will look similar to the following example.

Windows PowerShell Code de copie
WinRM Quick Configuration
Running command "Set-WSManQuickConfig" to enable this machine for remote management
through WinRM service.
 This includes:
    1. Starting or restarting (if already started) the WinRM service
    2. Setting the WinRM service type to auto start
    3. Creating a listener to accept requests on any IP address
    4. Enabling firewall exception for WS-Management traffic (for http only).

Do you want to continue?
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default
is "Y"): y
WinRM has been updated to receive requests.
WinRM service type changed successfully.
WinRM service started.
Configured LocalAccountTokenFilterPolicy to grant administrative rights remotely to local users.
WinRM has been updated for remote management.
Created a WinRM listener on HTTP://* to accept WS-Man requests to any IP on this machine.
WinRM firewall exception enabled.

On a computer running a 64-bit version of Windows, you may see an additional confirmation message.

Windows PowerShell Code de copie
Are you sure you want to perform this action?
Performing operation "Registering session configuration" on Target "Session
configuration "Microsoft.PowerShell32" is not found. Running command
"Register-PSSessionConfiguration Microsoft.PowerShell32 -processorarchitecture x86
-force" to create "Microsoft.PowerShell32" session configuration. This will restart
WinRM service.".
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"):

To determine how WinRM is configured, the authentication method, and the port numbers it will access, use the following command.

winrm get winrm/config/service

This should result in an output similar to the following.

Code de copie
Service
    RootSDDL = O:NSG:BAD:P(A;;GA;;;BA)S:P(AU;FA;GA;;;WD)(AU;SA;GWGX;;;WD)
    MaxConcurrentOperations = 4294967295
    MaxConcurrentOperationsPerUser = 15
    EnumerationTimeoutms = 60000
    MaxConnections = 25
    MaxPacketRetrievalTimeSeconds = 120
    AllowUnencrypted = false
    Auth
        Basic = false
        Kerberos = true
        Negotiate = true
        Certificate = false
        CredSSP = false
        CbtHardeningLevel = Relaxed
    DefaultPorts
        HTTP = 5985
        HTTPS = 5986
    IPv4Filter = *
    IPv6Filter = *
    EnableCompatibilityHttpListener = false
    EnableCompatibilityHttpsListener = false
    CertificateThumbprint

You can run winrm and winrm-related commands, such as the New-PSSession command, from either the Windows PowerShell console or the SharePoint 2010 Management Shell. However, these must be run as an administrator. To do this, right-click the Windows PowerShell console or the SharePoint 2010 Management Shell and then select Run As Administrator. You must be a member of the Administrators group on the remote machine or be able to provide administrator credentials to do this.

Remarque :
When your local computer and the remote computer are in different non-trusted domains or in a workgroup, additional steps are required to configure remoting. The workgroup scenario is likely to occur when SharePoint Foundation is installed for external collaboration or in a small business environment rather than in a typical SharePoint Server installation. For information on how to configure remoting between two workgroup machines, see the blog post at http://blogs.msdn.com/wmi/archive/2009/07/24/powershell-remoting-between-two-workgroup-machines.aspx.

Meeting Requirements for SharePoint PowerShell Remoting

To use WinRM to execute SharePoint PowerShell cmdlets on a remote machine, there are a number of additional requirements.

  1. You must have access to a userid with the correct rights to execute those commands. These requirements are applicable whether you are remoting into a server or locally executing SharePoint cmdlets. The userid must meet the following criteria.

    • Must be a member of the WSS_ADM_WGP local security group on the machine executing the commands.

    • Must be a member of the SharePoint_Shell_Access SQL Server role on the configuration database.

    • Must have access to the content database that you want to manipulate.

    You can use the SPShellAdmin cmdlets to help you manage these requirements. When you run the Add-SPShellAdmin cmdlet to add a userid to the SharePoint_Shell_Admin role, you must be mapped to Security_Admin role on the SQL instance and the db_owner role to the relevant databases. You need to run the Add-SPShellAdmin cmdlet for each content database that you want the userid to access.

  2. Designate one server in your farm as the server you will always use for remoting. On that server, increase the WinRM configuration option, MaxMemoryPerShellDB, to a large value, 512 or 1024. This configuration option limits the amount of memory a single remote process can use. Increasing the value will allow long-running commands to run without throwing OutOfMemory Exception errors. The command to display the values of the configuration options and sample output is shown here.

    winrm get winrm/config/winrs

    Code de copie
    Winrs
    AllowRemoteShellAccess = true
    IdleTimeout = 180000
    MaxConcurrentUsers = 5
    MaxShellRunTime = 2147483647
    MaxProcessesPerShell = 15
    MaxMemoryPerShellMB = 150
    MaxShellsPerUser = 5
 Winrs    AllowRemoteShellAccess = true    IdleTimeout = 180000    MaxConcurrentUsers = 5    MaxShellRunTime = 2147483647    MaxProcessesPerShell = 15    MaxMemoryPerShellMB = 150    MaxShellsPerUser = 5
    To modify the MaxMemoryPerShellDB setting, type the following Windows PowerShell command in the SharePoint 2010 Management Shell.

    Set-Item WSMan:\localhost\Shell\MaxMemoryPerShellMB 1024

  3. You must use Credential Security Provider (CredSSP) authentication. This authentication mechanism, introduced with Windows Vista, allows an application to delegate the credentials from one machine to another, a process called double hopping. This will enable you to provide the credentials that allow the SharePoint PowerShell cmdlets to talk to the Microsoft SQL Server that is hosting your SharePoint databases. If you do not use CredSSP and you try to remotely execute a SharePoint cmdlet, you are likely to receive a message that indicates the farm is unavailable. In the output from the Winrm get winrm/config/service command shown previously, notice that CredSSP is equal to False. There are several ways you can modify WinRM configuration options, including Group Policy, login scripts, and the command prompt. To enable CredSSP authentication though command-line interfaces, complete the following tasks.

    1. On the computer from which you are remoting, such as your Windows 7 desktop, type the following command, where Web1 is the SharePoint server. Type Y when prompted to confirm that you want to enable CredSSP authentication.

      Enable-WSManCredSSP -role client -DelegateComputer Web1

    2. On the SharePoint server where you are remoting to, type

      Enable-WSManCredSSP -role server

    Conseil :
    For more information on multi-hop support in WinRM, see http://msdn.microsoft.com/en-us/library/ee309365(VS.85).aspx.

Using WinRM Remoting

The commands you need to start a remote session to remotely manage a SharePoint farm or one specific SharePoint server are similar to those in the following example.

Code de copie
$cred = Get-Credential contoso\spfarm
$sess = New-PSSession Web1 -Authentication CredSSP -Credential $cred
Invoke-Command -Session $sess -ScriptBlock '
   {ADD-PSSnapin Microsoft.SharePoint.PowerShell;}
Sécurité Remarque :
You can limit the Windows PowerShell commands that a user can access during a remote session by using the -ConfigurationName parameter with the New-PSSession cmdlet or by using the Proxy cmdlet. For more information, see the blog post "Extending and/or Modifying Command with Proxies" at http://blogs.msdn.com/powershell/archive/2009/01/04/extending-and-or-modifing-commands-with-proxies.aspx.

When you enter the first command, a dialog box appears where you must type the password. This password and the user name are stored in the variable $Cred, which is used in the second command, New-PSSession, which establishes a persistent session with the remote server. Creating a persistent session is not necessary when using Windows PowerShell remoting, but if you do not establish a persistent connection, whenever you invoke a remote command that includes a SharePoint cmdlet, each Invoke-Command will also need to include the PSSnapin cmdlet. The third command, Invoke-Command PSSnapin, allows you to run SharePoint PowerShell cmdlets on the remote server.

Reference to the persistent session is stored in the variable $sess. You can direct any commands you want to that remote server by using this variable. In the following example, the cmdlet Get-SPServiceInstance is typed within the script block—the area between the curly brackets ({ }). The output from the Get-SPServiceInstance cmdlet returns the status of the services within a SharePoint farm.

Invoke-Command -Session $s -ScriptBlock {get-SPServiceInstance}

Code de copie
WARNING: column "PSComputerName" does not fit into the display and was removed.

TypeName                         Status   Id
--------                         ------   --
Business Data Connectivity       Online   3ad4d004-9ae3-4810-94bf-76cc43c9d507
Microsoft SharePoint Foundati... Online   81cc6474-fd6f-42ad-a932-25d67cff8cc1
Microsoft SharePoint Foundati... Disabled cb3b976c-b451-4abe-b808-0c6d191ccd3d
Microsoft SharePoint Foundati... Online   5bac9c93-483a-4901-ae46-f6f7ae0a12a8
Central Administration           Online   0c24457f-b58e-4daa-895e-4acd35ef7543
Microsoft SharePoint Foundati... Online   155570fa-0d4c-495d-9f31-5250e83bdd75
Microsoft SharePoint Foundati... Disabled c25ae170-c07d-48db-97b3-73b0d9b47e94
SharePoint Foundation Help Se... Online   8af8b8b1-92cb-48d2-8864-20a7e191d7c2
Important :
You can type multiple commands in a script block, either on separate lines or on the same line separated by a semicolon (;). If only one command is entered in the script block, the semicolon is optional, but it is good practice to include it. You can also use local variables to generate a remote script block as in the following example.

Code de copie
$url = "http://contoso.com"
$myscript = "get-spsite $url"
$sb = [scriptblock]::Create($myscript)
Invoke-Command $sess -ScriptBlock $sb

You can use the Windows PowerShell Invoke-Command cmdlet to communicate with many sessions, either on the same server or on different servers, from your desktop. This cmdlet enables you to start multiple administrative tasks at the same time that are then run in parallel. However, if these tasks are long running, you will not get control back until the command on the remote machine finishes. This is known as running the command interactively. To run asynchronously as a background job so that the Windows PowerShell prompt returns immediately and you can enter other commands, append the -AsJob parameter to the Invoke-Command, or alternatively, use the Start-Job cmdlet. Using this technique can reduce the amount of time to complete your administrative tasks, compared to running them sequentially. An example of how this can save you a considerable amount of time is during the upgrade process, when each session runs a database-attach-upgrade, and the time taken to complete all database upgrades is limited only by the resources of your SQL Server.

If you have many short-running tasks to complete on a specific server and don't want to keep typing Invoke-Command, use one of the following approaches.

  • You can enter an interactive session with that server by typing Enter-PSSession $sess. The command prompt will change from PS C:\Users\<userid>, where <userid> is the name of the current user, to [<remoteservername>]: PS C:\Users\<remotecredentials>\Documents, where <remotecredentials> is the userid you used for the CredSSP authentication. The command prompt reminds you that you are now submitting commands to the remote server. To return to interactive mode on your local computer, type Exit-PSSession or exit.

  • Use the Import-PSSession remoting cmdlet, also known as implicit remoting, to bring commands from the remote session into the local Windows PowerShell session. An additional advantage of the Import-PSSession approach is that you can interact with your local file system and talk to SharePoint as if you were logged on locally to the SharePoint server. By default, the Import-PSSession cmdlet imports all commands except commands that have the same name as commands in your current session. You can also import a subset of commands and prefix them with a word you specify, so that it is obvious to you which commands are local and which are remote. In the following example, the word Remote is added as a prefix to all SPSite cmdlets.

    Import-PSSession -session $sess -CommandName *-spsite -Prefix Remote

    Code de copie
    M ModuleType Name                      ExportedCommands
---------- ----                      ----------------
Script     tmp_1833f7bc-b269-4229... {Set-SPSite, Backup-SPSite, Get-SPSite,...
    In this example, you can use all SPSite cmdlets as if they were local commands; for example, by typing Get-RemoteSPSite you can return all site collections that match the given criteria. These imported commands are stored in a temporary module that is deleted at the end of the session. To create a persistent module that you can use in future sessions, use the Export-PSSession cmdlet. The imported commands still run in the remote session from which they were imported and therefore may take longer to run than local commands.

When you have completed all of your tasks, you can delete the persistent connection between your local machine and the remote machine by typing Remove-PSSession $sess.

Conseil :
For more information about Windows PowerShell remoting, see Chapter 4, "Using Sessions, Jobs, and Remoting" in the Windows PowerShell 2.0, Administrator's Pocket Consultant, by William Stanek (Microsoft Press, 2009), and the TechNet Magazine article "A Sneak Peek at Remote Management in Version 2.0" at http://technet.microsoft.com/en-us/magazine/2008.08.windowspowershell.aspx. Also take a look at the blog post "A Few Good WS-MAN (WinRM) Commands" at http://blogs.technet.com/otto/archive/2007/02/09/sample-vista-ws-man-winrm-commands.aspx.

Working with the SharePoint 2010 Management Shell

To open the SharePoint 2010 Management Shell, click Start, and then select Programs, Microsoft SharePoint 2010 Products, and finally, SharePoint 2010 Management Shell, as shown in Figure 5-2.

Figure 5-2 Accessing the SharePoint 2010 Management Shell

The SharePoint 2010 Management Shell is a custom console; it is not the same console that opens if you open the default Windows PowerShell console, a shortcut to which is usually placed on the taskbar. A review of the properties of the SharePoint 2010 Management Shell shortcut exposes the command that is executed.

Code de copie
C:\Windows\System32\WindowsPowerShell\v1.0\PowerShell.exe  -NoExit  " &
   ' C:\Program Files\Common Files\Microsoft Shared\Web Server
   Extensions\14\CONFIG\POWERSHELL\Registration\\sharepoint.ps1 ' "

The shortcut points to the file Sharepoint.ps1. This is an example of a Windows PowerShell profile, which is identical to any other Windows PowerShell script file and is used to store frequently used elements that need to be automatically loaded at the start of a Windows PowerShell session. Hence, just like normal scripting files, profiles can contain functions, aliases, and variables, and they can load any Windows PowerShell extensions, snap-ins, or modules you might need. A Windows PowerShell snap-in (PSSnapin) is a .NET program that is compiled into DLL files and contains new cmdlets, functions, and/or providers. Windows PowerShell comes with a number of snap-ins, including Microsoft.PowerShell.Core, Microsoft.PowerShell.Host, and Microsoft.PowerShell.WSMan.Management, as well as modules such as ActiveDirectory, FailoverClusters, and WebAdministration. As other products are installed on your computer, additional extensions will become available.

The main aim of the SharePoint profile file is to load the Windows PowerShell for SharePoint snap-in so you can then use the new cmdlets specific to SharePoint. The SharePoint profile file contains the following code, plus a signature.

Code de copie
$ver = $host | select version
if ($ver.Version.Major -gt 1)  {$Host.Runspace.ThreadOptions = "ReuseThread"}
Add-PsSnapin Microsoft.SharePoint.PowerShell
Set-location $home

This code obtains the version of Windows PowerShell, checks that it is greater than 1, and then if that is true, it sets the threading model so that the first thread will be reused, loads the SharePoint PowerShell snap-in, and then changes directory to the home folder, such as C:\users\<userid>, where userid is the person who is currently logged in. For more information on SharePoint, Windows PowerShell, and threading, see the sidebar titled "Memory Considerations When Using Windows PowerShell" later in this chapter.

The SharePoint PowerShell snap-in is not the only snap-in loaded into the SharePoint 2010 Management Shell. Therefore, not only can you use the SharePoint cmdlets, you also can use other cmdlets from the snap-ins that are loaded. To see all the snap-ins and the order in which they were loaded, type Get-PSSnapin. Your output should look similar to the following example.

Code de copie
Name        : Microsoft.PowerShell.Diagnostics
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains Windows Eventing and
              Performance Counter cmdlets.

Name        : Microsoft.WSMan.Management
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets (such as
              Get-WSManInstance and Set-WSManInstance) that are used by the
              Windows PowerShell host to manage WSMan operations.

Name        : Microsoft.PowerShell.Core
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets used to manage
              components of WindowsPowerShell.

Name        : Microsoft.PowerShell.Utility
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains utility Cmdlets used to
              manipulate data.

Name        : Microsoft.PowerShell.Host
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets (such as Start-
              Transcript and Stop-Transcript) that are provided for use with the
              Windows PowerShell console host.

Name        : Microsoft.PowerShell.Management
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains management cmdlets used to
              manage Windows components.

Name        : Microsoft.PowerShell.Security
PSVersion   : 2.0
Description : This Windows PowerShell snap-in contains cmdlets to manage Windows
              PowerShell security.

Name        : Microsoft.SharePoint.PowerShell
PSVersion   : 1.0
Description : Register all administration Cmdlets for Microsoft SharePoint Server.
Remarque :
If you develop your own scripts that can be called from the command prompt or by double-clicking the file in Windows Explorer, and those scripts contain Windows PowerShell for SharePoint commands, make sure that you include the command to set the threading model and load the Windows PowerShell for SharePoint snap-in in your scripts. When calling a script from within a Windows PowerShell console, you can use the #requires tag at the top of your script.

Real World Customizing Your Console

It is common practice to modify the profile file on the designated administrator machine. The profile could be altered so that it

  • Contains all the snap-ins or modules used by all IT professionals in an organization or department.

  • Tracks all Windows PowerShell commands executed.

  • Changes the prompt to indicate the server name. In an organization with a multitude of servers, it is all too easy to start an administrative task on the wrong server, so anything that can help an administrator identify the server he is working on will be helpful, such as configuring the window title to list the name of the server.

An example of a custom profile could contain the following code.

Code de copie
<# ***********************************************************
 Copyright (c)2010, Contoso, All Rights Reserved
 *************************************************************
Contoso PowerShell Profile - ContosoProfile.ps1
Author: Peter Connelly
Purpose: This profile sets the PowerShell window size, font and title
and loads the SharePoint snap-in
History: Version 1.0 01/02/2010 First version
#>
# Track all Windows PowerShell commands
$profilename = $MyInvocation.MyCommand.Name
$profilepath = $MyInvocation.MyCommand.Path
$transcriptFile = "C:\Contoso\Logs\Powershell_$profilename.log"
Start-Transcript $transcriptFile -append -force
Write-Output "Starting profile: $profilepath"

# Command from SharePoint Server 2010 profile file - SharePoint.ps1
$ver = $host | select version
if ($ver.Version.Major -gt 1)  {$Host.Runspace.ThreadOptions = "ReuseThread"}
Add-PsSnapin Microsoft.SharePoint.PowerShell
Set-location $home

# Check that this is a command-line interface and not the ISE
if ($host.name -eq "ConsoleHost")
{
  $width = 80
  $sizeWindow = new-object System.Management.Automation.Host.Size $width,40
  $sizeBuffer = new-object System.Management.Automation.Host.Size $width,9999
  <# Check to adhere to the following rules:
  The buffer width can't be resized to be narrower than the window's current
  width plus the window's width can't be resized to be wider than the
  buffer's current width. #>
  $S = $Host.UI.RawUI
  if ($s.WindowSize.width -gt $width)
  {
        $s.WindowSize = $sizeWindow
        $s.BufferSize = $sizeBuffer
  } else {
        $s.BufferSize = $sizeBuffer
        $s.WindowSize = $sizeWindow
  }
}
# Set foreground, background color and window title
$s.ForegroundColor = "Yellow";$s.BackgroundColor = "DarkBlue";
$s.WindowTitle = "$env:computername"
# #############################################################
# End of ContosoProfile.ps1
# #############################################################

Because the profile script is automatically executed every time you run the SharePoint 2010 Management Shell, it should be signed. More information about customizing your console can be found at http://technet.microsoft.com/en-us/library/ee156814.aspx.

Understanding cmdlets

Window PowerShell cmdlets are utilities that are built on top of application interfaces, and in the case of SharePoint 2010, the SharePoint Object Module, and SharePoint Web Services, that allow administrators to complete a number of tasks.

In general, cmdlets use a verb-noun pair. The noun specifies the object you want information about or that you want to manipulate, and the verb states what you want to do with that object. The verbs and nouns are always separated by a hyphen with no spaces, and SharePoint cmdlet verbs have a prefix of SP. For example, if you want to get (the verb) information about all the content databases (noun) in your farm, you would use the following SharePoint cmdlet, which would give you the output shown.

PS C:\Users\Peter> Get-SPContentDatabase

Code de copie
Id               : a1d5c96c-a41a-43b3-bc5d-3f8a93b26046
Name             : WSS_Content_a2fde53006e04bf5aae434ffd3c8a19c
WebApplication   : SPWebApplication Name=SharePoint - 80
Server           : SQL
CurrentSiteCount : 1

Id               : 363b11a3-6947-42f6-9df4-665eeff59c83
Name             : SPF_TeamsDB
WebApplication   : SPWebApplication Name=SPF_Teams
Server           : SQL
CurrentSiteCount : 1

Windows PowerShell also provides a few cmdlets that help you to work with the other cmdlets. Two examples of these are Get-Command, which can be shorted to gcm, and Get-Help, which can be shorted to help. (Shortened names of cmdlets are called aliases.) Get-Command allows you to find cmdlets, and then Get-Help can provide you with basic information about a cmdlet after it is retrieved. (You'll see how to use the Get-Help cmdlet in the section titled "Getting Help" later in this chapter.) In the following example, the Get-Command finds all the cmdlets associated with SharePoint.

Code de copie
PS C:\Users\Peter>Get-Command -PSSnapin "Microsoft.SharePoint.PowerShell" |
>>sort noun, verb |Format-Wide -Column 3
>><ENTER>
Remarque :
When you type a one-line Windows PowerShell script, or you have not provided all the required parameters, Windows PowerShell either prompts you for the parameter or starts a new line with >> so that you can enter more commands. When you have finished typing, press Enter for Windows PowerShell to execute the code. Because of page size restrictions, many of the commands in this chapter are shown on multiple lines when they could be typed on one line, so always remember to press Enter only to execute the scripts.

The set of commands shown previously takes the output from the Get-Command cmdlet and pipes it to the sort cmdlet. The sort cmdlet sorts the data in noun-then-verb order so that all SharePoint cmdlets that manipulate the same object are listed together. The cmdlets that manipulate the same object are then sorted in verb order. To reduce the amount of scrolling necessary in the SharePoint 2010 Management Shell, the sorted data is piped to the format-wide cmdlet. Such a combination of Windows PowerShell cmdlets is quite common. The output from the command set would look similar to the following sample.

Code de copie
Start-SPAdminJob           Get-SPAlternateURL         New-SPAlternateURL
Remove-SPAlternateURL      Set-SPAlternateURL         Install-SPApplicationC...
Start-SPAssignment         Stop-SPAssignment          Get-SPAuthenticationPr...
New-SPAuthenticationPro... Get-SPBackupHistory        Move-SPBlobStorageLoca...
Get-SPBrowserCustomerEx... Set-SPBrowserCustomerEx... Copy-SPBusinessDataCat...
…..(not all output shown)
Set-SPWebApplicationHtt... Get-SPWebPartPack          Install-SPWebPartPack
Uninstall-SPWebPartPack    Get-SPWebTemplate          Install-SPWebTemplate
Set-SPWebTemplate          Uninstall-SPWebTemplate    Get-SPWorkflowConfig
Set-SPWorkflowConfig
Remarque :
There is another cmdlet similar to the Get-Command that helps you work with cmdlets and that you might find useful—especially if you create your own commands or scripts. It is the Measure-Command cmdlet. This command allows you to measure the time it takes to run cmdlets or scripts. You may also find the Trace-Command cmdlet useful for debugging short script blocks.

Working with Objects

There are a considerable number of objects available in SharePoint, and as you might expect, there are more available in SharePoint Server than in SharePoint Foundation. By reading this book, you might have determined the relationship between these objects. For example, while a SharePoint farm can contain many Web applications, each SharePoint farm has one configuration database. Many of the SharePoint cmdlets use names that you can easily identify to determine which objects they will manipulate. To illustrate, the SPFarm cmdlets allow you to retrieve information about and back up or restore a SharePoint farm. For example, the SPFarmConfig cmdlet lets you retrieve and set properties for the farm.

However, there are a few cmdlet names that could confuse you. For example, the SPSite cmdlet allows you to manipulate site collections, and Chapter 2, "Understanding the Architecture of SharePoint 2010," explains that you can't create a site collection unless you have a Web application, which means using the SPWebApplication object. When a site collection is created, you choose a site template to create a site. In the SharePoint Object Model, this site is known as a web and not a site; hence, the object is named SPWeb. This can be quite confusing because the term "website" is often shortened to "site," and in the SharePoint Object Model, "site collection" is also shortened to "site." Because this terminology has been used through many versions of SharePoint and is used consistently by developers, it is easier for IT professionals to adopt this usage.

  • A web is a website and can be manipulated using the SPWeb object.

  • A site collection contains a collection of webs and can be manipulated using the SPSite object.

Figure 5-3 displays the most common objects and their relationships, but there are others, such as SPSiteCollection, which is a collection of SPSites.

The current selection of built-in cmdlets does not provide full coverage of all SharePoint objects, but you can write new cmdlets to manipulate these objects. To determine the objects associated with the SharePoint PowerShell cmdlets and the number of cmdlets per each object, use the commands in the following example, where a portion of the output is shown.

Code de copie
PS C:\Users\peter> Get-Command -PSSnapin "Microsoft.SharePoint.PowerShell" |
>>sort noun, verb | group-object -property noun
>><ENTER>
Code de copie
Count Name                      Group
----- ----                      -----
    1 SPAdminJob                {Start-SPAdminJob}
    4 SPAlternateURL            {Get-SPAlternateURL, New-SPAlternateURL, Rem...
    1 SPApplicationContent      {Install-SPApplicationContent}
    2 SPAssignment              {Start-SPAssignment, Stop-SPAssignment}
...(not all output shown)
    6 SPWeb                     {Export-SPWeb, Get-SPWeb, Import-SPWeb, New-...
    4 SPWebApplication          {Get-SPWebApplication, New-SPWebApplication,...
    1 SPWebApplicationExtension {New-SPWebApplicationExtension}
    2 SPWebApplicationHttpTh... {Disable-SPWebApplicationHttpThrottling, Ena...
    2 SPWebApplicationHttpTh... {Get-SPWebApplicationHttpThrottlingMonitor, ...
    3 SPWebPartPack             {Get-SPWebPartPack, Install-SPWebPartPack, U...
    4 SPWebTemplate             {Get-SPWebTemplate, Install-SPWebTemplate, S...
    2 SPWorkflowConfig          {Get-SPWorkflowConfig, Set-SPWorkflowConfig}

Fig 5-3 Common SharePoint objects and their relationships

Understanding Properties and Methods

Everything that SharePoint knows about an object is stored in data elements and values known as properties, which also describe the state of that object. For example, the SPContentDatabase object contains all the information about the content databases within the farm.

Objects not only have properties, they also contain actions that determine how they can be manipulated. In object-oriented terminology, these actions, or different ways of acting on an object, are called methods. To determine the properties and methods for the SPSite object, use the cmdlets in the following example, where a portion of the output is shown.

PS C:\Users\peter> Get-SPSite | Get-Member

Code de copie
   TypeName: Microsoft.SharePoint.SPSite

Name                                  MemberType Definition
----                                  ---------- ----------
AddWorkItem                           Method     System.Guid AddWorkItem(Sys...
BypassUseRemoteApis                   Method     System.Void BypassUseRemote...
CheckForPermissions                   Method     System.Void CheckForPermiss...
Close                                 Method     System.Void Close()
ConfirmUsage                          Method     bool ConfirmUsage()
Delete                                Method     System.Void Delete(), Syste...
Dispose                               Method     System.Void Dispose()
…
ToString                              Method     string ToString()
UpdateValidationKey                   Method     System.Void UpdateValidatio...
VisualUpgradeWebs                     Method     System.Void VisualUpgradeWe...
AdministrationSiteType                Property   Microsoft.SharePoint.SPAdmi...
AllowDesigner                         Property   System.Boolean AllowDesigne...
AllowMasterPageEditing                Property   System.Boolean AllowMasterP...
….(not all output shown)
WarningNotificationSent               Property   System.Boolean WarningNotif...
WebApplication                        Property   Microsoft.SharePoint.Admini...
WorkflowManager                       Property   Microsoft.SharePoint.Workfl...
WriteLocked                           Property   System.Boolean WriteLocked ...
Zone                                  Property   Microsoft.SharePoint.Admini...
Important :
Never miss an opportunity to pipe the Get-SP<noun> cmdlet to the Get-Member cmdlet. It is sometimes surprising what information an object is able to retrieve.

Real World: Performance Issues When Running Windows PowerShell Commands

If you want to find all the site collections in the farm, you can type Get-SPSite. However, the only output you will see is the URL of the site collections. For performance reasons, the Url property is the only property displayed by default. This is because site collections have many properties; if you display all of these properties for a large number of site collections, you will consume a large amount of memory, and the command will take a long time to run. Displaying just the Url property is almost instantaneous because it is cached. Therefore, you should refrain from running this command to display more than a few additional properties.

To display more than the default property, you can use the select Windows PowerShell cmdlet with the pipe (|) character. You also can use the wildcard character (*) with the select statement to list all the property values, as shown in the following example.

PS C:\Users\Peter> Get-SPSite "http://teams" | select *

Code de copie
ApplicationRightsMask                 : FullMask
ID                                    : cbf3290e-000e-4768-953c-99a983430283
SystemAccount                         : SHAREPOINT\system
Owner                                 : CONTOSO\spadmin
SecondaryContact                      : CONTOSO\peter
GlobalPermMask                        : FullMask
IISAllowsAnonymous                    : False
Protocol                              : http:
HostHeaderIsSiteName                  : False
HostName                              : teams
Port                                  : 80
...(not all output shown)
AllowDesigner                         : True
AllowRevertFromTemplate               : False
AllowMasterPageEditing                : False
ShowURLStructure                      : False

To get a list of all site collections in your farm, together with the name of the content database where they are stored (output that gives only the URL of the site collection and the content database name), you would use the commands as shown in the following example, which also shows the sample output.

PS C:\Users\peter> Get-SPSite | select url, contentdatabase

Code de copie
Url                                     ContentDatabase
---                                     ---------------
http://MySite                           SPContentDatabase Name=Contoso_MySiteDB
http://MySite/personal/peter            SPContentDatabase Name=Contoso_PersonalDB
http://MySite/personal/erin             SPContentDatabase Name=Contoso_PersonalDB
http://intranet.contoso.msft            SPContentDatabase Name=Contoso_IntranetDB
http://teams                            SPContentDatabase Name=Contoso_TeamsDB
http://teams/sites/Finance              SPContentDatabase Name=Contoso_TeamsDB

Using Verbs

SharePoint uses common verbs that you have seen with other sets of cmdlets; there are also a number of new verbs added in SharePoint that you may not have seen. Again, you can find these by using the Get-Command cmdlet, as shown here.

Code de copie
PS C:\Users\Peter>Get-Command -PSSnapin "Microsoft.SharePoint.PowerShell" |
>>sort verb | group verb | sort count -descending
>><ENTER>
Code de copie
Count Name                      Group
----- ----                      -----
  139 Get                       {Get-PluggableSecurityTrimmer, Get-SPAccessS...
  104 Set                       {Set-SPAccessServiceApplication, Set-SPAlter...
   88 New                       {New-SPAccessServiceApplication, New-SPAlter...
   77 Remove                    {Remove-PluggableSecurityTrimmer, Remove-SPA...
   11 Update                    {Update-SPFarmEncryptionKey, Update-SPInfoPa...
   10 Add                       {Add-PluggableSecurityTrimmer, Add-SPClaimTy...
   10 Install                   {Install-SPApplicationContent, Install-SPDat...
    8 Start                     {Start-SPAdminJob, Start-SPAssignment, Start...
    8 Import                    {Import-SPBusinessDataCatalogModel, Import-S...
    8 Export                    {Export-SPBusinessDataCatalogModel, Export-S...
    8 Uninstall                 {Uninstall-SPDataConnectionFile, Uninstall-S...
    7 Disable                   {Disable-SPBusinessDataCatalogEntity, Disabl...
    6 Enable                    {Enable-SPBusinessDataCatalogEntity, Enable-...
    6 Clear                     {Clear-SPLogLevel, Clear-SPMetadataWebServic...
    5 Stop                      {Stop-SPAssignment, Stop-SPEnterpriseSearchQ...
    4 Move                      {Move-SPBlobStorageLocation, Move-SPProfileM...
    3 Initialize                {Initialize-SPContentDatabase, Initialize-SP...
    3 Upgrade                   {Upgrade-SPContentDatabase, Upgrade-SPEnterp...
    3 Backup                    {Backup-SPConfigurationDatabase, Backup-SPFa...
    3 Restore                   {Restore-SPEnterpriseSearchServiceApplicatio...
    2 Resume                    {Resume-SPEnterpriseSearchServiceApplication...
    2 Test                      {Test-SPContentDatabase, Test-SPInfoPathForm...
    2 Suspend                   {Suspend-SPEnterpriseSearchServiceApplicatio...
    2 Revoke                    {Revoke-SPBusinessDataCatalogMetadataObject,...
    2 Mount                     {Mount-SPContentDatabase, Mount-SPStateServi...
    2 Grant                     {Grant-SPBusinessDataCatalogMetadataObject, ...
    2 Dismount                  {Dismount-SPContentDatabase, Dismount-SPStat...
    1 Merge                     {Merge-SPLogFile}
    1 Receive                   {Receive-SPSharedServiceApplicationInfo}
    1 Disconnect                {Disconnect-SPConfigurationDatabase}
    1 Unpublish                 {Unpublish-SPServiceApplication}
    1 Connect                   {Connect-SPConfigurationDatabase}
    1 Rename                    {Rename-SPServer}
    1 Restart                   {Restart-SPEnterpriseSearchQueryComponent}
    1 Copy                      {Copy-SPBusinessDataCatalogAclToChildren}
    1 Ping                      {Ping-SPEnterpriseSearchContentService}
    1 Publish                   {Publish-SPServiceApplication}

As you can see, the most common SharePoint-related verbs are

  • Get Queries a specific object or a collection of object and retrieves information concerning that object. For example, you could use it to retrieve information on all service applications. Only Get commands return one or more objects; all other commands execute on one object at a time.

    Get-SPServiceApplication

  • Set Modifies specific settings of an object. For example, you could use it to set the site collection owner for a specific site collection.

    Set-SPSite http://teams -OwnerAlias contoso\peter

  • New Creates a new instance of an object, such as creating a new site collection.

    Code de copie
    New-SPSite http://teams/sites/HR -OwnerAlias contoso\peter
-Name "HR Team" -Template STS#0
  • Remove Removes (deletes) an instance of the object, such as a site collection and all its subsites. Because of the dangerous nature of this verb, you usually have to confirm this action by using the -confirm parameter. If this parameter is not present, you will see a message asking you to confirm the action, as shown here.

    Code de copie
    PS C:\Users\Peter> Remove-SPSite http://teams/sites/HR
Confirm
Are you sure you want to perform this action?
Performing operation "Remove-SPSite" on Target "http://teams/sites/Finance".
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help
(default is "Y"):y

Parameters are used throughout the examples shown here. These are the words prefixed with a hyphen (-). In the next section, you will look at the Get-Help cmdlet and learn how it can help you find out more about these parameters, including which parameters are available for use with different cmdlets.

Getting Help

Windows PowerShell contains an extensive built-in help system, and you can access it quickly by typing help at the command-line interface. This is an alias for the cmdlet Get-Help. You can even get help about Get-Help by typing Get-Help Get-Help. The output from such a command lists a description of the cmdlet, the syntax used by the cmdlet, parameter descriptions, examples, and other related notes. You also can use the Get-Help cmdlet to get help with the basic Windows PowerShell language. For example, you can use the following commands to get help about specific topics: Get-Help foreach, or Get-Help substring, or Get-Help variables.

Remarque :
The best way to learn Windows PowerShell is to use its built-in help system. If you or your developers create new Windows PowerShell cmdlets, make sure you create your own help files. In addition to the built-in help, there are many resources on the Internet. For example, you can download a free Windows PowerShell Help 2.0 for either 32-bit or 64-bit from http://www.primaltools.com/downloads/communitytools/.

Help Files

Get-Help finds the information to display by using Extensible Markup Language (XML) files that are installed on the server. When you installed SharePoint, help files were installed along with the Windows PowerShell snap-in. These files can be found in %CommonProgramFiles%\Microsoft Shared\Web Server Extensions\14\CONFIG\PowerShell\Help or %CommonProgramFiles%\Microsoft Shared\Web Server Extensions\14\CONFIG\PowerShell\Help\<locale>, where locale defines the language of the computer, such as en-us. These files use the naming convention <dll filename>-help.xml, such as Microsoft.SharePoint.PowerShell.dll-help.xml, Microsoft.SharePont.Search.dll-help.xml, and Microsoft.Office.Access.Server.dll-help.xml. You can find which cmdlets use which XML help file by typing

Code de copie
PS C:\Users\Peter>Get-Command -PSSnapin "Microsoft.SharePoint.PowerShell" |
>>sort helpfile, name |
>>Format-Wide name -column 2 -groupby helpfile | more
>><ENTER>

Code de copie
   :

Get-SPExcelBlockedFileType        Get-SPExcelDataProvider
Remove-SPExcelDataProvider        Remove-SPExcelUserDefinedFunction
Set-SPExcelFileLocation

   HelpFile: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions
\14\CONFIG\PowerShell\Help\microsoft.office.access.server.dll-help.xml

Get-SPAccessServiceApplication    New-SPAccessServiceApplication
Set-SPAccessServiceApplication

   HelpFile: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions
\14\CONFIG\PowerShell\Help\Microsoft.Office.Excel.Server.MossHost.dll-help.xml

Get-SPExcelDataConnectionLibrary   Get-SPExcelFileLocation
Get-SPExcelServiceApplication      Get-SPExcelUserDefinedFunction
New-SPExcelBlockedFileType         New-SPExcelDataConnectionLibrary
New-SPExcelDataProvider            New-SPExcelFileLocation
New-SPExcelServiceApplication      New-SPExcelUserDefinedFunction
Remove-SPExcelBlockedFileType      Remove-SPExcelDataConnectionL...
Remove-SPExcelFileLocation         Set-SPExcelDataConnectionLibrary
Set-SPExcelDataProvider            Set-SPExcelServiceApplication
-- More -
Conseil :
You can find more information about the format of the cmdlet XML help files and how to make your own help files to complement new cmdlets you create at http://blogs.msdn.com/powershell/archive/2006/09/14/Draft-Creating-Cmdlet-Help.aspx and http://blogs.msdn.com/powershell/archive/2008/12/24/powershell-v2-external-maml-help.aspx.

ISE Help

In addition to the command-line help function, there is a graphical help file (WindowsPowerShellHelp.chm) located at %SystemRoot%\Help\mui\<LCID> where LCID is the locale identifier or language of your installation, such as 0409. You can access the graphical help file when using the ISE by selecting the command you want help for and then pressing F1. The chm file opens, and help is displayed for the command, as shown in Figure 5-4.

However, the chm file contains help only for the core Windows PowerShell cmdlets. If you need SharePoint-specific help, you should use the SharePoint 2010 Management Shell and the Get-Help cmdlet.

Conseil :
For more information on the Help feature in Windows PowerShell and how you can configure it to show help for aliases or how to disable local help and force ISE to get help directly from TechNet, see http://blogs.microsoft.co.il/blogs/scriptfanatic/archive/2009/01/31/using-help-in-powershell-ise.aspx. Microsoft recommends that you always check the online help to find the latest information and examples. The link to the online version can be found in the Related Links section when you use the Get-Help command.

Figure 5-4 Windows PowerShell graphical help

Using Parameters

To find which parameters you can use with a cmdlet, type either Get-Help <cmdlet> or Get-Command <cmdlet> -syntax, where <cmdlet> is the name of the cmdlet you want parameter information about. For example, Get-Help New-SPSite or Get-Command New-SPSite -syntax will provide you with information about the parameters associated with New-SPSite. The Get-Help cmdlet also has several parameters associated with it, and depending on the amount of information you want, you can use them with the Get-Help command. If you know a cmdlet very well and do not want a descriptive explanation of what the cmdlet does, then you may simply want to see some examples of how to use the cmdlet, in which case you would type Get-Help New-SPSite -examples.

To learn about which parameters to use with a cmdlet, review the syntax section of the help results, as shown in the following output. Optional parameters are enclosed within square brackets ([ ]) and the values to be passed to the parameters are enclosed within angled brackets (<>). The following example shows the syntax section of the Get-SPSite cmdlet.

Code de copie
SYNTAX
    Get-SPSite [-AssignmentCollection <SPAssignmentCollection>]
    [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>] [-Limit <String>]
    [-WebApplication <SPWebApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]
    [<CommonParameters>]

    Get-SPSite -Identity <SPSitePipeBind> [-AssignmentCollection
    <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>]
    [-Limit <String>] [-Regex <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
    [<CommonParameters>]

    Get-SPSite -ContentDatabase <SPContentDatabasePipeBind> [-AssignmentCollection
    <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>]
    [-Limit <String>] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

    Get-SPSite -SiteSubscription <SPSiteSubscriptionPipeBind> [-AssignmentCollection
    <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Filter <ScriptBlock>]
    [-Limit <String>] [-WhatIf [<SwitchParameter>]] [<CommonParameters>]

Notice that there are four ways to use Get-SPSite, and each syntax has an -AssignmentCollection parameter. The -AssignmentCollection parameter relates to an important aspect of the built-in SharePoint cmdlet, which is examined in more detail in the sidebar titled "Memory Considerations When Using Windows PowerShell," which appears later in this chapter.

The first syntax example shown in the listing above has no mandatory parameter, so the Get-SPSite cmdlet would have a scope of the farm or Web application. The other three syntaxes have a mandatory parameter that defines the scope as site collection, content database, or collection of site collections that subscribe to shared settings, features, and services, as shown in the following code. As is the case with the other SPSite cmdlets, in a large installation, this cmdlet could output a large amount of information, and the queries to many content databases could severely affect the performance of the SharePoint servers. Therefore, by default, the output reports only on the first 20 objects.

You can alter this output limit by using the -limit parameter, as shown in the following example, which outputs all site collections that are stored in the Contoso_TeamsDB content database.

Get-SPSite -ContentDatabase Contoso_TeamsDB -limit all

You can provide the values for these scope parameters, or in the case of the -identity parameter, where the value is a URL, you can use the wildcard character (*). The default help with no parameter provides a limited description of the command.

For more information, use the -detailed or the -full parameter. The -full parameter provides additional information about the parameters. For example, additional information about the -identity parameter is shown on the following page.

Code de copie
PARAMETERS
    -Identity <SPSitePipeBind>
        Specifies the URL or GUID of the site collection to get.

        The type must be a valid URL, in the form http://server_name or http://
        server_name/sites/sitename, or a valid GUID (for example, 12345678-90ab
        -cdef-1234-567890bcdefgh).

        Required?                    true
        Position?                    1
        Default value
        Accept pipeline input?       True
        Accept wildcard characters?  false

If you look at the last five lines of the output, you see that it provides more information on how to use the -identity parameter. For example, the required value is equal to True, which indicates that the -identity parameter is a mandatory parameter for the Get-SPSite cmdlet. However, the position value is equal to 1, which means that if you place a URL of a site collection immediate after the Get-SPSite cmdlet, you do not have to use the -identity parameter because the URL will be read as the identity (URL) of a site collection, where all the property values for site collections that exist under the personal managed path are displayed, as shown in the following example.

Get-SPSite http://MySite/personal/* | Select *

Many of the parameters have a value enclosed in angle brackets, with the suffix PipeBind. This indicates that the parameter can accept an object variable of a specific type. For example, [-ContentDatabase <SPContentDatabasePipeBind>] means that the -ContentDatabase parameter can accept a SharePoint content database object, and this object can be passed to the ContentDatabase object either as a variable, or it can be piped in from the results of another cmdlet. When you pipe an object into a cmdlet, you do not need to type or use a variable. When you pipe an object from one cmdlet into another cmdlet, you do not have to specify the parameter, because Windows PowerShell checks the type of object and will match it to the correct parameter. The following example lists all site collections that are stored in any content databases that have the characters oso anywhere in their names.

Get-SPContentDatabase | where {$_.name -match "oso"} | Get-SPSite -Limit 50

Get-SPContentDatabase returns a collection of content databases, and then you need to check each content database to see if it matches our condition. The Where-object cmdlet, which has the aliases where or ?, acts like a loop, so it will check each content database object returned from the Get-SPContentDatabase cmdlet. The variable $_ represents one content database object, and .name is the content database property that needs to be matched for our query. The operator is -match.

Windows PowerShell has a number of operators, such as -eq (equal to), -ne (not equal to), -lt (less than), -ge (greater than or equal to), -like (matches a wildcard pattern), and -notlike (does not match a wildcard pattern). The -like, -notlike, -match, and -notmatch operators are used for pattern matching. The -match and -notmatch operators use regular expressions to determine whether a value does or does not contain a match for an expression.

Conseil :
For more information on Windows PowerShell operators, see the section titled "Working with Expressions and Operators" in Chapter 5, "Navigating Core Windows PowerShell Structures," in Windows PowerShell 2.0, Administrator's Pocket Consultant, by William Stanek (Microsoft Press, 2009).

An alternative method to use instead of a WHERE statement is the -filter parameter, which uses the same syntax as the WHERE statement and can produce the same results. However, the -filter parameter executes on the server. Piping the results of the Get-SPContentDatabase cmdlet to the WHERE statement causes a SQL round trip to wherever the Windows PowerShell client is running. Using the -filter parameter can result in a faster performance, allowing the command to leverage the filtering abilities of SQL instead of attempting a local search. However, when you use the -filter parameter, only the Owner, SecondaryOwner, and LockState properties can be accessed for SPSite cmdlets. A number of cmdlets have other parameters that allow you to filter the resulting output. For example, SPWeb provides parameters to filter output on the template or title of the site (web). Still, in many cases the -filter parameter can save you time—for example, finding all the blog sites in a farm of 4300 webs takes about 1.2 seconds with the -filter parameter, but it takes approximately 15 minutes if you use a WHERE statement. Following are several examples that use the -filter parameter.

  • This example returns all site collections whose primary owner has the username peter.

    Get-SPSite -Filter {$_.Owner -eq "contoso\peter"}

  • This example returns all websites in the http://teams/sites/HR site collection that were created using the Blank Meeting Workspace template.

    Get-SPSite http://teams/sites/HR | Get-SPWeb -Filter {$_.Template -eq "STS#03"}

Remarque :
When you create a new site collection, if you do not specify a template or the template cannot be found, then you will need to create a website as the root of the site collection. You can do this by using the New-SPWeb command or by selecting the appropriate site template when you display the site collection for the first time in the browser.

To find details of the templates installed, together with the appropriate template ids, use the Get-SPWebTemplate cmdlet. A sample of the output of this command is shown here.

Code de copie
Name                 Title                                    LocaleId   Custom
----                 -----                                    --------   ------
GLOBAL#0             Global template                          1033       False
STS#0                Team Site                                1033       False
STS#1                Blank Site                               1033       False
STS#2                Document Workspace                       1033       False
MPS#0                Basic Meeting Workspace                  1033       False
MPS#1                Blank Meeting Workspace                  1033       False
MPS#2                Decision Meeting Workspace               1033       False
MPS#3                Social Meeting Workspace                 1033       False
MPS#4                Multipage Meeting Workspace              1033       False
CENTRALADMIN#0       Central Admin Site                       1033       False
WIKI#0               Wiki Site                                1033       False
BLOG#0               Blog                                     1033       False
SGS#0                Group Work Site                          1033       False
TENANTADMIN#0        Tenant Admin Site                        1033       False
ACCSRV#0             Access Services Site                     1033       False
ACCSRV#1             Assets Web Database                      1033       False
ACCSRV#3             Charitable Contributions Web Database    1033       False

On the Get-SPSite and Get-SPSiteAdministration, provide two other filters that use the SQL-driven filtering: the "Wildcard URLs" and regular expression (-RegEx) parameter, for example:

  • Get-SPSite http://intranet/sites/*

  • Get-SPSite "http://intranet/(sites|teams)/HR" -RegEx

Memory Considerations When Using Windows PowerShell

The default behavior of Windows PowerShell is that it runs a multithread environment and that each line, function, or script runs in its own thread ($host.Runspace.ThreadOptions == "Default"). This can cause memory leaks, but as you saw in the section titled "Working with the SharePoint 2010 Management Shell" earlier in this chapter, the SharePoint 2010 Management Shell runs each line, function, or script in the first thread ($host.Runspace.ThreadOptions ="ReuseThread"), which mitigates the problem—but memory leaks can still occur. Hence, the two SharePoint cmdlets that you should learn to use are the Start-SPAssignment and the Stop-SPAssignment. These relate to the -SPAssignmentCollection parameter that you may see used with a number of SharePoint cmdlets to return a "disposable object." In developer-speak, these are objects that implement the IDisposable Interface. If these objects are not disposed of correctly, they can cause memory leaks. In particular, this relates to the SPSite, SPWeb, and SPSiteAdministration objects. If you use cmdlets associated with these objects in one pipe and don't use variables to store the objects, the memory used is automatically disposed of at the end of a pipe. If you have a long pipe that obtains many objects, this can cause a shortage of memory on your SharePoint server, which then can have a noticeable effect on requests for pages from that server.

When you store any of the three objects in a variable, you then have to dispose of the memory assigned to that object. The following examples show the main methods of using these objects with variables and how to dispose of the memory.

  • Use the simple method of using the SPAssignment cmdlets, in which all objects are kept in a global memory store that is released when the Stop-SPAssignment cmdlet is called.

    Code de copie
    Start-SPAssignment -Global
$sc = Get-SPSite http://intranet
$sc.Title
Stop-SPAssignment -Global
  • Use the advanced method of using the SPAssignment cmdlet and tell it to track memory assigned to a specific variable. In the following example, the Start-SPAssignment cmdlet creates a named store that is pointed to by $o, and the variable $sc is associated with that named store and populated with information about the Internet site collection object. The Stop-SPAssignment cmdlet then releases the memory associated with the named store.

    Code de copie
    $o = Start-SPAssignment
$sc = $o | Get-SPSite http://intranet
Get-SPSite -Limit all
$sc.Title
$o | Stop-SPAssignment
  • If you are used to developing on the SharePoint platform, then you can use a similar technique to that which you use in your code to overcome this issue. For example, use variables within one Windows PowerShell line and dispose of them at the end of that line.

    Code de copie
    $sc = New-SPSite("http://Intranet"); $sc.Title; $sc.Dispose()
    This stores the site collection object in the variable $sc. The next command then prints out the title of the intranet site collection, and the last command releases the memory that stored the site collection object.

    Remarque :
    This same command can be run safely using the following syntax.

    New-SPSite(http://intranet) | Select Title

Be aware that the simple method of calling SPAssignment shown here also can cause memory problems. Any object you obtain between the Stop and Stop SPAssignment commands will be retained in the global assignment store and will not be released until the Stop-SPAssignment cmdlet is executed, whereas when you use the advanced method of calling SPAssignment, only the memory associated with variables you ask SPAssignment to track will be retained until the Stop-SPAssignment cmdlet is executed. Therefore, if you need to view large amount of information as you complete a task, and you do not want to starve the SharePoint server of memory, the advanced method of using SPAssigment is preferable. Use Get-Help About_SPAssignment to find more information.

cmdlets for SharePoint Foundation 2010

SharePoint Foundation 2010 contains over 240 SharePoint-related cmdlets. The exact number can be found by typing the following command.

@(Get-Command -PSSnapin "Microsoft.SharePoint.PowerShell").count

The most common objects that these cmdlets manipulate are the SPSite, SPServer, SPWeb, SPBusinessDataCatalogue, and SPConfigurationDatabase objects. Because Windows PowerShell is mainly an administrator's tool, and these are the components an administrator manages, this spread of cmdlet is not unexpected. These cmdlets also can be found in SharePoint 2010, which is built on top of SharePoint Foundation.

Conseil :
The document "Microsoft SharePoint Foundation 2010 Cmdlet Reference" is included on this book's companion media. This document contains the output that you would see if you typed the following command in the SharePoint 2010 Management Shell.

Code de copie
PS C:\Users\Peter>Get-Command -PSSnapin Microsoft.SharePoint.PowerShell |
>>Sort Noun, Verb | Get-Help -detailed > CmdletHelp.txt
>><ENTER>

This command generates a list of cmdlet Help topics that is sorted by noun. This list contains the same Help for each cmdlet that you can view in the SharePoint 2010 Management Shell by typing the following command.

Get-Help <Cmdlet-Name> -detailed

The document contains help information that was current at the time that the document was produced. Microsoft recommends that you always check the online help to find the latest information and examples. You can find the link to the online version in the Related Links section when you use the Get-Help command.

cmdlets for SharePoint 2010

If you use the same Windows PowerShell command shown in the previous section to determine the number of cmdlets available in SharePoint 2010, you will find that there are more than 530 SharePoint-related cmdlets associated with SharePoint 2010. Specifically, that is the number of cmdlets associated with a full install of the Enterprise Edition of SharePoint 2010 without FAST Search installed. To identify the additional cmdlets that SharePoint provides, Windows PowerShell can help again. On a computer with both SharePoint Foundation and a version of SharePoint Server installed, type the following command, changing the name of the redirect file name to reflect the SharePoint installation.

Code de copie
PS C:\users\peter>Get-Command -PSSnapin "Microsoft.SharePoint.PowerShell" |
>> Sort noun, verb |group -Property noun -NoElement > cmdlet_sps.txt
>><Enter>

Copy the files to the same server and then type the following command.

Code de copie
PS C:\Users\Peter>Compare-Object -ReferenceObject $(Get-Content .\cmdlet_sps.txt) '
>>-DifferenceObject $(Get-Content .\cmdlet_spf.txt)
>><ENTER>

You will see output similar to the following example.

Code de copie
InputObject                                                 SideIndicator
-----------                                                 -------------
    8 SPContentDatabase                                     =>
    3 PluggableSecurityTrimmer                              <=
    3 SPAccessServiceApplica...                             <=
    9 SPContentDatabase                                     <=
    5 SPContentDeploymentJob                                <=
    4 SPContentDeploymentPath                               <=
    4 SPDataConnectionFile                                  <=
    1 SPDataConnectionFileDe...                             <=
    2 SPEnterpriseSearchAdmi...                             <=
    3 SPEnterpriseSearchLang...                             <=
    4 SPEnterpriseSearchMeta...                             <=
...

Only those objects that do not appear on both installations, and those for which the count of the number of cmdlets per object is different, will appear in this list. The SideIndicator column indicates from which file the object with its cmdlet count came.

In SharePoint 2010, the most common objects that are manipulated by cmdlets are similar to those in SharePoint Foundation. However, the main additional commands available in SharePoint 2010 are the 131 cmdlets that help you manage the search process. (There are only four cmdlets associated with searches for SharePoint Foundation). Type the following command to check this for yourself.

Code de copie
PS C:\Users\Peter>@(gcm -PSSnapin "Microsoft.SharePoint.PowerShell" |
>>where {$_.name -like "*search*"}).count
>><ENTER>

SharePoint 2010 contains more application services than SharePoint Foundation, such as Excel Services, InfoPath Services, Secure Storage, State Service, Microsoft Visio, and PerformancePoint. Therefore, on a SharePoint Server farm, there are more cmdlets that you can use to create, manipulate, and delete application service objects.

Performing Basic Administrative Tasks

There are two types of administrative tasks that are needed in a SharePoint installation: tasks that need to be completed once and from any server, such as creating a new Web application, configuring the primary owner of a site collection, or deleting a specific website; and tasks that need to be completed more than once on a specific server or on more than one server, such as starting a service on a server, adding or removing a server from the farm, or connecting the server to a specific configuration database. The majority of work you will need to complete as a SharePoint administrator is of the first type—it does not matter which server you are logged on to, because you can complete your work from any server.

Windows PowerShell makes it easier to complete both types of administrative tasks. You can loop around a large number of objects and incorporate the scripts into automated tasks so that administrative tasks can be completed in less time. Just because administrative tasks may be easy to complete using Windows PowerShell, however, you should not allow its use to circumvent the controls you may have in place. Some of these farm-wide tasks are very dangerous; they can affect the whole installation. In a production environment, such tasks should be under strict change management.

Important :
Many organizations allow administrative tasks to be completed only by using remote access to the production servers. Computer room access is strictly controlled, so interactive access at the server console is rarely allowed—usually only for hardware-related issues. In such environments, even remote access to the production servers is restricted to a small number of Administrative computers, which administrators have to connect to using a VPN or Remote Desktop. An Administrative computer should be configured to allow only certain users or IP addresses to instigate remote desktop sessions. If this is your scenario, remotely managing your SharePoint Installation using Windows PowerShell should also be restricted to that Administrative computer. Windows PowerShell has a number of built-in capabilities that can help you reduce the risk of tasks that affect the whole of a SharePoint installation; these were referred to in the section titled "Managing Systems Remotely with WinRM" earlier in this chapter.

Windows PowerShell provides a number of "voluntary" capabilities that could be classified as best practices. In the next sections, you will learn more about two of these, the -whatif parameter and transcripts.

Using the -whatif Parameter

Windows PowerShell is a powerful tool, and like any other scripting language, it is all too easy to borrow someone else's code or download snippets from the Internet. You might then execute them without knowing exactly what they do. Using signed scripts and the Windows PowerShell execution policy, as well as restricting who is allowed to load script files onto your SharePoint server, are ways that you can protect your resources.

Windows PowerShell provides a mechanism that allows you to try a command before you execute it—the -whatif parameter. Type the following command.

PS C:\Users\Peter> Get-SPSite http://teams/sites/* | Remove-SPSite -whatif

This command produces the following sample output that lists all site collections and the operation(s) that would be performed on these objects if you executed the command without the -whatif parameter.

Code de copie
What if: Performing operation "Remove-SPSite" on Target "http://teams/sites/Sales".
What if: Performing operation "Remove-SPSite" on Target "http://teams/sites/Blogs".
What if: Performing operation "Remove-SPSite" on Target "http://teams/sites/Finance".
What if: Performing operation "Remove-SPSite" on Target "http://teams/sites/Wikis".
What if: Performing operation "Remove-SPSite" on Target "http://teams/sites/HR".

Nothing has been deleted by trying the command with the -whatif parameter. The parameter tells the Remove-SPSite cmdlet to display the object that would be affected by the command without performing the command. In this example, it displays the objects that would be permanently deleted.

Generating Transcripts

A pair of Windows PowerShell cmdlets, Start-Transcripts and Stop-Transcripts, allows you to record all the commands that you type at the prompt, together with the output. All activity is recorded between the start and stop commands. If you do not type stop, the transcript is terminated when the console session is terminated. This could be very useful in your production environment, where the machine-wide profile contains the Start-Transcript cmdlet to record the Windows PowerShell activities of all users. The recording to the transcript file is complete when they exit the console.

Important :
Don't use a Windows PowerShell cmdlet or script for the first time in a production environment. Also, try to keep it simple—don't use or create aliases if scripts are going to be supported by administrators who are new to Windows PowerShell, and always use Windows PowerShell comments when you create or amend scripts.

Real World: What If You Don't Use the -whatif Parameter?

Sometimes even experienced IT professionals can use the built-in cmdlets incorrectly with serious consequences, especially when cmdlets are used in combination with the pipe character. For example, if you type Get-SPSite | Remove-SPSite, all site collections in your farm will be permanently deleted. Everything—all the data in your lists and libraries, and all the content in your websites—would simply be gone. One likely result of this action is that all your help desk telephone lines would immediately ring. If one of the websites that disappeared was your main e-commerce Internet website, your company could quickly lose a great deal of money, and perhaps more importantly, the company could lose potential customers who might never return. To restore your farm, you would need your latest good backup tapes. The lesson of this example is simple: always use the -whatif parameter first!

Examples of SharePoint Administrative Tasks

Many administrative tasks must be completed on a daily basis, some are needed only occasionally, and then there are those few that are rarely required. Windows PowerShell can help with all of these types of tasks; in fact, you may discover that it is more critical to script a rarely executed task than one you perform every day. This may be because you need to execute that rare task quickly and correctly, because the ramifications of making even a small mistake while completing the task could be catastrophic. Throughout this book, you will see many examples of when and how to use Windows PowerShell. In the following sections, you explore a few examples that you may not have seen elsewhere.

Conseil :
There is a section of the Microsoft Script Center, http://gallery.technet.microsoft.com/ScriptCenter/en-us, that contains SharePoint-related scripts.

Deploying SharePoint 2010 with Windows PowerShell Scripts

During the lifetime of your SharePoint installation, there may be many tasks that you must complete (hopefully) only once, such as installing SharePoint and creating your farm. In large organizations with a variety of environments and many developers to support, however, you may find it prudent to develop scripts right from the outset that will build your SharePoint Web front-end (WFE) servers and your SharePoint applications servers, which host your applications services, such as InfoPath Services and search query and indexing services. In previous versions of SharePoint, you could complete such tasks using batch files and the SharePoint command-line tools psconfig and stsadm. You can still use these tools to automate the installation of your SharePoint 2010 and SharePoint Foundation 2010 servers. You will find more information about using these tools in Chapter 4, "Installing SharePoint 2010," so the details aren't repeated here. Microsoft has developed a script that is really the best practice for creating a SharePoint farm from scratch using Windows PowerShell. The order of these commands and parameters can be quite tricky, so Microsoft recommends that you use the Windows PowerShell module, SPModule, documented in the Microsoft's TechNet library article, Install SharePoint Server 2010 by using Windows PowerShell.

Conseil :
For information about SharePoint automation and the use of psconfig, stsadm, and Windows PowerShell, see http://stsadm.blogspot.com/.

When you work on a SharePoint installation, you will need to merge the logs. The Windows operating systems provide you with event logs to help you with your administrative tasks, and you can use the Windows PowerShell Get-Eventlog cmdlet to obtain detailed information from those logs. SharePoint also provides the Unified Logging Service (ULS). The ULS contains all application log events, and third-party logging software can be integrated into them as well. SharePoint 2010 includes several Windows PowerShell cmdlets for retrieving information and configuring the ULS. To find how ULS is configured on your farm, type the following command. (The sample output for this command is also shown here.)

Get-SPDiagnosticConfig

Code de copie
AllowLegacyTraceProviders                   : False
CustomerExperienceImprovementProgramEnabled : True
ErrorReportingEnabled                       : True
ErrorReportingAutomaticUploadEnabled        : True
DownloadErrorReportingUpdatesEnabled        : True
DaysToKeepLogs                              : 14
LogMaxDiskSpaceUsageEnabled                 : True
LogDiskSpaceUsageGB                         : 3
LogLocation                                 : %CommonProgramFiles%\Microsoft Sh
                                             ared\Web Server Extensions\14\LOG
                                             S\
LogCutInterval                              : 30
EventLogFloodProtectionEnabled              : True
EventLogFloodProtectionThreshold            : 5
EventLogFloodProtectionTriggerPeriod        : 2
EventLogFloodProtectionQuietPeriod          : 2
EventLogFloodProtectionNotifyInterval       : 5
ScriptErrorReportingEnabled                 : True
ScriptErrorReportingRequireAuth             : True
ScriptErrorReportingDelay                   : 60
 AllowLegacyTraceProviders                   : FalseCustomerExperienceImprovementProgramEnabled : TrueErrorReportingEnabled                       : TrueErrorReportingAutomaticUploadEnabled        : TrueDownloadErrorReportingUpdatesEnabled        : TrueDaysToKeepLogs                              : 14LogMaxDiskSpaceUsageEnabled                 : TrueLogDiskSpaceUsageGB                         : 3LogLocation                                 : %CommonProgramFiles%\Microsoft Sh                                             ared\Web Server Extensions\14\LOG                                             S\LogCutInterval                              : 30EventLogFloodProtectionEnabled              : TrueEventLogFloodProtectionThreshold            : 5EventLogFloodProtectionTriggerPeriod        : 2EventLogFloodProtectionQuietPeriod          : 2EventLogFloodProtectionNotifyInterval       : 5ScriptErrorReportingEnabled                 : TrueScriptErrorReportingRequireAuth             : TrueScriptErrorReportingDelay                   : 60

When diagnosing a problem, you can use cmdlets associated with the SPLogEvent object. You need machine administrator privileges to run these cmdlets, so you may need to start SharePoint 2010 Management Shell using Run As Administrator. Then you would use commands in steps similar to those shown in the following example.

  1. Set up two variables to store the start day and the end date, for example.

    Code de copie
    $SDate = Get-Date -Day 13 -Month 04 -Year 2010
$EDate = Get-Date -Day 14 -Month 04 -Year 2010
    Or the date could be today's date, but the event occurred approximately 15 minutes earlier than the current time. In this case, you set the variable to 20 minutes before the current time and 10 minutes before the current time.

    Code de copie
    $SDate = (Get-Date).AddMinutes(-20)
$EDate = (Get-Date).AddMinutes(-10)
  2. Obtain a list of events between those two dates and times.

    Get-SPLogEvent -StartDate $SDate -EndTime $Edate

    If the -EndTime parameter is not provided, the event logs will be displayed up until the current date and time.

A tracking number, known as the Correlation ID, is associated with each request you make to SharePoint. This number is stored as a value in a property associated with the SPLogEvent object. SQL Profiler traces also show the Correlation IDs. This number is displayed on an Error page, as shown in Figure 5-5.

Figure 5-5 Error page showing the Correlation ID

In a large or heavily used SharePoint installation, many logs may be produced during the period when a problem occurs. You can use the Correlation ID to help troubleshoot errors by reducing the amount of log information that is returned to those entries that are associated with the incident. Again, set the $sdate and the $edate variables to reflect the time around the incident. For an incident that you can't reproduce and one of your users always can reproduce, you might tell the help desk to ask the user to take a screenshot of the error page so you can be sure to obtain the exact Correlation ID number. Then you can pipe the results of the command shown in step 2 to the Where-Object cmdlet, as shown in the following example.

Code de copie
PS C:\Users\Peter>Get-SPLogEvent -StartDate $SDate -EndTime $EDate |
  where {$_.Correlation -eq "68bc5cf4-5a8c-4517-a879-86e35e57c862"}

The output will display only event logs between the two dates that are related to the problem associated with that Correlation ID.

Managing SharePoint Services

After you have run the SharePoint 2010 Products Configuration Wizard to install SharePoint on your servers, you can use the SharePoint 2010 Central Administration website to launch the Farm Configuration Wizard. Although it will get you up and running very quickly, it might not configure your farm as you want; for example, the database names it creates will be in the format name_GUID, where GUID is a randomly generated, globally unique identifier. Also, the farm wizard uses the account entered as the Application Pool Identity for the default content Web application and starts the Web Analytics Service by default—both of which may not be desirable on a production farm.

Using the wizard may be sufficient if you want to create a quick prototype or perhaps if you are using SharePoint in a developer environment. However, if any of those environments are limited in their CPU power or in the amount of memory they have, the farm wizard may not be suitable either. For example, the Web Analytics Service uses a large amount of CPU, so your developers might be interested in stopping that service. There are other services that they might want to start and stop on a regular basis, especially if they are using their computers as their day-to-day desktop connections, where they read e-mails and complete documentations, as well as to run SharePoint for development or prototyping.

You can use tools such as the Central Administration website to manage the configuration; however, you may forget to execute all the tasks necessary to complete a configuration change. Instead, you can use Windows PowerShell scripts, which—after you have tested them to make sure that you have not forgotten any tasks—should make managing configuration changes more reliable and error free. You should store these scripts in a central location after they are developed, to make them convenient for fellow administrators to use and incorporate in their environments. Your developer may also thank you for developing these scripts. Such automated tasks might include the following items.

  • To quickly delete a specific Web application, type

    Get-SPWebApplication http://teams | Remove-SPWebApplication -Confirm

  • To remove the Web application, the IIS website, and all the associated databases, type

    Remove-SPWebApplication http://teams -Confirm -DeleteIISSite ' -RemoveContentDatabases

If you do not run the Farm Configuration Wizard, you might find that you need a service that you originally thought you would not need. For example, if no application services are started, and then you try to use one of the SharePoint 2010 workflows, the Microsoft Visio diagram of the workflow progress will not be displayed. However, to solve this problem, you must do more than just create the Visio Application Service. There are other dependencies involved, one of which is the State Service Application. The state services can only be created in the Central Administration site, by using the farm wizard—something you will want to avoid as an administrator. To create the state service using Windows PowerShell, type the following commands.

Code de copie
PS: C:\Users\Peter>New-SPStateServiceDatabase -Name Contoso_StateService_DB |
>>New-SPStateServiceApplication -Name Contoso_StateService |
>>New-SPStateServiceApplicationProxy -Name Contoso_StateService_Proxy -Default
>><ENTER>
Remarque :
This command may not work in your environment if the associated service instance is not running. For a more comprehensive script, see "SP+PS 2010: PowerShell to Create a Service Application" at http://sharepoint.microsoft.com/blogs/zach/Lists/Posts/Post.aspx?ID=50.

Each service application is slightly different. For example, not all service applications require a database. Chapter 7 "Scaling Out a SharePoint Farm," contains more information about this. However, each service will require a service application proxy, which connects a Web application to the service application.

Using Windows PowerShell During the Upgrade Process

The following sections provide information about some Windows PowerShell commands you might find useful during an upgrade. The upgrade process is explained in more detail in Chapter 22, "Upgrading to SharePoint 2010."

Preparing for an Upgrade

After installing SharePoint 2010 and before upgrading, you can use the Test-SPContentDatabase cmdlet to check your SharePoint Server 2007 databases for current or potential issues, such as orphan data, missing site definitions, missing features, or missing assemblies. This cmdlet complements the pre-upgrade checker report mentioned in Chapter 22. Checking for these issues does not disrupt your SharePoint installation, and this cmdlet can also test the status of SharePoint 2010 databases, which can assist you in maintaining the continued health of your environment. The following example shows the command and its sample output.

Test-SPContentDatabase -name W_intranet -WebApplication http://www.contoso.msft

Code de copie
Category        : SiteOrphan
Error           : True
UpgradeBlocking : False
Message         : Database [W_intranet] contains a site (Id = [46ad6d70-9a5c-4d
                  e0-8daa-0f73f2466a6a], Url = [/]) whose id is already associa
                  ted with a different database (Id = [6987d2d8-6291-4ead-9eb0-
                  aefe7097a58e], name = [W_Intranet]) in the site map. Consider
                  deleting one of these sites which have conflicting ids.
Remedy          : The orphaned sites could cause upgrade failures. Try detach a
                  nd reattach the database which contains the orphaned sites. R
                  estart upgrade if necessary.

Category        : SiteOrphan
Error           : True
UpgradeBlocking : False
Message         : Database [W_intranet] contains a site (Id = [46ad6d70-9a5c-4d
                  e0-8daa-0f73f2466a6a], Url = [/]) whose url is already used b
                  y a different site, in database (Id = [6063e77c-991f-4c4b-b3a
                  c-68cb62e66502], name = [w_Internet]), in the same web applic
                  ation. Consider deleting one of the sites which have conflict
                  ing urls.
Remedy          : The orphaned sites could cause upgrade failures. Try detach a
                  nd reattach the database which contains the orphaned sites. R
                  estart upgrade if necessary.

Performing Post-Upgrade Tasks

The upgrade process is divided into two components, the content database upgrade and the visual upgrade. By separating these two components, your SharePoint team can decide to upgrade the Microsoft Office SharePoint Server 2007 Web application without users noticing the change, because their sites will maintain the old look and feel. Using the browser, they can preview what their site looks like with the new SharePoint 2010 look and feel and then decide when they permanently want to switch to the visual upgrade. After they make the switch, the browser will not allow them to switch back to the SharePoint Server 2007 look and feel.

The Set-SPWeb cmdlet does not have any parameter to help with this task; you will need to use the properties of the SPWeb object to complete this task. Type the following commands if you want to switch sites back to the old look and feel.

Code de copie
Start-SPAssignment -Global
$web = Get-SPWeb http://teams ;
$web.UIVersion = 3;
$web.UIVersionConfigurationEnabled = $true;
$web.Update();
Stop-SPAssignment
Remarque :
Previously in this chapter, you created variables to store values and objects. Variable names are prefixed with the dollar sign, $. In the sample code shown here, you will see $true used. This, together with a number of other keywords that look like variables, is an example of a special variable. A special variable should be treated as a reserved word that you cannot use in your scripts to store values or object. The special variable $true represents the value True, $false represents False, $null represents null, and $_ also has been used in this chapter and contains the current pipeline object. It is used in script blocks, filters, and the Where cmdlet.

After you run these commands, the website will revert to the SharePoint Server 2007 look and feel. The Site Actions button will be in the upper-right corner, for example, instead of in the upper-left corner. The Site Actions menu will have the Visual Upgrade option available, although the Visual Upgrade option at the site collection level may not be enabled. To enable the Visual Upgrade option at the site collection level, use the following commands.

Code de copie
$site = Get-SPSite http://teams
$site.UIVersionConfigurationEnabled = $true

When updating the properties of the SPSite object, there is no update method; the changes to the SPSite properties take effect immediately. You could type the following line as an alternative to the previous two lines of commands.

Code de copie
(Get-SPSite http://teams).UIVersionConfigurationEnabled = $false

To reset all "team" websites within a site collection back to the SharePoint Server 2007 look and feel, use the following command.

Code de copie
PS C:\Users\zzspfarm> Get-SPsite http://teams |
>> Get-SPWeb -Filter {$_.Template -eq "STS#0}|
>> ForEach-Object {
>> $_.UIVersion =3;
>> $_.UIVersionConfigurationEnabled = $false;
>> $_.Update();
>> }
>><ENTER>
Remarque :
These commands also can be run on a site or site collection that has not been upgraded—that is, on a site that was created as a version 4 site, thereby making a SharePoint 2010 site look like a SharePoint 2007 site.

Summary

This chapter explains how you can become familiar with the new Windows PowerShell cmdlets introduced by SharePoint 2010. It explores the SharePoint 2010 Management Shell and how to accomplish some simple but powerful administrative tasks using one-line Windows PowerShell commands.

There are more than 500 SharePoint cmdlets. This chapter could not possibly explain each command; instead, its aim was to provide some general guidelines and good practices for using SharePoint PowerShell in a production environment, such as the configuration and use of remote management, the voluntary use of transcripts, and the use of the -whatif parameter. You should not practice or try out Windows PowerShell commands for the first time on your production environment. Keep your scripts simple, use comments to document your scripts, and don't use or create aliases if the scripts are going to be supported by administrators who are unfamiliar with Windows PowerShell.

The chapter covered two important cmdlets, Start-SPAssignment and Stop-SPAssignment, in some detail. These cmdlets help with cmdlets that return disposable objects, such as SPSite, SPWeb, and SPSiteAdministration. Other SharePoint cmdlets were introduced to expand your knowledge of Windows PowerShell techniques. Chapter 12 builds on this chapter, using search scenarios. The next chapter continues the discussion of SharePoint 2010 farm management and specifically the Central Administration interface.

Historique des modifications

Date | Description | Raison
2011/01/10 | Publication initiale |


Articles de la Base de connaissances System Center Operations Manager (SharePoint Foundation 2010)

Les articles de cette section sont des articles de la Base de connaissances du pack d'administration de Microsoft SharePoint Foundation 2010 pour Microsoft System Center Operations Manager 2007. En principe, vous accédez à ces articles après un clic sur un lien figurant dans une alerte de la console Operations Manager. Vous pouvez également recourir à ces articles pour résoudre des problèmes liés à SharePoint Foundation 2010.

Dans cette section :

  • Capacité de stockage insuffisante dans le service ULS pour le répertoire des journaux - Événement 2150

  • Saturation du journal des événements - Événements 2158, 2159

  • Échec de connexion à la base de données SQL Server - Événement 3351

  • Échec de la sauvegarde en raison d'autorisations insuffisantes : événement 3353 (Produits SharePoint 2010)

  • Connexion à SQL Server impossible - Événement 3355

  • Le compte du pool d'applications ne peut pas ajouter de comptes d'utilisateur à Active Directory : événement 3359 (Produits SharePoint 2010)

  • L'unité d'organisation Active Directory n'est pas inscrite - Événement 3360 (produits SharePoint 2010)

  • La base de données SQL Server est pleine - Événement 3758

  • Base de données inaccessible - Événement 3760 (produits SharePoint 2010)

  • Échec du travail de déploiement de contenu - Événements 4958 5323 5325 5335

  • La base de données est en lecture seule - Événement 4971

  • Autorisations de base de données SQL insuffisantes - Événement 5214

  • Impossible d'écrire dans le journal de suivi - Événement 5401

  • Exceptions SQL inconnues - Événement 5586

  • Échec de la création du site par SharePoint Foundation - Événement 6141 (Produits SharePoint 2010)

  • Impossible de charger le fournisseur d'authentification - Événement 6143 (Produits SharePoint 2010)

  • Autorisations insuffisantes pour écrire dans le cache de données de configuration - Événement 6395

  • Échec de la mise à jour des mappages des accès de substitution - Événement 6397

  • Échec de l'exécution du minuteur Instance Service - Événement 6398

  • Espace disque libre insuffisant pour le service de journalisation unifié (ULS, Unified Logging Service) - Événement 6457

  • Accès refusé pour écrire dans le Registre - Événement 6588

  • Accès en écriture sur le disque refusé - Événement 6589

  • Le compte de pool d'applications doit être enregistré en tant que Kerberos - Événement 6590

  • Le service SMTP n'est pas en cours d'exécution - Événement 6599 (produits SharePoint 2010)

  • Échec du chargement du gestionnaire d'événements : Événement 6644 (Produits SharePoint 2010)

  • Autorisation sur la bibliothèque d'aide du produit - Événement 6769

  • Impossible de résoudre le nom du serveur SMTP sortant - Événement 6856 (Produits SharePoint 2010)

  • Connexion impossible à l'hôte SMTP - Événement 6857.

  • Une erreur est survenue au cours d'une communication avec le serveur SMTP - Événement 6858 (produits SharePoint 2010)

  • Les listes SharePoint ne peuvent pas recevoir de courrier électronique - Événement 6872 (produits SharePoint 2010)

  • Le service de messagerie ne peut pas remettre le courrier électronique - Événement 6873 (Produits SharePoint 2010)

  • Échec du récepteur d'événements : Événement 6875 (Produits SharePoint 2010)

  • Impossible de créer le travail du minuteur de sauvegarde - Événement (Produits SharePoint 2010)

  • Échec de la mise à jour de l'Administration centrale : Événement 7037 (Produits SharePoint 2010)

  • Alerte de début de limitation - Événements 8032 8062

  • Récupération des extrémités impossible - Événement 8070

  • Le dossier journal n'existe pas - Événement 8074 (produits SharePoint 2010)

  • Échec du travail du minuteur d'utilisation - Événement 8075 (produits SharePoint 2010)

  • Service Connexion de données métiers - Exception de la connexion d'adaptateur de base de données BDC - Événement 8080 (Produits SharePoint 2010)

  • Service BDC - Exception de génération liée au proxy de service Web BDC : événement 8082 (Produits SharePoint 2010)

  • Service Connexion de données métiers - Proxy BDC - exception inattendue - Événement 8085 (Produits SharePoint 2010)

  • Service BDC - Exception SQL : événement 8086 (Produits SharePoint 2010)

  • Le fichier journal de trace ULS a atteint la taille maximale : événement 8094 (Produits SharePoint 2010)

  • Le fichier journal d'utilisation ULS a atteint la taille maximale - Event 8095

  • Certificat de signature STS manquant : événement 8303 (Produits SharePoint 2010)

  • Le service d'émission de jeton de sécurité ne peut pas signer les informations d'identification - Événement 8304 (Produits SharePoint 2010)

  • Les revendications ne peuvent pas établir de point de terminaison : événement 8305 (Produits SharePoint 2010)

  • Erreur du fournisseur de revendications STS : événement 8307 (Produits SharePoint 2010)

  • Le service d'administration n'est pas en cours d'exécution

  • Service de lancement des conversions de documents non disponible

  • Service d'équilibrage de la charge de conversion de document indisponible

  • L'article technique n'est pas encore disponible

  • Le code en bac à sable est en cours d'exécution

  • Le service d'administration de SharePoint est désactivé

  • La recherche SharePoint Foundation 2010 n'est pas en cours d'exécution

  • L'Analyseur d'intégrité SharePoint a détecté une erreur ou un avertissement (Produits SharePoint 2010)

  • Le service minuteur de SharePoint Timer n'a pas pu démarrer

  • Le service minuteur de SharePoint Timer n'est pas en cours d'exécution

  • L'accès à distance à SQL Server est désactivé (Produits SharePoint 2010)

  • Le service de gestion du suivi n'est pas en cours d'exécution

  • L'application Web prend trop de temps pour restituer une page (SharePoint 2010 Products)

  • Application Web non disponible (produits SharePoint 2010)

  • Site Web non disponible (produits SharePoint 2010)

Historique des modifications


Capacité de stockage insuffisante dans le service ULS pour le répertoire des journaux - Événement 2150

nom de l'alerte : ULS dispose d'un espace de stockage insuffisant pour le répertoire des journaux

ID d'événement : 2150

Résumé : Le service de suivi Microsoft SharePoint Foundation (SPTracev4) est utilisé par Microsoft SharePoint Foundation 2010 pour gérer la sortie des journaux d'utilisation. Lorsque la journalisation de l'utilisation est activée, les administrateurs peuvent spécifier le chemin d'accès à utiliser pour le stockage des journaux d'utilisation. Ce fichier journal est utilisé par de nombreuses applications qui reposent sur SharePoint Foundation 2010. Cet événement se produit lorsque l'espace disque disponible est insuffisant pour la journalisation.

Symptômes : un ou plusieurs des symptômes suivants peuvent apparaître :

  • Le journal d'utilisation ne montre aucune nouvelle donnée d'utilisation.

  • Cet événement apparaît dans le journal des événements: ID d'événement : 2150 Description : Échec de la création d'un fichier journal d'utilisation à l'emplacement <emplacement du journal>. Au moins <nombre de Go requis pour reprendre la journalisation> Go d'espace libre sont nécessaires si les journaux d'utilisation se trouvent sur le lecteur système.

Cause : l'emplacement de journal configuré ne dispose pas de suffisamment d'espace libre pour la journalisation.

Solution : libérer de l'espace sur le disque ou déplacer le journal d'utilisation

  • SharePoint Foundation 2010 n'a pas pu écrire dans le journal d'utilisation. Ce journal d'utilisation contient des informations qui facilitent le suivi de l'utilisation et la création de rapports sur celle-ci.

    Pour libérer de l'espace sur le disque :

    1. Utilisez l'outil Nettoyage de disque pour libérer de l'espace là où sont stockés les fichiers journaux d'utilisation.

    2. Vérifiez si le journal de suivi dispose de suffisamment d'espace disque pour fonctionner correctement.

    3. Si l'espace disque est inadéquat, essayez de nettoyer les dossiers Temp sur le lecteur.

    4. Si cette procédure ne résout pas le problème, vous pouvez déplacer le fichier journal d'utilisation dans une partition disposant de davantage d'espace disque.

    Pour déplacer le fichier journal :

    1. Sur le site Web Administration centrale de SharePoint, dans la barre de lancement rapide, cliquez sur Analyse et dans la section Rapports, cliquez sur Journalisation de l'utilisation.

    2. Dans la page Journalisation de l'utilisation, dans la section Paramètres de journalisation, tapez le nouvel emplacement du fichier journal d'utilisation.

    3. Cliquez sur OK.

    Pour vérifier le fichier journal d'utilisation :

    1. Pour vérifier que Microsoft SharePoint Foundation 2010 peut créer le fichier journal d'utilisation et y écrire des données, dans la page Administration centrale, cliquez sur Analyse, puis, dans la section Rapports, cliquez sur Journalisation de l'utilisation.

    2. Dans la page Journalisation de l'utilisation, dans la section Paramètres de journalisation, copiez le chemin d'accès du fichier journal d'utilisation.

    3. Dans l'Explorateur Windows, accédez au fichier journal d'utilisation en utilisant le chemin d'accès copié. Les fichiers journaux d'utilisation sont au format binaire et le contenu ne peut pas être facilement affiché et assimilé. La taille du fichier journal d'utilisation augmente avec le temps, confirmant le bon fonctionnement de la journalisation de l'utilisation.

Historique des modifications


Saturation du journal des événements - Événements 2158, 2159

Nom de l'alerte : Saturation du journal des événements

ID d'événement : 2158 ou 2159

Résumé : La protection de flux du journal des événements empêche les événements répétés d'être consignés dans le journal des événements Windows. Lorsqu'un événement est consigné plusieurs fois sur une courte période, la protection de flux empêche les événements suivants du même type d'être consignés.

Symptômes : Cet événement apparaît dans le journal des événements : ID d'événement : 2158 ou 2159 Description : l'événement [ID d'événement] ([Nom du fournisseur d'événements]) de gravité [Gravité de l'événement] s'est à nouveau produit [Nombre d'occurrences] fois et a été supprimé dans le journal des événements.

Cause : Le même événement a été consigné plusieurs fois, ce qui a déclenché la protection de flux du journal des événements. Vous pouvez identifier les événements consignés plusieurs fois dans le texte Description de l'événement de l'ID d'événement 2158 ou 2159.

Historique des modifications


Échec de connexion à la base de données SQL Server - Événement 3351

Nom de l'alerte : Échec de connexion à la base de données SQL Server

ID d'événement : 3351

Résumé : Microsoft SharePoint Foundation utilise des bases de données Microsoft SQL Server 2008 pour stocker la plupart du contenu des sites et des paramètres de configuration de SharePoint Foundation, et utilise un compte de service pour communiquer avec la base de données pour le compte d'une demande de l'utilisateur. Notez qu'une application Web peut être associée à une ou plusieurs bases de données. Cette erreur signifie que SharePoint Foundation ne peut pas se connecter à SQL Server 2008 à l'aide du nom d'utilisateur et du mot de passe du compte de service spécifié.

Symptômes : Le symptôme suivant peut apparaître :

  • Cet événement apparaît dans le journal des événements : ID d'événement : 3351 Description : Échec de connexion à la base de données SQL. Des informations supplémentaires sur l'erreur SQL Server sont décrites ci-dessous.

Cause : Le nom d'utilisateur ou le mot de passe du compte de service Microsoft SharePoint Foundation n'était pas valide avant la session ou il est devenu non valide au cours de celle-ci.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les procédures suivantes.

Solution : Accorder les autorisations appropriées au compte d'accès à la base de données

  • Pour résoudre ce problème, attribuez le compte d'accès à la base de données puis vérifiez que le compte dispose des autorisations correctes dans SQL Server.

    Pour attribuer le compte d'accès à la base de données :

    1. Dans la page Web Administration centrale, sur la barre de lancement rapide, cliquez sur Sécurité puis, dans la section Sécurité générale, cliquez sur Configurer les comptes de service.

    2. Dans la section Gestion des informations d'identification, dans la liste déroulante supérieure, cliquez sur le pool d'applications Web correct pour votre application Web.

    3. Dans la liste déroulante Sélectionnez un compte pour ce composant, cliquez sur le compte de domaine avec lequel vous voulez associer ce pool d'applications Web, ou bien cliquez sur Enregistrer le nouveau compte géré pour associer un nouveau compte de domaine avec ce pool d'applications.

    4. Cliquez sur OK pour enregistrer les modifications.

    Pour vérifier que le compte dispose des autorisations appropriées dans SQL Server :

    1. Connectez-vous à l'ordinateur qui exécute SQL Server en utilisant un compte disposant d'autorisations d'administrateur.

    2. Dans SQL Server Management Studio, dans le volet de navigation de l'Explorateur d'objets, développez le nœud Sécurité, puis cliquez sur le nœud Connexions. Le nom du compte d'accès à la base de données indique qu'il s'agit d'un compte de connexion SQL.

    3. Si le compte existe, dans le volet de navigation de l'Explorateur d'objets, développez le nœud Bases de données, développez le nœud de la base de données de configuration (par exemple WSS_Config), développez le nœud Sécurité, puis cliquez sur Rôles.

    4. Développez le nœud Rôles de base de données, cliquez sur db_owner et sélectionnez Propriétés.

    5. Dans la boîte de dialogue Propriétés des rôles de base de données, regardez si le compte d'accès à la base de données figure dans la liste Membres de ce rôle. Si le compte n'y figure pas, cliquez sur Ajouter.

    Pour vérifier que les problèmes de base de données ont été résolus :

    1. Dans SharePoint 2010 Management Shell, exécutez la commande Windows PowerShell Get-SPSite | Format-Table -Property ID,WebApplication,ContentDatabase pour obtenir une liste des sites pour chaque application Web, afficher la liste de tous les sites dans les différentes bases de données et localiser un site donné dans chaque base de données.

    2. Accédez au site.

Historique des modifications


Échec de la sauvegarde en raison d'autorisations insuffisantes : événement 3353 (Produits SharePoint 2010)
Voir aussi

Nom de l'alerte : la sauvegarde a échoué en raison d'autorisations insuffisantes

ID d'événement : 3353

Résumé : cette erreur se produit lorsque le compte qui effectue la sauvegarde ne dispose pas d'autorisations suffisantes pour effectuer des opérations d'écriture dans le dossier de sauvegarde.

Lorsque vous sauvegardez une application Web, vous sauvegardez les bases de données de contenu et les paramètres de l'application Web, y compris tous les sites se trouvant dans les collections de sites, les fichiers stockés dans les bibliothèques de documents, les fichiers attachés aux listes, les paramètres de sécurité et d'autorisation, ainsi que les paramètres des fonctionnalités. Le processus de sauvegarde crée des fichiers qui contiennent toutes ces données.

De même, lorsque vous sauvegardez une collection de sites, un site ou une liste, le contenu de ces structures est écrit dans des fichiers ou dans des packages, puis le processus de restauration ou d'importation utilise ces fichiers pour récupérer les objets.

Symptômes: cet événement peut apparaître dans le journal des événements : ID d'événement : 3353 Description : Impossible d'écrire dans le dossier de sauvegarde.

Cause : la ou les causes peuvent être :

  1. Le compte de service SQL Server ne dispose pas d'un accès avec contrôle total au dossier de sauvegarde.

  2. Le compte de service du minuteur SharePoint ne dispose pas d'un accès avec contrôle total au dossier de sauvegarde.

  3. Si la sauvegarde ou la restauration a été réalisée à l'aide de Windows PowerShell, l'utilisateur qui a réalisé l'opération de sauvegarde ne disposait pas d'un accès avec contrôle total au dossier de sauvegarde.

Solution : vérifier les autorisations

  • Vérifiez les points ci-après, notamment que les comptes suivants disposent des autorisations de partage de fichier avec contrôle total et NTFS pour le dossier de sauvegarde partagé :

    • Le compte utilisé par le compte de service SQL Server.

    • Le compte de minuteur Windows SharePoint Services V4 (SPTimerV4).

    • Le compte ayant ouvert une session, si vous utilisez Windows PowerShell pour effectuer la sauvegarde ou la restauration.

    • Si le dossier de sauvegarde est un partage réseau, vérifiez que tous les comptes répertoriés ci-dessus ont accès à la fois au partage et au dossier proprement dit.

    • Si vous effectuez une opération de sauvegarde ou de restauration entre deux batteries de serveurs SharePoint, les services sur les deux batteries de serveurs doivent disposer des autorisations décrites ci-dessus.

  • Pour plus d'informations, voir Configuration des autorisations pour la sauvegarde et la récupération (SharePoint Foundation 2010).

Voir aussi

Concepts

Afficher les journaux de diagnostic (SharePoint Foundation 2010)

Historique des modifications


Connexion à SQL Server impossible - Événement 3355

Nom de l'alerte : Connexion impossible à SQL Server

ID d'événement : 3355

Résumé : Microsoft SharePoint Foundation 2010 utilise les bases de données Microsoft SQL Server 2008 pour stocker les paramètres de configuration et la plupart du contenu du site Web de Microsoft SharePoint Foundation. Par exemple, toutes les pages du site, tous les fichiers des bibliothèques de documents, tous les fichiers joints à des listes, et toutes les informations comprises dans des listes sont stockés dans la base de données de contenu, tandis que les paramètres de sécurité et d'autorisation ainsi que les autres paramètres de configuration sont stockés dans la base de données de configuration dans SQL Server.

SharePoint Foundation 2010 utilise un compte de service pour communiquer avec la base de données au nom d'une requête utilisateur. Ce compte de service peut être un nom d'utilisateur ou mot de passe spécifique (Nom de domaine ou mot de passe), ou un compte système prédéfini, tel que le Système local ou Service réseau. Lorsqu'une base de données SQL Server est créée, la taille maximale de la base de données est définie. Chaque base de données dispose d'un paramètre de taille distinct. Notez qu'une application Web doit être associée avec une ou plusieurs bases de données.

Cette erreur indique que Microsoft SharePoint Foundation n'a pas réussi à se connecter à la base de données SQL Server.

Symptômes : Un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les tentatives de communication avec SQL Server échouent et aucun contenu des bases de données hébergées sur SQL Server n'est accessible.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 3355 Connexion à SQL Server impossible. <Nom du serveur> introuvable. Des informations supplémentaires sur l'erreur provenant de SQL Server sont décrites ci-dessous.

Cause : La ou les causes peuvent être :

  1. SQL Server est peut-être hors connexion.

  2. Le compte d'accès de la base de données SharePoint Foundation ne dispose peut-être pas des autorisations nécessaires pour communiquer avec SQL Server.

  3. Un pare-feu fonctionnant sur le serveur local ou sur SQL Server bloque peut-être les communications réseau.

Solution : Accorder les autorisations appropriées au compte d'accès à la base de données

  • Vous devez être membre du groupe Administrateurs de batterie de serveurs pour effectuer cette tâche.

    Affecter le compte d'accès à la base de données :

    1. Sur la page d'accueil de l'Administration centrale, cliquez sur Sécurité et, dans la section Sécurité Générale, cliquez sur Configurer les comptes de service.

    2. Sur la page Comptes de service, dans la section Gestion des informations d'identification, dans la liste déroulante supérieure, cliquez sur le pool d'applications Web convenant à votre application Web.

    3. Dans la liste déroulante Sélectionnez un compte pour ce composant, cliquez sur le compte de domaine que vous souhaitez associer à ce pool d'applications Web, ou cliquez sur Enregistrer le nouveau compte géré pour associer un nouveau compte de domaine à ce pool d'applications.

    4. Cliquez sur OK pour enregistrer les modifications.

    Vérifiez que le compte dispose des autorisations adéquates dans SQL Server :

    1. Connectez-vous à l'ordinateur qui exécute SQL Server en utilisant un compte disposant d'autorisations d'administrateur.

    2. Dans SQL Server Management Studio, dans le volet de navigation Explorateur d'objet, développez le nœud Sécurité, puis le nœud Connexions. Le nom du compte d'accès de la base de données indique qu'il s'agit d'une connexion SQL.

    3. Si le compte existe, dans le volet de navigation Explorateur d'objet, développez le nœud Base de données, développez le nœud de la base de données de configuration, développez le nœud Sécurité, puis cliquez sur Rôles.

    4. Développez le nœud Rôles de base de données, cliquez avec le bouton droit sur le rôle db_owner et sélectionnez Propriétés.

    5. Dans la boîte de dialogue Propriétés du rôle de base de données, vérifiez que le compte d'accès à la base de données se trouve dans la liste Membres de ce rôle. Dans le cas contraire, cliquez sur Ajouter.

    Vérifiez que les problèmes liés à la base de données sont résolus :

    1. Dans SharePoint 2010 Management Shell, exécutez la commande Windows PowerShell Get-SPSite | Format-Table -Property ID,WebApplication,ContentDatabase pour obtenir une liste des sites pour chaque application Web, afficher la liste de tous les sites dans les différentes bases de données et localiser un site donné dans chaque base de données.

    2. Accédez à ce site et vérifiez que la page appropriée est affichée. Si une page de refus d'accès s'affiche avec une option de demande d'accès ou une option d'accès avec un autre compte d'utilisateur, l'opération a réussi.

    3. Dans la page Administration centrale, dans Lancement rapide, cliquez sur Gestion des applications et, dans la section Collection de sites, cliquez sur Spécifier les modèles de quotas.

    4. Sur la page Modèle de quota, créez un nouveau modèle de quota. Les paramètres spécifiques ne concernent pas ce test de vérification. Vous créez le modèle pour vérifier qu'il est accessible à l'étape 7.

    5. Cliquez sur OK pour enregistrer le modèle de quota.

    6. Actualisez la fenêtre de navigation puis retournez à la page Modèles de quota. Si le modèle de quota que vous avez créé peut être sélectionné, l'accès à la base de données de configuration de SQL Server 2008 dans Microsoft SharePoint Foundation est restauré.

    7. Cliquez sur Supprimer pour supprimer le modèle de quota.

Historique des modifications


Le compte du pool d'applications ne peut pas ajouter de comptes d'utilisateur à Active Directory : événement 3359 (Produits SharePoint 2010)

Nom de l'alerte : le compte du pool d'applications ne peut pas ajouter de comptes d'utilisateur à Active Directory

ID d'événement : 3359

Résumé : le pool d'applications des services Internet (IIS) crée des identités basées sur les utilisateurs Active Directory et associe ces identités à l'aide d'un jeu d'autorisations. Cela permet aux utilisateurs dans une unité d'organisation Active Directory d'hériter ces autorisations.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Le mode de création de compte ne fonctionne pas correctement, ce qui empêche l'ajout ou la lecture des données utilisateur.

  • Les comptes d'utilisateur ne sont pas automatiquement créés dans Active Directory.

  • L'événement figure dans le journal des événements : ID d'événement : 3359 Description : le compte du pool d'applications ne dispose pas des autorisations suffisantes pour ajouter des comptes d'utilisateurs dans Active Directory.

Cause : le compte utilisé par le pool d'applications ne dispose pas du niveau approprié d'autorisations nécessaires pour ajouter de nouveaux comptes d'utilisateur dans Active Directory.

Solution : déterminer l'unité d'organisation dans laquelle le compte du pool d'applications crée des comptes d'utilisateur

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez le texte suivant :

    Code de copie
    $wa=Get-SPWebApplication
$wa.Parent.CreateActiveDirectoryAccounts
$wa.Parent.ActiveDirectoryDomain
$wa.Parent.ActiveDirectoryOrganizationalUnit
Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Solution : ajouter les autorisations adéquates à l'unité d'organisation

  1. Sur un serveur sur lequel les outils Active Directory sont installés, ouvrez le composant logiciel enfichable Utilisateurs et ordinateurs Active Directory en tant qu'utilisateur disposant d'autorisations de domaine suffisantes, par exemple, en tant qu'administrateur de domaine. Pour ouvrir Utilisateurs et ordinateurs Active Directory, cliquez sur Démarrer, cliquez sur Exécuter, puis tapez dsa.msc.

  2. Dans l'arborescence de la console, cliquez avec le bouton droit sur l'unité d'organisation pour laquelle vous souhaitez déléguer le contrôle.

  3. Cliquez sur Délégation de contrôle pour démarrer l'Assistant Délégation de contrôle, puis suivez les instructions indiquées dans l'Assistant.

  4. Dans le volet Bienvenue, cliquez sur Suivant.

  5. Dans le volet Utilisateurs et groupes, cliquez sur Ajouter.

  6. Dans la zone Entrez les noms des objets à sélectionner, tapez le nom d'utilisateur que vous envisagez d'utiliser pour l'identité du pool d'applications d'administration, puis cliquez sur OK.

  7. Cliquez sur Suivant.

  8. Dans le volet Tâches à déléguer, activez les cases à cocher Créer, supprimer et gérer les comptes d'utilisateurs et Lire toutes les informations sur l'utilisateur, puis cliquez sur Suivant.

  9. Cliquez sur Terminer.

Historique des modifications


L'unité d'organisation Active Directory n'est pas inscrite - Événement 3360 (produits SharePoint 2010)

Nom d'alerte : unité d'organisation Active Directory non inscrite

ID d'événement : 3360

Résumé : cette erreur indique que l'unité d'organisation Active Directory créée pour le mode de création de compte n'existe pas.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Le mode de création de compte ne fonctionne pas correctement, ce qui empêche l'ajout ou la lecture des données utilisateur.

  • Cet événement figure dans le journal des événements : ID d'événement : 3360 Description : l'unité d'organisation Active Directory <nom de l'unité d'organisation> inscrite dans Windows SharePoint Services 4.0 n'existe pas.

Cause : cela peut être dû à une erreur pendant la mise en service ou à une erreur d'exécution ayant empêché la création de l'unité d'organisation spécifiée pendant la configuration de la batterie de serveurs, ou ayant entraîné la suppression de l'unité d'organisation ou l'attribution d'un nouveau nom à celle-ci. Tant que cette unité d'organisation n'est pas créée et inscrite, vous ne pouvez pas créer une collection de sites ou ajouter des utilisateurs.

Solution : ajouter l'unité d'organisation à Active Directory

  • Vous devez avoir ouvert une session en tant qu'administrateur de domaine pour effectuer cette procédure.

  • Cliquez sur Démarrer, sur Exécuter, puis tapez dsa.msc.

  • Développez le nœud Domaines.

  • Cliquez avec le bouton droit sur le domaine, cliquez sur Nouveau, puis cliquez sur Unité d'organisation.

  • Dans la zone <Insérer l'unité d'organisation ici>, tapez le nom de l'unité d'organisation tel qu'indiqué dans l'événement 7037.

  • Cliquez avec le bouton droit sur l'unité d'organisation, puis cliquez sur Délégation de contrôle.

  • Ajoutez le compte du pool d'applications pour l'application Web en cours d'utilisation pour la création de compte.

  • Cliquez sur Créer, supprimer et des gérer des comptes.

  • Cliquez sur Suivant.

  • Cliquez sur Terminer.

Historique des modifications


La base de données SQL Server est pleine - Événement 3758

Nom de l'alerte : la base de données SQL Server est complète

ID d'événement : 3758

Résumé : Microsoft SharePoint Foundation utilise des bases de données Microsoft SQL Server 2008 pour stocker la majeure partie du contenu des paramètres de site Web et de configuration SharePoint Foundation et utilise un compte de service pour communiquer avec la base de données au nom d'une demande de l'utilisateur. Lorsqu'une base de données SQL Server est créée, une valeur de la taille maximale de la base de données est définie. La taille est propre à chaque base de données. Notez qu'une application Web peut être associée à une ou à plusieurs bases de données. Cette erreur indique que la base de données a atteint la taille définie par son paramètre de taille maximale.

Symptômes : Le symptôme suivant peut apparaître :

  • Les utilisateurs ne peuvent pas ajouter ou mettre à jour du contenu dans SharePoint Foundation.

  • Les administrateurs ne peuvent pas mettre à jour les paramètres SharePoint Foundation.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 3758 Description : Erreur de la base de données complète sur l'instance SQL Server <nom de l'instance> dans la base de données <nom de la base de données>. Des informations supplémentaires sur l'erreur SQL Server sont décrites ci-dessous. <message d'erreur SQL>

Cause : la base de données a atteint sa taille maximale.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les tâches suivantes.

Solution : accroître la taille d'une base de données SQL Server

  • SharePoint Foundation ne peut pas écrire dans une base de données qui a atteint sa taille maximale. Augmentez la valeur de la taille maximale pour la base de données complète dont le nom apparaît dans le message d'événement.

    Pour accroître la taille d'une base de données :

    1. Dans SQL Server Management Studio, dans le volet de navigation Explorateur d'objets, développez le nœud de serveur, puis le nœud Bases de données.

    2. Cliquez avec le bouton droit sur la base de données de votre choix, puis cliquez sur Propriétés. Le nom de la base de données est indiqué dans le message d'événement.

    3. Dans la boîte de dialogue Propriétés de la base de données, dans le volet de navigation, cliquez sur Fichiers.

    4. Dans la section Fichiers de la base de données, dans la colonne Croissance automatique, cliquez sur les points de suspension associés au fichier de base de données.

    5. Dans la boîte de dialogue Modifier la croissance automatique, dans la section Taille de fichier maximale, vérifiez si l'option Restreindre la croissance des fichiers est sélectionnée. Si tel est le cas, augmentez la taille maximale des fichiers dans le champ situé à droite. Vous pouvez également configurer la base de données pour accroître sa taille de manière illimitée en sélectionnant l'option Croissance des fichiers illimitée.

    6. Cliquez sur OK pour enregistrer les modifications.

    Pour vérifier que les problèmes liés à la base de données sont résolus :

    1. Dans SharePoint 2010 Management Shell, exécutez la commande Windows PowerShell Get-SPSite | Format-Table -Property ID,WebApplication,ContentDatabase pour obtenir la liste des sites pour chaque application Web afin de recenser tous les sites dans les différentes bases de données et rechercher un site dans chaque base de données.

    2. Accédez au site.

    3. Essayez d'ajouter du contenu au site. Par exemple, ajoutez un élément de liste ou un document. Étant donné que SharePoint Foundation signale différentes erreurs suivant les circonstances de la modification, si l'ajout de contenu au site échoue, recherchez dans le journal des événements un message d'erreur tel que ceux indiqués dans le tableau suivant.

      Nom du journal :

      Application

      Source :

      Microsoft-Windows SharePoint-Windows SharePoint Services 4

      Date :

      2/4/2009 6:34:13

      ID d'événement :

      3758

      Catégorie de la tâche :

      Base de données

      Niveau :

      Critique

      Mots clés :

      Utilisateur :

      Domaine\MonUtilisateur

      Ordinateur :

      MonServeur

      Description :

      Erreur de la base de données complète sur l'instance SQL Server « CO137 » dans la base de données « wss_2 ». Des informations supplémentaires sur l'erreur SQL Server sont décrites ci-dessous. Impossible d'allouer de l'espace pour l'objet 'dbo.AllDocs'.'AllDocs_Url' dans la base de données 'wss_2' car le groupe de fichiers 'PRIMARY' est plein. Créez de l'espace disque en supprimant des fichiers qui ne sont pas indispensables, en supprimant des objets dans le groupe de fichiers, en ajoutant des fichiers supplémentaires au groupe de fichiers ou en définissant Autogrowth sur ON pour les fichiers existants dans le groupe de fichiers.

Historique des modifications


Base de données inaccessible - Événement 3760 (produits SharePoint 2010)

Nom de l'alerte : Base de données inaccessible

ID d'événement : 3760

Résumé : Microsoft SharePoint Foundation 2010 utilise des bases de données Microsoft SQL Server 2008 pour stocker la majeure partie du contenu du site Web et les paramètres de configuration. Par exemple, toutes les pages du site, les fichiers présents dans les bibliothèques de documents, les fichiers joints aux listes et les informations des listes sont stockés dans la base de données de contenu. Les paramètres de sécurité et des autorisations ainsi que d'autres paramètres de configuration sont stockés dans la base de données de configuration SQL Server.

SharePoint Foundation 2010 utilise un compte de service pour communiquer avec la base de données pour une demande d'un utilisateur. Ce compte de service peut correspondre à des noms de domaine/nom d'utilisateur et mot de passe spécifiques ou à un compte système prédéfini comme le système local ou le service réseau. Lorsqu'une base de données SQL Server est créée, une valeur pour la taille maximale de la base de données est définie. La taille est spécifique de chaque base de données. Notez qu'une application Web peut être associée à une ou à plusieurs bases de données.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Le contenu de la base de données n'est pas disponible et les tentatives d'accès à la base de données génèrent des erreurs.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 3760 Description : Erreur de la base de données complète sur l'instance SQL Server « <nom de l'instance> » dans la base de données « <nom de la base de données> ». Des informations supplémentaires sur l'erreur SQL Server sont décrites ci-dessous. <message d'erreur SQL>.

Cause : Un ou plusieurs des événements suivants pourraient avoir causé ce problème :

  • La connexion de l'utilisateur de SQL Server a échoué.

  • La base de données a été supprimée ou renommée.

  • La base de données n'est actuellement pas disponible car elle est hors connexion ou en état de chargement.

Important :
Vous devez être membre du groupe Administrateurs local pour effectuer cette tâche.

Résolution : vérifiez que Verify that SQL Server est en service

  • Sur le serveur de bases de données, dans le composant logiciel enfichable Services, vérifiez que le service SQL Server (MSSQLSERVER) est actif.

Résolution : vérifiez que le compte d'utilisateur peut se connecter à SQL Server

  • Connectez-vous à Microsoft SQL Server Management Studio en tant que le compte indiqué dans les détails de l'erreur et cliquez sur Connecter, puis sur Moteur de base de données.

  • Tapez le nom du serveur indiqué dans les détails de l'erreur et cliquez sur Connecter.

Résolution : vérifiez que la base de données existe

  • Dans Microsoft SQL Server Management Studio, développez le nœud du serveur.

  • Développez le nœud Bases de données.

  • Vérifiez que la base de données existe.
Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer ces tâches.

Solution : restaurer la base de données

  • Si la base de données SQL Server n'est pas présente ou accessible sur l'ordinateur qui exécute SQL Server, restaurez-la à partir d'une sauvegarde et reconnectez-la à SharePoint Foundation 2010.

    Pour restaurer la base de données à partir d'une sauvegarde :

    1. Sur le site Web Administration centrale de SharePoint, cliquez sur Sauvegarde et restauration, puis, dans la section Sauvegarde et restauration de la batterie, cliquez sur Restauration à partir d'une sauvegarde.

    2. Dans la page Restaurer à partir d'une sauvegarde, tapez le chemin d'accès de la sauvegarde dans la zone de texte Emplacement de l'historique de sauvegarde, sélectionnez la sauvegarde à restaurer, puis cliquez sur Suivant.

    3. Sélectionnez la base de données dans la liste, puis cliquez sur Suivant.

      Important :
      La sauvegarde doit inclure la base de données et l'application Web associée.

    4. Dans la section Options de restauration, sélectionnez l'option de configuration Existante. Cette opération remplace la base de données existante.

    5. Cliquez sur Lancer la restauration.

    Pour reconnecter la base de données dans l'Administration centrale :

    1. Dans la page Administration centrale, cliquez sur Gestion des applications, puis, dans la section Bases de données, cliquez sur Gérer les bases de données de contenu.

    2. Dans la page Gérer les bases de données de contenu, cliquez sur Ajouter une base de données de contenu, puis, dans la section Application Web, sélectionnez l'application Web.

    3. Sous Nom de la base de données et authentification, tapez le nom du serveur dans la zone de texte Serveur de base de données et tapez le nom de la base de données dans la zone de texte Nom de la base de données.

    4. Cliquez sur OK pour enregistrer les modifications.

    Pour vérifier que les problèmes de bases de données sont résolus :

    1. Dans SharePoint Management Shell, exécutez la commande Windows PowerShell Get-SPSite | Format-Table -Property ID,WebApplication,ContentDatabase pour obtenir la liste des sites pour chaque application Web afin de recenser tous les sites dans les différentes bases de données et rechercher un site dans chaque base de données.

    2. Accédez à ce site et assurez-vous que la page appropriée s'est affichée. Une page Accès refusé avec une option de demande d'accès ou l'option permettant d'ouvrir une session en tant qu'un autre utilisateur, indique que l'opération s'est déroulée correctement.

    3. Dans la page Administration centrale, cliquez sur Gestion des applications, puis, dans la section Collections de sites, cliquez sur Spécifier les modèles de quotas.

    4. Dans la page Modèles de quotas, créez un modèle de quota. Les paramètres spécifiques ne sont pas pertinents pour ce test de vérification. Vous créez le modèle pour vérifier s'il est accessible lors de l'étape 7.

    5. Cliquez sur OK pour enregistrer le modèle de quota.

    6. Actualisez la fenêtre de navigation et revenez à la page Modèles de quotas. Si vous pouvez sélectionner le modèle de quota que vous avez créé, l'accès à la base de données de configuration SharePoint Foundation 2010 a été restauré.

    7. Cliquez sur Supprimer pour supprimer le modèle de quota.

Historique des modifications


Échec du travail de déploiement de contenu - Événements 4958 5323 5325 5335

Nom de l'alerte : le travail de déploiement de contenu a échoué

ID d'événement : 4958 5323 5325 et 5325

Résumé : un travail de déploiement de contenu a échoué. Le contenu n'a peut-être pas été déployé correctement de l'environnement source à l'environnement cible.

Symptômes : un ou plusieurs messages apparaissent dans le journal d'événements :

  • ID d'événement : 4958 Description : Publication : Échec du travail de déploiement de contenu. Erreur : '<error>'.

  • ID d'événement : 5323 Description : Échec de transfert des fichiers vers le serveur de destination pour le travail de déploiement de contenu '<nom du travail>'. L'exception était : '<exception>'.

  • ID d'événement : 5325 Description : Échec de l'opération d'importation pour le travail de déploiement de contenu '<nom du travail>'. L'exception était : '<exception>'.

  • ID d'événement : 5326 Description : Échec de l'opération d'importation pour le travail de déploiement de contenu '<nom du travail>'. L'exception était : '<exception>'.

Cause : Le déploiement de contenu peut échouer pour diverses raisons. Les raisons de cet échec précis sont exposées dans le Rapport de déploiement du contenu sur la page Chemins d'accès et travaux de déploiement de contenu dans l'administration centrale.

Solution : afficher l'état du travail de déploiement de contenu

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Paramètres généraux de l'application.

  3. Sur la page Paramètres généraux de l'application, dans la section Déploiement de contenu, cliquez sur Gérer les chemins d'accès et les travaux de déploiement de contenu.

  4. Sur la page Gérer les chemins d'accès et les travaux de déploiement de contenu, confirmez l'état du travail. Si le travail a échoué, vous pouvez afficher les détails du travail en cliquant sur Échec.

  5. Sur la page Rapport du déploiement du contenu, dans la section Erreurs et avertissements, vous pouvez afficher les détails de l'erreur.

    Vous pouvez également les télécharger en cliquant sur Télécharger le rapport dans la section Liens rapides de la page Rapport du déploiement du contenu.

Solution : exécutez de nouveau le travail de déploiement du contenu

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Paramètres généraux de l'application.

  3. Sur la page Paramètres généraux de l'application, dans la section Déploiement de contenu, cliquez sur Gérer les chemins d'accès et les travaux de déploiement de contenu.

  4. Sur la page Gérer les chemins d'accès et les travaux de déploiement de contenu, cliquez sur la flèche adjacente au travail, puis cliquez sur Exécuter maintenant.

  5. Vous pouvez actualiser la page pour afficher l'état d'avancement du travail. Si le travail a échoué, vous pouvez afficher les détails du travail en cliquant sur Échec.

  6. Sur la page Rapport du déploiement du contenu, dans la section Erreurs et avertissements, vous pouvez afficher les détails de l'erreur.

    Vous pouvez également les télécharger en cliquant sur Télécharger le rapport dans la section Liens rapides de la page Rapport du déploiement du contenu.

Historique des modifications


La base de données est en lecture seule - Événement 4971

Nom de l'alerte : la base de données de contenu est en lecture seule

ID d'événement : 4971

Résumé : Microsoft SharePoint Foundation 2010 regroupe la plus grande part du contenu de l'application Web dans les bases de données de contenu, dont les collections de sites, les sites, les listes, les documents et les autorisations. Une application Web peut être associée à une ou à plusieurs bases de données.

Symptômes : Un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les utilisateurs ne peuvent pas ajouter ou mettre à jour du contenu dans les sites SharePoint Foundation 2010.

  • L'événement suivant apparaît dans le journal des événements : ID d'événement : 4971 Description : Impossible de mettre à jour la base de données sur l'instance SQL Server <nom de l'instance>. La base de données est en lecture seule. Des informations supplémentaires sur le serveur SQL Server sont décrites ci-dessous. <informations supplémentaires>.

Motif : SQL Server permet de définir la base de données en lecture seule. Dans ce mode, les données peuvent être lues dans la base de données, mais elles ne peuvent pas être ajoutées, modifiées ou supprimées. Sune base de données de contenu est en lecture seule, vous risquez de constater les symptômes décrits.

Solution : définir la base de données en lecture/écriture

  • Si vous constatez que le contenu de la base de données est en lecture seule, mettez la base de données SQL Server Management Studio en lecture/écriture.

    Pour vérifier que la base de données n'est pas en lecture seule :

    1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

    2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

    3. Sur la page Gestion des applications, dans la section Bases de données, cliquez sur Gérer les bases de données de contenu.

    4. Dans la page Gérer les bases de données de contenu, sélectionnez l'application Web dans la liste Application Web.

    5. Si Oui s'affiche dans la colonne Base de données en lecture seule de la base de donnéesde contenu, mettez la base de données en mode lecture/écriture.

    Pour définir la base de données de contenu en lecture/écriture

    1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est un membre du rôle de base de données fixe SQL db_owner pour la base de données de contenu.

    2. Ouvrez SQL Server Management Studio et connectez-vous au serveur de bases de données.

    3. Dans l'Explorateur d'objets, développez Bases de données.

    4. Cliquez avec le bouton droit sur la base de données que vous voulez mettre en lecture/écriture, puis cliquez sur Propriétés.

    5. Dans la boîte de dialogue Propriétés de base de données, dans la page de propriétés Options, sous État, sélectionnez False dans la liste déroulante à côté de Base de données en lecture seule, puis cliquez sur OK.

    6. Cliquez sur Oui.

Historique des modifications


Autorisations de base de données SQL insuffisantes - Événement 5214

Nom de l'alerte : Autorisations de base de données SQL Server insuffisantes

ID d'événement : 5214

Résumé : Microsoft SharePoint Foundation utilise les bases de données Microsoft SQL Server 2008 pour stocker la plupart des paramètres de configuration et du contenu du site Web. Par exemple, toutes les pages du site, tous les fichiers des bibliothèques de document, tous les fichiers joints à des listes, et toutes les informations comprises dans des listes sont stockés dans la base de données de contenu, tandis que les paramètres de sécurité et d'autorisation ainsi que les autres paramètres de configuration sont stockés dans la base de données de configuration dans SQL Server.

SharePoint Foundation utilise un compte de service pour communiquer avec la base de données au nom d'une requête utilisateur. Ce compte de service peut être un nom d'utilisateur et un mot de passe spécifiques (Nom de domaine ou mot de passe), ou un compte système prédéfini, tel que le Système local ou Service réseau. Cette erreur se produit lorsque le compte de service spécifié dans SharePoint Foundation n'a pas obtenu les autorisations suffisantes dans la base de données SQL Server.

Symptômes : Le symptôme suivant pourrait apparaître :

  • Cet événement apparaît dans le journal des événements : ID d'événement : 5214 Autorisations de base de données SQL insuffisantes pour l'utilisateur '<nom d'utilisateur>' dans la base de données <base de données> sur l'instance SQL Server <nom de l'instance>. Des informations supplémentaires sur l'erreur provenant de SQL Server sont décrites ci-dessous.

Cause : La ou les causes peuvent être :

  • Le compte de service auquel SharePoint Foundation est défini ne dispose pas des autorisations suffisantes pour la base de données à laquelle il essaie de se connecter.

  • Le compte de service n'est pas configuré correctement dans SharePoint Foundation.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour accomplir les tâches suivantes.

Solution : Accorder les autorisations appropriées au compte d'accès à la base de données

  • Pour résoudre ce problème, affectez le compte d'accès à la base de données puis vérifiez que le compte dispose de l'autorisation adéquate dans SQL Server.

    Pour attribuer le compte d'accès à la base de données :

    1. Sur le site Web de l'Administration centrale, cliquez sur Sécurité et, dans la section Sécurité Générale, cliquez sur Configurer les comptes de service.

    2. Sur la page Configurer les comptes de service, dans la section Gestion des informations d'identification, sélectionnez le pool d'applications Web convenant à votre application Web.

    3. Dans la section Sélectionnez un compte pour ce composant, sélectionnez le compte de domaine que vous souhaitez associer à ce pool d'applications Web, ou cliquez sur Enregistrer le nouveau compte géré pour associer un nouveau compte de domaine à ce pool d'applications.

      Remarque :
      Vous pouvez utiliser un compte local pour le pool d'applications Web seulement si SharePoint Foundation et SQL Server fonctionnent sur le même ordinateur.

    4. Cliquez sur OK pour enregistrer les modifications.

    Pour vérifier que le compte dispose des autorisations adéquates dans SQL Server :

    1. Connectez-vous à l'ordinateur qui exécute SQL Server en utilisant un compte disposant d'autorisations d'administrateur SQL.

    2. Dans SQL Server Management Studio, dans le volet de navigation Explorateur d'objet, développez le nœud Sécurité, puis cliquez sur le nœud Connexions. Le nom du compte d'accès de la base de données indique qu'il s'agit d'une connexion SQL.

    3. Si le compte existe, ouvrez le nœud de la base de données, ouvrez le nœud Sécurité, puis cliquez sur Rôles.

    4. Développez le nœud Rôles de base de données, cliquez avec le bouton droit sur db_owner et sélectionnez Propriétés.

    5. Dans la boîte de dialogue Propriétés des rôles de base de données, vérifiez que le compte d'accès à la base de données se trouve dans la liste Membres de ce rôle. Dans le cas contraire, cliquez sur Ajouter.

    Pour vérifier que les problèmes de bases de données sont résolus :

    1. Dans SharePoint 2010 Management Shell, exécutez la commande Windows PowerShell Get-SPSite | Format-Table -Property ID,WebApplication,ContentDatabase pour obtenir une liste des sites pour chaque application Web, afficher la liste de tous les sites dans les différentes bases de données et localiser un site donné dans chaque base de données.

    2. Naviguez jusqu'au site.

Historique des modifications


Impossible d'écrire dans le journal de suivi - Événement 5401

Nom de l'alerte : Impossible d'écrire dans le journal de suivi

ID d'événement : 5401

Résumé : Les journaux de suivi du service de journalisation unifiée (ULS, Unified Logging Service) contiennent des informations de diagnostic relatives à ce qui se passe sur un serveur Microsoft SharePoint Foundation 2010. Ces informations peuvent être utilisées pour diagnostiquer d'éventuels problèmes sur votre serveur.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Les fichiers des journaux de suivi ULS ne sont pas créés.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 5401 Description : Le service de gestion du suivi n'a pas pu créer le fichier journal de suivi à l'emplacement spécifié dans <emplacement journal>. Erreur <numéro erreur>: <description erreur>.

Cause : Cette erreur se produit lorsque le service de gestion du suivi ne peut pas créer un nouveau fichier journal.

Solution : Vérifier le journal des événements

  • Cette erreur peut se produire pour plusieurs raisons. Le numéro et la description de l'erreur décrivent la cause de l'erreur de façon plus détaillée ; utilisez les informations de la description pour déterminer les étapes de résolution les plus appropriées.

Historique des modifications


Exceptions SQL inconnues - Événement 5586

Nom de l'alerte : exceptions SQL inconnues

ID d'événement : 5586

Résumé : Microsoft SharePoint Foundation utilise des bases de données Microsoft SQL Server 2008 pour stocker les paramètres de configuration et la majeure partie du contenu du site Web. Par exemple, toutes les pages du site, les fichiers présents dans les bibliothèques de documents, les fichiers joints aux listes et les informations des listes sont stockés dans la base de données de contenu. Les paramètres de sécurité et des autorisations ainsi que d'autres paramètres de configuration sont stockés dans la base de données de configuration SQL Server 2008.

Microsoft SharePoint Foundation utilise un compte de service pour communiquer avec la base de données pour une demande d'un utilisateur. Ce compte de service peut correspondre à un nom d'utilisateur ou mot de passe spécifique (nom de domaine et mot de passe) ou à un compte système prédéfini comme le système local ou le service réseau. Lorsqu'une base de données SQL Server est créée, une valeur de la taille maximale de la base de données est définie. La taille est propre à chaque base de données. Notez qu'une application Web peut être associée à une ou à plusieurs bases de données.

Symptômes : Le symptôme suivant peut apparaître :

  • Cet événement apparaît dans le journal des événements : ID d'événement : 5586 Description : Erreur de la base de données complète sur l'instance SQL Server <nom de l'instance> dans la base de données <nom de la base de données>. Des informations supplémentaires sur l'erreur SQL Server sont décrites ci-dessous. <message d'erreur SQL>.

    Remarque :
    La description dépend du code d'erreur SQL.

Cause : une ou plusieurs des causes suivantes sont possibles :

  1. Autorisations insuffisantes pour la base de données SQL Server

  2. La base de données SQL Server est pleine

  3. Version MDAC incorrecte

  4. Base de données SQL Server introuvable

  5. Version SQL Server incorrecte

  6. Le classement SQL Server n'est pas pris en charge

  7. La base de données est en lecture seule

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les tâches suivantes.

Solution : accorder les autorisations appropriées au compte d'accès à la base de données

  • Pour résoudre ce problème, attribuez le compte d'accès à la base de données, puis vérifiez qu'il dispose de l'autorisation adéquate dans SQL Server.

    Pour attribuer le compte d'accès à la base de données

    1. Sur le site Web Administration centrale de SharePoint, cliquez sur Sécurité, puis, dans la section Sécurité générale, cliquez sur Configurer les comptes de service.

    2. Dans la page Configurer les comptes de service, dans la section Gestion des informations d'identification, sélectionnez le pool d'applications Web adéquat pour votre application Web.

    3. Dans la section Sélectionnez un compte pour ce composant, sélectionnez le compte de domaine à associer à ce pool d'applications Web ou cliquez sur Enregistrer le nouveau compte géré pour associer un nouveau compte de domaine à ce pool d'applications.

    4. Cliquez sur OK pour enregistrer les modifications.

    Pour vérifier que le compte dispose d'une autorisation appropriée dans SQL Server :

    1. Connectez-vous à l'ordinateur sur lequel SQL Server s'exécute en utilisant un compte disposant d'autorisations d'administrateur.

    2. Dans SQL Server Management Studio, dans le volet de navigation Explorateur d'objets, développez le nœud Sécurité, puis le nœud Connexions. Le nom du compte d'accès à la base de données indique qu'il s'agit d'un compte de connexion SQL, par exemple, ##MS_PolicyTsqlExecutionLogin##.

    3. Si le compte existe, développez le nœud Bases de données, développez le nœud Sécurité, puis cliquez sur Rôles.

    4. Développez le nœud Rôles de base de données, cliquez avec le bouton droit sur db_owner, puis sélectionnez Propriétés.

    5. Dans la boîte de dialogue Propriétés des rôles de base de données, vérifiez si le compte d'accès à la base de données se trouve dans la liste Membres de ce rôle. Si ce n'est pas le cas, cliquez sur Ajouter.
Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les tâches suivantes.

Solution : accroître la taille d'une base de données SQL Server

  • SharePoint Foundation ne peut pas écrire dans une base de données qui a atteint sa taille maximale. Une solution consiste à augmenter la valeur de la taille maximale pour la base de données complète, dont le nom apparaît dans le message d'événement.

    Pour accroître la taille d'une base de données :

    1. Dans SQL Server Management Studio, dans le volet de navigation Explorateur d'objets, développez le nœud de serveur, développez le nœud Bases de données, cliquez avec le bouton droit sur la base de données de votre choix, puis cliquez sur Propriétés. Le nom de la base de données est indiqué dans le message d'événement.

    2. Dans la boîte de dialogue Propriétés, dans le volet de navigation, cliquez sur Fichiers.

    3. Dans la boîte de dialogue Fichiers de la base de données, dans la colonne Croissance automatique, cliquez sur les points de suspension associés au fichier de base de données.

    4. Dans la boîte de dialogue Modifier la croissance automatique, sous Taille de fichier maximale, vérifiez si l'option Restreindre la croissance des fichiers (Mo) est sélectionnée. Si tel est le cas, augmentez la taille maximale des fichiers dans le champ situé à droite. Vous pouvez également configurer la base de données pour accroître sa taille de manière illimitée en sélectionnant l'option Croissance des fichiers illimitée.

    5. Cliquez sur OK pour enregistrer les modifications.
Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les tâches suivantes.

Solution : restaurer la base de données

  • Si la base de données SQL Server n'est pas présente ou accessible sur l'ordinateur qui exécute SQL Server, restaurez-la à partir d'une sauvegarde et reconnectez-la à SharePoint Foundation 2010.

    Pour restaurer la base de données à partir d'une sauvegarde :

    1. Copiez la sauvegarde de la base de données sur l'hôte SQL Server.

    2. Restaurez la base de données à l'aide de la commande RESTORE SQL Server . Pour plus d'informations sur la commande RESTORE , voir http://msdn.microsoft.com/fr-fr/library/ms186858(sql.90).aspx.

    Pour reconnecter la base de données dans l'Administration centrale :

    1. Dans la page Administration centrale, cliquez sur Gestion des applications, puis, dans la section Bases de données, cliquez sur Gérer les bases de données de contenu.

    2. Dans la page Gérer les bases de données de contenu, cliquez sur Ajouter une base de données de contenu, puis, dans la section Application Web, sélectionnez l'application Web.

    3. Dans la section Nom de la base de données et authentification, tapez le nom du serveur dans la zone de texte Serveur de base de données et le nom de la base de données dans la zone de texte Nom de la base de données.

    4. Cliquez sur OK pour enregistrer les modifications.

Solution : installer la version SQL Server appropriée

  • L'ordinateur qui héberge le rôle de serveur de base de données doit être doté de Microsoft SQL Server 2005 Service Pack 3 Cumulative Update (CU) 3 ou de SQL Server 2008 Service Pack 1 CU 2. Vous pouvez installer la version appropriée de SQL Server ou effectuer une mise à niveau du serveur vers celle-ci.
Remarque :
Vous devez disposer des autorisations db_owner sur la base de données pour effectuer la tâche suivante.

Solution : sélectionner le classement SQL Server approprié

  1. Connectez-vous à l'ordinateur sur lequel SQL Server est en cours d'exécution en utilisant un compte possédant des autorisations db_owner sur la base de données.

  2. Dans SQL Server Management Studio, dans le volet de navigation Explorateur d'objets, développez le nœud Bases de données. Cliquez avec le bouton droit sur la base de données qui était indiquée dans l'événement 4972, puis cliquez sur Propriétés.

  3. Sous l'onglet Général, le classement est répertorié dans la section Maintenance.

  4. Ouvrez la page Options pour modifier le classement.

  5. Sélectionnez le classement approprié dans la zone Classement.

Solution : modifier la base de données en lecture/écriture

  • Modifiez la base de données de manière à ce qu'elle soit accessible en lecture et en écriture (lecture/écriture) en effectuant les étapes suivantes pour accroître sa taille.

    Remarque :
    Vous devez disposer de l'accès db_owner à la base de données pour effectuer cette action.

    Pour accroître la taille de la base de données :

    1. Dans SQL Server Management Studio, dans le volet de navigation Explorateur d'objets, développez le nœud de serveur, puis le nœud Bases de données.

    2. Cliquez avec le bouton droit sur la base de données de votre choix, puis cliquez sur Propriétés. Le nom de la base de données est indiqué dans le message d'événement.

    3. Dans la boîte de dialogue Propriétés de la base de données, dans le volet de navigation, cliquez sur Fichiers.

    4. Dans la section Fichiers de la base de données, dans la colonne Croissance automatique, cliquez sur les points de suspension associés au fichier de base de données.

    5. Dans la boîte de dialogue Modifier la croissance automatique, dans la section Taille de fichier maximale, vérifiez si l'option Restreindre la croissance des fichiers est sélectionnée. Si tel est le cas, augmentez la taille maximale des fichiers dans le champ situé à droite. Vous pouvez également configurer la base de données pour accroître sa taille de manière illimitée en sélectionnant l'option Croissance des fichiers illimitée.

    6. Cliquez sur OK pour enregistrer les modifications.

Vérifier que les problèmes de bases de données sont résolus

  1. Dans SharePoint 2010 Management Shell, exécutez la commande Windows PowerShell Get-SPSite | Format-Table -Property ID,WebApplication,ContentDatabase pour obtenir la liste des sites pour chaque application Web afin de recenser tous les sites dans les différentes bases de données et rechercher un site dans chaque base de données.

  2. Accédez au site.

Historique des modifications


Échec de la création du site par SharePoint Foundation - Événement 6141 (Produits SharePoint 2010)

Nom de l'alerte : SharePoint Foundation n'est pas parvenu à créer un site

ID d'événement : 6141

Résumé : Dans Microsoft SharePoint Foundation 2010, les administrateurs peuvent créer de nouveaux sites SharePoint. Les propriétaires du site et, selon les paramètres du site, les visiteurs du site peuvent créer des sous-sites. Cette alerte indique qu'une tentative de création d'un site SharePoint a échoué.

Symptômes : Cet événement apparaît peut-être dans le journal des événements : ID d'événement : 6141 Description : Le site <Nom du site> n'a pas pu être créé. L'exception suivante s'est produite : <Détails de l'exception >.

Cause : Une ou plusieurs des causes suivantes sont possibles :

  • une erreur de configuration ;

  • l'utilisateur ne dispose pas d'autorisations suffisantes pour créer le site ;

  • l'utilisateur a tenté de créer un site avec un caractère non valide, tel que « + », dans le nom du site.

Pour déterminer l'erreur spécifique, voir le texte de l'exception dans la description de l'erreur.

Solution : L'utilisateur doit demander l'accès

  • Si la description de l'Événement 6141 est la suivante : « Impossible de créer le site %URLSite%. L'exception suivante s'est produite : Accès refusé. », cela signifie que l'utilisateur n'est pas autorisé à créer un site SharePoint. Les utilisateurs devront demander l'accès au site SharePoint afin qu'un administrateur SharePoint puisse mettre à jour leurs autorisations.

    Demandez à l'utilisateur de procéder comme suit :

  • Dans la page d'accueil du site, dans le coin supérieur droit de la page, cliquez en regard de « Bienvenue <nom d'utilisateur> ».

  • Cliquez sur Demander l'accès.

  • Dans la page Demander l'accès, tapez une description de votre demande, si nécessaire, puis cliquez sur Envoyer une requête.

Solution : L'utilisateur doit utiliser une autre URL

  • Si la description de l'Événement 6141 est la suivante : « Impossible de créer le site %URLSite%. L'exception suivante s'est produite : Le nom du site Web %NomSite% contient un caractère non valide. », cela signifie que l'utilisateur a tenté de créer le site à l'aide d'un caractère non valide. Demandez à l'utilisateur de recréer le site sans inclure de caractère spécial tel que « + » dans le nom.

Historique des modifications


Impossible de charger le fournisseur d'authentification - Événement 6143 (Produits SharePoint 2010)

Nom de l'alerte : Impossible de charger le fournisseur d'authentification

ID d'événement : 6143

Résumé : Pour authentifier les utilisateurs, Produits Microsoft SharePoint 2010 utilise les fournisseurs d'authentification fournis par Windows Server 2008 R2 (tels que l'authentification basée sur les formulaires ou l'authentification unique via le Web), par d'autres versions de Windows et par des fournisseurs tiers.

Lorsque vous utilisez l'authentification Kerberos v5, le compte de service utilisé par le pool d'applications IIS (Internet Information Services) de l'application Web doit être enregistré dans Active Directory comme nom principal de service (SPN) sur le domaine dont le serveur Web frontal est membre.

Cette erreur indique que le gestionnaire de rôles ou le fournisseur d'appartenance qui est spécifié pour une application Web particulière est configuré incorrectement.

Symptômes : Un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • L'authentification utilisateur ne fonctionne pas correctement, ce qui empêche les utilisateurs d'accéder au contenu.

  • Les jetons utilisateur ne sont pas mis à jour correctement à l'aide des appartenances aux rôles correctes, ce qui empêche les utilisateurs d'accéder au contenu auquel ils sont censés être autorisés à accéder d'après leurs rôles.

  • L'événement 6143 peut apparaître dans le journal des événements avec l'une des descriptions suivantes :

    • Description : Impossible d'obtenir le fournisseur d'appartenances nommé <nom du fournisseur d'appartenances>. Le fournisseur d'appartenances de ce processus n'a pas été configuré correctement. Vous devez le configurer dans le fichier .config pour chaque processus SharePoint.

    • Description : Impossible d'obtenir le gestionnaire de rôles nommé <nom du gestionnaire de rôles>. Le gestionnaire de rôles de ce processus n'a pas été configuré correctement. Vous devez le configurer dans le fichier .config pour chaque processus SharePoint.

Cause : Le gestionnaire de rôles ou le fournisseur d'appartenances spécifié pour une application Web particulière est peut-être configuré de manière incorrecte.

Solution : Vérifiez le mode d'authentification

  1. Dans la barre de lancement rapide de la page d'accueil Administration centrale, cliquez sur Sécurité.

  2. Dans la page Sécurité, dans la section Sécurité générale, cliquez sur Spécifier des fournisseurs d'authentification.

  3. Dans la page Fournisseurs d'authentification, vérifiez que l'application Web correcte est sélectionnée. Si ce n'est pas le cas, sélectionnez l'application Web à examiner.

  4. Dans la page Fournisseurs d'authentification, cliquez sur la zone dont vous souhaitez modifier les paramètres d'authentification.

  5. Dans la page Modifier l'authentification, dans la section Type d'authentification, examinez le type d'authentification sélectionné.

  6. Si Windows est sélectionné, examinez les paramètres dans la section Paramètres d'authentification IIS. Si Formulaires ou Authentification unique Web, examinez les paramètres dans les sections Nom du fournisseur d'appartenances et Nom du gestionnaire de rôles .

  7. Cliquez sur Annuler pour fermer sans enregistrer les modifications.

Solution : Configurez le mode d'authentification Kerberos v5

  1. Cette procédure n'est nécessaire que si vous utilisez l'authentification Kerberos v5.

  2. Vous devez être membre du groupe Administrateurs SharePoint pour effectuer cette tâche.

  3. Contactez un administrateur de domaine et vérifiez que le compte de service utilisé par le pool d'applications est enregistré comme nom principal de service pour tous les domaines associés à l'application Web.

    Remarque :
    Si vous n'avez pas besoin d'utiliser obligatoirement l'authentification Kerberos v5 ou si vous ne pouvez pas configurer le nom principal de service, utilisez plutôt l'authentification NTLM. Si vous utilisez l'authentification Kerberos v5 et que vous ne parvenez pas à configurer le nom principal de service, seuls les administrateurs de serveur pourront être authentifiés sur le site. Pour modifier le type d'authentification, voir la procédure « Configurer le mode d'authentification NTLM » plus loin dans cet article.

    Pour plus d'informations sur la façon de configurer Produits SharePoint 2010 de façon à utiliser l'authentification Kerberos v5, voir l'article 832769 de la Base de connaissances Microsoft intitulé Comment faire pour configurer un serveur virtuel Windows SharePoint Services pour utiliser l'authentification Kerberos et comment faire pour revenir ensuite à l'authentification NTLM.

Solution : Configurez le mode d'authentification NTLM

  1. Dans la barre de lancement rapide de la page d'accueil Administration centrale, cliquez sur Sécurité.

  2. Dans la page Sécurité, dans la section Sécurité générale, cliquez sur Spécifier des fournisseurs d'authentification.

  3. Dans la page Fournisseurs d'authentification, vérifiez que l'application Web correcte est sélectionnée. Si ce n'est pas le cas, sélectionnez l'application Web à examiner.

  4. Dans la page Fournisseurs d'authentification, cliquez sur la zone dont vous souhaitez modifier les paramètres d'authentification.

  5. Dans la page Modifier l'authentification, dans la section Type d'authentification, sélectionnez Authentification Windows.

  6. Sous Paramètres d'authentification IIS, vérifiez que la case à cocher Authentification Windows intégrée est activée, puis cliquez sur NTLM.

  7. Cliquez sur OK pour enregistrer les modifications.

Solution : Configurez le mode d'authentification unique via le Web ou basée sur les formulaires

  1. Cette procédure n'est nécessaire que si vous utilisez l'authentification Kerberos v5.

  2. Vous devez être membre du groupe Administrateurs SharePoint pour effectuer cette tâche.

  3. Examinez la documentation du fournisseur d'authentification unique via le Web ou basée sur les formulaires. Vérifiez que les composants corrects pour le fournisseur sont installés sur le serveur et que les paramètres du fournisseur sont configurés correctement dans le fichier Web.config du répertoire IIS de l'application Web. Prenez note du nom du fournisseur d'appartenances et du nom du gestionnaire de rôles mentionnés dans le fichier Web.config.

  4. Dans la barre de lancement rapide de la page d'accueil Administration centrale, cliquez sur Sécurité.

  5. Dans la page Sécurité, dans la section Sécurité générale, cliquez sur Spécifier des fournisseurs d'authentification.

  6. Dans la page Fournisseurs d'authentification, cliquez sur la zone correcte.

  7. Dans la page Modifier l'authentification, dans la section Authentification par revendications, prenez note du Nom du fournisseur d'appartenances ASP.NET. Vérifiez que ce nom est identique à celui mentionné dans le fichier Web.config.

  8. Prenez note du Nom du gestionnaire de rôles ASP.NET. Vérifiez que ce nom est identique à celui mentionné dans le fichier Web.config.

Historique des modifications


Autorisations insuffisantes pour écrire dans le cache de données de configuration - Événement 6395

Nom de l'alerte : Autorisations insuffisantes pour écrire dans le cache de données de configuration

ID d'événement : 6395

Résumé : Plusieurs fonctionnalités de Microsoft SharePoint Foundation 2010 reposent sur des processus en arrière-plan planifiés nommés travaux du minuteur. Les administrateurs peuvent configurer et planifier des travaux de minuteur en utilisant l'Administration centrale SharePoint. Lorsque vous utilisez la page Services sur le serveur du site Web Administration centrale SharePoint pour démarrer ou interrompre un service, un travail de minuteur effectue cette action.

Pour améliorer les performances de SharePoint Foundation 2010, la plupart des données de la base de données de configuration dans SQL Server 2008 sont conservées dans un cache du système de fichiers local, dénommé cache de données de configuration. SharePoint Foundation 2010 utilise le service de minuteur pour que ce cache reste synchronisé avec la base de données de configuration.

Cette erreur indique qu'un problème d'autorisation empêche des comptes approuvés d'écrire dans le répertoire %systemdrive%\Users\AllUsers\Microsoft\SharePoint\Config directory.

Symptômes : Le message suivant peut apparaître dans le journal des événements : ID d'événement : 6395 Autorisations insuffisantes pour écrire dans le cache de données de configuration. Plus d'informations sont comprises ci-dessous.

Cause : Le répertoire du cache de configuration a des paramètres de sécurité qui empêche l'accès en écriture à son contenu. Bien qu'ils puissent être mis à jour à l'échelle de la batterie de serveurs, les objets de configuration ne sont pas mis à jour localement.

Solution : attribution d'autorisations suffisantes sur le cache des données de configuration

  • Vérifiez que les groupes locaux WSS_ADMIN_WPG et WSS_RESTRICTED_WPG ont les autorisations nécessaires pour écrire dans le répertoire %systemdrive%\Users\All Users\Microsoft\SharePoint\Config. Vous devez disposer des autorisations Modifier dans ce répertoire pour effectuer cette action.

Historique des modifications


Échec de la mise à jour des mappages des accès de substitution - Événement 6397

Nom de l'alerte : Échec de la mise à jour des mappages des accès de substitution

ID d'événement : 6397

Résumé : Plusieurs fonctionnalités de Microsoft SharePoint Foundation 2010 ont recours à des processus d'arrière-plan planifiés appelés « travaux du minuteur ». Les administrateurs peuvent configurer et planifier des travaux du minuteur par le biais de l'Administration centrale de SharePoint. Lorsque vous utilisez la page Services sur le serveur dans le site Web Administration centrale de SharePoint pour démarrer ou arrêter un service, un travail du minuteur effectue cette action.

Pour améliorer les performances de SharePoint Foundation 2010, la plupart des données de la base de données de configuration de SQL Server 2008 sont conservées dans un cache du système de fichiers local, appelé « cache des données de configuration ». SharePoint Foundation 2010 utilise le service de minuteur pour maintenir ce cache synchronisé avec la base de données de configuration. Le mappage des accès de substitution est une fonctionnalité de Microsoft SharePoint Foundation 2010 permettant aux administrateurs de configurer un système avec équilibrage de la charge en mappant une URL entrante à des URL de substitution qui sont utilisées par SharePoint Foundation.

Cette erreur se produit lorsque le travail de minuteur utilisé pour mettre à jour les mappages d'accès de substitution a échoué sur le serveur spécifié.

Symptômes : Un ou plusieurs des symptômes suivants peuvent apparaître :

  • Les paramètres des mappages d'accès de substitution pour les applications Web applications sur le serveur local peuvent ne pas être à jour.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6397 La mise à jour du mappage des accès de substitution a échoué. Application Web affectée : <application Web>. Utilisateur actuel : <nom d'utilisateur>. Pour plus d'informations, voir ci-dessous.

Cause : Le mappage d'accès de substitution spécifié dans le cache de configuration n'a pas été appliqué aux paramètres IIS de l'ordinateur local.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie sur le site Administration centrale pour effectuer la tâche suivante.

Solution : Mettre à jour le mappage des accès de substitution

  • La chaîne de caractères de l'événement 6397 indique le mappage d'accès de substitution qui a échoué. Essayez de recréer le mappage à l'aide du site Administration centrale.

    Pour afficher ou modifier les paramètres de mappage des accès de substitution :

    1. Dans la page Administration centrale, cliquez sur Gestion des applications puis, dans la section Applications Web, cliquez sur Configurer les mappages d'accès de substitution.

    2. Pour modifier un mappage, cliquez sur celui-ci.

    Pour vérifier que le mappage des accès de substitution est correct :

    • Si le service d'administration SharePoint a été redémarré, dans SharePoint 2010 Management Shell, exécutez la commande Windows PowerShell Start-SPAdminJob pour vérifier que toutes les tâches requises par le service d'administration ont été effectuées.

Historique des modifications


Échec de l'exécution du minuteur Instance Service - Événement 6398

Nom de l'alerte : l'exécution du travail du minuteur SPServiceInstance a échoué

ID d'événement : 6398

Résumé : plusieurs fonctionnalités de Microsoft SharePoint Foundation 2010 reposent sur des processus en arrière-plan planifiés, appelés travaux du minuteur. Les administrateurs peuvent configurer, planifier et afficher l'état de ces travaux à l'aide de site Web Administration centrale de SharePoint.

Symptômes : Le symptôme suivant peut apparaître :

  • Cet événement apparaît dans le journal des événements : Event ID : 6398 La méthode Execute de la définition de travail <nom de la définition de travail> (ID <ID de travail>) a généré une exception. Plus d'informations sont disponibles ci-dessous. %n%n <Détails du travail>

    Définitions de travail les plus courantes :

    • SPPasswordManagementJobDefinition

      Objectif : envoie un courrier électronique et enregistre les événements dans un journal pour les mots de passe arrivant à expiration et les modifications de mot de passe. Grâce à ce travail du minuteur, les mots de passe gérés sont modifiés avant leur expiration.

    • SPGeneratePasswordJobDefinition

      Objectif : génère un nouveau mot de passe pour un compte, met à jour le mot de passe du compte, puis exécute des travaux pour déployer le nouveau mot de passe partout où il est requis.

    • SPAdminAppPoolCredentialDeploymentJobDefinition

      Objectif : met à jour les informations d'identification pour le pool d'applications Internet Information Services (IIS) 7.0 d'administration dans la batterie de serveurs.

    • SPContentAppPoolCredentialDeploymentJobDefinition

      Objectif : met à jour les informations d'identification d'un pool d'applications IIS de contenu sur tous les serveurs de la batterie.

    • SPWindowsServiceCredentialDeploymentJobDefinition

      Objectif : met à jour les informations d'identification d'un service Windows sur chaque ordinateur de la batterie sur lequel il est en cours d'exécution.

    • SPMasterPassphraseDeploymentJobDefinition

      Objectif : indique à toutes les applications Web frontales la nouvelle clé dérivée de la phrase secrète. Cette tâche est exécutée lorsque l'administrateur décide de modifier la phase secrète de la batterie de serveurs.

Cause : une ou plusieurs des causes suivantes sont possibles :

  • Le travail du minuteur d'un fournisseur tiers est introuvable ou endommagé.

  • Le travail du minuteur Microsoft SharePoint Foundation 2010 tiers est introuvable ou endommagé.

  • Causes de travail les plus courantes :

    • SPPasswordManagementJobDefinition

      Problème : les travaux du minuteur de modification du mot de passe (SPGeneratePasswordJobDefinition) n'ont pas été planifiés ou mis à jour pour les informations d'identification de la batterie de serveurs. Tout ajout ou toute modification réalisé récemment dans les planifications des modifications de mot de passe pour des informations d'identification dans la batterie de serveurs ne sera mis à jour de manière à refléter les modifications qu'une fois ce travail correctement exécuté.

    • SPGeneratePasswordJobDefinition

      Problème : un travail du minuteur planifié pour créer un mot de passe pour une information d'identification d'une batterie de serveurs a échoué. La valeur d'information d'identification actuelle n'est peut-être plus valide et doit être mise à jour manuellement dans le compte Active Directory. Si les informations d'identification du compte sont toujours valides, ce travail du minuteur doit être redémarré.

    • SPAdminAppPoolCredentialDeploymentJobDefinition

      Problème : les nouvelles informations d'identification du pool d'applications Web Administration centrale n'ont pas été mises à jour sur l'ordinateur local de manière à ce qu'elles correspondent à la valeur actuelle configurée pour la batterie de serveurs. Cela risque d'empêcher le démarrage de l'application Web Administration centrale.

    • SPContentAppPoolCredentialDeploymentJobDefinition

      Problème : les nouvelles informations d'identification du pool d'applications n'ont pas été mises à jour sur l'ordinateur local de manière à ce qu'elles correspondent à la valeur actuelle configurée pour la batterie de serveurs. Cela risque d'empêcher le démarrage de l'application Web.

    • SPWindowsServiceCredentialDeploymentJobDefinition

      Problème : les nouvelles informations d'identification du service n'ont pas été mises à jour sur l'ordinateur local de manière à ce qu'elles correspondent à la valeur actuelle configurée pour la batterie de serveurs. Cela risque d'empêcher le démarrage du service.

    • SPMasterPassphraseDeploymentJobDefinition

      Problème : le mot de passe principal de la batterie de serveurs n'a pas été mis à jour sur l'ordinateur local de manière à ce qu'il corresponde à la valeur actuelle configurée pour la batterie de serveurs. Cela risque d'empêcher le déchiffrement ou le chiffrement de la clé de chiffrement de la batterie de serveurs tant qu'il n'a pas été mis à jour localement.

Solution : déterminer la solution appropriée

  • À partir du nom de la définition de travail indiqué dans la description de l'événement, déterminez la solution appropriée :

    • SPPasswordManagementJobDefinition

      Solution : redémarrez ce travail du minuteur.

    • SPGeneratePasswordJobDefinition

      Solution : redémarrez ce travail du minuteur pour imposer manuellement une réinitialisation du mot de passe.

    • SPAdminAppPoolCredentialDeploymentJobDefinition

      Solution : redémarrez ce travail du minuteur pour exécuter les travaux de déploiement administrateur localement, afin d'imposer manuellement une réinitialisation du mot de passe.

    • SPContentAppPoolCredentialDeploymentJobDefinition

      Solution : redémarrez ce travail du minuteur pour exécuter les travaux de déploiement administrateur localement, afin d'imposer manuellement une réinitialisation du mot de passe.

    • SPWindowsServiceCredentialDeploymentJobDefinition

      Solution : redémarrez ce travail du minuteur pour exécuter les travaux de déploiement administrateur localement, afin d'imposer manuellement une réinitialisation du mot de passe.

    • SPMasterPassphraseDeploymentJobDefinition

      Solution : redémarrez ce travail du minuteur pour exécuter les travaux de déploiement administrateur localement, afin d'imposer manuellement une réinitialisation du mot de passe.

Pour les solutions de tous les autres travaux du minuteur, suivez les étapes de la section suivante. Pour résoudre le problème en question, utilisez la solution qui correspond à la cause que vous avez identifiée dans la section « Symptômes ». Une fois effectuées les étapes de la solution, reportez-vous à la section « Vérifier » pour vérifier que la fonctionnalité est opérationnelle.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer ces tâches.

Solution : configurer un travail du minuteur défectueux

  • Si vous ne trouvez pas l'assembly défectueux ou s'il est endommagé et qu'il ne s'agit pas d'un assembly SharePoint Foundation 2010, et que la définition du minuteur est un travail récurrent, vous devez désactiver le travail du minuteur défectueux.

    Pour désactiver le travail du minuteur défectueux :

    1. Dans la page Administration centrale, cliquez sur Analyse, puis, dans la section Travaux du minuteur, cliquez sur Examiner les définitions de travail.

    2. Recherchez le travail du minuteur dans la liste, puis cliquez sur le nom de la définition du travail du minuteur.

    3. Dans la page Modifier le travail du minuteur, cliquez sur Désactiver.

      Les travaux du minuteur désactivés sont accompagnés de la mention Désactivé dans la colonne Type de planification.

    Pour activer le travail du minuteur défectueux :

    1. Dans la page Administration centrale, cliquez sur Analyse, puis, dans la section Travaux du minuteur, cliquez sur Examiner les définitions de travail.

    2. Recherchez le travail du minuteur dans la liste, puis cliquez sur le nom de la définition du travail du minuteur.

    3. Dans la page Modifier le travail du minuteur, cliquez sur Activer.
Remarque :
Pour réaliser la procédure suivante, vous devez être membre du groupe Administrateurs sur l'ordinateur local.

Solution : réparer l'installation Windows SharePoint Services

  • Si l'assembly défectueux est introuvable ou endommagé et qu'il s'agit d'un assembly Microsoft SharePoint Foundation, vous devez réparer l'installation SharePoint Foundation pour restaurer ou réparer l'assembly.

    Remarque :
    La réparation de l'installation impose de redémarrer le serveur. Les modifications des applications Web et des autres paramètres sont conservées.

    Pour démarrer l'installation SharePoint Foundation :

    • Exécutez l'Assistant d'installation de Microsoft SharePoint Foundation 2010, sélectionnez l'option Réparer, puis cliquez sur Continuer.

    Pour vérifier que le travail du minuteur fonctionne :

    1. Si le travail du minuteur est un travail récurrent, accédez à la page Définitions du travail du minuteur et activez le travail du minuteur. Le travail doit être exécuté lors du prochain intervalle normalement planifié.

    2. Si le travail du minuteur est un travail ponctuel uniquement, réessayez la commande qui a déclenché le travail.

Historique des modifications


Espace disque libre insuffisant pour le service de journalisation unifié (ULS, Unified Logging Service) - Événement 6457

Nom de l'alerte : Espace disque libre insuffisant pour le service de journalisation unifié (ULS, Unified Logging Service)

ID d'événement : 6457

Résumé : Le service de suivi (SPTracev4) de Microsoft SharePoint Foundation est utilisé par Microsoft SharePoint Foundation 2010 pour gérer les messages de suivi générés. Lorsque la journalisation du suivi est activée, les administrateurs peuvent spécifier le chemin d'accès qui est utilisé pour stocker les journaux de suivi. Ce fichier journal est utilisé par beaucoup d'applications basées sur SharePoint Foundation. Le journal de suivi contient des informations utiles pour le diagnostic des problèmes des serveurs. SharePoint Foundation 2010 n'a pas pu écrire dans le journal de suivi. Cet événement se produit lorsqu'il n'y a pas suffisamment d'espace libre disponible pour la journalisation.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Le journal de suivi ne contient pas de nouvelles données.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6457 Description : Espace disque libre insuffisant. Le service de suivi arrête temporairement d'envoyer les messages de suivi au fichier journal. Le suivi reprendra lorsque plus de <nombre de Mo nécessaires pour la reprise de la journalisation> Mo d'espace disque seront libérés.

Cause : L'emplacement configuré pour les journaux n'a pas suffisamment d'espace disque libre pour la journalisation.

Solution : Libérer de l'espace disque

  1. Utilisez l'outil Nettoyage de disque pour libérer de l'espace disque là où les journaux de suivi sont stockés.

  2. Vérifiez que le journal de suivi dispose d'un espace disque suffisant pour fonctionner correctement.

  3. Si le journal de suivi n'a pas suffisamment d'espace disque, nettoyez les dossiers temporaires sur le lecteur.

  4. Si cette procédure ne résout pas le problème, il est également possible de déplacer le fichier du journal de suivi vers une partition où il y a davantage d'espace.

Solution : Déplacer le fichier journal

  1. Sur le site Web Administration centrale de SharePoint, cliquez sur Analyse et, dans la section Création de rapports, cliquez sur Configurer la journalisation des diagnostics.

  2. Dans la page Journalisation des diagnostics, dans la section Journal de suivi, entrez le nouvel emplacement des fichiers journaux de suivi dans la zone Chemin d'accès.

  3. Cliquez sur OK.

Historique des modifications


Accès refusé pour écrire dans le Registre - Événement 6588

Nom de l'alerte : l'accès en écriture au registre a été refusé

ID d'événement : 6588

Résumé : cette erreur se produit lorsqu'un pool d'applications IIS utilisé par Microsoft SharePoint Foundation 2010 essaie de mettre à jour une clé de Registre et que l'accès lui est refusé, car le compte de service qu'il utilise ne dispose pas des autorisations adéquates.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Des clés de Registre ne sont pas mises à jour correctement pour refléter les paramètres configurés.

  • Cet événement apparaît dans le journal des événements : ID événement : 6588 Description : Le compte du pool d'applications <nom du compte> ne peut pas écrire la clé de registre <nom de la clé> sur <emplacement de la clé>. Plus d'informations ci-dessous.

Cause : le compte de service du pool d'applications IIS utilisé par SharePoint Foundation 2010 ne dispose pas des autorisations d'accès appropriées pour écrire dans une clé de Registre.

Solution : accorder les autorisations appropriées au compte du pool d'applications

  • Le compte du pool d'applications Web ne dispose pas d'autorisations suffisantes pour écrire dans le registre ou dans un fichier sur le disque. Dans un premier temps, essayez de corriger les autorisations SharePoint Foundation 2010 à l'aide de l'outil en ligne de commande Psconfig. Si cette opération ne permet pas de résoudre le problème, utilisez les procédures suivantes dans l'ordre indiqué. Déterminez d'abord le compte utilisé pour l'application Web.

    Remarque :
    Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les procédures suivantes.

    Pour corriger les autorisations SharePoint Foundation 2010 :

    1. Ouvrez une fenêtre d'invite de commandes et, à l'invite, tapez la commande suivante :

      cd /d %commonprogramfiles%\Microsoft Shared\Web server extensions\14\BIN

    2. Corrigez les autorisations sur le serveur en entrant la commande suivante :

      psconfig -cmd secureresources

    3. Redémarrez IIS et apportez les modifications en entrant la commande suivante depuis l'invite de commandes : iisreset /noforce

    Pour déterminer le compte de l'application Web :

    1. Dans le Gestionnaire IIS, dans le volet Connexions, développez le nœud de serveur, puis cliquez sur Pools d'applications.

    2. Dans le volet de lecture, dans la vue des fonctionnalités, dans la colonne Identité, notez le compte du pool d'applications que vous avez identifié.

    Pour définir manuellement le compte de groupe requis pour le compte du pool d'applications Web sur l'ordinateur :

    1. Cliquez sur Démarrer, cliquez sur Outils d'administration, puis cliquez sur Gestion de l'ordinateur.

    2. Dans l'arborescence, développez Utilisateurs et groupes locaux, puis cliquez sur le dossier Groupes.

    3. Dans la liste du volet de lecture, cliquez avec le bouton droit sur WSS_WPG, puis cliquez sur Ajouter au groupe.

    4. Dans la boîte de dialogue Propriétés WSS_WPG, ajoutez le compte du pool d'applications Web en cliquant sur Ajouter.

    Pour accorder au compte du pool d'applications Web des autorisations requises pour un dossier :

    1. Sur l'ordinateur SharePoint Foundation, recherchez le dossier identifié dans l'événement 6588 ou 6589.

    2. Cliquez avec le bouton droit sur le dossier et sélectionnez Propriétés.

    3. Dans la boîte de dialogue Propriétés, sous l'onglet Sécurité, dans la section Groupes ou noms d'utilisateurs, sélectionnez Tout le monde, puis cliquez sur Modifier.

      Remarque :
      Une modification incorrecte du Registre peut endommager gravement le système. Avant d'apporter des modifications au Registre, sauvegardez les données de valeur stockées dans l'ordinateur.

    4. Dans la boîte de dialogue Autorisations pour <nom_dossier>, cliquez sur Ajouter pour ajouter le compte du pool d'applications Web. Le compte requiert l'autorisation d'écriture.

    Pour accorder au compte du pool d'applications Web les autorisations requises pour une clé de Registre :

    1. Cliquez successivement sur le bouton Démarrer, sur Tous les programmes, sur Accessoires, puis sur Exécuter.

    2. Tapez regedit, puis cliquez sur OK.

    3. Dans l'Éditeur du Registre, dans l'arborescence, recherchez la clé de Registre identifiée dans l'événement 6588 ou 6589.

    4. Cliquez avec le bouton droit sur la clé de Registre et sélectionnez Autorisations.

    5. Dans la boîte de dialogue Autorisations, cliquez sur Ajouter pour ajouter le compte du pool d'applications Web. Le compte nécessitera l'autorisation d'écriture.

    Pour vérifier :

    • Renouvelez l'opération qui a précédemment échoué.

Historique des modifications


Accès en écriture sur le disque refusé - Événement 6589

Nom de l'alerte : l'accès en écriture au disque a été refusé

ID d'événement : 6589

Résumé : cette erreur se produit lorsqu'un pool d'applications Internet Information Services (IIS) 7.0 utilisé par Microsoft SharePoint Foundation 2010 essaie de mettre à jour un fichier ou un dossier et que l'accès lui est refusé car le compte de service utilisé par le pool d'applications ne dispose pas des autorisations adéquates.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Des fichiers ne sont pas mis à jour correctement pour refléter les paramètres configurés.

  • Cet événement apparaît dans le journal des événements : ID événement : 6589 Description : Le compte du pool d'applications <nom du compte> ne dispose pas des autorisations suffisantes pour enregistrer le fichier <nom du fichier> sur <emplacement du fichier>. Plus d'informations ci-dessous.

Cause : le compte de service du pool d'applications IIS utilisé par SharePoint Foundation 2010 ne dispose pas des autorisations appropriées pour écrire dans un fichier ou un dossier dans le système de fichiers NTFS.

Solution : accorder les autorisations appropriées au compte du pool d'applications

  • Le compte du pool d'applications Web ne dispose pas d'autorisations suffisantes pour écrire dans le registre ou dans un fichier sur le disque. Dans un premier temps, essayez de corriger les autorisations SharePoint Foundation 2010 à l'aide de l'outil en ligne de commande Psconfig. Si cette opération ne permet pas de résoudre le problème, utilisez les procédures suivantes dans l'ordre indiqué. Déterminez d'abord le compte utilisé pour l'application Web.

    Remarque :
    Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les procédures suivantes.

    Pour corriger les autorisations SharePoint Foundation 2010 :

    1. Ouvrez une fenêtre d'invite de commandes et, à l'invite, tapez la commande suivante :

      cd /d %commonprogramfiles%\Microsoft Shared\Web server extensions\14\BIN

    2. Corrigez les autorisations sur le serveur en entrant la commande suivante :

      psconfig -cmd secureresources

    3. Redémarrez IIS et apportez les modifications en entrant la commande suivante depuis l'invite de commandes : iisreset /noforce

    Pour déterminer le compte de l'application Web :

    1. Dans le Gestionnaire IIS, dans le volet Connexions, développez le nœud de serveur, puis cliquez sur Pools d'applications.

    2. Dans le volet de lecture, dans la vue des fonctionnalités, dans la colonne Identité, notez le compte du pool d'applications que vous avez identifié.

    Pour définir manuellement le compte de groupe requis pour le compte du pool d'applications Web sur l'ordinateur :

    1. Cliquez sur Démarrer, cliquez sur Outils d'administration, puis cliquez sur Gestion de l'ordinateur.

    2. Dans l'arborescence, développez Utilisateurs et groupes locaux, puis cliquez sur Groupes.

    3. Dans la liste du volet de lecture, cliquez avec le bouton droit sur les groupes WSS_WPG, puis cliquez sur Ajouter au groupe.

    4. Dans la boîte de dialogue Propriétés WSS_WPG, ajoutez le compte du pool d'applications Web en cliquant sur Ajouter.

    Pour accorder au compte du pool d'applications Web des autorisations requises pour un dossier :

    1. Sur l'ordinateur SharePoint Foundation, recherchez le dossier identifié dans l'événement 6588 ou 6589.

    2. Cliquez avec le bouton droit sur le dossier et sélectionnez Propriétés.

    3. Dans la boîte de dialogue Propriétés, sous l'onglet Sécurité, dans la section Groupes ou noms d'utilisateurs, sélectionnez Tout le monde, puis cliquez sur Modifier.

      Remarque :
      Une modification incorrecte du Registre peut endommager gravement le système. Avant d'apporter des modifications au Registre, sauvegardez les données de valeur stockées dans l'ordinateur.

    4. Dans la boîte de dialogue Autorisations pour <nom_dossier>, cliquez sur Ajouter pour ajouter le compte du pool d'applications Web. Le compte requiert l'autorisation d'écriture.

    Pour accorder au compte du pool d'applications Web les autorisations requises pour une clé de Registre :

    1. Cliquez successivement sur le bouton Démarrer, sur Tous les programmes, sur Accessoires, puis sur Exécuter.

    2. Tapez regedit, puis cliquez sur OK.

    3. Dans l'Éditeur du Registre, dans l'arborescence, recherchez la clé de Registre identifiée dans l'événement 6588 ou 6589.

    4. Cliquez avec le bouton droit sur la clé de Registre et sélectionnez Autorisations.

    5. Dans la boîte de dialogue Autorisation, cliquez sur Ajouter pour ajouter le compte du pool d'applications Web. Le compte nécessitera l'autorisation d'écriture.

    Pour vérifier :

    • Renouvelez l'opération qui a précédemment échoué.

Historique des modifications


Le compte de pool d'applications doit être enregistré en tant que Kerberos - Événement 6590

Nom de l'alerte : Le compte du pool d'applications doit être enregistré en tant que Kerberos

ID d'événement : 6590

Résumé : Microsoft SharePoint Foundation 2010 peut utiliser les fournisseurs d'authentification que procure Windows Server 2008 pour authentifier les utilisateurs. Par exemple, Microsoft SharePoint Foundation peut utiliser l'authentification à base de formulaires ou l'authentification via le Web.

Lors de l'utilisation du protocole d'authentification Kerberos version 5, le compte de service qui est utilisé par le pool d'applications Internet Information Services (IIS) de votre application Web doit être inscrit dans les services AD DS (Active Directory Domain Services) comme SPN sur le domaine auquel appartient le serveur Web frontal.

Symptômes : Cet événement figure dans le journal des événements : ID d'événement : 6590 Description : le compte du pool d'applications ne dispose pas des autorisations suffisantes pour ajouter des comptes d'utilisateurs dans Active Directory. Lorsque vous utilisez l'authentification Kerberos, le compte de service utilisé par le pool d'applications IIS (Internet Information Services) de l'application Web doit être enregistré dans Active Directory comme nom principal de service (SPN) sur le domaine dont fait partie le serveur Web frontal.

Cause : La cause peut être une ou plusieurs des propositions suivantes :

  • Si vous utilisez l'authentification Kerberos v5, le compte du pool d'applications Web n'est pas un nom de fournisseur de sécurité enregistré.

  • Si vous utilisez l'authentification à base de formulaires ou l'authentification unique via le Web, le fournisseur d'authentification n'a pas pu être chargé, car aucun nom de fournisseur d'appartenances n'a été spécifié.

  • Le pool d'applications Web doit être redémarré pour que les modifications soient enregistrées.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour réaliser l'opération suivante.

Solution : Déterminer quel type d'authentification le site utilise

  1. Sur le site Web Administration centrale de SharePoint, dans la barre de lancement rapide, cliquez sur Sécurité. Dans la section Sécurité générale, cliquez sur Spécifier des fournisseurs d'authentification.

  2. Dans la page Fournisseurs d'authentification, sélectionnez l'application adéquate. Pour ce faire, cliquez sur la liste déroulante Application Web et cliquez sur Modifier Application Web. Dans la boîte de dialogue Sélectionner une application Web, cliquez sur l'application Web adéquate.

  3. Dans la page Fournisseurs d'authentification, cliquez sur la zone du site dans la liste.

  4. Dans la page Modifier l'authentification, le type d'authentification est affiché dans la section Paramètres d'authentification IIS.

Solution : Inscrire le compte du pool d'applications comme SPN

  • Le compte du pool d'applications Web n'est pas un nom de fournisseur de sécurité enregistré (SPN). Contactez un administrateur de domaine et assurez-vous que le compte de service utilisé par le pool d'applications est inscrit comme nom principal de service (SPN) pour tous les domaines associés à l'application Web.
Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour réaliser ces tâches.

Solution : Spécifier le nom du fournisseur d'appartenances et un gestionnaire de rôles

  1. Dans la page Administration centrale, dans la barre de lancement rapide, cliquez sur Sécurité. Dans la section Sécurité générale, cliquez sur Spécifier les fournisseurs d'authentification.

  2. Dans la page Fournisseurs d'authentification, sélectionnez la zone dont vous souhaitez modifier les paramètres d'authentification.

  3. Dans la page Modifier l'authentification, dans la section Type d'authentification, sélectionnez l'option Formulaires ou Authentification unique Web. L'option Authentification Windows est sélectionnée par défaut.

  4. Cliquez sur Enregistrer.

  5. Dans la section Nom du fournisseur d'appartenances, tapez le nom dans la zone de texte Nom du fournisseur d'appartenances.

  6. Dans la section Nom du gestionnaire de rôles, tapez le nom dans la zone de texte Nom du gestionnaire de rôles.

  7. Cliquez sur Enregistrer.

Solution : Modifier les paramètres d'authentification pour une zone

  1. Dans la page Administration centrale, dans la barre de lancement rapide, cliquez sur Sécurité. Dans la section Sécurité générale, cliquez sur Spécifier les fournisseurs d'authentification.

  2. Dans la page Fournisseurs d'authentification, sélectionnez la zone dont vous souhaitez modifier les paramètres d'authentification.

  3. Dans la page Modifier l'authentification, dans la section Type d'authentification, sélectionnez l'option d'authentification. L'option Authentification Windows est sélectionnée par défaut.

  4. Dans la section Paramètres d'authentification IIS, sélectionnez un paramètre. L'Authentification Windows intégrée — NTLM est sélectionnée par défaut. Si vous sélectionnez Négocier (Kerberos), vous devez effectuer des tâches supplémentaires pour configurer l'authentification.

  5. Cliquez sur Enregistrer.

Historique des modifications


Le service SMTP n'est pas en cours d'exécution - Événement 6599 (produits SharePoint 2010)

Nom d'alerte : le service SMTP n'est pas en cours d'exécution

ID d'événement : 6599

Résumé : Produits Microsoft SharePoint 2010 envoie des alertes et d'autres messages d'administration Produits SharePoint 2010 à l'aide d'un serveur de messagerie SMTP (Simple Mail Transfer Protocol). Lorsque Produits SharePoint 2010 est configuré pour recevoir le courrier entrant, le service SMTP remet les messages dans un dossier de dépôt. Un travail de minuteur SharePoint analyse le dossier de dépôt et insère les messages dans des listes SharePoint.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Produits SharePoint 2010 ne reçoit pas de courrier électronique entrant.

  • Certains serveurs Web frontaux reçoivent du courrier électronique entrant, tandis que d'autres n'en reçoivent pas.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6599 Description : une erreur s'est produite lors de la connexion au service SMTP de Windows.

Cause : la configuration automatique pour le courrier électronique entrant est activée et le service SMTP de Windows n'est pas installé sur un ou plusieurs serveurs, ou le service SMTP de Windows n'est pas en cours d'exécution sur un ou plusieurs serveurs.

Remarque :
Le serveur SMTP n'est pas installé par défaut. Vous pouvez ajouter SMTP à l'aide de la zone Résumé des fonctionnalités du Gestionnaire de serveur dans Windows Server 2008 R2.

Résolution : configurer les paramètres du courrier électronique sortant dans l'Administration centrale

  1. Remarque :
    SMTP est désactivé par défaut dans SharePoint Foundation 2010.

    Dans la page d'accueil Administration centrale, cliquez sur Paramètres système puis, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer les paramètres du courrier électronique sortant.

  2. Dans la page Paramètres du courrier électronique sortant, dans la section Paramètres de messagerie, tapez le nom du serveur SMTP adéquat dans la zone Serveur SMTP sortant.

Résolution : activer et configurer le service SMTP

  • Effectuez les étapes décrites dans l'article suivant : IIS 7.0 : Configurer le courrier électronique SMTP (http://technet.microsoft.com/fr-fr/library/cc772058(ws.10).aspx).

Résolution: démarrer le service SMTP

  1. Remarque :
    Dans le Gestionnaire des Services Internet (IIS) 6.0, connectez-vous au serveur SMTP.

    Développez le nœud du serveur, puis recherchez le serveur virtuel SMTP utilisé par Produits SharePoint 2010.

  2. Cliquez avec le bouton droit sur le serveur virtuel approprié, puis cliquez sur Démarrer.

Historique des modifications


Échec du chargement du gestionnaire d'événements : Événement 6644 (Produits SharePoint 2010)

Nom de l'alerte : échec du chargement du gestionnaire d'événements

ID d'événement : 6644

Résumé : dans Microsoft SharePoint Foundation 2010, vous pouvez lier un gestionnaire d'événements à un hôte d'événements (tel qu'un site entier, une liste ou une bibliothèque de documents). Cette opération vous permet d'utiliser des événements de bibliothèque de documents pour démarrer d'autres processus, tels que des processus de flux de travail.

Symptômes : cet événement figure dans le journal des événements : ID d'événement : 6644 Description : Erreur du Gestionnaire d'événements : <erreur>.

Cause : la ou les causes peuvent être :

  • L'assembly du récepteur d'événements personnalisé est introuvable ou est endommagé.

  • L'assembly SharePoint Foundation 2010 est introuvable ou est endommagé.

Solution: contacter le fabricant du récepteur d'événements personnalisé défectueux

  • Si l'assembly du récepteur d'événements défectueux est endommagé et qu'il ne s'agit pas d'un assembly SharePoint Foundation 2010, contactez son fabricant pour obtenir des informations supplémentaires.

Solution : réparer l'installation du produit

  1. La réparation de l'installation impose de redémarrer le serveur. Les modifications des applications Web et les autres modifications apportées aux paramètres sont conservées.

    Remarque :
    Vous devez être membre du groupe Administrateurs sur l'ordinateur local pour effectuer cette tâche.

    Pour démarrer l'installation Microsoft SharePoint Foundation 2010 :

    1. Dans le Panneau de configuration, ouvrez Programmes et fonctionnalités.

    2. Sélectionnez votre installation de SharePoint Foundation 2010 dans la liste, puis cliquez sur Modifier.

    3. Dans l'Assistant Configuration des produits SharePoint, sélectionnez Réparer, puis cliquez sur Continuer.

    4. Une fois les modifications effectuées dans l'Assistant Configuration des produits SharePoint, vérifiez que l'assembly du gestionnaire d'événements est réparé ou supprimé de tous les serveurs de la batterie de serveurs.

    5. Renouvelez l'opération qui a déclenché le gestionnaire d'événements. Ces événements doivent avoir disparu du journal des événements Windows.

Historique des modifications


Autorisation sur la bibliothèque d'aide du produit - Événement 6769

Nom de l'alerte : Autorisations de la bibliothèque de l'aide du produit

ID d'événement : 6769

Résumé : Microsoft SharePoint Foundation requiert que des autorisations spécifiques soient définies sur la bibliothèque de l'aide du produit pour que l'aide s'affiche correctement pour les utilisateurs. Pour cet ID d'événement, le moniteur SCOM contrôle la configuration des autorisations pour cette bibliothèque. La bibliothèque de l'aide du produit se trouve dans la collection de sites de l'aide sous l'application Web Administration centrale de SharePoint.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Les utilisateurs finals ne peuvent pas accéder à l'aide du produit.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6769 Description : Impossible d'actualiser les autorisations de la collection de sites de la bibliothèque de l'aide du produit.

Cause : Un problème avec l'actualisation des autorisations pour la collection de sites de la bibliothèque de l'aide du produit.

Solution : Réinitialiser les autorisations

  • Réinitialisez la configuration des autorisations à l'aide d'un travail Psconfig ou d'une applet de commande Windows PowerShell.

    Pour réinitialiser la configuration des autorisations à l'aide d'un travail Psconfig :

    • Ouvrez une fenêtre d'invite de commandes et, à l'invite, tapez psconfig -cmd helpcollections-install.

    Pour réinitialiser la configuration des autorisations à l'aide d'une applet de commande Windows PowerShell :

    1. Cliquez sur Démarrer, cliquez sur Tous les programmes, cliquez sur Produits Microsoft SharePoint 2010, puis cliquez sur SharePoint 2010 Management Shell. Une fenêtre d'invite de commandes s'ouvre.

    2. Tapez la commande Windows PowerShell Install-SPHelpCollection -All.

Historique des modifications


Impossible de résoudre le nom du serveur SMTP sortant - Événement 6856 (Produits SharePoint 2010)

Nom de l'alerte : impossible de résoudre le nom du serveur SMTP sortant

ID d'événement : 6856

Résumé : Microsoft SharePoint Foundation 2010 envoie des alertes et d'autres messages d'administration par le biais d'un serveur de messagerie SMTP. Vous pouvez spécifier le serveur SMTP à utiliser et définir l'adresse de messagerie qui doit envoyer des alertes et recevoir des réponses pour tous les sites dans la page Paramètres du courrier électronique sortant du site Web Administration centrale de SharePoint.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Il est impossible d'envoyer un courrier électronique avec SPUtility.SendEmail.

  • Il est impossible d'envoyer des messages électroniques, notamment des messages d'alerte, de confirmation, d'invitation et de dépassement de quota.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6856 Description : Impossible de résoudre le problème du nom de l'hôte SMTP <ID hôte>.

Cause : une ou plusieurs des causes suivantes sont possibles :

  • Microsoft SharePoint Foundation ne peut pas se connecter à l'hôte SMTP.

  • SharePoint Foundation 2010 ne peut pas résoudre le nom du serveur SMTP sortant.

Pour résoudre ce problème, utilisez la solution qui correspond à la cause que vous identifiez. Une fois la solution appliquée, reportez-vous à la section « Vérifier qu'une alerte de messagerie est envoyée » à la fin de cet article pour vérifier que la fonctionnalité est opérationnelle.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les actions suivantes.

Solution : démarrer et configurer le service SMTP

  1. Démarrez Internet Information Services 6.0 Manager, puis, dans l'arborescence, développez le nom du serveur.

  2. Cliquez avec le bouton droit sur le serveur virtuel SMTP utilisé par SharePoint Foundation (par exemple, Serveur virtuel SMTP par défaut), puis cliquez sur Démarrer.

  3. Pour configurer le serveur virtuel, cliquez avec le bouton droit sur celui-ci, puis cliquez sur Propriétés.

  4. Dans l'onglet Remise, cliquez sur Sécurité du courrier sortant.

  5. Dans la boîte de dialogue Sécurité sortante, l'option Accès anonyme ou Authentification Windows intégrée est sélectionnée. Si l'authentification Windows intégrée est sélectionnée, assurez-vous que le compte du pool d'applications de l'Administration centrale SharePoint Foundation a accès au service SMTP. Activez les cases à cocher Compte et Mot de passe, puis tapez le nom et le mot de passe du compte Windows qui vous permettent d'accéder à l'ordinateur auquel vous vous connectez.

Solution : configurer les paramètres du courrier électronique sortant dans l'Administration centrale

  1. Dans la page Administration centrale, cliquez sur Paramètres système, puis, dans la section Courrier électronique, cliquez sur Configurer les paramètres du courrier électronique sortant.

  2. Dans la page Paramètres du courrier électronique sortant, dans la section Paramètres de messagerie, tapez le nom du serveur SMTP adéquat dans la zone de texte Serveur SMTP sortant.

Vérifier qu'une alerte de messagerie est envoyée

  1. Accédez à un site Web SharePoint Foundation qui comporte une liste d'un type quelconque.

  2. Cliquez sur un élément de la liste.

  3. Cliquez sur un élément de la liste, puis, dans le Ruban, cliquez sur Partage et suivi.

  4. Cliquez sur M'avertir, puis, dans le menu, sélectionnez Pour cet élément.

  5. Dans la boîte de dialogue Nouvelle alerte, dans la section Envoyer les alertes à, tapez le nom de compte dans la zone de texte Utilisateurs.

  6. Après avoir vérifié les autres paramètres, cliquez sur OK.

    Un message électronique est envoyé à la boîte de réception, vous informant que vous avez créé une alerte.

Historique des modifications


Connexion impossible à l'hôte SMTP - Événement 6857.

Nom de l'alerte : Connexion impossible à l'hôte SMTP

ID d'événement : 6857

Résumé : Microsoft SharePoint Foundation 2010 envoie des alertes et d'autres messages d'administration en utilisant un serveur de messagerie SMTP. Vous pouvez spécifier le serveur SMTP à utiliser pour envoyer les alertes et vous pouvez choisir l'adresse de messagerie à utiliser pour l'envoi des alertes et la réception des réponses pour tous les sites. Pour cela, utilisez la page Paramètres du courrier électronique sortant du site Web Administration centrale de SharePoint.

Symptômes : Les symptômes suivants peuvent être perçus :

  • Impossible d'envoyer du courrier électronique avec SPUtility.SendEmail

  • Impossible d'envoyer des messages électroniques, y compris des alertes, un courrier de confirmation, une invitation ou un message sur un dépassement de quota.

  • Cet événement figure dans le journal des événements : ID d'événement : 6857 Description : impossible de résoudre le nom de l'hôte SMTP <id de l'hôte>.

Cause : La cause peut être une ou plusieurs des propositions suivantes :

  • Microsoft SharePoint Foundation ne peut pas se connecter à l'hôte SMTP.

  • SharePoint Foundation ne peut pas résoudre le nom du serveur SMTP sortant.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour réaliser les actions suivantes.

Solution : Démarrer et configurer le service SMTP

  1. Dans le Gestionnaire des services IIS 6.0, connectez-vous au serveur SMTP.

  2. Développez le nœud du serveur et cherchez le serveur virtuel SMTP utilisé par SharePoint Foundation.

  3. Cliquez avec le bouton droit sur le serveur virtuel approprié et cliquez sur Démarrer.

  4. Pour configurer le serveur virtuel, ouvrez ses propriétés.

  5. Dans l'onglet Remise, cliquez sur Sécurité sortante.

  6. Dans la boîte de dialogue Sécurité sortante, sélectionnez Accès anonyme ou Authentification Windows intégrée. Si vous sélectionnez Authentification Windows intégrée, assurez-vous que le compte du pool d'applications dans l'Administration centrale de SharePoint Foundation est authentifié sur le serveur SMTP en activant les cases à cocher Compte et Mot de passe.

Solution : Configurer les paramètres du courrier électronique sortant dans l'Administration centrale

  1. Dans la page Administration centrale, cliquez sur Paramètres système et dans la section Courrier électronique, cliquez sur Configurer les paramètres du courrier électronique sortant.

  2. Dans la page Paramètres du courrier électronique sortant, dans la section Paramètres de messagerie, tapez le serveur SMTP correct dans la zone de texte Serveur SMTP sortant.

Historique des modifications


Une erreur est survenue au cours d'une communication avec le serveur SMTP - Événement 6858 (produits SharePoint 2010)

Nom de l'alerte : une erreur s'est produite lors de la communication avec le serveur SMTP

ID d'événement : 6858

Résumé : Microsoft SharePoint Foundation 2010 envoie des alertes et d'autres messages d'administration par le biais d'un serveur de messagerie SMTP. Vous pouvez spécifier le serveur SMTP à utiliser pour l'envoi des alertes et définir l'adresse de messagerie qui doit envoyer des alertes et recevoir des réponses pour tous les sites dans la page Paramètres du courrier électronique sortant sur le site Web Administration centrale de SharePoint.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Il est impossible d'envoyer un courrier électronique avec SPUtility.SendEmail.

  • Il est impossible d'envoyer des messages électroniques, notamment des messages d'alerte, de confirmation, d'invitation et de dépassement de quota.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6858 Description : Impossible de résoudre le problème du nom de l'hôte SMTP <ID hôte>.

Cause : une ou plusieurs des causes suivantes sont possibles :

  • Microsoft SharePoint Foundation ne peut pas se connecter à l'hôte SMTP.

  • SharePoint Foundation ne peut pas résoudre le nom du serveur SMTP sortant.

Pour résoudre ce problème, utilisez la solution qui correspond à la cause que vous identifiez. Une fois la solution appliquée, reportez-vous à la section « Vérifier qu'une alerte de messagerie est envoyée » à la fin de cet article pour vérifier que la fonctionnalité est opérationnelle.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les actions suivantes.

Solution : démarrer et configurer le service SMTP

  1. Dans Internet Information Services (IIS) 6.0 Manager, connectez-vous au serveur SMTP.

  2. Développez le nœud de serveur et recherchez le serveur virtuel SMTP utilisé par SharePoint Foundation.

  3. Cliquez avec le bouton droit sur le serveur virtuel approprié, puis cliquez sur Démarrer.

  4. Pour configurer le serveur virtuel, ouvrez ses propriétés.

  5. Dans l'onglet Remise, cliquez sur Sécurité du courrier sortant.

  6. Dans la boîte de dialogue Sécurité sortante, sélectionnez l'option Accès anonyme ou Authentification Windows intégrée. Si vous avez sélectionné Authentification Windows intégrée, assurez-vous que le compte du pool d'applications de l'Administration centrale Windows SharePoint Services est authentifié sur le serveur SMTP en activant les cases à cocher Compte et Mot de passe.

Solution : configurer les paramètres du courrier électronique sortant dans l'Administration centrale

  1. Dans la page Administration centrale, cliquez sur Paramètres système, puis, dans la section Courrier électronique, cliquez sur Configurer les paramètres du courrier électronique sortant.

  2. Dans la page Paramètres du courrier électronique sortant, dans la section Paramètres de messagerie, tapez le nom du serveur SMTP adéquat dans la zone de texte Serveur SMTP sortant.

Vérifier qu'une alerte de messagerie est envoyée

  1. Accédez à un site Web SharePoint Foundation qui comporte une liste quelconque.

  2. Cliquez sur un élément de la liste.

  3. Cliquez sur un élément de la liste, puis, dans le Ruban, cliquez sur Partage et suivi.

  4. Cliquez sur M'avertir, puis, dans le menu, sélectionnez Pour cet élément.

  5. Dans la boîte de dialogue Nouvelle alerte, dans la section Envoyer les alertes à, tapez le nom de compte dans la zone de texte Utilisateurs.

  6. Après avoir vérifié les autres paramètres, cliquez sur OK.

    Un message électronique est envoyé à la boîte de réception, vous informant que vous avez créé une alerte.

Historique des modifications


Les listes SharePoint ne peuvent pas recevoir de courrier électronique - Événement 6872 (produits SharePoint 2010)

Nom d'alerte : les listes SharePoint ne peuvent pas recevoir de courrier électronique

ID d'événement : 6872

Résumé : le service de courrier électronique entrant Produits Microsoft SharePoint 2010 traite les messages électroniques à ajouter aux listes SharePoint. Le service traite le courrier électronique que le service Windows SMTP (Simple Mail Transfer Protocol) a ajouté à un dossier de dépôt.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les listes SharePoint ne reçoivent pas de courrier électronique entrant.

  • Des doublons s'affichent dans les listes qui reçoivent du courrier électronique entrant.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6872 Description : le service de courrier électronique entrant ne peut pas accéder au répertoire de dépôt ou ne dispose pas d'autorisations suffisantes.

Cause : la ou les causes peuvent être :

  1. Le service du minuteur SharePoint n'est pas autorisé à accéder en lecture au dossier de dépôt.

  2. Le dossier de dépôt spécifié n'existe pas.

  3. Le service du minuteur SharePoint n'est pas autorisé à accéder en écriture au dossier de dépôt.

Résolution : configurer le répertoire de dépôt dans les services Internet (IIS)

  • Dans le composant logiciel enfichable Gestionnaire des Services Internet (IIS) 6.0, développez le nœud Serveur.

  • Dans le nœud Serveur virtuel SMTP, double-cliquez sur Domaines.

  • Cliquez avec le bouton droit sur le domaine, puis cliquez sur Propriétés.

  • Notez l'emplacement du répertoire de dépôt. Si aucun répertoire de dépôt n'existe, créez-en un.

  • Accordez au service du minuteur SharePoint des autorisations sur le répertoire de dépôt.

Résolution : configurer les paramètres du courrier électronique entrant

  • Dans la page d'accueil de l'Administration centrale, cliquez sur Paramètres système.

  • Dans la page Paramètres système, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer les paramètres du courrier entrant.

  • Dans la page Configurer les paramètres du courrier entrant, si l'option Avancé est sélectionnée dans la section Service de gestion d'annuaire, tapez l'emplacement du répertoire de dépôt de la procédure précédente dans la zone Dossier de dépôt des messages électroniques, puis cliquez sur OK.

Historique des modifications


Le service de messagerie ne peut pas remettre le courrier électronique - Événement 6873 (Produits SharePoint 2010)

Nom de l'alerte : le service de messagerie ne peut pas remettre le courrier électronique

ID d'événement : 6873

Résumé : le service de messagerie Produits Microsoft SharePoint 2010 traite le courrier électronique destiné à être inséré dans des listes SharePoint. Le service traite le courrier que le service SMTP (Simple Mail Transfer Protocol) de Windows a ajouté à un dossier de dépôt.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les listes SharePoint ne reçoivent pas de courrier électronique.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 6599 Description : une erreur s'est produite lors du traitement du courrier électronique entrant

Cause : la ou les causes peuvent être :

  • Il n'y a aucune liste SharePoint correspondante pour le destinataire d'un message électronique.

  • L'expéditeur ne dispose pas des autorisations suffisantes pour ajouter du contenu à la liste SharePoint.

Solution : vérifier que la liste est configurée pour recevoir du courrier électronique

  1. Dans la liste fournie dans les détails de l'événement, dans le menu Liste, cliquez sur Paramètres de la liste.

  2. Sur la page Paramètres de la liste, sous Communications, cliquez sur Paramètres des messages électroniques entrants.

  3. Vérifiez les éléments suivants :

    • L'adresse de messagerie appropriée est entrée dans la zone Adresse de messagerie.

    • L'option Oui est sélectionnée sous Autoriser le composant bibliothèque de documents à recevoir du courrier électronique.

Solution : accorder à l'expéditeur les autorisations appropriées par rapport à la liste des destinataires

  1. Dans la liste fournie dans les détails de l'événement, dans le menu Liste, cliquez sur Paramètres de la liste.

  2. Dans la page Paramètres de la liste, sous Autorisations et gestion, cliquez sur Autorisations de cette liste.

  3. Vérifiez que le compte d'utilisateur fourni dans les détails de l'événement possède au moins l'autorisation Collaborateur par rapport à la liste.

Historique des modifications


Échec du récepteur d'événements : Événement 6875 (Produits SharePoint 2010)

Nom de l'alerte : échec du récepteur d'événements

ID d'événement : 6875

Résumé : dans Microsoft SharePoint Foundation 2010, vous pouvez lier un gestionnaire d'événements à un hôte d'événements (tel qu'un site entier, une liste ou une bibliothèque de documents). Cette opération vous permet d'utiliser des événements de bibliothèque de documents pour démarrer d'autres processus, tels que des processus de flux de travail.

Symptômes : cet événement figure dans le journal des événements : ID d'événement : 6875 Description : Erreur lors du chargement et de l'exécution du récepteur d'événements <nom du du récepteur> dans <emplacement du récepteur>. Des informations supplémentaires sont fournies ci-dessous. <informations supplémentaires>.

Cause : la ou les causes peuvent être :

  • L'assembly du récepteur d'événements personnalisé est introuvable ou est endommagé.

  • L'assembly SharePoint Foundation 2010 est introuvable ou est endommagé.

Solution: contacter le fabricant du récepteur d'événements défectueux

  1. Si l'assembly du récepteur d'événements défectueux est endommagé et qu'il ne s'agit pas d'un assembly SharePoint Foundation 2010, contactez son fabricant pour obtenir des informations supplémentaires.

Solution : réparer l'installation du produit

  1. La réparation de l'installation impose de redémarrer le serveur. Les modifications des applications Web et les autres modifications apportées aux paramètres sont conservées.

    Remarque :
    Vous devez être membre du groupe Administrateurs sur l'ordinateur local pour effectuer cette tâche.

    Pour démarrer l'installation SharePoint Foundation 2010 :

    1. Dans le Panneau de configuration, ouvrez Programmes et fonctionnalités.

    2. Sélectionnez votre installation de SharePoint Foundation 2010 dans la liste, puis cliquez sur Modifier.

    3. Dans l'Assistant Configuration des produits SharePoint, sélectionnez Réparer, puis cliquez sur Continuer.

    4. Une fois les modifications effectuées dans l'Assistant Configuration des produits SharePoint, vérifiez que l'assembly du gestionnaire d'événements est réparé ou supprimé de tous les serveurs de la batterie de serveurs.

    5. Renouvelez l'opération qui a déclenché le gestionnaire d'événements. Ces événements doivent avoir disparu du journal des événements Windows.

Historique des modifications


Impossible de créer le travail du minuteur de sauvegarde - Événement (Produits SharePoint 2010)

Nom de l'alerte : Impossible de créer le travail du minuteur de sauvegarde

ID d'événement : 7035

Résumé : Lorsque vous sauvegardez une application Web, vous sauvegardez les bases de données de contenu et les paramètres de l'application Web, y compris tous les sites dans les collections de sites, les fichiers dans les bibliothèques de documents, les fichiers associés à des listes, les paramètres de sécurité et d'autorisation, ainsi que les paramètres de fonctionnalités. Le processus de sauvegarde crée des fichiers qui contiennent toutes ces données. Le processus de restauration utilisent ces fichiers pour restaurer les bases de données de contenu et les paramètres de l'application Web.

De même, lorsque vous sauvegardez une collection de sites, un site ou une liste, le contenu de ces structures est écrit dans des fichiers ou des packages et le processus de restauration ou d'importation utilise ces fichiers pour récupérer les objets.

Symptômes : Un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Une ou plusieurs notifications d'avertissement apparaissent dans la section Disponibilité de la page État des opérations de sauvegarde et de restauration ou État précis du travail de sauvegarde dans l'Administration centrale.

  • L'événement suivant apparaît dans le journal des événements : ID d'événement : 7035 Description : Cet élément est déjà en cours de sauvegarde ou de restauration. Pour connaître l'état de ce processus, accédez à la page d'état du travail de sauvegarde/restauration sur le site d'administration.

Cause : Un travail du minuteur de sauvegarde/restauration existant a échoué ou ne s'est pas terminé, et le service du minuteur SharePoint ou le service Administration SharePoint n'est pas démarré.

Vérifiez que les services du minuteur et d'administration SharePoint sont en cours d'exécution

  1. Assurez-vous que les services suivants sont démarrés :

    1. Le service du minuteur V4 SharePoint doit être démarré sur tous les serveurs Web frontaux et serveurs d'applications de la batterie.

    2. Le service d'administration V4 SharePoint doit être démarré sur le serveur qui exécute le site Web Administration centrale.

Solution : Vérifiez que le travail du minuteur de sauvegarde ou de restauration précédent s'est terminé avec succès

  • Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  • Dans la page d'accueil de l'Administration centrale, cliquez sur Sauvegarde et restauration.

  • Dans la page Sauvegarde et restauration, sous Sauvegarde et restauration de la batterie, cliquez sur Vérifier l'état du travail de sauvegarde et de restauration.

  • Dans la page État des opérations de sauvegarde et de restauration, sous Disponibilité, vérifiez qu'aucun travail de sauvegarde ou de restauration n'est en cours, que le service du minuteur est en cours d'exécution et que le service d'administration est en cours d'exécution.

  • Cliquez sur le bouton Précédent dans le navigateur.

  • Dans la page Sauvegarde et restauration, sous Sauvegarde précise, cliquez sur Vérifier l'état précis du travail de sauvegarde.

  • Dans la page État précis du travail de sauvegarde, sous Disponibilité, vérifiez qu'aucun travail de sauvegarde n'est en cours, qu'aucun travail d'exportation n'est en cours et que le service du minuteur est en cours d'exécution.

  • Vérifiez l'état des travaux en cours dans les sections Sauvegarde de la collection de sites et Exportation de contenu.

Historique des modifications


Échec de la mise à jour de l'Administration centrale : Événement 7037 (Produits SharePoint 2010)

Nom de l'alerte : échec de la mise à jour de l'Administration centrale

ID d'événement : 7037

Résumé : cette erreur indique que le travail du minuteur Microsoft SharePoint Foundation 2010 consistant à mettre à jour l'Administration centrale sur une URL spécifique n'a pas été créé ou que l'URL locale basée sur le Registre pour l'Administration centrale n'a pas été mise à jour.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les paramètres d'URL du serveur local pour le site Web Administration centrale ne correspondent pas aux paramètres configurés.

  • Cet événement figure dans le journal des événements : ID d'événement : 7037 Description : Une erreur s'est produite lors de la création du travail du minuteur pour mettre à jour l'emplacement de l'URL de l'Administration centrale sur <URL>.

Cause : la ou les causes peuvent être :

  • La création du travail du minuteur destiné à mettre à jour les paramètres de l'Administration centrale a échoué. Cet échec peut être dû à une défaillance de communication avec la base de données de configuration pendant la création de l'objet de configuration.

  • La mise à jour de l'emplacement de Registre de l'URL de l'Administration centrale sur le serveur local a échoué en raison de problèmes liés aux autorisations de clés de Registre.

Solution : accorder des autorisations àsur l'emplacement de ruche approprié dans le Registre

  • Assurez-vous que les groupes d'administrateurs locaux et d'administrateurs de batterie de serveurs disposent d'un contrôle total sur l'URL locale basée sur le Registre pour l'Administration centrale.

    Remarque :
    Une modification incorrecte du Registre peut endommager gravement le système. Avant d'apporter des modifications au Registre, sauvegardez les données de valeur stockées dans l'ordinateur.

    1. Cliquez sur Démarrer et sur Exécuter, tapez regedit, puis cliquez sur OK.

    2. Dans l'Éditeur du Registre, dans l'arborescence, recherchez la clé de Registre suivante :HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\14.0\WSS\CentralAdministrationURL.

    3. Cliquez avec le bouton droit sur la clé de Registre, puis cliquez sur Autorisations.

    4. Assurez-vous qu les groupes locaux AdministratorsAdministrateurs et WSS_ADMIN_WPG disposent des autorisations Allow Full ControlAutoriser le contrôle total et qu'aucune autorisation Refuser n'a été définie. Ne supprimez pas ou ne modifiez pas d'autorisations pour une autre entrée de groupe ou d'utilisateur concernant cette clé de Registre.

Solution : redémarrer la mise à jour du port du site Web Administration centrale

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. Depuis l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPCentralAdministration -Port <Int32>

    Où :

    • <Int32> représente le nouveau numéro de port.

Pour plus d'informations, voir Set-SPCentralAdministration.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications


Alerte de début de limitation - Événements 8032 8062

Nom de l'alerte : la limitation SPServer démarre

ID d'événement : 8032 ou 8062

Résumé : la fonctionnalité de limitation du serveur Web frontal, introduite dans Microsoft SharePoint Foundation 2010, empêche le serveur de manquer de ressources pour les travaux de serveur hautement prioritaires. La limitation surveille les compteurs de performance sur le serveur et commence à rejeter les travaux faiblement prioritaires en retournant un message d'erreur 503 dès que les valeurs des compteurs sont supérieures ou inférieures aux seuils prédéfinis.

Symptômes : Les symptômes suivants peuvent apparaître :

  • Les utilisateurs reçoivent une erreur 503 dans le navigateur : « Le serveur est actuellement occupé. Réessayez ultérieurement ».

  • Cet événement apparaît dans le journal des événements : ID d'événement : 8032 Description : La limitation Http démarre, car une lourde charge a été détectée sur l'application Web <nom serveur>. Les compteurs affichant des performances excessives sont : <nom compteur de performance>.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 8062 Description : La limitation Http sur on <nom serveur> s'arrête, car aucune lourde charge n'est détectée en ce moment. <nombre de demandes> demandes ont été limitées pendant la période de limitation.

Cause : l'utilisation de l'UC, la mémoire disponible, la longueur de la file d'attente ASP.NET et le délai d'attente de la file d'attente ASP.NET sont supérieurs ou inférieurs au seuil prédéfini sur les serveurs Web frontaux.

Solution : modifier le seuil de limitation

  1. Cliquez sur Démarrer, sur Tous les programmes, sur Microsoft SharePoint 2010 Products, puis sur SharePoint 2010 Management Shell. Une fenêtre d'invite de commandes s'ouvre.

  2. Entrez la commande Windows PowerShell suivante pour lire la valeur de seuil associée aux compteurs de performance.

    Disable-SPWebApplicationHttpThrottling URL

  3. Entrez la commande suivante pour obtenir la valeur actuelle des seuils des compteurs de performance.

    Get-SPWebApplicationHttpThrottlingMonitors URL

  4. Passez les seuils en revue et déterminez si vous devez remplacer les valeurs actuelles par des seuils moins restrictifs. Par exemple, la commande Windows PowerShell suivante permet de définir le seuil de l'utilisation de l'UC sur 75 %.

    Set-SPWebApplicationHttpThrottlingMonitor URL -Category Processor -Counter "% Processor Time" -instance _Total -Max 75

Solution : désactiver la fonctionnalité de limitation

  1. Sur le site Web Administration centrale de SharePoint, dans la section Gestion des applications, cliquez sur Gérer les applications Web.

  2. Sous l'onglet Application Web du Ruban, cliquez sur Paramètres généraux, puis sélectionnez Limitation de ressource pour désactiver la limitation HTTP.

    Remarque :
    La désactivation de la fonction de limitation place le serveur dans une situation où il risque de manquer de ressources pour traiter les travaux hautement prioritaires en cas de charge de travail élevé. Il n'est pas recommandé de désactiver régulièrement la fonction de limitation.

Solution : mettre à niveau la configuration matérielle

  • Passez en revue votre plan de capacité. Suivant la cause du déclenchement de la limitation, vous pouvez prendre différentes mesures en guise de solutions :

    1. Ajouter de la mémoire.

    2. Mettre à niveau l'UC.

    3. Mettre à niveau les serveurs Web frontaux.

    4. Ajouter des serveurs Web frontaux.

    5. Mettre à niveau les serveurs hôtes SQL Server.

Historique des modifications


Récupération des extrémités impossible - Événement 8070

Nom de l'alerte : Impossible de récupérer les points de terminaison

ID d'événement : 8070

Résumé : L'Application de service d'équilibrage de charge et de détection d'application ne parvient pas à récupérer la liste des points de terminaison pour une application de service à partir de la batterie de serveurs distante.

Symptômes : Cet événement apparaît dans le journal des événements : ID d'événement : 8070 Description : une exception s'est produite lors de la tentative d'appel de GetEndPoints : <Nom du point de terminaison>.

Cause : Une ou plusieurs des causes suivantes sont possibles :

  • Cette batterie de serveurs n'a pas les autorisation pour se connecter à la batterie de serveurs distante.

  • Les erreurs de réseau ou les problèmes de connectivité empêchent le succès de cette opération.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie sur le site Administration centrale pour effectuer la tâche suivante.

Solution : vérifiez que cette batterie de serveurs dispose des autorisations requises pour se connecter à la batterie de serveurs distante

  • Contactez l'administrateur de la batterie de serveurs distante pour vous assurer que ce qui suit est vrai :

    • Cette batterie de serveurs a été ajoutée en tant que batterie de serveurs approuvée dans la batterie de serveurs distante.

    • Le compte de service de cette batterie de serveurs dispose des autorisations nécessaires pour accéder au service de topologie sur la batterie de serveurs distante.

  • Vérifiez que la batterie de serveurs distante a été ajoutée en tant que batterie de serveurs approuvée sur cette batterie de serveurs.

  • Pour établir l'approbation entre deux batteries de serveurs, chaque batterie doit ajouter l'autre certificat racine public de la batterie de serveurs à la liste des autorités racine de confiance en utilisant la commande New-SPTrustedRootAuthorityWindows PowerShell. Pour plus d'informations, voir New-SPTrustedRootAuthority.

Solution : vérifiez qu'il n'existe pas de problèmes réseau lors de la connexion à la batterie de serveurs distante

  • Exécutez une commande ping sur les serveurs dans la batterie de serveurs distante pour vérifier qu'ils sont disponibles.

  • Contactez l'administrateur de la batterie de serveurs distante pour vérifier qu'il n'existe aucun problème de connectivité sur cette batterie de serveurs.

Historique des modifications


Le dossier journal n'existe pas - Événement 8074 (produits SharePoint 2010)

Nom d'alerte : le dossier du journal n'existe pas

ID d'événement : 8074

Résumé : le dossier de journalisation spécifié dans le message d'erreur n'existe pas ou est inaccessible.

Symptômes : cet événement apparaît dans le journal des événements : ID d'événement :8074 Description : impossible d'accéder au répertoire <nom_répertoire> sur le serveur <nom_serveur>. Assurez-vous que ce répertoire existe et que le compte <domaine>\<nom_utilisateur> est autorisé à y accéder.

Cause : la ou les causes peuvent être :

  • Le dossier n'existe pas.

  • Le compte du service de gestion du suivi SharePoint 2010 (SPTraceV4) ne dispose pas d'autorisations en lecture et en écriture sur ce dossier.

Résolution : vérifier que le dossier de journalisation de l'utilisation existe

  • Ouvrez une session sur le serveur répertorié dans l'événement.

  • Accédez au dossier répertorié dans l'événement.

  • Si le dossier n'existe pas, créez-le.

  • Vérifiez que le compte du service de gestion du suivi SharePoint 2010 (SPTraceV4) dispose d'autorisations en lecture, en écriture et en suppression sur le dossier.

Historique des modifications


Échec du travail du minuteur d'utilisation - Événement 8075 (produits SharePoint 2010)

Nom d'alerte : échec du travail du minuteur d'utilisation

ID d'événement : 8075

Résumé : échec du travail du minuteur Traitement des données d'utilisation.

Symptômes : cet événement apparaît dans le journal des événements : ID d'événement : 8075 Description : échec du travail du minuteur Traitement des données d'utilisation. Vous pouvez réexécuter ce travail à l'aide de la page État du travail du minuteur dans le site Administration centrale de SharePoint.

Cause : la ou les causes peuvent être :

  • La journalisation de l'utilisation n'est pas activée.

  • Le compte de service de la batterie ne dispose pas d'autorisations suffisantes sur le dossier journal.

  • Le disque sur lequel se trouve le dossier journal est plein.

  • La base de données de journalisation n'existe pas ou n'est pas accessible en écriture.

  • Des problèmes réseau se sont produits entre le serveur de la batterie et le serveur de base de données.

Résolution : vérifier que la journalisation de l'utilisation est en cours d'exécution sur tous les serveurs de la batterie

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans la page d'accueil Administration centrale, sous Paramètres système, cliquez sur Gérer les serveurs de cette batterie.

  3. Dans la page Serveurs de la batterie, dans la section Serveur, enregistrez les noms de tous les serveurs de la batterie.

  4. Pour chaque serveur dans la batterie, procédez comme suit : dans le composant logiciel enfichable Services, vérifiez que le service de gestion du suivi SharePoint 2010 (SPTraceV4) est activé et démarré. S'il n'est pas démarré, démarrez-le.

  5. Sous l'onglet Connexion, enregistrez le compte Exécuter en tant que pour chaque service.

Résolution : vérifier que le dossier de journalisation de l'utilisation existe

  1. Ouvrez une session sur le serveur répertorié dans l'événement.

  2. Accédez au dossier répertorié dans l'événement.

  3. Si le dossier n'existe pas, créez-le.

  4. Vérifiez que le compte Exécuter en tant que du service de gestion du suivi SharePoint 2010 (SPTraceV4) dispose d'autorisations en lecture, en écriture et en suppression sur le dossier.

Résolution : vérifier que la base de données de journalisation existe

  • Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  • Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  • Dans la page Analyse, dans la section Rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  • Dans la page Configurer Web Analytics et la collection des données d'intégrité, dans la section Paramètres de la collection des données d'utilisation, notez le serveur et l'emplacement du dossier journal à partir de la zone Emplacement du fichier journal.

  • Dans la section Journalisation du serveur de base de données, notez l'emplacement de la base de données de journalisation à partir des zones Serveur de base de données et Nom de la base de données.

  • Dans SQL Server Management Studio, connectez-vous au serveur de base de données.

  • Développez le nœud Bases de données, puis vérifiez que la base de données existe et qu'elle est en ligne.

Résolution : réexécuter le travail du minuteur

  • Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  • Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  • Dans la page Analyse, dans la section Rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  • Dans la page Définitions des travaux, cliquez sur Traitement des données d'utilisation de Microsoft SharePoint Foundation.

  • Dans la page Modifier le travail du minuteur, cliquez sur Exécuter maintenant.

Historique des modifications


Service Connexion de données métiers - Exception de la connexion d'adaptateur de base de données BDC - Événement 8080 (Produits SharePoint 2010)

Nom de l'alerte : Service Connexion de données métiers - exception de connexion à l'adaptateur de base de données BDC

ID d'événement : 8080

Résumé : Le runtime du service Connexion de données métiers lit les métadonnées définies dans le modèle d'application de service, établit une connexion à la source de données externes et appelle les méthodes appropriées définies dans le modèle d'application pour n'importe laquelle des opérations. Cet événement est enregistré si la connexion ne peut pas être établie pour une base de données. Aucune des opérations déclenchées par des applications clientes ne sera exécutée et les données peuvent être rendues obsolètes.

Symptômes : Cet événement apparaît dans le journal des événements : ID d'événement : 8080 Description : L'application de service BDC %1 n'a pas réussi à ouvrir la connexion à l'aide de %2.

Cause : Une ou plusieurs des causes suivantes sont possibles :

  • Le modèle d'application du service Connexion de données métiers ne dispose pas des propriétés de connexion correctes pour la source de données externe.

  • La source de données externe ne fonctionne pas ou ne répond pas actuellement.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie de serveurs pour effectuer la procédure suivante.

Solution : Vérifiez que les propriétés de connexion de la source de données externes sont correctes

  1. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  2. Dans la page Gestion des applications, dans la section Applications de service, cliquez sur Gérer les applications de service.

  3. Dans la page Applications de service, sélectionnez l'Application de service BDC.

  4. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Systèmes externes.

  5. Cliquez sur le système externe pour afficher ses instances.

    Conseil :
    Par défaut, les seules instances de types de systèmes externes configurables sont les bases de données et les services Web.

  6. Sélectionnez le nom du système externe.

  7. Modifiez ou affichez les paramètres.

Pour plus d'informations sur les paramètres disponibles pour la configuration d'un système de base de données externe, voir Configurer une instance d'un système externe. Pour plus d'informations sur la gestion des modèles BDC, voir Gérer les modèles BDC (SharePoint Foundation 2010).

Solution : Vérifiez que la connexion réseau à la source de données externe fonctionne

  • Ouvrez une fenêtre d'invite de commande sur le serveur d'applications et tapez PING<nom_serveur>, où <nom_serveur> est le nom du serveur de base de données qui héberge la source de données externe.

Historique des modifications


Service BDC - Exception de génération liée au proxy de service Web BDC : événement 8082 (Produits SharePoint 2010)

Nom de l'alerte : Service BDC - exception de génération liée au proxy de service Web BDC

ID d'événement : 8082

Résumé : pendant l'utilisation d'un service Web, le service BDC obtient un proxy, puis appelle les méthodes appropriées en fonction des métadonnées définies dans le modèle d'application. Cet événement est journalisé lorsque le service BDC ne parvient pas obtenir un proxy vers un service Web. Cela affecte la synchronisation des données entre l'ordinateur client et la source de données externe.

Symptômes : l'événement suivant apparaît dans le journal des événements : ID d'événement : 8082 Description : Le service BDC n'a pas pu obtenir un proxy vers le service Web pour la source de données externe % nom de la source de données externe%.

Cause : la ou les causes peuvent être :

  • Le modèle d'application du service BDC ne possède pas les propriétés de connexion adéquates pour la source de données externe.

  • La source de données externe est arrêtée et ne répond pas.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour réaliser l'opération suivante.

Solution: vérifier que les propriétés de connexion de la source de données externe définies dans le modèle d'application sont correctes

  1. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  2. Dans la page Gestion des applications, dans la section Applications de service, cliquez sur Gérer les applications de service.

  3. Dans la page Applications de service, sélectionner l'application de service BDC.

  4. Sous l'onglet Modifier, dans le groupe Affichage, cliquez sur Systèmes externes.

    Conseil :
    Par défaut, le seul type de système externe configurable est un service Web. Par défaut, les seules instances de types de systèmes externes configurables sont les bases de données et les services Web.

  5. Pointez sur le système externe, cliquez sur la flèche qui apparaît, puis cliquez sur Paramètres.

  6. Modifiez ou affichez les paramètres.

Pour plus d'informations sur la configuration et la gestion d'une source de données externe, voir Configurer une instance d'un système externe dans l'article « Gérer les systèmes externes (SharePoint Foundation 2010) ». Pour plus d'informations sur la gestion des modèles BDC, voir Supprimer un modèle BDC.

Solution : vérifier que la source de données externe est accessible

  • À partir du serveur d'applications, effectuez un test Ping en direction du serveur de base de données qui héberge la source de données externe afin de vérifier que les serveurs peuvent communiquer via le réseau.

Historique des modifications


Service Connexion de données métiers - Proxy BDC - exception inattendue - Événement 8085 (Produits SharePoint 2010)

Nom de l'alerte : Service Connexion de données métiers - exception inattendu du proxy BDC

ID d'événement : 8085

Résumé : Lorsqu'un serveur Web reçoit une demande de la part d'un ordinateur client, il achemine cette demande vers un serveur d'applications par le biais d'un système d'équilibrage de la charge. Celui-ci conserve une liste des serveurs disponibles pour une application de service donnée. Si l'application de service Connexion de données métiers sur un ou plusieurs serveurs d'applications ne répond pas, le système d'équilibrage de la charge supprime le serveur d'applications de la liste des serveurs disponibles et cet événement est enregistré.

Si l'application de service Connexion de données métiers est activée sur plusieurs serveurs d'applications, les ordinateurs clients peuvent ne pas être affectés. Si elle est activée sur un seul serveur d'applications, les ordinateurs clients qui reposent sur les métadonnées dans le magasin de métadonnées de Connexion de données métiers ne pourront ni lire ni écrire des données à partir des sources de données externes définies dans les métadonnées. Le système d'équilibrage de la charge exécutera régulièrement une requête ping sur l'application de service et la réintègrera automatiquement à la liste lorsqu'elle recommencera à répondre.

Symptômes : Les ordinateurs clients ne peuvent ni lire ni écrire de données à partir des sources de données externes.

Cause : Une ou plusieurs des causes suivantes sont possibles :

  • Le serveur d'applications est inaccessible ou le modèle d'application de service Connexion de données métiers ne possède pas les propriétés de connexion correctes pour la source de données externe.

  • La source de données externe ne fonctionne pas ou ne répond pas actuellement.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer les actions suivantes.

Solution : Vérifiez que le serveur d'applications est disponible

  1. Dans la page d'accueil Administration centrale, dans la section Paramètres système, cliquez sur Gérer les serveurs de cette batterie.

  2. Dans la page Serveurs de la batterie, vérifiez que l'état du serveur sur lequel s'exécute le service Connexion de données métiers est Aucune action requise.

Solution : Vérifiez que l'application de service Connexion de données métiers est mise en service correctement

  1. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  2. Dans la page Gestion des applications, dans la section Applications de service, cliquez sur Gérer les applications de service.

  3. Dans la page Applications de service, recherchez l'Application de service Business Data Connectivity et, dans la colonne État, vérifiez que l'état du proxy de service est Démarré.

Historique des modifications


Service BDC - Exception SQL : événement 8086 (Produits SharePoint 2010)

Nom de l'alerte : Service BDC - exception SQL

ID d'événement : 8086

Résumé : l'application de service BDC se connecte au magasin de métadonnées afin de permettre aux utilisateurs de gérer les métadonnées contenues dans le magasin de métadonnées. Cet événement est journalisé lorsque l'application de service ne parvient pas à se connecter à la base de données. Les métadonnées BDC contenues dans le magasin de métadonnées ne sont pas accessibles. Cela a une incidence sur l'importation et l'exportation des modèles d'application ou sur la mise à jour des propriétés des objets BDC à l'aide de la page Proxy d'application du service BDC dans le site Web Administration centrale de SharePoint.

Symptômes : Cet événement apparaît dans le journal des événements : ID d'événement : 8086 Description : L'erreur de l'application de service BDC %nom% s'est produite suite à une exception de base de données.

Cause : la ou les causes peuvent être :

  • Le serveur de base de données de métadonnées est arrêté ou inaccessible en raison de problèmes liés au réseau.

  • Les informations de connexion relatives à la base de données de métadonnées de l'application de service BDC sont incorrectes.

  • La base de données de métadonnées de l'application de service BDC n'a pas été déployée correctement.

Solution : vérifier la disponibilité du serveur de base de données de métadonnées

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Gestion des applications.

  3. Dans la page Gestion des applications, dans la section Applications de service, cliquez sur Gérer les applications de service.

  4. Dans la page Applications de service, sélectionnez l'option Application du service BDC, puis cliquez sur Propriétés dans le Ruban.

  5. Vérifiez que le serveur de base de données répertorié dans la page Propriétés est disponible et qu'il est accessible à partir des Produits SharePoint 2010.

Historique des modifications


Le fichier journal de trace ULS a atteint la taille maximale : événement 8094 (Produits SharePoint 2010)

Nom de l'alerte : Le journal de suivi ULS a atteint sa taille maximale

ID d'événement : 8094

Résumé : Le service de suivi SharePoint 2010 (SPTracev4) est utilisé par Microsoft SharePoint Foundation 2010 pour gérer la sortie du journal d'utilisation. Lorsque la journalisation de suivi est activée, les administrateurs peuvent spécifierle chemin d§accès utilisé pour stocker le fichier journal de suivi. De nombreuses applications basées sur SharePoint Foundation 2010 utilisent ce fichier journal. Cet événement se produit quand il y a peu d'espace à l'emplacement du fichier journal configuré. Il tient lieu d'avertissement que la journalisation peut s'arrêter bientôt si on ne crée pas plus d'espace ou si on n'accorde pas plus d'espace à la journalisation.

Symptômes : Cet événement apparaît dans le journal des événements : ID d'événement : 8094 Description : la limite de stockage autorisée pour les journaux d'utilisation [limite configurée] est sur le point d'être atteinte. Augmentez les paramètres de limite de stockage maximale. Si vous ne le faites pas, les fichiers anciens seront supprimés une fois la limite atteinte.

Cause : L'espace disque pour la journalisation est insuffisant sur l'emplacement du fichier journal configuré ou l'espace amximum alloué à la journalisation est trop bas.

Solution : augmentez la limite d'espace pour les fichiers journaux

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configuration de la journalisation des diagnostics.

  4. Dans la section Journal de suivi, dans la zone Espace de stockage maximal pour les journaux de suivi (Go), apez un nombre supérieur de gigaoctets (Go) à allouer aux fichiers journaux. Quand les fichiers journaux atteignent cette taille sur le disque, les fichiers journaux les plus anciens seront supprimés.

  5. Cliquez sur OK.

Solution : modifiez l'emplacement des fichiers journaux

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configuration de la journalisation des diagnostics.

  4. Dans la section Journal de suivi, dans la zone Chemin d'accès, entrez le nouvel emplacement du fichier journal sur un disque ou une partition disposant d'un espace disque suffisant.

  5. Cliquez sur OK.

Solution : Libérer de l'espace disque

  1. Exécutez l'outil Nettoyage de disque pour libérer de l'espace là où sont stockés les fichiers journaux de suivi.

  2. Vérifiez que le service de suivi dispose de suffisamment d'espace disque pour écrire le fichier journal.

  3. Si le service de journalisation du suivi n'a pas d'espace disque suffisant pour écrire les fichiers journaux, supprimez le contenu des dossiers temporaires sur le disque.

Historique des modifications


Le fichier journal d'utilisation ULS a atteint la taille maximale - Event 8095

Nom de l'alerte : Journal d'utilisation ULS a atteint sa taille maximale

ID d'événement : 8095

Résumé : Le service de suivi SharePoint 2010 (SPTracev4) est utilisé par Microsoft SharePoint Foundation 2010 pour gérer la sortie du journal d'utilisation. Lorsque la journalisation de l'utilisation est activée, les administrateurs peuvent spécifier le chemin d'accès utiliser pour stocker le fichier du journal d'utilisation. Ce fichier journal est utilisé par de nombreuses applications basées sur SharePoint Foundation 2010. Cet événement se produit lorsqu'il reste peu d'espace sur l'emplacement du fichier journal configuré. Il tient lieu d'avertissement que la journalisation peut s'arrêter bientôt si on ne crée pas plus d'espace ou si on n'accorde pas plus d'espace à la journalisation.

Symptômes : Cet événement apparaît dans le journal des événements : ID d'événement : 8095 Description : la limite de stockage autorisée pour les journaux d'utilisation [limite configurée] est sur le point d'être atteinte. Augmentez les paramètres de limite de stockage maximale. Si vous ne le faites pas, les fichiers anciens seront supprimés une fois la limite atteinte.

Cause : L'espace disque pour la journalisation est insuffisant sur l'emplacement du fichier journal configuré ou l'espace maximum alloué à la journalisation est trop bas.

Solution : augmentez la limite d'espace pour les fichiers journaux

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la section Création de rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  4. Sur la page Configurer Web Analytics et la collection des données d'intégrité, dans la section Paramètres de la collection des données d'utilisation, tapez un nombre supérieur de gigaoctets (Go) à allouer aux fichiers journaux. Quand les fichiers journaux atteignent cette taille sur le disque, les fichiers journaux les plus anciens seront supprimés.

  5. Cliquez sur OK.

Solution : modifiez l'emplacement du fichier journal

  1. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  2. Dans la section Création de rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  3. Sur la page Configurer Web Analytics et la collection des données d'intégrité, dans la section Paramètres de la collection des données d'utilisation, entrez le nouvel emplacement du fichier journal sur un disque ou une partition disposant d'un espace disque suffisant.

  4. Cliquez sur OK.

Solution : Libérer de l'espace disque

  1. Utilisez l'outil Nettoyage de disque pour libérer de l'espace là où sont stockés les fichiers journaux d'utilisation.

  2. Vérifiez que le service de journalisation de l'utilisation dispose de suffisamment d'espace disque pour écrire le fichier journal.

  3. Si le service de journalisation de l'utilisation n'a pas suffisamment d'espace disque pour écrire le fichier journal, supprimez le contenu des dossiers temporaires sur le disque.

Pour vérifier le fichier journal d'utilisation :

  1. Sur la page d'accueil Administration centrale de SharePoint, cliquez sur Analyse et dans la section Création de rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  2. Sur la page Configurer Web Analytics et la collection des données d'intégrité, dans la section Paramètres de la collection des données d'utilisation, copiez le chemin d'accès du fichier journal d'utilisation.

  3. Dans l'Explorateur Windows, accédez au fichier journal d'utilisation en utilisant le chemin d'accès copié. Les fichiers journaux d'utilisation sont au format binaire et le contenu ne peut pas être facilement affiché et assimilé. La taille du fichier journal d'utilisation augmente avec le temps, confirmant le bon fonctionnement de la journalisation de l'utilisation.

Historique des modifications


Certificat de signature STS manquant : événement 8303 (Produits SharePoint 2010)

Nom de l'alerte : certificat de signature du service d'émission de jeton de sécurité manquant

ID d'événement : 8303

Résumé : le certificat de signature du service d'émission de jeton de sécurité (STS, Security Token service) que les Produits Microsoft SharePoint 2010 utilisent pour authentifier les utilisateurs est manquant.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les utilisateurs ne sont pas en mesure de se connecter aux Produits SharePoint 2010.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 8303 Description : Le service Access Data Services n'est plus disponible. [Session : <ID de session> Utilisateur : <nom d'utilisateur>]

Cause : la cause peut être l'une des suivantes :

  • Le certificat de signature STS inclus dans les Produits SharePoint 2010 est manquant.

  • Le certificat de signature STS signé automatiquement ou le certificat externe que vous utilisez est manquant.

Solution : importer un nouveau certificat de signature STS à partir de la batterie de serveurs des produits SharePoint 2010

  1. Récupérez le certificat racine de votre batterie de serveurs des produits SharePoint 2010.

  2. Exportez le certificat racine.

  3. À l'aide de l'utilitaire makecert, générez un nouveau certificat de signature STS, basé sur le certificat racine.

  4. Importez le nouveau certificat dans le magasin de certificats associé à votre système d'exploitation.

Solution: importer un nouveau certificat de signature STS signé automatiquement ou un nouveau certificat externe

  1. Récupérez le certificat racine de votre batterie de serveurs des produits SharePoint 2010.

  2. Exportez le certificat racine.

  3. Régénérez le certificat.

  4. Importez le nouveau certificat dans le magasin de certificats associé à votre système d'exploitation.

Historique des modifications


Le service d'émission de jeton de sécurité ne peut pas signer les informations d'identification - Événement 8304 (Produits SharePoint 2010)

Nom de l'alerte : Le service d'émission de jeton de sécurité ne peut pas signer les informations d'identification

ID d'événement : 8304

Résumé : Le service d'émission de jeton de sécurité ne peut pas signer les informations d'identification utilisateur.

Symptômes : Un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les utilisateurs ne peuvent pas se connecter à Microsoft SharePoint Foundation 2010.

  • L'ouverture de session échoue.

  • Le Sélecteur de personnes ne parvient pas à rechercher ou résoudre et retourne un message d'erreur.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 8307 Description : Une exception s'est produite lors de la tentative de création des informations d'identification de la signature : <exception>.

Cause : Une erreur s'est produite au niveau du fournisseur de revendications spécifié dans la description de l'exception.

Solution : Importez un nouveau certificat de signature de Service d'émission de jeton de sécurité à partir de la batterie de Produits SharePoint 2010

  1. Récupérez le certificat racine de votre batterie Produits Microsoft SharePoint 2010.

  2. Exportez le certificat racine.

  3. Utilisez l'utilitaire makecert pour générer un nouveau certificat de signature de Service d'émission de jeton de sécurité basé sur le certificat racine.

  4. Importez le nouveau certificat dans le magasin de certificats pour votre système d'exploitation.

Solution : Importez un nouveau certificat externe ou certificat de signature de Service d'émission de jeton de sécurité autosigné

  1. Récupérez le certificat racine de votre batterie Produits SharePoint 2010.

  2. Exportez le certificat racine.

  3. Regénérez le certificat.

  4. Importez le nouveau certificat dans le magasin de certificats pour votre système d'exploitation.

Historique des modifications


Les revendications ne peuvent pas établir de point de terminaison : événement 8305 (Produits SharePoint 2010)

Nom de l'alerte : les revendications du service d'émission de jeton de sécurité ne peuvent pas établir un point de terminaison

ID d'événement : 8305

Résumé : l'authentification par revendications du service d'émission de jeton de sécurité (STS, Security Token Service) ne peut pas établir un point de terminaison.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les utilisateurs ne sont pas en mesure de se connecter à Microsoft SharePoint Foundation 2010.

  • L'ouverture de session échoue.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 8305 Description : Une exception s'est produite lors de la tentative d'établissement d'un point de terminaison pour le contexte : <exception>.

Cause : le fournisseur de revendications n'est pas configuré correctement.

Pour vérifier que le service STS est en cours d'exécution à l'aide de Windows PowerShell

  1. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  2. Dans le menu Démarrer, cliquez sur Tous les programmes.

  3. Cliquez sur Produits Microsoft SharePoint 2010.

  4. Cliquez sur SharePoint 2010 Management Shell.

  5. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Get-SPServicAapplicationPool | Where {$_.DisplayName -eq <DisplayName>}| Format-List

    Où :

    • <DisplayName> représente le nom complet du pool d'applications du service STS. Par défaut, cette valeur est « SecurityTokenServiceApplicationPool ».

  6. Vérifiez que l'attribut Status du pool d'applications a pour valeur Online.

Solution : annuler les modifications apportées au fichier Web.config

  1. Si le fichier Web.config a été modifié, essayez de rétablir manuellement la version précédente ou, si vous avez sauvegardé le fichier, restaurez la sauvegarde.

Historique des modifications


Erreur du fournisseur de revendications STS : événement 8307 (Produits SharePoint 2010)

Nom de l'alerte : erreur du fournisseur de revendications STS

ID d'événement : 8307

Résumé : le service d'émission de jeton de sécurité (STS, Security Token Service) a rencontré une erreur.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les utilisateurs ne sont pas en mesure de se connecter à Microsoft SharePoint Foundation 2010.

  • L'ouverture de session échoue.

  • Le sélecteur de personnes ne parvient pas à effectuer une recherche ou une résolution et retourne un message d'erreur.

  • Cet événement apparaît dans le journal des événements : ID d'événement : 8307 Description : Une exception s'est produite dans le fournisseur de revendications <nom du fournisseur de revendications> lors de l'appel de <nom de la méthode> : <exception>.

Cause : une erreur s'est produite, liée au fournisseur de revendications spécifié dans la description de l'exception.

Solution : désactiver le fournisseur de revendications

  1. Désactivez le fournisseur de revendications à l'origine de l'erreur et contactez son fabricant afin qu'il vous aide à résoudre l'erreur. Pour plus d'informations, voir Configurer l'authentification par revendications (SharePoint Foundation 2010)

    Important :
    Certains composants SharePoint Foundation 2010 peuvent nécessiter le fournisseur de revendications et risquent de ne pas fonctionner correctement s'il est désactivé. Par exemple, les applications de service partagé peuvent échouer pendant un appel, car les modules de sécurité considèrent que les revendications système n'ont pas été ajoutées par ce fournisseur.

Historique des modifications


Le service d'administration n'est pas en cours d'exécution

Nom de l'alerte : le service d'administration n'est pas en cours d'exécution

ID d'événement : numéro d'ID d'événement

Résumé : le service d'administration Microsoft SharePoint Foundation doit s'exécuter sur tous les serveurs d'une batterie de serveurs Microsoft SharePoint Foundation 2010. Ce service effectue plusieurs opérations sur les serveurs locaux qui requièrent des autorisations d'administrateur local. Il s'agit d'opérations telles que la création et la suppression d'applications Web et d'applications de service ou le démarrage et l'arrêt de services. Si ce service n'est en cours d'exécution sur aucun serveur d'une batterie de serveurs SharePoint Foundation 2010, les opérations d'administration peuvent échouer ou ne réussir qu'en partie.

Cause : une ou plusieurs des causes suivantes sont possibles :

  • Le service d'administration SharePoint Foundation a été arrêté par un administrateur sur un ordinateur spécifique.

  • Le nom d'utilisateur ou le mot de passe du compte sous lequel le service d'administration SharePoint Foundation doit s'exécuter est incorrect.

  • Une condition d'erreur dans le service d'administration SharePoint Foundation a provoqué l'arrêt de celui-ci.

Solution : démarrer le service d'administration

  • Démarrez le service d'administration SharePoint Foundation à l'aide du composant logiciel enfichable Services (services.msc) de la console de gestion Microsoft dans Windows. Cliquez sur Démarrer, cliquez sur Exécuter, puis tapez la commande suivante :

    services.msc

Solution : vérifier le compte de service

  • Si le service ne parvient pas démarrer, vérifiez que le nom d'utilisateur et le compte sont membres du groupe Administrateurs sur l'ordinateur local.

Solution : réparer la configuration

  • Si le service n'a pas pu être démarré, essayez de réparer la configuration de SharePoint Foundation sur le serveur concerné en exécutant l'Assistant Configuration des produits et technologies SharePoint.

Historique des modifications


Service de lancement des conversions de documents non disponible

Nom de l'alerte : Service de lancement des conversions de documents indisponible

ID de l'événement : Aucun

Résumé : Le Service de lancement des conversions de documents démarre les conversions de documents sur un serveur d'applications. Si le service de lancement des conversions de documents est interrompu, le service d'équilibrage de la charge de conversion de documents continue et les conversions de documents échouent. Pour reprendre la conversion de documents, vous devez redémarrer le Service de lancement des conversions de documents.

Symptômes : Un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les documents ne sont pas convertis.

  • Le Service de lancement des conversions de documents ne fonctionne pas.

Cause : Le service de lancement des conversions de documents ne fonctionne plus. Ce problème peut se produire quand un administrateur interrompt le service par accident ou que le serveur est à court de RAM.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer la tâche suivante.

Solution : redémarrer les services.

  1. Dans la page d'accueil Administration centrale de SharePoint, dans la section Paramètres système, cliquez sur Gérer les services sur le serveur.

  2. Dans la page Services sur le serveur, cliquez sur Service de lancement des conversions de documents.

  3. Dans la section Sélectionner un serveur, vérifiez que le serveur souhaité est sélectionné. Dans le cas contraire, dans le menu Serveur, cliquez sur Modifier serveur.

  4. Ensuite, dans la page Sélectionner un serveur, cliquez sur le nom du serveur sur lequel vous souhaitez exécuter le Service de lancement des conversions de documents.

  5. Dans la section Schéma de communication, sélectionnez le schéma que doit utiliser le service de lancement pour les communications. Le schéma par défaut est http.

  6. Dans la section Numéro du port, tapez le numéro de port que le lanceur doit utiliser pour les communications. Entrez un numéro de port qui n'est pas utilisé par les autres services sur le serveur, mais qui est ouvert dans le pare-feu sur le serveur.

  7. Cliquez sur OK.

Historique des modifications


Service d'équilibrage de la charge de conversion de document indisponible

Nom de l'alerte : Service d'équilibrage de la charge de conversion de document indisponible

ID de l'événement : Aucun

Résumé : Le service d'équilibrage de la charge de conversion de documents gère la disponibilité des convertisseurs de documents. Interrompre le service interrompt également le processus de conversion de documents et désactive le service de lancement des conversions de documents. Pour reprendre le processus de conversion de documents, vous devez redémarrer me service d'équilibrage de la charge de conversion de documents, puis démarrer le service de lancement des conversions de documents.

Symptômes : Un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • Les documents ne sont pas convertis.

  • Seul un serveur semble encore convertir des documents.

  • Le service d'équilibrage de la charge de conversion de documents ne fonctionne pas.

Cause : Le service d'équilibrage de la charge de conversion de documents ne fonctionne plus. Ce problème peut se produire quand un administrateur interrompt le service par accident ou que le serveur n'a plus de RAM.

Remarque :
Vous devez être membre du groupe SharePoint Administrateurs de batterie pour effectuer la tâche suivante.

Résolution : Redémarrez le service d'équilibrage de la charge de conversion de documents

  1. Dans la page d'accueil Administration centrale de SharePoint, dans la section Paramètres système, cliquez sur Gérer les services sur le serveur.

  2. Dans la page Services sur le serveur, cliquez sur Service d'équilibrage de la charge de conversion de documents.

  3. Dans la section Sélectionner un serveur, vérifiez que le serveur souhaité est sélectionné. Dans le cas contraire, dans le menu Serveur, cliquez sur Modifier serveur.

  4. Ensuite, dans la page Sélectionner un serveur, cliquez sur le nom du serveur sur lequel vous souhaitez exécuter le Service d'équilibrage de la charge de conversion de documents.

  5. Dans la section Schéma de communication, sélectionnez le schéma que doit utiliser l'équilibrage de charge pour les communications. Le schéma par défaut est http.

  6. Dans la section Numéro du port, tapez le numéro de port que doit utiliser l'équilibrage de charge pour les communications. Choisissez un numéro de port qui n'est pas utilisé par les autres services sur le serveur, mais qui est ouvert dans le pare-feu sur le serveur.

  7. Cliquez sur OK.

Résolution : Redémarrez le service de lancement des conversions de documents

  1. Dans la page d'accueil Administration centrale de SharePoint, dans la section Paramètres système, cliquez sur Gérer les services sur le serveur.

  2. Dans la page Services sur le serveur, cliquez sur Service de lancement des conversions de documents.

  3. Dans la section Sélectionner un serveur, vérifiez que le serveur souhaité est sélectionné. Dans le cas contraire, dans le menu Serveur, cliquez sur Modifier serveur.

  4. Ensuite, dans la page Sélectionner un serveur, cliquez sur le nom du serveur sur lequel vous souhaitez exécuter le Service de lancement des conversions de documents.

  5. Dans la section Schéma de communication, sélectionnez le schéma que doit utiliser le service de lancement pour les communications. Le schéma par défaut est http.

  6. Dans la section Numéro du port, tapez le numéro de port que le lanceur doit utiliser pour les communications. Entrez un numéro de port qui n'est pas utilisé par les autres services sur le serveur, mais qui est ouvert dans le pare-feu sur le serveur.

  7. Cliquez sur OK.

Historique des modifications


L'article technique n'est pas encore disponible

Nom de l'alerte : L'article technique n'est pas encore disponible

ID d'événement : Aucun

Résumé : Le Pack d'administration de Microsoft System Center Operations Manager surveille Microsoft SharePoint Foundation 2010. System Center Operations Manager a généré une alerte en raison d'un problème dans SharePoint Foundation 2010.

Le lien dans l'alerte doit normalement mener à un article technique avec plus de détails sur la façon de résoudre le problème. L'article technique n'est cependant pas encore disponible. Il sera disponible à une date ultérieure. Pour résoudre le problème, essayez une ou plusieurs des solutions suivantes, en respectant l'ordre indiqué (cliquez sur le lien pour accéder à la procédure décrite dans cet article) :

  • Afficher et résoudre les alertes de l'analyseur d'intégrité SharePoint à l'aide de l'Administration centrale

  • Consultez le journal des événements Windows.

  • Consultez le journal de diagnostic.

  • Consultez le Guide du Pack d'administration et la documentation du produit.

  • Redémarrez le service affecté.

  • Redémarrer le pool d'applications

  • Redémarrez Internet Information Services.

  • Redémarrez le serveur affecté.

  • Contactez le support technique Microsoft.

Afficher et résoudre les alertes de l'analyseur d'intégrité SharePoint à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Analyseur d'intégrité, cliquez sur Examiner les problèmes et solutions.

  4. Dans la page Examiner les problèmes et solutions, cliquez sur l'alerte à afficher et à résoudre.

  5. Pour résoudre le problème, suivez l'aide fournie dans la section Solution de la boîte de dialogue Examiner les problèmes et solutions. Gardez la boîte de dialogue ouverte afin de pouvoir réexécuter la règle pour vérifier la résolution.

  6. Après avoir suivi l'aide fournie dans la section Solution, dans la boîte de dialogue Examiner les problèmes et solutions associée à l'alerte, cliquez sur Réanalyser maintenant pour vérifier la résolution. Si le problème est résolu, le statut de l'alerte passe à 4-Réussite.

Redémarrer le pool d'applications

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est un membre du groupe Administrateurs sur l'ordinateur local.

  2. Effectuez les étapes décrites dans l'article suivant : Recycler un pool d'applications à la demande (http://go.microsoft.com/fwlink/?linkid=168806&clcid=0x40C).

Historique des modifications


Le code en bac à sable est en cours d'exécution

Nom de l'alerte : Le code en mode bac à sable du service d'instance SP est en cours d'exécution

ID d'événement : Aucun ID d'événement

Résumé : L'ordinateur hôte du code en mode bac à sable SharePoint est un service Windows NT fonctionnant sur chaque serveur Microsoft SharePoint Foundation.

Symptômes : Vous ne parvenez pas à effectuer de requêtes nécessitant l'exécution du code utilisateur ou l'activation de solutions en mode bac à sable contenant le code utilisateur. La tâche qui échoue dépend de la topologie et du serveur où le service est arrêté.

Cause : Le service d'exécution de code en mode bac à sable sur l'ordinateur hôte n'est pas en cours d'exécution.

Solution : Démarrez le service sur le serveur concerné

  • Vous pouvez redémarrer l'ordinateur hôte du code en mode bac à sable SharePoint sur un serveur spécifique en utilisant la commande suivante à partir d'une invite de commandes avec élévation de privilèges :

    net start spusercodev4

Historique des modifications


Le service d'administration de SharePoint est désactivé

Nom de l'alerte : le service d'administration SharePoint est désactivé

ID d'événement : numéro d'ID d'événement

Résumé : le service d'administration SharePoint V4 (SPAdminV4) est désactivé, ce qui empêche les travaux du minuteur d'administration du serveur local de remplacer les paramètres de celui-ci par les paramètres à l'échelle de la batterie.

Cause : le service d'administration SharePoint V4 (SPAdminV4) est désactivé et ne peut pas être démarré.

Solution : désactiver la fonctionnalité de limitation

  • Si vous souhaitez que le service d'administration SharePoint V4 (SPAdminV4) s'exécute dans l'environnement, configurez-le de manière à ce qu'il démarre automatiquement, puis démarrez-le. Cette opération peut être effectuée à l'aide du composant logiciel enfichable Services (services.msc) de la console de gestion Microsoft ou, dans la fenêtre d'invite de commandes, des deux commandes suivantes, exécutées dans l'ordre indiqué par un administrateur de batterie de serveurs également membre du groupe Administrateurs sur l'ordinateur local.

    SC CONFIG SPAdminV4 start= auto

    SC START SPAdminV4

Solution : exécuter les travaux du minuteur d'administration sans démarrer le service d'administration

  • Si vous ne souhaitez pas que le service d'administration SharePoint V4 (SPAdminV4) soit défini de manière à s'exécuter dans l'environnement, par exemple pour des raisons liées au principe des privilèges minimum, les travaux du minuteur d'administration peuvent être exécutés directement sur le serveur local sans que le service d'administration démarre. Pour exécuter les travaux du minuteur immédiatement, dans SharePoint 2010 Management Shell, exécutez la commande Windows PowerShell suivante :

    Start-SPAdminJob

Remarque :
L'opération Start-SPAdminJob doit être exécutée sur tous les ordinateurs de la batterie de serveurs sur lesquels le service d'administration SharePoint V4 (SPAdminV4) n'est pas exécuté. Exécutez cette commande pour effectuer les tâches de mise en service et les autres tâches administratives généralement réalisées à l'aide du service du minuteur SharePoint Foundation (SPTimer_V4).

Historique des modifications


La recherche SharePoint Foundation 2010 n'est pas en cours d'exécution

Nom de l'alerte : La recherche SharePoint Foundation n'est pas en cours d'exécution

ID d'événement : Pas d'ID d'événement

Résumé : Le service de recherche Microsoft SharePoint Foundation 4 Search (SPSearch4) est un service Windows NT qui s'exécute sur chaque serveur hébergeant une application de service de recherche.

Symptômes : Un ou plusieurs des symptômes suivants peuvent apparaître :

  • Le service de recherche Microsoft SharePoint Foundation 4 Search (SPSearch4) est arrêté.

  • Vous n'êtes pas en mesure d'effectuer des tâches lorsque vous essayez d'utiliser la fonctionnalité d'analyse, de requête ou de recherche d'administration. La tâche qui échoue dépend de la topologie et du serveur sur lequel le service est arrêté.

Cause : Le service de recherche Microsoft SharePoint Foundation 4 Search (SPSearch4) n'est pas en cours d'exécution.

Résolution : Démarrez le service sur le serveur

  • Vous pouvez redémarrer le service de recherche Microsoft SharePoint Foundation 4 Search (SPSearch4) sur un serveur spécifique en tapant la commande suivante à une invite de commandes avec élévation de privilèges :

    net start spsearch4

Historique des modifications


L'Analyseur d'intégrité SharePoint a détecté une erreur ou un avertissement (Produits SharePoint 2010)

Nom de l'alerte : L'Analyseur d'intégrité SharePoint de a détecté une erreur ou un avertissement

ID de l'événement : Aucun

Résumé : l'analyseur d'intégrité SharePoint a détecté une erreur ou un avertissement liés aux performances, à la disponibilité ou à la sécurité de la batterie de serveurs. Pour savoir comment résoudre la condition d'erreur ou d'avertissement, consultez le message d'erreur et l'explication.

Résolution : Affichez et résolvez les alertes de l'Analyseur d'intégrité SharePoint à l'aide de l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Analyseur d'intégrité, cliquez sur Examiner les problèmes et solutions.

  4. Dans la page Examiner les problèmes et solutions, cliquez sur l'alerte à afficher et à résoudre.

  5. Pour résoudre le problème, suivez l'aide fournie dans la section Solution de la boîte de dialogue Examiner les problèmes et solutions. Gardez la boîte de dialogue ouverte afin de pouvoir réexécuter la règle pour vérifier la résolution.

  6. Après avoir suivi l'aide fournie dans la section Solution, dans la boîte de dialogue Examiner les problèmes et solutions associée à l'alerte, cliquez sur Réanalyser maintenant pour vérifier la résolution. Si le problème est résolu, le statut de l'alerte passe à 4-Réussite.

Historique des modifications


Le service minuteur de SharePoint Timer n'a pas pu démarrer

Nom de l'alerte : Le minuteur de SharePoint Services n'a pas pu démarrer

ID de l'événement : Aucun

Résumé : Microsoft SharePoint Foundation 2010 utilise le service Minuteur de Windows SharePoint Services version 4 (SPTimerV4) pour exécuter la plupart des tâches du système. Le service du minuteur redémarre quand le compte de service de batterie de serveur change et il redémarre chaque jour au cours du travail de recyclage du minuteur. Si SharePoint Foundation 2010 ne peut pas démarrer le service du minuteur, les mises à jour à la configuration de la batterie de serveurs ne seront pas synchronisées avec le serveur local.

Symptômes : Les tâches fréquentes du minuteur, par exemple les alertes immédiates et les workflows, ne s'exécutent pas. Les mises à jour de la configuration de la batterie de serveurs ne sont pas synchronisées avec le serveur local.

Cause : SharePoint Foundation 2010 ne peut pas démarrer le service minuteur de SharePoint Services V4 (SPTimerV4).

Résolution : Démarrer le service du minuteur

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est un membre du groupe Administrateurs sur l'ordinateur local.

  2. Ouvrez une fenêtre d'invite de commande, tapez la commande suivante, puis appuyez sur la touche ENTRÉE :

    net start sptimerv4

  3. Si le service ne démarre pas, vérifiez que le compte d'identité de service est configuré correctement à l'aide de la procédure « Vérifier le compte de service », plus loin dans cet article.

Résolution : Vérifier le compte de service

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est un membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, cliquez sur Outils d'administration, puis cliquez sur Services.

  3. Dans le composant logiciel enfichable Services, cliquez avec le bouton droit sur le service minuteur de SharePoint Services V4, puis cliquez sur Propriétés.

  4. Dans la boîte de dialogue Propriétés du service, sous l'onglet Se connecter, tapez le mot de passe du compte, confirmez-le puis cliquez sur OK.

  5. Cliquez avec le bouton droit sur le service, puis cliquez sur Démarrer.

Historique des modifications


Le service minuteur de SharePoint Timer n'est pas en cours d'exécution

Nom de l'alerte : Le service Minuteur de Windows SharePoint Services n'est pas en cours d'exécution

ID de l'événement : Aucun

Résumé : Microsoft SharePoint Foundation 2010 utilise le service Minuteur de Windows SharePoint Services version 4 (SPTimerV4) pour exécuter la plupart des tâches du système.

Symptômes : Les tâches fréquentes du minuteur, par exemple les alertes immédiates et les workflows, ne s'exécutent pas. Les mises à jour de la configuration de la batterie de serveurs ne sont pas synchronisées avec le serveur local.

Cause : Le service Minuteur de Windows SharePoint Services version 4 (SPTimerV4) ne s'exécute pas.

Résolution : Démarrer le service du minuteur

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est un membre du groupe Administrateurs sur l'ordinateur local.

  2. Ouvrez une fenêtre d'invite de commande, tapez la commande suivante, puis appuyez sur la touche ENTRÉE :

    net start sptimerv4

  3. Si le service ne démarre pas, vérifiez que le compte d'identité de service est configuré correctement à l'aide de la procédure « Vérifier le compte de service », plus loin dans cet article.

Résolution : Vérifier le compte de service

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est un membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, cliquez sur Outils d'administration, puis cliquez sur Services.

  3. Cliquez avec -click Windows SharePoint Services Timer V4, and then click Properties.

  4. Dans l'onglet Se connecter, confirmez que le compte utilisé est un compte d'utilisateur de domaine et membre des éléments suivants :

    • dbcreator Rôle de serveur fixe SQL Server

    • securityadmin Rôle de serveur fixe SQL Server

    • db_owner Rôle de base de données fixe pour toutes les bases de données de la batterie de serveurs

  5. Si le compte a des autorisations suffisantes, confirmez le mot de passe en tapant le mot de passe du compte, puis en le retapant dans la zone Confirmer le mot de passe, et cliquez sur OK.

  6. Démarrez le service en cliquant avec le bouton droit de la souris sur le nom de service dans la console Services, puis cliquez sur Démarrer.

Historique des modifications


L'accès à distance à SQL Server est désactivé (Produits SharePoint 2010)

Nom de l'alerte : l'accès à distance à SQL Server est désactivé.

ID de l'événement : aucun

Résumé : Produits Microsoft SharePoint 2010 utilise Microsoft SQL Server 2008 Express pour stocker les données, dont l'accès à distance est désactivé par défaut. En fonction de la configuration de votre batterie de serveurs, il est possible qu'un ordinateur distant nécessite l'accès à la base de données SQL Server 2008 Express.

Symptômes : échec de la connexion à SQL Server 2008 Express à partir d'un serveur distant.

Cause : l'accès à distance est désactivé.

Solution : activer l'accès à distance

  1. Activer l'accès à distance. Pour plus d'informations, voir Comment faire pour configurer SQL Server 2005 afin de permettre les connexions à distance (http://support.microsoft.com/kb/914277/fr).

Historique des modifications


Le service de gestion du suivi n'est pas en cours d'exécution

Nom de l'alerte : Le service de gestion du suivi n'est pas en cours d'exécution

ID d'événement : Pas d'ID d'événement

Résumé : Le service de gestion du suivi (SPTrace) de Microsoft SharePoint Foundation est un service obligatoire sur tous les serveurs Microsoft SharePoint Foundation. Si ce service est arrêté, les messages d'erreur ne sont pas tous consignés sur le serveur.

Symptômes : Aucune sortie du suivi n'est enregistrée dans les journaux de gestion de suivi et aucune erreur n'est journalisée dans le journal Windows.

Cause : La cause peut être une ou plusieurs des causes suivantes :

  • Un administrateur a involontairement arrêté le service de gestion de suivi de SharePoint Foundation.

  • Une mise à niveau qui a été démarrée sur ce serveur n'a pu être menée à terme.

Résolution : Redémarrez le service de gestion de suivi

  1. Connectez-vous au serveur SharePoint Foundation en tant qu'administrateur.

  2. Dans une fenêtre d'invite de commandes, tapez ce qui suit à l'invite :

    net start SPTrace

Historique des modifications


L'application Web prend trop de temps pour restituer une page (SharePoint 2010 Products)

Nom de l'alerte : l'application Web prend trop de temps pour restituer une page

ID de l'événement : aucun

Résumé : le compteur de performance Temps d'exécution/Demande de page Microsoft SharePoint Foundation 2010 surveille le temps que met une application Web pour afficher une page Web. Le seuil de ce compteur de performance peut être dépassé en cas de surcharge temporaire du réseau ou de pic de la demande de la part de l'ordinateur exécutant Microsoft SQL Server. Si le seuil est dépassé même si le réseau n'est pas surchargé, l'application Web consomme trop de mémoire.

Symptômes : un ou plusieurs symptômes parmi les suivants peuvent apparaître :

  • L'affichage des pages prend trop de temps.

  • Le seuil du compteur de performance Temps d'exécution/Demande de page est fréquemment dépassé.

Cause : la ou les causes peuvent être :

  • SharePoint Foundation 2010 n'est pas configuré correctement.

  • Le matériel du serveur n'est pas en mesure de gérer les demandes des utilisateurs.

Solution: suivre les meilleures pratiques en matière de configuration

  • Suivez les recommandations pour une configuration optimale indiquées dans Meilleures pratiques pour un fonctionnement optimal.

Solution : régler les performances d'un serveur Web

  • Suivez les recommandations en matière d'architecture physique et de réglage permettant d'améliorer les performances des serveurs Web indiquées dansRégler les performances d'un serveur Web (Office SharePoint Server).

Historique des modifications


Application Web non disponible (produits SharePoint 2010)

Nom d'alerte : application Web non disponible

ID d'événement : aucun

Résumé : ce moniteur tente d'accéder à l'application Web à partir du serveur SCOM (System Center Operations Manager) à l'aide du compte Exécuter en tant qu'administrateur. Le moniteur indique un état d'erreur lorsque le serveur SCOM reçoit un code d'état supérieur à 400.

Symptômes : le serveur SCOM reçoit un code d'état supérieur à 400.

Cause : la ou les causes peuvent être :

  • L'application Web n'est pas disponible.

  • Le compte Exécuter en tant qu'administrateur ne dispose pas des autorisations suffisantes pour accéder à l'application Web.

Résolution : vérifier que l'application Web existe et qu'elle est en cours d'exécution

  1. Dans le composant logiciel enfichable Gestionnaire des Services Internet (IIS), développez le nœud du serveur et le nœud Sites.

  2. Sélectionnez le site Web de l'application Web et vérifiez que le site est en cours d'exécution. Dans le cas contraire, démarrez-le. Si vous ne pouvez pas le démarrer, passez à l'étape suivante.

  3. Sélectionnez le nœud Pools d'applications. Dans le volet de droite, assurez-vous que le pool d'applications pour l'application Web est démarré. Dans le cas contraire, démarrez-le. Si vous ne pouvez pas le démarrer, passez à l'étape suivante pour vérifier le compte Identité.

  4. Cliquez avec le bouton droit sur le pool d'applications, puis cliquez sur Paramètres avancés.

  5. Dans la boîte de dialogue Paramètres avancés, dans la section Modèle de processus, assurez-vous que le compte Identité dispose d'autorisations suffisantes pour exécuter l'application Web.

  6. Vous devrez peut-être mettre à jour le mot de passe pour le compte Identité. Pour ce faire, cliquez sur les points de suspension en regard du compte.

  7. Dans la boîte de dialogue Identité du pool d'applications, cliquez sur Définir.

  8. Dans la boîte de dialogue Définir les informations d'identification, tapez le nom du compte et le mot de passe, puis cliquez sur OK.

  9. Dans le composant logiciel enfichable IIS, essayez de démarrer le pool d'applications. S'il ne démarre pas, le compte ne dispose pas d'autorisations suffisantes ; s'il démarre, démarrez alors le site Web.

Résolution : vérifier que le compte Exécuter en tant qu'administrateur dispose des autorisations nécessaires

  1. Dans la page d'accueil Administration centrale, cliquez sur Sécurité puis, dans la section Utilisateurs, cliquez sur Spécifier la stratégie utilisateur des applications Web.

  2. Dans la page Fournisseurs d'authentification, sélectionnez l'application Web adéquate. Pour ce faire, cliquez sur la flèche en regard de la liste Application Web, puis cliquez sur Modifier Application Web. Dans la boîte de dialogue Sélectionner une application Web, cliquez sur l'application Web adéquate.

  3. Cliquez sur le compte Exécuter en tant qu'administrateur. Il s'agit du compte qui est spécifié comme compte Identité dans la solution ci-dessus. Si le compte n'est pas répertorié, passez à l'étape suivante.

  4. Cliquez sur Ajouter des utilisateurs.

  5. Dans la page Modifier l'utilisateur, dans la section Niveaux de stratégies d'autorisation, activez la case à cocher Contrôle total : Dispose d'un contrôle total.

  6. Cliquez sur Enregistrer.

Historique des modifications


Site Web non disponible (produits SharePoint 2010)

Si une page Web n'est pas disponible, Produits SharePoint 2010 ne peut pas afficher la page Web, et les utilisateurs ne peuvent pas y accéder.

Nom d'alerte : site Web non disponible

ID d'événement : aucun

Résumé : si une page Web n'est pas disponible, Produits SharePoint 2010 ne peut pas afficher la page Web et les utilisateurs ne peuvent pas y accéder.

Symptômes : le site Web Produits SharePoint 2010 est en panne ou ses pages ne s'affichent pas.

Cause : la ou les causes peuvent être :

  • Le site Web n'est pas disponible.

  • Le compte Exécuter en tant qu'administrateur du pack d'administration n'est pas habilité à accéder au site Web Produits SharePoint 2010.

Solution : vérifier que le site Web apparaît dans la collection de sites

  1. Sur le site Web Administration centrale, dans la barre de lancement rapide, cliquez sur Gestion des applications.

  2. Dans la page Gestion des applications, dans la section Collections de sites, cliquez sur Afficher toutes les collections de sites.

  3. Si l'URL relative de la collection de sites n'est pas valide, exécutez une découverte duavec le pack d'administration.

  4. Si le problème persiste après l'exécution de la découverte du pack d'administration, vérifiez les points suivants :

    • Le serveur SharePoint Foundation qui héberge le site Web est en cours d'exécution et est accessible sur le réseau.

    • Les services Internet (IIS) sont en cours d'exécution.

Solution : vérifier que le compte Exécuter en tant qu'administrateur dispose des autorisations nécessaires

  1. Dans la page d'accueil Administration centrale, cliquez sur Sécurité, puis, dans la section Utilisateurs, cliquez sur Spécifier la stratégie utilisateur des applications Web.

  2. Dans la page Fournisseurs d'authentification, sélectionnez l'application adéquate. Pour ce faire, cliquez Application Web, puis sur Modifier Application Web. Dans la boîte de dialogue Sélectionner une application Web, cliquez sur l'application Web adéquate.

  3. Cliquez sur le compte Exécuter en tant qu'administrateur. Il s'agit du compte spécifié comme compte Identité dans les services Internet (IIS) pour l'application Web qui exécute le site Web. Si le compte n'est pas répertorié, cliquez sur Ajouter des utilisateurs.

  4. Dans la page Modifier l'utilisateur, dans la section Niveaux de stratégies d'autorisation, activez la case à cocher Contrôle total : Dispose d'un contrôle total.

  5. Cliquez sur Enregistrer.

Historique des modifications


Référence aux règles de l'Analyseur d'intégrité SharePoint (SharePoint Foundation 2010)

Les articles de cette section portent sur l'analyseur d'intégrité SharePoint. En règle générale, vous accédez à ces articles après avoir cliqué sur un lien contenu dans une alerte de l'analyseur d'intégrité SharePoint de l'Administration centrale. Ces articles peuvent vous être utiles pour diagnostiquer et résoudre les problèmes liés à Microsoft SharePoint Foundation 2010.

Dans cette section :

  • Web Applications using Claims authentication require an update

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Les Web Applications qui utilisent l'authentification basée sur les revendications nécessitent une mise à jour », et indique comment mettre à jour l'authentification basée sur les revendications.

  • Paramètre de mise à jour automatique incohérent entre les serveurs de batterie

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Le paramètre Mises à jour automatiques est incohérent sur les serveurs de la batterie »", et indique comment configurer les paramètres de mise à jour automatique de façon cohérente dans une batterie de serveurs.

  • La journalisation des diagnostics est définie en mode détaillé

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « La journalisation des diagnostics est définie en mode détaillé », et explique comment configurer la journalisation des diagnostics.

  • Le compte de batterie de serveur ne doit pas être utilisé pour d'autres services

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Le compte de la batterie de serveur ne doit pas être utilisé pour d'autres services », et indique comment modifier le compte utilisé pour les autres services.

  • Un ou plusieurs services ont démarré ou se sont arrêtés de manière inattendue

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Des services ont démarré ou se sont arrêtés brusquement », et explique comment démarrer le service qui ne fonctionne pas.

  • Les bases de données utilisées par SharePoint ont des index fragmentés

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Des bases de données utilisées par SharePoint comportent des index fragmentés », et explique comment réorganiser et régénérer les index.

  • Les bases de données contiennent des éléments orphelins

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Des bases de données de contenu contiennent des éléments orphelins », et indique comment supprimer les sites orphelins du contenu.

  • La messagerie sortante n'a pas été configurée

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Le courrier électronique sortant n'a pas été configuré », et explique comment configurer les paramètres de courrier électronique sortant dans l'Administration centrale.

  • Certaines règles de l'Analyseur d'intégrité n'ont pas de travaux de minuteur associés

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Certaines règles de l'analyseur d'intégrité ne sont associées à aucun travail du minuteur », et explique comment créer les travaux du minuteur de collecte de données relatives à l'état.

  • Les lecteurs manquent d'espace

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Les lecteurs manquent d'espace libre », et explique comment libérer de l'espace disque sur l'ordinateur serveur.

  • La taille du fichier d'échange doit dépasser la quantité de RAM physique du système

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « La taille du fichier d'échange doit dépasser la quantité de RAM physique dans le système », et explique comment augmenter la taille minimale du fichier d'échange.

  • Les comptes intégrés sont utilisés comme identités de service ou pool d'applications

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Les comptes intégrés sont utilisés comme pool d'applications ou identités de service », et indique comment modifier l'identité utilisée pour le service ou le pool d'applications.

  • Web Analytics : contrôle l'intégrité du composant Consolidateur de rapport

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Le service Web Analytics contrôle l'intégrité du composant Report Consolidator », et explique comment activer la suppression de données pour améliorer les performances de Report Consolidator.

  • Web Analytics : vérifie que lorsque Web Analytics est installé et en cours d'exécution, la journalisation de l'utilisation est activée dans la batterie.

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Le composant Web Analytics vérifie que la journalisation de l'utilisation est activée dans la batterie de serveurs lorsque le service Web Analytics est installé et en cours d'exécution », et explique comment activer la journalisation de l'utilisation.

  • Web Analytics : vérifie qu'une application Web est prise en charge par un proxy d'application de service Web Analytics au maximum

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Le service Web vérifie Analytics qu'une application Web est traitée par un seul proxy d'application de service Web Analytics », et indique comment dissocier d'autres proxys d'application de service Web Analytics.

  • Web Analytics : vérifie que SQL Server Service Broker est activé pour les bases de données de transit Web Analytics

    Cet article fournit des informations sur la règle de l'analyseur d'intégrité SharePoint « Web Analytics : vérifie que SQL Server Service Broker est activé pour les bases de données de la zone de transit Web Analytics », et indique comment activer la file d'attente de Service Broker.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | 2010/07/05 | Mise à jour du contenu


Les applications Web qui utilisent l'authentification basée sur les revendications nécessitent une mise à jour (SharePoint Foundation 2010)

Nom de règle : Les Web Applications qui utilisent l'authentification basée sur les revendications nécessitent une mise à jour

ID d'événement : aucun

Résumé : les applications Web qui utilisent l'authentification basée sur les revendications sont exposées à une faille de sécurité potentielle qui pourrait permettre aux utilisateurs d'élever leurs privilèges. Les serveurs Web qui hébergent des applications Web qui utilisent l'authentification basée sur les revendications sont potentiellement vulnérables.

Cause : cela peut se produire lorsque vous déployez une application Web Microsoft ASP.NET 2.0 sur un site Web hébergé sur un serveur exécutant Microsoft SharePoint Foundation 2010 et que IIS (Internet Information Services) version 7.0 ou 7.5 s'exécute en mode Intégré sur le serveur.

Si vous déployez des composants WebPart partiellement approuvés ou que vous créez des listes externes sur le site SharePoint, ces composants WebPart ou les listes externes peuvent bénéficier d'autorisations plus importantes qu'elles le devraient. Ce problème peut engendrer un risque de sécurité sur le site SharePoint. Par exemple, ces composants WebPart ou les listes externes peuvent générer des requêtes de base de données ou des demandes HTTP de manière inattendue.

Ce problème se produit en raison d'une modification intervenue dans le composant d'authentification ASP.NET 2.0. De ce fait, les composants WebPart partiellement approuvés ou les listes externes empruntent l'identité du compte de pool d'applications, et les composants WebPart peuvent accéder au site SharePoint à la faveur d'une autorisation complète.

Résolution : installer la mise à jour

  • Pour télécharger la mise à jour, rendez-vous à l'adresse KB979917 - Correctif QFE des problèmes SharePoint - Réparation du compteur de performances et emprunt d'identité d'utilisateur.

  • Pour plus d'informations sur la mise à jour, voir l'article n° 979917 de la base de connaissances.

Historique des modifications


Paramètre de mise à jour automatique incohérent entre les serveurs de batterie

Nom de la règle : Le paramètre Mises à jour automatiques est incohérent sur les serveurs de la batterie.

Résumé : Les paramètres de mise à jour automatiques configurés sur les serveurs de la batterie SharePoint ne sont pas les mêmes.

Cause : un ou plusieurs serveurs de la batterie ont des paramètres Mises à jour automatiques qui sont différents des autres serveurs dans la batterie.

Solution : Vérifier que tous les serveurs de la batterie ont le même paramètre Mises à jour automatiques

  • Choisissez un paramètre Mises à jour automatiques identique sur chaque serveur de la batterie. Sur chaque serveur de la batterie, ouvrez la page des paramètres de mise à jour automatiques et vérifiez que les paramètres sont configurés selon le paramètre établi.

    1. Cliquez sur Démarrer, sur Tous les programmes, puis sur Windows Update.

    2. Dans la page Windows Update du Panneau de configuration, cliquez sur Modifier les paramètres.

    3. Dans l'écran Choisissez comment Windows installe les mises à jour, assurez-vous que les paramètres de mise à jour sont conformes à vos intentions. Modifiez les paramètres de mise à jour si nécessaire.

      Remarque :
      Si vous ne pouvez pas modifier les paramètres de mise à jour, il est possible qu'ils soient verrouillés en raison de la stratégie de groupe. Dans ce cas, assurez-vous que la même stratégie de groupe est appliquée à d'autres serveurs dans la batterie.

Historique des modifications

Date | Description | Raison
4 juin 2010 | Publication initiale |


La journalisation des diagnostics est définie en mode détaillé

Nom de la règle : La journalisation des diagnostics est définie sur Détaillé

Résumé : SharePoint Foundation écrit les informations de journalisation des diagnostics pour enregistrer l'activité sur le serveur. Les journaux contiennent des informations qui peuvent vous aider à diagnostiquer des problèmes liés au serveur. Cette règle se produit lorsque la journalisation des diagnostics est définie sur Détaillé. Vous pouvez utiliser ce paramètre lorsque vous devez diagnostiquer un problème lié au serveur, mais il est conseillé de désactiver la journalisation détaillée lors d'opérations normales.

Cause : Une ou plusieurs catégories de journalisation détaillée sont définies sur Détaillé.

Solution : Réinitialiser la journalisation des diagnostics à son niveau par défaut

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configuration de la journalisation des diagnostics.

  4. Dans la section Limitation des événements, dans les listes Événement le moins critique à enregistrer dans le journal d'événements et Événement le moins critique à enregistrer dans le journal de suivi, sélectionnez Rétablir les valeurs par défaut.

  5. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
4 juin 2010 | Publication initiale |


Le compte de batterie de serveur ne doit pas être utilisé pour d'autres services

Nom de règle : Le compte de la batterie de serveur ne doit pas être utilisé pour d'autres services

Résumé : le compte sous lequel le service du minuteur SharePoint 2010 et d'autres services système sont exécutés dans la batterie de serveurs SharePoint ne doit pas être utilisée pour les autres services de la batterie.

Cause : le compte de la batterie de serveurs, qui est utilisé pour le service du minuteur SharePoint 2010 et le site Administration centrale, est doté de privilèges élevés et ne doit pas être utilisé pour d'autres services sur les ordinateurs de la batterie de serveurs. Il a été découvert que des services de la batterie utilisent ce compte.

Résolution : modifier le compte utilisé pour les autres services

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe Administrateurs de batterie de serveurs de SharePoint.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Sécurité puis, dans la section Sécurité générale, cliquez sur Configurer les comptes de service.

  3. Dans la page Comptes de service, dans la section Gestion des informations d'identification, dans la liste déroulante supérieure, cliquez sur le service dont vous souhaitez mettre à jour les informations d'identification.

  4. Dans la liste Sélectionnez un compte pour ce composant, cliquez sur le compte de domaine que vous voulez associer à ce service.

  5. Si vous souhaitez enregistrer le compte que vous avez sélectionné dans la batterie SharePoint Foundation 2010, cliquez sur Enregistrer le compte géré.

  6. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Un ou plusieurs services ont démarré ou se sont arrêtés de manière inattendue

Nom de règle : Des services ont démarré ou se sont arrêtés brusquement

Résumé : un service critique indispensable au fonctionnement de la batterie de serveurs SharePoint n'est pas en cours d'exécution.

Cause : un ou plus services critiques ne sont pas en cours d'exécution sur le serveur spécifié.

Résolution : démarrer le service qui n'est pas en cours d'exécution

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs sur l'ordinateur local.

  2. Cliquez sur Démarrer, sur Outils d'administration, puis sur Services.

  3. Cliquez avec le bouton droit sur le service à démarrer, puis cliquez sur Démarrer.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Les bases de données utilisées par SharePoint ont des index fragmentés
Voir aussi

Nom de la règle : Des bases de données utilisées par SharePoint comportent des index fragmentés

Résumé : Microsoft SharePoint Foundation 2010 utilise Microsoft SQL Server pour stocker la plupart du contenu pour le site Web et les paramètres de configuration. Une ou plusieurs des bases de données utilisées par SharePoint Foundation contient des index fragmentés. Un index fragmenté peut entraîner une dégradation des performances.

Cause : Les index de base de données peuvent se fragmenter au fil du temps en raison des opérations d'insertion et de mise à jour effectuées par SharePoint Foundation. Nous vous recommandons de supprimer et de reconstruire périodiquement ces index pour améliorer les performances du système.

Solution : Réorganiser et reconstruire les index

  1. Pour corriger la fragmentation d'index, vous pouvez réorganiser un index ou le reconstruire. Pour plus d'informations, voir Réorganisation et reconstruction d'index (http://go.microsoft.com/fwlink/?linkid=160083&clcid=0x40C).

Voir aussi

Autres ressources

Exemple : fragmentation d'index avec insertion/mises à jour, mesure et correction (éventuellement en anglais)

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Les bases de données contiennent des éléments orphelins

Nom de la règle : Les bases de données de contenu contiennent des éléments orphelins

Résumé : L'analyseur d'intégrité SharePoint a détecté certains sites dans une base de données de contenu qui ne sont pas référencés dans la base de données de configuration. Ces sites ne sont peut être pas accessibles.

Cause : Une opération de restauration qui n'a pas été achevée peut entraîner le non-référencement des sites d'une base de données de contenu dans la base de données de configuration SharePoint.

Résolution : Supprimer les sites orphelins des bases de données de contenu

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Analyseur d'intégrité, cliquez sur Examiner les problèmes et solutions.

  4. Dans la page Examiner les problèmes et solutions, cliquez sur l'alerte pour la règle en échec, puis cliquez sur Résoudre maintenant. Gardez la boîte de dialogue ouverte afin de pouvoir réexécuter la règle pour confrmer la résolution.

    Remarque :
    La fonctionnalité de résolution supprime tous les orphelins de la base de données de contenu.

  5. Après avoir suivi les étapes fournies dans la section Solution, dans la boîte de dialogue Examiner les problèmes et solutions associée à l'alerte, cliquez sur Réanalyser maintenant pour vérifier la résolution. Si le problème est résolu, la règle n'est pas signalée comme règle ayant échoué dans la page Examiner les problèmes et solutions.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


La messagerie sortante n'a pas été configurée

Nom de la règle : Le courrier électronique sortant n'a pas été configuré.

Résumé : Un serveur de messagerie sortant n'a pas été configuré sur ce déploiement de SharePoint Foundation. Si aucun serveur SMPT n'est configuré pour le courrier électronique sortant, SharePoint Foundation ne peut pas envoyer de messages électroniques, y compris les messages d'alertes, les messages de confirmation, les messages d'invitation et les messages de dépassement de quotas.

Cause : Un serveur de messagerie SMPT n'a pas encore été configuré dans la batterie.

Solution : Configurer les paramètres du courrier électronique sortant dans l'Administration centrale

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Paramètres système.

  3. Dans la page Paramètres système, dans la section Courrier électronique et messages texte (SMS), cliquez sur Configurer les paramètres du courrier électronique sortant.

  4. Dans la page Paramètres du courrier électronique sortant, dans la section Paramètres de messagerie, tapez les informations du serveur SMTP dans la zone Serveur SMTP sortant, puis spécifiez les adresses et le jeu de caractères que vous voulez utiliser.

  5. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Certaines règles de l'Analyseur d'intégrité n'ont pas de travaux de minuteur associés

Nom de la règle : Certaines règles de l'analyseur d'intégrité ne sont associées à aucun travail du minuteur

Résumé : Les travaux du minuteur qui exécutent des règles de l'analyseur d'intégrité SharePoint n'existent pas dans ce déploiement de SharePoint Foundation 2010.

Cause : Il est possible qu'une partie ou la totalité des règles de l'analyseur d'intégrité SharePoint ne s'exécutent pas si les travaux du minuteur de collection de données d'intégrité ne sont pas configurés.

Solution : Créer les travaux du minuteur de collection de données d'intégrité

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Analyseur d'intégrité, cliquez sur Examiner les problèmes et solutions.

  4. Dans la page Examiner les problèmes et solutions, cliquez sur l'alerte de la règle ayant échoué, puis cliquez sur Corriger maintenant.

  5. Après avoir suivi l'aide fournie dans la section Solution, dans la boîte de dialogue Examiner les problèmes et solutions associée à l'alerte, cliquez sur Réanalyser maintenant pour vérifier la résolution. Si le problème est résolu, la règle n'est pas signalée comme ayant échoué dans la page Examiner les problèmes et solutions.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Les lecteurs manquent d'espace

Nom de règle : Les lecteurs manquent d'espace libre

Résumé : les lecteurs de disque sur un ou plusieurs serveurs de la batterie sont à cours d'espace disque.

Remarque :
Cette règle analyse l'espace disque par rapport à la mémoire vive (RAM) de l'ordinateur. Lorsque l'espace disque représente moins de la moitié de la mémoire RAM de l'ordinateur, la règle d'intégrité déclenche une erreur. Lorsque l'espace disque est cinq fois inférieur à la mémoire RAM de l'ordinateur, la règle d'intégrité déclenche un avertissement. Par conséquent, les ordinateurs serveurs dotés d'une mémoire RAM conséquente ont davantage de chances de passer au travers de cette règle.

Résolution : libérer de l'espace disque sur l'ordinateur serveur

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs sur l'ordinateur local.

  2. Exécutez l'outil Nettoyage de disque pour libérer de l'espace disque sur l'ordinateur serveur.

Résolution : diminuer le nombre de jours de conservation des fichiers journaux

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie de serveurs.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configuration de la journalisation des diagnostics.

  4. Dans la page Journalisation des diagnostics, dans la section Journal de suivi, dans la zone Nombre de jours de conservation des fichiers journaux, tapez un nombre inférieur.

  5. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


La taille du fichier d'échange doit dépasser la quantité de RAM physique du système

Nom de règle : La taille du fichier d'échange doit dépasser la quantité de RAM physique dans le système

Résumé : la taille du fichier d'échange sur certains serveurs de la batterie SharePoint est plus petite que la taille totale de la mémoire physique disponible sur les serveurs.

Cause : selon une meilleure pratique Windows, la taille du fichier d'échange doit être égale ou supérieure à la quantité totale de mémoire physique disponible. Le nettoyage de la mémoire s'avère généralement plus efficace lorsque la mémoire du segment est récupérée automatiquement et que la taille du segment géré avoisine celle du fichier d'échange. Lorsque la taille du fichier d'échange est inférieure à celle de la mémoire vive (RAM), de nouvelles allocations de mémoire gérée sont accordées, ce qui entraîne un nettoyage de la mémoire plus conséquent et une utilisation supérieure du processeur.

Résolution : augmenter la taille minimale du fichier d'échange

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs sur l'ordinateur local.

  2. Dans la page Gestionnaire de serveur, cliquez sur Modifier les propriétés système.

  3. Dans la boîte de dialogue Propriétés du système, sous l'onglet Avancé, dans la section Performance, cliquez sur Paramètres.

  4. Dans la boîte de dialogue Options de performances, sous l'onglet Avancé, dans la section Performance, cliquez sur Paramètres.

  5. Dans la boîte de dialogue Mémoire virtuelle, activez la case à cocher Gestion automatique du fichier d'échange pour les lecteurs ou désactivez-la et spécifiez une taille de fichier d'échange supérieure ou égale à la taille de mémoire physique disponible sur l'ordinateur.

  6. Une fois que vous avez apporté les modifications souhaitées, cliquez sur OK, puis redémarrez l'ordinateur pour appliquer les modifications.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Les comptes intégrés sont utilisés comme identités de service ou pool d'applications

Nom de la règle : Les comptes intégrés sont utilisés comme identités de pool d'applications ou de service.

Résumé : Les comptes d'ordinateurs intégrés ou locaux sont utilisés comme identité de pool d'applications ou identité de service.

Cause : L'utilisation de comptes intégrés comme identités de pool d'applications ou identités de service n'est pas prise en charge dans une configuration de batterie. Les comptes intégrés comprennent notamment Service réseau, Service local et Système local.

Solution : Modifier l'identité qui est utilisée pour le service ou le pool d'applications

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, cliquez sur Sécurité.

  3. Dans la page Sécurité, à la section Sécurité générale, cliquez sur Configurer les comptes de service.

  4. Dans la page Comptes de service, à la section Gestion des informations d'identification, dans la liste déroulante supérieure, cliquez sur le service ou le pool d'applications Web dont vous voulez modifier l'identité.

  5. Dans la liste Sélectionnez un compte pour ce composant, cliquez sur le compte d'utilisateur de domaine à associer au service ou au pool d'applications.

    Si vous voulez enregistrer le compte que vous avez sélectionné dans la batterie SharePoint Foundation 2010, cliquez sur Enregistrer le compte géré.

  6. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Web Analytics : contrôle l'intégrité du composant Consolidateur de rapport

Nom de la règle : Le service Web Analytics contrôle l'intégrité du composant Report Consolidator

Résumé : En général, l'exécution du composant Report Consolidator ne doit pas prendre plus de deux heures. Cette règle est déclenchée si elle prend plus de cinq heures.

Cause : L'exécution du composant Report Consolidator prend plus de cinq heures.

Solution : Activer le découpage des données à l'aide de Windows PowerShell

  1. Vous pouvez activer le découpage des données à l'aide de l'applet de commande Set-WebAnalyticsServiceApplication. Lorsque la suppression des données est activée, le nombre de lignes de données dans les tables de la base de données de création de rapports est réduit à 20 000 lignes par jour par composant (site, collection de sites, application Web, etc.). Ceci réduit le temps nécessaire à l'exécution du composant Reporting.

  2. Vérifiez que vous disposez de la configuration minimale requise suivante : Voir Add-SPShellAdmin.

  3. Dans le menu Démarrer, cliquez sur Tous les programmes.

  4. Cliquez sur Produits Microsoft SharePoint 2010.

  5. Cliquez sur SharePoint 2010 Management Shell.

  6. À partir de l'invite de commandes Windows PowerShell, tapez la commande suivante :

    Code de copie
    Set-SPWebAnalyticsServiceApplication [-Identity <GUID>]-EnableDataTrimming

    Où :

    • <GUID> est l'identificateur GUID de l'application de service Web Analytics. Si vous n'avez qu'une seule application de service Web Analytics, il est inutile de spécifier le GUID.

Pour plus d'informations, voir Set-SPWebAnalyticsServiceApplication.

Remarque :
Nous vous recommandons d'utiliser Windows PowerShell pour les tâches d'administration en ligne de commande. L'outil en ligne de commande Stsadm a été abandonné, mais il est inclus pour assurer la compatibilité avec les versions précédentes.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Web Analytics : vérifie que lorsque Web Analytics est installé et en cours d'exécution, la journalisation de l'utilisation est activée dans la batterie.

Nom de la règle : Web Analytics : vérifie que lorsque Web Analytics est installé et en cours d'exécution, la journalisation de l'utilisation est activée dans la batterie.

Résumé : L'application de service Web Analytics collecte et signale les informations d'utilisation telles que l'affichage des pages, les visiteurs uniques, les requêtes de recherche lancées, etc. Si vous avez besoin de cette application de service, vous devez activer la journalisation de l'utilisation pour garantir la journalisation de ces données.

Cause : La journalisation de l'utilisation n'est pas activée pour l'application de service Web Analytics.

Résolution : Activez la journalisation de l'utilisation pour l'application de service Web Analytics

  1. Vérifiez que le compte d'utilisateur qui exécute cette procédure est membre du groupe Administrateurs de batterie.

    Remarque :
    Les paramètres des données d'utilisation et d'intégrité sont définis à l'échelle de la batterie de serveurs ; vous ne pouvez pas les définir pour des serveurs particuliers de la batterie.

  2. Dans la page Accueil de l'Administration centrale, cliquez sur Analyse.

  3. Dans la page Analyse, dans la section Rapports, cliquez sur Configurer la collection des données d'utilisation et d'intégrité.

  4. Dans la page Configurer la collecte de données d'utilisation et d'intégrité, dans la section Collecte des données d'utilisation, activez la case à cocher Activer la collection des données d'utilisation.

  5. Dans la section Sélection d'événement, sélectionnez les événements à journaliser en activant les cases à cocher en regard de ceux-ci dans la liste Événements à enregistrer. Vérifiez qu'au moins les événements suivants sont sélectionnés :

    1. Demandes de page

    2. Utilisation de la requête de recherche

    3. Utilisation de l'inventaire des sites

    4. Utilisation de l'évaluation

  6. Dans la section Paramètres de la collection des données d'utilisation, tapez le chemin d'accès au dossier où écrire les données d'utilisation et d'intégrité dans la zone Emplacement du fichier journal. Le chemin d'accès spécifié doit exister sur tous les serveurs de la batterie.

  7. Tapez l'espace disque maximum pour les fichiers journaux en gigaoctets (de 1 à 20 Go) dans la zone Taille maximale du fichier journal.

  8. Cliquez sur OK pour enregistrer les paramètres et activer la journalisation de l'utilisation.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Web Analytics : vérifie qu'une application Web est prise en charge par un proxy d'application de service Web Analytics au maximum

Nom de la règle : Le service Web Analytics vérifie qu'une application Web est traitée par un seul proxy d'application de service Web Analytics

Résumé : Lorsqu'une application Web est associée à une application de service Web Analytics, cette dernière journalise et traite les données d'utilisation pour cette application Web. Lorsqu'une application Web est associée à plusieurs applications de service Web Analytics, celles-ci journalisent et traitent les données pour l'application Web de manière imprévisible. Nous vous recommandons donc d'utiliser une seule application de service Web Analytics pour journaliser et traiter les données pour l'application Web.

Cause : Plusieurs applications de service Web Analytics ont été créées dans la même batterie et des applications Web ont été associées à plusieurs de ces applications de service Web Analytics.

Solution : Dissocier d'autres applications de service Web Analytics

  1. Vérifiez que le compte d'utilisateur qui effectue cette procédure est membre du groupe SharePoint Administrateurs de batterie.

  2. Dans la page d'accueil de l'Administration centrale, sous Gestion des applications, cliquez sur Gérer les applications Web.

  3. Dans la page Gérer les applications Web, cliquez sur l'application Web indiquée dans l'Analyseur d'intégrité, puis cliquez sur Connexions aux services.

  4. Dans la boîte de dialogue Configurer les associations des applications de service, désactivez toutes les cases à cocher en regard des applications de service Web sauf une.

    Remarque :
    Si les cases à cocher ne sont pas disponibles, procédez comme suit :

    1. Enregistrez les connexions répertoriées dans l'affichage par défaut.

    2. Sélectionnez [personnalisé] dans la zone de liste Modifier le groupe de connexions suivant.

    3. Désactivez toutes les cases à cocher en regard des applications de service Web sauf une, et veillez à sélectionner toutes les autres applications de service qui figuraient dans l'affichage par défaut.

  5. Cliquez sur OK.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Web Analytics : vérifie que SQL Server Service Broker est activé pour les bases de données de transit Web Analytics

Nom de la règle : Web Analytics : vérifie que SQL Server Service Broker est activé pour les bases de données de la zone de transit Web Analytics.

Résumé : La file d'attente Service Broker pour les bases de données Web Analytics n'est pas activée. Les données Web Analytics ne sont donc pas traitées.

Cause : Ceci peut être dû à un attachement ou détachement récent de bases de données SQL Server ou à une opération de sauvegarde ou de restauration.

Solution : Activer la file d'attente de Service Broker

  • Dans l'Administration centrale, dans la page Examiner les problèmes et solutions, cliquez sur la règle, puis sur Réparer automatiquement.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Référence d'installation (SharePoint Foundation 2010)

Dans cette section :

  • Référence de la ligne de commande d'installation (SharePoint Foundation 2010)

  • Référence de Config.xml (SharePoint Foundation 2010)

  • Référence de la ligne de commande de Psconfig (SharePoint Foundation 2010)

  • Commandes Windows PowerShell (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Référence de la ligne de commande d'installation (SharePoint Foundation 2010)

Dans Produits SharePoint 2010, l'outil en ligne de commande Setup s'utilise pour très peu d'opérations, la plupart réservées aux administrateurs informatiques.

Dans cet article :

  • Comment utiliser un commutateur de ligne de commande du programme d'installation

  • Commutateurs et paramètres disponibles

Comment utiliser un commutateur de ligne de commande du programme d'installation

Pour exécuter le programme d'installation à partir de la ligne de commande, tapez un espace après la commande, suivi d'une barre oblique (/), du nom du commutateur et parfois d'un autre espace et d'un ou plusieurs paramètres. Par exemple :

Code de copie
setup.exe /<switch> [parameter]

Les paramètres sont des instructions spécifiques qui fournissent au programme davantage d'informations sur la manière d'exécuter la commande. Le tableau de la section suivante contient plusieurs exemples de commutateurs.

Commutateurs et paramètres disponibles

Dans Produits SharePoint 2010, le programme d'installation reconnaît les options de ligne de commande suivants.

Commutateur ou paramètre Description
Code de copie
/config [path and file name]

Spécifie le fichier de configuration utilisé par le programme d'installation durant l'installation. Par défaut, le fichier Config.xml stocké dans le dossier de produit principal fait en sorte que le programme d'installation installe ce produit. Vous pouvez modifier le fichier Config.xml afin de personnaliser davantage l'installation ou vous pouvez pointer vers un fichier de configuration différent.

Le DVD du produit contient des exemples de fichiers Config.xml. Les exemples de fichiers sont stockés dans le dossier Files à la racine du DVD, dans des dossiers qui correspondent à différents scénarios.. Par exemple, le dossier Files\SetupFarmSilent contient un fichier Config.xml qui sert à installer une batterie de serveurs en mode silencieux.

Utilisez /config sur la ligne de commande d'installation pour pointer vers l'emplacement du fichier Config.xml par défaut d'un produit spécifique ou vers un fichier de configuration personnalisé.

Exemples

Pour pointer vers un fichier Config.xml personnalisé :

\\<server>\<share>\setup.exe /config \\<server>\<share>\<folder>\config.xml

où <folder> est le dossier qui contient le fichier Config.xml.

Ou pour pointer vers un fichier de configuration différent :

\\<server>\<share>\setup.exe /config \\<server>\<share>\Files\SetupFarmSilent\config.xml

Code de copie
/modify [ProductID]

Le commutateur /modify s'utilise avec un fichier Config.xml modifié pour exécuter le programme d'installation en mode de maintenance et apporter des modifications à une installation existante de Office, par exemple ajouter ou supprimer des fonctionnalités.

Recherchez la valeur de [ProductID] dans le fichier Setup.xml du produit que vous souhaitez modifier. Le fichier Setup.xml se trouve dans le dossier de produit principal à la racine du point d'installation réseau ou du DVD du produit. Par exemple, le fichier Setup.xml de SharePoint Foundation 2010 se trouve dans le dossier Wss.en-us.

Dans Setup.xml, [ProductID] correspond à la valeur de l'attribut Id de l'élément Setup. Par exemple :

- <Setup Id="Wss" Type="Product" ProductCode="{40120000-1110-0000-0000-0000000FF1CE}">

Le commutateur ne peut pas servir à modifier la configuration du serveur (par exemple d'une configuration de serveur autonome à une configuration de batterie de serveurs). Pour modifier la configuration, vous devez effectuer une désinstallation puis une réinstallation.

Exemples

\\<server>\<share>\setup.exe /modify wssmui.en.us /config \\<server>\<share>\<folder>config.xml

Dans cet exemple, le programme d'installation à la racine du DVD est exécuté en mode de maintenance pour modifier SharePoint Foundation, comme indiqué par l'ID de produit wss. Si aucun fichier Config.xml n'est spécifié, le programme d'installation utilise le fichier Config.xml qui se trouve dans le même dossier que le fichier Setup.exe.

\\<server>\<share>\setup.exe /modify wss

/repair [ProductID]

Exécute le programme d'installation afin de réparer les fichiers nécessaires au produit spécifié. L'exécution du programme d'installation en mode de réparation affecte uniquement les fichiers de programme et ne répare pas votre configuration de serveur ni tout autre site.

Recherchez la valeur de [ProductID] dans le fichier Setup.xml du produit que vous souhaitez modifier. Le fichier Setup.xml se trouve dans le dossier de produit principal à la racine du point d'installation réseau ou du DVD du produit. Par exemple, le fichier Setup.xml de SharePoint Foundation 2010 se trouve dans le dossier Global à la racine du DVD.

Remarque :
Vous devez également exécuter l'Assistant Configuration des produits SharePoint après avoir exécuté setup.exe /repair afin d'achever la réparation de la configuration. Si vous utilisez une configuration autonome, vous pouvez exécuter psconfig.exe -setup à partir de la ligne de commande pour réparer la configuration au lieu de recourir à l'Assistant. Si vous êtes dans une configuration de batterie de serveurs, vous devez utiliser l'interface de l'Assistant. Pour plus d'informations, voir l'aide de l'Assistant Configuration des produits SharePoint.

Exemple

\\<server>\<share>\setup.exe /repair Wss

/uninstall [ProductID]

Supprime le produit spécifié de l'ordinateur de l'utilisateur. Recherchez la valeur de [ProductID] dans le fichier Setup.xml du produit que vous souhaitez modifier.

Recherchez la valeur de [ProductID] dans le fichier Setup.xml du produit que vous souhaitez modifier. Le fichier Setup.xml se trouve dans le dossier de produit principal à la racine du point d'installation réseau ou du DVD du produit. Par exemple, le fichier Setup.xml de SharePoint Foundation 2010 se trouve dans le dossier Global à la racine du DVD.

Exemple

\\<server>\<share>\setup.exe /uninstall WSS

Exécute le programme d'installation avec un fichier Config.xml à une invite de commandes

L'exécution du programme d'installation avec un fichier de configuration vous permet de spécifier des choix de configuration (tels que l'emplacement des données ou le rôle de serveur) durant une installation en mode silencieux. Vous pouvez par exemple utiliser le fichier Config.xml pour :

  • effectuer une installation en mode silencieux ;

  • installer en utilisant une configuration commune à plusieurs serveurs ;

  • effectuer une installation automatisée ou à base de script.

Appliquez la procédure suivante pour exécuter le programme d'installation avec un fichier de configuration à une invite de commandes.

  1. Sur le lecteur qui contient le DVD du produit, naviguez jusqu'au répertoire racine pour rechercher le fichier Setup.exe.

  2. Exécutez le programme d'installation avec le fichier Config.xml sélectionné.

    setup /config <nom_et_chemin_accès_fichier>

    Remarque :
    Vous pouvez sélectionner l'un des exemples de fichiers fournis avec le DVD du produit Microsoft SharePoint Foundation 2010 ou personnaliser votre propre fichier de configuration.

  3. Appuyez sur Entrée.

Pour plus d'informations, voir Installer SharePoint Foundation 2010 à l'aide de Windows PowerShell.

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Référence de la ligne de commande de Psconfig (SharePoint Foundation 2010)

Dans Produits SharePoint 2010, vous pouvez utiliser l'outil en ligne de commande Psconfig comme interface pour effectuer plusieurs opérations qui déterminent la configuration des Produits SharePoint 2010. Vous devez être membre du groupe Administrateurs sur l'ordinateur local pour effectuer ces opérations.

Dans cet article

  • Comment utiliser les commandes Psconfig

  • Commandes et paramètres disponibles

Comment utiliser les commandes Psconfig

Lorsque vous exécutez Psconfig à une invite de commandes, vous pouvez spécifier des commandes pour contrôler son exécution. Pour exécuter Psconfig à une invite de commandes, naviguez jusqu'au dossier %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\14\bin, puis tapez les commandes en respectant la syntaxe suivante :

Code de copie
psconfig.exe -cmd <command> [optional parameters]

Le tableau de référence fourni dans la section suivante contient plusieurs exemples. Une aide est également disponible depuis l'interface en ligne de commande. Pour afficher l'aide, à l'invite de commandes, tapez ce qui suit :

Code de copie
psconfig.exe -?

Pour afficher l'aide sur une commande spécifique, tapez ce qui suit :

Code de copie
psconfig.exe -help <command name>

Pour s'exécuter correctement, les commandes de Psconfig doivent être exécutées dans un ordre spécifique. Si vous utilisez l'Assistant Configuration des produits SharePoint pour configurer une installation, il appelle les commandes (également appelées tâches de configuration) dans l'ordre correct. En revanche, si vous utilisez la ligne de commande pour exécuter Psconfig, vous devez vous assurer d'effectuer les tâches dans l'ordre correct. Les commandes Psconfig doivent être exécutées dans l'ordre suivant :

  1. configdb

  2. helpcollections

  3. secureresources

  4. services

  5. installfeatures

  6. adminvs

  7. evalprovision (uniquement pour les installations autonomes)

  8. applicationcontent

  9. upgrade

Important :
Si Psconfig détecte que la batterie de serveurs doit être mise à niveau, il démarre automatiquement une mise à niveau lorsque vous l'exécutez (même si vous n'avez pas sélectionné la commande upgrade).

Vous pouvez spécifier l'exécution de toutes les commandes dans une chaîne de ligne de commande unique. Dans ce cas, Psconfig exécute toutes les commandes dans l'ordre correct. Par exemple, à l'invite de commandes, vous pouvez exécuter une commande semblable à la suivante :

Code de copie
psconfig.exe -cmd configdb <parameters>
-cmd helpcollections <parameters>
-cmd secureresources <parameters>
-cmd services <parameters>
-cmd installfeatures <parameters>
-cmd adminvs <parameters>
-cmd evalprovision <parameters>
-cmd applicationcontent <parameters>

Pour plus d'informations sur la façon de configurer un serveur ou une batterie de serveurs à partir de la ligne de commande, voir le TechCenter Microsoft SharePoint Foundation 2010.

Commandes et paramètres disponibles

Dans l'Assistant Configuration des produits SharePoint, les options de ligne de commande suivantes sont reconnues.

Commande Description, paramètres et exemples

?

Affiche les commandes utilisables avec Psconfig.

Exemple

Code de copie
psconfig.exe -?

help <command name>

Affiche les commandes utilisables avec Psconfig. Si un nom de commande est spécifié, affiche l'aide de cette commande.

Exemple

psconfig.exe -help adminvs

adminvs

Gère l'application Web Administration centrale de SharePoint sur l'ordinateur local. Prend les paramètres facultatifs suivants :

[-provision]

Met en service l'application Web Administration centrale de SharePoint sur ce serveur. La mise en service crée une nouvelle application Web Administration centrale de SharePoint et un pool d'applications exécuté sous le compte d'administrateur de la batterie de serveurs.

[-unprovision]

Met hors service l'application Web Administration centrale de SharePoint sur ce serveur. La mise hors service supprime l'application Web Administration centrale de SharePoint et son pool d'applications.

[-port <port number>]

Le port d'application Web Administration centrale de SharePoint est un paramètre global de la batterie de serveurs. Lors de la modification du port, un travail du service du minuteur SharePoint est exécuté afin de synchroniser le port pour toutes les applications Web Administration centrale de SharePoint de la batterie de serveurs. Si aucun port n'est spécifié, c'est le port utilisé pour les applications Web Administration centrale de SharePoint existantes dans la batterie de serveurs qui est utilisé. Si aucune application Web Administration centrale de SharePoint n'a été mise en service dans la batterie de serveurs, le port par défaut est sélectionné de manière aléatoire si aucun port n'est spécifié.

[-windowsauthprovider <enablekerberos | onlyusentlm>]

Le fournisseur d'authentification d'application Web Administration centrale de SharePoint est un paramètre global de la batterie de serveurs. Lorsque vous modifiez le fournisseur d'authentification, un travail du service du minuteur SharePoint est exécuté afin de synchroniser le fournisseur sur toutes les applications Web Administration centrale de SharePoint de la batterie de serveurs. Si onlyusentlm est spécifié, NTLM est le fournisseur d'authentification exclusif pour toutes les applications Web Administration centrale de SharePoint. Tous les autres fournisseurs d'authentification sont désactivés et NTLM est l'unique fournisseur d'authentification autorisé. Si enablekerberos est spécifié, l'authentification Kerberos est activée pour toutes les applications Web Administration centrale de SharePoint. Si aucun fournisseur d'authentification n'est spécifié, c'est le fournisseur utilisé pour les applications Web Administration centrale de SharePoint existantes dans la batterie de serveurs qui est utilisé. Si aucune application Web Administration centrale de SharePoint n'a été mise en service dans la batterie de serveurs, le fournisseur d'authentification Kerberos est activé si aucun fournisseur d'authentification n'est spécifié.

Exemples

psconfig.exe -cmd adminvs -provision -port 8080 -windowsauthprovider onlyusentlm

psconfig.exe -cmd adminvs -unprovision

applicationcontent

Gère le contenu d'application partagé. Prend le paramètre obligatoire suivant :

-install

Copie les données d'applications partagées (par exemple les fichiers de ressources et binaires d'applications Web) dans des répertoires virtuels d'applications Web existants.

Exemple

psconfig.exe -cmd applicationcontent -install

configdb

Crée, connecte ou déconnecte ce serveur de la batterie de serveurs. Prend les paramètres facultatifs suivants :

[-create]

Crée une base de données de configuration et établit par conséquent une nouvelle batterie de serveurs. Si ce serveur est déjà connecté à une base de données de configuration, le serveur est tout d'abord déconnecté, puis la nouvelle base de données de configuration est créée.

[-disconnect]

Déconnecte ce serveur de la base de données de configuration, et par conséquent de la batterie de serveurs.

[-connect]

Établit une connexion à une base de données de configuration existante et joint par conséquent ce serveur à une batterie de serveurs existante. Si ce serveur est déjà connecté à une base de données de configuration, le serveur est tout d'abord déconnecté, puis connecté à la base de données de configuration existante.

[-server <SQLServerName>]

Ordinateur qui exécute Microsoft SQL Server et où se trouve la base de données de configuration.

[-database <SQLDatabaseName>]

Nom de la base de données de configuration.

[-dbuser <value>]

Nom d'utilisateur utilisé pour l'authentification SQL.

[-dbpassword <value>]

Mot de passe utilisé pour l'authentification SQL.

[-user <Domain\User>]

Compte d'utilisateur administrateur de la batterie de serveurs.

[-password <Password>]

Mot de passe du compte d'utilisateur administrateur de la batterie de serveurs.

[-addomain <value>]

Nom de domaine Active Directory utilisé pour la batterie de serveurs.

[-adorgunit <value>]

Nom d'unité d'organisation Active Directory utilisé pour la batterie de serveurs.

[-admincontentdatabase <SQLAdminContentDatabaseName>]

Nom de la base de données de contenu d'application Web Administration centrale.

Exemples

psconfig.exe -cmd configdb -create -server <Server_name> -database <Database_name>

-dbuser <DOMAIN\username> -dbpassword <password>

-user <DOMAIN\username> -password <password>

-addomain <domain_name> -adorgunit <org_unit>

-admincontentdatabase <Database_name>

psconfig.exe -cmd configdb -disconnect

psconfig.exe -cmd configdb -connect -server <Server_name> -database <Database_name>

-dbuser <DOMAIN\username> -dbpassword <password>

evalprovision

Met en service ce serveur en tant que serveur autonome (mode d'évaluation). Prend les paramètres obligatoires et facultatifs suivants :

-provision

Effectue une mise en service en mode autonome sur ce serveur.

[-port <port number>]

Numéro de port assigné à l'application Web SharePoint par défaut. S'il n'est pas spécifié, le port 80 est utilisé. Si une application Web SharePoint existante utilise déjà ce port, le site existant est remplacé. Si un site existant utilise ce port et n'est pas une application Web SharePoint, le site est désactivé et une nouvelle application Web SharePoint qui utilise ce port est créée.

[-overwrite]

Indique s'il faut remplacer un site Web Microsoft SharePoint Foundation 2010 existant durant l'installation. Si ce paramètre n'est pas spécifié, le site n'est pas supprimé.

Exemple

psconfig.exe -cmd evalprovision -provision -port 1100

helpcollections

Gère les collections d'aide. Prend le paramètre obligatoire suivant :

-installall

Installe toutes les collections d'aide existantes disponibles.

Exemple

psconfig.exe -cmd helpcollections -installall

installfeatures

Inscrit auprès de la batterie de serveurs toutes les fonctionnalités des Produits et technologies SharePoint situées sur le système de fichiers.

Exemple

psconfig.exe -cmd installfeatures

quiet

Exécute l'Assistant Configuration des produits SharePoint en mode silencieux. La sortie est écrite dans le fichier journal nommé PSCONFIG.EXE_MM_JJ_AA_HH_MM_SS_MS.log, où « _MM_JJ_AA_HH_MM_SS_MS » correspond à la date et à l'heure complètes d'exécution de l'utilitaire. LE fichier journal est stocké dans le répertoire %COMMONPROGRAMFILES%\Microsoft Shared\web server extensions\14\LOGS.

Exemple

psconfig.exe -cmd quiet

secureresources

Applique la sécurité des ressources Produits SharePoint 2010 sur le serveur. Par exemple, la sécurité est appliquée sur les fichiers, dossiers et clés de Registre.

Exemple

psconfig.exe -cmd secureresources

services

Gère les services Produits SharePoint 2010. Prend les paramètres facultatifs suivants :

[-install]

Inscrit auprès de la batterie de serveurs les services situés sur ce serveur.

[-provision]

Met en service les services situés sur ce serveur et les configure comme en ligne si les Produits SharePoint 2010 sont installés en mode autonome. La mise en service des services garantit également leur inscription.

Remarque :
Le paramètre [-provision] est pris en charge uniquement pour une installation autonome à serveur unique. Ne l'utilisez pas pour une installation de batterie.

Exemple

psconfig.exe -cmd services -install

psconfig.exe -cmd services -provision

setup

Effectue la configuration des Produits SharePoint 2010 en fonction du mode d'installation. Répare également la configuration. Si le produit est installé en mode autonome, la configuration autonome est terminée. Si le produit n'est pas en mode autonome, vous devez achever la configuration initiale à l'aide de l'Assistant Configuration des produits SharePoint plutôt qu'avec l'outil en ligne de commande Psconfig. Pour exécuter l'Assistant, dans le menu Démarrer, pointez sur Tous les programmes, sur Outils d'administration, puis cliquez sur Assistant Configuration des produits SharePoint.

Si vous souhaitez réparer une installation autonome, exécutez tout d'abord setup /repair (pour plus d'informations, voir le système d'aide du programme d'installation), puis psconfig.exe -setup. Pour les installations de batterie de serveurs, après avoir exécuté setup /repair, utilisez l'Assistant Configuration des produits SharePoint au lieu de l'outil en ligne de commande Psconfig.

Prend le paramètre facultatif suivant :

[-lcid <1033>]

ID de paramètre régional (LCID) qui spécifie la langue d'installation.

Exemple

psconfig.exe -cmd setup

standaloneconfig

Effectue une configuration autonome des Produits et technologies SharePoint. Prend les paramètres facultatifs suivants :

[-lcid <1033>]

ID de paramètre régional (LCID) qui spécifie la langue d'installation.

Exemple

psconfig.exe -cmd standaloneconfig

upgrade

Effectue une mise à niveau des Produits SharePoint 2010. Cette commande est exécutée automatiquement lorsque vous exécutez l'Assistant Configuration des produits SharePoint si le produit doit être mis à niveau. Prend les paramètres facultatifs suivants :

[-wait]

Si ce paramètre est spécifié, l'Assistant Configuration des produits SharePoint ne réapparaît qu'une fois la mise à niveau terminée. S'il n'est pas spécifié, l'Assistant réapparaît après avoir émis un travail du minuteur du service SharePoint pour effectuer la mise à niveau. Pour afficher l'état du travail de mise à niveau, vous pouvez accéder au site Web Administration centrale de SharePoint à l'aide de votre navigateur Web.

[-force]

Si ce paramètre est spécifié, l'Assistant Configuration des produits SharePoint arrête les actions de mise à niveau en cours d'exécution, puis redémarre la mise à niveau.

[-reghostonupgrade]

Si ce paramètre est spécifié, l'Assistant Configuration des produits SharePoint réinitialise tout le contenu à la version de définition de site durant la mise à niveau.

[-inplace <v2v|b2b>]

Si ce paramètre est spécifié, l'Assistant Configuration des produits SharePoint effectue une mise à niveau sur place. Si v2v est spécifié, une mise à niveau de version à version sur place est effectuée. Si b2b est spécifié, une mise à niveau de build à build sur place est effectuée.

[-preserveolduserexperience]

Si ce paramètre a la valeur false, l'Assistant Configuration des produits SharePoint met à jour les sites de façon à utiliser l'expérience utilisateur SharePoint la plus récente. Si vous ne spécifiez pas ce paramètre, la valeur par défaut est true.

[-passphrase]

Phrase secrète utilisée pour joindre la batterie de serveurs. La valeur de passphrase doit être identique sur tous les serveurs de la batterie pour que celle-ci fonctionne correctement.

Exemple

Code de copie
psconfig.exe -cmd upgrade -inplace v2v -wait

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Référence de Config.xml (SharePoint Foundation 2010)

Lorsque vous souhaitez contrôler la façon dont Microsoft SharePoint Foundation 2010 est installé, utilisez le fichier Config.xml et l'outil en ligne de commande Setup. Vous pouvez par exemple utiliser le fichier Config.xml pour effectuer les opérations suivantes :

  • effectuer une installation en mode silencieux de SharePoint Foundation 2010 ;

  • installer SharePoint Foundation 2010 en utilisant une configuration commune à plusieurs serveurs ;

  • effectuer une installation automatisée ou à base de script de SharePoint Foundation 2010.

Dans cet article :

  • Personnalisation de Config.xml

  • Aide-mémoire sur les éléments du fichier Config.xml

  • Fonctionnement

  • Format du fichier Config.xml

  • Guide de référence sur les éléments du fichier Config.xml

Personnalisation de Config.xml

Pour contrôler l'installation, commencez par modifier le fichier Config.xml dans un éditeur de texte afin d'y inclure les éléments souhaités ainsi que leurs paramètres appropriés. Ensuite, exécutez setup.exe /config [path and file name] pour spécifier que le programme d'installation s'exécutera et utilisera les options que vous avez définies dans le fichier Config.xml.

Important :
Utilisez un éditeur de texte, tel que le Bloc-notes, pour modifier le fichier Config.xml. N'utilisez pas un éditeur XML à usage général, tel que Microsoft Office Word 2007.

Le DVD du produit contient des exemples de fichiers Config.xml. Ceux-ci sont stockés dans le dossier Files à la racine du DVD, dans des dossiers qui correspondent aux différents scénarios. Il s'agit des dossiers suivants :

  • Setup Contient un fichier Config.xml utilisable lors de la configuration d'une nouvelle installation. Vous devez exécuter l'outil en ligne de commande Psconfig après avoir exécuté le programme d'installation, afin de terminer la configuration du serveur ou de la batterie de serveurs.

  • SetupFarmSilent Contient un fichier Config.xml utilisable pour la configuration d'une batterie de serveurs en mode silencieux.

  • SetupSilent Contient un fichier Config.xml file utilisable pour la configuration d'une nouvelle installation pour un serveur unique (autonome, avec Base de données interne Windows) en mode silencieux.

  • SetupUpgradeSilent Contient un fichier Config.xml file utilisable lors de la mise à niveau d'une batterie de serveurs existante sur place.

Pour plus d'informations sur les différences entre les différents scénarios de mise à niveau, voir Déterminer l'approche de mise à niveau (SharePoint Foundation 2010).

Aide-mémoire sur les éléments du fichier Config.xml

Le tableau suivant contient une liste d'éléments du fichier Config.xml. Ces éléments peuvent apparaître dans n'importe quel ordre, à l'exception de l'élément Élément Configuration, qui doit être le premier élément du fichier, et des éléments tels que Élément Command, dont la place dans le fichier Config.xml influe sur leur traitement au cours de l'installation.

Élément | Description
Élément Configuration | Élément de niveau supérieur.
Élément ARP | Valeurs qui déterminent le texte et le comportement de l'option Ajouter ou supprimer des programmes dans le Panneau de configuration du produit.
Élément Command | Exécute une commande durant l'installation.
Élément Display | Niveau d'interface utilisateur affiché pour l'utilisateur par le programme d'installation.
Élément Logging | Options déterminant le type de journalisation mis en œuvre par le programme d'installation.
Élément DATADIR | Emplacement à utiliser pour stocker les fichiers de données.
Élément Package | Package ou produit à installer.
Élément Setting | Valeurs des propriétés de Windows Installer.

Fonctionnement

Le programme d'installation recherche une copie de Config.xml dans le même dossier que Setup.exe. En l'absence de copie à cet endroit, le programme d'installation utilise le fichier Config.xml qui réside dans le dossier Files principal du produit en cours d'installation.

Vous pouvez également utiliser l'option de ligne de commande /config du programme d'installation pour indiquer l'emplacement du fichier Config.xml. Par exemple :

\\<serveur>\<partage>\setup.exe /config \\<serveur>\<partage>\<dossier>\config.xml

Format du fichier Config.xml

Les éléments XML dans Config.xml commencent par un crochet pointu (<) et se terminent par une barre oblique et un crochet pointu (/>).

Le format de base des éléments est le suivant :

<nom_élément [nom_attribut="valeur"] [nom_attribut="valeur"] … />

Par exemple :

Code de copie
<Display Level="none" CompletionNotice="no" />

Les éléments et les attributs respectent la casse. Les valeurs des attributs doivent être placées entre guillemets (") et ne respectent pas la casse.

Une définition d'élément peut s'étendre sur plusieurs lignes. Les espaces, retours chariot, sauts de ligne et caractères de tabulation sont ignorés dans une définition d'élément.

Par exemple :

Code de copie
<Display
   Level="none"
   CompletionNotice="no"
/>
Conseil :
Dans le cas de définitions d'élément longues, placez les attributs sur des lignes distinctes et utilisez des retraits pour faciliter la lecture du fichier.

L'élément Élément Configuration est un cas particulier et est obligatoire. Tous les autres éléments sont contenus dans l'élément Élément Configuration, qui se termine par </Configuration>.

L'exemple suivant montre un fichier de configuration pour une nouvelle installation du package Microsoft SharePoint Foundation 2010 :

<Configuration>

   <Package Id="sts">

      <Setting Id="SETUPTYPE" Value="CLEAN_INSTALL"/>

   </Package>

   <DATADIR Value="%CommonProgramFiles%\Microsoft Shared\Web Server Extensions\14\Data"/>

   <Logging Type="verbose" Path="%temp%" Template="Microsoft SharePoint Foundation 2010 Setup *.log"/>

   <Setting Id="UsingUIInstallMode" Value="1"/>

   <Setting Id="SETUP_REBOOT" Value="Never"/>

</Configuration>

Il est possible d'ajouter des commentaires à n'importe quel endroit, délimités d'un côté par un crochet pointu, un point d'exclamation et deux tirets (<!--) et de l'autre côté par deux tirets et un crochet pointu (-->).

Par exemple :

<!-- Install Microsoft SharePoint Server for clean install, using UI-->

<Configuration>

   <Package Id="sts">

      <Setting Id="LAUNCHEDFROMSETUPSTS" Value="Yes"/>

   </Package>

   <Package Id="spswfe">

      <Setting Id="SETUPCALLED" Value="1"/>

   </Package>

   <Logging Type="verbose" Path="%temp%" Template="SharePoint Server Setup(*).log"/>

      <!--<PIDKEY Value="Enter Product Key Here" />-->

      <Setting Id="SERVERROLE" Value="SINGLESERVER"/>

      <Setting Id="USINGUIINSTALLMODE" Value="1"/>

      <Setting Id="SETUPTYPE" Value="CLEAN_INSTALL"/>

      <Setting Id="SETUP_REBOOT" Value="Never"/>

   <!-- Tells Setup.exe not to reboot -->

</Configuration>

Guide de référence sur les éléments du fichier Config.xml

Les conventions ci-dessous sont utilisées dans les descriptions de ce guide de référence :

gras | Nom d'élément ou d'attribut
régulier | Texte à entrer en recopiant exactement le texte indiqué
italique | Espace réservé pour une valeur à ajouter
x|y | Choisir parmi plusieurs valeurs
[x] | Valeur facultative

Élément Configuration

Élément de niveau supérieur. Cet élément est obligatoire et tous les autres éléments doivent être inclus dans cet élément.

Syntaxe

<Configuration>

<Package Id="ID">

...

</Package>

...

</Configuration>

Attributs

Attribut | Valeur | Description
Package ID | ID de package | Package en cours d'installation.

Remarques

L'attribut Package ID identifie le produit et les technologies affectés par ce fichier Config.xml.

Exemple

L'ID de package pour SharePoint Foundation 2010 est sts. Utilisez l'ID de package sts dans Config.xml pour spécifier SharePoint Foundation 2010 en entrant ce qui suit :

Code de copie
<Configuration>
   <Package Id="sts">
   ...
   </Package>
   ...
</Configuration>

Élément ARP

Valeurs spécifiques qui déterminent le texte et le comportement de l'option Ajouter ou supprimer des programmes dans le Panneau de configuration du produit.

Syntaxe

<ARP attribut =" valeur " [attribut="valeur"] ... />

Attributs

Attribut | Valeur | Description
ARPCOMMENTS | texte | Texte supplémentaire ; peut comporter jusqu'à 255 caractères. Sachez toutefois que tous les caractères risquent de ne pas s'afficher.
ARPCONTACT | texte | Liste de coordonnées de services de support technique.
ARPNOMODIFY | Yes | Empêche les utilisateurs de modifier l'installation du produit en masquant le bouton Modifier.
 | No (par défaut) | Autorise les utilisateurs à modifier l'installation du produit.
ARPNOREMOVE | Yes | Empêche les utilisateurs de supprimer le produit en masquant le bouton Supprimer.
 | No (par défaut) | Autorise les utilisateurs à supprimer le produit.
ARPURLINFOABOUT | URL | URL de la page d'accueil du produit.
ARPURLUPDATEINFO | URL | URL permettant d'obtenir des informations sur les mises à jour du produit.
ARPHELPLINK | URL | URL d'un site Web à partir duquel les utilisateurs peuvent bénéficier d'un support technique.
ARPHELPTELEPHONE | texte | Numéros de téléphone de support technique.

Élément Command

Spécifie une ligne de commande à exécuter. Les commandes de l'élément Command sont traitées uniquement pendant les installations et désinstallations initiales. Si des commandes d'élément Command sont utilisées à des fins de personnalisation après l'installation initiale, elles sont ignorées.

Syntaxe

<Command

Path=" chemin_accès "

[QuietArg="arguments"]

[Args="arguments"]

[ChainPosition="Before" | "After"(par défaut)]

[Wait="millisecondes"]

[Execute="Install"(par défaut) | "Uninstall"]

[Platform="x86"(par défaut) | "x64"]

/>

Attributs

Vous pouvez spécifier des guillemets doubles (") dans les attributs Path et Args en spécifiant deux guillemets doubles ensemble ("").

Attribut | Valeur | Description
Path | chemin_accès | Chemin d'accès complet au package Windows Installer exécutable.
QuietArg | chaîne | Chaîne d'arguments à ajouter à la ligne de commande lorsque Élément Display Level=None.
Args | chaîne | Chaîne d'arguments à passer à l'exécutable.
ChainPosition | Before | Cette commande est exécutée avant l'installation du produit principal.
 | After (par défaut) | Cette commande est exécutée après l'installation du produit principal.
Wait | millisecondes | Lorsque vous effectuez une installation en affectant la valeur Full ou Basic à l'attribut Élément Display Level, il s'agit du nombre de millisecondes qui doivent s'écouler entre l'exécution du programme et la poursuite de l'installation. La valeur par défaut est 0 (zéro), qui définit un délai d'attente nul.
Execute | Install (par défaut) | Le programme d'installation exécute cette commande lorsque le produit principal est installé.
 | Uninstall | Le programme d'installation exécute cette commande lorsque le produit principal est désinstallé.
Platform | x86 (par défaut) | Indique que ce programme requiert une plateforme Intel x86. Cette commande s'exécute uniquement si l'ordinateur sur lequel l'installation est exécutée correspond à cette plateforme.
 | x64 | Indique que ce programme requiert un processeur 64 bits prenant en charge les extensions x64 de l'architecture x86. Cette commande s'exécute uniquement si l'ordinateur sur lequel l'installation est exécutée correspond à cette plateforme.

Remarques

L'élément Command dans le fichier Config.xml est destiné uniquement aux installations et désinstallations de produit. Les commandes de l'élément Command sont traitées uniquement pendant les installations et désinstallations initiales. Si les commandes de l'élément Command sont utilisées pour les personnalisations après l'installation initiale, elles sont ignorées.

La ligne de commande peut être spécifiée de façon à exécuter une commande arbitraire ou un exécutable léger que vous souhaitez exécuter lors de l'installation de ce produit.

L'élément Command dans Config.xml ne procure pas les fonctionnalités de déploiement logiciel offertes par un outil de gestion et de déploiement logiciel d'entreprise, telles que la capacité à suivre la progression du déploiement et à résoudre les problèmes. Nous vous recommandons par conséquent de limiter l'usage de l'élément Command dans Config.xml à l'exécution d'un programme exécutable léger ou d'une commande arbitraire ne modifiant pas l'ordinateur ou ne nécessitant aucune entrée de la part de l'utilisateur. Par exemple, vous pouvez exécuter un utilitaire pour copier des journaux ou une commande pour lancer une page d'accueil à l'issue de l'installation.

La ligne de commande peut être spécifiée pour une installation chaînée ou un exécutable qui s'exécute lorsque ce produit est installé. Dans ce cas, vous devez spécifier une ligne de commande pour le programme d'installation au lieu d'un fichier .msi unique.

Si deux éléments Command ou plus sont présents dans le fichier Config.xml, ils sont exécutés dans l'ordre spécifié dans Config.xml.

Important :
Le chaînage n'offre pas le même niveau de fiabilité que l'installation distincte de chaque produit. Par exemple, si vous chaînez deux installations ensemble et que l'un des produits échoue ou rencontre une erreur inattendue, l'installation principale et l'installation chaînée peuvent ne pas se dérouler correctement. Par conséquent, l'approche du chaînage n'est pas recommandée. La méthode recommandée pour l'installation conjointe de plusieurs produits dans des environnements d'entreprise consiste à faire appel à un programme de gestion du déploiement, tel que Microsoft System Center Configuration Manager 2010 ou Systems Management Server (SMS) 2003, ou un outil tiers, plutôt qu'au chaînage.

L'utilisation des attributs Args et QuietArg est la suivante :

  • L'attribut Args est toujours ajouté à la commande. Il peut inclure des commutateurs tels que /install ou Company=MonEntreprise.

  • L'attribut QuietArg est également ajouté si le programme d'installation est exécuté en mode silencieux (avec Display défini comme Display="none"). Dans ces cas-là, vous pouvez spécifier l'attribut QuietArg avec le commutateur "/quiet". Vous pouvez par exemple utiliser : QuietArg="/quiet".

  • Si la valeur de l'élément Args comprend des guillemets, vous pouvez mettre la valeur entière entre des guillemets simples (') comme dans l'exemple suivant :Args='"/param value"'

Les instructions suivantes s'appliquent à l'attribut Wait :

  • Attribuer à l'attribut Wait la valeur de 0 milliseconde indique une attente nulle entre l'exécution du programme et la poursuite de l'installation.

    Les codes de retour sont respectées uniquement si la valeur Wait est différente de zéro. Si vous spécifiez 0, le programme d'installation n'attendra pas pour poursuivre l'installation après avoir exécuté le programme spécifié. Par conséquent, il n'y a pas de code de retour à rapporter dans ce cas.

  • Attribuer à l'attribut Wait n'importe quelle valeur positive différente de zéro détermine une attente du nombre exact de millisecondes que vous spécifiez. Si le processus se termine avant le délai spécifié, le programme d'installation poursuit son exécution. Si le processus n'a pas terminé à l'issue du délai spécifié, l'installation échoue.

  • Attribuer à l'attribut Wait la valeur -1 indique d'attendre indéfiniment. Cela peut être problématique, car si le processus de commande cesse de répondre (se fige), le programme d'installation cesse de répondre et attend indéfiniment que la commande s'exécute.

Exemple

<Command Path="\\server\share\myscript.exe" Args='/id "123 abc"' QuietArg="/q" Wait="3000">

<Command Path="\\<server>\<share>\setup.exe /config \\<server>\<share>\<folder>\config.xml"

Élément DATADIR

Emplacement à utiliser pour stocker les fichiers de données, y compris les fichiers d'index de recherche.

Syntaxe

<DATADIR Value=" chemin_accès "/>

Attributs

Attribut | Valeur | Description
Value | chemin_accès | Le programme d'installation stocke les fichiers de données à l'emplacement spécifié.

Remarques

Vous pouvez utiliser des variables d'environnement système dans le chemin d'accès. Si cet élément n'est pas spécifié, les données sont stockées à l'emplacement suivant :

%ProgramFiles%\Microsoft SQL Server\MSSQL$SHAREPOINT\Data

Exemple

Code de copie
<DATADIR Value="d:\data"/>

Élément Display

Niveau d'interface utilisateur affiché pour l'utilisateur par le programme d'installation.

Syntaxe

<Display

Level="None" | "Basic" | "Full"(par défaut)

CompletionNotice="Yes"(par défaut) | "No"

SuppressModal="Yes" | "No"(par défaut)

NoCancel="Yes" | "No"(par défaut)

AcceptEula="Yes" | "No"(par défaut)

/>

Attributs

Attribut | Valeur | Description
Level | None | Aucune interface de programme d'installation ne s'affiche.
 | Basic | Le programme d'installation affiche l'écran d'accueil, la page Termes du contrat de licence logiciel Microsoft (si nécessaire), une barre de progression et l'avertissement de fin d'opération (si cela est autorisé).
 | Full (par défaut) | Le programme d'installation affiche l'ensemble de l'interface à l'utilisateur.
CompletionNotice | Yes | Applicable uniquement si Level a la valeur Basic ou None. Le programme d'installation affiche l'avertissement de fin d'opération.
 | No (par défaut) | Applicable uniquement si Level a la valeur Basic. Le programme n'affiche pas l'avertissement de fin d'opération.
SuppressModal | Yes | Applicable uniquement si Level a la valeur Basic. Le programme d'installation n'affiche pas les messages d'erreur ou autres boîtes de dialogue susceptibles d'interrompre l'installation.
 | No (par défaut) | Applicable uniquement si Level a la valeur Basic. Le programme d'installation affiche les messages d'erreur ou autres boîtes de dialogue éventuellement nécessaires.
NoCancel | Yes | Si Level a la valeur Full ou Basic, désactive le bouton d'annulation (la croix qui se trouve dans le coin supérieur droit de la boîte de dialogue de progression).
 | No (par défaut) | Si Level a la valeur Full ou Basic, autorise l'utilisateur à annuler l'installation à partir de la barre de progression.
AcceptEULA | Yes | Les termes du contrat de licence logiciel Microsoft sont acceptés pour le compte de l'utilisateur. Le programme d'installation n'affiche pas la page des termes du contrat de licence logiciel Microsoft.
 | No (par défaut) | Si Level n'a pas la valeur None, le programme d'installation affiche la page Termes du contrat de licence logiciel Microsoft.

Remarques

Si cet élément n'est pas défini, les paramètres par défaut sont utilisés. Si une valeur non valide est spécifiée, le programme d'installation termine l'installation.

Remarque :
L'élément Display n'est utilisé par le programme d'installation que si ce dernier détecte le fichier Config.xml dans le même dossier que Setup.exe ou si vous spécifiez le fichier Config.xml à l'aide de l'option de ligne de commande /config du programme d'installation.

Exemple

Code de copie
<Display Level="basic"
   CompletionNotice="yes"
   SupressModal="no"
   AcceptEula="yes"
/>

Élément Logging

Spécifie le type de journalisation mis en œuvre par le programme d'installation.

Syntaxe

<Logging

Type="Off" | "Standard"(par défaut) | "Verbose"

Path=" chemin_accès "

Template=" nom_fichier .txt"

/>

Attributs

Attribut | Valeur | Description
Type | Off | Le programme d'installation n'effectue pas de journalisation.
 | Standard (par défaut) | Le programme d'installation écrit les informations d'installation dans le fichier journal.
 | Verbose | Le programme d'installation écrit toutes les informations d'installation dans le fichier journal.
Path | chemin_accès | Chemin d'accès complet au dossier utilisé pour stocker le fichier journal. Vous pouvez utiliser des variables d'environnement. La valeur par défaut est %temp%.
Template | nom_fichier .txt | Nom du fichier journal. Si vous insérez la chaîne * dans le nom du fichier, un fichier journal unique est créé pour chaque installation effectuée par le programme d'installation (voir l'explication qui suit). Si vous n'insérez pas le caractère * et que le nom de fichier spécifié existe déjà, les informations sont ajoutées à la fin du fichier existant. L'extension de fichier .txt doit être incluse. Le modèle par défaut est SetupExe(*).log.

Remarques

Vous pouvez spécifier un signe * n'importe où dans la valeur Template. Le programme d'installation insère une chaîne à cet emplacement au format suivant :

AAAAMMJJHHMMSSxxx

où :

  1. AAAA = Année

  2. MM = Mois

  3. JJ = Jour

  4. HH = Heure

  5. MM = Minutes

  6. SS = Secondes

  7. xxx = chaîne unique générée par le programme d'installation

Remarque :
L'élément Logging est utilisé par le programme d'installation uniquement si vous spécifiez le fichier Config.xml à l'aide de l'option de ligne de commande /config du programme d'installation. Si vous ne spécifiez pas de fichier Config.xml à utiliser, le programme d'installation utilise les options de journalisation par défaut.

Exemple

Code de copie
<Logging Type="standard" Path="%temp%"
   Template="MyLog(*).txt"
/>

Dans cet exemple, le programme d'installation crée un fichier journal chaque fois qu'il installe le produit. Il utilise des noms de fichiers uniques tels que les suivants :

Code de copie
%temp%\MyLog(20060428110717CFC).txt
%temp%\MyLog(20060429113143C70).txt

Élément Package

Package ou produit à installer.

L'ID de package pour SharePoint Foundation 2010 est sts.

Élément Setting

Permet de spécifier des valeurs pour les propriétés de Windows Installer.

Syntaxe

<Setting Id=" nom " Value=" valeur " />

Attributs

Attribut | Valeur | Description
Id | nom | Nom de la propriété Windows Installer.
Value | valeur | Valeur à assigner à la propriété.

Valeurs

Les ID de paramètres suivants sont utilisés pour les installations de serveur :

ID | Valeurs acceptées | Description
REBOOT | ReallySuppress | Indique (pour Windows Installer) s'il faut autoriser un redémarrage une fois le programme d'installation terminé. Utilisez ReallySuppress pour spécifier qu'aucun redémarrage ne doit être effectué. Cette option doit être spécifiée au niveau global, et non par package.
SETUP_REBOOT | Never, AutoAlways, Always, AutoIfNeeded, IfNeeded | Indique (pour le programme d'installation) s'il faut autoriser un redémarrage une fois le programme d'installation terminé. Utilisez Never pour spécifier qu'aucun redémarrage ne doit être effectué. Cette option doit être spécifiée au niveau global, et non par package.
SETUPTYPE | CLEAN_INSTALL, V2V_INPLACE_UPGRADE | Indique s'il faut installer une nouvelle copie du produit ou de la technologie (CLEAN_INSTALL) ou installer la nouvelle version et mettre à niveau la version précédente sur place (V2V_INPLACE_UPGRADE). Ce paramètre doit être spécifié au niveau global, et non par package.
SETUPCALLED | 0 | 1 | À utiliser dans le cadre de l'attribut d'ID de package.
SERVERROLE | SINGLESERVER, APPLICATION | Spécifie le type de serveur sur lequel vous effectuez l'installation : autonome (SINGLESERVER) ou application (APPLICATION).
USINGUIINSTALLMODE | 0 | 1 | Indique si vous effectuez une installation silencieuse (0) ou si vous utilisez l'interface utilisateur pour le programme d'installation (1).

Remarques

Les propriétés de Windows Installer ne peuvent pas toutes être spécifiées dans l'élément Setting. Si une propriété bloquée est spécifiée, le programme d'installation termine le processus d'installation. Si une propriété prise en charge est spécifiée, le programme d'installation passe la propriété directement à Windows Installer.

Exemple

Code de copie
<Setting Id="REBOOT" Value="ReallySuppress" />

Historique des modifications

Date | Description | Raison
4 novembre 2010 | 2010/11/01 | Mise à jour du contenu
8 juillet 2010 | Publication initiale |


Commandes Windows PowerShell (SharePoint Foundation 2010)
Voir aussi

Cet article traite des applets de commande Windows PowerShell nécessaires à l'installation de Microsoft SharePoint Foundation 2010 sur un serveur autonome ou sur une batterie de serveurs.

Dans cet article :

  • Installation de produits SharePoint à l'aide de Windows PowerShell

  • Applets de commande d'installation Windows PowerShell

Pour plus d'informations sur les commandes et la syntaxe utilisées lors du déploiement à base de script d'une batterie SharePoint Foundation 2010, voir Référence de déploiement par script (SharePoint Foundation 2010).

Installation de produits SharePoint à l'aide de Windows PowerShell

Dans SharePoint Foundation 2010, vous pouvez utiliser des applets de commande Windows PowerShell en guise d'interface alternative pour effectuer plusieurs opérations qui contrôlent la configuration des produits SharePoint. En outre, vous pouvez rationaliser le déploiement en faisant appel à des installations en ligne de commande combinées à d'autres outils d'administration afin d'automatiser les installations en mode silencieux.

Vous pouvez exécuter les applets de commande Windows PowerShell dans SharePoint 2010 Management Shell ou ajouter le composant logiciel enfichable qui contient les applets de commande. L'utilisation d'un environnement de commande vous permet d'éliminer l'étape d'inscription du composant logiciel enfichable qui contient les applets de commande à l'aide de l'applet de commande Add-PSSnapin. Pour plus d'informations sur la façon d'utiliser Windows PowerShell avec Produits Microsoft SharePoint 2010, voir Administration des produits SharePoint 2010 à l'aide de Windows PowerShell.

Pour utiliser les applets de commande, vérifiez que la configuration requise suivante est satisfaite : Voir Add-SPShellAdmin. Pour plus d'informations sur la façon d'ajouter un utilisateur au rôle SharePoint_Shell_Access pour la base de données spécifiée, voir Add-SPShellAdmin.

Remarque :
Lorsque vous créez une batterie ou que vous joignez un serveur à une batterie pour la première fois, ignorez le message d'erreur suivant qui s'affiche : « La batterie locale n'est pas accessible. Les applets de commande avec le champ FeatureDependencyId ne sont pas enregistrées. »

Pour que leur exécution réussisse, les applets de commande doivent s'exécuter dans un ordre spécifique. Si vous utilisez l'Assistant Configuration des produits SharePoint pour configurer l'installation, il appelle les commandes (également appelées tâches de configuration) dans l'ordre correct. En revanche, si vous utilisez des applets de commande, vous devez vous assurer d'effectuer les tâches dans l'ordre correct. Les applets de commande Windows PowerShell doivent être exécutées dans l'ordre suivant :

  1. New-SPConfigurationDatabase

  2. Install-SPHelpCollection

  3. Initialize-SPResourceSecurity

  4. Install-SPService

  5. Install-SPFeature

  6. New-SPCentralAdministration

  7. Install-SPApplicationContent

Remarque :
Utilisez un nouveau processus Windows PowerShell pour effectuer des opérations sur une nouvelle batterie. Par exemple, lorsque vous ajoutez à une nouvelle batterie un serveur qui se trouvaient dans une batterie différente, redémarrez le processus Windows PowerShell avant d'ajouter le serveur à la nouvelle batterie.

Applets de commande d'installation Windows PowerShell

Vous pouvez utiliser les applets de commande Windows PowerShell suivantes pour installer et configurer SharePoint Foundation 2010.

Applet de commande Windows PowerShell | Description
New-SPConfigurationDatabase | Crée une base de données de configuration sur le serveur de bases de données spécifié. Il s'agit de la base de données centrale pour une nouvelle batterie SharePoint. Cette commande crée également la base de données de contenu d'administration.
Install-SPHelpCollection | Installe les fichiers de collection de sites d'aide pour Produits SharePoint 2010 dans la batterie actuelle. Vous devez spécifier le paramètre All pour installer tous les fichiers CAB de collection d'aide sous %Program Files%\Common Files\Microsoft Shared\Web Server Extensions\14\HCCab\<LCID> dans la collection de sites d'aide.
Initialize-SPResourceSecurity | Applique la sécurité des ressources sur le serveur local. Cette applet de commande applique la sécurité pour toutes les ressources, y compris les fichiers, dossiers et clés de Registre.
Install-SPService | Installe et éventuellement met en service des services sur une batterie. Cette applet de commande installe tous les services, instances de services et proxys de services spécifiés dans le Registre sur l'ordinateur serveur local.
Install-SPFeature | Installe une fonctionnalité de SharePoint spécifique à l'aide du fichier Feature.xml. Lorsque vous créez une batterie, vous devez spécifier le paramètre AllExistingFeatures pour installer toutes les fonctionnalités disponibles.
New-SPCentralAdministration | Crée une application Web Administration centrale et démarre le service d'administration centrale sur l'ordinateur local. L'Administration centrale est disponible uniquement sur les ordinateurs sur lesquels ce service s'exécute.
Install-SPApplicationContent | Copie les données d'applications partagées dans les dossiers d'applications Web existants.

Voir aussi

Concepts

Administration des produits SharePoint 2010 à l'aide de Windows PowerShell

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Répertoire d'installation et autres répertoires spéciaux (SharePoint Foundation 2010)

Dans cet article :

  • Fichiers du répertoire d'installation

  • Fichiers de ressources de composants WebPart

  • Fichiers de contenu de site Web

Cet article répertorie les dossiers et fichiers utilisés par Microsoft SharePoint Foundation 2010.

Fichiers du répertoire d'installation

Le tableau suivant répertorie les fichiers et dossiers créés dans le répertoire d'installation (%COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\14) lorsque vous installez SharePoint Foundation 2010.

Dossier Description Fichiers et fonction

AdmIsapi

Répertoire physique qui héberge les services Web spécifiques au site Web Administration centrale de SharePoint pour le répertoire virtuel _vti_adm dans l'Administration centrale.
  • Admin.asmx - Service Web pour les méthodes de service Web spécifiques à l'Administration centrale. Accessible par http://nom_serveur:<port_admin>/_vti_adm/admin.asmx.

  • AdminDisco.aspx - Fichier de découverte de service Web utilisé pour le service Web admin.asmx. Accessible par http://nom_serveur:<port_admin>/_vti_adm/admin.asmx?disco.

  • AdminWsdl.aspx - Fichier WSDL (Web Services Description Language) utilisé pour spécifier les méthodes et paramètres fournis par le service Web Admin.asmx. Accessible par http://nom_serveur:<port_admin>/_vti_adm/admin.asmx?wsdl.

  • Web.config - Fichier de configuration pour l'Administration centrale

Bin

Contient les principaux fichiers binaires pour SharePoint Foundation 2010.
  • *.dll - Principaux fichiers binaires

  • Owstimer.exe - Service du minuteur de Microsoft SharePoint

  • Stsadm.exe - Outil d'administration en ligne de commande SharePoint Foundation

  • Wssadmin - SharePoint Foundation Service d'administration

  • Stscfg.exe - Utilitaire de configuration utilisé par le programme d'installation

  • Mssearch.exe - Processus de recherche

  • Wsstracing.exe - Enregistre les événements dans le fichier journal de suivi de diagnostic SharePoint

  • Psconfig.exe - Assistant Configuration des produits SharePoint

  • Spwriter.exe - SharePoint Foundation Enregistreur VSS

Bin\LCID\

Contient les principaux fichiers binaires utilisés par des langues spécifiques. LCID est remplacé par l'ID de paramètre régional. Par exemple, 3082 est l'ID de paramètre régional de l'espagnol. Par conséquent, le chemin d'accès aux fichiers binaires de langue espagnole est \Bin\3082.

  • Fpext.msg - Chaînes de texte et messages d'erreur

  • Microsoft.Sharepoint.Msg.dll - Microsoft SharePoint Foundation Messages d'événements

  • Microsoft.Sharepoint.Perfmonmsg.dll

  • Mssmsg.dll - Composant de recherche Microsoft

  • WssSmanifest.man

Config

Contient les fichiers de configuration et valeurs par défaut du serveur.
  • *.xml - Fichier XML pour le mappage des valeurs par défaut

  • AppwpresWeb.config - Fichier de configuration

  • AdminWeb.config - Fichier de configuration pour le site Web Administration centrale

  • LayoutsWeb.config - Fichier de configuration pour le répertoire _layouts

  • Web.config - Fichier de configuration pour les applications Web

  • Wss_mediumtrust.config - Fichier de configuration

  • Wss_minimaltrust.config - Fichier de configuration

  • Wss_usercode.config

Config\Adminbin

Contient les principaux fichiers binaires.

*.dll

Config\AdminResources

Contient les ressources d'Administration centrale.

*.resx

Config\Bin

Contient les fichiers binaires pour le répertoire virtuel _vti/_bin.

Stssoap.dll - Fichier binaire utilisé pour le code SOAP

Microsoft.SharePoint.Applicationpages.dll - Fichier binaire principal

Config\Browsers

Contient le fichier de configuration pour la prise en charge de l'accès mobile aux données de liste.

Compat.browser

Config\IdentityModel

Contient les fichiers de configuration pour les revendications personnalisées.

Webconfig.Identitymodel.Add.xml

Webconfig.Identitymodel.Remove.xml

Config\Powershell\Format

Contient les fichiers qui définissent l'affichage par défaut des objets dans la console Windows PowerShell.

SharepointPowershell.Format.ps1xml

WssSearchPowershell.Format.ps1xml

Config\Powershell\Help

Informations sur les applets de commande Windows PowerShell pour Produits SharePoint 2010.

Microsoft.Sharepoint.Powershell.dll-help.xml

Microsoft.Sharepoint.Search.dll-help.xml

Config\Powershell\Help\UILanguage

Langue système par défaut dans laquelle afficher l'aide des applets de commande Windows PowerShell.

Microsoft.SharePoint.Powershell.dll-help.xml

Microsoft.SharePoint.Search.dll-help.xml

Microsoft.SharePoint.TopologyService-help.xml

Config\Powershell\Registration

Contient le code des applets de commande et les fichiers XML qui inscrivent les applets de commande.

Psconsole.psc1

SharePoint.ps1

SPCmdletSchema.xsd

WssCmdlet.xml

WssSearchCmdlets.xml

Config\Powershell\Types

Contient les fichiers texte XML qui vous permettent d'ajouter des propriétés et des méthodes aux objets utilisés dans Windows PowerShell.

SharepointPowershell.Types.ps1xml

WssSearchPowerShell.Types.ps1xml

Config\Resources

Contient les ressources de localisation.

*.resx

Config\Upgrade

Contient les fichiers XML utilisés lors du processus de mise à niveau.

GbwUpgrade.xml

GbwUpgradeB2B.xml

MpsUpgrade.xml

MpsUpgradeB2B.xml

WssUpgrade.xml

WssUpgradeB2B.xml

WssSearchUpgrade.xml

Data

Contient les fichiers d'index de recherche SharePoint Foundation.

HCCab\LCID

Contient les fichiers d'aide et de prise en charge. LCID est remplacé par l'ID de paramètre régional. Par exemple, 3082 est l'ID de paramètre régional de l'espagnol.

*.cab

Help\LCID

Contient le fichier d'aide .chm de l'Assistant Configuration des produits SharePoint. LCID est remplacé par l'ID de paramètre régional. Par exemple, 3082 est l'ID de paramètre régional de l'espagnol.

*.chm

Isapi

Répertoire physique adressé par le répertoire virtuel _vti/_bin.

Contient les interfaces RPC d'extensions serveur FrontPage (Shtml.dll, _vti_aut\Author.dll, _vti_adm\Admin.dll) et les interface RPC Microsoft SharePoint Foundation (Owssvr.dll).
  • *.asmx - Services Web

  • Authentication.asmx - Service Web pour les méthodes de service Web d'authentification SharePoint

  • AuthenticationDisco.aspx - Fichier de découverte de service Web utilisé pour le service Web Authentication.asmx

  • AuthenticationWsdl.aspx - Fichier de langue de description des services Web utilisé pour spécifier les méthodes et paramètres fournis par le service Web Authentication.asmx

  • *.xml - Fichier XML pour le code managé

  • Web.config - Fichier de configuration

Isapi\_Vti_Adm

Contient les interfaces RPC d'extensions serveur FrontPage.

Admin.dll - Interface RPC pour l'administration à distance des extensions serveur FrontPage, des autres applications clientes Microsoft Office et des autres applications clientes qui implémentent ce protocole.

Isapi\_Vti_Aut

Contient les fichiers binaires FrontPage.

Author.dll - Interface RPC pour la création à distance des extensions serveur FrontPage, des autres applications clientes Office et des autres applications clientes qui implémentent ce protocole.

Isapi\Anonsvc

Contient un fichier de configuration utilisé pour l'authentification anonyme.

Web.config

Isapi\Sts

Contient les fichiers utilisés par le service d'émission de jeton de sécurité SharePoint Server 2010.

Spsecuritytokenservice.svc

Web.config

Logs

Contient les fichiers journaux.

Policy

Contient les fichiers utilisés pour la stratégie de gestion des informations.

*.dll

*.config

Resources

Contient les fichiers de ressources.

*.resx

Template

Contient les modèles, fonctionnalités et fichiers de site Web principaux.

Template\LCIDSts

Contient les fichiers qui sont copiés à la racine du site Web lors de l'instanciation avec le modèle Site d'équipe (par exemple, Default.aspx). LCID est remplacé par l'ID de paramètre régional. Par exemple, le chemin d'accès pour l'espagnol est Template\3082\Sts.

Ce dossier contient uniquement le dossier DocTemp.

Template\LCID\Sts\Doctemp\Blankpgs

Contient les modèles de documents par défaut.

Bpstd.aspx

_Basicpage.htm

Template\LCID\Sts\Doctemp\Dcl

Contient les modèles de documents pour la Bibliothèque de connexions de données.

Template.odc

Template\LCID\Sts\Doctemp\Fp

Contient les modèles de documents pour FrontPage et SharePoint Designer.

Fptmpl.htm - Modèles de documents par défaut pour les documents FrontPage et SharePoint Designer

Template\LCID\Sts\Doctemp\Onenote

Contient les modèles de documents pour Microsoft OneNote.

Template.one

Template.onepkg

Template\LCID\Sts\Doctemp\Ppt

Contient les modèles de documents pour Microsoft PowerPoint.

Filelist.xml

Master03.css

Master03.htm

Master03.xml

Pptmpl.htm

Pptmpl.pot

Pptmpl.pptx

Pres.xml

Pptml.pptx

Preview.wmf

Slide001.htm

Template\LCID\Sts\Doctemp\Smartpgs

Contient les modèles de documents pour les pages de composants WebPart.

*.aspx

_Webpartpage.htm

Template\LCID\Sts\Doctemp\Word

Contient les modèles de documents pour Microsoft Word.

Wdtmpl.doc

Wdtmpl.htm

Wdtmpl.dotx

Template\LCID\Sts\Doctemp\Xl

Contient les modèles de documents pour Microsoft Excel.

Filelist.xml

Sheet001.htm

Sheet002.htm

Sheet003.htm

Style.css

Tabstrip.htm

Xltmpl.htm

Xltmpl.xls

Xltmpl.xlsx

Template\LCID\Sts\Doctemp\Xmlforms\Blank

Contient les modèles de documents pour Microsoft InfoPath.

Template.xml - Modèles de documents par défaut pour les documents XML

Template\LCID\Workflow

Contient les fichiers pour les activités de flux de travail. LCID est remplacé par l'ID de paramètre régional. Par exemple, 3082 est l'ID de paramètre régional de l'espagnol. Par conséquent, le chemin d'accès pour l'espagnol est Template\3082\Workflow.

Wss.actions

Moderationworkflow.xml

Template\LCID\Xml

Fichiers de modèles de sites pour la langue spécifique. LCID est remplacé par l'ID de paramètre régional. Par exemple, 3082 est l'ID de paramètre régional de l'espagnol. Par conséquent, le chemin d'accès pour l'espagnol est Template\3082\Xml.

Deadweb.xml

Rgnlstng.xml

Webtemp.xml

Template\Admin

Contient les modèles et pages maîtres pour l'Administration centrale.

*.aspx

Admin.master

Admin.sitemap

Template\Admin\Bdc

Contient les modèles et pages maîtres pour les Services Microsoft Business Connectivity.

*.aspx

Template\ControlTemplates

Contient les modèles de contrôles qui déterminent la mise en page des formulaires d'éléments de liste.

*.ascx

Template\DocumentTemplates

Contient la page utilisée pour la création de bibliothèques de documents.

Wkpstd.aspx

Template\Features

Contient les fonctionnalités de SharePoint Foundation.

Template\Features\AdminLinks

Contient les pages de gestion des applications et d'opérations qui utilisent l'infrastructure de fonctionnalités de SharePoint Foundation 2010 pour fournir l'extensibilité de lien.

Operations.xml

Applications.xml

Feature.xml

Template\Features\AnnouncementsList

Contient les fichiers utilisés pour la liste Annonces.

Feature.xml

Template\Features\AnnouncementsList\Announce

Contient un fichier de description de modèle pour la liste Annonces.

Schema.xml - Fichier de schéma

Template\Features\AnnouncementsList\ListTemplates

Contient un fichier de description de modèle pour la liste Annonces.

Announcements.xml

Template\Features\BasicWebParts

Contient les fichiers de descriptions de fonctionnalités et de descriptions de composants WebPart pour les composants WebPart SharePoint Foundation intégrés.

Feature.xml - Description des fonctionnalités

Elements.xml - Manifeste d'éléments

*.dwp - Descriptions des composants WebPart

Template\Features\ContactsList

Contient le fichier utilisé pour la liste Contacts.

Feature.xml

Template\Features\ContactsList\Contacts

Contient le fichier de contenu de modèle pour la liste Contacts.

Schema.xml - Fichier de schéma

Template\Features\ContactsList\ListTemplates

Contient le fichier de description de modèle pour la liste Contacts.

Contacts.xml

Template\Features\ContentLightup

Contient les fichiers qui fournissent plusieurs liens et composants d'interface utilisateur.

Feature.xml

Template\Features\ContentLightup\Controls

Contient les fichiers de contenu de modèle pour les éléments d'interface utilisateur standard.

SearchArea.xml

Template\Features\ContentTypeSettings

Contient les fichiers utilisés pour les paramètres de type de contenu.

Feature.xml

ContentTypeSettings.xml

Template\Features\ctypes

Contient les fichiers utilisés pour les types de contenu.

Ctypeswss.xml

Feature.xml

Template\Features\CustomList

Contient les fichiers utilisés pour les listes Personnalisé.

Feature.xml

Template\Features\CustomList\CustList

Contient le fichier de contenu de modèle pour les listes Personnalisé.

Schema.xml - Fichier de schéma

Template\Features\DataSourceLibrary

Contient les fichiers utilisés pour la Bibliothèque de sources de données.

Feature.xml

Template\Features\DataSourceLibrary\DataSrcs

Contient le fichier de contenu de modèle pour la Bibliothèque de sources de données.

Schema.xml - Fichier de schéma

Template\Features\DataSourceLibrary\ListTemplates

Contient le fichier de description de modèle pour la Bibliothèque de sources de données.

DataSourceLibrary.xml

Template\Features\DiscussionsList

Contient un fichier utilisé pour la liste Forum de discussion.

Feature.xml

Template\Features\DiscussionsList\Discuss

Contient le fichier de contenu de modèle pour la liste Forum de discussion.

Schema.xml - Fichier de schéma

Template\Features\DiscussionsList\ListTemplates

Contient le fichier de description de modèle pour la liste Forum de discussion.

Discussions.xml

Template\Features\DocumentLibrary

Contient le fichier utilisé pour le type de liste Bibliothèque de documents.

Feature.xml

Template\Features\DocumentLibrary\DOCLib

Contient les fichiers utilisés pour les bibliothèques de documents.

*.aspx - Pages de formulaire

*.htm - Boîtes de dialogue

Schema.xml - Fichier de schéma

Template\Features\DocumentLibrary\ListTemplates

Contient le fichier de description de modèle pour les bibliothèque de documents.

DocumentLibrary.xml

Template\Features\EventsList

Contient un fichier utilisé pour la liste Événements.

Feature.xml

Template\Features\EventsList\Events

Contient le fichier de contenu de modèle pour la liste Événements.

Schema.xml - Fichier de schéma

Template\Features\EventsList\ListTemplates

Contient le fichier de description de modèle pour la liste Événements.

Events.xml

Template\Features\ExternalList

Contient un fichier utilisé pour la liste Externe.

Feature.xml

Template\Features\ExternalList\ExtList

Contient le fichier de contenu de modèle pour la liste Externe.

Schema.xml - Fichier de schéma

Template\Features\ExternalList\ListTemplates

Contient le fichier de description de modèle pour la liste Externe.

ExternalList.xml

Template\Features\FacilityList

Contient un fichier utilisé pour la liste Facility.

Feature.xml

Template\Features\FacilityList\Facility

Contient le fichier de contenu de modèle pour la liste Facility.

Schema.xml - Fichier de schéma

Template\Features\FacilityList\ListTemplates

Contient le fichier de description de modèle pour la liste Facility.

Facilitylist.xml

Template\Features\FCGroupsList

Contient un fichier utilisé pour la liste FCGroups.

Feature.xml

Template\Features\FCGroupsList\FCGroups

Contient le fichier de contenu de modèle pour la liste FCGroups.

Schema.xml - Fichier de schéma

Template\Features\FCGroupsList\ListTemplates

Contient le fichier de description de modèle pour la liste FCGroups.

Fcgroupslist.xml

Template\Features\Fields

Contient les fichiers utilisés pour les champs dans une liste.

Feature.xml

Fieldswss.xml

Fieldswss2.xml

Fieldswss3.xml

Template\Features\GanttTasksList

Contient un fichier utilisé pour la liste Tâches du projet (Diagramme de Gantt).

Feature.xml

Template\Features\GanttTasksList\Gantt

Contient le fichier de contenu de modèle pour la liste Tâches du projet (Diagramme de Gantt).

Schema.xml

Template\Features\GanttTasksList\ ListTemplates

Contient le fichier de description de modèle pour la liste Tâches du projet (Diagramme de Gantt).

GanttTasksList.xml

Template\Features\GBWProvision

Contient les fichiers utilisés pour Group Board Workshop.

Feature.xml

Listinstance.xml

Template\Features\GBWWebParts

Contient les fichiers utilisés pour les composants WebPart Group Board Workshop.

Elements.xml

Feature.xml

Timecard.dwp

Whatsnew.dwp

Whereabouts.dwp

Template\Features\GridList

Contient un fichier utilisé pour la liste Personnalisé en mode Feuille de données.

Feature.xml

Template\Features\GridList\GridList

Contient un fichier utilisé pour la liste Personnalisé dans le type de liste de mode Feuille de données.

Schema.xml - Fichier de schéma

Template\Features\GridList\ ListTemplates

Contient le fichier de description de modèle pour la liste Personnalisé en mode Feuille de données.

GridList.xml

Template\Features\GroupWork

Contient les fichiers utilisés pour la liste Group Board Custom.

Feature.xml

Listinstance.xml

Template\Features\HelpLibrary

Contient un fichier utilisé pour la collection d'aide.

Feature.xml

Template\Features\HelpLibrary\HelpLibrary

Contient un fichier utilisé pour la collection d'aide.

Schema.xml - Fichier de schéma

Template\Features\HelpLibrary\ListTemplates

Contient le fichier de description de modèle pour la collection d'aide.

Helplibrary.xml

Template\Features\HolidaysList

Contient un fichier utilisé pour la liste Jours fériés.

Feature.xml

Template\Features\HolidaysList\Holidays

Contient un fichier utilisé pour la liste Jours fériés.

Schema.xml - Fichier de schéma

Template\Features\HolidaysList\ListTemplates

Contient le fichier de description de modèle pour la liste Jours fériés.

Holidayslist.xml

Template\Features\IMEDicList

Contient un fichier utilisé pour le dictionnaire médical.

Feature.xml

Template\Features\IMEDicList\IMEDic

Contient un fichier utilisé pour le dictionnaire médical.

Schema.xml - Fichier de schéma

Template\Features\IMEDicList\ListTemplates

Contient le fichier de description de modèle pour le dictionnaire médical.

Imediclist.xml

Template\Features\IssuesList

Contient un fichier utilisé pour la liste Suivi des problèmes.

Feature.xml

Template\Features\IssuesList\Issue

Contient le fichier de contenu de modèle pour la liste Suivi des problèmes.

Schema.xml - Fichier de schéma

Template\Features\IssuesList\ListTemplates

Contient le fichier de description de modèle pour la liste Suivi des problèmes.

Issues.xml

Template\Features\IssueTrackingWorkflow

Contient les fichiers utilisés pour le flux de travail Suivi des problèmes.

IssueTracking.xml

Feature.xml

Template\Features\LinksList

Contient un fichier utilisé pour la liste Liens.

Feature.xml

Template\Features\LinksList\Links

Contient le fichier de contenu de modèle pour la liste Liens.

Schema.xml - Fichier de schéma

Template\Features\LinksList\ListTemplates

Contient le fichier de description de modèle pour la liste Liens.

Links.xml

Template\Features\MobilityRedirect

Contient les fichiers utilisés pour la fonctionnalité Redirection de mobilité pour les listes.

Feature.xml

Default.aspx

Elements.xml

Template\Features\MpsWebParts

Contient les fichiers utilisés pour le pack de gestion pour Microsoft System Center Operations Manager 2007.

Feature.xml

Elements.xml

Template\Features\NoCodeWorkflowLibrary

Contient un fichier utilisé pour les flux de travail sans code.

Feature.xml

Template\Features\OpenInClient

Contient un fichier utilisé pour la fonctionnalité OpenInClient pour l'ouverture de documents activés pour le navigateur dans les applications clientes Office.

Feature.xml

Template\Features\PictureLibrary

Contient un fichier utilisé pour la Bibliothèque d'images.

Feature.xml

Template\Features\PictureLibrary\PicLib

Contient les fichiers de contenu de modèle utilisés pour la Bibliothèque d'images.

*.aspx

Schema.xml

Template\Features\PictureLibrary\ListTemplates

Contient le fichier de description de modèle pour la Bibliothèque d'images.

PictureLibrary.xml

Template\Features\ScheduleList

Contient un fichier utilisé pour la liste Planification.

Feature.xml

Template\Features\ScheduleList\Schedule

Contient le fichier de contenu de modèle utilisé pour la liste Planification.

Schema.xml

Template\Features\ScheduleList\ListTemplates

Contient le fichier de description de modèle pour la liste Planification.

Schedulelist.xml

Template\Features\SiteHelp

Contient un fichier utilisé pour l'aide de collection de sites personnalisée.

Feature.xml

Template\Features\SiteSettings

Contient les fichiers utilisés pour les paramètres de site.

Features.xml

SiteSetting.xml

Template\Features\SPSearchFeature

Contient un fichier pour la fonctionnalité de recherche de SharePoint Foundation.

Feature.xml

Template\Features\SurveysList

Contient un fichier pour la liste Enquête.

Feature.xml

Template\Features\SurveysList\Survey

Contient le fichier de contenu de modèle utilisé pour la liste Enquête.

Schema.xml

Template\Features\SurveysList\ListTemplates

Contient le fichier de description de modèle pour la liste Enquête.

Surveys.xml

Template\Features\TasksList

Contient un fichier pour la liste Tâches.

Feature.xml

Template\Features\TasksList\ListTemplates

Contient le fichier de description de modèle pour la liste Tâches.

Tasks.xml

Template\Features\TasksList\Tasks

Contient le fichier de contenu de modèle utilisé pour la liste Tâches.

Schema.xml - Fichier de schéma

Template\Features\TeamCollab

Contient un fichier qui fournit des fonctionnalités de collaboration d'équipe en rendant accessibles des listes standard telles que les bibliothèques de documents et problèmes.

Feature.xml

Template\Features\TenantAdminBDC

Contient des fichiers pour l'Administration BDC client.

Default.aspx

Feature.xml

Template\Features\TenantAdminBDCStapling

Contient des fichiers pour l'Association de l'administration BDC client.

Feature.xml

Featurestapling.xml

Template\Features\TenantAdminLinks

Contient des fichiers pour la Configuration du déploiement de contenu de l'Administration des clients.

Default.aspx

Feature.xml

Template\Features\TimecardList

Contient un fichier pour la liste Feuille de présence.

Feature.xml

Template\Features\TimecardList\ListTemplates

Contient le fichier de description de modèle pour la liste Feuille de présence.

Timecardlist.xml

Template\Features\TimecardList\Tasks

Contient le fichier de contenu de modèle utilisé pour la liste Feuille de présence.

Schema.xml - Fichier de schéma

Template\Features\WebPageLibrary

Contient un fichier utilisé pour la Bibliothèque de pages Web.

Feature.xml

Template\Features\WebPageLibrary\ListTemplates

Contient le fichier de description de modèle pour la Bibliothèque de pages Web.

WebPageLibrary.xml

Template\Features\WebPageLibrary\WebPageLib

Contient le fichier de contenu de modèle utilisé pour la Bibliothèque de pages Web.

Schema.xml - Fichier de schéma

Template\Features\WhatsNewList

Contient un fichier pour la liste Nouveautés.

Feature.xml

Template\Features\WhatsNewList\ListTemplates

Contient le fichier de description de modèle pour la liste Nouveautés.

Whatsnewlist.xml

Template\Features\WhatsNewList\Tasks

Contient le fichier de contenu de modèle utilisé pour la liste Nouveautés.

Schema.xml - Fichier de schéma

Template\Features\WhereaboutsList

Contient un fichier pour la liste Localisations.

Feature.xml

Template\Features\WhereaboutsList\ListTemplates

Contient le fichier de description de modèle pour la liste Localisations.

Whereaboutslist.xml

Template\Features\WhereaboutsList\Whereabouts

Contient le fichier de contenu de modèle utilisé pour la liste Localisations.

Schema.xml - Fichier de schéma

Template\Features\WikiPageHomePage

Contient le fichier utilisé pour la page d'accueil de site Wiki.

Feature.xml

Template\Features\WikiWelcome

Contient un fichier utilisé pour le site Wiki.

Feature.xml

Template\Features\WorkflowHistoryList

Contient un fichier qui fournit la prise en charge des listes Historique des flux de travail pour un site.

Feature.xml

Template\Features\WorkflowHistoryList\ListTemplates

Contient le fichier de description de modèle pour les listes Historique des flux de travail pour un site.

WorkflowHistory.xml

Template\Features\WorkflowHistoryList\Wrkflhis

Contient le fichier de contenu de modèle utilisé pour les listes Historique des flux de travail pour un site.

Schema.xml - Fichier de schéma

Template\Features\WorkflowProcessList

Permet de prendre en charge l'exécution d'actions de formulaire personnalisées.

Feature.xml

Template\Features\WorkflowProcessList\WorkflowProcess

Contient le fichier de contenu de modèle utilisé pour les processus de flux de travail.

Schema.xml - Fichier de schéma

Template\Features\WorkflowProcessList\ListTemplates

Contient le fichier de description de modèle pour les processus de flux de travail.

WorkflowProcess.xml

Template\Features\XmlFormLibrary

Contient un fichier utilisé pour les bibliothèques de formulaires.

Feature.xml

Template\Features\XmlFormLibrary\ListTemplates

Contient le fichier de description de modèle pour les bibliothèques de formulaires.

XmlFormLibrary.xml

Template\Features\XmlFormLibrary\XmlForm

Contient le fichier de contenu de modèle pour les bibliothèques de formulaires.

Schema.xml - Fichier de schéma

Template\Global

Contient des fichiers de définitions de sites utilisés pour l'initialisation de configurations de sites.

Default.master

Minimal.master

Mwsdefault.master

Mwsdefaultv4.master

V4.master

Template\Identitymodel\Forms

Contient des fichiers utilisés pour une page de formulaires de revendications.

Default.aspx

Web.config

Template\Identitymodel\Login

Contient des fichiers utilisés pour une page d'ouverture de session de revendications.

Default.aspx

Web.config

Template\Identitymodel\Trust

Contient des fichiers utilisés pour une page de connexion à un fournisseur approuvé.

Default.aspx

Web.config

Template\Identitymodel\Windows

Contient des fichiers utilisés pour une page de connexion à Windows.

Default.aspx

Web.config

Template\Images

Contient des images partagées par toutes les pages sur le serveur et adressées par le répertoire virtuel _layouts/images.

*.gif, *.jpg, *.png

Template\Layouts

Contient des sous-répertoires de langues qui contiennent des formulaires tels que ceux permettant de créer des listes et des pages d'administration de site, et qui sont adressés par le répertoire virtuel _layouts. Tous les sites partagent ces sous-répertoires.

*.aspx - Pages de formulaire

Web.config - Fichier de configuration

Template\Layouts\LCID

Contient des formulaires pour la création de listes, de pages d'administration de site et de formulaires pour une langue spécifique. LCID est remplacé par l'ID de paramètre régional. Par exemple, 3082 est l'ID de paramètre régional de l'espagnol. Par conséquent, le chemin d'accès pour l'espagnol est \Template\Layouts\3082.

*.htm - Boîtes de dialogue

*.htc - Contrôle de menu

*.js, - Fichiers JavaScript

*.xml - Modèles XML

*.xsd - Définitions XML

Template\Layouts\LCID\Images

Contient des images utilisées dans les pages de site par défaut pour une langue spécifique.

*.gif

Template\Layouts\LCID\Styles

Contient des feuilles de style partagées par tous les modèles de sites pour une langue particulière et adressables par le répertoire virtuel _layouts/styles.

*.css - Feuilles de style

Template\Pages

Contient les fichiers utilisés pour les pages maîtres.

Form.aspx

Viewpage.aspx

Webfldr.aspx

Template\Scenarios\AdminConfig

Contient le fichier de description de modèle pour un site Web pour l'administration et la configuration des Produits SharePoint 2010.

Adminconfig.xml

Template\Scenarios\BdcService

Contient le fichier de description de modèle pour un site Web d'administration Business Data Connectivity.

Bdcservice.xml

Template\Scenarios\JoinFarm

Contient le fichier de description de modèle pour un site Web où vous pouvez joindre et configurer une batterie.

Joinfarm.xml

Template\SiteTemplates\Blog

Contient le fichier qui est copié à la racine du site Web lors de l'instanciation d'un BLOG à l'aide d'un modèle BLOG.

Default.aspx

Template\SiteTemplates\Centraladmin

Contient les fichiers qui sont copiés à la racine du site Web lors de l'instanciation d'un site à l'aide d'une définition de site CentralAdmin.

*.aspx

Template\SiteTemplates\Centraladmin\Dwp

Contient le fichier utilisé pour les composants WebPart d'Administration centrale.

TopologyView.dwp

Template\SiteTemplates\Centraladmin\Lists\Admintasks

Contient le fichier de contenu de modèle utilisé pour la liste Tâches d'administration.

Schema.xml

Template\SiteTemplates\Centraladmin\Lists\Distributionlists

Contient les fichiers de contenu de modèle utilisés pour les listes de distribution.

*.aspx

Schema.xml

Template\SiteTemplates\Centraladmin\Lists\Healthreports

Contient le fichier de contenu de modèle utilisé pour les rapports d'intégrité.

Schema.xml

Template\SiteTemplates\Centraladmin\Lists\Healthrules

Contient le fichier de contenu de modèle utilisé pour la création de règles de l'analyseur d'intégrité.

Schema.xml

Template\SiteTemplates\Centraladmin\Xml

Contient le fichier de définition de site pour l'Administration centrale.

Onet.xml

Template\SiteTemplates\Mps

Contient les fichiers qui sont copiés à la racine du site Web lors de l'instanciation avec un modèle Espace de travail de réunion (par exemple, Default.aspx).

*.aspx - Pages de formulaire

Template\SiteTemplates\Mps\Doctemp\Smartpgs

Contient le fichier utilisé pour les pages de composants WebPart dans les Espaces de travail de réunion.

Spstd1.aspx - Page de formulaire

Template\SiteTemplates\Mps\Lists

Contient des dossiers pour les catégories des listes utilisées dans les modèles Espace de travail de réunion, ainsi que la définition de schéma et les affichages par défaut.

Template\SiteTemplates\Mps\Lists\Agenda

Contient les fichiers utilisés pour la liste Agenda.

*.aspx - Pages de formulaire

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Lists\Decision

Contient les fichiers utilisés pour la liste Décisions.

*.aspx - Pages de formulaire

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Lists\Meetings

Contient les fichiers utilisés pour les modèles Espace de travail de réunion.

MoveToDt.aspx - Page de formulaire

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Lists\Objectiv

Contient les fichiers utilisés pour la liste Objectifs.

*.aspx - Pages de formulaire

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Lists\People

Contient les fichiers utilisés pour la liste Participants.

*.aspx - Pages de formulaire

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Lists\Textbox

Contient les fichiers utilisés pour la liste Zone de texte.

*.aspx - Pages de formulaire

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Lists\Thgbring

Contient les fichiers utilisés pour la liste Éléments à prévoir.

*.aspx - Pages de formulaire

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Lists\Wkspglib

Contient les fichiers utilisés pour les listes dans les modèles Espace de travail de réunion.

Schema.xml - Fichier de schéma

Template\SiteTemplates\Mps\Xml

Contient les listes disponibles dans les modèles Espace de travail de réunion, les types de base pour les champs (Onet.xml) et le modèle d'affichage par défaut pour les nouveaux affichages.

Onet.xml

Template\SiteTemplates\Sgs

Contient les fichiers qui sont copiés à la racine du site Web lors de l'instanciation avec le modèle Site de travail de groupe (par exemple, Default.aspx).

Default.aspx - Page d'accueil par défaut pour les sites basés sur des modèles sgs

Contient le fichier de définition de site.

Onet.xml- Définit les barres de navigation, les types de listes disponibles, les configurations initiales et les modules

Template\SiteTemplates\Sts

Contient les fichiers qui sont copiés à la racine du site Web lors de l'instanciation avec le modèle Site d'équipe (par exemple, Default.aspx).

Default.aspx - Page d'accueil par défaut pour les sites basés sur des modèles Site d'équipe

Defaultdws.aspx

Template\SiteTemplates\Sts\Xml

Contient le fichier de définition de site.

Onet.xml- Définit les barres de navigation, les types de listes disponibles, les configurations initiales et les modules

Template\SiteTemplates\TenantAdmin

Contient les fichiers qui sont copiés à la racine du site Web lors de l'instanciation avec le modèle Administration des clients (par exemple, Default.aspx).

Default.aspx - Page d'accueil par défaut pour les sites basés sur des modèles Administration des clients

Template\SiteTemplates\TenantAdmin\Xml

Contient le fichier de définition de site.

Onet.xml- Définit les barres de navigation, les types de listes disponibles, les configurations initiales et les modules

Template\SiteTemplates\Wiki\Xml

Contient le fichier de définition de site.

Onet.xml

Template\Sql

Contient des procédures stockées pour Microsoft SQL Server.

*.sql - Procédures stockées pour SQL Server

Template\Themes

Contient la liste de thèmes.

Themes.inf - Liste de thèmes

Template\Themes\Theme

Contient des fichiers qui étaient utilisés par un thème spécifique.

*.gif ,*.jpg - Images

*.css - Feuilles de style

*.inf - Fichier de définition de thème

Theme.utf8 - Fichier de thème pour le codage UTF8

Template\Xml

Contient les fichiers XML utilisés par tous les modèles de site dans toutes les langues.

*.xmo - Modèles utilisés dans toutes les langues et tous les types de sites.

Template\Xml\Help

Contient les fichiers XML utilisés par le système d'aide.

Sts.xml - Fichier de mappage d'aide contextuelle

UserCode\

Contient les fichiers utilisés pour charger et exécuter des solutions bac à sable (sandbox).

SpucHostService.exe

SpucHostService.exe.config

SpucWorkerProcess.exe

SpucWorkerProcess.exe.config

SpucWorkerProcessProxy.exe

SpucWorkerProcessProxy.exe.config

UserCode\assemblies

Contient les fichiers binaires principaux pour l'exécution de solutions bac à sable (sandbox).

Microsoft.SharePoint.dll

Microsoft.SharePoint.SubsetProxy.dll

Microsoft.SharePoint.UserCode.dll

WebClients\Bdc

Contient un fichier de configuration de client Web pour une application de service BDC (Business Data Connectivity).

Client.config

WebClients\SecurityToken

Contient un fichier de configuration de client Web pour une application de service d'émission de jeton de sécurité.

Client.config

WebClients\SubscriptionSettings

Contient un fichier de configuration de client Web pour une application de service de paramètres d'abonnement.

Client.config

WebClients\Topology

Contient un fichier de configuration de client Web pour une application de service de topologie Web.

Client.config

WebServices\Bdc

Contient les fichiers utilisés pour exécuter une application de service BDC (Business Data Connectivity).

Bdcservice.svc

Web.config

WebServices\Root

Contient le fichier Web.config pour la racine d'application Web, qui stocke les options de configuration ASP.NET.

Web.config

WebServices\SecurityToken

Contient les fichiers utilisés pour exécuter une application de service d'émission de jeton de sécurité.

Securitytoken.svc

Web.config

Windowstokencache.svc

WebServices\SubscriptionSettings

Contient les fichiers utilisés pour exécuter une application de service de paramètres d'abonnement.

Subscriptionsettings.svc

Web.config

WebServices\Topology

Contient les fichiers utilisés pour exécuter une application de service de topologie Web.

Topology.svc

Web.config

Wpresources

Contient le fichier de configuration pour les composants WebPart.

Web.config

Fichiers de ressources de composants WebPart

Outre le répertoire d'installation, il existe un répertoire de ressources de composants WebPart qui contient les fichiers utilisés pour prendre en charge les composants WebPart personnalisés dans SharePoint Foundation 2010. Le répertoire %COMMONPROGRAMFILES%\Microsoft Shared\Web Server Extensions\Wpresources contient un fichier Web.config qui aide à contrôler la sécurité des fichiers ASP.NET utilisés dans des composants WebPart. Pour plus d'informations sur les composants WebPart, voir le Kit de développement logiciel SDK Microsoft SharePoint 2010 (http://go.microsoft.com/fwlink/?linkid=198386&clcid=0x40C).

Fichiers de contenu de site Web

Le tableau suivant répertorie les fichiers qui sont ajoutés à chaque site ou sous-site Web de niveau supérieur lorsqu'un site SharePoint est créé.

Dossier | Description | Fichiers et fonction
Inetpub\Wwwroot\Wss\VirtualDirectories\porthost header | Contient le fichier de configuration. | Web.config
Inetpub\Dossier\_vti_pvt | Contient les fichiers et dossiers d'extensions serveur FrontPage hérités. | Buildversion.cnf Service.cnf Services.cnf
Inetpub\Dossier\_Wpresources_ | Contient le fichier de configuration pour les composants WebPart. | Web.config

Tous les autres fichiers de site Web sont stockés dans la base de données de contenu et de configuration.

Historique des modifications

Date | Description | Raison
5 août 2010 | Publication initiale |


Autorisations utilisateur et niveaux d'autorisation (SharePoint Foundation 2010)

Dans cet article :

  • Niveaux d'autorisation par défaut

  • Autorisations utilisateur

Niveaux d'autorisation par défaut

Microsoft SharePoint Foundation 2010 comprend cinq niveaux d'autorisation par défaut. Vous pouvez personnaliser les autorisations disponibles dans ces niveaux (sauf pour les niveaux d'autorisation Accès limité et Contrôle total), ou créer des niveaux personnalisés qui contiennent uniquement les autorisations dont vous avez besoin.

Remarque :
Bien que vous ne puissiez pas modifier directement les niveaux d'autorisation Accès limité et Contrôle total, vous pouvez rendre des autorisations indisponibles pour l'application Web entière, ce qui supprime ces autorisations des niveaux Accès limité et Contrôle total. Pour plus d'informations, voir « Gérer les autorisations pour une application Web » dans le système d'aide de l'Administration centrale.

Niveau d'autorisation | Description | Autorisations incluses par défaut
Accès limité | Permet d'accéder aux ressources partagées dans le site Web pour que les utilisateurs puissent accéder à un élément au sein du site. Conçu pour être combiné avec des autorisations de granularité fine pour permettre aux utilisateurs d'accéder à une liste, une bibliothèque de documents, un élément ou un document spécifique, sans leur donner accès au site entier. Ne peut pas être personnalisé ni supprimé. | Afficher les pages des applications, Parcourir les informations utilisateur, Utiliser les interfaces distantes, Utiliser les fonctionnalités d'intégration des clients, Ouvrir
Lecture | Accorde l'accès en lecture seule au site Web. | Autorisations d'accès limité, plus : Afficher les éléments, Ouvrir les éléments, Afficher les versions, Créer des alertes, Utiliser la création de sites libre-service, Afficher les pages
Collaboration | Peut créer et modifier des éléments dans des listes et des bibliothèques de documents. | Autorisations de lecture plus : Ajouter des éléments, Modifier des éléments, Supprimer des éléments, Supprimer les versions, Parcourir les répertoires, Modifier les informations personnelles de l'utilisateur, Gérer les affichages personnels, Ajouter/Supprimer des composants WebPart personnels, Mettre à jour les composants WebPart personnels
Création | Peut créer des listes et des bibliothèques de documents et modifier des pages dans le site Web. | Autorisations de collaboration, plus : Gérer les listes, Remplacer l'extraction, Approuver les éléments, Ajouter et personnaliser des pages, Appliquer des thèmes et des bordures, Appliquer des feuilles de style
Contrôle total | Contrôle total de la portée. | Toutes les autorisations

Autorisations utilisateur

SharePoint Foundation 2010 comprend 32 autorisations, utilisées dans cinq niveaux d'autorisation par défaut. Vous pouvez modifier les autorisations qui sont incluses dans un niveau particulier (à l'exception des niveaux d'autorisation Accès limité et Contrôle total) ou créer un nouveau niveau pour contenir des autorisations spécifiques.

Autorisations de liste

Autorisation | Description | Autorisations dépendantes | Par défaut incluses dans ces niveaux d'autorisation
Gérer les listes | Créer et supprimer des listes, ajouter ou supprimer des colonnes dans une liste et ajouter ou supprimer des affichages publics dans une liste. | Afficher les éléments, Afficher les pages, Ouvrir, Gérer les affichages personnels | Création, Contrôle total
Remplacer l'extraction | Ignorer ou Archiver un document qui est extrait par un autre utilisateur sans enregistrer les modifications en cours. | Afficher les éléments, Afficher les pages, Ouvrir | Création, Contrôle total
Ajouter des éléments | Ajouter des éléments à des listes et ajouter des documents à des bibliothèques de documents. | Afficher les éléments, Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total
Modifier les éléments | Modifier des éléments dans des listes, modifier des documents dans des bibliothèques de documents, et personnaliser des pages de composants WebPart dans des bibliothèques de documents. | Afficher les éléments, Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total
Supprimer des éléments | Supprimer des éléments dans une liste, et des documents dans une bibliothèque de documents. | Afficher les éléments, Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total
Afficher les éléments | Afficher des éléments de listes et des documents de bibliothèques de documents. | Afficher les pages, Ouvrir | Lecture, Collaboration, Création, Contrôle total
Approuver les éléments | Approuver les versions secondaires des éléments de liste ou des documents. | Modifier les éléments, Afficher les éléments, Afficher les pages, Ouvrir | Création, Contrôle total
Ouvrir les éléments | Afficher la source des documents avec des gestionnaires de fichiers côté serveur. | Afficher les éléments, Afficher les pages, Ouvrir | Lecture, Collaboration, Création, Contrôle total
Afficher les versions | Afficher les versions antérieures des éléments de liste ou des documents. | Afficher les éléments, Ouvrir les éléments, Afficher les pages, Ouvrir | Lecture, Collaboration, Création, Contrôle total
Supprimer les versions | Supprimer les versions antérieures des éléments de liste ou des documents. | Afficher les éléments, Afficher les versions, Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total
Créer des alertes | Créer des alertes de messagerie. | Afficher les éléments, Afficher les pages, Ouvrir | Lecture, Collaboration, Création, Contrôle total
Afficher les pages des applications | Afficher les formulaires, les vues et les pages des applications. Énumérer les listes. | Ouvrir | Tout

Autorisations de site

Autorisation | Description | Autorisations dépendantes | Par défaut incluses dans ces niveaux d'autorisation
Gérer les autorisations | Créer et modifier des niveaux d'autorisation sur le site Web et attribuer des autorisations à des utilisateurs et des groupes. | Afficher les éléments, Ouvrir les éléments, Afficher les versions, Parcourir les répertoires, Afficher les pages, Énumérer les autorisations, Parcourir les informations utilisateur, Ouvrir | Contrôle total
Afficher les données d'utilisation | Afficher les rapports sur l'utilisation du site Web. | Afficher les pages, Ouvrir | Contrôle total
Créer des sous-sites | Créer des sous-sites tels que des sites d'équipe, des sites Espace de travail de réunion et des sites Espace de travail de document. | Afficher les pages, Parcourir les informations utilisateur, Ouvrir | Contrôle total
Gérer le site Web | Effectuer toutes les tâches d'administration pour le site Web et gérer le contenu. | Afficher les éléments, Ajouter et personnaliser des pages, Parcourir les répertoires, Afficher les pages, Énumérer les autorisations, Parcourir les informations utilisateur, Ouvrir | Contrôle total
Ajouter et personnaliser des pages | Ajouter, modifier ou supprimer des pages HTML ou des pages de composants WebPart, et modifier le site Web en utilisant un éditeur compatible avec Windows SharePoint Services. | Afficher les éléments, Parcourir les répertoires, Afficher les pages, Ouvrir | Création, Contrôle total
Appliquer des thèmes et des bordures | Appliquer un thème ou des bordures au site Web entier. | Afficher les pages, Ouvrir | Création, Contrôle total
Appliquer des feuilles de style | Appliquer une feuille de style (fichier .css) au site Web. | Afficher les pages, Ouvrir | Création, Contrôle total
Créer des groupes | Créer un groupe d'utilisateurs qui peut être utilisé n'importe où dans la collection de sites. | Afficher les pages, Parcourir les informations utilisateur, Ouvrir | Contrôle total
Parcourir les répertoires | Énumérer des fichiers et des dossiers dans un site Web à l'aide de Microsoft SharePoint Designer 2010 et des interfaces Web DAV. | Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total
Utiliser la création de sites libre-service | Créer un site Web à l'aide de la création de sites libre-service | Afficher les pages, Parcourir les informations utilisateur, Ouvrir | Lecture, Collaboration, Création, Contrôle total
Afficher les pages | Afficher les pages dans un site Web. | Ouvrir | Lecture, Collaboration, Création, Contrôle total
Énumérer les autorisations | Énumérer les autorisations sur un site Web, une liste, un dossier, un document ou des éléments de liste. | Parcourir les répertoires, Afficher les pages, Parcourir les informations utilisateur, Ouvrir | Contrôle total
Parcourir les informations utilisateur | Afficher des informations sur les utilisateurs du site Web. | Ouvrir | Tout
Gérer les alertes | Gérer les alertes pour tous les utilisateurs du site Web. | Afficher les éléments, Afficher les pages, Ouvrir | Contrôle total
Utiliser les interfaces distantes | Utiliser les interfaces SOAP, Web DAV ou SharePoint Designer 2010 pour accéder au site Web. | Ouvrir | Tout
Utiliser les fonctionnalités d'intégration des clients | Utiliser les fonctionnalités qui lancent des applications clientes. Sans cette autorisation, les utilisateurs doivent travailler sur les documents localement, puis télécharger leurs modifications. | Utiliser les interfaces distantes, Ouvrir | Tout
Ouvrir | Ouvrir un site Web, une liste ou un dossier pour accéder aux éléments qu'ils contiennent. | Aucun | Tout
Modifier les informations personnelles de l'utilisateur | Les utilisateurs peuvent modifier leurs propres informations utilisateur, par exemple ajouter une image. | Parcourir les informations utilisateur, Ouvrir | Collaboration, Création, Contrôle total

Autorisations personnelles

Autorisation | Description | Autorisations dépendantes | Par défaut incluses dans ces niveaux d'autorisation
Gérer les affichages personnels | Créer, modifier et supprimer des vues personnelles de listes. | Afficher les éléments, Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total
Ajouter/Supprimer des composants WebPart personnels | Ajouter ou supprimer des composants WebPart personnels sur une page de composants WebPart. | Afficher les éléments, Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total
Mettre à jour les composants WebPart personnels | Mettre à jour les composants WebPart pour afficher des informations personnalisées. | Afficher les éléments, Afficher les pages, Ouvrir | Collaboration, Création, Contrôle total

Historique des modifications

Date | Description | Raison
2011/01/03 | 2011/01/03 | Mise à jour du contenu


Types et descriptions de base de données (SharePoint Foundation 2010)

Cet article décrit la base de données installée pour Microsoft SharePoint Foundation 2010. Il comprend des informations relatives au placement et au redimensionnement.

Les bases de données SharePoint Foundation 2010 peuvent être hébergées dans Microsoft SQL Server 2008 R2, SQL Server 2008 avec Service Pack 1 (SP1) et mise à jour cumulative 2 ou SQL Server 2005 avec SP3 et mise à jour cumulative 3. Les installations autonomes peuvent également être hébergées dans les éditions Express de SQL Server 2008 R2 ou SQL Server 2008. Pour plus d'informations, voir Configuration matérielle et logicielle requise (SharePoint Foundation 2010).

Remarque :
Les noms de base de données répertoriés dans cette rubrique sont automatiquement créés lorsque vous exécutez l'Assistant Configuration des produits SharePoint. Vous n'êtes pas obligé d'utiliser ces conventions d'appellation. Vous pouvez spécifier les noms de base de données au moment de leur création ou modifier les noms de base de données après leur création. Pour plus d'informations, voir Déployer à l'aide de bases de données créées par des administrateurs de base de données (SharePoint Foundation 2010).

Les tailles de base de données répertoriées dans cet article sont basées sur les plages suivantes.

Descripteur | Plage de taille
Petit | 1 gigaoctet (Go) ou moins
Moyen | Jusqu'à 100 Go.
Grand | Jusqu'à 1 téraoctet
Très grand | 1 téraoctet ou plus

Dans cet article :

  • Bases de données SharePoint Foundation 2010

  • Bases de données système SQL Server

Pour obtenir une présentation graphique des bases de données utilisées par SharePoint Foundation 2010, voir Modèle de base de données (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=187968&clcid=0x40C).

Bases de données SharePoint Foundation 2010

Les bases de données suivantes appartiennent au déploiement SharePoint Foundation 2010. Ces bases de données appartiennent aussi à tout autre déploiement Produits SharePoint 2010.

Configuration

La base de données de configuration contient des données sur les bases de données SharePoint, les sites Web IIS (Internet Information Services), les applications Web, les solutions fiables, les packages de composants WebPart, les modèles de site, et les paramètres de batterie et d'application Web propres à Produits SharePoint 2010 tels que les paramètres de quota et les types de fichiers bloqués par défaut.

Préfixe de nom de base de données par défaut lors d'une installation à l'aide de l'Assistant Configuration des produits SharePoint | SharePoint_Config
Critères d'emplacement | Aucun
Informations générales de taille et facteurs de croissance | Petit. Cependant, les fichiers journaux de transaction sont susceptibles d'être volumineux. Pour plus d'informations, voir Autres remarques, ci-dessous.
Caractéristiques lecture/écriture | Lecture-intense
Méthode d'adaptation recommandée | Doit pouvoir monter en puissance. La base de données doit croître car une seule base de données de configuration est prise en charge par batterie (une forte augmentation est peu probable).
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération de SharePoint Foundation 2010, SQL Server et System Center Data Protection Manager (DPM) 2010. La base de données de configuration est un cas particulier pour la sauvegarde et la récupération. Pour plus d'informations, voir Autres remarques ci-dessous.
Modèle de récupération par défaut | Complet. Il est recommandé de transférer la base de données de configuration dans le modèle de récupération simple pour limiter la croissance du fichier journal.
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Oui
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

Autres remarques

Fichiers journaux de transaction. Nous vous recommandons de sauvegarder régulièrement le journal des transactions de la base de données de configuration pour forcer la troncation, ou — si vous ne mettez pas en miroir votre système — de changer la base de données pour une exécution en mode de récupération simple. Pour plus d'information, voir Troncation des fichiers journaux de transactions (http://go.microsoft.com/fwlink/?linkid=186687&clcid=0x40C).

Sauvegarde et récupération. La base de données de configuration est sauvegardée lorsque vous effectuez une sauvegarde de contenu et de configuration de batterie SharePoint et certains paramètres de configuration de la base de données sont exportés et stockés comme fichiers XML. Lorsqu'une batterie est restaurée, la base de données de configuration n'est pas restaurée. Au lieu de cela, les paramètres de configuration enregistrés sont importés. La base de données de configuration peut être sauvegardée et restaurée correctement à l'aide de SQL Server ou d'autres outils si la batterie SharePoint est mise hors connexion.

Remarque :
De nombreux paramètres de configuration ne sont pas enregistrés au cours de la sauvegarde ou restauration de la configuration seulement d'une batterie, notamment les paramètres d'application Web, les paramètres d'application de service et les paramètres spécifiques au serveur local. Ces paramètres sont enregistrés au cours d'une sauvegarde de configuration et de contenu de batterie mais certains, par exemple les paramètres proxy d'application de service, ne peuvent pas être restaurés au cours d'une récupération de batterie. Pour plus d'informations sur le contenu enregistré au cours d'une sauvegarde de récupération, voir Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010). Pour obtenir des informations sur la manière de documenter et de copier les paramètres de configuration qui ne sont pas sauvegardés, voir Copier des paramètres de configuration d'une batterie à l'autre (SharePoint Foundation 2010).

Contenu d'Administration Centrale

La base de données de contenu d'Administration Centrale est traitée comme une base de données de configuration. Elle stocke l'intégralité du site, notamment les documents ou les fichiers de site dans les bibliothèques de document, les données de liste et les propriétés des composants WebPart, ainsi que les droits et les noms d'utilisateur pour la collection de sites Administration Centrale.

Préfixe de nom de base de données par défaut lors d'une installation à l'aide de l'Assistant Configuration des produits SharePoint | SharePoint_AdminContent
Critères d'emplacement | Aucun
Informations générales de taille et facteurs de croissance | Petit.
Caractéristiques lecture/écriture | Varie
Méthode d'adaptation recommandée | Doit pouvoir monter en puissance. La base de données doit croître, car une seule base de données Administration Centrale est prise en charge par batterie (une forte croissance est peu probable).
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération, SharePoint Foundation 2010, SQL Server, et DPM 2010. La base de données de contenu Administration Centrale est un cas particulier pour la sauvegarde et la récupération. Pour plus d'informations, voir Autres remarques ci-dessous.
Modèle de récupération par défaut | Complet
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Oui
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

Autres remarques

Sauvegarde et récupération La base de données de contenu Administration Centrale est sauvegardée lorsque vous effectuez une sauvegarde de contenu et de configuration de batterie SharePoint. Lorsqu'une batterie est restaurée, la base de données de contenu Administration Centrale n'est pas restaurée. La base de données de contenu Administration Centrale peut être sauvegardée et restaurée correctement à l'aide de SQL Server ou d'autres outils si la batterie SharePoint est d'abord mise hors connexion.

Bases de données de contenu

Les bases de données de contenu stockent tout le contenu d'une collection de site, notamment les documents ou les fichiers de site ou dans des bibliothèques de document, des données de liste, des propriétés de composants WebPart, des journaux d'audit et des solutions en bac à sable, ainsi que les droits et les noms de l'utilisateur.

Toutes les données d'une collection de sites spécifique résident dans une base de données de contenu sur un seul serveur. Une base de données de contenu peut être associée à plusieurs collections de site.

Les bases de données de contenu contiennent aussi le cache Microsoft Office Web Apps, si Office Web Apps a été déployé. Un seul cache est créé par application Web SharePoint. Si plusieurs collections de sites, stockées dans différentes bases de données de contenu, ont la fonctionnalité OfficeWebAccess_2nd_CurrentVer activée, elles utiliseront toutes le même cache. Vous pouvez configurer la taille du cache, la période d'expiration et l'emplacement. Pour plus d'informations sur la taille du cache Office Web Apps, voir Manage the Office Web Apps cache.

Préfixe de nom de base de données par défaut lors d'une installation à l'aide de l'Assistant Configuration des produits SharePoint

WSS_Content

Critères d'emplacement

Aucune

Informations générales de taille et facteurs de croissance

Il est fortement recommandé de limiter la taille des bases de données de contenu à 200 Go pour garantir les performances du système. Pour plus d'informations, voir Autres remarques ci-dessous.

La taille des bases de données de contenu varie fortement en fonction de l'utilisation. Pour plus d'informations, voir Autres remarques ci-dessous.

Caractéristiques lecture/écriture

Varie à l'utilisation. Par exemple, les environnements de collaboration sont très consommateurs en écriture. Les environnements de gestion de document sont très consommateurs en lecture.

Méthode d'adaptation recommandée

La base de données de contenu qui prend en charge une collection de sites doit monter en puissance. La base de données doit pouvoir s'accroître selon les besoins. Cependant, vous pouvez créer des collections de sites supplémentaires associées à une application Web et associer la nouvelle collection de sites à une autre base de données de contenu. De plus, si une base de données de contenu est associée à plusieurs collections de sites, vous pouvez déplacer une collection de sites vers une autre base de données.

Règles d'intégrité associées

Aucune

Mécanismes de sauvegarde pris en charge

Sauvegarde et récupération, SharePoint Foundation 2010, SQL Server, et DPM 2010.

Modèle de récupération par défaut

Complet

Prend en charge la mise en miroir dans une batterie pour la disponibilité

Oui

Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident

Oui

Autres remarques

Limites recommandées pour la taille des bases de données de contenu

Il est fortement recommandé de limiter la taille des bases de données de contenu à 200 Go pour garantir les performances du système.

Important :
Les tailles de base de données de contenu jusqu'à 1 téraoctet ne sont prises en charge que pour les archives et les référentiels de site uniques et de grande taille dans lesquels les données demeurent raisonnablement statiques, tels que les systèmes de gestion de documents de référence et les sites de Centre d'enregistrements. Des tailles de base de données plus importantes sont prises en charge pour ces scénarios car leurs schémas d'E-S et les formats de leurs structures de données classiques ont été conçus et testés pour une plus grande échelle. Pour plus d'informations sur les référentiels de documents à grande échelle, voir « Évaluer les exigences en performances et en capacité pour les référentiels de documents à grande échelle » dans Performance and capacity test results and recommendations (SharePoint Server 2010).

Estimation de la taille de la base de données de contenu

La taille de la base de données de contenu varie fortement selon l'utilisation du site. Les facteurs de croissance incluent le nombre de documents, le nombre d'utilisateurs, l'utilisation des versions, des corbeilles, la taille des quotas et la configuration ou non du journal d'audit, et le nombre d'éléments choisis pour l'audit.

Si Office Web Apps est en cours d'utilisation, le cache Office Web Apps peut avoir un impact significatif sur la taille d'une base de données de contenu. Pour plus d'informations sur la taille du cache Office Web Apps, voir Manage the Office Web Apps cache.

Base de données de collecte de données relatives à l'état et à l'utilisation

La base de données d'application de service de collecte de données relatives à l'utilisation et à l'état stocke de manière temporaire des données relatives à l'utilisation et au contrôle de l'état. Elle peut servir à la génération de rapports et aux diagnostics.

Remarque :
Cette base de données est la seule base de données SharePoint Foundation 2010 pouvant être directement interrogée ou dont le modèle peut être modifié directement.

Préfixe de nom de base de données par défaut lors d'une installation à l'aide de l'Assistant Configuration des produits SharePoint | WSS_UsageApplication
Critères d'emplacement | La base de données d'application de service de collecte de données relatives à l'utilisation et à l'état est très active et doit être stockée séparément sur un disque ou une pile de disques, si possible.
Informations générales de taille et facteurs de croissance | Très grande. La taille de la base de données dépend du facteur de rétention, du nombre d'éléments pour la journalisation et le contrôle externe, du nombre d'applications Web en cours d'exécution dans l'environnement, du nombre d'utilisateurs actifs et des fonctionnalités activées.
Caractéristiques lecture/écriture | La base de données d'application de collecte de données relatives à l'utilisation et à l'état fait l'objet de très nombreuses écritures.
Méthode d'adaptation recommandée | Doit pouvoir monter en puissance. La base de données doit croître car une seule base de données de journalisation est prise en charge par batterie.
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération, SharePoint Foundation 2010, SQL Server, et DPM 2010.
Modèle de récupération par défaut | Simple
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Oui. Cependant, même si vous pouvez mettre en miroir la base de données d'application de collecte de données relatives à l'utilisation et à l'état, cette opération n'est pas recommandée. Elle est facile à recréer en cas d'incident.
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Oui. Cependant, même si vous pouvez mettre en miroir de manière asynchrone ou copier des journaux de transaction de la base de données d'application de collecte de données relatives à l'utilisation et à l'état, cette opération n'est pas recommandée. Elle est facile à recréer en cas d'incident.

Base de données BDC

La base de données d'application BDC stocke des types de contenu externes et des objets associés.

Préfixe de nom de base de données par défaut lors d'une installation à l'aide de l'Assistant Configuration des produits SharePoint | Bdc_Service_DB_
Critères d'emplacement | Aucune
Informations générales de taille et facteurs de croissance | Petite. La taille est déterminée par le nombre de connexions.
Caractéristiques lecture/écriture | La base de données BDC est très sollicitée pour des opérations de lecture.
Méthode d'adaptation recommandée | Doit pouvoir monter en puissance. La base de données doit croître, car une seule base de données BDC est prise en charge par batterie (une forte croissance est peu probable).
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération, SharePoint Foundation 2010, SQL Server, et DPM 2010.
Modèle de récupération par défaut | Complet
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Oui
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

Base de données du Registre d'application

La base de données d'application du service Registre d'application stocke des informations de compatibilité descendante permettant de se connecter à des informations utilisées par l'API Microsoft Office SharePoint Server 2007 Business Data Catalog.

Remarque :
Lorsque vous avez terminé la migration d'une application depuis le catalogue de données métiers Office SharePoint Server 2007, l'application de service Registre d'application peut être désactivée et la base de données supprimée.

Préfixe de nom de base de données par défaut lors d'une installation à l'aide de l'Assistant Configuration des produits SharePoint | Application_Registry_server_DB_
Critères d'emplacement | Aucune
Informations générales de taille et facteurs de croissance | Petite. La taille est déterminée par le nombre de connexions.
Caractéristiques lecture/écriture | Très sollicité pour des opérations de lecture.
Méthode d'adaptation recommandée | Doit pouvoir monter en puissance. La base de données doit croître, car une seule base de données du service Registre d'application est prise en charge par batterie (une forte croissance est peu probable).
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération, SharePoint Foundation 2010, SQL Server, et DPM 2010.
Modèle de récupération par défaut | Complet
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Oui
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

Base de données Paramètres d'abonnement

La base de données d'application de service des paramètres d'abonnement Microsoft SharePoint Foundation contient des paramètres et des fonctionnalités pour des clients hébergés. La base de données et l'application de service des paramètres d'abonnement ne sont pas créées par l'Assistant Configuration des produits SharePoint — elles doivent être créées au moyen des applets de commande Windows PowerShell. Pour plus d'informations, voir New-SPSubscriptionSettingsServiceApplication.

Préfixe de nom de base de données par défaut lors d'une installation à l'aide de l'Assistant Configuration des produits SharePoint | SubscriptionSettings_
Critères d'emplacement | Aucune
Informations générales de taille et facteurs de croissance | Petite. La taille est déterminée par le nombre de batteries, de clients et de fonctionnalités prises en charge.
Caractéristiques lecture/écriture | La base de données d'abonnement est très sollicitée en lecture.
Méthode d'adaptation recommandée | Augmentez la taille de la base de données qui prend en charge l'instance de l'application de service. Pour ce faire, créez des instances supplémentaire de l'application de service. Cependant, la décision de créer une application de service séparée doit répondre à des besoins commerciaux davantage que des considérations de taille.
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération, SharePoint Foundation 2010, SQL Server, et DPM 2010.
Modèle de récupération recommandé | Complet
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Oui
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

Bases de données système SQL Server

SharePoint Foundation 2010 est conçu sur SQL Server, et par conséquent, fait appel aux bases de données systèmes SQL Server. SQL Server ne prend pas en charge la mise à jour directement par les utilisateurs des informations dans les objets système tels que les tables système, les procédures stockées système et les affichages catalogue. Au lieu de cela, SQL Server fournit un jeu complet d'outils administratifs qui permettent aux utilisateurs d'administrer complètement leur système et de gérer tous les utilisateurs et objets dans une base de données. Pour plus d'informations sur les bases de données système SQL Server, voir Bases de données système (http://go.microsoft.com/fwlink/?linkid=186699&clcid=0x40C).

maître

La base de données maître enregistre toutes les informations au niveau du système d'une instance de SQL Server.

Nom de base de données par défaut | maître
Critères d'emplacement | Aucune
Informations générales de taille et facteurs de croissance | Petite
Caractéristiques lecture/écriture | Varie
Méthode d'adaptation recommandée | Doit croître (une forte croissance est peu probable).
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération SQL Server
Modèle de récupération par défaut | Simple
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Non
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

modèle

La base de données modèle est utilisée comme le modèle de toutes les bases de données créées sur l'instance de SQL Server. Les modifications apportées à cette base de données, telles que la taille de la base de données, le modèle de récupération et d'autres options de base de données, sont appliquées aux bases de données créées ultérieurement.

Nom de base de données par défaut | modèle
Critères d'emplacement | Aucune
Informations générales de taille et facteurs de croissance | Petit
Caractéristiques lecture/écriture | Varie
Méthode d'adaptation recommandée | Doit croître (une forte croissance est peu probable).
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération SQL Server
Modèle de récupération par défaut | Complet
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Non
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

msdb

La base de données msdb est utilisée par l'Agent SQL Server pour planifier des alertes et des tâches.

Nom de base de données par défaut | msdb
Critères d'emplacement | Aucun
Informations générales de taille et facteurs de croissance | Petite
Caractéristiques lecture/écriture | Varie
Méthode d'adaptation recommandée | La base de données doit croître (une forte croissance est peu probable).
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération SQL Server
Modèle de récupération par défaut | Simple
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Non
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

tempdb

La base de données tempdb est un espace de travail permettant d'entreposer des objets temporaires ou des jeux de résultats intermédiaires. Elle répond à tous les besoins de stockage temporaire. La base de données tempdb est recréée à chaque démarrage de SQL Server.

Nom de base de données par défaut | tempdb
Critères d'emplacement | Localisez sur un disque rapide sur une pile de disques à l'écart des autres bases de données. Créez autant de fichiers que nécessaire pour maximiser la bande passante de disque. L'utilisation de plusieurs fichiers réduit la contention de stockage tempdb et offre une meilleure évolutivité. Cependant, évitez de créer un trop grand nombre de fichiers ce qui risque de réduire les performances et augmenter la charge de gestion. En règle générale, créez un fichier de données pour chaque processeur sur le serveur puis augmentez ou réduisez le nombre de fichiers selon les besoins. Ne pas oublier qu'un double processeur correspond à deux processeurs.
Informations générales de taille et facteurs de croissance | Petite à très grande. La taille de la base de données tempDB augmente et se réduit très vite. La taille dépend du nombre d'utilisateurs du système, des processus spécifiques en cours d'exécution ; par exemple, la reconstruction en ligne d'index volumineux ou des tris importants entraîne une croissance rapide de la base de données.
Caractéristiques lecture/écriture | Varie
Méthode d'adaptation recommandée | Évolution verticale
Règles d'intégrité associées | Aucune
Mécanismes de sauvegarde pris en charge | Sauvegarde et récupération SQL Server
Modèle de récupération par défaut | Simple
Prend en charge la mise en miroir dans une batterie pour la disponibilité | Non
Prend en charge la mise en miroir asynchrone ou la copie des journaux de transaction vers une autre batterie pour la récupération en cas d'incident | Non

Historique des modifications

Date | Description | Raison
29 juillet 2010 | 2010/07/26 | Mise à jour du contenu


Expérience utilisateur sur les sites en lecture seule (SharePoint Foundation 2010)

Cet article décrit les modifications de l'interface sur un site Microsoft SharePoint Foundation 2010 pour lequel la base de données associée est définie comme étant en lecture seule (site en lecture seule).

L'expérience utilisateur sur un site en lecture seule se caractérise par les éléments suivants :

  • Les tâches courantes ne nécessitant pas d'écrire dans la base de données de contenu sont totalement disponibles.

  • La plupart des tâches courantes nécessitant d'écrire dans la base de données de contenu ne sont pas disponibles, car elles ont été désactivées dans l'interface utilisateur ou parce que l'utilisateur n'est plus autorisé à appliquer des modifications.

  • Certaines tâches courantes nécessitant d'écrire dans la base de données de contenu sont disponibles, mais renvoient des erreurs.

Cet article décrit les tâches courantes qui ne sont pas disponibles et celles qui renvoient des erreurs sur un site en lecture seule.

Tâches courantes qui ne sont pas disponibles sur un site en lecture seule et qui ne renvoient pas d'erreurs

L'interface utilisateur est modifiée afin que les tâches courantes impliquant des opérations d'écritures dans la base de données ne soient pas disponibles et apparaissent estompées. Les éléments de l'interface utilisateur qui ne sont pas disponibles sont répertoriés dans le tableau suivant.

Objet | Éléments de l'interface désactivés sur un site en lecture seule
Menu Actions du site | Page Édition Nouvelle page Nouvelle bibliothèque de documents Nouveau site Autres options de création Modifier le site dans SharePoint Designer Flux de travail d'un site
Onglet Outils de bibliothèque : Documents | Nouveau document Télécharger un document Nouveau dossier Modifier le document Extraire Archiver Annuler l'extraction Modifier les propriétés Historique des versions Supprimer le document Liaison mobile Gérer les copies Atteindre la source Flux de travail Publier Retirer la publication Approuver/Rejeter Annuler l'approbation
Onglet Outils de bibliothèque : Bibliothèque | Nouvelle ligne Actualiser les données Créer un affichage Modifier l'affichage Créer une colonne Modifier la bibliothèque Composants WebPart Formulaire Paramètres de la bibliothèque Flux de travail
Onglet Outils de liste : Éléments | Nouvel élément Nouveau dossier Modifier l'élément Supprimer l'élément Joindre un fichier Flux de travail Approuver/Rejeter
Onglet Outils de liste : Liste | Nouvelle ligne Actualiser les données Actualiser les données Créer un affichage Créer une colonne Liaison mobile Se connecter à Outlook Créer un diagramme Visio Ouvrir la planification Modifier la liste Composants WebPart Formulaire Paramètres de la liste Personnaliser le formulaire Flux de travail
Onglet Outils Calendrier : Événements | Nouvel événement Modifier l'événement Supprimer l'événement Flux de travail Approuver/Rejeter
Onglet Outils Calendrier : Calendrier | Créer un affichage Modifier l'affichage M'avertir
Paramètres du site : Utilisateurs et autorisations > Personnes et groupes | Nouveau Actions : Supprimer les utilisateurs du groupe Paramètres
Paramètres du site : Utilisateurs et autorisations > Autorisations de site | Accorder des autorisations Créer un groupe Autorisations utilisateur Supprimer les autorisations des utilisateurs Administrateurs de collections de sites
Paramètres du site : Utilisateurs et autorisations > Toutes les personnes | Actions : Supprimer les utilisateurs de la collection de sites Paramètres : Paramètres de liste

Certaines options qui ne sont pas disponibles sur un site en lecture seule paraissent disponibles, mais le bouton OK est désactivé sur les pages suivantes. Ces pages sont répertoriées ci-dessous.

  • Utilisateurs et autorisations

    • Administrateurs de collections de sites

    • Autorisations de site : Gérer les demandes d'accès

  • Aspect

    • Titre, description et icône

    • Barre de liens supérieure : Nouveau lien de navigation

    • Lancement rapide

      • Nouveau titre

      • Nouveau lien de navigation

    • Arborescence

  • Galeries

    • Colonnes de site

    • Types de contenu de site

  • Administration du site : Paramètres régionaux

  • Actions du site : Rétablir la définition du site

Tâches courantes qui paraissent disponibles sur un site en lecture seule, mais renvoient des erreurs

Certaines options qui ne sont pas disponibles dans une base de données en lecture seule paraissent disponibles dans l'interface, mais les utilisateurs obtiendront des messages d'erreur s'ils essaient d'effectuer ces actions. Les éléments de l'interface utilisateur qui renvoient des erreurs sont répertoriés dans le tableau suivant.

Composant ou zone Type d'opération ou d'action Comportement ou message d'erreur

Thème du site

Sur la page Thème du site, cliquer sur Appliquer.

SharePoint renvoie le message « Erreur : Accès refusé ».

Bibliothèques et listes du site

Cliquer sur Créer un nouveau contenu.

SharePoint renvoie le message « Une erreur inattendue s'est produite ».

Sites et espaces de travail

Cliquer sur Créer.

SharePoint renvoie le message « Erreur : Accès refusé ».

Personnaliser le volet Lancement rapide

Cliquer sur Modifier l'ordre, rétablir l'ordre des liens sur le page Réorganiser les liens, puis cliquer sur OK.

SharePoint renvoie le message « Erreur : Accès refusé ».

Fonctionnalités du site

Cliquer sur Activer ou Désactiver.

SharePoint renvoie le message « Erreur : Accès refusé ».

Supprimer ce site

SharePoint renvoie le message « Erreur : Accès refusé ».

Corbeille

Cliquer sur n'importe quel des boutons suivants :

  • Restaurer la sélection

  • Supprimer la sélection

  • Vider la Corbeille

SharePoint renvoie le message « Erreur : Accès refusé ».

Paramètres de SharePoint Designer

Modifier n'importe quel paramètre, puis cliquer sur OK.

SharePoint renvoie le message « Erreur : Accès refusé ».

Paramètres de l'aide

SharePoint renvoie le message « Erreur : Accès refusé ».

Ruban Commandes personnalisées

Cliquer sur Personnaliser le formulaire.

SharePoint renvoie l'erreur Microsoft InfoPath « Entrez les informations d'identification pour la connexion au service Web suivant ».

Ruban Outils de liste, onglet Liste

Cliquer sur Personnaliser le formulaire.

SharePoint renvoie l'erreur « Microsoft InfoPath 2010 est requis pour utiliser cette fonctionnalité ».

Historique des modifications


Modules linguistiques (SharePoint Foundation 2010)

Cet article présente la liste des modules linguistiques disponibles pour Microsoft SharePoint Foundation 2010. Les modules linguistiques permettent de créer des sites et des collections de sites en plusieurs langues sans qu'il soit nécessaire d'installer séparément SharePoint Foundation 2010 dans chaque langue. Pour plus d'informations sur les modules linguistiques, voir Déployer des modules linguistiques (SharePoint Foundation 2010). Les modules linguistiques peuvent être téléchargés à l'adresse Modules linguistiques pour SharePoint Foundation 2010.

Le tableau suivant répertorie les modules linguistiques disponibles pour SharePoint Foundation 2010 :

Langue | ID de langue
Arabe | 1025
Basque | 1069
Bulgare | 1026
Catalan | 1027
Chinois (simplifié) | 2052
Chinois (traditionnel) | 1028
Croate | 1050
Tchèque | 1029
Danois | 1030
Néerlandais | 1043
Anglais | 1033
Estonien | 1061
Finnois | 1035
Français | 1036
Galicien | 1110
Allemand | 1031
Grec | 1032
Hébreu | 1037
Hindi | 1081
Hongrois | 1038
Italien | 1040
Japonais | 1041
Kazakh | 1087
Coréen | 1042
Letton | 1062
Lituanien | 1063
Norvégien (Bokmål) | 1044
Polonais | 1045
Portugais (Brésil) | 1046
Portugais (Portugal) | 2070
Roumain | 1048
Russe | 1049
Serbe (latin) | 2074
Slovaque | 1051
Slovène | 1060
Espagnol | 3082
Suédois | 1053
Thaï | 1054
Turc | 1055
Ukrainien | 1058

Historique des modifications

Date | Description | Raison
14 octobre 2010 | 2010/10/11 | Mise à jour du contenu
16 septembre 2010 | 2010/09/13 | Mise à jour du contenu
12 août 2010 | 2010/08/09 | Mise à jour du contenu
15 juillet 2010 | 2010/07/12 | Mise à jour du contenu
10 juin 2010 | 2010/06/07 | Mise à jour du contenu
4 juin 2010 | 2010/05May/Week5 | Mise à jour du contenu


Langues pour les séparateurs de mots et générateurs de forme (SharePoint Foundation 2010)

Cet article répertorie les langues pour lesquelles Microsoft SharePoint Foundation 2010 fournit des analyseurs lexicaux et des générateurs de formes dérivées. Pour plus d'informations sur l'utilisation des analyseurs lexicaux et des analyseurs morphologiques avec des sites multilingues, voir Planifier des sites multilingues (SharePoint Foundation 2010).

Le tableau suivant répertorie les langues pour lesquelles SharePoint Foundation 2010 fournit des analyseurs lexicaux et des générateurs de formes dérivées :

Langue | Langue | Langue
Arabe* | Hindi | Pendjabi
Bengali | Hongrois* | Roumain
Bulgare | Islandais | Russe
Catalan | Indonésien | Serbe (cyrillique)
Chinois (simplifié)* | Italien | Serbe (latin)
Chinois (traditionnel)* | Japonais* | Slovaque
Croate | Kannada | Slovène
Tchèque | Coréen | Espagnol (Espagne)
Danois | Letton | Espagnol (Mexique)
Néerlandais | Lituanien | Suédois
Anglais | Malais | Tamoul
Finnois* | Malayalam | Télougou
Français | Marathi | Thaï*
Allemand | Norvégien | Turc*
Grec | Polonais | Ukrainien
Gujarati | Portugais (Brésil) | Ourdou
Hébreu* | Portugais (Portugal) | Vietnamien*

*Ces langues bénéficient uniquement d'analyseurs lexicaux. Aucun générateur de formes dérivées n'est disponible pour ces langues.

Historique des modifications


Référence de déploiement par script (SharePoint Foundation 2010)

Cet article décrit les commandes et la syntaxe utilisées dans le déploiement à base de script d'une batterie de serveurs Microsoft SharePoint Foundation 2010. Il contient également un tableau de modèles courants utilisés dans Installer SharePoint Foundation 2010 à l'aide de Windows PowerShell.

Important :
Les commandes Install-SharePoint, New-SharePointFarm et Join-SharePointFarm doivent être utilisées uniquement dans le contexte du fichier SPModule.zip.

Pour plus d'informations sur l'utilisation de ces commandes dans le cadre de l'installation de SharePoint Foundation 2010, voir Installer SharePoint Foundation 2010 à l'aide de Windows PowerShell.

Dans cet article :

  • Install-SharePoint

  • New-SharePointFarm

  • Join-SharePointFarm

  • Modèles courants de collection de sites

Install-SharePoint

La commande Install-SharePoint installe SharePoint Foundation 2010 sur tous les serveurs.

Il existe deux manières (définies par un jeu de paramètres) d'exécuter la commande Install-SharePoint. Dans le premier cas, vous spécifiez un chemin d'accès aux fichiers d'installation et de nombreuses autres valeurs afin de dévier par rapport aux valeurs par défaut. La seconde manière consiste à spécifier le chemin d'accès aux fichiers d'installation, puis le chemin d'accès à un fichier Config.xml. Durant l'installation, PIDKey et d'autres paramètres sont analysés dans le fichier config.xml.

La syntaxe de la commande Install-SharePoint est fournie ci-dessous. Notez que le résultat est déterminé par le jeu de paramètres spécifié. Pour le premier jeu de paramètres, le paramètre SetupExePath est obligatoire. Tous les autres paramètres sont facultatifs. Si aucune valeur n'est spécifiée pour le paramètre facultatif LogPath, la valeur par défaut est %Temp%.

Remarque :
Dans SharePoint Foundation, le paramètre PIDKey n'est pas obligatoire.

Install-SharePoint -SetupExePath <Chaîne> -PIDKey <Chaîne> [-LoggingType < Verbose | Off | Standard | Debug>] [-LogPath <Chaîne>] [-LogTemplate <Chaîne>] [-DisplayLevel <None | Basic | Full>] [-ShowCompletionNotice <ParamètreCommutateur>] [-UseIInstallMode <ParamètreCommutateur>] [-AcceptEula <ParamètreCommutateur>] [-ShowModalDialog <ParamètreCommutateur>] [-AllowCancel <ParamètreCommutateur>] [-ServerRole <APPLICATION | WFE | SINGLESERVER>] [-SetupType <CLEAN_INSTALL | V2V_INPLACE_UPGRADE | B2B_UPGRADE | SKU2SKU_UPGRADE>] [-InstallDirectory <Chaîne>] [-DataDirectory <Chaîne>] [-RunsWorkaround <ParamètreCommutateur>] [-PhysicalSKU <OfficeServer | SharePoint | SearchServer | SearchServerExpress | WCServer | ProjectServer | SharePointLanguagePack | ServerLanguagePack>]

Pour le second jeu de paramètres, il existe deux paramètres obligatoires : SetupExePath et ConfigXMLPath.

Install-SharePoint -SetupExePath <Chaîne> -ConfigXMLPath <Chaîne> [-PIDKey <Chaîne>] [-PhysicalSKU <OfficeServer | SharePoint | SearchServer | SearchServerExpress | WCServer | ProjectServer | SharePointLanguagePack | ServerLanguagePack>]

New-SharePointFarm

La commande New-SharePointFarm crée la batterie sur le serveur qui exécutera le site Web Administration centrale.

La commande effectue les actions suivantes :

  1. création de la base de données de configuration ;

  2. création de la base de données de contenu d'administration ;

  3. installation de la collection d'aide ;

  4. création de l'application Web Administration centrale ;

  5. copie des données d'applications partagées dans les dossiers d'applications Web existants.

La syntaxe de la commande New-SharePointFarm est fournie ci-dessous. Il existe deux paramètres obligatoires : DatabaseAccessAccount et DatabaseServer. Tous les autres paramètres sont facultatifs.

New-SharePointFarm -DatabaseAccessAccount <InformationsIdentificationPS> -DatabaseServer <Chaîne> [-Passphrase <ChaîneSécurisée>] [-Port <Int>] [-AdminAuthMethod <NTLM | Kerberos>] [-FarmName <Chaîne>]

Exemple : New-SharePointFarm -DatabaseAccessAccount (Get-Credential DOMAIN\username) -DatabaseServer "SQL01" -FarmName "TestFarm"

Join-SharePointFarm

Vous exécutez la commande Join-SharePointFarm sur des serveurs afin de les connecter à la batterie.

La syntaxe de la commande Join-SharePointFarm est fournie ci-dessous. Il existe deux paramètres obligatoires : DatabaseServer et ConfigurationDatabaseName. Tous les autres paramètres sont facultatifs.

Join-SharePointFarm -DatabaseServer <Chaîne> -ConfigurationDatabaseName <Chaîne> [-Passphrase <ChaîneSécurisée>]

Remarque :
Pour éviter que l'utilisateur soit invité à fournir le mot de passe, vous pouvez utiliser le paramètre Passphrase. La valeur du paramètre Passphrase est le mot de passe de l'utilisateur.

Modèles courants de collection de sites

Le tableau suivant décrit les modèles courants utilisés dans Installer SharePoint Foundation 2010 à l'aide de Windows PowerShell.

Valeur du paramètre | Description
GLOBAL#0 | Modèle global
STS#0 | Site d'équipe
STS#1 | Site vide
STS#2 | Espace de travail de document
MPS#0 | Espace de travail de réunion de base
MPS#1 | Espace de travail de réunion vide
MPS#2 | Espace de travail de réunion pour la prise de décision
MPS#3 | Espace de travail de réunion informelle
MPS#4 | Espace de travail de réunion multipage
CENTRALADMIN#0 | Site Administration centrale
WIKI#0 | Site Wiki
BLOG#0 | Blog
SGS#0 | Site de travail de groupe
TENANTADMIN#0 | Site d'administration des clients
ACCSRV#0 | Site Access Services
ACCSRV#1 | Base de données de biens Web
ACCSRV#3 | Base de données Web de dons
ACCSRV#4 | Base de données Web des contacts
ACCSRV#6 | Base de données Web de problèmes
ACCSRV#5 | Base de données Web de projets
BDR#0 | Centre de documents
OFFILE#0 | (obsolète) Centre des enregistrements
OFFILE#1 | Centre des enregistrements
OSRV#0 | Site d'administration des services partagés
PPSMASite#0 | PerformancePoint
BICenterSite#0 | Business Intelligence Center
PWA#0 | Site Project Web App
PWS#0 | Site Microsoft Project
SPS#0 | Site SharePoint Portal Server
SPSPERS#0 | Espace personnel SharePoint Portal Server
SPSMSITE#0 | Site de personnalisation
SPSTOC#0 | Modèle de zone Sommaire
SPSTOPIC#0 | Modèle de zone Rubrique
SPSNEWS#0 | Site de News
CMSPUBLISHING#0 | Site de publication
BLANKINTERNET#0 | Site de publication
BLANKINTERNET#1 | Site de communiqués de presse
BLANKINTERNET#2 | Site de publication avec flux de travail
SPSNHOME#0 | Site de News
SPSSITES#0 | Annuaire de sites
SPSCOMMU#0 | Modèle de zone Communauté
SPSREPORTCENTER#0 | Centre de rapports
SPSPORTAL#0 | Portail de collaboration
SRCHCEN#0 | Centre de recherche d'entreprise
PROFILES#0 | Profils
BLANKINTERNETCONT | Portail de publication
SPSMSITEHOST#0 | Hôte de sites Mon site
ENTERWIKI#0 | Wiki d'entreprise
SRCHCENTERLITE#0 | Centre de recherche de base
SRCHCENTERLITE#1 | Centre de recherche de base
SRCHCENTERFAST#0 | Centre FAST Search
visprus#0 | Référentiel de processus Visio

Historique des modifications


Référence de travaux du minuteur (SharePoint Foundation 2010)

Cet article décrit les travaux du minuteur par défaut pour SharePoint Foundation 2010. Un travail du minuteur s'exécute dans un service Windows spécifique pour SharePoint Foundation. Les travaux du minuteur effectuent également des tâches d'infrastructure pour le service du minuteur, telles que l'effacement de l'historique de travaux du minuteur et le recyclage du service du minuteur, ainsi que des tâches pour des applications Web, telles que l'envoi d'alertes par messagerie électronique. Un travail du minuteur contient une définition du service à exécuter et spécifie à quelle fréquence il est démarré. Le service du minuteur SharePoint 2010 (SPTimerv4) exécute des travaux du minuteur. De nombreuses fonctionnalités de SharePoint Foundation s'appuient sur les travaux du minuteur pour exécuter des services selon un planning.

Dans cet article :

  • Gérer les travaux du minuteur

  • Travaux du minuteur par défaut

Gérer les travaux du minuteur

Vous pouvez vérifier l'état d'un travail du minuteur et modifier sa définition.

Pour l'administration générale de tous les travaux, le site Administration centrale de SharePoint comprend une page État du travail du minuteur et une page Définitions des travaux. Ces pages sont accessibles dans l'Administration centrale, dans la page Analyse, dans la section Travaux du minuteur.

Dans le menu Affichage, vous pouvez filtrer les travaux du minuteur aux niveaux suivants :

  • Tout Affiche tous les travaux du minuteur pour la batterie.

  • Service Affiche tous les travaux du minuteur pour un service donné. Si vous sélectionnez cette commande, utilisez le menu Service pour sélectionner le service par lequel filtrer les travaux répertoriés.

  • Application Web Affiche tous les travaux du minuteur pour une application Web. Si vous sélectionnez cette option, utilisez le menu Application Web pour sélectionner l'application Web par laquelle filtrer les travaux répertoriés.

  • Serveur Affiche tous les travaux du minuteur pour le serveur spécifié. Si vous sélectionnez cette commande, utilisez le menu Serveur pour sélectionner le serveur par lequel filtrer les travaux répertoriés.

  • Définition du travail Affiche tous les travaux du minuteur pour la définition de travail spécifiée. Dans la page État du travail du minuteur, utilisez le menu Définition du travail pour sélectionner la définition de travail par laquelle filtrer les travaux répertoriés.

  • Travaux non réussis Affiche tous les travaux du minuteur dans la batterie qui ne se sont pas terminés.

Le service du minuteur SharePoint 2010 (SPTimerv4) est basé sur le calendrier grégorien pour la planification. Pour chaque travail que vous planifiez, vous devez spécifier quand ce travail s'exécutera dans un format horaire sur 24 heures. Vous devez spécifier l'horaire en heure locale plutôt que sous la forme d'un décalage par rapport au Temps universel coordonné (UTC). L'horaire est stockée dans ce format. Les plannings quotidiens, hebdomadaires et mensuels incluent également une fenêtre d'exécution. Le service du minuteur sélectionne un horaire aléatoire dans cet intervalle pour lancer l'exécution du travail sur chaque serveur applicable. Cette fonctionnalité convient aux travaux à charge élevée qui s'exécutent sur plusieurs serveurs dans la batterie. L'exécution de ce type de travail sur tous les serveurs simultanément risque de placer une charge trop importante sur la batterie. Les plannings de travaux du minuteur peuvent être spécifiés à l'aide de Windows PowerShell. Pour plus d'informations, voir Applets de commande pour les travaux du minuteur (SharePoint Foundation 2010).

Travaux du minuteur par défaut

Le tableau suivant répertorie les travaux du minuteur par défaut pour SharePoint Foundation 2010.

Titre du travail de minuteur Description Type de planification

Tâche d'actualisation des adresses d'applications

Synchronise les informations de connexion pour les applications de service distantes.

15 minutes

Suppression du journal d'audit

Supprime les entrées de journal d'audit des collections de sites.

Mensuel

Collection de données CEIP

Recueille des données pour le Programme d'amélioration du produit.

Quotidien

Tâche du minuteur de nettoyage des données de stockage de cellules

Supprime les données de stockage de cellules temporaires et libère de l'espace disque SQL Server.

Hebdomadaire

Tâche de suppression des données utilisateur de stockage de cellules

Supprime les données utilisateur stockées sous forme de stockage de cellules. Ce travail doit être exécuté uniquement si le serveur de bases de données SQL Server manque d'espace disque.

Important :
Ce travail peut provoquer une perte de données utilisateur et ne s'exécute pas automatiquement par défaut.

Mensuel

Journal des modifications

Documente les modifications apportées aux sites et pages dans l'application Web depuis la dernière exécution du travail du minuteur.

Quotidien

Actualisation de la configuration

Vérifie la présence de modifications de configuration dans la base de données de configuration.

15 secondes

Traitement de l'organisateur de contenu

Traite les documents dans la bibliothèque de remise qui répondent aux règles d'organisation.

Quotidien

Suppression des sites inactifs

Lorsque le nettoyage de site automatique est activé, les sites qui n'ont pas été utilisés depuis un laps de temps spécifique sont supprimés.

Quotidien

Supprimer l'historique des tâches

Supprime les anciennes entrées de l'historique des travaux du minuteur.

Hebdomadaire

Fournisseur de données de diagnostic : journal des événements

Recueille les entrées du journal des événements de Windows et stocke les données dans la base de données de journalisation.

10 minutes

Fournisseur de données de diagnostic : compteurs de performances - Serveurs de base de données

Recueille des données des compteurs de l'Analyseur de performances sur des serveurs de bases de données.

Important :
Le compte du service du minuteur doit disposer d'autorisations suffisantes pour recueillir les compteurs sur le serveur de bases de données. Ce compte doit être membre du groupe Utilisateurs de l'Analyseur de performances.

5 Minutes

Fournisseur de données de diagnostic : Compteurs de performance - Sites Web frontaux

Recueille des données des compteurs de l'Analyseur de performances sur des serveurs Web frontaux.

5 Minutes

Fournisseur de données de diagnostic : requêtes de blocage SQL

Recueille des données associées aux requêtes SQL bloquées.

15 secondes

Fournisseur de données de diagnostic : DMV SQL

Recueille des données DMV (Dynamic Management Views) SQL.

30 minutes

Fournisseur de données de diagnostic : journal de suivi

Recueille les entrées du journal de suivi et stocke les données d'utilisation dans la base de données de journalisation.

10 minutes

Avertissement du quota de disque

Recherche les sites qui ont dépassé le quota de stockage.

Quotidien

Suppression progressive du site

Supprime toutes les données de la base de données de contenu hôte pour toutes les collections de sites supprimées.

Quotidien

Tâche d'analyse de l'intégrité (Quotidien, Administration centrale, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent l'application Web Administration centrale et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Quotidien

Tâche d'analyse de l'intégrité (Quotidien, Administration centrale, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent l'application Web Administration centrale et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Quotidien

Tâche d'analyse de l'intégrité (Quotidien, Minuteur de Microsoft SharePoint Foundation, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent le service du minuteur SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Quotidien

Tâche d'analyse de l'intégrité (Quotidien, Minuteur de Microsoft SharePoint Foundation, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur le premier serveur détecté dans la batterie qui exécute le service du minuteur SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Quotidien

Tâche d'analyse de l'intégrité (Quotidien, Application Web de Microsoft SharePoint Foundation, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent des applications Web SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Quotidien

Tâche d'analyse de l'intégrité (Quotidien, Application Web de Microsoft SharePoint Foundation, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur le premier serveur détecté dans la batterie qui exécute des applications Web SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Quotidien

Tâche d'analyse de l'intégrité (Toutes les heures, Authentification basée sur les revendications, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent le service d'émission de jeton de sécurité et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Toutes les heures

Tâche d'analyse de l'intégrité (Toutes les heures, Minuteur de Microsoft SharePoint Foundation, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent le service du minuteur SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Toutes les heures

Tâche d'analyse de l'intégrité (Toutes les heures, Minuteur de Microsoft SharePoint Foundation, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur le premier serveur détecté dans la batterie qui exécute le service du minuteur SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Toutes les heures

Tâche d'analyse de l'intégrité (Toutes les heures, Service de profil utilisateur, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur le premier serveur détecté dans la batterie qui exécute des services de profils et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Toutes les heures

Tâche d'analyse de l'intégrité (Mensuel, Minuteur de Microsoft SharePoint Foundation, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur le premier serveur détecté dans la batterie qui exécute le service du minuteur SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Mensuel

Tâche d'analyse de l'intégrité (Hebdomadaire, Administration centrale, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent le site Web Administration centrale et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Hebdomadaire

Tâche d'analyse de l'intégrité (Hebdomadaire, Minuteur de Microsoft SharePoint Foundation, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent le service du minuteur SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Hebdomadaire

Tâche d'analyse de l'intégrité (Hebdomadaire, Minuteur de Microsoft SharePoint Foundation, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur le premier serveur détecté dans la batterie qui exécute le service du minuteur SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Hebdomadaire

Tâche d'analyse de l'intégrité (Hebdomadaire, Application Web de Microsoft SharePoint Foundation, Tous les serveurs)

Exécute des travaux Analyseur d'intégrité SharePoint sur tous les serveurs de la batterie qui exécutent des applications Web SharePoint et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Hebdomadaire

Tâche d'analyse de l'intégrité (Hebdomadaire, Service de profil utilisateur, N'importe quel serveur)

Exécute des travaux Analyseur d'intégrité SharePoint sur le premier serveur détecté dans la batterie qui exécute des services de profils et l'application de service de collecte de données relatives à l'état et à l'utilisation.

Hebdomadaire

Alertes immédiates

Envoie des alertes immédiates et planifiées.

5 Minutes

Collection des utilisations du stock de sites Microsoft SharePoint Foundation

Recueille des informations d'inventaire de sites pour chaque collection de sites de la batterie de serveurs.

Quotidien

Importation des données d'utilisation de Microsoft SharePoint Foundation

Importe les fichiers journaux d'utilisation dans la base de données de journalisation.

30 minutes

Traitement des données d'utilisation de Microsoft SharePoint Foundation

Vérifie la présence de données d'utilisation expirées au niveau de la batterie et supprime ces données. Les données d'utilisation expirées sont constituées des enregistrements dans la base de données centrale de collecte des données d'utilisations dont la date est antérieure à 30 jours.

Si l'application de service Web Analytics est également installée, ce travail du minuteur déplace les données vers une base de données de création de rapports Web Analytics. Vous pouvez exécuter ce travail du minuteur manuellement afin de forcer une vérification des données expirées ou forcer une importation des données d'utilisation vers une base de données d'application Web Analytics.

Quotidien

Gestion des mots de passe

Envoie un message électronique et enregistre les événements dans un journal pour les mots de passe arrivant à expiration et les modifications de mot de passe. Ce travail du minuteur aide à s'assurer que les mots de passe gérés sont modifiés avant leur expiration.

Quotidien

Travail de version de produit

Vérifie l'état d'installation de l'ordinateur et ajoute ces données à la base de données.

Quotidien

Corbeille

Recherche du contenu dans les Corbeilles et le déplace vers la phase suivante ou le supprime.

Quotidien

Mise à jour quotidienne de l'utilisation des ressources de la solution

Marque la limite quotidienne de contrôle du quota des ressources dans la solution bac à sable (sandbox).

Quotidien

Traitement du journal d'utilisation des ressources de la solution

Regroupe les données d'utilisation des ressources à partir de l'exécution de la solution bac à sable (sandbox).

5 Minutes

Mise à jour de l'utilisation des ressources de la solution

Enregistre les données d'utilisation des ressources à partir de l'exécution de la solution bac à sable (sandbox) et envoie un message électronique aux propriétaires de collections de sites qui dépassent le quota de ressources alloué.

15 minutes

Gestion du verrouillage du service du minuteur

Gère les verrous des bases de données de contenu utilisés par le service du minuteur afin de déterminer le serveur qui exécutera les travaux du minuteur pour une base de données de contenu.

1 minute

Recyclage du service du minuteur

Recycle le service du minuteur pour libérer les ressources.

Quotidien

Mettre à niveau la tâche d'élément de travail

Traite les journaux et regroupe les données d'utilisation pour chaque site.

Quotidien

Flux de travail

Traite les événements de flux de travail qui figurent dans le tableau d'éléments planifiés, tels que les retards.

5 Minutes

Nettoyage automatique du flux de travail

Supprime du tableau d'instances de flux de travail les tâches et les instances relatives aux flux de travail qui ont été marqués comme terminés depuis plus de n jours, où n est spécifié dans l'association de flux de travail. Analyse les tâches et le tableau d'instances de flux de travail.

Quotidien

Basculement du flux de travail

Traite les événements des flux de travail ayant échoué et étant marqués pour une nouvelle tentative.

15 Minutes

Historique des modifications

Date | Description | Raison
8 juillet 2010 | Publication initiale |


Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)

Cet article destiné aux administrateurs fournit des informations sur la version de juillet 2010 de la Boîte à outils d'administration de SharePoint version 1.0, qui comprend les fonctionnalités suivantes :

  • Le Kit de test de charge (LTK, Load Testing Kit), qui génère un test de charge Visual Studio Team System 2008 (VSTS) sur les journaux IIS Windows SharePoint Services 3.0. Le test de charge VSTS peut servir à générer une charge synthétique contre Microsoft SharePoint Foundation 2010 dans le cadre d'un exercice de planification de capacité ou un test de contrainte de pré-mise à niveau.

  • Le manifeste d'Assistant Configuration de la sécurité (SCW, Security Configuration Wizard), qui ajoute des rôles pour les Produits SharePoint 2010 à Windows Server 2008 avec Service Pack 2 ou à Windows Server 2008 R2.

  • Le Moteur de réplication de profil, qui fournit aux administrateurs de services partagés la capacité à répliquer des profils utilisateur et des données sociales entre des fournisseurs de services partagés dans Office SharePoint Server 2007 et des applications de service Profil utilisateur dans SharePoint Server 2010.

    Remarque :
    Cet outil n'est pas pris en charge pour SharePoint Foundation 2010.

  • Le connecteur CMIS (Content Management Interoperability Services) pour Microsoft SharePoint Server 2010, qui permet aux utilisateurs de SharePoint d'interagir avec le contenu stocké dans tout référentiel ayant implémenté la norme CMIS et de rendre le contenu SharePoint 2010 accessible à toute application ayant implémenté la norme CMIS.

    Remarque :
    Ce connecteur n'est pas pris en charge pour SharePoint Foundation 2010.

Si vous prévoyez d'installer toute la boîte à outils, sachez que le programme d'installation de la Boîte à outils d'administration SharePoint prend en charge l'utilisation du commutateur /quiet. En revanche, pour écrire des scripts d'installations partielles, la commande suivante doit être utilisée pour extraire le fichier Spat.msi du fichier SharePoint2010AdministrationToolkit.exe :

SharePoint2010AdministrationToolkit.exe /extract:<chemin_accès>

où chemin_accès est l'emplacement des fichiers extraits.

Le package d'installation est personnalisable et sélectionnable, ce qui signifie qu'un utilisateur peut contrôler les outils qui sont installés ou désinstallés et peut spécifier un dossier d'installation personnalisé pour n'importe quel outil.

La boîte à outils est téléchargeable à partir de la page Web Boîte à outils d'administration Microsoft SharePoint 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=196866&clcid=0x40C).

Dans cette section :

  • Installation de la Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)

  • Désinstallation de la Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)

  • Load Testing Kit (SharePoint Foundation 2010)

  • Manifeste de l'Assistant Configuration de la sécurité pour SharePoint Foundation 2010

Historique des modifications

Date | Description | Raison
15 juillet 2010 | Publication initiale |


Installation de la Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)
Voir aussi

Cet article explique comment installer la Boîte à outils d'administration SharePoint 2010.

La Boîte à outils d'administration SharePoint nécessite l'installation de Microsoft SharePoint Foundation 2010. L'appartenance aux groupes suivants est nécessaire pour installer chaque outil :

  • Load Testing Kit, manifeste d'Assistant Configuration de la sécurité, connecteur CMIS (Content Management Interoperability Services) : administrateur de la batterie et administrateur local

  • Moteur de réplication de profils utilisateur : administrateur local uniquement

    Remarque :
    L'outil Moteur de réplication de profils utilisateur est disponible uniquement par le biais d'applets de commande Windows PowerShell. Vérifiez que vous disposez de la configuration requise suivante : Voir Add-SPShellAdmin. Par ailleurs, sur un ordinateur Windows Server 2008, si le Contrôle de compte d'utilisateur est activé, vous devez élever l'autorisation de cet outil à Exécuter en tant qu'administrateur. Pour plus d'informations sur le Contrôle de compte d'utilisateur, voir Guide pas à pas du contrôle de compte d'utilisateur Windows.

    Le Moteur de réplication de profils utilisateur et le connecteur CMIS ne sont pas pris en charge par Microsoft SharePoint Foundation 2010.

Pour installer la Boîte à outils d'administration SharePoint 2010

  1. Dans la page Boîte à outils d'administration Microsoft SharePoint 2010 (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=196866&clcid=0x40C), téléchargez le fichier SharePoint2010AdministrationToolkit.exe en cliquant sur le bouton Télécharger, puis enregistrez le fichier sur votre disque dur.

  2. Double-cliquez sur le fichier de programme SharePoint2010AdministrationToolkit.exe sur votre disque dur pour démarrer le programme d'installation.

  3. Après avoir accepté les termes du contrat de licence logicielle Microsoft, cliquez sur Suivant.

  4. Sélectionnez les outils à installer en choisissant l'icône appropriée et sélectionnez le composant de niveau supérieur (« Ce composant sera installé en totalité sur le disque dur local »).

  5. Cliquez sur Parcourir pour modifier l'emplacement de ce dossier. Après avoir sélectionné un emplacement, cliquez sur OK, puis sur Suivant.

    L'emplacement de dossier par défaut est %ProgramFiles%\Microsoft\SharePoint 2010 Administration Toolkit.

  6. Pour achever l'installation, cliquez sur Terminer.

Voir aussi

Concepts

Désinstallation de la Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)

Historique des modifications

Date | Description | Raison
15 juillet 2010 | Publication initiale |


Désinstallation de la Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)

Cet article explique comment désinstaller toute la Boîte à outils d'administration SharePoint 2010 ou comment désinstaller un outil spécifique.

Pour désinstaller la Boîte à outils d'administration SharePoint 2010

  1. Dans Programmes et fonctionnalités, sélectionnez la Boîte à outils d'administration SharePoint 2010 et cliquez sur Désinstaller.

    Remarque :
    La même boîte de dialogue s'affiche si vous exécutez le fichier SharePoint2010AdministrationToolkit.exe au lieu de passer par Programmes et fonctionnalités.

  2. Cliquez sur Terminer.

Pour désinstaller un outil spécifique de la Boîte à outils d'administration SharePoint 2010

  1. Dans Programmes et fonctionnalités, sélectionnez la Boîte à outils d'administration SharePoint 2010 et cliquez sur Modifier.

    Remarque :
    La même boîte de dialogue s'affiche si vous exécutez le fichier SharePoint2010AdministrationToolkit.exe au lieu de passer par Programmes et fonctionnalités.

  2. Sélectionnez l'outil à supprimer.

  3. Cliquez sur Suivant, puis sur Terminer.

Historique des modifications

Date | Description | Raison
15 juillet 2010 | Publication initiale |


Manifeste de l'Assistant Configuration de la sécurité pour SharePoint Foundation 2010
Voir aussi

Cet article fournit des informations sur la façon d'inscrire le manifeste d'Assistant Configuration de la sécurité (SCW, Security Configuration Wizard) fourni avec la Boîte à outils d'administration de Microsoft SharePoint 2010. Le manifeste SCW ajoute des rôles pour Microsoft SharePoint Foundation 2010 à Windows Server 2008 Service Pack 2 ou à Windows Server 2008 R2.

Remarque :
Il s'agit de rôles spécifiques que vous créez dans l'Assistant Configuration de la sécurité après avoir installé le manifeste SCW de SharePoint Foundation, et non des rôles de serveurs permettant de configurer des fonctionnalités de Windows dans Server Manager.

L'Assistant Configuration de la sécurité est un outil de réduction de la surface d'attaque introduit dans Windows Server 2003 Service Pack 1. Il fait appel à une métaphore basée sur des rôles pour solliciter la fonctionnalité requise pour un serveur et désactive la fonctionnalité inutile. En automatisant cette meilleure pratique de sécurité, l'Assistant Configuration de la sécurité aide à créer des environnements Windows globalement moins susceptibles aux vulnérabilités de sécurité ayant été exploitées.

Pour plus d'informations sur l'Assistant Configuration de la sécurité dans Windows Server 2008, voir Assistant Configuration de la sécurité (http://go.microsoft.com/fwlink/?linkid=185511&clcid=0x40C).

Le manifeste SCW pour Microsoft SharePoint Foundation 2010 est fourni avec la Boîte à outils d'administration de SharePoint 2010. Différentes versions du manifeste sont fournies pour Windows Server 2008 Service Pack 2 et Windows Server 2008 R2.

Avant d'effectuer ces procédures, vérifiez que :

  • vous avez installé la Boîte à outils d'administration de SharePoint 2010 ;

  • vous exécutez Windows Server 2008 avec le Service Pack 2 ou Windows Server 2008 R2 ;

  • vous disposez d'une autorisation d'administration pour la fenêtre Invite de commandes.

Inscrire le manifeste SCW

Appliquez la procédure suivante pour inscrire le manifeste SCW.

Pour inscrire le manifeste SCW Microsoft SharePoint Foundation 2010

  1. Ouvrez une fenêtre Invite de commandes.

    Remarque :
    Si le Contrôle de compte d'utilisateur est activé dans Windows, vous serez peut-être invité à exécuter en tant qu'administrateur.

  2. À l'invite de commandes, tapez cd C:\Program Files\Microsoft\SharePoint 2010 Administration Toolkit\SCWManifests ou tapez l'emplacement où vous avez installé la Boîte à outils d'administration de SharePoint 2010.

  3. Inscrivez le manifeste SCW Microsoft SharePoint Foundation 2010 :

    • Si vous utilisez Windows Server 2008 Service Pack 2, tapez scwcmd register /kbname:SPF2010 /kbfile:SPF2010W2K8.xml et appuyez sur Entrée.

    • Si vous utilisez Windows Server 2008 R2, tapez scwcmd register /kbname:SPF2010 /kbfile:SPF2010W2K8R2.xml et appuyez sur Entrée.

Vous pouvez maintenant exécuter l'Assistant Configuration de la sécurité pour créer une stratégie de sécurité qui intègre les rôles pour SharePoint Foundation 2010.

Voir aussi

Concepts

Boîte à outils d'administration SharePoint 2010 (SharePoint Foundation 2010)

Autres ressources

Documentation de l'Assistant Configuration de la sécurité (éventuellement en anglais)

Historique des modifications

Date | Description | Raison
15 juillet 2010 | Publication initiale |


Load Testing Kit (SharePoint Foundation 2010)

Cet article fournit une vue d'ensemble et des procédures relatives au kit LTK (Load Testing Kit) de la Boîte à outils d'administration de Microsoft SharePoint 2010.

Vue d'ensemble

Le kit LTK permet à un administrateur de simuler un test de charge synthétique sur une batterie Microsoft SharePoint Foundation 2010. L'objectif de ce test consiste à aider l'administrateur à vérifier qu'une topologie Windows SharePoint Services 3.0 existante exécutée sur du matériel spécifique peut supporter une mise à niveau vers une batterie Microsoft SharePoint Foundation 2010 avec la même charge.

Le kit LTK est un outil en ligne de commande qui utilise des informations d'une batterie de production Windows SharePoint Services 3.0 en guise de données repères. L'exécution d'un test de charge nécessite trois étapes :

  1. Collecte des journaux.

  2. Préparation des données pour analyse.

  3. Utilisation du fichier de projet pour générer une charge synthétique..

Pour installer le kit LTK, vous devez être administrateur local sur un ordinateur x64. Les fichiers du kit LTK sont installés dans le dossier suivant : %ProgramFiles%\Microsoft\SharePoint 2010 Administration Toolkit\Load Testing Kit. Le kit LTK contient les fichiers suivants : Prerequisitecollector.exe, Prerequisitecollector.exe.config, Ltk.exe et Microsoft.Office.Server.AdministrationToolkit.LoadTestingKitIntl.dll. Ces fichiers doivent être copiés depuis le dossier d'installation vers un serveur quelconque de la batterie Windows SharePoint Services 3.0.

Pour utiliser l'outil, vous devez être membre du groupe SharePoint Administrateurs de batterie sur les batteries Windows SharePoint Services 3.0 (production d'origine) et SharePoint Foundation 2010 (mise à niveau). De plus, le fichier LTK.exe doit être exécuté sur un ordinateur où les produits SharePoint 2010 sont installés.

Collecte des journaux

La première étape consiste à recueillir tous les journaux des services Internet (IIS, Internet Information Services) sur l'ordinateur Windows SharePoint Services 3.0 et à déterminer le mappage application Web-à-ID. On exécute pour cela le fichier Prerequisitecollector.exe.

L'administrateur doit choisir un serveur dans la batterie assumant la fonction de serveur repère, puis installer le fichier Prerequisitecollector.exe sur ce serveur.

Remarque :
Le fichier Prerequisitecollector.exe doit être copié sur l'ordinateur physique dans la batterie Windows SharePoint Services 3.0, sinon un message d'erreur s'affiche.

Le fichier Prerequisitecollector.exe contient un paramètre, TargetFolder. Le paramètre TargetFolder spécifie l'emplacement de stockage des journaux IIS de Windows SharePoint Services 3.0.

L'outil Prerequisitecollector copiera tous les journaux IIS disponibles aux emplacements sources par défaut. Les tailles des fichiers journaux IIS pouvant être très conséquentes, nous vous conseillons de les vérifier au préalable et de planifier en conséquence. Si les tailles des journaux IIS sont trop importantes, vous pouvez les réduire à l'aide de LogParser.exe ou de tout autre outil comparable avant ou après leur copie.

En général, la durée nécessaire à la collecte d'un ensemble complet de journaux IIS est de 24 heures.

Préparation des données pour analyse

Une fois les journaux IIS capturés, utilisez l'application Load Testing Kit (Ltk.exe) pour préparer les données pour l'analyse.

Remarque :
Le produit Visual Studio Team System (VSTS) et Microsoft Visual Studio 2008 Service Pack 1 doivent être installés avant que Ltk.exe ne soit exécuté. De plus, une certaine connaissance de Visual Studio Team System (VSTS) est nécessaire. Pour installer VSTS, voir Visual Studio Team System 2008 Team Suite (http://go.microsoft.com/fwlink/?linkid=101641&clcid=0x40C).

Pour installer le Service Pack 1, voir Microsoft Visual Studio 2008 Service Pack 1 (http://go.microsoft.com/fwlink/?linkid=116488&clcid=0x40C).

Le fichier Ltk.exe génère un fichier de projet VSTS qui contient des fichiers de paramètres de tests Web (*.WebTest) et des fichiers de valeurs séparées par des virgules (*.csv) par défaut.

Pour analyser les fichiers journaux, tapez la syntaxe suivante :

ltk.exe -source LTKSource -output VSSolution -userlist users.csv

Syntaxe de Ltk.exe

ltk.exe -source <répertoire_source>

-output <répertoire_sortie>

-userlist <fichier_liste_utilisateurs>

[-userrolefixup]

[-debugmatchrules <règle1;règle2;règle3>]

Paramètres

Nom du paramètre | Valeur | Obligatoire ? | Description
source | Répertoire valide, par exemple IISLogs | Oui | Spécifie le dossier contenant les fichiers journaux IIS qui ont été recueillis à partir de l'ordinateur Office SharePoint Server 2007Windows SharePoint Services 3.0 à l'aide du fichier Prerequisitecollector.exe.
output | Répertoire valide, par exemple VSSolution | Oui | Spécifie le dossier du fichier de sortie Load Testing Kit, qui est un fichier de projet contenant tous les fichiers Visual Studio et .csv.
userlist | Emplacement valide où est stocké le fichier .csv, par exemple C:\users.csv | Oui | Spécifie un fichier .csv qui comporte au moins trois colonnes : Username, Password et Permission. Ce fichier .csv répertorie tous les utilisateurs que vous avez créés dans le domaine test et les autorisations qu'ils sont supposés représenter. Il doit y avoir au moins un utilisateur par autorisation. Les valeurs d'autorisation valides sont FullRead et FullControlWithoutAdmin.
userrolefixup | <aucune> | Non | Accorde les autorisations spécifiées dans le paramètre userlist en ajoutant les utilisateurs à la stratégie d'autorisation de l'application Web cible.
debugmatchrules | Règle valide utilisée pour interroger les fichiers journaux. | Non | Génère un journal détaillé qui mappe les entrées de journaux IIS correspondant à chaque règle. Ces règles de correspondance sont contenues dans la section MatchRules du fichier WebTestsConfiguration.xml qui se trouve dans le répertoire %ProgramFiles%\Microsoft\SharePoint 2010 Administration Toolkit\Load Testing Kit. Ce paramètre est destiné uniquement à des fins de débogage avancé.

Par exemple, pour utiliser le paramètre userlist pour ajouter un nom d'utilisateur « testacct » avec l'autorisation FullControlWithoutAdmin, utilisez les valeurs suivantes :

Nom d'utilisateur | Mot de passe | Autorisation
Domaine\testacct | Mot de passe | FullControlWithoutAdmin

Par exemple, pour utiliser le paramètre userlist pour ajouter un nom d'utilisateur « testacct » avec l'autorisation FullRead, utilisez les valeurs suivantes :

Nom d'utilisateur | Mot de passe | Autorisation
Domaine\testacct | Mot de passe | FullRead

Utilisation du fichier de projet pour générer une charge synthétique.

Une fois le fichier de projet généré, l'étape finale consiste à utiliser VSTS pour ouvrir et utiliser ce fichier de projet. Pour plus d'informations sur la façon d'utiliser un fichier de projet VSTS, voir Procédures pas à pas relatives aux tests de charge et aux tests de performances de site Web (http://go.microsoft.com/fwlink/?linkid=196791&clcid=0x40C).

Historique des modifications

Date | Description | Raison
15 juillet 2010 | Publication initiale |


Déclaration de conformité de niveau A (SharePoint Foundation 2010)

Déclaration de conformité pour Microsoft SharePoint Foundation 2010 concernant les Directives d'accessibilité du contenu Web 2.0 (éventuellement en anglais) (http://www.w3.org/TR/WCAG20/).

Déclaration de conformité pour l'expérience de configuration et d'administration au niveau A

Déclaration | Détails
Date de la déclaration | 12 mai 2010
Titre, version et URI des directives | Directives d'accessibilité du contenu Web 2.0 (éventuellement en anglais) (http://www.w3.org/TR/2008/REC-WCAG20-20081211/)
Niveau de conformité satisfait : (Niveau A, AA ou AAA) | A
Une description précise des pages Web, par exemple une liste d'URI pour lesquelles la revendication est effectuée, y compris l'inclusion ou non des sous-domaines dans la revendication. | Contenu par défaut fourni avec SharePoint Foundation 2010 et fonctionnalités d'administration et de configuration de SharePoint Foundation 2010. Pour d'autres fonctionnalités de produit, voir Déclaration de conformité de niveau AA (SharePoint Foundation 2010).
Une liste des technologies de contenu Web requises. | HTML JavaScript CSS
Technologies de contenu Web supplémentaires, mais non requises. | ARIA Silverlight RSS PNG GIF JPEG
Une liste de critères de réussite au-delà du niveau de conformité revendiqué qui ont été satisfaits. Ces informations doivent être fournies dans un format utilisable par les utilisateurs, de préférence sous la forme de métadonnées lisibles par ordinateur. | Conforme à 1.4.9 Images de texte (sans exception) - AAA. Conforme à 2.1.3 Clavier (sans exception) - AAA. Conforme à 2.2.3 Aucun minutage (sans exception) - AAA. Conforme à 2.3.2 Trois clignotements - AAA. Conforme à 2.4.8 Emplacement - AAA. Conforme à 3.3.6 Prévention des erreurs (Toutes) - AAA.

Cette déclaration de conformité concerne SharePoint Foundation 2010.

La personnalisation du produit entraîne l'invalidation de cette déclaration de conformité fournie par Microsoft. Les clients peuvent établir des déclarations de conformité indépendantes s'ils ont fait en sorte de satisfaire toutes les exigences pertinentes à leur personnalisation.

Veuilles contacter les fournisseurs AT (Assistive Technology) pour connaître les spécifications de compatibilité de produits AT spécifiques. Les produits AT compatibles avec toutes les technologies requises sont supposés être opérationnels avec le produit.

Ce document est fourni uniquement à titre d'information. MICROSOFT N'OFFRE AUCUNE GARANTIE, EXPLICITE OU IMPLICITE, DANS CE DOCUMENT.

Date de révision : 22/07/2010.

Microsoft met régulièrement à jour ses sites Web et fournit de nouvelles informations concernant l'accessibilité des produits à mesure que ces informations sont disponibles.

Historique des modifications

Date | Description | Raison
22 juillet 2010 | Publication initiale |


Déclaration de conformité de niveau AA (SharePoint Foundation 2010)

Déclaration de conformité pour Microsoft SharePoint Foundation 2010 concernant les Directives d'accessibilité du contenu Web 2.0 (éventuellement en anglais) (http://www.w3.org/TR/WCAG20/).

Déclaration de conformité pour l'expérience de lecteur principal, d'auteur et de collaborateur au niveau AA

Déclaration | Détails
Date de la déclaration | 12 mai 2010
Titre, version et URI des directives | Directives d'accessibilité du contenu Web 2.0 (éventuellement en anglais) (http://www.w3.org/TR/2008/REC-WCAG20-20081211/)
Niveau de conformité satisfait : (Niveau A, AA ou AAA) | AA
Une description précise des pages Web, par exemple une liste d'URI pour lesquelles la revendication est effectuée, y compris l'inclusion ou non des sous-domaines dans la revendication. | Tout le contenu par défaut fourni avec SharePoint Foundation 2010 et les fonctionnalités d'applications Web de SharePoint Foundation 2010, hormis en cas de limitation par la Déclaration de conformité de niveau A (SharePoint Foundation 2010).
Une liste des technologies de contenu Web requises. | HTML JavaScript CSS
Technologies de contenu Web supplémentaires, mais non requises. | ARIA Silverlight RSS PNG GIF JPEG
Une liste de critères de réussite au-delà du niveau de conformité revendiqué qui ont été satisfaits. Ces informations doivent être fournies dans un format utilisable par les utilisateurs, de préférence sous la forme de métadonnées lisibles par ordinateur. | Conforme à 1.4.9 Images de texte (sans exception) - AAA. Conforme à 2.1.3 Clavier (sans exception) - AAA. Conforme à 2.2.3 Aucun minutage (sans exception) - AAA. Conforme à 2.3.2 Trois clignotements - AAA. Conforme à 2.4.8 Emplacement - AAA. Conforme à 3.3.6 Prévention des erreurs (Toutes) - AAA.

Cette déclaration de conformité concerne SharePoint Foundation 2010.

La personnalisation du produit entraîne l'invalidation de cette déclaration de conformité fournie par Microsoft. Les clients peuvent établir des déclarations de conformité indépendantes s'ils ont fait en sorte de satisfaire toutes les exigences pertinentes à leur personnalisation.

Veuilles contacter les fournisseurs AT (Assistive Technology) pour connaître les spécifications de compatibilité de produits AT spécifiques. Les produits AT compatibles avec toutes les technologies requises sont supposés être opérationnels avec le produit.

Ce document est fourni uniquement à titre d'information. MICROSOFT N'OFFRE AUCUNE GARANTIE, EXPLICITE OU IMPLICITE, DANS CE DOCUMENT.

Date de révision : 22/07/2010.

Microsoft met régulièrement à jour ses sites Web et fournit de nouvelles informations concernant l'accessibilité des produits à mesure que ces informations sont disponibles.

Historique des modifications

Date | Description | Raison
22 juillet 2010 | Publication initiale |


Paramètres et fonctionnalités sauvegardés depuis une configuration de batterie (SharePoint Foundation 2010)
Voir aussi

Cet article décrit les paramètres et fonctionnalités inclus dans une sauvegarde de configuration de batterie de serveurs. Pour plus d'informations sur la façon de sauvegarder une configuration de batterie, voir Sauvegarder la configuration d'une batterie de serveurs (SharePoint Foundation 2010).

Paramètres et fonctionnalités sauvegardés

Le tableau suivant répertorie les paramètres et fonctionnalités inclus dans une sauvegarde de la configuration d'une batterie de serveurs et les pages du site Web Administration centrale de SharePoint où vous pouvez accéder à ces paramètres et fonctionnalités.

Paramètre ou fonctionnalité Description

Paramètres de mots de passe de comptes gérés

_Admin/PasswordSettings.aspx

Paramètres de courrier électronique sortant

_Admin/globalemailconfig.aspx

Remarque :
Les paramètres de courrier sortant sont restaurés uniquement lorsque le contenu et les paramètres sont restaurés à leurs emplacements d'origine dans la même batterie que celle à partir de laquelle ils ont été sauvegardés.

  • Lorsque vous utilisez l'Administration centrale pour restaurer une batterie, dans la page Restaurer à partir d'une sauvegarde - Étape 3 sur 3 : sélectionner les options de restauration, dans la section Options de restauration, sélectionnez l'option Type de restauration et utilisez le paramètre Configuration existante setting.

  • Lorsque vous utilisez l'applet de commande Windows PowerShell Restore-SPFarm pour restaurer une batterie, utilisez le paramètre RestoreMethod pour spécifier overwrite.

Remarque :
Les paramètres de courrier sortant sont restaurés uniquement lorsque le contenu et les paramètres sont restaurés à leur emplacement de serveur d'origine dans la même batterie. Si vous restaurez la configuration et le contenu dans une autre batterie, vous êtes invité à spécifier de nouveaux paramètres de configuration.

Solutions déployées dans la batterie (solutions approuvées)

_Admin/Solutions.aspx

Solutions qui sont déployées dans la batterie.

InfoPath Forms Services

_Admin/IpfsConfig.aspx

Liste des agents utilisateurs ajoutés à une batterie.

Service d'application Web

Paramètres partagés par toutes les applications Web de contenu.

  • Paramètres de mode création de compte AD DS (Active Directory Domain Services)

  • Paramètres antivirus _Admin/AVAdmin.aspx

  • Modèles de quotas

  • Paramètres de Gestion des droits relatifs à l'information (IRM) _Admin/IrmAdmin.aspx

  • Chemins d'accès gérés pour les collections de sites nommées par l'hôte

Service de solution bac à sable (sandbox)

Paramètres d'équilibrage de la charge et restrictions de solutions.

Paramètres de journalisation des diagnostics

_Admin/Metrics.aspx

Tous les paramètres de journalisation des diagnostics sont sauvegardés, à l'exception de l'emplacement du journal de suivi.

Voir aussi

Référence

Restore-SPFarm

Concepts

Restaurer la configuration d'une batterie de serveurs (SharePoint Foundation 2010)
Modifier les mots de passe utilisés pour les comptes d'administration (SharePoint Foundation 2010)
Configurer le courrier électronique sortant (SharePoint Foundation 2010)
Créer, modifier et supprimer des modèles de quota (SharePoint Foundation 2010)
Définir des chemins d'accès gérés (SharePoint Foundation 2010)
Configurer l'équilibrage de charge pour les solutions bac à sable (sandbox) (SharePoint Foundation 2010)
Bloquer ou débloquer une solution en mode bac à sable (SharePoint Foundation 2010)
Configurer la journalisation des diagnostics (SharePoint Foundation 2010)

Autres ressources

Get-SPInfoPathUserAgent

Historique des modifications

Date | Description | Raison
12 août 2010 | Publication initiale |


Peoplepicker-peopleeditoronlyresolvewithinsitecollection: Stsadm property (SharePoint Foundation 2010) (en anglais)

Checks the user against the existing site collection users.

Remarque :
This operation was added in Microsoft SharePoint Foundation 2010.

Syntax

The syntax for the setproperty operation is:

stsadm -o setproperty

-propertyname peoplepicker-peopleeditoronlyresolvewithinsitecollection

-propertyvalue {Yes | No}

[-url] <URL>

The syntax for the getproperty operation is:

stsadm -o getproperty

propertyname peoplepicker-peopleeditoronlyresolvewithinsitecollection

[-url] <URL>

Remarque :
You can substitute -pn for -propertyname and -pv for -propertyvalue.

Parameters

Name | Value
propertyname | Gets or sets the name of the property.
propertyvalue | Yes: Resolves only against the existing site collection users. No: Resolves users against the existing site collection users and users from other identity providers, for example, Active Directory Domain Services.
url | Typically a path to the URL of the Web application, in the form http://server_name.

Examples

Display users within a site collection

If you want to display users only from a specific site collection, use the following syntax:

stsadm -o setproperty -url http://<server> -pn peoplepicker- peoplepicker-peopleeditoronlyresolvewithinsitecollection -pv yes

If you want to display any user from an existing site collection, use the following syntax:

stsadm -o setproperty -url http://<server_name> -pn peoplepicker- peopleeditoronlyresolvewithinsitecollection -pv no

To view the current setting for the peopleeditoronlyresolvewithinsitecollection property, use the following syntax:

stsadm -o getproperty -pn peoplepicker- peopleeditoronlyresolvewithinsitecollection

Historique des modifications

Date | Description | Raison
2011/01/31 | Publication initiale |


D sf
Voir aussi

2/16/2011

Scope | Token
project | Microsoft SharePoint Foundation 2010
database | Microsoft SharePoint Foundation 2010

Voir aussi

Autres ressources

D misc
D ss
D ps
D srch
D or
D gr


Configurer le service Banque d'informations sécurisé (SharePoint Foundation 2010)

Cet article décrit les opérations du service Banque d'informations sécurisé Microsoft SharePoint Foundation 2010 qui permettent aux concepteurs de solutions de créer des applications cibles qui mappent les informations d'identification d'utilisateurs et de groupes aux informations d'identification de sources de données externes. À l'aide de ces applications cibles, des types de contenus externes du service Connexion de données métiers peuvent interagir avec leurs sources de données externes pour lire, écrire et modifier des données qui y sont stockées. Pour une présentation du service Banque d'informations sécurisé, voir Planifier le service Banque d'informations sécurisé (SharePoint Foundation 2010).

Avant d'utiliser le service Banque d'informations sécurisé pour créer des applications cibles, vous devez lui fournir un mot de passe. Ce mot de passe est utilisé pour générer une clé qui est utilisée pour chiffrer et déchiffrer les informations d'identification stockées dans la base de données du service Banque d'informations sécurisé. Si vous devez fournir le mot de passe initial, le message suivant apparaît lorsque vous ouvrez une instance d'application du service Banque d'informations sécurisé : Générez une nouvelle clé pour cette application du service Banque d'informations sécurisé.

Dans cet article :

  • Initialisation d'une instance d'application du service Banque d'informations sécurisé

  • Actualisation de la clé de chiffrement

  • Génération d'une nouvelle clé de chiffrement

  • Création d'une application cible

  • Définition d'informations d'identification pour une application cible

Initialisation d'une instance d'application du service Banque d'informations sécurisé

Vous pouvez utiliser les commandes du groupe Modifier du Ruban pour initialiser une instance d'une application du service Banque d'informations sécurisé.

Pour initialiser une instance d'application du service Banque d'informations sécurisé

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur d'application de service pour l'instance du service Banque d'informations sécurisé.

  2. Dans une instance d'une application du service Banque d'informations sécurisé, cliquez sur l'onglet Modifier.

  3. Dans le groupe Gestion de clé, cliquez sur Générer la nouvelle clé.

  4. Sur la page Générer la nouvelle clé, entrez un mot de passe dans la zone Mot de passe, et entrez la même chaîne dans la zone Confirmez le mot de passe.

    Important :
    Un mot de passe doit comporter au moins huit caractères et avoir au moins trois des quatre éléments suivants :

    • des caractères majuscules

    • des caractères minuscules

    • des chiffres

    • un des caractères spéciaux suivants

      "! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~

    Conseil :
    Le mot de passe que vous entrez ne sera pas stocké. Assurez-vous de l'écrire et de le stocker dans un endroit sûr. Vous devrez actualiser la clé, par exemple si vous ajoutez un nouveau serveur d'applications à la batterie de serveurs.

  5. Cliquez sur OK.

Il peut être nécessaire d'actualiser la clé de chiffrement si :

  • vous ajoutez un nouveau serveur d'applications à la batterie de serveurs ;

  • vous restaurez une base de données du service Banque d'informations sécurisé précédemment sauvegardée et que vous avez entretemps changé la clé de chiffrement ;

  • vous recevez un message d'erreur indiquant qu'il est impossible d'obtenir la clé principale.

Actualisation de la clé de chiffrement

Vous pouvez utiliser les commandes du groupe Gestion des clés du Ruban pour actualiser la clé de chiffrement.

Pour actualiser la clé de chiffrement

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur d'application de service pour l'instance du service Banque d'informations sécurisé.

  2. Dans une instance d'une application du service Banque d'informations sécurisé, cliquez sur l'onglet Modifier.

  3. Dans le groupe Gestion de clé, cliquez sur Actualiser la clé.

  4. Dans la zone Mot de passe, entrez le mot de passe que vous avez utilisé initialement pour générer la clé de chiffrement.

    Il s'agit du mot de passe que vous avez utilisé lors de l'initialisation de l'application du service Banque d'informations sécurisé ou bien de celui que vous avez utilisé lors de la création d'une nouvelle clé à l'aide de la commande Générer la nouvelle clé.

  5. Cliquez sur OK.

Génération d'une nouvelle clé de chiffrement

À titre de précaution de sécurité ou dans le cadre de la maintenance normale, vous pouvez décider de générer une nouvelle clé de chiffrement et éventuellement de forcer un nouveau chiffrement du service Banque d'informations sécurisé sur la base de la nouvelle clé.

Attention :
Vous devez sauvegarder la base de données de l'application du service Banque d'informations sécurisé avant de générer une nouvelle clé.

Pour générer une nouvelle clé de chiffrement

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur d'application de service pour l'instance du service Banque d'informations sécurisé.

  2. Dans une instance d'une application du service Banque d'informations sécurisé, cliquez sur l'onglet Modifier.

  3. Dans le groupe Gestion de clé, cliquez sur Générer la nouvelle clé.

  4. Sur la page Générer la nouvelle clé, entrez un mot de passe dans la zone Mot de passe, et entrez la même chaîne dans la zone Confirmez le mot de passe.

    Important :
    Un mot de passe doit comporter au moins huit caractères et avoir au moins trois des quatre éléments suivants :

    • des caractères majuscules

    • des caractères minuscules

    • des chiffres

    • un des caractères spéciaux suivants

      "! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~

    Conseil :
    Le mot de passe que vous entrez ne sera pas stocké. Assurez-vous de l'écrire et de le stocker dans un endroit sûr. Vous devrez actualiser la clé, par exemple si vous ajoutez un nouveau serveur d'applications à la batterie de serveurs.

  5. Pour forcer le rechiffrement de la base de données du service Banque d'informations sécurisé, cliquez sur Rechiffrer la base de données avec la nouvelle clé de chiffrement.

  6. Cliquez sur OK.

Création d'une application cible

Vous utilisez le service Banque d'informations sécurisé pour créer des applications cibles. Une application cible mappe les informations d'identification d'un utilisateur, d'un groupe ou d'une revendication à un ensemble d'informations d'identification sur une source de données externe, telle qu'une base de données SQL Server ou un service Web. Après avoir créé une application cible, vous pouvez l'associer à un type de contenu ou un modèle d'application externe pour fournir un accès à une source de données externe.

Pour créer une application cible

  1. Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur d'application de service pour l'instance du service Banque d'informations sécurisé.

  2. Dans une instance d'une application du service Banque d'informations sécurisé, cliquez sur l'onglet Modifier.

  3. Dans la page Gérer les applications cibles, cliquez sur Nouveau.

  4. Dans la zone ID de l'application cible , entrez une chaîne de texte.

    Il s'agit de la chaîne unique qui sera utilisée en interne par le service Banque d'informations sécurisé pour identifier cette application cible.

  5. Dans la zone Nom complet, entrez une chaîne de texte qui sera utilisée pour afficher l'identificateur de l'application cible dans l'interface utilisateur.

  6. Dans la zone Adresse de messagerie du contact, entrez l'adresse de messagerie du contact principal pour cette application cible.

    Il peut s'agir de toute adresse de messagerie valide et il n'est pas nécessaire que ce soit l'identité d'un administrateur de l'application du service Banque d'informations sécurisé.

  7. Lorsque vous créez une application cible de type Individuel (voir plus loin), vous pouvez implémenter une page Web personnalisée qui permet aux utilisateurs d'ajouter des informations d'identification individuelles pour la source de données de destination. Ceci requiert du code personnalisé pour passer les informations d'identification à l'application cible. Si vous avez procédé ainsi, entrez l'URL complète de cette page dans le champ URL de la page de l'application cible. Il existe trois options :

    • Utiliser la page fournie : tout site Web utilisant l'application cible pour accéder à des données externes se voit ajouter automatiquement une page d'inscription individuelle. L'URL de cette page est http:/<exemple_site>/_layouts/SecureStoreSetCredentials.aspx?TargetAppId=<ID_application_cible>, où <ID_application_cible> est la chaîne entrée dans la zone ID de l'application cible. En rendant public l'emplacement de cette page, vous pouvez permettre aux utilisateurs d'entrer leurs informations d'identification pour la source de données externe.

    • Utiliser une page personnalisée : vous fournissez une page Web personnalisée qui permet aux utilisateurs d'indiquer des informations d'identification individuelles. Tapez l'URL de la page personnalisée dans ce champ.

    • Aucune : il n'existe pas de page d'inscription. Les informations d'identification individuelles sont ajoutées uniquement par un administrateur du service Banque d'informations sécurisé à l'aide de l'application du service Banque d'informations sécurisé.

  8. Dans la zone Type d'application cible, entrez le type d'application cible : Groupe pour des informations d'identification de groupe, ou Individuel si chaque personne doit être mappée à un ensemble unique d'informations d'identification sur la source de données externe.

    Remarque :
    Il existe deux types principaux pour la création d'une application cible :

    • Groupe, pour le mappage de tous les membres d'un ou plusieurs groupes à un même ensemble d'informations d'identification sur la source de données externe.

    • Individuel, pour le mappage de chaque personne à un ensemble unique d'informations d'identification sur la source de données externe.

  9. Si les informations d'identification sur la source de données externe sont des informations d'identification Windows, activez la case à cocher Windows.

    Désactivez la case à cocher si les informations d'identification sur la source de données externe ne sont pas des informations d'identification Windows.

  10. Cliquez sur Suivant pour configurer les champs à utiliser pour envoyer les informations d'identification à la source de données externe.

  11. Utilisez la page Spécifiez les champs des informations d'identification pour votre application cible de la banque sécurisée pour configurer les différents champs qui peuvent être nécessaires pour fournir des informations d'identification à la source de données externe. Deux champs figurent par défaut dans la liste : Nom d'utilisateur et Mot de passe.

  12. Utilisez la page Spécifiez les champs des informations d'identification pour votre application cible de la banque sécurisée pour configurer les différents champs qui peuvent être nécessaires pour fournir des informations d'identification à la source de données externe. Deux champs figurent par défaut dans la liste : Nom d'utilisateur et Mot de passe.

    Pour ajouter un champ supplémentaire pour fournir des informations d'identification à la source de données externe, dans la page Spécifiez les champs des informations d'identification pour votre application cible de la banque sécurisée, cliquez sur Ajouter un champ.

    Par défaut, le type du nouveau champ est Générique. Les types de champs suivants sont disponibles :

    Champ Description

    Générique

    Des valeurs qui ne correspondent à aucune des autres catégories.

    Nom de l'utilisateur

    Un compte d'utilisateur qui identifie l'utilisateur.

    Mot de passe

    Un mot ou une phrase secrète.

    Code confidentiel

    Un numéro d'identification personnel.

    Clé

    Un paramètre qui détermine la sortie fonctionnelle d'un algorithme de chiffrement.

    Nom d'utilisateur Windows

    Un compte d'utilisateur Windows qui identifie l'utilisateur.

    Mot de passe Windows

    Un mot ou une phrase secrète pour un compte Windows.

    • Pour modifier le type d'un champ nouveau ou existant, cliquez sur la flèche qui apparaît à côté du type du champ, puis sélectionnez son nouveau type.

      Remarque :
      Chaque champ que vous ajoutez doit contenir des données lorsqu'il est envoyé pour définir les informations d'identification.

    • Vous pouvez modifier le nom qu'un utilisateur voit lorsqu'il interagit avec un champ. Dans la colonne Nom du champ de la page Spécifiez les champs des informations d'identification pour votre application cible de la banque sécurisée, modifiez un nom de champ en sélectionnant le texte actuel puis en entrant le nouveau texte.

    • Lorsqu'un champ est masqué, les caractères entrés par un utilisateur ne sont pas affichés : ils sont remplacés par un caractère de masque, tel que l'astérisque (« * »). Pour masquer un champ, cliquez sur la case à cocher pour ce champ dans la colonne Masqué de la page.

    • Pour supprimer un champ, cliquez sur l'icône de suppression pour ce champ dans la colonne Supprimer de la page.

    Lorsque vous avez terminé les modifications à apporter aux champs des informations d'identification, cliquez sur Suivant.

  13. Dans la page Spécifier les paramètres d'appartenance, dans le champ Administrateurs de l'application cible, indiquez la liste de tous les utilisateurs qui disposent d'un accès pour gérer les paramètres de l'application cible.

  14. Si le type de l'application cible est Groupe, dans le champ Membres, spécifiez la liste des groupes d'utilisateurs à mapper à un ensemble d'informations d'identification pour cette application cible.

  15. Cliquez sur OK pour terminer la configuration de l'application cible.

Définition d'informations d'identification pour une application cible

Après la création d'une application cible, un administrateur de cette application cible peut définir des informations d'identification pour celle-ci. Ces informations d'identification seront utilisées par les Services Microsoft Business Connectivity et par d'autres services pour fournir un accès à une source de données externe. Si l'application cible est de type Individuel, vous pouvez si vous le souhaitez permettre à des personnes individuelles de fournir leurs propres informations d'identification.

Pour définir des informations d'identification pour une application cible

  • Vérifiez que vous disposez des informations d'identification administratives suivantes :

    • Vous devez être administrateur d'application de service pour l'instance du service Banque d'informations sécurisé.

  • Dans une instance d'application du service Banque d'informations sécurisé, pointez sur l'identificateur de l'application cible, cliquez sur la flèche qui apparaît puis, dans le menu, cliquez sur Définir les informations d'identification.

    Si l'application cible est du type Groupe, entrez les informations d'identification pour la source de données externe. Les champs pour définir les informations d'identification varient en fonction des informations requises par la source de données externe.

    Si l'application cible est du type Individuel, entrez le nom d'utilisateur de la personne individuelle qui sera mappé à un ensemble d'informations d'identification sur la source de données externe, puis entrez les informations d'identification pour la source de données externe. Les champs pour définir les informations d'identification varient en fonction des informations requises par la source de données externe.


Move-SPBlobStorageLocation
Exemple
[image]

Copie une base de données Windows SharePoint Services 3.0 en utilisant le stockage BLOB.

Move-SPBlobStorageLocation [-SourceDatabase] <String> [-AssignmentCollection <SPAssignmentCollection>] [-BackupDatabase <String>] [-BackupFileName <String>] [-Confirm [<SwitchParameter>]] [-DebugMod <$true | $false>] [-DestDatabaseFilesBaseName <String>] [-DestinationDatabase <String>] [-DestinationDataSourceInstance <String>] [-Dir <String>] [-MasterPassword <String>] [-VerboseMod <$true | $false>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

SourceDatabase

Requis

System.String

Spécifie le nom de la base de données interne Windows.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

BackupDatabase

Facultatif

System.String

Spécifie le nom de la base de données à utiliser temporairement pendant ce processus. La base de données source au nom temporaire est copiée dans la base de données interne Windows. Si le paramètre BackupDatabase n'est pas spécifié, un nom est généré à partir du nom de la base de données source et un GUID aléatoire est créé.

BackupFileName

Facultatif

System.String

Spécifie le nom du fichier de sauvegarde qui permettra de faire une copie de la base de données d'origine. Si le paramètre BackupFileName n'est pas spécifié, un nom de fichier est généré à partir du nom de la base de données source et un GUID aléatoire est créé.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

DestDatabaseFilesBaseName

Facultatif

System.String

Spécifie le nom de base à utiliser pour générer des noms de fichiers pour la base de données de destination (à savoir des fichiers *.mdf ou *.ldf). Si le paramètre DestDatabaseFilesBaseName n'est pas spécifié, le nom spécifié dans le paramètre DestinationDatabase est utilisé pour créer une valeur.

DestinationDatabase

Facultatif

System.String

Spécifie le nom de la base de données migrée. Si le paramètre DestinationDatabase n'est pas spécifié, le paramètre SourceDatabase est utilisé.

DestinationDataSourceInstance

Facultatif

System.String

Spécifie le nom de l'instance de la base de données de destination. La valeur du paramètre SourceDatabase est migrée vers cette instance. Le nom de l'instance de base de données devrait être la version SQL Server 2008 avec SP1 et mise à jour cumulative 2 ou une version supérieure. Si le paramètre DestinationDataSourceInstance n'est pas spécifié, le nom de l'hôte local est utilisé.

Dir

Facultatif

System.String

Utilisé pour toutes les opérations de disque, y compris le stockage de sauvegardes temporaires et des fichiers de base de données (.mdf) d'une base de données migrée. Si le paramètre Dir n'est pas spécifié, un répertoire par défaut de l'instance SQL Server de destination est utilisé. L'espace libre dans ce répertoire doit représenter au moins deux fois la taille de la base de données source.

MasterPassword

Facultatif

System.String

Spécifie le mot de passe principal de l'instance de la base de données de destination pour l'installation du stockage BLOB. Si le mot de passe principal n'existe pas, la valeur spécifiée est utilisée pour créer un mot de passe principal. Si le paramètre MasterPassword n'est pas spécifié, une valeur aléatoire est utilisée.

VerboseMod

Facultatif

System.Boolean

Génère la sortie de journal en clair à afficher dans la fenêtre d'invite de commandes. Si le paramètre VerboseMod n'est pas spécifié, aucune sortie n'est affichée.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

Utilisez l'applet de commande Move-SPBlobStorageLocation pour copier une base de données Windows SharePoint Services 3.0 dans une instance de base de données SQL Server 2008 avec SP1 et mise à jour cumulative 2 en utilisant le stockage BLOB. La limite de taille de la base de données de Microsoft SQL Server 2008 avec le Service Pack 1 (SP1) et mise à jour cumulative 2 est de 4 gigaoctets (Go). Si une base de données Windows SharePoint Services 3.0 présente une taille supérieure à 4 Go, elle ne peut être copiée directement dans une instance de base de données Microsoft SQL Server 2008 avec le Service Pack 1 (SP1) et mise à jour cumulative 2. L'applet de commande Move-SPBlobStorageLocation utilise le stockage BLOB et copie les bases de données d'une taille supérieure à 4 Go. Le stockage BLOB permet de stocker les données sur le disque dur local et de conserver les liens vers les données de la base de données, ce qui permet de limiter la taille de cette dernière.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE 1-----------------------
Code de copie
Move-SPBlobStorageLocation WSS_Content

Cet exemple copie la base de données de contenu appelée WSS_Content de la base de données interne Windows vers le même nom de base de données dans Microsoft SQL Server 2008 Express en utilisant le stockage BLOB.

------------------EXEMPLE 2-----------------------
Code de copie
Move-SPBlobStorageLocation WSS_Content -DestinationDatabase WSS_V4_Content -BackupDatabase WSSBackupDB -VerboseMod:$true

Cet exemple copie la base de données de contenu appelée WSS_Content de la base de données interne Windows vers une base de données dans SQL Server 2008 Express. Le nom de la nouvelle base de données sera WSS_V4_Content. Pendant le transfert, le nom du fichier de sauvegarde sera WSSBackupDB. Le résultat de cette commande affiche des informations du journal dans la fenêtre d'invite de commandes.

Historique des modifications


Set-SPCustomLayoutsPage
Voir aussi Exemple
[image]

Mappe un nouveau chemin d'accès pour une page de disposition personnalisée.

Set-SPCustomLayoutsPage -Identity <None | AccessDenied | Confirmation | Error | Login | RequestAccess | Signout | WebDeleted> -RelativePath <String> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Set-SPCustomLayoutsPage -Identity <None | AccessDenied | Confirmation | Error | Login | RequestAccess | Signout | WebDeleted> -Reset <SwitchParameter> -WebApplication <SPWebApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.Administration.SPWebApplication+SPCustomPage

Spécifie la page de disposition personnalisée à définir.

Le type doit être l'un des suivants : None, AccessDenied, Confirmation, Error, Login, RequestAccess, Signout ou WebDeleted.

RelativePath

Requis

System.String

Spécifie le chemin d'accès de la page de disposition personnalisée.

Le type doit être un chemin d'accès de page de disposition valide au format _layouts/custompages/myaccessdenied.aspx.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web SharePoint qui contient la page de disposition personnalisée.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

Identity

Requis

Microsoft.SharePoint.Administration.SPWebApplication+SPCustomPage

Spécifie la page de disposition personnalisée à définir.

Le type doit être l'un des suivants : None, AccessDenied, Confirmation, Error, Login, RequestAccess, Signout ou WebDeleted.

Reset

Requis

System.Management.Automation.SwitchParameter

Réinitialise le mappage d'une page de disposition personnalisée.

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web SharePoint qui contient la page de disposition personnalisée.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeApp1), ou une instance d'un objet SPWebApplication valide.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Set-SPCustomLayoutsPage mappe un nouveau chemin d'accès pour une page de dispositions personnalisées dans une application Web. Pour supprimer le mappage d'une page de dispositions personnalisées, utilisez le paramètre Reset au lieu du paramètre RelativePath.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Set-SPCustomLayoutsPage -Identity "_layouts/accessdenied.aspx" -RelativePath "/_layouts/custompages/myaccessdenied.aspx" -WebApplication "http://server_name/mywebapp"

Cet exemple mappe le chemin d'accès spécifié pour la page de disposition AccessDenied dans l'application Web"http://server_name/mywebapp".

Voir aussi

Référence

Get-SPCustomLayoutsPage

Historique des modifications


(Obsolète) Afficher des rapports Web Analytics (SharePoint Foundation 2010)

Cet article est obsolète depuis le 23 mars 2010.


Planifier l'authentification par revendications (SharePoint Foundation 2010)

L'authentification par revendications pour Microsoft SharePoint Foundation 2010 repose sur Windows Identity Foundation. La structure Windows Identity Foundation est un ensemble de classes .NET Framework qui permettent d'implémenter une identité basée sur des revendications. Pour plus d'informations, voir Nom de code Microsoft « Geneva » (éventuellement en anglais) (http://go.microsoft.com/fwlink/?linkid=153922&clcid=0x40C).

Dans cet article :

  • À propos de l'authentification par revendications

  • Service d'émission de jeton de sécurité

  • Service d'émission de jeton de sécurité de fournisseur d'identités

  • Service d'émission de jeton de sécurité de partie de confiance

  • Authentification par revendications dans le cas d'une seule batterie de serveurs SharePoint

  • Authentification par revendications SharePoint dans le cas de plusieurs batteries de serveurs

À propos de l'authentification par revendications

Un jeton de sécurité est la principale composante d'un système d'authentification basé sur des revendications. Le jeton de sécurité est constitué d'un ensemble d'assertions d'identité portant sur un utilisateur authentifié. Les assertions sont des attributs associés à l'identité d'un utilisateur. Les assertions peuvent inclure un nom d'utilisateur, un rôle, un ID d'employé et une série d'autres attributs permettant de déterminer les niveaux d'autorisation d'accès aux ressources SharePoint Foundation 2010. Les assertions sont composées d'une liste de types et de valeurs. Un type peut être un nom d'employé, par exemple, tandis qu'une valeur peut être une chaîne de texte. Les jetons de sécurité sont créés et gérés par un service d'émission de jeton de sécurité. Un service d'émission de jeton de sécurité encapsule une collection d'assertions, en fonction d'attributs spécifiés par une stratégie, en un jeton de sécurité permettant d'authentifier et d'autoriser un utilisateur.

Service d'émission de jeton de sécurité

Un service d'émission de jeton de sécurité est un service Web qui répond aux demandes d'authentification en émettant des jetons de sécurité composés de revendications d'identité basées sur les informations de comptes d'utilisateur stockées dans les magasins d'attributs. Un magasin d'attributs peut se trouver dans les services de domaine Active Directory, une base de données SQL ou un magasin LDAP. Le contenu de chaque jeton de sécurité est déterminé par les contraintes de type d'attribut des demandes d'authentification négociées pour un service d'émission de jeton de sécurité et l'application Web SharePoint. Une collection négociée de revendications et de règles de revendications est appelée stratégie. Les stratégies se trouvent dans un magasin de stratégies et sont accessibles par un service d'émission de jeton de sécurité, en fonction des contraintes de l'application Web appelante.

Service d'émission de jeton de sécurité

Service d'émission de jeton de sécurité

Un service d'émission de jeton de sécurité remplit deux fonctions différentes, selon la relation qui le lie à l'application Web. Si le service d'émission de jeton de sécurité et l'application Web se trouvent dans la même batterie de serveurs SharePoint, le service d'émission de jeton de sécurité fonctionne comme un service d'émission de jeton de sécurité de fournisseur d'identités local. Si le service d'émission de jeton de sécurité et l'application Web se trouvent dans des batteries de serveurs différentes, le service d'émission de jeton de sécurité fonctionne comme un service d'émission de jeton de sécurité de partie de confiance. Ces types de services d'émission de jeton de sécurité sont décrits dans les sections suivantes.

Service d'émission de jeton de sécurité de fournisseur d'identités

Un service d'émission de jeton de sécurité de fournisseur d'identités est le fournisseur d'identités local d'une application Web SharePoint. Le service d'émission de jeton de sécurité de fournisseur d'identités et l'application Web se trouvent dans la même batterie de serveurs SharePoint. Le service d'émission de jeton de sécurité de fournisseur d'identités fournit des jetons de sécurité aux utilisateurs authentifiés dont les attributs sont disponibles dans les magasins d'attributs locaux.

Service d'émission de jeton de sécurité de fournisseur d'identités

Service d'émission de jeton de sécurité local

Service d'émission de jeton de sécurité de partie de confiance

Un service d'émission de jeton de sécurité de partie de confiance est un fournisseur d'identités partenaire disposant d'une relation d'approbation avec un service d'émission de jeton de sécurité de fournisseur d'identités. Un service d'émission de jeton de sécurité de partie de confiance et une application Web se trouvent dans des batteries de serveurs SharePoint différentes. En raison de cette relation d'approbation, le service d'émission de jeton de sécurité de partie de confiance peut autoriser un utilisateur externe dont les informations d'identification ne sont pas stockées localement, sous réserve qu'un service d'émission de jeton de sécurité de fournisseur d'identités émette un jeton de sécurité valide pour cet utilisateur. Le service d'émission de jeton de sécurité de partie de confiance peut émettre un nouveau jeton qui sera valide pour l'application Web externe à l'utilisateur, mais propre au service d'émission de jeton de sécurité de partie de confiance.

Service d'émission de jeton de sécurité de partie de confiance

Service d'émission de jeton de sécurité partenaire

Authentification par revendications dans le cas d'une seule batterie de serveurs SharePoint

Le flux de données dans le diagramme suivant illustre une demande d'authentification entrante provenant d'un utilisateur interne dont les informations d'identification sont directement accessibles par le service d'émission de jeton de sécurité propre à la batterie de serveurs. L'application Web répond à la demande d'authentification par une redirection vers le service d'émission de jeton de sécurité local. La demande d'authentification est soumise au service d'émission de jeton de sécurité local, qui la traite. Le service d'émission de jeton de sécurité recherche la stratégie pour l'application Web demandeuse dans le magasin de stratégies et crée un jeton pour l'utilisateur demandeur en utilisant des valeurs d'assertion d'identité stockées dans le magasin d'attributs. Un jeton de sécurité valide est retourné à l'utilisateur, puis soumis à l'application Web. Dans cet exemple, l'application Web retourne un cookie à l'utilisateur.

Service d'émission de jeton de sécurité dans le cas d'une seule batterie de serveurs

Authentification par revendications SharePoint dans le cas de plusieurs batteries de serveurs

Le flux de données dans le diagramme suivant illustre une demande d'authentification entrante provenant d'un utilisateur externe dont les informations d'identification ne sont pas directement accessibles par le service d'émission de jeton de sécurité local. L'application Web répond à la demande d'authentification par une redirection vers le service d'émission de jeton de sécurité partenaire. La demande d'authentification est soumise au service d'émission de jeton de sécurité partenaire et, en raison de la relation d'approbation entre le service d'émission de jeton de sécurité partenaire et le service d'émission de jeton de sécurité local, le service d'émission de jeton de sécurité partenaire crée un jeton de service d'émission de jeton de sécurité de fournisseur d'identités pour l'utilisateur et le soumet au service d'émission de jeton de sécurité local. Celui-ci déchiffre le jeton de service d'émission de jeton de sécurité de fournisseur d'identités, crée un jeton de service d'émission de jeton de sécurité de partie de confiance, qu'il retourne à l'utilisateur externe. Le jeton de service d'émission de jeton de sécurité de partie de confiance est ensuite soumis à l'application Web. Dans cet exemple, l'application Web retourne un cookie à l'utilisateur.

Service d'émission de jeton de sécurité entre batteries de serveurs

Service d'émission de jeton de sécurité dans le cas de plusieurs batteries de serveurs


Planifier le service Banque d'informations sécurisé (SharePoint Foundation 2010)

Dans Microsoft SharePoint Foundation 2010, le service Banque d'informations sécurisé remplace la fonctionnalité d'authentification unique (SSO). Ce service, qui utilise l'autorisation basée sur les revendications, inclut une base de données sécurisée pour stocker les informations d'identification associées aux ID d'applications. Ces ID d'applications peuvent être utilisés pour autoriser l'accès aux sources de données externes.

Dans cet article :

  • À propos du service Banque d'informations sécurisé

  • Préparation du service Banque d'informations sécurisé

  • ID d'applications

  • Mappages du service Banque d'informations sécurisé

  • Service Banque d'informations sécurisé et authentification par revendications

À propos du service Banque d'informations sécurisé

Le service Banque d'informations sécurisé est un service d'autorisation qui s'exécute sur un serveur d'applications. Ce service fournit une base de données utilisée pour stocker les informations d'identification (identité utilisateur et mot de passe) pour les ID d'applications, qui peuvent être utilisées par les applications pour autoriser l'accès aux ressources partagées. Par exemple, SharePoint Foundation 2010 peut utiliser la base de données Banque d'informations sécurisé pour stocker et récupérer les informations d'identification pour l'accès aux sources de données externes. Le service Banque d'informations sécurisé fournit la prise en charge pour stocker les informations d'identification de plusieurs systèmes principaux en utilisant les multiples ID d'applications.

Préparation du service Banque d'informations sécurisé

Lorsque vous vous préparez à déployer le service Banque d'informations sécurisé, gardez à l'esprit les instructions importantes suivantes :

  • Exécutez le service Banque d'informations sécurisé dans un pool d'applications distinct qui n'est utilisé pour aucun autre service.

  • Exécutez le service Banque d'informations sécurisé sur un serveur d'applications distinct qui n'est utilisé pour aucun autre service.

  • Créez la base de données de la banque d'informations sécurisée sur un serveur d'applications distinct exécutant SQL Server. N'utilisez pas l'installation de SQL Server qui contient les bases de données de contenu.

  • Avant de générer une nouvelle clé de chiffrement, sauvegardez la base de données de la banque d'informations sécurisée. Vous devez également sauvegarder la base de données Banque d'informations sécurisé après sa création initiale et à nouveau chaque fois que les informations d'identification sont rechiffrées. Lorsqu'une nouvelle clé est générée, les informations d'identification peuvent être rechiffrées avec la nouvelle clé. Si l'actualisation de la clé échoue ou si la phrase secrète est oubliée, les informations d'identification ne seront pas utilisables.

  • Sauvegardez la clé de chiffrement après la configuration initiale du service Banque d'informations sécurisé et chaque fois qu'elle est régénérée.

  • Ne stockez pas le support de sauvegarde de la clé de chiffrement au même emplacement que celui de la base de données de la banque d'informations sécurisée. Si un utilisateur obtient une copie de la base de données et de la clé, les informations d'identification stockées dans la base de données pourraient être compromises.

ID d'applications

Chaque entrée du service Banque d'informations sécurisé contient un ID d'application qui est utilisé pour récupérer un ensemble d'informations d'identification de la base de données de la banque d'informations sécurisée. Chaque ID d'application peut avoir des autorisations appliquées de sorte que seuls des utilisateurs ou des groupes spécifiques puissent accéder aux informations d'identification stockées pour cet ID d'application. Les applications utilisent les ID d'applications pour récupérer les informations d'identification dans la base de données de la banque d'informations sécurisée pour le compte d'un utilisateur. L'application peut ensuite utiliser les informations d'identification extraites pour accéder à une source de données.

Les ID d'applications sont utilisés pour mapper les utilisateurs aux jeux d'informations d'identification. Les mappages sont disponibles pour des groupes ou des individus. Dans un mappage de groupe, chaque utilisateur qui est un membre d'un groupe de domaines spécifique est mappé au même jeu d'informations d'identification. Dans un mappage individuel, chaque utilisateur est mappé à un ensemble unique d'informations d'identification

Mappages du service Banque d'informations sécurisé

Le service Banque d'informations sécurisé prend en charge les mappages individuels et les mappages de groupe. Il maintient un ensemble d'informations d'identification pour les ID d'applications des ressources stockées dans la base de données de la banque d'informations sécurisée. Les mappages individuels pour une application sont extraits en fonction de l'ID de cette application. Ils sont utiles si vous avez besoin de journaliser les informations sur les accès individuels des utilisateurs aux ressources partagées. Pour les mappages de groupe, une couche de sécurité vérifie les informations d'identification de groupe pour plusieurs utilisateurs d'un domaine par rapport à un ensemble unique d'informations d'identification pour une ressource identifiée par un ID d'application qui est stocké dans la base de données de la banque d'informations sécurisée. Les mappages de groupe sont plus faciles à gérer que les mappages individuels et offrent de meilleures performances.

Service Banque d'informations sécurisé et authentification par revendications

Le service Banque d'informations sécurisé est un service utilisant les revendications. Il peut accepter les jetons de sécurité et les déchiffrer pour obtenir l'ID de l'application, puis effectuer une recherche. Lorsqu'un service d'émission de jeton de sécurité SharePoint Foundation 2010 émet un jeton de sécurité en réponse à une demande d'authentification, le service Banque d'informations sécurisé déchiffre le jeton et lit la valeur de l'ID d'application. Le service Banque d'informations sécurisé utilise l'ID d'application pour récupérer les informations d'identification de la base de données de la banque d'informations sécurisée. Les informations d'identification sont ensuite utilisées pour autoriser l'accès aux ressources.


Receive-SPServiceApplicationConnectionInfo
Exemple
[image]

Configure cette batterie pour recevoir des informations sur les services d'une autre batterie.

Receive-SPServiceApplicationConnectionInfo [-FarmUrl] <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Filter <String>]

Paramètres

Paramètre | Requis | Type | Description
FarmUrl | Requis | System.Uri |
AssignmentCollection | Facultatif | Microsoft.SharePoint.PowerShell.SPAssignmentCollection |
Filter | Facultatif | System.String |

Description détaillée

L'applet de commande Receive-SPServiceApplicationConnectionInfo récupère la liste des applications de service publiées par une autre batterie.

Pour les autorisations et les informations les plus à jour sur les produits Windows PowerShell for SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE-----------------------
Code de copie
Receive-SPServiceApplicationConnectionInfo -FarmUrl http://FarmB/topology/topology.svc

Cet exemple récupère une liste des applications de service publiées par une batterie donnée.

Le paramètre FarmURL peut être obtenu par l'applet de commande Get-SPTopologyServiceApplication.

Historique des modifications


Uninstall-SPWebPartPack
Voir aussi Exemple
[image]

Désinstalle le package de composants WebPart spécifié.

Uninstall-SPWebPartPack [-Identity] <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Language <UInt32>] [-WebApplication <SPWebApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Paramètres

Paramètre Requis Type Description

Identity

Requis

System.String

Spécifie le package de composants WebPart dans la base de données de configuration de la batterie de serveurs.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Language

Facultatif

System.Int32

Spécifie l'ID de langue du package de composants WebPart à supprimer. Si aucune langue n'est spécifiée, le package de composants WebPart est désinstallé pour toutes les langues.

Le type doit être un identificateur de langue valide sous la forme 1033.

WebApplication

Facultatif

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web à partir de laquelle désinstaller le package de composants WebPart. Si aucune application Web n'est spécifiée, le package de composants WebPart est désinstallé de toutes les applications Web.

Le type doit être un nom valide au format WebApplication-1212, ou une URL au format http://server_name/WebApplication-1212.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Uninstall-SPWebPartPack désinstalle le package de composants WebPart spécifié par le paramètre Identity.

Pour connaître les autorisations et les dernières informations sur Windows PowerShell pour les produits SharePoint, voir la documentation en ligne (http://go.microsoft.com/fwlink/?linkid=163185&clcid=0x40C).

Types d'entrée

Types retournés

None

Erreurs

Erreur | Description

Exceptions

Exceptions | Description

Exemple

------------------EXEMPLE1------------------
Code de copie
Uninstall-SPWebPartPack  "mypart.wpp" -WebApplication http://portal

Cet exemple désinstalle mypart.wpp de l'application Web http://portal.

------------------EXEMPLE2------------------
Code de copie
Get-SPWebPartPack -WebApplication http://portal | Uninstall-SPWebPartPack

Cet exemple désinstalle tous les packages de composants WebPart de l'application Web http://portal.

Voir aussi

Référence

Get-SPWebPartPack
Install-SPWebPartPack

Historique des modifications


Déployer Office Web Apps (SharePoint Foundation 2010)

Office Web Apps est le compagnon en ligne des applications Word, Excel, PowerPoint et OneNote, qui permet aux utilisateurs d'accéder à leurs documents à partir de n'importe quel emplacement. Les utilisateurs peuvent afficher, partager et utiliser des documents avec d'autres et en ligne, par le biais d'ordinateurs personnels, de téléphones mobiles et sur le Web. Office Web Apps est disponible pour les utilisateurs par le biais de Windows Live et pour les clients professionnels disposant de solutions de licence en volume et de gestion de documents Microsoft Office 2010, basées sur Microsoft SharePoint Foundation 2010.

Cet article décrit comment déployer Office Web Apps sur Microsoft SharePoint Foundation 2010.

Le présent article contient les sections suivantes :

  • Public visé et portée de l'article

  • Présentation du déploiement d'Office Web Apps

  • Installation et configuration d'Office Web Apps sur un serveur autonome

  • Installation et configuration d'Office Web Apps sur une batterie de serveurs

  • Activation des services et de la fonctionnalité Office Web Apps à l'aide de Windows PowerShell

Public visé et portée de l'article

Les informations fournies dans cet article sur le déploiement d'Office Web Apps sont destinées aux professionnels de l'informatique qui installent et administrent SharePoint Foundation 2010 sur un serveur autonome ou une batterie de serveurs. Cet article ne fournit pas de conseils ou d'instructions sur le déploiement de SharePoint Foundation 2010. Pour plus d'informations sur le mode de déploiement de SharePoint Foundation 2010, voir Déploiement (WSS 4.0) dans la documentation de SharePoint Foundation 2010.

Présentation du déploiement d'Office Web Apps

L'installation d'Office Web Apps sur SharePoint Foundation 2010 ajoute l'application Service d'affichage Word, les services de calcul Excel et l'application de service PowerPoint à la liste des services partagés SharePoint disponibles. Aucun service SharePoint supplémentaire n'est requis pour la modification dans Word ou pour les fichiers OneNote. L'installation fournit également une série de pages Web et de gestionnaires, chacun utilisé par Word Web App, Excel Web App, PowerPoint Web App et OneNote Web App.

La fonctionnalité fournie par PowerPoint Web App active également la fonctionnalité Diffuser le diaporama de PowerPoint. Il s'agit d'une nouvelle fonctionnalité dans Microsoft Office 2010 qui permet aux présentateurs de diffuser un diaporama à partir de PowerPoint 2010 pour des personnes distantes qui regardent le diaporama par le biais d'un navigateur Web. Le déploiement de la fonctionnalité Diffuser le diaporama n'est pas abordé dans le présent document de déploiement. Pour en savoir plus sur le déploiement de la fonctionnalité Diffuser le diaporama, voir le livre blanc Déploiement de la fonctionnalité Diffuser le diaporama (éventuellement en anglais) à l'adresse : http://go.microsoft.com/fwlink/?linkid=166102&clcid=0x40C. Ce livre blanc fournit un résumé de cette nouvelle fonctionnalité pour les administrateurs système et les responsables informatiques qui utilisent SharePoint, et il les prépare à évaluer, à planifier et à implémenter la fonctionnalité Diffuser le diaporama de manière efficace dans leurs environnements.

Le déploiement d'Office Web Apps comporte trois phases principales :

  • Installation d'Office Web Apps en exécutant le programme d'installation (WCSetup.exe)

  • Activation des services Office Web Apps

  • Activation de la fonctionnalité Office Web Apps sur les collections de sites pour lesquelles Office Web Apps doit être disponible

Installation d'Office Web Apps

L'installation d'Office Web Apps pour des déploiements autonomes ou de batteries de serveurs nécessite l'exécution de WCSetup.exe sur chaque serveur SharePoint Foundation 2010, puis l'exécution de PSConfig. L'exécution de PSConfig inscrit les services Office Web Apps sur le serveur.

Activation des services Office Web Apps

L'activation des applications de service pour des déploiements autonomes et de batteries de serveurs dépend de l'état de SharePoint Foundation 2010 ainsi que de l'exécution ou non de l'Assistant Configuration après installation de SharePoint (PSConfig.exe) ou de l'Assistant Configuration de batterie de serveurs de SharePoint.

Sur une installation autonome, si vous n'avez jamais exécuté PSConfig dans le cadre de l'installation de SharePoint, l'exécution de PSConfig dans le cadre de l'installation d'Office Web Apps activera automatiquement les instances de service, les applications de service et les proxys d'applications de service requis.

De même, sur une installation de batterie de serveurs, si nous n'avez jamais exécuté l'Assistant Configuration de batterie de serveurs avant d'installer Office Web Apps, l'exécution de l'Assistant Configuration de batterie de serveurs avec l'installation d'Office Web Apps activera automatiquement les instances de service, les applications de service et les proxys d'applications de service requis.

Si aucune des conditions ci-dessus ne s'applique, vous devez activer manuellement les instances de service, les applications de service et les proxys appropriés.

L'activation des applications et des proxys des services Office Web Apps peut être effectuée par le biais des étapes suivantes :

  • Démarrage des instances de service Les instances de service peuvent être démarrées en utilisant la page Services sur le serveur dans l'Administration centrale de SharePoint ou en exécutant un script Windows PowerShell (fourni plus loin dans cet article).

  • Création des applications de service et des proxys Les applications de service et leurs proxys associés peuvent être créés en utilisant la page Gérer les applications de service dans l'Administration centrale de SharePoint ou en exécutant un script Windows PowerShell (fourni plus loin dans cet article). Remarque : l'exécution des applications de service démarrera automatiquement sur chaque instance de service.

Activation de la fonctionnalité Office Web Apps

L'activation de la fonctionnalité Office Web Apps peut être effectuée par le biais de l'étape suivante :

  • Activation de la fonctionnalité Office Web Apps Active la fonctionnalité Office Web Apps sur toutes les collections de sites SharePoint sur un serveur autonome ou une batterie de serveurs où Office Web Apps doit être disponible. Vous pouvez activer la fonctionnalité Office Web Apps en exécutant un script Windows PowerShell (fourni plus loin dans cet article).

Installation et configuration d'Office Web Apps sur un serveur autonome

Attention :
Activez les services Office Web Apps immédiatement après l'exécution de l'installation. Lorsque vous exécutez Wcsetup.exe, le programme d'installation d'Office Web Apps prend le contrôle du paramètre Comportement d'ouverture par défaut des documents activés pour le navigateur pour toutes les bibliothèques de documents. Si un utilisateur clique sur un document dans une bibliothèque au sein de SharePoint Foundation après l'exécution de l'installation d'Office Web Apps, mais avant l'activation des services Office Web Apps, il se peut qu'il obtienne un lien rompu lors de l'ouverture d'un document dans un navigateur. Nous vous recommandons par conséquent fortement d'activer les services Office Web Apps et la fonctionnalité Office Web Apps immédiatement après l'exécution de l'installation ou de désactiver l'option d'ouverture par défaut tant que la fonctionnalité et les services Office Web Apps n'ont pas été activés.

Important :
Clé de produit de la version préliminaire Pour cette version bêta préliminaire d'Office Web Apps, entrez la clé de produit suivante lorsque vous exécutez WCsetup.exe : BQDC3-93DMP-HGJB2-MFFV8-622QJ.

Exécution du programme d'installation d'Office Web Apps

  1. À partir du dossier racine, exécutez WCsetup.exe.

  2. Dans la page Tapez la clé de produit, entrez votre clé de produit, puis cliquez sur Continuer.

  3. Dans la page Choisir un emplacement pour les fichiers, cliquez sur Installer maintenant pour effectuer l'installation à l'emplacement par défaut. Pour effectuer l'installation à un autre emplacement, spécifiez cet emplacement, puis cliquez sur Installer maintenant.

  4. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Assurez-vous que la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint est activée, puis cliquez sur Fermer pour démarrer PSConfig.

Exécution de PSConfig pour enregistrer et activer des services

Remarque :
Cette procédure s'applique uniquement si l'Assistant Configuration après installation de SharePoint (PSConfig) n'a pas été exécuté avec l'installation initiale de SharePoint.

  1. Si vous avez laissé la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint activée à l'étape précédente, dans la page Bienvenue dans les produits SharePoint de PSconfig, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés ou réinitialisés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Configuration réussie, cliquez sur Terminer. Votre nouveau site SharePoint s'ouvre.

Installation et configuration d'Office Web Apps sur une batterie de serveurs

Attention :
Activez les services Office Web Apps immédiatement après l'exécution de l'installation. Lorsque vous exécutez Wcsetup.exe, le programme d'installation d'Office Web Apps prend le contrôle du paramètre Comportement d'ouverture par défaut des documents activés pour le navigateur pour toutes les bibliothèques de documents. Si un utilisateur clique sur un document dans une bibliothèque au sein de SharePoint Foundation après l'exécution de l'installation d'Office Web Apps, mais avant l'activation des services Office Web Apps, il se peut qu'il obtienne un lien rompu lors de l'ouverture d'un document dans un navigateur. Nous vous recommandons par conséquent fortement d'activer les services Office Web Apps et la fonctionnalité Office Web Apps immédiatement après l'exécution de l'installation ou de désactiver l'option d'ouverture par défaut tant que la fonctionnalité et les services Office Web Apps n'ont pas été activés.

Important :
Clé de produit de la version préliminaire Pour cette version bêta préliminaire d'Office Web Apps, entrez la clé de produit suivante lorsque vous exécutez WCsetup.exe : BQDC3-93DMP-HGJB2-MFFV8-622QJ.

Exécution du programme d'installation d'Office Web Apps

Remarque :
Vous devez installer Office Web Apps en exécutant WCSetup.exe sur chaque serveur qui hébergera Office Web Apps dans la batterie de serveurs.

  1. À partir du dossier racine, exécutez WCsetup.exe.

  2. Dans la page Tapez la clé de produit, entrez votre clé de produit, puis cliquez sur Continuer.

  3. Dans la page Choisir un emplacement pour les fichiers, cliquez sur Installer maintenant pour effectuer l'installation à l'emplacement par défaut. Pour effectuer l'installation à un autre emplacement, spécifiez cet emplacement, puis cliquez sur Installer maintenant.

  4. Lorsque l'installation est terminée, une boîte de dialogue vous invite à terminer la configuration de votre serveur. Assurez-vous que la case à cocher Exécuter l'Assistant Configuration des produits et technologies SharePoint est activée.

  5. Cliquez sur Fermer pour démarrer l'Assistant de configuration.

Exécution de PSConfig pour enregistrer des services

  1. Dans la page Bienvenue dans les produits SharePoint, cliquez sur Suivant.

  2. Dans la boîte de dialogue qui vous signale que certains services devront éventuellement être redémarrés ou réinitialisés au cours de la configuration, cliquez sur Oui.

  3. Dans la page Modifier les paramètres de la batterie de serveurs, sélectionnez Ne pas se déconnecter de cette batterie de serveurs, puis cliquez sur Suivant.

  4. Dans la page Configuration réussie, cliquez sur Terminer. Votre nouveau site SharePoint s'ouvre.

Exécution de l'Assistant Configuration de batterie de serveurs des produits SharePoint pour activer des services

Remarque :
Cette procédure doit être exécutée uniquement si l'Assistant Configuration de batterie de serveurs n'a pas été exécuté au préalable. Si l'Assistant Configuration de batterie de serveurs a déjà été exécuté, vous pouvez ignorer cette procédure et activer Office Web Apps à l'aide de Windows PowerShell.

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, Produits Microsoft SharePoint 2010, puis Administration centrale de SharePoint 2010.

  2. Dans la page d'accueil Administration centrale de SharePoint, cliquez sur Assistants de configuration.

  3. Dans la page Assistants de configuration, cliquez sur Exécuter l'Assistant Configuration de batterie de serveurs.

  4. Dans la page d'accueil Assistant Configuration de batterie de serveurs, choisissez Passer en revue les paramètres à l'aide de cet Assistant, puis appuyez sur Suivant.

  5. Dans la page Configuration de votre batterie SharePoint, dans Compte de service, tapez un nom pour le compte d'administration de la batterie de serveurs.

  6. Dans Services, sélectionnez les services Office Web Apps que vous voulez activer, puis cliquez sur Suivant.

  7. Créez un nouveau site de niveau supérieur en option. Dans la page Créer une collection de sites, suivez les étapes de l'Assistant pour créer un nouveau site de niveau supérieur.

  8. Dans la page Configuration de votre batterie SharePoint, cliquez sur Terminer. La configuration d'Office Web Apps est terminée.

Activation des services et de la fonctionnalité Office Web Apps à l'aide de Windows PowerShell

Lors de l'activation d'Office Web Apps à l'aide de Windows PowerShell, vous pouvez exécuter les étapes suivantes sur un serveur SharePoint Foundation autonome ou à partir de n'importe quel serveur SharePoint Foundation dans une batterie de serveurs.

Remarque :
L'exécution manuelle de ces étapes à l'aide de Windows PowerShell est nécessaire uniquement si vous avez installé SharePoint Foundation et exécuté PSConfig sur un serveur autonome avant d'installer Office Web Apps. Ou bien, vous devez effectuer ces étapes si vous avez installé SharePoint Foundation et exécuté l'Assistant Configuration de batterie de serveurs sur un serveur de batterie de serveurs avant d'installer Office Web Apps. Si vous avez des doutes à propos de votre configuration SharePoint et de votre activation Office Web Apps, vous pouvez vérifier l'état de chaque service et application de service dans les pages Gérer les services sur le serveur et Gérer les applications de service dans l'Administration centrale de SharePoint. Si aucun service Office Web Apps n'est en cours d'exécution ou si les applications de service n'existent pas, vous devez exécuter les étapes suivantes.

Pour exécuter des scripts dans Windows PowerShell, vous devez définir la stratégie d'exécution permettant d'exécuter des scripts de manière non restreinte.

Définition de la stratégie d'exécution des scripts de Windows PowerShell

  1. Cliquez sur Démarrer, pointez sur Tous les programmes, sur Windows PowerShell, cliquez avec le bouton droit sur Windows PowerShell, puis cliquez sur Exécuter en tant qu'administrateur.

  2. Dans la console Windows PowerShell, à l'invite de commandes, tapez set-executionpolicy unrestricted, puis appuyez sur Entrée.

Démarrage des instances de service

Une instance de service fournit l'emplacement physique d'une application de service. Pour chaque serveur devant exécuter les applications de service Office Web Apps, vous devez démarrer les instances de service. Démarrez les instances de service en exécutant le script suivant dans Windows PowerShell :

Code de copie
$machinesToActivate = @("contosoapp1","contosoapp2")
$serviceInstanceNames = @("Word Viewing Service", "PowerPoint Service","Excel Calculation Services")
foreach ($machine in $machinesToActivate)
{
  foreach ($serviceInstance in $serviceInstanceNames)
  {
     $serviceID = $(Get-SPServiceInstance | where {$_.TypeName -match $serviceInstance} | where {$_.Server -match "SPServer Name="+$machine}).ID
     Start-SPServiceInstance -Identity $serviceID
  }
}

Spécifiez les paramètres suivants :

Paramètre | Valeur
$machinesToActivate | Nom du serveur

Création des applications de service et des proxys d'applications de service

Après le démarrage des instances de service, les applications de service et les proxys d'applications de service qui connectent les sites Web frontaux aux applications de service doivent être créés. Créez les applications de service et les proxys d'applications de service en exécutant le script suivant :

Code de copie
$appPool = Get-SPServiceApplicationPool -Name "SharePoint Web Services Default"
New-SPWordViewingServiceApplication -Name "WdView" -ApplicationPool $appPool | New-SPWordViewingServiceApplicationProxy -Name "WdProxy"
New-SPPowerPointServiceApplication -Name "PPT" -ApplicationPool $appPool | New-SPPowerPointServiceApplicationProxy -Name "PPTProxy"
New-SPExcelServiceApplication -Name "Excel" -ApplicationPool $appPool

Activation de la fonctionnalité Office Web Apps sur toutes les collections de sites

Office Web Apps nécessite l'activation de la fonctionnalité Office Web Apps sur toutes les collections de sites pour lesquelles les applications Web seront disponibles. Activez la fonctionnalité Office Web Apps pour toutes les collections de sites en exécutant le script suivant :

Code de copie
$webAppsFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OfficeWebApps"}).Id
Get-SPSite -limit ALL |foreach{Enable-SPFeature $webAppsFeatureId -url $_.URL }

Configuration supplémentaire (facultatif)

Après l'activation d'Office Web Apps, la fonctionnalité de clic par défaut dans SharePoint Foundation pointera vers Office Web Apps au lieu de l'application cliente d'Office. Vous pouvez remplacer cette fonctionnalité dans SharePoint Foundation au niveau des collections de sites et des bibliothèques de documents. Les scripts Windows PowerShell suivants fournissent des exemples de modification du comportement de clic par défaut pour chaque niveau :

Collection de sites - Cet exemple désactive le paramètre de clic par défaut pour toutes les collections de sites :

Code de copie
$webAppsFeatureId = $(Get-SPFeature -limit all | where {$_.displayname -eq "OfficeWebApps"}).Id
$singleSiteCollection = Get-SPSite -Identity http://<site_name>
Enable-SPFeature $webAppsFeatureId

Spécifiez les paramètres suivants :

Paramètre | Valeur
-Identity | URL

Bibliothèque de documents - Cet exemple désactive le paramètre de clic par défaut pour toutes les bibliothèques de documents dans le site1 :

Code de copie
Get-SPWeb -site http://foo/sites/site1 |% {}{$_.Lists}{$_.Update()} |% {$_.DefaultItemOpen = $false}

Spécifiez les paramètres suivants :

Paramètre | Valeur
-site | URL


Update-SPInfoPathUserFileUrl
Exemple
[image]

Met à jour des modèles de formulaires InfoPath (fichiers .xsn) et des connexions de données universelles (fichiers .udcx).

Update-SPInfoPathUserFileUrl [-WebApplication] <SPWebApplicationPipeBind> -Find <Uri> -Replace <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Scan <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Update-SPInfoPathUserFileUrl [-ContentDatabase] <SPContentDatabasePipeBind> -Find <Uri> -Replace <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Scan <SwitchParameter>] [-WhatIf [<SwitchParameter>]]
Update-SPInfoPathUserFileUrl [-Site] <SPSitePipeBind> -Find <Uri> -Replace <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Scan <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Paramètres

1

Paramètre

Requis

Type

Description

WebApplication

Requis

Microsoft.SharePoint.PowerShell.SPWebApplicationPipeBind

Spécifie l'application Web SharePoint parente dans laquelle est lancée la mise à jour.

Le type doit être une URL valide au format http://server_name, un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom d'application Web SharePoint valide (par exemple, MyOfficeApp1) ou une instance d'un objet SPWebApplication valide.

Find

Requis

System.Uri

Spécifie l'URL à rechercher.

Le type doit être une URL valide, au format http://previous_server_name.

Replace

Requis

System.Uri

Spécifie l'URL à rechercher.

Le type doit être une URL valide, au format http://server_name.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Scan

Facultatif

System.Management.Automation.SwitchParameter

Exécutez l'outil et consignez les opérations pouvant être effectuées. Le contenu n'est pas modifié à la suite d'une analyse.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

2

Paramètre

Requis

Type

Description

ContentDatabase

Requis

Microsoft.SharePoint.PowerShell.SPContentDatabasePipeBind

Spécifie la base de données de contenu parente dans laquelle est lancée la mise à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, un nom valide de base de données de contenu (par exemple, SPContent DB1) ou une instance d'objet SPContentDatabase valide.

Find

Requis

System.Uri

Spécifie l'URL à rechercher.

Le type doit être une URL valide, au format http://previous_server_name.

Replace

Requis

System.Uri

Spécifie l'URL à rechercher.

Le type doit être une URL valide, au format http://server_name.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Scan

Facultatif

System.Management.Automation.SwitchParameter

Exécutez l'outil et consignez les opérations pouvant être effectuées. Le contenu n'est pas modifié à la suite d'une analyse.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

3

Paramètre

Requis

Type

Description

Site

Requis

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Spécifie la collection de sites parente dans laquelle est lancée la mise à jour.

Le type doit être un GUID valide au format 12345678-90ab-cdef-1234-567890bcdefgh, une URL valide au format http://sites/exemple ou une instance d'objet SPSite valide.

Find

Requis

System.Uri

Spécifie l'URL à rechercher.

Le type doit être une URL valide, au format http://previous_server_name.

Replace

Requis

System.Uri

Spécifie l'URL à rechercher.

Le type doit être une URL valide, au format http://server_name.

AssignmentCollection

Facultatif

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Gère les objets de manière à optimiser leur libération. L'utilisation d'objets, tels que SPWeb ou SPSite, peut consommer des quantités de mémoire élevées et le recours à ces objets dans des scripts Windows PowerShell implique une gestion appropriée de la mémoire. À l'aide de l'objet SPAssignment, vous pouvez affecter des objets à une variable et les libérer dès qu'ils ne sont plus nécessaires afin de libérer de la mémoire. Lorsque les objets SPWeb, SPSite ou SPSiteAdministration sont utilisés, ils sont automatiquement libérés si une collection d'attributions ou le paramètre Global ne sont pas utilisés.

Remarque :
Lorsque le paramètre Global est utilisé, tous les objets sont contenus dans le magasin global. Si des objets ne sont pas utilisés immédiatement ou libérés à l'aide de la commande Stop-SPAssignment, un scénario d'insuffisance de mémoire peut se produire.

Confirm

Facultatif

System.Management.Automation.SwitchParameter

Vous demande confirmation avant d'exécuter la commande. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Scan

Facultatif

System.Management.Automation.SwitchParameter

Exécutez l'outil et consignez les opérations pouvant être effectuées. Le contenu n'est pas modifié à la suite d'une analyse.

WhatIf

Facultatif

System.Management.Automation.SwitchParameter

Affiche un message qui explique l'effet de la commande au lieu de l'exécuter. Pour plus d'informations, tapez la commande suivante : get-help about_commonparameters

Description détaillée

L'applet de commande Update-SPInfoPathAdminFileUrl met à jour des connexions de données dans des modèles de formulaires InfoPath (fichiers .xsn) et des connexions de données universelles (fichiers .udcx). Ceci permet la mise à jour des connexions de données InfoPath faisant référence à la batterie de serveurs actuelle lorsque le contenu est migré vers une autre URL de batterie de serveurs.

Types d'entrée

Types retournés

Exemple

------------------EXEMPLE------------------
Code de copie
Get-SPWebApplication http://contoso2010 | Update-SPInfoPathUserFileUrl
-find "http://contoso2007"
-replace "http://contoso2010"

Cet exemple met à jour des connexions de données dans des modèles de formulaires InfoPath et des fichiers UDC pour l'intégralité du contenu de l'application Web http://contoso2010. Les connexions de données faisant référence à http://contoso2007 sont mises à jour pour faire référence à http://contoso2010.

Historique des modifications


(Obsolète) Afficher des rapports d'administration (SharePoint Foundation 2010)

Cet article est obsolète depuis le 23 mars 2010.


Résolution des problèmes liés à SharePoint Foundation 2010

Bienvenue dans la documentation de résolution des problèmes de Microsoft SharePoint Foundation 2010. Vous pouvez utiliser cette documentation pour diagnostiquer et résoudre des erreurs spécifiques et vérifier qu'elles ne sont plus présentes.

Les informations de dépannage sont organisées en fonction des zones logiques présentant un intérêt pour l'administrateur lors de l'analyse et de la résolution des problèmes SharePoint Foundation 2010. Dans chaque zone logique des outils de gestion, vous trouverez des informations de référence et de résolution pour les problèmes relatifs à chaque événement enregistré par SharePoint Foundation 2010. Par exemple : les événements liés aux travaux du minuteur sont affectés à une zone fonctionnelle appelée Travaux du minuteur.

Nous vous encourageons à nous faire part de vos commentaires. Vos commentaires, vos suggestions et vos conseils de dépannage peuvent être intégrés aux futures versions de ce contenu.


Présentation de la surveillance de l'intégrité (SharePoint Foundation)

Microsoft SharePoint Foundation 2010 comprend un outil d'analyse d'intégrité appelé Gestionnaire de maintenance SharePoint qui permet à SharePoint Foundation de rechercher automatiquement les problèmes de configuration, de performance et d'utilisation potentiels. En tant qu'administrateur de batterie de serveurs, vous pouvez configurer des travaux de rapport d'intégrité spécifiques dans le cadre des opérations suivantes :

  • exécution selon une planification prédéfinie ;

  • alerte en cas de détection de problèmes ;

  • formulation de rapports pouvant être utilisés pour la surveillance des performances, la planification des capacités et le dépannage.

Cet article explique la structure et les fonctionnalités de base du Gestionnaire de maintenance SharePoint et indique à quel moment utiliser cet outil pour surveiller les activités dans une batterie de serveurs SharePoint. Pour des détails sur la configuration et l'exécution de travaux et de règles d'intégrité spécifiques, voir Référence technique sur la surveillance de l'intégrité.

Fonctionnement du Gestionnaire de maintenance SharePoint

Le Gestionnaire de maintenance SharePoint exécute des règles d'intégrité prédéfinies sur les serveurs de la batterie de serveurs. Des règles d'intégrité tierces peuvent être ajoutées à l'ensemble de règles.

Une règle d'intégrité exécute un test et retourne un état qui indique l'issue du test. Les résultats possibles sont répertoriés dans le tableau suivant.

État du test Signification

Réussite

Le Gestionnaire de maintenance SharePoint a exécuté le test et n'a découvert aucun problème.

Résolu

Le Gestionnaire de maintenance SharePoint a exécuté le test, découvert un problème et appliqué la solution logicielle appropriée. Le problème a été correctement résolu.

Échec

Le Gestionnaire de maintenance SharePoint n'a pas exécuté le test ou celui-ci s'est exécuté correctement, mais n'a pas résolu un problème découvert.

Problème détecté

Le test a découvert un problème, mais n'a pas essayé de le résoudre, en raison du paramètre de règle d'intégrité. Un niveau de gravité apparaît avec une description du problème découvert. Les niveaux de gravité sont les suivants :

  • Erreur critique

  • Avertissement

  • Informatif

Important :
Gardez à l'esprit que si une règle est exécutée sur plusieurs serveurs, un résultat « Réussite » n'est possible qu'une fois tous les serveurs testés avec succès.

Utilisation des informations d'état des règles d'intégrité

Lorsqu'une règle échoue, l'état est reporté dans la liste des problèmes de maintenance dans SharePoint Server, ainsi que dans le journal des événements Windows. Le Pack d'administration de Microsoft System Center Operations Manager peut également détecter et afficher les problèmes découverts par le Gestionnaire de maintenance SharePoint.

Vous pouvez également exporter les indicateurs d'états des règles dans un fichier XML en vue d'une analyse ou d'une assistance supplémentaires.

Planification des règles d'intégrité

Une règle d'intégrité peut être exécutée selon une planification définie ou de façon aléatoire. Toutes les règles d'intégrité sont disponibles par le biais du site Web Administration centrale de SharePoint, dans la page Analyse, pour une exécution immédiate ou planifiée.

Catégories de règles d'intégrité

Chaque règle d'intégrité appartient à l'une des catégories suivantes :

  • Sécurité

  • Performances

  • Configuration

  • Disponibilité

Configuration des règles d'intégrité

Chaque règle d'intégrité possède des paramètres configurables, décrits dans le tableau suivant.

Paramètre | Valeurs possibles
Titre | Nom de la règle d'intégrité. Vous pouvez renommer une règle d'intégrité pour clarifier sa fonctionnalité.
Domaine d'application | Vous pouvez configurer une règle d'intégrité de manière à ce qu'elle s'exécute sur un single server, all servers ou any server. Si elle est définie sur any server, la règle s'exécute sur le premier serveur disponible qu'elle rencontre.
Délai | Vous pouvez planifier une règle d'intégrité de manière à ce qu'elle s'exécute Hourly, Daily, Weekly, Monthly ou On Demand Only.
Activé | Vous pouvez utiliser ce commutateur pour activer ou désactiver une règle d'intégrité.
Réparer automatiquement | Vous pouvez indiquer si une règle d'intégrité doit essayer d'exécuter automatiquement une récupération des conditions d'erreurs qu'elle détecte. Si ce paramètre est défini sur No et qu'un problème est découvert, l'état résultant est Issue Detected. Si ce paramètre est défini sur Yes et qu'un problème est découvert, une résolution réussie du problème génère l'état Fixed, tandis qu'un problème non résolu génère l'état Failure.
Version | Cet historique de version vous permet d'effectuer le suivi des modifications de métadonnées réalisées sur chaque règle. Le numéro de version est mis à jour chaque fois que la règle est enregistrée.

Vous pouvez accepter les paramètres par défaut de chaque règle d'intégrité ou modifier le comportement de la règle en reconfigurant ces paramètres.

Travaux du minuteur d'analyse de l'intégrité

Les règles d'intégrité planifiées sont collectées et répertoriées dans l'Administration centrale, sur la page Analyse, dans la section Travaux du minuteur. Par exemple, toutes les règles d'intégrité configurées pour être exécutées sur tous les serveurs sur une base quotidienne sont collectées dans un travail par lots nommé Health Analysis Job (Daily, Central Administration, All).

Pour plus d'informations sur les travaux du minuteur, voir Gérer les travaux du minuteur SharePoint

Rapports d'analyse de l'intégrité

Vous pouvez générer des rapports d'analyse de l'intégrité dans l'Administration centrale, sur la page Monitoring Reports, et vous pouvez générer des rapports personnalisés en extrayant les données d'utilisation stockées ou en vous connectant à la base de données directement via SQL Server Reporting Services.

Utilisation de commandes PowerShell avec le Gestionnaire de maintenance SharePoint

Le Gestionnaire de maintenance SharePoint accepte des instructions PowerShell depuis l'invite de commandes pour la réalisation des opérations suivantes :

  • lancement de travaux du minuteur d'analyse de l'intégrité ;

  • extraction des données de surveillance de l'intégrité ;

  • exécution de règles d'intégrité spécifiques.


Produits et produits associés Windows PowerShell pour SharePoint 2010

Les sections suivantes comprennent le contenu de référence le plus récent pour les applets de commande Windows PowerShell spécifiques à des produits :

  • Référence pour Windows PowerShell pour SharePoint Foundation 2010

  • Windows PowerShell for SharePoint Server 2010 reference

  • Windows PowerShell for Search Server 2010 reference

  • Windows PowerShell for Office Web Apps reference