Microsoft BizTalk Adapter for Oracle E-Business Suite Help

Welcome to Microsoft BizTalk Adapter for Oracle E-Business Suite, which includes a variety of resources that can help you learn to develop, deploy, administer, and use the Oracle E-Business adapter.

Getting started icon | Getting Started Information about new features, limitations, prerequisites, and topics for users who are new to the adapter.
Tutorials icon | Oracle E-Business Adapter Tutorial Step-by-step instructions for learning how to use the adapter for specific scenarios.
Adapter Architecture icon | Planning and Architecture Architectural overview of the adapter.
Adapter Development icon | Development Instructions on how to use the adapter with BizTalk Server, the Windows Communication Foundation (WCF) service model, and the WCF channel model.
Adapter Deployment icon | Deployment Information about installing the adapter, migrating from previous versions of the adapter, and troubleshooting the installation.
Adapter Troubleshooting icon | Troubleshooting Information about enabling tracing and about troubleshooting issues with the BizTalk Adapter Pack and with the adapter, in particular.
Adapter Samples icon | Samples Samples demonstrating how to use the adapter.
Community resources icon | Community Resources Information about how to get assistance with the BizTalk Adapter Pack.

© 2014 Microsoft Corporation. All rights reserved.


Getting Started

This section provides an overview of the adapter, prerequisites, and topics for users who are new to Microsoft BizTalk Adapter Pack. Information is provided about the features of Microsoft BizTalk Adapter for Oracle E-Business Suite and the different operations that can be performed on the Oracle database by using the adapter.

What is an adapter?

An adapter is a software component that enables you to send and receive messages to and from a line-of-business (LOB) system. The primary goal of an adapter is to facilitate the exchange of business documents between trading partners. Because each business system may adhere to specific document formats and protocols, the adapter must use a delivery mechanism that conforms to commonly recognized standards and protocols to provide a uniform interface to the users.

The adapters in the BizTalk Adapter Pack can be divided into two broad categories:

  • LOB adapters. LOB adapters provide a service-oriented programming model to access LOB systems—for example, adapters for SAP or Siebel applications.

  • Data adapters. Data adapters provide a service-oriented programming model to access databases—for example, adapters for the Oracle database or SQL Server.

There are five adapters in the BizTalk Adapter Pack:

  • Microsoft BizTalk Adapter for Oracle E-Business Suite (Oracle E-Business adapter)

  • Microsoft BizTalk Adapter for SQL Server (SQL adapter)

  • Microsoft BizTalk Adapter for Oracle Database (Oracle Database adapter)

  • Microsoft BizTalk Adapter for mySAP Business Suite (SAP adapter)

  • Microsoft BizTalk Adapter for Siebel eBusiness Applications (Siebel adapter)

    Note
    The Siebel adapter is not available for 64-bit platforms.

If you do not already know how you want to use the Oracle E-Business adapter at your company, we recommend that you start by exploring the features and functionality of the adapter described in Understanding BizTalk Adapter for Oracle E-Business Suite.

In This Section

  • Prerequisite Skills and Knowledge

  • Common Administrative Tasks

  • Common Developer Tasks

  • Understanding BizTalk Adapter for Oracle E-Business Suite

  • Oracle E-Business Adapter Tutorial

  • Community Resources

  • Frequently Asked Questions

© 2014 Microsoft Corporation. All rights reserved.


Prerequisite Skills and Knowledge
See Also

The potential users for the BizTalk Adapter Pack are:

  • Developers who directly program to the adapters.

  • IT professionals who consume the adapters using other integration platforms like Microsoft BizTalk Server and other tools.

  • Independent software vendors (ISVs) who build solutions on top of the adapters.

The prerequisite skills and knowledge required for each role are detailed below.

Prerequisites for Developers

A developer using Microsoft BizTalk Adapter for Oracle E-Business Suite must be at least moderately experienced with the use of:

  • Microsoft Visual Studio 2013, with the development of .NET solutions

  • Programming with the .NET Framework 4.5 or .NET Framework 4.5.1

  • Programming with the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK

  • Extensible Markup Language (XML)

  • XML Schema Definition (XSD) language

  • Web Services Definition Language (WSDL)

Prerequisites for IT Professionals

An IT professional using the Microsoft BizTalk Adapter for Oracle E-Business Suite must be at least moderately experienced with the use of:

  • SQL Server Integration Services (SSIS)

  • Microsoft BizTalk Server

  • Windows SharePoint Services

Prerequisites for ISVs

ISVs using the Microsoft BizTalk Adapter for Oracle E-Business Suite must be at least moderately experienced with the use of:

  • The internal workings and concepts of Oracle E-Business Suite to be able to build applications on top of the adapters

  • .NET Framework 4.5 or .NET Framework 4.5.1

  • The WCF LOB Adapter SDK

See Also

Other Resources

Getting Started
Understanding BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Common Administrative Tasks

The following table provides links to topics helpful for deploying, using, and maintaining Microsoft BizTalk Adapter for Oracle E-Business Suite.

Administrative Tasks

  • Oracle E-Business Adapter Tutorial

  • Deployment

Planning and Architecture

  • Planning and Architecture

  • Understanding BizTalk Adapter for Oracle E-Business Suite

  • Security and Protection

Other Resources

  • Community Resources

  • Glossary

See Also

Concepts

Common Developer Tasks

Other Resources

Getting Started

© 2014 Microsoft Corporation. All rights reserved.


Common Developer Tasks

The following table provides links to topics useful for developing applications on top of Microsoft BizTalk Adapter for Oracle E-Business Suite.

Developer Tasks

  • Establishing a Connection to the Oracle E-Business Suite

  • Developing BizTalk Applications

  • Developing Applications By Using the WCF Service Model

  • Developing Applications by Using the WCF Channel Model

Planning and Architecture

  • Planning and Architecture

  • Understanding BizTalk Adapter for Oracle E-Business Suite

  • Security and Protection

Other Resources

  • Community Resources

  • Troubleshooting

  • Glossary

© 2014 Microsoft Corporation. All rights reserved.


Understanding BizTalk Adapter for Oracle E-Business Suite

The BizTalk Adapter Pack enables service-oriented programmatic access in order to interact with an external system. The adapters provide the following advantages to clients:

  • Consistent design-time experience. The adapters provide a common and user-friendly design-time experience for browsing, searching, and retrieving metadata of LOB artifacts.

  • Varied programming options. The adapters provide a choice of programming model including the Windows Communication Foundation (WCF) channel model, WCF service model, ADO.NET, Web services, or BizTalk Server supported models.

  • Uniform experience across LOBs. The adapters standardize on using WCF and Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK, and hence provide a uniform experience of gaining access to any LOB system.

As mentioned, the adapters are built on top of the WCF LOB Adapter SDK. This SDK provides a common basis for building integration adapters that a variety of client applications such as BizTalk Server and Microsoft Office can consume. The WCF LOB Adapter SDK aligns the adapter strategy with the Microsoft services strategy by exposing integration adapters as WCF channels. For more information about the WCF LOB Adapter SDK, see the WCF LOB Adapter SDK documentation. The WCF LOB Adapter SDK documentation is installed along with the WCF LOB Adapter SDK, typically under <installation drive>:\Program Files\WCF LOB Adapter SDK\Documents.

To perform operations in Oracle E-Business Suite, adapter clients must have access to relevant artifacts in Oracle E-Business Suite. External applications can add or remove data in Oracle E-Business Suite interface tables and the database tables by using SQL statements. Applications can also access data in the interface tables and the database tables by using views, functions, and procedures. With Microsoft BizTalk Adapter for Oracle E-Business Suite, adapter clients can browse the artifacts in Oracle E-Business Suite as well as in the underlying database. In Oracle E-Business Suite, the adapter clients can browse interface tables, interface views, concurrent programs, and request sets while in the underlying Oracle database, the adapter clients can browse tables, views, stored procedures, functions, PL/SQL APIs, and packages. Adapter clients can select the artifacts they require for their solution and retrieve metadata for those artifacts. This enables users to access and execute the operations on the artifacts in Oracle E-Business Suite and the underlying Oracle database.

This section lists the features of the Microsoft BizTalk Adapter for Oracle E-Business Suite.

In This Section

  • Overview of BizTalk Adapter for Oracle E-Business Suite

  • Key Features in BizTalk Adapter for Oracle E-Business Suite

  • Limitations of BizTalk Adapter for Oracle E-Business Suite

See Also

Other Resources

Getting Started

© 2014 Microsoft Corporation. All rights reserved.


Overview of BizTalk Adapter for Oracle E-Business Suite

The Microsoft BizTalk Adapter for Oracle E-Business Suite exposes Oracle E-Business Suite as a WCF service. Adapter clients can perform operations on the Oracle E-Business Suite by exchanging SOAP messages with the adapter. The adapter consumes the SOAP message and makes appropriate ODP.NET calls to perform the operation. The adapter returns the response from Oracle E-Business Suite back to the client in the form of SOAP messages.

The Oracle E-Business adapter displays metadata of the Oracle E-Business Suite artifacts (PL/SQL APIs, interface tables/views, concurrent programs, and request sets) and the underlying Oracle database artifacts (such as tables, functions, and procedures) that describe the structure of a SOAP message in the form of Web Services Description Language (WSDL). The Oracle E-Business adapter uses the Add Adapter Service Reference Visual Studio Plug-in, Add Adapter Metadata Wizard, and Consume Adapter Service BizTalk Project Add-in to enable adapter clients to retrieve metadata for operations. The adapter also generates programming artifacts that can be used in your programming solution. For more information about Add Adapter Service Reference Visual Studio Plug-in, Add Adapter Metadata Wizard, and Consume Adapter Service BizTalk Project Add-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

The Oracle E-Business adapter uses the Oracle Data Provider for .NET (ODP.NET) 11.1.0.7 to communicate with Oracle E-Business Suite. ODP.NET 11.1.0.7 is one of the components of Oracle Data Access Components (ODAC). You can use the Oracle E-Business adapter to communicate with Oracle E-Business Suite in the following ways:

  • By developing BizTalk applications. For more information, see Developing BizTalk Applications.

  • By using the Windows Communication Foundation (WCF) service model. For more information, see Developing Applications By Using the WCF Service Model.

  • By using the WCF channel model. For more information, see Developing Applications by Using the WCF Channel Model.

In This Section

  • How Does the Adapter Connect to Oracle E-Business Suite?

  • How Does the Adapter Surface Oracle E-Business Suite Metadata?

  • What Operations Can Be Performed Using the Adapter?

  • How does the Adapter Handle Transactions?

  • Other Features Supported by the Adapter

See Also

Other Resources

Understanding BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


How Does the Adapter Connect to Oracle E-Business Suite?

The Microsoft BizTalk Adapter for Oracle E-Business Suite uses ODP.NET 11.1.0.7 to connect to Oracle E-Business Suite. The Oracle E-Business adapter requires adapter clients to provide a connection string, called the connection Uniform Resource Identifier (URI), to connect to the Oracle E-Business Suite. Internally, the Oracle E-Business adapter connects to the underlying Oracle database through the URI. With a connection URI, adapter clients can specify connection parameters to connect to an external system.

The Oracle E-Business adapter enables adapter clients to connect to Oracle E-Business Suite in the following two ways:

  • Using tnsnames.ora: The connection URI provided by the adapter client contains only the net service name specified in the tnsnames.ora file. The adapter extracts the connection parameters such as server name, service name, and port number from the net service name entry in the tnsnames.ora file. To use this approach, the computer running the Oracle client must be configured to include the net service name for the Oracle database in the tnsnames.ora file.

    Important
    Due to an Oracle Client limitation, the DataSourceName parameter (net service name) in the connection URI cannot contain more than 39 characters if you are performing operations in a transaction. Therefore, make sure that the value specified for the DataSourceName parameter is less than or equal to 39 characters if you will be performing operations in a transaction.

  • Without using tnsnames.ora: The connection URI provided by the adapter clients contains the connection parameters such as server name, service name, and port number. In this case, the net service name in the tnsnames.ora file, or the actual tnsnames.ora file itself, does not need to be present on the client computer. This is helpful when you have a large number of users connecting to the Oracle database in your organization, and adding/updating servers does not lead to manually adding/updating the connection details in the tnsnames.ora file on every client computer.

    Important
    This mode of connectivity is not supported if you are performing operations in a transaction. This is due to a limitation of Oracle Client.

For more information about connecting to Oracle E-Business Suite, see Establishing a Connection to the Oracle E-Business Suite.

Make sure you comply with the security guidelines when establishing a connection with Oracle E-Business Suite. For more information about security guidelines, see Security and Protection.

Specifying Client Credentials

In Oracle E-Business adapter, you can provide credentials to connect to Oracle E-Business Suite in the following two places:

  • On the Security tab in the Configure Adapter dialog box. You can find this dialog box in the Consume Adapter Service Add-in, Add Adapter Metadata Wizard, or Add Adapter Service Reference Plug-in.

  • In the OracleUserName and OraclePassword binding properties on the Binding Properties tab in the Configure Adapter dialog box. You can find this dialog box in the Consume Adapter Service Add-in, Add Adapter Metadata Wizard, or Add Adapter Service Reference Plug-in. In this case, the credentials are stored in plain text in the binding file.

The Oracle E-Business adapter exposes the ClientCredentialType binding property that allows you to specify the set of credentials (Oracle E-Business Suite or Oracle database) that will be used to connect to Oracle E-Business Suite.

  • To connect using the Oracle database credentials, specify the ClientCredentialType binding property as Database, and then, on the Security tab, specify the database credentials in the User name and Password text boxes. If you will be performing operations on any of the Oracle E-Business Suite artifacts (interface table, interface view, concurrent program, request set, or Oracle E-Business Suite PL/SQL APIs), you must also provide the Oracle E-Business Suite credentials in the OracleUserName and OraclePassword binding properties.

  • To connect using Oracle E-Business Suite credentials, specify the ClientCredentialType binding property as EBusiness, and then specify Oracle E-Business Suite credentials in the User name and Password text boxes on the Security tab. You must also specify the Oracle database credentials for the OracleUserName and OraclePassword binding properties.

For more information about specifying client credentials, see Specifying Credentials for the Oracle E-Business Suite.

Windows Authentication

The Oracle E-Business adapter supports Windows Authentication while connecting to Oracle E-Business Suite. With Windows Authentication, the adapter clients can determine a user’s identity based on Windows logon credentials, and can leverage the built-in security of the Windows environment. For information about connecting to Oracle E-Business Suite by using Windows Authentication, see Connecting to Oracle E-Business Suite Using Windows Authentication.

See Also

Other Resources

Overview of BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


How Does the Adapter Surface Oracle E-Business Suite Metadata?

The metadata that Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces from Oracle E-Business Suite and the underlying Oracle database describes the message structure for communicating with Oracle E-Business Suite using the adapter. The Oracle E-Business adapter supports two interfaces for retrieving metadata.

  • MetadataExchange provided by Windows Communication Foundation (WCF). WCF provides a metadata-exchange endpoint for all WCF bindings, which enables clients to get metadata from Oracle E-Business Suite.

  • IMetadataRetrievalContract provided by the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK, which supports the metadata browsing and searching capabilities of the adapter.

The Oracle E-Business adapter surfaces the Oracle E-Business Suite and the underlying database artifacts, and respective operations that the adapter clients can invoke. These operations are discussed later in this topic.

You can use the adapter clients to browse, search, and retrieve metadata by:

  • Creating a BizTalk project in Visual Studio

  • Using the WCF channel model

  • Using the WCF service model

When using a BizTalk project, you must use the Consume Adapter Service BizTalk Project Add-in or the Add Adapter Metadata Wizard to generate metadata for the operations that you want to perform in Oracle E-Business Suite. When using the WCF service model, you must use the Add Adapter Service Reference Visual Studio Plug-in to generate the proxy classes for performing operations in Oracle E-Business Suite. For more information about browsing, searching, and retrieving metadata using Consume Adapter Service Add-in, Add Adapter Metadata Wizard or Add Adapter Service Reference Plug-in, see Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio.

Browsing Metadata

The Oracle E-Business adapter enables adapter clients to browse interface tables, interface views, concurrent programs, and request sets in Oracle E-Business Suite and tables, views, stored procedures, functions, and packages in the underlying database. As part of the metadata browse operation, the adapter also surfaces the operations that can be performed on the Oracle database, including some custom operations supported by the adapters. These operations are available from Consume Adapter Service Add-in, Add Adapter Metadata Wizard, and Add Adapter Service Reference Plug-in.

The Oracle E-Business adapter surfaces most of the operations under the following three nodes:

  1. Application-Based View: Contains the operations grouped by each application for the Oracle E-Business Suite artifacts.

  2. Artifact-Based View: Contains the operations grouped by artifact type (such as Interface Tables, Interface Views, and so on) in Oracle E-Business Suite and the underlying database.

  3. Schema-Based View: Contains the operations grouped by each schema for the underlying database artifacts.

There are some generic operations exposed at the root level that are applicable for both the nodes. Moreover, different operations are surfaced based on the type of operation: outbound or inbound.

The following table lists the outbound and inbound operations surfaced by the Oracle E-Business adapter:

Outbound Operations Inbound Operations

Application-Based View:

Contains a list of Oracle Applications in the underlying Oracle E-Business Suite. Expand an Oracle Application node to see the following artifacts:

  • Interface Tables: A list of all the interface tables. Select an interface table to view the Insert, Select, Update, and Delete operations.

  • Interface Views: A list of all the interface views. Select an interface view to view the Select operation.

  • Concurrent Programs: The following operations for the concurrent programs:

    • A set of all the concurrent programs specific to the Oracle Application that are exposed as operations.

    • The Get_Status operation to get the status of a concurrent program.

    • The Wait_For_Request operation to wait for a request to be completed before returning status.

    • The Submit_Request operation to call or execute a concurrent program by specifying the parameters required for the execution of the concurrent program.

  • Request Sets: A set of all the request sets specific to the Oracle Application that are exposed as operations.

Application-Based View:

Contains a list of Oracle Applications in the underlying Oracle E-Business Suite. Expand an Oracle Application node to see the following artifacts:

  • Interface Tables: The Poll operation for the interface tables that enables adapter clients to obtain inbound data from the Oracle E-Business Suite based on a query polling mechanism supported by the adapter.

  • Interface Views: The Poll operation for the interface views that enables adapter clients to obtain inbound data from the Oracle E-Business Suite based on a query polling mechanism supported by the adapter.

Artifact-Based View:

Contains all the artifacts in Oracle E-Business Suite and the underlying database. Expand an artifact node to see a list of the Oracle Applications or schemas based on the origin of the artifact (applications or database). For example, the Interface Tables node will display a list of Oracle Applications whereas the Tables node will display a list of database schemas.

The Artifact-Based View displays the artifacts listed under Applications-Based View and Schema-Based View. Each artifact node lists the operations relevant for an Oracle Application or a database schema.

Artifact-Based View:

Except concurrent programs and request sets, contains all the artifacts in Oracle E-Business Suite and all the artifacts in the underlying database. Expand an artifact node to see a list of the Oracle Applications or schemas based on the origin of the artifact (applications or database). For example, the Interface Tables node will display a list of Oracle Applications whereas the Tables node will display a list of database schemas.

The Artifact-Based View displays the artifacts listed under Applications-Based View and Schema-Based View. Each artifact node lists the operations relevant for an Oracle Application or a database schema.

Schema-Based View:

Contains a list of schemas in the underlying Oracle database. Expand schema node to see the following artifacts:

  • PL/SQL APIs: A list of all the PL/SQL APIs. Select a PL/SQL API to view the packaged procedures and functions that are exposed as operations.

  • Procedures: A list of procedures in the schema that are exposed as operations.

  • Functions: A list of functions in the schema that are exposed as operations.

  • Tables: A list of all the tables. Select a table to view the Insert, Select, Update, and Delete operations.

  • Views: A list of all the views. Select a view to view the Select operation.

Schema-Based View:

Contains a list of schemas in the underlying Oracle database. Expand schema node to see the following artifacts:

  • PL/SQL APIs: A list of all the PL/SQL APIs. Select a PL/SQL API to view the packaged procedures and functions that are exposed as operations for polling.

  • Procedures: A list of procedures in the schema that are exposed as operations for polling.

  • Functions: A list of functions in the schema that are exposed as operations for polling.

  • Tables: A list of all the tables. Select a table to view the Poll operation for the table.

  • Views: A list of all the views. Select a view to view the Poll operation for the view.

The Oracle E-Business adapter also exposes the following generic outbound operations at the root level: ExecuteReader, ExecuteScalar, and ExecuteNonQuery. For information about these operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations.

The Oracle E-Business adapter also exposes the Notification operation at the root level that enables adapter clients to receive database change notification messages from Oracle E-Business Suite. For more information about the notification operation, see Receiving Database Change Notifications.

For more information about how the metadata is categorized, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

Searching Metadata

Using the Oracle E-Business adapter, you can perform a search query in Oracle E-Business Suite and on the underlying Oracle database by using the Oracle search expressions that are compatible with the LIKE operator. For example, adapter clients can use a search expression such as “EMP%” to obtain tables starting with EMP. The adapter converts this to the following SQL query:

Copy Code
SELECT TABLE_NAME FROM ALL_TABLES WHERE TABLE_NAME LIKE 'EMP%' AND OWNER = 'SCOTT'

Where, SCOTT is the schema with a collection of Oracle database artifacts.

The following table lists the special characters that can be used for search and their interpretation by the Oracle Database adapter.

Special character | Interpretation
_ (underscore) | Matches exactly one character For example, A_ matches AB, AC, and AD.
% (percentage) | Matches zero or more characters. For example, A% matches A, AB, ABC.
\ (escape) | Escapes the special meaning of % and _. The \ (escape) character is used before a wildcard character to indicate that the wildcard character should be interpreted as a regular character. For example, A\_B matches A_B.
Important
  • The search string is case-sensitive.

  • The search works differently under the different view (Application-Based View, Artifact-Based View, and Schema-Based View). To know how you can search for artifacts and operations under each view, see “Searching Under Different Views” in Searching for Operations.

  • To search for an application you can specify the friendly name or the short name of the application. For example, to search for the Receivables application you can specify the search string as either Receive% or AR. AR is the application short name.

  • To search for a concurrent program you can specify the friendly name or the actual name of the concurrent program. For example, to search for the Customer Interface concurrent program you can specify the search string as either %Customer Interface% or %RACUST%. RACUST is the actual name of the concurrent program. Also, the search result will always contain the standard concurrent programs irrespective of whether their name matches with the specified search string.

Retrieving Metadata

When retrieving metadata, the Oracle E-Business adapter can extract metadata under a schema, including all or a subset of database objects with the respective object and operation parameters. The adapter presents the entities from Oracle E-Business Suite and the underlying Oracle database as element names in XML. Because underscores are the only permissible special characters that can be included, all other special characters in the element names are encoded using underscores. For example, emp$name is encoded as emp_x0024_name. For more information, see Retrieving Metadata for Operations.

See Also

Other Resources

Overview of BizTalk Adapter for Oracle E-Business Suite
Understanding BizTalk Adapter for Oracle E-Business Suite
Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations
Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio

© 2014 Microsoft Corporation. All rights reserved.


What Operations Can Be Performed Using the Adapter?

Adapter clients can perform operations in Oracle E-Business Suite by:

  • Creating BizTalk projects

  • Using the WCF channel model

  • Using the WCF service model

The Microsoft BizTalk Adapter for Oracle E-Business Suite exposes operations that applications can invoke on it and that it can, in turn, invoke on applications. These operations are invoked by sending SOAP messages over a channel. If a response is required, it is returned in a SOAP message over the same channel. For information about the message structure and the SOAP action associated with each operation, see Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite.

This section provides information about the operations supported in Oracle E-Business Suite using the Oracle E-Business adapter.

In This Section

  • Setting Application Context

  • Operations on Interface Tables and Interface Views

  • Operations on PL/SQL APIs

  • Operations on Concurrent Programs

  • Operations on Request Sets

  • Operations on Interface Tables, Interface Views, Tables, and Views That Contain LOB Data

  • Operations on Tables That Contain BFILE Data Types

  • Operations on Functions and Stored Procedures

  • Operations on Functions and Procedures with REF CURSOR Parameters

  • Operations on Functions and Procedures with RECORD Types

  • Operations on Synonyms

  • Receiving Database Change Notifications

  • Support for Inbound Calls Using Polling

  • Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations

  • Support for Composite Operations

  • Support for Oracle User-Defined Types

See Also

Other Resources

Overview of BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Setting Application Context

In Microsoft BizTalk Adapter for Oracle E-Business Suite, setting application context is mandatory for some Oracle E-Business Suite artifacts (interface tables, interface views, concurrent programs, and request sets) before you can perform operations on them. The Oracle E-Business adapter does not allow you to perform operations on these artifacts until you have set the application context. However, for artifacts in the underlying Oracle database, it is up to the user whether they want to set the application context or not.

What is Application Context

Application context is a set of elements associated with an artifact in Oracle E-Business Suite that implements user preferences and access control on the artifact. Application context consists of the following elements:

  • User name: A user that can connect to Oracle E-Business Suite.

  • Responsibility: A responsibility is an access level in Oracle E-Business Suite that allows users to access only those data and functions that are appropriate to their roles in an organization. Responsibilities can allow access to a specific application, operating units, set of books, and a restricted list of windows, functions, and other responsibilities. By virtue of assigning responsibilities to a user, you can grant/restrict access of the user in Oracle E-Business Suite.

  • Organization ID: Oracle E-Business Suite supports setting up of multiple organizations. These different organizations are uniquely identified by a value, Organization ID, in the Org_ID column of the table in Oracle E-Business Suite that stores information about these organizations. By virtue of assigning a responsibility to an organization or selecting an organization explicitly, you can grant/restrict access of a user to an organization.

For more information about responsibility, multiple organizations, and Organization ID in Oracle E-Business Suite, consult the Oracle documentation at http://go.microsoft.com/fwlink/?LinkId=124538.

Setting Application Context

As the Oracle E-Business adapter connects to the underlying database in the Oracle E-Business Suite, application context for the Oracle E-Business Suite artifacts are not established or initialized in the adapter. You can initialize or set the application context for these artifacts in the Oracle E-Business adapter by using either of the following:

  • Binding properties: The Oracle E-Business adapter exposes the following binding properties for setting the application context: OracleEBSOrganizationId, OracleUserName, OraclePassword, OracleEBSResponsibilityKey, OracleEBSResponsibilityName, and ApplicationShortName. You do not need to specify values for all these binding properties to set application context for various artifacts. For information about the binding properties required for setting application context for an artifact, see Binding Properties for Setting Application Context later in this topic.

  • Message context properties: The Oracle E-Business adapter exposes the following message context properties for setting the application context: ApplicationShortName, OrganizationID, ResponsibilityKey, and ResponsibilityName. For specifying the user name and password, you must use the binding properties. For information about how to set application context using message context properties, see Set the Application Context Using Message Context Properties.

Important
The value specified for the OracleEBSResponsibilityKey binding property overrides the value of the OracleEBSResponsibilityName binding property. Similarly, the value specified for the ResponsibilityKey message context property overrides the value specified for the ResponsibilityName message context property.

Precedence Order (Binding Properties vs. Message Context Properties)

If you set the application context using both the binding properties and message context properties, the values specified for message context properties takes precedence and overrides the values specified for the binding properties. But, for example, if you specify the application short name as a message context property and the others as binding properties, only the value for the application short name is taken from the message context property and the rest are picked from the relevant binding properties.

Precedence Order for Application Short Name

While setting the application context, the application short name is used in the following precedence order (highest to lowest):

  • The application short name specified in the ApplicationShortName message context property.

  • The application short name specified in the SOAP action (for interface tables, interface views, concurrent programs, and request sets only).

  • The application short name specified in the ApplicationShortName binding property.

However, for interface tables, interface views, concurrent programs, and request sets, this precedence order is only applicable while setting the application context. To identify the interface tables, interface views, concurrent programs, and request sets, the application short name in the SOAP action is used.

Precedence Order for Responsibility Key and Responsibility Name

While setting the application context, the responsibility key and responsibility name are used in the following precedence order (highest to lowest):

  • The responsibility key specified in the ResponsibilityKey message context property.

  • The responsibility name specified in the ResponsibilityName message context property.

  • The responsibility key specified in the OracleEBSResponsibilityKey binding property.

  • The responsibility name specified in the OracleEBSResponsibilityName binding property.

Tip
Why use message context properties over binding properties to set the application context? If you set the application context using binding properties, the WCF-Custom send port for the Oracle E-Business adapter can be used only for the specific organization ID, responsibility, and application that you specified for the binding properties. On the contrary, if you use the message context property you can configure a “generic” WCF-Custom send port and set the application context at the message level.

Setting Application Context For Interface Tables, Interface Views, Concurrent Programs, and Request Sets (Mandatory)

You must set the application context before performing operations on interface tables, interface views, concurrent programs, and request sets in Oracle E-Business adapter. To do this, you have to provide appropriate values for the binding properties or the message context properties as specified earlier.

Important
You cannot perform operations on interface tables, interface views, concurrent programs, and request sets unless you have set appropriate values for the required binding properties or the message context properties.

Setting Application Context For PL/SQL APIs, Procedures, Functions, Tables, and Views

  • PL/SQL APIs: The Oracle E-Business adapter exposes PL/SQL APIs associated with the Oracle database as well as the Oracle E-Business Suite application. While it is optional to set the application context for the PL/SQL APIs associated with the Oracle database, it is mandatory to set the application context for the PL/SQL APIs associated with the Oracle E-Business Suite application.

  • Procedures and Functions: It is not mandatory to set the application context to perform operations on procedures and functions in the Oracle database.

  • Tables and Views: It is not mandatory to set the application context to perform operations on tables and views in the Oracle database. However, for custom Oracle E-Business Suite application, users may or may not register the base database tables as interface tables. If a database table is not registered as an interface table, it will be displayed along with the database tables in the Oracle E-Business adapter. Because these tables are associated with an Oracle E-Business application, for any operation on these tables you must set the application context.

To set the application context for these artifacts, you must provide appropriate values for the binding properties or the message context properties as specified earlier.

Setting Application Context For Poll, ExecuteNonQuery, ExecuteReader, ExecuteScalar, and Composite Operations

Apart from the artifacts, you can also set the application context for various operations that are performed on these artifacts.

  • To set the application context for the Poll operation, you can only use the binding properties as specified earlier. For setting application context, you must provide appropriate values for the binding properties that are applicable for the artifact on which the Poll operation is performed. For example, if the Poll operation is performed on an interface table then you must specify values for the binding properties for the interface table.

  • To set the application context for the ExecuteNonQuery, ExecuteReader, and ExecuteScalar operations, you must provide appropriate values for the binding properties or the message context properties as specified earlier. For setting application context for these operations, you must provide appropriate values for the binding properties or the message context properties that are applicable for the artifact on which the operations are performed.

  • To set the application context for composite operations, you must provide appropriate values for the binding properties or the message context properties as specified earlier. For setting application context for composite operations, you must provide appropriate values for the binding properties or the message context properties that are applicable for the individual operations. For example, if a composite operation contains two operations: one on the interface table and the other on the database table then you must specify values for the binding properties or the message context properties for the interface table as well as the binding properties or the message context properties for the database table.

    Important
    For all these operations, it is mandatory to set the application context if the operation is performed on an artifact in Oracle E-Business Suite (interface table, interface view, concurrent programs or request sets). If the operation is performed on an artifact in the underlying database, it is not mandatory to set the application context. For example, if you are performing the Poll operation on an interface table, it is mandatory to set the application context whereas if the Poll operation is performed on a table, it is not mandatory to set the application context.

Setting the Language for Performing Operations

The Oracle E-Business adapter supports the Multi-Language Support (MLS) feature of Oracle E-Business Suite, and allows you to specify a language while performing operations. The adapter exposes the Language binding property under the MlsSettings binding property and the Language message context property to specify a language for performing operations.

The value specified for the Language message context property overrides the value of the Language binding property under the MlsSettings binding property. For more information about the MlsSettings binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

Binding Properties for Setting Application Context For Various Artifacts

The following table provides information about the binding properties for which you must specify appropriate values to set application context for various artifacts:

Artifacts | OracleEBSOrganizationId | OracleUserName | OraclePassword | OracleEBSResponsibilityKey or OracleEBSResponsibilityName | ApplicationShortName
Interface Tables and Interface Views | √* | √ | √ | √ |
Concurrent Programs | √* | √ | √ | √ |
Request Sets | √* | √ | √ | √ |
PL/SQL APIs | √* | √ | √ | √ | √
Procedures and Functions | √* | √ | √ | √ | √
Tables and Views | √* | √ | √ | √ | √

√* = Optional

Important
  • The default value of the OracleEBSOrganizationId binding property (optional) is null. If you specify a value for the OracleEBSOrganizationId binding property, the Oracle E-Business adapter sets the ORG_ID of the session to this value while setting the application context.

  • The value specified for the OracleEBSResponsibilityKey binding property overrides the value specified for the OracleEBSResponsibilityName binding property.

For detailed information about each of these binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Interface Tables and Interface Views

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces a set of standard operations (Select, Insert, Update, and Delete) for each interface table, and the Select operation for each interface view in Oracle E-Business Suite. By using these operations, you can perform the SELECT, INSERT, UPDATE, and DELETE statements qualified by a WHERE clause on the target interface table, and the SELECT statement qualified by a WHERE clause on the target interface view. These operations are also called data manipulation language (DML) operations.

Important
Before you can perform operations on interface tables and interface views, you must set the applications context for these artifacts in Oracle E-Business adapter. This is because setting applications context facilitates secure transactions in Oracle E-Business Suite by setting user preferences (such as responsibility, organization, and language settings) and access control for an artifact. For more information about applications context and how to set it, see Setting Application Context.

The following table shows the DML operations that the Oracle E-Business adapter supports:

Operation Description

Select

Performs a Select Operation on the target interface table or interface view based on a supplied list of column names and a filter string that specifies a SQL WHERE clause.

The return value for a Select operation is a strongly-typed result set that contains the specified columns and rows.

Insert

Performs an Insert operation on the target interface table. The Insert operation supports multiple-record insert into the target interface table based on a supplied record set.

The return value for an Insert operation is the number of rows inserted.

InlineValue

For all simple data records in an Insert operation, you can choose to override the value of a record by specifying a value for an optional attribute called InlineValue. The InlineValue attribute can be used to insert computed values into interface tables such as populating the primary key column using a sequence or inserting system date (using SYSDATE) into a date column. For example, in the following INSERT statement:

Copy Code
<Insert xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/AR/AR_ARCHIVE_PURGE_INTERIM">
  <RECORDSET>
    <InsertRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/AR/AR_ARCHIVE_PURGE_INTERIM">
      <TRNS_DATE InlineValue="sysdate">2008-06-21T15:52:19</TRNS_DATE>
      <EMPNAME>John</EMPNAME>
    </InsertRecord>
  </RECORDSET>
</Insert>

Even though “2008-06-21T15:52:19” is specified as a value for TRNS_DATE, the value of the InlineValue attribute, “SYSDATE,” (system date) will be inserted into the target interface table.

While using the InlineValue attribute:

  • Avoid using constant values for the InlineValue attribute. For example, in the INSERT statement, if you specify <EMPNAME InlineValue="John"/> then it will result in an error. This is because the value of the InlineValue attribute is passed on as-is to Oracle, and in this case John is passed to Oracle E-Business Suite, which is not the expected value (expected value is ‘John’). You would have to use single quotes around the employee name. For example: <EMPNAME InlineValue="’John’"/>.

  • If you want to use a select query for the InlineValue attribute, you must enclose the SELECT statement in parentheses and also ensure that the select query fetches only a single record. For example: <EMPNAME InlineValue="(SELECT NAME FROM MS_SAMPLE_EMPLOYEES WHERE ID=123)"/>.

Note
If an element is marked as NOT NULL in Oracle E-Business Suite, you must specify a value for that element even if you have specified an inline value. Failing to do this will cause the schema validation to fail.

Update

Performs an Update operation on the target interface table. The records to be updated are specified by a filter string that specifies a SQL WHERE clause. The values for the update are specified in a template record.

The return value for an Update operation is the number of rows updated.

Delete

Performs a Delete operation on the target interface table based on a SQL WHERE clause that is specified in a filter string.

The return value for a Delete operation is the number of rows deleted.

Important
  • The Oracle E-Business adapter surfaces the same set of standard operations (Select, Insert, Update, and Delete) for each table, and the Select operation for each view in the underlying Oracle database. The above DML operations are also valid for the underlying Oracle database tables and views.

  • It is not mandatory to set the applications context to perform operations on tables and views in the Oracle database. However, for custom Oracle E-Business Suite applications, users may or may not register the base database tables as interface tables. If a database table is not registered as an interface table, it will be available under the Tables subnode in the Artifact-Based View node or in the Schema Based View node at design-time while using Consume Adapter Service Add-in, Add Adapter Metadata Wizard or Add Adapter Service Reference Plug-in. Because these tables are associated with an Oracle E-Business application, for any operation on these tables you must set the application context. For more information about applications context and how to set it, see Setting Application Context.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on PL/SQL APIs

Oracle E-Business Suite provides a set of PL/SQL APIs in the form of packaged functions and stored procedures. These packaged functions and procedures are surfaced as operations in Microsoft BizTalk Adapter for Oracle E-Business Suite. The PL/SQL APIs are grouped by schema names under the Artifact-Based View and Schema-Based View nodes when you connect to Oracle E-Business Suite using Consume Adapter Service Add-in, Add Adapter Metadata Wizard or Add Adapter Service Reference Plug-in. For information about browsing the PL/SQL APIs in the Oracle E-Business adapter, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

The Oracle E-Business adapter displays the PL/SQL APIs associated with the Oracle database as well as the applications in Oracle E-Business Suite under the Artifact-Based View and Schema-Based View nodes.

Important
  • Before you can perform operations on PL/SQL APIs associated with applications in Oracle E-Business Suite, you must set the applications context. This is because setting applications context facilitates secure transactions in Oracle E-Business Suite by setting user preferences (such as responsibility, organization, and language settings) and access control for an artifact. However, it is optional to set the applications context for PL/SQL APIs associated with Oracle database. For information about applications context, and how to set it, see Setting Application Context.

  • The Oracle E-Business adapter cannot ascertain whether or not a default value is assigned for a parameter in a PL/SQL API in Oracle. Moreover, the adapter also cannot ascertain whether a parameter is defined as mandatory or optional in a PL/SQL API in Oracle. The adapter treats every parameter as an optional parameter, and if no value is specified for a parameter that:

    • Has a default value specified in Oracle then the default value is used.

    • Is defined as a mandatory parameter in Oracle then an exception is thrown.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Concurrent Programs

Concurrent programs in Oracle E-Business Suite are surfaced as operations in Microsoft BizTalk Adapter for Oracle E-Business Suite. Along with the concurrent programs specific to an Oracle application, the Oracle E-Business adapter also surfaces the following three standard operations: Get_Status, Wait_For_Request, and Submit_Request. This implies that if an Oracle application has two concurrent programs, five operations will be exposed: one for each concurrent program, and three for the standard operations.

For information about:

  • Browsing and searching concurrent programs, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

  • How to invoke concurrent programs in the Oracle E-Business adapter, see Invoking Concurrent Programs in Oracle E-Business Suite Using BizTalk Server.

Important
You must set the applications context for concurrent programs in Oracle E-Business adapter before you can perform any operations on concurrent programs. This is because setting applications context facilitates secure transactions in Oracle E-Business Suite by setting user preferences (such as responsibility, organization, and language settings) and access control for an artifact. For information about applications context, and how to set it, see Setting Application Context.

The following sections provide information about the operations exposed by the Oracle E-Business adapter for concurrent programs.

<Concurrent_Program_Name> Operation

As mentioned earlier, there will be as many <Concurrent_Program_Name> operations as the number of concurrent programs in an Oracle Aapplication. The <Concurrent_Program_Name> operation takes five standard parameters: three of complex type and two of simple type.

Note
For the concurrent programs that do not expose their metadata, the Oracle E-Business adapter exposes 100 optional parameters for each of these concurrent programs. To invoke these concurrent programs successfully, the user must consult the Oracle E-Business Suite documentation to figure out the parameters for a concurrent program that require a value, and then specify them. An example of such a concurrent program is Journal Import (actual name: GLLEZL) in the General Ledger application.

Complex type parameters

  • SetOptions: Enables you to set options for the concurrent program before submitting the request. SetOptions takes the following options as parameters:

    • Implicit: Indicates whether to display the concurrent request in the user’s Concurrent Requests form in Oracle E-Business Suite. You can specify any of the following four values: No, Yes, Error or Warning. Specifying No causes the requests to be displayed in the user’s Concurrent Requests form in Oracle E-Business Suite. Specifying Yes implies that the request may be viewed only from the system administrator's privileged Concurrent Requests form. Specifying Error causes the request to be displayed in the user’s Concurrent Requests form only if it fails. Specifying Warning causes the request to display in the user’s Concurrent Requests form only if it there is a warning or an error.

    • Protected: Indicates whether the concurrent request is protected against updates made using the Concurrent Requests form in Oracle E-Business Suite. You can specify Yes (protected) or No (not protected).

    • Language: Indicates the National Language Support (NLS) language. If no value is specified, it defaults to the current language.

    • Territory: Indicates the language territory. If no value is specified, it defaults to the current language territory.

    • ContinueOnFail: Indicates whether the concurrent request submission should continue or throw an exception in case SetOptions fails. You can specify True (continue) or False (throw an exception).

  • SetPrintOptions: Enables you to set the print options for the concurrent program before submitting the request. SetPrintOptions takes the following options as parameters:

    • Printer: Indicates the printer name where the concurrent request output should be sent. You cannot override this print option if it is already set in the Concurrent Programs form in Oracle E-Business Suite.

    • Style: Indicates the print style used to print the concurrent request output. For example, you can specify the orientation (Landscape or Portrait). If the print style is already set in the Concurrent Programs form in Oracle E-Business Suite, and the Style Required check box is selected, you cannot override this print option.

    • Copies: Indicates the number of copies to be printed of the concurrent request output.

    • SaveOutput: Indicates whether or not to save the output file. You can specify Yes or No.

    • PrintTogether: Applicable only for those requests that contain sub-requests. Indicates how the output of sub-requests is printed. If you specify Y, the output of sub-requests is printed only after all the sub-requests are complete. If you specify N, the output of each sub-request is printed as it completes.

    • ContinueOnFail: Indicates whether the concurrent request submission should continue or throw an exception in case SetPrintOptions fails. You can specify True (continue) or False (throw an exception).

  • SetRepeatOptions: Enables you to set the repeat options for the concurrent program before submitting the request. SetRepeatOptions takes the following options as parameters:

    • RepeatTime: Indicates the time of day to repeat the concurrent request.

    • RepeatInterval: This parameter is applicable only when RepeatTime is NULL. Indicates the interval between resubmissions of the request. Use this option along with RepeatUnit to specify the time between resubmissions.

    • RepeatUnit: This parameter is applicable only when RepeatTime is NULL. The unit of time used along with RepeatInterval to specify the time between resubmissions of the request. You can specify Minutes, Hours, Days or Months.

    • RepeatType: This parameter is applicable only when RepeatTime is NULL. Indicates whether the repeat interval is applied after the “start” of a concurrent request execution or after the “end” of a concurrent request execution.

    • RepeatEndTime: Indicates the date and time to stop resubmitting the concurrent request.

    • ContinueOnFail: Indicates whether the concurrent request submission should continue or throw an exception in case SetRepeatOptions. You can specify True (continue) or False (throw an exception).

Simple Type Parameters

  • Description: Description of the concurrent request.

  • StartTime: Indicates the time at which the concurrent request should start running.

Get_Status operation

The standard operation, Get_Status, returns the request phase/status and the completion message of a concurrent program. This operation takes the request ID of a concurrent program (RequestID) as an input, and then returns the following information:

  • Phase: The user-friendly request phase from FND_LOOKUPS.

  • Status: The user-friendly request status from FND_LOOKUPS.

  • DevPhase: The request phase as a string that can be used for program logic comparisons.

  • DevStatus: The request status as a string that can be used for program logic comparisons.

  • Message: The completion message if the request has completed.

Wait_For_Request operation

The standard operation, Wait_For_Request, waits for request completion, and then returns the request phase/status and the completion message. This operation takes the request ID of a concurrent program (RequestID), the number of seconds to wait between checks (Interval), and the maximum time in seconds to wait for the request's completion (MaxWait) as input parameters, and then returns the same information as in the Get_Status operation.

Submit_Request operation

The standard operation, Submit_Request, submits a concurrent request for processing by a concurrent manager. If the request completes successfully, this operation returns the concurrent request ID. Otherwise, it returns “0”.

The Submit_Request operation takes six standard parameters: three each of complex type simple type. Apart from these parameters, it also takes the arguments of the concurrent program as an array of string.

Complex type parameters

The Submit_Request operation takes SetOptions, SetPrintOptions, and SetRepeatOptions as input parameters. For information about these parameters, see <Concurrent_Program_Name> Operation earlier in this section.

Simple type parameters

  • Program: Short name of the concurrent program for which the request should be submitted.

  • Description: Description of the concurrent request.

  • StartTime: The time at which the concurrent request should start running.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Request Sets

A request set in Oracle E-Business Suite is a set of reports and concurrent programs that are organized into various stages. You can use a single request set to run a set of reports and concurrent programs. Request sets are divided into one or more stages, and each stage contains a set of reports and concurrent programs. These stages are linked with each other, and the order of the execution of each stage is defined. For more information about request sets, see ttp://go.microsoft.com/fwlink/?LinkId=129539.

Microsoft BizTalk Adapter for Oracle E-Business Suite enables you to execute request sets in Oracle E-Business Suite. The request sets are exposed as operations in the Oracle E-Business adapter. Since a request set contains a set of concurrent programs, those concurrent programs are the input parameters for a request set operation. Along with the concurrent programs, the request set operation takes four complex type parameters and a simple type parameter as input.

Important
You must set the applications context for request sets in Oracle E-Business adapter before you can perform any operations on request sets. This is because setting applications context facilitates secure transactions in Oracle E-Business Suite by setting user preferences (such as responsibility, organization, and language settings) and access control for an artifact. For information about applications context, and how to set it, see Setting Application Context.

Complex type parameters

  • SetRelClassOptions: Enables you to set scheduling options for the request set. If both SetRelClassOptions and SetRepeatOptions are set then SetRelClassOptions will take precedence. SetRelClassOptions takes the following options as parameters:

    • Application: Indicates the short name of the application associated with the request set.

    • ClassName: Indicates the name of the class associated with the request set.

    • CanceOrHold: Indicates the Cancel or Hold flag.

    • StaleDate: Indicates the date on or after which this request set will be canceled if the request set has not yet run.

    • ContinueOnFail: Indicates whether the request set submission should continue or throw an exception in case SetRelClassOptions fails. You can specify “True” (continue) or “False” (throw an exception).

  • SetPrintOptions: Enables you to set the print options for the request set. SetPrintOptions takes the following options as parameters:

    • Printer: Indicates the printer name where the request set output should be sent.

    • Style: Indicates the print style used to print the request set output. For example, you can specify the orientation (“Landscape” or “Portrait”).

    • Copies: Indicates the number of copies to be printed of the request set output.

    • SaveOutput: Indicates whether or not to save the output file. You can specify “True” or “False”.

    • PrintTogether: Applicable only for sub-requests. Indicates how the output of sub-requests is printed. If you specify “Y”, the output of sub-requests is printed only after all the sub-requests are complete. If you specify “N”, the output of each sub-request is printed as it completes.

    • ContinueOnFail: Indicates whether the request set submission should continue or throw an exception in case SetPrintOptions fails. You can specify “True” (continue) or “False” (throw an exception).

  • SetRepeatOptions: Enables you to set the repeat options for the request set. SetRepeatOptions takes the following options as parameters:

    • RepeatTime: Indicates the time of day to repeat the request set.

    • RepeatInterval: This parameter is applicable only when RepeatTime is NULL. Indicates the interval between resubmissions of the request. Use this option along with RepeatUnit to specify the time between resubmissions.

    • RepeatUnit: This parameter is applicable only when RepeatTime is NULL. The unit of time used along with RepeatInterval to specify the time between resubmissions of the request. You can specify “Minutes”, “Hours”, “Days” or “Months”.

    • RepeatType: This parameter is applicable only when RepeatTime is NULL. Indicates whether the repeat interval is applied after the “start” of a previous request set execution or after the “end” of a previous request set execution.

    • RepeatEndTime: Indicates the date and time to stop resubmitting the request set.

    • ContinueOnFail: Indicates whether the request set submission should continue or throw an exception in case SetRepeatOptions fails. You can specify “True” (continue) or “False” (throw an exception).

  • SetNlsOptions: Enables you to set the NLS options for the request set. SetNlsOptions takes the following options as parameters:

    • Language: Indicates the NLS language.

    • Language: Indicates the language territory.

    • ContinueOnFail: Indicates whether the request set submission should continue or throw an exception in case SetNlsOptions fails. You can specify “True” (continue) or “False” (throw an exception).

Simple type parameter

StartTime: Indicates the time at which the request set should start running.

If the request set completes successfully, a concurrent request ID is returned. Otherwise, “0” is returned.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Interface Tables, Interface Views, Tables, and Views That Contain LOB Data

The Microsoft BizTalk Adapter for Oracle E-Business Suite provides support for the Oracle large object (LOB) data types:

  • Binary large object (BLOB)

  • Character large object (CLOB)

  • National character large object (NCLOB)

  • Binary file (BFILE). For more information, see Operations on Tables That Contain BFILE Data Types.

In the underlying Oracle database, LOB data types are used to store large amounts of data, up to 4 gigabytes (GB). Except for the BFILE data type, LOB data types support both input and output streaming.

The Oracle E-Business adapter surfaces the following operations for interface tables, interface views, tables and views that contain LOB columns:

  • Read_<LOBColName>: The Read_<LOBColName> operation is surfaced for interface tables, interface views, tables and views that contain BLOB, CLOB, NCLOB, and BFILE columns, where <LOBColName> is the name of the column of type BLOB, CLOB, NCLOB or BFILE. By using the Read_<LOBColName> operation, adapter clients can read values in an LOB column as a data stream. This operation takes a filter string as parameter.

    Note
    The Read_<LOBColName> operation is designed to support input streaming of LOB data in the WCF service model. You should use a table Select operation to read LOB data from a WCF channel model or BizTalk Server solution.

  • Update_<LOBColName>: The Update_<LOBColName> operation is surfaced for interface tables and tables only that contain BLOB, CLOB, and NCLOB columns, where <LOBColName> is the name of the column of type BLOB, CLOB, and NCLOB. By using the Update_<LOBColName> operation, adapter clients can update values in an LOB column. For the BLOB data type, this operation takes base64binary encoded data as the parameter, whereas for the CLOB and NCLOB data types, this operation takes a string filter as the parameter.

    Note
    The Update_<LOBColName> operation:

    • Is not supported for the BFILE data type. Adapter clients can alternatively use the Update operation. For more information, see Operations on Tables That Contain BFILE Data Types.

    • Is not exposed for interface views and views.

    • Must be performed as part of a transaction. To ensure this, the UseAmbientTransaction binding property must be set to True. For information about the UseAmbientTransaction binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

Important
The Oracle E-Business adapter surfaces a Read_<LOBColName> and an Update_<LOBColName> operation for each LOB column in a table. So, if there are two LOB columns in a table (LOBCol1 and LOBCol2), you will have two Read_<LOBColName> operations (Read_LOBCol1 and Read_LOBCol2) and two Update_<LOBColName> operations (Update_LOBCol1 and Update_LOBCol2).

For more information about:

  • Invoking the Read_<LOBColName> and Update_<LOBColName> operations on a table in the underlying database in Oracle E-Business Suite using BizTalk Server, see Performing Operations on Tables with Large Data Types Using BizTalk Server.

  • Message structure and SOAP actions for performing Read_<LOBColName> and Update_<LOBColName> operations, see Message Schemas for Special LOB Operations.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Tables That Contain BFILE Data Types

The Microsoft BizTalk Adapter for Oracle E-Business Suite supports the BFILE data type in tables and stored procedures. The following table summarizes the BFILE data type exposed by the adapter based on the operation performed and the LOB artifact (table/procedure) accessed:

Artifact | Operation | Data type exposed for BFILE col/param | Comments
TABLE | INSERT | String | Represents the logical Oracle directory path to the file to be inserted into the BFILE column E.g. MYDIR/screen.jpg where MYDIR is a logical directory in Oracle
TABLE | UPDATE | String | Represents the logical Oracle directory path to the file to be updated into the BFILE column
TABLE | SELECT | byte[] | Represents the binary data constituting the BFILE
STORED PROC | IN PARAM | String | Represents the logical Oracle directory path to the file to be inserted into the BFILE column E.g. MYDIR/screen.jpg where MYDIR is a logical directory in Oracle
STORED PROC | OUT PARAM | String | Represents the logical Oracle directory path to the file to be inserted into the BFILE column E.g. MYDIR/screen.jpg where MYDIR is a logical directory in Oracle
STORED PROC | INOUT PARAM | Not Supported | -

The special operation Read_<LOBColName> is also supported on tables with BFILE data type, where <LOBColName> is the LOB column name in the table. The Update_<LOBColName> operation is not supported for BFILE data type. Adapter clients can alternately use the Update operation.

For information about:

  • The Read_<LOBColName> and Update_<LOBColName> operations, see Operations on Interface Tables, Interface Views, Tables, and Views That Contain LOB Data.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Functions and Stored Procedures

The Microsoft BizTalk Adapter for Oracle E-Business Suite supports Oracle functions and procedures in the following manner:

  • Functions are surfaced as operations. The name of the operation is the name of the Oracle function. IN, OUT, and IN OUT parameters are supported, as well as, RETURN values.

    Important
    If you pass an invalid parameter in a function (that is, pass a string value for a numeric field), the Oracle E-Business adapter might throw an exception depending on the ODP.NET behavior. This is because the Oracle E-Business adapter uses ODP.NET to communicate with Oracle E-Business Suite.

  • Procedures are surfaced as operations. The name of the operation is the name of the Oracle procedure. IN, OUT, and IN OUT parameters are supported.

    Important
    As part of a procedure, if you insert or update a decimal value (for example, 15.2) into a numeric field of an interface table or database table, the Oracle E-Business adapter will throw an exception. This is because the Oracle E-Business adapter uses ODP.NET to communicate with Oracle E-Business Suite, and ODP.NET does not support accepting decimal values for the numeric fields.

  • REF CURSOR types are supported for IN and OUT parameters for procedures and functions, as well as for function RETURN values. For more information, see Operations on Functions and Procedures with REF CURSOR Parameters.

  • RECORD types are supported for IN, OUT, and IN OUT parameters for procedures and functions, as well as for function RETURN values. Both simple and complex (nested) RECORD types are supported. Operations on Functions and Procedures with RECORD Types

Note
You can also set the applications context for functions and stored procedures in Oracle E-Business adapter. For information about applications context, and how to set it, see Setting Application Context.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Functions and Procedures with REF CURSOR Parameters

A REF CURSOR is a PL/SQL data type that represents a pointer to a server-side result set generated by executing a query. A REF CURSOR type enables input and output streaming of data and is ideal for transferring large amounts of data to and from a PL/SQL code. The Microsoft BizTalk Adapter for Oracle E-Business Suite provides support for strongly-typed and weakly-typed (SYS_REFCURSOR) REF CURSORs that can be passed to PL/SQL procedures and functions as IN and OUT parameters.

  • IN REF CURSOR. Adapter clients must use an IN REF CURSOR by supplying a PL/SQL code (as string) that opens REF CURSOR on the Oracle database. The adapter creates variable and sets it the opened REF CURSOR and calls a function or procedure with that variable. Therefore, IN REF CURSOR parameters in PL/SQL stored procedure and functions should be represented as strings that take a PL/SQL code block as input value marking the OUT REF CURSOR variable with a "?".

  • OUT REF CURSOR. OUT REF CURSOR parameters are returned as either strongly-typed or weakly-typed result sets. The type of the result set returned depends on whether the REF CURSOR parameter is declared as a strongly-typed or weakly-typed REF CURSOR in the stored procedure or function definition on the Oracle server.

  • IN OUT REF CURSOR parameters. Because the Oracle E-Business adapter models IN REF CURSOR parameters as strings and OUT REF CURSOR parameters as complex types, it cannot support a single type for an IN OUT REF CURSOR parameter. For this reason, it treats IN OUT REF CURSOR parameters as two different parameters: an IN parameter in the request message and an OUT parameter in the response message.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Functions and Procedures with RECORD Types

Oracle RECORD types are used to represent hierarchical information in parameters passed to PL/SQL functions and procedures. The Microsoft BizTalk Adapter for Oracle Database surfaces RECORD types as complex XML types. The Microsoft BizTalk Adapter for Oracle E-Business Suite supports the following kinds of RECORD types:

  • RECORD types that are declared as TABLE%ROWTYPE parameters in stored procedures and functions.

  • RECORD types that are declared as TYPE of RECORD parameters in PL/SQL packages. For example, TYPE rec_type1 IS RECORD(name varchar2(100), age number(3));

  • RECORD types that contain nested records.

  • RECORD types that appear as IN, OUT, or IN OUT parameters to procedures or functions.

  • RECORD types that are RETURN values of functions.

    Note
    The Oracle E-Business adapter does not support BFILE types as RECORD members.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Operations on Synonyms

The Oracle E-Business adapter allows you to perform operations on synonyms. A synonym is an alias or friendly name for the database objects (such as tables, views, stored procedures, functions, and packages). For more information about synonyms in Oracle, see http://go.microsoft.com/fwlink/?LinkId=138058.

Advantages of Using Synonyms

Synonyms are helpful in the following scenarios:

  • Working with different schemas: If you are working with different schemas, and need to access the objects across schemas, you have to use different SQL statements to access those objects. You can create a synonym for an object in a schema, and use the synonym in your SQL statement to access the object. If you need to access the underlying object in a different schema, modify the definition of the synonym to point to the object in a different schema. Thus, the applications based on the synonym continue to function without modification in the SQL statement.

    For example, suppose you have two identical schemas for your test and production environments: “Test” and “Prod.” To access a table called “Employee” in the “Test” schema, you must use Test.Employee or Employee (if “Test” is the default schema) in your SQL statement. If you want to use the “Employee” table in the production schema, you must now use Prod.Employee or Employee (change the default schema to “Prod”) in your SQL statement. To get around this issue, you can create a synonym for the “Test.Employee” table (say “EMP”), and then use it in your SQL statements. Whenever you need to perform operation on the “Prod.Employee” table, modify the definition of the “EMP” synonym to point it to the “Prod.Employee” table. This ensures that you do not have to modify your SQL statements to perform operation on the object in different schemas.

  • Changes in the underlying objects: The synonyms insulate you from any changes in the name or location of the underlying objects on which you are performing an operation. You can modify the synonym definition to accommodate any changes in the name or location of the underlying objects.

    For example, suppose that you are using a table in one of your stored procedures. Now, if the table name changes or the table is moved to some other location then your stored procedure will stop working. To work around this, you can use a synonym for the table in the stored procedure, and update the synonym definition if there is a change in the name or location of the table.

  • Simplified and secure access: In a distributed environment, you must use the schema name along with the object names to ensure that you are accessing the correct object. Moreover, you must also ensure that the user has required privileges on the target object. To simplify this, you can assign a simple name for an object by creating a synonym that has the full qualified path to the object, and then grant appropriate privileges on the synonym.

Working with Synonyms in the Adapter

The Oracle E-Business adapter exposes the synonyms in Oracle for:

  • Tables

  • Views

  • Stored Procedures

  • Functions

  • Packages

The synonyms for each of these artifacts are exposed alongside the respective underlying artifact in the Consume Adapter Service Add-in, Add Adapter Metadata Wizard, and Add Adapter Service Reference Plug-in. For example, the Tables node under the Schema-based view will display all the synonyms for tables along with the database tables in a schema, the Views node under the Schema-based view will display all the synonyms for views along with the database views in a schema, and so on.

  • For synonyms created on tables and views, the same operations are exposed as for the underlying tables and views respectively. For example, if the underlying tables and views contain LOB columns, the synonyms for those tables and views will also expose the Read_<LOBColName> and Update_<LOBColName> operations for table synonyms and the Read_<LOBColName> operation for the view synonyms.

  • For synonyms created on stored procedures, functions, and packages, the synonyms are exposed as operations alongside the respective underlying stored procedures, functions, and packages in a schema.

Note
The Oracle E-Business adapter supports only local synonyms. This implies that only those synonyms are supported by the adapter that target the artifacts on the local server.

Moreover, the message actions for the synonyms are the same as the underlying object except for the artifact name on which the action is performed. For example, the message action for the Select operation on a table in the SCOTT schema is: Tables/Select/SCOTT/[TABLE_NAME]. If you are performing a Select operation on a synonym for the same table in the SCOTT schema then the message action will be: Tables/Select/SCOTT/[SYNONYM_NAME].

When you invoke an operation on a synonym in the adapter, the adapter calls the synonym in the Oracle database to execute the operation. However, the adapter uses the underlying object name in the synonym definition to fetch the metadata.

Synonyms can be used in normal outbound operations, composite operations, and polling.

Note
You can search for synonyms in Consume Adapter Service Add-in or Add Adapter Service Reference Plug-in just like other objects. However, you cannot search for procedures inside synonym packages from a skip-level node as you can do for the procedures inside packages. For information about searching for operations in the adapter, see Searching for Operations.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Receiving Database Change Notifications

The Microsoft BizTalk Adapter for Oracle E-Business Suite supports the ODP.NET Database Change Notification feature. Using this feature, the adapter clients can register a SELECT statement as the notification query on the database, and the database sends a notification to the adapter client as and when the result set of the SELECT statement changes. The database change notification is implemented in the adapter using the OracleDependency class. For more information about the Database Change Support feature in ODP.NET and the OracleDependency class, see http://go.microsoft.com/fwlink/?LinkId=124801.

The Oracle E-Business adapter exposes an inbound operation, Notification, to support database change notification. However, for the database change notification to work with Oracle E-Business adapter, you must ensure the following:

  • Connect to Oracle E-Business Suite with the underlying Oracle database version 10.2 or later. Oracle database versions prior to 10.2 do not support notifications.

  • Connect to Oracle E-Business Suite as a user that has the CHANGE NOTIFICATION privilege to create a notification registration. To grant the CHANGE NOTIFICATION privilege to a user, connect to the Oracle database as a user with administrative privileges, and run the following command at the SQL prompt:

    Copy Code
    grant change notification to <user name>
  • Decide on a TCP port that can be used by ODP.NET to receive database change notifications from Oracle database. Add the TCP port to Windows Firewall exceptions list. For instructions on how to add ports to Windows Firewall exceptions list, see http://go.microsoft.com/fwlink/?LinkID=196959. You must provide the same TCP port number for the NotificationPort binding property. For more information about the binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

A typical database change notification using the Oracle E-Business adapter involves the following:

  1. The adapter clients must specify Notification as the inbound operation in the InboundOperationType binding property. The default value for this binding property is Polling.

  2. The adapter clients must specify a SQL SELECT statement to register for database change notifications in the NotificationStatement binding property. The adapter client gets a notification from Oracle database as and when the result set for the specified SQL statement changes.

  3. The adapter clients must specify whether the adapter sends a notification to the adapter clients as soon as the listener is started in the NotifyOnListenerStart binding property.

  4. The notification is sent to the adapter clients as and when the result set of the SELECT statement specified in the NotificationStatement binding property is changed.

Caution
If there is a network outage between the Oracle database and the adapter client, the notifications will not be sent to the adapter clients for the changes done on the Oracle database during the period of network outage, and thereafter. Therefore, you must use the Polling operation instead of the Notification operation for critical scenarios.

Differences between Notification and Polling

Though notification and polling are both inbound operations, and inform the adapter clients about the data changes in the Oracle database, the following table illustrates some differences between the two. The following differences will help you decide on an operation depending on your requirements:

Notification Polling

Notification is supported only for Oracle database versions 10.2 and later.

Polling is supported for all the Oracle database versions that are supported by the Oracle E-Business adapter.

The data-change notification is always instantaneous.

You can either configure the polling interval to check the data available for polling at regular intervals or instantaneously as and when the data is available.

Tip
Polling can give you better throughput in scenarios where the data changes are happening continuously, and you do not want to be notified of each change as and when it happens. Instead, you specify a polling interval after which you want to be notified of all the changes that have happened since the last change notification.

Notification is initiated by the Oracle database. The notification statement issued by the adapter just instructs the database to initiate notification in case there is a change in the result set of the statement. Notification is a feature of the Oracle database.

Polling is initiated by the adapter. The adapter executes a SQL statement to validate whether data is available for polling, and then initiates polling by executing the polling statement if some data is available for polling.

You can use the notification statement to only read data in an Oracle database.

You can use the polling statement to read or update data in the Oracle database.

Notification informs only about the type of change in the data such as Insert, Update, and Delete.

Polling informs you about the actual data that has changed.

For more information about:

  • The binding properties related to the Notification operation, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

  • How to use the Notification operation in Oracle E-Business adapter, see Receiving Database Change Notifications Using BizTalk Server.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Support for Inbound Calls Using Polling

The Microsoft BizTalk Adapter for Oracle E-Business Suite enables client programs to receive messages from Oracle E-Business Suite informing them of changes to data in Oracle E-Business Suite. The Oracle E-Business adapter supports receiving "polling-based" messages wherein the adapter executes a specified SQL statement, stored procedure, function or a procedure within a package, retrieves the data, and provides the result to the client at regular intervals of time.

Note
You can also set the applications context for the Poll operation in Oracle E-Business adapter. It is mandatory to set the applications context for the Poll operation if the operation is performed on an interface table or interface view. For information about applications context, and how to set it, see Setting Application Context.

A typical polling operation using the Oracle E-Business adapter involves the following:

  1. The adapter clients must specify Polling as the inbound operation in the InboundOperationType binding property. The default value for this binding property is Polling.

  2. The adapter clients must specify a SELECT statement for the PolledDataAvailableStatement binding property to determine whether there is data available for polling. If the first column of the first row of the first result set returned on execution of this statement contains a positive integer value, there is date available for polling.

  3. The adapter clients must specify a polling interval for the PollingInterval binding property to define the interval in seconds at which the statement specified in the PolledDataAvailableStatement binding property is executed. At the end of every polling interval, the polled data available statement is executed, and the result set is returned.

  4. The adapter clients must specify a SELECT statement or a stored procedure for the PollingInput binding property. If you want to poll a table or view, you must specify a SELECT statement for this binding property. If you want to poll using a stored procedure, you must specify the entire request message for this binding property.

    The statement in the PollingInput binding property is executed only if there is data available for polling, which is determined by the PolledDataAvailableStatement binding property in step 2.

  5. The adapter clients must specify an action for the polling operation in the PollingAction binding property. The polling action for a specific operation is determined from the metadata generated for the operation using the Consume Adapter Service Add-in.

  6. The adapter clients can use the PollWhileDataFound binding property to ignore the polling interval, and continuously poll data, as and when available.

    Important
    If you set the value of the PollWhileDataFound binding property to True, the adapter clients continuously poll data from Oracle and in the process open and close connections to the Oracle database in a loop. As the rate at which connections are opened by ODP.NET is greater than the connections being closed, the connections get exhausted after some time, and an exception is thrown. As a work around, make sure that the value of the UseOracleConnectionPool is set to True, and an appropriate value is mentioned in the IncrPoolSize binding property to control the number of connections that can be opened by the adapter clients.

  7. The adapter clients can specify a post-poll statement, an Oracle PL/SQL block, for the PostPollStatement binding property. The statement specified in this binding property is executed after the statement specified in the PollingInput binding property is executed.

    Note
    The adapter executes the statement specified in the PollingInput and PostPollStatement binding properties in a transaction. For more information about transactions in the Oracle E-Business adapter, see How does the Adapter Handle Transactions?.

The adapter suppresses any empty polling responses coming from Oracle E-Business Suite.

The illustration below provides information about the polling workflow in Oracle E-Business adapter. Two scenarios for the polling workflow are illustrated:

  1. When the value of the PollWhileDataFound is set to “False” (default setting).

  2. When the value of the PollWhileDataFound is set to “True.”

Polling Scenario (PollWhileDataFound=False) Polling Scenario (PollWhileDataFound = True)

Differences between Polling and Notification

Though polling and notification are both inbound operations, and inform the adapter clients about the data changes in the Oracle database, the following table lists some differences between the two. The following differences will help you decide on an operation depending on your requirements:

Polling Notification

Polling is supported for all the Oracle database versions that are supported by the Oracle E-Business adapter.

Notification is only supported for Oracle database versions 10.2 and later.

You can either configure the polling interval to check the data available for polling at regular intervals or instantaneously as and when the data is available.

Tip
Polling can give you better throughput in scenarios where the data changes are happening continuously, and you do not want to be notified of each change as and when it happens. Instead, you specify a polling interval after which you want to be notified of all the changes that have happened since the last change notification.

The data-change notification is always instantaneous.

Polling is initiated by the adapter. The adapter executes a SQL statement to validate whether data is available for polling, and then initiates polling by executing the polling statement if some data is available for polling.

Notification is initiated by the Oracle database. The notification statement issued by the adapter just instructs the database to initiate notification in case there is a change in the result set of the statement. Notification is a feature of the Oracle database.

You can use the polling statement to read or update data in the Oracle database.

You can use the notification statement to only read data in an Oracle database.

Polling informs you about the actual data that has changed.

Notification informs only about the type of change in the data such as Insert, Update, and Delete.

For more information about:

  • The binding properties related to polling, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

  • Receiving polling-based messages using BizTalk Server, see Polling Oracle E-Business Suite Using BizTalk Server.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations

The Microsoft BizTalk Adapter for Oracle E-Business Suite exposes the following outbound operations at the root level:

  • ExecuteNonQuery: Use this operation to execute any arbitrary SQL statements or PL/SQL blocks in Oracle E-Business Suite if you want to return multiple result sets. The input parameters of this function include a string parameter (the entire PL/SQL block to be executed) and an array of strings (OutRefCursorNames). Each string value specified in OutRefCursorNames is assumed to be the parameter name of an output REF CURSOR with the PL/SQL block returning REF CURSORS with the same names. This function also takes an OUT parameter (OutRefCursors), which is an array of DataSets. For information about DataSet, consult the Oracle documentation at http://go.microsoft.com/fwlink/?LinkId=124538. The return value of this operation is of integer data type, and indicates the number of affected rows.

  • ExecuteReader: Use this operation to execute any arbitrary SQL statements or PL/SQL blocks in Oracle E-Business Suite if you want the result set to be returned as DataSet. This operation takes a string parameter as input, and returns a DataSet.

  • ExecuteScalar: Use this operation to execute any arbitrary SQL statements or PL/SQL blocks in Oracle E-Business Suite if you want only one value to be returned. If the return value is a result set, only the value in the first column of the first row is returned in a XML string format.

Note
  • The ExecuteNonQuery, ExecuteReader, and ExecuteScalar operations are not supported for the User Defined Types (UDTs).

  • You can also set the applications context for the ExecuteNonQuery, ExecuteReader, and ExecuteScalar operations in Oracle E-Business adapter. It is mandatory to set the applications context for the ExecuteNonQuery, ExecuteReader, and ExecuteScalar operations if any of the operation is targeted on an artifact in Oracle E-Business Suite (interface table, interface view, concurrent programs or request sets). For information about applications context, and how to set it, see Setting Application Context.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Support for Composite Operations

The Oracle E-Business adapter enables adapter clients to perform composite operations that can include any number of the following operations, and in any order:

  • Select, Insert, Update, and Delete operations on an interface table and database table.

  • Select operation on an interface view and database view.

  • Stored procedures, functions, and procedures within packages that are surfaced as operations in the adapter.

The operations in a composite operation can target tables and views in the same database or different databases. However, data cannot be shared or reused across different operations in a composite operation. For example, in a composite operation, the result set of a Select operation cannot be used as the input parameter for a stored procedure.

Each operation in a composite operation is performed using a separate connection. The Oracle E-Business adapter consumes as many connections from the ODP.NET connection pool as the number of operations in a composite operation, and then releases the connections as the operations get executed. However, if an operation in the composite operation returns a result set, the connection is released only after the message is consumed.

Important
If you experience time-out issues while executing a composite operation then it could be because the number of connections is less than the number of operations in a composite operation involving:

  • Stored procedures containing BFILE, BLOB, CLOB, NCLOB, and REF CURSOR as OUT or IN OUT parameters.

  • Select operation.

To resolve this issue, you must ensure that if there are “n” number of such operations in a composite operation, the value specified for the MinPoolSize binding property is “n+1” or greater. For more information about the MinPoolSize binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

For information about:

  • How to perform composite operations in Oracle E-Business adapter using BizTalk Server, see Performing Composite Operations on Oracle Database by Using BizTalk Server.

  • Message schemas for the composite operation, see Message Schemas for the Composite Operation.

Note
You can also set the applications context for composite operations in the Oracle E-Business adapter. It is mandatory to set the applications context for the composite operations if any of the operations in a composite operation is performed on an interface table or interface view. For information about applications context, and how to set it, see Setting Application Context.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


Support for Oracle User-Defined Types

The Microsoft BizTalk Adapter for Oracle E-Business Suite supports performing operations on artifacts in Oracle E-Business Suite and the underlying database that contain Oracle User-Defined Types (UDTs). The UDTs can be present in the following artifacts:

  • Interface tables and interface views containing UDT columns.

  • Database tables and views containing UDT columns.

  • Packages, stored procedures, and functions containing UDT parameters.

What is an Oracle UDT?

Oracle UDTs help in representing complex entities as a “single” object that can be shared among the applications. For example, it is possible to model real-world entities such as "Customers" or "Sales Orders" as objects in the Oracle database. Oracle UDTs are defined in the Oracle database, and they are of the following two types:

  • Object types. For example, Oracle Object.

  • Collection types. For example, nested table types or VARRAY.

The name of the Oracle UDT is case sensitive, and must be specified in the following way: [SCHEMA_NAME].[UDT_NAME].

How Does the Adapter Support Oracle UDT?

ODP.NET supports UDTs by representing Oracle UDTs defined in the Oracle database as .NET types (custom types). Custom types define the mapping between the Oracle UDT attributes or elements to the .NET members. Custom types can be .NET classes or structures, and can represent either Oracle Objects or Oracle Collections. Owing to the fact that the Oracle E-Business adapter uses ODP.NET to connect to the Oracle database, it inherits support for Oracle UDTs.

The Oracle E-Business adapter uses the ODP.NET to specify a custom type mapping to map a .NET custom type to an Oracle UDT in the database. To specify a custom type mapping, the Oracle E-Business adapter uses a custom type factory. Therefore, in order to use an Oracle UDT, an assembly (.dll file) is required that defines the custom type factory. The Oracle E-Business adapter enables you to generate an assembly for the custom type factory while generating the metadata for an artifact/operation that contains an Oracle UDT.

Note
The adapter generates the assembly for the Oracle UDTs based on the classes used by the ODP.NET to support Oracle UDTs. For detailed information about how Oracle UDTs are supported in ODP.NET, see http://go.microsoft.com/fwlink/?LinkId=140697.

To generate the assembly file for using the Oracle UDTs at design time and then use it later at the run time, the Oracle E-Business adapter exposes the following binding properties:

  • GeneratedUserTypesAssemblyFilePath (design time)

  • GeneratedUserTypesAssemblyKeyFilePath (design time)

  • UserAssembliesLoadPath (run time)

For information about these binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

Performing Operations On Artifacts Containing Oracle UDTs

To perform operations on artifacts containing UDTs using the Oracle E-Business adapter, you must do the following during design time and run time.

Design Time

You must perform these steps while generation schema for the operation in Visual Studio.

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in, the Add Adapter Metadata Wizard, or the Add Adapter Service Reference Plug-in. For information about doing so, see Connecting to the Oracle E-Business Suite in Visual Studio.

  2. While connecting, in the Binding Properties tab of the Configure Adapter dialog box, specify appropriate values for the GeneratedUserTypesAssemblyFilePath and GeneratedUserTypesAssemblyKeyFilePath binding properties. For information about these binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

  3. When you are connected to Oracle E-Business Suite in Visual Studio, browse to the required artifact that contains an Oracle UDT. For information about browsing artifacts, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

  4. Select the required artifact, and then click OK. The Oracle E-Business adapter generates the metadata for the selected operation along with the assembly (.dll file) for the Oracle UDT in the selected artifact. The assembly is created at the location that you specified in the GeneratedUserTypesAssemblyFilePath binding property.

  5. Proceed with the rest of the steps for building and deploying your project.

Run Time

You must perform these steps in the adapter clients to perform operations on the Oracle UDTs.

In BizTalk Server

  • Manually add the Oracle UDT assembly created in step 4 in “Design Time” to the Global Assembly Cache (GAC) on your computer. Alternatively, you can manually copy the Oracle UDT assembly under the BizTalk Server installation location. For BizTalk Server 2013 R2, typically this is <installation drive>:\Program Files\Microsoft BizTalk Server 2013 R2.

  • While configuring the BizTalk Server WCF-Custom or WCF-OracleEBS port, in the Binding tab, specify the location of the Oracle UDT assembly for the UserAssembliesLoadPath binding property. For information about this binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

In Visual Studio

  • Manually add the Oracle UDT assembly created in step 4 in “Design Time” to the Global Assembly Cache (GAC) on your computer. Alternatively, you can manually copy the Oracle UDT assembly to the same location as the project executable file, which typically is under the project’s \bin\Debug folder.

  • Specify the location of the Oracle UDT assembly for the UserAssembliesLoadPath binding property. For information about this binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

See Also

Other Resources

What Operations Can Be Performed Using the Adapter?

© 2014 Microsoft Corporation. All rights reserved.


How does the Adapter Handle Transactions?

Microsoft BizTalk Adapter for Oracle E-Business Suite does not initiate a transaction while performing an operation in Oracle E-Business Suite. Instead, the adapter performs the operations using the transaction context provided by the adapter clients. In order to perform operations in a transaction using the Oracle E-Business adapter, you must:

  • Enable transactions in the adapter clients. For example, to enable transactions in BizTalk Server 2013 R2, you must select the Use Transaction check box in the Transactions area of the Messages tab for a WCF-Custom or WCF-OracleEBS port.

  • Set the value of the UseAmbientTransaction binding property to True in the adapter. For more information about the binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

Important
To use the adapter to perform transactions in Oracle E-Business Suite, you must have installed the Oracle Services For Microsoft Transaction Server component, while installing the Oracle client, on the computer running the adapter client.

Transactions in the Outbound Operations

The Oracle E-Business adapter performs an outbound operation in a single transaction. For composite operations, all the operations are performed in a single transaction but using different ODP.NET connections. For more information about the outbound operations surfaced by the Oracle E-Business adapter, see How Does the Adapter Surface Oracle E-Business Suite Metadata?.

Transactions in the Inbound Operations

The Oracle E-Business adapter exposes the following two inbound operations:

  • Polling: The polling statement and the post-poll statement (if specified) are executed in a transaction, whereas, the polled data available statement is executed in a different transaction. Similarly, the polling statement and the post-poll statement are executed using the same ODP.NET connection, whereas, the polled data available statement is executed using a different ODP.NET connection.

  • Notification: The notification operation is performed in a transaction using a single ODP.NET connection.

For more information about the inbound operations surfaced by the Oracle E-Business adapter, see How Does the Adapter Surface Oracle E-Business Suite Metadata?.

See Also

Other Resources

Overview of BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Other Features Supported by the Adapter

In addition to the features discussed throughout the topics of Overview of BizTalk Adapter for Oracle E-Business Suite, the Microsoft BizTalk Adapter for Oracle E-Business Suite also provides the following features that are useful for adapter clients:

  • Support for configuring adapters using binding properties. Adapter clients can configure the Oracle E-Business adapter by specifying certain binding properties. For example, clients can configure the adapter to use the ODP.NET connection pool by setting the UseOracleConnectionPool binding property. For more information, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

  • Support for null values for operation parameters. Adapter clients can provide null values for operation parameters using the “nil” attribute in the input XML.

  • Support for dynamic ports in BizTalk. Through the BizTalk WCF-Custom adapter, the Oracle E-Business adapter supports a dynamic port that enables dynamic routing of messages from BizTalk Server based on the message context properties. For more information, see Configuring Dynamic Ports.

See Also

Other Resources

Overview of BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Key Features in BizTalk Adapter for Oracle E-Business Suite

This section lists the key features in Microsoft BizTalk Adapter for Oracle E-Business Suite.

Technology-Related Features

Feature Comment

Use of Windows Communication Foundation (WCF)

The Oracle E-Business adapter is built on top of the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK (WCF LOB Adapter SDK). In turn, the WCF LOB Adapter SDK is built on top of WCF. The adapters are exposed as WCF channels to adapter clients. This enables connectivity, metadata exchange, and business data exchange with external systems.

Support for the WCF channel model and the WCF service models

In the WCF channel model, adapter clients can consume the Oracle E-Business adapter by directly sending and receiving XML messages.

In the WCF service model, adapter clients can generate a .NET proxy class from the Web Services Description Language (WSDL) obtained using Oracle E-Business adapter.

Use of ODP.NET

The Oracle E-Business adapter uses the Oracle Data Provider for .NET (ODP.NET) to interface with Oracle E-Business Suite.

Two ways of connecting to Oracle E-Business Suite

The adapter clients can connect to Oracle E-Business Suite by either using the net service name in the tnsnames.ora file or by directly specifying the connection parameters, and thus eliminating the need to use a net service name or the tnsnames.ora file. Not requiring the tnsnames.ora file to connect to Oracle E-Business Suite saves you from the hassle of manually updating the connection parameters (net service name) in the tnsnames.ora file on every client computer when you add or update Oracle servers in your environment. For more information, see Establishing a Connection to the Oracle E-Business Suite.

Support for Windows Authentication

The adapter clients can use Windows Authentication to connect to Oracle E-Business Suite. Windows Authentication enables you to determine the user’s identity based on the Windows logon credentials, and thus helps you to leverage the built-in security of the Windows environment. For more information about Windows Authentication in the Oracle E-Business adapter, see Connecting to Oracle E-Business Suite Using Windows Authentication.

Support for using the Oracle E-Business adapter with Microsoft Office SharePoint Server (MOSS)

You can use the adapters to present data from the Oracle E-Business Suite onto a MOSS portal. For more information, see Using the Oracle E-Business Adapter with Microsoft Office SharePoint Server.

Metadata-Related Features

Feature Comment

Batch retrieval of metadata

Adapter clients can browse and search metadata for all the artifacts exposed by Oracle E-Business Suite and the underlying database. The artifacts are displayed based on the connected user credentials, and are:

  • Grouped by each application for the Oracle E-Business Suite artifacts.

  • Grouped by each artifact in Oracle E-Business Suite and the underlying database.

  • Grouped by each schema for the underlying database artifacts.

Performance-Related Features

Feature | Comment
Connection pooling | The Oracle E-Business adapter enables clients to use the ODP.NET connection pooling by configuring the UseOracleConnectionPool binding property. For more information about this binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.
Cache management | The Oracle E-Business adapter enables clients to use the ODP.NET cache management by configuring the StatementCachePurge and StatementCacheSize binding properties. For more information about this binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.
Support for performance counters | The Oracle E-Business adapter supports WCF-based performance counters for use by adapter clients. For more information about performance counters, see Using Performance Counters.

Operations-Related Features

Feature Comment

Support for operations on interface tables and interface views

Adapter clients can perform basic Insert, Update, Delete, and Select operations on Oracle E-Business Suite interface tables. Only select operation can be performed on the Oracle E-Business Suite interface views.

Support for executing PL/SQL APIs

Adapter clients can execute PL/SQL APIs in Oracle E-Business Suite. PL/SQL APIs contain stored procedures and functions within a package.

Support for executing concurrent programs

Adapter clients can execute concurrent programs in Oracle E-Business Suite.

Support for executing request sets

Adapter clients can execute request sets in Oracle E-Business Suite. A request set is a set of concurrent programs, and can be used to run several concurrent programs with predefined parameters. Request sets are executed in stages. For more information about request sets, see http://go.microsoft.com/fwlink/?LinkId=129539.

Support for specifying inline values in the Insert operation

You can use the InlineValue attribute in the Insert operation to insert computed values into interface tables and database tables in Oracle. This is an optional attribute and is available for all simple data records in an Insert operation. If you specify a value for this attribute, it overrides the specified value of a record. For more information about the InlineValue attribute, see Operations on Interface Tables and Interface Views.

Support for inbound calls using polling

The Oracle E-Business adapter supports receiving "polling-based" data-changed messages wherein the adapter executes a specified SQL statement, stored procedure, function, or procedure within a package, retrieves the data, and provides the result to the client.

Support for invoking functions and procedures

Adapter clients can invoke functions and procedures in the underlying Oracle database. The Oracle E-Business adapter surfaces functions and procedures as operations that can be performed on the underlying Oracle database.

Support for composite operations

The Oracle E-Business adapter enables adapter clients to perform composite operations in Oracle E-Business Suite. A composite operation can include any number of the following operations, and in any order:

  • Operations on interface tables, interface views, tables, and views.

  • Stored procedures, functions, and procedures within packages that are surfaced as operations in the adapter.

Support for executing arbitrary SQL statements and PL/SQL blocks

The Oracle E-Business adapter enables adapter clients to execute arbitrary SQL statements or PL/SQL blocks using the ExecuteReader, ExecuteScalar, and ExecuteNonQuery operations. For more information about these operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations.

Support for User-Defined Types (UDTs), boolean parameters, and PL/SQL table types

Adapter clients can support operations in artifacts that contain UDTs, and operations in stored procedures and functions that contain boolean parameters and PL/SQL table type. For information about UDT support, see Support for Oracle User-Defined Types.

Support for input and output REF CURSORS

Adapter clients can operate with input and output REF CURSORS on procedures and functions.

Support for PL/SQL RECORD data types

Adapter clients can operate with RECORD and nested RECORD types in stored procedures and functions.

Support for overloaded functions and procedures in PL/SQL API

Adapter clients can invoke overloaded functions and procedures in PL/SQL APIs. However, the Oracle E-Business adapter does not support the use of overloaded procedures using strongly-typed and weakly-typed REF CURSORS. Internally, the adapter treats both the strongly-typed and weakly-typed REF CURSORS as just REF CURSORS.

Support for database change notifications

Adapter clients can receive database change notifications from Oracle database based on a triggering SELECT statement. The notification is sent by Oracle database to the adapter clients as and when the result set for the SELECT statement changes. For more information about database change notifications, see Receiving Database Change Notifications.

Support for synonyms

Adapter clients can perform operations on synonyms created for tables, views, stored procedures, functions and packages. For more information about synonyms, and how you can use the Oracle E-Business adapter to perform operations on synonyms, see Operations on Synonyms.

Other Features

Feature Comment

Multi-Language Support (MLS)

Adapter clients can use the Oracle E-Business adapter to perform operations in Oracle E-Business Suite and the underlying database having multiple language packs installed. This implies that the adapter clients can perform operations on the data in multiple languages. For example, you can view localized (non-English) data in an interface view, or insert localized data in a table. The Oracle E-Business adapter supports as many languages as those supported by the underlying Oracle E-Business Suite installation.

The Oracle E-Business adapter exposes the MlsSettings binding property to configure the multiple language support feature. For more information about the binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

See Also

Other Resources

Understanding BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Limitations of BizTalk Adapter for Oracle E-Business Suite

General Limitations

The following are known limitations for Microsoft BizTalk Adapter for Oracle E-Business Suite:

  • The Oracle E-Business adapter does not support XML Gateway, Advanced Queuing, and Business Events.

    However, you can get around the Business Events limitation in the following way:

    1. In Oracle Business Events System, create a subscription to invoke a custom PL/SQL procedure when a business event occurs.

    2. Write a custom PL/SQL procedure that receives the business event.

    3. Use the custom PL/SQL procedure to store the resultant data (event and event payload) in a table.

    4. Use the Oracle E-Business adapter to poll or receive notifications from the table.

  • The Oracle E-Business adapter does not support XML Types.

  • The Oracle E-Business adapter does not enable clients to set the value of the first element in a VARRAY to NULL.

  • The Oracle E-Business adapter does not support records that contain fields of type PL/SQL tables of RECORD type.

  • The Oracle E-Business adapter does not support User-Defined Types (UDTs) that have circular references.

  • The Oracle E-Business adapter does not support the BFILE data type inside complex types (such as RECORD type, TABLE type, UDT, and VARRAY).

  • The Oracle E-Business adapter supports UDT nesting only up to two levels.

  • Except for PL/SQL tables, the Oracle E-Business adapter does not support UDTs that are defined inside a package.

  • When using the adapters with BizTalk Server, if the credentials on the WCF-custom send port are incorrect, the request messages are not processed. After you specify the correct credentials, the message is sent to Oracle E-Business Suite and a response is received. However, the response message is not available to the out port. In such scenarios, you may need to restart the host instance.

Limitations Due to ODP.NET

The following are known limitations for Oracle E-Business adapter due to the limitation of ODP.NET:

  • The Oracle E-Business adapter does not support PL/SQL tables that are not indexed by a numeric field.

  • The Oracle E-Business adapter does not support associative arrays that do not contain any element.

  • The Oracle E-Business adapter does not support UDTs that contain the TimeStamp data type with local time zone attributes (TimeStampLTZ).

  • The Oracle E-Business adapter does not support UDTs that contain a “.” (period) in their names.

  • The Oracle E-Business adapter does not support UDTs that contain BLOB, CLOB, and NCLOB data types as an IN OUT parameter.

  • The Oracle E-Business adapter does not support Varray of Varray of the following simple types: BFILE, IntervalDS, IntervalYM, TimeStampLTZ, and TimeStampTZ.

  • Due to the limitation of associative arrays, PL/SQL tables or PL/SQL tables of records that contain any of the following data types are not supported in the Oracle E-Business adapter:

    • BFILE

    • BLOB

    • CLOB

    • IntervalDS

    • IntervalYM

    • Long

    • NCLOB

    • RowID

    • TimeStamp

    • TimeStampLTZ

    • TimeStampTZ

See Also

Other Resources

Understanding BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Oracle E-Business Adapter Tutorial

The Microsoft BizTalk Adapter for Oracle E-Business Suite tutorial contains a step-by-step demonstration of how to present data from Oracle E-Business Suite system on a Microsoft SharePoint portal. It also demonstrated how you can configure a search application on the SharePoint portal that can search for an entity in a sample artifact in Oracle E-Business Suite.

In addition to the tutorial, the topics in the Developing BizTalk Applications section provide detailed instructions on how to use the Oracle E-Business adapter with BizTalk Server.

In This Section

Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site

See Also

Other Resources

Oracle E-Business Adapter Tutorial

© 2014 Microsoft Corporation. All rights reserved.


Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site

This tutorial provides detailed instructions on using the Oracle E-Business adapter with Microsoft Office SharePoint Server to present data from Oracle E-Business Suite on a SharePoint portal. It also demonstrates how to configure a search application in the Microsoft Office SharePoint Server that allows you to do a full-text search from a SharePoint portal on the configured Oracle E-Business Suite artifact.

To demonstrate how to do so, consider a sample interface table in Oracle E-Business Suite that stores information about employees. In this tutorial, an application is created in Microsoft Office SharePoint Server that retrieve a list of customers from Oracle E-Business Suite based on a search string using:

  • A Business Data List Web Part in Microsoft Office SharePoint Server

  • The search feature in Microsoft Office SharePoint Server

Note
Before proceeding with the tutorial, make sure you have installed all the prerequisites for using the Oracle E-Business adapter with Microsoft Office SharePoint Server. For information about the prerequisites, see the BizTalk Adapter Pack installation guide, typically installed at C:\Program Files\Microsoft BizTalk Adapter Pack\Documents.

In This Section

  • Step 1: Use the Oracle E-Business Adapter to Create and Publish a WCF Service

  • Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts

  • Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite

  • Step 4: Test Your SharePoint Application

© 2014 Microsoft Corporation. All rights reserved.


Step 1: Use the Oracle E-Business Adapter to Create and Publish a WCF Service
Step 1 of 4

Time to complete: 15 minutes

Objective: You can use the WCF LOB Adapter Service Development Wizard to generate a WCF service from the Oracle E-Business Suite artifacts that can be hosted in a hosting environment such as Internet Information Services (IIS) or Windows Process Activation Service (WAS). This topic demonstrates how to use the wizard to generate a WCF service file.

Prerequisites

Before running the wizard, install the following:

  • Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK either with the Complete option or the Custom option (and choosing Tools within this option). This installs the Visual Studio template for the Adapter Service Development Wizard.

  • Microsoft BizTalk Adapter for Oracle E-Business Suite from the BizTalk Adapter Pack.

For more information about these prerequisites, see the BizTalk Adapter Pack installation guide. The installation guide is typically installed at <installation drive>:\Program Files\Microsoft BizTalk Adapter Pack\Documents.

Note
You must also run the create_apps_artifacts.sql script provided with the Microsoft Office SharePoint Server sample to create the MS_SAMPLE_EMPLOYEE interface table in the Application Object Library application. This interface table is used in this tutorial.

In this topic

We will perform the following tasks in this topic:

  1. Create a WCF Service for the Select Operation on the MS_SAMPLE EMPLOYEE Interface Table

  3. Modify the .cs file

  4. Publish the WCF Service

Create a WCF Service for the Operation on Oracle E-Business Artifact

This section provides the steps to create a WCF service for the Select operation on the MS_SAMPLE EMPLOYEE Interface Table.

To Create a WCF Service for the Select Operation on the MS_SAMPLE EMPLOYEE Interface Table

  1. Start Visual Studio, and then create a project.

  2. In the New Project dialog box, from the Project types pane, select Visual C#. From the Templates pane, select WCF Adapter Service.

    Alternatively, from the Project types pane, expand Visual C#, and then select Web. From the Templates pane, select WCF Adapter Service.

    New Project dialog box

    Note
    If you installed Visual Studio 2013 with the Web Development component, the WCF Adapter Service template is also available from the New Web Site option (File > New > Web Site).

    However, the Oracle E-Business adapter only supports Web sites that are created on the file system. Therefore, while creating a Web site in the New Web Site dialog box, you must click File System in the Location list.

  3. Specify a name and location for the solution, and then click OK. The WCF Adapter Service Development Wizard starts.

  4. On the Welcome page, click Next.

  5. On the Choose Operations page, specify a connection string to connect to Oracle E-Business Suite. To do so:

    1. In the Select a binding list, click oracleEBSBinding, and then click Configure.

    2. In the Configure Adapter dialog box, click the Binding Properties tab.

      1. Under the General category, for the ClientCredentialType binding property, select EBusiness.

      2. Under the OracleEBS category, specify appropriate values for the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. In this case, you need to provide database credentials for the OracleUserName and OraclePassword binding properties.

      3. Under the Metadata category, for the EnableSafeTyping binding property, select True. If you are retrieving values for the date column, we recommend that you set the EnableSafeTyping binding property to True when generating the metadata.

    3. Click the URI Properties tab, and then specify values for the connection parameters. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

    4. Click the Security tab, and in the Client credential type list, select Username. Specify a valid Oracle E-Business Suite user name and password to connect to Oracle E-Business Suite.

    5. Click OK to close the Configure Adapter dialog box, and then click Connect. After Visual Studio successfully establishes a connection with Oracle E-Business Suite, the connection status is shown as Connected. You can also see the Oracle E-Business Suite metadata being displayed on the Choose Operations page.

  6. On the Choose Operations page, in the Select contract type list, click Client (Outbound operations).

  7. In the Select a category box, browse to the MS_SAMPLE_EMPLOYEE interface table in Application Object library application. For information about browsing to an artifact in the adapter, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

  8. In the Available categories and operations box, select the Select operation, and then click Add. The Select operation is added to the Added categories and operations box.

    Adding the Select Operation
    Note
    You can add more than one operation for each artifact. You can also add operations for different Oracle E-Business Suite artifacts. For example, you can add one operation for an interface table and another for a concurrent program. In addition, you can search for specific operations by specifying wildcard characters in search expressions. For more information about the supported special characters and the node levels at which you can search for the operations, see Searching for Operations.

  9. On the Choose Operations page, click Next.

  10. On the Configure Service and Endpoint Behaviors page, specify values to configure the service and endpoint behavior.

    1. In the Service Behavior Configuration box, specify values for the following:

      For the property Specify the value

      EnableMetadataExchange

      Set this to True to create a metadata exchange endpoint. By setting this to True, you make the service metadata available using standardized protocols, such as WS-Metadata Exchange (MEX) and HTTP/GET requests. Default is False.

      IncludeExceptionDetailsinFault

      Set this to True to include managed exception information in detail of SOAP faults returned to the client for debugging purposes. Default is False.

      Name

      Name for the service behavior configuration. For this tutorial, type customServiceBehavior.

      UseServiceCertificate

      Specifies whether you want to use the message level security mode of WCF. Default is True. For this tutorial, you must set this to False.

      Note
      Because we are not using service certificates for this tutorial, you do not need to provide values for the FindValue, StoreLocation, StoreName, and X509FindType properties. For more information about the certificates and the associated properties, see "X509ClientCertificateCredentialsElement Properties" at http://go.microsoft.com/fwlink/?LinkId=103771.

    2. In the Endpoint Behavior Configuration box, specify values for the following:

      For the property Specify the value

      Authentication Type

      For Microsoft Office SharePoint Server to consume the WCF service, you should set this as HTTPUserNamePassword. This enables clients to specify user name and password as part of the HTTP header.

      Name

      Specify a name for the endpoint behavior configuration. For this tutorial, type customEndpointBehavior.

      UsernameHeader

      Name for the user name header. For this example, specify MyUserHeader. For more information about HTTP headers, see "Support for Custom HTTP and SOAP Headers" at http://go.microsoft.com/fwlink/?LinkId=106692.

      Note
      You must specify a value for this property if the Authentication Type is set to HTTPUserNamePassword. If Authentication Type is set to Auto, this property is optional.

      PasswordHeader

      Name for the password header. For this example, specify MyPassHeader. For more information about HTTP headers, see "Support for Custom HTTP and SOAP Headers" at http://go.microsoft.com/fwlink/?LinkId=106692.

      Note
      You must specify a value for this property if the Authentication Type is set to HTTPUserNamePassword. If Authentication Type is set to Auto, this property is optional.

    The following figure shows the Configure Service and Endpoint Behaviors page with the specified values.

    Configure Service and Endpoint Behaviors page

  11. On the Configure Service and Endpoint Behaviors page, click Next.

  12. On the Configure Service Endpoint Binding and Address page, the Select a contract to configure displays the artifact (MS_SAMPLE_EMPLOYEE) that you configured. The Operations under the selected contract box displays the Select operation you selected for the artifact on the Choose Operations page.

  13. In the Configure the address and binding for the contract box, specify values for the following:

    For the property Specify the value

    Binding Configuration

    The wizard only supports basic HTTP binding. So, the binding configuration field is automatically populated to System.ServiceModel.Configuration.BasicHttpBindingElement.

    Click the ellipsis button (…) to change the properties for HTTP binding. To use a secure communication channel, you must always set the Mode property to Transport. The wizard sets the default value for the Mode property as Transport.

    For more information about the other bindings exposed, see "BasicHttpBindingElement Members" at http://go.microsoft.com/fwlink/?LinkId=103773.

    Endpoint Name

    Specify an endpoint name for the contract.

    The other fields on this page are automatically populated based on the values you specified in the earlier pages.

    Click Apply.

    Note
    If you do not specify any values on this page, the default values are accepted for all the contracts.

    The following figure shows the Configure Service Endpoint Binding and Address page with the specified values.

    Configure Service Endpoint Binding and Address

  14. On the Configure Service Endpoint Binding and Address page, click Next. The Summary page lists a tree structure of the Oracle E-Business Suite artifact and the operation selected for the artifact.

  15. Review the summary, and then click Finish.

  16. The wizard creates a WCF service and adds the following files to the Visual Studio project:

    1. .svc file. This is the WCF service file. The wizard generates one file for each contract.

    2. Web.config file.

    3. Service code (.cs file)

Modify the .cs file

When you create a service out of an Oracle E-Business Suite artifact using the Oracle E-Business adapter and want to use it from the Business Data List Web Part in Microsoft Office SharePoint Server, you are expected to provide the full filter clause starting with the WHERE clause. For example, if you want to search for an employee who name is “John”, you need to provide the following filter clause in the Business Data List Web Part:

Copy Code
where NAME like ‘JOHN’

However, if you want the user to only provide the name as an input for the filter clause without actually mentioning the whole filter clause, you can add a code in the .cs file that modifies the filter clause coming in from the Business Data List Web Part in Microsoft Office SharePoint Server to pass it to Oracle E-Business in the WHERE clause format.

For example, in the case of this tutorial, if you want the user to enter an employee name in Business Data List Web Part in Microsoft Office SharePoint Server and retrieve record for that employee, you can add the following code in the .cs file:

Copy Code
SelectResponse InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE.Select(SelectRequest request)
{
     request.FILTER = "where NAME like '" + request.FILTER + "'"; // The code to avoid the users from specifying the WHERE clause in the filter from Business Data List Web Part.
     return base.Channel.Select(request);
}

Publish the WCF Service

Make sure that SSL is enabled for IIS. For instructions on how to enable SSL for IIS, see http://go.microsoft.com/fwlink/?LinkId=197170.

To publish the WCF service:

  1. Right-click the project in Solution Explorer, and then click Publish.

  2. In the Publish Web dialog box, specify a URL for the WCF service. For example:

    Copy Code
    https://<COMPUTER_NAME>:<PORT_NUMBER>/MS_SAMPLE_EMPLOYEE/
    Note
    You must publish the WCF service to a SSL-enabled location. In other words, the value in the Target Location box must start with “https://”. Because the user credentials are passed in the HTTP header, the wizard automatically configured the adapter’s binding behavior to use “Transport” as the security mode, which implies SSL encryption. You can of course go back, and edit the web.config file to change the value of the <security mode> parameter, but using SSL is always a better option when you have sensitive information transported in clear text in the HTTP header.

  3. From the Copy box, click All project files.

  4. Click Publish.

  5. Verify that the WCF service is published successfully.

    1. Start the IIS Microsoft Management Console. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

    2. Navigate to the node where you published the service. For the MS_SAMPLE_EMPLOYEE service, navigate to Internet Information Services > <Computer Name> > Web Sites > Default Web Site > MS_SAMPLE_EMPLOYEE.

    3. On the right pane, right-click the InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE.svc file, and then click Browse.

    4. The Web page shows up with the URL for retrieving the WSDL. You may want to test metadata retrieval using the svcutil command. For example, the command to retrieve metadata for the MS_SAMPLE_EMPLOYEE service is:

      Copy Code
      svcutil.exe https://<COMPUTER_NAME>:<PORT_NUMBER>/MS_SAMPLE_EMPLOYEE/InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE.svc?wsdl

Next Step

To create an application definition file for the Oracle E-Business Suite artifact, use the Business Data Catalog Definition Editor. For instructions, see Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts. The application definition file identifies where the LOB data is stored and the format in which it is stored.

See Also

Other Resources

Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site

© 2014 Microsoft Corporation. All rights reserved.


Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts
Step 2 of 4

Time to complete: 15 minutes

Objective: The Business Data Catalog feature in Microsoft SharePoint Server exposes and incorporates data from line-of-business (LOB) applications into portals. To incorporate this data into your portal site, you must build an application definition file that Microsoft Office SharePoint Server can consume.

The Business Data Catalog Definition Editor tool, available with Microsoft Office SharePoint Server 2007 SDK, enables you to create an application definition file for the Business Data Catalog. This tool automatically generates an XML file for the definition file, so you do not need to manually create the file in an XML editor.

The purpose of the Microsoft Office SharePoint Server application that you are creating is to:

  • Query for an employee in the MS_SAMPLE_EMPLOYEE interface table using a Business Data List Web Part based on an employee name.

  • Perform a full-text search from Microsoft Office SharePoint Server on the MS_SAMPLE_EMPLOYEE interface table.

For each of these requirements, you must complete a set of tasks in the Business Data Catalog Definition Editor tool. This topic provides instructions on how to perform these tasks.

Prerequisites

  • Be sure that you have the Business Data Catalog Definition Editor installed as part of the Microsoft Office SharePoint Server 2007 SDK. You can download the SDK from http://go.microsoft.com/fwlink/?LinkId=104130.

  • Publish the WCF service as described in Step 1: Use the Oracle E-Business Adapter to Create and Publish a WCF Service.

In this topic

We will perform the following tasks in this topic:

  1. Connect to the WCF LOB Service and Create Entity

  2. Specify User Name and Password Headers for the Methods

  3. Scenario 1: Query for Employees using a Business Data List Web Part

  4. Scenario 2: Full-Text Search on MS_SAMPLE_EMPLOYEE Interface Table from Microsoft Office SharePoint Server

  5. Set Default Parameters for the Method Instances

  6. Set up Single Sign-On for Connecting to Oracle E-Business Suite

  7. Export the Application Definition to a File

Connect to the WCF LOB Service and Create Entity

You must connect to the WCF service to extract the Web Services Description Language (WSDL) for the service. From the WSDL, the Business Data Catalog Definition Editor extracts the methods. These methods can be used to create entities. For this tutorial, an entity is created.

To connect to the WCF service and create entities

  1. Start the Business Data Catalog Definition Editor. On the Start menu, click Microsoft Business Data Catalog Definition Editor.

  2. On the toolbar, click Add LOB System.

  3. In the Add LOB System window, click Connect to Webservice.

  4. In the URL box, type the URL for the WCF service. For this tutorial, the URL will be:

    Copy Code
    https://<COMPUTER_NAME>:<PORT_NUMBER>/MS_SAMPLE_EMPLOYEE/InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE.svc

    The URL is available when you test whether the WCF service is published successfully, as described in Publish the WCF Service.

  5. Click Connect.

  6. To see the operations you selected in the WCF Adapter Service Development Wizard, click the Add Web Method tab. You will see the following method: Select.

  7. Drag the Select methods to the Design Surface. As you drag the method to the Design Surface, an entity is created, and the method becomes part of that entity.

    Add Select method to the Design Surface

  8. Click OK.

  9. In the Enter the name for the LOB System dialog box, type a name in the LOB System Name box. For this example, call it MS_SAMPLE_EMPLOYEE, and then click OK.

  10. In the Business Data Catalog Definition Editor, the newly created entity is listed as Entity0. Rename the entity to Employee. Perform the following steps to rename the entity:

    1. Expand the MS_SAMPLE_EMPLOYEE node, and then expand the Entities node.

    2. Select the Entity0 node.

    3. In the Properties pane, type Employee in the Name box.

      Rename the entity

Specify User Name and Password Headers for the Methods

When creating a WCF service for the Select operation on the MS_SAMPLE_EMPLOYEE interface table in Oracle E-Business Suite, you specified user name and password headers as part of the endpoint behavior configuration in Step 1: Use the Oracle E-Business Adapter to Create and Publish a WCF Service. You must specify the same values for the Select method property.

To specify user name and password headers for the Select method

  1. In the Metadata Objects pane, expand the Employee node, and then expand the Methods node.

  2. Click the Select node, and in the Properties pane click the ellipsis (…) button against the Properties box.

  3. In the PropertyView Collection Editor window, click Add, and in the Property pane, type HttpHeaderUserName for the Name box. Type MyUserHeader for the PropertyValue box. Select System.String for the Type box.

  4. In the PropertyView Collection Editor window, click Add, and in the Property pane, type HttpHeaderPassword for the Name box. Similarly, type MyPasswordHeader for the PropertyValue box. Select System.String for the Type box.

    Add a property

  5. Click OK.

Scenario 1: Query for Employees using a Business Data List Web Part

To create an application definition file that can be used to search for employees from a Business Data List Web Part and based on employee name, you must perform the following set of tasks.

  1. In the Select method, create a filter and map it to the FILTER parameter.

  2. Create a Finder method instance for the Select method. A Finder method retrieves a list of records based on a filter.

To create a filter, and map it to the FILTER parameter

  1. Create a filter.

    1. In the Metadata Objects pane, expand the Employee node, and then expand the Methods node.

    2. Expand the Select method, right-click Filters, and then click Add Filter.

      Add a filter to the SELECT method
    3. In the Properties pane, for the FilterType property, select Equals.

    4. In the Properties pane, type EmployeeName in the Name box.

      Specify filter properties

  2. Map the filter to the FILTER parameter in the Select method.

    1. In the Metadata Objects pane, expand the Employee node, and then expand the Methods node.

    2. Expand the Select method, and then expand the Parameters node.

    3. Expand the FILTER node, and click the second FILTER node.

    4. In the Properties pane, select EmployeeName from the FilterDescriptor list.

      Map the filter to the Select method parameter

To create a Finder method instance for the Select method

  1. In the Metadata Objects pane, expand the Employee node, and then expand the Methods node.

  2. Expand the Select node, right-click Instances, and then click Add Method Instance.

    Add a method instance

  3. In the Create Method Instance window, click Finder for Method Instance Type. Select Return for Return TypeDescriptor.

    Create a Finder method instance

  4. Click OK.

  5. In the Properties pane, type Finder_Instance in the Name box.

    Specify a name for the Finder method instance

Scenario 2: Full-Text Search on MS_SAMPLE_EMPLOYEE Interface Table from Microsoft Office SharePoint Server

To create an application definition file that can be used to perform a full-text search on MS_SAMPLE_EMPLOYEE interface table from Microsoft Office SharePoint Server, you must perform the following set of tasks.

  • In the Select method, create an identifier, and map it to the FILTER parameter and the return value that stores the employee name.

  • Create a Specific Finder method instance for the Select. The Specific Finder method will find a specific record based on the identifier, that is, an employee name.

  • Create an ID Enumerator method instance.

To create an identifier, and map it to the FILTER parameter and employee name return value

  1. Create an identifier for the Employee entity.

    1. In the Metadata Objects pane, expand the Employee node.

    2. Right-click the Identifiers node, and then select Add Identifier.

      Create an Identifier
    3. In the Properties pane, type EmployeeName in the Name box.

    4. Select System.String for the Type box.

      Specify identifier properties

  2. Map the identifier to the FILTER parameter for the Select method.

    1. In the Metadata Objects pane, expand the Employee node, and then expand the Methods node.

    2. Expand the Select method, and then expand the Parameters node.

    3. Expand the FILTER parameter, and then click the second FILTER node.

    4. In the Properties pane, select EmployeeName[Employee] from the Identifier list.

      Setting identifier for the FILTER parameter

  3. Map the identifier to the employee name return value.

    1. In the Metadata Objects pane, expand the Employee node, and then expand the Methods node.

    2. Expand the Select method, and then expand the Parameters node.

    3. Expand the Return node, then the second Return node, then the Item node, and then click the Name node.

    4. In the Properties pane, select EmployeeName[Employee] from the Identifier list.

To create a Specific Finder method instance for the Select method

  1. In the Metadata Objects pane, expand the Employee node, and then the Methods node.

  2. Expand the Select node, right-click Instances, and then select Add Method Instance to open the Create Method Instance window.

    Add a method instance

  3. In the Create Method Instance window, select Specific Finder for Method Instance Type. Select Return for Return TypeDescriptor.

    Add a Specific Finder method instance

  4. Click OK.

  5. In the Properties pane, type SpeciFinder_Instance for the Name box.

To create an Id Enumerator method instance for the Select method

  1. In the Metadata Objects pane, expand the Employee node, and then the Methods node.

  2. Expand the Select node, right-click Instances, and then select Add Method Instance to open the Create Method Instance window.

    Add a method instance

  3. In the Create Method Instance window, select Id Enumerator for Method Instance Type. Select Return for Return TypeDescriptor.

    Create an Id Enumerator method instance

  4. Click OK.

  5. In the Properties pane, type IDEnumerator_Instance for the Name box.

Set Default Parameters for the Method Instances

The Select method requires you to specify the column names. Therefore, you need to specify a default value for the COLUMN_NAMES parameter for the Finder, Specific Finder, and Id Enumerator method instances created earlier. Additionally, you should also specify a default value for the FILTER parameter for the Id Enumerator method instance.

To set the default parameters for the method instances

  1. In the Metadata Objects pane, expand the Employee node, and then expand the Methods node.

  2. Expand the Select node, and then expand the Parameters node.

  3. Expand the COLUMN_NAMES node, and then select the COLUMN_NAMES parameter.

  4. In the Properties pane, click the ellipsis button (…) against the DefaultValues box.

  5. In the DefaultValueView Collection Editor dialog box, click Add, and in the property pane, click Finder_Instance in the SelectMethodInstance list.

    Specifying default value for the Finder instance

  6. Type * in the Value box.

  7. Similarly, repeat steps 5 and 6 to add default values for the SpecificFinder_Instance and IDEnumerator_Instance method instances.

  8. In the DefaultValueView Collection Editor dialog box, click OK.

  9. Next, add a default value for the FILTER parameter for the IDEnumerator_Instance method instance. Expand the FILTER node, and then select the FILTER parameter.

  10. In the Properties pane, click the ellipsis button (…) against the DefaultValues box.

  11. In the DefaultValueView Collection Editor dialog box, click Add, and in the property pane, click IDEnumerator_Instance in the SelectMethodInstance list.

  12. Type % in the Value box.

    Default values for the Id Enumerator instance

  13. In the DefaultValueView Collection Editor dialog box, click OK.

Set up Single Sign-On for Connecting to Oracle E-Business Suite

After you have finished performing all the procedures in this topic, you will have created an application definition file that can be imported into a SharePoint application. From the application, you invoke the methods to retrieve relevant data from Oracle E-Business Suite. To enable this, you must create a mapping between a user in the Oracle E-Business Suite and the user in the SharePoint application. You create this mapping in SharePoint Central Administration console after you have imported the application definition file.

However, to create the mapping you must set a property SecondarySsoApplicationId in the Business Data Catalog Definition Editor.

To set the SecondarySsoApplicationId property

  1. In the Metadata Objects pane, expand the MS_SAMPLE_EMPLOYEE node, and then expand the Instances node.

  2. Click MS_SAMPLE_EMPLOYEE_Instance, and in the Properties pane, click the ellipsis (…) button against the Properties box.

  3. In the PropertyView Collection Editor dialog box, click Add, and in the Property pane, type SecondarySsoApplicationId for the Name box. Similarly, type OracleSSO for the PropertyValue box. Select System.String for the Type box.

    Add the SSO Property

  4. Click OK.

Export the Application Definition to a File

You have now created an application definition that contains Oracle E-Business Suite instance metadata. You must export this definition to an XML file, which can be imported into Microsoft Office SharePoint Server.

To export the application definition to a file

  1. In the Metadata Objects pane, right-click the MS_SAMPLE_EMPLOYEE node, and then click Export.

  2. Save the file as Employee.xml.

Next Steps

You must now create a SharePoint application to retrieve data from Oracle E-Business Suite. For instructions, see Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite.

See Also

Other Resources

Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site

© 2014 Microsoft Corporation. All rights reserved.


Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite
Step 3 of 4

Time to complete: 15 minutes

Objective: You must now import the application definition file in Microsoft Office SharePoint Server, and set up an application to retrieve data from Oracle E-Business Suite.

Prerequisites

  • You should have created an application definition file as described in Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts.

  • The Microsoft Single Sign-on service must be running.

In this topic

We will perform the following tasks in this topic:

  • Creating an SSO Application in SharePoint

  • Creating a Shared Services Provider

  • Importing the Application Definition File

Creating an SSO Application in SharePoint

To access the data in Oracle E-Business Suite from a SharePoint application, you must set up an SSO application that maps a SharePoint user to an Oracle E-Business Suite user. Creating an SSO application in SharePoint involves the following steps:

  1. Manage server settings for single sign-on. In this step, you specify a user account that can manage and set up the single sign-on service. You can do so on the Manage Server Settings page. This option is available from the SharePoint Central Administration console. For more information about this step, refer to the “Configure Single Sign-On for Office SharePoint Server 2007” section at http://go.microsoft.com/fwlink/?LinkId=105291.

  2. Manage settings for enterprise application definitions. In this step, you configure the settings for the enterprise application definition. You can do so from the Manage Settings for Enterprise Application Definitions page. This option is available from the SharePoint Central Administration console.

    1. On Central Administration, on the top navigation bar, click Operations.

    2. On the Operations page, in the Security Configuration section, click Manage settings for single sign-on.

    3. On the Manage Settings for Single Sign-On page, in the Enterprise Application Definition Settings section, click Manage settings for enterprise application definitions.

    4. On the Manage Enterprise Application Definitions page, provide values for the Display name, Application name, and the Contact e-mail address fields.

      Important
      For the Application name field, make sure you specify the same SSO application name that you specified for the SecondarySsoApplicationId variable while creating the application definition file, as described in Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts.

    5. Leave the other fields as default, and click OK.

  3. Manage account information for enterprise application definitions. In this step, you enable individual users or groups to connect to an enterprise application from SharePoint. Essentially, in this step you map an individual user or group to a user in the LOB system. You also specify the credentials to connect to the LOB system. You can do so from the Manage Account Information for Enterprise Application Definitions page. This option is available from the SharePoint Central Administration console. For more information about this step, refer to the “Manage account information for an enterprise application definition” section at http://go.microsoft.com/fwlink/?LinkId=105291.

Creating a Shared Services Provider

A Shared Service Provider is a logical grouping of shared services and their supporting resources. You can create an SSP by using the SharePoint Central Administration console.

You must define a Web site when creating an SSP. Remember the port number and the site address that you create. You will import the Business Data Catalog application definition to this site.

For more information about creating an SSP, see "Chapter overview: Create and configure Shared Services Providers" at http://go.microsoft.com/fwlink/?LinkId=105119.

Importing the Application Definition File

You must now import the application definition file into the SSP.

To import the application definition file

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and then click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the SSP to which you want to import the application definition.

  3. In the Business Data Catalog section, click Import application definition.

  4. On the Import Application Definition page that opens, browse to Employee.xml, select the file, and then click Open.

  5. Click Import.

  6. After the application definition file is imported successfully, click OK.

    The application created as a result of importing the application definition file, MS_SAMPLE_EMPLOYEE, appears.

    The application in SharePoint

Next Steps

Now, you are ready to create Web Parts to create a SharePoint site to view and search the business data that will be extracted from Oracle E-Business Suite. We will create a:

  • Business Data List Web Part to display employee records from the MS_SAMPLE_EMPLOYEE interface table. See Scenario 1: Display Data Using Business Data List Web Part.

  • Search Box Web Part to perform a full-text search on the MS_SAMPLE_EMPLOYEE interface table. See Scenario 2: Perform a Search Using the Search Box Web Part.

See Also

Other Resources

Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site

© 2014 Microsoft Corporation. All rights reserved.


Scenario 1: Display Data Using Business Data List Web Part

We will use the Business Data List Web Part for the Finder method instance. This Web Part enables you to specify a search expression to retrieve a list of employees from Oracle E-Business Suite. For this tutorial, this is called the Display Employees Web Part. This section provides instructions to create this Web Part. For more information about creating Web Parts, see "Customize business data lists, Web Parts, and sites" at http://go.microsoft.com/fwlink/?LinkId=104131.

You must create a Web Part page before adding the Web Parts.

Creating a Web Part Page

This section provides instructions to create a Web Part page.

To create a Web Part page

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the SSP to which you want to import the application definition.

  3. On the Shared Services Administration page, in the upper-right corner, click Site Actions, and then click Create.

    Menu to create a web part

  4. On the Create page, in the Web Pages section, click Web Part Page.

  5. On the New Web Part page, do the following:

    1. In the Name field, type a name for the page. For this tutorial, type the name as MS_SAMPLE_EMPLOYEE.

    2. Select the Overwrite if file already exists check box, if you want to overwrite old pages with the same name as the new page you create.

    3. In the Layout section, from the Choose a Layout Template box, select a layout for the Web Part page. For this tutorial, select Full Page, Vertical.

    4. In the Save Location section, in the Document Library list, click Form Templates.

    5. Click Create. The following figure shows the Web Part page after it is created.

      The new WebPart page
    6. You must now add the Web Parts to this page.

Adding a Business Data List Web Part

You must now add a Business Data List Web Part to the Web Part page. Using this Web Part you will retrieve a list of employee records from the MS_SAMPLE_EMPLOYEE interface table in Oracle E-Business Suite that matches a search expression. This Web Part corresponds to the Finder method instance (Finder_Instance) that you created in the Business Data Catalog Definition Editor.

To add a Business Data List Web Part

  1. On the MS_SAMPLE_EMPLOYEE page, click Add a Web Part.

  2. In the Add Web Parts dialog box, in the Business Data section, select the Business Data List check box, and then click Add.

    Options to create a business data Web Part

  3. In the newly added Business Data List Web Part, click the Open the tool pane link.

    Open the tool pane for Web Part

  4. The Business Data List tool pane opens in the right pane. In the Business Data List section, for the Type field, click the Browse button.

    Business Data List tool pane

  5. In the Business Data Type Picker dialog box, select the MS_SAMPLE_EMPLOYEE_Instance application, and then click OK.

    Select the application instance

  6. Expand the Appearance node, and in the Title box, type a title for the Web Part. For this Web Part, type Employee List.

  7. In the Business Data List tool pane, click Apply, and then click OK. The Business Data List Web Part now looks like the following:

    Business Data List Web Part

  8. The Web Part lists the fields that are returned by executing the Select operation on the MS_SAMPLE_EMPLOYEE interface table.

See Also

Tasks

Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite

Concepts

Scenario 2: Perform a Search Using the Search Box Web Part

© 2014 Microsoft Corporation. All rights reserved.


Scenario 2: Perform a Search Using the Search Box Web Part

We will configure the search settings in Microsoft Office SharePoint Server to configure a search application using which you can perform a full text search on the MS_SAMPLE_EMPLOYEE interface table in Oracle E-Business Suite. Later, we will add a Search Box Web Part to from where you can perform the search.

Configuring search in Microsoft Office SharePoint Server involves the following:

  1. Define the Content Source

  2. Define a Scope for the Crawled Content

  3. Add the Scope to the Search Dropdown

  4. Add the Search Box Web Part

Define the Content Source

This section talks about defining a content source from where Microsoft Office SharePoint Server can crawl the data. This involves mapping the content to the Id Enumerator method instance created in Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts.

To define a content source

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and then click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the Shared Service Provider (SSP) where you want to configure the search application.

  3. On the Home page, in the Search section, click Search settings.

  4. On the Configure Search Settings page, in the left pane under Crawling, click Default content access account to specify an account to use as the default account when crawling content.

  5. On the Default Content Access Account page, specify the user name and password credentials, and click OK. You will return to the Search Administration page.

  6. In the left pane under Crawling, click Content Sources.

  7. On the Manage Content Sources page, click New Content Source.

  8. On the Manage Content Sources page, click New Content Source.

  9. On the Add Content Source page:

    1. Type MS_SAMPLE_EMPLOYEE in the Name box.

    2. In the Content Source Type area, click Business Data.

    3. In the Applications area, click Crawl selected applications, and then select the MS_SAMPLE_EMPLOYEE_Instance check box.

    4. In the Start Full Crawl area, select the Start full crawl of this content source check box, and then click OK.

      Add content source

  10. You will return to the Manage Content Sources page with the new content source added. The content source will crawl through the data in the MS_SAMPLE_EMPLOYEE interface table in the Oracle E-Business Suite. Wait until the crawling is completed.

  11. In the left pane under Crawling, click Crawl Log, and then verify the log file to ensure that the crawling is successful.

Define a Scope for the Crawled Content

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and then click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the Shared Service Provider (SSP) where you want to configure the search application.

  3. On the Home page, in the Search section, click Search settings.

  4. On the Configure Search Settings page, in the left pane under Queries and Results, click Scopes to define a scope for the crawling of data.

  5. On the View Scopes page, click New Scope.

  6. On the Create Scope page, type MS_SAMPLE_EMPLOYEE_Search in the Title box, and then click OK.

    Create a scope

  7. You will return to the View Scopes page with the new scope added. In the Update Status column for the newly added scope, click the Add rules link.

  8. On the Add Scope Rule page:

    1. In the Scope Rule Type area, click Content Source.

    2. In the Content Source list, click MS_SAMPLE_EMPLOYEE, and then click OK.

      Add a scope rule

  9. You will return to the View Scopes page with the rule added for the scope. In the left pane, click Search Administration.

  10. On the Search Administration page, locate the Scopes needing update row, and click the Start update now link.

The Scope update status row will display the status of the scope update. Wait until the update is complete. After the updated is completed, the scope is ready to be used.

Add the Scope to the Search Dropdown

After you have created the search scope, you must add the scope to the search dropdown in Microsoft Office SharePoint Server so that it can be used.

To add the scope to the search dropdown

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and then click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the Shared Service Provider (SSP) where you want to configure the search application.

  3. On the Shared Services Administration page, in the upper-right corner, click Site Actions, and then click Site Settings.

  4. On the Site Settings page, in the Site Collection Administration section, click Search scopes.

  5. On the View Scopes page, click the Search Dropdown link.

  6. On the Edit Scope Display Group page:

    1. In the Scopes area, select the MS_SAMPLE_EMPLOYEE_Search check box.

    2. In the Default Scope area, click MS_SAMPLE_EMPLOYEE_Search in the Default Scope list, and then click OK.

      Edit Scope Display Group page

  7. You will return to the View Scopes page with the MS_SAMPLE_EMPLOYEE_Search scope added in the Search Dropdown display group.

Add the Search Box Web Part

To enable the users to perform a full-text search on the MS_SAMPLE_EMPLOYEE interface table in Oracle E-Business Suite, you must now create a Web part page, and add a Search Box Web Part to it.

To add the Search Box Web Part

  1. Create a Web Part page called MS_SAMPLE_EMPLOYEE_Search. To know the steps for creating a Web Part page, see To create a Web Part page in Scenario 1: Display Data Using Business Data List Web Part.

  2. On the MS_SAMPLE_EMPLOYEE_Search page, click Add a Web Part.

  3. In the Add Web Parts dialog box, in the Search section, select the Search Box check box, and then click Add.

    Add the Search Box Web Part

  4. The Search Box Web part is added to the MS_SAMPLE_EMPLOYEE_Search page.

    Search Box Web Part

See Also

Tasks

Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite

Concepts

Scenario 1: Display Data Using Business Data List Web Part

© 2014 Microsoft Corporation. All rights reserved.


Step 4: Test Your SharePoint Application
Step 4 of 4

Time to complete: 10 minutes

Objective: After you have added Web Parts in the SharePoint site and created an application, you must test the application by retrieving some data from the Oracle E-Business Suite. This topic provides instructions on how to use the application to retrieve the data from the Oracle E-Business Suite.

Prerequisites

You should have created the Web Part page that contains the appropriate Web Parts to retrieve business data. See Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite.

Scenario 1: To test the SharePoint application created using Business Data List Web Part

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and then click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the SSP under which you created the application.

  3. In the left pane, click View All Site Content. In the right pane, click Form Templates.

  4. In the Form Category list, click MS_SAMPLE_EMPLOYEE. You specified this name when you created the Web Part page in Scenario 1: Display Data Using Business Data List Web Part.

  5. Search for employees based on a search string. For example, to search for all the employees, type % in the text box, and click Retrieve Data. The following figure shows the records retrieved from Oracle E-Business Suite:

  6. You can also search for a specific employee by entering their first name or last name:

    • To search using the first name, type the initial letters of an employee name followed by the % symbol to return records of all the employees matching the search criteria.

    • To search using the last name, type % followed by employee’s last name.

    Note
    The search string is case sensitive.

    Searching by first name of an employee

Scenario 2: To test the SharePoint application created to perform a full-text search

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and then click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the SSP under which you created the application.

  3. In the left pane, click View All Site Content. In the right pane, click Form Templates.

  4. In the Form Category list, click MS_SAMPLE_EMPLOYEE_Search. You specified this name when you created the Web Part page in Add the search-related Web Parts in Scenario 2: Perform a Search Using the Search Box Web Part.

  5. The MS_SAMPLE_EMPLOYEE_Search page displays the search box where you can perform a full-text search on the MS_SAMPLE EMPLOYEE table. For example, if you want to search for all the employees who live in New York, type New York in the search box, and press ENTER.

    Specify a search parameter

  6. A page appears with the search results. Each matching records is displayed as a link in the search results page.

  7. Click a link in the search result to view the respective employee record.

    Detailed employee record

Summary

In this tutorial, you created a WCF service for the Oracle E-Business Suite artifacts you want to access from a SharePoint Portal. You also created an application definition for the Oracle E-Business Suite artifacts that is imported into a SharePoint portal to create Web Parts to present and search data in Oracle E-Business Suite.

See Also

Other Resources

Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site

© 2014 Microsoft Corporation. All rights reserved.


Community Resources

There are two principal sources of information from Microsoft about the BizTalk Adapter Pack:

  • The documentation and samples installed with the BizTalk Adapter Pack.

  • The Microsoft BizTalk Adapter Pack forums.

BizTalk Adapter Pack Documentation

You can install the BizTalk Adapter Pack documentation when you install the BizTalk Adapter Pack. (For information about how to install the BizTalk Adapter Pack, see the installation guide. The installation guide is typically available at <installation drive>:\Program Files\Microsoft BizTalk Adapter Pack\Documents.) The core documentation covers the concepts and procedures required to use the BizTalk Adapter Pack.

After you install the BizTalk Adapter Pack Setup program, you can access the documentation through the Microsoft BizTalk Adapter Pack program group on the Start menu.

BizTalk Adapter Pack Samples

This BizTalk Adapter Pack release provides samples demonstrating how to use the adapters with:

  • BizTalk Server.

  • The Windows Communication Foundation (WCF) channel model.

  • The WCF service model.

  • Microsoft Office SharePoint Server.

The samples are available at http://go.microsoft.com/fwlink/?LinkID=196854.

BizTalk Adapter Pack Forums

You can post your queries about the BizTalk Adapter Pack on the forums.

Resource | Location
BizTalk Adapter Pack Forums | http://go.microsoft.com/fwlink/?LinkId=87695

See Also

Other Resources

Getting Started

© 2014 Microsoft Corporation. All rights reserved.


Frequently Asked Questions

This section contains frequently asked questions (FAQs) related to Microsoft BizTalk Adapter for Oracle E-Business Suite and the BizTalk Adapter Pack that you might have while learning or using the product. The FAQs are divided into four categories: General, BizTalk Server, WCF Service Model, and WCF Channel Model.

However, if you have specific questions related to Oracle E-Business adapter or BizTalk Adapter Pack that are not listed in this section, you can post your query on the BizTalk Adapter Pack forum at http://go.microsoft.com/fwlink/?LinkId=87695.

In This Section

  • General FAQs

  • BizTalk Server FAQs

  • WCF Service Model FAQs

  • WCF Channel Model FAQs

See Also

Other Resources

Getting Started

© 2014 Microsoft Corporation. All rights reserved.


General FAQs

The following are some frequently asked questions (FAQs) related to Microsoft BizTalk Adapter for Oracle E-Business Suite and the BizTalk Adapter Pack.

What are the supported BizTalk versions for the BizTalk Adapter Pack?

The BizTalk Adapter Pack is supported with Microsoft BizTalk Server 2013 R2.

What privileges are required to run the setup wizard?

You must always run the BizTalk Adapter Pack setup wizard with a user account that has administrative privileges on the computer.

What is WCF? Where can I read more about it?

WCF stands for Windows Communication Foundation. WCF is a programming framework developed by Microsoft for building service-oriented applications. WCF is a part of .NET framework, and enables developers to build secure, reliable, and transacted solutions that integrate across platforms and interoperate with existing investments. For more information about WCF, see http://go.microsoft.com/fwlink/?LinkID=196850.

What is WCF LOB Adapter SDK? Where can I read more about it?

The WCF LOB Adapter SDK is a collection of tools and components that provide a consistent framework for developing reusable, metadata-rich adapters for line-of-business systems. Adapters written using the WCF LOB Adapter SDK are surfaced as custom WCF bindings and can be consumed by a WCF-capable client.

For more information about WCF LOB Adapter SDK, see the WCF LOB Adapter SDK documentation, which is installed along with the WCF LOB Adapter SDK at the following location on your computer: <installation drive>:\Program Files\WCF LOB Adapter SDK\Documents.

How do I get started using the adapter?

To get started with using the Oracle E-Business adapter, you must figure out a role that suits you as a user of the adapter. The potential roles that are users of the Oracle E-Business adapter are the following: Developers, IT professionals, and Independent Software Vendors (ISVs). For information about the prerequisites for each of these roles, see Prerequisite Skills and Knowledge. For a list of tasks that are applicable for various users of the Oracle E-Business adapter, see Common Administrative Tasks and Common Developer Tasks.

How can I use the Oracle E-Business adapter to communicate with Oracle E-Business Suite?

You can use the Oracle E-Business adapter to communicate with Oracle E-Business Suite either by developing BizTalk applications, using the WCF service model or using the WCF channel model. For more information, see Overview of BizTalk Adapter for Oracle E-Business Suite.

What interfaces are supported by the Oracle E-Business adapter for retrieving metadata?

The Oracle E-Business adapter supports two interfaces for retrieving metadata:

  • MetadataExchange provided by WCF. WCF provides a metadata-exchange endpoint for all WCF bindings, which enables clients to get metadata from Oracle E-Business Suite.

  • IMetadataRetrievalContract provided by the WCF LOB Adapter SDK, which supports the metadata browsing and searching capabilities of the adapter.

How does the adapter connect to Oracle E-Business Suite?

The Oracle E-Business adapter uses Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7, Oracle Data Access Components for Oracle Client 11.1.0.7. The adapter clients must provide a connection string, connection Uniform Resource Identifier (URI), to connect to Oracle E-Business Suite. Internally, the adapter maps the connection URI to a connection string to connect to the underlying database in Oracle E-Business Suite. For more information, see Establishing a Connection to the Oracle E-Business Suite.

Does the Oracle E-Business adapter provide a secure way of communicating with the Oracle E-Business Suite? Are there any best practices to ensure data security?

The Oracle E-Business adapter supports Enterprise Single Sign-On (SSO) for authentication on the connections that it establishes with Oracle E-Business Suite. The SSO uses a database and a master secret to encrypt and store user credentials. It also provides services to map Microsoft Windows accounts to secondary credentials that are used to access a back-end system.

The Oracle E-Business adapter also requires you to enter username and password credentials to connect to Oracle E-Business Suite. These credentials are used to authenticate the user, and thus provide a level of authorization for the connections. The Oracle E-Business adapter provides a number of methods through which you can supply these credentials. For information about how to securely provide Oracle credentials in BizTalk solutions, see Security Considerations When Using the Adapter with BizTalk Server. For information about how to securely provide Oracle credentials in programming solutions, see Security Considerations When Programming on the Adapter.

For more information about:

  • Data security in the Oracle E-Business adapter, see Security and Protection.

  • Best practices to ensure data security in the Oracle E-Business adapter, see Best Practices.

Is there a GUI provided by the Oracle E-Business adapter to view and perform operations on the artifacts in Oracle E-Business Suite?

The Consume Adapter Service BizTalk Project Add-in and the Add Adapter Service Reference Visual Studio Plug-in provide a dialog box where you can view and perform operations on the artifacts in Oracle E-Business Suite. For more information about the GUI provided by the Oracle E-Business adapter, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

What are binding properties in the Oracle E-Business adapter? Where can I find information about all the binding properties in the Oracle E-Business adapter?

Adapter clients can use binding properties in the Oracle E-Business adapter to configure and control the adapter’s behavior. For information about all the binding properties surfaced in the Oracle E-Business adapter, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

What are inbound and outbound operations in the Oracle E-Business adapter?

In inbound operations, the LOB system (Oracle E-Business Suite) is the client and the adapter clients are the service, wherein the transactions originate from Oracle E-Business Suite. For example, the Polling and Notification operations.

In outbound operations, the adapter clients are the client and the LOB system (Oracle E-Business Suite) becomes the service, wherein the transactions originate from the adapter clients. For example, the Insert, Select, Update, and Delete Operation on Interface tables, operation on stored procedures and functions, and composite operations.

Where can I find information about the Oracle data types that are supported in the Oracle E-Business adapter?

For information about the Oracle data types supported in the Oracle E-Business adapter, see Basic Oracle Data Types.

What is applications context? How can I set applications context for various Oracle artifacts in the Oracle E-Business adapter?

For information about applications context and how to set it in the Oracle E-Business adapter, see Setting Application Context.

Which approach (BizTalk Server, WCF service model or WCF channel model) can I use to perform various operations using the Oracle E-Business adapter?

For information about the approach you can use to perform various operations using the Oracle E-Business adapter, see Development.

Does the Microsoft BizTalk Adapter Pack support tracing?

Microsoft BizTalk Adapter Pack enables adapter clients to activate Windows Communication Foundation (WCF) tracing and adapter-specific tracing. For more information about tracing, see Diagnostic Tracing and Message Logging.

Where are the trace files stored?

The trace files are stored at a location that the adapter clients specify. The adapter clients can specify this location when enabling tracing. For more information about tracing, see Diagnostic Tracing and Message Logging.

How do I view the traces?

You can use the WCF Service Trace Viewer tool to view the traces. For more information about the tool, see “Using Service Trace Viewer for Viewing Correlated Traces and Troubleshooting” at http://go.microsoft.com/fwlink/?LinkId=91243.

See Also

Other Resources

Frequently Asked Questions

© 2014 Microsoft Corporation. All rights reserved.


BizTalk Server FAQs

The following are some frequently asked questions (FAQs) related to Microsoft BizTalk Adapter for Oracle E-Business Suite and the BizTalk Server.

Which BizTalk Server tools are used while working with SQL adapter? Where can I find more information about these tools?

You should have a working knowledge of the following BizTalk Server tools: BizTalk Explorer, Orchestration Designer, Pipeline Designer, BizTalk Mapper, and BizTalk Server Administration console. For more information about these tools, see Learn About BizTalk Server Tools.

Can I reuse bindings of a BizTalk application? How?

A binding creates a mapping between a logical endpoint such as an orchestration port or a role link and a physical endpoint such as a send and receive port. This enables communication between different components of a BizTalk business solution. The binding information is stored in an XML file that contains binding information for each BizTalk orchestration in the scope of a BizTalk assembly, application, or group. You can export the bindings of a BizTalk assembly, application, or group, and then reuse it by importing into any other BizTalk application or group. For more information, see Reusing Adapter Bindings.

What is the “Transaction Isolation Level”? How can I configure it?

The transaction isolation level determines the degree to which a transaction is isolated from the data changes made by other transactions. It defines the locking behavior of the Transact-SQL commands issued by a connection to the Oracle database. For more information about the transaction isolation level, see http://go.microsoft.com/fwlink/?LinkId=126985.

For instructions about configuring transaction isolation level in BizTalk Server, see Configure Transaction Isolation Level and Transaction Timeout.

See Also

Other Resources

Frequently Asked Questions

© 2014 Microsoft Corporation. All rights reserved.


WCF Service Model FAQs

The following are some frequently asked questions (FAQs) related to Microsoft BizTalk Adapter for Oracle E-Business Suite and the Windows Communication Foundation (WCF) service model.

What is the WCF service model?

The WCF service model is a programming model provided by WCF in which the LOB system (Oracle E-Business Suite) is exposed as a WCF service. The service contract that exists between a client and a service is represented as a .NET interface, and operations are represented as methods on this interface. The WCF service model generates a proxy class—the WCF client class—through which your code can invoke operations and receive data using the Oracle E-Business adapter. For more information about the WCF service model, see Developing Applications By Using the WCF Service Model.

Why would I want to use the WCF service model rather than the WCF channel model?

The WCF service model presents a model that is familiar to .NET programmers and that hides the underlying complexities of SOAP message exchange over a channel. Moreover, the Add Adapter Service Reference Plug-in is integrated with the Visual Studio design experience, and presents a standard Microsoft Windows interface that provides powerful browsing and searching capabilities on operations exposed by the adapter. Therefore, the WCF service model is often the best choice to develop programming solutions for the Oracle E-Business adapter.

How do I get started with the WCF service model?

You can use either of the following tools provided by the WCF service model to generate a WCF client class or a WCF service contract and associated helper code from the service metadata that the Oracle E-Business adapter exposes:

  • The ServiceModel Metadata Utility Tool (svcutil.exe), which ships with WCF.

  • The Add Adapter Service Reference Visual Studio Plug-in, which ships with the Oracle E-Business adapter.

For more information about how to generate a WCF client or a WCF service contract, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

See Also

Other Resources

Frequently Asked Questions

© 2014 Microsoft Corporation. All rights reserved.


WCF Channel Model FAQs

The following are some frequently asked questions (FAQs) related to Microsoft BizTalk Adapter for Oracle E-Business Suite and the Windows Communication Foundation (WCF) channel model.

What is the WCF channel model?

The WCF channel model is a low-level abstraction of the SOAP message exchange between clients and services. It provides interfaces and types that enable you to send and receive messages by using a layered protocol stack called a channel stack. Each layer of the stack is composed of a channel, and each channel is created from a WCF binding. The Oracle E-Business adapter is a WCF custom transport binding that exposes an Oracle database as a WCF service. For more information about the WCF channel model, see Overview of Using the WCF Channel Model with the Adapter.

Why would I want to use the WCF channel model rather than the WCF service model?

You would want to use the WCF channel model over the WCF service model because:

  • The WCF channel model provides more fine-grained control over the operations that you perform on the Oracle database because in the WCF channel model, you directly control the contents of the messages that you send over the channel.

  • The WCF channel model provided more comprehensive support for end-to-end streaming of Oracle large object (LOB) data types than the WCF service model. This is because in the WCF channel model, you directly control how you provide the message body on outgoing messages and how you process the message body on incoming messages.

How do I get started with the WCF channel model?

Using the WCF channel model, you can invoke operations and receive the results of a polling query by exchanging SOAP messages with the Oracle E-Business adapter over a WCF channel. To get started, you need to create outbound (client) and inbound (service) channels. For more information about creating channels in the WCF channel model, see Creating a Channel.

See Also

Other Resources

Frequently Asked Questions

© 2014 Microsoft Corporation. All rights reserved.


Planning and Architecture

This section describes the architecture for the Microsoft BizTalk Adapter for Oracle E-Business Suite. An understanding of the Oracle E-Business adapter architecture can help you:

  • Understand the relationship between the Oracle E-Business adapter and the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK.

  • Understand security boundaries, so that you can better secure data in your solution.

  • Understand the Oracle E-Business adapter binding properties.

  • Troubleshoot installation issues.

The following topics describe the architecture of end-to-end solutions that use the Oracle E-Business adapter to operate on an Oracle database and the internal architecture of the Oracle E-Business adapter.

In This Section

  • Architecture of BizTalk Adapter for Oracle E-Business Suite

  • Oracle E-Business Suite Adapter and the WCF LOB Adapter SDK

© 2014 Microsoft Corporation. All rights reserved.


Architecture of BizTalk Adapter for Oracle E-Business Suite

The Microsoft BizTalk Adapter for Oracle E-Business Suite is a Windows Communication Foundation (WCF) custom binding. This binding contains a single custom transport binding element that enables communication with an Oracle E-Business Suite. The Oracle E-Business adapter is wrapped by the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK runtime and is exposed to applications through the WCF channel architecture. The Oracle E-Business adapter communicates with the Oracle E-Business Suite through the Oracle Data Provider for .NET (ODP.NET) and the Oracle client, which are part of the Oracle Data Access Components (ODAC) for Windows.

The following figure shows the end-to-end architecture for solutions that are developed by using the Oracle E-Business adapter.

Oracle Database adapter architecture diagram

Consuming the Adapter

The Oracle E-Business adapter exposes the Oracle E-Business Suite as a WCF service to client applications. To perform operations and access data on the Oracle E-Business Suite, client applications exchange SOAP messages with the Oracle E-Business adapter through WCF channels. The preceding figure shows four ways in which the Oracle E-Business adapter can be consumed.

  • Through a WCF channel model application. A WCF channel model application performs operations on the Oracle E-Business Suite by using the WCF channel model to exchange SOAP messages directly with the Oracle E-Business adapter.

  • Through a WCF service model application. A WCF service model application calls methods on a WCF client to perform operations on the Oracle E-Business Suite. A WCF client models the operations exposed by the Oracle E-Business adapter as .NET methods. You can use the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK or the WCF ServiceModel Metadata Utility Tool (svcutil.exe) to create a WCF client class from metadata exposed by the Oracle E-Business adapter.

  • Through a BizTalk receive location or send port that is configured to use the Microsoft BizTalk WCF-Custom adapter. The WCF-Custom adapter enables the use of WCF extensibility features. By using the WCF-Custom adapter you can select and configure the Oracle EBS Binding and the behavior for the receive location or send port. For more information about how to use the Oracle E-Business adapter in BizTalk Server solutions, see Developing BizTalk Applications.

  • Through an IIS-hosted Web service. In this scenario, a WCF service proxy generated by using the adapter is hosted in IIS using the basicHttpBinding WCF binding. This exposes the service contract as a Web service to external users. IIS automatically hosts the adapter at runtime, which, in turn, communicates with the Oracle E-Business Suite.

The Oracle E-Business adapter and ODAC are always hosted in-process with the application or service that consumes the adapter.

The Oracle E-Business Adapter and WCF

WCF presents a programming model based on the exchange of SOAP messages over channels between clients and services. These messages are sent between endpoints exposed by a communicating client and service. An endpoint consists of:

  • An endpoint address, which specifies the location at which messages are received

  • A binding, which specifies the communication protocols used to exchange messages

  • A contract, which specifies the operations and data types exposed by the endpoint.

A binding consists of one or more binding elements that stack on top of each other to define how messages are exchanged with the endpoint. At a minimum, a binding must specify the transport and encoding that are used to exchange messages with the endpoint. Message exchange between endpoints occurs over a channel stack that is composed of one or more channels. Each channel is a concrete implementation of one of the binding elements in the binding configured for the endpoint. For more information about WCF and the WCF programming model, see the WCF Help documentation at http://go.microsoft.com/fwlink/?LinkID=196850.

The Microsoft BizTalk Adapter for Oracle E-Business Suite exposes a WCF custom binding, the Oracle E-Business Suite Binding (Microsoft.Adapters.OracleEBS.OracleEBSBinding). By default, this binding contains a single custom transport binding element, the Oracle E-Business Suite Adapter Binding Element (Microsoft.Adapters.OracleEBS.OracleEBSAdapter), which enables operations on an Oracle E-Business Suite.

Microsoft.Adapters.OracleEBS.OracleEBSBinding (the Oracle E-Business Suite Binding) and Microsoft.Adapters.OracleEBS.OracleEBSAdapter (the Oracle E-Business Suite Adapter Binding Element) are public classes and are also exposed to the configuration system. Because the Oracle E-Business Suite Adapter Binding Element is exposed publicly, you can build your own custom WCF bindings capable of extending the functionality of the Oracle E-Business adapter. For example, you could implement a custom binding to support Enterprise Single Sign-on (SSO) in a WCF channel or service model solution. The reasons for doing this would be to aggregate database operations into a single multifunction operation or to perform schema transformation between operations implemented by a custom application and operations on the Oracle E-Business Suite.

The Oracle E-Business adapter is built on top of the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK and runs on top of the WCF LOB Adapter SDK runtime. The WCF LOB Adapter SDK provides a software framework and tooling infrastructure that the Oracle E-Business adapter uses to provide a rich set of features to users and adapter clients.

ODP.NET

The Oracle E-Business adapter connects with the Oracle E-Business Suite through the ODP.NET and the Oracle client. Both of these components are part of Oracle Data Access Components (ODAC).

ODP.NET implements a data provider for the Oracle E-Business Suite that is consistent with the ADO.NET interface. The Oracle E-Business adapter uses the classes exposed by ODP.NET to operate on the Oracle E-Business Suite.

The Oracle client provides connectivity to the Oracle E-Business Suite. You establish a connection to an Oracle E-Business Suite by providing a connection URI to the Oracle E-Business adapter. You can specify the connection URI in two ways:

  • Using tnsnames.ora. In this approach, the connection URI provided by the adapter client contains only the net service name specified in the tnsnames.ora file. The adapter extracts the connection parameters such as server name, service name, port number, etc. from the net service name entry in the file. To use this approach, the computer running the Oracle client must be configured to include the net service name for the Oracle database in the tnsnames.ora file.

  • Without using tnsnames.ora. In this approach, the adapter clients specify the connection parameters directly in the connection URI. This does not require the net service name to be present in the tnsnames.ora file on the client computer. This approach does not even require the tnsnames.ora file to be present on the client computer.

For more information about the connection URI, see Establishing a Connection to the Oracle E-Business Suite. For more information about installing ODAC, see Installing the BizTalk Adapter Pack.

See Also

Other Resources

Planning and Architecture

© 2014 Microsoft Corporation. All rights reserved.


Oracle E-Business Suite Adapter and the WCF LOB Adapter SDK

The Microsoft BizTalk Adapter for Oracle E-Business Suite implements a set of core components that uses functionality provided by the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK and provides connectivity to the Oracle database through Oracle Data Provider for .NET (ODP.NET).

The WCF LOB Adapter SDK serves as the software layer through which the Oracle E-Business adapter interfaces with the Windows Communication Foundation (WCF). ODP.NET serves as the layer through which the Oracle E-Business adapter interfaces with the Oracle database. The following figure shows the relationships between the internal components of the Oracle E-Business adapter, WCF LOB Adapter SDK, and ODP.NET.

Oracle E-Business adapter internal architecture

See Also

Other Resources

Planning and Architecture

© 2014 Microsoft Corporation. All rights reserved.


Security and Protection

Oracle E-Business applications deal with sensitive business information such as customer account details. Applications that use the Microsoft BizTalk Adapter for Oracle E-Business Suite to access and modify this information either locally or across a distributed network might inadvertently expose it to access by unauthorized actors, unless efforts are made to protect and secure the data during transmission. Data protection and security are usually thought of in the following terms:

  • Authorization controls access to a resource based on the identity of the requester.

  • Authentication provides mechanisms for verifying the identity of a requester.

  • Data confidentiality provides mechanisms for protecting the privacy of data through encryption.

  • Data integrity provides mechanisms to digitally sign data, so that the receiver can ensure that the data has not been altered in-transit.

Another important area of concern is the user-name password credentials that you supply to the Oracle E-Business adapter. The adapter uses these credentials to open connections to the Oracle database. These credentials can be supplied in the connection URI; however, because the user name and password are clear text, the Oracle E-Business adapter provides alternative methods that you can use to supply these credentials in a more secure manner.

The topics in this section provide guidelines to help you better secure the solutions that you develop with the Oracle E-Business adapter.

In This Section

  • Security Considerations Between Oracle E-Business Suite and the Adapter

  • Security Considerations When Using the Adapter with BizTalk Server

  • Security Considerations When Programming on the Adapter

  • Best Practices

© 2014 Microsoft Corporation. All rights reserved.


Security Considerations Between Oracle E-Business Suite and the Adapter

The Oracle E-Business adapter provides no support for helping to secure communication between it and the Oracle database. You must provide a security mechanism to help ensure appropriate levels of authorization, authentication, data privacy, and data integrity for data exchanges between the adapter and the Oracle database.

One possible mechanism for helping to provide more security across the network is Internet Protocol Security (IPsec). IPsec is a framework of open standards for protecting communications over Internet Protocol (IP) networks. For more information about IPsec and about using IPsec with Microsoft products, see the Microsoft TechNet article "IPsec" at http://go.microsoft.com/fwlink/?LinkID=196851.

However, in the absence of security mechanisms like IPsec, the administrator must configure native Oracle data encryption and integrity to ensure secure data exchanges between the adapter client and Oracle E-Business Suite.

You must supply user name password credentials to the Oracle E-Business adapter. The Oracle E-Business adapter uses these credentials to authenticate the user on the Oracle database when it opens a connection. These credentials provide a level of authorization on the Oracle database for the connection.

Note
The credentials used by the Oracle E-Business adapter to establish a connection on the Oracle database do not provide message-level or transport-level authentication or authorization for data traveling across the network. They are only used to open a connection and authenticate the user on the Oracle database.

The Oracle E-Business adapter provides a number of methods through which you can supply these credentials. For information about how to more securely provide Oracle credentials in BizTalk solutions, see Security Considerations When Using the Adapter with BizTalk Server. For information about how to more securely provide Oracle database credentials in programming solutions, see Security Considerations When Programming on the Adapter.

Managing Audit Logs

Audit logs enable you to store information about the actions performed by various clients on your enterprise software, and helps usage monitoring and problem tracking. However, the Oracle E-Business adapter does not provide any way to manage audit logs for the actions performed by the adapter clients in Oracle E-Business Suite. This might pose a security threat as the adapter clients can repudiate the actions performed by them in Oracle E-Business Suite. To mitigate this issue, you must enable audit trail in Oracle to log the actions performed by the adapter clients in Oracle E-Business Suite. For information about how you can set up Oracle audit trails, see the “Oracle Workflow - Oracle E-Business Suite Process” white paper at http://go.microsoft.com/fwlink/?LinkId=136388.

See Also

Concepts

Best Practices

Other Resources

Security and Protection

© 2014 Microsoft Corporation. All rights reserved.


Security Considerations When Using the Adapter with BizTalk Server

When you configure a send port or a receive port (location) by using the BizTalk Server Administration console or use the Consume Adapter Service BizTalk Project Add-in to retrieve message schemas for a BizTalk solution, you must provide credentials for the Oracle E-Business Suite. It is important to supply these credentials in a secure way to help prevent them from being revealed to potentially malicious actors. This topic discusses how to most securely supply credentials for the Microsoft BizTalk Adapter for Oracle E-Business Suite for BizTalk Server solutions.

A more general discussion of security in the context of BizTalk solutions is an expansive topic and is beyond the scope of this documentation. For information about how you can make your BizTalk solutions more secure, see the "Security and Protection" topic in the BizTalk Server Help documentation at http://go.microsoft.com/fwlink/?LinkID=101135.

How Do I Protect Credentials When I Use the Consume Adapter Service BizTalk Project Add-in or Add Adapter Metadata Wizard?

When you use the Consume Adapter Service Add-in or the Add Adapter Metadata Wizard to retrieve message schemas for a BizTalk solution, you can provide credentials to connect to Oracle E-Business Suite in the following two places:

  • On the Security tab in the Configure Adapter dialog box. This ensures that your credentials will not be displayed in the Configure a URI field of the Consume Adapter Service Add-in dialog box, where anyone with access to your computer screen can read them.

  • In the OracleUserName and OraclePassword binding properties on the Binding Properties tab in the Configure Adapter dialog box. For security reasons, the OraclePassword binding property is not available in the binding file (XML file) file generated as a result of using the Consume Adapter Service Add-in.

    Note
    Using the Add Adapter Metadata Wizard does not generate any binding file.

For more information about how to retrieve message schemas by using the Consume Adapter Service Add-in or Add Adapter Metadata Wizard, see Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio.

How Do I Protect Credentials When I Configure a Send Port or a Receive Location?

BizTalk solutions use the Microsoft BizTalk WCF-Custom or WCF-Oracle EBS adapter to consume WCF services. The Oracle E-Business adapter is a WCF binding that enables clients to consume the Oracle E-Business Suite as if it were a WCF service. BizTalk solutions consume the Oracle E-Business adapter through send ports and receive locations that are configured to use the WCF-Custom or WCF-OracleEBS adapter, which is, in turn, configured to use the Oracle E-Business adapter as its transport. For more information about how to configure send ports and receive ports (receive locations), including how to configure the WCF-Custom adapter, see Configuring a Physical Port Binding Using a Port Binding File.

You configure the Oracle E-Business Suite credentials from the Credentials tab of the WCF-Custom Transport Properties dialog box for send ports or from the Other tab of the WCF-Custom Transport Properties dialog box for receive locations. Because the WCF-Custom or WCF-Oracle EBS adapter supports Enterprise Single Sign-On (SSO), you can choose to provide either a user name and password or an SSO affiliate application on either of these tabs. The following topics discuss both options.

User Name Password Credentials

You should only supply a user name and password from the Credentials tab (for send ports) or the Other tab (for receive locations) in the WCF-Custom Transport Properties dialog box. This ensures the following:

  • Your credentials will not be displayed in the Address (URI) field of the dialog box. This prevents those who have access to your screen (or who have permissions that enable them to view the send port or receive location properties) from seeing your credentials.

  • Your password will not be written to the binding file if you export the send port or receive port binding. This prevents anyone from with access to the file from viewing your password.

OraclePassword Binding Property

The value that you specify in the OraclePassword binding property for the send or receive port is available in clear text when you export bindings from an application in BizTalk Server. Therefore, after exporting a binding file from an application in BizTalk Server, you must manually remove the value of the OraclePassword binding property from the binding file, and then specify it again on each host where the exported binding will be used.

Enterprise Single Sign-On and SSO Affiliate Applications

You can configure the WCF-Custom adapter to use Enterprise Single Sign-on (SSO) to get the credentials for the Oracle E-Business Suite. SSO uses a database and a master secret to encrypt and store user credentials. It also provides services to map Microsoft Windows accounts to secondary credentials that are used to access a back-end system. By using SSO, you can map a Windows account to a user name and password on the Oracle database.

SSO uses affiliate applications and SSO mappings to map credentials to the back-end system. An affiliate application is a logical entity in SSO that refers to a system or an application that requires secondary credentials. An SSO mapping is associated with an affiliate application. It maps a Windows account to the secondary credentials used by that account to access the affiliate system or application. An SSO mapping can be associated with a Windows user account or with a group.

To use SSO with the Oracle Database adapter, you must do the following.

  1. Create an affiliate application in SSO to hold the user name password credentials for the Oracle E-Business Suite. This step is often performed by someone with special types of SSO administrative privileges.

  2. Create a user or group mapping for the affiliate application that maps your Windows account to the user name and password that are used to establish a connection with the Oracle database. Depending on your installation, a user might be able to perform this step or it might require someone with special types of SSO administrative privileges.

Note
When configured for SSO, the WCF-Custom adapter uses services provided by SSO to get the Oracle user name and password from the SSO database. It provides these (unencrypted) to the Oracle E-Business adapter, so that the adapter can open a connection to the Oracle E-Business Suite. SSO provides no encryption or protection across the connection between the Oracle E-Business adapter and the Oracle E-Business Suite.

For information about how to use SSO, including information about how to create affiliate applications and SSO mappings, see the "Using SSO" topic in the BizTalk Server documentation at http://go.microsoft.com/fwlink/?LinkId=103052. For more general information about SSO, see the "Implementing Enterprise Single Sign-On" topic in the BizTalk Server documentation at http://go.microsoft.com/fwlink/?LinkId=103054.

The AcceptCredentialsInUri Binding Property

The Oracle E-Business adapter surfaces the AcceptCredentialsInUri binding property. This property determines whether Oracle database or Oracle E-Business Suite credentials are permitted in the connection URI. By default, AcceptCredentialsInUri is false and the Oracle E-Business adapter throws an exception if credentials are included in the URI.

This property is surfaced because there are certain programming scenarios that require the credentials to be present in the connection URI. This should never be the case when you are configuring a send port or a receive location, or when you are using the Consume Adapter Service Add-in to retrieve message schemas from the Oracle E-Business adapter. It is recommended that you do not set AcceptCredentialsInUri to true. For more information about the Oracle E-Business adapter binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

The AcceptCredentialsInUri binding property is not available in BizTalk Server in the Binding tab while configuring a WCF-Custom or WCF-OracleEBS receive or send port. To set the value of the AcceptCredentialsInUri binding property, you must open the adapter bindings file (XML file) that is created after you have generated metadata using the Consume Adapter Service Add-in, and then locate this binding property in the file. Specify an appropriate value for this binding property, save the binding file, and then import the binding file in BizTalk Server. See Importing Bindings for instructions.

See Also

Concepts

Best Practices

Other Resources

Security and Protection

© 2014 Microsoft Corporation. All rights reserved.


Security Considerations When Programming on the Adapter

How Do I Protect Credentials When I Use the Add Adapter Service Reference Visual Studio Plug-in?

When you use the Add Adapter Service Reference Plug-in to create a WCF client, you must supply a user name and password for the Oracle E-Business Suite. You should only do this from the Security tab on the Configure Adapter dialog box. By entering the Oracle credentials from the Security tab instead of directly into the Configure a URI field, you ensure the following:

  • The credentials will not be displayed in the Configure a URI field of the Add Adapter Service Reference Plug-in dialog box where anyone with access to your computer screen can read them.

  • The credentials will not appear in the configuration file that the Add Adapter Service Reference Plug-in generates.

For more information about how to generate a WCF client by using the Add Adapter Service Reference Plug-in, including how to enter a user name and password for the Oracle E-Business Suite, see Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio.

What Are Best Practices for Setting Credentials in Code?

WCF provides the ClientCredentials class to help you configure the credentials that a client communication object, such as a ChannelFactory, uses to authenticate itself with a service. By using the ClientCredentials class, you ensure that WCF takes whatever authentication mechanisms are specified in that object’s channel stack and applies them to the exchange between your client and the service.

Because the Microsoft BizTalk Adapter for Oracle E-Business Suite is hosted in-process with its consuming application, it is not imperative to use the ClientCredentials class to set credentials on the client communication objects that the consuming application uses. It is, however, considered good practice to do so.

The Oracle E-Business adapter encourages the use of the ClientCredentials class. This property specifies whether the adapter will accept the user name and password for the Oracle database in the connection URI. AcceptCredentialsInUri defaults to false, which means that the adapter will throw an exception if the connection URI contains credentials. You can set AcceptCredentialsInUri to true to supply credentials in the connection URI, if required in the client application.

The following example shows how to use the Credentials property to set credentials for the Oracle E-Business Suite on a ChannelFactory.

Copy Code
// Create binding and endpoint
OracleEBSBinding binding = new OracleEBSBinding();
EndpointAddress address = new EndpointAddress("oracleebs://ebs-instance");

// Create the channel factory
ChannelFactory<IRequestChannel> factory = new ChannelFactory<IRequestChannel>(binding, address);

// Set user name and password
factory.Credentials.UserName.UserName = "myuser";
factory.Credentials.UserName.Password = "mypassword";

// Open the channel factory
factory.Open();

The following example shows how to use the ClientCredentials class to set credentials for the Oracle E-Business Suite on a WCF client.

Copy Code
// Initialize a new client for the SQLEXECUTE operation from configuration
ConcurrentPrograms_ARClient client =
  new ConcurrentPrograms_ARClient("OracleEBSBinding_ConcurrentPrograms_AR");

// Set user name and password
client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";

// Open the client
client.Open();

How Can I Provide for More Secure Data Exchange Across Process Boundaries?

The Oracle E-Business adapter is hosted in-process with the application or service that consumes it. Because the adapter is hosted in-process with the consumer, there is no need to provide security on messages exchanged between the consumer and the Oracle E-Business adapter. However, if the consuming application or service sends messages that contain sensitive database information across a process boundary to another service or client, you should take measures to provide adequate protection for this data in your environment. Windows Communication Foundation (WCF) provides many options for helping to secure messages sent between clients and services. For more information about helping to secure messages sent between clients and services in WCF, see "Securing Services and Clients" at http://go.microsoft.com/fwlink/?LinkId=89725. For more general information about security features that WCF provides, see "Windows Communication Foundation Security" at http://go.microsoft.com/fwlink/?LinkId=89726.

See Also

Other Resources

Security and Protection

© 2014 Microsoft Corporation. All rights reserved.


Best Practices

This section provides best practices that you should follow to more completely protect sensitive data when you use or develop applications that consume the Microsoft BizTalk Adapter for Oracle E-Business Suite.

Security Best Practices for the Connection between the Oracle E-Business Adapter and the Oracle Database

  • The Oracle E-Business adapter provides no support for helping to secure communication between it and the Oracle E-Business Suite. You must provide a mechanism to help ensure an adequate level of security for data exchanged between the adapter and the Oracle database.

  • Do not provide user name password credentials for the Oracle database in the connection URI. See the following sections for alternative methods of providing credentials to the Oracle E-Business adapter.

  • The Oracle E-Business adapter also enables you to use Windows Authentication while connecting to Oracle E-Business Suite to generate metadata and perform operations, either through Visual Studio or BizTalk Server. Before using Windows Authentication, you must perform the steps listed in Connecting to Oracle E-Business Suite Using Windows Authentication.

For more information, see Security Considerations Between Oracle E-Business Suite and the Adapter.

Security Best Practices for Consuming the Oracle E-Business Adapter with BizTalk Server

  • You should avoid providing user name password credentials for Oracle E-Business Suite in the connection URI.

  • When you use the Consume Adapter Service Add-in, enter the user name password credential for Oracle E-Business Suite from the Security tab of the Configure Adapter dialog box.

  • When you configure the BizTalk WCF-Custom adapter for the Oracle E-Business adapter on a send port, enter the user name password credential for the Oracle database from the Credentials tab of the Configure WCF Custom Transport dialog box.

  • When you configure the BizTalk WCF-Custom adapter for the Oracle E-Business adapter on a receive location, enter the user name password credential for the Oracle database from the Other tab of the Configure WCF Custom Transport dialog box.

  • After exporting a binding file from an application in BizTalk Server, you must manually remove the value of the OraclePassword binding property (available in clear text) from the binding file, and then specify it again on each host where the exported binding will be used.

  • The Oracle E-Business adapter also enables you to use Windows Authentication while connecting to Oracle E-Business Suite to generate metadata and perform operations, either through Visual Studio or BizTalk Server. Before using Windows Authentication, you must perform the steps listed in Connecting to Oracle E-Business Suite Using Windows Authentication.

  • If an application that consumes the Oracle E-Business adapter sends messages that contain sensitive database information across a process boundary to another service or client, ensure that these messages have sufficient security measures applied to provide adequate data protection in your environment.

For more information, see Security Considerations When Using the Adapter with BizTalk Server.

Security Best Practices for Consuming the Oracle E-Business Adapter with Programming Solutions

  • You should avoid providing user name password credentials for the Oracle database in the connection URI.

  • When you use the Add Adapter Service Reference Visual Studio Plug-in, enter the user name password credential for the Oracle database from the Security tab of the Configure Adapter dialog box.

  • In WCF channel model programming, use the Credentials property on the channel factory to set the user name password credential for the Oracle database.

  • In WCF service model programming, use the ClientCredentials property on the WCF client to set the user name password credential for the Oracle database.

  • If an application that consumes the Oracle E-Business adapter sends messages that contain sensitive database information across a process boundary to another service or client, ensure that these messages have sufficient security measures applied to provide adequate data protection in your environment.

  • The Oracle E-Business adapter also enables you to use Windows Authentication while connecting to Oracle E-Business Suite to generate metadata and perform operations, either through Visual Studio or BizTalk Server. Before using Windows Authentication, you must perform the steps listed in Connecting to Oracle E-Business Suite Using Windows Authentication.

For more information see, Security Considerations When Programming on the Adapter.

Security Best Practices for Hosting the Oracle E-Business Adapter in IIS

Hosting the Oracle E-Business adapter in Microsoft Internet Information Services (IIS) as a Web service exposes operations surfaced by the Oracle E-Business adapter to Web clients. These operations might involve exchanging sensitive data over the Internet, so you should take measures to help ensure that this data is as secure as possible.

WCF provides two standard bindings for HTTP transport: the BasicHttpBinding provides basic HTTP transport with no security mechanisms; the WSHttpBinding supports both transport-level and message-level security mechanisms.

You can either use the BasicHttpBinding over an HTTPS connection, or use the WSHttpBinding to help protect your data. The WCF LOB Adapter SDK includes the WCF LOB Adapter Service Development Wizard to generate WCF service for LOB artifacts. This wizard only supports use of BasicHttpBinding.

You can also develop a custom HTTP binding to leverage additional security mechanisms that your environment provides. For more information about the security features that WCF provides, see "Securing Services and Clients" at http://go.microsoft.com/fwlink/?LinkId=89725.

Security Best Practices for WCF Diagnostic Tracing and Message Logging

WCF supports diagnostic tracing and message logging. You configure diagnostic tracing and message logging either through configuration files or by using Windows Management Instrumentation (WMI). Depending on the configuration options you set, WCF diagnostic tracing or message logging can emit sensitive information to log files, where it could potentially be exposed to observation by unauthorized users.

Follow the recommendations provided in the WCF documentation to mitigate potential security threats exposed by enabling these features. At a minimum, you should observe the following best practices for diagnostic tracing and message logging:

  • Do not enable “verbose” or “information” tracing in a production environment. This may lead to performance degradation. However, you must enable “warning” and “error” tracing in a production environment. If you enable tracing, you must take proper security measures to protect your data. See the WCF documentation for more information.

  • Ensure that log files and configuration files are protected by access control lists (ACLs).

The following warnings apply specifically to the messages that are exchanged between a client application and the Oracle E-Business adapter:

  • WCF diagnostic tracing can log the header (but not the body) of messages exchanged with the Oracle E-Business adapter. Because the message action is in the message header, this reveals the operations invoked on the Oracle E-Business adapter by the client.

  • If WCF message logging is enabled and logMessagesAtServiceLevel is true, the message header (but not the message body) of messages exchanged between the adapter client and the Oracle E-Business adapter are logged. Because the message action is in the message header, this reveals the operations that the client invoked on the Oracle E-Business adapter. If logEntireMessage is also true, the message body will be logged. This can reveal sensitive database information.

For more information about improving security when you enable diagnostic tracing, see "Security Concerns and Useful Tips for Tracing" at http://go.microsoft.com/fwlink/?LinkId=89796. For more information about improving security when you enable message logging, see "Security Concerns for Message Logging" at http://go.microsoft.com/fwlink/?LinkId=89797.

See Also

Other Resources

Security and Protection

© 2014 Microsoft Corporation. All rights reserved.


Development

The Microsoft BizTalk Adapter for Oracle E-Business Suite is a Windows Communication Foundation (WCF) binding. Client applications can consume the Oracle E-Business adapter to invoke operations on Oracle E-Business Suite artifacts. The Oracle E-Business adapter can be consumed:

  • Through a physical port binding in a BizTalk Server solution.

  • By invoking methods on an instance of a client proxy.

  • By sending SOAP messages over a channel instance in code that uses the WCF channel model.

The following table:

  • Lists the different operations that can be performed on Oracle E-Business Suite using the Oracle E-Business adapter.

  • Provides links to the topics containing information about performing the task using the chosen approach (BizTalk Server, WCF service model or WCF channel model).

Operation | BizTalk Server | WCF Service Model | WCF Channel Model
Performing operations on interface tables and views | Performing Insert, Update, Delete, or Select Operations on Interface Tables and Interface Views Using BizTalk Server | Performing Insert, Update, Delete, or Select Operations on Interface Tables and Views Using the WCF Service Model | Performing an Insert Operation on an Interface Table Using the WCF Channel Model
Performing operations on tables and views with large data types | Performing Operations on Tables with Large Data Types Using BizTalk Server | Performing Operations on Tables with Large Data Types Using the WCF Service Model |
Performing composite operations on Oracle database | Performing Composite Operations on Oracle Database by Using BizTalk Server |  |
Invoking concurrent programs in Oracle E-Business Suite | Invoking Concurrent Programs in Oracle E-Business Suite Using BizTalk Server | Invoking Concurrent Programs in Oracle E-Business Suite Using the WCF Service Model |
Invoking request sets in Oracle E-Business Suite | Invoking Request Sets in Oracle E-Business Suite Using BizTalk Server | Invoking Request Sets in Oracle E-Business Suite Using the WCF Service Model |
Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery operations | Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using BizTalk Server | Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using WCF Service Model |
Polling Oracle database Using BizTalk Server | Polling Oracle E-Business Suite Using BizTalk Server | Polling Oracle E-Business Suite Using the WCF Service Model |
Receiving database change notifications from Oracle E-Business Suite | Receiving Database Change Notifications Using BizTalk Server | Receiving Database Change Notifications Using the WCF Service Model | Polling Using SELECT Statement Using the WCF Channel Model

The topics in this section provide information, procedures, and examples to help you develop applications that consume the Oracle E-Business adapter in both BizTalk Server and .NET programming solutions. The topics also provide information on other key aspects of using the adapters such as:

  • Connecting to the Oracle E-Business Suite.

  • Retrieving metadata from the Oracle E-Business Suite.

  • Using binding properties to configure the adapter.

In This Section

  • Establishing a Connection to the Oracle E-Business Suite

  • Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio

  • Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties

  • Receiving Polling-based Data-changed Messages

  • Before Developing Applications Using the Oracle E-Business Suite Adapter

  • Developing BizTalk Applications

  • Developing Applications By Using the WCF Service Model

  • Developing Applications by Using the WCF Channel Model

  • Using the Oracle E-Business Adapter with Microsoft Office SharePoint Server

  • Samples

  • How Do I?

© 2014 Microsoft Corporation. All rights reserved.


Establishing a Connection to the Oracle E-Business Suite

The Microsoft BizTalk Adapter for Oracle E-Business Suite is a Windows Communication Foundation (WCF) custom binding. As such, it enables communication to Oracle E-Business Suite through a WCF endpoint address. In WCF the endpoint address identifies the network location of a service and is typically expressed as a Uniform Resource Identifier (URI). The Oracle E-Business adapter expresses this location as a connection URI, which contains properties that the Oracle E-Business adapter uses to establish a connection to Oracle E-Business Suite. You must specify a connection URI when you:

  • Create a channel factory or a channel listener using the WCF channel model or when you create a WCF client or service host using the WCF service model.

  • Create a physical port binding in a BizTalk Server solution.

  • Use the Add Adapter Service Reference Visual Studio Plug-in to generate a WCF client class or WCF service interface for a WCF service model solution.

  • Use the Consume Adapter Service BizTalk Project Add-in to retrieve message schemas from the Oracle E-Business adapter for a BizTalk Server solution.

  • Use the ServiceModel Metadata Utility tool (svcutil.exe) to generate a WCF client class or WCF service interface for a WCF service model solution.

The Oracle E-Business adapter supports two ways of establishing a connection to the underlying Oracle database:

  • Using tnsnames.ora. In this approach, the connection URI provided by the adapter client contains only the net service name specified in the tnsnames.ora file. The adapter extracts the connection parameters such as server name, service name, port number, etc. from the net service name entry in the file. To use this approach, the computer running the Oracle client must be configured to include the net service name for the Oracle database in the tnsnames.ora file.

    Important
    Due to an Oracle Client limitation, the DataSourceName parameter (net service name) in the connection URI cannot contain more than 39 characters if you are performing operations in a transaction. Therefore, make sure that the value specified for the DataSourceName parameter is less than or equal to 39 characters if you will be performing operations in a transaction.

  • Without using tnsnames.ora. In this approach, the adapter clients specify the connection parameters directly in the connection URI. This does not require the net service name to be present in the tnsnames.ora file on the client computer. This approach does not even require the tnsnames.ora file to be present on the client computer.

    Important
    This mode of connectivity is not supported if you are performing operations in a transaction. This is due to a limitation of Oracle Client.

The topics in this section describe how to establish a connection between the Oracle E-Business adapter and Oracle E-Business Suite by providing you with:

  • Information about configuring the Oracle client (required only if using the tnsnames.ora to establish the connection.)

  • Information about the connection properties and the structure of the Oracle E-Business Suite connection URI.

  • Links to topics that show how to specify a connection URI by using the Oracle E-Business adapter.

  • Information about connecting to Oracle E-Business Suite using Windows Authentication.

In This Section

  • Configuring the Oracle Client

  • The Oracle E-Business Suite Connection URI

  • Connecting to Oracle E-Business Suite Using Windows Authentication

© 2014 Microsoft Corporation. All rights reserved.


Configuring the Oracle Client
Important
This topic is relevant only if you are using tnsnames.ora to connect to the Oracle database.

To establish a connection to the Microsoft BizTalk Adapter for Oracle E-Business Suite, the adapter connects to the underlying Oracle database through the Oracle client installed on your computer. The Oracle E-Business adapter passes the net service name that you specify in the connection URI to the Oracle client to establish a connection to Oracle E-Business Suite. The net service name is an alias that the Oracle client uses to acquire connection information for the target Oracle database service.

The Oracle client resolves the net service name according to the naming method that it is configured to use. You use the Oracle Net Configuration Assistant to configure the naming methods to be used by the Oracle client. The Oracle E-Business adapter supports the Local Naming method for connecting to Oracle E-Business Suite. This method uses a local file, tnsnames.ora, to resolve the net service name.

The tnsnames.ora file associates net service names with connect descriptors that contain the information that the Oracle client needs to establish a connection to a specific Oracle database service (instance). The following is a sample entry from tnsnames.ora.

Copy Code
ADAPTER =
  (DESCRIPTION =
    (ADDRESS_LIST =
      (ADDRESS = (PROTOCOL = TCP)(HOST = yourOracleServer)(PORT = 1521))
    )
    (CONNECT_DATA =
      (SERVICE_NAME = yourOracleDatabaseServiceName)
    )
  )

In this sample entry, ADAPTER is the net service name. The connect descriptor specifies address information and the service name of the Oracle database service associated with ADAPTER. You can use the Oracle Net Configuration Assistant to create and configure net service names in tnsnames.ora. After you have configured the net service name, you can specify it in a connection URI as in the following example.

Copy Code
oracleebs://ADAPTER

For more information about using the Oracle Net Configuration Assistant and about tnsnames.ora, see the Oracle Database Net Services Administrator's Guide. Consult your database administrator about configuration details for your specific installation.

See Also

Other Resources

Establishing a Connection to the Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


The Oracle E-Business Suite Connection URI

The Microsoft BizTalk Adapter for Oracle E-Business Suite connection URI contains properties that the adapter uses to establish a connection to Oracle E-Business Suite, and essentially the underlying Oracle database. The Oracle E-Business adapter supports two ways of connecting to the underlying Oracle database: using tnsnames.ora and without using tnsnames.ora. Based on the kind of connectivity approach, the format of the connection URI is also different. This topic provides information about the Oracle connection URI and also provides links to other topics that explain how to specify a URI in different programming scenarios.

Oracle E-Business Suite is an application layer that interfaces with an underlying Oracle database, and is categorized into different applications such as Financials and HR, based on the different needs within an organization. Each of these applications provides various “forms” that enable users to enter data into the underlying Oracle database. Access to these forms is restricted by associating users with an application context that comprises the organization ID to which a user belongs, the “responsibility” associated with the user, and the name of the Oracle E-Business Suite application that the user wants to invoke. Even though the adapter connects directly to the underlying database and does not use forms to interface with the Oracle E-Business Suite, setting the application context is mandatory when performing operations on the Oracle E-Business Suite artifacts. So, to connect to the Oracle E-Business suite, and the underlying Oracle database, using the Oracle E-Business adapter, you must:

  • Specify a connection URI to connect to Oracle E-Business Suite and the underlying Oracle database. While establishing a connection, you can choose to specify the credentials for Oracle E-Business Suite or the underlying Oracle database.

  • Set the application context for the user. The Oracle E-Business adapter exposes certain binding properties that accept the credentials and the responsibility. For more information about these binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For more information about setting the application context, see Setting Application Context.

This section provides information about how to specify the connection URI to connect to the underlying database using tnsnames.ora and without using tnsnames.ora. It also provides information about using the connection URI to connect to Oracle E-Business Suite.

The Connection URI to Connect to the Underlying Oracle Database Using tnsnames.ora

Important
  • For this approach, you must add the net service name entry in the tnsnames.ora file on the computer with the adapter client installed. For more information about the net service name entry, see Configuring the Oracle Client.

  • Due to an Oracle Client limitation, the DataSourceName parameter (net service name) in the connection URI cannot contain more than 39 characters if you are performing operations in a transaction. Therefore, make sure that the value specified for the DataSourceName parameter is less than or equal to 39 characters if you will be performing operations in a transaction.

The connection URI can contain an Oracle net service name that is used to identify the Oracle E-Business Suite service with which you want to connect. The Oracle client resolves the Oracle net service name that you provide in the connection URI to connection information for an Oracle E-Business Suite service, according to a hierarchy of Oracle naming methods that you configure it to use. One common naming method is called local naming. In local naming, the Oracle client uses a file called tnsnames.ora to resolve the Oracle net service name.

A typical endpoint address URI in WCF is represented as: scheme://userauthparams@hostinfoparams, where:

  • scheme is the scheme name.

  • userauthparams is a name-value collection of parameters required for user authentication by the endpoint.

  • hostinfoparams is information required to establish the connection to the host; for example, a net service name.

The Oracle E-Business adapter connection URI adheres to this basic format and is implemented as follows:

Copy Code
oracleebs://User=[USER_NAME];Password=[PASSWORD]@[NET_SERVICE_NAME]

The following table explains the properties contained in the connection URI.

Connection URI Property Category Description

[USER_NAME]

userauthparams

The user name to use for authentication. The Oracle E-Business adapter exposes a ClientCredentialType binding property that specifies the type of Oracle client credential that the client specifies to establish a connection. The possible values for the ClientCredentialType binding property are Database and EBusiness. Depending on the value for this binding property, you must specify relevant credentials. For more information, see Oracle Credentials and the Connection URI.

Note
You must set the AcceptCredentialsInUri binding property to true to specify the user name and password in the connection URI.

Note
The Oracle E-Business adapter does not preserve the case of the value that you enter for the user name when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the user name to be preserved or if you want to enter a user name containing special characters, you must specify the value within double quotes.

[PASSWORD]

userauthparams

The password to use for authentication. The Oracle E-Business adapter exposes a ClientCredentialType binding property that specifies the type of Oracle client credential that the client specifies to establish a connection. If the ClientCredentialType property is set to Database, the clients must specify the password for an Oracle database user. If the ClientCredentialType property is set to EBusiness, the clients must specify the password for an Oracle E-Business Suite user.

Note
The Oracle E-Business adapter does not preserve the case of the value that you enter for the password when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the password to be preserved or if you want to enter a password containing special characters, you must specify the value within double quotes.

[NET_SERVICE_NAME]

hostinfoparams

A net service name that is specified in the tnsnames.ora file on the computer where the Oracle E-Business adapter is installed. For more information about net service names and tnsnames.ora, see Configuring the Oracle Client.

The Connection URI to Connect to the Underlying Oracle Database Without Using tnsnames.ora

Important
  • For this approach, you need not have the net service name entry in the tnsnames.ora. Also, you do not even need to have the tnsnames.ora file on the computer with the adapter client installed.

  • This mode of connectivity is not supported if you are performing operations in a transaction. This is due to a limitation of Oracle Client.

A typical endpoint address URI in WCF is represented as: scheme://userauthparams@hostinfoparams, where:

  • scheme is the scheme name.

  • userauthparams is a name-value collection of parameters required for user authentication by the endpoint.

  • hostinfoparams is information required to establish the connection to the host; for example, server name, port number, etc.

The Oracle E-Business adapter connection URI adheres to this basic format and is implemented as follows:

Copy Code
oracleebs://User=[USER_NAME];Password=[PASSWORD]@[SERVER_NAME]:[PORT_NUMBER]/[SERVICE_NAME]/[SERVICE_TYPE]

The following table explains the properties contained in the connection URI.

Connection URI Property Category Description

[USER_NAME]

userauthparams

The user name to use for authentication. The Oracle E-Business adapter exposes a ClientCredentialType binding property that specifies the type of Oracle client credential that the client specifies to establish a connection. The possible values for the ClientCredentialType binding property are Database and EBusiness. Depending on the value for this binding property, you must specify relevant credentials. For more information, see Oracle Credentials and the Connection URI.

Note
You must set the AcceptCredentialsInUri binding property to true to specify the user name and password in the connection URI.

Note
The Oracle E-Business adapter does not preserve the case of the value that you enter for the user name when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the user name to be preserved or if you want to enter a user name containing special characters, you must specify the value within double quotes.

[PASSWORD]

userauthparams

The password to use for authentication. The Oracle E-Business adapter exposes a ClientCredentialType binding property that specifies the type of Oracle client credential that the client specifies to establish a connection. If the ClientCredentialType property is set to Database, the clients must specify the password for an Oracle database user. If the ClientCredentialType property is set to EBusiness, the clients must specify the password for an Oracle E-Business Suite user.

Note
The Oracle E-Business adapter does not preserve the case of the value that you enter for the password when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the password to be preserved or if you want to enter a password containing special characters, you must specify the value within double quotes.

[SERVER_NAME]

hostinfoparams

Name of the server on which the Oracle E-Business Suite is running. This is mandatory.

[PORT_NUMBER]

hostinfoparams

The Oracle Net Listener port. The default value 1521.

[SERVICE_NAME]

hostinfoparams

The Oracle database service name. This is mandatory.

[SERVICE_TYPE]

hostinfoparams

The type of Oracle service. The possible values are Dedicated or Shared. A dedicated service uses a dedicated server process to serve only one user process. A shared service uses a shared server process that can serve multiple user processes. Default is Dedicated.

Oracle Credentials and the Connection URI

By default, the Oracle E-Business adapter throws an exception when the Oracle credentials are specified in the connection URI. This is because these credentials are represented as plain text in the connection URI, and this poses a security risk. You can set the AcceptCredentialsInUri binding property to control whether the connection URI can contain credentials for the Oracle database. If the AcceptCredentialsInUri property is false, which is the default, the Oracle E-Business adapter throws an exception if the connection URI contains Oracle credentials; if the property is true, no exception is thrown.

Important
Due to the security risks posed by passing credentials in strings as plain text, you should avoid specifying Oracle database connection credentials in the connection URI. For more information about how to more securely provide credentials for the Oracle database, see Security and Protection.

You may also choose to specify either the database credentials or the Oracle E-Business Suite credentials for establishing a connection to Oracle E-Business Suite. The adapter exposes three binding properties to enable this behavior: ClientCredentialType, OracleUserName, OraclePassword.

The possible values for the ClientCredentialType binding property are Database and EBusiness.

  • If the ClientCredentialType property is set to Database, the clients must specify the database credentials.

  • If the ClientCredentialType property is set to EBusiness, the clients must specify the Oracle E-Business Suite credentials. In this case, the adapter clients must also specify the database credentials for the OracleUserName and OraclePassword binding properties.

Important
In scenarios where the adapter clients specify the database credentials to connect to Oracle E-Business Suite by setting the ClientCredentialType binding property to Database, but invoke an Oracle E-Business Suite artifact, the values specified for OracleUserName and OraclePassword binding properties are used for setting the application context. Setting the application context is mandatory for invoking artifacts in Oracle E-Business Suite. For more information about setting the application context, see Setting Application Context.

Using Reserved Characters in the Connection URI

The Oracle E-Business adapter does not support specifying a connection URI that has special characters for any of the parameter values. If the connection parameter values contain special characters, make sure you do one of the following:

  • If you are specifying the URI in Visual Studio using Add Adapter Service Reference Plug-in or Consume Adapter Service Add-in, you must specify them as-is in the URI Properties tab, that is, without using any escape characters. If you specify the URI directly in the Configure a URI field and the connection parameters contain reserved characters, you must specify the connection parameters using proper escape characters.

  • If you are specifying the URI while creating a send or receive port in BizTalk Server Administration console, and the connection parameters contain reserved characters, you must specify the connection parameters using proper escape characters.

Using the Connection URI to Connect to Oracle E-Business Suite

The following is an example of a connection URI for Oracle E-Business adapter using tnsnames.ora.

Copy Code
oracleebs://ADAPTER

In this example, ADAPTER is a net service name that is associated with the SERVICE NAME and connection information for the target Oracle database in tnsnames.ora.

The following is an example of a connection URI for Oracle E-Business adapter without using tnsnames.ora.

Copy Code
oracleebs://yourOracleServer:1521/yourOracleDatabaseServiceName/Dedicated

In this example, the server name is “yourOracleServer” and the service name is “yourOracleDatabaseServiceName”.

For information about how to establish a connection to Oracle E-Business Suite when you:

  • Use the Consume Adapter Service BizTalk Project Add-in or the Add Adapter Service Reference Visual Studio Plug-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

  • Configure a send port or receive port (location) in a BizTalk Server solution, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter.

See Also

Concepts

Configuring the Oracle Client

Other Resources

Establishing a Connection to the Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Connecting to Oracle E-Business Suite Using Windows Authentication

The Oracle E-Business adapter enables adapter clients to use Windows Authentication to establish a connection with the Oracle E-Business Suite. To use Windows Authentication adapter clients must specify a “/” for user name and leave the password blank. For more information about connecting to the Oracle E-Business Suite using Windows Authentication, see Connecting to the Oracle E-Business Suite in Visual Studio.

To use Windows Authentication, you must do the following:

  • If the ClientCredentialType property is set to Database, specify “/” for the user name and leave the password blank to connect to the Oracle E-Business Suite.

  • If the ClientCredentialType property is set to EBusiness, specify the Oracle E-Business Suite credentials to connect. Also, you must specify “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

To enable adapter clients to use Windows Authentication to connect to an Oracle database, you must perform the following tasks on the computer running the Oracle database.

  1. Make sure that the sqlnet.ora file on both the client and the server, available under ORACLE_BASE\ORACLE_HOME\network\admin\sqlnet.ora, has the following entry:

    Copy Code
    SQLNET.AUTHENTICATION_SERVICES= (NTS)
  2. Connect to the Oracle database as SYSDBA.

  3. Create the Windows user as an external user in Oracle database. Note that the user name must be in upper case.

    Copy Code
    CREATE USER “OPS$<DOMAIN_NAME>\<USER_NAME>” IDENTIFIED EXTERNALLY;
  4. Grant privileges to the user.

    Copy Code
    GRANT CONNECT,RESOURCE TO “OPS$<DOMAIN_NAME>\<USER_NAME>”;
  5. The Oracle E-Business Suite artifacts are available under the APPS schema. To enable the newly created user, logging in using Windows Authentication, to access the Oracle E-Business Suite artifacts, the user’s schema must be changed to the APPS schema. You can add the following SQL command to the logon script that changes the user’s default schema to APPS when the user logs on.

    Copy Code
    alter session set current_schema=APPS;
  6. Even though you changed the schema of the user to APPS schema, you will still not be able to see Oracle E-Business Suite artifacts while browsing and generating metadata using the Oracle E-Business adapter. This is because the newly created user does not have permissions for the APPS schema. Make sure you provided permission for the APPS schema for the newly created user.

See Also

Concepts

Configuring the Oracle Client

Other Resources

Establishing a Connection to the Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio

The Microsoft BizTalk Adapter for Oracle E-Business Suite provides three Visual Studio components that you can use to help you develop solutions using the adapter:

  • Consume Adapter Service BizTalk Project Add-in

  • Add Adapter Metadata Wizard

  • Add Adapter Service Reference Visual Studio Plug-in

Adapter clients must use these components to connect to Oracle E-Business Suite, and then generate metadata for the operations they want to perform. All these Visual Studio components simplify development by:

  • Providing a Microsoft Windows interface through which you can browse and search for operations that you want to use in your solution.

  • Retrieving metadata exposed by the adapter for these target operations.

  • Converting that metadata, which is expressed as a Web Services Description Language (WSDL) document by the adapter, into a form that you can use in your solution (XSD message schemas for BizTalk projects or a .NET object representation of a service contract for the WCF service model) and adding it to your project.

This section provides instructions about how to use the Consume Adapter Service Add-in, the Add Adapter Metadata Wizard, and the Add Adapter Service Reference Plug-in.

Note
If you have created a solution using the adapter on a particular version of Oracle E-Business Suite, and now want to deploy the solution on a different version of Oracle E-Business Suite then you should test the solution before deploying it. You might face issues while deploying the solution on a different version of Oracle E-Business Suite because the metadata of the underlying artifact might be different. To resolve this issue, you should regenerate the metadata using the adapter on the same version of Oracle E-Business Suite on which you intend to deploy the solution.

In This Section

  • Connecting to the Oracle E-Business Suite in Visual Studio

  • Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations

© 2014 Microsoft Corporation. All rights reserved.


Connecting to the Oracle E-Business Suite in Visual Studio

This section provides information about how to use the Consume Adapter Service Add-in, the Add Adapter Metadata Wizard, and the Add Adapter Service Reference Plug-in.

  • The Consume Adapter Service BizTalk Project Add-in is available in BizTalk Server projects. You use the Consume Adapter Service Add-in to generate message schemas (XSDs) for operations that you want to target in your BizTalk solution. For more information about developing solutions with BizTalk Server, see Developing BizTalk Applications.

  • The Add Adapter Metadata Wizard is available in BizTalk Server projects. You use the Add Adapter Metadata Wizard to generate message schemas (XSDs) for operations that you want to target in your BizTalk solution. For more information about developing solutions with BizTalk Server, see Developing BizTalk Applications.

    Note
    Because the Oracle E-Business adapter is exposed both as a WCF-Custom binding and as BizTalk adapter, you can use either the Consume Adapter Service Add-in or the Add Adapter Metadata Wizard from a BizTalk project to connect to Oracle E-Business Suite.

  • The Add Adapter Service Reference Visual Studio Plug-in is available in non-BizTalk programming projects. You use the Add Adapter Service Reference Plug-in to generate a WCF client class or a WCF service callback interface when you develop solutions using the WCF service model. For more information about developing solutions with the WCF service model, see Developing Applications By Using the WCF Service Model.

To use the Consume Adapter Service Add-in, the Add Adapter Metadata Wizard, or the Add Adapter Service Reference Plug-in, you must first connect to the Oracle E-Business Suite. All three methods present a dialog box through which you configure a connection by setting the following:

  • Connection parameters. These are the parameters that are used to build the connection URI. You must specify a data source (Oracle net service name).

  • User name password credentials for the Oracle E-Business Suite. These are used to authenticate you on the Oracle E-Business Suite when the connection is established. You must specify a user name and password.

    Important
    At this stage, you can specify the credentials for the Oracle E-Business Suite or the underlying Oracle database. To connect and generate metadata you can specify any credentials. However, while performing operation to invoke an Oracle E-Business Suite artifact, you must specify the Oracle E-Business Suite credentials because they are required to set the application context for the Oracle E-Business Suite application you want to invoke. For more information about setting applications context, see Setting Application Context.

  • Binding properties. Binding properties are optional at design-time, that is, while generating metadata for operations. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

At a minimum, when you configure the connection to the Oracle database, you only have to specify binding properties and connection parameters that are needed to establish the connection and that affect the metadata returned by the Oracle Database adapter for the operations you want to target. However, you might also want to specify values for any additional binding properties and connection parameters that will be used at run time. This is because:

  • The Consume Adapter Service Add-in creates a BizTalk port binding file from the binding properties and connection parameters that you specify when you configure the connection, and adds this file to your project. Later, you can use this binding file to create a port in the BizTalk Server Administration console. For more information about the binding file, see Configuring a Physical Port Binding Using a Port Binding File.

  • The Add Adapter Service Reference Plug-in creates an app.config file from the binding properties and connection properties that you specify when you configure the connection, and adds this file in your project directory.

In This Section

  • Connecting to Oracle E-Business Suite in Visual Studio Using Consume Adapter Service Add-in

  • Connecting to Oracle E-Business Suite in Visual Studio Using Add Adapter Metadata Wizard

  • Connecting to Oracle E-Business Suite in Visual Studio Using Add Adapter Service Reference Plug-in

See Also

Other Resources

Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio

© 2014 Microsoft Corporation. All rights reserved.


Connecting to Oracle E-Business Suite in Visual Studio Using Consume Adapter Service Add-in

The Consume Adapter Service Add-in is installed when you install WCF LOB Adapter SDK. The Consume Adapter Service Add-in loads all the WCF-Custom bindings installed on the computer. To connect to Oracle E-Business Suite using the WCF-based Oracle E-Business adapter in a BizTalk project, you must use the oracleEBSBinding.

This topic provides instructions on how to use the Consume Adapter Service Add-in.

Connecting to Oracle E-Business Suite Using the Consume Adapter Service Add-in

Perform the following steps to connect to Oracle E-Business Suite using the Consume Adapter Service Add-in.

To connect to Oracle E-Business Suite

  1. To connect using the Consume Adapter Service Add-in in a BizTalk solution:

    1. Create a BizTalk project using Visual Studio.

    2. Right-click the project in Solution Explorer, point to Add, and then click Add Generated Items.

    3. In the Add Generated Items dialog box, do the following:

      Use this To do this

      Categories

      Click Consume Adapter Service.

      Templates

      Click Consume Adapter Service.

    4. Click Add. The Consume Adapter Service Add-in opens.

  2. From the Select a binding drop-down list, select oracleEBSBinding and click Configure.

  3. In the Configure Adapter dialog box, click the Security tab, and from the Client credential type drop-down list box, select Username and specify the user name and password to connect to the Oracle E-Business Suite.

    Use this To do this

    To connect using Oracle database credentials

    Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

    To connect using Oracle E-Business Suite credentials

    Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

    To connect using Windows Authentication if ClientCredentialType is set to “Database”

    Specify a “/” for the User name text box and leave the Password text box blank.

    To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

    Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

  4. Click the URI Properties tab, and specify values for the connection parameters. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

    Note
    If the connection parameters contain any reserved characters, you must specify them as-is in the URI Properties tab, that is, without using any escape characters. However, if you specify the URI directly in the Configure a URI field and the connection parameters contain reserved characters, you must specify the connection parameters using proper escape characters.

  5. Click the Binding Properties tab, and then specify values for the binding properties, if any, required by the operations you want to target. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

  6. Click OK.

  7. Click Connect. After the connection is established, the connection status is shown as Connected.

    The following figure shows the Consume Adapter Service Add-in immediately after the connection is established.

    Consume Adapter Service dialog box

    The Consume Adapter Service Add-in displays different nodes containing various operations that can be performed on the Oracle E-Business Suite and the Oracle database. For more information on how the metadata is categorized under the various nodes, see How Does the Adapter Surface Oracle E-Business Suite Metadata?.

See Also

Concepts

Connecting to Oracle E-Business Suite Using Windows Authentication

Other Resources

Connecting to the Oracle E-Business Suite in Visual Studio

© 2014 Microsoft Corporation. All rights reserved.


Connecting to Oracle E-Business Suite in Visual Studio Using Add Adapter Metadata Wizard

The Oracle E-Business adapter is also exposed as a BizTalk adapter and, therefore, you can use the Add Adapter Metadata Wizard to generate schema for the operations you want to perform on Oracle E-Business Suite using the adapter.

Connecting to Oracle E-Business Suite Using the Add Adapter Metadata Wizard

Perform the following steps to connect to Oracle E-Business Suite using the Add Adapter Metadata Wizard.

To connect to Oracle E-Business Suite

  1. To connect using the Add Adapter Metadata Wizard in a BizTalk solution:

    1. Create a BizTalk project using Visual Studio.

    2. Right-click the project in Solution Explorer, point to Add, and then click Add Generated Items.

    3. In the Add Generated Items dialog box, do the following:

      Use this To do this

      Categories

      Click Add Adapter.

      Templates

      Click Add Adapter Metadata.

    4. Click Add. The Add Adapter Metadata Wizard opens.

    5. In the Add Adapter Metadata Wizard, select WCF-OracleEBS. Select the computer on which BizTalk Server is installed and the name of the BizTalk database.

      Important
      If you already have a WCF-OracleEBS port configured in BizTalk, select the port from the Port list.

    6. Click Next.

  2. From the Select a binding drop-down list, select oracleEBSBinding and click Configure.

  3. In the Configure Adapter dialog box, click the Security tab, and from the Client credential type drop-down list box, select Username and specify the user name and password to connect to the Oracle E-Business Suite.

    Use this

    To do this

    To connect using Oracle database credentials

    Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

    To connect using Oracle E-Business Suite credentials

    Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

    To connect using Windows Authentication if ClientCredentialType is set to “Database”

    Specify a “/” for the User name text box and leave the Password text box blank.

    To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

    Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

  4. Click the URI Properties tab, and specify values for the connection parameters. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

    Note
    If the connection parameters contain any reserved characters, you must specify them as-is in the URI Properties tab, that is, without using any escape characters. However, if you specify the URI directly in the Configure a URI field and the connection parameters contain reserved characters, you must specify the connection parameters using proper escape characters.

  5. Click the Binding Properties tab, and then specify values for the binding properties, if any, required by the operations you want to target. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

    Note
    If you are generating metadata using Add Adapter Metadata Wizard and you selected an existing WCF-OracleEBS send port, you need not specify the binding properties. The binding properties are picked from the send port configuration. However, you may choose to specify the binding properties that are required at design-time, if any. In such case, the new values for binding properties will be used at design-time while generating the metadata. However, at run-time the values specified for binding properties in the send port configuration will be applicable.

  6. Click OK.

  7. Click Connect. After the connection is established, the connection status is shown as Connected.

    The following figure shows the Consume Adapter Service Add-in immediately after the connection is established.

    Consume Adapter Service dialog box

    The Consume Adapter Service Add-in displays different nodes containing various operations that can be performed on the Oracle E-Business Suite and the Oracle database. For more information on how the metadata is categorized under the various nodes, see How Does the Adapter Surface Oracle E-Business Suite Metadata?.

See Also

Concepts

Connecting to Oracle E-Business Suite Using Windows Authentication

Other Resources

Connecting to the Oracle E-Business Suite in Visual Studio

© 2014 Microsoft Corporation. All rights reserved.


Connecting to Oracle E-Business Suite in Visual Studio Using Add Adapter Service Reference Plug-in

To connect to Oracle E-Business Suite using the Oracle E-Business adapter in a .NET programming solution, you must use the Add Adapter Service Reference Visual Studio Plug-in. This topic provides instructions on how to use the Add Adapter Service Reference Plug-in.

Connecting to Oracle E-Business Suite Using the Add Adapter Service Reference Plug-in

Perform the following steps to connect to Oracle E-Business Suite using the Add Adapter Service Reference Plug-in.

To connect to Oracle E-Business Suite

  1. To connect using the Add Adapter Service Reference Plug-in in a programming solution:

    1. Create a project using Visual Studio.

    2. Right-click the project in Solution Explorer, and then click Add Adapter Service Reference. The Add Adapter Service Reference Plug-in opens.

  2. From the Select a binding drop-down list, select oracleEBSBinding and click Configure.

  3. In the Configure Adapter dialog box, click the Security tab, and from the Client credential type drop-down list box, select Username and specify the user name and password to connect to the Oracle E-Business Suite.

    Use this

    To do this

    To connect using Oracle database credentials

    Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

    To connect using Oracle E-Business Suite credentials

    Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

    To connect using Windows Authentication if ClientCredentialType is set to “Database”

    Specify a “/” for the User name text box and leave the Password text box blank.

    To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

    Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

  4. Click the URI Properties tab, and specify values for the connection parameters. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

    Note
    If the connection parameters contain any reserved characters, you must specify them as-is in the URI Properties tab, that is, without using any escape characters. However, if you specify the URI directly in the Configure a URI field and the connection parameters contain reserved characters, you must specify the connection parameters using proper escape characters.

  5. Click the Binding Properties tab, and then specify values for the binding properties, if any, required by the operations you want to target. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

  6. Click OK.

  7. Click Connect. After the connection is established, the connection status is shown as Connected.

    The following figure shows the Consume Adapter Service Add-in immediately after the connection is established. The graphical user interface is the same for the Add Adapter Service Reference Plug-in.

    Consume Adapter Service dialog box

    The Add Adapter Service Reference Plug-in displays different nodes containing various operations that can be performed on the Oracle E-Business Suite and the Oracle database. For more information on how the metadata is categorized under the various nodes, see How Does the Adapter Surface Oracle E-Business Suite Metadata?.

See Also

Concepts

Connecting to Oracle E-Business Suite Using Windows Authentication

Other Resources

Connecting to the Oracle E-Business Suite in Visual Studio

© 2014 Microsoft Corporation. All rights reserved.


Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations

This section provides information about how to use the Consume Adapter Service BizTalk Project Add-in and the Add Adapter Service Reference Visual Studio Plug-in. By using these Visual Studio components, you can:

  • Browse for operations to retrieve metadata.

  • Search for operations to retrieve metadata.

  • Add message schemas for selected operations and port binding configuration files to a BizTalk Server project when using the Consume Adapter Service Add-in.

  • Add a WCF client class or a WCF service contract (interface) for selected operations and a configuration file (app.config) to a non-BizTalk programming project when using the Add Adapter Service Reference Plug-in.

How is the Metadata Categorized?

The Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in gives three different views of the artifacts available in the Oracle E-Business Suite server you connect to—Application-based view, Artifact-based view, and the Schema-based view. Why do you need three different views for the same set of artifacts? The following table lists the reasons why you should you use a specific view.

View When do you use it

Application-based view

This view is categorized by the Oracle E-Business Suite application names. Use this view when you know which application contains the artifacts you want to work with.

Artifact-based view

This view is categorized by the Oracle E-Business Suite artifacts. Use this view when you know which Oracle E-Business Suite artifact you want to work with but you are not sure which application the artifact belongs to. Using this view, you can search for a specific artifact across all Oracle E-Business Suite applications.

The artifact-based view also lists the artifacts in the underlying Oracle database such as PL-SQL APIs, tables, views, functions, and procedures. These artifacts are further categorized based on the schema they belong to. So, another use of the artifact-based view is to use artifacts that belong to your schema as well as the artifacts that belong to other schemas. This view also enables you to search for artifacts across all schemas.

Schema-based view

This view is categorized by the schemas available in the underlying Oracle database. Use this view when you know which schema has the artifacts you want to work with. Within this view, the artifacts as categorized as PL-SQL APIs, procedures, functions, tables, and views.

For more information on how the Oracle E-Business Suite artifacts are categorized, see How Does the Adapter Surface Oracle E-Business Suite Metadata? Another key reason for organizing the artifacts in different views is the ease to search for specific artifacts. For more information on how you can search for artifacts, see Searching for Operations.

Important
The nodes show up based on the connection URI you specify while establishing a connection. If you specify credentials that do not have permissions on the Oracle E-Business Suite artifacts, you cannot use the artifacts in the Application-based view. Also, the Artifact-based view does not list the artifacts belonging to Oracle E-Business Suite.

In This Section

  • Browsing for Operations Under the Application-Based View

  • Browsing for Operations Under the Artifact-Based View

  • Browsing for Operations Under the Schema-Based View

  • Searching for Operations

  • Retrieving Metadata for Operations

See Also

Other Resources

Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio

© 2014 Microsoft Corporation. All rights reserved.


Browsing for Operations Under the Application-Based View

You can use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in to browse for outbound and inbound operations that can be performed on Oracle E-Business Suite using the Oracle E-Business adapter. This topic provides information on how to browse for outbound and inbound operations under the application-based view.

Note
The Consume Adapter Service Add-in and the Add Adapter Service Reference Plug-in present essentially the same interface when you browse and search for operations, so both components are covered in the same topics.

Prerequisites

You must connect to the Oracle E-Business Suite before you can browse metadata for target operations. For information about how to connect to the Oracle database when you use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

Browsing for Outbound Operations

Perform the following steps to browse the outbound operations under the application-based view.

To browse metadata for outbound operations under the Application-Based view

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

  2. From the Select contract type list, select Client (Outbound operations).

  3. The Select a category box lists the different views under which the Oracle E-Business Suite artifacts are categorized.

    The following figure shows the Consume Adapter Service Add-in. The root node (/) is selected, and the general category nodes available under the root node are listed in the Available categories and operations box.

    Operations and categories at the root level

    Note
    The standard operations such as ExecuteReader, ExecuteScalar, and ExecuteNonQuery are available at the root level. For more information about these operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations. For instructions on how to execute these operations using the Oracle E-Business adapter, see Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using BizTalk Server.

  4. Expand the Application-Based View node to see all the Oracle E-Business suite applications available on the server you connected to. Expand an application to see categories for interface tables, interface views, concurrent programs, and request sets available for that application.

    Tip
    You can directly go to the “immediate” category node or subcategory nodes in the tree, by typing the name of the artifact in while the focus is on the tree view in the Select a category box. For example, to jump to the Alert node, keep the focus on the Application-Based View node, and then type Alert.

  5. Expand the Interface Tables node to see the interface tables for the Oracle application. Click an interface table to see the list of operations available for the table in the Available categories and operations box.

    Browse interface tables in Oracle E-Business Suite

    Note
    If an interface table contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The name of such operations are Read_<LOBColName>. For example, if the interface table has a column, FILE_DATA, of type BLOB, the adapter exposes a Read_FILE_DATA operation. If an interface table has more than one column of type BLOB, CLOB, NCLOB, and BFILE the adapter will expose as many number of Read_<LOBColName> operations.

    Similarly, if an interface table contains columns of type BLOB, CLOB, or NCLOB the adapter also exposes a specific operation to update data into such columns. The name of such operations are Update_<LOBColName>. For example, if the interface table has a column, FILE_DATA, of type BLOB, the adapter exposes an Update_FILE_DATA operation. If an interface table has more than one column of type BLOB, CLOB, and NCLOB the adapter will expose as many number of Update_<LOBColName> operations. Note that the update operation is not supported on columns of type BFILE.

  6. Expand the Interface Views node to see the interface views for the Oracle application. Click an interface view to see the list of operations available for the view in the Available categories and operations box.

    Browse interface views in Oracle E-Business Suite

    Note
    If an interface view contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The name of such operations are Read_<LOBColName>. For example, if the interface view has a column, FILE_CONTENT, of type BLOB, the adapter exposes a Read_FILE_CONTENT operation. If an interface view has more than one column of type BLOB, CLOB, NCLOB, or BFILE the adapter will expose as many number of Read_<LOBColName> operations. Note that Update_<LOBColName> operations are not supported on views.

  7. Click the Concurrent Programs node to see the concurrent programs for an application in the Available categories and operations box.

    Browse concurrent programs for Oracle application

    This figure shows the concurrent programs specific to an Oracle application and the standard concurrent programs for all Oracle applications.

    Important
    The Consume Adapter Service Add-in (or the Add Adapter Service Reference Plug-in) displays friendly names of concurrent programs. However, the metadata for the concurrent program has the actual name of the concurrent program. For example, the Receivables application contains a “Customer Interface” concurrent program. However, the metadata has the concurrent program name as RACUST, which is the actual name of the concurrent program.

  8. Click the Request Sets node to see the request sets for an application in the Available categories and operations box.

    Browse request sets for an Oracle application

    Important
    The Consume Adapter Service Add-in (or the Add Adapter Service Reference Plug-in) displays friendly names of request sets. However, the metadata for the request set has the actual name of the request set. For example, the Applications DBA application contains a “DownloadPatches” request set. However, the metadata has the request set name as FNDRSSUB1623, which is the actual name of the request set.

Browsing for Inbound Operations

Perform the following steps to browse the inbound operations under the application-based view.

To browse metadata for inbound operations under the Application-based view

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

  2. From the Select contract type list, for inbound operations select Service (Inbound operations).

  3. The Select a category box lists the different views under which the Oracle E-Business Suite artifacts are categorized.

    The following figure shows the Consume Adapter Service Add-in. The root node (/) is selected, and the general category nodes available under the root node are listed in the Available categories and operations box.

    Inbound operation at the root level

    The inbound operation, Notification, is also available at the root level.

  4. Expand the Application-Based View node to see all the Oracle E-Business suite applications available on the server you connected to. Expand an application to see categories for interface tables and interface views.

    Tip
    You can directly go to the “immediate” category node or subcategory nodes in the tree, by typing the name of the artifact in while the focus is on the tree view in the Select a category box. For example, to jump to the Alert node, keep the focus on the Application-Based View node, and then type Alert.

  5. Expand an Oracle application to see categories for interface tables and interface views available for that application. Expand the Interface Tables and Interface Views nodes to see the interface tables and interface views for the Oracle application. Click an interface table or interface view to see the inbound operation available for the table or view in the Available categories and operations box.

    In the following figure, an interface view is selected in the Select a category box and the inbound operation supported on the view is listed in the Available categories and operations box.

    Inbound operations on interface views

    Note
    The Oracle E-Business adapter does not surface concurrent programs and request sets for inbound operations.

See Also

Other Resources

Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations

© 2014 Microsoft Corporation. All rights reserved.


Browsing for Operations Under the Artifact-Based View

You can use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in to browse for outbound and inbound operations that can be performed on Oracle E-Business Suite using the Oracle E-Business adapter. This topic provides information on how to browse for outbound and inbound operations under the artifact-based view.

Note
The Consume Adapter Service Add-in and the Add Adapter Service Reference Plug-in present essentially the same interface when you browse and search for operations, so both components are covered in the same topics.

Prerequisites

You must connect to the Oracle E-Business Suite before you can browse metadata for target operations. For information about how to connect to the Oracle database when you use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

Browsing for Outbound Operations

Perform the following steps to browse the outbound operations under the artifact-based view.

To browse metadata for outbound operations under the Artifact-Based view

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

  2. From the Select contract type list, for outbound operations select Client (Outbound operations).

  3. The Select a category box lists the different views under which the Oracle E-Business Suite artifacts are categorized.

    The following figure shows the Consume Adapter Service Add-in. The root node (/) is selected, and the general category nodes available under the root node are listed in the Available categories and operations box.

    Operations and categories at the root level

    Note
    The standard operations such as ExecuteReader, ExecuteScalar, and ExecuteNonQuery are available at the root level. For more information about these operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations. For instructions on how to execute these operations using the Oracle E-Business adapter, see Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using BizTalk Server.

  4. Expand the Artifact-Based View node to see category for artifacts, both for the Oracle E-Business Suite and the underlying database. Each category is further categorized based on the application it belongs to (for Oracle-E-Business Suite artifacts such as interface table, interface views, concurrent programs, and request sets) or the schema it belongs to (for Oracle database artifacts such as PL-SQL APIs, procedures, functions, tables, and views).

    Tip
    You can directly go to the “immediate” category node or subcategory nodes in the tree, by typing the name of the artifact while the focus is on the tree view in the Select a category box. For example, to jump to the Procedures node, keep the focus on the Artifact-Based View node, and then type Procedures.

  5. Expand the Interface Tables node to see all the Oracle E-Business Suite applications. Expand an Oracle E-Business suite application to list all the interface tables belonging to that application. Click an interface table name to see operations available for the table in the Available categories and operations box.

    Note
    If an interface table contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The name of such operations are Read_<LOBColName>. For example, if the interface table has a column, FILE_DATA, of type BLOB, the adapter exposes a Read_FILE_DATA operation. If an interface table has more than one column of type BLOB, CLOB, NCLOB, and BFILE the adapter will expose as many number of Read_<LOBColName> operations.

    Similarly, if an interface table contains columns of type BLOB, CLOB, or NCLOB the adapter also exposes a specific operation to update data into such columns. The name of such operations are Update_<LOBColName>. For example, if the interface table has a column, FILE_DATA, of type BLOB, the adapter exposes an Update_FILE_DATA operation. If an interface table has more than one column of type BLOB, CLOB, and NCLOB the adapter will expose as many number of Update_<LOBColName> operations. Note that the update operation is not supported on columns of type BFILE.

  6. Expand the Interface Views node to see all the Oracle E-Business Suite applications. Expand an Oracle E-Business suite application to list all the interface views belonging to that application. Click an interface view name to see operations available for the view in the Available categories and operations box.

    Note
    If an interface view contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The names of such operations are Read_<LOBColName>. For example, if the interface view has a column, FILE_CONTENT, of type BLOB, the adapter exposes a Read_FILE_CONTENT operation. If an interface view has more than one column of type BLOB, CLOB, NCLOB, or BFILE the adapter will expose as many number of Read_<LOBColName> operations. Note that Update_<LOBColName> operations are not supported on views.

  7. Expand the Concurrent Programs node to see all the Oracle E-Business Suite applications. Click an Oracle E-Business suite application to list all the concurrent programs belonging to that application in the Available categories and operations box.

    Important
    The Consume Adapter Service Add-in (or the Add Adapter Service Reference Plug-in) displays friendly names of concurrent programs. However, the metadata for the concurrent program has the actual name of the concurrent program. For example, the Receivables application contains a “Customer Interface” concurrent program. However, the metadata has the concurrent program name as RACUST, which is the actual name of the concurrent program.

  8. Expand the Request Sets node to see all the Oracle E-Business Suite applications. Click an Oracle E-Business suite application to list all the request sets belonging to that application in the Available categories and operations box.

    Important
    The Consume Adapter Service Add-in (or the Add Adapter Service Reference Plug-in) displays friendly names of request sets. However, the metadata for the request set has the actual name of the request set. For example, the Applications DBA application contains a “DownloadPatches” request set. However, the metadata has the request set name as FNDRSSUB1623, which is the actual name of the request set.

  9. Expand the PL-SQL APIs node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Expand the Current Schema (<schema name>) node to see all packages defined for that schema. Click a package name to see the functions and procedures within the package in the Available categories and operations box.

    Browse packages in the Oracle database

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Expand a schema node to see a list of packages defined for that schema. Click a package name to see the functions and procedures within the package in the Available categories and operations box.

    Browse packages in Oracle database for all schemas

  10. Expand the Procedures node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Click the Current Schema (<schema name>) node to see all the procedures defined for that schema in the Available categories and operations box.

    Browse procedures in Oracle database for a schema

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Click a schema node to see a list of procedures defined for that schema in the Available categories and operations box.

    Browse procedures in Oracle database for schemas

  11. Expand the Functions node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Click the Current Schema (<schema name>) node to see all the functions defined for that schema in the Available categories and operations box.

    Browse functions in Oracle database for a schema

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Click a schema node to see a list of functions defined for that schema in the Available categories and operations box.

    Browse functions in Oracle database for all schema

  12. Expand the Tables node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Expand the Current Schema (<schema name>) node to see all the tables defined for that schema. Click a table name to see the operations supported on that table in the Available categories and operations box.

    Browse tables in Oracle database for a schema

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Expand a schema node to see a list of tables defined for that schema. Click a table name to see the operations supported on that table in the Available categories and operations box.

    Browse Oracle database tables for all schemas

    Note
    If a table contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The name of such operations are Read_<LOBColName>. For example, if the table has a column, PHOTO, of type BLOB, the adapter exposes a Read_PHOTO operation. If a table has more than one column of type BLOB, CLOB, NCLOB, and BFILE the adapter will expose as many number of Read_<LOBColName> operations.

    Similarly, if a table contains columns of type BLOB, CLOB, or NCLOB the adapter also exposes a specific operation to update data into such columns. The name of such operations are Update_<LOBColName>. For example, if the table has a column, PHOTO, of type BLOB, the adapter exposes an Update_PHOTO operation. If a table has more than one column of type BLOB, CLOB, and NCLOB the adapter will expose as many number of Update_<LOBColName> operations. Note that the update operation is not supported on columns of type BFILE.

  13. Expand the Views node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Expand the Current Schema (<schema name>) node to see all the views defined for that. Click a view name to see the operations supported on that view in the Available categories and operations box.

    Browse views in Oracle database for current schema

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Expand a schema node to see a list of views defined for that schema. Click a view name to see the operations supported on that view in the Available categories and operations box.

    Browse views in Oracle database for all schemas

    Note
    If a view contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The name of such operations are Read_<LOBColName>. For example, if the view has a column, RULE, of type BLOB, the adapter exposes a Read_RULE operation. If a view has more than one column of type BLOB, CLOB, NCLOB, or BFILE the adapter will expose as many number of Read_<LOBColName> operations. Note that Update_<LOBColName> operations are not supported on views.

Browsing for Inbound Operations

Perform the following steps to browse the inbound operations under the artifact-based view.

To browse metadata for inbound operations under the Artifact-based view

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

  2. From the Select contract type list, for inbound operations select Service (Inbound operations).

  3. The Select a category box lists the different views under which the Oracle E-Business Suite artifacts are categorized.

    The following figure shows the Consume Adapter Service Add-in. The root node (/) is selected, and the general category nodes available under the root node are listed in the Available categories and operations box.

    Inbound operation at the root level

    The inbound operation, Notification, is also available at the root level.

  4. Expand the Artifact-Based View node to see category for artifacts, both for the Oracle E-Business Suite and the underlying database. Each category is further categorized based on the application it belongs to (for Oracle-E-Business Suite artifacts such as interface table and interface views) or the schema it belongs to (for Oracle database artifacts such as PL-SQL APIs, procedures, functions, tables, and views).

    Tip
    You can directly go to the “immediate” category node or subcategory nodes in the tree, by typing the name of the artifact while the focus is on the tree view in the Select a category box. For example, to jump to the Procedures node, keep the focus on the Artifact-Based View node, and then type Procedures.

    Note
    The Oracle E-Business adapter does not surface concurrent programs and request sets for inbound operations.

  5. Expand an Oracle application to see categories for interface tables and interface views available for that application. Expand the Interface Tables and Interface Views nodes to see the interface tables and interface views for the Oracle application. Click an interface table or interface view to see the inbound operation available for the table or view in the Available categories and operations box.

    In the following figure, an interface view is selected in the Select a category box and the inbound operation supported on the view is listed in the Available categories and operations box.

    Inbound operations on interface views

  6. Expand the PL-SQL APIs node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Expand the Current Schema (<schema name>) node to see all packages defined for that schema. Click a package name to see the functions and procedures within the package in the Available categories and operations box. Each of the listed functions and procedures can be used to poll the Oracle database.

    Browse PL-SQL APIs in Oracle database for polling

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Expand a schema node to see a list of packages defined for that schema. Click a package name to see the functions and procedures within the package in the Available categories and operations box. Each of the listed functions and procedures can be used to poll the Oracle database.

    Browse PL-SQL APIs for all schemas for polling

  7. Expand the Procedures node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Click the Current Schema (<schema name>) node to see all the procedures defined for that schema in the Available categories and operations box. Each of the listed procedures can be used to poll the Oracle database.

    Browse procedures for all schemas for polling

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Click a schema node to see a list of procedures defined for that schema in the Available categories and operations box. Each of the listed procedures can be used to poll the Oracle database.

    Browse procedures in Oracle database for polling

  8. Expand the Functions node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Click the Current Schema (<schema name>) node to see all the functions defined for that schema in the Available categories and operations box. Each of the listed functions can be used to poll the Oracle database.

    Browse functions in Oracle database for polling

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Click a schema node to see a list of functions defined for that schema in the Available categories and operations box. Each of the listed functions can be used to poll the Oracle database.

    Browse functions in Oracle database for polling

  9. Expand the Tables node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Expand the Current Schema (<schema name>) node to see all the tables defined for that schema. Click a table name to see the Poll inbound operation supported on that table in the Available categories and operations box.

    Browse tables in Oracle database for polling

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Expand a schema node to see a list of tables defined for that schema. Click a table name to see the Poll inbound operation supported on that table in the Available categories and operations box.

    Browse tables in Oracle database for polling

  10. Expand the Views node to see category nodes for the current user schema (with which you login) and all other schemas defined in the underlying Oracle database. Expand the Current Schema (<schema name>) node to see all the views defined for that. Click a view name to see the Poll inbound operation supported on that view in the Available categories and operations box.

    Browse views in Oracle database for polling

    Similarly, expand the All Schemas node to see a list of all the schemas defined in the Oracle database. Expand a schema node to see a list of views defined for that schema. Click a view name to see the Poll inbound operation supported on that view in the Available categories and operations box.

    Browse views in Oracle database for polling

See Also

Other Resources

Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations

© 2014 Microsoft Corporation. All rights reserved.


Browsing for Operations Under the Schema-Based View

You can use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in to browse for outbound and inbound operations that can be performed on Oracle E-Business Suite using the Oracle E-Business adapter. This topic provides information on how to browse for outbound and inbound operations under the schema-based view.

Note
The Consume Adapter Service Add-in and the Add Adapter Service Reference Plug-in present essentially the same interface when you browse and search for operations, so both components are covered in the same topics.

Prerequisites

You must connect to the Oracle E-Business Suite before you can browse metadata for target operations. For information about how to connect to the Oracle database when you use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

Browsing for Outbound Operations

Perform the following steps to browse the outbound operations under the schema-based view.

To browse metadata for outbound operations under the Schema-Based view

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

  2. From the Select contract type list, for outbound operations select Client (Outbound operations).

  3. The Select a category box lists the different views under which the Oracle E-Business Suite artifacts are categorized.

    The following figure shows the Consume Adapter Service Add-in. The root node (/) is selected, and the general category nodes available under the root node are listed in the Available categories and operations box.

    Operations and categories at the root level

    Note
    The standard operations such as ExecuteReader, ExecuteScalar, and ExecuteNonQuery are available at the root level. For more information about these operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations. For instructions on how to execute these operations using the Oracle E-Business adapter, see Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using BizTalk Server.

  4. Expand the Schema-Based View node to see the schemas defined in the underlying database. Each schema is further categorized on the basis of PL-SQL APIs, procedures, functions, tables, and views it contains.

    Tip
    You can directly go to the “immediate” category node or subcategory nodes in the tree, by typing the name of the artifact while the focus is on the tree view in the Select a category box. For example, to jump to the SCOTT schema, keep the focus on the Schema-Based View node, and then type SCOTT.

  5. Expand the PL-SQL APIs node to see the list of packages defined in the Oracle database for a particular schema. Click a package name to see the functions and procedures defined within that package in the Available categories and operations box.

    Browse packages in the Oracle database

  6. Click the Procedures node to see the list of procedures in the Available categories and operations box.

    Browse procedures in Oracle database

  7. Click the Functions node to see the list of functions in the Available categories and operations box.

    Browse funcitons in Oracle database

  8. Expand the Tables node to see the list of tables for a particular schema. Click a table name to see the operations supported on the table in the Available categories and operations box.

    Browse for tables in Oracle database

    Note
    If a table contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The name of such operations are Read_<LOBColName>. For example, if the table has a column, PHOTO, of type BLOB, the adapter exposes a Read_PHOTO operation. If a table has more than one column of type BLOB, CLOB, NCLOB, and BFILE the adapter will expose as many number of Read_<LOBColName> operations.

    Similarly, if a table contains columns of type BLOB, CLOB, or NCLOB the adapter also exposes a specific operation to update data into such columns. The name of such operations are Update_<LOBColName>. For example, if the table has a column, PHOTO, of type BLOB, the adapter exposes an Update_PHOTO operation. If a table has more than one column of type BLOB, CLOB, and NCLOB the adapter will expose as many number of Update_<LOBColName> operations. Note that the update operation is not supported on columns of type BFILE.

  9. Expand the Views node to see the list of views for a particular schema. Click a view name to see the operations supported on the view in the Available categories and operations box.

    Browse for views in Oracle database

    Note
    If a view contains columns of type BLOB, CLOB, NCLOB, or BFILE the adapter also exposes a specific operation to read data from such columns. The name of such operations are Read_<LOBColName>. For example, if the view has a column, RULE, of type BLOB, the adapter exposes a Read_RULE operation. If a view has more than one column of type BLOB, CLOB, NCLOB, or BFILE the adapter will expose as many number of Read_<LOBColName> operations. Note that Update_<LOBColName> operations are not supported on views.

Browsing for Inbound Operations

Perform the following steps to browse the inbound operations under the schema-based view.

To browse metadata for inbound operations under the Schema-based view

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

  2. From the Select contract type list, for inbound operations select Service (Inbound operations).

  3. The Select a category box lists the different views under which the Oracle E-Business Suite artifacts are categorized.

    The following figure shows the Consume Adapter Service Add-in. The root node (/) is selected, and the general category nodes available under the root node are listed in the Available categories and operations box.

    Inbound operation at the root level

    The inbound operation, Notification, is also available at the root level.

  4. Expand the Schema-Based View node to see the schemas defined in the underlying database. Each schema is further categorized on the basis of PL-SQL APIs, procedures, functions, tables, and views it contains.

    Tip
    You can directly go to the “immediate” category node or subcategory nodes in the tree, by typing the name of the artifact while the focus is on the tree view in the Select a category box. For example, to jump to the SCOTT schema, keep the focus on the Schema-Based View node, and then type SCOTT.

  5. Expand the PL-SQL APIs node to see the list of packages defined in the Oracle database for a particular schema. Click a package name to see the functions and procedures defined within that package in the Available categories and operations box. Each of the listed functions and procedures can be used to poll the Oracle database.

    Browse packages in Oracle database for polling

  6. Click the Procedures node to see the list of procedures in the Available categories and operations box. Each of the listed procedures can be used to poll the Oracle database.

    Browse procedures in Oracle database for polling

  7. Click the Functions node to see the list of functions in the Available categories and operations box. Each of the listed functions can be used to poll the Oracle database.

    Browse functions in Oracle database for polling

  8. Expand the Tables node to see the list of tables for a particular schema. Click a table name to see the Poll inbound operation supported on the table in the Available categories and operations box.

    Browse tables in Oracle database for polling

  9. Expand the Views node to see the list of views for a particular schema. Click a view name to see the Poll inbound operation supported on the view in the Available categories and operations box.

    Browse views in Oracle database for polling

See Also

Other Resources

Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations

© 2014 Microsoft Corporation. All rights reserved.


Searching for Operations

You can use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in to search for specific artifacts in the Oracle E-Business Suite. This topic provides information on how the search is supported for different views and what wildcard characters can be used for searching Oracle artifacts. This topic also provides information on how to search using the Consume Adapter Service Add-in or Add Adapter Service Reference Plug-in.

Note
The Consume Adapter Service Add-in and the Add Adapter Service Reference Plug-in present essentially the same interface when you browse and search for operations, so both components are covered in the same topics.

For more information see How Does the Adapter Surface Oracle E-Business Suite Metadata?.

Prerequisites

You must connect to the Oracle E-Business Suite before you can search metadata for target operations. For information about how to connect to the Oracle database when you use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

Support for Wildcard Characters

When searching Oracle E-Business Suite metadata using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in, the Oracle E-Business adapter supports wildcard and escape characters in the search expression.

Special character | Interpretation
_ (underscore) | Matches exactly one character For example, A_ matches AB, AC, AD.
% (percentage) | Matches zero or more characters. For example, A% matches A, AB, ABC.
\ (escape) | Escapes the special meaning of % and _ For example, A\_B matches A_B.

Note
Escape character is a character that is put before a wildcard character to indicate that the wildcard should be interpreted as a regular character and not as a wildcard.

Searching Under Different Views

The Consume Adapter Service Add-in and the Add Adapter Service Reference Plug-in categorizes data into three views—application-based view, artifact-based view, and schema-based view. One of the reasons to categorize the artifacts under these three views is to facilitate search based on what you are searching for. The following table describes how search can differ across these views.

View How to search

Application-based view

This view is categorized by the Oracle E-Business Suite application names. You must use this view when you know which application contains the artifacts you want to work with.

Users using this view will be familiar with the Oracle applications and are aware what application they want to use. Hence, the search under this view is supported only at the immediate level. For example, if the Application-Based View node is selected, users can search for an application in the Oracle E-Business Suite. Similarly, if the Interface Table node is selected, users can search for an interface table in an Oracle E-Business application.

Artifact-based view

This view is categorized by the Oracle E-Business Suite artifacts. When working with Oracle E-Business Suite application artifacts, users must use this view when they know which Oracle E-Business Suite artifact they want to work with but are not sure which application the artifact belongs to.

Using this view, users can search for a specific artifact across all Oracle E-Business Suite applications. For example, users can select the Interface Tables node and search using the string AR%. This is how search will be performed:

  • Because the interface tables are further categorized under applications, all the applications start with AR will be listed.

  • All the interface tables starting with AR will be listed. These tables can belong to any Oracle E-Business suite application.

When working with Oracle database artifacts using this view, users can search for a specific artifact either under the current schema with which you log in or all schemas. For example, if users want to use a procedure CREATE_ACCOUNT but are not aware which schema the procedure belongs to, they can select the All Schemas node and then search using the string CREATE%.

Schema-based view

This view is categorized by the schemas available in the underlying Oracle database. You must use this view when you know which schema has the artifacts you want to work with.

Users using this view will be familiar with the schema that has the artifact they want to work with. Hence, the search under this view is supported only at the immediate level. For example, if the Schema-Based View node is selected, users can search for a schema in the Oracle database. Similarly, if the Table node is selected, users can search for a table in an Oracle E-Business application.

Searching for Operations

To search metadata in Oracle E-Business Suite using the Consume Adapter Service Add-in, perform the following steps.

To search metadata in Oracle E-Business Suite

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

  2. From the Select contract type list, select the type of contract based on whether you are searching for inbound or outbound operations.

  3. In the Select a category box, click the category node under which you want to search for a specific artifact. For example, to search for an Oracle application, click the Application-Based View node.

    Note
    To search for an application you can specify the friendly name or the short name of the application. For example, to search for the Receivables application you can specify the search string as either Receive% or AR. AR is the application short name.

  4. In the Search in category box, type a search expression to search for a specific artifact. For example, to search for Oracle applications that has "Customer" in their name, type %Customer%.

    Note
    The search string is case-sensitive.

  5. To start the search, click the button with the right-arrow icon. After the search is complete, the Available categories and operations box lists the artifacts that satisfy the search criteria.

    The following figure shows the Oracle applications tables that contain “Customer” in their name.

    Search metadata in Oracle E-Business Suite

    Note
    To search for a concurrent program you can specify the friendly name or the actual name of the concurrent program. For example, to search for the Customer Interface concurrent program you can specify the search string as either %Customer Interface% or %RACUST%. RACUST is the actual name of the concurrent program.

    Also, the search result will always contain the standard concurrent programs irrespective of whether their name matches with the specified search string.

See Also

Other Resources

Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations

© 2014 Microsoft Corporation. All rights reserved.


Retrieving Metadata for Operations

You can use the Consume Adapter Service Add-in to generate schema for selected Oracle E-Business Suite artifacts. After you have browsed and searched for the artifacts you want to invoke, you can generate schema for those artifacts and send messages, conforming to the schema, to Oracle E-Business Suite.

Note
The Consume Adapter Service Add-in and the Add Adapter Service Reference Plug-in present essentially the same interface when you browse and search for operations, so both components are covered in the same topics.

Prerequisites

You must connect to the Oracle E-Business Suite before you retrieve metadata for target operations. For information about how to connect to the Oracle database when you use the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

Generating Schema Using the Consume Adapter Service Add-in

Note
You can select category nodes to return all the operations in that category's sub-tree—for example, you can select the Concurrent Programs node (to generate schema for all the concurrent programs for an Oracle application) or you can select a specific concurrent program. For more information about the nodes, see Metadata Node IDs.

To generate schema for Oracle E-Business Suite artifacts

  1. Connect to Oracle E-Business Suite using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. See Connecting to the Oracle E-Business Suite in Visual Studio for instructions.

    Important
    To generate schema for performing operations using BizTalk Server you must set the EnableBizTalkCompatibilityMode binding property to True. You must set this binding property while establishing a connection to the Oracle E-Business Suite.

  2. From the Select contract type list, select the type of contract based on whether you are generating schema for inbound or outbound operations.

  3. Click the category node for which you want to generate metadata. For example, if you want to generate metadata for a concurrent program within an Oracle application, click Concurrent Programs.

  4. Expand the category node, and select the specific item within that node for which you want to generate metadata. For example, to generate metadata for concurrent programs for the “Banking Center” application, expand the Concurrent Programs node, and then click Banking Center.

  5. In the Available categories and operations box, select the operations that you want to invoke and then click Add. The selected operations are listed in the Added categories and operations box. For example, to invoke “Purge FTP bank account” and “Get_Status” concurrent programs, click the operation names, and then click Add.

    The following figure shows the Consume Adapter Service Add-in, which lists the selected operations.

    Retrieve metadata from Oracle E-Business Suite

    If you want to generate schema for multiple operations, there may be some duplicate element definitions among these schema that may cause failure in compiling the BizTalk project. For example, consider a scenario where you generate schema for an operation “Op1”. The schema for “Op1” contains a parameter of data type “CT1”. After generating the schema for “Op1” you close the Consume Adapter Service Add-in and re-open it to generate schema for another operation “Op2”. Assume that “Op2” also contains a parameter of data type “CT1”. After you exit the Consume Adapter Service Add-in and compile the project, you will get compilation errors because the complex data type “CT1” is defined twice in different XSD files. In such situations, we recommend the following:

    • Generate schema for all the operations in a single run of Consume Adapter Service Add-in. This ensures that the Consume Adapter Service Add-in generates only one definition for the complex data type “CT1”.

    • If you want to generate schema for multiple operations across different runs of Consume Adapter Service Add-in, make sure you select the Generate unique schema types check box, so that the generated XSD files contain unique namespaces for the complex data type “CT1”.

  6. Click OK. The schema file is saved with an .xsd extension at the same location as the BizTalk project.

    Note
    If you are using the Consume Adapter Service Add-in to generate metadata for operations on Oracle artifacts, by default the files are created with a specific naming convention: The generated XSD file name has the following three parts:

    • "OracleEBSBinding” or the prefix provided in the Filename prefix box.

    • The name included in the fileNameHint annotation tag in the generated WSDL. For operations, the file name hint is same as the operation group. For the complex types, the file name hint is the namespace without the “http://schemas.microsoft.com/OracleEBS/2008/05/” prefix. For example, the file name hint for an interface table operation follows the convention <InterfaceTables>+<app_short_name>+<interface_table_name>.

    • (Optional) An integer to ensure that the file name is unique.

    Finally, the name of an XSD file is arrived upon as <file_name_prefix>+<fileNameHint>+n, where “n” is an unique integer.

    Note
    The Consume Adapter Service Add-in also creates a binding file (an XML file) containing the binding properties that you specified when generating the schema for an operation and the SOAP action to invoke the operation. You can import this binding file in the BizTalk Server Administration console to create a WCF-Custom port with the connection URI, binding properties, and the SOAP action set. For more information, see Configuring a Physical Port Binding Using a Port Binding File.

    You have successfully generated metadata for Oracle E-Business Suite artifacts. You can use the metadata to send messages to Oracle E-Business Suite to perform specific operations. See Developing BizTalk Applications for more information about how to perform these operations.

Generating a WCF Client or WCF Service Contract Using the Add Adapter Service Reference Plug-in

You can use the Add Adapter Service Reference Plug-in to generate either WCF client code for outbound operations or WCF service code for the inbound operations.

To generate WCF client class or service contract for Oracle E-Business Suite operations

  1. In the Add Adapter Service Reference Plug-in, from the Select contract type drop-down list, select the type of contract based on whether you will be performing inbound or outbound operations.

  2. Browse or search for categories (such as an interface table) or for the specific operations for which you want to generate a WCF client (or WCF service contract).
    For example, to browse for the operations on the AR_ARCHIVE_PURGE_INTERIM interface table, in the Select a category box:

    1. Expand the root node (/) to see the categories under which the operations are surfaced for the Oracle E-Business Suite. The same interface table can be available under the Application-Based View node as well as the Artifact-Based View node. In this example, you generate the WCF client class from the Application-Based View node.

    2. Under the root node, expand the Application-Based View node to see the available applications in the Oracle E-Business Suite.

    3. Expand the node for the Receivables application and then expand the Interface Tables node.

    4. Click the AR_ARCHIVE_PURGE_INTERIM interface table node, and in the Available categories and operations box, select the operations for which you want to generate a WCF client (or WCF service contract), and then click Add. The selected operations are listed in the Added categories and operations box.

      The following figure shows the Add Adapter Service Reference Plug-in with the Insert and Select operations for the AR_ARCHIVE_PURGE_INTERIM table selected.

      Generate a WCF client or service contract

      Important
      Depending on the outbound operations (or categories) that you select, more than one WCF client class may be generated. For more details, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

  3. For most scenarios the default serialization options are sufficient; however, if needed, you can control several aspects about the code that is generated and the type of serializer that is used. To set these options:

    1. Click Advanced Options to open the Advanced Options box.

    2. In the Advanced Options box under Choose options for generated proxy, select the options that you want. For example, you can select whether asynchronous methods are generated for the WCF client or disable the generation of a configuration file.

    3. Under Serializer select the serializer that should be used.

    The following figure shows the Advanced Options box with the default selections (Auto is selected for the serializer and no other options are selected).

    The Advanced Options box default settings

    The options that you can configure in the Advanced Options box are equivalent to some of the options available when you use the ServiceModel Metadata Utility Tool (svcutil.exe). For more information about these options, see "ServiceModel Metadata Utility Tool (Svcutil.exe)" at http://go.microsoft.com/fwlink/?LinkId=99821.

  4. Click OK. The Add Adapter Service Reference Plug-in saves the WCF client class (or WCF service interface) and helper code for the operations and categories that you have selected in your project directory. By default, a configuration file is also saved. Slightly different files are generated for inbound and outbound operations; for more information, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

You can select any node that is listed in the Available categories and operations box. If you select a category node then all of the operations available under that node and its sub-nodes will be selected. For example, to generate a WCF client for all of the operations surfaced for the AR_ARCHIVE_PURGE_INTERIM table, you can select the AR_ARCHIVE_PURGE_INTERIM node.

See Also

Other Resources

Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations

© 2014 Microsoft Corporation. All rights reserved.


Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties

This topic was last updated on: June 05, 2009

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces several binding properties. By setting these properties, you can control some of the adapter's behavior. This section describes the Oracle E-Business adapter binding properties. It also shows how you can access them by using .NET programming or by setting properties on a BizTalk Server physical port binding.

The Adapter Binding Properties

The Oracle E-Business Suite is an application layer over the underlying Oracle database. Some binding properties configure the adapter’s behavior while interfacing with Oracle E-Business Suite, while other properties configure the behavior while interfacing with the Oracle database. The following table shows all the Oracle E-Business adapter binding properties grouped by category. The category refers to the node under which each binding property appears in the dialog boxes that are presented by different applications to configure the adapter (or binding).

Binding Property Category Description .NET Type

ClientCredentialType

General

Specifies which set of credentials are specified while establishing a connection with the Oracle E-Business Suite. The possible values are Database and EBusiness.

  • If set to Database, adapter clients must specify the database credentials to establish the connection and the E-Business Suite credentials for the OracleUserName and OraclePassword binding properties.

  • If set to EBusiness, adapter clients must specify the E-Business Suite credentials to establish the connection and the database credentials for the OracleUserName and OraclePassword binding properties.

    Important
    If ClientCredentialType binding property is set to EBusiness, specifying the database user name and password for OracleUserName and OraclePassword binding properties is mandatory.

Default is Database.

enum (ClientCredential)

CloseTimeout

General

The WCF connection close timeout. Specifies a time span value that indicates the interval of time provided for the internal WCF channel close operation to complete. The default is 1 minute. Not supported.

System.TimeSpan

EnableBizTalkCompatibilityMode

General

Specifies how the adapter generates schema for a DataSet. Set this to True to generate the schema for DataSet correctly.

When using the adapters from BizTalk Server, you must always set the property to True. When using the adapters from Visual Studio, you must always set the property to False.

bool (System.Boolean)

InboundOperationType

General

Specifies whether you want to perform Polling or Notification inbound operation. Default is Polling.

For more information about Polling see Support for Inbound Calls Using Polling. For more information about Notification, see Receiving Database Change Notifications.

enum

Name

General

A read-only value that returns the name of the file generated by the Add Adapter Service Reference Visual Studio Plug-in to hold the WCF client class. The Add Adapter Service Reference Plug-in forms the file name by appending "Client" to the value of the Name property. The value returned is "OracleEBSBinding"; for this value, the generated file will be named "OracleEBSBindingClient".

string

OpenTimeout

General

The WCF connection open timeout. Specifies a time span value that indicates the interval of time provided for the internal channel open operation to complete. The default is 1 minute.

Important
The Oracle E-Business adapter always uses OpenTimeout to set the connection open timeout when it opens a connection to the Oracle database. The adapter ignores any timeout (System.TimeSpan) parameters passed when you open a communication object, such as a channel.

System.TimeSpan

ReceiveTimeout

General

The WCF message receive timeout. Specifies a time span value that indicates the maximum interval of time for which the adapter waits for an inbound message. The default is 10 minutes.

Important
For inbound operations such as polling, we recommend setting the timeout to the maximum possible value, which is 24.20:31:23.6470000 (24 days). When using the adapter with BizTalk Server, setting the timeout to a large value does not impact the functionality of the adapter.

System.TimeSpan

SendTimeout

General

The WCF message send timeout. Specifies a time span value that indicates the interval of time provided for the internal channel send operation to complete. The default is 5 minute.

System.TimeSpan

UseAmbientTransaction

General

Specifies whether the Oracle E-Business adapter performs the operations using the transaction context provided by the caller. Default is true, which means that the adapter always performs the operations in a transaction context, assuming that the client is providing the transactional context. If there are other resources participating in the transaction, the connections created enlist in System.Transaction and are elevated to an MSDTC transaction.

However, there can be scenarios where you do not want the adapter to perform operations in a transactional context. For example:

  • While performing a simple SELECT operation on the Oracle database (on a send port)

  • While specify a polling statement that performs a SELECT operation and does not involve any changes to the table either through a DELETE statement or by invoking a stored procedure (on a receive port)

Both these operations do not make any updates to the database table and hence, elevating these operations to use an MSDTC transaction can be a performance overhead. In such scenarios, you can set the binding property to false so that the Oracle E-Business adapter does not perform the operations in a transaction context.

Note
Not performing operations in a transactional context is advisable only for operations that do not make changes to the database. For operations that update data in the database, we recommend setting the binding property to true otherwise you might either experience message loss or duplicate messages depending on whether you are performing inbound or outbound operations.

bool (System.Boolean)

DataFetchSize

Buffer management

ODP.NET property. Specifies the amount of data in bytes that ODP.NET fetches from the result set in one server roundtrip. The default is 65536. This property is used for performance tuning.

long (System.Int64)

InsertBatchSize

Buffer management

Specifies the batch size for multiple record Insert operations. The default is 20. For values of InsertBatchSize greater than one, the Oracle E-Business adapter batches the specified number of records into a single ODP.NET call. If the number of records in the Insert operation is not a multiple of the batch size, the final batch will contain fewer records than the batch size value. For example, if the insert message has 10 records and the InsertBatchSize is set to 1, the adapter reads individual records and writes them into the Oracle database. So, the adapter performs 10 separate operations on the Oracle database. Similarly, if the insert message has 10 records and the InsertBatchSize is set to 5, the adapter will read and write 5 records at a time into the Oracle database, therefore performing only 2 insert operations.

A well-chosen value for InsertBatchSize can greatly improve adapter performance for multiple record Insert operations.

int (System.Int32)

LongDatatypeColumnSize

Buffer management

Specifies the maximum size in bytes of an Oracle long data type column. The maximum value of this binding property can be 32512. The default is 0. You must use the default value if you are not performing operation on long data type. You must explicitly set an appropriate value for this binding property if you are:

  • Executing a stored procedure that contains parameters of long data type.

  • Performing a Select operation on a table that contains columns with long data type, and the SELECT statement does not include the primary key column.

If you want to set the maximum value for this binding property, set the value to -1.

Note
This binding property is deprecated.

int

MaxOutputAssociativeArrayElements

Buffer management

Specifies the size of the associate array that the adapter creates when performing operations that return an associative array in the response. The adapter communicates the size of the array to ODP.NET, which in turn creates a buffer depending on the array size. Default is 32.

This binding property is useful when performing operations involving PL/SQL table types.

int (System.Int32)

MetadataPooling

Buffer management

ODP.NET property. Specifies whether ODP.NET caches metadata information for executed queries. The default is true, which enables metadata pooling. Caching this information improves performance; however, if changes to the underlying Oracle artifacts occur on the Oracle system, this pooled metadata will be out of sync. This might cause operations performed on the Oracle system to return unexpected exceptions. This property is used for performance tuning.

bool (System.Boolean)

StatementCachePurge

Buffer management

ODP.NET property. Specifies whether the ODP.NET statement cache associated with a connection is purged when the connection is returned to the connection pool. The default is false, which disables statement cache purging. This property is used for performance tuning.

bool (System.Boolean)

StatementCacheSize

Buffer management

ODP.NET property. Specifies the maximum number of statements that can be cached by each ODP.NET connection. Setting this property to a non-zero value enables statement caching for connections. The default is 10. This property is used for performance tuning.

int (System.Int32)

OracleConnectionClientId

Debug

Specifies a client identifier (ID) for the connection used by the adapter to connect to Oracle. This is useful if you have enabled Oracle server-side tracing, and want to selectively trace the operations for a particular client ID. This also allows you to filter and view the Oracle server traces based on a client ID.

String

EnablePerformanceCounters

Diagnostics

Specifies whether to enable the WCF LOB Adapter SDK performance counters and the Oracle E-Business adapter LOB Latency performance counter. The default is False; performance counters are disabled. The LOB Latency performance counter measures the total time spent by the Oracle E-Business adapter in making calls to Oracle E-Business Suite.

bool (System.Boolean)

EnableSafeTyping

Metadata

Enables or disables safe typing. The default is false; safe typing is disabled. This feature controls how the adapter surfaces certain Oracle data types. For more information about safe typing, see Basic Oracle Data Types.

bool (System.Boolean)

UseSchemaInNameSpace

Metadata

Specifies whether the schema name (SCOTT, HR, and so on) is included in the xml namespace for operations and their associated types on the underlying database artifacts. The default is True; the schema name is included in the namespace. The advantage of not having scheme name included in the namespace is that if there is a table with same name (for example, EMP) in two different schemas then the same XML can be used to perform the simple SQL operations (Insert, Update, Delete, Select) on both tables.

For example, if the UseSchemaInNamespace property is true, the namespace for these operations on the SCOTT.EMP table is "http://schemas.microsoft.com/OracleEBS/Tables/SCOTT/EMP"; if it is false, the namespace is "http://schemas.microsoft.com/OracleEBS/Tables/EMP ".

Important
The message action is not affected by the UseSchemaInNamesapce binding property; it always includes the schema name.

Important
We strongly recommend setting this binding property to True while generating metadata. If you set this property to false, the Oracle schema names (for example, SCOTT) will not be available in the XML namespace of the generated schema. So, if there are two tables with the same name in two different Oracle schemas, and they are added to the same BizTalk project, the BizTalk project will fail to build and deploy. If you want to include such schemas in the same BizTalk project, you must manually edit them to include the Oracle schema name in the XML namespace.

bool (System.Boolean)

MlsSettings

Multi Language Support

An Oracle E-Business Suite instance can have multiple language packs installed. So, if the adapter is retrieving metadata from an Oracle E-Business Suite instance that has multi-language support (MLS), the adapter must present information with the same language setting as the logged in user prefers.

The MlsSettings binding property enables adapter clients to specify the MLS-specific options. This binding property can be specified both at design time and run time. The MlsSettings binding property is a complex binding property that in turn contains more binding properties. All these binding properties are optional. The adapter uses the binding properties in the following manner to set the MLS context:

  • For binding properties that have values specified, the adapter uses those values to set the MLS context.

  • For binding properties that do not have values specified, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.

Following table lists the binding properties that are part of the MlsSettings binding property. All these properties are optional.

Property Name Description

Calendar

Specifies the calendar system. This binding property maps to the NLS_CALENDAR setting in the ODP.NET client.

Comparison

Specifies a method of comparison for the WHERE clauses and comparison in PL/SQL blocks. This binding property maps to the NLS_COMP setting in the ODP.NET client.

Currency

Specifies the string to use as a local currency symbol for the L number format element. For information about the various number format elements and format models in Oracle, see http://go.microsoft.com/fwlink/?LinkId=135807. This binding property maps to the NLS_CURRENCY setting in the ODP.NET client.

DateFormat

Specifies the format in which the date is presented. This binding property maps to the NLS_DATE_FORMAT setting in the ODP.NET client.

DateLanguage

Specifies the language for day and month names. This binding property maps to the NLS_DATE_LANGUAGE setting in the ODP.NET client.

DualCurrency

Specifies the dual currency symbol, such as Euro, for the U number format element. For information about the various number format elements and format models in Oracle, see http://go.microsoft.com/fwlink/?LinkId=135807. This binding property maps to the NLS_DUAL_CURRENCY setting in the ODP.NET client.

ISOCurrency

Specifies the string to use as an international currency symbol for the C number format element. For information about the various number format elements and format models in Oracle, see http://go.microsoft.com/fwlink/?LinkId=135807. This binding property maps to the NLS_ISO_CURRENCY setting in the ODP.NET client.

Language

Specifies the language to be set as part of MLS context. This binding property maps to the NLS_LANGUAGE setting in the ODP.NET client.

Important
The value for the OracleEBSResponsibilityName binding property must be specified in the same language as specified for the Language binding property. For example, if you set the Language binding property to Spanish, the responsibility name you specify for the OracleEBSResponsibilityName binding property must also be in Spanish.

LengthSemantics

Enables creation of CHAR and VARCHAR2 columns using either byte or character (default) length semantics. This binding property maps to the NLS_LENGTH_SEMANTICS setting in the ODP.NET client.

NCharConversionException

Specifies whether the data loss during an implicit or explicit character type conversion reports an error or not. The default is True. This binding property maps to the NLS_NCHAR_CONV_EXCP setting in the ODP.NET client.

NumericCharacters

Specifies the decimal character and group separator. This binding property maps to the NLS_NUMERIC_CHARACTERS setting in the ODP.NET client.

Sort

Specifies the type of sort for character data. This binding property maps to the NLS_SORT setting in the ODP.NET client.

Territory

Specifies the conventions of date and numeric format for a territory. This binding property maps to the NLS_TERRITORY setting in the ODP.NET client.

TimeStampFormat

Specifies the string format for TimeStamp data types. This binding property maps to the NLS_TIMESTAMP_FORMAT setting in the ODP.NET client.

TimeStampTZFormat

Specifies the string format for TimeStampTZ data types. This binding property maps to the NLS_TIMESTAMP_TZ_FORMAT setting in the ODP.NET client.

TimeZone

Specifies the time zone region name. This binding property maps to the TIME_ZONE setting in the ODP.NET client.

enum

NotificationPort

Notification

Specifies the port number that ODP.NET must open to listen for database change notification from Oracle database. Default is -1, which signifies that ODP.NET uses a valid, random, unused port number.

Important
Adapter clients will not receive database change notifications if Windows Firewall is turned on. Also, turning off Windows Firewall to receive notifications is not advisable. So, to receive notifications without compromising the security of the client-side computers, we recommend specifying a positive integer value as a port number and then adding that port number to the Windows Firewall exceptions list. If you set this binding property to the default value of -1, ODP.NET uses a random port and adapter clients will not know which port to add to Windows Firewall exceptions list. For instructions on how to add ports to Windows Firewall exceptions list, see http://go.microsoft.com/fwlink/?LinkID=196959.

Caution
If there is more than one application in an application domain receiving notifications using the Oracle E-Business adapter, the NotificationPort binding property for all applications must be set to the same port number. This is because ODP.NET creates only one listener that listens on one port within an application domain.

int (System.Int32)

NotificationStatement

Notification

Specifies the SELECT statement used to register for getting notifications from Oracle database. An example SELECT statement could resemble the following.

Copy Code
SELECT TID,ACCOUNT,PROCESSED FROM SCOTT.ACCOUNTACTIVITY WHERE PROCESSED = ‘n’
Note
You must specify the database object name along with the schema name. For example, SCOTT.ACCOUNTACTIVITY.

The adapter gets a notification message from Oracle database only when the result set for the specified SELECT statement changes.

string

NotifyOnListenerStart

Notification

Specifies whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts. Default is True.

bool (System.Boolean)

ConnectionLifetime

Oracle Connection Pool

ODP.NET property. Specifies the maximum duration in seconds of a connection. The default is 0. This property is used for performance tuning.

int (System.Int32)

DecrPoolSize

Oracle Connection Pool

ODP.NET property. Specifies the number of connections that are closed when an excessive amount of established connections are not in use. The default is 1. This is used for performance tuning.

int (System.Int32)

IncrPoolSize

Oracle Connection Pool

ODP.NET property. Specifies the number of new connections to be created when a new connection is requested and there are no available connections in the ODP.NET connection pool. The default is 5. This property is used for performance tuning.

int (System.Int32)

MaxPoolSize

Oracle Connection Pool

ODP.NET property. Specifies the maximum number of connections in an ODP.NET connection pool. The default is 100. This property is used for performance tuning.

Important
You must set MaxPoolSize judiciously. It is possible to exhaust the number of connections available from ODP.NET, if this value is set too large.

int (System.Int32)

MinPoolSize

Oracle Connection Pool

ODP.NET property. Specifies the minimum number of connections in an ODP.NET connection pool. The default is 1. This property is used for performance tuning.

int (System.Int32)

UseOracleConnectionPool

Oracle Connection Pool

ODP.NET property. Specifies whether to use the ODP.NET connection pool. The default is true, which enables connection pooling. The Oracle E-Business adapter implements connection pooling by using the ODP.NET connection pool.

bool (System.Boolean)

ApplicationShortName

OracleEBS

The short name for an Oracle E-Business Suite application. You must provide the application short name while setting the application context for certain PL/SQL APIs, and database tables or views. But, why do we need to set the application context for only certain PL/SQL APIs, and database tables or views?

  • The PL/SQL APIs, both associated with the Oracle database and the applications in the Oracle E-Business Suite, are also available under the “Artifact-Based View” and the Schema-Based View” node at design-time while using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. While executing the PL/SQL APIs associated with the Oracle database, you need not set this binding property. However, while executing a PL/SQL API associated with an Oracle E-Business Suite application, you must set the application context by specifying a valid value for this binding property.

  • For custom Oracle E-Business Suite applications, users may or may not register the base database tables as interface tables. If a database table is not registered as an interface table, it will be available under the “Database” node at design-time while using the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in. However, because these tables are associated with an Oracle E-Business application, for any operation on these tables you must set the application context.

So, to perform any operation on a PL/SQL API, and database tables or views belonging to the Oracle E-Business Suite, you must always specify the application short name.

Important
While executing a PL/SQL API or performing any operation on database tables or views associated with an Oracle E-Business Suite application, you must also:

  • Set the ClientCredentialType binding property to EBusiness,

  • Set the OracleUserName, OraclePassword binding properties to specify the credentials to connect to the Oracle E-Business Suite, and

  • Set the OracleEBSResponsibilityName binding property to the appropriate responsibility name.

By setting these binding properties you inform the adapter that the PL/SQL API, or the database table or view, you are operating on is associated with an Oracle E-Business Suite application and hence the ApplicationShortName binding property becomes mandatory. On the contrary if you are executing a PL/SQL API, or any operation on database tables or views, associated with an Oracle E-Business Suite application, and you do not set the ClientCredentialType, OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties appropriately, the adapter ignores the ApplicationShortName, even if it is set, and assumes that the PL/SQL API or the database table you are performing operations on belongs to the Oracle database.

string

OracleEBSOrganizationId

OracleEBS

Specifies the organization ID to which an Oracle E-Business Suite application belongs. This property is optional and is considered only when:

  • The ClientCredentialType binding property is set to EBusiness, and

  • The OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties are specified appropriately.

string

OracleEBSResponsibilityKey

OracleEBS

The responsibility key associated with the Oracle E-Business Suite user.

Unlike the responsibility name (OracleEBSResponsibilityName binding property), the responsibility key is not dependent on the language specified. It implies that you do not have to specify responsibility keys in different languages depending on the value specified in the Language binding property while setting the MLS context.

Important
  • The value specified for the OracleEBSResponsibilityKey binding property overrides the value specified for the OracleEBSResponsibilityName binding property.

  • If you will be performing operations on the data in multiple languages and do not want to specify a responsibility name in each language, you should specify a value for this binding property while performing operations on interface tables, selecting values from interface views, or executing a concurrent program or request set. Of course, you can always use this binding property even if you are working only with data in the English language.

string

OracleEBSResponsibilityName

OracleEBS

The name of the responsibility associated with the Oracle E-Business Suite user.

The responsibility name is dependent on the language specified. It implies that if you are setting the MLS context by specifying a value for the Language binding property, the value for the OracleEBSResponsibilityName binding property must be specified in the same language as specified for the Language binding property. For example, if you set the Language binding property to Spanish, the responsibility name you specify for the OracleEBSResponsibilityName binding property must also be in Spanish.

Important
You must specify a value for this binding property while performing operations on interface tables, selecting values from interface views, or executing a concurrent program.

string

OraclePassword

OracleEBS

  • If the ClientCredentialType binding property is set to Database, this property specifies the password for an Oracle database user.

  • If the ClientCredentialType binding property is set to EBusiness, this property specifies the password for an Oracle E-Business Suite user.

The Oracle E-Business adapter does not preserve the case of the value that you enter for the OraclePassword binding property when it connects to Oracle E-Business Suite. The password is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the password to be preserved or if you want to enter a password containing special characters, you must specify the value within double quotes.

Important
  • While performing operations on interface tables, selecting values from interface views, executing a concurrent program, or executing a PL/SQL API associated with an Oracle E-Business Suite application you must set the ClientCredentialType binding property to EBusiness and then specify a valid password to connect to Oracle E-Business Suite.

  • The OraclePassword binding property is not available in the binding file (XML file) or the app.config file generated as a result of using the Consume Adapter Service BizTalk Project Add-in or the Add Adapter Service Reference Visual Studio Plug-in.

string

OracleUserName

OracleEBS

  • If the ClientCredentialType binding property is set to Database, this property specifies the user name for authentication on the Oracle database.

  • If the ClientCredentialType binding property is set to EBusiness, this property specifies the user name for authentication on the Oracle E-Business Suite.

The Oracle E-Business adapter does not preserve the case of the value that you enter for the OracleUserName binding property when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the user name to be preserved or if you want to enter a user name containing special characters, you must specify the value within double quotes.

Important
While performing operations on interface tables, selecting values from interface views, executing a concurrent program, or executing a PL/SQL API associated with an Oracle E-Business Suite application you must set the ClientCredentialType binding property to EBusiness and then specify a valid user name to connect to Oracle E-Business Suite.

string

PolledDataAvailableStatement

Polling

Specifies the SELECT statement executed to determine whether any data is available for polling for a specific table. The specified statement must return a result set consisting of rows and columns. The value in the first cell of the result set indicates whether the adapter executes the value specified for the PollingInput binding property. If the first cell of the result contains a positive value, the adapter executes the polling statement. For example, a valid statement for this binding property will be:

Copy Code
Select * from <table_name>
Tip
If you want the adapter to continue polling irrespective of whether the table being polled has data, you can specify the value for this binding property as Select 1 FROM DUAL.

Note
You must not specify stored procedures for this binding property. Also, this statement must not modify the underlying Oracle database.

string

PollingAction

Polling

Specifies the action for the polling operation. You can determine the polling action for a specific operation from the metadata you generate for the operation using the Consume Adapter Service Add-in.

string

PollingInput

Polling

Specifies the polling statement. You can specify a simple SELECT statement or a stored procedure for polling. If you want to poll a table or view, you must specify a SELECT statement for this binding property. If you want to poll using a stored procedure, you must specify the entire request message for this binding property. The request message must be the same that you send to the adapter for invoking the stored procedure as an outbound operation.

Note
The SQL statement or the stored procedure specified for this binding property is executed only if the statement executed by the PolledDataAvailableStatement binding property returns some data.

Important
The Oracle E-Business adapter executes the polling statement and the post-poll statement (if specified) inside of an Oracle transaction. If you are using a SELECT statement in the PollingInput binding property, we recommend that you specify a FOR UPDATE clause in your SELECT statement. This will ensure that the selected records are locked during the transaction and that the post-poll statement can perform any required updates on the selected records.

string

PollingInterval

Polling

Specifies the transacted polling interval, that is, the interval in seconds at which the Oracle E-Business adapter executes the statement you specified for PollingInput binding property against the Oracle database. The default is 30. The polling interval is used by the adapter for the following:

  • The time interval between successive polls. This interval is used to run the poll and post-poll queries. If these queries are executed within the specified interval, the adapter sleeps for the remaining time in the interval.

  • The polling transaction timeout value. This value must be set large enough to include the polling statement execution time, the post-poll statement (if specified) execution time, and the time to receive the reply from the client application to commit the transaction.

If the client application sends a reply before the polling interval expires, the adapter commits the transaction and waits until the polling interval is reached to execute the next poll.

If the client application returns a fault, the adapter terminates the transaction.

If the polling interval expires before the client application sends the reply, the transaction will time out.

int (System.Int32)

PollWhileDataFound

Polling

Specifies whether the Oracle E-Business adapter ignores the polling interval and continuously polls the Oracle database, if data is available in the table being polled. If no data is available in the table, the adapter reverts to execute the SQL statement at the specified polling interval. Default is false.

Consider a scenario where the polling interval is set to 60 seconds, and the statement specified for PolledDataAvailableStatement returns that data is available for polling. The adapter then executes the statement specified for the PollingInput binding property. Assuming that the adapter takes just 10 seconds to execute the statement, it will now have to wait for 50 seconds before executing the PolledDataAvailableStatement again, and then subsequently execute the polling statement. Instead, to optimize the performance you can set the PollWhileDataFound binding property to true so that the adapter can start executing the next polling cycle as soon as the previous polling cycle ends.

Note
This binding property is applicable both for polling on tables and views and polling using stored procedure.

string

PostPollStatement

Polling

Specifies a statement block that is executed after the statement specified by the PollingInput binding property is executed. The default is null; no post-poll statement is executed. The post-poll statement executes inside the polling transaction. Two common uses for the post-poll statement are to:

  • Update a column in the rows returned in the polling statement to indicate that they have been processed and should be excluded from subsequent polling queries.

  • Move processed records to a different table.

Important
If a post-poll statement is specified, PollingInterval should be set large enough for the post-poll statement to complete before the interval expires.

For more information about how to use binding properties in a polling scenario, see Overview of Polling-based Data-changed Notifications.

string

SkipNilNodes

Run Time Behavior

Specifies whether the Oracle E-Business adapter will skip inserting or updating values for nodes that are marked as ‘nil’ in the request XML. This binding property is applicable for inserting or updating records in a table and for RECORD type parameters in stored procedures. Default is true, which means the adapter will skip passing values for nodes that are marked as ‘nil’. In this case, the default value in Oracle (if specified) is taken into account for nodes that are marked as ‘nil’. If set to false, the adapter explicitly passes a null value for these nodes.

Note
  • For nodes that are not present in the request XML, the adapter always skips passing values, irrespective of the value of the SkipNilNodes binding property.

  • For PL/SQL tables of RECORDS, the adapter always passes a null value for nodes that are either marked as ‘nil’ or not present in the request XML, irrespective of the value of the SkipNilNodes binding property.

The following example explains the difference in the adapter configuration based on the value you set for this binding property. Assume a request XML resembles the following:

Copy Code
<EMPNO>1000</EMPNO>
<ENAME>John</ENAME>
<SAL nil=’true’></SAL>

If SkipNilNodes is set to true, the adapter executes the following command:

Copy Code
INSERT INTO EMP (EMPNO, ENAME) VALUES (1000, “John”);

If SkipNilNodes is set to false, the adapter executes the following query:

Copy Code
INSERT INTO EMP (EMPNO, ENAME, SAL) VALUES (1000, “John”, null);

Note that in the second statement, the adapter explicitly inserts a null value for the parameter “SAL”.

bool (System.Boolean)

GeneratedUserTypesAssemblyFilePath

UDT .NET Type Generation – Design Time

Specifies the name and path of the DLL that the adapter generates, while generating metadata, containing all UDTs that are used in the metadata. You must specify a DLL name if you are generating metadata for packages, stored procedures, or functions that use UDTs. Specifying the DLL name is optional for tables and views that have UDTs. The generated DLL is saved to the same location as the executable.

This binding property is required only while generating metadata.

Note
  • You must specify only one filename. For all the UDTs in the metadata, the adapter generates a single file with the given name. If you do not specify a name, the adapter generates the DLL with a GUID name.

  • This binding property is not available in BizTalk Server while configuring a WCF-OracleEBS receive or send port.

string

GeneratedUserTypesAssemblyKeyFilePath

UDT .NET Type Generation – Design Time

Specifies the name and path of the key file that the adapter uses to create a strongly-typed assembly.

This binding property is optional and is required only while generating metadata.

Note
This binding property is not available in BizTalk Server while configuring a WCF-OracleEBS receive or send port.

string

UserAssembliesLoadPath

UDT .NET Type Generation – Run Time

Specifies the name of the DLLs, separated by a semi-colon, which the adapter creates while generating metadata. These DLLs are saved at the location you specified for the GeneratedUserTypesAssemblyFilePath binding property while generating metadata. You must manually copy these DLLs to the following locations:

  • For BizTalk projects: Copy the DLLs at the same location as BTSNTSvc.exe. For BizTalk Server 2013 R2, this is available typically under <installation drive>:\Program Files\Microsoft BizTalk Server 2013 R2.

  • For .NET Projects: Copy the DLLs to the \bin\Development folder within your .NET project folder.

This binding property is required only while sending and receiving messages to perform operations on the Oracle E-Business Suite.

string

AcceptCredentialsInUri

Not surfaced by the Consume Adapter Service Add-in or the Add Adapter Service Reference Plug-in.

Specifies whether the Oracle E-Business Suite connection URI can contain user credentials. The default is false, which disables user credentials in the connection URI. If AcceptCredentialsInUri is false and the Oracle connection URI contains user credentials, the Oracle E-Business adapter throws an exception. You can set AcceptCredentialsInUri to true if you must specify credentials in the URI. For more information, see The Oracle E-Business Suite Connection URI.

bool (System.Boolean)

How Do I Set the Binding Properties?

You can set the binding properties when you specify a connection to the Oracle E-Business Suite. For information about how to set binding properties when you:

  • Use the Consume Adapter Service BizTalk Project Add-in or the Add Adapter Service Reference Visual Studio Plug-in, see Connecting to the Oracle E-Business Suite in Visual Studio.

  • Configure a send port or receive port (location) in a BizTalk Server solution, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter.

  • Use the WCF channel model in a programming solution, see Creating a Channel.

  • Use the WCF service model in a programming solution, see Specifying a Client Binding for the Oracle E-Business Suite.

Important
While using the Consume Adapter Service BizTalk Project Add-in or the Add Adapter Service Reference Visual Studio Plug-in, if you do not specify a value for a binding property of type string and whose default value is null then that binding property will not be available in the binding file (an XML file) or the app.config file respectively. You must manually add the binding property and its value in the binding file or the app.config file, if required.

However, the OraclePassword binding property is not available in the binding file or the app.config file even if you specify a value for this binding property while using the Consume Adapter Service BizTalk Project Add-in or the Add Adapter Service Reference Visual Studio Plug-in.

See Also

Other Resources

Development

© 2014 Microsoft Corporation. All rights reserved.


Receiving Polling-based Data-changed Messages

This topic was last updated on: June 05, 2009

The Microsoft BizTalk Adapter for Oracle E-Business Suite supports receiving polling-based data-changed messages by polling the interface tables, interface views, tables, and views. The adapter delivers the messages to your application by:

  • Executing a SQL SELECT query to determine whether data is available for polling. You can configure the adapter to execute the SQL SELECT query periodically or continuously.

  • Executing a SQL SELECT query against an Oracle table or view or executing stored procedures, functions, or packaged procedures and functions.

  • Executing an optional post-poll PL/SQL code block on Oracle E-Business Suite. This code block is often used to update a field on the queried records in the target or to move the queried records to another table or view.

  • Returning the query results in a result set by invoking the POLL operation or the stored procedures, functions, or packaged procedures and functions that are exposed as polling operations.

The adapter executes all of these operations inside an Oracle transaction.

How Do I Configure the Oracle E-Business Adapter for Receiving Data-changed Messages Using Binding Properties?

You configure the Oracle E-Business adapter to receive data-changed messages by setting some or all of the following binding properties.

Binding Property Value Default Required/Optional

InboundOperationType

Make sure that the value is set to Polling.

Polling

Required. If not explicitly set, the default value will apply.

PolledDataAvailableStatement

Specify the SELECT statement executed to determine whether any data is available for polling for a specific table. The specified statement must return a result set consisting of rows and columns. The value in the first cell of the result set indicates whether the adapter executes the value specified for the PollingInput binding property. If the first cell of the result contains a positive value, the adapter executes the polling statement. For example, a valid statement for this binding property will be:

Copy Code
Select * from <table_name>
Note
You must not specify stored procedures for this binding property. Also, this statement must not modify the data in Oracle E-Business Suite or the underlying Oracle database.

null

Required.

PollingAction

Specifies the action for the polling operation. You can determine the polling action for a specific operation from the metadata you generate for the operation using the Consume Adapter Service Add-in.

null

Optional for polling operations on tables and views using the SELECT statement.

PollingInput

Specify either of the following:

  • SQL SELECT statement that should be executed against Oracle E-Business Suite. This statement should include a FOR UPDATE clause. For information about the FOR UPDATE clause, see Specifying a FOR UPDATE Clause in the Polling Statement later in this topic.

  • Request message for a stored procedure, function, or procedure or function within a package that you want to be polled.

null

Required. Setting PollingInput to a non-null value enables polling.

PollingInterval

Set to the interval, in seconds, at which you want the adapter to query Oracle E-Business Suite. This property specifies the polling interval and the polling transaction time out. The value should be greater than the amount of time it takes to execute the query and post-poll statement (if one is specified) on Oracle E-Business Suite plus the amount of time it takes for the client to process the query data and return the polling response message.

30

Required. If not explicitly set, the default value will apply.

PollWhileDataFound

Specifies whether the Oracle E-Business adapter ignores the polling interval and continuously polls Oracle E-Business Suite, if data is available in the table being polled. If no data is available in the table, the adapter reverts to execute the SQL statement at the specified polling interval

False

Required. If not explicitly set, the default value will apply.

PostPollStatement

Set to an optional PL/SQL code block that is executed by the adapter after the query is performed, but before the query data is returned to the client.

null

Optional. If no value is specified, a post poll statement is not executed.

Note
If you are using the WCF service model or the WCF channel model, you must also set the AcceptCredentialsInUri binding property.

Specifying a FOR UPDATE Clause in the Polling Statement

If you are using a SELECT statement as the polling statement and executing a post-poll statement that affects the rows specified in the SELECT statement, you must use the FOR UPDATE clause in the polling statement. Specifying a FOR UPDATE clause ensures that the records selected by the polling statement are locked during the transaction and that the post-poll statement can perform any required updates on them.

Caution
You can have scenarios where in the time window between the polling and post-poll statements, more records are added to the table that meet the condition of the post-poll statement. In such situations, the post-poll statement would update all the records that satisfy the condition and not just the records selected as part of the polling statement.

If a post-poll statement is specified and the polling statement does not contain a FOR UPDATE clause, you will experience one of the following two conditions:

  • If TransactionIsolationLevel is set to ReadCommitted, the post-poll query will not update the selected rows.

  • If TransactionIsolationLevel is set to Serializable, the following target system exception (Microsoft.ServiceModel.Channels.Common.TargetSystemException) will occur when the post-poll statement is executed: "ORA-08177 can't serialize access for this transaction". In such a case, you must set the PollingRetryCount binding property to define the number of times you want the adapter to retry the same transaction.

For instructions on how to set the transaction isolation level, see Configure Transaction Isolation Level and Transaction Timeout.

The polling and post-poll statements are executed in a transaction if the adapter clients have configured to use transactions and the value of the UseAmbientTransaction binding property is set to True in the adapter.

An example of a polling query with the FOR UPDATE option is:

Copy Code
SELECT * from EMP WHERE FLAG = 'Y' FOR UPDATE

Specifying a NOWAIT Clause in the Polling Statement

You may have scenarios where concurrent threads are accessing the table being polled, leading to too many contentions in the table. This may cause the polling query to be blocked to get a lock on table rows. If you are using a SELECT statement as the polling statement, you may want to specify a NOWAIT keyword along with the FOR UPDATE keyword in the SELECT statement. This will cause the polling query execution within the adapter to return immediately if there are locks on rows which the polling query is trying to select. An exception is usually thrown by Oracle under such conditions. Again, adapter clients may use the PollingInterval binding property to specify the time interval after which the adapter clients must retry for polling the data.

An example of a polling query with the NOWAIT option is:

Copy Code
SELECT * from EMP WHERE FLAG = 'Y' FOR UPDATE NOWAIT

Specifying a SKIP LOCKED Clause in the Polling Statement

You may have scenarios where due to concurrent threads accessing the table being polled, some rows in the result set of the WHERE clause specified in the polling query are locked. For example, your polling query returns 6 rows from a table; 4 out of these 6 rows are already locked because of some other transaction. In this case, you might want to specify a SKIP LOCKED keyword along with the FOR UPDATE keyword that instructs the database to attempt to lock the rows specified by the WHERE clause, and to skip any rows that are found to be already locked. The unlocked rows in the WHERE clause are locked during the transaction and the post-poll statement can perform any required updates on them so that these rows are not polled again. This ensures that you do not have to wait to receive the polling messages until all the rows specified by the WHERE clause are unlocked.

The SKIP LOCKED keyword is useful in a scenario where you have adapter clients on multiple computers that are polling the same table in a database. You can load balance among the adapter clients by configuring the polling operation in such a way that you receive polling-based data-change messages for the rows specified by the WHERE clause that are unlocked at that point of time, and then update the row to ensure that if a polling-based data-change message is received by an adapter client, the other clients do not get the same message.

An example of a polling query with the SKIP LOCKED option is:

Copy Code
SELECT * from EMP WHERE FLAG = 'Y' FOR UPDATE SKIP LOCKED

Support for Ordered Delivery (FIFO)

In a production environment, polling can be used to monitor the data changes in Oracle E-Business Suite. These data-changed messages are received by the adapter client using the Oracle E-Business adapter. Based on business scenarios, it can be critical that the data-changed messages are received by the adapter client in the right order.

The Oracle E-Business adapter supports ordered delivery or first-in-first-out (FIFO) to maintain the order in which messages are received from Oracle E-Business Suite. Here are a few considerations related to support for FIFO in inbound scenarios for the Oracle E-Business adapter.

  • If the message is being consumed by an orchestration, the orchestration must have the ordered delivery set for the messages coming from the Oracle E-Business adapter receive port.

  • If the message is being consumed by a send port (in a content-based routing) scenario, the send port must have ordered delivery set for the messages coming from the Oracle E-Business adapter receive port.

The WCF-Custom or WCF-OracleEBS adapter has a property Suspend request message on failure that specifies whether to suspend the request message that fails inbound processing. This property can be set on the Messages tab of the WCF-Custom or WCF-OracleEBS receive port under the Error handling section. The following table lists the scenarios describing how the incoming messages are processed based on whether this property is set and the state of the message subscriber (orchestration or port).

WCF-Custom port property Subscriber in Unenlisted state Subscriber in Enlisted but Stopped state

Suspend request message on failure property NOT set

  • Routing Failure Report is generated as a suspended (non-resumable message)

  • Actual message is not suspended

  • Post poll query is not executed as transaction gets aborted. Hence polling repeats and fetches the rows again.

  • Errors reported in the event log to describe what has happened.

  • Not considered a “Failure”. There are no error messages in the event log.

  • Actual message is put into the suspended (resumable) queue.

  • When the subscribing port or orchestration starts, the messages are automatically resumed. If ordered delivery is set on the subscriber, it will be honored.

  • The messages may also be resumed manually.

Suspend request message on failure property IS set

  • Routing Failure Report is generated as a suspended (non-resumable message)

  • Actual message is also suspended

  • Post poll query is not executed as transaction gets aborted. Hence polling repeats and fetches the rows again.

  • Errors reported in the event log to describe what has happened.

  • Not considered a “Failure”. There are no error messages in the event log.

  • Actual message is put into the suspended (resumable) queue.

  • When the subscribing port or orchestration starts, the messages are automatically resumed. If ordered delivery is set on the subscriber, it will be honored.

  • The messages may also be resumed manually.

See Also

Other Resources

Development
Polling Oracle E-Business Suite Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Before Developing Applications Using the Oracle E-Business Suite Adapter

This section provides information about what you must do before developing applications using the Oracle E-Business adapter.

In This Section

  • Configure MSDTC on Oracle E-Business Suite and Adapter Client

© 2014 Microsoft Corporation. All rights reserved.


Configure MSDTC on Oracle E-Business Suite and Adapter Client

The operations performed on Oracle E-Business Suite using the Oracle E-Business adapter (through BizTalk Server, the WCF service model, or the WCF channel model) can be performed within a transaction scope. If the client program has more than one transactional resource as part of the same transaction, the transaction gets elevated to an MSDTC transaction. To enable the adapter to perform operations within the scope of an MSDTC transaction, you must configure MSDTC both on the computer running the Oracle E-Business adapter and Oracle E-Business Suite. Also, you must add MSDTC to the exceptions list of Windows Firewall. This section provides information about how to perform these tasks on computers running the adapter client and Oracle E-Business Suite.

Note
The steps to configure MSDTC may vary slightly for different operating systems. The steps mentioned in this section apply to Windows Client and Windows Server Operating system.

To configure MSDTC

  1. Start the Component Services MMC snap-in.

    • Click Start, click Control Panel, double-click Administrative Tools, and then double-click Component Services.

  2. In the Component Services MMC snap-in, from the left pane expand Component Services, expand Computers, right-click My Computer, and then click Properties.

  3. In the My Computer Properties dialog box, click the MSDTC tab.

  4. In the Transaction Configuration section, click Security Configuration.

  5. In the Security Configuration dialog box, select the Network DTC Access check box and within that, select the Allow Remote Clients check box.

  6. In the Transaction Manager Communication section, select the Allow Inbound and Allow Outbound check boxes.

  7. In the Security Configuration dialog box, click OK.

  8. In the dialog box informing that the MSDTC service will be restarted, click Yes. After the MSDTC service is restarted, click OK

  9. In the My Computer Properties dialog box, click OK.

To add MSDTC to Windows Firewall exceptions list

  1. Open the Windows Firewall dialog box.

    • Click Start, click Control Panel, and then double-click Windows Firewall.

  2. In the Windows Firewall dialog box, click the Advanced Settings tab on the right pane,.

  3. In the Windows Firewall with Advanced Settings Window, right click Inbound Rules and click New Rule.

  4. In the New Inbound Rule Wizard dialog box, Select the type of rule you want to create, and then Click Next and browse to the location of msdtc.exe in the .

  5. The next step Program appears, Browse to the location of msdtc.exe in This program path to apply the rule to a specific program.

  6. Provide appropriate values to the steps in the New Inbound Rule Wizard window, and then click OK.

See Also

Other Resources

Before Developing Applications Using the Oracle E-Business Suite Adapter

© 2014 Microsoft Corporation. All rights reserved.


Developing BizTalk Applications

Developing BizTalk applications involves creating a BizTalk project in Visual Studio and using the Consume Adapter Service BizTalk Project Add-in or Add Adapter Metadata Wizard to generate XML schema. Once you have generated the schema, you can either use Content-Based Routing (CBR) or create BizTalk orchestrations to send and receive messages that conform to the generated schema.

CBR can be used in scenarios where the messages being sent to Oracle E-Business Suite do not require any intensive processing. For example, if you know that the receive port will receive messages only of a certain type, you can add a filter to the send port to route messages that match the filter expression to the send port.

In BizTalk orchestrations, you create send and receive ports to send and receive messages to and from the WCF-Custom adapter, which in turn sends the messages to BizTalk Server. This section provides information about using BizTalk orchestrations to perform operations on Oracle E-Business Suite using the Oracle E-Business adapter. The Oracle E-Business adapter in turn uses the WCF-Custom adapter, which can interact with a WCF binding.

Important
To use the Oracle E-Business adapter with Microsoft BizTalk Server, you must always set the EnableBizTalkCompatibilityMode binding property to True. For information about how to set binding properties, see Specifying Binding Properties.

In This Section

  • Before You Develop BizTalk Applications

  • Building Blocks for Developing BizTalk Applications

  • Performing Insert, Update, Delete, or Select Operations on Interface Tables and Interface Views Using BizTalk Server

  • Performing Operations on Tables with Large Data Types Using BizTalk Server

  • Performing Composite Operations on Oracle Database by Using BizTalk Server

  • Invoking Concurrent Programs in Oracle E-Business Suite Using BizTalk Server

  • Invoking Request Sets in Oracle E-Business Suite Using BizTalk Server

  • Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using BizTalk Server

  • Polling Oracle E-Business Suite Using BizTalk Server

  • Receiving Database Change Notifications Using BizTalk Server

See Also

Other Resources

Development

© 2014 Microsoft Corporation. All rights reserved.


Before You Develop BizTalk Applications

This section provides information about what you must do before developing BizTalk applications using the Oracle E-Business adapter. This section also points you to the BizTalk Server tools that are used to develop BizTalk applications.

In This Section

  • Create a Strong-Name Key File

  • Learn About BizTalk Server Tools

© 2014 Microsoft Corporation. All rights reserved.


Create a Strong-Name Key File

You must create a strong-name key file to build projects in Microsoft Visual Studio. A strong name consists of the project's identity—its simple text name, version number, and culture information (if provided)—plus a public key and a digital signature. The strong-name key file contains the public key and the private key.

Important
Creating a strong-name key file is a one-time task. You can use the same key for all the BizTalk applications you develop.

Prerequisites

You must have Microsoft Visual Studio installed on the computer where you want to create a strong-name key.

To create a strong-name key file

  1. Start Visual Studio Command Prompt.

  2. At the command prompt, navigate to the location where you want to create the key file. For example, type cd C:\Sample, and then press ENTER.

  3. At the command prompt, type sn -k <key file name>.snk, and then press ENTER.

    Note
    You should receive a message at the command prompt stating that the key pair was written to the strong-name key file.

  4. At the command prompt, type exit, and then press ENTER.

See Also

Concepts

Learn About BizTalk Server Tools

Other Resources

Before You Develop BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Learn About BizTalk Server Tools

The topics on how to use the Oracle E-Business adapter in Developing BizTalk Applications are written with the assumption that you have working knowledge of a number of BizTalk Server tools. You will use the following tools to develop BizTalk applications using the Oracle E-Business adapter:

  • Microsoft Visual Studio 2013

  • BizTalk Explorer

  • Orchestration Designer

  • Pipeline Designer

  • BizTalk Mapper

  • BizTalk Server Administration console

Prerequisites

You must install Microsoft BizTalk Server before you can access the BizTalk Server tools.

BizTalk Server Tools

The following table includes topics in the BizTalk Server documentation that explain how to use each of the listed tools.

Tool Topics in BizTalk Server Documentation

Visual Studio

  • Using Visual Studio (http://go.microsoft.com/fwlink/?LinkId=107180)

  • Working with BizTalk Projects (http://go.microsoft.com/fwlink/?LinkId=107181)

  • Deploying BizTalk Assemblies from Visual Studio into a BizTalk Application (http://go.microsoft.com/fwlink/?LinkId=107182)

Learn more about Visual Studio:

  • Introduction to Solutions, Projects, and Items (http://go.microsoft.com/fwlink/?LinkID=196962)

  • Solution Explorer Concepts (http://go.microsoft.com/fwlink/?LinkID=196962)

Orchestration Designer

  • Creating Orchestrations Using Orchestration Designer (http://go.microsoft.com/fwlink/?LinkId=107184)

Pipeline Designer

  • Creating Pipelines Using Pipeline Designer (http://go.microsoft.com/fwlink/?LinkId=107185)

BizTalk Mapper

  • Creating Maps Using BizTalk Mapper (http://go.microsoft.com/fwlink/?LinkId=107186)

BizTalk Server Administration console

  • Using the BizTalk Server Administration Console (http://go.microsoft.com/fwlink/?LinkId=107187)

See Also

Tasks

Create a Strong-Name Key File

Other Resources

Before You Develop BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Building Blocks for Developing BizTalk Applications

To perform operations on Oracle E-Business Suite by using the Oracle E-Business adapter with BizTalk Server, you must perform a set of design-time and run-time tasks using Visual Studio and BizTalk Server Administration console respectively. This section provides an overview of these tasks. All the topics in this section, which demonstrate how to perform specific operations on Oracle E-Business Suite using BizTalk Server, are modeled on these high-level tasks.

Using Visual Studio

  1. Create BizTalk project, and generate schema. You must create a BizTalk project in Visual Studio, and generate schema for the operation that you will perform on Oracle E-Business Suite. For example, if you want to select records from an Oracle E-Business Suite interface table, you must generate schema for the Select operation for that table. To generate schema, you must use the Consume Adapter Service Add-in or Add Adapter Metadata Wizard. For more information, see Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio.

  2. Set up an orchestration. Once you have generated the schema, you must set up an orchestration by using the Orchestration Designer. For a basic orchestration, you add the Send and Receive shapes along with the Send and Receive logical ports. In later steps, you map these logical ports to physical ports by using the BizTalk Server Administration console. The orchestration uses these ports to pick messages that an adapter client sends. The orchestration then passes the messages to Oracle E-Business Suite. Once Oracle E-Business Suite sends a response, the orchestration passes the response back to the adapter client.

  3. Create messages, and link to schema. In your orchestration, you must create messages that will be mapped to the schema you generated in the first step. Typically, you create a request message and a response message. These messages are mapped to the corresponding request and response schemas.

  4. Map message shapes to messages and ports. In your orchestration, you must now map each shape that you added in the second step to messages that you created in the third step. You must also map a message shape to the port on which that message will be sent.

    For example, if the first shape in your orchestration is a Receive shape that will receive a message, you map this shape to a request message and the port that sends the request message.

  5. Build and deploy the BizTalk project. After you have set up the orchestration and mapped messages, ports, and schemas, you must build the BizTalk solution. For building a project in Visual Studio, you need an assembly key file. After you successfully build the solution, you must deploy the solution.

Note
More detailed description of these high-level tasks, including procedural information, is provided in various topics of this section.

Once you have successfully built and deployed the BizTalk project, your design-time tasks in Visual Studio are accomplished. You must now perform certain run-time tasks using the BizTalk Server Administration console.

Using the BizTalk Server Administration Console

  1. Configure the application. The BizTalk project you deployed by using Visual Studio shows up in the BizTalk Server Administration console as an orchestration. You must configure this orchestration by mapping the logical ports you created in Visual Studio to physical ports that you must now create using the BizTalk Server Administration console.

    On the physical ports, you must specify an "action" or "action mapping". This action corresponds to the operation you want to perform on Oracle E-Business Suite. You need to specify the action if you are not using dynamic actions. For more information about actions, see Specifying SOAP Action.

  2. Start the application. After the application is configured, you must start the application, and drop request messages at a defined file location. The orchestration consumes the request messages, passes them to Oracle E-Business Suite, and receives a response. This response is available to the adapter client at another defined file location.

To accomplish these high-level tasks, you must also perform other tasks. For example, when you use the Consume Adapter Service Add-in or Add Adapter Metadata Wizard to generate the schema, you must specify a connection URI to connect to Oracle E-Business Suite. This section provides information on such repetitive tasks that you must perform as you develop BizTalk applications using the Oracle E-Business adapter.

In This Section

  • Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console

  • Specifying the Connection URI

  • Specifying Credentials for the Oracle E-Business Suite

  • Specifying Binding Properties

  • Specifying SOAP Action

  • Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter

  • Configuring a Physical Port Binding Using a Port Binding File

  • Configuring Dynamic Ports

  • Reusing Adapter Bindings

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console

The Oracle E-Business adapter can be used in BizTalk Server either as a WCF-Custom port or a WCF-OracleEBS port. If you want to use the Oracle E-Business adapter through a WCF-Custom port, you do not need to add the WCF-Custom port to the BizTalk Server Administration console because the WCF-Custom port is added to the BizTalk Server Administration console by default. However, if you want to use the Oracle E-Business adapter through a WCF-OracleEBS port, you must first add the WCF-OracleEBS adapter to the BizTalk Server Administration console.

This topic provides instructions on how to add the WCF-OracleEBS adapter to the BizTalk Server Administration console.

Important
If you want to configure a WCF-Custom port for the Oracle E-Business adapter, you need not perform this procedure.

To add the Oracle E-Business Suite Adapter

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand the BizTalk Group, expand Platform Settings, and then click Adapters.

  3. Right-click Adapters, point to New, and click Adapter.

    Add an adapter

  4. In the Adapter Properties dialog box, specify a name for the adapter and from the Adapter list, select WCF-OracleEBS.

    Add WCF-OracleEBS adapter to BizTalk

  5. Click OK.

See Also

Tasks

Building Blocks for Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Specifying the Connection URI

A connection URI is a connection string that contains parameters required to connect to Oracle E-Business Suite. While using the Consume Adapter Service Add-in or Add Adapter Metadata Wizard in Visual Studio, you must specify the URI to connect to Oracle E-Business Suite to generate the metadata. While configuring an orchestration using the BizTalk Server Administration console, you must specify the URI to connect to Oracle E-Business Suite to perform operations.

Specifying the Connection URI from Visual Studio

From Visual Studio, you must specify the connection URI using the Consume Adapter Service Add-in or Add Adapter Metadata Wizard.

To specify the connection URI using Consume Adapter Service Add-in

  1. Right-click your BizTalk project, point to Add, and then click Add Generated Items.

  2. In the Add Generated Items dialog box, do the following:

    Use this To do this

    Categories

    Click Consume Adapter Service.

    Templates

    Click Consume Adapter Service.

  3. To start the Consume Adapter Service dialog box, click Add.

  4. In the Consume Adapter Service dialog box, from the Select a binding list, select oracleEBSBinding, and then click Configure.

  5. In the Configure Adapter dialog box, click the Security tab. From the Client credential type list, select Username and specify the user name and password to connect to the Oracle E-Business Suite.

    Use this To do this

    To connect using Oracle database credentials

    Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

    To connect using Oracle E-Business Suite credentials

    Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

    To connect using Windows Authentication if ClientCredentialType is set to “Database”

    Specify a “/” for the User name text box and leave the Password text box blank.

    To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

    Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

  6. Click the URI Properties tab, and specify values for different parameters. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

  7. Click the Binding Properties tab, and specify the binding values, if any, which are required before generating the schema. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

  8. Click OK.

To specify the connection URI using Add Adapter Metadata Wizard

  1. Right-click your BizTalk project, point to Add, and then click Add Generated Items.

  2. In the Add Generated Items dialog box, do the following:

    Use this To do this

    Categories

    Click Add Adapter.

    Templates

    Click Add Adapter Metadata.

  3. Click Add. The Add Adapter Metadata Wizard opens.

  4. In the Add Adapter Metadata Wizard, select WCF-OracleEBS. Select the computer on which BizTalk Server is installed and the name of the BizTalk database.

    Important
    If you already have a WCF-OracleEBS port configured in BizTalk, select the port from the Port list.

  5. Click Next.

  6. In the Consume Adapter Service dialog box, from the Select a binding list, select oracleEBSBinding, and then click Configure.

  7. In the Configure Adapter dialog box, click the Security tab. From the Client credential type list, select Username and specify the user name and password to connect to the Oracle E-Business Suite.

    Use this To do this

    To connect using Oracle database credentials

    Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

    To connect using Oracle E-Business Suite credentials

    Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

    To connect using Windows Authentication if ClientCredentialType is set to “Database”

    Specify a “/” for the User name text box and leave the Password text box blank.

    To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

    Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

  8. Click the URI Properties tab, and specify values for different parameters. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

  9. Click the Binding Properties tab, and specify the binding values, if any, which are required before generating the schema. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

    Note
    If you selected an existing WCF-OracleEBS send port, you need not specify the binding properties. The binding properties are picked from the send port configuration. However, you may choose to specify the binding properties that are required at design-time, if any. In such case, the new values for binding properties will be used at design-time while generating the metadata. However, at run-time the values specified for binding properties in the send port configuration will be applicable.

  10. Click OK.

Specifying the Connection URI from the BizTalk Server Administration Console

From the BizTalk Server Administration console, you must specify the connection URI as part of the WCF-Custom or WCF-OracleEBS port configuration.

To specify the connection URI for the WCF-Custom port

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, then expand Applications, and then expand the application under which you want to create a port, and click Send Ports or Receive Ports. In the right pane, you can choose to create a port or select an existing port.

  3. In the port properties dialog box, from the Type drop-down list, select WCF-Custom, and then click Configure.

    Note
    To see the location properties dialog box for a receive port, click the Receive Location tab on the left pane of the port properties dialog box, and then click New.

  4. In the WCF-Custom Transport Properties dialog box, click the General tab.

  5. In the Address (URI) text box, specify the connection URI to connect to Oracle E-Business Suite. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

  6. In the WCF-Custom Transport Properties dialog box, click the Binding tab. From the Binding Type drop-down list, select oracleEBSBinding.

  7. If you are creating a send port, in the WCF-Custom Transport Properties dialog box, click the Credentials tab, and do one of the following:

    • Select the Do not use Single Sign-On option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select the Use Single Sign-On option, and specify an affiliate Enterprise Single Sign-on (SSO) application.

  8. If you are creating a receive port, in the WCF-Custom Transport Properties dialog box, click the Other tab, and do one of the following:

    • Select User account option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select Get credentials from affiliate application option, and specify an affiliate SSO application.

  9. Click OK.

To specify the connection URI for the WCF-OracleEBS port

  1. Start the BizTalk Server Administration console.

  2. Add the WCF-OracleEBS adapter to the BizTalk Server Administration console. For instructions, see Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console.

  3. In the console tree, expand BizTalk Group, then expand Applications, and then expand the application under which you want to create a port, and click Send Ports or Receive Ports. In the right pane, you can choose to create a port or select an existing port.

  4. In the port properties dialog box, from the Type drop-down list, select the WCF-OracleEBS adapter you add earlier, and then click Configure.

    Note
    To see the location properties dialog box for a receive port, click the Receive Location tab on the left pane of the port properties dialog box, and then click New.

  5. In the transport properties dialog box, click the General tab.

  6. Click the Configure button and provide values for the connection parameters. For more information about the connection URI for the Oracle E-Business adapter, see The Oracle E-Business Suite Connection URI.

  7. In the transport properties dialog box, click the Binding tab and specify values for binding properties.

    Note
    The binding properties are displayed based on whether you are configuring a send port or a receive port. For example, binding properties related to notifications are not available while configuring a send port because notifications are inbound operations and require a receive port configuration.

  8. If you are creating a send port, in the transport properties dialog box, click the Credentials tab, and do one of the following:

    • Select the Do not use Single Sign-On option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select the Use Single Sign-On option, and specify an affiliate Enterprise Single Sign-on (SSO) application.

  9. If you are creating a receive port, in the transport properties dialog box, click the Other tab, and do one of the following:

    • Select User account option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select Get credentials from affiliate application option, and specify an affiliate SSO application.

  10. Click OK.

See Also

Tasks

Building Blocks for Developing BizTalk Applications

Concepts

Connecting to Oracle E-Business Suite Using Windows Authentication

© 2014 Microsoft Corporation. All rights reserved.


Specifying Credentials for the Oracle E-Business Suite

The Oracle E-Business adapter requires the adapter clients to provide client credentials. The adapter uses these credentials to authenticate the user with the Oracle E-Business Suite and to establish a connection.

Adapter clients can provide the client credentials both when using Visual Studio and when using the BizTalk Server Administration console. When using Visual Studio, credentials are required to generate the metadata. When using the BizTalk Server Administration console, credentials are required to perform operations on Oracle E-Business Suite.

Important
You can specify the credentials for the Oracle E-Business Suite or the underlying Oracle database. To connect and generate metadata you can specify any credentials. However, while performing an operation to invoke an Oracle E-Business Suite artifact, you must specify the Oracle E-Business Suite credentials because they are required to set the application context for the Oracle E-Business Suite application you want to invoke. For more information about setting applications context, see Setting Application Context.

This section provides information about specifying client credentials in Visual Studio and the BizTalk Server Administration console.

Specifying Credentials from Visual Studio

From Visual Studio, you must specify the credentials using the Consume Adapter Service Add-in or the Add Adapter Metadata Wizard.

To specify credentials using Consume Adapter Service Add-in

  1. Right-click your BizTalk project, and then select Add Generated Items.

  2. In the Add Generated Items dialog box, do the following:

    Use this To do this

    Categories

    Click Consume Adapter Service.

    Templates

    Click Consume Adapter Service.

  3. To start the Consume Adapter Service dialog box, click Add.

  4. In the Consume Adapter Service dialog box, from the Select a binding list, select oracleEBSBinding, and then click Configure.

  5. In the Configure Adapter dialog box, click the Security tab, and from the Client credential type list, select Username and specify the user name and password to connect to the Oracle E-Business Suite.

    Use this To do this

    To connect using Oracle database credentials

    Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

    To connect using Oracle E-Business Suite credentials

    Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

    To connect using Windows Authentication if ClientCredentialType is set to “Database”

    Specify a “/” for the User name text box and leave the Password text box blank.

    To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

    Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

  6. Click OK.

To specify credentials using Add Adapter Metadata Wizard

  1. Right-click your BizTalk project, point to Add, and then click Add Generated Items.

  2. In the Add Generated Items dialog box, do the following:

    Use this To do this

    Categories

    Click Add Adapter.

    Templates

    Click Add Adapter Metadata.

  3. Click Add. The Add Adapter Metadata Wizard opens.

  4. In the Add Adapter Metadata Wizard, select WCF-OracleEBS. Select the computer on which BizTalk Server is installed and the name of the BizTalk database.

    Important
    If you already have a WCF-OracleEBS port configured in BizTalk, select the port from the Port list.

  5. Click Next.

  6. In the Consume Adapter Service dialog box, from the Select a binding list, select oracleEBSBinding, and then click Configure.

  7. In the Configure Adapter dialog box, click the Security tab, and from the Client credential type list, select Username and specify the user name and password to connect to the Oracle E-Business Suite.

    Use this To do this

    To connect using Oracle database credentials

    Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

    To connect using Oracle E-Business Suite credentials

    Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

    To connect using Windows Authentication if ClientCredentialType is set to “Database”

    Specify a “/” for the User name text box and leave the Password text box blank.

    To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

    Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

  8. Click OK.

Specifying Credentials from the BizTalk Server Administration Console

From the BizTalk Server Administration console, you must specify the credentials as part of the WCF-Custom or WCF-OracleEBS port configuration.

To specify credentials for the WCF-Custom port

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, then expand Applications, and then expand the application under which you want to create a port, and click Send Ports or Receive Ports. In the right pane, you can choose to create a port or select an existing port.

  3. In the port properties dialog box, from the Type drop-down list, select WCF-Custom, and then click Configure.

    Note
    To see the location properties dialog box for a receive port, click the Receive Location tab on the left pane of the port properties dialog box, and then click New.

  4. In the WCF-Custom Transport Properties dialog box, click the Binding tab. From the Binding Type drop-down list, select oracleEBSBinding.

  5. If you are creating a send port, in the WCF-Custom Transport Properties dialog box, click the Credentials tab, and do one of the following:

    • Select the Do not use Single Sign-On option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select the Use Single Sign-On option, and specify an affiliate Enterprise Single Sign-on (SSO) application.

  6. If you are creating a receive port, in the WCF-Custom Transport Properties dialog box, click the Other tab, and do one of the following:

    • Select User account option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select Get credentials from affiliate application option, and specify an affiliate SSO application.

  7. Click OK.

To specify credentials for the WCF-OracleEBS port

  1. Start the BizTalk Server Administration console.

  2. Add the WCF-OracleEBS adapter to the BizTalk Server Administration console. For instructions, see Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console.

  3. In the console tree, expand BizTalk Group, then expand Applications, and then expand the application under which you want to create a port, and click Send Ports or Receive Ports. In the right pane, you can choose to create a port or select an existing port.

  4. In the port properties dialog box, from the Type drop-down list, select WCF-OracleEBS, and then click Configure.

    Note
    To see the location properties dialog box for a receive port, click the Receive Location tab on the left pane of the port properties dialog box, and then click New.

  5. In the port properties dialog box, click the Binding tab. From the Binding Type drop-down list, select oracleEBSBinding.

  6. If you are creating a send port, in the transport properties dialog box, click the Credentials tab, and do one of the following:

    • Select the Do not use Single Sign-On option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select the Use Single Sign-On option, and specify an affiliate Enterprise Single Sign-on (SSO) application.

  7. If you are creating a receive port, in the transport properties dialog box, click the Other tab, and do one of the following:

    • Select User account option, and specify the user name and password to connect to Oracle E-Business Suite.

      Use this To do this

      To connect using Oracle database credentials

      Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

      To connect using Oracle E-Business Suite credentials

      Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

      To connect using Windows Authentication if ClientCredentialType is set to “Database”

      Specify a “/” for the User name text box and leave the Password text box blank.

      To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

      Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

    • Select Get credentials from affiliate application option, and specify an affiliate SSO application.

  8. Click OK.

See Also

Tasks

Building Blocks for Developing BizTalk Applications

Concepts

Connecting to Oracle E-Business Suite Using Windows Authentication

© 2014 Microsoft Corporation. All rights reserved.


Specifying Binding Properties

The Oracle E-Business adapter surfaces several binding properties that enable you to control some of its behavioral characteristics. This section provides information about setting the binding properties from Visual Studio and from the BizTalk Server Administration console. From Visual Studio, you must specify the binding properties while generating schema for specific operations. From BizTalk Server, you must specify the binding properties as part of the send or receive port for sending or receiving messages from Oracle E-Business Suite.

For information about the binding properties, including a list of binding properties for the Oracle E-Business adapter, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

Specifying Binding Properties from Visual Studio

From Visual Studio, you must specify the binding properties using the Consume Adapter Service Add-in or the Add Adapter Metadata Wizard.

To specify binding properties using Consume Adapter Service Add-in

  1. Right-click your BizTalk project, and then select Add Generated Items.

  2. In the Add Generated Items dialog box, do the following:

    Use this To do this

    Categories

    Click Consume Adapter Service.

    Templates

    Click Consume Adapter Service.

  3. To start the Consume Adapter Service dialog box, click Add.

  4. In the Consume Adapter Service dialog box, from the Select a binding drop-down list, select oracleEBSBinding, and then click Configure.

  5. In the Configure Adapter dialog box, click the Binding Properties tab, and then specify the different binding properties.

  6. Click OK.

To specify binding properties using Add Adapter Metadata Wizard

  1. Right-click your BizTalk project, point to Add, and then click Add Generated Items.

  2. In the Add Generated Items dialog box, do the following:

    Use this To do this

    Categories

    Click Add Adapter.

    Templates

    Click Add Adapter Metadata.

  3. Click Add. The Add Adapter Metadata Wizard opens.

  4. In the Add Adapter Metadata Wizard, select WCF-OracleEBS. Select the computer on which BizTalk Server is installed and the name of the BizTalk database.

    Important
    If you already have a WCF-OracleEBS port configured in BizTalk, select the port from the Port list.

  5. Click Next.

  6. In the Consume Adapter Service dialog box, from the Select a binding list, select oracleEBSBinding, and then click Configure.

  7. Click the Binding Properties tab, and specify the binding values, if any, which are required before generating the schema. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

    Note
    If you selected an existing WCF-OracleEBS send port, you need not specify the binding properties. The binding properties are picked from the send port configuration. However, you may choose to specify the binding properties that are required at design-time, if any. In such a case, the new values for binding properties will be used at design-time while generating the metadata. However, at run-time the values specified for binding properties in the send port configuration will be applicable.

  8. Click OK.

Specifying Binding Properties from the BizTalk Server Administration Console

From the BizTalk Server Administration console, you must specify the binding properties as part of the WCF-Custom or WCF-OracleEBS port configuration.

To specify binding properties for the WCF-Custom port

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, then expand Applications, and then expand the application under which you want to create a port, and click Send Ports or Receive Ports. In the right pane, you can choose to create a port or select an existing port.

  3. In the port properties dialog box, from the Type drop-down list, select WCF-Custom, and then click Configure.

    Note
    To see the location properties dialog box for a receive port, click the Receive Location tab on the left pane of the port properties dialog box, and then click New.

  4. In the WCF-Custom Transport Properties dialog box, click the Binding tab.

  5. From the Binding Type list, select oracleEBSBinding.

  6. In the Configuration box, specify the values for the different binding properties, and then click OK.

To specify binding properties for the WCF-OracleEBS port

  1. Start the BizTalk Server Administration console.

  2. Add the WCF-OracleEBS adapter to the BizTalk Server Administration console. For instructions, see Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console.

  3. In the console tree, expand BizTalk Group, then expand Applications, and then expand the application under which you want to create a port, and click Send Ports or Receive Ports. In the right pane, you can choose to create a port or select an existing port.

  4. In the port properties dialog box, from the Type drop-down list, select the WCF-OracleEBS adapter you added earlier, and then click Configure.

    Note
    To see the location properties dialog box for a receive port, click the Receive Location tab on the left pane of the port properties dialog box, and then click New.

  5. In the transport properties dialog box, click the Binding tab and specify values for binding properties.

    Note
    The binding properties are displayed based on whether you are configuring a send port or a receive port. For example, binding properties related to notifications are not available while configuring a send port because notifications are inbound operations and require a receive port configuration.

See Also

Tasks

Building Blocks for Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Specifying SOAP Action

To perform any operation on Oracle E-Business Suite using the WCF-based Oracle E-Business adapter, you must specify a SOAP action. The SOAP action communicates to the adapter what action should be performed. You can specify the SOAP action either from Visual Studio or from the BizTalk Server Administration console. However, if you specify the SOAP action from both locations, the action you specified from Visual Studio will be overridden.

For more information about specifying SOAP action, see http://go.microsoft.com/fwlink/?LinkId=102063.

Specifying SOAP Action from Visual Studio

From Visual Studio, you must specify the SOAP action as part of the orchestration by using an Expression shape.

To specify SOAP action from Visual Studio

  1. In the BizTalk orchestration, include an Expression shape by dragging it from the BizTalk Orchestration toolbox.

  2. Double-click the Expression shape to open BizTalk Expression Editor.

  3. Specify the action in BizTalk Expression Editor. For example:

    Copy Code
    OutboundMessage(WCF.Action)="InterfaceTables/Insert/SQLGL/GL/GL_ALLOC_HISTORY"

    For more information about the Expression shape and BizTalk Expression Editor, see http://go.microsoft.com/fwlink/?LinkId=102064.

Specifying SOAP Action from the BizTalk Server Administration Console

From the BizTalk Server Administration console, you must specify the SOAP action as part of the WCF-Custom or WCF-OracleEBS port configuration.

To specify a SOAP action for the WCF-Custom port

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, then expand Applications, and then click Send Ports. In the right pane, you can choose to create a port or select an existing port.

  3. In the port properties dialog box, from the Type drop-down list, select WCF-Custom, and then click Configure.

  4. In the WCF-Custom Transport Properties dialog box, click the General tab.

  5. In the Action text box, specify the SOAP action for the operation. You can specify the action in the following ways:

    • By using the single action format. Use this format if the WCF-Custom port sends and receive messages for a single operation. For example:

      Copy Code
      InterfaceTables/Insert/SQLGL/GL/GL_ALLOC_HISTORY
    • By using the action mapping format. Use this format if a single WCF-Custom port sends and receives messages for more than one operation. For example, if a single WCF-Custom port sends and receives messages for Op1 (to insert records in the GL_ALLOC_HISTORY table) and Op2 (to update records in the GL_ALLOC_HISTORY table), the SOAP action can be specified in the following manner:

      Copy Code
      <BtsActionMapping>
  <Operation Name="Op1" Action="InterfaceTables/Insert/SQLGL/GL/GL_ALLOC_HISTORY" />
  <Operation Name="Op2" Action="InterfaceTables/Update/SQLGL/GL/GL_ALLOC_HISTORY " />
</BtsActionMapping>
      The action mapping approach provides greater flexibility in terms of specifying a set of actions, and hence enabling messages that belong to different action types to flow through the same port.

      The format for the SOAP action is different for each operation. For more information about the action format for each operation, see individual topics under Technical Reference.

To specify a SOAP action for the WCF-OracleEBS port

  1. Start the BizTalk Server Administration console.

  2. Add the WCF-OracleEBS adapter to the BizTalk Server Administration console. For instructions, see Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console.

  3. In the console tree, expand BizTalk Group, then expand Applications, and then click Send Ports. In the right pane, you can choose to create a port or select an existing port.

  4. In the port properties dialog box, from the Type drop-down list, select the WCF-OracleEBS adapter you add earlier, and then click Configure.

  5. In the transport properties dialog box, click the General tab.

  6. In the Action text box, specify the SOAP action for the operation. You can specify the action in the following ways:

    • By using the single action format. Use this format if the WCF-OracleEBS port sends and receive messages for a single operation. For example:

      Copy Code
      InterfaceTables/Insert/SQLGL/GL/GL_ALLOC_HISTORY
    • By using the action mapping format. Use this format if a single WCF-OracleEBS port sends and receives messages for more than one operation. For example, if a single WCF-OracleEBS port sends and receives messages for Op1 (to insert records in the GL_ALLOC_HISTORY table) and Op2 (to update records in the GL_ALLOC_HISTORY table), the SOAP action can be specified in the following manner:

      Copy Code
      <BtsActionMapping>
  <Operation Name="Op1" Action="InterfaceTables/Insert/SQLGL/GL/GL_ALLOC_HISTORY" />
  <Operation Name="Op2" Action="InterfaceTables/Update/SQLGL/GL/GL_ALLOC_HISTORY " />
</BtsActionMapping>
      The action mapping approach provides greater flexibility in terms of specifying a set of actions, and hence enabling messages that belong to different action types to flow through the same port.

      The format for the SOAP action is different for each operation. For more information about the action format for each operation, see individual topics under Technical Reference.

See Also

Tasks

Building Blocks for Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter

This section provides information about configuring the Microsoft BizTalk Adapter for Oracle E-Business Suite as a WCF custom binding or as a WCF-OracleEBS port by using the BizTalk Server Administration console. After deploying the adapter, you will be able to send and receive messages from Oracle E-Business Suite by using the BizTalk Server Administration console. The steps for deploying the adapter vary depending on:

  • The direction of communication between BizTalk Server and the Oracle E-Business adapter. You may choose to configure a send, receive, send-receive, or a receive-send port. Your choices are summarized in the following table.

    Port direction Communication pattern Direction of communication to choose from

    Send

    One-way

    I will always be sending messages on this port.

    Receive

    One-way

    I will always be receiving messages on this port.

    Send-receive

    Request-response

    I will be sending a request and receiving a response.

    Receive-send

    Solicit-response

    I will be receiving a request and sending a response.

    For more information, see the BizTalk Server Help documentation at http://go.microsoft.com/fwlink/?LinkID=101130.

  • Whether the adapter sends messages to or receives messages from Oracle E-Business Suite. Depending on whether you want to send or receive messages, you will create a send or receive port, respectively.

    Note
    You can also configure the send or receive ports by importing a binding configuration file that is created by the Consume Adapter Service Add-in as part of metadata generation. For instructions on configuring ports using this binding file, see Configuring a Physical Port Binding Using a Port Binding File.

In This Section

  • Configuring a Port Using the WCF-Custom Adapter

  • Configuring a Port Using the WCF-OracleEBS Adapter

See Also

Tasks

Building Blocks for Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Configuring a Port Using the WCF-Custom Adapter

This topic provides instructions on how to configure WCF-Custom send and receive ports to perform outbound and inbound operations on Oracle E-Business Suite using the Oracle E-Business adapter.

Prerequisites

To perform the procedures in this topic, you must be logged on with an account that is a member of the BizTalk Server Administrators or BizTalk Operators group. For more detailed information about permissions, see the BizTalk Server Help documentation at http://go.microsoft.com/fwlink/?LinkID=101130.

Deploying Adapters for Sending Messages to Oracle E-Business Suite

Perform the following steps to configure a WCF-Custom send port for sending messages to Oracle E-Business Suite using the BizTalk Server Administration console.

To deploy adapters for sending messages to Oracle E-Business Suite

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, and then expand Applications.

  3. Expand the application under which you want to deploy the Oracle E-Business adapter.

  4. Right-click Send Ports, point to New, and then point to the type of port you want to configure depending on the mode of communication between BizTalk Server and Oracle E-Business Suite.

  5. In the Send Port Properties dialog box, on the General tab, type a name for the send port.

  6. From the Type drop-down list, select WCF-Custom, and then click Configure.

  7. In the WCF-Custom Transport Properties dialog box, do the following:

    1. Click the General tab, and in the Address (URI) field, specify the connection URI for Oracle E-Business Suite. For more information about the connection URI, see The Oracle E-Business Suite Connection URI.

    2. On the General tab, in the Action text box, type the action for the operation. See individual topics in Technical Reference for a list of actions for each operation. For example, the action to invoke the Insert operation on an interface table (FA_BOOKS) under the Asset application is:

      Copy Code
      InterfaceTables/Insert/OFA/FA/FA_BOOKS
    3. Click the Binding tab, and from the Binding Type list, select oracleEBSBinding. You can specify the different binding properties exposed by the Oracle E-Business adapter. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

    4. Click the Credentials tab, and then do one of the following:

      • Select the Do not use Single Sign-On option, and specify the user name and password to connect to Oracle E-Business Suite.

        Use this To do this

        To connect using Oracle database credentials

        Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

        To connect using Oracle E-Business Suite credentials

        Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

        To connect using Windows Authentication if ClientCredentialType is set to “Database”

        Specify a “/” for the User name text box and leave the Password text box blank.

        To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

        Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

      • Select the Use Single Sign-On option, and specify an affiliate Enterprise Single Sign-on (SSO) application.

    5. To return to the Send Port Properties dialog box, click OK.

  8. From the Send handler list, select BizTalkServerApplication.

  9. If you chose Static One-Way Send Port in step 4, specify a send pipeline. From the Send pipeline list, select the pipeline that corresponds to XMLTransmit.

  10. If you chose Static Solicit-Response Port in step 4, specify send and receive pipelines.

    1. From the Send pipeline drop-down list, select the pipeline that corresponds to XMLTransmit.

    2. From the Receive pipeline drop-down list, select the pipeline that corresponds to XMLReceive.

  11. Click OK.

Deploying Adapters for Receiving Messages from Oracle E-Business Suite

Perform the following steps to configure a WCF-Custom receive port for receiving messages from Oracle E-Business Suite using the BizTalk Server Administration console.

To deploy adapters for receiving messages from Oracle E-Business Suite

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, and then expand Applications.

  3. Expand the application under which you want to deploy the Oracle E-Business adapter.

  4. Right-click Receive Ports, point to New, and click One-way Receive Port or Request Response Receive Port, depending on the mode of communication between BizTalk Server and Oracle E-Business Suite.

  5. In the Receive Port Properties dialog box, on the General tab, type a name for the receive port.

  6. On the Receive Locations tab, click New. The Receive Location Properties dialog box appears.

  7. In the Receive Location Properties dialog box, do the following:

    1. Specify a name for the receive location.

    2. From the Type drop-down list, select WCF-Custom, and then click Configure.

  8. In the WCF-Custom Transport Properties dialog box, do the following:

    1. Click the General tab, and in the Address (URI) field, specify the connection URI for Oracle E-Business Suite. For more information about the connection URI, see The Oracle E-Business Suite Connection URI.

    2. Click the Binding tab, and from the Binding Type drop-down list, select oracleEBSBinding. You can specify the different binding properties exposed by the Oracle E-Business adapter. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

    3. Click the Behavior tab to set the transaction isolation level. For more information about setting transaction isolation level, see Configure Transaction Isolation Level and Transaction Timeout.

    4. Click the Others tab, and do one of the following:

      • Select User account option, and specify the user name and password to connect to Oracle E-Business Suite.

        Use this To do this

        To connect using Oracle database credentials

        Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

        To connect using Oracle E-Business Suite credentials

        Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

        To connect using Windows Authentication if ClientCredentialType is set to “Database”

        Specify a “/” for the User name text box and leave the Password text box blank.

        To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

        Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

      • Select Get credentials from affiliate application option, and specify an affiliate SSO application.

    5. To return to the Receive Location Properties dialog box, click OK.

  9. From the Receive handler drop-down list, select BizTalkServerApplication.

  10. If you chose One-way Receive Port in step 4, specify a receive pipeline. From the Receive pipeline list, select the pipeline corresponding to XMLReceive.

  11. If you chose Request Response Receive Port in step 4, specify send and receive pipelines.

    1. From the Receive pipeline drop-down list, select the pipeline that corresponds to XMLReceive.

    2. From the Send pipeline drop-down list, select the pipeline that corresponds to XMLTransmit.

  12. In the Receive Location Properties dialog box, click OK.

  13. In the Receive Port Properties dialog box, click OK.

See Also

Concepts

Connecting to Oracle E-Business Suite Using Windows Authentication

Other Resources

Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter

© 2014 Microsoft Corporation. All rights reserved.


Configuring a Port Using the WCF-OracleEBS Adapter

This topic provides instructions on how to configure WCF-OracleEBS send and receive ports to perform outbound and inbound operations on Oracle E-Business Suite using the Oracle E-Business adapter.

Prerequisites

To perform the procedures in this topic, you must be logged on with an account that is a member of the BizTalk Server Administrators or BizTalk Operators group. For more detailed information about permissions, see the BizTalk Server Help documentation at http://go.microsoft.com/fwlink/?LinkID=101130.

Deploying Adapters for Sending Messages to Oracle E-Business Suite

Perform the following steps to configure a WCF-OracleEBS send port for sending messages to Oracle E-Business Suite using the BizTalk Server Administration console.

To deploy adapters for sending messages to Oracle E-Business Suite

  1. Start the BizTalk Server Administration console.

  2. Add the WCF-OracleEBS adapter to the BizTalk Server Administration console. For instructions, see Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console.

  3. In the console tree, expand BizTalk Group, and then expand Applications.

  4. Expand the application under which you want to deploy the Oracle E-Business adapter.

  5. Right-click Send Ports, point to New, and then point to the type of port you want to configure depending on the mode of communication between BizTalk Server and Oracle E-Business Suite.

  6. In the Send Port Properties dialog box, on the General tab, type a name for the send port.

  7. From the Type drop-down list, select WCF-OracleEBS, and then click Configure.

  8. In the transport properties dialog box, do the following:

    1. Click the General tab, click the Configure button and provide values for the connection parameters. For more information about the connection URI, see The Oracle E-Business Suite Connection URI.

    2. On the General tab, in the Action text box, type the action for the operation. See individual topics in Technical Reference for a list of actions for each operation. For example, the action to invoke the Insert operation on an interface table (FA_BOOKS) under the Asset application is:

      Copy Code
      InterfaceTables/Insert/OFA/FA/FA_BOOKS
    3. Click the Binding tab and specify values for the binding properties exposed by the Oracle E-Business adapter. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

      Note
      The binding properties are displayed based on whether you are configuring a send port or a receive port. For example, binding properties related to notifications are not available while configuring a send port because notifications are inbound operations and require a receive port configuration.

    4. Click the Credentials tab, and then do one of the following:

      • Select the Do not use Single Sign-On option, and specify the user name and password to connect to Oracle E-Business Suite.

        Use this To do this

        To connect using Oracle database credentials

        Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

        To connect using Oracle E-Business Suite credentials

        Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

        To connect using Windows Authentication if ClientCredentialType is set to “Database”

        Specify a “/” for the User name text box and leave the Password text box blank.

        To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

        Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

      • Select the Use Single Sign-On option, and specify an affiliate Enterprise Single Sign-on (SSO) application.

    5. To return to the Send Port Properties dialog box, click OK.

  9. From the Send handler list, select BizTalkServerApplication.

  10. If you chose Static One-Way Send Port in step 5, specify a send pipeline. From the Send pipeline list, select the pipeline that corresponds to XMLTransmit.

  11. If you chose Static Solicit-Response Port in step 4, specify send and receive pipelines.

    1. From the Send pipeline drop-down list, select the pipeline that corresponds to XMLTransmit.

    2. From the Receive pipeline drop-down list, select the pipeline that corresponds to XMLReceive.

  12. Click OK.

Deploying Adapters for Receiving Messages from Oracle E-Business Suite

Perform the following steps to configure a WCF-OracleEBS receive port for receiving messages from Oracle E-Business Suite using the BizTalk Server Administration console.

To deploy adapters for receiving messages from Oracle E-Business Suite

  1. Start the BizTalk Server Administration console.

  2. Add the WCF-OracleEBS adapter to the BizTalk Server Administration console. For instructions, see Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console.

  3. In the console tree, expand BizTalk Group, and then expand Applications.

  4. Expand the application under which you want to deploy the Oracle E-Business adapter.

  5. Right-click Receive Ports, point to New, and click One-way Receive Port or Request Response Receive Port, depending on the mode of communication between BizTalk Server and Oracle E-Business Suite.

  6. In the Receive Port Properties dialog box, on the General tab, type a name for the receive port.

  7. On the Receive Locations tab, click New. The Receive Location Properties dialog box appears.

  8. In the Receive Location Properties dialog box, do the following:

    1. Specify a name for the receive location.

    2. From the Type drop-down list, select WCF-OracleEBS, and then click Configure.

  9. In the transport properties dialog box, do the following:

    1. Click the General tab, click the Configure button, and provide values for the connection parameters. For more information about the connection URI, see The Oracle E-Business Suite Connection URI.

    2. Click the Binding tab and specify values for binding properties exposed by the Oracle E-Business adapter. For more information about binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

      Note
      The binding properties are displayed based on whether you are configuring a send port or a receive port. For example, binding properties related to notifications are not available while configuring a send port because notifications are inbound operations and require a receive port configuration.

    3. Click the Behavior tab to set the transaction isolation level. For more information about setting transaction isolation level, see Configure Transaction Isolation Level and Transaction Timeout.

    4. Click the Others tab, and do one of the following:

      • Select User account option, and specify the user name and password to connect to Oracle E-Business Suite.

        Use this To do this

        To connect using Oracle database credentials

        Specify the ClientCredentialType binding property to Database and specify database credentials for User name and Password text boxes.

        To connect using Oracle E-Business Suite credentials

        Specify the ClientCredentialType binding property to EBusiness and specify Oracle E-Business Suite credentials for User name and Password text boxes. In this case, you must also specify Oracle database credentials for OracleUserName and OraclePassword binding properties.

        To connect using Windows Authentication if ClientCredentialType is set to “Database”

        Specify a “/” for the User name text box and leave the Password text box blank.

        To connect using Windows Authentication if ClientCredentialType is set to “EBusiness”

        Specify Oracle E-Business Suite credentials for User name and Password text boxes. You must also specify a “/” for the OracleUserName binding property and leave the OraclePassword binding property blank.

      • Select Get credentials from affiliate application option, and specify an affiliate SSO application.

    5. To return to the Receive Location Properties dialog box, click OK.

  10. From the Receive handler drop-down list, select BizTalkServerApplication.

  11. If you chose One-way Receive Port in step 5, specify a receive pipeline. From the Receive pipeline list, select the pipeline corresponding to XMLReceive.

  12. If you chose Request Response Receive Port in step 5, specify send and receive pipelines.

    1. From the Receive pipeline drop-down list, select the pipeline that corresponds to XMLReceive.

    2. From the Send pipeline drop-down list, select the pipeline that corresponds to XMLTransmit.

  13. In the Receive Location Properties dialog box, click OK.

  14. In the Receive Port Properties dialog box, click OK.

See Also

Concepts

Connecting to Oracle E-Business Suite Using Windows Authentication

Other Resources

Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter

© 2014 Microsoft Corporation. All rights reserved.


Configuring a Physical Port Binding Using a Port Binding File

When you use the Consume Adapter Service BizTalk Project Add-in to generate metadata for Oracle E-Business Suite artifacts, other than the schema files, the Consume Adapter Service Add-in also generates a port binding file. You can import this binding file into your BizTalk application to create a physical send or receive port. For instructions on importing binding files, see Importing Bindings. If you import this binding file, you do not have to manually create a physical send or receive port.

Important
While using the Consume Adapter Service BizTalk Project Add-in, if you do not specify a value for a binding property of type string and whose default value is null then that binding property will not be available in the binding file. You must manually add the binding property and its value in the binding file, if required.

Creating a port using the port binding file always creates a two-way send port or a one-way receive port. If you want to create a one-way send port, you can create it manually by following the procedure mentioned in Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter. Or you can follow the workarounds documented in this topic to modify the port binding file to create one-way send ports.

Note
For inbound operations, the port binding file will always create a one-way receive port. This is because the Oracle E-Business adapter only supports one-way receive port for inbound operations.

Important
Using the Add Adapter Metadata Wizard does not create a port binding file using which you can create a WCF-OracleEBS port. However, you could make some changes to the port binding file generated by the Consume Adapter Service Add-in and use it to create a WCF-OracleEBS port. For more information, see Configuring a WCF-OracleEBS Port Using the Port Binding File Generated Using Consume Adapter Service Add-in.

Following are some key points that you must understand with respect to the binding file that the Consume Adapter Service Add-in generates:

  • The files are created with a specific naming convention. If you generated metadata for outbound operations, that is, to send messages to Oracle E-Business Suite, the name of the file is WcfSendPort_OracleEBSBinding_Custom.bindinginfo.xml.

    If you generated metadata for inbound operations, that is, to receive messages from Oracle E-Business Suite, the name of the file is WcfReceivePort_OracleEBSBinding_Custom.bindinginfo.xml.

  • The file contains information about the binding configuration, the binding type, the endpoint URI, and the port action based on the operations for which metadata was generated. When you import this binding file into your BizTalk application to create a port, all the relevant information required to configure a physical port is automatically set on the port.

    Important
    By default, the action on the send port is mapped to the operation name for which you generated metadata. For example, if you generate metadata for the Insert operation on the interface table (e.g. FA_BOOKS), the action on the port is set to <Operation Name="Insert" Action="InterfaceTables/Insert/OFA/FA/FA_BOOKS" />. However, the operation name on the logical send port you create in the BizTalk orchestration might not be the same. You must ensure that the operation name in the logical send port (in the BizTalk orchestration) and the physical send port (in BizTalk Server Administration console) are the same. If not, you will receive an error while sending messages to Oracle E-Business Suite through the send port.

  • You only need to provide the credentials for the port to connect to Oracle E-Business Suite. Although the binding file does retain the user name with which to connect, for security reasons the binding file does not contain the password.

Key Considerations for Using the Port Binding File

  • When you import the binding file, you might get a dialog message informing that the BizTalk application name in the binding file does not match the application name to which you are importing the binding file. You can safely ignore this message and continue.

  • The binding file also contains names of ports and receive locations. If the BizTalk application to which you are importing the binding file creates a port or a receive location that has the same name as an already existing port in the same BizTalk application, you will get an error. You must manually edit the binding file to specify a unique name for the ports or receive locations.

  • The binding file also contains information about the connection URI. If the binding file creates a receive location that has the same receive URI as an already existing receive location in the same BizTalk application, you will get an error. You must manually edit the binding file to specify a unique URI.

  • By default, the port binding file for outbound operations always contains definitions for a two-way send port. When you import this file in a BizTalk application, it creates a two-way send port. However, you may have an orchestration that has a one-way send port. So, when you configure such an orchestration and use the port created by importing the binding file, the port is not available in the list. This happens because the logical port you created as part of the orchestration is a one-way port while the physical port created in the orchestration is a two-way port. In such cases, you can edit the binding file to make the following changes:

    For this Do this

    To edit the port binding file to configure a one-way send port

    1. In the following excerpt, change the value of the IsTwoWay property to false. Originally, this is set to true.

      Copy Code
      <SendPort Name="port_name" IsStatic="true" IsTwoWay="false" BindingOption="0">
    2. Comment out the following excerpts:

      Copy Code
      <ReceivePipeline Name="Microsoft.BizTalk.DefaultPipelines.XMLReceive"
  FullyQualifiedName="Microsoft.BizTalk.DefaultPipelines.XMLReceive,
  Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral,
  PublicKeyToken=token" Type="1" TrackingOption="None" Description=""/>
      Copy Code
      <ReceivePipelineData xsi:nil="true" />

    Important
    For inbound operations, the port binding file will always create a one-way receive port. This is because the Oracle E-Business adapter only supports one-way receive port for inbound operations.

Configuring a WCF-OracleEBS Port Using the Port Binding File Generated Using Consume Adapter Service Add-in

The Consume Adapter Service Add-in creates a port binding file that you can import in BizTalk Server Administration console. You can use the same port binding file to also create the BizTalk WCF-OracleEBS port in BizTalk Server Administration console. However, before creating WCF-OracleEBS port you must perform the following tasks to modify the port binding file.

  1. Open the port binding file in a text editor.

  2. Search and replace “WCF-Custom” with the name with which you added the WCF-OracleEBS adapter in BizTalk Server Administration console. For example, if you added the WCF-OracleEBS adapter as “OracleEBSAdapter”, replace “WCF-Custom” with “OracleEBSAdapter”.

  3. Search for the “ConfigurationClsid” attribute, and replace the existing value of the attribute with “F452BB15-7A0D-495d-9395-C630D3FD29CD”.

  4. Save and close the binding file.

  5. Import the binding file in BizTalk Server Administration console. For instructions on how to import the binding file, see Importing Bindings.

See Also

Tasks

Building Blocks for Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Configuring Dynamic Ports

In BizTalk Server, you can configure dynamic ports for a WCF-Custom adapter. Because the Oracle E-Business adapter is a WCF-based adapter, you can dynamically configure a port for the Oracle E-Business adapter by using message context properties.

For the Oracle E-Business adapter, the URI, action, and binding may be determined from a property on an incoming message, and then specified in the Expression shape, as shown in the following example:

Copy Code
Request2=Request1;
Request2(WCF.Action)="InterfaceTables/Insert/OFA/FA/FA_BOOKS";
Request2(WCF.BindingType)="oracleEBSBinding";
Request2(WCF.UserName)="myuser";
Request2(WCF.Password)="mypass";
SendPort(Microsoft.XLANGs.BaseTypes.Address)="oracleebs://ebs_instance";
SendPort(Microsoft.XLANGs.BaseTypes.TransportType)="WCF-Custom";
Note
If you are using a WCF-OracleEBS adapter in BizTalk Server Administration console, you can also specify the transport type as SendPort(Microsoft.XLANGs.BaseTypes.TransportType)="OracleEBSAdapter", where OracleEBSAdapter is the name with which you added the WCF-OracleEBS adapter in BizTalk Server Administration console.

In the preceding example,

  • Request2 message is being created from Request1 message. Both messages map to an operation schema, which is generated using the Consume Adapter Service Add-in.

  • SendPort is the name of the logical send port in the BizTalk orchestration.

The Expression shape is part of the BizTalk orchestration. Deploying the orchestration also creates a WCF-Custom send port.

For more information about configuring dynamic ports, see “Configuring Dynamic Send Ports Using WCF Adapters Context Properties” at http://go.microsoft.com/fwlink/?LinkId=106735.

See Also

Tasks

Building Blocks for Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Reusing Adapter Bindings

A binding creates a mapping between a logical endpoint (such as an orchestration port or a role link) and a physical endpoint (such as a send and receive port). This enables communication between different components of a BizTalk Server business solution. You can create bindings by using the BizTalk Server Administration console.

What is a Binding File?

A binding file is an XML file that contains binding information for each BizTalk orchestration in the scope of a BizTalk assembly, application, or group. The binding file describes:

  • The host to which each orchestration is bound.

  • The trust level of the host.

  • The settings for each send port, receive port, receive location, and party that has been configured.

You can generate binding files and then apply the bindings that they contain to an assembly, application, or group. This prevents having to manually configure bindings in different deployment environments and speeds up application deployment.

A binding file is not automatically generated for a BizTalk assembly, application, or group. However, you can generate a binding file by exporting bindings. Similarly, you can then import the binding file into an application or group. This section provides instructions on how to import and export bindings.

For more information about bindings and about binding files, see the BizTalk Server Help documentation at http://go.microsoft.com/fwlink/?LinkID=101130.

In This Section

  • Exporting Bindings

  • Importing Bindings

See Also

Tasks

Building Blocks for Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Exporting Bindings

This section describes how to export bindings for a BizTalk application into an XML file. You can then import the bindings from the XML file into another BizTalk application. Importing bindings overwrites any existing bindings of the same name in the application. You can also add bindings to an application, which does not overwrite existing bindings. The bindings that you add do not take effect until you import the application.

Prerequisites

To perform the procedures in this topic, you must be logged on with an account that is a member of the BizTalk Server Administrators or BizTalk Operators group. For more detailed information about permissions, see the BizTalk Server Help documentation at http://go.microsoft.com/fwlink/?LinkID=101130.

To export bindings using the BizTalk Server Administration console

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, and then expand Applications.

  3. Right-click the application whose bindings you want to export, point to Export, and then click Bindings.

  4. On the Export Bindings page, in Export to file, type the absolute path of the XML file to which to export the bindings.

    Example: C:\Bindings\Application1Bindings.xml.

  5. Ensure that Export all bindings from the current application is selected.

  6. To export all party information for the group, select the Export Global Party information check box.

  7. Click OK.

    The bindings are exported into an XML file in the location that you specified.

Note
For security reasons, when you export a binding file, BizTalk Server removes the passwords for the bindings from the file. After importing the bindings, you must reconfigure passwords for send ports and receive locations before they will function. You configure passwords in the Transport Properties dialog box of the BizTalk Server Administration console for the send port or receive location. For information about specifying user name and passwords, see Specifying Credentials for the Oracle E-Business Suite.

See Also

Concepts

Reusing Adapter Bindings

© 2014 Microsoft Corporation. All rights reserved.


Importing Bindings

This topic describes how to use the BizTalk Server Administration console to import bindings into a BizTalk application from an XML file.

Prerequisites

To perform the procedures in this topic, you must be logged on with an account that is a member of the BizTalk Server Administrators or BizTalk Operators group. For more detailed information about permissions, see the BizTalk Server Help documentation at http://go.microsoft.com/fwlink/?LinkID=101130.

To import bindings using the BizTalk Server Administration console

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand BizTalk Group, and then expand Applications.

  3. Right-click the application into which you want to import bindings, point to Import, and then click Bindings.

  4. Click the binding file, and then click Open.

    The artifacts in the binding file are written to the application. They are displayed in appropriate folders of the application. For example, the send ports that are imported as part of the bindings are displayed under the Send Ports folder.

Note
For security reasons, when you export a binding file, BizTalk Server removes the passwords for the bindings from the file. After importing the bindings, you must reconfigure passwords for send ports and receive locations before they will function. You configure passwords in the Transport Properties dialog box of the BizTalk Server Administration console for the send port or receive location. For information about specifying user name and passwords, see Specifying Credentials for the Oracle E-Business Suite.

See Also

Concepts

Reusing Adapter Bindings

© 2014 Microsoft Corporation. All rights reserved.


Performing Insert, Update, Delete, or Select Operations on Interface Tables and Interface Views Using BizTalk Server

The Oracle E-Business adapter surfaces a set of standard operations such as Insert, Update, Delete, Select on interface tables and views. This topic provides instructions on how to perform these operations using the adapter. For more information about how the adapter supports these operations, see Operations on Interface Tables and Interface Views. For information about the structure of the SOAP message for these operations, see Message Schemas for Insert, Update, Delete, and Select Operations.

Note
The adapter also exposes specific operations for tables and views that contain large data types such as BLOB, CLOB, NCLOB, and BFILE. For more information about such operations, see Operations on Interface Tables, Interface Views, Tables, and Views That Contain LOB Data. For instructions on how to perform operations on tables and columns with large data types using BizTalk Server, see Performing Operations on Tables with Large Data Types Using BizTalk Server.

How to Perform Basic Operations on Oracle E-Business Suite

Performing an operation on Oracle E-Business Suite by using Oracle E-Business adapter with BizTalk Server involves procedural tasks described in Building Blocks for Developing BizTalk Applications. To perform Insert, Update, Delete, or Select operations on tables and views in Oracle E-Business Suite, these tasks are:

  1. Create a BizTalk project, and generate schema for the operation you want to invoke on an interface table or view.

  2. Create messages in the BizTalk project for sending and receiving messages from the Oracle E-Business Suite.

  3. Create an orchestration to invoke the operation on the interface table or view.

  4. Build and deploy the BizTalk project.

  5. Configure the BizTalk application by creating physical send and receive ports.

  6. Start the BizTalk application.

This topic provides instructions to perform these tasks.

Generating Schema

This topic demonstrates how to perform basic Insert, Update, Delete, or Select operations by inserting records in the AR_ARCHIVE_PURGE_INTERIM interface table in Oracle E-Business Suite. This interface table is available in the Receivables application in the Oracle E-Business Suite.

To demonstrate how to insert records, schema is generated for the Insert operation for the AR_ARCHIVE_PURGE_INTERIM table. You must create a BizTalk project and use the Consume Adapter Service Add-in to generate the schema. See Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio for more information about how to generate schemas.

Defining Messages and Message Types

The schema that you generated earlier describes the “types” required for the messages in the orchestration. A message is typically a variable, the type for which defined by the corresponding schema. You must now create messages for the orchestration and link them to schemas you generated in the previous step.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration, and then click Add.

  2. Open the Orchestration View window of the BizTalk project, if it is not already open. To do so, click View, point to Other Windows, and then click Orchestration View.

  3. In Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for the Message_1, do the following:

    Use this To do this

    Identifier

    Type Request

    Message Type

    From the drop-down list, expand Schemas, and then select InsertInterfaceTable.OracleEBSBinding.Insert, where InsertInterfaceTable is the name of your BizTalk project. OracleEBSBinding is the schema generated for the Insert operation on the AR_ARCHIVE_PURGE_INTERIM table.

  6. Repeat step 2 to create a new message. In the Properties pane for the new message, do the following:

    Use this To do this

    Identifier

    Type Response

    Message Type

    From the drop-down list, expand Schemas, and then select InsertInterfaceTable.OracleEBSBinding.InsertResponse.

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for performing an operation on Oracle E-Business Suite. In this orchestration, you drop a request message at a defined receive location. The Oracle E-Business adapter consumes this message and passes it on to Oracle E-Business Suite. The response from Oracle E-Business Suite is saved to another location. A typical orchestration for performing basic table operations on Oracle database would contain:

  • Send and Receive shapes to send messages to Oracle database and receive responses.

  • A one-way receive port to receive request messages to send to the Oracle database.

  • A two-way send port to send request messages to Oracle database and receive responses.

  • A one-way send port to send the responses from Oracle database to a folder.

A sample orchestration for the Select operation resembles the following:

Orchestration to insert data into interface tables

Adding Message Shapes

Make sure you specify the following properties for each of the message shapes. The names listed in the Shape column are the names of the message shapes as displayed in the just-mentioned orchestration.

Shape Shape Type Properties

ReceiveMessage

Receive

  • Set Name to ReceiveMessage

  • Set Activate to True

SendMessage

Send

  • Set Name to SendMessage

ReceiveResponse

Receive

  • Set Name to ReceiveResponse

  • Set Activate to False

SendResponse

Send

  • Set Name to SendResponse

Adding Ports

Make sure you specify the following properties for each of the logical ports. The names listed in the Port column are the names of the ports as displayed in the orchestration.

Port Properties

MessageIn

  • Set Identifier to MessageIn

  • Set Type to MessageInType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

LOBPort

  • Set Identifier to LOBPort

  • Set Type to LOBPortType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

ResponseOut

  • Set Identifier to ResponseOut

  • Set Type to ResponseOutType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

Specify Messages for Action Shapes, and Connect Them to Ports

The following table specifies the properties and their values that you should set to specify messages for action shapes and to link the messages to the ports. The names listed in the Shape column are the names of the message shapes as displayed in the orchestration mentioned earlier.

Shape Properties

ReceiveMessage

  • Set Message to Request

  • Set Operation to MessageIn.Insert.Request

SendMessage

  • Set Message to Request

  • Set Operation to LOBPort.Insert.Request

ReceiveResponse

  • Set Message to Response

  • Set Operation to LOBPort.Insert.Response

SendResponse

  • Set Message to Response

  • Set Operation to ResponseOut.Insert.Request

After you have specified these properties, the message shapes and ports are connected, and your orchestration is complete.

You must now build the BizTalk solution and deploy it to BizTalk Server. For more information, see http://go.microsoft.com/fwlink/?LinkId=102359.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a location on the hard disk and a corresponding file port where you will drop a request message. The BizTalk orchestration will consume the request message and send it to Oracle E-Business Suite.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the response message containing the response from Oracle E-Business Suite.

    • Define a physical WCF-Custom or WCF-OracleEBS send port to send messages to Oracle E-Business Suite. You must also specify the action in the send port. For information about how to create ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter

      To perform operations on interface tables or interface views using the Oracle E-Business adapter, you must set the right application context in which the operation is invoked. The Oracle E-Business adapter provides certain binding properties to specify the application context for any operation. You must set these binding properties on the WCF-Custom or WCF-OracleEBS port used for performing operations on interface tables.

      • If the ClientCredentialType binding property is set to Database, then you must specify the following binding properties to set the applications context.

        Binding Property Value

        OracleUserName

        Specify the name of an Oracle E-Business Suite user. The Oracle E-Business adapter does not preserve the case of the value that you enter for the OracleUserName binding property when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the user name to be preserved or if you want to enter a user name containing special characters, you must specify the value within double quotes.

        OraclePassword

        The password for the Oracle E-Business Suite user. The Oracle E-Business adapter does not preserve the case of the value that you enter for the OraclePassword binding property when it connects to Oracle E-Business Suite. The password is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the password to be preserved or if you want to enter a password containing special characters, you must specify the value within double quotes.

        OracleEBSResponsibilityName

        The responsibility associated with the Oracle E-Business Suite user.

      • If the ClientCredentialType binding property is set to EBusiness, you must have already specified Oracle E-Business credentials while establishing the connection. In such a case you must only specify value for the OracleEBSResponsibilityName binding property.

      For more information about the different binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For more information on how the adapter supports setting the application context, see Setting Application Context.

      Note
      You can set the application context either by specifying the binding properties or by setting the message context properties exposed by the Oracle E-Business adapter. For instructions on how to set the binding properties, see Specifying Binding Properties. For instructions on how to set the application context using message context properties, see Set the Application Context Using Message Context Properties.

      Note
      Generating the schema using the Consume Adapter Service BizTalk Project Add-in also creates a binding file that contains information about the ports and the actions to be set for those ports. You can import this binding file from the BizTalk Server Administration console to create send ports (for outbound calls) or receive ports (for inbound calls). For more information, see Configuring a Physical Port Binding Using a Port Binding File.

Starting the Application

You must start the BizTalk application for inserting records into the AR_ARCHIVE_PURGE_INTERIM interface table. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The FILE receive port to receive request messages for the orchestration is running.

  • The FILE send port to receive the response messages from the orchestration is running.

  • The WCF-Custom or WCF-OracleEBS send port to send messages to Oracle E-Business Suite is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you run the application, you must drop a request message to the FILE receive location. The schema for the request message must conform to the schema for the Insert operation that you generated earlier. For example, the request message to select all records from the AR_ARCHIVE_PURGE_INTERIM interface table is:

Copy Code
<Insert xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/AR/AR/AR_ARCHIVE_PURGE_INTERIM">
  <RECORDSET>
    <InsertRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/AR/AR_ARCHIVE_PURGE_INTERIM">
      <TRX_ID>001</TRX_ID>
      <RELATED_ID>002</RELATED_ID>
    </InsertRecord>
  </RECORDSET>
</Insert>

This request message will insert records into the AR_ARCHIVE_PURGE_INTERIM interface table. See Message Schemas for Insert, Update, Delete, and Select Operations for more information about the request message schema for performing basic DML operations on Oracle E-Business Suite using the Oracle E-Business adapter.

For simple data columns, like in the preceding request message, you can also use the InlineValue attribute. For more information about the InlineValue attribute, see the description of the Insert operation in Operations on Interface Tables and Interface Views.

For example, the preceding request message with inline values will resemble the following:

Copy Code
<Insert xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/AR/AR/AR_ARCHIVE_PURGE_INTERIM">
  <RECORDSET>
    <InsertRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/AR/AR_ARCHIVE_PURGE_INTERIM">
      <TRX_ID InlineValue="(Select TRX_ID FROM table_name)">001</TRX_ID>
      <RELATED_ID>002</RELATED_ID>
    </InsertRecord>
  </RECORDSET>
</Insert>

In this request message, the value for TRX_ID column is retrieved from another table. So, even though “001” is specified as a value for TRX_ID, the value for the SELECT statement specified for InlineValue attribute will get inserted into the table.

The orchestration consumes the message and sends it to Oracle E-Business Suite. The response from Oracle E-Business Suite is saved at the other FILE location defined as part of the orchestration. For example, the response from Oracle E-Business Suite for the preceding request message is:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<InsertResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/AR/AR/AR_ARCHIVE_PURGE_INTERIM">
  <InsertResult>1</InsertResult>
</InsertResponse>

The response contains the number of rows inserted into the table.

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. After you generate a binding file, you can import the configuration settings from the file, so that you do not need to create items such as the send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Performing Operations on Tables with Large Data Types Using BizTalk Server

The Oracle E-Business adapter enables adapter clients to perform operations on interface tables and views with large data types such as BLOB, CLOB, NCLOB, and BFILE.

  • For columns of type BLOB, CLOB, and NCLOB the adapter enables clients to read as well as update data. The adapter exposes Read_<LOBColName> and Update_<LOBColName> operations to read and update data respectively, where <LOBColName> is the name of column with large data type. If there is more than one column with large data type in a single interface table, the adapter exposes as many read and update operations for that interface table.

  • For columns of type BFILE, adapter clients can only read data. The adapter exposes Read_<LOBColName> operation to read data from columns of BFILE type. If there is more than one column with large data type in a single interface table, the adapter exposes as many read operations for the interface table.

For more information about these operations, see Operations on Interface Tables, Interface Views, Tables, and Views That Contain LOB Data. For information about message schemas for performing these operations, see Message Schemas for Special LOB Operations.

How to Perform Operations on Columns with Large Data Types

Performing an operation on Oracle E-Business Suite by using Oracle E-Business adapter with BizTalk Server involves procedural tasks described in Building Blocks for Developing BizTalk Applications. To perform operations on interface tables and interface views in Oracle E-Business Suite that contain large data types, these tasks are:

  1. Create a BizTalk project, and generate schema for the operation (Read_<LOBColName> or Update_<LOBColName>) you want to invoke on a table or view.

  2. Create messages in the BizTalk project for sending and receiving messages from the Oracle E-Business Suite.

  3. Create an orchestration to invoke the operation on the interface table or view.

  4. Build and deploy the BizTalk project.

  5. Configure the BizTalk application by creating physical send and receive ports.

  6. Start the BizTalk application.

This topic provides instructions to perform these tasks.

How This Topic Demonstrates Reading and Writing Data Into Columns of Large Data Types

To demonstrate reading and writing data into columns of large data types, this topic provides instructions to create an orchestration that does the following:

  • Update the PHOTO column (of BLOB data type) of the CUSTOMER table.

  • Read the value for the PHOTO column for the updated record.

This orchestration is designed in such a way that you only provide the request message for the update operation at run-time. The message for the read operation will be constructed within the operation.

Note
The orchestration in this topic reads and updates data from the CUSTOMER table, which is a base database table created by running the scripts provided with the samples. You must perform similar procedures as described in this topic to perform read or update operations on any interface table or interface view.

Generating Schema

This topic demonstrates how to perform basic read and update operations on a PHOTO column (of BLOB data type) in a CUSTOMER table. This table is created by running the scripts provided with the samples.

To demonstrate how to read and write data to a column of large data type, schema is generated for the Update_PHOTO and Read_PHOTO operations for the CUSTOMER table. You must create a BizTalk project and use the Consume Adapter Service Add-in to generate the schema. See Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio for more information about how to generate schemas.

Defining Messages and Message Types

The schema that you generated earlier describes the “types” required for the messages in the orchestration. A message is typically a variable, the type for which is defined by the corresponding schema. You must now create messages for the orchestration, and link them to schemas that you generated in the previous step.

In this orchestration you must create four messages—one receive-response set for the Update_PHOTO operation and the other receive-response set for the Read_PHOTO operation.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration, and then click Add.

  2. Open the Orchestration View window of the BizTalk project, if it is not already open. To do so, click View, point to Other Windows, and then click Orchestration View.

  3. In Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for the Message_1, do the following:

    Use this To do this

    Identifier

    Type UpdateMessage

    Message Type

    From the drop-down list, expand Schemas, and then select LOBOperations.OracleEBSBinding.Update_PHOTO, where LOBOperations is the name of your BizTalk project. OracleEBSBindingSchema is the schema generated for invoking the Update_PHOTO operation on CUSTOMER table.

  6. Repeat step 3 to create three new message. In the Properties pane for the new message, do the following:

    Set Identifier to Set Message Type to

    UpdateResponse

    LOBOperations.OracleEBSBinding.Update_PHOTOResponse

    ReadMessage

    LOBOperations.OracleEBSBinding1.Read_PHOTO

    ReadResponse

    LOBOperations.OracleEBSBinding1.Read_PHOTOResponse

Setting up the Orchestration

In this orchestration, the adapter receives a request message to perform an Update_PHOTO operation on a CUSTOMER table. The notification message is received at a FILE location. The adapter consumes this message and passes it on to Oracle database. The response from Oracle database is saved at another location. Once the response is received, the orchestration constructs a message to invoke the Read_PHOTO operation, which reads the value of the PHOTO column updated by the Update_PHOTO operation. The response for this message is also received at the same FILE location.

So, your orchestration must contain the following:

  • A FILE receive port to drop a request message for Update_PHOTO operation.

  • A two-way WCF-Custom or WCF-OracleEBS send port to send messages to execute the Update_PHOTO operation.

  • A two-way WCF-Custom or WCF-OracleEBS send port to send messages to execute the Read_PHOTO operation. You can also perform both Read_PHOTO and Update_PHOTO using the same WCF-Custom or WCF-OracleEBS send port. In this topic, you will use a single send port for both the operations.

  • A Construct Message shape to construct messages within the orchestration.

  • A FILE send port to save the response messages for Update_PHOTO and Read_PHOTO operations.

  • Receive and send shapes.

A sample orchestration resembles the following.

Orchestration to operate on large data type column

Adding Message Shapes

Make sure you specify the following properties for each of the message shapes. The names listed in the Shape column are the names of the message shapes as displayed in the just-mentioned orchestration.

Shape Shape Type Properties

ReceiveUpdateMessage

Receive

  • Set Name to ReceiveUpdateMessage

  • Set Activate to True

SendUpdateMessage

Send

  • Set Name to SendUpdateMessage

ReceiveUpdateResponse

Receive

  • Set Name to ReceiveUpdateResponse

SendUpdateResponse

Receive

  • Set Name to SendUpdateResponse

SendReadMessage

Send

  • Set Name to SendReadMessage

ReceiveReadResponse

Receive

  • Set Name to ReceiveReadResponse

SaveReadResponse

Send

  • Set Name to SaveReadResponse

Adding Construct Message Shape

You can use the Construct Message shape to generate a request message within the orchestration to execute the Read_PHOTO operation. To do so, you must add a Construct Message shape and within that a Message Assignment shape to your orchestration. For this example, the Message Assignment shape invokes code that generates a message that is sent to Oracle E-Business Suite to execute the Read_PHOTO operation. The Message Assignment shape also sets the action for the message to be sent to Oracle E-Business Suite.

For the construct message shape, set the Message Constructed property to ReadMessage.

The code to generate the response could be part of the same Visual Studio solution as your BizTalk project. A sample code for generating a response message looks like this.

Copy Code
namespace MessageCreator
{
    public class MessageCreator
    {
        private static XmlDocument Message;
        private static string XmlFileLocation;
        private static string ResponseDoc;

        public static XmlDocument XMLMessageCreator()
        {
            XmlFileLocation = "C:\\TestLocation\\MessageIn";
            try
            {
                ResponseDoc = (Directory.GetFiles(XmlFileLocation, "*.xml", SearchOption.TopDirectoryOnly))[0];
            }
            catch (Exception ex)
            {
                Console.WriteLine("Trying to get XML from: " + XmlFileLocation);
                Console.WriteLine("EXCEPTION: " + ex.ToString());
                throw ex;
            }
            //Create Message From XML
            Message = new XmlDocument();
            Message.PreserveWhitespace = true;
            Message.Load(ResponseDoc);
            return Message;
        }
    }
}

For the above code excerpt to be able to generate a request message, you must have an XML request message (for the Read_PHOTO operation) in the location specified for the XmlFileLocation variable.

Note
After you build the project, MessageCreator.dll will be created in the project directory. You must add this DLL to the global assembly cache (GAC). Also, you must add the MessageCreator.dll as a reference in the BizTalk project.

Add the following expression to invoke this code from the Message Assignment shape and to set the action for message. To add an expression, double-click the Message Assignment shape to open the Expression Editor.

Copy Code
ReadMessage = MessageCreator.MessageCreator.XMLMessageCreator();
ReadMessage(WCF.Action) = "Tables/ReadLOB/SCOTT/CUSTOMER/PHOTO ";

Adding Ports

Make sure you specify the following properties for each of the logical ports. The names listed in the Port column are the names of the ports as displayed in the orchestration.

Port Properties

MessageIn

  • Set Identifier to MessageIn

  • Set Type to MessageInType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

LOBPort

  • Set Identifier to LOBPort

  • Set Type to LOBPortType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

  • Create an operation Read_LOB. This operation is used for messages to read values from large data type columns.

  • Create an operation Update_LOB. This operation is used for messages to update values in large data type columns.

ResponseOut

  • Set Identifier to ResponseOut

  • Set Type to ResponseOutType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

  • Create an operation Read_LOB. This operation is used for messages to read values from large data type columns.

  • Create an operation Update_LOB. This operation is used for messages to update values in large data type columns.

Specify Messages for Action Shapes and Connect to Ports

The following table specifies the properties and their values that you should set to specify messages for action shapes and to link the messages to the ports. The names listed in the Shape column are the names of the message shapes as displayed in the orchestration mentioned earlier.

Shape Properties

ReceiveUpdateMessage

  • Set Message to UpdateMessage

  • Set Operation to MessageIn.Update_LOB.Request

SendUpdateMessage

  • Set Message to UpdateMessage

  • Set Operation to LOBPort.Update_LOB.Request

ReceiveUpdateResponse

  • Set Message to UpdateResponse

  • Set Operation to LOBPort.Update_LOB.Response

SendUpdateResponse

  • Set Message to UpdateResponse

  • Set Operation to ResponseOut.Update_LOB.Request

SendReadMessage

  • Set Message to ReadMessage

  • Set Operation to LOBPort.Read_LOB.Request

ReceiveReadResponse

  • Set Message to ReadResponse

  • Set Operation to LOBPort.Read_LOB.Response

SendReadResponse

  • Set Message to ReadResponse

  • Set Operation to ResponseOut.Read_LOB.Request

After you have specified these properties, the message shapes and ports are connected and your orchestration is complete.

You must now build the BizTalk solution and deploy it to a BizTalk Server. For more information, see "Building and Running Orchestrations" at http://go.microsoft.com/fwlink/?LinkId=102359.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a location on the hard disk and a corresponding FILE port where you will drop a request message. The BizTalk orchestration will consume the request message and send it to Oracle database.

    • Define a location on the hard disk and a corresponding FILE port where the BizTalk orchestration will drop the response message containing the response from Oracle database.

    • Define a physical WCF-Custom or WCF-OracleEBS send port to send messages to Oracle database. You must also specify the action in the send port. For information about how to create ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter. You must make the following considerations while configuring the WCF-Custom or WCF-OracleEBS send port.

      • An Update_<LOBColName> operation must be performed as part of transaction. To ensure this, the UseAmbientTransaction binding property must be set to True.

      • Because the WCF-Custom or WCF-OracleEBS send port sends and receives messages conforming to more than one schema and performs two operations, you must set dynamic action for both the operations. For more information about actions, see Specifying SOAP Action. For this orchestration, the action should be set as follows:

        Copy Code
        <BtsActionMapping xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Operation Name="Update_LOB" Action="Tables/UpdateBlob/SCOTT/CUSTOMER/PHOTO" />
  <Operation Name="Read_LOB" Action="Tables/ReadLOB/SCOTT/CUSTOMER/PHOTO" />
</BtsActionMapping>
        Important
        Note that the operation name in a dynamic action must be same as the operation name you specified on the logical ports while creating the BizTalk orchestration.

      Note
      To perform operations on interface tables or interface views you must also set the application context. For more information on how the adapter supports setting the application context, see Setting Application Context. You can set the application context either by specifying the binding properties or by setting the message context properties exposed by the Oracle E-Business adapter. For instructions on how to set the binding properties, see Specifying Binding Properties. For instructions on how to set the application context using message context properties, see Set the Application Context Using Message Context Properties.

      Note
      Generating the schema using the Consume Adapter Service BizTalk Project Add-in also creates a binding file that contains information about the ports and the actions to be set for those ports. You can import this binding file from the BizTalk Server Administration console to create send ports (for outbound calls) or receive ports (for inbound calls). For more information, see Configuring a Physical Port Binding Using a Port Binding File.

Starting the Application

Before starting the BizTalk orchestration, make sure the request XML to invoke the Read_PHOTO operation is available at C:\TestLocation\MessageIn. The request XML must resemble the following:

Copy Code
<Read_PHOTO xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/CUSTOMER">
  <FILTER>WHERE NAME='Mindy Martin'</FILTER>
</Read_PHOTO>

Note
The request message has a filter on the specific name because in the request message for Update_PHOTO operation, the value for the PHOTO column is updated for the same name. So, the read operation will read the same value that you insert using the update operation.

You must now start the BizTalk application for reading and writing values of large data types from an Oracle database. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The FILE receive port to receive request messages for the orchestration is running.

  • The FILE send port to receive the response messages from the orchestration is running.

  • The WCF-Custom or WCF-OracleEBS send port to send messages to Oracle database is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you start the application you must drop a request message to the FILE receive location. The schema for the request message must conform to the schema for the Update_PHOTO operation you generated earlier. For example, a request message that updates the PHOTO column of the CUSTOMER table resembles the following:

Copy Code
<Update_PHOTO xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/CUSTOMER">
  <FILTER>WHERE Name='Mindy Martin'</FILTER>
  <DATA>U2FtcGxlIERhdGE=</DATA>
</Update_PHOTO>

Note
While updating BLOB columns, the DATA element must always contain a base64 encoded value. For CLOB and NCLOB, the DATA element can have string values.

The preceding request message updates the value in the PHOTO column for the record matching the WHERE clause. See Message Schemas for Operations on Large Data Types for more information about the request message schema for performing operations on large data types using the Oracle E-Business adapter.

The orchestration consumes the message and sends it to Oracle database. The response from Oracle database is saved at the other FILE location defined as part of the orchestration. For example, the response from Oracle database for the preceding request message resembles the following:

Copy Code
<?xml version="1.0" encoding="utf-8"?>
<Update_PHOTOResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/CUSTOMER" />

The orchestration now constructs a request message for the Read_PHOTO operation by using the request message available at C:\TestLocation\MessageIn. The request message is sent to Oracle database and the response is saved at the same FILE location. The response for the read operation on PHOTO column resembles the following:

Copy Code
<?xml version="1.0" encoding="utf-8"?>
<Read_PHOTOResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/CUSTOMER">
  <Read_PHOTOResult>U2FtcGxlIERhdGE=</Read_PHOTOResult>
</Read_PHOTOResponse>

Note
Note that the response contains the same value for the PHOTO column that you passed in the Update_PHOTO operation.

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. Once you generate a binding file, you can import the configuration settings from the file, so that you do not need to create items such as send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Performing Composite Operations on Oracle Database by Using BizTalk Server

The Oracle E-Business adapter enables adapter clients to perform composite operations on Oracle database. A composite operation can include:

  • Insert, Update, Delete, and Select operations on database tables. Select operation on database views.

  • Insert, Update, Delete, and Select operations on interface tables. Select operation on interface views.

  • Stored procedures and functions, inside or outside a package.

A single composite operation can have any number of these operations, in any order. For example, you can have two inserts followed by a delete, and finally a stored procedure execution. Also, you can have different operations targeting different database tables or views. For more information about how the adapter supports composite operations, see Support for Composite Operations. For information about the structure of the SOAP message for composite operations, see Message Schemas for the Composite Operation.

How to Perform Composite Operations on Oracle Database?

Performing an operation on Oracle database using Oracle E-Business adapter with BizTalk Server involves procedural tasks described in Building Blocks for Developing BizTalk Applications. To perform composite operations on Oracle database, these tasks are:

  1. Create a BizTalk project in Visual Studio and generate schema for all the operations you want to invoke.

  2. Manually create a schema file that includes references to all the schemas you generated in the previous step.

  3. Create messages in the BizTalk project for sending and receiving messages from Oracle database. These messages must conform to the request and response schema you created in the previous step.

  4. Create an orchestration to invoke the composite operation on Oracle database.

  5. Build and deploy the BizTalk project.

  6. Configure the BizTalk application by creating physical send and receive ports.

  7. Start the BizTalk application.

This topic provides instructions on how to perform these tasks.

Generating Schema

In this topic, to demonstrate how to perform composite operations, we will perform the following tasks in the same order:

  • Insert record into the ACCOUNTACTIVITY table.

  • Retrieve all the records in the ACCOUNTACTIVITY table by invoking the GET_ALL_ACTIVITY procedure within the ACCOUNT_PKG package.

  • Delete the record from the ACCOUNTACTIVITY table.

Run the scripts provided with the samples to create the ACCOUNTACTIVITY table. For more information about the samples, see Samples.

You must create a BizTalk project and use the Consume Adapter Service Add-in to generate the schema. See Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio for more information about how to generate schemas.

Creating a Composite Schema Definition

You must now create a composite schema in the Visual Studio BizTalk project that references the schemas you created for the individual operations. Perform the following steps to create a composite schema definition.

To add a composite schema definition

  1. Add a schema file to the BizTalk project in Visual Studio. Right-click the solution name, point to Add, and then click New Item. In the Add New Item dialog box, from the Categories box, click Schema Files. From the Templates box, click Schema. Specify a name for the schema file and click OK.

    For this example, specify the schema file name as CompositeSchema.xsd.

  2. Add references to the schema generated for the different operations that you want to perform. In this example, the different schemas generated for operations are:

    • OracleEBSBinding.xsd, for Insert and Delete operations on ACCOUNTACTIVITY table.

    • OracleEBSBinding2.xsd, for the GET_ALL_ACTIVITY procedure.

    To add references:

    1. Right-click the root <Schema> node in the CompositeSchema.xsd, and click Properties.

    2. In the Property box, click the ellipsis button (…) against the Imports property.

      Import schema definitions
    3. In the Imports dialog box, from the Import new schema as list, select XSD Import, and then click Add.

    4. In the BizTalk Type Picker dialog box, expand the BizTalk project name node, expand Schemas, and then select the schema you want to import. For this example, select <BizTalk_project_name>.OracleEBSBinding.xsd. Click OK.

      Repeat this step to import <BizTalk_project_name>.OracleEBSBinding2.xsd too.

    5. In the Imports dialog box, click OK.

  3. Add two child nodes to the root schema node. One child node corresponds to the request schema for performing the composite operation. The other child node corresponds to the response schema. The node that corresponds to the request schema can have any name. The node that corresponds to the response schema must be called <request_schema_node>Response. For this example, we will call the request schema node as Request. So, the response schema node is called RequestResponse.

    Note
    By default, a Root node is also added to a new schema file. You can rename the Root node to Request. To rename a node, right-click the node name and click Rename.

    To add a node under the <Schema> node:

    1. Right-click the <Schema> node, point to Insert Schema Node, and click Child Record.

    2. Rename the new node to RequestResponse.

  4. Add child nodes under the Request node that correspond to the request schema for each operation that you will perform as part of the composite operation. For this example, you must add child nodes corresponding to the following:

    • Insert and Delete operations on the ACCOUNTACTIVITY table.

    • GET_ALL_ACTIVITY procedure.

    Important
    You must add the nodes in the same order in which you want to perform the operations. For example, if you want to insert a record, then execute a stored procedure, and then delete a record you must first add a node for the Insert operation, followed by a node for the stored procedure, and finally a node for the Delete operation.

    To add child nodes to the Request node:

    1. Right-click the Request node, point to Insert Schema Node, and then click Child Record.

      Insert child nodes for a schema
    2. Rename the record to correspond to a request schema for an operation that you perform as part of the composite operation. For example, rename the node to “Insert”.

    3. Map the Insert node to the request schema for the Insert operation on the ACCOUNTACTIVITY table. To do so, right-click the Insert node, and click Properties. In the Properties box, from the Data Structure Type list, select Insert (Reference).

      Map child nodes to request schema
    4. Repeat these steps to add nodes for the request schemas for GET_ALL_ACTIVITY stored procedure and the Delete operation. Specify the node names and map them to the corresponding schema as mentioned in the following table.

      Node name Mapped to schema

      GET_ALL_ACTIVITY

      GET_ALL_ACTIVITY (Reference)

      Delete

      Delete (Reference)

  5. Add child nodes under the RequestResponse node that correspond to the response schema for each operation that you will perform as part of the composite operation. For this example, you must add child nodes corresponding to the following:

    • Insert and Delete operations on the ACCOUNTACTIVITY table.

    • GET_ALL_ACTIVITY stored procedure.

    Important
    You must add the child nodes in the same order as the child nodes under the Request node.

    To add child nodes to the RequestResponse node:

    1. Right-click the RequestResponse node, point to Insert Schema Node, and click Child Record.

    2. Rename the record to correspond to a response schema for an operation that you perform as part of the composite operation. For example, rename the node to “InsertResponse”.

    3. Map the InsertResponse node to the response schema for the Insert operation on the ACCOUNTACTIVITY table. To do so, right-click the InsertResponse node, and click Properties. In the Properties box, from the Data Structure Type list, select InsertResponse (Reference).

    4. Repeat these steps to add nodes for the response schemas for the GET_ALL_ACTIVITY stored procedure and the Delete operation. Specify the node names and map them to the corresponding schema as mentioned in the following table.

      Node name Mapped to schema

      GET_ALL_ACTIVITYResponse

      GET_ALL_ACTIVITYResponse (Reference)

      DeleteResponse

      DeleteResponse (Reference)

  6. Save the CompositeSchema.xsd file.

Defining Messages and Message Types

The composite schema that you created in the last step describes the “types” required for the messages in an orchestration. A message is typically a variable, the type for which is defined by the corresponding schema. You must now create messages for the orchestration and link them to schema you created in the previous step.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project in Visual Studio. From Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration, and then click Add.

  2. Open the Orchestration View window of the BizTalk project, if it is not already open. To do so, click View, point to Other Windows, and then click Orchestration View.

  3. In Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for the Message_1, do the following:

    Use this To do this

    Identifier

    Type Request

    Message Type

    From the drop-down list, expand Schemas, and then select Composite_Op.CompositeSchema.Request, where Composite_Op is the name of your BizTalk project. CompositeSchema is the schema you created manually for the composite operations.

  6. Repeat step 2 to create a new message. In the Properties pane for the new message, do the following:

    Use this To do this

    Identifier

    Type Response

    Message Type

    From the drop-down list, expand Schemas, and then select Composite_Op.CompositeSchema.RequestResponse.

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for performing composite operations on Oracle database. In this orchestration, you drop a request message at a defined receive location. The request message must conform to the composite schema you created earlier. The Oracle E-Business adapter consumes this message and passes it on to Oracle database. The response from Oracle database is saved to another location. You must include Send and Receive shapes to send messages to Oracle database and receive responses, respectively. A basic orchestration for performing composite operations resembles the following:

Orchestration to peform composite operations

Adding Message Shapes

Make sure you specify the following properties for each of the message shapes. The names listed in the Shape column are the names of the message shapes as displayed in the just-mentioned orchestration.

Shape Shape Type Properties

ReceiveMessage

Receive

  • Set Name to ReceiveMessage

  • Set Activate to True

SendMessage

Send

  • Set Name to SendMessage

ReceiveResponse

Receive

  • Set Name to ReceiveResponse

  • Set Activate to False

SendResponse

Send

  • Set Name to SendResponse

Adding Ports

Make sure you specify the following properties for each of the logical ports. The names listed in the Port column are the names of the ports as displayed in the orchestration.

Port Properties

MessageIn

  • Set Identifier to MessageIn

  • Set Type to MessageInType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

LOBPort

  • Set Identifier to LOBPort

  • Set Type to LOBPortType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

ResponseOut

  • Set Identifier to ResponseOut

  • Set Type to ResponseOutType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

Specify Messages for Action Shapes, and Connect Them to Ports

The following table specifies the properties and their values that you should set to specify messages for action shapes and to link the messages to the ports. The names listed in the Shape column are the names of the message shapes as displayed in the orchestration mentioned earlier.

Shape Properties

ReceiveMessage

  • Set Message to Request

  • Set Operation to MessageIn.CompositeOp.Request

SendMessage

  • Set Message to Request

  • Set Operation to LOBPort.CompositeOp.Request

ReceiveResponse

  • Set Message to Response

  • Set Operation to LOBPort.CompositeOp.Response

SendResponse

  • Set Message to Response

  • Set Operation to ResponseOut.CompositeOp.Request

After you have specified these properties, the message shapes and ports are connected and your orchestration is complete.

You must now build the BizTalk solution and deploy it to a BizTalk Server. For more information, see http://go.microsoft.com/fwlink/?LinkId=102359.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a location on the hard disk and a corresponding file port where you will drop a request message. The BizTalk orchestration will consume the request message and send it to Oracle database.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the response message containing the response from Oracle database.

    • Define a physical WCF-Custom or WCF-OracleEBS send port to send messages to Oracle database. Because the operations that are being as part of the composite operation are executed in a single transaction, make sure the UseAmbientTransaction binding property is set to True.

      You must also specify the action in the send port. The action for a composite operation is “CompositeOperation”. For information about how to create ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter. For more information about how to specify actions for ports, see Specifying SOAP Action.

      Important
      As part of composite operations, if you are executing operations on objects, for example stored procedures, functions, interface tables, or interface views, which belong to an Oracle E-Business Suite application, you must set the application context by specifying the requisite binding properties. For more information about setting the application context, see Setting Application Context.

      You can set the application context either by specifying the binding properties or by setting the message context properties exposed by the Oracle E-Business adapter. For instructions on how to set the binding properties, see Specifying Binding Properties. For instructions on how to set the application context using message context properties, see Set the Application Context Using Message Context Properties.

      Note
      Generating the schema using the Consume Adapter Service BizTalk Project Add-in also creates a binding file that contains information about the ports and the actions to be set for those ports. You can import this binding file from the BizTalk Server Administration console to create send ports (for outbound calls) or receive ports (for inbound calls). For more information, see Configuring a Physical Port Binding Using a Port Binding File. If you import this binding file, the action on the send port is set to a dynamic action involving all the operations you selected in the Consume Adapter Service Add-in while generating the schema. For a composite operation, you must replace the dynamic action with “CompositeOperation”.

Starting the Application

You must start the BizTalk application for performing composite operations on Oracle database. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The FILE receive port to receive request messages for the orchestration is running.

  • The FILE send port to receive the response messages from the orchestration is running.

  • The WCF-Custom or WCF-OracleEBS send port to send messages to Oracle database is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you run the application, you must drop a request message to the FILE receive location. The schema for the request message must conform to the schema for the composite operations you created earlier. For example, a request message that inserts a record in the ACCOUNTACTIVITY table, invokes the GET_ALL_ACTIVITY stored procedure, and deletes a record from the ACCOUNTACTIVITY table is:

Copy Code
<Request xmlns="http://Composite_Op.CompositeSchema">
  <Insert xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/ACCOUNTACTIVITY">
    <RECORDSET>
      <InsertRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/SCOTT/ACCOUNTACTIVITY">
        <TID InlineValue="tid_seq.nextval"></TID>
        <ACCOUNT>100001</ACCOUNT>
        <AMOUNT>1500</AMOUNT>
        <DESCRIPTION></DESCRIPTION>
        <TRANSDATE InlineValue="sysdate">1999-05-31T13:20:00</TRANSDATE>
        <PROCESSED>n</PROCESSED>
      </InsertRecord>
    </RECORDSET>
  </Insert>
  <GET_ALL_ACTIVITY xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/SCOTT/ACCOUNT_PKG" />
  <Delete xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/ACCOUNTACTIVITY">
    <FILTER>WHERE AMOUNT = 1500</FILTER>
  </Delete>
</Request>

The preceding request message first inserts a record and then invokes the GET_ALL_ACTIVITY procedure to get all the records in the ACCOUNTACTIVITY table. Then, the inserted record is deleted by specifying a FILTER clause. See Message Schemas for the composite operations for more information about the request message schema for performing composite operations on Oracle database using the Oracle E-Business adapter.

Note
In the preceding message, the excerpt for the Insert operation uses the “InlineValue” attribute. For more information about the “InlineValue” attribute see the schema description for Insert operation in Message Schemas for Insert, Update, Delete, and Select Operations.

The orchestration consumes the message and sends it to Oracle database. The response from Oracle database is saved at the other FILE location defined as part of the orchestration. For example, the response from Oracle database for the preceding request message resembles the following:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<RequestResponse xmlns="http://Composite_Op.CompositeSchema">
  <InsertResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/ACCOUNTACTIVITY">
    <InsertResult>1</InsertResult>
  </InsertResponse>
  <GET_ALL_ACTIVITYResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/SCOTT/ACCOUNT_PKG">
    <ALLRECS>
      <xs:schema id="NewDataSet" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
        <xs:element msdata:IsDataSet="true" name="NewDataSet">
          <xs:complexType>
            <xs:sequence>
              <xs:element minOccurs="0" maxOccurs="unbounded" name="NewTable">
                <xs:complexType>
                  <xs:sequence>
                    <xs:element minOccurs="0" name="TID" type="xs:decimal" />
                    <xs:element minOccurs="0" name="ACCOUNT" type="xs:decimal" />
                    <xs:element minOccurs="0" name="AMOUNT" type="xs:decimal" />
                    <xs:element minOccurs="0" name="DESCRIPTION" type="xs:string" />
                    <xs:element minOccurs="0" name="TRANSDATE" type="xs:dateTime" />
                    <xs:element minOccurs="0" name="PROCESSED" type="xs:string" />
                  </xs:sequence>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:complexType>
        </xs:element>
      </xs:schema>
      <diffgr:diffgram xmlns:diffgr="urn:schemas-microsoft-com:xml-diffgram-v1">
        <NewDataSet xmlns="">
          <NewTable>
            ......
            ......
          </NewTable>
          ......
          ......
          <NewTable>
            <TID>10</TID>
            <ACCOUNT>100001</ACCOUNT>
            <AMOUNT>1000</AMOUNT>
            <TRANSDATE>2008-07-28T21:39:57</TRANSDATE>
            <PROCESSED>n</PROCESSED>
          </NewTable>
        </NewDataSet>
      </diffgr:diffgram>
    </ALLRECS>
  </GET_ALL_ACTIVITYResponse>
  <DeleteResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/SCOTT/ACCOUNTACTIVITY">
    <DeleteResult>1</DeleteResult>
  </DeleteResponse>
</RequestResponse>

The preceding response contains multiple result sets corresponding the different operations performed as part of the composite operation. For example, the InsertResult element contains ‘1’, indicating the number of rows inserted by the Insert operation. Similarly, the DeleteResult element contains ‘1’, indicating the number of rows deleted by the Delete operation.

Important
If you experience time-out issues while executing a composite operation then it could be because the number of connections is less than the number of operations in a composite operation involving:

  • Stored procedures containing BFILE, BLOB, CLOB, NCLOB, and REF CURSOR as OUT or IN OUT parameters.

  • Select operation.

To resolve this issue, you must ensure that if there are “n” number of such operations in a composite operation, the value specified for the MinPoolSize binding property is “n+1” or greater. For more information about the MinPoolSize binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. Once you generate a binding file, you can import the configuration settings from the file, so that you do not need to create items such as send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Invoking Concurrent Programs in Oracle E-Business Suite Using BizTalk Server

Oracle E-Business Suite exposes concurrent programs that you can execute to perform specific operations on Oracle applications. Each Oracle application has a set of standard concurrent programs (that are same across all operations) and certain concurrent programs that are specific to an Oracle application. The Oracle E-Business adapter exposes all concurrent programs as operations that adapter clients can invoke. For more information on how the adapter supports concurrent programs, see Operations on Concurrent Programs. For information about the structure of SOAP messages for invoking concurrent programs, see Message Schemas for Concurrent Programs.

Note
For the concurrent programs that do not expose their metadata, the Oracle E-Business adapter exposes 100 optional parameters for each of these concurrent programs. To invoke these concurrent programs successfully, the user must consult the Oracle E-Business Suite documentation to figure out the parameters for a concurrent program that require a value, and then specify them. An example of such a concurrent program is Journal Import (actual name: GLLEZL) in the General Ledger application.

Prerequisites

You must have completed the steps in Before You Develop BizTalk Applications.

How to Invoke Concurrent Programs in Oracle Applications

Performing an operation on Oracle E-Business Suite using the Oracle E-Business adapter with BizTalk Server involves procedural tasks described in Building Blocks for Developing BizTalk Applications. To invoke a concurrent program, these tasks are:

  • Create a BizTalk project, and generate schema for the concurrent program you want to invoke.

  • Create messages in the BizTalk project for sending and receiving messages to and from Oracle E-Business Suite.

  • Create an orchestration to invoke the concurrent program.

  • Build and deploy the BizTalk project.

  • Configure the BizTalk application by creating physical send and receive ports.

  • Start the BizTalk application.

This topic provides instructions to perform these tasks.

Generating Schema

This topic demonstrates how to invoke the Customer Interface concurrent program from the Receivables application. This application is available with the default Oracle E-Business Suite application. This concurrent program returns a request ID. To check the status of the concurrent program, we execute the Get_Status concurrent program by passing the request ID received in the response of the Customer Interface concurrent program.

In this topic, we generate schema for both the Customer Interface and Get_Status concurrent programs. For more information about how to generate schema, see Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio.

Defining Messages and Message Types

The schema that you generated earlier describes the “types” required for the messages in the orchestration. A message is typically a variable, the type for which is defined by the corresponding schema. You must now create messages for the orchestration, and link them to schemas that you generated in the previous step.

In this orchestration you must create four messages—one receive-response set to invoke the Customer Interface concurrent program and the other receive-response set to invoke the Get_Status concurrent program.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration, and then click Add.

  2. Open the Orchestration View window of the BizTalk project, if it is not already open. To do so, click View, point to Other Windows, and then click Orchestration View.

  3. In Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for the Message_1, do the following:

    Use this To do this

    Identifier

    Type Request

    Message Type

    From the drop-down list, expand Schemas, and then select ConcurrentProgram.OracleEBSBindingSchema.RACUST, where ConcurrentProgram is the name of your BizTalk project. OracleEBSBindingSchema is the schema generated for invoking the Customer Interface concurrent program.

    Note
    RACUST is the actual name of the Customer Interface concurrent program. While the Consume Adapter Service Add-in displays the friendly name (Customer Interface), the schema contains the actual name of the concurrent program.

  6. Repeat step 3 to create three new message. In the Properties pane for the new message, do the following:

    Set Identifier to Set Message Type to

    Response

    ConcurrentProgram.OracleEBSBindingSchema.RACUSTResponse

    Get_StatusRequest

    ConcurrentProgram.OracleEBSBindingSchema1.GetStatusForConcurrentProgram

    Get_StatusResponse

    ConcurrentProgram.OracleEBSBindingSchema1.GetStatusForConcurrentProgramResponse

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for invoking concurrent programs in Oracle E-Business Suite. In this orchestration, you will be dropping a request message at a defined receive location. The orchestration consumes this message and passes it on to Oracle E-Business Suite to invoke the Customer Interface concurrent program. The response for the concurrent program is received from Oracle and is saved at another location. The response message contains a request ID. The orchestration includes a Construct Message shape to extract the request ID from the response and construct a message that conforms to the schema of the Get_Status concurrent program. The message to invoke the Get_Status concurrent program is sent to the Oracle E-Business Suite with the request ID as a parameter. You must include send and receive shapes, message construction shapes, and ports to send messages to Oracle and receive responses.

Typically, the Customer Interface concurrent program will take some time to execute, so you need to wait before executing the Get_Status concurrent. You can automate this by adding a Delay shape.

A sample orchestration resembles the following:

Orchestration to invoke concurrent programs

Adding Message Shapes

Specify the following properties for each of the message shapes. The names listed in the Shape column correspond to the message shapes as displayed in the preceding orchestration.

Shape Shape Type Properties

ReceiveMessage

Receive

  • Set Name to ReceiveMessage

  • Set Activate to True

SendMessage

Send

  • Set Name to SendMessage

ReceiveResponse

Receive

  • Set Name to ReceiveResponse

  • Set Activate to False

SendResponse

Send

  • Set Name to SendResponse

SendGetStatus

Send

  • Set Name to SendGetStatus

ReceiveStatusResponse

Receive

  • Set Name to ReceiveStatusResponse

  • Set Activate to False

SaveStatusResponse

Send

  • Set Name to SaveStatusResponse

Adding a Delay Shape

If you want the orchestration to wait between invoking the Customer Interface and Get_Status concurrent programs, you must add a Delay shape to the orchestration. You must add a Delay shape after the orchestration copies the response for the Customer Interface concurrent program to a FILE send port. So, you must add a Delay shape after the SendResponse shape.

Within the Delay shape, you can specify the time interval for which the orchestration must wait before proceeding by adding the following code to the Expression Editor for the Delay shape:

Copy Code
new System.TimeSpan(0,2,0)

By adding this code, the orchestration will wait for two minutes before proceeding. For more information about how to configure the Delay shape, see http://go.microsoft.com/fwlink/?LinkId=122405.

Adding the Construct Message Shape

The response from the Oracle E-Business Suite for the Customer Interface concurrent program contains a request ID. To get the status of the concurrent program, you must pass the same request ID as a parameter to the Get_Status concurrent program. To do so, in the orchestration, you must include a Construct Message shape, and within that a Message Assignment shape. The purpose of the Construct Message shape is:

  • To extract the request ID from the response that is received for the Customer Interface concurrent program.

  • To construct a message that conforms to the message schema for the Get_Status concurrent program.

For the Construct Message shape, set the Message Constructed property to Get_StatusRequest.

For the Message Assignment shape, add the below. Before adding the code, you must have:

Copy Code
XmlDoc = new System.Xml.XmlDocument();
XmlDoc.LoadXml("<GetStatusForConcurrentProgram xmlns='http://schemas.microsoft.com/OracleEBS/2008/05/ConcurrentPrograms/AR'><RequestId /></GetStatusForConcurrentProgram>");
Get_StatusRequest = XmlDoc;
Get_StatusRequest.RequestId = xpath(Response,"string(/*[local-name()='RACUSTResponse']/*[local-name()='RACUSTResult']/text())");

Adding Ports

To configure the ports, you specify the properties listed in the table below for each of the logical ports. The names listed in the Port column correspond to the names of the ports displayed in the orchestration.

Port Properties

MessageIn

  • Set Identifier to MessageIn

  • Set Type to MessageInType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

LOBPort

  • Set Identifier to LOBPort

  • Set Type to LOBPortType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

ResponseOut

  • Set Identifier to ResponseOut

  • Set Type to ResponseOutType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

  • Create an operation Cust_Interface. This operation is used for the Customer Interface concurrent program.

  • Create an operation Get_Status. This operation is used for the Get_Status concurrent program.

LOBPort_GetStatus

  • Set Identifier to LOBPort_GetStatus

  • Set Type to LOBPort_GetStatusType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

Specify Messages for Action Shapes and Connect to Ports

The following table specifies the property values to specify messages for action shapes and linking them to the ports. The names listed in the Shape column correspond to the names of the message shapes as displayed in the orchestration diagram.

After you have specified these properties, the message shapes and ports are connected and your orchestration is complete.

You must now build the BizTalk solution and then deploy it to a BizTalk Server. For more information, see http://go.microsoft.com/fwlink/?LinkId=102359.

Shape Properties

ReceiveMessage

  • Set Message to Request

  • Set Operation to MessageIn.Cust_Interface.Request

SendMessage

  • Set Message to Request

  • Set Operation to LOBport.Cust_Interface.Request

ReceiveResponse

  • Set Message to Response

  • Set Operation to LOBport.Cust_Interface.Response

SendResponse

  • Set Message to Response

  • Set Operation to ResponseOut.Cust_Interface.Request

SendGetStatus

  • Set Message to Get_StatusRequest

  • Set Operation to LOBPort_GetStatus.Get_Status.Request

ReceiveStatusResponse

  • Set Message to Get_StatusResponse

  • Set Operation to LOBPort_GetStatus.Get_Status.Response

SaveStatusResponse

  • Set Message to Get_StatusResponse

  • Set Operation to ResponseOut.Get_Status.Request

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a location on the hard disk and a corresponding file port where you will drop a request message. The BizTalk orchestration will consume the request message and send it to the Oracle E-Business Suite.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the response message containing the response from Oracle E-Business Suite.

    • Define two physical WCF-Custom or WCF-OracleEBS send ports—one to send messages to Oracle E-Business Suite to execute the Customer Interface concurrent program and the other to execute the Get_Status concurrent program. You must also specify the action in the send ports. For information about how to create ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter.

      To invoke concurrent programs using the Oracle E-Business adapter, you must set the right application context in which the operation is invoked. The Oracle E-Business adapter provides certain binding properties to specify the application context for any operation. You must set these binding properties on the WCF-Custom or WCF-OracleEBS port used for invoking concurrent programs.

      • If the ClientCredentialType binding property is set to Database, then you must specify the following binding properties to set the applications context.

        Binding Property Value

        OracleUserName

        Specify the name of an Oracle E-Business Suite user. The Oracle E-Business adapter does not preserve the case of the value that you enter for the OracleUserName binding property when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the user name to be preserved or if you want to enter a user name containing special characters, you must specify the value within double quotes.

        OraclePassword

        The password for the Oracle E-Business Suite user. The Oracle E-Business adapter does not preserve the case of the value that you enter for the OraclePassword binding property when it connects to Oracle E-Business Suite. The password is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the password to be preserved or if you want to enter a password containing special characters, you must specify the value within double quotes.

        OracleEBSResponsibilityName

        The responsibility associated with the Oracle E-Business Suite user.

      • If the ClientCredentialType binding property is set to EBusiness, you must have already specified Oracle E-Business credentials while establishing the connection. In such a case you must only specify value for the OracleEBSResponsibilityName binding property.

      For more information about the different binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For more information on how the adapter supports setting the application context, see Setting Application Context.

      Note
      You can set the application context either by specifying the binding properties or by setting the message context properties exposed by the Oracle E-Business adapter. For instructions on how to set the binding properties, see Specifying Binding Properties. For instructions on how to set the application context using message context properties, see Set the Application Context Using Message Context Properties.

      Note
      Generating the schema using the Consume Adapter Service BizTalk Project Add-in also creates a binding file that contains information about the ports and the actions to be set for those ports. You can import this binding file from the BizTalk Server Administration console to create send ports (for outbound calls) or receive ports (for inbound calls). For more information, see Configuring a Physical Port Binding Using a Port Binding File.

Starting the Application

You must start the BizTalk application before invoking the concurrent programs. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The FILE receive port to receive request messages for the orchestration is running.

  • The FILE send port to receive the response messages from the orchestration is running.

  • The WCF-Custom or WCF-OracleEBS send port to invoke the Customer Interface concurrent program is running.

  • The WCF-Custom or WCF-OracleEBS send port to invoke the Get_Status concurrent program is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you run the application, you must drop a request message that conforms to the schema for invoking the Customer Interface concurrent program. For example, the request message to invoke the Customer Interface concurrent program is:

Copy Code
<RACUST xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/ConcurrentPrograms/AR">
  <Description>Customer Interface Program</Description>
  <StartTime></StartTime>
  <CREATE_RECIPROCAL_CUSTOMER>Yes</CREATE_RECIPROCAL_CUSTOMER>
  <ORG_ID>203</ORG_ID>
</RACUST>

Note
The request message for invoking a concurrent program requires some optional parameters such as SetOptions, SetPrintOptions, and SetRepeatOptions. The request message provided here does not contain these optional parameters. For information on the complete request message, including optional parameters, see Message Schemas for Concurrent Programs.

The orchestration consumes the message, passes it on to the Oracle E-Business Suite, and receives a response. The response message is saved at the other file location specified as part of the orchestration. The response for the Customer Interface concurrent program resembles the following:

Copy Code
<?xml version="1.0" encoding="utf-8"?>
<RACUSTResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/ConcurrentPrograms/AR">
  <RACUSTResult>2794708</RACUSTResult>
</RACUSTResponse>

The response from the Oracle E-Business Suite contains a request ID. The orchestration extracts the request ID from the response message, constructs a message to invoke the Get_Status concurrent program, and passes it to the Oracle E-Business Suite to execute the Get_Status concurrent program. After the response is received for th Get_Status concurrent program, it is copied to the same file location as the first response. The response for the Get_Status concurrent program resembles the following:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<GetStatusForConcurrentProgramResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/ConcurrentPrograms/AR">
  <GetStatusForConcurrentProgramResult>true</GetStatusForConcurrentProgramResult>
  <Phase>Pending</Phase>
  <Status>Standby</Status>
  <DevPhase>PENDING</DevPhase>
  <DevStatus>STANDBY</DevStatus>
  <Message>null</Message>
</GetStatusForConcurrentProgramResponse>

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. After you generate a binding file, you can import the configuration settings from the file, so that you do not need to create items such as send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Invoking Request Sets in Oracle E-Business Suite Using BizTalk Server

Microsoft BizTalk Adapter for Oracle E-Business Suite enables you to execute request sets in Oracle E-Business Suite. Request sets are divided into one or more stages, and each stage contains a set of reports and concurrent programs. For more information on how the adapter supports request sets, see Operations on Request Sets. For information about the structure of SOAP messages for invoking request sets, see Message Schemas for Request Sets.

Prerequisites

You must have completed the steps in Before You Develop BizTalk Applications.

How to Invoke Request Sets in Oracle E-Business Suite

Performing an operation on Oracle E-Business Suite using the Oracle E-Business adapter with BizTalk Server involves procedural tasks described in Building Blocks for Developing BizTalk Applications. To invoke a request set, these tasks are:

  • Create a BizTalk project, and generate schema for the request set you want to invoke.

  • Create messages in the BizTalk project for sending and receiving messages to and from Oracle E-Business Suite.

  • Create an orchestration to invoke the request set.

  • Build and deploy the BizTalk project.

  • Configure the BizTalk application by creating physical send and receive ports.

  • Start the BizTalk application.

This topic provides instructions to perform these tasks.

Generating Schema

This topic demonstrates how to invoke a request set, by invoking the Function Security Reports (friendly name) request set from the Application Object Library application. The actual name of the request set is FNDRSSUB43. This request set is available with the default Oracle E-Business Suite application. This request set returns a request ID.

Hence, in this topic, we generate schema for the FNDRSSUB43 request set. See Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio for more information about how to generate schema.

Defining Messages and Message Types

The schema that you generated earlier describes the “types” required for the messages in the orchestration. A message is typically a variable, the type for which is defined by the corresponding schema. You must now create messages for the orchestration, and link them to schemas that you generated in the previous step.

In this orchestration you must create two messages—one to send message to invoke the request set and another to receive a response for the request set.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration, and then click Add.

  2. Open the Orchestration View window of the BizTalk project, if it is not already open. To do so, click View, point to Other Windows, and then click Orchestration View.

  3. In Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for the Message_1, do the following:

    Use this To do this

    Identifier

    Type Request

    Message Type

    From the drop-down list, expand Schemas, and then select RequestSet.OracleEBSBindingRequestSets_FND.FNDRSSUB43, where RequestSet is the name of your BizTalk project. OracleEBSBindingRequestSets is the schema generated for invoking the FNDRSSUB43 request set.

  6. Repeat step 3 to create a message. In the Properties pane for the new message, do the following:

    Use this To do this

    Response

    RequestSet.OracleEBSBindingRequestSets_FND.FNDRSSUB43Response

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for invoking request sets in Oracle E-Business Suite. In this orchestration, you will be dropping a request message at a defined receive location. The orchestration consumes this message and passes it on to Oracle E-Business Suite to invoke the FNDRSSUB43 request set. The response for the request set is received from Oracle and is saved at another location. A typical orchestration to invoke a request set would contain:

  • Send and Receive shapes to send messages to Oracle E-Business Suite and receive responses.

  • A one-way receive port to receive request messages to send to Oracle E-Business Suite.

  • A two-way send port to send request messages to Oracle E-Business Suite and receive responses.

  • A one-way send port to send the responses from Oracle E-Business Suite to a folder.

A sample orchestration to invoke a request set resembles the following:

Orchestration to invoke request sets

Adding Message Shapes

Specify the following properties for each of the message shapes. The names listed in the Shape column are the names of the message shapes as displayed in the preceding orchestration.

Shape Shape Type Properties

ReceiveMessage

Receive

  • Set Name to ReceiveMessage

  • Set Activate to True

SendMessage

Send

  • Set Name to SendMessage

ReceiveResponse

Receive

  • Set Name to ReceiveResponse

  • Set Activate to False

SendResponse

Send

  • Set Name to SendResponse

Adding Ports

Make sure you specify the following properties for each of the logical ports. The names listed in the Port column are the names of the ports as displayed in the orchestration.

Port Properties

MessageIn

  • Set Identifier to MessageIn

  • Set Type to MessageInType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

LOBPort

  • Set Identifier to LOBPort

  • Set Type to LOBPortType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

ResponseOut

  • Set Identifier to ResponseOut

  • Set Type to ResponseOutType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

Specify Messages for Action Shapes and Connect to Ports

The following table specifies the properties and their values to be set to specify messages for action shapes and linking them to the ports. The names listed in the Shape column are the names of the message shapes as displayed in the previous orchestration.

Shape Properties

ReceiveMessage

  • Set Message to Request

  • Set Operation to MessageIn.RequestSet.Request

SendMessage

  • Set Message to Request

  • Set Operation to LOBPort.RequestSet.Request

ReceiveResponse

  • Set Message to Response

  • Set Operation to LOBPort.RequestSet.Response

SendResponse

  • Set Message to Response

  • Set Operation to ResponseOut.RequestSet.Request

After you have specified these properties, the message shapes and ports are connected and your orchestration is complete.

You must now build the BizTalk solution and then deploy it to a BizTalk Server. For more information, see http://go.microsoft.com/fwlink/?LinkId=102359.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a location on the hard disk and a corresponding file port where you will drop a request message. The BizTalk orchestration will consume the request message and send it to the Oracle E-Business Suite.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the response message containing the response from Oracle E-Business Suite.

    • Define a physical WCF-Custom or WCF-OracleEBS send port to send messages to Oracle E-Business Suite. You must also specify the action in the send port. For information about how to create send ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter.

      To invoke request sets using the Oracle E-Business adapter, you must set the right application context in which the operation is invoked. The Oracle E-Business adapter provides certain binding properties to specify the application context for any operation. You must set these binding properties on the WCF-Custom or WCF-OracleEBS port used for invoking request sets.

      • If the ClientCredentialType binding property is set to Database, then you must specify the following binding properties to set the applications context.

        Binding Property Value

        OracleUserName

        Specify the name of an Oracle E-Business Suite user. The Oracle E-Business adapter does not preserve the case of the value that you enter for the OracleUserName binding property when it connects to Oracle E-Business Suite. The user name is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the user name to be preserved or if you want to enter a user name containing special characters, you must specify the value within double quotes.

        OraclePassword

        The password for the Oracle E-Business Suite user. The Oracle E-Business adapter does not preserve the case of the value that you enter for the OraclePassword binding property when it connects to Oracle E-Business Suite. The password is passed to Oracle E-Business Suite using the standard rules of SQL*Plus. However, if you want the case of the password to be preserved or if you want to enter a password containing special characters, you must specify the value within double quotes.

        OracleEBSResponsibilityName

        The responsibility associated with the Oracle E-Business Suite user.

      • If the ClientCredentialType binding property is set to EBusiness, you must have already specified Oracle E-Business credentials while establishing the connection. In such a case you must only specify value for the OracleEBSResponsibilityName binding property.

      For more information about the different binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For more information on how the adapter supports setting the application context, see Setting Application Context.

      Note
      You can set the application context either by specifying the binding properties or by setting the message context properties exposed by the Oracle E-Business adapter. For instructions on how to set the binding properties, see Specifying Binding Properties. For instructions on how to set the application context using message context properties, see Set the Application Context Using Message Context Properties.

      Note
      Generating the schema using the Consume Adapter Service BizTalk Project Add-in also creates a binding file that contains information about the ports and the actions to be set for those ports. You can import this binding file from the BizTalk Server Administration console to create send ports (for outbound calls) or receive ports (for inbound calls). For more information, see Configuring a Physical Port Binding Using a Port Binding File.

Starting the Application

You must start the BizTalk application for invoking the request sets. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The FILE receive port to receive request messages for the orchestration is running.

  • The FILE send port to receive the response messages from the orchestration is running.

  • The WCF-Custom or WCF-OracleEBS send port to invoke the FNDRSSUB43 request set is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you run the application, you must drop a request message that conforms to the schema for invoking the FNDRSSUB43 request set. For example, the request message to invoke the FNDRSSUB43 request set is:

Copy Code
<FNDRSSUB43 xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSets/FND">
  <StartTime></ StartTime>
  <All_x0020_Requests_x0020_in_x0020_the_x0020_Set_STAGE10>
    <FNDMNNAV xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetStage/FND/FNDRSSUB43">
      <Responsibility xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetConcurrentProgram/FND/FNDRSSUB43/STAGE10/FND">System Administrator</Responsibility>
      <ns3:Application xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetConcurrentProgram/FND/FNDRSSUB43/STAGE10/FND"></ns3:Application>
    </ns2:FNDMNNAV>
    <ns2:FNDMNMNU xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetStage/FND/FNDRSSUB43">
      <ns3:Responsibility xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetConcurrentProgram/FND/FNDRSSUB43/STAGE10/FND">System Administrator</ns3:Responsibility>
      <ns3:Application xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetConcurrentProgram/FND/FNDRSSUB43/STAGE10/FND"></ns3:Application>
    </ns2:FNDMNMNU>
    <ns2:FNDMNFUN xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetStage/FND/FNDRSSUB43">
      <ns3:Responsibility xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetConcurrentProgram/FND/FNDRSSUB43/STAGE10/FND">System Administrator</ns3:Responsibility>
      <ns3:Application xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSetConcurrentProgram/FND/FNDRSSUB43/STAGE10/FND"></ns3:Application>
    </ns2:FNDMNFUN>
  </ns0:All_x0020_Requests_x0020_in_x0020_the_x0020_Set_STAGE10>
</ns0:FNDRSSUB43>

Note
The request message for invoking a request set requires some optional parameters such as SetRelClassOptions, SetPrintOptions, SetRepeatOptions, and SetNlsOptions. The request message provided here does not contain these optional parameters. For information on the complete request message, including optional parameters, see Message Schemas for Request Sets.

The orchestration consumes the message, passes it on to the Oracle E-Business Suite, and receives a response. The response message is saved at the other file location specified as part of the orchestration. The response for the FNDRSSUB43 request set resembles the following:

Copy Code
<?xml version="1.0" encoding="utf-8"?>
<FNDRSSUB43Response xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/RequestSets/FND">
  <FNDRSSUB43Result>2543208</FNDRSSUB43Result>
</FNDRSSUB43Response>

The response from the Oracle E-Business Suite contains a request ID. Request ID ‘0’ denotes that the final submit operation on the request set failed. In such a case, you can specify other optional parameters in the request message, such as ContinueOnFail, to find out the reason of failure and to debug further.

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. Once you generate a binding file, you can import the configuration settings from the file, so that you do not need to create items such as send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using BizTalk Server

The Oracle E-Business adapter exposes generic operations such as ExecuteNonQuery, ExecuteReader, and ExecuteScalar. You can use these operations to execute any SQL statement on Oracle database. These operations differ based on the kind of response you get for the SQL statement. For more information about how the adapter supports these operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations.

This topic demonstrates how to perform an ExecuteReader operation using the Oracle E-Business adapter with BizTalk Server. You can follow the same set of procedures described in this topic to perform ExecuteNonQuery and ExecuteScalar operations.

How to Invoke ExecuteReader operation on Oracle Database

Performing an operation on a Oracle database by using Oracle E-Business adapter with BizTalk Server involves procedural tasks described in Building Blocks for Developing BizTalk Applications. To invoke the ExecuteReader operation on Oracle database, these tasks are:

  1. Create a BizTalk project, and generate schema for the ExecuteReader operation.

  2. Create messages in the BizTalk project for sending and receiving messages from Oracle database.

  3. Create an orchestration to invoke the operation on Oracle database.

  4. Build and deploy the BizTalk project.

  5. Configure the BizTalk application by creating physical send and receive ports.

  6. Start the BizTalk application.

This topic provides instructions to perform these tasks.

Generating Schema

This topic demonstrates how to invoke the ExecuteReader operation on an Oracle database using the Oracle E-Business adapter with BizTalk Server. The ExecuteReader operation takes any SQL statement as a parameter and returns the result set for the operation as an array of DataSet. For this topic, we execute a SELECT statement on ACCOUNTACTIVITY table using the ExecuteReader operation. The ACCOUNTACTIVITY table is created by running the scripts provided with the samples. For more information about the script, see Samples.

To demonstrate how to invoke ExecuteReader operation, schema is generated for the ExecuteReader operation. You must create a BizTalk project and use the Consume Adapter Service Add-in to generate the schema. For more information about how to generate schemas, see Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio.

Defining Messages and Message Types

The schema that you generated earlier describes the “types” required for the messages in the orchestration. A message is typically a variable, the type for which defined by the corresponding schema. You must now create messages for the orchestration and link them to schemas you generated in the previous step.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration, and then click Add.

  2. Open the Orchestration View window of the BizTalk project, if it is not already open. To do so, click View, point to Other Windows, and then click Orchestration View.

  3. In Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for the Message_1, do the following:

    Use this To do this

    Identifier

    Type Request

    Message Type

    From the drop-down list, expand Schemas, and then select Execute_Reader.GenericOperation.ExecuteReader, where Execute_Reader is the name of your BizTalk project. GenericOperation is the schema generated for the ExecuteReader operation.

  6. Repeat step 2 to create a new message. In the Properties pane for the new message, do the following:

    Use this To do this

    Identifier

    Type Response

    Message Type

    From the drop-down list, expand Schemas, and then select Execute_Reader.GenericOperation.ExecuteReaderResponse.

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for performing an operation on Oracle database. In this orchestration, you drop a request message at a defined receive location. The Oracle E-Business adapter consumes this message and passes it on to Oracle database. The response from Oracle database is saved to another location. A typical orchestration for invoking generic operations such as ExecuteReader would contain:

  • Send and Receive shapes to send and receive messages from an Oracle database.

  • A two-way receive port to send and receive messages from an Oracle database.

  • A one-way send port to send response from Oracle database to a folder.

A sample orchestration for invoking an ExecuteReader operation resembles the following:

Orchestration to invoke ExecuteReader operation

Adding Message Shapes

You need to configure the following properties for each of the message shapes. The names listed in the Shape column correspond to the names of the message shapes as displayed in the just-mentioned orchestration.

Shape Shape Type Properties

ReceiveMessage

Receive

  • Set Name to ReceiveMessage

  • Set Activate to True

SendMessage

Send

  • Set Name to SendMessage

ReceiveResponse

Receive

  • Set Name to ReceiveResponse

  • Set Activate to False

SendResponse

Send

  • Set Name to SendResponse

Adding Ports

For each of the logical ports, configure the properties in the table below. The names listed in the Port column correspond to the names of the ports as displayed in the orchestration.

Port Properties

MessageIn

  • Set Identifier to MessageIn

  • Set Type to MessageInType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

LOBPort

  • Set Identifier to LOBPort

  • Set Type to LOBPortType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

ResponseOut

  • Set Identifier to ResponseOut

  • Set Type to ResponseOutType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

Specify Messages for Action Shapes and Connect Them to Ports

The following table specifies the property values to specify messages for action shapes and to link the messages to the ports. The names listed in the Shape column correspond to the names of the message shapes as displayed in the orchestration diagram earlier.

After you have configure these properties, the message shapes and ports are connected, and your orchestration is complete.

Then, you must now build the BizTalk solution and deploy it to BizTalk Server. For more information, see http://go.microsoft.com/fwlink/?LinkId=102359.

Shape Properties

ReceiveMessage

  • Set Message to Request

  • Set Operation to MessageIn.Exec_Reader.Request

SendMessage

  • Set Message to Request

  • Set Operation to LOBPort.Exec_Reader.Request

ReceiveResponse

  • Set Message to Response

  • Set Operation to LOBPort.Exec_Reader.Response

SendResponse

  • Set Message to Response

  • Set Operation to ResponseOut.Exec_Reader.Request

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a location on the hard disk and a corresponding file port where you will drop a request message. The BizTalk orchestration will consume the request message and send it to the Oracle database.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the response message containing the response from the Oracle database.

    • Define a physical WCF-Custom or WCF-OracleEBS send port to send messages to the Oracle database. You must also specify the action in the send port. For information about how to create send ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter.

      Important
      As part of generic operations, if you are executing operations on objects, for example stored procedures, functions, interface tables, or interface views, which belong to an Oracle E-Business Suite application, you must set the application context by specifying the requisite binding properties. For more information about setting the application context, see Setting Application Context.

      You can set the application context either by specifying the binding properties or by setting the message context properties exposed by the Oracle E-Business adapter. For instructions on how to set the binding properties, see Specifying Binding Properties. For instructions on how to set the application context using message context properties, see Set the Application Context Using Message Context Properties.

      Note
      Generating the schema using the Consume Adapter Service BizTalk Project Add-in also creates a binding file that contains information about the ports and the actions to be set for those ports. You can import this binding file from the BizTalk Server Administration console to create send ports (for outbound calls) or receive ports (for inbound calls). For more information, see Configuring a Physical Port Binding Using a Port Binding File.

Starting the Application

You must start the BizTalk application before invoking ExecuteReader operation on Oracle database. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The FILE receive port to receive request messages for the orchestration is running.

  • The FILE send port to receive the response messages from the orchestration is running.

  • The WCF-Custom or WCF-OracleEBS send port to send messages to Oracle database is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you run the application, you must drop a request message to the FILE receive location. The schema for the request message must conform to the schema for the ExecuteReader operation you generated earlier. For example, the request message to execute a SELECT statement using an ExecuteReader operation is:

Copy Code
<ExecuteReader xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/">
  <Query>SELECT * FROM ACCOUNTACTIVITY</Query>
</ExecuteReader>

See Message Schemas for ExecuteReader, ExecuteScalar, and ExecuteNonQuery Operations for more information about the request message schema for invoking an ExecuteReader operation using the Oracle E-Business adapter.

The orchestration consumes the message and sends it to the Oracle database. The response from the Oracle database is saved at the other FILE location defined as part of the orchestration. The response for the ExecuteReader operation contains a result set as a DataSet. For example, the response from the Oracle database for the preceding request message is:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<ExecuteReaderResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/">
  <ExecuteReaderResult>
    <xs:schema id="NewDataSet" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
      <xs:element msdata:IsDataSet="true" name="NewDataSet">
        <xs:complexType>
          <xs:sequence>
            <xs:element minOccurs="0" maxOccurs="unbounded" name="NewTable">
              <xs:complexType>
                <xs:sequence>
                  <xs:element minOccurs="0" name="TID" type="xs:decimal" />
                  <xs:element minOccurs="0" name="ACCOUNT" type="xs:decimal" />
                  <xs:element minOccurs="0" name="AMOUNT" type="xs:decimal" />
                  <xs:element minOccurs="0" name="DESCRIPTION" type="xs:string" />
                  <xs:element minOccurs="0" name="TRANSDATE" type="xs:dateTime" />
                  <xs:element minOccurs="0" name="PROCESSED" type="xs:string" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:schema>
    <diffgr:diffgram xmlns:diffgr="urn:schemas-microsoft-com:xml-diffgram-v1">
      <NewDataSet xmlns="">
        <NewTable>
          <TID>1</TID>
          <ACCOUNT>100001</ACCOUNT>
          <AMOUNT>500</AMOUNT>
          <DESCRIPTION />
          <TRANSDATE>2008-08-04T13:04:20</TRANSDATE>
          <PROCESSED>n</PROCESSED>
        </NewTable>
        <NewTable>
          ......
          ......
        </NewTable>
        ......
        ......
      </NewDataSet>
    </diffgr:diffgram>
  </ExecuteReaderResult>
</ExecuteReaderResponse>

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. After you generate a binding file, you can import the configuration settings from the file, so that you do not need to create items such as the send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Polling Oracle E-Business Suite Using BizTalk Server

You can configure the Oracle E-Business adapter to receive polling-based messages from Oracle database. The adapter provides two ways of polling the Oracle database:

  • Using SELECT statements. You can specify a simple SELECT statement to poll the Oracle database. The adapter executes the SELECT statement at specified intervals and returns the result to the adapter clients.

  • Using stored procedures. You can specify a stored procedure to poll the Oracle database. The adapter executes the stored procedure at specified intervals and returns the result to the adapter clients.

The key difference in the two approaches is the way adapter clients specify a polling statement that the adapter uses to poll the Oracle database. While the polling statement for the first approach is a simple SELECT statement, the polling statement for the stored procedure approach is a request message that executes the stored procedure. Adapter clients specify the polling statement, for either approach, for the PollingInput binding property. For more information about the binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

The topics in this section provide instructions on how to poll using a SELECT statement and a stored procedure.

In This Section

  • Polling Using SELECT Statement

  • Polling Using Stored Procedures

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Polling Using SELECT Statement

You can configure the Oracle E-Business adapter to receive periodic data-change messages by using a SELECT statement to continuously poll the interface tables, interface views, tables and views in Oracle E-Business Suite. You can specify a SELECT statement as a polling statement that the adapter executes periodically to poll Oracle E-Business Suite. You can also specify a post-poll PL/SQL code block that the adapter executes after the polling statement is executed.

To enable polling, you must specify certain binding properties on the WCF-Custom or WCF-OracleEBS receive port. For more information about how the adapter supports polling, see Support for Inbound Calls Using Polling. For information about the structure of the SOAP message for polling operations, see Message Schemas for the Polling Operations.

Configuring a Polling Operation with Oracle E-Business Suite Adapter Binding Properties

The following table summarizes the Oracle E-Business adapter binding properties that you use to configure the adapter to receive data change messages. You must specify these binding properties while configuring the receive port in BizTalk Server Administration console.

Binding Property Description

InboundOperationType

Specifies whether you want to perform Polling or Notification inbound operation. Default is Polling.

PolledDataAvailableStatement

Specifies the SQL statement that the adapter executes to determine whether any data is available for polling. Only if a record is available, the SELECT statement you specify for the PollingInput binding property will be executed.

PollingInterval

Specifies the interval, in seconds, at which the Oracle E-Business adapter executes the statement specified for the PolledDataAvailableStatement binding property. The default is 30 seconds. The polling interval determines the time interval between successive polls. If the statement is executed within the specified interval, the adapter sleeps for the remaining time in the interval.

PollingInput

Specifies the polling statement. To poll using a SELECT statement, you must specify a SELECT statement for this binding property. The default is null.

You must specify a value for PollingInput binding property to enable polling. The polling statement is executed only if there is data available for polling, which is determined by the PolledDataAvailableStatement binding property.

PollingAction

Specifies the action for the polling operation. You can determine the polling action for a specific operation from the metadata you generate for the operation using the Consume Adapter Service Add-in.

PostPollStatement

Specifies a statement block that is executed after the statement specified by the PollingInput binding property is executed.

PollWhileDataFound

Specifies whether the Oracle E-Business adapter ignores the polling interval and continuously executes the polling statement, if data is available in the table being polled. If no data is available in the table, the adapter reverts to execute the polling statement at the specified polling interval. Default is false.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to poll the Oracle database, read further.

How This Topic Demonstrates Polling

In this topic, to demonstrate how the Oracle E-Business adapter supports receiving data change messages using SELECT statements, create a BizTalk project and generate schema for the Poll operation for table you want to poll. In this topic, we generate schema for the Poll operation for the MS_SAMPLE_EMPLOYEE interface table in the Application Object Library application. This table is created when you run the create_apps_artifacts.sql script provided with the samples to create these objects in Oracle E-Business Suite.

Next, we will use content-based routing (CBR) in BizTalk Server to configure an application with a receive port that will receiving polling messages from the MS_SAMPLE_EMPLOYEE interface table, and then route it to a send port. In this case, we will create a filter on the send port that checks the receive location specified, and the message is routed to the send port.

To demonstrate a polling operation, we do the following:

  • Specify a SELECT statement for the PolledDataAvailableStatement binding property to determine where the interface table being polled (MS_SAMPLE_EMPLOYEE) has any data. In this example, you can set this binding property as:

    Copy Code
    SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE
    This ensures that the adapter executes the polling statement only when the MS_SAMPLE_EMPLOYEE interface table has some records.

  • Specify a SELECT statement for the PollingInput binding property. This statement retrieves all the rows in the MS_SAMPLE_EMPLOYEE interface table. In this example, you can set this binding property as:

    Copy Code
    SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE
    Note
    For information about the FOR UPDATE clause used in the SELECT statement, see Specifying a FOR UPDATE Clause in the Polling Statement.

  • Specify a DELETE statement as part of the PostPollStatement binding property. This statement will delete all data from MS_SAMPLE_EMPLOYEE interface table. In this example, you can set this binding property as:

    Copy Code
    DELETE FROM MS_SAMPLE_EMPLOYEE
    Once this happens, the next time the statement specified for PollingInput will be executed, it will not fetch any data.

  • Until more data is added to the MS_SAMPLE_EMPLOYEE interface table, you will not get any polling messages. So, you must repopulate the MS_SAMPLE_EMPLOYEE interface table with new records. You can do so by running the insert_apps_data.sql script provided with the samples. After you run this script, the next polling operation will fetch the new records inserted into the table.

How to Receive Data-change Messages from Oracle E-Business Suite

Performing an operation on Oracle database using Oracle E-Business adapter with BizTalk Server involves the following procedural tasks described in Building Blocks for Developing BizTalk Applications. To configure the adapter to poll Oracle E-Business Suite using a SELECT statement, these tasks are:

  1. Create a BizTalk project, and generate schema for the Poll operation for the interface table you want to poll.

  2. Build and deploy the BizTalk project.

  3. Configure the BizTalk application by creating receive and send ports. Additionally, add filter on the send port so that it checks the receive location specified in the receive port, and the polling message is routed to the send port.

    Important
    For inbound polling scenarios you must always configure a one-way receive port. Two-way receive ports are not supported for inbound operations.

  4. Start the BizTalk application.

This topic provides instructions to perform these tasks.

Sample Based On This Topic

A sample, PollingUsingSelectStatement, based on this topic is also provided with the BizTalk Adapter Pack. For more information, see Samples.

Generating Schema

You must generate the schema for the Poll operation on the MS_SAMPLE_EMPLOYEE interface table in the Application Object Library application. Perform the following tasks while generating the schema using the Consume Adapter Service Add-in.

  • Select the contract type as Service (Inbound operation).

  • Generate schema for the Poll operation on the MS_SAMPLE_EMPLOYEE interface table. You can select the operation and the interface table either from the Application-Based View node or the Artifact -Based View node.

For more information about how to generate schema, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

Building and Deploying the BizTalk Project

You must now build the BizTalk solution, and deploy it to a BizTalk Server. For information about deploying the solution to BizTalk Server, see http://go.microsoft.com/fwlink/?LinkId=107182.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the application is listed under the Applications node in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. As part of configuring the application, you must create a receive port and a send port in the application, and then add filter to the send port so that all the messages from the receive port are routed to the send port.

Configuring an application involves:

  • Selecting a host for the application.

  • Creating receive and send ports.

Creating a Receive Port

You must create a WCF-Custom or WCF-OracleEBS one-way receive port, which polls Oracle using the SELECT statement specified for the PollingInput binding property. For information about how to create receive ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter. While creating the receive port, ensure you specify the following binding properties.

For Polling

Binding Property Value

InboundOperationType

Set this to Polling.

PolledDataAvailableStatement

For this example, set this binding property to:

Copy Code
SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE

PollingAction

Retrieve the polling action from the schema generated for the Poll operation on MS_SAMPLE_EMPLOYEE interface table. For this example, set this binding property to InterfaceTables/Poll/FND/APPS/MS_SAMPLE_EMPLOYEE.

PollingInput

For this binding property, specify a SELECT statement to retrieve all records from the MS_SAMPLE_EMPLOYEE interface table. For this example, set this binding property to:

Copy Code
SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE

PostPollStatement

Specify the post-poll statement to delete all data from the MS_SAMPLE_EMPLOYEE interface table. For this example, set this binding property to:

Copy Code
DELETE FROM MS_SAMPLE_EMPLOYEE

For Setting Application Context

If you are performing operation on Oracle E-Business Suite artifacts, you must specify values for the appropriate binding properties to set the application context. For more information about application context and the binding properties required for setting application context, see Setting Application Context.

For this example, specify appropriate values for the oracleUserName, oraclePassword, and oracleEBSResponsibility binding properties.

Note
We recommend configuring the transaction isolation level and the transaction timeout while performing inbound operations using the Oracle E-Business adapter. You can do so by adding the service behavior while configuring the receive port. For instruction on how to add the service behavior, see Configure Transaction Isolation Level and Transaction Timeout.

Creating a Send Port

Define a location on the hard disk and create a corresponding FILE send port where BizTalk Server will drop the messages from Oracle. These messages will be in response to the polling statement that you specify for the receive port. For information about how to create send ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter.

You must also add a filter on the send port to route messages from the receive location. To add filter to the send port:

  1. Double-click the send port to open the Send Port Properties dialog box.

  2. In the Send Port Properties dialog box, click the Filters tab.

  3. Specify the following values:

    • In the Property list, click BTS.ReceivePortName.

    • In the Operator list, click ==.

    • In the Value field, specify the receive port name.

  4. In the Send Port Properties dialog box, click OK.

Starting the Application

You must start the BizTalk application for polling Oracle E-Business Suite. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The WCF-Custom or WCF-OracleEBS one-way receive port, which polls Oracle using the SELECT statement specified for the PollingInput binding property, is running.

  • The FILE send port, which receives messages from Oracle database, is running.

Executing the Operation

After you run the application, the following set of actions take place, in the same sequence:

  • The adapter executes the PolledDataAvailableStatement which returns a positive value indicating the adapter to execute the statement specified for PollingInput binding property.

  • The adapter executes the SELECT statement for the PollingInput binding property and returns all the rows in the MS_SAMPLE_EMPLOYEE interface table. The response from Oracle E-Business Suite resembles the following:

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Poll xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/FND/APPS/MS_SAMPLE_EMPLOYEE">
  <DATA>
    <SelectRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/APPS/MS_SAMPLE_EMPLOYEE">
     <EMP_NO>10002</EMP_NO>
     <NAME>JEFF PRICE</NAME>
     <DESIGNATION>MANAGER</DESIGNATION>
     <SALARY>25000</SALARY>
     <JOIN_DATE>2007-12-15T00:00:00</JOIN_DATE>
    </SelectRecord>
    <SelectRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/APPS/MS_SAMPLE_EMPLOYEE">
     <EMP_NO>10003</EMP_NO>
     <NAME>DON HALL</NAME>
     <DESIGNATION>ACCOUNTANT</DESIGNATION>
     <SALARY>12000</SALARY>
     <JOIN_DATE>2005-10-29T00:00:00</JOIN_DATE>
    </SelectRecord>
    …
    <SelectRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/APPS/MS_SAMPLE_EMPLOYEE">
     …
    </SelectRecord>
    …
  </DATA>
</Poll>
  • The adapter executes the post-poll statement, which deletes all the data from MS_SAMPLE_EMPLOYEE interface table.

  • After the polling interval, the adapter again executes PolledDataAvailableStatement. Because the MS_SAMPLE_EMPLOYEE interface table has no records now, PolledDataAvailableStatement does not return a positive value and hence the adapter does not execute the statement specified for the PollingInput binding property. As a result, adapter client does not get any polling message.

  • The adapter client will not get any more polling messages until some records are explicitly inserted into the MS_SAMPLE_EMPLOYEE interface table. To insert more records, you can run the insert_apps_data.sql script provided with the samples. After you run this script, the next time PolledDataAvailableStatement is executed, it returns a positive value. As a result, the adapter executes the polling statement and adapter clients again receive a polling message.

Note
The Oracle E-Business adapter will continue to poll until you explicitly disable the receive port from the BizTalk Server Administration console.

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the bindings file. Once you generate a bindings file, you can import the configuration settings from the file so that you do not need to create the send ports and receive ports. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Polling Oracle E-Business Suite Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Polling Using Stored Procedures

You can configure the Oracle E-Business adapter to receive periodic data-change messages by using stored procedures to continuously poll the Oracle database. You can specify a stored procedure as a polling statement that the adapter executes periodically to poll the Oracle database.

To enable polling, you must specify certain binding properties on the WCF-Custom or WCF-OracleEBS receive port. For more information about how the adapter supports polling, see Support for Inbound Calls Using Polling. For information about the structure of the SOAP message for polling operations, see Message Schemas for the Polling Operations.

Configuring a Polling Operation with Oracle E-Business Adapter Binding Properties

The following table summarizes the Oracle E-Business adapter binding properties that you use to configure the adapter to receive data-change messages. You must specify these binding properties while configuring the WCF-Custom or WCF-OracleEBS receive port in the BizTalk Server Administration console.

Binding Property Description

InboundOperationType

Specifies whether you want to perform a Polling or Notification inbound operation. Default is Polling.

PolledDataAvailableStatement

Specifies the SQL statement that the adapter executes to determine whether any data is available for polling. Only if a record is available, the stored procedure you specified for the PollingInput binding property will be executed.

PollingInterval

Specifies the interval, in seconds, at which the Oracle E-Business adapter executes the statement specified for the PolledDataAvailableStatement binding property. The default is 30 seconds. The polling interval determines the time interval between successive polls. If the statement is executed within the specified interval, the adapter sleeps for the remaining time in the interval.

PollingInput

Specifies the polling statement. To poll using a stored procedure, you must specify the entire request message for this binding property. The request message must be the same that you send to the adapter for invoking the stored procedure as an outbound operation. The default is null.

You must specify a value for PollingInput binding property to enable polling. The polling statement is executed only if there is data available for polling, which is determined by the PolledDataAvailableStatement binding property.

PollingAction

Specifies the action for the polling operation. You can determine the polling action for a specific operation from the metadata you generate for the operation using the Consume Adapter Service Add-in.

PostPollStatement

Specifies a statement block that is executed after the statement specified by the PollingInput binding property is executed.

PollWhileDataFound

Specifies whether the Oracle E-Business adapter ignores the polling interval and continuously executes the polling statement, if data is available in the table being polled. If no data is available in the table, the adapter reverts to execute the polling statement at the specified polling interval. Default is false.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to poll the Oracle database, read the following sections.

How This Topic Demonstrates Polling

In this topic, to demonstrate how the Oracle E-Business adapter supports receiving data change messages using stored procedures, create a BizTalk project and generate schema for the stored procedure you want to use to poll the Oracle database. In this topic, we use the GET_ACTIVITYS stored procedure to poll the ACCOUNTACTIVITY table. This stored procedure is available with the ACCOUNT_PKG package. You can run the SQL scripts provided with the samples to create these objects in the database.

Note
The orchestration in this topic polls the ACCOUNTACTIVITY table, which is a base database table created by running the scripts provided with the samples. You must perform similar procedures as described in this topic to poll any other table, including interface tables.

To demonstrate a polling operation, we do the following:

  • Specify a SELECT statement for the PolledDataAvailableStatement binding property to determine where the table being polled (ACCOUNTACTIVITY) has any data. In this example, you can set this binding property as:

    Copy Code
    SELECT COUNT (*) FROM ACCOUNTACTIVITY
    This ensures that the adapter executes the polling statement only when the ACCOUNTACTIVITY table has some records.

  • Execute a stored procedure, GET_ACTIVITYS, by providing the request message as part of the PollingInput binding property. This stored procedure will retrieve all the rows in the ACCOUNTACTIVITY table and you will get a response message from the adapter.

  • EXECUTE a PL/SQL block as part of the PostPollStatement binding property. This statement will move all data from ACCOUNTACTIVITY table to another table in the database. Once this happens, the next time PollingInput will be executed, it will not fetch any data and hence the GET_ACTIVITYS stored procedure will return an empty response message.

  • Until more data is added to the ACCOUNTACTIVITY table, you will continue to get empty response messages. So, you must repopulate the ACCOUNTACTIVITY table with new records. You can do so by running the more_activity_data.sql script provided with the samples. After you run this script, the next polling operation will fetch the new records inserted into the table.

How to Receive Data-change Messages from Oracle

Performing an operation on Oracle database using Oracle E-Business adapter with BizTalk Server involves the following procedural tasks described in Building Blocks for Developing BizTalk Applications. To configure the adapter to poll Oracle database using a stored procedure, these tasks are:

  1. Create a BizTalk project, and generate schema for the stored procedure you want to use for polling.

  2. Create a message in the BizTalk project for receiving messages from Oracle database.

  3. Create an orchestration to receive messages from Oracle database and save them to a folder.

  4. Build and deploy the BizTalk project.

  5. Configure the BizTalk application by creating physical send and receive ports.

    Important
    For inbound polling scenarios you must always configure a one-way receive port. Two-way receive ports are not supported for inbound operations.

  6. Start the BizTalk application.

This topic provides instructions to perform these tasks.

Sample Based On This Topic

A sample, PollingUsingStoredProc, based on this topic is also provided with the BizTalk Adapter Pack. For more information, see Samples.

Generating Schema

You must generate the schema for the GET_ACTIVITYS operation. Perform the following tasks while generating the schema using the Consume Adapter Service Add-in.

  • Select the contract type as Service (Inbound operation).

  • Generate schema for the GET_ACTIVITYS procedure.

For more information about how to generate schema, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

Defining Messages and Message Types

The schema that you generated earlier describes the "types" required for the messages in the orchestration. A message is typically a variable, the type for which is defined by the corresponding schema. Once the schema is generated, you must link it to the messages from the Orchestration view of the BizTalk project.

For this topic, you must create one message to receive messages from Oracle.

Perform the following steps to create messages and link them to schema.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From the Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration and then click Add.

  2. Open the orchestration view window of the BizTalk project, if it is not already open. Click View, point to Other Windows, and then click Orchestration View.

  3. In the Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for Message_1, do the following:

    Use this To do this

    Identifier

    Type Receive.

    Message Type

    From the drop-down list, expand Schemas, and select Polling.OracleEBSBindingSchema, where Polling is the name of your BizTalk project. OracleEBSBindingSchema is the response schema generated for the GET_ACTIVITYS stored procedure.

    Important
    Because polling is a one way operation, the schema generated by the adapter does not contain a response node, and hence there is only one root node in the schema. If you use such schemas for a message type, you must identify the schema by the filename of the generated schema.

    For example, if you create schema for a two-way operation, the nodes in the schema file with a name OracleEBSBindingSchema may look like “Request” and “Response”. If you want to create a message in the orchestration that maps to the request schema, you can identify the schema in the list by looking for OracleEBSBindingSchema.Request. However, in the case of polling operation, because the only node is “Poll”, it is not easy to identify the schema you want to map to because schemas with single nodes are not listed as <schemafilename>.<rootnodename>. Instead, such schemas are listed by only the filename. In such a case, the only way to identify the schema is by the schema filename, for example, OracleEBSBindingSchema.

    The Consume Adapter Service Add-in generates schema for both inbound and outbound operations for the GET_ACTIVITYS stored procedure. You must use the schema for inbound operation to:

    • Map the message created as part of the orchestration.

    • To retrieve the action you must specify for the PollingAction binding property at run-time.

    You must use the schema for the outbound operation to get the request message you must specify as part of the PollingInput binding property.

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for receiving polling-based data-change messages from Oracle. In this orchestration, the adapter receives the response by executing the stored procedure for which you specified the request message as part of the PollingInput binding property. The response message for the stored procedure is saved to a FILE location. A typical orchestration for polling Oracle database would contain:

  • Receive and Send shapes to receive messages from Oracle and send to a FILE port, respectively.

  • A one-way receive port to receive messages from Oracle database.

    Important
    For inbound polling scenarios you must always configure a one-way receive port. Two-way receive ports are not supported for inbound operations.

  • A one-way send port to send polling responses from Oracle database.

A sample orchestration resembles the following.

Orchestration for a polling query for Oracle

Adding Message Shapes

Make sure you specify the following properties for each of the message shapes. The names listed in the Shape column are the names of the message shapes as displayed in the just-mentioned orchestration.

Shape Shape Type Properties

ReceiveMessage

Receive

  • Set Name to ReceiveMessage

  • Set Activate to True

SaveMessage

Send

  • Set Name to SaveMessage

Adding Ports

Make sure you specify the following properties for each of the logical ports. The names listed in the Port column are the names of the ports as displayed in the orchestration.

Port Properties

OracleReceivePort

  • Set Identifier to OracleReceivePort

  • Set Type to OracleReceivePortType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

SaveMessagePort

  • Set Identifier to SaveMessagePort

  • Set Type to SaveMessagePortType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

Specify Messages for Action Shapes and Connect to Ports

The following table specifies the properties and their values that you should set to specify messages for action shapes and to link the messages to the ports. The names listed in the Shape column are the names of the message shapes as displayed in the orchestration mentioned earlier.

Shape Properties

ReceiveMessage

  • Set Message to Receive

  • Set Operation to OracleReceivePort.Polling.Request

SaveMessage

  • Set Message to Receive

  • Set Operation to SaveMessagePort.Polling.Request

After you have specified these properties, the message shapes and ports are connected and your orchestration is complete.

You must now build the BizTalk solution and deploy it to a BizTalk Server. For more information, see "Building and Running Orchestrations" at http://go.microsoft.com/fwlink/?LinkId=102359.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see "How to Configure an Application" at http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a location on the hard disk and a corresponding FILE port where the BizTalk orchestration will drop the messages from Oracle. These messages will be in response to the polling statement that you specify for the receive port.

    • Define a physical WCF-Custom or WCF-OracleEBS one-way receive port. This port polls the Oracle database. For information about how to create receive ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter. Make sure you specify the following binding properties for the receive port.

      Binding Property Value

      InboundOperationType

      Set this to Polling.

      PolledDataAvailableStatement

      For this example, set this binding property to:

      Copy Code
      SELECT COUNT (*) FROM ACCOUNTACTIVITY

      This ensures that the adapter executes the polling statement only when the ACCOUNTACTIVITY table has some records.

      PollingAction

      Retrieve the polling action from the schema generated for the inbound message for the GET_ACTIVITYS procedure. For this example, set this binding property to PollingPackageApis/APPS/ACCOUNT_PKG/GET_ACTIVITYS.

      PollingInput

      For this binding property, specify the request message to invoke the GET_ACTIVITYS stored procedure. You can get the request message from the schema for the outbound operation generated by the Consume Adapter Service Add-in. You must provide the entire XML message as an input for this binding property. For this example, set this binding property to:

      Copy Code
      <GET_ACTIVITYS xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/APPS/ACCOUNT_PKG">
  <INRECS>OPEN ? FOR SELECT * FROM ACCOUNTACTIVITY</INRECS>
</GET_ACTIVITYS>

      The GET_ACTIVITYS stored procedure takes an input REF CURSOR as parameter.

      PostPollStatement

      Specify the post-poll statement to move all data from ACCOUNTACTIVITY table to another table. For this example, set this binding property to:

      Copy Code
      BEGIN ACCOUNT_PKG.PROCESS_ACTIVITY(); END;

      For more information about the different binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

      Important
      If you are polling an interface table, you must set the application context by specifying the requisite binding properties. For more information about setting the application context see Setting Application Context.

      Note
      We recommend configuring the transaction isolation level and the transaction timeout while performing inbound operations using the Oracle E-Business adapter. You can do so by adding the service behavior while configuring the WCF-Custom or WCF-OracleEBS receive port. For instruction on how to add the service behavior, see Configure Transaction Isolation Level and Transaction Timeout.

Starting the Application

You must start the BizTalk application for polling Oracle database. For instructions on starting a BizTalk application, see http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The WCF-Custom or WCF-OracleEBS one-way receive port, which polls Oracle using the stored procedure specified for the PollingInput binding property, is running.

  • The FILE send port, which receives messages from Oracle database, is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you run the application, the following set of actions take place, in the same sequence:

  • The adapter executes the PolledDataAvailableStatement which returns a positive value indicating the adapter to execute the statement specified for PollingInput binding property.

  • The adapter executes the GET_ACTIVITYS stored procedure specified for the PollingInput binding property and returns all the rows in the ACCOUNTACTIVITY table. The response from Oracle database resembles the following:

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<GET_ACTIVITYS xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PollingPackageApis/APPS/ACCOUNT_PKG">
  <OUTRECS>
    <OUTRECSRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/ReferencedRecordTypes/APPS/ACCOUNT_PKG/GET_ACTIVITYS/APPS/GET_ACTIVITYS">
      <TID>1</TID>
      <ACCOUNT>100001</ACCOUNT>
      <AMOUNT>500</AMOUNT>
      <DESCRIPTION />
      <TRANSDATE>2008-06-21T15:52:19</TRANSDATE>
      <PROCESSED>n</PROCESSED>
    </OUTRECSRecord>
    <OUTRECSRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/ReferencedRecordTypes/APPS/ACCOUNT_PKG/GET_ACTIVITYS/APPS/GET_ACTIVITYS">
      ......
      ......
    </OUTRECSRecord>
    ......
    ......
  </OUTRECS>
</GET_ACTIVITYS>
  • The adapter executes the post-poll statement, which moves all the data from ACCOUNTACTIVITY table to another table.

  • After the polling interval, the adapter again executes PolledDataAvailableStatement. Because ACCOUNTACTIVITY table has no records now, PolledDataAvailableStatement does not return a positive value and hence the adapter does not execute the statement specified for the PollingInput binding property. As a result, adapter client does not get any polling message.

  • The adapter client will not get any more polling messages until some records are explicitly inserted into the ACCOUNTACTIVITY table. To insert more records, you can run the more_activity_data.sql script provided with the samples. After you run this script, the next time PolledDataAvailableStatement is executed, it returns a positive value. As a result, the adapter executes the polling statement and adapter clients again receive a polling message.

Note
The Oracle E-Business adapter will continue to poll until you explicitly disable the receive port from the BizTalk Server Administration console.

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the bindings file. Once you generate a bindings file, you can import the configuration settings from the file so that you do not need to create the send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Polling Oracle E-Business Suite Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Receiving Database Change Notifications Using BizTalk Server

You can configure the Oracle E-Business adapter to receive database change notification messages from Oracle E-Business Suite. You can specify a SELECT statement that the adapter uses to register for notifications with Oracle E-Business Suite. The adapter receives a notification message when the result set for the SELECT statement, registered for notification, changes. For more information about how the adapter supports notification, see Receiving Database Change Notifications.

Following are some scenarios in which you can configure the Oracle E-Business adapter with BizTalk Server to receive notifications from Oracle E-Business Suite:

  • Adapter clients get only “incremental” notification, for example, only for those changes that were made to a database table since the last notification.

  • If a large number of rows are inserted into a database table, the adapter clients can configure multiple receive locations to load-balance receiving notifications.

After the adapter clients receive a notification message, they can perform specific tasks based on the kind of notification received. For example, a BizTalk orchestration can be designed in such a way that it performs one set of tasks if an insert notification is received and another set of tasks if an update notification is received.

Caution
If there is a network outage between the Oracle database and the adapter client, the notifications will not be sent to the adapter clients for the changes done on the Oracle database during the period of network outage, and thereafter. Therefore, you must use the Polling operation instead of the Notification operation for critical scenarios.

The topics in this section provide information on how to configure the adapter for each of these scenarios. To start getting notifications from Oracle E-Business Suite using the Oracle E-Business adapter, you must specify certain binding properties. For more information about the binding properties related to notifications, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For more information about structure of notification messages, see Message Schemas for the Notification Operation.

For receiving notifications from Oracle E-Business Suite, make sure:

  • You use the adapter to connect to Oracle database version 10.2 or later. Oracle database versions prior to 10.2 do not support notifications.

  • The change notification privilege is required for receiving database change notifications. To configure this privilege, connect to Oracle database using administrative privileges and then type the following command on the SQL prompt.

    Copy Code
    grant change notification to <user name>
  • Decide on a TCP port you want ODP.NET to use for receiving database change notifications from Oracle database. Add that port to Windows Firewall exceptions list. For instructions on how to add ports to Windows Firewall exceptions list, see http://go.microsoft.com/fwlink/?LinkID=196959. You must provide the same port number for the NotificationPort binding property. For more information about the binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

In This Section

  • Considerations for Receiving Database Change Notifications Using the Adapter

  • Processing Notification Messages to Perform Specific Tasks

  • Receiving Database Change Notifications Incrementally Using BizTalk Server

  • Receiving Database Change Notifications On Multiple Receive Locations

  • Receiving Database Change Notifications After a Receive Location Breakdown

See Also

Other Resources

Developing BizTalk Applications

© 2014 Microsoft Corporation. All rights reserved.


Considerations for Receiving Database Change Notifications Using the Adapter

This topic provides some considerations and best practices that you must keep in mind while using the Oracle E-Business adapter to receive database notifications from an Oracle database.

Considerations While Using the Adapter to Receive Notifications

You must consider the following while using the Oracle E-Business adapter to receive query notifications.

  • The Oracle E-Business adapter simply passes on the notification, which it receives from the Oracle database, to the adapter clients. The adapter does not distinguish between the notifications for different operations, i.e., the adapter does not have any information whether a particular notification is for an Insert operation or an Update operation.

  • The notification message for an operation is not affected by the number of records affected by that operation. For example, irrespective of the number of records inserted in an Oracle database table, the adapter clients receive only one notification message.

  • We recommend that the adapter client application contain the logic to interpret the kind of notification received from the Oracle database. The adapter client applications can do so by extracting the information in the <Info> element of the received notification message. Here’s an example of a notification message received for an Insert operation.

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Details>
    <NotificationDetails>
      <ResourceName>SCOTT.ACCOUNTACTIVITY</ResourceName>
      <Info>1</Info>
      <QueryId>0</QueryId>
    </NotificationDetails>
  </Details>
  <Info>Insert</Info>
  <ResourceNames>
    <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/Arrays">SCOTT.ACCOUNTACTIVITY</string>
  </ResourceNames>
  <Source>Data</Source>
  <Type>Change</Type>
</Notification>
    Notice the value within the <Info> element. This value provides information on the operation for which the notification message was received. Your application should have the functionality to extract the value within the <Info> element and then based on the value, perform subsequent tasks. The topic Processing Notification Messages to Perform Specific Tasks has instructions on how to extract the value within the <Info> element.

  • Ideally, after the client application receives a notification, it should update the record for which the notification is already received so that the subsequent notifications are not for the same record. For example, consider an ACCOUNTACTIVITY table that has a Processed column. For all new records inserted into the ACCOUNTACTIVITY table, the value in the Processed column is always ‘n’. For example, after an insert operation, the records in the ACCOUNTACTIVITY table will look like the following:

    Account Transaction ID Processed

    10001

    n

    To get notifications for the newly inserted record, the adapter client will set the NotificaitonStatement binding property as:

    Copy Code
    SELECT * FROM SCOTT.ACCOUNTACTIVITY WHERE PROCESSED = ‘n’
    After, receiving the notification, the client application must set the value of the Processed column to ‘y’ so that the notification statement does not operate on the record that was already notified for. So, to achieve this, the client application must perform an Update operation on the ACCOUNTACTIVITY table. After the Update operation, the same record in the ACCOUNTACTIVITY table will look like the following:

    Account Transaction ID Processed

    10001

    y

    Interestingly, the Update operation will again send a notification to the adapter client and the whole process will be repeated again. So, the client application must have the required logic to discard such unwanted notifications.

  • If the NotifyOnListenerStart binding property is true, the adapter will send a notification to the adapter client every time the receive location starts. For more information on how to use the binding property and interpret the notification message, see Receiving Database Change Notifications After a Receive Location Breakdown.

Typical Orchestration for Receiving Notifications

This section outlines the typical orchestration flow for receiving notifications using the Oracle E-Business adapter.

  1. The first thing that the orchestration must do is to check the kind of notification received. The things to check for are:

    • Whether the notification was received for the receive location restart.

    • Whether the notification was received for an operation on a database table, such as Insert, Update, or Delete.

    The orchestration must include an Expression shape, and within that an xpath query, to decide what kind of message is received.

  2. After the notification type is available, the orchestration must include a decision block to perform specific actions based on the type of notification received. To achieve this, the orchestration must include a Decide shape. The Decide shape consists of a Rule block and an Else block. Within the Rule block, you must specify the condition and then include orchestration shapes to perform certain operations if the condition is met. Within the Else block, you must include orchestration shapes to perform certain operations if the condition is not met.

The preceding recommendations are described in detail in Processing Notification Messages to Perform Specific Tasks.

See Also

Other Resources

Receiving Database Change Notifications Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Processing Notification Messages to Perform Specific Tasks

You can use the Oracle E-Business adapter to receive notifications for changes to the Oracle database tables. However, the adapter only sends you a notification that some records were inserted, updated, or deleted in a certain database table. Any post-processing on those records must be handled by the client applications themselves. This topic presents a scenario-based description on how to process the records in the table based on the kind of notification received from the Oracle database.

Scenarios for Performing Subsequent Actions After Receiving Notification

Following are a couple of scenarios in which the adapter clients must perform certain post-notification tasks.

  • Scenario 1. Consider a scenario where the adapter client must perform certain tasks based on the kind of notification you receive from the Oracle database. For example, the client application must update the records in table “A” if records are inserted in table “B”. Similarly, the client application must delete records from table “A” if records are deleted from table “B”.

    In this scenario, from the notification message received, the adapter clients must extract the type of notification to decide whether the notification was for an insert operation or a delete operation. Once the notification type is ascertained, the adapter clients must perform subsequent actions to insert or update the relevant tables.

  • Scenario 2. Consider a scenario where the receive location that receives notification messages for changes to a table goes down. While the receive location is down, some records are added to the table. However, for these records the adapter client does not receive any notification. When the receive location is back up, the adapter notifies the client by sending a specific message, and then the client application must look for all the records that were inserted in the database table while the receive location was down.

    In this scenario, from the notification message received, the adapter clients must extract the information regarding whether the notification is for a change to a database table or for the receive location starting. If the notification is for the receive location starting, the adapter clients must implement the logic to process the records that might have been inserted, updated, or deleted while the receive location was down.

Note
These are just some example scenarios that are listed for a better understanding of how to use the notification feature in the Oracle E-Business adapter. However, the basic set of tasks required to extract the type of notification received will be similar for all scenarios. This topic provides instructions on how to extract the type of notification from a notification message.

How This Topic Demonstrates Receiving Notification Messages

In this topic, to demonstrate how to process notification messages to perform subsequent tasks, we consider a basic scenario where an adapter client uses BizTalk application to receive notification messages for changes to the ACCOUNTACTIVITY table. After the notification is received, the client filters the type of notification received and performs subsequent action. To demonstrate a very basic scenario, let us consider that the adapter client copies the notification messages to different folders based on the kind of notification received. Therefore:

  • If the notification message is for an Insert or Update operation, the adapter client copies the message to C:\TestLocation\UpsertNotification folder.

  • If the notification message is for any other operation, for example Delete, the adapter client copies the message to C:\TestLocation\OtherNotificaiton folder.

To achieve this as part of a BizTalk application, the orchestration must contain the following:

  • A one-way receive port to receive notification messages.

  • An Expression shape that contains an xpath query to extract the information about the kind of notification message received.

  • A Decide shape to include a decision block in the orchestration. In this decision block, the application decides on what subsequent operations to perform based on the notification message received.

  • Two one-way send ports that finally receive the notification messages.

Configuring Notifications with the Oracle E-Business Adapter Binding Properties

The following table summarizes the Oracle E-Business adapter binding properties that you use to configure receiving notifications from Oracle E-Business Suite. You must specify these binding properties when configuring the receive port in the BizTalk Server Administration console.

Note
You may choose to specify these binding properties when generating the schema for the Notification operation, even though it is not mandatory. If you do so, the port binding file that the Consume Adapter Service Add-in generates as part of the metadata generation also contains the values you specify for the binding properties. You can later import this binding file in the BizTalk Server Administration console to create the WCF-custom or WCF-OracleEBS receive port with the binding properties already set. For more information about creating a WCF-custom or WCF-OracleEBS port using the binding file, see Configuring a Physical Port Binding Using a Port Binding File.

Binding Property | Description
InboundOperationType | Specifies the inbound operation that you want to perform. To receive notification messages, set this to Notification.
NotificationPort | Specifies the port number that ODP.NET must open to listen for database change notification from Oracle database.
NotificationStatement | Specifies the SELECT statement used to register for query notifications. The adapter gets a notification message only when the result set for the specified SELECT statement changes.
NotifyOnListenerStart | Specifies whether the adapter sends a notification to the adapter clients when the listener is started.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to receive notifications from Oracle E-Business Suite, read further.

How to Receive Notification Messages from Oracle E-Business Suite

Performing an operation on Oracle E-Business Suite using the Oracle E-Business adapter with BizTalk Server involves the procedural tasks described in Building Blocks for Developing BizTalk Applications. To configure the adapter to receive notification messages, these tasks are:

  1. Create a BizTalk project, and then generate schema for the Notification inbound operation. Optionally, you can specify values for the InboundOperationType, NotificationPort, and NotificationStatement binding properties.

  2. Create a message in the BizTalk project for receiving notification from Oracle E-Business Suite.

  3. Create an orchestration as described in the preceding section.

  4. Build and deploy the BizTalk project.

  5. Configure the BizTalk application by creating physical send and receive ports.

    Note
    For inbound operations, like receiving notification messages, you must only configure a one-way WCF-Custom or WCF-OracleEBS receive port. Two-way receive ports are not supported for inbound operations.

  6. Start the BizTalk application.

This topic provides instructions to perform these tasks.

Generating Schema

You must generate the schema for the Notification inbound operation. For more information about how to generate the schema, see Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio.

Perform the following tasks when generating the schema. Skip the first step if you do not want to specify the binding properties at design-time.

  1. Specify a value for InboundOperationType, NotificationPort, and NotificationStatement binding properties while generating the schema. For more information about this binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For instructions on how to specify binding properties, see Specifying Binding Properties.

  2. Select the contract type as Service (Inbound operations).

  3. Generate schema for the Notification operation.

Defining Messages and Message Types

The schema that you generated in the previous section describes the "types" required for the messages in the orchestration. A message is typically a variable, the type for which is defined by the corresponding schema. After the schema is generated, you must link it to the messages from the Orchestration view of the BizTalk project.

For this topic, you must create one message to receive notifications from the Oracle database.

Perform the following steps to create messages and link them to schema.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From the Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration and then click Add.

  2. Open the orchestration view window of the BizTalk project, if it is not already open. Click View, point to Other Windows, and then click Orchestration View.

  3. In the Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for Message_1, do the following:

    Use this To do this

    Identifier

    Type NotifyReceive.

    Message Type

    From the drop-down list, expand Schemas, and select Process_Notification.OracleEBSBinding.Notification, where Process_Notification is the name of your BizTalk project. OracleEBSBinding is the schema generated for the Notification operation.

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for receiving notification messages from the Oracle database and then performing tasks based on the type of notification received. In this orchestration, the adapter receives the notification message based on the SELECT statement specified for the NotificationStatement binding property. The xpath query specified within the Expression shape extracts the type of notification into a variable, say NotificationType. The Decide shape uses the value in this variable to decide on the kind of notification received and takes the appropriate “path” to perform subsequent operations. As mentioned in the preceding section, the orchestration will perform the following operations based on the kind of notification message received.

  • If the notification message is for an Insert or Update operation, the adapter client copies the message to C:\TestLocation\UpsertNotification folder.

  • If the notification message is for any other operation, for example Delete, the adapter client copies the message to C:\TestLocation\OtherNotificaiton folder.

So, your orchestration must contain the following:

  • A one-way receive port to receive notification messages.

  • An Expression shape that contains an xpath query to extract the kind of notification received.

  • A Decide shape to include a decision block in the orchestration. In this decision block, the application decides on what subsequent operations to perform based on the notification message received.

  • Two one-way send ports that finally receive the notification messages.

  • Receive shape.

A sample orchestration resembles the following:

Orchestration to perform post-notification task

Adding Message Shapes

Make sure you specify the following properties for each of the message shapes. The names listed in the Shape column are the names of the message shapes as displayed in the orchestration diagram.

Shape Shape Type Properties

ReceiveNotification

Receive

  • Set Name to ReceiveNotification

  • Set Activate to True

Adding an Expression Shape

The purpose of including an Expression shape in the orchestration is to have an xpath query to extract the kind of notification message received. Before creating an xpath query, let us look at the format of a notification message. A typical notification message resembles the following:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Details>
    <NotificationDetails>
      <ResourceName>SCOTT.ACCOUNTACTIVITY</ResourceName>
      <Info>1</Info>
      <QueryId>0</QueryId>
    </NotificationDetails>
  </Details>
  <Info>Insert</Info>
  <ResourceNames>
    <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/Arrays">SCOTT.ACCOUNTACTIVITY</string>
  </ResourceNames>
  <Source>Data</Source>
  <Type>Change</Type>
</Notification>

As you see, the information about the type of the notification is available within the <info> tag, within the parent <Notification> tag. So, as part of this expression shape you must:

  • Create a variable that contains the value within the <Info> tag and set its type to System.String. For more information about creating variables, see http://go.microsoft.com/fwlink/?LinkId=102357.

    For this topic, name the variable as NotificationType.

  • Create an xpath query to extract the value from the <Info> tag. The xpath query will resemble the following:

    Copy Code
    NotificationType = xpath(NotifyReceive,"string(/*[local-name()='Notification']/*[local-name()='Info']/text())");
    In this xpath query, NotifyReceive is the message you created for receiving notification messages. The excerpt within the string function indicates that the query must extract the value within the <Info> tag, which in turn is within the <Notification> tag. Finally, the value extracted by the query is assigned to the NotificaitonType variable.

Adding a Decide Shape

The purpose of adding a Decide shape is to include a decision block in the orchestration to decide what subsequent operations to perform based on the kind of notification message received. The decision is made on the basis of the value of the NotificationType variable. In this topic, the orchestration makes a decision based on the kind of notification message received. So, the condition in the Rule shape is specified as follows:

Copy Code
NotificationType.Equals("Insert") | NotificationType.Equals("Update")

This condition suggests that if the value for NotificaitonType variable is Insert or Update, the orchestration will perform one set of tasks. If the value of NotificationType variable is anything else, the orchestration will perform other set of tasks.

As mentioned in the preceding sections, to demonstrate a simple approach, the orchestration will copy messages to different folders based on the notification message type. So, within the Rule and Else blocks, you must add Send shapes to send the messages to different ports. For this topic, name the Send shape in the Rule block as SendUpsertNotification and the Send shape in the Else block as SendOtherNotification.

Adding Ports

You must now add the following logical ports to the orchestration:

  • One-way receive port to receive notification messages from the Oracle database.

  • One-way send port to send notification messages for Insert and Update operations to a specific folder.

  • One-way send port to send notification messages for any other operations to a specific folder.

Make sure you specify the following properties for each of the logical ports. The names listed in the Port column are the names of the ports as displayed in the orchestration diagram shown earlier in this topic.

Port Properties

OracleNotifyPort

  • Set Identifier to OracleNotifyPort

  • Set Type to OracleNotifyPortType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

NotificationUpsertPort

  • Set Identifier to NotificationUpsertPort

  • Set Type to NotificationUpsertPortType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

OtherNotificationPort

  • Set Identifier to OtherNotificationPort

  • Set Type to OtherNotificationPortType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

Specify Messages for Action Shapes and Connect to Ports

The following table specifies the properties and their values that you should set to specify messages for action shapes and to link the messages to the ports. The names listed in the Shape column are the names of the message shapes as displayed in the orchestration diagram shown earlier in this topic.

Shape Properties

ReceiveNotification

  • Set Message to NotifyReceive

  • Set Operation to OracleNotifyPort.Notify.Request

SendUpsertNotification

  • Set Message to NotifyReceive

  • Set Operation to NotificationUpsertPort.Upsert.Request

SendOtherNotification

  • Set Message to Select

  • Set Operation to OtherNotificationPort.Other.Request

After you have specified these properties, the message shapes and ports are connected and your orchestration is complete.

You must now build the BizTalk solution and deploy it to a BizTalk Server. For more information, see "Building and Running Orchestrations" at http://go.microsoft.com/fwlink/?LinkId=102359.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see "How to Configure an Application" at http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a physical WCF-Custom or WCF-OracleEBS one-way receive port. This port listens for notifications coming from Oracle E-Business Suite. For information about how to create receive ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter. Make sure you specify the following binding properties for the receive port.

      Important
      You do not need to perform this step if you specified the binding properties at design-time. In such a case, you can create a WCF-custom or WCF-OracleEBS receive port, with the required binding properties set, by importing the binding file created by the Consume Adapter Service Add-in. For more information see Configuring a Physical Port Binding Using a Port Binding File.

      Binding Property Value

      InboundOperationType

      Set this to Notification.

      NotificationPort

      Specifies the port number that ODP.NET must open to listen for database change notification from Oracle database. Set this to the same port number that you must have added to the Windows Firewall exceptions list. For instructions on how to add ports to Windows Firewall exceptions list, see http://go.microsoft.com/fwlink/?LinkID=196959.

      Important
      If you set this to the default value of -1, you will have to completely disable Windows Firewall to receive notification messages.

      NotificationStatement

      Set this to:

      Copy Code
      SELECT TID,ACCOUNT,PROCESSED FROM SCOTT.ACCOUNTACTIVITY WHERE PROCESSED = ‘n’
      Note
      You must specify the table name along with the schema name. For example, SCOTT.ACCOUNTACTIVITY.

      NotifyOnListenerStart

      Set this to True.

      For more information about the different binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

      Important
      If you are configuring notifications for an interface table, you must set the application context by specifying the requisite binding properties. For more information about setting the application context see Setting Application Context.

      Note
      We recommend configuring the transaction isolation level and the transaction timeout while performing inbound operations using the Oracle E-Business adapter. You can do so by adding the service behavior while configuring the WCF-Custom or WCF-OracleEBS receive port. For instruction on how to add the service behavior, see Configure Transaction Isolation Level and Transaction Timeout.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the notification messages from the Oracle database for Insert and Update operations. Configure this port to drop notification messages to the folder C:\TestLocation\UpsertNotification.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the notification messages from the Oracle database for all other operations. Configure this port to drop notification messages to the folder C:\TestLocation\OtherNotification.

Starting the Application

You must start the BizTalk application for receiving notification messages from the Oracle database and for performing the subsequent Select and Update operations. For instructions on starting a BizTalk application, see “How to Start an Orchestration” at http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The WCF-Custom or WCF-OracleEBS one-way receive port, which receives the notification messages from the Oracle database is running.

  • The two FILE send ports, which receive messages from Oracle database, are running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

After you start the BizTalk orchestration, the following set of actions take place:

  • Because the NotifyOnListenerStart binding property is set to True, you receive the following message:

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Info>ListenerStarted</Info>
  <Source>OracleEBSBinding</Source>
  <Type>Startup</Type>
</Notification>
    Note that the value in the <Info> tag is “ListnerStarted”. Hence, this message is received in C:\TestLocation\OtherNotification folder.

  • Insert a record in the ACCOUNTACTIVITY table. You will receive a notification message resembling the following:

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Details>
    <NotificationDetails>
      <ResourceName>SCOTT.ACCOUNTACTIVITY</ResourceName>
      <Info>1</Info>
      <QueryId>0</QueryId>
    </NotificationDetails>
  </Details>
  <Info>Insert</Info>
  <ResourceNames>
    <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/Arrays">SCOTT.ACCOUNTACTIVITY</string>
  </ResourceNames>
  <Source>Data</Source>
  <Type>Change</Type>
</Notification>
    Note that the value in the <Info> tag is “Insert”. Hence, this message is received in C:\TestLocation\UpsertNotification folder.

  • Update a record in the ACCOUNTACTIVITY table. You will receive a notification message resembling the following:

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Details>
    <NotificationDetails>
      <ResourceName>SCOTT.ACCOUNTACTIVITY</ResourceName>
      <Info>32</Info>
      <QueryId>0</QueryId>
    </NotificationDetails>
  </Details>
  <Info>Update</Info>
  <ResourceNames>
    <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/Arrays">SCOTT.ACCOUNTACTIVITY</string>
  </ResourceNames>
  <Source>Data</Source>
  <Type>Change</Type>
</Notification>
    Note that the value in the <Info> tag is “Update”. Hence, this message is received in C:\TestLocation\UpsertNotification folder.

  • Delete a record from the ACCOUNTACTIVITY table. You will receive a notification message resembling the following:

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Details>
    <NotificationDetails>
      <ResourceName>SCOTT.ACCOUNTACTIVITY</ResourceName>
      <Info>16</Info>
      <QueryId>0</QueryId>
    </NotificationDetails>
  </Details>
  <Info>Delete</Info>
  <ResourceNames>
    <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/Arrays">SCOTT.ACCOUNTACTIVITY</string>
  </ResourceNames>
  <Source>Data</Source>
  <Type>Change</Type>
</Notification>
    Note that the value in the <Info> tag is “Delete”. Hence, this message is received in C:\TestLocation\OtherNotification folder.

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. Once you generate a binding file, you can import the configuration settings from the file, so that you do not need to create the send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

Performing Complex Operations After Receiving Notification Messages

For simplicity and better understanding, the orchestration in this topic copies messages to different folders based on the notification type. However, in real-world scenarios you might want to perform more complex operations. You can perform similar procedures as provided in this topic and build on them to perform the operations you wish. For example, you can change the orchestration to insert records in another table if you get a notification message for an Insert operation on the ACCOUNTACTIVITY table. In such a case, you can make appropriate changes within the Decide shape.

See Also

Other Resources

Receiving Database Change Notifications Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Receiving Database Change Notifications Incrementally Using BizTalk Server
Important
For the sake of brevity, this topic only describes how to receive notifications incrementally. In business scenarios, the orchestration must ideally include the logic to extract the kind of notification message received and then perform any subsequent operations. In other words, the orchestration described in this topic must be built on top of the orchestration described in Processing Notification Messages to Perform Specific Tasks.

This topic demonstrates how to configure the Oracle E-Business adapter to receive incremental query notification messages from Oracle. To demonstrate incremental notifications, we consider a table, ACCOUNTACTIVITY, with a “Processed” column. When a new record is inserted to this table, the value of the “Processed” column is set to ‘n’. You can configure the adapter to receive incremental notifications by doing the following:

  • Register for notifications using a SELECT statement that retrieves all records that have “Processed” column as ‘n’. You can do so by specifying the SELECT statement for the NotificationStatement binding property.

  • For rows which have been notified for, update the “Processed” column to ‘y’.

This topic demonstrates how to create a BizTalk orchestration and configure a BizTalk application to achieve this.

Configuring Notifications with the Oracle E-Business Adapter Binding Properties

The table below summarizes the Oracle E-Business adapter binding properties that you use to configure receiving notifications from Oracle E-Business Suite. You must specify these binding properties while configuring the receive port in the BizTalk Server Administration console.

Note
You may choose to specify these binding properties when generating the schema for the Notification operation, even though it is not mandatory. If you do so, the port binding file that the Consume Adapter Service Add-in generates as part of the metadata generation also contains the values you specify for the binding properties. You can later import this binding file in the BizTalk Server Administration console to create the WCF-custom or WCF-OracleEBS receive port with the binding properties already set. For more information about creating a receive port using the binding file, see Configuring a Physical Port Binding Using a Port Binding File.

Binding Property | Description
InboundOperationType | Specifies the inbound operation that you want to perform. To receive notification messages, set this to Notification.
NotificationPort | Specifies the port number that ODP.NET must open to listen for database change notification from Oracle database.
NotificationStatement | Specifies the SELECT statement used to register for query notifications. The adapter gets a notification message only when the result set for the specified SELECT statement changes.
NotifyOnListenerStart | Specifies whether the adapter sends a notification to the adapter clients when the listener is started.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to receive notifications from Oracle E-Business Suite, read further.

How This Topic Demonstrates Receiving Notification Messages

In this topic, to demonstrate how the Oracle E-Business adapter supports receiving incremental database change notification messages from Oracle E-Business Suite, we will configure the adapter to receive notifications for changes to the ACCOUNTACTIVTY table. Let us assume that the ACCOUNTACTIVITY table has columns “TID”, “Account”, and “Processed”. Whenever a new record is added, the value of the “Processed” column is set to ‘n’. So, to get incremental notifications you will have to do the following tasks as part of the BizTalk orchestration:

  • Get notification for all records where “Processed” is ‘n’. You can do this by specifying a SELECT statement as a notification statement.

  • After the notification is received for a certain record, set “Processed” to ‘y’. You can do this by executing a stored procedure, PROCESS_RECORDS, which updates the “Processed” column.

To demonstrate receiving incremental notifications, we do the following:

  • Generate schema for the Notification (inbound operation), and PROCESS_RECORDS (outbound operation) on the ACCOUNTACTIVITY table.

  • Create an orchestration that has the following:

    • A receive location to receive notification messages. You can configure for notification by specifying the SELECT statement as:

      Copy Code
      SELECT TID,ACCOUNT,PROCESSED FROM SCOTT.ACCOUNTACTIVITY WHERE PROCESSED = ‘n’
      Note
      You must specify the table name along with the schema name. For example, SCOTT.ACCOUNTACTIVITY.

    • A send port to update the rows for which notification has already been sent. You will execute the PROCESS_RECORDS stored procedure on this port to set the value of “Processed” column to ‘y’ for the records for which notification is received.

      Note that this operation must be executed after receiving the notification messages so that the processed rows are updated. To do away with the overhead of waiting to get the notification response and then manually dropping a request message to execute the PROCESS_RECORDS procedure, you will generate the request message for PROCESS_RECORDS procedure within the orchestration itself. You can do so by using the Construct Message shape within an orchestration.

How to Receive Notification Messages from Oracle E-Business Suite

Performing an operation on Oracle E-Business Suite using Oracle E-Business adapter with BizTalk Server involves the procedural tasks described in Building Blocks for Developing BizTalk Applications. To configure the adapter to receive notification messages, these tasks are:

  1. Create a BizTalk project, and then generate schema for the Notification (inbound operation) and PROCESS_RECORDS procedure (outbound operation) on the ACCOUNTACTIVITY table. Optionally, you can specify values for the InboundOperationType, NotificationPort, and NotificationStatement binding properties.

  2. Create a message in the BizTalk project for receiving notification from Oracle E-Business Suite.

  3. Create messages in the BizTalk project for executing the PROCESS_RECORDS stored procedure and receiving response messages.

  4. Create an orchestration that does the following:

    • Receives notification message from Oracle E-Business Suite.

    • Creates a message to execute the PROCESS_RECORDS procedure.

    • Sends this message to Oracle E-Business Suite to select and update the records and receive a response.

  5. Build and deploy the BizTalk project.

  6. Configure the BizTalk application by creating physical send and receive ports.

    Note
    For inbound operations, like receiving notification messages, you must only configure a one-way WCF-Custom or WCF-OracleEBS receive port. Two-way receive ports are not supported for inbound operations.

  7. Start the BizTalk application.

This topic provides instructions to perform these tasks.

Generating Schema

You must generate the schema for the Notification operation and PROCESS_RECORDS procedure. See Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio for more information about how to generate the schema. Perform the following tasks when generating the schema. Skip the first step if you do not want to specify the binding properties at design-time.

  1. Specify a value for InboundOperationType, NotificationPort, and NotificationStatement binding properties while generating the schema. For more information about this binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For instructions on how to specify binding properties, see Specifying Binding Properties.

  2. Select the contract type as Service (Inbound operations).

  3. Generate schema for the Notification operation.

  4. Select the contract type as Client (Outbound operations).

  5. Generate schema for the PROCESS_RECORDS procedure. This procedure is available under the ACCOUNT_PKG package.

Defining Messages and Message Types

The schema that you generated earlier describes the "types" required for the messages in the orchestration. A message is typically a variable, the type for which is defined by the corresponding schema. Once the schema is generated, you must link it to the messages from the Orchestration view of the BizTalk project.

For this topic, you must create three messages—one to receive notifications from the Oracle E-Business Suite, one to execute the PROCESS_RECORDS procedure, and one to receive the response for the procedure.

Perform the following steps to create messages and link them to schema.

To create messages and link to schema

  1. Add an orchestration to the BizTalk project. From the Solution Explorer, right-click the BizTalk project name, point to Add, and then click New Item. Type a name for the BizTalk orchestration and then click Add.

  2. Open the orchestration view window of the BizTalk project, if it is not already open. Click View, point to Other Windows, and then click Orchestration View.

  3. In the Orchestration View, right-click Messages, and then click New Message.

  4. Right-click the newly created message, and then select Properties Window.

  5. In the Properties pane for Message_1, do the following:

    Use this To do this

    Identifier

    Type NotifyReceive.

    Message Type

    From the drop-down list, expand Schemas, and select OracleNotifyIncremental.OracleEBSBinding.Notification, where OracleNotifyIncremental is the name of your BizTalk project. OracleEBSBinding is the schema generated for the Notification operation.

  6. Repeat step 3 to create two new messages. In the Properties pane for the new message, do the following:

    Set Identifier to Set Message Type to

    Procedure

    OracleNotifyIncremental.OracleEBSBinding1.PROCESS_RECORDS, where OracleEBSBinding1 is the schema generated for the PROCESS_RECORDS procedure.

    ProcedureResponse

    OracleNotifyIncremental.OracleEBSBinding1.PROCESS_RECORDSResponse

Setting up the Orchestration

You must create a BizTalk orchestration to use BizTalk Server for receiving notification messages from Oracle E-Business Suite and then updating the rows for which notification was received. In this orchestration, the adapter receives the notification message based on the SELECT statement specified for the NotificationStatement binding property. The notification message is received at a FILE location. Once the response is received, the orchestration constructs a message to invoke the PROCESS_RECORDS procedure, which updates the rows for which notification is received. The response for this message is also received at the same FILE location.

So, your orchestration must contain the following:

  • A one-way WCF-Custom or WCF-OracleEBS receive port to receive notification messages.

  • A two-way WCF-Custom or WCF-OracleEBS send port to send messages to execute the PROCESS_RECORDS procedure.

  • A Construct Message shape to construct messages, to execute PROCESS_RECORDS procedure, within the orchestration.

  • A FILE send port to save the notification message and the response for the PROCESS_RECORDS procedure.

  • Receive and send shapes.

A sample orchestration resembles the following.

Orchestration to receive notifications from Oracle

Adding Message Shapes

Make sure you specify the following properties for each of the message shapes. The names listed in the Shape column are the names of the message shapes as displayed in the just-mentioned orchestration.

Shape Shape Type Properties

ReceiveNotification

Receive

  • Set Name to ReceiveNotification

  • Set Activate to True

SaveNotification

Send

  • Set Name to SaveNotification

SendProcMessage

Send

  • Set Name to SendProcMessage

ReceiveProcResponse

Receive

  • Set Name to ReceiveProcResponse

SaveProcResponse

Send

  • Set Name to SaveProcResponse

Adding Construct Message Shape

You can use the Construct Message shape to generate a request message within the orchestration to execute the PROCESS_RECORDS procedure. To do so, you must add a Construct Message shape and within that a Message Assignment shape to your orchestration. For this example, the Message Assignment shape invokes code that generates a message that is sent to Oracle E-Business Suite to execute the procedure. The Message Assignment shape also sets the action for the message to be sent to Oracle E-Business Suite.

For the construct message shape, set the Message Constructed property to Procedure.

The code to generate the response could be part of the same Visual Studio solution as your BizTalk project. A sample code for generating a response message looks like this.

Copy Code
namespace MessageCreator
{
    public class MessageCreator
    {
        private static XmlDocument Message;
        private static string XmlFileLocation;
        private static string ResponseDoc;

        public static XmlDocument XMLMessageCreator()
        {
            XmlFileLocation = "C:\\TestLocation\\MessageIn";
            try
            {
                ResponseDoc = (Directory.GetFiles(XmlFileLocation, "*.xml", SearchOption.TopDirectoryOnly))[0];
            }
            catch (Exception ex)
            {
                Console.WriteLine("Trying to get XML from: " + XmlFileLocation);
                Console.WriteLine("EXCEPTION: " + ex.ToString());
                throw ex;
            }
            //Create Message From XML
            Message = new XmlDocument();
            Message.PreserveWhitespace = true;
            Message.Load(ResponseDoc);
            return Message;
        }
    }
}

For the above code excerpt to be able to generate a request message, you must have an XML request message (for the PROCESS_RECORDS procedure) in the location specified for the XmlFileLocation variable.

Note
After you build the project, MessageCreator.dll will be created in the project directory. You must add this DLL to the global assembly cache (GAC). Also, you must add the MessageCreator.dll as a reference in the BizTalk project.

Add the following expression to invoke this code from the Message Assignment shape and to set the action for message. To add an expression, double-click the Message Assignment shape to open the Expression Editor.

Copy Code
Procedure = MessageCreator.MessageCreator.XMLMessageCreator();
Procedure(WCF.Action) = "PackageApis/SCOTT/ACCOUNT_PKG/PROCESS_RECORDS";

Adding Ports

Make sure you specify the following properties for each of the logical ports. The names listed in the Port column are the names of the ports as displayed in the orchestration.

Port Properties

OracleNotifyPort

  • Set Identifier to OracleNotifyPort

  • Set Type to OracleNotifyPortType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Receive

SaveMessagePort

  • Set Identifier to SaveMessagePort

  • Set Type to SaveMessagePortType

  • Set Communication Pattern to One-Way

  • Set Communication Direction to Send

  • Create an operation Notify. This operation is used for notification messages.

  • Create an operation Procedure. This operation is used for select response messages.

OracleOutboundPort

  • Set Identifier to OracleOutboundPort

  • Set Type to OracleOutboundPortType

  • Set Communication Pattern to Request-Response

  • Set Communication Direction to Send-Receive

Specify Messages for Action Shapes and Connect to Ports

The following table specifies the properties and their values that you should set to specify messages for action shapes and to link the messages to the ports. The names listed in the Shape column are the names of the message shapes as displayed in the orchestration mentioned earlier.

Shape Properties

ReceiveNotification

  • Set Message to NotifyReceive

  • Set Operation to OracleNotifyPort.Notify.Request

SaveNotification

  • Set Message to NotifyReceive

  • Set Operation to SaveMessagePort.Notify.Request

SendProcMessage

  • Set Message to Procedure

  • Set Operation to OracleOutboundPort.Procedure.Request

ReceiveProcResponse

  • Set Message to ProcedureResponse

  • Set Operation to OracleOutboundPort.Procedure.Response

SaveProcResponse

  • Set Message to ProedureResponse

  • Set Operation to SaveMessagePort.Procedure.Request

After you have specified these properties, the message shapes and ports are connected and your orchestration is complete.

You must now build the BizTalk solution and deploy it to a BizTalk Server. For more information, see "Building and Running Orchestrations" at http://go.microsoft.com/fwlink/?LinkId=102359.

Configuring the BizTalk Application

After you have deployed the BizTalk project, the orchestration you created earlier is listed under the Orchestrations pane in the BizTalk Server Administration console. You must use the BizTalk Server Administration console to configure the application. For more information about configuring an application, see "How to Configure an Application" at http://go.microsoft.com/fwlink/?LinkID=196961.

Configuring an application involves:

  • Selecting a host for the application.

  • Mapping the ports that you created in your orchestration to physical ports in the BizTalk Server Administration console. For this orchestration you must:

    • Define a physical WCF-Custom or WCF-OracleEBS one-way receive port. This port listens for notifications coming from Oracle E-Business Suite. For information about how to create receive ports, see Manually Configuring a Physical Port Binding to the Oracle E-Business Adapter. Make sure you specify the following binding properties for the receive port.

      Important
      You do not need to perform this step if you specified the binding properties at design-time. In such a case, you can create a receive port, with the required binding properties set, by importing the binding file created by the Consume Adapter Service Add-in. For more information see Configuring a Physical Port Binding Using a Port Binding File.

      Binding Property Value

      InboundOperationType

      Set this to Notification.

      NotificationPort

      Specifies the port number that ODP.NET must open to listen for database change notification from Oracle database. Set this to the same port number that you must have added to the Windows Firewall exceptions list. For instructions on how to add ports to Windows Firewall exceptions list, see http://go.microsoft.com/fwlink/?LinkID=196959.

      Important
      If you set this to the default value of -1, you will have to completely disable Windows Firewall to receive notification messages.

      NotificationStatement

      Set this to:

      Copy Code
      SELECT TID,ACCOUNT,PROCESSED FROM SCOTT.ACCOUNTACTIVITY WHERE PROCESSED = ‘n’
      Note
      You must specify the table name along with the schema name. For example, SCOTT.ACCOUNTACTIVITY.

      NotifyOnListenerStart

      Set this to True.

      For more information about the different binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

      Important
      If you are configuring notifications for an interface table, you must set the application context by specifying the requisite binding properties. For more information about setting the application context see Setting Application Context.

      Note
      We recommend configuring the transaction isolation level and the transaction timeout while performing inbound operations using the Oracle E-Business adapter. You can do so by adding the service behavior while configuring the WCF-Custom or WCF-OracleEBS receive port. For instruction on how to add the service behavior, see Configure Transaction Isolation Level and Transaction Timeout.

    • Define a physical WCF-Custom or WCF-OracleEBS send port to send messages to Oracle E-Business Suite to execute the PROCESS_REOCRDS procedure. You must also specify the action in the send port.

    • Define a location on the hard disk and a corresponding file port where the BizTalk orchestration will drop the messages from Oracle E-Business Suite. These will be the notification messages received from Oracle E-Business Suite and messages for the PROCESS_RECORDS procedure you execute through the WCF-Custom or WCF-OracleEBS send port.

Starting the Application

You must start the BizTalk application for receiving notification messages from Oracle E-Business Suite and for executing the PROCESS_RECORDS procedure. For instructions on starting a BizTalk application, see “How to Start an Orchestration” at http://go.microsoft.com/fwlink/?LinkId=102387.

At this stage, make sure:

  • The WCF-Custom or WCF-OracleEBS one-way receive port, which receives the notification messages from Oracle E-Business Suite is running.

  • The WCF-Custom or WCF-OracleEBS send port to execute the PROCESS_RECORDS procedure is running.

  • The FILE send port, which receives messages from Oracle E-Business Suite, is running.

  • The BizTalk orchestration for the operation is running.

Executing the Operation

Assume that the ACCOUNTACTIVITY table already has some records. Also, make sure the XML message to execute PROCESS_RECORDS procedure is available at C:\TestLocation\MessageIn. The XML file should resemble the following:

Copy Code
<PROCESS_RECORDS xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/SCOTT/ACCOUNT_PKG" />

Once the BizTalk orchestration is started, the following set of actions take place, in the same sequence:

  • The adapter receives a notification message that resembles the following:

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Info>ListenerStarted</Info>
  <Source>OracleEBSBinding</Source>
  <Type>Startup</Type>
</Notification>
    This message notifies that the receive port for receiving the notification messages is started. Note that the value for the <Info> element is “ListnerStarted”.

  • The adapter executes the PROCESS_RECORDS procedure. The next response from Oracle E-Business Suite is for the procedure.

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<PROCESS_RECORDSResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/SCOTT/ACCOUNT_PKG">
  <TABLE_DATA>
    <xs:schema id="NewDataSet" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
      <xs:element msdata:IsDataSet="true" name="NewDataSet">
        <xs:complexType>
          <xs:sequence>
            <xs:element minOccurs="0" maxOccurs="unbounded" name="NewTable">
              <xs:complexType>
                <xs:sequence>
                  <xs:element minOccurs="0" name="TID" type="xs:decimal" />
                  <xs:element minOccurs="0" name="ACCOUNT" type="xs:decimal" />
                  <xs:element minOccurs="0" name="PROCESSED" type="xs:string" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:schema>
    <diffgr:diffgram xmlns:diffgr="urn:schemas-microsoft-com:xml-diffgram-v1">
    <NewDataSet xmlns="">
      <NewTable>
        <TID>1</TID>
        <ACCOUNT>100001</ACCOUNT>
        <PROCESSED>n</PROCESSED>
      </NewTable>
      <NewTable>
        ......
        ......
      </NewTable>
      ......
      ......
    </NewDataSet>
    </diffgr:diffgram>
  </TABLE_DATA>
</PROCESS_RECORDSResponse>

    This is the response for the SELECT statement execute as part of the PROCESS_RECORDS procedure.

  • The PROCESS_RECORDS procedure also updates the rows to set PROCESSED to ‘y’. Hence, the adapter receives another notification for the Update operation.

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/">
  <Details>
    <NotificationDetails>
      <ResourceName>SCOTT.ACCOUNTACTIVITY</ResourceName>
      <Info>32</Info>
      <QueryId>0</QueryId>
    </NotificationDetails>
  </Details>
  <Info>Update</Info>
  <ResourceNames>
    <string xmlns="http://schemas.microsoft.com/2003/10/Serialization/Arrays">SCOTT.ACCOUNTACTIVITY</string>
  </ResourceNames>
  <Source>Data</Source>
  <Type>Change</Type>
</Notification>
    Note that the Info element contains “Update”.

  • After the second notification, the adapter again executes the PROCESS_RECORDS procedure. However, now because there are no records where PROCESSED column is set to ‘n’, the procedure returns an empty response resembling the following.

    Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<PROCESS_RECORDSResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/SCOTT/ACCOUNT_PKG">
  <TABLE_DATA>
    <xs:schema id="NewDataSet" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:msdata="urn:schemas-microsoft-com:xml-msdata">
      <xs:element msdata:IsDataSet="true" name="NewDataSet">
        <xs:complexType>
          <xs:sequence>
            <xs:element minOccurs="0" maxOccurs="unbounded" name="NewTable">
              <xs:complexType>
                <xs:sequence>
                  <xs:element minOccurs="0" name="TID" type="xs:decimal" />
                  <xs:element minOccurs="0" name="ACCOUNT" type="xs:decimal" />
                  <xs:element minOccurs="0" name="PROCESSED" type="xs:string" />
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:schema>
    <diffgr:diffgram xmlns:diffgr="urn:schemas-microsoft-com:xml-diffgram-v1">
      <NewDataSet xmlns="" />
    </diffgr:diffgram>
  </TABLE_DATA>
</PROCESS_RECORDSResponse>

Best Practices

After you have deployed and configured the BizTalk project, you can export configuration settings to an XML file called the binding file. Once you generate a binding file, you can import the configuration settings from the file, so that you do not need to create the send ports and receive ports for the same orchestration. For more information about binding files, see Reusing Adapter Bindings.

See Also

Other Resources

Receiving Database Change Notifications Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Receiving Database Change Notifications On Multiple Receive Locations

Consider a scenario where you have multiple receive locations created as part of different BizTalk applications configured to receive query notifications for the same table (e.g. ACCOUNTACTIVITY) in the same database. If a hundred records are inserted into the same table, all the receive locations will get the notification message. To effectively receive notifications across multiple receive locations, you can call operations from your BizTalk application in such a way that if a notification is received by one receive location, the other receive location does not get the same notification. So, you can effectively load-balance notifications received on multiple locations.

The tasks required to set up an orchestration to load-balance receiving notifications are same as that for Receiving Database Change Notifications Incrementally Using BizTalk Server. This topic lists the only the difference between the two approaches.

Load-Balancing Query Notifications Across Multiple Receive Locations

Like in the topic Receiving Database Change Notifications Incrementally Using BizTalk Server, you configured incremental notifications by executing a PROCESS_RECORDS procedure. To configure load-balancing, you could execute a stored procedure that deletes the records that have been notified for. For example, consider a stored procedure NOTIFY_LOAD_BALANCE with the following definition:

Copy Code
PROCEDURE NOTIFY_LOAD_BALANCE (TABLE_DATA OUT SYS_REFCURSOR) IS
  var int;
BEGIN
  SELECT TID INTO var FROM ACCOUNTACTIVITY WHERE ROWNUM = 1 FOR UPDATE;
  OPEN TABLE_DATA FOR SELECT * FROM ACCOUNTACTIVITY WHERE TID = var;
  DELETE FROM ACCOUNTACTIVITY WHERE TID = var;
END NOTIFY_LOAD_BALANCE;

When you execute this stored procedure as part of the BizTalk application, the record for which notification is already received gets deleted. So, the other receive location gets notification for the next record.

Here are the high-level steps you must perform to configure load-balancing for receiving notifications.

  1. Create schema for Notification (inbound operation) and NOTIFY_LOAD_BALANCE procedure (outbound operation).

  2. Add an orchestration and add three messages for receiving notification, executing the procedure, and getting response for the procedure.

  3. Create an orchestration by adding Send and Receive shapes, Construct Message shape, and ports. You can use the same sample code for constructing a message to invoke the NOTIFY_LOAD_BALANCE stored procedure. Note that while performing the operation in BizTalk Server Administration console, you must have the request message for the NOTIFY_LOAD_BALANCE procedure in the location C:\TestLocation\MessageIn. You do so because the code snippet you invoke as part of the orchestration created in Receiving Database Change Notifications Incrementally Using BizTalk Server creates a request message based on the request XML present in C:\TestLocation\MessageIn.

  4. Build and deploy the application. To demonstrate load-balancing, you must deploy this orchestration at least on two different computers that have BizTalk Server and Oracle E-Business adapter installed.

  5. In the BizTalk Server Administration console on both the computers, specify the following binding properties for the WCF-Custom or WCF-OracleEBS receive location:

    Binding Property Value

    InboundOperationType

    Set this to Notification.

    NotificationPort

    Specifies the port number that ODP.NET must open to listen for database change notification from Oracle database. Set this to the same port number that you must have added to the Windows Firewall exceptions list. For instructions on how to add ports to Windows Firewall exceptions list, see http://go.microsoft.com/fwlink/?LinkID=196959.

    Important
    If you set this to the default value of -1, you will have to completely disable Windows Firewall to receive notification messages.

    NotificationStatement

    Set this to:

    Copy Code
    SELECT TID,ACCOUNT,PROCESSED FROM SCOTT.ACCOUNTACTIVITY WHERE PROCESSED = ‘n’
    Note
    You must specify the table name along with the schema name. For example, SCOTT.ACCOUNTACTIVITY.

    NotifyOnListenerStart

    Set this to True.

  6. Start the BizTalk application.

  7. To start receiving notifications, insert a hundred records into the ACCOUNTACTIVITY table. While doing so, make sure the request XML for invoking the NOTIFY_LOAD_BALANCE procedure is available in C:\TestLocation\MessageIn.

  8. Monitor the location (on both the computers) where the BizTalk application will be dropping the notification messages. You will notice that of the hundred records inserted, one location gets notifications for some records while the other location gets notification for the remaining records. Together, both the locations will get notification for all the hundred records.

See Also

Other Resources

Receiving Database Change Notifications Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Receiving Database Change Notifications After a Receive Location Breakdown

Consider a scenario where you have a BizTalk application that receives database change notification messages when changes are made to the ACCOUNTACTIVITY table. If the receive location configured as part of the BizTalk application breaks down, and simultaneously records are added into the ACCOUNTACTIVITY table, you will not receive notifications for the recently added records. You will also not know when the receive location is available again. The Oracle E-Business adapter exposes a binding property, NotifyOnListenerStart, that you can configure to get a notification that the receive location has recovered. You can specify the following values for the NotifyOnListenerStart binding property:

  • Set this property to True, to receive a notification informing that the receive location is available, as soon as the receive location recovers.

  • Set this property to False, to not receive a notification informing that the receive location is available, after the receive location recovers.

Default is True.

Configuring the Oracle E-Business Adapter Behavior

For either of the approaches, you do not need to perform any specific tasks while generating metadata or while configuring the BizTalk application. You only need to set the NotifyOnListenerStart binding property accordingly on the WCF-Custom or WCF-OracleEBS receive location. To create the BizTalk application, you must perform the same set of tasks as described in Receiving Database Change Notifications Incrementally Using BizTalk Server. However, when configuring the BizTalk application using BizTalk Server, you can try changing the value of NotifyOnListenerStart binding property and see the difference in the two configurations.

The following figure demonstrates how the notifications are received based on the value of the NotifyOnListenerStart binding property.

Configure SQL Adapter for notifications

Note that in the first scenario, when the NotifyOnListenerStart is set to True and records are inserted into the database table while the receive location was down, the adapter only sends you a notification message when the receive location comes up. The adapter does not perform any operation to process the records that were inserted while the receive location was down. The adapter client must implement the relevant logic in their application to process the records that were inserted while the receive location was down.

See Also

Other Resources

Receiving Database Change Notifications Using BizTalk Server

© 2014 Microsoft Corporation. All rights reserved.


Developing Applications By Using the WCF Service Model

Windows Communication Foundation (WCF) provides a programming model called the WCF service model to connect to the Microsoft BizTalk Adapter for Oracle E-Business Suite. The service model was added to WCF to address, in part, some of the limitations of the WCF channel programming model.

The WCF service model uses familiar .NET paradigms to hide the complexities of exchanging SOAP message over a channel. The service model accomplishes this simplification by reading the entire SOAP message into memory before copying the information into .NET data structures. Loading long messages into memory may not be practical for some applications. In these cases, developers should use the WCF channel model. For more information about using the WCF channel model, see Developing Applications by Using the WCF Channel Model.

At the lowest level, the WCF presents the WCF channel model in which clients invoke operations on a service by exchanging SOAP messages over a channel established between client and service endpoints. The WCF channel model exposes data types and methods that enable you to operate directly on the WCF channel architecture. The WCF channel model provides you with direct control over the contents of the SOAP messages you create and over the way both your application and the Oracle E-Business adapter consume them. However, creating well-formed SOAP messages to send over a channel and validating the reply messages returned can be a detailed and exacting task.

The WCF service model uses proxy classes to invoke operations on a target service or to receive operations from a client. The Oracle E-Business adapter exposes the Oracle E-Business Suite as a WCF service on which you can invoke operations.

  • The proxy class used to invoke operations on a target service is called a WCF client class. This class models the operations exposed by a service as .NET methods with strongly-typed parameters. By using the WCF service model, you can invoke the operations exposed by the Oracle E-Business adapter as .NET methods on the WCF client. For more information about WCF clients, see "WCF Client Overview" at http://go.microsoft.com/fwlink/?LinkId=91458

You can use either of the following tools to generate a WCF client class and associated helper code from the service metadata that the Oracle E-Business adapter exposes:

  • The ServiceModel Metadata Utility Tool (svcutil.exe), which ships with WCF.

  • The Add Adapter Service Reference Visual Studio Plug-in, which ships with the Oracle E-Business adapter and is integrated with the Visual Studio design experience. This tool presents a standard Microsoft Windows interface that provides powerful browsing and searching capabilities on operations that the adapter exposes. For more information about how to generate a WCF client, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

In This Section

The following topics give information about how to develop applications that use the WCF service model:

  • Overview of Using the WCF Service Model with the Adapter

  • Metadata and the WCF Service Model

  • Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts

  • Specifying a Client Binding for the Oracle E-Business Suite

  • Performing Insert, Update, Delete, or Select Operations on Interface Tables and Views Using the WCF Service Model

  • Performing Operations on Tables with Large Data Types Using the WCF Service Model

  • Invoking Concurrent Programs in Oracle E-Business Suite Using the WCF Service Model

  • Invoking Request Sets in Oracle E-Business Suite Using the WCF Service Model

  • Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using WCF Service Model

  • Polling Oracle E-Business Suite Using the WCF Service Model

  • Receiving Database Change Notifications Using the WCF Service Model

See Also

Other Resources

Development

© 2014 Microsoft Corporation. All rights reserved.


Overview of Using the WCF Service Model with the Adapter

The Microsoft BizTalk Adapter for Oracle E-Business Suite exposes an Oracle E-Business Suite system as a WCF service. To perform operations on Oracle E-Business Suite artifacts, for example to invoke a stored procedure, you invoke an operation on the adapter, which, in turn, performs the operation on the Oracle E-Business Suite. Your code acts as a client to the WCF service presented by the adapter.

In the Windows Communication Foundation (WCF) service model, the service contract that exists between a client and a service is represented as a .NET interface, and operations are represented as methods on this interface. The Oracle E-Business adapter and WCF provide tools that enable you to generate this interface for targeted operations from the metadata that the adapter exposes. These tools also create a WCF client class that can be used to invoke the operations exposed in the service interface. A client application can call the methods of the WCF client class to invoke operations on the adapter.

The following section explains how to use the WCF service model to invoke operations with a WCF client.

Invoking Operations on the Oracle E-Business Suite with a WCF Client

To use the WCF service model to invoke operations on the Oracle E-Business adapter, you must first generate a WCF client class for the target operations. You can then create an instance of this class, a WCF client, and call its methods to perform these operations on the Oracle E-Business Suite.

To invoke operations on the Oracle E-Business adapter

  1. Generate a WCF client class and helper code. Use the Add Adapter Service Reference Visual Studio Plug-in or the ServiceModel Metadata Utility Tool (svcutil.exe) to generate a WCF client class targeted at Oracle E-Business Suite artifacts with which you want to work. For more information about how to generate a WCF client, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

  2. Create a WCF client instance and configure the WCF client. Configuring the WCF client involves specifying the binding and endpoint address (connection URI) that the client will use. You can do this either imperatively in code or declaratively in configuration. The following code creates a WCF client that targets the Customer Interface concurrent program in the Receivables application in the Oracle E-Business Suite. It also sets the credentials for the Oracle E-Business Suite. The WCF client is initialized from configuration.

    Copy Code
    ConcurrentPrograms_ARClient client = new ConcurrentPrograms_ARClient("OracleEBSBinding_ConcurrentPrograms_AR"); //picking the binding and address from app.config

client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";
    Note
    You can either specify the client binding and endpoint address in the code or declare it in the app.config configuration file. The preceding code snippet uses the latter. For more information on how to use either approaches, see Specifying a Client Binding for the Oracle E-Business Suite.

  3. Open the WCF client.

    Copy Code
    client.Open();

  4. Invoke methods on the WCF client created in step 2 to perform operations on the Oracle E-Business Suite. The following code invokes the Customer Interface concurrent program in the Receivables application in the Oracle E-Business Suite.

    Copy Code
    string Result = client.RACUST(null, null, null, description, null, recipro_cust, org_id);

    RACUST is the actual name of the Customer Interface concurrent program. Customer Interface is the friendly name of the concurrent program.

  5. Close the WCF client.

    Copy Code
    client.Close();

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Metadata and the WCF Service Model

In the WCF service model, you use the Add Adapter Service Reference Visual Studio Plug-in or the ServiceModel Metadata Utility Tool (svcutile.exe) to do the following:

  • Generate a service contract—the WCF service contract—through which your code can receive operations from the adapter. This .NET interface represents the service contract for target operations.

  • Generate proxy classes—the WCF client class—through which your code can invoke operations on the adapter.

  • Annotated classes that represent the supporting message contracts, operation contracts, and data contracts for the service contract.

For help in understanding the structure of this generated code, see "Understanding Generated Client Code" at http://go.microsoft.com/fwlink/?LinkId=98365. This topic specifically describes code that svcutil.exe generates, but its content is also applicable to the code that the Add Adapter Service Reference Plug-in generates.

For information about how to generate a WCF client class or WCF service contract for target operations and about the differences between svcutil.exe and the Add Adapter Service Reference Plug-in, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts

You can use the Add Adapter Service Reference Visual Studio Plug-in to generate a WCF client class or a WCF service contract (interface) targeted at selected operations on Oracle E-Business Suite artifacts. You can also use the ServiceModel Metadata Utility Tool (svcutil.exe) to generate the WCF client class or WCF service contract; however, the Add Adapter Service Reference Plug-in exposes the functionality of the ServiceModel Metadata Utility Tool through a standard Microsoft Windows interface. It also provides browse and search capabilities that are not available with the svcutil.exe tool, and it generates a configuration file based on the binding properties that you select when you connect to the Oracle E-Business Suite.

Generating a Client Class by Using the Add Adapter Service Reference Plug-in

Perform the following steps to generate a WCF client class by using the Add Adapter Service Reference Plug-in.

To generate a WCF client class

  1. In Visual Studio Solution Explorer, right-click your project, and then click Add Adapter Service Reference.

  2. After the Add Adapter Service Reference dialog box opens, follow the steps in Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio to connect to the Oracle E-Business Suite and browse and search for operations. To create a WCF client class for the operations that you select, be sure that Client (Outbound operations) is selected from the Select contract type drop-down list (this is the default).

  3. After you select all of the operations that you want to target, click OK to generate the WCF client class.

The Add Adapter Service Reference Plug-in adds two files to your project:

  • OracleEBSBindingClient.cs. This file contains the generated WCF client class and helper code for the operations that you selected.

  • app.config. This file contains a binding configuration and client endpoint configurations. These configurations are based on the selections you made when you configured the binding and connection for the Add Adapter Service Reference Plug-in.

    Important
    While using the Add Adapter Service Reference Visual Studio Plug-in, if you do not specify a value for a binding property of type string and whose default value is null then that binding property will not be available in the app.config file. You must manually add the binding property and its value in the app.config file, if required.

Generating a WCF Service Contract by Using the Add Adapter Service Reference Plug-in

The adapter exposes inbound operations to enable Oracle E-Business Suite to send messages to an adapter client. For such operations you must generate a WCF service contract. This section provides information on how to generate a service contract for inbound operations exposed by the adapter.

Perform the following steps to generate a WCF service contract by using the Add Adapter Service Reference Plug-in.

To generate a WCF service contract for inbound operations

  1. In Visual Studio Solution Explorer, right-click your project, and then click Add Adapter Service Reference.

  2. After the Add Adapter Service Reference dialog box opens, follow the steps in Retrieving Metadata for Oracle E-Business Suite Operations in Visual Studio to connect to the Oracle E-Business Suite. There are several binding properties and a URI property that you may want to set when you connect to the Oracle E-Business Suite.

  3. After you have connected to the Oracle E-Business Suite, select Service (Inbound operations) from the Select contract type drop-down list.

  4. In the Select a category box, browse to the inbound operation for which you want to generate the service contract. For example, for Notification operation, click the root node (/), select Notification from the Available categories and operations box, and then click Add. For instructions on how to browse for inbound operations, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

  5. To generate the WCF service contract for the operation, click OK.

The Add Adapter Service Reference Plug-in adds three files to your project:

  • OracleEBSBindingInterface.cs. This file contains the generated WCF service contract (interface) and helper code for the inbound operation.

  • OracleEBSBindingService.cs. This file contains a class that implements the interface defined in OracleDBBindingInterface.cs. You can implement the business logic that processes the records returned by the inbound operation.

  • app.config. This file contains a binding configuration, endpoint behaviors, and service endpoint configuration that are based on the selections you made when you configured the binding and connection for the Add Adapter Service Reference Plug-in.

    Important
    While using the Add Adapter Service Reference Visual Studio Plug-in, if you do not specify a value for a binding property of type string and whose default value is null then that binding property will not be available in the app.config file. You must manually add the binding property and its value in the app.config file, if required.

Using svcutil.exe to Generate a WCF Client Class or a WCF Service Contract

You can use svcutil.exe to generate a WCF client class or a WCF service interface for your application. You must configure svcutil.exe to use it with the Oracle E-Business adapter.

Svcutil.exe generates the WCF client class or WCF service contract in an output file. The default file name is output.cs. You must manually include this file in your Visual Studio project. For more information about svcutil.exe, see http://go.microsoft.com/fwlink/?LinkId=139432.

© 2014 Microsoft Corporation. All rights reserved.


Specifying a Client Binding for the Oracle E-Business Suite

After you have generated the WCF client class, you can create a WCF client (instance) and invoke its methods to consume the Oracle E-Business adapter.

To create the WCF client, you must specify an endpoint address and a binding. The endpoint address must contain a valid Oracle E-Business Suite connection URI, and the binding must be an instance of an Oracle E-Business Suite binding (OracleEBSBinding). For more information about the Oracle E-Business Suite connection URI, see Establishing a Connection to the Oracle E-Business Suite. We recommend that you do not specify the user credentials as part of the connection URI. You may instead use the ClientCredentials property of the WCF client, as explained in this topic.

You can specify the Oracle E-Business Suite binding and the endpoint address in your code or in a configuration file. When you use the Add Adapter Service Reference Visual Studio Plug-in to generate the WCF client class, a configuration file (app.config) is also created for your project. This file contains configuration settings that reflect the binding properties and connection information (except credentials) that you specified when you connected to the Oracle E-Business Suite with the Add Adapter Service Reference Plug-in.

Specifying the Binding and Endpoint Address in Code

The following code shows how to create a WCF client by specifying the binding and endpoint address in code using the ClientCredentials property of the WCF client.

Copy Code
//Create an Oracle EBS binding and set the binding properties
OracleEBSBinding binding = new OracleEBSBinding();
binding.OracleUserName = "myOracleEBSUser";
binding.OraclePassword = "myOracleEBSPassword";
binding.OracleEBSResponsibilityName = "Responsibility";
binding.OracleEBSOrganizationId = "204";

//Create the client endpoint
EndpointAddress address = new EndpointAddress("oracleebs://<oracleebs_instance_name>/");

//Create the client and specify the credentials
ConcurrentPrograms_ARClient client = new ConcurrentPrograms_ARClient(binding,address);
client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";

//Open the client
client.Open();

Specifying the Binding and Endpoint Address in a Configuration File

The following code shows how to create a WCF client by specifying the binding and endpoint address in an app.config file.

Copy Code
//Create the client by specifying the endpoint name in the app.config. In this case, the binding properties
//must also be specified in the app.config.
ConcurrentPrograms_ARClient client = new ConcurrentPrograms_ARClient("OracleEBSBinding_ConcurrentPrograms_AR");

//Specify the credentials
client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";

client.Open();

The following XML shows the configuration file created for the Customer Interface concurrent program by the Add Adapter Service Reference Plug-in. This file contains the client endpoint configuration referenced in the preceding example.

Copy Code
<?xml version="1.0" encoding="utf-8"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
    <system.serviceModel>
        <bindings>
            <oracleEBSBinding>
                <binding openTimeout="00:05:00" name="OracleEBSBinding" closeTimeout="00:01:00"
                    receiveTimeout="00:10:00" sendTimeout="00:01:00" clientCredentialType="Database"
                    inboundOperationType="Polling" metadataPooling="true" statementCachePurge="false"
                    statementCacheSize="10" pollWhileDataFound="false" pollingInterval="30"
                    useOracleConnectionPool="true" minPoolSize="1" maxPoolSize="100"
                    incrPoolSize="5" decrPoolSize="1" connectionLifetime="0" acceptCredentialsInUri="false"
                    useAmbientTransaction="true" notifyOnListenerStart="true"
                    notificationPort="-1" dataFetchSize="65536" longDatatypeColumnSize="32512"
                    skipNilNodes="true" maxOutputAssociativeArrayElements="32"
                    enableSafeTyping="false" insertBatchSize="20" useSchemaInNameSpace="true"
                    enableBizTalkCompatibilityMode="true">
                    <mlsSettings language="" dateFormat="" dateLanguage="" numericCharacters=""
                        sort="" territory="" comparison="" currency="" dualCurrency=""
                        iSOCurrency="" calendar="" lengthSemantics="" nCharConversionException="true"
                        timeStampFormat="" timeStampTZFormat="" timeZone="" />
                </binding>
            </oracleEBSBinding>
        </bindings>
        <client>
            <endpoint address="oracleebs://ebs-70-12/" binding="oracleEBSBinding"
                bindingConfiguration="OracleEBSBinding" contract="ConcurrentPrograms_AR"
                name="OracleEBSBinding_ConcurrentPrograms_AR" />
        </client>
    </system.serviceModel>
</configuration>

If a project has more than one WCF client, there will be multiple client endpoint entries defined in the configuration file. Each WCF client entry will have a unique name based on its binding configuration and target Oracle E-Business Suite artifact. If you connect multiple times to create the WCF clients in your project, multiple binding configuration entries will be created, one for each connection. These binding configuration entries will be named in the following manner: OracleEBSBinding, OracleEBSBinding1, and so on. Each client endpoint entry created during a specific connection will reference the binding entry created during that connection.

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Performing Insert, Update, Delete, or Select Operations on Interface Tables and Views Using the WCF Service Model

The Oracle E-Business adapter discovers a set of basic Insert, Select, Update, and Delete operations on interface tables. By using these operations, you can perform simple Insert, Select, Update, and Delete statements qualified by a WHERE clause on a target interface table. This topic provides instructions on how to perform these operations using the WCF service model.

Note
The Oracle E-Business adapter supports only Select operations on interface views.

For more information about how the adapter supports these operations, see Operations on Interface Tables and Interface Views.

About the Examples Used in this Topic

The example in this topic performs operations on the MS_SAMPLE_EMPLOYEE interface table. The table is created by running the script provided with the samples. For more information about samples, see Samples. A sample, Interface_Table_Ops, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

The WCF Client Class

The name of the WCF client generated for the basic operations that the Oracle E-Business adapter discovers is based on the name of the table or view, as listed in the following table.

Artifact | WCF Client Name
Interface tables | InterfaceTables_[APP_NAME]_[SCHEMA]_[TABLE_NAME]Client
Interface views | InterfaceViews_[APP_NAME]_[SCHEMA]_[VIEW_NAME]Client

[APP_NAME] = Actual name of the Oracle E-Business Suite application; for example, FND.

[SCHEMA] = Collection of artifacts; for example, APPS.

[TABLE_NAME] = The name of the table; for example, MS_SAMPLE_EMPLOYEE.

[VIEW_NAME] = The name of the view; for example, MS_SAMPLE_EMPLOYEE_View.

Method Signature for Invoking Operations on Tables

The following table shows the method signatures for the basic operations on an table. The signatures are the same for a view, except that the view namespace and name replace those of the table.

Operation | Method Signature
Insert | string Insert(InsertRecord[] RECORDSET);
Select | SelectRecord[] Select(string COLUMN_NAMES, string FILTER);
Update | string Update(UpdateRecord RECORDSET, string FILTER);
Delete | string Delete(string FILTER);

As an example, the following code shows the method signatures for a WCF client class generated for the Delete, Insert, Select and Update operations on the MS_SAMPLE_EMPLOYEE interface table under the default APPS schema.

Copy Code
public partial class InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEEClient : System.ServiceModel.ClientBase<InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE>, InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE {
    public SelectRecord[] Select(string COLUMN_NAMES, string FILTER);

    public string Insert(InsertRecord[] RECORDSET);

    public string Update(UpdateRecord RECORDSET, string FILTER);

    public string Delete(string FILTER);
}

In this snippet, InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEEClient is the name of the WCF class in the OracleEBSBindingClient.cs generated by the Add Adapter Service Reference Plug-in.

Parameters for Table Operations

This section provides the parameters required by each table operation

Select Operation

COLUMN_NAMES | FILTER
A comma-delimited list of column names in the target; for example, "EMP_NO, DESIGNATION". The column list specifies the columns of the target that should be returned in the result set. Columns not specified in the column list will be set to their .NET default values in the returned record set. For nillable columns, this value is null. | The contents of a WHERE clause that specifies the target rows of the query; for example, "Designation = 'Manager'". You can set this parameter to null to return all rows of the target.

The return value for a Select operation is a strongly-typed result set that contains the specified columns and rows.

Insert Operation

Insert operation type | RECORDSET
Multiple record | A collection of INSERTRECORDS that should be inserted into the table.

The return value for an Insert operation is the number of rows inserted.

Update Operation

RECORDSET | FILTER
A collection of records that should be updated in the table. | The contents of a WHERE clause that specifies the target rows of the query; for example, "Designation = 'Manager'". You can set this parameter to null to return all rows of the target.

The return value for an Update operation is the number of rows updated.

Delete Operation

The Delete operation takes as input a WHERE clause that specifies the rows to be deleted. The return value for a Delete operation is the number of rows deleted.

Creating a WCF Client to Invoke Operations on Interface Tables and Interface Views

The generic set of actions required to perform an operation on Oracle E-Business Suite using a WCF client involves a set of tasks described in Overview of Using the WCF Service Model with the Adapter. This section describes how to create a WCF client to invoke basic Insert, Select, Update, Delete operations on an interface table.

To create a WCF client to perform operations on tables

  1. Create a Visual C# project in Visual Studio. For this topic, create a console application.

  2. Generate the WCF client class for the Insert, Select, Update, and Delete operation on the MS_SAMPLE_EMPLOYEE interface table. For more information about generating a WCF client class, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

    Important
    Before generating the WCF client class, make sure you set the EnableBizTalkCompatibilityMode binding property to false.

  3. In the Solution Explorer, add reference to Microsoft.Adapters.OracleEBS and Microsoft.ServiceModel.Channels.

  4. Open the Program.cs file and add the following namespaces:

    • Microsoft.Adapters.OracleEBS

    • System.ServiceModel

  5. Open the Program.cs file and create a client as described in the snippet below.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
EndpointAddress address = new EndpointAddress("oracleebs://ebs_instance_name");
InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEEClient client = new InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEEClient(binding, address);

    In this snippet, InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEEClient is the WCF client defined in OracleEBSBindingClient.cs. This file is generated by the Add Adapter Service Reference Plug-in.

    Note
    In this snippet, you explicitly specify the binding and endpoint address in your application code. You can use these values from the application configuration file, app.config, also generated by the Add Adapter Service Reference Plug-in. For more information on the different ways of specifying client binding, see Specifying a Client Binding for the Oracle E-Business Suite.

  6. Set the credentials for the client.

    Copy Code
    client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";

  7. Because you are performing an operation on an interface table, you must set the application context. In this example, to set the application context, you specify the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. For more information about application context, see Setting Application Context.

    Copy Code
    binding.OracleUserName = "myOracleEBSUserName";
binding.OraclePassword = "myOracleEBSPassword";
binding.OracleEBSResponsibilityName = "myOracleEBSResponsibility";

  8. Open the client as described in the snippet below:

    Copy Code
    try
{
   Console.WriteLine("Opening Client...");
   client.Open();
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

  9. Invoke the Insert operation on the MS_SAMPLE_EMPLOYEE table.

    Copy Code
    Console.WriteLine("The application will insert a record in the MS_SAMPLE_EMPLOYEE interface table");

// The date values cannot contain time zone information. Hence, you must use
// DateTimeKind.Unspecified to not include the time zone information.
DateTime date = new DateTime(DateTime.Now.Ticks, DateTimeKind.Unspecified);

string result;

InsertRecord[] recordSet = new InsertRecord[1];

EMP_NO__COMPLEX_TYPE emp_no = new EMP_NO__COMPLEX_TYPE();
emp_no.Value = "10007";

NAME__COMPLEX_TYPE name = new NAME__COMPLEX_TYPE();
name.Value = "John Smith";

DESIGNATION__COMPLEX_TYPE desig = new DESIGNATION__COMPLEX_TYPE();
desig.Value = "Manager";

SALARY__COMPLEX_TYPE salary = new SALARY__COMPLEX_TYPE();
salary.Value = "500000";

JOIN_DATE__COMPLEX_TYPE doj = new JOIN_DATE__COMPLEX_TYPE();
doj.Value = date;

recordSet[0] = new InsertRecord();
recordSet[0].EMP_NO = emp_no;
recordSet[0].NAME = name;
recordSet[0].DESIGNATION = desig;
recordSet[0].SALARY = salary;
recordSet[0].JOIN_DATE = doj;

try
{
   result = client.Insert(recordSet);
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

Console.WriteLine("Number of records inserted= " + result);
Console.WriteLine("Press any key to continue...");
Console.ReadLine();

    You can replace the preceding code snippet to perform Select, Update, or Delete operations as well. You can also append the code snippets to perform all operation in a single application. For code snippets on how to perform these operations, see Select Operation, Update Operation, and Delete Operation respectively.

  10. Close the client as described in the snippet below:

    Copy Code
    client.Close();
Console.WriteLine("Press any key to exit...");
Console.ReadLine();

  11. Build the project and then run it. The application inserts a record in the MS_SAMPLE_EMPLOYEE table.

Select Operation

The following code shows a Select operation that targets the MS_SAMPLE_EMPLOYEE interface table. The Select operation selects the last record inserted into the table. The returned record is written to the console.

Copy Code
Console.WriteLine("The application will now select the last inserted record");
SelectRecord[] selectRecords;
try
{
   selectRecords = client.Select("*", "WHERE EMP_NO LIKE 10007");
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

Console.WriteLine("The details of the newly added employee are:");
Console.WriteLine("********************************************");
for (int i = 0; i < selectRecords.Length; i++)
{
   Console.WriteLine("Employee ID         : " + selectRecords[i].EMP_NO);
   Console.WriteLine("Employee Name       : " + selectRecords[i].NAME);
   Console.WriteLine("Employee Desigation : " + selectRecords[i].DESIGNATION);
   Console.WriteLine("Employee Salary     : " + selectRecords[i].SALARY);
   Console.WriteLine();
}
Console.WriteLine("********************************************");
Console.WriteLine("Press any key to continue ...");
Console.ReadLine();

Update Operation

The following code shows an Update operation that targets the MS_SAMPLE_EMPLOYEE interface table.

Copy Code
Console.WriteLine("The application will now update the employee name in the newly inserted record");
string recordsUpdated;
UpdateRecord updateRecordSet = new UpdateRecord();
updateRecordSet.NAME = "Tom Smith";
updateRecordSet.DESIGNATION = "Accountant";

try
{
   recordsUpdated = client.Update(updateRecordSet, "WHERE EMP_NO LIKE 10007");
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

Console.WriteLine("No of records updated: " + recordsUpdated);
Console.WriteLine("Press any key to continue...");
Console.ReadLine();

Delete Operation

The following code shows a Delete operation that targets the MS_SAMPLE_EMPLOYEE interface table.

Copy Code
Console.WriteLine("The sample will now delete the record that it first inserted");
string deletedRecords;
try
{
   deletedRecords = client.Delete("WHERE EMP_NO LIKE 10007");
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}
Console.WriteLine("No of records deleted: " + deletedRecords);
Console.WriteLine("Press any key to exit...");
Console.ReadLine();

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Performing Operations on Tables with Large Data Types Using the WCF Service Model

The Oracle E-Business adapter enables adapter clients to perform operations on interface tables and views with large data types such as BLOB, CLOB, NCLOB, and BFILE.

  • For columns of type BLOB, CLOB, and NCLOB, the adapter enables clients to read as well as update data. The adapter exposes Read_<LOBColName> and Update_<LOBColName> operations to read and update data respectively, where <LOBColName> is the name of column with large data type. If there is more than one column with large data type in a single interface table, the adapter exposes as many read and update operations for that interface table.

  • For columns of type BFILE, adapter clients can only read data. The adapter exposes Read_<LOBColName> operation to read data from columns of BFILE type. If there is more than one column with large data type in a single interface table, the adapter exposes as many read operations for the interface table.

For more information about these operations, see Operations on Interface Tables, Interface Views, Tables, and Views That Contain LOB Data.

About the Examples Used in this Topic

The example in this topic updates a BLOB column (PHOTO) in the CUSTOMER database table and then retrieves the data from the same column. The table is created by running the script provided with the samples. For more information about samples, see Samples. A sample, LargeDataTypes_ServiceModel, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

Note
This topic lists detailed tasks for updating and reading columns of large data types in a base database table. You must perform the same set of tasks for updating and reading columns of large data types in an interface table.

The WCF Client Class

The name of the WCF client generated for the operations on tables with large data types by the Oracle E-Business adapter is based on the name of the table, as listed in the following table.

Artifact | WCF Client Name
Interface tables | InterfaceTables_[APP_NAME]_[SCHEMA]_[TABLE_NAME]Client

[APP_NAME] = Actual name of the Oracle E-Business Suite application; for example, FND.

[SCHEMA] = Collection of artifacts; for example, APPS.

[TABLE_NAME] = The name of the table; for example, MS_SAMPLE_EMPLOYEE.

[VIEW_NAME] = The name of the view; for example, MS_SAMPLE_EMPLOYEE_View.

Method Signature for Invoking Operations on Tables

The following table shows the method signatures for the basic operations on a table. The signatures are the same for a view, except that the view namespace and name replace those of the table.

Operation | Method Signature
Update_<column_name> | public void Update_<column_name>(string FILTER, byte[] DATA);
Read_<column_name> | public System.IO.Stream Read_<column_name>(string FILTER);

As an example, the following code shows the method signatures for a WCF client class generated for the Update_PHOTO and Read_PHOTO operations on the CUSTOMER database table under the APPS schema.

Copy Code
public partial class Tables_APPS_CUSTOMERClient : System.ServiceModel.ClientBase<Tables_APPS_CUSTOMER>, Tables_APPS_CUSTOMER {

    public void Update_PHOTO(string FILTER, byte[] DATA);

    public System.IO.Stream Read_PHOTO(string FILTER);
}

In this snippet, Tables_APPS_CUSTOMERClient is the name of the WCF class in the OracleEBSBindingClient.cs generated by the Add Adapter Service Reference Plug-in. Update_PHOTO and Read_PHOTO are methods that can be invoked to update and read columns of large data types in a table.

Parameters for Table Operations

This section provides the parameters required by the Update_<column_name> and Read_<column_name> operation.

Operation name Parameters

Update_<column_name>

Requires the following parameters:

  • string FILTER. This parameter must contain the where clause that denotes the record for which data has to be updated. For example, "WHERE Name='Mindy Martin'".

  • byte[] DATA. Contains a byte array of data to be update in a column of large data type.

Read_<column_name>

Requires the following parameters:

  • string FILTER. This parameter must contain the where clause that denotes the record from which the data has to be read. For example, "WHERE Name='Mindy Martin'".

Creating a WCF Client to Invoke Operations on Tables with Columns of Large Data Types

The generic set of actions required to perform an operation on Oracle E-Business Suite using a WCF client involves a set of tasks described in Overview of Using the WCF Service Model with the Adapter. This section describes how to create a WCF client to invoke Update_PHOTO and Read_PHOTO operations on a CUSTOMER database table.

To create a WCF client

  1. Create a Visual C# project in Visual Studio. For this topic, create a console application.

  2. Generate the WCF client class for the Update_PHOTO and Read_PHOTO operations on the CUSTOMER database table. For more information about generating a WCF client class, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

    Important
    Before generating the WCF client class, make sure you set the EnableBizTalkCompatibilityMode binding property to false.

  3. In the Solution Explorer, add reference to Microsoft.Adapters.OracleEBS and Microsoft.ServiceModel.Channels, System.Transactions.

  4. Open the Program.cs file and add the following namespaces:

    • Microsoft.Adapters.OracleEBS

    • System.ServiceModel

    • System.Transactions

    • System.IO

  5. Open the Program.cs file and create a client as described in the snippet below.

    Copy Code
    Tables_APPS_CUSTOMERClient client = new Tables_APPS_CUSTOMERClient("OracleEBSBinding_Tables_APPS_CUSTOMER");

client.ClientCredentials.UserName.UserName = "<Enter user name here>";
client.ClientCredentials.UserName.Password = "<Enter password here>";

    In this snippet, Tables_APPS_CUSTOMERClient is the WCF client defined in OracleEBSBindingClient.cs. This file is generated by the Add Adapter Service Reference Plug-in.

    Note
    In this snippet, you use the binding and endpoint address from the configuration file app.config. You can also explicitly specify these values in your code. For more information on the different ways of specifying client binding, see Specifying a Client Binding for the Oracle E-Business Suite.

  6. Set the credentials for the client.

    Copy Code
    client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";
    Important
    In this example, you are performing operations on a database table. However, if you are performing operations on an interface table, you must set the application context by specifying appropriate values for the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. You must specify these binding properties before opening the client. For more information about application context, see Setting Application Context.

  7. Open the client as described in the snippet below:

    Copy Code
    try
{
   Console.WriteLine("Opening Client...");
   client.Open();
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

  8. Invoke the Update_PHOTO operation on the CUSTOMER table.

    The Update_PHOTO operation requires a byte array for the data to be updated. In this code snippet, you use the FileStream class to create a byte array for a photo, SamplePhoto.jpg. For this application to work, the file must be copied to the project’s bin directory.

    Important
    The Update_PHOTO operation must be performed in a transaction, so the UseAmbientTransaction binding property must be set to true and the Update_PHOTO operation must be performed within a transaction scope. You can set the UseAmbientTransaction binding property either in the app.config or by explicitly setting it in your application as binding.UseAmbientTransaction = true. Note that if you are specifying the binding property explicitly in the code, you must do so before opening the client.

    Copy Code
    byte[] photo;

using (FileStream fs = new FileStream("SamplePhoto.jpg", FileMode.Open))
{
    try
    {
        Console.WriteLine("Reading the photo");
        int count = 0;
        photo = new byte[fs.Length];
        while ((count += fs.Read(photo, count, (int)(((fs.Length - count) > 4096) ? 4096 : fs.Length - count))) < fs.Length) ;
    }
    catch(Exception ex)
    {
        Console.WriteLine("Exception: " + ex.Message);
        throw;
    }
}

Console.WriteLine("Updating data for the 'PHOTO' column");
// Invoking the Update_PHOTO operation inside a transaction scope
using (TransactionScope tx = new TransactionScope())
{
    string filter = "WHERE Name='Mindy Martin'";
    client.Update_PHOTO(filter, photo);
    tx.Complete();
}

  9. Invoke the Read_PHOTO operation on the CUSTOMER table.

    The Read_PHOTO gives the output in the form of System.IO.Stream. The adapter client must implement the FileStream class to read the data from Read_PHOTO operation. After the Read_PHOTO operation is complete, a file PhotoCopy.jpg is copied under the project’s bin directory.

    Copy Code
    using (FileStream fs = new FileStream("PhotoCopy.jpg", FileMode.Create))
{
    Console.WriteLine("Reading photo data");
    String ReadFilter = "WHERE NAME='Mindy Martin'";
    Stream photoStream = client.Read_PHOTO(ReadFilter);
    Console.WriteLine("Photo data read -- writing to PhotoCopy.jpg");

    int count;
    int length = 0;
    byte[] buffer = new byte[4096];
    while ((count = photoStream.Read(buffer, 0, 4096)) > 0)
    {
        fs.Write(buffer, 0, count);
        length+=count;
    }
    Console.WriteLine("{0} bytes written to PhotoCopy.jpg", length);
}

Console.WriteLine("Photo updated and read back -- Hit <RETURN> to end");
Console.ReadLine();

  10. Close the client as described in the snippet below:

    Copy Code
    client.Close();
Console.WriteLine("Press any key to exit...");
Console.ReadLine();

  11. Build the project and then run it. The application updates the PHOTO column of the CUSTOMER table and then reads the content of the PHOTO column.

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Invoking Concurrent Programs in Oracle E-Business Suite Using the WCF Service Model

Oracle E-Business Suite exposes concurrent programs that you can execute to perform specific operations on Oracle applications. Each Oracle application has a set of standard concurrent programs (that are same across all operations) and certain concurrent programs that are specific to an Oracle application. The Oracle E-Business adapter exposes all concurrent programs as operations that adapter clients can invoke. For more information about how the adapter supports concurrent programs, see Operations on Concurrent Programs.

Note
For the concurrent programs that do not expose their metadata, the Oracle E-Business adapter exposes 100 optional parameters for each of these concurrent programs. To invoke these concurrent programs successfully, the user must consult the Oracle E-Business Suite documentation to figure out the parameters for a concurrent program that require a value, and then specify them. An example of such a concurrent program is Journal Import (actual name: GLLEZL) in the General Ledger application.

About the Examples Used in this Topic

The example in this topic invokes the MS_SAMPLE_COPY_EMP_DATA concurrent program, followed by the Get_Status concurrent program to know the status of the first concurrent program. These concurrent programs are invoked from the Application Object Library application. The MS_SAMPLE_COPY_EMP_DATA is created by running the script provided with the samples. For more information about samples, see Samples. A sample, ConcurrentProgram_ServiceModel, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

The WCF Client Class

The name of the WCF client generated for invoking the concurrent programs by the Oracle E-Business adapter is listed in the following table.

Artifact | WCF Client Name
Concurrent Program | ConcurrentPrograms_[APP_NAME]Client

[APP_NAME] = Actual name of the Oracle E-Business Suite application; for example, FND.

Method Signature for Invoking Concurrent Programs

The following table shows the method signature for the concurrent programs.

Operation | Method Signature
Concurrent program | public <return type> <Concurrent_program_name>(param 1, param 2, …)

As an example, the following code shows the method signatures for a WCF client class generated for the MS_SAMPLE_COPY_EMP_DATA and Get_Status concurrent programs.

Copy Code
public partial class ConcurrentPrograms_FNDClient : System.ServiceModel.ClientBase<ConcurrentPrograms_FND>, ConcurrentPrograms_FND {

    public string MS_SAMPLE_COPY_EMP_DATA(schemas.microsoft.com.OracleEBS._2008._05.Options.SetOptions SetOptions,
      schemas.microsoft.com.OracleEBS._2008._05.Options.SetPrintOptions SetPrintOptions,
      schemas.microsoft.com.OracleEBS._2008._05.Options.SetRepeatOptions SetRepeatOptions,
      string Description, string StartTime);

    public bool GetStatusForConcurrentProgram(string RequestId, out string Phase, out string Status,
      out string DevPhase, out string DevStatus, out string Message);
}

In this snippet, ConcurrentPrograms_FNDClient is the name of the WCF class in the OracleEBSBindingClient.cs generated by the Add Adapter Service Reference Plug-in. MS_SAMPLE_COPY_EMP_DATA is the name of the method to invoke the concurrent program. GetStatusForConcurrentProgram is the name of the method to invoke the concurrent program to get the status of the first concurrent program.

Note
GetStatusForConcurrentProgram is the actual name of the Get_Status concurrent program.

Creating a WCF Client to Invoke Concurrent Programs

The generic set of actions required to perform an operation on Oracle E-Business Suite using a WCF client involves a set of tasks described in Overview of Using the WCF Service Model with the Adapter. This section describes how to create a WCF client to invoke the MS_SAMPLE_COPY_EMP_DATA and Get_Status concurrent programs.

To create a WCF client

  1. Create a Visual C# project in Visual Studio. For this topic, create a console application.

  2. Generate the WCF client class for the MS_SAMPLE_COPY_EMP_DATA and Get_Status concurrent programs. For more information about generating a WCF client class, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

    Important
    Before generating the WCF client class, make sure you set the EnableBizTalkCompatibilityMode binding property to false.

  3. In the Solution Explorer, add reference to Microsoft.Adapters.OracleEBS and Microsoft.ServiceModel.Channels.

  4. Open the Program.cs file and add the following namespaces:

    • Microsoft.Adapters.OracleEBS

    • System.ServiceModel

  5. Open the Program.cs file and create a client as described in the snippet below.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
EndpointAddress address = new EndpointAddress("oracleebs://ebs_instance_name");
ConcurrentPrograms_FNDClient client = new ConcurrentPrograms_FNDClient(binding, address);

    In this snippet, ConcurrentPrograms_FNDClient is the WCF client defined in OracleEBSBindingClient.cs. This file is generated by the Add Adapter Service Reference Plug-in.

    Note
    In this snippet, you explicitly specify the binding and endpoint address in your application code. You can also use these values from the application configuration file, app.config, also generated by the Add Adapter Service Reference Plug-in. For more information on the different ways of specifying client binding, see Specifying a Client Binding for the Oracle E-Business Suite.

  6. Set the credentials for the client.

    Copy Code
    client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";

  7. Because you are invoking concurrent programs in an Oracle E-Business Suite application, you must set the application context. In this example, to set the application context, you specify the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. For more information about application context, see Setting Application Context.

    Copy Code
    binding.OracleUserName = "myOracleEBSUserName";
binding.OraclePassword = "myOracleEBSPassword";
binding.OracleEBSResponsibilityName = "myOracleEBSResponsibility";

  8. Open the client as described in the snippet below:

    Copy Code
    try
{
   Console.WriteLine("Opening Client...");
   client.Open();
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

  9. Invoke the MS_SAMPLE_COPY_EMP_DATA and Get_Status concurrent programs.

    Copy Code
    string RequestID;
bool Result;
string Phase;
string Status;
string DevPhase;
string DevStatus;
string Message;

try
{
    Console.WriteLine("Invoking the MS_SAMPLE_COPY_EMP_DATA concurrent program");
    RequestID = client.MS_SAMPLE_COPY_EMP_DATA(null, null, null, null, null);
    Console.WriteLine("The request ID generated for the concurrent program is : " + RequestID);
    Console.WriteLine("********************************************************");
    Console.WriteLine("\nWaiting for 60 seconds for the concurrent program to be complete");
    System.Threading.Thread.Sleep(60000);
    Console.WriteLine("\nInvoking the Get_Status concurrent program");
    Result = client.GetStatusForConcurrentProgram(RequestID, out Phase, out Status, out DevPhase, out DevStatus, out Message);
    Console.WriteLine("\nResult is  : " + Result);
    Console.WriteLine("Phase is     : " + Phase);
    Console.WriteLine("Status is    : " + Status);
    Console.WriteLine("DevPhase is  : " + DevPhase);
    Console.WriteLine("DevStatus is : " + DevStatus);
    Console.WriteLine("Message is   : " + Message);
    Console.WriteLine("********************************************************");
    Console.WriteLine("\nHit <RETURN> to end");
    Console.ReadLine();
}
catch (Exception ex)
{
    Console.WriteLine("Exception : " + ex);
    throw;
}

  10. Close the client as described in the snippet below:

    Copy Code
    client.Close();

  11. Build the project and then run it. The application invokes the MS_SAMPLE_COPY_EMP_DATA and returns a request ID. The ID is then passed to the Get_Status concurrent program, which finally provides the status of the MS_SAMPLE_COPY_EMP_DATA column program.

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Invoking Request Sets in Oracle E-Business Suite Using the WCF Service Model

Microsoft BizTalk Adapter for Oracle E-Business Suite enables you to execute request sets in Oracle E-Business Suite. Request sets are divided into one or more stages, and each stage contains a set of reports and concurrent programs. For more information about how the adapter supports request sets, see Operations on Request Sets.

The WCF Client Class

The name of the WCF client generated for invoking the request sets by the Oracle E-Business adapter is listed in the following table.

Artifact | WCF Client Name
Request Set | RequestSets_[APP_NAME]Client

[APP_NAME] = Actual name of the Oracle E-Business Suite application; for example, SQLAP.

Method Signature for Invoking Request Sets

The following table shows the method signature for request sets.

Operation | Method Signature
Request Set | public <return type> <request set name>(param 1, param 2, …)

As an example, the following code shows the method signatures for a WCF client class generated for the reqset_singlestage request set.

Note
This is a custom request set and might not be available on your Oracle E-Business Solution instance.

Copy Code
public partial class RequestSets_SQLAPClient : System.ServiceModel.ClientBase<RequestSets_SQLAP>, RequestSets_SQLAP{

    public string REQSTG(
      schemas.microsoft.com.OracleEBS._2008._05.Options.SetRelClassOptions SetRelClassOptions,
      schemas.microsoft.com.OracleEBS._2008._05.Options.SetPrintOptions SetPrintOptions,
      schemas.microsoft.com.OracleEBS._2008._05.Options.SetRepeatOptions SetRepeatOptions,
      schemas.microsoft.com.OracleEBS._2008._05.Options.SetNlsOptions SetNlsOptions,
      string StartTime,
      schemas.microsoft.com.OracleEBS._2008._05.RequestSetStage.SQLAP.REQSTG.set1 set1_set1);
}

In this snippet, RequestSets_SQLAPClient is the name of the WCF class in the OracleEBSBindingClient.cs generated by the Add Adapter Service Reference Plug-in. REQSTG is the name of the method to invoke the request set.

Creating a WCF Client to Invoke Request Sets

The generic set of actions required to perform an operation on Oracle E-Business Suite using a WCF client involves a set of tasks described in Overview of Using the WCF Service Model with the Adapter. This section describes how to create a WCF client to invoke the reqset_singlestage request set.

To create a WCF client

  1. Create a Visual C# project in Visual Studio. For this topic, create a console application.

  2. Generate the WCF client class for the reqset_singlestage request set. For more information about generating a WCF client class, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

    Important
    Before generating the WCF client class, make sure you set the EnableBizTalkCompatibilityMode binding property to false.

  3. In the Solution Explorer, add reference to Microsoft.Adapters.OracleEBS and Microsoft.ServiceModel.Channels.

  4. Open the Program.cs file and add the following namespaces:

    • Microsoft.Adapters.OracleEBS

    • System.ServiceModel

  5. Open the Program.cs file and create a client as described in the snippet below.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
EndpointAddress address = new EndpointAddress("oracleebs://ebs_instance_name");
RequestSets_SQLAPClient client = new RequestSets_SQLAPClient(binding, address);

    In this snippet, RequestSets_SQLAPClient is the WCF client defined in OracleEBSBindingClient.cs. This file is generated by the Add Adapter Service Reference Plug-in.

    Note
    In this snippet, you explicitly specify the binding and endpoint address in your application code. You can also use these values from the application configuration file, app.config, also generated by the Add Adapter Service Reference Plug-in. For more information about the different ways of specifying client binding, see Specifying a Client Binding for the Oracle E-Business Suite.

  6. Set the credentials for the client.

    Copy Code
    client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";

  7. Because you are invoking request sets in an Oracle E-Business Suite application, you must set the application context. In this example, to set the application context, you specify the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. For more information about application context, see Setting Application Context.

    Copy Code
    binding.OracleUserName = "myOracleEBSUserName";
binding.OraclePassword = "myOracleEBSPassword";
binding.OracleEBSResponsibilityName = "myOracleEBSResponsibility";

  8. Open the client as described in the snippet below:

    Copy Code
    try
{
   Console.WriteLine("Opening Client...");
   client.Open();
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

  9. Invoke the reqset_singlestage request set.

    Copy Code
    string RequestID;

schemas.microsoft.com.OracleEBS._2008._05.RequestSetStage.SQLAP.REQSTG.set1 param =
    new schemas.microsoft.com.OracleEBS._2008._05.RequestSetStage.SQLAP.REQSTG.set1();

param.INSPARAMPROG = new schemas.microsoft.com.OracleEBS._2008._05.RequestSetConcurrentProgram.SQLAP.REQSTG.set1.SQLAP1.INSPARAMPROG();
param.INSPARAMPROG.p_id = "123";
param.INSPARAMPROG.p_name = "MyName";

try
{
    Console.WriteLine("Invoking the reqset_singlestage request set");
    RequestID = client.REQSTG(null, null, null, null, null, param);
    Console.WriteLine("The request ID generated for the request set is : " + RequestID);
    Console.WriteLine("*****************************************************************");
    Console.WriteLine("\nHit <RETURN> to end");
    Console.ReadLine();
}
catch (Exception ex)
{
    Console.WriteLine("Exception : " + ex);
    throw;
}

  10. Close the client as described in the snippet below:

    Copy Code
    client.Close();

  11. Build the project and then run it. The application invokes the reqset_singlestage request set and returns a request ID, which is written to the console.

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using WCF Service Model

The Oracle E-Business adapter exposes generic operations such as ExecuteNonQuery, ExecuteReader, and ExecuteScalar. You can use these operations to execute any statement on Oracle E-Business Suite. These operations differ based on the kind of response you get for the statement. For more information about how the adapter supports these operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations.

This topic demonstrates how to perform an ExecuteReader operation using the Oracle E-Business adapter using the WCF service model. You can follow the same set of procedures described in this topic to perform ExecuteNonQuery and ExecuteScalar operations.

About the Examples Used in this Topic

The example in this topic performs an ExecuteReader operation to perform a SELECT operation on the MS_SAMPLE_EMPLOYEE interface table. The table is created by running the script provided with the samples. For more information about samples, see Samples. A sample, ExecuteReader, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

The WCF Client Class

The name of the WCF client generated for invoking generic operations (ExecuteNonQuery, ExecuteReader, or ExecuteScalar) using the Oracle E-Business adapter is listed in the following table.

Operations | WCF Client Name
ExecuteNonQuery, ExecuteReader, or ExecuteScalar | GenericOperation_Client

Method Signature for Invoking Generic Operations

The following table shows the signature for the method exposed to invoke the generic operations.

Operation | Method Signature
ExecuteNonQuery | int ExecuteNonQuery(string Query, string[] OutputRefCursorNames, out System.Data.DataSet[] OutputRefCursors)
ExecuteReader | System.Data.DataSet ExecuteReader(string Query)
ExecuteScalar | string ExecuteScalar(string Query)

As an example, the signature for the generic operation methods is shown in the following code snippet.

Copy Code
public partial class GenericOperation_Client : System.ServiceModel.ClientBase<GenericOperation_>, GenericOperation_ {
  public int ExecuteNonQuery(string Query, string[] OutputRefCursorNames, out System.Data.DataSet[] OutputRefCursors);
  public System.Data.DataSet ExecuteReader(string Query);
  public string ExecuteScalar(string Query);
}

In this snippet,

  • GenericOperation_Client is the name of the class. This class is used to create a client to invoke the generic operation, ExecuteReader.

  • public System.Data.DataSet ExecuteReader(string Query) is the method that you invoke to perform a SELECT statement on the MS_SAMPLE_EMPLOYEE interface table.

Creating a WCF Client to Invoke an ExecuteReader Operation

The generic set of actions required to perform an operation on Oracle E-Business Suite using a WCF client involves a set of tasks described in Overview of Using the WCF Service Model with the Adapter. This section describes how to create a WCF client to invoke the ExecuteReader operation.

To create a WCF client to invoke ExecuteReader operation

  1. Create a Visual C# project in Visual Studio. For this topic, create a console application.

  2. Generate the WCF client class for the ExecuteReader generic operation. This operation is available under the root node when you connect to the Oracle E-Business Suite using the Add Adapter Service Reference Plug-in. For more information about generating a WCF client class, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

    Important
    Before generating the WCF client class, make sure you set the EnableBizTalkCompatibilityMode binding property to false.

  3. In the Solution Explorer, add reference to Microsoft.Adapters.OracleEBS and Microsoft.ServiceModel.Channels.

  4. Open the Program.cs file and add the following namespaces:

    • Microsoft.Adapters.OracleEBS

    • System.ServiceModel

  5. In the Program.cs file, create a client as described in the snippet below.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
EndpointAddress address = new EndpointAddress("oracleebs://ebs-72-11");
GenericOperation_Client client = new GenericOperation_Client(binding, address);

    In this snippet, GenericOperation_Client is the WCF client defined in OracleEBSBindingClient.cs. This file is generated by the Add Adapter Service Reference Plug-in.

    Note
    In this snippet, you explicitly specify the binding and endpoint address in your application code. You can use these values from the application configuration file, app.config, also generated by the Add Adapter Service Reference Plug-in. For more information about the different ways of specifying client binding, see Specifying a Client Binding for the Oracle E-Business Suite.

  6. Set the credentials for the client.

    Copy Code
    client.ClientCredentials.UserName.UserName = "myuser";
client.ClientCredentials.UserName.Password = "mypassword";

  7. Because you are performing an operation on an interface table, you must set the application context. In this example, to set the application context, you specify the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. For more information about application context, see Setting Application Context.

    Copy Code
    binding.OracleUserName = "myOracleEBSUserName";
binding.OraclePassword = "myOracleEBSPassword";
binding.OracleEBSResponsibilityName = "myOracleEBSResponsibility";

  8. Open the client as described in the snippet below:

    Copy Code
    try
{
   Console.WriteLine("Opening Client...");
   client.Open();
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

  9. Invoke the ExecuteReader operation for performing the SELECT operation on MS_SAMPLE_EMPLOYEE table. Before you invoke the ExecuteReader operation, you must add the System.Data namespace to your code.

    Copy Code
    string query = "SELECT * FROM MS_SAMPLE_EMPLOYEE";
DataSet ds = client.ExecuteReader(query);

Console.WriteLine("Invoking the SELECT statement using ExecuteReader");
Console.WriteLine("*****************************************************");
foreach (DataTable tab in ds.Tables)
{
   foreach (DataRow row in tab.Rows)
   {
      Console.WriteLine("The details of the employee are: ");
      for (int i = 0; i < tab.Columns.Count; i++)
      {
         Console.WriteLine(row[i]);
      }
      Console.WriteLine();
   }
}
Console.WriteLine("*****************************************************");
Console.ReadLine();

  10. Close the client as described in the snippet below:

    Copy Code
    client.Close();
Console.WriteLine("Press any key to exit...");
Console.ReadLine();

  11. Build the project and then run it. All the records in the MS_SAMPLE_EMPLOYEE table are displayed on the console.

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Polling Oracle E-Business Suite Using the WCF Service Model

You can configure the Oracle E-Business adapter to receive polling-based messages from the Oracle database. The adapter provides two ways of polling the Oracle database:

  • Using SELECT statements. You can specify a simple SELECT statement to poll the Oracle database. The adapter executes the SELECT statement at specified intervals and returns the result to the adapter clients.

  • Using stored procedures. You can specify a stored procedure to poll the Oracle database. The adapter executes the stored procedure at specified intervals and returns the result to the adapter clients.

The key difference in the two approaches is the way adapter clients specify a polling statement that the adapter uses to poll the Oracle database. While the polling statement for the first approach is a simple SELECT statement, the polling statement for the stored procedure approach is a request message that executes the stored procedure. Adapter clients specify the polling statement, for either approach, for the PollingInput binding property. For more information about the binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

The topics in this section provide instructions on how to poll using a SELECT statement and a stored procedure.

In This Section

  • Polling Using SELECT Statement Using the WCF Service Model

  • Polling Using Stored Procedures Using the WCF Service Model

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Polling Using SELECT Statement Using the WCF Service Model

You can configure the Oracle E-Business adapter to receive periodic data-change messages by using a SELECT statement to continuously poll the interface tables, interface views, tables and views in Oracle E-Business Suite. You can specify a SELECT statement as a polling statement that the adapter executes periodically to poll Oracle E-Business Suite. You can also specify a post-poll PL/SQL code block that the adapter executes after the polling statement is executed.

To enable polling, you must specify certain binding properties as described in this topic. For more information about how the adapter supports polling, see Support for Inbound Calls Using Polling.

Configuring a Polling Operation with Oracle E-Business Suite Adapter Binding Properties

The following table summarizes the Oracle E-Business adapter binding properties that you use to configure the adapter to receive data change messages. You must specify these binding properties while running the polling application.

Binding Property Description

InboundOperationType

Specifies whether you want to perform Polling or Notification inbound operation. Default is Polling.

PolledDataAvailableStatement

Specifies the SQL statement that the adapter executes to determine whether any data is available for polling. Only if a record is available, the SELECT statement you specify for the PollingInput binding property will be executed.

PollingInterval

Specifies the interval, in seconds, at which the Oracle E-Business adapter executes the statement specified for the PolledDataAvailableStatement binding property. The default is 30 seconds. The polling interval determines the time interval between successive polls. If the statement is executed within the specified interval, the adapter sleeps for the remaining time in the interval.

PollingInput

Specifies the polling statement. To poll using a SELECT statement, you must specify a SELECT statement for this binding property. The default is null.

You must specify a value for PollingInput binding property to enable polling. The polling statement is executed only if there is data available for polling, which is determined by the PolledDataAvailableStatement binding property.

PollingAction

Specifies the action for the polling operation. You can determine the polling action from the service interface generated for the operation using the Add Adapter Service Reference Visual Studio Plug-in.

PostPollStatement

Specifies a statement block that is executed after the statement specified by the PollingInput binding property is executed.

PollWhileDataFound

Specifies whether the Oracle E-Business adapter ignores the polling interval and continuously executes the polling statement, if data is available in the table being polled. If no data is available in the table, the adapter reverts to execute the polling statement at the specified polling interval. Default is false.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to poll the Oracle database, read further.

How This Topic Demonstrates Polling

In this topic, to demonstrate how the Oracle E-Business adapter supports receiving data change messages using SELECT statements, you poll the MS_SAMPLE_EMPLOYEE interface table in the Application Object Library application. This table is created when you run the create_apps_artifacts.sql script provided with the samples to create these objects in Oracle E-Business Suite.

To demonstrate a polling operation, we do the following:

  • Specify a SELECT statement for the PolledDataAvailableStatement binding property to determine where the interface table being polled (MS_SAMPLE_EMPLOYEE) has any data. In this example, you can set this binding property as:

    Copy Code
    SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE
    This ensures that the adapter executes the polling statement only when the MS_SAMPLE_EMPLOYEE interface table has some records.

  • Specify a SELECT statement for the PollingInput binding property. This statement retrieves all the rows in the MS_SAMPLE_EMPLOYEE interface table. In this example, you can set this binding property as:

    Copy Code
    SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE
    Note
    For information about the FOR UPDATE clause used in the SELECT statement, see Specifying a FOR UPDATE Clause in the Polling Statement.

  • Specify a DELETE statement as part of the PostPollStatement binding property. This statement will delete all data from MS_SAMPLE_EMPLOYEE interface table. In this example, you can set this binding property as:

    Copy Code
    DELETE FROM MS_SAMPLE_EMPLOYEE
    After this happens, the next time the statement specified for PollingInput will be executed, it will not fetch any data.

  • Until more data is added to the MS_SAMPLE_EMPLOYEE interface table, you will not get any polling messages so you must repopulate the MS_SAMPLE_EMPLOYEE interface table with new records. You can do so by running the insert_apps_data.sql script provided with the samples. After you run this script, the next polling operation will fetch the new records inserted into the table.

Configuring Polling in the WCF Service Model

To poll an interface table using the Oracle E-Business adapter with the WCF service model, you must:

  • Generate a WCF service contract (interface) for the Poll operation on the MS_SAMPLE_EMPLOYEE interface table. To do this, you could use the Add Adapter Service Reference Plug-in.

  • Implement a WCF service from this interface.

  • Host this WCF service using a service host (System.ServiceModel.ServiceHost).

About the Examples Used in this Topic

The examples in this topic poll the MS_SAMPLE_EMPLOYEE interface table. A script to generate the table is supplied with the samples. For more information about the samples, see Samples. A sample, SelectPolling_ServiceModel, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

The WCF Service Contract and Class

You can use the Add Adapter Service Reference Plug-in to create a WCF service contract (interface) and supporting classes for the Polling operation. For more information about generating a WCF service contract, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

The WCF Service Contract (Interface)

The following code shows the WCF service contract (interface) generated for the Poll operation on MS_SAMPLE_EMPLOYEE interface table.

Copy Code
[System.CodeDom.Compiler.GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[System.ServiceModel.ServiceContractAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/", ConfigurationName="InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE")]
public interface InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE {

    // CODEGEN: Generating message contract since the wrapper namespace (http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/FND/APPS/MS_SAMPLE_EMPLOYEE) of message Poll
    // does not match the default value (http://schemas.microsoft.com/OracleEBS/)
    [System.ServiceModel.OperationContractAttribute(IsOneWay=true, Action="InterfaceTables/Poll/FND/APPS/MS_SAMPLE_EMPLOYEE")]
    void Poll(Poll request);
}

The Message Contracts

Following is the message contract for the Poll operation on MS_SAMPLE_EMPLOYEE interface table.

Copy Code
[System.Diagnostics.DebuggerStepThroughAttribute()]
[System.CodeDom.Compiler.GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[System.ServiceModel.MessageContractAttribute(WrapperName="Poll", WrapperNamespace="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/FND/APPS/MS_SAMPLE" +
    "_EMPLOYEE", IsWrapped=true)]
public partial class Poll {

    [System.ServiceModel.MessageBodyMemberAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/FND/APPS/MS_SAMPLE" +
        "_EMPLOYEE", Order=0)]
    public schemas.microsoft.com.OracleEBS._2008._05.TableViewRecord.APPS.MS_SAMPLE_EMPLOYEE.SelectRecord[] DATA;

    public Poll() {
    }

    public Poll(schemas.microsoft.com.OracleEBS._2008._05.TableViewRecord.APPS.MS_SAMPLE_EMPLOYEE.SelectRecord[] DATA) {
        this.DATA = DATA;
    }
}

WCF Service Class

The Add Adapter Service Reference Plug-in also generates a file that has a stub for the WCF service class implemented from the service contract (interface). The name of the file is OracleEBSBindingService.cs. You can insert the logic to process the Poll operation directly into this class. The following code shows the WCF service class generated by the Add Adapter Service Reference Plug-in.

Copy Code
namespace OracleEBSBindingNamespace {

    public class OracleEBSBindingService : InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE {

        // CODEGEN: Generating message contract since the wrapper namespace (http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/FND/APPS/MS_SAMPLE_EMPLOYEE) of message Poll
        // does not match the default value (http://schemas.microsoft.com/OracleEBS/)
        public virtual void Poll(Poll request) {
            throw new System.NotImplementedException("The method or operation is not implemented.");
        }
    }
}

Receiving Inbound Messages for the Poll Operation Using a SELECT Statement

This section provides instructions on how to write a .NET application to receive inbound polling messages using the Oracle E-Business adapter.

To receive polling messages using a SELECT statement

  1. Use the Add Adapter Service Reference Plug-in to generate a WCF service contract (interface) and helper classes for the Poll operation on the MS_SAMPLE_EMPLOYEE interface table. For more information, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts. You can optionally specify the binding properties while generating the service contract and helper classes. This guarantees that they are properly set in the generated configuration file.

  2. Implement a WCF service from the interface and helper classes generated in step 1. The Poll method of this class can throw an exception to abort the polling transaction, if an error is encountered processing the data received from the Poll operation; otherwise the method does not return anything. You must attribute the WCF service class as follows:

    Copy Code
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

    Within the Poll method, you can implement your application logic directly. This class can be found in OracleEBSBindingService.cs. This code in this example sub-classes the OracleEBSBindingService class. In this code, the polling message received and is written to the console.

    Copy Code
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

public class PollingService : OracleEBSBindingNamespace.OracleEBSBindingService
{
    public override void Poll(Poll request)
    {
        Console.WriteLine("\nNew Polling Records Received");
        Console.WriteLine("*************************************************");
        Console.WriteLine("Emp No\tName\tDesignation\tSalary");
        for (int i = 0; i < request.DATA.Length; i++)
        {
            Console.WriteLine("{0}\t{1}\t{2}\t{3}",
            request.DATA[i].EMP_NO,
            request.DATA[i].NAME,
            request.DATA[i].DESIGNATION,
            request.DATA[i].SALARY);
        }
        Console.WriteLine("*************************************************");
        Console.WriteLine("\nHit <RETURN> to stop polling");
    }
}

  3. You must implement the following class to avoid passing credentials as part of the URI. In the latter part of the application, you will instantiate this class to pass on the credentials.

    Copy Code
    class PollingCredentials : ClientCredentials, IServiceBehavior
{
    public void AddBindingParameters(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase, Collection<ServiceEndpoint> endpoints, BindingParameterCollection bindingParameters)
    {
        bindingParameters.Add(this);
    }

    public void ApplyDispatchBehavior(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
    { }

    public void Validate(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
    { }

    protected override ClientCredentials CloneCore()
    {
        ClientCredentials clone = new PollingCredentials();
        clone.UserName.UserName = this.UserName.UserName;
        clone.UserName.Password = this.UserName.Password;
        return clone;
    }
}

  4. Create an OracleEBSBinding and configure the polling operation by specifying the binding properties. You can do this either explicitly in code or declaratively in configuration. At a minimum, you must specify the InboundOperationType, PolledDataAvailableStatement, PollingInput, and PollingAction binding properties.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
binding.InboundOperationType = InboundOperation.Polling;
binding.PolledDataAvailableStatement = "SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE";
binding.PollingInput = "SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE";
binding.PollingAction = "InterfaceTables/Poll/FND/APPS/MS_SAMPLE_EMPLOYEE";
binding.PostPollStatement = "DELETE FROM MS_SAMPLE_EMPLOYEE";

  5. Because you are polling an interface table, you must also set the applications context. For more information about application context and the binding properties required for setting application context, see Setting Application Context.

    Copy Code
    binding.OracleUserName = "myOracleEBSUserName";
binding.OraclePassword = "myOracleEBSPassword";
binding.OracleEBSResponsibilityName = "myOracleEBSResponsibility";

  6. Specify Oracle E-Business Suite credentials by instantiating the PollingCredentials class you created in Step 3.

    Copy Code
    PollingCredentials credentials = new PollingCredentials();
credentials.UserName.UserName = "<Enter user name here>";
credentials.UserName.Password = "<Enter password here>";

  7. Create an instance of the WCF service created in step 2.

    Copy Code
    // create service instance
PollingService service = new PollingService();

  8. Create an instance of System.ServiceModel.ServiceHost by using the WCF service and a base connection URI. The base connection URI cannot contain the inbound ID, if specified. You must also pass the credentials here.

    Copy Code
    // Enable service host
Uri[] baseUri = new Uri[] { new Uri("oracleebs://ebs_instance_name") };
ServiceHost serviceHost = new ServiceHost(service, baseUri);
serviceHost.Description.Behaviors.Add(credentials);

  9. Add a service endpoint to the service host. To do this:

    • Use the binding created in step 4.

    • Specify a connection URI that contains credentials and, if required, an inbound ID.

    • Specify the contract as "InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE" to poll the MS_SAMPLE_EMPLOYEE interface table.

    Copy Code
    // Add service endpoint: be sure to specify InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE as the contract
Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name");
serviceHost.AddServiceEndpoint("InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE", binding, ConnectionUri);

  10. To receive polling data, open the service host. The adapter will return data whenever the query returns a result set.

    Copy Code
    // Open the service host to begin polling
serviceHost.Open();

  11. To terminate polling, close the service host.

    Important
    The adapter will continue to poll until the service host is closed.

    Copy Code
    serviceHost.Close();

Example

The following example shows a polling application that polls the MS_SAMPLE_EMPLOYEE interface table. The PollingInput property contains the select statement that reads all the data from the MS_SAMPLE_EMPLOYEE table and the post poll statement deletes all the data from the same table. The first polling message gives all the records from the MS_SAMPLE_EMPLOYEE interface table. Subsequent polling messages will not contain any records because the post poll statement deletes the records. Until more data is added to the MS_SAMPLE_EMPLOYEE interface table, you will not get any polling messages. So, you must repopulate the MS_SAMPLE_EMPLOYEE interface table with new records. You can do so by running the insert_apps_data.sql script provided with the samples. After you run this script, the next polling operation will fetch the new records inserted into the table. The adapter will continue to poll until you close the service host by pressing <RETURN>.

Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Microsoft.Adapters.OracleEBS;
using Microsoft.ServiceModel.Channels;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.ServiceModel.Channels;
using System.Collections.ObjectModel;

namespace SelectPolling_ServiceModel
{
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

    public class PollingService : OracleEBSBindingNamespace.OracleEBSBindingService
    {
        public override void Poll(Poll request)
        {
            Console.WriteLine("\nNew Polling Records Received");
            Console.WriteLine("*************************************************");
            Console.WriteLine("Emp No\tName\tDesignation\tSalary");
            for (int i = 0; i < request.DATA.Length; i++)
            {
                Console.WriteLine("{0}\t{1}\t{2}\t{3}",
                request.DATA[i].EMP_NO,
                request.DATA[i].NAME,
                request.DATA[i].DESIGNATION,
                request.DATA[i].SALARY);
            }
            Console.WriteLine("*************************************************");
            Console.WriteLine("\nHit <RETURN> to stop polling");
        }
    }

    class PollingCredentials : ClientCredentials, IServiceBehavior
    {
        public void AddBindingParameters(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase, Collection<ServiceEndpoint> endpoints, BindingParameterCollection bindingParameters)
        {
            bindingParameters.Add(this);
        }

        public void ApplyDispatchBehavior(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
        { }

        public void Validate(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
        { }

        protected override ClientCredentials CloneCore()
        {
            ClientCredentials clone = new PollingCredentials();
            clone.UserName.UserName = this.UserName.UserName;
            clone.UserName.Password = this.UserName.Password;
            return clone;
        }
    }

    class Program
    {
        static void Main(string[] args)
        {
            ServiceHost serviceHost = null;
            try
            {
                Console.WriteLine("Sample started...");
                Console.WriteLine("Press any key to start polling...");
                Console.ReadLine();

                OracleEBSBinding binding = new OracleEBSBinding();
                binding.InboundOperationType = InboundOperation.Polling;
                binding.PolledDataAvailableStatement = "SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE";
                binding.PollingInput = "SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE";
                binding.PollingAction = "InterfaceTables/Poll/FND/APPS/MS_SAMPLE_EMPLOYEE";
                binding.PostPollStatement = "DELETE FROM MS_SAMPLE_EMPLOYEE";
                binding.OracleUserName = "myOracleEBSUserName";
                binding.OraclePassword = "myOracleEBSPassword";
                binding.OracleEBSResponsibilityName = "myOracleEBSResponsibility";

                // This URI is used to specify the address for the ServiceEndpoint
                // It must contain the InboundId that was used to generate
                // the WCF service callback interface
                Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name");

                // This URI is used to initialize the ServiceHost. It cannot contain
                // an InboundID; otherwise,an exception is thrown when
                // the ServiceHost is initialized.
                Uri[] baseUri = new Uri[] { new Uri("oracleebs://ebs_instance_name") };

                PollingCredentials credentials = new PollingCredentials();
                credentials.UserName.UserName = "<Enter user name here>";
                credentials.UserName.Password = "<Enter password here>";

                Console.WriteLine("Opening service host...");
                PollingService service = new PollingService();
                serviceHost = new ServiceHost(service, baseUri);
                serviceHost.Description.Behaviors.Add(credentials);
                serviceHost.AddServiceEndpoint("InterfaceTables_FND_APPS_MS_SAMPLE_EMPLOYEE", binding, ConnectionUri);
                serviceHost.Open();
                Console.WriteLine("Service host opened...");
                Console.WriteLine("Polling started...");
                Console.ReadLine();
            }
            catch (Exception e)
            {
                Console.WriteLine("Exception :" + e.Message);
                Console.ReadLine();

                /* If there is an error it will be specified in the inner exception */
                if (e.InnerException != null)
                {
                    Console.WriteLine("InnerException: " + e.InnerException.Message);
                    Console.ReadLine();
                }
            }
            finally
            {
                // IMPORTANT: you must close the ServiceHost to stop polling
                if (serviceHost.State == CommunicationState.Opened)
                    serviceHost.Close();
                else
                    serviceHost.Abort();
            }
        }
    }
}

See Also

Other Resources

Polling Oracle E-Business Suite Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Polling Using Stored Procedures Using the WCF Service Model

You can configure the Oracle E-Business adapter to receive periodic data-change messages by using stored procedures to periodically poll the Oracle database. You can specify a stored procedure as a polling statement that the adapter executes periodically to poll the Oracle database.

To enable polling, you must specify certain binding properties as described in this topic. For more information about how the adapter supports polling, see Support for Inbound Calls Using Polling.

Configuring a Polling Operation with Oracle E-Business Adapter Binding Properties

The following table summarizes the Oracle E-Business adapter binding properties that you use to configure the adapter to receive data-change messages. You must specify these binding properties while running the polling application.

Binding Property Description

InboundOperationType

Specifies whether you want to perform a Polling or Notification inbound operation. Default is Polling.

PolledDataAvailableStatement

Specifies the SQL statement that the adapter executes to determine whether any data is available for polling. Only if a record is available, the stored procedure you specified for the PollingInput binding property will be executed.

PollingInterval

Specifies the interval, in seconds, at which the Oracle E-Business adapter executes the statement specified for the PolledDataAvailableStatement binding property. The default is 30 seconds. The polling interval determines the time interval between successive polls. If the statement is executed within the specified interval, the adapter sleeps for the remaining time in the interval.

PollingInput

Specifies the polling statement. To poll using a stored procedure, you must specify the entire request message for this binding property. The request message must be the same that you send to the adapter for invoking the stored procedure as an outbound operation. The default is null.

You must specify a value for PollingInput binding property to enable polling. The polling statement is executed only if there is data available for polling, which is determined by the PolledDataAvailableStatement binding property.

PollingAction

Specifies the action for the polling operation. You can determine the polling action from the service interface generated for the operation using the Add Adapter Service Reference Visual Studio Plug-in.

PostPollStatement

Specifies a statement block that is executed after the statement specified by the PollingInput binding property is executed.

PollWhileDataFound

Specifies whether the Oracle E-Business adapter ignores the polling interval and continuously executes the polling statement, if data is available in the table being polled. If no data is available in the table, the adapter reverts to execute the polling statement at the specified polling interval. Default is false.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to poll, read the following sections.

How This Topic Demonstrates Polling

In this topic, to demonstrate how the Oracle E-Business adapter supports receiving data change messages using stored procedures, you use the GET_ACTIVITYS stored procedure to poll the ACCOUNTACTIVITY table in the Oracle database. This stored procedure is available with the ACCOUNT_PKG package. You can run the SQL scripts provided with the samples to create these objects in the database.

Note
The example in this topic polls the ACCOUNTACTIVITY table, which is a base database table created by running the scripts provided with the samples. You must perform similar procedures as described in this topic to poll any other table, including interface tables.

To demonstrate a polling operation, we do the following:

  • Specify a SELECT statement for the PolledDataAvailableStatement binding property to determine where the table being polled (ACCOUNTACTIVITY) has any data. In this example, you can set this binding property as:

    Copy Code
    SELECT COUNT (*) FROM ACCOUNTACTIVITY
    This ensures that the adapter executes the polling statement only when the ACCOUNTACTIVITY table has some records.

  • Execute a stored procedure, GET_ACTIVITYS, by providing the request message as part of the PollingInput binding property. This stored procedure will retrieve all the rows in the ACCOUNTACTIVITY table and you will get a response message from the adapter.

  • Execute a PL/SQL block as part of the PostPollStatement binding property. This statement will move all data from ACCOUNTACTIVITY table to another table in the database. After this happens, the next time PollingInput is executed, it will not fetch any data and hence the GET_ACTIVITYS stored procedure will return an empty response message.

  • Until more data is added to the ACCOUNTACTIVITY table, you will continue to get empty response messages so you must repopulate the ACCOUNTACTIVITY table with new records. You can do so by running the more_activity_data.sql script provided with the samples. After you run this script, the next polling operation will fetch the new records inserted into the table.

Configuring Polling in the WCF Service Model

To poll using stored procedures with the Oracle E-Business adapter with the WCF service model, you must:

  • Generate a WCF service contract (interface) for the stored procedure using which you are going to poll. For this example, you must generate the WCF service contract for the GET_ACTIVITYS stored procedure as an inbound operation. To do this, you could use the Add Adapter Service Reference Plug-in.

  • Implement a WCF service from this interface.

  • Host this WCF service using a service host (System.ServiceModel.ServiceHost).

About the Examples Used in this Topic

The examples in this topic poll the ACCOUNTACTIVITY database table using the GET_ACTIVITYS stored procedure. A script to generate the table and the stored procedure is supplied with the samples. For more information about the samples, see Samples. A sample, StoredProcPolling_ServiceModel, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

The WCF Service Contract and Class

You can use the Add Adapter Service Reference Plug-in to create a WCF service contract (interface) and supporting classes for the GET_ACTIVITYS inbound operation. For more information about generating a WCF service contract, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

The WCF Service Contract (Interface)

The following code shows the WCF service contract (interface) generated for the GET_ACTIVITYS inbound operation.

Copy Code
[System.CodeDom.Compiler.GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[System.ServiceModel.ServiceContractAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/", ConfigurationName="PollingPackageApis_APPS_ACCOUNT_PKG")]
public interface PollingPackageApis_APPS_ACCOUNT_PKG {

    // CODEGEN: Generating message contract since the wrapper namespace (http://schemas.microsoft.com/OracleEBS/2008/05/PollingPackageApis/APPS/ACCOUNT_PKG) of message GET_ACTIVITYS
    // does not match the default value (http://schemas.microsoft.com/OracleEBS/)
    [System.ServiceModel.OperationContractAttribute(IsOneWay=true, Action="PollingPackageApis/APPS/ACCOUNT_PKG/GET_ACTIVITYS")]
    void GET_ACTIVITYS(GET_ACTIVITYS request);
}

The Message Contracts

Following is the message contract for the GET_ACTIVITYS inbound operation.

Copy Code
[System.Diagnostics.DebuggerStepThroughAttribute()]
[System.CodeDom.Compiler.GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[System.ServiceModel.MessageContractAttribute(WrapperName="GET_ACTIVITYS", WrapperNamespace="http://schemas.microsoft.com/OracleEBS/2008/05/PollingPackageApis/APPS/ACCOUNT_PK" +
    "G", IsWrapped=true)]
public partial class GET_ACTIVITYS {

    [System.ServiceModel.MessageBodyMemberAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/2008/05/PollingPackageApis/APPS/ACCOUNT_PK" +
        "G", Order=0)]
    public schemas.microsoft.com.OracleEBS._2008._05.RecordTypes.APPS.ACCOUNT_PKG.GET_ACTIVITYS.OUTRECSRecord[] OUTRECS;

    public GET_ACTIVITYS() {
    }

    public GET_ACTIVITYS(schemas.microsoft.com.OracleEBS._2008._05.RecordTypes.APPS.ACCOUNT_PKG.GET_ACTIVITYS.OUTRECSRecord[] OUTRECS) {
        this.OUTRECS = OUTRECS;
    }
}

WCF Service Class

The Add Adapter Service Reference Plug-in also generates a file that has a stub for the WCF service class implemented from the service contract (interface). The name of the file is OracleEBSBindingService.cs. You can insert the logic to process the GET_ACTIVITYS operation directly into this class. The following code shows the WCF service class generated by the Add Adapter Service Reference Plug-in.

Copy Code
namespace OracleEBSBindingNamespace {

    public class OracleEBSBindingService : PollingPackageApis_APPS_ACCOUNT_PKG {

        // CODEGEN: Generating message contract since the wrapper namespace (http://schemas.microsoft.com/OracleEBS/2008/05/PollingPackageApis/APPS/ACCOUNT_PKG) of message GET_ACTIVITYS
        // does not match the default value (http://schemas.microsoft.com/OracleEBS/)
        public virtual void GET_ACTIVITYS(GET_ACTIVITYS request) {
            throw new System.NotImplementedException("The method or operation is not implemented.");
        }
    }
}

Receiving Inbound Messages For Polling Using a Stored Procedure

This section provides instructions on how to write a .NET application to receive inbound polling messages using the Oracle E-Business adapter.

To receive polling messages using a stored procedure

  1. Use the Add Adapter Service Reference Plug-in to generate a WCF service contract (interface) and helper classes for the GET_ACTIVITYS inbound operation. For more information, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts. You can optionally specify the binding properties while generating the service contract and helper classes. This guarantees that they are properly set in the generated configuration file.

  2. Implement a WCF service from the interface and helper classes generated in step 1. The GET_ACTIVITYS method of this class can throw an exception to abort the polling transaction, if an error is encountered processing the data received from the GET_ACTIVITYS operation; otherwise the method does not return anything. You must attribute the WCF service class as follows:

    Copy Code
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

    Within the GET_ACTIVITYS method, you can implement your application logic directly. This class can be found in OracleEBSBindingService.cs. This code in this example sub-classes the OracleEBSBindingService class. In this code, the polling message received and is written to the console.

    Copy Code
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

public class PollingService : OracleEBSBindingNamespace.OracleEBSBindingService
{
    public override void  GET_ACTIVITYS(GET_ACTIVITYS request)
    {
        Console.WriteLine("\nNew Polling Records Received");
        Console.WriteLine("*************************************************");
        Console.WriteLine("Tx Id\tAccount\tAmount\tProcessed");
        for (int i = 0; i < request.OUTRECS.Length; i++)
        {
            Console.WriteLine("{0}\t{1}\t{2}\t{3}",
            request.OUTRECS[i].TID,
            request.OUTRECS[i].ACCOUNT,
            request.OUTRECS[i].AMOUNT,
            request.OUTRECS[i].PROCESSED);
        }
        Console.WriteLine("*************************************************");
        Console.WriteLine("\nHit <RETURN> to stop polling");
    }
}

  3. You must implement the following class to avoid passing credentials as part of the URI. In the latter part of the application, you will instantiate this class to pass on the credentials.

    Copy Code
    class PollingCredentials : ClientCredentials, IServiceBehavior
{
    public void AddBindingParameters(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase, Collection<ServiceEndpoint> endpoints, BindingParameterCollection bindingParameters)
    {
        bindingParameters.Add(this);
    }

    public void ApplyDispatchBehavior(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
    { }

    public void Validate(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
    { }

    protected override ClientCredentials CloneCore()
    {
        ClientCredentials clone = new PollingCredentials();
        clone.UserName.UserName = this.UserName.UserName;
        clone.UserName.Password = this.UserName.Password;
        return clone;
    }
}

  4. Create an OracleEBSBinding and configure the polling operation by specifying the binding properties. You can do this either explicitly in code or declaratively in configuration. At a minimum, you must specify the InboundOperationType, PolledDataAvailableStatement, PollingInput, and PollingAction binding properties.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
binding.InboundOperationType = InboundOperation.Polling;
binding.PolledDataAvailableStatement = "SELECT COUNT (*) FROM ACCOUNTACTIVITY";
binding.PollingInput = "<GET_ACTIVITYS xmlns='http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/APPS/ACCOUNT_PKG'><INRECS>OPEN ? FOR SELECT * FROM ACCOUNTACTIVITY</INRECS></GET_ACTIVITYS>";
binding.PollingAction = "PollingPackageApis/APPS/ACCOUNT_PKG/GET_ACTIVITYS";
binding.PostPollStatement = "BEGIN ACCOUNT_PKG.PROCESS_ACTIVITY(); END;";
    Note
    Note that the value for the PollingInput binding property contains the request message for invoking the GET_ACTIVITYS stored procedure as an outbound operation.

    Important
    In this example, because you are polling a database table, you do not need to set the applications context. However, if you were polling an interface table, you must set the applications context by specifying the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. For more information about application context, see Setting Application Context.

  5. Specify Oracle E-Business Suite credentials by instantiating the PollingCredentials class you created in Step 3.

    Copy Code
    PollingCredentials credentials = new PollingCredentials();
credentials.UserName.UserName = "<Enter user name here>";
credentials.UserName.Password = "<Enter password here>";

  6. Create an instance of the WCF service created in step 2.

    Copy Code
    // create service instance
PollingService service = new PollingService();

  7. Create an instance of System.ServiceModel.ServiceHost by using the WCF service and a base connection URI. The base connection URI cannot contain the inbound ID, if specified. You must also pass the credentials here.

    Copy Code
    // Enable service host
Uri[] baseUri = new Uri[] { new Uri("oracleebs://ebs_instance_name") };
ServiceHost serviceHost = new ServiceHost(service, baseUri);
serviceHost.Description.Behaviors.Add(credentials);

  8. Add a service endpoint to the service host. To do this:

    • Use the binding created in step 4.

    • Specify a connection URI that contains credentials and, if required, an inbound ID.

    • Specify the contract as "PollingPackageApis_APPS_ACCOUNT_PKG" to poll the MS_SAMPLE_EMPLOYEE interface table.

    Copy Code
    // Add service endpoint: be sure to specify PollingPackageApis_APPS_ACCOUNT_PKG as the contract
Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name");
serviceHost.AddServiceEndpoint("PollingPackageApis_APPS_ACCOUNT_PKG", binding, ConnectionUri);

  9. To receive polling data, open the service host. The adapter will return data whenever the query returns a result set.

    Copy Code
    // Open the service host to begin polling
serviceHost.Open();

  10. To terminate polling, close the service host.

    Important
    The adapter will continue to poll until the service host is closed.

    Copy Code
    serviceHost.Close();

Example

The following example shows a polling application that polls the ACCOUNTACTIVITY database table using the GET_ACTIVITYS stored procedure. The PollingInput binding property contains the request message to invoke the GET_ACTIVITYS stored procedure that reads all the data from the ACCOUNTACTIVITY table and the post poll statement moves all the data from ACCOUNTACTIVITY to ACTIVITYHISTORY table.

The first polling message gives all the records from the ACCOUNTACTIVITY table. Subsequent polling messages will not contain any records because the post poll statement deletes the records. Until more data is added to the ACCOUNTACTIVITY table, you will not get any polling messages so you must repopulate the ACCOUNTACTIVITY table with new records. You can do so by running the more_activity_data.sql script provided with the samples.

After you run this script, the next polling operation will fetch the new records inserted into the table. The adapter will continue to poll until you close the service host by pressing <RETURN>.

Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Microsoft.Adapters.OracleEBS;
using Microsoft.ServiceModel.Channels;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.ServiceModel.Channels;
using System.Collections.ObjectModel;

namespace StoredProcPolling_ServiceModel
{
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

    public class PollingService : OracleEBSBindingNamespace.OracleEBSBindingService
    {
        public override void  GET_ACTIVITYS(GET_ACTIVITYS request)
        {
            Console.WriteLine("\nNew Polling Records Received");
            Console.WriteLine("*************************************************");
            Console.WriteLine("Tx Id\tAccount\tAmount\tProcessed");
            for (int i = 0; i < request.OUTRECS.Length; i++)
            {
                Console.WriteLine("{0}\t{1}\t{2}\t{3}",
                request.OUTRECS[i].TID,
                request.OUTRECS[i].ACCOUNT,
                request.OUTRECS[i].AMOUNT,
                request.OUTRECS[i].PROCESSED);
            }
            Console.WriteLine("*************************************************");
            Console.WriteLine("\nHit <RETURN> to stop polling");
        }
    }

    class PollingCredentials : ClientCredentials, IServiceBehavior
    {
        public void AddBindingParameters(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase, Collection<ServiceEndpoint> endpoints, BindingParameterCollection bindingParameters)
        {
            bindingParameters.Add(this);
        }

        public void ApplyDispatchBehavior(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
        { }

        public void Validate(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
        { }

        protected override ClientCredentials CloneCore()
        {
            ClientCredentials clone = new PollingCredentials();
            clone.UserName.UserName = this.UserName.UserName;
            clone.UserName.Password = this.UserName.Password;
            return clone;
        }
    }

    class Program
    {
        static void Main(string[] args)
        {
            ServiceHost serviceHost = null;
            try
            {
                Console.WriteLine("Sample started...");
                Console.WriteLine("Press any key to start polling...");
                Console.ReadLine();

                OracleEBSBinding binding = new OracleEBSBinding();
                binding.InboundOperationType = InboundOperation.Polling;
                binding.PolledDataAvailableStatement = "SELECT COUNT (*) FROM ACCOUNTACTIVITY";
                binding.PollingInput = "<GET_ACTIVITYS xmlns='http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/APPS/ACCOUNT_PKG'><INRECS>OPEN ? FOR SELECT * FROM ACCOUNTACTIVITY</INRECS></GET_ACTIVITYS>";
                binding.PollingAction = "PollingPackageApis/APPS/ACCOUNT_PKG/GET_ACTIVITYS";
                binding.PostPollStatement = "BEGIN ACCOUNT_PKG.PROCESS_ACTIVITY(); END;";

                // This URI is used to specify the address for the ServiceEndpoint
                // It must contain the InboundId that was used to generate
                // the WCF service callback interface
                Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name");

                // This URI is used to initialize the ServiceHost. It cannot contain
                // an InboundID; otherwise,an exception is thrown when
                // the ServiceHost is initialized.
                Uri[] baseUri = new Uri[] { new Uri("oracleebs://ebs_instance_name") };

                PollingCredentials credentials = new PollingCredentials();
                credentials.UserName.UserName = "<Enter user name here>";
                credentials.UserName.Password = "<Enter password here>";

                Console.WriteLine("Opening service host...");
                PollingService service = new PollingService();
                serviceHost = new ServiceHost(service, baseUri);
                serviceHost.Description.Behaviors.Add(credentials);
                serviceHost.AddServiceEndpoint("PollingPackageApis_APPS_ACCOUNT_PKG", binding, ConnectionUri);
                serviceHost.Open();
                Console.WriteLine("Service host opened...");
                Console.WriteLine("Polling started...");
                Console.ReadLine();
            }
            catch (Exception e)
            {
                Console.WriteLine("Exception :" + e.Message);
                Console.ReadLine();

                /* If there is an error it will be specified in the inner exception */
                if (e.InnerException != null)
                {
                    Console.WriteLine("InnerException: " + e.InnerException.Message);
                    Console.ReadLine();
                }
            }
            finally
            {
                // IMPORTANT: you must close the ServiceHost to stop polling
                if (serviceHost.State == CommunicationState.Opened)
                    serviceHost.Close();
                else
                    serviceHost.Abort();
            }
        }
    }
}

See Also

Other Resources

Polling Oracle E-Business Suite Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Receiving Database Change Notifications Using the WCF Service Model

This topic demonstrates how to configure the Oracle E-Business adapter to receive query notification messages from an Oracle database. To demonstrate notifications, consider a table, ACCOUNTACTIVITY, with a “Processed” column. When a new record is inserted to this table, the value of the Status column is set to “n.” You can configure the adapter to receive notifications by registering for notifications using a SQL statement that retrieves all records that have “Processed” column as “n.” You can do so by specifying the SQL statement for the NotificationStatement binding property. After the adapter client receives the notification, it can contain the logic to do any subsequent tasks on the Oracle database. In this example, for the sake of simplicity, the adapter client lists all the records in the table that have the “Processed” column as “n.”

Configuring Notifications with the Oracle E-Business Adapter Binding Properties

The table below summarizes the Oracle E-Business adapter binding properties that you use to configure receiving notifications from Oracle E-Business Suite. You must specify these binding properties while running the .NET application to receive notifications.

Binding Property | Description
InboundOperationType | Specifies the inbound operation that you want to perform. To receive notification messages, set this to Notification.
NotificationPort | Specifies the port number that ODP.NET must open to listen for database change notification from Oracle database.
NotificationStatement | Specifies the Select statement used to register for query notifications. The adapter gets a notification message only when the result set for the specified Select statement changes.
NotifyOnListenerStart | Specifies whether the adapter sends a notification to the adapter clients when the listener is started.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to receive notifications from Oracle E-Business Suite, read the remainder of this topic.

Configuring Notifications Using the WCF Service Model

To receive the notifications using the WCF service model, you must:

  • Generate a WCF service contract (interface) for the Notification operation from the metadata exposed by the adapter. To do this, you could use the Add Adapter Service Reference Plug-in.

  • Generate a WCF client for the Select operation on the ACCOUNTACTIVITY table. To do this, you could use the Add Adapter Service Reference Plug-in.

  • Implement a WCF service from this interface.

  • Host this WCF service using a service host (System.ServiceModel.ServiceHost).

About the Examples Used in this Topic

The examples in this topic receives notification for the ACCOUNTACTIVITY table. A script to generate the table is supplied with the samples. For more information about the samples, see Samples. A sample, Notification_ServiceModel, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

The WCF Service Contract and Class

You can use the Add Adapter Service Reference Plug-in to create a WCF service contract (interface) and supporting classes for the Notification operation. For more information about generating a WCF service contract, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts.

The WCF Service Contract (Interface)

The following code shows the WCF service contract (interface) generated for the Notification operation.

Copy Code
[System.CodeDom.Compiler.GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[System.ServiceModel.ServiceContractAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/", ConfigurationName="Notification_")]
public interface Notification_ {

    // CODEGEN: Generating message contract since the wrapper namespace (http://schemas.microsoft.com/OracleEBS/2008/05/Notification/) of message Notification
    // does not match the default value (http://schemas.microsoft.com/OracleEBS/)
    [System.ServiceModel.OperationContractAttribute(IsOneWay=true, Action="Notification")]
    void Notification(Notification request);
}

The Message Contracts

Following is the message contract for the Notification operation.

Copy Code
[System.Diagnostics.DebuggerStepThroughAttribute()]
[System.CodeDom.Compiler.GeneratedCodeAttribute("System.ServiceModel", "3.0.0.0")]
[System.ServiceModel.MessageContractAttribute(WrapperName="Notification", WrapperNamespace="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/", IsWrapped=true)]
public partial class Notification {

    [System.ServiceModel.MessageBodyMemberAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/", Order=0)]
    public schemas.microsoft.com.OracleEBS._2008._05.Notification.NotificationDetails[] Details;

    [System.ServiceModel.MessageBodyMemberAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/", Order=1)]
    public string Info;

    [System.ServiceModel.MessageBodyMemberAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/", Order=2)]
    public string[] ResourceNames;

    [System.ServiceModel.MessageBodyMemberAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/", Order=3)]
    public string Source;

    [System.ServiceModel.MessageBodyMemberAttribute(Namespace="http://schemas.microsoft.com/OracleEBS/2008/05/Notification/", Order=4)]
    public string Type;

    public Notification() {
    }

    public Notification(schemas.microsoft.com.OracleEBS._2008._05.Notification.NotificationDetails[] Details, string Info, string[] ResourceNames, string Source, string Type) {
        this.Details = Details;
        this.Info = Info;
        this.ResourceNames = ResourceNames;
        this.Source = Source;
        this.Type = Type;
    }
}

WCF Service Class

The Add Adapter Service Reference Plug-in also generates a file that has a stub for the WCF service class implemented from the service contract (interface). The name of the file is OracleEBSBindingService.cs. You can insert the logic to process the Notification operation directly into this class. The following code shows the WCF service class generated by the Add Adapter Service Reference Plug-in.

Copy Code
namespace OracleEBSBindingNamespace {

    public class OracleEBSBindingService : Notification_ {

        // CODEGEN: Generating message contract since the wrapper namespace (http://schemas.microsoft.com/OracleEBS/2008/05/Notification/) of message Notification
        // does not match the default value (http://schemas.microsoft.com/OracleEBS/)
        public virtual void Notification(Notification request) {
            throw new System.NotImplementedException("The method or operation is not implemented.");
        }
    }
}

Receiving Query Notifications Using WCF Service Model

This section provides instructions on how to write a .NET application to receive query notifications using the Oracle E-Business adapter.

To receive query notifications

  1. Use the Add Adapter Service Reference Plug-in to generate a WCF client for Select operation on the ACCOUNTACTIVITY table. You will use this client to perform Select operations after receiving a notification message. Add a new class, TableOperation.cs, to your project and add the following code snippet to perform a Select operation.

    Copy Code
    using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace Notification_ServiceModel
{
    class TableOperation
    {
        public void TableOp()
        {
            //////////////////////////////////////////////////////////////////////
            // CREATING THE CLIENT AND SETTING CLIENT CREDENTIALS
            //////////////////////////////////////////////////////////////////////

            Tables_APPS_ACCOUNTACTIVITYClient client = new Tables_APPS_ACCOUNTACTIVITYClient();
            client.ClientCredentials.UserName.UserName = "<Enter user name here>";
            client.ClientCredentials.UserName.Password = "<Enter password here>";

            ////////////////////////////////////////////////////////////////////
            // OPENING THE CLIENT
            //////////////////////////////////////////////////////////////////////
            try
            {
                Console.WriteLine("Opening the client ...");
                client.Open();
            }
            catch (Exception ex)
            {
                Console.WriteLine("Exception: " + ex.Message);
                throw;
            }

            ////////////////////////////////////////////////////////////////////////////////////////
            // SELECTING THE LAST INSERTED VALUES
            ////////////////////////////////////////////////////////////////////////////////////////
            Console.WriteLine("The application will now select the last inserted record");

            schemas.microsoft.com.OracleEBS._2008._05.TableViewRecord.APPS.ACCOUNTACTIVITY.SelectRecord[] selectRecords;

            try
            {
                selectRecords = client.Select("*", "WHERE PROCESSED = 'n'");
            }
            catch (Exception ex)
            {
                Console.WriteLine("Exception: " + ex.Message);
                throw;
            }

            Console.WriteLine("The details of the newly added records are:");
            Console.WriteLine("********************************************");
            for (int i = 0; i < selectRecords.Length; i++)
            {
                Console.WriteLine("Transaction ID   : " + selectRecords[i].TID);
                Console.WriteLine("Account ID       : " + selectRecords[i].ACCOUNT);
                Console.WriteLine("Processed Status : " + selectRecords[i].PROCESSED);
                Console.WriteLine();
            }
            Console.WriteLine("********************************************");
        }
    }
}

  2. Use the Add Adapter Service Reference Plug-in to generate a WCF service contract (interface) and helper classes for the Notification operation.

    For more information, see Generating a WCF Client or a WCF Service Contract for Oracle E-Business Solution Artifacts. You can optionally specify the binding properties while generating the service contract and helper classes. This guarantees that they are properly set in the generated configuration file.

  3. Implement a WCF service from the interface and helper classes generated in step 2. The Notification method of this class can throw an exception to abort the operation, if an error is encountered processing the data received from the Notification operation; otherwise the method does not return anything. You must attribute the WCF service class as follows:

    Copy Code
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

    Within the Notification method, you can implement your application logic directly. This class can be found in OracleEBSBindingService.cs. This code in this example sub-classes the OracleEBSBindingService class. In this code, the notification message received is written to the console. Additionally, the TableOp method within the TableOperation class is invoked to perform the Select operation.

    Copy Code
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

public class NotificationService : OracleEBSBindingNamespace.OracleEBSBindingService
{
    public override void Notification(Notification request)
    {
        Console.WriteLine("\nNew Notification Received");
        Console.WriteLine("*************************************************");
        Console.WriteLine(request.Info);
        Console.WriteLine(request.Source);
        Console.WriteLine(request.Type);
        Console.WriteLine("*************************************************");

        TableOperation Ops = new TableOperation();
        Ops.TableOp();

    }
}

  4. You must implement the following class to pass credentials for the Oracle E-Business Suite. In the latter part of the application, you will instantiate this class to pass on the credentials.

    Copy Code
    class NotificationCredentials : ClientCredentials, IServiceBehavior
{
    public void AddBindingParameters(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase, Collection<ServiceEndpoint> endpoints, BindingParameterCollection bindingParameters)
    {
        bindingParameters.Add(this);
    }

    public void ApplyDispatchBehavior(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
    { }

    public void Validate(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
    { }

    protected override ClientCredentials CloneCore()
    {
        ClientCredentials clone = new NotificationCredentials();
        clone.UserName.UserName = this.UserName.UserName;
        clone.UserName.Password = this.UserName.Password;
        return clone;
    }
}

  5. Create an OracleEBSBinding and configure the adapter to receive query notifications by specifying the binding properties. You can do this either explicitly in code or declaratively in configuration. At a minimum, you must specify the InboundOperationType and NotificationStatement binding properties.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
binding.InboundOperationType = InboundOperation.Notification;
binding.NotificationStatement = "SELECT TID,ACCOUNT,PROCESSED FROM APPS.ACCOUNTACTIVITY WHERE PROCESSED = 'n'";
binding.NotifyOnListenerStart = true;
binding.NotificationPort = 10;
    Important
    The value for the NotificationPort binding property must be set to the same port number that you must have added to the Windows Firewall exceptions list. For instructions on how to add ports to Windows Firewall exceptions list, see http://go.microsoft.com/fwlink/?LinkID=196959.

    Important
    If you do not set the NotificationPort binding property, the adapter will assume the default value of -1 for this binding property. In such a case, you will have to completely disable Windows Firewall to receive notification messages.

  6. Specify Oracle E-Business Suite credentials by instantiating the NotificationCredentials class you created in Step 4.

    Copy Code
    NotificationCredentials credentials = new NotificationCredentials();
credentials.UserName.UserName = "<Enter user name here>";
credentials.UserName.Password = "<Enter password here>";

  7. Create an instance of the WCF service created in step 3.

    Copy Code
    // create service instance
NotificationService service = new NotificationService();

  8. Create an instance of System.ServiceModel.ServiceHost by using the WCF service and a base connection URI. You must also specify the credentials here.

    Copy Code
    // Enable service host
Uri[] baseUri = new Uri[] { new Uri("oracleebs://ebs_instance_name") };
ServiceHost serviceHost = new ServiceHost(service, baseUri);
serviceHost.Description.Behaviors.Add(credentials);

  9. Add a service endpoint to the service host. To do this:

    • Use the binding created in step 5.

    • Specify a connection URI that contains credentials and, if required, an inbound ID.

    • Specify the contract as "Notification_".

    Copy Code
    // Add service endpoint: be sure to specify Notification_ as the contract
Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name?");
serviceHost.AddServiceEndpoint("Notification_", binding, ConnectionUri);

  10. To receive notification message, open the service host.

    Copy Code
    // Open the service host to begin receiving notifications
serviceHost.Open();

  11. To stop receiving notifications, close the service host.

    Copy Code
    serviceHost.Close();

Example

The following example shows a .NET application to receive notification messages for the ACCOUNTACTIVITY table.

Note
The following code snippet instantiates a TableOperation.cs class and invokes the TableOp method. The class and the method are described in Step 1.

Copy Code
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

using Microsoft.Adapters.OracleEBS;
using Microsoft.ServiceModel.Channels;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.ServiceModel.Channels;
using System.Collections.ObjectModel;

namespace Notification_ServiceModel
{
    [ServiceBehavior(InstanceContextMode = InstanceContextMode.Single)]

    public class NotificationService : OracleEBSBindingNamespace.OracleEBSBindingService
    {
        public override void Notification(Notification request)
        {
            Console.WriteLine("\nNew Notification Received");
            Console.WriteLine("*************************************************");
            Console.WriteLine(request.Info);
            Console.WriteLine(request.Source);
            Console.WriteLine(request.Type);
            Console.WriteLine("*************************************************");

            TableOperation Ops = new TableOperation();
            Ops.TableOp();

        }
    }

    class NotificationCredentials : ClientCredentials, IServiceBehavior
    {
        public void AddBindingParameters(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase, Collection<ServiceEndpoint> endpoints, BindingParameterCollection bindingParameters)
        {
            bindingParameters.Add(this);
        }

        public void ApplyDispatchBehavior(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
        { }

        public void Validate(ServiceDescription serviceDescription, ServiceHostBase serviceHostBase)
        { }

        protected override ClientCredentials CloneCore()
        {
            ClientCredentials clone = new NotificationCredentials();
            clone.UserName.UserName = this.UserName.UserName;
            clone.UserName.Password = this.UserName.Password;
            return clone;
        }
    }

    class Program
    {
        static void Main(string[] args)
        {
            ServiceHost serviceHost = null;
            try
            {
                Console.WriteLine("Sample started...");
                Console.WriteLine("Press any key to start receiving notifications...");
                Console.ReadLine();

                OracleEBSBinding binding = new OracleEBSBinding();
                binding.InboundOperationType = InboundOperation.Notification;
                binding.NotificationStatement = "SELECT TID,ACCOUNT,PROCESSED FROM APPS.ACCOUNTACTIVITY WHERE PROCESSED = 'n'";
                binding.NotifyOnListenerStart = true;
                binding.NotificationPort = 10;

                // This URI is used to specify the address for the ServiceEndpoint
                // It must contain the InboundId that was used to generate
                // the WCF service callback interface
                Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name");

                // This URI is used to initialize the ServiceHost. It cannot contain
                // an InboundID; otherwise,an exception is thrown when
                // the ServiceHost is initialized.
                Uri[] baseUri = new Uri[] { new Uri("oracleebs://ebs_instance_name") };

                NotificationCredentials credentials = new NotificationCredentials();
                credentials.UserName.UserName = "<Enter user name here>";
                credentials.UserName.Password = "<Enter password here>";

                Console.WriteLine("Opening service host...");
                NotificationService service = new NotificationService();
                serviceHost = new ServiceHost(service, baseUri);
                serviceHost.Description.Behaviors.Add(credentials);
                serviceHost.AddServiceEndpoint("Notification_", binding, ConnectionUri);
                serviceHost.Open();
                Console.WriteLine("Service host opened...");
                Console.WriteLine("Waiting for notification...");

                Console.WriteLine("\nHit <RETURN> to stop receiving notification");
                Console.ReadLine();
            }
            catch (Exception e)
            {
                Console.WriteLine("Exception :" + e.Message);
                Console.ReadLine();

                /* If there is an error it will be specified in the inner exception */
                if (e.InnerException != null)
                {
                    Console.WriteLine("InnerException: " + e.InnerException.Message);
                    Console.ReadLine();
                }
            }
            finally
            {
                // IMPORTANT: you must close the ServiceHost to stop polling
                if (serviceHost.State == CommunicationState.Opened)
                    serviceHost.Close();
                else
                    serviceHost.Abort();
            }

        }
    }
}

See Also

Other Resources

Developing Applications By Using the WCF Service Model

© 2014 Microsoft Corporation. All rights reserved.


Developing Applications by Using the WCF Channel Model

You can use the Windows Communication Foundation (WCF) channel model to consume the Microsoft BizTalk Adapter for Oracle E-Business Suite by sending XML messages directly over a channel instance created with the Oracle EBS Binding.

One advantage of using the WCF channel model over using the strongly-typed classes and methods that the WCF service model exposes is that the channel model provides more fine-grained control over the operations that you perform on the Oracle E-Business Suite. This control comes from the fact that in the WCF channel model, you directly control the contents of the messages that you send over the channel.

In certain scenarios, this extra level of control can be beneficial. For example, when you use the WCF channel model to perform an Update operation on a table, you can selectively update columns in the target rows by omitting columns from the update template that you pass in the message. The only columns that are required are those with “nillable=false” in the WSDL. The update method exposed by a WCF client uses a strongly-typed record parameter for the template that includes every column in the table schema.

The topics in this section explain how to perform operations on the Oracle E-Business adapter by using the WCF channel model.

In This Section

  • Overview of Using the WCF Channel Model with the Adapter

  • Creating a Channel

  • Performing an Insert Operation on an Interface Table Using the WCF Channel Model

  • Polling Using SELECT Statement Using the WCF Channel Model

See Also

Other Resources

Development

© 2014 Microsoft Corporation. All rights reserved.


Overview of Using the WCF Channel Model with the Adapter

To invoke operations on the Microsoft BizTalk Adapter for Oracle E-Business Suite, your code acts as a WCF client and sends outbound operations to the adapter. In the WCF channel model, your code invokes operations on the adapter by sending a request message over a channel.

To invoke inbound operations, such as receiving polling-based data-changed messages using the Poll operation provided by the adapter, your code acts as a WCF service and receives the inbound operation from the adapter. In other words, your code receives a request message from the adapter over a channel.

The topics in this section provide an overview of using the Oracle E-Business adapter with the WCF channel model.

WCF Channel Model Overview

Clients and services communicate by exchanging SOAP messages. The WCF channel model is a low-level abstraction of this message exchange. It provides interfaces and types that enable you to send and receive messages by using a layered protocol stack called a channel stack. Each layer of the stack is composed of a channel, and each channel is created from a WCF binding. At the lowest layer is the transport channel. The transport channel implements the underlying transport mechanism between a service and a client and presents each message to the higher layers (and ultimately the consuming application) as a System.ServiceModel.Message. The WCF Message class is an abstraction of a SOAP message. WCF provides several channel interfaces, called channel shapes, that model the basic SOAP message exchange patterns, such as request-reply or one-way. A WCF transport binding provides an implementation of one or more channel shapes that higher layers can use to send and receive messages. For more information about the WCF channel model, see "Channel Model Overview" at http://go.microsoft.com/fwlink/?LinkId=82614.

The Oracle E-Business adapter is a WCF custom transport binding that exposes an Oracle E-Business Suite artifact as a WCF service.

Supported Channel Shapes for the Oracle E-Business Suite Adapter

The adapter implements the following WCF channel shapes:

  • IRequestChannel (System.ServiceModel.Channels.IRequestChannel). The IRequestChannel interface implements the client side of a request-reply message exchange. You can use an IRequestChannel to perform operations for which you want to consume a response, for example to perform a SELECT query on an interface table.

  • IOutputChannel (System.ServiceModel.Channels.IOutputChannel). This shape implements the client side of a one-way message exchange. You can use an IOutputChannel to invoke an operation for which you do not need to consume a response, for example to call a procedure that has no OUT parameters.

    Important
    All underlying calls by the adapter to the Oracle client are synchronous. This includes calls to the Oracle client that are the result of operations invoked over an IOutputChannel. When you use an IOutputChannel, the adapter discards the response received from the Oracle client.

  • IInputChannel (System.ServiceModel.Channels.IInputChannel). This shape implements the service side of a one-way message exchange. You use an IInputChannel to receive inbound messages from the adapter.

Like any WCF binding, the Oracle E-Business adapter uses a factory pattern to provide channels to application code. You use a Microsoft.Adapters.OracleEBSBinding object to create instances of:

  • System.ServiceModel.ChannelFactory<IRequestChannel> to provide IRequestChannel channels you can use to invoke request-response operations on the adapter.

  • System.ServiceModel.ChannelFactory<IOutputChannel> to provide IOutputChannel channels you can use to invoke one-way operations on the adapter.

  • System.ServiceModel.IChannelListener<IInputChannel> to provide IInputChannel channels you can use to receive inbound messages from the adapter.

Creating Messages for the Oracle Enterprise Business Solution in the WCF Channel Model

In WCF the System.ServiceModel.Channels.Message class provides an in memory representation of a SOAP message. You create a Message instance by invoking the static Message.Create method.

There are two important parts to the SOAP message that you must specify when you create a Message instance to send to the Oracle E-Business adapter.

  • The message action is a string that is part of the SOAP message header. The message action identifies the operation that should be invoked on the Oracle E-Business Suite. The following shows the message action specified to invoke the Customer Interface concurrent program under the Receivables application in Oracle E-Business Suite: ConcurrentPrograms/AR/RACUST.

  • The message body contains the parameter data for the operation. The message body is composed of well-formed XML that corresponds to the message schema expected by the Oracle E-Business adapter for the requested operation. The following message body specifies a request message to invoke the Customer Interface concurrent program.

    Copy Code
    <RACUST xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/ConcurrentPrograms/AR">
  <Description>Customer Interface Program</Description>
  <StartTime></StartTime>
  <CREATE_RECIPROCAL_CUSTOMER>Yes</CREATE_RECIPROCAL_CUSTOMER>
  <ORG_ID>203</ORG_ID>
</RACUST>

For information about the Oracle E-Business adapter message schemas and message actions for operations, see Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite.

The Create method is overloaded and offers many different options for providing the message body. The following code shows how to create a Message instance by using an XmlReader to supply the message body. In this code, the message body is read from a file.

Copy Code
XmlReader readerIn = XmlReader.Create("ConcProgRequest.xml");
Message messageIn = Message.CreateMessage(MessageVersion.Default,
    "ConcurrentPrograms/AR/RACUST",
    readerIn);

where, ConProgRequest.xml contains the request message.

Important
You must provide a message action in your Message instance. This is typically done when the Message instance is created.

See Also

Other Resources

Developing Applications by Using the WCF Channel Model

© 2014 Microsoft Corporation. All rights reserved.


Creating a Channel

In the WCF channel model, you invoke operations on the Oracle E-Business Suite and receive the results by exchanging SOAP messages with the Microsoft BizTalk Adapter for Oracle E-Business Suite over a WCF channel.

  • You invoke operations (outbound operations) by using either an IRequestChannel or an IOutputChannel to send messages to the adapter.

  • You receive messages for inbound operations over an IInputChannel.

The topics in this section provide information about how to create and configure channel shapes that are used for inbound and outbound operations.

Creating Outbound (Client) Channels

You can use either an IRequestChannel or an IOutputChannel to invoke operations on the Oracle E-Business Suite. In either case, you first create a System.ServiceModel.ChannelFactory using the appropriate interface. You then use the factory to create the channel. After you have created the channel you can use it to invoke operations on the adapter.

To create and open an outbound channel

  1. Create and initialize an instance of ChannelFactory for the desired channel shape by using an endpoint and a binding. The endpoint specifies an Oracle E-Business Suite connection URI and the binding is an instance of OracleEBSBinding.

  2. Provide Oracle E-Business Suite credentials for the channel factory by using the Credentials property.

  3. Open the channel factory.

  4. Get an instance of the channel by invoking the CreateChannel method on the channel factory.

  5. Open the channel.

You can specify the binding and endpoint address in your code or from configuration.

Specifying the Binding and Endpoint Address in Code

The following code example shows how to create an IRequestChannel by specifying the binding and endpoint address in code. The code to create an IOutputChannel is the same except that you must specify an IOutputChannel interface for the ChannelFactory and channel type.

Copy Code
// Create binding -- set binding properties before you open the factory.
OracleEBSBinding binding = new OracleEBSBinding();

// Create address
EndpointAddress address = new EndpointAddress("oracleebs://<oracleebs_instance_name>/");

// Create channel factory from binding and address.
ChannelFactory<IRequestChannel> factory =
    new ChannelFactory<IRequestChannel>(binding, address);

// Specify credentials.
factory.Credentials.UserName.UserName = "myuser";
factory.Credentials.UserName.Password = "mypassword";

// Open factory
factory.Open();

// Get channel and open it.
IRequestChannel channel = factory.CreateChannel();
channel.Open();

Specifying the Binding and Endpoint Address in Configuration

The following code example shows how to create a channel factory from a client endpoint specified in configuration.

Copy Code
// Create channel factory from configuration.
ChannelFactory<IRequestChannel> factory =
new ChannelFactory<IRequestChannel>("MyRequestChannel");

// Specify credentials.
factory.Credentials.UserName.UserName = "myuser";
factory.Credentials.UserName.Password = "mypassword";

// Open the factory.
factory.Open();

// Get a channel and open it.
IRequestChannel channel = factory.CreateChannel();
channel.Open();

The Configuration Settings

The following code shows the configuration settings used for the preceding example. The contract for the client endpoint must be "System.ServiceModel.Channels.IRequestChannel" or "System.ServiceModel.Channels.IOutputChannel" depending on the kind of channel shape that you want to create.

Copy Code
<?xml version="1.0" encoding="utf-8"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
    <system.serviceModel>
        <bindings>
            <oracleEBSBinding>
                <binding openTimeout="00:05:00" name="OracleEBSBinding" closeTimeout="00:01:00"
                    receiveTimeout="00:10:00" sendTimeout="00:01:00" clientCredentialType="Database"
                    inboundOperationType="Polling" metadataPooling="true" statementCachePurge="false"
                    statementCacheSize="10" pollWhileDataFound="false" pollingInterval="30"
                    useOracleConnectionPool="true" minPoolSize="1" maxPoolSize="100"
                    incrPoolSize="5" decrPoolSize="1" connectionLifetime="0" acceptCredentialsInUri="false"
                    useAmbientTransaction="true" notifyOnListenerStart="true"
                    notificationPort="-1" dataFetchSize="65536" longDatatypeColumnSize="0"
                    skipNilNodes="true" maxOutputAssociativeArrayElements="32"
                    enableSafeTyping="false" insertBatchSize="20" useSchemaInNameSpace="true"
                    enableBizTalkCompatibilityMode="true" enablePerformanceCounters="false">
                    <mlsSettings language="" dateFormat="" dateLanguage="" numericCharacters=""
                        sort="" territory="" comparison="" currency="" dualCurrency=""
                        iSOCurrency="" calendar="" lengthSemantics="" nCharConversionException="true"
                        timeStampFormat="" timeStampTZFormat="" timeZone="" />
                </binding>
            </oracleEBSBinding>
        </bindings>
        <client>
            <endpoint address="oracleebs://oracle_ebs_instance/" binding="oracleEBSBinding"
                bindingConfiguration="OracleEBSBinding" contract="System.ServiceModel.Channels.IRequestChannel"
                name="MyRequestChannel" />
        </client>
    </system.serviceModel>
</configuration>

Creating Inbound (Service) Channels

You configure the Oracle E-Business adapter to poll the Oracle database tables and views by setting binding properties on an instance of OracleEBSBinding. You then use this binding to build a channel listener from which you can get an IInputChannel channel to receive inbound operations from the adapter.

To create and open an IInputChannel to receive messages for inbound operations

  1. Create an instance of OracleEBSBinding.

  2. Set the binding properties required for the inbound operation. For example, for a polling operation, at a minimum you must set the InboundOperationType, PolledDataAvailableStatement, PollingAction, and the PollingInput binding properties to configure the Oracle E-Business adapter to poll the Oracle database.

  3. Create a binding parameter collection using the BindingParameterCollection class and set the credentials.

  4. Create a channel listener by invoking BuildChannelListener<IInputChannel> method on the OracleEBSBinding. You specify the Oracle connection URI as one of the parameters to this method.

  5. Open the listener.

  6. Get an IInputChannel channel by invoking the AcceptChannel method on listener.

  7. Open the channel.

The following code shows how to create a channel listener and get an IInputChannel to receive messages for inbound operations from the adapter.

Important
The Oracle E-Business adapter only supports one-way receive. So, you must use IInputChannel to receive messages for inbound operations from Oracle E-Business Suite.

Copy Code
// Create a binding: specify the InboundOperationType, the PolledDataAvailableStatement, the PollingAction, and
// the PollingInput binding properties.
OracleEBSBinding binding = new OracleEBSBinding();
binding.InboundOperationType = InboundOperation.Polling;
binding.PolledDataAvailableStatement = "SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE";
binding.PollingAction = "InterfaceTables/Poll/FND/APPS/MS_SAMPLE_EMPLOYEE";
binding.PollingInput = "SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE";

// Create a binding parameter collection and set the credentials
ClientCredentials credentials = new ClientCredentials();
credentials.UserName.UserName = "myuser";
credentials.UserName.Password = "mypassword";

BindingParameterCollection bindingParams = new BindingParameterCollection();
bindingParams.Add(credentials);

// Get a listener from the binding and open it.
Uri connectionUri = new Uri("oracleebs://oracle_ebs_instance/");
IChannelListener<IInputChannel> listener = binding.BuildChannelListener<IInputChannel>(connectionUri, bindingParams);
listener.Open();

// Get a channel from the listener and open it.
IInputChannel channel = listener.AcceptChannel();
channel.Open();

See Also

Other Resources

Developing Applications by Using the WCF Channel Model

© 2014 Microsoft Corporation. All rights reserved.


Performing an Insert Operation on an Interface Table Using the WCF Channel Model

The Oracle E-Business adapter discovers a set of Insert, Select, Update, and Delete operations on Oracle E-Business Suite interface tables. By using these operations, you can perform simple Insert, Select, Update, and Delete statements qualified by a Where clause on a target interface table. This topic provides instructions on how to perform an Insert operation on an interface table using the WCF channel model.

For more information on how the adapter supports these operations, see Operations on Interface Tables and Interface Views. For more information about how to perform operations on Oracle E-Business Suite using the WCF Channel model, see Overview of Using the WCF Channel Model with the Adapter.

About the Examples Used in this Topic

The example in this topic performs operations on the MS_SAMPLE_EMPLOYEE interface table. The table is created by running the script provided with the samples. For more information about samples, see Samples. A sample, InsertOperation, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

The Insert Message

To perform operations on the Oracle E-Business Suite using the WCF channel model, you must have the request message specific to the operation. The request message to perform an Insert operation on the MS_SAMPLE_EMPLOYEE interface table resembles the following:

Copy Code
<Insert xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/FND/APPS/MS_SAMPLE_EMPLOYEE">
  <RECORDSET>
    <InsertRecord xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableViewRecord/APPS/MS_SAMPLE_EMPLOYEE">
      <EMP_NO>10050</EMP_NO>
      <NAME>John Smith</NAME>
      <DESIGNATION>Manager</DESIGNATION>
      <SALARY>500000</SALARY>
      <JOIN_DATE>1999-05-31</JOIN_DATE>
    </InsertRecord>
  </RECORDSET>
</Insert>

This request message inserts a record with following details:

Copy Code
Employee Number = 10050
Name = Tom Smith
Designation = Manager
Salary = 500000

You must copy the message to a file, e.g. InsertRequest.xml. This file is used in this example to send the request message to Oracle E-Business Suite using the Oracle E-Business adapter. For more information about the message schema for operations on table, see Message Schemas for Insert, Update, Delete, and Select Operations.

Creating a WCF Channel Application

This section provides instructions on how to create a WCF channel application to perform an Insert operation on the MS_SAMPLE_EMPLOYEE interface table.

To create a WCF channel application for inserting records into the table

  1. Create a Visual C# project in Visual Studio. For this topic, create a console application.

  2. In the Solution Explorer, add reference to Microsoft.Adapters.OracleEBS, Microsoft.ServiceModel.Channels, System.ServiceModel, and System.Runtime.Serialization.

  3. Open the Program.cs file and add the following namespaces:

    • Microsoft.Adapters.OracleEBS

    • Microsoft.ServiceModel.Channels

    • System.ServiceModel

    • System.ServiceModel.Channels

    • System.Xml

  4. Create the binding and endpoint.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
EndpointAddress address = new EndpointAddress("oracleebs://ebs_instance_name");

  5. Because you are performing an operation on an interface table, you must set the application context. In this example, to set the application context, you specify the OracleUserName, OraclePassword, and OracleEBSResponsibilityName binding properties. For more information about application context, see Setting Application Context.

    Copy Code
    binding.OracleUserName = "myOracleEBSUserName";
binding.OraclePassword = "myOracleEBSPassword";
binding.OracleEBSResponsibilityName = "myOracleEBSResponsibility";

  6. Create and open the channel factory. This application sends request message to Oracle E-Business Suite and receives a response, hence you must implement the IRequestChannel interface.

    Copy Code
    ChannelFactory<IRequestChannel> factory = new ChannelFactory<IRequestChannel>(binding, address);
factory.Credentials.UserName.UserName = "<Enter user name here>";
factory.Credentials.UserName.Password = "<Enter password here>";
factory.Open();

  7. Create and open the channel.

    Copy Code
    IRequestChannel channel;
try
{
   channel = factory.CreateChannel();
   channel.Open();
}
catch (Exception ex)
{
   Console.WriteLine("Exception :" + ex.Message);
   throw;
}

  8. Create and send the request message.

    Copy Code
    XmlReader readerIn;
try
{
   readerIn = XmlReader.Create("InsertRequest.xml");
   Console.WriteLine("Reader created");
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}
Message messageIn;
Message messageOut;
try
{
   messageIn = Message.CreateMessage(MessageVersion.Default, "InterfaceTables/Insert/FND/APPS/MS_SAMPLE_EMPLOYEE", readerIn);
   messageOut = channel.Request(messageIn);
}
catch (Exception ex)
{
   Console.WriteLine("Exception: " + ex.Message);
   throw;
}

    While creating the request message, you must specify the message action that indicates the action that the adapter performs on the interface table. To perform an Insert operation on the MS_SAMPLE_EMPLOYEE table, the message action is InterfaceTables/Insert/FND/APPS/MS_SAMPLE_EMPLOYEE. For information about how you can determine the message action for various operations on tables, see Message Schemas for Insert, Update, Delete, and Select Operations.

  9. Get the response message.

    Copy Code
    XmlReader readerOut = messageOut.GetReaderAtBodyContents();
XmlDocument doc = new XmlDocument();
doc.Load(readerOut);
doc.Save("C:\\Response.xml");

  10. Close the message, channel, and channel factory.

    Copy Code
    messageOut.Close();
channel.Close();
factory.Close();

  11. Build the project. After building the project, you must copy the request message, InsertRequest.xml, at the same location as your project executable. Typically, this location is \bin\Debug\ under your project directory.

  12. Run the application. The response message, Response.xml, is saved at the location you specified in the application. The response message contains the number or records inserted and resembles the following:

    Copy Code
    <InsertResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/InterfaceTables/FND/APPS/MS_SAMPLE_EMPLOYEE">
  <InsertResult>1</InsertResult>
</InsertResponse>

    The value “1” denotes that a single record is inserted into the MS_SAMPLE_EMPLOYEE table.

See Also

Other Resources

Developing Applications by Using the WCF Channel Model

© 2014 Microsoft Corporation. All rights reserved.


Polling Using SELECT Statement Using the WCF Channel Model

You can configure the Oracle E-Business adapter to receive periodic data-change messages by using a SELECT statement to continuously poll the interface tables, interface views, tables and views in Oracle E-Business Suite. You can specify a SELECT statement as a polling statement that the adapter executes periodically to poll Oracle E-Business Suite. You can also specify a post-poll PL/SQL code block that the adapter executes after the polling statement is executed.

To enable polling, you must specify certain binding properties as described in this topic. For more information about how the adapter supports polling, see Support for Inbound Calls Using Polling.

Configuring a Polling Operation with Oracle E-Business Suite Adapter Binding Properties

The following table summarizes the Oracle E-Business adapter binding properties that you use to configure the adapter to receive data change messages. You must specify these binding properties while running the polling application.

Binding Property Description

InboundOperationType

Specifies whether you want to perform Polling or Notification inbound operation. Default is Polling.

PolledDataAvailableStatement

Specifies the SQL statement that the adapter executes to determine whether any data is available for polling. Only if a record is available, the SELECT statement you specify for the PollingInput binding property will be executed.

PollingInterval

Specifies the interval, in seconds, at which the Oracle E-Business adapter executes the statement specified for the PolledDataAvailableStatement binding property. The default is 30 seconds. The polling interval determines the time interval between successive polls. If the statement is executed within the specified interval, the adapter sleeps for the remaining time in the interval.

PollingInput

Specifies the polling statement. To poll using a SELECT statement, you must specify a SELECT statement for this binding property. The default is null.

You must specify a value for PollingInput binding property to enable polling. The polling statement is executed only if there is data available for polling, which is determined by the PolledDataAvailableStatement binding property.

PollingAction

Specifies the action for the polling operation. You can determine the polling action from the service interface generated for the operation using the Add Adapter Service Reference Visual Studio Plug-in.

PostPollStatement

Specifies a statement block that is executed after the statement specified by the PollingInput binding property is executed.

PollWhileDataFound

Specifies whether the Oracle E-Business adapter ignores the polling interval and continuously executes the polling statement, if data is available in the table being polled. If no data is available in the table, the adapter reverts to execute the polling statement at the specified polling interval. Default is false.

For a more complete description of these properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For a complete description of how to use the Oracle E-Business adapter to poll the Oracle database, read the remainder of this topic.

How This Topic Demonstrates Polling

In this topic, to demonstrate how the Oracle E-Business adapter supports receiving data change messages using SELECT statements, you poll the MS_SAMPLE_EMPLOYEE interface table in the Application Object Library application. This table is created when you run the create_apps_artifacts.sql script provided with the samples to create these objects in Oracle E-Business Suite.

To demonstrate a polling operation, we do the following:

  • Specify a SELECT statement for the PolledDataAvailableStatement binding property to determine where the interface table being polled (MS_SAMPLE_EMPLOYEE) has any data. In this example, you can set this binding property as:

    Copy Code
    SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE
    This ensures that the adapter executes the polling statement only when the MS_SAMPLE_EMPLOYEE interface table has some records.

  • Specify a SELECT statement for the PollingInput binding property. This statement retrieves all the rows in the MS_SAMPLE_EMPLOYEE interface table. In this example, you can set this binding property as:

    Copy Code
    SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE
    Note
    For information about the FOR UPDATE clause used in the SELECT statement, see Specifying a FOR UPDATE Clause in the Polling Statement.

  • Specify a DELETE statement as part of the PostPollStatement binding property. This statement will delete all data from MS_SAMPLE_EMPLOYEE interface table. In this example, you can set this binding property as:

    Copy Code
    DELETE FROM MS_SAMPLE_EMPLOYEE
    After this happens, the next time the statement specified for PollingInput will be executed, it will not fetch any data.

  • Until more data is added to the MS_SAMPLE_EMPLOYEE interface table, you will not get any polling messages so you must repopulate the MS_SAMPLE_EMPLOYEE interface table with new records. You can do so by running the insert_apps_data.sql script provided with the samples. After you run this script, the next polling operation will fetch the new records inserted into the table.

Consuming the Polling Request Message

The adapter invokes the polling operation on your code to poll the Oracle E-Business Suite. That is, the adapter sends a polling request message that you receive over an IInputChannel channel shape. The polling request message contains the result set of the query specified by the PollingInput binding property. You can consume the polling message in one of two ways:

  • To consume the message using node-value streaming, you must call the WriteBodyContents method on the response message and pass it an XmlDictionaryWriter that implements node-value streaming.

  • To consume the message using node streaming, you can call GetReaderAtBodyContents on the response message to get an XmlReader.

About the Examples Used in this Topic

The examples in this topic poll the MS_SAMPLE_EMPLOYEE interface table. A script to generate the table is supplied with the samples. For more information about the samples, see Samples. A sample, SelectPolling_ChannelModel, which is based on this topic, is also provided with the Oracle E-Business adapter samples.

Receiving Inbound Messages for Polling Operation Using the WCF Channel Model

This section provides instructions on how to write a .NET application (channel model) to receive inbound polling messages using the Oracle E-Business adapter.

To receive polling messages from the adapter

  1. Create a Microsoft Visual C#® project in Visual Studio. For this topic, create a console application.

  2. In the Solution Explorer, add reference to Microsoft.Adapters.OracleEBS, Microsoft.ServiceModel.Channels, System.ServiceModel, and System.Runtime.Serialization.

  3. Open the Program.cs file and add the following namespaces:

    • Microsoft.Adapters.OracleEBS

    • System.ServiceModel

    • System.ServiceModel.Description

    • System.ServiceModel.Channels

    • System.Xml

  4. Specify a connection URI. For more information about the adapter connection URI, see The Oracle E-Business Suite Connection URI.

    Copy Code
    Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name");

  5. Create an instance of OracleEBSBinding and set the binding properties required to configure polling. At a minimum you must set the InboundOperationType, PolledDataAvailableStatement, PollingInput, and PollingAction binding properties. For more information about binding properties used to configure polling, see Support for Inbound Calls Using Polling.

    Copy Code
    OracleEBSBinding binding = new OracleEBSBinding();
binding.InboundOperationType = InboundOperation.Polling;
binding.PolledDataAvailableStatement = "SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE";
binding.PollingInput = "SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE";
binding.PollingAction = "InterfaceTables/Poll/FND/APPS/MS_SAMPLE_EMPLOYEE";
binding.PostPollStatement = "DELETE FROM MS_SAMPLE_EMPLOYEE";

  6. Because you are polling an interface table, you must also set the applications context. For more information about application context and binding properties required for setting application context, see Setting Application Context.

    Copy Code
    binding.OracleUserName = "<Enter user name here>";
binding.OraclePassword = "<Enter password here>";
binding.OracleEBSResponsibilityName = "<Enter responsibility here>";

  7. Create a binding parameter collection and set the credentials.

    Copy Code
    ClientCredentials credentials = new ClientCredentials();
credentials.UserName.UserName = "<Enter user name here>";
credentials.UserName.Password = "<Enter password here>";

BindingParameterCollection bindingParams = new BindingParameterCollection();
bindingParams.Add(credentials);

  8. Create a channel listener and open it. You create the listener by invoking BuildChannelListener<IInputChannel> method on the OracleEBSBinding.

    Copy Code
    IChannelListener<IInputChannel> listener = binding.BuildChannelListener<IInputChannel>(connectionUri, bindingParams);
listener.Open();

  9. Get an IInputChannel channel by invoking the AcceptChannel method on the listener and open it.

    Copy Code
    IInputChannel channel = listener.AcceptChannel();
channel.Open();

  10. Invoke Receive on the channel to get the next inbound message from the adapter.

    Copy Code
    Message message = channel.Receive();

  11. Consume the result set returned by the inbound operation. You can consume the message using either an XmlReader or an XmlDictionaryWriter.

    Copy Code
    XmlReader reader = message.GetReaderAtBodyContents();

  12. Close the channel when you have completed processing the request.

    Copy Code
    channel.Close()
    Important
    You must close the channel after you have finished processing the inbound operation. Failure to close the channel may affect the behavior of your code.

  13. Close the listener when you are finished receiving data-changed messages.

    Copy Code
    listener.Close()
    Important
    Closing the listener does not close channels created using the listener. You must explicitly close each channel created using the listener.

Example

The following example shows a polling application that polls the MS_SAMPLE_EMPLOYEE interface table. The PollingInput property contains the select statement that reads all the data from the MS_SAMPLE_EMPLOYEE table and the post poll statement deletes all the data from the same table. The polling message is written to C:\PollingOutput.xml.

Subsequent polling messages will not contain any records until more data is added to the MS_SAMPLE_EMPLOYEE interface table. You can do so by running the insert_apps_data.sql script provided with the samples. After you run this script, the next polling operation will fetch the new records inserted into the table. The adapter will continue to poll until you close the service host by pressing <RETURN>.

Copy Code
using System;
using Microsoft.Adapters.OracleEBS;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.ServiceModel.Channels;
using System.Xml;

namespace SelectPolling_ChannelModel
{
    class Program
    {
        static void Main(string[] args)
        {
            Console.WriteLine("Sample started. This sample will poll 5 times and will perform the following tasks:");
            Console.WriteLine("Press any key to start polling...");
            Console.ReadLine();
            IChannelListener<IInputChannel> listener = null;

            IInputChannel channel = null;

            try
            {
                TimeSpan messageTimeout = new TimeSpan(0, 0, 30);

                OracleEBSBinding binding = new OracleEBSBinding();
                binding.InboundOperationType = InboundOperation.Polling;
                binding.PolledDataAvailableStatement = "SELECT COUNT (*) FROM MS_SAMPLE_EMPLOYEE";
                binding.PollingInput = "SELECT * FROM MS_SAMPLE_EMPLOYEE FOR UPDATE";
                binding.PollingAction = "InterfaceTables/Poll/FND/APPS/MS_SAMPLE_EMPLOYEE";
                binding.PostPollStatement = "DELETE FROM MS_SAMPLE_EMPLOYEE";
                binding.OracleUserName = "<Enter user name here>";
                binding.OraclePassword = "<Enter password here>";
                binding.OracleEBSResponsibilityName = "<Enter responsibility here>";

                Uri ConnectionUri = new Uri("oracleebs://ebs_instance_name?");

                ClientCredentials credentials = new ClientCredentials();
                credentials.UserName.UserName = "<Enter user name here>";
                credentials.UserName.Password = "<Enter password here>";

                BindingParameterCollection bindingParams = new BindingParameterCollection();
                bindingParams.Add(credentials);

                listener = binding.BuildChannelListener<IInputChannel>(ConnectionUri, bindingParams);
                listener.Open();

                channel = listener.AcceptChannel();
                channel.Open();

                Console.WriteLine("Channel and Listener opened...");
                Console.WriteLine("\nWaiting for polled data...");
                Console.WriteLine("Receive request timeout is {0}", messageTimeout);

                // Poll five times with the specified message timeout
                // If a timeout occurs polling will be aborted
                for (int i = 0; i < 5; i++)
                {
                    Console.WriteLine("Polling: " + i);
                    Message message = null;
                    XmlReader reader = null;
                    try
                    {
                        //Message is received so process the results
                        message = channel.Receive(messageTimeout);
                    }
                    catch (System.TimeoutException toEx)
                    {
                        Console.WriteLine("\nNo data for request number {0}: {1}", i + 1, toEx.Message);
                        continue;
                    }

                    // Get the query results using an XML reader
                    try
                    {
                        reader = message.GetReaderAtBodyContents();
                    }
                    catch (Exception ex)
                    {
                        Console.WriteLine("Exception :" + ex);
                        throw;
                    }

                    XmlDocument doc = new XmlDocument();
                    doc.Load(reader);
                    using (XmlWriter writer = XmlWriter.Create("C:\\PollingOutput.xml"))
                    {
                        doc.WriteTo(writer);
                        Console.WriteLine("The polling response is saved at 'C:\\PollingOutput.xml'");
                    }
                    // return the cursor
                    Console.WriteLine();

                    // close the reader
                    reader.Close();

                    message.Close();
                }
                Console.WriteLine("\nPolling done -- hit <RETURN> to finish");
                Console.ReadLine();
            }
            catch (Exception ex)
            {
                Console.WriteLine("Exception is: " + ex.Message);
                Console.ReadLine();
                if (ex.InnerException != null)
                {
                    Console.WriteLine("Inner Exception is: " + ex.InnerException.Message);
                    Console.ReadLine();
                }
            }
            finally
            {
                // IMPORTANT: close the channel and listener to stop polling
                if (channel != null)
                {
                    if (channel.State == CommunicationState.Opened)
                        channel.Close();
                    else
                        channel.Abort();
                }

                if (listener != null)
                {
                    if (listener.State == CommunicationState.Opened)
                        listener.Close();
                    else
                        listener.Abort();
                }
            }
        }
    }
}

See Also

Other Resources

Developing Applications by Using the WCF Channel Model

© 2014 Microsoft Corporation. All rights reserved.


Using the Oracle E-Business Adapter with Microsoft Office SharePoint Server

Most line-of-business (LOB) applications have proprietary interfaces that are accessible to relatively few people with the required subject matter expertise. However, because information workers need relevant information at all levels in an organization, the subject matter experts have to export required data into more familiar applications, like Microsoft Excel, for information workers to consume the information.

The new collection of Microsoft Office client applications and features bridges this gap by bringing backend business data into the most common interface for information workers, Microsoft Office. Microsoft Office client applications seamlessly present data from LOB applications through interfaces familiar to information workers. One example is the Business Data Catalog in Microsoft Office SharePoint Server.

In This Section

  • About Business Data Catalog

  • Using the Oracle E-Business Adapter to Integrate the Oracle E-Business Suite with the Business Data Catalog and Microsoft Office SharePoint Server

  • Considerations While Using the Oracle-Business Adapter with Microsoft Office SharePoint Server

  • How Do I Use a Custom Web Part?

See Also

Other Resources

Development

© 2014 Microsoft Corporation. All rights reserved.


About Business Data Catalog

The Business Data Catalog is a new integration component in Microsoft Office SharePoint Server 2007 and later. The Business Data Catalog is a shared service and surfaces business data from backend applications via databases and Web services, without the need for writing any code. It is a metadata repository that defines business entities like customers, invoices, and purchase orders. Once defined, clients can use these entities.

The Business Data Catalog provides a Business Data Catalog Definition Editor to help you author application definition files for the Business Data Catalog in Microsoft Office SharePoint Server 2007 and later. Using the Business Data Catalog Definition Editor, you can create and edit metadata for business applications.

For more information about the Business Data Catalog, see "Business Data Catalog" at http://go.microsoft.com/fwlink/?LinkId=103882.

See Also

Other Resources

Using the Oracle E-Business Adapter with Microsoft Office SharePoint Server

© 2014 Microsoft Corporation. All rights reserved.


Using the Oracle E-Business Adapter to Integrate the Oracle E-Business Suite with the Business Data Catalog and Microsoft Office SharePoint Server

The Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK includes the WCF LOB Adapter Service Development Wizard, which generates a WCF service for specific LOB artifacts. This WCF service is hosted in a hosting environment such as Microsoft Internet Information Services (IIS). The Business Data Catalog Definition Editor uses the URL where the WCF service is hosted to get the Web Services Description Language (WSDL) for the WCF service. Using the WSDL, the Business Data Catalog Definition Editor extracts the methods available to the WCF service. These methods can be used to establish entities and the association between the entities.

The Business Data Catalog Definition Editor helps you create an application definition file (an XML file) that Microsoft Office SharePoint Server can consume. Once the application definition file is imported to Microsoft Office SharePoint Server, you can create Web Parts to present the information from enterprise applications. For more information, see “Creating Web Parts” in Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite in Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site.

Tutorial

To demonstrate how to use the Oracle E-Business adapter with Microsoft Office SharePoint Server, the BizTalk Adapter Pack includes a tutorial that provides step-by-step instructions to present data from Oracle E-Business Suite on a SharePoint site. See Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site.

See Also

Other Resources

Using the Oracle E-Business Adapter with Microsoft Office SharePoint Server

© 2014 Microsoft Corporation. All rights reserved.


Considerations While Using the Oracle-Business Adapter with Microsoft Office SharePoint Server

This topic contains information about the issues you might encounter while using the Microsoft BizTalk Adapter for Oracle E-Business Suite with Microsoft Office SharePoint Server, along with resolutions. The issues are divided into two categories:

  • General issues

  • Issues involving custom Web Parts

General Issues

This section contains issues that have no resolution.

Issue 1: The simple type data returned by the WCF service is not displayed

Explanation: Microsoft Office SharePoint Server expects the data returned by the WCF service to be of DataSet or Collection type only. If the data returned by the WCF service is of simple type, Microsoft Office SharePoint Server does not display the data.

Resolution: No resolution. It is a known limitation with Microsoft Office SharePoint Server.

Issue 2: An error message is displayed if the data returned by the WCF service is NULL

Explanation: If the data returned by the WCF service is a NULL value, Microsoft Office SharePoint Server displays an error message. For example, suppose you are using the Business Data List Web Part for the Finder method instance, and are searching for customers in Oracle E-Business Suite based on a search expression. The search expression that you specified fetches a NULL value. In this case, Microsoft Office SharePoint Server will display an error message.

Resolution: No resolution. It is a known limitation with Microsoft Office SharePoint Server.

Issue 3: An array of simple type returned by the WCF service is not displayed

Explanation: If the data returned by the WCF service is an array of simple type, Microsoft Office SharePoint Server does not display the data. Moreover, when you execute a method instance in Business Data Catalog Definition Editor that returns an array of simple type, the following error message is displayed: “Backend system adapter returned a structure incompatible with the corresponding metadata (MethodInstance, Parameter or TypeDescriptor).”

Resolution: No resolution. It is a known limitation with Microsoft Office SharePoint Server and Business Data Catalog Definition Editor.

Issue 4: Cannot import an application definition file that contains a complex type parameter having more than 300 fields

Explanation: Microsoft Office SharePoint Server cannot import an application definition file that has more than 300 fields in the complex type parameter returned by the WCF service, and displays an error message if you try to do so. This is due to the limitation of Microsoft Office SharePoint Server of not being able to display more than 300 fields of a complex type parameter.

Resolution: Use the Business Data Catalog Definition Editor to limit the number of fields of the complex type parameter to less than or equal to 300. Depending on your requirement, you can delete the fields of the complex type parameter in the Business Data Catalog Definition Editor that you do not require to be displayed in Microsoft Office SharePoint Server. Alternatively, you can also export the application definition file from Business Data Catalog Definition Editor with all the fields, and then modify the application definition file in a notepad or any XML authoring application to delete the fields that are not required in order to limit the number of fields to 300.

Issues Involving Custom Web Parts

This section contains issues that require the use of custom Web Part for a resolution. For detailed information about using a custom Web Part to resolve issues that might come up while working with Oracle E-Business adapter and Microsoft Office SharePoint Server, see How Do I Use a Custom Web Part?.

Issue 1: Limitation with displaying a single record in Microsoft Office SharePoint Server based on multiple values

Explanation: If you want to display a single record in Microsoft Office SharePoint Server based on multiple values (input parameters) from Oracle E-Business Suite, you cannot use any of the three Web Parts (Business Data List, Business Data Item, and Business Data Related List) specified in Step 3: Create a SharePoint Application to Retrieve Data from Oracle E-Business Suite in Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site.

Resolution: You must use a custom Web Part to do this. For information about using a custom Web Part, see How Do I Use a Custom Web Part?. In “Step 1: Create a Custom Web Part” of that topic, you can use the following code sample in step 5. The following code sample takes BankCountry and BankKey as the input parameters, and then displays them as a single record in Microsoft Office SharePoint Server.

Copy Code
namespace CustomWebPart
{
    public class CustomWebPart : WebPart
    {
        private string displayText = "Hello World!";

        [WebBrowsable(true), Personalizable(true)]
        public string DisplayText
        {
            get { return displayText; }
            set { displayText = value; }
        }
        protected override void Render(System.Web.UI.HtmlTextWriter writer)
        {
            string BankCountry = "US";
            string BankKey = "134329042";

/***Step 1: Get the required entity and method.***/

            LobSystem newSystem = ApplicationRegistry.GetLobSystems()["BAPI_BANK_GETDETAIL"]; // Name specified in application definition file
            LobSystemInstance newSystemInstance = newSystem.GetLobSystemInstances()["BAPI_BANK_GETDETAIL_Instance"]; // Name specified in application definition file
            Entity CategoryEntity = newSystem.GetEntities()["Entity"]; // Name specified in application definition file
            Method newMethod = CategoryEntity.GetMethods()["BAPI_BANK_GETDETAIL"]; // Name specified in application definition file
            MethodInstance methodInstance = newMethod.GetMethodInstances()["MethodInstance"]; // Name specified in application definition file

/***Step 2: Get the list of input parameters.***/

            Object[] args = methodInstance.GetMethod().CreateDefaultParameterInstances(methodInstance); //Get the default values of the input parameters.
            Object[] ArgsInput = new Object[args.Length];

/***Step 3: Assign them required values.***/

            Type t = null;
            char[] myString = BankCountry.ToCharArray();
            String s = new String(myString);
            t = s.GetType();
            ArgsInput[0] = Activator.CreateInstance(t, myString);

            myString = BankKey.ToCharArray();
            s = new String(myString);
            t = s.GetType();
            ArgsInput[1] = Activator.CreateInstance(t, myString);

/***Step 4: Execute the particular method instance using the required value.***/

            IEntityInstance IE = (IEntityInstance)CategoryEntity.Execute(methodInstance, newSystemInstance, ref ArgsInput); //Method instance of type Specific Finder is being used here.

/***Step 5: Display the output on the custom Web Part in Microsoft Office SharePoint Server.***/

            writer.Write("<table>");
            writer.Write("<tr>");
            foreach (Field f in CategoryEntity.GetFinderView().Fields)
            {
                writer.Write("<td>");
                writer.Write(IE[f]);
                writer.Write("</td>");
            }
            writer.Write("</tr>");
            writer.Write("</table>");
        }
    }
Note
The application definition file must contain the Specific Finder method instance. A Specific Finder method finds a specific record based on an identifier. For information about creating a Specific Finder method instance, see “Requirement 2: Retrieve Details for a Specific Customer from the List of Customers” in Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts in Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site.

Issue 2: Cannot specify values to array elements

Explanation: If the input parameter of the WCF service is an array, you cannot specify values to the array elements using filters that are defined in the application definition file created using the Business Data Catalog Definition Editor. It implies that you cannot use the Business Data List or Business Data Item Web Part in Microsoft Office SharePoint Server to specify values for these input parameters (elements of array) to the WCF service. This is because of the way arrays are defined in the application definition file.

Resolution: Use a custom Web Part to assign values to array elements. For information about using a custom Web Part, see How Do I Use a Custom Web Part?. For example, you can use the following code sample in step 3 in “Issue 1: Limitation with displaying a single record in Microsoft Office SharePoint Server based on multiple values” to assign values to array elements.

Copy Code
/***Assign required values to parameters of type array.***/
/***Assumption is that the ith parameter of Method is of type Array and all the simple type elements in the array are of string type.***/

            Type t = asm.GetType(args[i].GetType().ToString()); // Get type of the parameter
            Type TElement = t.GetElementType(); // Getting type of element of array
            int index = 5; //Size of Array
            Array ElementArray = Array.CreateInstance(TElement, index); //Creating an array of length: index

            for (int ind = 0; ind < index; ind++)
            {
                //Creating an instance of an element of array
                object ElementType = Activator.CreateInstance(TElement);
                FieldInfo[] FI = ElementType.GetType().GetFields();
                for (int f = 0; f < FI.Length; f++)
                {
                    ElementType.GetType().GetFields()[f].SetValue(ElementType, (Object)"ElementValue");
                }
                ElementArray.SetValue(ElementType, ind);
            }

            ArgsInput[i] = (object)ElementArray; // As shown in sample, ArgsInput is fed as input while executing Method Instance

Issue 3: Limitation with specifying NULL values to complex type parameters

Explanation: If you do not specify any value for a complex type parameter from a Web Part in Microsoft Office SharePoint Server, NULL should be passed on as the value for the complex type parameter to the WCF service. However, a non-NULL value is passed for the complex type parameter, and NULL is passed for its children elements (of simple type). This causes a mismatch between the expected message schema and the message schema that is passed on to the WCF service. As a result, the Oracle E-Business adapter might display an error message.

Note
To find out the default value of a complex type parameter when no value is passed from a Web Part in Microsoft Office SharePoint Server, use step 2 in the code sample mentioned in “Issue 1: Limitation with displaying a single record in Microsoft Office SharePoint Server based on multiple values.”

Resolution: Use a custom Web Part to assign a NULL value to the complex type parameter. For information about using a custom Web Part, see How Do I Use a Custom Web Part?.

See Also

Other Resources

Using the Oracle E-Business Adapter with Microsoft Office SharePoint Server

© 2014 Microsoft Corporation. All rights reserved.


How Do I Use a Custom Web Part?

This section provides information about using a custom Web Part with Microsoft Office SharePoint Server. To use a custom Web Part, you must do the following:

  1. Create a custom Web Part

  2. Deploy the custom Web Part to a SharePoint portal

  3. Configure the SharePoint portal to use the custom Web Part

Before You Begin

Before you create a custom Web Part:

  • Publish the Oracle E-Business Suite artifacts as a WCF service. For more information, see Step 1: Use the Oracle E-Business Adapter to Create and Publish a WCF Service in Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site.

  • Create an application definition file for the Oracle E-Business Suite artifacts using the Business Data Catalog in Microsoft Office SharePoint Server. For more information, see Step 2: Create an Application Definition File for the Oracle E-Business Suite Artifacts in Tutorial: Presenting Data from Oracle E-Business Suite on a SharePoint Site.

Step 1: Create a custom Web Part

To create a custom Web Part using Visual Studio, do the following:

  1. StartVisual Studio 2013, and then create a project.

  2. In the New Project dialog box, from the Project types pane, select Visual C#. From the Templates pane, select Class Library.

  3. Specify a name and location for the solution. For this topic, specify CustomWebPart in the Name and Solution Name boxes. Specify a location, and then click OK.

  4. Add a reference to the System.Web component into the project. Right-click the project name in Solution Explorer, and then click Add Reference. In the Add Reference dialog box, select System.Web in the .NET tab, and then click OK. The System.Web component contains the required namespace of System.Web.UI.WebControls.WebParts.

  5. Add the required code based on your issue in the project. For the code sample that is relevant to a certain issue, see “Issues Involving Custom Web Parts” in Considerations While Using the Oracle-Business Adapter with Microsoft Office SharePoint Server.

  6. Build the project. On successful build of the project, a .dll file, CustomWebPart.dll, will be generated in the <project folder>/bin/Debug folder.

  7. Only for 64-bit computer: Sign the CustomWebPart.dll file with a strong name before performing the following steps. Otherwise, you will not be able to import, and hence use the CustomWebPart.dll in the SharePoint portal in “Step 3: Configure the SharePoint Portal to use the custom Web Part.” For information about how to sign an assembly with a strong name, see http://go.microsoft.com/fwlink/?LinkId=197169.

Step 2: Deploy the custom Web Part to a SharePoint Portal

You must do the following to make the CustomWebPart.dll file (custom Web Part) that is created in “Step 1: Create a custom Web Part” of this topic usable on the SharePoint portal:

  • Copy the CustomWebPart.dll file to the bin folder of the SharePoint Portal: Microsoft Office SharePoint Server creates portals under the <root drive>:\Inetpub\wwwroot\wss\VirtualDirectories folder. A folder is created for each portal, and can be identified with the port number. You must copy the CustomWebPart.dll file created in “Step 1: Create a custom Web Part” of this topic to the <root drive>:\Inetpub\wwwroot\wss\VirtualDirectories\<Port_Number>\bin folder. For example, if the port number of your SharePoint portal is 13614, you must copy the CustomWebPart.dll file to the <root drive>:\Inetpub\wwwroot\wss\VirtualDirectories\13614\bin folder.

    Tip
    Another way to find the folder location of your SharePoint portal is by using the Internet Information Services (IIS) Manager window (Start > Run > inetmgr). Locate your SharePoint portal in the Internet Information Services (IIS) Manager window ([computer_name] > Web Sites > [Portal-Name]), right-click, and then click Properties in the shortcut menu. In the properties dialog box of the SharePoint portal, click the Home Directory tab, and then select the Local path box.

  • Add the Safe Control Entry in the web.config File: Because the CustomWebPart.dll file will be used on different computers and by multiple users, you must declare the file as “safe.” To do so, open the web.config file located in the SharePoint portal folder at <root drive>:\Inetpub\wwwroot\wss\VirtualDirectories\<Port_Number>. Under the <SafeControls> section of the web.config file, add the following safe control entry:

    • On 32-bit computer:

      Copy Code
      <SafeControl Assembly="CustomWebPart" Namespace="CustomWebPart" TypeName="*" Safe="True" />
    • On 64-bit computer:

      Copy Code
      <SafeControl Assembly="CustomWebPart, Version=1.0.0.0, Culture=neutral, PublicKeyToken=<PUBLICKKEYTOKEN_OF_CustomWebPart.dll>" Namespace="CustomWebPart" TypeName="*" Safe="True" />
    Save the web.config file, and then close it.

Step 3: Configure the SharePoint portal to use the custom Web Part

You need to add the custom Web Part to the Microsoft Office SharePoint Server Web Part Gallery, so that you can use it on your SharePoint portal. To do so:

  1. Start SharePoint 3.0 Central Administration. Click Start, point to All Programs, point to Microsoft Office Server, and then click SharePoint 3.0 Central Administration.

  2. In the left navigation pane, click the name of the Shared Service Provider (SSP) to which you want to add the custom Web Part.

  3. On the Shared Services Administration page, in the upper-right corner, click Site Actions, and then click Create.

  4. On the Site Settings page, click Web Parts under the Galleries column.

  5. On the Web Part Gallery page, to add the custom Web Part to the gallery, click New. At this point the custom Web Part is not available in the Web Part Gallery page.

  6. On the New Web Parts page, locate CustomWebPart (name of the custom Web Part) in the list, select the check box on the left, and then click Populate Gallery on the top of the page. This will add the CustomWebPart entry in the Web Part Gallery page.

Now you can use the custom Web Part (CustomWebPart) to create Web Parts in your SharePoint portal. The custom Web Part (CustomWebPart) will appear under the Miscellaneous section in the Add Web Parts page.

See Also

Other Resources

Using the Oracle E-Business Adapter with Microsoft Office SharePoint Server

© 2014 Microsoft Corporation. All rights reserved.


Samples

Samples for Microsoft BizTalk Adapter for Oracle E-Business Suite are categorized into:

  • BizTalk Server samples

  • WCF service model samples

  • WCF channel model samples

  • Microsoft Office SharePoint Server samples

The samples are available at http://go.microsoft.com/fwlink/?LinkID=196854. The SQL scripts for creating the interface tables, concurrent programs, tables, and packages used in the samples are also available along with the samples for the Oracle E-Business adapter.

The following tables contain the names and descriptions of the samples for the Oracle E-Business adapter.

BizTalk Server Samples

Sample Directory Name | Description
InterfaceTableInsert | Demonstrates how to insert records into an interface table in Oracle E-Business Suite using Oracle E-Business adapter.
ConcurrentProgram | Demonstrates how to invoke a concurrent program in Oracle E-Business Suite using the Oracle E-Business adapter.
RequestSet | Demonstrates how to invoke a request set in Oracle E-Business Suite using the Oracle E-Business adapter.
MsgContextProperty | Demonstrates how to use the message context properties exposed by the Oracle E-Business adapter to set application context to perform operations on artifacts in Oracle E-Business Suite using the Oracle E-Business adapter.
OracleEBS_CompositeOperation | Demonstrates how to perform composite operations in Oracle E-Business Suite using the Oracle E-Business adapter.
OracleNotifyIncremental | Demonstrates how to receive “incremental” query notification messages from Oracle using the Oracle E-Business adapter.
PollingUsingSelectStatement | Demonstrates how to configure a polling query using a SELECT statement and receive the results using the Oracle E-Business adapter.
PollingUsingStoredProc | Demonstrates how to configure a polling query using a stored procedure and receive the results using the Oracle E-Business adapter.

WCF Service Model Samples

Sample Directory Name | Description
ConcProgram_ServiceModel | Demonstrates how to invoke concurrent programs in Oracle E-Business Suite using the adapter.
ExecuteReader | Demonstrates how to invoke an ExecuteReader operation on Oracle E-Business Suite using the adapter.
Interface_Table_Ops | Demonstrates how to perform operations on interface tables in Oracle E-Business Suite using the adapter.
LargeDataTypes_ServiceModel | Demonstrates how to perform operations on tables with columns of large data types in Oracle E-Business Suite using the adapter.
Notification_ServiceModel | Demonstrates how to receive notifications from databases behind Oracle E-Business Suite using the adapter.
SelectPolling_ServiceModel | Demonstrates how to use a SELECT statement to poll an interface table in Oracle E-Business Suite using the adapter.
StoredProcPolling_ServiceModel | Demonstrates how to use a stored procedure to poll tables in Oracle E-Business Suite using the adapter.

WCF Channel Model Samples

Sample Directory Name | Description
InsertOperation | Demonstrates how to perform an Insert operation on an interface table in Oracle E-Business Suite using the adapter.
SelectPolling_ChannelModel | Demonstrates how to use a SELECT statement to poll an interface table in Oracle E-Business Suite using the adapter.

Microsoft Office SharePoint Server Samples

Sample Directory Name | Description
MOSS_Sample | Demonstrates how to use the Oracle E-Business adapter to create a Windows Communication Foundation (WCF) service from Oracle E-Business Suite artifacts, and then use the WCF service to display data in Microsoft Office SharePoint Server using a Business Data List Web Part.

See Also

Other Resources

Development

© 2014 Microsoft Corporation. All rights reserved.


How Do I?

The topics in this section describe how to perform various operations using the Microsoft BizTalk Adapter for Oracle E-Business Suite.

In This Section

  • Configure Transaction Isolation Level and Transaction Timeout

  • Set the Application Context Using Message Context Properties

See Also

Other Resources

Development

© 2014 Microsoft Corporation. All rights reserved.


Configure Transaction Isolation Level and Transaction Timeout

While performing inbound operations (Polling and Notification) using the Microsoft BizTalk Adapter for Oracle E-Business Suite with BizTalk Server, you should appropriately configure the transaction isolation level and the transaction timeout values. To do this:

  1. Start the BizTalk Server Administration console.

  2. In the console tree, expand the BizTalk Group, and then expand Applications.

  3. Expand the BizTalk application that you have deployed after generating the metadata using the Oracle E-Business adapter.

  4. Right-click Receive Ports, point to New, and then click One-way Receive Port.

  5. In the Receive Port Properties dialog box, on the General tab, type a name for the receive port.

  6. In the left pane of the Receive Port Properties dialog box, click Receive Locations, and then click New in the right pane to define a new receive location.

  7. In the Receive Location Properties dialog box, click WCF-Custom in the Type list.

  8. Click Configure adjacent to the Type list.

  9. In the WCF-Custom Transport Properties dialog box, click the Behavior tab.

  10. In the Behavior list, right-click ServiceBehavior, and click Add extension.

  11. In the Select Behavior Extension dialog box, select oracleEBSAdapterInboundTransactionBehavior, and click OK.

  12. In the left pane of the WCF-Custom Transport Properties, select the oracleEBSAdapterInboundTransactionBehavior service under ServiceBehavior.

  13. In the right pane of the WCF-Custom Transport Properties, specify appropriate values for the transactionIsolationLevel and transactionTimeout parameters. You can select any of the following transaction isolation levels: Serializable, RepeatableRead, ReadCommitted, ReadUncommitted, Snapshot, Chaos, and Unspecified. For information about these transaction isolation levels, see the Members section at http://go.microsoft.com/fwlink/?LinkId=126983.

    Important
    Oracle E-Business Suite supports only the following two transaction isolation levels: ReadCommitted and Serializable.

    Setting Transaction Isolation Level
  14. Click OK in the WCF-Custom Transport Properties dialog box.

  15. Click OK in the open dialog boxes to save the changes.

© 2014 Microsoft Corporation. All rights reserved.


Set the Application Context Using Message Context Properties

To perform operations on Oracle E-Business Suite artifacts using the Oracle E-Business adapter, you must set the application context appropriately. You can set the application context in the following ways:

  • By specifying the binding properties that the adapter exposes. For more information, see Setting Application Context.

  • By using message context properties that the adapter exposes. You must consider the following when setting the application context by using message context properties.

    • You can set values only for ApplicationShortName, OrganizationID, ResponsibilityKey, and ResponsibilityName by using message context properties. For the user name and password, you must use the binding properties. The value specified for the ResponsibilityKey message context property overrides the value specified for the ResponsibilityName message context property.

    • If you set the application context using both the binding properties and message context properties, the values specified for message context properties take precedence and override the values specified for the binding properties. However, for example, if you specify the application short name as a message context property, and the organization ID and responsibility name as binding properties, only the value for the application short name is taken from the message context property. The rest are picked from the relevant binding properties.

Why use message context properties over binding properties to set the application context? If you set the application context using binding properties, the WCF-Custom send port for the Oracle E-Business adapter can be used only for the specific organization ID, responsibility, and application that you specified for the binding properties. On the contrary, if you use the message context property, you can configure a “generic” WCF-Custom send port, and set the application context at the message level.

Adapter clients must set the message context properties on the message that is sent to Oracle E-Business Suite to invoke an operation on Oracle E-Business Suite. The messages in BizTalk Server are immutable. Hence, clients must first create a message from the existing message, and then set the message context properties on the new message. For the procedure described in this section, assume that the existing message is called Request, and the new message is called New_Request.

To set the message context properties for BizTalk applications

  1. Open the BizTalk project in Visual Studio.

  2. In Solution Explorer, right-click References, and then click Add References.

  3. In the Add Reference dialog box, click the Browse tab, and then browse to the location where the BizTalk property schema DLL for the Oracle E-Business adapter is available.

    This DLL, Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll, is installed by the BizTalk Adapter Pack at <installation drive>:\Program Files\Microsoft BizTalk Adapter Pack\bin.

  4. Select the DLL, and then click Add.

  5. In the BizTalk orchestration, add a message, New_Request. For the Message Type property, make sure you select the same type as the existing request message.

  6. Before the Send shape using which the message is sent to the send port, add a Construct Message shape and within that, a Message Assignment shape.

  7. Double-click the Message Assignment shape to open BizTalk Expression Editor.

  8. In BizTalk Expression Editor, add the following, and then click OK:

    Copy Code
    New_Request = Request;
New_Request(Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.ApplicationShortName) = "AR";
New_Request(Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.ResponsibilityKey) = "RECEIVABLES_VISION_OPERATIONS";
New_Request(Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.ResponsibilityName) = "Receivables, Vision Operations (USA)";
New_Request(Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.OrganizationId) = "204";
    Important
    The value specified for the ResponsibilityKey message context property overrides the value specified for the ResponsibilityName message context property.

  9. Make sure further processing of the orchestration is done by using the New_Request message.

  10. Before you can deploy this orchestration in BizTalk Server, you must add the assembly reference for Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll in the BizTalk application where you will be deploying the orchestration. To deploy an assembly in BizTalk Server:

    1. Start the BizTalk Server Administration console.

    2. In the console tree, expand BizTalk Group, then expand Applications, and then the application to which you want to add a BizTalk assembly.

    3. Right-click Resources, point to Add, and then click BizTalk Assemblies.

    4. In the Add Resources dialog box, click Add, navigate to the folder containing the BizTalk assembly file, which is <installation drive>:\Program Files\Microsoft BizTalk Adapter Pack\bin. Select the Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll file, and then click Open.

    5. On the Options tab, specify the options for installing the BizTalk assembly to the global assembly cache (GAC), and then click OK.

Setting the Language for Performing Operations

The Oracle E-Business adapter supports the Multi-Language Support (MLS) feature of Oracle E-Business Suite, and allows you to specify a language while performing operations. The adapter exposes the Language message context property to specify a language for performing operations.

The value specified for the Language message context property overrides the value of the Language binding property under the MlsSettings binding property. For more information about the MlsSettings binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

See Also

Other Resources

How Do I?

© 2014 Microsoft Corporation. All rights reserved.


Deployment

This section provides information about deploying the Microsoft BizTalk Adapter Pack. It also provides a link to information about troubleshooting common installation issues.

In This Section

  • Installing the BizTalk Adapter Pack

  • Troubleshooting Your Installation

© 2014 Microsoft Corporation. All rights reserved.


Installing the BizTalk Adapter Pack

See the BizTalk Adapter Pack installation guide for installation prerequisites and complete instructions for installing the BizTalk Adapter Pack. This document is installed on your computer, typically under <installation drive>:\Program Files\Microsoft BizTalk Adapter Pack\Documents.

See Also

Concepts

Troubleshooting Your Installation

Other Resources

Deployment

© 2014 Microsoft Corporation. All rights reserved.


Troubleshooting Your Installation

Installation of the Microsoft BizTalk Adapter Pack copies the product binaries on a computer and registers the bindings for each adapter. For information about troubleshooting BizTalk Adapter Pack installation issues, see Troubleshooting Installation Issues.

See Also

Other Resources

Deployment

© 2014 Microsoft Corporation. All rights reserved.


Troubleshooting

The BizTalk Adapter Pack uses or depends on several Microsoft technologies, including but not limited to the Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK, Microsoft Visual Studio, and Microsoft .NET Framework 4.5 or .NET Framework 4.5.1. The BizTalk Adapter Pack is built on top of the WCF LOB Adapter SDK, which in turn requires .NET Framework 4.5 or .NET Framework 4.5.1. The adapters can be consumed either by writing applications using Visual Studio or by creating BizTalk applications. For issues related to each of these technologies and products, see the respective documentation.

This section provides information about troubleshooting the BizTalk Adapter Pack, including:

  • Enabling tracing to diagnose issues with the adapters.

  • Handling installation and operational issues that you might encounter when working with the adapters, including probable cause and a resolution.

  • Using performance counters to gauge adapter performance.

  • Handling exceptions and errors, including probable cause, and a resolution.

In This Section

  • Diagnostic Tracing and Message Logging

  • Troubleshooting Installation Issues

  • Troubleshooting Operational Issues

  • Using Performance Counters

© 2014 Microsoft Corporation. All rights reserved.


Diagnostic Tracing and Message Logging

Diagnostic tracing helps to effectively diagnose problems that you might encounter when using the adapters. This topic provides information about the following three types of tracing supported with Microsoft BizTalk Adapter for Oracle E-Business Suite:

  • Oracle server-side tracing using a client identifier.

  • WCF tracing between the adapter client and the adapter.

  • WCF tracing within the adapter.

Oracle Server Side Tracing Using a Client Identifier

Oracle allows you to perform server-side tracing for the operations performed by client applications on the Oracle database. Because requests from client applications can be routed to different database sessions, it becomes difficult to trace the origin of the request. However, Oracle facilitates end-to-end application tracing using client identifiers. The Oracle E-Business adapter exposes the OracleConnectionClientId binding property that allows you to specify the client identifier at the design time for the connection used by the adapter to connect to Oracle. The adapter client identifier helps you in selective tracing of the operations performed by the adapter client on Oracle, and also allows you to filter and view the Oracle server traces based on the client identifier. For information about how you can enable tracing for client identifiers in Oracle, see http://go.microsoft.com/fwlink/?LinkId=135746.

WCF Tracing Between the Adapter Client and the Adapter

Adapter clients can enable WCF tracing to trace issues between the adapter client and the adapter. WCF tracing is used to trace the input XML that comes from the adapter client by using the WCF service model and is useful in diagnosing serialization issues. WCF tracing is not used for the WCF channel model or for output messages from the adapter to the adapter client. You can activate WCF tracing for BizTalk applications and WCF service model applications by adding an excerpt to the respective configuration files. Also, you can enable tracing both at design-time and run-time.

  • Tracing at design-time. For the design-time experience, you may use the Add Adapter Service Reference Plug-in, Consume Adapter Service Add-in, or the Add Adapter Metadata Wizard. All these tools can be used from Visual Studio. So, to enable tracing for the design-time experience, you must add the excerpt to the devenv.exe.config file located in <installation drive>:\Program Files\Microsoft Visual Studio <version>\Common7\IDE.

  • Tracing at run-time. For run-time tracing, you must add the excerpt depending on the application you are using.

    • For a BizTalk Server applications, you must add the excerpt to the BizTalk configuration file, typically BTSNTSvc.exe.config. For BizTalk Server 2013 R2, this file is available typically under <installation drive>:\Program Files\Microsoft BizTalk Server 2013 R2.

    • For a WCF service model .NET application, you must add the excerpt to the app.config file of your project.

To enable WCF tracing, add the following excerpt within the <configuration> tag.

Copy Code
<system.diagnostics>
    <sources>
      <source name ="System.ServiceModel" switchValue="Verbose">
        <listeners>
          <add name="xml" />
        </listeners>
      </source>
      <source name ="System.ServiceModel.MessageLogging"
              switchValue="Verbose, ActivityTracing">
        <listeners>
          <add name="xml" />
        </listeners>
      </source>
      <source name ="System.Runtime.Serialization" switchValue="Verbose">
        <listeners>
          <add name="xml" />
        </listeners>
      </source>
   </sources>
   <sharedListeners>
      <add name="xml" type="System.Diagnostics.XmlWriterTraceListener"
           traceOutputOptions="LogicalOperationStack"
           initializeData="C:\log\WCFTrace.svclog" />
   </sharedListeners>
   <trace autoflush="true" />
  </system.diagnostics>
  <system.serviceModel>
    <diagnostics>
      <messageLogging
           logEntireMessage="true"
           logMalformedMessages="false"
           logMessagesAtServiceLevel="true"
           logMessagesAtTransportLevel="false"/>
    </diagnostics>
  </system.serviceModel>

This saves the WCF traces to C:\log\WCFTrace.svclog. For more information about WCF tracing, see "Tracing" at http://go.microsoft.com/fwlink/?LinkId=91242.

Important
Make sure you mitigate potential security threats of exposing sensitive business data that can be caused when enabling tracing. For recommendations, see Best Practices.

WCF Tracing Within the Adapter

The adapters log different categories of useful information to the trace file such as errors, warnings, and information messages. Such information is useful in understanding the process flow within the adapter and diagnosing issues with the adapter. You can activate the WCF LOB Adapter SDK and adapter tracing for BizTalk applications and WCF service model applications by adding an excerpt to the respective configuration files. Also, you can enable tracing both at design-time and run-time.

  • Tracing at design-time. For the design-time experience, you may use the Add Adapter Service Reference Plug-in, Consume Adapter Service Add-in, or the Add Adapter Metadata Wizard. All these tools can be used from Visual Studio. So, to enable tracing for the design-time experience, you must add the excerpt to the devenv.exe.config file located in <installation drive>:\Program Files\Microsoft Visual Studio <version>\Common7\IDE.

  • Tracing at run-time. For run-time tracing, you must add the excerpt depending on the application you are using.

    • For a BizTalk Server applications, you must add the excerpt to the BizTalk configuration file, typically BTSNTSvc.exe.config. For BizTalk Server 2006 R2, this file is available typically under <installation drive>:\Program Files\Microsoft BizTalk Server 2006. For BizTalk Server 2013 R2, this file is available typically under <installation drive>:\Program Files\Microsoft BizTalk Server 2013 R2.

    • For a WCF service model .NET application, you must add the excerpt to the app.config file of your project.

To enable WCF LOB Adapter SDK and adapter tracing, add the following excerpt within the <configuration> tag.

Copy Code
<system.diagnostics>
    <sources>
      <source name="Microsoft.ServiceModel.Channels" switchValue="Error">
        <listeners>
          <add name="xml" />
        </listeners>
      </source>
      <source name="Microsoft.Adapters.OracleEBS" switchValue="Information">
        <listeners>
          <add name="xml" />
        </listeners>
      </source>
    </sources>
    <sharedListeners>
      <add name="xml" type="System.Diagnostics.XmlWriterTraceListener"
   traceOutputOptions="LogicalOperationStack"
          initializeData="C:\log\AdapterTrace.svclog" />
    </sharedListeners>
    <trace autoflush="true" />
  </system.diagnostics>

This saves the WCF traces to C:\log\AdapterTrace.svclog.

Viewing the Traces

You can use the Windows Communication Foundation (WCF) Service Trace Viewer tool to view the traces. For more information about the tool, see "Using Service Trace Viewer for Viewing Correlated Traces and Troubleshooting" at http://go.microsoft.com/fwlink/?LinkId=91243.

Configuring Tracking for BizTalk Applications

The BizTalk Server Administration console lets you configure various tracking options for items such as send ports and receive ports. The tracking configuration settings enable you to track inbound and outbound event data, message properties, message bodies, and orchestrations. For more information about configuring tracking for BizTalk applications, see the "Configuring Tracking Using the BizTalk Server Administration Console" at http://go.microsoft.com/fwlink/?LinkId=106851.

You can also use Health and Activity Tracking (HAT) to view historical or tracked data. For more information, see "Viewing Historical or Tracked Data Using HAT" at http://go.microsoft.com/fwlink/?LinkId=106852.

See Also

Other Resources

Troubleshooting

© 2014 Microsoft Corporation. All rights reserved.


Troubleshooting Installation Issues

This topic was last updated on: June 05, 2009

Installation of the Microsoft BizTalk Adapter Pack copies the product binaries on the computer and registers the bindings for each adapter. This section discusses using troubleshooting techniques to resolve installation errors.

Logging Messages for Setup Actions

The BizTalk Adapter Pack setup program performs the standard task of installing the BizTalk Adapter Pack. Additionally, the setup also performs certain custom actions such as registering the adapter bindings. You can log messages for both the standard as well as custom actions that the setup performs.

  • The BizTalk Adapter Pack setup installs the adapter-specific files using an MSI. Therefore, the logging for the setup is the standard MSI logging. For more information about logging for an MSI, see http://go.microsoft.com/fwlink/?LinkId=196953.

  • All logs for the custom actions that the setup program performs are available at %TEMP%\adaptersetup.log. If the tracing to the log file fails, the traces are also available in the event log.

Known Issues

The following are the most common errors you might encounter when installing the BizTalk Adapter Pack, along with their probable cause and resolution.

  • Setup fails to register adapter bindings

  • Error while using the Consume Adapter Service add-in or Add Adapter Service Reference plug-in on a 64-bit installation

  • Invalid binding error while configuring Oracle E-Business Suite adapter ports in BizTalk Server Administration Console on a 64-bit installation

Setup fails to register adapter bindings

Problem

The Microsoft BizTalk Adapter Pack setup wizard fails to register the adapter bindings, but proceeds with the adapter installation.

Cause

This might result due to problems with Windows Communication Foundation (WCF) installation, Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK installation, or the machine.config file being corrupt. The adapter bindings are written to the machine.config file.

Resolution

You should manually register the Oracle E-Business adapter binding.

To register the adapter binding

  1. Navigate to the machine.config file on the computer. For example, on a 32-bit platform, the machine.config is available under <system drive>:\WINDOWS\Microsoft.NET\Framework\<version>\CONFIG.

    In this path, <version> is the version of the .NET Framework.

  2. Open the file by using a text editor.

  3. To register the Oracle E-Business adapter binding:

    1. Search for the element "system.serviceModel" and add the following under it:

      Copy Code
      <client>
  <endpoint binding="oracleEBSBinding" contract="IMetadataExchange" name="oracleebs" />
</client>
    2. Search for the element "bindingElementExtensions" under system.serviceModel\extensions.

    3. Look for the missing Oracle E-Business adapter binding. Add the following section under the "bindingElementExtensions" node.

      For Oracle E-Business adapter, add:

      Copy Code
      <add name="oracleEBSAdapter" type="Microsoft.Adapters.OracleEBS.OracleEBSBindingElementExtensionElement, Microsoft.Adapters.OracleEBS, Version=<version>, Culture=neutral, PublicKeyToken=<public key>" />
    4. Search for the element "bindingExtensions" under system.serviceModel\extensions.

    5. Look for the missing Oracle E-Business adapter binding. Add the following section under the "bindingExtensions" node.

      For Oracle E-Business adapter, add:

      Copy Code
      <add name="oracleEBSBinding" type="Microsoft.Adapters.OracleEBS.OracleEBSBindingCollectionElement, Microsoft.Adapters.OracleEBS, Version=<version>, Culture=neutral, PublicKeyToken=<public key>" />

    Note
    For information about how to determine the public key and the version, see Determining the Public Key and Version.

  4. Save and close the machine.config file.

Determining the Public Key and Version

Perform the following steps to determine the public key for Oracle E-Business adapter.

To determine the public key

  1. Navigate to the Windows directory, typically C:\WINDOWS\assembly.

  2. Right-click the DLL for which you want the public key and the version, and then select Properties. The following table lists the name of the DLL for Oracle E-Business adapter.

    Adapter Name of the DLL

    Oracle E-Business adapter

    Microsoft.Adapters.OracleEBS

  3. On the General tab, the value against the Public Key Token label specifies the public key for the DLL. Similarly, value against the Version label specifies the version number for the DLL.

  4. Copy the public key, and then click Cancel.

Error while using the Consume Adapter Service add-in or Add Adapter Service Reference plug-in on a 64-bit installation

Problem

Using the Add Adapter Service Reference Visual Studio Plug-in or the Consume Adapter Service BizTalk Project Add-in from Visual Studio on a 64-bit computer running 64-bit version of the BizTalk Adapter Pack results in the following error:

Copy Code
No valid adapters are installed on this machine

Cause

The Oracle E-Business adapter is a WCF custom binding, which is registered under System.ServiceModel in the machine.config file. A 64-bit platform has two machine.config files, one used by the 32-bit applications and the other used by the 64-bit applications. So, when you install the 64-bit version of the BizTalk Adapter Pack, the setup wizard registers the bindings in the 64-bit version of the machine.config file. However, Visual Studio runs as a 32-bit process and hence when you launch the Consume Adapter Service Add-in from Visual Studio, the plug-in checks for the bindings in the 32-bit version of the machine.config file and fails giving an error.

Resolution

  • Install both the 32-bit and 64-bit versions of the BizTalk Adapter Pack on a 64-bit WCF LOB Adapter SDK installation.

    Important
    You must only have a 64-bit WCF LOB Adapter SDK installation. Side-by-side installation of 32-bit and 64-bit WCF LOB Adapter SDK on a single computer is not supported.

  • Install both the 32-bit and 64-bit versions of the Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7.

    Note
    To make sure your application works with the most recent version of ODP.NET, you must have the "policy DLLs" installed on the computer and registered in the GAC. For more information, see "Oracle Data Provider for .NET FAQ" at http://go.microsoft.com/fwlink/?LinkId=92834.

Invalid binding error while configuring Oracle E-Business Suite adapter ports in BizTalk Server Administration Console on a 64-bit installation

Problem

When you try to configure a port for the adapter in BizTalk Server Administration console, you get the following error:

Copy Code
"Unable to create binding configuration element for editing. Check the values of the BindingType and BindingConfiguration properties.
(Microsoft.Biztalk.Adapter.Wcf.Converters.CreateBindingException) Unable to get binding type for binding extension "oracleEBSBinding".
Verify the binding extension is registered in machine.config."

Cause

The Oracle E-Business adapter is a WCF custom binding, which is registered under System.ServiceModel in the machine.config file. A 64-bit platform has two machine.config files, one used by the 32-bit applications and the other used by the 64-bit applications. So, when you install the 64-bit version of the BizTalk Adapter Pack, the setup wizard registers the bindings in the 64-bit version of the machine.config file. However, BizTalk Server Administration console runs as a 32-bit process and hence when you configure a port for the adapter, it checks for the bindings in the 32-bit version of the machine.config file and fails giving an error.

Resolution

  • Install both the 32-bit and 64-bit versions of the BizTalk Adapter Pack on a 64-bit WCF LOB Adapter SDK installation.

    Important
    You must only have a 64-bit WCF LOB Adapter SDK installation. Side-by-side installation of 32-bit and 64-bit WCF LOB Adapter SDK on a single computer is not supported.

  • Install both the 32-bit and 64-bit versions of the Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7.

    Note
    To make sure your application works with the most recent version of ODP.NET, you must have the "policy DLLs" installed on the computer and registered in the GAC. For more information, see "Oracle Data Provider for .NET FAQ" at http://go.microsoft.com/fwlink/?LinkId=92834.

See Also

Other Resources

Troubleshooting

© 2014 Microsoft Corporation. All rights reserved.


Troubleshooting Operational Issues

This topic was last updated on: June 05, 2009

This section discusses using troubleshooting techniques to resolve operational errors that you might encounter when using Microsoft BizTalk Adapter for Oracle E-Business Suite.

Enabling Tracing

For more information about tracing support in the Oracle E-Business adapter, Diagnostic Tracing and Message Logging.

Known Issues

The following are the most common errors you might encounter when using the BizTalk Adapter Pack, along with their probable cause and resolution.

  • Error in loading the adapter bindings

  • The Oracle E-Business Suite adapter does not display in the list of adapters in BizTalk Server Administration console

  • Error while performing operations on the Oracle E-Business Suite

  • BizTalk process might crash due to an incorrect Oracle client version when a request message is dropped at the receive location

  • Adapter might throw an overflow exception on executing an operation

  • Adapter might throw an arithmetic overflow exception on executing an ExecuteScalar operation

  • Adapter client might throw the following exception on executing an operation: “Could not retrieve user id, responsibility id, application id. Check if correct values were passed in.”

  • Error with RootNode TypeName in BizTalk Projects

  • Invalid binding warning when using the adapter in Visual Studio

  • BizTalk Server throws an exception if you use more than one Notification schema in the same application or use the Notification schema across multiple applications on the same host

  • Timeout Exception while browsing Oracle E-Business Suite Artifacts in Visual Studio

  • Memory usage and thread count increases when using the adapter in a transacted inbound operation

Error in loading the adapter bindings

Problem

When you try to start the Add Adapter Service Reference Visual Studio Plug-in or the Consume Adapter Service BizTalk Project Add-in, you get the following error:

Copy Code
There was an error loading the binding, <binding name>, from your system configuration.
ConfigurationErrorsException: Exception has been thrown by the target of an invocation.

Cause

When you try to start the Add Adapter Service Reference Plug-in or the Consume Adapter Service Add-in, WCF loads the adapter bindings for all the installed adapters. In turn, the adapter bindings are dependent on the specific client software for the enterprise application. You might face this issue for one or both of the following reasons:

  • The required LOB client software is not installed on the computer where you installed the adapter.

  • You did a Typical or Complete installation of the adapter, which installs all the adapters contained in the BizTalk Adapter Pack. However, the LOB client libraries might be installed for only one enterprise application. As a result, the GUI fails to load the bindings for the other adapters.

Resolution

  • Make sure that the required LOB client versions are installed on the computer where you installed the BizTalk Adapter Pack. For information about the supported client versions, see the installation guide available at <installation drive>:\Program Files\Microsoft BizTalk Adapter Pack.

  • Make sure you do a custom installation of the adapters to install only the adapter you need.

The Oracle E-Business Suite adapter does not display in the list of adapters in BizTalk Server Administration console

Problem

Unlike the earlier version of the adapters shipped with BizTalk Server, the Oracle E-Business adapter shipped with BizTalk Adapter Pack does not show up in the list of adapters in the BizTalk Server Administration console.

Cause

The latest Oracle E-Business adapter is a WCF custom binding. So, although the BizTalk Server Administration console displays the WCF-Custom adapter, it does not display the WCF custom bindings and hence, does not display the WCF-based Oracle E-Business adapter.

Resolution

You can explicitly add the Oracle E-Business adapter to the BizTalk Server Administration console by following the steps mentioned in Adding the Oracle E-Business Suite Adapter to BizTalk Server Administration Console.

Error while performing operations on the Oracle E-Business Suite

Problem

The adapter gives the following error when performing any operation on the Oracle E-Business Suite using BizTalk Server.

  • For BizTalk Server 2013 R2

    Copy Code
    System.ArgumentNullException: Value cannot be null.

Cause

The WCF action for the message is not specified. WCF requires a SOAP action to be specified for every operation, which informs the adapter about the operation to be performed on the LOB application.

Resolution

Specify the SOAP action in the send port or as a message context property in a BizTalk orchestration. For instructions, see Specifying SOAP Action. See Technical Reference to see a list of actions for each operation.

BizTalk process might crash due to an incorrect Oracle client version when a request message is dropped at the receive location

Problem

After a request message is dropped at a receive location defined in a BizTalk orchestration, the orchestration consumes the message and BizTalk host (BTSNTSvc.exe) crashes and restarts.

Cause

Installing the Oracle client adds the reference to the latest client assemblies in the PATH variable. Also, the references to the most recent installation of the Oracle client assembly precede the reference to the existing client assemblies. So, if the most recent Oracle client installation is not of a supported client version, BizTalk host crashes and then restarts.

For example, assume that the supported Oracle client 11.1.0.7 is already installed on the computer and the PATH variable has the following reference:

Copy Code
C:\oracle\product\11.1.0\client_1\bin;

If an unsupported Oracle client, for example 10.2.0.3, is installed on the same computer, the PATH variable will have the following reference:

Copy Code
C:\oracle\product\10.2.0\db_2\bin;C:\oracle\product\11.1.0\client_1\bin;

Note that the unsupported client version is referenced before the supported version and hence BizTalk host crashes. If there are more than one BizTalk hosts running, then the one hosting the adapter crashes.

Resolution

If more than one Oracle client is installed on the same computer, make sure the supported Oracle client version is referenced before the other Oracle client versions in the PATH variable. For example, if the supported Oracle client version is 11.1.0.7, the reference in the PATH variable must look like:

Copy Code
C:\oracle\product\11.1.0\client_1\bin;C:\oracle\product\10.2.0\db_2\bin;

Adapter might throw an overflow exception on executing an operation

Problem

Using the adapter, if you try to perform an operation containing Oracle numeric data types inside DataSets or weakly-typed REF CURSORS, the adapter might throw an overflow exception.

Cause

This happens if you supply a large value for the Oracle numeric data type inside DataSets or weakly-typed REF CURSORS that cannot fit into the respective .NET type.

Resolution

If you want to pass large values for the Oracle numeric data type inside DataSets or weakly-typed REF CURSORS, you must enable safe typing by setting the value of the EnableSafeTyping binding property to true. Enabling safe typing exposes the Oracle numeric data type inside DataSets or weakly-typed REF CURSORS as strings.

Adapter might throw an arithmetic overflow exception on executing an ExecuteScalar operation

Problem

Using the adapter, if you try to execute a SELECT statement in an ExecuteScalar operation that retrieves a large number, the adapter throws the following exception: “System.OverflowException: Arithmetic operation resulted in an overflow.”

Cause

This happens due to the known limitation of ExecuteScalar operation in ODP.NET. ODP.NET tries to fit in the data into the .NET Decimal data type, and if the result is too large to fit in the .NET Decimal type, the exception is thrown.

Resolution

Use TO_CHAR() in the SELECT statement in the ExecuteScalar operation to convert the returned data as string.

Adapter client might throw the following exception on executing an operation: “Could not retrieve user id, responsibility id, application id. Check if correct values were passed in.”

Problem

The adapter clients might throw this exception if you are performing operations on Oracle E-Business Suite artifacts (interface tables, interface views, concurrent programs, and request sets).

Cause

This happens if you supply an incorrect combination of Oracle user name, password, and responsibility name while performing operations on interface tables, interface views, concurrent programs, and request sets. The Oracle E-Business adapter requires these values in order to set the application context for these artifacts. For more information about setting application context, see Setting Application Context.

Resolution

You must specify a correct combination of the Oracle user name, password, and responsibility to appropriately set application context for an Oracle E-Business Suite artifact. To specify values for Oracle user name and password, you must use the OracleUserName and OraclePassword binding properties. To specify value for the Oracle responsibility, you can either use the OracleEBSResponsibilityName binding property or message context property.

Error with RootNode TypeName in BizTalk Projects

Problem

In a BizTalk project in Visual Studio, if the schemas generated from the Consume Adapter Service Add-in contains invalid characters or reserved words for the RootNode TypeName property, the following error will occur while compiling the project:

Copy Code
Node <node reference> - Specify a valid .NET type name for this root node.
The current .NET type name of this root node is invalid (it is a reserved BizTalk Keyword or is an invalid C# identifier).

Resolution

  1. Right-click the rood node referenced in the error and select Properties.

  2. For the RootNode TypeName property, remove any illegal characters or reserved words, for example, dot (.).

Invalid binding warning when using the adapter in Visual Studio

Problem

When you use the adapter to create an application in Visual Studio 2013 and you open the configuration file (app.config) generated by the adapter, you see a warning similar to the following:

Copy Code
The element 'bindings' has invalid child element 'oracleEBSBinding'. List of possible elements expected: 'basicHttpBinding, customBinding, ...

Cause

This warning appears because the Oracle E-Business adapter binding, oracleEBSBinding, is not a standard binding shipped with the Windows Communication Foundation (WCF).

Resolution

You can safely ignore this warning.

BizTalk Server throws an exception if you use more than one Notification schema in the same application or use the Notification schema across multiple applications on the same host

Problem

BizTalk Server throws an XLANG exception or an exception stating that the application cannot locate the document specification because multiple schemas matched the message type.

Cause

This happens because of either of the following:

  • You have generated more than one Notification schema in a BizTalk Server project, deployed it to a BizTalk Server application, and then ran the application to receive notifications from the Oracle database. Because the Notification schemas are common, there is a conflict between the schemas that are deployed in the BizTalk Server application.

  • In case of multiple projects, you have generated a Notification schema for each of the BizTalk Server projects, deployed each project to a separate BizTalk Server application on the same host, and then ran an application or applications to receive notifications from the Oracle database. Because the schemas and assemblies are accessible across the applications in BizTalk Server, there is a conflict between the common schemas deployed under various BizTalk Server applications and assemblies.

Resolution

Use a single Notification schema file for a BizTalk Server application. If you need to use the Notification schema in multiple BizTalk Server applications on the same host, create an application containing a single Notification schema, and then use the notification schema from all other applications in BizTalk Server.

Timeout Exception while browsing Oracle E-Business Suite Artifacts in Visual Studio

Problem

While browsing Oracle E-Business Suite artifacts in a Visual Studio project using the Add Adapter Metadata Wizard, Add Adapter Service Reference Plug-in, or Consume Adapter Service Add-in you might encounter a timeout exception.

Cause

This might happen if the server hosting the Oracle E-Business Suite is slow, server is located at a remote location, or the schema you are looking under has a large number of artifacts.

Resolution

You can either choose to increase the value of the SendTimeout binding property or provide a search expression in the Search in category text box to reduce the number of artifacts that the adapter retrieves.

For more information about specifying binding properties, see Specifying Binding Properties. For more information about searching artifacts in Oracle E-Business Suite, see Browsing, Searching, and Retrieving Metadata for Oracle E-Business Operations.

Memory usage and thread count increases when using the adapter in a transacted inbound operation

Problem

In a transacted inbound operation, such as Polling, if there is no data available in the table being polled and the adapter continues to poll, over a period of time you experience an increase in the memory usage and the thread count.

Cause

If there is no data available in the table being polled, after every receive timeout cycle, Windows Communication Foundation (WCF) spawns a new thread to continue the polling operation. Hence, the thread count and memory usage increases over a period of time. However, if the table being polled has some data, the same thread continues to perform all subsequent polls.

Resolution

We recommend setting the ReceiveTimeout to the maximum possible value, which is 24.20:31:23.6470000 (24 days) so that a new thread is spawned only every 24 days. This will ensure that the memory usage and thread count does not grow too much too soon.

For more information about the ReceiveTimeout binding property, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. For instructions on specifying binding properties, see Specifying Binding Properties.

Note
When using the adapter with BizTalk Server, setting the timeout to a large value does not impact the functionality of the adapter.

See Also

Other Resources

Troubleshooting

© 2014 Microsoft Corporation. All rights reserved.


Using Performance Counters

Microsoft BizTalk Adapter Pack clients can use performance counters to gauge the performance of the adapters. The BizTalk Adapter Pack setup program creates the performance counter category BizTalk .NET Adapter for Oracle E-Business Suite along with installing the BizTalk Adapter Pack.

The LOB Time (Cumulative) Performance Counter

The BizTalk .NET Adapter for Oracle E-Business Suite category has one performance counter called the “LOB Time (Cumulative).” This performance counter denotes the time, in milliseconds, that the LOB client library takes to complete an action that the adapter initiates. The Oracle E-Business adapter creates an instance of the performance counter in any of the following patterns:

Copy Code
<process id>:<app domain id>:<oracle data source>:<string>

Where "string" could be:

  • Connection.Open

  • Connection.Close

  • Metadata

  • Message action. For example, if the action is InterfaceTables/Insert/FND/APPS/MS_SAMPLE_EMPLOYEE then the string will be InterfaceTables.Insert.FND.APPS.MS_SAMPLE_EMPLOYEE.

The Oracle data source is the same as specified in the connection URI.

The performance counter is initialized only after the adapter makes the first call to the Oracle database. Also, the InstanceLifetime property of the performance counter is set to 'Process', which means that the performance counter ceases to exist as soon as the program that creates the counter terminates. For more information about the InstanceLifetime property, see http://go.microsoft.com/fwlink/?LinkId=104181.

Note
The precision of the LOB Time (Cumulative) performance counter is 16 milliseconds.

Enabling Performance Counters

The performance counters can be enabled or disabled by setting the binding property EnablePerformanceCounters. To enable performance counters, set the EnablePerformanceCounters binding property to True. To disable performance counters, set EnablePerformanceCounters to False. By default, EnablePerformanceCounters is set to False.

Performance Counters and the WCF LOB Adapter SDK

Changing the value of the EnablePerformanceCounters binding property also changes the value of the corresponding performance counter for the WCF LOB Adapter SDK. Also, the binding property for the WCF LOB Adapter SDK is static, whereas that for the BizTalk Adapter Pack is dynamic. Therefore, if there are two instances of the Oracle E-Business adapter binding in the AppDomain, and the EnablePerformanceCounters binding property is set to True in one and False in the other, the adapter-specific performance counter will be enabled in one and disabled in the other. However, because the binding property for WCF LOB Adapter SDK is static, it will either be set to True or False depending on what value was specified last.

See Also

Other Resources

Troubleshooting

© 2014 Microsoft Corporation. All rights reserved.


Technical Reference

This section covers technical reference information about Microsoft BizTalk Adapter for Oracle E-Business Suite.

In This Section

  • Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

  • Glossary

© 2014 Microsoft Corporation. All rights reserved.


Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

The Microsoft BizTalk Adapter for Oracle E-Business Suite is a Windows Communication Foundation (WCF) custom binding. It exposes operations that applications can invoke on it and that it can, in turn, invoke on applications. These operations are invoked by sending SOAP messages over a channel. If a response is required, it is returned in a SOAP message over the same channel.

As a WCF service, the Oracle E-Business adapter exposes metadata for its operations and data types by using standard WCF mechanisms. The sections in this topic describe the XML structure of the messages and data types that the Oracle E-Business adapter uses.

In This Section

  • Basic Oracle Data Types

  • Message Schemas for Insert, Update, Delete, and Select Operations

  • Message Schemas for Stored Procedures, Functions, and PL/SQL APIs

  • Message Schemas for Concurrent Programs

  • Message Schemas for Request Sets

  • Message Schemas for Special LOB Operations

  • Message Schemas for the Polling Operations

  • Message Schemas for the Notification Operation

  • Message Schemas for the ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations

  • Message Schemas for the Composite Operation

See Also

Other Resources

Technical Reference

© 2014 Microsoft Corporation. All rights reserved.


Basic Oracle Data Types

This topic describes how the Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces basic Oracle data types.

Supported Oracle Data Types

The Oracle E-Business adapter supports safe typing for some Oracle data types. When safe typing is enabled, these data types are represented as strings. You configure safe typing by enabling the EnableSafeTyping binding property (disabled by default). For more information about the Oracle E-Business adapter binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties.

Note
Safe typing is not supported if data types are inside User Defined Types (UDTs).

The following table shows how the Oracle data types are surfaced with safe typing disabled (EnableSafeTyping is false). Oracle data types that are affected by the EnableSafeTyping binding property are marked with an asterisk (*).

Oracle Data Type XSD type .NET type Comments

BFile

input: xsd:string

output: xsd:base64Binary

String

Byte[]

BFile data type is not supported inside complex types (such as RecordType, TableType, UDT, and VArray).

Blob

xsd:base64Binary

Byte[]

-

Char

xsd:string

String

-

Clob

xsd:string

String

-

Date*

(No safe typing if inside an UDT)

xsd:dateTime

DateTime

Date values cannot contain time zone information (UTC or UTC offsets):

  • xsd:dateTime values must not contain UTC or UTC offsets

  • DateTime.Kind must be DateTimeKind.Unspecified

If time zone information is specified, the adapter throws an XmlReaderParsingException exception with a message that indicates the field.

Note
The Oracle E-Business adapter exposes Oracle Date data type as xsd:dateTime instead of xsd:date because:

  • Oracle Date data type can also contain time value.

  • There is no .NET equivalent for xsd:date.

Float**

xsd:float if prec <=7

xsd:double if prec > 7 and <=15

xsd:string if prec > 15

Float

Double

String

You must specify the value consistent with the format specified for the decimal character and group separator in the NumericCharacters binding property under the MlsSettings binding property. If no value is specified for the NumericCharacters binding property, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.

IntervalDS

xsd:string

xsd:duration if inside an UDT

String

Timespan if inside an UDT

The adapter returns the IntervalDS data as a string using the OracleIntervalDS.ToString method.

The value should be expressed in Oracle native format: Day HH:MI:SSxFF (for example, "5 15:30:12.99").

IntervalYM

xsd:string

xsd:long if inside an UDT

String

Long if inside an UDT

The adapter returns the IntervalYM data as a string using the OracleIntervalYM.ToString method.

The value should be expressed in Oracle native format: Year-Month; for example, "1-2" (1 year and 2 months).

Long

xsd:string

String

Starting with the Oracle database 9i release, the LONG data type is deprecated. Oracle recommends using the Large Object (LOB) data types instead. Therefore, when performing operations on the Oracle database using the Oracle Database adapter, we recommend using Oracle database artifacts that operate on LOB data types and not the LONG data type.

LongRaw

xsd:base64Binary

Byte[]

-

NChar

xsd:string

String

-

NClob

xsd:string

String

Number**

xsd:decimal if prec <=28

xsd:string if prec > 28

Decimal
String

-

NVarchar2

xsd:string

String

-

Raw

xsd:base64Binary

Byte[]

RowID

xsd:string

String

-

TimeStamp*

(No safe typing if inside an UDT)

xsd:dateTime if prec <= 7

xsd:string if prec > 7

DateTime

String

When exposed as string (prec > 7), the value should be expressed in Oracle NLS_TIMESTAMP_FORMAT. You can specify the string format for TimeStamp data types in the TimeStampFormat binding property under the MlsSettings binding property. If no value is specified for the TimeStampFormat binding property, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.

TimeStamp values cannot contain time zone information (UTC or UTC offsets):

  • xsd:dateTime values must not contain UTC or UTC offsets

  • DateTime.Kind must be DateTimeKind.Unspecified

If time zone information is specified, the adapter throws an XmlReaderParsingException exception with a message that indicates the field.

TimeStampLTZ

xsd:string

String

TimeStampLTZ is not supported inside UDTs.

Outside an UDT: The value should be expressed in Oracle NLS_TIMESTAMP_TZ_FORMAT. You can specify the string format for TimeStampLTZ data types in the TimeStampTZFormat binding property under the MlsSettings binding property. If no value is specified for the TimeStampTZFormat binding property, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.

TimeStampTZ

xsd:string

xsd:dateTime if inside an UDT

String

DateTime if inside an UDT

Outside an UDT: The value should be expressed in Oracle NLS_TIMESTAMP_TZ_FORMAT. You can specify the string format for TimeStampTZ data types in the TimeStampTZFormat binding property under the MlsSettings binding property. If no value is specified for the TimeStampTZFormat binding property, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.

Decimal**

xsd:decimal if prec <=28

xsd:string if prec > 28

Decimal

String

-

Varchar2

xsd:string

String

-

Binary Float**

xsd:float if prec <=7

xsd:string if prec > 7

Float

String

You must specify the value consistent with the format specified for the decimal character and group separator in the NumericCharacters binding property under the MlsSettings binding property. If no value is specified for the NumericCharacters binding property, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.

Binary Double**

xsd:double if prec <=15

xsd:string if prec > 15

Double

String

-

Binary Integer**

xsd:integer

Int32

Boolean

xsd:boolean

Nullable boolean

XMLTYPE

xsd:string

String

Supported for top level procedure parameters.

Reserved XML characters like ‘<’, ‘>’ must be replaced with their entity representation (&lt;, &gt;) when developing applications in BizTalk, and when using WCF channel Model. This is not required in the case of WCF Service Model.

*The way in which these Oracle data types are surfaced is affected by the EnableSafeTyping binding property.

**The way in which these Oracle numeric data types inside DataSets and weakly-typed REF CURSORS are surfaced is affected by the EnableSafeTyping binding property.

Important
  • The maximum length of the value in an Oracle data type in the Oracle E-Business adapter is bound by the maximum length of the value supported by ODP.NET for the Oracle data type.

  • The Oracle E-Business adapter internally treats the Oracle numeric data types inside UDTs as .NET Decimal. However, in general (that is outside UDTs), the Oracle E-Business adapter internally treats the Oracle numeric data types as OracleDecimal.

Safe Typing Enabled

The following table shows how the Oracle data types that are affected by safe typing are changed when the EnableSafeTyping binding property is true.

Note
Oracle data types that are not in this table are surfaced in the same way whether safe typing is enabled or disabled.

Oracle Data Type | XSD type | .NET type | Comment
Date | xsd:string | String | The value should be expressed in Oracle NLS_DATE_FORMAT. You can specify the format for the Date data types in the DateFormat binding property under the MlsSettings binding property. If no value is specified for the DateFormat binding property, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.
TimeStamp | xsd:string | String | The value should be expressed in Oracle NLS_TIMESTAMP_FORMAT. You can specify the string format for TimeStamp data types in the TimeStampFormat binding property under the MlsSettings binding property. If no value is specified for the TimeStampFormat binding property, the adapter uses the MLS settings for the ODP.NET client on the same computer where the adapter is installed.
Important
If safe typing is enabled, the Oracle numeric data types inside DataSets and weakly-typed REF CURSORS are always exposed as strings.

Validation

The Oracle E-Business adapter performs no explicit validation on the values that you specify for Oracle data types. However, depending on the Oracle data type and whether safe typing is enabled or disabled, implicit validation may be performed:

  • When de-serializing between the XML passed in a message and the .NET types that are used internally by the adapter.

  • By ODP.NET for some data types.

See Also

Other Resources

Technical Reference
Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for Insert, Update, Delete, and Select Operations

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces basic Insert, Update, Delete, and Select operations for each interface table in Oracle E-Business Suite and each table in the underlying database. The adapter also surfaces the Select operation for each interface view in Oracle E-Business Suite and each view in the underlying database. These operations perform the appropriate SQL statement qualified by a WHERE clause. The Oracle E-Business adapter uses strongly-typed records and record sets in these operations.

Message Structure for Basic Operations

The following table shows the XML message structure for the basic operations exposed by the Oracle E-Business adapter on Oracle E-Business Suite interface tables and interface views and on the underlying database tables and views. The target object for an operation is specified in the message action and also appears in the target namespace.

Note
See attribute descriptions after table.

Operation XML Message Description SQL Executed by the Adapter

Insert

Copy Code
<Insert xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <RECORDSET>
    <InsertRecord>
      <[FIELD1_NAME] InlineValue="value">[value1]</[FIELD1_NAME]>
      <[FIELD2_NAME] InlineValue="value">[value2]</[FIELD2_NAME]>
      …
    </InsertRecord>
  </RECORDSET>
</Insert>

The value for the InlineValue attribute, if specified, overrides the value of an element.

Copy Code
INSERT INTO TABLE_NAME (FIELD1_NAME, FIELD2_NAME, …) VALUES (value1, value2, …);

Insert Response

Copy Code
<InsertResponse xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <InsertResult>[rows inserted]</InsertResult>
</InsertResponse>

The number of rows inserted is returned in the InsertResult element.

--

Select

Copy Code
<Select xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <COLUMN_NAMES>[COLUMN_list]</COLUMN_NAMES>
  <FILTER>WHERE_clause</FILTER>
</Select>

A SELECT query is performed on the target table using the WHERE clause specified in the FILTER element. The result set contains the columns in the comma-separated list of column names specified in the COLUMN_NAMES element.

Important
This is the only operation that is applicable for interface views and database views.

Copy Code
SELECT COLUMN_list FROM TABLE_NAME WHERE WHERE_clause;

Select Response

Copy Code
<SelectResponse  xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <SelectResult>
    <SelectRecord>
      <[FIELD1_NAME]>value1</[FIELD1_NAME]>
      <[FIELD2_NAME]>value2</[FIELD2_NAME]>
      …
    </SelectRecord>
  </SelectResult>
</SelectResponse>

The result set generated by the SELECT query.

--

Update

Copy Code
<Update xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <RECORDSET>
    <[FIELD1_NAME]>value1</[FIELD1_NAME]>
    <[FIELD2_NAME]>value2</[FIELD2_NAME]>
      …
  </RECORDSET>
  <FILTER>WHERE_clause</FILTER>
</Update>

Rows that match the where clause specified in the FILTER element are updated to the values specified in the RECORDSET. Only the columns that are specified in the RECORDSET element are updated in each matching row.

Copy Code
UPDATE [TABLE_NAME] SET [FIELD1_NAME] = value1, [FIELD2_NAME] = value2, … WHERE WHERE_clause;

Update Response

Copy Code
<UpdateResponse xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <UpdateResult>[rows inserted]</UpdateResult>
</UpdateResponse>

The number of rows updated is returned in the UpdateResult element.

--

Delete

Copy Code
<Delete xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <FILTER>WHERE_clause</FILTER>
</Delete>

Rows matching the WHERE clause specified by the FILTER element are deleted.

Copy Code
DELETE FROM [TABLE_NAME] WHERE WHERE_clause;

Delete Response

Copy Code
<DeleteResponse xmlns="[VERSION]/InterfaceTables/[SCHEMA]/[APP_NAME]/[INTERFACETABLE_NAME]">
  <DeleteResult>[rows deleted]</DeleteResult>
</DeleteResponse>

The number of rows deleted is returned in the DeleteResult element.

--

Attribute descriptions:

[VERSION] = The message version string; for example, http://schemas.microsoft.com/OracleEBS/2008/05.

[SCHEMA] = Collection of Oracle artifacts; for example, SCOTT.

[APP_NAME] = Application short name.

[INTERFACETABLE_NAME] = Name of the interface table.

[FIELD1_NAME] = Table field name.

[COLUMN_list] = Comma-separated list of columns.

[WHERE_clause] = WHERE_clause for the SELECT statement used for the operation; for example, ID > 10.

Important
The message structure for the basic operations on interface views, database tables, and database views is the same as that on interface tables, but the namespace for the operation specifies an interface view, database table, or database view rather than an interface table.

Message Actions for Basic Operations

The following table shows the message actions that the Oracle E-Business adapter uses for the basic operations on the interface tables and interface view in Oracle E-Business Suite, and the tables and views in the underlying database. The Oracle E-Business adapter uses the interface table, interface view, database table, or database view specified in the message action to determine the target of the operation.

Note
See entity descriptions after table.

Operation | Message Action | Example
Insert | Applications: InterfaceTables/Insert/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME] Database: Tables/Insert/[SCHEMA]/[TABLE_NAME] | Applications: InterfaceTables/Insert/SQLGL/GL/GL_ALLOC_HISTORY Database: Tables/Insert/GL/GL_ALLOC_HISTORY
Insert Response | Applications: InterfaceTables/Insert/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME]/response Database: Tables/Insert/[SCHEMA]/[TABLE_NAME]/response | Applications: InterfaceTables/Insert/SQLGL/GL/GL_ALLOC_HISTORY/response Database: Tables/Insert/GL/GL_ALLOC_HISTORY/response
Select | Applications: InterfaceTables/Select/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME] Database: Tables/Select/[SCHEMA]/[TABLE_NAME] | Applications: InterfaceTables/Select/SQLGL/GL/GL_ALLOC_HISTORY Database: Tables/Select/GL/GL_ALLOC_HISTORY
Select Response | Applications: InterfaceTables/Select/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME]/response Database: Tables/Select/[SCHEMA]/[TABLE_NAME]/response | Applications: InterfaceTables/Select/SQLGL/GL/GL_ALLOC_HISTORY/response Database: Tables/Select/GL/GL_ALLOC_HISTORY/response
Update | Applications: InterfaceTables/Update/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME] Database: Tables/Update/[SCHEMA]/[TABLE_NAME] | Applications: InterfaceTables/Update/SQLGL/GL/GL_ALLOC_HISTORY Database: Tables/Update/GL/GL_ALLOC_HISTORY
Update Response | Applications: InterfaceTables/Update/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME]/response Database: Tables/Update/[SCHEMA]/[TABLE_NAME]/response | Applications: InterfaceTables/Update/SQLGL/GL/GL_ALLOC_HISTORY/response Database: Tables/Update/GL/GL_ALLOC_HISTORY/response
Delete | Applications: InterfaceTables/Delete/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME] Database: Tables/Delete/[SCHEMA]/[TABLE_NAME] | Applications: InterfaceTables/Delete/SQLGL/GL/GL_ALLOC_HISTORY Database: Tables/Delete/GL/GL_ALLOC_HISTORY
Delete Response | Applications: InterfaceTables/Delete/[SHORT_NAME]/[APP_NAME]/[TABLE_NAME]/response Database: Tables/Delete/[SCHEMA]/[TABLE_NAME]/response | Applications: InterfaceTables/Delete/SQLGL/GL/GL_ALLOC_HISTORY/response Database: Tables/Delete/GL/GL_ALLOC_HISTORY/response

Entity descriptions:

  • [SCHEMA] - Collection of Oracle artifacts (for example, GL).

  • [TABLE_NAME] - Name of the table (for example, GL_ALLOC_HISTORY).

Important
The message action for the Select operation on an interface view is the same as that for the interface table, except that "InterfaceViews" replaces "InterfaceTables." Similarly, the message action for the Select operation on a database view is the same as that for the database table, except that "Views" replaces "Tables.”

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for Stored Procedures, Functions, and PL/SQL APIs

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces the underlying Oracle database stored procedures, functions, and PL/SQL APIs (stored procedures and functions within a package) as operations. This section describes the message structure and actions used to invoke stored procedures, functions, and PL/SQL APIs.

Message Structure of Stored Procedures, Functions, and PL/SQL APIs

The operations surfaced for functions and stored procedures follow a request-response message exchange pattern. The following table shows the structure of these request and response messages.

Note
See entity descriptions after the table.

Operation XML Message Description

Stored Procedure Request

Copy Code
<[SP_NAME] xmlns="[VERSION]/Procedures/[SCHEMA]">
  <[PRM1_NAME]>value1</[PRM1_NAME]>
  <[PRM2_NAME]>value2</[PRM2_NAME]>
  …
</[SP_NAME]>

Supports Oracle IN and IN OUT parameters in the message body

Stored Procedure Response

Copy Code
<[SP_NAME]Response xmlns="[VERSION]/Procedures/[SCHEMA]">
  <[PRM1_NAME]>value1<[PRM1_NAME]>
  <[PRM2_NAME]>value2</[PRM2_NAME]>
  …
</[SP_NAME]Response>

Supports Oracle OUT and IN OUT parameters in the message body

Function Request

Copy Code
<[FN_NAME] xmlns="[VERSION]/Functions/[SCHEMA] ">
  <[PRM1_NAME]>value1</[PRM1_NAME]>
  <[PRM2_NAME]>value2</[PRM2_NAME]>
  …
</[FN_NAME]>

Supports Oracle IN and IN OUT parameters in the message body

Function Response

Copy Code
<[FN_NAME]Response xmlns="[VERSION]/Functions/[SCHEMA]">
  <[FN_NAME]Result>return_value</[FN_NAME]Result>
  <[PRM1_NAME]>value1</[PRM1_NAME]>
  <[PRM2_NAME]>value2</[PRM2_NAME]>
  …

</[FN_NAME]Response>

Supports Oracle OUT and IN OUT parameters in the message body

The function return value is returned in the <[FN_NAME]Result> element. This is the first element in the response message. It comes before any parameters.

PL/SQL API Request

Copy Code
<[SP_NAME] xmlns="[VERSION]/PackageApis/[SCHEMA]/[PACKAGE_NAME/[SP_NAME]">
  <[PRM1_NAME]>value1</[PRM1_NAME]>
  <[PRM2_NAME]>value2</[PRM2_NAME]>
  …
</[SP_NAME]>

Same as Function or Stored Procedure

Packaged Procedure or Function Response

Copy Code
<[SP_NAME]Response xmlns="[VERSION]/PackageApis/[SCHEMA]/[PACKAGE_NAME]/[SP_NAME]">
  <[PRM1_NAME]>value1</[PRM1_NAME]>
  <[PRM2_NAME]>value2</[PRM2_NAME]>
  …
</[SP_NAME]Response>

Same as Function or Stored Procedure

Entity descriptions:

[VERSION] = http://schemas.microsoft.com/OracleEBS/2008/05.

[SCHEMA] = Collection of Oracle artifacts; for example, SCOTT.

[SP_NAME] = The stored procedure to be executed; for example, SP_INSERT.

[FN_NAME] = The function to be executed; for example, FN_GETID.

[PRM1_NAME] = The name of the Oracle parameter. See the Description column for supported parameter directions for each message.

[PACKAGE_NAME] = The name of the package that contains the targeted procedure or function.

The Oracle database supports overloading for stored procedures and functions. The Oracle E-Business adapter supports this capability by appending an overload string to the target namespace for each overloaded artifact. The value of this string is "overload1" for the first overload, "overload2" for the second overload, and so on. The following example shows the message structure for two overloaded stored procedures.

Copy Code
Stored Procedure Overload 1:
<[SP_NAME] xmlns="[VERSION]/PackageApis/[SCHEMA]/[PACKAGE_NAME]/[SP_NAME]/overload1">
  <[PRM1_NAME]>value1</[PRM1_NAME]>
  <[PRM2_NAME]>value1</[PRM2_NAME]>
  …
</[SP_NAME]>

Stored Procedure Overload 2:
<[SP_NAME] xmlns="[VERSION]/PackageApis/[SCHEMA]/[PACKAGE_NAME]/[SP_NAME]/overload2">
  <[PRM1_NAME]>value1</I_[PRM1_NAME]>
  <[PRM2_NAME]>value1</I_[PRM2_NAME]>
  …
</[SP_NAME]>

Message Actions of Stored Procedures, Functions, and PL/SQL APIs

The Oracle E-Business adapter uses the following message actions for stored procedure, function, and PL/SQL API operations.

Note
See entity descriptions after the table.

Message | Action | Example
Stored Procedure Request | Procedures/[SCHEMA]/[SP_NAME] | Procedures/SCOTT/SP_INSERT
Stored Procedure Response | Procedures/[SCHEMA]/[SP_NAME]/response | Procedures/SCOTT/SP_INSERT/response
Function Request | Functions/[SCHEMA]/[FN_NAME] | Functions/SCOTT/FN_GETID
Function Response | Functions/[SCHEMA]/[FN_NAME]/response | Functions/SCOTT/FN_GETID/response
PL/SQL API Request | [SCHEMA]/Package/[PACKAGE_NAME]/[SP_NAME] | SCOTT/Package/CUSTOMER/SP_INSERT
Packaged Stored Procedure Response | [SCHEMA]/Package/[PACKAGE_NAME]/[SP_NAME]/response | SCOTT/Package/CUSTOMER/SP_INSERT/response
Packaged Function Request | [SCHEMA]/Package/[PACKAGE_NAME]/[FN_NAME] | SCOTT/Package/CUSTOMER/FN_GETID
Packaged Function Response | [SCHEMA]/Package/[PACKAGE_NAME]/[FN_NAME]/response | SCOTT/Package/CUSTOMER/FN_GETID/response
Overloaded Stored Procedure Request | [SCHEMA]/Procedure/[SP_NAME]/[OVERLOAD] | SCOTT/Procedure/SP_INSERT/overload1
Overloaded Stored Procedure Response | [SCHEMA]/Procedure/[SP_NAME]/[OVERLOAD]/response | SCOTT/Procedure/SP_INSERT/overload1/response

Entity descriptions:

[SCHEMA] = Collection of Oracle artifacts; for example, SCOTT.

[SP_NAME] = The stored procedure to be executed; for example, SP_INSERT.

[FN_NAME] = The function to be executed; for example, FN_GETID.

[PACKAGE_NAME] = The name of the package that contains the targeted procedure or function.

[OVERLOAD] = The Overload parameter. The possible values are overload1, overload2, and so on.

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for Concurrent Programs

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces concurrent programs as operations. Along with the concurrent programs exposed as operations, the Oracle E-Business adapter also surfaces the following three standard operations: Get_Status, Wait_For_Request, and Submit_Request. For information about these operations related to concurrent programs, see Operations on Concurrent Programs.

Message Structure of Concurrent Program Operations

The operations surfaced for concurrent programs follow a request-response message exchange pattern. The following table shows the structure of these request and response messages.

Note
See entity descriptions after the table.

Operation XML Message Description

[Concurrent_Program_Name] Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<[Concurrent_Program_Name] xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]/">
  <SetOptions>
    <Implicit>[value]</Implicit>
    <Protected>[value]</Protected>
    <Language>[value]</Language>
    <Territory>[value]</Territory>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetOptions>
  <SetPrintOptions>
    <Printer>[value]</Printer>
    <Style>[value]</Style>
    <Copies>[value]</Copies>
    <SaveOutput>[value]</SaveOutput>
    <PrintTogether>[value]</PrintTogether>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetPrintOptions>
  <SetRepeatOptions>
    <RepeatTime>[value]</RepeatTime>
    <RepeatInterval>[value]</RepeatInterval>
    <RepeatUnit>[value]</RepeatUnit>
    <RepeatType>[value]</RepeatType>
    <RepeatEndTime>[value]</RepeatEndTime>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetRepeatOptions>
  <Description>[value]</Description>
  <StartTime><[value]</StartTime>
  <[CONCURRENT_PROGRAM_ARGUMENT1]>[value]</[CONCURRENT_PROGRAM_ARGUMENT1]>
  <[CONCURRENT_PROGRAM_ARGUMENT2]>[value]</[CONCURRENT_PROGRAM_ARGUMENT2]>
  …
</[Concurrent_Program_Name]>
  • The [Concurrent_Program_Name] operation takes five standard parameters: SetOptions, SetPrintOptions, SetRepeatOptions, Description, and StartTime.

  • The ContinueOnFail parameter indicates whether the concurrent request submission should continue in case the parent parameter (SetOptions, SetPrintOptions, or SetRepeatOptions) fails, or whether it should throw an exception. You can specify True (continue) or False (throw an exception).

  • For detailed information about each parameter, see Operations on Concurrent Programs.

[Concurrent_Program_Name] Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<[Concurrent_Program_Name]Response xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]">
  <[Concurrent_Program_Name]Result>[value]</[Concurrent_Program_Name]Result>
</[Concurrent_Program_Name]Response>

The response from Oracle E-Business Suite contains a concurrent request ID.

Get_Status Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<GetStatusForConcurrentProgram xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]">
  <RequestId>[value]</RequestId>
</GetStatusForConcurrentProgram>

This Get_Status request message takes the request ID of a concurrent program as an input.

Get_Status Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<GetStatusForConcurrentProgramResponse xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]">
  <GetStatusForConcurrentProgramResult>[value]</GetStatusForConcurrentProgramResult>
  <Phase>[value]</Phase>
  <Status>[value]</Status>
  <DevPhase>[value]</DevPhase>
  <DevStatus>[value]</DevStatus>
  <Message>[value]</Message>
</GetStatusForConcurrentProgramResponse>

This Get_Status response message returns the request phase/status and the completion message of a concurrent program.

For detailed information about each parameter, see Operations on Concurrent Programs.

Wait_For_Request Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<WaitForRequestForConcurrentProgram xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]">
  <RequestId>[value]</RequestId>
  <Interval>[value]</Interval>
  <MaxWait>[value]</MaxWait>
</WaitForRequestForConcurrentProgram>

For detailed information about each parameter, see Operations on Concurrent Programs.

Wait_For_Request Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<WaitForRequestForConcurrentProgramResponse xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]">
  <WaitForRequestForConcurrentProgramResult>[value]</WaitForRequestForConcurrentProgramResult>
  <Phase>[value]</Phase>
  <Status>[value]</Status>
  <DevPhase>[value]</DevPhase>
  <DevStatus>[value]</DevStatus>
  <Message>[value]</Message>
</WaitForRequestForConcurrentProgramResponse>

This Wait_For_Request response message returns the request phase/status and the completion message of a concurrent program.

For detailed information about each parameter, see Operations on Concurrent Programs.

Submit_Request Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<SubmitRequestForConcurrentProgram xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]">
  <SetOptions>
    <Implicit>[value]</Implicit>
    <Protected>[value]</Protected>
    <Language>[value]</Language>
    <Territory>[value]</Territory>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetOptions>
  <SetPrintOptions>
    <Printer>[value]</Printer>
    <Style>[value]</Style>
    <Copies>[value]</Copies>
    <SaveOutput>[value]</SaveOutput>
    <PrintTogether>[value]</PrintTogether>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetPrintOptions>
  <SetRepeatOptions>
    <RepeatTime>[value]</RepeatTime>
    <RepeatInterval>[value]</RepeatInterval>
    <RepeatUnit>[value]</RepeatUnit>
    <RepeatType>[value]</RepeatType>
    <RepeatEndTime>[value]</RepeatEndTime>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetRepeatOptions>
  <Program>[value]</Program>
  <Description>[value]</Description>
  <StartTime>[value]</StartTime>
  <Arguments>[array_of_strings</Arguments>
</SubmitRequestForConcurrentProgram>

For detailed information about each parameter, see Operations on Concurrent Programs.

Submit_Request Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<SubmitRequestForConcurrentProgramResponse xmlns="[VERSION]/ConcurrentPrograms/[APP_SHORT_NAME]">
  <SubmitRequestForConcurrentProgramResult>[value]</SubmitRequestForConcurrentProgramResult>
</SubmitRequestForConcurrentProgramResponse>

If the submit request completes successfully, the response message returns the concurrent request ID. Otherwise, it returns “0”.

Entity descriptions:

[VERSION] = http://schemas.microsoft.com/OracleEBS/2008/05

[APP_SHORT_NAME] = Application short name

[CONCURRENT_PROGRAM_ARGUMENT] = Argument expected by the concurrent program as defined in Oracle E-Business Suite

Message Actions for Concurrent Programs

The Oracle E-Business adapter uses the following message actions for concurrent programs.

Note
See entity descriptions after the table.

Message | Action | Example
[Concurrent_Program_Name] Request | ConcurrentPrograms/[APP_SHORT_NAME]/[CONCURRENT_PROGRAM_SHORT_NAME] | ConcurrentPrograms/SQLGL/ADSFINS
[Concurrent_Program_Name] Response | ConcurrentPrograms/[APP_SHORT_NAME]/[CONCURRENT_PROGRAM_SHORT_NAME]/response | ConcurrentPrograms/SQLGL/ADSFINS/response
Get_Status Request | ConcurrentPrograms/[APP_SHORT_NAME]/GetStatusForConcurrentProgram | ConcurrentPrograms/SQLGL/GetStatusForConcurrentProgram
Get_Status Response | ConcurrentPrograms/[APP_SHORT_NAME]/GetStatusForConcurrentProgram/response | ConcurrentPrograms/SQLGL/GetStatusForConcurrentProgram/response
Wait_For_Request Request | ConcurrentPrograms/[APP_SHORT_NAME]/WaitForRequestForConcurrentProgram | ConcurrentPrograms/SQLGL/WaitForRequestForConcurrentProgram
Wait_For_Request Response | ConcurrentPrograms/[APP_SHORT_NAME]/WaitForRequestForConcurrentProgram/response | ConcurrentPrograms/SQLGL/WaitForRequestForConcurrentProgram/response
Submit_Request Request | ConcurrentPrograms/[APP_SHORT_NAME]/SubmitRequestForConcurrentProgram | ConcurrentPrograms/SQLGL/SubmitRequestForConcurrentProgram
Submit_Request Response | ConcurrentPrograms/[APP_SHORT_NAME]/SubmitRequestForConcurrentProgram/response | ConcurrentPrograms/SQLGL/SubmitRequestForConcurrentProgram/response

Entity descriptions:

[APP_SHORT_NAME] = Application short name

[CONCURRENT_PROGRAM_SHORT_NAME] = Concurrent Program short name

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for Request Sets

Each request set in an Oracle application in Oracle E-Business Suite is surfaced as an operation in Microsoft BizTalk Adapter for Oracle E-Business Suite.

Message Structure of Request Set Operation

The operations surfaced for request set follow a request-response message exchange pattern. The following table shows the structure of these request and response messages.

Note
See entity descriptions after the table.

Operation XML Message Description

[Request_Set_Name] Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<[Request_Set_Name] xmlns="[VERSION]/RequestSets/[APP_SHORT_NAME]/">
  <SetRelClassOptions>
    <Application>[value]</Application>
    <ClassName>[value]</ClassName>
    <CancelOrHold>[value]</CancelOrHold>
    <StaleDate>[value]</StaleDate>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetRelClassOptions>
  <SetPrintOptions>
    <Printer>[value]</Printer>
    <Style>[value]</Style>
    <Copies>[value]</Copies>
    <SaveOutput>[value]</SaveOutput>
    <PrintTogether>[value]</PrintTogether>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetPrintOptions>
  <SetRepeatOptions>
    <RepeatTime>[value]</RepeatTime>
    <RepeatInterval>[value]</RepeatInterval>
    <RepeatUnit>[value]</RepeatUnit>
    <RepeatType>[value]</RepeatType>
    <RepeatEndTime>[value]</RepeatEndTime>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetRepeatOptions>
  <SetNlsOptions>
    <Language>[value]</Language>
    <Territory>[value]</Territory>
    <ContinueOnFail>[value]</ContinueOnFail>
  </SetNlsOptions>
  <StartTime><[value]</StartTime>
  <[CONCURRENT_PROGRAM_NAME1]>[value]</[CONCURRENT_PROGRAM_NAME1]>
  <[CONCURRENT_PROGRAM_NAME2]>[value]</[CONCURRENT_PROGRAM_NAME2]>
  …
</[Request_Set_Name]>
  • The [Request_Set_Name] operation takes five standard parameters: SetRelClassOptions, SetPrintOptions, SetRepeatOptions, SetNlsOptions, and StartTime.

  • The ContinueOnFail parameter indicates whether the request set submission should continue or throw an exception in case the parent parameter (SetRelClassOptions, SetPrintOptions, SetRepeatOptions or SetNlsOptions) fails. You can specify True (continue) or False (throw an exception).

  • For detailed information about each parameter, see Operations on Request Sets.

[Request_Set_Name] Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<[Request_Set_Name]Response xmlns="[VERSION]/RequestSets/[APP_SHORT_NAME]">
  <[Request_Set_Name]Result>[value]</[Request_Set_Name]Result>
</[Request_Set_Name]Response>

The response from Oracle E-Business Suite contains a concurrent request ID.

Entity descriptions:

[VERSION] = http://schemas.microsoft.com/OracleEBS/2008/05

.

[CONCURRENT_PROGRAM_NAME] = Concurrent program included in the request set.

Message Actions for Request Sets

The Oracle E-Business adapter uses the following message actions for request sets.

Note
See entity descriptions after the table.

Message | Action | Example
Request Set request | RequestSets/[APP_SHORT_NAME]/[REQUESTSET_SHORT_NAME] | RequestSets/SQLGL/FNDRSSUB965
Request Set response | RequestSets/[APP_SHORT_NAME]/[REQUESTSET_SHORT_NAME]]/response | RequestSets/SQLGL/FNDRSSUB965/response

Entity descriptions:

[APP_SHORT_NAME] = Application short name.

[REQUESTSET_SHORT_NAME] = Request Set short name.

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for Special LOB Operations

The Read_<LOBColName> and Update_<LOBColName> operations are surfaced for tables and views that contain LOB columns, where <LOBColName> is the LOB column in the table or view. These operations enable you to read or write the LOB data as a stream of base64Binary-encoded data. They operate on a single column of LOB data in a single row.

For an overview of the Read_<LOBColName> and Update_<LOBColName> operations and of the Oracle LOB data types supported, see Operations on Interface Tables, Interface Views, Tables, and Views That Contain LOB Data.

Message Structure of LOB Data-Type Operations

The following table shows the structure of the request and response messages for the Read_<LOBColName> and Update_<LOBColName> operations. The target table for the operation is specified in the message action and also appears in the target namespace.

Note
See entity descriptions after the table.

Operation XML Message Description

Read_<LOBColName>

Copy Code
<Read_[LOBColName] xmlns="[VERSION]/Tables/[SCHEMA]/[TABLE_NAME]">
  <FILTER>[WHERE_clause]</FILTER>
</Read_[LOBColName]>

The LOB data in the row that matches the where clause specified in the FILTER element is returned. The where clause should match only a single row. If there is more than one matching row, the Oracle E-Business adapter will throw an exception.

Read_<LOBColName> Response

Copy Code
<Read_[LOBColName]Response xmlns="[VERSION]/Tables/[SCHEMA]/[TABLE_NAME]">
  <Read_[LOBColName]Result>
    [LOB_DATA]
  </Read_[LOBColName]Result>
</Read_[LOBColName]Response>

The LOB data is returned as a stream of base64Binary encoded data.

Update_<LOBColName>

Copy Code
<Update_[LOBColName] xmlns="[VERSION]/Tables/[SCHEMA]/[TABLE_NAME]">
  <FILTER>[WHERE_clause]</LOB_COLUMN>
  <DATA>[Value]</DATA>
</Update_[LOBColName]>

The LOB data in the row that matches the where clause specified in the FILTER element is updated with the data in the <DATA> element. The where clause should match only a single row. If there is more than one matching row, the Oracle E-Business adapter throws an exception.

Note
While updating BLOB columns, the <DATA> element must always contain a base64 encoded value. For CLOB and NCLOB, the <DATA> element can have string values.

Update_<LOBColName> Response

Copy Code
<Update_[LOBColName]Response xmlns="[VERSION]/Tables/[SCHEMA]/[TABLE_NAME]">
</Update_[LOBColName]Response>

An empty response is returned.

Entity descriptions:

[VERSION] = The message version string; for example, "http://schemas.microsoft.com/OracleEBS/2008/05".

[SCHEMA] = Collection of Oracle artifacts; for example, SCOTT.

[TABLE_NAME] = The table that contains the targeted LOB column; for example, CUSTOMER.

[LOBCol_Name] = The name of a LOB column; for example, Photo.

[WHERE_clause] = An Oracle database SELECT statement WHERE clause that matches a single row; for example, ID = 1.

[LOB_DATA] = The LOB column data in base64Binary type.

Important
The message structure for the Read_<LOBColName> and Update_<LOBColName> operations on views is the same as that on tables except that the namespace for the operation specifies a view rather than a table: <ReadLOB xmlns ="[VERSION]/Views/[SCHEMA]/[VIEW_NAME]">.

Message Actions for LOB Data-Type Operations

The following table shows the message actions that are used by the Oracle E-Business adapter for the Read_<LOBColName> and Update_<LOBColName> operations on tables. The Oracle E-Business adapter uses the table name and the LOB column name specified in the message action to determine the target table and LOB column for the operation.

Note
See entity descriptions after the table.

Operation | Action | Example
Read_<LOBColName> | Tables/ReadLOB/[SCHEMA]/[TABLE_NAME]/[LOBColName] | Tables/ReadLOB/SCOTT/CUSTOMER/Photo
Read_<LOBColName> Response | Tables/ReadLOB/[SCHEMA]/[TABLE_NAME]/[LOBColName]/response | Tables/ReadLOB/SCOTT/CUSTOMER/Photo/response
Update_<LOBColName> | For BLOB: Tables/UpdateBLOB/[SCHEMA]/[TABLE_NAME]/[LOBColName] For CLOB and NCLOB: Tables/UpdateCLOB/[SCHEMA]/[TABLE_NAME]/[LOBColName] | For BLOB: Tables/UpdateBLOB/SCOTT/CUSTOMER/Photo/ For CLOB and NCLOB: Tables/UpdateCLOB/SCOTT/CUSTOMER/Photo1/
Update_<LOBColName> Response | For BLOB: Tables/UpdateBLOB/[SCHEMA]/[TABLE_NAME]/[LOBColName]/response For CLOB and NCLOB: Tables/UpdateCLOB/[SCHEMA]/[TABLE_NAME]/[LOBColName]/response | For BLOB: Tables/UpdateBLOB/SCOTT/CUSTOMER/Photo/response For CLOB and NCLOB: Tables/UpdateCLOB/SCOTT/CUSTOMER/Photo1/response

Entity descriptions:

[SCHEMA] = Collection of Oracle artifacts; for example, SCOTT.

[TABLE_NAME] = The table that contains the targeted LOB column; for example, CUSTOMER. (The SCOTT.CUSTOMER table is installed by a SQL script included in the samples.)

[LOBCol_Name] = The name of a LOB column; for example, Photo.

Important
The message action for Read_<LOBColName> and Update_<LOBColName> operations on views is similar to that used for tables, except that action for the operation specifies a view rather than a table: Views/ReadLOB/[SCHEMA]/[VIEW_NAME]/[LOBColName].

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for the Polling Operations

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces various inbound operations related to polling depending on the target object in Oracle E-Business Suite. For interface tables, interface views, tables, and views, a single Poll operation is surfaced whereas you can have multiple custom polling operations for PL/SQL APIs, functions, and stored procedures.

You configure the polling operations by setting binding properties in the Oracle E-Business adapter. For more information about these binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. You set the PollingStatement binding property to specify a SQL statement, stored procedure, function or a procedure within a package for the polling query. The result set of this query is returned as data to your code in the polling operation.

Message Structure for the Polling Operations

The following table shows the XML message structure for the various polling operations.

Note
See entity descriptions after the table.

Operation Target Object XML Message Description

Poll

  • Interface Tables

  • Interface Views

  • Tables

  • Views

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Poll xmlns="[Version]/[TargetObject]/[Schema]/[TargetObject_Name]">
   <DATA>
     <SelectRecord>
       <Column1>[Value]</Column1>
       <Column2>[Value]</Column2>
       …
     </SelectRecord>
   </DATA>
</Poll>

For example, the XML message for the Poll operation on Interface Tables will be as follows:

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Poll xmlns="[Version]/InterfaceTables/[Schema]/[InterfaceTable_Name]">
   <DATA>
     <SelectRecord>
       <Column1>[Value]</Column1>
       <Column2>[Value]</Column2>
       …
     </SelectRecord>
   </DATA>
</Poll>

[CustomPollingOperation]

  • PL/SQL APIs

  • Stored Procedures

  • Functions

PL/SQL APIs

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<[CustomPollingOperation] xmlns="[Version]/PollingPackageAPis/[Schema]/[PL/SQL API]">
   <[CustomPollingOperation]Result>[Value]</[CustomPollingOperation]Result>
</[CustomPollingOperation]>

Functions

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<[CustomPollingOperation] xmlns="[Version]/PollingFunctions/[Schema]">
   <[CustomPollingOperation]Result>
     <COL1>[Value]</COL1]>
     <COL2>[Value]</COL2>
     …
   </[CustomPollingOperation]Result>
</[CustomPollingOperation]>

Stored Procedures

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<[CustomPollingOperation] xmlns="[Version]/PollingFunctions/[Schema]">
   <[CustomPollingOperation]Result>
     <PRM1>[Value]</PRM1>
     <PRM2>[Value]</PRM2>
     …
   </[CustomPollingOperation]Result>
</[CustomPollingOperation]>

The structure of the result set in the polling operation is determined by the data type of the elements in the target object.

Entity descriptions:

[Version] = http://schemas.microsoft.com/OracleEBS/2008/05.

[CustomPollingOperation] = Name of the custom polling operation.

[Schema] = Name of the Oracle schema. For example, SCOTT.

[PL/SQL API] = Name of the PL/SQL API on which a custom polling operation is performed.

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for the Notification Operation

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces the Notification operation to receive database change notifications from the underlying database in Oracle E-Business Suite.

You configure the Notification operation by setting binding properties in the Oracle E-Business adapter. For more information about the Notification-related binding properties, see Working with BizTalk Adapter for Oracle E-Business Suite Binding Properties. You set the NotificationStatement binding property to specify a SELECT statement for the query notification.

Message Structure for the Notification Operation

The following table shows the XML message structure for the Notification operation.

Operation XML Message Description

Notification

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Notification xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Notification">
   <Info>Value</Info>
   <Source>Value</Source>
   <Type>Value</Type>
</Notification>

This is the inbound message that is sent by Oracle E-Business Suite to the adapter clients. In the message:

  • The <Info> tag indicates the reason for the notification. For example, an “insert” value in this tag indicates that data has been inserted in one or more of the tables referenced in the notification statement.

  • The <Source> tag indicates the source for the notification. For example, a “data” value in this tag indicates a change in the data in a referenced object. Similarly, an “object” value in this tag indicates a change in a referenced object.

  • The <Type> tag indicates the type of data change. For example, an “Update” value in the <Type> tag indicates that the results of the query have been updated.

Message Action for the Notification Operation

The message action for the notification operation is “Notification.”

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for the ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations

The Microsoft BizTalk Adapter for Oracle E-Business Suite exposes the ExecuteNonQuery, ExecuteReader, and ExecuteScalar outbound operations at the root level to execute any arbitrary SQL statements or PL/SQL blocks in Oracle E-Business Suite.

For more information about:

  • These operations, see Support for ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations.

  • Performing these operations using the Oracle E-Business adapter, see Performing ExecuteReader, ExecuteScalar, or ExecuteNonQuery Operations Using BizTalk Server.

Message Structure for the ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations

The messages in these operations follow a request-response message exchange pattern, and the following table shows the structure of these request and response messages.

Note
See entity descriptions after the table.

Operation XML Message

ExecuteNonQuery Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<ExecuteNonQuery xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/ ">
  <Query>[PL/SQL block]</Query>
  <OutputRefCursorNames>
    <string>[stringvalue1]</string>
    <string>[stringvalue2]</string>
    …
  </OutputRefCursorNames>
</ExecuteNonQuery>

ExecuteNonQuery Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<ExecuteNonQueryResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/ ">
  <ExecuteNonQueryResult>[value]</ExecuteNonQueryResult>
  <OutputRefCursors>
    <DataSet>
      <Any>[value]</Any>
      <Any>[value]</Any>
      …
    </DataSet>
  </OutputRefCursors>
</ExecuteNonQueryResponse>

ExecuteReader Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<ExecuteReader xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/ ">
  <Query>[PL/SQL block]</Query>
</ExecuteReader>

ExecuteReader Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<ExecuteReaderResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/ ">
  <ExecuteReaderResult>
    <Any>[value]</Any>
    <Any>[value]</Any>
      …
  </ExecuteReaderResult>
</ExecuteReaderResponse>

ExecuteScalar Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<ExecuteScalar xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/ ">
  <Query>[PL/SQL block]</Query>
</ExecuteScalar>

ExecuteScalar Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<ExecuteScalarResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/GenericOperation/ ">
  <ExecuteScalarResult>[value]</ExecuteScalarResult>
</ExecuteScalarResponse>

Entity descriptions:

[PL/SQL block] = The entire PL/SQL block to be executed.

[stringvalue1] = A value in the array of strings.

Message Action for the ExecuteNonQuery, ExecuteReader, and ExecuteScalar Operations

The following table shows the message actions that are used by the ExecuteNonQuery, ExecuteReader, and ExecuteScalar operations.

Operation | Action
ExecuteNonQuery Request | GenericOp/ExecuteNonQuery
ExecuteNonQuery Response | GenericOp/ExecuteNonQuery/response
ExecuteReader Request | GenericOp/ExecuteReader
ExecuteReader Response | GenericOp/ExecuteReader/response
ExecuteScalar Request | GenericOp/ExecuteScalar
ExecuteScalar Response | GenericOp/ExecuteScalar/response

© 2014 Microsoft Corporation. All rights reserved.


Message Schemas for the Composite Operation

The Microsoft BizTalk Adapter for Oracle E-Business Suite enables you to execute composite operations in Oracle E-Business Suite. A composite operation can contain multiple operations, and in any order. For information about which operations can be included in a composite operation, see Support for Composite Operations.

For information about how to perform composite operations using the Oracle E-Business adapter, see Performing Composite Operations on Oracle Database by Using BizTalk Server.

Message Structure for the Composite Operation

Since a composite operation contains multiple individual operations; the message structure of a composite operation contains message structures of the individual operations. The composite operation message follows a request-response message exchange pattern.

The following table shows the structure of the request and response messages of a composite operation that contains an Insert operation, a packaged stored procedure that does not take any input parameters, and a Delete operation.

Note
See entity descriptions after the table.

Operation XML Message

Composite Operation Request

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<Request xmlns="http://[PROJECT_NAME].[COMPOSITE_SCHEMA_NAME]">
  <Insert xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/[SCHEMA]/[TABLE_NAME]">
    <Recordset>
      <InsertRecord>
        <[FIELD1_NAME]>[value1]</[FIELD1_NAME]>
          <InLineValue>[value]</InlineValue>
        <[FIELD2_NAME]>[value2]</[FIELD2_NAME]>
          <InLineValue>[value]</InlineValue>
        …
      <InsertRecord>
   </RECORDSET>
  </Insert>
  <[SP_NAME] xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/PackageApis/[SCHEMA]/[APP_NAME]" />
  <Delete xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/[SCHEMA]/[TABLE_NAME]">
    <FILTER>[WHERE_clause]</FILTER>
  </Delete>
</Request>

Composite Operation Response

Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<RequestResponse xmlns="http://[PROJECT_NAME].[COMPOSITE_SCHEMA_NAME]">
  <InsertResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Tables/[SCHEMA]/[TABLE_NAME]">
    <InsertResult>[value]</InsertResult>
  </InsertResponse>
  <[SP_NAME]Response xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/Procedures/[SCHEMA]">
    <[PRM1_NAME]>value1<[PRM1_NAME]>
    <[PRM2_NAME]>value2</[PRM2_NAME]>
    …
  </[SP_NAME]Response>
  <DeleteResponse xmlns="http://schemas.microsoft.com/OracleEBS/2008/05/TableOp/[SCHEMA]/[TABLE_NAME]">
    <DeleteResult>[value]</DeleteResult>
  </DeleteResponse>
</RequestResponse>

Entity descriptions:

[PROJECT_NAME] = Name of the BizTalk project that contains the composite operation schema.

[COMPOSITE_SCHEMA_NAME] = Name of the composite operation schema given by the user.

[SCHEMA] = Collection of Oracle artifacts; for example, SCOTT.

[TABLE_NAME] = Name of the table; for example, EMPLOYEE.

[FIELD1_NAME] = Table field name; for example, NAME.

[SP_NAME] = The packaged stored procedure to be executed; for example, ADD_EMP_DETAILS.

[APP_NAME] = Name of the Oracle Application that contains the packaged stored procedure.

[PRM1_NAME] = The name of the Oracle parameter in the packaged stored procedure.

Message Action for the Composite Operation

The message action for the composite operation is “CompositeOperation.”

See Also

Other Resources

Messages and Message Schemas for BizTalk Adapter for Oracle E-Business Suite

© 2014 Microsoft Corporation. All rights reserved.


Glossary

The following terms and definitions are used in Microsoft BizTalk Adapter for Oracle E-Business Suite Help.

Microsoft BizTalk Adapter Pack Glossary

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

Term | Definition
adapter | A WCF-based component that helps exchange messages between applications (for example, a line-of-business system) and BizTalk Server. The adapter consists of design-time components and run-time components for receive and send operations.
adapter client | An application that interacts with a line-of-business (LOB) system through the adapter.

B

Term | Definition
binding | A process by which software components and layers are linked together. When a network component is installed, the binding relationships and dependencies for the components are established. Binding allows components to communicate with each other. In BizTalk Server, an established mapping between an orchestration adapter-agnostic endpoint (port or role link) and physical adapter-specific endpoints (send/receive ports or party).
BizTalk Server | Connects diverse software. BizTalk Server enables you to create and modify process logic that uses that software. BizTalk Server also enables information workers to monitor running processes, interact with trading partners, and perform other business-oriented tasks.

C

Term | Definition
channel | A concrete implementation of a binding element. The binding represents the configuration, and the channel is the implementation associated with that configuration. Therefore, there is a channel associated with each binding element. Channels stack on top of each other to create the concrete implementation of the binding: the channel stack.
connection URI | A string that identifies a resource in a distributed environment. Adapters use a connection Uniform Resource Identifier (URI) that contains the information necessary to establish a connection with the LOB system.
contract | Specifies the collection and structure of messages required to access the operations offered by the service.

D

Term | Definition
data manipulation language (DML) | The subset of SQL statements that is used to retrieve and manipulate data. DML statements typically start with SELECT, INSERT, UPDATE, or DELETE.
design-time experience | Procedures and operations that a developer performs during design time; for example, using the Consume Adapter Service BizTalk Project Add-in to retrieve message schemas.

E

Term | Definition
endpoint address | A network address that identifies the location of a Windows Communication Foundation (WCF) service endpoint. For an adapter, the endpoint address is expressed as a connection Uniform Resource Identifier (URI) that contains location and connection parameters. The adapter can use these to establish a connection to the underlying line-of-business (LOB) system.
Enterprise Single Sign-on system | An SSO database, a master secret server, and one or more Enterprise Single Sign-On (SSO) servers. These servers do the mapping between the Windows and non-Windows credentials, look up the credentials in the SSO database, and are used for administering the SSO system. The SSO database is also used as a configuration store to hold custom configuration data for adapters.
Extensible Markup Language | A markup language designed to describe data. XML tags are not predefined.

G

Term | Definition
GAC | See global assembly cache.
global assembly cache (GAC) | A machine-wide code cache that stores assemblies specifically installed to be shared by many applications on the computer. Applications deployed in the global assembly cache must have a strong name.

H

Term | Definition
Health and Activity Tracking (HAT) | A user interface that enables specified data to be tracked. This interface can be used to monitor the health of the BizTalk Server farm and to track and view specific events and messages.

I

Term | Definition
inbound operation | An operation that is invoked by a line-of-business (LOB) system on the adapter.

M

Term | Definition
metadata | In WCF, refers to a description of the contract exposed by a service. This is known as the service description and is expressed in a WSDL document. The metadata exposed by an adapter describes the (interface to) the operations that it can perform on the underlying LOB system.
Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK | The specifications for building BizTalk adapters using open standards based on Web services.

O

Term | Definition
one-way | A message exchange pattern (MEP) in which the sender sends a message, but no response is returned by the receiver. In BizTalk Server, MEPs are referred to as communication patterns.
outbound operation | An operation that is invoked by the adapter on the line-of-business system (LOB).
output.cs | The default output file created by the ServiceModel Metadata Utility tool (svcutil.exe).

P

Term | Definition
polling | A technique that device drivers use to find out from multiple devices whether they contain data to transmit. The devices are polled one at a time.
proxy | In WCF, refers to a managed-code object that implements the service contract exposed by a service. The WCF service model is based on the use of such proxies. In the WCF service model, the service contract is expressed as a .NET interface.

R

Term | Definition
request-response | A message exchange pattern (MEP) in which the sender sends a request message and expects a response message from the receiver. In BizTalk Server, MEPs are referred to as communication patterns. Depending on the messaging technology and the direction of the request message (inbound or outbound), this pattern is also called request-reply or solicit-response.
run-time experience | Procedures and operations performed by a developer during run time or when deploying a solution; for example, creating a physical port binding from the BizTalk Server Administration console.

S

Term | Definition
schema | The structure for a message. A schema can contain multiple subschema.
ServiceModel Metadata Utility Tool (svcutil.exe) | A command-line utility that is included with WCF. It is used to create service model proxy code from the service description (metadata) that is exposed by a WCF service such as an adapter. For outbound operations, the tool creates a WCF client class and helper code; for inbound operations, the tool creates a WCF service contract and helper code.
Simple Object Access Protocol | See SOAP.
SOAP | A simple, XML-based protocol for exchanging structured and type information in decentralized, distributed environments. WCF is based on the exchange of SOAP messages between clients and services to invoke operations and return results.
SOAP message | A well-formed XML document. It should use the SOAP envelope and SOAP encoding namespaces and include an optional XML declaration, followed by a SOAP envelope (the root element), which is made up of an optional SOAP header and a SOAP message body.
SQL Server Integration Services (SSIS) | A component that is used to import, export, and transform data from different data sources. Previously called data transformation service (DTS).
SSIS | See SQL Server Integration Services.
SSO | See Enterprise Single Sign-on system.
strongly-typed data | A data set or result set that is bound to an underlying object type. Each row in a strongly-typed XML data set is composed of typed, named elements that correspond to fields of the underlying object type.
svcutil.exe | See ServiceModel Metadata Utility Tool.

U

Term | Definition
Uniform Resource Identifier (URI) | See connection URI

W

Term | Definition
WCF | See Windows Communication Foundation
WCF channel model | A programming model that relies on several interfaces and other types. Channels provide a low-level programming model for sending and receiving messages.
WCF client | A client-application construct that exposes the service operations as methods. You can use the Add Adapter Service Reference Visual Studio Plug-in or the ServiceModel Metadata Utility Tool to generate a WCF client class from the metadata exposed by an adapter.
WCF LOB Adapter SDK | See Microsoft Windows Communication Foundation (WCF) Line of Business (LOB) Adapter SDK
WCF service contract | A managed-code representation of the service contract. It is expressed as an interface in which classes and methods are attributed to define the service, operation, message, and data contracts used to communicate with a service. You can use the ServiceModel Metadata Utility tool or the Add Adapter Service Reference Visual Studio Plug-in to generate a WCF service contract from the metadata exposed by an adapter. You implement the WCF service contract to receive operations from an LOB system.
WCF service model | A WCF programming model in which a service is represented as a managed code object. The operations exposed by the service are represented as methods with strongly-typed data.
weakly-typed data | A data set or result set that is not bound to an underlying object type. Each row in a weakly-typed XML data set is composed of a collection of generic columns in which attributes describe the name and type of each element.
Web services | A unit of application logic providing data and services to other applications. Applications access XML Web services using standard Web protocols and data formats such as HTTP, XML, and SOAP, independent of how each XML Web service is implemented. XML Web services combine the best aspects of component-based development and the Web, and are a cornerstone of the Microsoft .NET programming model.
Web Services Description Language (WSDL) | An XML-based language that describes a service as a set of endpoints that operate on messages. The WSDL document describes the service contract, operation contracts, message contracts, and data contracts that a client must use to interface with the service.
Windows Communication Foundation (WCF) | A Microsoft service-oriented communication infrastructure. The framework inherently provides clients with a service programming model and a channel programming model for finer control of message exchanges.
WSDL | See Web Services Description Language.

X

Term | Definition
XML | See Extensible Markup Language.
XML Schema definition language (XSD) | A schema language. An XML Schema defines the elements, attributes, and data types that comply with the World Wide Web Consortium (W3C) XML Schema Part 1: Structures Recommendation for the XML Schema Definition Language. The W3C XML Schema Part 2: Datatypes Recommendation is the recommendation for defining data types that are used in XML schemas. The XML Schema definition language enables you to define the structure and data types for XML messages.
XSD | See XML Schema definition language.

© 2014 Microsoft Corporation. All rights reserved.


Microsoft BizTalk Adapter for Oracle E-Business Suite Developer Reference

This section provides API reference for Oracle E-Business adapter.

© 2014 Microsoft Corporation. All rights reserved.


Class Library

Namespaces

Namespace
Microsoft.Adapters.OracleEBS
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema


Microsoft.Adapters.OracleEBS Namespace

Classes

Class | Description
MlsSettings | Multiple Language System Settings configuration element
OracleEBSAdapter | The Binding Element for the Oracle E-Business Suite Adapter.
OracleEBSBinding | Represents the Oracle E-Business Suite WCF Binding.
OracleEBSBindingCollectionElement | Represents the StandardBindingCollectionElement for the Oracle E-Business Suite Adapter.
OracleEBSBindingConfigurationElement | Represents the StandardBindingElement for the Oracle E-Business Suite Adapter.
OracleEBSBindingElementExtensionElement | Enables the configuration of the Oracle E-Business Suite Adapter Binding from an application configuration file.
OracleEBSConnectionUri | Builds the Uniform Resource Identifier (URI) for establishing connection to the Oracle E-Business Suite and essentially the underlying Oracle database.
OracleEBSInboundTransactionBehavior |

Enumerations

Enumeration | Description
ClientCredential | The set of credentials that are specified while establishing a connection with the Oracle E-Business Suite.
InboundOperation | The Inbound Operation to be performed.
OracleServiceType |


ClientCredential Enumeration
[image]

The set of credentials that are specified while establishing a connection with the Oracle E-Business Suite.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As ClientCredential

Syntax

Visual Basic
Public Enumeration ClientCredential
C#
public enum ClientCredential
C++
public enum class ClientCredential
J#
public enum ClientCredential
JScript
public enum ClientCredential

Members

Member name | Description
Database | The Database credentials.
EBusiness | The E-Business Suite credentials.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

Microsoft.Adapters.OracleEBS Namespace


InboundOperation Enumeration
[image]

The Inbound Operation to be performed.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As InboundOperation

Syntax

Visual Basic
Public Enumeration InboundOperation
C#
public enum InboundOperation
C++
public enum class InboundOperation
J#
public enum InboundOperation
JScript
public enum InboundOperation

Members

Member name | Description
Notification | The Notification Inbound Operation.
Polling | The Polling Inbound Operation.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference


MlsSettings Class
See Also Members
[image]

Multiple Language System Settings configuration element

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings

Syntax

Visual Basic
Public Class MlsSettings
    Inherits ConfigurationElement
C#
public class MlsSettings : ConfigurationElement
C++
public ref class MlsSettings : public ConfigurationElement
J#
public class MlsSettings extends ConfigurationElement
JScript
public class MlsSettings extends ConfigurationElement

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
Microsoft.Adapters.OracleEBS.MlsSettings

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Members


MlsSettings Members
See Also Constructors Methods Properties
[image]

Multiple Language System Settings configuration element

The following tables list the members exposed by the MlsSettings type.

Public Constructors

Name | Description
MlsSettings | Overloaded. Initializes a new instance of the MlsSettings class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | Calendar | Gets or sets the calendar used in the management license settings.
public property | Comparison | Gets or sets the comparison used in the management license settings.
public property | Currency | Gets or sets the currency used in the management license settings.
public property | DateFormat | Gets or sets the date format used in the used in the management license settings.
public property | DateLanguage | Gets or sets the date format used in the management license settings.
public property | DualCurrency | Gets or sets the dual currency used in the management license settings.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | ISOCurrency | Gets or sets the ISO currency used in the management license settings.
public property | Language | Gets or sets the language used in the management license settings.
public property | LengthSemantics | Gets or sets the length semantics used in the management license settings.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | NCharConversionException | Gets or sets whether the specified object is a national character conversion exception.
public property | NumericCharacters | Gets or sets the numeric characters used in the management license settings.
public property | Sort | Gets or sets the sort order used in the management license settings.
public property | Territory | Gets or sets the territory used in the management license settings.
public property | TimeStampFormat | Gets or sets the time stamp format used in the management license settings.
public property | TimeStampTZFormat | Gets or sets the time stamp time zone format used in the management license settings.
public property | TimeZone | Gets or sets time zone used in the management license settings.
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the properties used in the management license settings.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | Overridden. Creates a string representation of the current MlsSettings configuration element.
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

See Also

Reference

MlsSettings Class


MlsSettings Constructor
[image]

Initializes a new instance of the MlsSettings class.

Overload List

Name | Description
MlsSettings () | Initializes a new instance of the MlsSettings configuration element
MlsSettings (MlsSettings) | Initializes a new instance of the MlsSettings configuration element from an existing instance.

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings Constructor ()
[image]

Initializes a new instance of the MlsSettings configuration element

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New MlsSettings

Syntax

Visual Basic
Public Sub New
C#
public MlsSettings ()
C++
public:
MlsSettings ()
J#
public MlsSettings ()
JScript
public function MlsSettings ()

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings Constructor (MlsSettings)
[image]

Initializes a new instance of the MlsSettings configuration element from an existing instance.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim other As MlsSettings

Dim instance As New MlsSettings(other)

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors")> _
<SuppressMessageAttribute("Microsoft.Design", "CA1062:ValidateArgumentsOfPublicMethods")> _
Public Sub New ( _
    other As MlsSettings _
)
C#
[SuppressMessageAttribute("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors")]
[SuppressMessageAttribute("Microsoft.Design", "CA1062:ValidateArgumentsOfPublicMethods")]
public MlsSettings (
    MlsSettings other
)
C++
[SuppressMessageAttribute(L"Microsoft.Usage", L"CA2214:DoNotCallOverridableMethodsInConstructors")]
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1062:ValidateArgumentsOfPublicMethods")]
public:
MlsSettings (
    MlsSettings^ other
)
J#
/** @attribute SuppressMessageAttribute("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors") */
/** @attribute SuppressMessageAttribute("Microsoft.Design", "CA1062:ValidateArgumentsOfPublicMethods") */
public MlsSettings (
    MlsSettings other
)
JScript
SuppressMessageAttribute("Microsoft.Usage", "CA2214:DoNotCallOverridableMethodsInConstructors")
SuppressMessageAttribute("Microsoft.Design", "CA1062:ValidateArgumentsOfPublicMethods")
public function MlsSettings (
    other : MlsSettings
)

Parameters

other

The exsisting instance.

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | Overridden. Creates a string representation of the current MlsSettings configuration element.

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

See Also

Reference

MlsSettings Class


MlsSettings.ToString Method
[image]

Creates a string representation of the current MlsSettings configuration element.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim returnValue As String

returnValue = instance.ToString

Syntax

Visual Basic
Public Overrides Function ToString As String
C#
public override string ToString ()
C++
public:
virtual String^ ToString () override
J#
public String ToString ()
JScript
public override function ToString () : String

Return Value

The current MlsSettings configuration element as a string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | Calendar | Gets or sets the calendar used in the management license settings.
public property | Comparison | Gets or sets the comparison used in the management license settings.
public property | Currency | Gets or sets the currency used in the management license settings.
public property | DateFormat | Gets or sets the date format used in the used in the management license settings.
public property | DateLanguage | Gets or sets the date format used in the management license settings.
public property | DualCurrency | Gets or sets the dual currency used in the management license settings.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | ISOCurrency | Gets or sets the ISO currency used in the management license settings.
public property | Language | Gets or sets the language used in the management license settings.
public property | LengthSemantics | Gets or sets the length semantics used in the management license settings.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | NCharConversionException | Gets or sets whether the specified object is a national character conversion exception.
public property | NumericCharacters | Gets or sets the numeric characters used in the management license settings.
public property | Sort | Gets or sets the sort order used in the management license settings.
public property | Territory | Gets or sets the territory used in the management license settings.
public property | TimeStampFormat | Gets or sets the time stamp format used in the management license settings.
public property | TimeStampTZFormat | Gets or sets the time stamp time zone format used in the management license settings.
public property | TimeZone | Gets or sets time zone used in the management license settings.

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the properties used in the management license settings.

See Also

Reference

MlsSettings Class


MlsSettings.Calendar Property
[image]

Gets or sets the calendar used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.Calendar

instance.Calendar = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("calendar", DefaultValue:=Nothing)> _
Public Property Calendar As String
C#
[ConfigurationPropertyAttribute("calendar", DefaultValue=null)]
public string Calendar { get; set; }
C++
[ConfigurationPropertyAttribute(L"calendar", DefaultValue=nullptr)]
public:
virtual property String^ Calendar {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_Calendar ()

/** @property */
public final void set_Calendar (String value)
JScript
public final function get Calendar () : String

public final function set Calendar (value : String)

Property Value

The calendar used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.Comparison Property
[image]

Gets or sets the comparison used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.Comparison

instance.Comparison = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("comparison", DefaultValue:=Nothing)> _
Public Property Comparison As String
C#
[ConfigurationPropertyAttribute("comparison", DefaultValue=null)]
public string Comparison { get; set; }
C++
[ConfigurationPropertyAttribute(L"comparison", DefaultValue=nullptr)]
public:
virtual property String^ Comparison {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_Comparison ()

/** @property */
public final void set_Comparison (String value)
JScript
public final function get Comparison () : String

public final function set Comparison (value : String)

Property Value

The comparison used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.Currency Property
[image]

Gets or sets the currency used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.Currency

instance.Currency = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("currency", DefaultValue:=Nothing)> _
Public Property Currency As String
C#
[ConfigurationPropertyAttribute("currency", DefaultValue=null)]
public string Currency { get; set; }
C++
[ConfigurationPropertyAttribute(L"currency", DefaultValue=nullptr)]
public:
virtual property String^ Currency {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_Currency ()

/** @property */
public final void set_Currency (String value)
JScript
public final function get Currency () : String

public final function set Currency (value : String)

Property Value

The currency used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.DateFormat Property
[image]

Gets or sets the date format used in the used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.DateFormat

instance.DateFormat = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("dateFormat", DefaultValue:=Nothing)> _
Public Property DateFormat As String
C#
[ConfigurationPropertyAttribute("dateFormat", DefaultValue=null)]
public string DateFormat { get; set; }
C++
[ConfigurationPropertyAttribute(L"dateFormat", DefaultValue=nullptr)]
public:
virtual property String^ DateFormat {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_DateFormat ()

/** @property */
public final void set_DateFormat (String value)
JScript
public final function get DateFormat () : String

public final function set DateFormat (value : String)

Property Value

The date format used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.DateLanguage Property
[image]

Gets or sets the date format used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.DateLanguage

instance.DateLanguage = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("dateLanguage", DefaultValue:=Nothing)> _
Public Property DateLanguage As String
C#
[ConfigurationPropertyAttribute("dateLanguage", DefaultValue=null)]
public string DateLanguage { get; set; }
C++
[ConfigurationPropertyAttribute(L"dateLanguage", DefaultValue=nullptr)]
public:
virtual property String^ DateLanguage {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_DateLanguage ()

/** @property */
public final void set_DateLanguage (String value)
JScript
public final function get DateLanguage () : String

public final function set DateLanguage (value : String)

Property Value

The date format used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.DualCurrency Property
[image]

Gets or sets the dual currency used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.DualCurrency

instance.DualCurrency = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("dualCurrency", DefaultValue:=Nothing)> _
Public Property DualCurrency As String
C#
[ConfigurationPropertyAttribute("dualCurrency", DefaultValue=null)]
public string DualCurrency { get; set; }
C++
[ConfigurationPropertyAttribute(L"dualCurrency", DefaultValue=nullptr)]
public:
virtual property String^ DualCurrency {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_DualCurrency ()

/** @property */
public final void set_DualCurrency (String value)
JScript
public final function get DualCurrency () : String

public final function set DualCurrency (value : String)

Property Value

The dual currency used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.ISOCurrency Property
[image]

Gets or sets the ISO currency used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.ISOCurrency

instance.ISOCurrency = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("iSOCurrency", DefaultValue:=Nothing)> _
Public Property ISOCurrency As String
C#
[ConfigurationPropertyAttribute("iSOCurrency", DefaultValue=null)]
public string ISOCurrency { get; set; }
C++
[ConfigurationPropertyAttribute(L"iSOCurrency", DefaultValue=nullptr)]
public:
virtual property String^ ISOCurrency {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_ISOCurrency ()

/** @property */
public final void set_ISOCurrency (String value)
JScript
public final function get ISOCurrency () : String

public final function set ISOCurrency (value : String)

Property Value

The ISO curreny used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.Language Property
[image]

Gets or sets the language used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.Language

instance.Language = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("language", DefaultValue:=Nothing)> _
Public Property Language As String
C#
[ConfigurationPropertyAttribute("language", DefaultValue=null)]
public string Language { get; set; }
C++
[ConfigurationPropertyAttribute(L"language", DefaultValue=nullptr)]
public:
virtual property String^ Language {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_Language ()

/** @property */
public final void set_Language (String value)
JScript
public final function get Language () : String

public final function set Language (value : String)

Property Value

The language used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.LengthSemantics Property
[image]

Gets or sets the length semantics used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.LengthSemantics

instance.LengthSemantics = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("lengthSemantics", DefaultValue:=Nothing)> _
Public Property LengthSemantics As String
C#
[ConfigurationPropertyAttribute("lengthSemantics", DefaultValue=null)]
public string LengthSemantics { get; set; }
C++
[ConfigurationPropertyAttribute(L"lengthSemantics", DefaultValue=nullptr)]
public:
virtual property String^ LengthSemantics {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_LengthSemantics ()

/** @property */
public final void set_LengthSemantics (String value)
JScript
public final function get LengthSemantics () : String

public final function set LengthSemantics (value : String)

Property Value

the length semantics used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.NCharConversionException Property
[image]

Gets or sets whether the specified object is a national character conversion exception.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As Boolean

value = instance.NCharConversionException

instance.NCharConversionException = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("nCharConversionException", DefaultValue:=True)> _
Public Property NCharConversionException As Boolean
C#
[ConfigurationPropertyAttribute("nCharConversionException", DefaultValue=true)]
public bool NCharConversionException { get; set; }
C++
[ConfigurationPropertyAttribute(L"nCharConversionException", DefaultValue=true)]
public:
virtual property bool NCharConversionException {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_NCharConversionException ()

/** @property */
public final void set_NCharConversionException (boolean value)
JScript
public final function get NCharConversionException () : boolean

public final function set NCharConversionException (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the specified object is a national conversion exception; otherwise, <languageKeyword>false</languageKeyword>. The default value is <languageKeyword>true</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.NumericCharacters Property
[image]

Gets or sets the numeric characters used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.NumericCharacters

instance.NumericCharacters = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("numericCharacters", DefaultValue:=Nothing)> _
Public Property NumericCharacters As String
C#
[ConfigurationPropertyAttribute("numericCharacters", DefaultValue=null)]
public string NumericCharacters { get; set; }
C++
[ConfigurationPropertyAttribute(L"numericCharacters", DefaultValue=nullptr)]
public:
virtual property String^ NumericCharacters {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_NumericCharacters ()

/** @property */
public final void set_NumericCharacters (String value)
JScript
public final function get NumericCharacters () : String

public final function set NumericCharacters (value : String)

Property Value

The numeric characters used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.Properties Property
[image]

Gets the properties used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim value As ConfigurationPropertyCollection

value = Me.Properties

Syntax

Visual Basic
Protected Overrides ReadOnly Property Properties As ConfigurationPropertyCollection
C#
protected override ConfigurationPropertyCollection Properties { get; }
C++
protected:
virtual property ConfigurationPropertyCollection^ Properties {
    ConfigurationPropertyCollection^ get () override;
}
J#
/** @property */
protected ConfigurationPropertyCollection get_Properties ()
JScript
protected override function get Properties () : ConfigurationPropertyCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.Sort Property
[image]

Gets or sets the sort order used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.Sort

instance.Sort = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("sort", DefaultValue:=Nothing)> _
Public Property Sort As String
C#
[ConfigurationPropertyAttribute("sort", DefaultValue=null)]
public string Sort { get; set; }
C++
[ConfigurationPropertyAttribute(L"sort", DefaultValue=nullptr)]
public:
virtual property String^ Sort {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_Sort ()

/** @property */
public final void set_Sort (String value)
JScript
public final function get Sort () : String

public final function set Sort (value : String)

Property Value

The sort used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.Territory Property
[image]

Gets or sets the territory used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.Territory

instance.Territory = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("territory", DefaultValue:=Nothing)> _
Public Property Territory As String
C#
[ConfigurationPropertyAttribute("territory", DefaultValue=null)]
public string Territory { get; set; }
C++
[ConfigurationPropertyAttribute(L"territory", DefaultValue=nullptr)]
public:
virtual property String^ Territory {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_Territory ()

/** @property */
public final void set_Territory (String value)
JScript
public final function get Territory () : String

public final function set Territory (value : String)

Property Value

The territory used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.TimeStampFormat Property
[image]

Gets or sets the time stamp format used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.TimeStampFormat

instance.TimeStampFormat = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("timeStampFormat", DefaultValue:=Nothing)> _
Public Property TimeStampFormat As String
C#
[ConfigurationPropertyAttribute("timeStampFormat", DefaultValue=null)]
public string TimeStampFormat { get; set; }
C++
[ConfigurationPropertyAttribute(L"timeStampFormat", DefaultValue=nullptr)]
public:
virtual property String^ TimeStampFormat {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_TimeStampFormat ()

/** @property */
public final void set_TimeStampFormat (String value)
JScript
public final function get TimeStampFormat () : String

public final function set TimeStampFormat (value : String)

Property Value

The time stamp format used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.TimeStampTZFormat Property
[image]

Gets or sets the time stamp time zone format used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.TimeStampTZFormat

instance.TimeStampTZFormat = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("timeStampTZFormat", DefaultValue:=Nothing)> _
Public Property TimeStampTZFormat As String
C#
[ConfigurationPropertyAttribute("timeStampTZFormat", DefaultValue=null)]
public string TimeStampTZFormat { get; set; }
C++
[ConfigurationPropertyAttribute(L"timeStampTZFormat", DefaultValue=nullptr)]
public:
virtual property String^ TimeStampTZFormat {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_TimeStampTZFormat ()

/** @property */
public final void set_TimeStampTZFormat (String value)
JScript
public final function get TimeStampTZFormat () : String

public final function set TimeStampTZFormat (value : String)

Property Value

The time stamp time zone formta used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


MlsSettings.TimeZone Property
[image]

Gets or sets time zone used in the management license settings.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As MlsSettings
Dim value As String

value = instance.TimeZone

instance.TimeZone = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("timeZone", DefaultValue:=Nothing)> _
Public Property TimeZone As String
C#
[ConfigurationPropertyAttribute("timeZone", DefaultValue=null)]
public string TimeZone { get; set; }
C++
[ConfigurationPropertyAttribute(L"timeZone", DefaultValue=nullptr)]
public:
virtual property String^ TimeZone {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_TimeZone ()

/** @property */
public final void set_TimeZone (String value)
JScript
public final function get TimeZone () : String

public final function set TimeZone (value : String)

Property Value

The time zone used in the management license settings.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

MlsSettings Class
MlsSettings Members


OracleEBSAdapter Class
See Also Members
[image]

The Binding Element for the Oracle E-Business Suite Adapter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")> _
Public Class OracleEBSAdapter
    Inherits CommonAdapter
C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")]
public class OracleEBSAdapter : CommonAdapter
C++
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1705:LongAcronymsShouldBePascalCased")]
public ref class OracleEBSAdapter : public CommonAdapter
J#
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased") */
public class OracleEBSAdapter extends CommonAdapter
JScript
SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")
public class OracleEBSAdapter extends CommonAdapter

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.BindingElement
System.ServiceModel.Channels.TransportBindingElement
Microsoft.ServiceModel.Channels.Common.Adapter
Microsoft.Adapters.AdapterUtilities.CommonAdapter
Microsoft.Adapters.OracleEBS.OracleEBSAdapter

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Members


OracleEBSAdapter Members
See Also Constructors Methods Properties
[image]

The Binding Element for the Oracle E-Business Suite Adapter.

The following tables list the members exposed by the OracleEBSAdapter type.

Public Constructors

Name | Description
OracleEBSAdapter | Initializes a new instance of the OracleApps class
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets whether the connection URI can contain user credentials for the database.
public property | ApplicationShortName | Gets or sets the application short name.
public property | ClientCredentialType | Gets or sets the client credential type.
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | DataFetchSize | Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | EnableBizTalkCompatibilityMode | Gets or sets whether the BizTalk compatibility mode is enabled.
public property | EnablePerformanceCounters | Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets whether enables or disables safe typing.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the inbound operation type.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | ManualAddressing | (inherited from TransportBindingElement)
public property | MaxBufferPoolSize | (inherited from TransportBindingElement)
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in the connection pool.
public property | MaxReceivedMessageSize | (inherited from TransportBindingElement)
public property | MetadataPooling | Gets or sets whether data provider caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in the connection pool.
public property | MlsSettings | Gets or sets the Multiple Language System Settings configuration element.
public property | NotificationPort | Gets or sets the port number that must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets whether the specified object notifies on listener start.
public property | OracleConnectionClientId | Gets or sets the Oracle connection client identifier.
public property | OracleEBSOrganizationId | Gets or sets the Oracle EBS organization identifier.
public property | OracleEBSResponsibilityKey | Gets or sets the Oracle EBS responsibility key.
public property | OracleEBSResponsibilityName | Gets or sets the Oracle EBS responsibility name.
public property | OraclePassword | Gets or sets the Oracle password.
public property | OracleUserName | Gets or sets the Oracle user name.
public property | PolledDataAvailableStatement | Gets or sets the polled data available statement.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling input.
public property | PollingInterval | Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets whether the specified object continuously poll data when it is available.
public property | PostPollStatement | Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | Scheme | Overridden. Gets the scheme used in the adapter.
public property | SkipNilNodes | Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets whether the data provider statement cache associated with a connection is purged.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each data provider connection.
public property | TransactedReceiveEnabled | (inherited from Adapter)
public property | UseAmbientTransaction | Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets whether to use the Oracle connection pool.
public property | UserAssembliesLoadPath | Gets or sets the path where the assemblies will be loaded.
public property | UseSchemaInNameSpace | Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.
Top

Protected Properties

 | Name | Description
protected property | Namespace | Overridden. Gets the namespace used for the adapter.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | BuildChannelFactory | Overridden. (inherited from BindingElement)
public method | BuildChannelListener | Overridden. (inherited from BindingElement)
public method | CanBuildChannelFactory | Overridden. (inherited from BindingElement)
public method | CanBuildChannelListener | Overridden. (inherited from BindingElement)
public method | Clone | Overridden. (inherited from BindingElement)
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetProperty | Overridden. (inherited from BindingElement)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | BuildConnectionFactory | Overridden. Initializes a channel factory for producing channels of a specified type from the specified object.
protected method | BuildConnectionUri | Overridden. Builds the connection for the uniform resource identifier.
protected method | BuildWsdlRetrieval | Overridden. Builds an IWsdlRetrieval object.
protected method | CloneAdapter | Overridden. Returns a deep copy of the current Adapter object.
protected method | Finalize | (inherited from Object)
protected method | IsHandlerSupported | Overridden. Indicates whether the provided TConnectionHandler is supported by the current Adapter object.
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OracleEBSAdapter Class


OracleEBSAdapter Constructor
[image]

Initializes a new instance of the OracleApps class

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New OracleEBSAdapter

Syntax

Visual Basic
Public Sub New
C#
public OracleEBSAdapter ()
C++
public:
OracleEBSAdapter ()
J#
public OracleEBSAdapter ()
JScript
public function OracleEBSAdapter ()

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | BuildChannelFactory | Overridden. (inherited from BindingElement)
public method | BuildChannelListener | Overridden. (inherited from BindingElement)
public method | CanBuildChannelFactory | Overridden. (inherited from BindingElement)
public method | CanBuildChannelListener | Overridden. (inherited from BindingElement)
public method | Clone | Overridden. (inherited from BindingElement)
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetProperty | Overridden. (inherited from BindingElement)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | BuildConnectionFactory | Overridden. Initializes a channel factory for producing channels of a specified type from the specified object.
protected method | BuildConnectionUri | Overridden. Builds the connection for the uniform resource identifier.
protected method | BuildWsdlRetrieval | Overridden. Builds an IWsdlRetrieval object.
protected method | CloneAdapter | Overridden. Returns a deep copy of the current Adapter object.
protected method | Finalize | (inherited from Object)
protected method | IsHandlerSupported | Overridden. Indicates whether the provided TConnectionHandler is supported by the current Adapter object.
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OracleEBSAdapter Class


OracleEBSAdapter.BuildConnectionFactory Method
[image]

Initializes a channel factory for producing channels of a specified type from the specified object.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim connectionUri As ConnectionUri
Dim clientCredentials As ClientCredentials
Dim context As BindingContext
Dim returnValue As IConnectionFactory

returnValue = Me.BuildConnectionFactory(connectionUri, clientCredentials, context)

Syntax

Visual Basic
Protected Overrides Function BuildConnectionFactory ( _
    connectionUri As ConnectionUri, _
    clientCredentials As ClientCredentials, _
    context As BindingContext _
) As IConnectionFactory
C#
protected override IConnectionFactory BuildConnectionFactory (
    ConnectionUri connectionUri,
    ClientCredentials clientCredentials,
    BindingContext context
)
C++
protected:
virtual IConnectionFactory^ BuildConnectionFactory (
    ConnectionUri^ connectionUri,
    ClientCredentials^ clientCredentials,
    BindingContext^ context
) override
J#
protected IConnectionFactory BuildConnectionFactory (
    ConnectionUri connectionUri,
    ClientCredentials clientCredentials,
    BindingContext context
)
JScript
protected override function BuildConnectionFactory (
    connectionUri : ConnectionUri,
    clientCredentials : ClientCredentials,
    context : BindingContext
) : IConnectionFactory

Parameters

connectionUri

The connection for the unified resource identifier.

clientCredentials

The client credentials

context

The specified context.

Return Value

The channel factory.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.BuildConnectionUri Method
[image]

Builds the connection for the uniform resource identifier.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim uri As Uri
Dim returnValue As ConnectionUri

returnValue = Me.BuildConnectionUri(uri)

Syntax

Visual Basic
Protected Overrides Function BuildConnectionUri ( _
    uri As Uri _
) As ConnectionUri
C#
protected override ConnectionUri BuildConnectionUri (
    Uri uri
)
C++
protected:
virtual ConnectionUri^ BuildConnectionUri (
    Uri^ uri
) override
J#
protected ConnectionUri BuildConnectionUri (
    Uri uri
)
JScript
protected override function BuildConnectionUri (
    uri : Uri
) : ConnectionUri

Parameters

uri

The uniform resource identifier.

Return Value

The connection for the uniform resource identifier.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.BuildWsdlRetrieval Method
[image]

Builds an IWsdlRetrieval object.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim metadataLookup As MetadataLookup
Dim returnValue As IWsdlRetrieval

returnValue = Me.BuildWsdlRetrieval(metadataLookup)

Syntax

Visual Basic
Protected Overrides Function BuildWsdlRetrieval ( _
    metadataLookup As MetadataLookup _
) As IWsdlRetrieval
C#
protected override IWsdlRetrieval BuildWsdlRetrieval (
    MetadataLookup metadataLookup
)
C++
protected:
virtual IWsdlRetrieval^ BuildWsdlRetrieval (
    MetadataLookup^ metadataLookup
) override
J#
protected IWsdlRetrieval BuildWsdlRetrieval (
    MetadataLookup metadataLookup
)
JScript
protected override function BuildWsdlRetrieval (
    metadataLookup : MetadataLookup
) : IWsdlRetrieval

Parameters

metadataLookup

The specified MetadataLookup object.

Return Value

An IWsdlRetrieval object using the specified MetadataLookup object.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.CloneAdapter Method
[image]

Returns a deep copy of the current Adapter object.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim returnValue As Adapter

returnValue = Me.CloneAdapter

Syntax

Visual Basic
Protected Overrides Function CloneAdapter As Adapter
C#
protected override Adapter CloneAdapter ()
C++
protected:
virtual Adapter^ CloneAdapter () override
J#
protected Adapter CloneAdapter ()
JScript
protected override function CloneAdapter () : Adapter

Return Value

An Adapter object containing a deep copy of the current Adapter.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.IsHandlerSupported Method
[image]

Indicates whether the provided TConnectionHandler is supported by the current Adapter object.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim returnValue As Boolean

returnValue = Me.IsHandlerSupported

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Design", "CA1004:GenericMethodsShouldProvideTypeParameter")> _
Protected Overrides Function IsHandlerSupported(Of TConnectionHandler As IConnectionHandler) As Boolean
C#
[SuppressMessageAttribute("Microsoft.Design", "CA1004:GenericMethodsShouldProvideTypeParameter")]
protected override bool IsHandlerSupported<TConnectionHandler> () where TConnectionHandler : IConnectionHandler
C++
[SuppressMessageAttribute(L"Microsoft.Design", L"CA1004:GenericMethodsShouldProvideTypeParameter")]
protected:
generic<typename TConnectionHandler> where TConnectionHandler : IConnectionHandler
virtual bool IsHandlerSupported () override
J#
JScript

Return Value

<languageKeyword>True</languageKeyword> if the provided TConnectionHandler is supported by the current Adapter object; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets whether the connection URI can contain user credentials for the database.
public property | ApplicationShortName | Gets or sets the application short name.
public property | ClientCredentialType | Gets or sets the client credential type.
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | DataFetchSize | Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | EnableBizTalkCompatibilityMode | Gets or sets whether the BizTalk compatibility mode is enabled.
public property | EnablePerformanceCounters | Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets whether enables or disables safe typing.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the inbound operation type.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | ManualAddressing | (inherited from TransportBindingElement)
public property | MaxBufferPoolSize | (inherited from TransportBindingElement)
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in the connection pool.
public property | MaxReceivedMessageSize | (inherited from TransportBindingElement)
public property | MetadataPooling | Gets or sets whether data provider caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in the connection pool.
public property | MlsSettings | Gets or sets the Multiple Language System Settings configuration element.
public property | NotificationPort | Gets or sets the port number that must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets whether the specified object notifies on listener start.
public property | OracleConnectionClientId | Gets or sets the Oracle connection client identifier.
public property | OracleEBSOrganizationId | Gets or sets the Oracle EBS organization identifier.
public property | OracleEBSResponsibilityKey | Gets or sets the Oracle EBS responsibility key.
public property | OracleEBSResponsibilityName | Gets or sets the Oracle EBS responsibility name.
public property | OraclePassword | Gets or sets the Oracle password.
public property | OracleUserName | Gets or sets the Oracle user name.
public property | PolledDataAvailableStatement | Gets or sets the polled data available statement.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling input.
public property | PollingInterval | Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets whether the specified object continuously poll data when it is available.
public property | PostPollStatement | Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | Scheme | Overridden. Gets the scheme used in the adapter.
public property | SkipNilNodes | Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets whether the data provider statement cache associated with a connection is purged.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each data provider connection.
public property | TransactedReceiveEnabled | (inherited from Adapter)
public property | UseAmbientTransaction | Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets whether to use the Oracle connection pool.
public property | UserAssembliesLoadPath | Gets or sets the path where the assemblies will be loaded.
public property | UseSchemaInNameSpace | Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.

Protected Properties

 | Name | Description
protected property | Namespace | Overridden. Gets the namespace used for the adapter.

See Also

Reference

OracleEBSAdapter Class


OracleEBSAdapter.AcceptCredentialsInUri Property
[image]

Gets or sets whether the connection URI can contain user credentials for the database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.AcceptCredentialsInUri

instance.AcceptCredentialsInUri = value

Syntax

Visual Basic
Public Property AcceptCredentialsInUri As Boolean
C#
public bool AcceptCredentialsInUri { get; set; }
C++
public:
virtual property bool AcceptCredentialsInUri {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_AcceptCredentialsInUri ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_AcceptCredentialsInUri (boolean value)
JScript
CompilerGeneratedAttribute
public final function get AcceptCredentialsInUri () : boolean

CompilerGeneratedAttribute
public final function set AcceptCredentialsInUri (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if use the Oracle connection URI can contain user credentials for the Oracle database; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.ApplicationShortName Property
[image]

Gets or sets the application short name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.ApplicationShortName

instance.ApplicationShortName = value

Syntax

Visual Basic
Public Property ApplicationShortName As String
C#
public string ApplicationShortName { get; set; }
C++
public:
virtual property String^ ApplicationShortName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_ApplicationShortName ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_ApplicationShortName (String value)
JScript
CompilerGeneratedAttribute
public final function get ApplicationShortName () : String

CompilerGeneratedAttribute
public final function set ApplicationShortName (value : String)

Property Value

The application short name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.ClientCredentialType Property
[image]

Gets or sets the client credential type.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As ClientCredential

value = instance.ClientCredentialType

instance.ClientCredentialType = value

Syntax

Visual Basic
Public Property ClientCredentialType As ClientCredential
C#
public ClientCredential ClientCredentialType { get; set; }
C++
public:
virtual property ClientCredential ClientCredentialType {
    ClientCredential get () sealed;
    void set (ClientCredential value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final ClientCredential get_ClientCredentialType ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_ClientCredentialType (ClientCredential value)
JScript
CompilerGeneratedAttribute
public final function get ClientCredentialType () : ClientCredential

CompilerGeneratedAttribute
public final function set ClientCredentialType (value : ClientCredential)

Property Value

The client credential type.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.ConnectionLifetime Property
[image]

Gets or sets the maximum duration in seconds of a connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.ConnectionLifetime

instance.ConnectionLifetime = value

Syntax

Visual Basic
Public Property ConnectionLifetime As Integer
C#
public int ConnectionLifetime { get; set; }
C++
public:
virtual property int ConnectionLifetime {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_ConnectionLifetime ()

/** @property */
public final void set_ConnectionLifetime (int value)
JScript
public final function get ConnectionLifetime () : int

public final function set ConnectionLifetime (value : int)

Property Value

The maximum duration in seconds of a connection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.DataFetchSize Property
[image]

Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Long

value = instance.DataFetchSize

instance.DataFetchSize = value

Syntax

Visual Basic
Public Property DataFetchSize As Long
C#
public long DataFetchSize { get; set; }
C++
public:
virtual property long long DataFetchSize {
    long long get () sealed;
    void set (long long value) sealed;
}
J#
/** @property */
public final long get_DataFetchSize ()

/** @property */
public final void set_DataFetchSize (long value)
JScript
public final function get DataFetchSize () : long

public final function set DataFetchSize (value : long)

Property Value

The amount of data in bytes that data provider fetches from the result set in one server round trip.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.DecrPoolSize Property
[image]

Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.DecrPoolSize

instance.DecrPoolSize = value

Syntax

Visual Basic
Public Property DecrPoolSize As Integer
C#
public int DecrPoolSize { get; set; }
C++
public:
virtual property int DecrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_DecrPoolSize ()

/** @property */
public final void set_DecrPoolSize (int value)
JScript
public final function get DecrPoolSize () : int

public final function set DecrPoolSize (value : int)

Property Value

The number of connections that are closed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.EnableBizTalkCompatibilityMode Property
[image]

Gets or sets whether the BizTalk compatibility mode is enabled.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.EnableBizTalkCompatibilityMode

instance.EnableBizTalkCompatibilityMode = value

Syntax

Visual Basic
Public Property EnableBizTalkCompatibilityMode As Boolean
C#
public bool EnableBizTalkCompatibilityMode { get; set; }
C++
public:
virtual property bool EnableBizTalkCompatibilityMode {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnableBizTalkCompatibilityMode ()

/** @property */
public final void set_EnableBizTalkCompatibilityMode (boolean value)
JScript
public final function get EnableBizTalkCompatibilityMode () : boolean

public final function set EnableBizTalkCompatibilityMode (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the BizTalk compatibility mode is enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.EnablePerformanceCounters Property
[image]

Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.EnablePerformanceCounters

instance.EnablePerformanceCounters = value

Syntax

Visual Basic
Public Property EnablePerformanceCounters As Boolean
C#
public bool EnablePerformanceCounters { get; set; }
C++
public:
virtual property bool EnablePerformanceCounters {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnablePerformanceCounters ()

/** @property */
public final void set_EnablePerformanceCounters (boolean value)
JScript
public final function get EnablePerformanceCounters () : boolean

public final function set EnablePerformanceCounters (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counteris enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.EnableSafeTyping Property
[image]

Gets or sets whether enables or disables safe typing.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.EnableSafeTyping

instance.EnableSafeTyping = value

Syntax

Visual Basic
Public Property EnableSafeTyping As Boolean
C#
public bool EnableSafeTyping { get; set; }
C++
public:
virtual property bool EnableSafeTyping {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnableSafeTyping ()

/** @property */
public final void set_EnableSafeTyping (boolean value)
JScript
public final function get EnableSafeTyping () : boolean

public final function set EnableSafeTyping (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if safe typing is enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.GeneratedUserTypesAssemblyFilePath Property
[image]

Gets or sets the name and path of the DLL that the adapter generates.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.GeneratedUserTypesAssemblyFilePath

instance.GeneratedUserTypesAssemblyFilePath = value

Syntax

Visual Basic
Public Property GeneratedUserTypesAssemblyFilePath As String
C#
public string GeneratedUserTypesAssemblyFilePath { get; set; }
C++
public:
virtual property String^ GeneratedUserTypesAssemblyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_GeneratedUserTypesAssemblyFilePath ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_GeneratedUserTypesAssemblyFilePath (String value)
JScript
CompilerGeneratedAttribute
public final function get GeneratedUserTypesAssemblyFilePath () : String

CompilerGeneratedAttribute
public final function set GeneratedUserTypesAssemblyFilePath (value : String)

Property Value

The name and path of the DLL that the adapter generates.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.GeneratedUserTypesAssemblyKeyFilePath Property
[image]

Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.GeneratedUserTypesAssemblyKeyFilePath

instance.GeneratedUserTypesAssemblyKeyFilePath = value

Syntax

Visual Basic
Public Property GeneratedUserTypesAssemblyKeyFilePath As String
C#
public string GeneratedUserTypesAssemblyKeyFilePath { get; set; }
C++
public:
virtual property String^ GeneratedUserTypesAssemblyKeyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_GeneratedUserTypesAssemblyKeyFilePath ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_GeneratedUserTypesAssemblyKeyFilePath (String value)
JScript
CompilerGeneratedAttribute
public final function get GeneratedUserTypesAssemblyKeyFilePath () : String

CompilerGeneratedAttribute
public final function set GeneratedUserTypesAssemblyKeyFilePath (value : String)

Property Value

The name and path of the key file that the adapter uses to create a strongly-typed assembly

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.InboundOperationType Property
[image]

Gets or sets the inbound operation type.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As InboundOperation

value = instance.InboundOperationType

instance.InboundOperationType = value

Syntax

Visual Basic
Public Property InboundOperationType As InboundOperation
C#
public InboundOperation InboundOperationType { get; set; }
C++
public:
virtual property InboundOperation InboundOperationType {
    InboundOperation get () sealed;
    void set (InboundOperation value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final InboundOperation get_InboundOperationType ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_InboundOperationType (InboundOperation value)
JScript
CompilerGeneratedAttribute
public final function get InboundOperationType () : InboundOperation

CompilerGeneratedAttribute
public final function set InboundOperationType (value : InboundOperation)

Property Value

The polling or Notification inbound operation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.IncrPoolSize Property
[image]

Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.IncrPoolSize

instance.IncrPoolSize = value

Syntax

Visual Basic
Public Property IncrPoolSize As Integer
C#
public int IncrPoolSize { get; set; }
C++
public:
virtual property int IncrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_IncrPoolSize ()

/** @property */
public final void set_IncrPoolSize (int value)
JScript
public final function get IncrPoolSize () : int

public final function set IncrPoolSize (value : int)

Property Value

The number of new connections.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.InsertBatchSize Property
[image]

Gets or sets the batch size for multiple record Insert operations.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.InsertBatchSize

instance.InsertBatchSize = value

Syntax

Visual Basic
Public Property InsertBatchSize As Integer
C#
public int InsertBatchSize { get; set; }
C++
public:
virtual property int InsertBatchSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_InsertBatchSize ()

/** @property */
public final void set_InsertBatchSize (int value)
JScript
public final function get InsertBatchSize () : int

public final function set InsertBatchSize (value : int)

Property Value

The batch size for multiple record Insert operations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.LongDatatypeColumnSize Property
[image]

Gets or sets the maximum size in bytes of an Oracle long data type column.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.LongDatatypeColumnSize

instance.LongDatatypeColumnSize = value

Syntax

Visual Basic
<ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")> _
Public Property LongDatatypeColumnSize As Integer
C#
[ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
public int LongDatatypeColumnSize { get; set; }
C++
[ObsoleteAttribute(L"Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
public:
virtual property int LongDatatypeColumnSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_LongDatatypeColumnSize ()

/** @property */
public final void set_LongDatatypeColumnSize (int value)
JScript
public final function get LongDatatypeColumnSize () : int

public final function set LongDatatypeColumnSize (value : int)

Property Value

The maximum size in bytes of an Oracle long data type column.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.MaxOutputAssociativeArrayElements Property
[image]

Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.MaxOutputAssociativeArrayElements

instance.MaxOutputAssociativeArrayElements = value

Syntax

Visual Basic
Public Property MaxOutputAssociativeArrayElements As Integer
C#
public int MaxOutputAssociativeArrayElements { get; set; }
C++
public:
virtual property int MaxOutputAssociativeArrayElements {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxOutputAssociativeArrayElements ()

/** @property */
public final void set_MaxOutputAssociativeArrayElements (int value)
JScript
public final function get MaxOutputAssociativeArrayElements () : int

public final function set MaxOutputAssociativeArrayElements (value : int)

Property Value

The size of the associate array that the adapter creates when performing operations that return an associative array in the response.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.MaxPoolSize Property
[image]

Gets or sets the maximum number of connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.MaxPoolSize

instance.MaxPoolSize = value

Syntax

Visual Basic
Public Property MaxPoolSize As Integer
C#
public int MaxPoolSize { get; set; }
C++
public:
virtual property int MaxPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxPoolSize ()

/** @property */
public final void set_MaxPoolSize (int value)
JScript
public final function get MaxPoolSize () : int

public final function set MaxPoolSize (value : int)

Property Value

The maximum number of connections in the connection pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.MetadataPooling Property
[image]

Gets or sets whether data provider caches metadata information for executed queries.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.MetadataPooling

instance.MetadataPooling = value

Syntax

Visual Basic
Public Property MetadataPooling As Boolean
C#
public bool MetadataPooling { get; set; }
C++
public:
virtual property bool MetadataPooling {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_MetadataPooling ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_MetadataPooling (boolean value)
JScript
CompilerGeneratedAttribute
public final function get MetadataPooling () : boolean

CompilerGeneratedAttribute
public final function set MetadataPooling (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the data provider caches metadata information for executed queries; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.MinPoolSize Property
[image]

Gets or sets the minimum number of connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.MinPoolSize

instance.MinPoolSize = value

Syntax

Visual Basic
Public Property MinPoolSize As Integer
C#
public int MinPoolSize { get; set; }
C++
public:
virtual property int MinPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MinPoolSize ()

/** @property */
public final void set_MinPoolSize (int value)
JScript
public final function get MinPoolSize () : int

public final function set MinPoolSize (value : int)

Property Value

The minimum number of connections in the connection pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.MlsSettings Property
[image]

Gets or sets the Multiple Language System Settings configuration element.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As MlsSettings

value = instance.MlsSettings

instance.MlsSettings = value

Syntax

Visual Basic
Public Property MlsSettings As MlsSettings
C#
public MlsSettings MlsSettings { get; set; }
C++
public:
virtual property MlsSettings^ MlsSettings {
    MlsSettings^ get () sealed;
    void set (MlsSettings^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final MlsSettings get_MlsSettings ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_MlsSettings (MlsSettings value)
JScript
CompilerGeneratedAttribute
public final function get MlsSettings () : MlsSettings

CompilerGeneratedAttribute
public final function set MlsSettings (value : MlsSettings)

Property Value

The Multiple Language System Settings configuration element.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.Namespace Property
[image]

Gets the namespace used for the adapter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim value As String

value = Me.Namespace

Syntax

Visual Basic
Protected Overrides ReadOnly Property Namespace As String
C#
protected override string Namespace { get; }
C++
protected:
virtual property String^ Namespace {
    String^ get () override;
}
J#
/** @property */
protected String get_Namespace ()
JScript
protected override function get Namespace () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.NotificationPort Property
[image]

Gets or sets the port number that must open to listen for database change notification from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.NotificationPort

instance.NotificationPort = value

Syntax

Visual Basic
Public Property NotificationPort As Integer
C#
public int NotificationPort { get; set; }
C++
public:
virtual property int NotificationPort {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_NotificationPort ()

/** @property */
public final void set_NotificationPort (int value)
JScript
public final function get NotificationPort () : int

public final function set NotificationPort (value : int)

Property Value

The port number that must open to listen for database change notification from Oracle database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.NotificationStatement Property
[image]

Gets or sets the SELECT statement used to register for getting notifications from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.NotificationStatement

instance.NotificationStatement = value

Syntax

Visual Basic
Public Property NotificationStatement As String
C#
public string NotificationStatement { get; set; }
C++
public:
virtual property String^ NotificationStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_NotificationStatement ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_NotificationStatement (String value)
JScript
CompilerGeneratedAttribute
public final function get NotificationStatement () : String

CompilerGeneratedAttribute
public final function set NotificationStatement (value : String)

Property Value

The SELECT statement used to register for getting notifications from Oracle database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.NotifyOnListenerStart Property
[image]

Gets or sets whether the specified object notifies on listener start.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.NotifyOnListenerStart

instance.NotifyOnListenerStart = value

Syntax

Visual Basic
Public Property NotifyOnListenerStart As Boolean
C#
public bool NotifyOnListenerStart { get; set; }
C++
public:
virtual property bool NotifyOnListenerStart {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_NotifyOnListenerStart ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_NotifyOnListenerStart (boolean value)
JScript
CompilerGeneratedAttribute
public final function get NotifyOnListenerStart () : boolean

CompilerGeneratedAttribute
public final function set NotifyOnListenerStart (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> the specified object notifies on listener start; otherwise, <languageKeyword>False</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.OracleConnectionClientId Property
[image]

Gets or sets the Oracle connection client identifier.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.OracleConnectionClientId

instance.OracleConnectionClientId = value

Syntax

Visual Basic
Public Property OracleConnectionClientId As String
C#
public string OracleConnectionClientId { get; set; }
C++
public:
virtual property String^ OracleConnectionClientId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleConnectionClientId ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleConnectionClientId (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleConnectionClientId () : String

CompilerGeneratedAttribute
public final function set OracleConnectionClientId (value : String)

Property Value

The Oracle connection client identifier.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.OracleEBSOrganizationId Property
[image]

Gets or sets the Oracle EBS organization identifier.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.OracleEBSOrganizationId

instance.OracleEBSOrganizationId = value

Syntax

Visual Basic
Public Property OracleEBSOrganizationId As String
C#
public string OracleEBSOrganizationId { get; set; }
C++
public:
virtual property String^ OracleEBSOrganizationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleEBSOrganizationId ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleEBSOrganizationId (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleEBSOrganizationId () : String

CompilerGeneratedAttribute
public final function set OracleEBSOrganizationId (value : String)

Property Value

The Oracle EBS organization identifier.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.OracleEBSResponsibilityKey Property
[image]

Gets or sets the Oracle EBS responsibility key.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.OracleEBSResponsibilityKey

instance.OracleEBSResponsibilityKey = value

Syntax

Visual Basic
Public Property OracleEBSResponsibilityKey As String
C#
public string OracleEBSResponsibilityKey { get; set; }
C++
public:
virtual property String^ OracleEBSResponsibilityKey {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleEBSResponsibilityKey ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleEBSResponsibilityKey (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleEBSResponsibilityKey () : String

CompilerGeneratedAttribute
public final function set OracleEBSResponsibilityKey (value : String)

Property Value

The Oracle EBS responsibility key.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.OracleEBSResponsibilityName Property
[image]

Gets or sets the Oracle EBS responsibility name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.OracleEBSResponsibilityName

instance.OracleEBSResponsibilityName = value

Syntax

Visual Basic
Public Property OracleEBSResponsibilityName As String
C#
public string OracleEBSResponsibilityName { get; set; }
C++
public:
virtual property String^ OracleEBSResponsibilityName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleEBSResponsibilityName ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleEBSResponsibilityName (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleEBSResponsibilityName () : String

CompilerGeneratedAttribute
public final function set OracleEBSResponsibilityName (value : String)

Property Value

The Oracle EBS responsibility name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.OraclePassword Property
[image]

Gets or sets the Oracle password.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.OraclePassword

instance.OraclePassword = value

Syntax

Visual Basic
Public Property OraclePassword As String
C#
public string OraclePassword { get; set; }
C++
public:
virtual property String^ OraclePassword {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OraclePassword ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OraclePassword (String value)
JScript
CompilerGeneratedAttribute
public final function get OraclePassword () : String

CompilerGeneratedAttribute
public final function set OraclePassword (value : String)

Property Value

The Oracle password.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.OracleUserName Property
[image]

Gets or sets the Oracle user name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.OracleUserName

instance.OracleUserName = value

Syntax

Visual Basic
Public Property OracleUserName As String
C#
public string OracleUserName { get; set; }
C++
public:
virtual property String^ OracleUserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleUserName ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleUserName (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleUserName () : String

CompilerGeneratedAttribute
public final function set OracleUserName (value : String)

Property Value

The Oracle user name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.PolledDataAvailableStatement Property
[image]

Gets or sets the polled data available statement.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.PolledDataAvailableStatement

instance.PolledDataAvailableStatement = value

Syntax

Visual Basic
Public Property PolledDataAvailableStatement As String
C#
public string PolledDataAvailableStatement { get; set; }
C++
public:
virtual property String^ PolledDataAvailableStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PolledDataAvailableStatement ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PolledDataAvailableStatement (String value)
JScript
CompilerGeneratedAttribute
public final function get PolledDataAvailableStatement () : String

CompilerGeneratedAttribute
public final function set PolledDataAvailableStatement (value : String)

Property Value

The polled data available statement.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.PollingAction Property
[image]

Gets or sets the action for the polling operation.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.PollingAction

instance.PollingAction = value

Syntax

Visual Basic
Public Property PollingAction As String
C#
public string PollingAction { get; set; }
C++
public:
virtual property String^ PollingAction {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PollingAction ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PollingAction (String value)
JScript
CompilerGeneratedAttribute
public final function get PollingAction () : String

CompilerGeneratedAttribute
public final function set PollingAction (value : String)

Property Value

The action for the polling operation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.PollingInput Property
[image]

Gets or sets the polling input.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.PollingInput

instance.PollingInput = value

Syntax

Visual Basic
Public Property PollingInput As String
C#
public string PollingInput { get; set; }
C++
public:
virtual property String^ PollingInput {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PollingInput ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PollingInput (String value)
JScript
CompilerGeneratedAttribute
public final function get PollingInput () : String

CompilerGeneratedAttribute
public final function set PollingInput (value : String)

Property Value

The polling input.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.PollingInterval Property
[image]

Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.PollingInterval

instance.PollingInterval = value

Syntax

Visual Basic
Public Property PollingInterval As Integer
C#
public int PollingInterval { get; set; }
C++
public:
virtual property int PollingInterval {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_PollingInterval ()

/** @property */
public final void set_PollingInterval (int value)
JScript
public final function get PollingInterval () : int

public final function set PollingInterval (value : int)

Property Value

The transacted polling interval.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.PollWhileDataFound Property
[image]

Gets or sets whether the specified object continuously poll data when it is available.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.PollWhileDataFound

instance.PollWhileDataFound = value

Syntax

Visual Basic
Public Property PollWhileDataFound As Boolean
C#
public bool PollWhileDataFound { get; set; }
C++
public:
virtual property bool PollWhileDataFound {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_PollWhileDataFound ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PollWhileDataFound (boolean value)
JScript
CompilerGeneratedAttribute
public final function get PollWhileDataFound () : boolean

CompilerGeneratedAttribute
public final function set PollWhileDataFound (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the specified object continously poll data when it is available; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.PostPollStatement Property
[image]

Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.PostPollStatement

instance.PostPollStatement = value

Syntax

Visual Basic
Public Property PostPollStatement As String
C#
public string PostPollStatement { get; set; }
C++
public:
virtual property String^ PostPollStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PostPollStatement ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PostPollStatement (String value)
JScript
CompilerGeneratedAttribute
public final function get PostPollStatement () : String

CompilerGeneratedAttribute
public final function set PostPollStatement (value : String)

Property Value

The PL/SQL block that is executed after the polling statement

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.Scheme Property
[image]

Gets the scheme used in the adapter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.Scheme

Syntax

Visual Basic
Public Overrides ReadOnly Property Scheme As String
C#
public override string Scheme { get; }
C++
public:
virtual property String^ Scheme {
    String^ get () override;
}
J#
/** @property */
public String get_Scheme ()
JScript
public override function get Scheme () : String

Property Value

The scheme used in the adapter.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.SkipNilNodes Property
[image]

Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.SkipNilNodes

instance.SkipNilNodes = value

Syntax

Visual Basic
Public Property SkipNilNodes As Boolean
C#
public bool SkipNilNodes { get; set; }
C++
public:
virtual property bool SkipNilNodes {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_SkipNilNodes ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_SkipNilNodes (boolean value)
JScript
CompilerGeneratedAttribute
public final function get SkipNilNodes () : boolean

CompilerGeneratedAttribute
public final function set SkipNilNodes (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the nil node is skipped; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.StatementCachePurge Property
[image]

Gets or sets whether the data provider statement cache associated with a connection is purged.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.StatementCachePurge

instance.StatementCachePurge = value

Syntax

Visual Basic
Public Property StatementCachePurge As Boolean
C#
public bool StatementCachePurge { get; set; }
C++
public:
virtual property bool StatementCachePurge {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_StatementCachePurge ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_StatementCachePurge (boolean value)
JScript
CompilerGeneratedAttribute
public final function get StatementCachePurge () : boolean

CompilerGeneratedAttribute
public final function set StatementCachePurge (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the statement cache purge is specified; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.StatementCacheSize Property
[image]

Gets or sets the maximum number of statements that can be cached by each data provider connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Integer

value = instance.StatementCacheSize

instance.StatementCacheSize = value

Syntax

Visual Basic
Public Property StatementCacheSize As Integer
C#
public int StatementCacheSize { get; set; }
C++
public:
virtual property int StatementCacheSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_StatementCacheSize ()

/** @property */
public final void set_StatementCacheSize (int value)
JScript
public final function get StatementCacheSize () : int

public final function set StatementCacheSize (value : int)

Property Value

The maximum number of statements that can be cached by each data provider connection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.UseAmbientTransaction Property
[image]

Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.UseAmbientTransaction

instance.UseAmbientTransaction = value

Syntax

Visual Basic
Public Property UseAmbientTransaction As Boolean
C#
public bool UseAmbientTransaction { get; set; }
C++
public:
virtual property bool UseAmbientTransaction {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_UseAmbientTransaction ()

/** @property */
public final void set_UseAmbientTransaction (boolean value)
JScript
public final function get UseAmbientTransaction () : boolean

public final function set UseAmbientTransaction (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the Oracle Database adapter performs the operations using the transaction context provided by the caller; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.UseOracleConnectionPool Property
[image]

Gets or sets whether to use the Oracle connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.UseOracleConnectionPool

instance.UseOracleConnectionPool = value

Syntax

Visual Basic
Public Property UseOracleConnectionPool As Boolean
C#
public bool UseOracleConnectionPool { get; set; }
C++
public:
virtual property bool UseOracleConnectionPool {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_UseOracleConnectionPool ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_UseOracleConnectionPool (boolean value)
JScript
CompilerGeneratedAttribute
public final function get UseOracleConnectionPool () : boolean

CompilerGeneratedAttribute
public final function set UseOracleConnectionPool (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if use the Oracle connection pool; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.UserAssembliesLoadPath Property
[image]

Gets or sets the path where the assemblies will be loaded.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As String

value = instance.UserAssembliesLoadPath

instance.UserAssembliesLoadPath = value

Syntax

Visual Basic
Public Property UserAssembliesLoadPath As String
C#
public string UserAssembliesLoadPath { get; set; }
C++
public:
virtual property String^ UserAssembliesLoadPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_UserAssembliesLoadPath ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_UserAssembliesLoadPath (String value)
JScript
CompilerGeneratedAttribute
public final function get UserAssembliesLoadPath () : String

CompilerGeneratedAttribute
public final function set UserAssembliesLoadPath (value : String)

Property Value

The path where the assemblies will be loaded.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSAdapter.UseSchemaInNameSpace Property
[image]

Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSAdapter
Dim value As Boolean

value = instance.UseSchemaInNameSpace

instance.UseSchemaInNameSpace = value

Syntax

Visual Basic
Public Property UseSchemaInNameSpace As Boolean
C#
public bool UseSchemaInNameSpace { get; set; }
C++
public:
virtual property bool UseSchemaInNameSpace {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_UseSchemaInNameSpace ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_UseSchemaInNameSpace (boolean value)
JScript
CompilerGeneratedAttribute
public final function get UseSchemaInNameSpace () : boolean

CompilerGeneratedAttribute
public final function set UseSchemaInNameSpace (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the schema name is included in the xml namespace for operations and their associated types; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSAdapter Class
OracleEBSAdapter Members


OracleEBSBinding Class
See Also Members
[image]

Represents the Oracle E-Business Suite WCF Binding.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")> _
Public Class OracleEBSBinding
    Inherits AdapterBinding
C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")]
public class OracleEBSBinding : AdapterBinding
C++
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1705:LongAcronymsShouldBePascalCased")]
public ref class OracleEBSBinding : public AdapterBinding
J#
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased") */
public class OracleEBSBinding extends AdapterBinding
JScript
SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")
public class OracleEBSBinding extends AdapterBinding

Inheritance Hierarchy

System.Object
System.ServiceModel.Channels.Binding
Microsoft.ServiceModel.Channels.Common.AdapterBinding
Microsoft.Adapters.OracleEBS.OracleEBSBinding

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Members


OracleEBSBinding Members
See Also Constructors Methods Properties
[image]

Represents the Oracle E-Business Suite WCF Binding.

The following tables list the members exposed by the OracleEBSBinding type.

Public Constructors

Name | Description
OracleEBSBinding | Overloaded. Initializes a new instance of the OracleEBSBinding class.
Top

Public Properties

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets whether the connection URI can contain user credentials for the database.
public property | ApplicationShortName | Gets or sets the application short name.
public property | AssuresOrderedDelivery | (inherited from AdapterBinding)
public property | ClientCredentialType | Gets or sets the client credential type.
public property | CloseTimeout | (inherited from Binding)
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | ConnectionUriType | Overridden. Gets the type of the specific ConnectionUri.
public property | DataFetchSize | Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | DefaultXsdFileNamePrefix | (inherited from AdapterBinding)
public property | EnableBizTalkCompatibilityMode | Gets or sets whether the BizTalk compatibility mode is enabled.
public property | EnablePerformanceCounters | Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets whether enables or disables safe typing.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the inbound operation type.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in the connection pool.
public property | MessageVersion | (inherited from Binding)
public property | MetadataPooling | Gets or sets whether data provider caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in the connection pool.
public property | MlsSettings | Gets or sets the Multiple Language System Settings configuration element.
public property | Name | (inherited from Binding)
public property | Namespace | (inherited from Binding)
public property | NotificationPort | Gets or sets the port number that must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.
public property | OpenTimeout | (inherited from Binding)
public property | OracleConnectionClientId | Gets or sets the Oracle connection client identifier.
public property | OracleEBSOrganizationId | Gets or sets the Oracle EBS organization identifier.
public property | OracleEBSResponsibilityKey | Gets or sets the Oracle EBS responsibility key.
public property | OracleEBSResponsibilityName | Gets or sets the Oracle EBS responsibility name.
public property | OraclePassword | Gets or sets the Oracle password.
public property | OracleUserName | Gets or sets the Oracle user name.
public property | PolledDataAvailableStatement | Gets or sets the polled data available statement.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling input.
public property | PollingInterval | Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets whether the specified object continuously poll data when it is available.
public property | PostPollStatement | Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | QueuedDelivery | (inherited from AdapterBinding)
public property | ReceiveTimeout | (inherited from Binding)
public property | Scheme | Overridden. Gets the scheme of the binding.
public property | SendTimeout | (inherited from Binding)
public property | SkipNilNodes | Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets whether the data provider statement cache associated when a connection is purged.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each data provider connection.
public property | SupportsCertificateAuthentication | (inherited from AdapterBinding)
public property | SupportsMetadataBrowse | Overridden. Gets a value that indicates whether the binding supports metadata browsing.
public property | SupportsMetadataGet | Overridden. Gets a value that indicates whether the binding supports metadata retrieval.
public property | SupportsMetadataSearch | Overridden. Gets a value that indicates whether the binding supports metadata search.
public property | SupportsUserNameAuthentication | (inherited from AdapterBinding)
public property | SupportsWindowsAuthentication | (inherited from AdapterBinding)
public property | UseAmbientTransaction | Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets whether to use the Oracle connection pool.
public property | UserAssembliesLoadPath | Gets or sets the path where the assemblies will be loaded.
public property | UseSchemaInNameSpace | Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CreateBindingElements | Overridden. Creates a clone of the existing BindingElement and returns it.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetProperty | (inherited from Binding)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OracleEBSBinding Class


OracleEBSBinding Constructor
[image]

Initializes a new instance of the OracleEBSBinding class.

Overload List

Name | Description
OracleEBSBinding () | Initializes a new instance of the OracleEBSBinding class.
OracleEBSBinding (String) | Initializes a new instance of the OracleEBSBinding class with a configuration name.

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding Constructor ()
[image]

Initializes a new instance of the OracleEBSBinding class.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New OracleEBSBinding

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Usage", "CA1806:DoNotIgnoreMethodResults", MessageId:="Microsoft.Adapters.OracleEBS.OracleEBSAdapter")> _
Public Sub New
C#
[SuppressMessageAttribute("Microsoft.Usage", "CA1806:DoNotIgnoreMethodResults", MessageId="Microsoft.Adapters.OracleEBS.OracleEBSAdapter")]
public OracleEBSBinding ()
C++
[SuppressMessageAttribute(L"Microsoft.Usage", L"CA1806:DoNotIgnoreMethodResults", MessageId=L"Microsoft.Adapters.OracleEBS.OracleEBSAdapter")]
public:
OracleEBSBinding ()
J#
/** @attribute SuppressMessageAttribute("Microsoft.Usage", "CA1806:DoNotIgnoreMethodResults", MessageId="Microsoft.Adapters.OracleEBS.OracleEBSAdapter") */
public OracleEBSBinding ()
JScript
SuppressMessageAttribute("Microsoft.Usage", "CA1806:DoNotIgnoreMethodResults", MessageId="Microsoft.Adapters.OracleEBS.OracleEBSAdapter")
public function OracleEBSBinding ()

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding Constructor (String)
[image]

Initializes a new instance of the OracleEBSBinding class with a configuration name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim configName As String

Dim instance As New OracleEBSBinding(configName)

Syntax

Visual Basic
Public Sub New ( _
    configName As String _
)
C#
public OracleEBSBinding (
    string configName
)
C++
public:
OracleEBSBinding (
    String^ configName
)
J#
public OracleEBSBinding (
    String configName
)
JScript
public function OracleEBSBinding (
    configName : String
)

Parameters

configName

The name of the configuration.

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelFactory | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | BuildChannelListener | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelFactory | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CanBuildChannelListener | (inherited from Binding)
public method | CreateBindingElements | Overridden. Creates a clone of the existing BindingElement and returns it.
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetProperty | (inherited from Binding)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OracleEBSBinding Class


OracleEBSBinding.CreateBindingElements Method
[image]

Creates a clone of the existing BindingElement and returns it.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim returnValue As BindingElementCollection

returnValue = instance.CreateBindingElements

Syntax

Visual Basic
Public Overrides Function CreateBindingElements As BindingElementCollection
C#
public override BindingElementCollection CreateBindingElements ()
C++
public:
virtual BindingElementCollection^ CreateBindingElements () override
J#
public BindingElementCollection CreateBindingElements ()
JScript
public override function CreateBindingElements () : BindingElementCollection

Return Value

The collection that contains the binding elements.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding Properties
[image]

Public Properties

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets whether the connection URI can contain user credentials for the database.
public property | ApplicationShortName | Gets or sets the application short name.
public property | AssuresOrderedDelivery | (inherited from AdapterBinding)
public property | ClientCredentialType | Gets or sets the client credential type.
public property | CloseTimeout | (inherited from Binding)
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | ConnectionUriType | Overridden. Gets the type of the specific ConnectionUri.
public property | DataFetchSize | Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | DefaultXsdFileNamePrefix | (inherited from AdapterBinding)
public property | EnableBizTalkCompatibilityMode | Gets or sets whether the BizTalk compatibility mode is enabled.
public property | EnablePerformanceCounters | Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets whether enables or disables safe typing.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the inbound operation type.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in the connection pool.
public property | MessageVersion | (inherited from Binding)
public property | MetadataPooling | Gets or sets whether data provider caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in the connection pool.
public property | MlsSettings | Gets or sets the Multiple Language System Settings configuration element.
public property | Name | (inherited from Binding)
public property | Namespace | (inherited from Binding)
public property | NotificationPort | Gets or sets the port number that must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.
public property | OpenTimeout | (inherited from Binding)
public property | OracleConnectionClientId | Gets or sets the Oracle connection client identifier.
public property | OracleEBSOrganizationId | Gets or sets the Oracle EBS organization identifier.
public property | OracleEBSResponsibilityKey | Gets or sets the Oracle EBS responsibility key.
public property | OracleEBSResponsibilityName | Gets or sets the Oracle EBS responsibility name.
public property | OraclePassword | Gets or sets the Oracle password.
public property | OracleUserName | Gets or sets the Oracle user name.
public property | PolledDataAvailableStatement | Gets or sets the polled data available statement.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling input.
public property | PollingInterval | Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets whether the specified object continuously poll data when it is available.
public property | PostPollStatement | Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | QueuedDelivery | (inherited from AdapterBinding)
public property | ReceiveTimeout | (inherited from Binding)
public property | Scheme | Overridden. Gets the scheme of the binding.
public property | SendTimeout | (inherited from Binding)
public property | SkipNilNodes | Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets whether the data provider statement cache associated when a connection is purged.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each data provider connection.
public property | SupportsCertificateAuthentication | (inherited from AdapterBinding)
public property | SupportsMetadataBrowse | Overridden. Gets a value that indicates whether the binding supports metadata browsing.
public property | SupportsMetadataGet | Overridden. Gets a value that indicates whether the binding supports metadata retrieval.
public property | SupportsMetadataSearch | Overridden. Gets a value that indicates whether the binding supports metadata search.
public property | SupportsUserNameAuthentication | (inherited from AdapterBinding)
public property | SupportsWindowsAuthentication | (inherited from AdapterBinding)
public property | UseAmbientTransaction | Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets whether to use the Oracle connection pool.
public property | UserAssembliesLoadPath | Gets or sets the path where the assemblies will be loaded.
public property | UseSchemaInNameSpace | Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.

See Also

Reference

OracleEBSBinding Class


OracleEBSBinding.AcceptCredentialsInUri Property
[image]

Gets or sets whether the connection URI can contain user credentials for the database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.AcceptCredentialsInUri

instance.AcceptCredentialsInUri = value

Syntax

Visual Basic
<CategoryAttribute("Security")> _
<BrowsableAttribute(True)> _
Public Property AcceptCredentialsInUri As Boolean
C#
[CategoryAttribute("Security")]
[BrowsableAttribute(true)]
public bool AcceptCredentialsInUri { get; set; }
C++
[CategoryAttribute(L"Security")]
[BrowsableAttribute(true)]
public:
virtual property bool AcceptCredentialsInUri {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_AcceptCredentialsInUri ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_AcceptCredentialsInUri (boolean value)
JScript
CompilerGeneratedAttribute
public final function get AcceptCredentialsInUri () : boolean

CompilerGeneratedAttribute
public final function set AcceptCredentialsInUri (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if use the Oracle connection URI can contain user credentials for the Oracle database; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.ApplicationShortName Property
[image]

Gets or sets the application short name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.ApplicationShortName

instance.ApplicationShortName = value

Syntax

Visual Basic
<CategoryAttribute("OracleEBS")> _
<BrowsableAttribute(True)> _
Public Property ApplicationShortName As String
C#
[CategoryAttribute("OracleEBS")]
[BrowsableAttribute(true)]
public string ApplicationShortName { get; set; }
C++
[CategoryAttribute(L"OracleEBS")]
[BrowsableAttribute(true)]
public:
virtual property String^ ApplicationShortName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_ApplicationShortName ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_ApplicationShortName (String value)
JScript
CompilerGeneratedAttribute
public final function get ApplicationShortName () : String

CompilerGeneratedAttribute
public final function set ApplicationShortName (value : String)

Property Value

The application short name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.ClientCredentialType Property
[image]

Gets or sets the client credential type.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As ClientCredential

value = instance.ClientCredentialType

instance.ClientCredentialType = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
Public Property ClientCredentialType As ClientCredential
C#
[BrowsableAttribute(true)]
public ClientCredential ClientCredentialType { get; set; }
C++
[BrowsableAttribute(true)]
public:
virtual property ClientCredential ClientCredentialType {
    ClientCredential get () sealed;
    void set (ClientCredential value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final ClientCredential get_ClientCredentialType ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_ClientCredentialType (ClientCredential value)
JScript
CompilerGeneratedAttribute
public final function get ClientCredentialType () : ClientCredential

CompilerGeneratedAttribute
public final function set ClientCredentialType (value : ClientCredential)

Property Value

The client credential type.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.ConnectionLifetime Property
[image]

Gets or sets the maximum duration in seconds of a connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.ConnectionLifetime

instance.ConnectionLifetime = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property ConnectionLifetime As Integer
C#
[BrowsableAttribute(true)]
[CategoryAttribute("OracleConnectionPool")]
public int ConnectionLifetime { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int ConnectionLifetime {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_ConnectionLifetime ()

/** @property */
public final void set_ConnectionLifetime (int value)
JScript
public final function get ConnectionLifetime () : int

public final function set ConnectionLifetime (value : int)

Property Value

The maximum duration in seconds of a connection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.ConnectionUriType Property
[image]

Gets the type of the specific ConnectionUri.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Type

value = instance.ConnectionUriType

Syntax

Visual Basic
Public Overrides ReadOnly Property ConnectionUriType As Type
C#
public override Type ConnectionUriType { get; }
C++
public:
virtual property Type^ ConnectionUriType {
    Type^ get () override;
}
J#
/** @property */
public Type get_ConnectionUriType ()
JScript
public override function get ConnectionUriType () : Type

Property Value

The type of the specific ConnectionUri.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.DataFetchSize Property
[image]

Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Long

value = instance.DataFetchSize

instance.DataFetchSize = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<BrowsableAttribute(True)> _
Public Property DataFetchSize As Long
C#
[CategoryAttribute("BufferManagement")]
[BrowsableAttribute(true)]
public long DataFetchSize { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[BrowsableAttribute(true)]
public:
virtual property long long DataFetchSize {
    long long get () sealed;
    void set (long long value) sealed;
}
J#
/** @property */
public final long get_DataFetchSize ()

/** @property */
public final void set_DataFetchSize (long value)
JScript
public final function get DataFetchSize () : long

public final function set DataFetchSize (value : long)

Property Value

The amount of data in bytes that data provider fetches from the result set in one server round trip.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.DecrPoolSize Property
[image]

Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.DecrPoolSize

instance.DecrPoolSize = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property DecrPoolSize As Integer
C#
[BrowsableAttribute(true)]
[CategoryAttribute("OracleConnectionPool")]
public int DecrPoolSize { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int DecrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_DecrPoolSize ()

/** @property */
public final void set_DecrPoolSize (int value)
JScript
public final function get DecrPoolSize () : int

public final function set DecrPoolSize (value : int)

Property Value

The number of connections that are closed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.EnableBizTalkCompatibilityMode Property
[image]

Gets or sets whether the BizTalk compatibility mode is enabled.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.EnableBizTalkCompatibilityMode

instance.EnableBizTalkCompatibilityMode = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
Public Property EnableBizTalkCompatibilityMode As Boolean
C#
[BrowsableAttribute(true)]
public bool EnableBizTalkCompatibilityMode { get; set; }
C++
[BrowsableAttribute(true)]
public:
virtual property bool EnableBizTalkCompatibilityMode {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_EnableBizTalkCompatibilityMode ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_EnableBizTalkCompatibilityMode (boolean value)
JScript
CompilerGeneratedAttribute
public final function get EnableBizTalkCompatibilityMode () : boolean

CompilerGeneratedAttribute
public final function set EnableBizTalkCompatibilityMode (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the BizTalk compatibility mode is enabled.; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.EnablePerformanceCounters Property
[image]

Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.EnablePerformanceCounters

instance.EnablePerformanceCounters = value

Syntax

Visual Basic
<CategoryAttribute("Diagnostics")> _
<BrowsableAttribute(True)> _
Public Property EnablePerformanceCounters As Boolean
C#
[CategoryAttribute("Diagnostics")]
[BrowsableAttribute(true)]
public bool EnablePerformanceCounters { get; set; }
C++
[CategoryAttribute(L"Diagnostics")]
[BrowsableAttribute(true)]
public:
virtual property bool EnablePerformanceCounters {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_EnablePerformanceCounters ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_EnablePerformanceCounters (boolean value)
JScript
CompilerGeneratedAttribute
public final function get EnablePerformanceCounters () : boolean

CompilerGeneratedAttribute
public final function set EnablePerformanceCounters (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter is enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.EnableSafeTyping Property
[image]

Gets or sets whether enables or disables safe typing.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.EnableSafeTyping

instance.EnableSafeTyping = value

Syntax

Visual Basic
<CategoryAttribute("Metadata")> _
<BrowsableAttribute(True)> _
Public Property EnableSafeTyping As Boolean
C#
[CategoryAttribute("Metadata")]
[BrowsableAttribute(true)]
public bool EnableSafeTyping { get; set; }
C++
[CategoryAttribute(L"Metadata")]
[BrowsableAttribute(true)]
public:
virtual property bool EnableSafeTyping {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_EnableSafeTyping ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_EnableSafeTyping (boolean value)
JScript
CompilerGeneratedAttribute
public final function get EnableSafeTyping () : boolean

CompilerGeneratedAttribute
public final function set EnableSafeTyping (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if safe typing is enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.GeneratedUserTypesAssemblyFilePath Property
[image]

Gets or sets the name and path of the DLL that the adapter generates.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.GeneratedUserTypesAssemblyFilePath

instance.GeneratedUserTypesAssemblyFilePath = value

Syntax

Visual Basic
<CategoryAttribute("UDT .NET Type Generation - Design Time")> _
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(False, False)> _
Public Property GeneratedUserTypesAssemblyFilePath As String
C#
[CategoryAttribute("UDT .NET Type Generation - Design Time")]
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(false, false)]
public string GeneratedUserTypesAssemblyFilePath { get; set; }
C++
[CategoryAttribute(L"UDT .NET Type Generation - Design Time")]
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(false, false)]
public:
virtual property String^ GeneratedUserTypesAssemblyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_GeneratedUserTypesAssemblyFilePath ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_GeneratedUserTypesAssemblyFilePath (String value)
JScript
CompilerGeneratedAttribute
public final function get GeneratedUserTypesAssemblyFilePath () : String

CompilerGeneratedAttribute
public final function set GeneratedUserTypesAssemblyFilePath (value : String)

Property Value

The name and path of the DLL that the adapter generates.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.GeneratedUserTypesAssemblyKeyFilePath Property
[image]

Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.GeneratedUserTypesAssemblyKeyFilePath

instance.GeneratedUserTypesAssemblyKeyFilePath = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(False, False)> _
<CategoryAttribute("UDT .NET Type Generation - Design Time")> _
Public Property GeneratedUserTypesAssemblyKeyFilePath As String
C#
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(false, false)]
[CategoryAttribute("UDT .NET Type Generation - Design Time")]
public string GeneratedUserTypesAssemblyKeyFilePath { get; set; }
C++
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(false, false)]
[CategoryAttribute(L"UDT .NET Type Generation - Design Time")]
public:
virtual property String^ GeneratedUserTypesAssemblyKeyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_GeneratedUserTypesAssemblyKeyFilePath ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_GeneratedUserTypesAssemblyKeyFilePath (String value)
JScript
CompilerGeneratedAttribute
public final function get GeneratedUserTypesAssemblyKeyFilePath () : String

CompilerGeneratedAttribute
public final function set GeneratedUserTypesAssemblyKeyFilePath (value : String)

Property Value

The name and path of the key file that the adapter uses to create a strongly-typed assembly.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.InboundOperationType Property
[image]

Gets or sets the inbound operation type.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As InboundOperation

value = instance.InboundOperationType

instance.InboundOperationType = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(True, False)> _
Public Property InboundOperationType As InboundOperation
C#
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
public InboundOperation InboundOperationType { get; set; }
C++
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
public:
virtual property InboundOperation InboundOperationType {
    InboundOperation get () sealed;
    void set (InboundOperation value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final InboundOperation get_InboundOperationType ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_InboundOperationType (InboundOperation value)
JScript
CompilerGeneratedAttribute
public final function get InboundOperationType () : InboundOperation

CompilerGeneratedAttribute
public final function set InboundOperationType (value : InboundOperation)

Property Value

The Polling or Notification inbound operation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.IncrPoolSize Property
[image]

Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.IncrPoolSize

instance.IncrPoolSize = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property IncrPoolSize As Integer
C#
[BrowsableAttribute(true)]
[CategoryAttribute("OracleConnectionPool")]
public int IncrPoolSize { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int IncrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_IncrPoolSize ()

/** @property */
public final void set_IncrPoolSize (int value)
JScript
public final function get IncrPoolSize () : int

public final function set IncrPoolSize (value : int)

Property Value

The number of new connections.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.InsertBatchSize Property
[image]

Gets or sets the batch size for multiple record Insert operations.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.InsertBatchSize

instance.InsertBatchSize = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<BrowsableAttribute(True)> _
Public Property InsertBatchSize As Integer
C#
[CategoryAttribute("BufferManagement")]
[BrowsableAttribute(true)]
public int InsertBatchSize { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[BrowsableAttribute(true)]
public:
virtual property int InsertBatchSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_InsertBatchSize ()

/** @property */
public final void set_InsertBatchSize (int value)
JScript
public final function get InsertBatchSize () : int

public final function set InsertBatchSize (value : int)

Property Value

The batch size for multiple record Insert operations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.LongDatatypeColumnSize Property
[image]

Gets or sets the maximum size in bytes of an Oracle long data type column.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.LongDatatypeColumnSize

instance.LongDatatypeColumnSize = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<BrowsableAttribute(True)> _
<ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")> _
Public Property LongDatatypeColumnSize As Integer
C#
[CategoryAttribute("BufferManagement")]
[BrowsableAttribute(true)]
[ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
public int LongDatatypeColumnSize { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[BrowsableAttribute(true)]
[ObsoleteAttribute(L"Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
public:
virtual property int LongDatatypeColumnSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_LongDatatypeColumnSize ()

/** @property */
public final void set_LongDatatypeColumnSize (int value)
JScript
public final function get LongDatatypeColumnSize () : int

public final function set LongDatatypeColumnSize (value : int)

Property Value

The maximum size in bytes of an Oracle long data type column.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.MaxOutputAssociativeArrayElements Property
[image]

Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.MaxOutputAssociativeArrayElements

instance.MaxOutputAssociativeArrayElements = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("BufferManagement")> _
Public Property MaxOutputAssociativeArrayElements As Integer
C#
[BrowsableAttribute(true)]
[CategoryAttribute("BufferManagement")]
public int MaxOutputAssociativeArrayElements { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"BufferManagement")]
public:
virtual property int MaxOutputAssociativeArrayElements {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxOutputAssociativeArrayElements ()

/** @property */
public final void set_MaxOutputAssociativeArrayElements (int value)
JScript
public final function get MaxOutputAssociativeArrayElements () : int

public final function set MaxOutputAssociativeArrayElements (value : int)

Property Value

The size of the associate array that the adapter creates when performing operations that return an associative array in the response.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.MaxPoolSize Property
[image]

Gets or sets the maximum number of connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.MaxPoolSize

instance.MaxPoolSize = value

Syntax

Visual Basic
<CategoryAttribute("OracleConnectionPool")> _
<BrowsableAttribute(True)> _
Public Property MaxPoolSize As Integer
C#
[CategoryAttribute("OracleConnectionPool")]
[BrowsableAttribute(true)]
public int MaxPoolSize { get; set; }
C++
[CategoryAttribute(L"OracleConnectionPool")]
[BrowsableAttribute(true)]
public:
virtual property int MaxPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxPoolSize ()

/** @property */
public final void set_MaxPoolSize (int value)
JScript
public final function get MaxPoolSize () : int

public final function set MaxPoolSize (value : int)

Property Value

The maximum number of connections in the connection pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.MetadataPooling Property
[image]

Gets or sets whether data provider caches metadata information for executed queries.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.MetadataPooling

instance.MetadataPooling = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<BrowsableAttribute(True)> _
Public Property MetadataPooling As Boolean
C#
[CategoryAttribute("BufferManagement")]
[BrowsableAttribute(true)]
public bool MetadataPooling { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[BrowsableAttribute(true)]
public:
virtual property bool MetadataPooling {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_MetadataPooling ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_MetadataPooling (boolean value)
JScript
CompilerGeneratedAttribute
public final function get MetadataPooling () : boolean

CompilerGeneratedAttribute
public final function set MetadataPooling (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the data provider caches metadata information for executed queries; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.MinPoolSize Property
[image]

Gets or sets the minimum number of connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.MinPoolSize

instance.MinPoolSize = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property MinPoolSize As Integer
C#
[BrowsableAttribute(true)]
[CategoryAttribute("OracleConnectionPool")]
public int MinPoolSize { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int MinPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MinPoolSize ()

/** @property */
public final void set_MinPoolSize (int value)
JScript
public final function get MinPoolSize () : int

public final function set MinPoolSize (value : int)

Property Value

The minimum number of connections in the connection pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.MlsSettings Property
[image]

Gets or sets the Multiple Language System Settings configuration element.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As MlsSettings

value = instance.MlsSettings

instance.MlsSettings = value

Syntax

Visual Basic
<CategoryAttribute("Multi Language Support")> _
<BrowsableAttribute(True)> _
Public Property MlsSettings As MlsSettings
C#
[CategoryAttribute("Multi Language Support")]
[BrowsableAttribute(true)]
public MlsSettings MlsSettings { get; set; }
C++
[CategoryAttribute(L"Multi Language Support")]
[BrowsableAttribute(true)]
public:
virtual property MlsSettings^ MlsSettings {
    MlsSettings^ get () sealed;
    void set (MlsSettings^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final MlsSettings get_MlsSettings ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_MlsSettings (MlsSettings value)
JScript
CompilerGeneratedAttribute
public final function get MlsSettings () : MlsSettings

CompilerGeneratedAttribute
public final function set MlsSettings (value : MlsSettings)

Property Value

The Multiple Language System Settings configuration element.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.NotificationPort Property
[image]

Gets or sets the port number that must open to listen for database change notification from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.NotificationPort

instance.NotificationPort = value

Syntax

Visual Basic
<CategoryAttribute("Notification")> _
<BindingPropertyDirectionAttribute(True, False)> _
<BrowsableAttribute(True)> _
Public Property NotificationPort As Integer
C#
[CategoryAttribute("Notification")]
[BindingPropertyDirectionAttribute(true, false)]
[BrowsableAttribute(true)]
public int NotificationPort { get; set; }
C++
[CategoryAttribute(L"Notification")]
[BindingPropertyDirectionAttribute(true, false)]
[BrowsableAttribute(true)]
public:
virtual property int NotificationPort {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_NotificationPort ()

/** @property */
public final void set_NotificationPort (int value)
JScript
public final function get NotificationPort () : int

public final function set NotificationPort (value : int)

Property Value

The port number that must open to listen for database change notification from Oracle database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.NotificationStatement Property
[image]

Gets or sets the SELECT statement used to register for getting notifications from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.NotificationStatement

instance.NotificationStatement = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<BrowsableAttribute(True)> _
<CategoryAttribute("Notification")> _
Public Property NotificationStatement As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[BrowsableAttribute(true)]
[CategoryAttribute("Notification")]
public string NotificationStatement { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[BrowsableAttribute(true)]
[CategoryAttribute(L"Notification")]
public:
virtual property String^ NotificationStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_NotificationStatement ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_NotificationStatement (String value)
JScript
CompilerGeneratedAttribute
public final function get NotificationStatement () : String

CompilerGeneratedAttribute
public final function set NotificationStatement (value : String)

Property Value

The SELECT statement used to register for getting notifications from Oracle database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.NotifyOnListenerStart Property
[image]

Gets or sets whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.NotifyOnListenerStart

instance.NotifyOnListenerStart = value

Syntax

Visual Basic
<CategoryAttribute("Notification")> _
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(True, False)> _
Public Property NotifyOnListenerStart As Boolean
C#
[CategoryAttribute("Notification")]
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
public bool NotifyOnListenerStart { get; set; }
C++
[CategoryAttribute(L"Notification")]
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
public:
virtual property bool NotifyOnListenerStart {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_NotifyOnListenerStart ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_NotifyOnListenerStart (boolean value)
JScript
CompilerGeneratedAttribute
public final function get NotifyOnListenerStart () : boolean

CompilerGeneratedAttribute
public final function set NotifyOnListenerStart (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.OracleConnectionClientId Property
[image]

Gets or sets the Oracle connection client identifier.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.OracleConnectionClientId

instance.OracleConnectionClientId = value

Syntax

Visual Basic
<CategoryAttribute("Debug")> _
<BrowsableAttribute(True)> _
Public Property OracleConnectionClientId As String
C#
[CategoryAttribute("Debug")]
[BrowsableAttribute(true)]
public string OracleConnectionClientId { get; set; }
C++
[CategoryAttribute(L"Debug")]
[BrowsableAttribute(true)]
public:
virtual property String^ OracleConnectionClientId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleConnectionClientId ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleConnectionClientId (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleConnectionClientId () : String

CompilerGeneratedAttribute
public final function set OracleConnectionClientId (value : String)

Property Value

The Oracle connection client identifier.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.OracleEBSOrganizationId Property
[image]

Gets or sets the Oracle EBS organization identifier.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.OracleEBSOrganizationId

instance.OracleEBSOrganizationId = value

Syntax

Visual Basic
<CategoryAttribute("OracleEBS")> _
<BrowsableAttribute(True)> _
Public Property OracleEBSOrganizationId As String
C#
[CategoryAttribute("OracleEBS")]
[BrowsableAttribute(true)]
public string OracleEBSOrganizationId { get; set; }
C++
[CategoryAttribute(L"OracleEBS")]
[BrowsableAttribute(true)]
public:
virtual property String^ OracleEBSOrganizationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleEBSOrganizationId ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleEBSOrganizationId (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleEBSOrganizationId () : String

CompilerGeneratedAttribute
public final function set OracleEBSOrganizationId (value : String)

Property Value

The Oracle EBS organization identifier.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.OracleEBSResponsibilityKey Property
[image]

Gets or sets the Oracle EBS responsibility key.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.OracleEBSResponsibilityKey

instance.OracleEBSResponsibilityKey = value

Syntax

Visual Basic
<CategoryAttribute("OracleEBS")> _
<BrowsableAttribute(True)> _
Public Property OracleEBSResponsibilityKey As String
C#
[CategoryAttribute("OracleEBS")]
[BrowsableAttribute(true)]
public string OracleEBSResponsibilityKey { get; set; }
C++
[CategoryAttribute(L"OracleEBS")]
[BrowsableAttribute(true)]
public:
virtual property String^ OracleEBSResponsibilityKey {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleEBSResponsibilityKey ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleEBSResponsibilityKey (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleEBSResponsibilityKey () : String

CompilerGeneratedAttribute
public final function set OracleEBSResponsibilityKey (value : String)

Property Value

The Oracle EBS responsibility key.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.OracleEBSResponsibilityName Property
[image]

Gets or sets the Oracle EBS responsibility name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.OracleEBSResponsibilityName

instance.OracleEBSResponsibilityName = value

Syntax

Visual Basic
<CategoryAttribute("OracleEBS")> _
<BrowsableAttribute(True)> _
Public Property OracleEBSResponsibilityName As String
C#
[CategoryAttribute("OracleEBS")]
[BrowsableAttribute(true)]
public string OracleEBSResponsibilityName { get; set; }
C++
[CategoryAttribute(L"OracleEBS")]
[BrowsableAttribute(true)]
public:
virtual property String^ OracleEBSResponsibilityName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleEBSResponsibilityName ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleEBSResponsibilityName (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleEBSResponsibilityName () : String

CompilerGeneratedAttribute
public final function set OracleEBSResponsibilityName (value : String)

Property Value

The Oracle EBS responsibility name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.OraclePassword Property
[image]

Gets or sets the Oracle password.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.OraclePassword

instance.OraclePassword = value

Syntax

Visual Basic
<CategoryAttribute("OracleEBS")> _
<BrowsableAttribute(True)> _
<PasswordPropertyTextAttribute(True)> _
Public Property OraclePassword As String
C#
[CategoryAttribute("OracleEBS")]
[BrowsableAttribute(true)]
[PasswordPropertyTextAttribute(true)]
public string OraclePassword { get; set; }
C++
[CategoryAttribute(L"OracleEBS")]
[BrowsableAttribute(true)]
[PasswordPropertyTextAttribute(true)]
public:
virtual property String^ OraclePassword {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OraclePassword ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OraclePassword (String value)
JScript
CompilerGeneratedAttribute
public final function get OraclePassword () : String

CompilerGeneratedAttribute
public final function set OraclePassword (value : String)

Property Value

The Oracle password.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.OracleUserName Property
[image]

Gets or sets the Oracle user name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.OracleUserName

instance.OracleUserName = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("OracleEBS")> _
Public Property OracleUserName As String
C#
[BrowsableAttribute(true)]
[CategoryAttribute("OracleEBS")]
public string OracleUserName { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"OracleEBS")]
public:
virtual property String^ OracleUserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_OracleUserName ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_OracleUserName (String value)
JScript
CompilerGeneratedAttribute
public final function get OracleUserName () : String

CompilerGeneratedAttribute
public final function set OracleUserName (value : String)

Property Value

The Oracle user name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.PolledDataAvailableStatement Property
[image]

Gets or sets the polled data available statement.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.PolledDataAvailableStatement

instance.PolledDataAvailableStatement = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
Public Property PolledDataAvailableStatement As String
C#
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
public string PolledDataAvailableStatement { get; set; }
C++
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
public:
virtual property String^ PolledDataAvailableStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PolledDataAvailableStatement ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PolledDataAvailableStatement (String value)
JScript
CompilerGeneratedAttribute
public final function get PolledDataAvailableStatement () : String

CompilerGeneratedAttribute
public final function set PolledDataAvailableStatement (value : String)

Property Value

The polled data available statement.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.PollingAction Property
[image]

Gets or sets the action for the polling operation.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.PollingAction

instance.PollingAction = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
<BrowsableAttribute(True)> _
Public Property PollingAction As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
[BrowsableAttribute(true)]
public string PollingAction { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
[BrowsableAttribute(true)]
public:
virtual property String^ PollingAction {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PollingAction ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PollingAction (String value)
JScript
CompilerGeneratedAttribute
public final function get PollingAction () : String

CompilerGeneratedAttribute
public final function set PollingAction (value : String)

Property Value

The action for the polling operation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.PollingInput Property
[image]

Gets or sets the polling input.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.PollingInput

instance.PollingInput = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("Polling")> _
<BindingPropertyDirectionAttribute(True, False)> _
Public Property PollingInput As String
C#
[BrowsableAttribute(true)]
[CategoryAttribute("Polling")]
[BindingPropertyDirectionAttribute(true, false)]
public string PollingInput { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"Polling")]
[BindingPropertyDirectionAttribute(true, false)]
public:
virtual property String^ PollingInput {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PollingInput ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PollingInput (String value)
JScript
CompilerGeneratedAttribute
public final function get PollingInput () : String

CompilerGeneratedAttribute
public final function set PollingInput (value : String)

Property Value

The polling input.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.PollingInterval Property
[image]

Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.PollingInterval

instance.PollingInterval = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
Public Property PollingInterval As Integer
C#
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
public int PollingInterval { get; set; }
C++
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
public:
virtual property int PollingInterval {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_PollingInterval ()

/** @property */
public final void set_PollingInterval (int value)
JScript
public final function get PollingInterval () : int

public final function set PollingInterval (value : int)

Property Value

The transacted polling interval.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.PollWhileDataFound Property
[image]

Gets or sets whether the specified object continuously poll data when it is available.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.PollWhileDataFound

instance.PollWhileDataFound = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
Public Property PollWhileDataFound As Boolean
C#
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
public bool PollWhileDataFound { get; set; }
C++
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
public:
virtual property bool PollWhileDataFound {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_PollWhileDataFound ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PollWhileDataFound (boolean value)
JScript
CompilerGeneratedAttribute
public final function get PollWhileDataFound () : boolean

CompilerGeneratedAttribute
public final function set PollWhileDataFound (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the specified object continuously poll data when it is available; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.PostPollStatement Property
[image]

Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.PostPollStatement

instance.PostPollStatement = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
Public Property PostPollStatement As String
C#
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
public string PostPollStatement { get; set; }
C++
[BrowsableAttribute(true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
public:
virtual property String^ PostPollStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_PostPollStatement ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_PostPollStatement (String value)
JScript
CompilerGeneratedAttribute
public final function get PostPollStatement () : String

CompilerGeneratedAttribute
public final function set PostPollStatement (value : String)

Property Value

The PL/SQL block that is executed after the polling statement.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.Scheme Property
[image]

Gets the scheme of the binding.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.Scheme

Syntax

Visual Basic
Public Overrides ReadOnly Property Scheme As String
C#
public override string Scheme { get; }
C++
public:
virtual property String^ Scheme {
    String^ get () override;
}
J#
/** @property */
public String get_Scheme ()
JScript
public override function get Scheme () : String

Property Value

The scheme of the binding.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.SkipNilNodes Property
[image]

Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.SkipNilNodes

instance.SkipNilNodes = value

Syntax

Visual Basic
<CategoryAttribute("Run Time Behavior")> _
<BrowsableAttribute(True)> _
Public Property SkipNilNodes As Boolean
C#
[CategoryAttribute("Run Time Behavior")]
[BrowsableAttribute(true)]
public bool SkipNilNodes { get; set; }
C++
[CategoryAttribute(L"Run Time Behavior")]
[BrowsableAttribute(true)]
public:
virtual property bool SkipNilNodes {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_SkipNilNodes ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_SkipNilNodes (boolean value)
JScript
CompilerGeneratedAttribute
public final function get SkipNilNodes () : boolean

CompilerGeneratedAttribute
public final function set SkipNilNodes (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the nil node is skipped; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.StatementCachePurge Property
[image]

Gets or sets whether the data provider statement cache associated when a connection is purged.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.StatementCachePurge

instance.StatementCachePurge = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<BrowsableAttribute(True)> _
Public Property StatementCachePurge As Boolean
C#
[CategoryAttribute("BufferManagement")]
[BrowsableAttribute(true)]
public bool StatementCachePurge { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[BrowsableAttribute(true)]
public:
virtual property bool StatementCachePurge {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_StatementCachePurge ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_StatementCachePurge (boolean value)
JScript
CompilerGeneratedAttribute
public final function get StatementCachePurge () : boolean

CompilerGeneratedAttribute
public final function set StatementCachePurge (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the data provider statement cache associated with a connection is purged; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.StatementCacheSize Property
[image]

Gets or sets the maximum number of statements that can be cached by each data provider connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Integer

value = instance.StatementCacheSize

instance.StatementCacheSize = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("BufferManagement")> _
Public Property StatementCacheSize As Integer
C#
[BrowsableAttribute(true)]
[CategoryAttribute("BufferManagement")]
public int StatementCacheSize { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"BufferManagement")]
public:
virtual property int StatementCacheSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_StatementCacheSize ()

/** @property */
public final void set_StatementCacheSize (int value)
JScript
public final function get StatementCacheSize () : int

public final function set StatementCacheSize (value : int)

Property Value

The maximum number of statements that can be cached by each data provider connection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.SupportsMetadataBrowse Property
[image]

Gets a value that indicates whether the binding supports metadata browsing.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.SupportsMetadataBrowse

Syntax

Visual Basic
Public Overrides ReadOnly Property SupportsMetadataBrowse As Boolean
C#
public override bool SupportsMetadataBrowse { get; }
C++
public:
virtual property bool SupportsMetadataBrowse {
    bool get () override;
}
J#
/** @property */
public boolean get_SupportsMetadataBrowse ()
JScript
public override function get SupportsMetadataBrowse () : boolean

Property Value

<languageKeyword>True</languageKeyword> if the binding supports metadata browsing; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.SupportsMetadataGet Property
[image]

Gets a value that indicates whether the binding supports metadata retrieval.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.SupportsMetadataGet

Syntax

Visual Basic
Public Overrides ReadOnly Property SupportsMetadataGet As Boolean
C#
public override bool SupportsMetadataGet { get; }
C++
public:
virtual property bool SupportsMetadataGet {
    bool get () override;
}
J#
/** @property */
public boolean get_SupportsMetadataGet ()
JScript
public override function get SupportsMetadataGet () : boolean

Property Value

<languageKeyword>True</languageKeyword> if the binding supports metadata retrieval; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.SupportsMetadataSearch Property
[image]

Gets a value that indicates whether the binding supports metadata search.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.SupportsMetadataSearch

Syntax

Visual Basic
Public Overrides ReadOnly Property SupportsMetadataSearch As Boolean
C#
public override bool SupportsMetadataSearch { get; }
C++
public:
virtual property bool SupportsMetadataSearch {
    bool get () override;
}
J#
/** @property */
public boolean get_SupportsMetadataSearch ()
JScript
public override function get SupportsMetadataSearch () : boolean

Property Value

<languageKeyword>True</languageKeyword> if the binding supports metadata search; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.UseAmbientTransaction Property
[image]

Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.UseAmbientTransaction

instance.UseAmbientTransaction = value

Syntax

Visual Basic
<CategoryAttribute("Transactions")> _
<BrowsableAttribute(True)> _
Public Property UseAmbientTransaction As Boolean
C#
[CategoryAttribute("Transactions")]
[BrowsableAttribute(true)]
public bool UseAmbientTransaction { get; set; }
C++
[CategoryAttribute(L"Transactions")]
[BrowsableAttribute(true)]
public:
virtual property bool UseAmbientTransaction {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_UseAmbientTransaction ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_UseAmbientTransaction (boolean value)
JScript
CompilerGeneratedAttribute
public final function get UseAmbientTransaction () : boolean

CompilerGeneratedAttribute
public final function set UseAmbientTransaction (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the Oracle Database adapter performs the operations using the transaction context provided by the caller; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.UseOracleConnectionPool Property
[image]

Gets or sets whether to use the Oracle connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.UseOracleConnectionPool

instance.UseOracleConnectionPool = value

Syntax

Visual Basic
<CategoryAttribute("OracleConnectionPool")> _
<BrowsableAttribute(True)> _
Public Property UseOracleConnectionPool As Boolean
C#
[CategoryAttribute("OracleConnectionPool")]
[BrowsableAttribute(true)]
public bool UseOracleConnectionPool { get; set; }
C++
[CategoryAttribute(L"OracleConnectionPool")]
[BrowsableAttribute(true)]
public:
virtual property bool UseOracleConnectionPool {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_UseOracleConnectionPool ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_UseOracleConnectionPool (boolean value)
JScript
CompilerGeneratedAttribute
public final function get UseOracleConnectionPool () : boolean

CompilerGeneratedAttribute
public final function set UseOracleConnectionPool (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if use the Oracle connection pool; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.UserAssembliesLoadPath Property
[image]

Gets or sets the path where the assemblies will be loaded.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As String

value = instance.UserAssembliesLoadPath

instance.UserAssembliesLoadPath = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("UDT .NET Type Generation - Run Time")> _
Public Property UserAssembliesLoadPath As String
C#
[BrowsableAttribute(true)]
[CategoryAttribute("UDT .NET Type Generation - Run Time")]
public string UserAssembliesLoadPath { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"UDT .NET Type Generation - Run Time")]
public:
virtual property String^ UserAssembliesLoadPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final String get_UserAssembliesLoadPath ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_UserAssembliesLoadPath (String value)
JScript
CompilerGeneratedAttribute
public final function get UserAssembliesLoadPath () : String

CompilerGeneratedAttribute
public final function set UserAssembliesLoadPath (value : String)

Property Value

The path where the assemblies will be loaded.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBinding.UseSchemaInNameSpace Property
[image]

Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBinding
Dim value As Boolean

value = instance.UseSchemaInNameSpace

instance.UseSchemaInNameSpace = value

Syntax

Visual Basic
<CategoryAttribute("Metadata")> _
<BrowsableAttribute(True)> _
Public Property UseSchemaInNameSpace As Boolean
C#
[CategoryAttribute("Metadata")]
[BrowsableAttribute(true)]
public bool UseSchemaInNameSpace { get; set; }
C++
[CategoryAttribute(L"Metadata")]
[BrowsableAttribute(true)]
public:
virtual property bool UseSchemaInNameSpace {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final boolean get_UseSchemaInNameSpace ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public final void set_UseSchemaInNameSpace (boolean value)
JScript
CompilerGeneratedAttribute
public final function get UseSchemaInNameSpace () : boolean

CompilerGeneratedAttribute
public final function set UseSchemaInNameSpace (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the schema name is included in the xml namespace for operations and their associated types; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBinding Class
OracleEBSBinding Members


OracleEBSBindingCollectionElement Class
See Also Members
[image]

Represents the StandardBindingCollectionElement for the Oracle E-Business Suite Adapter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingCollectionElement

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")> _
Public Class OracleEBSBindingCollectionElement
    Inherits StandardBindingCollectionElement(Of OracleEBSBinding, OracleEBSBindingConfigurationElement)
C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")]
public class OracleEBSBindingCollectionElement : StandardBindingCollectionElement<OracleEBSBinding,OracleEBSBindingConfigurationElement>
C++
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1705:LongAcronymsShouldBePascalCased")]
public ref class OracleEBSBindingCollectionElement : public StandardBindingCollectionElement<OracleEBSBinding^, OracleEBSBindingConfigurationElement^>
J#
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased") */
public class OracleEBSBindingCollectionElement extends StandardBindingCollectionElement<OracleEBSBinding,OracleEBSBindingConfigurationElement>
JScript
SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")
public class OracleEBSBindingCollectionElement extends StandardBindingCollectionElement<OracleEBSBinding,OracleEBSBindingConfigurationElement>

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.BindingCollectionElement
System.ServiceModel.Configuration.StandardBindingCollectionElement
Microsoft.Adapters.OracleEBS.OracleEBSBindingCollectionElement

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingCollectionElement Members


OracleEBSBindingCollectionElement Members
See Also Constructors Methods Properties
[image]

Represents the StandardBindingCollectionElement for the Oracle E-Business Suite Adapter.

The following tables list the members exposed by the OracleEBSBindingCollectionElement type.

Public Constructors

Name | Description
OracleEBSBindingCollectionElement | Initializes a new instance of the OracleEBSBindingCollectionElement class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | BindingName | (inherited from BindingCollectionElement)
public property | Bindings | (inherited from StandardBindingCollectionElement)
public property | BindingType | Overridden. (inherited from BindingCollectionElement)
public property | ConfiguredBindings | Overridden. (inherited from BindingCollectionElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | ContainsKey | Overridden. (inherited from BindingCollectionElement)
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

See Also

Reference

OracleEBSBindingCollectionElement Class


OracleEBSBindingCollectionElement Constructor
[image]

Initializes a new instance of the OracleEBSBindingCollectionElement class.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New OracleEBSBindingCollectionElement

Syntax

Visual Basic
Public Sub New
C#
public OracleEBSBindingCollectionElement ()
C++
public:
OracleEBSBindingCollectionElement ()
J#
public OracleEBSBindingCollectionElement ()
JScript
public function OracleEBSBindingCollectionElement ()

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingCollectionElement Class
OracleEBSBindingCollectionElement Members


OracleEBSBindingCollectionElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | ContainsKey | Overridden. (inherited from BindingCollectionElement)
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

See Also

Reference

OracleEBSBindingCollectionElement Class


OracleEBSBindingCollectionElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | BindingName | (inherited from BindingCollectionElement)
public property | Bindings | (inherited from StandardBindingCollectionElement)
public property | BindingType | Overridden. (inherited from BindingCollectionElement)
public property | ConfiguredBindings | Overridden. (inherited from BindingCollectionElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. (inherited from ConfigurationElement)

See Also

Reference

OracleEBSBindingCollectionElement Class


OracleEBSBindingConfigurationElement Class
See Also Members
[image]

Represents the StandardBindingElement for the Oracle E-Business Suite Adapter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")> _
Public NotInheritable Class OracleEBSBindingConfigurationElement
    Inherits StandardBindingElement
C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")]
public sealed class OracleEBSBindingConfigurationElement : StandardBindingElement
C++
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1705:LongAcronymsShouldBePascalCased")]
public ref class OracleEBSBindingConfigurationElement sealed : public StandardBindingElement
J#
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased") */
public final class OracleEBSBindingConfigurationElement extends StandardBindingElement
JScript
SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")
public final class OracleEBSBindingConfigurationElement extends StandardBindingElement

Remarks

This class is used for configuring the Oracle E-Business Suite Adapter via .config files.

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.StandardBindingElement
Microsoft.Adapters.OracleEBS.OracleEBSBindingConfigurationElement

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement Members
See Also Constructors Methods Properties
[image]

Represents the StandardBindingElement for the Oracle E-Business Suite Adapter.

The following tables list the members exposed by the OracleEBSBindingConfigurationElement type.

Public Constructors

Name | Description
OracleEBSBindingConfigurationElement | Overloaded.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets whether the connection URI can contain user credentials for the database.
public property | ApplicationShortName | Gets or sets the application short name.
public property | ClientCredentialType | Gets or sets the client credential type.
public property | CloseTimeout | (inherited from StandardBindingElement)
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | DataFetchSize | Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EnableBizTalkCompatibilityMode | Gets or sets whether the BizTalk compatibility mode is enabled.
public property | EnablePerformanceCounters | Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets whether enables or disables safe typing.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the inbound operation type.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in the connection pool.
public property | MetadataPooling | Gets or sets whether data provider caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in the connection pool.
public property | MlsSettings | Gets or sets the Multiple Language System Settings configuration element.
public property | Name | (inherited from StandardBindingElement)
public property | NotificationPort | Gets or sets the port number that must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.
public property | OpenTimeout | (inherited from StandardBindingElement)
public property | OracleConnectionClientId | Gets or sets the Oracle connection client identifier.
public property | OracleEBSOrganizationId | Gets or sets the Oracle EBS organization identifier.
public property | OracleEBSResponsibilityKey | Gets or sets the Oracle EBS responsibility key.
public property | OracleEBSResponsibilityName | Gets or sets the Oracle EBS responsibility name.
public property | OraclePassword | Gets or sets the Oracle password.
public property | OracleUserName | Gets or sets the Oracle user name.
public property | PolledDataAvailableStatement | Gets or sets the polled data available statement.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling input.
public property | PollingInterval | Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets whether the specified object continuously poll data when it is available.
public property | PostPollStatement | Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | ReceiveTimeout | (inherited from StandardBindingElement)
public property | SendTimeout | (inherited from StandardBindingElement)
public property | SkipNilNodes | Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets whether the data provider statement cache associated when a connection is purged.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each data provider connection.
public property | UseAmbientTransaction | Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets whether to use the Oracle connection pool.
public property | UserAssembliesLoadPath | Gets or sets the path where the assemblies will be loaded.
public property | UseSchemaInNameSpace | Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.
Top

Protected Properties

 | Name | Description
protected property | BindingElementType | (inherited from StandardBindingElement)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | ApplyConfiguration | (inherited from StandardBindingElement)
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnApplyConfiguration | (inherited from StandardBindingElement)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

See Also

Reference

OracleEBSBindingConfigurationElement Class


OracleEBSBindingConfigurationElement Constructor
[image]

Initializes a new instance of the OracleEBSBindingConfigurationElement class.

Overload List

Name | Description
OracleEBSBindingConfigurationElement () | Initializes a new instance of the OracleEBSBindingConfigurationElement class.
OracleEBSBindingConfigurationElement (String) | Initializes a new instance of the OracleEBSBindingConfigurationElement class with the specified name.

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement Constructor ()
[image]

Initializes a new instance of the OracleEBSBindingConfigurationElement class.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New OracleEBSBindingConfigurationElement

Syntax

Visual Basic
Public Sub New
C#
public OracleEBSBindingConfigurationElement ()
C++
public:
OracleEBSBindingConfigurationElement ()
J#
public OracleEBSBindingConfigurationElement ()
JScript
public function OracleEBSBindingConfigurationElement ()

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement Constructor (String)
[image]

Initializes a new instance of the OracleEBSBindingConfigurationElement class with the specified name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim name As String

Dim instance As New OracleEBSBindingConfigurationElement(name)

Syntax

Visual Basic
Public Sub New ( _
    name As String _
)
C#
public OracleEBSBindingConfigurationElement (
    string name
)
C++
public:
OracleEBSBindingConfigurationElement (
    String^ name
)
J#
public OracleEBSBindingConfigurationElement (
    String name
)
JScript
public function OracleEBSBindingConfigurationElement (
    name : String
)

Parameters

name

The specified name.

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | ApplyConfiguration | (inherited from StandardBindingElement)
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnApplyConfiguration | (inherited from StandardBindingElement)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

See Also

Reference

OracleEBSBindingConfigurationElement Class


OracleEBSBindingConfigurationElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets whether the connection URI can contain user credentials for the database.
public property | ApplicationShortName | Gets or sets the application short name.
public property | ClientCredentialType | Gets or sets the client credential type.
public property | CloseTimeout | (inherited from StandardBindingElement)
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | DataFetchSize | Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EnableBizTalkCompatibilityMode | Gets or sets whether the BizTalk compatibility mode is enabled.
public property | EnablePerformanceCounters | Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets whether enables or disables safe typing.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the inbound operation type.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in the connection pool.
public property | MetadataPooling | Gets or sets whether data provider caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in the connection pool.
public property | MlsSettings | Gets or sets the Multiple Language System Settings configuration element.
public property | Name | (inherited from StandardBindingElement)
public property | NotificationPort | Gets or sets the port number that must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.
public property | OpenTimeout | (inherited from StandardBindingElement)
public property | OracleConnectionClientId | Gets or sets the Oracle connection client identifier.
public property | OracleEBSOrganizationId | Gets or sets the Oracle EBS organization identifier.
public property | OracleEBSResponsibilityKey | Gets or sets the Oracle EBS responsibility key.
public property | OracleEBSResponsibilityName | Gets or sets the Oracle EBS responsibility name.
public property | OraclePassword | Gets or sets the Oracle password.
public property | OracleUserName | Gets or sets the Oracle user name.
public property | PolledDataAvailableStatement | Gets or sets the polled data available statement.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling input.
public property | PollingInterval | Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets whether the specified object continuously poll data when it is available.
public property | PostPollStatement | Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | ReceiveTimeout | (inherited from StandardBindingElement)
public property | SendTimeout | (inherited from StandardBindingElement)
public property | SkipNilNodes | Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets whether the data provider statement cache associated when a connection is purged.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each data provider connection.
public property | UseAmbientTransaction | Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets whether to use the Oracle connection pool.
public property | UserAssembliesLoadPath | Gets or sets the path where the assemblies will be loaded.
public property | UseSchemaInNameSpace | Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.

Protected Properties

 | Name | Description
protected property | BindingElementType | (inherited from StandardBindingElement)
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. (inherited from ConfigurationElement)

See Also

Reference

OracleEBSBindingConfigurationElement Class


OracleEBSBindingConfigurationElement.AcceptCredentialsInUri Property
[image]

Gets or sets whether the connection URI can contain user credentials for the database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.AcceptCredentialsInUri

instance.AcceptCredentialsInUri = value

Syntax

Visual Basic
<CategoryAttribute("Security")> _
<BrowsableAttribute(False)> _
<ConfigurationPropertyAttribute("acceptCredentialsInUri")> _
Public Property AcceptCredentialsInUri As Boolean
C#
[CategoryAttribute("Security")]
[BrowsableAttribute(false)]
[ConfigurationPropertyAttribute("acceptCredentialsInUri")]
public bool AcceptCredentialsInUri { get; set; }
C++
[CategoryAttribute(L"Security")]
[BrowsableAttribute(false)]
[ConfigurationPropertyAttribute(L"acceptCredentialsInUri")]
public:
virtual property bool AcceptCredentialsInUri {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_AcceptCredentialsInUri ()

/** @property */
public final void set_AcceptCredentialsInUri (boolean value)
JScript
public final function get AcceptCredentialsInUri () : boolean

public final function set AcceptCredentialsInUri (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if use the Oracle connection URI can contain user credentials for the Oracle database; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.ApplicationShortName Property
[image]

Gets or sets the application short name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.ApplicationShortName

instance.ApplicationShortName = value

Syntax

Visual Basic
<CategoryAttribute("OracleEBS")> _
<ConfigurationPropertyAttribute("applicationShortName")> _
Public Property ApplicationShortName As String
C#
[CategoryAttribute("OracleEBS")]
[ConfigurationPropertyAttribute("applicationShortName")]
public string ApplicationShortName { get; set; }
C++
[CategoryAttribute(L"OracleEBS")]
[ConfigurationPropertyAttribute(L"applicationShortName")]
public:
virtual property String^ ApplicationShortName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_ApplicationShortName ()

/** @property */
public final void set_ApplicationShortName (String value)
JScript
public final function get ApplicationShortName () : String

public final function set ApplicationShortName (value : String)

Property Value

The application short name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.ClientCredentialType Property
[image]

Gets or sets the client credential type.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As ClientCredential

value = instance.ClientCredentialType

instance.ClientCredentialType = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("clientCredentialType")> _
Public Property ClientCredentialType As ClientCredential
C#
[ConfigurationPropertyAttribute("clientCredentialType")]
public ClientCredential ClientCredentialType { get; set; }
C++
[ConfigurationPropertyAttribute(L"clientCredentialType")]
public:
virtual property ClientCredential ClientCredentialType {
    ClientCredential get () sealed;
    void set (ClientCredential value) sealed;
}
J#
/** @property */
public final ClientCredential get_ClientCredentialType ()

/** @property */
public final void set_ClientCredentialType (ClientCredential value)
JScript
public final function get ClientCredentialType () : ClientCredential

public final function set ClientCredentialType (value : ClientCredential)

Property Value

The client credential type.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.ConnectionLifetime Property
[image]

Gets or sets the maximum duration in seconds of a connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.ConnectionLifetime

instance.ConnectionLifetime = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("connectionLifetime")> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property ConnectionLifetime As Integer
C#
[ConfigurationPropertyAttribute("connectionLifetime")]
[CategoryAttribute("OracleConnectionPool")]
public int ConnectionLifetime { get; set; }
C++
[ConfigurationPropertyAttribute(L"connectionLifetime")]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int ConnectionLifetime {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_ConnectionLifetime ()

/** @property */
public final void set_ConnectionLifetime (int value)
JScript
public final function get ConnectionLifetime () : int

public final function set ConnectionLifetime (value : int)

Property Value

The maximum duration in seconds of a connection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.DataFetchSize Property
[image]

Gets or sets the amount of data in bytes that data provider fetches from the result set in one server round trip.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Long

value = instance.DataFetchSize

instance.DataFetchSize = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<ConfigurationPropertyAttribute("dataFetchSize")> _
Public Property DataFetchSize As Long
C#
[CategoryAttribute("BufferManagement")]
[ConfigurationPropertyAttribute("dataFetchSize")]
public long DataFetchSize { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[ConfigurationPropertyAttribute(L"dataFetchSize")]
public:
virtual property long long DataFetchSize {
    long long get () sealed;
    void set (long long value) sealed;
}
J#
/** @property */
public final long get_DataFetchSize ()

/** @property */
public final void set_DataFetchSize (long value)
JScript
public final function get DataFetchSize () : long

public final function set DataFetchSize (value : long)

Property Value

The amount of data in bytes that data provider fetches from the result set in one server round trip.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.DecrPoolSize Property
[image]

Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.DecrPoolSize

instance.DecrPoolSize = value

Syntax

Visual Basic
<CategoryAttribute("OracleConnectionPool")> _
<ConfigurationPropertyAttribute("decrPoolSize")> _
Public Property DecrPoolSize As Integer
C#
[CategoryAttribute("OracleConnectionPool")]
[ConfigurationPropertyAttribute("decrPoolSize")]
public int DecrPoolSize { get; set; }
C++
[CategoryAttribute(L"OracleConnectionPool")]
[ConfigurationPropertyAttribute(L"decrPoolSize")]
public:
virtual property int DecrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_DecrPoolSize ()

/** @property */
public final void set_DecrPoolSize (int value)
JScript
public final function get DecrPoolSize () : int

public final function set DecrPoolSize (value : int)

Property Value

The number of connections that are closed.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.EnableBizTalkCompatibilityMode Property
[image]

Gets or sets whether the BizTalk compatibility mode is enabled.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.EnableBizTalkCompatibilityMode

instance.EnableBizTalkCompatibilityMode = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("enableBizTalkCompatibilityMode")> _
Public Property EnableBizTalkCompatibilityMode As Boolean
C#
[ConfigurationPropertyAttribute("enableBizTalkCompatibilityMode")]
public bool EnableBizTalkCompatibilityMode { get; set; }
C++
[ConfigurationPropertyAttribute(L"enableBizTalkCompatibilityMode")]
public:
virtual property bool EnableBizTalkCompatibilityMode {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnableBizTalkCompatibilityMode ()

/** @property */
public final void set_EnableBizTalkCompatibilityMode (boolean value)
JScript
public final function get EnableBizTalkCompatibilityMode () : boolean

public final function set EnableBizTalkCompatibilityMode (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the BizTalk compatibility mode is enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.EnablePerformanceCounters Property
[image]

Gets or sets whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.EnablePerformanceCounters

instance.EnablePerformanceCounters = value

Syntax

Visual Basic
<CategoryAttribute("Diagnostics")> _
<ConfigurationPropertyAttribute("enablePerformanceCounters")> _
Public Property EnablePerformanceCounters As Boolean
C#
[CategoryAttribute("Diagnostics")]
[ConfigurationPropertyAttribute("enablePerformanceCounters")]
public bool EnablePerformanceCounters { get; set; }
C++
[CategoryAttribute(L"Diagnostics")]
[ConfigurationPropertyAttribute(L"enablePerformanceCounters")]
public:
virtual property bool EnablePerformanceCounters {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnablePerformanceCounters ()

/** @property */
public final void set_EnablePerformanceCounters (boolean value)
JScript
public final function get EnablePerformanceCounters () : boolean

public final function set EnablePerformanceCounters (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter is enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.EnableSafeTyping Property
[image]

Gets or sets whether enables or disables safe typing.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.EnableSafeTyping

instance.EnableSafeTyping = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("enableSafeTyping")> _
<CategoryAttribute("Metadata")> _
Public Property EnableSafeTyping As Boolean
C#
[ConfigurationPropertyAttribute("enableSafeTyping")]
[CategoryAttribute("Metadata")]
public bool EnableSafeTyping { get; set; }
C++
[ConfigurationPropertyAttribute(L"enableSafeTyping")]
[CategoryAttribute(L"Metadata")]
public:
virtual property bool EnableSafeTyping {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnableSafeTyping ()

/** @property */
public final void set_EnableSafeTyping (boolean value)
JScript
public final function get EnableSafeTyping () : boolean

public final function set EnableSafeTyping (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if safe typing is enabled; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.GeneratedUserTypesAssemblyFilePath Property
[image]

Gets or sets the name and path of the DLL that the adapter generates.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.GeneratedUserTypesAssemblyFilePath

instance.GeneratedUserTypesAssemblyFilePath = value

Syntax

Visual Basic
<CategoryAttribute("UDT .NET Type Generation - Design Time")> _
<ConfigurationPropertyAttribute("generatedUserTypesAssemblyFilePath")> _
<BindingPropertyDirectionAttribute(False, False)> _
Public Property GeneratedUserTypesAssemblyFilePath As String
C#
[CategoryAttribute("UDT .NET Type Generation - Design Time")]
[ConfigurationPropertyAttribute("generatedUserTypesAssemblyFilePath")]
[BindingPropertyDirectionAttribute(false, false)]
public string GeneratedUserTypesAssemblyFilePath { get; set; }
C++
[CategoryAttribute(L"UDT .NET Type Generation - Design Time")]
[ConfigurationPropertyAttribute(L"generatedUserTypesAssemblyFilePath")]
[BindingPropertyDirectionAttribute(false, false)]
public:
virtual property String^ GeneratedUserTypesAssemblyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_GeneratedUserTypesAssemblyFilePath ()

/** @property */
public final void set_GeneratedUserTypesAssemblyFilePath (String value)
JScript
public final function get GeneratedUserTypesAssemblyFilePath () : String

public final function set GeneratedUserTypesAssemblyFilePath (value : String)

Property Value

The name and path of the DLL that the adapter generates.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.GeneratedUserTypesAssemblyKeyFilePath Property
[image]

Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.GeneratedUserTypesAssemblyKeyFilePath

instance.GeneratedUserTypesAssemblyKeyFilePath = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("generatedUserTypesAssemblyKeyFilePath")> _
<CategoryAttribute("UDT .NET Type Generation - Design Time")> _
<BindingPropertyDirectionAttribute(False, False)> _
Public Property GeneratedUserTypesAssemblyKeyFilePath As String
C#
[ConfigurationPropertyAttribute("generatedUserTypesAssemblyKeyFilePath")]
[CategoryAttribute("UDT .NET Type Generation - Design Time")]
[BindingPropertyDirectionAttribute(false, false)]
public string GeneratedUserTypesAssemblyKeyFilePath { get; set; }
C++
[ConfigurationPropertyAttribute(L"generatedUserTypesAssemblyKeyFilePath")]
[CategoryAttribute(L"UDT .NET Type Generation - Design Time")]
[BindingPropertyDirectionAttribute(false, false)]
public:
virtual property String^ GeneratedUserTypesAssemblyKeyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_GeneratedUserTypesAssemblyKeyFilePath ()

/** @property */
public final void set_GeneratedUserTypesAssemblyKeyFilePath (String value)
JScript
public final function get GeneratedUserTypesAssemblyKeyFilePath () : String

public final function set GeneratedUserTypesAssemblyKeyFilePath (value : String)

Property Value

The name and path of the key file that the adapter uses to create a strongly-typed assembly.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.InboundOperationType Property
[image]

Gets or sets the inbound operation type.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As InboundOperation

value = instance.InboundOperationType

instance.InboundOperationType = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("inboundOperationType")> _
Public Property InboundOperationType As InboundOperation
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("inboundOperationType")]
public InboundOperation InboundOperationType { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"inboundOperationType")]
public:
virtual property InboundOperation InboundOperationType {
    InboundOperation get () sealed;
    void set (InboundOperation value) sealed;
}
J#
/** @property */
public final InboundOperation get_InboundOperationType ()

/** @property */
public final void set_InboundOperationType (InboundOperation value)
JScript
public final function get InboundOperationType () : InboundOperation

public final function set InboundOperationType (value : InboundOperation)

Property Value

The Polling or Notification inbound operation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.IncrPoolSize Property
[image]

Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.IncrPoolSize

instance.IncrPoolSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("incrPoolSize")> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property IncrPoolSize As Integer
C#
[ConfigurationPropertyAttribute("incrPoolSize")]
[CategoryAttribute("OracleConnectionPool")]
public int IncrPoolSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"incrPoolSize")]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int IncrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_IncrPoolSize ()

/** @property */
public final void set_IncrPoolSize (int value)
JScript
public final function get IncrPoolSize () : int

public final function set IncrPoolSize (value : int)

Property Value

The number of new connections.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.InsertBatchSize Property
[image]

Gets or sets the batch size for multiple record Insert operations.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.InsertBatchSize

instance.InsertBatchSize = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<ConfigurationPropertyAttribute("insertBatchSize")> _
Public Property InsertBatchSize As Integer
C#
[CategoryAttribute("BufferManagement")]
[ConfigurationPropertyAttribute("insertBatchSize")]
public int InsertBatchSize { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[ConfigurationPropertyAttribute(L"insertBatchSize")]
public:
virtual property int InsertBatchSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_InsertBatchSize ()

/** @property */
public final void set_InsertBatchSize (int value)
JScript
public final function get InsertBatchSize () : int

public final function set InsertBatchSize (value : int)

Property Value

The batch size for multiple record Insert operations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.LongDatatypeColumnSize Property
[image]

Gets or sets the maximum size in bytes of an Oracle long data type column.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.LongDatatypeColumnSize

instance.LongDatatypeColumnSize = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<ConfigurationPropertyAttribute("longDatatypeColumnSize")> _
<ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")> _
Public Property LongDatatypeColumnSize As Integer
C#
[CategoryAttribute("BufferManagement")]
[ConfigurationPropertyAttribute("longDatatypeColumnSize")]
[ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
public int LongDatatypeColumnSize { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[ConfigurationPropertyAttribute(L"longDatatypeColumnSize")]
[ObsoleteAttribute(L"Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
public:
virtual property int LongDatatypeColumnSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_LongDatatypeColumnSize ()

/** @property */
public final void set_LongDatatypeColumnSize (int value)
JScript
public final function get LongDatatypeColumnSize () : int

public final function set LongDatatypeColumnSize (value : int)

Property Value

The maximum size in bytes of an Oracle long data type column.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.MaxOutputAssociativeArrayElements Property
[image]

Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.MaxOutputAssociativeArrayElements

instance.MaxOutputAssociativeArrayElements = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<ConfigurationPropertyAttribute("maxOutputAssociativeArrayElements")> _
Public Property MaxOutputAssociativeArrayElements As Integer
C#
[CategoryAttribute("BufferManagement")]
[ConfigurationPropertyAttribute("maxOutputAssociativeArrayElements")]
public int MaxOutputAssociativeArrayElements { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[ConfigurationPropertyAttribute(L"maxOutputAssociativeArrayElements")]
public:
virtual property int MaxOutputAssociativeArrayElements {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxOutputAssociativeArrayElements ()

/** @property */
public final void set_MaxOutputAssociativeArrayElements (int value)
JScript
public final function get MaxOutputAssociativeArrayElements () : int

public final function set MaxOutputAssociativeArrayElements (value : int)

Property Value

The size of the associate array that the adapter creates when performing operations that return an associative array in the response.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.MaxPoolSize Property
[image]

Gets or sets the maximum number of connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.MaxPoolSize

instance.MaxPoolSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("maxPoolSize")> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property MaxPoolSize As Integer
C#
[ConfigurationPropertyAttribute("maxPoolSize")]
[CategoryAttribute("OracleConnectionPool")]
public int MaxPoolSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"maxPoolSize")]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int MaxPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxPoolSize ()

/** @property */
public final void set_MaxPoolSize (int value)
JScript
public final function get MaxPoolSize () : int

public final function set MaxPoolSize (value : int)

Property Value

The maximum number of connections in the connection pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.MetadataPooling Property
[image]

Gets or sets whether data provider caches metadata information for executed queries.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.MetadataPooling

instance.MetadataPooling = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("metadataPooling")> _
<CategoryAttribute("BufferManagement")> _
Public Property MetadataPooling As Boolean
C#
[ConfigurationPropertyAttribute("metadataPooling")]
[CategoryAttribute("BufferManagement")]
public bool MetadataPooling { get; set; }
C++
[ConfigurationPropertyAttribute(L"metadataPooling")]
[CategoryAttribute(L"BufferManagement")]
public:
virtual property bool MetadataPooling {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_MetadataPooling ()

/** @property */
public final void set_MetadataPooling (boolean value)
JScript
public final function get MetadataPooling () : boolean

public final function set MetadataPooling (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the data provider caches metadata information for executed queries; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.MinPoolSize Property
[image]

Gets or sets the minimum number of connections in the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.MinPoolSize

instance.MinPoolSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("minPoolSize")> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property MinPoolSize As Integer
C#
[ConfigurationPropertyAttribute("minPoolSize")]
[CategoryAttribute("OracleConnectionPool")]
public int MinPoolSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"minPoolSize")]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property int MinPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MinPoolSize ()

/** @property */
public final void set_MinPoolSize (int value)
JScript
public final function get MinPoolSize () : int

public final function set MinPoolSize (value : int)

Property Value

The minimum number of connections in the connection pool.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.MlsSettings Property
[image]

Gets or sets the Multiple Language System Settings configuration element.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As MlsSettings

value = instance.MlsSettings

instance.MlsSettings = value

Syntax

Visual Basic
<CategoryAttribute("Multi Language Support")> _
<ConfigurationPropertyAttribute("mlsSettings")> _
Public Property MlsSettings As MlsSettings
C#
[CategoryAttribute("Multi Language Support")]
[ConfigurationPropertyAttribute("mlsSettings")]
public MlsSettings MlsSettings { get; set; }
C++
[CategoryAttribute(L"Multi Language Support")]
[ConfigurationPropertyAttribute(L"mlsSettings")]
public:
virtual property MlsSettings^ MlsSettings {
    MlsSettings^ get () sealed;
    void set (MlsSettings^ value) sealed;
}
J#
/** @property */
public final MlsSettings get_MlsSettings ()

/** @property */
public final void set_MlsSettings (MlsSettings value)
JScript
public final function get MlsSettings () : MlsSettings

public final function set MlsSettings (value : MlsSettings)

Property Value

The Multiple Language System Settings configuration element.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.NotificationPort Property
[image]

Gets or sets the port number that must open to listen for database change notification from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.NotificationPort

instance.NotificationPort = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("notificationPort")> _
<CategoryAttribute("Notification")> _
<BindingPropertyDirectionAttribute(True, False)> _
Public Property NotificationPort As Integer
C#
[ConfigurationPropertyAttribute("notificationPort")]
[CategoryAttribute("Notification")]
[BindingPropertyDirectionAttribute(true, false)]
public int NotificationPort { get; set; }
C++
[ConfigurationPropertyAttribute(L"notificationPort")]
[CategoryAttribute(L"Notification")]
[BindingPropertyDirectionAttribute(true, false)]
public:
virtual property int NotificationPort {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_NotificationPort ()

/** @property */
public final void set_NotificationPort (int value)
JScript
public final function get NotificationPort () : int

public final function set NotificationPort (value : int)

Property Value

The port number that must open to listen for database change notification from Oracle database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.NotificationStatement Property
[image]

Gets or sets the SELECT statement used to register for getting notifications from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.NotificationStatement

instance.NotificationStatement = value

Syntax

Visual Basic
<CategoryAttribute("Notification")> _
<ConfigurationPropertyAttribute("notificationStatement")> _
<BindingPropertyDirectionAttribute(True, False)> _
Public Property NotificationStatement As String
C#
[CategoryAttribute("Notification")]
[ConfigurationPropertyAttribute("notificationStatement")]
[BindingPropertyDirectionAttribute(true, false)]
public string NotificationStatement { get; set; }
C++
[CategoryAttribute(L"Notification")]
[ConfigurationPropertyAttribute(L"notificationStatement")]
[BindingPropertyDirectionAttribute(true, false)]
public:
virtual property String^ NotificationStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_NotificationStatement ()

/** @property */
public final void set_NotificationStatement (String value)
JScript
public final function get NotificationStatement () : String

public final function set NotificationStatement (value : String)

Property Value

The SELECT statement used to register for getting notifications from Oracle database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.NotifyOnListenerStart Property
[image]

Gets or sets whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.NotifyOnListenerStart

instance.NotifyOnListenerStart = value

Syntax

Visual Basic
<CategoryAttribute("Notification")> _
<ConfigurationPropertyAttribute("notifyOnListenerStart")> _
<BindingPropertyDirectionAttribute(True, False)> _
Public Property NotifyOnListenerStart As Boolean
C#
[CategoryAttribute("Notification")]
[ConfigurationPropertyAttribute("notifyOnListenerStart")]
[BindingPropertyDirectionAttribute(true, false)]
public bool NotifyOnListenerStart { get; set; }
C++
[CategoryAttribute(L"Notification")]
[ConfigurationPropertyAttribute(L"notifyOnListenerStart")]
[BindingPropertyDirectionAttribute(true, false)]
public:
virtual property bool NotifyOnListenerStart {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_NotifyOnListenerStart ()

/** @property */
public final void set_NotifyOnListenerStart (boolean value)
JScript
public final function get NotifyOnListenerStart () : boolean

public final function set NotifyOnListenerStart (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.OracleConnectionClientId Property
[image]

Gets or sets the Oracle connection client identifier.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.OracleConnectionClientId

instance.OracleConnectionClientId = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleConnectionClientId")> _
<CategoryAttribute("Debug")> _
Public Property OracleConnectionClientId As String
C#
[ConfigurationPropertyAttribute("oracleConnectionClientId")]
[CategoryAttribute("Debug")]
public string OracleConnectionClientId { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleConnectionClientId")]
[CategoryAttribute(L"Debug")]
public:
virtual property String^ OracleConnectionClientId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleConnectionClientId ()

/** @property */
public final void set_OracleConnectionClientId (String value)
JScript
public final function get OracleConnectionClientId () : String

public final function set OracleConnectionClientId (value : String)

Property Value

The Oracle connection client identifier.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.OracleEBSOrganizationId Property
[image]

Gets or sets the Oracle EBS organization identifier.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.OracleEBSOrganizationId

instance.OracleEBSOrganizationId = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleEBSOrganizationId")> _
<CategoryAttribute("OracleEBS")> _
Public Property OracleEBSOrganizationId As String
C#
[ConfigurationPropertyAttribute("oracleEBSOrganizationId")]
[CategoryAttribute("OracleEBS")]
public string OracleEBSOrganizationId { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleEBSOrganizationId")]
[CategoryAttribute(L"OracleEBS")]
public:
virtual property String^ OracleEBSOrganizationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleEBSOrganizationId ()

/** @property */
public final void set_OracleEBSOrganizationId (String value)
JScript
public final function get OracleEBSOrganizationId () : String

public final function set OracleEBSOrganizationId (value : String)

Property Value

The Oracle EBS organization identifier.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.OracleEBSResponsibilityKey Property
[image]

Gets or sets the Oracle EBS responsibility key.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.OracleEBSResponsibilityKey

instance.OracleEBSResponsibilityKey = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleEBSResponsibilityKey")> _
<CategoryAttribute("OracleEBS")> _
Public Property OracleEBSResponsibilityKey As String
C#
[ConfigurationPropertyAttribute("oracleEBSResponsibilityKey")]
[CategoryAttribute("OracleEBS")]
public string OracleEBSResponsibilityKey { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleEBSResponsibilityKey")]
[CategoryAttribute(L"OracleEBS")]
public:
virtual property String^ OracleEBSResponsibilityKey {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleEBSResponsibilityKey ()

/** @property */
public final void set_OracleEBSResponsibilityKey (String value)
JScript
public final function get OracleEBSResponsibilityKey () : String

public final function set OracleEBSResponsibilityKey (value : String)

Property Value

The Oracle EBS responsibility key.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.OracleEBSResponsibilityName Property
[image]

Gets or sets the Oracle EBS responsibility name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.OracleEBSResponsibilityName

instance.OracleEBSResponsibilityName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleEBSResponsibilityName")> _
<CategoryAttribute("OracleEBS")> _
Public Property OracleEBSResponsibilityName As String
C#
[ConfigurationPropertyAttribute("oracleEBSResponsibilityName")]
[CategoryAttribute("OracleEBS")]
public string OracleEBSResponsibilityName { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleEBSResponsibilityName")]
[CategoryAttribute(L"OracleEBS")]
public:
virtual property String^ OracleEBSResponsibilityName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleEBSResponsibilityName ()

/** @property */
public final void set_OracleEBSResponsibilityName (String value)
JScript
public final function get OracleEBSResponsibilityName () : String

public final function set OracleEBSResponsibilityName (value : String)

Property Value

The Oracle EBS responsibility name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.OraclePassword Property
[image]

Gets or sets the Oracle password.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.OraclePassword

instance.OraclePassword = value

Syntax

Visual Basic
<PasswordPropertyTextAttribute(True)> _
<CategoryAttribute("OracleEBS")> _
<ConfigurationPropertyAttribute("oraclePassword")> _
Public Property OraclePassword As String
C#
[PasswordPropertyTextAttribute(true)]
[CategoryAttribute("OracleEBS")]
[ConfigurationPropertyAttribute("oraclePassword")]
public string OraclePassword { get; set; }
C++
[PasswordPropertyTextAttribute(true)]
[CategoryAttribute(L"OracleEBS")]
[ConfigurationPropertyAttribute(L"oraclePassword")]
public:
virtual property String^ OraclePassword {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OraclePassword ()

/** @property */
public final void set_OraclePassword (String value)
JScript
public final function get OraclePassword () : String

public final function set OraclePassword (value : String)

Property Value

The Oracle password.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.OracleUserName Property
[image]

Gets or sets the Oracle user name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.OracleUserName

instance.OracleUserName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleUserName")> _
<CategoryAttribute("OracleEBS")> _
Public Property OracleUserName As String
C#
[ConfigurationPropertyAttribute("oracleUserName")]
[CategoryAttribute("OracleEBS")]
public string OracleUserName { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleUserName")]
[CategoryAttribute(L"OracleEBS")]
public:
virtual property String^ OracleUserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleUserName ()

/** @property */
public final void set_OracleUserName (String value)
JScript
public final function get OracleUserName () : String

public final function set OracleUserName (value : String)

Property Value

The Oracle user name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.PolledDataAvailableStatement Property
[image]

Gets or sets the polled data available statement.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.PolledDataAvailableStatement

instance.PolledDataAvailableStatement = value

Syntax

Visual Basic
<CategoryAttribute("Polling")> _
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("polledDataAvailableStatement")> _
Public Property PolledDataAvailableStatement As String
C#
[CategoryAttribute("Polling")]
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("polledDataAvailableStatement")]
public string PolledDataAvailableStatement { get; set; }
C++
[CategoryAttribute(L"Polling")]
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"polledDataAvailableStatement")]
public:
virtual property String^ PolledDataAvailableStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PolledDataAvailableStatement ()

/** @property */
public final void set_PolledDataAvailableStatement (String value)
JScript
public final function get PolledDataAvailableStatement () : String

public final function set PolledDataAvailableStatement (value : String)

Property Value

The polled data available statement.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.PollingAction Property
[image]

Gets or sets the action for the polling operation.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.PollingAction

instance.PollingAction = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
<ConfigurationPropertyAttribute("pollingAction")> _
Public Property PollingAction As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
[ConfigurationPropertyAttribute("pollingAction")]
public string PollingAction { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
[ConfigurationPropertyAttribute(L"pollingAction")]
public:
virtual property String^ PollingAction {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PollingAction ()

/** @property */
public final void set_PollingAction (String value)
JScript
public final function get PollingAction () : String

public final function set PollingAction (value : String)

Property Value

The action for the polling operation.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.PollingInput Property
[image]

Gets or sets the polling input.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.PollingInput

instance.PollingInput = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
<ConfigurationPropertyAttribute("pollingInput")> _
Public Property PollingInput As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
[ConfigurationPropertyAttribute("pollingInput")]
public string PollingInput { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
[ConfigurationPropertyAttribute(L"pollingInput")]
public:
virtual property String^ PollingInput {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PollingInput ()

/** @property */
public final void set_PollingInput (String value)
JScript
public final function get PollingInput () : String

public final function set PollingInput (value : String)

Property Value

The polling input.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.PollingInterval Property
[image]

Gets or sets the transacted polling interval, that is, the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.PollingInterval

instance.PollingInterval = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
<ConfigurationPropertyAttribute("pollingInterval")> _
Public Property PollingInterval As Integer
C#
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
[ConfigurationPropertyAttribute("pollingInterval")]
public int PollingInterval { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
[ConfigurationPropertyAttribute(L"pollingInterval")]
public:
virtual property int PollingInterval {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_PollingInterval ()

/** @property */
public final void set_PollingInterval (int value)
JScript
public final function get PollingInterval () : int

public final function set PollingInterval (value : int)

Property Value

The transacted polling interval.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.PollWhileDataFound Property
[image]

Gets or sets whether the specified object continuously poll data when it is available.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.PollWhileDataFound

instance.PollWhileDataFound = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Polling")> _
<ConfigurationPropertyAttribute("pollWhileDataFound")> _
Public Property PollWhileDataFound As Boolean
C#
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Polling")]
[ConfigurationPropertyAttribute("pollWhileDataFound")]
public bool PollWhileDataFound { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Polling")]
[ConfigurationPropertyAttribute(L"pollWhileDataFound")]
public:
virtual property bool PollWhileDataFound {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_PollWhileDataFound ()

/** @property */
public final void set_PollWhileDataFound (boolean value)
JScript
public final function get PollWhileDataFound () : boolean

public final function set PollWhileDataFound (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the specified object continuously poll data when it is available; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.PostPollStatement Property
[image]

Gets or sets the PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.PostPollStatement

instance.PostPollStatement = value

Syntax

Visual Basic
<CategoryAttribute("Polling")> _
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("postPollStatement")> _
Public Property PostPollStatement As String
C#
[CategoryAttribute("Polling")]
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("postPollStatement")]
public string PostPollStatement { get; set; }
C++
[CategoryAttribute(L"Polling")]
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"postPollStatement")]
public:
virtual property String^ PostPollStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PostPollStatement ()

/** @property */
public final void set_PostPollStatement (String value)
JScript
public final function get PostPollStatement () : String

public final function set PostPollStatement (value : String)

Property Value

The PL/SQL block that is executed after the polling statement.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.SkipNilNodes Property
[image]

Gets or sets whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.SkipNilNodes

instance.SkipNilNodes = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("skipNilNodes")> _
<CategoryAttribute("Run Time Behavior")> _
Public Property SkipNilNodes As Boolean
C#
[ConfigurationPropertyAttribute("skipNilNodes")]
[CategoryAttribute("Run Time Behavior")]
public bool SkipNilNodes { get; set; }
C++
[ConfigurationPropertyAttribute(L"skipNilNodes")]
[CategoryAttribute(L"Run Time Behavior")]
public:
virtual property bool SkipNilNodes {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_SkipNilNodes ()

/** @property */
public final void set_SkipNilNodes (boolean value)
JScript
public final function get SkipNilNodes () : boolean

public final function set SkipNilNodes (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the nil node is skipped; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.StatementCachePurge Property
[image]

Gets or sets whether the data provider statement cache associated when a connection is purged.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.StatementCachePurge

instance.StatementCachePurge = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<ConfigurationPropertyAttribute("statementCachePurge")> _
Public Property StatementCachePurge As Boolean
C#
[CategoryAttribute("BufferManagement")]
[ConfigurationPropertyAttribute("statementCachePurge")]
public bool StatementCachePurge { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[ConfigurationPropertyAttribute(L"statementCachePurge")]
public:
virtual property bool StatementCachePurge {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_StatementCachePurge ()

/** @property */
public final void set_StatementCachePurge (boolean value)
JScript
public final function get StatementCachePurge () : boolean

public final function set StatementCachePurge (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the data provider statement cache associated with a connection is purged; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.StatementCacheSize Property
[image]

Gets or sets the maximum number of statements that can be cached by each data provider connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Integer

value = instance.StatementCacheSize

instance.StatementCacheSize = value

Syntax

Visual Basic
<CategoryAttribute("BufferManagement")> _
<ConfigurationPropertyAttribute("statementCacheSize")> _
Public Property StatementCacheSize As Integer
C#
[CategoryAttribute("BufferManagement")]
[ConfigurationPropertyAttribute("statementCacheSize")]
public int StatementCacheSize { get; set; }
C++
[CategoryAttribute(L"BufferManagement")]
[ConfigurationPropertyAttribute(L"statementCacheSize")]
public:
virtual property int StatementCacheSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_StatementCacheSize ()

/** @property */
public final void set_StatementCacheSize (int value)
JScript
public final function get StatementCacheSize () : int

public final function set StatementCacheSize (value : int)

Property Value

The maximum number of statements that can be cached by each data provider connection.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.UseAmbientTransaction Property
[image]

Gets or sets whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.UseAmbientTransaction

instance.UseAmbientTransaction = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("useAmbientTransaction")> _
Public Property UseAmbientTransaction As Boolean
C#
[ConfigurationPropertyAttribute("useAmbientTransaction")]
public bool UseAmbientTransaction { get; set; }
C++
[ConfigurationPropertyAttribute(L"useAmbientTransaction")]
public:
virtual property bool UseAmbientTransaction {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_UseAmbientTransaction ()

/** @property */
public final void set_UseAmbientTransaction (boolean value)
JScript
public final function get UseAmbientTransaction () : boolean

public final function set UseAmbientTransaction (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the Oracle Database adapter performs the operations using the transaction context provided by the caller; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.UseOracleConnectionPool Property
[image]

Gets or sets whether to use the Oracle connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.UseOracleConnectionPool

instance.UseOracleConnectionPool = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("useOracleConnectionPool")> _
<CategoryAttribute("OracleConnectionPool")> _
Public Property UseOracleConnectionPool As Boolean
C#
[ConfigurationPropertyAttribute("useOracleConnectionPool")]
[CategoryAttribute("OracleConnectionPool")]
public bool UseOracleConnectionPool { get; set; }
C++
[ConfigurationPropertyAttribute(L"useOracleConnectionPool")]
[CategoryAttribute(L"OracleConnectionPool")]
public:
virtual property bool UseOracleConnectionPool {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_UseOracleConnectionPool ()

/** @property */
public final void set_UseOracleConnectionPool (boolean value)
JScript
public final function get UseOracleConnectionPool () : boolean

public final function set UseOracleConnectionPool (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if use the Oracle connection pool; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.UserAssembliesLoadPath Property
[image]

Gets or sets the path where the assemblies will be loaded.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As String

value = instance.UserAssembliesLoadPath

instance.UserAssembliesLoadPath = value

Syntax

Visual Basic
<CategoryAttribute("UDT .NET Type Generation - Run Time")> _
<ConfigurationPropertyAttribute("userAssembliesLoadPath")> _
Public Property UserAssembliesLoadPath As String
C#
[CategoryAttribute("UDT .NET Type Generation - Run Time")]
[ConfigurationPropertyAttribute("userAssembliesLoadPath")]
public string UserAssembliesLoadPath { get; set; }
C++
[CategoryAttribute(L"UDT .NET Type Generation - Run Time")]
[ConfigurationPropertyAttribute(L"userAssembliesLoadPath")]
public:
virtual property String^ UserAssembliesLoadPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_UserAssembliesLoadPath ()

/** @property */
public final void set_UserAssembliesLoadPath (String value)
JScript
public final function get UserAssembliesLoadPath () : String

public final function set UserAssembliesLoadPath (value : String)

Property Value

The path where the assemblies will be loaded.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingConfigurationElement.UseSchemaInNameSpace Property
[image]

Gets or sets whether the schema name is included in the xml namespace for operations and their associated types.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingConfigurationElement
Dim value As Boolean

value = instance.UseSchemaInNameSpace

instance.UseSchemaInNameSpace = value

Syntax

Visual Basic
<CategoryAttribute("Metadata")> _
<ConfigurationPropertyAttribute("useSchemaInNameSpace")> _
Public Property UseSchemaInNameSpace As Boolean
C#
[CategoryAttribute("Metadata")]
[ConfigurationPropertyAttribute("useSchemaInNameSpace")]
public bool UseSchemaInNameSpace { get; set; }
C++
[CategoryAttribute(L"Metadata")]
[ConfigurationPropertyAttribute(L"useSchemaInNameSpace")]
public:
virtual property bool UseSchemaInNameSpace {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_UseSchemaInNameSpace ()

/** @property */
public final void set_UseSchemaInNameSpace (boolean value)
JScript
public final function get UseSchemaInNameSpace () : boolean

public final function set UseSchemaInNameSpace (value : boolean)

Property Value

<languageKeyword>True</languageKeyword> if the schema name is included in the xml namespace for operations and their associated types; otherwise, <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingConfigurationElement Class
OracleEBSBindingConfigurationElement Members


OracleEBSBindingElementExtensionElement Class
See Also Members
[image]

Enables the configuration of the Oracle E-Business Suite Adapter Binding from an application configuration file.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")> _
Public Class OracleEBSBindingElementExtensionElement
    Inherits BindingElementExtensionElement
C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")]
public class OracleEBSBindingElementExtensionElement : BindingElementExtensionElement
C++
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1705:LongAcronymsShouldBePascalCased")]
public ref class OracleEBSBindingElementExtensionElement : public BindingElementExtensionElement
J#
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased") */
public class OracleEBSBindingElementExtensionElement extends BindingElementExtensionElement
JScript
SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")
public class OracleEBSBindingElementExtensionElement extends BindingElementExtensionElement

Remarks

The Microsoft BizTalk Adapter for Oracle E-Business Suite surfaces several binding properties. By setting these properties, you can control some of the adapter's behavior while interfacing with Oracle E-Business Suite or with the Oracle database.

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BindingElementExtensionElement
Microsoft.Adapters.OracleEBS.OracleEBSBindingElementExtensionElement

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement Members
See Also Constructors Methods Properties
[image]

Enables the configuration of the Oracle E-Business Suite Adapter Binding from an application configuration file.

The following tables list the members exposed by the OracleEBSBindingElementExtensionElement type.

Public Constructors

Name | Description
OracleEBSBindingElementExtensionElement | Initializes a new instance of the OracleEBSBindingElementExtensionElement class.
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets a value that indicates whether the Oracle E-Business Suite connection URI is allowed to contain credentials.
public property | ApplicationShortName | Gets or sets the short name for an Oracle E-Business Suite application.
public property | BindingElementType | Overridden. Gets the binding element type.
public property | ClientCredentialType | Gets or sets the sets of credentials to specify when establishing a connection to Oracle E-Business Suite. The possible values are Database or EBusiness.
public property | ConfigurationElementName | (inherited from ServiceModelExtensionElement)
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | DataFetchSize | Gets or sets the amount of data in bytes the ODP.NET fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EnableBizTalkCompatibilityMode | Gets or sets a value that indicates how the adapter generates schema for a DataSet.
public property | EnablePerformanceCounters | Gets or sets a value that indicates whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets a value that indicates whether to enable or disable safe typing, that is, how the adapter surfaces certain Oracle data types.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates, while generating metadata, containing all UDTs that are used in the metadata.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the manner how the adapter receives messages from Oracle E-Business Suite. The possible values are Polling or Notification.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the ODP.NET connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in an ODP.NET connection pool.
public property | MetadataPooling | Gets or sets a value that indicates whether ODP.NET caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in an ODP.NET connection pool.
public property | MlsSettings | Gets or sets the settings for multi-language support (MLS) specific options.
public property | NotificationPort | Gets or sets the port number that ODP.NET must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets a value that indicates whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.
public property | OracleConnectionClientId | Gets or sets the client identifier (ID) for the connection used by the adapter to connect to Oracle.
public property | OracleEBSOrganizationId | Gets or sets the organization ID to which an Oracle E-Business Suite application belongs.
public property | OracleEBSResponsibilityKey | Gets or sets the responsibility key associated with the Oracle E-Business Suite user.
public property | OracleEBSResponsibilityName | Gets or sets the name of the responsibility associated with the Oracle E-Business Suite user.
public property | OraclePassword | Gets or sets the password credential for an Oracle database user or an Oracle E-Business Suite user.
public property | OracleUserName | Gets or sets the user name credential for an Oracle database user or an Oracle E-Business Suite user.
public property | PolledDataAvailableStatement | Gets or sets the SELECT statement executed to determine whether any data is available for polling for a specific table.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling statement.
public property | PollingInterval | Gets or sets the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets a value that indicates whether the Oracle Database adapter ignores the polling interval and continuously polls the Oracle database, if data is available in the table being polled.
public property | PostPollStatement | Gets or sets a PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | SkipNilNodes | Gets or sets a value that indicates whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets a value that indicates whether the ODP.NET statement cache associated with a connection is purged when the connection is returned to the connection pool.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each ODP.NET connection.
public property | UseAmbientTransaction | Gets or sets a value that indicates whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets a value that indicates whether to use the ODP.NET connection pool.
public property | UserAssembliesLoadPath | Gets or sets the name of the DLLs, separated by a semi-colon, which the adapter creates while generating metadata.
public property | UseSchemaInNameSpace | Gets or sets a value that indicates whether the schema name is included in the XML namespace for operations and their associated types.
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the collection of configuration properties.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | ApplyConfiguration | Overridden. Applies the configuration properties from the specified binding element to the adapter.
public method | CopyFrom | Overridden. Copies the configuration properties from the specified configuration element.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | CreateBindingElement | Overridden. Creates the adapter binding element for Oracle E-Business Suite.
protected method | Finalize | (inherited from Object)
protected method | InitializeFrom | Overridden. Initializes the adapter with the configuration properties with the specified binding element.
protected method | IsModified | Overridden. (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SerializeElement | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

See Also

Reference

OracleEBSBindingElementExtensionElement Class


OracleEBSBindingElementExtensionElement Constructor
[image]

Initializes a new instance of the OracleEBSBindingElementExtensionElement class.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New OracleEBSBindingElementExtensionElement

Syntax

Visual Basic
Public Sub New
C#
public OracleEBSBindingElementExtensionElement ()
C++
public:
OracleEBSBindingElementExtensionElement ()
J#
public OracleEBSBindingElementExtensionElement ()
JScript
public function OracleEBSBindingElementExtensionElement ()

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | ApplyConfiguration | Overridden. Applies the configuration properties from the specified binding element to the adapter.
public method | CopyFrom | Overridden. Copies the configuration properties from the specified configuration element.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | CreateBindingElement | Overridden. Creates the adapter binding element for Oracle E-Business Suite.
protected method | Finalize | (inherited from Object)
protected method | InitializeFrom | Overridden. Initializes the adapter with the configuration properties with the specified binding element.
protected method | IsModified | Overridden. (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SerializeElement | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

See Also

Reference

OracleEBSBindingElementExtensionElement Class


OracleEBSBindingElementExtensionElement.ApplyConfiguration Method
[image]

Applies the configuration properties from the specified binding element to the adapter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim bindingElement As BindingElement

instance.ApplyConfiguration(bindingElement)

Syntax

Visual Basic
Public Overrides Sub ApplyConfiguration ( _
    bindingElement As BindingElement _
)
C#
public override void ApplyConfiguration (
    BindingElement bindingElement
)
C++
public:
virtual void ApplyConfiguration (
    BindingElement^ bindingElement
) override
J#
public void ApplyConfiguration (
    BindingElement bindingElement
)
JScript
public override function ApplyConfiguration (
    bindingElement : BindingElement
)

Parameters

bindingElement

The specified binding element.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.CopyFrom Method
[image]

Copies the configuration properties from the specified configuration element.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)

Syntax

Visual Basic
Public Overrides Sub CopyFrom ( _
    from As ServiceModelExtensionElement _
)
C#
public override void CopyFrom (
    ServiceModelExtensionElement from
)
C++
public:
virtual void CopyFrom (
    ServiceModelExtensionElement^ from
) override
J#
public void CopyFrom (
    ServiceModelExtensionElement from
)
JScript
public override function CopyFrom (
    from : ServiceModelExtensionElement
)

Parameters

from

The specified configuration element.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.CreateBindingElement Method
[image]

Creates the adapter binding element for Oracle E-Business Suite.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim returnValue As BindingElement

returnValue = Me.CreateBindingElement

Syntax

Visual Basic
Protected Overrides Function CreateBindingElement As BindingElement
C#
protected override BindingElement CreateBindingElement ()
C++
protected:
virtual BindingElement^ CreateBindingElement () override
J#
protected BindingElement CreateBindingElement ()
JScript
protected override function CreateBindingElement () : BindingElement

Return Value

The adapter binding element for Oracle E-Business Suite.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.InitializeFrom Method
[image]

Initializes the adapter with the configuration properties with the specified binding element.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim bindingElement As BindingElement

Me.InitializeFrom(bindingElement)

Syntax

Visual Basic
Protected Overrides Sub InitializeFrom ( _
    bindingElement As BindingElement _
)
C#
protected override void InitializeFrom (
    BindingElement bindingElement
)
C++
protected:
virtual void InitializeFrom (
    BindingElement^ bindingElement
) override
J#
protected void InitializeFrom (
    BindingElement bindingElement
)
JScript
protected override function InitializeFrom (
    bindingElement : BindingElement
)

Parameters

bindingElement

The specified binding element.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | AcceptCredentialsInUri | Gets or sets a value that indicates whether the Oracle E-Business Suite connection URI is allowed to contain credentials.
public property | ApplicationShortName | Gets or sets the short name for an Oracle E-Business Suite application.
public property | BindingElementType | Overridden. Gets the binding element type.
public property | ClientCredentialType | Gets or sets the sets of credentials to specify when establishing a connection to Oracle E-Business Suite. The possible values are Database or EBusiness.
public property | ConfigurationElementName | (inherited from ServiceModelExtensionElement)
public property | ConnectionLifetime | Gets or sets the maximum duration in seconds of a connection.
public property | DataFetchSize | Gets or sets the amount of data in bytes the ODP.NET fetches from the result set in one server round trip.
public property | DecrPoolSize | Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.
public property | ElementInformation | (inherited from ConfigurationElement)
public property | EnableBizTalkCompatibilityMode | Gets or sets a value that indicates how the adapter generates schema for a DataSet.
public property | EnablePerformanceCounters | Gets or sets a value that indicates whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.
public property | EnableSafeTyping | Gets or sets a value that indicates whether to enable or disable safe typing, that is, how the adapter surfaces certain Oracle data types.
public property | GeneratedUserTypesAssemblyFilePath | Gets or sets the name and path of the DLL that the adapter generates, while generating metadata, containing all UDTs that are used in the metadata.
public property | GeneratedUserTypesAssemblyKeyFilePath | Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.
public property | InboundOperationType | Gets or sets the manner how the adapter receives messages from Oracle E-Business Suite. The possible values are Polling or Notification.
public property | IncrPoolSize | Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the ODP.NET connection pool.
public property | InsertBatchSize | Gets or sets the batch size for multiple record Insert operations.
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | LongDatatypeColumnSize | Gets or sets the maximum size in bytes of an Oracle long data type column. Obsolete.
public property | MaxOutputAssociativeArrayElements | Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.
public property | MaxPoolSize | Gets or sets the maximum number of connections in an ODP.NET connection pool.
public property | MetadataPooling | Gets or sets a value that indicates whether ODP.NET caches metadata information for executed queries.
public property | MinPoolSize | Gets or sets the minimum number of connections in an ODP.NET connection pool.
public property | MlsSettings | Gets or sets the settings for multi-language support (MLS) specific options.
public property | NotificationPort | Gets or sets the port number that ODP.NET must open to listen for database change notification from Oracle database.
public property | NotificationStatement | Gets or sets the SELECT statement used to register for getting notifications from Oracle database.
public property | NotifyOnListenerStart | Gets or sets a value that indicates whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.
public property | OracleConnectionClientId | Gets or sets the client identifier (ID) for the connection used by the adapter to connect to Oracle.
public property | OracleEBSOrganizationId | Gets or sets the organization ID to which an Oracle E-Business Suite application belongs.
public property | OracleEBSResponsibilityKey | Gets or sets the responsibility key associated with the Oracle E-Business Suite user.
public property | OracleEBSResponsibilityName | Gets or sets the name of the responsibility associated with the Oracle E-Business Suite user.
public property | OraclePassword | Gets or sets the password credential for an Oracle database user or an Oracle E-Business Suite user.
public property | OracleUserName | Gets or sets the user name credential for an Oracle database user or an Oracle E-Business Suite user.
public property | PolledDataAvailableStatement | Gets or sets the SELECT statement executed to determine whether any data is available for polling for a specific table.
public property | PollingAction | Gets or sets the action for the polling operation.
public property | PollingInput | Gets or sets the polling statement.
public property | PollingInterval | Gets or sets the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.
public property | PollWhileDataFound | Gets or sets a value that indicates whether the Oracle Database adapter ignores the polling interval and continuously polls the Oracle database, if data is available in the table being polled.
public property | PostPollStatement | Gets or sets a PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.
public property | SkipNilNodes | Gets or sets a value that indicates whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.
public property | StatementCachePurge | Gets or sets a value that indicates whether the ODP.NET statement cache associated with a connection is purged when the connection is returned to the connection pool.
public property | StatementCacheSize | Gets or sets the maximum number of statements that can be cached by each ODP.NET connection.
public property | UseAmbientTransaction | Gets or sets a value that indicates whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.
public property | UseOracleConnectionPool | Gets or sets a value that indicates whether to use the ODP.NET connection pool.
public property | UserAssembliesLoadPath | Gets or sets the name of the DLLs, separated by a semi-colon, which the adapter creates while generating metadata.
public property | UseSchemaInNameSpace | Gets or sets a value that indicates whether the schema name is included in the XML namespace for operations and their associated types.

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
protected property | Properties | Overridden. Gets the collection of configuration properties.

See Also

Reference

OracleEBSBindingElementExtensionElement Class


OracleEBSBindingElementExtensionElement.AcceptCredentialsInUri Property
[image]

Gets or sets a value that indicates whether the Oracle E-Business Suite connection URI is allowed to contain credentials.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.AcceptCredentialsInUri

instance.AcceptCredentialsInUri = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("acceptCredentialsInUri", DefaultValue:=False)> _
Public Property AcceptCredentialsInUri As Boolean
C#
[ConfigurationPropertyAttribute("acceptCredentialsInUri", DefaultValue=false)]
public bool AcceptCredentialsInUri { get; set; }
C++
[ConfigurationPropertyAttribute(L"acceptCredentialsInUri", DefaultValue=false)]
public:
virtual property bool AcceptCredentialsInUri {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_AcceptCredentialsInUri ()

/** @property */
public final void set_AcceptCredentialsInUri (boolean value)
JScript
public final function get AcceptCredentialsInUri () : boolean

public final function set AcceptCredentialsInUri (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the Oracle E-Business Suite connection URI is allowed to contain credentials, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>false</languageKeyword>.

Remarks

By default, the Oracle Database adapter throws an exception when the Oracle database credentials are specified in the connection URI. This is because these credentials are represented as plain text in the connection URI, and this poses a security risk.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.ApplicationShortName Property
[image]

Gets or sets the short name for an Oracle E-Business Suite application.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.ApplicationShortName

instance.ApplicationShortName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("applicationShortName", DefaultValue:=Nothing)> _
Public Property ApplicationShortName As String
C#
[ConfigurationPropertyAttribute("applicationShortName", DefaultValue=null)]
public string ApplicationShortName { get; set; }
C++
[ConfigurationPropertyAttribute(L"applicationShortName", DefaultValue=nullptr)]
public:
virtual property String^ ApplicationShortName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_ApplicationShortName ()

/** @property */
public final void set_ApplicationShortName (String value)
JScript
public final function get ApplicationShortName () : String

public final function set ApplicationShortName (value : String)

Property Value

The short name for an Oracle E-Business Suite application.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.BindingElementType Property
[image]

Gets the binding element type.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Type

value = instance.BindingElementType

Syntax

Visual Basic
Public Overrides ReadOnly Property BindingElementType As Type
C#
public override Type BindingElementType { get; }
C++
public:
virtual property Type^ BindingElementType {
    Type^ get () override;
}
J#
/** @property */
public Type get_BindingElementType ()
JScript
public override function get BindingElementType () : Type

Property Value

The binding element type.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.ClientCredentialType Property
[image]

Gets or sets the sets of credentials to specify when establishing a connection to Oracle E-Business Suite. The possible values are Database or EBusiness.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As ClientCredential

value = instance.ClientCredentialType

instance.ClientCredentialType = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("clientCredentialType", DefaultValue:=ClientCredential.Database)> _
Public Property ClientCredentialType As ClientCredential
C#
[ConfigurationPropertyAttribute("clientCredentialType", DefaultValue=ClientCredential.Database)]
public ClientCredential ClientCredentialType { get; set; }
C++
[ConfigurationPropertyAttribute(L"clientCredentialType", DefaultValue=ClientCredential::Database)]
public:
virtual property ClientCredential ClientCredentialType {
    ClientCredential get () sealed;
    void set (ClientCredential value) sealed;
}
J#
/** @property */
public final ClientCredential get_ClientCredentialType ()

/** @property */
public final void set_ClientCredentialType (ClientCredential value)
JScript
public final function get ClientCredentialType () : ClientCredential

public final function set ClientCredentialType (value : ClientCredential)

Property Value

The sets of credentials to specify when establishing a connection to Oracle E-Business Suite. The default is Database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.ConnectionLifetime Property
[image]

Gets or sets the maximum duration in seconds of a connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.ConnectionLifetime

instance.ConnectionLifetime = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("connectionLifetime", DefaultValue:=0)> _
Public Property ConnectionLifetime As Integer
C#
[ConfigurationPropertyAttribute("connectionLifetime", DefaultValue=0)]
public int ConnectionLifetime { get; set; }
C++
[ConfigurationPropertyAttribute(L"connectionLifetime", DefaultValue=0)]
public:
virtual property int ConnectionLifetime {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_ConnectionLifetime ()

/** @property */
public final void set_ConnectionLifetime (int value)
JScript
public final function get ConnectionLifetime () : int

public final function set ConnectionLifetime (value : int)

Property Value

The maximum duration in seconds of a connection. The default is zero.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.DataFetchSize Property
[image]

Gets or sets the amount of data in bytes the ODP.NET fetches from the result set in one server round trip.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Long

value = instance.DataFetchSize

instance.DataFetchSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("dataFetchSize", DefaultValue:=65536)> _
Public Property DataFetchSize As Long
C#
[ConfigurationPropertyAttribute("dataFetchSize", DefaultValue=65536)]
public long DataFetchSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"dataFetchSize", DefaultValue=65536)]
public:
virtual property long long DataFetchSize {
    long long get () sealed;
    void set (long long value) sealed;
}
J#
/** @property */
public final long get_DataFetchSize ()

/** @property */
public final void set_DataFetchSize (long value)
JScript
public final function get DataFetchSize () : long

public final function set DataFetchSize (value : long)

Property Value

The amount of data in bytes the ODP.NET fetches from the result set in one server round trip. The default is 65536.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.DecrPoolSize Property
[image]

Gets or sets the number of connections that are closed when an excessive amount of established connections are not in use.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.DecrPoolSize

instance.DecrPoolSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("decrPoolSize", DefaultValue:=1)> _
Public Property DecrPoolSize As Integer
C#
[ConfigurationPropertyAttribute("decrPoolSize", DefaultValue=1)]
public int DecrPoolSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"decrPoolSize", DefaultValue=1)]
public:
virtual property int DecrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_DecrPoolSize ()

/** @property */
public final void set_DecrPoolSize (int value)
JScript
public final function get DecrPoolSize () : int

public final function set DecrPoolSize (value : int)

Property Value

The number of connections that are closed when an excessive amount of established connections are not in use. The default is one.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.EnableBizTalkCompatibilityMode Property
[image]

Gets or sets a value that indicates how the adapter generates schema for a DataSet.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.EnableBizTalkCompatibilityMode

instance.EnableBizTalkCompatibilityMode = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("enableBizTalkCompatibilityMode", DefaultValue:=True)> _
Public Property EnableBizTalkCompatibilityMode As Boolean
C#
[ConfigurationPropertyAttribute("enableBizTalkCompatibilityMode", DefaultValue=true)]
public bool EnableBizTalkCompatibilityMode { get; set; }
C++
[ConfigurationPropertyAttribute(L"enableBizTalkCompatibilityMode", DefaultValue=true)]
public:
virtual property bool EnableBizTalkCompatibilityMode {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnableBizTalkCompatibilityMode ()

/** @property */
public final void set_EnableBizTalkCompatibilityMode (boolean value)
JScript
public final function get EnableBizTalkCompatibilityMode () : boolean

public final function set EnableBizTalkCompatibilityMode (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if using the adapters from Biz Talk Server, otherwise <languageKeyword>false</languageKeyword>.

Remarks

When using the adapters from BizTalk Server, you must always set the property to True. When using the adapters from Visual Studio, you must always set the property to False.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.EnablePerformanceCounters Property
[image]

Gets or sets a value that indicates whether to enable the WCF LOB Adapter SDK performance counters and the Oracle Database adapter LOB Latency performance counter.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.EnablePerformanceCounters

instance.EnablePerformanceCounters = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("enablePerformanceCounters", DefaultValue:=False)> _
Public Property EnablePerformanceCounters As Boolean
C#
[ConfigurationPropertyAttribute("enablePerformanceCounters", DefaultValue=false)]
public bool EnablePerformanceCounters { get; set; }
C++
[ConfigurationPropertyAttribute(L"enablePerformanceCounters", DefaultValue=false)]
public:
virtual property bool EnablePerformanceCounters {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnablePerformanceCounters ()

/** @property */
public final void set_EnablePerformanceCounters (boolean value)
JScript
public final function get EnablePerformanceCounters () : boolean

public final function set EnablePerformanceCounters (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if performance counters is enabled, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.EnableSafeTyping Property
[image]

Gets or sets a value that indicates whether to enable or disable safe typing, that is, how the adapter surfaces certain Oracle data types.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.EnableSafeTyping

instance.EnableSafeTyping = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("enableSafeTyping", DefaultValue:=False)> _
Public Property EnableSafeTyping As Boolean
C#
[ConfigurationPropertyAttribute("enableSafeTyping", DefaultValue=false)]
public bool EnableSafeTyping { get; set; }
C++
[ConfigurationPropertyAttribute(L"enableSafeTyping", DefaultValue=false)]
public:
virtual property bool EnableSafeTyping {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_EnableSafeTyping ()

/** @property */
public final void set_EnableSafeTyping (boolean value)
JScript
public final function get EnableSafeTyping () : boolean

public final function set EnableSafeTyping (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the safe typing is enabled, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.GeneratedUserTypesAssemblyFilePath Property
[image]

Gets or sets the name and path of the DLL that the adapter generates, while generating metadata, containing all UDTs that are used in the metadata.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.GeneratedUserTypesAssemblyFilePath

instance.GeneratedUserTypesAssemblyFilePath = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("generatedUserTypesAssemblyFilePath", DefaultValue:=Nothing)> _
<BindingPropertyDirectionAttribute(False, False)> _
Public Property GeneratedUserTypesAssemblyFilePath As String
C#
[ConfigurationPropertyAttribute("generatedUserTypesAssemblyFilePath", DefaultValue=null)]
[BindingPropertyDirectionAttribute(false, false)]
public string GeneratedUserTypesAssemblyFilePath { get; set; }
C++
[ConfigurationPropertyAttribute(L"generatedUserTypesAssemblyFilePath", DefaultValue=nullptr)]
[BindingPropertyDirectionAttribute(false, false)]
public:
virtual property String^ GeneratedUserTypesAssemblyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_GeneratedUserTypesAssemblyFilePath ()

/** @property */
public final void set_GeneratedUserTypesAssemblyFilePath (String value)
JScript
public final function get GeneratedUserTypesAssemblyFilePath () : String

public final function set GeneratedUserTypesAssemblyFilePath (value : String)

Property Value

The name and path of the DLL that the adapter generates, while generating metadata, containing all UDTs that are used in the metadata.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.GeneratedUserTypesAssemblyKeyFilePath Property
[image]

Gets or sets the name and path of the key file that the adapter uses to create a strongly-typed assembly.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.GeneratedUserTypesAssemblyKeyFilePath

instance.GeneratedUserTypesAssemblyKeyFilePath = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(False, False)> _
<ConfigurationPropertyAttribute("generatedUserTypesAssemblyKeyFilePath", DefaultValue:=Nothing)> _
Public Property GeneratedUserTypesAssemblyKeyFilePath As String
C#
[BindingPropertyDirectionAttribute(false, false)]
[ConfigurationPropertyAttribute("generatedUserTypesAssemblyKeyFilePath", DefaultValue=null)]
public string GeneratedUserTypesAssemblyKeyFilePath { get; set; }
C++
[BindingPropertyDirectionAttribute(false, false)]
[ConfigurationPropertyAttribute(L"generatedUserTypesAssemblyKeyFilePath", DefaultValue=nullptr)]
public:
virtual property String^ GeneratedUserTypesAssemblyKeyFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_GeneratedUserTypesAssemblyKeyFilePath ()

/** @property */
public final void set_GeneratedUserTypesAssemblyKeyFilePath (String value)
JScript
public final function get GeneratedUserTypesAssemblyKeyFilePath () : String

public final function set GeneratedUserTypesAssemblyKeyFilePath (value : String)

Property Value

The name and path of the key file that the adapter uses to create a strongly-typed assembly.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.InboundOperationType Property
[image]

Gets or sets the manner how the adapter receives messages from Oracle E-Business Suite. The possible values are Polling or Notification.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As InboundOperation

value = instance.InboundOperationType

instance.InboundOperationType = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("inboundOperationType", DefaultValue:=InboundOperation.Polling)> _
<BindingPropertyDirectionAttribute(True, False)> _
Public Property InboundOperationType As InboundOperation
C#
[ConfigurationPropertyAttribute("inboundOperationType", DefaultValue=InboundOperation.Polling)]
[BindingPropertyDirectionAttribute(true, false)]
public InboundOperation InboundOperationType { get; set; }
C++
[ConfigurationPropertyAttribute(L"inboundOperationType", DefaultValue=InboundOperation::Polling)]
[BindingPropertyDirectionAttribute(true, false)]
public:
virtual property InboundOperation InboundOperationType {
    InboundOperation get () sealed;
    void set (InboundOperation value) sealed;
}
J#
/** @property */
public final InboundOperation get_InboundOperationType ()

/** @property */
public final void set_InboundOperationType (InboundOperation value)
JScript
public final function get InboundOperationType () : InboundOperation

public final function set InboundOperationType (value : InboundOperation)

Property Value

One of the enumeration values of InboundOperation. The default is Polling.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.IncrPoolSize Property
[image]

Gets or sets the number of new connections to be created when a new connection is requested and there are no available connections in the ODP.NET connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.IncrPoolSize

instance.IncrPoolSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("incrPoolSize", DefaultValue:=5)> _
Public Property IncrPoolSize As Integer
C#
[ConfigurationPropertyAttribute("incrPoolSize", DefaultValue=5)]
public int IncrPoolSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"incrPoolSize", DefaultValue=5)]
public:
virtual property int IncrPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_IncrPoolSize ()

/** @property */
public final void set_IncrPoolSize (int value)
JScript
public final function get IncrPoolSize () : int

public final function set IncrPoolSize (value : int)

Property Value

The number of new connections to be created when a new connection is requested and there are no available connections in the ODP.NET connection pool. The default is five.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.InsertBatchSize Property
[image]

Gets or sets the batch size for multiple record Insert operations.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.InsertBatchSize

instance.InsertBatchSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("insertBatchSize", DefaultValue:=20)> _
Public Property InsertBatchSize As Integer
C#
[ConfigurationPropertyAttribute("insertBatchSize", DefaultValue=20)]
public int InsertBatchSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"insertBatchSize", DefaultValue=20)]
public:
virtual property int InsertBatchSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_InsertBatchSize ()

/** @property */
public final void set_InsertBatchSize (int value)
JScript
public final function get InsertBatchSize () : int

public final function set InsertBatchSize (value : int)

Property Value

The batch size for multiple record Insert operations. The default is 20.

Remarks

The Oracle E-Business adapter batches the specified number of records into a single ODP.NET call. A well-chosen value for InsertBatchSize can greatly improve adapter performance for multiple record Insert operations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.LongDatatypeColumnSize Property
[image]

Gets or sets the maximum size in bytes of an Oracle long data type column.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.LongDatatypeColumnSize

instance.LongDatatypeColumnSize = value

Syntax

Visual Basic
<ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")> _
<ConfigurationPropertyAttribute("longDatatypeColumnSize", DefaultValue:=0)> _
Public Property LongDatatypeColumnSize As Integer
C#
[ObsoleteAttribute("Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
[ConfigurationPropertyAttribute("longDatatypeColumnSize", DefaultValue=0)]
public int LongDatatypeColumnSize { get; set; }
C++
[ObsoleteAttribute(L"Long data type is deprecated in Oracle. Refer to Oracle documentation for suggested alternatives")]
[ConfigurationPropertyAttribute(L"longDatatypeColumnSize", DefaultValue=0)]
public:
virtual property int LongDatatypeColumnSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_LongDatatypeColumnSize ()

/** @property */
public final void set_LongDatatypeColumnSize (int value)
JScript
public final function get LongDatatypeColumnSize () : int

public final function set LongDatatypeColumnSize (value : int)

Property Value

The maximum size in bytes of an Oracle long data type column.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.MaxOutputAssociativeArrayElements Property
[image]

Gets or sets the size of the associate array that the adapter creates when performing operations that return an associative array in the response.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.MaxOutputAssociativeArrayElements

instance.MaxOutputAssociativeArrayElements = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("maxOutputAssociativeArrayElements", DefaultValue:=32)> _
Public Property MaxOutputAssociativeArrayElements As Integer
C#
[ConfigurationPropertyAttribute("maxOutputAssociativeArrayElements", DefaultValue=32)]
public int MaxOutputAssociativeArrayElements { get; set; }
C++
[ConfigurationPropertyAttribute(L"maxOutputAssociativeArrayElements", DefaultValue=32)]
public:
virtual property int MaxOutputAssociativeArrayElements {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxOutputAssociativeArrayElements ()

/** @property */
public final void set_MaxOutputAssociativeArrayElements (int value)
JScript
public final function get MaxOutputAssociativeArrayElements () : int

public final function set MaxOutputAssociativeArrayElements (value : int)

Property Value

The size of the associate array. The default is 32.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.MaxPoolSize Property
[image]

Gets or sets the maximum number of connections in an ODP.NET connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.MaxPoolSize

instance.MaxPoolSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("maxPoolSize", DefaultValue:=100)> _
Public Property MaxPoolSize As Integer
C#
[ConfigurationPropertyAttribute("maxPoolSize", DefaultValue=100)]
public int MaxPoolSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"maxPoolSize", DefaultValue=100)]
public:
virtual property int MaxPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MaxPoolSize ()

/** @property */
public final void set_MaxPoolSize (int value)
JScript
public final function get MaxPoolSize () : int

public final function set MaxPoolSize (value : int)

Property Value

The maximum number of connections in an ODP.NET connection pool. The default is 100.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.MetadataPooling Property
[image]

Gets or sets a value that indicates whether ODP.NET caches metadata information for executed queries.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.MetadataPooling

instance.MetadataPooling = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("metadataPooling", DefaultValue:=True)> _
Public Property MetadataPooling As Boolean
C#
[ConfigurationPropertyAttribute("metadataPooling", DefaultValue=true)]
public bool MetadataPooling { get; set; }
C++
[ConfigurationPropertyAttribute(L"metadataPooling", DefaultValue=true)]
public:
virtual property bool MetadataPooling {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_MetadataPooling ()

/** @property */
public final void set_MetadataPooling (boolean value)
JScript
public final function get MetadataPooling () : boolean

public final function set MetadataPooling (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> when metadata pooling is enabled, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>true</languageKeyword>.

Remarks

Caching this information improves performance; however, if changes to the underlying Oracle artifacts occur on the Oracle system, this pooled metadata will be out of sync. This might cause operations performed on the Oracle system to return unexpected exceptions.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.MinPoolSize Property
[image]

Gets or sets the minimum number of connections in an ODP.NET connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.MinPoolSize

instance.MinPoolSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("minPoolSize", DefaultValue:=1)> _
Public Property MinPoolSize As Integer
C#
[ConfigurationPropertyAttribute("minPoolSize", DefaultValue=1)]
public int MinPoolSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"minPoolSize", DefaultValue=1)]
public:
virtual property int MinPoolSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_MinPoolSize ()

/** @property */
public final void set_MinPoolSize (int value)
JScript
public final function get MinPoolSize () : int

public final function set MinPoolSize (value : int)

Property Value

The minimum number of connections in an ODP.NET connection pool. The default is one.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.MlsSettings Property
[image]

Gets or sets the settings for multi-language support (MLS) specific options.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As MlsSettings

value = instance.MlsSettings

instance.MlsSettings = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("mlsSettings", DefaultValue:=Nothing)> _
Public Property MlsSettings As MlsSettings
C#
[ConfigurationPropertyAttribute("mlsSettings", DefaultValue=null)]
public MlsSettings MlsSettings { get; set; }
C++
[ConfigurationPropertyAttribute(L"mlsSettings", DefaultValue=nullptr)]
public:
virtual property MlsSettings^ MlsSettings {
    MlsSettings^ get () sealed;
    void set (MlsSettings^ value) sealed;
}
J#
/** @property */
public final MlsSettings get_MlsSettings ()

/** @property */
public final void set_MlsSettings (MlsSettings value)
JScript
public final function get MlsSettings () : MlsSettings

public final function set MlsSettings (value : MlsSettings)

Property Value

The settings for MLS-specific options.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.NotificationPort Property
[image]

Gets or sets the port number that ODP.NET must open to listen for database change notification from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.NotificationPort

instance.NotificationPort = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("notificationPort", DefaultValue:=-1)> _
<CategoryAttribute("Notification")> _
Public Property NotificationPort As Integer
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("notificationPort", DefaultValue=-1)]
[CategoryAttribute("Notification")]
public int NotificationPort { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"notificationPort", DefaultValue=-1)]
[CategoryAttribute(L"Notification")]
public:
virtual property int NotificationPort {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_NotificationPort ()

/** @property */
public final void set_NotificationPort (int value)
JScript
public final function get NotificationPort () : int

public final function set NotificationPort (value : int)

Property Value

The port number that ODP.NET must open to listen for database change notification from Oracle database. The default is -1, which signifies that ODP.NET uses a valid, random, unused port number.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.NotificationStatement Property
[image]

Gets or sets the SELECT statement used to register for getting notifications from Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.NotificationStatement

instance.NotificationStatement = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("notificationStatement", DefaultValue:=Nothing)> _
<CategoryAttribute("Notification")> _
Public Property NotificationStatement As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("notificationStatement", DefaultValue=null)]
[CategoryAttribute("Notification")]
public string NotificationStatement { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"notificationStatement", DefaultValue=nullptr)]
[CategoryAttribute(L"Notification")]
public:
virtual property String^ NotificationStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_NotificationStatement ()

/** @property */
public final void set_NotificationStatement (String value)
JScript
public final function get NotificationStatement () : String

public final function set NotificationStatement (value : String)

Property Value

The SELECT statement used to register for getting notifications from Oracle database.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.NotifyOnListenerStart Property
[image]

Gets or sets a value that indicates whether the adapter sends a notification message to the adapter clients, informing that the receive location is running, when the listener starts.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.NotifyOnListenerStart

instance.NotifyOnListenerStart = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("notifyOnListenerStart", DefaultValue:=True)> _
<BindingPropertyDirectionAttribute(True, False)> _
<CategoryAttribute("Notification")> _
Public Property NotifyOnListenerStart As Boolean
C#
[ConfigurationPropertyAttribute("notifyOnListenerStart", DefaultValue=true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute("Notification")]
public bool NotifyOnListenerStart { get; set; }
C++
[ConfigurationPropertyAttribute(L"notifyOnListenerStart", DefaultValue=true)]
[BindingPropertyDirectionAttribute(true, false)]
[CategoryAttribute(L"Notification")]
public:
virtual property bool NotifyOnListenerStart {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_NotifyOnListenerStart ()

/** @property */
public final void set_NotifyOnListenerStart (boolean value)
JScript
public final function get NotifyOnListenerStart () : boolean

public final function set NotifyOnListenerStart (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the adapter sends a notification to the adapter clients when listener starts, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>true</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.OracleConnectionClientId Property
[image]

Gets or sets the client identifier (ID) for the connection used by the adapter to connect to Oracle.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.OracleConnectionClientId

instance.OracleConnectionClientId = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleConnectionClientId", DefaultValue:=Nothing)> _
Public Property OracleConnectionClientId As String
C#
[ConfigurationPropertyAttribute("oracleConnectionClientId", DefaultValue=null)]
public string OracleConnectionClientId { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleConnectionClientId", DefaultValue=nullptr)]
public:
virtual property String^ OracleConnectionClientId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleConnectionClientId ()

/** @property */
public final void set_OracleConnectionClientId (String value)
JScript
public final function get OracleConnectionClientId () : String

public final function set OracleConnectionClientId (value : String)

Property Value

The client ID for the connection used by the adapter to connect to Oracle.

Remarks

This is useful if you have enabled Oracle server-side tracing, and want to selectively trace the operations for a particular client ID. This also allows you to filter and view the Oracle server traces based on a client ID.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.OracleEBSOrganizationId Property
[image]

Gets or sets the organization ID to which an Oracle E-Business Suite application belongs.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.OracleEBSOrganizationId

instance.OracleEBSOrganizationId = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleEBSOrganizationId", DefaultValue:=Nothing)> _
Public Property OracleEBSOrganizationId As String
C#
[ConfigurationPropertyAttribute("oracleEBSOrganizationId", DefaultValue=null)]
public string OracleEBSOrganizationId { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleEBSOrganizationId", DefaultValue=nullptr)]
public:
virtual property String^ OracleEBSOrganizationId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleEBSOrganizationId ()

/** @property */
public final void set_OracleEBSOrganizationId (String value)
JScript
public final function get OracleEBSOrganizationId () : String

public final function set OracleEBSOrganizationId (value : String)

Property Value

The organization ID to which an Oracle E-Business Suite application belongs.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.OracleEBSResponsibilityKey Property
[image]

Gets or sets the responsibility key associated with the Oracle E-Business Suite user.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.OracleEBSResponsibilityKey

instance.OracleEBSResponsibilityKey = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleEBSResponsibilityKey", DefaultValue:=Nothing)> _
Public Property OracleEBSResponsibilityKey As String
C#
[ConfigurationPropertyAttribute("oracleEBSResponsibilityKey", DefaultValue=null)]
public string OracleEBSResponsibilityKey { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleEBSResponsibilityKey", DefaultValue=nullptr)]
public:
virtual property String^ OracleEBSResponsibilityKey {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleEBSResponsibilityKey ()

/** @property */
public final void set_OracleEBSResponsibilityKey (String value)
JScript
public final function get OracleEBSResponsibilityKey () : String

public final function set OracleEBSResponsibilityKey (value : String)

Property Value

The responsibility key associated with the Oracle E-Business Suite user.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.OracleEBSResponsibilityName Property
[image]

Gets or sets the name of the responsibility associated with the Oracle E-Business Suite user.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.OracleEBSResponsibilityName

instance.OracleEBSResponsibilityName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleEBSResponsibilityName", DefaultValue:=Nothing)> _
Public Property OracleEBSResponsibilityName As String
C#
[ConfigurationPropertyAttribute("oracleEBSResponsibilityName", DefaultValue=null)]
public string OracleEBSResponsibilityName { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleEBSResponsibilityName", DefaultValue=nullptr)]
public:
virtual property String^ OracleEBSResponsibilityName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleEBSResponsibilityName ()

/** @property */
public final void set_OracleEBSResponsibilityName (String value)
JScript
public final function get OracleEBSResponsibilityName () : String

public final function set OracleEBSResponsibilityName (value : String)

Property Value

The name of the responsibility associated with the Oracle E-Business Suite user.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.OraclePassword Property
[image]

Gets or sets the password credential for an Oracle database user or an Oracle E-Business Suite user.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.OraclePassword

instance.OraclePassword = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oraclePassword", DefaultValue:=Nothing)> _
Public Property OraclePassword As String
C#
[ConfigurationPropertyAttribute("oraclePassword", DefaultValue=null)]
public string OraclePassword { get; set; }
C++
[ConfigurationPropertyAttribute(L"oraclePassword", DefaultValue=nullptr)]
public:
virtual property String^ OraclePassword {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OraclePassword ()

/** @property */
public final void set_OraclePassword (String value)
JScript
public final function get OraclePassword () : String

public final function set OraclePassword (value : String)

Property Value

The password credential for an Oracle database user or an Oracle E-Business Suite user.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.OracleUserName Property
[image]

Gets or sets the user name credential for an Oracle database user or an Oracle E-Business Suite user.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.OracleUserName

instance.OracleUserName = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("oracleUserName", DefaultValue:=Nothing)> _
Public Property OracleUserName As String
C#
[ConfigurationPropertyAttribute("oracleUserName", DefaultValue=null)]
public string OracleUserName { get; set; }
C++
[ConfigurationPropertyAttribute(L"oracleUserName", DefaultValue=nullptr)]
public:
virtual property String^ OracleUserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_OracleUserName ()

/** @property */
public final void set_OracleUserName (String value)
JScript
public final function get OracleUserName () : String

public final function set OracleUserName (value : String)

Property Value

The user name credential for an Oracle database user or an Oracle E-Business Suite user.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.PolledDataAvailableStatement Property
[image]

Gets or sets the SELECT statement executed to determine whether any data is available for polling for a specific table.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.PolledDataAvailableStatement

instance.PolledDataAvailableStatement = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("polledDataAvailableStatement", DefaultValue:=Nothing)> _
Public Property PolledDataAvailableStatement As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("polledDataAvailableStatement", DefaultValue=null)]
public string PolledDataAvailableStatement { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"polledDataAvailableStatement", DefaultValue=nullptr)]
public:
virtual property String^ PolledDataAvailableStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PolledDataAvailableStatement ()

/** @property */
public final void set_PolledDataAvailableStatement (String value)
JScript
public final function get PolledDataAvailableStatement () : String

public final function set PolledDataAvailableStatement (value : String)

Property Value

The SELECT statement executed to determine whether any data is available for polling for a specific table.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.PollingAction Property
[image]

Gets or sets the action for the polling operation.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.PollingAction

instance.PollingAction = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("pollingAction", DefaultValue:=Nothing)> _
Public Property PollingAction As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("pollingAction", DefaultValue=null)]
public string PollingAction { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"pollingAction", DefaultValue=nullptr)]
public:
virtual property String^ PollingAction {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PollingAction ()

/** @property */
public final void set_PollingAction (String value)
JScript
public final function get PollingAction () : String

public final function set PollingAction (value : String)

Property Value

The action for the polling operation.

Remarks

You can determine the polling action for a specific operation from the metadata you generate for the operation using the Consume Adapter Service Add-in.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.PollingInput Property
[image]

Gets or sets the polling statement.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.PollingInput

instance.PollingInput = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("pollingInput", DefaultValue:=Nothing)> _
Public Property PollingInput As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("pollingInput", DefaultValue=null)]
public string PollingInput { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"pollingInput", DefaultValue=nullptr)]
public:
virtual property String^ PollingInput {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PollingInput ()

/** @property */
public final void set_PollingInput (String value)
JScript
public final function get PollingInput () : String

public final function set PollingInput (value : String)

Property Value

The polling statement.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.PollingInterval Property
[image]

Gets or sets the interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.PollingInterval

instance.PollingInterval = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("pollingInterval", DefaultValue:=30)> _
Public Property PollingInterval As Integer
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("pollingInterval", DefaultValue=30)]
public int PollingInterval { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"pollingInterval", DefaultValue=30)]
public:
virtual property int PollingInterval {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_PollingInterval ()

/** @property */
public final void set_PollingInterval (int value)
JScript
public final function get PollingInterval () : int

public final function set PollingInterval (value : int)

Property Value

The interval in seconds at which the Oracle Database adapter executes the polling statement against the Oracle database. The default is 30.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.PollWhileDataFound Property
[image]

Gets or sets a value that indicates whether the Oracle Database adapter ignores the polling interval and continuously polls the Oracle database, if data is available in the table being polled.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.PollWhileDataFound

instance.PollWhileDataFound = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("pollWhileDataFound", DefaultValue:=False)> _
Public Property PollWhileDataFound As Boolean
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("pollWhileDataFound", DefaultValue=false)]
public bool PollWhileDataFound { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"pollWhileDataFound", DefaultValue=false)]
public:
virtual property bool PollWhileDataFound {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_PollWhileDataFound ()

/** @property */
public final void set_PollWhileDataFound (boolean value)
JScript
public final function get PollWhileDataFound () : boolean

public final function set PollWhileDataFound (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the Oracle Database adapter ignores the polling interval and continuously polls the Oracle database while data is available; <languageKeyword>false</languageKeyword> if the Oracle adapters executes the SQL Statement at the specified polling interval. The default is <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.PostPollStatement Property
[image]

Gets or sets a PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.PostPollStatement

instance.PostPollStatement = value

Syntax

Visual Basic
<BindingPropertyDirectionAttribute(True, False)> _
<ConfigurationPropertyAttribute("postPollStatement", DefaultValue:=Nothing)> _
Public Property PostPollStatement As String
C#
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute("postPollStatement", DefaultValue=null)]
public string PostPollStatement { get; set; }
C++
[BindingPropertyDirectionAttribute(true, false)]
[ConfigurationPropertyAttribute(L"postPollStatement", DefaultValue=nullptr)]
public:
virtual property String^ PostPollStatement {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_PostPollStatement ()

/** @property */
public final void set_PostPollStatement (String value)
JScript
public final function get PostPollStatement () : String

public final function set PostPollStatement (value : String)

Property Value

A PL/SQL block that is executed after the polling statement and before the /POLLINGSTMT message is sent to the consumer. The default is <languageKeyword>null</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.Properties Property
[image]

Gets the collection of configuration properties.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim value As ConfigurationPropertyCollection

value = Me.Properties

Syntax

Visual Basic
Protected Overrides ReadOnly Property Properties As ConfigurationPropertyCollection
C#
protected override ConfigurationPropertyCollection Properties { get; }
C++
protected:
virtual property ConfigurationPropertyCollection^ Properties {
    ConfigurationPropertyCollection^ get () override;
}
J#
/** @property */
protected ConfigurationPropertyCollection get_Properties ()
JScript
protected override function get Properties () : ConfigurationPropertyCollection

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.SkipNilNodes Property
[image]

Gets or sets a value that indicates whether the Oracle Database adapter will skip inserting or updating values for nodes that are marked as ?nil? in the request XML.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.SkipNilNodes

instance.SkipNilNodes = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("skipNilNodes", DefaultValue:=True)> _
<CategoryAttribute("Run Time Behavior")> _
Public Property SkipNilNodes As Boolean
C#
[ConfigurationPropertyAttribute("skipNilNodes", DefaultValue=true)]
[CategoryAttribute("Run Time Behavior")]
public bool SkipNilNodes { get; set; }
C++
[ConfigurationPropertyAttribute(L"skipNilNodes", DefaultValue=true)]
[CategoryAttribute(L"Run Time Behavior")]
public:
virtual property bool SkipNilNodes {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_SkipNilNodes ()

/** @property */
public final void set_SkipNilNodes (boolean value)
JScript
public final function get SkipNilNodes () : boolean

public final function set SkipNilNodes (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the adapter will skip passing values for nodes that are marked as ‘nil’; <languageKeyword>false</languageKeyword> if the adapter explicitly passes a null value for these nodes. The default is <languageKeyword>false</languageKeyword>.

Remarks

This binding property is applicable for inserting or updating records in a table and for RECORD type parameters in stored procedures.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.StatementCachePurge Property
[image]

Gets or sets a value that indicates whether the ODP.NET statement cache associated with a connection is purged when the connection is returned to the connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.StatementCachePurge

instance.StatementCachePurge = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("statementCachePurge", DefaultValue:=False)> _
Public Property StatementCachePurge As Boolean
C#
[ConfigurationPropertyAttribute("statementCachePurge", DefaultValue=false)]
public bool StatementCachePurge { get; set; }
C++
[ConfigurationPropertyAttribute(L"statementCachePurge", DefaultValue=false)]
public:
virtual property bool StatementCachePurge {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_StatementCachePurge ()

/** @property */
public final void set_StatementCachePurge (boolean value)
JScript
public final function get StatementCachePurge () : boolean

public final function set StatementCachePurge (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> when the statement cache purging is enabled, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>false</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.StatementCacheSize Property
[image]

Gets or sets the maximum number of statements that can be cached by each ODP.NET connection.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Integer

value = instance.StatementCacheSize

instance.StatementCacheSize = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("statementCacheSize", DefaultValue:=10)> _
Public Property StatementCacheSize As Integer
C#
[ConfigurationPropertyAttribute("statementCacheSize", DefaultValue=10)]
public int StatementCacheSize { get; set; }
C++
[ConfigurationPropertyAttribute(L"statementCacheSize", DefaultValue=10)]
public:
virtual property int StatementCacheSize {
    int get () sealed;
    void set (int value) sealed;
}
J#
/** @property */
public final int get_StatementCacheSize ()

/** @property */
public final void set_StatementCacheSize (int value)
JScript
public final function get StatementCacheSize () : int

public final function set StatementCacheSize (value : int)

Property Value

The maximum number of statements that can be cached by each ODP.NET connection. The default is 10.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.UseAmbientTransaction Property
[image]

Gets or sets a value that indicates whether the Oracle Database adapter performs the operations using the transaction context provided by the caller.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.UseAmbientTransaction

instance.UseAmbientTransaction = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("useAmbientTransaction", DefaultValue:=True)> _
Public Property UseAmbientTransaction As Boolean
C#
[ConfigurationPropertyAttribute("useAmbientTransaction", DefaultValue=true)]
public bool UseAmbientTransaction { get; set; }
C++
[ConfigurationPropertyAttribute(L"useAmbientTransaction", DefaultValue=true)]
public:
virtual property bool UseAmbientTransaction {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_UseAmbientTransaction ()

/** @property */
public final void set_UseAmbientTransaction (boolean value)
JScript
public final function get UseAmbientTransaction () : boolean

public final function set UseAmbientTransaction (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the adapter always performs the operations in a transaction context, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>true</languageKeyword>.

Remarks

Not performing operations in a transactional context is advisable only for operations that do not make changes to the database. For operations that update data in the database, we recommend setting the binding property to true otherwise you might either experience message loss or duplicate messages depending on whether you are performing inbound or outbound operations.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.UseOracleConnectionPool Property
[image]

Gets or sets a value that indicates whether to use the ODP.NET connection pool.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.UseOracleConnectionPool

instance.UseOracleConnectionPool = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("useOracleConnectionPool", DefaultValue:=True)> _
Public Property UseOracleConnectionPool As Boolean
C#
[ConfigurationPropertyAttribute("useOracleConnectionPool", DefaultValue=true)]
public bool UseOracleConnectionPool { get; set; }
C++
[ConfigurationPropertyAttribute(L"useOracleConnectionPool", DefaultValue=true)]
public:
virtual property bool UseOracleConnectionPool {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_UseOracleConnectionPool ()

/** @property */
public final void set_UseOracleConnectionPool (boolean value)
JScript
public final function get UseOracleConnectionPool () : boolean

public final function set UseOracleConnectionPool (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the ODP.NET connection pool is used, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>true</languageKeyword>.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.UserAssembliesLoadPath Property
[image]

Gets or sets the name of the DLLs, separated by a semi-colon, which the adapter creates while generating metadata.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As String

value = instance.UserAssembliesLoadPath

instance.UserAssembliesLoadPath = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("userAssembliesLoadPath", DefaultValue:=Nothing)> _
Public Property UserAssembliesLoadPath As String
C#
[ConfigurationPropertyAttribute("userAssembliesLoadPath", DefaultValue=null)]
public string UserAssembliesLoadPath { get; set; }
C++
[ConfigurationPropertyAttribute(L"userAssembliesLoadPath", DefaultValue=nullptr)]
public:
virtual property String^ UserAssembliesLoadPath {
    String^ get () sealed;
    void set (String^ value) sealed;
}
J#
/** @property */
public final String get_UserAssembliesLoadPath ()

/** @property */
public final void set_UserAssembliesLoadPath (String value)
JScript
public final function get UserAssembliesLoadPath () : String

public final function set UserAssembliesLoadPath (value : String)

Property Value

The name of the DLLs, separated by a semi-colon, which the adapter creates while generating metadata.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSBindingElementExtensionElement.UseSchemaInNameSpace Property
[image]

Gets or sets a value that indicates whether the schema name is included in the XML namespace for operations and their associated types.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSBindingElementExtensionElement
Dim value As Boolean

value = instance.UseSchemaInNameSpace

instance.UseSchemaInNameSpace = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("useSchemaInNameSpace", DefaultValue:=True)> _
Public Property UseSchemaInNameSpace As Boolean
C#
[ConfigurationPropertyAttribute("useSchemaInNameSpace", DefaultValue=true)]
public bool UseSchemaInNameSpace { get; set; }
C++
[ConfigurationPropertyAttribute(L"useSchemaInNameSpace", DefaultValue=true)]
public:
virtual property bool UseSchemaInNameSpace {
    bool get () sealed;
    void set (bool value) sealed;
}
J#
/** @property */
public final boolean get_UseSchemaInNameSpace ()

/** @property */
public final void set_UseSchemaInNameSpace (boolean value)
JScript
public final function get UseSchemaInNameSpace () : boolean

public final function set UseSchemaInNameSpace (value : boolean)

Property Value

<languageKeyword>true</languageKeyword> if the schema name is included in the XML namespace, otherwise <languageKeyword>false</languageKeyword>. The default is <languageKeyword>true</languageKeyword>.

Remarks

The advantage of not having scheme name included in the namespace is that if there is a table with same name in two different schemas then the same XML can be used to perform the simple SQL operations (Insert, Update, Delete, Select) on both tables.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSBindingElementExtensionElement Class
OracleEBSBindingElementExtensionElement Members


OracleEBSConnectionUri Class
See Also Members
[image]

Builds the Uniform Resource Identifier (URI) for establishing connection to the Oracle E-Business Suite and essentially the underlying Oracle database.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")> _
Public Class OracleEBSConnectionUri
    Inherits ConnectionUri
C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")]
public class OracleEBSConnectionUri : ConnectionUri
C++
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1705:LongAcronymsShouldBePascalCased")]
public ref class OracleEBSConnectionUri : public ConnectionUri
J#
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased") */
public class OracleEBSConnectionUri extends ConnectionUri
JScript
SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")
public class OracleEBSConnectionUri extends ConnectionUri

Inheritance Hierarchy

System.Object
Microsoft.ServiceModel.Channels.Common.ConnectionUri
Microsoft.Adapters.OracleEBS.OracleEBSConnectionUri

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Members


OracleEBSConnectionUri Members
See Also Constructors Methods Properties
[image]

Builds the Uniform Resource Identifier (URI) for establishing connection to the Oracle E-Business Suite and essentially the underlying Oracle database.

The following tables list the members exposed by the OracleEBSConnectionUri type.

Public Constructors

Name | Description
OracleEBSConnectionUri | Overloaded. Initializes a new instance of the OracleEBSConnectionUri class.
Top

Public Properties

 | Name | Description
public property | DataSourceName | Gets or sets the Oracle data source name.
public property | PortNumber | Gets or sets the Oracle Net listener port.
public property | SampleUriString | Overridden. Gets formatted URI string.
public property | SecureUriString | (inherited from ConnectionUri)
public property | ServerAddress | Gets or sets the name or IP address of the server on which the Oracle E-Business Suite is running.
public property | ServiceName | Gets or sets the Oracle database service name.
public property | ServiceType | Gets or sets the Oracle service type. The possible values are Dedicated or Shared.
public property | Uri | Overridden. Gets or sets the connection URI.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetAttributes | (inherited from ConnectionUri)
public method | GetClassName | (inherited from ConnectionUri)
public method | GetComponentName | (inherited from ConnectionUri)
public method | GetConverter | (inherited from ConnectionUri)
public method | GetDefaultEvent | (inherited from ConnectionUri)
public method | GetDefaultProperty | (inherited from ConnectionUri)
public method | GetEditor | (inherited from ConnectionUri)
public method | GetEvents | (inherited from ConnectionUri)
public method | GetEvents | (inherited from ConnectionUri)
public method | GetHashCode | (inherited from Object)
public method | GetProperties | (inherited from ConnectionUri)
public method | GetProperties | (inherited from ConnectionUri)
public method | GetPropertyOwner | (inherited from ConnectionUri)
public method | GetType | (inherited from Object)
public method | ToString | Overridden. (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OracleEBSConnectionUri Class


OracleEBSConnectionUri Constructor
[image]

Initializes a new instance of the OracleEBSConnectionUri class.

Overload List

Name | Description
OracleEBSConnectionUri () | Initializes a new instance of the ConnectionUri class.
OracleEBSConnectionUri (Uri, Boolean) | Initializes a new instance of the ConnectionUri class with a URI object.

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri Constructor ()
[image]

Initializes a new instance of the ConnectionUri class.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New OracleEBSConnectionUri

Syntax

Visual Basic
Public Sub New
C#
public OracleEBSConnectionUri ()
C++
public:
OracleEBSConnectionUri ()
J#
public OracleEBSConnectionUri ()
JScript
public function OracleEBSConnectionUri ()

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri Constructor (Uri, Boolean)
[image]

Initializes a new instance of the ConnectionUri class with a URI object.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim uri As Uri
Dim enableCredentialsInUri As Boolean

Dim instance As New OracleEBSConnectionUri(uri, enableCredentialsInUri)

Syntax

Visual Basic
Public Sub New ( _
    uri As Uri, _
    enableCredentialsInUri As Boolean _
)
C#
public OracleEBSConnectionUri (
    Uri uri,
    bool enableCredentialsInUri
)
C++
public:
OracleEBSConnectionUri (
    Uri^ uri,
    bool enableCredentialsInUri
)
J#
public OracleEBSConnectionUri (
    Uri uri,
    boolean enableCredentialsInUri
)
JScript
public function OracleEBSConnectionUri (
    uri : Uri,
    enableCredentialsInUri : boolean
)

Parameters

uri

The connection URI.

enableCredentialsInUri

<languageKeyword>true</languageKeyword> to enable credentials in connection URI, otherwise <languageKeyword>false</languageKeyword> .

Remarks

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetAttributes | (inherited from ConnectionUri)
public method | GetClassName | (inherited from ConnectionUri)
public method | GetComponentName | (inherited from ConnectionUri)
public method | GetConverter | (inherited from ConnectionUri)
public method | GetDefaultEvent | (inherited from ConnectionUri)
public method | GetDefaultProperty | (inherited from ConnectionUri)
public method | GetEditor | (inherited from ConnectionUri)
public method | GetEvents | (inherited from ConnectionUri)
public method | GetEvents | (inherited from ConnectionUri)
public method | GetHashCode | (inherited from Object)
public method | GetProperties | (inherited from ConnectionUri)
public method | GetProperties | (inherited from ConnectionUri)
public method | GetPropertyOwner | (inherited from ConnectionUri)
public method | GetType | (inherited from Object)
public method | ToString | Overridden. (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OracleEBSConnectionUri Class


OracleEBSConnectionUri Properties
[image]

Public Properties

 | Name | Description
public property | DataSourceName | Gets or sets the Oracle data source name.
public property | PortNumber | Gets or sets the Oracle Net listener port.
public property | SampleUriString | Overridden. Gets formatted URI string.
public property | SecureUriString | (inherited from ConnectionUri)
public property | ServerAddress | Gets or sets the name or IP address of the server on which the Oracle E-Business Suite is running.
public property | ServiceName | Gets or sets the Oracle database service name.
public property | ServiceType | Gets or sets the Oracle service type. The possible values are Dedicated or Shared.
public property | Uri | Overridden. Gets or sets the connection URI.

See Also

Reference

OracleEBSConnectionUri Class


OracleEBSConnectionUri.DataSourceName Property
[image]

Gets or sets the Oracle data source name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri
Dim value As String

value = instance.DataSourceName

instance.DataSourceName = value

Syntax

Visual Basic
<CategoryAttribute("TNS Alias")> _
Public Property DataSourceName As String
C#
[CategoryAttribute("TNS Alias")]
public string DataSourceName { get; set; }
C++
[CategoryAttribute(L"TNS Alias")]
public:
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}
J#
/** @property */
public String get_DataSourceName ()

/** @property */
public void set_DataSourceName (String value)
JScript
public function get DataSourceName () : String

public function set DataSourceName (value : String)

Property Value

The Oracle data source name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri.PortNumber Property
[image]

Gets or sets the Oracle Net listener port.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri
Dim value As Integer

value = instance.PortNumber

instance.PortNumber = value

Syntax

Visual Basic
<BrowsableAttribute(True)> _
<CategoryAttribute("Connect Descriptor")> _
<DefaultValueAttribute(1521)> _
Public Property PortNumber As Integer
C#
[BrowsableAttribute(true)]
[CategoryAttribute("Connect Descriptor")]
[DefaultValueAttribute(1521)]
public int PortNumber { get; set; }
C++
[BrowsableAttribute(true)]
[CategoryAttribute(L"Connect Descriptor")]
[DefaultValueAttribute(1521)]
public:
property int PortNumber {
    int get ();
    void set (int value);
}
J#
/** @property */
public int get_PortNumber ()

/** @property */
public void set_PortNumber (int value)
JScript
public function get PortNumber () : int

public function set PortNumber (value : int)

Property Value

The Oracle Net listener port.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri.SampleUriString Property
[image]

Gets formatted URI string.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri
Dim value As String

value = instance.SampleUriString

Syntax

Visual Basic
Public Overrides ReadOnly Property SampleUriString As String
C#
public override string SampleUriString { get; }
C++
public:
virtual property String^ SampleUriString {
    String^ get () override;
}
J#
/** @property */
public String get_SampleUriString ()
JScript
public override function get SampleUriString () : String

Property Value

The formatted URI string.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri.ServerAddress Property
[image]

Gets or sets the name or IP address of the server on which the Oracle E-Business Suite is running.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri
Dim value As String

value = instance.ServerAddress

instance.ServerAddress = value

Syntax

Visual Basic
<CategoryAttribute("Connect Descriptor")> _
Public Property ServerAddress As String
C#
[CategoryAttribute("Connect Descriptor")]
public string ServerAddress { get; set; }
C++
[CategoryAttribute(L"Connect Descriptor")]
public:
property String^ ServerAddress {
    String^ get ();
    void set (String^ value);
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public String get_ServerAddress ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public void set_ServerAddress (String value)
JScript
CompilerGeneratedAttribute
public function get ServerAddress () : String

CompilerGeneratedAttribute
public function set ServerAddress (value : String)

Property Value

The name or IP address of the server on which the Oracle E-Business Suite is running.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri.ServiceName Property
[image]

Gets or sets the Oracle database service name.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri
Dim value As String

value = instance.ServiceName

instance.ServiceName = value

Syntax

Visual Basic
<CategoryAttribute("Connect Descriptor")> _
Public Property ServiceName As String
C#
[CategoryAttribute("Connect Descriptor")]
public string ServiceName { get; set; }
C++
[CategoryAttribute(L"Connect Descriptor")]
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public String get_ServiceName ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public void set_ServiceName (String value)
JScript
CompilerGeneratedAttribute
public function get ServiceName () : String

CompilerGeneratedAttribute
public function set ServiceName (value : String)

Property Value

The Oracle database service name.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri.ServiceType Property
[image]

Gets or sets the Oracle service type. The possible values are Dedicated or Shared.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri
Dim value As OracleServiceType

value = instance.ServiceType

instance.ServiceType = value

Syntax

Visual Basic
<CategoryAttribute("Connect Descriptor")> _
Public Property ServiceType As OracleServiceType
C#
[CategoryAttribute("Connect Descriptor")]
public OracleServiceType ServiceType { get; set; }
C++
[CategoryAttribute(L"Connect Descriptor")]
public:
property OracleServiceType ServiceType {
    OracleServiceType get ();
    void set (OracleServiceType value);
}
J#
/** @property */
/** @attribute CompilerGeneratedAttribute() */
public OracleServiceType get_ServiceType ()

/** @property */
/** @attribute CompilerGeneratedAttribute() */
public void set_ServiceType (OracleServiceType value)
JScript
CompilerGeneratedAttribute
public function get ServiceType () : OracleServiceType

CompilerGeneratedAttribute
public function set ServiceType (value : OracleServiceType)

Property Value

One of the enumeration values of the OracleServiceType. The default is Dedicated.

Remarks

A dedicated service uses a dedicated server process to serve only one user process. A shared service uses a shared server process that can serve multiple user processes.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSConnectionUri.Uri Property
[image]

Gets or sets the connection URI.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSConnectionUri
Dim value As Uri

value = instance.Uri

instance.Uri = value

Syntax

Visual Basic
Public Overrides Property Uri As Uri
C#
public override Uri Uri { get; set; }
C++
public:
virtual property Uri^ Uri {
    Uri^ get () override;
    void set (Uri^ value) override;
}
J#
/** @property */
public Uri get_Uri ()

/** @property */
public void set_Uri (Uri value)
JScript
public override function get Uri () : Uri

public override function set Uri (value : Uri)

Property Value

The connection URI.

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSConnectionUri Class
OracleEBSConnectionUri Members


OracleEBSInboundTransactionBehavior Class
See Also Members
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior

Syntax

Visual Basic
<SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")> _
Public NotInheritable Class OracleEBSInboundTransactionBehavior
    Inherits BehaviorExtensionElement
    Implements IServiceBehavior
C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")]
public sealed class OracleEBSInboundTransactionBehavior : BehaviorExtensionElement, IServiceBehavior
C++
[SuppressMessageAttribute(L"Microsoft.Naming", L"CA1705:LongAcronymsShouldBePascalCased")]
public ref class OracleEBSInboundTransactionBehavior sealed : public BehaviorExtensionElement, IServiceBehavior
J#
/** @attribute SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased") */
public final class OracleEBSInboundTransactionBehavior extends BehaviorExtensionElement implements IServiceBehavior
JScript
SuppressMessageAttribute("Microsoft.Naming", "CA1705:LongAcronymsShouldBePascalCased")
public final class OracleEBSInboundTransactionBehavior extends BehaviorExtensionElement implements IServiceBehavior

Inheritance Hierarchy

System.Object
System.Configuration.ConfigurationElement
System.ServiceModel.Configuration.ServiceModelExtensionElement
System.ServiceModel.Configuration.BehaviorExtensionElement
Microsoft.Adapters.OracleEBS.OracleEBSInboundTransactionBehavior

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior Members
See Also Constructors Methods Properties Explicit Interface Implementations
[image]

The following tables list the members exposed by the OracleEBSInboundTransactionBehavior type.

Public Constructors

Name | Description
OracleEBSInboundTransactionBehavior |
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | BehaviorType | Overridden.
public property | ConfigurationElementName | (inherited from ServiceModelExtensionElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | TransactionIsolationLevel |
public property | TransactionTimeout |
Top

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | CopyFrom | Overridden.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | IsModified | Overridden. (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SerializeElement | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)
Top

Explicit Interface Implementations

Name | Description
AddBindingParameters |
ApplyDispatchBehavior |
Validate |
Top

See Also

Reference

OracleEBSInboundTransactionBehavior Class


OracleEBSInboundTransactionBehavior Constructor
[image]

Initializes a new instance of the OracleEBSInboundTransactionBehavior Class.Initializes a new instance of the OracleEBSInboundTransactionBehavior Class.

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As New OracleEBSInboundTransactionBehavior

Syntax

Visual Basic
Public Sub New
C#
public OracleEBSInboundTransactionBehavior ()
C++
public:
OracleEBSInboundTransactionBehavior ()
J#
public OracleEBSInboundTransactionBehavior ()
JScript
public function OracleEBSInboundTransactionBehavior ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | CopyFrom | Overridden.
public method | Equals | Overridden. (inherited from Object)
public method | GetHashCode | Overridden. (inherited from Object)
public method | GetType | (inherited from Object)
public method | IsReadOnly | (inherited from ConfigurationElement)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | IsModified | Overridden. (inherited from ConfigurationElement)
protected method | ListErrors | (inherited from ConfigurationElement)
protected method | MemberwiseClone | (inherited from Object)
protected method | OnDeserializeUnrecognizedAttribute | (inherited from ConfigurationElement)
protected method | OnDeserializeUnrecognizedElement | (inherited from ConfigurationElement)
protected method | OnRequiredPropertyNotFound | (inherited from ConfigurationElement)
protected method | PostDeserialize | (inherited from ConfigurationElement)
protected method | PreSerialize | (inherited from ConfigurationElement)
protected method | Reset | Overridden. (inherited from ConfigurationElement)
protected method | SerializeElement | Overridden. (inherited from ConfigurationElement)
protected method | SetPropertyValue | (inherited from ConfigurationElement)

Explicit Interface Implementations

Name | Description
AddBindingParameters |
ApplyDispatchBehavior |
Validate |

See Also

Reference

OracleEBSInboundTransactionBehavior Class


OracleEBSInboundTransactionBehavior.CopyFrom Method
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior
Dim from As ServiceModelExtensionElement

instance.CopyFrom(from)

Syntax

Visual Basic
Public Overrides Sub CopyFrom ( _
    from As ServiceModelExtensionElement _
)
C#
public override void CopyFrom (
    ServiceModelExtensionElement from
)
C++
public:
virtual void CopyFrom (
    ServiceModelExtensionElement^ from
) override
J#
public void CopyFrom (
    ServiceModelExtensionElement from
)
JScript
public override function CopyFrom (
    from : ServiceModelExtensionElement
)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior.AddBindingParameters Method
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior
Dim serviceDescription As ServiceDescription
Dim serviceHostBase As ServiceHostBase
Dim endpoints As Collection(Of ServiceEndpoint)
Dim bindingParameters As BindingParameterCollection

CType(instance, IServiceBehavior).AddBindingParameters(serviceDescription, serviceHostBase, endpoints, bindingParameters)

Syntax

Visual Basic
Private Sub System.ServiceModel.Description.IServiceBehavior.AddBindingParameters ( _
    serviceDescription As ServiceDescription, _
    serviceHostBase As ServiceHostBase, _
    endpoints As Collection(Of ServiceEndpoint), _
    bindingParameters As BindingParameterCollection _
) Implements IServiceBehavior.AddBindingParameters
C#
void IServiceBehavior.AddBindingParameters (
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase,
    Collection<ServiceEndpoint> endpoints,
    BindingParameterCollection bindingParameters
)
C++
private:
virtual void System.ServiceModel.Description.IServiceBehavior.AddBindingParameters (
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase,
    Collection<ServiceEndpoint^>^ endpoints,
    BindingParameterCollection^ bindingParameters
) sealed = IServiceBehavior::AddBindingParameters
J#
JScript

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior.ApplyDispatchBehavior Method
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior
Dim serviceDescription As ServiceDescription
Dim serviceHostBase As ServiceHostBase

CType(instance, IServiceBehavior).ApplyDispatchBehavior(serviceDescription, serviceHostBase)

Syntax

Visual Basic
Private Sub System.ServiceModel.Description.IServiceBehavior.ApplyDispatchBehavior ( _
    serviceDescription As ServiceDescription, _
    serviceHostBase As ServiceHostBase _
) Implements IServiceBehavior.ApplyDispatchBehavior
C#
void IServiceBehavior.ApplyDispatchBehavior (
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase
)
C++
private:
virtual void System.ServiceModel.Description.IServiceBehavior.ApplyDispatchBehavior (
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase
) sealed = IServiceBehavior::ApplyDispatchBehavior
J#
JScript

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior.Validate Method
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior
Dim serviceDescription As ServiceDescription
Dim serviceHostBase As ServiceHostBase

CType(instance, IServiceBehavior).Validate(serviceDescription, serviceHostBase)

Syntax

Visual Basic
Private Sub System.ServiceModel.Description.IServiceBehavior.Validate ( _
    serviceDescription As ServiceDescription, _
    serviceHostBase As ServiceHostBase _
) Implements IServiceBehavior.Validate
C#
void IServiceBehavior.Validate (
    ServiceDescription serviceDescription,
    ServiceHostBase serviceHostBase
)
C++
private:
virtual void System.ServiceModel.Description.IServiceBehavior.Validate (
    ServiceDescription^ serviceDescription,
    ServiceHostBase^ serviceHostBase
) sealed = IServiceBehavior::Validate
J#
JScript

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | BehaviorType | Overridden.
public property | ConfigurationElementName | (inherited from ServiceModelExtensionElement)
public property | ElementInformation | (inherited from ConfigurationElement)
public property | LockAllAttributesExcept | (inherited from ConfigurationElement)
public property | LockAllElementsExcept | (inherited from ConfigurationElement)
public property | LockAttributes | (inherited from ConfigurationElement)
public property | LockElements | (inherited from ConfigurationElement)
public property | LockItem | (inherited from ConfigurationElement)
public property | TransactionIsolationLevel |
public property | TransactionTimeout |

Protected Properties

 | Name | Description
protected property | EvaluationContext | (inherited from ConfigurationElement)

See Also

Reference

OracleEBSInboundTransactionBehavior Class


OracleEBSInboundTransactionBehavior.BehaviorType Property
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior
Dim value As Type

value = instance.BehaviorType

Syntax

Visual Basic
Public Overrides ReadOnly Property BehaviorType As Type
C#
public override Type BehaviorType { get; }
C++
public:
virtual property Type^ BehaviorType {
    Type^ get () override;
}
J#
/** @property */
public Type get_BehaviorType ()
JScript
public override function get BehaviorType () : Type

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior.TransactionIsolationLevel Property
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior
Dim value As IsolationLevel

value = instance.TransactionIsolationLevel

instance.TransactionIsolationLevel = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("transactionIsolationLevel", DefaultValue:=IsolationLevel.Serializable)> _
Public Property TransactionIsolationLevel As IsolationLevel
C#
[ConfigurationPropertyAttribute("transactionIsolationLevel", DefaultValue=IsolationLevel.Serializable)]
public IsolationLevel TransactionIsolationLevel { get; set; }
C++
[ConfigurationPropertyAttribute(L"transactionIsolationLevel", DefaultValue=IsolationLevel::Serializable)]
public:
property IsolationLevel TransactionIsolationLevel {
    IsolationLevel get ();
    void set (IsolationLevel value);
}
J#
/** @property */
public IsolationLevel get_TransactionIsolationLevel ()

/** @property */
public void set_TransactionIsolationLevel (IsolationLevel value)
JScript
public function get TransactionIsolationLevel () : IsolationLevel

public function set TransactionIsolationLevel (value : IsolationLevel)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleEBSInboundTransactionBehavior.TransactionTimeout Property
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleEBSInboundTransactionBehavior
Dim value As TimeSpan

value = instance.TransactionTimeout

instance.TransactionTimeout = value

Syntax

Visual Basic
<ConfigurationPropertyAttribute("transactionTimeout")> _
Public Property TransactionTimeout As TimeSpan
C#
[ConfigurationPropertyAttribute("transactionTimeout")]
public TimeSpan TransactionTimeout { get; set; }
C++
[ConfigurationPropertyAttribute(L"transactionTimeout")]
public:
property TimeSpan TransactionTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
J#
/** @property */
public TimeSpan get_TransactionTimeout ()

/** @property */
public void set_TransactionTimeout (TimeSpan value)
JScript
public function get TransactionTimeout () : TimeSpan

public function set TransactionTimeout (value : TimeSpan)

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OracleEBSInboundTransactionBehavior Class
OracleEBSInboundTransactionBehavior Members


OracleServiceType Enumeration
[image]

Namespace: Microsoft.Adapters.OracleEBS
Assembly: Microsoft.Adapters.OracleEBS (in Microsoft.Adapters.OracleEBS.dll)

Usage

Visual Basic
Dim instance As OracleServiceType

Syntax

Visual Basic
Public Enumeration OracleServiceType
C#
public enum OracleServiceType
C++
public enum class OracleServiceType
J#
public enum OracleServiceType
JScript
public enum OracleServiceType

Members

Member name | Description
Dedicated |
Shared |

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference


Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace

Classes

Class | Description
ApplicationContextPropertySchema |
ApplicationShortName |
Language |
OrganizationId |
ResponsibilityKey |
ResponsibilityName |


ApplicationContextPropertySchema Class
See Also Members
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ApplicationContextPropertySchema

Syntax

Visual Basic
<SerializableAttribute> _
<SchemaTypeAttribute(SchemaTypeEnum.Property)> _
Public NotInheritable Class ApplicationContextPropertySchema
    Inherits SchemaBase
C#
[SerializableAttribute]
[SchemaTypeAttribute(SchemaTypeEnum.Property)]
public sealed class ApplicationContextPropertySchema : SchemaBase
C++
[SerializableAttribute]
[SchemaTypeAttribute(SchemaTypeEnum::Property)]
public ref class ApplicationContextPropertySchema sealed : public SchemaBase
J#
/** @attribute SerializableAttribute() */
/** @attribute SchemaTypeAttribute(SchemaTypeEnum.Property) */
public final class ApplicationContextPropertySchema extends SchemaBase
JScript
SerializableAttribute
SchemaTypeAttribute(SchemaTypeEnum.Property)
public final class ApplicationContextPropertySchema extends SchemaBase

Inheritance Hierarchy

System.Object
Microsoft.XLANGs.BaseTypes.SchemaBase
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.ApplicationContextPropertySchema

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationContextPropertySchema Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationContextPropertySchema Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ApplicationContextPropertySchema type.

Public Constructors

Name | Description
ApplicationContextPropertySchema |
Top

Public Properties (see also Protected Properties)

 | Name | Description
public property | ParseTables | (inherited from SchemaBase)
public property | RootNodes | Overridden.
public property | Schema | (inherited from SchemaBase)
public property | SchemaCollection | (inherited from SchemaBase)
public property | XmlContent | Overridden.
Top

Protected Properties

 | Name | Description
protected property | RawSchema | (inherited from SchemaBase)
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | CreateResolvedSchema | (inherited from SchemaBase)
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ApplicationContextPropertySchema Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationContextPropertySchema Constructor
[image]

Initializes a new instance of the ApplicationContextPropertySchema Class.Initializes a new instance of the ApplicationContextPropertySchema Class.

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As New ApplicationContextPropertySchema

Syntax

Visual Basic
Public Sub New
C#
public ApplicationContextPropertySchema ()
C++
public:
ApplicationContextPropertySchema ()
J#
public ApplicationContextPropertySchema ()
JScript
public function ApplicationContextPropertySchema ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationContextPropertySchema Class
ApplicationContextPropertySchema Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationContextPropertySchema Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | CreateResolvedSchema | (inherited from SchemaBase)
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ApplicationContextPropertySchema Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationContextPropertySchema Properties
[image]

Public Properties (see also Protected Properties)

 | Name | Description
public property | ParseTables | (inherited from SchemaBase)
public property | RootNodes | Overridden.
public property | Schema | (inherited from SchemaBase)
public property | SchemaCollection | (inherited from SchemaBase)
public property | XmlContent | Overridden.

Protected Properties

 | Name | Description
protected property | RawSchema | (inherited from SchemaBase)

See Also

Reference

ApplicationContextPropertySchema Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationContextPropertySchema.RootNodes Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ApplicationContextPropertySchema
Dim value As String()

value = instance.RootNodes

Syntax

Visual Basic
Public Overrides ReadOnly Property RootNodes As String()
C#
public override string[] RootNodes { get; }
C++
public:
virtual property array<String^>^ RootNodes {
    array<String^>^ get () override;
}
J#
/** @property */
public String[] get_RootNodes ()
JScript
public override function get RootNodes () : String[]

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationContextPropertySchema Class
ApplicationContextPropertySchema Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationContextPropertySchema.XmlContent Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ApplicationContextPropertySchema
Dim value As String

value = instance.XmlContent

Syntax

Visual Basic
Public Overrides ReadOnly Property XmlContent As String
C#
public override string XmlContent { get; }
C++
public:
virtual property String^ XmlContent {
    String^ get () override;
}
J#
/** @property */
public String get_XmlContent ()
JScript
public override function get XmlContent () : String

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationContextPropertySchema Class
ApplicationContextPropertySchema Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationShortName Class
See Also Members
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ApplicationShortName

Syntax

Visual Basic
<SerializableAttribute> _
<IsSensitivePropertyAttribute(False)> _
<PropertyGuidAttribute("f77a3fcb-4204-41af-8176-a94757e41fe3")> _
<PropertyTypeAttribute("ApplicationShortName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")> _
Public NotInheritable Class ApplicationShortName
    Inherits MessageContextPropertyBase
C#
[SerializableAttribute]
[IsSensitivePropertyAttribute(false)]
[PropertyGuidAttribute("f77a3fcb-4204-41af-8176-a94757e41fe3")]
[PropertyTypeAttribute("ApplicationShortName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")]
public sealed class ApplicationShortName : MessageContextPropertyBase
C++
[SerializableAttribute]
[IsSensitivePropertyAttribute(false)]
[PropertyGuidAttribute(L"f77a3fcb-4204-41af-8176-a94757e41fe3")]
[PropertyTypeAttribute(L"ApplicationShortName", L"http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", L"string", L"System.String")]
public ref class ApplicationShortName sealed : public MessageContextPropertyBase
J#
/** @attribute SerializableAttribute() */
/** @attribute IsSensitivePropertyAttribute(false) */
/** @attribute PropertyGuidAttribute("f77a3fcb-4204-41af-8176-a94757e41fe3") */
/** @attribute PropertyTypeAttribute("ApplicationShortName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String") */
public final class ApplicationShortName extends MessageContextPropertyBase
JScript
SerializableAttribute
IsSensitivePropertyAttribute(false)
PropertyGuidAttribute("f77a3fcb-4204-41af-8176-a94757e41fe3")
PropertyTypeAttribute("ApplicationShortName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")
public final class ApplicationShortName extends MessageContextPropertyBase

Inheritance Hierarchy

System.Object
Microsoft.XLANGs.BaseTypes.PropertyBase
Microsoft.XLANGs.BaseTypes.MessageContextPropertyBase
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.ApplicationShortName

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationShortName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationShortName Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ApplicationShortName type.

Public Constructors

Name | Description
ApplicationShortName |
Top

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ApplicationShortName Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationShortName Constructor
[image]

Initializes a new instance of the ApplicationShortName Class.Initializes a new instance of the ApplicationShortName Class.

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As New ApplicationShortName

Syntax

Visual Basic
Public Sub New
C#
public ApplicationShortName ()
C++
public:
ApplicationShortName ()
J#
public ApplicationShortName ()
JScript
public function ApplicationShortName ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationShortName Class
ApplicationShortName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationShortName Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ApplicationShortName Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationShortName Properties
[image]

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.

See Also

Reference

ApplicationShortName Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationShortName.Name Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ApplicationShortName
Dim value As XmlQualifiedName

value = instance.Name

Syntax

Visual Basic
Public Overrides ReadOnly Property Name As XmlQualifiedName
C#
public override XmlQualifiedName Name { get; }
C++
public:
virtual property XmlQualifiedName^ Name {
    XmlQualifiedName^ get () override;
}
J#
/** @property */
public XmlQualifiedName get_Name ()
JScript
public override function get Name () : XmlQualifiedName

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationShortName Class
ApplicationShortName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ApplicationShortName.Type Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ApplicationShortName
Dim value As Type

value = instance.Type

Syntax

Visual Basic
Public Overrides ReadOnly Property Type As Type
C#
public override Type Type { get; }
C++
public:
virtual property Type^ Type {
    Type^ get () override;
}
J#
/** @property */
public Type get_Type ()
JScript
public override function get Type () : Type

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ApplicationShortName Class
ApplicationShortName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Language Class
See Also Members
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As Language

Syntax

Visual Basic
<SerializableAttribute> _
<IsSensitivePropertyAttribute(False)> _
<PropertyTypeAttribute("Language", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")> _
<PropertyGuidAttribute("8BC62754-297D-4908-9332-4E2A619483DA")> _
Public NotInheritable Class Language
    Inherits MessageContextPropertyBase
C#
[SerializableAttribute]
[IsSensitivePropertyAttribute(false)]
[PropertyTypeAttribute("Language", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")]
[PropertyGuidAttribute("8BC62754-297D-4908-9332-4E2A619483DA")]
public sealed class Language : MessageContextPropertyBase
C++
[SerializableAttribute]
[IsSensitivePropertyAttribute(false)]
[PropertyTypeAttribute(L"Language", L"http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", L"string", L"System.String")]
[PropertyGuidAttribute(L"8BC62754-297D-4908-9332-4E2A619483DA")]
public ref class Language sealed : public MessageContextPropertyBase
J#
/** @attribute SerializableAttribute() */
/** @attribute IsSensitivePropertyAttribute(false) */
/** @attribute PropertyTypeAttribute("Language", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String") */
/** @attribute PropertyGuidAttribute("8BC62754-297D-4908-9332-4E2A619483DA") */
public final class Language extends MessageContextPropertyBase
JScript
SerializableAttribute
IsSensitivePropertyAttribute(false)
PropertyTypeAttribute("Language", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")
PropertyGuidAttribute("8BC62754-297D-4908-9332-4E2A619483DA")
public final class Language extends MessageContextPropertyBase

Inheritance Hierarchy

System.Object
Microsoft.XLANGs.BaseTypes.PropertyBase
Microsoft.XLANGs.BaseTypes.MessageContextPropertyBase
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.Language

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

Language Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Language Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the Language type.

Public Constructors

Name | Description
Language |
Top

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

Language Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Language Constructor
[image]

Initializes a new instance of the Language Class.Initializes a new instance of the Language Class.

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As New Language

Syntax

Visual Basic
Public Sub New
C#
public Language ()
C++
public:
Language ()
J#
public Language ()
JScript
public function Language ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

Language Class
Language Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Language Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

Language Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Language Properties
[image]

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.

See Also

Reference

Language Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Language.Name Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As Language
Dim value As XmlQualifiedName

value = instance.Name

Syntax

Visual Basic
Public Overrides ReadOnly Property Name As XmlQualifiedName
C#
public override XmlQualifiedName Name { get; }
C++
public:
virtual property XmlQualifiedName^ Name {
    XmlQualifiedName^ get () override;
}
J#
/** @property */
public XmlQualifiedName get_Name ()
JScript
public override function get Name () : XmlQualifiedName

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

Language Class
Language Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Language.Type Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As Language
Dim value As Type

value = instance.Type

Syntax

Visual Basic
Public Overrides ReadOnly Property Type As Type
C#
public override Type Type { get; }
C++
public:
virtual property Type^ Type {
    Type^ get () override;
}
J#
/** @property */
public Type get_Type ()
JScript
public override function get Type () : Type

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

Language Class
Language Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


OrganizationId Class
See Also Members
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As OrganizationId

Syntax

Visual Basic
<SerializableAttribute> _
<IsSensitivePropertyAttribute(False)> _
<PropertyGuidAttribute("35247e23-2b8b-45dd-8dd7-d9e9c0965827")> _
<PropertyTypeAttribute("OrganizationId", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")> _
Public NotInheritable Class OrganizationId
    Inherits MessageContextPropertyBase
C#
[SerializableAttribute]
[IsSensitivePropertyAttribute(false)]
[PropertyGuidAttribute("35247e23-2b8b-45dd-8dd7-d9e9c0965827")]
[PropertyTypeAttribute("OrganizationId", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")]
public sealed class OrganizationId : MessageContextPropertyBase
C++
[SerializableAttribute]
[IsSensitivePropertyAttribute(false)]
[PropertyGuidAttribute(L"35247e23-2b8b-45dd-8dd7-d9e9c0965827")]
[PropertyTypeAttribute(L"OrganizationId", L"http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", L"string", L"System.String")]
public ref class OrganizationId sealed : public MessageContextPropertyBase
J#
/** @attribute SerializableAttribute() */
/** @attribute IsSensitivePropertyAttribute(false) */
/** @attribute PropertyGuidAttribute("35247e23-2b8b-45dd-8dd7-d9e9c0965827") */
/** @attribute PropertyTypeAttribute("OrganizationId", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String") */
public final class OrganizationId extends MessageContextPropertyBase
JScript
SerializableAttribute
IsSensitivePropertyAttribute(false)
PropertyGuidAttribute("35247e23-2b8b-45dd-8dd7-d9e9c0965827")
PropertyTypeAttribute("OrganizationId", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")
public final class OrganizationId extends MessageContextPropertyBase

Inheritance Hierarchy

System.Object
Microsoft.XLANGs.BaseTypes.PropertyBase
Microsoft.XLANGs.BaseTypes.MessageContextPropertyBase
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.OrganizationId

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OrganizationId Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


OrganizationId Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the OrganizationId type.

Public Constructors

Name | Description
OrganizationId |
Top

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

OrganizationId Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


OrganizationId Constructor
[image]

Initializes a new instance of the OrganizationId Class.Initializes a new instance of the OrganizationId Class.

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As New OrganizationId

Syntax

Visual Basic
Public Sub New
C#
public OrganizationId ()
C++
public:
OrganizationId ()
J#
public OrganizationId ()
JScript
public function OrganizationId ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OrganizationId Class
OrganizationId Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


OrganizationId Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

OrganizationId Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


OrganizationId Properties
[image]

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.

See Also

Reference

OrganizationId Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


OrganizationId.Name Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As OrganizationId
Dim value As XmlQualifiedName

value = instance.Name

Syntax

Visual Basic
Public Overrides ReadOnly Property Name As XmlQualifiedName
C#
public override XmlQualifiedName Name { get; }
C++
public:
virtual property XmlQualifiedName^ Name {
    XmlQualifiedName^ get () override;
}
J#
/** @property */
public XmlQualifiedName get_Name ()
JScript
public override function get Name () : XmlQualifiedName

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OrganizationId Class
OrganizationId Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


OrganizationId.Type Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As OrganizationId
Dim value As Type

value = instance.Type

Syntax

Visual Basic
Public Overrides ReadOnly Property Type As Type
C#
public override Type Type { get; }
C++
public:
virtual property Type^ Type {
    Type^ get () override;
}
J#
/** @property */
public Type get_Type ()
JScript
public override function get Type () : Type

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

OrganizationId Class
OrganizationId Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityKey Class
See Also Members
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ResponsibilityKey

Syntax

Visual Basic
<SerializableAttribute> _
<PropertyGuidAttribute("74E011E2-6945-4ce3-87DE-987C453F4F0F")> _
<PropertyTypeAttribute("ResponsibilityKey", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")> _
<IsSensitivePropertyAttribute(False)> _
Public NotInheritable Class ResponsibilityKey
    Inherits MessageContextPropertyBase
C#
[SerializableAttribute]
[PropertyGuidAttribute("74E011E2-6945-4ce3-87DE-987C453F4F0F")]
[PropertyTypeAttribute("ResponsibilityKey", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")]
[IsSensitivePropertyAttribute(false)]
public sealed class ResponsibilityKey : MessageContextPropertyBase
C++
[SerializableAttribute]
[PropertyGuidAttribute(L"74E011E2-6945-4ce3-87DE-987C453F4F0F")]
[PropertyTypeAttribute(L"ResponsibilityKey", L"http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", L"string", L"System.String")]
[IsSensitivePropertyAttribute(false)]
public ref class ResponsibilityKey sealed : public MessageContextPropertyBase
J#
/** @attribute SerializableAttribute() */
/** @attribute PropertyGuidAttribute("74E011E2-6945-4ce3-87DE-987C453F4F0F") */
/** @attribute PropertyTypeAttribute("ResponsibilityKey", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String") */
/** @attribute IsSensitivePropertyAttribute(false) */
public final class ResponsibilityKey extends MessageContextPropertyBase
JScript
SerializableAttribute
PropertyGuidAttribute("74E011E2-6945-4ce3-87DE-987C453F4F0F")
PropertyTypeAttribute("ResponsibilityKey", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")
IsSensitivePropertyAttribute(false)
public final class ResponsibilityKey extends MessageContextPropertyBase

Inheritance Hierarchy

System.Object
Microsoft.XLANGs.BaseTypes.PropertyBase
Microsoft.XLANGs.BaseTypes.MessageContextPropertyBase
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.ResponsibilityKey

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityKey Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityKey Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ResponsibilityKey type.

Public Constructors

Name | Description
ResponsibilityKey |
Top

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ResponsibilityKey Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityKey Constructor
[image]

Initializes a new instance of the ResponsibilityKey Class.Initializes a new instance of the ResponsibilityKey Class.

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As New ResponsibilityKey

Syntax

Visual Basic
Public Sub New
C#
public ResponsibilityKey ()
C++
public:
ResponsibilityKey ()
J#
public ResponsibilityKey ()
JScript
public function ResponsibilityKey ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityKey Class
ResponsibilityKey Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityKey Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ResponsibilityKey Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityKey Properties
[image]

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.

See Also

Reference

ResponsibilityKey Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityKey.Name Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ResponsibilityKey
Dim value As XmlQualifiedName

value = instance.Name

Syntax

Visual Basic
Public Overrides ReadOnly Property Name As XmlQualifiedName
C#
public override XmlQualifiedName Name { get; }
C++
public:
virtual property XmlQualifiedName^ Name {
    XmlQualifiedName^ get () override;
}
J#
/** @property */
public XmlQualifiedName get_Name ()
JScript
public override function get Name () : XmlQualifiedName

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityKey Class
ResponsibilityKey Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityKey.Type Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ResponsibilityKey
Dim value As Type

value = instance.Type

Syntax

Visual Basic
Public Overrides ReadOnly Property Type As Type
C#
public override Type Type { get; }
C++
public:
virtual property Type^ Type {
    Type^ get () override;
}
J#
/** @property */
public Type get_Type ()
JScript
public override function get Type () : Type

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityKey Class
ResponsibilityKey Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityName Class
See Also Members
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ResponsibilityName

Syntax

Visual Basic
<SerializableAttribute> _
<PropertyGuidAttribute("0e8f522c-17ef-4d7b-ae5c-1d406dac9384")> _
<PropertyTypeAttribute("ResponsibilityName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")> _
<IsSensitivePropertyAttribute(False)> _
Public NotInheritable Class ResponsibilityName
    Inherits MessageContextPropertyBase
C#
[SerializableAttribute]
[PropertyGuidAttribute("0e8f522c-17ef-4d7b-ae5c-1d406dac9384")]
[PropertyTypeAttribute("ResponsibilityName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")]
[IsSensitivePropertyAttribute(false)]
public sealed class ResponsibilityName : MessageContextPropertyBase
C++
[SerializableAttribute]
[PropertyGuidAttribute(L"0e8f522c-17ef-4d7b-ae5c-1d406dac9384")]
[PropertyTypeAttribute(L"ResponsibilityName", L"http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", L"string", L"System.String")]
[IsSensitivePropertyAttribute(false)]
public ref class ResponsibilityName sealed : public MessageContextPropertyBase
J#
/** @attribute SerializableAttribute() */
/** @attribute PropertyGuidAttribute("0e8f522c-17ef-4d7b-ae5c-1d406dac9384") */
/** @attribute PropertyTypeAttribute("ResponsibilityName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String") */
/** @attribute IsSensitivePropertyAttribute(false) */
public final class ResponsibilityName extends MessageContextPropertyBase
JScript
SerializableAttribute
PropertyGuidAttribute("0e8f522c-17ef-4d7b-ae5c-1d406dac9384")
PropertyTypeAttribute("ResponsibilityName", "http://schemas.microsoft.com/OracleEBS/2008/05/OracleEBSContextProperties", "string", "System.String")
IsSensitivePropertyAttribute(false)
public final class ResponsibilityName extends MessageContextPropertyBase

Inheritance Hierarchy

System.Object
Microsoft.XLANGs.BaseTypes.PropertyBase
Microsoft.XLANGs.BaseTypes.MessageContextPropertyBase
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.ResponsibilityName

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityName Members
See Also Constructors Methods Properties
[image]

The following tables list the members exposed by the ResponsibilityName type.

Public Constructors

Name | Description
ResponsibilityName |
Top

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.
Top

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)
Top

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)
Top

See Also

Reference

ResponsibilityName Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityName Constructor
[image]

Initializes a new instance of the ResponsibilityName Class.Initializes a new instance of the ResponsibilityName Class.

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As New ResponsibilityName

Syntax

Visual Basic
Public Sub New
C#
public ResponsibilityName ()
C++
public:
ResponsibilityName ()
J#
public ResponsibilityName ()
JScript
public function ResponsibilityName ()

Remarks

The default constructor initializes any fields to their default values.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityName Class
ResponsibilityName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityName Methods
[image]

Public Methods (see also Protected Methods)

 | Name | Description
public method | Equals | (inherited from Object)
public method | GetHashCode | (inherited from Object)
public method | GetType | (inherited from Object)
public method | ToString | (inherited from Object)

Protected Methods

 | Name | Description
protected method | Finalize | (inherited from Object)
protected method | MemberwiseClone | (inherited from Object)

See Also

Reference

ResponsibilityName Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityName Properties
[image]

Public Properties

 | Name | Description
public property | Name | Overridden.
public property | QName | (inherited from PropertyBase)
public property | Type | Overridden.

See Also

Reference

ResponsibilityName Class
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityName.Name Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ResponsibilityName
Dim value As XmlQualifiedName

value = instance.Name

Syntax

Visual Basic
Public Overrides ReadOnly Property Name As XmlQualifiedName
C#
public override XmlQualifiedName Name { get; }
C++
public:
virtual property XmlQualifiedName^ Name {
    XmlQualifiedName^ get () override;
}
J#
/** @property */
public XmlQualifiedName get_Name ()
JScript
public override function get Name () : XmlQualifiedName

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityName Class
ResponsibilityName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


ResponsibilityName.Type Property
[image]

Namespace: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema
Assembly: Microsoft.Adapters.OracleEBS.BiztalkPropertySchema (in Microsoft.Adapters.OracleEBS.BiztalkPropertySchema.dll)

Usage

Visual Basic
Dim instance As ResponsibilityName
Dim value As Type

value = instance.Type

Syntax

Visual Basic
Public Overrides ReadOnly Property Type As Type
C#
public override Type Type { get; }
C++
public:
virtual property Type^ Type {
    Type^ get () override;
}
J#
/** @property */
public Type get_Type ()
JScript
public override function get Type () : Type

Thread Safety

Any public static (Shared in Visual Basic) members of this type are thread safe. Any instance members are not guaranteed to be thread safe.

Platforms

Development Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

Target Platforms

The 32-bit and 64-bit editions of Windows Server 2003 R2 (except the Web Editions); The 32-bit and 64-bit editions of Windows Server 2003 with SP2 (except the Web Edition); The 32-bit and 64-bit editions of Windows Server 2008 (except the Web Editions); The 32-bit and 64-bit editions of Windows Vista Ultimate, Enterprise, and Business editions; The 32-bit and 64-bit editions of Windows XP Professional with SP3; Windows Small Business Server 2003 with SP1 or SP2; Windows Small Business Server 2008

See Also

Reference

ResponsibilityName Class
ResponsibilityName Members
Microsoft.Adapters.OracleEBS.BiztalkPropertySchema Namespace


Copyright Notice

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted in examples herein are fictitious. No association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2014 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Server, Windows Vista, Active Directory, ActiveX, BizTalk, Excel, FrontPage, InfoPath, JScript, IntelliSense, MSDN, Outlook, PivotChart, PivotTable, Windows SharePoint Services, Tahoma, Visio, Visual Basic, Visual C++, Visual C#, Visual SourceSafe, Visual Studio, Win32, and Windows NT are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Enterprise integration patterns are taken from Enterprise Integration Patterns, by Gregor Hohpe and Bobby Woolf and the Pattern Catalog Table of Contents (http://go.microsoft.com/fwlink/?LinkID=62480) and are used under permission.

All other trademarks are property of their respective owners.

© 2014 Microsoft Corporation. All rights reserved.