What’s New in Microsoft Dynamics GP 2013 eConnect

Microsoft Dynamics GP 2013 eConnect includes several changes to the eConnect schema, XML nodes, and elements The following sections describe the specific additions, changes, and deletions:

  • New classes for the Microsoft.Dynamics.GP.eConnect
  • Changes to the Microsoft.Dynamics.GP.eConnect.Serialization classes
  • Adds new property to the Configuration class
  • New XML schema
  • Changed XML Schema
  • New XML nodes
  • New XML elements
  • Changed XML elements

Documentation Feedback


New classes for the Microsoft.Dynamics.GP.eConnect

The Microsoft.Dynamics.GP.eConnect namespace adds the following class:

  • DtcEventRegistrar Class


Changes to the Microsoft.Dynamics.GP.eConnect.Serialization classes

The classes in the Serialization namespace had all the fields converted to properties. The names of the properties match the field names that were in previous versions of the Serialization namespace.


Adds new property to the Configuration class

A new read-only property was added to the Configuration class. The property specifies whether a warning message is logged when a transactions is promoted to a distributed transaction. The default value is true.

You can change the logging behavior by setting LogDTCPromotions value in the eConnect configuration file. The following example shows how to specify the LogDTCPromotions value:

<appSettings>
    <add key=”LogDTCPromotions” value=”false” />
</appSettings>


New XML schema

The following schema types were added to eConnect:

  • FACreateAssetPurchaseType


Changed XML Schema

The following schema types have been changed:

Schema | Change
POPEnterMatchInvoiceType | Added the <taPopEnterMatchLotInsert> and <taPopEnterMatchSerialInsert> nodes.


New XML nodes

The following XML nodes were added:

XML node | Schema document
<taCreateAssetPurchase> | FACreateAssetPurchaseType
<taPopEnterMatchLotInsert> | POPEnterMatchInvoiceType
<taPopEnterMatchSerialInsert> | POPEnterMatchInvoiceType


New XML elements

The following table displays XML nodes that have new elements The pre and post procedures are not listed, but when pre and post procedures exist, they include the same change

XML node | Element | Data type
<taCreateCustomerAddress>* | ShipToName | string
 | Print_Phone_NumberGB | i4
<taCreateIVItemClass> | UseQtyOverageTolerance | i4
 | UseQtyShortageTolerance | i4
 | QtyOverTolerancePercent | i4
 | QtyShortTolerancePercent | i4
<taIVMultibinBinToBinTransfer> | Bin_XFer_Doc_Number | string
 | Bin_XFer_Date | datetime
 | Reason_Code | string
 | AddMoreSerLots | i4
 | USERID | string
<taIVTransactionLineInsert> | Reason_Code | string
<taIVTransferLineInsert> | Reason_Code | string
<taPoHdr>* | Print_Phone_NumberGB | i4
<taPoLine>* | Print_Phone_NumberGB | i4
<taPopEnterMatchInvLine> | TrackedDropShipped | i4
<taSopHdrIvcInsert>* | Print_Phone_NumberGB | i4
<taSopLineIvcInsert>* | Print_Phone_NumberGB | i4
<taUpdateCreateItemRcd>* | UseQtyOverageTolerance | i4
 | UseQtyShortageTolerance | i4
 | QtyOverTolerancePercent | i4
 | QtyShortTolerancePercent | i4


Changed XML elements

The following elements have been changed The pre and post procedures are not listed, but when pre and post procedures exist, they include the change

XML node | Element | Change
<taPAMiscLogLineInsert> | PAUNITCOST | Changed the default value.


eConnect Programmer’s Guide

The Programmer’s Guide contains the basic information you need to begin using Microsoft Dynamics GP eConnect The Guide is divided into parts that focus on specific topics If you are new to eConnect, review the Overview and XML Document information since they will help you to understand the basics of eConnect The remaining parts of the Guide focus on specific development tools and approaches that eConnect supports You should refer to the topics that best suit your application development environment and tools The list that follows introduces the components of the Programmer’s Guide:

  • eConnect Overview provides an introduction to the eConnect application programming interfaces (API) Review these chapters to understand the API components and how you can use eConnect to add Microsoft Dynamics GP data and functionality o your application
  • eConnect Schema and XML Documents explains the documents that eConnect uses to describe Microsoft Dynamics GP documents and operations This information will help you to construct an eConnect XML document
  • .NET Development discusses eConnect’s support for MIcrosoft NET The eConnect install provides three NET assemblies you can use to add eConnect functionality to a project Review this information to learn what the assemblies contain and how to use them
  • MSMQ Development discusses how to use eConnect with Microsoft Message Queues (MSMQ) This application programming interface (API) allows you to exchange data with Microsoft Dynamics GP using the eConnect Incoming, and Outgoing Services
  • Business Logic provides information about using and extending the eConnect business objects Review this section if you need to use or alter eConnect’s business logic to meet a unique business operation
  • Transaction Requester discusses how you can use eConnect to request data from Microsoft Dynamics GP Review this portion of the documentation when your application needs to retrieve data
  • eConnect Samples discusses the sample applications that install with eConnect


eConnect Overview

This portion of the documentation provides an introduction to eConnect. Review the following to learn what eConnect can do and understand the components it uses to support your application development efforts. The list that follows contains the topics that are discussed:

  • Overview introduces eConnect and how you can use eConnect to integrate Microsoft Dynamics GP data and functionality into your applications.
  • Architecture describes the components and application programming interfaces (APIs) that eConnect provides. Use this information to understand how eConnect works and to determine which API best supports your development environment and tools.


Overview

Microsoft Dynamics GP eConnect allows you to integrate your business applications with Microsoft Dynamics GP. The following topics introduce Microsoft Dynamics GP eConnect:

  • What is eConnect?
  • What eConnect can do
  • eConnect Example
  • Getting started


What is eConnect?

eConnect is a collection of tools, components, and interfaces that allow applications to programmatically interact with Microsoft Dynamics GP. The key eConnect components and interfaces include:

  • A .NET managed code assembly
  • A Microsoft BizTalk® Application Integration Component (AIC)
  • Microsoft Message Queuing (MSMQ) services

These eConnect interfaces allow external applications like web storefronts, web services, point-of-sale systems, or legacy applications to integrate with Microsoft Dynamics GP. The external applications can perform actions like creating, updating, retrieving, and deleting back office documents and transactions. While eConnect supplies a large number of documents, not every Microsoft Dynamics GP feature is available through eConnect.

Throughout the documentation, the terms back office and front office are used. The term back office refers to the financial management system, in this case, Microsoft Dynamics GP. The term front office refers to customer relationship management systems, data warehouses, web sites, or other applications that communicate with the back office.

eConnect allows you to leverage the existing transaction-based business logic of Microsoft Dynamics GP. This allows you to focus your time and energy on creating or enhancing custom applications for the front office.


What eConnect can do

eConnect allows you to enhance your applications as follows:

  1. Add real-time access to Dynamics GP data.

eConnect provides real-time access to back office data. It offers a way to add up-to-date back office information to existing front office applications like web storefronts or service applications.

  2. Share financial management data across applications.

eConnect allows multiple applications to share financial management data. The eConnect interfaces can support a number of independent applications. Changes to financial data in Dynamics GP are simultaneously available to all applications with an eConnect connection to that company in Dynamics GP.

Application integrations using eConnect include the following benefits:

  1. Reduce development time.

eConnect has a large number of integration points for Microsoft Dynamics GP. Software developers can quickly add back office integration to an application. This reduces cost by simplifying the development effort while providing fast access to Microsoft Dynamics GP data. eConnect also reduces development time when the business logic contained in the back office is reused by new custom applications.

An eConnect integration also reduces costs by reducing data re-entry. An automated eConnect integration between Microsoft Dynamics GP and a new or existing online storefront, web service, or other data source eliminates the time and cost of manually copying data.

  2. Reuse existing development tools.

eConnect allows software developers to select their tool of choice when working with eConnect. Developers can use Microsoft .NET, Microsoft SQL Server stored procedures, BizTalk, or MSMQ.

  3. Leverage industry-standard technologies.

eConnect includes components for MSMQ and BizTalk Server, which are industry standard tools that support integration between applications.

eConnect also uses XML documents to move data into and out of Microsoft Dynamics GP. The XML documents are a text-based representation of back office data. An XML schema specifies the data that is included in each type of XML document. This allows eConnect to provide back office integration to any application capable of creating or consuming these XML documents.


eConnect Example

To help you understand how eConnect benefits your development effort, the following example presents a business problem and its solution using eConnect and Microsoft Dynamics GP.

Introduction

A theater business owns dozens of dinner theaters scattered throughout the United States. The company differentiates itself from its competitors by delivering high-quality service to its customers. To build upon this advantage, the company wants to allow customers to reserve specific theater seating while online.

The company wants a web-based system that customers use to reserve seats. In addition, the company wants to provide customers the ability to view the previous functions they attended. The web portal should also provide customers access to other valuable information and services.

Requirements

To provide the expected services, the solution must address the following requirements:

  • Use Windows Live ID for security for the online reservation system.
  • Allow customers to reserve one or more specific seats at a theater (for example, a single customer reserves 10 seats in a row for his or her family members).
  • Create a sales invoice in the back office when the reservation is submitted.
  • Allow a sales invoice to be cancelled.
  • Record a Microsoft Dynamics GP deposit for the reservation fee when the reservation is submitted.
  • Give customers the ability to request their dinner of choice from a specified group of vendors.
  • Allow customers to request specific items in the theater by using a handheld device that is situated at each table.
  • For non-reservation customers, allow a theater card to be swiped at arrival. The card automatically creates a sales invoice in the back office.
  • Create a payables transaction in the back office when food and beverage items are ordered. Submit a sales order to the vendor.
  • At the end of the theater presentation, generate a receipt for each customer.
  • Create payroll transactions for employee tips.
  • At the end of the theater presentation, a submit a check to each vendor. Each check includes all customer transactions for that vendor.

Solution

To meet these requirements, a web-based solution is proposed. The web application uses BizTalk and eConnect to integrate with Microsoft Dynamics GP. The combination of eConnect and BizTalk allow the web application to perform the following tasks:

  • Use eConnect to create the sales invoices in Microsoft Dynamics GP. The web application creates an eConnect XML document and sends it to a BizTalk queue. eConnect receives the XML document from BizTalk and uses the XML document to create the sales invoice.
  • Use eConnect to cancel an existing sales invoice. The web application creates an XML document and sends it to a BizTalk queue. eConnect receives the XML document from BizTalk and uses the XML document to void the specified sales invoice.
  • Use eConnect to create payables transactions representing the customer’s food and beverage orders. The web application creates an XML document and sends it to a BizTalk queue. eConnect receives the XML document from BizTalk and uses the XML document to create the payables transactions. The web application could also submit a receivables transaction to the vendor through the BizTalk server if the vendor is also using eConnect or an accounting system that supports a similar type of document exchange.
  • Use eConnect to process check submissions. The web application creates an XML document and sends it to a BizTalk queue. eConnect receives the XML document from BizTalk and completes the custom check submission. This step includes the following customizations:
  • Create a new stored procedure to handle the creation of checks for all vendor transactions.
  • Create a cash receipt. After creating the vendor check, create an XML document using Microsoft Dynamics GP data that details the check’s contents. Perform a transform of the XML document to create a cash receipt for the vendor. This transaction occurs after making a payment through an online credit card processing system.
  • Submit the cash receipts to the vendors. If the vendors also use BizTalk server, eConnect, and Microsoft Dynamics GP, develop a process to electronically submit the cash receipts.
  • Use eConnect to retrieve a specified invoice. The web application uses the XML document that is returned by eConnect to generate a printout for the customer.
  • Use eConnect to update payroll to reflect employee tips. The web application creates a XML document and sends it to a BizTalk queue. eConnect receives the XML document from the BizTalk queue and updates Microsoft Dynamics GP to reflect tip amounts for each employee.

Summary

The example shows how eConnect simplifies the development of the web solution. eConnect’s schema-based XML documents allows the application to easily incorporate back office functionality using existing development tools.

The example also shows how reusing the business logic and the transaction processing abilities of Microsoft Dynamics GP simplify development. The web application can submit the document and rely upon Microsoft Dynamics GP to successfully complete the transaction.

The example uses eConnect as part of a web-based solution. A web-based solution simplifies the deployment of features that use eConnect integrations. An update of the web application or web service makes your new or updated features immediately available to all users.


Getting started

To use eConnect in a development project, complete the following:

1. Review the eConnect architecture.

Review Architecture to familiarize yourself with eConnect’s components. eConnect supports several application programming interfaces (APIs) that you can use to integrate with Microsoft Dynamics GP. If you understand how eConnect’s underlying components work together, you can quickly identify the eConnect API that meets the needs of your integration project.

2. Discuss the installation process.

Before starting a new project, discuss the eConnect installation procedure with your system administrator. You need to ensure the eConnect business objects are installed on the Microsoft Dynamics GP server. You also need to identify any unique configuration settings that occurred during installation. You should evaluate how configuration settings impact each eConnect API.

3. Learn about eConnect XML documents.

eConnect uses XML documents to describe Microsoft Dynamics GP documents and transactions. Refer to eConnect Schema and XML Documents, to learn how eConnect XML documents are structured. Refer to the Schema Reference and an XML Node Reference of the eConnect help documentation to learn about specific eConnect schemas, nodes, and elements.

4. Select the API for your project.

Once you select the eConnect API you intend to use, review the portion of the Programmer’s Guide that discusses that API. For example, if you want to use eConnect with a .NET development project, review .NET Development to learn how to add and use eConnect in your project.


Architecture

When using Microsoft Dynamics GP eConnect, it is helpful to understand its architecture. Architectural information is divided into the following sections:

  • Architecture diagram
  • Business objects
  • eConnect APIs
  • BizTalk
  • Transaction Requester


Architecture diagram

eConnect installs a collection of components that work together to provide programmatic access to Microsoft Dynamics GP data. The following diagram illustrates the basic components:

The diagram illustrates eConnect’s two key layers and the components that make up those layers. The two layers are as follows:

  • The data access layer contains the eConnect business objects. The business objects are a collection of SQL stored procedures installed on the Microsoft Dynamics GP server. eConnect uses the business objects to perform all retrieve, create, update, and delete operations.
  • The runtime layer contains a collection of files, Windows services, and components that provide the application programming interfaces (API) you use to send or retrieve XML documents. The API enable your application to use the business objects. You must install the components of the runtime layer on the same computer as your integrating application. When you develop a new application, install and use the API that best meets your integration needs.

The diagram shows that an integrating application can bypass the API layer and use the eConnect business objects directly.

The Transaction Requester is an interface you use to retrieve specified types of eConnect XML documents. Typically, the Transaction Requester uses the Outgoing Service to publish document to an MSMQ queue. The Transaction Requester includes the eConnect Requester Setup tool that you use to specify the types of transactions the Outgoing Service publishes as an XML document.


Business objects

The stored procedures contain the business logic used by eConnect. Any integration that uses eConnect to query, create, update, or delete data from Microsoft Dynamics GP uses one or more of these stored procedures.

The eConnect business objects include the Microsoft Dynamics GP documents and transactions that are commonly used in application integration. While eConnect supplies a large number of documents, not every Microsoft Dynamics GP feature is available through eConnect.

You cannot edit or modify the business logic in an eConnect stored procedure. To enable the customization of business logic, eConnect includes a pre and post stored procedures for each eConnect stored procedure. The pre stored procedure runs immediately before the eConnect stored procedure, while the post stored procedure runs immediately after the eConnect stored procedure. To customize the business logic, add SQL queries and commands to one or both of these stored procedures.

For example, assume you want the eConnect stored procedure named taCreateTerritory to always populate a field with a specified value. To implement your customization, add custom SQL code to the stored procedure named taCreateTerritoryPre that populates the field with the specified value. Your custom code runs immediately before every execution of the taCreateTerritory stored procedure.

The following diagram shows the typical sequence of events that occur within a business object:

Notice how the business object validates data parameters, adds default values, and performs a status check after each event. The business object uses status checks to handle errors. When a status check detects an error, it immediately stops the stored procedure, initiates a rollback of the transaction, and returns an error message to the caller.

For example, a status check detects that an error occurred during the update operation of the business object. The status check immediately stops the stored procedure, rolls back the transaction, and then returns an error message. In this scenario, the business object never runs the post stored procedure.

The eConnect business objects are placed on your database server during the install of Microsoft Dynamics GP, and the creation of a new company database. There are two ways to access the business objects.

  • Call individual business objects from the integrating application. However, direct calls require you to implement a connection to the database server, add security restrictions that prevent unauthorized access to data, and include proper error handling. For more information about direct calls, see Calling the business objects.
  • Use one of the APIs that eConnect provides. The APIs offer a simpler approach to using the eConnect business objects from an integrating application. The types of eConnect APIs that are available are discussed in the sections that follow.

Refer to Business Logic Overview for additional information about extending the business objects and calling the eConnect stored procedures.


eConnect APIs

eConnect provides a collection of APIs that allow you to use the business objects. There are APIs for Microsoft .NET, and Microsoft Message Queuing (MSMQ). The variety of eConnect APIs allows you to use the interface that best fits your integration project and the available development tools.

To support its API, eConnect supplies a Windows service named eConnect for Microsoft Dynamics GP 2013 Integration Service. The eConnect Integration Service manages interaction between your application and the eConnect business objects. You must install the eConnect Integration Service in the Services on the computer you use to run your applicaiton. Refer to the eConnect Installation and Administration Guide for information about installing and configuring the eConnect Integration Service.

To use the eConnect API, your application must create or read eConnect XML documents. Refer to eConnect XML Documents for additional information about creating eConnect XML documents.

The eConnect install includes files containing the XML schema for all its documents. A schema is an XML file (with typical extension .xsd) that describes the syntax and semantics of XML documents using a standard XML syntax. An XML schema specifies the content constraints and the vocabulary that compliant documents must accommodate.

You can use these files to perform validation. When eConnect validates a document, it uses the schema to ensure the document contains the expected information. It rejects documents that do not comply with the schema specifications. The schema files can also serve as a reference. Since the files describe each type of eConnect document, you can use them to research questions about the schemas, nodes, and elements a document may contain.

The following APIs use XML documents and the eConnect Integration Service:

Microsoft .NET

When you install the eConnect integration Service, the installer places two .NET assemblies on your computer. The installer also registers these assemblies in the global assembly cache.

You can add these assemblies to a Visual Studio project by adding a reference to each assembly file. Once you include the .NET assemblies in your project, you gain access to the eConnect Integration Service. The .NET assemblies enable your application to parse eConnect XML documents, create a connection to the Microsoft Dynamics GP server and call the eConnect business objects. Your eConnect enabled solution can then use XML documents to create, delete, update, or retrieve Microsoft Dynamics GP data.

Refer to eConnect and .NET for information about creating solutions using the eConnect .NET assemblies.

MSMQ

The MSMQ API includes two Windows services. The services are as follows:

  • The Incoming Service monitors a specified queue and retrieves XML documents placed in that queue. The Incoming Service then uses the eConnect Integration Service to parse the XML documents, create a connection to the Microsoft Dynamics GP server, and call the eConnect business objects. To use this API, you create an application that submits XML documents to the specified queue.
  • The Outgoing Service publishes XML documents to a queue in response to specified events in Microsoft Dynamics GP. To use this API, you create applications that retrieve the XML documents from the queue and perform actions based on the XML data.

To develop solutions that use the MSMQ API, you should carefully consider the following:

  • The MSMQ API is asynchronous. Due to the disconnected nature of the API, changes are not immediately reflected in Microsoft Dynamics GP or in the integrating application. In addition, your application cannot immediately determine whether a document submitted using the Incoming Service was successfully processed.
  • All applications that use the MSMQ API must be able to access the specified MSMQ queues.
  • The eConnect Outgoing Service relies on the eConnect Transaction Requester to create SQL triggers in the Microsoft Dynamics GP database. If you plan to use the Outgoing Service, you must use the Transaction Requester to identify the Microsoft Dynamics GP documents and events that you want the Outgoing Service to publish to a specified queue.

Refer to MSMQ for additional information about creating solutions using MSMQ and the Incoming and Outgoing Services.


BizTalk

eConnect provides a BizTalk application integration component (AIC) that you can install on your BizTalk server. The BizTalk adapter allows you to use BizTalk to manage interaction with eConnect business objects.

The adapter supports the use of eConnect as a part of a BizTalk orchestration or in a simple pass-through situation. A BizTalk orchestration allows applications with differing message formats to integrate, while a BizTalk pass-through simply routes messages between applications.

The choice between using a BizTalk Orchestration or a pass-through depends on the level of flexibility your solution requires. An orchestration provides the greatest flexibility. For example, you can customize the adapter by adding bindings to other applications.

Refer the BizTalk documentation for information about developing a BizTalk-based integration.


Transaction Requester

The Transaction Requester is a collection of SQL database tables and database triggers that eConnect uses to make Dynamics GP data changes available to the Outgoing Service. The following diagram illustrates the Transaction Requester:

When you install the Transaction Requester, the installer creates three tables in each specified Microsoft Dynamics GP database:

  • eConnect_Out This table stores data from selected create, update, or delete operations that occur within Microsoft Dynamics GP. The data identifies the individual transactions that occurred. The Outgoing Service uses the data in this table to create an XML document that is placed in a queue.
  • eConnect_Out_Setup This table contains configuration information for the Transaction Requester. To keep the Transaction Requester working, do not make changes to this table.
  • eConnectOutTemp This table is a temporary data store.

For example, assume you want your application to be updated when a new customer is added to Microsoft Dynamics GP. To begin, you use the eConnect Requester Setup utility to specify the customer object and the SQL insert operation. The eConnect Requester Setup adds a SQL trigger to the database. When a new customer record is inserted, the SQL trigger creates a record of the event in the eConnect_Out table.

The eConnect Outgoing Service periodically queries the eConnect_Out table. The service uses the record in the table to create an XML document that describes the new customer document.

The Outgoing Service then places the XML document in a message queue where it can be retrieved and used by your application.

To configure the eConnect Transaction Requester, use the eConnect Requester Setup utility. The eConnect Requester Setup utility allows you to specify Dynamics GP objects and operations you want to export to another application. The utility then adds SQL triggers to Dynamics GP that populate the eConnect_Out table for the specified objects and operations. For a detailed explanation of how to use the eConnect Requester Setup utility, see the eConnect Installation and Administration Guide.

Refer to Customizing the Transaction Requester for information about using and customizing the Transaction Requester Service.


eConnect Schema and XML Documents

To use eConnect, you must be able to create or consume eConnect XML documents. This portion of the documentation explains the XML schemas that govern how eConnect XML documents are assembled. The list that follows contains the information you need to understand eConnect’s XML schema and documents:

  • eConnect Schema introduces eConnect XML schema. The schema define how to supply data using eConnect XML documents. The schema also allow you to validate the documents you submit to ensure they can be processed by eConnect.
  • eConnect XML Documents introduces eConnect XML documents. Review this information to understand how you use these XML documents to describe Microsoft Dynamics GP documents and operations.
  • XML Document Examples provides examples of eConnect XML document. The examples demonstrates how XML components fit together to create an actual eConnect XML document.


eConnect Schema

To integrate your application with Microsoft Dynamics GP, eConnect requires you to submit XML documents that describe Microsoft Dynamics GP documents and transactions. To ensure the documents can be consistently processed, eConnect supplies a collection of XML schema that define the XML documents eConnect accepts. Information about the schemas include the following:

  • eConnect schema overview
  • Installing eConnect schema
  • Using eConnect schema
  • eConnect schema reference


eConnect schema overview

eConnect uses XML schema to define what an eConnect XML document contains. A schema is an XML file (with typical extension .xsd) that describes the syntax and semantics of XML documents using a standard XML syntax. An XML schema specifies the content constraints and the vocabulary that compliant documents must accommodate.

eConnect transports the XML documents as messages between your application and eConnect.


Installing eConnect schema

When you include the schemas component of the eConnect install, the installer places schema files in a schemas folder on your computer. The following schema resources are available:

  • The install places the .xsd schema files in the directory c:\Program Files\Microsoft Dynamics\eConnect 12.0\XML Sample Documents\Incoming XSD Individual Schemas. The files in the directory contain the schema for each eConnect XML document.
  • The install places a file named eConnect.xsd that contains the schema definition for all eConnect XML documents. The install typically places this file in the directory c:\Program Files\Microsoft Dynamics\eConnect 12.0\XML Sample Documents\Incoming XSD Schemas.


Using eConnect schema

To use the eConnect application programming interfaces (APIs), your application must be able to create XML documents or read XML documents based on these schema. If you submit a document that does not comply with its schema definition, it will be rejected and an error will be logged in the eConnect event log.

The schema files also allow you to perform validation of the documents you create. The eConnect API allow you to specify the schema file for the document.

  • Use the eConnect.xsd file when your application needs to validate all types of XML documents.
  • Use the individual document XSD files to perform validation for a specific eConnect XML document.

The schema files contain the definition of each eConnect XML document, transaction type schema, and XML node. If you have questions about the schema XML nodes, and elements for a specified eConnect document, the schema files are the definitive source of the information you need.


eConnect schema reference

The eConnect online help documentation contains two reference sections that describes the eConnect transaction type schemas and the XML nodes. These references help you identify the nodes, elements, and values you can use in an eConnect XML document.

Refer to XML Schema Reference for a list of the schema that eConnect provides.


eConnect XML Documents

An eConnect XML document is a text based data structure that represents a Microsoft Dynamics GP transaction or document. To submit or retrieve Microsoft Dynamics GP data, you send or receive data as an eConnect XML document.

You use an eConnect XML document to represent the data for a Microsoft Dynamics GP operation. For example, you have to create an XML document when you want to add or update a record in Microsoft Dynamics GP.

To help you create an eConnect XML document, you can use the classes in the Microsoft.Dynamics.GP.eConnect.Serialization .NET assembly. You can use the classes to create a document and then convert that document to XML. For information about the serialization classes, see Creating an eConnect document for a .NET project and Serializing an eConnect document object.

When you use eConnect to retrieve a Microsoft Dynamics GP document, the data appears as an eConnect XML document. To use the data, you get values from the XML document.

The following sections provide more detailed information about eConnect XML documents:

  • eConnect XML document structure
  • Creating an eConnect XML document
  • Using the eConnect XML document sample files
  • Using eConnect to update existing data
  • Automating document number assignment
  • Special characters in eConnect XML documents


eConnect XML document structure

An eConnect XML document is collection of related XML components that represent a Microsoft Dynamics GP transaction or document. The XML components are in a parent/child hierarchy that define the data structure for the document type. The components and hierarchy for a document type is specified by an XML schema. For information about the schema, see eConnect schema overview.

The following table lists the basic components of an eConnect XML document:

Component type | Description
eConnect document | The root of the document. The eConnect document is the parent to one or more eConnect transaction type nodes.
eConnect transaction type | Specifies the type of the document or transaction. The transaction type is the parent to one or more eConnect XML nodes.
eConnect XML nodes | The parent to one or elements. The elements contain the data values for the document.

The following diagram illustrates a simple eConnect XML document. Notice how the eConnect document implements the parent/child relationships specified by the eConnect schema. Also notice how the eConnect transaction type is the parent to the <eConnectProcessInfo> and <taSopHdrIvcInsert> eConnect XML nodes.

eConnect document

An eConnect XML document always contains a single <eConnect> node. The <eConnect> node is the root node of the document. The <eConnect> node contains one or more transaction type nodes.

In addition, the <eConnect> node defines the scope of the SQL transaction for the specified operation. If any child component of the <eConnect> node fails, a rollback is performed that removes all the changes and updates specified by the XML document.

As a result, an eConnect XML document should include information related to a single Microsoft Dynamics GP operation. This ensures all the component pieces of the operation are consistently applied or rolled back.

If you encounter a situation that requires using unrelated transaction types within a document, evaluate whether a SQL rollback will cause problems for your application or your Microsoft Dynamics GP data.

eConnect Transaction Type

An eConnect transaction type is an XML component that represents a Microsoft Dynamics GP document or operation. An eConnect XML document always includes one or more transaction type nodes. If you want your eConnect XML document to perform more than one operation, you have to add a transaction type node for each operation.

To create an eConnect XML document, you first add a transaction type node to the <eConnect> root node. For example, you add a <RMCustomerMasterType> transaction type node to a document that represents a new customer.

A transaction type node is the parent of one or more eConnect XML nodes. The eConnect schema files show the XML nodes you use to populate each transaction type. For information about the schema files, see Using eConnect schema.

eConnect XML node

An eConnect node is an XML component that contains a collection of elements. An element has a name and can contain a data value. You use the data values of the elements when you use eConnect to perform a Microsoft Dynamics GP operation. The eConnect schema files specify the elements contained in an XML node.

Some eConnect transaction types can include a collection of more than one XML node of a specified type. The schema identifies these nodes by appending “_Items" to the node name. For example, the <RMCustomerMasterType> can include more than one address for a customer. The <taCreateCustomerAddress_Items> node indicates that you can add more than one <taCreateCustomerAddress> XML node for a customer.

The following table describes the properties for an eConnect XML element:

Property | Description
Name | Specifies the name that identifies the element. You use the name to identify a specific element in a document.
Required | Specifies whether the element requires a value. If you do specify a value for the element, the transaction produces an error, In the schema files, a required element has both the minOccurs and maxOccurs property set to 1.
Type | Specifies the expected data type for the element value. For example, an element that contains text will have a data type of string.
Default | Specifies the default value for an element.
Length | Specifies the maximum data length of the value you can use to populate an element. The length is determined by the business object input parameter that handles the specified element.
Constraint | Specifies the data value or values that the element can accept. To populate the element, you must specify a value that satisfies the data constraint. If you specify a value that does not meet the data constraint, an error occurs and the transaction fails.

The <eConnectProcessInfo> node

The eConnect schema specifies that the first XML node of each eConnect transaction type schema must be an <eConnectProcessInfo> node. You can use the elements of the <eConnectProcessInfo> node to change how specific transaction types are processed. The following example shows how to use the <eConnectProcessInfo> node to override the default eConnect connection string:

<eConnectProcessInfo>
    <ConnectionString>
        Integrated Security=SSPI;
        Persist Security Info=False;
        Initial Catalog=TWO;
        Data Source=machinename
    </ConnectionString>
</eConnectProcessInfo>

Refer to XML Schema Reference to view the transaction type schemas.


Creating an eConnect XML document

An eConnect XML document is a text-based representation of a Microsoft Dynamics GP document or transaction. As a result, you can use many XML or text tools to produce an eConnect XML document.

However, you must structure the XML in the document to comply with the hierarchy of nodes specified by the eConnect schema for the specified eConnect transaction type. If you do not provide the XML nodes and elements in the expected order, the document will be rejected.

To manually create an XML document, find the eConnect transaction type in the XML Schema Reference and add the XML nodes in the specified order. Next, find each XML node in the XML Node Reference and add the XML elements in the specified order.

You can also use the schema file for the specified transaction type to validate the structure of your XML document.

After you create the XML document, you can use MSMQ or the .NET assembly (Microsoft.Dynamics.GP.eConnect.dll) to submit the XML document to eConnect. Any XML document that you submit keeps the XML nodes and element in the order that you provided. MSMQ and the classes in the eConnect assembly do not change the order of the XML nodes and elements.

To create an eConnect document for a .NET project, you can use the eConnect serialization assembly. The Microsoft.Dynamics.GP.eConnect.Serialization assembly is a .NET assembly that you can use to programmatically produce eConnect XML documents. To learn more about how to use the serialization classes, see Serializing an eConnect document object.

The serialization assembly does automatically order the XML nodes and elements to comply with the eConnect schema requirements.


Using the eConnect XML document sample files

To assist you with developing and testing eConnect solutions, the eConnect SDK includes several files that contain sample XML documents. Typically, the eConnect install places these files in the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\XML Sample Documents\Incoming

The XML files represent several types of eConnect documents and include test data. You can use the sample documents as an example for an XML document you want to use. You can also use the sample documents to test an eConnect application.


Using eConnect to update existing data

Many eConnect XML documents allow you to update existing Microsoft Dynamics GP documents. To perform an update, your eConnect XML document must include XML nodes that provide update functionality.

XML nodes with update functionality represent eConnect business objects that can determine whether the node identifies an existing Microsoft Dynamics GP data document. If the document exists, the business object updates that document. If an existing document is not found, the business object creates a new Microsoft Dynamics GP data document.

When the eConnect business object updates an existing Microsoft Dynamics GP document, it uses one of the following techniques:

  • The business object completes a document exchange. A document exchange replaces all existing data with the values supplied by the XML node elements. If the XML node leaves an element empty, the business object replaces the previous value in Microsoft Dynamics GP with the eConnect default value. Document exchange requires your XML node to include values for all the elements and not just the elements that are being updated.
  • The business object completes field level updates. Field level updates allow your XML node to include only the elements that have new values. If the XML node excludes an element, the existing value in Microsoft Dynamics GP remains unchanged.

The XML Node Reference identifies XML nodes that provide update functionality. The description of these XML nodes specify whether the nodes perform a document exchange or a field level update.


Automating document number assignment

Microsoft Dynamics GP uses document numbers to uniquely identify each document. Many types of documents have document numbers. Each document type has a specified series of numbers and a new document is given the next available number from the series. When you use eConnect to create a document, you have to give that document a unique document number.

To simplify the numbering of new documents, several types of eConnect XML documents automate the assignment of the document number. The document gets the next available number at the time that it is created in Microsoft Dynamics GP.

The following table shows the eConnect documents and schemas that support the automated assignment of a document number:

Document Type | Schema name | XML element
General Ledger | GLTransaction | <JRNENTRY></JRNENTRY>
Inventory | IVInventoryTransaction | <IVDOCNBR></IVDOCNBR>
Inventory | IVInventoryTransfer | <IVDOCNBR></IVDOCNBR>
Purchase Order Processing | POPReceivings | <POPRCTNM></POPRCTNM>
Purchase Order Processing | POPTransaction | <PONUMBER></PONUMBER>
Purchasing | PMTransaction | <VCHNUMWK></VCHNUMWK>
Receivables | RMTransaction | <DOCNUMBR></DOCNUMBR>
Sales Order Processing | SOPTransaction | <SOPNUMBE></SOPNUMBE>

To have eConnect supply a document number, your XML document must contain a schema that supports automatic numbering. The XML nodes in the schema must include the XML element that specifies the document number, but the value of the element must remain empty.

The following XML example shows how to use automated number assignment for a new GL transaction document. Notice how the value of the <JRNENTRY> element is empty. When the business object encounters the empty element, the business object performs a query that gets the next available GL journal entry number. The business object uses the query result to populate the <JRNENTRY> element.

<taGLTransactionHeaderInsert>
    <BACHNUMB>TEST14</BACHNUMB>
    <JRNENTRY></JRNENTRY>
    <REFRENCE>General Transaction</REFRENCE>
    <TRXDATE>2007-01-21</TRXDATE>
    <RVRSNGDT>1900-01-01</RVRSNGDT>
    <TRXTYPE>0</TRXTYPE>
    <SQNCLINE>16384</SQNCLINE>
</taGLTransactionHeaderInsert>

However, SOP documents do not require an empty element. When you create a SOP document, eConnect assigns a document number even if the <SOPNUMBE> element is excluded from the XML document.

There are several types of SOP documents and each type uses a separate series of document numbers. To specify the type of a SOP document, you use the <SOPTYPE> and <DOCID> elements.

For example, you want to create a new sales order document. You add a <taSopHdrIvcInsert> XML node to you document. To get the correct type of document number, you populate the <SOPTYPE> with 2 and the <DOCID> with STDORD. You do not include the <SOPNUMBE> element. When you submit the document, it gets the next available document number for a sales order.

You can override the behavior that adds the document number. If you populate the document number element with a value, eConnect always uses the specified value in the Microsoft Dynamics GP document.

The following XML example shows an eConnect XML document that uses automatic document numbering. Notice how the <taGLTransactionLineInsert> and <taGLTransactionHeaderInsert> XML nodes include an empty <JRNENTRY> element.

<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <GLTransactionType>
        <taGLTransactionLineInsert_Items>
            <taGLTransactionLineInsert>
                <BACHNUMB>TEST14</BACHNUMB>
                <JRNENTRY></JRNENTRY>
                <SQNCLINE>16384</SQNCLINE>
                <ACTINDX>0</ACTINDX>
                <CRDTAMNT>15.00</CRDTAMNT>
                <DEBITAMT>0.00</DEBITAMT>
                <ACTNUMST>000-2300-00</ACTNUMST>
            </taGLTransactionLineInsert>
            <taGLTransactionLineInsert>
                <BACHNUMB>TEST14</BACHNUMB>
                <JRNENTRY></JRNENTRY>
                <SQNCLINE>32768</SQNCLINE>
                <ACTINDX>0</ACTINDX>
                <CRDTAMNT>0.00</CRDTAMNT>
                <DEBITAMT>15.00</DEBITAMT>
                <ACTNUMST>000-2310-00</ACTNUMST>
            </taGLTransactionLineInsert>
        </taGLTransactionLineInsert_Items>
        <taGLTransactionHeaderInsert>
            <BACHNUMB>TEST14</BACHNUMB>
            <JRNENTRY></JRNENTRY>
            <REFRENCE>General Transaction</REFRENCE>
            <TRXDATE>2007-01-21</TRXDATE>
            <RVRSNGDT>1900-01-01</RVRSNGDT>
            <TRXTYPE>0</TRXTYPE>
            <SQNCLINE>16384</SQNCLINE>
        </taGLTransactionHeaderInsert>
    </GLTransactionType>
</eConnect>


Special characters in eConnect XML documents

If your XML data contains one or more special characters, you must add a CDATA format tag to your data element. The following table lists the special characters that require the use of a CDATA tag.

Special character | Special meaning | Entity encoding
< | Begins a tag | &lt;
> | Ends a tag | &gt;
“ | Quotation mark | &quot;
‘ | Apostrophe | &apos;
& | Ampersand | &amp;

The MSXML parser requires a CDATA format tag when you use one of these characters. The following example demonstrates the use of a CDATA format tag:

<VENDNAME>
    <![CDATA[Consolidated Telephone & Telegraph]]>
</VENDNAME>

You can also use a CDATA tag to remove data from a field. To clear data from a field, create an eConnect XML document that updates the targeted record. Use a CDATA tag that contains a blank space to populate the eConnect element that represents the field.

The following example uses a CDATA tag to clear the Short Name field of a customer. Notice how the CDATA tag contains a single blank space.

<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <RMCustomerMasterType>
        <eConnectProcessInfo>
        </eConnectProcessInfo>
        <taUpdateCreateCustomerRcd>
            <CUSTNMBR>AARONFIT0001</CUSTNMBR>
            <SHRTNAME>
                <![CDATA[ ]]>
            </SHRTNAME>
            <UpdateIfExists>1</UpdateIfExists>
        </taUpdateCreateCustomerRcd>
    </RMCustomerMasterType>
</eConnect>


XML Document Examples

This portion of the documentation contains XML examples that show how to use an eConnect document to create, retrieve, update and delete a record. The following sections include XML examples for each type of operation:

  • Create a customer
  • Delete a customer address
  • Retrieve a customer
  • Assign a document number to a sales order


Create a customer

The following XML example uses an eConnect XML document to create a customer. Note the following characteristics of the document:

  • The document contains a single <RMCustomerMasterType> transaction type schema. The schema specifies the XML nodes you use to create a customer.
  • You use the <taUpdateCreateCustomerRcd> node to describe the customer record.
  • Notice how the elements of the <taUpdateCreateCustomerRcd> node are populated with values that identify the new customer.
<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <RMCustomerMasterType>
        <eConnectProcessInfo>
        </eConnectProcessInfo>
        <taUpdateCreateCustomerRcd>
            <CUSTNMBR>JEFF0002</CUSTNMBR>
            <CUSTNAME>JL Lawn Care Service</CUSTNAME>
            <STMTNAME>JL Lawn Care Service</STMTNAME>
            <SHRTNAME>JL Lawn Care</SHRTNAME>
            <ADRSCODE>PRIMARY</ADRSCODE>
            <ADDRESS1>123 Main Street</ADDRESS1>
            <CITY>Valley City</CITY>
            <STATE>ND</STATE>
            <ZIPCODE>58072</ZIPCODE>
            <COUNTRY>USA</COUNTRY>
            <PHNUMBR1>55532336790000</PHNUMBR1>
            <PHNUMBR2>55551161817181</PHNUMBR2>
            <FAX>55584881000000</FAX>
            <UPSZONE>red</UPSZONE>
            <SHIPMTHD>PICKUP</SHIPMTHD>
            <TAXSCHID>USALLEXMPT-0</TAXSCHID>
            <PRBTADCD>PRIMARY</PRBTADCD>
            <PRSTADCD>PRIMARY</PRSTADCD>
            <STADDRCD>PRIMARY</STADDRCD>
            <SLPRSNID>GREG E.</SLPRSNID>
            <SALSTERR>TERRITORY 6</SALSTERR>
            <COMMENT1>comment1</COMMENT1>
            <COMMENT2>comment2</COMMENT2>
            <PYMTRMID>Net 30</PYMTRMID>
            <CHEKBKID>PAYROLL</CHEKBKID>
            <KPCALHST>0</KPCALHST>
            <RMCSHACTNUMST>000-1100-00</RMCSHACTNUMST>
            <UseCustomerClass>0</UseCustomerClass>
            <UpdateIfExists>1</UpdateIfExists>
        </taUpdateCreateCustomerRcd>
    </RMCustomerMasterType>
</eConnect>


Delete a customer address

The following XML example shows how to use an eConnect XML document to delete a customer address. Note the following characteristics of the document:

  • The document contains a single <RMDeleteCustomerAddressType> transaction type schema. The schema specifies the XML node you use to identify an address record.
  • Notice how the <RMDeleteCustomerAddress> schema includes a single <taDeleteCustomerAddress> XML node.
  • Notice how the elements of the <taDeleteCustomerAddress> XML node are populated with values that identify the customer address you want to delete.
<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <RMDeleteCustomerAddressType>
        <taDeleteCustomerAddress>
            <CUSTNMBR>AARONFIT0001</CUSTNMBR>
            <ADRSCODE>WAREHOUSE</ADRSCODE>
        </taDeleteCustomerAddress>
    </RMDeleteCustomerAddress>
</eConnect>


Retrieve a customer

The following XML example shows how to use an eConnect XML document to retrieve a customer record. Note the following characteristics of the document:

  • The document contains a single <RQeConnectOutType> transaction type schema. The schema contains XML nodes you use to specify an existing customer record.
  • Notice how the <RQeConnectOutType> schema includes <eConnectProcessInfo> and <eConnectOut> nodes. You use these nodes to specify the customer and how you want to retrieve the data for the customer record.
  • Notice how the <Outgoing> element of the <eConnectProcessInfo> node is set to TRUE. You use TRUE to specify that this is a request for an existing record. Also notice how the <MessageID> element describes the record type.
  • Notice that the <DOCTYPE> element of the <eConnectOut> node specifies the value Customer. The value identifies the type of document in the eConnect_Out_Setup table that you want to use to retrieve the record.
  • Notice how the <OUTPUTTYPE> element specifies the value of 2. A value of 2 instructs eConnect to return complete customer record for the specified customer.
  • Notice how the <INDEX1TO> and <INDEX1FROM> elements specify the ID of the customer you want to retrieve. To retrieve a customer, the INDEX1 column in the eConnect_Out_Setup table requires you to submit a CUSTNMBR value. To retrieve a single record, you use the same ID value to populate the <INDEX1TO> and <INDEX1FROM> elements.
  • The values that populate the <FORLOAD>, <FORLIST>, and <ACTION> elements instruct eConnect to return the document to the caller and not create a record in the eConnect_Out table.
<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <RQeConnectOutType>
        <eConnectProcessInfo>
            <Outgoing>TRUE</Outgoing>
            <MessageID>Customer</MessageID>
        </eConnectProcessInfo>
        <eConnectOut>
            <DOCTYPE>Customer</DOCTYPE>
            <OUTPUTTYPE>2</OUTPUTTYPE>
            <INDEX1TO>ADAMPARK0001</INDEX1TO>
            <INDEX1FROM>ADAMPARK0001</INDEX1FROM>
            <FORLOAD>0</FORLOAD>
            <FORLIST>1</FORLIST>
            <ACTION>0</ACTION>
            <ROWCOUNT>0</ROWCOUNT>
            <REMOVE>0</REMOVE>
        </eConnectOut>
    </RQeConnectOutType>
</eConnect>


Assign a document number to a sales order

The following XML example shows how to use an eConnect XML document to create a sales order. In addition, the document uses eConnect to query Microsoft Dynamics GP for a sales order number. The query result populates the <SOPNUMBE> element of the document. Note the following characteristics of the document:

  • The document contains a single <SOPTransactionType> transaction type schema. The schema specifies the XML nodes you use to create a sales order.
  • Notice how the document uses a <taSopLineIvcInsert> node to create a line item and a <taSopHdrIvcInsert> node for the header of the sales order. The <taSopLineIvcInsert_Items> node enables the document to include one or more line items.
  • Notice how the <SOPNUMBE> element of the <taSopLineIvcInsert> and <taSopHdrIvcInsert> nodes do not specify a value. The element will be populated when the query obtains the new sales order number.
  • Notice how the <SOPTYPE> element of the <taSopLineIvcInsert> and <taSopHdrIvcInsert> nodes are populated the with the value of 2. The value specifies that the document is a sales order.
  • Notice that the <DOCID> element of the <taSopHdrIvcInsert> node is populated with the value STDORD. The value specifies the type of sales order you want to create.
  • The values you use in the <SOPTYPE> and <DOCID> elements determine the type of Microsoft Dynamics GP document number that is requested for this sales order.
<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <SOPTransactionType>
        <taSopLineIvcInsert_Items>
            <taSopLineIvcInsert>
                <SOPTYPE>2</SOPTYPE>
                <SOPNUMBE></SOPNUMBE>
                <CUSTNMBR>ALTONMAN0001</CUSTNMBR>
                <DOCDATE>2007-03-03</DOCDATE>
                <LOCNCODE>WAREHOUSE</LOCNCODE>
                <ITEMNMBR>ACCS-CRD-12WH</ITEMNMBR>
                <UNITPRCE>9.95</UNITPRCE>
                <XTNDPRCE>19.90</XTNDPRCE>
                <QUANTITY>2</QUANTITY>
                <MRKDNAMT>0</MRKDNAMT>
                <COMMNTID>TEST</COMMNTID>
                <COMMENT_1>cmt1</COMMENT_1>
                <COMMENT_2>cmt2</COMMENT_2>
                <COMMENT_3>cmt3</COMMENT_3>
                <COMMENT_4>cmt4</COMMENT_4>
                <ITEMDESC>yes</ITEMDESC>
                <TAXAMNT>0</TAXAMNT>
                <QTYONHND>0</QTYONHND>
                <QTYRTRND>0</QTYRTRND>
                <QTYINUSE>0</QTYINUSE>
                <QTYINSVC>0</QTYINSVC>
                <QTYDMGED>0</QTYDMGED>
                <NONINVEN>0</NONINVEN>
                <LNITMSEQ>0</LNITMSEQ>
                <DROPSHIP>0</DROPSHIP>
                <QTYTBAOR>0</QTYTBAOR>
                <DOCID>STDORD</DOCID>
                <SALSTERR>TERRITORY 2</SALSTERR>
                <SLPRSNID>GREG E.</SLPRSNID>
            </taSopLineIvcInsert>
        </taSopLineIvcInsert_Items>
        <taSopHdrIvcInsert>
            <SOPTYPE>2</SOPTYPE>
            <DOCID>STDORD</DOCID>
            <SOPNUMBE></SOPNUMBE>
            <ORIGNUMB>0</ORIGNUMB>
            <ORIGTYPE>0</ORIGTYPE>
            <TAXSCHID>USASTCITY-6*</TAXSCHID>
            <FRTSCHID>USASTCITY-6*</FRTSCHID>
            <MSCSCHID>USASTCITY-6*</MSCSCHID>
            <SHIPMTHD>UPS GROUND</SHIPMTHD>
            <TAXAMNT>0</TAXAMNT>
            <LOCNCODE>WAREHOUSE</LOCNCODE>
            <DOCDATE>2007-03-03</DOCDATE>
            <FREIGHT>3.00</FREIGHT>
            <MISCAMNT>2.00</MISCAMNT>
            <TRDISAMT>0</TRDISAMT>
            <DISTKNAM>0</DISTKNAM>
            <MRKDNAMT>0</MRKDNAMT>
            <CUSTNMBR>ALTONMAN0001</CUSTNMBR>
            <CUSTNAME>Alton Manufacturing</CUSTNAME>
            <CSTPONBR>4859</CSTPONBR>
            <ShipToName>SERVICE</ShipToName>
            <ADDRESS1>P.O. Box 3333</ADDRESS1>
            <CNTCPRSN>person1</CNTCPRSN>
            <FAXNUMBR>55553200810000</FAXNUMBR>
            <CITY>Detroit</CITY>
            <STATE>MI</STATE>
            <ZIPCODE>48233-3343</ZIPCODE>
            <COUNTRY>USA</COUNTRY>
            <PHNUMBR1>55553289890000</PHNUMBR1>
            <PHNUMBR3>55553200810000</PHNUMBR3>
            <SUBTOTAL>19.90</SUBTOTAL>
            <DOCAMNT>24.90</DOCAMNT>
            <PYMTRCVD>0</PYMTRCVD>
            <SALSTERR>TERRITORY 2</SALSTERR>
            <SLPRSNID>GREG E.</SLPRSNID>
            <USER2ENT>sa</USER2ENT>
            <BACHNUMB>TEST</BACHNUMB>
            <PRBTADCD>PRIMARY</PRBTADCD>
            <PRSTADCD>SERVICE</PRSTADCD>
            <FRTTXAMT>0</FRTTXAMT>
            <MSCTXAMT>0</MSCTXAMT>
            <ORDRDATE>2007-03-03</ORDRDATE>
            <MSTRNUMB>0</MSTRNUMB>
            <NONINVEN>0</NONINVEN>
            <PYMTRMID>2% 10/Net 30</PYMTRMID>
            <USINGHEADERLEVELTAXES>0</USINGHEADERLEVELTAXES>
            <CREATECOMM>0</CREATECOMM>
            <CREATETAXES>1</CREATETAXES>
            <DEFTAXSCHDS>0</DEFTAXSCHDS>
            <FREIGTBLE>1</FREIGTBLE>
            <MISCTBLE>1</MISCTBLE>
        </taSopHdrIvcInsert>
    </SOPTransactionType>
</eConnect>


.NET Development

This section of the documentation discusses how to include eConnect in a .NET development project. The eConnect runtime includes .NET assemblies that enable you to view, create, update, and delete or void Microsoft Dynamics GP data from a Microsoft .NET solution. The following sections describe how to add and use the eConnect .NET assemblies:

  • .NET Development Overview introduces the eConnect assemblies and namespaces. You use these assemblies and namespaces to add eConnect to your .NET development project.
  • eConnect and .NET describes how to use classes in the Microsoft.Dynamics.GP.eConnect namespace. You use classes from the Microsoft.Dynamics.GP.eConnect namespace to send and request eConnect XML documents from your .NET solution.
  • Serialization describes how to use the classes in the Microsoft.Dynamics.GP.eConnect.Serialization namespace. You use the serialization classes to create .NET objects that represent eConnect XML documents.
  • eConnect Integration Service describes how to use the eConnect Integration Service from a .NET application. You use the service to send and request eConnect XML documents from your .NET solution.


.NET Development Overview

This section of the documentation describes how to add an eConnect .NET assembly to a Microsoft Visual Studio development project. To access the eConnect business objects from a .NET solution, you must add one or more of the eConnect .NET assemblies to your development project. The following topics describe how to add an eConnect assembly and namespace to a project in Visual Studio:

  • eConnect and .NET
  • Adding a reference
  • Including the namespace
  • Specifying configuration settings
  • Tracing an eConnect .NET application


eConnect and .NET

A .NET assembly is the fundamental building block of all .NET applications. An assembly includes the types and resources that produce a logical unit of functionality. In eConnect, an assembly is stored as a .dll file.

To add eConnect functionality to a .NET solution, you use one or more of the following assemblies:

  • Microsoft.Dynamics.GP.eConnect.dll
  • Microsoft.Dynamics.GP.eConnect.Serialization.dll

The eConnect installer typically places these files in the directory c:\Program Files\Microsoft Dynamics\eConnect 12.0\Objects\Dot Net.

Each eConnect assembly contains an eConnect namespace. The values of each namespace matches the name of the assembly where it is found. For example, the Microsoft.Dynamics.GP.eConnect.dll assembly is where you find the Microsoft.Dynamics.GP.eConnect namespace.

Each eConnect namespace is a collection of related classes and enumerations. For example, the Microsoft.Dynamics.GP.eConnect namespace includes the eConnectMethods class as well as other classes and enumerations. For more information about eConnect namespaces, classes, and enumerations, see eConnect .NET Reference.

To use an eConnect class in a .NET development project, use Visual Studio to add a reference to the assembly that contains the namespace for that class. For information about how to add a reference, see Adding a reference.

To use the eConnect .NET assemblies, you must have Microsoft .NET Framework 2.0, or Microsoft Visual Studio 2005 or later installed on your computer.


Adding a reference

To add an eConnect class or enumeration to your .NET development project, use Visual Studio to add a reference to the eConnect assembly. To add a reference, complete the following steps:

  1. Open the Add Reference window.

From the Visual Studio Project menu, click Add Reference. The Add Reference window opens and displays the .NET tab.

  2. Find the assembly.

In the .NET tab, scroll the list of assemblies and click the eConnect assembly name. For example, click Microsoft.Dynamics.GP.eConnect.

  3. Add a reference to the assembly.

To add the reference, click OK. The specified assembly is added to the list of references for your Visual Studio project. The Add Reference window closes.


Including the namespace

Each eConnect assembly defines a namespace for the classes that it contains. A .NET namespace is a second organizational method that groups type names in a effort to reduce the chance of a name collision. The eConnect namespaces are as follows:

  • Microsoft.Dynamics.GP.eConnect
  • Microsoft.Dynamics.GP.eConnect.Serialization

You typically includes the namespace when you specify the type of an eConnect object. To demonstrate the use of a namespace, the following Visual Basic example instantiates a GetSopNumber object. Notice how the namespace and class name are used to specify the object type:

'Use GetSopNumber from the Microsoft.Dynamics.GP.eConnect
'namespace
Dim SopNumber As New Microsoft.Dynamics.GP.eConnect.GetSopNumber

To simplify your code, use the Visual Basic Imports statement or C# using statement to specify the namespace from a referenced assembly. These statements eliminate the need to include the namespace when you specify an object type.

The following Visual Basic example uses the Imports statement to add the Microsoft.Dynamics.GP.eConnect namespace to the .vb file of a project. You typically add the Imports statement to the top of the file where you are using the members of that namespace:

Imports Microsoft.Dynamics.GP.eConnect

The following C# example shows how to add a using statement to include namespace information in the .cs file of a project. You typically add the using statement to the top of the file:

using Microsoft.Dynamics.GP.eConnect;

After you use the Imports or using statements to include a namespace, you can use the eConnect class name to specify the type of an object. The following Visual Basic example shows how to import the Microsoft.Dynamics.GP.eConnect namespace and then instantiate a GetSopNumber object.

Imports Microsoft.Dynamics.GP.eConnect

'Use GetSopNumber from the Microsoft.Dynamics.GP.eConnect namespace
Dim SopNumber As New GetSopNumber

If you are using the eConnect Integration Service you can use Imports or using statements for the service reference. The following Visual Basic example shows how to import the service reference for an application named VbTestApp.

Imports vbServiceTestApp.eConnectIntegrationService

The following C# code example shows how to add a using statement for a service reference to an application named ServiceTestApp.

using ServiceTestApp.eConnectIntegrationService;


Specifying configuration settings

To optimize the performance of your application, you might want to customize how your application interacts with the eConnect Integration Service. For example, if you use eConnect to send large eConnect XML documents, you might want to increase the settings that specify maximum message size.

To specify configuration settings, you add one or more key nodes to the <appSetting> node of the configuration file. The configuration file you update depends upon whether you are using a reference to the Microsoft.Dynamics.GP.eConnect assembly or a service reference to the eConnect Integration Service.

Reference type | Configuration file | Description
Reference | <ApplicationName>.exe.config | Add configuration keys to the application configuration file of your .NET application.
Service reference | Microsoft.Dynamics.GP.eConnect.Service.exe.config | Add configuration keys to the configuration file of the eConnect Integration Service. The configuration file for the service is typically found in the folder C:\Program Files\Microsoft Dynamics\eConnect 12.0\Service

To specify a configuration setting, you add a <key> node to the appSetting section of the configuration file. In the key node, you specify the name of the configuration setting and the value to use. The eConnect Integration Service enables you to supply custom values for the following configuration settings.

Name

Description

MaxReadQuotaSize

Specifies the maximum size of read messages.

MaxReceivedMessageSize

Specifies the maximum size of an XML document.

ProcTimeOut

Specifies the number of seconds to wait before a time out occurs

RequireProxyService

Specifies whether to use the identity of the logged on user or the service identity when accessing SQL server. Set the value to true when you want the application to use the service identity.

If your application includes a service reference to eConnect, the application always uses the service identity to access SQL. The value of this configuration setting is ignored.

SendTimeout

Specifies the length of time to wait when connecting to the eConnect Integration Service. Used when the RequiredProxyService is set to True.

ServiceAddress

Specifies the URL of the eConnect Integration Service.

ServiceOperationTimeout

Specifies the length of time to wait for an operation to complete. Used when the RequiredProxyService is set to True.

TransactionIsolationLevel

Specifies the isolation level of the transaction. The typical transaction isolation level for eConnect is ReadUncommitted.

TransactionTimeoutSeconds

Specifies the length of time to wait for a SQL transaction to complete.

For more infomation about the configuration settings, see Configuration Class in the eConnect .NET Reference section.

If you add configuration settings to the configuration file of your application, you can also use the Configuration class in the Microsoft.Dynamics.GP.eConnect namespace to programmatically set configuration settings. Any configuration value set by the Configuration class override the value set in your application configuration file.

The following steps show how to add configuration settings to an eConnect .NET application. To begin, open the configuration file in a text editor.

Before you edit the Microsoft.Dynamics.GP.eConnnect.Service.exe.config file, make a copy of the file and store the file in a safe location. If you encounter problems with the service, use the saved copy to restore the existing service configuration.

Adding appSettings to the configuration file

To use custom configuration settings, add an <appSettings> node to the <configuration> of the application or service configuration file.

The following XML example shows how to add appSettings to an application configuration file.

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <appSettings>
    </appSettings>
</configuration>

Adding configuration values

To specify custom configuration settings, add individual key and value information for each setting.

The following XML example adds configuration information for the SendTimeout, MaxReadQuotaSize, and MaxReceivedMessageSize. Notice how MaxReadQuotaSize and MaxReceivedMessageSize use the maximum value for those configuration settings.

<appSettings>
    <add key="SendTimeout" value="60" />
    <add key="MaxReadQuotaSize" value="2147483647" />
    <add key="MaxReceivedMessageSize" value="2147483647" />
</appSettings>

Saving the configuration

To use your custom configuration settings, save the configuration file and restart your application.

If you edited the Microsoft.Dynamics.GP.eConnnect.Service.exe.config file. Stop and restart the eConnect Integration Service before restarting your application.


Tracing an eConnect .NET application

When using eConnect with your .NET application, you might want to use tracing to monitor the execution of your application. The classes in the Microsoft.Dynamics.GP.eConnect namespace support .NET tracing.

To enable tracing, you add the eConnectTraceSource and trace listeners to the application configuration file. The configuration file you update depends upon whether you are using a reference to the Microsoft.Dynamics.GP.eConnect assembly or a service reference to the eConnect Integration Service.

Reference type | Configuration file | Description
Reference | <ApplicationName>.exe.config | Add the trace source and listeners to the application configuration file of your application.
Service reference | Microsoft.Dynamics.GP.eConnect.Service.exe.config | Add the trace source and listeners to the configuration file of the eConnect Integration Service. The configuration file for the service is typically found in the folder C:\Program Files\Microsoft Dynamics\eConnect 12.0\Service

When you add eConnectTraceSource to the configuration file, the eConnect .NET interface generates trace messages that can be collected and recorded in specified logs, or files.

To collect and record tracing information, you must specify the type of output you want to record. The eConnect trace source has a property named switchValue that you use to specify the type of tracing data to collect. Set switchValue to one of the following values.

switchValue | Description
Error | All exceptions are recorded.
Information | Records important and successful milestones of application execution regardless of whether the application is working properly or not.
Off | Disable tracing for the application.
Verbose | Records events that mark successful milestones. Includes low level events for both user code and the service. Useful for debugging or for application optimization.

Tracing in eConnect supports the same trace listeners as other .NET applications. A trace listener is the mechanism that collects and records trace information. To specify where trace information is recorded, use one of the following trace listeners.

Name | Description
ConsoleTraceListener | Directs tracing output to either the standard output or the standard error stream.
DelimitedListTraceListener | Directs tracing output to a text writer, such as a stream writer, or to a stream, such as a file stream. The trace output is in a delimited text format that uses a specified delimiter.
EventLogTraceListener | Directs tracing output to a specified event log.
TextWriterTraceListener | Directs output to an instance of the TextWriter class or to anything that is a Stream class. It can also write to the console or to a file.
XmlWriterTraceListener | Directs tracing output as XML-encoded data to a TextWriter or to a Stream, such as a FileStream. Typically, output is recorded in an XML file.

The most commonly used trace listeners are the TextWriterTraceListener and the XmlWriterTraceListener. These listeners record trace information to a file. For more information about these or the other trace listeners, refer to the documentation for the .NET framework.

For information about how to get tracing information from the eConnect Integration Service, see eConnect Integration Service tracing in the Troubleshooting section of the eConnect Installation and Administration Guide.

The following steps show how to add tracing to an eConnect .NET application. To begin, open the configuration file in a text editor.

Before you edit the Microsoft.Dynamics.GP.eConnnect.Service.exe.config file, make a copy of the file and store the file in a safe location. If you encounter problems with the service, use the saved copy to restore the existing service configuration.

Adding a trace source

To enable eConnect tracing, add a trace source named eConnectTraceSource to the system. diagnostics section of the configuration file. Use the switchValue attribute of the source to specify the type of information you want logged. The eConnectTraceSource logs trace information that is available in the classes and methods of the Microsoft.Dynamics.GP.eConnect namespace.

Typically, the Microsoft.Dynamics.GP.eConnect.Service.exe.config file includes the eConnectTraceSource. To enable tracing, change the switchValue of the eConnectTraceSource to Error, Information, or Verbose.

The following XML example adds the eConnectTraceSource to an application configuration file. Notice how switchValue is set to Verbose.

<system.diagnostics>
    <sources>
        <source name="eConnectTraceSource" switchValue="Verbose">
    </source>
    <trace autoflush="true" />
</system.diagnostics>

Adding listeners

Add the listener you want to use to log the trace results. Add a <sharedListeners> node to the <system.diagnostics> section of you application file. Add and configure the listeners you want to use.

Typically, the Microsoft.Dynamics.GP.eConnect.Service.exe.config file includes listeners. Update the initializeData attribute of the eConnectTextTracelistener or the eConnectXmlTracelistener to specify a folder and file name for the trace file.

The following XML example shows how to add a shared listener to your application configuration file. Notice how a TextWriterTraceListener is specified. The intializeData attribute specifies the location and name of the log file.

<sharedListeners>
    <add initializeData="c:\TEMP\eConnect.log"
        type="System.Diagnostics.TextWriterTraceListener,
        System, Version=2.0.0.0, Culture=neutral,
        PublicKeyToken=b77a5c561934e089"
        name="eConnectTextTracelistener">
            <filter type="" />
    </add>
</sharedListeners>

Adding a listener to the source

To use the listener, add the listener to the listeners of the eConnectTraceSource. Specify the name of the listener you added to the SharedListeners.

Typically, the Microsoft.Dynamics.GP.eConnect.Service.exe.config file includes a listener named eConnectTextTracelistener with the eConnectTraceSource. You do not need to make any changes to use this listener. To use the eConnectXmlTracelistener, add that listener to listeners node of the eConnectTraceSource.

The following XML example adds the shared listener named eConnectTextTracelistener to the eConnectTraceSource in an application configuration file.

<source name="eConnectTraceSource" switchValue="Verbose">
    <listeners>
        <add name="eConnectTextTracelistener">
            <filter type="" />
        </add>
    </listeners>
</source>

Collecting trace data

Save the changes to the application configuration file. If you made change to the Microsoft.Dynamics.GP.eConnect.Service.exe.config, stop and restart the eConnect Integration Service.

To generate trace data, start your application and perform the operations you want to trace. To view the result, open the specified log or file and review the trace information.

Stopping the trace

When you are done collecting trace information. You should disable the eConnectTraceSource. In the configuration file, set the switchValue attribute of the eConnectTraceSource to Off.

<source name="eConnectTraceSource" switchValue="Off">

Example

The following XML example shows the system.diagnostics node from an application configuration file. Notice how eConnectTraceSource has been added with a switchValue set to Verbose. Also notice how two listeners have been specified for eConnectTraceSource. The eConnectTextTraceListener logs trace information as text to a file name eConnect.log. The eConnectXmlTracelistener logs trace information as XML in a file named eConnectLog.xml.

<system.diagnostics>
    <sources>
        <source name="eConnectTraceSource" switchValue="Verbose">
            <listeners>
                <add name="eConnectXmlTracelistener">
                    <filter type="" />
                </add>
                <add name="eConnectTextTracelistener">
                    <filter type="" />
                </add>
            </listeners>
        </source>
    </sources>
    <sharedListeners>
        <add initializeData="c:\TEMP\eConnect.log"
            type="System.Diagnostics.TextWriterTraceListener,
            System, Version=2.0.0.0, Culture=neutral,
            PublicKeyToken=b77a5c561934e089"
            name="eConnectTextTracelistener">
                <filter type="" />
        </add>
        <add initializeData="c:\TEMP\eConnectLog.xml"
            type="System.Diagnostics.XmlWriterTraceListener,
            System, Version=2.0.0.0, Culture=neutral,
            PublicKeyToken=b77a5c561934e089"
            name="eConnectXmlTracelistener">
                <filter type="" />
        </add>
    </sharedListeners>
    <trace autoflush="true" />
</system.diagnostics>


eConnect and .NET

This section of the documentation describes how to use the classes in the Microsoft.Dynamics.GP.eConnect assembly. The following topics show how to use these classes to enable your .NET application to create, update, retrieve, and delete or void Microsoft Dynamics GP data.

  • Microsoft.Dynamics.GP.eConnect
  • Using CreateEntity for new records
  • Retrieving XML documents with GetEntity
  • Retrieving a document number
  • Returning a document number
  • Retrieving a sales document number
  • Returning a sales document number
  • eConnect exception handling


Microsoft.Dynamics.GP.eConnect

To use eConnect to retrieve or update data from Microsoft Dynamics GP, add the Microsoft.Dynamics.GP.eConnect assembly and namespace to your .NET project.

To use the classes in the Microsoft.Dynamics.GP.eConnect namespace, you must add a reference to the Microsoft.Dynamics.GP.eConnect assembly to your .NET project. For information about how to add a reference, see Adding a reference.

The Microsoft.Dynamics.GP.eConnect namespace includes the following classes:.

Class | Description
Configuration | Specifies the properties you use to configure an eConnect application.
DocumentRollback | Enables you to create a collection of Microsoft Dynamics GP document numbers. You use the collection with the RollBackDocumentList method of the GetNextDocNumbers class to return unused numbers.
eConnectException | The eConnectException class enables you to catch or throw eConnect-specific errors. If a method in the eConnectMethods class encounter an error, the method throws an eConnectException. For more information about the eConnect exceptions, see eConnectException Class.
eConnectMethods | The eConnectMethods class allows you to send and receive XML that represent eConnect documents. For more information about how to use the eConnectMethods class, see eConnectMethods Class.
EnumTypes | The EnumTypes class defines enumerations that you use to connect to the eConnect business objects. You typically use these enumerations as parameters for the eConnect_EntryPoint and eConnect_Requester methods of the eConnectMethods class. For more information about the eConnect enumerations, see EnumTypes Class.
GetNextDocNumbers | Enables you to get the next available number for several types of Microsoft Dynamics GP documents.
GetSopNumber | Enables you to retrieve the next available number for a sales document. This class also allows you to return a SOP number that was retrieved but not used.
RollBackDocument | Specifies a single Microsoft Dynamics GP document number. Use a RollBackDocument object when you need access to an individual record in the arraylist produced by the RollBackDocuments method of the DocumentRollback class.

For more information about the classes in the Microsoft.Dynamics.GP.eConnect namespace, see Microsoft.Dynamics.GP.eConnect Namespace.


Using CreateEntity for new records

The eConnectMethods class enables your .NET application to add new data records in Microsoft Dynamics GP. To create a record, use the following methods:

Method | Description
CreateEntity | Creates a record using information from an eConnect XML document. Use CreateEntity to add data entities like customers or vendors. You specify the type of record to create with a parameter that represents an eConnect XML document. If the operation succeeds, the method returns True as a boolean value.
CreateTransactionEntity | Create a transaction using information from an eConnect XML document. Use CreateTransactionEntity for transaction documents like sales orders or inventory transactions. You specify the type of transaction to create with a parameter that represents an eConnect XML document. If the operation succeeds, the method returns an XML string that represents the eConnect XML document that was created.

The eConnectMethods class also includes methods to update or delete existing records in Microsoft Dynamics GP. To use these methods, you must supply the eConnect XML document for the specified operation and document type.

To create, update, and delete or void a record in Microsoft Dynamics GP, you must create an XML string for your eConnect XML document. The following are the most common techniques for creating this string.

  • Construct a string that contains the eConnect XML schema and node tags that are required for your operation. In addition, include the XML tags and values for the XML elements that you want to populate with data.
  • Load text from a file or other data store that contains an existing eConnect XML document into a .NET XmlDocument object. Use the OuterXML property of the XmlDocument class to convert the XML document to a string.

To work with eConnect, the text that is loaded into the XmlDocument object must be a valid eConnect XML document.

  • Use classes from the eConnect Serialization namespace to construct an object that represents an eConnect XML document. Use a .NET XmlSerializer and a XmlDocument object to convert your document object to a string.

For more information about eConnect XML documents, see .eConnect XML document structure.

The following steps show how to use the CreateEntity method to create a record using XML from a textbox control.

Instantiate an eConnectMethods object

To begin, instantiate an eConnectMethods object. The following Visual Basic example shows how to instantiate an eConnectMethods object:

'Instantiate an eConnectMethods object
Dim eConnectObject As New eConnectMethods

Load the eConnect XML document

The following Visual Basic example shows how to use the XML text from a textbox control as the source of the eConnect XML document. Notice how text from the specified control is loaded into a .NET XmlDocument object.

'Load the text from the textbox control into an XmlDocument object
Dim xmlDoc As XmlDocument
xmlDoc.LoadXml(XmlDoc_TextBox.Text)

Create an eConnect connection string

The CreateEntity method requires an eConnect connection string. You use the connection string to specify the Dynamics GP data server and the company database.

For information about eConnect connection strings, see the eConnect Installation chapter of the eConnect Installation and Administration Guide.

The following Visual Basic example shows how to creates a connection string:

'Set the connection string
'This connection string uses integrated security to connect to the
'TWO database on the local computer
Dim ConnectionString As String
ConnectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

Submit the eConnect document

Use the CreateEntity method to submit the document to the eConnect business objects. To call the CreateEntity method, supply parameters that specify the connection string, and the eConnect XML document string.

The CreateEntity method returns a boolean value that indicates whether the XML document was successfully submitted. A return value of True indicates the operation succeeded.

The following Visual Basic example uses the CreateEntity method to submit an eConnect XML document. Notice the following:

  • The ConnectionString parameter specifies the Dynamics GP data server and the company database.
  • The XML string parameter is created using the OuterXml property of the XmlDocument object.
'If eConnectResult is TRUE, the XML document was successfully submitted
Dim eConnectResult As Boolean
eConnectResult = eConnectObject.CreateEntity(ConnectionString, _
    xmlDoc.OuterXml)


Retrieving XML documents with GetEntity

The eConnectMethods class includes a method named GetEntity that enables you to retrieve data from Microsoft Dynamics GP. The GetEntity method gives you programmatic access to the eConnect Transaction Requester. You use the GetEntity method to get a string that represents a Transaction Requester XML document.

The Transaction Requester limits the types of documents you can retrieve with the GetEntity method. To retrieve a document, that document type must be specified in the eConnect_Out_Setup table of your company database. To see the default set of document types, see Requester document types.

To specify the data to retrieve, create an XML string that represents a Transaction Requester query document. The following are the most common techniques for creating a string that represents a Transaction Requester query document.

  • Construct a string that contains the XML tags and values required by the Transaction Requester for the specified document type.
  • Load text from a file or other data store that contains an existing Transaction Requester query into a .NET XmlDocument. Use the OuterXML property of the XmlDocument class to convert the XML document to a string.

To work with eConnect, the text that is loaded into the XmlDocument object must be a valid Transaction Requester query. For more information about the structure of a Transaction Requester query document, see Retrieve a customer.

  • Use the eConnectOut, RQeConnectOutType, and eConnectType classes from the eConnect Serialization namespace to construct an object that represents a Transaction Requester query. Use a .NET XmlSerializer and a XmlDocument object to convert the query document to a string.

The following steps show how to use the GetEntity method to retrieve a transaction requester document for a customer.

Instantiate an eConnectMethods object

To begin, instantiate an eConnectMethods object. The following Visual Basic example shows how to instantiate an eConnectMethods object:

'Instantiate an eConnectMethods object
Dim eConnectObject As New eConnectMethods

Create a Transaction Requester document

The following Visual Basic example shows how to use classes from the eConnect serialization namespace to construct an object that requests a single customer record. Notice how the INDEX1FROM and INDEX1TO fields specify the ID of the customer, the OUTPUTTYPE field specifies the customer master document, and the FORLIST field specifies to return the document to the caller. Also notice how the .NET XmlSerializer is used to load the document object into a .NET XmlDocument.

'**Create an eConnect requestor document that specifies a single customer**
'Create the requestor node
Dim myRequest As New eConnectOut()
With myRequest
    .DOCTYPE = "Customer"
    .OUTPUTTYPE = 1
    .INDEX1FROM = "AARONFIT0001"
    .INDEX1TO = "AARONFIT0001"
    .FORLIST = 1
End With

'Create the requestor schema document type
'Since the eConnect document requires an array, create an
‘array of RQeConnectOutType
Dim econnectOutType() As RQeConnectOutType = _
    New RQeConnectOutType(0) {New RQeConnectOutType}
econnectOutType(0).eConnectOut = myRequest

'Create the eConnect document type
Dim eConnectDoc As New eConnectType()
eConnectDoc.RQeConnectOutType = econnectOutType

'**Serialize the eConnect document**
'Create a memory stream for the serialized eConnect document
Dim memStream As New MemoryStream()

'Create an Xml Serializer and serialize the eConnect document
‘to the memory stream
Dim serializer As New XmlSerializer(GetType(eConnectType))
serializer.Serialize(memStream, eConnectDoc)

'Reset the position property to the start of the buffer
memStream.Position = 0

'**Load the serialized Xml into an Xml document**
Dim xmldoc As New XmlDocument()
xmldoc.Load(memStream)

Create an eConnect connection string

The GetEntity method requires that you supply an eConnect connection string. Use the connection string to specify the Dynamics GP data server and the company database.

For information about eConnect connection strings, see the eConnect Installation chapter of the eConnect Installation and Administration Guide.

The following Visual Basic code example shows how to creates a connection string:

'Create an eConnect connection string
Dim connectionString As String
connectionString = "data source=localhost; initial catalog=TWO; “ _
    & “integrated security=SSPI; persist security info=False; “ _
    & “packet size=4096"

Retrieve the XML document

Use the GetEntity method to populate a string that represents the XML document that the Transaction Requester retrieved. To call the method, supply parameters that specify the connection string, and an XML string that specifies the data you want to retrieve.

For more information about the eConnect_Requester method, see eConnect_Requester Method.

The following Visual Basic example uses the GetEntity method to retrieve a customer XML document. Notice the following:

  • The ConnectionString parameter specifies the Dynamics GP data server and the company database.
  • The XML string parameter is created using the OuterXml property of the XmlDocument object.
'Retrieve the specified document
Dim customerDoc = eConnectMethods.GetEntity(connectionString, _
    EnumTypes.ConnectionStringType.SqlClient, xmldoc.OuterXml)


Retrieving a document number

The GetNextDocNumbers class includes methods that enable you to retrieve several types of Microsoft Dynamics GP document numbers. Typically, you use the GetNextDocNumbers class when you use eConnect to create a new record in Microsoft Dynamics GP.

The following Visual Basic example shows how to use the GetNextDocNumbers class to get document numbers for several types of documents.

'Use the connection string to connect to the TWO database
‘ on the local computer
Dim connectionString As String
connectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

'Instantiate a GetNextDocNumbers object
Dim getDocNumbers As New GetNextDocNumbers()

'Use the GetNextDocNumbers object to retrieve a series of Microsoft Dynamics ‘ GP document numbers
Dim poNumber = getDocNumbers.GetNextPONumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, connectionString)
Dim invNumber = getDocNumbers.GetNextIVNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, _
    GetNextDocNumbers.IVDocType.IVAdjustment, connectionString)
Dim rmNumber = getDocNumbers.GetNextRMNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, _
    GetNextDocNumbers.RMPaymentType.RMReturn, connectionString)
Dim pmNumber = getDocNumbers.GetPMNextVoucherNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, connectionString)
Dim sopNumber = getDocNumbers.GetNextSOPNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, "STDINV", _
    GetNextDocNumbers.SopType.SOPInvoice, connectionString)


Returning a document number

After you get a Microsoft Dynamics GP document number, you might find that you do not need to use that number. Typically, you return an unused document number so the number can be used later with another document.

To return a document number, you use the DocumentRollback class. The DocumentRollback class enables you to build a list of document numbers. You use this list with the RollBackDocumentList method of GetNextDocNumbers class to return unused document numbers to Microsoft Dynamics GP.

The following steps show how to retrieve a collection of document numbers and how to return those numbers to Microsoft Dynamics GP. You will also see how to view the individual members of a DocumentRollback arraylist.

Create the connection string

To retrieve and return document numbers, you need a connection string that specifies the data server and the company database.

The following Visual Basic example shows how to create a connection string.

'Create a connection string that connects to the TWO database
‘ on the local computer
Dim connectionString As String
connectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

Get the document number

To retrieve a document number, use the GetNextDocNumbers class. For more information about how to retrieve document number from Microsoft Dynamics GP, see Retrieving a document number.

The following Visual Basic example uses the GetNextDocNumbers class to retrieve several types of Microsoft Dynamics GP document numbers.

'Instantiate a GetNextDocNumbers object
Dim getDocNumbers As New GetNextDocNumbers()

'Use the GetNextDocNumbers object to retrieve a series of
‘ Microsoft Dynamics GP document numbers
Dim poNumber = getDocNumbers.GetNextPONumber( _
GetNextDocNumbers.IncrementDecrement.Increment, connectionString)
Dim invNumber = getDocNumbers.GetNextIVNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, _
    GetNextDocNumbers.IVDocType.IVAdjustment, connectionString)
Dim rmNumber = getDocNumbers.GetNextRMNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, _
    GetNextDocNumbers.RMPaymentType.RMReturn, connectionString)
Dim pmNumber = getDocNumbers.GetPMNextVoucherNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, connectionString)
Dim sopNumber = getDocNumbers.GetNextSOPNumber( _
    GetNextDocNumbers.IncrementDecrement.Increment, "STDINV", _
    GetNextDocNumbers.SopType.SOPInvoice, connectionString)

Specify the document number to return

To specify the document numbers to return, create a DocumentRollback object. Use the Add method of the DocumentRollback class to build a list of unused document numbers. To use the Add method, you must specify the document type and the document number. The Add method creates a RollBackDocument object and adds that object to an internal arraylist.

The following Visual Basic example shows how to use the Add method of the DocumentRollback class. Notice how the TransactionType enumeration specifies the type of each document.

'Instantiate a DcoumentRollback object
Dim docRollBack As New DocumentRollback()

'Add the document numbers to the DocumentRollback object
docRollBack.Add(TransactionType.POP, poNumber)
docRollBack.Add(TransactionType.IVTrans, invNumber)
docRollBack.Add(TransactionType.RM, rmNumber)
docRollBack.Add(TransactionType.PM, pmNumber)
docRollBack.Add(TransactionType.SOP, sopNumber)

Search the document number arraylist (optional)

To find information about each document number in a DocumentRollback object, search the arraylist of that object. Since each member of the arraylist is a RollBackDocument object, you can use the document number, document type, and other properties to find important information about each document number in the collection.

The following Visual Basic examples shows how to search for document numbers in a DocumentRollback arraylist. Notice how the ArrayList, the ForEach loop, and the RollBackDocument type are used to create a list of document numbers.

'**Iterate through the document numbers to return**
'Determine whether the document rollback object contains any document numbers
If docRollBack.CollectionContainsDocuments() = True Then

    'Instantiate an arraylist
    Dim aList As New ArrayList()

    'Load the arraylist with the information about the document numbers
    aList = docRollBack.RollBackDocuments()

    'Instantiate a list of strings
    Dim returns As New List(Of String)

    'Iterate the array list and inspect the document numbers
    'Use the RollBackDocument type to provide access to the DocumentNumber
    ' property of each object in the arraylist
    For Each number As RollBackDocument In aList

        returns.Add(number.DocumentNumber)

    Next

End If

Return the document number to Microsoft Dynamics GP

To return one or more document numbers, use the RollBackDocumentList method of the GetNextDocNumbers class. The RollBackDocumentList method requires you to provide an arraylist that contains one or more Microsoft Dynamics GP document numbers.

To provide the arraylist, use the RollBackDocuments method of your DocumentRollback object. The method returns an arraylist that includes the document numbers you previously added to your DocumentRollback object..

The following Visual Basic example shows how to use the RollBackDocumentList method of the GetNextDocNumbers class. Notice how the RollBackDocuments method of the DocumentRollback object supplies the arraylist parameter for the RollBackDocumentList method.

'Use the RollBackDocumentList method of the GetNextDocNumbers
‘ object to return the unused document numbers
'Use the RollBackDocuments method of the DocumentRollback object
‘ to specify the document numbers
            getDocNumbers.RollBackDocumentList(docRollBack.RollBackDocuments(), _
    connectionString)


Retrieving a sales document number

To retrieve a Microsoft Dynamics GP sales document number, use the GetNextSopNumber method of the GetSopNumber class. To use the GetNextSopNumber method you specify the type of sale document, the document ID, and an eConnect connection string. The method returns the next available document number for the specified type of sales document.

The following Visual Basic example shows how to use the GetNextSopNumber method of the GetSopNumber class. Notice how the GetNextDocNumbers.SopType enumeration specifies the type of sales document. Also notice the use of STDINV as the document ID.

'Create a connection string that connects to the TWO database
‘ on the local computer
Dim connectionString As String
connectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

'Instantiate a GetSopNumber object
Dim getSopNumber As New GetSopNumber

'Get the next available sales invoice document number
Dim salesInvoiceNumber As String
salesInvoiceNumber = getSopNumber.GetNextSopNumber( _
    GetNextDocNumbers.SopType.SOPInvoice, _
    "STDINV", connectionString)


Returning a sales document number

To return an unused Microsoft Dynamics GP sales document number, you use the RollBackSopNumber method of the GetSopNumber class. To use the RollBackSopNumber method you specify the document number, the type of sale document, the document ID, and an eConnect connection string.

The following Visual Basic example shows how to use the RollBackSopNumber method of the GetSopNumber class to return an unused sales invoice document number. Notice how the GetSopNumber class is used to first retrieve the sales invoice document number. Also notice the use of STDINV as the document ID when the document is retrieved and when it is returned.

'Create a connection string that connects to the TWO database on the local
‘ computer
Dim connectionString As String
connectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

'Instantiate a GetSopNumber object
Dim getSopNumber As New GetSopNumber

'Get the next available sales invoice document number
Dim salesInvoiceNumber As String
salesInvoiceNumber = getSopNumber.GetNextSopNumber( _
    GetNextDocNumbers.SopType.SOPInvoice, _
    "STDINV", connectionString)

'Return the sales invoice number to Microsoft Dynamics GP
Dim returnSucceeded = getSopNumber.RollBackSopNumber(salesInvoiceNumber, _
    GetNextDocNumbers.SopType.SOPInvoice, _
    "STDINV", connectionString)


eConnect exception handling

The eConnectException classes produces eConnect-specific error information. You typically use the eConnectExceptions in the following situations.

  • You add code to your .NET project that detects eConnect-specific errors. You then add code that specifies the actions to take when an eConnect error occurs.
  • You use the eConnectException class to create and throw a new exception object. For example, you use the errMessage parameter of the eConnectException class to add error information that specifies where the error occurred in your .NET application.

If you use the classes in Microsoft.Dynamics.GP.eConnect, you should include code to catch and handle eConnect exceptions from the methods of those classes. The most common exception handling technique is the Try/Catch block. For example, you place a Try block around a call to the CreateEntity method. You then use a Catch block to handle the eConnectException type. Typically, you add code to the Catch block that attempts to correct the error, reports the error to the user, or records error information to a log.

For more information about the eConnect exceptions, see eConnectException Class.

The following Visual Basic example shows how to use a Try/Catch block to handle an eConnectException. Notice how the first Catch statement handles eConnectExceptions while the second Catch handles all other exception types. In this example, the application displays the error information from the message property of the exception in a textbox control.

Dim ConnectionString As String
Dim eConnectResult As Boolean
Dim eConnectObject As New eConnectMethods
Dim xmlDoc As XmlDocument

'Set the connection string
'This connection string uses integrated security to connect to the
'TWO database on the local computer
ConnectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

'Load the contents of the textbox into the xmlDoc object
xmlDoc.LoadXml(XmlDoc_TextBox.Text)

Try
    'Instantiate an eConnectMethods object
    Dim eConnectObject As New eConnectMethods

    'If eConnectResult is TRUE, the XML document was successfully submitted
    eConnectResult = eConnectObject.CreateEntity(ConnectionString,
        xmlDoc.OuterXml)

'If an eConnect error occurs, display the error message
Catch eConnectError as eConnectException
    ReturnData_TextBox.Text = eConnectError.Message
'If an unexpected error occurs, display the error message
Catch ex As Exception
    ReturnData_TextBox.Text = ex.Message
End Try


Serialization

This section of the documentation describes how to use classes from the Microsoft.Dynamics.GP.eConnect.Serialization namespace. You use serialization classes to create .NET objects that represent eConnect XML documents. The following items are discussed:

  • Microsoft.Dynamics.GP.eConnect.Serialization
  • Creating an eConnect document for a .NET project
  • Using serialization flags
  • Serializing an eConnect document object
  • Deserializing a Transaction Requester document


Microsoft.Dynamics.GP.eConnect.Serialization

To create .NET objects that represent Connect XML document, add the Microsoft.Dynamics.GP.eConnect.Serialization assembly and namespace to your project.

To use the classes in the Microsoft.Dynamics.GP.eConnect.Serialization namespace, you must add a reference to the Microsoft.Dynamics.GP.eConnect.Serialization assembly to your .NET project. For information about how to add a reference, see Adding a reference.

The Microsoft.Dynamics.GP.eConnect.Serialization namespace includes the following types of classes.

Category | Description
Node types | The node classes represent the data nodes of an eConnect XML document. The node classes have fields that specify Dynamics GP data values.
Transaction types | The transaction type classes represent the document type and operation for an eConnect XML document. The transaction type classes have fields that you populate with node classes.
Document type | The eConnectType class represents the root node of an eConnect XML document. To complete a document, you populate the fields of the eConnectType class with one or more transaction type classes.

For more information about the structure of an eConnect XML doucment, see eConnect XML document structure.

To see the list of serialization classes or to find more information about a specific class, see the Microsoft.Dynamics.GP.eConnect.Serialization Namespace reference.


Creating an eConnect document for a .NET project

The serialization classes enable you to use .NET to create an object that represents an eConnect XML document. The following sections show how to use the serialization classes to construct a document object. You typically use these objects with the the Create, Update, or Delete method of the eConnectMethods class.

To create an eConnect document object using serialization classes, complete the following steps.

Create an eConnect node object

To begin, use the serialization classes to instantiate the objects that represent the XML nodes for your type of transaction and operation. Populate the fields of the object with the data values you want to use.

The following Visual Basic example shows how to instantiate a taSopHdrIvcInsert object. Notice how the fields of the object are populated with data values:

Dim salesHdr As New taSopHdrIvcInsert

With salesHdr
    .SOPTYPE = 3
    .SOPNUMBE = "INV2001"
    .DOCID = "STDINV"
    .BACHNUMB = "eConnect"
    .TAXSCHID = "USASTCITY-6*"
    .FRTSCHID = "USASTCITY-6*"
    .MSCSCHID = "USASTCITY-6*"
    .LOCNCODE = "WAREHOUSE"
    .DOCDATE = DateString 'Today
    .CUSTNMBR = "CONTOSOL0001"
    .CUSTNAME = "Contoso, Ltd"
    .ShipToName = "WAREHOUSE"
    .ADDRESS1 = "2345 Main St."
    .CNTCPRSN = "Joe Healy"
    .FAXNUMBR = "13125550150"
    .CITY = "Aurora"
    .STATE = "IL"
    .ZIPCODE = "65700"
    .COUNTRY = "USA"
    .SUBTOTAL = 53.8
    .DOCAMNT = 53.8
    .USINGHEADERLEVELTAXES = 0
    .PYMTRMID = "Net 30"
End With

Create an eConnect transaction type object

An eConnect XML document uses transaction type schemas to group related nodes for a specified operation. To perform this step, you instantiate a transaction type object. You then populate the fields of the transaction type object with node objects for that specified transaction type.

The following Visual Basic example shows how to instantiate a SOPTransactionType object. Notice how the taSopHdrIvcInsert field is populated with the salesHdr object from the the previous step:

Dim salesOrder As New SOPTransactionType

salesOrder.taSopHdrIvcInsert = salesHdr

Create an eConnect document object

An eConnect XML document uses a document node to package transaction types for the eConnect business objects. To perform this step in .NET, you instantiate an eConnectType object. You then populate the fields of the document object with your transaction type objects.

The following Visual Basic example instantiates an eConnectType object. Notice how the SOPTransactionType field is populated with salesOrder object from the previous step:

Dim eConnect As New eConnectType

eConnect.SOPTransactionType = salesOrder

Serialize the eConnect document

To use or store your .NET eConnect document object, use the .NET XmlDocument and XmlSerializer classes to convert the .NET document object into an eConnect XML document. You typically serialize your .NET document for the following scenarios:

  • You use the XmlDocument to supply the XML string parameter for the Create, Update, or Delete method of the eConnectMethods class. You use these methods when you use eConnect to create, update, and delete or void Dynamics GP data records.
  • You write the serialized eConnect object to an XML file. You use XML files when you use Microsoft message queuing (MSMQ) and the eConnect Incoming Service to create, update, and delete or void Dynamics GP data records. You can also use the files to archive your transactions to a disk.

For information about how to serialize an eConnect document object, see Serializing an eConnect document object.


Using serialization flags

Several classes in the eConnect serialization namespace include fields called serialization flags. A serialization flag is a boolean member of the class that you use to specify whether to use or discard the value assigned to a related field.

The serialization flag fields in an eConnect serialization class always append the word “Specified” to the name of the field that the boolean flag targets.

To update a field that has a serialization flag, you assign a value to the field and set the value of the related serialization flag to True. The serialization flag instructs the business object to use the value you assigned to the field to update the record in the database. If you set the serialization flag to False or do not include the serialization flag, the value you supply in the class field is not used.

You use serialization flags when the underlying eConnect business object supports update functionality. Update functionality enables you to update a record by submitting a document that specifies a few fields that have new values. Fields not explicitly included in the update document retain their existing value. For more information about eConnect update functionality, see Using eConnect to update existing data.

The following Visual Basic example illustrates the use of a serialization flag in a .NET development project. Notice the use of the HOLD and HOLDSpecified fields of the taUpdateCreateCustomerRcd class. The value of the HOLD field places a hold on the customer. The value of the HOLDSpecifed field enables the update of the customer hold status. If HOLDSpecified is omitted or is not set to True, the value assigned to HOLD is discarded and the hold status of the customer remains unchanged.

public sub UseSerializationFlag()
    Try

        '**Create a customer document**
        'Use the taUpdateCreateCustomerRcd class to specify
        ' the customer update
        Dim customer As New taUpdateCreateCustomerRcd
        With customer
            'Specify the customer
            .CUSTNMBR = "AARONFIT0001"

            'Use the HOLD field to place a hold on the customer
            'Set the serialization flag HOLDSpecifed to True.
            .HOLD = 1
            .HOLDSpecified = True
        End With

        'Add the customer object to the RMCustomerMasterType transaction type
        Dim customerTransactionType As New RMCustomerMasterType
        customerTransactionType.taUpdateCreateCustomerRcd = customer

        'Create an array of RMCustomerMasterType and add
        ' the customer transaction type object to the array
        Dim mySMCustomerMaster(0) As RMCustomerMasterType
        mySMCustomerMaster(0) = customerTransactionType

        'Add the array of transaction type objects to an
        ' eConnect document object
        Dim eConnectDoc As New eConnectType
        eConnectDoc.RMCustomerMasterType = mySMCustomerMaster

        '**Serialize the eConnect document**
        'Create a memory stream for the serialized eConnect document
        Dim memStream As New MemoryStream()

        'Create an Xml Serializer and serialize the eConnect document
        ' to the memory stream
        Dim serializer As New XmlSerializer(GetType(eConnectType))
        serializer.Serialize(memStream, eConnectDoc)

        'Reset the position property to the start of the buffer
        memStream.Position = 0

        '**Load the serialized Xml into an Xml document**
        Dim xmldoc As New XmlDocument()
        xmldoc.Load(memStream)

        'Instantiate an eConnectMethods object
        Dim eConnectObject As New eConnectMethods

        '**Set the connection string**
        'The connection string targets the TWO database on the local computer
        Dim ConnectionString As String
        ConnectionString="Data Source=localhost; Integrated Security=SSPI;" _
            & "Persist Security Info=False; Initial Catalog=TWO;"

        '**Update the customer record**
        'If eConnectResult is TRUE, the XML document was
        ' successfully submitted
        Dim eConnectResult As Boolean
        eConnectResult=eConnectObject.UpdateEntity(ConnectionString, _
            xmlDoc.OuterXml)

    Catch eConnectError As eConnectException
        Console.Write(eConnectError.ToString())

    Catch ex As System.Exception
        Console.Write(ex.ToString())
    End Try
End Sub


Serializing an eConnect document object

The serialization classes enable you to programmatically create eConnect document objects from your .NET application. However, to submit your document to the eConnect business objects, you must convert the .NET document object to the XML format that the business objects require. To convert a .NET document object to XML, use the .NET XmlSerializer and XmlDocument classes to produce a serialized version of your document.

In .NET, serialization is the process of converting an object into a form that can be persisted or transported. For eConnect, you typically convert your document object to a string. For more information about .NET serialization, refer to the .NET Framework SDK.

The following Visual Basic example shows how to create an eConnect sales invoice object and serializes the sales invoice to an XML file. The serialized information is then used with the CreateTransactionEntity method to create the sales invoice in Dynamic GP. As you review the example, note the following actions:

  • The SerializeSalesOrderObject subroutine uses several eConnect serialization classes to create an eConnect sales order document object. Notice how the two taSopLineIvcInsert objects and the taSopHdrIvcInsert object populate the SOPTransactionType object. Also notice how the SOPTransactionType populates the SOPTransactionType field of the eConnectType document object.
  • The SerializeSalesOrderObject subroutine shows how to use a .NET XmlSerializer, FileStream, and XmlTextWriter to serialize the eConnect document object to a file. The code example writes an XML representation of the sales order document object to the SalesOrder.xml file.
  • Notice how the Main subroutine loads the XML from the SalesOrder.xml file into a .NET XmlDocument object.
  • The example shows how to use the OuterXml property of the XmlDocument to populate a string with the XML for the sales order document.
  • The example shows how to instantiate an an eConnectMethods object and how to use the CreateTransactionEntity method. Notice how the sales order document string is used as a parameter for the CreateTransactionEntity method. The example then uses the CreateTransactionEntity method to create the sales order document in the Dynamic GP company database specified by the connection string.
Imports System
Imports System.Xml
Imports System.Xml.Serialization
Imports System.IO
Imports System.Text
Imports Microsoft.Dynamics.GP.eConnect
Imports Microsoft.Dynamics.GP.eConnect.Serialization

Public Class CreateInvoice
  Shared Sub Main()

        Dim salesInvoice As New CreateInvoice
        Dim salesOrderDocument As String
        Dim sConnectionString As String
        Dim eConCall As New eConnectMethods

        Try
            'Call the SerializeSalesOrderObject subroutine and specify
            'a file name
            salesInvoice.SerializeSalesOrderObject("SalesOrder.xml")

            'Create an XML document object and load it with the XML from the
            'file that the SerializeSalesOrder subroutine created
            Dim xmldoc As New Xml.XmlDocument
            xmldoc.Load("SalesOrder.xml")

            'Convert the XML to a string
            salesOrderDocument = xmldoc.OuterXml

            'Create a connection string to the Microsoft Dynamics GP server
            'Integrated Security is required (Integrated security=SSPI)
            sConnectionString = "data source=localhost;" _
                & "initial catalog=TWO;integrated security=SSPI;" _
                & "persist security info=False; packet size=4096"

            'Create the invoice in Microsoft Dynamics GP
            eConCall.CreateTransactionEntity(sConnectionString, _
                    salesOrderDocument)

        Catch exp As eConnectException
            Console.Write(exp.ToString)
        Catch ex As System.Exception
            Console.Write(ex.ToString)
        Finally
            eConCall.Dispose()
        End Try

    End Sub

    'This subroutine creates an eConnect invoice XML document and
    'writes the XML to a file
  Sub SerializeSalesOrderObject(ByVal filename As String)

            Dim salesOrder As New SOPTransactionType
            Dim salesLine As New taSopLineIvcInsert_ItemsTaSopLineIvcInsert
            Dim salesLine2 As New taSopLineIvcInsert_ItemsTaSopLineIvcInsert
            Dim salesHdr As New taSopHdrIvcInsert
            Dim LineItems(1) As taSopLineIvcInsert_ItemsTaSopLineIvcInsert

        Try

            'Populate the elements of the first invoice line
            With salesLine
                .Address1 = "2345 Main St.”
                .CUSTNMBR = "CONTOSOL0001"
                .SOPNUMBE = "INV2001"
                .CITY = "Aurora"
                .SOPTYPE = 3
                .DOCID = "STDINV"
                .QUANTITY = 2
                .ITEMNMBR = "ACCS-CRD-12Wh"
                .ITEMDESC = "Phone Cord – 12’ White"
                .UNITPRCE = 10.95
                .XTNDPRCE = 21.9
                .LOCNCODE = "WAREHOUSE"
                .DOCDATE = DateString   'Today
            End With

            'Add the invoice line to the array
            LineItems(0) = salesLine

            'Populate the elements of the second invoice line
            With salesLine2
                .Address1 = "2345 Main St."
                .CUSTNMBR = "CONTOSOL0001"
                .SOPNUMBE = "INV2001"
                .CITY = "Aurora"
                .SOPTYPE = 3
                .DOCID = "STDINV"
                .QUANTITY = 2
                .ITEMNMBR = "ACCS-CRD-25BK"
                .ITEMDESC = "Phone Cord – 25’ Black"
                .UNITPRCE = 15.95
                .XTNDPRCE = 31.9
                .LOCNCODE = "WAREHOUSE"
                .DOCDATE = DateString   'Today
            End With

            'Add the invoice line to the array
            LineItems(1) = salesLine2

            'Use the array of invoice lines to populate the transaction types
            'array of line items
            ReDim Preserve salesOrder.taSopLineIvcInsert_Items(1)
            salesOrder.taSopLineIvcInsert_Items = LineItems

            'Populate the elements of the taSopHdrIvcInsert XML node
            With salesHdr
                .SOPTYPE = 3
                .SOPNUMBE = "INV2001"
                .DOCID = "STDINV"
                .BACHNUMB = "eConnect"
                .TAXSCHID = "USASTCITY-6*"
                .FRTSCHID = "USASTCITY-6*"
                .MSCSCHID = "USASTCITY-6*"
                .LOCNCODE = "WAREHOUSE"
                .DOCDATE = DateString 'Today
                .CUSTNMBR = "CONTOSOL0001"
                .CUSTNAME = "Contoso, Ltd."
                .ShipToName = "WAREHOUSE"
                .ADDRESS1 = "2345 Main St."
                .CNTCPRSN = "Joe Healy"
                .FAXNUMBR = "13125550150"
                .CITY = "Aurora"
                .STATE = "IL"
                .ZIPCODE = "65700"
                .COUNTRY = "USA"
                .SUBTOTAL = 53.8
                .DOCAMNT = 53.8
                .USINGHEADERLEVELTAXES = 0
                .PYMTRMID = "Net 30"
            End With

            'Add the header node to the transaction type object
            salesOrder.taSopHdrIvcInsert = salesHdr

            'Create an eConnect document object and populate it with
            'the transaction type object
            Dim eConnect As New eConnectType
            ReDim Preserve eConnect.SOPTransactionType(0)
            eConnect.SOPTransactionType(0) = salesOrder

            'Create a file on the hard disk
            Dim fs As New FileStream(filename, FileMode.Create)
            Dim writer As New XmlTextWriter(fs, New UTF8Encoding)

            'Serialize using the XmlTextWriter to the file
            Dim serializer As New XmlSerializer(GetType (eConnectType))
            serializer.Serialize(writer, eConnect)
            writer.Close()

        Catch ex As System.Exception
            Console.Write(ex.ToString)
        End Try

    End Sub
End Class

If you use the example code to create the SalesOrder.xml file. the file should contain the following XML:

<?xml version="1.0" encoding="utf-8"?>
<eConnect xmlns:xsd=”http://www.w3.org/2001/XMLSchema” xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SOPTransactionType>
        <taSopLineIvcInsert_Items>
            <taSopLineIvcInsert>
                <SOPTYPE>3</SOPTYPE>
                <SOPNUMBE>INV2001</SOPNUMBE>
                <CUSTNMBR>CONTOSOL0001</CUSTNMBR>
                <DOCDATE>05-07-2004</DOCDATE>
                <LOCNCODE>WAREHOUSE</LOCNCODE>
                <ITEMNMBR>ACCS-CRD-12WH</ITEMNMBR>
                <UNITPRCE>10.95</UNITPRCE>
                <XTNDPRCE>21.9</XTNDPRCE>
                <QUANTITY>2</QUANTITY>
                <ITEMDESC>Phone Cord – 12’ White</ITEMDESC>
                <DOCID>STDINV</DOCID>
                <ADDRESS1>2345 Main St.</ADDRESS1>
                <CITY>Aurora</CITY>
            </taSopLineIvcInsert>
            <taSopLineIvcInsert>
                <SOPTYPE>3</SOPTYPE>
                <SOPNUMBE>INV2001</SOPNUMBE>
                <CUSTNMBR>CONTOSOL0001</CUSTNMBR>
                <DOCDATE>05-07-2004</DOCDATE>
                <LOCNCODE>WAREHOUSE</LOCNCODE>
                <ITEMNMBR>ACCS-CRD-25BK</ITEMNMBR>
                <UNITPRCE>15.95</UNITPRCE>
                <XTNDPRCE>31.9</XTNDPRCE>
                <QUANTITY>2</QUANTITY>
                <ITEMDESC>Phone Cord – 25’ Black</ITEMDESC>
                <DOCID>STDINV</DOCID>
                <ADDRESS1>2345 Main St.</ADDRESS1>
                <CITY>Aurora</CITY>
            </taSopLineIvcInsert>
        </taSopLineIvcInsert_Items>
        <taSopHdrIvcInsert>
            <SOPTYPE>3</SOPTYPE>
            <DOCID>STDINV</DOCID>
            <SOPNUMBE>INV2001</ SOPNUMBE>
            <TAXSCHID>USASTCITY-6*</TAXSCHID>
            <FRTSCHID>USASTCITY-6*</FRTSCHID>
            <MSCSCHID>USASTCITY-6*</MSCSCHID>
            <LOCNCODE>WAREHOUSE</LOCNCODE>
            <DOCDATE>05-07-2004</DOCDATE>
            <CUSTNMBR>CONTOSOL0001</CUSTNMBR>
            <CUSTNAME>Contoso, Ltd.</CUSTNAME>
            <ShipToName>WAREHOUSE</ShipToName>
            <ADDRESS1>2345 Main St.</ADDRESS1>
            <CNTCPRSN>Joe Healy</CNTCPRSN>
            <FAXNUMBR>13125550150</FAXNUMBR>
            <CITY>Aurora</CITY>
            <STATE>IL</STATE>
            <ZIPCODE>65700</ZIPCODE>
            <COUNTRY>USA</COUNTRY>
            <SUBTOTAL>53.8</SUBTOTAL>
            <DOCAMNT>53.8</DOCAMNT>
            <BACHNUMB>eConnect</BACHNUMB >
            <PYMTRMID>Net 30</PYMTRMID>
        </taSopHdrIvcInsert>
    </SOPTransactionType>
</eConnect>


Deserializing a Transaction Requester document

This section of the documentation shows how to convert the string returned by the GetEntity method of the eConnectMethods class to an eConnect serialization object that you can use in your .NET development project. In .NET, the process of converting a string to an object is called deserialization. To deserialize the eConnect XML to an object from the eConnect Serialization classes, you use the following eConnect and .NET components.

  • To retrieve eConnect data as an XML string, use the GetEntity method of the eConnectMethods class. The GetEntity method uses the eConnect Transaction Requester to retrieve data and create an XML string.

The eConnect Transaction Requester supports a limited number of eConnect document types. Always check whether the Transaction Requester can retrieve the document type that you want to use. Also check that the Transaction Requester returns the data fields you need to create a valid object.

  • You use .NET StringReaders and XmlTextReaders to reformat the XML string you receive from the GetEntity method. Typically, you use the data fields from the Transaction Requester XML string to populate the data fields of an XML string that represents a serialized eConnect document type.
  • Use the Deserialize method of the .NET XmlSeralizer to create an instance of an eConnect serialization class. The Deserialize method converts the XML string into an eConnect serialization object you can use with your .NET project.

To illustrate the deserialization procedure, the following steps show how to retrieve customer information as an XML string and how to convert that string into a taUpdateCreateCustomerRcd object.

Use GetEntity to retrieve a record

Use the GetEntity method to retrieve an XML string that includes the data fields for the specified Transaction Requester document.

To view an example of how to use the GetEntity method to retrieve a customer record, see Retrieving XML documents with GetEntity.

The following Visual Basic example shows how to use the GetEntity method to obtain a customer record. Notice how the return result populates the customerDoc string.

'Retrieve the customer document
Dim customerDoc = eConnectMethods.GetEntity(connectionString, xmldoc.OuterXml)

Retrieve the data fields for the record

Use a .NET StringReader and XmlTextReader to retrieve the data fields from the Transaction Requester XML string. Create a new XML string that contains the data fields.

The following Visual Basic example retrieves the field values contained in the customerDoc string. Notice how customerDoc is loaded into the StringReader and XmlTextReader objects. Also notice how the XmlTextReader uses the name of the Customer node in customerDoc to identify the parent node of the data fields. The ReadInnerXml method of the XmlTextReader returns a string that contains all the data fields that were retrieved by the Transaction Requester.

'**Retrieve the customer XML**
'Load the customer document string into a StringReader
Dim requestReader As New StringReader(customerDoc)

'Use the StringReader to populate an XML text reader
Dim xmlTextReader As New XmlTextReader(requestReader)

'Use the XML text reader to find the customer XML in the eConnect
' Requester response document
'The eConnect_Out_Setup table shows that the customer XML data will
' be enclosed in <Customer> tags
xmlTextReader.ReadToFollowing("Customer")
Dim customerXml = xmlTextReader.ReadInnerXml()

Create a serialized eConnect object

Create a string that represents a serialized version of the object you want to create. For example, to create a taUpdateCreateCustomerRcd you create a string that includes the XML for the customer object.

The following Visual Basic example shows how to create a string that represents a serialized taUpdateCreateCustomerRcd object. Notice how the customerXml string supplies the XML for the data fields. The customerObjectXml string is then added to a .NET StringReader object.

'Create a string that places the customer XML into an taUpdateCreateCustomerRcd XML node
Dim customerObjectXml = String.Concat("<?xml version=""1.0""?> _
    <taUpdateCreateCustomerRcd>", customerXml, _
    "</taUpdateCreateCustomerRcd>")

'Use a StringReader to read the XML for the taUpdateCreateCustomerRcd XML node
Dim customerReader As New StringReader(customerObjectXml)

Deserialize the eConnect XML string

Use your XML string with the Deserialize method of the .NET XmlSerializer to create an instance of an eConnect serialization object. The Deserialize method uses the XML in the string to populate the fields of the object.

The following Visual Basic example shows how to use a .NET XmlSerializer to deserialize the customerObjectXml in the customerReader object. Notice how CType is used to specify the type of the object.

'**Deserialize the taUpdateCreateCustomerRcd XML node from the StringReader**
Dim deSerializer As New XmlSerializer(GetType(taUpdateCreateCustomerRcd))

'Cast the deserialized object to a taUpdateCreateCustomerRcd
' serialization object
Dim testObject = CType(deSerializer.Deserialize(customerReader), _
    taUpdateCreateCustomerRcd)


eConnect Integration Service

This section of the documentation describes how to use the eConnect Integration Service in a .NET application. The eConnect integration service is a Windows Communication Foundation (WCF) service that enables you to perform specified operations using eConnect XML documents. The following items are discussed:

  • eConnect for Microsoft Dynamics GP 2013 Integration Service
  • Adding a service reference
  • Client constructors
  • Using the CreateEntity method to add a record
  • eConnect Integration Service exception handling


eConnect for Microsoft Dynamics GP 2013 Integration Service

The eConnect Integration Service is a Windows service that enables you to use the eConnect business objects from a .NET application. You can use the eConnect Integration Service instead of the Microsoft.Dynamics.GP.eConnect assembly.

To use the eConnect Integration Service, you use a WCF service from your application. A WCF service gives you more flexibility but configuring and using the service can become complex. Before you attempt to use the eConnect Integration Service, you should be familiar with WCF .

The eConnect Integration Service includes classes, methods, and enumerations that you use to perform operations. The classes of the eConnect Integration Service includes many of the same methods that you find in the classes of the Microsoft.Dynamics.GP.eConnect namespace. For more information, see Microsoft.Dynamics.GP.eConnect Namespace.

To add eConnect functionality to an application, you use the following eConnect Integration Service classes.

Class | Description
DocumentNumberRollbackClient | Specifies a collection of Microsoft Dynamics GP document numbers that were not used. This class contains methods found in the DocumentRollback class of the Microsoft.Dynamics.GP.eConnect assembly.
eConnectClient | Provides access to Microsoft Dynamics GP data. This class contains methods found in the eConnectMethods and GetNextDocNumbers classes of the Microsoft.Dynamics.GP.eConnect assembly.
eConnectFault | Specifies an eConnect exception that occurred during a service operation. This class is similar to eConnectException class of the Microsoft.Dynamics.GP.eConnect assembly.
eConnectSqlFault | Specifies one or more SQL exceptions that occurred during a service operation. You use this class to identify SQL exceptions during an eConnect operation. This class is similar to eConnectSqlFault class of the Microsoft.Dynamics.GP.eConnect assembly.
RollBackDocument | Specifies a single Microsoft Dynamics GP document number that was not used. This class contains the same properties found in the RollBackDocument class of the Microsoft.Dynamics.GP.eConnect assembly.
TransactionRecordIdsClient | Retrieves the next document number for several types of Microsoft Dynamics GP documents. This class contains methods found in the GetNextDocNumbers class of the Microsoft.Dynamics.GP.eConnect assembly.

The eConnect Integration Service also includes the following enumerations

Enumeration | Description
IncrementDecrement | Specifies whether to retrieve or return a document number.
IVDocType | Specifies the type of an inventory document.
RMPaymentType | Specifies the type of a receivables document.
SopType | Specifies the type of a sales order document.
TransactionType | Specifies the type of a transaction.


Adding a service reference

To use the eConnect Integration Service with a .NET application, you have to first add a service reference to the Visual Studio project for the application.

To add the service reference, your Visual Studio project must specify the target framework as .NET Framework 3.5.

To add a service reference to a Visual Studio project, complete the following steps.

  1. Add a Service Reference.

In Visual Studio, click the the Project menu, and then click Add Service Reference. The Add Service Reference window opens.

  2. Specify the service URL.

In the Address box of the Add Service Reference window, enter the URL of eConnect Integration Service. Use the following format for the URL:

net.pipe://<server name>/Microsoft/Dynamics/GP/eConnect/

The following example shows a URL for the eConnect Integration service. Notice how the URL specifies localhost for the server name.

net.pipe://localhost/Microsoft/Dynamics/GP/eConnect/

Click Go.

  3. Specify the eConnect service.

In the Services box, click eConnect. In the Namespace box, enter a name for the service. Click OK. The service reference is created and the service configuration information is added to the configuration file of the application.


Client constructors

To use the eConnect Integration Service, you first initialize one or more of the following eConnect client classes:

  • DocumentNumberRollbackClient
  • eConnectClient
  • TransactionRecordIdsClient

Each class includes one or more constructors you can use to initialize a client object. Typically, you use the default constructor. The default constructor uses the endpoint specified in Microsoft.Dynamics.GP.eConnect.Service.exe.config file. When you install eConnect, the configuration file is added to the folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\Service\

The following C# code example use the default constructor to initialize an eConnectClient object:

// Initialize a new instance of the eConnectClient
eConnectClient eConnectObject = new eConnectClient();

However, you can use other constructor methods to specify the eConnect Integration Service endpoint you want to use. All of the client classes inherit from the System.ServiceModel.ClientBase class. The ClientBase class includes overloaded constructors that you can use to specify endpoint information.

For example, the following table lists all the constructor methods for the eConnectClient class

The DocumentNumberRollbackClient and TransactionRecordIdsClient include overloaded constructors with the same parameters as the eConnectClient class.

You use one of these constructors when you want to target a different endpoint then the default endpoint..

Name | Description
eConnectClient() | Initializes a new instance of the eConnectClient class using the default target endpoint.
eConnectClient(string endpointConfigurationName) | Initializes a new instance of the eConnectClient class using the specified endpoint configuration. You have to add the endpoint configuration information to the configuration file of your application.
eConnectClient(string endpointConfigurationName, string remoteAddress) | Initializes a new instance of the eConnectClient class using the specified endpoint configuration. You have to add the endpoint configuration information to the configuration file of your application. You also specify the service address you want to use.
eConnectClient(string endpointConfigurationName, System.ServiceModel.EndpointAddress remoteAddress) | Initializes a new instance of the eConnectClient class using the specified endpoint configuration. You have to add the endpoint configuration information to the configuration file of your application. You also specify the service address you want to use.
eConnectClient(System.ServiceModel.Channels.Binding binding, System.ServiceModel.EndpointAddress remoteAddress) | Initializes a new instance of the eConnectClient class using the specified binding and endpoint address.

The constructors use the following parameters.

Name | Type | Description
binding | System.ServiceModel.Channels.Binding | Specifies the binding to use to make calls to the service.
endpointConfiguationName | string | Specifies the name of the endpoint in the application configuration file.
remoteAddress | string | Specifies the address of the eConnect Integration Service.
remoteAddress | System.ServiceModel.EndpointAddress | Specifies the address of the eConnect Integration Service.


Using the CreateEntity method to add a record

The eConnectClient class of the eConnect Integration Service includes methods that create, update, delete, and retrieve Microsoft Dynamics GP data. In addition, the class includes methods you can use to retrieve and restore Microsoft Dynamics GP document numbers.

To learn how to use the eConnectClients class, use the following steps to create a customer in Microsoft Dynamics GP. The example shows how to use the CreateEntity method of the eConnectClient class.

Add a service reference to the project

To begin, use Visual Studio to add a service reference to the eConnect Integration Service. In the Solution Explorer, right-click References, and then click Add Service Reference. In the Add Service Reference window, enter the following in Address, and then click Go.

net.pipe://localhost/Microsoft/Dynamics/GP/eConnect

Click eConnect in the list of Services and type a Namespace value that specifies a name for the service reference. For example, enter eConnectIntegrationService.

Add the service namespace to the project

Use the service reference name you entered in the previous step to add the namespace in your Visual Studio project. To add the namespace in C#, you add a using statement. To add the namespace in Visual Basic you add an Imports statement.

The following C# example adds a using statement that specifies a namespace from the service reference. In this example, ServiceTestApp is the name of the application project and eConnectIntegrationService is the name specified for the service reference.

using ServiceTestApp.eConnectIntegrationService;

Instantiate an eConnectClient object

To use the integration service, instantiate an eConnectClient object. The object includes the CreateEntity method you use to add a customer to Microsoft Dynamics GP.

The following C# example shows how to use the eConnectClient constructor to create the object:

// Instantiate an eConnectClient object
eConnectClient eConnectObject = new eConnectClient();

Use an XML file to load the customer document

To create a customer you use an eConnect XML document that includes the data for the customer. One way to get the customer document is to create an XML file that contains the customer information. For information about how to create an eConnect XML document for a customer, see Create a customer.

The following C# example shows how to load an eConnect XML document from a file. Notice how the text from the specified file is loaded into a .NET XmlDocument object. Also notice how an XML string is created using the OuterXml property of the XmlDocument object.

// Use the XML document in the specified file to create
// a string representation of the customer
XmlDocument newCustDoc = new XmlDocument();
newCustDoc.Load("CustomerCreate.xml");
string newCustomerDocument = newCustDoc.OuterXml;

Create an eConnect connection string

The CreateEntity method requires an eConnect connection string. You use the connection string to specify the Dynamics GP data server and the company database.

For information about eConnect connection strings, see the eConnect Installation chapter of the eConnect Installation and Administration Guide.

The following C# example shows how to create a connection string:

//Create a connection string
string connectionString = "Data Source=localhost;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=TWO;";

Use CreateEntity to submit the customer document

Use the CreateEntity method to submit the document to the eConnect business objects. To use the CreateEntity method, you have to supply parameters that specify the connection string, and the customer.

The CreateEntity method returns a boolean value that indicates whether the XML document was successfully submitted. A return value of True indicates the operation succeeded.

The following C# example uses the CreateEntity method to submit an eConnect XML document. Notice that the first parameter is the connection string. Also notice that the second parameter is the string that represents the eConnect XML document for the customer.

// If eConnectResult is TRUE, the XML document was successfully submitted
bool result = eConnectObject.CreateEntity(connectionString, newCustomerDocument);


eConnect Integration Service exception handling

The eConnect Integration Service includes the following exception classes that you can use to catch and handle eConnect errors:

  • eConnectFault
  • eConnectSqlFault

You use these classes together with the FaultException generic class from the System.ServiceModel namespace. You use eConnectFault and eConnectSqlFault to specify the exception type. The following example shows how to use eConnectFault with the FaultException class.

FaultException<eConnectFault>

The most common exception handling technique is the Try/Catch block. For example, you place a Try block around a call to the GetEntity method. You then use one or more Catch blocks to handle exceptions. You can add code to each Catch block that attempts to correct the error, reports the error to the user, or records the error in a log.

The following C# example shows a console application that uses eConnectFault, and eConnectSqlFault together with FaultException to handle eConnect exceptions. To follow this example, you use Visual Studio to add a service reference to the eConnect Integration Service. Notice that the application does not require a reference to either of the eConnect .NET assemblies.

To create the parameters for GetEntity, the sample includes two methods:

  • The ConnectionString method creates an eConnect connection string that specifies the Microsoft Dynamics GP database you want to query.
  • The SpecifyCustomer method returns an XML string. The XML represents an eConnect requestor document that specifies the customer to retrieve. Notice how you can use the method to specify the ID of the customer you want to retrieve.

You could also use the classes in the eConnect Serialization namespace to create the XML string. For more information, see Retrieving XML documents with GetEntity.

Finally, notice how the Dispose method is called to release the resources used by the eConnectClient.

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.ServiceModel;
using ExceptionHandling.eConnectIntegrationService;

namespace ExceptionHandling
{
    class Program
    {
        static void Main(string[] args)
        {
            eConnectClient client = null;

            try
            {
                // Instantiate an eConnectClient object
                client = new eConnectClient();

                // Get a requestor document for a specified customer
                string customer = client.GetEntity(
                    ConnectionString("localhost", "TWO"),
                    SpecifyCustomer("AARONFIT0001"));

                // Show customer XML document in the console window
                Console.WriteLine(customer);
                Console.WriteLine("\n\nTo continue, press any key");
                Console.ReadKey(false);
            }
            catch (FaultException<eConnectFault> eFault)
            {
                Console.WriteLine(eFault.ToString());
                Console.WriteLine("\n\nTo continue, press any key");
                Console.ReadKey(false);
            }
            catch (FaultException<eConnectSqlFault> sqlFault)
            {
                Console.WriteLine(sqlFault.ToString());
                Console.WriteLine("\n\nTo continue, press any key");
                Console.ReadKey(false);
            }
            catch (Exception err)
            {
                Console.WriteLine(err.Message);
                Console.WriteLine("\n\nTo continue, press any key");
                Console.ReadKey(false);
            }
            finally
            {
                if (client != null)
                {
                    client.Dispose();
                }
            }
        }

        // Return a string that represents a transaction requestor XML
        // document for the specified customer
        static string SpecifyCustomer(string custID)
        {
            return String.Format(@"<?xml version=""1.0"" ?>
                <eConnect
                xmlns:xsi=""http://www.w3.org/2001/XMLSchema-instance""
                xmlns:xsd=""http://www.w3.org/2001/XMLSchema"">
                <RQeConnectOutType><eConnectProcessInfo xsi:nil=""true"" />
                <taRequesterTrxDisabler_Items xsi:nil=""true"" />
                <eConnectOut><DOCTYPE>Customer</DOCTYPE>
                <OUTPUTTYPE>1</OUTPUTTYPE><INDEX1TO>{0}</INDEX1TO>
                <INDEX1FROM>{1}</INDEX1FROM><FORLIST>1</FORLIST>
                </eConnectOut></RQeConnectOutType></eConnect>",
                custID, custID);
        }

        // Return a string that represents an eConnect connection string
        // to the specified server and database
        static string ConnectionString(string dataSource, string catalog)
        {
            return String.Format(@"data source={0}; initial catalog={1};
                integrated security=SSPI; persist security info=False;
                packet size=4096", dataSource, catalog);
        }
    }
}


MSMQ Development

This portion of the documentation discusses how to use Microsoft Message Queuing (MSMQ) with eConnect’s Incoming and Outgoing services. The services allow you to submit and retrieve XML documents. The following information is discussed:

  • MSMQ explains how MSMQ and the Incoming and Outgoing Services work together.
  • Incoming Service discusses how to use the Incoming Service to integrate your application’s data into Microsoft Dynamics GP.
  • Outgoing Service discusses how to use the Outgoing Service to retrieve XML documents that represent transactions or documents in Microsoft Dynamics GP.


MSMQ

eConnect provides an interface built upon the Microsoft Message Queue (MSMQ) infrastructure. You can use the interface to transport XML documents between your application and Microsoft Dynamics GP. This portion of the document provides an introduction to using the MSMQ interface and discusses the following:

  • Microsoft Message Queue overview
  • Windows Services used with MSMQ
  • eConnect MSMQ Control


Microsoft Message Queue overview

Message queuing is a message infrastructure and development platform for creating distributed, loosely-coupled messaging applications. Message queuing provides guaranteed message delivery, efficient routing, security, transaction support, and priority-based messaging. The eConnect MSMQ interface leverages the abilities of MSMQ to handle messages between applications.

A queue is a logical container that MSMQ uses to store messages. Applications can send messages to queues where they are stored until a receiving application retrieves the message from the queue.

Applications typically create queues, locate existing queues, send messages to queues, and read messages in queues. To perform an operation on a queue, an application must first reference the queue.


Windows Services used with MSMQ

The eConnect installation includes two Windows Services that are used with the MSMQ interface.

  • The Incoming Service periodically monitors a specified queue. When it finds messages in the queue, it takes the message, validates the XML document the message contains, and uses the eConnect business object to perform a Microsoft Dynamics GP operation.
  • The Outgoing Service publishes XML documents to a specified queue. You can configure the Microsoft Dynamics GP documents and operations that are published. Messages published to the queue can be retrieved by other applications. The application can retrieve the XML document from the message and perform actions based upon the data the document contains.

Refer to the eConnect Installation and Administration Guide for information about installing and configuring the Incoming Service and the Outgoing Service.


eConnect MSMQ Control

The eConnect installation provides a utility you use to monitor queues and messages. The eConnect MSMQ Control allows you to open a queue, see the list of messages in the queue, and view the contents of individual messages.

Use the utility during development to ensure messages are getting delivered and that they contain the expected XML data. You can also use the control to debug messages. You can view, edit, and resend messages. For additional information about using the eConnect MSMQ Control, refer to the Utilities chapter in the eConnect Installation and Administration Guide.


Incoming Service

The Incoming Service allows you to create applications that place eConnect XML documents into an MSMQ message and store the message in a queue. Once a message is placed in the queue, the Incoming Service is able to retrieve the message from the queue. The Service creates an XML document from the body of the message. The Incoming Service takes the data from the XML document and uses it with the business objects to perform the specified operation.

The Income Service can validate messages to ensure the XML document complies with the schema, and then call the eConnect Business Objects to perform the operation contained in the XML document.

To use the Incoming Service refer to the following sections:

  • Creating an eConnect XML document
  • Creating an MSMQ message
  • Incoming Service example


Creating an eConnect XML document

To use the Incoming Service, your application must be able to create eConnect XML documents. eConnect provides a .NET assembly named eConnect Serialization that simplifies creating these documents. To use eConnect serialization, you must add a reference to your project to the Microsoft.Dynamics.GP.eConnect.Serialization assembly.

Refer to Serialization for additional information about the eConnect serialization classes.


Creating an MSMQ message

To use MSMQ, add a reference to the System.Messaging assembly of the .NET framework. To send your XML document to the queue, complete the following steps:

  1. Specify the MSMQ destination.

Create a message queue object and specify the eConnect incoming queue. The Incoming Service uses the private queue named eConnect_incoming. The following Visual Basic .NET code creates the object and specifies the eConnect_incoming queue on the local server:

Dim MyQueue As New MessageQueue(".\private$\econnect_incoming")
  2. Populate an MSMQ message.

Create a message object. The following example creates a message object, and then populates the label and message body properties:

Dim MyMessage As New Message
MyMessage.Label = "eConnect Test with ActiveXMessageFormatter"
MyMessage.Body = sCustomerXmlDoc

Notice how the string representation of the XML document is used to populate the message body.

  3. Specify the message format.

Create a message formatter object to specify how to serialize and deserialize the message body. The following sample uses an ActiveXMessageFormatter:

Dim MyFormatter As New ActiveXMessageFormatter

MyMessage.Formatter = MyFormatter
MyFormatter.Write(MyMessage, sCustomerXmlDoc)
  4. Use a queue transaction.

The eConnect_incoming is a transactional queue. A transactional queue requires a MesssageQueueTransaction object. The following Visual Basic .NET code shows how to create and use MesssageQueueTransaction to send a message to the eConnect_incoming queue:

Dim MyQueTrans As New MessageQueueTransaction
MyQueTrans.Begin()
    MyQueue.Send(MyMessage, MyQueTrans)
MyQueTrans.Commit()
  5. Close the queue connection.

Once the message is sent, close the queue object. The following sample closes the queue and frees its resources.

MyQueue.Close()

Refer to the System.Messaging documentation of the .NET Framework for additional information about message queue classes and enumerations.


Incoming Service example

This example creates a customer XML document and sends it to the queue the Incoming Service monitors. This example requires references to the System.Messaging and Microsoft.Dynamics.GP.eConnect.Serialization assemblies.

Notice how the example performs the following steps:

  • Creates an eConnect serialization object for a customer and populates its elements with data.
  • Creates an eConnect XML document that describes a new customer to add to Microsoft Dynamics GP.
  • Serializes the eConnect XML document object to create a string representation of the XML.
  • Specifies the MSMQ queue that will receive the message.
  • Places the string representation of the XML document in an MSMQ message object.
  • Sends the message to the specified queue.
Private Sub CreateCustomerSendtoMSMQ()
    Try
        'XML document compnents
        Dim eConnect As New eConnectType
        Dim CustomerType As New SMCustomerMasterType
        Dim MyCustomer As New taUpdateCreateCustomerRcd

        'Serialization objects
        Dim serializer As New XmlSerializer(GetType(eConnectType))
        Dim MemStream As New MemoryStream
        Dim sCustomerXmlDoc As String

        'Populate the MyCustomer object with data.
        With MyCustomer
            .CUSTNMBR = "JOEH0001"
            .CUSTNAME = "Joe Healy"
            .ADRSCODE = "PRIMARY"
            .ADDRESS1 = "789 First Ave N"
            .CITY = "Rollag"
            .STATE = "MN"
            .ZIPCODE = "23589"
        End With

        'Build the XML document
        CustomerType.taUpdateCreateCustomerRcd = MyCustomer
        ReDim eConnect.SMCustomerMasterType(0)
        eConnect.SMCustomerMasterType(0) = CustomerType

        'Serialize the XML document
        serializer.Serialize(MemStream, eConnect)
        MemStream.Position = 0

        'Use the Memory Stream to create an xml string
        Dim xmlreader As New XmlTextReader(MemStream)
        While xmlreader.Read
            sCustomerXmlDoc = sCustomerXmlDoc & xmlreader.ReadOuterXml & vbCr
        End While

        'Create the MSMQ queue and message objects
        Dim MyQueue As New MessageQueue(".\private$\econnect_incoming")
        Dim MyMessage As New Message
        Dim MyQueTrans As New MessageQueueTransaction
        Dim MyFormatter As New ActiveXMessageFormatter

        'Build the MSMQ message and send it to the queue
        MyMessage.Label = "eConnect Test with ActiveXMessageFormatter"
        MyMessage.Body = sCustomerXmlDoc
        MyMessage.Formatter = MyFormatter
        MyFormatter.Write(MyMessage, sCustomerXmlDoc)
        MyQueTrans.Begin()
        MyQueue.Send(MyMessage, MyQueTrans)
        MyQueTrans.Commit()
        MyQueue.Close()

    Catch ex As System.Exception
        Debug.Write(ex.Message & vbCrLf & ex.StackTrace)
        SerializedXmlDoc.Text = ex.Message & vbCrLf & ex.StackTrace
    End Try
End Sub


Outgoing Service

You use the Outgoing Service to publish XML documents that represent specified documents and operations in Microsoft Dynamics GP. The Outgoing Service periodically queries the eConnect_Out tables in Microsoft Dynamics GP. It uses entries in that table to generate XML documents. The documents are placed in an XML message and sent to the default queue ./private$/econnect_outgoing.

Refer to the eConnect Installation and Administration Guide for information about configuring the Outgoing Service.

The following topics are discussed:

  • Publishing the eConnect XML documents
  • Retrieving the MSMQ message
  • Outgoing Service Example


Publishing the eConnect XML documents

To begin using the Outgoing Service, you specify the Microsoft Dynamics GP documents and operations to publish. eConnect supplies a utility named the Requester Enabler/Disabler to manage this. The utility creates SQL triggers in the Microsoft Dynamics GP database that update the eConnect_Out table.

For information about configuring the Requester Enable/Disabler utility, refer to the Utilities chapter of the eConnect Installation and Administration Guide.

The Outgoing Service queries the eConnect_Out tables to identify the documents to publish. The Outgoing Service creates eConnect XML documents that represent the Microsoft Dynamics GP documents to publish. The service encloses the eConnect XML document in an MSMQ message, and routes the message to the specified queue.


Retrieving the MSMQ message

To use the Outgoing Service, your application needs to retrieve the messages from the queue. The default queue the Outgoing Services uses is .\private$\econnect_outgoing. To develop applications that retrieve messages, add a reference to the System.Messaging assembly of the .NET framework. The basic procedure to retrieve a message from the queue is as follows:

  1. Create a message queue object.

Instantiate a MessageQueue object. Use the path to the local outgoing queue .\private$\econnect_outgoing. Populate the queue object’s Formatter property to allow the message to be deserialized. The following Visual Basic .NET example demonstrates these steps:

Dim myQueue As New MessageQueue(".\private$\econnect_outgoing")
myQueue.Formatter = New ActiveXMessageFormatter
  2. Create a transaction object.

The econnect_outgoing queue is a transactional queue. You must include a queue transaction object with your request. The following example creates the transaction object:

Dim myTransaction As New MessageQueueTransaction
  3. Create a message object.

Instantiate an object that will receive the message retrieved from the specified queue:

Dim myMessage As New Message
  4. Retrieve a message.

Use the object you created to retrieve a message from the queue. This example retrieves the first available message from the queue:

myTransaction.Begin()
myMessage = myQueue.Receive(myTransaction)
myTransaction.Commit()
  5. Get the XML data from the message.

The body of the message will contain a string. The string represents the XML document that describes the Microsoft Dynamics GP operation that triggered the message. The following example retrieves the string from an MSMQ message:

Dim myDocument As [String] = CType(myMessage.Body, [String])


Outgoing Service Example

This example retrieves an MSMQ message from the Outgoing Service queue. This example requires references to the System.Messaging and System.XML assemblies.

Notice how the example performs the following steps:

  • Creates a MessageQueue object to access the Outgoing Service’s message queue.
  • Creates the MSMQ Formatter, MessageQueueTransaction, and Message objects.
  • Retrieves the message from the queue.
  • Retrieves the string from the Message object
  • Loads the string into an XML document object and uses it to display the XML in a textbox. To allow access to specific XML elements and values, the example parses the string into XML. Refer to the .NET Framework documentation for information about creating XML from a string.
Private Sub GetMessage()
    'Create queue object to retrieve messages from the default outgoing queue
    Dim MyQueue As New MessageQueue(".\private$\econnect_outgoing")

    'Create an MSMQ formatter and transaction objects
    MyQueue.Formatter = New ActiveXMessageFormatter
    Dim MyTransaction As New MessageQueueTransaction

    'Create a message object
    Dim MyMessage As Message

    Try
        'Retrieve a message from the queue
        'This example assumes there is always a message waiting in the queue
        MyTransaction.Begin()
        MyMessage = MyQueue.Receive(MyTransaction)
        MyTransaction.Commit()

        'Retrieve the string from the message
        Dim MyDocument As [String] = CType(MyMessage.Body, [String])

        'Load the string into an XML document object
        Dim MyXml As New XmlDocument
        MyXml.LoadXml(MyDocument)

        'Display the XML from the queue message
        MessageText.Text = MyXml.InnerXml

    Catch err As SystemException
        ErrorText.Text = err.InnerException.ToString()
    End Try
End Sub


Business Logic

This portion of the documentation explains how to work with the eConnect business objects. The discussion includes information about using and extending the business rules contained in the business objects. The following information is discussed:

  • Business Logic Overview provides an overview of eConnect’s business logic and how it can be used or extended by your application.
  • Custom XML Nodes discusses how you add custom XML nodes to an eConnect XML document.
  • Business Logic Extensions discusses how to use the pre and post stored procedures to modify eConnect’s business logic.


Business Logic Overview

This portion of the documentation describes options to use and extend eConnect’s business logic. The following topics are discussed:

  • Business logic
  • Extending business logic
  • Calling the business objects


Business logic

Business logic is the collection of rules that constrain and guide the handling of business data. eConnect encapsulates its business logic in business objects. The business objects recreate Microsoft Dynamics GP’s business logic for the documents and operations that eConnect supports.

The eConnect business objects implement business logic using SQL stored procedures. Any eConnect action that queries, creates, updates, or deletes data from Microsoft Dynamics GP uses one or more stored procedures. The eConnect install encrypts these stored procedures so you cannot edit the SQL instructions they contain.

While you cannot directly modify eConnect’s core stored procedures, eConnect’s business logic can be modified to respond to unique business problems. To adjust its business logic to a unique business problem, eConnect allows you to customize it’s XML documents and add custom SQL code that supplements the eConnect stored procedures.


Extending business logic

When you develop an application that uses eConnect, you may encounter business situations that do not conform to eConnect’s existing business logic. To resolve these situations, eConnect allows you to refine its existing business logic. Use the following to supplement eConnect’s business logic:

Add XML nodes to an existing schema eConnect allows you to add custom XML nodes to its document schema. When you add an XML node to a document schema, you must also add a custom SQL stored procedure that processes your XML node’s data. For more information about adding XML nodes, see Custom XML Nodes.

Extend the business logic Each eConnect SQL stored procedure provides a named pre and post procedure. To modify eConnect’s business logic, add SQL code to the pre and post procedures that meet your unique business requirement. For more information about extending eConnect’s business logic, see Business Logic Extensions.


Calling the business objects

You may add eConnect business logic to an application by directly calling an eConnect SQL stored procedure.

eConnect encapsulates its business logic in a collection of SQL stored procedures. When you use Microsoft Dynamics GP Utilities to create a new company, GP Utilities automatically install the eConnect SQL stored procedures on your Microsoft Dynamics GP SQL server. Since the stored procedures are available on the SQL server, you can use them to add eConnect business logic to your application.

You should avoid direct calls to the stored procedures. To add eConnect business logic to an application, use the eConnect application programming interface (API) that supports your application’s development environment.

Refer to the SQL Server help documentation for information about calling a SQL stored procedure from an application.

If you encounter a situation that requires a direct call to an eConnect stored procedure, your application must address the following:

  • Create a connection to the database server.
  • Implement security restrictions to prevent unauthorized use of your database connection.
  • Implement transaction management to commit or rollback changes.
  • Identify and handle error conditions.
  • Update your application whenever changes are made to the parameters for the stored procedure.

If you call an eConnect SQL stored procedure, you must always assess whether the procedure succeeded. The eConnect stored procedures use the ErrorState element to indicate whether the procedure encountered an error. If the value of ErrorState is 0, the procedure was successful. If the ErrorState value is anything other than 0, an error occurred and the transaction must be rolled back.

You must check the value of the ErrorState element after each call to an eConnect stored procedure. All eConnect stored procedures reset the ErrorState element to zero when they start.


Custom XML Nodes

This portion of the documentation discusses how you add custom XML nodes to eConnect XML documents. You use custom XML nodes to allow eConnect to process new types of data. The following topics are discussed:

  • Adding an XML node
  • Creating a SQL stored procedure


Adding an XML node

eConnect allows you to add XML nodes to the XML document schema. Custom XML nodes enable you to use new data elements in an eConnect XML document. You also use custom XML nodes to trigger the business logic in a custom SQL stored procedure.

To begin, specify a name for your XML node. The name must be unique and must match the name of a SQL stored procedure. In addition, the name of the XML node cannot end with the word Items.

In the eConnect transaction type schema documents, XML nodes that end with Items indicate the node contains one or more child nodes. If you attempt to use a single XML node with a name that ends with Items, your transaction will fail.

When eConnect processes an XML document, it uses the name of each XML node to find the SQL stored procedure that contains the business logic for that XML node. For example, a document that includes a custom XML node named <eConnectCustomProcedure> requires the target database to include a SQL stored procedure named eConnectCustomProcedure.

After you have a name for your XML node, you must specify the data elements for your XML node. The data elements contain the values for the XML document. To add data elements to an XML node, use the following guidelines:

  • Define the data elements of your custom XML node. Typically, the number of data elements match the input parameters of the SQL stored procedure.
  • Specify a unique name for each data element. Typically, the data element names match the names used for the input parameter of the SQL stored procedure.
  • Determine the data type of each element. Use the data type and data length constraints from the input parameters of the SQL stored procedures to specify the type of data for each element.

The SQL stored procedure uses the data elements of the XML node to complete the business logic associated with that XML node.

To show a custom XML node, the following XML example defines a node named <eConnectCustomProcedure>. Notice how the XML node includes a single data element named <CUSTNMBR> that holds a customer ID value:

<eConnectCustomProcedure>
    <CUSTNMBR>CONTOSOL0002</CUSTNMBR>
</eConnectCustomProcedure>

After you define your custom XML node, add your new XML node to an existing eConnect transaction type schema. To use your XML node, you need to include that node in an eConnect XML document.

The following XML example adds the <eConnectCustomProcedure> XML node to an eConnect XML document. Notice how the <eConnectCustomProcedure> node has been added to the <RMCustomerMasterType> transaction type.

<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <RMCustomerMasterType>
        <eConnectProcessInfo>
        </eConnectProcessInfo>
        <eConnectCustomProcedure>
            <CUSTNMBR>CONTOSOL0002</CUSTNMBR>
        </eConnectCustomProcedure>
        <taUpdateCreateCustomerRcd>
            <CUSTNMBR>CONTOSOL0002</CUSTNMBR>
            <CUSTNAME>Contoso, Ltd.</CUSTNAME>
            <TAXSCHID>USALLEXMPT-0</TAXSCHID>
            <SHIPMTHD>PICKUP</SHIPMTHD>
            <ADDRESS1>321 Main S </ADDRESS1>
            <CITY>Valley City</CITY>
            <STATE>ND</STATE>
            <ZIPCODE>56789</ZIPCODE>
            <COUNTRY>USA</COUNTRY>
            <PHNUMBR1>13215550100</PHNUMBR1>
            <PHNUMBR2>13215550110</PHNUMBR2>
            <FAX>13215550120</FAX>
            <SALSTERR>TERRITORY 6 </SALSTERR>
            <SLPRSNID>SEAN C .</SLPRSNID>
            <SLPRSNFN>Sean</SLPRSNFN>
            <SPRSNSLN>Chai</SPRSNSLN>
            <UPSZONE>red</UPSZONE>
            <CNTCPRSN>Joe Healy</CNTCPRSN>
            <CHEKBKID>PAYROLL</CHEKBKID>
            <PYMTRMID>Net 30 </PYMTRMID>
            <COMMENT1>comment1</COMMENT1>
            <COMMENT2>comment2</COMMENT2>
            <USERDEF1>Retail</USERDEF1>
            <PRBTADCD>PRIMARY</PRBTADCD>
            <PRSTADCD>PRIMARY</PRSTADCD>
            <ADRSCODE>PRIMARY</ADRSCODE>
            <STADDRCD>PRIMARY</STADDRCD>
            <CRCARDID>Gold Credit </CRCARDID>
            <STMTNAME>Contoso, Ltd.</STMTNAME>
            <SHRTNAME>Contoso, Ltd.</SHRTNAME>
            <Revalue_Customer>1</Revalue_Customer>
            <Post_Results_To>0</Post_Results_To>
            <CRLMTAMT>90000.00</CRLMTAMT>
        </taUpdateCreateCustomerRcd>
    </RMCustomerMasterType>
</eConnect>


Creating a SQL stored procedure

When you add a custom XML node, you also have to create a SQL stored procedure for that node. You use the stored procedure to create, update, or delete a database record using the values in the data elements of the node. To associate the stored procedure with the node, the stored procedure and the custom node must have the same name.

For example, the previous section adds an <eConnectCustomProcedure> node to an XML document. To process the new node, you have to create a stored procedure named eConnectCustomProcedure. To process the data elements in the node, the stored procedure must include the following parameters:

  • You add an input parameter for each element of your custom node. For example, the <eConnectCustomProcedure> node requires you to add a CUSTNMBR parameter to the eConnectCustomProcedure stored procedure.
  • You add the input parameters in the same order that the element appears in the custom XML node.
  • To use the eConnect error handling process, you add output parameters that can hold an ErrorState value and an ErrString message. ErrorState specifies whether an error occurred and ErrString includes error codes and other information.

To add a stored procedure to your database server, refer to the SQL Server help documentation for information about installing SQL stored procedures.

The following SQL example shows a stored procedure for the <eConnectCustomProcedure> XML node. Notice that the eConnectCustomProcedure name matches the name of the node. Also notice how the input parameter named I_vCUSTNMBR maps to the CUSTNMBR element of the node. Finally, notice that the procedure includes output parameters named O_iErrorState and oErrString that enable the procedure to return error information.

/* Begin_Procs eConnectCustomProcedure */
if exists (select * from dbo.sysobjects where id =
    Object_id('dbo.eConnectCustomProcedure') and type = 'P')
begin
    drop proc dbo.eConnectCustomProcedure
end
go

create procedure dbo.eConnectCustomProcedure

@I_vCUSTNMBR char(15), /* Customer Number - only required field */
@O_iErrorState int output, /* Return value: 0 = No Errors, Any Errors > 0 */
@oErrString varchar(255) output /* Return Error Code List */

as

declare
    @CUSTBLNC int,
    @O_oErrorState int,
    @iError int,
    @iStatus smallint,@iAddCodeErrState int

/*********************** Initialize locals ******************************/
select
    @O_iErrorState = 0,
    @oErrString = '',
    @iStatus = 0,
    @iAddCodeErrState = 0

/***************** Custom Procedure edit check validation ***************/
/*If the @I_vCUSTNMBR variable is '' then we need to add the error code */
/*35010 to the @oErrString output variable.*/
/*The method that eConnect uses to append all error string is the */
/*taUpdateString procedure.*/
/*Error codes can be appended to the @oErrString variable: for example you */
/*could append a 33 44 55 66 to the @oErrString variable */
/*After the error codes have been appended to the @oErrString variable. */
/***********************************************************************/
if ( @I_vCUSTNMBR = '' )
begin
    select @O_iErrorState = 35010 /* Customer number is empty */
    exec @iStatus = taUpdateString
        @O_iErrorState,
        @oErrString,
        @oErrString output,
        @iAddCodeErrState output
end
/* Do some custom business logic */
select @CUSTBLNC = CUSTBLNC
    from RM00103 (nolock)
    where CUSTNMBR = @I_vCUSTNMBR
/* End custom business logic */

return (@O_iErrorState)
go

grant execute on dbo.eConnectCustomProcedure to DYNGRP
go


Business Logic Extensions

This portion of the documentation discusses how to customize the eConnect business logic to address unique business requirements. The following topics are discussed:

  • Modifying business logic
  • Using pre and post stored procedures


Modifying business logic

When you use Microsoft Dynamics GP Utilities to create a company, the creation process places all the eConnect stored procedures for that company’s database on your Microsoft Dynamics GP SQL server. These stored procedures contain eConnect’s business logic. You cannot modify any of the eConnect core stored procedures.

When eConnect processes an XML document, it executes a SQL stored procedure for each XML node in that document. When the stored procedure executes, it also executes the pre and post stored procedures for that businss object. The following example describes the sequence of actions initiated by a call to the taSopHdrIvcInsert stored procedure..

  • The pre stored procedure runs prior to the core stored procedure. In this example, the taSopHdrIvcInsertPre executes. After the pre stored procedure completes, the business object checks for errors. If it detects an error, the stored procedure stops, initiates a rollback, and returns an error message to the caller. If no error is detected, the stored procedure continues.
  • The taSopHdrIvcInsert stored procedure runs. When the stored procedure completes, it checks for errors. If it detects an error, the stored procedure stops, initiates a rollback, and returns an error message to the caller. If no error is detected, the stored procedure continues with a call to the post stored procedure.
  • The post stored procedure runs immediately after the core stored procedure. In this example, the taSopHdrIvcInsertPost stored procedure executes. After the post stored procedure completes, the business object checks for errors. If it detects an error, the stored procedure stops, initiates a rollback, and returns an error message to the caller. If no error is detected, the stored procedure ends and returns to the caller.

For additional information about the sequence of events in an eConnect stored procedure, refer to the Business objects.

To alert the eConnect business object of an error in your pre or post stored procedure, use the output parameters for that stored procedure. To report the status of your pre or post procedure, use the output parameters as follows:

  • If the pre or post stored procedure completes successfully, set the value of the ErrorState output parameter to zero.
  • If the pre or post stored procedures encounter an error, set the ErrorState parameter of the stored procedure to a non-zero value. If the eConnect business object finds a non-zero value in the ErrorState parameter, the stored procedure halts and initiates a rollback of the transaction.
  • When an error occurs in the pre or post stored procedures, set a value in the ErrString output parameter that describes the error.


Using pre and post stored procedures

To modify eConnect’s business logic, place custom SQL code in the pre or post procedures. The custom code in the pre and post procedures allow you to modify or extend the behavior of the core eConnect stored procedure. To customize a pre or post stored procedure, complete the following steps:

  1. Open the .sql file for the stored procedure.

eConnect supplies a file for each pre and post stored procedure you can modify. To find a specific file, open the folder C:\Program Files\Microsoft Dynamics\eConnect 12.0\Custom Procedures. This folder contains a subfolder for each transaction type schema. Open the subfolder that contains the stored procedure you want to modify.

As an example, assume you want to modify the taUpdateCreateCustomerRcdPost stored procedure. Open the C:\Program Files\Microsoft Dynamics\eConnect 12.0\Custom Procedures\Receivables folder. Next, open the taUpdateCreateCustomerRcdPost.sql file. You may edit the file using any text editor or Microsoft SQL Server Management Studio.

  2. Add your custom SQL code.

With the .sql file open, you can add custom SQL code to the file. The only parts of the document you should change are the Revision History and the section of the file specified for custom business logic. Your SQL code should be added between the following comments:

/* Create Custom Business Logic */

/* End Create Custom Business Logic */

To avoid errors or unexpected results, do not modify any of the other statements in the file. After adding your custom business logic, save the file.

  3. Run the .sql file in Microsoft SQL Server Management Studio.

Open the modified file with Microsoft SQL Server Management Studio. Use the drop-down list from the toolbar to specify the Microsoft Dynamics GP database that contains the target stored procedure. Click the Execute button. The Query Messages window displays whether the stored procedure was successfully updated. If it succeeded, the stored procedure now includes your custom SQL code.

The following SQL example shows a customized taCreateTerritoryPre stored procedure. The example overrides the value in the Territory Description (SLTERDSC) parameter to reflect that the sales territory was created using eConnect:

/* Begin_Procs taCreateTerritoryPre */
if exists (select * from sysobjects where id = object_id('dbo.taCreateTerritoryPre')and type = 'P')
begin
    drop procedure dbo.taCreateTerritoryPre
end
go

create procedure dbo.taCreateTerritoryPre
/*
**********************************************************************
* (c) 2004 Microsoft Business Solutions, Inc.
**********************************************************************
*
* PROCEDURE NAME: taCreateTerritoryPre
*
* SANSCRIPT NAME: NA
*
* PARAMETERS:
*
* DESCRIPTION: taCreateSalespersonPost Integration Stored Procedure
*
* TABLES:
*           Table Name Access
*           ========== ======
*
* PROCEDURES CALLED:
*
* DATABASE: Company
*
* RETURN VALUE:
*           0   = Successful
*           non-0 = Not successful
*
* REVISION HISTORY:
*
*   Date    Who     Comments
*   ----------------------------------------------------------------
*
*
********************************************************************
*
********************************************************************
*/
@I_vSALSTERR  char(15) output, /*Territory ID <Required>*/
@I_vSLTERDSC  char(30) output, /*Territory Description <Optional>*/
@I_vSLPRSNID  char(15) output, /*Salesperson ID <Optional>*/
@I_vSTMGRFNM  char(15) output, /*Sales Terr Managers First Name <Optional>*/
@I_vSTMGRMNM  char(15) output, /*Sales Terr Managers Middle Name <Optional>*/
@I_vSTMGRLNM  char(20) output, /*Sales Terr Managers Last Name <Optional>*/
@I_vCOUNTRY  char(60) output,  /*Country <Optional>*/
@I_vCOSTTODT  numeric(19,5) output, /*Cost to Date <Optional>*/
@I_vTTLCOMTD  numeric(19,5) output, /*Total Commissions to Date <Optional>*/
@I_vTTLCOMLY  numeric(19,5) output, /*Total Commissions Last Year <Optional>*/
@I_vNCOMSLYR  numeric(19,5) output, /*Non-Comm Sales Last Year <Optional>*/
@I_vCOMSLLYR  numeric(19,5) output, /*Comm Sales Last Year <Optional>*/
@I_vCSTLSTYR  numeric(19,5) output, /*Cost Last Year <Optional>*/
@I_vCOMSLTDT  numeric(19,5) output, /*Commissioned Sales To Date <Optional>*/
@I_vNCOMSLTD  numeric(19,5) output, /*Non-Comm Sales To Date <Optional>*/
@I_vKPCALHST  tinyint output,/*Keep Calendar History - 0=No 1=Yes <Optional>*/
@I_vKPERHIST  tinyint output,/*Keep Period History - 0=No 1=Yes <Optional>*/
@I_vMODIFDT datetime output, /*Modified Date <Optional>*/
@I_vCREATDDT datetime output,  /*Create Date <Optional>*/
@I_vUSRDEFND1  char(50) output, /*User Defined field-developer use only*/
@I_vUSRDEFND2  char(50) output, /*User Defined field-developer use only*/
@I_vUSRDEFND3  char(50) output, /*User Defined field-developer use only*/
@I_vUSRDEFND4  varchar(8000) output, /*User Defined field-developer use only*/
@I_vUSRDEFND5  varchar(8000) output, /*User Defined field-developer use only */
@O_iErrorState int output,/* Return value: 0=No Errors, 1=Error Occurred*/
@oErrString  varchar(255) output /* Return Error Code List*/

as

set nocount on

select @O_iErrorState = 0

/* Create Custom Business Logic */

set @I_vSLTERDSC = 'Created by eConnect'

/* End Create Custom Business Logic */

return (@O_iErrorState)
go

grant execute on dbo.taCreateTerritoryPre to DYNGRP
go

/* End_Procs taCreateTerritoryPre */


Transaction Requester

This portion of the documentation contains information about the eConnect Transaction Requester Service. You use Transaction Requester to retrieve data from Microsoft Dynamics GP. The following topics are discussed:

  • Using the Transaction Requester discusses how to use the Transaction Requester Service. The Transaction Requester publishes eConnect XML documents to an MSMQ queue.
  • Customizing the Transaction Requester discusses creating a custom Transaction Requester Service that retrieves data in ways that a base Transaction Requester Service cannot.


Using the Transaction Requester

The Transaction Requester is an eConnect service that publishes eConnect XML documents to an MSMQ queue. You use the Transaction Requester to retrieve information about specific Microsoft Dynamics GP documents and operations. The discussion addresses the following topics:

  • Transaction Requester Overview
  • Requester document types
  • Requester document tables
  • Using the RequesterTrx element
  • Using the <taRequesterTrxDisabler> XML node


Transaction Requester Overview

The eConnect Transaction Requester enables you to retrieve XML that represents a document and operation. You typically use the Transaction Requester to publish XML documents to an MSMQ. There are two components to the Transaction Requester:

eConnect Requester Setup This utility allows you to specify the XML documents that are published to an MSMQ queue. Use eConnect Requester Setup to identify Microsoft Dynamics GP documents, operations, and the MSMQ queue that receives the document. Refer to the eConnect Installation and Administration Guide to learn about using the eConnect Requester Setup utility.

Outgoing Service The Transaction Requester employs the Outgoing Service to publish the specified XML documents to the queue. To use the Transaction Requester Service, you must configure and enable the Outgoing Service. Refer to the eConnect Installation Guide to learn about the Outgoing Service’s configuration options.

Once the XML documents are published to the queue, your application can retrieve them from the queue. You can then parse the XML document and perform actions based upon the information they contain. For more information about how to retrieve documents from a queue, see Outgoing Service.

The Transaction Requester also enable you to retrieve XML documents from a .NET application. To retrieve XML that represents a document, add code to your .NET application that uses the GetEntity method of the eConnectMethods class. For information about how to use the GetEntity method, see eConnect and .NET.


Requester document types

The Transaction Requester enables you to request an XML document related to a create, update, or delete operation for the following document types:

  • Cash_Receipt
  • Customer
  • Customer_Balance
  • Employee
  • GL_Accounts
  • GL_Hist_Trans
  • GL_Open_Trans
  • GL_Work_Trans
  • Item
  • Item_ListPrice
  • ItemPriceLevels
  • Payables_History_Transaction
  • Payables_Posted_Transaction
  • Payables_Transaction
  • PO_History_Transaction
  • PO_Receiving_Hist_Trans
  • PO_Receiving_Transaction
  • Project_Acct_Contract
  • Project_Acct_Contract_Template
  • Project_Acct_Cost_Category
  • Project_Acct_Employee_Rate
  • Project_Acct_EmployeeExpense
  • Project_Acct_Equipment_Rate
  • Project_Acct_MiscLog
  • Project_Acct_Position_Rate
  • Project_Acct_Project
  • Project_Acct_Project_Access
  • Project_Acct_Project_Template
  • Project_Acct_Timesheet
  • Purchase_Order_Transaction
  • Receivables_Hist_Trans
  • Receivables_Posted_Transaction
  • Receivables_Transaction
  • RM_SalesPerson
  • Sales_History_Transaction
  • Sales_Transaction
  • UOFM
  • Vendor
  • VendorItem


Requester document tables

The following table shows the Microsoft Dynamics GP tables the Transaction Requester uses to retrieve data for the specified document type:

Document type | Alias | Tables used
Cash_Receipt | Cash_Receipt | RM10201
Customer | Customer Address Internet_Address | RM00101 RM00102 SY01200
Customer_Balances | Customer Balance | RM00101 RM00103
Employee | Employee Address | UPR00100 UPR00102
GL_Accounts | GL_Accounts Details | GL00105 GL00100
GL_Hist_Trans | GL_Hist_Trans | GL30000
GL_Open_Trans | GL_Open_Trans | GL20000
GL_Work_Trans | GL_Work_Trans | GL10000
Item | Item Quantities | IV00101 IV00102
Item_ListPrice | Item ListPrice | IV00101 IV00105
ItemPriceLevels | ItemPriceLevels | IV00108
Payables_History_Transaction | PM_Hist_Trans Tax | PM30200 PM30700
Payables_Posted_Transaction | PM_Posted_Trans Tax | PM2000 PM10500
Payables_Transaction | PM_Trans Tax | PM1000 PM10500
PO_History_Transaction | PO_Hist_Trans Line Comment | POP30100 POP30110 POP10150
PO_Receiving_Hist_Trans | PO_Receiving_Hist Line Quantities | POP30300 POP30310 POP10500
PO_Receiving_Transaction | PO_Receiving Line Quantities | POP10300 POP10310 POP10500
Project_Acct_Contract | PA_Contract Cont_Bill_Cycle PA_Project | PA01101 PA02401 PA01201
Project_Acct_Contract_Template | PA_Contract_Temp Cont_Bill_Cycle_Temp | PA41501 PA42901
Project_Acct_Cost_Category | Cost_Category | PA01001
Project_Acct_Employee_Rate | PA_Employ_Rate Line | PA01402 PA01403
Project_Acct_EmployeeExpense | PA_EmpExp Line Tax | PA10500 PA10501 PA10502
Project_Acct_Equipment_Rate | PA_Equip_Rate Line | PA01406 PA01407
Project_Acct_MiscLog | PA_MiscLog Line | PA10200 PA10201
Project_Acct_Position_Rate | PA_Employ_Rate Line | PA01404 PA01405
Project_Acct_Project | PA_Project Bill_Cycle Budget Budget_IVItems Fee Fee_Schedule Access_List Equip_List | PA01201 PA61020 PA01301 PA01303 PA02101 PA05200 PA01408 PA01409
Project_Acct_Project_Access | Proj_Acct_List Employee_Detail Address | PA01408 UPR00100 UPR00102
Project_Acct_Project_Template | PA_Project_Temp Proj_Bill_Cycle_Temp Budget Budget_Items Fee Fee_Schedule Equip_List Access_List | PA41601 PA60020 PA40201 PA40202 PA60040 PA40203 PA41409 PA41401
Project_Acct_Timesheet | PA_Time Line | PA10000 PA10001
Purchase_Order_Transaction | Header Line Comment | POP10100 POP10110 POP10150
Receivables_Hist_Trans | Header Invoice_Tax | RM30101 RM30601
Receivables_Posted_Transaction | Header Invoice_Tax | RM20101 RM10601
Receivables_Transaction | Header Invoice_Tax | RM10301 RM10601
RM_SalesPerson | RM_SalesPerson | RM00301
Sales_History_Transaction | SO_Hist_Trans Line Line_Tax Commissions Distribution Payments Holds UserDefined Deposit Notes | SOP30200 SOP30300 SOP10105 SOP10101 SOP10102 SOP10103 SOP10104 SOP10106 SOP30201 SY03900
Sales_Transaction | SO_Trans Commissions Line LineTax Distribution Payments Holds UserDefined Deposit Notes | SOP10100 SOP10101 SOP10200 SOP10105 SOP10102 SOP10103 SOP10104 SOP10106 SOP30201 SY03900
UOFM | UOFM | IV40201
Vendor | Vendor Vendor_Addr | PM00200 PM00300
VendorItem | VendorItem | IV00103


Using the RequesterTrx element

Many eConnect XML nodes include an element named RequesterTrx. The RequesterTrx element enables you to specify whether the Transaction Requester should publish a transaction that creates, updates, or deletes Microsoft Dynamics GP record as an XML document.

To specify that an incoming eConnect XML document should not publish the transaction to the eConnect_Out table, set the RequesterTrx element of each XML node in the document to 0. A RequesterTrx element with a value of 0 instructs the Transaction Requester to not publish the current transaction in the eConnect_Out table.

For example, you use the eConnect Requester Setup utility to publish all customer inserts, updates, or deletes to the eConnect_Out table. To prevent a specific eConnect customer XML document from being published, you set the RequesterTrx element of the <taUpdateCreateCustomerRcd> XML node to 0.

For most XML nodes, the default value of the RequesterTrx element is 0. The default prevents the Transaction Requester from recognizing creates, updates, and deletes that originate from eConnect.

To ensure an eConnect XML document you use to create, update, or delete a record in Microsoft Dynamics GP is handled by the Transaction Requester, set the RequesterTrx element of that XML node to 1.


Using the <taRequesterTrxDisabler> XML node

The <taRequesterTrxDisabler> XML node gives you the ability to disable core and third-party Transaction Requester document types for individual transactions. All the eConnect transaction type schemas allow you to add one or more <taRequesterTrxDisabler> XML nodes.

You use <taRequesterTrxDisabler> with the classes in Microsoft.Dynamics.GP.eConnect .NET assembly. You typically use <taRequesterTrxDisabler> when submitting documents through the Create, Update or Delete method of the eConnectMethods class.

You typically use the <taRequesterTrxDisabler> node with core or third-party document types that do not support the use of the RequesterTrx element. If the document you are using has XML nodes that have RequesterTrx elements, use the RequesterTrx elements to specify whether the Transaction Requester publishes your transaction. For information about the RequesterTrx element, see Using the RequesterTrx element.

To disable the Transaction Requester for a single transaction, add a <taRequesterTrxDisabler> XML node to the transaction type schema. To disable multiple Transaction Requester document types, add separate <taRequesterTrxDisabler> nodes to the transaction type schema. To specify the Transaction Requester document type, add a document type name to the DOCTYPE element.

Use the Index elements to identify a specific document. For example, the Transaction Requester requires the Customer document type to include a CUSTNUMBR value. To disable the Transaction Requester for a document that updates a specific customer, you populate the INDEX1 field with the Customer ID.

The following XML example uses two <taRequesterTrxDisabler> nodes to disable the “Customer” and “Sales_Transaction” Transaction Requester document types. Notice how the INDEX values are used to specify the individual transactions.

<?xml version="1.0" encoding="utf-8" ?>
<eConnect xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <SOPTransactionType>
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler>
                <DOCTYPE>Customer</DOCTYPE>
                <INDEX1>CONTOSOL0001</INDEX1>
            </taRequesterTrxDisabler>
            <taRequesterTrxDisabler>
                <DOCTYPE>Sales_Transaction</DOCTYPE>
                <INDEX1>INV2001</INDEX1>
                <INDEX2>3</INDEX2>
            </taRequesterTrxDisabler>
        </taRequesterTrxDisabler_Items>
        <taSopLineIvcInsert_Items>
            <taSopLineIvcInsert>
                <SOPTYPE>3</SOPTYPE>
                <SOPNUMBE>INV2001</SOPNUMBE>
                <CUSTNMBR>CONTOSOL0001</CUSTNMBR>
                <DOCDATE>02/02/2006</DOCDATE>
                <LOCNCODE>WAREHOUSE</LOCNCODE>
                <ITEMNMBR>ACCS-CRD-12WH</ITEMNMBR>
                <UNITPRCE>10.95</UNITPRCE>
                <XTNDPRCE>21.9</XTNDPRCE>
                <QUANTITY>2</QUANTITY>
                <ITEMDESC>Phone Cord - 12' White</ITEMDESC>
                <DOCID>STDINV</DOCID>
                <ADDRESS1>2345 Main St</ADDRESS1>
                <CITY>Aurora</CITY>
            </taSopLineIvcInsert>
            <taSopLineIvcInsert>
                <SOPTYPE>3</SOPTYPE>
                <SOPNUMBE>INV2001</SOPNUMBE>
                <CUSTNMBR>CONTOSOL0001</CUSTNMBR>
                <DOCDATE>02/02/2006</DOCDATE>
                <LOCNCODE>WAREHOUSE</LOCNCODE>
                <ITEMNMBR>ACCS-CRD-25BK</ITEMNMBR>
                <UNITPRCE>15.95</UNITPRCE>
                <XTNDPRCE>31.9</XTNDPRCE>
                <QUANTITY>2</QUANTITY>
                <ITEMDESC>Phone Cord - 25' Black</ITEMDESC>
                <DOCID>STDINV</DOCID>
                <ADDRESS1>2345 Main St</ADDRESS1>
                <CITY>Aurora</CITY>
            </taSopLineIvcInsert>
        </taSopLineIvcInsert_Items>
        <taSopHdrIvcInsert>
            <SOPTYPE>3</SOPTYPE>
            <DOCID>STDINV</DOCID>
            <SOPNUMBE>INV2001</SOPNUMBE>
            <TAXSCHID>USASTCITY-6*</TAXSCHID>
            <FRTSCHID>USASTCITY-6*</FRTSCHID>
            <MSCSCHID>USASTCITY-6*</MSCSCHID>
            <LOCNCODE>WAREHOUSE</LOCNCODE>
            <DOCDATE>02/02/2006</DOCDATE>
            <CUSTNMBR>CONTOSOL0001</CUSTNMBR>
            <CUSTNAME>Contoso Ltd</CUSTNAME>
            <ShipToName>WAREHOUSE</ShipToName>
            <ADDRESS1>2345 Main St</ADDRESS1>
            <CNTCPRSN>Joe Healy</CNTCPRSN>
            <FAXNUMBR>13215550150</FAXNUMBR>
            <CITY>Aurora</CITY>
            <STATE>IL</STATE>
            <ZIPCODE>60507</ZIPCODE>
            <COUNTRY>USA</COUNTRY>
            <SUBTOTAL>53.8</SUBTOTAL>
            <DOCAMNT>53.8</DOCAMNT>
            <BACHNUMB>eConnect</BACHNUMB>
            <PYMTRMID>Net 30</PYMTRMID>
        </taSopHdrIvcInsert>
    </SOPTransactionType>
</eConnect>


Customizing the Transaction Requester

eConnect allows you to create custom Transaction Requester Services that retrieve data from Microsoft Dynamics GP. This portion of the document describes how to create a custom Transaction Requester Service. The discussion includes the following topics:

  • Creating a Transaction Requester document type
  • Implementing the RequesterTrx element


Creating a Transaction Requester document type

The Transaction Requester allows you to create custom Transaction Requester document types. You can use the Transaction Requester to define new document types that support your specific business needs. For example, you can create a document type to retrieve data from tables that the original Transaction Requester document types do not include.

To create a custom Transaction Requester Service, you first identify the tables and other information that the Transaction Requester requires. You need to identify a document type name, the tables to use, the index columns, the key fields used to join tables, and the data fields you want to include in your document.

You must recreate all custom requester services after an installation has completed. The install drops and recreates the eConnect_Out_Setup table. Any custom information in the eConnect_Out_Setup table is lost.

To define your document type, you need to add the information you gathered to the eConnect_Out_Setup table. The Transaction Requester uses the information in this table to retrieve and publish eConnect XML documents.

The following table describes the columns of the eConnect_Out_Setup table.

Column name | Data type | Description
DOCTYPE | varchar | Identifies the service.
INSERT_ENABLED | int | Determines whether the service is enabled or disabled for an insert action. Enabled=1, Disabled=0
UPDATE_ENABLED | int | Determines whether the service is enabled or disabled for an update action. Enabled=1, Disabled=0
DELETE_ENABLED | int | Determines whether the service is enabled or disabled for a delete action. Enabled=1, Disabled=0
TABLENAME | varchar | Physical name of table in SQL Server.
ALIAS | varchar | Alias name for DOCTYPE, which is used in the output XML document. (Try to keep alias names as short as possible.)
MAIN | int | Determines whether this record is associated with the primary table or a child table. MAIN=1 defines a primary table; MAIN=2 or greater defines a secondary table. Increment by one for every level.
PARENTLEVEL | int | Determines the parent for this record. When you specify a table as a secondary table (the value of MAIN is greater than 1) you need to specify its parent level. Set the parent level to 1 if it directly links to the main table. If your secondary table links to a child table of the main table, use the value in the child table’s MAIN column as your table’s PARENTLEVEL value.
ORDERBY | int | Defines whether this level needs to be included in the order by clause. ORDERBY=1 defines this level to be included; ORDERBY=0 defines this level to be ignored.
USERDEF1-5 | varchar | Used for any user-defined purpose.
REQUIRED1 | varchar | Defines the name of the column to verify whether data exists for it during an insert transaction. If the column specified is empty, this transaction is ignored. If the column has data in it and the service is enabled, the transaction is echoed to the shadow table (eConnect_Out). If no column is specified, all transactions are written out to the shadow table.
INDEX1-15 | varchar | Specifies the column name of the primary index that should be used for this table. You can specify 1 to 15 columns.
INDEXCNT | int | Defines the number of columns that are specified for the index columns.
TRIGGER1-15 | varchar | Specifies column names used for creating triggers. The columns specified should link back to the columns that you specified in the INDEX1-15 columns of the main table. These columns are used to determine what data needs to be written out to the shadow table (eConnect_Out).
JOINTABLE | varchar | Specifies the table name that needs to be used for joining.
JOIN1-10 | varchar | Specifies column names from the table specified in the TABLENAME column that are used to join to the table specified in the JOINTABLE column.
JOINTO1-10 | varchar | Specifies column names from the table specified in the JOINTABLE column that are used in conjunction with the columns listed in the JOIN1-10 columns.
DATACNT | int | Defines the number of columns that are specified for the data columns.
DATA1-180 | varchar | Specifies names of the data columns that you want to appear in the XML document. You can specify 1 to 180 columns.

The Transaction Requester cannot support SQL Server data columns that are defined as either text or binary.

To add a document type to the Transaction Requester, use a SQL query to insert a new record to the eConnect_Out_Setup table of your Microsoft Dynamics GP company database. Use the query to populate the columns that uniquely define your document type. To ensure the Transaction Requester can use your document type, your SQL query must include the following required information:

  • The number of tables you use to retrieve data defines the number of inserts you use to add your document type to the eConnect_Out_Setup table.
  • When you create a custom document type, you must define a single table as the main table. You specify the main table by setting the value of MAIN to 1.
  • Additional tables for the document type have a value of MAIN greater than one. In addition, these tables supply a value for the JOINTABLE column.
  • Take care to match the columns specified by the JOIN1-10 and JOINTO1-10 fields. Use these columns to define the relationships between the joined tables. For example, the column specified by JOIN1 must contain values that match values in the column specified by JOINTO1.

The following SQL example uses two insert statements to define a Transaction Requester document type for employees. The new Transaction Requester document type combines data from the Microsoft Dynamics GP UPR00100 and UPR00102 tables.

/* Employee Document Setup */
/* this insert will create the record for the parent table – UPR00100 */
insert into eConnect_Out_Setup   (
    DOCTYPE,
    MAIN,
    PARENTLEVEL,
    ORDERBY,
    INDEX1,
    INDEXCNT,
    TRIGGER1,
    TRIGGERCNT,
    TABLENAME,
    ALIAS,
    DATACNT,DATA1,
    DATA2,
    DATA3,
    DATA4,
    DATA5,
    DATA6,
    DATA7,
    DATA8,
    DATA9,
    DATA10,
    DATA11,
    DATA12,
    DATA13,
    DATA14,
    DATA15,
    DATA16,
    DATA17
)
select
    'Employee',
    1,
    0,
    1,
    'EMPLOYID',
    1,
    'EMPLOYID',
    1,
    'UPR00100',
    'Employee',
    17,
    'EMPLCLAS',
    'INACTIVE',
    'LASTNAME',
    'FRSTNAME',
    'MIDLNAME',
    'ADRSCODE',
    'SOCSCNUM',
    'BRTHDATE',
    'GENDER',
    'ETHNORGN',
    'Calc_Min_Wage_Bal',
    'DIVISIONCODE_I',
    'DEPRTMNT',
    'JOBTITLE',
    'SUPERVISORCODE_I',
    'LOCATNID',
    'WCACFPAY'
GO
/* Employee Address Document Setup */
/* this insert will create the record for the child table */
/* (UPR00102) and link it to the parent table (UPR00100) */
insert into eConnect_Out_Setup   (
    DOCTYPE,
    MAIN,
    PARENTLEVEL,
    ORDERBY,
    INDEX1,
    INDEX2,
    INDEXCNT,
    TRIGGER1,
    TRIGGERCNT,
    TABLENAME,
    ALIAS,
    JOINTABLE,
    JOIN1,
    JOINTO1,
    DATACNT,
    DATA1,
    DATA2,
    DATA3,
    DATA4,
    DATA5,
    DATA6,
    DATA7,
    DATA8,
    DATA9,
    DATA10,
    DATA11,
    DATA12,
    DATA13,
    DATA14,
    DATA15,
    DATA16
)
select
    'Employee',
    2,
    1,
    1,
    'EMPLOYID',
    'ADRSCODE',
    2,
    'EMPLOYID',
    1,
    'UPR00102',
    'Address',
    'UPR00100',
    'EMPLOYID',
    'EMPLOYID',
    16,
    'ADDRESS1',
    'ADDRESS2',
    'ADDRESS3',
    'CITY',
    'STATE',
    'ZIPCODE',
    'COUNTY',
    'COUNTRY',
    'PHONE1',
    'PHONE2',
    'PHONE3',
    'FAX',
    'Foreign_Address',
    'Foreign_StateProvince',
    'Foreign_Postal_Code',
    'CCode'
GO

After you add your document type to the eConnect_Out_Setup table, the Transaction Requester works the same as the existing Transaction Requester document types. For example, the Outgoing Service publishes the data fields in an XML document to MSMQ.

The following XML examples show the XML documents that the Transaction Requester produces for the employee document type. The first example shows the master document you get when you set OutputType to 1.

<root>
    <eConnect_Out ACTION="0" EMPLOYID="BARR0001">
        <Employee>
            <EMPLOYID>HEALY0001</EMPLOYID>
            <EMPLCLAS>INST</EMPLCLAS>
            <INACTIVE>0</INACTIVE>
            <LASTNAME>Healy</LASTNAME>
            <FRSTNAME>Joe</FRSTNAME>
            <MIDLNAME></MIDLNAME>
            <ADRSCODE>PRIMARY</ADRSCODE>
            <SOCSCNUM>944229198</SOCSCNUM>
            <BRTHDATE>1961-10-07T00:00:00</BRTHDATE>
            <GENDER>1</GENDER>
            <ETHNORGN>1</ETHNORGN>
            <Calc_Min_Wage_Bal>0</Calc_Min_Wage_Bal>
            <DIVISIONCODE_I></DIVISIONCODE_I>
            <DEPRTMNT>CONS</DEPRTMNT>
            <JOBTITLE>CONS1</JOBTITLE>
            <SUPERVISORCODE_I></SUPERVISORCODE_I>
            <LOCATNID></LOCATNID>
            <WCACFPAY>0</WCACFPAY>
        </Employee>
    </eConnect_Out>
</root>

The following example shows the complete document you get when you set the OutputType to 2.

<root>
    <eConnect_Out ACTION="0" EMPLOYID="BARR0001">
        <Employee>
            <EMPLOYID>HEALY0001</EMPLOYID>
            <EMPLCLAS>INST</EMPLCLAS>
            <INACTIVE>0</INACTIVE>
            <LASTNAME>Healy</LASTNAME>
            <FRSTNAME>Joe</FRSTNAME>
            <MIDLNAME></MIDLNAME>
            <ADRSCODE>PRIMARY</ADRSCODE>
            <SOCSCNUM>944229198</SOCSCNUM>
            <BRTHDATE>1961-10-07T00:00:00</BRTHDATE>
            <GENDER>1</GENDER>
            <ETHNORGN>1</ETHNORGN>
            <Calc_Min_Wage_Bal>0</Calc_Min_Wage_Bal>
            <DIVISIONCODE_I></DIVISIONCODE_I>
            <DEPRTMNT>CONS</DEPRTMNT>
            <JOBTITLE>CONS1</JOBTITLE>
            <SUPERVISORCODE_I></SUPERVISORCODE_I>
            <LOCATNID></LOCATNID>
            <WCACFPAY>0</WCACFPAY>
            <Address>
                <EMPLOYID>HEALY0001</EMPLOYID>
                <ADRSCODE>PRIMARY</ADRSCODE>
                <ADDRESS1>4567 Main Ave</ADDRESS1>
                <ADDRESS2></ADDRESS2>
                <ADDRESS3></ADDRESS3>
                <CITY>Wauwatosa</CITY>
                <STATE>WI</STATE>
                <ZIPCODE>43210-9876 </ZIPCODE>
                <COUNTY></COUNTY>
                <COUNTRY>USA</COUNTRY>
                <PHONE1>4145550150</PHONE1>
                <PHONE2></PHONE2>
                <PHONE3></PHONE3>
                <FAX></FAX>
                <Foreign_Address>0</Foreign_Address>
                <Foreign_StateProvince></Foreign_StateProvince>
                <Foreign_Postal_Code></Foreign_Postal_Code>
                <CCode></CCode>
            </Address>
        </Employee>
    </eConnect_Out>
</root>


Implementing the RequesterTrx element

To control whether the Transaction Requester publishes your document type for a create, update or delete, use the RequesterTrx element of the XML node. The RequesterTrx element enables you to specify whether the Transaction Requester should publish the current transaction as an XML document.

To use the RequesterTrx in a document type, you need to use an eConnect stored procedure named eConnectOutVerify. This stored procedure prevents the Transaction Requester from publishing a document where the RequesterTrx flag is set to 0.

To use the eConnectOutVerify stored procedure, call the eConnectOutVerify from the eConnect pre and post stored procedure of the business object associated with your XML node. To use the eConnectOutVerify stored procedure, your pre and post procedures must supply the following values:

  • Use the DOCTYPE parameter to specify the Transaction Requester document type. Use the same DOCTYPE value you used to add the document type to the eConnect_Out_Setup table. In the following example, the Transaction Requester document type is Employee.
  • Use the INDEX parameters (INDEX1 - 15) to identify the specific document you want to exclude from the Transaction Requester. You must supply a value for each index you defined in the eConnect_Out_Setup table for your document type. In the following example, the value of @I_vEMPLOYID is assigned to INDEX1 to specify the ID of the employee.

The following SQL examples shows how to use eConnectOutVerify from the pre and post procedures for the Employee example. Notice how the pre procedure uses eConnectOutVerify to identify document type and the employee. Also, notice how the post procedure sets the eConnectOutVerify Delete parameter to 1. The Delete parameter restores the original configuration of the Transaction Requester.

Pre procedure example
/*** Call eConnectOutVerify proc ***/
if (@I_vRequesterTrx =0)
begin
    exec @iStatus = eConnectOutVerify
        @I_vDOCTYPE ='Employee',
        @I_vINDEX1=@I_vEMPLOYID ,
        @I_vINDEX2='',
        @I_vINDEX3='',
        @I_vINDEX4='',
        @I_vINDEX5='',
        @I_vINDEX6='',
        @I_vINDEX7='',
        @I_vINDEX8='',
        @I_vINDEX9='',
        @I_vINDEX10='',
        @I_vINDEX11='',
        @I_vINDEX12='',
        @I_vINDEX13='',
        @I_vINDEX14='',
        @I_vINDEX15='',
        @I_vDelete = 0,
        @O_iErrorState = @ iCustomState output
    select @iError = @@error
    if @iStatus = 0 and @ iError <> 0
    begin
        select @iStatus = @ iError
    end
    if (@iStatus <> 0) or (@ iCustomState <> 0)
    begin
        select @O_iErrorState = 9999 /* eConnectOutVerify proc returned an error value */
        exec @iStatus = taUpdateString
            @O_iErrorState ,
            @oErrString ,
            @oErrString output,
            @O_oErrorState output
    end
end

Post procedure example

/*** Call eConnectOutVerify proc ***/
if (@I_vRequesterTrx =0)
begin
    exec @iStatus = eConnectOutVerify
        @I_vDOCTYPE ='Employee',
        @I_vINDEX1=@I_vEMPLOYID ,
        @I_vINDEX2='',
        @I_vINDEX3='',
        @I_vINDEX4='',
        @I_vINDEX5='',
        @I_vINDEX6='',
        @I_vINDEX7='',
        @I_vINDEX8='',
        @I_vINDEX9='',
        @I_vINDEX10='',
        @I_vINDEX11='',
        @I_vINDEX12='',
        @I_vINDEX13='',
        @I_vINDEX14='',
        @I_vINDEX15='',
        @I_vDelete = 1,
        @O_iErrorState = @ iCustomState output
    select @iError = @@error
    if @iStatus = 0 and @ iError <> 0
    begin
        select @iStatus = @ iError
    end
    if (@iStatus <> 0) or (@ iCustomState <> 0)
    begin
        select @O_iErrorState = 9999 /* eConnectOutVerify proc returned an error value */
        exec @iStatus = taUpdateString
            @O_iErrorState ,
            @oErrString ,
            @oErrString output,
            @O_oErrorState output
    end
end


eConnect Samples

This portion of the documentation describes the sample applications you get when you install the Help and Samples feature. The samples are a collection of Visual Studio projects you can use to build applications that work with eConnect. The eConnect install places the folders and files for each project in the following location:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples

The following samples are discussed:

  • Create a Customer describes a sample that creates a Microsoft Dynamics GP customer.
  • Create a Sales Order describes a sample that creates a Microsoft Dynamics GP sales order document.
  • XML Document Manager describes a sample that uses eConnect XML documents stored in XML files to complete operations in a Microsoft Dynamics GP database.
  • Get a Document Number describes two samples that demonstrate how to retrieve document numbers from Microsoft Dynamics GP.
  • Retrieve Data describes a sample that retrieves customer data from Microsoft Dynamics GP.
  • MSMQ Document Sender describes a sample application that converts an eConnect XML document to MSMQ message and places the message in a queue.


Create a Customer

This sample application demonstrate how to use the eConnect .NET assemblies to create a new Microsoft Dynamics GP customer. This console application provides a basic example of creating Microsoft Dynamics GP data with eConnect. The following topics are discussed:

  • Overview
  • Running the sample application
  • How the sample application works
  • How eConnect was used


Overview

The sample application shows how to use eConnect serialization classes, write an eConnect XML document to a file, and create a new Microsoft Dynamics GP customer. Before you run this application, set the eConnect connection string in the source file to access the appropriate Microsoft Dynamics GP database.

This sample application is available in both C# and Visual Basic .NET. To build this application, you must have Visual Studio and the .NET Framework installed on your computer. To find project files for the C# application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\CSHARP Console Application

To find the project files for the Visual Basic .NET application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\VB DOT NET Console Application


Running the sample application

To run this sample application, perform the following steps:

  1. Start Visual Studio and open the solution file for the sample application.

The solution file for the C# version of the sample is named eConnect_CSharp_ConsoleApplication.sln. The solution file is in the CSHARPConsoleApplication folder inside the Samples folder.

The solution file for the Visual Basic .NET versions is named eConnect_VB_ConsoleApplication.sln. The solution file is in the VBDOTNETConsoleApplication folder inside the Samples folder.

  2. Open the source file.

Open the Visual Studio Solution Explorer. Open the Class1.cs file in the C# project or Module1.vb file in the Visual Basic .NET project.

  3. Update the connection string.

Locate the variable named sConnectionString and set the Data Source value to the name of your Microsoft Dynamics GP SQL Server. Set the Initial Catalog value to the name of the Microsoft Dynamics GP company database where you would like the new customer to be created.

  4. Choose Start Debugging from the Debug menu.

To build the solution, choose “Start Debugging” in the Debug menu. Notice how the console window opens and closes.

  5. View the customer.xml file.

The C# project creates the customer.xml file in the project’s \bin\debug folder. The Visual Basic .NET project creates the customer.xml file in the project’s \bin folder. The customer.xml file contains the eConnect XML document for the new customer.

  6. Verify the customer is in Microsoft Dynamics GP.

Use the Microsoft Dynamics GP client to verify the customer was created. Search for the customer based on the eConnect XML document in the customer.xml file.


How the sample application works

The sample application is a basic console application that uses classes from the eConnect .NET assemblies to create a new Microsoft Dynamics GP customer. The application creates an eConnect XML customer document using several eConnect serialization objects. When the document is complete, the application writes the document’s XML to the customer.xml file.

The application validates the customer XML to ensure the eConnect XML document is complete. To perform validation, the application uses the eConnect schema information in the eConnect.xsd file.

The application uses eConnect connection string information to connect to the eConnect business objects in your Microsoft Dynamics GP database.

The application takes the eConnect XML document, accesses the eConnect business objects, and creates a new Microsoft Dynamics GP customer.

If an error occurs, the error message is displayed in the console window.


How eConnect was used

The sample application uses classes from the Microsoft.Dynamics.GP.eConnect and Microsoft.Dynamics.GP.eConnect.Serialization assemblies.

Microsoft.Dynamics.GP.eConnect

The application uses the eConnectMethods class to instantiate an eConnectMethods object. The application uses the object’s CreateEntity method to create the customer. The CreateEntity method accesses the business objects on the server specified by the eConnect connection string.

Microsoft.Dynamics.GP.eConnect.Serialization

The application uses several serialization classes to construct an eConnect XML document. To create an XML document, the application instantiates eConnectType, RMCustomerMasterType, and taUpdateCreateCustomerRcd objects.

The application first populates the taUpdateCreateCustomerRcd properties to specify the new customer. It uses the taUpdateCreateCustomerRcd object to populate the RMCustomerMasterType object. The RMCustomerMasterType then populates the eConnectType object. The eConnectType object represents a complete eConnect XML document.

The application writes the XML from the eConnectType object to a file. The application converts the XML contents of the file to a string and passes that string to the CreateEntity method.


Create a Sales Order

The sample application uses the eConnect .NET assemblies to create a Microsoft Dynamics GP sales order document. The following topics are discussed:

  • Overview
  • Running the sample application
  • How the sample application works
  • How eConnect was used


Overview

The sample application shows how to use eConnect serialization classes, write an eConnect XML document to a file, and create a new Microsoft Dynamics GP sales order document. Before you run this application, set the eConnect connection string in the source file to access the appropriate Microsoft Dynamics GP database.

This sample application is available in both C# and Visual Basic .NET. To build this application, you must have Visual Studio and the .NET Framework installed on your computer. To find project files for the C# application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\CSHARP SalesOrder Console Application

To find the project files for the Visual Basic .NET application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\VB DOT NET SalesOrder Console Application


Running the sample application

To run this sample application, perform the following steps:

  1. Start Visual Studio and open the solution file for the sample application.

The solution file for the C# version of the sample is named eConnectSalesOrder_CSharp_ConsoleApplication.sln. The solution file is in the CSHARPSalesorderConsoleApplication folder inside the Samples folder.

The solution file for the Visual Basic .NET version is named eConnect_VB_ConsoleApplicationSales.sln. The solution file is in the VBDOTNETSalesorderConsoleApplication folder inside the Samples folder.

  2. Open the source file.

Open the Visual Studio Solution Explorer. Open test.cs in the C# project or Module1.vb in the Visual Basic .NET project.

  3. Update the connection string.

Locate the variable named sConnectionString and set the Data Source value to the name of your Microsoft Dynamics GP SQL Server. Set the Initial Catalog value to the name of the Microsoft Dynamics GP company database where you would like the new sales order to be created.

  4. Choose Start Debugging from the Debug menu.

To build the solution, choose “Start Debugging” in the Debug menu. Notice how the console window opens and closes.

  5. View the SalesOrder.xml file.

The C# project creates the SalesOrder.xml file in the project’s \bin\debug folder. The Visual Basic .NET project creates the SalesOrder.xml file in the \bin folder. The SalesOrder.xml file contains the eConnect XML document for the new sales order.

  6. Verify the sales order is in Microsoft Dynamics GP.

Use the Microsoft Dynamics GP client to verify the sales order was created. Search for the sales order created based on the eConnect XML document in the SalesOrder.xml file.


How the sample application works

The sample application is a console application that uses classes from the eConnect .NET assemblies to create a new Microsoft Dynamics GP sales order document. The application creates an eConnect XML sales order document using several eConnect serialization classes. When the eConnect XML document is complete, the application writes the document XML to the SalesOrder.xml file.

The application uses eConnect connection string information to connect to the eConnect business objects in your Microsoft Dynamics GP database.

The application takes the eConnect XML document, accesses the eConnect business objects, and creates a new Microsoft Dynamics GP sales order document.

If an error occurs, the error message is displayed in the console window.


How eConnect was used

The sample application uses classes from the Microsoft.Dynamics.GP.eConnect and Microsoft.Dynamics.GP.eConnect.Serialization assemblies.

Microsoft.Dynamics.GP.eConnect

The application uses the eConnectMethods class to instantiate an eConnectMethods object. The application uses the CreateTransactionEntity method to create the sales order. The CreateTransactionEntity method needs the sales order XML document and the eConnect connection string.

The CreateTransactionEntity method returns a string. The string contains the XML of the document that was created. You can use the string to verify the document was created or to view values that were generated by eConnect. For example, use the XML in the string to view the document ID assigned to a new sales document.

Microsoft.Dynamics.GP.eConnect.Serialization

The application uses several serialization classes to construct an eConnect XML document. To create a sales order document, the sample application instantiates the eConnectType, SOPTransactionType, taSopLineIvcInsert_ItemsTaSopLineIvc-Insert, and taSopHdrIvcInsert classes.

The application instantiates two taSopLineIvcInsert_ItemsTaSopLineIvcInsert objects. It populates each properties of the object to represent a sales order line item. The application completes the sales order by instantiating a taSopHdrIvcInsert object and populating its properties.

To combine the line items and header object into a logical unit, the application instantiates a SOPTransactionType object and populates it with the taSopLineIvcInsert_ItemsTaSopLineIvcInsert and taSopHdrIvcInsert objects. The application completes the eConnect XML document by instantiating an eConnectType object and populating it with SOPTransactionType object.

The application uses a .NET XMLSerializer to write the eConnect XML document to the SalesOrder.xml file. The application passes the XML contents of this file to the eConnect_EntryPoint method.


XML Document Manager

The Document Manager sample is a .NET application that uses eConnect XML documents to create, or retrieve Microsoft Dynamics GP data. The following topics are discussed:

  • Overview
  • Running the sample application
  • How the sample application works
  • How eConnect was used


Overview

This sample application uses classes from the eConnect .NET assemblies to process an eConnect XML document. The sample displays the message or data from each eConnect operation. To process an eConnect XML document, you must first configure the eConnect connection string.

This sample application is available in both C# and Visual Basic .NET. To build this application, you must have Visual Studio and the .NET Framework installed on your computer. To find project files for the C# application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\CSHARP DirectDocSender

To find the project files for the Visual Basic .NET application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\XMLDocumentSender

The C# and Visual Basic .NET versions perform the same tasks but the user interfaces are slightly different.


Running the sample application

To run this sample application, perform the following steps:

  1. Start Visual Studio and open the solution file for the sample application.

The solution file for the C# version of the sample is named DirectDocSenderDotNet.sln. The solution file is in the CSHARPDirectDocSender folder inside the Samples folder.

The solution file for the Visual Basic .NET version is named XmlDocumentSender.sln. The solution file is in the XmlDocumentSender folder inside the Samples folder.

  2. Choose Start Debugging from the Debug menu.

To build the solution, choose “Start Debugging” in the Debug menu. The application starts.

  3. Update the connection string.

Click the ellipsis (...) button next to the Connection String box. A dialog box opens. Enter your Microsoft Dynamics GP SQL Server name, log in name, password, and database name. Click OK.

  4. Select an eConnect XML document file.

Click the ellipsis (...) button next to the Select XML File button. A dialog box opens. Use the dialog box to find a file that contains an eConnect XML document. Select the file and click Open.

  5. Review the XML document.

The XML Document box displays the contents of the file you selected. You may edit the XML in the box. If you edit the XML, click the Save XML button to write your changes to a file.

  6. Send the XML document.

Click the Send XML button. The application uses classes from the eConnect .NET assemblies to perform the operations specified by the XML document.

  7. Review the results.

The Return Information box displays the result.


How the sample application works

The sample application uses a class from the eConnect .NET assemblies to process eConnect XML documents. The application creates, or retrieves Microsoft Dynamics GP data using the eConnect XML document.

The application requires an eConnect connection string to specify a Microsoft Dynamics GP database. Use the connection string dialog box to specify your server name, log in name , password, and database.

The application uses eConnect XML documents to perform operations on Microsoft Dynamics GP data. The contents of the eConnect XML document determines the type of operation.

Click the Send XML button to have the application perform the create, or request operation. The application displays the return result of each operation in the Return Information box.

The application allows you to edit the contents of the XML Document box. To save the changes you make to the eConnect XML document, click the Save XML button. The application writes the contents of the XML Document box to a file.

If an error occurs, the application displays the error message in the Return Information box.


How eConnect was used

The sample application uses a class from the Microsoft.Dynamics.GP.eConnect assemblies.

Microsoft.Dynamics.GP.eConnect

When you click the Send Xml button, the application instantiates an eConnectMethods object. How the object is used depends upon the eConnect XML document.

  • If the document’s eConnectProcessInfo node contains the element Outgoing and the element value is TRUE, the document’s XML is requesting Microsoft Dynamics GP data.

When the eConnect XML document requests data, the application uses the eConnectMethods object’s GetEntity method. The GetEntity method returns an eConnect XML document string that contains the requested data.

  • If the eConnectProcessInfo node does not contain the Outgoing element or it is set to FALSE, the document’s XML creates, updates, or deletes Microsoft Dynamics GP data.

When the eConnect XML document creates, updates, or deletes Microsoft Dynamics GP data, the application uses the eConnectMethods object’s CreateEntity method. The CreateEntity method uses the eConnect XML to perform the specified operation and returns a boolean value that specifies whether the operation was successful.

This sample application does not validate the eConnect XML document before sending its XML element values to the business objects.


Get a Document Number

The Document Number samples include two .NET applications that retrieve the next available document numbers from Microsoft Dynamics GP. The following topics are discussed:

  • Overview
  • Running the sample applications
  • How the sample applications work
  • How eConnect was used


Overview

There are two sample applications that demonstrate how to retrieve document numbers. The C# version allows you to request a document number for SOP, PM, SOP Payments, IV, and PO.

The Visual Basic .NET. version demonstrates how to retrieve and return a SOP document number.

To build either sample application, you must have Visual Studio and the .NET Framework installed on your computer. To find project files for the C# application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\CSHARP GetNextDocumentNumber

To find the project files for the Visual Basic .NET application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\NextNum_TestHarness


Running the sample applications

To run either sample application, perform the following steps:

  1. Start Visual Studio and open the solution file for the sample application.

The solution file for the C# sample application is named DocumentNumberSample.sln. The solution file is in the CSHARPGetNextDocumentNumber folder inside the Samples folder.

The solution file for the Visual Basic .NET sample application is named NextNum_TestHarness.sln. The solution file is in the NextNum_TestHarness folder inside the Samples folder.

  2. Choose Start Debugging from the Debug menu.

To build either solution, choose “Start Debugging” in the Debug menu. The application starts.

  3. Update the connection string.

To configure the connection string in the C# sample application, enter the name of your Microsoft Dynamics GP SQL server in the SQL Server box. Enter the name of your Microsoft Dynamics GP database in the Database box.

The Visual Basic .NET application uses a dialog box to manage the connection string parameters. Click the ellipsis (...) button labeled BackOffice Connection String. Use the dialog box to specify your Microsoft Dynamics GP server name, log in name, password, and database. Click OK to close the dialog window.

  4. Retrieve the next document number.

To retrieve the next available document numbers using the C# application, click the Get Next Numbers button. The application will display the next number for each document type.

To retrieve the next available SOP document number using the Visual Basic .NET application, mark the Get next number option and click the Run button. The application display the next available SOP number. To return the number, mark the Rollback number option and click the Run button.


How the sample applications work

Each time you click the C# application’s Get Next Numbers button, it retrieves the next document number for each document type from the company identified by the SQL Server and Database settings. The application displays the number for each type of document.

If you mark the Visual Basic .NET application’s Get next number option and click the Run button, the application retrieves and displays the next available SOP document number. If you subsequently mark the Rollback number option and click Run, the application will indicate that it has put back the specified SOP document number.

If an error occurs while running either application, the application opens a dialog box and displays the error message.


How eConnect was used

Both sample applications use classes in the Microsoft.Dynamics.GP.eConnect assembly.

Microsoft.Dynamics.GP.eConnect

The two applications vary in how they use the Microsoft.Dynamics.GP.eConnect classes. If you review the button click event handlers for each application you will note the following differences:

  • The C# application instantiates a GetNextDocNumbers object and a GetSopNumber object. The application uses the GetSopNumber object’s GetNextSopNumber method to retrieve the next available SOP document number.

The application uses the GetNextDocNumbers object to retrieve numbers for the other document types it displays. To retrieve these numbers, the application uses the GetNextPMPaymentNumber, GetNextRMNumber, GetNextIVNumber, and GetNextPONumber methods.

  • The Visual Basic .NET application instantiates a GetSopNumber object. If the Get next number option is marked, the application uses the GetSopNumber object’s GetNextSopNumber method to retrieve the next SOP document number. If the Rollback number option is marked, the application uses the GetSopNumber object’s RollBackSopNumber method.


Retrieve Data

The Requester Console Application uses an eConnect XML document to retrieve Microsoft Dynamics GP data. The following topics are discussed:

  • Overview
  • Running the sample application
  • How the sample application works
  • How eConnect was used


Overview

This C# sample application uses eConnect serialization classes to create an eConnect XML request document. The application serializes the request document to a file. The application uses the XML from the file to retrieve Microsoft Dynamics GP customer data. The application displays the customer data in the console window.

Before you run this application, set the eConnect connection string in the source file to access the appropriate Microsoft Dynamics GP database.

The application’s request document requires you to target a Microsoft Dynamics GP server that includes the TWO sample database.

To build this application, you must have Visual Studio and the 3.5 .NET Framework installed on your computer. To find project files for the C# application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\CSHARP Requester Console Application


Running the sample application

To run this sample application, perform the following steps:

  1. Start Visual Studio and open the solution file for the sample application.

The solution file for this sample is named RequesterConsoleApplication.sln. The solution file is in the CSHARPRequesterConsoleApplication folder inside the Samples folder.

  2. Open the source file.

Open the Visual Studio Solution Explorer and open the Class1.cs file.

  3. Update the connection string.

Locate the variable named sConnectionString and set the Data Source value to the name of your Microsoft Dynamics GP SQL Server. Set the Initial Catalog value to TWO.

  4. Build the RequesterConsoleApplication.exe.

Choose “Build RequesterConsoleApplication” in the Build menu.

  5. Open a console window.

From the Start menu, choose All Programs >> Accessories >> Command Prompt. In the console window, open the directory where you built the RequesterConsoleApplication.exe.

  6. Run the RequesterConsoleApplication.

Type RequesterConsoleApplication.exe and press Enter. When the application completes, the console window displays XML data for Aaron Fitz Electric.


How the sample application works

The RequesterConsoleApplication uses classes from the eConnect .NET assemblies to create an eConnect XML request document. The application creates the eConnect XML request document using several eConnect serialization classes. The application converts the eConnect XML request document to an XML string.

The application uses the XML string and the eConnect business objects to retrieve an XML document that contains the requested customer data. The application displays the customer data in the console window.

The application uses eConnect connection string information to connect to the eConnect business objects.

If an error occurs, the application displays the error message in the console window.


How eConnect was used

The sample application uses classes from the Microsoft.Dynamics.GP.eConnect and Microsoft.Dynamics.GP.eConnect.Serialization assemblies.

Microsoft.Dynamics.GP.eConnect

The application instantiates the eConnectMethods class to create an eConnectMethods object. The application uses the object’s GetEntity method to retrieve the specified customer data. The GetEntity method requires two strings. One represents an eConnect XML request document and the other is the eConnect connection string.

Microsoft.Dynamics.GP.eConnect.Serialization

The application uses several serialization classes to construct an eConnect XML request document. To create a request document, the sample application instantiates the eConnectType, RQeConnectOutType, and eConnectOut classes.

The application populates the properties of the eConnectOut object to specify the customer. It then populates RQeConnectOutType object with the eConnectOut object. The application completes the eConnect XML request document by populating the eConnectType object with the RQeConnectOutType object.

The application uses a .NET XmlSerializer to write the eConnectType object as a string. The application uses the XML string as parameter of the eConnect_Requester method.


MSMQ Document Sender

The MSMQ Document Sender sample is a .NET application that converts an eConnect XML document to a Microsoft Message Queue (MSMQ) message and places that message in a specified queue. The following topics are discussed:

  • Overview
  • Running the sample application
  • How the sample application works
  • How eConnect was used


Overview

This sample application converts an eConnect XML document to a MSMQ message and places the message in a MSMQ queue. Use this application with the eConnect Incoming Service to create, update, and delete Microsoft Dynamics GP data.

This sample application uses Visual Basic .NET. To build this application, you must have Visual Studio and the 2.0 .NET Framework installed on your computer. You must also have MSMQ installed and running on your computer.

To find the project files for this Visual Basic .NET application, open the following folder:

c:\Program Files\Microsoft Dynamics\eConnect 12.0\eConnect Samples\VB DOT NET Queue Client


Running the sample application

To run this sample application, perform the following steps:

  1. Start Visual Studio and open the solution file for the sample application.

The solution file is named QueueClientForDotNet.sln. The solution file is in the VBDOTNETQueueClient folder inside the Samples folder.

  2. Choose Start Debugging from the Debug menu.

To build the solution, choose “Start Debugging” in the Debug menu. The application starts.

  3. Mark the MSMQ Private or Public queue option.

You may use either Private or Public queues. The application default specifies private queues.

  4. Select the queue that will receive the message.

The Local Private Queues drop-down list contains the MSMQ queues on your computer. Select the queue in the list you want to receive the eConnect XML message.

  5. Enter a message label.

Use the message label to identify your message when viewing the contents of the queue.

  6. Select an eConnect XML document file.

Click the ellipsis (...) button next to the XML Document Path box. A dialog box opens. Use the dialog box to find and open an XML file. Highlight the file you want to use and click Open.

  7. Review the XML document.

The Browser View and Text View tabs display the contents of the XML file. You may edit the XML in the Text View tab. If you edit the XML, you will be prompted to save your changes to the file.

  8. Send the XML as a message to MSMQ.

Click the Send to Queue button to send the eConnect XML message to the specified queue. A message box indicates the message was successfully sent to the specified queue. Click OK.


How the sample application works

The sample application opens the specified file, reads the XML from the file, and writes the XML as a string to the Text View tab.

When you click the Send to Queue button, the application converts the XML in the Text View tab to an MSMQ message. To complete the message, the application assigns the value from the Message Label box to the message.

The application sends the message to the MSMQ queue specified in the Local Private Queue list. The application opens a dialog box that states the MSMQ message was successfully sent to the queue.

If an error occurs, the application opens a dialog box and displays the error message.


How eConnect was used

The application uses an eConnect XML document as the basis for the MSMQ message. The sample application does not use any of the eConnect .NET assemblies.


eConnect .NET Reference

The following sections describe the namespaces, classes, enumerations and methods that you use to add eConnect for Microsoft Dynamics GP functionality to a .NET development project.

To add eConnect functionality, you add a reference in your .NET development project to one or more of the eConnect .NET assemblies. The assemblies are typically found in the following location.

C:\Program Files\Microsoft Dynamics\eConnect 12.0\API

The eConnect assemblies includes the following namespaces:

  • Microsoft.Dynamics.GP.eConnect Namespace
  • Microsoft.Dynamics.GP.eConnect.Serialization Namespace


Microsoft.Dynamics.GP.eConnect Namespace

This section of the documentation describes the classes and enumeration contained in the Microsoft.Dynamics.GP.eConnect namespace. You typically use these classes and enumerations to request and submit eConnect documents.

Assembly

Microsoft.Dynamics.GP.eConnect.dll

Classes

The Microsoft.Dynamics.GP.eConnect namespace includes the following classes

Class | Description
Configuration Class | Specifies the properties you use to configure an eConnect application.
DocumentRollback Class | Specifies a collection of Microsoft Dynamics GP document numbers that were not used.
DtcEventRegistrar Class | Specifies how you want to handle event logging when a transaction is promoted to a distributed transaction.This class is a static class.
eConnectException Class | Defines the type of exception created by the eConnect interface.
eConnectFault Class | Specifies an eConnect exception that occurred during a service operation. You use an eConnectFault object to retrieve eConnect error information for applications that use a service reference with the eConnect Integration Service.
eConnectMethods Class | Provides access to Microsoft Dynamics GP data.
eConnectSqlError Class | Specifies a SQL exception. A collection of eConnectSqlError objects is used to construct an eConnectSqlFault object.
eConnectSqlErrorCollection Class | Specifies a collection of eConnectSqlError objects. The collection is used to construct an eConnectSqlFault object.
eConnectSqlFault Class | Specifies one or more SQL exceptions that occurred during a service operation. You use an eConnectSqlFault object to retrieve SQL error information for applications that use a service reference with the eConnect Integration Service.
EnumTypes Class | Defines enumerations used by methods in the eConnectMethods class.
GetNextDocNumbers Class | Retrieves the next document number for several types of Microsoft Dynamics GP documents.
GetSopNumber Class | Retrieves the next SOP document number.
RollBackDocument Class | Specifies a single Microsoft Dynamics GP document number that was not used

Enumerations

The Microsoft.Dynamics.GP.eConnect namespace includes the following enumerations

Enumeration | Description
EnumTypes.ConnectionStringType Enumeration | Specifies the type of data server
EnumTypes.SchemaValidationType Enumeration | Specifies the type of validation.
IncrementDecrement Enumeration | Specifies whether to retrieve or restore a document number.
IVDocType Enumeration | Specifies the type of an inventory document.
RMPaymentType Enumeration | Specifies the type of a receivables document.
SopType Enumeration | Specifies the type of a sales order document.
TransactionType Enumeration | Specifies the type of transaction.


Configuration Class

Specifies the service configuration settings for an eConnect application.

Constructor

Name | Description
Configuration() | Initializes an instance of the Configuration class.

Properties

Name

Type

Default

Description

LogDtcPromotions

bool

true

Specifies whether to log a warning when a transaction is promoted to a distributed transaction. This property is read-only. To change logging behavior, use the configuration file to set this property to false.

MaxReadQuotaSize

int

2147483647

Specifies the maximum size of read messages. The default value is the largest possible value.

MaxReceivedMessageSize

int

2147483647

Specifies the maximum size of an XML document. The default value is the largest possible value.

ProcTimeOut

int

600

Specifies the number of seconds to wait before a time out occurs

RequireProxyService

bool

true

Specifies whether to use the identify of the logged on user or the service identity when accessing SQL server. The value true forces the application to use the service identity.

ReuseBaseTransaction

bool

false

Specifies whether to reuse the base transaction for all new connection strings. Set the value to false to always use a new SQL connection.

If you set the value to true, you can reuse an existing SQL connection for different connection strings. However, reusing an existing connection causes the transaction to be promoted to a SQL Distributed Transaction Coordinator (DTC) transaction. A DTC transaction requires additional overhead that can slow the completion of the transaction.

SendTimeout

System.Timespan

60 minutes

Specifies the length of time to wait when connecting to the eConnect Integration Service. Used when the RequiredProxyService is set to true.

ServiceAddress

String

net.pipe://localhost/Microsoft/Dynamics/GP/eConnect/

Specifies the URL of the eConnect Integration Service.

ServiceOperationTimeout

System.Timespan

60 minutes

Specifies the length of time to wait for an operation to complete. Used when the RequiredProxyService is set to true.

TransactionIsolationLevel

System.Transaction.IsolationLevel

ReadUncommitted

Specifies the isolation level of the transaction.

TransactionTimeoutSeconds

System.Timespan

60 minutes

Specifies the length of time to wait for a SQL transaction to complete.

Remarks

These properties are typically populated with values from the application configuration file. However, you can also set or change these properties from your application. If you change a Configuration class property in your application code, the new value overrides the value specified in the configuration file.


DocumentRollback Class

The DocumentRollback class allows you to create a collection that stores Microsoft Dynamics GP document numbers.

Use a DocumentRollback object to store the document numbers you retrieve for an eConnect transaction. If an error occurs during your eConnect transaction, the DocumentRollback class allows you to produce an arraylist that specifies all the document numbers in your transaction. The RollBackDocumentList method of the GetNextDocNumbers class uses this arraylist to restore the specified Microsoft Dynamics GP document numbers.

Constructor

Name | Description
DocumentRollback() | Initializes an instance of the DocumentRollback class.

Methods

Name | Return Value | Description
Add Method | void | Adds a Microsoft Dynamics GP document number to a DocumentRollback collection.
Dispose Method | void | Releases the resources of the DocumentRollback object.
CollectionContainsDocuments Method | bool | Specifies whether a DocumentRollback collection is empty.
GetRollBackDocumentList Method | List<RollBackDocument> | Returns a list of document numbers from the Rollback collection.
RollBackDocuments Method | ArrayList | Returns an arraylist of document numbers from the Rollback collection.


Add Method

This method adds a Microsoft Dynamics GP document number to the DocumentRollback collection.

Class

Microsoft.Dynamics.GP.eConnect.DocumentRollback

Syntax

public void Add(
    TransactionType transactionType,
    string documentNumber
)

public void Add(
    TransactionType,
    short,
    string documentNumber
)

public void Add(
    TransactionType,
    short, documentType
    string, documentNumber
    string documentID
)
Parameters

Name | Data type | Description
transactionType | Microsoft.Dynamics.GP. eConnect.TransactionType | Use a TransactionType enumeration member to specify the transaction type associated with the document number. TransactionType includes the following members: GL IVTrans IVTransfer PM POP POPReceipt RM SOP
documentType | short | An integer that specifies the document type associated with the Microsoft Dynamics GP document number.
documentNumber | string | A string that specifies a Microsoft Dynamics GP document number.
documentID | string | A string that specifies the document ID associated with the document number.

Return Value

Type: void

The method does not return a value.


Dispose Method

Releases all resources used by the DocumentRollback class.

Class

Microsoft.Dynamics.GP.eConnect.DocumentRollback

Syntax

public void Dispose()
Return Value

Type: void

The method does not return a value.

Remarks

Use Dispose when you are finished using the DocumentRollback object. The Dispose method releases the resources of that object.

Always call Dispose before you release the last reference to the DocumentRollback object.


CollectionContainsDocuments Method

This method specifies whether the collection of document numbers is empty.

Class

Microsoft.Dynamics.GP.eConnect.DocumentRollback

Syntax

public bool CollectionContainsDocuments()
Return Value

Type: bool

A return value of true indicates one or more document numbers have been added to the collection. A return value of false indicates no document numbers have been added to the collection


GetRollBackDocumentList Method

This method returns a list of RollBackDocument objects.

Class

Microsoft.Dynamics.GP.eConnect.DocumentRollback

Syntax

public System.Collections.ArrayList GetRollBackDocumentList()
Return Value

Type: List<RollBackDocument>

RollBackDocuments returns an arraylist that contains the collection of document numbers that were added to this DocumentRollback object. To restore these Microsoft Dynamics GP document numbers, use this arraylist as a parameter for the RollBackDocumentList method of the GetNextDocNumbers class


RollBackDocuments Method

This method returns an arraylist of RollBackDocument objects.

Class

Microsoft.Dynamics.GP.eConnect.DocumentRollback

Syntax

public System.Collections.ArrayList RollBackDocuments()
Return Value

Type: ArrayList

RollBackDocuments returns an arraylist that contains the collection of document numbers that were added to this DocumentRollback object. To restore these Microsoft Dynamics GP document numbers, use this arraylist as a parameter for the RollBackDocumentList method of the GetNextDocNumbers class

See Also

RollBackDocumentList Method


DtcEventRegistrar Class

The DtcEventRegistrar class is a static class you use to specify how to handle event logging when a transaction is promoted to a distributed transaction.

Methods

Name | Return Value | Description
DisableDistributedTransactionLogging | void | Turn off the logging of DTC promotions so that they occur silently.
EnableDistributedTransactionLogging | void | Turn on the logging of DTC promotions so that they are added to the event log.

Remarks

You use the class to disable or enable the event handler associated with logging a warning message when a transaction is promoted to a distributed transaction.


DisableDistributedTransactionLogging

Use this static method to turn off the logging of DTC promotions. The warning messages associated with DTC promotions will not appear in the event log.

Class

Microsoft.Dynamics.GP.eConnect.DtcEventRegistrar

Syntax

public void DtcEventRegistrar.DisableDistributedTransactionLogging()
Return Value

Type: void

The method does not return a value.


EnableDistributedTransactionLogging

Use this static method to turn on the logging of DTC promotions. The warning messages associated with DTC promotions appear in the event log.

Class

Microsoft.Dynamics.GP.eConnect.DtcEventRegistrar

Syntax

public void DtcEventRegistrar.DisableDistributedTransactionLogging()
Return Value

Type: void

The method does not return a value.


eConnectException Class

The eConnectException class allows you to catch and handle eConnect-specific errors. If an error occurs that originates with business objects or framework, eConnect throws an eConnectException object. You can use the properties of the eConnectException object to identify the type of error and its accompanying error message.

The eConnectException class inherits from the System.ApplicationException class. eConnectException uses the properties of the parent class. Refer to the .NET Framework documentation for information about the System.ApplicationException class.

Constructor

Initializes a new instance of the eConnectException class.

Name | Description
eConnectException() | Create a new eConnect exception.
eConnectException(string errMessage) | Creates an eConnect exception with the specified error message.
ConnectException(string errMessage, System.Exception systemException) | Creates an eConnect exception with a specified error message and a reference to an inner exception.
eConnectException(System.Runtime.Serialization.SerializationInfo info, System.Runtime.Serialization.StriamingContext context) | Creates an eConnect exception using serialized exception information.

Parameters

Name | Data type | Description
errMessage | string | Specifies the error message for the exception.
systemException | System.Exception | Specifies the inner exception that was caught.
info | System.Runtime.Serialization.SerializationInfo | Specifies a serialized instance of an exception.
context | System.Runtime.Serialization.StreamingContext | Specifies the source of a serialized stream.

Properties

Name | Type | Description
InnerException | System.Exception | Specifies the inner exception that is associated with the exception.
Message | string | Specifies the error message for the exception
Source | string | Specifies the source of the exception
StackTrace | string | Specifies the stack trace at the time of the exception.


eConnectFault Class

The eConnectFault class enables you to catch and handle eConnect specific errors. If you create a Service Reference to the eConnect Integration Service, a service operation returns an eConnectFault object when an eConnect error occurs.

Constructor

Name | Description
eConnectFault() | Initializes an instance of the eConnectFault class.

Properties

Name | Type | Description
ExceptionType | string | Specifies the type of error that occurred.
Message | string | Specifies the error message for the exception.
Source | string | Specifies the source of the exception.
StackTrace | string | Specifies the stack trace at the time of the exception.


eConnectMethods Class

Use the eConnectMethods class to send or request eConnect documents. To use the eConnectMethods class you must first instantiate an object.

Inherits from the System.EnterpriseServices.ServicedComponent class.

Constructor

Name | Description
eConnectMethods() | Initializes an instance of the eConnectMethods class.

Properties

Name | Type | Default | Description
RequireProxyService | bool | true | Specifies whether to use the identify of the logged on user or the service identity when accessing SQL server. The value true forces the application to use the service identity. The value in this class overrides the RequireProxyService setting in the configuration file.

Methods

Name | Return Value | Description
CreateEntity Method | boolean | Creates a record from an eConnect XML document.
CreateTransactionEntity Method | string | Creates a transaction from an eConnect XML document.
DeleteEntity Method | boolean | Deletes a specified record from Microsoft Dynamics GP.
DeleteTransactionEntity Method | boolean | Deletes a specified transaction from Microsoft Dynamics GP.
Dispose Method | void | Releases the resources of the eConnectMethods object.
eConnect_EntryPoint Method | boolean | Use this method to submit an XML document.
eConnect_Requester Method | string | Use this method to retrieve XML documents.
GetEntity Method | string | Releases all resources used by the eConnectMethods class.
UpdateEntity Method | boolean | Updates a specified record in Microsoft Dynamics GP.
UpdateTransactionEntity Method | boolean | Updates a specified transaction in Microsoft Dynamics GP.

Examples

The following Visual Basic .NET code sample creates an eConnectMethods object:

'Instantiate an eConnectMethods object
Dim eConnectObject As New eConnectMethods


CreateEntity Method

Creates a record from an eConnect XML document.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public bool CreateEntity(string connectionString, string sXML)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
sXML | string | An eConnect XML document.

Return Value

Type: boolean

The method returns a boolean value that indicates whether the XML document was successfully created. A return value of True indicates the operation succeeded.

Remarks

Use the CreateEntity method to create new data records in Microsoft Dynamics GP. For example, use CreateEntity to add a new customer or vendor.

To submit a document, create a string that represents the eConnect XML document. Use the string as the sXML parameter.

If an error occurs, the method throws an eConnectException, application exception, or exception.

Examples

The following C# code example creates a customer record from XML in a file named CustomerCreate.xml. Notice how the CreateEntity method returns a boolean value.

// Use an XML document to create a string representation of the customer
XmlDocument newCustDoc = new XmlDocument();
newCustDoc.Load("CustomerCreate.xml");
newCustomerDocument = newCustDoc.OuterXml;

// Specify the Microsoft Dynamics GP server and database in
// the connection string
sConnectionString = @"data source=MySrvr;initial catalog=TWO;
    integrated security=SSPI;persist security info=False;
    packet size=4096";

// Use the CreateEntity method
bool testResult = e.CreateEntity(sConnectionString, newCustomerDocument);

See Also

  • CreateTransactionEntity Method


CreateTransactionEntity Method

Creates a transaction from an eConnect XML document. Returns a string that includes XML for the document that was created.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public string CreateTransactionEntity(string connectionString, string sXML)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
sXML | string | An eConnect XML document.

Return Value

Type: string

The return value is a string that contains the XML for the document that was created.

Remarks

Use the CreateTransactionEntity method to create new transaction data in Microsoft Dynamics GP. For example, use CreateTransactionEntity to add a sales order or inventory transaction document.

To submit a document, create a string that represents the eConnect XML document. Use the string as the sXML parameter.

Use the return value to verify the data that was created. For example, use the XML to obtain the document ID for transaction documents that automatically generate document ID numbers.

If an error occurs, the method throws an eConnectException, application exception, or exception.

Examples

The following Visual Basic .NET code example creates a sales order document. The XML that specifies the sales order to create is retrieved from the file named CustomerDelete.xml. Notice how the CreateTransactionEntity returns an XML string that represents the new sales order.

'Load the eConnect XML document into an XMLDocument object
Dim xmldoc As New Xml.XmlDocument
xmldoc.Load("SalesOrder.xml ")

'Use the XMLDocument object to create an XML string representation
‘of the eConnect XML Sales Order document
Dim salesOrderDocument As String
salesOrderDocument = xmldoc.OuterXml

'Create a connection string to the Microsoft Dynamics GP database server
'Integrated Security is required. Integrated security=SSPI
Dim sConnectionString As String
sConnectionString = "data source=MySrvr;initial catalog=TWO;" _
    & "integrated security=SSPI;persist security info=False;" _
    & "packet size=4096"

'Use CreateTransactionEntity to create the sales order document
‘in Microsoft Dynamics GP
Dim newSalesOrder As String
newSalesOrder = eConCall.CreateTransactionEntity(sConnectionString, salesOrderDocument)

See Also

  • CreateEntity Method


DeleteEntity Method

Deletes a specified record from Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public bool DeleteEntity(string connectionString, string sXML)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
sXML | string | An eConnect XML document.

Return Value

Type: boolean

The method returns a boolean value that indicates whether the XML document was successfully deleted. A return value of True indicates the operation succeeded.

Remarks

Use the DeleteEntity method to remove a data record from Microsoft Dynamics GP. For example, use DeleteEntity to remove a customer or vendor.

Use the DeleteEntity method with eConnect XML document types that include nodes to delete records. If the schema for a document type does not include a node to delete a record, you cannot use DeleteEntity with that document type.

Examples

The following C# code example deletes a specified customer record. The XML that specifies the customer to delete is retrieved from the file named CustomerDelete.xml. Notice how the DeleteEntity method returns a boolean value.

// Specify the Microsoft Dynamics GP server and database in
// the connection string
sConnectionString = @"data source=MySrvr;initial catalog=TWO;
    integrated security=SSPI;persist security info=False;
    packet size=4096";

// Retrieve the XML that specifies the customer to delete from an XML file
// Use the XML in the file to create an XML document
XmlDocument deleteCustDoc = new XmlDocument();
deleteCustDoc.Load("CustomerDelete.xml");
deleteCustomerDocument = deleteCustDoc.OuterXml;

// Delete the specified customer record
bool testResult = e.DeleteEntity(sConnectionString, deleteCustomerDocument);

See Also

  • DeleteTransactionEntity Method


DeleteTransactionEntity Method

Deletes a specified transaction from Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public bool DeleteTransactionEntity(string connectionString, string sXML)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
sXML | string | An eConnect XML document.

Return Value

Type: boolean

The method returns a boolean value that indicates whether the XML document was successfully deleted. A return value of True indicates the operation succeeded.

Remarks

Use the DeleteTransactionEntity method to remove transaction data from Microsoft Dynamics GP. For example, use DeleteTransactionEntity to remove a sales order or inventory transaction document.

Use the DeleteTransactionEntity method with eConnect XML transaction types that include nodes to delete records. If the document schema for a transaction type does not include a node to delete a record, you cannot use DeleteTransactionEntity with that transaction type.

See Also

  • DeleteEntity Method


Dispose Method

Releases all resources used by the eConnectMethods class.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public void Dispose()
Return Value

Type: void

The method does not return a value.

Remarks

Use Dispose when you are finished using the eConnectMethods object. The Dispose method releases the resources of that object.

Always call Dispose before you release the last reference to the eConnectMethods object.


eConnect_EntryPoint Method

Use the eConnect_EntryPoint method to submit an eConnect document.

This method is obsolete and will be removed in a future version of eConnect.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public bool eConnect_EntryPoint(
    string connectionString,
    EnumType.ConnectionStringType connectionType,
    string sXML,
    EnumType.ValidationType validationType,
    string eConnectSchema
)
Parameters

Name

Data type

Description

connectionString

string

Specifies your data server and database.

connectionType

Microsoft.Dynamics.GP.
eConnect.EnumTypes.
ConnectionStringType

Use the ConnectionStringType enumeration member that specifies the type of your data server. ConnectionStringType includes the following members:

SqlClient

OleDB

sXML

string

An eConnect XML document.

validationType

Microsoft.Dynamics.GP.
eConnect.EnumTypes.
SchemaValidationType

Use a SchemaValidationType enumeration member to specify the type of data validation to perform. SchemaValidationType includes the following members:

None

XSD

eConnectSchema

string

Optional.

If you set the ValidationType parameter to XSD, you must specify the filepath to the .xsd file that contains the schema definition.

If you set the ValidationType parameter to None, the parameter defaults to an empty string and you do not need to supply a value.

Return Value

Type: boolean

The method returns a boolean value that indicates whether the XML document was successfully submitted. A return value of True indicates the operation was successfully completed.

Remarks

This method is obsolete. To replace existing calls to eConnect_EntryPoint, use the CreateEntity, CreateTransactionEntity, DeleteEntity, DeleteTransactionEntity, UpdateEntity or UpdateTransactionEntity method.

To submit a document, create a string that represents the eConnect XML document. Use the string as the sXML parameter.

If an error occurs, the method throws an eConnectException, application exception, or exception.

Examples

The following Visual Basic .NET example uses the eConnect_EntryPoint method to submit an eConnect XML document. Notice that the ConnectionType parameter uses the EnumTypes.ConnectionStringType.SqlClient enumeration to specify a SQL client connection. The ValidationType parameter uses the EnumTypes.SchemaValidationType.None enumeration to specify that the XML document is not validated. If you set the ValidationType parameter to None, the eConnect_EntryPoint method does not require the eConnectSchema parameter. The parameter defaults to an empty string.

Dim ConnectionString As String
Dim eConnectResult As Boolean
Dim eConnectObject As New eConnectMethods
Dim xmlDoc As XmlDocument

'Set the connection string
'This connection string uses integrated security to connect to the
'TWO database on the local computer
ConnectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

'Load the contents of the textbox into the xmlDoc object
xmlDoc.LoadXml(XmlDoc_TextBox.Text)

'Instantiate an eConnectMethods object
Dim eConnectObject As New eConnectMethods

'If eConnectResult is TRUE, the XML document was successfully submitted
eConnectResult = eConnectObject.eConnect_EntryPoint(ConnectionString, _
    EnumTypes.ConnectionStringType.SqlClient, _
    xmlDoc.OuterXml, _
    EnumTypes.SchemaValidationType.None)

See Also

  • CreateEntity Method
  • CreateTransactionEntity Method
  • DeleteEntity Method
  • DeleteTransactionEntity Method
  • UpdateEntity Method
  • UpdateTransactionEntity Method
  • EnumTypes.ConnectionStringType Enumeration
  • EnumTypes.SchemaValidationType Enumeration


eConnect_Requester Method

Use the eConnect_Requester method to retrieve Microsoft Dynamics GP data in an eConnect document.

This method is obsolete and will be removed in a future version of eConnect.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public string eConnect_Requester(
    string connectionString,
    EnumTypes.ConnectionStringType connectionType,
    string sXML
)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
connectionType | Microsoft.Dynamics.GP. eConnect.EnumTypes. ConnectionStringType | Use the ConnectionStringType enumeration member that specifies the type of your data server. ConnectionStringType includes the following members: SqlClient OleDB
sXML | string | An eConnect XML document.

Return Value

Type: string

The string is an XML document that represents the requested data.

Remarks

This method is obsolete. Replace existing calls to the eConnect_Requester with the GetEntity method.

To use the eConnect_Requester method to retrieve a document, create an eConnect XML document that specifies the document to retrieve. The document must use the RQeConnectOutType schema and the eConnectOut node to identify the document.

If an error occurs, the method throws an eConnectException, application exception, or exception.

Examples

The following Visual Basic .NET example uses the eConnect_Requester method to retrieve and display an XML document:

Dim ConnectionString As String
Dim eConnectObject As New eConnectMethods
Dim xmlDoc As XmlDocument

'Set the connection string
'This connection string uses integrated security to connect to the
'TWO database on the local computer
ConnectionString = "Data Source=localhost; Integrated Security=SSPI;" _
    & "Persist Security Info=False; Initial Catalog=TWO;"

'Instantiate an eConnectMethods object
Dim eConnectObject As New eConnectMethods

'Display the XML document in a textbox
ReturnData_TextBox.Text=eConnectObject.eConnect_Requester(ConnectionString, _
    EnumTypes.ConnectionStringType.SqlClient, _
    xmlDoc.OuterXml)

See Also

  • GetEntity Method
  • EnumTypes.ConnectionStringType Enumeration


GetEntity Method

Retrieves specified data from Microsoft Dynamics GP. The data is returned as an XML string that represents the specified eConnect XML document.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public string GetEntity(string connectionString, string sXML)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
sXML | string | An eConnect XML document.

Return Value

Type: string

The string is an XML document that represents the requested data.

Remarks

To use the GetEntity method to retrieve a document, create an eConnect XML document that specifies the document to retrieve. The document must use the RQeConnectOutType schema and the eConnectOut node to identify the document.

If an error occurs, the method throws an eConnectException, application exception, or exception.

Examples

The following C# code example retrieves a single customer record. An eConnect requester document is used to specify the customer. Notice how the GetEntity method returns the specified customer data as an XML string.

// Specify the Microsoft Dynamics GP server and database in
// the connection string
sConnectionString = @"data source=MySrvr;initial catalog=TWO;
    integrated security=SSPI;persist security info=False;
    packet size=4096";

// Specify the customer to retrieve
eConnectOut myRequest = new eConnectOut();
myRequest.DOCTYPE = "Customer";
myRequest.OUTPUTTYPE = 1;
myRequest.INDEX1FROM = "Customer001";
myRequest.INDEX1TO = "Customer001";
myRequest.FORLIST = 1;

// Create the eConnect requester XML document object
RQeConnectOutType[] eConnectOutType =
    new RQeConnectOutType[1] { new RQeConnectOutType() };
eConnectOutType[0].eConnectOut = myRequest;

eConnectType eConnectDoc = new eConnectType();
eConnectDoc.RQeConnectOutType = eConnectOutType;

// Serialize the object to produce an XML document
MemoryStream memStream = new MemoryStream();

XmlSerializer serializer = new XmlSerializer(typeof(eConnectType));
serializer.Serialize(memStream, eConnectDoc);

memStream.Position = 0;

XmlDocument myDoc = new XmlDocument();
myDoc.Load(memStream);

// Retrieve the specified customer document
string myCustomer = e.GetEntity(sConnectionString, myDoc.OuterXml);


UpdateEntity Method

Updates a specified record in Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public bool UpdateEntity(string connectionString, string sXML)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
sXML | string | An eConnect XML document.

Return Value

Type: boolean

The method returns a boolean value that indicates whether the XML document was successfully updated. A return value of True indicates the operation succeeded.

Remarks

Use the UpdateEntity method to update an existing data record in Microsoft Dynamics GP. For example, use UpdateEntity to update existing customer or vendor records.

To update a document, create a string that represents the updated eConnect XML document. Use the string as the sXML parameter.

If an error occurs, the method throws an eConnectException, application exception, or exception.

Examples

The following C# code example updates a customer. The XML that specifies the customer and the updated data is retrieved from a file. Notice how the UpdateEntity method returns a boolean value.

// Use an XML document to specify the customer and the updated data
XmlDocument updateCustDoc = new XmlDocument();
updateCustDoc.Load("CustomerUpdate.xml");
updateCustomerDocument = updateCustDoc.OuterXml;

// Specify the Microsoft Dynamics GP server and database in
// the connection string
sConnectionString = @"data source=MySrvr;initial catalog=TWO;
    integrated security=SSPI;persist security info=False;
    packet size=4096";

//UpdateEntity
bool testResult = e.UpdateEntity(sConnectionString, updateCustomerDocument);

See Also

  • UpdateTransactionEntity Method


UpdateTransactionEntity Method

Updates a specified transaction in Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.eConnectMethods

Syntax

public bool UpdateTransactionEntity(string connectionString, string sXML)
Parameters

Name | Data type | Description
connectionString | string | Specifies your data server and database.
sXML | string | An eConnect XML document.

Return Value

Type: boolean

The method returns a boolean value that indicates whether the XML document was successfully updated. A return value of True indicates the operation succeeded.

Remarks

Use the UpdateTransactionEntity method to update existing transaction data in Microsoft Dynamics GP. For example, use UpdateTransactionEntity to update existing sales order or inventory transaction documents.

To update a document, create a string that represents the updated eConnect XML transaction document. Use the string as the sXML parameter.

If an error occurs, the method throws an eConnectException, application exception, or exception.

Examples

The following Visual Basic .NET code example updates an existing sales order document. The XML that specifies the sales order to update is retrieved from the file named SalesOrderUpdate.xml. Notice how the UpdateTransactionEntity returns a boolean value.

'Load the eConnect XML document into an XMLDocument object
Dim xmldoc As New Xml.XmlDocument
xmldoc.Load("SalesOrderUpdate.xml ")

'Use the XMLDocument object to create an XML string representation
‘of the updated eConnect Sales Order XML document
Dim salesOrderDocument As String
salesOrderDocument = xmldoc.OuterXml

'Create a connection string to the Microsoft Dynamics GP database server
'Integrated Security is required. Integrated security=SSPI
Dim sConnectionString As String
sConnectionString = "data source=MySrvr;initial catalog=TWO;" _
    & "integrated security=SSPI;persist security info=False;" _
    & "packet size=4096"

'UpdateTransactionEntity
Dim testResult As Boolean
testResult = eConCall.UpdateTransactionEntity( _
    sConnectionString, salesOrderDocument)

See Also

  • UpdateEntity Method


eConnectSqlError Class

The eConnectSqlError class supports the eConnect .NET framework infrastructure and is not intended to be used directly form your code. The class provides information about a SQL exception.

Constructor

Name | Description
eConnectSqlError(int infoNumber, byte errorState, byte errorClass, string server, string errorMessage, string procedure, int lineNumber) | Initializes an instance of the eConnectSqlError class.

Parameters

Name | Data type | Description
infoNumber | int | Specifies a number for the exception.
errorState | byte | Specifies error state information for the exception.
errorClass | byte | Specifies the class of the exception.
server | string | Specifies the server.
errorMessage | string | Specifies the error message for the exception.
procedure | string | Specifies the procedure for the exception.
lineNumber | int | Specifies the line where the exception occurred.

Properties

Name | Type | Description
Class | byte | Specifies a class for the exception.
ErrorClass | byte | Specifies an error class for the exception.
LineNumber | int | Specifies the line number where the exception occurred.
Message | string | Specifies the message for the exception.
Number | int | Specifies the number for the exception.
Procedure | string | Specifies the procedure for the exception.
Server | string | Specifies the server for the exception.
Source | string | Specifies the source of the exception.
State | byte | Specifies state information for the exception.

See Also

  • eConnectSqlErrorCollection Class
  • eConnectSqlFault Class


eConnectSqlErrorCollection Class

The eConnectSqlErrorCollection class supports the eConnect .NET framework infrastructure and is not intended to be used directly form your code. The class provides access to a collection of eConnectSqlError objects.

Inherits from the System.Collection.Generic.List<eConnectSqlError> class.

Constructor

Name | Description
eConnectSqlErrorCollection() | Initializes an instance of the eConnectSqlErrorCollection class.

See also

  • eConnectSqlError Class
  • eConnectSqlFault Class


eConnectSqlFault Class

The eConnectSqlFaults class enables you to catch and handle SQL specific exceptions. If you create a Service Reference to the eConnect Integration Service, a service operation returns an eConnectSQLFault object when a SQL error occurs.

Constructor

Name | Description
eConnectSqlFault(eConnectSqlErrorCollection errors) | Initializes an instance of the eConnectSqlFault class.

Parameters

Name | Data type | Description
errors | eConnectSqlErrorCollection | A eConnectSqlErrorCollection object.

Properties

Name | Type | Description
Errors | eConnectSqlErrorCollection | The eConnectSqlErrorCollection object that contains the SQL error information.
Message | string | Specifies the error message associated with the exception.
StackTrace | string | Specifies stack trace information associated with the exception.


EnumTypes Class

Defines enumerations used with the eConnect_EntryPoint and eConnect_Requester methods.

Constructor

Name | Description
EnumTypes() | Initializes an instance of the EnumTypes class.

Enumerations

Name | Description
ConnectionStringType | Specifies the type of data server
SchemaValidataionType | Specifies whether to validate XML documents


EnumTypes.ConnectionStringType Enumeration

Specifies the type of data server associated with a connection string.

Members

Value | Description
OleDB | Connect using ODBC connection
SqlClient | Connect using SQL connection

Remarks

Used as parameter for the eConnectMethods.eConnect_EntryPoint and the eConnectMethods.eConnect_Requester methods.

See Also

  • eConnect_EntryPoint Method
  • eConnect_Requester Method


EnumTypes.SchemaValidationType Enumeration

Specifies whether to perform data validation of an eConnect document.

Members

Value | Description
None | No validation is performed
XSD | Use XSD schema for validation

Remarks

Used as a parameter for the eConnectMethods.eConnect_EntryPoint method

See Also

  • eConnect_EntryPoint Method


GetNextDocNumbers Class

The GetNextDocNumbers class allows you to retrieve the next valid document number for several Microsoft Dynamics GP document types. To use the GetNextDocNumbers class you must first instantiate an object.

Inherits from the System.EnterpriseServices.ServicedComponent class.

Constructor

Name | Description
GetNextDocNumbers() | Initializes an instance of the GetNextDocNumbers class.

Properties

Name | Type | Default | Description
RequireProxyService | boolean | true | Specifies whether to use the identify of the logged on user or the service identity when accessing SQL server. The value true forces the application to use the service identity. The value in this class overrides the RequireProxyService setting in the configuration file.

Methods

Name | Return Value | Description
Dispose Method | void | Releases the resources of the GetNextDocNumbers object.
GetNextGLJournalEntryNumber Method | string | Retrieves the next general ledger journal entry document number.
GetNextIVNumber Method | string | Retrieves the next document number for a specified type of inventory document.
GetNextPONumber Method | string | Retrieves the next purchase order number.
GetNextPOPReceiptNumber Method | string | Retrieves the next purchase order receipt document number.
GetNextRMNumber Method | string | Retrieves the next document number for a specified type of receivable document.
GetNextSOPNumber Method | string | Retrieves the next document number for a specified type of sales order document.
GetPMNextVoucherNumber Method | string | Retrieves the next payables management document number.
RollBackDocumentList Method | void | Returns one or more unused document numbers.
SortAndRollBackDocumentList Method | void | Sorts and rolls back a list of document numbers.

Examples

The following Visual Basic .NET example creates a GetNextDocNumbers object:

'Instantiate a GetNextDocNumbers object
Dim NextDocNumberObject As New GetNextDocNumbers


Dispose Method

Releases all resources used by the GetNextDocNumbers class.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public void Dispose()
Return Value

Type: void

The method does not return a value.

Remarks

Use Dispose when you are finished using the GetNextDocNumbers object. The Dispose method releases the resources of that object.

Always call Dispose before you release the last reference to the GetNextDocNumbers object.


GetNextGLJournalEntryNumber Method

This method will retrieve the next general ledger journal entry document number from Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public virtual string GetNextGLJournalEntryNumber(
    GetNextDocNumbers.IncrementDecrement incDec,
    string connString
)
Parameters

Name | Data type | Description
incDec | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IncrementDecrement | Use the IncrementDecrement enumeration member Increment to get the next GL journal entry number. Do not use the enumeration member Decrement in this version of eConnect.
connString | string | Specifies the SQL server and database.

Return Value

Type: string

This method returns a string that contains the requested general ledger journal entry document number.

See Also

  • IncrementDecrement Enumeration


GetNextIVNumber Method

This method will retrieve the next document number for the specified type of Microsoft Dynamics GP inventory document.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public virtual string GetNextIVNumber(
    GetNextDocNumbers.IncrementDecrement incDec,
    GetNextDocNumbers.IVDocType docType,
    string connString
)
Parameters

Name | Data type | Description
incDec | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IncrementDecrement | Use the IncrementDecrement enumeration member Increment to get the next IV document number. Do not use the enumeration member Decrement in this version of eConnect.
docType | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IVDocType | Use an IVDocType enumeration member to specify the type of IV document number to return. IVDocType includes the following members: IVAdjustment IVVariance IVTransfer
connString | string | Specifies the SQL server and database.

Return Value

Type: string

This method returns a string that contains the inventory document number.

See Also

  • IncrementDecrement Enumeration
  • IVDocType Enumeration


GetNextPONumber Method

This method will retrieve the next purchase order document number from Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public virtual string GetNextPONumber(
    GetNextDocNumbers.IncrementDecrement incDec,
    string connString
)
Parameters

Name | Data type | Description
incDec | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IncrementDecrement | Use the IncrementDecrement enumeration member Increment to get the next PO document number. Do not use the enumeration member Decrement in this version of eConnect.
connString | string | Specifies the SQL server and database.

Return Value

Type: string

This method returns a string that contains the requested purchase order document number.

See Also

  • IncrementDecrement Enumeration


GetNextPOPReceiptNumber Method

This method will retrieve the next purchase order processing receipt document number from Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public virtual string GetNextPOPReceiptNumber(
    GetNextDocNumbers.IncrementDecrement incDec,
    string connString
)
Parameters

Name | Data type | Description
incDec | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IncrementDecrement | Use the IncrementDecrement enumeration member Increment to get the next POP receipt document number. Do not use the enumeration member Decrement in this version of eConnect.
connString | string | Specifies the SQL server and database.

Return Value

Type: string

This method returns a string that contains the requested purchase order processing receipt document number.

See Also

  • IncrementDecrement Enumeration


GetNextRMNumber Method

This method will retrieve the next document number for the specified type of Microsoft Dynamics GP receivables management document.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public virtual string GetNextRMNumber(
    GetNextDocNumbers.IncrementDecrement incDec,
    GetNextDocNumbers.RMPaymentTYpe docType,
    string connString
)
Parameters

Name | Data type | Description
incDec | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IncrementDecrement | Use the IncrementDecrement enumeration member Increment to get the next RM document number. Do not use the enumeration member Decrement in this version of eConnect.
docType | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.RMPaymentType | Use an RMPaymentType enumeration member to specify the type of RM document number to return. RMPaymentType includes the following members: RMInvoices RMScheduledPayments RMDebitMemos RMFinanceCharges RMServiceRepairs RMWarranty RMCreditMemo RMReturn RMPayments
connString | string | Specifies the SQL server and database.

Return Value

Type: string

This method returns a string that contains the requested receivables management document number.

See Also

  • IncrementDecrement Enumeration
  • RMPaymentType Enumeration


GetNextSOPNumber Method

This method will retrieve the next document number for the specified type of Microsoft Dynamics GP sales order processing document.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public virtual string GetNextSOPNumber(
    GetNextDocNumbers.IncrementDecrement incDec,
    string docIdKey,
    GetNextDocNumbers.SOPType docType,
    string connString
)
Parameters

Name | Data type | Description
incDec | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IncrementDecrement | Use the IncrementDecrement enumeration member Increment to get the next SOP document number. Use Decrement to return the DocIDKey parameter as an unused document number.
docIdKey | string | Specifies the document ID
docType | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.SopType | Use a SopType enumeration member to specify the type of SOP document number to return. SopType includes the following members: SOPQuote SOPOrder SOPInvoice SOPReturn SOPBackOrder.
connString | string | Specifies the SQL server and database.

Return Value

Type: string

This method returns a string that contains the requested SOP document number.

See Also

  • IncrementDecrement Enumeration
  • SopType Enumeration


GetPMNextVoucherNumber Method

This method will retrieve the next payables management voucher number from Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public virtual string GetPMNextVoucherNumber(
    GetNextDocNumbers.IncrementDecrement incDec,
    string connString
)
Parameters

Name | Data type | Description
incDec | Microsoft.Dynamics.GP. eConnect.GetNextDocNumbers.IncrementDecrement | Use the IncrementDecrement enumeration member Increment to get the next PM payment document number. Do not use the enumeration member Decrement in this version of eConnect.
connString | string | Specifies the SQL server and database.

Return Value

Type: string

This method returns a string that contains the requested payables management payment document number

See Also

  • IncrementDecrement Enumeration


RollBackDocumentList Method

This method allows you to restore a Microsoft Dynamics GP document number that was retrieved using one of the previous methods.

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public void RollBackDocumentList(
    System.Collections.ArrayList rollBackDocumentList,
    string connString
)

public void RollBackDocumentList(
    System.Collections.Generic.List<RollBackDocument> rollBackDocumentList,
    string connString
)
Parameters

Name | Data type | Description
rollBackDocumentList | ArrayList | A collection of one or more RollBackDocument objects. Each RollBackDocument object specifies a Microsoft Dynamics GP document number.
rollBackDocumentList | List<RollBackDocument> | A collection of one or more RollBackDocument objects. Each RollBackDocument object specifies a Microsoft Dynamics GP document number.
connString | string | Specifies the SQL server and database.

Return Value

Type: void

The method does not return a value

Remarks

The RollBackDocumentList method requires an arraylist of RollBackDocument objects that specify the document numbers. The arraylist allows you to restore a single document number or several document numbers.

See Also

  • RollBackDocument Class


SortAndRollBackDocumentList Method

This method sorts and rolls back a list of document numbers..

Class

Microsoft.Dynamics.GP.eConnect.GetNextDocNumbers

Syntax

public void SortAndRollBackDocumentList(
    System.Collections.Generic.List<RollBackDocument> rollBackDocumentList,
    string connectionString
)
Parameters

Name | Data type | Description
rollBackDocumentList | List<RollBackDocument> | A list of RollBackDocument objects.
connectionString | string | Specifies the SQL server and database.

Return Value

Type: void

The method does not return a value.

Remarks

The SortAndRollBackDocumentList method requires a list of RollBackDocument objects that specify document numbers. The GetRollBackDocumentList method of the DocumentRollback class produces a list of RollBackDocument objects.

See Also

  • GetRollBackDocumentList Method


GetSopNumber Class

The GetSopNumber class allows you to retrieve the next valid SOP number from Microsoft Dynamics GP. You can use the SOP number to create new sales documents. The class allows you to return numbers that you do not use.

Inherits from the System.EnterpriseServices.ServicedComponent class.

Constructor

Name | Description
GetSopNumber() | Initializes an instance of the GetSopNumber class.

Methods

Name | Return Value | Description
Dispose Method | void | Releases the resources of the GetSopNumber object.
GetNextSopNumber Method | string | Retrieves the next document number for a specified type of sales order document.
RollBackSopNumber Method | bool | Returns an unused sales document number.

Examples

The following Visual Basic .NET example creates a GetSopNumber object:

'Instantiate a GetSopNumber object
Dim SopNumberObject As New GetSopNumber


Dispose Method

Releases all resources used by the GetSopNumber class.

Class

Microsoft.Dynamics.GP.eConnect.GetSopNumber

Syntax

public void Dispose()
Return Value

Type: void

The method does not return a value.

Remarks

Use Dispose when you are finished using the GetSopNumber object. The Dispose method releases the resources of that object.

Always call Dispose before you release the last reference to the GetSopNumber object.


GetNextSopNumber Method

This method will retrieve the next sales document number from Microsoft Dynamics GP.

Class

Microsoft.Dynamics.GP.eConnect.GetSopNumber

Syntax

public string GetNextSopNumber(
    int sopTypeKey,
    string docIdKey,
    string connString
)
Parameters

Name | Data type | Description
sopTypeKey | integer | Specifies the type of the document: 1 = Quote 2 = Order 3 = Invoice 4 = Return 5 = Back order 6 = Fulfillment order
docIdKey | string | Specifies the document ID
connString | string | Specifies the SQL server and database

Return Value

Type: string

This method returns a string that contains the requested SOP number

Examples

The following Visual Basic .NET example uses the GetNextSopNumber method to retrieve a sales invoice number from Microsoft Dynamics GP:

Dim ConnectionString As String
Dim SopNumber As String

'Set the connection string
'This connection string uses integrated security to connect to the
'TWO database on the local computer
ConnectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;Initial Catalog=TWO;"

'Instantiate a GetSopNumber object
Dim SopNumberObject As New GetSopNumber

'Get the next SOP number
SopNumber = SopNumberObject.GetNextSopNumber(3, "STDINV", ConnectionString)

See Also

RollBackSopNumber Method


RollBackSopNumber Method

Use this method to return unused sales order numbers. This makes the numbers available for use with other Microsoft Dynamics GP SOP documents.

Class

Microsoft.Dynamics.GP.eConnect.GetSopNumber

Syntax

public bool RollBackSopNumber(
    string sopNumKey,
    int sopTypeKey,
    string docIdKey,
    string connString
)
Parameters

Name | Data type | Description
sopNumKey | string | Specifies the number to return to Microsoft Dynamics GP
sopTypeKey | string | Specifies the type of the document: 1 = Quote 2 = Order 3 = Invoice 4 = Return 5 = Back order 6 = Fulfillment order
docIdKey | string | Specifies the document ID
connString | string | Specifies the SQL server and database

Return Value

Type: bool

This method returns a boolean value that indicates whether the rollback request was successfully completed. A value of True indicates the rollback was successful.

Examples

The following segment of Visual Basic .NET code uses the RollBackSopNumber method to make an unused SOP number available in Microsoft Dynamics GP:

Dim ConnectionString As String
Dim SopNumber As String

'Set the connection string
'This connection string uses integrated security to connect to the
'TWO database on the local computer
ConnectionString = "Data Source=localhost;Integrated Security=SSPI;" _
    & "Persist Security Info=False;InitRoial Catalog=TWO;"

'Instantiate a GetSopNumber object
Dim SopNumberObject As New GetSopNumber

'Get the next sales invoice number
SopNumber = SopNumberObject.GetNextSopNumber(3, "STDINV", ConnectionString)

'Return the sales invoice number to Microsoft Dynamics GP
SopNumber = SopNumberObject.RollBackSopNumber(SopNumber, 3, "STDINV", _
    ConnectionString)

See Also

GetNextSopNumber Method


IncrementDecrement Enumeration

Specifies whether to increase or decrease a document number.

Members

Value | Description
Decrement | Decrease the value of the next document number
Increment | Increase the value of the next document number

Remarks

Used as a parameter for several methods. The methods use the value to specify whether to get or or return the next document number.

See Also

  • GetNextGLJournalEntryNumber Method
  • GetNextIVNumber Method
  • GetNextPONumber Method
  • GetNextPOPReceiptNumber Method
  • GetNextRMNumber Method
  • GetNextSOPNumber Method
  • GetPMNextVoucherNumber Method


IVDocType Enumeration

Specifies the type of an inventory document.

Members

Value | Description
IVAdjustment | Inventory adjustment
IVTransfer | Inventory transfer
IVVariance | Inventory variance

Remarks

Used as a parameter for the GetNextDocNumber.GetNextIVNumber method.

See Also

  • GetNextIVNumber Method


RMPaymentType Enumeration

Specifies the type of a receivables document.

Members

Value | Description
RMCreditMemo | Receivables credit memo
RMDebitMemos | Receivables debit memo
RMFinanceCharges | Receivable finance charge
RMInvoices | Receivables invoice
RMPayments | Receivables payment
RMReturn | Receivables return
RMScheduledPayments | Receivables scheduled payment
RMServiceRepairs | Receivables repair
RMWarranty | Receivables warranty

Remarks

Used as a parameter for the GetNextDocNumber.GetNextRMNumber method.

See Also

  • GetNextRMNumber Method


RollBackDocument Class

The RollBackDocument class allows you to create an object that associates a Microsoft Dynamics GP document with a document number.

Constructor

Name | Description
RollBackDocument(Microsoft.Dynamics.GP.eConnect.TransactionType transactionType, short? documentType, string documentID, string documentNumber) | Initializes an instance of the RollBackDocument class.
Microsoft.Dynamics.GP.eConnect.RollBackDocument.RollBackDocument(Microsoft.Dynamics.GP.eConnect.TransactionType transactionType, short? documentType, string documentNumber) | Initializes an instance of the RollBackDocument class.

Parameters

Name | Data type | Description
transactionType | Microsoft.Dynamics.GP. eConnect.TransactionType | Use a TransactionType enumeration member to specify the transaction type associated with the document number. TransactionType includes the following members: GL IVTrans IVTransfer PM POP POPReceipt RM SOP
documentType | Int16 | Specifies the document type associated with the document number. This parameter accepts a null value.
documentID | string | Specifies the document ID associated with the document number.
documentNumber | string | Specifies a Microsoft Dynamics GP document number.

Properties

Name | Type | Description
DocumentID | string | A read-only property that specifies the ID of the document.
DocumentNumber | string | A read-only property that specifies a Microsoft Dynamics GP document number.
DocumentTransactionType | TransactionType | A read-only property that specifies the transaction type.
DocumentType | short | A read-only property that specifies the type of the document.

Remarks

This class is typically used by the DocumentRollbackClass to create objects that store information about documents and document numbers. For example, the DocumentRollback.RollBackDocuments method returns an arraylist that contains RollbackDocument objects.

The RollBackDocument constructor enables you to associate a Microsoft Dynamics GP document with a document number. To retrieve document and document number information from and existing RollbackDocument object, use the read-only properties of that object.

See Also

DocumentRollback Class


SopType Enumeration

Specifies the type of a sales order document.

Members

Value | Description
SOPBackOrder | Sales back order
SOPInvoice | Sales invoice
SOPOrder | Sales order
SOPQuote | Sales quote
SOPReturn | Sales return

Remarks

Used as an input parameter for the GetNextDocNumber.GetNextSOPNumber method.

See Also

  • GetNextSOPNumber Method


TransactionType Enumeration

Specifies the type of an eConnect transaction.

Members

Value | Description
GL | General ledger
IVTrans | Inventory transaction
IVTransfer | Inventory transfer
PM | Payables management
POP | Purchase order
POPReceipt | Purchase order receipt
RM | Receivables management
SOP | Sales Order

Remarks

Used as an input parameter for the DocumentRollback.Add method and the RollBackDocument constructor. Also used in the DocumentTransactionType property of the RollBackDocument class.

See Also

  • Add Method
  • RollBackDocument Class


Microsoft.Dynamics.GP.eConnect.Serialization Namespace

This section of the documentation describes the classes contained in the Microsoft.Dynamics.GP.eConnect.Serialization namespace. You uses these classes to construct objects that represent eConnect documents. In eConnect, you use documents to create, update, retrieve, and delete or void Microsoft Dynamics GP data.

Each of the following classes correspond to an eConnect XML schema or node. For more information about a document or a field in the document, see the documentation for that eConnect XML schema or node.

If you have a detailed question about what nodes are used with a schema or what values to use with a field, see the XML reference documentation that is related to that class.

Assembly

Microsoft.Dynamics.GP.eConnect.Serialization.dll

Classes

The Microsoft.Dynamics.GP.eConnect.Serialization namespace includes the following classes

Class | Description
AATrxDimCodeMaintType Class | Specifies an analytical accounting dimension.
BRBankDepositsType Class | Represents a bank deposit.
BRBankTransactionType Class | Represents a bank transaction.
BRBankTransactionVoidType Class | Voids a bank transaction.
BRDeleteBankDepositsType Class | Deletes an bank deposit.
BRPostBankDepositsType Class | Specifies a bank deposit to post.
CMPCreateBankType Class | Specifies a bank record to create.
CMPCreateCountryType Class | Creates a country record.
CMPCreditCardType Class | Specifies a credit card.
CMPInternetAddressType Class | Specifies an internet address.
CMPShippingMethodType Class | Specifies a shipping method.
eConnectOut Class | Specifies the output parameters returned by an eConnect requester document..
eConnectProcessInfo Class | Specifies eConnect processing attributes for an eConnect document.
eConnectType Class | Specifies a collection of one or more eConnect documents.
FACreateAccountGroupType Class | Creates an account group.
FACreateAssetBookIDType Class | Creates an asset book entry.
FACreateAssetBookITCType Class | Creates an asset ITC entry.
FACreateAssetClassIDType Class | Creates an asset class ID.
FACreateAssetIDType Class | Creates an asset ID.
FACreateAssetInsuranceType Class | Creates an asset insurance entry.
FACreateAssetLeaseType Class | Creates an asset lease entry.
FACreateAssetPurchaseType Class | Create an asset purchase entry.
FACreateAssetUserDataType Class | Creates an asset user entry.
FACreateBookClassType Class | Creates an asset book class.
FACreateBookIDType Class | Creates an asset book ID.
FACreateInsuranceClassIDType Class | Creates an assent insurance class ID.
FACreateLeaseCompanyType Class | Creates a lease company type.
FACreateLocationIDType Class | Creates an asset location ID.
FACreatePhysicalLocationIDType Class | Creates an asset physical location ID.
FACreateRetirementCodeType Class | Creates an asset retirement code.
FACreateStructureType Class | Creates an asset structure.
FSEquipmentType Class | Specifies field service equipment entry.
FSRMAType Class | Specifies a field service return entry.
FSRTVType Class | Specifies a field service vendor return entry.
FSServiceCallType Class | Specifies a service call entry.
GLAccountType Class | Creates or updates a general ledger account.
GLCheckbookMasterType Class | Creates a checkbook.
GLCreateAccountCategoryType Class | Creates a general ledger account category.
GLCreateAccountCurrenciesType Class | Creates a currency type that is associated with general ledger accounts.
GLFixedAllocationAccountType Class | Creates or updates a general ledger fixed allocation account.
GLTransactionType Class | Specifies a general ledger transaction.
GLVariableAllocationAccountType Class | Creates or updates a general ledger variable allocation account.
HRApplicantEducationType Class | Creates or updates applicant education information.
HRApplicantInterviewType Class | Creates or update applicant interview information.
HRApplicantReferenceType Class | Creates or updates reference information for an applicant.
HRApplicantSkillType Class | Create or update job skill information for an applicant.
HRApplicantTestType Class | Creates or updates test information for an applicant.
HRApplicantType Class | Creates or updates applicant information.
HRApplicantWorkHistoryType Class | Creates or updates work history information for an applicant.
HRCreateSkillSetType Class | Creates skill set information.
HRCreateTestType Class | Creates test information.
HRDeleteApplicantApplicationType Class | Removes information for the specified applicant.
HRDeleteApplicantEducationLineType Class | Removes specified education line information for applicant.
HRDeleteApplicantEducationType Class | Removes education information for a specified applicant.
HRDeleteApplicantInterviewType Class | Removes interview information for a specified applicant.
HRDeleteApplicantReferenceLineType Class | Removes specified reference information for an applicant.
HRDeleteApplicantReferenceType Class | Removes reference information for the specified applicant.
HRDeleteApplicantRequisitionType Class | Removes requisition information for a specified applicant.
HRDeleteApplicantTestLineType Class | Removes specified test information for an applicant.
HRDeleteApplicantTestType Class | Removes test information for a specified applicant.
HRDeleteApplicantType Class | Removes the specified applicant.
HRDeleteApplicantWorkHistoryLineType Class | Removes specified work history information for an applicant.
HRDeleteApplicantWorkHistoryType Class | Removes work history information for the specified applicant.
HRDeleteRequisitonType Class | Removes the specified requisition.
HRDeleteSkillSetLineType Class | Removes the specified information from a skill set.
HRDeleteSkillSetType Class | Removes the specified skill set.
HRDeleteSkillType Class | Removes the specified job skill information.
HRDeleteTestType Class | Removes the specified test information.
HRRequisitionType Class | Create or updates a job requisition.
HRSkillType Class | Creates or updates job skill information.
IVCreateIVItemClassType Class | Creates an inventory item class.
IVCreateItemCurrencyType Class | Associates a currency with an inventory item.
IVCreateItemPriceListType Class | Creates a price list for an inventory item.
IVCreatePlannerType Class | Creates an inventory planner.
IVCreatePriceGroupType Class | Creates an inventory price group.
IVCreatePriceLevelType Class | Creates an inventory price level.
IVCreateSiteBinType Class | Creates an inventory bin.
IVCreateUOFMScheduleType Class | Creates a unit of measure schedule for an inventory item.
IVInventoryItemSiteType Class | Creates a site for inventory items.
IVInventorySiteType Class | Associates a site with an inventory item.
IVInventoryTransactionType Class | Specifies an inventory transaction.
IVInventoryTransferType Class | Specifies an inventory transfer.
IVItemMasterType Class | Specifies an inventory item.
IVLotCategoryType Class | Specifies an inventory lot category.
IVMultibinBinToBinTransferType Class | Specifies a transfer between inventory bins.
IVVendorItemType Class | Specifies an inventory item vendor.
LBCreateLockboxBankDetailsType Class | Associates a lockbox with a bank.
LBCreateLockboxType Class | Creates a lockbox.
PAAccountsSetupType Class | Creates a project account.
PAChangeOrderType Class | Specifies a project change order.
PAContractBillingCycleType Class | Specifies a project billing cycle.
PAContractsType Class | Specifies a project contract.
PAEmployeeExpenseType Class | Specifies expenses for a project employee.
PAEquipmentLogTransactionType Class | Specifies an equipment log transaction for a project.
PAMiscLogExpenseType Class | Specifies a miscellaneous log expense for a project.
PAProjectAccessListType Class | Specifies a project access list.
PAProjectBillingCyclesType Class | Specifies the billing cycle for a project.
PAProjectBudgetMasterType Class | Specifies the project budget.
PAProjectEquipmentListType Class | Specifies the equipment list for a project.
PAProjectFeesType Class | Specifies the fees for a project.
PAProjectsType Class | Specifies a project.
PATimeSheetsType Class | Specifies a times sheet for a project.
PMCreateBuyerType Class | Creates a buyer.
PMDeleteVendorAddressType Class | Removes the specified vendor address information.
PMManualCheckType Class | Creates a manual check for a payment.
PMScheduledPaymentsType Class | Specifies a payment schedules.
PMTransactionType Class | Specifies a payment transaction.
PMVendorAddressType Class | Specifies the address of a vendor.
PMVendorMasterType Class | Specifies a vendor.
POPDocumentDeleteType Class | Removes an existing purchase order.
POPDocumentVoidType Class | Voids an existing purchase order
POPEnterMatchInvoiceType Class | Specifies a purchase order invoice.
POPMapSitesType Class | Specifies a site.
POPReceivingsType Class | Specifies a purchase order receipt.
POPTransactionType Class | Specifies a purchase order transaction.
POPtoSOPLinkRemoveType Class | Removes the POP to SOP link.
RMApplyType Class | Applies credit memos, returns, and cash receipts to invoices.
RMCashReceiptsType Class | Specifies a cash receipt.
RMCreateCustomerItemsType Class | Associates an inventory item with a customer.
RMCreateParentIDType Class | Creates a parent record for a national account.
RMCustomerAddressType Class | Creates or updates a customer address record.
RMCustomerClassType Class | Specifies a customer class.
RMCustomerMasterType Class | Specifies a customer.
RMDeleteCustomerAddressType Class | Removes a customer address record.
RMDeleteCustomerType Class | Removes a customer record.
RMDeleteSalespersonType Class | Removes a salesperson record.
RMParentIDChildType Class | Specifies a child member of a national account.
RMProspectMasterType Class | Specifies a sales prospect.
RMSalespersonMasterType Class | Creates or updates a salesperson.
RMScheduledPaymentsType Class | Specifies a receivables payment schedule.
RMTerritoryMasterType Class | Creates a sales territory record.
RMTransactionType Class | Specifies a receivables transaction.
RMUnapplyTransactionType Class | Reverses a receivables transaction.
RMVoidTransactionType Class | Voids a receivables transaction.
RQeConnectOutType Class | Specifies the data records to retrieve using the eConnect Transaction Requester.
SMMdaType Class | Updates a MDA document.
SMTransactionBatchType Class | Creates a batch.
SOPDeleteDocumentType Class | Removes a sales order.
SOPDeleteLineType Class | Removes a sales line from a sales document.
SOPDistributionsType Class | Specifies a sales order distribution
SOPLineComponentType Class | Creates or updates the components of a sales line.
SOPProcessHoldMasterType Class | Creates or updates a sales process hold.
SOPProcessHoldType Class | Creates or updates a sales process hold.
SOPSerialType Class | Creates or updates a serial sales order.
SOPTransactionType Class | Specifies a sales order.
SOPVoidDocumentType Class | Voids a sales order.
SOPtoPOPTransactionType Class | Uses a sales order document to create a purchase order.
taAATrxDimCodeMaint Class | Specifies an analytical accounting transaction dimension code.
taAnalyticsDistribution_ItemsTaAnalyticsDistribution Class | Specifies an analytical accounting distribution.
taApplicantInterviewUpdate_ItemsTaApplicantInterviewUpdate Class | Updates interview information for a specified applicant.
taBRBankDepositsHeader Class | Specifies a bank deposit header.
taBRBankDepositsLine_ItemsTaBRBankDepositsLine Class | Creates a bank deposit line.
taBRBankTransactionDist_ItemsTaBRBankTransactionDist Class | Specifies a bank transaction distribution.
taBRBankTransactionHeader Class | Specifies a bank transaction header.
taBRBankTransactionVoid Class | Voids a bank transaction.
taBRDeleteBankDeposits Class | Deletes a bank deposit.
taBRPostBankDeposits Class | Posts a bank deposit.
taCreateAccountCategory Class | Creates a general ledger account category.
taCreateAccountCurrencies Class | Creates a general ledger account currency.
taCreateAccountGroup Class | Creates a fixed asset account group.
taCreateApplicant Class | Creates applicant information.
taCreateApplicantEducation Class | Creates education information for a specified applicant.
taCreateApplicantInterviewInsert Class | Creates interview information for a specified applicant.
taCreateApplicantReferences Class | Creates reference information for a specified applicant.
taCreateApplicantSkills Class | Creates job skill information for a specified applicant.
taCreateApplicantTests Class | Creates test information for a specified applicant.
taCreateApplicantWorkHistory Class | Create work history information for a specified applicant.
taCreateAssetBook Class | Creates a fixed asset book record.
taCreateAssetBookITC Class | Creates a fixed asset ITC record.
taCreateAssetClassID Class | Creates a fixed asset class ID.
taCreateAssetID Class | Creates an asset ID.
taCreateAssetInsurance Class | Creates asset insurance.
taCreateAssetLease Class | Creates an asset lease.
taCreateAssetPurchase Class | Creates an asset purchase.
taCreateAssetUserData Class | Creates asset user information.
taCreateBank Class | Creates a bank ID.
taCreateBenefit Class | Creates a payroll benefit.
taCreateBenefitBasedOnPayDedCodes_ItemsTaCreateBenefitBasedOnPayDedCodes Class | Creates a payroll deduction based on a pay code.
taCreateBookClass Class | Creates a fixed asset book class ID.
taCreateBookID Class | Creates a fixed asset book ID.
taCreateBuyer Class | Creates a buyer.
taCreateCheckbook Class | Creates a checkbook.
taCreateComputerCheckLineInsert_ItemsTaCreateComputerCheckLineInsert Class | Creates a payroll computer check line.
taCreateCreditCard Class | Creates a credit card.
taCreateCustomerAddress_ItemsTaCreateCustomerAddress Class | Creates a customer address.
taCreateCustomerClass Class | Creates a customer class.
taCreateCustomerItems_ItemsTaCreateCustomerItems Class | Associates a customer with an item.
taCreateDeduction Class | Creates a payroll deduction.
taCreateDeductionBasedOnPayCodes_ItemsTaCreateDeductionBasedOnPayCodes Class | Creates a payroll deduction based on a pay code.
taCreateDepartment Class | Creates a payroll department.
taCreateEmployee Class | Creates or updates an employee.
taCreateEmployeeAddress Class | Create or updates an employee address
taCreateEmployeeBenefit Class | Creates an employee benefit.
taCreateEmployeeBenefitBasedOnPayDedCodes_ItemsTaCreateEmployeeBenefitBasedOnPayDedCodes Class | Creates an employee benefit based on payroll deduction/pay codes.
taCreateEmployeeClass Class | Creates an employee class.
taCreateEmployeeDeduction Class | Creates an employee payroll deduction.
taCreateEmployeeDeductionBasedOnPayCodes_ItemsTaCreateEmployeeDeductionBasedOnPayCodes Class | Creates an employee payroll deduction based a pay code.
taCreateEmployeeLocalTax Class | Creates an employee payroll local tax.
taCreateEmployeePayCode Class | Create payroll employee pay codes.
taCreateEmployeeStateTax Class | Create payroll state tax.
taCreateEmployeeTax Class | Create employee taxes.
taCreateFixedAllocationAccountRcd_ItemsTaCreateFixedAllocationAccountRcd Class | Creates or updates a general ledger fixed allocation account.
taCreateIVItemClass Class | Creates an inventory item class.
taCreateInsuranceClassID Class | Creates a fixed asset insurance class ID.
taCreateInternetAddresses_ItemsTaCreateInternetAddresses Class | Creates an internet address.
taCreateInventorySite Class | Creates an inventory site.
taCreateItemVendors_ItemsTaCreateItemVendors Class | Creates an inventory item vendor.
taCreateKitItemRcd_ItemsTaCreateKitItemRcd Class | Creates an inventory kit item.
taCreateLeaseCompany Class | Creates a fixed asset lease company.
taCreateLocalTax Class | Create payroll local tax.
taCreateLocalTaxDetail_ItemsTaCreateLocalTaxDetail Class | Create payroll local tax detail information.
taCreateLocation Class | Create a payroll location.
taCreateLocationID Class | Creates a fixed asset location ID.
taCreateLockbox Class | Creates a lockbox.
taCreateLockboxBankDetails Class | Creates lockbox bank details.
taCreateLotCategory Class | Creates an inventory lot category.
taCreateManualCheckHeaderInsert Class | Creates a payroll manual check header.
taCreateManualCheckLineInsert_ItemsTaCreateManualCheckLineInsert Class | Creates a payroll manual check line.
taCreateParentID Class | Creates a parent ID for a national account.
taCreatePayCode Class | Creates a payroll pay code.
taCreatePayrollBatchHeaderInsert Class | Creates a payroll batch header.
taCreatePhysicalLocationID Class | Creates a fixed asset physical location ID.
taCreatePlanner Class | Creates an inventory planner.
taCreatePosition Class | Creates a payroll position code.
taCreateProcessHold Class | Creates a process hold.
taCreateProspect Class | Creates a prospect ID.
taCreateRequisitions Class | Creates a job requisition.
taCreateRetirementCode Class | Creates a fixed asset retirement code.
taCreateSalesperson Class | Creates a salesperson.
taCreateShiftCode Class | Creates a payroll shift code.
taCreateShippingMethod Class | Creates a shipping method.
taCreateSiteBin Class | Creates an inventory bin.
taCreateSkills Class | Creates a job skill.
taCreateSkillSets Class | Creates a job skill set.
taCreateSkillSetsLIne_ItemsTaCreateSkillSetsLine Class | Creates a collection of skills that are associated with a skill set.
taCreateSOPTrackingInfo Class | Creates tracking information for a sales order.
taCreateSopPaymentInsertRecord_ItemsTaCreateSopPaymentInsertRecord Class | Creates a sales order payment.
taCreateStructure Class | Creates a fixed asset structure ID.
taCreateSupervisor Class | Creates a supervisor.
taCreateTerritory Class | Creates a sales territory ID.
taCreateTests Class | Create test information.
taCreateUpdateBatchHeaderRcd Class | Creates or updates a batch header.
taCreateVariableAllocationAccountRcd_ItemsTaCreateVariableAllocationAccountRcd Class | Creates or updates a general ledger variable allocation account.
taCreateVendorAddress_ItemsTaCreateVendorAddress Class | Creates a vendor address.
taCreateWorkersCompensationCode Class | Creates a workers compensation code.
taDeleteApplicant Class | Removes a specified applicant.
taDeleteApplicantApplication Class | Removes application information for a specified applicant.
taDeleteApplicantEducation Class | Removes education information for a specified applicant.
taDeleteApplicantEducationLine Class | Removes specified education information for an applicant.
taDeleteApplicantInterview Class | Removes Interview information for a specified applicant.
taDeleteApplicantReferences Class | Removes reference information for a specified applicant.
taDeleteApplicantReferencesLine Class | Removes the specified reference information for an applicant.
taDeleteApplicantRequisitionsLine Class | Removes the specified requisition information for an applicant.
taDeleteApplicantTests Class | Removes test information for the specified applicant.
taDeleteApplicantTestsLine Class | Removes specified test information for an applicant.
taDeleteApplicantWorkHistory Class | Removes work history information for a specified applicant.
taDeleteApplicantWorkHistoryLine Class | Removes specified work history information for an applicant.
taDeleteCustomerAddress Class | Removes a specified customer address.
taDeleteCustomerRcd Class | Removes a specified customer.
taDeleteEmployee Class | Removes an employee from payroll.
taDeleteEmployeeAddress Class | Removes address information for an employee.
taDeleteEmployeePayCode Class | Removes pay code information for an employee.
taDeleteRequisition Class | Removes a job requisition.
taDeleteSalespersonRcd Class | Removes a specified salesperson.
taDeleteSkills Class | Removes job skill information.
taDeleteSkillSetsLine Class | Removes the specified skill information from a skill set.
taDeleteSkillsSets Class | Removes a skill set.
taDeleteTests Class | Removes test information.
taDeleteVendorAddress Class | Removes address information for a vendor.
taFSEquipmentMaster Class | Specifies a field service equipment record.
taFSEquipmentReading_ItemsTaFSEquipmentReading Class | Specifies a field service equipment reading record.
taFSRMALineSerial_ItemsTaFSRMALineSerial Class | Specifies a field service RMA line serial number.
taFSRMALine_ItemsTaFSRMALine Class | Creates or updates a field service RMA line.
taFSRMAMaster Class | Specifies a field service RMA record.
taFSRTVLineSerial_ItemsTaFSRTVLineSerial Class | Specifies a field service RTV line serial number.
taFSRTVLine_ItemsTaFSRTVLine Class | Creates or updates a field service RTV line.
taFSRTVMaster Class | Specifies a field service RTV record.
taFSServiceCallCodesEquipment_ItemsTaFSServiceCallCodesEquipment Class | Specifies a field service call analysis code.
taFSServiceCallLineSerial_ItemsTaFSServiceCallLineSerial Class | Specifies a field service call line serial number.
taFSServiceCallLine_ItemsTaFSServiceCallLine Class | Creates or updates a field service call line.
taFSServiceCallMaster Class | Specifies a field service call.
taFSServiceCallMultiTech Class | Specifies a multitech service call.
taGLTransactionHeaderInsert Class | Specifies a general ledger transaction header.
taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert Class | Specifies a general ledger transaction line.
taItemSite_ItemsTaItemSite Class | Creates or updates an inventory item site.
taIVCreateItemPriceListHeader Class | Creates or updates an inventory item price list header.
taIVCreateItemPriceListLine_ItemsTaIVCreateItemPriceListLine Class | Creates or updates an inventory item price list line.
taIVCreatePriceGroup Class | Create an inventory price group.
taIVCreatePriceLevel Class | Creates an inventory price level.
taIVCreateUOFMScheduleHeader Class | Creates an inventory unit of measure schedule header.
taIVCreateUOFMScheduleLine_ItemsTaIVCreateUOFMScheduleLine Class | Creates an inventory unit of measure schedule line.
taIVMultibinBinToBinTransfer Class | Specifies an inventory bin to bin transfer.
taIVTransactionHeaderInsert Class | Creates an inventory transaction header.
taIVTransactionLineInsert_ItemsTaIVTransactionLineInsert Class | Creates an inventory transaction line.
taIVTransactionLotInsert_ItemsTaIVTransactionLotInsert Class | Creates an inventory lot line.
taIVTransactionMultiBinInsert_ItemsTaIVTransactionMultiBinInsert Class | Creates an inventory multibin transaction.
taIVTransactionSerialInsert_ItemsTaIVTransactionSerialInsert Class | Creates an inventory serial line.
taIVTransferHeaderInsert Class | Creates an inventory transfer header.
taIVTransferLineInsert_ItemsTaIVTransferLineInsert Class | Creates an inventory transfer line.
taIVTransferLotInsert_ItemsTaIVTransferLotInsert Class | Creates an inventory transfer lot.
taIVTransferMultiBinInsert_ItemsTaIVTransferMultiBinInsert Class | Creates an inventory multibin transfer.
taIVTransferSerialInsert_ItemsTaIVTransferSerialInsert Class | Creates an inventory transfer serial line.
taMdaUpdate_ItemsTaMdaUpdate Class | Specifies a MDA update.
taPAAccountsSetup_ItemsTaPAAccountsSetup Class | Creates a project account.
taPAChangeOrderEntryBudget_ItemsTaPAChangeOrderEntryBudget Class | Specifies a project budget change order.
taPAChangeOrderEntryFeeDetail_ItemsTaPAChangeOrderEntryFeeDetail Class | Specifies project change order fee details.
taPAChangeOrderEntryFeeHeader_ItemsTaPAChangeOrderEntryFeeHeader Class | Specifies a project change order fee header.
taPAChangeOrderEntryFeeSchedule_ItemsTaPAChangeOrderEntryFeeSchedule Class | Specifies a project change order fee schedule.
taPAChangeOrderEntryHdr Class | Specifies a project change order header.
taPAContractBillingCycle_ItemsTaPAContractBillingCycle Class | Specifies a project contract billing cycle.
taPAContracts Class | Creates a project contract.
taPAEmpExpenseHdrInsert Class | Creates a project employee expense header.
taPAEmpExpenseLineInsert_ItemsTaPAEmpExpenseLineInsert Class | Creates a project employee expense line.
taPAEmpExpenseTaxInsert_ItemsTaPAEmpExpenseTaxInsert Class | Creates a project employee expense tax line.
taPAEquipLogHdrInsert Class | Creates a project equipment log header.
taPAEquipLogLineInsert_ItemsTaPAEquipLogLineInsert Class | Creates a project equipment log line.
taPAMiscLogHdrInsert Class | Creates a project miscellaneous log header.
taPAMiscLogLineInsert_ItemsTaPAMiscLogLineInsert Class | Creates a project miscellaneous log line.
taPAProjectAccess_ItemsTaPAProjectAccess Class | Creates or updates project access information.
taPAProjectBillingCycle_ItemsTaPAProjectBillingCycle Class | Creates a project billing cycle.
taPAProjectBudgetMaster_ItemsTaPAProjectBudgetMaster Class | Specifies a project budget.
taPAProjectEquip_ItemsTaPAProjectEquip Class | Specifies a project equipment list.
taPAProjectFeeSchedule_ItemsTaPAProjectFeeSchedule Class | Specifies a project fee schedule.
taPAProjectFee_ItemsTaPAProjectFee Class | Specifies a project fee.
taPAProjects_ItemsTaPAProjects Class | Specifies a project.
taParentIDChild_ItemsTaParentIDChild Class | Associates a child account with a parent national account
taPATimeSheetHdrInsert Class | Creates a project time sheet header.
taPATimeSheetLineInsert_ItemsTaPATimeSheetLineInsert Class | Creates a project time sheet line.
taPMDistribution_ItemsTaPMDistribution Class | Creates a payables distribution.
taPMManualCheck Class | Creates a payables manual check.
taPMSchedPmnts Class | Specifies a payables payment schedule.
taPMTransactionInsert Class | Specifies a payables transaction.
taPMTransactionTaxInsert_ItemsTaPMTransactionTaxInsert Class | Creates payables tax information.
taPoHdr Class | Specifies a purchase order header.
taPoLine_ItemsTaPoLine Class | Specifies a purchase order line.
taPopDistribution_ItemsTaPopDistribution Class | Creates a purchase order distribution.
taPopEnterMatchInvHdr Class | Creates or updates a purchase order invoice header.
taPopEnterMatchInvLine_ItemsTaPopEnterMatchInvLine Class | Creates or updates a purchase order invoice line.
taPopEnterMatchInvToShpMultiLine_ItemsTaPopEnterMatchInvToShpMultiLine Class | Creates or updates a purchase order invoice multiple shipment line.
taPopEnterMatchLotInsert_ItemsTaPopEnterMatchLotInsert | Create or updates purchase order lot lines.
taPopEnterMatchSerialInsert_ItemsTaPopEnterMatchSerialInsert | Create or update purchase order serial lines.
taPopIvcTaxInsert_ItemsTaPopIvcTaxInsert Class | Creates a purchase order tax line.
taPOPMapSites Class | Creates a purchase order site.
taPopPoDelete Class | Removes a specified purchase order.
taPopPoVoid Class | Voids a specified purchase order.
taPopRcptHdrInsert Class | Creates a purchase order receipt header.
taPopRcptLineInsert_ItemsTaPopRcptLineInsert Class | Creates a purchase order receipt line.
taPopRcptLineTaxInsert_ItemsTaPopRcptLineTaxInsert Class | Creates a purchase order receipt tax line.
taPopRcptLotInsert_ItemsTaPopRcptLotInsert Class | Creates a purchase order receipt lot line.
taPopRcptMultiBin_ItemsTaPopRcptMultiBin Class | Specifies a purchase order multibin receivings.
taPopRcptSerialInsert_ItemsTaPopRcptSerialInsert Class | Creates a purchase order receipt serial line.
taPopRctUserDefined Class | Creates a user defined purchase order receipt.
taPopRemoveSopLink Class | Removes specified POP to SOP link.
taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler Class | Specifies requester services to disable
taRMApply Class | Specifies a receivables apply.
taRMCashReceiptInsert Class | Specifies a cash receipt.
taRMCommissions_ItemsTaRMCommissions Class | Creates a sales commission.
taRMDistribution_ItemsTaRMDistribution Class | Creates a receivables distribution.
taRMSchedPmnts Class | Creates a receivables payment schedule.
taRMTransaction Class | Specifies a receivables transaction.
taRMTransactionTaxInsert_ItemsTaRMTransactionTaxInsert Class | Creates tax information for a receivables transaction.
taRMUnapplyTransaction Class | Unapplies a receivables transaction.
taRMVoidTransaction Class | Void a receivables transaction.
taSopCommissions_ItemsTaSopCommissions Class | Creates a sales order commission.
taSopDeleteDocument Class | Removes a sales document.
taSopDistribution_ItemsTaSopDistribution Class | Creates a sales order distribution.
taSopHdrIvcInsert Class | Creates a sales invoice header.
taSopLineDelete Class | Removes a sales invoice line.
taSopLineIvcInsert_ItemsTaSopLineIvcInsert Class | Creates a sales invoice line.
taSopLineIvcInsertComponent_ItemsTaSopLineIvcInsertComponent Class | Specifies a component for a sales invoice line.
taSopLineIvcTaxInsert_ItemsTaSopLineIvcTaxInsert Class | Specifies tax information for a sales invoice line.
taSopLotAuto_ItemsTaSopLotAuto Class | Specifies a sales lot.
taSopMultiBin_ItemsTaSopMultiBin Class | Specifies a multibin sales order.
taSopSerial_ItemsTaSopSerial Class | Specifies the serial number of line from a sales document.
taSopToPopLink Class | Specifies a SOP to POP link.
taSopTrackingNum_ItemsTaSopTrackingNum Class | Creates a sales order tracking number.
taSopUpdateCreateProcessHold Class | Creates a sales order process hold.
taSopUserDefined Class | Creates a user defined sales order document.
taSopVoidDocument Class | Voids a specified sales order document.
taUpdateCreateAccountRcd Class | Creates or updates a general ledger account.
taUpdateCreateCountryCode Class | Create or update a country code.
taUpdateCreateCustomerRcd Class | Creates or updates a customer.
taUpdateCreateItemCurrencyRcd_ItemsTaUpdateCreateItemCurrencyRcd Class | Creates or updates the association between and an inventory item and a currency.
taUpdateCreateItemRcd Class | Creates or updates an inventory item.
taUpdateCreatePAVendorRcd Class | Creates or update a project vendor.
taUpdateCreateVendorRcd Class | Creates or updates a vendor.
UPRComputerTrxType Class | Specifies a payroll transaction.
UPRCreateBenefitType Class | Creates a payroll benefit.
UPRCreateDeductionType Class | Creates a payroll deduction.
UPRCreateDepartmentType Class | Creates a payroll department.
UPRCreateEmployeeAddressType Class | Creates an employee address.
UPRCreateEmployeeBenefitType Class | Creates a payroll benefit for an employee.
UPRCreateEmployeeClassType Class | Creates an employee class.
UPRCreateEmployeeDeductionType Class | Creates a deduction for an employee.
UPRCreateEmployeeLocalTaxType Class | Associates a local tax with an employee.
UPRCreateEmployeePayCodeType Class | Creates an employee pay code.
UPRCreateEmployeeStateTaxType Class | Associates a state tax with an employee.
UPRCreateEmployeeTaxType Class | Creates an employee tax record.
UPRCreateEmployeeType Class | Creates an employee.
UPRCreateLocalTaxType Class | Creates a local tax record.
UPRCreateLocationType Class | Creates a payroll location.
UPRCreatePayCodeType Class | Creates a payroll pay code.
UPRCreatePositionType Class | Creates a payroll position.
UPRCreateShiftCodeType Class | Creates a payroll shift code.
UPRCreateSupervisorType Class | Create a supervisor record.
UPRCreateWorker_CompensationCodeType Class | Creates a worker compensation code.
UPRDeleteEmployeeAddressType Class | Removes address information for the specified employee.
UPRDeleteEmployeePayCodeType Class | Removes pay code information for the specified employee.
UPRDeleteEmployeeType Class | Removes an employee.
UPRManualTrxType Class | Specifies a payroll transaction.


AATrxDimCodeMaintType Class

A class that represents the eConnect transaction type you use to specify an analytical accounting dimension.

Constructor

Name | Description
AATrxDimCodeMaintType() | Initializes an instance of the AATrxDimCodeMaintType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAATrxDimCodeMaint | taAATrxDimCodeMaint | A node that specifies an analytical accounting transaction dimension code.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

AATrxDimCodeMaintType


BRBankDepositsType Class

A class that represents the eConnect transaction type you use to specify a bank deposit.

Constructor

Name | Description
BRBankDepositsType() | Initializes an instance of the BRBankDepositsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taBRBankDepositsHeader | taBRBankDepositsHeader | A node that specifies a bank depoost header.
taBRBankDepositsLine_Items | taBRBankDepositsLine_ItemsTaBRBankDepositsLine[] | A collection of nodes that create one or more bank deposit lines.
taBRPostBankDeposits | taBRPostBankDeposits | A node that posts a bank deposit.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

BRBankDepositsType


BRBankTransactionType Class

A class that represents the eConnect transaction type you use to specify a bank transaction.

Constructor

Name | Description
BRBankTransactionType() | Initializes an instance of the BRBankTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taBRBankTransactionDist_Items | taBRBankTransactionDist_ItemsTaBRBankTransactionDist[] | A collection of nodes that specify one or more a bank transaction distributions.
taBRBankTransactionHeader | taBRBankTransactionHeader | A node that specifies a bank transaction header.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

BRBankTransactionType


BRBankTransactionVoidType Class

A class that represents the eConnect transaction type you use to void a bank transaction.

Constructor

Name | Description
BRBankTransactionVoidType() | Initializes an instance of the BRBankTransactionVoidType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taBRBankTransactionDist_Items | taBRBankTransactionDist_ItemsTaBRBankTransactionDist[] | A collection of nodes that specify one or more bank transaction distributions.
taBRBankTransactionVoid | taBRBankTransactionVoid | A node that voids a bank transaction.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

BRBankTransactionVoidType


BRDeleteBankDepositsType Class

A class that represents the eConnect transaction type you use to delete a bank deposit.

Constructor

Name | Description
BRDeleteBankDepositsType() | Initializes an instance of the BRDeleteBankDepositsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taBRDeleteBankDeposits | taBRDeleteBankDeposits | A node that deletes a bank deposit.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

BRDeleteBankDepositsType


BRPostBankDepositsType Class

A class that represents the eConnect transaction type you use to post a bank deposit.

Constructor

Name | Description
BRPostBankDepositsType() | Initializes an instance of the BRPostBankDepositsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taBRPostBankDeposits | taBRPostBankDeposits | A node that posts a bank deposit.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

BRPostBankDepositsType


CMPCreateBankType Class

A class that represents the eConnect transaction type you use to create a bank record.

Constructor

Name | Description
CMPCreateBankType() | Initializes an instance of the CMPCreateBankType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateBank | taCreateBank | A node that creates a bank ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

CMPCreateBankType


CMPCreateCountryType Class

A class that represents the eConnect transaction type you use to create a country.

Constructor

Name | Description
CMPCreateCountryType() | Initializes an instance of the CMPCreateCountryType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateCountryCode | taUpdateCreateCountryCode | A node that create or update a country code.

See Also

CMPCreateCountryType


CMPCreditCardType Class

A class that represents the eConnect transaction type you use to specify a credit card.

Constructor

Name | Description
CMPCreditCardType() | Initializes an instance of the CMPCreditCardType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateCreditCard | taCreateCreditCard | A node that creates a credit card.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

CMPCreditCardType


CMPInternetAddressType Class

A class that represents the eConnect transaction type you use to specify an internet address.

Constructor

Name | Description
CMPInternetAddressType() | Initializes an instance of the CMPInternetAddressType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

CMPInternetAddressType


CMPShippingMethodType Class

A class that represents the eConnect transaction type you use to specify a shipping method.

Constructor

Name | Description
CMPShippingMethodType() | Initializes an instance of the CMPShippingMethodType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateShippingMethod | taCreateShippingMethod | A node that creates a shipping method.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

eConnect schema


eConnectOut Class

Constructor

A class that represents the node you use to specify the data to retrieve using a specified eConnect Transaction Requester document type..

Name | Description
eConnectOut() | Initializes an instance of the eConnectOut class.

Properties

Name | Type | Description
ACTION | int32 | Type of data to return
DATE1 | string | Delete specified records from the eConnect_Out shadow table
DOCTYPE | string | Document type
FORLIST | int32 | Specifies whether to populate the eConnect_Out shadow table
FORLOAD | int32 | Use the eConnect_Out shadow table
INDEX10FROM | string | Used for selection criteria
INDEX10TO | string | Used for selection criteria
INDEX11FROM | string | Used for selection criteria
INDEX11TO | string | Used for selection criteria
INDEX12FROM | string | Used for selection criteria
INDEX12TO | string | Used for selection criteria
INDEX13FROM | string | Used for selection criteria
INDEX13TO | string | Used for selection criteria
INDEX14FROM | string | Used for selection criteria
INDEX14TO | string | Used for selection criteria
INDEX15FROM | string | Used for selection criteria
INDEX15TO | string | Used for selection criteria
INDEX1FROM | string | Used for selection criteria
INDEX1TO | string | Used for selection criteria
INDEX2FROM | string | Used for selection criteria
INDEX2TO | string | Used for selection criteria
INDEX3FROM | string | Used for selection criteria
INDEX3TO | string | Used for selection criteria
INDEX4FROM | string | Used for selection criteria
INDEX4TO | string | Used for selection criteria
INDEX5FROM | string | Used for selection criteria
INDEX5TO | string | Used for selection criteria
INDEX6FROM | string | Used for selection criteria
INDEX6TO | string | Used for selection criteria
INDEX7FROM | string | Used for selection criteria
INDEX7TO | string | Used for selection criteria
INDEX8FROM | string | Used for selection criteria
INDEX8TO | string | Used for selection criteria
INDEX9FROM | string | Used for selection criteria
INDEX9TO | string | Used for selection criteria
OUTPUTTYPE | int32 | Specify return document type
REMOVE | int32 | Remove information from the eConnect_Out shadow table
ROWCOUNT | int32 | Specify maximum number of rows
WhereClause | string | Specify the query to use

See Also

<eConnectOut>


eConnectProcessInfo Class

A class that represent the node you use to specify the eConnect processing attributes associated with an eConnect document.

Constructor

Name | Description
eConnectProcessInfo() | Initializes an instance of the eConnectProcessInfo class.

Properties

Name | Type | Description
ConnectionString | string | Specify an eConnect connection string
ProcTimeOut | string | Specifies a time out value to use with the operation

See Also

<eConnectProcessInfo>


eConnectType Class

The class that represents the root of an eConnect document. To create an eConnect transaction, add one or more of the following transaction type classes to the specified field of the eConnectType document object.

Constructor

Name | Description
eConnectType() | Initializes an instance of the eConnectType class.

Properties

Name | Type | Description
AATrxDimCodeMaintType | AATrxDimCodeMaintType[] | A collection of one or more analytical account dimension documents.
BRBankDepositsType | BRBankDepositsType[] | A collection of one or more bank deposit documents.
BRBankTransactionType | BRBankTransactionType[] | A collection of one or more bank transaction documents.
BRBankTransactionVoidType | BRBankTransactionVoidType[] | A collection of one or more bank transaction void documents.
BRDeleteBankDepositsType | BRDeleteBankDepositsType[] | A collection of one or more bank deposit documents.
BRPostBankDepositsType | BRPostBankDepositsType[] | A collection of one or more bank deposit posting documents.
CMPCreateBankType | CMPCreateBankType[] | A collection of one or more documents that create a bank.
CMPCreateCountryType | CMPCreateCountryType[] | A collection of one or more documents that create a country.
CMPCreditCardType | CMPCreditCardType[] | A collection of one or more credit card documents.
CMPInternetAddressType | CMPInternetAddressType[] | A collection of one or more internet address documents.
CMPShippingMethodType | CMPShippingMethodType[] | A collection of one or more shipping method documents.
FACreateAccountGroupType | FACreateAccountGroupType[] | A collection of one or more documents that create account groups.
FACreateAssetBookITCType | FACreateAssetBookITCType[] | A collection of one or more documents that create asset book ITC.
FACreateAssetBookType | FACreateAssetBookType[] | A collection of one or more documents that create asset books.
FACreateAssetClassIDType | FACreateAssetClassIDType[] | A collection of one or more documents that create asset classes.
FACreateAssetIDType | FACreateAssetIDType[] | A collection of one or more documents that create asset IDs.
FACreateAssetInsuranceType | FACreateAssetInsuranceType[] | A collection of one or more documents that create asset insurance.
FACreateAssetLeaseType | FACreateAssetLeaseType[] | A collection of one or more documents that create asset leases.
FACreateAssetPurchaseType | FACreateAssetPurchaseType[] | A collection of one or more documents that create asset purchases.
FACreateAssetUserDataType | FACreateAssetUserDataType[] | A collection of one or more documents that create user data.
FACreateBookClassType | FACreateBookClassType[] | A collection of one or more documents that create book classes.
FACreateBookIDType | FACreateBookIDType[] | A collection of one or more documents that create book IDs.
FACreateInsuranceClassIDType | FACreateInsuranceClassIDType[] | A collection of one or more documents that create insurance class IDs.
FACreateLeaseCompanyType | FACreateLeaseCompanyType[] | A collection of one or more documents that create asset leases.
FACreateLocationIDType | FACreateLocationIDType[] | A collection of one or more documents that create location IDs.
FACreatePhysicalLocationIDType | FACreatePhysicalLocationIDType[] | A collection of one or more documents that create physical location IDs.
FACreateRetirementCodeType | FACreateRetirementCodeType[] | A collection of one or more documents that create retirement codes.
FACreateStructureType | FACreateStructureType[] | A collection of one or more documents that create structure types.
FSEquipmentType | FSEquipmentType[] | A collection of one or more equipment documents.
FSRMAType | FSRMAType[] | A collection of one or more RMA documents.
FSRTVType | FSRTVType[] | A collection of one or more RTV documents.
FSServiceCallType | FSServiceCallType[] | A collection of one or more service call documents.
GLAccountType | GLAccountType[] | A collection of one or more general ledger account documents.
GLCheckbookMasterType | GLCheckbookMasterType[] | A collection of one or more checkbook master documents.
GLCreateAccountCategoryType | GLCreateAccountCategoryType[] | A collection of one or more general ledger account category documents.
GLCreateAccountCurrenciesType | GLCreateAccountCurrenciesType[] | A collection of one or more documents that create account currencies.
GLFixedAllocationAccountType | GLFixedAllocationAccountType[] | A collection of one or more general fixed allocation account documents.
GLTransactionType | GLTransactionType[] | A collection of one or more general ledger transaction documents.
GLVariableAllocationAccountType | GLVariableAllocationAccountType[] | A collection of one or more variable allocation account documents.
HRApplicantEducationType | HRApplicantEducationType[] | A collection of one or more applicant education documents.
HRApplicantInterviewType | HRApplicantInterviewType[] | A collection of one or more interview documents for an applicant.
HRApplicantReferenceType | HRApplicantReferenceType[] | A collection of one or more reference documents for an applicant.
HRApplicantSkillType | HRApplicantSkillType[] | A collection of one or more skills documents for an applicant.
HRApplicantTestType | HRApplicantTestType[] | A collection of one or more test documents for an applicant.
HRApplicantType | HRApplicantType[] | A collection of one or more documents that creates or update applicant information.
HRApplicantWorkHistoryType | HRApplicantWorkHistoryType[] | A collection of one or more documents that create or update work history information for an applicant.
HRCreateSkillSetType | HRCreateSkillSetType[] | A collection of one or more documents that create a skill set.
HRCreateTestType | HRCreateTestType[] | A collection of one or more documents that create test information.
HRDeleteApplicantApplicationType | HRDeleteApplicantApplicationType | A collection of one or more documents that remove specified applicant information.
HRDeleteApplicantEducationLineType | HRDeleteApplicantEducationLineType[] | A collection of one or more documents that remove specified education information for an applicant.
HRDeleteApplicantEducationType | HRDeleteApplicantEducationType[] | A collection of one or more documents that remove education information for applicants.
HRDeleteApplicantInterviewType | HRDeleteApplicantInterviewType[] | A collection of one or more documents that remove interview information for applicants.
HRDeleteApplicantReferenceLineType | HRDeleteApplicantReferenceLineType[] | A collection of one or more documents that remove specified reference information for an applicant.
HRDeleteApplicantReferenceType | HRDeleteApplicantReferenceType[] | A collection of one or more documents that remove reference information for applicants.
HRDeleteApplicantRequisitionType | HRDeleteApplicantRequisitionType[] | A collection of one or more documents that remove requisition information for applicants.
HRDeleteApplicantTestLineType | HRDeleteApplicantTestLineType[] | A collection of one or more documents that remove specified test information for an applicant.
HRDeleteApplicantTestType | HRDeleteApplicantTestType[] | A collection of one or more documents that remove test information for applicants.
HRDeleteApplicantType | HRDeleteApplicantType[] | A collection of one or more documents that remove applicant information.
HRDeleteApplicantWorkHistoryLineType | HRDeleteApplicantWorkHistoryLineType[] | A collection of one or more documents that remove specified work history information for an applicant.
HRDeleteApplicantWorkHistoryType | HRDeleteApplicantWorkHistoryType[] | A collection of one or more documents that remove work history information for applicants.
HRDeleteRequisitionType | HRDeleteRequisitionType[] | A collection of one or more documents that remove requisition information.
HRDeleteSkillSetLineType | HRDeleteSkillSetLineType[] | A collection of one or more documents that remove specified skill set information.
HRDeleteSkillSetType | HRDeleteSkillSetType[] | A collection of one or more documents that remove skill set information.
HRDeleteSkillType | HRDeleteSkillType[] | A collection of one or more documents that remove job skill information.
HRDeleteTestType | HRDeleteTestType[] | A collection of one or more documents that remove test information.
HRRequisitionType | HRRequisitionType[] | A collection of one or more requisition documents.
HRSkillType | HRSkillType[] | A collection of one or more job skill documents.
IVCreateIVItemClassType | IVCreateIVItemClassType[] | A collection of one or more inventory item class documents.
IVCreateItemCurrencyType | IVCreateItemCurrencyType[] | A collection of one or more documents that create an item currency.
IVCreateItemPriceListType | IVCreateItemPriceListType[] | A collection of one or more documents that create an item price list.
IVCreatePlannerType | IVCreatePlannerType[] | A collection of one or more documents that create an inventory planner.
IVCreatePriceGroupType | IVCreatePriceGroupType[] | A collection of one or more documents that create an inventory price group.
IVCreatePriceLevelType | IVCreatePriceLevelType[] | A collection of one or more documents that create an inventory price level.
IVCreateSiteBinType | IVCreateSiteBinType[] | A collection of one or more documents that create an inventory bin.
IVCreateUOFMScheduleType | IVCreateUOFMScheduleType[] | A collection of one or more documents that create a unit of measure schedule.
IVInventoryItemSiteType | IVInventoryItemSiteType[] | A collection of one or more item site documents.
IVInventorySiteType | IVInventorySiteType[] | A collection of one or more inventory site documents.
IVInventoryTransactionType | IVInventoryTransactionType[] | A collection of one or more inventory transaction documents.
IVInventoryTransferType | IVInventoryTransferType[] | A collection of one or more inventory transfer documents.
IVItemMasterType | IVItemMasterType[] | A collection of one or more item master documents.
IVLotCategoryType | IVLotCategoryType[] | A collection of one or more lot category documents.
IVMultibinBinToBinTransferType | IVMultibinBinToBinTransferType[] | A collection of one or more bin to bin transfer documents.
IVVendorItemType | IVVendorItemType[] | A collection of one or more vendor item documents.
LBCreateLockboxBankDetailsType | LBCreateLockboxBankDetailsType[] | A collection of one or more documents that create a bank lockbox.
LBCreateLockboxType | LBCreateLockboxType[] | A collection of one or more documents that create a lockbox.
PAAccountsSetupType | PAAccountsSetupType[] | A collection of one or more project accounting account documents.
PAChangeOrderType | PAChangeOrderType[] | A collection of one or more documents that create change orders.
PAContractBillingCycleType | PAContractBillingCycleType[] | A collection of one or more contract billing cycle documents.
PAContractsType | PAContractsType[] | A collection of one or more contract documents.
PAEmployeeExpenseType | PAEmployeeExpenseType[] | A collection of one or more employee expense documents.
PAEquipmentLogTransactionType | PAEquipmentLogTransactionType[] | A collection of one or more equipment log documents.
PAMiscLogExpenseType | PAMiscLogExpenseType[] | A collection of one or more miscellaneous expense documents.
PAProjectAccessListType | PAProjectAccessListType[] | A collection of one or more project access list documents.
PAProjectBillingCyclesType | PAProjectBillingCyclesType[] | A collection of one or more billing cycle documents.
PAProjectBudgetMasterType | PAProjectBudgetMasterType[] | A collection of one or more budget master documents.
PAProjectEquipmentListType | PAProjectEquipmentListType[] | A collection of one or more project equipment list documents.
PAProjectFeesType | PAProjectFeesType[] | A collection of one or more project fee documents.
PAProjectsType | PAProjectsType[] | A collection of one or more project documents.
PATimeSheetsType | PATimeSheetsType[] | A collection of one or more project timesheet documents.
PMCreateBuyerType | PMCreateBuyerType[] | A collection of one or more documents that create buyers.
PMDeleteVendorAddressType | PMDeleteVendorAddressType[] | A collection of one or more documents that remove address information for vendors.
PMManualCheckType | PMManualCheckType[] | A collection of one or more manual check documents.
PMScheduledPaymentsType | PMScheduledPaymentsType[] | A collection of one or more scheduled payment documents.
PMTransactionType | PMTransactionType[] | A collection of one or more payable transaction documents.
PMVendorAddressType | PMVendorAddressType[] | A collection of one or more vendor address documents.
PMVendorMasterType | PMVendorMasterType[] | A collection of one or more vendor master documents.
POPDocumentDeleteType | POPDocumentDeleteType[] | A collection of one or more documents that delete a purchase order.
POPDocumentVoidType | POPDocumentVoidType[] | A collection of one or more documents that void a purchase order.
POPEnterMatchInvoiceType | POPEnterMatchInvoiceType[] | A collection of one or more documents that associate invoice and purchaser orders.
POPMapSitesType | POPMapSitesType[] | A collection of one or more purchase order sites.
POPReceivingsType | POPReceivingsType[] | A collection of one or more purchase order receivings documents.
POPTransactionType | POPTransactionType[] | A collection of one or more purchase order transaction documents.
POPtoSOPLinkRemoveType | POPtoSOPLinkRemoveType[] | A collection of one or more documents that remove the link between a sales order and purchase order.
RMApplyType | RMApplyType[] | A collection of one or more receivables apply documents.
RMCashReceiptsType | RMCashReceiptsType[] | A collection of one or more cash receipt documents.
RMCreateCustomerItemsType | RMCreateCustomerItemsType[] | A collection of one or more documents that create customer items.
RMCreateParentIDType | RMCreateParentIDType[] | A collection of one or more documents that create a corporate parent account.
RMCustomerAddressType | RMCustomerAddressType[] | A collection of one or more customer address documents.
RMCustomerClassType | RMCustomerClassType[] | A collection of one or more customer class documents.
RMCustomerMasterType | RMCustomerMasterType[] | A collection of one or more customer master documents.
RMDeleteCustomerAddressType | RMDeleteCustomerAddressType[] | A collection of one or more documents that delete a customer address.
RMDeleteCustomerType | RMDeleteCustomerType[] | A collection of one or more documents that delete a customer.
RMDeleteSalespersonType | RMDeleteSalespersonType[] | A collection of one or more documents that delete a salesperson.
RMParentIDChildType | RMParentIDChildType[] | A collection of one or more documents that associate child accounts with a parent corporate account.
RMProspectMasterType | RMProspectMasterType[] | A collection of one or more prospect documents.
RMSalespersonMasterType | RMSalespersonMasterType[] | A collection of one or more salesperson documents.
RMScheduledPaymentsType | RMScheduledPaymentsType[] | A collection of one or more payment schedule documents.
RMTerritoryMasterType | RMTerritoryMasterType[] | A collection of one or more sales territory master documents.
RMTransactionType | RMTransactionType[] | A collection of one or more receivables transaction documents.
RMUnapplyTransactionType | RMUnapplyTransactionType[] | A collection of one or more receivables unapply documents.
RMVoidTransactionType | RMVoidTransactionType[] | A collection of one or more documents that void a receivables transaction.
RQeConnectOutType | RQeConnectOutType[] | A collection of one or more eConnect requester documents.
SMMdaType | SMMdaType[] | A collection of one or more MDA documents.
SMTransactionBatchType | SMTransactionBatchType[] | A collection of one or more batch documents.
SOPDeleteDocumentType | SOPDeleteDocumentType[] | A collection of one or more documents that delete a sales order.
SOPDeleteLineType | SOPDeleteLineType[] | A collection of one or more documents that delete a specified line from a sales order.
SOPDistributionsType | SOPDistributionsType[] | A collection of one or more distribution documents.
SOPLineComponentType | SOPLineComponentType[] | A collection of one or more line component documents.
SOPProcessHoldMasterType | SOPProcessHoldMasterType[] | A collection of one or more process hold master documents.
SOPProcessHoldType | SOPProcessHoldType[] | A collection of one or more process hold documents.
SOPSerialType | SOPSerialType[] | A collection of one or more serial line documents for a sales order.
SOPTransactionType | SOPTransactionType[] | A collection of one or more sales order transaction documents.
SOPVoidDocumentType | SOPVoidDocumentType[] | A collection of one or more documents that void a sales order.
SOPtoPOPTransactionType | SOPtoPOPTransactionType[] | A collection of one or more sales order to purchase order documents.
UPRComputerTrxType | UPRComputerTrxType[] | A collection of one or more payroll computer transaction documents.
UPRCreateBenefitType | UPRCreateBenefitType[] | A collection of one or more documents that create a payroll benefit.
UPRCreateDeductionType | UPRCreateDeductionType[] | A collection of one or more documents that create a payroll deduction.
UPRCreateDepartmentType | UPRCreateDepartmentType[] | A collection of one or more documents that create a payroll department.
UPRCreateEmployeeAddressType | UPRCreateEmployeeAddressType[] | A collection of one or more documents that create an employee address.
UPRCreateEmployeeBenefitType | UPRCreateEmployeeBenefitType[] | A collection of one or more documents that create an employee benefit.
UPRCreateEmployeeClassType | UPRCreateEmployeeClassType[] | A collection of one or more documents that create an employee class.
UPRCreateEmployeeDeductionType | UPRCreateEmployeeDeductionType[] | A collection of one or more documents that create an employee deduction.
UPRCreateEmployeeLocalTaxType | UPRCreateEmployeeLocalTaxType[] | A collection of one or more documents that create a local employee tax.
UPRCreateEmployeePayCodeType | UPRCreateEmployeePayCodeType[] | A collection of one or more documents that create an employee pay code.
UPRCreateEmployeeStateTaxType | UPRCreateEmployeeStateTaxType[] | A collection of one or more documents that create a state payroll tax.
UPRCreateEmployeeTaxType | UPRCreateEmployeeTaxType[] | A collection of one or more documents that create an employee tax.
UPRCreateEmployeeType | UPRCreateEmployeeType[] | A collection of one or more documents that create an employee type.
UPRCreateLocalTaxType | UPRCreateLocalTaxType[] | A collection of one or more documents that create a local payroll tax.
UPRCreateLocationType | UPRCreateLocationType[] | A collection of one or more documents that create a payroll location.
UPRCreatePayCodeType | UPRCreatePayCodeType[] | A collection of one or more documents that create a pay code.
UPRCreatePositionType | UPRCreatePositionType[] | A collection of one or more documents that create a payroll position.
UPRCreateShiftCodeType | UPRCreateShiftCodeType[] | A collection of one or more documents that create a payroll shift code.
UPRCreateSupervisorType | UPRCreateSupervisorType[] | A collection of one or more documents that create a supervisor.
UPRCreateWorker_CompensationCodeType | UPRCreateWorker_CompensationCodeType[] | A collection of one or more documents that create worker compensation codes.
UPRDeleteEmployeeAddressType | UPRDeleteEmployeeAddressType[] | A collection of one or more documents that remove address information for employees.
UPRDeleteEmployeePayCodeType | UPRDeleteEmployeePayCodeType[] | A collection of one or more documents that remove pay code information for employees.
UPRDeleteEmployeeType | UPRDeleteEmployeeType[] | A collection of one or more documents that delete an employee.
UPRManualTrxType | UPRManualTrxType[] | A collection of one or more manual transaction documents.

See Also

eConnect schema


FACreateAccountGroupType Class

A class that represent a eConnect transaction type you use to create an account group.

Constructor

Name | Description
FACreateAccountGroupType() | Initializes an instance of the FACreateAccountGroupType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAccountGroup | taCreateAccountGroup | A node that creates a fixed asset account group.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAccountGroupType


FACreateAssetBookITCType Class

A class that represents the eConnect transaction type you use to create an asset ITC entry.

Constructor

Name | Description
FACreateAssetBookITCType() | Initializes an instance of the FACreateAssetBookITCType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetBookITC | taCreateAssetBookITC | A node that creates a fixed asset ITC record.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetBookITCType


FACreateAssetBookIDType Class

A class that represents the eConnect transaction type you use to create an asset book entry.

Constructor

Name | Description
FACreateAssetBookType() | Initializes an instance of the FACreateAssetBookType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetBook | taCreateAssetBook | A node that creates a fixed asset book record.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetBookIDType


FACreateAssetClassIDType Class

A class that represents the eConnect transaction type you use to creates an asset class ID.

Constructor

Name | Description
FACreateAssetClassIDType() | Initializes an instance of the FACreateAssetClassIDType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetClassID | taCreateAssetClassID | A node that creates a fixed asset class ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetClassIDType


FACreateAssetIDType Class

A class that represents the eConnect transaction type you use to creates an asset ID.

Constructor

Name | Description
FACreateAssetIDType() | Initializes an instance of the FACreateAssetIDType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetID | taCreateAssetID | A node that creates an asset ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetIDType


FACreateAssetInsuranceType Class

A class that represents the eConnect transaction type you use to create an asset insurance entry.

Constructor

Name | Description
FACreateAssetInsuranceType() | Initializes an instance of the FACreateAssetInsuranceType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetInsurance | taCreateAssetInsurance | A node that creates asset insurance entry.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetInsuranceType


FACreateAssetLeaseType Class

A class that represents the eConnect transaction type you use to create an asset lease entry.

Constructor

Name | Description
FACreateAssetLeaseType() | Initializes an instance of the FACreateAssetLeaseType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetLease | taCreateAssetLease | A node that creates an asset lease.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetLeaseType


FACreateAssetPurchaseType Class

A class that represents the eConnect transaction type you use to create an asset purchase entry.

Constructor

Name | Description
FACreateAssetPurchaseType() | Initializes an instance of the FACreateAssetPurchaseType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetPurchase | taCreateAssetPurchase | A node that creates asset purchase information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetPurchaseType


FACreateAssetUserDataType Class

A class that represents the eConnect transaction type you use to create an asset user entry.

Constructor

Name | Description
FACreateAssetUserDataType() | Initializes an instance of the FACreateAssetUserDataType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAssetUserData | taCreateAssetUserData | A node that creates asset user information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateAssetUserDataType


FACreateBookClassType Class

A class that represents the eConnect transaction type you use to create an asset book class.

Constructor

Name | Description
FACreateBookClassType() | Initializes an instance of the FACreateBookClassType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateBookClass | taCreateBookClass | A node that creates a fixed asset book class ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateBookClassType


FACreateBookIDType Class

A class that represents the eConnect transaction type you use to create an asset book ID.

Constructor

Name | Description
FACreateBookIDType() | Initializes an instance of the FACreateBookIDType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateBookID | taCreateBookID | A node that creates a fixed asset book ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateBookIDType


FACreateInsuranceClassIDType Class

A class that represents the eConnect transaction type you use to create an assent insurance class ID.

Constructor

Name | Description
FACreateInsuranceClassIDType() | Initializes an instance of the FACreateInsuranceClassIDType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateInsuranceClassID | taCreateInsuranceClassID | A node that creates a fixed asset insurance class ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateInsuranceClassIDType


FACreateLeaseCompanyType Class

A class that represents the eConnect transaction type you use to create a lease company.

Constructor

Name | Description
FACreateLeaseCompanyType() | Initializes an instance of the FACreateLeaseCompanyType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateLeaseCompany | taCreateLeaseCompany | A node that creates a fixed asset lease company.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateLeaseCompanyType


FACreateLocationIDType Class

A class that represents the eConnect transaction type you use to create an asset location ID.

Constructor

Name | Description
FACreateLocationIDType() | Initializes an instance of the FACreateLocationIDType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateLocationID | taCreateLocationID | A node that creates a fixed asset location ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateLocationIDType


FACreatePhysicalLocationIDType Class

A class that represents the eConnect transaction type you use to create an asset physical location ID.

Constructor

Name | Description
FACreatePhysicalLocationIDType() | Initializes an instance of the FACreatePhysicalLocationIDType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreatePhysicalLocationID | taCreatePhysicalLocationID | A node that creates a fixed asset physical location ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreatePhysicalLocationIDType


FACreateRetirementCodeType Class

A class that represents the eConnect transaction type you use to create an asset retirement code.

Constructor

Name | Description
FACreateRetirementCodeType() | Initializes an instance of the FACreateRetirementCodeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateRetirementCode | taCreateRetirementCode | A node that creates a fixed asset retirement code.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateRetirementCodeType


FACreateStructureType Class

A class that represents the eConnect transaction type you use to create an asset structure.

Constructor

Name | Description
FACreateStructureType() | Initializes an instance of the FACreateStructureType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateStructure | taCreateStructure | A node that creates a fixed asset structure ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FACreateStructureType


FSEquipmentType Class

A class that represents the eConnect transaction type you use to specify a field service equipment entry.

Constructor

Name | Description
FSEquipmentType() | Initializes an instance of the FSEquipmentType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taFSEquipmentMaster | taFSEquipmentMaster | A node that specifies a field service equipment record.
taFSEquipmentReading_Items | taFSEquipmentReading_ItemsTaFSEquipmentReading[] | A collect of nodes that specify one or more field service equipment reading records.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FSEquipmentType


FSRMAType Class

A class that represents the eConnect transaction type you use to specify a field service return entry.

Constructor

Name | Description
FSRMAType() | Initializes an instance of the FSRMAType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taFSRMALineSerial_Items | taFSRMALineSerial_ItemsTaFSRMALineSerial[] | A collection of nodes that specify one or more field service RMA line serial numbers.
taFSRMALine_Items | taFSRMALine_ItemsTaFSRMALine[] | A collection of nodes that create or update one or more field service RMA lines.
taFSRMAMaster | taFSRMAMaster | A node that specifies a field service RMA record.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FSRMAType


FSRTVType Class

A class that represents the eConnect transaction type you use to specify a field service vendor return entry.

Constructor

Name | Description
FSRTVType() | Initializes an instance of the FSRTVType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taFSRTVLineSerial_Items | taFSRTVLineSerial_ItemsTaFSRTVLineSerial[] | A collection of nodes that specify one or more field service RTV line serial numbers.
taFSRTVLine_Items | taFSRTVLine_ItemsTaFSRTVLine[] | A collection of nodes that create or update one or more field service RTV lines.
taFSRTVMaster | taFSRTVMaster | A node that specifies a field service RTV record.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FSRTVType


FSServiceCallType Class

A class that represents the eConnect transaction type you use to specify a service call entry.

Constructor

Name | Description
FSServiceCallType() | Initializes an instance of the FSServiceCallType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taFSServiceCallCodesEquipment_Items | taFSServiceCallCodesEquipment_ItemsTaFSServiceCallCodesEquipment[] | A collection of nodes that specify one or more field service call analysis codes.
taFSServiceCallLineSerial_Items | taFSServiceCallLineSerial_ItemsTaFSServiceCallLineSerial[] | A collection of nodes that specify one or more field service call line serial numbers.
taFSServiceCallLine_Items | taFSServiceCallLine_ItemsTaFSServiceCallLine[] | A collection of nodes that create or update one or more field service call lines.
taFSServiceCallMaster | taFSServiceCallMaster | A node that specifies a field service call.
taFSServiceCallMultiTech_Items | taFSServiceCallMultiTech_ItemsTaFSServiceCallMultiTech[] | A node that specifies a multi tech service call.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

FSServiceCallType


GLAccountType Class

A class that represents the eConnect transaction type you use to create or update a general ledger account.

Constructor

Name | Description
GLAccountType() | Initializes an instance of the GLAccountType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateFixedAllocationAccountRcd_Items | taCreateFixedAllocationAccountRcd_ItemsTaCreateFixedAllocationAccountRcd[] | A collection of nodes that create or update one or more general ledger fixed allocation accounts.
taCreateVariableAllocationAccountRcd_Items | taCreateVariableAllocationAccountRcd_ItemsTaCreateVariableAllocationAccountRcd[] | A collection of nodes that create or update one or more general ledger variable allocation accounts.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateAccountRcd | taUpdateCreateAccountRcd | A node that creates or updates a general ledger account.

See Also

GLAccountType


GLCheckbookMasterType Class

A class that represents the eConnect transaction type you use to create a checkbook.

Constructor

Name | Description
GLCheckbookMasterType() | Initializes an instance of the GLCheckbookMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateCheckbook | taCreateCheckbook | A node that creates a checkbook.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

GLCheckbookMasterType


GLCreateAccountCategoryType Class

A class that represents the eConnect transaction type you use to create a general ledger account category.

Constructor

Name | Description
GLCreateAccountCategoryType() | Initializes an instance of the GLCreateAccountCategoryType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAccountCategory | taCreateAccountCategory | A node that creates a general ledger account category.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

GLCreateAccountCategoryType


GLCreateAccountCurrenciesType Class

A class that represents the eConnect transaction type you use to create a currency type that is associated with general ledger accounts.

Constructor

Name | Description
GLCreateAccountCurrenciesType() | Initializes an instance of the GLCreateAccountCurrenciesType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateAccountCurrencies | taCreateAccountCurrencies | A node that creates a general ledger account currency.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

GLCreateAccountCurrenciesType


GLFixedAllocationAccountType Class

A class that represents the eConnect transaction type you use to create or update a general ledger fixed allocation account.

Constructor

Name | Description
GLFixedAllocationAccountType() | Initializes an instance of the GLFixedAllocationAccountType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateFixedAllocationAccountRcd_Items | taCreateFixedAllocationAccountRcd_ItemsTaCreateFixedAllocationAccountRcd[] | A collection of nodes that create or update one or more general ledger fixed allocation accounts.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateAccountRcd | taUpdateCreateAccountRcd | A node that creates or updates a general ledger account.

See Also

GLFixedAllocationAccount


GLTransactionType Class

A class that represents the eConnect transaction type you use to specify a general ledger transaction.

Constructor

Name | Description
GLTransactionType() | Initializes an instance of the GLTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taGLTransactionHeaderInsert | taGLTransactionHeaderInsert | A node that specifies a general ledger transaction header.
taGLTransactionLineInsert_Items | taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert[] | A collection of nodes that specify one or more general ledger transaction lines.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

GLTransactionType


GLVariableAllocationAccountType Class

A class that represents the eConnect transaction type you use to create or update a general ledger variable allocation account.

Constructor

Name | Description
GLVariableAllocationAccountType() | Initializes an instance of the GLVariableAllocationAccountType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateVariableAllocationAccountRcd_Items | taCreateVariableAllocationAccountRcd_ItemsTaCreateVariableAllocationAccountRcd[] | A collection of nodes that create or update one or more general ledger variable allocation accounts.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateAccountRcd | taUpdateCreateAccountRcd | A node that creates or updates a general ledger account.

See Also

GLVariableAllocationAccountType


HRApplicantEducationType Class

A class that represents the eConnect transaction type you use to specify education information for an applicant.

Constructor

Name | Description
HRApplicantEducationType() | Initializes an instance of the HRApplicantEducationType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateApplicantEducation | taCreateApplicantEducation | A node that creates applicant education information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRApplicantEducationType


HRApplicantInterviewType Class

A class that represents the eConnect transaction type you use to specify interview information for an applicant.

Constructor

Name | Description
HRApplicantInterviewType() | Initializes an instance of the HRApplicantInterviewType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taApplicantInterviewUpdate_Items | taApplicantInterviewUpdate_ItemsTaApplicantInterviewUpdate[] | A collection of nodes that provide interview information for an applicant.
taCreateApplicantInterviewInsert | taCreateApplicantInterviewInsert | A node that creates interview information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRApplicantInterviewType


HRApplicantReferenceType Class

A class that represents the eConnect transaction type you use to specify reference information for an applicant.

Constructor

Name | Description
HRApplicantReferenceType() | Initializes an instance of the HRApplicantReferenceType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateApplicantReferences | taCreateApplicantReferences | A node that creates reference information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRApplicantReferenceType


HRApplicantSkillType Class

A class that represents the eConnect transaction type you use to specify skill information for an applicant.

Constructor

Name | Description
HRApplicantSkillType() | Initializes an instance of the HRApplicantSkillType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateApplicantSkills | taCreateApplicantSkills | A node that creates skill information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRApplicantSkillType


HRApplicantTestType Class

A class that represents the eConnect transaction type you use to specify test information for an applicant.

Constructor

Name | Description
HRApplicantTestType() | Initializes an instance of the HRApplicantTestType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateApplicantTests | taCreateApplicantTests | A node that creates test information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRApplicantTestType


HRApplicantType Class

A class that represents the eConnect transaction type you use to specify applicant information.

Constructor

Name | Description
HRApplicantType() | Initializes an instance of the HRApplicantType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateApplicant | taCreateApplicant | A node that creates applicant information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRApplicantType


HRApplicantWorkHistoryType Class

A class that represents the eConnect transaction type you use to specify work history information for an applicant.

Constructor

Name | Description
HRApplicantWorkHistoryType() | Initializes an instance of the HRApplicantWorkHistoryType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateApplicantWorkHistory | taCreateApplicantWorkHistory | A node that creates work history information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRApplicantWorkHistoryType


HRCreateSkillSetType Class

A class that represents the eConnect transaction type you use to create skill set information.

Constructor

Name | Description
HRCreateSkillSetType() | Initializes an instance of the HRCreateSkillSetType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateSkillSets | taCreateSkillSets | A node that creates skill set information.
taCreateSkillSetsLine_Items | taCreateSkillSetsLine_ItemsTaCreateSkillSetsLine[] | A collection of nodes that provide detailed skill set information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRCreateSkillSetType


HRCreateTestType Class

A class that represents the eConnect transaction type you use to create test information.

Constructor

Name | Description
HRCreateTestType() | Initializes an instance of the HRCreateTestType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateTests | taCreateTests | A node that creates test information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRCreateTestType


HRDeleteApplicantApplicationType Class

A class that represents the eConnect transaction type you use to remove an application.

Constructor

Name | Description
HRDeleteApplicantApplicationType() | Initializes an instance of the HRDeleteApplicantApplicationType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantApplication | taDeleteApplicantApplication | A node that removes application information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantApplicationType


HRDeleteApplicantEducationLineType Class

A class that represents the eConnect transaction type you use to remove specified applicant education information.

Constructor

Name | Description
HRDeleteApplicantEducationLineType() | Initializes an instance of the HRDeleteApplicantEducationLineType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantEducationLine | taDeleteApplicantEducationLine | A node that removes specified education information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantEducationLineType


HRDeleteApplicantEducationType Class

A class that represents the eConnect transaction type you use to remove education information for an applicant.

Constructor

Name | Description
HRDeleteApplicantEducationType() | Initializes an instance of the HRDeleteApplicantEducationType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantEducation | taDeleteApplicantEducation | A node that specifies the education information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantEducationType


HRDeleteApplicantInterviewType Class

A class that represents the eConnect transaction type you use to remove interview information for an applicant.

Constructor

Name | Description
HRDeleteApplicantInterviewType() | Initializes an instance of the HRDeleteApplicantInterviewType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantInterview | taDeleteApplicantInterview | A node that specifies the interview information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantInterviewType


HRDeleteApplicantReferenceLineType Class

A class that represents the eConnect transaction type you use to remove specified reference information for an applicant.

Constructor

Name | Description
HRDeleteApplicantReferenceLineType() | Initializes an instance of the HRDeleteApplicantReferenceLineType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantReferencesLine | taDeleteApplicantReferencesLine | A node that specifies the reference information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantReferenceLineType


HRDeleteApplicantReferenceType Class

A class that represents the eConnect transaction type you use to remove reference information for an applicant.

Constructor

Name | Description
HRDeleteApplicantReferenceType() | Initializes an instance of the HRDeleteApplicantReferenceType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantReferences | taDeleteApplicantReferences | A node that specifies reference information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantReferenceType


HRDeleteApplicantRequisitionType Class

A class that represents the eConnect transaction type you use to remove requisition information for an applicant.

Constructor

Name | Description
HRDeleteApplicantRequisitionType() | Initializes an instance of the HRDeleteApplicantRequisitionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantRequisitionsLine | taDeleteApplicantRequisitionsLine | A node that specifies requisition information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantRequisitionType


HRDeleteApplicantTestLineType Class

A class that represents the eConnect transaction type you use to remove specified test information for an applicant.

Constructor

Name | Description
HRDeleteApplicantTestLineType() | Initializes an instance of the HRDeleteApplicantTestLineType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantTestsLine | taDeleteApplicantTestsLine | A node that specifies detailed test information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantTestLineType


HRDeleteApplicantTestType Class

A class that represents the eConnect transaction type you use to remove test information for an applicant.

Constructor

Name | Description
HRDeleteApplicantTestType() | Initializes an instance of the HRDeleteApplicantTestType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantTests | taDeleteApplicantTests | A node that specifies applicant test information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantTestType


HRDeleteApplicantType Class

A class that represents the eConnect transaction type you use to remove applicant information.

Constructor

Name | Description
HRDeleteApplicantType() | Initializes an instance of the HRDeleteApplicantType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicant | taDeleteApplicant | A node that specifies the applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantType


HRDeleteApplicantWorkHistoryLineType Class

A class that represents the eConnect transaction type you use to remove specified work history information for an applicant.

Constructor

Name | Description
HRDeleteApplicantWorkHistoryLineType() | Initializes an instance of the HRDeleteApplicantWorkHistoryLineType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantWorkHistoryLine | taDeleteApplicantWorkHistoryLine | A node that specifies work history information for an applicant.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantWorkHistoryLineType


HRDeleteApplicantWorkHistoryType Class

A class that represents the eConnect transaction type you use to remove work history information for an applicant.

Constructor

Name | Description
HRDeleteApplicantWorkHistoryType() | Initializes an instance of the HRDeleteApplicantWorkHistoryType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteApplicantWorkHistory | taDeleteApplicantWorkHistory | A node that specifies work history information for an applicant
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteApplicantWorkHistoryType


HRDeleteRequisitonType Class

A class that represents the eConnect transaction type you use to remove a requisition.

Constructor

Name | Description
HRDeleteRequisitonType() | Initializes an instance of the HRDeleteRequisitonType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteRequisition | taDeleteRequisition | A node that specifies a requisition.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteRequistionType


HRDeleteSkillSetLineType Class

A class that represents the eConnect transaction type you use to remove specified skill set information.

Constructor

Name | Description
HRDeleteSkillSetLineType() | Initializes an instance of the HRDeleteSkillSetLineType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteSkillSetsLine | taDeleteSkillSetsLine | A node that specifies skill set information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteSkillSetLineType


HRDeleteSkillSetType Class

A class that represents the eConnect transaction type you use to remove skill set information.

Constructor

Name | Description
HRDeleteSkillSetType() | Initializes an instance of the HRDeleteSkillSetType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteSkillSets | taDeleteSkillSets | A node that specifies a skill set.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteSkillSetType


HRDeleteSkillType Class

A class that represents the eConnect transaction type you use to remove specified job skill information.

Constructor

Name | Description
HRDeleteSkillType() | Initializes an instance of the HRDeleteSkillType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteSkills | taDeleteSkills | A node that specifies job skill information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteSkillType


HRDeleteTestType Class

A class that represents the eConnect transaction type you use to remove test information.

Constructor

Name | Description
HRDeleteTestType() | Initializes an instance of the HRDeleteTestType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteTests | taDeleteTests | A node that specifies test information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRDeleteTestType


HRRequisitionType Class

A class that represents the eConnect transaction type you use to specify requisition information.

Constructor

Name | Description
HRRequisitionType() | Initializes an instance of the HRRequisitionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateRequisitions | taCreateRequisitions | A node that specifies information for a requisition.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRRequisitionType


HRSkillType Class

A class that represents the eConnect transaction type you use to specify job skill information.

Constructor

Name | Description
HRSkillType() | Initializes an instance of the HRSkillType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateSkills | taCreateSkills | A node that specifies job skill information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

HRSkillType


IVCreateIVItemClassType Class

A class that represents the eConnect transaction type you use to create an inventory item class.

Constructor

Name | Description
IVCreateIVItemClassType() | Initializes an instance of the IVCreateIVItemClassType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateIVItemClass | taCreateIVItemClass | A node that creates an inventory item class.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVCreateIVItemClassType


IVCreateItemCurrencyType Class

A class that represents the eConnect transaction type you use to associate a currency with an inventory item.

Constructor

Name | Description
IVCreateItemCurrencyType() | Initializes an instance of the IVCreateItemCurrencyType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateItemCurrencyRcd_Items | taUpdateCreateItemCurrencyRcd_ItemsTaUpdateCreateItemCurrencyRcd[] | A collection of nodes that create or update the association between and one or more inventory items and currencies.

See Also

IVCreateItemCurrencyType


IVCreateItemPriceListType Class

A class that represents the eConnect transaction type you use to create a price list for an inventory item.

Constructor

Name | Description
IVCreateItemPriceListType() | Initializes an instance of the IVCreateItemPriceListType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taIVCreateItemPriceListHeader | taIVCreateItemPriceListHeader | A node that creates or updates an inventory item price list header.
taIVCreateItemPriceListLine_Items | taIVCreateItemPriceListLine_ItemsTaIVCreateItemPriceListLine[] | A collection of nodes that create or update one or more inventory item price list lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVCreateItemPriceListType


IVCreatePlannerType Class

A class that represents the eConnect transaction type you use to create an inventory planner.

Constructor

Name | Description
IVCreatePlannerType() | Initializes an instance of the IVCreatePlannerType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreatePlanner | taCreatePlanner | A node that creates an inventory planner.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVCreatePlannerType


IVCreatePriceGroupType Class

A class that represents the eConnect transaction type you use to create an inventory price group.

Constructor

Name | Description
IVCreatePriceGroupType() | Initializes an instance of the IVCreatePriceGroupType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taIVCreatePriceGroup | taIVCreatePriceGroup | A node that create an inventory price group.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVCreatePriceGroupType


IVCreatePriceLevelType Class

A class that represents the eConnect transaction type you use to create an inventory price level.

Constructor

Name | Description
IVCreatePriceLevelType() | Initializes an instance of the IVCreatePriceLevelType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taIVCreatePriceLevel | taIVCreatePriceLevel | A node that creates an inventory price level.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVCreatePriceLevelType


IVCreateSiteBinType Class

A class that represents the eConnect transaction type you use to create an inventory bin.

Constructor

Name | Description
IVCreateSiteBinType() | Initializes an instance of the IVCreateSiteBinType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateSiteBin | taCreateSiteBin | A node that creates an inventory bin.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVCreateSiteBinType


IVCreateUOFMScheduleType Class

A class that represents the eConnect transaction type you use to create a unit of measure schedule for an inventory item.

Constructor

Name | Description
IVCreateUOFMScheduleType() | Initializes an instance of the IVCreateUOFMScheduleType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taIVCreateUOFMScheduleHeader | taIVCreateUOFMScheduleHeader | A node that creates an inventory unit of measure schedule header.
taIVCreateUOFMScheduleLine_Items | taIVCreateUOFMScheduleLine_ItemsTaIVCreateUOFMScheduleLine[] | A collection of nodes that create one or more inventory unit of measure schedule lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVCreateUOFMScheduleType


IVInventoryItemSiteType Class

A class that represents the eConnect transaction type you use to create a site for inventory items.

Constructor

Name | Description
IVInventoryItemSiteType() | Initializes an instance of the IVInventoryItemSiteType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taItemSite_Items | taItemSite_ItemsTaItemSite[] | A collection of nodes that create or update one or more inventory item sites.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVInventoryItemSiteType


IVInventorySiteType Class

A class that represents the eConnect transaction type you use to associate a site with an inventory item.

Constructor

Name | Description
IVInventorySiteType() | Initializes an instance of the IVInventorySiteType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateInventorySite | taCreateInventorySite | A node that creates an inventory site.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVInventorySiteType


IVInventoryTransactionType Class

A class that represents the eConnect transaction type you use to specify an inventory transaction.

Constructor

Name | Description
IVInventoryTransactionType() | Initializes an instance of the IVInventoryTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taIVTransactionHeaderInsert | taIVTransactionHeaderInsert | A node that creates an inventory transaction header.
taIVTransactionLineInsert_Items | taIVTransactionLineInsert_ItemsTaIVTransactionLineInsert[] | A collection of nodes that create one or more inventory transaction lines.
taIVTransactionLotInsert_Items | taIVTransactionLotInsert_ItemsTaIVTransactionLotInsert[] | A collection of nodes that creates one or more inventory transaction lots.
taIVTransactionMultiBinInsert_Items | taIVTransactionMultiBinInsert_ItemsTaIVTransactionMultiBinInsert[] | A collection of nodes that create one or more inventory multibin transactions.
taIVTransactionSerialInsert_Items | taIVTransactionSerialInsert_ItemsTaIVTransactionSerialInsert[] | A collection of nodes that create one or more inventory serial lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateItemRcd | taUpdateCreateItemRcd | A node that creates or updates an inventory item.

See Also

IVInventoryTransactionType


IVInventoryTransferType Class

A class that represents the eConnect transaction type you use to specify an inventory transfer.

Constructor

Name | Description
IVInventoryTransferType() | Initializes an instance of the IVInventoryTransferType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taIVTransferHeaderInsert | taIVTransferHeaderInsert | A node that creates an inventory transfer header.
taIVTransferLineInsert_Items | taIVTransferLineInsert_ItemsTaIVTransferLineInsert[] | A collection of nodes that create one or more inventory transfer lines.
taIVTransferLotInsert_Items | taIVTransferLotInsert_ItemsTaIVTransferLotInsert[] | A collection of nodes that create one or more inventory transfer lots.
taIVTransferMultiBinInsert_Items | taIVTransferMultiBinInsert_ItemsTaIVTransferMultiBinInsert[] | A collection of nodes that create one or more inventory multibin transfers.
taIVTransferSerialInsert_Items | taIVTransferSerialInsert_ItemsTaIVTransferSerialInsert[] | A collection of nodes that create one or more inventory transfer serial lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateItemRcd | taUpdateCreateItemRcd | A node that creates or updates an inventory item.

See Also

IVInventoryTransferType


IVItemMasterType Class

A class that represents the eConnect transaction type you use to specify an inventory item.

Constructor

Name | Description
IVItemMasterType() | Initializes an instance of the IVItemMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taCreateItemVendors_Items | taCreateItemVendors_ItemsTaCreateItemVendors[] | A collection of nodes that create one or more inventory item vendors.
taCreateKitItemRcd_Items | taCreateKitItemRcd_ItemsTaCreateKitItemRcd[] | A collection of noes that create one or more inventory kit items.
taIVCreateItemPriceListHeader | taIVCreateItemPriceListHeader | A node that creates or updates an inventory item price list header.
taIVCreateItemPriceListLine_Items | taIVCreateItemPriceListLine_ItemsTaIVCreateItemPriceListLine[] | A collection nodes that create or update one or more inventory item price list lines.
taItemSite_Items | taItemSite_ItemsTaItemSite[] | A collection of nodes that create or update one or more inventory item sites.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateItemCurrencyRcd_Items | taUpdateCreateItemCurrencyRcd_ItemsTaUpdateCreateItemCurrencyRcd[] | A collection of nodes that create or update the association between one or more inventory items and currencies.
taUpdateCreateItemRcd | taUpdateCreateItemRcd | A node that creates or updates an inventory item.

See Also

IVItemMasterType


IVLotCategoryType Class

A class that represents the eConnect transaction type you use to specify an inventory lot category.

Constructor

Name | Description
IVLotCategoryType() | Initializes an instance of the IVLotCategoryType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateLotCategory | taCreateLotCategory | A node that creates an inventory lot category.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVLotCategoryType


IVMultibinBinToBinTransferType Class

A class that represents the eConnect transaction type you use to specify a transfer between inventory bins.

Constructor

Name | Description
IVMultibinBinToBinTransferType() | Initializes an instance of the IVMultibinBinToBinTransferType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taIVMultibinBinToBinTransfer | taIVMultibinBinToBinTransfer | A node that specifies an inventory bin to bin transfer.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVMultibinBinToBinTransferType


IVVendorItemType Class

A class that represents the eConnect transaction type you use to specify an inventory item vendor.

Constructor

Name | Description
IVVendorItemType() | Initializes an instance of the IVVendorItemType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateItemVendors_Items | taCreateItemVendors_ItemsTaCreateItemVendors[] | A collection of nodes that create one or more inventory item vendors.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

IVVendorItemType


LBCreateLockboxBankDetailsType Class

A class that represents the eConnect transaction type you use to associate a lockbox with a bank.

Constructor

Name | Description
LBCreateLockboxBankDetailsType() | Initializes an instance of the LBCreateLockboxBankDetailsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateLockboxBankDetails | taCreateLockboxBankDetails | A node that creates lockbox bank details.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

LBCreateLockboxBankDetailsType


LBCreateLockboxType Class

A class that represents the eConnect transaction type you use to create a lockbox.

Constructor

Name | Description
LBCreateLockboxType() | Initializes an instance of the LBCreateLockboxType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateLockbox | taCreateLockbox | A node that creates a lockbox.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

LBCreateLockboxType


PAAccountsSetupType Class

A class that represents the eConnect transaction type you use to create a project account.

Constructor

Name | Description
PAAccountsSetupType() | Initializes an instance of the PAAccountsSetupType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAAccountsSetup_Items | taPAAccountsSetup_ItemsTaPAAccountsSetup[] | A collection of nodes that create one or more project accounts.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAAccountsSetupType


PAChangeOrderType Class

A class that represents the eConnect transaction type you use to specify a project change order.

Constructor

Name | Description
PAChangeOrderType() | Initializes an instance of the PAChangeOrderType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAChangeOrderEntryBudget_Items | taPAChangeOrderEntryBudget_ItemsTaPAChangeOrderEntryBudget[] | A collection of nodes that specify one or more project budget change orders.
taPAChangeOrderEntryFeeDetail_Items | taPAChangeOrderEntryFeeDetail_ItemsTaPAChangeOrderEntryFeeDetail[] | A collection of nodes that specify one or more project change order fee details.
taPAChangeOrderEntryFeeHeader_Items | taPAChangeOrderEntryFeeHeader_ItemsTaPAChangeOrderEntryFeeHeader[] | A collection of nodes that specify one or more a project change order fee headers.
taPAChangeOrderEntryFeeSchedule_Items | taPAChangeOrderEntryFeeSchedule_ItemsTaPAChangeOrderEntryFeeSchedule[] | A collection nodes that specify one or more project change order fee schedules.
taPAChangeOrderEntryHdr | taPAChangeOrderEntryHdr | A node that specifies a project change order header.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAChangeOrderType


PAContractBillingCycleType Class

A class that represents the eConnect transaction type you use to specify a project billing cycle.

Constructor

Name | Description
PAContractBillingCycleType() | Initializes an instance of the PAContractBillingCycleType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAContractBillingCycle_Items | taPAContractBillingCycle_ItemsTaPAContractBillingCycle[] | A collection of nodes that specify one or more project contract billing cycles.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAContractBillingCycleType


PAContractsType Class

A class that represents the eConnect transaction type you use to specify a project contract.

Constructor

Name | Description
PAContractsType() | Initializes an instance of the PAContractsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAAccountsSetup_Items | taPAAccountsSetup_ItemsTaPAAccountsSetup[] | A collection of nodes that create one or more project accounts.
taPAContractBillingCycle_Items | taPAContractBillingCycle_ItemsTaPAContractBillingCycle[] | A collection of nodes that specify one or more project contract billing cycles.
taPAContracts | taPAContracts | A node that creates a project contract.
taPAProjectAccess_Items | taPAProjectAccess_ItemsTaPAProjectAccess[] | A collection of nodes that create or update project access information.
taPAProjectBillingCycle_Items | taPAProjectBillingCycle_ItemsTaPAProjectBillingCycle[] | A collection of nodes that specify one or more project contract billing cycles.
taPAProjectBudgetMaster_Items | taPAProjectBudgetMaster_ItemsTaPAProjectBudgetMaster[] | A collection of nodes that specify a project budget.
taPAProjectEquip_Items | taPAProjectEquip_ItemsTaPAProjectEquip[] | A collection of nodes that specify a project equipment list.
taPAProjectFeeSchedule_Items | taPAProjectFeeSchedule_ItemsTaPAProjectFeeSchedule[] | A collection of nodes that specify a project fee schedule.
taPAProjectFee_Items | taPAProjectFee_ItemsTaPAProjectFee[] | A collection of nodes that specify one or more project fees.
taPAProjects_Items | taPAProjects_ItemsTaPAProjects[] | A collection of nodes that specify one or more project items.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAContractsType


PAEmployeeExpenseType Class

A class that represents the eConnect transaction type you use to specify expenses for a project employee.

Constructor

Name | Description
PAEmployeeExpenseType() | Initializes an instance of the PAEmployeeExpenseType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taPAEmpExpenseHdrInsert | taPAEmpExpenseHdrInsert | A node that creates a project employee expense header.
taPAEmpExpenseLineInsert_Items | taPAEmpExpenseLineInsert_ItemsTaPAEmpExpenseLineInsert[] | A collection of nodes that create one or more project employee expense lines.
taPAEmpExpenseTaxInsert_Items | taPAEmpExpenseTaxInsert_ItemsTaPAEmpExpenseTaxInsert[] | A collection of nodes that create one or more project employee expense tax lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateVendorRcd | taUpdateCreateVendorRcd | A node that creates or updates a vendor.

See Also

PAEmployeeExpenseType


PAEquipmentLogTransactionType Class

A class that represents the eConnect transaction type you use to specify an equipment log transaction for a project.

Constructor

Name | Description
PAEquipmentLogTransactionType() | Initializes an instance of the PAEquipmentLogTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAEquipLogHdrInsert | taPAEquipLogHdrInsert | A node that creates a project equipment log header.
taPAEquipLogLineInsert_Items | taPAEquipLogLineInsert_ItemsTaPAEquipLogLineInsert[] | A collection of nodes that create one or more project equipment log lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAEquipmentLogTransactionType


PAMiscLogExpenseType Class

A class that represents the eConnect transaction type you use to specify a miscellaneous log expense for a project.

Constructor

Name | Description
PAMiscLogExpenseType() | Initializes an instance of the PAMiscLogExpenseType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAMiscLogHdrInsert | taPAMiscLogHdrInsert | A node that creates a project miscellaneous log header.
taPAMiscLogLineInsert_Items | taPAMiscLogLineInsert_ItemsTaPAMiscLogLineInsert[] | A collection of nodes that create one or more project miscellaneous log lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAMiscLogExpenseType


PAProjectAccessListType Class

A class that represents the eConnect transaction type you use to specify a project access list.

Constructor

Name | Description
PAProjectAccessListType() | Initializes an instance of the PAProjectAccessListType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAProjectAccess_Items | taPAProjectAccess_ItemsTaPAProjectAccess[] | A collection of nodes that create or update project access information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAProjectAccessListType


PAProjectBillingCyclesType Class

A class that represents the eConnect transaction type you use to specify the billing cycle for a project.

Constructor

Name | Description
PAProjectBillingCyclesType() | Initializes an instance of the PAProjectBillingCyclesType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAProjectBillingCycle_Items | taPAProjectBillingCycle_ItemsTaPAProjectBillingCycle[] | A collection of nodes that create one or more project billing cycles.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAProjectBillingCyclesType


PAProjectBudgetMasterType Class

A class that represents the eConnect transaction type you use to specify the project budget.

Constructor

Name | Description
PAProjectBudgetMasterType() | Initializes an instance of the PAProjectBudgetMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAProjectBudgetMaster_Items | taPAProjectBudgetMaster_ItemsTaPAProjectBudgetMaster[] | A collection of nodes that specify one or more project budgets.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAProjectBudgetMasterType


PAProjectEquipmentListType Class

A class that represents the eConnect transaction type you use to specify the equipment list for a project.

Constructor

Name | Description
PAProjectEquipmentListType() | Initializes an instance of the PAProjectEquipmentListType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAProjectEquip_Items | taPAProjectEquip_ItemsTaPAProjectEquip[] | A collection of nodes that specify a project equipment list.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAProjectEquipmentListType


PAProjectFeesType Class

A class that represents the eConnect transaction type you use to specify the fees for a project.

Constructor

Name | Description
PAProjectFeesType() | Initializes an instance of the PAProjectFeesType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAProjectFeeSchedule_Items | taPAProjectFeeSchedule_ItemsTaPAProjectFeeSchedule[] | A collection of nodes that specify a project fee schedule.
taPAProjectFee_Items | taPAProjectFee_ItemsTaPAProjectFee[] | A collection of nodes that specify one or more project fees.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAProjectFeesType


PAProjectsType Class

A class that represents the eConnect transaction type you use to specify a project.

Constructor

Name | Description
PAProjectsType() | Initializes an instance of the PAProjectsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPAAccountsSetup_Items | taPAAccountsSetup_ItemsTaPAAccountsSetup[] | A collection of nodes that create one or more project accounts.
taPAProjectAccess_Items | taPAProjectAccess_ItemsTaPAProjectAccess[] | A collection of nodes that create or update project access information.
taPAProjectBillingCycle_Items | taPAProjectBillingCycle_ItemsTaPAProjectBillingCycle[] | A collection of nodes that create one or more project billing cycles.
taPAProjectBudgetMaster_Items | taPAProjectBudgetMaster_ItemsTaPAProjectBudgetMaster[] | A collection of nodes that specify one or more project budgets.
taPAProjectEquip_Items | taPAProjectEquip_ItemsTaPAProjectEquip[] | A collection of nodes that specify a project equipment list.
taPAProjectFeeSchedule_Items | taPAProjectFeeSchedule_ItemsTaPAProjectFeeSchedule[] | A collection of nodes that specify a project fee schedule.
taPAProjectFee_Items | taPAProjectFee_ItemsTaPAProjectFee[] | A collection of nodes that specify one or more project fees.
taPAProjects_Items | taPAProjects_ItemsTaPAProjects[] | A collection of nodes that specify project items.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PAProjectsType


PATimeSheetsType Class

A class that represents the eConnect transaction type you use to specify a times sheet for a project.

Constructor

Name | Description
PATimeSheetsType() | Initializes an instance of the PATimeSheetsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPATimeSheetHdrInsert | taPATimeSheetHdrInsert | A node that creates a project time sheet header.
taPATimeSheetLineInsert_Items | taPATimeSheetLineInsert_ItemsTaPATimeSheetLineInsert[] | A collection of nodes that create one or more project time sheet lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PATimeSheetsType


PMCreateBuyerType Class

A class that represents the eConnect transaction type you use to create a buyer.

Constructor

Name | Description
PMCreateBuyerType() | Initializes an instance of the PMCreateBuyerType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateBuyer | taCreateBuyer | A node that creates a buyer.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PMCreateBuyerType


PMDeleteVendorAddressType Class

A class that represents the eConnect transaction type you use to remove vendor address information.

Constructor

Name | Description
PMDeleteVendorAddressType() | Initializes an instance of the PMDeleteVendorAddressType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteVendorAddress | taDeleteVendorAddress | A node that specifies the vendor address to remove.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PMDeleteVendorAddressType


PMManualCheckType Class

A class that represents the eConnect transaction type you use to create a manual check for a payment.

Constructor

Name | Description
PMManualCheckType() | Initializes an instance of the PMManualCheckType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taPMDistribution_Items | taPMDistribution_ItemsTaPMDistribution[] | A collection of nodes that create one or more payables distributions.
taPMManualCheck | taPMManualCheck | A node that creates a payables manual check.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateVendorRcd | taUpdateCreateVendorRcd | A node that creates or updates a vendor.

See Also

PMManualCheckType


PMScheduledPaymentsType Class

A class that represents the eConnect transaction type you use to specify a payment schedule.

Constructor

Name | Description
PMScheduledPaymentsType() | Initializes an instance of the PMScheduledPaymentsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPMSchedPmnts | taPMSchedPmnts | A node that specifies a payables payment schedule.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PMScheduledPaymentsType


PMTransactionType Class

A class that represents the eConnect transaction type you use to specify a payment transaction.

Constructor

Name | Description
PMTransactionType() | Initializes an instance of the PMTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taPMDistribution_Items | taPMDistribution_ItemsTaPMDistribution[] | A collection of nodes that create one or more payables distributions.
taPMTransactionInsert | taPMTransactionInsert | A node that specifies a payables transaction.
taPMTransactionTaxInsert_Items | taPMTransactionTaxInsert_ItemsTaPMTransactionTaxInsert[] | A collection of nodes that create payables tax information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateVendorRcd | taUpdateCreateVendorRcd | A node that creates or updates a vendor.

See Also

PMTransactionType


PMVendorAddressType Class

A class that represents the eConnect transaction type you use to specify the address of a vendor.

Constructor

Name | Description
PMVendorAddressType() | Initializes an instance of the PMVendorAddressType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

PMVendorAddressType


PMVendorMasterType Class

A class that represents the eConnect transaction type you use to specify a vendor.

Constructor

Name | Description
PMVendorMasterType() | Initializes an instance of the PMVendorMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreatePAVendorRcd | taUpdateCreatePAVendorRcd | A node that creates or update a project vendor.
taUpdateCreateVendorRcd | taUpdateCreateVendorRcd | A node that creates or updates a vendor.

See Also

PMVendorMasterType


POPDocumentDeleteType Class

A class that represents the eConnect transaction type you use to remove an existing purchase order.

Constructor

Name | Description
POPDocumentDeleteType() | Initializes an instance of the POPDocumentDeleteType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPopPoDelete | taPopPoDelete | A node that removes a specified purchase order.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

POPDocumentDeleteType


POPDocumentVoidType Class

A class that represents the eConnect transaction type you use to void an existing purchase order

Constructor

Name | Description
POPDocumentVoidType() | Initializes an instance of the POPDocumentVoidType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPopPoVoid | taPopPoVoid | A node that voids a specified purchase order.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

POPDocumentVoidType


POPEnterMatchInvoiceType Class

A class that represents the eConnect transaction type you use to specify a purchase order invoice.

Constructor

Name | Description
POPEnterMatchInvoiceType() | Initializes an instance of the POPEnterMatchInvoiceType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taPopDistribution_Items | taPopDistribution_ItemsTaPopDistribution[] | A collection of nodes that create one or more purchase order distributions.
taPopEnterMatchInvHdr | taPopEnterMatchInvHdr | A node that creates or updates a purchase order invoice header.
taPopEnterMatchInvLine_Items | taPopEnterMatchInvLine_ItemsTaPopEnterMatchInvLine[] | A collection of nodes that create or update one or more purchase order invoice lines.
taPopEnterMatchInvToShpMultiLine_Items | taPopEnterMatchInvToShpMultiLine_ItemsTaPopEnterMatchInvToShpMultiLine[] | A collection of nodes that create or update one or more purchase order invoice multiple shipment lines.
taPopEnterMatchLotInsert_Items | taPopEnterMatchLotInsert_ItemsTaPopEnterMatchLotInsert[] | A collection of nodes that create or update one or more purchase order lot lines.
taPopEnterMatchSerialInsert_Items | taPopEnterMatchSerialInsert_ItemsTaPopEnterMatchSerialInsert[] | A collection of nodes that create or update one or more purchase order serial lines.
taPopRcptLineTaxInsert_Items | taPopRcptLineTaxInsert_ItemsTaPopRcptLineTaxInsert[] | A collection of nodes that create one or more purchase order receipt tax lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateItemRcd | taUpdateCreateItemRcd | A node that creates or updates an inventory item.
taUpdateCreateVendorRcd | taUpdateCreateVendorRcd | A node that creates or updates a vendor.

See Also

POPEnterMatchInvoiceType


POPMapSitesType Class

A class that represents the eConnect transaction type you use to specify a site.

Constructor

Name | Description
POPMapSitesType() | Initializes an instance of the POPMapSitesType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPOPMapSites | taPOPMapSites | A node that creates a purchase order site.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

POPMapSitesType


POPReceivingsType Class

A class that represents the eConnect transaction type you use to specify a purchase order receipt.

Constructor

Name | Description
POPReceivingsType() | Initializes an instance of the POPReceivingsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taPopDistribution_Items | taPopDistribution_ItemsTaPopDistribution[] | A collection of nodes that create one or more purchase order distributions.
taPopRcptHdrInsert | taPopRcptHdrInsert | A node that creates a purchase order receipt header.
taPopRcptLineInsert_Items | taPopRcptLineInsert_ItemsTaPopRcptLineInsert[] | A collection of nodes that create one or more purchase order receipt lines.
taPopRcptLineTaxInsert_Items | taPopRcptLineTaxInsert_ItemsTaPopRcptLineTaxInsert[] | A collection of nodes that creates one or more purchase order receipt tax lines.
taPopRcptLotInsert_Items | taPopRcptLotInsert_ItemsTaPopRcptLotInsert[] | A collection of nodes that create one or more purchase order receipt lot lines.
taPopRcptMultiBin_Items | taPopRcptMultiBin_ItemsTaPopRcptMultiBin[] | A collection of nodes that specify one or more purchase order multibin receivings.
taPopRcptSerialInsert_Items | taPopRcptSerialInsert_ItemsTaPopRcptSerialInsert[] | A collection of nodes that create one or more purchase order receipt serial lines.
taPopRctUserDefined | taPopRctUserDefined | A node that creates a user defined purchase order receipt.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateItemRcd | taUpdateCreateItemRcd | A node that creates or updates an inventory item.
taUpdateCreateVendorRcd | taUpdateCreateVendorRcd | A node that creates or updates a vendor.

See Also

POPReceivingsType


POPTransactionType Class

A class that represents the eConnect transaction type you use to specify a purchase order transaction.

Constructor

Name | Description
POPTransactionType() | Initializes an instance of the POPTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateCustomerAddress_Items | taCreateCustomerAddress_ItemsTaCreateCustomerAddress[] | A collection of nodes that create one or more customer addresses.
taCreateVendorAddress_Items | taCreateVendorAddress_ItemsTaCreateVendorAddress[] | A collection of nodes that create one or more vendor addresses.
taPoHdr | taPoHdr | A node that specifies a purchase order header.
taPoLine_Items | taPoLine_ItemsTaPoLine[] | A collection of nodes that specify one or more purchase order lines.
taPopDistribution_Items | taPopDistribution_ItemsTaPopDistribution[] | A collection of nodes that create one or more purchase order distributions.
taPopIvcTaxInsert_Items | taPopIvcTaxInsert_ItemsTaPopIvcTaxInsert[] | A collection of nodes that create one or more purchase order tax lines.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateCustomerRcd | taUpdateCreateCustomerRcd | A node that creates or updates a customer.
taUpdateCreateItemRcd | taUpdateCreateItemRcd | A node that creates or updates an inventory item.
taUpdateCreateVendorRcd | taUpdateCreateVendorRcd | A node that creates or updates a vendor.

See Also

POPTransactionType


POPtoSOPLinkRemoveType Class

A class that represents the eConnect transaction type you use to remove a POP to SOP link.

Constructor

Name | Description
POPtoSOPLinkRemoveType() | Initializes an instance of the POPtoSOPLinkRemoveType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taPopRemoveSopLink | taPopRemoveSopLink | A node that removes specified POP to SOP link.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

POPtoSOPLinkRemoveType


RMApplyType Class

A class that represents the eConnect transaction type you use to apply credit memos, returns, and cash receipts to invoices.

Constructor

Name | Description
RMApplyType() | Initializes an instance of the RMApplyType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taRMApply | taRMApply | A node that specifies a receivables apply.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMApplyType


RMCashReceiptsType Class

A class that represents the eConnect transaction type you use to specify a cash receipt.

Constructor

Name | Description
RMCashReceiptsType() | Initializes an instance of the RMCashReceiptsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateCustomerAddress_Items | taCreateCustomerAddress_ItemsTaCreateCustomerAddress[] | A collection of nodes that create one or more customer addresses.
taRMCashReceiptInsert | taRMCashReceiptInsert | A collection of nodes that specify one or more cash receipts.
taRMDistribution_Items | taRMDistribution_ItemsTaRMDistribution[] | A collection of nodes that create one or more receivables distributions.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateCustomerRcd | taUpdateCreateCustomerRcd | A node that creates or updates a customer.

See Also

RMCashReceiptsType


RMCreateCustomerItemsType Class

A class that represents the eConnect transaction type you use to associate an inventory item with a customer.

Constructor

Name | Description
RMCreateCustomerItemsType() | Initializes an instance of the RMCreateCustomerItemsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateCustomerItems_Items | taCreateCustomerItems_ItemsTaCreateCustomerItems[] | A collection of nodes that associate customers with items.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMCreateCustomerItemsType


RMCreateParentIDType Class

A class that represents the eConnect transaction type you use to create a parent record for a national account.

Constructor

Name | Description
RMCreateParentIDType() | Initializes an instance of the RMCreateParentIDType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateParentID | taCreateParentID | A node that creates a parent ID for a national account.
taParentIDChild_Items | taParentIDChild_ItemsTaParentIDChild[] | A collection of nodes that associate one or more child accounts with a parent national account.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMCreateParentIDType


RMCustomerAddressType Class

A class that represents the eConnect transaction type you use to create or updates a customer address record.

Constructor

Name | Description
RMCustomerAddressType() | Initializes an instance of the RMCustomerAddressType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateCustomerAddress_Items | taCreateCustomerAddress_ItemsTaCreateCustomerAddress[] | A collection of nodes that create one or more customer addresses.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMCustomerAddressType


RMCustomerClassType Class

A class that represents the eConnect transaction type you use to specify a customer class.

Constructor

Name | Description
RMCustomerClassType() | Initializes an instance of the RMCustomerClassType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateCustomerClass | taCreateCustomerClass | A node that creates a customer class.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMCustomerClassType


RMCustomerMasterType Class

A class that represents the eConnect transaction type you use to specify a customer.

Constructor

Name | Description
RMCustomerMasterType() | Initializes an instance of the RMCustomerMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateCustomerAddress_Items | taCreateCustomerAddress_ItemsTaCreateCustomerAddress[] | A collection of nodes that create one or more customer addresses.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taCreateParentID | taCreateParentID | A node that creates a parent ID for a national account.
taParentIDChild_Items | taParentIDChild_ItemsTaParentIDChild[] | A collection of nodes that associate one or more child accounts with a parent national account.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateCustomerRcd | taUpdateCreateCustomerRcd | A node that creates or updates a customer.

See Also

RMCustomerMasterType


RMDeleteCustomerAddressType Class

A class that represents the eConnect transaction type you use to remove a customer address record.

Constructor

Name | Description
RMDeleteCustomerAddressType() | Initializes an instance of the RMDeleteCustomerAddressType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteCustomerAddress | taDeleteCustomerAddress | A node that removes a specified customer address.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMDeleteCustomerAddressType


RMDeleteCustomerType Class

A class that represents the eConnect transaction type you use to remove a customer record.

Constructor

Name | Description
RMDeleteCustomerType() | Initializes an instance of the RMDeleteCustomerType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteCustomerRcd | taDeleteCustomerRcd | A node that removes a specified customer.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMDeleteCustomerType


RMDeleteSalespersonType Class

A class that represents the eConnect transaction type you use to remove a salesperson record.

Constructor

Name | Description
RMDeleteSalespersonType() | Initializes an instance of the RMDeleteSalespersonType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteSalespersonRcd | taDeleteSalespersonRcd | A node that removes a specified salesperson.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMDeleteSalespersonType


RMParentIDChildType Class

A class that represents the eConnect transaction type you use to specify a child member of a national account.

Constructor

Name | Description
RMParentIDChildType() | Initializes an instance of the RMParentIDChildType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taParentIDChild_Items | taParentIDChild_ItemsTaParentIDChild[] | A collection of nodes that associate one or more child accounts with a parent national account.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMParentIDChildType


RMProspectMasterType Class

A class that represents the eConnect transaction type you use to specify a sales prospect.

Constructor

Name | Description
RMProspectMasterType()( | Initializes an instance of the RMProspectMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateProspect | taCreateProspect | A node that creates a prospect ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMProspectMasterType


RMSalespersonMasterType Class

A class that represents the eConnect transaction type you use to create or update a salesperson.

Constructor

Name | Description
RMSalespersonMasterType() | Initializes an instance of the RMSalespersonMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taCreateSalesperson | taCreateSalesperson | A node that creates a salesperson.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMSalespersonMasterType


RMScheduledPaymentsType Class

A class that represents the eConnect transaction type you use to specify a receivables payment schedule.

Constructor

Name | Description
RMScheduledPaymentsType() | Initializes an instance of the RMScheduledPaymentsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRMSchedPmnts | taRMSchedPmnts | A node that creates a receivables payment schedule.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMScheduledPaymentsType


RMTerritoryMasterType Class

A class that represents the eConnect transaction type you use to create a sales territory record.

Constructor

Name | Description
RMTerritoryMasterType() | Initializes an instance of the RMTerritoryMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateTerritory | taCreateTerritory | A node that creates a sales territory ID.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMTerritoryMasterType


RMTransactionType Class

A class that represents the eConnect transaction type you use to specify a receivables transaction.

Constructor

Name | Description
RMTransactionType() | Initializes an instance of the RMTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateCustomerAddress_Items | taCreateCustomerAddress_ItemsTaCreateCustomerAddress[] | A collection of nodes that create one or more customer addresses.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taRMCommissions_Items | taRMCommissions_ItemsTaRMCommissions[] | A collection of nodes that create one or more sales commission records.
taRMDistribution_Items | taRMDistribution_ItemsTaRMDistribution[] | A collection of nodes that create one or more receivables distributions.
taRMTransaction | taRMTransaction | A node that specifies a receivables transaction.
taRMTransactionTaxInsert_Items | taRMTransactionTaxInsert_ItemsTaRMTransactionTaxInsert[] | A collection of nodes that create tax information for a receivables transaction.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taUpdateCreateCustomerRcd | taUpdateCreateCustomerRcd | A node that creates or updates a customer.

See Also

RMTransactionType


RMUnapplyTransactionType Class

A class that represents the eConnect transaction type you use to reverse a receivables transaction.

Constructor

Name | Description
RMUnapplyTransactionType() | Initializes an instance of the RMUnapplyTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taRMUnapplyTransaction | taRMUnapplyTransaction | A node that unapplies a receivables transaction.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMUnapplyTransactionType


RMVoidTransactionType Class

A class that represents the eConnect transaction type you use to void a receivables transaction.

Constructor

Name | Description
RMVoidTransactionType()( | Initializes an instance of the RMVoidTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRMVoidTransaction | taRMVoidTransaction | A node that voids a receivables transaction.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RMVoidTransactionType


RQeConnectOutType Class

A class that represents the eConnect transaction type you use to specify the data records to rerieve using the eConnect Transaction Requester.

Constructor

Name | Description
RQeConnectOutType() | Initializes an instance of the RQeConnectOutType class.

Properties

Name | Type | Description
eConnectOut | eConnectOut | A node that specifies the data to retrieve.
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

RQeConnectOutType


SMMdaType Class

A class that represents the eConnect transaction type you use to update a MDA eConnect transaction type.

Constructor

Name | Description
SMMdaType() | Initializes an instance of the SMMdaType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

SMMdaType


SMTransactionBatchType Class

A class that represents the eConnect transaction type you use to create a batch.

Constructor

Name | Description
SMTransactionBatchType() | Initializes an instance of the SMTransactionBatchType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateUpdateBatchHeaderRcd | taCreateUpdateBatchHeaderRcd | A collection of nodes that create or update one or more batch headers.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

SMTransactionBatchType


SOPDeleteDocumentType Class

A class that represents the eConnect transaction type you use to remove a sales order.

Constructor

Name | Description
SOPDeleteDocumentType() | Initializes an instance of the SOPDeleteDocumentType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopDeleteDocument | taSopDeleteDocument | A node that removes a sales document.

See Also

SOPDeleteDocumentType


SOPDeleteLineType Class

A class that represents the eConnect transaction type you use to remove a sales line from a sales document.

Constructor

Name | Description
SOPDeleteLineType() | Initializes an instance of the SOPDeleteLineType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopLineDelete | taSopLineDelete | A collection of nodes that remove one or more sales invoice lines.

See Also

SOPDeleteLineType


SOPDistributionsType Class

A class that represents the eConnect transaction type you use to specify a sales order distribution.

Constructor

Name | Description
SOPDistributionsType() | Initializes an instance of the SOPDistributionsType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopDistribution_Items | taSopDistribution_ItemsTaSopDistribution[] | A collection of nodes that create one or more sales order distributions.

See Also

SOPDistributionsType


SOPLineComponentType Class

A class that represents the eConnect transaction type you use to create or update the components of a sales line.

Constructor

Name | Description
SOPLineComponentType() | Initializes an instance of the SOPLineComponentType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopLineIvcInsertComponent_Items | taSopLineIvcInsertComponent_ItemsTaSopLineIvcInsertComponent[] | A collection of nodes that specify one or more components for a sales invoice line.

See Also

SOPLineComponentType


SOPProcessHoldMasterType Class

A class that represents the eConnect transaction type you use to create or update a sales process hold.

Constructor

Name | Description
SOPProcessHoldMasterType() | Initializes an instance of the SOPProcessHoldMasterType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateProcessHold | taCreateProcessHold | A node that creates a process hold.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

SOPProcessHoldMasterType


SOPProcessHoldType Class

A class that represents the eConnect transaction type you use to create or update a sales process hold.

Constructor

Name | Description
SOPProcessHoldType() | Initializes an instance of the SOPProcessHoldType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopUpdateCreateProcessHold | taSopUpdateCreateProcessHold | A node that creates a sales order process hold.

See Also

SOPProcessHoldType


SOPSerialType Class

A class that represents the eConnect transaction type you use to create or update a serial sales order.

Constructor

Name | Description
SOPSerialType() | Initializes an instance of the SOPSerialType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopSerial_Items | taSopSerial_ItemsTaSopSerial[] | A collection of nodes that specifies the serial numbers of lines from a sales document.

See Also

SOPSerialType


SOPTransactionType Class

A class that represents the eConnect transaction type you use to specify a sales order.

Constructor

Name | Description
SOPTransactionType() | Initializes an instance of the SOPTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taAnalyticsDistribution_Items | taAnalyticsDistribution_ItemsTaAnalyticsDistribution[] | A collection of nodes that specify one or more analytical accounting distributions.
taCreateCustomerAddress_Items | taCreateCustomerAddress_ItemsTaCreateCustomerAddress[] | A collection of nodes that create one or more customer addresses.
taCreateSOPTrackingInfo | taCreateSOPTrackingInfo | A node that creates tracking information for a sales order.
taCreateSopPaymentInsertRecord_Items | taCreateSopPaymentInsertRecord_ItemsTaCreateSopPaymentInsertRecord[] | A collection of nodes that create one or more sales order payments.
taMdaUpdate_Items | taMdaUpdate_ItemsTaMdaUpdate[] | A collection of nodes that specify one or more MDA updates.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopCommissions_Items | taSopCommissions_ItemsTaSopCommissions[] | A collection of nodes that create one or more sales order commissions.
taSopDistribution_Items | taSopDistribution_ItemsTaSopDistribution[] | A collection of nodes that create one or more sales order distributions.
taSopHdrIvcInsert | taSopHdrIvcInsert | A node that creates a sales invoice header.
taSopLineIvcInsertComponent_Items | taSopLineIvcInsertComponent_ItemsTaSopLineIvcInsertComponent[] | A collection of nodes that specify one or more components for a sales invoice line.
taSopLineIvcInsert_Items | taSopLineIvcInsert_ItemsTaSopLineIvcInsert[] | A collection of nodes that create one or more sales invoice lines.
taSopLineIvcTaxInsert_Items | taSopLineIvcTaxInsert_ItemsTaSopLineIvcTaxInsert[] | A collection of nodes that specify tax information for a sales invoice line.
taSopLotAuto_Items | taSopLotAuto_ItemsTaSopLotAuto[] | A collection of nodes that specify a sales lot.
taSopMultiBin_Items | taSopMultiBin_ItemsTaSopMultiBin[] | A collection of nodes that specify a multibin sales order.
taSopSerial_Items | taSopSerial_ItemsTaSopSerial[] | A collection of nodes that specify the serial number of line from a sales document.
taSopToPopLink | taSopToPopLink | A node that specifies a SOP to POP link.
taSopTrackingNum_Items | taSopTrackingNum_ItemsTaSopTrackingNum[] | A collection of nodes that create one or more sales order tracking numbers.
taSopUpdateCreateProcessHold | taSopUpdateCreateProcessHold | A node that creates a sales order process hold.
taSopUserDefined | taSopUserDefined | A node that creates a user defined sales order document.
taUpdateCreateCustomerRcd | taUpdateCreateCustomerRcd | A node that creates or updates a customer.
taUpdateCreateItemRcd | taUpdateCreateItemRcd | A node that creates or updates an inventory item.

See Also

SOPTransactionType


SOPVoidDocumentType Class

A class that represents the eConnect transaction type you use to void a sales order.

Constructor

Name | Description
SOPVoidDocumentType() | Initializes an instance of the SOPVoidDocumentType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopVoidDocument | taSopVoidDocument | A node that voids a specified sales order document.

See Also

SOPVoidDocumentType


SOPtoPOPTransactionType Class

A class that represents the eConnect transaction type you use when you use a sales order to create a purchase order.

Constructor

Name | Description
SOPtoPOPTransactionType() | Initializes an instance of theSOPtoPOPTransactionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.
taSopToPopLink | taSopToPopLink | A node that specifies a SOP to POP link.

See Also

SOPtoPOPTransactionType


taAATrxDimCodeMaint Class

A class that represents the eConnect node you use to specify an analytical accounting transaction dimension code.

Constructor

Name | Description
taAATrxDimCodeMaint() | Initializes an instance of the taAATrxDimCodeMaint class.

Properties

Name | Type | Description
INACTIVE | int16 | Inactive
INACTIVESpecified | bool | Set to True when you assign a value to INACTIVE
NOTETEXT | string | Notes field
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
aaNode | string | Analytical accounting node
aaOwnedBy | string | Transaction dimension code owner
aaTrxDim | string | Analytical accounting transaction dimension
aaTrxDimCode | string | Analytical accounting transaction dimension code
aaTrxDimCodeDescr | string | Transaction dimension code description
aaTrxDimCodeDescr2 | string | Transaction dimension code description
aaUDFBoolean1 | int16 | User defined boolean field
aaUDFBoolean1Specified | bool | Set to True when you assign a value to aaUDFBoolean1
aaUDFBoolean2 | int16 | User defined boolean field
aaUDFBoolean2Specified | bool | Set to True when you assign a value to aaUDFBoolean2
aaUDFBoolean3 | int16 | User defined boolean field
aaUDFBoolean3Specified | bool | Set to True when you assign a value to aaUDFBoolean3
aaUDFBoolean4 | int16 | User defined boolean field
aaUDFBoolean4Specified | bool | Set to True when you assign a value to aaUDFBoolean4
aaUDFBoolean5 | int16 | User defined boolean field
aaUDFBoolean5Specified | bool | Set to True when you assign a value to aaUDFBoolean5
aaUDFDate1 | string | User defined date field
aaUDFDate2 | string | User defined date field
aaUDFDate3 | string | User defined date field
aaUDFDate4 | string | User defined date field
aaUDFDate5 | string | User defined date field
aaUDFNumeric1 | Decimal | User defined numeric field
aaUDFNumeric1Specified | bool | Set to True when you assign a value to aaUDFNumeric1
aaUDFNumeric2 | Decimal | User defined numeric field
aaUDFNumeric2Specified | bool | Set to True when you assign a value to aaUDFNumeric2
aaUDFNumeric3 | Decimal | User defined numeric field
aaUDFNumeric3Specified | bool | Set to True when you assign a value to aaUDFNumeric3
aaUDFNumeric4 | Decimal | User defined numeric field
aaUDFNumeric4Specified | bool | Set to True when you assign a value to aaUDFNumeric4
aaUDFNumeric5 | Decimal | User defined numeric field
aaUDFNumeric5Specified | bool | Set to True when you assign a value to aaUDFNumeric5
aaUDFText1 | string | User defined text field
aaUDFText2 | string | User defined text field
aaUDFText3 | string | User defined text field
aaUDFText4 | string | User defined text field
aaUDFText5 | string | User defined text field

See Also

<taAATrxDimCodeMaint>*


taAnalyticsDistribution_ItemsTaAnalyticsDistribution Class

A class that represents the eConnect node you use to specify an analytical accounting distribution.

Constructor

Name | Description
taAnalyticsDistribution_ItemsTaAnalyticsDistribution() | Initializes an instance of the taAnalyticsDistribution_ItemsTaAnalyticsDistribution class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTINDXSpecified | bool | Set to True when you assign a value to ACTINDX
ACTNUMST | string | Account number
AMOUNT | Decimal | Amount
AMOUNTSpecified | bool | Set to True when you assign a value to AMOUNT
DOCNMBR | string | Document number
DOCType | int16 | Document type
DistRef | string | Distribution reference
DistSequence | int32 | GL distribution sequence number
DistSequenceSpecified | bool | Set to True when you assign a value to DistSequence
NOTETEXT | string | Notes field
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
aaAssignedPercent | Decimal | Assigned percentage
aaAssignedPercentSpecified | bool | Set to True when you assign a value to aaAssignedPercent
aaSubLedgerAssignID | int32 | Subledger assign look up ID
aaSubLedgerDistID | int32 | Subledger distribution lookup ID
aaSubLedgerDistIDSpecified | bool | Set to True when you assign a value to aaSubLedgerDistID
aaSubLedgerHdrID | int32 | Subledger header lookup ID
aaSubLedgerHdrIDSpecified | bool | Set to True when you assign a value to aaSubLedgerHdrID
aaTrxCodeID | int32 | Transaction dimension code ID
aaTrxCodeIDSpecified | bool | Set to True when you assign a value to aaTrxCodeID
aaTrxDim | string | Transaction dimension
aaTrxDimCode | string | Transaction dimension alphanumeric code
aaTrxDimCodeBool | int16 | Transaction dimension boolean field
aaTrxDimCodeBoolSpecified | bool | Set to True when you assign a value to aaTrxDimCodeBool
aaTrxDimCodeDate | string | Transaction dimension date field
aaTrxDimCodeNum | Decimal | Transaction dimension numeric field
aaTrxDimCodeNumSpecified | bool | Set to True when you assign a value to aaTrxDimCodeNum
aaTrxDimID | int32 | Transaction dimension ID
aaTrxDimIDSpecified | bool | Set to True when you assign a value to aaTrxDimID

See Also

<taAnalyticsDistribution>*


taApplicantInterviewUpdate_ItemsTaApplicantInterviewUpdate Class

A class that represents the eConnect node you use to update interview information for an applicant.

Constructor

Name | Description
taApplicantInterviewUpdate_ItemsTaApplicantInterviewUpdate() | Initializes an instance of the taApplicantInterviewUpdate_ItemsTaApplicantInterviewUpdate class.

Properties

Name | Type | Description
APPINTTYPESTR_I | string | Interview type
APPLICANTNUMBER_I | Decimal | Applicant number
APPLYDATE_I | string | Interview date
CATEGORY_I | string | Category
CHANGEBY_I | string | Changed by
COMPANYCODE_I | string | Company ID
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
NOTE | string | Note
POSITIONCODE_I | string | Score
REVIEWSCORE_I | Decimal | Score
REVIEWSCORE_ISpecified | bool | Set to True when you assign a value to REVIEWSCORE_I
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taApplicantInterviewUpdate>*


taBRBankDepositsHeader Class

A class that represents the eConnect node you use to specify a bank depoost header.

Constructor

Name | Description
taBRBankDepositsHeader() | Initializes an instance of the taBRBankDepositsHeader class.

Properties

Name | Type | Description
CHEKBKID | string | Checkbook ID
CheckCount | int32 | Check count
CheckTotal | Decimal | Check total
CoinAmount | Decimal | Coin total
CreditCardCount | int32 | Credit card count
CreditCardTotal | Decimal | Credit card total
CurrencyAmount | int32 | Currency total
CurrencyCount | int32 | Currency count
DATELMTS | int16 | Date limits
DEPDATE | string | Deposit date
DEPType | int16 | Deposit type
DSCRIPTN | string | Description
DYSTINCR | int16 | Days to increment
DepAmt | Decimal | Deposit amount
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange ID description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
GLPOSTDT | string | General ledger posting date
MDFUSRID | string | Modified user ID
Option | int16 | Deposit option
PRVDSLMT | int16 | Previous days limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type ID
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculate method
RequesterTrx | int16 | Requester transaction
TIME1 | string | MC exchange time
TRXDTDEF | int16 | Transaction date default
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate
depositnumber | string | Deposit number

See Also

<taBRBankDepositsHeader>


taBRBankDepositsLine_ItemsTaBRBankDepositsLine Class

A class that represents the eConnect node you use to create a bank deposit line.

Constructor

Name | Description
taBRBankDepositsLine_ItemsTaBRBankDepositsLine() | Initializes an instance of the taBRBankDepositsLine_ItemsTaBRBankDepositsLine class.

Properties

Name | Type | Description
BANKNAME | string | Bank name
BNKBRNCH | string | Bank branch
CHEKBKID | string | Checkbook ID
CMRECNUM | Decimal | Receipt number
CMRECNUMSpecified | bool | Set the flag to True when you assign a value to the CMRECNUM
COINTOTAL | Decimal | Coin total
CURRENCYTOTAL | int32 | Currency total
DATELMTS | int16 | Date limits
DEPDATE | string | Deposit date
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange ID description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
PRVDSLMT | int16 | previous day limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type ID
RATEVARC | Decimal | Rate variance
RCPTNMBR | string | Receipt number
RTCLCMTD | int16 | Rate calculation method
RcpType | int16 | Receipt type
RcpTypeSpecified | bool | Set the flag to True when you assign a value to RcpType
RequesterTrx | int16 | Requester transaction
TIME1 | string | MC exchange time
TRXDTDEF | int16 | Transaction date default
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate
depositnumber | string | Deposit number

See Also

<taBRBankDepositsLine>


taBRBankTransactionDist_ItemsTaBRBankTransactionDist Class

A class that represents the eConnect node you use to specify a bank transaction distribution.

Constructor

Name | Description
taBRBankTransactionDist_ItemsTaBRBankTransactionDist() | Initializes an instance of the taBRBankTransactionDist_ItemsTaBRBankTransactionDist class.

Properties

Name | Type | Description
ACTNUMST | string | Account number
CRDTAMNT | Decimal | Credit amount
DEBITAMT | Decimal | Debit amount
DistRef | string | Distribution reference
Option | int16 | Transaction option
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taBRBankTransactionDist>


taBRBankTransactionHeader Class

A class that represents the eConnect node you use to specify a bank transaction header.

Constructor

Name | Description
taBRBankTransactionHeader() | Initializes an instance of the taBRBankTransactionHeader class.

Properties

Name | Type | Description
BACHNUMB | string | General ledger batch number
CARDNAME | string | Credit card name
CHEKBKID | string | Checkbook ID
CMTrxNum | string | Transaction number
CMTrxType | int16 | Transaction type
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limits
DSCRIPTN | string | Description
DYSTINCR | int16 | Days to increment
DistRef | string | Distribution reference
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange ID description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
GLPOSTDT | string | General ledger posting date
Option | int16 | Transaction option
PRVDSLMT | int16 | Previous day limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type ID
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RcpType | int16 | Receipt type
RequesterTrx | int16 | Requester transaction
TIME1 | string | Time
TRXAMNT | Decimal | transaction amount
TRXDATE | string | Transaction date
TRXDTDEF | int16 | Transaction date default
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate
paidtorcvdfrom | string | Paid to or received from

See Also

<taBRBankTransactionHeader>


taBRBankTransactionVoid Class

A class that represents the eConnect node you use to void a bank transaction.

Constructor

Name | Description
taBRBankTransactionVoid() | Initializes an instance of the taBRBankTransactionVoid class.

Properties

Name | Type | Description
BACHNUMB | string | General ledger batch number
CHEKBKID | string | Checkbook ID
CMDNUMWK | Decimal | Control number
CMTrxNum | string | Transaction number
CreateDist | int16 | Auto-create distribution
DistRef | string | Distribution reference
GLPOSTDT | string | General ledger posting date
Option | int16 | Transaction option
RequesterTrx | int16 | Requester transaction
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VOIDDATE | string | Void date
VOIDDESC | string | Void description

See Also

<taBRBankTransactionVoid>


taBRDeleteBankDeposits Class

A class that represents the eConnect node you use to delete a bank deposit.

Constructor

Name | Description
taBRDeleteBankDeposits() | Initializes an instance of the taBRDeleteBankDeposits class.

Properties

Name | Type | Description
CHEKBKID | string | Checkbook ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
depositnumber | string | Deposit number

See Also

<taBRDeleteBankDeposits>


taBRPostBankDeposits Class

A class that represents the eConnect node you use to post a bank deposit.

Constructor

Name | Description
taBRPostBankDeposits() | Initializes an instance of the taBRPostBankDeposits class.

Properties

Name | Type | Description
CHEKBKID | string | Checkbook ID
PTDUSRID | string | User ID for posting
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
depositnumber | string | deposit number

See Also

<taBRPostBankDeposits>


taCreateAccountCategory Class

A class that represents the eConnect node you use to create a general ledger account category.

Constructor

Name | Description
taCreateAccountCategory() | Initializes an instance of the taCreateAccountCategory class.

Properties

Name | Type | Description
ACCATDSC | string | Account category description
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateAccountCategory>


taCreateAccountCurrencies Class

A class that represents the eConnect node you use to create a general ledger account currency.

Constructor

Name | Description
taCreateAccountCurrencies() | Initializes an instance of the taCreateAccountCurrencies class.

Properties

Name | Type | Description
Account_Number | string | Account number
CURNCYID | string | Currency ID
Post_Results_To | int16 | Post results to
REVALUE | int16 | Revalue
REVLUHOW | int16 | Revalue how
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateAccountCurrencies>


taCreateAccountGroup Class

A class that represents the eConnect node you use to create a fixed asset account group.

Constructor

Name | Description
taCreateAccountGroup() | Initializes an instance of the taCreateAccountGroup class.

Properties

Name | Type | Description
ACCTGRPDESC | string | Account group description
ACCTGRPID | string | Account group ID
ASSETCOSTACCT | string | Asset cost account
CLEARINGACCT | string | Clearing account
DEPREXPACCT | string | Depreciation expense account
DEPRRESACCT | string | Depreciation reserve account
LASTMNTDDATE | string | Create date
LASTMNTDUSERID | string | User ID
NONRECOGGAINLOSSACCT | string | Non-recognized gain/loss account
PRIORYRDEPRACCT | string | Prior year depreciation account
PROCEEDSACCT | string | Proceeds account
RECOGGAINLOSSACCT | string | Recognized gain/loss account
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateAccountGroup>


taCreateApplicant Class

A class that represents the eConnect node you use to create an applicant.

Constructor

Name | Description
taCreateApplicant() | Initializes an instance of the taCreateApplicant class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
APPLYDATE_I | string | Application Date
CHANGEBY_I | string | Changed by
CHECKBOXES_I_1 | int16 | Checkbox 1
CHECKBOXES_I_1Specified | bool | Set to True when you assign a value to CHECKBOXES_I_1
CHECKBOXES_I_2 | int16 | Checkbox 2
CHECKBOXES_I_2Specified | bool | Set to True when you assign a value to CHECKBOXES_I_2
CHECKBOXES_I_3 | int16 | Checkbox 3
CHECKBOXES_I_3Specified | bool | Set to True when you assign a value to CHECKBOXES_I_3
CHECKBOXES_I_4 | int16 | Checkbox 4
CHECKBOXES_I_4Specified | bool | Set to True when you assign a value to CHECKBOXES_I_4
CHECKBOXES_I_5 | int16 | Checkbox 5
CHECKBOXES_I_5Specified | bool | Set to True when you assign a value to CHECKBOXES_I_5
CITY | string | City
COLORCODE_I | int16 | Color code
COLORCODE_ISpecified | bool | Set to True when you assign a value to COLORCODE_I
COMPANYCODE_I | string | Company ID
COUNTRY | string | Country
DATE1_I | string | Date 1
DATE2_I | string | Date 2
DATE3_I | string | Date 3
DATE4_I | string | Date 4
DATE5_I | string | Date 5
DEPARTMENTCODE_I | string | Department
DISABLEDVETERAN | int16 | Disabled veteran
DISABLEDVETERANSpecified | bool | Set to True when you assign a value to DISABLEDVETERAN
DIVISIONCODE_I | string | Division
DOLLARS_I_1 | Decimal | Currency 1
DOLLARS_I_1Specified | bool | Set to True when you assign a value to DOLLARS_I_1
DOLLARS_I_2 | Decimal | Currency 2
DOLLARS_I_2Specified | bool | Set to True when you assign a value to DOLLARS_I_2
DOLLARS_I_3 | Decimal | Currency 3
DOLLARS_I_3Specified | bool | Set to True when you assign a value to DOLLARS_I_3
DOLLARS_I_4 | Decimal | Currency 4
DOLLARS_I_4Specified | bool | Set to True when you assign a value to DOLLARS_I_4
DOLLARS_I_5 | Decimal | Currency 5
DOLLARS_I_5Specified | bool | Set to True when you assign a value to DOLLARS_I_5
DSCRIPTN | string | Rejection comments
EEOAGE_I | int16 | Age category
EEOAGE_ISpecified | bool | Set to True when you assign a value to EEOAGE_I
EEOETHNICORIGIN_I | int16 | Ethnic origin category
EEOETHNICORIGIN_ISpecified | bool | Set to True when you assign a value to EEOETHNICORIGIN_I
EXT_I | string | Telephone extension
FFIRSTNAME_I | string | First name
GENDERGB_I | int16 | Gender
GENDERGB_ISpecified | bool | Set to True when you assign a value to GENDERGB_I
HANDICAPPED | int16 | Handicapped
HANDICAPPEDSpecified | bool | Set to True when you assign a value to HANDICAPPED
HOMEPHONE | string | Telephone number
ISEQUENCENUMBER_I | int16 | Line sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
LOCATNID | string | Location
MIDLNAME | string | Middle name
NUMERICEXTRA_1 | int32 | Alpha/Numeric 1
NUMERICEXTRA_1Specified | bool | Set to True when you assign a value to NUMERICEXTRA_1
NUMERICEXTRA_2 | int32 | Alpha/Numeric 2
NUMERICEXTRA_2Specified | bool | Set to True when you assign a value to NUMERICEXTRA_2
NUMERICEXTRA_3 | int32 | Alpha/Numeric 3
NUMERICEXTRA_3Specified | bool | Set to True when you assign a value to NUMERICEXTRA_3
NUMERICEXTRA_4 | int32 | Alpha/Numeric 4
NUMERICEXTRA_4Specified | bool | Set to True when you assign a value to NUMERICEXTRA_4
NUMERICEXTRA_5 | int32 | Alpha/Numeric 5
NUMERICEXTRA_5Specified | bool | Set to True when you assign a value to NUMERICEXTRA_5
OTHERVET | int16 | Other veterans
OTHERVETSpecified | bool | Set to True when you assign a value to OTHERVET
POSITIONCODE_I | string | Position
REFERENCESOURCE_I | string | Referral source description
REFSOURCEDDL_I | int16 | Referral source category
REFSOURCEDDL_ISpecified | bool | Set to True when you assign a value to REFSOURCEDDL_I
REJECTREASON_I | int16 | Reject reason
REJECTREASON_ISpecified | bool | Set to True when you assign a value to REJECTREASON_I
RELOCATION_I | int16 | Relocation
RELOCATION_ISpecified | bool | Set to True when you assign a value to RELOCATION_I
REPLYLETTERSENT_I | int16 | Reply letter sent
REPLYLETTERSENT_ISpecified | bool | Set to True when you assign a value to REPLYLETTERSENT_I
REQUISITIONNUMBER_I | int32 | Requisition number
REQUISITIONNUMBER_ISpecified | bool | Set to True when you assign a value to REQUISITIONNUMBER_I
RequesterTrx | int16 | Requester transaction
SSN_I | string | Social security number
STATE | string | State
STATUS0_I | int16 | Status
STATUS0_ISpecified | bool | Set to True when you assign a value to STATUS0_I
STRINGS_I_1 | string | String 1
STRINGS_I_2 | string | String 2
STRINGS_I_3 | string | String 3
STRINGS_I_4 | string | String 4
STRINGS_I_5 | string | String 4
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VETERAN | int16 | Veteran
VETERANSpecified | bool | Set to True when you assign a value to VETERAN
VIETNAMVETERAN | int16 | Vietnam veteran
VIETNAMVETERANSpecified | bool | Set to True when you assign a value to VIETNAMVETERAN
WORKPHONE | string | Telephone number
ZIPCODE_I | string | Postal code

See Also

<taCreateApplicant>*


taCreateApplicantEducation Class

A class that represents the eConnect node you use to create education information for an applicant.

Constructor

Name | Description
taCreateApplicantEducation() | Initializes an instance of the taCreateApplicantEducation class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
CHANGEBY_I | string | Changed by
DEGREE | string | Degree
FFIRSTNAME_I | string | First name
GPA | string | Grade point average
GPABASE | string | GPA base
GRADUATIONYEAR | string | Graduation year
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
MAJOR | string | Major
NOTE | string | Notes
RequesterTrx | int16 | Requester transaction
UNIVERSITY | string | School
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateApplicantEducation>*


taCreateApplicantInterviewInsert Class

A class that represents the eConnect node you use to create interview information for an applicant.

Constructor

Name | Description
taCreateApplicantInterviewInsert() | Initializes an instance of the taCreateApplicantInterviewInsert class.

Properties

Name | Type | Description
APPINTTYPESTR_I | string | Interview type
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
APPLYDATE_I | string | Interview date
COMPANYCODE_I | string | Company ID
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
POSITIONCODE_I | string | Position
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateApplicantInterviewInsert>*


taCreateApplicantReferences Class

A class that represents the eConnect node you use to create reference information for an applicant.

Constructor

Name | Description
taCreateApplicantReferences() | Initializes an instance of the taCreateApplicantReferences class.

Properties

Name | Type | Description
ADDRESS1 | string | Address
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
CHANGEBY_I | string | Changed by
CITY | string | City
COMPANY_I | string | Company
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
NOTE | string | Notes
REFERENCENAME_I | string | Reference name
REFRELATIONSHIP_I | string | Reference relationship
RequesterTrx | int16 | Requester transaction
STATE | string | State
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
WORKPHONE | string | Telephone number
ZIPCODE_I | string | Postal code

See Also

<taCreateApplicantReferences>*


taCreateApplicantSkills Class

A class that represents the eConnect node you use to create skill information for an applicant.

Constructor

Name | Description
taCreateApplicantSkills() | Initializes an instance of the taCreateApplicantSkills class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
COMMENT20_I | string | Comments
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
POINTS_I | int32 | Proficiency
POINTS_ISpecified | bool | Set to True when you assign a value to POINTS_I
RequesterTrx | int16 | Requester transaction
SKILL | string | Skill
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateApplicantSkills>*


taCreateApplicantTests Class

A class that represents the eConnect node you use to create test information for an applicant.

Constructor

Name | Description
taCreateApplicantTests() | Initializes an instance of the taCreateApplicantTests class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | string | Set to True when you assign a value to APPLICANTNUMBER_I
CHANGEBY_I | string | Changed by
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
NOTE | string | Notes
RequesterTrx | int16 | Requester transaction
STRTDATE | string | Start date
TESTCODE_I | string | Test code
TESTSCORE_I | string | Test score
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateApplicantTests>*


taCreateApplicantWorkHistory Class

A class that represents the eConnect node you use to create work history information for an applicant.

Constructor

Name | Description
taCreateApplicantWorkHistory() | Initializes an instance of the taCreateApplicantWorkHistory class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
CHANGEBY_I | string | Changed by
COMPENSATIONPERIOD_I | int16 | Compensation period
COMPENSATIONPERIOD_ISpecified | bool | Set to True when you assign a value to COMPENSATIONPERIOD_I
ENDDATE | string | End date
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
NAME | string | Employer name
NOTE | string | Notes
POSITION_I | string | Position
RequesterTrx | int16 | Requester transaction
STRTDATE | string | Start date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
WAGE_I | Decimal | Wage
WAGE_ISpecified | bool | Set to True when you assign a value to WAGE_I
YEARSOFEXP_I | string | Years of experience

See Also

<taCreateApplicantWorkHistory>*


taCreateAssetBook Class

A class that represents the eConnect node you use to create a fixed asset book record.

Constructor

Name | Description
taCreateAssetBook() | Initializes an instance of the taCreateAssetBook class.

Properties

Name | Type | Description
AMORTIZATIONAMOUNT | Decimal | Amortization amount/percentage
AMORTIZATIONAMOUNTSpecified | bool | Set to True when you assign a value to AMORTIZATIONAMOUNT
AMORTIZATIONCODE | int16 | Amortization code
AMORTIZATIONCODESpecified | bool | Set to True when you assign a value to AMORTIZATIONCODE
ASSETID | string | Asset ID
ASSETIDSUF | int16 | Asset ID suffix
AVERAGINGCONV | int16 | Averaging convention
AVERAGINGCONVSpecified | bool | Set to True when you assign a value to AVERAGINGCONV
BOOKID | string | Book ID
COSTBASIS | Decimal | Cost basis
COSTBASISSpecified | bool | Set to True when you assign a value to COSTBASIS
DATEADDED | string | Date added
DEPRECIATIONMETHOD | int16 | Depreciation method
DEPRECIATIONMETHODSpecified | bool | Set to True when you assign a value to DEPRECIATIONMETHOD
DEPRTODATE | string | Depreciation to date
Initial_Allowance_Perc | Decimal | Initial allowance percentage
Initial_Allowance_PercSpecified | bool | Set to True when you assign a value to Initial_Allowance_Perc
LTDDEPRAMT | Decimal | LTD depreciation
LTDDEPRAMTSpecified | bool | Set to True when you assign a value to LTDDEPRAMT
LUXAUTOIND | int16 | Luxury auto
LUXAUTOINDSpecified | bool | Set to True when you assign a value to LUXAUTOIND
LUXELAUTO | int16 | Luxury electric auto
LUXELAUTOSpecified | bool | Set to True when you assign a value to LUXELAUTO
LUXVANTRUCK | int16 | Luxury van or truck
LUXVANTRUCKSpecified | bool | Set to True when you assign a value to LUXVANTRUCK
ORIGINALLIFEDAYS | int16 | Original life days
ORIGINALLIFEDAYSSpecified | bool | Set to True when you assign a value to ORIGINALLIFEDAYS
ORIGINALLIFEYEARS | int16 | Original life years
ORIGINALLIFEYEARSSpecified | bool | Set to True when you assign a value to ORIGINALLIFEYEARS
PLINSERVDATE | string | Placed in service date
SALVAGEVALUE | Decimal | Salvage value
SALVAGEVALUESpecified | bool | Set to True when you assign a value to SALVAGEVALUE
SPECDEPRALLOW | int16 | Special depreciation allowance
SPECDEPRALLOWPCT | Decimal | Special depreciation allowance percentage
SPECDEPRALLOWPCTSpecified | bool | Set to True when you assign a value to SPECDEPRALLOWPCT
SPECDEPRALLOWSpecified | bool | Set to True when you assign a value to SPECDEPRALLOW
SWITCHOVER | int16 | Switch over
SWITCHOVERSpecified | bool | Set to True when you assign a value to SWITCHOVER
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
YTDDEPRAMT | Decimal | Year-to-date depreciation
YTDDEPRAMTSpecified | bool | Set to True when you assign a value to YTDDEPRAMT

See Also

<taCreateAssetBook>


taCreateAssetBookITC Class

A class that represents the eConnect node you use to create a fixed asset ITC record.

Constructor

Name | Description
taCreateAssetBookITC() | Initializes an instance of the taCreateAssetBookITC class.

Properties

Name | Type | Description
ASSETID | string | Asset ID
ASSETIDSUF | int16 | Asset ID suffix
BOOKID | string | Book ID
ITCAMTALLOWED | Decimal | ITC amount allowed
ITCAMTALLOWEDSpecified | bool | Set to True when you assign a value to ITCAMTALLOWED
ITCAMTTAKEN | Decimal | ITC amount taken
ITCAMTTAKENSpecified | bool | Set to True when you assign a value to ITCAMTTAKEN
ITCCODEREDAMT | Decimal | ITC cost reduction amount
ITCCODEREDAMTSpecified | bool | Set to True when you assign a value to ITCCODEREDAMT
ITCRECAPTURE | Decimal | ITC recapture
ITCRECAPTURESpecified | bool | Set to True when you assign a value to ITCRECAPTURE
MISCCOSTADJ | Decimal | Miscellaneous cost adjustment
MISCCOSTADJSpecified | bool | Set to True when you assign a value to MISCCOSTADJ
ORGCOSTBASIS | Decimal | Original cost basis
ORGCOSTBASISSpecified | bool | Set to True when you assign a value to ORGCOSTBASIS
SECT179EXPDED | Decimal | Section 179 expense deduction
SECT179EXPDEDSpecified | bool | Set to True when you assign a value to SECT179EXPDED
TEFRAFLAG | int16 | TEFRA flag
TEFRAFLAGSpecified | bool | Set to True when you assign a value to TEFRAFLAG
USERWHOENTERED | string | USer who entered
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateAssetBookITC>


taCreateAssetClassID Class

A class that represents the eConnect node you use to create a fixed asset class ID.

Constructor

Name | Description
taCreateAssetClassID() | Initializes an instance of the taCreateAssetClassID class.

Properties

Name | Type | Description
ACCTGRPID | string | Account group ID
ASSETCLASSID | string | Asset class ID
ASSETCLASSIDDESC | string | Asset class description
INSCLASSID | string | Insurance class ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateAssetClassID>


taCreateAssetID Class

A class that represents the eConnect node you use to create an asset ID.

Constructor

Name | Description
taCreateAssetID() | Initializes an instance of the taCreateAssetID class.

Properties

Name | Type | Description
ACCTGRPID | string | Account group ID
ACQDATE | string | Acquisition date
ASSESSEDVALUE | Decimal | Assessed value
ASSESSEDVALUESpecified | bool | Set to True when you assign a value to ASSESSEDVALUE
ASSETBEGQTY | int32 | Asset beginning quantity
ASSETBEGQTYSpecified | bool | Set to True when you assign a value to ASSETBEGQTY
ASSETCLASSID | string | Asset class ID
ASSETCURRMAINT | Decimal | Current year maintenance
ASSETCURRMAINTSpecified | bool | Set to True when you assign a value to ASSETCURRMAINT
ASSETDESC | string | Asset description
ASSETID | string | Asset ID
ASSETIDSUF | int16 | Asset ID suffix
ASSETLTDMAINT | Decimal | LTD maintenance
ASSETLTDMAINTSpecified | bool | Set to True when you assign a value to ASSETLTDMAINT
ASSETQTY | int32 | Asset quantity
ASSETQTYSpecified | bool | Set to True when you assign a value to ASSETQTY
ASSETSTATUS | int16 | Asset status
ASSETSTATUSSpecified | bool | Set to True when you assign a value to ASSETSTATUS
ASSETType | int16 | Asset type
ASSETTypeSpecified | bool | Set to True when you assign a value to ASSETTYPE
ASSETYTDMAINT | Decimal | YTD maintenance
ASSETYTDMAINTSpecified | bool | Set to True when you assign a value to ASSETYTDMAINT
Acquisition_Cost | Decimal | Acquisition cost
Acquisition_CostSpecified | bool | Set to True when you assign a value to Acquisition_Cost
Asset_Label | string | Asset label
CUSTODIAN | string | Custodian
DATEADDED | string | Date added
DELETEDATE | string | Date deleted
EXTASSETDESC | string | Extended asset description
LASTMAINTDATE | string | Last maintenance date
LOCATNID | string | Location ID
MFGRNAME | string | Manufacturer name
MODELNUMBER | string | Model number
Master_Asset_ID | string | Master asset ID
PIN | string | PIN
PROPType | int16 | Property type
PROPTypeSpecified | bool | Set to True when you assign a value to PROPType
Physical_Location_ID | string | Physical location ID
SERLNMBR | string | Serial number
SHRTNAME | string | Short name
STRUCTUREID | string | Structure ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
Verified_Date | string | Verified date
WARRENTYDATE | string | Warranty date

See Also

<taCreateAssetID>*


taCreateAssetInsurance Class

A class that represents the eConnect node you use to create asset insurance entry.

Constructor

Name | Description
taCreateAssetInsurance() | Initializes an instance of the taCreateAssetInsurance class.

Properties

Name | Type | Description
ASSETID | string | Asset ID
ASSETIDSUF | int16 | Asset ID suffix
DEPRREPROCOST | Decimal | Depreciation reduction cost
EXCLUSIONAMT | Decimal | Exclusion amount
EXCLUSIONType | string | Exclusion type
INSURANCECLASS | string | Insurance class ID
INSURANCEVALUE | Decimal | Insurance value
INSURANCEYEAR | int16 | Insurance year
REPLACEMENTCOST | Decimal | Replacement cost
REPROCOST | Decimal | Reproduction cost
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateAssetInsurance>


taCreateAssetLease Class

A class that represents the eConnect node you use to create an asset lease.

Constructor

Name | Description
taCreateAssetLease() | Initializes an instance of the taCreateAssetLease class.

Properties

Name | Type | Description
ASSETID | string | Asset ID
ASSETIDSUF | int16 | Asset ID suffix
LEASECOMPID | string | Lease company ID
LEASECONTRACTID | string | Contract ID
LEASEENDDATE | string | End date
LEASEINTRATE | int16 | Interest rate
LEASEPAYMENT | Decimal | Lease payment
LEASEType | int16 | Lease type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateAssetLease>


taCreateAssetPurchase Class

A class that represents the eConnect node you use to create asset purchase information.

Constructor

Name | Description
taCreateAssetPurchase() | Initializes an instance of the taCreateAssetPurchase class.

Properties

Name | Type | Description
ASSETID | string | Asset ID
ASSETIDSUF | int16 | Asset suffix ID
Acquisition_Cost | Decimal | Acquisition cost
Acquisition_CostSpecified | bool | Set to True when you assign a value to Acquisition_Cost
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limits
DATELMTSSpecified | bool | Set to True when you assign a value to DATELMTS
DOCDATE | string | Document date
DOCNUMBR | string | Document number
DYSTINCR | int16 | Days to increment
DYSTINCRSpecified | bool | Set to True when you assign a value to DYSTINCR
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange ID description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
ORCTRNUM | string | Voucher or receipt number
PORDNMBR | string | Purchase order number
PRVDSLMT | int16 | Previous days limits
PRVDSLMTSpecified | bool | Set to True when you assign a value to PRVDSLMT
PURCHDESC | string | Purchase description
PURCHLINESEQ | int32 | Purchase line sequence number
PURCHLINESEQSpecified | bool | Set to True when you assign a value to PURCHLINESEQ
RATEEXPR | int16 | Rate Expiration
RATEEXPRSpecified | bool | Set to True when you assign a value to RATEEXPR
RATETPID | string | Rate type ID
RATEVARC | Decimal | Rate variance
RATEVARCSpecified | bool | Set to True when you assign a value to RATEVARC
RTCLCMTD | int16 | Rate calculation method
RTCLCMTDSpecified | bool | Set to True when you assign a value to RTCLCMTD
TIME1 | string | Time 1
TRXDTDEF | int16 | Transaction date default
TRXDTDEFSpecified | bool | Set to True when you assign a value to TRXDTDEF
TRXSORCE | string | Transaction source
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
XCHGRATE | Decimal | Exchange rate

See Also

<taCreateAssetPurchase>


taCreateAssetUserData Class

A class that represents the eConnect node you use to create asset user information.

Constructor

Name | Description
taCreateAssetUserData() | Initializes an instance of the taCreateAssetUserData class.

Properties

Name | Type | Description
ASSETID | string | Asset ID
ASSETIDSUF | int16 | Asset ID suffix
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
USRFIELD1 | string | User-defined field
USRFIELD2 | string | User-defined field
USRFIELD3 | string | User-defined field
USRFIELD4 | string | User-defined field
USRFIELD5 | string | User-defined field
USRFIELD6 | string | User-defined field
USRFIELD7 | string | User-defined field
USRFIELD8 | string | User-defined field
USRFIELD9 | string | User-defined field
USRFIELD10 | string | User-defined field
USRFIELD11 | Decimal | User-defined field
USRFIELD11Specified | bool | Set to True when you assign a value to USRFIELD11
USRFIELD12 | Decimal | User-defined field
USRFIELD12Specified | bool | Set to True when you assign a value to USRFIELD12
USRFIELD13 | Decimal | User-defined field
USRFIELD13Specified | bool | Set to True when you assign a value to USRFIELD13
USRFIELD14 | Decimal | User-defined field
USRFIELD14Specified | bool | Set to True when you assign a value to USRFIELD14
USRFIELD15 | Decimal | User-defined field
USRFIELD15Specified | bool | Set to True when you assign a value to USRFIELD15
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateAssetUserData>*


taCreateBank Class

A class that represents the eConnect node you use to create a bank ID.

Constructor

Name | Description
taCreateBank() | Initializes an instance of the taCreateBank class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
BANKID | string | Bank ID
BANKNAME | string | Bank name
BNKBRNCH | string | Bank branch
CITY | string | City
COUNTRY | string | Country
DDTRANUM | string | DD transit number
FAXNUMBR | string | Fax number
PHNUMBR1 | string | Telephone number
PHNUMBR2 | string | Telephone number
PHONE3 | string | Telephone number
RequesterTrx | int16 | Requester transaction
STATE | string | State
TRNSTNBR | string | Transit number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
ZIPCODE | string | Postal code

See Also

<taCreateBank>


taCreateBenefit Class

A class that represents the eConnect node you use to create a payroll benefit.

Constructor

Name | Description
taCreateBenefit() | Initializes an instance of the taCreateBenefit class.

Properties

Name | Type | Description
BENEFIT | string | Benefit
BNFBEGDT | string | Benefit begin date
BNFENDDT | string | Benefit end date
BNFFRMLA | int16 | Benefit formula
BNFITAMT_1 | Decimal | Benefit amount
BNFITAMT_2 | Decimal | Benefit amount
BNFITAMT_3 | Decimal | Benefit amount
BNFITAMT_4 | Decimal | Benefit amount
BNFITAMT_5 | Decimal | Benefit amount
BNFLFMAX | Decimal | Benefit lifetime maximum
BNFPRCNT_1 | Decimal | Benefit percent
BNFPRCNT_2 | Decimal | Benefit percent
BNFPRCNT_3 | Decimal | Benefit percent
BNFPRCNT_4 | Decimal | Benefit percent
BNFPRCNT_5 | Decimal | Benefit percent
BNFTFREQ | int16 | Benefit frequency
BNFTMTHD | int16 | Benefit method
BNFTRMAX_1 | Decimal | Benefit tier maximum
BNFTRMAX_2 | Decimal | Benefit tier maximum
BNFTRMAX_3 | Decimal | Benefit tier maximum
BNFTRMAX_4 | Decimal | Benefit tier maximum
BNFTRMAX_5 | Decimal | Benefit tier maximum
BNFYRMAX | Decimal | Benefit year maximum
BNPAYPMX | Decimal | Benefit pay period maximum
BNTRMXUN_1 | Decimal | Benefit tier maximum units
BNTRMXUN_2 | Decimal | Benefit tier maximum units
BNTRMXUN_3 | Decimal | Benefit tier maximum units
BNTRMXUN_4 | Decimal | Benefit tier maximum units
BNTRMXUN_5 | Decimal | Benefit tier maximum units
BORCDTYP | int16 | Based on record type
BSDORCDS | int16 | Based on records
Benefit_Fiscal_Max | Decimal | Benefit Fiscal Year Maximum
DATAENTDFLT | int16 | Date entry default
DSCRIPTN | string | Description
EMPLRMAXMAT | Decimal | Employer maximum match
FFEDTXRT | Decimal | Flat federal tax rate
FLSTTXRT | Decimal | Flat state tax rate
INACTIVE | int16 | Inactive
RequesterTrx | int16 | Requester transaction
SBJTFDTX | int16 | Subject to federal tax
SBJTFUTA | int16 | Subject to FUTA tax
SBJTLTAX | int16 | Subject to local tax
SBJTMCAR | int16 | Subject to FICA medicare tax
SBJTSSEC | int16 | Subject to FICA social security tax
SBJTSTTX | int16 | Subject to state tax
SBJTSUTA | int16 | Subjet to SUTA tax
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VARBENFT | int16 | Variable benefit/transaction
W2BXLABL | string | W-2 box label
W2BXLABL2 | string | W-2 box label 2
W2BXLABL3 | string | W-2 box label 3
W2BXLABL4 | string | W-2 box label 4
W2BXNMBR | int16 | W-2 box number
W2BXNMBR2 | int16 | W-2 box number 2
W2BXNMBR3 | int16 | W-2 box number 3
W2BXNMBR4 | int16 | W-2 box number 4

See Also

<taCreateBenefit>*


taCreateBenefitBasedOnPayDedCodes_ItemsTaCreateBenefitBasedOnPayDedCodes Class

A class that represents the eConnect node you use to create a payroll deduction based on a pay code.

Constructor

Name | Description
taCreateBenefitBasedOnPayDedCodes_ItemsTaCreateBenefitBasedOnPayDedCodes() | Initializes an instance of the taCreateBenefitBasedOnPayDedCodes_ItemsTaCreateBenefitBasedOnPayDedCodes class.

Properties

Name | Type | Description
BENEFIT | string | Benefit
BORCDTYP | int16 | Based on record type
BSDONCDE | string | Deduction description
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateBenefitBasedOnPayDedCodes>


taCreateBookClass Class

A class that represents the eConnect node you use to create a fixed asset book class ID.

Constructor

Name | Description
taCreateBookClass() | Initializes an instance of the taCreateBookClass class.

Properties

Name | Type | Description
AMORTIZATIONAMOUNT | Decimal | Amortization amount/percentage
AMORTIZATIONCODE | int16 | Amortization code
ASSETCLASSID | string | Asset class ID
AVERAGINGCONV | int16 | Averaging convention
BOOKID | string | Book ID
DEPRECIATIONMETHOD | int16 | Depreciation method
Initial_Allowance_Perc | int16 | Initial allowance percentage
LUXAUTOIND | int16 | Luxury auto
ORIGINALLIFEDAYS | int16 | Original life days
ORIGINALLIFEYEARS | int16 | Original life years
SALVAGEEST | int16 | Salvage estimate
SALVAGEPCT | Decimal | Salvage percentage
SPECDEPRALLOW | int16 | Special depreciation allowance
SPECDEPRALLOWPCT | int16 | Special depreciation allowance percentage
SWITCHOVER | int16 | Switch over
TEFRAFLAG | int16 | TEFRA flag
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateBookClass>


taCreateBookID Class

A class that represents the eConnect node you use to create a fixed asset book ID.

Constructor

Name | Description
taCreateBookID() | Initializes an instance of the taCreateBookID class.

Properties

Name | Type | Description
Auto_Add_Book_Info | int16 | Auto add book information
BOOKDESC | string | Book ID description
BOOKID | string | Book ID
CURRFISCALYR | int16 | Current fiscal year
DEPRPERIOD | int16 | Depreciation period
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateBookID>


taCreateBuyer Class

A class that represents the eConnect node you use to create a buyer.

Constructor

Name | Description
taCreateBuyer() | Initializes an instance of the taCreateBuyer class.

Properties

Name | Type | Description
BUYERID | string | Buyer ID
DSCRIPTN | string | Description
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateBuyer>


taCreateCheckbook Class

A class that represents the eConnect node you use to create a checkbook.

Constructor

Name | Description
taCreateCheckbook() | Initializes an instance of the taCreateCheckbook class.

Properties

Name | Type | Description
ACTNUMST | string | Account number
BANKID | string | Bank ID
BNKACTNM | string | Bank account number
CHEKBKID | string | Checkbook ID
CMUSRDF1 | string | User-defined field
CMUSRDF2 | string | User-defined field
CURNCYID | string | Currency ID
DDACTNUM | string | Bank account number from the direct deposit button
DDINDNAM | string | Account name from the direct deposit button
DDTRANS | string | Account type from the direct deposit button
DSCRIPTN | string | Checkbook description
DUPCHNUM | int16 | Allow duplicate check numbers
DepositRateTypeID | string | Deposit rate type ID
INACTIVE | int16 | Inactive
LOCATNID | string | Company address ID
Last_Reconciled_Balance | Decimal | Last reconciled balance
Last_Reconciled_Date | string | Last reconciled date
MXCHDLR | Decimal | Maximum check amount
NXTCHNUM | string | Next check number
Next_Deposit_Number | string | Next deposit number
OVCHNUM1 | int16 | Override check numbers
PaymentRateTypeID | string | Payment rate type ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateCheckbook>


taCreateComputerCheckLineInsert_ItemsTaCreateComputerCheckLineInsert Class

A class that represents the eConnect node you use to create a payroll computer check line.

Constructor

Name | Description
taCreateComputerCheckLineInsert_ItemsTaCreateComputerCheckLineInsert() | Initializes an instance of the taCreateComputerCheckLineInsert_ItemsTaCreateComputerCheckLineInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
COMPTRTP | int16 | Computer transaction type
DAYSWRDK | Decimal | Days worked
DEPRTMNT | string | Department
EMPLOYID | string | Employee ID
HRLYPYRT | Decimal | Hourly pay rate
JOBTITLE | string | Job title/position code
LOCALTAX | string | Local tax
PAYRTAMT | Decimal | Pay rate amount
RECEIPTS | Decimal | Receipts
RequesterTrx | int16 | Requester transaction
SALCHG | int16 | Salary change
SHFTCODE | string | Shift code
SHFTPREM | Decimal | Shift premium
STATECD | string | State code
SUTASTAT | string | SUTA state
TRXBEGDT | string | Transaction begin date
TRXENDDT | string | Transaction end date
TRXHRUNT | Decimal | Transaction hours/unit
UPRTRXCD | string | UPR transaction code
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VARDBAMT | Decimal | Variable deduction/benefit amount
VARDBPCT | Decimal | Variable deduction/benefit percent
WKSWRKD | Decimal | Weeks worked
WRKRCOMP | string | Worker compensation code

See Also

<taCreateComputerCheckLineInsert>


taCreateCreditCard Class

A class that represents the eConnect node you use to create a credit card.

Constructor

Name | Description
taCreateCreditCard() | Initializes an instance of the taCreateCreditCard class.

Properties

Name | Type | Description
ACTNUMST | string | Account number
CARDNAME | string | Credit card name
CBPAYBLE | int16 | Used by company
CBRCVBLE | int16 | Accepted from customers
CKBKNUM1 | string | Checkbook number
CREATDDT | string | Create date
MODIFDT | string | modified date
RCVBGRBX | int16 | Receivable group box
RequesterTrx | int16 | Requester transaction
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID

See Also

<taCreateCreditCard>


taCreateCustomerAddress_ItemsTaCreateCustomerAddress Class

A class that represents the eConnect node you use to create a customer address.

Constructor

Name | Description
taCreateCustomerAddress_ItemsTaCreateCustomerAddress() | Initializes an instance of the taCreateCustomerAddress_ItemsTaCreateCustomerAddress class.

Properties

Name | Type | Description
ADDRESS1 | string | Customer address information
ADDRESS2 | string | Customer address information
ADDRESS3 | string | Customer address information
ADRSCODE | string | Address ID
CCode | string | Country code
CITY | string | Customer city
CNTCPRSN | string | Contact person
COUNTRY | string | Customer country
CUSTNMBR | string | Customer number
FAX | string | Customer fax information
GPSFOINTEGRATIONID | string | Front office integration ID
INTEGRATIONID | string | Integration ID
INTEGRATIONSOURCE | int16 | Integration source
INTEGRATIONSOURCESpecified | bool | Set to True when you assign a value to INTEGRATIONSOURCE
LOCNCODE | string | Location code
PHNUMBR1 | string | Customer telephone information
PHNUMBR2 | string | Customer telephone information
PHNUMBR3 | string | Customer telephone information
Print_Phone_NumberGB | int16 | Print phone number
Print_Phone_NumberGBSpecified | bool | Set to True when you assign a value to Print_Phone_NumberGB
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory
SHIPMTHD | string | Shipping method
SLPRSNID | string | Salesperson ID
STATE | string | Customer state
ShipToName | string | Ship to name
TAXSCHID | string | Tax schedule
UPSZONE | string | UPS zone
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
ZIPCODE | string | Customer postal code

See Also

<taCreateCustomerAddress>*


taCreateCustomerClass Class

A class that represents the eConnect node you use to create a customer class.

Constructor

Name | Description
taCreateCustomerClass() | Initializes an instance of the taCreateCustomerClass class.

Properties

Name | Type | Description
ACCTRECACCT | string | Account receivables account
BALNCTYP | int16 | Balance type
CASHACCT | string | Cash account
CHEKBKID | string | Checkbook ID
CLASDSCR | string | Class description
CLASSID | string | Class ID
COSTOFSALESACCT | string | Cost of sales account
CRLMTAMT | Decimal | Credit amount
CRLMTPAM | Decimal | Credit limit period amount
CRLMTPER | int16 | Credit limit period
CRLMTTYP | int16 | Credit limit type
CURNCYID | string | Currency ID
CUSTDISC | int16 | Customer discount/trade discount
CUSTPRIORITY | int16 | Customer priority
DEFCACTY | int16 | Cash account type
DEFLTCLS | int16 | Default class
DISGRPER | int16 | Discount grace period
DUEGRPER | int16 | Due date of grace period
FINCHDLR | Decimal | Finance charge amount
FINCHRGACCT | string | Finance charge account
FNCHATYP | int16 | Finance charge type
FNCHPCNT | int16 | Finance charge percentage
IVACCT | string | Inventory account
KPCALHST | int16 | Keep calendar history
KPDSTHST | int16 | Keep distribution history
KPERHIST | int16 | Keep period history
KPTRXHST | int16 | Keep transaction history
MINPYDLR | Decimal | Minimum payment amount
MINPYPCT | int16 | Minimum payment percentage
MINPYTYP | int16 | Minimum payment type
MXWOFTYP | int16 | Maximum write-off type
MXWROFAM | Decimal | Maximum write-off amount
ORDERFULFILLDEFAULT | int16 | Order fulfillment shortage default
PRCLEVEL | string | Price level
PYMTRMID | string | Payment term ID
Post_Results_To | int16 | Post results to
RATETPID | string | Rate ID
RMOvrpymtWrtoffAcct | string | Overpayment write-off account
RequesterTrx | int16 | Requester transaction
Revalue_Customer | int16 | Revalue customer
SALESACCT | string | Sales account
SALESORDERRETACCT | string | Sales order returns account
SALSTERR | string | Sales territory
SHIPMTHD | string | Shipping method
SLPRSNID | string | Salesperson ID
STMTCYCL | int16 | Statement cycle
TAXSCHID | string | Tax schedule ID
TERMDISCAVAILACCT | string | Term discount available account
TERMDISCTAKENACCT | string | Term discount taken account
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
WRITEOFFACCT | string | Write-off account

See Also

<taCreateCustomerClass>


taCreateCustomerItems_ItemsTaCreateCustomerItems Class

A class that represents the eConnect node you use to associate a customer with an item.

Constructor

Name | Description
taCreateCustomerItems_ItemsTaCreateCustomerItems() | Initializes an instance of the taCreateCustomerItems_ItemsTaCreateCustomerItems class.

Properties

Name | Type | Description
CUSTITEMDESC | string | Customer item description
CUSTITEMGENERICDESC | string | Customer generic
CUSTITEMNMBR | string | Customer item
CUSTITEMSHORNAME | string | Customer item short name
CUSTNMBR | string | Customer ID
ENDDATE | string | Substitute item effective end date
ITEMNMBR | string | Item number
RequesterTrx | int16 | Requester transaction
STRTDATE | string | Substitute item effective start date
SUBITEMNMBR | string | Substitute item number
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateCustomerItems>


taCreateDeduction Class

A class that represents the eConnect node you use to create a payroll deduction.

Constructor

Name | Description
taCreateDeduction() | Initializes an instance of the taCreateDeduction class.

Properties

Name | Type | Description
BSDORCDS | int16 | Based on records
DATAENTDFLT | int16 | Data entry default
DEDBEGDT | string | Beginning date
DEDCAMNT_1 | Decimal | Deduction amount
DEDCAMNT_2 | Decimal | Deduction amount
DEDCAMNT_3 | Decimal | Deduction amount
DEDCAMNT_4 | Decimal | Deduction amount
DEDCAMNT_5 | Decimal | Deduction amount
DEDENDDT | string | Ending date
DEDFRMLA | int16 | Deduction formula
DEDLTMAX | Decimal | Deduction lifetime maximum
DEDNFREQ | int16 | Deduction frequency
DEDNMTHD | int16 | Deduction method
DEDNPRCT_1 | Decimal | Deduction percentage
DEDNPRCT_2 | Decimal | Deduction percentage
DEDNPRCT_3 | Decimal | Deduction percentage
DEDNPRCT_4 | Decimal | Deduction percentage
DEDNPRCT_5 | Decimal | Deduction percentage
DEDTRMAX_1 | Decimal | Deduction tier maximum
DEDTRMAX_2 | Decimal | Deduction tier maximum
DEDTRMAX_3 | Decimal | Deduction tier maximum
DEDTRMAX_4 | Decimal | Deduction tier maximum
DEDTRMAX_5 | Decimal | Deduction tier maximum
DEDTYPE | int16 | Deduction type
DEDUCTON | string | Deduction
DEDYRMAX | Decimal | Deduction year maximum
DEPYPRMX | Decimal | Deduction pay period maximum
DETRMXUN_1 | Decimal | Deduction tier maximum units
DETRMXUN_2 | Decimal | Deduction tier maximum units
DETRMXUN_3 | Decimal | Deduction tier maximum units
DETRMXUN_4 | Decimal | Deduction tier maximum units
DETRMXUN_5 | Decimal | Deduction tier maximum units
DSCRIPTN | string | Description
Deduction_Fiscal_Yr_Max | Decimal | Deduction Fiscal Year Maximum
EARNINGSCODE | string | Earning code
GARNCAT | int16 | Garnishment Category
INACTIVE | int16 | Inactive
RequesterTrx | int16 | Requester transaction
SFRFEDTX | int16 | Sheltered from federal tax
SFRLCLTX | int16 | Sheltered from local tax
SHFRFICA | int16 | Sheltered from FICA tax
SHFRSTTX | int16 | Sheltered from state tax
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VARDEDTN | int16 | Variable deduction
W2BXLABL | string | W-2 box label
W2BXLABL2 | string | W-2 box label 2
W2BXLABL3 | string | W-2 box label 3
W2BXLABL4 | string | W-2 box label 4
W2BXNMBR | int16 | W-2 box number
W2BXNMBR2 | int16 | W-2 box number 2
W2BXNMBR3 | int16 | W-2 box number 3
W2BXNMBR4 | int16 | W-2 box number 4

See Also

<taCreateDeduction>*


taCreateDeductionBasedOnPayCodes_ItemsTaCreateDeductionBasedOnPayCodes Class

A class that represents the eConnect node you use to create a payroll deduction based on a pay code.

Constructor

Name | Description
taCreateDeductionBasedOnPayCodes_ItemsTaCreateDeductionBasedOnPayCodes() | Initializes an instance of the taCreateDeductionBasedOnPayCodes_ItemsTaCreateDeductionBasedOnPayCodes class.

Properties

Name | Type | Description
BSDONCDE | string | Deduction description
DEDUCTON | string | Deduction
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateDeductionBasedOnPayCodes>


taCreateDepartment Class

A class that represents the eConnect node you use to create a payroll department.

Constructor

Name | Description
taCreateDepartment() | Initializes an instance of the taCreateDepartment class.

Properties

Name | Type | Description
DEPRTMNT | string | Department
DSCRIPTN | string | Description
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateDepartment>*


taCreateEmployee Class

A class that represents the eConnect node you use to create or update an employee.

Constructor

Name | Description
taCreateEmployee() | Initializes an instance of the taCreateEmployee class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Address code
ALTERNATENAME | string | Alternate name
ATACRSTM | int16 | Auto-accrue sick time
ATACRSTMSpecified | bool | Set to True when you assign a value to ATACRSTM
ATACRVAC | int16 | Auto-accrue vacation
ATACRVACSpecified | bool | Set to True when you assign a value to ATACRVAC
AccountNumber | string | Account number
BENADJDATE | string | Benefit adjustment date
BENEFITEXPIRE_I | string | Benefit expire
BIRTHDAY | int16 | Birth day
BIRTHMONTH | int16 | Birth month
BRTHDATE | string | Birthdate
CHANGEBY_I | string | Change by
CHANGEDATE_I | string | Change date
CITIZEN | int16 | Citizen
CITY | string | City
COUNTRY | string | Country
COUNTY | string | County
Calc_Min_Wage_Bal | int16 | Calculate minimum wage balance
Calc_Min_Wage_BalSpecified | bool | Set to True when you assign a value to Calc_Min_Wage_Bal
DATEOFLASTREVIEW_I | string | Date of last review
DATEOFNEXTREVIEW_I | string | Date of next review
DEMPINAC | string | Date employee inactivated
DEPRTMNT | string | Department
DISABLEDVETERAN | int16 | Disabled veteran
DIVISIONCODE_I | string | Division code
DefaultFromClass | int16 | Default information from class
EMPLCLAS | string | Employee class
EMPLOYID | string | Employee ID
EMPLOYMENTTYPE | int16 | Employment type
EMPLOYMENTTYPESpecified | bool | Set to True when you assign a value to EMPLOYMENTTYPE
EMPLSUFF | string | Employee suffix
ETHNORGN | int16 | Ethnic origin
FAX | string | Fax number
FEDCLSSCD | string | Federal class
FRSTNAME | string | First name
GENDER | int16 | Gender
HANDICAPPED | int16 | Handicapped
HRSTATUS | int16 | HR status
I9RENEW | string | I9 renew
INACTIVE | int16 | Inactive
JOBTITLE | string | Job title/position
LASTDAYWORKED_I | string | Last day worked
LASTNAME | string | Last name
LOCATNID | string | Location ID
MARITALSTATUS | int16 | Marital status
MIDLNAME | string | Middle name
MINETPAY | Decimal | Minimum net pay
MINETPAYSpecified | bool | Set to True when you assign a value to MINETPAY
Military_Discharge_Date | string | Military discharge date
NICKNAME | string | Nickname
OTHERVET | int16 | Other veteran
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
Primary_Pay_Record | string | Primary pay record
RATECLSS | string | Rate class
RSNEMPIN | string | Reason employee inactivated
RequesterTrx | int16 | Requester transaction
SIKTIMAV | Decimal | Sick time available
SIKTIMAVSpecified | bool | Set to True when you assign a value to SIKTIMAV
SKTMACAM | Decimal | Sick time accrual amount
SKTMACAMSpecified | bool | Set to True when you assign a value to SKTMACAM
SKTMHPYR | Decimal | Sick time hours per year
SKTMHPYRSpecified | bool | Set to True when you assign a value to SKTMHPYR
SMOKER_I | int16 | Smoker
SOCSCNUM | string | Social security number
SPOUSE | string | Spouse
SPOUSESSN | string | Spouse social security number
STATE | string | State
STATUSCD | string | Status code
STMACMTH | int16 | Sick time accrual method
STRTDATE | string | Start date
SUPERVISORCODE_I | string | Supervisor code
SUTASTAT | string | SUTA state
UNIONCD | string | Union code
UNIONEMPLOYEE | int16 | Union employee
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VACAPRYR | Decimal | Vacation hours per year
VACAPRYRSpecified | bool | Set to True when you assign a value to VACAPRYR
VACAVLBL | Decimal | Vacation available
VACAVLBLSpecified | bool | Set to True when you assign a value to VACAVLBL
VACCRAMT | Decimal | Vacation accrual amount
VACCRAMTSpecified | bool | Set to True when you assign a value to VACCRAMT
VACCRMTH | int16 | Vacation accrual method
VACCRMTHSpecified | bool | Set to True when you assign a value to VACCRMTH
VERIFIED | int16 | Verified
VETERAN | int16 | Veteran
VIETNAMVETERAN | int16 | Vietnam veteran
WCACFPAY | int16 | Cash account from
WKHRPRYR | int16 | Work hours per year
WRKRCOMP | string | Worker compensation code
WRNSTFLSBLWZR | int16 | Warn if sick time falls below zero
WRNSTFLSBLWZRSpecified | bool | Set to True when you assign a value to WRNSTFLSBLWZR
WRNVCNFLSBLWZR | int16 | Warn if vacation falls below zero
WRNVCNFLSBLWZRSpecified | bool | Set to True when you assign a value to WRNVCNFLSBLWZR
ZIPCODE | string | Postal code

See Also

<taCreateEmployee>*


taCreateEmployeeAddress Class

A class that represents the eConnect node you use to create or update an employee address.

Constructor

Name | Description
taCreateEmployeeAddress() | Initializes an instance of the taCreateEmployeeAddress class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Address code
CCode | string | Country code
CITY | string | City
COUNTRY | string | Country
COUNTY | string | County
EMPLOYID | string | Employee ID
FAX | string | Fax number
Foreign_Address | int16 | Foreign address
Foreign_Postal_Code | string | Foreign postal code
Foreign_StateProvince | string | Foreign state or province
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
RequesterTrx | int16 | Requester transaction
STATE | string | State
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
ZIPCODE | string | Postal code

See Also

<taCreateEmployeeAddress>*


taCreateEmployeeBenefit Class

A class that represents the eConnect node you use to create an employee benefit.

Constructor

Name | Description
taCreateEmployeeBenefit() | Initializes an instance of the taCreateEmployeeBenefit class.

Properties

Name | Type | Description
BENEFIT | string | Benefit
BNFBEGDT | string | Benefit begin date
BNFENDDT | string | Benefit end date
BNFFRMLA | int16 | Benefit formula
BNFFRMLASpecified | bool | Set to True when you assign a value to BNFFRMLA
BNFITAMT_1 | Decimal | Benefit amount
BNFITAMT_1Specified | bool | Set to True when you assign a value to BNFITAMT_1
BNFITAMT_2 | Decimal | Benefit amount
BNFITAMT_2Specified | bool | Set to True when you assign a value to BNFITAMT_2
BNFITAMT_3 | Decimal | Benefit amount
BNFITAMT_3Specified | bool | Set to True when you assign a value to BNFITAMT_3
BNFITAMT_4 | Decimal | Benefit amount
BNFITAMT_4Specified | bool | Set to True when you assign a value to BNFITAMT_4
BNFITAMT_5 | Decimal | Benefit amount
BNFITAMT_5Specified | bool | Set to True when you assign a value to BNFITAMT_5
BNFLFMAX | Decimal | Benefit lifetime maximum
BNFLFMAXSpecified | bool | Set to True when you assign a value to BNFLFMAX
BNFPRCNT_1 | Decimal | Benefit percentage
BNFPRCNT_1Specified | bool | Set to True when you assign a value to BNFPRCNT_1
BNFPRCNT_2 | Decimal | Benefit percentage
BNFPRCNT_2Specified | bool | Set to True when you assign a value to BNFPRCNT_2
BNFPRCNT_3 | Decimal | Benefit percentage
BNFPRCNT_3Specified | bool | Set to True when you assign a value to BNFPRCNT_3
BNFPRCNT_4 | Decimal | Benefit percentage
BNFPRCNT_4Specified | bool | Set to True when you assign a value to BNFPRCNT_4
BNFPRCNT_5 | Decimal | Benefit percentage
BNFPRCNT_5Specified | bool | Set to True when you assign a value to BNFPRCNT_5
BNFTFREQ | int16 | Benefit frequency
BNFTFREQSpecified | bool | Set to True when you assign a value to BNFTFREQ
BNFTMTHD | int16 | Benefit method
BNFTMTHDSpecified | bool | Set to True when you assign a value to BNFTMTHD
BNFTRMAX_1 | Decimal | Benefit tier maximum
BNFTRMAX_1Specified | bool | Set to True when you assign a value to BNFTRMAX_1
BNFTRMAX_2 | Decimal | Benefit tier maximum
BNFTRMAX_2Specified | bool | Set to True when you assign a value to BNFTRMAX_2
BNFTRMAX_3 | Decimal | Benefit tier maximum
BNFTRMAX_3Specified | bool | Set to True when you assign a value to BNFTRMAX_3
BNFTRMAX_4 | Decimal | Benefit tier maximum
BNFTRMAX_4Specified | bool | Set to True when you assign a value to BNFTRMAX_4
BNFTRMAX_5 | Decimal | Benefit tier maximum
BNFTRMAX_5Specified | bool | Set to True when you assign a value to BNFTRMAX_5
BNFYRMAX | Decimal | Benefit year maximum
BNFYRMAXSpecified | bool | Set to True when you assign a value to BNFYRMAX
BNPAYPMX | Decimal | Benefit pay period maximum
BNPAYPMXSpecified | bool | Set to True when you assign a value to BNPAYPMX
BNTRMXUN_1 | Decimal | Benefit tier maximum units
BNTRMXUN_1Specified | bool | Set to True when you assign a value to BNTRMXUN_1
BNTRMXUN_2 | Decimal | Benefit tier maximum units
BNTRMXUN_2Specified | bool | Set to True when you assign a value to BNTRMXUN_2
BNTRMXUN_3 | Decimal | Benefit tier maximum units
BNTRMXUN_3Specified | bool | Set to True when you assign a value to BNTRMXUN_3
BNTRMXUN_4 | Decimal | Benefit tier maximum units
BNTRMXUN_4Specified | bool | Set to True when you assign a value to BNTRMXUN_4
BNTRMXUN_5 | Decimal | Benefit tier maximum units
BNTRMXUN_5Specified | bool | Set to True when you assign a value to BNTRMXUN_5
BORCDTYP | int16 | Based on record type
BORCDTYPSpecified | bool | Set to True when you assign a value to BORCDTYP
BSDORCDS | int16 | Based on records
BSDORCDSSpecified | bool | Set to True when you assign a value to BSDORCDS
Benefit_Fiscal_Max | Decimal | Benefit fiscal year maximum
Benefit_Fiscal_MaxSpecified | bool | Set to True when you assign a value to Benefit_Fiscal_Max
DATAENTDFLT | int16 | Data entry default
DATAENTDFLTSpecified | bool | Set to True when you assign a value to DATAENTDFLT
EMPLOYID | string | Employee ID
EMPLRMAXMAT | Decimal | Employer maximum match
EMPLRMAXMATSpecified | bool | Set to True when you assign a value to EMPLRMAXMAT
FFEDTXRT | Decimal | Flat federal tax rate
FFEDTXRTSpecified | bool | Set to True when you assign a value to FFEDTXRT
FLSTTXRT | Decimal | Flat state tax rate
FLSTTXRTSpecified | bool | Set to True when you assign a value to FLSTTXRT
INACTIVE | int16 | Inactive
RequesterTrx | int16 | Requester transaction
SBJTFDTX | int16 | Subject to federal tax
SBJTFDTXSpecified | bool | Set to True when you assign a value to SBJTFDTX
SBJTFUTA | int16 | Subject to FUTA tax
SBJTFUTASpecified | bool | Set to True when you assign a value to SBJTFUTA
SBJTLTAX | int16 | Subject to local tax
SBJTLTAXSpecified | bool | Set to True when you assign a value to SBJTLTAX
SBJTMCAR | int16 | Subject to FICA medicare tax
SBJTMCARSpecified | bool | Set to True when you assign a value to SBJTMCAR
SBJTSSEC | int16 | Subject to FICA social security tax
SBJTSSECSpecified | bool | Set to True when you assign a value to SBJTSSEC
SBJTSTTX | int16 | Subject to state tax
SBJTSTTXSpecified | bool | Set to True when you assign a value to SBJTSTTX
SBJTSUTA | int16 | Subject to SUTA tax
SBJTSUTASpecified | bool | Set to True when you assign a value to SBJTSUTA
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
UseDefaultCoBenefit | int16 | Use default company benefit
VARBENFT | int16 | Variable benefit
VARBENFTSpecified | bool | Set to True when you assign a value to VARBENFT
W2BXLABL | string | W-2 box label
W2BXLABL2 | string | W-2 box label 2
W2BXLABL3 | string | W-2 box label 3
W2BXLABL4 | string | W-2 box label 4
W2BXNMBR | int16 | W-2 box number
W2BXNMBRSpecified | bool | Set to True when you assign a value to W2BXNMBR
W2BXNMBR2 | int16 | W-2 box number 2
W2BXNMBR2Specified | bool | Set to True when you assign a value to W2BXNMBR2
W2BXNMBR3 | int16 | W-2 box number 3
W2BXNMBR3Specified | bool | Set to True when you assign a value to W2BXNMBR3
W2BXNMBR4 | int16 | W-2 box number 4
W2BXNMBR4Specified | bool | Set to True when you assign a value to W2BXNMBR4

See Also

<taCreateEmployeeBenefit>*


taCreateEmployeeBenefitBasedOnPayDedCodes_ItemsTaCreateEmployeeBenefitBasedOnPayDedCodes Class

A class that represents the eConnect node you use to create an employee benefit based on payroll deduction/pay codes.

Constructor

Name | Description
taCreateEmployeeBenefitBasedOnPayDedCodes_ItemsTaCreateEmployeeBenefitBasedOnPayDedCodes() | Initializes an instance of the taCreateEmployeeBenefitBasedOnPayDedCodes_ItemsTaCreateEmployeeBenefitBasedOnPayDedCodes class.

Properties

Name | Type | Description
BENEFIT | string | Benefit
BORCDTYP | int16 | Based on record type
BSDONCDE | string | Deduction description
EMPLOYID | string | Employee ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateEmployeeBenefitBasedOnPayDedCodes>


taCreateEmployeeClass Class

A class that represents the eConnect node you use to create an employee class.

Constructor

Name | Description
taCreateEmployeeClass() | Initializes an instance of the taCreateEmployeeClass class.

Properties

Name | Type | Description
ATACRSTM | int16 | Auto-accrue sick time
ATACRVAC | int16 | Auto-accrue vacation
AccountNumber | string | Account number
Calc_Min_Wage_Bal | int16 | Calculate minimum wage balance
DEFLTCLS | int16 | Default class
DEPRTMNT | string | Department
DSCRIPTN | string | Description
DefaultFromClass | int16 | Default from class
EMPLCLAS | string | Employee class ID
EMPLOYMENTTYPE | int16 | Employment type
JOBTITLE | string | Job title
MINETPAY | Decimal | Minimum net pay
RequesterTrx | int16 | Requester transaction
SIKTIMAV | Decimal | Sick time available
SKTMACAM | Decimal | Sick time accrual amount
SKTMHPYR | Decimal | Sick time hours per year
STMACMTH | int16 | Sick time accrual method
SUTASTAT | string | SUTA state
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VACAPRYR | Decimal | Vacation hours per year
VACAVLBL | Decimal | Vacation available
VACCRAMT | Decimal | Vacation accrual amount
VACCRMTH | int16 | Vacation accrual method
WCACFPAY | int16 | Cash account for pay
WKHRPRYR | int16 | Work hours per year
WRKRCOMP | string | Worker compensation
WRNSTFLSBLWZR | int16 | Warn if sick time falls below zero
WRNVCNFLSBLWZR | int16 | Warn if vacation fall below zero

See Also

<taCreateEmployeeClass>*


taCreateEmployeeDeduction Class

A class that represents the eConnect node you use to create an employee payroll deduction.

Constructor

Name | Description
taCreateEmployeeDeduction() | Initializes an instance of the taCreateEmployeeDeduction class.

Properties

Name | Type | Description
AMNTTAKEN | Decimal | Amount taken
AMNTTAKENSpecified | bool | Set to True when you assign a value to AMNTTAKEN
BSDORCDS | int16 | Based on records
BSDORCDSSpecified | bool | Set to True when you assign a value to BSDORCDS
COURTDATE | string | Court data
COURTNAME | string | Court name
DATAENTDFLT | int16 | Data entry default
DATAENTDFLTSpecified | bool | Set to True when you assign a value to DATAENTDFLT
DEDBEGDT | string | Begin date
DEDCAMNT_1 | Decimal | Deduction amount
DEDCAMNT_1Specified | bool | Set to True when you assign a value to DEDCAMNT_1
DEDCAMNT_2 | Decimal | Deduction amount
DEDCAMNT_2Specified | bool | Set to True when you assign a value to DEDCAMNT_2
DEDCAMNT_3 | Decimal | Deduction amount
DEDCAMNT_3Specified | bool | Set to True when you assign a value to DEDCAMNT_3
DEDCAMNT_4 | Decimal | Deduction amount
DEDCAMNT_4Specified | bool | Set to True when you assign a value to DEDCAMNT_4
DEDCAMNT_5 | Decimal | Deduction amount
DEDCAMNT_5Specified | bool | Set to True when you assign a value to DEDCAMNT_5
DEDENDDT | string | End date
DEDFRMLA | int16 | Deduction formula
DEDFRMLASpecified | bool | Set to True when you assign a value to DEDFRMLA
DEDLTMAX | Decimal | Deduction lifetime maximum
DEDLTMAXSpecified | bool | Set to True when you assign a value to DEDLTMAX
DEDNFREQ | int16 | Deduction frequency
DEDNFREQSpecified | bool | Set to True when you assign a value to DEDNFREQ
DEDNMTHD | int16 | Deduction method
DEDNMTHDSpecified | bool | Set to True when you assign a value to DEDNMTHD
DEDNPRCT_1 | Decimal | Deduction percentage
DEDNPRCT_1Specified | bool | Set to True when you assign a value to DEDNPRCT_1
DEDNPRCT_2 | Decimal | Deduction percentage
DEDNPRCT_2Specified | bool | Set to True when you assign a value to DEDNPRCT_2
DEDNPRCT_3 | Decimal | Deduction percentage
DEDNPRCT_3Specified | bool | Set to True when you assign a value to DEDNPRCT_3
DEDNPRCT_4 | Decimal | Deduction percentage
DEDNPRCT_4Specified | bool | Set to True when you assign a value to DEDNPRCT_4
DEDNPRCT_5 | Decimal | Deduction percentage
DEDNPRCT_5Specified | bool | Set to True when you assign a value to DEDNPRCT_5
DEDTRMAX_1 | Decimal | Deduction tier maximum
DEDTRMAX_1Specified | bool | Set to True when you assign a value to DEDTRMAX_1
DEDTRMAX_2 | Decimal | Deduction tier maximum
DEDTRMAX_2Specified | bool | Set to True when you assign a value to DEDTRMAX_2
DEDTRMAX_3 | Decimal | Deduction tier maximum
DEDTRMAX_3Specified | bool | Set to True when you assign a value to DEDTRMAX_3
DEDTRMAX_4 | Decimal | Deduction tier maximum
DEDTRMAX_4Specified | bool | Set to True when you assign a value to DEDTRMAX_4
DEDTRMAX_5 | Decimal | Deduction tier maximum
DEDTRMAX_5Specified | bool | Set to True when you assign a value to DEDTRMAX_5
DEDUCTON | string | Deduction
DEDYRMAX | Decimal | Deduction year maximum
DEDYRMAXSpecified | bool | Set to True when you assign a value to DEDYRMAX
DEPYPRMX | Decimal | Deduction pay period maximum
DEPYPRMXSpecified | bool | Set to True when you assign a value to DEPYPRMX
DETRMXUN_1 | Decimal | Deduction tier maximum units
DETRMXUN_1Specified | bool | Set to True when you assign a value to DETRMXUN_1
DETRMXUN_2 | Decimal | Deduction tier maximum units
DETRMXUN_2Specified | bool | Set to True when you assign a value to DETRMXUN_2
DETRMXUN_3 | Decimal | Deduction tier maximum units
DETRMXUN_3Specified | bool | Set to True when you assign a value to DETRMXUN_3
DETRMXUN_4 | Decimal | Deduction tier maximum units
DETRMXUN_4Specified | bool | Set to True when you assign a value to DETRMXUN_4
DETRMXUN_5 | Decimal | Deduction tier maximum units
DETRMXUN_5Specified | bool | Set to True when you assign a value to DETRMXUN_5
DOCDESCR | string | Document ID
Deduction_Fiscal_Yr_Max | Decimal | Deduction fiscal year maximum
Deduction_Fiscal_Yr_MaxSpecified | bool | Set to True when you assign a value to Deduction_Fiscal_Yr_Max
EARNINGSCODE | string | Earning code
EMPLOYID | string | Employee ID
FEDMAXDED | string | Federal maximum deduction
INACTIVE | int16 | Inactive
ORIGINALAMOUNT | Decimal | Original amount
ORIGINALAMOUNTSpecified | bool | Set to True when you assign a value to ORIGINALAMOUNT
RequesterTrx | int16 | Requester transaction
SFRFEDTX | int16 | Sheltered from federal tax
SFRFEDTXSpecified | bool | Set to True when you assign a value to SFRFEDTX
SFRLCLTX | int16 | Sheltered from local tax
SFRLCLTXSpecified | bool | Set to True when you assign a value to SFRLCLTX
SHFRFICA | int16 | Sheltered from FICA tax
SHFRFICASpecified | bool | Set to True when you assign a value to SHFRFICA
SHFRSTTX | int16 | Sheltered from state tax
SHFRSTTXSpecified | bool | Set to True when you assign a value to SHFRSTTX
STATEMAXDED | string | State maximum deduction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
UseDefaultCoDeduction | int16 | Use default company deduction
VARDEDTN | int16 | Variable deduction
VARDEDTNSpecified | bool | Set to True when you assign a value to VARDEDTN
VENDORID | string | Vendor ID
W2BXLABL | string | W-2 box label
W2BXLABL2 | string | W-2 box label 2
W2BXLABL3 | string | W-2 box label 3
W2BXLABL4 | string | W-2 box label 4
W2BXNMBR | int16 | W-2 box number
W2BXNMBRSpecified | bool | Set to True when you assign a value to W2BXNMBR
W2BXNMBR2 | int16 | W-2 box number 2
W2BXNMBR2Specified | bool | Set to True when you assign a value to W2BXNMBR2
W2BXNMBR3 | int16 | W-2 box number 3
W2BXNMBR3Specified | bool | Set to True when you assign a value to W2BXNMBR3
W2BXNMBR4 | int16 | W-2 box number 4
W2BXNMBR4Specified | bool | Set to True when you assign a value to W2BXNMBR4

See Also

<taCreateEmployeeDeduction>*


taCreateEmployeeDeductionBasedOnPayCodes_ItemsTaCreateEmployeeDeductionBasedOnPayCodes Class

A class that represents the eConnect node you use to create an employee payroll deduction based a pay code.

Constructor

Name | Description
taCreateEmployeeDeductionBasedOnPayCodes_ItemsTaCreateEmployeeDeductionBasedOnPayCodes() | Initializes an instance of the taCreateEmployeeDeductionBasedOnPayCodes_ItemsTaCreateEmployeeDeductionBasedOnPayCodes class.

Properties

Name | Type | Description
BSDONCDE | string | Deduction description
DEDUCTON | string | Deduction
EMPLOYID | string | Employee ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateEmployeeDeductionBasedOnPayCodes>


taCreateEmployeeLocalTax Class

A class that represents the eConnect node you use to create an employee payroll local tax.

Constructor

Name | Description
taCreateEmployeeLocalTax() | Initializes an instance of the taCreateEmployeeLocalTax class.

Properties

Name | Type | Description
ADTLLOCWTHDNG | Decimal | Additional withholding
AULCLTAX | int16 | Automatically calculate
EMPLOYID | string | Employee ID
INACTIVE | int16 | Inactive
LCLFGSTS | string | Legal filing status
LOCALTAX | string | Local tax
NUMOFEXM | int16 | Number of exemptions
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateEmployeeLocalTax>*


taCreateEmployeePayCode Class

A class that represents the eConnect node you use to create payroll employee pay codes.

Constructor

Name | Description
taCreateEmployeePayCode() | Initializes an instance of the taCreateEmployeePayCode class.

Properties

Name | Type | Description
ACRUSTIM | int16 | Auto-accrue sick time
ACRUSTIMSpecified | bool | Set to True when you assign a value to ACRUSTIM
ACRUVACN | int16 | Auto-accrue vacation time
ACRUVACNSpecified | bool | Set to True when you assign a value to ACRUVACN
BSPAYRCD | string | Based on pay code
DATAENTDFLT | int16 | Data entry default
DATAENTDFLTSpecified | bool | Set to True when you assign a value to DATAENTDFLT
EMPLOYID | string | Employee ID
FFEDTXRT | Decimal | Federal tax rate
FFEDTXRTSpecified | bool | Set to True when you assign a value to FFEDTXRT
FLSTTXRT | Decimal | State tax rate
FLSTTXRTSpecified | bool | Set to True when you assign a value to FLSTTXRT
INACTIVE | int16 | Inactive
MXPYPPER | Decimal | Maximum per pay period
MXPYPPERSpecified | bool | Set to True when you assign a value to MXPYPPER
PAYADVNC | Decimal | Pay advance
PAYADVNCSpecified | bool | Set to True when you assign a value to PAYADVNC
PAYFACTR | Decimal | Pay factor
PAYFACTRSpecified | bool | Set to True when you assign a value to PAYFACTR
PAYPEROD | int16 | Pay period
PAYPERODSpecified | bool | Set to True when you assign a value to PAYPEROD
PAYRCORD | string | Pay code
PAYRTAMT | Decimal | Pay rate amount
PAYRTAMTSpecified | bool | Set to True when you assign a value to PAYRTAMT
PAYUNIT | string | Pay unit
PAYUNPER | int16 | Pay unit period
PAYUNPERSpecified | bool | Set to True when you assign a value to PAYUNPER
PYADVTKN | Decimal | Pay advance taken
Primary_Pay_Record | int16 | Primary pay record
RPTASWGS | int16 | Report as wages
RPTASWGSSpecified | bool | Set to True when you assign a value to RPTASWGS
RequesterTrx | int16 | Requester transaction
SBJTFDTX | int16 | Subject to federal tax
SBJTFDTXSpecified | bool | Set to True when you assign a value to SBJTFDTX
SBJTFUTA | int16 | Subject to FUTA tax
SBJTFUTASpecified | bool | Set to True when you assign a value to SBJTFUTA
SBJTLTAX | int16 | Subject to local tax
SBJTLTAXSpecified | bool | Set to True when you assign a value to SBJTLTAX
SBJTMCAR | int16 | Subject to medicare tax
SBJTMCARSpecified | bool | Set to True when you assign a value to SBJTMCAR
SBJTSSEC | int16 | Subject to social security tax
SBJTSSECSpecified | bool | Set to True when you assign a value to SBJTSSEC
SBJTSTTX | int16 | Subject to state tax
SBJTSTTXSpecified | bool | Set to True when you assign a value to SBJTSTTX
SBJTSUTA | int16 | Subject to SUTA tax
SBJTSUTASpecified | bool | Set to True when you assign a value to SBJTSUTA
SHFTCODE | string | Shift code
SUTASTAT | string | SUTA state
TipType | int16 | Tip type
TipTypeSpecified | bool | Set to True when you assign a value to TipType
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
UseDefaultCoPayCode | int16 | Use default company pay code
W2BXLABL | string | W-2 box label
W2BXLABL2 | string | W-2 box label 2
W2BXLABL3 | string | W-2 box label 3
W2BXLABL4 | string | W-2 box label 4
W2BXNMBR | int16 | W-2 box number
W2BXNMBRSpecified | bool | Set to True when you assign a value to W2BXNMBR
W2BXNMBR2 | int16 | W-2 box number 2
W2BXNMBR2Specified | bool | Set to True when you assign a value to W2BXNMBR2
W2BXNMBR3 | int16 | W-2 box number 3
W2BXNMBR3Specified | bool | Set to True when you assign a value to W2BXNMBR3
W2BXNMBR4 | int16 | W-2 box number 4
W2BXNMBR4Specified | bool | Set to True when you assign a value to W2BXNMBR4
WRKRCOMP | string | Worker compensation code

See Also

<taCreateEmployeePayCode>*


taCreateEmployeeStateTax Class

A class that represents the eConnect node you use to create payroll state tax.

Constructor

Name | Description
taCreateEmployeeStateTax() | Initializes an instance of the taCreateEmployeeStateTax class.

Properties

Name | Type | Description
ADNLALOW | int16 | Additional allowances
ADSTWHDG | Decimal | Additional state withholding
DEPNDNTS | int16 | Dependants
EMPLOYID | string | Employee ID
ESTDEDAL | int16 | Estimated deduction allowance
ESTSTWHD | Decimal | Estimated state withholding
EXFBLSPS | int16 | Exemption for blind spouse
EXFORO65 | int16 | Exemption for over 65
EXFSPO65 | int16 | Exemption for spouse over 65
EXMFBLND | int16 | Exemption for the blind
EXMFRSLF | int16 | Exemption for self
EXMFRSPS | int16 | Exemption for spouse
EXMFSPAL | int16 | Exemption for special allowance
EXMTAMNT | Decimal | Exemption amount
INACTIVE | int16 | Inactive
PRSNEXPT | int16 | Personal exemption
RequesterTrx | int16 | Requester transaction
STATECD | string | State code
TXFLGSTS | string | Tax filing status
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateEmployeeStateTax>*


taCreateEmployeeTax Class

A class that represents the eConnect node you use to create employee taxes.

Constructor

Name | Description
taCreateEmployeeTax() | Initializes an instance of the taCreateEmployeeTax class.

Properties

Name | Type | Description
ADFDWHDG | Decimal | Additional federal withholding
EICFLGST | string | EIC filing status
EMPLOYID | string | Employee ID
ESTFEDWH | Decimal | Estimated federal withholding
FDFLGSTS | string | Federal filing status
FEDEXMPT | int16 | Number of exemptions
LOCALTAX | string | Local tax code
MCRQGEMP | int16 | Medicare qualified government employee
NYTXDiff | int16 | New York tax difference
RequesterTrx | int16 | Requester transaction
STATECD | string | State code
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
W2BF942E | int16 | W-2 box for 942 employee
W2BFDCMP | int16 | W-2 box for deferred compensation
W2BFDCSD | int16 | W-2 box for the deceased
W2BFLREP | int16 | W-2 box for legal representation
W2BFPPLN | int16 | W-2 box for a pension plan
W2BFSTEM | int16 | W-2 box for a statutory employee

See Also

<taCreateEmployeeTax>*


taCreateFixedAllocationAccountRcd_ItemsTaCreateFixedAllocationAccountRcd Class

A class that represents the eConnect node you use to create or update a general ledger fixed allocation account.

Constructor

Name | Description
taCreateFixedAllocationAccountRcd_ItemsTaCreateFixedAllocationAccountRcd() | Initializes an instance of the taCreateFixedAllocationAccountRcd_ItemsTaCreateFixedAllocationAccountRcd class.

Properties

Name | Type | Description
ACTNUMST | string | Account number
DISTACTNUMST | string | Distribution account
PRCNTAGE | Decimal | Percentage
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateFixedAllocationAccountRcd>*


taCreateIVItemClass Class

A class that represents the eConnect node you use to create an inventory item class.

Constructor

Name | Description
taCreateIVItemClass() | Initializes an instance of the taCreateIVItemClass class.

Properties

Name | Type | Description
ALWBKORD | int16 | Allow back orders
Assembly_Variance_Acct | string | Assembly variance account
Cost_of_Goods_Sold_Acct | string | Cost of goods sold account
DECPLQTY | int16 | Decimal place quantity
DEFLTCLS | int16 | Default class
Damaged_Acct | string | Damaged account
Drop_Ship_Items_Acct | string | Drop ship items account
ITEMTYPE | int16 | Item type
ITMCLSCD | string | Item class Id
ITMCLSDC | string | Item class description
ITMGEDSC | string | Item generic description
ITMTRKOP | int16 | Item tracking option
ITMTSHID | string | Sales tax schedule ID
In_Service_Acct | string | In service account
In_Use_Acct | string | In use account
Inventory_Acct | string | Inventory account
Inventory_Offset_Acct | string | Inventory offset account
Inventory_Returns_Acct | string | Inventory returns account
KPCALHST | int16 | Keep calendar history
KPDSTHST | int16 | Keep distribution history
KPERHIST | int16 | Keep period history
KPTRXHST | int16 | Keep transaction history
LOTEXPWARN | int16 | Lot expiration warning
LOTEXPWARNDAYS | int16 | Lot expiration days
LOTTYPE | string | Lot category
Markdowns_Acct | string | Markdowns account
PRCLEVEL | string | Price level
PRICMTHD | int16 | Price method
PriceGroup | string | Price group
Purchase_Item_Tax_Schedu | string | Purchase tax schedule ID
Purchase_Price_Variance_Acct | string | Purchase price variance account
Purchase_Tax_Options | int16 | Purchase tax options
QtyOverTolerancePercent | int32 | Quantity overage tolerance percent
QtyShortTolerancePercent | int32 | Quantity short tolerance percent
Revalue_Inventory | int16 | Revalue inventory
Sales_Acct | string | Sales account
Sales_Returns_Acct | string | Sales returns account
TAXOPTNS | int16 | Sales tax options
Tolerance_Percentage | int32 | Tolerance percentage
UOMSCHDL | string | Unit of measure schedule ID
USCATVLS_1 | string | User-defined field
USCATVLS_2 | string | User-defined field
USCATVLS_3 | string | User-defined field
USCATVLS_4 | string | User-defined field
USCATVLS_5 | string | User-defined field
USCATVLS_6 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
Unrealized_Purchase_Price_Variance_Acct | string | Unrealized purchase price variance account
UseQtyOverageTolerance | int16 | Use quantity overage tolerance
UseQtyShortageTolerance | int16 | Use quantity shortage tolerance
VCTNMTHD | int16 | Valuation method
Variance_Acct | string | Variance account

See Also

<taCreateIVItemClass>


taCreateInsuranceClassID Class

A class that represents the eConnect node you use to create a fixed asset insurance class ID.

Constructor

Name | Description
taCreateInsuranceClassID() | Initializes an instance of the taCreateInsuranceClassID class.

Properties

Name | Type | Description
DEPRRATEPCT | Decimal | Depreciation rate percentage
INFLATIONRATEPCT | Decimal | Inflation rate percentage
INSCLASSDESC | string | Insurance class description
INSCLASSID | string | Insurance class ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateInsuranceClassID>


taCreateInternetAddresses_ItemsTaCreateInternetAddresses Class

A class that represents the eConnect node you use to create an internet address.

Constructor

Name | Description
taCreateInternetAddresses() | Initializes an instance of the taCreateInternetAddresses class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
EmailBccAddress | string | Email BCC address
EmailCcAddress | string | Email CC address
EmailToAddress | string | Email to address
INET1 | string | email address
INET2 | string | web site address
INET3 | string | FTP address
INET4 | string | Image
INET5 | string | Logon
INET6 | string | Password
INET7 | string | User-defined field
INET8 | string | User-defined field
INETINFO | string | Internet information
Master_ID | string | Master record ID
Master_Type | string | Master type
Messenger_Address | string | Messenger address
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateInternetAddresses>


taCreateInventorySite Class

A class that represents the eConnect node you use to create an inventory site.

Constructor

Name | Description
taCreateInventorySite() | Initializes an instance of the taCreateInventorySite class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
BOMRCPTBIN | string | Assembly receipts bin
CCode | string | Country code
CITY | string | City
COUNTRY | string | Country
FAXNUMBR | string | Fax number
INCLDDINPLNNNG | int16 | Include in planning
LOCNCODE | string | Location code
LOCNDSCR | string | Location description
Location_Segment | string | Location segment
MATERIALISSUEBIN | string | Material issues bin
MORECEIPTBIN | string | Manufacturing receipts bin
PCTAXSCH | string | Purchase tax schedule ID
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
PORECEIPTBIN | string | Purchase receipt bin
PORETRNBIN | string | Purchase return bin
REPAIRISSUESBIN | string | Repair issues bin
SOFULFILLMENTBIN | string | Sales order fulfillment bin
SORETURNBIN | string | Sales order returns bin
STATE | string | State
STAXSCHD | string | Sales tax schedule ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
ZIPCODE | string | Postal code

See Also

<taCreateInventorySite>


taCreateItemVendors_ItemsTaCreateItemVendors Class

A class that represents the eConnect node you use to create an inventory item vendor.

Constructor

Name | Description
taCreateItemVendors_ItemsTaCreateItemVendors() | Initializes an instance of the taCreateItemVendors_ItemsTaCreateItemVendors class.

Properties

Name | Type | Description
AVRGLDTM | int32 | Average lead time
ECORDQTY | Decimal | Economic order quantity
FREEONBOARD | int16 | Free on board
ITEMNMBR | string | Item number
Last_Currency_ID | string | Last currency ID
Last_Originating_Cost | Decimal | Last origination cost
MAXORDQTY | Decimal | Maximum order quantity
MINORQTY | Decimal | Minimum order quantity
MNFCTRITMNMBR | string | Manufacturer item number
NORCTITM | int16 | Number of receipts for item
ORDERMULTIPLE | Decimal | Order multiple
PLANNINGLEADTIME | int16 | Planning lead time
PRCHSUOM | string | Purchasing unit of measure
QTYRQSTN | Decimal | Quantity requisitioned
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
VNDITDSC | string | Vendor item description
VNDITNUM | string | Vendor item number

See Also

<taCreateItemVendors>*


taCreateKitItemRcd_ItemsTaCreateKitItemRcd Class

A class that represents the eConnect node you use to create an inventory kit item.

Constructor

Name | Description
taCreateKitItemRcd_ItemsTaCreateKitItemRcd() | Initializes an instance of the taCreateKitItemRcd_ItemsTaCreateKitItemRcd class.

Properties

Name | Type | Description
CMPITQTY | Decimal | Component quantity
CMPITUOM | string | Component unit of measure
CMPTITNM | string | Component item number
ITEMNMBR | string | Item number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateKitItemRcd>


taCreateLeaseCompany Class

A class that represents the eConnect node you use to create a fixed asset lease company.

Constructor

Name | Description
taCreateLeaseCompany() | Initializes an instance of the taCreateLeaseCompany class.

Properties

Name | Type | Description
LEASECOMPID | string | Lease company ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID

See Also

<taCreateLeaseCompany>


taCreateLocalTax Class

A class that represents the eConnect node you use to create payroll local tax.

Constructor

Name | Description
taCreateLocalTax() | Initializes an instance of the taCreateLocalTax class.

Properties

Name | Type | Description
DSCRIPTN | string | Description
EXMTAMNT | Decimal | Exemption amount
INACTIVE | int16 | Inactive
LCLTAXRT | Decimal | Local tax rate
LCLTXAMT | Decimal | Local tax amount
LCLTXCAL_1 | int16 | Local tax information
LCLTXCAL_2 | int16 | Local tax information
LCLTXCAL_3 | int16 | Local tax information
LCLTXCAL_4 | int16 | Local tax information
LCLTXCAL_5 | int16 | Local tax information
LOCALTAX | string | Local tax
MAXPERYR | Decimal | Maximum per year
MNTXBLWG | Decimal | Minimum taxable wages
MYTDTXWG | Decimal | Minimum/maximum YTD taxable wages
RequesterTrx | int16 | Requester transaction
STDDEDAM | Decimal | Standard deduction amount
STDDMTHD | int16 | Standard deduction method
STDDPCNT | Decimal | Standard deduction percentage
STDEDMAX | Decimal | Standard deduction maximum
STDEDMIN | Decimal | Standard deduction minimum
TAXTYPE | int16 | Tax type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateLocalTax>*


taCreateLocalTaxDetail_ItemsTaCreateLocalTaxDetail Class

A class that represents the eConnect node you use to create payroll local tax detail information.

Constructor

Name | Description
taCreateLocalTaxDetail_ItemsTaCreateLocalTaxDetail() | Initializes an instance of the taCreateLocalTaxDetail_ItemsTaCreateLocalTaxDetail class.

Properties

Name | Type | Description
LOCALTAX | string | Local tax
RXBRKTRT | Decimal | Tax bracket rate
RequesterTrx | int16 | Requester transaction
TXBREXWG | Decimal | Tax bracket excess wages
TXBRKTAM | Decimal | Tax bracket amount
TXBRULMT | Decimal | Tax bracket upper limit
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateLocalTaxDetail>


taCreateLocation Class

A class that represents the eConnect node you use to create a payroll location.

Constructor

Name | Description
taCreateLocation() | Initializes an instance of the taCreateLocation class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRCNTCT | string | Contact
CCode | string | Country code
CITY | string | City
COUNTRY | string | Country
COUNTY | string | County
FAXNUMBR | string | Fax number
LOCATNID | string | Location ID
LOCATNNM | string | Location description
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
RequesterTrx | int16 | Requester transaction
STATE | string | State
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
ZIPCODE | string | Postal code

See Also

<taCreateLocation>*


taCreateLocationID Class

A class that represents the eConnect node you use to create a fixed asset location ID.

Constructor

Name | Description
taCreateLocationID() | Initializes an instance of the taCreateLocationID class.

Properties

Name | Type | Description
CITYCODE | string | City code
CITYDESCR | string | City description
COUNTYCODE | string | County code
COUNTYDESCR | string | County description
LASTMNTDDATE | string | Create date
LASTMNTDUSERID | string | User ID
LOCATNID | string | Location ID
STATEABBREV | string | State abbreviation
STATECD | string | State code
STATEDESCR | string | State description
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateLocationID>


taCreateLockbox Class

A class that represents the eConnect node you use to create a lockbox.

Constructor

Name | Description
taCreateLockbox() | Initializes an instance of the taCreateLockbox class.

Properties

Name | Type | Description
CHEKBKID | string | Checkbook ID
CREATDDT | string | Create date
DECPLCUR | int16 | Decimal places on amounts
LockboxDescription | string | Description
LockboxID | string | Lockbox ID
MODIFDT | string | Modified date
OmitLastRecords | int32 | Omit last records
OmitStartRecords | int32 | Omit start records
STRGA255 | string | Location of lockbox file
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XPRTFTYP | int16 | File format type
paApplyMethod | int16 | Lockbox apply method
paDeailRowIndicator | string | Detail row indicator
paHeaderRowIndicator | string | Header row indicator
paLockboxFormatType Class | int16 | Lockbox format type

See Also

<taCreateLockbox>


taCreateLockboxBankDetails Class

A class that represents the eConnect node you use to create lockbox bank details.

Constructor

Name | Description
taCreateLockboxBankDetails() | Initializes an instance of the taCreateLockboxBankDetails class.

Properties

Name | Type | Description
BANKNAME | string | Bank name
BNKBRNCH | string | Bank branch
CUSTNMBR | string | Customer number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateLockboxBankDetails>


taCreateLotCategory Class

A class that represents the eConnect node you use to create an inventory lot category.

Constructor

Name | Description
taCreateLotCategory() | Initializes an instance of the taCreateLotCategory class.

Properties

Name | Type | Description
LOTTYPE | string | Lot category
LTATRDSC_1 | string | Lot attribute description
LTATRDSC_2 | string | Lot attribute description
LTATRDSC_3 | string | Lot attribute description
LTATRDSC_4 | string | Lot attribute description
LTATRDSC_5 | string | Lot attribute description
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateLotCategory>


taCreateManualCheckHeaderInsert Class

A class that represents the eConnect node you use to create a payroll manual check header.

Constructor

Name | Description
taCreateManualCheckHeaderInsert() | Initializes an instance of the taCreateManualCheckHeaderInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
CHEKBKID | string | Checkbook ID
CHEKNMBR | string | Check number
EMPLOYID | string | Employee ID
MLCHKTYP | int16 | Manual check type
POSTEDDT | string | Posted date
PYADNMBR | int32 | Pay/adjustment number
RequesterTrx | int16 | Requester transaction
USEGPPYADNMBR | int32 | Use default pay/adjustment number
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateManualCheckHeaderInsert>


taCreateManualCheckLineInsert_ItemsTaCreateManualCheckLineInsert Class

A class that represents the eConnect node you use to create a payroll manual check line.

Constructor

Name | Description
taCreateManualCheckLineInsert_ItemsTaCreateManualCheckLineInsert() | Initializes an instance of the taCreateManualCheckLineInsert_ItemsTaCreateManualCheckLineInsert class.

Properties

Name | Type | Description
DAYSWRDK | Decimal | Days worked
DEPRTMNT | string | Department
EFICAMT | Decimal | FICA amount
EMPLOYID | string | Employee number
JOBTITLE | string | Job title
LOCALTAX | string | Local tax code
MLCHKTYP | int16 | Manual check type
MLTRXAMT | Decimal | Transaction amount
MLTRXHRS | Decimal | Transaction hours
MLTRXNBR | int32 | Manual transaction number
MLTRXTYP | int16 | Manual transaction type
PYADNMBR | int32 | Pay/adjustment number
RECEIPTS | Decimal | Receipts
RequesterTrx | int16 | Requester transaction
SHFTCODE | string | Shift code
STATECD | string | State code
SUTASTAT | string | SUTA state
TRXBEGDT | string | Begin date
TRXENDDT | string | End date
TXBLWAGS | Decimal | Taxable wages
UPRTRXCD | string | Payroll transaction code
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
WKSWRKD | Decimal | Weeks worked
WRKRCOMP | string | Worker compensation code

See Also

<taCreateManualCheckLineInsert>


taCreateParentID Class

A class that represents the eConnect node you use to create a parent ID for a national account.

Constructor

Name | Description
taCreateParentID() | Initializes an instance of the taCreateParentID class.

Properties

Name | Type | Description
CPRCSTNM | string | Corporate customer number
NAALLOWRECEIPTS | int16 | Allow receipts
NACREDITCHECK | int16 | Credit checks
NADEFPARENTVEN | int16 | Parent vendor
NAFINANCECHARGE | int16 | Finance charges
NAHOLDINACTIVE | int16 | Apply hold/inactive status
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateParentID>*


taCreatePayCode Class

A class that represents the eConnect node you use to create a payroll pay code.

Constructor

Name | Description
taCreatePayCode() | Initializes an instance of the taCreatePayCode class.

Properties

Name | Type | Description
ACRUSTIM | int16 | Accrue sick time
ACRUVACN | int16 | Accrue vacation
BSPAYRCD | string | Base pay record
DATAENTDFLT | int16 | Data entry default
DSCRIPTN | string | Description
FFEDTXRT | Decimal | Federal tax rate
FLSTTXRT | Decimal | State tax rate
INACTIVE | int16 | Inactive
MXPYPPER | Decimal | Maximum pay per year
PAYADVNC | Decimal | Pay advance
PAYFACTR | Decimal | Pay factor
PAYPEROD | int16 | Pay period
PAYRCORD | string | Deduction
PAYRTAMT | Decimal | Pay rate amount
PAYTYPE | int16 | Pay type
PAYUNIT | string | Pay unit
PAYUNPER | int16 | Pay unit period
RPTASWGS | int16 | Report as wages
RequesterTrx | int16 | Requester transaction
SBJTFDTX | int16 | Subject to federal tax
SBJTFUTA | int16 | Subject to FUTA tax
SBJTLTAX | int16 | Subject to local tax
SBJTMCAR | int16 | Subject to medicare tax
SBJTSSEC | int16 | Subject to social security tax
SBJTSTTX | int16 | Subject to state tax
SBJTSUTA | int16 | Subject to SUTA tax
SHFTCODE | string | Shift code
TipType | int16 | Tip type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
W2BXLABL | string | W-2 box label
W2BXLABL2 | string | W-2 box label 2
W2BXLABL3 | string | W-2 box label 3
W2BXLABL4 | string | W-2 box label 4
W2BXNMBR | int16 | W-2 box number
W2BXNMBR2 | int16 | W-2 box number 2
W2BXNMBR3 | int16 | W-2 box number 3
W2BXNMBR4 | int16 | W-2 box number 4

See Also

<taCreatePayCode>*


taCreatePayrollBatchHeaderInsert Class

A class that represents the eConnect node you use to create a payroll batch header.

Constructor

Name | Description
taCreatePayrollBatchHeaderInsert() | Initializes an instance of the taCreatePayrollBatchHeaderInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
BCHCOMNT | string | Comment
CNTRLTRX | int32 | Control transaction count
CTRLEMPCT | int16 | Control employee count
POSTEDDT | string | Posted date
RequesterTrx | int16 | Requester transaction
UPRBCHFR | int16 | Batch frequency
UPRBCHOR | int16 | Payrol batch origin
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreatePayrollBatchHeaderInsert>*


taCreatePhysicalLocationID Class

A class that represents the eConnect node you use to create a fixed asset physical location ID.

Constructor

Name | Description
taCreatePhysicalLocationID() | Initializes an instance of the taCreatePhysicalLocationID class.

Properties

Name | Type | Description
LOCATNID | string | Location ID
Last_Inventory_Date | string | Last inventory date
Physical_Location_Desc | string | Physical location description
Physical_Location_ID | string | Physical location ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreatePhysicalLocationID>


taCreatePlanner Class

A class that represents the eConnect node you use to create an inventory planner.

Constructor

Name | Description
taCreatePlanner() | Initializes an instance of the taCreatePlanner class.

Properties

Name | Type | Description
PLANNERID | string | Planner ID
PLANNERNAME | string | Name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreatePlanner>


taCreatePosition Class

A class that represents the eConnect node you use to create a payroll position code.

Constructor

Name | Description
taCreatePosition() | Initializes an instance of the taCreatePosition class.

Properties

Name | Type | Description
CHANGEBY_I | string | Change by
CHANGEDATE_I | string | Change date
DSCRIPTN | string | Description
EEOCLASS_I | int16 | EEO Class
FLSASTATUS | int16 | FLSA Status
JOBTITLE | string | Job title/position code
REPORTSTOPOS | string | Reports to Position
REVIEWSETUPNAME_I | string | Review Type
RequesterTrx | int16 | Requester transaction
SKILLSET_I | string | Default Skill Set
TXTFIELD | string | Position Description
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreatePosition>*


taCreateProcessHold Class

A class that represents the eConnect node you use to create a process hold.

Constructor

Name | Description
taCreateProcessHold() | Initializes an instance of the taCreateProcessHold class.

Properties

Name | Type | Description
DSCRIPTN | string | Description
FUFIPHOL | int16 | Fulfill process hold
HOLDDATE | string | Hold date
PASSWORD | string | Password
POSTPHOL | int16 | Post process hold
PRCHLDID | string | Process hold ID
PRINPHOL | int16 | Print process hold
USER2ENT | string | User ID
UpdateIfExists | int32 | Update if exists flag
XFERPHOL | int16 | Transfer process hold

See Also

<taCreateProcessHold>*


taCreateProspect Class

A class that represents the eConnect node you use to create a prospect ID.

Constructor

Name | Description
taCreateProspect() | Initializes an instance of the taCreateProspect class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
CITY | string | City
CNTCPRSN | string | Contact person
COUNTRY | string | Country
CREATDDT | string | Create date
CUSTCLAS | string | Customer class
CUSTNAME | string | Customer name
FAX | string | Fax number
MODIFDT | string | Modified date
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
PRCLEVEL | string | Price level
PROSPID | string | Prospect ID
SHIPMTHD | string | Shipping method
STATE | string | State
TAXSCHID | string | Tax schedule ID
USER2ENT | string | User ID
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
ZIP | string | Postal code

See Also

<taCreateProspect>


taCreateRequisitions Class

A class that represents the eConnect node you use to create a requisition.

Constructor

Name | Description
taCreateRequisitions() | Initializes an instance of the taCreateRequisitions class.

Properties

Name | Type | Description
ADVERTISINGCOSTS_I | Decimal | Advertising costs
ADVERTISINGCOSTS_ISpecified | bool | Set to True when you assign a value to ADVERTISINGCOSTS_I
ADVERTISINGLIST_I_1 | string | Advertising
ADVERTISINGLIST_I_2 | string | Advertising
ADVERTISINGLIST_I_3 | string | Advertising
ADVERTISINGLIST_I_4 | string | Advertising
ADVERTISINGLIST_I_5 | string | Advertising
APPLICANTSAPPLIED_I | int16 | Applicants
APPLICANTSAPPLIED_ISpecified | bool | Set to True when you assign a value to APPLICANTSAPPLIED_I
APPSINTERVIEWED_I | int16 | Applicants interviewed
APPSINTERVIEWED_ISpecified | bool | Set to True when you assign a value to APPSINTERVIEWED_I
CHANGEBY_I | string | Changed by
COMPANYCODE_I | string | Company code
DEPARTMENTCODE_I | string | Department
DIVISIONCODE_I | string | Division
ENDDATE | string | Internal close date
MANAGER_I | string | Manager
OPENINGDATE_I | string | Opening date
POSITIONCODE_I | string | Position
POSITIONSAVAILABLE_I | int16 | Positions available
POSITIONSAVAILABLE_ISpecified | bool | Set to True when you assign a value to POSITIONSAVAILABLE_I
POSITIONSFILLED_I | int16 | Positions filled
POSITIONSFILLED_ISpecified | bool | Set to True when you assign a value to POSITIONSFILLED_I
RECRUITERSFEES_I | Decimal | Recruiter fees
RECRUITERSFEES_ISpecified | bool | Set to True when you assign a value to RECRUITERSFEES_I
RECRUITER_I | string | Recruiter
RECRUITMENT_I | int16 | Job title
RECRUITMENT_ISpecified | bool | Set to True when you assign a value to RECRUITMENT_I
REQSTATUS_I | int16 | Status
REQUISITIONNUMBER_I | int32 | Requisition number
RequesterTrx | int16 | Requester transaction
STRTDATE | string | Internal post date
SUPERVISORCODE_I | string | Supervisor
USRDEFND1 | string | User-defined field
USRDEFND12 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateRequisitions>*


taCreateRetirementCode Class

A class that represents the eConnect node you use to create a fixed asset retirement code.

Constructor

Name | Description
taCreateRetirementCode() | Initializes an instance of the taCreateRetirementCode class.

Properties

Name | Type | Description
LASTMNTDDATE | string | Last maintenance date
LASTMNTDUSERID | string | Last maintenance user ID
RETIRECODEDESCR | string | Description
RETIREMENTCODE | string | Retirement code
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateRetirementCode>


taCreateSOPTrackingInfo Class

A class that represents the eConnect node you use to create tracking information for a sales order.

Constructor

Name | Description
taCreateSOPTrackingInfo() | Initializes an instance of the taCreateSOPTrackingInfo class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | SOP number
SOPType Class | int16 | SOP type
Tracking_Number | string | Tracking number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateSOPTrackingInfo>


taCreateSalesperson Class

A class that represents the eConnect node you use to create a salesperson.

Constructor

Name | Description
taCreateSalesperson() | Initializes an instance of the taCreateSalesperson class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
CITY | string | City
COMAPPTO | int16 | Commission apply
COMMCODE | string | Commission code
COMMDEST | int16 | Commission destination
COMPRCNT | Decimal | Commission percentage
COMSLLYR | Decimal | Commissioned sales last year
COMSLTDT | Decimal | Commissioned sales to-date
COSTTODT | Decimal | Cost to date
COUNTRY | string | Country
CREATDDT | string | Create date
CSTLSTYR | Decimal | Cost last year
EMPLOYID | string | Employee ID
FAX | string | Fax number
INACTIVE | int16 | Inactive
KPCALHST | int16 | Keep calendar history
KPERHIST | int16 | Keep fiscal year history
MODIFDT | string | Modified date
NCOMSLTD | Decimal | Non-commissioned sales to-date
NCOMSLYR | Decimal | Non-commissioned sales last year
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory ID
SLPRSNFN | string | First name
SLPRSNID | string | Salesperson ID
SPRSNSLN | string | Last name
SPRSNSMN | string | Middle name
STATE | string | State
STDCPRCT | Decimal | Standard commission percentage
TTLCOMLY | Decimal | Total commission last year
TTLCOMTD | Decimal | Total commission to-date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
ZIP | string | Postal code

See Also

<taCreateSalesperson>*


taCreateShiftCode Class

A class that represents the eConnect node you use to create a payroll shift code.

Constructor

Name | Description
taCreateShiftCode() | Initializes an instance of the taCreateShiftCode class.

Properties

Name | Type | Description
DSCRIPTN | string | Description
INACTIVE | int16 | Inactive
RequesterTrx | int16 | Requester transaction
SHFTAMT | Decimal | Shift amount
SHFTCODE | string | Shift code
SHFTPCT | Decimal | Shift percentage
SHFTTYPE | int16 | Shift type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateShiftCode>*


taCreateShippingMethod Class

A class that represents the eConnect node you use to create a shipping method.

Constructor

Name | Description
taCreateShippingMethod() | Initializes an instance of the taCreateShippingMethod class.

Properties

Name | Type | Description
CARRACCT | string | Carrier account
CARRIER | string | Carrier
CONTACT | string | Contact
CREATDDT | string | Create date
MODIFDT | string | Modified date
NOTETEXT | string | Note
PHONNAME | string | Telephone number
SHIPMTHD | string | Shipping method
SHIPTYPE | int16 | Shipping type
SHMTHDSC | string | Description
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateShippingMethod>*


taCreateSiteBin Class

A class that represents the eConnect node you use to create an inventory bin.

Constructor

Name | Description
taCreateSiteBin() | Initializes an instance of the taCreateSiteBin class.

Properties

Name | Type | Description
BIN | string | Bin
LOCNCODE | string | Location ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateSiteBin>


taCreateSkills Class

A class that represents the eConnect node you use to create job skill information.

Constructor

Name | Description
taCreateSkills() | Initializes an instance of the taCreateSkills class.

Properties

Name | Type | Description
COMPENSATIONPERIOD_I | int16 | Compensation period
COMPENSATIONPERIOD_ISpecified | bool | Set to True when you assign a value to COMPENSATIONPERIOD_I
COMPENSATIONVALUE_I | Decimal | Compensation value
COMPENSATIONVALUE_ISpecified | bool | Set to True when you assign a value to COMPENSATIONVALUE_I
RequesterTrx | int16 | Requester transaction
SKILLTITLE_I | string | Skill
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateSkills>*


taCreateSkillSets Class

A class that represents the eConnect node you use to create a skill set.

Constructor

Name | Description
taCreateSkillSets() | Initializes an instance of the taCreateSkillSets class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SKILLSET_I | string | Skill set
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateSkillSets>*


taCreateSkillSetsLIne_ItemsTaCreateSkillSetsLine Class

A class that represents the eConnect node you use to specify skill set information.

Constructor

Name | Description
taCreateSkillSetsLIne_ItemsTaCreateSkillSetsLine() | Initializes an instance of the taCreateSkillSetsLIne_ItemsTaCreateSkillSetsLine class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SKILLSET_I | string | Skill set
SKILLTITLE_I | string | Skill
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateSkillSetsLine>*


taCreateSopPaymentInsertRecord_ItemsTaCreateSopPaymentInsertRecord Class

A class that represents the eConnect node you use to create a sales order payment.

Constructor

Name | Description
taCreateSopPaymentInsertRecord_ItemsTaCreateSopPaymentInsertRecord() | Initializes an instance of the taCreateSopPaymentInsertRecord_ItemsTaCreateSopPaymentInsertRecord class.

Properties

Name | Type | Description
AUTHCODE | string | Authorization code
Action | int16 | Action
ActionSpecified | bool | Set to True when you assign a value to Action
CARDNAME | string | Credit card name
CHEKBKID | string | Checkbook ID
CHEKNMBR | string | Check number
CUSTNAME | string | Customer name
CUSTNMBR | string | Customer number
DOCAMNT | Decimal | Payment amount
DOCDATE | string | Document date
DOCNUMBR | string | Payment or cash receipt number
EXPNDATE | string | Credit card expiration date
MDFUSRID | string | User ID
PROCESSELECTRONICALLY | int16 | Process electronically
PYMTTYPE | int32 | Payment type
RCTNCCRD | string | Credit card number
SEQNUMBR | int32 | Sequence number
SEQNUMBRSpecified | bool | Set to True when you assign a value to SEQNUMBR
SOPNUMBE | string | Invoice number
SOPTYPE | int16 | SOP type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VOIDDATE | string | Void date

See Also

<taCreateSopPaymentInsertRecord>


taCreateStructure Class

A class that represents the eConnect node you use to create a fixed asset structure ID.

Constructor

Name | Description
taCreateStructure() | Initializes an instance of the taCreateStructure class.

Properties

Name | Type | Description
STRUCTDESCR | string | Description
STRUCTUREID | string | Structure ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateStructure>


taCreateSupervisor Class

A class that represents the eConnect node you use to create a supervisor.

Constructor

Name | Description
taCreateSupervisor() | Initializes an instance of the taCreateSupervisor class.

Properties

Name | Type | Description
CHANGEBY_I | string | Change by
CHANGEDATE_I | string | Change date
EMPLOYID | string | Employee ID
RequesterTrx | int16 | Requester transaction
SUPERVISOR | string | Description
SUPERVISORCODE_I | string | Supervisor code
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateSupervisor>*


taCreateTerritory Class

A class that represents the eConnect node you use to create a sales territory ID.

Constructor

Name | Description
taCreateTerritory() | Initializes an instance of the taCreateTerritory class.

Properties

Name | Type | Description
COMSLLYR | Decimal | Commissioned sales last year
COMSLTDT | Decimal | Commissioned sales to date
COSTTODT | Decimal | Cost to date
COUNTRY | string | Country
CREATDDT | string | Create date
CSTLSTYR | Decimal | Cost last year
KPCALHST | int16 | Keep calendar history
KPERHIST | int16 | Keep period history
MODIFDT | string | Modified date
NCOMSLTD | Decimal | Non-commissioned sales to date
NCOMSLYR | Decimal | Non-commissioned sales last year
SALSTERR | string | Territory ID
SLPRSNID | string | Salesperson ID
SLTERDSC | string | Description
STMGRFNM | string | Manger first name
STMGRLNM | string | Manager last name
STMGRMNM | string | Manager middle name
TTLCOMLY | Decimal | Total commission last year
TTLCOMTD | Decimal | Total commission to date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateTerritory>


taCreateTests Class

A class that represents the eConnect node you use to create job test information.

Constructor

Name | Description
taCreateTests() | Initializes an instance of the taCreateTests class.

Properties

Name | Type | Description
CHANGEBY_I | string | Changed by
RequesterTrx | int16 | Requester transaction
TESTCODE_I | string | Test code
TEST_I | string | Test
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateTests>


taCreateUpdateBatchHeaderRcd Class

A class that represents the eConnect node you use to create or update a batch header.

Constructor

Name | Description
taCreateUpdateBatchHeaderRcd() | Initializes an instance of the taCreateUpdateBatchHeaderRcd class.

Properties

Name | Type | Description
APPROVL | int16 | Batch Approval
APPRVLDT | string | Batch approval date
APRVLUSERID | string | Batch approval user ID
BACHFREQ | int16 | Batch frequency
BACHFREQSpecified | bool | Set to True when you assign a value to BACHFREQ
BACHNUMB | string | Batch number
BCHCOMNT | string | Comment
BCHSOURC | string | Source
BRKDNALL | int16 | Breakdown allocation
CHEKBKID | string | Checkbook ID
CNTRLTOT | Decimal | Expected total
CNTRLTOTSpecified | bool | Set to True when you assign a value to CNTRLTOT
CNTRLTRX | int32 | Expected transaction count
CNTRLTRXSpecified | bool | Set to True when you assign a value to CNTRLTRX
DOCAMT | Decimal | Batch total
EFTFileFormat | int16 | EFT file format
GLPOSTDT | string | General ledger post date
MSCBDINC | int16 | Increment days for miscellaneous batch
MSCBDINCSpecified | bool | Set to True when you assign a value to MSCBDINC
NUMOFTRX | int32 | Number of transactions
ORIGIN | int32 | Origin
POSTTOGL | int16 | Post to general ledger
PmtMethod | int16 | Print method
RECPSTGS | int16 | Recurring posting
RECPSTGSSpecified | bool | Set to True when you assign a value to RECPSTGS
RequesterTrx | int16 | Requester transaction
SERIES | int32 | Series
TRXSOURC | string | Transaction Source
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taCreateUpdateBatchHeaderRcd>


taCreateVariableAllocationAccountRcd_ItemsTaCreateVariableAllocationAccountRcd Class

A class that represents the eConnect node you use to create or update a general ledger variable allocation account.

Constructor

Name | Description
taCreateVariableAllocationAccountRcd_ItemsTaCreateVariableAllocationAccountRcd() | Initializes an instance of the taCreateVariableAllocationAccountRcd_ItemsTaCreateVariableAllocationAccountRcd class.

Properties

Name | Type | Description
ACTNUMST | string | Account number
BREAKACTNUMST | string | Breakdown account
DISTACTNUMST | string | Distribution account
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taCreateVariableAllocationAccountRcd>*


taCreateVendorAddress_ItemsTaCreateVendorAddress Class

A class that represents the eConnect node you use to create a vendor address.

Constructor

Name | Description
taCreateVendorAddress_ItemsTaCreateVendorAddress() | Initializes an instance of the taCreateVendorAddress_ItemsTaCreateVendorAddress class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Address ID
CCode | string | Country code
CITY | string | City
COUNTRY | string | Country
FAXNUMBR | string | Fax number
PHNUMBR1 | string | Telephone number
PHNUMBR2 | string | Telephone number
PHNUMBR3 | string | Telephone number
RequesterTrx | int16 | Requester transaction
SHIPMTHD | string | Shipping method
STATE | string | State
TAXSCHID | string | Tax schedule
UPSZONE | string | UPS zone
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
VNDCNTCT | string | Contact person
ZIPCODE | string | Postal code

See Also

<taCreateVendorAddress>*


taCreateWorkersCompensationCode Class

A class that represents the eConnect node you use to create a workers compensation code.

Constructor

Name | Description
taCreateWorkersCompensationCode() | Initializes an instance of the taCreateWorkersCompensationCode class.

Properties

Name | Type | Description
DSCRIPTN | string | Description
RequesterTrx | int16 | Requester transaction
STATECD | string | State code
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
WCMOTMTH | int16 | Worker compensation overtime method
WCWGLIMT | Decimal | Worker compensation wage limit
WKCMPAMT | Decimal | Worker compensation amount
WKCMPCNT | Decimal | Worker compensation percentage
WKCMPMTH | int16 | Calculation method
WKCMPUNT | Decimal | Worker compensation per unit
WRKRCOMP | string | Worker compensation code

See Also

<taCreateWorkersCompensationCode>*


taDeleteApplicant Class

A class that represents the eConnect node you use to specify the applicant to remove.

Constructor

Name | Description
taDeleteApplicant() | Initializes an instance of the taDeleteApplicant class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicant>


taDeleteApplicantApplication Class

A class that represents the eConnect node you use to specify the job application to remove.

Constructor

Name | Description
taDeleteApplicantApplication() | Initializes an instance of the taDeleteApplicantApplication class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Internal sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
REQUISITIONNUMBER_I | int32 | Requisition number
REQUISITIONNUMBER_ISpecified | bool | Set to True when you assign a value to REQUISITIONNUMBER_I
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantApplication>


taDeleteApplicantEducation Class

A class that represents the eConnect node you use to specify the applicant education information to remove.

Constructor

Name | Description
taDeleteApplicantEducation() | Initializes an instance of the taDeleteApplicantEducation class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantEducation>


taDeleteApplicantEducationLine Class

A class that represents the eConnect node you use to specify the applicant education information line to remove.

Constructor

Name | Description
taDeleteApplicantEducationLine() | Initializes an instance of the taDeleteApplicantEducationLine class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
UNIVERSITY | string | University
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantEducationLine>


taDeleteApplicantInterview Class

A class that represents the eConnect node you use to specify the applicant interview information to remove.

Constructor

Name | Description
taDeleteApplicantInterview() | Initializes an instance of the taDeleteApplicantInterview class.

Properties

Name | Type | Description
APPINTTYPESTR_I | string | Interview type
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
APPLYDATE_I | string | Interview date
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantInterview>


taDeleteApplicantReferences Class

A class that represents the eConnect node you use to specify the applicant reference information to remove.

Constructor

Name | Description
taDeleteApplicantReferences() | Initializes an instance of the taDeleteApplicantReferences class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantReferences>


taDeleteApplicantReferencesLine Class

A class that represents the eConnect node you use to specify the reference line information to remove.

Constructor

Name | Description
taDeleteApplicantReferencesLine() | Initializes an instance of the taDeleteApplicantReferencesLine class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
REFERENCENAME_I | string | Reference name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantReferencesLine>


taDeleteApplicantRequisitionsLine Class

A class that represents the eConnect node you use to specify the requisition line to remove.

Constructor

Name | Description
taDeleteApplicantRequisitionsLine() | Initializes an instance of the taDeleteApplicantRequisitionsLine class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
REQUISITIONNUMBER_I | int32 | Requisition number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantRequisitionsLine>


taDeleteApplicantTests Class

A class that represents the eConnect node you use to specify the applicant test information to remove.

Constructor

Name | Description
taDeleteApplicantTests() | Initializes an instance of the taDeleteApplicantTests class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantTests>


taDeleteApplicantTestsLine Class

A class that represents the eConnect node you use to specify the applicant test line information to remove.

Constructor

Name | Description
taDeleteApplicantTestsLine() | Initializes an instance of the taDeleteApplicantTestsLine class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
TESTCODE_I | string | Test code
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantTestsLine>


taDeleteApplicantWorkHistory Class

A class that represents the eConnect node you use to specify the applicant work history information to remove.

Constructor

Name | Description
taDeleteApplicantWorkHistory() | Initializes an instance of the taDeleteApplicantWorkHistory class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
LLASTNAME_I | string | Last name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantWorkHistory>


taDeleteApplicantWorkHistoryLine Class

A class that represents the eConnect node you use to specify the applicant work history line to remove.

Constructor

Name | Description
taDeleteApplicantWorkHistoryLine() | Initializes an instance of the taDeleteApplicantWorkHistoryLine class.

Properties

Name | Type | Description
APPLICANTNUMBER_I | Decimal | Applicant number
APPLICANTNUMBER_ISpecified | bool | Set to True when you assign a value to APPLICANTNUMBER_I
FFIRSTNAME_I | string | First name
ISEQUENCENUMBER_I | int16 | Sequence number
ISEQUENCENUMBER_ISpecified | bool | Set to True when you assign a value to ISEQUENCENUMBER_I
LLASTNAME_I | string | Last name
NAME | string | Employer name
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteApplicantWorkHistoryLine>


taDeleteCustomerAddress Class

A class that represents the eConnect node you use to remove a specified customer address.

Constructor

Name | Description
taDeleteCustomerAddress() | Initializes an instance of the taDeleteCustomerAddress class.

Properties

Name | Type | Description
ADRSCODE | string | Address ID
CUSTNMBR | string | Customer number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteCustomerAddress>


taDeleteCustomerRcd Class

A class that represents the eConnect node you use to remove a specified customer.

Constructor

Name | Description
taDeleteCustomerRcd() | Initializes an instance of the taDeleteCustomerRcd class.

Properties

Name | Type | Description
CUSTNMBR | string | Customer
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteCustomerRcd>


taDeleteEmployee Class

A class that represents the eConnect node you use to remove an employee from payroll.

Constructor

Name | Description
taDeleteEmployee() | Initializes an instance of the taDeleteEmployee class.

Properties

Name | Type | Description
EMPLOYID | string | Employee ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteEmployee>


taDeleteEmployeeAddress Class

A class that represents the eConnect node you use to specify the employee address to remove.

Constructor

Name | Description
taDeleteEmployeeAddress() | Initializes an instance of the taDeleteEmployeeAddress class.

Properties

Name | Type | Description
ADRSCODE | string | Address ID
EMPLOYID | string | Employee number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteEmployeeAddress>


taDeleteEmployeePayCode Class

A class that represents the eConnect node you use to specify the employee pay code to remove.

Constructor

Name | Description
taDeleteEmployeePayCode() | Initializes an instance of the taDeleteEmployeePayCode class.

Properties

Name | Type | Description
EMPLOYID | string | Employee number
PAYRCORD | string | Pay code
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteEmployeePayCode>


taDeleteRequisition Class

A class that represents the eConnect node you use to specify the requisition to remove.

Constructor

Name | Description
taDeleteRequisition() | Initializes an instance of the taDeleteRequisition class.

Properties

Name | Type | Description
REQUISITIONNUMBER_I | int32 | Requisition number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteRequisition>


taDeleteSalespersonRcd Class

A class that represents the eConnect node you use to remove a specified salesperson.

Constructor

Name | Description
taDeleteSalespersonRcd() | Initializes an instance of the taDeleteSalespersonRcd class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SLPRSNID | string | Salesperson ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteSalespersonRcd>


taDeleteSkills Class

A class that represents the eConnect node you use to specify the job skill to remove.

Constructor

Name | Description
taDeleteSkills() | Initializes an instance of the taDeleteSkills class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SKILLSET_I | string | Skill
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteSkills>


taDeleteSkillSetsLine Class

A class that represents the eConnect node you use to specify the skill set line to remove.

Constructor

Name | Description
taDeleteSkillSetsLine() | Initializes an instance of the taDeleteSkillSetsLine class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SKILLSET_I | string | Skill set
SKILLTITLE_I | string | Skill
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteSkillSetsLine>


taDeleteSkillsSets Class

A class that represents the eConnect node you use to specify the skill set to remove.

Constructor

Name | Description
taDeleteSkillsSets() | Initializes an instance of the taDeleteSkillsSets class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SKILLSET_I | string | Skill set
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteSkillSets>


taDeleteTests Class

A class that represents the eConnect node you use to specify the test information to remove.

Constructor

Name | Description
taDeleteTests() | Initializes an instance of the taDeleteTests class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
TESTCODE_I | string | Test code
TEST_I | string | Test
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taDeleteTests>


taDeleteVendorAddress Class

A class that represents the eConnect node you use to specify the vendor address to remove.

Constructor

Name | Description
taDeleteVendorAddress() | Initializes an instance of the taDeleteVendorAddress class.

Properties

Name | Type | Description
ADRSCODE | string | Address ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID

See Also

<taDeleteVendorAddress>


taFSEquipmentMaster Class

A class that represents the eConnect node you use to specify a field service equipment record.

Constructor

Name | Description
taFSEquipmentMaster() | Initializes an instance of the taFSEquipmentMaster class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Customer address code
CITY | string | City
CNTCPRSN | string | Contact person
COUNTRY | string | Country
CUSTNMBR | string | Customer number
INSTDTE | string | Install date
ITEMNMBR | string | Item number
LSTPMDTE | string | Last maintenance date
LSTSRVDTE | string | Last service call date
NOTETXT | string | Notes
OFFID | string | Office ID
REFRENCE | string | Reference
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
SLRWARR | string | Seller warranty
SLRWEND | string | Seller warranty end date
SLRWSTART | string | Seller warranty start date
SRLSTAT | string | Status
STATE | string | State
SVCAREA | string | Service area
SVC_Asset_Tag | string | Asset tag
SVC_PM_Date | int16 | Annual service month
SVC_PM_DateSpecified | bool | Set to True when you assign a value to SVC_PM_Date
SVC_PM_Day | int16 | Annual service day
SVC_PM_DaySpecified | bool | Set to True when you assign a value to SVC_PM_Day
SVC_Register_Date | string | Registered date
SVC_Serial_ID | string | Service serial ID
Shipped_Date | string | Shipped date
TECHID | string | Technician ID
TIMEZONE | string | Time zone
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
Version | string | Version of equipment
WARRCDE | string | Warranty code
WARREND | string | Warranty end date
WARRSTART | string | Warranty start date
ZIP | string | Postal code

See Also


taFSEquipmentReading_ItemsTaFSEquipmentReading Class

A class that represents the eConnect node you use to specify a field service equipment reading record.

Constructor

Name | Description
taFSEquipmentReading_ItemsTaFSEquipmentReading() | Initializes an instance of the taFSEquipmentReading_ItemsTaFSEquipmentReading class.

Properties

Name | Type | Description
ITEMNMBR | string | Item number
LSTDTEDT | string | Last reading date
Meters_1 | int32 | Current meter reading
Meters_1Specified | bool | Set to True when you assign a value to Meters_1
Meters_2 | int32 | Current meter reading
Meters_2Specified | bool | Set to True when you assign a value to Meters_2
Meters_3 | int32 | Current meter reading
Meters_3Specified | bool | Set to True when you assign a value to Meters_3
Meters_4 | int32 | Current meter reading
Meters_4Specified | bool | Set to True when you assign a value to Meters_4
Meters_5 | int32 | Current meter reading
Meters_5Specified | bool | Set to True when you assign a value to Meters_5
Replaces_1 | int16 | Meter replaced
Replaces_2 | int16 | Meter replaced
Replaces_3 | int16 | Meter replaced
Replaces_4 | int16 | Meter replaced
Replaces_5 | int16 | Meter replaced
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taFSEquipmentReading>*


taFSRMALineSerial_ItemsTaFSRMALineSerial Class

A class that represents the eConnect node you use to specify a field service RMA line serial number.

Constructor

Name | Description
taFSRMALineSerial_ItemsTaFSRMALineSerial() | Initializes an instance of the taFSRMALineSerial_ItemsTaFSRMALineSerial class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
BIN | string | Bin
CUSTNMBR | string | Customer number
DATERECD | string | Date received
ITEMNMBR | string | Item number
LNSEQNBR | Decimal | Line sequence number
LOCNCODE | string | Location code
QTYTYPE | int16 | Quantity type
RETDOCID | string | RMA number
ReplaceItem | int16 | Replacement item
RequesterTrx | int16 | Requester transaction
Return_Record_Type | int16 | RMA record type
SERLNMBR | string | Serial number
SERLTQTY | Decimal | Serial/Lot quantity
SLTSQNUM | int32 | Serial sequence number
SVC_Original_Serial | int16 | Original IV serial number
SVC_Original_SerialSpecified | bool | Set to True when you assign a value to SVC_Original_Serial
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taFSRMALineSerial>*


taFSRMALine_ItemsTaFSRMALine Class

A class that represents the eConnect node you use to create or update a field service RMA line.

Constructor

Name | Description
taFSRMALine_ItemsTaFSRMALine() | Initializes an instance of the taFSRMALine_ItemsTaFSRMALine class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Address code
Bill_of_Lading | string | Bill of lading
CITY | string | City
CMPNTSEQ | int32 | Component sequence number
CMPNTSEQSpecified | bool | Set to True when you assign a value to CMPNTSEQ
COMPDTE | string | Closed date
COMPTME | string | Closed time
CONTACT | string | Contact person
COUNTRY | string | Country
CSTPONBR | string | Customer PO number
CURNCYID | string | Currency ID
CUSTNAME | string | Customer name
CUSTNMBR | string | Customer number
CUSTOWN | int16 | Customer owned
CUSTOWNSpecified | bool | Set to True when you assign a value to CUSTOWN
Commit_Date | string | RMA commit date
Commit_Time | string | RMA commit time
ENTDTE | string | RMA entered date
ENTTME | string | RMA entered time
EQPLINE | int32 | Equipment sequence line number
EQPLINESpecified | bool | Set to True when you assign a value to EQPLINE
ETADTE | string | Expected arrival date
ETATME | string | Expected arrival time
FACTSEAL | int16 | Factory sealed
FACTSEALSpecified | bool | Set to True when you assign a value to FACTSEAL
Flat_Rate_Repair_Price | Decimal | Flat rate repair price
Flat_Rate_Repair_PriceSpecified | bool | Set to True when you assign a value to Flat_Rate_Repair_Price
ITEMDESC | string | Item description
ITEMNMBR | string | Item number
Item_Number_Invoice | string | Invoice item number
LNITMSEQ | int32 | Sequence number of service call line
LNITMSEQSpecified | bool | Set to True when you assign a value to LNITMSEQ
LNSEQNBR | Decimal | Line sequence number
LOCNCODE | string | Location code
Location_Code_Replacemen | string | Replacement location code
NOTETXT | string | Notes
NTE_Price | Decimal | Not-to-exceed price
NTE_PriceSpecified | bool | Set to True when you assign a value to NTE_Price
OFFID | string | Office ID
PRMDATE | string | Promise date
QUANTITY | Decimal | Quantity
QUANTITYSpecified | bool | Set to True when you assign a value to QUANTITY
RETADDR1 | string | Return address
RETADDR2 | string | Return address
RETADDR3 | string | Return address
RETCOST | Decimal | Returned unit cost
RETCOSTSpecified | bool | Set to True when you assign a value to RETCOST
RETDOCID | string | RMA number
RETORIG | int16 | Return origin
RETORIGSpecified | bool | Set to True when you assign a value to RETORIG
RETREF | string | Return reference document number
RETSTAT | string | RMA status code
RETTYPE | string | Return type
RETUDATE | string | Return date
RTRNCITY | string | Return city
RTRNNAME | string | Return location name
RTRNZIP | string | Return postal code
Repair_Cost | Decimal | Repair cost
Repair_CostSpecified | bool | Set to True when you assign a value to Repair_Cost
Repair_Price | Decimal | Replacement unit price
Repair_PriceSpecified | bool | Set to True when you assign a value to Repair_Price
Replace_Cost | Decimal | Replacement unit cost
Replace_CostSpecified | bool | Set to True when you assign a value to Replace_Cost
Replace_Item_Number | string | Replacement item number
Replace_Price | Decimal | Repair price
Replace_PriceSpecified | bool | Set to True when you assign a value to Replace_Price
Replace_Price_Level | string | Replacement price level
Replace_QTY | Decimal | Replacement quantity
Replace_QTYSpecified | bool | Set to True when you assign a value to Replace_QTY
Replace_U_Of_M | string | Replacement unit of measure
RequesterTrx | int16 | Requester transaction
Return_Country | string | Return country
Return_Item_Description | string | Returned item description
Return_Item_Number | string | Returned item number
Return_Location_Code | string | Returned location code
Return_QTY | Decimal | Returned quantity
Return_QTYSpecified | bool | Set to True when you assign a value to Return_QTY
Return_Record_Type | int16 | RMA record type
Return_Time | string | Return time
Return_U_Of_M | string | Returned unit of measure
SHIPMTHD | string | Shipping method
SOP_Line_Item_Sequence | int32 | Sales invoice sequence number
SOP_Line_Item_SequenceSpecified | bool | Set to True when you assign a value to SOP_Line_Item_Sequence
STATE | string | State
SVC_Extended_Return_Pric | Decimal | Return extended price
SVC_Extended_Return_PricSpecified | bool | Set to True when you assign a value to SVC_Extended_Return_Pric
SVC_FO_ID | string | Front office integration ID
SVC_RMA_From_Service | int16 | RMA from service call
SVC_RMA_From_ServiceSpecified | bool | Set to True when you assign a value to SVC_RMA_From_Service
SVC_RMA_Reason_Code | string | RMA reason code
SVC_Ready_To_Close | int16 | Ready to close
SVC_Ready_To_CloseSpecified | bool | Set to True when you assign a value to SVC_Ready_To_Close
SVC_Return_Price | Decimal | Return unit price
SVC_Return_PriceSpecified | bool | Set to True when you assign a value to SVC_Return_Price
SVC_Return_Price_Level | string | Return price level
SVC_Return_State | string | Return state code
SVC_SCM_Complete | int16 | SCM completed
SVC_SCM_CompleteSpecified | bool | Set to True when you assign a value to SVC_SCM_Complete
UNITCOST | Decimal | Unit cost
UNITCOSTSpecified | bool | Set to True when you assign a value to UNITCOST
UNITPRCE | Decimal | Unit price
UNITPRCESpecified | bool | Set to True when you assign a value to UNITPRCE
UOFM | string | Unit of measure
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USERID | string | User ID
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
XTNDPRCE | Decimal | Extended price
XTNDPRCESpecified | bool | Set to True when you assign a value to XTNDPRCE
ZIPCODE | string | Postal code

See Also

<taFSRMALine>*


taFSRMAMaster Class

A class that represents the eConnect node you use to specify a field service RMA record.

Constructor

Name | Description
taFSRMAMaster() | Initializes an instance of the taFSRMAMaster class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Customer address ID
Bill_To_Customer | string | Bill to customer ID
Bill_of_Lading | string | Bill of lading
CITY | string | CIty
CKHOLD | int16 | Check for customer hold
COMPDTE | string | Closed date
COMPTME | string | Closed time
CONTACT | string | Contact person
COUNTRY | string | Country
CSTPONBR | string | Customer PO number
CURNCYID | string | Currency ID
CUSTNAME | string | Customer name
CUSTNMBR | string | Customer ID
Commit_Date | string | Commit date
Commit_Time | string | Commit time
ENTDTE | string | RMA entered date
ENTTME | string | RMA entered time
ETADTE | string | Expected return date
ETATME | string | Expected return time
LOCNCODE | string | Return location code
NOTETXT | string | Notes
OFFID | string | Office ID
RETADDR1 | string | Return address
RETADDR2 | string | Return address
RETADDR3 | string | Return address
RETDOCID | string | RMA number
RETORIG | int16 | Return origin
RETORIGSpecified | bool | Set to True when you assign a value to RETORIG
RETREF | string | Return reference
RETSTAT | string | RMA status
RETTYPE | string | Return type
RETUDATE | string | Received date
RTRNCITY | string | Return city
RTRNNAME | string | Return location name
RTRNZIP | string | Return postal code
RequesterTrx | int16 | Requester transaction
Return_Country | string | Return country
Return_Record_Type | int16 | RMA record type
Return_Time | string | Received time
SHIPMTHD | string | Shipping method
STATE | string | State
SVC_Bill_To_Address_Code | string | Bill to customer address ID
SVC_FO_ID | string | Front office integration ID
SVC_RMA_From_Service | int16 | RMA from service call
SVC_RMA_From_ServiceSpecified | bool | Set to True when you assign a value to SVC_RMA_From_Service
SVC_RMA_Reason_Code | string | RMA reason code
SVC_Return_State | string | Return state
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USERID | string | User ID
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
ZIPCODE | string | Postal code

See Also

<taFSRMAMaster>*


taFSRTVLineSerial_ItemsTaFSRTVLineSerial Class

A class that represents the eConnect node you use to specify a field service RTV line serial number.

Constructor

Name | Description
taFSRTVLineSerial_ItemsTaFSRTVLineSerial() | Initializes an instance of the taFSRTVLineSerial_ItemsTaFSRTVLineSerial class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
BIN | string | Bin
CREATEEQUIPMENT | int16 | Create equipment record
DATERECD | string | Date received
ITEMNMBR | string | Item number
InOrOut | int16 | Incoming or outgoing
LOCNCODE | string | Location code
QTYTYPE | int16 | Quantity type
QTYTypeSpecified | bool | Set to True when you assign a value to QTYTYPE
RTV_Line | Decimal | Sequence number
RTV_Number | string | RTV number
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
SERLTQTY | Decimal | Serial/lot quantity
SLTSQNUM | int32 | Serial sequence number
SVC_Original_Serial | int16 | Original IV serial
SVC_Original_SerialSpecified | bool | Set to True when you assign a value to SVC_Original_Serial
Shipped | int16 | Shipped
ShippedSpecified | bool | Set to True when you assign a value to Shipped
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID

See Also

<taFSRTVLineSerial>*


taFSRTVLine_ItemsTaFSRTVLine Class

A class that represents the eConnect node you use to create or update a field service RTV line.

Constructor

Name | Description
taFSRTVLine_ItemsTaFSRTVLine() | Initializes an instance of the taFSRTVLine_ItemsTaFSRTVLine class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
Bill_of_Lading | string | Bill of lading for return
Bill_of_Lading_Out | string | Bill of lading for shipping
COMPDTE | string | Closed date
COMPTME | string | Closed time
CURNCYID | string | Set to True when you assign a value to
CUSTOWN | int16 | Customer owned item
CUSTOWNSpecified | bool | Set to True when you assign a value to CUSTOWN
DSCRIPTN | string | Description
ENTDTE | string | RTV entered date
ENTTME | string | RTV entered time
Expense_Cost | Decimal | Expense cost
Expense_CostSpecified | bool | Set to True when you assign a value to Expense_Cost
Expense_Price | Decimal | Expense price
Expense_PriceSpecified | bool | Set to True when you assign a value to Expense_Price
ITEMDESC | string | Item description
ITEMNMBR | string | Item number
LNSEQNBR | Decimal | Line sequence number
LNSEQNBRSpecified | bool | Set to True when you assign a value to LNSEQNBR
LOCCODEB | string | Location shipped
LOCNCODE | string | Location received
Labor_Cost | Decimal | Labor cost
Labor_CostSpecified | bool | Set to True when you assign a value to Labor_Cost
Labor_Price | Decimal | Labor price
Labor_PriceSpecified | bool | Set to True when you assign a value to Labor_Price
NOTETXT | string | Notes
OFFID | string | Office ID
PRMDATE | string | RTV promised date
Part_Cost | Decimal | Unit cost
Part_CostSpecified | bool | Set to True when you assign a value to Part_Cost
Part_Price | Decimal | Unit price
Part_PriceSpecified | bool | Set to True when you assign a value to Part_Price
Promised_Time | string | RTV promised time
QUANTITY | Decimal | Quantity
QUANTITYSpecified | bool | Set to True when you assign a value to QUANTITY
REFRENCE | string | Reference
RETDOCID | string | RMA number
RTV_Line | Decimal | Sequence number
RTV_LineSpecified | bool | Set to True when you assign a value to RTV_Line
RTV_Number | string | RTV number
RTV_Type | string | RTV type
Receipt_Time | string | Receipt time
Receiptdate | string | Receipt date
Reference2 | string | Additional reference information
RequesterTrx | int16 | Requester transaction
Return_Item_Number | string | Returned item number
SHIPMTHD | string | Shipping method
SVC_Process_SEQ_Number | Decimal | RMA process sequence number
SVC_Process_SEQ_NumberSpecified | bool | Set to True when you assign a value to SVC_Process_SEQ_Number
Ship_Address_1 | string | Shipping address
Ship_Address_2 | string | Shipping address
Ship_Address_3 | string | Shipping address
Ship_Address_Name | string | Contact person
Ship_City | string | City
Ship_Country | string | Country
Ship_State | string | State
Shipped_Date | string | Ship date
Shipped_Time | string | Ship time
Shipping_Method_Out | string | Shipping method
Tracking_Number | string | Tracking number
Travel_Cost | Decimal | Travel cost
Travel_CostSpecified | bool | Set to True when you assign a value to Travel_Cost
Travel_Price | Decimal | Travel price
Travel_PriceSpecified | bool | Set to True when you assign a value to Travel_Price
UOFM | string | Unit of measure
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
VNDITNUM | string | Vendor item number
VRMA_Document_ID | string | Vendor RMA document number
ZIPCODE | string | Postal code

See Also

<taFSRTVLine>*


taFSRTVMaster Class

A class that represents the eConnect node you use to specify a field service RTV record.

Constructor

Name | Description
taFSRTVMaster() | Initializes an instance of the taFSRTVMaster class.

Properties

Name | Type | Description
ADRSCODE | string | Address ID
Bill_of_Lading | string | BIll of lading return
Bill_of_Lading_Out | string | Bill of lading for shipping
CKHOLD | int16 | Check hold status
CURNCYID | string | Currency ID
DSCRIPTN | string | Description
ENTDTE | string | RTV entered date
ENTTME | string | RTV entered time
LOCCODEB | string | Location shipped
LOCNCODE | string | Location received
NOTETXT | string | Notes
OFFID | string | Office ID
RETDOCID | string | RMA number
RTV_Number | string | RTV number
RTV_Return_Status | string | RTV status
RTV_Type | string | RTV type
RequesterTrx | int16 | Requester transaction
SHIPMTHD | string | Shipping method
Ship_Address_1 | string | Shipping address
Ship_Address_2 | string | Shipping address
Ship_Address_3 | string | Shipping address
Ship_Address_Name | string | Contact person
Ship_City | string | City
Ship_Country | string | Country
Ship_State | string | State
Shipping_Method_Out | string | Shipping method
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USERID | string | User ID
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDNAME | string | Vendor name
VENDORID | string | Vendor ID
VRMA_Document_ID | string | Vendor RMA number
ZIPCODE | string | Postal code

See Also

<taFSRTVMaster>*


taFSServiceCallCodesEquipment_ItemsTaFSServiceCallCodesEquipment Class

A class that represents the eConnect node you use to specify a field service call analysis code.

Constructor

Name | Description
taFSServiceCallCodesEquipment_ItemsTaFSServiceCallCodesEquipment() | Initializes an instance of the taFSServiceCallCodesEquipment_ItemsTaFSServiceCallCodesEquipment class.

Properties

Name | Type | Description
CALLNBR | string | Call number
CAUSECDE | string | Cause code
CUSTNMBR | string | Customer number
ITEMNMBR | string | Item number
PMPERF | int16 | PM performed
PROBCDE | string | Problem code
RPRCODE | string | Repair code
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
SRVRECTYPE | int16 | Service record type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taFSServiceCallCodesEquipment>*


taFSServiceCallLineSerial_ItemsTaFSServiceCallLineSerial Class

A class that represents the eConnect node you use to specify a field service call line serial number.

Constructor

Name | Description
taFSServiceCallLineSerial_ItemsTaFSServiceCallLineSerial() | Initializes an instance of the taFSServiceCallLineSerial_ItemsTaFSServiceCallLineSerial class.

Properties

Name | Type | Description
ADRSCODE | string | Address ID
BIN | string | Bin
CALLNBR | string | Call number
CUSTNMBR | string | Customer number
EQPLINE | int32 | Equipment sequence number
ITEMNMBR | string | Item number
LINITMTYP | string | Line type
LNITMSEQ | int32 | Line sequence number
LOCNCODE | string | Location code
QTYTYPE | int16 | Quantity type
RequesterTrx | int16 | Requester transaction
SERLTNUM | string | Serial number
SERLTQTY | int32 | Serial/lot quantity
SLTSQNUM | int64 | Serial sequence number
SRVRECTYPE | int16 | Service record type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taFSServiceCallLineSerial>*


taFSServiceCallLine_ItemsTaFSServiceCallLine Class

A class that represents the eConnect node you use to create or update a field service call line.

Constructor

Name | Description
taFSServiceCallLine_ItemsTaFSServiceCallLine() | Initializes an instance of the taFSServiceCallLine_ItemsTaFSServiceCallLine class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
ATYALLOC | Decimal | Allocated in inventory
ATYALLOCSpecified | bool | Set to True when you assign a value to ATYALLOC
BILLABLTIM | Decimal | Billable time
BILLABLTIMSpecified | bool | Set to True when you assign a value to BILLABLTIM
CALLNBR | string | Call number
CKCREATEPO | int16 | Create purchase order
CKNORETURNS | int16 | Returnable status
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
Create_Overtime_Labor | int16 | Create overtime labor
ENDDATE | string | End date
ENDTME | string | End time
ENTDTE | string | Entered date
ENTTME | string | Entered time
EQPLINE | int32 | Equipment sequence number
ITEMDESC | string | Item description
ITEMNMBR | string | Item number
LABPCT | Decimal | Percent billable
LABPCTSpecified | bool | Set to True when you assign a value to LABPCT
LINITMTYP | string | Service call type
LNITMSEQ | int64 | Line sequence number
LOCNCODE | string | Location code
MISCPCT | Decimal | Percent billable
MISCPCTSpecified | bool | Set to True when you assign a value to MISCPCT
Miles_End | int32 | Ending mileage
Miles_EndSpecified | bool | Set to True when you assign a value to Miles_End
Miles_Start | int32 | Starting mileage
Miles_StartSpecified | bool | Set to True when you assign a value to Miles_Start
Miles_Used | int32 | Total mileage
Miles_UsedSpecified | bool | Set to True when you assign a value to Miles_Used
NOTETXT | string | Notes
NonInventory | int16 | Noninventory
Overtime_Labor_Item_Number | string | Overtime labor item number
PARTPCT | Decimal | Percentage billable
PARTPCTSpecified | bool | Set to True when you assign a value to PARTPCT
PRICELVL | string | Price level
PRMDATE | string | Promised date
QTYBACKO | Decimal | Quantity backordered
QTYBACKOSpecified | bool | Set to True when you assign a value to QTYBACKO
QTYORDER | Decimal | Quantity
QTYORDERSpecified | bool | Set to True when you assign a value to QTYORDER
QTYSOLD | Decimal | Quantity used
QTYSOLDSpecified | bool | Set to True when you assign a value to QTYSOLD
RequesterTrx | int16 | Requester transaction
SRVRECTYPE | int16 | Service record type
SRVSTAT | string | Status
STRTDATE | string | Start date
STRTTIME | string | Start time
SVC_Address_Option | int16 | Address options
SVC_Address_OptionSpecified | bool | Set to True when you assign a value to SVC_Address_Option
SVC_Disable_XFR_Grouping | int16 | Group related lines
SVC_Disable_XFR_GroupingSpecified | bool | Set to True when you assign a value to SVC_Disable_XFR_Grouping
SVC_FO_ID | string | Front office integration ID
SVC_Misc_Address_Code | string | Miscellaneous address ID
TECHID | string | Technician ID
TRANSTME | Decimal | Actual time
TRANSTMESpecified | bool | Set to True when you assign a value to TRANSTME
UNITCOST | Decimal | Unit cost
UNITCOSTSpecified | bool | Set to True when you assign a value to UNITCOST
UNITPRCE | Decimal | Unit price
UNITPRCESpecified | bool | Set to True when you assign a value to UNITPRCE
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
Work_Type | string | Work type code
XTNDPRCE | Decimal | Extended price
XTNDPRCESpecified | bool | Set to True when you assign a value to XTNDPRCE

See Also

<taFSServiceCallLine>*


taFSServiceCallMaster Class

A class that represents the eConnect node you use to specify a field service call.

Constructor

Name | Description
taFSServiceCallMaster() | Initializes an instance of the taFSServiceCallMaster class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Address code
ARRIVDTE | string | Arrival date
ARRIVTME | string | Arrival time
AutoCreateLabor | int16 | Auto-create labor lines
CALLNBR | string | Call number
CITY | string | City
CKHOLD | int16 | Check hold status
CNTCPRSN | string | Contact person
COMPDTE | string | Closed date
COMPTME | string | Closed time
CONTNBR | string | Contract number
COUNTRY | string | Country
CURNCYID | string | Currency ID
CUSTNAME | string | Customer name
CUSTNMBR | string | Customer number
Customer_Reference | string | Customer reference
DISPDTE | string | Dispatch date
DISPTME | string | Dispatch time
ENTDTE | string | Entered date
ENTTME | string | Entered time
ETADTE | string | Expected date
ETATME | string | Expected time
NOTETXT | string | Notes
OFFID | string | Office ID
PHONE1 | string | Telephone number
PORDNMBR | string | Purchase order number
PRICELVL | string | Price level
PYMTRMID | string | Payment terms ID
RequesterTrx | int16 | Requester transaction
Response_Date | string | Response date
Response_Time | string | Response time
SLPRSNID | string | Salesperson ID
SRVRECTYPE | int16 | Service record type
SRVSTAT | string | Service call status
SRVTYPE | string | Service type
STATE | string | State
SVCAREA | string | Service area
SVCDESCR | string | Service description
SVC_FO_ID | string | Front office integration ID
SVC_On_Hold | int16 | Service on hold
SVC_On_HoldSpecified | bool | Set to True when you assign a value to SVC_On_Hold
TECHID | string | Technician ID
TIMEZONE | string | Time zone
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
ZIP | string | Postal code
priorityLevel | int16 | Priority level

See Also

<taFSServiceCallMaster>*


taFSServiceCallMultiTech Class

A class that represents the eConnect node you use to specify service call information.

Constructor

Name | Description
taFSServiceCallMultiTech() | Initializes an instance of the taFSServiceCallMultiTech class.

Properties

Name | Type | Description
CALLNBR | string | Call number
CUSTNMBR | string | Customer number
EQPLINE | int32 | Equipment line number
ITEMNMBR | string | Item number
LNITMSEQ | int32 | Line item sequence number
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
SRVRECTYPE | int16 | Service record type
TECHID | string | Tech ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taFSServiceCallMultiTech>*


taGLTransactionHeaderInsert Class

A class that represents the eConnect node you use to specify a general ledger transaction header.

Constructor

Name | Description
taGLTransactionHeaderInsert() | Initializes an instance of the taGLTransactionHeaderInsert class.

Properties

Name | Type | Description
Adjustment_Transaction | int16 | Adjustment transaction
BACHNUMB | string | Batch number
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
JRNENTRY | int32 | Journal entry number
Ledger_ID | int16 | Ledger ID
NOTETEXT | string | Notes
PRVDSLMT | int16 | Previous day limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type ID
RATEVARC | Decimal | Rate variance
REFRENCE | string | Reference
RTCLCMTD | int16 | Rate calculation method
RVRSNGDT | string | Reversing date
RequesterTrx | int16 | Requester transaction
SERIES | int16 | Series
SOURCDOC | string | Source document
SQNCLINE | Decimal | Sequence
TIME1 | string | Time
TRXDATE | string | Transaction date
TRXDTDEF | int16 | Transaction date default
TRXTYPE | int16 | Transaction type
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate

See Also

<taGLTransactionHeaderInsert>


taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert Class

A class that represents the eConnect node you use to specify a general ledger transaction line.

Constructor

Name | Description
taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert() | Initializes an instance of the taGLTransactionLineInsert_ItemsTaGLTransactionLineInsert class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTNUMST | string | Account number
BACHNUMB | string | Batch number
CRDTAMNT | Decimal | Credit amount
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DEBITAMT | Decimal | Debit amount
DOCDATE | string | Document date
DSCRIPTN | string | Description
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
JRNENTRY | int32 | Journal entry number
ORCTRNUM | string | Originating control number
ORDOCNUM | string | Originating document number
ORMSTRID | string | Originating master ID
ORMSTRNM | string | Originating master name
ORTRXDESC | string | Originating transaction description
ORTRXTYP | int16 | Originating transaction type
OrigSeqNum | int32 | Originating sequence number
PRVDSLMT | int16 | Previous days limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type ID
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
SQNCLINE | Decimal | Sequence
TAXACTNUMST | string | Tax account
TAXAMNT | Decimal | Tax amount
TAXDTLID | string | Tax detail ID
TIME1 | string | Time
TRXDTDEF | int16 | Transaction date default
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate

See Also

<taGLTransactionLineInsert>


taIVCreateItemPriceListHeader Class

A class that represents the eConnect node you use to create or update an inventory item price list header.

Constructor

Name | Description
taIVCreateItemPriceListHeader() | Initializes an instance of the taIVCreateItemPriceListHeader class.

Properties

Name | Type | Description
CURNCYID | string | Currency ID
ITEMNMBR | string | Item number
PRCLEVEL | string | Price level
PRICMTHD | int16 | Price method
PRICMTHDSpecified | bool | Set to True when you assign a value to PRICMTHD
PriceGroup | string | Price group
RequesterTrx | int16 | Requester transaction
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taIVCreateItemPriceListHeader>*


taIVCreateItemPriceListLine_ItemsTaIVCreateItemPriceListLine Class

A class that represents the eConnect node you use to create or update an inventory item price list line.

Constructor

Name | Description
taIVCreateItemPriceListLine_ItemsTaIVCreateItemPriceListLine() | Initializes an instance of the taIVCreateItemPriceListLine_ItemsTaIVCreateItemPriceListLine class.

Properties

Name | Type | Description
CURNCYID | string | Currency ID
ITEMNMBR | string | Item number
PRCLEVEL | string | Price level
RNDGAMNT | Decimal | Rounding amount
ROUNDHOW | int16 | Rounding option
ROUNDTO | int16 | Rounding policy
RequesterTrx | int16 | Requester transaction
TOQTY | Decimal | To quantity
UMSLSOPT | int16 | Unit of measure selling option
UMSLSOPTSpecified | bool | Set to True when you assign a value to UMSLSOPT
UOFM | string | Unit of measure
UOMPRICE | Decimal | Unit of measure price/percentage
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | User-defined field

See Also

<taIVCreateItemPriceListLine>*


taIVCreatePriceGroup Class

A class that represents the eConnect node you use to create an inventory price group.

Constructor

Name | Description
taIVCreatePriceGroup() | Initializes an instance of the taIVCreatePriceGroup class.

Properties

Name | Type | Description
DSCRIPTN | string | Description
PriceGroup | string | Price group
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVCreatePriceGroup>


taIVCreatePriceLevel Class

A class that represents the eConnect node you use to create an inventory price level.

Constructor

Name | Description
taIVCreatePriceLevel() | Initializes an instance of the taIVCreatePriceLevel class.

Properties

Name | Type | Description
DSCRIPTN | string | Description
PRCLEVEL | string | Price level
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVCreatePriceLevel>


taIVCreateUOFMScheduleHeader Class

A class that represents the eConnect node you use to create an inventory unit of measure schedule header.

Constructor

Name | Description
taIVCreateUOFMScheduleHeader() | Initializes an instance of the taIVCreateUOFMScheduleHeader class.

Properties

Name | Type | Description
BASEUOFM | string | Base unit of measure
RequesterTrx | int16 | Requester transaction
UMDPQTYS | int16 | Decimal place quantity
UMSCHDSC | string | Unit of measure schedule description
UOMSCHDL | string | Unit of measure schedule
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVCreateUOFMScheduleHeader>


taIVCreateUOFMScheduleLine_ItemsTaIVCreateUOFMScheduleLine Class

A class that represents the eConnect node you use to create an inventory unit of measure schedule line.

Constructor

Name | Description
taIVCreateUOFMScheduleLine_ItemsTaIVCreateUOFMScheduleLine() | Initializes an instance of the taIVCreateUOFMScheduleLine_ItemsTaIVCreateUOFMScheduleLine class.

Properties

Name | Type | Description
EQUIVUOM | string | Equivalent unit of measure
EQUOMQTY | Decimal | Equivalent unit of measure quantity
RequesterTrx | int16 | Requester transaction
UOFM | string | Unit of measure
UOFMLONGDESC | string | Description
UOMSCHDL | string | Unit of measure schedule
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVCreateUOFMScheduleLine>


taIVMultibinBinToBinTransfer Class

A class that represents the eConnect node you use to specify an inventory bin to bin transfer.

Constructor

Name | Description
taIVMultibinBinToBinTransfer() | Initializes an instance of the taIVMultibinBinToBinTransfer class.

Properties

Name | Type | Description
AddMoreSerLots | int16 | Add serial lot numbers
BIN | string | Bin
Bin_XFer_Date | string | Bin transfer document date
Bin_XFer_Doc_Number | string | Bin transfer document number
CreateBin | int16 | Create a bin
EXPNDATE | string | Expiration date
ITEMNMBR | string | Item number
LOCNCODE | string | Location code
QTYTYPE | int16 | Quantity type
QUANTITY | Decimal | Quantity
Reason_Code | string | Reason code
RequesterTrx | int16 | Requester transaction
ResetQty | int16 | Reset quantity
SerLotNmbr | string | Serial or lot number
TOBIN | string | To bin
UOFM | string | Unit of measure
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVMultibinBinToBinTransfer>


taIVTransactionHeaderInsert Class

A class that represents the eConnect node you use to create an inventory transaction header.

Constructor

Name | Description
taIVTransactionHeaderInsert() | Initializes an instance of the taIVTransactionHeaderInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
DOCDATE | string | Document date
IVDOCNBR | string | Document number
IVDOCTYP | int16 | Document type
MDFUSRID | string | Modified user ID
NOTETEXT | string | Notes
POSTEDDT | string | Posted date
POSTTOGL | int16 | Post to general ledger
PTDUSRID | string | Posted user ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransactionHeaderInsert>


taIVTransactionLineInsert_ItemsTaIVTransactionLineInsert Class

A class that represents the eConnect node you use to create an inventory transaction line.

Constructor

Name | Description
taIVTransactionLineInsert_ItemsTaIVTransactionLineInsert() | Initializes an instance of the taIVTransactionLineInsert_ItemsTaIVTransactionLineInsert class.

Properties

Name | Type | Description
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
IVDOCTYP | int16 | Document type
IVIVINDX | int32 | Inventory index
IVIVOFIX | int32 | Inventory offset index
InventoryAccount | string | Inventory account
InventoryAccountOffSet | string | Offset account
LNSEQNBR | Decimal | Line sequence number
OverrideQty | int16 | Override quantity
Reason_COde | string | Reason code
RequesterTrx | int16 | Requester transaction
TRXLOCTN | string | Location ID
TRXQTY | Decimal | Transaction quantity
UNITCOST | Decimal | Unit cost
UNITCOSTSpecified | bool | Set to True when you assign a value to UNITCOST
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransactionLineInsert>


taIVTransactionLotInsert_ItemsTaIVTransactionLotInsert Class

A class that represents the eConnect node you use to create an inventory transaction line.

Constructor

Name | Description
taIVTransactionLotInsert_ItemsTaIVTransactionLotInsert() | Initializes an instance of the taIVTransactionLotInsert_ItemsTaIVTransactionLotInsert class.

Properties

Name | Type | Description
ADJTYPE | int16 | Adjustment type
AUTOCREATELOT | int32 | Auto-create lot number
BIN | string | Bin
CreateBin | int16 | Create a bin
DATERECD | string | Date of the lot
EXPNDATE | string | Expiration date
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
IVDOCTYP | int16 | Document type
LNSEQNBR | int32 | Line sequence number
LOCNCODE | string | Location code
LOTNUMBR | string | Lot number
MFGDATE | string | Manufacturing date
RequesterTrx | int16 | Requester transaction
SERLTQTY | Decimal | Quantity
USERDATE | string | User date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransactionLotInsert>


taIVTransactionMultiBinInsert_ItemsTaIVTransactionMultiBinInsert Class

A class that represents the eConnect node you use to create an inventory multibin transaction.

Constructor

Name | Description
taIVTransactionMultiBinInsert_ItemsTaIVTransactionMultiBinInsert() | Initializes an instance of the taIVTransactionMultiBinInsert_ItemsTaIVTransactionMultiBinInsert class.

Properties

Name | Type | Description
ADJTYPE | int16 | Adjustment type
BIN | string | Bin
CreateBin | int16 | Create a bin
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
IVDOCTYP | int16 | Document type
LNSEQNBR | Decimal | Line sequence number
OverrideBin | int16 | Override bin shortage
QUANTITY | Decimal | Quantity
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransactionMultiBinInsert>


taIVTransactionSerialInsert_ItemsTaIVTransactionSerialInsert Class

A class that represents the eConnect node you use to create an inventory serial line.

Constructor

Name | Description
taIVTransactionSerialInsert_ItemsTaIVTransactionSerialInsert() | Initializes an instance of the taIVTransactionSerialInsert_ItemsTaIVTransactionSerialInsert class.

Properties

Name | Type | Description
ADJTYPE | int16 | Adjustment type
AUTOCREATESERIAL | int32 | Auto-create serial number
BIN | string | Bin
CreateBin | int16 | Create a bin
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
IVDOCTYP | int16 | Document type
LNSEQNBR | Decimal | Line sequence number
LOCNCODE | string | Location code
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransactionSerialInsert>


taIVTransferHeaderInsert Class

A class that represents the eConnect node you use to create an inventory transfer header.

Constructor

Name | Description
taIVTransferHeaderInsert() | Initializes an instance of the taIVTransferHeaderInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
DOCDATE | string | Document date
IVDOCNBR | string | Document number
POSTTOGL | int16 | Post to general ledger
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransferHeaderInsert>


taIVTransferLineInsert_ItemsTaIVTransferLineInsert Class

A class that represents the eConnect node you use to create an inventory transfer line.

Constructor

Name | Description
taIVTransferLineInsert_ItemsTaIVTransferLineInsert() | Initializes an instance of the taIVTransferLineInsert_ItemsTaIVTransferLineInsert class.

Properties

Name | Type | Description
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
IVIVINDX | int32 | Inventory index
IVIVOFIX | int32 | Offset index
InventoryAccount | string | Inventory account
InventoryAccountOffSet | string | Offset account
LNSEQNBR | Decimal | Line sequence number
OverrideQty | int16 | Override quantity
Reason code | string | Reason code
RequesterTrx | int16 | Requester transaction
TRFQTYTY | int16 | Transfer from quantity
TRNSTLOC | string | Transfer location
TRTQTYTY | int16 | Transfer to quantity
TRXLOCTN | string | Transaction location
TRXQTY | Decimal | Transaction quantity
UNITCOST | Decimal | Unit cost
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransferLineInsert>


taIVTransferLotInsert_ItemsTaIVTransferLotInsert Class

A class that represents the eConnect node you use to create an inventory transfer lot.

Constructor

Name | Description
taIVTransferLotInsert_ItemsTaIVTransferLotInsert() | Initializes an instance of the taIVTransferLotInsert_ItemsTaIVTransferLotInsert class.

Properties

Name | Type | Description
AUTOCREATELOT | int32 | Auto-create lot number
BIN | string | Bin
CreateBin | int16 | Create a bin
EXPNDATE | string | Expiration date
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
LNSEQNBR | int32 | Line sequence number
LOCNCODE | string | Location code
LOTNUMBR | string | Lot number
MFGDATE | string | Manufacturing date
OverrideBin | int16 | Override bin shortage
QTYTYPE | int16 | Quantity type
RequesterTrx | int16 | Requester transaction
SERLTQTY | Decimal | Quantity
SLTSQNUM | int32 | Lot sequence number
TOBIN | string | To bin
TOLOCNCODE | string | Transfer location code
USERDATE | string | User date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransferLotInsert>


taIVTransferMultiBinInsert_ItemsTaIVTransferMultiBinInsert Class

A class that represents the eConnect node you use to create an inventory multibin transfer.

Constructor

Name | Description
taIVTransferMultiBinInsert_ItemsTaIVTransferMultiBinInsert() | Initializes an instance of the taIVTransferMultiBinInsert_ItemsTaIVTransferMultiBinInsert class.

Properties

Name | Type | Description
BIN | string | Bin
CreateBin | int16 | Create a bin
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
LNSEQNBR | Decimal | Line sequence number
OverrideBin | int16 | Override bin shortage
QUANTITY | Decimal | Quantity
RequesterTrx | int16 | Requester transaction
SERLTNUM | string | Serial or lot number
SLTSQNUM | int32 | Serial or lot sequence number
TOBIN | string | To bin
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransferMultiBinInsert>


taIVTransferSerialInsert_ItemsTaIVTransferSerialInsert Class

A class that represents the eConnect node you use to create an inventory transfer serial line.

Constructor

Name | Description
taIVTransferSerialInsert_ItemsTaIVTransferSerialInsert() | Initializes an instance of the taIVTransferSerialInsert_ItemsTaIVTransferSerialInsert class.

Properties

Name | Type | Description
AUTOCREATESERIAL | int32 | Auto-create serial number
BIN | string | Bin
CreateBin | int16 | Create a bin
ITEMNMBR | string | Item number
IVDOCNBR | string | Document number
LNSEQNBR | Decimal | Line sequence number
LOCNCODE | string | Location code
OverrideBin | int16 | Override bin shortage
QTYTYPE | int16 | Quantity type
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
TOBIN | string | To bin
TOLOCNCODE | string | Transfer location code
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taIVTransferSerialInsert>


taItemSite_ItemsTaItemSite Class

A class that represents the eConnect node you use to create or update an inventory item site.

Constructor

Name | Description
taItemSite_ItemsTaItemSite() | Initializes an instance of the taItemSite_ItemsTaItemSite class.

Properties

Name | Type | Description
BINNMBR | string | Bin
ITEMNMBR | string | Item number
LOCNCODE | string | Location code
Landed_Cost_Group_ID | string | Landed cost group
PRIMVNDR | string | Primary vendor ID
QTYRQSTN | Decimal | Requisition quantity
QTYRQSTNSpecified | bool | Set to True when you assign a value to QTYRQSTN
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taItemSite>*


taMdaUpdate_ItemsTaMdaUpdate Class

A class that represents the eConnect node you use to specify a MDA update.

Constructor

Name | Description
taMdaUpdate_ItemsTaMdaUpdate() | Initializes an instance of the taMdaUpdate_ItemsTaMdaUpdate class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
CODEID | string | Code ID
DTAQNTY | Decimal | Quantity
DTAREF | string | Data reference
DTASERIES | int16 | Data series
GROUPID | string | Group ID
POSTDESC | string | Override posting description
SEQNUMBR | int32 | Sequence number

See Also

<taMdaUpdate>


taPAAccountsSetup_ItemsTaPAAccountsSetup Class

A class that represents the eConnect node you use to create a project account.

Constructor

Name | Description
taPAAccountsSetup_ItemsTaPAAccountsSetup() | Initializes an instance of the taPAAccountsSetup_ItemsTaPAAccountsSetup class.

Properties

Name | Type | Description
PAAccount | string | Account number
PAacctType | int16 | Account type
PAcosttrxid | string | Cost transaction ID
PArecordid | string | Record ID
PAsfid | int16 | File ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAAccountsSetup>


taPAChangeOrderEntryBudget_ItemsTaPAChangeOrderEntryBudget Class

A class that represents the eConnect node you use to specify a project budget change order.

Constructor

Name | Description
taPAChangeOrderEntryBudget_ItemsTaPAChangeOrderEntryBudget() | Initializes an instance of the taPAChangeOrderEntryBudget_ItemsTaPAChangeOrderEntryBudget class.

Properties

Name | Type | Description
LNITMSEQ | int32 | Line sequence number
PACHGORDNO | string | Change order number
PACONTNUMBER | string | Contract number
PACOSTATUS | int16 | Change order status
PACOSTCATID | string | Cost category ID
PAEnDate | string | End date
PAGBTRKCHG | int16 | Track changes
PAOverheaPercentage | Decimal | Variance overhead amount percentage
PAOvhdAmtPerUnit | Decimal | Variance overhead amount per unit
PAPROJNUMBER | string | Project number
PAPURCHTAXSCHED | string | Purchase tax schedule ID
PAProfitAmount | Decimal | Profit amount
PAProfitPercent | Decimal | Profit percent
PAPurchase_Tax_Options | int16 | Purchase tax options
PAQtyQ | Decimal | Quantity
PASales_Tax_Options | int16 | Sales tax options
PAUNITCOST | Decimal | Unit cost
PAVARMUPRCNT | Decimal | Variable mark up percent
PAVAROVERHDPRCNT | Decimal | Variance overhead percent
PAVAROVRHDUNIT | Decimal | Variance overhead per unit amount
PAVARPROFAMT | Decimal | Variance profit amount
PAVarianceCosts | Decimal | Variance cost
PAVarianceQty | Decimal | Variance quantity
PAbegindate | string | Begin date
PAbilltaxscheduleid | string | Billing tax schedule ID
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAChangeOrderEntryBudget>


taPAChangeOrderEntryFeeDetail_ItemsTaPAChangeOrderEntryFeeDetail Class

A class that represents the eConnect node you use to specify project change order fee details.

Constructor

Name | Description
taPAChangeOrderEntryFeeDetail_ItemsTaPAChangeOrderEntryFeeDetail() | Initializes an instance of the taPAChangeOrderEntryFeeDetail_ItemsTaPAChangeOrderEntryFeeDetail class.

Properties

Name | Type | Description
PACHGORDNO | string | Change order number
PACONTNUMBER | string | Contract number
PAEnDate | string | End date
PAFeeAmount | Decimal | Fee amount
PAFeeID | string | Fee ID
PAFeePercent | Decimal | Fee percent
PAFeeToUse | int16 | Fee to use
PAFrequency | int16 | Frequency
PALineItemSeq | int32 | Line sequence number
PAPROJNUMBER | string | Project number
PARenew | int16 | Renew
PARenewal_Date | string | Renew date
PASales_Tax_Options | int16 | Sales tax options
PA_Renew_Day | int32 | Renew day
PA_Renew_Month | int32 | Renew month
PAbegindate | string | Begin date
PAbilltaxscheduleid | string | Billing tax schedule ID
PAtotcbEL | int16 | Equipment log
PAtotcbML | int16 | Miscellaneous log
PAtotcber | int16 | Employee expense
PAtotcbinv | int16 | Inventory
PAtotcbts | int16 | Timesheet
PAtotcbvi | int16 | Purchasing inventory
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAChangeOrderEntryFeeDetail>


taPAChangeOrderEntryFeeHeader_ItemsTaPAChangeOrderEntryFeeHeader Class

A class that represents the eConnect node you use to specify a project change order fee header.

Constructor

Name | Description
taPAChangeOrderEntryFeeHeader_ItemsTaPAChangeOrderEntryFeeHeader() | Initializes an instance of the taPAChangeOrderEntryFeeHeader_ItemsTaPAChangeOrderEntryFeeHeader class.

Properties

Name | Type | Description
PACHGORDNO | string | Change order number
PAEnDate | string | End date
PALineItemSeq | int16 | Line sequence number
PAPROJNUMBER | string | Project number
PATOTPRJFEEAMT | Decimal | Total project fee amount
PATOTRETNFEEAMT | Decimal | Total retainer fee amount
PATOTRETNTNAMT | Decimal | Total retention fee amount
PATOTSRVCFEEAMT | Decimal | Total service fee amount
PAbegindate | string | Begin date
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAChangeOrderEntryFeeHeader>


taPAChangeOrderEntryFeeSchedule_ItemsTaPAChangeOrderEntryFeeSchedule Class

A class that represents the eConnect node you use to specify a project change order fee schedule.

Constructor

Name | Description
taPAChangeOrderEntryFeeSchedule_ItemsTaPAChangeOrderEntryFeeSchedule() | Initializes an instance of the taPAChangeOrderEntryFeeSchedule_ItemsTaPAChangeOrderEntryFeeSchedule class.

Properties

Name | Type | Description
LNITMSEQ | int32 | Line sequence number
PACHGORDNO | string | Change order number
PACONTNUMBER | string | Contract number
PADT | string | Scheduled date
PAFeeAmount | Decimal | Fee amount
PAFeeID | string | Fee ID
PAGBTRKCHG | int16 | Track changes
PAPROJNUMBER | string | Project number
PAsequencenumber | int16 | Sequence number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAChangeOrderEntryFeeSchedule>


taPAChangeOrderEntryHdr Class

A class that represents the eConnect node you use to specify a project change order header.

Constructor

Name | Description
taPAChangeOrderEntryHdr() | Initializes an instance of the taPAChangeOrderEntryHdr class.

Properties

Name | Type | Description
APPRVLDT | string | Approval date
DSCRIPTN | string | Description
PAAPPROVBY | string | Approved by
PACHGORDNO | string | Change order number
PACOCUSTNO | string | Customer number
PACODESC | string | Change order description
PACONTNUMBER | string | Contract number
PACOSTATUS | int16 | Change order status
PACOTYPE | int16 | Change order type
PADOCDT | string | Change order date
PAESTBY | string | Estimated by
PAGBTRKCHG | int16 | Track changes
PAREVBY | string | Revised by
PAREVPOSITION | string | Revised by position
PAREVREASON | string | Revised reason
REQSTDBY | string | Requested by
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAChangeOrderEntryHdr>


taPAContractBillingCycle_ItemsTaPAContractBillingCycle Class

A class that represents the eConnect node you use to specify a project contract billing cycle.

Constructor

Name | Description
taPAContractBillingCycle_ItemsTaPAContractBillingCycle() | Initializes an instance of the taPAContractBillingCycle_ItemsTaPAContractBillingCycle class.

Properties

Name | Type | Description
Action | int16 | Action
PABILLCYCLEID | string | Billing cycle ID
PABILLFORMAT | string | Billing format
PACONTNUMBER | string | Contract number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAContractBillingCycle>


taPAContracts Class

A class that represents the eConnect node you use to create a project contract.

Constructor

Name | Description
taPAContracts() | Initializes an instance of the taPAContracts class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
COMAPPTO | int16 | Sales commission applied
COMAPPTOSpecified | bool | Set to True when you assign a value to COMAPPTO
COMPRCNT | int32 | Sales commission percent
COMPRCNTSpecified | bool | Set to True when you assign a value to COMPRCNT
CUSTNMBR | string | Customer number
DSCPCTAM | Decimal | Discount period amount
DSCPCTAMSpecified | bool | Set to True when you assign a value to DSCPCTAM
PAAcctgMethod | int16 | Accounting method
PABILLCYCLEID1 | string | Billing cycle ID
PABILLFORMAT | string | Billing format
PABusMgrID | string | Business manager ID
PACONTNUMBER | string | Contract number
PAContMgrID | string | Contract manager ID
PAMCCURNCYID | string | MC currency ID
PAProjectType | int16 | Project type
PASTAT | int16 | Status
PASTATSpecified | bool | Set to True when you assign a value to PASTAT
PASegmentCB | int16 | Account segment checkbox
PASegmentCBSpecified | bool | Set to True when you assign a value to PASegmentCB
PATRKCHGORDS | int16 | Track change orders
PATRKCHGORDSSpecified | bool | Set to True when you assign a value to PATRKCHGORDS
PATRKCOBDGADDFLY | int16 | Track changes orders for new budget
PATRKCOBDGADDFLYSpecified | bool | Set to True when you assign a value to PATRKCOBDGADDFLY
PAUD1_Cont | string | User-defined field
PAUD2_Cont | string | User-defined field
PA_RestrictCustomerList | int16 | Restrict customer list
PA_RestrictCustomerListSpecified | bool | Set to True when you assign a value to PA_RestrictCustomerList
PAbillnoteEE | string | Employee expense
PAbillnoteEL | string | Equipment log
PAbillnoteFEE | string | Fee
PAbillnoteINV | string | Inventory
PAbillnoteML | string | Miscellaneous log
PAbillnoteTS | string | Timesheet
PAbillnoteVI | string | Vi
PAcloseProjcosts | int16 | Close to project costs
PAcloseProjcostsSpecified | bool | Set to True when you assign a value to PAcloseProjcosts
PAclosetobillings | int16 | Close to billings
PAclosetobillingsSpecified | bool | Set to True when you assign a value to PAclosetobillings
PAcontclassid | string | Contract class ID
PAcontid | string | Contract ID
PAcontname | string | Contract name
PApurordnum | string | Purchase order number
PRBTADCD | string | Bill to address
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory ID
SLPRSNID | string | Salesperson ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateExisting | int16 | Update if exists flag

See Also

<taPAContracts>


taPAEmpExpenseHdrInsert Class

A class that represents the eConnect node you use to create a project employee expense header.

Constructor

Name | Description
taPAEmpExpenseHdrInsert() | Initializes an instance of the taPAEmpExpenseHdrInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
BCKTXAMT | Decimal | Back out tax amount
BKTPURAM | Decimal | Back out purchase amount
CAMCBKID | string | Checkbook ID
CAMPMTNM | string | Cash payment number
CAMPYNBR | string | Check payment number
CAMTDATE | string | Cash date
CARDNAME | string | Credit card name
CASHAMNT | Decimal | Cash amount
CCAMPYNM | string | Credit card payment number
CCRCTNUM | string | Credit card receipt number
CDOCNMBR | string | Cash document number
CHAMCBID | string | Checkbook ID
CHEKAMNT | Decimal | Check amount
CHEKDATE | string | Check date
CHEKNMBR | string | Check number
CHRGAMNT | Decimal | Charge amount
CRCARDDT | string | Credit card date
CRCRDAMT | Decimal | Credit card amount
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DOCAMNT | Decimal | Document amount
DYSTINCR | int16 | Days to increment
EMPLOYID | string | Employee ID
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
FRTAMNT | Decimal | Freight amount
FRTSCHID | string | Freight schedule
FRTTXAMT | Decimal | Freight tax amount
MSCCHAMT | Decimal | Miscellaneous charge amount
MSCSCHID | string | Miscellaneous schedule ID
MSCTXAMT | Decimal | Miscellaneous tax amount
PACOMM | string | Comment
PADOCDT | string | Document date
PAEnDate | string | End date
PAFreight_Taxable_P | int16 | Taxable freight
PAMisc_Taxable_P | int16 | Taxable miscellaneous
PAPD | string | Post date
PAREFNO | string | Reference number
PAREIMBURSTAXAMT | Decimal | Reimbursable tax amount
PAReimbursableAmount | Decimal | Reimbursable amount
PAStartDate | string | Start date
PATACRV | Decimal | Total accrued revenue
PATQTY | Decimal | Total quantity
PAUD1 | string | User-defined field
PAUD2 | string | User-defined field
PAVENADDRESSID | string | Vendor Address ID
PAerdocnumber | string | Employee expense document number
PAertrxtype | int16 | Employee expense transaction type
PApostoDynPM | int16 | Post to payable management
PAreptsuff | string | reporting suffix
PDK_EE_No | string | Employee expense number
PRVDSLMT | int16 | Previous day limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type ID
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
SHIPMTHD | string | Shipping method
TAXAMNT | Decimal | Tax amount
TAXSCHID | string | Tax schedule
TEN99AMNT | Decimal | 1099 amount
TIME1 | string | Time
TRDISAMT | Decimal | Trade discount
TRXDTDEF | int16 | Transaction date default
TaxInvRecvd | int16 | Tax invoice received
TaxInvReqd | int16 | Tax invoice required
Tax_Date | string | Tax date
UN1099AM | Decimal | Unapplied 1099 amount
USERID | string | User ID
USINGHEADERLEVELTAXES | int16 | Use header level taxes
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate

See Also

<taPAEmpExpenseHdrInsert>


taPAEmpExpenseLineInsert_ItemsTaPAEmpExpenseLineInsert Class

A class that represents the eConnect node you use to create a project employee expense line.

Constructor

Name | Description
taPAEmpExpenseLineInsert_ItemsTaPAEmpExpenseLineInsert() | Initializes an instance of the taPAEmpExpenseLineInsert_ItemsTaPAEmpExpenseLineInsert class.

Properties

Name | Type | Description
BCKTXAMT | Decimal | Back out tax amount
CURNCYID | string | Currency ID
EMPLOYID | string | Employee ID
ITMTSHID | string | Item tax schedule
LNITMSEQ | int32 | Line sequence number
PACOSTCATID | string | Cost category
PADT | string | Date
PAExpenseType | int16 | Expense type
PAPROJNUMBER | string | Project number
PAPaymentMethod | int16 | Payment method
PAPurchase_Tax_Options | int16 | Purchase tax options
PAQtyQ | Decimal | Quantity
PAREFNO | string | Reference number
PAReference_Line_Seq_N | int32 | Reference line sequence number
PAUNITCOST | Decimal | Unit cost
PAUnit_of_Measure | string | Unit of measure
PAbllngtype | int16 | Billing type
PAerdocnumber | string | Employee expense document number
PAertrxType Class | int16 | Employee expense transaction type
PAitemnumber | string | Item number
RequesterTrx | int16 | Requester transaction
TAXAMNT | Decimal | Tax amount
UOMSCHDL | string | Unit of measure schedule
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAEmpExpenseLineInsert>


taPAEmpExpenseTaxInsert_ItemsTaPAEmpExpenseTaxInsert Class

A class that represents the eConnect node you use to create a project employee expense tax line.

Constructor

Name | Description
taPAEmpExpenseTaxInsert_ItemsTaPAEmpExpenseTaxInsert() | Initializes an instance of the taPAEmpExpenseTaxInsert_ItemsTaPAEmpExpenseTaxInsert class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
BKOUTTAX | int16 | Back out tax
EMPLOYID | string | Employee ID
FRTTXAMT | Decimal | Freight tax
LNITMSEQ | int32 | Line sequence number
MSCTXAMT | Decimal | Miscellaneous tax
PAREIMBURSTAXAMT | Decimal | Reimbursed tax amount
PAerdocnumber | string | Employee expense document number
PAertrxtype | int16 | Employee expense transaction type
PCTAXAMT | Decimal | Purchase tax amount
RequesterTrx | int16 | Requester transaction
TAXAMNT | Decimal | Tax amount
TAXDTLID | string | Tax detail
TAXTYPE | int16 | Tax type
TDTTXPUR | Decimal | Tax detail total taxable purchase
TXDTTPUR | Decimal | Tax detail total purchase
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAEmpExpenseTaxInsert>


taPAEquipLogHdrInsert Class

A class that represents the eConnect node you use to create a project equipment log header.

Constructor

Name | Description
taPAEquipLogHdrInsert() | Initializes an instance of the taPAEquipLogHdrInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
PACOMM | string | Comment
PADOCDT | string | Document date
PAEQLOGNO | string | Document number
PAEQLTRX | int16 | Equipment log transaction type
PAEQUIPTID | string | Equipment ID
PAREFNO | string | Reference number
PAREPD | int32 | Reporting period
PAREPDT | string | Reporting period date
PATACRV | Decimal | Accrued revenue
PATQTY | Decimal | Quantity
PAreptsuff | string | Reporting suffix
PAtotcosts | Decimal | Cost
PRVDSLMT | int16 | Previous day limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
TIME1 | string | Time
TRXDTDEF | int16 | Transaction date default
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate

See Also

<taPAEquipLogHdrInsert>


taPAEquipLogLineInsert_ItemsTaPAEquipLogLineInsert Class

A class that represents the eConnect node you use to create a project equipment log line.

Constructor

Name | Description
taPAEquipLogLineInsert_ItemsTaPAEquipLogLineInsert() | Initializes an instance of the taPAEquipLogLineInsert_ItemsTaPAEquipLogLineInsert class.

Properties

Name | Type | Description
CURNCYID | string | Currency ID
LNITMSEQ | int32 | Line item sequence number
PACOSTCATID | string | Cost category
PADOCDT | string | Document date
PADT | string | Date
PAEQLOGNO | string | Document number
PAEQLTRX | int16 | Transaction type
PAEQUIPTID | string | Equipment ID
PAPROJNUMBER | string | Project ID
PAQtyQ | Decimal | Quantity
PAREFNO | string | Reference number
PAREPD | int32 | Reporting period
PAREPDT | string | Reporting period begin date
PATB | string | Begin time
PATE | string | End time
PATOTCST | Decimal | Total cost
PAUNITCOST | Decimal | Unit cost
PAUnit_of_Measure | string | Unit of measure
PAbllngType Class | int16 | Billing type
PAtx500 | string | Notes
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAEquipLogLineInsert>


taPAMiscLogHdrInsert Class

A class that represents the eConnect node you use to create a project miscellaneous log header.

Constructor

Name | Description
taPAMiscLogHdrInsert() | Initializes an instance of the taPAMiscLogHdrInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
PACOMM | string | Comment
PADOCDT | string | Document date
PAMISCLDOCNO | string | Log number
PAREFNO | string | Reference number
PAREPD | int32 | Reporting period
PAREPDT | string | Reporting period begin date
PATACRV | Decimal | Total accrued revenue
PATQTY | Decimal | Quantity
PAreptsuff | string | Reporting suffix
PAtotcosts | Decimal | Total cots
PRVDSLMT | int16 | Previous day limit
PSMISCID | string | Miscellaneous ID
PSMISCLTRXTYPE | int16 | Transaction type
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
TIME1 | string | Time
TRXDTDEF | int16 | Transaction date default
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate

See Also

<taPAMiscLogHdrInsert>


taPAMiscLogLineInsert_ItemsTaPAMiscLogLineInsert Class

A class that represents the eConnect node you use to create a project miscellaneous log line.

Constructor

Name | Description
taPAMiscLogLineInsert_ItemsTaPAMiscLogLineInsert() | Initializes an instance of the taPAMiscLogLineInsert_ItemsTaPAMiscLogLineInsert class.

Properties

Name | Type | Description
CURNCYID | string | Currency ID
LNITMSEQ | int32 | Line sequence number
PACOSTCATID | string | Cost category
PADOCDT | string | Document date
PADT | string | Date
PAMISCLDOCNO | string | Log number
PAPROJNUMBER | string | Project number
PAQtyQ | Decimal | Quantity
PAREFNO | string | Reference number
PAREPD | int32 | Reporting period
PAREPDT | string | Reporting period begin date
PATOTCST | Decimal | Total cost
PAUNITCOST | Decimal | Unit cost
PAUNITCOSTSpecified | bool | Set to True when you assign a value to PAUNITCOST
PAUnit_of_Measure | string | Unit of measure
PAbllngType | int16 | Billing type
PAtx500 | string | Notes
PSMISCID | string | Miscellaneous ID
PSMISCLTRXTYPE | int16 | Transaction type
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAMiscLogLineInsert>


taPAProjectAccess_ItemsTaPAProjectAccess Class

A class that represents the eConnect node you use to create or update project access information.

Constructor

Name | Description
taPAProjectAccess_ItemsTaPAProjectAccess() | Initializes an instance of the taPAProjectAccess_ItemsTaPAProjectAccess class.

Properties

Name | Type | Description
Action | int16 | Action
EMPLOYID | string | Employee ID
PAPROJNUMBER | string | Project number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAProjectAccess>


taPAProjectBillingCycle_ItemsTaPAProjectBillingCycle Class

A class that represents the eConnect node you use to create a project billing cycle.

Constructor

Name | Description
taPAProjectBillingCycle_ItemsTaPAProjectBillingCycle() | Initializes an instance of the taPAProjectBillingCycle_ItemsTaPAProjectBillingCycle class.

Properties

Name | Type | Description
Action | int16 | Action
PABILLCYCLEID | string | Billing cycle ID
PABILLFORMAT | string | Billing format
PAPROJNUMBER | string | Project number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAProjectBillingCycle>


taPAProjectBudgetMaster_ItemsTaPAProjectBudgetMaster Class

A class that represents the eConnect node you use to specify a project budget.

Constructor

Name | Description
taPAProjectBudgetMaster_ItemsTaPAProjectBudgetMaster() | Initializes an instance of the taPAProjectBudgetMaster_ItemsTaPAProjectBudgetMaster class.

Properties

Name | Type | Description
LNITMSEQ | int32 | Line sequence number
LNITMSEQSpecified | bool | Set to True when you assign a value to LNITMSEQ
PABBeginDate | string | Begin date
PABEndDate | string | End date
PABProfitAmt | Decimal | Baseline profit
PABProfitAmtSpecified | bool | Set to True when you assign a value to PABProfitAmt
PABProfitPcnt | Decimal | Baseline profit percent
PABProfitPcntSpecified | bool | Set to True when you assign a value to PABProfitPcnt
PABQuantity | Decimal | Baseline quantity
PABQuantitySpecified | bool | Set to True when you assign a value to PABQuantity
PABTotalCost | Decimal | Baseline total cost
PABTotalCostSpecified | bool | Set to True when you assign a value to PABTotalCost
PABUnitCost | Decimal | Baseline unit cost
PABUnitCostSpecified | bool | Set to True when you assign a value to PABUnitCost
PABaselineBTaxSchedID | string | Baseline billing tax schedule
PABaselineCTaxSchedID | string | Baseline cost tax schedule
PABaselineOvhdAmtPerUnit | Decimal | Baseline overhead per unit
PABaselineOvhdAmtPerUnitSpecified | bool | Set to True when you assign a value to PABaselineOvhdAmtPerUnit
PABaselineOvrhdPct | Decimal | Baseline overhead percentage
PABaselineOvrhdPctSpecified | bool | Set to True when you assign a value to PABaselineOvrhdPct
PABaselinePTaxOptions | int16 | Baseline purchase tax options
PABaselinePTaxOptionsSpecified | bool | Set to True when you assign a value to PABaselinePTaxOptions
PABaselineSTaxOptions | int16 | Baseline sales tax
PABaselineSTaxOptionsSpecified | bool | Set to True when you assign a value to PABaselineSTaxOptions
PACOSTCATID | string | Cost category
PAFBeginDate | string | Forecast begin date
PAFEndDate | string | Forecast end date
PAFProfitAmt | Decimal | Forecast profit amount
PAFProfitAmtSpecified | bool | Set to True when you assign a value to PAFProfitAmt
PAFProfitPcnt | Decimal | Forecast profit percentage
PAFProfitPcntSpecified | bool | Set to True when you assign a value to PAFProfitPcnt
PAFQuantity | Decimal | Forecast quantity
PAFQuantitySpecified | bool | Set to True when you assign a value to PAFQuantity
PAFTotalCost | Decimal | Forecast total cost
PAFTotalCostSpecified | bool | Set to True when you assign a value to PAFTotalCost
PAFUnitCost | Decimal | Forecast unit cost
PAFUnitCostSpecified | bool | Set to True when you assign a value to PAFUnitCost
PAForecastBTaxSchedID | string | Forecast billing tax schedule
PAForecastCTaxSchedID | string | Forecast cost tax schedule
PAForecastOvrhdAmtPerUnt | Decimal | Forecast overhead per unit
PAForecastOvrhdAmtPerUntSpecified | bool | Set to True when you assign a value to PAForecastOvrhdAmtPerUnt
PAForecastOvrhdPct | Decimal | Forecast overhead percentage
PAForecastOvrhdPctSpecified | bool | Set to True when you assign a value to PAForecastOvrhdPct
PAForecastPTaxOptions | int16 | Forecast purchase tax options
PAForecastPTaxOptionsSpecified | bool | Set to True when you assign a value to PAForecastPTaxOptions
PAForecastSTaxOptions | int16 | Forecast sales tax
PAForecastSTaxOptionsSpecified | bool | Set to True when you assign a value to PAForecastSTaxOptions
PALineItemSeq | int32 | Line item sequence number
PALineItemSeqSpecified | bool | Set to True when you assign a value to PALineItemSeq
PAPROJNUMBER | string | Project number
PAPay_Code_Hourly | string | Hourly pay code
PAPay_Code_Salary | string | Salary pay code
PAProfitType | int16 | Profit type
PAProfitTypeSpecified | bool | Set to True when you assign a value to PAProfitType
PASTAT | int16 | Status
PASTATSpecified | bool | Set to True when you assign a value to PASTAT
PAUnit_of_Measure | string | Unit of measure
PAbllngType | int16 | Billing type
PAbllngTypeSpecified | bool | Set to True when you assign a value to PAbllngType
RequesterTrx | int16 | Requester transaction
RollUpEst_to_Forecast | int16 | Update forecast
RollUpEst_to_ForecastSpecified | bool | Set to True when you assign a value to RollUpEst_to_Forecast
UOMSCHDL | string | Unit of measure schedule
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateExisting | int16 | Not used
UpdateExistingSpecified | bool | Not used

See Also

<taPAProjectBudgetMaster>


taPAProjectEquip_ItemsTaPAProjectEquip Class

A class that represents the eConnect node you use to specify a project equipment list.

Constructor

Name | Description
taPAProjectEquip_ItemsTaPAProjectEquip() | Initializes an instance of the taPAProjectEquip_ItemsTaPAProjectEquip class.

Properties

Name | Type | Description
Action | int16 | Action
PAEQUIPTID | string | Equipment ID
PAPROJNUMBER | string | Project number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPAProjectEquip>


taPAProjectFeeSchedule_ItemsTaPAProjectFeeSchedule Class

A class that represents the eConnect node you use to specify a project fee schedule.

Constructor

Name | Description
taPAProjectFeeSchedule_ItemsTaPAProjectFeeSchedule() | Initializes an instance of the taPAProjectFeeSchedule_ItemsTaPAProjectFeeSchedule class.

Properties

Name | Type | Description
LNITMSEQ | int32 | Line sequence number
PADT | string | Schedule date
PAFeeAmount | Decimal | Fee amount
PAFeeID | string | Fee ID
PAPROJNUMBER | string | Project number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateExisting | int16 | Not used

See Also

<taPAProjectFeeSchedule>


taPAProjectFee_ItemsTaPAProjectFee Class

A class that represents the eConnect node you use to specify a project fee.

Constructor

Name | Description
taPAProjectFee_ItemsTaPAProjectFee() | Initializes an instance of the taPAProjectFee_ItemsTaPAProjectFee class.

Properties

Name | Type | Description
PAFeeAmount | Decimal | Fee amount
PAFeeID | string | Fee ID
PALineItemSeq | int32 | Line sequence number
PAPROJNUMBER | string | Project number
PAPercent_Cost | Decimal | Percentage of cost
PAPercent_Revenue | Decimal | Percentage of revenue
PAService_Fee_Amount | Decimal | Service fee amount
PA_Retention_Percent | Decimal | Retention percentage
PAbilltaxscheduleid | string | Billing tax schedule
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateExisting | int16 | Not used

See Also

<taPAProjectFee>


taPAProjects_ItemsTaPAProjects Class

A class that represents the eConnect node you use to specify a project.

Constructor

Name | Description
taPAProjects_ItemsTaPAProjects() | Initializes an instance of the taPAProjects_ItemsTaPAProjects class.

Properties

Name | Type | Description
CUSTNMBR | string | Customer number
DSCPCTAM | int16 | Discount percentage
DSCPCTAMSpecified | bool | Set to True when you assign a value to DSCPCTAM
PAAcctgMethod | int16 | Accounting method
PAAcctgMethodSpecified | bool | Set to True when you assign a value to PAAcctgMethod
PABBeginDate | string | Baseline begin date
PABEndDate | string | Baseline end date
PABILLCYCLEID1 | string | Billing cycle ID
PABILLFORMAT | string | Billing format
PABusMgrID | string | Business manager ID
PACONTNUMBER | string | Contract number
PADepartment | string | Department
PAEquip_Rate_Table_Acc | int16 | Equipment rate table accepts replacements
PAEquip_Rate_Table_AccSpecified | bool | Set to True when you assign a value to PAEquip_Rate_Table_Acc
PAEquip_Rate_Table_ID | string | Equipment rate table
PAEstimatorID | string | Estimator ID
PALabor_RateTable_Type | int16 | Labor rate table type
PALabor_RateTable_TypeSpecified | bool | Set to True when you assign a value to PALabor_RateTable_Type
PALabor_Rate_Table_Acc | int16 | Labor rate table accepts replacements
PALabor_Rate_Table_AccSpecified | bool | Set to True when you assign a value to PALabor_Rate_Table_Acc
PALabor_Rate_Table_ID | string | Labor rate table
PAPROJNUMBER | string | Project number
PAProjectType | int16 | Project type
PAProjectTypeSpecified | bool | Set to True when you assign a value to PAProjectType
PASTAT | int16 | Status
PASTATSpecified | bool | Set to True when you assign a value to PASTAT
PASegmentCB | int16 | Segment checkbox
PASegmentCBSpecified | bool | Set to True when you assign a value to PASegmentCB
PATRKCHGORDS | int16 | Track change orders
PATRKCHGORDSSpecified | bool | Set to True when you assign a value to PATRKCHGORDS
PATRKCOBDGADDFLY | int16 | Track change orders for the budget
PATRKCOBDGADDFLYSpecified | bool | Set to True when you assign a value to PATRKCOBDGADDFLY
PAUD1Proj | string | User-defined field
PAUD2_Proj | string | User-defined field
PA_RestrictCustomerList | int16 | Restrict customer list
PA_RestrictCustomerListSpecified | bool | Set to True when you assign a value to PA_RestrictCustomerList
PA_Retention_Percent | Decimal | Retention percentage
PA_Retention_PercentSpecified | bool | Set to True when you assign a value to PA_Retention_Percent
PAbillnoteDefault | string | Billing note - default
PAbillnoteEE | string | Billing note - employee expense
PAbillnoteEL | string | Billing note - equipment logs
PAbillnoteFEE | string | Billing note - fees
PAbillnoteINV | string | Billing note - inventory
PAbillnoteML | string | Billing note - miscellaneous log
PAbillnoteTS | string | Billing note - timesheet
PAbillnoteVI | string | Billing note - VI
PAbllngType | int16 | Billing type
PAbllngTypeSpecified | bool | Set to True when you assign a value to PAbllngType
PAcloseProjcosts | int16 | Close to project costs
PAcloseProjcostsSpecified | bool | Set to True when you assign a value to PAcloseProjcosts
PAclosetobillings | int16 | Close to billings
PAclosetobillingsSpecified | bool | Set to True when you assign a value to PAclosetobillings
PAprjclsid | string | Project class
PAprojid | string | Project ID
PAprojmngrid | string | Project manager ID
PAprojname | string | Project name
PApurordnum | string | Purchase order number
PRBTADCD | string | Bill to address
RequesterTrx | int16 | Requester transaction
SUTASTAT | string | SUTA state
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateExisting | int16 | Not used
WRKRCOMP | string | Worker Compensation ID

See Also

<taPAProjects>


taPATimeSheetHdrInsert Class

A class that represents the eConnect node you use to create a project time sheet header.

Constructor

Name | Description
taPATimeSheetHdrInsert() | Initializes an instance of the taPATimeSheetHdrInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DYSTINCR | int16 | Days to increment
EMPLOYID | string | Employee ID
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
PACOMM | string | Comment
PADOCDT | string | Document date
PAREFNO | string | Reference number
PAREPD | int32 | Reporting period
PAREPDT | string | Reporting period begin date
PATACRV | Decimal | Total accrued revenue
PATQTY | Decimal | Quantity
PATSNO | string | Timesheet number
PATSTYP | int16 | Timesheet transaction type
PAreptsuff | string | Reporting suffix
PAtotcosts | Decimal | Total costs
PDK_TS_No | string | Timesheet number
PRVDSLMT | int16 | Previous day limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
TIME1 | string | Time
TRXDTDEF | int16 | Transaction default date
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate

See Also

<taPATimeSheetHdrInsert>


taPATimeSheetLineInsert_ItemsTaPATimeSheetLineInsert Class

A class that represents the eConnect node you use to create a project time sheet line.

Constructor

Name | Description
taPATimeSheetLineInsert_ItemsTaPATimeSheetLineInsert() | Initializes an instance of the taPATimeSheetLineInsert_ItemsTaPATimeSheetLineInsert class.

Properties

Name | Type | Description
CURNCYID | string | Currency ID
EMPLOYID | string | Employee ID
LNITMSEQ | int32 | Line sequency number
PACOSTCATID | string | Cost category
PADT | string | Date
PADepartment | string | Department
PAJob_Title | string | Job title
PAPROJNUMBER | string | Project number
PAPayCode | string | Pay code
PAQtyQ | Decimal | Quantity
PAREFNO | string | Reference number
PASalary_Posting_Type | int16 | Salary posting type
PATB | string | Begin time
PATE | string | End time
PATOTCST | Decimal | Total cost
PATSNO | string | Timesheet number
PATSTYP | int16 | Timesheet transaction type
PAUNITCOST | Decimal | Unit cost
PAUNITCOSTSpecified | bool | Set to True when you assign a value to PAUNITCOST
PAUnit_of_Measure | string | Unit of measure
PAbllngType | int16 | Billing type
PAtx500 | string | Notes
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPATimeSheetLineInsert>


taPMDistribution_ItemsTaPMDistribution Class

A class that represents the eConnect node you use to create a payables distribution.

Constructor

Name | Description
taPMDistribution_ItemsTaPMDistribution() | Initializes an instance of the taPMDistribution_ItemsTaPMDistribution class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTNUMST | string | Account number
CRDTAMNT | Decimal | Credit amount
DEBITAMT | Decimal | Debit amount
DISTTYPE | int16 | Distribution type
DOCTYPE | int16 | Document type
DSTSQNUM | int32 | Sequence number
DistRef | string | Distribution reference
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VCHRNMBR | string | Voucher number
VENDORID | string | Vendor ID

See Also

<taPMDistribution>


taPMManualCheck Class

A class that represents the eConnect node you use to create a payables manual check.

Constructor

Name | Description
taPMManualCheck() | Initializes an instance of the taPMManualCheck class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
BatchCHEKBKID | string | Batch checkbook ID
CARDNAME | string | Credit card name
CHEKBKID | string | Checkbook ID
CREATEDIST | int16 | Auto-create distributions
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DOCAMNT | Decimal | Document amount
DOCDATE | string | Document date
DOCNUMBR | string | Document number
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
MDFUSRID | string | Modified user ID
PMNTNMBR | string | Payment number
PRVDSLMT | int16 | Previous day limit
PSTGDATE | string | Posting date
PTDUSRID | string | Posted user ID
PYENTTYP | int16 | Payment type
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
TIME1 | string | Time
TRXDSCRN | string | Description
TRXDTDEF | int16 | Transaction default date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID
XCHGRATE | Decimal | Exchange rate

See Also

<taPMManualCheck>


taPMSchedPmnts Class

A class that represents the eConnect node you use to specify a payables payment schedule.

Constructor

Name | Description
taPMSchedPmnts() | Initializes an instance of the taPMSchedPmnts class.

Properties

Name | Type | Description
FIRST_INV_DOC_DATE | string | First invoice date
FIRST_INV_DUE_DATE | string | First invoice due date
INT_EXP_ACCT_IDX | int32 | Interest expense account index
IntExpenseAccount | string | Interest expense account
NUM_PAYMENTS | int16 | Number of payments
ORIG_DOC_TYPE | int16 | Document type
ORIG_VOUCHER_NUM | string | Original voucher number
PAYMENT_AMOUNT | Decimal | Payment amount
PAY_ACCT_IDX | int32 | Account index
PAY_OFFSET_ACCT_IDX | int32 | Offset account index
PYMNT_FREQUENCY | int16 | Payment frequency
PayAccount | string | Account number
PayOffsetAccount | string | Offset account
RequesterTrx | int16 | Requester transaction
SCHEDULE_AMOUNT | Decimal | Schedule amount
SCHEDULE_DESC | string | Schedule description
SCHEDULE_INT_RATE | Decimal | Schedule interest rate
SCHEDULE_INT_TYPE1 | int16 | Schedule interest type
SCHEDULE_NUMBER | string | Schedule number
SCH_DOC_DATE | string | Schedule document date
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPMSchedPmnts>


taPMTransactionInsert Class

A class that represents the eConnect node you use to specify a payables transaction.

Constructor

Name | Description
taPMTransactionInsert() | Initializes an instance of the taPMTransactionInsert class.

Properties

Name | Type | Description
APDSTKAM | Decimal | Applied Discount taken
BACHNUMB | string | Batch number
BatchCHEKBKID | string | Batch checkbook ID
CAMCBKID | string | Cash checkbook ID
CAMPMTNM | string | Cash amount payment number
CAMPYNBR | string | Check payment number
CAMTDATE | string | Cash amount date
CARDNAME | string | Credit card name
CASHAMNT | Decimal | Cash amount
CCAMPYNM | string | Credit card payment number
CCRCTNUM | string | Credit card receipt number
CDOCNMBR | string | Cash document number
CHAMCBID | string | Check amount checkbook ID
CHEKAMNT | Decimal | Check amount
CHEKBKID | string | Checkbook ID
CHEKDATE | string | Check date
CHEKNMBR | string | Check number
CHRGAMNT | Decimal | Charge amount
CRCARDDT | string | Credit card date
CRCRDAMT | Decimal | Credit card amount
CREATEDIST | int16 | Auto-create distributions
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DISAMTAV | Decimal | Discount available
DISAMTAVSpecified | bool | Set to True when you assign a value to DISAMTAV
DISCDATE | string | Discount date
DISTKNAM | Decimal | Discount taken
DOCAMNT | Decimal | Document amount
DOCDATE | string | Document date
DOCNUMBR | string | Document number
DOCTYPE | int16 | Document type
DSCDLRAM | Decimal | Discount amount
DSCDLRAMSpecified | bool | Set to True when you assign a value to DSCDLRAM
DUEDATE | string | Due date
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
FRTAMNT | Decimal | Freight amount
FRTSCHID | string | Freight schedule
MDFUSRID | string | Modified user ID
MSCCHAMT | Decimal | Miscellaneous charge
MSCSCHID | string | Miscellaneous schedule
PCHSCHID | string | Purchase schedule
PORDNMBR | string | Purchase order number
POSTEDDT | string | Posted date
PRCHAMNT | Decimal | Purchase amount
PRCTDISC | Decimal | Percent discount
PRCTDISCSpecified | bool | Set to True when you assign a value to PRCTDISC
PRVDSLMT | int16 | Previous day limit
PSTGDATE | string | Posting date
PTDUSRID | string | Posted user ID
PYMTRMID | string | Payment terms
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
SHIPMTHD | string | Shipping method
TAXAMNT | Decimal | Tax amount
TAXSCHID | string | Tax schedule
TEN99AMNT | Decimal | 1099 amount
TIME1 | string | Time
TRDISAMT | Decimal | Discount amount
TRXDSCRN | string | Description
TRXDTDEF | int16 | Transaction default date
Tax_Date | string | Tax date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VADCDTRO | string | Remit to address
VADDCDPR | string | Primary address
VCHNUMWK | string | Voucher number
VENDORID | string | Vendor ID
XCHGRATE | Decimal | Exchange rate

See Also

<taPMTransactionInsert>


taPMTransactionTaxInsert_ItemsTaPMTransactionTaxInsert Class

A class that represents the eConnect node you use to create payables tax information.

Constructor

Name | Description
taPMTransactionTaxInsert_ItemsTaPMTransactionTaxInsert() | Initializes an instance of the taPMTransactionTaxInsert_ItemsTaPMTransactionTaxInsert class.

Properties

Name | Type | Description
ACTINDX | int32 | Batch number
ACTNUMST | string | Account number
BACHNUMB | string | Batch number
DOCTYPE | int16 | Document type
FRTTXAMT | Decimal | Freight tax
MSCTXAMT | Decimal | Miscellaneous tax
PCTAXAMT | Decimal | Purchase tax
RequesterTrx | int16 | Requester transaction
TAXAMNT | Decimal | Tax amount
TAXDTLID | string | Tax detail
TDTTXPUR | Decimal | Purchase tax detail
TXDTTPUR | Decimal | Total purchases tax detail
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VCHRNMBR | string | Voucher number
VENDORID | string | Vendor ID

See Also

<taPMTransactionTaxInsert>


taPOPMapSites Class

A class that represents the eConnect node you use to create a purchase order site.

Constructor

Name | Description
taPOPMapSites() | Initializes an instance of the taPOPMapSites class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
LOCNCODE | string | Location code
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPOPMapSites>


taParentIDChild_ItemsTaParentIDChild Class

A class that represents the eConnect node you use to associate a child account with a parent national account

Constructor

Name | Description
taParentIDChild_ItemsTaParentIDChild() | Initializes an instance of the taParentIDChild_ItemsTaParentIDChild class.

Properties

Name | Type | Description
CPRCSTNM | string | Corporate customer number
CUSTNMBR | string | Customer number
CreateRemove | int16 | Create/Remove flag
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taParentIDChild>


taPoHdr Class

A class that represents the eConnect node you use to specify a purchase order header.

Constructor

Name | Description
taPoHdr() | Initializes an instance of the taPoHdr class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ALLOWSOCMTS | int16 | Allow sales commitments
ALLOWSOCMTSSpecified | bool | Set to True when you assign a value to ALLOWSOCMTS
BCKTXAMT | Decimal | Back tax
BCKTXAMTSpecified | bool | Set to True when you assign a value to BCKTXAMT
BUYERID | string | Buyer ID
BackoutFreightTaxAmt | Decimal | Back out freight tax
BackoutFreightTaxAmtSpecified | bool | Set to True when you assign a value to BackoutFreightTaxAmt
BackoutMiscTaxAmt | Decimal | Back out miscellaneous tax
BackoutMiscTaxAmtSpecified | bool | Set to True when you assign a value to BackoutMiscTaxAmt
BackoutTradeDiscTax | Decimal | Back out trade discount tax
BackoutTradeDiscTaxSpecified | bool | Set to True when you assign a value to BackoutTradeDiscTax
CCode | string | Country code
CITY | string | City
CMMTTEXT | string | Comment
CMPNYNAM | string | Company name
CNTRLBLKTBY | int16 | Control blanket by
CNTRLBLKTBYSpecified | bool | Set to True when you assign a value to CNTRLBLKTBY
COMMENT_1 | string | Comment information
COMMENT_2 | string | Comment information
COMMENT_3 | string | Comment information
COMMENT_4 | string | Comment information
COMMNTID | string | Comment
CONFIRM1 | string | Approver
CONTACT | string | Contact person
CONTENDDTE | string | Contract expiration date
COUNTRY | string | Country
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
DATELMTS | int16 | Date limit
DATELMTSSpecified | bool | Set to True when you assign a value to DATELMTS
DISAMTAV | Decimal | Discount available
DISAMTAVSpecified | bool | Set to True when you assign a value to DISAMTAV
DISCDATE | string | Discount date
DOCDATE | string | Document date
DSCDLRAM | Decimal | Discount amount
DSCDLRAMSpecified | bool | Set to True when you assign a value to DSCDLRAM
DSCPCTAM | Decimal | Discount percentage
DSCPCTAMSpecified | bool | Set to True when you assign a value to DSCPCTAM
DUEDATE | string | Due date
DYSTINCR | int16 | Days to increment
DYSTINCRSpecified | bool | Set to True when you assign a value to DYSTINCR
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
FAX | string | Fax number
FRTAMNT | Decimal | Freight amount
FRTAMNTSpecified | bool | Set to True when you assign a value to FRTAMNT
FRTSCHID | string | Freight tax schedule
FRTTXAMT | Decimal | Freight tax
FRTTXAMTSpecified | bool | Set to True when you assign a value to FRTTXAMT
HOLD | int16 | Hold
MSCCHAMT | Decimal | Miscellaneous charges
MSCCHAMTSpecified | bool | Set to True when you assign a value to MSCCHAMT
MSCSCHID | string | Miscellaneous tax schedule
MSCTXAMT | Decimal | Miscellaneous tax
MSCTXAMTSpecified | bool | Set to True when you assign a value to MSCTXAMT
NOTETEXT | string | Notes
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
PONUMBER | string | Purchase order number
POSTATUS | int16 | Status
POSTATUSSpecified | bool | Set to True when you assign a value to POSTATUS
POTYPE | int16 | Purchase order type
POTYPESpecified | bool | Set to True when you assign a value to POTYPE
PRBTADCD | string | Bill to address
PRMDATE | string | Promise date
PRMSHPDTE | string | Promise ship date
PRSTADCD | string | Primary address
PRVDSLMT | int16 | Previous day limit
PRVDSLMTSpecified | bool | Set to True when you assign a value to PRVDSLMT
PURCHADDRESS1 | string | Purchase address information
PURCHADDRESS2 | string | Purchase address information
PURCHADDRESS3 | string | Purchase address information
PURCHCCode | string | Purchase country code
PURCHCITY | string | Purchase city
PURCHCMPNYNAM | string | Purchase company name
PURCHCONTACT | string | Purchase contact person
PURCHCOUNTRY | string | Purchase country
PURCHFAX | string | Purchase fax number
PURCHPHONE1 | string | Purchase telephone number
PURCHPHONE2 | string | Purchase telephone number
PURCHPHONE3 | string | Purchase telephone number
PURCHSTATE | string | Purchase state
PURCHZIPCODE | string | Purchase postal code
PYMTRMID | string | Payment terms
Print_Phone_NumberGB | int16 | Print phone number
Print_Phone_NumberGBSpecified | bool | Set to True when you assign a value to Print_Phone_NumberGB
Purchase_Freight_Taxable | int16 | Purchase freight taxable
Purchase_Freight_TaxableSpecified | bool | Set to True when you assign a value to Purchase_Freight_Taxable
Purchase_Misc_Taxable | int16 | Purchase miscellaneous taxable
Purchase_Misc_TaxableSpecified | bool | Set to True when you assign a value to Purchase_Misc_Taxable
RATEEXPR | int16 | Rate expiration
RATEEXPRSpecified | bool | Set to True when you assign a value to RATEEXPR
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RATEVARCSpecified | bool | Set to True when you assign a value to RATEVARC
REQDATE | string | Required date
REQTNDT | string | Requisition date
RTCLCMTD | int16 | Rate calculation method
RTCLCMTDSpecified | bool | Set to True when you assign a value to RTCLCMTD
RequesterTrx | int16 | Requester transaction
SHIPMTHD | string | Shipping method
STATE | string | State
SUBTOTAL | Decimal | Subtotal
SUBTOTALSpecified | bool | Set to True when you assign a value to SUBTOTAL
TAXAMNT | Decimal | Tax amount
TAXAMNTSpecified | bool | Set to True when you assign a value to TAXAMNT
TAXSCHID | string | Tax schedule
TIME1 | string | Time
TRDISAMT | Decimal | Trade discount
TRDISAMTSpecified | bool | Set to True when you assign a value to TRDISAMT
TRXDTDEF | int16 | Transaction default date
TRXDTDEFSpecified | bool | Set to True when you assign a value to TRXDTDEF
TXRGNNUM | string | Vendor tax registration number
USERID | string | User ID
USINGHEADERLEVELTAXES | int16 | Use header level taxes
USINGHEADERLEVELTAXESSpecified | bool | Set to True when you assign a value to USINGHEADERLEVELTAXES
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VADCDPAD | string | Vendor address
VENDNAME | string | Vendor name
VENDORID | string | Vendor ID
XCHGRATE | Decimal | Exchange rate
ZIPCODE | string | Postal code

See Also

<taPoHdr>*


taPoLine_ItemsTaPoLine Class

A class that represents the eConnect node you use to specify a purchase order line.

Constructor

Name | Description
taPoLine_ItemsTaPoLine() | Initializes an instance of the taPoLine_ItemsTaPoLine class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Address code
BCKTXAMT | Decimal | Back tax amount
BCKTXAMTSpecified | bool | Set to True when you assign a value to BCKTXAMTBCKTXAMT
BSIVCTTL | int16 | Based on invoice total
BSIVCTTLSpecified | bool | Set to True when you assign a value to BSIVCTTL
BackoutTradeDiscTax | Decimal | Back out trade discount tax
BackoutTradeDiscTaxSpecified | bool | Set to True when you assign a value to BackoutTradeDiscTax
CCode | string | Country code
CITY | string | City
CMMTTEXT | string | Comment
CMPNYNAM | string | Company name
COMMENT_1 | string | Comment information
COMMENT_2 | string | Comment information
COMMENT_3 | string | Comment information
COMMENT_4 | string | Comment information
COMMNTID | string | Comment ID
CONTACT | string | Contact person
COUNTRY | string | Country
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
CostCatID | string | Cost category
DOCDATE | string | Document date
FAX | string | Fax number
FREEONBOARD | int16 | Free on board
FREEONBOARDSpecified | bool | Set to True when you assign a value to FREEONBOARD
ITEMDESC | string | Description
ITEMNMBR | string | Item number
IVIVINDX | int32 | Inventory index
IVIVINDXSpecified | bool | Set to True when you assign a value to IVIVINDX
InventoryAccount | string | Inventory account
LOCNCODE | string | Location code
Landed_Cost_Group_ID | string | Landed cost group
LineNumber | int32 | Line number
LineNumberSpecified | bool | Set to True when you assign a value to LineNumber
NONINVEN | int16 | Non-inventory flag
NOTETEXT | string | Notes
ORD | int32 | Sequence number
ORDSpecified | bool | Set to True when you assign a value to ORD
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
PLNNDSPPLID | int16 | Planned supplier ID
PLNNDSPPLIDSpecified | bool | Set to True when you assign a value to PLNNDSPPLID
POLNESTA | int16 | Line status
POLNESTASpecified | bool | Set to True when you assign a value to POLNESTA
PONUMBER | string | Purchase order number
POTYPE | int16 | Purchase order type
POTYPESpecified | bool | Set to True when you assign a value to POTYPE
PRMDATE | string | Promise date
PRMSHPDTE | string | Promised ship date
Print_Phone_NumberGB | int16 | Print phone number
Print_Phone_NumberGBSpecified | bool | Set to True when you assign a value to Print_Phone_NumberGB
ProjNum | string | Project number
Purchase_IV_Item_Taxable | int16 | Purchase inventory item - taxable
Purchase_IV_Item_TaxableSpecified | bool | Set to True when you assign a value to
Purchase_Item_Tax_Schedu | string | Purchase tax schedule
Purchase_Site_Tax_Schedu | string | Purchase site tax schedule
QTYCANCE | Decimal | Quantity cancelled
QTYCANCESpecified | bool | Set to True when you assign a value to QTYCANCE
QUANTITY | Decimal | Quantity
QUANTITYSpecified | bool | Set to True when you assign a value to QUANTITY
RELEASEBYDATE | string | Release to vendor date
REQDATE | string | Required date
REQSTDBY | string | Requested by
RequesterTrx | int16 | Requester transaction
SHIPMTHD | string | Shipping method
STATE | string | State
TAXAMNT | Decimal | Tax amount
TAXAMNTSpecified | bool | Set to True when you assign a value to TAXAMNT
UNITCOST | Decimal | Unit cost
UNITCOSTSpecified | bool | Set to True when you assign a value to UNITCOST
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
VNDITDSC | string | Vendor description
VNDITNUM | string | Vendor item number
ZIPCODE | string | Postal code

See Also

<taPoLine>*


taPopDistribution_ItemsTaPopDistribution Class

A class that represents the eConnect node you use to create a purchase order distribution.

Constructor

Name | Description
taPopDistribution_ItemsTaPopDistribution() | Initializes an instance of the taPopDistribution_ItemsTaPopDistribution class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTNUMST | string | Account number
CRDTAMNT | Decimal | Credit amount
DEBITAMT | Decimal | Debit amount
DISTTYPE | int16 | Distribution type
DistRef | string | Distribution reference
POPRCTNM | string | Invoice number
POPTYPE | int16 | Purchase order type
RequesterTrx | int16 | Requester transaction
SEQNUMBR | int32 | Sequence number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID

See Also

<taPopDistribution>


taPopEnterMatchInvHdr Class

A class that represents the eConnect node you use to create or update a purchase order invoice header.

Constructor

Name | Description
taPopEnterMatchInvHdr() | Initializes an instance of the taPopEnterMatchInvHdr class.

Properties

Name | Type | Description
AUTOCOST | int32 | Auto-fill cost
BACHNUMB | string | Batch number
BackoutTradeDiscTax | Decimal | Back out trade discount tax
CREATEDIST | int16 | Auto-create distributions
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DISAVAMT | Decimal | Discount available
DISAVAMTSpecified | bool | Set to True when you assign a value to DISAVAMT
DISCDATE | string | Discount date
DSCDLRAM | Decimal | Discount amount
DSCDLRAMSpecified | bool | Set to True when you assign a value to DSCDLRAM
DSCPCTAM | Decimal | Discount percentage
DSCPCTAMSpecified | bool | Set to True when you assign a value to DSCPCTAM
DUEDATE | string | Due date
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
FRTAMNT | Decimal | Freight amount
FRTSCHID | string | Freight tax schedule
FRTTXAMT | Decimal | Freight tax amount
MISCAMNT | Decimal | Miscellaneous amount
MSCSCHID | string | Miscellaneous tax schedule
MSCTXAMT | Decimal | Miscellaneous tax amount
NOTETEXT | string | Notes
POPRCTNM | string | Receipt number
PRVDSLMT | int16 | Previous day limit
PYMTRMID | string | Payment terms
Purchase_Freight_Taxable | int16 | Purchase freight taxable
Purchase_Misc_Taxable | int16 | Purchase miscellaneous taxable
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
SUBTOTAL | Decimal | Subtotal
TAXAMNT | Decimal | Tax amount
TAXSCHID | string | Tax schedule
TEN99AMNT | Decimal | 1099 amount
TIME1 | string | Time
TRDISAMT | Decimal | Trade discount
TRXDTDEF | int16 | Transaction default date
USER2ENT | string | User who entered
USINGHEADERLEVELTAXES | int16 | Use header level taxes
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VADCDTRO | string | Remit to address
VENDNAME | string | Vendor name
VENDORID | string | Vendor ID
VNDDOCNM | string | Vendor document number
XCHGRATE | Decimal | Exchange rate
receiptdate | string | Receipt date

See Also

<taPopEnterMatchInvHdr>


taPopEnterMatchInvLine_ItemsTaPopEnterMatchInvLine Class

A class that represents the eConnect node you use to create or update a purchase order invoice line.

Constructor

Name | Description
taPopEnterMatchInvLine_ItemsTaPopEnterMatchInvLine() | Initializes an instance of the taPopEnterMatchInvLine_ItemsTaPopEnterMatchInvLine class.

Properties

Name | Type | Description
AUTOCOST | int32 | Auto-fill cost
AutoInvoice | int16 | Automatic invoice
CURNCYID | string | Currency ID
CostCatID | string | Cost category
EXTDCOST | Decimal | Extended cost
ITEMNMBR | string | Item number
LandedCost | int16 | Landed cost
NONINVEN | int16 | Non-inventory item
POLNENUM | int32 | Sequence number
PONUMBER | string | Purchase order number
POPMtchShpRcpt | string | Match shipment receipt
POPRCTNM | string | Purchase order receipt
ProjNum | string | Project number
Purchase_IV_Item_Taxable | int16 | Purchase inventory item tax
Purchase_Item_Tax_Schedu | string | Purchase item tax schedule
Purchase_Site_Tax_Schedu | string | Purchase site tax schedule
QTYINVCD | Decimal | Invoice quantity
RCPTLNNM | int32 | Receipt line number
RequesterTrx | int16 | Requester transaction
Revalue_Inventory | int16 | Revalue inventory
Revalue_InventorySpecified | bool | Set to True when you assign a value to Revalue_Inventory
ShipRCPTLNNM | int32 | Receipt line number
TAXAMNT | Decimal | Tax amount
TrackedDropShipped | int16 | Track drop shipped
UNITCOST | Decimal | Unit cost
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID
VNDITDSC | string | Vendor item description
VNDITNUM | string | Vendor item number
VarianceAccount | string | Variance account

See Also

<taPopEnterMatchInvLine>


taPopEnterMatchInvToShpMultiLine_ItemsTaPopEnterMatchInvToShpMultiLine Class

A class that represents the eConnect node you use to create or update a purchase order invoice multiple shipment line.

Constructor

Name | Description
taPopEnterMatchInvToShpMultiLine_ItemsTaPopEnterMatchInvToShpMultiLine() | Initializes an instance of the taPopEnterMatchInvToShpMultiLine_ItemsTaPopEnterMatchInvToShpMultiLine class.

Properties

Name | Type | Description
ITEMNMBR | string | Item number
IVCLINNO | int32 | Line number
LandedCost | int16 | Landed cost
NONINVEN | int16 | noninventory item
PONUMBER | string | Purchase order number
POPMtchShpRcpt | string | Match shipment receipt
POPRCTNM | string | Receipt number
QTYINVCD | Decimal | Invoice quantity
Revalue_Inventory | int16 | Revalue inventory
Revalue_InventorySpecified | bool | Set to True when you assign a value to Revalue_Inventory
ShipRCPTLNNM | int32 | Receipt line number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID
VNDITNUM | string | Vendor item number
VarianceAccount | string | Variance account

See Also

<taPopEnterMatchInvToShpMultiLine>


taPopEnterMatchLotInsert_ItemsTaPopEnterMatchLotInsert

A class that represents the eConnect node you use to create or update a purchase order lot lines.

Constructor

Name | Description
taPopEnterMatchLotInsert_ItemsTaPopEnterMatchLotInsert() | Initializes an instance of the taPopEnterMatchLotInsert_ItemsTaPopEnterMatchLotInsert class.

Properties

Name | Type | Description
EXPNDATE | string | Expiration Date
ITEMNMBR | string | Item number
MFGDATE | string | Manufacturing date
POPRCTNM | string | Document number
RCPTLNNM | int32 | Receipt Line Number
RequesterTrx | int16 | Requester transaction
SERLTNUM | string | Lot number
SERLTQTY | Decimal | Quantity for the lot item
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopEnterMatchLotInsert>


taPopEnterMatchSerialInsert_ItemsTaPopEnterMatchSerialInsert

A class that represents the eConnect node you use to create or update a purchase order serial lines.

Constructor

Name | Description
taPopEnterMatchSerialInsert_ItemsTaPopEnterMatchSerialInsert() | Initializes an instance of the taPopEnterMatchSerialInsert_ItemsTaPopEnterMatchSerialInsert class.

Properties

Name | Type | Description
ITEMNMBR | string | Item number
POPRCTNM | string | Document number
RCPTLNNM | int32 | Receipt Line Number
RequesterTrx | int16 | Requester transaction
SERLTNUM | string | Serial number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopEnterMatchSerialInsert>


taPopIvcTaxInsert_ItemsTaPopIvcTaxInsert Class

A class that represents the eConnect node you use to create a purchase order tax line.

Constructor

Name | Description
taPopIvcTaxInsert_ItemsTaPopIvcTaxInsert() | Initializes an instance of the taPopIvcTaxInsert_ItemsTaPopIvcTaxInsert class.

Properties

Name | Type | Description
BKOUTTAX | int16 | Back out tax
FRTTXAMT | Decimal | Freight tax
MSCTXAMT | Decimal | Miscellaneous tax
ORD | int32 | Line sequence number
PONUMBER | string | Purchase order number
RequesterTrx | int16 | Requester transaction
TAXAMNT | Decimal | Tax amount
TAXDTLID | string | Tax detail
TAXPURCH | Decimal | Tax purchases
TAXTYPE | int16 | Tax type
TOTPURCH | Decimal | Total purchases
TRXSORCE | string | Transaction source
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID

See Also

<taPopIvcTaxInsert>


taPopPoDelete Class

A class that represents the eConnect node you use to remove a specified purchase order.

Constructor

Name | Description
taPopPoDelete() | Initializes an instance of the taPopPoDelete class.

Properties

Name | Type | Description
PONUMBER | string | Purchase order number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopPoDelete>


taPopPoVoid Class

A class that represents the eConnect node you use to void a specified purchase order.

Constructor

Name | Description
taPopPoVoid() | Initializes an instance of the taPopPoVoid class.

Properties

Name | Type | Description
PONUMBER | string | Purchase order number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopPoVoid>


taPopRcptHdrInsert Class

A class that represents the eConnect node you use to create a purchase order receipt header.

Constructor

Name | Description
taPopRcptHdrInsert() | Initializes an instance of the taPopRcptHdrInsert class.

Properties

Name | Type | Description
ACTLSHIP | string | Ship date
AUTOCOST | int32 | Auto-fill cost information
BACHNUMB | string | Batch number
BCKTXAMT | Decimal | Back tax amount
BackoutTradeDiscTax | Decimal | Back out trade discount tax amount
CAMCBKID | string | Cash checkbook ID
CAMPMTNM | string | Cash payment number
CAMPYNBR | string | Check amount payment number
CAMTDATE | string | Cash amount date
CARDNAME | string | Credit card name
CASHAMNT | Decimal | Cash amount
CCAMPYNM | string | Credit card payment number
CCRCTNUM | string | Credit card receipt number
CDOCNMBR | string | Cash document number
CHAMCBID | string | Checkbook ID
CHEKAMNT | Decimal | Check amount
CHEKDATE | string | Check date
CHEKNMBR | string | Check number
CRCARDDT | string | Credit card date
CRCRDAMT | Decimal | Credit card amount
CREATEDIST | int16 | Autocreate distributions
CURNCYID | string | Currency ID
DATELMTS | int16 | Date limit
DISAVAMT | Decimal | Discount available
DISAVAMTSpecified | bool | Set to True when you assign a value to DISAVAMT
DISCDATE | string | Discount date
DISTKNAM | Decimal | Discount taken
DSCDLRAM | Decimal | Discount amount
DSCDLRAMSpecified | bool | Set to True when you assign a value to DSCDLRAM
DSCPCTAM | Decimal | Discount percentage
DSCPCTAMSpecified | bool | Set to True when you assign a value to DSCPCTAM
DUEDATE | string | Due date
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
FRTAMNT | Decimal | Freight amount
FRTSCHID | string | Freight tax schedule
FRTTXAMT | Decimal | Freight tax
MISCAMNT | Decimal | Miscellaneous amount
MSCSCHID | string | Miscellaneous tax schedule
MSCTXAMT | Decimal | Miscellaneous tax
NOTETEXT | string | Notes
POPRCTNM | string | Purchase order receipt number
POPTYPE | int16 | Purchase order type
PRVDSLMT | int16 | Previous day limit
PYMTRMID | string | Payment terms
Purchase_Freight_Taxable | int16 | Purchase freight taxable
Purchase_Misc_Taxable | int16 | Purchase miscellaneous taxable
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
REFRENCE | string | Reference
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
SHIPMTHD | string | Shipping method
SUBTOTAL | Decimal | Subtotal
SUBTOTALSpecified | bool | Set to True when you assign a value to SUBTOTAL
TAXAMNT | Decimal | Tax amount
TAXSCHID | string | Tax schedule
TEN99AMNT | Decimal | 1099 amount
TIME1 | string | Time
TRDISAMT | Decimal | Trade discount
TRDISAMTSpecified | bool | Set to True when you assign a value to TRDISAMT
TRXDTDEF | int16 | Transaction default date
TXRGNNUM | string | Tax registration number
Tax_Date | string | Tax date
USER2ENT | string | User that entered
USINGHEADERLEVELTAXES | int16 | Use header level taxes
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VADCDTRO | string | Remit to address
VCHRNMBR | string | Voucher number
VENDNAME | string | Vendor name
VENDORID | string | Vendor ID
VNDDOCNM | string | Vendor document number
WITHHAMT | Decimal | Withholding amount
XCHGRATE | Decimal | Exchange rate
receiptdate | string | Receipt date

See Also

<taPopRcptHdrInsert>


taPopRcptLineInsert_ItemsTaPopRcptLineInsert Class

A class that represents the eConnect node you use to create a purchase order receipt line.

Constructor

Name | Description
taPopRcptLineInsert_ItemsTaPopRcptLineInsert() | Initializes an instance of the taPopRcptLineInsert_ItemsTaPopRcptLineInsert class.

Properties

Name | Type | Description
ACTLSHIP | string | Ship date
AUTOCOST | int32 | Auto-fill cost information
AutoAssignBin | int16 | Use default bin
BOLPRONUMBER | string | BOL/pro number
CMMTTEXT | string | Comment
CURNCYID | string | Currency ID
CostCatID | string | Cost category
EXTDCOST | Decimal | Extended cost
EXTDCOSTSpecified | bool | Set to True when you assign a value to EXTDCOST
INVINDX | int32 | Inventory index
ITEMDESC | string | Item description
ITEMNMBR | string | Item number
InventoryAccount | string | Inventory account
JOBNUMBR | string | Job number
LOCNCODE | string | Location code
Landed_Cost_Group_ID | string | Landed cost group
NONINVEN | int16 | Non-inventory item
POLNENUM | int32 | Purchase order line number
PONUMBER | string | Purchase order number
POPRCTNM | string | Receipt number
POPTYPE | int16 | Receipt type
ProjNum | string | Project number
Purchase_IV_Item_Taxable | int16 | Purchase inventory item taxable
Purchase_Item_Tax_Schedu | string | Purchase item tax schedule
Purchase_Site_Tax_Schedu | string | Purchase site tax schedule
QTYINVCD | Decimal | Quantity invoiced
QTYSHPPD | Decimal | Quantity shipped
RCPTLNNM | int32 | Receipt line number
RequesterTrx | int16 | Requester transaction
TAXAMNT | Decimal | Tax amount
UNITCOST | Decimal | Unit cost
UNITCOSTSpecified | bool | Set to True when you assign a value to UNITCOST
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID
VNDITDSC | string | Vendor item description
VNDITNUM | string | Vendor item number
receiptdate | string | Receipt date

See Also

<taPopRcptLineInsert>


taPopRcptLineTaxInsert_ItemsTaPopRcptLineTaxInsert Class

A class that represents the eConnect node you use to create a purchase order receipt tax line.

Constructor

Name | Description
taPopRcptLineTaxInsert_ItemsTaPopRcptLineTaxInsert() | Initializes an instance of the taPopRcptLineTaxInsert_ItemsTaPopRcptLineTaxInsert class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTNUMST | string | Inventory account
FRTTXAMT | Decimal | Freight tax amount
MSCTXAMT | Decimal | Miscellaneous tax amount
POPRCTNM | string | Receipt number
RCPTLNNM | int32 | Receipt line number
RequesterTrx | int16 | Requester transaction
TAXAMNT | Decimal | Tax amount
TAXDTLID | string | Tax detail
TAXPURCH | Decimal | Taxable purchases
TAXTYPE | int16 | Tax type
TOTPURCH | Decimal | Total purchases
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID

See Also

<taPopRcptLineTaxInsert>


taPopRcptLotInsert_ItemsTaPopRcptLotInsert Class

A class that represents the eConnect node you use to create a purchase order receipt lot line.

Constructor

Name | Description
taPopRcptLotInsert_ItemsTaPopRcptLotInsert() | Initializes an instance of the taPopRcptLotInsert_ItemsTaPopRcptLotInsert class.

Properties

Name | Type | Description
BIN | string | Bin
CREATEBIN | int16 | Create a bin
EXPNDATE | string | Expiration date
ITEMNMBR | string | Item number
LOCNCODE | string | Location code
MFGDATE | string | Manufacturing date
POPRCTNM | string | Document number
RCPTLNNM | int32 | Receipt line number
RequesterTrx | int16 | Requester transaction
SERLTNUM | string | Lot number
SERLTQTY | Decimal | Lot quantity
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopRcptLotInsert>


taPopRcptMultiBin_ItemsTaPopRcptMultiBin Class

A class that represents the eConnect node you use to specify a purchase order multibin receivings.

Constructor

Name | Description
taPopRcptMultiBin_ItemsTaPopRcptMultiBin() | Initializes an instance of the taPopRcptMultiBin_ItemsTaPopRcptMultiBin class.

Properties

Name | Type | Description
BIN | string | Bin
CreateBin | int32 | Create a bin
ITEMNMBR | string | Item number
POPRCTNM | string | Receipt number
QUANTITY | Decimal | Quantity
RCPTLNNM | int32 | Receipt line number
RequesterTrx | int16 | Requester transaction
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopRcptMultiBin>


taPopRcptSerialInsert_ItemsTaPopRcptSerialInsert Class

A class that represents the eConnect node you use to create a purchase order receipt serial line.

Constructor

Name | Description
taPopRcptSerialInsert_ItemsTaPopRcptSerialInsert() | Initializes an instance of the taPopRcptSerialInsert_ItemsTaPopRcptSerialInsert class.

Properties

Name | Type | Description
BIN | string | Bin
CREATEBIN | int16 | Create a bin
ITEMNMBR | string | Item number
LOCNCODE | string | Location code
POPRCTNM | string | Document number
RCPTLNNM | int32 | Receipt line number
RequesterTrx | int16 | Requester transaction
SERLTNUM | string | Serial number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopRcptSerialInsert>


taPopRctUserDefined Class

A class that represents the eConnect node you use to create a user defined purchase order receipt.

Constructor

Name | Description
taPopRctUserDefined() | Initializes an instance of the taPopRctUserDefined class.

Properties

Name | Type | Description
POPRCTNM | string | Receipt number
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
User_Defined_Date01 | string | User-defined date
User_Defined_Date02 | string | User-defined date
User_Defined_Date03 | string | User-defined date
User_Defined_Date04 | string | User-defined date
User_Defined_Date05 | string | User-defined date
User_Defined_Date06 | string | User-defined date
User_Defined_Date07 | string | User-defined date
User_Defined_Date08 | string | User-defined date
User_Defined_Date09 | string | User-defined date
User_Defined_Date10 | string | User-defined date
User_Defined_Date11 | string | User-defined date
User_Defined_Date12 | string | User-defined date
User_Defined_Date13 | string | User-defined date
User_Defined_Date14 | string | User-defined date
User_Defined_Date15 | string | User-defined date
User_Defined_Date16 | string | User-defined date
User_Defined_Date17 | string | User-defined date
User_Defined_Date18 | string | User-defined date
User_Defined_Date19 | string | User-defined date
User_Defined_Date20 | string | User-defined date
User_Defined_List01 | string | User-defined list
User_Defined_List02 | string | User-defined list
User_Defined_List03 | string | User-defined list
User_Defined_List04 | string | User-defined list
User_Defined_List05 | string | User-defined list
User_Defined_Text01 | string | User-defined text
User_Defined_Text02 | string | User-defined text
User_Defined_Text03 | string | User-defined text
User_Defined_Text04 | string | User-defined text
User_Defined_Text05 | string | User-defined text
User_Defined_Text06 | string | User-defined text
User_Defined_Text07 | string | User-defined text
User_Defined_Text08 | string | User-defined text
User_Defined_Text09 | string | User-defined text
User_Defined_Text10 | string | User-defined text

See Also

<taPopRcptUserDefined>


taPopRemoveSopLink Class

A class that represents the eConnect node you use to remove specified POP to SOP link.

Constructor

Name | Description
taPopRemoveSopLink() | Initializes an instance of the taPopRemoveSopLink class.

Properties

Name | Type | Description
CMPNTSEQ | int32 | Component sequence number
LNITMSEQ | int32 | Line sequence number
PONUMBER | string | Purchase order number
RemoveAllLinks | int16 | Remove links
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Sales order number
SOPTYPE | int16 | Sales order type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taPopRemoveSopLink>


taRMApply Class

A class that represents the eConnect node you use to specify a receivables apply.

Constructor

Name | Description
taRMApply() | Initializes an instance of the taRMApply class.

Properties

Name | Type | Description
APFRDCNM | string | Apply from document number
APFRDCTY | int32 | Document type
APPLYDATE | string | Apply date
APPTOAMT | Decimal | Amount to apply
APTODCNM | string | Apply to document number
APTODCTY | int32 | Document type
DISTKNAM | Decimal | Discount taken
DISTKNAMSpecified | bool | Set to True when you assign a value to DISTKNAM
GLPOSTDT | string | Apply posting date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
WROFAMNT | Decimal | Write-off amount

See Also

<taRMApply>


taRMCashReceiptInsert Class

A class that represents the eConnect node you use to specify a cash receipt.

Constructor

Name | Description
taRMCashReceiptInsert() | Initializes an instance of the taRMCashReceiptInsert class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
BatchCHEKBKID | string | Batch checkbook ID
CHEKBKID | string | Checkbook ID
CHEKNMBR | string | Check or credit card number
CRCARDID | string | Credit card ID
CREATEDIST | int16 | Auto-create distributions
CSHRCTYP | int16 | Cash receipt type
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
DATELMTS | int16 | Date limit
DOCDATE | string | Document date
DOCNUMBR | string | Document number
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
GLPOSTDT | string | GL posting date
LSTUSRED | string | Last user to edit
ORTRXAMT | Decimal | Transaction amount
PRVDSLMT | int16 | Previous day limit
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
TIME1 | string | Time
TRXDSCRN | string | Transaction description
TRXDTDEF | int16 | Transaction default date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
XCHGRATE | Decimal | Exchange rate

See Also

<taRMCashReceiptInsert>


taRMCommissions_ItemsTaRMCommissions Class

A class that represents the eConnect node you use to create a sales commission.

Constructor

Name | Description
taRMCommissions_ItemsTaRMCommissions() | Initializes an instance of the taRMCommissions_ItemsTaRMCommissions class.

Properties

Name | Type | Description
COMDLRAM | Decimal | Commission amount
COMPRCNT | Decimal | Commission percentage
CUSTNMBR | string | Customer number
DOCAMNT | Decimal | Document amount
DOCNUMBR | string | Document number
PRCTOSAL | Decimal | Percent of sale
RMDTYPAL | int16 | Document type
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory
SEQNUMBR | int32 | Sequence number
SLPRSNID | string | Salesperson ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taRMCommissions>


taRMDistribution_ItemsTaRMDistribution Class

A class that represents the eConnect node you use to create a receivables distribution.

Constructor

Name | Description
taRMDistribution_ItemsTaRMDistribution() | Initializes an instance of the taRMDistribution_ItemsTaRMDistribution class.

Properties

Name | Type | Description
ACTNUMST | string | Account number
CRDTAMNT | Decimal | Credit amount
CUSTNMBR | string | Customer number
DEBITAMT | Decimal | Debit amount
DISTTYPE | int16 | Distribution type
DOCNUMBR | string | Document number
DSTINDX | int32 | Account index
DistRef | string | Distribution reference
RMDTYPAL | int16 | Document type
SEQNUMBR | int32 | Sequence number
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taRMDistribution>


taRMSchedPmnts Class

A class that represents the eConnect node you use to create a receivables payment schedule.

Constructor

Name | Description
taRMSchedPmnts() | Initializes an instance of the taRMSchedPmnts class.

Properties

Name | Type | Description
FIRST_INV_DOC_DATE | string | First invoice document date
FIRST_INV_DUE_DATE | string | First invoice due date
INT_INCOME_ACCT_IDX | int32 | Interest income account index
IntIncomeAccount | string | Interest income account
NUM_PAYMENTS | int16 | Number of payments
ORIG_DOC_NUMBER | string | Document number
ORIG_DOC_TYPE | int16 | Document type
PAYMENT_AMOUNT | Decimal | Payment amount
PYMNT_FREQUENCY | int16 | Payment frequency
REC_ACCT_IDX | int32 | Receivables account index
REC_OFFSET_ACCT_IDX | int32 | Receivable offset account index
RecAccount | string | Receivables account
RecOffsetAccount | string | Receivables offset account
RequesterTrx | int16 | Requester transaction
SCHEDULE_AMOUNT | Decimal | Schedule amount
SCHEDULE_DESC | string | Schedule description
SCHEDULE_INT_RATE | Decimal | Schedule interest rate
SCHEDULE_INT_TYPE1 | int16 | Schedule interest type
SCHEDULE_NUMBER | string | Schedule number
SCH_DOC_DATE | string | Schedule document date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taRMSchedPmnts>


taRMTransaction Class

A class that represents the eConnect node you use to specify a receivables transaction.

Constructor

Name | Description
taRMTransaction() | Initializes an instance of the taRMTransaction class.

Properties

Name | Type | Description
ADRSCODE | string | Address code
BACHNUMB | string | Batch number
BKTFRTAM | Decimal | Back out freight amount
BKTMSCAM | Decimal | Back out miscellaneous amount
BKTSLSAM | Decimal | Back out sales amount
BatchCHEKBKID | string | Batch checkbook ID
CASHAMNT | Decimal | Cash amount
CASHDATE | string | Cash date
CBKIDCHK | string | Checkbook ID
CBKIDCRD | string | Credit card checkbook ID
CBKIDCSH | string | Checkbook ID
CHEKAMNT | Decimal | Check amount
CHEKDATE | string | Check date
CHEKNMBR | string | Check number
COMAPPTO | int16 | Commission apply to
COMAPPTOSpecified | bool | Set to True when you assign a value to COMAPPTO
COMDLRAM | Decimal | Commission amount
COMDLRAMSpecified | bool | Set to True when you assign a value to COMDLRAM
COSTAMNT | Decimal | Cost amount
CRCARDDT | string | Credit card date
CRCRDAMT | Decimal | Credit card amount
CRCRDNAM | string | Credit card name
CREATEDIST | int16 | Auto-create distributions
CSTPONBR | string | Customer purchase order number
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
DATELMTS | int16 | Date limit
DCNUMCHK | string | Check document number
DCNUMCRD | string | Credit card document number
DCNUMCSH | string | Cash document number
DISAVAMT | Decimal | Discount available
DISAVAMTSpecified | bool | Set to True when you assign a value to DISAVAMT
DISCDATE | string | Discount date
DISCRTND | Decimal | Discount returned
DISTKNAM | Decimal | Discount taken
DOCAMNT | Decimal | Document amount
DOCDATE | string | Document date
DOCDESCR | string | Document description
DOCNUMBR | string | Document number
DSCDLRAM | Decimal | Discount amount
DSCDLRAMSpecified | bool | Set to True when you assign a value to DSCDLRAM
DSCPCTAM | Decimal | Discount percentage
DSCPCTAMSpecified | bool | Set to True when you assign a value to DSCPCTAM
DUEDATE | string | Due date
DYSTINCR | int16 | Days to increment
DistRef | string | Distribution reference
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
FRTAMNT | Decimal | Freight amount
GSTDSAMT | Decimal | GST discount
LSTUSRED | string | Last user to edit
MISCAMNT | Decimal | Miscellaneous amount
PPSAMDED | Decimal | PPS amount deducted
PRVDSLMT | int16 | Previous day limit
PTDUSRID | string | Posted user ID
PYMTRMID | string | Payment terms
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
RCTNCCRD | string | Credit card receipt number
RMDTYPAL | int16 | Document type
RTCLCMTD | int16 | Rate calculation method
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory
SHIPMTHD | string | Shipping method
SLPRSNID | string | Salesperson ID
SLSAMNT | Decimal | Sales amount
TAXAMNT | Decimal | Tax amount
TAXSCHID | string | Tax schedule
TIME1 | string | Time
TRDDISCT | int16 | Trade discount
TRDISAMT | Decimal | Trade discount amount
TRXDTDEF | int16 | Transaction default date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
WROFAMNT | Decimal | Write-off amount
XCHGRATE | Decimal | Exchange rate

See Also

<taRMTransaction>


taRMTransactionTaxInsert_ItemsTaRMTransactionTaxInsert Class

A class that represents the eConnect node you use to create tax information for a receivables transaction.

Constructor

Name | Description
taRMTransactionTaxInsert_ItemsTaRMTransactionTaxInsert() | Initializes an instance of the taRMTransactionTaxInsert_ItemsTaRMTransactionTaxInsert class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTNUMST | string | Account number
BACHNUMB | string | Batch number
CUSTNMBR | string | Customer number
DOCNUMBR | string | Document number
FRTTXAMT | Decimal | Freight tax amount
MSCTXAMT | Decimal | Miscellaneous tax amount
RMDTYPAL | int16 | Document type
RequesterTrx | int16 | Requester transaction
SEQNUMBR | int32 | Sequence number
STAXAMNT | Decimal | Sales tax amount
TAXAMNT | Decimal | Tax amount
TAXDTLID | string | Tax detail
TAXDTSLS | Decimal | Total sales tax detail
TDTTXSLS | Decimal | Taxable sales tax detail
TDTTXSLSSpecified | bool | Set to True when you assign a value to TDTTXSLS
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taRMTransactionTaxInsert>


taRMUnapplyTransaction Class

A class that represents the eConnect node you use to unapply a receivables transaction.

Constructor

Name | Description
taRMUnapplyTransaction() | Initializes an instance of the taRMUnapplyTransaction class.

Properties

Name | Type | Description
APTODCNM | string | Apply to document number
APTODCTY | int16 | Apply to document type
CUSTNMBR | string | Customer number
DOCNUMBR | string | Document number
GLPOSTDT | string | General ledger posting date
RMDTYPAL | int16 | Document type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taRMUnapplyTransaction>


taRMVoidTransaction Class

A class that represents the eConnect node you use to void a receivables transaction.

Constructor

Name | Description
taRMVoidTransaction() | Initializes an instance of the taRMVoidTransaction class.

Properties

Name | Type | Description
CUSTNMBR | string | Customer number
DOCNUMBR | string | Document number
GLPOSTDT | string | General ledger posting date
RMDTYPAL | int16 | Document type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VOIDDATE | string | Void date
VOIDSTTS | int16 | Void status

See Also

<taRMVoidTransaction>


taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler Class

A class that represents the eConnect node you use to specify requester services to disable

Constructor

Name | Description
taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler() | Initializes an instance of the taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler class.

Properties

Name | Type | Description
DOCTYPE | string | Document type
Delete | int16 | Delete from temporary table
INDEX1 | string | Index information
INDEX10 | string | Index information
INDEX11 | string | Index information
INDEX12 | string | Index information
INDEX13 | string | Index information
INDEX14 | string | Index information
INDEX15 | string | Index information
INDEX2 | string | Index information
INDEX3 | string | Index information
INDEX4 | string | Index information
INDEX5 | string | Index information
INDEX6 | string | Index information
INDEX7 | string | Index information
INDEX8 | string | Index information
INDEX9 | string | Index information

See Also

<taRequesterTrxDisabler>


taSopCommissions_ItemsTaSopCommissions Class

A class that represents the eConnect node you use to create a sales order commission.

Constructor

Name | Description
taSopCommissions_ItemsTaSopCommissions() | Initializes an instance of the taSopCommissions_ItemsTaSopCommissions class.

Properties

Name | Type | Description
COMMAMNT | Decimal | Commission amount
COMPRCNT | Decimal | Commission percentage
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
LNITMSEQ | int32 | Line sequence number
PRCTOSAL | Decimal | Percent of sales
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory
SLPRSNID | string | Salesperson ID
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taSopCommissions>


taSopDeleteDocument Class

A class that represents the eConnect node you use to remove a sales document.

Constructor

Name | Description
taSopDeleteDocument() | Initializes an instance of the taSopDeleteDocument class.

Properties

Name | Type | Description
RemovePayments | int16 | Move payments
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taSopDeleteDocument>


taSopDistribution_ItemsTaSopDistribution Class

A class that represents the eConnect node you use to create a sales order distribution.

Constructor

Name | Description
taSopDistribution_ItemsTaSopDistribution() | Initializes an instance of the taSopDistribution_ItemsTaSopDistribution class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTNUMST | string | Account number
CRDTAMNT | Decimal | Credit amount
CUSTNMBR | string | Customer number
DEBITAMT | Decimal | Debit amount
DISTTYPE | int16 | Distribution type
DistRef | string | Distribution reference
RequesterTrx | int16 | Requester transaction
SEQNUMBR | int32 | Sequence number
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taSopDistribution>


taSopHdrIvcInsert Class

A class that represents the eConnect node you use to create a sales invoice header.

Constructor

Name | Description
taSopHdrIvcInsert() | Initializes an instance of the taSopHdrIvcInsert class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
BACHNUMB | string | Batch number
BACKDATE | string | Back order date
BatchCHEKBKID | string | Batch checkbook ID
CITY | string | City
CKCreditLimit | int16 | Check credit limit
CKHOLD | int16 | Check hold status
CMMTTEXT | string | Comment
CNTCPRSN | string | Contact person
COMMAMNT | Decimal | Commission amount
COMMENT_1 | string | Comment information
COMMENT_2 | string | Comment information
COMMENT_3 | string | Comment information
COMMENT_4 | string | Comment information
COMMNTID | string | Comment
COMPRCNT | Decimal | Commission percentage
COUNTRY | string | Country
CREATECOMM | int16 | Auto-create commissions
CREATEDIST | int16 | Auto-create distributions
CREATETAXES | int16 | Auto-create taxes
CSTPONBR | string | Customer purchase order number
CURNCYID | string | Currency ID
CUSTNAME | string | Customer name
CUSTNMBR | string | Customer number
DATELMTS | int16 | Date limit
DEFPRICING | int16 | Use default pricing
DEFTAXSCHDS | int16 | Default tax schedule
DISAVAMT | Decimal | Discount available amount
DISAVAMTSpecified | bool | Set to True when you assign a value to DISAVAMT
DISCDATE | string | Discount date
DISTKNAM | Decimal | Discount taken
DOCAMNT | Decimal | Document amount
DOCDATE | string | Document date
DOCID | string | Document ID
DSCDLRAM | Decimal | Discount amount
DSCDLRAMSpecified | bool | Set to True when you assign a value to DSCDLRAM
DSCPCTAM | Decimal | Discount percentage
DSCPCTAMSpecified | bool | Set to True when you assign a value to DSCPCTAM
DUEDATE | string | Due date
DYSTINCR | int16 | Days to increment
EXCHDATE | string | Exchange date
EXGTBDSC | string | Exchange description
EXPNDATE | string | Expiration date
EXTBLSRC | string | Exchange rate source
FAXNUMBR | string | Fax number
FREIGHT | Decimal | Freight amount
FREIGTBLE | int32 | Taxable freight
FRTSCHID | string | Freight schedule
FRTTXAMT | Decimal | Freight tax amount
GPSFOINTEGRATIONID | string | Front office integration ID
INTEGRATIONID | string | Integration ID
INTEGRATIONSOURCE | int16 | Integration source
INVODATE | string | Invoice date
LOCNCODE | string | Location code
MISCAMNT | Decimal | Miscellaneous amount
MISCTBLE | int32 | Taxable miscellaneous amount
MRKDNAMT | Decimal | Mark down amount
MSCSCHID | string | Miscellaneous schedule
MSCTXAMT | Decimal | Miscellaneous tax amount
MSTRNUMB | int32 | Master number
NOTETEXT | string | Notes
ORDRDATE | string | Order date
ORIGNUMB | string | Order number
ORIGTYPE | int16 | Original document type
PHNUMBR1 | string | Telephone number
PHNUMBR2 | string | Telephone number
PHNUMBR3 | string | Telephone number
PRBTADCD | string | BIll to address
PRCLEVEL | string | Price level
PRSTADCD | string | Ship to address
PRVDSLMT | int16 | Previous day limit
PYMTRCVD | Decimal | Total payments and deposits
PYMTRMID | string | Payment terms
Print_Phone_NumberGB | int16 | Printt phone number
Print_Phone_NumberGBSpecified | bool | Set to True when you assign a value to Print_Phone_NumberGB
QUOEXPDA | string | Quote expiration date
QUOTEDAT | string | Quote date
QUOTEDYSTINCR | int16 | Quoted days to increment
RATEEXPR | int16 | Rate expiration
RATETPID | string | Rate type
RATEVARC | Decimal | Rate variance
REFRENCE | string | Reference
REPTING | int16 | Reporting
RETUDATE | string | Return date
RTCLCMTD | int16 | Rate calculation method
ReqShipDate | string | Requested ship date
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory
SHIPMTHD | string | Shipping method
SLPRSNID | string | Salesperson ID
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
STATE | string | State
SUBTOTAL | Decimal | Subtotal
ShipToName | string | Ship to name
TAXAMNT | Decimal | Tax amount
TAXEXMT1 | string | Tax exempt information
TAXEXMT2 | string | Tax exempt information
TAXSCHID | string | Tax schedule
TIME1 | string | Time
TIMETREP | int16 | Times to repeat
TRADEPCT | Decimal | Trade discount percentage
TRADEPCTSpecified | bool | Set to True when you assign a value to TRADEPCT
TRDISAMT | Decimal | Trade discount amount
TRDISAMTSpecified | bool | Set to True when you assign a value to TRDISAMT
TRXDTDEF | int16 | Transaction default date
TRXFREQU | int16 | Frequency
TXRGNNUM | string | Tax registration number
UPSZONE | string | UPS zone
USER2ENT | string | User that entered
USINGHEADERLEVELTAXES | int32 | Use header level taxes
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateExisting | int16 | Update if exists flag
XCHGRATE | Decimal | Exchange rate
ZIPCODE | string | Postal code

See Also

<taSopHdrIvcInsert>*


taSopLineDelete Class

A class that represents the eConnect node you use to remove a sales invoice line.

Constructor

Name | Description
taSopLineDelete() | Initializes an instance of the taSopLineDelete class.

Properties

Name | Type | Description
CMPNTSEQ | int32 | Component sequence number
DeleteType | int16 | Delete line type
ITEMNMBR | string | Item number
LNITMSEQ | int32 | Line sequence number
RecreateDist | int16 | Recreate distributions
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taSopLineDelete>


taSopLineIvcInsertComponent_ItemsTaSopLineIvcInsertComponent Class

A class that represents the eConnect node you use to specify a component for a sales invoice line.

Constructor

Name | Description
taSopLineIvcInsertComponent_ItemsTaSopLineIvcInsertComponent() | Initializes an instance of the taSopLineIvcInsertComponent_ItemsTaSopLineIvcInsertComponent class.

Properties

Name | Type | Description
AUTOALLOCATELOT | int32 | Auto-create lot numbers
AUTOALLOCATESERIAL | int32 | Auto-create serial numbers
AutoAssignBin | int16 | Auto-assign bin
CMPITUOM | string | Component unit of measure
CMPNTSEQ | int32 | Component sequence number
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
DOCID | string | Document number
ITEMDESC | string | Item description
ITEMNMBR | string | Item number
LNITMSEQ | int32 | Line sequence number
LOCNCODE | string | Location code
NONINVEN | int16 | Non-inventory item
QTYCANCE | Decimal | Quantity cancelled
QTYDMGED | Decimal | Quantity damaged
QTYFULFI | Decimal | Quantity fulfilled
QTYFULFISpecified | bool | Set to True when you assign a value to QTYFULFI
QTYINSVC | Decimal | Quantity in service
QTYINUSE | Decimal | Quantity in use
QTYONHND | Decimal | Quantity on hand
QTYRTRND | Decimal | Quantity returned
QTYTBAOR | Decimal | Quantity back ordered
QUANTITY | Decimal | Quantity
QUOTEQTYTOINV | Decimal | Quote quantity to invoice
QtyShrtOpt | int16 | Quantity shortage options
RecreateDist | int16 | Recreate distributions
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
UNITCOST | Decimal | Unit cost
UNITCOSTSpecified | bool | Set to True when you assign a value to UNITCOST
USERDATE | string | User date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taSopLineIvcInsertComponent>*


taSopLineIvcInsert_ItemsTaSopLineIvcInsert Class

A class that represents the eConnect node you use to create a sales invoice line.

Constructor

Name | Description
taSopLineIvcInsert_ItemsTaSopLineIvcInsert() | Initializes an instance of the taSopLineIvcInsert_ItemsTaSopLineIvcInsert class.

Properties

Name | Type | Description
ACTLSHIP | string | Ship date
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ALLOCATE | int16 | Allocate quantities
AUTOALLOCATELOT | int32 | Auto-create lot numbers
AUTOALLOCATESERIAL | int32 | Auto-create serial numbers
AutoAssignBin | int16 | Auto assign bin
CITY | string | City
CKCreditLimit | int16 | Check credit limit
CMMTTEXT | string | Comment
CNTCPRSN | string | Contact person
COMMENT_1 | string | Comment information
COMMENT_2 | string | Comment information
COMMENT_3 | string | Comment information
COMMENT_4 | string | Comment information
COMMNTID | string | Comment ID
COUNTRY | string | Country
CSLSINDX | string | Cost of goods sold index
CURNCYID | string | Currency ID
CUSTNMBR | string | Customer number
DEFEXTPRICE | int32 | Use default extended pricing
DEFPRICING | int32 | Use default pricing
DMGDINDX | string | Damaged index
DOCDATE | string | Document date
DOCID | string | Document number
DROPSHIP | int16 | Drop ship
EXCEPTIONALDEMAND | int16 | Resource planning
FAXNUMBR | string | Fax number
FUFILDAT | string | Fulfillment date
GPSFOINTEGRATIONID | string | Front office integration ID
INSRINDX | string | In service index
INTEGRATIONID | string | Integration ID
INTEGRATIONSOURCE | int16 | Integration source
INUSINDX | string | In use index
INVINDX | string | Inventory index
ITEMDESC | string | Item description
ITEMNMBR | string | Item number
ITMTSHID | string | Item tax schedule
IVITMTXB | int16 | Taxable inventory item
IncludePromo | int16 | Extended price promotion
KitCompMan | int16 | Kit components
LNITMSEQ | int32 | Line sequence number
LOCNCODE | string | Location code
MKDNINDX | string | Markdown index
MRKDNAMT | Decimal | Markdown amount
MRKDNAMTSpecified | bool | Set to True when you assign a value to MRKDNAMT
MRKDNPCT | Decimal | Markdown percentage
MRKDNPCTSpecified | bool | Set to True when you assign a value to MRKDNPCT
NONINVEN | int16 | Non-inventory item
PHONE1 | string | Telephone number
PHONE2 | string | Telephone number
PHONE3 | string | Telephone number
PRCLEVEL | string | Price level
PRSTADCD | string | Ship to address
Print_Phone_NumberGB | int16 | Print phone number
Print_Phone_NumberGBSpecified | bool | Set to True when you assign a value to Print_Phone_NumberGB
QTYCANCE | Decimal | Quantity cancelled
QTYDMGED | Decimal | Quantity damaged
QTYFULFI | Decimal | Quantity fulfilled
QTYFULFISpecified | bool | Set to True when you assign a value to QTYFULFI
QTYINSVC | Decimal | Quantity in service
QTYINUSE | Decimal | Quantity in use
QTYONHND | Decimal | Quantity on hand
QTYRTRND | Decimal | Quantity returned
QTYTBAOR | Decimal | Quantity back ordered
QUANTITY | Decimal | Quantity
QUOTEQTYTOINV | Decimal | Quote quantity to invoice
QtyShrtOpt | int16 | Quantity shortage option
RTNSINDX | string | Returns index
RecreateDist | int16 | Recreate distributions
ReqShipDate | string | Requested ship date
RequesterTrx | int16 | Requester transaction
SALSTERR | string | Sales territory
SHIPMTHD | string | Shipping method
SLPRSNID | string | Salesperson ID
SLSINDX | string | Sales index
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
STATE | string | State
ShipToName | string | Ship to name
TAXAMNT | Decimal | Tax amount
TAXSCHID | string | Tax schedule
TOTALQTY | Decimal | Total line quantity
UNITCOST | Decimal | Unit cost
UNITCOSTSpecified | bool | Set to True when you assign a value to UNITCOST
UNITPRCE | Decimal | Unit price
UOFM | string | Unit of measure
USERDATE | string | User date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
XTNDPRCE | Decimal | Extended price
ZIPCODE | string | Postal code

See Also

<taSopLineIvcInsert>*


taSopLineIvcTaxInsert_ItemsTaSopLineIvcTaxInsert Class

A class that represents the eConnect node you use to specify tax information for a sales invoice line.

Constructor

Name | Description
taSopLineIvcTaxInsert_ItemsTaSopLineIvcTaxInsert() | Initializes an instance of the taSopLineIvcTaxInsert_ItemsTaSopLineIvcTaxInsert class.

Properties

Name | Type | Description
ACTINDX | int32 | Account index
ACTNUMST | string | Account number
CUSTNMBR | string | Customer number
FREIGHT | Decimal | Freight amount
FRTTXAMT | Decimal | Freight tax amount
LNITMSEQ | int32 | Line sequence number
MISCAMNT | Decimal | Miscellaneous amount
MSCTXAMT | Decimal | Miscellaneous tax amount
RequesterTrx | int16 | Requester transaction
SALESAMT | Decimal | Sales amount
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
STAXAMNT | Decimal | Sales tax amount
TAXDTLID | string | Tax detail
TAXTYPE | int16 | Tax type
TDTTXSLS | Decimal | Total taxable sales
TDTTXSLSSpecified | bool | Set to True when you assign a value to TDTTXSLS
TXDTOTTX | Decimal | Total tax detail
TXDTOTTXSpecified | bool | Set to True when you assign a value to TXDTOTTX
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taSopLineIvcTaxInsert>


taSopLotAuto_ItemsTaSopLotAuto Class

A class that represents the eConnect node you use to specify a sales lot.

Constructor

Name | Description
taSopLotAuto_ItemsTaSopLotAuto() | Initializes an instance of the taSopLotAuto_ItemsTaSopLotAuto class.

Properties

Name | Type | Description
ALLOCATE | int16 | Allocate quantities
AUTOCREATELOT | int32 | Auto-create lot numbers
BIN | string | Bin
CMPNTSEQ | int32 | Component sequence
CREATEBIN | int16 | Create a bin
DATERECD | string | Date received
DOCID | string | Document number
DROPSHIP | int16 | Drop ship
EXPNDATE | string | Expiration date
ITEMNMBR | string | Item number
LNITMSEQ | int32 | Line sequence number
LOCNCODE | string | Location code
LOTNUMBR | string | Lot number
LOTNUMBRToReplace | string | Previous lot number
MFGDATE | string | Manufacturing date
QTYFULFI | Decimal | Quantity fulfilled
QTYFULFISpecified | bool | Set to True when you assign a value to QTYFULFI
QTYTYPE | int16 | Quantity type
QUANTITY | Decimal | Quantity
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
UOFM | string | Unit of measure
USERDATE | string | User date
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taSopLotAuto>*


taSopMultiBin_ItemsTaSopMultiBin Class

A class that represents the eConnect node you use to specify a multibin sales order.

Constructor

Name | Description
taSopMultiBin_ItemsTaSopMultiBin() | Initializes an instance of the taSopMultiBin_ItemsTaSopMultiBin class.

Properties

Name | Type | Description
BIN | string | Bin
CMPNTSEQ | int32 | Component sequence number
CreateBin | int32 | Create a bin
ITEMNMBR | string | Item number
LNITMSEQ | int32 | Line sequency number
OverrideBin | int16 | Override bin shortage
QTYTYPE | int16 | Quantity type
QUANTITY | Decimal | Quantity
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
UOFM | string | Unit of measure
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taSopMultiBin>


taSopSerial_ItemsTaSopSerial Class

A class that represents the eConnect node you use to specify the serial number of line from a sales document.

Constructor

Name | Description
taSopSerial_ItemsTaSopSerial() | Initializes an instance of the taSopSerial_ItemsTaSopSerial class.

Properties

Name | Type | Description
ALLOCATE | int16 | Allocate quantities
AUTOCREATESERIAL | int32 | Auto-create serial numbers
BIN | string | Bin
CMPNTSEQ | int32 | Component sequence number
CREATEBIN | int16 | Create a bin
DOCID | string | Document ID
DROPSHIP | int16 | Drop ship
ITEMNMBR | string | Item number
LNITMSEQ | int32 | Line sequency number
LOCNCODE | string | Location code
QTYFULFI | Decimal | Quantity fulfilled
QTYFULFISpecified | bool | Set to True when you assign a value to QTYFULFI
QTYTYPE | int16 | Quantity type
QUANTITY | Decimal | Quantity
RequesterTrx | int16 | Requester transaction
SERLNMBR | string | Serial number
SERLNMBRToReplace | string | Previous serial number
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taSopSerial>*


taSopToPopLink Class

A class that represents the eConnect node you use to specify a SOP to POP link.

Constructor

Name | Description
taSopToPopLink() | Initializes an instance of the taSopToPopLink class.

Properties

Name | Type | Description
CURNCYID | string | Currency ID
DOCDATE | string | Document date
SHIPMTHD | string | Shipping method
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USERID | string | User ID
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VENDORID | string | Vendor ID

See Also

<taSopToPopLink>


taSopTrackingNum_ItemsTaSopTrackingNum Class

A class that represents the eConnect node you use to create a sales order tracking number.

Constructor

Name | Description
taSopTrackingNum_ItemsTaSopTrackingNum() | Initializes an instance of the taSopTrackingNum_ItemsTaSopTrackingNum class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
Tracking_Number | string | Tracking number
Type | int16 | Type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field

See Also

<taSopTrackingNum>


taSopUpdateCreateProcessHold Class

A class that represents the eConnect node you use to create a sales order process hold.

Constructor

Name | Description
taSopUpdateCreateProcessHold() | Initializes an instance of the taSopUpdateCreateProcessHold class.

Properties

Name | Type | Description
DELETE1 | int32 | Delete process hold
DSCRIPTN | string | Description
FUFIPHOL | int16 | Fulfill process hold
HOLDDATE | string | Hold date
PASSWORD | string | Password
POSTPHOL | int16 | Posting process hold
PRCHLDID | string | Process hold
PRINPHOL | int16 | Printing process hold
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
TIME1 | string | Hold time
USERID | string | User ID
UpdateIfExistsMaster | int32 | Update hold master
UpdateSopIfExists | int32 | Update sales order
XFERPHOL | int16 | Transfer process hold

See Also

<taSopUpdateCreateProcessHold>*


taSopUserDefined Class

A class that represents the eConnect node you use to create a user defined sales order document.

Constructor

Name | Description
taSopUserDefined() | Initializes an instance of the taSopUserDefined class.

Properties

Name | Type | Description
RequesterTrx | int16 | Requester transaction
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDAT01 | string | User-defined date
USRDAT02 | string | User-defined date
USRDEF03 | string | User-defined field
USRDEF04 | string | User-defined field
USRDEF05 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
USRTAB01 | string | User-defined table
USRTAB03 | string | User-defined table
USRTAB09 | string | User-defined table

See Also

<taSopUserDefined>


taSopVoidDocument Class

A class that represents the eConnect node you use to void a specified sales order document.

Constructor

Name | Description
taSopVoidDocument() | Initializes an instance of the taSopVoidDocument class.

Properties

Name | Type | Description
BACHNUMB | string | Batch number
RemovePayments | int16 | Remove deposits
SOPNUMBE | string | Document number
SOPTYPE | int16 | Sales order type
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
VOIDDATE | string | void date

See Also

<taSopVoidDocument>


taUpdateCreateAccountRcd Class

A class that represents the eConnect node you use to create or update a general ledger account.

Constructor

Name | Description
taUpdateCreateAccountRcd() | Initializes an instance of the taUpdateCreateAccountRcd class.

Properties

Name | Type | Description
ACCTENTR | int16 | Account entry
ACCTTYPE | int16 | Account type
ACTALIAS | string | Account alias
ACTDESCR | string | Account description
ACTIVE | int16 | Active
ACTNUMST | string | Account number
BALFRCLC | int16 | Based on
CATEGORY | string | Account category
DECPLACS | int16 | Decimal places
DSPLKUPSIV | int16 | Inventory look up
DSPLKUPSPR | int16 | Payroll lookup
DSPLKUPSPURCH | int16 | Purchasing lookup
DSPLKUPSSALES | int16 | Sales lookup
FXDORVAR | int16 | Fixed or variable allocation
NOTETEXT | string | Notes
PSTNGTYP | int16 | Posting type
PostIvIn | int16 | Inventory post type
PostPRIn | int16 | Payroll post type
PostPurchIn | int16 | Purchases post type
PostSlsIn | int16 | Sales post type
RequesterTrx | int16 | Requester transaction
TPCLBLNC | int16 | Typical balance
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
USRDEFS1 | string | User-defined field
USRDEFS2 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taUpdateCreateAccountRcd>*


taUpdateCreateCountryCode Class

A class that represents the eConnect node you use to create or update a country code.

Constructor

Name | Description
taUpdateCreateCountryCode() | Initializes an instance of the taUpdateCreateCountryCode class.

Properties

Name | Type | Description
CCode | string | Country code
CCodeDesc | string | Description
ECFLAG | int16 | EU member
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taUpdateCreateCountryCode>*


taUpdateCreateCustomerRcd Class

A class that represents the eConnect node you use to create or update a customer.

Constructor

Name | Description
taUpdateCreateCustomerRcd() | Initializes an instance of the taUpdateCreateCustomerRcd class.

Properties

Name | Type | Description
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
ADRSCODE | string | Address code
BALNCTYP | int16 | Balance type
BALNCTYPSpecified | bool | Set to True when you assign a value to BALNCTYP
BANKNAME | string | Bank name
BNKBRNCH | string | Bank branch
BccEmail_Recipient | string | Blind copy email recipients
CCRDXPDT | string | Credit card expiration date
CCode | string | Country code
CHEKBKID | string | Checkbook ID
CITY | string | City
CNTCPRSN | string | Contact person
COMMENT1 | string | Comment information
COMMENT2 | string | Comment information
COUNTRY | string | Country
CRCARDID | string | Credit card ID
CRCRDNUM | string | Credit card number
CRLMTAMT | Decimal | Credit limit amount
CRLMTAMTSpecified | bool | Set to True when you assign a value to CRLMTAMT
CRLMTPAM | Decimal | Credit limit period amount
CRLMTPAMSpecified | bool | Set to True when you assign a value to CRLMTPAM
CRLMTPER | int16 | Credit limit period
CRLMTPERSpecified | bool | Set to True when you assign a value to CRLMTPER
CRLMTTYP | int16 | Credit limit type
CRLMTTYPSpecified | bool | Set to True when you assign a value to CRLMTTYP
CURNCYID | string | Currency ID
CUSTCLAS | string | Customer class
CUSTDISC | Decimal | Trade discount
CUSTDISCSpecified | bool | Set to True when you assign a value to CUSTDISC
CUSTNAME | string | Customer name
CUSTNMBR | string | Customer number
CUSTPRIORITY | int16 | Customer priority
CUSTPRIORITYSpecified | bool | Set to True when you assign a value to CUSTPRIORITY
CcEmail_Recipient | string | Copied email recipients
CreateAddress | int16 | Create primary address code
DEFCACTY | int16 | Cash account type
DEFCACTYSpecified | bool | Set to True when you assign a value to DEFCACTY
DISGRPER | int16 | Discount grace period
DISGRPERSpecified | bool | Set to True when you assign a value to DISGRPER
DUEGRPER | int16 | Due date grace period
DUEGRPERSpecified | bool | Set to True when you assign a value to DUEGRPER
FAX | string | Fax number
FINCHDLR | Decimal | Finance charge amount
FINCHDLRSpecified | bool | Set to True when you assign a value to FINCHDLR
FNCHATYP | int16 | Finance charge type
FNCHATYPSpecified | bool | Set to True when you assign a value to FNCHATYP
FNCHPCNT | Decimal | Finance charge percentage
FNCHPCNTSpecified | bool | Set to True when you assign a value to FNCHPCNT
GPSFOINTEGRATIONID | string | Front office integration ID
HOLD | int16 | Hold status
HOLDSpecified | bool | Set to True when you assign a value to HOLD
INACTIVE | int16 | Inactive
INACTIVESpecified | bool | Set to True when you assign a value to INACTIVE
INCLUDEINDP | int16 | Include in demand planning
INCLUDEINDPSpecified | bool | Set to True when you assign a value to INCLUDEINDP
INTEGRATIONID | string | Integration ID
INTEGRATIONSOURCE | int16 | Integration source
KPCALHST | int16 | Calendar year history
KPCALHSTSpecified | bool | Set to True when you assign a value to KPCALHST
KPDSTHST | int16 | Distribution history
KPDSTHSTSpecified | bool | Set to True when you assign a value to KPDSTHST
KPERHIST | int16 | Fiscal year history
KPERHISTSpecified | bool | Set to True when you assign a value to KPERHIST
KPTRXHST | int16 | Transaction history
KPTRXHSTSpecified | bool | Set to True when you assign a value to KPTRXHST
MINPYDLR | Decimal | Minimum payment amount
MINPYDLRSpecified | bool | Set to True when you assign a value to MINPYDLR
MINPYPCT | Decimal | Minimum payment percentage
MINPYPCTSpecified | bool | Set to True when you assign a value to MINPYPCT
MINPYTYP | int16 | Minimum payment type
MINPYTYPSpecified | bool | Set to True when you assign a value to MINPYTYP
MXWOFTYP | int16 | Maximum write-off type
MXWOFTYPSpecified | bool | Set to True when you assign a value to MXWOFTYP
MXWROFAM | Decimal | Maximum write-off amount
MXWROFAMSpecified | bool | Set to True when you assign a value to MXWROFAM
NOTETEXT | string | Notes
ORDERFULFILLDEFAULT | int16 | Order fulfillment shortage
ORDERFULFILLDEFAULTSpecified | bool | Set to True when you assign a value to ORDERFULFILLDEFAULT
PHNUMBR1 | string | Telephone number
PHNUMBR2 | string | Telephone number
PHNUMBR3 | string | Telephone number
PRBTADCD | string | Bill to address
PRCLEVEL | string | Price level
PRSTADCD | string | Ship to address
PYMTRMID | string | Payment terms
Post_Results_To | int16 | Post results to
Post_Results_ToSpecified | bool | Set to True when you assign a value to Post_Results_To
RATETPID | string | Rate type
RMARACTNUMST | string | Receivables account
RMAVACTNUMST | string | Terms discount available account
RMCOSACTNUMST | string | Cost of goods sold account
RMCSHACTNUMST | string | Cash account
RMFCGACTNUMST | string | Finance charge account
RMIVACTNUMST | string | Inventory account
RMOvrpymtWrtoffACTNUMST | string | Overpayment write-off account
RMSLSACTNUMST | string | Sales account
RMSORACTNUMST | string | Sales order returns
RMTAKACTNUMST | string | Terms discount taken account
RMWRACTNUMST | string | Write-offs account
RequesterTrx | int16 | Requester transaction
Revalue_Customer | int16 | Revalue customer
Revalue_CustomerSpecified | bool | Set to True when you assign a value to Revalue_Customer
SALSTERR | string | Sales territory
SHIPCOMPLETE | int16 | Ship complete documents
SHIPCOMPLETESpecified | bool | Set to True when you assign a value to SHIPCOMPLETE
SHIPMTHD | string | Shipping method
SHRTNAME | string | Short name
SLPRSNID | string | Salesperson ID
STADDRCD | string | Statement address
STATE | string | State
STMTCYCL | int16 | Statement cycle
STMTCYCLSpecified | bool | Set to True when you assign a value to STMTCYCL
STMTNAME | string | Statement name
Send_Email_Statements | int16 | Send email statement
Send_Email_StatementsSpecified | bool | Set to True when you assign a value to Send_Email_Statements
TAXEXMT1 | string | Tax exempt information
TAXEXMT2 | string | Tax exempt information
TAXSCHID | string | Tax schedule
TXRGNNUM | string | Tax registration number
ToEmail_Recipient | string | Email recipient
UPSZONE | string | UPS zone
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USERLANG | int16 | User language
USERLANGSpecified | bool | Set to True when you assign a value to USERLANG
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
UseCustomerClass | int16 | Use class settings
ZIPCODE | string | Postal code

See Also

<taUpdateCreateCustomerRcd>*


taUpdateCreateItemCurrencyRcd_ItemsTaUpdateCreateItemCurrencyRcd Class

A class that represents the eConnect node you use to create or update the association between and an inventory item and a currency.

Constructor

Name | Description
taUpdateCreateItemCurrencyRcd_ItemsTaUpdateCreateItemCurrencyRcd() | Initializes an instance of the taUpdateCreateItemCurrencyRcd_ItemsTaUpdateCreateItemCurrencyRcd class.

Properties

Name | Type | Description
CURNCYID | string | Currency ID
DECPLCUR | int16 | Currency decimal places
ITEMNMBR | string | Item number
LISTPRCE | Decimal | List price
RequesterTrx | int16 | Requester transaction
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag

See Also

<taUpdateCreateItemCurrencyRcd>*


taUpdateCreateItemRcd Class

A class that represents the eConnect node you use to create or update an inventory item.

Constructor

Name | Description
taUpdateCreateItemRcd() | Initializes an instance of the taUpdateCreateItemRcd class.

Properties

Name | Type | Description
ABCCODE | int16 | ABC code
ABCCODESpecified | bool | Set to True when you assign a value to ABCCODE
ALTITEM1 | string | Alternate item
ALTITEM2 | string | Alternate item
ALWBKORD | int16 | Allow back orders
ALWBKORDSpecified | bool | Set to True when you assign a value to ALWBKORD
ASMVRACTNUMST | string | Assembly variance account
CNTRYORGN | string | Country of origin
CURRCOST | Decimal | Current cost
CURRCOSTSpecified | bool | Set to True when you assign a value to CURRCOST
DECPLCUR | int16 | Currency decimal places
DECPLCURSpecified | bool | Set to True when you assign a value to DECPLCUR
DECPLQTY | int16 | Quantity decimal places
DECPLQTYSpecified | bool | Set to True when you assign a value to DECPLQTY
DPSHPACTNUMST | string | Drop ship account
INCLUDEINDP | int16 | Include in demand planning
INCLUDEINDPSpecified | bool | Set to True when you assign a value to INCLUDEINDP
ITEMDESC | string | Item description
ITEMNMBR | string | Item number
ITEMSHWT | Decimal | Shipping weight
ITEMSHWTSpecified | bool | Set to True when you assign a value to ITEMSHWT
ITEMTYPE | int16 | Item type
ITEMTYPESpecified | bool | Set to True when you assign a value to ITEMTYPE
ITMCLSCD | string | Class ID
ITMGEDSC | string | Generic description
ITMSHNAM | string | Item short name
ITMTRKOP | int16 | Item tracking
ITMTRKOPSpecified | bool | Set to True when you assign a value to ITMTRKOP
ITMTSHID | string | Tax schedule
IVCOGSACTNUMST | string | Cost of goods sold account
IVDMGACTNUMST | string | Damaged account
IVINSVACTNUMST | string | In service account
IVINUSACTNUMST | string | In use account
IVIVACTNUMST | string | Inventory account
IVIVOFACTNUMST | string | Inventory offset account
IVRETACTNUMST | string | Inventory returns account
IVSLDSACTNUMST | string | Markdown account
IVSLRNACTNUMST | string | Sales returns account
IVSLSACTNUMST | string | Sales account
IVVARACTNUMST | string | Variance account
KPCALHST | int16 | Calendar history
KPCALHSTSpecified | bool | Set to True when you assign a value to KPCALHST
KPDSTHST | int16 | Distribution history
KPDSTHSTSpecified | bool | Set to True when you assign a value to KPDSTHST
KPERHIST | int16 | Fiscal year history
KPERHISTSpecified | bool | Set to True when you assign a value to KPERHIST
KPTRXHST | int16 | Transaction history
KPTRXHSTSpecified | bool | Set to True when you assign a value to KPTRXHST
KTACCTSR | int16 | Cost of goods sold account source
KTACCTSRSpecified | bool | Set to True when you assign a value to KTACCTSR
LISTPRCE | Decimal | List price
LISTPRCESpecified | bool | Set to True when you assign a value to LISTPRCE
LOCNCODE | string | Location code
LOTEXPWARN | int16 | Lot expiration warning
LOTEXPWARNDAYS | int16 | Days to lot expiration
LOTEXPWARNDAYSSpecified | bool | Set to True when you assign a value to LOTEXPWARNDAYS
LOTEXPWARNSpecified | bool | Set to True when you assign a value to LOTEXPWARN
LOTTYPE | string | Lot type
MINSHELF1 | int16 | Minimum shelf life
MINSHELF1Specified | bool | Set to True when you assign a value to MINSHELF1
MINSHELF2 | int16 | Minimum shelf life
MINSHELF2Specified | bool | Set to True when you assign a value to MINSHELF2
NOTETEXT | string | Notes
PRCHSUOM | string | Purchasing unit of measure
PRICMTHD | int16 | Pricing method
PRICMTHDSpecified | bool | Set to True when you assign a value to PRICMTHD
PURPVACTNUMST | string | Purchase price variance account
PriceGroup | string | Price group
Purchase_Item_Tax_Schedu | string | Purchase tax schedule
Purchase_Tax_Options | int16 | Purchase tax options
Purchase_Tax_OptionsSpecified | bool | Set to True when you assign a value to Purchase_Tax_Options
QtyOverTolerancePercent | int32 | Quantity over tolerance percentage
QtyOverTolerancePercentSpecified | bool | Set to True when you assign a value to QtyOverTolerancePercent
QtyShortTolerancePercent | int32 | Quantity short tolerance percentage
QtyShortTolerancePercentSpecified | bool | Set to True when you assign a value to QtyShortTolerancePercent
RequesterTrx | int16 | Requester transaction
Revalue_Inventory | int16 | Revalue inventory
Revalue_InventorySpecified | bool | Set to True when you assign a value to Revalue_Inventory
STNDCOST | Decimal | Standard cost
STNDCOSTSpecified | bool | Set to True when you assign a value to STNDCOST
TAXOPTNS | int16 | Tax options
TAXOPTNSSpecified | bool | Set to True when you assign a value to TAXOPTNS
TCC | string | Tax community code
Tolerance_Percentage | Decimal | Tolerance percentage
Tolerance_PercentageSpecified | bool | Set to True when you assign a value to Tolerance_Percentage
UOMSCHDL | string | Unit of measure schedule
UPPVACTNUMST | string | Unrealized purchase price variance account
USCATVLS_1 | string | User category
USCATVLS_2 | string | User category
USCATVLS_3 | string | User category
USCATVLS_4 | string | User category
USCATVLS_5 | string | User category
USCATVLS_6 | string | User category
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
UseItemClass | int16 | Use class settings
UseQtyOverageTolerance | int16 | Use quantity overage tolerance
UseQtyOverageToleranceSpecified | bool | Set to True when you assign a value to UseQtyOverageTolerance
UseQtyShortageTolerance | int16 | Use quantity shortage tolerance
UseQtyShortageToleranceSpecified | bool | Set to True when you assign a value to UseQtyShortageTolerance
VCTNMTHD | int16 | Valuation method
VCTNMTHDSpecified | bool | Set to True when you assign a value to VCTNMTHD
WRNTYDYS | int16 | Warranty days
WRNTYDYSSpecified | bool | Set to True when you assign a value to WRNTYDYS

See Also

<taUpdateCreateItemRcd>*


taUpdateCreatePAVendorRcd Class

A class that represents the eConnect node you use to create or update a project vendor.

Constructor

Name | Description
taUpdateCreatePAVendorRcd() | Initializes an instance of the taUpdateCreatePAVendorRcd class.

Properties

Name | Type | Description
PAFFProfitAmount | Decimal | FF profit amount
PAFFProfitPercent | Decimal | FF profit percentage
PAFFProfitType | int16 | FF profit type
PAProfitAmountCP | Decimal | CP profit amount
PAProfitPercentCP | Decimal | CP profit percentage
PAProfit_Type__CP | int16 | CP profit type
PATMProfitAmount | Decimal | TM profit amount
PATMProfitPercent | Decimal | Tm profit percentage
PATMProfitType | int16 | TM profit type
PAUD1 | string | User-defined field
PAUD2 | string | User-defined field
PAUNITCOST | Decimal | Unit cost
PAUnit_of_Measure | string | Unit of measure
PAddlDefpoformatouse | int16 | Purchase order format
UpdateIfExists | int16 | Update if exists flag
VENDORID | string | Vendor ID
VNDCLSID | string | Vendor class

See Also

<taUpdateCreatePAVendorRcd>*


taUpdateCreateVendorRcd Class

A class that represents the eConnect node you use to create or update a vendor.

Constructor

Name | Description
taUpdateCreateVendorRcd() | Initializes an instance of the taUpdateCreateVendorRcd class.

Properties

Name | Type | Description
ACNMVNDR | string | Vendor account number
ACPURACTNUMST | string | Accrued purchases account
ADDRESS1 | string | Address information
ADDRESS2 | string | Address information
ADDRESS3 | string | Address information
CCode | string | Country code
CHEKBKID | string | Checkbook ID
CITY | string | City
COMMENT1 | string | Comment information
COMMENT2 | string | Comment information
COUNTRY | string | Country
CREDTLMT | int16 | Credit limit type
CREDTLMTSpecified | bool | Set to True when you assign a value to CREDTLMT
CRLMTDLR | Decimal | Credit limit amount
CRLMTDLRSpecified | bool | Set to True when you assign a value to CRLMTDLR
CURNCYID | string | Currency ID
CreateAddress | int16 | Create primary address code
DISGRPER | int16 | Discount grace period
DISGRPERSpecified | bool | Set to True when you assign a value to DISGRPER
DUEGRPER | int16 | Due date grace period
DUEGRPERSpecified | bool | Set to True when you assign a value to DUEGRPER
FAXNUMBR | string | Fax number
FREEONBOARD | int16 | Free on board
FREEONBOARDSpecified | bool | Set to True when you assign a value to FREEONBOARD
HOLD | int16 | Hold
HOLDSpecified | bool | Set to True when you assign a value to HOLD
KGLDSTHS | int16 | Distribution history
KGLDSTHSSpecified | bool | Set to True when you assign a value to KGLDSTHS
KPCALHST | int16 | Calendar history
KPCALHSTSpecified | bool | Set to True when you assign a value to KPCALHST
KPERHIST | int16 | Fiscal year history
KPERHISTSpecified | bool | Set to True when you assign a value to KPERHIST
KPTRXHST | int16 | Transaction history
KPTRXHSTSpecified | bool | Set to True when you assign a value to KPTRXHST
MAXINDLR | Decimal | Maximum invoice amount
MAXINDLRSpecified | bool | Set to True when you assign a value to MAXINDLR
MINORDER | Decimal | Minimum order
MINORDERSpecified | bool | Set to True when you assign a value to MINORDER
MINPYDLR | Decimal | Minimum payment amount
MINPYDLRSpecified | bool | Set to True when you assign a value to MINPYDLR
MINPYPCT | Decimal | Minimum payment percentage
MINPYPCTSpecified | bool | Set to True when you assign a value to MINPYPCT
MINPYTYP | int16 | Minimum payment type
MINPYTYPSpecified | bool | Set to True when you assign a value to MINPYTYP
MXIAFVND | int16 | Maximum invoice type
MXIAFVNDSpecified | bool | Set to True when you assign a value to MXIAFVND
MXWOFAMT | Decimal | Maximum write-off amount
MXWOFAMTSpecified | bool | Set to True when you assign a value to MXWOFAMT
NOTETEXT | string | Notes
PHNUMBR1 | string | Telephone number
PHNUMBR2 | string | Telephone number
PHNUMBR3 | string | Telephone number
PMAPACTNUMST | string | Payables account
PMCSHACTNUMST | string | Cash account
PMDAVACTNUMST | string | Term discount available account
PMDTKACTNUMST | string | Term discount taken account
PMFINACTNUMST | string | Finance charge account
PMFRTACTNUMST | string | Freight account
PMMSCHACTNUMST | string | Miscellaneous account
PMPRCHACTNUMST | string | Purchases account
PMTAXACTNUMST | string | Tax account
PMTDSCACTNUMST | string | Trade discount account
PMWRTACTNUMST | string | Write-off account
PTCSHACF | int16 | Cash account type
PTCSHACFSpecified | bool | Set to True when you assign a value to PTCSHACF
PURPVACTNUMST | string | Purchase price variance account
PYMNTPRI | string | Payment priority
PYMTRMID | string | Payment terms
Post_Results_To | int16 | Post results to
Post_Results_ToSpecified | bool | Set to True when you assign a value to Post_Results_To
RATETPID | string | Rate type
RequesterTrx | int16 | Requester transaction
Revalue_Vendor | int16 | Revalue vendor
Revalue_VendorSpecified | bool | Set to True when you assign a value to Revalue_Vendor
SHIPMTHD | string | Shipping method
STATE | string | State
TAXSCHID | string | Tax schedule
TEN99BOXNUMBER | int16 | Tax 1099 box number
TEN99BOXNUMBERSpecified | bool | Set to True when you assign a value to TEN99BOXNUMBER
TEN99Type | int16 | Tax 1099 type
TEN99TypeSpecified | bool | Set to True when you assign a value to TEN99Type
TRDDISCT | Decimal | Trade discount
TRDDISCTSpecified | bool | Set to True when you assign a value to TRDDISCT
TXIDNMBR | string | Tax ID number
TXRGNNUM | string | Tax registration number
UPSZONE | string | UPS zone
USERDEF1 | string | User-defined field
USERDEF2 | string | User-defined field
USERLANG | int16 | User language
USERLANGSpecified | bool | Set to True when you assign a value to USERLANG
USRDEFND1 | string | User-defined field
USRDEFND2 | string | User-defined field
USRDEFND3 | string | User-defined field
USRDEFND4 | string | User-defined field
USRDEFND5 | string | User-defined field
UpdateIfExists | int16 | Update if exists flag
UseVendorClass | int16 | Use class settings
VADCDPAD | string | Vendor purchase address
VADCDSFR | string | Vendor ship from address
VADCDTRO | string | Vendor remit to address
VADDCDPR | string | Vendor address
VENDNAME | string | Vendor name
VENDORID | string | Vendor ID
VENDSHNM | string | Vendor short name
VENDSTTS | int16 | Vendor status
VENDSTTSSpecified | bool | Set to True when you assign a value to VENDSTTS
VNDCHKNM | string | Vendor check name
VNDCLSID | string | Vendor class ID
VNDCNTCT | string | Vendor contact
WRITEOFF | int16 | Write-off type
WRITEOFFSpecified | bool | Set to True when you assign a value to WRITEOFF
ZIPCODE | string | Postal code

See Also

<taUpdateCreateVendorRcd>*


UPRComputerTrxType Class

A class that represents the document you use to specify a payroll transaction.

Constructor

Name | Description
UPRComputerTrxType() | Initializes an instance of the UPRComputerTrxType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateComputerCheckLineInsert_Items | taCreateComputerCheckLineInsert_ItemsTaCreateComputerCheckLineInsert[] | A collection of nodes that create one or more payroll computer check lines.
taCreatePayrollBatchHeaderInsert | taCreatePayrollBatchHeaderInsert | A node that creates a payroll batch header.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRComputerTrxType


UPRCreateBenefitType Class

A class that represents the document you use to create a payroll benefit.

Constructor

Name | Description
UPRCreateBenefitType() | Initializes an instance of the UPRCreateBenefitType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateBenefit | taCreateBenefit | A node that creates a payroll benefit.
taCreateBenefitBasedOnPayDedCodes_Items | taCreateBenefitBasedOnPayDedCodes_ItemsTaCreateBenefitBasedOnPayDedCodes[] | A collection of nodes that create one or more payroll deductions based on a pay codes.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateBenefitType


UPRCreateDeductionType Class

A class that represents the document you use to create a payroll deduction.

Constructor

Name | Description
UPRCreateDeductionType() | Initializes an instance of the UPRCreateDeductionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateDeduction | taCreateDeduction | A node that creates a payroll deduction.
taCreateDeductionBasedOnPayCodes_Items | taCreateDeductionBasedOnPayCodes_ItemsTaCreateDeductionBasedOnPayCodes[] | A collection of nodes that create one or more payroll deductions based on a pay codes.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateDeductionType


UPRCreateDepartmentType Class

A class that represents the document you use to create a payroll department.

Constructor

Name | Description
UPRCreateDepartmentType() | Initializes an instance of the UPRCreateDepartmentType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateDepartment | taCreateDepartment | A node that creates a payroll department.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateDepartmentType


UPRCreateEmployeeAddressType Class

A class that represents the document you use to create an employee address.

Constructor

Name | Description
UPRCreateEmployeeAddressType() | Initializes an instance of the UPRCreateEmployeeAddressType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeeAddress | taCreateEmployeeAddress | A node that create or updates an employee address.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeAddressType


UPRCreateEmployeeBenefitType Class

A class that represents the document you use to create a payroll benefit for an employee.

Constructor

Name | Description
UPRCreateEmployeeBenefitType() | Initializes an instance of the UPRCreateEmployeeBenefitType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeeBenefit | taCreateEmployeeBenefit | A node that creates an employee benefit.
taCreateEmployeeBenefitBasedOnPayDedCodes_Items | taCreateEmployeeBenefitBasedOnPayDedCodes_ItemsTaCreateEmployeeBenefitBasedOnPayDedCodes[] | A collection of nodes that create one or more employee benefits based on deduction/pay codes.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeBenefitType


UPRCreateEmployeeClassType Class

A class that represents the document you use to create an employee class.

Constructor

Name | Description
UPRCreateEmployeeClassType() | Initializes an instance of the UPRCreateEmployeeClassType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeeClass | taCreateEmployeeClass | A node that creates or updates an employee.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeClassType


UPRCreateEmployeeDeductionType Class

A class that represents the document you use to create a deduction for an employee.

Constructor

Name | Description
UPRCreateEmployeeDeductionType() | Initializes an instance of the UPRCreateEmployeeDeductionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeeDeduction | taCreateEmployeeDeduction | A node that creates an employee payroll deduction.
taCreateEmployeeDeductionBasedOnPayCodes_Items | taCreateEmployeeDeductionBasedOnPayCodes_ItemsTaCreateEmployeeDeductionBasedOnPayCodes[] | A collection of nodes that create one or more employee payroll deductions based a pay code.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeDeductionType


UPRCreateEmployeeLocalTaxType Class

A class that represents the document you use to associate a local tax with an employee.

Constructor

Name | Description
UPRCreateEmployeeLocalTaxType() | Initializes an instance of the UPRCreateEmployeeLocalTaxType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeeLocalTax | taCreateEmployeeLocalTax | A node that creates an employee payroll local tax.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeLocalTaxType


UPRCreateEmployeePayCodeType Class

A class that represents the document you use to create an employee pay code.

Constructor

Name | Description
UPRCreateEmployeePayCodeType() | Initializes an instance of the UPRCreateEmployeePayCodeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeePayCode | taCreateEmployeePayCode | A node that create payroll employee pay codes.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeePayCodeType


UPRCreateEmployeeStateTaxType Class

A class that represents the document you use to associate a state tax with an employee.

Constructor

Name | Description
UPRCreateEmployeeStateTaxType() | Initializes an instance of the UPRCreateEmployeeStateTaxType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeeStateTax | taCreateEmployeeStateTax | A node that create payroll state tax.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeStateTaxType


UPRCreateEmployeeTaxType Class

A class that represents the document you use to create an employee tax record.

Constructor

Name | Description
UPRCreateEmployeeTaxType() | Initializes an instance of the UPRCreateEmployeeTaxType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployeeTax | taCreateEmployeeTax | A node that create employee taxes.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeTaxType


UPRCreateEmployeeType Class

A class that represents the document you use to create an employee.

Constructor

Name | Description
UPRCreateEmployeeType() | Initializes an instance of the UPRCreateEmployeeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateEmployee | taCreateEmployee | A node that creates or updates an employee.
taCreateInternetAddresses_Items | taCreateInternetAddressesTaCreateInternetAddresses[] | A collection of taCreateInternetAddresses nodes that create one or more internet address es.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateEmployeeType


UPRCreateLocalTaxType Class

A class that represents the document you use to create a local tax record.

Constructor

Name | Description
UPRCreateLocalTaxType() | Initializes an instance of the UPRCreateLocalTaxType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateLocalTax | taCreateLocalTax | A node that create payroll local tax.
taCreateLocalTaxDetail_Items | taCreateLocalTaxDetail_ItemsTaCreateLocalTaxDetail[] | A collection of nodes that create payroll local tax detail information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateLocalTaxType


UPRCreateLocationType Class

A class that represents the document you use to create a payroll location.

Constructor

Name | Description
UPRCreateLocationType()( | Initializes an instance of the UPRCreateLocationType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateLocation | taCreateLocation | A node that create a payroll location.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateLocationType


UPRCreatePayCodeType Class

A class that represents the document you use to create a payroll pay code.

Constructor

Name | Description
UPRCreatePayCodeType() | Initializes an instance of the UPRCreatePayCodeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreatePayCode | taCreatePayCode | A node that creates a payroll pay code.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreatePayCodeType


UPRCreatePositionType Class

A class that represents the document you use to create a payroll position.

Constructor

Name | Description
UPRCreatePositionType() | Initializes an instance of the UPRCreatePositionType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreatePosition | taCreatePosition | A node that creates a payroll position code.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreatePositionType


UPRCreateShiftCodeType Class

A class that represents the document you use to create a payroll shift code.

Constructor

Name | Description
UPRCreateShiftCodeType() | Initializes an instance of the UPRCreateShiftCodeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateShiftCode | taCreateShiftCode | A node that creates a payroll shift code.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateShiftCodeType


UPRCreateSupervisorType Class

A class that represents the document you use to create a supervisor record.

Constructor

Name | Description
UPRCreateSupervisorType() | Initializes an instance of the UPRCreateSupervisorType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateSupervisor | taCreateSupervisor | A node that creates a supervisor.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateSupervisorType


UPRCreateWorker_CompensationCodeType Class

A class that represents the document you use to create a worker compensation code.

Constructor

Name | Description
UPRCreateWorker_CompensationCodeType() | Initializes an instance of the UPRCreateWorker_CompensationCodeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateWorkersCompensationCode | taCreateWorkersCompensationCode | A node that creates a workers compensation code.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRCreateWorkersCompensationType


UPRDeleteEmployeeAddressType Class

A class that represents the document you use to remove address information for an employee.

Constructor

Name | Description
UPRDeleteEmployeeAddressType() | Initializes an instance of the UPRDeleteEmployeeAddressType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteEmployeeAddress | taDeleteEmployeeAddress | A node that specifies an employee address record.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRDeleteEmployeeAddressType


UPRDeleteEmployeePayCodeType Class

A class that represents the document you use to remove pay code information for an employee.

Constructor

Name | Description
UPRDeleteEmployeePayCodeType() | Initializes an instance of the UPRDeleteEmployeePayCodeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteEmployeePayCode | taDeleteEmployeePayCode | A node that specifies employee pay code information.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRDeleteEmployeePayCodeType


UPRDeleteEmployeeType Class

A class that represents the document you use to remove an employee.

Constructor

Name | Description
UPRDeleteEmployeeType() | Initializes an instance of the UPRDeleteEmployeeType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taDeleteEmployee | taDeleteEmployee | A node that removes an employee from payroll.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRDeleteEmployeeType


UPRManualTrxType Class

A class that represents the document you use to specify a payroll transaction.

Constructor

Name | Description
UPRManualTrxType() | Initializes an instance of the UPRManualTrxType class.

Properties

Name | Type | Description
eConnectProcessInfo | eConnectProcessInfo | eConnect processing information.
taCreateManualCheckHeaderInsert | taCreateManualCheckHeaderInsert | A node that creates a payroll manual check header.
taCreateManualCheckLineInsert_Items | taCreateManualCheckLineInsert_ItemsTaCreateManualCheckLineInsert[] | A collection of nodes that create one or more payroll manual check lines.
taCreatePayrollBatchHeaderInsert | taCreatePayrollBatchHeaderInsert | A node that creates a payroll batch header.
taRequesterTrxDisabler_Items | taRequesterTrxDisabler_ItemsTaRequesterTrxDisabler[] | A collection of taRequesterTrxDisabler nodes.

See Also

UPRManualTrxType


XML Schema Reference

This section of the documentation provides information about the Microsoft Dynamics GP eConnect document and transaction type schema. You use document and transactions types to construct the XML documents that eConnect uses to create, update, retrieve, and delete or void Dynamics GP data. The following sections describe the schema and identify the XML nodes you use to populate the eConnect document and transaction types:

  • Analytical Accounting
  • Bank Reconciliation
  • Company
  • eConnect
  • Field Service
  • Fixed Assets
  • General Ledger
  • Human Resources
  • Inventory
  • Lockbox
  • Payroll
  • Project Accounting
  • Purchase Order Processing
  • Purchasing
  • Receivables
  • Sales Order Processing
  • Shared Master

If you review the transaction type schema, you might find nodes that include the name of an XML node with _Items appended to the node name. These nodes enable you to add one or more XML nodes of the specified type to your document. For example, the taBRBankDepositsLine_Items node of the BRBankDepositsType transaction type specifies that you can include one or more taBRBankDepositsLine XML nodes in that document.

The eConnect installation includes .xsd files that contain the definition of each schema. The individual schema files are typically found at C:\Program files\Microsoft Dynamics\eConnect 11.0\XML Sample Documents\Incoming XSD Individual Schemas.


Analytical Accounting

The Analytical Accounting schemas are as follows:

  • AATrxDimCodeMaintType


AATrxDimCodeMaintType

Description

An eConnect transaction type that specifies an analytical accounting dimension.

XML nodes

  • <taAATrxDimCodeMaint>*

Remarks

Use the AA Transaction Dimension Code Maintenance schema to set up or delete transaction dimension codes for alphanumeric transaction dimensions. The schema recreates the functionality of the Transaction Dimension Code Maintenance window of the Microsoft Dynamics GP client.

The <taAATrxDimCodeMaint> node includes user-defined elements that can be associated with a transaction dimension code. These elements recreate the functionality of the Trx Dimension Code User-Defined Fields Maintenance window of the Microsoft Dynamics GP client

If you integrate Analytical Accounting with FRx, use only letters, numbers, or underscores in the transaction dimension codes. FRx does not support transaction dimension codes that contain special characters.

Document structure

<eConnect>
    <AATrxDimCodeMaintType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taAATrxDimCodeMaint />
    </AATrxDimCodeMaintType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Bank Reconciliation

The bank transaction entry is a posting window and it does not allow you to save batches. When you use eConnect to enter a bank transaction, it generates a batch in the General Ledger. eConnect does not post through the General Ledger. You must verify and post all the batches generated by eConnect to the Microsoft Dynamics GP General Ledger.

If your Microsoft Dynamics GP setup allows posting through the General Ledger, this does not apply to eConnect.

Microsoft Dynamics GP requires a distribution when you enter or void a transaction. To ensure the distribution is included, eConnect automatically supplies the required distribution. You cannot change how eConnect automatically creates this required distribution. If you configure eConnect to not automatically create distributions, eConnect still creates these required distributions.

At this time, the <taBRBankTransactionDist>, <taBRBankTransactionHeader>, <taBRBankTransactionVoid> XML nodes do not use the RequesterTrx element.

The Bank Reconciliation schemas are as follows:

  • BRBankDepositsType
  • BRBankTransactionType
  • BRBankTransactionVoidType
  • BRDeleteBankDepositsType
  • BRPostBankDepositsType


BRBankDepositsType

Description

An eConnect transaction type that represents bank deposit information.

XML nodes

  • <taBRBankDepositsLine>
  • <taBRBankDepositsHeader>
  • <taBRPostBankDeposits>

XML document structure

<eConnect>
    <BRBankDepositsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taBRBankDepositsLine_Items>
            <taBrBankDepositsLine />
        </taBRBankeDepositsLine_Items>
        <taBRBankBankDepositsHeader />
        <taBRPostBankDeposits/>
    </BRBankDepositsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


BRBankTransactionType

Description

An eConnect transaction type that represents a bank transaction.

XML nodes

  • <taBRBankTransactionDist>
  • <taAnalyticsDistribution>*
  • <taBRBankTransactionHeader>

Remarks

You use the schema’s <taBRBankTransactionDist> XML node to enter distributions. The distributions will not have matching debits and credits. eConnect automatically creates the one required distribution. You cannot change the behavior that automatically produces the required distribution.

eConnect sets the type of the default distribution (DefaultDist) based on the values specified by the Option and transaction type (CMTrxNum) elements of the <taBRBankTransactionHeader> XML node. The following table shows the default distribution type for the valid combinations of Option and CMTrxType values:

Option | CMTrxType | DefaultDist
1 | 3 | Credit
1 | 4 | Credit
1 | 5 | Debit
1 | 6 | Credit

The <taBRBankTransactionHeader> XML node contains the batch number element (BACHNUMB). BACHNUMB specifies the General Ledger (GL) batch that eConnect creates. Microsoft Dynamics GP uses an audit trail code for the GL batch number. Microsoft Dynamics GP also uses the audit trail code to identify the originating transaction source. To recreate the behavior of Microsoft Dynamics GP, eConnect implements the following rules for batch numbers:

  • When you do not specify a BACHNUMB, eConnect uses a default batch process similar to Microsoft Dynamics GP. The key difference, eConnect creates a separate batch with a unique audit trail code for each transaction.
  • When you specify a BACHNUMB, eConnect uses that value to identify the batch. However, Microsoft Dynamics GP still supplies the audit trail code which is also used to identify originating transaction source. While the batch number will not match the cash management audit trail code, all drill back capabilities will work.

Document structure

<eConnect>
    <BRBankTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taBRBankTransactionDist_Items>
            <taBRBankTransactionDist />
        </taBRBankTransactionDist_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taBRBankTransactionHeader />
    </BRBankTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


BRBankTransactionVoidType

Description

An eConnect transaction type that voids a bank transaction.

XML nodes

  • <taBRBankTransactionDist>
  • <taAnalyticsDistribution>*
  • <taBRBankTransactionVoid>

Remarks

You use the schema’s <taBRBankTransactionDist> XML node to enter manual distributions. If distributions do not need to be changed, reversing entries are created from the original distributions.

The create distribution (CreateDist) element of the <taBRBankTransactionVoid> XML node has a default value of 1. The default value allows eConnect to automatically create reversing distributions from the original transaction. If you set CreateDist to 0, the required default distribution is still automatically created.

If you manually send distributions by setting CreateDist to 0, the credits will not match the debits. The DefaultDist depends on the value specified by the Option element of the <taBRBankTransactionVoid> XML node and the transaction type. However, the CMTrxType element is not used in the <taBRBankTransactionVoid> XML node. To determine the type of the default entry, you need to know the transaction type that is being voided. The following table displays the DefaultDist for each transaction type:

Option | Transaction Type | DefaultDist
3 | Check | Debit
3 | Withdrawal | Debit
3 | Increase Adjustment | Credit
3 | Decrease Adjustment | Debit

If you set CreateDist to 1, you can still use <taBRBankTransactionDist> XML nodes to specify manual distributions. This creates the original distributions and the allows the manual distributions to have matching debits and credits.

If multiple bank reconciliation documents have the same checkbook ID (CHEKBKID) and the transaction number (CMTrxNum), use the control number (CMDNUMWK) element of the <taBRBankTransactionVoid> XML node to specify the document. The CMDNUMWK element is equivalent to the CMRECNUM column of the CM20200 table. This column contains the primary key of the bank transactions to be voided. You retrieve the CMDNUMWK value by querying the CM20200 table to return the CMRECNUM value of the document that is being voided.

The <taBRBankTransactionVoid> XML node contains the batch number element (BACHNUMB). BACHNUMB specifies the General Ledger (GL) batch that eConnect creates. Microsoft Dynamics GP uses an audit trail code for the GL batch number. Microsoft Dynamics GP also uses the audit trail code to identify the originating transaction source. To recreate the behavior of Microsoft Dynamics GP, eConnect implements the following rules for batch numbers:

  • When you do not specify a BACHNUMB, eConnect uses a default batch process similar to Microsoft Dynamics GP. The key difference, eConnect creates a separate batch with a unique audit trail code for each transaction.
  • When you specify a BACHNUMB, eConnect uses that value to identify the batch. However, Microsoft Dynamics GP still supplies the audit trail code which is also used to identify originating transaction source. While the batch number will not match the cash management audit trail code, all drill back capabilities will work.

Document structure

<eConnect>
    <BRBankTransactionVoidType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taBRBankTransactionDist_Items>
            <taBRBankTransactionDist />
        </taBRBankTransactionDist_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taBRBankTransactionVoid />
    </BRBankTransactionVoidType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


BRDeleteBankDepositsType

Description

An eConnect transaction type that specifies a bank deposit to delete.

XML nodes

  • <taBRDeleteBankDeposits>

Document structure

<eConnect>
    <BRDeleteBankDepositsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taBRDeleteBankDeposits />
    </BRDeleteBankDepositsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


BRPostBankDepositsType

Description

An eConnect transaction type that specifies a bank deposit to post.

XML nodes

  • <taBRPostBankDeposits>

Document structure

<eConnect>
    <BRPostBankDepositsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taBRPostBankDeposits />
    </BRPostBankDepositsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Company

The Company schemas are as follows:

  • CMPCreateBankType
  • CMPCreateCountryType
  • CMPCreditCardType
  • CMPInternetAddressType
  • CMPShippingMethodType


CMPCreateBankType

Description

An eConnect transaction type that specifies the bank record to create.

XML nodes

  • <taCreateBank>

Document structure

<eConnect>
    <CMPCreateBankType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateBank />
    </CMPCreateBankType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


CMPCreateCountryType

Description

An eConnect transaction type that represents a country.

XML nodes:

  • <taUpdateCreateCountryCode>*

Document structure

<eConnect>
    <CMPCreateCountryType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateCountryCode />
    </CMPCreateCountryType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


CMPCreditCardType

Description

An eConnect transaction type that represents a credit card.

XML nodes

  • <taCreateCreditCard>

Document structure

<eConnect>
    <CMPCreditCardType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateCreditCard />
    </CMPCreditCardType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


CMPInternetAddressType

Description

An eConnect transaction type that represents an internet address.

XML nodes

  • <taCreateInternetAddresses>

Document structure

<eConnect>
    <CMPInternetAddressType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
    </CMPInternetAddressType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


CMPShippingMethodType

Description

An eConnect transaction type that represents a shipping method.

XML nodes

  • <taCreateShippingMethod>*

Document structure

<eConnect>
    <CMPShippingMethodType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateShippingMethod />
    </CMPShippingMethodType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


eConnect

The eConnect schemas are as follows:

  • eConnect schema
  • RQeConnectOutType


eConnect schema

Description

The base node for all eConnect documents. To create an eConnect XML document, add one or more of the following tranaction types.

Schema

  • <BRBankDepositsType >
  • <BRBankTransactionType>
  • <BRBankTransactionVoidType>
  • <BRDeleteBankDepositsType>
  • <BRPostBankDepositsType>
  • <CMPCreateBankType>
  • <CMPCreateCountryType>
  • <CMPCreditCardType>
  • <CMPInternetAddressType>
  • <CMPShippingMethodType>
  • <FACreateAccountGroupType>
  • <FACreateAssetBookIDType>
  • <FACreateAssetBookITCType>
  • <FACreateAssetClassIDType>
  • <FACreateAssetIDType>
  • <FACreateAssetInsuranceType>
  • <FACreateAssetLeaseType>
  • <FACreateAssetPurchaseType>
  • <FACreateAssetUserDataType>
  • <FACreateBookClassType>
  • <FACreateBookIDType>
  • <FACreateInsuranceClassIDType>
  • <FACreateLeaseCompanyType>
  • <FACreateLocationIDType>
  • <FACreatePhysicalLocationIDType>
  • <FACreateRetirementCodeType>
  • <FACreateStructureType>
  • <FSEquipmentType
  • <FSRMType>
  • <FSRTVType>
  • <FSServiceCallType>
  • <GLAccountType>
  • <GLCheckbookMasterType>
  • <GLCreateAccountCategoryType>
  • <GLCreateAccountCurrenciesType>
  • <GLFixedAllocationAccountType>
  • <GLTransactionType>
  • <GLVariableAllocationAccountType>
  • <HRApplicantEducationType>
  • <HRApplicantInterviewType>
  • <HRApplicantReferenceType>
  • <HRApplicantSkillType>
  • <HRApplicantTestType>
  • <HRApplicantType>
  • <HRApplicantWorkHistoryType>
  • <HRCreateSkillSetType>
  • <HRCreateTestType>
  • <HRDeleteApplicantApplicationType>
  • <HRDeleteApplicantEducationLineType>
  • <HRDeleteApplicantEducationType>
  • <HRDeleteApplicantInterviewType>
  • <HRDeleteApplicantReferenceLineType>
  • <HRDeleteApplicantReferenceType>
  • <HRDeleteApplicantRequisitionTYpe>
  • <HRDeleteApplicantTestLineType>
  • <HRDeleteApplicantTestType>
  • <HRDeleteApplicantType>
  • <HRDeleteApplicantWorkHistoryLineType>
  • <HRDeleteApplicantWorkHistoryType>
  • <HRDeleteRequistionType>
  • <HRDeleteSkillSetLineType>
  • <HRDeleteSkillSetType>
  • <HRDeleteSkillType>
  • <HRDeleteTestType>
  • <HRRequisitionType>
  • <HRSkillType>
  • <IVCreateItemCurrencyType>
  • <IVCreateItemPriceListType>
  • <IVCreateIVItemClassType>
  • <IVCreatePlannerType>
  • <IVCreatePriceGroupType>
  • <IVCreatePriceLevelType>
  • <IVCreateSiteBinType>
  • <IVCreateUOFMScheduleType>
  • <IVInventoryItemSiteType>
  • <IVInventorySiteType>
  • <IVInventoryTransactionType>
  • <IVInventoryTransferType>
  • <IVItemMasterType>
  • <IVLotCategoryType>
  • <IVMultibinBinToBinTransferType>
  • <IVVendorItemType>
  • <LBCreateLockboxBankDetailsType>
  • <LBCreateLockboxType>
  • <PAAccountsSetupType>
  • <PAChangeOrderType>
  • <PAContractBillingCycleType>
  • <PAContractsType>
  • <PAEmployeeExpenseType>
  • <PAEquipmentLogTransactionType>
  • <PAMiscLogExpenseType>
  • <PAProjectAccessListType>
  • <PAProjectBillingCyclesType>
  • <PAProjectBudgetMasterType>
  • <PAProjectEquipmentListType>
  • <PAProjectFeesType>
  • <PAProjectsType>
  • <PATimeSheetsType>
  • <PMCreateBuyerType>
  • <PMDeleteVendorAddressType>
  • <PMManualCheckType>
  • <PMScheduledPaymentsType>
  • <PMTransactionType>
  • <PMVendorAddressType>
  • <PMVendorMasterType>
  • <POPDocumentDeleteType>
  • <POPDocumentVoidType>
  • <POPEnterMatchInvoiceType>
  • <POPMapSitesType>
  • <POPReceivingsType>
  • <POPtoSOPLinkRemoveType>
  • <POPTransactionType>
  • <RMApplyType>
  • <RMCashReceiptsType>
  • <RMCreateCustomerItemsType>
  • <RMCreateParentIDType>
  • <RMCustomerAddressType>
  • <RMCustomerClassType>
  • <RMCustomerMasterType>
  • <RMDeleteCustomerAddressType>
  • <RMDeleteCustomerType>
  • <RMDeleteSalespersonType>
  • <RMParentIDChildType>
  • <RMProspectMasterType>
  • <RMSalespersonMasterType>
  • <RMScheduledPaymentsType>
  • <RMTerritoryMasterType>
  • <RMTransactionType>
  • <RMUnapplyTransactionType>
  • <RMVoidTransactionType>
  • <RQeConnectOutType>
  • <SMMdaType>
  • <SMTransactionBatchType>
  • <SOPDeleteDocumentType>
  • <SOPDeleteLineType>
  • <SOPDistributionsType>
  • <SOPLineComponentType>
  • <SOPProcessHoldMasterType>
  • <SOPProcessHoldType>
  • <SOPSerialType>
  • <SOPtoPOPTransactionType>
  • <SOPTransactionType>
  • <SOPVoidDocumentType>
  • <UPRComputerTrxType>
  • <UPRCreateBenefitType>
  • <UPRCreateDeductionType>
  • <UPRCreateDepartmentType>
  • <UPRCreateEmployeeAddressType>
  • <UPRCreateEmployeeBenefitType>
  • <UPRCreateEmployeeClassType>
  • <UPRCreateEmployeeDeductionType>
  • <UPRCreateEmployeeLocalTaxType>
  • <UPRCreateEmployeePayCodeType>
  • <UPRCreateEmployeeStateTaxType>
  • <UPRCreateEmployeeTaxType>
  • <UPRCreateEmployeeType>
  • <UPRCreateLocalTaxType>
  • <UPRCreateLocationType>
  • <UPRCreatePayCodeType>
  • <UPRCreatePositionType>
  • <UPRCreateShiftCodeType>
  • <UPRCreateSupervisorType>
  • <UPRCreateWorker_CompensationCodeType>
  • <UPRDeleteEmployeeAddresssType>
  • <UPRDeleteEmployeePayCodeType>
  • <UPRDeleteEmployeeType>
  • <UPRManualTrxType>

Remarks

An eConnect XML document must contain all nodes required to create a valid transaction. You cannot split the nodes for a single transaction across multiple XML documents. However, you can modify XML documents to your specific business needs. This allows you to combine related documents to create new types of master records.

For example, a customer could be combined with a sales transaction document. This functionality allows you to create an eConnect XML document that contains all the XML transaction types and nodes required for your customer sales document.

For additional information about using the <eConnect> schema to create eConnect XML documents. see eConnect XML Documents

Document structure

<eConnect>

</eConnect>


RQeConnectOutType

Description

An eConnect transaction type that specifies the data records to retrieve using the eConnect Transaction Requester.

XML nodes

  • <eConnectOut>

Document structure

<eConnect>
    <RQeConnecOutType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <eConnectOut />
    </RQeConnecOutType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Field Service

The Field Service schemas are as follows:

  • FSEquipmentType
  • FSRMAType
  • FSRTVType
  • FSServiceCallType


FSEquipmentType

Description

An eConnect transaction type that describes equipment.

XML nodes

  • <taFSEquipmentMaster>*
  • <taFSEquipmentReading>*

Document structure

<eConnect>
    <FSEquipmentType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taFSEquipmentReading_Items>
            <taFSEquipmentReading />
        </taFSEquipmentReading_Items>
        <taFSEquipmentMaster />
    </FSEquipmentType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FSRMAType

Description

An eConnect transaction type that describes returns.

XML nodes

  • <taFSRMALine>*
  • <taFSRMALineSerial>*
  • <taFSRMAMaster>*

Document structure

<eConnect>
    <FSRMAType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taFSRMALineSerial_Items>
            <taFSRMALineSerial />
        </taFSRMALineSerial_Items>
        <taFSRMALine_Items>
            <taFSRMALine />
        </taFSRMALine_Items>
        <taFSRMAMaster />
    </FSRMAType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FSRTVType

Description

An eConnect transaction type that describes vendor returns.

XML nodes

  • <taFSRTVLine>*
  • <taFSRTVLineSerial>*
  • <taFSRTVMaster>*

Document structure

<eConnect>
    <FSRTVType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taFSRTVLineSerial_Items>
            <taFSRTVLineSerial />
        </taFSRTVLineSerial_Items>
        <taFSRTVLine_Items>
            <taFSRTVLine />
        </taFSRTVLine_Items>
        <taFSRTVMaster>*
    </FSRTVType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FSServiceCallType

Description

An eConnect transaction type that describes service calls.

XML nodes

  • <taFSServiceCallCodesEquipment>*
  • <taFSServiceCallLine>*
  • <taFSServiceCallLineSerial>*
  • <taFSServiceCallMaster>*
  • <taFSServiceCallMultiTech>*

Document structure

<eConnect>
    <FSServiceCallType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taFSServiceLineSerial_Items>
            <taFSServiceCallLineSerial />
        </taFSServiceLineSerial_Items>
        <taFSServiceCallLine_Items>
            <taFSServiceCallLine />
        </taFSServiceCallLine_Items>
        <taFSServiceCallCodesEquipment_Items>
            <taFSServiceCallCodesEquipment />
        </taFSServiceCallCodesEquipment_Items>
        <taFSServiceCallMultiTech_Items>
            <taFSServiceCallMultiTech>
        <taFSServiceCallMultiTech_Items>
        <taFSServiceCallMaster />
    </FSServiceCallType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Fixed Assets

The Fixed Assets schemas are as follows:

  • FACreateAccountGroupType
  • FACreateAssetBookIDType
  • FACreateAssetBookITCType
  • FACreateAssetClassIDType
  • FACreateAssetIDType
  • FACreateAssetInsuranceType
  • FACreateAssetLeaseType
  • FACreateAssetPurchaseType
  • FACreateAssetUserDataType
  • FACreateBookClassType
  • FACreateBookIDType
  • FACreateInsuranceClassIDType
  • FACreateLeaseCompanyType
  • FACreateLocationIDType
  • FACreatePhysicalLocationIDType
  • FACreateRetirementCodeType
  • FACreateStructureType


FACreateAccountGroupType

Description

An eConnect transaction type that describes an account group.

XML nodes

  • <taCreateAccountGroup>

Document structure

<eConnect>
    <FACreateAccountGroupType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAccountGroup />
    </FACreateAccountGroupType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetBookIDType

Description

An eConnect transaction type that describes an asset book entry.

XML nodes

  • <taCreateAssetBook>

Document structure

<eConnect>
    <FACreateAssetBookIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetBook />
    </FACreateAssetBookIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetBookITCType

Description

An eConnect transaction type that describes an asset ITC entry.

XML nodes

  • <taCreateAssetBookITC>

Document structure

<eConnect>
     <FACreateAssetBookITCType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetBookITC />
     </FACreateAssetBookITCType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetClassIDType

Description

An eConnect transaction type that specifies an asset class.

XML nodes

  • <taCreateAssetClassID>

Document structure

<eConnect>
     <FACreateAssetClassIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetClassID />
     </FACreateAssetClassIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetIDType

Description

An eConnect transaction type that specifies an asset.

XML nodes

  • <taCreateAssetID>*

Document structure

<eConnect>
    <FACreateAssetIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetID />
    </FACreateAssetIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetInsuranceType

Description

An eConnect transaction type that describes asset insurance.

XML nodes

  • <taCreateAssetInsurance>

Document structure

<eConnect>
    <FACreateAssetInsuranceType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetInsurance />
    </FACreateAssetInsuranceType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetLeaseType

Description

An eConnect transaction type that describes an asset lease.

XML nodes

  • <taCreateAssetLease>

Document structure

<eConnect>
    <FACreateAssetLeaseType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetLease />
    </FACreateAssetLeaseType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetPurchaseType

Description

An eConnect transaction type that describes an asset purchase.

XML nodes

  • <taCreateAssetPurchase>

Document structure

<eConnect>
    <FACreateAssetPurchaseType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetPurchase />
    </FACreateAssetPurchaseType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateAssetUserDataType

Description

An eConnect transaction type that describes an asset user.

XML nodes

  • <taCreateAssetUserData>*

Document structure

<eConnect>
    <FACreateAssetUserDataType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAssetUserData />
    </FACreateAssetUserDataType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateBookClassType

Description

An eConnect transaction type that describes an asset book class.

XML nodes

  • <taCreateBookClass>

Document structure

<eConnect>
    <FACreateBookClassType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateBookClass />
    </FACreateBookClassType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateBookIDType

Description

An eConnect transaction type that specifies a book class.

XML node:

  • <taCreateBookID>

Document structure

<eConnect>
    <FACreateBookIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateBookID />
    </FACreateBookIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateInsuranceClassIDType

Description

An eConnect transaction type that specifies an insurance class.

XML nodes

  • <taCreateInsuranceClassID>

Document structure

<eConnect>
    <FACreateInsuranceClassIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateInsuranceClassID />
    </FACreateInsuranceClassIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateLeaseCompanyType

Description

An eConnect transaction type that describes a lease company.

XML nodes

  • <taCreateLeaseCompany>

Document structure

<eConnect>
    <FACreateLeaseCompanyType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateLeaseCompany />
    </FACreateLeaseCompanyType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateLocationIDType

Description

An eConnect transaction type that specifies an asset location.

XML nodes

  • <taCreateLocationID>

Document structure

<eConnect>
    <FACreateLocationIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateLocationID />
    </FACreateLocationIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreatePhysicalLocationIDType

Description

An eConnect transaction type that specifies an asset location.

XML nodes

  • <taCreatePhysicalLocationID>

Document structure

<eConnect>
    <FACreatePhysicalLocationIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreatePhysicalLocationID />
    </FACreatePhysicalLocationIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateRetirementCodeType

Description

An eConnect transaction type that describes an asset retirement code.

XML nodes

  • <taCreateRetirementCode>

Document structure

<eConnect>
     <FACreateRetirementCodeType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateRetirementCode />
     </FACreateRetirementCodeType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


FACreateStructureType

Description

An eConnect transaction type that describes an asset structure.

XML nodes

  • <taCreateStructure>

Document structure

<eConnect>
    <FACreateStructureType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateStructure />
    </FACreateStructureType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


General Ledger

The General Ledger schemas are as follows:

  • GLAccountType
  • GLCheckbookMasterType
  • GLCreateAccountCategoryType
  • GLCreateAccountCurrenciesType
  • GLFixedAllocationAccount
  • GLTransactionType
  • GLVariableAllocationAccountType


GLAccountType

Description

An eConnect transaction type that describes a general ledger account.

XML nodes

  • <taUpdateCreateAccountRcd>*
  • <taCreateVariableAllocationAccountRcd>*
  • <taCreateFixedAllocationAccountRcd>*

Document structure

<eConnect>
    <GLAccountType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateAccountRcd />
        <taCreateVariableAllocationAccountRcd_Items>
            <taCreateVariableAllocationAccountRcd />
        </taCreateVariableAllocationAccountRcd_Items>
        <taCreateFixedAllocationAccountRcd_Items>
            <taCreateFixedAllocationAccountRcd />
        </taCreateFixedAllocationAccountRcd_Items>
    </GLAccountType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


GLCheckbookMasterType

Description

An eConnect transaction type that describes a checkbook account.

XML nodes

  • <taCreateCheckbook>

Document structure

<eConnect>
    <GLCheckbookMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateCheckbook />
    </GLCheckbookMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


GLCreateAccountCategoryType

Description

An eConnect transaction type that describes a general ledger account category.

XML nodes

  • <taCreateAccountCategory>

Document structure

<eConnect>
    <GLCreateAccountCategoryType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAccountCategory />
    </GLCreateAccountCategoryType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


GLCreateAccountCurrenciesType

Description

An eConnect transaction type that describes a currency associated with a general ledger account.

XML nodes

  • <taCreateAccountCurrencies>

Document structure

<eConnect>
    <GLCreateAccountCurrenciesType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateAccountCurrencies />
    </GLCreateAccountCurrenciesType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


GLFixedAllocationAccount

Description

An eConnect transaction type that describes a fixed allocation account.

XML nodes

  • <taUpdateCreateAccountRcd>*
  • <taCreateFixedAllocationAccountRcd>*

Remarks

The GL Fixed Allocation Account schema requires that the account already exists in the GL00100 table.

Use the <taCreateFixedAllocationAccountRcd> XML node to assign a distribution or percentages to an existing fixed allocation account.

Document structure

<eConnect>
    <GLFixedAllocationAccountType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateAccountRcd />
        <taCreateFixedAllocationAccountRcd_Items>
            <taCreateFixedAllocationAccountRcd />
        </taCreateFixedAllocationAccountRcd_Items>
    </GLFixedAllocationAccountType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


GLTransactionType

Description

An eConnect transaction type that describes a general ledger transaction.

XML nodes

  • <taGLTransactionLineInsert>
  • <taAnalyticsDistribution>*
  • <taGLTransactionHeaderInsert>
  • <taMdaUpdate>

Remarks

To use the <taGLTransactionLineInsert> node in a General Ledger transaction, you must assign a value to either ACTINDX or ACTNUMST. When ACTINDX and ACTNUMST both supply a value, ACTNUMST overrides ACTINDX.

Document structure

<eConnect>
    <GLTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taGLTransactionLineInsert_Items>
            <taGLTransactionLineInsert />
        </taGLTransactionLineInsert_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taGLTransactionHeaderInsert />
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </GLTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


GLVariableAllocationAccountType

Description

An eConnect transaction type that describes a variable allocation account.

XML nodes

  • <taUpdateCreateAccountRcd>*
  • <taCreateVariableAllocationAccountRcd>*

Remarks

The GL Variable Allocation Account schema requires that the account already exists in the GL00100 table.

Use the <taCreateVariableAllocationAccountRcd> XML node to assign account breakdowns or distributions to an existing variable allocation account.

Document structure

<eConnect>
    <GLVariableAllocationAccountType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateAccountRcd />
        <taCreateVariableAllocationAccountRcd_Items>
            <taCreateVariableAllocationAccountRcd />
        </taCreateVariableAllocationAccountRcd_Items>
    </GLVariableAllocationAccountType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Human Resources

The Human Resources schemas are as follows:

  • HRApplicantEducationType
  • HRApplicantInterviewType
  • HRApplicantReferenceType
  • HRApplicantSkillType
  • HRApplicantTestType
  • HRApplicantType
  • HRApplicantWorkHistoryType
  • HRCreateSkillSetType
  • HRCreateTestType
  • HRDeleteApplicantApplicationType
  • HRDeleteApplicantEducationLineType
  • HRDeleteApplicantEducationType
  • HRDeleteApplicantInterviewType
  • HRDeleteApplicantReferenceLineType
  • HRDeleteApplicantReferenceType
  • HRDeleteApplicantRequisitionType
  • HRDeleteApplicantTestLineType
  • HRDeleteApplicantTestType
  • HRDeleteApplicantType
  • HRDeleteApplicantWorkHistoryLineType
  • HRDeleteApplicantWorkHistoryType
  • HRDeleteRequistionType
  • HRDeleteSkillSetLineType
  • HRDeleteSkillSetType
  • HRDeleteSkillType
  • HRDeleteTestType
  • HRRequisitionType
  • HRSkillType


HRApplicantEducationType

Description

An eConnect transaction type that specifies education information about an applicant.

XML nodes

  • <taCreateApplicantEducation>*

Document structure

<eConnect>
    <HRApplicantEducationType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateApplicantEducation />
    </HRApplicantEducationType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRApplicantInterviewType

Description

An eConnect transaction type that specifies interview information for an applicant.

XML nodes

  • <taCreateApplicantInterviewInsert>*
  • <taApplicantInterviewUpdate>*

Document structure

<eConnect>
    <HRApplicantInterviewType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateApplicantInverviewInsert />
        <taApplicantInterviewUpdate_Items>
            <taApplicantInterviewUpdate />
        </taApplicantInterviewUpdate_Items>
    </HRApplicantInterviewType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRApplicantReferenceType

Description

An eConnect transaction type that specifies reference information for an applicant.

XML nodes

  • <taCreateApplicantReferences>*

Document structure

<eConnect>
    <HRApplicantReferenceType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateApplicantReferences />
    </HRApplicantReferenceType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRApplicantSkillType

Description

An eConnect transaction type that specifies skill information for an applicant.

XML nodes

  • <taCreateApplicantSkills>*

Document structure

<eConnect>
    <HRApplicantSkillType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateApplicantSkills />
    </HRApplicantSkillType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRApplicantTestType

Description

An eConnect transaction type that specifies test information for an applicant.

XML nodes

  • <taCreateApplicantTests>*

Document structure

<eConnect>
    <HRApplicantTestType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateApplicantTests />
    </HRApplicantTestType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRApplicantType

Description

An eConnect transaction type that specifies applicant information.

XML nodes

  • <taCreateApplicant>*

Document structure

<eConnect>
    <HRApplicantType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateApplicant />
    </HRApplicantType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRApplicantWorkHistoryType

Description

An eConnect transaction type that specifies work history information for an applicant.

XML nodes

  • <taCreateApplicantWorkHistory>*

Document structure

<eConnect>
    <HRApplicantWorkHistoryType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateApplicantWorkHistory />
    </HRApplicantWorkHistoryType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRCreateSkillSetType

Description

An eConnect transaction type that creates skill set information.

XML nodes

  • <taCreateSkillSets>*
  • <taCreateSkillSetsLine>*

Document structure

<eConnect>
    <HRCreateSkillSetType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateSkillSets />
        <taCreateSkillSetsLine_Items>
            <taCreateSkillSetsLine />
        </taCreateSkillSetsLine_Items>
    </HRCreateSkillSetType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRCreateTestType

Description

An eConnect transaction type that creates test information.

XML nodes

  • <taCreateTests>

Document structure

<eConnect>
    <HRCreateTestType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateTests />
    </HRCreateTestType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantApplicationType

Description

An eConnect transaction type that removes an application.

XML nodes

  • <taDeleteApplicantApplication>

Document structure

<eConnect>
    <HRDeleteApplicantApplicationType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantApplication />
    </HRDeleteApplicantApplicationType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantEducationLineType

Description

An eConnect transaction type that removes specified applicant education information.

XML nodes

  • <taDeleteApplicantEducationLine>

Document structure

<eConnect>
    <HRDeleteApplicantEducationLineType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantEducationLine />
    </HRDeleteApplicantEducationLineType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantEducationType

Description

An eConnect transaction type that removes education information for an applicant.

XML nodes

  • <taDeleteApplicantEducation>

Document structure

<eConnect>
    <HRDeleteApplicantEducationType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantEducation />
    </HRDeleteApplicantEducationType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantInterviewType

Description

An eConnect transaction type that removes interview information for an applicant.

XML nodes

  • <taDeleteApplicantInterview>

Document structure

<eConnect>
    <HRDeleteApplicantInterviewType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantInterview />
    </HRDeleteApplicantInterviewType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantReferenceLineType

Description

An eConnect transaction type that removes specified reference information for an applicant.

XML nodes

  • <taDeleteApplicantReferencesLine>

Document structure

<eConnect>
    <HRDeleteApplicantReferenceLineType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantReferencesLine />
    </HRDeleteApplicantReferenceLineType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantReferenceType

Description

An eConnect transaction type that removes reference information for an applicant.

XML nodes

  • <taDeleteApplicantReferences>

Document structure

<eConnect>
    <HRDeleteApplicantReferenceType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantReferences />
    </HRDeleteApplicantReferenceType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantRequisitionType

Description

An eConnect transaction type that removes requistion information for an applicant.

XML nodes

  • <taDeleteApplicantRequisitionsLine>

Document structure

<eConnect>
    <HRDeleteApplicantRequisitionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantRequisitionsLine />
    </HRDeleteApplicantRequisitionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantTestLineType

Description

An eConnect transaction type that removes specified test information for an applicant.

XML nodes

  • <taDeleteApplicantTestsLine>

Document structure

<eConnect>
    <HRDeleteApplicantTestLineType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantTestsLine />
    </HRDeleteApplicantTestLineType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantTestType

Description

An eConnect transaction type that removes test information for an applicant.

XML nodes

  • <taDeleteApplicantTests>

Document structure

<eConnect>
    <HRDeleteApplicantTestType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantTests />
    </HRDeleteApplicantTestType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantType

Description

An eConnect transaction type that removes applicant information.

XML nodes

  • <taDeleteApplicant>

Document structure

<eConnect>
    <HRDeleteApplicantType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicant />
    </HRDeleteApplicantType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantWorkHistoryLineType

Description

An eConnect transaction type that removes specified work history information for an applicant.

XML nodes

  • <taDeleteApplicantWorkHistoryLine>

Document structure

<eConnect>
    <HRDeleteApplicantWorkHistoryLineType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteAppplicantWorkHistoryLine />
    </HRDeleteApplicantWorkHistoryLineType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteApplicantWorkHistoryType

Description

An eConnect transaction type that removes work history information for an applicant.

XML nodes

  • <taDeleteApplicantWorkHistory>

Document structure

<eConnect>
    <HRDeleteApplicantWorkHistoryType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteApplicantWorkHistory />
    </HRDeleteApplicantWorkHistoryType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteRequistionType

Description

An eConnect transaction type that removes a requisition.

XML nodes

  • <taDeleteRequisition>

Document structure

<eConnect>
    <HRDeleteRequistionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteRequistion />
    </HRDeleteRequistionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteSkillSetLineType

Description

An eConnect transaction type that removes specified skill set information.

XML nodes

  • <taDeleteSkillSetsLine>

Document structure

<eConnect>
    <HRDeleteSkillSetLineType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteSkillSetsLine />
    </HRDeleteSkillSetLineType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteSkillSetType

Description

An eConnect transaction type that removes skill set information.

XML nodes

  • <taDeleteSkillSets>

Document structure

<eConnect>
    <HRDeleteSkillSetType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteSkillSets />
    </HRDeleteSkillSetType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteSkillType

Description

An eConnect transaction type that removes skill information.

XML nodes

  • <taDeleteSkills>

Document structure

<eConnect>
    <HRDeleteSkillType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteSkills />
    </HRDeleteSkillType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRDeleteTestType

Description

An eConnect transaction type that removes test information.

XML nodes

  • <taDeleteTests>

Document structure

<eConnect>
    <HRDeleteTestType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteTests />
    </HRDeleteTestType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRRequisitionType

Description

An eConnect transaction type that specifies requisition information.

XML nodes

  • <taCreateRequisitions>*

Document structure

<eConnect>
    <HRRequisitionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateRequisitions />
    </HRRequisitionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


HRSkillType

Description

An eConnect transaction type that specifies skill information.

XML nodes

  • <taCreateSkills>*

Document structure

<eConnect>
    <HRSkillType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateSkills />
    </HRSkillType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Inventory

The Inventory schemas are as follows:

  • IVCreateItemCurrencyType
  • IVCreateItemPriceListType
  • IVCreateIVItemClassType
  • IVCreatePlannerType
  • IVCreatePriceGroupType
  • IVCreatePriceLevelType
  • IVCreateSiteBinType
  • IVCreateUOFMScheduleType
  • IVInventoryItemSiteType
  • IVInventorySiteType
  • IVInventoryTransactionType
  • IVInventoryTransferType
  • IVItemMasterType
  • IVLotCategoryType
  • IVMultibinBinToBinTransferType
  • IVVendorItemType


IVCreateItemCurrencyType

Description

An eConnect transaction type that describes the currency associated with an inventory item.

XML nodes

  • <taUpdateCreateItemCurrencyRcd>*

Document structure

<eConnect>
    <IVCreateItemCurrencyType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemCurrencyRcd_Items>
            <taUpdateCreateItemCurrencyRcd />
        </taUpdateCreateItemCurrencyRcd_Items>
    </IVCreateItemCurrencyType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVCreateItemPriceListType

Description

An eConnect transaction type that describes the price list for an inventory item.

XML nodes

  • <taIVCreateItemPriceListLine>*
  • <taIVCreateItemPriceListHeader>*

Remarks

Pricing method does not change on updates

Document structure

<eConnect>
    <IVCreateItemPriceListType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taIVCreateItemPriceListLine_Items>
            <taIVCreateItemPriceListLine />
        </taIVCreateItemPriceListLine_Items>
        <taIVCreateItemPriceListHeader />
    </IVCreateItemPriceListType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVCreateIVItemClassType

Description

An eConnect transaction type that describes an item class.

XML nodes

  • <taCreateIVItemClass>

Document structure

<eConnect>
    <IVCreateIVItemClassType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateIVItemClass />
    </IVCreateIVItemClassType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVCreatePlannerType

Description

An eConnect transaction type that describes a planner.

XML nodes

  • <taCreatePlanner>

Document structure

<eConnect>
    <IVCreatePlannerType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreatePlanner />
    </IVCreatePlannerType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVCreatePriceGroupType

Description

An eConnect transaction type that describes an inventory price group.

XML nodes

  • <taIVCreatePriceGroup>

Document structure

<eConnect>
    <IVCreatePriceGroupType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taIVCreatePriceGroup />
    </IVCreatePriceGroupType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVCreatePriceLevelType

Description

An eConnect transaction type that describes an inventory price level.

XML nodes

  • <taIVCreatePriceLevel>

Document structure

<eConnect>
    <IVCreatePriceLevelType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taIVCreatePriceLevel />
    </IVCreatePriceLevelType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVCreateSiteBinType

Description

An eConnect transaction type that describe an inventory bin.

XML nodes

  • <taCreateSiteBin>

Document structure

<eConnect>
    <IVCreateSiteBinType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateSiteBin />
    </IVCreateSiteBinType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVCreateUOFMScheduleType

Description

An eConnect transaction type that describe a unit of measure.

XML nodes

  • <taIVCreateUOFMScheduleLine>
  • <taIVCreateUOFMScheduleHeader>

Document structure

<eConnect>
    <IVCreateUOFMScheduleType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taIVCreateUOFMScheduleLine_Items>
            <taIVCreateUOFMScheduleLine />
        </taIVCreateUOFMScheduleLine_Items>
        <taIVCreateUOFMScheduleHeader />
    </IVCreateUOFMScheduleType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVInventoryItemSiteType

Description

An eConnect transaction type that descibes the inventory site associated with an inventory item.

XML nodes

  • <taItemSite>*

Document structure

<eConnect>
    <IVInventoryItemSiteType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taItemSite_Items>
            <taItemSite />
        </taItemSite_Items>
    </IVInventoryItemSiteType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVInventorySiteType

Description

An eConnect transaction type that describes an inventory site.

XML nodes

  • <taCreateInventorySite>

Document structure

<eConnect>
    <IVInventorySiteType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateInventorySite />
    </IVInventorySiteType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVInventoryTransactionType

Description

An eConnect transaction type that describes an inventory transaction.

XML nodes

  • <taUpdateCreateItemRcd>*
  • <taIVTransactionSerialInsert>
  • <taIVTransactionLotInsert>
  • <taIVTransactionLineInsert>
  • <taAnalyticsDistribution>*
  • <taIVTransactionMultiBinInsert>
  • <taIVTransactionHeaderInsert>

Document structure

<eConnect>
    <IVInventoryTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemRcd />
        <taIVTransactionSerialInsert_Items>
            <taIVTransactionSerialInsert />
        </taIVTransactionSerialInsert_Items>
        <taIVTransactionLotInsert_Items>
            <taIVTransactionLotInsert />
        </taIVTransactionLotInsert_Items>
        <taIVTransactionLineInsert_Items>
            <taIVTransactionLineInsert />
        </taIVTransactionLineInsert_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taIVTransactionMultiBinInsert_Items>
            <taIVTransactionMultiBinInsert />
        </taIVTransactionMultiBinInsert_Items>
        <taIVTransactionHeaderInsert/>
    </IVInventoryTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVInventoryTransferType

Description

An eConnect transaction type that describes an inventory transfer.

XML nodes

  • <taUpdateCreateItemRcd>*
  • <taIVTransferSerialInsert>
  • <taIVTransferLotInsert>
  • <taIVTransferLineInsert>
  • <taAnalyticsDistribution>*
  • <taIVTransferMultiBinInsert>
  • <taIVTransferHeaderInsert>

Document structure

<eConnect>
    <IVInventoryTransferType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemRcd />
        <taIVTransferSerialInsert_Items>
            <taIVTransferSerialInsert />
        </taIVTransferSerialInsert_Items>
        <taIVTransferLotInsert_Items>
            <taIVTransferLotInsert />
        </taIVTransferLotInsert_Items>
        <taIVTransferLineInsert_Items>
            <taIVTransferLineInsert />
        </taIVTransferLineInsert_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taIVTransferMultiBinInsert_Items>
            <taIVTransferMultiBinInsert />
        </taIVTransferMultiBinInsert_Items>
        <taIVTransferHeaderInsert />
    </IVInventoryTransferType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVItemMasterType

Description

An eConnect transaction type that describes an inventory item.

XML nodes

  • <taUpdateCreateItemRcd>*
  • <taUpdateCreateItemCurrencyRcd>*
  • <taIVCreateItemPriceListLine>*
  • <taIVCreateItemPriceListHeader>*
  • <taItemSite>*
  • <taCreateItemVendors>*
  • <taCreateKitItemRcd>
  • <taCreateInternetAddresses>

Remarks

Create a new item record The <taUpdateCreateITemRcd> XML node allows you to create new item records from the IV Item Master schema. Complete the following steps to create a new item record:

  1. Populate the required fields.

The ITEMNMBR and ITEMDESC elements are required. The UOMSCHDL element is also required unless it is provided by the item class.

  2. Set UpdateIfExists.

The UpdateIfExists element can be set to one or zero to create a new item.

  3. Set UseItemClass.

Set the UseItemClass element to 0 to use only the element values specified by the <taUpdateCreateItemRcd> XML node. Elements not specified by the <taUpdateCreateItemRcd> XML node use the default values supplied by Microsoft Dynamics GP.

Set the UseItemClass element to 1 to use an item class as a source for default values. If UseItemClass is set to 1, you must specify the item class ID in the ITMCLSCD element. The item class provides default values for elements not specified by the <taUpdateCreateItemRcd> XML node. If the item class does not provide an element with at default value, the item record uses the default value supplied by Microsoft Dynamics GP.

Update an item record The <taUpdateCreateITemRcd> XML node allows you to update an existing item record from the IV Item Master schema. Complete the following steps to update an item record:

  1. Populate the required fields.

The ITEMNMBR element is required.

  2. Set UpdateIfExists.

The UpdateIfExists element must be set to one.

  3. Set UseItemClass.

Set the element UseItemClass to 0 to update only the elements specified by the <taUpdateCreateItemRcd> XML node. The XML node should include only the elements that have updated values. Elements that are excluded from the XML node or that supply a null value, retain their existing value.

Set the UseItemClass element to 1 to use default values provided by an item class. In an update, you may choose whether or not to supply a item class ID in the ITMCLSCD element.

If you specify an item class ID in the ITMCLSCD element, updates to elements use the following rules:

  • Elements set by the <taUpdateCreateItemRcd> XML node are always used. The specified value overrides any value supplied by the item class.
  • Elements excluded from the XML node or set to null use the values specified by the item class.
  • Elements excluded from the XML node or set to null and not included in the item class always retain their existing value.

If you do not specify an item class ID in the ITMCLSCD element, the <taUpdateCreateItemRcd> XML node updates only the elements specified by the XML node. Elements that are excluded from the XML node or that supply a null value, retain their existing value.

Document structure

<eConnect>
    <IVItemMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemRcd />
        <taUpdateCreateItemCurrencyRcd_Items>
            <taUpdateCreateItemCurrencyRcd />
        </taUpdateCreateItemCurrencyRcd_Items>
        <taIVCreateItemPriceListLine_Items>
            <taIVCreateItemPriceListLine />
        </taIVCreateItemPriceListLine_Items>
        <taIVCreateItemPriceListHeader />
        <taItemSite_Items>
            <taItemSite />
        </taItemSite_Items>
        <taCreateItemVendors_Items>
            <taCreateItemVendors />
        </taCreateItemVendors_Items>
        <taCreateKitItemRcd_Items>
            <taCreateKitItemRcd />
        </taCreateKitItemRcd_Items>
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
    </IVItemMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVLotCategoryType

Description

An eConnect transaction type that describes a inventory lot category.

XML nodes

  • <taCreateLotCategory>

Document structure

<eConnect>
    <IVLotCategoryType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateLotCategory />
    </IVLotCategoryType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVMultibinBinToBinTransferType

Description

An eConnect transaction type that describes an inventory transfer between bins.

XML nodes

  • <taIVMultibinBinToBinTransfer>

Remarks

To use the IV Multibin Bin To Bin schema, multibins must be enabled.

The IV Multibin Bin To Bin schema provides the same functionality as the Bin Quantity Transfer Entry window. The schema supports transfers at one site between bins with the same quantity type (QTYTYPE). For example, use the <taIVMultibinBinToBinTransfer> XML node to transfer from bin (BIN) “A” to bin (TOBIN) “B” at site (LOCNCODE) "North" where both bins have a QTYTYPE value of "1” (On hand). To transfer between sites or quantity types, the transfer entry window must be used.

Transfers of serial-numbered items must be performed one at a time. You must set the quantity (QUANTITY) element to 1. You must also set the unit of measure (UOFM) element to the base unit of measure. Take care that the reset quantity (ResetQty) element has not been set to 1. A ResetQty value of 1 causes the QUANTITY element to use the total quantity that is available.

If the create bin (CreateBin) element is 1, the bin specified by the TOBIN element will be created. The CreateBin setting does not apply to the bin specified by the BIN element. The BIN cannot be created because the quantity available would be zero.

Document structure

<eConnect>
    <IVMultibinBinToBinTransferType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taIVMultibinBinToBinTransfer />
    </IVMultibinBinToBinTransferType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


IVVendorItemType

Description

An eConnect transaction type that describes an item vendor.

XML nodes

  • <taCreateItemVendors>*

Document structure

<eConnect>
    <IVVendorItemType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateItemVendors_Items>
            <taCreateItemVendors />
        </taCreateItemVendors_Items>
    </IVVendorItemType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Lockbox

The Lockbox schemas are as follows:

  • LBCreateLockboxBankDetailsType
  • LBCreateLockboxType


LBCreateLockboxBankDetailsType

Description

An eConnect transaction type that describes the lockbox associated with a bank.

XML nodes

  • <taCreateLockboxBankDetails>

Document structure

<eConnect>
    <LBCreateLockboxBankDetailsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateLockboxBankDetails />
    </LBCreateLockboxBankDetailsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


LBCreateLockboxType

Description

An eConnect transaction type that describes a lockbox.

XML nodes

  • <taCreateLockbox>

Document structure

<eConnect>
    <LBCreateLockboxType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateLockbox />
    </LBCreateLockboxType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Payroll

The Payroll schemas are as follows:

  • UPRComputerTrxType
  • UPRCreateBenefitType
  • UPRCreateDeductionType
  • UPRCreateDepartmentType
  • UPRCreateEmployeeType
  • UPRCreateEmployeeAddressType
  • UPRCreateEmployeeBenefitType
  • UPRCreateEmployeeClassType
  • UPRCreateEmployeeDeductionType
  • UPRCreateEmployeeLocalTaxType
  • UPRCreateEmployeePayCodeType
  • UPRCreateEmployeeStateTaxType
  • UPRCreateEmployeeTaxType
  • UPRCreateLocalTaxType
  • UPRCreateLocationType
  • UPRCreatePayCodeType
  • UPRCreatePositionType
  • UPRCreateShiftCodeType
  • UPRCreateSupervisorType
  • UPRCreateWorkersCompensationType
  • UPRDeleteEmployeeAddressType
  • UPRDeleteEmployeePayCodeType
  • UPRDeleteEmployeeType
  • UPRManualTrxType


UPRComputerTrxType

Description

An eConnect transaction type that describes a payroll transaction.

XML nodes

  • <taCreatePayrollBatchHeaderInsert>*
  • <taCreateComputerCheckLineInsert>

Document structure

<eConnect>
    <UPRComputerTrxType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreatePayrollBatchHeaderInsert />
        <taCreateComputerCheckLineInsert_Items>
            <taCreateComputerCheckLineInsert />
        </taCreateComputerCheckLineInsert_Items>
    </UPRComputerTrxType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateBenefitType

Description

An eConnect transaction type that creates a payroll benefit.

XML nodes

  • <taCreateBenefit>*
  • <taCreateBenefitBasedOnPayDedCodes>

Document structure

<eConnect>
    <UPRCreateBenefitType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateBenefit />
        <taCreateBenefitBasedOnPayDedCodes_Items>
            <taCreateBenefitBasedOnPayDedCodes />
        </taCreateBenefitBasedOnPayDedCodes_Items>
    </UPRCreateBenefitType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateDeductionType

Description

An eConnect transaction type that creates a payroll deduction.

XML nodes

  • <taCreateDeduction>*
  • <taCreateDeductionBasedOnPayCodes>

Document structure

<eConnect>
    <UPRCreateDeductionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateDeduction />
        <taCreateDeductionBasedOnPayCodes_Items>
            <taCreateDeductionBasedOnPayCodes />
        </taCreateDeductionBasedOnPayCodes_Items>
    </UPRCreateDeductionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateDepartmentType

Description

An eConnect transaction type that creates a payroll department.

XML nodes

  • <taCreateDepartment>*

Document structure

<eConnect>
    <UPRCreateDepartmentType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateDepartment />
    </UPRCreateDepartmentType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeType

Description

An eConnect transaction type that creates an employee record.

XML nodes

  • <taCreateEmployee>*
  • <taCreateInternetAddresses>

Document structure

<eConnect>
    <UPRCreateEmployeeType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployee />
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
    </UPRCreateEmployeeType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeAddressType

Description

An eConnect transaction type that creates an employye address record.

XML nodes

  • <taCreateEmployeeAddress>*
  • <taCreateInternetAddresses>

Document structure

<eConnect>
    <UPRCreateEmployeeAddressType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeeAddress />
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
    </UPRCreateEmployeeAddressType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeBenefitType

Description

An eConnect transaction type that creates a payroll benefit for an employee.

XML nodes

  • <taCreateEmployeeBenefit>*
  • <taCreateEmployeeBenefitBasedOnPayDedCodes>

Document structure

<eConnect>
    <UPRCreateEmployeeBenefitType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeeBenefit />
        <taCreateEmployeeBenefitBasedOnPayDedCodes_Items>
            <taCreateEmployeeBenefitBasedOnPayDedCodes />
        </taCreateEmployeeBenefitBasedOnPayDedCodes_Items>
    </UPRCreateEmployeeBenefitType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeClassType

Description

An eConnect transaction type that creates an employee class.

XML nodes

  • <taCreateEmployeeClass>*

Document structure

<eConnect>
    <UPRCreateEmployeeClassType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeeClass />
    </UPRCreateEmployeeClassType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeDeductionType

Description

An eConnect transaction type that creates an employee deduction.

XML nodes

  • <taCreateEmployeeDeduction>*
  • <taCreateEmployeeDeductionBasedOnPayCodes>

Document structure

<eConnect>
    <UPRCreateEmployeeDeductionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeeDeduction />
        <taCreateEmployeeDeductionBasedOnPayCodes_Items>
            <taCreateEmployeeDeductionBasedOnPayCodes />
        </taCreateEmployeeDeductionBasedOnPayCodes_Items>
    </UPRCreateEmployeeDeductionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeLocalTaxType

Description

An eConnect transaction type that associates a local tax with an employee.

XML nodes

  • <taCreateEmployeeLocalTax>*

Document structure

<eConnect>
    <UPRCreateEmployeeLocalTaxType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeeLocalTax />
    </UPRCreateEmployeeLocalTaxType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeePayCodeType

Description

An eConnect transaction type that creates an employee pay code.

XML nodes

  • <taCreateEmployeePayCode>*

Document structure

<eConnect>
    <UPRCreateEmployeePayCodeType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeePayCode />
    </UPRCreateEmployeePayCodeType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeStateTaxType

Description

An eConnect transaction type that associates a state tax with an employee.

XML nodes

  • <taCreateEmployeeStateTax>*

Document structure

<eConnect>
    <UPRCreateEmployeeStateTaxType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeeStateTax />
    </UPRCreateEmployeeStateTaxType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateEmployeeTaxType

Description

An eConnect transaction type that creates an employee tax record.

XML nodes

  • <taCreateEmployeeTax>*

Document structure

<eConnect>
    <UPRCreateEmployeeTaxType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateEmployeeTax />
    </UPRCreateEmployeeTaxType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateLocalTaxType

Description

An eConnect transaction type that creates a local tax record.

XML nodes

  • <taCreateLocalTax>*
  • <taCreateLocalTaxDetail>

Document structure

<eConnect>
    <UPRCreateLocalTaxType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateLocalTax />
        <taCreateLocalTaxDetail_Items>
            <taCreateLocalTaxDetail>
        </taCreateLocalTaxDetail_Items>
    </UPRCreateLocalTaxType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateLocationType

Description

An eConnect transaction type that creates an payroll location record.

XML nodes

  • <taCreateLocation>*

Document structure

<eConnect>
    <UPRCreateLocationType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateLocation />
    </UPRCreateLocationType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreatePayCodeType

Description

An eConnect transaction type that creates a payroll pay code.

XML nodes

  • <taCreatePayCode>*

Document structure

<eConnect>
    <UPRCreatePayCodeType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreatePayCode />
    </UPRCreatePayCodeType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreatePositionType

Description

An eConnect transaction type that creates a payroll position.

XML nodes

  • <taCreatePosition>*

Document structure

<eConnect>
    <UPRCreatePositionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreatePosition />
    </UPRCreatePositionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateShiftCodeType

Description

An eConnect transaction type that creates a payroll shift code.

XML nodes

  • <taCreateShiftCode>*

Document structure

<eConnect>
    <UPRCreateShiftCodeType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateShiftCode />
    </UPRCreateShiftCodeType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateSupervisorType

Description

An eConnect transaction type that creates a supervisor record.

XML nodes

  • <taCreateSupervisor>*

Document structure

<eConnect>
    <UPRCreateSupervisorType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateSupervisor />
    </UPRCreateSupervisorType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRCreateWorkersCompensationType

Description

An eConnect transaction type that creates a worker compensation code.

XML nodes

  • <taCreateWorkersCompensationCode>*

Document structure

<eConnect>
    <UPRCreateWorkersCompensationType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateWorkersCompensationCode />
    </UPRCreateWorkersCompensationType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRDeleteEmployeeAddressType

Description

An eConnect transaction type that removes address information for an employee.

XML nodes

  • <taDeleteEmployeeAddress>

Document structure

<eConnect>
    <UPRDeleteEmployeeAddressType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteEmployeeAddress />
    </UPRDeleteEmployeeAddressType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRDeleteEmployeePayCodeType

Description

An eConnect transaction type that removes pay code information for an employee.

XML nodes

  • <taDeleteEmployeePayCode>

Document structure

<eConnect>
    <UPRDeleteEmployeePayCodeType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteEmployeePayCode />
    </UPRDeleteEmployeePayCodeType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRDeleteEmployeeType

Description

An eConnect transaction type that removes an employee record.

XML nodes

  • <taDeleteEmployee>

Document structure

<eConnect>
    <UPRDeleteEmployeeType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteEmployee />
    </UPRDeleteEmployeeType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


UPRManualTrxType

Description

An eConnect transaction type that describes a payroll transaction.

XML nodes

  • <taCreatePayrollBatchHeaderInsert>*
  • <taCreateManualCheckLineInsert>
  • <taCreateManualCheckHeaderInsert>

Document structure

<eConnect>
    <UPRManualTrxType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreatePayrollBatchHeaderInsert />
        <taCreateManualCheckLineInsert_Items>
            <taCreateManualCheckLineInsert />
        </taCreateManualCheckLineInsert_Items>
        <taCreateManualCheckHeaderInsert />
    </UPRManualTrxType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Project Accounting

The Project Accounting schemas are as follows:

  • PAAccountsSetupType
  • PAChangeOrderType
  • PAContractBillingCycleType
  • PAContractsType
  • PAEmployeeExpenseType
  • PAEquipmentLogTransactionType
  • PAMiscLogExpenseType
  • PAProjectAccessListType
  • PAProjectBillingCyclesType
  • PAProjectBudgetMasterType
  • PAProjectEquipmentListType
  • PAProjectFeesType
  • PAProjectsType
  • PATimeSheetsType


PAAccountsSetupType

Description

An eConnnect document that creates a project account.

XML nodes

  • <taPAAccountsSetup>

Document structure

<eConnect>
    <PAAccountsSetupType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAAccountsSetup_Items>
            <taPAAccountsSetup />
        </taPAAccountsSetup_Items>
    </PAAccountsSetupType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAChangeOrderType

Description

An eConnect transaction type that describes a change order.

XML nodes

  • <taPAChangeOrderEntryBudget>
  • <taPAChangeOrderEntryFeeSchedule>
  • <taPAChangeOrderEntryFeeDetail>
  • <taPAChangeOrderEntryFeeHeader>
  • <taPAChangeOrderEntryHdr>

Document structure

<eConnect>
    <PAChangeOrderType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAChangeOrderEntryBudget_Items>
            <taPAChangeOrderEntryBudget />
        </taPAChangeOrderEntryBudget_Items>
        <taPAChangeOrderEntryFeeSchedule_Items>
            <taPAChangeOrderEntryFeeSchedule />
        </taPAChangeOrderEntryFeeSchedule_Items>
        <taPAChangeOrderEntryFeeDetail_Items>
            <taPAChangeOrderEntryFeeDetail />
        </taPAChangeOrderEntryFeeDetail_Items>
        <taPAChangeOrderEntryFeeHeader_Items>
            <taPAChangeOrderEntryFeeHeader />
        </taPAChangeOrderEntryFeeHeader_Items>
        <taPAChangeOrderEntryHdr />
    </PAChangeOrderType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAContractBillingCycleType

Description

An eConnect transaction type that describes a billing cycle.

XML nodes

  • <taPAContractBillingCycle>

Document structure

<eConnect>
    <PAContractBillingCycleType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAContractBillingCycle_Items>
            <taPAContractBillingCycle />
        </taPAContractBillingCycle_Items>
    </PAContractBillingCycleType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAContractsType

Description

An eConnect transaction type that describes a contract.

XML nodes

  • <taPAContracts>
  • <taPAContractBillingCycle>
  • <taPAAccountsSetup>
  • <taPAProjects>
  • <taPAProjectBillingCycle>
  • <taPAProjectAccess>
  • <taPAProjectEquip>
  • <taPAProjectFeeSchedule>
  • <taPAProjectFee>
  • <taPAProjectBudgetMaster>

Document structure

<eConnect>
    <PAContractsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAContracts />
        <taPAContractBillingCycle_Items>
            <taPAContractBillingCycle />
        </taPAContractBillingCycle_Items>
        <taPAAccountsSetup_Items>
            <taPAAccountsSetup />
        </taPAAccountsSetup_Items>
        <taPAProjects_Items>
            <taPAProjects />
        </taPAProjects_Items>
        <taPAProjectBillingCycle_Items>
            <taPAProjectBillingCycle />
        </taPAProjectBillingCycle_Items>
        <taPAProjectAccess_Items>
            <taPAProjectAccess />
        </taPAProjectAccess_Items>
        <taPAProjectEquip_Items>
            <taPAProjectEquip />
        </taPAProjectEquip_Items>
        <taPAProjectFeeSchedule_Items>
            <taPAProjectFeeSchedule />
        </taPAProjectFeeSchedule_Items>
        <taPAProjectFee_Items>
            <taPAProjectFee />
        </taPAProjectFee_Items>
        <taPAProjectBudgetMaster_Items>
            <taPAProjectBudgetMaster />
        </taPAProjectBudgetMaster_Items>
    </PAContractsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAEmployeeExpenseType

Description

An eConnect transaction type that describes an employee expense.

XML nodes

  • <taUpdateCreateVendorRcd>*
  • <taCreateVendorAddress>*
  • <taPAEmpExpenseLineInsert>
  • <taPAEmpExpenseTaxInsert>
  • <taPAEmpExpenseHdrInsert>

Document structure

<eConnect>
    <PAEmployeeExpenseType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateVendorRcd />
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taPAEmpExpenseLineInsert_Items>
            <taPAEmpExpenseLineInsert />
        </taPAEmpExpenseLineInsert_Items>
        <taPAEmpExpenseTaxInsert_Items>
            <taPAEmpExpenseTaxInsert />
        </taPAEmpExpenseTaxInsert_Items>
        <taPAEmpExpenseHdrInsert />
    </PAEmployeeExpenseType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAEquipmentLogTransactionType

Description

An eConnect transaction type that describes an equipment log transaction.

XML nodes

  • <taPAEquipLogLineInsert>
  • <taPAEquipLogHdrInsert>

Document structure

<eConnect>
    <PAEquipmentLogTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAEquipLogLineInsert_Items>
            <taPAEquipLogLineInsert />
        </taPAEquipLogLineInsert_Items>
        <taPAEquipLogHdrInsert />
    </PAEquipmentLogTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAMiscLogExpenseType

Description

An eConnect transaction type that describes a miscellaneous log expense.

XML nodes

  • <taPAMiscLogLineInsert>
  • <taPAMiscLogHdrInsert>

Document structure

<eConnect>
    <PAMiscLogExpenseType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAMiscLogLineInsert_Items>
            <taPAMiscLogLineInsert />
        </taPAMiscLogLineInsert_Items>
        <taPAMiscLogHdrInsert />
    </PAMiscLogExpenseType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAProjectAccessListType

Description

An eConnect transaction type that describes an access list.

XML nodes

  • <taPAProjectAccess>

Document structure

<eConnect>
    <PAProjectAccessListType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAProjectAccess_Items>
            <taPAProjectAccess />
        </taPAProjectAccess_Items>
    </PAProjectAccessListType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAProjectBillingCyclesType

Description

An eConnect transaction type that describes a billing cycle.

XML nodes

  • <taPAProjectBillingCycle>

Document structure

<eConnect>
    <PAProjectBillingCyclesType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAProjectBillingCycle_Items>
            <taPAProjectBillingCycle />
        </taPAProjectBillingCycle_Items>
    </PAProjectBillingCyclesType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAProjectBudgetMasterType

Description

An eConnect transaction type that describes a project budget.

XML nodes

  • <taPAProjectBudgetMaster>

Document structure

<eConnect>
    <PAProjectBudgetMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAProjectBudgetMaster_Items>
            <taPAProjectBudgetMaster />
        </taPAProjectBudgetMaster_Items>
    </PAProjectBudgetMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAProjectEquipmentListType

Description

An eConnect transaction type that describes an equipment list.

XML nodes

  • <taPAProjectEquip>

Document structure

<eConnect>
    <PAProjectEquipmentListType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAProjectEquip_Items>
            <taPAProjectEquip />
        </taPAProjectEquip_Items>
    </PAProjectEquipmentListType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAProjectFeesType

Description

An eConnect transaction type that describes the fees for a project.

XML nodes

  • <taPAProjectFee>
  • <taPAProjectFeeSchedule>

Document structure

<eConnect>
    <PAProjectFeesType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAProjectFeeSchedule_Items>
            <taPAProjectFeeSchedule />
        </taPAProjectFeeSchedule_Items>
        <taPAProjectFee_Items>
            <taPAProjectFee />
        </taPAProjectFee_Items>
    <PAProjectFeesType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PAProjectsType

Description

An eConnect transaction type that describes a project.

XML nodes

  • <taPAProjects>
  • <taPAProjectBillingCycle>
  • <taPAAccountsSetup>
  • <taPAProjectAccess>
  • <taPAProjectEquip>
  • <taPAProjectFee>
  • <taPAProjectFeeSchedule>
  • <taPAProjectBudgetMaster>

Document structure

<eConnect>
    <PAProjectsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPAProjects_Items>
            <taPAProjects />
        </taPAProjects_Items>
        <taPAProjectBillingCycle_Items>
            <taPAProjectBillingCycle />
        </taPAProjectBillingCycle_Items>
        <taPAAccountsSetup_Items>
            <taPAAccountsSetup />
        </taPAAccountsSetup_Items>
        <taPAProjectAccess_Items>
            <taPAProjectAccess />
        </taPAProjectAccess_Items>
        <taPAProjectEquip_Items>
            <taPAProjectEquip />
        </taPAProjectEquip_Items>
        <taPAProjectFeeSchedule_Items>
            <taPAProjectFeeSchedule />
        </taPAProjectFeeSchedule_Items>
        <taPAProjectFee_Items>
            <taPAProjectFee />
        </taPAProjectFee_Items>
        <taPAProjectBudgetMaster_Items>
            <taPAProjectBudgetMaster />
        <t/aPAProjectBudgetMaster_Items>
    </PAProjectsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PATimeSheetsType

Description

An eConnect transaction type that describes a time sheet.

XML nodes

  • <taPATimeSheetLineInsert>
  • <taPATimeSheetHdrInsert>

Document structure

<eConnect>
    <PATimeSheetsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPATimeSheetLineInsert_Items>
            <taPATimeSheetLineInsert />
        </taPATimeSheetLineInsert_Items>
        <taPATimeSheetHdrInsert />
    </PATimeSheetsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Purchase Order Processing

The Purchase Order Processing schemas are as follows:

  • POPDocumentDeleteType
  • POPDocumentVoidType
  • POPEnterMatchInvoiceType
  • POPMapSitesType
  • POPReceivingsType
  • POPtoSOPLinkRemoveType
  • POPTransactionType


POPDocumentDeleteType

Description

An eConnect transaction type that removes a purchase order.

XML nodes

  • <taPopPoDelete>

Document structure

<eConnect>
    <POPDocumentDeleteType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPopPoDelete />
    </POPDocumentDeleteType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


POPDocumentVoidType

Description

An eConnect transaction type that voids a purchase order.

XML nodes

  • <taPopPoVoid>

Remarks

The status of the purchase order (PO) must be new, and an SOP to POP link cannot be present.

To have a POP void behave like a POP delete, complete the following:

  • Clear the Purchase Order checkbox from Maintain History in the Purchase Order Processing Setup window. Open Purchase Order Processing Setup by clicking Tools >> Setup >> Purchasing >> Purchasing Order Processing.
  • Clear the option to reprint Purchasing Voided Transactions. Open Tools >> Setup >> Posting >> Audit trail codes. In the Display dropdown menu choose Purchasing. If either box is marked, the PO will simply be voided.

Document structure

<eConnect>
    <POPDocumentVoidType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPopPoVoid />
    </POPDocumentVoidType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


POPEnterMatchInvoiceType

Description

An eConnect transaction type that describes a purchase order invoice.

XML nodes

  • <taUpdateCreateItemRcd>*
  • <taUpdateCreateVendorRcd>*
  • <taCreateVendorAddress>*
  • <taPopRcptLineTaxInsert>
  • <taPopDistribution>
  • <taAnalyticsDistribution>*
  • <taPopEnterMatchLotInsert>
  • <taPopEnterMatchSerialInsert>
  • <taPopEnterMatchInvLine>
  • <taPopEnterMatchInvToShpMultiLine>
  • <taPopEnterMatchInvHdr>
  • <taMdaUpdate>

Remarks

You can only use the taPopEnterMatchSerialInsert and taPopEnterMatchLotInsert nodes when the purchase order is a drop-ship or drop-ship blanket type for the associated taPopEnterMatchInvLine node.

Header taxes The calculation that eConnect uses to validate the header tax amount differ between a purchase invoice and a purchase order. To complete your transaction, you must supply the header TAXAMNT value required by a purchase invoice document.

When eConnect validates the amount of the <taPopEnterMatchInvHdr> TAXAMNT element, it totals the value from each of the purchase invoice's line tax amounts. The validation calculation does not include freight or miscellaneous tax amounts. If the header TAXAMNT value is not equal to the line tax amounts, eConnect returns a validation error.

The following example uses a simplified version of a POPEnterMatchInvoiceType schema object to illustrate the related elements:

Header.TAXAMNT= 25 (Line.TAXAMNT of 25)
Header.FRTAMNT= 30
Header.MISCAMNT= 23
Header.UsingHeaderLevelTaxes = 0

Line.TAXAMNT= 25

LineTaxInsert.TAXAMNT= 25
LineTaxInsert.FRTTXAMT= 30
LineTaxInsert.MSCTXAMT= 23

AutoInvoice The AutoInvoice element of the <taPopEnterMatchInvLine> XML node allows you to automatically invoice against a purchase order. AutoInvoice is a boolean element with a value of either 0 or 1. If AutoInvoice is set to 1, the AUTOCOST element of the <taPopEnterMatchInvLine> XML node must also be set to 1. Setting AUTOCOST to 0 is not valid. The AUTOCOST element allows you to base cost on the purchase order.

The AutoInvoice settings applies to a specific purchase order and not the vendor. If you set AutoInvoice to 1, eConnect automatically invoices shipments that are received against the purchase order number that is specified for the transaction.

MultiLine You use the <taPopEnterMatchInvToShpMultiLine> XML node when you need to manually enter/match a transaction that has one item that spans multiple shipments. The <taPopEnterMatchInvToShpMultiLine> XML node allows the line to be passed to the <taPopEnterMatchInvLine> node with the first shipment to match against. Use the <taPopEnterMatchInvToShpMultiLine> XML node to allow other shipments to be added to the line that it matches. If you use multiple <taPopEnterMatchInvToShpMultiLine> XML nodes, the totals for the transaction must be immediately passed to the <taPopEnterMatchInvLine> XML node.

Document structure

<eConnect>
    <POPEnterMatchInvoiceType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemRcd />
        <taUpdateCreateVendorRcd />
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taPopRcptLineTaxInsert_Items>
            <taPopRcptLineTaxInsert />
        </taPopRcptLineTaxInsert_Items>
        <taPopDistribution_Items>
            <taPopDistribution />
        </taPopDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution>
        </taAnalyticsDistribution_Items>
        <taPopEnterMatchLotInsert_Items>
            <taPopEnterMatchLotInsert>
        </taPopEnterMatchLotInsert_Items>
        <taPopEnterMatchSerialInsert_Items>
            <taPopEnterMatchSerialInsert>
        </taPopEnterMatchSerialInsert_Items>
        <taPopEnterMatchInvLine_Items>
            <taPopEnterMatchInvLine />
        </taPopEnterMatchInvLine_Items>
        <taPopEnterMatchInvToShpMultiLine_Items>
            <taPopEnterMatchInvToShpMultiLine>
        </taPopEnterMatchInvToShpMultiLine_Items>
        <taPopEnterMatchInvHdr />
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </POPEnterMatchInvoiceType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


POPMapSitesType

Description

An eConnect transaction type that describes a site.

XML nodes

  • <taPOPMapSites>

Document structure

<eConnect>
    <POPMapSitesType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPOPMapSites />
    </POPMapSitesType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


POPReceivingsType

Description

An eConnect transaction type that describe a purchase order receipt.

XML nodes

  • <taUpdateCreateItemRcd>*
  • <taUpdateCreateVendorRcd>*
  • <taCreateVendorAddress>*
  • <taPopRcptLotInsert>
  • <taPopRcptSerialInsert>
  • <taPopRcptLineInsert>
  • <taPopRcptMultiBin>
  • <taPopRcptLineTaxInsert>
  • <taPopRcptUserDefined>
  • <taPopDistribution>
  • <taAnalyticsDistribution>*
  • <taPopRcptHdrInsert>
  • <taMdaUpdate>

Remarks

You no longer need to pass a sequence record of zero through the tax nodes. The tax nodes are now automatically updated. You only pass a sequence record of zero when you use header-level taxes.

The added lot number functionality allows you to create a purchase order for an item that uses a lot number and perform POP Receiving against it. The quantity for the item with the lot number is automatically updated. You can then access the SOP transaction schema and the lot number items, which are located in a sales order; they are automatically assigned to that item (at the front-end, users can either automatically assign or manually pick lots to pull the quantity from; this is not the case with eConnect). If the lot quantity available is less than the quantity that the user tried to pass in, an edit check occurs.

For POP back out taxes, users must manually pass in taxes with a tax amount, TAXAMNT, and a tax purchase amount, TAXPURCH. If the tax is included in the item price, the line should read TAXAMNT=0. The following demonstrate how the parameters should be set:

<taPopRcptLineTaxInsert>
TAXDTLID=POP;
TAXAMNT=13.83,;
TAXTYPE=0;
RCPTLNNM=16384;
TAXPURCH=152.10

<taPopRcptLineTaxInsert>
Purchase_Item_Tax_Schedu=POP SCH;
Purchase_Site_Tax_Schedu=POP SCH;
TAXAMNT=0;
UNITCOST=152.10;
EXTDCOST=152.10

<taPopRcptHdrInsert>
USINGHEADERLEVELTAXES=0;
TAXAMNT=0

Document structure

<eConnect>
    <POPReceivingsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemRcd />
        <taUpdateCreateVendorRcd />
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taPopRcptLotInsert_Items>
            <taPopRcptLotInsert />
        </taPopRcptLotInsert_Items>
        <taPopRcptSerialInsert_Items>
            <taPopRcptSerialInsert />
        </taPopRcptSerialInsert_Items>
        <taPopRcptLineInsert_Items>
            <taPopRcptLineInsert />
        </taPopRcptLineInsert_Items>
        <taPopRcptMultiBin_Items>
            <taPopRcptMultiBin />
        </taPopRcptMultiBin_Items>
        <taPopRcptLineTaxInsert_Items>
            <taPopRcptLineTaxInsert />
        </taPopRcptLineTaxInsert_Items>
        <taPopRcptUserDefined />
        <taPopDistribution_Items>
            <taPopDistribution />
        </taPopDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taPopRcptHdrInsert />
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </POPReceivingsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


POPtoSOPLinkRemoveType

Description

An eConnect transaction type that removes a POP to SOP link.

XML nodes

  • <taPopRemoveSopLink>

Document structure

<eConnect>
    <POPtoSOPLinkRemoveType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPopRemoveSopLink />
    </POPtoSOPLinkRemoveType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


POPTransactionType

Description

An eConnect transaction type that describes a purchase order.

XML nodes

  • <taUpdateCreateItemRcd>*
  • <taUpdateCreateVendorRcd>*
  • <taCreateVendorAddress>*
  • <taUpdateCreateCustomerRcd>*
  • <taCreateCustomerAddress>*
  • <taPopIvcTaxInsert>
  • <taPopDistribution>
  • <taAnalyticsDistribution>*
  • <taPoLine>*
  • <taPoHdr>*

Remarks

Header taxes The calculation that eConnect uses to validate the header tax amount differ between a purchase order and a purchase invoice. To complete your transaction, you must supply the header TAXAMNT value required by a purchase order document.

When eConnect validates the amount of the <taPoHdr> TAXAMNT element, it combines the values from each purchase order line's tax, with related freight tax and miscellaneous tax amounts. If the header TAXAMNT value does not equal this combined tax value, eConnect returns a validation error.

The following example uses a simplified version of a POPTransactionType schema object to illustrate the related elements:

Header.TAXAMNT= 45 (TAXAMNT of 10 + FRTTXAMT of 7 + MSCTXAMT of 28)
Header.FRTTXAMT= 7
Header.MSCTXAMT= 28
Header.UsingHeaderLevelTaxes = 0

Line.TAXAMNT= 10

TaxInsert.FRTTXAMT= 7
TaxInsert.MSCTXAMT= 28
TaxInsert.TAXAMNT= 10

Document structure

<eConnect>
    <POPTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemRcd />
        <taUpdateCreateVendorRcd />
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taUpdateCreateCustomerRcd />
        <taCreateCustomerAddress_Items>
            <taCreateCustomerAddress />
        </taCreateCustomerAddress_Items>
        <taPopIvcTaxInsert_Items>
            <taPopIvcTaxInsert />
        </taPopIvcTaxInsert_Items>
        <taPopDistribution_Items>
            <taPopDistribution />
        </taPopDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taPoLine_Items>
            <taPoLine />
        </taPoLine_Items>
        <taPoHdr />
    </POPTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Purchasing

The Purchasing schemas are as follows:

  • PMCreateBuyerType
  • PMDeleteVendorAddressType
  • PMManualCheckType
  • PMScheduledPaymentsType
  • PMTransactionType
  • PMVendorAddressType
  • PMVendorMasterType


PMCreateBuyerType

Description

An eConnect transaction type that creates a buyer.

XML nodes

  • <taCreateBuyer>

Document structure

<eConnect>
    <PMCreateBuyerType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateBuyer />
    </PMCreateBuyerType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PMDeleteVendorAddressType

Description

An eConnect transaction type that removes vendor address information.

XML nodes

  • <taDeleteVendorAddress>

Document structure

<eConnect>
    <PMDeleteVendorAddressType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteVendorAddress />
    </PMDeleteVendorAddressType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PMManualCheckType

Description

An eConnect transaction type that describes a payables transaction.

XML nodes

  • <taUpdateCreateVendorRcd>*
  • <taCreateVendorAddress>*
  • <taPMDistribution>
  • <taAnalyticsDistribution>*
  • <taPMManualCheck>
  • <taMdaUpdate>

Document structure

<eConnect>
    <PMManualCheckType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateVendorRcd />
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taPMDistribution_Items>
            <taPMDistribution />
        </taPMDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taPMManualCheck />
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </PMManualCheckType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PMScheduledPaymentsType

Description

An eConnect transaction type that describes a payment schedule.

XML nodes

  • <taPMSchedPmnts>

Document structure

<eConnect>
    <PMScheduledPaymentsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taPMSchedPmnts />
    </PMScheduledPaymentsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PMTransactionType

Description

An eConnect transaction type that describes a payment transaction.

XML nodes

  • <taUpdateCreateVendorRcd>*
  • <taCreateVendorAddress>*
  • <taPMTransactionTaxInsert>
  • <taPMDistribution>
  • <taAnalyticsDistribution>*
  • <taPMTransactionInsert>
  • <taMdaUpdate>

Remarks

The PM Transaction schema supports credit memos, returns, and multiple-currency functionality. The schema contains the <taPMTransactionInsert> XML node. The elements of the XML node include the following restrictions:

  • The <taPMTransactionInsert> XML node does not support updates to existing transactions.
  • The due date (DUEDATE) and discount date (DISCDATE) elements are automatically calculated using the payment terms from the specified payment terms ID (PYMTRMID). If you specify an invalid PYMTRMID, the DUEDATE element defaults to the value of the document date (DOCDATE) element and the value of the DISCDATE element defaults to 1900.
  • If you do not specify both the PYMTRMID and the discount amount available (DISAMTAV), the value of the discount available is calculated using the defaults for the vendor ID for the payment terms.
  • You set element value with the number that represents the amount of the percent discount (PRCTDISC). For example, you use 2 to represent a 2% discount. In the past, you had to supply a value that included the decimal value. For example, you had to use 200 to represent 2%.
  • If you specify both the DISAMTAV and the discount dollar amount (DSCDLRAM), DSCDLRAM is set to 0. DSCDLRAM retains its value only when the specified amount is equal to the value of the DISAMTAV element.
  • If you specify both the DISAMTAV and the PRCTDISC, PRCTDISC is set to 0. PRCTDISC retains is value only when the specified amount is equal to the value of the DISAMTAV element.
  • You cannot specify a value for both PRCTDISC and DSCDLRAM. If you specify a value for both elements the edit check returns an error. To resolve the error, set at least one of these elements to zero.

The following examples demonstrate how to coordinate values between the related elements:

Example 1—Uses PYMTRMID of “net 30” and sets PRCTDISC to 10 percent:

PYMTRMID = net 30
PRCTDISC = 10.00
DISAMTAV = Set to null or pass in the actual 10 percent value. The value specified by this element overrides the calculated discount amount.
DSCDLRAM = Zero or <blank> allowed; otherwise, an error will result

Example 2—Receives a discount available amount of $50.00:

PYMTRMID = Set to null or a valid payment term ID.
PRCTDISC* = Set to any value between 0.00 and 99.99
DISAMTAV = 50
DSCDLRAM = 0 or 50

*If the PRCTDISC value is the percentage that equals the $50 discount available, the percentage will be written to the coinciding table.

Document structure

<eConnect>
    <PMTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateVendorRcd />
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taPMTransactionTaxInsert_Items>
            <taPMTransactionTaxInsert />
        </taPMTransactionTaxInsert_Items>
        <taPMDistribution_Items>
            <taPMDistribution />
        </taPMDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taPMTransactionInsert />
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </PMTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PMVendorAddressType

Description

An eConnect transaction type that describes a vendor address.

XML nodes

  • <taCreateVendorAddress>*
  • <taCreateInternetAddresses>

Document structure

<eConnect>
    <PMVendorAddressType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
    </PMVendorAddressType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


PMVendorMasterType

Description

An eConnect docuement that describes a vendor.

XML nodes

  • <taUpdateCreateVendorRcd>*
  • <taCreateVendorAddress>*
  • <taCreateInternetAddresses>
  • <taUpdateCreatePAVendorRcd>*

Remarks

Create a New Vendor Record The <taUpdateCreateVendorRcd> XML node allows you to create a new vendor record from the PM Vendor Master schema. Complete the following steps to create a vendor record:

  1. Populate the required elements.

The vendor ID (VENDORID) and vendor name (VENDNAME) elements are required.

  2. Set the UpdateIfExists element.

To create a new vendor, set the UpdateIfExists element one or zero.

  3. Set UserVendorClass.

Set the UseVendorClass element to 0 to use only the element values specified by the <taUpdateCreateVendorRcd> XML node. Elements not specified by the <taUpdateCreateVendorRcd> XML node use the default value supplied by Microsoft Dynamics GP.

Set the UseVendorClass element to 1 to use a vendor class as a source for default values. If UseVendorClass is set to 1, you must specify the vendor class ID in the vendor class ID (VNDCLSID) element. The vendor class provides default values for elements not specified by the <taUpdateCreateVendorRcd> XML node. If the vendor class does not provide an element with a default value, the vendor record uses the default value supplied by Microsoft Dynamics GP.

Update a Vendor Record The <taUpdateCreateVendorRcd> XML node allow you to update an existing vendor record from the PM Vendor Master schema. Complete the following steps to update a vendor record:

  1. Populate the required fields.

The VENDORID element is required.

  2. Set UpdateIfExists.

The UpdateIfExists element must be set to one.

  3. Set UseVendorClass.

Set the UseVendorClass element to 0 to update only the elements specified by the <taUpdateCreateVendorRcd> XML node. The XML node should include only the elements that have updated values. Elements that are excluded from the XML node or that supply a null value, retain their existing value.

Set the UseVendorClass element to 1 to use default value provided by a vendor class. In an update, you may choose whether or not to supply a vendor class ID in the VNDCLSID element.

If you specify a vendor class ID in the VNDCLSID element, updates to elements use the following rules:

  • Element values set by the <taUpdateCreateVendorRcd> XML node are always used. The specified values override any values supplied by the vendor class.
  • Elements excluded from the XML node or set to null use the values specified by the vendor class.
  • Elements excluded form the XML node or set to null and not included in the vendor class always retain their existing value.

If you do not specify a vendor class ID in the VNDCLSID element, the <taUpdateCreateVendorRcd> XML node updates only the elements specified by the XML node. Elements that are excluded from the XML node or that supply a null value, retain their existing value.

Document structure

<eConnect>
    <PMVendorMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateVendorRcd />
        <taCreateVendorAddress_Items>
            <taCreateVendorAddress />
        </taCreateVendorAddress_Items>
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
        <taUpdateCreatePAVendorRcd />
    </PMVendorMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Receivables

The Receivables schemas are as follows:

  • RMApplyType
  • RMCashReceiptsType
  • RMCreateCustomerItemsType
  • RMCreateParentIDType
  • RMCustomerAddressType
  • RMCustomerClassType
  • RMCustomerMasterType
  • RMDeleteCustomerType
  • RMDeleteCustomerAddressType
  • RMDeleteSalespersonType
  • RMParentIDChildType
  • RMProspectMasterType
  • RMSalespersonMasterType
  • RMScheduledPaymentsType
  • RMTerritoryMasterType
  • RMTransactionType
  • RMUnapplyTransactionType
  • RMVoidTransactionType


RMApplyType

Description

An eConnect transaction type that applies credit memos, returns, and cash receipts to invoices.

XML nodes

  • <taAnalyticsDistribution>*
  • <taRMApply>

Document structure

<eConnect>
    <RMApplyType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taRMApply />
    </RMApplyType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMCashReceiptsType

Description

An eConnect transaction type that describes a cash receipt.

XML nodes

  • <taUpdateCreateCustomerRcd>*
  • <taCreateCustomerAddress>*
  • <taRMDistribution>
  • <taAnalyticsDistribution>*
  • <taRMCashReceiptInsert>

Remarks

You add additional nodes to this XML schema to create master records on the fly.

Document structure

<eConnect>
    <RMCashReceiptsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateCustomerRcd />
        <taCreateCustomerAddress_Items>
            <taCreateCustomerAddress />
        /<taCreateCustomerAddress_Items>
        <taRMDistribution_Items>
            <taRMDistribution />
        </taRMDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taRMCashReceiptInsert />
    </RMCashReceiptsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMCreateCustomerItemsType

Description

An eConnect transaction type that associates an item with a customer.

XML nodes

  • <taCreateCustomerItems>

Document structure

<eConnect>
    <RMCreateCustomerItemsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateCustomerItems_Items>
            <taCreateCustomerItems />
        </taCreateCustomerItems_Items>
    </RMCreateCustomerItemsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMCreateParentIDType

Description

An eConnect transaction type that creates the parent record for a national account.

XML nodes

  • <taCreateParentID>*
  • <taParentIDChild>

Document structure

<eConnect>
    <RMCreateParentIDType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateParentID />
        <taParentIDChild_Items>
            <taParentIDChild />
        </taParentIDChild_Items>
    </RMCreateParentIDType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMCustomerAddressType

Description

An eConnect transaction type that creates or updates a customer address record.

XML nodes

  • <taCreateCustomerAddress>*
  • <taCreateInternetAddresses>

Document structure

<eConnect>
    <RMCustomerAddressType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateCustomerAddress_Items>
            <taCreateCustomerAddress />
        </taCreateCustomerAddress_Items>
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
    </RMCustomerAddressType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMCustomerClassType

Description

An eConnect transaction type that describes a customer class.

XML nodes

  • <taCreateCustomerClass>

Document structure

<eConnect>
    <RMCustomerClassType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateCustomerClass />
    </RMCustomerClassType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMCustomerMasterType

Description

An eConnect transaction type that describes a customer.

XML nodes

  • <taUpdateCreateCustomerRcd>*
  • <taCreateCustomerAddress>*
  • <taCreateInternetAddresses>
  • <taCreateParentID>*
  • <taParentIDChild>

Remarks

The <taUpdateCreateCustomerRcd> XML node allows you to create or update customer records from the RM Customer Master schema. The primary address ID (ADRSCODE) element of the <taUpdateCreateCustomerRcd> XML node identifies the customer’s primary address. The following restrictions apply to the ADRSCODE element:

  • If you create a new customer record, the ADRSCODE element is required. A customer record with no ADRSCODE value cannot be used in a sales order processing (SOP) transaction.
  • If you perform an update to an existing customer record, the ADRSCODE element is optional. You do not need to supply a value for the ADRSCODE element.

Create a New Customer Record The <taUpdateCreateCustomerRcd> XML node allows you to create a new customer record from the RM Customer Master schema. Complete the following steps to create a new customer record:

  1. Populate the required elements.

The customer number (CUSTNMBR) element is required.

  2. Set the UpdateIfExists element.

To create a new customer, set the UpdateIfExists element to zero or one.

  3. Set UseCustomerClass.

Set the UseCustomerClass element to 0 to use only the element values specified by the <taUpdateCreateCustomerRcd> XML node. Elements not specified by the <taUpdateCreateCustomerRcd> XML node use the default value supplied by Microsoft Dynamics GP.

Set the UseCustomerClass element to 1 to use a customer class as a source for default values. If UseCustomerClass is set to 1, you must specify the customer class ID in the customer class ID (CUSTCLAS) element. The customer class provides default values for the elements not specified by the <taUpdateCreateCustomerRcd> XML node. If the customer class does not provide an element with a default value, the customer record uses the default value supplied by Microsoft Dynamics GP.

Update a Customer Record The <taUpdateCreateCustomerRcd> XML node allows you to update an existing customer record from the RM Customer Master schema. Complete the following steps to update a customer record:

  1. Populate the required elements.

The CUSTNMBR element is required.

  2. Set UpdateIfExists.

The UpdateIfExists element must be set to one.

  3. Set UseCustomerClass.

Set the UseCustomerClass element to 0 to update only the elements specified by the <taUpdateCreateCustomerRcd> XML node. The XML node should include only the elements that have updated values. Elements that are excluded form the XML node or that supply a null value, retain their existing value.

Set the UseCustomerClass element to 1 to use default values provided by a customer class. In an update, you may choose whether or not to supply a customer class ID in the CUSTCLAS element. If you specify a customer class ID in the CUSTCLAS element, updates to elements use the following rules:

  • Elements set by the <taUpdateCreateCustomerRcd> XML node are always used. The specified value overrides any values supplied by the customer class.
  • Elements excluded from the XML node or set to null use the values specified by the customer class.
  • Elements excluded from the XML node or set to null and not included in the customer class always retain their existing value.

If you do not specify a customer class in the CUSTCLAS element, the <taUpdateCreateCustomerRcd> XML node updates only the elements specified by the XML node. Elements that are excluded from the XML node or that supply a null value, retain their existing values.

Document structure

<eConnect>
    <RMCustomerMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateCustomerRcd />
        <taCreateCustomerAddress_Items>
            <taCreateCustomerAddress />
        </taCreateCustomerAddress_Items>
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
        <taCreateParentID />
        <taParentIDChild_Items>
            <taParentIDChild />
        </taParentIDChild_Items>
    </RMCustomerMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMDeleteCustomerType

Description

An eConnect transaction type that removes a customer record.

XML nodes

  • <taDeleteCustomerRcd>

Document structure

<eConnect>
    <RMDeleteCustomerType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteCustomerRcd />
    </RMDeleteCustomerType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMDeleteCustomerAddressType

Description

An eConnect transaction type that removes a customer address record.

XML nodes

  • <taDeleteCustomerAddress>

Document structure

<eConnect>
    <RMDeleteCustomerAddressType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteCustomerAddress />
    </RMDeleteCustomerAddressType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMDeleteSalespersonType

Description

An eConnect transaction type tht removes a salesperson record.

XML nodes

  • <taDeleteSalespersonRcd>

Document structure

<eConnect>
    <RMDeleteSalespersonType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taDeleteSalespersonRcd />
    </RMDeleteSalespersonType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMParentIDChildType

Description

An eConnect transaction type that describes a child member of a national account.

XML nodes

  • <taParentIDChild>

Document structure

<eConnect>
    <RMParentIDChildType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taParentIDChild_Items>
            <taParentIDChild />
        </taParentIDChild_Items>
    </RMParentIDChildType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMProspectMasterType

Description

An eConnect transaction type that describes a sales prospect.

XML nodes

  • <taCreateProspect>

Document structure

<eConnect>
    <RMProspectMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateProspect />
    </RMProspectMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMSalespersonMasterType

Description

An eConnect transaction type that creates or updates a salesperson record.

XML nodes

  • <taCreateSalesperson>*
  • <taCreateInternetAddresses>

Document structure

<eConnect>
    <RMSalespersonMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateSalesperson />
        <taCreateInternetAddresses_Items>
            <taCreateInternetAddresses />
        </taCreateInternetAddresses_Items>
    </RMSalespersonMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMScheduledPaymentsType

Description

An eConnect transaction type that describes a receivables payment schedule.

XML nodes

  • <taRMSchedPmnts>

Document structure

<eConnect>
    <RMScheduledPaymentsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taRMSchedPmnts />
    </RMScheduledPaymentsType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMTerritoryMasterType

Description

An eConnect transaction type that creates a sales territory record.

XML nodes

  • <taCreateTerritory>

Document structure

<eConnect>
    <RMTerritoryMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateTerritory />
    </RMTerritoryMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMTransactionType

Description

An eConnect transaction type that describes a receivables transaction.

XML nodes

  • <taUpdateCreateCustomerRcd>*
  • <taCreateCustomerAddress>*
  • <taRMCommissions>
  • <taRMTransactionTaxInsert>
  • <taRMDistribution>
  • <taAnalyticsDistribution>*
  • <taRMTransaction>
  • <taMdaUpdate>

Document structure

<eConnect>
    <RMTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateCustomerRcd />
        <taCreateCustomerAddress_Items>
            <taCreateCustomerAddress />
        </taCreateCustomerAddress_Items>
        <taRMCommissions_Items>
            <taRMCommissions>
        </taRMCommissions_Items>
        <taRMTransactionTaxInsert_Items>
            <taRMTransactionTaxInsert />
        </taRMTransactionTaxInsert_Items>
        <taRMDistribution_Items>
            <taRMDistribution />
        </taRMDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution>
        </taAnalyticsDistribution_Items>
        <taRMTransaction />
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </RMTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMUnapplyTransactionType

Description

An eConnect transaction type that reverses a receivables transaction.

XML nodes

  • <taAnalyticsDistribution>*
  • <taRMUnapplyTransaction>

Document structure

<eConnect>
    <RMUnapplyTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taRMUnapplyTransaction />
    </RMUnapplyTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


RMVoidTransactionType

Description

An eConnect transaction type that voids a receivables transaction.

XML nodes

  • <taRMVoidTransaction>

Document structure

<eConnect>
    <RMVoidTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taRMVoidTransaction />
    </RMVoidTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Sales Order Processing

The Sales Order Processing schemas are as follows:

  • SOPDeleteDocumentType
  • SOPDeleteLineType
  • SOPDistributionsType
  • SOPLineComponentType
  • SOPProcessHoldType
  • SOPProcessHoldMasterType
  • SOPSerialType
  • SOPtoPOPTransactionType
  • SOPTransactionType
  • SOPVoidDocumentType


SOPDeleteDocumentType

Description

An eConnect transaction type that removes a sales order.

XML nodes

  • <taAnalyticsDistribution>*
  • <taSopDeleteDocument>

Document structure

<eConnect>
    <SOPDeleteDocumentType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taSopDeleteDocument />
    </SOPDeleteDocumentType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPDeleteLineType

Description

An eConnect transaction type that removes a sales line item from a sales document.

XML nodes

  • <taSopLineDelete>

Remarks

To delete a sales order processing (SOP) line item, you must identify the SOP line item. Use <taSopLineDelete> XML node’s SOP type (SOPTYPE), invoice number (SOPNUMBE), and item number (ITEMNMBR) elements to uniquely identify the SOP line item. eConnect uses the values specified by these elements to find and delete the SOP line.

If the document contains multiple lines with the same ITEMNMBR element, the line sequence (LNITMSEQ) element is required. Use the LNITMSEQ to identify the specific SOP line item to delete. If the document does not contain duplicate ITEMNMBR elements, LNITMSEQ is an optional element.

Document structure

<eConnect>
    <SOPDeleteLineType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taSopLineDelete />
    </SOPDeleteLineType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPDistributionsType

Description

An eConnect transaction type that describes a sales order distribution.

XML nodes

  • <taSopDistribution>
  • <taAnalyticsDistribution>*

Document structure

<eConnect>
    <SOPDistributionsType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taSopDistribution_Items>
            <taSopDistribution />
        </taSopDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
    </SOPDistributionsType>
    </eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPLineComponentType

Description

An eConnect transaction type that creates or updates a component of a sales line record.

XML nodes

  • <taSopLineIvcInsertComponent>*

Remarks

If you use the <taSopLineIvcInsertComponent> XML node to manually update components, the updates does not automatically recalculate taxes.

Document structure

<eConnect>
    <SOPLineComponentType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taSopLineIvcInsertComponent_Items>
            <taSopLineIvcInsertComponent />
        </taSopLineIvcInsertComponent_Items>
    </SOPLineComponentType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPProcessHoldType

Description

An eConnect transaction type that create or updates a sale process hold.

XML nodes

  • <taSopUpdateCreateProcessHold>*

Document structure

<eConnect>
    <SOPProcessHoldType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taSopUpdateCreateProcessHold />
    </SOPProcessHoldType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPProcessHoldMasterType

Description

An eConnect transaction type that creates or updates a sales process hold.

XML nodes

  • <taCreateProcessHold>*

Document structure

<eConnect>
    <SOPProcessHoldMasterType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateProcessHold />
    </SOPProcessHoldMasterType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPSerialType

Description

An eConnect transaction type that creates or updates a serial sales order document.

XML nodes

  • <taSopSerial>*

Document structure

<eConnect>
    <SOPSerialType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taSopSerial_Items>
            <taSopSerial />
        </taSopSerial_Items>
    </SOPSerialType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPtoPOPTransactionType

Description

An eConnect transaction type that uses a sales order document to create a purchase order.

XML nodes

  • <taSopToPopLink>

Document structure

<eConnect>
    <SOPtoPOPTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taSopToPopLink />
    </SOPtoPOPTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPTransactionType

Description

An eConnect transaction type that decribes a sale order.

XML nodes

  • <taUpdateCreateItemRcd>*
  • <taUpdateCreateCustomerRcd>*
  • <taCreateCustomerAddress>*
  • <taSopSerial>*
  • <taSopLotAuto>*
  • <taSopLineIvcInsert>*
  • <taSopLineIvcInsertComponent>*
  • <taSopTrackingNum>
  • <taSopCommissions>
  • <taSopLineIvcTaxInsert>
  • <taCreateSopPaymentInsertRecord>
  • <taSopUserDefined>
  • <taSopDistribution>
  • <taAnalyticsDistribution>*
  • <taSopMultiBin>
  • <taSopHdrIvcInsert>*
  • <taSopToPopLink>
  • <taSopUpdateCreateProcessHold>*
  • <taCreateSOPTrackingInfo>
  • <taMdaUpdate>

Remarks

The SOP Transaction schema allows you to use commissions, distributions, header level or detailed taxes, markdown amounts, and items with lot numbers. The guidelines to complete these operations are as follows:

Commissions Use the <taSopHderIvcInsert> XML node to control how commissions are calculated. To let eConnect calculate commission amounts, set the autocreate commissions (CREATECOMM) element to 1. To manually calculate commission amounts, set CREATECOMM to 0 . If CREATECOMM is set to 0, you must use the <taSopCommissions> XML node to specify the commission amount

Manual updates to commissions are not supported. If you attempt to manually update commissions, an error will occur and the transaction will fail. A future release of eConnect will include this functionality.

Distributions Use the <taSopHdrIvcInsert> XML node to control whether distributions are created. To allow default distributions to be created, set the create distribution (CREATEDIST) element to 1. The CREATEDIST element defaults to a value of 1. To manually create distributions, set CREATEDIST to 0. If CREATEDIST is set to 0, use the <taSopDistribution> XML node to specify the distributions.

Manual updates to distributions are not supported. If you attempt to manually update distributions, an error will occur and the transaction will fail. A future release of eConnect will include this functionality.

Taxes Use the <taSopHdrIvcInsert> XML node to control how taxes are calculated. To use header level taxes, set the header level taxes (USINGHEADERLEVELTAXES) element to 1. To use detailed taxes, set USINGHEADERLEVELTAXES to 0. The default value for USINGHEADERLEVELTAXES is 0. If you set USINGHEADERLEVELTAXES to 1, be aware of the following:

  • Header level taxes only specify tax information when the line sequence element of the <taSopLineIvcTaxInsert> XML node is set to 0. To use header level taxes when the tax is set as “tax included in item price”, you must include a sequence number in the tax node. eConnect automatically creates the 0 sequence number tax layer. As a result, the tax amount is not passed to either the header or the line, and it does not reduce the document amount or the subtotal. You must manually calculate the tax amount and specify that along with the reduced sales amount in the <taSopLineIvcTaxInsert> XML node. To simplify using “tax included in item price” you should set the CREATETAXES element of the <taSopHdrIvcInsert> node to 1. This allows eConnect to autocreate taxes. The following display how to populate select elements when using header level taxes and a tax detail of “tax include in item price”:
<taSopLineIvcTaxInsert>
LNITMSEQ = 16384,/*Required-Line item sequence*/
TAXDTLID = 'TAX IN ITEM',/*Required-the example uses 10% tax
included in item price */
SALESAMT = 454.55,
STAXAMNT = 45.45

<taSopHdrIvcInsert
TAXAMNT  = 0,
SUBTOTAL = 500, /*Required*/
DOCAMNT  = 500, /*Required*/
USINGHEADERLEVELTAXES = 1,
CREATETAXES = 0
  • You can use header level taxes with invoices that will be posted without being transferred, or with orders that will be fully transferred to invoices and then posted. When an order is partially transferred to invoices or back orders, the tax is recalculated. There are no details with header level taxes so when taxes are recalculated on a partially transferred order, the tax information is lost and not carried forward.
  • If you do not use the miscellaneous tax (MSCTXAMNT) and freight taxes (FRTTXAMNT) elements in the <taSopLineIvcTaxInsert> XML node, you must set the sales tax amount (STAXAMNT) element with the actual sales tax amount. If MSCTXAMNT and FRTTXAMNT are used, STAXAMNT is not used.
  • If you use the <taSopLineIvcInsertComponent> XML node to manually update components, the update does not automatically recalculate taxes. To ensure the update recalculates taxes, include the <taSopHdrIvcInsert> node, and set the CREATETAXES element to 1.

Tax engine eConnect includes a tax engine that allows you to automatically create taxes. If you use the tax engine, you no longer need to specify tax information in the tax nodes. The <taSopHdrIvcInsert> XML node contains six elements that control the tax engine. To use the tax engine, be aware of the following:

  • To use the tax engine, set the create taxes flag (CREATETAXES) element to 1 . If you are integrating your own taxes, set CREATETAXES to 0.

Manual updates to taxes are not supported. If you attempt to manually update taxes, an error will occur and the transaction will fail. A future release of eConnect will include this functionality.

  • The freight tax schedule (FRTSCHID) and miscellaneous tax schedule (MSCSHID) elements mirror the tax schedule ID (TAXSCHID) element.
  • If the default tax schedule flag (DEFTAXSCHDS) element is set to 0, you must populate the TAXSCHID, FRTSCHID, and MSCSHID elements of the <taSopHdrIvcInsert> XML node. You must also set the item tax schedule ID (ITMTSHID) and the delivery method tax schedule ID (TAXSCHID) elements of the <taSopLineIvcInsert> XML node.
  • If the DEFTAXSCHDS element is set to 1, the tax schedule defined by setup will be the default. You must specify the shipping method (SHIPMTHD) element to provide the schedules used to create freight and miscellaneous tax for the SOP header. In addition, the ITMTSHID and TAXSCHID element of the <taSopLineIvcInsert> XML node must be excluded from the XML node or set to null. If you populate these two elements as blank (‘ ‘) it will blank out the schedules and no taxes will be created.
  • The freight taxable (FREIGTBLE) and miscellaneous amount taxable (MISCTBLE) elements in the <taSopHdrIvcInsert> XML node default to 0. Use these elements to indicate whether freight or miscellaneous charges are taxable. You set these elements to indicate whether these charges are taxable, nontaxable, or based on the customer’s tax schedules. These are the same options available in the Microsoft Dynamics GP client.
  • The inventory item taxable (IVITMTXB) element of the <taSopLineIvcInsert> node defaults to 0. You use this element to indicate whether the individual freight charge is taxable, nontaxable or based on the customer’s tax schedule. These are the same options available in the Microsoft Dynamics GP client.

You may still use the tax nodes to calculate taxes. However, you no longer need to pass a sequence record of zero through the tax nodes. You only need a sequence record of zero when header level taxes are used. If you specify the taxes, the CREATETAXES element must be set to 0.

Markdown amounts If you set the markdown percent (MRKDNPCT) of the <taSopLineIvcInsert> XML node, you must set the DEFPRICING element of the <taSopHdrIvcInsert> XML node to 1. This allows eConnect to calculate the DOCAMNT, SUBTOTAL, and mark down amount (MRKDNAMT) elements for the <taSopHdrIvcInsert> XML node.

When using the MRKDNAMT element of the <taSopLineIvcInsert> XML node, you should be aware that the SOP line and SOP header calculate the markdown amounts differently. The line markdown amount is per quantity. The header markdown amount is the total of the markdown amounts from each line item.

Lot numbers eConnect allows you to auto-fulfill lot numbers when the inventory item is tracked as a lot item. When you use the <taSopLotAuto> XML node, it must be called before the <taSopLineIvcInsert> XML node. Set the AUTOALLOCATELOT element of the <taSopLineIvcInsert> XML node with one of the following values:

AUTOALLOCATELOT | Description
0 | Auto: Fulfillment of lot numbers occurs automatically. This option uses the existing lot in IV00300. The <taSopLotAuto> XML node is not called.
1 | Manual: Fulfillment of lot numbers uses the lot numbers specified by the <taSopLotAuto> XML node.
2 | Mixed: Fulfillment of lot numbers uses the lot numbers specified by the <taSopLotAuto> XML node. Remaining quantities use the lots from IV00300.

The lot schema nodes also exist for purchase order receipts, inventory transactions, and inventory transfers.)

Pricing engine The eConnect pricing engine allows you to calculate standard or extended pricing using the default pricing (DEFPRICING), extended pricing (DEFEXTPRICE), and the include extended pricing promotion (IncludePromo) elements of the <taSopLineIvcInsert> XML node and the DEFPRICING element of the <taSopHdrIvcInsert> XML node.

  • Set the DEFPRICING element to 1 to automatically calculate the unit price (UNITPRICE) and extended price (XTNDPRCE). The pricing engine does not require the UNITPRICE and XTNDPRCE elements.
  • Set the DEFEXTPRICE element to 1 to calculate the XTNDPRCE value. You must also specify the UNITPRICE.
  • When using extended pricing, set the IncludePromo element to 1 to apply the promotion applicable to that line. These include Percentage Off, Value Off, or Quantity Free.
  • Set the DEFPRICING element in the header to calculate the SUBTOTAL element from the <taSopLineIvcInsert> XML nodes. The pricing engine does not require the SUBTOTAL element.

If you use Cost based pricing with a multicurrency transaction, you cannot use eConnect default pricing. Also, if you use Currency Amount pricing for a multicurrency transaction but have not set up a price for the specified currency, you cannot use the default pricing option. In both of these cases, you must pass in a price.

Business logic The taCreateSopPaymentInsertRecord allows you to use a credit card order and to credit the card at the time the order ships. This enables eConnect to better handle deposits and recognize revenue. For example, you can transfer a portion of the credit card payment when the invoice is created. The revenue for the payment will be recognized when the invoice is posted and the product ships.

The stored procedure that handles the header uses the header document ID (DOCID) element to determine what appears on the header of the order or invoice. The DOCID element passed to the header does not affect what happens on the line. The business logic that uses the DOCID element of the line nodes exists in the stored procedure that handles lines. If the DOCID element is not specified in the line node, the stored procedure uses a default value. The settings for the default DOCID value determines how item allocation and fulfillment occurs.

If you use more than one taSopLineIvcInsert node in a document, you must order the entries by item number. Use the values in the ITEMNMBR element to sequence the taSopLineIncInsert nodes in the document.

Updating SOP documents To update an existing SOP documents, you must comply with the following restrictions:

  • If you modify the header or line, you must resend the entire document. Elements that are excluded or left blank are updated to be empty. The result is that they look like they were removed from the document.
  • To update the quantity and reuse the lot number of a sales line that is a lot tracked item, you have to first delete the existing sales line. Use the taSopLineDelete node to delete the existing sales line.
  • To modify an existing SOP header, set the UpdateIfExists element to 1. You must include values for all elements of the SOP header document. Several elements use calculated values or cannot be modified from the header. These elements do not need to be included in the SOP header document:
DOCID
ORIGNUMB
ORIGTYPE
TAXAMNT
MRKDNAMT
CUSTNMBR
SUBTOTAL
DOCAMNT
USER2ENT
ADVPMNTS
FRTTXAMT
MSCTXAMT
ORDRDATE
MSTRNUMB
APLYWITH
WITHHAMT
SALEDATE
USINGHEADERLEVELTAXES
COMMAMNT
CURNCYID
  • eConnect validates the SOP header document during the update.
  • A SOP header update can recalculate taxes, commissions, and distributions by setting the appropriate elements to 1. You can also use multiple currency by setting rate changes and static string elements.
  • To modify an existing SOP line, set the UpdateIfExists element of the <taSopLineIvcInsert> XML node to 1. You must include all the SOP line elements in the update. This includes both the changed elements and the elements that are not being changed. You need to also consider the following:
  • If taxes or commissions do not need to be recreated, the SOP line can be passed by itself. Any related header information will be automatically recalculated.
  • If taxes or commissions need to be recalculated, include the SOP header and set the appropriate elements to 1.
  • To recalculate distributions form the SOP line, set the RecreateDist element to 1. The RecreateDist element is only used during updates and not for the initial creation of the line.
  • Multi currency is supported.
  • eConnect validates the new line using edit checks from the original line to ensure the new line is valid in situations where transfer have occurred.
  • To modify an existing SOP line component, set the UpdateIfExists element of the <taSopLineIncInsertComponent> XML node to 1. You must include all the SOP line component elements in the update. This includes both the changed elements and the elements that are not being changed. You need to also consider the following:
  • If taxes or commissions do not need to be recreated, the SOP line can be passed by itself. Any related header information will be automatically recalculated.
  • If taxes or commissions need to be recalculated, include the SOP header and set the appropriate elements to 1.
  • To recalculate distributions from the SOP line component, set the RecreateDist element to 1. The RecreateDist element is only used during updates and not for the initial creation of the component line.
  • You modify SOP payments and deposits to an existing transaction by supplying additional payment or deposit information in the <taCreateSopPaymentInsert> node. Populate the node in the manner as a new transaction. To modify an existing payment or deposit, set the Action element to 3. You should also consider the following:
  • When you modify an existing payment or deposit, the existing payment or deposit is removed and replaced with the new one you have supplied. This allows all modules to have reversing information so that the new information can be posted.
  • When adding or modifying payments or deposits, you must set the payment received (PYMTRCVD) element of the <taSopHdrIvcInsert> XML node with the total of all payments or deposits associated with the transaction being updated.

Quantity shortages To use the quantity shortage option (QtyShrtOpt) element of the <taSopLineIvcInsert> XML node, you must remember the following restrictions:

  • eConnect only uses the QtyShrtOpt setting when the quantity available (quantity on hand less quantity available) is less than the value specified in the quantity ( QUANTITY) element.
  • If you are using invoices (SOPTYPE=3) and the QtyShrtOpt is not set to 2, you must set the DEFPRICING element of the <taSopHdrInvInsert> node to 1. This allows the DOCAMNT and/or SUBTOTAL elements to be automatically recalculated and populated with the correct values. This DEFPRICING restriction does not apply to orders.

Document structure

<eConnect>
    <SOPTransactionType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateItemRcd />
        <taUpdateCreateCustomerRcd />
        <taCreateCustomerAddress_Items>
            <taCreateCustomerAddress />
        </taCreateCustomerAddress_Items>
        <taSopSerial_Items>
            <taSopSerial />
        </taSopSerial_Items>
        <taSopLotAuto_Items>
            <taSopLotAuto />
        </taSopLotAuto_Items>
        <taSopLineIvcInsert_Items>
            <taSopLineIvcInsert />
        </taSopLineIvcInsert_Items>
        <taSopLineIvcInsertComponent_Items>
            <taSopLineIvcInsertComponent />
        </taSopLineIvcInsertComponent_Items>
        <taSopTrackingNum_Items>
            <taSopTrackingNum />
        </taSopTrackingNum_Items>
        <taSopCommissions_Items>
            <taSopCommissions />
        </taSopCommissions_Items>
        <taSopLineIvcTaxInsert_Items>
            <taSopLineIvcTaxInsert />
        </taSopLineIvcTaxInsert_Items>
        <taCreateSopPaymentInsertRecord_Items>
            <taCreateSopPaymentInsertRecord />
        </taCreateSopPaymentInsertRecord_Items>
        <taSopUserDefined />
        <taSopDistribution_Items>
            <taSopDistribution />
        </taSopDistribution_Items>
        <taAnalyticsDistribution_Items>
            <taAnalyticsDistribution />
        </taAnalyticsDistribution_Items>
        <taSopMultiBin_Items>
            <taSopMultiBin />
        </taSopMultiBin_Items>
        <taSopHdrIvcInsert />
        <taSopToPopLink />
        <taSopUpdateCreateProcessHold />
        <taCreateSOPTrackingInfo />
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </SOPTransactionType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SOPVoidDocumentType

Description

An eConnect transaction type that voids a sale order.

XML nodes

  • <taSopVoidDocument>

Document structure

<eConnect>
    <SOPVoidDocumentType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taSopVoidDocument />
    </SOPVoidDocumentType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


Shared Master

The Shared Master schemas are as follows:

  • SMMdaType
  • SMTransactionBatchType


SMMdaType

Description

An eConnect transaction type that updates a MDA document.

XML nodes

  • <taMdaUpdate>

Remarks

eConnect initially creates MDA records without quantities. Use the <taMdaUpdate> XML node to set quantities.

Document structure

<eConnect>
    <SMMdaType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taMdaUpdate_Items>
            <taMdaUpdate />
        </taMdaUpdate_Items>
    </SMMdaType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


SMTransactionBatchType

Description

An eConnect doument that creates a batch.

XML nodes

  • <taCreateUpdateBatchHeaderRcd>

Document structure

<eConnect>
    <SMTransactionBatchType>
        <eConnectProcessInfo />
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler />
        </taRequesterTrxDisabler_Items>
        <taCreateUpdateBatchHeaderRcd />
    </SMTransactionBatchType>
</eConnect>

See also

  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>


XML Node Reference

This section of the documentation describes the XML nodes that populate an eConnect XML document with data. The documentation lists the XML elements of the node and provides information about how to populate each element with data.

An XML node with an asterisk (*) specifies that the XML node provides field levelupdate functionality. You can use field level updates to create an eConnect document where you specify only the elements that have new values. Any elements you do not include in the document retain their existing value. All unmarked nodes use document exchange for updates. For more information about how to update existing data, see Using eConnect to update existing data.

Analytical Accounting

  • <taAATrxDimCodeMaint>*
  • <taAnalyticsDistribution>*

Bank Reconciliation

  • <taBRBankDepositsHeader>
  • <taBRBankDepositsLine>
  • <taBRBankTransactionDist>
  • <taBRBankTransactionHeader>
  • <taBRBankTransactionVoid>
  • <taBRDeleteBankDeposits>
  • <taBRPostBankDeposits>

Company

  • <taCreateBank>
  • <taCreateCreditCard>
  • <taCreateInternetAddresses>
  • <taCreateShippingMethod>*
  • <taUpdateCreateCountryCode>*

eConnect

  • <eConnectOut>
  • <eConnectProcessInfo>
  • <taRequesterTrxDisabler>

Field Service

  • <taFSEquipmentMaster>*
  • <taFSEquipmentReading>*
  • <taFSRMALine>*
  • <taFSRMALineSerial>*
  • <taFSRMAMaster>*
  • <taFSRTVLine>*
  • <taFSRTVLineSerial>*
  • <taFSRTVMaster>*
  • <taFSServiceCallCodesEquipment>*
  • <taFSServiceCallLine>*
  • <taFSServiceCallLineSerial>*
  • <taFSServiceCallMaster>*
  • <taFSServiceCallMultiTech>*

Fixed Asset Management

  • <taCreateAccountGroup>
  • <taCreateAssetBook>
  • <taCreateAssetBookITC>
  • <taCreateAssetClassID>
  • <taCreateAssetID>*
  • <taCreateAssetInsurance>
  • <taCreateAssetLease>
  • <taCreateAssetPurchase>
  • <taCreateAssetUserData>*
  • <taCreateBookClass>
  • <taCreateBookID>
  • <taCreateInsuranceClassID>
  • <taCreateLeaseCompany>
  • <taCreateLocationID>
  • <taCreatePhysicalLocationID>
  • <taCreateRetirementCode>
  • <taCreateStructure>

General Ledger

  • <taCreateAccountCategory>
  • <taCreateAccountCurrencies>
  • <taCreateCheckbook>
  • <taCreateFixedAllocationAccountRcd>*
  • <taCreateVariableAllocationAccountRcd>*
  • <taGLTransactionHeaderInsert>
  • <taGLTransactionLineInsert>
  • <taUpdateCreateAccountRcd>*

Human Resources

  • <taApplicantInterviewUpdate>*
  • <taCreateApplicant>*
  • <taCreateApplicantEducation>*
  • <taCreateApplicantInterviewInsert>*
  • <taCreateApplicantReferences>*
  • <taCreateApplicantSkills>*
  • <taCreateApplicantTests>*
  • <taCreateApplicantWorkHistory>*
  • <taCreateRequisitions>*
  • <taCreateSkills>*
  • <taCreateSkillSets>*
  • <taCreateSkillSetsLine>*
  • <taCreateTests>
  • <taDeleteApplicant>
  • <taDeleteApplicantApplication>
  • <taDeleteApplicantEducation>
  • <taDeleteApplicantEducationLine>
  • <taDeleteApplicantInterview>
  • <taDeleteApplicantReferences>
  • <taDeleteApplicantReferencesLine>
  • <taDeleteApplicantRequisitionsLine>
  • <taDeleteApplicantTests>
  • <taDeleteApplicantTestsLine>
  • <taDeleteApplicantWorkHistory>
  • <taDeleteApplicantWorkHistoryLine>
  • <taDeleteEmployeePayCode>
  • <taDeleteRequisition>
  • <taDeleteSkills>
  • <taDeleteSkillSets>
  • <taDeleteSkillSetsLine>
  • <taDeleteTests>

Inventory

  • <taCreateInventorySite>
  • <taCreateItemVendors>*
  • <taCreateIVItemClass>
  • <taCreateKitItemRcd>
  • <taCreateLotCategory>
  • <taCreatePlanner>
  • <taCreateSiteBin>
  • <taItemSite>*
  • <taIVCreateItemPriceListHeader>*
  • <taIVCreateItemPriceListLine>*
  • <taIVCreatePriceGroup>
  • <taIVCreatePriceLevel>
  • <taIVCreateUOFMScheduleHeader>
  • <taIVCreateUOFMScheduleLine>
  • <taIVMultibinBinToBinTransfer>
  • <taIVTransactionHeaderInsert>
  • <taIVTransactionLineInsert>
  • <taIVTransactionLotInsert>
  • <taIVTransactionMultiBinInsert>
  • <taIVTransactionSerialInsert>
  • <taIVTransferHeaderInsert>
  • <taIVTransferLineInsert>
  • <taIVTransferLotInsert>
  • <taIVTransferMultiBinInsert>
  • <taIVTransferSerialInsert>
  • <taUpdateCreateItemCurrencyRcd>*
  • <taUpdateCreateItemRcd>*

Lockbox

  • <taCreateLockbox>
  • <taCreateLockboxBankDetails>

Payroll

  • <taCreateBenefit>*
  • <taCreateBenefitBasedOnPayDedCodes>
  • <taCreateComputerCheckLineInsert>
  • <taCreateDeduction>*
  • <taCreateDeductionBasedOnPayCodes>
  • <taCreateDepartment>*
  • <taCreateEmployee>*
  • <taCreateEmployeeAddress>*
  • <taCreateEmployeeBenefit>*
  • <taCreateEmployeeBenefitBasedOnPayDedCodes>
  • <taCreateEmployeeClass>*
  • <taCreateEmployeeDeduction>*
  • <taCreateEmployeeDeductionBasedOnPayCodes>
  • <taCreateEmployeeLocalTax>*
  • <taCreateEmployeePayCode>*
  • <taCreateEmployeeStateTax>*
  • <taCreateEmployeeTax>*
  • <taCreateLocalTax>*
  • <taCreateLocalTaxDetail>
  • <taCreateLocation>*
  • <taCreateManualCheckHeaderInsert>
  • <taCreateManualCheckLineInsert>
  • <taCreatePayCode>*
  • <taCreatePayrollBatchHeaderInsert>*
  • <taCreatePosition>*
  • <taCreateShiftCode>*
  • <taCreateSupervisor>*
  • <taCreateWorkersCompensationCode>*
  • <taDeleteEmployee>
  • <taDeleteEmployeeAddress>

Project Accounting

  • <taPAAccountsSetup>
  • <taPAChangeOrderEntryBudget>
  • <taPAChangeOrderEntryFeeDetail>
  • <taPAChangeOrderEntryFeeHeader>
  • <taPAChangeOrderEntryFeeSchedule>
  • <taPAChangeOrderEntryHdr>
  • <taPAContractBillingCycle>
  • <taPAContracts>
  • <taPAEmpExpenseHdrInsert>
  • <taPAEmpExpenseLineInsert>
  • <taPAEmpExpenseTaxInsert>
  • <taPAEquipLogHdrInsert>
  • <taPAEquipLogLineInsert>
  • <taPAMiscLogHdrInsert>
  • <taPAMiscLogLineInsert>
  • <taPAProjectAccess>
  • <taPAProjectBillingCycle>
  • <taPAProjectBudgetMaster>
  • <taPAProjectEquip>
  • <taPAProjectFee>
  • <taPAProjectFeeSchedule>
  • <taPAProjects>
  • <taPATimeSheetHdrInsert>
  • <taPATimeSheetLineInsert>

Purchase Order Processing

  • <taPopDistribution>
  • <taPopEnterMatchInvHdr>
  • <taPopEnterMatchInvLine>
  • <taPopEnterMatchInvToShpMultiLine>
  • <taPopEnterMatchLotInsert>
  • <taPopEnterMatchSerialInsert>
  • <taPopIvcTaxInsert>
  • <taPOPMapSites>
  • <taPopPoDelete>
  • <taPopPoVoid>
  • <taPopRcptHdrInsert>
  • <taPopRcptLineInsert>
  • <taPopRcptLineTaxInsert>
  • <taPopRcptLotInsert>
  • <taPopRcptMultiBin>
  • <taPopRcptSerialInsert>
  • <taPopRcptUserDefined>
  • <taPopRemoveSopLink>
  • <taPoHdr>*
  • <taPoLine>*

Purchasing

  • <taCreateBuyer>
  • <taCreateVendorAddress>*
  • <taDeleteVendorAddress>
  • <taParentIDChild>
  • <taPMDistribution>
  • <taPMManualCheck>
  • <taPMSchedPmnts>
  • <taPMTransactionInsert>
  • <taPMTransactionTaxInsert>
  • <taUpdateCreatePAVendorRcd>*
  • <taUpdateCreateVendorRcd>*

Receivables

  • <taCreateCustomerAddress>*
  • <taCreateCustomerClass>
  • <taCreateCustomerItems>
  • <taCreateParentID>*
  • <taCreateProspect>
  • <taCreateSalesperson>*
  • <taCreateTerritory>
  • <taDeleteCustomerAddress>
  • <taDeleteCustomerRcd>
  • <taDeleteSalespersonRcd>
  • <taRMApply>
  • <taRMCashReceiptInsert>
  • <taRMCommissions>
  • <taRMDistribution>
  • <taRMSchedPmnts>
  • <taRMTransaction>
  • <taRMTransactionTaxInsert>
  • <taRMUnapplyTransaction>
  • <taRMVoidTransaction>
  • <taUpdateCreateCustomerRcd>*

Sales Order Processing

  • <taCreateProcessHold>*
  • <taCreateSopPaymentInsertRecord>
  • <taCreateSOPTrackingInfo>
  • <taSopCommissions>
  • <taSopDeleteDocument>
  • <taSopDistribution>
  • <taSopHdrIvcInsert>*
  • <taSopLineDelete>
  • <taSopLineIvcInsert>*
  • <taSopLineIvcInsertComponent>*
  • <taSopLineIvcTaxInsert>
  • <taSopLotAuto>*
  • <taSopMultiBin>
  • <taSopSerial>*
  • <taSopToPopLink>
  • <taSopTrackingNum>
  • <taSopUpdateCreateProcessHold>*
  • <taSopUserDefined>
  • <taSopVoidDocument>

Shared Master

  • <taCreateUpdateBatchHeaderRcd>
  • <taMdaUpdate>


<eConnectOut>

Additional information

The <eConnectOut> XML node is an important part of the XML document you use to complete a Transaction Requester query. You use the elements of the <eConnectOut> XML node to specify the type of document, the records to select, and how to return the query result.

Element name | Data type | Length | Required | Default | Description
DOCTYPE | string | 50 | Y | Not applicable | Type of document.
OUTPUTTYPE | i4 | 4 | N | 0 | Specifies the format of the information 0=List 1=Master document 2=Complete document 3=Remove. Use when REMOVE is set to 1.
INDEX1TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX1.
INDEX2TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX2.
INDEX3TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX3.
INDEX4TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX4.
INDEX5TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX5.
INDEX6TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX6.
INDEX7TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX7.
INDEX8TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX8.
INDEX9TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX9.
INDEX10TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX10.
INDEX11TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX11.
INDEX12TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX12.
INDEX13TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX13.
INDEX14TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX14.
INDEX15TO | string | 75 | N | <blank> | Specifies the last select criteria value for INDEX15.
INDEX1FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX1.
INDEX2FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX2.
INDEX3FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX3.
INDEX4FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX4.
INDEX5FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX5.
INDEX6FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX6.
INDEX7FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX7.
INDEX8FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX8.
INDEX9FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX9.
INDEX10FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX10.
INDEX11FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX11.
INDEX12FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX12.
INDEX13FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX13.
INDEX14FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX14.
INDEX15FROM | string | 75 | N | <blank> | Specifies the first select criteria value for INDEX15.
FORLOAD | i4 | 4 | N | 0 | Specifies whether to save the query information in the eConnect_Out table. 0=Do not load query information in the eConnect_Out table. 1=Load query information in the eConnect_Out table
FORLIST | i4 | 4 | N | 0 | Specifies whether to return the query result to the caller. No query information is added to the eConnect_Out table. 0=Do not return the XML from the query result to the caller. 1=Return the XML from the query result to the caller. When FORLIST is set to 1, the values of FORLOAD, REMOVE, and ACTION are automatically reset to 0.
ACTION | i4 | 4 | N | 0 | Use ACTION to specify the type of data to return. You set this element when you request data using the eConnect_Out table. 0=All documents 1=Inserts 2=Updates 3=Deletes 4=Returns inserts and updates as separate documents. 5=Combines all inserts and updates into a single document.
ROWCOUNT | i4 | 4 | N | 0 | Specifies the number of rows to return. 0=All rows Any other number specifies the maximum number of documents to get.
REMOVE | i4 | 4 | N | 0 | Specifies whether to remove the query document from the eConnect_Out table. 0=Do not remove the query from the eConnect_Out table 1=Remove the query from the eConnect_out table.
DATE1 | datetime | 16 | N | <blank> | Specifies the date to use to remove documents from the eConnect_Out table. OUTPUTTYPE must be 3 and REMOVE must be 1. Records in the eConnect_Out table with date values prior to this date are deleted.
WhereClause | string | 1000 | N | <blank> | Specifies a custom "where clause" using the columns from the parent table of the requested document type.

To use the <eConnectOut> XML node with the Transaction Requester, you need to use the following elements:

  • You use DOCTYPE to specify the type of Transaction Requester document you are targeting. The DOCTYPE value must match one of the document types in the eConnect_Out_Setup table. Examples include Customer, Employee, and Sales_Transaction.
  • You use FORLOAD when you want your query to produce documents for the Outgoing Service. If you set FORLOAD to one, your query information is placed in the eConnect_Out table. The Outgoing Service uses your query information to create an eConnect XML document and place that document into a queue.
  • You use FORLIST when you want the Transaction Requester to return the query result directly. You typically use this with the GetEntity method of the eConnectMethods class to get an XML string that represents the query result.
  • You use the INDEXFROM and INDEXTO elements to specify the select criteria for your query. The number for each INDEXFROM and INDEXTO correpond to the INDEX columns for the specified document type in the eConnect_Out_Setup table. For example, INDEX1 for the Customer document type in the eConnect_Out_Setup table is CUSTNMBR. To use <eConnectOut> to retrieve cusomer information, you must use customer number values in INDEX1FROM and INDEX1TO.
  • To request a single record, place the same value in the INDEX1FROM and INDEX1TO field. To get several records, place the first value in the INDEXFROM element and the last element in the INDEXTO element. The Transaction Requester retrieves your first and last values and any records with an index value between them.

The following example shows how to use <eConnectOut> to retrieve a list of customers from the TWO database. Notice how INDEX1FROM specifies a customer number and INDEX1TO specifies a second customer number. The Transaction Requester returns XML that includes the two specified customers and any customers with a customer number between the two specified values.

<eConnectOut>
    <DOCTYPE>Customer</DOCTYPE>
    <OUTPUTTYPE>2</OUTPUTTYPE>
    <INDEX1TO>ALTONMAN0001</INDEX1TO>
    <INDEX1FROM>AARONFIT0001</INDEX1FROM>
    <FORLOAD>0</FORLOAD>
    <FORLIST>1</FORLIST>
    <ACTION>0</ACTION>
    <ROWCOUNT>0</ROWCOUNT>
    <REMOVE>0</REMOVE>
</eConnectOut>


<eConnectProcessInfo>

Additional information

The <eConnectProcessInfo> XML node overrides enables you to change settings for completing transactions. Each eConnect schema includes the <eConnectProcessInfo> XML node.

Element name | Data type | Description
ConnectionString | string | Override the default connection string.
ProcTimeOut | string | Specifies the number of seconds to use before a transaction time out cccurs. Use this field to override the default timeout value for transactions that are expected to take longer than 6 minutes to complete.

The <eConnectProcessInfo> node should always follow the transaction type node. The following XML document example uses the ConnectionString element of the <eConnectProcessInfo> node to make inventory changes in two different company databases. The first SMInventoryItemSiteType transaction type assigns item number 256 SDRAM to the location 0095 of the TWO company. The second SMInventoryItemSiteType assigns the item number 128 SDRAM to the 0095 location of the TEST company.

<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <SMInventoryItemSiteType>
        <eConnectProcessInfo>
            <ConnectionString>
                Integrated Security=SSPI;
                Persist Security Info=False;
                Initial Catalog=TWO;
                Data Source=machinename
            </ConnectionString>
        </eConnectProcessInfo>
        <taItemSite>
            <ITEMNMBR>256 SDRAM</ITEMNMBR>
            <LOCNCODE>0095<LOCNCODE>
        </taItemSite>
    </SMInventoryItemSiteType>
    <SMInventoryItemSiteType>
        <eConnectProcessInfo>
            <ConnectionString>
                Integrated Security=SSPI;
                Persist Security Info=False;
                Initial Catalog=TEST;
                Data Source=machinename
            </ConnectionString>
        </eConnectProcessInfo>
        <taItemSite>
            <ITEMNMBR>128 SDRAM</ITEMNMBR>
            <LOCNCODE>0095</LOCNCODE>
        </taItemSite>
    </SMInventoryItemSiteType>
</eConnect>


<taAATrxDimCodeMaint>*

Element name

Data type

Length

Required

Default

Description

aaTrxDim

string

30

Y

Not applicable

AA Transaction Dimension

The specified Transaction Dimension must already exist. Setup for the Transaction Dimension must enable adding codes. The checkbox 'Create New Codes On The Fly' on the Transaction Dimension Maintenance window enables

aaTrxDimCode

string

30

Y

Not applicable

AA Transaction Dimension Code

String reference to the desired transaction dimension code. It can exist to be updated or can be created on the fly

NOTETEXT

string

8000

N

<blank>

Create, update, or remove notes for the specified dimension code

INACTIVE

i4

2

N

0

0 = Active,

1 = inactive

New codes default to Active unless otherwise specified. Existing codes can be updated to either active or inactive based on the value (0 or 1) - If the Transaction Dimension / Transaction Dimension Code combination is setup as an owner of another it cannot be updated to inactive.

aaTrxDimCodeDescr

string

50

N

<blank>

Transaction Dimension Code Description. Required for new codes. Existing description 1 string can be changed, but cannot be left blank

aaTrxDimCodeDescr2

string

50

N

<blank>

Transaction Dimension Code Description 2. Optional for both new created codes and existing code updates

aaNode

string

50

N

<blank>

Required for new codes and can be changed using update logic. Node must exist and be already be linked to the Transaction Dimension. The Node and the Node Link cannot be created on the fly

aaOwnedBy

string

30

N

<blank>

Transaction Dimension Code Owner. Required for new codes that have a transaction dimension owned by another transaction dimension. This is available only if the transaction dimension selected is owned by another transaction dimension and both are of the alphanumeric type

aaUDFText1

string

31

N

<blank>

User-defined text1

aaUDFText2

string

31

N

<blank>

User-defined text2

aaUDFText3

string

31

N

<blank>

User-defined text3

aaUDFText4

string

31

N

<blank>

User-defined text4

aaUDFText5

string

31

N

<blank>

User-defined text5

aaUDFDate1

datetime

16

N

<blank>

User-defined date1

aaUDFDate2

datetime

16

N

<blank>

User-defined date2

aaUDFDate3

datetime

16

N

<blank>

User-defined date3

aaUDFDate4

datetime

16

N

<blank>

User-defined date4

aaUDFDate5

datetime

16

N

<blank>

User-defined date5

aaUDFNumeric1

number

12

N

<blank>

User-defined numeric1

aaUDFNumeric2

number

12

N

<blank>

User-defined numeric2

aaUDFNumeric3

number

12

N

<blank>

User-defined numeric3

aaUDFNumeric4

number

12

N

<blank>

User-defined numeric4

aaUDFNumeric5

number

12

N

<blank>

User-defined numeric5

aaUDFBoolean1

i4

2

N

<blank>

User-defined boolean1

aaUDFBoolean2

i4

2

N

<blank>

User-defined boolean2

aaUDFBoolean3

i4

2

N

<blank>

User-defined boolean3

aaUDFBoolean4

i4

2

N

<blank>

User-defined boolean4

aaUDFBoolean5

i4

2

N

<blank>

User-defined boolean5

UpdateIfExists

i4

2

N

1

Flag that specifies whether to update the data if it exists:

0 = Create only (returns an error if the transaction dimension code already exists);

1 = Update if exists (if the specified transaction dimension code does not exist, the code is not created and no error is returned);

2 = Create, do not update (does not returns an error if the transaction dimension code already exists)

RequesterTrx

i4

2

N

0

Requester transaction:

0 = False;

1 = True (if True, the Requester shadow table is populated)

(Not Used)

USRDEFND1

string

50

N

<blank>

User-defined field - developer use only

USRDEFND2

string

50

N

<blank>

User-defined field - developer use only

USRDEFND3

string

50

N

<blank>

User-defined field - developer use only

USRDEFND4

string

8000

N

<blank>

User-defined field - developer use only

USRDEFND5

string

8000

N

<blank>

User-defined field - developer use only

When an update is performed, elements that are not specifically included in the <taAATrxDimCodeMaint> node retain their existing values. To remove values from a specific element, complete an update that removes the existing value from that element. The following table displays the values to use to remove the data from an element of each data type.

Data type | Updated value
string | ‘’ (empty string)
datetime | ‘’ (empty date)
number | 0
boolean | 0


<taAnalyticsDistribution>*

Element name | Data type | Length | Required | Default | Description
DOCNMBR | string | 50 | Y | Not applicable | The document number. Specify the same number as the document that includes the analytical accounting distribution. Refer to the next table for additional information.
DOCTYPE | i4 | 2 | Y | 0 | The document type. The possible value of the document type is determined by the source of the document number. Refer to the next table to view the document types for each document.
AMOUNT | number | 21 | N | <blank> | When you need to change the assigned percentages, supply only the amount or percentage. No other elements should be included. You do not need to supply a dimension value.
aaAssignedPercent | number | 9 | N | <blank> | When you need to change the assigned percentages, supply only the amount or percentage. No other elements should be included. You do not need to supply a dimension value.
DistSequence | i4 | 2 | N | <blank> | The GL distribution sequence number. If you have duplicate accounts in a transaction, associate them using sequence number values.
ACTNUMST | string | 75 | N | <blank> | Account number
ACTINDX | i4 | 2 | N | <blank> | Account index
DistRef | string | 31 | N | <blank> | Distribution reference
NOTETEXT | string | 8000 | N | <blank> | Notes field
aaTrxDim | string | 31 | N | <blank> | Transaction dimension
aaTrxDimCode | string | 31 | N | <blank> | The transaction dimension alphanumeric code. If you update only the dimension code value, do not update the amount, assigned percentage, or other elements.
aaTrxDimCodeNum | number | 21 | N | <blank> | Transaction dimension numeric
aaTrxDimCodeBool | i4 | 2 | N | <blank> | Transaction dimension yes/no
aaTrxDimCodeDate | datetime | 16 | N | <blank> | Transaction dimension date
aaTrxDimID | i4 | 2 | N | <blank> | Transaction dimension ID
aaTrxCodeID | i4 | 2 | N | <blank> | Transaction dimension code ID
aaSubLedgerHdrID | i4 | 2 | N | <blank> | Subledger header lookup
aaSubLedgerDistID | i4 | 2 | N | <blank> | Subledger distribution lookup
aaSubLedgerAssignID | i4 | 2 | N | 1 | The subledger assign lookup ID. To add new distribution lines, use this element and increment its value by 1 for each assignment.
UpdateIfExists | i4 | 2 | N | 1 | Flag that specifies whether to update the data if it exists: 0 = Do not update; 1 = Update if record exists
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0 = False; 1 = True (if True, the Requester shadow table is populated)
USRDEFND1 | string | 50 | N | <blank> | User-defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field - developer use only

The document number and document type values vary, depending on the type of XML document that contains the analytical accounting distribution. For example, if the analytical accounting distribution is associated with a bank receipt document, the DOCNMBR value should be the same as the CMRECNUM value of the bank receipt document. With the DOCNMBR set to the value of the bank receipt document, set the DOCTYPE value of the analytical accounting distribution to 2.

The following table shows the document type values that can be used with a document number, based on the type of document number.

Document number (DOCNMBR) | Possible document type values (DOCTYPE)
General Ledger (JRNENTRY) | 0 = Transactions
Bank Transaction (CMRECNUM) | 3 = Credit 4 = Withdrawal 5 = Increase adjustment 6 = Decrease adjustment
Bank Receipt (CMRECNUM) | 2 = Check, cash, or credit card
RM Transaction (DOCNUMBR) | 1 = Sales invoice 3 = Debit memo 4 = Finance charge 5 = Service or repair 6 = Warranty 7 = Credit memo 8 = Return 9 = RM cash receipt
PM Transaction | 0 = Voucher 1 = Payment
SOP Transaction (SOPNUMBE) | 3 = Invoice 4 = Return
IV Transaction (IVDOCNBR) | 1 = Adjustment (increase or decrease) 2 = Variance 3 = Transfer
POP Transaction (PONUMBER) | 0 = Purchase order
POP Transaction (POPRCTNM) | 1 = Shipment 2 = Enter/Match 3 = Shipment/Invoice


<taApplicantInterviewUpdate>*

Element name | Data type | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | <blank> | Last Name
FFIRSTNAME_I | string | 15 | Y | <blank> | First Name
APPLYDATE_I | datetime | 16 | Y | Not applicable | Interview Date
APPINTTYPESTR_I | string | 21 | Y | Not applicable | Interview Type
CATEGORY_I | string | 31 | Y | Not applicable | Category
APPLICANTNUMBER_I | number | 21 | Y | 0 | Applicant Number - Required only if you have multiple applicants with the same name combination OR if you are going to pass the Applicant Number and not the LASTNAME and FIRSTNAME
COMPANYCODE_I | string | 5 | Y | Not applicable | Company ID
REVIEWSCORE_I | number | 21 | N | 0 | Score
POSITIONCODE_I | string | 7 | N | <blank> | Score
NOTE | string | 8000 | N | <blank> | Note
CHANGEBY_I | string | 15 | N | <blank> | Changed by
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow Interview data to be updated if it exists. 0=no, 1=yes
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction Optional - 0=false,1=true - if true than populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User Defined field - developer use only

* The <taApplicantInterviewUpdate> node uses field level updates to provide update functionality.


<taBRBankDepositsHeader>

Element name | Data type | Length | Required | Default | Description
Option | i4 | 2 | N | 1 | Deposit option: 1=Enter/Edit; 2=Void* *void functionality not available in this release
DEPTYPE | i4 | 2 | N | 1 | Deposit type: 1=Deposit with receipt; 2=Deposit without receipt; 3=Clear unused receipts* *clear functionality not available in this release
DEPDATE | datetime | 16 | N | <blank> | Deposit date
GLPOSTDT | datetime | 16 | N | <blank> | GL posting date
CHEKBKID | string | 15 | Y | Not applicable | Checkbook ID
depositnumber | string | 20 | Y | Not applicable | Deposit number
DSCRIPTN | string | 30 | N | <blank> | Description
DepAmt | number | 21 | N | 0 | Deposit amount; required for DEPTYPE=2
CheckTotal | number | 21 | N | 0 | Check total; used for DEPTYPE=2
CheckCount | i4 | 4 | N | 0 | Check count; used for DEPTYPE=2
CreditCardTotal | number | 21 | N | 0 | Credit card total; used for DEPTYPE=2
CreditCardCount | i4 | 4 | N | 0 | Credit card count; used for DEPTYPE=2
CurrencyAmount | i4 | 4 | N | 0 | Currency total; used for DEPTYPE=2
CurrencyCount | i4 | 4 | N | 0 | Currency count; used for DEPTYPE=2
CoinAmount | number | 21 | N | 0 | Coin total; used for DEPTYPE=2
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment; used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limit
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | MC exchange time=Time 1
MDFUSRID | string | 15 | N | <blank> | Modified user ID; defaults to 'eBusiness' if not passed in
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if true it populates the Requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taBRBankDepositsLine>

Element name | Data type | Length | Required | Default | Description
depositnumber | string | 20 | Y | Not applicable | Deposit number
RCPTNMBR | string | 20 | N | Default from setup | Receipt number; used to find receipt in CM20300 table
CHEKBKID | string | 15 | N | Default from setup | Checkbook ID; used to find receipt in CM20300 table
RcpType | i4 | 2 | N | Default from setup | Receipt type: 1=Check; 2=Cash; 3=Credit Card
CMRECNUM | number | 21 | N | Default from setup | Receipt number; use only if RCPTNMBR plus CHEKBKID plus RcpType are not unique
DEPDATE | datetime | 16 | N | <blank> | Deposit date; needs to match the taBRBankDepositsHeader if a multi currency transaction
BANKNAME | string | 30 | N | Default from setup | Bank name
BNKBRNCH | string | 20 | N | Default from setup | Bank branch
CURRENCYTOTAL | i4 | 4 | N | 0 | Originating currency total
COINTOTAL | number | 21 | N | 0 | Originating coin total
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment; used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limit
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | MC exchange time=Time 1
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if true it populates the Requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taBRBankTransactionDist>

Element name | Data type | Length | Required | Default | Description
Option | i4 | 2 | Y | Not applicable | Transaction option: 1=Enter transaction; 2=Enter receipt; 3=Void transaction; 4=Void Receipt
ACTNUMST | string | 75 | Y | Not applicable | Account number string; must include separator characters
DEBITAMT | number | 21 | N | 0 | Debit amount
CRDTAMNT | number | 21 | N | 0 | Credit amount
DistRef | string | 30 | N | <blank> | Distribution reference
RequesterTrx | i4 | 2 | N | 0 | Requester transaction element is not used by eConnect in this node at this time
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taBRBankTransactionHeader>

Element name | Data type | Length | Required | Default | Description
Option | i4 | 2 | Y | Not applicable | Transaction option: 1=Enter transaction; 2=Enter receipt
CMTrxType | i4 | 2 | N | 3 | Transaction type (only used when Option=1): 3=Check; 4=Withdrawal; 5=Increase adjustment; 6=Decrease adjustment
RcpType | i4 | 2 | N | 1 | Receipt type (only used when Option=2): 1=Check; 2=Cash; 3=Credit card
TRXDATE | datetime | 16 | N | <blank> | Transaction date; default is system date
CHEKBKID | string | 15 | Y | Not applicable | Checkbook ID
CURNCYID | string | 15 | N | <blank> | Currency ID; default is currency assigned to the checkbook
CMTrxNum | string | 20 | Y | Not applicable | Transaction number
CARDNAME | string | 15 | N | <blank> | Credit card name; required when RcpType=3
paidtorcvdfrom | string | 30 | N | <blank> | Paid to: when Option=1 or Rcvd from: when Option=2
DSCRIPTN | string | 30 | N | <blank> | Description
TRXAMNT | number | 21 | Y | Not applicable | Transaction amount
USERID | string | 15 | N | <blank> | User ID; default is eBusiness
GLPOSTDT | datetime | 16 | N | <blank> | GL posting date; default is TRXDATE
DistRef | string | 30 | N | <blank> | Distribution reference; only used for required default distribution
BACHNUMB | string | 15 | N | <blank> | GL batch number For additional information, see Bank Reconciliationi
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default is from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default is from setup | Days to increment; only used when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default is from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default is from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous days limit
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1; if not passed in, field used for finding XCHGRATE
RequesterTrx | i4 | 2 | N | 0 | Requester transaction element is not used by eConnect in this node at this time
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taBRBankTransactionVoid>

Element name | Data type | Length | Required | Default | Description
Option | i4 | 2 | Y | Not applicable | Transaction option: 3=Void transaction; 4=Void Receipt
VOIDDATE | datetime | 16 | N | <blank> | Void date; default is original transaction date
CHEKBKID | string | 15 | Y | Not applicable | Checkbook ID
CMTrxNum | string | 20 | Y | Not applicable | Transaction number
VOIDDESC | string | 30 | N | Default from setup | Void description; defaults from original transaction
USERID | string | 15 | N | <blank> | User ID; default is "eBusiness"
GLPOSTDT | datetime | 16 | N | <blank> | GL posting date; default is original GLPOSTDT
DistRef | string | 30 | N | Default from setup | Distribution reference; defaults from original transaction
CreateDist | i4 | 1 | N | 1 | Automatically pull in original distributions*: 0=False; 1=True Manual distributions can also be used. For additional information, see Bank Reconciliation
CMDNUMWK | number | 21 | N | 0 | Control Number; only needed if the combination of CMTrxNum and CHEKBKID are not unique
BACHNUMB | string | 15 | N | <blank> | GL batch number For additional information, see Bank Reconciliation
RequesterTrx | i4 | 2 | N | 0 | Requester transaction element is not used by eConnect in this node at this time
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taBRDeleteBankDeposits>

Element name | Data type | Length | Required | Default | Description
CHEKBKID | string | 15 | Y | Not applicable | Checkbook ID
depositnumber | string | 20 | Y | Not applicable | Deposit number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if true it populates the Requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taBRPostBankDeposits>

Element name | Data type | Length | Required | Default | Description
CHEKBKID | string | 15 | Y | Not applicable | Checkbook ID
depositnumber | string | 20 | Y | Not applicable | Deposit number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if true it populates the Requester shadow table)
PTDUSRID | string | 15 | N | <blank> | User ID for posting
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAccountCategory>

Element name | Data type | Length | Required | Default | Description
ACCATDSC | string | 50 | Y | Not applicable | Account category description
Requester_trx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAccountCurrencies>

Element name | Datatype | Length | Required | Default | Description
Account_Number | string | 75 | Y | Not applicable | Account number
CURNCYID | string | 15 | Y | Not applicable | Currency ID
REVALUE | i4 | 1 | N | 0 | Revalue: 0=False; 1=True
REVLUHOW | i4 | 2 | N | 0 | Revalue how: 0=Net change; 1=Period balance
Post_ Results _To | i4 | 2 | N | 0 | Post results to: 0=Account; 1=Financial offset
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAccountGroup>

Element name | Datatype | Length | Required | Default | Description
ACCTGRPID | string | 15 | Y | Not applicable | Account group ID
ACCTGRPDESC | string | 30 | N | <blank> | Account group description
DEPREXPACCT | string | 75 | N | <blank> | Depreciation expense account
DEPRRESACCT | string | 75 | N | <blank> | Depreciation reserve account
PRIORYRDEPRACCT | string | 75 | N | <blank> | Prior year depreciation account
ASSETCOSTACCT | string | 75 | N | <blank> | Asset cost account
PROCEEDSACCT | string | 75 | N | <blank> | Proceeds account
RECOGGAINLOSSACCT | string | 75 | N | <blank> | Recognized gain/loss account
NONRECOGGAINLOSSACCT | string | 75 | N | <blank> | Non-recognized gain/loss account
CLEARINGACCT | string | 75 | N | <blank> | Clearing account
LASTMNTDDATE | datetime | 16 | N | Default from setup | Create date
LASTMNTDUSERID | string | 15 | N | <blank> | User ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateApplicant>*

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLYDATE_I | datetime | 16 | Y | Not applicable | Application date
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant number - Optional/Required - Required if Updating a duplicate Last /First Name combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Line Sequence Number - Null = create or update if single line for the Applicant. Not Null = update
MIDLNAME | string | 15 | N | <blank> | Middle name
SSN_I | string | 15 | N | <blank> | Social security number
ADDRESS1 | string | 61 | N | <blank> | Address information
ADDRESS2 | string | 61 | N | <blank> | Address information
CITY | string | 35 | N | <blank> | Address city
STATE | string | 29 | N | <blank> | Address state
ZIPCODE_I | string | 11 | N | <blank> | Postal code
COUNTRY | string | 61 | N | <blank> | Country
HOMEPHONE | string | 21 | N | <blank> | Phone 1
WORKPHONE | string | 21 | N | <blank> | Phone 2
EXT_I | string | 5 | N | <blank> | Telephone extension
REQUISITIONNUMBER_I | i4 | 4 | N | 0 | Requisition number
COMPANYCODE_I | string | 5 | Y | Not applicable | Company ID
DIVISIONCODE_I | string | 7 | N | <blank> | Division
DEPARTMENTCODE_I | string | 7 | N | <blank> | Department
POSITIONCODE_I | string | 7 | N | <blank> | Position
LOCATNID | string | 15 | N | <blank> | Location
STATUS0_I | i4 | 2 | N | 0 | Status 0 = Blank, 1 = Active, 2 = Open, 3 = Rejected, 4 = Hired 5 = Other
REJECTREASON_I | i4 | 2 | N | <blank> | Reject Reason 1 = Testing, 2 = Interview, 3 = References, 4 = Experience, 5 = Education 6 = Other
DSCRIPTN | string | 31 | N | <blank> | Rejection comments
RELOCATION_I | i4 | 2 | N | <blank> | Relocation 0 = Yes 1 = No
REPLYLETTERSENT_I | i4 | 1 | N | <blank> | Reply Letter Sent 0 = False 1 = True
COLORCODE_I | i4 | 2 | N | <blank> | Color Code 1 = Blue, 2 = Green, 3 = Yellow, 4 = Red, 5 = N/A
REFSOURCEDDL_I | i4 | 2 | N | <blank> | Referral Source 0 = None, 1 = Word of Mouth, 2 = Referred by Employee, 3 = Referred by an Agency, 4 = Newspaper, 5 = Other, 6 = Internet
REFERENCESOURCE_I | string | 31 | N | <blank> | Referral Source Description
GENDERGB_I | i4 | 2 | N | <blank> | Gender 0 = Male, 1 = Female 2 = Unknown
EEOETHNICORIGIN_I | i4 | 2 | N | <blank> | Ethic Origin 1 = White, 2 = American Indian or Alaskan Native, 3 = Black or African American, 4 = Asian, 5 = Hispanic or Latino, 6 = Two or More Races, 7 = N/A 8 = Native Hawaiian or Pacific Islander
EEOAGE_I | i4 | 2 | N | <blank> | Age 1 = 18 to 25, 2 = 26 to 35, 3 = 36 to 45, 4 = 46 to 55, 5 = 56 +, 6 = Unknown 7 = 00 to 17
HANDICAPPED | i4 | 1 | N | <blank> | Handicapped 0 = False 1 = True
VETERAN | i4 | 1 | N | <blank> | Veteran 0 = False 1 = True
DISABLEDVETERAN | i4 | 1 | N | <blank> | Disabled Veterans 0 = False 1 = True
VIETNAMVETERAN | i4 | 1 | N | <blank> | Vietnam Veterans 0 = False 1 = True
OTHERVET | i4 | 1 | N | <blank> | Other Veterans 0 = False 1 = True
CHANGEBY_I | string | 15 | N | <blank> | Changed by
DATE1_I | datetime | 16 | N | <blank> | Date 1 For extra date fields
DATE2_I | datetime | 16 | N | <blank> | Date 2 For extra date fields
DATE3_I | datetime | 16 | N | <blank> | Date 3 For extra date fields
DATE4_I | datetime | 16 | N | <blank> | Date 4 For extra date fields
DATE5_I | datetime | 16 | N | <blank> | Date 5 For extra date fields
STRINGS_I_1 | string | 31 | N | <blank> | String 1 For extra fields
STRINGS_I_2 | string | 31 | N | <blank> | String 2 For extra fields
STRINGS_I_3 | string | 31 | N | <blank> | String 3 For extra fields
STRINGS_I_4 | string | 31 | N | <blank> | String 4 For extra fields
STRINGS_I_5 | string | 31 | N | <blank> | String 5 For extra fields
NUMERICEXTRA_1 | i4 | 4 | N | <blank> | Alpha/Numeric 1 For extra number fields
NUMERICEXTRA_2 | i4 | 4 | N | <blank> | Alpha/Numeric 2 For extra number fields
NUMERICEXTRA_3 | i4 | 4 | N | <blank> | Alpha/Numeric 3 For extra number fields
NUMERICEXTRA_4 | i4 | 4 | N | <blank> | Alpha/Numeric 4 For extra number fields
NUMERICEXTRA_5 | i4 | 4 | N | <blank> | Alpha/Numeric 5 For extra number fields
DOLLARS_I_1 | number | 21 | N | <blank> | Currency 1 For extra currency fields
DOLLARS_I_2 | number | 21 | N | <blank> | Currency 2 For extra currency fields
DOLLARS_I_3 | number | 21 | N | <blank> | Currency 3 For extra currency fields
DOLLARS_I_4 | number | 21 | N | <blank> | Currency 4 For extra currency fields
DOLLARS_I_5 | number | 21 | N | <blank> | Currency 5 For extra currency fields
CHECKBOXES_I_1 | i4 | 1 | N | <blank> | Checkboxes 1 For extra checkbox fields
CHECKBOXES_I_2 | i4 | 1 | N | <blank> | Checkboxes 2 For extra checkbox fields
CHECKBOXES_I_3 | i4 | 1 | N | <blank> | Checkboxes 3 For extra checkbox fields
CHECKBOXES_I_4 | i4 | 1 | N | <blank> | Checkboxes 4 For extra checkbox fields
CHECKBOXES_I_5 | i4 | 1 | N | <blank> | Checkboxes 5 For extra checkbox fields
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow Applicant data to be updated if it exists. 0=no, 1=yes
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true if true then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User Defined field - developer use only

* The <taCreateApplicant> node uses field level updates to provide update functionality.


<taCreateApplicantEducation>*

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant number Required if you have multiple applicants with the same name combination or if not passing First and Last Name
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Sequence number Required on an update if the applicant has more then one educational record.
UNIVERSITY | string | 31 | N | <blank> | School
DEGREE | string | 31 | N | <blank> | Degree
MAJOR | string | 31 | N | <blank> | Major
GPA | string | 5 | N | <blank> | Grade point average
GPABASE | string | 3 | N | <blank> | GPA base
GRADUATIONYEAR | string | 5 | N | <blank> | Graduation year
NOTE | string | 8000 | N | <blank> | Notes
CHANGEBY_I | string | 15 | N | <blank> | Changed by
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow Education data to be updated if it exists. 0=no, 1=yes
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true if true then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User Defined field - developer use only

* The <taCreateApplicantEducation> node uses field level updates to provide update functionality.


<taCreateApplicantInterviewInsert>*

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLYDATE_I | datetime | 16 | Y | Not applicable | Interview date
APPINTTYPESTR_I | string | 21 | Y | Not applicable | Interview type
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you want to pass the Applicant Number instead of the LASTNAME and FIRSTNAME
COMPANYCODE_I | string | 5 | Y | Not applicable | Company ID
POSITIONCODE_I | string | 7 | N | <blank> | Position
UpdateIfExists | i4 | 1 | N | 0 | Flag to allow Interview data to be updated if it exists. 0=no, 1=yes
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | NN | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 |  | <blank> | User Defined field - developer use only

* The default for the <taCreateApplicantInterviewInsert> node is to use document exchange to provide update functionality. You can use field level updates if you set UpdateIfExist to 1.


<taCreateApplicantReferences>*

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
REFERENCENAME_I | string | 61 | Y | Not applicable | Reference name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you want to pass Applicant Number and not pass LASTNAME and FIRSTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Sequence Number Required on an update if the applicant has more then one reference record
REFRELATIONSHIP_I | string | 15 | N | <blank> | Reference relationship
COMPANY_I | string | 65 | N | <blank> | Company
ADDRESS1 | string | 61 | N | <blank> | Address
CITY | string | 35 | N | <blank> | City
STATE | string | 29 | N | <blank> | State
ZIPCODE_I | string | 11 | N | <blank> | Postal code
WORKPHONE | string | 21 | N | <blank> | Phone
NOTE | string | 8000 | N | <blank> | Notes
CHANGEBY_I | string | 15 | N | <blank> | Changed by
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow Applicant References data to be updated if it exists 0=no, 1=yes
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User Defined field - developer use only

* The <taCreateApplicantReferences> node uses field level updates to provide update functionality.


<taCreateApplicantSkills>*

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
SKILL | stirng | 31 | Y | Not applicable | Skill
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you are going to pass Applicant Number and not LASTNAME FIRSTNAME
COMMENT20_I | string | 21 | N | <blank> | Comment
POINTS_I | i4 | 4 | N | <blank> | Proficiency 0 to 9999 are valid values
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow Applicant Test Skill data to be updated if it exists 0 = Delete Line, 1 = Insert 2 = Update
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User Defined field - developer use only

* The <taCreateApplicantSkills> node uses field level updates to provide update functionality.


<taCreateApplicantTests>*

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | strign | 15 | Y | Not applicable | First name
TESTCODE_I | string | 7 | Y | Not applicable | Test code
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you want to pass Applicant Number and not FIRSTNAME and LASTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Sequence Number Required on an update if the Applicant has more then one educational record
STRTDATE | datetime | 16 | N | <blank> | Start date
TESTSCORE_I | string | 21 | N | <blank> | Test score
NOTE | string | 8000 | N | <blank> | Notes
CHANGEBY_I | string | 15 | N | <blank> | Changed by
UpdateIfExists | i4 | 1 | N | 0 | Flag to allow Applicant Test data to be updated if it exists. 0=no, 1=yes
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User Defined field - developer use only

* The default for the <taCreateApplicantTests> node is to use document exchange to provide update functionality. You can use field level updates if you set UpdateIfExist to 1.


<taCreateApplicantWorkHistory>*

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
NAME | string | 31 | Y | Not applicable | Employer name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you are passing Applicant Number instead of FIRSTNAME LASTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Sequence Number Required on an update if the Applicant has more then one Work/History record
WAGE_I | number | 21 | N | <blank> | Wage
COMPENSATIONPERIOD_I | i4 | 2 | N | <blank> | Compensation Period 1=Hourly, 2=Weekly, 3=BiWeekly, 4=Semimonthly, 5=Monthly, 6=Quarterly, 7=Semiannually, 8=Annually 9=Daily/Miscellaneous
POSITION_I | string | 31 | N | <blank> | Position
STRTDATE | datetime | 16 | N | <blank> | Start date
ENDDATE | datetime | 16 | N | <blank> | End date
YEARSOFEXP_I | string | 3 | N | <blank> | Years of experience
NOTE | string | 8000 | N | <blank> | Notes
CHANGEBY_I | string | 15 | N | <blank> | Changed by
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow Education data to be updated if it exists. 0=no, 1=yes
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User Defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User Defined field - developer use only

* The <taCreateApplicantWorkHistory> node uses field level updates to provide update functionality.


<taCreateAssetBook>

Element name | Datatype | Length | Required | Default | Description
ASSETID | string | 15 | Y | Not applicable | Asset ID
ASSETIDSUF | i4 | 2 | N | 1 | Asset suffix ID
BOOKID | string | 15 | Y | Not applicable | Book ID
PLINSERVDATE | datetime | 16 | N | <blank> | Place In service date
DATEADDED | datetime | 16 | N | <blank> | Date added
DEPRTODATE | datetime | 16 | N | <blank> | Depreciate to date
COSTBASIS | number | 21 | N | <blank> | Cost basis
SALVAGEVALUE | number | 21 | N | <blank> | Salvage value
YTDDEPRAMT | number | 21 | Y | Not applicable | YTD depreciation
LTDDEPRAMT | number | 21 | Y | Not applicable | LTD depreciation
DEPRECIATIONMETHOD | i4 | 2 | N | <blank> | Depreciation method: 1=Straight-line orig. life; 2=Straight-line rem. life; 3=125%DB; 4=150% DB; 5=175% DB; 6=200% DB; 7=SOY digits; 8=Remaining life; 9=Amortization; 10=ACRS personal; 11=ACRS real; 12=ACRS real MSL; 13=ACRS LIH; 14=ACRS foreign real; 15=No depreciation; 16=Declining balance
AVERAGINGCONV | i4 | 2 | N | <blank> | Averaging convention: 1=Half-year; 2=Modified half-year; 3=Mid-month (1st); 4=Mid-month (15th); 5=Mid-quarter; 6=Next month; 7=Full month; 8=Next year; 9=Full year; 10=Full year all year; 11=None; 12=Next period; 13=Full period
SWITCHOVER | i4 | 2 | N | <blank> | Switch over: 1=No switch; 2=Straight-line
ORIGINALLIFEYEARS | i4 | 2 | N | <blank> | Original life years
ORIGINALLIFEDAYS | i4 | 2 | N | <blank> | Original life days
AMORTIZATIONCODE | i4 | 2 | N | <blank> | Amortization code: 0=None; 1=Daily; 2=Weekly; 3=Monthly; 4=Quarterly; 5=Yearly; 6=Percentage; 7=Rate
AMORTIZATIONAMOUNT | number | 21 | N | <blank> | Amortization amount/percentage
Initial_Allowance_Perc | number | 21 | N | <blank> | Initial allowance percentage
SPECDEPRALLOW | i4 | 2 | N | <blank> | Special depreciation allowance: 1=False; 2=True
SPECDEPRALLOWPCT | number | 21 | N | <blank> | Special depreciation allowance percentage
LUXAUTOIND | i4 | 2 | N | <blank> | Luxury auto: 1=False; 2=True
LUXVANTRUCK | i4 | 1 | N | <blank> | Luxury van or truck: 0=False; 1=True
LUXELAUTO | i4 | 1 | N | <blank> | Luxury electric auto: 0=False; 1=True
USERID | string | 15 | N | <blank> | ID of user who entered
UpdateIfExists | i4 | 1 | N | 0 | Flag to allow data to be updated if it exists: 0=No; 1=Yes Do not use 1. taCreateAssetBook does not currently support updates. Update functionality will be added in a future release.
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAssetBookITC>

Element name | Datatype | Length | Required | Default | Description
ASSETID | string | 15 | Y | Not applicable | Asset ID
ASSETIDSUF | i4 | 2 | N | 1 | Asset suffix ID
BOOKID | string | 15 | Y | Not applicable | Book ID
ORGCOSTBASIS | number | 21 | N | <blank> | Original cost basis
SECT179EXPDED | number | 21 | N | <blank> | Section 179 expense deduction
ITCCODEREDAMT | number | 21 | N | <blank> | ITC cost reduction amount
MISCCOSTADJ | number | 21 | N | <blank> | Miscellaneous cost adjustment
TEFRAFLAG | i4 | 2 | N | <blank> | TEFRA flag: 1=None; 2=Full credit reduce cost by 50% 3=Full credit reduce cost by 100% 4=Reduce ITC % by 2 points
ITCAMTTAKEN | number | 21 | N | <blank> | ITC amount taken
ITCAMTALLOWED | number | 21 | N | <blank> | ITC amount allowed
ITCRECAPTURE | number | 21 | N | <blank> | ITC recapture
USERWHOENTERED | string | 15 | N | <blank> | User who entered
UpdateIfExists | i4 | 1 | N | 0 | Flag to allow data to be updated if it exists: 0=No; 1=Yes Do not use 1. taCreateAssetBookITC does not currently support updates. Update functionality will be added in a future release.
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAssetClassID>

Element name | Datatype | Length | Required | Default | Description
ASSETCLASSID | string | 15 | Y | Not applicable | Asset class ID
ASSETCLASSIDDESCR | string | 30 | N | <blank> | Asset class description
ACCTGRPID | string | 15 | N | <blank> | Account group ID
INSCLASSID | string | 15 | N | <blank> | Insurance class ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAssetID>*

Element name | Datatype | Length | Required | Default | Description
ASSETID | string | 15 | Y | Not applicable | Asset ID
ASSETIDSUF | i4 | 2 | N | 1 | Asset suffix ID
SHRTNAME | string | 15 | N | Default from setup | Short name
ASSETDESC | string | 40 | Y | Not applicable | Asset description
EXTASSETDESC | string | 40 | N | Default from setup | Extended description
Master_Asset_ID | string | 19 | N | Default from setup | Master asset ID
STRUCTUREID | string | 30 | N | Default from setup | Structure ID
ASSETCLASSID | string | 15 | Y | Not applicable | Asset class ID
LOCATNID | string | 15 | N | Default from setup | Location ID
ACQDATE | datetime | 16 | Y | Not applicable | Acquisition date
Acquisition_Cost | number | 21 | N | Default from setup | Acquisition cost
ASSETTYPE | i4 | 2 | N | Default from setup | Asset type: 1=New; 2=Used; 3=Leased
ASSETSTATUS | i4 | 2 | N | Default from setup | Asset status: 1=Active; 2=Deleted; 3=Partial open; 4=Retired
PROPTYPE | i4 | 2 | N | Default from setup | Property type: 1=Personal; 2=Personal, listed; 3=Real; 4=Real, listed; 5=Real, conservation; 6=Real, energy; 7=Real, farms; 8=Real, low-income housing; 9=Amortization
ASSETQTY | i4 | 4 | N | Default from setup | Quantity
ASSETBEGQTY | i4 | 4 | N | Default from setup | Beginning quantity
ASSETCURRMAINT | number | 21 | N | Default from setup | Current year maintenance
ASSETYTDMAINT | number | 21 | N | Default from setup | YTD maintenance
ASSETLTDMAINT | number | 21 | N | Default from setup | LTD maintenance
LASTMAINTDATE | datetime | 16 | N | Default from setup | Last maintenance date
ASSESSEDVALUE | number | 21 | N | Default from setup | Assessed value
MFGRNAME | string | 25 | N | Default from setup | Manufacturers name
SERLNMBR | string | 20 | N | Default from setup | Serial number
MODELNUMBER | string | 20 | N | Default from setup | Model number
WARRENTYDATE | datetime | 16 | N | Default from setup | Warranty date
CUSTODIAN | string | 25 | N | Default from setup | Custodian
DATEADDED | datetime | 16 | N | Default from setup | Date added
DELETEDATE | datetime | 16 | N | Default from setup | Date deleted
Physical_Location_ID | string | 15 | N | Default from setup | Physical location ID
Asset_Label | string | 19 | N | Default from setup | Asset label
Verified_Date | datetime | 16 | N | Default from setup | Verified date
PIN | string | 15 | N | Default from setup | PIN
ACCTGRPID | string | 15 | N | Default from setup | Account group ID
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated, if it exists: 0=No; 1=Yes
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateAssetID> node uses field level updates to provide update functionality.


<taCreateAssetInsurance>

Element name | Data type | Length | Required | Default | Description
ASSETID | string | 15 | Y | Not applicable | Asset ID
ASSETIDSUF | i4 | 2 | N | 1 | Asset suffix ID
INSURANCECLASS | string | 15 | Y | Not applicable | Insurance class ID
INSURANCEYEAR | i4 | 2 | N | 0 | Insurance year
INSURANCEVALUE | number | 21 | N | 0 | Insurance value
REPLACEMENTCOST | number | 21 | N | 0 | Replacement cost
REPROCOST | number | 21 | N | 0 | Reproduction cost
DEPRREPROCOST | number | 21 | N | 0 | Depreciation reduction cost
EXCLUSIONAMT | number | 21 | N | 0 | Exclusion amount
EXCLUSIONTYPE | string | 15 | N | <blank> | Exclusion type
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAssetLease>

Element name | Data type | Length | Required | Default | Description
ASSETID | string | 15 | Y | Not applicable | Asset ID
ASSETIDSUF | i4 | 2 | N | 1 | Asset suffix ID
LEASECOMPID | string | 15 | N | <blank> | Lease company ID
LEASETYPE | i4 | 2 | N | 0 | Lease type: 1=Capital; 2=Operating
LEASECONTRACTID | string | 15 | N | <blank> | Contract ID
LEASEPAYMENT | number | 21 | N | 0 | Lease payment
LEASEINTRATE | number | 21 | N | 0 | Interest rate
LEASEENDDATE | datetime | 16 | N | <blank> | End date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateAssetPurchase>

Element name | Data type | Length | Required | Default | Description
ASSETID | string | 15 | Y | Not Applicable | Asset ID
ASSETIDSUF | i4 | 2 | Y | 1 | Asset suffix ID
PURCHLINESEQ | i4 | 4 | Y | <blank> | Purchase line sequence number Optional on Insert and Required on an Update
PURCHDESC | string | 40 | N | <blank> | Purchase description
Acquisition_Cost | number | 21 | N | <blank> | Acquisition cost
VENDORID | string | 15 | N | <blank> | Vendor ID
DOCNUMBR | string | 20 | N | <blank> | Document number
DOCDATE | datetime | 16 | Y | Not Applicable | Document date
TRXSORCE | string | 13 | N | <blank> | Transaction source
ORCTRNUM | string | 20 | N | <blank> | Voucher or receipt number
PORDNMBR | string | 20 | N | <blank> | Purchase order number
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | <blank> | Rate Expiration 0 = None 1=Daily 2=Weekly 3=Bi-Weekly 4=Semi-Monthly 5=Monthly 6=Quarterly 7=Annually 8=Miscellaneous 9=None
DYSTINCR | i4 | 2 | N | <blank> | Days to increment
RATEVARC | number | 21 | N | <blank> | Rate variance
TRXDTDEF | i4 | 2 | N | <blank> | Transaction date default 0=Exact Date 1=Next Date 2=Previous Date
RTCLCMTD | i4 | 2 | N | <blank> | Rate calculation method 0=Multiply 1=Divide
PRVDSLMT | i4 | 2 | N | <blank> | Previous days limits
DATELMTS | i4 | 2 | N | <blank> | Date limits 0=Unlimited 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
USERID | string | 15 | N | <blank> | User ID
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=No 1=Yes
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taCreateAssetUserData>*

Element name | Data type | Length | Required | Default | Description
ASSETID | string | 15 | Y | Not applicable | Asset ID
ASSETIDSUF | i4 | 2 | N | 1 | Asset suffix ID
USRFIELD1 | string | 6 | N | Default from setup | User-defined field 1
USRFIELD2 | string | 6 | N | Default from setup | User-defined field 2
USRFIELD3 | string | 10 | N | Default from setup | User-defined field 3
USRFIELD4 | string | 10 | N | Default from setup | User-defined field 4
USRFIELD5 | string | 20 | N | Default from setup | User-defined field 5
USRFIELD6 | string | 20 | N | Default from setup | User-defined field 6
USRFIELD7 | string | 20 | N | Default from setup | User-defined field 7
USRFIELD8 | string | 20 | N | Default from setup | User-defined field 8
USRFIELD9 | string | 40 | N | Default from setup | User-defined field 9
USRFIELD10 | string | 40 | N | Default from setup | User-defined field 10
USRFIELD11 | number | 21 | N | Default from setup | User-defined field 11
USRFIELD12 | number | 21 | N | Default from setup | User-defined field 12
USRFIELD13 | number | 21 | N | Default from setup | User-defined field 13
USRFIELD14 | number | 21 | N | Default from setup | User-defined field 14
USRFIELD15 | number | 21 | N | Default from setup | User-defined field 15
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateAssetUserData> node uses field level updates to provide update functionality.


<taCreateBank>

Element name | Data type | Length | Required | Default | Description
BANKID | string | 15 | Y | Not applicable | Bank ID
BANKNAME | string | 30 | Y | Not applicable | Bank name
ADDRESS1 | string | 60 | N | <blank> | Address 1
ADDRESS2 | string | 60 | N | <blank> | Address 2
ADDRESS3 | string | 60 | N | <blank> | Address 3
CITY | string | 35 | N | <blank> | City
STATE | string | 29 | N | <blank> | State
ZIPCODE | string | 10 | N | <blank> | Zip/postal Code
COUNTRY | string | 20 | N | <blank> | Country
PHNUMBR1 | string | 21 | N | <blank> | Phone number 1
PHNUMBR2 | string | 21 | N | <blank> | Phone number 2
PHONE3 | string | 21 | N | <blank> | Phone number 3
FAXNUMBR | string | 21 | N | <blank> | Fax number
TRNSTNBR | string | 9 | N | <blank> | Transit number
BNKBRNCH | string | 20 | N | <blank> | Bank branch
DDTRANUM | string | 9 | N | <blank> | DD transit number
Requester_trx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateBenefit>*

Element name | Data type | Length | Required | Default | Description
BENEFIT | string | 6 | Y | Not applicable | Benefit
DSCRIPTN | string | 30 | Y | Not applicable | Deduction description
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
BNFBEGDT | datetime | 16 | Y | Not applicable | Benefit begin date
BNFENDDT | datetime | 16 | N | <blank> | Benefit end date
VARBENFT | i4 | 1 | N | 0 | Variable benefit/transaction required: 0=False; 1=True
BNFTFREQ | i4 | 2 | N | 1 | Benefit frequency: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Quarterly; 6=Semiannually; 7=Annually; 8=Daily/miscellaneous
SBJTFDTX | i4 | 1 | N | 0 | Subject to federal tax: 0=False; 1=True
SBJTSSEC | i4 | 1 | N | 0 | Subject to FICA Social Security tax: 0=False; 1=True
SBJTMCAR | i4 | 1 | N | 0 | Subject to FICA Medicare tax: 0=False; 1=True
SBJTSTTX | i4 | 1 | N | 0 | Subject to state tax: 0=False; 1=True
SBJTLTAX | i4 | 1 | N | 0 | Subject to local tax: 0=False; 1=True
SBJTFUTA | i4 | 1 | N | 0 | Subject to FUTA tax: 0=False; 1=True
SBJTSUTA | i4 | 1 | N | 0 | Subject to SUTA tax: 0=False; 1=True
FFEDTXRT | number | 21 | N | 0 | Flat federal tax rate
FLSTTXRT | number | 21 | N | 0 | Flat state tax rate
BORCDTYP | i4 | 2 | N | 1 | Based on record type: 1=Paycodes; 2=Deductions
BSDORCDS | i4 | 2 | N | 0 | Based on records: 0=False; 1=True
BNFTMTHD | i4 | 2 | N | 1 | Benefit method: 1=% of gross; 2=% of net wages; 3=% of deduction; 4=Fixed amount; 5=Amount per unit
BNFFRMLA | i4 | 2 | N | 0 | Benefit formula
BNFPRCNT_1 | number | 21 | N | 0 | Benefit percent 1
BNFPRCNT_2 | number | 21 | N | 0 | Benefit percent 2
BNFPRCNT_3 | number | 21 | N | 0 | Benefit percent 3
BNFPRCNT_4 | number | 21 | N | 0 | Benefit percent 4
BNFPRCNT_5 | number | 21 | N | 0 | Benefit percent 5
BNFITAMT_1 | number | 21 | N | 0 | Benefit amount 1
BNFITAMT_2 | number | 21 | N | 0 | Benefit amount 2
BNFITAMT_3 | number | 21 | N | 0 | Benefit amount 3
BNFITAMT_4 | number | 21 | N | 0 | Benefit amount 4
BNFITAMT_5 | number | 21 | N | 0 | Benefit amount 5
BNFTRMAX_1 | number | 21 | N | 0 | Benefit tier maximum 1
BNFTRMAX_2 | number | 21 | N | 0 | Benefit tier maximum 2
BNFTRMAX_3 | number | 21 | N | 0 | Benefit tier maximum 3
BNFTRMAX_4 | number | 21 | N | 0 | Benefit tier maximum 4
BNFTRMAX_5 | number | 21 | N | 0 | Benefit tier maximum 5
BNTRMXUN_1 | number | 21 | N | 0 | Benefit tier maximum units 1
BNTRMXUN_2 | number | 21 | N | 0 | Benefit tier maximum units 2
BNTRMXUN_3 | number | 21 | N | 0 | Benefit tier maximum units 3
BNTRMXUN_4 | number | 21 | N | 0 | Benefit tier maximum units 4
BNTRMXUN_5 | number | 21 | N | 0 | Benefit tier maximum units 5
BNPAYPMX | number | 21 | N | 0 | Benefit pay period Maximum
BNFYRMAX | number | 21 | N | 0 | Benefit year maximum
Benefit_Fiscal_Max | number | 21 | N | 0 | Benefit Fiscal Year Maximum
BNFLFMAX | number | 21 | N | 0 | Benefit lifetime maximum
W2BXNMBR | i4 | 2 | N | 0 | W-2 box number
W2BXLABL | string | 6 | N | <blank> | W-2 box label
W2BXNMBR2 | i4 | 2 | N | 0 | W-2 Box Number 2
W2BXLABL2 | string | 6 | N | <blank> | W-2 Box Label 2
W2BXNMBR3 | i4 | 2 | N | 0 | W-2 Box Number 3
W2BXLABL3 | string | 6 | N | <blank> | W-2 Box Label 3
W2BXNMBR4 | i4 | 2 | N | 0 | W-2 Box Number 4
W2BXLABL4 | string | 6 | N | <blank> | W-2 Box Label 4
DATAENTDFLT | i4 | 1 | N | 0 | Data entry default: 0=False; 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateBenefit> node uses field level updates to provide update functionality.


<taCreateBenefitBasedOnPayDedCodes>

Element name | Data type | Length | Required | Default | Description
BENEFIT | string | 6 | Y | Not applicable | Benefit
BORCDTYP | i4 | 2 | Y | Not applicable | Based on record type: 1=Pay codes; 2=Deductions
BSDONCDE | string | 6 | Y | Not applicable | Deduction description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateBookClass>

Element name | Data type | Length | Required | Default | Description
BOOKID | string | 15 | Y | Not applicable | Book ID
ASSETCLASSID | string | 15 | Y | Not applicable | Asset class ID
DEPRECIATIONMETHOD | i4 | 2 | Y | Not applicable | Depreciation method: 1=Straight-line original life; 2=Straight-line remaining life; 3=125% DB; 4=150% DB; 5=175% DB; 6=200% DB; 7=SOY digits; 8=Remaining life; 9=Amortization; 10=ACRS personal; 11=ACRS real; 12=ACRS real MSL; 13=ACRS real LIH; 14=ACRS foreign real; 15=No depreciation; 16=Declining balance
AVERAGINGCONV | i4 | 2 | Y | Not applicable | Averaging convention: 1=Half-year; 2=Modified half-year; 3=Midmonth (first); 4=Midmonth (fifteenth); 5=Midquarter; 6=Next month; 7=Full month; 8=Next year; 9=Full year; 1 0=Full year all year; 11=None; 12=Next period; 13=Full period
AMORTIZATIONCODE | i4 | 2 | N | 0 | Amortization code: 1=Daily; 2=Weekly; 3=Monthly; 4=Quarterly; 5=Yearly; 6=Percentage; 7=Rate
AMORTIZATIONAMOUNT | number | 21 | N | 0 | Amortization amount/percentage
SWITCHOVER | i4 | 2 | N | 1 | Switch over: 1=No switch; 2=Straight line
ORIGINALLIFEYEARS | i4 | 2 | N | 0 | Original life years
ORIGINALLIFEDAYS | i4 | 2 | N | 0 | Original life days
Initial_Allowance_Perc | i4 | 2 | N | 0 | Initial allowance percentage
SPECDEPRALLOW | i4 | 2 | N | 1 | Special depreciation allowance: 1=No; 2=Yes
SPECDEPRALLOWPCT | i4 | 2 | N | 0 | Special depreciation allowance percentage
SALVAGEPCT | number | 21 | N | 0 | Salvage percentage
SALVAGEEST | i4 | 1 | N | 0 | Salvage estimate: 1=No; 2 =Yes
LUXAUTOIND | i4 | 2 | N | 1 | Luxury auto: 1=No; 2=Yes
TEFRAFLAG | i4 | 2 | N | 1 | TEFRA option: 1=None; 2=Full credit reduce cost by 50%; 3=Full credit reduce cost by 100%; 4=Reduce ITC% by 2 points
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateBookID>

Element name | Data type | Length | Required | Default | Description
BOOKID | string | 15 | Y | Not applicable | Book ID
BOOKDESC | string | 30 | N | <blank> | Book ID description
DEPRPERIOD | i4 | 2 | Y | Not applicable | Depreciation period: 1=Periodic; 2=Daily
CURRFISCALYR | i4 | 2 | Y | Not applicable | Current fiscal year
Auto_Add_Book_Info | i4 | 1 | N | 1 | Auto add book information: 0=False; 1=True
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateBuyer>

Element name | Data type | Length | Required | Default | Description
BUERID | string | 15 | Y | Not applicable | Buyer ID
DSCRIPTN | string | 30 | Y | Not applicable | Description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateCheckbook>

Element name | Data type | Length | Required | Default | Description
CHEKBKID | string | 15 | Y | Not applicable | Checkbook ID
DSCRIPTN | string | 30 | Y | Not applicable | Checkbook description
BANKID | string | 15 | N | <blank> | Bank ID
CURNCYID | string | 15 | Y | Not applicable | Currency ID
ACTNUMST | string | 75 | Y | Not applicable | Account number
BNKACTNM | string | 15 | N | <blank> | Bank account number
NXTCHNUM | string | 20 | N | 00000000000000000001 | Next check number
Next_Deposit_Number | string | 20 | N | 00000000000000000001 | Next deposit number
INACTIVE | i4 | 1 | N | 0 | Inactive flag
MXCHDLR | number | 21 | N | 0 | Maximum check amount
DUPCHNUM | i4 | 1 | N | 0 | Allow duplicate check numbers
OVCHNUM1 | i4 | 1 | N | 1 | Override check numbers
LOCATNID | string | 15 | N | <blank> | Company address ID
CMUSRDF1 | string | 20 | N | <blank> | User defined 1
CMUSRDF2 | string | 20 | N | <blank> | User defined 2
Last_Reconciled_Date | datetime | 16 | N | <blank> | Last reconciled date
Last_Reconciled_Balance | number | 21 | N | 0 | Last reconciled balance
DDACTNUM | string | 17 | N | <blank> | Bank account number from the direct deposit button
DDINDNAM | string | 22 | N | <blank> | Account name from the direct deposit button
DDTRANS | string | 2 | N | 27 | Account type from the direct deposit button: 27=Checking; 37=Savings
PaymentRateTypeID | string | 15 | N | <blank> | Payment rate type ID
DepositRateTypeID | string | 15 | N | <blank> | Deposit rate type ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateComputerCheckLineInsert>

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
COMPTRTP | i4 | 2 | N | 1 | Computer transaction type: 1=Pay code; 2=Deduction; 3=Benefit
SALCHG | i4 | 2 | N | 0 | Salary change; required if passing a salary pay code: 1=Reallocate dollars; 2=Reallocate hours; 3=Reduce dollars; 4=Reduce hours; 5=Additional amount
UPRTRXCD | string | 6 | Y | Not applicable | UPR transaction code
TRXBEGDT | datetime | 16 | N | <blank> | Transaction begin date
TRXENDDT | datetime | 16 | N | <blank> | Transaction end date
TRXHRUNT | number | 21 | N | 0 | Transaction hours/units; required if the pay code passed is: 1=Salary with a salary change of reallocated hours; 2=Salary with a salary change of reduced hours; 3=Piecework; 4=Overtime; 5=Double time; 6=Vacation; 7=Sick; 8=Holiday; 9=Minimum wage balance
HRLYPYRT | number | 21 | N | 0 | Hourly pay rate
PAYRTAMT | number | 21 | N | 0 | Pay rate amount; required if passing the pay code: 1=Salary with a salary change of reallocated dollars; 2=Salary with a salary change of reduced dollars; 3=Salary with a salary change of additional amount; 4=Charged tips; 5=Reported tips
VARDBAMT | number | 21 | N | 0 | Variable deduction/benefit amount
VARDBPCT | number | 21 | N | 0 | Variable deduction/benefit percent
RECEIPTS | number | 21 | N | 0 | Receipts
DAYSWRDK | number | 21 | N | 0 | Days worked
WKSWRKD | number | 21 | N | 0 | Weeks worked
DEPRTMNT | string | 6 | N | <blank> | Department; if empty, pulls from UPR00100
JOBTITLE | string | 6 | N | <blank> | Job title/position code; if empty, pulls from UPR00100
STATECD | string | 2 | N | <blank> | State code
LOCALTAX | string | 6 | N | <blank> | Local tax
SUTASTAT | string | 2 | N | <blank> | SUTA state
WRKRCOMP | string | 6 | N | <blank> | Workers' compensation code
SHFTCODE | string | 6 | N | <blank> | Shift code
SHFTPREM | number | 21 | N | 0 | Shift premium
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USERID | string | 15 | N | <blank> | User ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | Use-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateCreditCard>

Element name | Data type | Length | Required | Default | Description
RCVBGRBX | i4 | 2 | N | 0 | Receivable group box: 0=Bank Card; 1=Charge Card
CARDNAME | string | 15 | Y | Not applicable | Credit card name
CBPAYBLE | i4 | 1 | N | 0 | Used by company: 0=False; 1=True
CBRCVBLE | i4 | 1 | N | 0 | Accepted from customers: 0=False; 1=True
CKBKNUM1 | string | 15 | N | <blank> | Checkbook number 1; for customers
ACTNUMST | string | 75 | N | <blank> | Account Number
VENDORID | string | 15 | N | <blank> | Vendor ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USERID | string | 15 | N | <blank> | User ID
CREATDDT | datetime | 16 | N | Default from setup | Create date
MODIFDT | datetime | 16 | N | Default from setup | Modified date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateCustomerAddress>*

Element name | Datatype | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
ADRSCODE | string | 15 | Y | Not applicable | Address ID
SLPRSNID | string | 15 | N | <blank> | Salesperson ID
UPSZONE | string | 3 | N | <blank> | UPS zone
SHIPMTHD | string | 15 | N | <blank> | Shipping method
TAXSCHID | string | 15 | N | <blank> | Tax schedule
CNTCPRSN | string | 60 | N | <blank> | Contact person
ADDRESS1 | string | 60 | N | <blank> | Customer address one
ADDRESS2 | string | 60 | N | <blank> | Customer address two
ADDRESS3 | string | 60 | N | <blank> | Customer address three
COUNTRY | string | 60 | N | <blank> | Customer country
CITY | string | 35 | N | <blank> | Customer city
STATE | string | 29 | N | <blank> | Customer state
ZIPCODE | string | 10 | N | <blank> | Customer zip
PHNUMBR1 | string | 21 | N | <blank> | Phone one
PHNUMBR2 | string | 21 | N | <blank> | Phone two
PHNUMBR3 | string | 21 | N | <blank> | Phone three
FAX | string | 21 | N | <blank> | Fax
GPSFOINTEGRATIONID | string | 30 | N | <blank> | Front office integration ID
INTEGRATIONSOURCE | i4 | 2 | N | 0 | Integration source
INTEGRATIONID | string | 30 | N | <blank> | Integration ID
CCode | string | 6 | N | <blank> | Country code
LOCNCODE | string | 10 | N | <blank> | Location code
SALSTERR | string | 15 | N | <blank> | Sales territory
ShipToName | string | 64 | N | <blank> | Ship to name
Print_Phone_NumberGB | i4 | 2 | N | <blank> | Print phone number: 0=Do not print; 1=Phone 1; 2=Phone 2; 3=Phone 3; 4=Fax
USERDEF1 | string | 20 | N | <blank> | User defined 1
USERDEF2 | string | 20 | N | <blank> | User defined 2
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow updates to customer data: 0=No not update; 1=Update if exists
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateCustomerAddress> node uses field level updates to provide update functionality.


<taCreateCustomerClass>

Element name | Datatype | Length | Required | Default | Description
CLASSID | string | 15 | Y | Not applicable | Class ID
CLASDSCR | string | 30 | N | <blank> | Class description
CRLMTTYP | i4 | 2 | N | 0 | Credit limit type: 0=No credit; 1=Unlimited; 2=Amount
CRLMTAMT | number | 21 | N | 0 | Credit amount
CRLMTPER | i4 | 2 | N | 0 | Credit limit period
CRLMTPAM | number | 21 | N | 0 | Credit limit period amount
DEFLTCLS | i4 | 1 | N | 0 | Default class
BALNCTYP | i4 | 2 | N | 0 | Balance type: 0=Open item; 1=Balance forward
CHEKBKID | string | 15 | N | <blank> | Checkbook ID
TAXSCHID | string | 15 | N | <blank> | Tax schedule ID
SHIPMTHD | string | 15 | N | <blank> | Shipping method
PYMTRMID | string | 20 | N | <blank> | Payment term ID
CUSTDISC | i4 | 2 | N | 0 | Customer discount/trade discount
MINPYTYP | i4 | 2 | N | 0 | Minimum payment type: 0=No minimum; 1=Percent; 2=Amount
MINPYDLR | number | 21 | N | 0 | Minimum payment dollar
MINPYPCT | i4 | 2 | N | 0 | Minimum payment percent
MXWOFTYP | i4 | 2 | N | 0 | Maximum write-off type: 0=Not allowed; 1=Unlimited; 2=Maximum
MXWROFAM | number | 21 | N | 0 | Maximum write-off amount
FNCHATYP | i4 | 2 | N | 0 | Finance charge amount type: 0=None; 1=Percent; 2=Amount
FINCHDLR | number | 21 | N | 0 | Finance charge dollar
FNCHPCNT | i4 | 2 | N | 0 | Finance charge percent
PRCLEVEL | string | 10 | N | <blank> | Price level
CURNCYID | string | 15 | N | <blank> | Currency ID
RATETPID | string | 15 | N | <blank> | Rate ID
DEFCACTY | i4 | 2 | N | 0 | Cash account from: 0=Checkbook; 1=Customer
CASHACCT | string | 75 | N | <blank> | Cash account
ACCTRECACCT | string | 75 | N | <blank> | Account Receivable account
SALESACCT | string | 75 | N | <blank> | Sales account
COSTOFSALESACCT | string | 75 | N | <blank> | Cost of sales account
IVACCT | string | 75 | N | <blank> | Inventory account
TERMDISCTAKENACCT | string | 75 | N | <blank> | Terms discount taken account
TERMDISCAVAILACCT | string | 75 | N | <blank> | Terms discount available account
FINCHRGACCT | string | 75 | N | <blank> | Finance charges account
WRITEOFFACCT | string | 75 | N | <blank> | Write-off account
SALESORDERRETACCT | string | 75 | N | <blank> | Sales order returns account
SALSTERR | string | 15 | N | <blank> | Sales territory
SLPRSNID | string | 15 | N | <blank> | Sales person ID
STMTCYCL | i4 | 2 | N | 5 | Statement cycle: 1=No statement; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Bimonthly; 7=Quarterly
KPCALHST | i4 | 1 | N | 1 | Keep calendar history: 0=False; 1=True
KPDSTHST | i4 | 1 | N | 1 | Keep distribution history: 0=False; 1=True
KPERHIST | i4 | 1 | N | 1 | Keep period history: 0=False; 1=True
KPTRXHST | i4 | 1 | N | 1 | Keep transaction history: 0=False; 1=True
DISGRPER | i4 | 2 | N | 0 | Discount grace period
DUEGRPER | i4 | 2 | N | 0 | Due date of grace period
Revalue_Customer | i4 | 1 | N | 1 | Revalue customer: 0=False; 1=True
Post_Results_To | i4 | 2 | N | 0 | Post results to: 0=Receivables/discount account 1=Sales offset account
ORDERFULFILLDEFAULT | i4 | 1 | N | 1 | Order fulfillment shortage default: 1=None; 2=Back order remaining; 3=Cancel remaining
CUSTPRIORITY | i4 | 2 | N | 1 | Customer priority; valid input values are 1 (none) to 100
RMOvrpymtWrtoffAcct | string | 75 | N | <blank> | RM overpayment write-off account
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateCustomerItems>

Element name | Datatype | Length | Required | Default | Description
ITEMNMBR | string | 30 | Y | Not applicable | Item number
CUSTNMBR | string | 15 | Y | Not applicable | Customer ID
CUSTITEMNMBR | string | 30 | N | <blank> | Customer item
CUSTITEMDESC | string | 50 | N | <blank> | Customer item description
CUSTITEMSHORNAME | string | 15 | N | <blank> | Customer item short name
CUSTITEMGENERICDESC | string | 10 | N | <blank> | Customer generic
USRDEF1 | string | 20 | N | <blank> | User defined 1
USRDEF2 | string | 20 | N | <blank> | User defined 2
USRDEF03 | string | 20 | N | <blank> | User defined 3
USRDEF04 | string | 20 | N | <blank> | User defined 4
USRDEF05 | string | 20 | N | <blank> | User defined 5
SUBITEMNMBR | string | 30 | N | <blank> | Substitute item number
STRTDATE | datetime | 16 | N | <blank> | Substitute items effective start date
ENDDATE | datetime | 16 | N | <blank> | Substitute items effective end date
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateDeduction>*

Element name | Data type | Length | Required | Default | Description
DEDUCTION | string | 6 | Y | Not applicable | Deduction
DSCRIPTN | string | 30 | Y | Not applicable | Deduction description
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
DEDBEGDT | datetime | 16 | Y | Not applicable | Begin date
DEDENDDT | datetime | 16 | N | <blank> | End date
DEDTYPE | i4 | 2 | N | 1 | Deduction Type 1 = Standard 2 = Garnishment
GARNCAT | i4 | 2 | Y | 0 | Garnishment Category Required if Deduction Type is set to a 2 1= Support Order, 2 = Tax Levy, 3 = Bankruptcy, 4 = Garnishment 5 = Other
VARDEDTN | i4 | 1 | N | 0 | Variable deduction: 0=False; 1=True
DEDNFREQ | i4 | 2 | N | 1 | Deduction frequency: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Quarterly; 6=Semiannually; 7=Annually; 8=Daily/miscellaneous
SFRFEDTX | i4 | 1 | N | 0 | Sheltered from federal tax: 0=False; 1=True
SHFRFICA | i4 | 1 | N | 0 | Sheltered from FICA tax: 0=False; 1=True
SHFRSTTX | i4 | 1 | N | 0 | Sheltered from state tax: 0=False; 1=True
SFRLCLTX | i4 | 1 | N | 0 | Sheltered from local tax: 0=False; 1=True
BSDORCDS | i4 | 2 | N | 0 | Based on records: 0=All; 1=Selected
DEDNMTHD | i4 | 2 | N | 1 | Deduction method: 1=Percentage of gross wages; 2=Percentage of net wages; 3=Fixed amount; 4=Amount per unit 5=Percentage of earnings wage
DEDFRMLA | i4 | 2 | N | 0 | Deduction formula: 0=Single; 1=Multiple
EARNINGSCODE | string | 15 | N | <blank> | Earning code
DEDCAMNT_1 | number | 21 | N | 0 | Deduction amount 1
DEDCAMNT_2 | number | 21 | N | 0 | Deduction amount 2
DEDCAMNT_3 | number | 21 | N | 0 | Deduction amount 3
DEDCAMNT_4 | number | 21 | N | 0 | Deduction amount 4
DEDCAMNT_5 | number | 21 | N | 0 | Deduction amount 5
DEDNPRCT_1 | number | 21 | N | 0 | Deduction percentage 1
DEDNPRCT_2 | number | 21 | N | 0 | Deduction percentage 2
DEDNPRCT_3 | number | 21 | N | 0 | Deduction percentage 3
DEDNPRCT_4 | number | 21 | N | 0 | Deduction percentage 4
DEDNPRCT_5 | number | 21 | N | 0 | Deduction percentage 5
DEDTRMAX_1 | number | 21 | N | 0 | Deduction tier maximum 1
DEDTRMAX_2 | number | 21 | N | 0 | Deduction tier maximum 2
DEDTRMAX_3 | number | 21 | N | 0 | Deduction tier maximum 3
DEDTRMAX_4 | number | 21 | N | 0 | Deduction tier maximum 4
DEDTRMAX_5 | number | 21 | N | 0 | Deduction tier maximum 5
DETRMXUN_1 | number | 21 | N | 0 | Deduction tier maximum units 1
DETRMXUN_2 | number | 21 | N | 0 | Deduction tier maximum units 2
DETRMXUN_3 | number | 21 | N | 0 | Deduction tier maximum units 3
DETRMXUN_4 | number | 21 | N | 0 | Deduction tier maximum units 4
DETRMXUN_5 | number | 21 | N | 0 | Deduction tier maximum units 5
DEPYPRMX | number | 21 | N | 0 | Deduction pay period maximum
DEDYRMAX | number | 21 | N | 0 | Deduction year maximum
Deduction_Fiscal_Yr_Max | number | 21 | N | 0 | Deduction Fiscal Year Maximum
DEDLTMAX | number | 21 | N | 0 | Deduction life maximum
W2BXNMBR | i4 | 2 | N | 0 | W-2 box number
W2BXLABL | string | 6 | N | <blank> | W-2 box label
W2BXNMBR2 | i4 | 2 | N | 0 | W-2 Box Number 2
W2BXLABL2 | string | 6 | N | <blank> | W-2 Box Label 2
W2BXNMBR3 | i4 | 2 | N | 0 | W-2 Box Number 3
W2BXLABL3 | string | 6 | N | <blank> | W-2 Box Label 3
W2BXNMBR4 | i4 | 2 | N | 0 | W-2 Box Number 4
W2BXLABL4 | string | 6 | N | <blank> | W-2 Box Label 4
DATAENTDFLT | i4 | 1 | N | 0 | Data entry default: 0=False; 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateDeduction> node uses field level updates to provide update functionality.


<taCreateDeductionBasedOnPayCodes>

Element name | Data type | Length | Required | Default | Description
DEDUCTION | string | 6 | Y | Not applicable | Deduction
BSDONCDE | string | 30 | Y | Not applicable | Deduction description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateDepartment>*

Element name | Data type | Length | Required | Default | Description
DEPRTMNT | string | 6 | Y | Not applicable | Department
DSCRIPTN | string | 30 | Y | Not applicable | Department description
UpdateIfExists 1 | i4 | 1 | N | 1 | Flag to allow customer data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateDepartment> node uses field level updates to provide update functionality.


<taCreateEmployee>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
EMPLCLAS | string | 15 | N | <blank> | Employee class
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
LASTNAME | string | 20 | Y | Not applicable | Last name
FRSTNAME | string | 15 | Y | Not applicable | First name
MIDLNAME | string | 15 | N | <blank> | Middle name
EMPLSUFF | string | 4 | N | <blank> | Employee suffix
ADRSCODE | string | 15 | N | <blank> | Address code
ADDRESS1 | string | 30 | N | <blank> | Address code 1
ADDRESS2 | string | 30 | N | <blank> | Address code 2
ADDRESS3 | string | 30 | N | <blank> | Address code 3
CITY | string | 30 | N | <blank> | City
STATE | string | 29 | N | <blank> | State
ZIPCODE | string | 10 | N | <blank> | ZIP Code
COUNTY | string | 20 | N | <blank> | County
COUNTRY | string | 20 | N | <blank> | Country
PHONE1 | string | 21 | N | <blank> | Phone number 1
PHONE2 | string | 21 | N | <blank> | Phone number 2
PHONE3 | string | 21 | N | <blank> | Phone number 3
FAX | string | 21 | N | <blank> | Fax number
SOCSCNUM | string | 15 | Y | Not applicable | Social Security number
BRTHDATE | datetime | 16 | N | <blank> | Birth date
GENDER | i4 | 2 | N | 3 | Gender: 1=Male; 2=Female; 3=Not applicable
ETHNORGN | i4 | 2 | N | 7 | Ethnic origin: 1=White; 2=Native American or Alaskan Native; 3=Black or African American; 4=Asian; 5=Hispanic or Latino; 6=Two or more races; 7=Not applicable; 8=Native Hawaiian or Pacific Islander
Calc_Min_Wage_Bal | i4 | 1 | N | Default from setup | Calculate minimum wage balance: 0=False; 1=True
DIVISIONCODE_I | string | 6 | N | <blank> | Division code; HR option only
DEPRTMNT | string | 6 | Y | Not applicable | Department
JOBTITLE | string | 6 | Y | Not applicable | Job title/position
SUPERVISORCODE_I | string | 6 | N | <blank> | Supervisor Code
LOCATNID | string | 15 | N | <blank> | Location ID
WCACFPAY | i4 | 2 | N | 0 | Cash account from: 0=Checkbook; 1=Employee
AccountNumber | string | 75 | N | <blank> | Account number
WKHRPRYR | i4 | 2 | N | 0 | Work hours per year
STRTDATE | datetime | 16 | N | <blank> | Start date
DEMPINAC | datetime | 16 | N | <blank> | Date employee inactivated; this field is active if INACTIVE=1
RSNEMPIN | string | 30 | N | <blank> | Reason employee inactivated; this field is active if INACTIVE=1
MINETPAY | number | 21 | N | Default from setup | Minimum net pay
SUTASTAT | string | 2 | N | <blank> | SUTA state
WRKRCOMP | string | 6 | N | <blank> | Workers' compensation code
ATACRVAC | i4 | 1 | N | Default from setup | Auto accrue vacation: 0=False; 1=True
VACCRAMT | number | 21 | N | Default from setup | Vacation accrual amount
VACCRMTH | i4 | 2 | N | Default from setup | Vacation accrual method: 0=Hours worked; 1=Set hours
VACAPRYR | number | 21 | N | Default from setup | Vacation hours per year
VACAVLBL | number | 21 | N | Default from setup | Vacation available
WRNVCNFLSBLWZR | i4 | 1 | N | Default from setup | Warn if vacation falls below zero: 0=False; 1=True
ATACRSTM | i4 | 1 | N | <blank> | Auto accrue sick time: 0=False 1=True
STMACMTH | i4 | 2 | N | 0 | Sick Time Accrual Method: 0=Hours worked 1=Set hours
SKTMACAM | number | 21 | N | <blank> | Sick time accrual amount
SIKTIMAV | number | 21 | N | <blank> | Sick time available
SKTMHPYR | number | 21 | N | <blank> | Sick time hours per year
WRNSTFLSBLWZR | i4 | 1 | N | <blank> | Warn sick time falls below zero 0=False 1=True
USERDEF1 | string | 20 | N | <blank> | User defined 1
USERDEF2 | string | 20 | N | <blank> | User defined 2
EMPLOYMENTTYPE | i4 | 2 | N | Default from setup | Type of employment: 1=Full-time regular; 2=Full-time temporary; 3=Part-time regular; 4=Part-time temporary; 5=Intern; 6=Other
MARITALSTATUS | i4 | 2 | N | 3 | Marital status: 1=Married; 2=Single; 3=Not applicable
BENADJDATE | datetime | 16 | N | <blank> | Benefit adjustment date
LASTDAYWORKED_I | datetime | 16 | N | <blank> | Last day worked
BIRTHDAY | i4 | 2 | N | 0 | Birthday
BIRTHMONTH | i4 | 2 | N | 0 | Birth month: 1=January; 2=February; 3=March; 4=April; 5=May; 6=June; 7=July; 8=August; 9=September; 10=October; 11=November; 12=December
SPOUSE | string | 15 | N | <blank> | Spouse
SPOUSESSN | string | 15 | N | <blank> | Spouse Social Security number
NICKNAME | string | 20 | N | <blank> | Nickname
ALTERNATENAME | string | 20 | N | <blank> | Alternate name
STATUSCD | string | 15 | N | <blank> | Status code
HRSTATUS | i4 | 2 | N | 1 | HR Status; HR option only: 1=Active; 2=Family leave; 3=Leave of absence; 4=Maternity; 5=Retired; 6=Separated; 7=Suspended; 8=Terminated; 9=Other
DATEOFLASTREVIEW_I | datetime | 16 | N | <blank> | Date of last review; HR option only
DATEOFNEXTREVIEW_I | datetime | 16 | N | <blank> | Date of next review; HR option only
BENEFITEXPIRE_I | datetime | 16 | N | <blank> | Benefit expire
HANDICAPPED | i4 | 1 | N | 0 | Handicapped; HR option only: 0=False; 1=True
VETERAN | i4 | 1 | N | 0 | Veteran; HR option only: 0=False; 1=True
VIETNAMVETERAN | i4 | 1 | N | 0 | Vietnam veteran; HR option only: 0=False; 1=True
DISABLEDVETERAN | i4 | 1 | N | 0 | Disabled veteran; HR option only: 0=False; 1=True
UNIONEMPLOYEE | i4 | 1 | N | 0 | Union employee; HR option only: 0=False; 1=True
SMOKER_I | i4 | 1 | N | 0 | Smoker; HR option only: 0=False; 1=True
CITIZEN | i4 | 1 | N | 0 | Citizen; HR option only: 0=False; 1=True
VERIFIED | i4 | 1 | N | 0 | Verified; HR option only: 0=False; 1=True
I9RENEW | datetime | 16 | N | <blank> | I9 renew; HR option only
Primary_Pay_Record | string | 6 | N | <blank> | Primary pay record; HR option only
CHANGEBY_I | string | 15 | N | <blank> | Change by; HR option only
CHANGEDATE_I | datetime | 16 | N | <blank> | Change date; HR option only
UNIONCD | string | 6 | N | <blank> | Union code; HR option only
RATECLSS | string | 15 | N | <blank> | Rate class; HR option only
FEDCLSSCD | string | 10 | N | <blank> | Federal class; HR option only
OTHERVET | i4 | 1 | N | 0 | Other veterans; HR option only
Military_Discharge_Date | datetime | 16 | N | <blank> | Military discharge date; HR option only
DefaultFromClass | i4 | 1 | N | 1 | Default information from class: 0=False; 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployee> node uses field level updates to provide update functionality.


<taCreateEmployeeAddress>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
ADRSCODE | string | 15 | Y | Not applicable | Address code
ADDRESS1 | string | 60 | N | <blank> | Address line 1
ADDRESS2 | string | 60 | N | <blank> | Address line 2
ADDRESS3 | string | 60 | N | <blank> | Address line 3
CITY | string | 35 | N | <blank> | City
STATE | string | 29 | N | <blank> | State
ZIPCODE | string | 10 | N | <blank> | ZIP Code/postal code
COUNTY | string | 60 | N | <blank> | County
COUNTRY | string | 60 | N | <blank> | Country
PHONE1 | string | 21 | N | <blank> | Phone 1
PHONE2 | string | 21 | N | <blank> | Phone 2
PHONE3 | string | 21 | N | <blank> | Phone 3
FAX | string | 21 | N | <blank> | Fax number
Foreign_Address | i4 | 1 | N | 0 | Foreign address: 0=False; 1=True
Foreign_StateProvince | string | 23 | N | <blank> | Foreign state or province
Foreign_Postal_Code | string | 15 | N | <blank> | Foreign postal code
Ccode | string | 6 | N | <blank> | Country code
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow address data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeeAddress> node uses field level updates to provide update functionality.


<taCreateEmployeeBenefit>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
BENEFIT | string | 6 | Y | Not applicable | Pay code
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
BNFBEGDT | datetime | 16 | N | <blank> | Benefit begin date; required if UseDefaultCoBenefit=0 and optional if UseDefaultCoBenefit=1
BNFENDDT | datetime | 16 | N | <blank> | Benefit end date
VARBENFT | i4 | 1 | N | Default from setup | Variable benefit/transaction required: 0=False; 1=True
BNFTFREQ | i4 | 2 | N | Default from setup | Benefit frequency: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Quarterly; 6=Semiannually; 7=Annually; 8=Daily/miscellaneous
SBJTFDTX | i4 | 1 | N | Default from setup | Subject to federal tax: 0=False; 1=True
SBJTSSEC | i4 | 1 | N | Default from setup | Subject to FICA Social Security tax: 0=False; 1=True
SBJTMCAR | i4 | 1 | N | Default from setup | Subject to FICA Medicare tax: 0=False; 1=True
SBJTSTTX | i4 | 1 | N | Default from setup | Subject to state tax: 0=False; 1=True
SBJTLTAX | i4 | 1 | N | Default from setup | Subject to local tax: 0=False; 1=True
SBJTFUTA | i4 | 1 | N | Default from setup | Subject to FUTA tax: 0=False; 1=True
SBJTSUTA | i4 | 1 | N | Default from setup | Subject to SUTA tax: 0=False; 1=True
FFEDTXRT | number | 21 | N | Default from setup | Flat federal tax rate
FLSTTXRT | number | 21 | N | Default from setup | Flat state tax rate
BORCDTYP | i4 | 2 | N | Default from setup | Based on record type: 1=Pay codes; 2=Deductions
BSDORCDS | i4 | 2 | N | Default from setup | Based on records: 0=False; 1=True
BNFTMTHD | i4 | 2 | N | Default from setup | Benefit method: 1=Percentage of gross wages; 2=Percentage of net wages; 3=Percentage of deduction; 4=Fixed amount; 5=Amount per unit
BNFFRMLA | i4 | 2 | N | Default from setup | Benefit formula: 0=Single; 1=Multiple
BNFPRCNT_1 | number | 21 | N | Default from setup | Benefit percent 1
BNFPRCNT_2 | number | 21 | N | Default from setup | Benefit percent 2
BNFPRCNT_3 | number | 21 | N | Default from setup | Benefit percent 3
BNFPRCNT_4 | number | 21 | N | Default from setup | Benefit percent 4
BNFPRCNT_5 | number | 21 | N | Default from setup | Benefit percent 5
BNFITAMT_1 | number | 21 | N | Default from setup | Benefit amount 1
BNFITAMT_2 | number | 21 | N | Default from setup | Benefit amount 2
BNFITAMT_3 | number | 21 | N | Default from setup | Benefit amount 3
BNFITAMT_4 | number | 21 | N | Default from setup | Benefit amount 4
BNFITAMT_5 | number | 21 | N | Default from setup | Benefit amount 5
BNFTRMAX_1 | number | 21 | N | Default from setup | Benefit tier max 1
BNFTRMAX_2 | number | 21 | N | Default from setup | Benefit tier max 2
BNFTRMAX_3 | number | 21 | N | Default from setup | Benefit tier max 3
BNFTRMAX_4 | number | 21 | N | Default from setup | Benefit tier max 4
BNFTRMAX_5 | number | 21 | N | Default from setup | Benefit tier max 5
BNTRMXUN_1 | number | 21 | N | Default from setup | Benefit tier max units 1
BNTRMXUN_2 | number | 21 | N | Default from setup | Benefit tier max units 2
BNTRMXUN_3 | number | 21 | N | Default from setup | Benefit tier max units 3
BNTRMXUN_4 | number | 21 | N | Default from setup | Benefit tier max units 4
BNTRMXUN_5 | number | 21 | N | Default from setup | Benefit tier max units 5
BNPAYPMX | number | 21 | N | Default from setup | Benefit pay period maximum
BNFYRMAX | number | 21 | N | Default from setup | Benefit year maximum
Benefit_Fiscal_Max | number | 21 | N | 0 | Benefit Fiscal Year Maximum
BNFLFMAX | number | 21 | N | Default from setup | Benefit lifetime maximum
W2BXNMBR | i4 | 2 | N | Default from setup | W-2 box number
W2BXLABL | string | 6 | N | Default from setup | W-2 box label
W2BXNMBR2 | i4 | 2 | N | <blank> | W-2 Box Number 2
W2BXLABL2 | string | 6 | N | <blank> | W-2 Box Label 2
W2BXNMBR3 | i4 | 2 | N | 0 | W-2 Box Number 3
W2BXLABL3 | string | 6 | N | <blank> | W-2 Box Label 3
W2BXNMBR4 | i4 | 2 | N | 0 | W-2 Box Number 4
W2BXLABL4 | string | 6 | N | <blank> | W-2 Box Label 4
DATAENTDFLT | i4 | 1 | N | Default from setup | Data entry default: 0=False; 1=True
EMPLRMAXMAT | number | 21 | N | Default from setup | Employer maximum match
UseDefaultCoBenefit | i4 | 2 | N | Default from setup | Use default company benefit: 0=False; 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow address data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeeBenefit> node uses field level updates to provide update functionality.


<taCreateEmployeeBenefitBasedOnPayDedCodes>

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
BENEFIT | string | 6 | Y | Not applicable | Benefit
BORCDTYP | i4 | 2 | Y | Not applicable | Based on record type: 1=Pay codes; 2=Deductions
BSDONCDE | string | 6 | Y | Not applicable | Deduction description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateEmployeeClass>*

Element name | Data type | Length | Required | Default | Description
EMPLCLAS | string | 15 | Y | Not applicable | Employee class ID
DSCRIPTN | string | 30 | Y | Not applicable | Class description
DEPRTMNT | string | 6 | N | <blank> | Department
JOBTITLE | string | 6 | N | <blank> | Job title
SUTASTAT | string | 2 | N | <blank> | SUTA state
WRKRCOMP | string | 6 | N | <blank> | Workers' compensation
MINETPAY | number | 21 | N | 0 | Minimum net pay
WKHRPRYR | i4 | 2 | N | 2080 | Work hours per year
WCACFPAY | i4 | 2 | N | 0 | Which cash account for pay: 0=Checkbook; 1=Employee
AccountNumber | string | 75 | N | <blank> | Account number
USERDEF1 | string | 20 | N | <blank> | User defined 1
USERDEF2 | string | 20 | N | <blank> | User defined 2
ATACRVAC | i4 | 1 | N | 0 | Auto accrue vacation: 0=False; 1=True
VACCRMTH | i4 | 2 | N | 0 | Vacation accrual method: 0=False; 1=True
VACCRAMT | number | 21 | N | 0 | Vacation accrual amount
VACAPRYR | number | 21 | N | 0 | Vacation hours per year
VACAVLBL | number | 21 | N | 0 | Vacation available
WRNVCNFLSBLWZR | i4 | 1 | N | 1 | Warn vacation falls below zero: 0=False; 1=True
ATACRSTM | i4 | 1 | N | 0 | Auto accrue sick time
STMACMTH | i4 | 2 | N | 0 | Sick time accrual method
SKTMACAM | number | 21 | N | 0 | Sick time accrual amount
SKTMHPYR | number | 21 | N | 0 | Sick time hours per year
SIKTIMAV | number | 21 | N | 0 | Sick time available
WRNSTFLSBLWZR | i4 | 1 | N | 1 | Warn sick time falls below zero: 0=False; 1=True
DEFLTCLS | i4 | 1 | N | 0 | Default class: 0=False; 1=True
Calc_Min_Wage_Bal | i4 | 1 | N | 0 | Calculate minimum wage balance: 0=False; 1=True
EMPLOYMENTTYPE | i4 | 2 | N | 1 | Type of employment: 1=Full-time regular; 2=Full-time temporary; 3=Part-time regular; 4=Part-time temporary; 5=Intern
DefaultFromClass | i4 | 1 | N | 1 | Flag to determine if a parameter is brought in blank and whether or not to pull from Default class: 0=No; 1=Yes
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow employee data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeeClass> node uses field level updates to provide update functionality.


<taCreateEmployeeDeduction>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
DEDUCTON | string | 6 | Y | Not applicable | Deduction
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
DEDBEGDT | datetime | 16 | N | <blank> | Deduction start date; required if not using deduction code as the default, so UseDefaultCoDeduction=0; optional if using the default and then UseDefaultCoDeduction=1
DEDENDDT | datetime | 16 | N | <blank> | Deduction end date
VARDEDTN | i4 | 1 | N | Default from setup | Variable deduction: 0=False; 1=True
DEDNFREQ | i4 | 2 | N | Default from setup | Deduction frequency: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Quarterly; 6=Semiannually; 7=Annually; 8=Daily/miscellaneous
SFRFEDTX | i4 | 1 | N | Default from setup | Sheltered from federal tax: 0=False; 1=True
SHFRFICA | i4 | 1 | N | Default from setup | Sheltered from FICA tax: 0=False; 1=True
SHFRSTTX | i4 | 1 | N | Default from setup | Sheltered from state tax: 0=False; 1=True
SFRLCLTX | i4 | 1 | N | Default from setup | Sheltered from local tax: 0=False; 1=True
BSDORCDS | i4 | 2 | N | Default from setup | Based on records: 0=All; 1=Selected
DEDNMTHD | i4 | 2 | N | Default from setup | Deduction method: 1=Percentage of gross wages; 2=Percentage of net wages; 3=Fixed amount; 4=Amount per unit 5=Percentatge of earnings wage
DEDFRMLA | i4 | 2 | N | Default from setup | Deduction formula: 0=Single; 1=Multiple
DEDNPRCT_1 | number | 21 | N | Default from setup | Deduction percentage 1
DEDNPRCT_2 | number | 21 | N | Default from setup | Deduction percentage 2
DEDNPRCT_3 | number | 21 | N | Default from setup | Deduction percentage 3
DEDNPRCT_4 | number | 21 | N | Default from setup | Deduction percentage 4
DEDNPRCT_5 | number | 21 | N | Default from setup | Deduction percentage 5
DEDCAMNT_1 | number | 21 | N | Default from setup | Deduction amount 1
DEDCAMNT_2 | number | 21 | N | Default from setup | Deduction amount 2
DEDCAMNT_3 | number | 21 | N | Default from setup | Deduction amount 3
DEDCAMNT_4 | number | 21 | N | Default from setup | Deduction amount 4
DEDCAMNT_5 | number | 21 | N | Default from setup | Deduction amount 5
DEDTRMAX_1 | number | 21 | N | Default from setup | Deduction tier maximum 1
DEDTRMAX_2 | number | 21 | N | Default from setup | Deduction tier maximum 2
DEDTRMAX_3 | number | 21 | N | Default from setup | Deduction tier maximum 3
DEDTRMAX_4 | number | 21 | N | Default from setup | Deduction tier maximum 4
DEDTRMAX_5 | number | 21 | N | Default from setup | Deduction tier maximum 5
DETRMXUN_1 | number | 21 | N | Default from setup | Deduction tier maximum units 1
DETRMXUN_2 | number | 21 | N | Default from setup | Deduction tier maximum units 2
DETRMXUN_3 | number | 21 | N | Default from setup | Deduction tier maximum units 3
DETRMXUN_4 | number | 21 | N | Default from setup | Deduction tier maximum units 4
DETRMXUN_5 | number | 21 | N | Default from setup | Deduction tier maximum units 5
DEPYPRMX | number | 21 | N | Default from setup | Deduction pay period maximum
DEDYRMAX | number | 21 | N | Default from setup | Deduction year maximum
Deduction_Fiscal_Yr_Max | number | 21 | N | 0 | Deduction fiscal year maximum
DEDLTMAX | number | 21 | N | Default from setup | Deduction life maximum
W2BXNMBR | i4 | 2 | N | Default from setup | W-2 box number
W2BXLABL | string | 6 | N | Default from setup | W-2 box label
W2BXNMBR2 | i4 | 2 | N | <blank> | W-2 Box Number 2
W2BXLABL2 | string | 6 | N | <blank> | W-2 Box Label 2
W2BXNMBR3 | i4 | 2 | N | 0 | W-2 Box Number 3
W2BXLABL3 | string | 6 | N | <blank> | W-2 Box Label 3
W2BXNMBR4 | i4 | 2 | N | 0 | W-2 Box Number 4
W2BXLABL4 | string | 6 | N | <blank> | W-2 Box Label 4
DATAENTDFLT | i4 | 1 | N | Default from setup | Data entry default: 0=False; 1=True
UseDefaultCoDeduction | i4 | 2 | N | 1 | Use default company deduction: 0=False; 1=True
EARNINGSCODE | string | 15 | N | <blank> | Earnings code
COURTDATE | datetime | 16 | N | <blank> | Court Date
COURTNAME | string | 31 | N | <blank> | Court name
DOCDESCR | string | 31 | N | <blank> | Document ID
ORIGINALAMOUNT | number | 21 | N | 0 | Original amount
AMNTTAKEN | number | 21 | N | 0 | Amount taken
FEDMAXDED | string | 15 | N | <blank> | Federal maximum deduction
STATEMAXDED | string | 15 | N | <blank> | State maximum deduction
VENDORID | string | 15 | N | <blank> | Vendor ID
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow address data to be updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeeDeduction> node uses field level updates to provide update functionality.


<taCreateEmployeeDeductionBasedOnPayCodes>

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
DEDUCTION | string | 6 | Y | Not applicable | Deduction
BSDONCDE | string | 30 | Y | Not applicable | Deduction description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateEmployeeLocalTax>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
LOCALTAX | string | 6 | Y | Not applicable | Local tax
LCLFGSTS | string | 6 | N | <blank> | Local filing status: SINGLE=Single; MAR=Married; ''=Not Applicable
AULCLTAX | i4 | 1 | N | 1 | Automatically calculate: 0=False; 1=True
NUMOFEXM | i4 | 2 | N | 0 | Number of exemptions
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
ADTLLOCWTHDNG | number | 21 | N | 0 | Additional withholding
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeeLocalTax> node uses field level updates to provide update functionality.


<taCreateEmployeePayCode>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
PAYRCORD | string | 6 | Y | Not applicable | Pay code
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
BSPAYRCD | string | 6 | N | Default from setup | Based on pay code
PAYRTAMT | number | 21 | N | Default from setup | Pay rate amount
PAYUNIT | string | 25 | N | Default from setup | Pay unit; required if passing a piecework pay code
PAYUNPER | i4 | 2 | N | Default from setup | Pay unit period: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Quarterly; 6=Semiannually; 7=Annually; 8=Daily/miscellaneous
RPTASWGS | i4 | 1 | N | Default from setup | Report as wages: 0=False; 1=True
SBJTFDTX | i4 | 1 | N | Default from setup | Subject to federal tax: 0=False; 1=True
SBJTSSEC | i4 | 1 | N | Default from setup | Subject to Social Security: 0=False; 1=True
SBJTMCAR | i4 | 1 | N | Default from setup | Subject to Medicare: 0=False; 1=True
SBJTSTTX | i4 | 1 | N | Default from setup | Subject to state tax: 0=False; 1=True
SBJTLTAX | i4 | 1 | N | Default from setup | Subject to local tax: 0=False; 1=True
SBJTFUTA | i4 | 1 | N | Default from setup | Subject to FUTA tax: 0=False; 1=True
SBJTSUTA | i4 | 1 | N | Default from setup | Subject to SUTA Tax: 0=False; 1=True
SUTASTAT | string | 2 | N | <blank> | SUTA state
FFEDTXRT | number | 21 | N | Default from setup | Federal tax rate
FLSTTXRT | number | 21 | N | Default from setup | State tax rate
PAYPEROD | i4 | 2 | N | Default from setup | Pay period
MXPYPPER | number | 21 | N | Default from setup | Maximum per pay period
TipType | i4 | 2 | N | Default from setup | Tip type: 1=Directly; 2=Indirectly
PAYADVNC | number | 21 | N | Default from setup | Pay advance
ACRUVACN | i4 | 1 | N | Default from setup | Auto accrue vacation time: 0=False; 1=True
ACRUSTIM | i4 | 1 | N | Default from setup | Auto accrue sick time: 0=False; 1=True
WRKRCOMP | string | 6 | N | <blank> | Workers' compensation code
W2BXNMBR | i4 | 2 | N | Default from setup | W-2 box number
W2BXLABL | string | 6 | N | Default from setup | W-2 box label
W2BXNMBR2 | i4 | 2 | N | <blank> | W-2 Box Number 2
W2BXLABL2 | string | 6 | N | <blank> | W-2 Box Label 2
W2BXNMBR3 | i4 | 2 | N | 0 | W-2 Box Number 3
W2BXLABL3 | string | 6 | N | <blank> | W-2 Box Label 3
W2BXNMBR4 | i4 | 2 | N | 0 | W-2 Box Number 4
W2BXLABL4 | string | 6 | N | <blank> | W-2 Box Label 4
PYADVTKN | number | 21 | N | 0 | Pay advance taken
DATAENTDFLT | i4 | 1 | N | Default from setup | Data entry level: 0=False; 1=True
Primary_Pay_Record | i4 | 1 | N | 0 | Primary Pay Record HR Only Option 0=False 1=True
SHFTCODE | string | 6 | N | Default from setup | Shift code
PAYFACTR | number | 21 | N | Default from setup | Pay factor
UseDefaultCoPayCode | i4 | 2 | N | 1 | Use default company pay code: 0=False; 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow address data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeePayCode> node uses field level updates to provide update functionality.


<taCreateEmployeeStateTax>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
STATECD | string | 15 | Y | Not applicable | State code
TXFLGSTS | string | 30 | N | <blank> | Tax filing status
EXMFBLND | i4 | 1 | N | 0 | Exemption for blind: 0=False; 1=True
EXFBLSPS | i4 | 1 | N | 0 | Exemption for blind spouse: 0=False; 1=True
EXFORO65 | i4 | 1 | N | 0 | Exemption for over 65: 0=False; 1=True
EXMFRSLF | i4 | 1 | N | 0 | Exemption for self: 0=False; 1=True
EXMFSPAL | i4 | 1 | N | 0 | Exemption for special allowance: 0=False; 1=True
EXMFRSPS | i4 | 1 | N | 0 | Exemption for spouse: 0=False; 1=True
EXFSPO65 | i4 | 1 | N | 0 | Exemption for spouse over 65: 0=False; 1=True
PRSNEXPT | i4 | 2 | N | 0 | Personal exemption
DEPNDNTS | i4 | 2 | N | 0 | Dependents
ADNLALOW | i4 | 2 | N | 0 | Additional allowances
ESTDEDAL | i4 | 2 | N | 0 | Estimated deduction allowance
EXMTAMNT | number | 21 | N | 0 | Exemption amount
ADSTWHDG | number | 21 | N | 0 | Additional state withholding
ESTSTWHD | number | 21 | N | 0 | Estimated state withholding
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow employee data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeeStateTax> node uses field level updates to provide update functionality.


<taCreateEmployeeTax>*

Element name | Data type | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
FDFLGSTS | string | 15 | N | <blank> | Federal filing status: MAR=Married; SINGLE=Single; BLANK=Exempt; NRA=Non-resident alien
FEDEXMPT | i4 | 30 | N | 0 | Number of exemptions claimed
ADFDWHDG | number | 30 | N | 0 | Additional federal withholding
ESTFEDWH | number | 30 | N | 0 | Estimated federal withholding
STATECD | string | 30 | N | <blank> | State code
LOCALTAX | string | 29 | N | <blank> | Local tax code
W2BF942E | i4 | 1 | N | 0 | W2 box for 942 employee: 0=False; 1=True
W2BFDCSD | i4 | 1 | N | 0 | W2 box for deceased: 0=False; 1=True
W2BFDCMP | i4 | 1 | N | 0 | W2 box for deferred compensation: 0=False; 1=True
W2BFLREP | i4 | 1 | N | 0 | W2 box for legal representative: 0=False; 1=True
W2BFPPLN | i4 | 1 | N | 0 | W2 box for pension plan: 0=False; 1=True
W2BFSTEM | i4 | 1 | N | 0 | W2 box for statutory employee: 0=False; 1=True
MCRQGEMP | i4 | 1 | N | 0 | Medicare qualified government employee
EICFLGST | string | 6 | N | <blank> | EIC filing status: BLANK=Not eligible; MAR=Married, both spouses file certificate; MAR2=Married without spouse filing certificate; SINGLE=Single/head of household
NYTXDiff | i4 | 1 | N | 1 | Withhold NY tax difference
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow employee data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateEmployeeTax> node uses field level updates to provide update functionality.


<taCreateFixedAllocationAccountRcd>*

Element name | Data type | Length | Required | Default | Description
ACTNUMST | string | 75 | N | <blank> | Account string
DISTACTNUMST | string | 75 | N | <blank> | Distribution account string
PRCNTAGE | number | 21 | N | 0 | Percentage
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateFixedAllocationAccountRcd> node uses field level updates to provide update functionality.


<taCreateInsuranceClassID>

Element name | Data type | Length | Required | Default | Description
INSCLASSID | string | 15 | Y | Not applicable | Insurance class ID
INSCLASSDESCR | string | 30 | N | <blank> | Insurance class ID description
INFLATIONRATEPCT | number | 21 | N | 0 | Inflation rate percentage
DEPRRATEPCT | number | 21 | N | 0 | Depreciation rate percentage
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateInternetAddresses>

Element name | Data type | Length | Required | Default | Description
Master_Type | string | 3 | Y | Not applicable | Master type: CUS=Customer record; ITM=Item record; VEN=Vendor record; CMP=Company record; SLP=Salesperson record; EMP=Employee record
Master_ID | string | 30 | Y | Not applicable | Master record ID
ADRSCODE | string | 15 | N | <blank> | Address code—not required for item record and salesperson record
INET1 | string | 200 | N | <blank> | E-mail address
INET2 | string | 200 | N | <blank> | Web-site address
INET3 | string | 200 | N | <blank> | FTP address
INET4 | string | 200 | N | <blank> | Image
INET5 | string | 200 | N | <blank> | Logon
INET6 | string | 200 | N | <blank> | Password
INET7 | string | 200 | N | <blank> | User-defined field 1
INET8 | string | 200 | N | <blank> | User-defined field 2
INETINFO | string | 1000 | N | <blank> | Internet information
Messenger_Address | string | 200 | N | <blank> | Messenger address
EmailBccAddress | string | 1000 | N | <blank> | Email BCC address
EmailCcAddress | string | 1000 | N | <blank> | Email CC address
EmailToAddress | string | 1000 | N | <blank> | Email to address
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateInventorySite>

Element name | Data type | Length | Required | Default | Description
LOCNCODE | string | 10 | Y | <blank> | Location/site code
LOCNDSCR | string | 30 | Y | <blank> | Location/site description
ADDRESS1 | string | 60 | N | <blank> | Address 1
ADDRESS2 | string | 60 | N | <blank> | Address 2
ADDRESS3 | string | 60 | N | <blank> | Address 3
CITY | string | 35 | N | <blank> | City
STATE | string | 29 | N | <blank> | State
ZIPCODE | string | 10 | N | <blank> | ZIP Code
COUNTRY | string | 60 | N | <blank> | Country
PHONE1 | string | 20 | N | <blank> | Phone 1
PHONE2 | string | 20 | N | <blank> | Phone 2
PHONE3 | string | 20 | N | <blank> | Phone 3
FAXNUMBR | string | 20 | N | <blank> | Fax number
Location_Segment | string | 66 | N | <blank> | Location segment
STAXSCHD | string | 15 | N | <blank> | Sales tax schedule ID
PCTAXSCH | string | 15 | N | <blank> | Purchases tax schedule ID
INCLDDINPLNNNG | i4 | 1 | N | 1 | Include in planning: 0=False; 1=True
CCode | string | 6 | N | <blank> | Country code
PORECEIPTBIN | string | 15 | N | <blank> | Purchase receipt bin
PORETRNBIN | string | 15 | N | <blank> | Purchase return bin
SOFULFILLMENTBIN | string | 15 | N | <blank> | Sales order fulfillment bin
SORETURNBIN | string | 15 | N | <blank> | Sales order returns bin
BOMRCPTBIN | string | 15 | N | <blank> | Assembly receipts bin
MATERIALISSUEBIN | string | 15 | N | <blank> | Material issues bin
MORECEIPTBIN | string | 15 | N | <blank> | Manufacturing receipts bin
REPAIRISSUESBIN | string | 15 | N | <blank> | Repair issues bin
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateItemVendors>*

Element name | Data type | Length | Required | Default | Description
ITEMNMBR | string | 30 | Y | Not applicable | Item number
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VNDITNUM | string | 30 | N | <blank> | Vendor item number
QTYRQSTN | number | 21 | N | 0 | Quantity requisitioned
AVRGLDTM | i4 | 4 | N | 0 | Average lead time
NORCTITM | i4 | 2 | N | 0 | Number of receipts for item
MINORQTY | number | 21 | N | 0 | Minimum order quantity
MAXORDQTY | number | 21 | N | 0 | Maximum order quantity
ECORDQTY | number | 21 | N | 0 | Economic order quantity
VNDITDSC | string | 100 | N | <blank> | Vendor item description
Last_Originating_Cost | number | 21 | N | 0.01 | Last originating cost
Last_Currency_ID | string | 15 | N | <blank> | Last currency ID
FREEONBOARD | i4 | 2 | N | 1 | Free on board: 1=None; 2=Origin; 3=Destination
PRCHSUOM | string | 8 | N | <blank> | Purchasing unit of measure
PLANNINGLEADTIME | i4 | 2 | N | 0 | Planning lead time
ORDERMULTIPLE | number | 21 | N | 1 | Order multiple
MNFCTRITMNMBR | string | 30 | N | <blank> | Manufacturer’s item
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow item vendor information to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateItemVendors> node uses field level updates to provide update functionality.


<taCreateIVItemClass>

Element Name | Datatype | Length | Required | Default | Description
ITMCLSCD | string | 10 | Y | Not applicable | Item class ID
ITMCLSDC | string | 30 | Y | Not applicable | Item class description
DEFLTCLS | i4 | 1 | N | 0 | Default class: 0=False; 1=True
ITEMTYPE | i4 | 2 | N | 1 | Item type: 1=Sales inventory; 2=Discontinued; 3=Kit; 4=Miscellaneous charges; 5=Services; 6=Flat fee
ITMTRKOP | i4 | 2 | N | 1 | Item tracking option: 1=None; 2=Serial numbers; 3=Lots
LOTTYPE | string | 10 | N | <blank> | Lot category
LOTEXPWARN | i4 | 1 | N | 0 | Lot Expiration Warn: 0 = no warning 1 = warnings enabled If the item is not lot number tracked, the value of this element is not used.
LOTEXPWARN DAYS | i4 | 2 | N | 0 | Days Before Lot Expires: Valid entries equal 0 - 999. If LOTEXPWARN is 0 then LOTEXPWARNDAYS always defaults to 0. If the item is not lot number tracked, the value of this element is not used.
KPERHIST | i4 | 1 | N | 0 | Keep period history: 0=False; 1=True
KPTRXHST | i4 | 1 | N | 0 | Keep transaction history: 0=False; 1=True
KPCALHST | i4 | 1 | N | 0 | Keep calendar history: 0=False; 1=True
KPDSTHST | i4 | 1 | N | 0 | Keep distribution history: 0=False; 1=True
ALWBKORD | i4 | 1 | N | 0 | Allow back orders: 0=False; 1=True
ITMGEDSC | string | 10 | N | <blank> | Item generic description
TAXOPTNS | i4 | 2 | N | 2 | Sales tax options: 1=Taxable; 2=Nontaxable
ITMTSHID | string | 15 | N | <blank> | Sales tax schedule ID
Purchase_Tax_Options | i4 | 2 | N | 2 | Purchase tax options: 1=Taxable; 2=Nontaxable; 3=Base on vendor
Purchase_Item_Tax_Schedu | string | 15 | N | <blank> | Purchase tax schedule ID
UOMSCHDL | string | 11 | N | <blank> | Unit of measure schedule ID
VCTNMTHD | i4 | 2 | N | 1 | Valuation method: 1=FIFO perpetual; 2=LIFO perpetual; 3=Average perpetual; 4=FIFO periodic; 5=LIFO periodic
USCATVLS_1 | string | 10 | N | <blank> | User defined 1
USCATVLS_2 | string | 10 | N | <blank> | User defined 2
USCATVLS_3 | string | 10 | N | <blank> | User defined 3
USCATVLS_4 | string | 10 | N | <blank> | User defined 4
USCATVLS_5 | string | 10 | N | <blank> | User defined 5
USCATVLS_6 | string | 10 | N | <blank> | User defined 6
DECPLQTY | i4 | 2 | N | 1 | Decimal places quantity: 1=0; 2=1; 3=2; 4=3; 5=4; 6=5
Inventory_Acct | string | 75 | N | <blank> | Inventory account
Inventory_Offset_Acct | string | 75 | N | <blank> | Inventory offset account
Cost_of_Goods_Sold_Acct | string | 75 | N | <blank> | Cost of goods sold account
Sales_Acct | string | 75 | N | <blank> | Sales account
Markdowns_Acct | string | 75 | N | <blank> | Markdowns account
Sales_Returns_Acct | string | 75 | N | <blank> | Sales returns account
In_Use_Acct | string | 75 | N | <blank> | In use account
In_Service_Acct | string | 75 | N | <blank> | In service account
Damaged_Acct | string | 75 | N | <blank> | Damaged account
Variance_Acct | string | 75 | N | <blank> | Variance account
Drop_Ship_Items_Acct | string | 75 | N | <blank> | Drop ship items account
Purchase_Price_Variance_Acct | string | 75 | N | <blank> | Purchase price variance account
Unrealized_Purchase_Price_Variance_Acct | string | 75 | N | <blank> | Unrealized purchase price variance account
Inventory_Returns_Acct | string | 75 | N | <blank> | Inventory returns account
Assembly_Variance_Acct | string | 75 | N | <blank> | Assembly variance account
PRCLEVEL | string | 10 | N | <blank> | Price level
PriceGroup | string | 10 | N | <blank> | Price group
PRICMTHD | i4 | 2 | N | 1 | Price method: 1=Currency amount; 2=Percentage of list price; 3=Percentage mark-up of current cost; 4=Percentage mark-up of standard cost; 5=Percentage margin of current cost; 6=Percentage margin of standard cost
Revalue_Inventory | i4 | 1 | N | 1 | Revalue inventory: 0=False; 1=True
Tolerance_Percentage | i4 | 4 | N | 0 | Tolerance percentage
UseQtyOverageTolerance | i4 | 1 | N | 0 | Use quantity overage tolerance: 0=Do not use; 1=Use
UseQtyShortageTolerance | i4 | 1 | N | 0 | Use quantity shortage tolerance: 0=Do not use; 1=Use
QtyOverTolerancePercent | i4 | 4 | N | 0 | Quantity over tolerance percent: Provide a value of 0 - 99999. For example, 99999 equals 99.999.
QtyShortTolerancePercent | i4 | 4 | N | 0 | Quantity short tolerance percent: Provide a value of 0 - 99999. For example, 99999 equals 99.999.
USRDEFND1 | string | 50 | N | <blank> | User defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateKitItemRcd>

Element name | Data type | Length | Required | Default | Description
ITEMNMBR | string | 30 | Y | Not applicable | Item number
CMPTITNM | string | 30 | Y | Not applicable | Component item number
CMPITUOM | string | 8 | Y | Not applicable | Component unit of measure
CMPITQTY | number | 21 | N | 0 | Component quantity
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateLeaseCompany>

Element name | Data type | Length | Required | Default | Description
LEASECOMPID | string | 15 | Y | Not applicable | Lease company ID
VENDORID | string | 15 | N | <blank> | Vendor ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateLocalTax>*

Element name | Data type | Length | Required | Default | Description
LOCALTAX | string | 6 | Y | Not applicable | Local tax
DSCRIPTN | string | 30 | Y | Not applicable | Local tax description
LCLTXCAL_1 | i4 | 2 | N | 0 | Local tax 1: 1=Subtract exemption; 2=Check minimum annualized taxable wages; 3=Apply tax rate; 4=Apply tax table; 5=Subtract flat tax amount; 6=Check maximum withholding; 7=Check minimum YTD taxable wages; 8=Subtract standard deduction; 9=Check maximum YTD taxable wages
LCLTXCAL_2 | i4 | 2 | N | 0 | Local tax 2: 1=Subtract exemption; 2=Check minimum annualized taxable wages; 3=Apply tax rate; 4=Apply tax table; 5=Subtract flat tax amount; 6=Check maximum withholding; 7=Check minimum YTD taxable wages; 8=Subtract standard deduction; 9=Check maximum YTD taxable wages
LCLTXCAL_3 | i4 | 2 | N | 0 | Local tax 3: 1=Subtract exemption; 2=Check minimum annualized taxable wages; 3=Apply tax rate; 4=Apply tax table; 5=Subtract flat tax amount; 6=Check maximum withholding; 7=Check minimum YTD taxable wages; 8=Subtract standard deduction; 9=Check maximum YTD taxable wages
LCLTXCAL_4 | i4 | 2 | N | 0 | Local tax 4: 1=Subtract exemption; 2=Check minimum annualized taxable wages; 3=Apply tax rate; 4=Apply tax table; 5=Subtract flat tax amount; 6=Check maximum withholding; 7=Check minimum YTD taxable wages; 8=Subtract standard deduction; 9=Check maximum YTD taxable wages
LCLTXCAL_5 | i4 | 2 | N | 0 | Local tax 5: 1=Subtract exemption; 2=Check minimum annualized taxable wages; 3=Apply tax rate; 4=Apply tax table; 5=Subtract flat tax amount; 6=Check maximum withholding; 7=Check minimum YTD taxable wages; 8=Subtract standard deduction; 9=Check maximum YTD taxable wages
EXMTAMNT | number | 21 | N | 0 | Exemption amount
MNTXBLWG | number | 21 | N | 0 | Minimum taxable wages
MYTDTXWG | number | 21 | N | 0 | Minimum/Maximum YTD taxable wages
LCLTAXRT | number | 21 | N | 0 | Local tax rate
LCLTXAMT | number | 21 | N | 0 | Local tax amount
MAXPERYR | number | 21 | N | 0 | Maximum per year
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
STDDMTHD | i4 | 2 | N | 0 | Standard deduction method
STDDPCNT | number | 21 | N | 0 | Standard deduction percentage
STDDEDAM | number | 21 | N | 0 | Standard deduction amount
STDEDMAX | number | 21 | N | 0 | Standard deduction maximum
STDEDMIN | number | 21 | N | 0 | Standard deduction minimum
TAXTYPE | i4 | 2 | N | 4 | Tax type: 1=City income tax; 2=County income tax; 3=School district income tax; 4=Other income tax
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateLocalTax> node uses field level updates to provide update functionality.


<taCreateLocalTaxDetail>

Element name | Data type | Length | Required | Default | Description
LOCALTAX | string | 6 | Y | Not applicable | Local tax
TXBRULMT | number | 21 | N | 0 | Tax bracket upper limit
TXBRKTAM | number | 21 | N | 0 | Tax bracket amount
RXBRKTRT | number | 21 | N | 0 | Tax bracket rate
TXBREXWG | number | 21 | N | 0 | Tax bracket excess wages
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateLocation>*

Element name | Data type | Length | Required | Default | Description
LOCATNID | string | 6 | Y | Not applicable | Location ID
LOCATNNM | string | 30 | Y | Not applicable | Location description
ADRCNTCT | string | 60 | N | <blank> | Contact
ADDRESS1 | string | 60 | N | <blank> | Address 1
ADDRESS2 | string | 60 | N | <blank> | Address 2
ADDRESS3 | string | 60 | N | <blank> | Address 3
CITY | string | 35 | N | <blank> | City
COUNTY | string | 60 | N | <blank> | County
STATE | string | 29 | N | <blank> | State
ZIPCODE | string | 10 | N | <blank> | ZIP Code
COUNTRY | string | 60 | N | <blank> | Country
PHONE1 | string | 20 | N | <blank> | Phone number 1
PHONE2 | string | 20 | N | <blank> | Phone number 2
PHONE3 | string | 20 | N | <blank> | Phone number 3
FAXNUMBER | string | 20 | N | <blank> | Fax number
CCode | string | 6 | N | <blank> | Country code
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateLocation> node uses field level updates to provide update functionality.


<taCreateLocationID>

Element name | Data type | Length | Required | Default | Description
LOCATNID | string | 15 | Y | Not applicable | Location ID
STATEDESCR | string | 30 | N | <blank> | State description
COUNTYDESCR | string | 30 | N | <blank> | County description
CITYDESCR | string | 30 | N | <blank> | City description
STATEABBREV | string | 2 | N | <blank> | State abbreviation
STATECD | string | 2 | N | <blank> | State code
COUNTYCODE | string | 3 | N | <blank> | County code
CITYCODE | string | 4 | N | <blank> | City code
LASTMNTDDATE | datetime | 16 | N | Default from setup | Create date
LASTMNTDUSERID | string | 15 | N | <blank> | User ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateLockbox>

Element name | Data type | Length | Required | Default | Description
LockBoxID | string | 15 | Y | Not applicable | Lockbox ID
LockboxDescription | string | 30 | Y | Not applicable | Lockbox description
CHEKBKID | string | 15 | Y | Not applicable | Checkbook ID
STRGA255 | string | 255 | Y | Not applicable | Location of lockbox file
paLockboxFormatType | i4 | 2 | N | 1 | Lockbox format type (optional/required): 1=Single line; 2=Multiple line
XPRTFTYP | i4 | 2 | N | 1 | File format type (optional/required): 1=Fixed length; 2=Tab delimited; 3=Comma delimited
DECPLCUR | i4 | 2 | N | 1 | Decimal places on amounts
PaApplyMethod | i4 | 2 | N | 1 | Lockbox apply method
OmitStartRecords | i4 | 4 | N | 0 | Omit start records
OmitLastRecords | i4 | 4 | N | 0 | Omit last records
paHeaderRowIndicator | string | 10 | N | <blank> | Header row indicator
paDeailRowIndicator | string | 10 | N | <blank> | Detail row indicator
CREATDDT | datetime | 16 | N | <blank> | Create date
MODIFDT | datetime | 16 | N | <blank> | Modified date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateLockboxBankDetails>

Element name | Data type | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
BANKNAME | string | 30 | N | <blank> | Bank name
BNKBRNCH | string | 20 | N | <blank> | Bank branch
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateLotCategory>

The five lot attribute description (LTATRDSC) elements are not labeled as optional or required. You must always populate one of the LTATRDSC elements. However, it does not matter which element you populate. After you populate the one required LTATRDSC element, populating the remaining LTATRDSC element is optional.

Element name | Data type | Length | Required | Default | Description
LOTTYPE | string | 10 | Y | Not applicable | Lot category
LTATRDSC_1 | string | 15 | * | <blank> | Lot attribute description 1
LTATRDSC_2 | string | 15 | * | <blank> | Lot attribute description 2
LTATRDSC_3 | string | 15 | * | <blank> | Lot attribute description 3
LTATRDSC_4 | string | 15 | * | <blank> | Lot attribute description 4
LTATRDSC_5 | string | 15 | * | <blank> | Lot attribute description 5
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateManualCheckHeaderInsert>

Element name | Datatype | Length | Required | Default | Description
MLCHKTYP | i4 | 2 | N | 0 | Manual check type: 0=Manual check type; 1=Adjustment; 2=Beginning balance
PYADNMBR | i4 | 4 | Y | Not applicable | Payment/Adjustment number
BACHNUMB | string | 15 | Y | Not applicable | Batch number
CHEKBKID | string | 15 | N | <blank> | Checkbook ID; pulls from UPR40200 if not populated
CHEKNMBR | string | 20 | N | <blank> | Check number; pulls from CM00100 if not populated
POSTEDDT | datetime | 16 | N | <blank> | Posted date
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
USEGPPYADNMBR | i4 | 4 | N | 1 | Use GP default payment/adjustment number: 0=False; 1=True (this number replaces PYADNMBR)
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USERID | string | 15 | N | <blank> | User ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateManualCheckLineInsert>

Element name | Data type | Length | Required | Default | Description
MLCHKTYP | i4 | 2 | N | 0 | Manual check type: 0=Manual check type; 1=Adjustment; 2=Beginning balance
PYADNMBR | i4 | 4 | Y | Not applicable | Payment/adjustment number
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
MLTRXNBR | string | 15 | N | <blank> | Manual transaction number
MLTRXTYP | string | 20 | N | <blank> | Manual transaction type: 1=Pay code; 2=Deduction; 3=Benefit; 4=Federal tax; 5=FICA Social Security tax; 6=FICA Medicare tax; 7=State tax; 8=Local tax; 9=Pay advance; 10=Withhold advance; 11=FICA Social Security/tips; 12=FICA Medicare/tips; 13=Federal tax/tips; 14=Uncollected FICA Social Security; 15=Uncollected FICA Medicare
UPRTRXCD | string | 16 | N | <blank> | UPR transaction code; this element is optional if passing any of the transaction types listed, but users must pass a valid transaction code on any transaction type not listed: 4=Federal tax; 5=FICA Social Security tax; 6=FICA Medicare tax; 11=FICA Social Security/tips; 12=FICA Medicare/tips; 13=Federal tax/tips; 14=Uncollected FICA Social Security; 15=Uncollected FICA Medicare
TRXBEGDT | string | 15 | Y | Not applicable | Transaction begin date
TRXENDDT | i4 | 4 | N | 1 | Transaction end date
MLTRXAMT | i4 | 4 | N | 1 | Manual transaction amount
MLTRXHRS | i4 | 4 | N | 1 | Manual transaction hours
RECEIPTS | i4 | 4 | N | 1 | Receipts
DEPRTMNT | i4 | 4 | N | 1 | Department; if blank it will pull from UPR00100
JOBTITLE | i4 | 4 | N | 1 | Job title; if blank will pull from UPR00100
STATECD | i4 | 4 | N | 1 | State code
LOCALTAX | i4 | 4 | N | 1 | Local tax code
WRKRCOMP | i4 | 4 | N | 1 | Workers' compensation code
SUTASTAT | i4 | 4 | N | 1 | SUTA state
DAYSWRDK | i4 | 4 | N | 1 | Days worked
WKSWRKD | i4 | 4 | N | 1 | Weeks worked
SHFTCODE | i4 | 4 | N | 1 | Shift code
TXBLWAGS | number | 21 | N | 0 | Taxable wages Valid for MLTRXTYP types of 4=Federal tax; 5=FICA social security tax; 6=FICA medicare tax; 7=State tax; 8=Local tax; 11=FICA social security/tips; 12=Medicare/tips; 13=Federal tax/tips
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USERID | string | 15 | N | <blank> | User ID
EFICAMT | number | 21 | N | 0 | Employer FICA amount Valid for MLTRXTYP values of: 5=FICA social security tax; 6=FICA medicare tax; 11=FICA social security/tips; 12=Medicare/tips;
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateParentID>*

Element name | Datatype | Length | Required | Default | Description
CPRCSTNM | string | 15 | Y | Not applicable | Corporate customer number
NAALLOWRECEIPTS | i4 | 1 | N | 1 | Allow receipts entry for children of the national account
NACREDITCHECK | i4 | 1 | N | 0 | Base credit check on consolidated national account
NAFINANCECHARGE | i4 | 1 | N | 0 | Base finance charge on consolidated national account
NAHOLDINACTIVE | i4 | 1 | N | 0 | Apply hold/inactive status of parent across national account
NADEFPARENTVEN | i4 | 1 | N | 0 | Default parent vendor for children refund checks
UpdateIfExists | i4 | 1 | N | 0 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taCreateParentID> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taCreatePayCode>*

Element name | Data type | Length | Required | Default | Description
PAYRCORD | string | 6 | Y | Not applicable | Deduction
DSCRIPTN | string | 30 | Y | Not applicable | Deduction description
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
PAYTYPE | i4 | 2 | N | 1 | Pay type: 1=Hourly; 2=Salary; 3=Piecework; 4=Commission; 5=Business expense; 6=Overtime; 7=Double time; 8=Vacation; 9=Sick; 10=Holiday; 11=Pension; 12=Other; 13=Earned income credit; 14=Charged tips; 15=Reported tips; 16=Minimum wage balance
BSPAYRCD | string | 6 | N | <blank> | Base pay record
PAYRTAMT | number | 21 | N | 0 | Pay rate amount
PAYUNIT | string | 25 | N | <blank> | Pay unit
PAYUNPER | i4 | 2 | N | 1 | Pay unit period: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Quarterly; 6=Semiannually; 7=Annually; 8=Daily/miscellaneous
PAYPEROD | i4 | 2 | N | 1 | Pay period: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Quarterly; 6=Semiannually; 7=Annually; 8=Daily/miscellaneous
MXPYPPER | number | 21 | N | 0 | Max pay per year
TipType | i4 | 2 | N | 1 | Tip type: 1=Directly; 2=Indirectly
PAYADVNC | number | 21 | N | 0 | Pay advance
RPTASWGS | i4 | 1 | N | 0 | Report as wages: 0=False; 1=True
W2BXNMBR | i4 | 2 | N | 0 | W–2 box number
W2BXLABL | string | 6 | N | <blank> | W–2 box label
W2BXNMBR2 | i4 | 2 | N | <blank> | W-2 Box Number 2
W2BXLABL2 | string | 6 | N | <blank> | W-2 Box Label 2
W2BXNMBR3 | i4 | 2 | N | 0 | W-2 Box Number 3
W2BXLABL3 | string | 6 | N | <blank> | W-2 Box Label 3
W2BXNMBR4 | i4 | 2 | N | 0 | W-2 Box Number 4
W2BXLABL4 | string | 6 | N | <blank> | W-2 Box Label 4
SBJTFDTX | i4 | Not applicable | Not applicable | Not applicable | Subject to federal tax: 0=False; 1=True
SBJTSSEC | i4 | 1 | N | 1 | Subject to Social Security: 0=False; 1=True
SBJTMCAR | i4 | 1 | N | 1 | Subject to Medicare: 0=False; 1=True
SBJTSTTX | i4 | 1 | N | 1 | Subject to state tax: 0=False; 1=True
SBJTLTAX | i4 | 1 | N | 1 | Subject to local tax: 0=False; 1=True
SBJTFUTA | i4 | 1 | N | 1 | Subject to FUTA tax: 0=False; 1=True
SBJTSUTA | i4 | 1 | N | 1 | Subject to SUTA tax: 0=False; 1=True
FFEDTXRT | number | 21 | N | 0 | Flat federal tax rate
FLSTTXRT | number | 21 | N | 0 | Flat state tax rate
ACRUVACN | i4 | 1 | N | 0 | Accrue vacation: 0=False; 1=True
ACRUSTIM | i4 | 1 | N | 0 | Accrue sick time: 0=False; 1=True
DATAENTDFLT | i4 | 1 | N | 0 | Data entry default: 0=False; 1=True
SHFTCODE | string | 6 | N | <blank> | Shift code
PAYFACTR | number | 21 | N | 0 | Pay factor
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User Defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreatePayCode> node uses field level updates to provide update functionality.


<taCreatePayrollBatchHeaderInsert>*

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number
UPRBCHOR | i4 | 2 | N | 2 | UPR batch origin: 1=Computer checks; 2=Manual checks
BCHCOMNT | string | 60 | N | <blank> | Batch comment
UPRBCHFR | i4 | 2 | N | 1 | Batch frequency: 1=Single use; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Semiannually; 8=Annually; 9=Miscellaneous
POSTEDDT | datetime | 16 | N | <blank> | Posted date
CNTRLTRX | i4 | 4 | N | 0 | Control transaction count
CTRLEMPCT | i4 | 2 | N | 0 | Control employee count
UpdateIfExists | i4 | 1 | N | 1 | Updated if exists: 0=False; 1=True
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreatePayrollBatchHeaderInsert> node uses field level updates to provide update functionality.


<taCreatePhysicalLocationID>

Element name | Data type | Length | Required | Default | Description
Physical_Location_ID | string | 15 | Y | Not applicable | Physical location ID
Physical_Location_Desc | string | 30 | N | <blank> | Physical location description
LOCATNID | string | 15 | N | <blank> | Location ID
Last_Inventory_Date | datetime | 16 | N | <blank> | Last inventory date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreatePlanner>

Element name | Data type | Length | Required | Default | Description
PLANNERID | string | 3 | Y | Not applicable | Planner ID
PLANNERNAME | string | 30 | Y | Not applicable | Planner name
PLANNERNAME | string | 30 | Y | Not applicable | Planner name
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreatePosition>*

Element name | Data type | Length | Required | Default | Description
JOBTITLE | string | 6 | Y | Not applicable | Job title/position code
DSCRIPTN | string | 30 | Y | Not applicable | Department description
EEOCLASS_I | i4 | 2 | N | 0 | EEO Clas HRP Option when it is loaded 1=First/Mid-Level Officials and Mgrs 2=Professionals, 3=Technicians 4=Sales Workers, 5=Administrative Support Workers, 6=Craft Workers 7=Operatives, 8=Laborers and Helpers, 9=Service Workers 10=Exec/Sr Level Officials and Mgrs
FLSASTATUS | i4 | 2 | N | 0 | FLSA Status HRP Option when it is loaded 1=Exempt, 2=Non-Exempt Salaried 3=Non-Exempt Hourly
REPORTSTOPOS | string | 7 | N | <blank> | Reports to Position HRP option when it is loaded
REVIEWSETUPNAME_I | string | 31 | N | <blank> | Review Type HRP Option when it is loaded
SKILLSET_I | string | 31 | N | <blank> | Default Skill Set HRP Option when it is loaded
TXTFIELD | string | 8000 | N | <blank> | Position Description HRP Option when it is loaded
CHANGEBY_I | string | 15 | N | <blank> | Change by
CHANGEDATE_I | datetime | 16 | N | Default from setup | Change date
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreatePosition> node uses field level updates to provide update functionality.


<taCreateProcessHold>*

Element name | Data type | Length | Required | Default | Description
PRCHLDID | string | 15 | Y | Not applicable | Process hold ID
DSCRIPTN | string | 30 | N | <blank> | Process hold description
PASSWORD | string | 15 | N | <blank> | Process hold password
XFERPHOL | i4 | 1 | N | 0 | Transferring process hold
POSTPHOL | i4 | 1 | N | 0 | Posting process hold
FUFIPHOL | i4 | 1 | N | 0 | Fulfill process hold
PRINPHOL | i4 | 1 | N | 0 | Printing process hold
HOLDDATE | datetime | 16 | N | <blank> | Hold date
USER2ENT | string | 15 | N | <blank> | User ID
UpdateIfExists | i4 | 4 | N | 0 | Process hold master will be updated if it exists within parameters

* The default action for the <taCreateProcessHold> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taCreateProspect>

Element name | Datatype | Length | Required | Default | Description
PROSPID | string | 15 | Y | Not applicable | Prospect ID
CUSTNAME | string | 65 | N | <blank> | Customer name
CNTCPRSN | string | 60 | N | <blank> | Contact person
ADDRESS1 | string | 60 | N | <blank> | Address one
ADDRESS2 | string | 60 | N | <blank> | Address two
ADDRESS3 | string | 60 | N | <blank> | Address three
CITY | string | 35 | N | <blank> | City
STATE | string | 29 | N | <blank> | State
ZIP | string | 10 | N | <blank> | Zip code
COUNTRY | string | 60 | N | <blank> | Country
CUSTCLAS | string | 15 | N | <blank> | Customer class
PHONE1 | string | 21 | N | <blank> | Phone one
PHONE2 | string | 21 | N | <blank> | Phone two
PHONE3 | string | 21 | N | <blank> | Phone three
PRCLEVEL | string | 10 | N | <blank> | Price level
FAX | string | 21 | N | <blank> | Fax number
SHIPMTHD | string | 15 | N | <blank> | Shipping method
TAXSCHID | string | 15 | N | <blank> | Tax schedule ID
USERDEF1 | string | 20 | N | <blank> | User defined one
USERDEF2 | string | 20 | N | <blank> | User defined two
USER2ENT | string | 15 | N | <blank> | User who entered
CREATDDT | datetime | 16 | N | <blank> | Create date
MODIFDT | datetime | 16 | N | <blank> | Modified date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateRequisitions>*

Element name | Datatype | Length | Required | Default | Description
REQUISITIONNUMBER_I | i4 | 4 | Y | Not applicable | Requistion number
REQSTATUS_I | i4 | 2 | Y | Not applicable | Status 1=Open, 2=Closed, 3=On Hold 4=Immediate
DEPARTMENTCODE_I | string | 7 | Y | Not applicable | Department
POSITIONCODE_I | string | 7 | Y | Not applicable | Position
COMPANYCODE_I | string | 5 | Y | Not applicable | Company code
DIVISIONCODE_I | string | 7 | N | <blank> | Division
MANAGER_I | string | 31 | N | <blank> | Manager
SUPERVISORCODE_I | string | 7 | N | <blank> | Supervisor
STRTDATE | datetime | 16 | N | <blank> | Internal post date
ENDDATE | datetime | 16 | N | <blank> | Internal close date
OPENINGDATE_I | datetime | 16 | N | <blank> | Opening date
RECRUITER_I | string | 31 | N | <blank> | Recruiter
RECRUITMENT_I | i4 | 2 | N | <blank> | Job Title 0 = Internal 1 = External
ADVERTISINGLIST_I_1 | string | 15 | N | <blank> | Advertising
ADVERTISINGLIST_I_2 | string | 15 | N | <blank> | Advertising
ADVERTISINGLIST_I_3 | string | 15 | N | <blank> | Advertising
ADVERTISINGLIST_I_4 | string | 15 | N | <blank> | Advertising
ADVERTISINGLIST_I_5 | string | 15 | N | <blank> | Advertising
POSITIONSAVAILABLE_I | i4 | 2 | N | <blank> | Positions available
POSITIONSFILLED_I | i4 | 2 | N | <blank> | Positions filled
APPLICANTSAPPLIED_I | i4 | 2 | N | <blank> | Applicants
APPSINTERVIEWED_I | i4 | 2 | N | <blanke> | Applicants interviewed
ADVERTISINGCOSTS_I | number | 21 | N | <blank> | Advertising costs
RECRUITERSFEES_I | number | 21 | N | <blank> | Recruiter fees
CHANGEBY_I | string | 15 | N | <blank> | Changed by
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow Department data to be updated if it exists. 0=Create only; 1=Update if exists; 2=Create, do NOT update(no error)
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateRequisitions> node uses field level updates to provide update functionality.


<taCreateRetirementCode>

Element name | Data type | Length | Required | Default | Description
RETIREMENTCODE | string | 8 | Y | Not applicable | Retirement code
RETIRECODEDESCR | string | 30 | N | <blank> | Retirement code description
LASTMNTDDATE | datetime | 16 | N | Default from setup | Last maintained date
LASTMNTDUSERID | string | 15 | N | <blank> | Last maintained user ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateSalesperson>*

Element name | Data type | Length | Required | Default | Description
SLPRSNID | string | 15 | Y | Not applicable | Salesperson ID
SALSTERR | string | 15 | Y | Not applicable | Territory ID
EMPLOYID | string | 15 | N | <blank> | Employee ID
VEDORID | string | 15 | N | <blank> | Vendor ID
SLPRSNFN | string | 15 | N | <blank> | Salesperson first name
SPRSNSMN | string | 15 | N | <blank> | Salesperson middle name
SPRSNSLN | string | 20 | N | <blank> | Salesperson last name
ADDRESS1 | string | 60 | N | <blank> | Address ID 1
ADDRESS2 | string | 60 | N | <blank> | Address ID 2
ADDRESS3 | string | 60 | N | <blank> | Address ID 3
CITY | string | 35 | N | <blank> | City
STATE | string | 29 | N | <blank> | State
ZIP | string | 10 | N | <blank> | ZIP Code
COUNTRY | string | 60 | N | <blank> | Country
PHONE1 | string | 21 | N | 00000000000000 | Phone1
PHONE2 | string | 21 | N | 00000000000000 | Phone2
PHONE3 | string | 21 | N | 00000000000000 | Phone3
FAX | string | 21 | N | 00000000000000 | Fax
INACTIVE | i4 | 1 | N | 0 | Inactive salesperson
COMMCODE | string | 15 | N | <blank> | Commission code
COMPRCNT | number | 21 | N | 0 | Commission percent
STDCPRCT | number | 21 | N | 0 | Standard commission percent
COMAPPTO | i4 | 2 | N | 0 | Commission applied: Apply to sales=0; Invoice=1
COSTTODT | number | 21 | N | 0 | Cost to date
CSTLSTYR | number | 21 | N | 0 | Cost last year
TTLCOMTD | number | 21 | N | 0 | Total commissions to date
TTLCOMLY | number | 21 | N | 0 | Total commissions last year
COMSLTDT | number | 21 | N | 0 | Commissioned sales to date
COMSLLYR | number | 21 | N | 0 | Commissioned sales last year
NCOMSLTD | number | 21 | N | 0 | Non-commissioned sales to date
NCOMSLYR | number | 21 | N | 0 | Non-commissioned sales last year
KPCALHST | i4 | 1 | N | 1 | Keep calendar history
KPERHIST | i4 | 1 | N | 1 | Keep fiscal year history
MODIFDT | datetime | 16 | N | <blank> | Modified date
CREATDDT | datetime | 16 | N | <blank> | Create date
COMMDEST | i4 | 2 | N | 0 | Commission destination
UpdateIfExists | i4 | 1 | N | 0 | Flag to allow data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | Use-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taCreateSalesperson> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taCreateShiftCode>*

Element name | Data type | Length | Required | Default | Description
SHFTCODE | string | 6 | Y | Not applicable | Shift code
DSCRIPTN | string | 30 | Y | Not applicable | Department description
SHFTTYPE | i4 | 2 | N | 0 | Shift type: 0=Amount; 1=Percent
SHFTAMT | number | 21 | N | 0 | Shift amount
SHFTPCT | number | 21 | N | 0 | Shift percent
INACTIVE | i4 | 1 | N | 0 | Inactive: 0=False; 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateShiftCode> node uses field level updates to provide update functionality.


<taCreateShippingMethod>*

Element name | Data type | Length | Required | Default | Description
SHIPMTHD | string | 15 | Y | Not applicable | Shipping method
SHMTHDSC | string | 30 | N | <blank> | Description
PHONNAME | string | 14 | N | <blank> | Phone number
CONTACT | string | 60 | N | <blank> | Contact
CARRACCT | string | 15 | N | <blank> | Carrier account
CARRIER | string | 30 | N | <blank> | Carrier
SHIPTYPE | i4 | 2 | N | 1 | Shipping type: 0=Pickup; Delivery
UpdateIfExists | i4 | 1 | N | 0 | Flag to allow data to be updated if it exists: 0=No; 1=Yes
USERID | string | 15 | N | <blank> | User ID
CREATDDT | datetime | 16 | N | Default from setup | Create date
MODIFDT | datetime | 16 | N | Default from setup | Modified date
NOTETEXT | string | 8000 | N | Default from setup | Note text
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taCreateShippingMethod> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taCreateSiteBin>

Element name | Data type | Length | Required | Default | Description
LOCNCODE | string | 10 | Y | Not applicable | Location code/site ID
BIN | string | 15 | Y | Not applicable | Bin
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateSkills>*

Element name | Datatype | Length | Required | Default | Description
SKILLTITLE_I | string | 31 | Y | Not applicable | Skill
COMPENSATIONVALUE_I | number | 21 | N | 0 | Compensation value
COMPENSATIONPERIOD_I | i4 | 2 | N | 0 | Compensation Period 0 = Undefined, 1 = Hourly, 2 = Weekly, 3 = Bi-Weekly, 4 = Semi-Monthly, 5 = Monthly, 6 = Quarterly, 7 = Semiannually 8 = Annually 9 = Daily/Miscellaneous
UpdateIfExists | i4 | 1 | N | 1 | Update If Exists Flag 0=Create only; 1=Update if exists; 2=Create, do NOT update(no error)
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateSkills> node uses field level updates to provide update functionality.


<taCreateSkillSets>*

Element name | Datatype | Length | Required | Default | Description
SKILLSET_I | string | 31 | Y | Not applicable | Skill set
UpdateIfExists | i4 | 2 | N | 0 | Update If Exists 0 = False 1 = True
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateSkillSets> node uses field level updates to provide update functionality.


<taCreateSkillSetsLine>*

Element name | Datatype | Length | Required | Default | Description
SKILLSET_I | string | 31 | Y | Not applicable | Skill set
SKILLTITLE_I | string | 31 | Y | Not applicable | Skill
UpdateIfExists | i4 | 2 | N | 0 | Update If Exists 0 = False 1 = True
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateSkillSetsLine> node uses field level updates to provide update functionality.


<taCreateSopPaymentInsertRecord>

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Invoice number
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
CUSTNAME | string | 64 | N | <blank> | Customer name
DOCDATE | datetime | 16 | N | <blank> | Document date
DOCAMNT | number | 21 | N | 0 | Payment amount; required and used only when Action=1 or 3
CHEKBKID | string | 15 | N | <blank> | Checkbook ID
CARDNAME | string | 15 | N | <blank> | Credit card name—value if credit card transaction
CHEKNMBR | string | 20 | N | <blank> | Check number—value if check
RCTNCCRD | string | 20 | N | <blank> | Credit card number—value if credit card
AUTHCODE | string | 15 | N | <blank> | Authorization code—value if credit card
EXPNDATE | datetime | 16 | N | <blank> | Credit card expiration date
PYMTTYPE** | i4 | 4 | N | 1 | Payment types: 1=Cash deposit; 2=Check deposit; 3=Credit card deposit; 4=Cash payment; 5=Check payment; 6=Credit card payment
DOCNUMBR | string | 20 | N | <blank> | Payment number/cash receipt number; required if Action=2, SOPTYPE=2, and PYMTTYPE=(1, 2, or 3); required if Action=2 and SOPTYPE=3; required if Action=3, SOPTYPE=2, and PYMTTYPE=(1, 2, or 3)
Action | i4 | 2 | N | Default from setup | Default from setup: 1=New transaction/new payment; 3=Modify existing payment Must set to 2 manually; 2=Delete payment
SEQNUMBR | i4 | 4 | N | Default from setup | Sequence number; required if Action=1, SOPTYPE=2, and multiple PYMTTYPE=6 exist Required if Action=2, SOPTYPE=2, and PYMTTYPE=6 Required if Action=3 and DOCNUMBR and PYMTTYPE elements exist multiple times on document
MDFUSRID | string | 15 | N | <blank> | Modified user iD
VOIDDATE | datetime | 16 | N | <blank> | Void date
PROCESSELECTRONICALLY | i4 | 1 | N | 0 | Process Electronically 0 = False 1 = True
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

** The following are the valid payment type codes for each SOPTYPE:

SOPTYPE | PYMTTYPE
2 | 1=Cash deposit 2=Check deposit; 3=Credit card deposit 6=Credit card payment
3 | 4=Cash payment 5=Check payment 6=Credit card payment
4 | 4=Cash payment 5=Check payment 6=Credit card payment
5 | 1=Cash deposit 2=Check deposit; 3=Credit card deposit 6=Credit card payment

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateSOPTrackingInfo>

Element name | Data type | Length | Required | Default | Description
SOPNUMBE | string | 21 | Y | Not applicable | SOP number
SOPTYPE | i4 | 2 | Y | Not applicable | SOP type: 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
Tracking_Number | string | 40 | Y | Not applicable | Tracking number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateStructure>

Element name | Data type | Length | Required | Default | Description
STRUCTUREID | string | 30 | Y | Not applicable | Structure ID
STRUCTDESCR | string | 30 | N | <blank> | Structure ID description
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateSupervisor>*

Element name | Data type | Length | Required | Default | Description
SUPERVISORCODE | string | 6 | Y | Not applicable | Supervisor code
SUPERVISOR | string | 30 | Y | Not applicable | Supervisor description
EMPLOYID | string | 15 | N | <blank> | Employee ID
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
CHANGEBY | string | 15 | N | <blank> | Change by
CHANGEDATE | datetime | 16 | N | Default from setup | Change date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateSupervisor> node uses field level updates to provide update functionality.


<taCreateTerritory>

Element name | Data type | Length | Required | Default | Description
SALSTERR | string | 15 | Y | Not applicable | Territory ID
SLTERDSC | string | 30 | N | <blank> | Territory description
SLPRSNID | string | 15 | N | <blank> | Salesperson ID
STMGRFNM | string | 15 | N | <blank> | Sales territory manager's first name
STMGRMNM | string | 15 | N | <blank> | Sales territory manager's middle name
STMGRLNM | string | 20 | N | <blank> | Sales territory manager's last name
COUNTRY | string | 20 | N | <blank> | Country
COSTTODT | number | 21 | N | 0 | Cost to date
TTLCOMTD | number | 21 | N | 0 | Total commissions to date
TTLCOMLY | number | 21 | N | 0 | Total commissions last year
NCOMSLYR | number | 21 | N | 0 | Non-commissioned sales last year
COMSLLYR | number | 21 | N | 0 | Commissioned sales last year
CSTLSTYR | number | 21 | N | 0 | Cost last year
COMSLTDT | number | 21 | N | 0 | Commissioned sales to date
NCOMSLTD | number | 21 | N | 0 | Non-commissioned sales to date
KPCALHST | i4 | 1 | N | 1 | Keep calendar history: 0=No; 1=Yes
KPERHIST | i4 | 1 | N | 1 | Keep period history: 0=No; 1=Yes
MODIFDT | datetime | 16 | N | <blank> | Modified date
CREATDDT | datetime | 16 | N | <blank> | Create date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateTests>

Element name | Datatype | Length | Required | Default | Description
TEST_I | string | 31 | Y | Not applicable | Test
TESTCODE_I | string | 7 | Y | Not applicable | Test code
CHANGEBY_I | string | 15 | N | <blank> | Changed by
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateUpdateBatchHeaderRcd>

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch ID
BCHCOMNT | string | 60 | N | <blank> | Batch comment
SERIES | i4 | 4 | Y | Not applicable | 1=All; 2=Financial; 3=Sales; 4=Purchasing; 5=Inventory; 6=Payroll; 7=Project
GLPOSTDT | datetime | 16 | N | <blank> | General ledger posting date
BCHSOURC | string | 15 | Y | Not applicable | Batch source
DOCAMT | number | 21 | Y | Not applicable | Batch total
ORIGIN | i4 | 4 | Y | Not applicable | For GL: 1= General entry For IV: 1=Transaction entry; 2=Transfer entry For PM: 1=Transaction entry; 2=Computer check; 3=Manual payment For RM: 1=Transaction entry; 2=Cash receipts entry For SOP: 1=Sales transaction entry
NUMOFTRX | i4 | 4 | Y | Not applicable | Number of transactions
CHEKBKID | string | 15 | N | <blank> | Checkbook ID
CNTRLTOT | number | 21 | N | Default from setup | Expected total
CNTRLTRX | i4 | 4 | N | Default from setup | Number of transactions batch must contain before marked for posting.
POSTTOGL | i4 | 2 | N | 0 | Post to GL: Defaults to 0 if nothing is passed in. 0=False 1=True
PmtMethod | i4 | 2 | N | 0 | Payment method radio group
EFTFileFormat | i4 | 2 | N | 0 | EFT file format
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, populates requester shadow table)
BRKDNALL | i4 | 1 | N | 0 | Breakdown allocation
USERID | string | 15 | N | <blank> | User ID
BACHFREQ | i4 | 1 | N | Default from setup | Batch frequency; default is 1 for new batches or defaults to current value for existing batches: 1=Single use; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Bimonthly; 7=Quarterly; 8=Miscellaneous
RECPSTGS | i4 | 2 | N | Default from setup | Number of times a recurring batch should post for recurring posting: 0=Unlimited; this is valid with batch frequency, BACHFREQ, types 2-8 only; default is 0 for new recurring batches or defaults to current value for existing batches
MSCBDINC | i4 | 2 | N | Default from setup | Number of days to increment the transaction date if miscellaneous frequency, BACHFREQ =8, is selected for this batch; default is 0 for new batches or defaults to current value for existing batches; MSCBDINC is only valid with BACHFREQ =8
APPROVL | i4 | 1 | N | 0 | Batch Approval 0=False 1=True
APPRVLDT | datetime | 16 | N | <blank> | Batch approval date
APRVLUSERID | string | 15 | N | <blank> | Batch approval user ID
TRXSOURC | string | 25 | Y | <blank> | Transaction Source Required for Batch Approval
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taCreateVariableAllocationAccountRcd>*

Element name | Data type | Length | Required | Default | Description
ACTNUMST | string | 75 | N | <blank> | Account string
DISTACTNUMST | string | 75 | N | <blank> | Distribution account string
BREAKACTNUMST | string | 75 | N | <blank> | Breakdown account string
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateVariableAllocationAccountRcd> node uses field level updates to provide update functionality.


<taCreateVendorAddress>*

Element name | Data type | Length | Required | Default | Description
VENDORID | string | 15 | Y | Not applicable | Vendor ID
ADRSCODE | string | 15 | Y | Not applicable | Address ID
UPSZONE | string | 3 | N | <blank> | UPS zone
SHIPMTHD | string | 15 | N | <blank> | Shipping method
TAXSCHID | string | 15 | N | <blank> | Tax schedule
VNDCNTCT | string | 60 | N | <blank> | Contact person
ADDRESS1 | string | 60 | N | <blank> | Vendor address one
ADDRESS2 | string | 60 | N | <blank> | Vendor address two
ADDRESS3 | string | 60 | N | <blank> | Vendor address three
COUNTRY | string | 60 | N | <blank> | Vendor country
CITY | string | 35 | N | <blank> | Vendor city
STATE | string | 29 | N | <blank> | Vendor state
ZIPCODE | string | 10 | N | <blank> | Vendor ZIP Code/postal code
PHNUMBR1 | string | 21 | N | <blank> | Phone one
PHNUMBR2 | string | 21 | N | <blank> | Phone two
PHNUMBR3 | string | 21 | N | <blank> | Phone three
FAXNUMBR | string | 21 | N | <blank> | Fax
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow updates to vendor data: 0=No not update; 1=Update if exists
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
CCode | string | 6 | N | <blank> | Country code
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateVendorAddress> node uses field level updates to provide update functionality.


<taCreateWorkersCompensationCode>*

Element name | Data type | Length | Required | Default | Description
WRKRCOMP | string | 6 | Y | Not applicable | Workers' compensation code
STATECD | string | 2 | Y | Not applicable | State code
DSCRIPTN | string | 30 | Y | Not applicable | Department description
WKCMPMTH | i4 | 2 | N | 1 | Calculation method: 1=Percentage of gross; 2=Fixed amount; 3=Number of hours/units; 4= Days worked
WKCMPAMT | number | 21 | N | 0 | Workers' compensation amount
WKCMPUNT | number | 21 | N | 0 | Workers' compensation per unit
WKCMPCNT | number | 21 | N | 0 | Workers' compensation percent
WCMOTMTH | i4 | 2 | N | 0 | Workers' compensation overtime method: 0=Straight pay rate; 1=Overtime pay rate
WCWGLIMT | number | 21 | N | 0 | Workers' compensation wage limit
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to updated if it currently exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taCreateWorkersCompensationCode> node uses field level updates to provide update functionality.


<taDeleteApplicant>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination or if you are going to pass this instead of the LASTNAME and FIRSTNAME combination
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantApplication>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination or if you are going to pass this instead of the LASTNAME and FIRSTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Internal Sequence Number Required only if you are going to pass this instead of Requisition Number OR if you have multiple instances of the same Applicant and Requisition Number
REQUISITIONNUMBER_I | i4 | 4 | Y | Not applicable | Requisition Number Required only if you are not passing the Sequence Number
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantEducation>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination or if you are going to pass this instead of the LASTNAME and FIRSTNAME combination
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantEducationLine>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination or if you are going to pass this instead of the LASTNAME and FIRSTNAME combination
UNIVERSITY | string | 31 | Y | Not applicable | University
ISEQUENCENUMBER_I | i4 | 2 | Y | <blank> | Sequence Number Required only if you have the same applicants and same university on more then one record
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantInterview>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPINTTYPESTR_I | string | 21 | Y | Not applicable | Interview type
APPLYDATE_I | datetime | 16 | Y | Not applicable | Interview date
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you are passing Applicant Number and not LASTNAME and FIRSTNAME combination
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantReferences>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you want to pass Applicant Number and not pass LASTNAME and FIRSTNAME combination
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantReferencesLine>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
REFERENCENAME_I | string | 61 | Y | Not applicable | Reference name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you want to pass Applicant Number and not pass LASTNAME and FIRSTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | <blank> | Sequence Number Required only if you have the same applicants and same reference on more then one record
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantRequisitionsLine>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
REQUISITIONNUMBER_I | i4 | 4 | Y | Not applicable | Requisition number
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you want to pass Applicant Number and not pass LASTNAME and FIRSTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Sequence Number Required only if you have the same applicant and same requisition on more then one record
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantTests>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination or if you want to pass Applicant Number instead of FIRSTNAME and LASTNAME combination
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantTestsLine>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
TESTCODE_I | string | 7 | Y | Not applicable | Test code
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you pass Application Number instead of FIRSTNAME and LASTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Sequence Number Required only if you have the same applicants and same Test Code on more then one record
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 |  | N | User-defined field—developer use only
USRDEFND2 | string | 50 |  | N | User-defined field—developer use only
USRDEFND3 | string | 50 |  | N | User-defined field—developer use only
USRDEFND4 | string | 8000 |  | N | User-defined field—developer use only
USRDEFND5 | string | 8000 |  | N | User-defined field—developer use only


<taDeleteApplicantWorkHistory>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if passing Applicant Number and not FIRSTNAME LASTNAME combination
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction - 0=false,1=true - if true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteApplicantWorkHistoryLine>

Element name | Datatype | Length | Required | Default | Description
LLASTNAME_I | string | 21 | Y | Not applicable | Last name
FFIRSTNAME_I | string | 15 | Y | Not applicable | First name
NAME | string | 31 | Y | Not applicable | Employer name
APPLICANTNUMBER_I | number | 21 | Y | Not applicable | Applicant Number Required only if you have multiple applicants with the same name combination OR if you are passing Applicant Number instead of FIRSTNAME LASTNAME combination
ISEQUENCENUMBER_I | i4 | 2 | Y | Not applicable | Sequence Number Required only if you have the same applicants and same name/employeer on more then one record
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteCustomerAddress>

Element name | Data type | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
ADRSCODE | string | 15 | Y | Not applicable | Address ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteCustomerRcd>

Element name | Data type | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteEmployee>

Element name | Datatype | Length | Required | Default | Description
EMLOYID | string | 15 | Y | Not applicable | Employee number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteEmployeeAddress>

Element name | Datatype | Length | Required | Default | Description
EMLOYID | string | 15 | Y | Not applicable | Employee number
ADRSCODE | string | 15 | Y | Not applicable | Address ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteEmployeePayCode>

Element name | Datatype | Length | Required | Default | Description
EMPLOYID | string | 15 | Y | Not applicable | Employee number
PAYRCORD | string | 7 | Y | Not applicable | Pay code
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteRequisition>

Element name | Datatype | Length | Required | Default | Description
REQUISITIONNUMBER_I | i4 | 4 | Y | Not applicable | Requisition number
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteSalespersonRcd>

Element name | Datatype | Length | Required | Default | Description
SLPRSNID | string | 15 | Y | Not applicable | Salesperson ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteSkills>

Element name | Datatype | Length | Required | Default | Description
SKILLTITLE_I | string | 31 | Y | Not appllicable | Skill
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteSkillSets>

Element name | Datatype | Length | Required | Default | Description
SKILLSET_I | string | 31 | Y | Not applicable | Skill set
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteSkillSetsLine>

Element name | Datatype | Length | Required | Default | Description
SKILLSET_I | string | 31 | Y | Not applicable | Skill set
SKILLTITLE_I | string | 31 | Y | Not applicable | Skill
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteTests>

Element name | Datatype | Length | Required | Default | Description
TEST_I | string | 31 | Y | Not applicable | Test
TESTCODE_I | string | 7 | Y | Not applicable | Test code
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taDeleteVendorAddress>

Element name | Datatype | Length | Required | Default | Description
VENDORID | string | 15 | Y | Not applicable | Vendor ID
ADRSCODE | string | 15 | Y | Not applicable | Address ID
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true If true, then populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taFSEquipmentMaster>*

Element name | Data type | Length | Required | Default | Description
SERLNMBR | string | 21 | Y | Not applicable | Serial number
ITEMNMBR | string | 31 | Y | Not applicable | Item number
REFRENCE | string | 31 | N | <blank> | A reference about the equipment
Version | string | 31 | N | <blank> | The version of the equipment
SRLSTAT | string | 11 | N | Default from setup | The status of the equipment
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
ADRSCODE | string | 15 | Y | Not applicable | Customer address code
ADDRESS1 | string | 61 | N | <blank> | Customer address line 1
ADDRESS2 | string | 61 | N | <blank> | Customer address line 2
ADDRESS3 | string | 61 | N | <blank> | Customer address line 2
CITY | string | 35 | N | <blank> | Customer city
STATE | string | 29 | N | <blank> | Customer state code
ZIP | string | 11 | N | <blank> | Customer ZIP Code
COUNTRY | string | 61 | N | <blank> | Customer country
CNTCPRSN | string | 61 | N | <blank> | Customer Contact person
INSTDTE | datetime | 16 | N | Not applicable | The date the equipment was installed
Shipped_Date | datetime | 16 | N | Not applicable | The date the equipment was shipped
SVC_Register_Date | datetime | 16 | N | Not applicable | The date the equipment was registered
LSTPMDTE | datetime | 16 | N | Not applicable | The last date that preventive maintenance was performed on the equipment
LSTSRVDTE | datetime | 16 | N | Not applicable | The last date of a service call for the equipment
TECHID | string | 11 | N | <blank> | The primary technician responsible for the equipment
OFFID | string | 11 | N | <blank> | The office responsible for servicing the equipment
SVCAREA | string | 11 | N | <blank> | The service area in which the equipment is installed
TIMEZONE | string | 3 | N | <blank> | The time zone where is equipment is installed
VENDORID | string | 15 | N | <blank> | The vendor from which the equipment was originally purchased
WARRCDE | string | 11 | N | <blank> | The warranty code offered by the vendor for the equipment
WARRSTART | datetime | 16 | N | Not applicable | The date the vendor warranty starts for the equipment
WARREND | datetime | 16 | N | Not applicable | The date the vendor warranty ends for the equipment
SLRWARR | string | 11 | N | <blank> | The seller warranty code, which represents the warranty your company offers after the vendor warranty expires
SLRWSTART | datetime | 16 | N | Not applicable | The date the seller warranty starts for the equipment
SLRWEND | datetime | 16 | N | Not applicable | The date the seller warranty ends for the equipment
NOTETXT | string | 2000 | N | <blank> | Notes field
SVC_PM_Date | i4 | 2 | N | <blank> | The month preferred by the customer for when annual preventive maintenance events are to be performed. Valid values are: January; February; March; April; May; June; July; August; September; October; November; December
SVC_PM_Day | i4 | 2 | N | <blank> | The day of the month preferred by the customer for when annual preventive maintenance events are to be performed
USERDEF1 | string | 21 | N | <blank> | User defined 1
USERDEF2 | string | 21 | N | <blank> | User defined 2
USRDEF03 | string | 21 | N | <blank> | User defined 3
USRDEF04 | string | 21 | N | <blank> | User defined 4
USRDEF05 | string | 21 | N | <blank> | User defined 5
SVC_Serial_ID | string | 21 | N | <blank> | The serial number for the item on the equipment. This field is only available for serial tracked items.
SVC_Asset_Tag | string | 21 | N | <blank> | The asset tag for the equipment
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSEquipmentMaster> node uses field level updates to provide update functionality.


<taFSEquipmentReading>*

Element name | Data type | Length | Required | Default | Description
SERLNMBR | string | 21 | Y | Not applicable | Serial number
ITEMNMBR | string | 31 | Y | Not applicable | Item number
Meters_1 | i4 | 8 | N | <blank> | The current reading for meter 1.
Meters_2 | i4 | 8 | N | <blank> | The current reading for meter 2.
Meters_3 | i4 | 8 | N | <blank> | The current reading for meter 3.
Meters_4 | i4 | 8 | N | <blank> | The current reading for meter 4.
Meters_5 | i4 | 8 | N | <blank> | The current reading for meter 5.
Replaces_1 | i4 | 1 | N | 0 | Flag which indicates that meter 1 has been replaced. Values are: 0=False; 1=True
Replaces_2 | i4 | 1 | N | 0 | Flag which indicates that meter 2 has been replaced. Values are: 0=False; 1=True
Replaces_3 | i4 | 1 | N | 0 | Flag which indicates that meter 3 has been replaced. Values are: 0=False; 1=True
Replaces_4 | i4 | 1 | N | 0 | Flag which indicates that meter 4 has been replaced. Values are: 0=False; 1=True
Replaces_5 | i4 | 1 | N | 0 | Flag which indicates that meter 5 has been replaced. Values are: 0=False; 1=True
LSTDTEDT | datetime | 16 | N | Not applicable | The date the equipment reading was last updated.

* The <taFSEquipmentReading> node uses document exchange to provide update functionality.


<taFSRMALine>*

Element name | Data type | Length | Required | Default | Description
Return_Record_Type | i4 | 2 | Y | Not applicable | RMA record type
RETDOCID | string | 15 | Y | Not applicable | RMA number The number must include 15 alphanumeric characters. The first three characters of the number must be RMA. For example,RMA0000001234GP.
LNSEQNBR | number | 21 | N | 0 | The sequence number for the line. If not provided on an update a new line will be created.
RETTYPE | string | 11 | N | Default from setup | Return Type
RETSTAT | string | 3 | N | Default from setup | RMA Status Code
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
ADRSCODE | string | 15 | Y | Not applicable | Customer address code
ITEMNMBR | string | 31 | Y | Not applicable | Item number of item being returned
ITEMDESC | string | 101 | N | Not applicable | Description of item being returned
LOCNCODE | string | 11 | Y | <blank> | Return location code
SVC_Ready_To_Close | i4 | 1 | N | 0 | Flag to indicate whether the line is ready for closing or not; 0=No, 1=Yes
SVC_RMA_Reason_Code | string | 3 | N | <blank> | RMA Reason code
NOTETXT | string | 2000 | N | <blank> | Notes field
RETORIG | i4 | 2 | N | 1 | Return Origin; 1=None, 2=Service Call, 3=SOP
RETREF | string | 31 | N | <blank> | Return reference document number – SOP Invoice or Service Call Number
EQPLINE | i4 | 4 | N | Not applicable | Equipment sequence line number of the service call line
LNITMSEQ | i4 | 4 | N | Not applicable | The sequence number for the service call line
SVC_RMA_From_Service | i4 | 1 | N | Not applicable | Flag to indicate whether RMA was created from Service Call; 0=No, 1=Yes
CMPNTSEQ | i4 | 4 | N | Not applicable | The component sequence number for the sales invoice line
SOP_Line_Item_Sequence | i4 | 4 | N | Not applicable | The line sequence number for the sales invoice line
ENTDTE | datetime | 16 | N | Not applicable | The date the RMA was entered
ENTTME | datetime | 16 | N | Not applicable | The time the RMA was entered
ETADTE | datetime | 16 | N | Not applicable | The date the item being returned is expected to arrive
ETATME | datetime | 16 | N | Not applicable | The time the item being returned is expected to arrive
Commit_Date | datetime | 16 | N | Not applicable | The commit date for the RMA
Commit_Time | datetime | 16 | N | Not applicable | The commit time for the RMA
RETUDATE | datetime | 16 | N | Not applicable | The date the item being returned was received
Return_Time | datetime | 16 | N | Not applicable | The time the item being returned was received
COMPDTE | datetime | 16 | N | Not applicable | The date the RMA was closed
COMPTME | datetime | 16 | N | Not applicable | The time the RMA was closed
PRMDATE | datetime | 16 | N | Not applicable | The promise date for the RMA
USERID | string | 15 | N | <blank> | The user who created the RMA
OFFID | string | 11 | N | <blank> | Office ID responsible for the RMA
RTRNNAME | string | 45 | N | <blank> | Return location name
RETADDR1 | string | 61 | N | <blank> | Return address line 1
RETADDR2 | string | 61 | N | <blank> | Return address line 2
RETADDR3 | string | 61 | N | <blank> | Return address line 2
RTRNCITY | string | 21 | N | <blank> | Return city
SVC_Return_State | string | 29 | N | <blank> | Return state code
RTRNZIP | string | 11 | N | <blank> | Return ZIP Code
Return_Country | string | 61 | N | <blank> | Return country
CUSTNAME | string | 65 | N | <blank> | Customer name
CONTACT | string | 61 | N | <blank> | Customer contact
ADDRESS1 | string | 61 | N | <blank> | Customer address line 1
ADDRESS2 | string | 61 | N | <blank> | Customer address line 2
ADDRESS3 | string | 61 | N | <blank> | Customer address line 2
CITY | string | 35 | N | <blank> | Customer city
STATE | string | 29 | N | <blank> | Customer state code
ZIPCODE | string | 11 | N | <blank> | Customer ZIP Code
COUNTRY | string | 61 | N | <blank> | Customer country
CSTPONBR | string | 21 | N | <blank> | Customer PO number
QUANTITY | number | 21 | N | Not applicable | Quantity of item being returned
UOFM | string | 9 | N | <blank> | Unit of measure
UNITCOST | number | 21 | N | 0 | Unit cost of item being returned
UNITPRCE | number | 21 | N | 0 | Unit price of item being returned
XTNDPRCE | number | 21 | N | 0 | Extended price of item being returned
CUSTOWN | i4 | 1 | N | 0 | Flag to indicate if item was owned by customer. 0=No, 1=Yes
FACTSEAL | i4 | 1 | N | 0 | Flag to indicate if item was factory sealed. 0=No, 1=Yes
Flat_Rate_Repair_Price | number | 21 | N | 0 | Flat rate repair price
Repair_Price | number | 21 | N | 0 | Repair price
NTE_Price | number | 21 | N | 0 | Not to exceed price
Repair_Cost | number | 21 | N | 0 | Repair cost
Bill_of_Lading | string | 31 | N | <blank> | Bill of Lading for shipping out to customer
SHIPMTHD | string | 15 | N | <blank> | Shipping method
Location_Code_Replacemen | string | 11 | N | <blank> | Replacement location code
Replace_Item_Number | string | 31 | N | <blank> | Replacement item number
Replace_U_Of_M | string | 9 | N | <blank> | Replacement unit of measure
Replace_Price_Level | string | 11 | N | <blank> | Replacement price level
Replace_QTY | number | 21 | N | 0 | Replacement quantity
Replace_Cost | number | 21 | N | 0 | Replacement unit cost
Replace_Price | number | 21 | N | 0 | Replacement unit price
Item_Number_Invoice | string | 31 | N | <blank> | Invoice item number
USERDEF1 | string | 21 | N | <blank> | User defined 1
USERDEF2 | string | 21 | N | <blank> | User defined 2
USRDEF03 | string | 21 | N | <blank> | User defined 3
USRDEF04 | string | 21 | N | <blank> | User defined 4
USRDEF05 | string | 21 | N | <blank> | User defined 5
CURNCYID | string | 15 | N | <blank> | Currency ID
Return_Item_Number | string | 31 | N | <blank> | Item number of item that was returned
Return_Item_Description | string | 51 | N | <blank> | Description of item that was returned
Return_Location_Code | string | 11 | N | <blank> | Location code where item was returned
Return_QTY | number | 21 | N | 0 | Quantity of item that was returned
Return_U_Of_M | string | 8 | N | <blank> | Return unit of measure
RETCOST | number | 21 | N | 0 | Return unit cost
SVC_Return_Price_Level | string | 11 | N | <blank> | Return price level
SVC_Return_Price | number | 21 | N | 0 | Return unit price
SVC_Extended_Return_Pric | number | 21 | N | 0 | Return extended price
SVC_FO_ID | string | 51 | N | <blank> | Front office integration ID
SVC_SCM_Complete | i4 | 2 | N | 0 | Flag to indicate whether SCM is complete; 0=False, 1=True
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSRMALine> node uses field level updates to provide update functionality.


<taFSRMALineSerial>*

Element name | Data type | Length | Required | Default | Description
Return_Record_Type | i4 | 2 | Y | Not applicable | RMA record type
RETDOCID | string | 15 | Y | Not applicable | RMA number The number must include 15 alphanumeric characters. The first three characters of the number must be RMA. For example,RMA0000001234GP.
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
ADRSCODE | string | 15 | Y | Not applicable | Customer address code
LNSEQNBR | number | 21 | Y | 0 | The sequence number for the line
QTYTYPE | i4 | 2 | Y | 1 | Quantity Type; 1=On Hand; 2=Returned; 3=In Use; 4=In Service; 5=Damaged
SERLTQTY | number | 21 | N | 1 | Serial/Lot Qty, > 0 indicates add/update, < 0 indicates delete if exists
ITEMNMBR | string | 31 | Y | Not applicable | Item number of item being returned
SERLNMBR | string | 21 | Y | Not applicable | Serial number of item being returned
LOCNCODE | string | 11 | Y | Not applicable | The location code for serial numbers used on the RMA line
SLTSQNUM | i4 | 4 | N | 0 | Serial sequence number. If not passed in this value defaults to 1 for the first serial number and increments by 1 for each additional serial number tracked for a single parts line. On an update if this value is not provided a new serial line record will be created instead of updating the existing record.
BIN | string | 15 | N | <blank> | Bin number
SVC_Original_Serial | i4 | 1 | N | Not applicable | Flag to indicate whether its the original IV Serial. 0=No, 1=Yes
DATERECD | datetime | 16 | N | Not applicable | Date received
ReplaceItem | i4 | 1 | N | 0 | Flag to indicate if the line is for a Replacement Item. 0=No, 1=Yes
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSRMALineSerial> node uses field level updates to provide update functionality.


<taFSRMAMaster>*

Element name | Data type | Length | Required | Default | Description
Return_Record_Type | i4 | 2 | Y | Not applicable | RMA record type
RETDOCID | string | 15 | Y | Not applicable | RMA number The number must include 15 alphanumeric characters. The first three characters of the number must be RMA. For example,RMA0000001234GP.
RETORIG | i4 | 2 | N | Default from setup | Return Origin; 1=None, 2=Service Call, 3=SOP
RETREF | string | 31 | N | <blank> | Return reference document number – SOP Invoice or Service Call Number
RETSTAT | string | 3 | N | Default from setup | RMA Status Code
RETTYPE | string | 15 | Y | Default from setup | Return Type
ENTDTE | datetime | 16 | N | Not applicable | The date the RMA was entered
ENTTME | datetime | 16 | N | Not applicable | The time the RMA was entered
ETADTE | datetime | 16 | N | Not applicable | The date the item being returned is expected to arrive
ETATME | datetime | 16 | N | Not applicable | The time the item being returned is expected to arrive
Commit_Date | datetime | 16 | N | Not applicable | The commit date for the RMA
Commit_Time | datetime | 16 | N | Not applicable | The commit time for the RMA
RETUDATE | datetime | 16 | N | Not applicable | The date the item being returned was received
Return_Time | datetime | 16 | N | Not applicable | The time the item being returned was received
COMPDTE | datetime | 16 | N | Not applicable | The date the RMA was closed
COMPTME | datetime | 16 | N | Not applicable | The time the RMA was closed
USERID | string | 15 | N | <blank> | The user who created the RMA
OFFID | string | 11 | N | <blank> | Office ID responsible for the RMA
RTRNNAME | string | 45 | N | <blank> | Return location name
RETADDR1 | string | 61 | N | <blank> | Return address line 1
RETADDR2 | string | 61 | N | <blank> | Return address line 2
RETADDR3 | string | 61 | N | <blank> | Return address line 2
RTRNCITY | string | 21 | N | <blank> | Return city
SVC_Return_State | string | 29 | N | <blank> | Return state code
RTRNZIP | string | 11 | N | <blank> | Return ZIP Code
Return_Country | string | 61 | N | <blank> | Return country
LOCNCODE | string | 11 | N | Default from setup | Return location code
CUSTNMBR | string | 15 | Y | Not applicable | Customer ID
ADRSCODE | string | 15 | Y | Not applicable | Customer Address ID
CUSTNAME | string | 65 | N | <blank> | Customer name
CONTACT | string | 61 | N | <blank> | Customer contact
ADDRESS1 | string | 61 | N | <blank> | Customer address line 1
ADDRESS2 | string | 61 | N | <blank> | Customer address line 2
ADDRESS3 | string | 61 | N | <blank> | Customer address line 2
CITY | string | 35 | N | <blank> | Customer city
STATE | string | 29 | N | <blank> | Customer state code
ZIPCODE | string | 11 | N | <blank> | Customer ZIP Code
COUNTRY | string | 61 | N | <blank> | Customer country
NOTETXT | string | 2000 | N | <blank> | Notes field
Bill_of_Lading | string | 31 | N | <blank> | Bill of Lading for shipping out to customer
SHIPMTHD | string | 15 | N | <blank> | Shipping Method
Bill_To_Customer | string | 15 | N | Default from setup | Bill To Customer ID
SVC_Bill_To_Address_Code | string | 15 | N | Default from setup | Bill To Customer Address ID
USERDEF1 | string | 21 | N | <blank> | User defined 1
USERDEF2 | string | 21 | N | <blank> | User defined 2
USRDEF03 | string | 21 | N | <blank> | User defined 3
USRDEF04 | string | 21 | N | <blank> | User defined 4
USRDEF05 | string | 21 | N | <blank> | User defined 5
CURNCYID | string | 15 | N | <blank> | Currency ID
CSTPONBR | string | 21 | N | <blank> | Customer PO number
SVC_RMA_Reason_Code | string | 3 | N | <blank> | RMA Reason code
SVC_RMA_From_Service | i4 | 1 | N | Not applicable | Flag to indicate whether RMA was created from Service Call; 0=No, 1=Yes
SVC_FO_ID | string | 51 | N | <blank> | Front office integration ID
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSRMAMaster> node uses field level updates to provide update functionality.


<taFSRTVLine>*

Element name | Data type | Length | Required | Default | Description
RTV_Number | string | 15 | Y | Not applicable | RTV number
RTV_Line | number | 21 | N | Not applicable | The sequence number for the line
RTV_Type | string | 11 | N | Default from setup | RTV Type
VRMA_Document_ID | string | 15 | N | <blank> | Vendor’s RMA Document Number
RETDOCID | string | 15 | N | Not applicable | Customer’s RMA Number
LNSEQNBR | number | 21 | N | <blank> | RMA line sequence number
SVC_Process_SEQ_ Number | number | 21 | N | <blank> | RMA process sequence number
DSCRIPTN | string | 31 | N | <blank> | RTV description
REFRENCE | string | 31 | N | <blank> | Reference information
Reference2 | string | 31 | N | <blank> | Additional reference information
ITEMNMBR | string | 31 | Y | Not applicable | Item number being returned
ITEMDESC | string | 101 | N | Not applicable | Item description
QUANTITY | number | 21 | N | 0 | Quantity of item being returned
UOFM | string | 9 | Y | <blank> | Unit of measure
VENDORID | string | 15 | Y | Not applicable | Vendor ID
ADRSCODE | string | 15 | Y | Not applicable | Vendor Address ID
Ship_Address_Name | string | 65 | N | <blank> | Name of Contact Person for Vendor’s Ship To Address
Ship_Address_1 | string | 61 | N | <blank> | Ship to address line 1
Ship_Address_2 | string | 61 | N | <blank> | Ship to address line 2
Ship_Address_3 | string | 61 | N | <blank> | Ship to address line 3
Ship_City | string | 35 | N | <blank> | City name of vendor’s ship to address
Ship_State | string | 29 | N | <blank> | State of vendor’s ship to address
ZIPCODE | string | 11 | N | <blank> | Zip Code of vendor’s ship to address
Ship_Country | string | 61 | N | <blank> | Country name of vendor’s ship to address
VNDITNUM | string | 31 | N | <blank> | Vendor’s Item Number
Return_Item_Number | string | 31 | N | <blank> | Item Number being returned
OFFID | string | 11 | N | <blank> | Office ID responsible for RTV
LOCCODEB | string | 11 | N | <blank> | Location Code from where item was shipped to vendor
LOCNCODE | string | 11 | N | <blank> | Location Code from where item will be received
ENTDTE | datetime | 16 | N | Not applicable | The date the RTV line was entered
ENTTME | datetime | 16 | N | Not applicable | The time the RTV line was entered
PRMDATE | datetime | 16 | N | Not applicable | The date the RTV line was promised
Promised_Time | datetime | 16 | N | Not applicable | The time the RTV line was promised
Shipped_Date | datetime | 16 | N | Not applicable | The date the RTV line was shipped
Shipped_Time | datetime | 16 | N | Not applicable | The time the RTV line was shipped
Receiptdate | datetime | 16 | N | Not applicable | The date the RTV line was received
Receipt_Time | datetime | 16 | N | Not applicable | The time the RTV line was received
COMPDTE | datetime | 16 | N | Not applicable | The date the RTV line was closed
COMPTME | datetime | 16 | N | Not applicable | The time the RTV line was closed
Bill_of_Lading_Out | string | 31 | N | <blank> | Bill of Lading number for shipment to vendor
Shipping_Method_Out | string | 15 | N | <blank> | Shipping method for shipment to vendor
Bill_of_Lading | string | 31 | N | <blank> | Bill of Lading number for returning
SHIPMTHD | string | 15 | N | <blank> | Shipment method for returning
Tracking_Number | string | 41 | N | <blank> | Shipment tracking number
NOTETXT | string | 2000 | N | <blank> | Notes field
CUSTOWN | i4 | 1 | N | Default from setup | Flag to indicate whether item was owned by customer; 0=No, 1=Yes
USERDEF1 | string | 21 | N | <blank> | User defined 1
USERDEF2 | string | 21 | N | <blank> | User defined 2
USRDEF03 | string | 21 | N | <blank> | User defined 3
USRDEF04 | string | 21 | N | <blank> | User defined 4
USRDEF05 | string | 21 | N | <blank> | User defined 5
CURNCYID | string | 15 | Y | <blank> | Currency ID
Part_Price | number | 21 | N | 0 | Unit price
Part_Cost | number | 21 | N | 0 | Unit cost
Labor_Price | number | 21 | N | 0 | Labor price involved in fulfilling RTV
Labor_Cost | number | 21 | N | 0 | Labor cost involved in fulfilling RTV
Expense_Price | number | 21 | N | 0 | Expense price involved in fulfilling RTV
Expense_Cost | number | 21 | N | 0 | Expense cost involved in fulfilling RTV
Travel_Price | number | 21 | N | 0 | Travel price involved in fulfilling RTV
Travel_Cost | number | 21 | N | 0 | Travel cost involved in fulfilling RTV
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSRTVLine> node uses field level updates to provide update functionality.


<taFSRTVLineSerial>*

Element name | Data type | Length | Required | Default | Description
RTV_Number | string | 15 | Y | Not applicable | RTV number
RTV_Line | number | 21 | N | Not applicable | The sequence number for the line
VENDORID | string | 15 | Y | Not applicable | Vendor ID
ADRSCODE | string | 15 | Y | Not applicable | Vendor address code
QTYTYPE | i4 | 2 | Y | Not applicable | Quantity Type; 1=On Hand; 2=Returned; 3=In Use; 4=In Service; 5=Damaged
SERLTQTY | number | 21 | N | 1 | Serial/Lot Qty, > 0 indicates add/update, < 0 indicates delete if exists
SLTSQNUM | i4 | 4 | N | o | Serial sequence number. If not passed in this value defaults to 1 for the first serial number and increments by 1 for each additional serial number tracked for a single parts line. On an update if this value is not provided a new serial line record will be created instead of updating the existing record.
InOrOut | i4 | 2 | N | 1 | Flag which indicates whether it’s an incoming item (from vendor) or an outgoing (to vendor) item. Values: 1=Sent/Out, 2=Received/In
ITEMNMBR | string | 31 | Y | Not applicable | Item number of item being returned
SERLNMBR | string | 21 | N | Not applicable | Serial number of item being returned
LOCNCODE | string | 11 | Y | Not applicable | The location code for serial numbers used on the RMA line
BIN | string | 15 | N | <blank> | Bin number
SVC_Original_Serial | i4 | 1 | N | Not applicable | Flag to indicate whether its the original IV Serial. 0=No, 1=Yes
DATERECD | datetime | 16 | N | Not applicable | Date received
Shipped | i4 | 1 | N | Not applicable | Flag to indicate if the serial has been shipped. 0=No, 1=Yes
CREATEEQUIPMENT | i4 | 1 | N | 0 | Flag to create equipment record if none exists for the serial number. 0=No, 1=Yes
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSRTVLineSerial> node uses field level updates to provide update functionality.


<taFSRTVMaster>*

Element name | Data type | Length | Required | Default | Description
RTV_Number | string | 15 | Y | Not applicable | RTV number
RTV_Type | string | 11 | Y | Default from setup | RTV Type
RTV_Return_Status | string | 3 | N | Default from setup | RTV Status
VRMA_Document_ID | string | 15 | N | <blank> | Vendor’s RMA Document Number
RETDOCID | string | 15 | N | <blank> | Customer’s RMA Number
DSCRIPTN | string | 31 | N | <blank> | RTV description
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VENDNAME | string | 65 | N | <blank> | Vendor name
CKHOLD | i4 | 2 | N | 0 | A flag to determine whether the vendor's hold status is checked when the document is created. 0=Do not check; 1=check
ADRSCODE | string | 15 | Y | Not applicable | Vendor Address ID
Ship_Address_Name | string | 65 | N | <blank> | Name of Contact Person for Vendor’s Ship To Address
Ship_Address_1 | string | 61 | N | <blank> | Ship to address line 1
Ship_Address_2 | string | 61 | N | <blank> | Ship to address line 2
Ship_Address_3 | string | 61 | N | <blank> | Ship to address line 3
Ship_City | string | 35 | N | <blank> | City name of vendor’s ship to address
Ship_State | string | 29 | N | <blank> | State of vendor’s ship to address
ZIPCODE | string | 11 | N | <blank> | Zip Code of vendor’s ship to address
Ship_Country | string | 61 | N | <blank> | Country name of vendor’s ship to address
ENTDTE | datetime | 16 | N | Not applicable | The date the RTV was entered
ENTTME | datetime | 16 | N | Not applicable | The time the RTV was entered
LOCCODEB | string | 11 | N | <blank> | Location Code from where item was shipped to vendor
LOCNCODE | string | 11 | N | <blank> | Location Code from where item will be received
Bill_of_Lading_Out | string | 31 | N | <blank> | Bill of Lading number for shipment to vendor
Shipping_Method_Out | string | 15 | N | <blank> | Shipping method for shipment to vendor
Bill_of_Lading | string | 31 | N | <blank> | Bill of Lading number for returning
SHIPMTHD | string | 15 | N | <blank> | Shipment method for returning
OFFID | string | 11 | N | <blank> | Office ID responsible for RTV
NOTETXT | string | 2000 | N | <blank> | Notes field
USERID | string | 15 | N | <blank> | User who created the Return To Vendor
USERDEF1 | string | 21 | N | <blank> | User defined 1
USERDEF2 | string | 21 | N | <blank> | User defined 2
USRDEF03 | string | 21 | N | <blank> | User defined 3
USRDEF04 | string | 21 | N | <blank> | User defined 4
USRDEF05 | string | 21 | N | <blank> | User defined 5
CURNCYID | string | 15 | Y | <blank> | Currency ID
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSRTVMaster> node uses field level updates to provide update functionality.


<taFSServiceCallCodesEquipment>*

Element name | Data type | Length | Required | Default | Description
SRVRECTYPE | i4 | 2 | Y | Not applicable | Service record type: 1=Quote; 2=Open
CALLNBR | string | 11 | Y | Not applicable | Call number
ITEMNMBR | string | 31 | N | <blank> | Item number
SERLNMBR | string | 21 | N | <blank> | Serial number
CUSTNMBR | string | 15 | N | <blank> | Customer number
PROBCDE | string | 11 | N | <blank> | Problem code
CAUSECDE | string | 11 | N | <blank> | Cause code
RPRCODE | string | 11 | N | <blank> | Repair code
PMPERF | i4 | 1 | N | 0 | PM performed
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSServiceCallCodesEquipment> node uses field level updates to provide update functionality.


<taFSServiceCallLine>*

Element name | Data type | Length | Required | Default | Description
SRVRECTYPE | i4 | 2 | Y | Not applicable | Service record type
CALLNBR | string | 11 | Y | Not applicable | Service call number
EQPLINE | i4 | 4 | N | 1 | The Equipment Sequence Number. If not provided on an update the default will be 1.
LNITMSEQ | i4 | 4 | N | 0 | The sequence number for the line. If not provided on an update a new service call line record will be created.
LINITMTYP | string | 3 | Y | P | Indicates the type of service call line. Options are: A=Additional Charge; E=Expense; L=Labor; P=Parts. If not provided the default will be P for parts.
SRVSTAT | string | 3 | N | Not applicable | The status of the service call line; Only valid for line type = L (Labor) or P (Parts).
TECHID | string | 11 | N | Not applicable | The technician of the service call line; Only valid for line type = L (Labor) or P (Parts).
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
ADRSCODE | string | 15 | Y | Not applicable | Customer address code
ITEMNMBR | string | 31 | Y | Not applicable | Item number If multiple bins is enabled, inventory setup is not supported.
CKNORETURNS | i4 | 1 | N | 0 | Flag used to indicate not to create returnable line for items that are set as returnable; 0=False; 1=True
ITEMDESC | string | 101 | N | Not applicable | Item description
LOCNCODE | string | 11 | Y | Not applicable | The location code for parts used on the service call line
UOFM | string | 9 | N | <blank> | Unit of measure
QTYORDER | number | 21 | N | 0 | The amount of labor or quantity of parts required for the service call line. Only valid for line type = L (Labor) or P (Parts).
ATYALLOC | number | 21 | N | 0 | The quantity of the parts line that is allocated in Inventory. Only valid for line type = P (Parts) and will be unallocated when the part is used.
QTYBACKO | number | 21 | N | 0 | The quantity of the parts line that is backordered. Only valid for line type = P (Parts) and will be reduced as the backorder is filled by an Inventory transfer or receipt of a purchase order.
QTYSOLD | number | 21 | N | 0 | The quantity of the line that was actually used. This is the value that will be transferred to the invoice during the service call billing process. You will have to manually post the inventory adjustment transaction that is created.
UNITCOST | number | 21 | N | 0 | The cost per unit of measure for the current detailed entry. This cost will typically default from the Inventory current cost for most items, but can be modified for additional charge and expense lines.
UNITPRCE | number | 21 | N | 0 | The price per unit of measure for the service call line
XTNDPRCE | number | 21 | N | 0 | The extended price of the line, which is the unit price times the quantity sold. This value may also be affected by the applicable billing percentage for parts, labor or miscellaneous lines.
NOTETXT | string | 3000 | N | <blank> | Notes field
STRTDATE | datetime | 16 | N | Not applicable | Only valid for line type = L (Labor) and contains the date on which the labor line started.
STRTTIME | datetime | 16 | N | Not applicable | Only valid for line type = L (Labor) and contains the time on which the labor line started.
ENDDATE | datetime | 16 | N | Not applicable | Only valid for line type = L (Labor) and contains the date on which the labor line ended.
ENDTME | datetime | 16 | N | Not applicable | Only valid for line type = L (Labor) and contains the time on which the labor line ended.
TRANSTME | number | 11 | N | 0 | The actual time for a labor line and is only valid for line type = L (Labor). Values should be in portions of an hour. For example, a half hour would be 00030, while one hour would be 00100
BILLABLTIM | number | 11 | N | 0 | The amount of time that should be billed for a labor line and is only valid for line type = L (Labor).This value may vary from the transaction time field based on rounding or minimum labor settings. Values should be in portions of an hour. For example, a half hour would be 00030, while one hour would be 00100
ENTDTE | datetime | 16 | N | Not applicable | Entry Date
ENTTME | datetime | 16 | N | Not applicable | Entry Time
LABPCT | number | 21 | N | Default from setup | The percent of the line that is billable to the customer. This value is only used in calculations for records where line type = L (Labor). The value will default from any contract or warranty attached to the current contract, otherwise it will default to 100
PARTPCT | number | 21 | N | Default from setup | The percent of the line that is billable to the customer. This value is only used in calculations for records where line type = P (Parts). The value will default from any contract or warranty attached to the current contract, otherwise it will default to 100
MISCPCT | number | 21 | N | Default from setup | The percent of the line that is billable to the customer. This value is only used in calculations for records where line type = A (Additional Charge) or E (Expense). The value will default from any contract or warranty attached to the current contract, otherwise it will default to 100
CKCREATEPO | i4 | 2 | N | 0 | Flag used to indicate if a PO for a parts line should be created; 0=False; 1=True
VENDORID | string | 15 | N | Not applicable | Vendor number
PRMDATE | datetime | 16 | N | Not applicable | Promised Date
Miles_Start | i4 | 8 | N | <blank> | The starting mileage for the line. Only valid for line type = L (Labor)
Miles_End | i4 | 8 | N | <blank> | The ending mileage for the line. Only valid for line type = L (Labor)
Miles_Used | i4 | 8 | N | <blank> | The total mileage for the line, (Miles_End less Miles_Start). Only valid for line type = L (Labor).
PRICELVL | string | 15 | N | Default from setup | The Inventory price level for the line. For parts, expense and additional charge lines the price level defaults from the Service Call header. For labor lines, the price level defaults from the Technician assigned to the labor line.
SVC_Address_Option | i4 | 2 | N | Default from setup | The Address Option selection and is only valid for line type = P (Parts). Valid options are: 0=Labor, Additional Charge or Expense record; 1=Customer Address ID; 2=Tech Site; 3=Misc Address Code; 4=Transfer Header Modified
SVC_Misc_Address_Code | string | 15 | N | <blank> | The miscellaneous address to be used when SVC_Address_Option =3
SVC_Disable_XFR_Grouping | i4 | 1 | N | 0 | Flag which indicates whether transfer or purchase order lines will be consolidated or not consolidated with other open transfers or purchase orders. 0=False; 1=True
Work_Type | string | 11 | N | <blank> | The work type code for the line. Only valid for line type = L (Labor).
SVC_FO_ID | string | 51 | N | <blank> | Front office integration ID
CURNCYID | string | 15 | N | Default from setup | Currency ID
NonInventory | i4 | 1 | N | 0 | Non-inventory items 0=Inventory item 1=Noninventory item
Create_Overtime_Labor | i4 | 1 | N | 0 | Overtime labor rates to be used for labor outside of technician schedule. 0=False 1=True
Overtime_Labor_item_Number | string | 31 | N | Default from setup | Item number for overtime labor if automatic overtime ins enabled. The default is the overtime labor item for the specified Service Type.
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSServiceCallLine> node uses field level updates to provide update functionality.


<taFSServiceCallLineSerial>*

Element name | Data type | Length | Required | Default | Description
SRVRECTYPE | i4 | 2 | Y | Not applicable | Service record type
CALLNBR | string | 11 | Y | Not applicable | Service call number
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
ADRSCODE | string | 15 | Y | Not applicable | Customer address code
EQPLINE | i4 | 4 | Y | 1 | The Equipment Sequence Number. If not provided on an update the default will be 1.
LINITMTYP | string | 3 | N | P | Indicates the type of service call line. Options are: A=Additional Charge; E=Expense; L=Labor; P=Parts
LNITMSEQ | i4 | 4 | Y | 1 | The sequence number for the line
QTYTYPE | i4 | 2 | Y | 1 | The type of Inventory that the current serial number record represents. Service Call only uses On Hand quantity types. 1=On Hand; 2=Returned; 3=In Use; 4=In Service; 5=Damaged
ITEMNMBR | string | 31 | Y | Not applicable | Item number
SERLTNUM | string | 21 | Y | Not applicable | Serial number
SERLTQTY | number | 21 | N | 1 | Serial/Lot Qty, > 0 indicates add/update, < 0 indicates delete if exists
SLTSQNUM | i4 | 4 | N | 0 | Serial sequence number. If not passed in this value defaults to 1 for the first serial number and increments by 1 for each additional serial number tracked for a single parts line. On an update if this value is not provided a new serial line record will be created instead of updating the existing record.
LOCNCODE | string | 11 | Y | Not applicable | The location code for serial numbers used on the service call line
BIN | string | 15 | N | <blank> | The bin number for each serial detail line in which the serial number can be found or which bin it should be placed into (return line)
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow data to be updated if it exists: 0=Do not update; 1=Update
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSServiceCallLineSerial> node uses field level updates to provide update functionality.


<taFSServiceCallMaster>*

Element name | Data type | Length | Required | Default | Description
SRVRECTYPE | i4 | 2 | Y | Not applicable | Service record type
CALLNBR | string | 11 | Y | Not applicable | Service call number
SRVSTAT | string | 3 | N | Default from setup | Service call status code
SRVTYPE | string | 11 | N | Default from setup | Service type
SVCDESCR | string | 61 | N | <blank> | Service description
PriorityLevel | i4 | 2 | N | 0 | Priority level
CUSTNMBR | string | 15 | Y | <blank> | Customer number
Customer_Reference | string | 21 | N | <blank> | Customer reference
ADRSCODE | string | 15 | Y | <blank> | Customer address code
CUSTNAME | string | 65 | N | <blank> | Customer name
ADDRESS1 | string | 61 | N | <blank> | Customer address line 1
ADDRESS2 | string | 61 | N | <blank> | Customer address line 2
ADDRESS3 | string | 61 | N | <blank> | Customer address line 3
CITY | string | 35 | N | <blank> | Customer city
STATE | string | 29 | N | <blank> | Customer state code
ZIP | string | 11 | N | <blank> | Customer ZIP Code
COUNTRY | string | 61 | N | <blank> | Customer country
CNTCPRSN | string | 61 | N | <blank> | Customer Contact person
PHONE1 | string | 21 | N | <blank> | Customer phone 1
CKHOLD | i4 | 2 | N | 0 | Flag to allow check on hold status: 0=Does not check hold status; 1=Checks hold status
OFFID | string | 11 | N | <blank> | Office ID
SVCAREA | string | 11 | N | <blank> | Service area
TECHID | string | 11 | N | <blank> | Technician ID
TIMEZONE | string | 3 | N | <blank> | Time zone
CONTNBR | string | 11 | N | <blank> | Contract number
PRICELVL | string | 15 | N | Default from setup | The price level assigned to the current service call. This value defaults from the customer card, item card of the item to be repaired or service setup, in that order. This price level will default on all entries in the SVC00203 table except labor transactions.
ENTDTE | datetime | 16 | N | <blank> | Entry date
ENTTME | datetime | 16 | N | <blank> | Entry time
ETADTE | datetime | 16 | N | <blank> | ETA date
ETATME | datetime | 16 | N | <blank> | ETA Time
DISPDTE | datetime | 16 | N | <blank> | Dispatch date
DISPTME | datetime | 16 | N | <blank> | Dispatch time
ARRIVDTE | datetime | 16 | N | <blank> | Arrival date
ARRIVTME | datetime | 16 | N | <blank> | Arrival time
COMPDTE | datetime | 16 | N | <blank> | Complete date
COMPTME | datetime | 16 | N | <blank> | Complete time
Response_Date | datetime | 16 | N | <blank> | Response date
Response_Time | datetime | 16 | N | <blank> | Response time
SLPRSNID | string | 15 | N | <blank> | Salesperson ID
PORDNMBR | string | 20 | N | <blank> | Purchase order number
NOTETXT | string | 2000 | N | Default from setup | Notes field
USERDEF1 | string | 21 | N | <blank> | User defined 1
USERDEF2 | string | 21 | N | <blank> | User defined 2
USERDEF3 | string | 21 | N | <blank> | User defined 3
USERDEF4 | string | 21 | N | <blank> | User defined 4
USERDEF5 | string | 21 | N | <blank> | User defined 5
SVC_On_Hold | i4 | 1 | N | 0 | Flag to indicate the service call is on hold
PYMTRMID | string | 21 | N | <blank> | Payment term ID
SVC_FO_ID | string | 50 | N | <blank> | Front office integration ID
CURNCYID | string | 15 | N | <blank> | Currency ID
AutoCreateLabor | i4 | 1 | N | 0 | Flag to allow labor lines to be automatically created for Arrival and Completion: 0=No; 1=Yes
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taFSServiceCallMaster> node uses field level updates to provide update functionality.


<taFSServiceCallMultiTech>*

Element name | Data type | Length | Required | Default | Description
SRVRECTYPE | i4 | 2 | Y | Not applicable | Service record type 1 = Quote 2 = Open
CALLNBR | string | 11 | Y | Not applicable | Call number
ITEMNMBR | string | 31 | N | <blank> | Item number
SERLNMBR | string | 21 | N | <blank> | Serial number
EQPLINE | i4 | 4 | N | 0 | Equipment line number
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence number
CUSTNMBR | stringq | 15 | N | <blank> | Customer number
TECHID | string | 11 | N | <blank> | Tech ID
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow the item location data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taFSServiceCallMultiTech> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taGLTransactionHeaderInsert>

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number
JRNENTRY | i4 | 4 | Y | Not applicable | Journal entry number
REFRENCE | string | 30 | Y | Not applicable | Reference
TRXDATE | datetime | 16 | Y | Not applicable | Transaction date
RVRSNGDT | datetime | 16 | N | <blank> | Reversing date
TRXTYPE | i4 | 2 | Y | Not applicable | Transaction type: 0=Regular; 1=Reversing
SQNCLINE | number | 21 | N | 0 | Sequence line
SERIES | i4 | 2 | N | 2 | Series: 1=All; 2=Financial; 3=Sales; 4=Purchasing; 5=Inventory; 6=Payroll; 7=Project
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Bi-weekly; 4=Semiweekly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
SOURCDOC | string | 11 | N | <blank> | Source document
Ledger_ID | i4 | 2 | N | 1 | Ledger ID 1=Base, 2=IFRS, 3=Local
USERID | string | 15 | N | <blank> | User ID
Adjustment_Transaction | i4 | 2 | N | 0 | Adjustment transaction checkbox 0=False 1=True
NOTETEXT | string | 8000 | N | <blank> | Note text
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taGLTransactionLineInsert>

Element | Datatype | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number
JRNENTRY | i4 | 4 | Y | Not applicable | Journal entry number
SQNCLINE | number | 21 | N | 0 | Sequence line
ACTINDX | i4 | 4 | N | 0 | Account index
CRDTAMNT | number | 21 | Y | Not applicable | Credit amount
DEBITAMT | number | 21 | Y | Not applicable | Debit amount
ACTNUMST | string | 75 | N | <blank> | Account string
DSCRIPTN | string | 30 | N | <blank> | Description
ORCTRNUM | string | 20 | N | <blank> | Originating control number
ORDOCNUM | string | 20 | N | <blank> | Originating document number
ORMSTRID | string | 30 | N | <blank> | Originating master ID
ORMSTRNM | string | 64 | N | <blank> | Originating master name
ORTRXTYP | i4 | 2 | N | 0 | Originating transaction type
OrigSeqNum | i4 | 4 | N | 0 | Originating sequence number
ORTRXDESC | string | 30 | N | <blank> | Originating transaction description
TAXDTLID | string | 15 | N | <blank> | Tax detail ID
TAXAMNT | number | 21 | N | 0 | Tax amount
TAXACTNUMST | string | 75 | N | <blank> | Tax account string
DOCDATE | datetime | 16 | N | <blank> | Document date
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Bi-weekly; 4=Semiweekly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous days limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taItemSite>*

Element name | Data type | Length | Required | Default | Description
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LOCNCODE | string | 10 | Y | Not applicable | Location code/site
BINNMBR | string | 20 | N | Default is from setup | Bin
PRIMVNDR | string | 15 | N | Default is from setup | Primary vendor ID
Landed_Cost_Group_ID | string | 15 | N | Default is from setup | Landed cost group ID
QTYRQSTN | number | 21 | N | Default is from setup | Requisition quantity
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow the item location data to be updated if it exists: 0=No; 1=Yes
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taItemSite> node uses field level updates to provide update functionality.


<taIVCreateItemPriceListHeader>*

Element name | Datatype | Length | Required | Default | Description
ITEMNMBR | string | 30 | Y | Not applicable | Item number
PRICMTHD | i4 | 2 | N | Default from setup | Price method: 1=Currency amount; 2=Percentage of list; 3=Percentage mark-up of current cost; 4=Percentage mark-up of standard cost; 5=Percentage margin of current cost; 6=Percentage margin of standard cost If default is not set up in the back office, the default is 1.
PriceGroup | string | 10 | N | Default from setup | Price group; if empty, default is from IV00101
UOFM | string | 8 | N | Default from setup | Default selling unit of measure
PRCLEVEL | string | 10 | N | Default from setup | Price level
CURNCYID | string | 15 | N | <blank> | Currency ID
UpdateIfExists | i4 | 2 | N | 1 | Update if exists: 0=False; 1=True
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taIVCreateItemPriceListHeader> node uses field level updates to provide update functionality.


<taIVCreateItemPriceListLine>*

Element name | Data type | Length | Required | Default | Description
ITEMNMBR | string | 30 | Y | Not applicable | Item number
CURNCYID | string | 15 | N | <blank> | Currency ID
PRCLEVEL | string | 10 | N | <blank> | Price level
UOFM | string | 8 | N | <blank> | Unit of measure
TOQTY | number | 21 | N | 999999999999.00000 | To quantity
UOMPRICE | number | 21 | N | 0 | Unit of measure price/percentage
RNDGAMNT | number | 21 | N | 0 | Round amount
ROUNDHOW | i4 | 2 | N | 0 | Round option: 1=Multiple of; 2=Ends in
ROUNDTO | i4 | 2 | N | 1 | Round policy: 1=None; 2=Up; 3=Down; 4=To nearest
UMSLSOPT | i4 | 2 | N | Default from setup | Unit of measure selling option: 1=Not available; 2=Whole; 3=Whole and fractional
UpdateIfExists | i4 | 2 | N | 1 | Update if exists: 0=False; 1=True
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taIVCreateItemPriceListLine> node uses field level updates to provide update functionality.


<taIVCreatePriceGroup>

Element name | Datatype | Length | Required | Default | Description
PriceGroup | string | 10 | Y | Not applicable | Price group
DSCRIPTN | string | 30 | N | <blank> | Description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVCreatePriceLevel>

Element name | Datatype | Length | Required | Default | Description
PRCLEVEL | string | 10 | Y | Not applicable | Price level
DSCRIPTN | string | 30 | N | <blank> | Description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVCreateUOFMScheduleHeader>

Element name | Data type | Length | Required | Default | Description
UOMSCHDL | string | 10 | Y | Not applicable | Unit of measure schedule
UMSCHDSC | string | 30 | Y | Not applicable | Unit of measure schedule description
BASEUOFM | string | 8 | Y | Not applicable | Base unit of measure
UMDPQTYS | i4 | 2 | N | 0 | Decimal places quantity
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if true. it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVCreateUOFMScheduleLine>

Element name | Data type | Length | Required | Default | Description
UOMSCHDL | string | 10 | Y | Not applicable | Unit of measure schedule
UOFM | string | 8 | Y | Not applicable | Unit of measure
EQUIVUOM | string | 8 | Y | Not applicable | Equivalent unit of measure
EQUOMQTY | number | 21 | Y | Not applicable | Equivalent unit of measure quantity
UOFMLONGDESC | string | 254 | N | <blank> | Unit of measure long description
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVMultibinBinToBinTransfer>

Element name | Datatype | Length | Required | Default | Description
Bin_XFer_Doc_Number | string | 17 | Y | Not applicable | Document number
Bin_XFer_Date | datetime | 16 | Y | Not applicable | Document date
Reason_Code | string | 15 | N | <blank> | Reason code
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LOCNCODE | string | 10 | Y | Not applicable | Site ID
QTYTYPE | i4 | 2 | N | 1 | Quantity type: 1=On hand; 2=Returned; 3=In use; 4=In service; 5=Damaged
UOFM | string | 8 | N | <blank> | Unit of measure; if not passed in, default is with the base unit of measure; serial numbers must use base unit of measure and only one can be transferred at a time
BIN | string | 15 | Y | Not applicable | Bin (transfer from)
QUANTITY | number | 21 | Y | Not applicable | Quantity; if it is a serial-numbered quantity, it must be set to 1
TOBIN | string | 15 | Y | Not applicable | To bin (transfer to)
CreateBin | i4 | 1 | N | 0 | Create bin on the fly: 0=False; 1=True
ResetQty | i4 | 1 | N | 0 | Reset quantity flag: 0=Do not reset QUANTITY to the quantity available; 1=Reset QUANTITY to the quantity available in the bin
AddMoreSerLots | i4 | 1 | N | 0 | Add additional serial lot numbers to an existing document: 0=Do not allow; 1=Allow
SerLotNmbr | string | 20 | N | <blank> | Serial or lot number; required if the item is serial or lot numbered
EXPNDATE | datetime | 16 | N | <blank> | Expiration Date: Can be used to select a specific lot layer.
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USERID | string | 15 | N | <blank> | User ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransactionHeaderInsert>

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number
IVDOCNBR | string | 17 | Y | Not applicable | IV document number
IVDOCTYP | i4 | 2 | Y | Not applicable | IV document type
DOCDATE | datetime | 16 | Y | Not applicable | Document date
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
POSTTOGL | i4 | 2 | N | 1 | Post to GL—optional but default is 1 if no value is passed in
MDFUSRID | string | 15 | N | <blank> | Modified user ID
PTDUSRID | string | 15 | N | <blank> | Posted user ID
POSTEDDT | datetime | 16 | N | <blank> | Posted date
NOTETEXT | string | 8000 | N | <blank> | Note text
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransactionLineInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | IV document number
IVDOCTYP | i4 | 2 | Y | Not applicable | IV document types: 1=Adjustment; 2=Variance
ITEMNMBR | string | 30 | Y | Not applicable | Item number
Reason_Code | string | 15 | N | <blank> | Reason code
LNSEQNBR | number | 21 | N | 0 | Line item sequence number
UOFM | string | 8 | N | <blank> | Unit of measure; the base unit of measure will default if left blank
TRXQTY | number | 21 | N | 0 | Transaction quantity
UNITCOST | number | 21 | N | 0 | Unit cost
TRXLOCTN | string | 10 | Y | Not applicable | Location ID
IVIVINDX | i4 | 4 | N | 0 | Inventory index
InventoryAccount | string | 75 | N | <blank> | Inventory account number string
IVIVOFIX | i4 | 4 | N | 0 | Inventory offset index
InventoryAccountOffSet | string | 75 | N | <blank> | Inventory account number string for offset account
OverrideQty | i4 | 1 | N | 1 | Override quantity flag; to use this element, inventory control must allow for adjustment overrides: 0=Reset TRXQTY with quantity available; 1=Override quantity available and use TRXQTY
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransactionLotInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | Document number
IVDOCTYP | i4 | 2 | Y | Not applicable | Document types: 1=Adjustment; 2=Variance
USERDATE | datetime | 16 | N | Current system time | User Date: Used to determine if a lot is expired
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LOTNUMBR | string | 20 | Y | Not applicable | Lot number
SERLTQTY | number | 21 | Y | Not applicable | Quantity for lot item
ADJTYPE | i4 | 2 | N | 0 | Adjustment type: 0=Increase; 1=Decrease
BIN | string | 15 | N | <blank> | Bin; default is autocreate when multibin is enabled and not passed in
CreateBin | i4 | 1 | N | 0 | Create bin on the fly: 0=False; 1=True
LNSEQNBR | i4 | 4 | N | 0 | Line sequence number
LOCNCODE | string | 10 | N | <blank> | Location code; required only if adding a lot number on the fly
EXPNDATE | datetime | 16 | Y/N | Not applicable | Expiration Date: Required when selecting an expired lot layer. Used to specify the date for a newly created lot layer. If an expiration date is supplied for a decrease adjustment/variance, a lot layer needs to exist.
MFGDAT | datetime | 16 | N | <blank> | Manufacturing Date: Used to specify the date for a newly created lot layer.
AUTOCREATELOT | i4 | 4 | N | 0 | Autocreate lot numbers on the fly: 0=False; 1=True
DATERECD | datetime | 16 | N | Not applicable | Date of the lot used for a decrease adjustment override. If DATERECD is not supplied, it will default to the USERDATE value.
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransactionMultiBinInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | Document number
IVDOCTYP | string | 30 | Y | Not applicable | Document types: 1=Adjustment; 2=Variance
ITEMNMBR | number | 21 | Y | Not applicable | Item number
LNSEQNBR | string | 15 | N | 0 | Line item sequence number
QUANTITY | string | 15 | Y | Not applicable | Quantity
ADJTYPE | number | 21 | N | 0 | Adjustment type: 0=Increase; 1=Decrease
BIN | string | 20 | Y | Not applicable | Bin
CreateBin | i4 | 1 | N | 0 | Create bin on the fly: 0=False; 1=True
OverrideBin | i4 | 1 | N | 0 | Override bin shortage flag: 0=Do not override; 1=Override
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransactionSerialInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | Document number
IVDOCTYP | i4 | 2 | Y | Not applicable | Document types: 1=Adjustment; 2=Variance
ITEMNMBR | string | 30 | Y | Not applicable | Item number
SERLNMBR | string | 20 | N | <blank> | Serial number
ADJTYPE | i4 | 2 | N | 0 | Adjustment type: 0=Increase; 1=Decrease
BIN | string | 15 | N | <blank> | Bin; default is autocreate if multibins are enabled and a value for bin is not passed in
CreateBin | i4 | 1 | N | 0 | Create bin on the fly: 0=False; 1=True
LNSEQNBR | number | 21 | N | 0 | Line sequence number
LOCNCODE | string | 10 | N | <blank> | Location code; required only if adding a serial number on the fly for a decrease adjustment
AUTOCREATESERIAL | i4 | 4 | N | 0 | Autocreate serial number on the fly: 0=False; 1=True
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransferHeaderInsert>

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number
IVDOCNBR | string | 17 | Y | Not applicable | IV document number
DOCDATE | datetime | 16 | Y | Not applicable | Document date
POSTTOGL | i4 | 1 | N | 0 | Post to GL: 0=False; 1=True
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransferLineInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | Document number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
Reason_Code | string | 15 | N | <blank> | Reason code
LNSEQNBR | number | 21 | N | 0 | Line item sequence number
TRXQTY | number | 21 | N | 0 | Transaction quantity
UNITCOST | number | 21 | N | 0 | Unit cost
TRXLOCTN | string | 10 | Y | Not applicable | Transaction location
TRNSTLOC | string | 10 | Y | Not applicable | Transfer to location
TRFQTYTY | i4 | 2 | N | 1 | Transfer from quantity: 1=On hand; 2=Returned; 3=In use; 4=In service; 5=Damaged
TRTQTYTY | i4 | 2 | N | 1 | Transfer to quantity: 1=On hand; 2=Returned; 3=In use; 4=In service; 5=Damaged
IVIVINDX | i4 | 4 | N | 0 | Inventory index
InventoryAccount | string | 75 | N | <blank> | Inventory account number string
IVIVOFIX | i4 | 4 | N | 0 | Inventory offset index
InventoryAccountOffSet | string | 75 | N | <blank> | Inventory account number string for offset account
OverrideQty | i4 | 1 | N | 1 | Override quantity flag; to use this element, inventory control must allow for transfer overrides: 0=Reset TRXQTY with quantity available; 1=Override quantity available and use TRXQTY
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransferLotInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | Document number
USERDATE | datetime | 16 | N | Current system time | User Date: Used to determine if a lot is expired
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LOTNUMBR | string | 20 | Y | Not applicable | Lot number
SERLTQTY | number | 21 | Y | Not applicable | Quantity for lot item
LOCNCODE | string | 10 | Y | Not applicable | Location code
EXPNDATE | datetime | 16 | Y/N | Not applicable | Expiration Date: Required when selecting an expired lot layer. Used to specify the date for a newly created lot layer.
MFGDAT | datetime | 16 | N | <blank> | Manufacturing Date: Used to specify the date for a newly created lot layer.
AUTOCREATELOT | i4 | 4 | N | 0 | Autocreate lot number on the fly: 0=False; 1=True
LNSEQNBR | i4 | 4 | N | 0 | Line sequence number
QTYTYPE | i4 | 2 | N | 1 | Transfer from quantity type: 1=On hand; 2=Returned; 3=In use; 4=In service; 5=Damaged
BIN | string | 15 | N | <blank> | Bin (transfer from); required when multibin is enabled
TOBIN | string | 15 | N | <blank> | To bin (transfer to); required when multibin is enabled
TOLOCNCODE | string | 10 | N | <blank> | Transfer to location code; required if creating TOBIN on the fly
CreateBin | i4 | 1 | N | 0 | Create bin on the fly: 0=False; 1=True
OverrideBin | i4 | 1 | N | 0 | Override bin shortage flag: 0=Do not override; 1=Override
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransferMultiBinInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | Document number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LNSEQNBR | number | 21 | N | 0 | Line sequence number; required if the item is on more than one line
BIN | string | 15 | Y | Not applicable | Bin (transfer from)
TOBIN | string | 15 | Y | Not applicable | To bin (transfer to)
QUANTITY | number | 21 | Y | Not applicable | Quantity if serial-numbered quantity must be 1
CreateBin | i4 | 1 | N | 0 | Create bin on the fly: 0=False; 1=True
OverrideBin | i4 | 1 | N | 0 | Override bin shortage flag: 0=Do not override; 1=Override
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taIVTransferSerialInsert>

Element name | Data type | Length | Required | Default | Description
IVDOCNBR | string | 17 | Y | Not applicable | Document number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
SERLNMBR | string | 20 | Y | Not applicable | Serial number
LNSEQNBR | number | 21 | N | 0 | Line sequence number
LOCNCODE | string | 10 | N | <blank> | Location code. Required when adding a serial number on the fly. Also required when multi-bin is enabled and AUTOCREATESERIAL is set to 0.
AUTOCREATESERIAL | i4 | 4 | N | 0 | Autocreate serial number on the fly: 0=False; 1=True
QTYTYPE | i4 | 2 | N | 1 | Transfer from quantity type: 1=On hand; 2=Returned; 3=In use; 4=In service; 5=Damaged
BIN | string | 15 | N | <blank> | Bin (transfer from). Required when multi-bin is enabled and AUTOCREATESERIAL is set to 0.
TOBIN | string | 15 | N | <blank> | To bin (transfer to). Required when multi-bin is enabled and AUTOCREATESERIAL is set to 0.
TOLOCNCODE | string | 10 | N | <blank> | Transfer to location code. Required when creating TOBIN on the fly. Also required when multi-bin is enabled and AUTOCREATESERIAL is set to 0.
CreateBin | i4 | 1 | N | 0 | Create bin on the fly: 0=False; 1=True
OverrideBin | i4 | 1 | N | 0 | Override bin shortage flag: 0=Do not override; 1=Override
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taMdaUpdate>

Element name | Data type | Length | Required | Default | Description
DTASERIES | i4 | 2 | Y | Not applicable | Data series: 2=GL; 3=RM; 4=PM; 1 1=SOP; 12=POP
ACTINDX | i4 | 4 | Y | Not applicable | Account index
SEQNUMBR | i4 | 4 | Y | Not applicable | Sequence number
DTAREF | string | 25 | Y | Not applicable | Data reference
DTAQNTY | number | 21 | Y | Not applicable | Data quantity
GROUPID | string | 15 | Y | Not applicable | Group ID
CODEID | i4 | 2 | Y | Not applicable | Code ID
POSTDESC | string | 50 | N | Default from setup | Can use to override the posting description

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAAccountsSetup>

Element name | Data type | Length | Required | Default | Description
PAsfid | i4 | 2 | Y | Not applicable | PA source file ID: 27=Contract; 28=Project; 35=Contract fee; 34=Project fee
PArecordid | string | 15 | Y | Not applicable | PA record ID
PAcosttrxid | string | 17 | N | <blank> | PA cost transaction ID (leave blank for fee accounts): TS=Timesheet; EL=Employee log; VI=Purchase materials; ML=Miscellaneous log; EE=employee expense
PAaccttype | i4 | 2 | N | 0 | PA account type**
PAAccount | string | 75 | Y | Not applicable | PA account number string
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

** Select one of the following PA account types for the PAaccttype element:

Category | Description
Time and material | 1=Work in progress 2=Cost of goods sold 3=Cost contra 4=Unbilled AR 5=Unbilled revenue 6=Accounts receivable 7=Project revenue sales 8=<OverheadtaPAChangeOrderEntryBudget> XML node
Time and material fees | 7=Project sales 6=Accounts receivables 9=Project deferred revenue
Fixed price/cost plus | 30=Work in progress 31=Cost contra 32=Accounts receivable 33=Project billings 34=Project expense 35=Project revenue 36=Project loss 37=Billings in excess of earnings 38=Earnings in excess of billings 39=Overhead
Fixed price/cost in addition to fees | 30=Project work in progress 32=Accounts receivable 33=Project billings 35=Project revenue 37=Billings in excess of earnings 38=Earnings in excess of billings 40=Retention accounts received 10655=Project deferred revenue

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAChangeOrderEntryBudget>

Element name | Data type | Length | Required | Default | Description
PACHGORDNO | string | 17 | Y | Not applicable | PA change order number
PACONTNUMBER | string | 11 | Y | Not applicable | PA contract number
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PACOSTCATID | string | 15 | Y | Not applicable | PA cost category ID
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence
PAbegindate | datetime | 16 | N | <blank> | PA begin date
PAEnDate | datetime | 16 | N | <blank> | PA end date
PAVarianceQty | number | 21 | N | 0 | PA variance quantity
PAQtyQ | number | 21 | N | 0 | PA quantity
PAVarianceCosts | number | 21 | N | 0 | PA variance costs
PAUNITCOST | number | 21 | N | 0 | PA unit costs
PAVARMUPRCNT | number | 21 | N | 0 | PA variance mark up percent
PAProfitPercent | number | 21 | N | 0 | PA profit percent
PAVARPROFAMT | number | 21 | N | 0 | PA variance profit amount
PAProfitAmount | number | 21 | N | 0 | PA profit amount
PAOvhdAmtPerUnit | number | 21 | N | 0 | PA overhead amount per unit
PAOverheaPercentage | number | 21 | N | 0 | PA overhead percentage
PAVAROVRHDUNIT | number | 21 | N | 0 | PA variance overhead amount per unit
PAVAROVERHDPRCNT | number | 21 | N | 0 | PA variance overhead percentage
PACOSTATUS | i4 | 2 | N | 0 | PA change order status: 1=Pending; 2=Unapproved; 3=Approved; 4=Canceled; 5=Completed
PAGBTRKCHG | i4 | 21 | Y | Not applicable | Track changes: 0=Baseline; 1=Forecast
PASales_Tax_Options | i4 | 2 | N | 0 | PA sales tax options: 1=Taxable; 2=Based on customer; 3=Nontaxable
PAbilltaxscheduleid | string | 15 | N | <blank> | PA billing tax schedule ID
PAPurchase_Tax_Options | number | 21 | N | 0 | PA purchase tax options: 1=Taxable; 2=Based on customer; 3=Nontaxable
PAPURCHTAXSCHED | number | 21 | N | 0 | PA purchase tax schedule ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAChangeOrderEntryFeeDetail>

Element name | Datatype | Length | Required | Default | Description
PACONTNUMBER | string | 11 | Y | Not applicable | PA contract number
PACHGORDNO | string | 17 | Y | Not applicable | PA change order number
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PAFeeID | string | 15 | Y | Not applicable | PA fee ID
PAFeeAmount | number | 21 | N | 0 | Fee amount
PAFeePercent | number | 21 | N | 0 | Fee percent
PAFeeToUse | i4 | 2 | Y | Not applicable | PA fee to use
PASales_Tax_Options | i4 | 2 | N | 0 | PA sales tax options: 1=Taxable; 2=Nontaxable; 3=Based on customer
PAbilltaxscheduleid | string | 15 | N | <blank> | PA billing tax schedule ID
PAFrequency | i4 | 2 | Y | Not applicable | PA frequency: 1=Scheduled; 2=Per invoice; 3=At project completion
PALineItemSeq | i4 | 4 | N | 0 | PA line item sequence
PAbegindate | datetime | 16 | N | <blank> | PA begin date
PAEnDate | datetime | 16 | N | <blank> | PA end date
PARenew | i4 | 2 | N | 0 | PA renew
PARenewal_Date | datetime | 16 | N | <blank> | PA renewal date
PA_Renew_Day | i4 | 4 | N | 0 | PA renewal day
PA_Renew_Month | i4 | 4 | N | 0 | PA renewal month
PAtotcbts | i4 | 1 | N | 0 | Include transaction-type timesheets
PAtotcbEL | i4 | 1 | N | 0 | Include transaction-type equipment logs
PAtotcbML | i4 | 1 | N | 0 | Include transaction-type miscellaneous logs
PAtotcbvi | i4 | 1 | N | 0 | Include transaction-type purchasing inventory
PAtotcber | i4 | 1 | N | 0 | Include transaction-type employee expense
PAtotcbinv | i4 | 1 | N | 0 | Include transaction-type inventory
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAChangeOrderEntryFeeHeader>

Element name | Data type | Length | Required | Default | Description
PACHGORDNO | string | 17 | Y | Not applicable | PA change order number
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PALineItemSeq | i4 | 2 | N | 0 | PA line item sequence
PAbegindate | datetime | 16 | Y | Not applicable | PA begin date
PAEnDate | datetime | 16 | Y | Not applicable | PA end date
PATOTPRJFEEAMT | number | 21 | N | 0 | PA total project fee amount
PATOTRETNFEEAMT | number | 21 | N | 0 | PA total retainer fee amount
PATOTRETNTNAMT | number | 21 | N | 0 | PA total retention fee amount
PATOTSRVCFEEAMT | number | 21 | N | 0 | PA total service fee amount
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAChangeOrderEntryFeeSchedule>

Element name | Datatype | Length | Required | Default | Description
PAFeeID | string | 15 | Y | Not applicable | PA fee ID
PACHGORDNO | string | 17 | Y | Not applicable | PA change order number
PACONTNUMBER | string | 11 | Y | Not applicable | PA contract number
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PAsequencenumber | i4 | 2 | Y | Not applicable | PA sequence number
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence
PADT | datetime | 16 | N | <blank> | Scheduled date
PAFeeAmount | number | 21 | N | 0 | Fee amount
PAGBTRKCHG | i4 | 2 | Y | Not applicable | Track changes: 1=Baseline; 2=Forecast
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAChangeOrderEntryHdr>

Element name | Datatype | Length | Required | Default | Description
PACHGORDNO | string | 17 | Y | Not applicable | PA change order number
PACONTNUMBER | string | 11 | Y | Not applicable | PA contract number
PADOCDT | string | 11 | Y | Not applicable | PA change order date
PAGBTRKCHG | i4 | 2 | Y | Not applicable | Track changes: 0=Baseline; 1=Forecast
PACODESC | string | 15 | N | <blank> | PA change order description
PACOCUSTNO | string | 21 | N | <blank> | PA change order customer number
PACOTYPE | i4 | 2 | N | 0 | PA change order type: 1=Internal; 2=Company; 3=Customer
PACOSTATUS | i4 | 2 | N | 1 | PA change order status*: 1=Pending; 2=Unapproved; 3=Approved; 4=Canceled; 5=Completed (Only 1=Pending is supported at this time)
REQSTDBY | string | 21 | N | <blank> | Requested by
PAESTBY | string | 21 | N | <blank> | Estimated by
PAREVBY | string | 15 | N | <blank> | Revised by
PAREVPOSITION | string | 31 | N | <blank> | Revised by position
PAREVREASON | string | 31 | N | <blank> | Revised reason
PAAPPROVBY | string | 15 | N | <blank> | Approved by
DSCRIPTN | string | 31 | N | <blank> | Approved by description
APPRVLDT | datetime | 16 | N | <blank> | Approval date
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAContractBillingCycle>

Element name | Data type | Length | Required | Default | Description
PACONTNUMBER | string | 11 | Y | Not applicable | PA contract number
PABILLCYCLEID | string | 15 | Y | Not applicable | PA billing cycle ID
PABILLFORMAT | string | 15 | Y | Not applicable | PA billing format ID
Action | i4 | 2 | N | 1 | Action: 1=Add billing cycle; 2=Delete billing cycle
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAContracts>

Element name | Data type | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
PAcontid | string | 15 | Y | Not applicable | PA contract ID
PAcontname | string | 31 | Y | Not applicable | PA contract name
PACONTNUMBER | string | 11 | Y | Not applicable | PA contract number
PAcontclassid | string | 15 | N | Default from setup | PA contract class ID
PAProjectType | i4 | 2 | Y | Not applicable | PA project type: 1=Time and materials; 2=Cost plus; 3=Fixed price
PAAcctgMethod | i4 | 2 | Y | Not applicable | PA accounting method: 1=When performed; 2=When billed; 3=Cost to cost; 4=Effort expended; 5=Completed; 6=Effort expended labor only
PAMCCURNCYID | string | 15 | N | <blank> | PA MC currency ID
PASTAT | i4 | 2 | N | Default from setup | PA status: 1=Open; 2=On hold; 3=Closed; 4=Estimate; 5=Completed
PApurordnum | string | 17 | N | Default from setup | PA purchase order number
PAcloseProjcosts | i4 | 2 | N | Default from setup | PA close to project costs
PAclosetobillings | i4 | 2 | N | Default from setup | PA close to billings
PAUD1_Cont | string | 51 | N | Default from setup | PA user defined 1
PAUD2_Cont | string | 51 | N | Default from setup | PA user defined 2
PAContMgrID | string | 15 | N | Default from setup | PA contract manager ID
PABusMgrID | string | 15 | N | Default from setup | PA business manager ID
ADRSCODE | string | 15 | N | Default from setup | Address code
SLPRSNID | string | 15 | N | Default from setup | Sales person ID
SALSTERR | string | 15 | N | Default from setup | Sales territory ID
COMPRCNT | i4 | 4 | N | Default from setup | Sales commission percent
COMAPPTO | i4 | 2 | N | Default from setup | Sales commission applied to
PABILLFORMAT | string | 15 | N | Default from setup | PA billing format
PRBTADCD | string | 15 | N | Default from setup | Primary bill to address ID
PA_RestrictCustomerList | i4 | 2 | N | Default from setup | PA restrict to customer list
DSCPCTAM | number | 21 | N | Default from setup | Discount percent amount
PASegmentCB | i4 | 2 | N | Default from setup | PA account segment check box
PABILLCYCLEID1 | string | 15 | N | Default from setup | PA billing cycle ID
PATRKCHGORDS | i4 | 2 | N | Default from setup | PA track change orders
PATRKCOBDGADDFLY | i4 | 2 | N | Default from setup | PA track change orders for new budget on the fly
PAbillnoteTS | string | 1000 | N | <blank> | PA billing note—timesheets
PAbillnoteEL | string | 1000 | N | <blank> | PA billing note—equipment logs
PAbillnoteML | string | 1000 | N | <blank> | PA billing note—miscellaneous logs
PAbillnoteVI | string | 1000 | N | <blank> | PA billing note—VI
PAbillnoteEE | string | 1000 | N | <blank> | PA billing note—employee expense
PAbillnoteINV | string | 1000 | N | <blank> | PA billing note—inventory
PAbillnoteFEE | string | 1000 | N | <blank> | PA billing note—fee
UpdateExisting | i4 | 1 | N | 0 | Update functionality does not exist at this time. This element will be used for future releases.
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAEmpExpenseHdrInsert>

Element name | Datatype | Length | Required | Default | Description
PAertrxtype | i4 | 2 | Y | Not applicable | PA employee expense transaction type: 1=Standard; 2=Referenced
PAerdocnumber | string | 17 | Y | Not applicable | PA employee expense document number
PADOCDT | datetime | 16 | Y | Not applicable | PA document date
BACHNUMB | string | 15 | Y | Not applicable | Batch number
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
PAVENADDRESSID | string | 15 | Y | Not applicable | PA vendor address ID
PAStartDate | datetime | 16 | Y | Not applicable | PA start date
PAEnDate | datetime | 16 | Y | Not applicable | PA end date
CURNCYID | string | 15 | Y | Not applicable | Currency ID
USERID | string | 15 | N | <blank> | User ID
PAREFNO | string | 17 | N | <blank> | PA reference document number
SHIPMTHD | string | 15 | N | <blank> | Shipping method
PAUD1 | string | 21 | N | <blank> | PA user defined 1
PAUD2 | string | 21 | N | <blank> | PA user defined 2
PAreptsuff | string | 5 | N | <blank> | PA reporting suffix If an employee has multiple expense transactions that have the same start and end dates, add a sequence number that uniquely identifies each transaction.
PACOMM | string | 51 | N | <blank> | PA comment
PATQTY | number | 21 | N | 0 | PA total quantity
PAREIMBURSTAXAMT | number | 21 | N | 0 | PA reimbursable tax amount
BKTPURAM | number | 21 | N | 0 | Back out purchases amount
PATACRV | number | 21 | N | 0 | PA total accrued revenues
TRDISAMT | number | 21 | N | 0 | Trade discount amount
PAFreight_Taxable_P | i4 | 2 | N | 0 | PA freight taxable: purchase: 1=Taxable; 2=Nontaxable; 3=Based on vendor
FRTSCHID | string | 15 | N | <blank> | Freight schedule ID
FRTAMNT | number | 21 | N | 0 | Freight amount
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
PAMisc_Taxable_P | i4 | 2 | N | 0 | PA miscellaneous taxable: purchase: 1=Taxable; 2=Nontaxable; 3=Based on vendor
MSCSCHID | string | 15 | N | <blank> | Miscellaneous schedule ID
MSCCHAMT | number | 21 | N | 0 | Miscellaneous charges amount
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
DOCAMNT | number | 21 | N | 0 | Document amount
TEN99AMNT | number | 21 | N | 0 | 1099 amount
UN1099AM | number | 21 | N | 0 | Unapplied 1099 amount
CASHAMNT | number | 21 | N | 0 | Cash amount
CAMCBKID | string | 15 | N | <blank> | Cash amount checkbook ID
CDOCNMBR | string | 21 | N | <blank> | Cash document number
CAMTDATE | datetime | 16 | N | <blank> | Cash amount date
CAMPMTNM | string | 21 | N | <blank> | Cash amount payment number
CHRGAMNT | number | 21 | N | 0 | Charge amount
CHEKAMNT | number | 21 | N | 0 | Check amount
CHEKNMBR | string | 21 | N | <blank> | Check number
CHEKDATE | datetime | 16 | N | <blank> | Check date
CAMPYNBR | string | 21 | N | <blank> | Check amount payment number
CHAMCBID | string | 15 | N | <blank> | Check amount checkbook ID
CARDNAME | string | 15 | N | <blank> | Card name
CRCRDAMT | number | 21 | N | 0 | Credit card amount
CRCARDDT | datetime | 16 | N | <blank> | Credit card date
CCAMPYNM | string | 21 | N | <blank> | Credit card payment number
CCRCTNUM | string | 21 | N | <blank> | Credit card receipt number
TAXSCHID | string | 15 | N | <blank> | Tax schedule ID
TAXAMNT | number | 21 | N | 0 | Tax amount
BCKTXAMNT | number | 21 | N | 0 | Back out tax amount
PAReimbursableAmount | number | 21 | N | 0 | PA reimbursable amount
PAPD | datetime | 16 | N | <blank> | PA post date
PApostoDynPM | i4 | 1 | N | 1 | PA post to dynamic payables management: 1=Post to payable management
Tax_Date | datetime | 16 | N | <blank> | Tax date
TaxInvRecvd | i4 | 1 | N | 0 | 1=Tax invoice received
TaxInvReqd | i4 | 1 | N | 0 | 1=Tax invoice received
USINGHEADERLEVELTAXES | i4 | 2 | N | 0 | Using header level taxes
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default is from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default is from setup | Days to increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default is from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default is from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
PDK_EE_No | string | 31 | N | <blank> | PDK employee expense number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAEmpExpenseLineInsert>

Element name | Datatype | Length | Required | Default | Description
PAertrxtype | i4 | 2 | Y | Not applicable | PA employee expense transaction type: 1=Standard 2=Referenced
PAerdocnumber | string | 17 | Y | Not applicable | PA employee expense document number
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
PADT | datetime | 16 | Y | Not applicable | PA date
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PACOSTCATID | string | 15 | Y | Not applicable | PA cost category ID
CURNCYID | string | 15 | Y | Not applicable | Currency ID
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence
PAitemnumber | string | 31 | N | <blank> | PA item number
PAREFNO | string | 17 | N | <blank> | PA reference document number
PAQtyQ | number | 21 | N | 0 | PA quantity
PAUnit_of_Measure | string | 9 | N | <blank> | PA unit of measure
UOMSCHDL | string | 11 | N | <blank> | Unit of measure schedule
PAUNITCOST | number | 21 | N | 0 | PA unit cost
PAPurchase_Tax_Options | i4 | 2 | N | 3 | PA purchase tax options: 1=Taxable; 2=Nontaxable; 3=Based on vendor
ITMTSHID | string | 15 | N | <blank> | Item tax schedule ID
TAXAMNT | number | 21 | N | 0 | Tax amount
BCKTXAMT | number | 21 | N | 0 | Back out tax amount
PAPaymentMethod | i4 | 2 | N | 3 | PA payment method: 1=Cash; 2=Company credit card; 3=Personal credit card
PAExpenseType | i4 | 2 | N | 1 | PA expense type: 1=Reimbursable; 2=Personal expense
PAReference_Line_Seq_N | i4 | 4 | N | 0 | PA reference line sequence number
PAbllngtype | i4 | 2 | N | 1 | PA billing type: 1=Standard; 2=No charge; 3=No billing
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAEmpExpenseTaxInsert>

Element name | Data type | Length | Required | Default | Description
PAertrxtype | i4 | 2 | Y | Not applicable | PA employee expense transaction type: 1=Standard 2=Referenced
PAerdocnumber | string | 17 | Y | Not applicable | PA employee expense document number
LNITMSEQ | i4 | 4 | Y | Not applicable | Line item sequence
TAXDTLID | string | 15 | Y | Not applicable | Tax detail ID
TAXTYPE | i4 | 2 | Y | Not applicable | 0=Regular; 1=Freight; 2=Miscellaneous
EMPLOYID | number | 15 | Y | Not applicable | Employee ID
TAXAMNT | number | 21 | N | 0 | Tax amount
PAREIMBURSTAXAMT | number | 21 | N | 0 | PA reimbursed tax amount
BKOUTTAX | number | 21 | N | 0 | Back out tax
PCTAXAMT | number | 21 | N | 0 | Purchase tax amount
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
TXDTTPUR | number | 21 | N | 0 | Tax detail total purchase
TDTTXPUR | number | 21 | N | 0 | Tax detail total taxable purchase
ACTINDX | i4 | 4 | N | 0 | account Index
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAEquipLogHdrInsert>

Element name | Data type | Length | Required | Default | Description
PAEQLTRX | i4 | 2 | Y | Not applicable | PA Equipment Log Transaction Type 1=Standard 2=Referenced
PAEQLOGNO | string | 17 | Y | Not applicable | PA Equipment Log Document Number
PADOCDT | datetime | 16 | Y | Not applicable | PA Document Date
BACHNUMB | string | 15 | Y | Not applicable | Batch Number
PAEQUIPTID | string | 15 | Y | Not applicable | PA Equipment ID
PAREPD | i4 | 4 | Y | Not applicable | PA Reporting Period
PAREPDT | datetime | 16 | Y | Not applicable | PA Reporting Period Begin Date
CURNCYID | string | 15 | Y | Not applicable | Currency ID
PAREFNO | string | 17 | N | <blank> | PA Reference Document Number
PAreptsuff | string | 5 | N | <blank> | PA Reporting Suffix - used to create a unique record if a record already exists with this PAEQUIPTID,PAREPD combination.
PACOMM | string | 51 | N | <blank> | PA Comment
PATQTY | number | 21 | N | 0 | PA Total Quantity
PAtotcosts | number | 21 | N | 0 | PA Total Costs
PATACRV | number | 21 | N | 0 | PA Total Accrued Revenues
XCHGRATE | number | 21 | N | 0 | Exchange Rate
RATETPID | string | 15 | N | <blank> | Rate Type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration Date
EXCHDATE | datetime | 16 | N | <blank> | Exchange Date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID Desc.
EXTBLSRC | string | 50 | N | <blank> | Exchange Rate Source
RATEEXPR | i4 | 2 | N | <blank> | Rate Expiration The breakdown is: 1=Daily, 2=Weekly, 3=Bi-Weekly, 4=Semi-Monthly, 5=Monthly, 6=Quarterly, 7=Annually, 8=Miscellaneous, 9=None, 0=None
DYSTINCR | i4 | 2 | N | <blank> | Days to Increment Only used when RATEEXPR = 8
RATEVARC | number | 21 | N | 0 | Rate Variance
TRXDTDEF | i4 | 2 | N | 0 | Trx Date Default 0=Exact Date, 1=Next Date, 2=Previous Date
RTCLCMTD | i4 | 2 | N | <blank> | Rate Calc. Method 0=Multiply, 1= Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous Days Limits
DATELMTS | i4 | 2 | N | 0 | Date Limits 0=Unlimited, 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true - if true than populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAEquipLogLineInsert>

Element name | Data type | Length | Required | Default | Description
PAEQLTRX | i4 | 2 | Y | Not applicable | PA Equipment Transaction Type 1=Standard 2=Referenced
PAEQLOGNO | string | 17 | Y | Not applicable | PA Equipment Document Number
PADOCDT | datetime | 16 | Y | Not applicable | PA Document Date
PAEQUIPTID | string | 15 | Y | Not applicable | PA Equipment ID
PAREPD | i4 | 4 | Y | Not applicable | PA Reporting Period
PAREPDT | datetime | 16 | Y | Not applicable | PA Reporting Period Begin Date
CURNCYID | string | 15 | Y | Not applicable | Currency ID
PAREFNO | string | 17 | N | <blank> | PA Reference Document Number
LNITMSEQ | i4 | 4 | N | 0 | Line Item Sequence
PADT | datetime | 16 | Y | Not applicable | PA Date
PAPROJNUMBER | string | 15 | Y | Not applicable | Project ID
PACOSTCATID | string | 15 | Y | Not applicable | Cost Category ID
PATB | datetime | 16 | N | <blank> | PA Time Begin
PATE | datetime | 16 | N | <blank> | PA Time End
PAQtyQ | number | 21 | N | 0 | PA Quantity
PAbllngtype | i4 | 2 | N | 1 | PA Billing Type 1=STD, 2=N/C, 3=N/B
PAUnit_of_Measure | string | 9 | N | <blank> | PA Unit of Measure
PAUNITCOST | number | 21 | N | 0 | PA Unit Cost
PATOTCST | number | 21 | N | 0 | PA Total Cost
PAtx500 | string | 256 | N | <blank> | PA Billing Note Text
RequesterTrx | i4 | 2 | N | 0 | Requester Transaction 0=false, 1=true - if true than populates Requester shadow table
USRDEFND1 | string | 50 | N | <blank> | User-defined field - developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field - developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field - developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field - developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field - developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAMiscLogHdrInsert>

Element name | Data type | Length | Required | Default | Description
PSMISCLTRXTYPE | i4 | 2 | Y | Not applicable | PA miscellaneous log transaction type: 1=Standard; 2=Referenced
PAMISCLDOCNO | string | 17 | Y | Not applicable | PA miscellaneous log number
PADOCDT | datetime | 16 | Y | Not applicable | PA document date
BACHNUMB | string | 15 | Y | Not applicable | Batch number
PSMISCID | string | 15 | Y | Not applicable | PA miscellaneous ID
PAREPD | i4 | 4 | Y | Not applicable | PA reporting period
PAREPDT | datetime | 16 | Y | Not applicable | PA reporting period begin date
CURNCYID | string | 15 | Y |  | Currency ID
PAREFNO | string | 17 | N | <blank> | PA Reference document number
PAreptsuff | string | 5 | N | <blank> | PA reporting suffix
PACOMM | string | 51 | N | <blank> | PA comment
PATQTY | number | 21 | N | 0 | PA total quantity
PAtotcosts | number | 21 | N | 0 | PA total costs
PATACRV | number | 21 | N | 0 | PA total accrued revenues Always use the default value. The amount of accrued revenue is always calculated. If you specify a value other than the default, an error will occur.
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default is from setup | Rate expiration 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default is from setup | Days to increment; used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default is from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default is from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAMiscLogLineInsert>

Element name | Data type | Length | Required | Default | Description
PSMISCLTRXTYPE | i4 | 2 | Y | Not applicable | PA miscellaneous transaction type: 1=Standard; 2=Referenced
PAMISCLDOCNO | string | 17 | Y | Not applicable | PA miscellaneous log number
PADOCDT | datetime | 16 | Y | Not applicable | PA document date
PSMISCID | string | 15 | Y | Not applicable | PA miscellaneous ID
PAREPD | i4 | 4 | Y | Not applicable | PA reporting period
PAREPDT | datetime | 16 | Y | Not applicable | PA reporting period begin date
CURNCYID | string | 15 | Y | Not applicable | Currency ID
PAREFNO | string | 17 | N | <blank> | PA reference document number
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence
PADT | datetime | 16 | Y | Not applicable | PA date
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PACOSTCATID | string | 15 | Y | Not applicable | Cost category ID
PAQtyQ | number | 21 | N | 0 | PA quantity
PAbllngtype | i4 | 2 | N | 1 | PA billing type: 1=Standard; 2=No charge; 3=No billing
PAUnit_of_Measure | string | 9 | N | <blank> | PA unit of measure
PAUNITCOST | number | 21 | N | Default from setup | PA unit cost
PATOTCST | number | 21 | N | 0 | PA total cost
Patx500 | string | 256 | N | <blank> | PA billing note text
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAProjectAccess>

Element name | Data type | Length | Required | Default | Description
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
EMPLOYID | string | 15 | Y | Not applicable | PA employee ID
Action | i4 | 2 | Y | Not applicable | Action: 1=Add employee; 2=Delete employee
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAProjectBillingCycle>

Element name | Data type | Length | Required | Default | Description
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PABILLCYCLEID | string | 15 | Y | Not applicable | PA billing cycle ID
PABILLFORMAT | string | 15 | Y | Not applicable | PA billing format
Action | i4 | 2 | N | 1 | Action: 1=Add billing cycle; 2=Delete billing cycle
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAProjectBudgetMaster>

Element name | Data type | Length | Required | Default | Description
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PACOSTCATID | string | 15 | Y | Not applicable | PA cost category ID
PASTAT | i4 | 2 | N | Default from setup | PA status: 1=Open; 2=On hold; 3=Closed*; 4=Estimate; 5=Completed (*note the closed status is not supported in this release)
PAProfitType | i4 | 2 | N | Default from setup | PA profit type: 1=Billing rate; 2=Markup percentage; 3=Price unit fixed; 4=Price unit variable; 5=Total profit; 6=Percent of baseline; 7=Percent of actual; 8=None; 9=Price level
PAbllngtype | i4 | 2 | N | Default from setup | PA billing type: 1=Standard; 2=No charge; 3=No billing
PABBeginDate | datetime | 16 | N | Default from setup | PA begin date
PABEndDate | datetime | 16 | N | Default from setup | PA end date
LNITMSEQ | i4 | 4 | N | Default from setup | Line item sequence
PALineItemSeq | i4 | 4 | N | Default from setup | PA line item sequence
PABQuantity | number | 21 | N | Default from setup | PA baseline quantity
PABUnitCost | number | 21 | N | Default from setup | PA baseline cost
PABProfitAmt | number | 21 | N | Default from setup | PA baseline profit amount
PABProfitPcnt | number | 21 | N | Default from setup | PA baseline profit percent
PABTotalCost | number | 21 | N | Default from setup | PA baseline total cost
PABaselineOvhdAmtPerUnit | number | 21 | N | Default from setup | PA baseline overhead amount per unit
PABaselineOvrhdPct | number | 21 | N | Default from setup | PA baseline overhead percent
PABaselinePTaxOptions | i4 | 2 | N | Default from setup | PA baseline purchase tax options
PABaselineCTaxSchedID | string | 15 | N | Default from setup | PA baseline cost tax schedule ID
PABaselineSTaxOptions | i4 | 2 | N | Default from setup | PA baseline sales tax options
PABaselineBTaxSchedID | string | 15 | N | Default from setup | PA baseline billings tax schedule ID
PAFQuantity | number | 21 | N | Default from setup | PA forecast quantity
PAFUnitCost | number | 21 | N | Default from setup | PA forecast cost
PAFTotalCost | number | 21 | N | Default from setup | PA forecast total cost
PAFProfitAmt | number | 21 | N | Default from setup | PA forecast profit amount
PAFProfitPcnt | number | 21 | N | Default from setup | PA forecast profit percent
PAForecastOvrhdAmtPerUnt | number | 21 | N | Default from setup | PA forecast overhead amount per unit
PAForecastOvrhdPct | number | 21 | N | Default from setup | PA forecast overhead percent
PAForecastPTaxOptions | i4 | 2 | N | Default from setup | PA forecast purchase tax options
PAForecastCTaxSchedID | string | 15 | N | Default from setup | PA forecast cost tax schedule ID
PAForecastSTaxOptions | i4 | 2 | N | Default from setup | PA forecast sales tax options
PAForecastBTaxSchedID | string | 15 | N | Default from setup | PA forecast billings tax schedule ID
PAFBeginDate | datetime | 16 | N | Default from setup | PA forecast begin date
PAFEndDate | datetime | 16 | N | Default from setup | PA forecast end date
PAUnit_of_Measure | string | 9 | N | Default from setup | PA unit of measure
UOMSCHDL | string | 11 | N | Default from setup | Unit of measure schedule
PAPay_Code_Hourly | string | 7 | N | Default from setup | PA pay code hourly
PAPay_Code_Salary | string | 7 | N | Default from setup | PA pay code salary
UpdateExisting | i4 | 1 | N | Default from setup | Update functionality does not exist at this time; this will be used for future release
RollUpEst_to_Forecast | i4 | 1 | N | Default from setup | Flag that determines whether or not changes made in estimate status roll up to forecast values: 0=No rollup; 1=Roll up to forecast values
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAProjectEquip>

Element name | Data type | Length | Required | Default | Description
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PAEQUIPTID | string | 15 | Y | Not applicable | PA equipment ID
Action | i4 | 2 | N | 1 | Action: 1=Add; 2=Delete
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAProjectFee>

Element name | Data type | Length | Required | Default | Description
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PAFeeID | string | 15 | Y | Not applicable | PA fee ID
PALineItemSeq | i4 | 4 | N | 0 | PA line item sequence
PAFeeAmount | number | 21 | N | 0 | PA fee amount
PAPercent_Cost | number | 21 | N | 0 | PA percent of cost
PAPercent_Revenue | number | 21 | N | 0 | PA percent of revenue
PA_Retention_Percent | number | 21 | N | 0 | PA retention percent
PAService_Fee_Amount | number | 21 | N | 0 | PA service fee amount
PAbilltaxscheduleid | string | 15 | N | <blank> | PA billing tax schedule ID
UpdateExisting | i4 | 1 | N | 0 | Updating functionality does not exist at this time; this will be used for future release
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

If you use PAFeeAmount to specify the amount of a retainer fee, the retainer fee is added to the project fee amount.

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAProjectFeeSchedule>

Element name | Data type | Length | Required | Default | Description
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
LNITMSEQ | i4 | 15 | N | 0 | Line item sequence
PAFeeID | string | 4 | Y | Not applicable | PA fee ID
PADT | datetime | 21 | N | <blank> | Schedule date
PAFeeAmount | number | 21 | N | 0 | Fee amount
UpdateExisting | i4 | 1 | N | 0 | Updating functionality does not exist at this time; this will be used for future release
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPAProjects>

Element name | Data type | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
PACONTNUMBER | string | 11 | Y | Not applicable | PA contract number
PAprojid | string | 15 | Y | Not applicable | PA project ID
PAprojname | string | 31 | Y | Not applicable | PA project name
PAPROJNUMBER | string | 15 | Y | Not applicable | PA project number
PAProjectType | i4 | 2 | N | Default from setup | PA project type: 1=Time and materials; 2=Cost plus; 3=Fixed price
PAAcctgMethod | i4 | 2 | N | Default from setup | PA account method: 1=When performed; 2=When billed; 3=Cost to cost; 4=Effort expended; 5=Completed; 6=Effort expended labor only
PASTAT | i4 | 2 | N | Default from setup | PA status: 1=Open; 2=On hold; 3=Closed; 4=Estimate; 5=Completed
PABBeginDate | datetime | 16 | N | Default from setup | PA baseline begin date
PABEndDate | datetime | 16 | N | Default from setup | PA baseline end date
PAprjclsid | string | 15 | N | Default from setup | PA project class ID
PApurordnum | string | 17 | N | Default from setup | PA purchase order number
PAcloseProjcosts | i4 | 2 | N | Default from setup | PA close to project costs
PAclosetobillings | i4 | 2 | N | Default from setup | PA close to billings
PADepartment | string | 7 | N | Default from setup | PA department
PAEstimatorID | string | 15 | N | Default from setup | PA estimator ID
PAprojmngrid | string | 15 | N | Default from setup | PA project manager ID
PABusMgrID | string | 15 | N | Default from setup | PA business manager ID
PALabor_Rate_Table_ID | string | 31 | N | Default from setup | PA labor rate table ID
PALabor_RateTable_Type | i4 | 2 | N | Default from setup | PA labor rate table type
PALabor_Rate_Table_Acc | i4 | 2 | N | Default from setup | PA labor rate table accept replacements
PAEquip_Rate_Table_ID | string | 31 | N | Default from setup | PA equipment rate table ID
PAEquip_Rate_Table_Acc | i4 | 2 | N | Default from setup | PA equipment rate table accept replacements
PAbllngtype | i4 | 2 | N | Default from setup | PA billing type: 1=Standard; 2=No charge; 3=No billing
PABILLFORMAT | string | 15 | N | Default from setup | PA billing format
DSCPCTAM | i4 | 2 | N | Default from setup | Discount percent amount
PA_Retention_Percent | number | 21 | N | Default from setup | PA retention percent
PAUD1Proj | string | 51 | N | Default from setup | PA user defined 1
PAUD2_Proj | string | 51 | N | Default from setup | PA user defined 2
PASegmentCB | i4 | 2 | N | Default from setup | PA segment check box
PRBTADCD | string | 15 | N | Default from setup | Primary bill to address code
PAbillnoteDefault | string | 1000 | N | Default from setup | PA billing note— default
PAbillnoteTS | string | 1000 | N | Default from setup | PA billing note—timesheets
PAbillnoteEL | string | 1000 | N | Default from setup | PA billing note—equipment logs
PAbillnoteML | string | 1000 | N | Default from setup | PA billing note—miscellaneous logs
PAbillnoteVI | string | 1000 | N | Default from setup | PA billing note—VI
PAbillnoteEE | string | 1000 | N | Default from setup | PA billing note—employee expense
PAbillnoteINV | string | 1000 | N | Default from setup | PA billing note—inventory
PAbillnoteFEE | string | 1000 | N | Default from setup | PA billing note—fee
PABILLCYCLEID1 | string | 15 | N | Default from setup | PA billing cycle ID
PA_RestrictCustomerList | i4 | 2 | N | Default from setup | PA restrict customer list
WRKRCOMP | string | 7 | N | Default from setup | Workers' compensation ID
SUTASTAT | string | 3 | N | Default from setup | SUTA state ID
PATRKCHGORDS | i4 | 2 | N | Default from setup | PA track change orders
PATRKCOBDGADDFLY | i4 | 2 | N | Default from setup | PA track change orders for new budget on the fly
UpdateExisting | i4 | 1 | N | 0 | Update functionality does not exist at this time; this will be used for future release
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taParentIDChild>

Element name | Datatype | Length | Required | Default | Description
CPRCSTNM | string | 15 | Y | Not applicable | Corporate customer number
CUSTNMBR | string | 15 | Y | Not applicable | Customer number to assign as child
CreateRemove | i4 | 1 | N | 0 | Create/Remove flag: 0=Create new child record; 1=Remove child record
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taPATimeSheetHdrInsert>

Element name | Data type | Length | Required | Default | Description
PATSTYP | i4 | 2 | Y | Not applicable | PA timesheet transaction type: 1=Standard; 2=Referenced
PATSNO | string | 17 | Y | Not applicable | PA timesheet number
PADOCDT | datetime | 16 | Y | Not applicable | PA document date
BACHNUMB | string | 15 | Y | Not applicable | Batch number
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
PAREPD | i4 | 4 | Y | Not applicable | PA reporting period
PAREPDT | datetime | 16 | Y | Not applicable | PA reporting period begin date
CURNCYID | string | 15 | Y | Not applicable | Currency ID
PAREFNO | string | 17 | N | <blank> | PA reference document number
PAreptsuff | string | 5 | N | <blank> | PA reporting suffix
PACOMM | string | 51 | N | <blank> | PA comment
PATQTY | number | 21 | N | 0 | PA total quantity
PAtotcosts | number | 21 | N | 0 | PA total costs
PATACRV | number | 21 | N | 0 | PA total accrued revenues
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment; used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
USERID | string | 15 | N | <blank> | User ID
PDK_TS_No | string | 31 | N | <blank> | PDK timesheet number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPATimeSheetLineInsert>

Element name | Data type | Length | Required | Default | Description
PATSTYP | i4 | 2 | Y | Not applicable | PA timesheet transaction type: 1=Standard; 2=Referenced
PATSNO | string | 17 | Y | Not applicable | PA timesheet number
EMPLOYID | string | 15 | Y | Not applicable | Employee ID
CURNCYID | string | 15 | Y | Not applicable | Currency ID
PAREFNO | string | 17 | N | <blank> | PA reference document number
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence
PADT | datetime | 16 | Y | Not applicable | PA date
PAPROJNUMBER | number | 21 | Y | Not applicable | Project ID
PACOSTCATID | string | 15 | Y | Not applicable | Cost category ID
PATB | datetime | 16 | N | <blank> | PA time begin
PATE | datetime | 16 | N | <blank> | PA time end
PAQtyQ | number | 21 | N | 0 | PA quantity
PAbllngtype | i4 | 2 | N | 1 | PA billing type: 1=Standard; 2=No charge; 3=No billing
PAUnit_of_Measure | string | 9 | N | <blank> | PA unit of measure
PAUNITCOST | number | 21 | N | Default from setup | PA unit cost
PAPayCode | string | 7 | N | <blank> | PA pay code
PADepartment | string | 7 | N | <blank> | PA department
PAJob_Title | string | 7 | N | <blank> | PA job title
PATOTCST | number | 21 | N | 0 | PA total cost
PASalary_Posting_Type | i4 | 2 | N | 0 | PA salary posting type: 0=No post; 1=Reallocate dollars; 2=Reallocate hours; 3=Additional amount
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
PAtx500 | string | 8000 | N | <blank> | PA billing note text
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User—defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPMDistribution>

Element name | Data type | Length | Required | Default | Description
DOCTYPE | i4 | 2 | Y | Not applicable | Document type: 1=Invoice; 2=Finance charge; 3=Miscellaneous charge; 4=Return; 5=Credit memo; 6=Manual checks
VCHRNMBR | string | 17 | Y | Not applicable | Voucher number/payment number; if passing a manual check, pass in payment number
VENDORID | string | 15 | Y | Not applicable | Vendor ID
DSTSQNUM | i4 | 4 | N | 0 | Sequence number
DISTTYPE | i4 | 2 | Y | Not applicable | Distribution type: 1=Cash; 2=Pay; 3=Avail; 4=Taken; 5=Fnchg; 6=Purch; 7=Trade; 8=Misc; 9=Freight; 10=Taxes; 11=Write; 12=Other; 13=Gst; 14=Wh; 15=Unit; 16=Round
DistRef | string | 30 | N | <blank> | Distribution reference
ACTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Account number string
DEBITAMT | number | 21 | N | 0 | Debit amount
CRDTAMNT | number | 21 | N | 0 | Credit amount
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

The following are the valid distribution types (DISTYPE) for each document type (DOCTYPE):

DOCTYPE | Distribution types
1 | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
2 | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
3 | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
4 | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
5 | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15
6 | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15

If you set the DISTTYPE element to 15 (unit accounts), a unit account index is required.

Notice that all the distribution types are valid except DISTTYPE=16. DISTTYPE=16 is reserved. The system uses this distribution type when it needs to automatically create a multi-currency rounding difference.

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPMManualCheck>

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number; batch for the manual check—created on the fly
PMNTNMBR | string | 17 | Y | Not applicable | Payment/voucher number
VENDORID | string | 15 | Y | Not applicable | Vendor ID
DOCNUMBR | string | 20 | Y | Not applicable | Document/check number
DOCAMNT | number | 21 | Y | Not applicable | Document/check amount
DOCDATE | datetime | 16 | Y | Not applicable | Document date
PSTGDATE | datetime | 16 | N | <blank> | Posting date
PYENTTYP | i4 | 2 | Y | Not applicable | Payment entry type: 0=Check; 1=Cash; 2=Credit card
CARDNAME | string | 15 | N | <blank> | Credit card name; required if choosing PYENTTYP=2
CURNCYID | string | 15 | N | <blank> | Currency ID
CHEKBKID | string | 15 | N | <blank> | Checkbook ID; required if choosing PYENTTYP=0 or 1
TRXDSCRN | string | 30 | N | <blank> | Transaction description
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment; used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits
TIME1 | datetime | 16 | N | <blank> | Time 1: 0=Unlimited; 1=Limited
MDFUSRID | string | 15 | N | <blank> | Modified user ID
PTDUSRID | string | 15 | N | <blank> | Posted user ID
BatchCHEKBKID | string | 15 | N | <blank> | Checkbook ID for the batch
CREATEDIST | i4 | 2 | N | 1 | Flag to autocreate distributions: 0=Manual; 1=Automatic—use if not calling <taPMDistribution> node
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPMSchedPmnts>

Element name | Data type | Length | Required | Default | Description
ORIG_VOUCHER_NUM | string | 21 | Y | Not applicable | Original voucher number
ORIG_DOC_TYPE | i4 | 2 | Y | Not applicable | Original document type: 1=Invoice; 3=Miscellaneous charge
PAY_OFFSET_ACCT_IDX | i4 | 2 | Y/N | 0 | Payables offset account index; either the index or string is required
PayOffsetAccount | string | 75 | Y/N | <blank> | Payable offset account string. (The account string is checked first. If it is populated, the account index is set based on the string. If the account string is not populated, account index is used.)
FIRST_INV_DOC_DATE | datetime | 16 | N | <blank> | First invoice document date; required if payment frequency is 1=semimonthly and the day must be either the first or the fifteenth (day requirement for semimonthly only)
FIRST_INV_DUE_DATE | datetime | 16 | N | <blank> | First invoice due date; required if payment frequency is 1=semimonthly and the day must be either the first or the fifteenth (day requirement for semimonthly only)
INT_EXP_ACCT_IDX | i4 | 4 | N | 0 | Interest expense account index; either the index or the string is required if interest rate entered
IntExpenseAccount | string | 75 | N | <blank> | Interest expense account string; either the index or the string is required if interest rate entered
PAYMENT_AMOUNT | number | 21 | N | 0 | Payment amount; if both PAYMENT_AMOUNT and NUM_PAYMENTS are passed in, the number of payments will be recalculated
NUM_PAYMENTS | i4 | 2 | N | 0 | Number of payments; either the number of payments or the payment amount must be greater than 0 (both cannot be zero); if payment amount is entered, the number of payments must hold a value of 1 (minimum) through 999 (maximum)
SCHEDULE_NUMBER | string | 21 | N | <blank> | Schedule number; will get next number optional to pass in
PYMNT_FREQUENCY | i4 | 2 | N | 2 | Payment frequency: 1=Semimonthly; 2=Monthly; 3=Quarterly; 4=Semiannually; 5=Annually
PAY_ACCT_IDX | i4 | 4 | N | 0 | Accounts payable account index
PayAccount | string | 75 | N | <blank> | Account payable account string; use if want to override the default
SCH_DOC_DATE | datetime | 16 | N | <blank> | Schedule document date; will get from original document
SCHEDULE_AMOUNT | number | 21 | N | 0 | Schedule amount; will get from original document
SCHEDULE_DESC | string | 31 | N | <blank> | Schedule description
SCHEDULE_INT_RATE | number | 21 | N | 0 | Schedule interest rate; front end allows negative interest but this will not; interest rate can range from 0.0001 through 99.9999
SCHEDULE_INT_TYPE1 | i4 | 2 | N | 0 | Schedule interest type: 0=Compound; 1=Simple
USERID | string | 15 | N | eConnect | User ID used to update the PM keys
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPMTransactionInsert>

Element name | Data type | Length | Required | Default | Description
BACHNUMB | string | 15 | Y | Not applicable | Batch number; batch for the cash receipt; created on the fly
VCHNUMWK | string | 17 | Y | Not applicable | Voucher number—must be unique
VENDORID | string | 15 | Y | Not applicable | Vendor ID
DOCNUMBR | string | 20 | Y | Not applicable | Document number—unique based on PM40100 setup option
DOCTYPE | i4 | 2 | Y | Not applicable | Document type: 1=Invoice 2=Finance Charge 3=Miscellaneous Charge 4=Return 5=Credit Memo
DOCAMNT | number | 21 | Y | Not applicable | Document amount=MSCCHAMT + PRCHAMNT + TAXAMNT + FRTAMNT – TRDISAMT
DOCDATE | datetime | 16 | Y | Not applicable | Document date
PSTGDATE | datetime | 16 | N | <blank> | Posting date
VADCDTRO | string | 15 | N | <blank> | Remit to Address ID
VADDCDPR | string | 15 | N | <blank> | Primary address ID; must exist if filled - use <taCreateVendorAddress> to create the master record
PYMTRMID | string | 20 | N | Default from setup | Payment terms ID; must exist if filled
TAXSCHID | string | 15 | N | <blank> | Tax schedule ID; must exist if filled and a tax amount is passed in
DUEDATE | datetime | 16 | N | <blank> | Due date
DSCDLRAM | number | 21 | N | Default from setup | Discount dollar amount
DISCDATE | datetime | 16 | N | <blank> | Discount date
PRCHAMNT | number | 21 | N | 0 | Purchases amount
CHRGAMNT | number | 21 | N | 0 | Charge amount=DOCAMNT – CASHAMNT –CHEKAMNT – CRCRDAMT – DISTKNAM (required if on account amount)
CASHAMNT | number | 21 | N | 0 | Cash amount
CAMCBKID | string | 15 | N | <blank> | Cash amount checkbook ID
CDOCNMBR | string | 20 | N | <blank> | Cash document number—required if cash amount is greater than 0
CAMTDATE | datetime | 16 | N | <blank> | Cash amount date
CAMPMTNM | string | 20 | N | <blank> | Cash amount payment number
CHEKAMNT | number | 21 | N | 0 | Check amount
CHAMCBID | string | 15 | N | <blank> | Check amount checkbook ID
CHEKDATE | datetime | 16 | N | <blank> | Check amount date
CAMPYNBR | string | 20 | N | <blank> | Check payment number
CRCRDAMT | number | 21 | N | 0 | Credit card amount
CCAMPYNM | string | 20 | N | <blank> | Credit card payment number
CHEKNMBR | string | 20 | N | <blank> | Check document number
CARDNAME | string | 15 | N | <blank> | Credit card name
CCRCTNUM | string | 20 | N | <blank> | Credit card receipt number
CRCARDDT | datetime | 16 | N | <blank> | Credit card amount date
CHEKBKID | string | 15 | N | <blank> | Checkbook ID
TRXDSCRN | string | 30 | N | <blank> | Transaction description
TRDISAMT | number | 21 | N | 0 | Trade discount amount
TAXAMNT | number | 21 | N | 0 | Tax amount
FRTAMNT | number | 21 | N | 0 | Freight amount
TEN99AMNT | number | 21 | N | 0 | 1099 amount
MSCCHAMT | number | 21 | N | 0 | Miscellaneous charge amount
PORDNMBR | string | 20 | N | <blank> | Purchase order number
SHIPMTHD | string | 15 | N | <blank> | Shipping method
DISAMTAV | number | 21 | N | Default from setup | Discount amount available
DISTKNAM | number | 21 | N | 0 | Discount taken amount
APDSTKAM | number | 21 | N | 0 | Applied discount taken amount
MDFUSRID | string | 15 | N | <blank> | Modified user ID
POSTEDDT | datetime | 16 | N | <blank> | Posted date
PTDURID | string | 15 | N | <blank> | Posted user ID
PCHSCHID | string | 15 | N | <blank> | Purchase schedule ID
FRTSCHID | string | 15 | N | <blank> | Freight schedule ID
MSCSCHID | string | 15 | N | <blank> | Miscellaneous schedule ID
PRCTDISC | number | 21 | N | Default from setup | Percent discount
Tax_Date | datetime | 16 | N | <blank> | Tax date
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATEPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits
TIME1 | datetime | 16 | N | <blank> | Time 1: 0=Unlimited; 1=Limited
BatchCHEKBKID | string | 15 | N | <blank> | Checkbook ID for the batch
CREATEDIST | i4 | 2 | N | 1 | Flag to autocreate distributions: 0=Manual; 1=Automatic—use if not calling the <taPMDistribution> node
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPMTransactionTaxInsert>

Element name | Data type | Length | Required | Default | Description
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VCHRNMBR | string | 17 | Y | Not applicable | Voucher number—must be a unique number
DOCTYPE | i4 | 2 | Y | Not applicable | Document type: 1=Invoice 2=Finance Charge 3=Miscellaneous Charge 4=Return 5=Credit Memo
BACHNUMB | string | 15 | Y | Not applicable | Batch number—batch for cash receipt;. created on the fly, populates SY00500 and RM10301
TAXDTLID | string | 15 | Y | Not applicable | Tax detail ID
TAXAMNT | number | 21 | Y | Not applicable | Tax amount
PCTAXAMT | number | 21 | N | 0 | Purchases tax amount
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
TDTTXPUR | number | 21 | N | 0 | Tax detail purchases—this is the goods value
TXDTTPUR | number | 21 | N | 0 | Total tax detail purchased
ACTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Account number string
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPoHdr>*

Element name | Data type | Length | Required | Default | Description
POTYPE | i4 | 2 | N | 1 | 1=Standard (items shipped to business); 2=Drop ship (items shipped direct to customer) 3=Blanket 4=Drop Ship Blanket
PONUMBER | string | 17 | Y | Not applicable | Unique identifier for the PO
VENDORID | string | 15 | Y | Not applicable | ID of the vendor you are purchasing from
VENDNAME | string | 64 | N | Default from setup | Name of the vendor
DOCDATE | datetime | 16 | N | Default is current date | Document date; date of the purchase order
BUYERID | string | 15 | N | Default from setup | Buyer who is responsible for the purchase order
ALLOWSOCMTS | i4 | 1 | N | Default from setup | Allow sales commitments: 1=Allow PO to be committed to SOP line items
TRDISAMT | number | 21 | N | Default from setup | Trade discount amount
FRTAMNT | number | 21 | N | Default from setup | Freight amount
MSCCHAMT | number | 21 | N | Default from setup | Miscellaneous charge amount
TAXAMNT | number | 21 | N | Default from setup | Tax amount
SUBTOTAL | number | 21 | Y | Default from setup | Subtotal=Total before taxes
CUSTNMBR | string | 15 | N | Default from setup | Customer ID to which the vendor is shipping the items on a drop ship
PRSTADCD | string | 15 | N | Default from setup | Address ID to which the order is being sent
CMPNYNAM | string | 64 | N | Default from setup | Company associated with the ship to address ID
CONTACT | string | 30 | N | Default from setup | Contact person for the ship to address ID
ADDRESS1 | string | 30 | N | Default from setup | Address line 1 of the ship to address ID
ADDRESS2 | string | 30 | N | Default from setup | Address line 2 of the ship to address ID
ADDRESS3 | string | 30 | N | Default from setup | Address line 3 of the ship to address ID
CITY | string | 30 | N | Default from setup | City of the ship to address ID
STATE | string | 29 | N | Default from setup | State of the ship to address ID
ZIPCODE | string | 10 | N | Default from setup | ZIP Code/postal code of the ship to address ID
CCode | string | 6 | N | Default from setup | Country code
COUNTRY | string | 20 | N | Default from setup | Country of the ship to address ID
PHONE1 | string | 21 | N | Default from setup | Phone number at the ship to address ID
PHONE2 | string | 21 | N | Default from setup | Additional phone number at the ship to address ID
PHONE3 | string | 21 | N | Default from setup | Additional phone number at the ship to address ID
FAX | string | 21 | N | Default from setup | Fax number at the ship to address ID
Print_Phone_NumberGB | i4 | 2 | N | Default from setup | Print phone number: 0=Do not print; 1=Phone 1; 2=Phone 2; 3=Phone 3; 4=Fax
VADCDPAD | string | 15 | N | Default from setup | Vendor address code
PURCHCMPNYNAM | string | 64 | N | Default from setup | Purchase company name
PURCHCONTACT | string | 30 | N | Default from setup | Purchase contact
PURCHADDRESS1 | string | 30 | N | Default from setup | Purchase address 1
PURCHADDRESS2 | string | 30 | N | Default from setup | Purchase address 2
PURCHADDRESS3 | string | 30 | N | Default from setup | Purchase address 3
PURCHCITY | string | 30 | N | Default from setup | Purchase city
PURCHSTATE | string | 29 | N | Default from setup | Purchase state
PURCHZIPCODE | string | 10 | N | Default from setup | Purchase zip code
PURCHCCode | string | 6 | N | Default from setup | Purchase country code
PURCHCOUNTRY | string | 20 | N | Default from setup | Purchase country
PURCHPHONE1 | string | 21 | N | Default from setup | Purchase phone 1
PURCHPHONE2 | string | 21 | N | Default from setup | Purchase phone 2
PURCHPHONE3 | string | 21 | N | Default from setup | Purchase phone 3
PURCHFAX | string | 21 | N | Default from setup | Purchase fax
PRBTADCD | string | 15 | N | Default from setup | Bill to address ID
SHIPMTHD | string | 15 | N | Default from setup | Shipping method
PYMTRMID | string | 20 | N | Default from setup | Payment terms extended to your company by the vendor
DSCPCTAM | number | 21 | N | Default from setup | Discount percent amount
DSCDLRAM | number | 21 | N | Default from setup | Discount dollar amount
DISAMTAV | number | 21 | N | Default from setup | Discount available amount
DUEDATE | datetime | 16 | N | Default from setup | Due date
DISCDATE | datetime | 16 | N | Default from setup | Discount date
TXRGNNUM | string | 25 | N | Default from setup | Vendor’s tax registration number
CONFIRM1 | string | 20 | N | Default from setup | Name of the person the order should be approved by
COMMNTID | string | 15 | N | Default from setup | Comment ID
COMMENT_1 | string | 50 | N | Default from setup | Comment part 1
COMMENT_2 | string | 50 | N | Default from setup | Comment part 2
COMMENT_3 | string | 50 | N | Default from setup | Comment part 3
COMMENT_4 | string | 50 | N | Default from setup | Comment part 4
HOLD | i4 | 1 | N | 0 | 0=Not on hold; 1=On hold
TAXSCHID | string | 15 | N | Default from setup | Tax schedule ID
Purchase_Freight_Taxable | i4 | 2 | N | Default from setup | Purchase freight taxable: 1=Taxable; 2=Nontaxable; 3=Based on vendor
Purchase_Misc_Taxable | i4 | 2 | N | Default from setup | Purchase miscellaneous taxable: 1=Taxable; 2=Nontaxable; 3=Based on vendor
FRTSCHID | string | 15 | N | Default from setup | Freight tax schedule ID
MSCSCHID | string | 15 | N | Default from setup | Miscellaneous tax schedule ID
FRTTXAMT | number | 21 | N | Default from setup | Freight tax amount
MSCTXAMT | number | 21 | N | Default from setup | Miscellaneous tax amount
BCKTXAMT | number | 21 | N | Default from setup | Back tax amount
BackoutFreightTaxAmt | number | 21 | N | Default from setup | Back out freight tax amount
BackoutMiscTaxAmt | number | 21 | N | Default from setup | Back out miscellaneous tax amount
BackoutTradeDiscTax | number | 21 | N | Default from setup | Back out trade discount tax amount
USINGHEADERLEVELTAXES | i4 | 2 | N | Default from setup | Using header level taxes
CURNCYID | string | 15 | N | Default from setup | Currency ID
XCHGRATE | number | 21 | N | Default from setup | Exchange rate
RATETPID | string | 15 | N | Default from setup | Rate type ID
EXPNDATE | datetime | 16 | N | Default from setup | Expiration date
EXCHDATE | datetime | 16 | N | Default from setup | Exchange date
EXGTBDSC | string | 30 | N | Default from setup | Exchange ID description
EXTBLSRC | string | 50 | N | Default from setup | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | Default from setup | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Method; 1=Divide
PRVDSLMT | i4 | 2 | N | Default from setup | Previous day's limits
DATELMTS | i4 | 2 | N | Default from setup | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | Default from setup | Time1
USERID | string | 15 | N | Default from setup | User to enter (USER2ENT)
POSTATUS | i4 | 2 | N | Default from setup | PO status: 1=New; 2=Released; 3=Change order; 4=Received; 5=Closed; 6=Cancelled
CMMTTEXT | string | 500 | N | Default from setup | Comment text; use only if not utilizing COMMENT_1 through COMMENT_4
PRMDATE | datetime | 16 | N | Default from setup | Promise date
PRMSHPDTE | datetime | 16 | N | Default from setup | Promise ship date
REQDATE | datetime | 16 | N | Default from setup | Required date
CONTENDDTE | datetime | 16 | N | Default from setup | Contract expiration date
CNTRLBLKTBY | i4 | 2 | N | Default from setup | Control Blanket By: 0=Quantity 1=Value
REQTNDT | datetime | 16 | N | Default from setup | Requisition Date
UpdateIfExists | i4 | 2 | N | 0 | Flag to allow data to be updated, if it exists: 0=No; 1=Yes Partial updates allowed
NOTETEXT | string | 8000 | N | Default from setup | Notes field
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taPoHdr> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taPoLine>*

Element name | Data type | Length | Required | Default | Description
POTYPE | i4 | 2 | N | Default from setup | 1=Standard (items shipped to your business); 2=Drop ship (items shipped direct to customer) 3=Blanket 4=Drop Ship Blanket
PONUMBER | string | 17 | Y | Not applicable | Unique identifier for the PO
DOCDATE | datetime | 16 | N | Default from setup | Document Date: The date of the purchase order Required by PA
VENDORID | string | 15 | Y | Not applicable | ID of the vendor you’re purchasing items from
LOCNCODE | string | 10 | N | Default from setup | ID of the site for which you’re purchasing the items
VNDITNUM | string | 30 | N | Default from setup | Vendor item number
ITEMNMBR | string | 30 | N | Default from setup | Item number
QUANTITY | number | 21 | N | Default from setup | Total quantity for the line item
QTYCANCE | number | 21 | N | Default from setup | Quantity that is to be canceled
FREEONBOARD | i4 | 2 | N | Default from setup | Terms of sale that identify the point at which ownership of goods passes to the buyer: 1=None; 2=Origin; 3=Destination
REQSTDBY | string | 20 | N | Default from setup | Person or department who requested this line item
COMMNTID | string | 15 | N | Default from setup | Comment ID
COMMENT_1 | string | 50 | N | Default from setup | Comment part 1
COMMENT_2 | string | 50 | N | Default from setup | Comment part 2
COMMENT_3 | string | 50 | N | Default from setup | Comment part 3
COMMENT_4 | string | 50 | N | Default from setup | Comment part 4
REQDATE | datetime | 16 | N | Default from setup | Required date by which the items must be received
RELEASEBYDATE | datetime | 16 | N | Default from setup | Date PO line needs to be released to vendor in order to receive the item by the required date
PRMDATE | datetime | 16 | N | Default from setup | Date the vendor promised you would receive merchandise or services
PRMSHPDTE | datetime | 16 | N | Default from setup | Date the vendor promised the merchandise would be shipped
NONINVEN | i4 | 2 | N | 0 | 0=Inventory item; 1=Non-inventory item
IVIVINDX | i4 | 4 | N | Default from setup | Inventory account
InventoryAccount | string | 75 | N | <blank> | Inventory account number string
ITEMDESC | string | 100 | N | Default from setup | Description for line item
UNITCOST | number | 21 | N | Default from setup | Cost for item in specified unit of measure
VNDITDSC | string | 100 | N | Default from setup | Vendor’s description for line item
UOFM | string | 8 | N | Default from setup | Unit of measure in which this item is being purchased
Purchase_IV_Item_Taxable | i4 | 2 | N | Default from setup | Purchase inventory item taxable: 1=Taxable; 2=Nontaxable; 3=Base on vendor
Purchase_Item_Tax_Schedu | string | 15 | N | Default from setup | Purchase item tax schedule—blank unless Purchase_IV_Item_Taxable=1
Purchase_Site_Tax_Schedu | string | 15 | N | Default from setup | Purchase site tax schedule
BSIVCTTL | i4 | 2 | N | Default from setup | Based on invoice total
TAXAMNT | number | 21 | N | Default from setup | Tax amount
BCKTXAMT | number | 21 | N | Default from setup | Back tax amount
Landed_Cost_Group_ID | string | 15 | N | Default from setup | Landed cost group ID
PLNNDSPPLID | i4 | 2 | N | Default from setup | Planned supplier ID
SHIPMTHD | string | 15 | N | Default from setup | Shipping method
BackoutTradeDiscTax | number | 21 | N | Default from setup | Back out trade discount amount
POLNESTA | i4 | 2 | N | Default from setup | PO line status: 1=New; 2=Released; 3=Change order; 4=Received; 5=Closed; 6=Cancelled
CMMTTEXT | string | 500 | N | Default from setup | Comment text; used only if utilizing COMMENT_1 through COMMENT_4
ORD | i4 | 4 | N | Default from setup | Sequence number used to track each item; must be unique per PO line.
CUSTNMBR | string | 15 | N | Default from setup | Customer number
ADRSCODE | string | 15 | N | Default from setup | Address code
CMPNYNAM | string | 64 | N | Default from setup | Name
CONTACT | string | 30 | N | Default from setup | Contact
ADDRESS1 | string | 30 | N | Default from setup | Address line 1
ADDRESS2 | string | 30 | N | Default from setup | Address line 2
ADDRESS3 | string | 30 | N | Default from setup | Address line 3
CITY | string | 30 | N | Default from setup | City
STATE | string | 29 | N | Default from setup | State
ZIPCODE | string | 10 | N | Default from setup | ZIP Code/postal code
Ccode | string | 6 | N | Default from setup | Country code
COUNTRY | string | 20 | N | Default from setup | Country
PHONE1 | string | 21 | N | Default from setup | Phone 1
PHONE2 | string | 21 | N | Default from setup | Phone 2
PHONE3 | string | 21 | N | Default from setup | Phone 3
FAX | string | 21 | N | Default from setup | Fax
Print_Phone_NumberGB | i4 | 2 | N | Default from setup | Print phone number: 0=Do not print; 1=Phone 1; 2=Phone 2; 3=Phone 3; 4=Fax
CURNCYID | string | 15 | N | Default from setup | Currency ID
ProjNum | string | 15 | N | Default from setup | Project number; for use with Project Accounting only
CostCatID | string | 15 | N | Default from setup | Cost category ID; for use with Project Accounting only
LineNumber | i4 | 4 | N | Default from setup | Line number: Use 0 for a master line of a Blanket PO
UpdateIfExists | i4 | 2 | N | 0 | Flag to allow data to be updated, if it exists: 0=No; 1=Yes Partial updates allowed
NOTETEXT | string | 8000 | N | <blank> | Notes: In an update, an empty NOTETEXT element leaves existing notes unchanged.
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taPoLine> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taPopDistribution>

Element name | Data type | Length | Required | Default | Description
POPTYPE | i4 | 2 | Y | Not applicable | 1=Shipment; 2=Invoice; 3=Shipment/invoice
POPRCTNM | string | 17 | Y | Not applicable | Invoice number
SEQNUMBR | i4 | 4 | N | 0 | Sequence number
ACTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Account number string
CRDTAMNT | number | 21 | N | 0 | Credit amount
DEBITAMT | number | 21 | N | 0 | Debit amount
DistRef | string | 30 | N | <blank> | Distribution reference
DISTTYPE | i4 | 2 | Y | Not applicable | Distribution type: 1=Purchase; 2=Trade; 3=Freight; 4=Miscellaneous; 5=Tax; 6=Available; 7=Pay; 8=Other; 9=Accrued 13=Case 14=Taken 15=Work in Progress 16=Unbilled Account 17=Cost of Goods Sold 18=Contra Account 19=Project Overhead 20=Unbilled Project
VENDORID | string | 15 | Y | Not applicable | Vendor number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.

The valid distribution types for each POPTYPE are as follows:

POPTYPE | Distribution types
1 | 1, 2, 3, 4, 5, 6, 7, 8, or 9
2 | 1, 2, 3, 4, 5, 6, 7, 8, or 9
3 | 1, 2, 3, 4, 5, 6, 7, or 8


<taPopEnterMatchInvHdr>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
VNDDOCNM | string | 20 | Y | Not applicable | Vendor document number
Receiptdate | datetime | 16 | Y | Not applicable | Receipt date
BACHNUMB | string | 15 | Y | Not applicable | Batch number
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VENDNAME | string | 64 | N | <blank> | Vendor name
SUBTOTAL | number | 21 | Y | Not applicable | Subtotal; set to zero if using AutoCost option
TRDISAMT | number | 21 | N | 0 | Trade discount amount
FRTAMNT | number | 21 | N | 0 | Freight amount
MISCAMNT | number | 21 | N | 0 | Miscellaneous amount
TAXAMNT | number | 21 | N | 0 | Tax amount
TEN99AMNT | number | 21 | N | 0 | 1099 amount
PYMTRMID | string | 20 | N | Default from setup | Payments terms ID
DSCPCTAM | number | 21 | N | Default from setup | Discount percent amount
DSCDLRAM | number | 21 | N | Default from setup | Discount dollar amount
DISAVAMT | number | 21 | N | Default from setup | Discount available amount
USER2ENT | string | 15 | N | <blank> | User who entered
TIME1 | datetime | 16 | N | <blank> | Time
AUTOCOST | i4 | 4 | N | 0 | Parameter to autofill cost based on PO: 0=Enter manually; 1=Automatic
TAXSCHID | string | 15 | N | <blank> | Tax schedule ID
Purchase_Freight_Taxable | i4 | 2 | N | 2 | Purchase freight taxable: 1=Taxable; 2=Nontaxable; 3=Base on vendor
Purchase_Misc_Taxable | i4 | 2 | N | 2 | Purchase miscellaneous taxable: 1=Taxable; 2=Nontaxable; 3=Base on vendor
FRTSCHID | string | 15 | N | <blank> | Freight tax schedule ID
MSCSCHID | string | 15 | N | <blank> | Miscellaneous tax schedule ID
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
USINGHEADERLEVELTAXES | i4 | 2 | N | 0 | Header level taxes; used if no line taxes and assigning at the header level: 0=False; 1=True
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATEPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment; used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
DUEDATE | datetime | 16 | N | <blank> | Due date
DISCDATE | datetime | 16 | N | <blank> | Discount date
NOTETEXT | string | 8000 | N | <blank> | PO receipt note text
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
CreateDist | i4 | 2 | N | 1 | Flag to autocreate distributions: 0=Manual; 1=Automatic
BackoutTradeDiscTax | number | 21 | N | 0 | Back out trade discount tax amount
VADCDTRO | string | 15 | N | Default from setup | Remit to address ID
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopEnterMatchInvLine>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
POPMtchShpRcpt | string | 17 | N | <blank> | Match shipment receipt number; required if matching to a shipment and AutoInvoice=0
ShipRCPTLNNM | i4 | 4 | N | 0 | Receipt line number=RCPTLNNM for the shipment being matched
PONUMBER | string | 17 | N | <blank> | Purchase order number; blank if not matching against PO or landed cost
QTYINVCD | number | 21 | N | 0 | Invoice quantity to match; full amount if using <taPopEnterMatchInvToShpMultiLine>; zero if using AutoInvoice
Revalue_Inventory | i4 | 2 | N | Default from setup | Revalue inventory: Null=default; 0=False; 1=True
ITEMNMBR | string | 30 | N | <blank> | Item number; ITEMNMBR or VNDITNUM must contain a value
VENDORID | string | 15 | Y | Not applicable | Vendor ID
RCPTLNNM | i4 | 4 | N | 0 | Receipt line number
VNDITNUM | string | 30 | N | <blank> | Vendor item number; VNDITNUM or ITEMNMBR must contain a value
VNDITDSC | string | 100 | N | <blank> | Vendor item description
VarianceAccount | string | 75 | N | <blank> | Variance account
UOFM | string | 8 | N | <blank> | Unit of measure; used only if not receiving against a PO
UNITCOST | number | 21 | Y | Not applicable | Unit cost; if using AUTOCOST, set to zero
EXTDCOST | number | 21 | Y | Not applicable | Extended cost; if using AUTOCOST, set to zero
NONINVEN | i4 | 2 | N | 0 | Non-inventoried item; 0=Inventory item; 1=Non-inventoried item
AUTOCOST | i4 | 4 | N | 0 | Parameter to autofill cost based on PO: 0=Enter manually; 1=Automatic
Purchase_IV_Item_Taxable | i4 | 2 | N | 2 | Purchase inventory item taxable: 1=Taxable; 2=Nontaxable; 3=Based on vendor
Purchase_Item_Tax_Schedu | string | 15 | N | <blank> | Purchase item tax schedule; blank unless Purchase_IV_Item_Taxable=1
Purchase_Site_Tax_Schedu | string | 15 | N | <blank> | Purchase tax site schedule
TAXAMNT | number | 21 | N | 0 | Tax amount
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
POLNENUM | i4 | 4 | N | 0 | Sequence number used to track each line item on the PO; must be unique per PO
AutoInvoice | i4 | 2 | N | 0 | Automatic invoice: 0=Manual; 1=Auto (Auto invoices the PO passed in against shipments)
CURNCYID | string | 15 | N | <blank> | Currency ID; pulls from PO unless not doing matching immediately (otherwise, user can specify)
LandedCost | i4 | 2 | N | 0 | Landed cost: 0=Standard item or non-inventoried item; 1=Landed cost item—use ITEMNMBR for landed cost
ProjNum | string | 15 | N | Default from setup | Project number; for use with Project Accounting only
CostCatID | string | 15 | N | Default from setup | Cost category ID; for use with Project Accounting only
TrackedDropShipped | i4 | 2 | N | 0 | Track dropped shipped: 0=Do not track serial or lot; 1=Track serial or lot
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopEnterMatchInvToShpMultiLine>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
POPMtchShpRcpt | string | 17 | Y | Not applicable | Match shipment receipt number
PONUMBER | string | 17 | N | <blank> | Purchase order number; blank if not matching against a PO or landed cost
QTYINVCD | number | 21 | Y | Not applicable | Invoice quantity to match
Revalue_Inventory | i4 | 2 | N | Default from setup | Revalue inventory: Null=default; 0=False; 1=True
ITEMNMBR | string | 30 | N | <blank> | Item number; ITEMNMBR or VNDITNUM is required
ShipRCPTLNNM | i4 | 4 | N | 0 | Receipt line number; RCPTLNNM for the shipment being matched
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VNDITNUM | string | 30 | N | <blank> | Vendor item number; either VNDITNUM or ITEMNMBR is required
VarianceAccount | string | 75 | N | <blank> | Variance account
IVCLINNO | i4 | 4 | N | 0 | Equals RCPTLNNM for invoice; equals RCPTLNNM in <taPopEnterMatchInvLine>
LandedCost | i4 | 2 | N | 0 | 0=Standard item or non-IV item; 1=Landed cost item (use ITEMNMBR for landed cost)
NONINVEN | i4 | 2 | N | 0 | Non-inventoried item: 0=Inventory item; 1=Non-inventory item
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopEnterMatchLotInsert>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
SERLTNUM | string | 20 | Y | Not applicable | Lot number
SERLTQTY | number | 21 | Y | Not applicable | Quantity for the lot item
RCPTLNNM | i4 | 4 | Y | Not applicable | Receipt Line Number: The number of the receipt line item
EXPNDATE | datetime | 16 | N | Default from setup | Expiration Date
MFGDATE | datetime | 16 | N | <blank> | Manufacturing date
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True—if True, populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taPopEnterMatchSerialInsert>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
SERLTNUM | string | 20 | Y | Not applicable | Serial number
RCPTLNNM | i4 | 4 | Y | Not applicable | Receipt Line Number: The number of the receipt line item
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True—if True, populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taPopIvcTaxInsert>

Element name | Data type | Length | Required | Default | Description
PONUMBER | string | 17 | Y | Not applicable | PO number
TAXTYPE | i4 | 2 | N | 0 | 0=Regular, 1=Freight, 2=Miscellaneous
ORD | i4 | 4 | N | 0 | Line item sequence—ignored for freight/miscellaneous
TAXDTLID | string | 15 | Y | Not applicable | Tax detail ID
BKOUTTAX | i4 | 2 | N | 0 | Back out tax
TAXAMNT | number | 21 | N | 0 | Tax amount
FRTTXAMT | number | 21 | N | 0 | Freight tax
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
TAXPURCH | number | 21 | N | 0 | Tax purchase amount
TOTPURCH | number | 21 | N | 0 | Total purchase amount
TRXSORCE | string | 13 | N | <blank> | Transaction source
VENDORID | string | 15 | Y | Not applicable | ID of the vendor you are purchasing from, used as a default MC
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True—if True, populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPOPMapSites>

Element name | Data type | Length | Required | Default | Description
LOCNCODE | string | 10 | Y | Not applicable | Location code/site ID
ADRSCODE | string | 15 | Y | Not applicable | Address code
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopPoDelete>

To use this XML node, the status of the PO must be new and the SOP to POP link cannot be present.

Element name | Data type | Length | Required | Default | Description
PONUMBER | string | 17 | Y | Not applicable | PO number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taPopPoVoid>

Element name | Data type | Length | Required | Default | Description
PONUMBER | string | 17 | Y | Not applicable | PO number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taPopRcptHdrInsert>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
POPTYPE | i4 | 2 | Y | Not applicable | Receipt type: 1=Shipment 3=Shipment/invoice
VNDDOCNM | string | 20 | N | <blank> | Vendor document number Required when POPTYPE=3
receiptdate | datetime | 16 | Y | Not applicable | Receipt date
ACTLSHIP | datetime | 16 | N | <blank> | Actual ship date
BACHNUMB | string | 15 | Y | Not applicable | Batch number
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VENDNAME | string | 64 | N | <blank> | Vendor name
SUBTOTAL | number | 21 | N | Default from setup | Subtotal—set to 0 if using AUTOCOST option
TRDISAMT | number | 21 | N | Default from setup | Trade discount amount
FRTAMNT | number | 21 | N | 0 | Freight amount
MISCAMNT | number | 21 | N | 0 | Miscellaneous amount
TAXAMNT | number | 21 | N | 0 | Tax amount
TEN99AMNT | number | 21 | N | 0 | 1099 amount
PYMTRMID | string | 20 | N | Default from setup | Payment terms ID
DSCPCTAM | number | 21 | N | Default from setup | Discount percent amount
DSCDLRAM | number | 21 | N | Default from setup | Discount dollar amount
DISAVAMT | number | 21 | N | Default from setup | Discount available amount
REFRENCE | string | 30 | N | <blank> | Reference
USER2ENT | string | 15 | N | <blank> | User who entered
VCHRNMBR | string | 20 | N | <blank> | Voucher number
Tax_Date | datetime | 16 | N | <blank> | Tax date
TIME1 | datetime | 16 | N | <blank> | Time 1
WITHHAMT | number | 21 | N | 0 | Withholding amount
TXRGNNUM | string | 25 | N | <blank> | Tax registration number
AUTOCOST | i4 | 4 | N | 0 | Parameter to autofill cost based on PO: 0=Enter manually; 1=Automatic
TAXSCHID | string | 15 | N | <blank> | Tax schedule ID
Purchase_Freight_Taxable | i4 | 2 | N | 2 | Purchase freight taxable
Purchase_Misc_Taxable | i4 | 2 | N | 2 | Purchase miscellaneous taxable
FRTSCHID | string | 15 | N | <blank> | Freight tax schedule ID
MSCSCHID | string | 15 | N | <blank> | Miscellaneous tax schedule ID
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
BCKTXAMT | number | 21 | N | 0 | Back tax amount
BackoutTradeDiscTax | number | 21 | N | 0 | Back out trade discount tax amount
SHIPMTHD | string | 15 | N | Default from setup | Shipping method
USINGHEADERLEVELTAXES | i4 | 2 | N | 0 | Using header level taxes
CREATEDIST | i4 | 2 | N | 1 | Flag to autocreate distributions: 0=Manual (need to call <taPopDistributions>); 1=Automatic
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to Increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
DUEDATE | datetime | 16 | N | <blank> | Due date
DISCDATE | datetime | 16 | N | <blank> | Discount date
NOTETEXT | string | 8000 | N | <blank> | PO receipt note text
VADCDTRO | string | 15 | N | Default from setup | Remit to address ID
CASHAMNT | number | 21 | N | 0 | Cash Amount: (Use only with Project Accounting)
CAMCBKID | string | 15 | N | <blank> | Cash Amount Checkbook ID: (Use only with Project Accounting)
CDOCNMBR | string | 21 | N | <blank> | Cash Document Number: (Use only with Project Accounting)
CAMTDATE | datetime | 16 | N | <blank> | Cash Amount Date: (Use only with Project Accounting)
CAMPMTNM | string | 21 | N | <blank> | Cash Amount Payment Number: (Use only with Project Accounting)
CHEKAMNT | number | 21 | N | 0 | Check Amount: (Use only with Project Accounting)
CHAMCBID | string | 15 | N | <blank> | Check Amount Checkbook ID: (Use only with Project Accounting)
CHEKNMBR | string | 21 | N | <blank> | Check Number: (Use only with Project Accounting)
CHEKDATE | datetime | 16 | N | <blank> | Check Date: (Use only with Project Accounting)
CAMPYNBR | string | 21 | N | <blank> | Check Amount Payment Number: (Use only with Project Accounting)
CRCRDAMT | number | 21 | N | 0 | Credit Card Amount: (Use only with Project Accounting)
CARDNAME | string | 15 | N | <blank> | Credit Card Name: (Use only with Project Accounting)
CCRCTNUM | string | 21 | N | <blank> | Credit Card Receipt Number: (Use only with Project Accounting)
CRCARDDT | datetime | 16 | N | <blank> | Credit Card Date: (Use only with Project Accounting)
CCAMPYNM | string | 21 | N | <blank> | Credit Card Amount Payment Number: (Use only with Project Accounting)
DISTKNAM | number | 21 | N | 0 | Discount Taken Amount: (Use only with Project Accounting)
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopRcptLineInsert>

Element name | Datatype | Length | Required | Default | Description
POPTYPE | i4 | 2 | Y | Not applicable | Receipt type: 1=Shipment; 3=Shipment/invoice
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
PONUMBER | string | 17 | N | <blank> | Purchase order number; required if receiving against a purchase order
ITEMNMBR | string | 30 | Y | Not applicable | Item number
ITEMDESC | string | 100 | N | Default from setup | Item description for non-inventory
VENDORID | string | 15 | Y | Not applicable | Vendor ID
RCPTLNNM | i4 | 4 | N | 0 | Receipt line number
VNDITNUM | string | 30 | Y | Not applicable | Vendor item number
VNDITDSC | string | 100 | N | <blank> | Vendor item description
ACTLSHIP | datetime | 16 | N | <blank> | Actual ship date
INVINDX | i4 | 4 | N | 0 | Inventory index
InventoryAccount | string | 75 | N | <blank> | Inventory account
UOFM | string | 8 | N | <blank> | Unit of measure
UNITCOST | number | 21 | N | Default from setup | Unit cost; set to zero, or leave "null" if using AUTOCOST=1
EXTDCOST | number | 21 | N | Default from setup | Extended cost
NONINVEN | i4 | 2 | N | 0 | Non-inventory
JOBNUMBR | string | 17 | N | <blank> | Job number
BOLPRONUMBER | string | 30 | N | <blank> | BOL/pro number
QTYSHPPD | number | 21 | Y | Not applicable | Quantity shipped
QTYINVCD | number | 21 | N | 0 | Quantity invoiced (required if POPTYPE=3)
AUTOCOST | i4 | 4 | N | 0 | Parameter to autofill cost based on the PO: 0=Manual; 1=Automatic
Purchase_IV_Item_Taxable | i4 | 2 | N | 2 | Purchase inventory item taxable: 1=Taxable; 2=Nontaxable; 3=Based on vendor
Purchase_Item_Tax_Schedu | string | 15 | N | <blank> | Purchase item tax schedule (blank unless Purchase_IV_Item_Taxable=1)
Purchase_Site_Tax_Schedu | string | 15 | N | <blank> | Purchase site tax schedule
TAXAMNT | number | 21 | N | 0 | Tax amount
Landed_Cost_Group_ID | string | 15 | N | Default from setup | Landed cost group ID
LOCNCODE | string | 10 | N | <blank> | Location code in receiving
POLNENUM | i4 | 4 | N | 0 | PO line number; must be unique per PO line
receiptdate | datetime | 16 | N | <blank> | Receipt date; required if using landed cost
CURNCYID | string | 15 | N | <blank> | Currency ID; information pulled from purchase order unless not doing a receiving against a purchase order
ProjNum | string | 15 | N | <blank> | Project number; for use with Project Accounting only
CostCatID | string | 15 | N | <blank> | Cost category ID: for use with Project Accounting only
AutoAssignBin | i4 | 2 | N | 1 | Use Default Bin; will use the PORECEIPTBIN bin from the item site combination or the site default
CMMTTEXT | string | 500 | N | <blank> | Comment Text: When the receipt includes a purchase order, this element is populated from the purchase order. If the receipt does not include a purchase order, the comment is left blank.
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopRcptLineTaxInsert>

Element name | Data type | Length | Required | Default | Description
VENDORID | string | 15 | Y | Not applicable | Vendor ID
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
TAXDTLID | string | 15 | Y | Not applicable | Tax detail ID
TAXTYPE | i4 | 2 | Y | Not applicable | 0=Regular; 1=Freight; 2=Miscellaneous
ACTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Inventory account
TAXAMNT | number | 21 | N | 0 | Tax amount
TAXPURCH | number | 21 | N | 0 | Taxable purchases
TOTPURCH | number | 21 | N | 0 | Total purchases
RCPTLNNM | i4 | 4 | N | 0 | Receipt line number
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopRcptLotInsert>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Document number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
SERLTNUM | string | 20 | Y | Not applicable | Lot number
SERLTQTY | number | 21 | Y | Not applicable | Quantity for lot item
RCPTLNNM | i4 | 4 | Y | Not applicable | Receipt line number—the ordinal for the receipt's line item with which the lot is associated
BIN | string | 15 | N | <blank> | Bin; used when multi bins are enabled Defaults from IV00102, then IV40700 if not passed
CREATEBIN | i4 | 1 | N | 0 | Create bin: 0=No; 1=Yes Can only create bin when multi bins are enabled
LOCNCODE | string | 10 | N | <blank> | Location code in receiving; pass same value as the line Required when multi bin is enabled
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopRcptMultiBin>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Receipt number
RCPTLNNM | i4 | 4 | N | 0 | Receipt line number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
BIN | string | 15 | N | <blank> | Bin number
QUANTITY | number | 21 | Y | Not applicable | Quantity shipped
UOFM | string | 8 | N | <blank> | Unit of measure
CreateBin | i4 | 4 | N | 0 | Create bin on the fly: 0=False; 1-True
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopRcptSerialInsert>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | Document number
ITEMNMBR | string | 30 | Y | Not applicable | Item number
SERLTNUM | string | 20 | Y | Not applicable | Serial number
RCPTLNNM | i4 | 4 | Y | Not applicable | Receipt line number; the ordinal for the receipt's line item with which the serial is associated
BIN | string | 15 | N | <blank> | Bin; used when multi bins are enabled Defaults from IV00102, then IV40700 if not passed
CREATEBIN | i4 | 1 | N | 0 | Create bin: 0=No; 1=Yes Can only create bin when multi bins are enabled
LOCNCODE | string | 10 | N | <blank> | Location code in receiving; pass same value as the line Required when multi bin is enabled
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopRcptUserDefined>

Element name | Data type | Length | Required | Default | Description
POPRCTNM | string | 17 | Y | Not applicable | PO receipt number
User_Defined_List01 | string | 31 | N | <blank> | User-defined list 1
User_Defined_List02 | string | 31 | N | <blank> | User-defined list 2
User_Defined_List03 | string | 31 | N | <blank> | User-defined list 3
User_Defined_List04 | string | 31 | N | <blank> | User-defined list 4
User_Defined_List05 | string | 31 | N | <blank> | User-defined list 5
User_Defined_Text01 | string | 31 | N | <blank> | User-defined text 1
User_Defined_Text02 | string | 31 | N | <blank> | User-defined text 2
User_Defined_Text03 | string | 31 | N | <blank> | User-defined text 3
User_Defined_Text04 | string | 31 | N | <blank> | User-defined text 4
User_Defined_Text05 | string | 31 | N | <blank> | User-defined text 5
User_Defined_Text06 | string | 31 | N | <blank> | User-defined text 6
User_Defined_Text07 | string | 31 | N | <blank> | User-defined text 7
User_Defined_Text08 | string | 31 | N | <blank> | User-defined text 8
User_Defined_Text09 | string | 31 | N | <blank> | User-defined text 9
User_Defined_Text10 | string | 31 | N | <blank> | User-defined text 10
User_Defined_Date01 | datetime | 16 | N | <blank> | User-defined date 1
User_Defined_Date02 | datetime | 16 | N | <blank> | User-defined date 2
User_Defined_Date03 | datetime | 16 | N | <blank> | User-defined date 3
User_Defined_Date04 | datetime | 16 | N | <blank> | User-defined date 4
User_Defined_Date05 | datetime | 16 | N | <blank> | User-defined date 5
User_Defined_Date06 | datetime | 16 | N | <blank> | User-defined date 6
User_Defined_Date07 | datetime | 16 | N | <blank> | User-defined date 7
User_Defined_Date08 | datetime | 16 | N | <blank> | User-defined date 8
User_Defined_Date09 | datetime | 16 | N | <blank> | User-defined date 9
User_Defined_Date10 | datetime | 16 | N | <blank> | User-defined date 10
User_Defined_Date11 | datetime | 16 | N | <blank> | User-defined date 11
User_Defined_Date12 | datetime | 16 | N | <blank> | User-defined date 12
User_Defined_Date13 | datetime | 16 | N | <blank> | User-defined date 13
User_Defined_Date14 | datetime | 16 | N | <blank> | User-defined date 14
User_Defined_Date15 | datetime | 16 | N | <blank> | User-defined date 15
User_Defined_Date16 | datetime | 16 | N | <blank> | User-defined date 16
User_Defined_Date17 | datetime | 16 | N | <blank> | User-defined date 17
User_Defined_Date18 | datetime | 16 | N | <blank> | User-defined date 18
User_Defined_Date19 | datetime | 16 | N | <blank> | User-defined date 19
User_Defined_Date20 | datetime | 16 | N | <blank> | User-defined date 20
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taPopRemoveSopLink>

Element name | Data type | Length | Required | Default | Description
PONUMBER | string | 17 | Y | Not applicable | PO number
SOPNUMBE | string | 21 | N | <blank> | SOP number; pass in to remove just one SOP link
SOPTYPE | i4 | 1 | N | 0 | SOP type; used when SOP number as unique key; required when SOPNUMBE is passed in
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence number; used to identify specific line on SOP document to remove link
CMPNTSEQ | i4 | 4 | N | 0 | Component sequence number; used with kits
RemoveAllLinks | i4 | 1 | N | 0 | Remove all PO links: 0=No; 1=Yes (if 1, all links are removed regardless of SOP info)
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taRequesterTrxDisabler>

You use the <taRequesterTrxDisabler> XML node to prevent the Transaction Requester from publishing an eConnect XML document to an MSMQ queue. This node enables you to disable the Transaction Requester service for a specified core or third-party document type that is setup in the eConnect_Out_Setup table.

This XML node is used with the classes in the Microsoft.Dynamics.GP.eConnect .NET assembly. You typically use <taRequesterTrxDisabler> when submitting documents through the Create, Update or Delete methods of the eConnectMethods class.

To disable a Transaction Requester document type, add a <taRequesterTrxDisabler> XML node to the transaction type schema in your eConnect XML document. To disable multiple Transaction Requester document types for a single transaction type, add a separate <taRequesterTrxDisabler> XML node for each document type.

Use the INDEX elements to identify a specific document. To learn which INDEX fields require values and the type of values to use, view the document type you want to disable in the eConnect_Out_Setup table. For example, the eConnect_Out_Setup table shows that the Customer document type includes a single INDEX that requires a CUSTNUMBR value. To disable the Transaction Requester for a specific customer document, populate the INDEX1 field with the Customer ID. .

Element name | Datatype | Length | Required | Default | Description
DOCTYPE | string | 50 | Y | Not applicable | Document type Specify the name of a document type found in the DOCTYPE column of the eConnect_Out_Setup table.
INDEX1 | string | 75 | N | <blank> | Index 1 Used for selection criteria. Specify a value that identifies the current document.
INDEX2 | string | 75 | N | <blank> | Index 2 Used for selection criteria. Specify a value that identifies the current document.
INDEX3 | string | 75 | N | <blank> | Index 3 Used for selection criteria. Specify a value that identifies the current document.
INDEX4 | string | 75 | N | <blank> | Index 4 Used for selection criteria. Specify a value that identifies the current document.
INDEX5 | string | 75 | N | <blank> | Index 5 Used for selection criteria. Specify a value that identifies the current document.
INDEX6 | string | 75 | N | <blank> | Index 6 Used for selection criteria. Specify a value that identifies the current document.
INDEX7 | string | 75 | N | <blank> | Index 7 Used for selection criteria. Specify a value that identifies the current document.
INDEX8 | string | 75 | N | <blank> | Index 8 Used for selection criteria. Specify a value that identifies the current document.
INDEX9 | string | 75 | N | <blank> | Index 9 Used for selection criteria. Specify a value that identifies the current document.
INDEX10 | string | 75 | N | <blank> | Index 10 Used for selection criteria. Specify a value that identifies the current document.
INDEX11 | string | 75 | N | <blank> | Index 11 Used for selection criteria. Specify a value that identifies the current document.
INDEX12 | string | 75 | N | <blank> | Index 12 Used for selection criteria. Specify a value that identifies the current document.
INDEX13 | string | 75 | N | <blank> | Index 13 Used for selection criteria. Specify a value that identifies the current document.
INDEX14 | string | 75 | N | <blank> | Index 14 Used for selection criteria. Specify a value that identifies the current document.
INDEX15 | string | 75 | N | <blank> | Index 15 Used for selection criteria. Specify a value that identifies the current document.
Delete | i4 | 2 | N | 0 | Flag that specifies whether to delete the record from the eConnectOutTemp table

The following XML document example shows how to use the <taRequesterTrxDisabler> XML node. Notice how the DOCTYPE element specifies the Customer document type and the INDEX1 element specifies the customer ID. Also notice that the RequesterTrx element was set to 1.

Many XML nodes include a RequesterTrx element. This element also allows you to specify whether or not to publish transaction information to the eConnect_Out table. The typical default value of the RequesterTrx element is to not publish transaction information to the eConnect_Out table.

<eConnect xmlns:dt="urn:schemas-microsoft-com:datatypes">
    <RMCustomerMasterType>
        <taRequesterTrxDisabler_Items>
            <taRequesterTrxDisabler>
                <DOCTYPE>Customer</DOCTYPE>
                INDEX1>JEFF0002</INDEX1>
            </taRequesterTrxDisabler>
        </taRequesterTrxDisabler_Items>
        <taUpdateCreateCustomerRcd>
            <CUSTNMBR>JEFF0002</CUSTNMBR>
            <CUSTNAME>JL Lawn Care Service</CUSTNAME>
            <STMTNAME>JL Lawn Care Service, Co.</STMTNAME>
            <SHRTNAME>JL Lawn Care</SHRTNAME>
            <ADRSCODE>PRIMARY</ADRSCODE>
            <ADDRESS1>123 Main Street</ADDRESS1>
            <CITY>Valley City</CITY>
            <STATE>ND</STATE>
            <ZIPCODE>58072</ZIPCODE>
            <COUNTRY>USA</COUNTRY>
            <PHNUMBR1>55532336790000</PHNUMBR1>
            <PHNUMBR2>55551161817181</PHNUMBR2>
            <FAX>55584881000000</FAX>
            <UPSZONE>red</UPSZONE>
            <SHIPMTHD>PICKUP</SHIPMTHD>
            <TAXSCHID>USALLEXMPT-0</TAXSCHID>
            <PRBTADCD>PRIMARY</PRBTADCD>
            <PRSTADCD>PRIMARY</PRSTADCD>
            <STADDRCD>PRIMARY</STADDRCD>
            <SLPRSNID>GREG E.</SLPRSNID>
            <SALSTERR>TERRITORY 6</SALSTERR>
            <COMMENT1>comment1</COMMENT1>
            <COMMENT2>comment2</COMMENT2>
            <PYMTRMID>Net 30</PYMTRMID>
            <CHEKBKID>PAYROLL</CHEKBKID>
            <KPCALHST>0</KPCALHST>
            <UseCustomerClass>0</UseCustomerClass>
            <UpdateIfExists>1</UpdateIfExists>
            <RequesterTrx>1</RequesterTrx>
        </taUpdateCreateCustomerRcd>
    </RMCustomerMasterType>
</eConnect>


<taRMApply>

Element name | Datatype | Length | Required | Default | Description
APTODCNM | string | 21 | Y | Not applicable | Apply to document number
APFRDCNM | string | 21 | Y | Not applicable | Apply from document number
APPTOAMT | number | 21 | Y | Not applicable | Amount to apply
APFRDCTY | i4 | 4 | Y | Not applicable | Document type of apply from document. Valid document types for APFRDCTY: Credit Memo=7; Return=8; Cash Receipt=9
APTODCTY | i4 | 4 | Y | Not applicable | Document type of apply to document. Valid document types for APTODCTY: Sales/Invoice=1; Debit Memo=3; Finance Charge=4; Service/Repair=5; Warranty=6
DISTKNAM | number | 21 | N | Default from setup | Discount taken: Null=Use existing discount; xx(dollar amount)=Use dollar amount, even if zero
WROFAMNT | number | 21 | N | 0 | Write-off amount
APPLYDATE | datetime | 16 | N | Default from setup | Apply date
GLPOSTDT | datetime | 16 | N | Default from setup | Apply posting date


<taRMCashReceiptInsert>

Element name | Datatype | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
DOCNUMBR | string | 20 | Y | Not applicable | Document number
DOCDATE | datetime | 16 | Y | Not applicable | Document date
ORTRXAMT | number | 21 | Y | Not applicable | Transaction amount
GLPOSTDT | datetime | 16 | Y | Not applicable | GL posting date
BACHNUMB | string | 15 | Y | Not applicable | Batch number
CSHRCTYP | i4 | 2 | Y | Not applicable | Cash receipt type 0=Check 1=Cash 2=Credit card
CHEKBKID | string | 15 | N | <blank> | Checkbook ID
CHEKNMBR | string | 20 | N | <blank> | Check number or credit card number
CRCARDID | string | 15 | N | <blank> | Credit card ID
TRXDSCRN | string | 30 | N | <blank> | Transaction description
LSTUSRED | string | 15 | N | <blank> | Last user to edit
BatchCHEKBKID | string | 15 | N | <blank> | Checkbook ID for the batch
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly, 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment—only used when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
CREATEDIST | i4 | 2 | N | 1 | Flag to automatically create distributions: 0=Manual; 1=Automatic
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taRMCommissions>

Element name | Datatype | Length | Required | Default | Description
RMDTYPAL | i4 | 2 | Y | Not applicable | Document type: 1=Sales/Invoice; 3=Debit memo; 5=Service/repair; 8=Returns
DOCNUMBR | string | 20 | Y | Not applicable | Document number
SEQNUMBR | i4 | 2 | N | 0 | Sequence number
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
SLPRSNID | string | 15 | Y | Not applicable | Salesperson ID
SALSTERR | string | 15 | N | <blank> | Sales territory
COMPRCNT | number | 21 | N | 0 | Commission percentage
COMDLRAM | number | 21 | N | 0 | Commission amount
DOCAMNT | number | 21 | Y | Not applicable | Document amount
PRCTOSAL | number | 21 | N | 100.00 | Percent of sale the commission is based on
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False, 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taRMDistribution>

Element name | Datatype | Length | Required | Default | Description
RMDTYPAL | i4 | 2 | Y | Not applicable | 1=Sales/invoice; 3=Debit memo; 4=Finance charge; 5=Service/repair; 6=Warranty; 7=Credit memo; 8=Return; 9=Cash receipt
DOCNUMBR | string | 20 | Y | Not applicable | Document number
CUSTNMBR | string | 15 | Y | Not applicable | Vendor ID
SEQNUMBR | i4 | 4 | N | 0 | Sequence number
DISTTYPE | i4 | 2 | Y | Not applicable | Distribution type: 1=Cash; 2=Taken; 3=Recv; 4=Write; 5=Avail; 6=Gst; 7=Wh; 8=Other; 9=Sales; 10=Trade; 11=Freight; 12=Misc; 13=Taxes; 14=Cogs; 15=Inv; 16=Fnchg; 17=Returns; 18=DrMemo; 19=CrMemo; 20=Service; 21=Warrexp; 22=Warrsls; 23=Commexp; 24=Cpmmpay
DistRef | string | 30 | N | <blank> | Distribution reference
DSTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Account number string
DEBITAMT | number | 21 | N | 0 | Debit amount
CRDTAMNT | number | 21 | N | 0 | Credit amount
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

The valid distribution types for each RMDTYPAL value are as follows:

RMDTYPAL | Distribution types
1 | 1, 2, 3, 5, 8, 9, 10, 11, 12, 13, 14, 15, 23, 24
3 | 1, 2, 3, 5, 8, 10, 11, 12, 13, 14, 15, 18, 23, 24
4 | 1, 2, 3, 5, 8, 10, 11, 12, 13, 14, 15, 16, 23, 24
5 | 1, 2, 3, 5, 8, 10, 11, 12, 13, 14, 15, 20, 23, 24
6 | 8, 10, 11, 12, 13, 14, 15, 21, 22
7 | 1, 2, 3, 4, 5, 6, 7, 8, 10, 11, 12, 13, 14, 15, 19, 23, 24
8 | 1, 2, 3, 4, 5, 6, 7, 8, 10, 11, 12, 13, 14, 15, 17, 21

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taRMSchedPmnts>

Element name | Datatype | Length | Required | Default | Description
ORIG_DOC_NUMBER | string | 21 | Y | Not applicable | Original document number
ORIG_DOC_TYPE | i4 | 2 | Y | Not applicable | Original document type: 1=Sales/invoice; 3=Debit memos; 5=Service/repairs
REC_OFFSET_ACCT_IDX | i4 | 4 | N | 0 | Receivables offset account index; either an index or a string is required
RecOffsetAcct | string | 75 | N | <blank> | Receivables offset account string (The account string is checked first; if it is populated, the account index is set based on the string. If the account string is not populated, the account index is used.)
FIRST_INV_DOC_DATE | datetime | 16 | N | <blank> | First invoice document date; required if the payment frequency is 1=Semimonthly and the day must be either the first or fifteenth (day requirement for semimonthly only)
FIRST_INV_DUE_DATE | datetime | 16 | N | <blank> | First invoice due date; required if the payment frequency is 1=Semi-monthly and the day must be either the first or fifteenth (day requirement for semimonthly only)
INT_INCOME_ACCT_IDX | i4 | 4 | N | 0 | Interest income account index; either the index or the string is required if the interest rate is entered
IntIncomeAccount | string | 75 | N | <blank> | Interest income account string; either the index or the string is required if the interest rate is entered
PAYMENT_AMOUNT | number | 21 | N | 0 | Payment amount; if both PAYMENT_AMOUNT and NUM_PAYMENTS are passed in, the number of payments are recalculated
NUM_PAYMENTS | i4 | 2 | N | 0 | Number of payments; either the number of payments or the payment amount must be>0 (both cannot be zero); if payment amount is entered, the number of payments must hold a value of 1 (minimum) to 999(maximum)
SCHEDULE_NUMBER | string | 21 | N | <blank> | Schedule number
PYMNT_FREQUENCY | i4 | 2 | N | 2 | Payment frequency: 1=Semimonthly; 2=Monthly; 3=Quarterly; 4=Semiannually; 5=Annually
REC_ACCT_IDX | i4 | 4 | N | 0 | Receivables account index
RecAccount | string | 75 | N | <blank> | Receivables account string
SCH_DOC_DATE | datetime | 16 | N | <blank> | Schedule document date
SCHEDULE_AMOUNT | number | 21 | N | 0 | Schedule amount
SCHEDULE_DESC | string | 31 | N | <blank> | Schedule description
SCHEDULE_INT_RATE | number | 21 | N | 0 | Schedule interest rate; front end allows negative interest but this element will not
SCHEDULE_INT_TYPE1 | i4 | 2 | N | 0 | Schedule interest type: 0=Compound; 1=Simple
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taRMTransaction>

Element name | Data type | Length | Required | Default | Description
RMDTYPAL | i4 | 2 | Y | Not applicable | 1=Sales/invoice; 3=Debit memo; 4=Finance charge; 5=Service/repair; 6=Warranty; 7=Credit memo; 8=Return
DOCNUMBR | string | 17 | Y | Not applicable | Document number
DOCDATE | datetime | 16 | Y | Not applicable | Document date
BACHNUMB | string | 15 | Y | Not applicable | Batch number
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
DOCAMNT | number | 21 | Y | Not applicable | Document amount
SLSAMNT | number | 21 | Y | Not applicable | Sales amount
DOCDESCR | string | 30 | N | <blank> | Document description
ADRSCODE | string | 15 | N | <blank> | Address code
SLPRSNID | string | 15 | N | Default from setup | Salesperson ID
SALSTERR | string | 15 | N | Default from setup | Sales territory
SHIPMTHD | string | 15 | N | <blank> | Shipping method
TAXSCHID | string | 15 | N | Default from setup | Tax schedule ID
CSTPONBR | string | 20 | N | <blank> | Customer PO number
COSTAMNT | number | 21 | N | 0 | Cost amount
TRDISAMT | number | 21 | N | 0 | Trade discount amount
TRDDISCT | i4 | 2 | N | 0 | Trade discount
FRTAMNT | number | 21 | N | 0 | Freight amount
MISCAMNT | number | 21 | N | 0 | Miscellaneous amount
TAXAMNT | number | 21 | N | 0 | Tax amount
BKTSLSAM | number | 21 | N | 0 | Back out sales amount
BKTFRTAM | number | 21 | N | 0 | Back out freight amount
BKTMSCAM | number | 21 | N | 0 | Back out miscellaneous amount
CASHAMNT | number | 21 | N | 0 | Cash amount
CBKIDCSH | string | 15 | N | <blank> | Checkbook ID cash
CASHDATE | datetime | 16 | N | <blank> | Cash date
DCNUMCSH | string | 20 | N | <blank> | Document number cash
CHEKAMNT | number | 21 | N | 0 | Check amount
CBKIDCHK | string | 15 | N | <blank> | Checkbook ID check
CBKIDCRD | string | 15 | N | <blank> | Checkbook ID credit card
CHEKNMBR | string | 20 | N | <blank> | Check number
CHEKDATE | datetime | 16 | N | <blank> | Check date
DCNUMCHK | string | 20 | N | <blank> | Document number of the check
CRCRDAMT | number | 21 | N | 0 | Credit card amount
CRCRDNAM | string | 15 | N | <blank> | Credit card name
RCTNCCRD | string | 20 | N | <blank> | Receipt number for the credit card
CRCARDDT | datetime | 16 | N | <blank> | Credit card date
DCNUMCRD | string | 20 | N | <blank> | Document number for the credit card
DISCRTND | number | 21 | N | 0 | Discount returned
DISTKNAM | number | 21 | N | 0 | Discount taken amount
WROFAMNT | number | 21 | N | 0 | Write-off amount for credit documents
PPSAMDED | number | 21 | N | 0 | PPS amount deducted for credits
GSTDSAMT | number | 21 | N | 0 | GST discount amount
PYMTRMID | string | 20 | N | Default from setup | Payment term ID
DISAVAMT | number | 21 | N | Default from setup | Discount available amount
DSCDLRAM | number | 21 | N | Default from setup | Discount dollar amount
DSCPCTAM | number | 21 | N | Default from setup | Discount percent amount
LSTUSRED | string | 15 | N | <blank> | Last user to edit
PTDUSRID | string | 15 | N | <blank> | Posted user ID
DistRef | string | 30 | N | <blank> | Distribution reference
BatchCHEKBKID | string | 15 | N | <blank> | Checkbook ID for the batch
DUEDATE | datetime | 16 | N | <blank> | Due date
DISCDATE | datetime | 16 | N | <blank> | Discount date
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | Time 1
COMDLRAM | number | 21 | N | Default from setup | Commission amount
COMAPPTO | i4 | 2 | N | Default from setup | Commission apply to
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
CREATEDIST | i4 | 2 | N | 1 | Flag to autocreate distributions: 0=Manual; 1=Automatic
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taRMTransactionTaxInsert>

Element name | Datatype | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer ID
DOCNUMBR | string | 20 | Y | Not applicable | Document number—must be unique
RMDTYPAL | i4 | 2 | Y | Not applicable | Document type
BACHNUMB | string | 15 | Y | Not applicable | Batch number
TAXDTLID | string | 15 | Y | Not applicable | Tax detail ID
TAXAMNT | number | 21 | Y | Not applicable | Tax amount
STAXAMNT | number | 12 | Y | Not applicable | Sales tax amounts
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
MSCTXAMT | number | 12 | N | 0 | Miscellaneous tax amount
TAXDTSLS | number | 21 | Y | Not applicable | Tax detail total sales
SEQNUMBR | i4 | 4 | N | 0 | Sequence number
ACTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Account number string
TDTTXSLS | number | 21 | N | Default from setup | Tax detail of total taxable sales
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False, 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taRMUnapplyTransaction>

Element name | Datatype | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
DOCNUMBR | string | 20 | Y | Not applicable | Document number
RMDTYPAL | i4 | 2 | Y | Not applicable | Document type
APTODCTY | i4 | 2 | N | 0 | Apply to document type; leaving this element empty will unapply all documents Valid document types for APTODCTY: Sales/Invoice=1; Debit Memo=3; Finance Charge=4; Service/Repair=5; Warranty=6
APTODCNM | string | 20 | N | <blank> | Apply to document number; leaving this element empty will unapply all documents
GLPOSTDT | datetime | 16 | N | <blank> | General ledger posting date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taRMVoidTransaction>

Element name | Datatype | Length | Required | Default | Description
CUSTNMBR | string | 15 | N | Default from setup | Customer number
DOCNUMBR | string | 20 | Y | Not applicable | Document number
VOIDSTTS | i4 | 2 | Y | Not applicable | Void status: Void=1; NSF=2; Waived=3
RMDTYPAL | i4 | 2 | Y | Not applicable | Valid document types to void: 7=Credit memo; 8=Returns; 9=Cash receipts
VOIDDATE | datetime | 16 | Y | Not applicable | Transaction void date
GLPOSTDT | datetime | 16 | Y | Not applicable | GL posting date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

Do not use taRMVoidTransaction to void a payment for a multi-currency transaction. The eConnect apply processes do not support multi-currency.


<taSopCommissions>

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Bkorder; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Document number
LNITMSEQ | i4 | 4 | N | 0 | Line sequence number—leave 0 to autocreate sequence number
SLPRSNID | string | 15 | Y | Not applicable | Salesperson ID
SALSTERR | string | 15 | N | <blank> | Sales territory
COMPRCNT | number | 21 | N | 0 | Salesperson commission percentage
COMMAMNT | number | 21 | N | 0 | Commission amount
PRCTOSAL | number | 21 | N | 100.00 | Percent of sale that the commission is based on
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
CURNCYID | string | 15 | N | <blank> | Currency ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taSopDeleteDocument>

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Bkorder; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | SOP number/invoice number
RemovePayments | i4 | 2 | N | 1 | 0=Do not remove posted deposits; 1=Remove posted deposits and post reversing entry to GL
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taSopDistribution>

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | SOP type: 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Bkorder; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | SOP number
SEQNUMBR | i4 | 4 | N | 0 | Sequence number
DISTTYPE | i4 | 2 | Y | Not applicable | Distribution type: 1=Sales; 2=Receiving; 3=Cash; 4=Taken; 5=Available; 6=Trade; 7=Freight; 8=Miscellaneous; 9=Taxes; 10=Mark; 11=Commission Expense; 12=Commission pay; 13=Other; 14=COGS; 15=Invoice; 16=Returns; 17=In use; 18=In service; 19=Damaged; 20=Unit; 21=Deposits; 22=Round
DistRef | string | 30 | N | <blank> | Distribution reference
ACTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Account number string
DEBITAMT | number | 21 | N | 0 | Debit amount
CRDTAMNT | number | 21 | N | 0 | Credit amount
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

The valid distribution types for each SOPTYPE are as follows:

SOPTYPE | Distribution types
3 | 1 , 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, or 21
4 | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, or 21

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taSopHdrIvcInsert>*

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment orders
DOCID | string | 15 | Y | Not applicable | Document ID
SOPNUMBE | string | 21 | Y | Not applicable | Invoice number
ORIGNUMB | string | 20 | N | <blank> | Order number
ORIGTYPE | i4 | 2 | N | 0 | Document type of the originating SOP number
TAXSCHID | string | 15 | N | <blank> | Tax schedule
FRTSCHID | string | 15 | N | <blank> | Freight tax schedule
MSCSCHID | string | 15 | N | <blank> | Miscellaneous tax schedule
SHIPMTHD | string | 15 | N | Default from setup | Shipping method
TAXAMNT | number | 21 | N | 0 | Tax amount
LOCNCODE | string | 10 | N | <blank> | Location code
DOCDATE | datetime | 16 | Y | Not applicable | Document date
FREIGHT | number | 21 | N | 0 | Freight amount
MISCAMNT | number | 21 | N | 0 | Miscellaneous amount
TRDISAMT | number | 21 | N | Default from setup | Trade discount amount
TRADEPCT | number | 21 | N | Default from setup | Trade discount percentage
DISTKNAM | number | 21 | N | 0 | Discount taken amount—cannot be larger then discount available amount
MRKDNAMT | number | 21 | N | 0 | Markdown amount
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
CUSTNAME | string | 64 | N | <blank> | Customer name
CSTPONBR | string | 20 | N | <blank> | Customer purchase order number
ShipToName | string | 64 | N | <blank> | Ship to name: The default gets the ship to name from the customer ship to address
ADDRESS1 | string | 60 | N | <blank> | Customer address one
ADDRESS2 | string | 60 | N | <blank> | Customer address two
ADDRESS3 | string | 60 | N | <blank> | Customer address three
CNTCPRSN | string | 60 | N | <blank> | Contact person
FAXNUMBR | string | 21 | N | <blank> | Fax number
CITY | string | 35 | N | <blank> | Customer city
STATE | string | 29 | N | <blank> | Customer state
ZIPCODE | string | 10 | N | <blank> | Customer ZIP Code
COUNTRY | string | 60 | N | <blank> | Customer country
PHNUMBR1 | string | 21 | N | <blank> | Phone one
PHNUMBR2 | string | 21 | N | <blank> | Phone two
PHNUMBR3 | string | 21 | N | <blank> | Phone three
Print_Phone_NumberGB | i4 | 2 | N | Default from setup | Print phone number: 0=Do not print; 1=Phone 1; 2=Phone 2; 3=Phone 3; 4=Fax
SUBTOTAL | number | 21 | N | 0 | Subtotal=Total before taxes
DOCAMNT | number | 21 | N | 0 | Document amount/total
PYMTRCVD | number | 21 | N | 0 | Total of all payments and deposits
SALSTERR | string | 15 | N | <blank> | Sales territory
SLPRSNID | string | 15 | N | <blank> | Salesperson ID
UPSZONE | string | 3 | N | Default from setup | UPS zone
USER2ENT | string | 15 | N | <blank> | User who entered
BACHNUMB | string | 15 | Y | Not applicable | Batch number
PRBTADCD | string | 15 | N | <blank> | Primary bill to address code
PRSTADCD | string | 15 | N | Default from setup | Primary ship to address code
FRTTXAMT | number | 21 | N | 0 | Freight tax amount
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax amount
ORDRDATE | datetime | 16 | N | <blank> | Order date
MSTRNUMB | i4 | 4 | N | 0 | Master Number—default is next number if 0
PYMTRMID | string | 20 | N | Default from setup | Payment terms ID—default is from customer if not passed in
DUEDATE | datetime | 16 | N | <blank> | Due date
DISCDATE | datetime | 16 | N | <blank> | Discount date
REFRENCE | string | 30 | N | <blank> | GL reference
USINGHEADERLEVELTAXES | i4 | 4 | N | 0 | Header level taxes
BatchCHEKBKID | string | 15 | N | <blank> | Checkbook ID for the batch
CREATECOMM | i4 | 2 | N | 0 | Flag to autocreate commissions: 0=Manual; 1=Automatic—use if not calling <taSopCommissions> node
COMMAMNT | number | 21 | N | 0 | Total amount of commissions for this document—used only with manual commissions
COMPRCNT | number | 21 | N | 0 | Used for all salespeople if passed in and CREATECOMM=1; leave blank to use default percentages
CREATEDIST | i4 | 2 | N | 1 | Flag to autocreate distributions: 0=Manual; 1=Automatic—use if not calling <taSopDistribution> node
CREATETAXES | i4 | 2 | N | 0 | Flag to autocreate taxes with tax engine; leave at 0 if integrating your own
DEFTAXSCHDS | i4 | 2 | N | 0 | Flag to default tax schedules based on setup if incoming tax schedules empty
CURNCYID | string | 15 | N | <blank> | Currency ID
XCHGRATE | number | 21 | N | 0 | Exchange rate
RATETPID | string | 15 | N | <blank> | Rate type ID
EXPNDATE | datetime | 16 | N | <blank> | Expiration date
EXCHDATE | datetime | 16 | N | <blank> | Exchange date
EXGTBDSC | string | 30 | N | <blank> | Exchange ID description
EXTBLSRC | string | 50 | N | <blank> | Exchange rate source
RATEEXPR | i4 | 2 | N | Default from setup | Rate expiration: 0=None 1=Daily; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Quarterly; 7=Annually; 8=Miscellaneous; 9=None;
DYSTINCR | i4 | 2 | N | Default from setup | Days to increment—used only when RATEEXPR=8
RATEVARC | number | 21 | N | 0 | Rate variance
TRXDTDEF | i4 | 2 | N | Default from setup | Transaction date default: 0=Exact date; 1=Next date; 2=Previous date
RTCLCMTD | i4 | 2 | N | Default from setup | Rate calculation method: 0=Multiply; 1=Divide
PRVDSLMT | i4 | 2 | N | 0 | Previous day's limits
DATELMTS | i4 | 2 | N | 0 | Date limits: 0=Unlimited; 1=Limited
TIME1 | datetime | 16 | N | <blank> | MC exchange time=Time 1
DISAVAMT | number | 21 | N | Default from setup | Discount available amount; cannot be larger than document amount
DSCDLRAM | number | 21 | N | Default from setup | Discount dollar amount
DSCPCTAM | number | 21 | N | Default from setup | Discount percent amount
FREIGTBLE | i4 | 4 | N | 0 | Freight taxable: 0=Default from SOP setup; 1=Taxable; 2=Nontaxable; 3=Base on customers
MISCTBLE | i4 | 4 | N | 0 | Miscellaneous amount taxable: 0=Default from SOP setup; 1=Taxable; 2=Nontaxable; 3=Base on customers
COMMNTID | string | 15 | N | Default from setup | Comment ID
COMMENT_1 | string | 50 | N | <blank> | Comment 1
COMMENT_2 | string | 50 | N | <blank> | Comment 2
COMMENT_3 | string | 50 | N | <blank> | Comment 3
COMMENT_4 | string | 50 | N | <blank> | Comment 4
GPSFOINTEGRATIONID | string | 30 | N | <blank> | Front office integration ID
INTEGRATIONSOURCE | i4 | 2 | N | 0 | Integration source
INTEGRATIONID | string | 30 | N | <blank> | Integration ID
ReqShipDate | datetime | 16 | N | <blank> | Requested ship date
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
CKCreditLimit | i4 | 1 | N | 0 | Flag to allow check on credit limits before transaction is processed: 0=Does not check credit limit; 1=Checks credit limit
CKHOLD | i4 | 1 | N | 0 | Flag to allow check on hold status: 0=Does not check hold status; 1=Checks hold status
UpdateExisting | i4 | 1 | N | 0 | Used to modify header: 0=New transaction; 1=Update header—used to update after transaction exists
QUOEXPDA | datetime | 16 | N | <blank> | Quote expiration date; defaults based on setup if not filled in
QUOTEDAT | datetime | 16 | N | <blank> | Quote date; used for SOPTYPE <> 1; if SOPTYPE=1, DOCDATE is used
INVODATE | datetime | 16 | N | <blank> | Invoice date; used for SOPTYPE <> 3; if SOPTYPE=3, DOCDATE is used
BACKDATE | datetime | 16 | N | <blank> | Back order date; used for SOPTYPE <> 4; if SOPTYPE=4, DOCDATE is used
RETUDATE | datetime | 16 | N | <blank> | Return date; used for SOPTYPE <> 5; if SOPTYPE=5, DOCDATE is used
CMMTTEXT | string | 500 | N | <blank> | Comment text; used only if not using COMMENT_1 through COMMENT_4
PRCLEVEL | string | 10 | N | <blank> | Price level
DEFPRICING | i4 | 1 | N | 0 | 1=Subtotal will be calculated from SOP line or lines
TAXEXMT1 | string | 25 | N | Default from setup | Tax exempt 1; default is from customer if not supplied
TAXEXMT2 | string | 25 | N | Default from setup | Tax exempt 2; default is from customer if not supplied
TXRGNNUM | string | 25 | N | Default from setup | Tax registration number; default is from customer if not supplied
REPTING | i4 | 1 | N | 0 | Repeating: 0=False; 1=True Only valid for SOPTYPE=1 or 2
TRXFREQU | i4 | 2 | N | 0 | Frequency: 1=Weekly; 2=Biweekly; 3=Semimonthly; 4=Monthly; 5=Bi-Monthly; 6=Quarterly; 7=Misc. Only valid for SOPTYPE=1 or 2
TIMETREP | i4 | 2 | N | 0 | Times Repeating; Only valid for SOPTYPE=1 or 2
QUOTEDYSTINCR |  | 2 | N | 0 | Days to Increment; Only valid for SOPTYPE=1 or 2
NOTETEXT | string | 8000 | N | Default from setup | Notes field
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taSopHdrIvcInsert> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taSopLineDelete>

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Invoice number
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence number for item to be deleted
ITEMNMBR | string | 30 | Y | Not applicable | Item number for line item to be deleted
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
RecreateDist | i4 | 2 | N | 0 | 0=Do not re-create; 1=Re-create distributions
CMPNTSEQ | i4 | 4 | N | 0 | Component sequence number to be deleted; required if same component item on multiple lines is used when deleting component lines on a kit and not the kit itself
DeleteType | i4 | 2 | Y | Not applicable | 1=Line item deletion; 2=Kit item line component deletion
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taSopLineIvcInsert>*

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Invoice number
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
DOCDATE | datetime | 16 | Y | Not applicable | Invoice date
USERDATE | datetime | 16 | N | System date | User Date: Used to determine if a lot is expired., defaults to system date
LOCNCODE | string | 10 | N | <blank> | Location code
ITEMNMBR | string | 30 | Y | Not applicable | Item number If you have a document with more than one taSopLineIvcInsert node, use the values in the ITEMNMBR element to specify the sequence where each node appears in the document.
AutoAssignBin | i4 | 2 | N | 1 | Auto assign bin will use either the SOFULFILLMENT or SORETURN bin
UNITPRCE | number | 21 | N | 0 | Unit price for item
XTNDPRCE | number | 21 | N | 0 | Extended price for line item
QUANTITY | number | 21 | Y | Not applicable | Quote=Quantity to order; Order and Bkorder=Quantity to invoice; Invoice=Billed quantity; Return=Total quantity
MRKDNAMT | number | 21 | N | Default from setup | Markdown amount
MRKDNPCT | number | 21 | N | Default from setup | Markdown percent; if MRKDNPCT is utilized, in <taSopHdrIvcInsert> the element DEFPRICING must be set to 1 or error 67 will occur.
COMMNTID | string | 15 | N | <blank> | Comment ID
COMMENT_1 | string | 50 | N | <blank> | Comment 1
COMMENT_2 | string | 50 | N | <blank> | Comment 2
COMMENT_3 | string | 50 | N | <blank> | Comment 3
COMMENT_4 | string | 50 | N | <blank> | Comment 4
UNITCOST | number | 21 | N | Default from setup | Unit cost Used with non-inventory items or return type documents. If null, the default is pulled for inventory or 0 for non-inventory.
PRCLEVEL | string | 10 | N | <blank> | Price level
ITEMDESC | string | 100 | N | <blank> | Item description
TAXAMNT | number | 21 | N | 0 | Tax amount on line item without freight and miscellaneous tax
QTYONHND | number | 21 | N | 0 | Return quantity type: On hand
QTYRTRND | number | 21 | N | 0 | Return quantity type: Returned
QTYINUSE | number | 21 | N | 0 | Return quantity type: In use
QTYINSVC | number | 21 | N | 0 | Return quantity type: In service
QTYDMGED | number | 21 | N | 0 | Return quantity type: Damaged
NONINVEN | i4 | 2 | N | 0 | Non-inventory: 0=No; 1=Yes
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence number; by default, the line item sequence number will be autoincremented by 16,384 for each SOP line if it is not passed in; if the value needs to be passed in, we recommend passing in a value of 16,384 for the first line and increment the value by 16,384 for each subsequent line (that is, pass in a value of 16,384 for the first SOP line and then 32,768 for the second SOP line)
DROPSHIP | i4 | 2 | N | 0 | Drop ship flag 1=Drop ship
QTYTBAOR | number | 21 | N | 0 | Quantity to back order
DOCID | string | 15 | N | <blank> | Document ID; if left blank, line will autoallocate and fulfill
SALSTERR | string | 15 | N | Default from setup | Sales territory
SLPRSNID | string | 15 | N | Default from setup | Salesperson ID
ITMTSHID | string | 15 | N | Default from setup | Item tax schedule ID; if user wants to pass in a blank schedule ID, '' (tick tick) must be passed in for ITMTSHID
IVITMTXB | i4 | 2 | N | 0 | IV item taxable; user can change item tax option per line: 0=Default; 1=Tax; 2=Nontax; 3=Based on customer
TAXSCHID | string | 15 | N | Default from setup | Delivery method tax schedule ID; can be used to override the default delivery method tax schedule; if user wants to pass in a blank schedule ID, '' (tick tick) must be passed in for TAXSCHID
PRSTADCD | string | 15 | N | Default from setup | Primary ship to address code
ShipToName | string | 64 | N | <blank> | Ship to name: The default gets the ship to name from the customer ship to address.
CNTCPRSN | string | 60 | N | <blank> | Contact person
ADDRESS1 | string | 60 | N | <blank> | Customer address one per ship to line item
ADDRESS2 | string | 60 | N | <blank> | Customer address two per ship to line item
ADDRESS3 | string | 60 | N | <blank> | Customer address three per ship to line item
CITY | string | 35 | N | <blank> | City per ship to line item
STATE | string | 29 | N | <blank> | State per ship to line item
ZIPCODE | string | 10 | N | <blank> | ZIP Code per ship to line item
COUNTRY | string | 60 | N | <blank> | Country per ship to line item
PHONE1 | string | 21 | N | <blank> | Phone 1 per ship to line item
PHONE2 | string | 21 | N | <blank> | Phone 2 per ship to line item
PHONE3 | string | 21 | N | <blank> | Phone 3 per ship to line item
FAXNUMBR | string | 21 | N | <blank> | Fax per ship to line item
Print_Phone_NumberGB | i4 | 2 | N | Default from setup | Print phone number: 0=Do not print; 1=Phone 1; 2=Phone 2; 3=Phone 3; 4=Fax
EXCEPTIONALDEMAND | i4 | 1 | N | 0 | Resource planning
ReqShipDate | datetime | 16 | N | <blank> | Requested ship date
FUFILDAT | datetime | 16 | N | <blank> | Fulfill date
ACTLSHIP | Datetime | 16 | N | <blank> | Actual ship date
SHIPMTHD | string | 15 | N | Default from setup | Shipping method
INVINDX | string | 75 | N | <blank> | Inventory account number string
CSLSINDX | string | 75 | N | <blank> | Cost of goods sold account number string
SLSINDX | string | 75 | N | <blank> | Sales account number string
MKDNINDX | string | 75 | N | <blank> | Markdowns account number string
RTNSINDX | string | 75 | N | <blank> | Returns account number string
INUSINDX | string | 75 | N | <blank> | In use account number string
INSRINDX | string | 75 | N | <blank> | In service account number string
DMGDINDX | string | 75 | N | <blank> | Damaged account number string
AUTOALLOCATESERIAL | i4 | 4 | N | 0 | Autoallocate serial numbers on the fly: 0=Auto; 1=Manual; 2=Mixed
AUTOALLOCATELOT | i4 | 4 | N | 0 | Autoallocate lot numbers on the fly: 0=Auto; 1=Manual; 2=Mixed
GPSFOINTEGRATIONID | string | 30 | N | <blank> | Front office integration ID
INTEGRATIONSOURCE | i4 | 2 | N | 0 | Integration source
INTEGRATIONID | string | 30 | N | <blank> | Integration ID
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
QTYCANCE | number | 21 | N | 0 | Quantity canceled; will subtract from the QUANTITY passed in
QTYFULFI | number | 21 | N | Default from setup | Quantity fulfilled—if set to a value other than null, that quantity value will be used
ALLOCATE | i4 | 2 | N | 0 | Allocates quantities; 0=Use DOCID default; 1=Allocate quantities
UpdateIfExists | i4 | 2 | N | 0 | Used to add or modify existing documents; 1=Add/modify—entire line will need to be resent
RecreateDist | i4 | 2 | N | 0 | Used only if UpdateIfExists=1; 0=Do not re-create distributions; 1=Re-create distributions
QUOTEQTYTOINV | number | 21 | N | 0 | Quote quantity to invoice; added to QUANTITY and QTYCANCE for total quote amount
TOTALQTY | number | 21 | N | 0 | Total line quantity; used if total line quantity exceeds individual quantity amounts being sent in
CMMTTEXT | string | 500 | N | <blank> | Comment text; used only if COMMENT_1 through COMMENT_4 are not being used
KitCompMan | i4 | 2 | N | 0 | Manually passing kit components: 0=False; 1=True (if 1, LNITMSEQ is required)
DEFPRICING | i4 | 4 | N | 0 | 1=Unit price and extended price will use default
DEFEXTPRICE | i4 | 4 | N | 0 | Extended price will use the default based on the unit price and quantity passed in
CURNCYID | string | 15 | N | <blank> | Currency ID
UOFM | string | 8 | N | <blank> | Unit of measure
IncludPromo | i4 | 2 | N | 0 | Include extended pricing promotion, including free items
CKCreditLimit | i4 | 1 | N | 0 | Check credit limit at line level: 0=Do not check credit limit; 1=Check limit (users still have the ability to check credit limit at the header level)
QtyShrtOpt | i4 | 2 | N | 2 | Quantity shortage option: 1=Sell balance; 2=Override shortage; 3=Back Order all; 4=Back Order balance; 5=Cancel all; 6=Cancel balance More information available in SOP Transaction General Information.
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taSopLineIvcInsert> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taSopLineIvcInsertComponent>*

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | SOP number
USERDATE | datetime | 16 | N | System date | User Date: Used to determine if a lot is expired., defaults to system date
LOCNCODE | string | 10 | N | <blank> | Location code; default is from IV setup if not passed in
LNITMSEQ | i4 | 4 | Y | Not applicable | Line sequence; must match kit item line sequence
ITEMNMBR | string | 30 | Y | Not applicable | Component item number
AutoAssignBin | i4 | 2 | N | 1 | Autoassign bin; either the SOFULFILLMENT bin or the SORETURN bin will be used (item site combination or site default)
ITEMDESC | string | 100 | N | <blank> | Item description
QUANTITY | number | 21 | Y | Not applicable | Quantity to invoice when SOPTYPE=1,2, and 5; billed quantity for SOPTYPE=3
QTYTBAOR | number | 21 | N | 0 | Quantity to back order
QTYCANCE | number | 21 | N | 0 | Quantity canceled
QTYFULFI | number | 21 | N | Default from setup | Quantity fulfilled—if set to a value other than null, that quantity will be used
QUOTEQTYTOINV | number | 21 | N | 0 | Quote quantity to invoice; added to QUANTITY and QTYCANCE for total amount
QTYONHND | number | 21 | N | 0 | Quantity on hand; used for SOPTYPE=4
QTYRTRND | number | 21 | N | 0 | Quantity returned; used for SOPTYPE=4
QTYINUSE | number | 21 | N | 0 | Quantity in use; used for SOPTYPE=4
QTYINSVC | number | 21 | N | 0 | Quantity in service; used for SOPTYPE=4
QTYDMGED | number | 21 | N | 0 | Quantity damaged; used for SOPTYPE=4
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
DOCID | string | 15 | N | <blank> | Document ID; should be same as DOCID passed to the <taSopLineIvcInsert> node for Kit
UNITCOST | number | 21 | N | Default from setup | Unit cost Used with non-inventory items or return type documents. If null, the default is pulled for inventory or 0 for non-inventory. A kit item return does not use the specified unit cost value, the value defaults to the current cost or standard cost of the item.
NONINVEN | i4 | 2 | N | 0 | 0=Inventoried component item; 1=Non-inventoried component item
AUTOALLOCATESERIAL | i4 | 4 | N | 0 | Autofulfill serial numbers on the fly; 0=Auto; 1=Manual; 2=Mixed
AUTOALLOCATELOT | i4 | 4 | N | 0 | Auto-fulfill lot numbers on the fly; 0=Auto; 1=Manual; 2=Mixed
CMPNTSEQ | i4 | 4 | N | 0 | Component sequence; required if UpdateIfExists=1; uses the default if not passed in and not required
CMPITUOM | string | 9 | N | <blank> | Component unit of measure; uses the default if not passed in
CURNCYID | string | 15 | N | <blank> | Currency ID
UpdateIfExists | i4 | 2 | N | 0 | Used to add or modify existing components: 0=Add; 1=Modify
RecreateDist | i4 | 2 | N | 0 | Used only is UpdateIfExists=1; determines if distributions auto recreate
RequestrTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
QtyShrtOpt | i4 | 2 | N | 2 | Quantity shortage option: 1=Sell balance; 2=Override shortage; 3=BO all; 4=BO balance; 5=Cancel all; 6=Cancel balance
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The default action for the <taSopLineIvcInsertComponent> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taSopLineIvcTaxInsert>

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
TAXTYPE | i4 | 2 | N | 0 | 0=Regular; 1=Freight; 2=Miscellaneous (required/optional field)
SOPNUMBE | string | 21 | Y | Not applicable | Invoice number
CUSTNMBR | string | 15 | Y | Not applicable | Customer number (required/optional field)
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence—ignored for freight/miscellaneous required/optional field
SALESAMT | number | 21 | N | 0 | Details taxable amount for sales
FRTTXAMT | number | 21 | N | 0 | Freight tax—must be on freight record and 0 sequence number record
MSCTXAMT | number | 21 | N | 0 | Miscellaneous tax—must be on miscellaneous record and 0 sequence number record
FREIGHT | number | 21 | N | 0 | Freight amount—must be on freight record and 0 sequence number record
MISCAMNT | number | 21 | N | 0 | Miscellaneous amount—must be on miscellaneous record and 0 sequence number record
TAXDTLID | string | 15 | Y | Not applicable | Tax detail ID
ACTINDX | i4 | 4 | N | 0 | Account index
ACTNUMST | string | 75 | N | <blank> | Account number string
STAXAMNT | number | 21 | N | 0 | Sales tax amount—not used for freight
TDTTXSLS | number | 21 | N | Default from setup | Total taxable sales amount
TXDTOTTX | number | 21 | N | Default from setup | Tax detail total tax potential
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taSopLotAuto>*

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 2=Order; 3=Invoice; 4=Return; 5=Bkorder; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Document number
USERDATE | datetime | 16 | N | System date | User Date: Used to determine if a lot is expired.
LNITMSEQ | i4 | 4 | Y | Not applicable | Line item sequence; used to order line items; internally, the number is incremented by 16384 and the same value that is passed in to the related <taSopLineIvcInsert> node should be used
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LOCNCODE | string | 10 | N | <blank> | Location code
QUANTITY | number | 21 | Y | Not applicable | Total quantity for line item
BIN | string | 15 | N | <blank> | Bin; BIN is required if multi bins are enabled and creating a lot # on the fly, otherwise defaults from IV00300
CREATEBIN | i4 | 1 | N | 0 | Create Bin*: 0=No; 1=Yes *CREATEBIN is only used when automatically creating lot number and multi bins are enabled
LOTNUMBR | string | 20 | N | <blank> | Lot number for autocreation
EXPNDATE | datetime | 16 | N | <blank> | Expiration Date: Used to specify the date for a newly created lot layer. If an expiration date is supplied for a decrease adjustment/variance, a lot layer needs to exist.
MFGDATE | datetime | 16 | N | <blank> | Manufacturing Date: Used to specify the date for a newly created lot layer.
QTYTYPE | i4 | 2 | N | 1 | Quantity type: 1= on hand; 2= returned; 3= in se; 4= in service; 5= damaged
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
DOCID | string | 15 | N | <blank> | Document ID; should match DOCID passed to <taSopLineIvcInsert>
DROPSHIP | i4 | 2 | N | 0 | Drop ship flag; 1=Drop ship—should match drop ship passed to <taSopLineIvcInsert>
QTYFULFI | number | 21 | N | Default from startup | Quantity fulfilled; the sum of this field on all <taSopLotAuto> nodes should match QTYFULFI passed to <taSopLineIvcInsert>; if set to a value other than null, that value is used (this is to help users because this node shouldn't be called if not fulfilling
ALLOCATE | i4 | 2 | N | 0 | Allocates quantities; should match ALLOCATE passed to <taSopLineIvcInsert> node; 0=Use DOCID default; 1=Allocate quantities if DOCID allows—this is to help users because this node shouldn't be called if not fulfilling
CMPNTSEQ | i4 | 4 | N | 0 | Component sequence
LOTNUMBRToReplace | string | 20 | N | <blank> | Previous lot number; used only if modifying an existing lot number; quantity has to match to an existing line
AUTOCREATELOT | i4 | 4 | N | 0 | Autocreate lot number on the fly (for the amount over any existing amount for the lot being used): 0=False; 1=True
UOFM | string | 8 | N | <blank> | Unit of measure; should match SOP line
DATERECD | datetime | 16 | N | <blank> | Date received
UpdateIfExists | i4 | 2 | N | 1 | Used to add or modify existing documents: 0=New document; 1=Modify existing
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taSopLotAuto> node uses field level updates to provide update functionality.


<taSopMultiBin>

You use the <taSopMultiBin> XML node to manually add bins, use a bin other than the default, or when you enter non-serial/non-lot items.

Element name | Data type | Length | Required | Default | Description
SOPNUMBE | string | 21 | Y | Not applicable | SOP document number
SOPTYPE | i4 | 2 | Y | Not applicable | SOP type: 2=Order; 3=Invoice; 4=Return (5=Back order—not valid); 6=Fulfillment order
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LNITMSEQ | i4 | 4 | N | 0 | Line item sequence; must match the sequence number in the SOP line if the item is on more than one line
CMPNTSEQ | i4 | 4 | N | 0 | Component sequence; must match the sequence number in the SOP line if the item is a kit item
BIN | string | 15 | N | <blank> | Bin number; the default bin will be used if this element is not passed in
QTYTYPE | i4 | 2 | N | 1 | Quantity type: 1=On hand; 2=Returned; 3=In use; 4=In service; 5=Damaged
UOFM | string | 8 | N | <blank> | Unit of measure; the default unit of measure will be used if this element is not passed in
QUANTITY | number | 21 | Y | Not applicable | Quantity; must be greater than zero
CreateBin | i4 | 4 | N | 0 | Create bin on the fly: 0=False; 1=True
OverrideBin | i4 | 1 | N | 0 | Override bin shortage flag: 0=Do not override; 1=Override
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field; developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field; developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taSopSerial>*

To use the default serial number, or to use serial number created by back office system, set the AUTOCREATESERIAL element of the <taSopLineIvcInsert> XML node to 1. To manually specify serial numbers, set the AUTOCREATESERIAL element to 0. Use the <taSopSerial> XML node to specify the serial number.

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 4 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Document number
LNITMSEQ | i4 | 4 | Y | Not applicable | Line item sequence
CMPNTSEQ | i4 | 4 | N | 0 | Component sequence
QTYTYPE | i4 | 2 | N | 1 | Quantity type: 1=Quantity on hand; 2=Quantity returned; 3=Quantity in use; 4=Quantity in service; 5=Quantity damaged
ITEMNMBR | string | 30 | Y | Not applicable | Item number
LOCNCODE | string | 10 | Y | Not applicable | If empty, default from IV is used
QUANTITY | number | 21 | N | 1 | Not used; always is set to 1 because serial numbers are a 1:1 relationship with the SOP line; multiple nodes would need to be used to pass in multiple serial numbers
BIN | string | 15 | N | <blank> | Bin; if multibins are enabled and AUTOCREATESERIAL=1, or SOPTYPE=4, this element is required; otherwise, its default is from IV00200
CREATEBIN | i4 | 1 | N | 0 | Create bin: 0=No; 1=Yes—can create bin only when multibins are enabled and AUTOCREATESERIAL=1, or SOPTYPE=4
SERLNMBR | string | 20 | N | <blank> | Serial number
AUTOCREATESERIAL | i4 | 4 | N | 0 | Autocreate serial number on the fly: 0=False; 1=True
DOCID | string | 15 | N | <blank> | Document ID; should match DOCIDpassed to taSopLineIvcInsert
DROPSHIP | i4 | 2 | N | 0 | Drop ship flag; 1=Drop ship—should match Drop Ship_State to taSopLineIvcInsert
QTYFULFI | number | 21 | N | Default from setup | Quantity fulfilled; the sum of this field on all <taSopSerial> nodes being passed in should match QTYFULFI passed to <taSopLineIvcInsert>; if set to a value other than null, that value is used (this element is to help users because this node should only be called if quantities need fulfilling)
ALLOCATE | i4 | 2 | N | 0 | Allocates quantities; should match ALLOCATE passed to <taSopLineIvcInsert>; 0=Use DOCID default; 1=Allocate quantities if DOCID allows (this is to help users because this node shouldn't be called if not fulfilling)
UpdateIfExists | i4 | 2 | N | 0 | Used to add or modify existing components: 0=Add; 1=Modify existing
SERLNMBRToReplace | string | 20 | N | 0 | Previous serial number; used only if modifying an existing serial number
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field; developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field; developer use only

* The default action for the <taSopSerial> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taSopToPopLink>

You can use the <taSopToPopLink> XML node to create new purchase orders.

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 2=Order; 5=Back order
SOPNUMBE | string | 21 | Y | Not applicable | SOP number
VENDORID | string | 15 | N | <blank> | ID of vendor purchasing from for non-inventory items; required if non-inventory items are used (the vendor ID for inventory items uses Primary Vendor for the Item/Location combination as the default and does not use this parameter)
DOCDATE | datetime | 16 | N | <blank> | Date of the POs; default is current system state
CURNCYID | string | 15 | N | <blank> | Currency ID to use for all POs; default is from vendor or MC setup
SHIPMTHD | string | 15 | N | Default from setup | Shipping method to use for all POs; default is from vendor
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taSopTrackingNum>

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Document number
Tracking_Number | string | 40 | Y | Not applicable | Tracking number
Type | i4 | 2 | N | 0 | Type: 0=New document tracking number or adding a tracking number to an existing document; 1=Flag to delete tracking number on an existing document
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taSopUpdateCreateProcessHold>*

Element name | Data type | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Invoice number
PRCHLDID | string | 15 | Y | Not applicable | Process hold ID
DSCRIPTN | string | 30 | N | <blank> | Process hold description
PASSWORD | string | 15 | N | <blank> | Process hold password
XFERPHOL | i4 | 1 | N | 0 | Transferring process hold
POSTPHOL | i4 | 1 | N | 0 | Posting process hold
FUFIPHOL | i4 | 1 | N | 0 | Fulfill process hold
PRINPHOL | i4 | 1 | N | 0 | Printing process hold
HOLDDATE | datetime | 16 | N | <blank> | Hold date
USERID | string | 15 | N | <blank> | User ID
TIME1 | datetime | 16 | N | <blank> | Hold time
DELETE1 | i4 | 4 | N | 0 | 0=Add process hold, 1=Remove process hold
UpdateIfExistsMaster | i4 | 4 | N | 0 | Update process hold master information, if it exists in the parameters
UpdateSopIfExists | i4 | 4 | N | 0 | Update SOP record if it exists
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)

* The default action for the <taSopUpdateCreateProcessHold> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taSopUserDefined>

Element name | Datatype | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | <blank> | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | <blank> | Invoice number
USRDAT01 | datetime | 16 | N | <blank> | User-defined date 1
USRDAT02 | datetime | 16 | N | <blank> | User-defined date 2
USRTAB01 | string | 20 | N | Default from setup | User-defined table 1
USRTAB09 | string | 20 | N | Default from setup | User-defined table 2
USRTAB03 | string | 20 | N | Default from setup | User-defined table 3
USERDEF1 | string | 20 | N | Default from setup | User defined 1
USERDEF2 | string | 20 | N | Default from setup | User defined 2
USRDEF03 | string | 20 | N | Default from setup | User defined 3
USRDEF04 | string | 20 | N | Default from setup | User defined 4
USRDEF05 | string | 20 | N | Default from setup | User defined 5
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

This node uses document exchange for updates. All existing values are overwritten with the value specified by the update document. If a field in the update is blank, the existing value is changed to be blank.


<taSopVoidDocument>

Element name | Datatype | Length | Required | Default | Description
SOPTYPE | i4 | 2 | Y | Not applicable | 1=Quote; 2=Order; 3=Invoice; 4=Return; 5=Back order; 6=Fulfillment order
SOPNUMBE | string | 21 | Y | Not applicable | Invoice number
BACHNUMB | string | 15 | N | <blank> | User ID for new batch ID in history
RemovePayments | i4 | 2 | N | 1 | 0=Do not remove deposits; 1=Remove deposits
VOIDDATE | datetime | 16 | N | <blank> | Void date
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only


<taUpdateCreateAccountRcd>*

Element name | Data type | Length | Required | Default | Description
ACTNUMST | string | 75 | N | <blank> | Account string
ACTALIAS | string | 21 | N | <blank> | Account alias
ACCTTYPE | i4 | 2 | N | 1 | Account type: 1=Posting; 2=Unit account; 3=Posting allocation; 4=Unit allocation
ACTDESCR | string | 50 | N | <blank> | Account description: If a value is not supplied, the element value defaults from the segment setup.
PSTNGTYP | i4 | 2 | N | 0 | Posting type: 0=Balance sheet; 1=Profit & loss account
CATEGORY | string | 50 | N | <blank> | Account category—required if a posting account
ACTIVE | i4 | 1 | N | 1 | Active: 0=Inactive; 1=Active
TPCLBLNC | i4 | 2 | N | 0 | Typical balance: 0=Debit; 1=Credit
DECPLACS | i4 | 2 | N | 0 | Decimal Places—only used for unit accounts
FXDORVAR | i4 | 2 | N | 0 | Fixed or variable allocation: 1=Fixed; 2=Variable
BALFRCLC | i4 | 2 | N | 0 | Based on flag: 0=Year to date; 1=Transaction period
USERDEF1 | string | 20 | N | <blank> | User defined 1
USERDEF2 | string | 20 | N | <blank> | User defined 2
PostSlsIn | i4 | 2 | N | 1 | Post sales in: 1=Detail; 2=Summary
PostIvIn | i4 | 2 | N | 1 | Post inventory in: 1=Detail; 2=Summary
PostPurchIn | i4 | 2 | N | 1 | Post purchasing in: 1=Detail; 2=Summary
PostPRIn | i4 | 2 | N | 1 | Post payroll in: 1=Detail; 2=Summary
ACCTENTR | i4 | 1 | N | 1 | Allow account entry: 0=False; 1=True
USRDEFS1 | string | 30 | N | <blank> | User defined string 1
USRDEFS2 | string | 30 | N | <blank> | User defined string 2
UpdateIfExists | i4 | 1 | N | 1 | Flag to update account data if it exists: 0=No; 1=Yes
NOTETEXT | string | 8000 | N | <blank> | Notes field
DSPLKUPSSALES | i4 | 1 | N | 1 | Include in Lookup for Sales: 0=False; 1=True Valid for ACCTTYPE values of 1, 2, 3, and 4.
DSPLKUPSIV | i4 | 1 | N | 1 | Include in Lookup for Inventory Control: 0=False; 1=True Valid for ACCTTYPE values of 1, 3, and 4.
DSPLKUPSPURCH | i4 | 1 | N | 1 | Include in Lookup for Purchasing: 0=False; 1=True Valid for ACCTTYPE values of 1, 2, 3, and 4.
DSPLKUPSPR | i4 | 1 | N | 1 | Include in Lookup for Payroll: 0=False; 1=True Valid for ACCTTYPE values of 1, 3, and 4.
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taUpdateCreateAccountRcd> node uses field level updates to provide update functionality.


<taUpdateCreateCountryCode>*

Element name | Data type | Length | Required | Default | Description
CCode | string | 6 | Y | Not applicable | Country code
CCodeDesc | string | 30 | Y | Not applicable | Country code description
ECFLAG | i4 | 2 | N | 0 | EU member: 0=False; 1=True
UpdateIfExists | i4 | 2 | N | 0 | Update if exists: 0=False; 1=True
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1= True (if True, it populates requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field; developer use only
USRDEFND3 | string | 8000 | N | <blank> | User-defined field; developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field; developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field; developer use only

* The default action for the <taUpdateCreateCountryCode> node is to use document exchange to provide update functionality. To use field level updates, set UpdateIfExists to 1.


<taUpdateCreateCustomerRcd>*

Element name | Data type | Length | Required | Default | Description
CUSTNMBR | string | 15 | Y | Not applicable | Customer number
HOLD | i4 | 1 | N | Default from setup | Hold status: 0=Not on hold; 1=On hold Default is zero on new record
INACTIVE | i4 | 1 | N | Default from setup | Inactive: 0=Active; 1=Inactive Default is zero on new record
CUSTNAME | string | 64 | N | Default from setup | Customer name
SHRTNAME | string | 15 | N | Default from setup | Short name; if not passed in, default is CUSTNAME
STMTNAME | string | 64 | N | Default from setup | Statement name; if not passed in, default is CUSTNAME
CUSTCLAS | string | 15 | N | Default from setup | Customer class ID
CUSTPRIORITY | i4 | 2 | N | Default from setup | Customer priority; valid input values 1 (none) to 100 Default is one on new record
ADRSCODE | string | 15 | N | Default from setup | Primary address ID
CNTCPRSN | string | 60 | N | Default from setup | Contact person
ADDRESS1 | string | 60 | N | Default from setup | Customer address one
ADDRESS2 | string | 60 | N | Default from setup | Customer address two
ADDRESS3 | string | 60 | N | Default from setup | Customer address three
CITY | string | 35 | N | Default from setup | City
STATE | string | 29 | N | Default from setup | State
ZIPCODE | string | 10 | N | Default from setup | Zip code
CCode | string | 6 | N | Default from setup | Country code
COUNTRY | string | 60 | N | Default from setup | Country
PHNUMBR1 | string | 21 | N | Default from setup | Phone one
PHNUMBR2 | string | 21 | N | Default from setup | Phone two
PHNUMBR3 | string | 21 | N | Default from setup | Phone three
FAX | string | 21 | N | Default from setup | Fax
UPSZONE | string | 3 | N | Default from setup | UPS zone
SHIPMTHD | string | 15 | N | Default from setup | Shipping method
TAXSCHID | string | 15 | N | Default from setup | Tax schedule ID
SHIPCOMPLETE | i4 | 1 | N | Default from setup | Ship complete documents: 0=False; 1=True Default is zero on new record
PRSTADCD | string | 15 | N | Default from setup | Primary ship to address code
PRBTADCD | string | 15 | N | Default from setup | Primary bill to address code
STADDRCD | string | 15 | N | Default from setup | Statement to address code
SLPRSNID | string | 15 | N | Default from setup | Salesperson ID
SALSTERR | string | 15 | N | Default from setup | Sales territory
USERDEF1 | string | 20 | N | Default from setup | User-defined one
USERDEF2 | string | 20 | N | Default from setup | User-defined two
COMMENT1 | string | 30 | N | Default from setup | Comment one
COMMENT2 | string | 30 | N | Default from setup | Comment two
CUSTDISC | number | 21 | N | Default from setup | Trade discount
PYMTRMID | string | 20 | N | Default from setup | Payment terms ID
DISGRPER | i4 | 2 | N | Default from setup | Discount grace period
DUEGRPER | i4 | 2 | N | Default from setup | Due date grace period
PRCLEVEL | string | 10 | N | Default from setup | Price level
NOTETEXT | string | 8000 | N | Default from setup | Note text
BALNCTYP | i4 | 1 | N | Default from setup | Balance type: 0=Open item; 1=Balance forward Default is zero on new record
FNCHATYP | i4 | 2 | N | Default from setup | Finance charge type: 0=None; 1=Percent; 2=Amount Default is zero for new record
FNCHPCNT | number | 21 | N | Default from setup | Finance charge percent; used if FNCHATYP=1
FINCHDLR | number | 21 | N | Default from setup | Finance charge dollar; used if FNCHATYP=2
MINPYTYP | i4 | 2 | N | Default from setup | Minimum payment type: 0=No minimum; 1=Percent; 2=Amount Default is zero for new record
MINPYPCT | number | 21 | N | Default from setup | Minimum payment percent; used if MINPYTYP=1
MINPYDLR | number | 21 | N | Default from setup | Minimum payment dollar amount; used if MINPYTYP=2
CRLMTTYP | i4 | 2 | N | Default from setup | Credit limit type: 0=No credit; 1=Unlimited; 2=Amount Default is zero on new record
CRLMTAMT | number | 21 | N | Default from setup | Credit limit amount; used if CRLMTTYP=2
CRLMTPER | i4 | 2 | N | Default from setup | Credit limit period; used if CRLMTTYP=2 and the credit limit warning is used in Microsoft Dynamics GP application
CRLMTPAM | number | 21 | N | Default from setup | Credit limit period amount; used if CRLMTTYP=2 and the credit limit warning is used in Microsoft Dynamics GP application
MXWOFTYP | i4 | 2 | N | Default from setup | Maximum write-off type: 0=Not allowed; 1=Unlimited; 2=Maximum Default is zero for new record
MXWROFAM | number | 21 | N | Default from setup | Maximum write-off amount; used if MXWOFTYP=2
Revalue_Customer | i4 | 1 | N | Default from setup | Revalue customer: 0=Do not revalue; 1=Revalue Default is one for new record
Post_Results_To | i4 | 2 | N | Default from setup | Post results to: 0=Receivables/Discount Account; 1=Sales offset Default is zero on new records
ORDERFULFILLDEFAULT | i4 | 1 | N | Default from setup | Order fulfillment shortage: 1=None; 2=Back order remaining; 3=Cancel remaining Default is one on new record
INCLUDEINDP | i4 | 1 | N | Default from setup | Include in demand planning: 0=Do not include; 1=Include Default is one on new record
CRCARDID | string | 15 | N | Default from setup | Credit card ID
CRCRDNUM | string | 20 | N | Default from setup | Credit card number
CCRDXPDT | datetime | 16 | N | Default from setup | Credit card expiration date
BANKNAME | string | 30 | N | Default from setup | Bank name
BNKBRNCH | string | 20 | N | Default from setup | Bank branch
USERLANG | i4 | 2 | N | Default from setup | User language; default is zero on new record
TAXEXMT1 | string | 25 | N | Default from setup | Tax exempt one
TAXEXMT2 | string | 25 | N | Default from setup | Tax exempt two
TXRGNNUM | string | 25 | N | Default from setup | Tax registration number
CURNCYID | string | 15 | N | Default from setup | Currency ID
RATETPID | string | 15 | N | Default from setup | Rate type ID
STMTCYCL | i4 | 2 | N | Default from setup | Statement Cycle: 1=No Statement; 2=Weekly; 3=Biweekly; 4=Semimonthly; 5=Monthly; 6=Bimonthly; 7=Quarterly
KPCALHST | i4 | 1 | N | Default from setup | Maintain history—calendar year: 0=Do not maintain history; 1=Maintain history Default is 1 on new record
KPERHIST | i4 | 1 | N | Default from setup | Maintain history—fiscal year: 0=Do not maintain history; 1=Maintain history Default is 1 on new record
KPTRXHST | i4 | 1 | N | Default from setup | Maintain history—transaction: 0=Do not maintain history; 1=Maintain history Default is 1 on new record
KPDSTHST | i4 | 1 | N | Default from setup | Maintain history—distribution: 0=Do not maintain history; 1=Maintain history Default is 1 on new record
Send_Email_Statements | i4 | 1 | N | Default from setup | Send e-mail statements: 0=Do not sent statements; 1=Send statements Default is zero on new record
ToEmail_Recipient | string | 80 | N | Default from setup | To email recipient; separate each recipient with a semicolon
CcEmail_Recipient | string | 80 | N | Default from setup | Carbon copy email recipient; separate each recipient with a semicolon
BccEmail_Recipient | string | 80 | N | Default from setup | Blind carbon copy email recipient; separate each recipient with a semicolon
CHEKBKID | string | 15 | N | Default from setup | Checkbook ID
DEFCACTY | i4 | 2 | N | Default from setup | Cash account from: 0=Checkbook; 1=Customer Default is zero on new record
RMCSHACTNUMST | string | 75 | N | Default from setup | Cash account; only valid if DEFCACTY=1
RMARACTNUMST | string | 75 | N | Default from setup | Accounts receivable account
RMSLSACTNUMST | string | 75 | N | Default from setup | Sales account
RMCOSACTNUMST | string | 75 | N | Default from setup | Cost of sales account
RMIVACTNUMST | string | 75 | N | Default from setup | Inventory account
RMTAKACTNUMST | string | 75 | N | Default from setup | Terms discount taken account
RMAVACTNUMST | string | 75 | N | Default from setup | Terms discount available account
RMFCGACTNUMST | string | 75 | N | Default from setup | Finance charges account
RMWRACTNUMST | string | 75 | N | Default from setup | Write-offs account
RMSORACTNUMST | string | 75 | N | Default from setup | Sales order returns account
RMOvrpymtWrtoffACTNUMST | string | 75 | N | Default from setup | Overpayment write-offs account
GPSFOINTEGRATIONID | string | 30 | N | <blank> | Front office integration ID
INTEGRATIONSOURCE | i4 | 2 | N | 0 | Integration source
INTEGRATIONID | string | 30 | N | <blank> | Integration ID
UseCustomerClass | i4 | 1 | N | 0 | Flag to have class setting roll down to elements not passed in; uses the CUSTCLAS class to roll down
CreateAddress | i4 | 1 | N | 1 | Flag to allow a primary address code to be created on the fly: 0=Do not create address code; 1=Create address code
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow customer data to be updated if it exists: 0=Do not update; 1=Update if record exists; 2=Create if record does not exist and exits without error if record does exist
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taUpdateCreateCustomerRcd> node uses field level updates to provide update functionality.


<taUpdateCreateItemCurrencyRcd>*

Element name | Data type | Length | Required | Default | Description
ITEMNMBR | string | 30 | Y | Not applicable | Item number
CURNCYID | string | 15 | Y | Not applicable | Currency ID
DECPLCUR | i4 | 2 | N | 0 | Decimal places currency
LISTPRCE | number | 21 | N | 0 | List price
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow the data to be updated if it exists: 0=No; 1=Yes
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taUpdateCreateItemCurrencyRcd> node uses field level updates to provide update functionality.


<taUpdateCreateItemRcd>*

Element name

Data type

Length

Required

Default

Description

ITEMNMBR

string

30

Y

Not applicable

Item number

ITEMDESC

string

100

N

Default from setup

Item description

ITMSHNAM

string

15

N

Default from setup

Short description

ITMGEDSC

string

10

N

Default from setup

Generic description

ITMCLSCD

string

10

N

Default from setup

Class ID

ITEMTYPE

i4

2

N

Default from setup

Item type

1=Sales inventory;

2=Discontinued;

3=Kit;

4=Miscellaneous charges;

5=Services;

6=Flat fee

Default is one on new record

VCTNMTHD

i4

2

N

Default from setup

Valuation method:

0=Any ITEMTYPE other than 1 or 2;

1=FIFO perpetual;

2=LIFO perpetual;

3=Average perpetual;

4=FIFO periodic;

5=LIFO periodic

Default is one on new record

TAXOPTNS

i4

2

N

Default from setup

Sales tax options:

1=Taxable;

2=Nontaxable;

3=Base on customers

Default is one on new record

ITMTSHID

string

15

N

Default from setup

Tax schedule ID

UOMSCHDL

string

10

N

Default from setup

Unit of measure schedule ID

Required for a new record, but can roll down from class

ITEMSHWT

number

N

Default from setup

Shipping weight; only used when ITEMTYPE=1, 2, or 3

TCC

string

30

N

Default from setup

Tax community code; only used if the "Enable Intrastat Tracking" option is enabled in Company Setup

CNTRYORGN

string

6

N

Default from setup

Country origin; only used if the "Enable Intrastat Tracking" option is enabled in Company Setup

DECPLQTY

i4

2

N

Default from setup

Quantity Decimals; DECPLQTY can equal 0, 1, 2, 3, 4, or 5; if ITEMTYPE=3, then DECPLQTY must be set to zero

Default is zero on new record

DECPLCUR

i4

2

N

Default from setup

Currency Decimals; used for item if not registered for multi-currency or used for functional currency

If registered for multi-currency and want other currencies, use the <taUpdateCreateItemCurrencyRcd> node.

Purchase_Tax_Options

i4

2

N

Default from setup

Purchasing tax option:

1=Taxable;

2=Nontaxable;

3=Base on vendors

Default is one on new record

Purchase_Item_Tax_Schedu

string

15

N

Default from setup

Purchase tax schedule ID

STNDCOST

number

21

N

Default from setup

Standard cost

CURRCOST

number

21

N

Default from setup

Current cost

LISTPRCE

number

21

N

Default from setup

List price; used if multi-currency is not registered or used for functional currency if multi-currency is registered

NOTETEXT

string

8000

N

Default from setup

Note text

ALTITEM1

string

30

N

Default from setup

Alternate item 1

ALTITEM2

string

30

N

Default from setup

Alternate item 2

ITMTRKOP

i4

2

N

Default from setup

Item tracking:

1=None;

2=Serial Numbers;

3=Lot Numbers

Used when ITEMTYPE= 1 or 2

Default is one on new record

LOTTYPE

string

10

N

Default from setup

Lot category

LOTEXPWARN

i4

1

N

0

Lot Expiration Warn:

0 = no warning

1 = warnings enabled

If this item is not lot tracked, the value of this element is not used.

LOTEXPWARNDAYS

i4

2

N

0

Days Before Lot Expires:

Valid entries equal 0 - 999.

If LOTEXPWARN is 0 then LOTEXPWARNDAYS always defaults to 0. If this item is not lot tracked, the value of this element is not used.

INCLUDEINDP

i4

1

N

Default from setup

Include in Demand Planning;

0=Do Not Include;

1=Include

Default is zero on new record

MINSHELF1

i4

2

N

Default from setup

Minimum shelf life 1:

Valid entries equal 0-9999

Use when ITMTRKOP=3

Default is zero on new record

MINSHELF2

i4

2

N

Default from setup

Minimum shelf life 2:

Valid entries equal 0-9999

Use when ITMTRKOP=3

Default is zero on new record

ALWBKORD

i4

1

N

Default from setup

Allow back orders:

0=Do not allow back orders;

1=Allow back orders

Default is zero on new record

WRNTYDYS

i4

2

N

Default from setup

Warranty days; valid entries equal 0-9999

Default is zero on new record

ABCCODE

i4

2

N

Default from setup

ABC code:

1=None;

2=A;

3=B;

4=C

Default is one on new record

USCATVLS_1

string

10

N

Default from setup

User category 1

USCATVLS_2

string

10

N

Default from setup

User category 2

USCATVLS_3

string

10

N

Default from setup

User category 3

USCATVLS_4

string

10

N

Default from setup

User category 4

USCATVLS_5

string

10

N

Default from setup

User category 5

USCATVLS_6

string

10

N

Default from setup

User category 6

KPCALHST

i4

1

N

Default from setup

Maintain history—calendar year:

0=Do not keep history;

1=Keep history

Default is 0 on new record

KPERHIST

i4

1

N

Default from setup

Maintain history—fiscal year:

0=Do not keep history;

1=Keep history

Default is 0 on new record

KPTRXHST

i4

1

N

Default from setup

Maintain history—transaction:

0=Do not keep history;

1=Keep history

Default is 0 on new record

KPDSTHST

i4

1

N

Default from setup

Maintain history—distribution:

0=Do not keep history;

1=Keep history

Default is 0 on new record

IVIVACTNUMST

string

75

N

Default from setup

Inventory account

IVIVOFACTNUMST

string

75

N

Default from setup

Inventory offset account

IVCOGSACTNUMST

string

75

N

Default from setup

Cost of goods sold account

IVSLSACTNUMST

string

75

N

Default from setup

Sales account

IVSLDSACTNUMST

string

75

N

Default from setup

Markdown account

IVSLRNACTNUMST

string

75

N

Default from setup

Sales return account

IVINUSACTNUMST

string

75

N

Default from setup

In use account

IVINSVACTNUMST

string

75

N

Default from setup

In service account

IVDMGACTNUMST

string

75

N

Default from setup

Damaged account

IVVARACTNUMST

string

75

N

Default from setup

Variance account

DPSHPACTNUMST

string

75

N

Default from setup

Drop-ship items account

PURPVACTNUMST

string

75

N

Default from setup

Purchase price variance account

UPPVACTNUMST

string

75

N

Default from setup

Unrealized purchase price variance account

IVRETACTNUMST

string

75

N

Default from setup

Inventory returns account

ASMVRACTNUMST

string

75

N

Default from setup

Assembly variance account

KTACCTSR

i4

2

N

Default from setup

Cost of goods sold account source:

0=From component item;

1=From kit item

Default is zero on new record

PRCHSUOM

string

8

N

Default from setup

Purchasing unit of measure

Revalue_Inventory

i4

1

N

Default from setup

Revalue inventory for cost variance:

0=Do not revalue;

1=Revalue

Default is zero on new record

Tolerance_Percentage

number

21

N

Default from setup

Tolerance percentage

LOCNCODE

string

10

N

Default from setup

Location code; assigns site to item if it is not already assigned

PRICMTHD

i4

2

N

Default from setup

Price method:

1=Currency amount;

2=Percent of List price;

3=Percent of markup of current cost;

4=Percent markup of standard cost;

5=Percent margin of current cost;

6=Percent margin of standard cost

Default is one

PriceGroup

string

10

N

Default from setup

Price group

UseQtyOverageTolerance

i4

1

N

Default from setup

Use quantity overage tolerance:

0=Do not use;

1=Use

UseQtyShortageTolerance

i4

1

N

Default from setup

Use quantity shortage tolerance:

0=Do not use;

1=Use

QtyOverTolerancePercent

i4

4

N

Default from setup

Quantity over tolerance percent:

Provide a value of 0 - 99999. For example, 99999 equals 99.999.

QtyShortTolerancePercent

i4

4

N

Default from setup

Quantity short tolerance percent:

Provide a value of 0 - 99999. For example, 99999 equals 99.999.

UseItemClass

i4

1

N

0

Flag to have class setting roll down to elements that are not passed in; uses the ITMCLSCD class

UpdateIfExists

i4

1

N

1

Flag to allow item data to be updated if it exists: 0=Do not update;

1=Update if exists;

2=Create if record does not exist and exits without error if record does exist

RequesterTrx

i4

2

N

0

Requester transaction

0=False;

1=True (if True, it populates the requester shadow table)

USRDEFND1

string

50

N

Default from setup

User-defined field—developer use only

USRDEFND2

string

50

N

Default from setup

User-defined field—developer use only

USRDEFND3

string

50

N

Default from setup

User-defined field—developer use only

USRDEFND4

string

8000

N

Default from setup

User-defined field—developer use only

USRDEFND5

string

8000

N

Default from setup

User-defined field—developer use only

* The <taUpdateCreateItemRcd> node uses field level updates to provide update functionality.


<taUpdateCreatePAVendorRcd>*

Element name | Data type | Length | Required | Default | Description
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VNDCLSID | string | 10 | N | <blank> | Vendor class ID
PAddlDefpoformatouse | i4 | 2 | N | <blank> | Project account default PO format to use
PAUnit_of_Measure | string | 9 | N | 0 | Project account unit of measure
PAUNITCOST | number | 21 | N | 0 | Project account unit of cost
PATMProfitType | i4 | 2 | N | 0 | Project account profit type—TM: 1=Billing rate; 2=Markup percentage; 8=None
PATMProfitAmount | number | 21 | N | 0 | Project account profit amount—TM
PATMProfitPercent | number | 21 | N | 0 | Project account profit percent—TM
PAFFProfitType | i4 | 2 | N | 0 | Project account profit type—FF: 3=Profit fixed; 5=Total profit; 6=Percent of baseline; 8=None
PAFFProfitAmount | number | 21 | N | 0 | Project account profit amount—FF
PAFFProfitPercent | number | 21 | N | 0 | Project account profit percent—FF
PAProfit_Type_CP | i4 | 2 | N | 0 | Project account profit type—CP: 3=Profit fixed; 4=Profit variable; 5=Total profit; 6=Percent of baseline; 7=Percent of actual; 8=None
PAProfitAmountCP | number | 21 | N | 0 | Project account profit amount—CP
PAProfitPercentCP | number | 21 | N | 0 | Project account profit percent—CP
PAUD1 | string | 21 | N | <blank> | Project account user defined 1
PAUD2 | string | 21 | N | <blank> | Project account user defined 2
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow vendor data to be updated if it exists: 0=No; 1=Yes

* The <taUpdateCreatePAVendorRcd> node uses field level updates to provide update functionality.


<taUpdateCreateVendorRcd>*

Element name | Data type | Length | Required | Default | Description
VENDORID | string | 15 | Y | Not applicable | Vendor ID
VENDNAME | string | 64 | N | Default from setup | Vendor name
VENDSHNM | string | 15 | N | Default from setup | Vendor short name
VNDCHKNM | string | 64 | N | Default from setup | Vendor check name
HOLD | i4 | 1 | N | Default from setup | Hold: 0=Not on hold; 1=Hold Default is zero on new record
VENDSTTS | i4 | 2 | N | Default from setup | Vendor status: 1=Active; 2=Inactive; 3=Temporary Default is 1 on new record
VNDCLSID | string | 10 | N | Default from setup | Vendor class ID
VADDCDPR | string | 15 | N | Default from setup | Primary vendor address ID
VNDCNTCT | string | 60 | N | Default from setup | Vendor contact
ADDRESS1 | string | 60 | N | Default from setup | Address 1
ADDRESS2 | string | 60 | N | Default from setup | Address 2
ADDRESS3 | string | 60 | N | Default from setup | Address 3
CITY | string | 35 | N | Default from setup | City
STATE | string | 29 | N | Default from setup | State
ZIPCODE | string | 10 | N | Default from setup | Zip Code
CCode | string | 6 | N | Default from setup | Country code
COUNTRY | string | 60 | N | Default from setup | Country
PHNUMBR1 | string | 21 | N | Default from setup | Phone 1
PHNUMBR2 | string | 21 | N | Default from setup | Phone 2
PHNUMBR3 | string | 21 | N | Default from setup | Phone 3
FAXNUMBR | string | 21 | N | Default from setup | Fax number
TAXSCHID | string | 15 | N | Default from setup | Tax schedule ID
SHIPMTHD | string | 15 | N | Default from setup | Shipping method
UPSZONE | string | 3 | N | Default from setup | UPS zone
VADCDPAD | string | 15 | N | Default from setup | Vendor purchase address ID
VADCDTRO | string | 15 | N | Default from setup | Vendor remit to address ID
VADCDSFR | string | 15 | N | Default from setup | Vendor ship from address ID
ACNMVNDR | string | 20 | N | Default from setup | Vendor account number
COMMENT1 | string | 30 | N | Default from setup | Comment 1
COMMENT2 | string | 30 | N | Default from setup | Comment 2
NOTETEXT | string | 8000 | N | Default from setup | Note text
CURNCYID | string | 15 | N | Default from setup | Currency ID
RATETPID | string | 15 | N | Default from setup | Rate type ID
PYMTRMID | string | 20 | N | Default from setup | Payment terms ID
DISGRPER | i4 | 2 | N | Default from setup | Discount grace period; max value is 99
DUEGRPER | i4 | 2 | N | Default from setup | Due date grace period; max value is 99
PYMNTPRI | string | 3 | N | Default from setup | Payment priority
MINORDER | number | 21 | N | Default from setup | Minimum order
TRDDISCT | number | 21 | N | Default from setup | Trade discount
TXIDNMBR | string | 11 | N | Default from setup | Tax ID number
TXRGNNUM | string | 25 | N | Default from setup | Tax registration number
CHEKBKID | string | 15 | N | Default from setup | Checkbook ID
USERDEF1 | string | 20 | N | Default from setup | User-defined 1
USERDEF2 | string | 20 | N | Default from setup | User-defined 2
TEN99TYPE | i4 | 2 | N | Default from setup | Tax 1099 type: 1=Not a 1099 vendor; 2=Dividend; 3=Interest; 4=Miscellaneous
TEN99BOXNUMBER | i4 | 2 | N | Default from setup | Tax 1099 box number
FREEONBOARD | i4 | 2 | N | Default from setup | Free on board: 1=None; 2=Origin; 3=Destination Default is 1 on new order
USERLANG | i4 | 2 | N | Default from setup | User language; default is 0 on new record
MINPYTYP | i4 | 2 | N | Default from setup | Minimum payment type: 0=No minimum; 1=Percent; 2=Amount Default is zero on new record
MINPYDLR | number | 21 | N | Default from setup | Minimum payment dollar amount; used if MINPYTYP=2
MINPYPCT | number | 21 | N | Default from setup | Minimum payment percent; used if MINPYTYP=1
MXIAFVND | i4 | 2 | N | Default from setup | Maximum invoice amount type: 0=No maximum; 1=Amount Default is zero on new record
MAXINDLR | number | 21 | N | Default from setup | Maximum invoice dollar amount; used if MXIAFVND=1
CREDTLMT | i4 | 2 | N | Default from setup | Credit limit type: 0=No credit; 1=Unlimited; 2=Amount Default is zero on new record
CRLMTDLR | number | 21 | N | Default from setup | Credit limit dollar amount; used if CREDTLMT=2
WRITEOFF | i4 | 2 | N | Default from setup | Write-off type: 0=Not allowed; 1=Unlimited; 2=Maximum
MXWOFAMT | number | 21 | N | Default from setup | Maximum write-off amount; used if WRITEOFF=2
Revalue_Vendor | i4 | 1 | N | Default from setup | Revalue vendor: 0=Do not revalue; 1=Revalue Default is 1 on new record
Post_Results_To | i4 | 2 | N | Default from setup | Post results to: 0=Payable/Discount account; 1=Purchasing offset account Default is 1 on new record
KPCALHST | i4 | 1 | N | Default from setup | Maintain history—calendar year: 0=Do not maintain; 1=Maintain Default is 1 on new record
KPERHIST | i4 | 1 | N | Default from setup | Maintain history—fiscal year: 0=Do not maintain; 1=Maintain Default is 1 on new record
KPTRXHST | i4 | 1 | N | Default from setup | Maintain history—transaction: 0=Do not maintain; 1=Maintain Default is 1 on new record
KGLDSTHS | i4 | 1 | N | Default from setup | Maintain history—distribution: 0=Do not maintain; 1=Maintain Default is 1 on new record
PTCSHACF | i4 | 2 | N | Default from setup | Use cash account from: 0=Checkbook; 1=Vendor Default is zero on new record
PMCSHACTNUMST | string | 75 | N | Default from setup | Cash account; only valid if PTCSHACF=1
PMAPACTNUMST | string | 75 | N | Default from setup | Accounts payable account
PMDAVACTNUMST | string | 75 | N | Default from setup | Terms discount available account
PMDTKACTNUMST | String | 75 | N | Default from setup | Terms discount taken account
PMFINACTNUMST | string | 75 | N | Default from setup | Finance charges account
PMPRCHACTNUMST | string | 75 | N | Default from setup | Purchases account
PMTDSCACTNUMST | string | 75 | N | Default from setup | Trade discount account
PMMSCHACTNUMST | string | 75 | N | Default from setup | Miscellaneous account
PMFRTACTNUMST | string | 75 | N | Default from setup | Freight account
PMTAXACTNUMST | string | 75 | N | Default from setup | Tax account
PMWRTACTNUMST | string | 75 | N | Default from setup | Write-off account
ACPURACTNUMST | string | 75 | N | Default from setup | Accrued purchases account
PURPVACTNUMST | string | 75 | N | Default from setup | Purchase price variance account
UseVendorClass | i4 | 1 | N | 0 | Flag to have class setting roll down to elements that not passed in; uses the VNDCLSID class
CreateAddress | i4 | 1 | N | 1 | Flag to allow a primary address code to be created on the fly: 0=Do not create address code; 1=Create address code
UpdateIfExists | i4 | 1 | N | 1 | Flag to allow vendor data to be updated if it exists: 0=Do not update; 1=Update if exists; 2=Create if record does not exist and exits without error if record does exist
RequesterTrx | i4 | 2 | N | 0 | Requester transaction: 0=False; 1=True (if True, it populates the requester shadow table)
USRDEFND1 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND2 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND3 | string | 50 | N | <blank> | User-defined field—developer use only
USRDEFND4 | string | 8000 | N | <blank> | User-defined field—developer use only
USRDEFND5 | string | 8000 | N | <blank> | User-defined field—developer use only

* The <taUpdateCreateVendorRcd> node uses field level updates to provide update functionality.


Glossary

Application programming interface (API)

Back office

BizTalk adapter

BizTalk server

Business document

Connection string

DCOM

eConnect

eConnect Integration Service

eConnect XML document

Extensible Stylesheet Language (XSL)

Front office

Incoming Service

Microsoft message queuing(MSMQ)

Middleware

Outgoing Service

Post stored procedure

Pre stored procedure

Schema

Serialization Flag

Services

Stored procedure

Transaction Requester

Trigger

Windows Communication Foundation (WCF)

XML


Glossary

Application programming interface (API)

A set of functions or features you access to programmatically use or manipulate a software component or application.

Back office

A financial management system. In an eConnect environment, this refers to Microsoft Dynamics GP.

BizTalk adapter

A preconfigured BizTalk Application Integration Component (AIC) that allows BizTalk server to use eConnect.

BizTalk server

A Microsoft platform that manages the exchange of data between applications.

Business document

A well-formed XML document containing business data. This data may represent a sales order or other business information.

Connection string

A text representation of the initialization properties needed to connect to a data store.

DCOM

A wire protocol that enables software components to communicate directly over a network.

eConnect

A collection of tools, components, and APIs that provide programmatic integration with Microsoft Dynamics GP.

eConnect Integration Service

A Microsoft Windows service that enables applications to send XML documents to the eConnect business objects (SQL stored procedures) Also, enables applications to retrieve specified XML documents from Microsoft Dynamics GP.

eConnect XML document

A text document that describes Microsoft Dynamics GP data. The eConnect XML schema specifies the content and structure of data in the document.

Extensible Stylesheet Language (XSL)

A high-level data manipulation language. XSL is used to manipulate XML documents.

Front office

An application that communicates with the back office. Examples include customer relationship management systems, data warehouses, and web sites.

Incoming Service

A Microsoft Windows service that monitors a queue for new eConnect XML documents. Valid documents are used to create, update, or delete records in Microsoft Dynamics GP.

Microsoft message queuing
(MSMQ)

A message infrastructure and development platform for creating distributed, loosely-coupled messaging applications.

Middleware

Software that mediates between an application program and a network. It manages the interaction among disparate applications across the heterogeneous computing platforms.

Outgoing Service

A Microsoft Windows service that publishes eConnect XML documents to a specified queue. The XML documents represent documents that were created, updated, or deleted in Microsoft Dynamics GP.

Post stored procedure

A customized SQL stored procedure that runs immediately after an eConnect stored procedure.

Pre stored procedure

A customized SQL stored procedure that runs immediately before an eConnect stored procedure.

Schema

An XML file (with typical extension .XSD) that describes the syntax and semantics of XML documents using a standard XML syntax. An XML schema specifies the content constraints and vocabulary that compliant documents must accommodate.

Serialization Flag

A boolean property that specifies whether to use or discard the value assigned to a property of an eConnect serialization class.

Services

Microsoft Windows services are long-running applications that perform some system function. They typically do not display any user interface. eConnect uses several services for moving eConnect XML documents in and out of various message queues.

Stored procedure

A group of Transact-SQL statements compiled into a single execution plan. The business logic for eConnect is contained in stored procedures.

Transaction Requester

The Transaction Requester publishes eConnect XML documents to a queue. The XML documents represent Microsoft Dynamics GP documents.

Trigger

A special class of SQL stored procedure that executes automatically when an update, insert, or delete statement is issued for a table or view.

Windows Communication Foundation (WCF)

A runtime and a set of APIs for creating systems that send messages between services and clients. Used to create applications that communicate with other applications on the same system or a remote system.

XML

A text-based format that uses markup tags (words surrounded by ‘<‘ and ‘>’) to describe how a document is structured and the data it contains.


Copyright notice

Copyright © 2012 Microsoft Corporation All rights reserved

Limitation of liability

This document is provided “as-is”. Information and views expressed in this document, including URL and other Internet Web site references, may change without notice. You bear the risk of using it.

Some examples depicted herein are provided for illustration only and are fictitious. No real association or connection is intended or should be inferred.

Intellectual property

This document does not provide you with any legal rights to any intellectual property in any Microsoft product.

You may copy and use this document for your internal, reference purposes.

Trademarks

Microsoft, Microsoft Dynamics, Visual Basic, Windows, and Windows Server are trademarks of the Microsoft group of companies.

All other trademarks are property of their respective owners.

Warranty disclaimer

Microsoft Corporation disclaims any warranty regarding the sample code contained in this documentation, including the warranties of merchantability and fitness for a particular purpose.

License agreement

Use of this product is covered by a license agreement provided with the software product. If you have any questions, please call the Microsoft Dynamics GP Customer Assistance Department at 800-456-0025 (in the U.S. or Canada) or +1-701-281-6500.

Publication date

December 2012


Microsoft Dynamics® GP 2013 eConnect Programmer’s Guide and Reference

This documentation contains detailed information about the operations, classes, XML schema and nodes available in Microsoft Dynamics GP eConnect. Information is divided into the following sections:

  • What’s New in Microsoft Dynamics GP 2013 eConnect
  • eConnect Programmer’s Guide
  • eConnect .NET Reference
  • XML Schema Reference
  • XML Node Reference

Last updated: November 26, 2012