Installieren von Team Foundation Server und Visual Studio ALM

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Installieren von Team Foundation Server und Visual Studio ALM
Feedback senden

Team Foundation Server mit SQL Server Express

Wenn Sie Team Foundation Server mit geringstmöglichem Vorbereitungsaufwand installieren möchten, verwenden Sie die Basiskonfiguration, die in SQL Server Express enthalten ist. Auf diese Weise übernimmt der Installations-Assistent die gesamte Konfiguration.

Mit der grundlegenden Konfiguration von Team Foundation Server können Sie Fehler, Aufgaben und andere Arbeitsaufgaben nachverfolgen. Sie können Dateien mit der Versionskontrolle überwachen und Team Web Access zum Protokollieren und Beheben von Fehlern verwenden. Sie können jedoch die Berichterstellung oder SharePoint nicht mit der Basiskonfiguration konfigurieren.

Tipp Tipp

Wenn Sie Team Foundation Server unter einem Serverbetriebssystem installieren, können Sie die Berichterstellung oder SharePoint später immer noch hinzufügen. Wenn Sie die Berichterstellung und SharePoint von Anfang an benötigen, verwenden Sie eine der anderen, unten aufgeführten Team Foundation Server-Installationsoptionen.

Schneller Einstieg in Team Foundation Server

Schritt 1 Stellen Sie sicher, dass das Betriebssystem und die Hardware den Anforderungen von Team Foundation Server entspricht. Für Clientbetriebssysteme können Sie die 32-Bit- oder 64-Bit-Version von Windows 7 oder Windows 8 verwenden. Für Server müssen Sie eine 64-Bit-Version verwenden.

Weitere Informationen finden Sie unter: Systemanforderungen für Team Foundation Server.

Schritt 2 Führen Sie das Team Foundation Server-Installationsprogramm ("tfs_server.exe") von der Produkt-DVD aus, und verwenden Sie anschließend den Assistenten für die Basiskonfiguration, um Ihre Installation zu konfigurieren.

Wählen Sie die Standardinstallation

Weitere Informationen finden Sie unter: Ausführen der Team Foundation Server-Installation und Konfigurieren von Team Foundation Server mit der grundlegenden Konfiguration.

Tipp Tipp

Laden Sie die neueste Version des Installationshandbuchs für Team Foundation Server und Visual Studio ALM herunter, um sich über aktuelle Änderungen an diesen Schritten zu informieren.

Verschiedene Methoden für die Installation von Team Foundation Server

Sie können Team Foundation Server auf viele verschiedene Arten installieren. Es handelt sich aber stets um dasselbe Produkt. Verwenden Sie das Szenario, das den Anforderungen des Teams am besten entspricht.

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration

Sie können Team Foundation Server und sämtliche erforderlichen Komponenten auf einem Einzelserver installieren. Der Schwerpunkt dieses Szenarios liegt auf der Neuinstallation der erforderlichen Software. Sie können jedoch auch vorhandene Installationen verwenden, sofern sämtliche Softwarekomponenten auf demselben Computer installiert sind.

Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration

Sie können Team Foundation Server und sämtliche erforderlichen Komponenten auf mehr als einem Server installieren oder eine der Standardoptionen anpassen. Beispielsweise möchten Sie die Berichterstellung, aber kein Projektportal nutzen. Der Schwerpunkt dieses Szenarios liegt auf der Verwendung der vorhandenen Infrastruktur zur Erfüllung der Softwareanforderungen sowie der Verwendung weiterer Serverprodukte, mit denen optimale Integration in Team Foundation Server geleistet wird, z. B. SharePoint Server 2010.

Gewusst wie: Aktualisieren von Team Foundation Server

Sie können eine frühere Version von Team Foundation Server oder die Vorschauausgabe aktualisieren.

Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit)

Sie können einer vorhandenen Team Foundation Server-Bereitstellung einen Anwendungsebenenserver hinzufügen, um die Redundanz der Bereitstellung sicherzustellen oder um einen fehlerhaften Anwendungsebenenserver wiederherzustellen.

Anpassen der ALM-Umgebung mit einer oder mehreren dieser Anwendungen

Fügen Sie einen Buildserver oder Proxy zur ALM-Umgebung hinzu. Integrieren Sie Project Server, oder fügen Sie der Team Foundation Server-Bereitstellung eine Installation von SharePoint-Produkten hinzu.

Gewusst wie: Installieren des Team Foundation Build-Diensts

Der Team Foundation-Builddienst kann Ihnen automatisch helfen, Code zu erstellen und freizugeben.

Gewusst wie: Zwischenspeichern von Versionskontrolldateien auf einer Remotesite

Sie sparen möglicherweise Bandbreite durch die Installation des Team Foundation Server-Proxys ein, der Versionskontrolldateien zwischenspeichert, damit Entwickler, die an Remotespeicherorten arbeiten, dieselben Dateien nicht mehrfach herunterladen müssen.

Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server

Wenn Project Server von Teammitglieder genutzt wird, können Sie Team Foundation Server-Erweiterungen für Project Server verwenden, um Project Server in Team Foundation Server zu integrieren.

Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server

Wenn Sie kein Portal auf demselben Computer wie Team Foundation Server ausführen möchten, können Sie Team Foundation Server-Erweiterungen für SharePoint-Produkte verwenden, um SharePoint-Produkte zu Team Foundation Server hinzuzufügen. Als Neuheit in dieser Version des Produkts können Sie diese Anwendung verwenden, um SharePoint Foundation 2010 zu installieren, oder um der bereits installierten Bereitstellung von Team Foundation Server SharePoint hinzuzufügen.

Bild für Footer
Senden Sie Feedback zu diesem Thema an Microsoft.


Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Siehe auch Feedback senden

Auf einem Einzelserver installieren

Wenn Sie Team Foundation Server auf einem einzelnen Server mit Berichterstellung und einem Teamportal installieren möchten, verwenden Sie die Standardkonfiguration, um die Installation einfacher zu gestalten.

Bei der Standardkonfiguration installieren Sie zunächst SQL Server und den Berichtsserver, aber Team Foundation Server kann SharePoint Foundation 2010 für Sie installieren. Als Neuheit in dieser Version von Team Foundation Server können Sie eine vorhandene Installation von SharePoint-Produkten mit dem Assistenten für die Standardkonfiguration verwenden. Dies ist hilfreich, wenn Sie die Einfachheit der Standardkonfiguration beibehalten möchten, Sie aber eine andere Version von SharePoint-Produkten verwenden möchten als die, die im Lieferumfang von Team Foundation Server enthalten ist. Wenn Sie mehr Kontrolle über die Installationsoptionen haben möchten, verwenden Sie die erweiterte Konfiguration: Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration.

Tipp Tipp

SharePoint Foundation 2010 kann nicht auf Windows Server 2012 installiert werden. Wenn Sie die Standardkonfiguration für Windows Server 2012 verwenden möchten, müssen Sie die Installation von SharePoint Foundation 2010 überspringen.

So installieren Sie Team Foundation Server mit der Standardkonfiguration

Schritt 1 Stellen Sie sicher, dass das Betriebssystem und die Hardware den Anforderungen von Team Foundation Server und allen zugehörigen erforderlichen Komponenten entspricht. Als Neuheit in dieser Version von Team Foundation Server müssen Sie einen 64-Bit-Server verwenden, wenn Sie ein Serverbetriebssystem verwenden. Bestimmen Sie das Dienstkonto, das Sie für Team Foundation Server verwenden.

Weitere Informationen finden Sie unter: Systemanforderungen für Team Foundation Server, Erforderliche Konten für die Installation von Team Foundation Server.

Tipp Tipp

Bei der Standardkonfiguration ist lediglich ein einzelnes Benutzerkonto erforderlich, um Team Foundation Server zu installieren.

Schritt 2 Installieren Sie SQL Server 2008 R2 oder SQL Server 2012. Sie müssen alle diese SQL Server-Funktionen installieren: Datenbankmodul, Volltextsuche (Volltext- und semantische Extraktionen für die Suche in SQL Server 2012), Analysis Services und Reporting Services (Reporting Services - systemeigen in SQL Server 2012).

Nachdem Sie SQL Server installiert haben, konfigurieren Sie den Analysis-Server für den automatischen Failover.

Weitere Informationen finden Sie unter: Manuelle Installation von SQL Server für Team Foundation Server, Konfigurieren von Analysis Services für die Wiederherstellung nach einem Fehler

Schritt 3 Führen Sie das Team Foundation Server-Installationsprogramm von der Produkt-DVD aus, und verwenden Sie anschließend den Assistenten für die Standardkonfiguration, um Ihre Installation zu konfigurieren. Dieser Assistent installiert, konfiguriert und integriert SharePoint Foundation 2010 mit Team Foundation Server. Dort verwenden Sie das einzelne Benutzerkonto, das im Tipp weiter oben erwähnt wurde.

Wählen Sie die TFS-Standardkonfiguration

Weitere Informationen finden Sie unter: Ausführen der Team Foundation Server-Installation, Konfigurieren von Team Foundation Server mit der Standardkonfiguration

Tipp Tipp

Laden Sie die aktuelle Version dieses Handbuchs von der folgenden Seite auf der Microsoft-Website herunter: Installationshandbuch für Team Foundation, alle aktuellen Änderungen an diesem Schritt anzuzeigen.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Installieren des Team Foundation Build-Diensts


Systemanforderungen für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Systemanforderungen für Team Foundation Server
Siehe auch Feedback senden

Bevor Sie Team Foundation Server installieren, müssen Sie sicherstellen, dass das System die in diesem Thema beschriebenen Anforderungen hinsichtlich des Betriebssystems erfüllt. Als Neuheit in dieser Version müssen Sie ein 64-Bit-Serverbetriebssystem zum Installieren von Team Foundation Server verwenden. 32-Bit-Clientbetriebssysteme werden unterstützt, wohingegen 32-Bit-Serverbetriebssysteme nicht mehr unterstützt werden. Team Foundation Server bietet eine Option zum Installieren von SharePoint Foundation 2010 als Begleitprogramm zum Verwalten von Teamdokumenten. Wenn Sie sie nutzen, wirkt sich dies erheblich auf Ihre Hardwareanforderungen aus. Siehe SharePoint Hardware Requirements weiter unten.

Dieses Thema enthält darüber hinaus Hardwareempfehlungen. Hierbei handelt es sich im Unterschied zu den Betriebssysteminformationen nicht um Anforderungen, sondern lediglich um Empfehlungen. Im Allgemeinen gilt Folgendes: Je größer das Team, desto größer der Bedarf an robuster Hardware. Sie benötigen möglicherweise mehrere Server, um die Last zu verteilen.

Betriebssystemanforderungen

Sie können Team Foundation Server auf einem Server installieren, auf dem eines der folgenden Betriebssysteme ausgeführt wird:

Serverbetriebssysteme:

  • 64-Bit-Version von Windows Server 2008 mit SP2

  • 64-Bit-Versionen von Windows Server 2008 R2 ¹ mit SP1

  • 64-Bit-Versionen von Windows Server 2012 ²

Hinweis Hinweis

Die Server Core-Installationsoption von Windows Server 2008, Windows Server 2008 R2 oder Windows Server 2012 wird von Team Foundation Server nicht unterstützt.

Clientbetriebssysteme:

  • 64-Bit- oder 32-Bit-Versionen von Windows 7 mit SP1 (Windows 7 Home Premium mit SP1, Windows 7 Professional mit SP1, Windows 7 Enterprise mit SP1, Windows 7 Ultimate mit SP1)

  • 64-Bit- oder 32-Bit-Versionen von Windows 8

Hinweis Hinweis

Sie können Team Foundation Server auf einem Clientcomputer installieren, auf dem eines der Betriebssysteme in der folgenden Liste ausgeführt wird. Clientbetriebssysteme unterstützen jedoch keine Integration in SharePoint-Produkte oder die Berichtsfunktion. Wenn Sie eine dieser Funktionen verwenden möchten, müssen Sie Team Foundation Server unter einem Serverbetriebssystem installieren.

¹ Wenn Sie Team Foundation Server oder SQL Server unter Windows Server 2008 R2 installieren, muss .NET Framework 3.5 installiert sein. Auf Windows Server 2008 R2 können Sie .NET Framework 3.5 über den Assistenten zum Hinzufügen von Features in Server-Manager installieren. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Hinzufügen von Serverrollen und Features.

² Da der Team Foundation Server den SharePoint Foundation 2010 mit der Standardkonfiguration installiert, können Sie ihn auf Windows Server 2012 nicht verwenden. Wenn Sie Team Foundation Server auf Windows Server 2012 installieren möchten, verwenden Sie die erweiterte Konfiguration, und überspringen Sie die Installation von SharePoint Foundation 2010.

Hardwareempfehlungen

Die folgende Tabelle enthält Hardwarerichtlinien für die Teams, die Team Foundation Server ohne SharePoint-Produkte installieren. Kleine Shops können mit der grundlegenden Konfiguration Team Foundation Server ausführen. Dafür sind lediglich 1 GB RAM sowie 8 GB freier Festplattenspeicher erforderlich.

Anzahl der Benutzer | Konfiguration | CPU | Arbeitsspeicher | Festplatte
Weniger als 250 Benutzer | Einzelserver (Team Foundation Server und das Datenbankmodul auf demselben Server). | 1 Einzelkernprozessor mit 2,13 GHz | 2 GB | 1 Datenträger mit 7.200 U/min (125 GB)
250 bis 500 Benutzer | Bei einem Server: | 1 Doppelkernprozessor mit 2,13 GHz | 4 GB | 1 Datenträger mit 10.000 U/min (300 GB)
500 bis 2.200 Benutzer | Zwei Server (Team Foundation Server und das Datenbankmodul auf unterschiedlichen Servern). Diese Zeile gilt für Team Foundation Server. | 1 Intel Xeon-Doppelkernprozessor mit 2,13 GHz | 4 GB | 1 Datenträger mit 7.200 U/min (500 GB)
 | Diese Zeile gilt für das Datenbankmodul mit 500 bis 2.200 Benutzern. | 1 Intel Xeon-Vierkernprozessor mit 2,33 GHz | 8 GB | SAS-Datenträgerarray mit 10.000 U/min (2 TB)
2.200 bis 3.600 Benutzer | Bei zwei Servern: Diese Zeile gilt für Team Foundation Server. | 1 Intel Xeon-Vierkernprozessor mit 2,13 GHz | 8 GB | 1 Datenträger mit 7.200 U/min (500 GB)
 | Diese Zeile gilt für das Datenbankmodul mit 2.200 bis 3.600 Benutzern. | 2 Intel Xeon-Vierkernprozessoren mit 2,33 GHz | 16 GB | SAS-Datenträgerarray mit 10.000 U/min (3 TB)

SharePoint-Hardwareanforderungen

Wenn Sie SharePoint-Produkte installieren, benötigen Sie robustere als die in der vorherigen Tabelle aufgeführte Hardware. SharePoint Foundation 2010 erfordert beispielsweise eine 64-Bit-CPU mit 4 Kernen sowie mindestens 4 GB Systemspeicher und kann von Team Foundation Server für Sie installiert werden. Wenn Sie nur über 4 GB Arbeitsspeicher verfügen, warnt Sie der Team Foundation Installer, dass Sie über 10 GB verfügen sollten. Der Installationsvorgang kann jedoch abgeschlossen werden.

Die vollständigen SharePoint-Hardwareanforderungen finden Sie unter:

  • Hardware- und Softwareanforderungen (SharePoint Foundation 2010)

  • Bestimmen von Hardware- und Softwareanforderungen (Windows SharePoint Services)

  • Hardware- und Softwareanforderungen (SharePoint Server 2010)

  • Bestimmen der Hardware- und Softwareanforderungen (Office SharePoint Server)

Virtualisierung

Microsoft unterstützt die Virtualisierung von Team Foundation Server in unterstützten Virtualisierungsumgebungen. Weitere Informationen finden Sie auf den folgenden Seiten der Microsoft-Website:

  • Microsoft-Serversoftware und unterstützte Virtualisierungsumgebungen

  • Supportrichtlinie für Microsoft-Software, die nicht auf Microsoft-Hardwarevirtualisierungssoftware ausgeführt wird

  • Supportpartner für Fremdanbieter-Hardwarevirtualisierungssoftware

  • Server Virtualization (offiziell unterstützte Produkte)

Weitere Informationen zu Team Foundation Server-Anforderungen für Begleitprodukte: SQL Server, SharePoint-Produkte und Project Server

SQL Server-Anforderungen für Team Foundation Server

Team Foundation Server erfordert SQL Server. Ihnen stehen jedoch mehrere Optionen zur Verfügung, einschließlich einer Option zum Installieren von SQL Server Express durch Team Foundation Server.

Anforderungen von SharePoint-Produkten für Team Foundation Server

SharePoint-Produkte sind für Team Foundation Server nicht erforderlich. Wenn Sie SharePoint-Produkte verwenden möchten, stehen Ihnen zahlreiche Optionen zur Verfügung, einschließlich der Option, SharePoint Foundation 2010 durch Team Foundation Server installieren zu lassen.

Project Server-Anforderungen für Team Foundation Server

Project Server ist für Team Foundation Server nicht erforderlich, wenn Sie es jedoch verwenden möchten, müssen Sie eine unterstützte Version verwenden.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server
Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server


Sprachanforderungen für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Sprachanforderungen für Team Foundation Server
Siehe auch Feedback senden

Sie können Visual Studio Team Foundation Server unter unterstützten Betriebssystemen in verschiedenen Sprachen installieren. Sie können jedoch nicht jede Kombination von lokalisiertem Betriebssystem und Team Foundation Server zusammen verwenden. Die Sprache der Installation von SharePoint-Produkte kann auch die Bereitstellung komplizieren. Sie können jedoch dem Server, auf dem SharePoint-Produkte ausgeführt werden, zur Erfüllung der Anforderungen für Team Foundation Server ein entsprechendes Language Pack hinzufügen.

In der folgenden Tabelle sind die verschiedenen unterstützten Sprachkombinationen aufgeführt:

Betriebssystem | Team Foundation Server | SharePoint-Produkte
Englisch | Englisch | Englisch
Englisch | Andere Sprache außer Englisch | Sprache (oder Language Pack) muss mit Team Foundation Server übereinstimmen
Andere Sprache außer Englisch | Englisch | Englisch (oder hinzugefügtes Language Pack für Englisch)
Andere Sprache außer Englisch | Sprache muss mit Betriebssystem übereinstimmen | Sprache (oder hinzugefügtes Language Pack) muss mit Team Foundation Server übereinstimmen

In den folgenden Regeln werden die Sprachanforderungen für Installationen von Team Foundation Server erläutert.

  • Wenn Sie das Betriebssystem auf Englisch ausführen, können Sie eine beliebige Sprachversion von Team Foundation Server installieren. Wenn Sie das Betriebssystem nicht auf Englisch ausführen, müssen Sie die englische Version von Team Foundation Server oder die in der Sprache des Betriebssystems lokalisierte Version von Team Foundation Server installieren.

  • Wenn Sie SharePoint-Produkte verwenden möchten, müssen diese mit der Sprache der Installation von Team Foundation Server übereinstimmen, oder Sie müssen das Language Pack installieren, das der Sprache der Installation von Team Foundation Server entspricht.

Sie können z. B. die japanische Version von Team Foundation Server unter einem englischen oder japanischen Betriebssystem installieren, aber nicht unter einem deutschen Betriebssystem. Wenn Sie die japanische Version von Team Foundation Server installieren, muss auch entweder die japanische Version von SharePoint-Produkte oder das japanische Language Pack für SharePoint-Produkte auf dem Server vorhanden sein, auf dem SharePoint-Produkte ausgeführt werden.

Für die folgenden Komponenten bestehen keine besonderen zusätzlichen Sprachanforderungen für die Verwendung von Team Foundation Server:

  • Team Foundation-Builddienst

  • Team Foundation Server Proxy

  • Team Explorer

  • Visual Studio Lab Management

Für Testcontroller und Agents bestehen eigene Sprachanforderungen. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Test Controller and Test Agent Requirements (auf Englisch).

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Aktualisieren von Team Foundation Server


Team Foundation Server-Anforderungen für Active Directory

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Team Foundation Server-Anforderungen für Active Directory
Siehe auch Feedback senden

Sie können Visual Studio Team Foundation Server auf mehr als einem Server installieren, wenn alle Instanzen Teil einer Active Directory-Domäne sind, die auf einer Funktionsebene basiert, die von Team Foundation Server unterstützt wird. Sie können Team Foundation Server auf einem einzelnen Server installieren, der Teil einer Active Directory-Domäne oder Mitglied einer Arbeitsgruppe ist.

Sie können Team Foundation Server nicht auf Servern installieren, die Teil einer Domäne sind, deren Domänencontroller Windows NT Server 4.0 ausführen. In der folgenden Tabelle werden die Funktionsebenen für Active Directory-Domänen aufgeführt, die von Team Foundation Server unterstützt werden.

Funktionsebenen für Active Directory-Domänen | Unterstützt
Windows 2000 im gemischten Modus Domänencontroller, auf denen Windows NT Server 4.0, Windows 2000, Windows Server 2003 und Windows Server 2003 R2 ausgeführt wird. | Nein
Windows 2000 im einheitlichen Modus Domänencontroller, auf denen Windows 2000, Windows Server 2003, Windows Server 2003 R2 oder Windows Server 2008 ausgeführt wird. | Ja
Windows Server 2003 im Zwischenmodus Domänencontroller, auf denen Windows NT Server 4.0, Windows Server 2003 und Windows Server 2003 R2 ausgeführt wird. | Nein
Windows Server 2003-Modus Domänencontroller, auf denen Windows Server 2003, Windows Server 2003 R2 oder Windows Server 2008 ausgeführt wird. | Ja
Windows Server 2008-Modus Domänencontroller, auf denen Windows Server 2008 ausgeführt wird. | Ja

Siehe auch

Konzepte

Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server
Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server


Ausführen der Team Foundation Server-Installation

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Ausführen der Team Foundation Server-Installation
Siehe auch Feedback senden

Führen Sie folgende Schritte aus, um das Team Foundation Server-Installationsprogramm auszuführen. Mit diesem Prozess kopieren Sie Team Foundation Server in das Dateisystem und konfigurieren die Funktionen so, dass diese dem Betriebssystem und der Bereitstellung entsprechen.

Für Remotebereitstellungen der SharePoint-Produkte können Sie eine spezielle Version des Installationsprogramms verwenden. Hierdurch werden nur die Team Foundation Server-Erweiterungen auf dem SharePoint-Produkte-Server installiert. Dadurch funktioniert der Server mit den SharePoint-Produkten fehlerfrei. Sie müssen dieses spezielle Installationsprogramm nicht auf dem Server ausführen, auf dem Team Foundation Server läuft und bei dem die Erweiterungen standardmäßig mit den meisten Installationen von Team Foundation Server installiert werden.

Tipp Tipp

Wenn Sie über ein Remoteportal für die SharePoint-Produkte verfügen, müssen Sie Team Foundation Server-Erweiterungen für SharePoint-Produkte auf dem Remoteportal installieren. Wenn SharePoint-Produkte auf mehreren Servern in einer Webfarm ausgeführt werden, müssen diese Erweiterungen auf jedem Server in dieser Farm installiert und konfiguriert werden.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren sein.

So führen Sie das Team Foundation Server-Installationsprogramm aus

  1. Legen Sie die Team Foundation Server-DVD ins Laufwerk ein, und starten Sie die Datei "tfs_server.exe", um die Installation zu starten.

    Tipp Tipp

    Wenn Sie nicht alle Komponenten von Team Foundation Server auf dem Server installieren möchten, auf dem SharePoint-Produkte ausgeführt wird, starten Sie im Ordner "SharePoint-Erweiterungen" die Datei tfs_sharePointExtensions.exe, um nur die Team Foundation Server-Erweiterungen für SharePoint-Produkte zu installieren.

  2. Akzeptieren Sie im Dialogfeld mit den Lizenzbedingungen die Lizenzbedingungen, und wählen Sie dann Jetzt installieren aus. Wenn Sie Team Foundation Server an einem bestimmten Speicherort im Dateisystem installieren möchten, wählen Sie die Schaltfläche zum Durchsuchen (...) neben dem Standard-Installationsspeicherort aus.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server


Konfigurieren von Team Foundation Server mit der grundlegenden Konfiguration

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Team Foundation Server mit der grundlegenden Konfiguration
Siehe auch Feedback senden

Sie können Team Foundation Server so konfigurieren, dass die grundlegende Konfiguration verwendet wird, damit Sie SQL Server Express nutzen können.

Tipp Tipp

Sie können über das Menü Start auf das Team Foundation Server-Konfigurationstool zugreifen, indem Sie die Team Foundation Server-Verwaltungskonsole starten und dann Anwendungsebene und Installierte Funktionen konfigurieren auswählen.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Team Foundation Server ausgeführt wird.

So konfigurieren Sie Team Foundation Server mit der grundlegenden Konfiguration

  1. Wählen Sie im Team Foundation Server-Konfigurationstool die Optionen Standard und Assistent starten aus.

    Der Assistent für die Basiskonfiguration wird angezeigt.

  2. Lesen Sie die Willkommensseite, und wählen Sie dann Weiter aus.

  3. Führen Sie eine der folgenden Aktionen aus:

    • Wählen Sie SQL Server Express installieren, um die Konfigurationsdatenbank in einer Instanz von SQL Server Express zu hosten, und wählen Sie anschließend Weiter.

    • Wählen Sie Vorhandene SQL Server-Instanz verwenden, um die Konfigurationsdatenbank in einer vorhandenen Instanz von SQL Server zu hosten, und wählen Sie Weiter. Geben Sie dann unter SQL Server-Instanz den Namen des Servers, der SQL Server ausführt, oder die benannte Instanz ein, von dem bzw. von der die Konfigurationsdatenbanken gehostet werden sollen, und wählen Sie Weiter. Wählen Sie Test aus, um die Verbindung mit SQL Server zu testen.

  4. Überprüfen Sie die Informationen, und wählen Sie dann Weiter aus.

    Die Konfiguration wird überprüft.

  5. Wählen Sie Konfigurieren aus.

    Die Konfigurationseinstellungen werden angewendet.

  6. Wählen Sie Weiter aus.

  7. Wählen Sie Schließen aus.

  8. Wählen Sie Schließen aus.

    Die Team Foundation Server-Verwaltungskonsole wird angezeigt.

Siehe auch

Konzepte

Installieren von Team Foundation Server und Visual Studio ALM


Konfigurieren von Team Foundation Server mit der Standardkonfiguration

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Team Foundation Server mit der Standardkonfiguration
Siehe auch Feedback senden

Sie können Team Foundation Server für die Verwendung der Standardkonfiguration konfigurieren. Zum Abschließen dieser Prozedur müssen Sie über ein Domänenkonto verfügen, das Sie als Dienstkonto für SharePoint Foundation 2010 (WSSSERVICE) verwenden.

Weitere Informationen zu Konten finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

Tipp Tipp

Sie können über das Menü Start auf das Team Foundation Server-Konfigurationstool zugreifen, indem Sie die Team Foundation Server-Verwaltungskonsole starten und dann Anwendungsebene und Installierte Funktionen konfigurieren auswählen.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Team Foundation Server ausgeführt wird.

So konfigurieren Sie Team Foundation Server mit der Standardkonfiguration

  1. Wählen Sie Standardeinzelserver und dann Assistent starten.

    Der Assistent Team Foundation Server-Standardkonfiguration wird angezeigt.

  2. Lesen Sie die Willkommensseite, und wählen Sie dann Weiter aus.

  3. Geben Sie in Benutzerkonto den Namen des Dienstkontos ein, das Sie für SharePoint Foundation 2010 verwenden möchten (WSSSERVICE).

    Dieses Konto wird auch als Berichtsleserkonto zum Erstellen von Berichten (TFSREPORTS) verwendet.

  4. Geben Sie in Kennwort das Kennwort für dieses Dienstkonto ein, und klicken Sie dann auf Weiter.

  5. Wählen Sie SharePoint Foundation 2010 installieren aus.

  6. Nachdem über den Team Foundation Server SharePoint Foundation 2010 installiert wurde, wählen Sie Weiter.

  7. Überprüfen Sie die Informationen, und wählen Sie dann Weiter aus.

    Die Konfiguration wird überprüft.

  8. Wählen Sie Konfigurieren aus.

    Die Konfigurationseinstellungen werden angewendet.

  9. Wählen Sie Weiter aus.

  10. Wählen Sie Schließen aus.

  11. Wählen Sie Schließen aus.

    Die Team Foundation Server-Verwaltungskonsole wird angezeigt.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration


Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Siehe auch Feedback senden

Installieren von Team Foundation Server mit vorhandener Infrastruktur auf mehreren Servern

Auf mehr als einem Server installieren

Wenn Sie die Standardinstallationsoptionen für Team Foundation Server ändern möchten, verwenden Sie die erweiterte Konfiguration, über die Sie Team Foundation Server auf mehreren Servern konfigurieren und viele weitere Optionen ändern können.

Warum sollten erweitere Funktionen zum Einsatz kommen? Die Standardinstallation entspricht eventuell nicht Ihren Anforderungen. Möglicherweise möchten Sie einen benutzerdefinierten Port in einer Einzelserverinstallation verwenden, oder Team Foundation Server und die Konfigurationsdatenbank auf verschiedenen Servern installieren. Möglicherweise werden in Ihrer Organisation bereits SQL Server- oder SharePoint-Produkte ausgeführt, und Sie möchten möglicherweise eine dieser Installationen verwenden, um Teamprojekte oder Daten für Team Foundation Server zu hosten. Wenn Sie die optionalen Funktionen verwenden, die erforderliche Serversoftware voraussetzen, können diese Installationen ebenfalls auf unterschiedlichen Servern gehostet werden. Wenn Sie mehrere Server verwenden, können Sie die Last zwischen Team Foundation Server und der Konfigurationsdatenbank verteilen oder sicherstellen, dass erforderliche Serversoftware für Funktionen wie Berichterstellung oder die Portalwebsite auf geeigneter Hardware ausgeführt wird.

Verwechseln Sie die Mehrserverinstallation nicht mit den stabilen Funktionen für horizontales Skalieren, die Team Foundation Server bietet. Mit diesen Skalierungsfunktionen kann eine Team Foundation Server-Farm erstellt und eine Teamprojektauflistung einer Instanz von SQL Server hinzugefügt werden, die nicht Bestandteil der ursprünglichen Bereitstellung von Team Foundation Server war. Diese Skalierungsfunktionen werden in diesem Szenario jedoch nicht behandelt. Dieses Szenario bietet Ihnen eine Anleitung für die Erstbereitstellung von Team Foundation Server mit konfigurierbaren Installationsoptionen, z. B. das Installieren von TFS auf mehreren Servern. Weitere Informationen zum Hinzufügen eines Anwendungsebenenservers zu einer Bereitstellung von Team Foundation Server finden Sie unter Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit).

Tipp Tipp

Eine Mehrserverinstallation erfordert eine Active Directory-Domäne und Domänenkonten oder das Netzwerkdienstkonto. Sie können keine lokalen Konten als Dienstkonten verwenden.

So installieren Sie Team Foundation Server mit der erweiterten Konfiguration

Die Aufgaben in der folgenden Tabelle helfen Ihnen, die Betriebssysteme und die Netzwerkumgebung für eine Team Foundation Server-Installation auf mehreren Servern vorzubereiten.

Aufgabe

Ausführliche Anweisungen

Schritt 1

Überprüfen Sie die unterstützte Hard- und Software. Stellen Sie sicher, dass das Betriebssystem auf jedem Server, auf dem Sie eine Team Foundation Server-Komponente installieren, die Team Foundation Server-Anforderungen erfüllt. Vergewissern Sie sich, dass die Hardwareleistung ausreichend ist, um Team Foundation Server und alle erforderliche Serversoftware auszuführen. Überprüfen Sie die Sprachanforderungen für Team Foundation Server.

Um Team Foundation Server auf mehreren Servern zu verwenden, muss eine Active Directory-Domäne verfügbar sein, die die Anforderungen für Team Foundation Server erfüllt.

Überprüfen Sie die erforderlichen Berechtigungen und Benutzerkonten. Überprüfen Sie, dass das Konto, mit dem Sie Team Foundation Server installieren, ein Mitglied der Sicherheitsgruppe Administratoren auf den Servern ist, auf denen Sie Team Foundation Server installieren. Wenn Sie planen, die Berichterstellung zu konfigurieren, müssen Sie auch ein Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, der SQL Server Reporting Services ausführt. Wenn Sie SharePoint-Produkte konfigurieren möchten, müssen Sie Mitglied der Gruppe Farmadministratoren auf der SharePoint-Zentraladministrationswebsite sein.

Legen Sie die Dienstkonten fest, die Sie zum Installieren von Team Foundation Server, SQL Server und SharePoint-Produkte verwenden werden.

  • Systemanforderungen für Team Foundation Server

  • Sprachanforderungen für Team Foundation Server

  • Erforderliche Konten für die Installation von Team Foundation Server

  • Team Foundation Server-Anforderungen für Active Directory

  • Erforderliche Ports für die Installation von Team Foundation Server

Schritt 2

Richten Sie SQL Server ein. Überprüfen Sie die Sortierungsanforderungen von Team Foundation Server. Bestimmen Sie die Sortiereinstellungen, die in Ihrer Organisation für Daten beachtet werden müssen, und stellen Sie sicher, dass diese Einstellungen den Anforderungen von Team Foundation Server entsprechen. Wenn diese Einstellungen nicht auf allen SQL Server-Instanzen gleich sind, die Team Foundation Server hinzugefügt werden, kann dies zu unerwarteten Ergebnissen führen.

Installieren Sie entweder SQL Server auf dem Server, auf dem das Datenbankmodul und die Volltextsuche gehostet werden, oder stellen Sie sicher, dass eine vorhandene Installation die Anforderungen von Team Foundation Server erfüllt. Standardmäßig erstellt Team Foundation Server während der Installation die erforderlichen Datenbanken. Sie können jedoch auch leere Datenbanken unter Beachtung der entsprechenden Namenskonventionen bereitstellen. Das Bereitstellen leerer Datenbanken ist optional.

(Optional) Richten Sie die Berichterstellung ein. Wenn Sie die Berichterstellung verwenden möchten, müssen Sie entweder SQL Server Reporting Services und SQL Server Analysis Services installieren oder überprüfen, ob eine vorhandene Installation die Team Foundation Server-Anforderungen erfüllt. Sie müssen für den Berichtsserver nicht die gleiche SQL Server-Instanz wie für das Datenbankmodul verwenden. Sie können den Berichtsserver sogar auf mehreren Servern hosten. Der Berichtsserver kann jedoch nicht für andere Anwendungen verwendet werden. Team Foundation Server verlangt einen dedizierten Berichtsserver. Wenn sich der Berichtsserver nicht auf demselben Server wie Team Foundation Server befindet, müssen Sie der Gruppe Inhalts-Manager auf dem Berichtsserver das Dienstkonto für Team Foundation Server hinzufügen.

Überprüfen Sie SQL Server. Überprüfen Sie, ob alle Instanzen von SQL Server so konfiguriert wurden, dass sie die Mindestanforderungen von Team Foundation Server erfüllen.

  • SQL Server-Anforderungen für Team Foundation Server

  • Manuelle Installation von SQL Server für Team Foundation Server

  • Hinzufügen des Dienstkontos von Team Foundation Server zum Berichtsserver

  • Überprüfen von SQL Server für Team Foundation Server

  • SQL Server-Sortierungsanforderungen für Team Foundation Server

  • Bereitstellen von SQL Server-Datenbanken für Team Foundation Server

Schritt 3

(Optional) Installieren und konfigurieren Sie Microsoft Office SharePoint 2007 oder SharePoint Server 2010 auf Anwendungsebene (dargestellt).

Wenn Sie die SharePoint-Produkte verwenden möchten, die mit Team Foundation Server installiert werden, fahren Sie mit der Installation von Team Foundation Server fort. Andernfalls haben Sie folgende Möglichkeiten:

  • Installieren Sie unterstützten Versionen von SharePoint-Produkten auf Anwendungsebene, bevor Sie Team Foundation Server installieren. Dies ist hilfreich, wenn Sie nicht die mit Team Foundation Server bereitgestellte SharePoint-Version verwenden möchten. Wenn Sie Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 verwenden, müssen Sie die erforderlichen Konfigurationsschritte für die Dashboardkompatibilität vor der Installation von Team Foundation Server ausführen.

  • Installieren Sie Team Foundation Server auf einem Server, der eine unterstützte Installation von SharePoint-Produkten hostet. Dies ist hilfreich, wenn Sie bereits über eine SharePoint-Installation verfügen und Team Foundation Server auf derselben Hardware installieren möchten. Denken Sie daran, die SharePoint-Konfiguration zu überprüfen, bevor Sie Team Foundation Server installieren.

  • Installieren Sie Team Foundation Server-Erweiterungen für SharePoint-Produkte auf einer Remoteinstallation von SharePoint-Produkten. Dies ist hilfreich, wenn Sie SharePoint auf anderer Hardware ausführen als der, auf der Sie Team Foundation Server installieren möchten. Denken Sie daran, die Team Foundation Server-Erweiterungen für SharePoint zu installieren und alle erforderlichen Konfigurationen für Dashboards vorzunehmen, bevor Sie Team Foundation Server installieren.

  • Manuelle Installation von SharePoint-Produkten für Team Foundation Server auf Windows Server

  • Konfigurieren der Enterprise Editionen von SharePoint Server 2010 oder Office SharePoint Server 2007 für eine Dashboardkompatibilität

  • Überprüfen von SharePoint-Produkten für Team Foundation Server

  • Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server

Schritt 4

Richten Sie Team Foundation Server ein. Installieren Sie Team Foundation Server, und verwenden Sie dann das Team Foundation Server-Konfigurationstool zum Konfigurieren der Bereitstellung.

Abschließende Konfiguration von Microsoft Office SharePoint 2007 oder SharePoint Server 2010.

Wenn Sie Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 installiert haben, müssen Sie die für Team Foundation Server erstellte Unternehmensanwendungsdefinition konfigurieren. Wenn Sie Windows SharePoint Services 3.0 verwenden oder die Installation von SharePoint-Produkte übersprungen haben, können Sie diesen Schritt überspringen.

  • Ausführen der Team Foundation Server-Installation

  • Konfigurieren von Team Foundation Server mit der erweiterten Konfiguration

  • Konfigurieren der Unternehmensanwendungsdefinition für Team Foundation Server

Tipp Tipp

Laden Sie die aktuelle Version dieses Handbuchs von der folgenden Seite auf der Microsoft-Website herunter: Installationshandbuch für Team Foundation, alle aktuellen Änderungen an diesem Schritt anzuzeigen.

Siehe auch

Konzepte

Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit)
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server
Anforderungen von SharePoint-Produkten für Team Foundation Server


Konfigurieren von Team Foundation Server mit der erweiterten Konfiguration

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Team Foundation Server mit der erweiterten Konfiguration
Siehe auch Feedback senden

Sie können Team Foundation Server mit der erweiterten Konfiguration einrichten, die es Ihnen ermöglicht, die meisten Einstellungen anzupassen. Obwohl Sie bei Verwendung eines Clients diese Konfiguration auf einem Client- oder Serverbetriebssystem ausführen können, können Sie kein Portal und keine Berichterstellung zur Bereitstellung hinzufügen.

Um diese Schritte auf einem Clientbetriebssystem ausführen zu können, benötigen Sie keine Domänenkonten. Auf einem Server muss mindestens ein Domänenkonto zur Verfügung stehen, das für alle folgenden Identitäten verwendet werden kann:

  • Das Dienstkonto für Team Foundation Server (TFSSERVICE).

  • Das Berichtsleserkonto für das Erstellen von Berichten (TFSREPORTS).

  • Das Dienstkonto für neue Installationen von SharePoint Foundation 2010 (WSSSERVICE).

Weitere Informationen zu Konten finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

Tipp Tipp

Sie können über das Menü Start auf das Team Foundation Server-Konfigurationstool zugreifen, indem Sie die Team Foundation Server-Verwaltungskonsole starten und dann Anwendungsebene und Installierte Funktionen konfigurieren auswählen.

Erforderliche Berechtigungen

Zum Ausführen dieser Schritte müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Sie Team Foundation Server installieren möchten. Wenn Sie die Berichterstellung konfigurieren möchten, müssen Sie außerdem Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem SQL Server Reporting Services ausgeführt wird. Wenn Sie SharePoint-Produkte konfigurieren möchten, müssen Sie Mitglied der Gruppe Farmadministratoren auf der SharePoint-Produkte-Verwaltungswebsite sein. Wenn Sie das Datenbankmodul, in dem die Konfigurationsdatenbank gehostet wird, nicht installiert haben oder die verwendete Instanz von SQL Server von einem Datenbankadministrator verwaltet wird, müssen Sie Mitglied der sysadmin-Serverrolle in sein, um diese Prozedur ausführen zu können.

Tipp Tipp

Wenn Sie oder der Datenbankadministrator die erforderlichen SQL Server-Berechtigungen besser verstehen möchten, finden Sie weitere Informationen auf der folgenden Seite der Microsoft-Website: Für die Konfiguration von TFS erforderliche Datenbankberechtigungen.

So konfigurieren Sie Team Foundation Server mit der erweiterten Konfiguration

  1. Klicken Sie im Tool Team Foundation Server-Konfiguration auf Erweitert und dann auf Assistent starten.

    Der Assistent für die Erweiterte Konfiguration wird angezeigt.

  2. Lesen Sie die Willkommensseite, und wählen Sie dann Weiter aus.

  3. Geben Sie unter SQL Server-Instanz den Namen des Servers, der SQL Server ausführt, oder die benannte Instanz ein, von dem bzw. von der die Konfigurationsdatenbanken gehostet werden sollen, und wählen Sie Weiter.

    Zusätzlich können Sie die folgenden optionalen Schritte ausführen:

    • Geben Sie unter Datenbankbezeichnung eine Bezeichnung ein, die dann in allen drei Namen der Standarddatenbank eingebettet wird.

      Auf diese Weise können Sie auf einer einzigen Instanz von SQL Server mehrere Konfigurationsdatenbanken hosten.

    • Aktivieren Sie das Kontrollkästchen Bereits vorhandene leere Datenbank(en) verwenden, und geben Sie dann Datenbanken an, die auf dem Server gehostet werden, der unter SQL Server-Instanz benannt ist.

      Die Namen für diese Datenbanken müssen der Standardnamensstruktur folgen (mit oder ohne Bezeichnung). Die Standardnamensstruktur wird unter Team Foundation Server-Datenbanken beschrieben.

    • Wählen Sie Test aus, um die Verbindung mit SQL Server zu testen.

  4. Klicken Sie unter Dienstkonto auf Systemkonto verwenden, um ein integriertes Konto zu verwenden, oder klicken Sie auf Benutzerkonto verwenden, um ein Domänenkonto oder ein lokales Konto zu verwenden. Wenn Sie ein Benutzerkonto verwenden, müssen Sie das Kennwort eingeben. Sie können optional Test wählen, um die Kombination aus Benutzerkonto und Kennwort zu testen.

    Als Standardwert für dieses Dienstkonto (TFSSERVICE) wird ein integriertes Konto verwendet.

  5. Klicken Sie unter Authentifizierungsmethode auf NTLM oder auf Aushandlung (Kerberos) und dann auf Weiter.

    • Wenn Sie NTLM auswählen, wird die NTLM-Authentifizierung verwendet. Diese Option ist die Standardeinstellung.

    • Wenn Sie Aushandlung (Kerberos) auswählen, wird zuerst versucht, die Kerberos-Authentifizierung auszuführen. Wenn dieser Versuch fehlschlägt, wird die NTLM-Authentifizierung verwendet.

  6. Geben Sie unter Website einen Namen in Name der Website und ein Portnummer in Port ein. Dabei handelt es sich um den Namen, der in Internetinformationsdienste (IIS) angezeigt wird, und um die Portnummer, mit der die Verbindung mit Team Foundation Server hergestellt wird.

    Die Standardwerte für Website sind Team Foundation Server und 8080.

  7. Unter Virtuelles IIS-Verzeichnis können Sie den Standardwert tfs übernehmen. Sie können jedoch auch optional den Namen eines virtuellen Verzeichnisses eingeben.

  8. Beachten Sie unter Website die URL der Team Foundation Server-Website. Diese wird entsprechend Ihren Eingaben in Website und Virtuelles IIS-Verzeichnis automatisch erstellt. Clients stellen mithilfe dieser URL eine Verbindung mit Team Foundation Server her. Wählen Sie Weiter aus.

    Unter einem Clientbetriebssystem müssen Sie mit Schritt 11 fortfahren. Bei einem Clientbetriebssystem können Sie weder ein Portal noch die Berichterstellung (Schritt 9 und Schritt 10) hinzufügen.

  9. Verwenden Sie die Seite Konfigurieren Sie die Berichterstellung für Team Foundation Server, um festzulegen, ob die Berichterstellung verwendet werden soll. Aktivieren Sie das Kontrollkästchen Berichterstellung für die Verwendung mit Team Foundation Server konfigurieren, wenn die Berichterstellung verwendet werden soll, oder deaktivieren Sie das Kontrollkästchen, wenn keine Berichterstellung verwendet werden soll. Wählen Sie dann Weiter aus.

    1. Geben Sie in Reporting Services-Instanz den Namen des Servers ein, auf dem SQL Server Reporting Services ausgeführt wird, und klicken Sie auf URLs eingeben.

      Die URLs für den Berichtsserver und dessen Verwaltungswebsite werden in den Dropdownlisten für URL des Berichtsservers und URL des Berichts-Managers angezeigt.

    2. Stellen Sie sicher, dass die angezeigten Werte die URLs sind, die Sie für Team Foundation Server verwenden möchten, und wählen Sie Weiter.

    3. Geben Sie in SQL Analysis Services-Instanz den Namen des Servers ein, auf dem SQL Server Analysis Services ausgeführt wird, und wählen Sie anschließend Weiter.

      Um die Verbindung mit SQL Server zu testen, können Sie optional Test auswählen.

    4. Geben Sie den Namen und das Kennwort des Berichtsleserkontos (TFSREPORTS) ein, und wählen Sie Weiter aus.

      Wenn Sie in Schritt 4 ein Benutzerkonto als Dienstkonto von Team Foundation Server angegeben haben, müssen Sie das Kontrollkästchen Für das Berichtsleserkonto ein anderes Konto als das Team Foundation Server-Dienstkonto verwenden aktivieren, um ein anderes Konto zu verwenden.

      Sie können optional Test wählen, um die Kombination aus Benutzerkonto und Kennwort zu testen.

  10. Geben Sie auf der Seite Konfigurieren Sie SharePoint für Team Foundation Server an, ob Sie SharePoint-Produkte verwenden möchten oder nicht. Aktivieren Sie das Kontrollkästchen SharePoint-Produkte für die Verwendung mit Team Foundation Server konfigurieren, um SharePoint-Produkte zu verwenden, oder deaktivieren Sie das Kontrollkästchen, um SharePoint-Produkte zu überspringen. Wählen Sie Weiter aus.

    Wenn Sie das Kontrollkästchen zum Konfigurieren von SharePoint-Produkte aktiviert haben, führen Sie eine der folgenden Vorgehensweisen aus:

    • Installieren und konfigurieren Sie SharePoint auf diesem Computer.

      1. Wählen Sie SharePoint auf diesem Computer installieren und konfigurieren aus, und klicken Sie auf Weiter.

      2. Klicken Sie auf die große Schaltfläche SharePoint Foundation 2010 installieren. Wählen Sie Weiter aus, wenn die Installation abgeschlossen ist.

      3. Geben Sie ein Benutzerkonto und das Kennwort für das Dienstkonto von SharePoint Foundation 2010 (WSSSERVICE) ein. Wenn Sie in Schritt 4 ein Benutzerkonto als Dienstkonto von Team Foundation Server angegeben haben, müssen Sie das Kontrollkästchen Verwenden Sie für die SharePoint-Farm ein anderes Konto als das Dienstkonto von Team Foundation Server aktivieren, um ein anderes Konto zu verwenden.

      4. Wählen Sie Weiter aus.

    • Integrieren Sie es in einer Remote-SharePoint-Farm.

      1. Wählen Sie In eine SharePoint-Remotefarm integrieren aus, und klicken Sie auf Weiter.

      2. Geben Sie unter Website-URL die URL für die SharePoint-Webanwendung ein.

      3. Geben Sie unter Verwaltungs-URL die URL der Website für die SharePoint-Zentraladministration ein. Wählen Sie Test, um die Konnektivität der einzelnen URLs zu testen.

      4. Wählen Sie Weiter aus.

  11. Aktivieren Sie das Kontrollkästchen Neue Teamprojektsammlung erstellen, um eine Sammlung zu erstellen, oder deaktivieren Sie das Kontrollkästchen, um diesen Schritt zu überspringen.

    Wenn Sie eine Sammlung erstellen, können Sie die Standardwerte übernehmen oder einen neuen Namen und eine Beschreibung eingeben. Wählen Sie Weiter aus.

  12. Überprüfen Sie auf der Seite Überprüfen die Einstellungen, und wählen Sie Weiter aus.

    Die Konfiguration wird überprüft.

  13. Wählen Sie Konfigurieren aus.

    Die Konfigurationseinstellungen werden angewendet. Dieser Prozess kann mehrere Minuten in Anspruch nehmen.

  14. Wählen Sie Weiter aus.

  15. Wählen Sie Schließen aus.

  16. Wählen Sie Schließen aus.

    Die Team Foundation Server-Verwaltungskonsole wird angezeigt.

Siehe auch

Konzepte

Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server
Gewusst wie: Installieren des Team Foundation Build-Diensts


Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit)

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit)
Feedback senden

Team Foundation Server hinzufügen

Die folgenden Gründe können Anlass für das Hinzufügen eines Anwendungsebenenservers zu einer vorhandenen Bereitstellung von Team Foundation Server sein:

  • Sie möchten eine Redundanz in der Bereitstellung von Team Foundation Server realisieren.

  • Sie möchten, dass die Bereitstellung von Team Foundation Server schneller ausgeführt wird.

  • Sie möchten einen fehlerhaften Anwendungsebenenserver wiederherstellen.

  • Sie möchten eine Anwendungsebene auf einen anderen Server verschieben.

Redundanz und Leistung

Mit dem Assistenten für die nur für die Anwendungsebene geltende Konfiguration können Sie nun auch die Verfügbarkeit, Skalierbarkeit und Leistung der Anwendungsebene verbessern.

Um von mehreren Anwendungsebenenservern zu profitieren, sollten Sie sicherstellen, dass die anfängliche Bereitstellung von Team Foundation Server die folgenden Eigenschaften erfüllt:

  • Die Anwendungsebene und die Konfigurationsdatenbank sind auf separaten Servern installiert.

  • Sie haben ein Domänenkonto für das Team Foundation Server-Dienstkonto (TFSSERVICE) verwendet.

  • Netzwerklastenausgleich (NLB) wird bereitgestellt.

Sie verwenden NLB, um einen Cluster von Webservern zu erstellen, die als einzelner logischer Webdienst angezeigt werden. Diese Vorgehensweise ist vom Assistenten für die nur für die Anwendungsebene geltende Konfiguration getrennt. Weitere Informationen zum Einrichten von NLB finden Sie auf der folgenden Seite auf der Microsoft-Website: Netzwerklastenausgleich.

Wenn Sie einen NLB-Cluster erstellen, müssen Sie für die Konfigurationsdatenbank oder für Teamprojektsammlungen keinen SQL Server-Cluster verwenden. SQL Server-Cluster, die Sie zur Steigerung der Leistung, Skalierbarkeit und Verfügbarkeit bereitstellen, sind unabhängig vom NLB-Cluster.

Notfallwiederherstellung und Hardwareupgrade

Wenn Sie eine Sicherungskopie der Konfigurationsdatenbank erstellt haben und auf der Anwendungsebene ein Hardwarefehler auftritt, können Sie die Anwendungsebene mithilfe des Assistenten für die nur für die Anwendungsebene geltende Konfiguration wiederherstellen.

Sie können die Anwendungsebene auch mit dem Assistenten für die nur für die Anwendungsebene geltende Konfiguration verschieben. Obwohl keine bestimmte Architektur erforderlich ist, um eine Anwendungsebene zu verschieben, müssen Sie Zugriff auf die Konfigurationsdatenbank für die Bereitstellung haben.

So erstellen Sie eine Team Foundation Server-Farm

Führen Sie die Schritte aus dieser Prüfliste aus, um einer vorhandenen Team Foundation Server-Bereitstellung eine Anwendungsebene hinzuzufügen.

Aufgabe

Ausführliche Anweisungen

Schritt 1

Überprüfen Sie die unterstützte Hard- und Software. Stellen Sie sicher, dass das Betriebssystem und die Hardware den Anforderungen von Team Foundation Server entspricht.

  • Systemanforderungen für Team Foundation Server

Schritt 2

Richten Sie Team Foundation Server ein. Installieren Sie Team Foundation Server, und führen Sie den Konfigurations-Assistenten "Nur Anwendungsebene" aus.

  • Ausführen der Team Foundation Server-Installation

  • Konfigurieren von Team Foundation Server mit dem Konfigurations-Assistenten auf Anwendungsebene

Tipp Tipp

Laden Sie die aktuelle Version dieses Handbuchs von der folgenden Seite auf der Microsoft-Website herunter: Installationshandbuch für Team Foundation, alle aktuellen Änderungen an diesem Schritt anzuzeigen.


Konfigurieren von Team Foundation Server mit dem Konfigurations-Assistenten auf Anwendungsebene

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Team Foundation Server mit dem Konfigurations-Assistenten auf Anwendungsebene
Feedback senden

Sie können die Vorgehensweise in diesem Thema verwenden, um einer vorhandenen Team Foundation Server-Bereitstellung eine Anwendungsebene hinzuzufügen.

Um diese Schritte ausführen zu können, muss die Team Foundation Server-Bereitstellung ein Domänenkonto für das zugehörige Dienstkonto (TFSSERVICE) verwenden. Wenn Sie ursprünglich ein integriertes Konto für TFSSERVICE verwendet haben, müssen Sie es in ein Domänenkonto umwandeln. Weitere Informationen finden Sie im Abschnitt "Zuweisen eines anderen Kontos als Dienstkonto" auf dieser Seite der Microsoft-Website: Ändern des Dienstkontos oder Kennworts für Team Foundation Server.

Tipp Tipp

Sie können über das Menü Start auf das Team Foundation Server-Konfigurationstool zugreifen, indem Sie die Team Foundation Server-Verwaltungskonsole starten und dann Anwendungsebene und Installierte Funktionen konfigurieren auswählen.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein.

So konfigurieren Sie Team Foundation Server mit der Option "Nur für Anwendungsebene"

  1. Wählen Sie Nur für Anwendungsebene geltende Konfiguration und dann Assistent starten.

    Der Team Foundation Server-Assistent Nur für Anwendungsebenen wird angezeigt.

  2. Lesen Sie die Willkommensseite, und wählen Sie dann Weiter aus.

  3. Geben Sie in SQL Server-Instanz die Instanz von SQL Server ein, die die Konfigurationsdatenbank für die Installation von Team Foundation Server hostet, für die Sie einen Anwendungsebenenserver hinzufügen möchten, und wählen Sie dann Verfügbare Datenbanken auflisten.

    Der Assistent führt alle Datenbanken auf dieser Instanz von SQL Server auf.

  4. Wählen Sie eine Datenbank aus, und klicken Sie dann auf Weiter.

    Der Assistent zeigt die Anwendungsebeneneinstellungen für diesen Server an.

  5. Klicken Sie in der Liste auf das Konto, das Sie verwenden möchten: Geben Sie das Kennwort für das Dienstkonto ein. Sie können optional Test wählen, um die Kombination aus Benutzerkonto und Kennwort zu testen.

    Hinweis Hinweis

    Stellen Sie sicher, dass das Dienstkonto, das Sie angeben, der Gruppe Farmadministratoren für die SharePoint-Zentraladministrationswebsite hinzugefügt wurde. Weitere Informationen finden Sie unter Hinzufügen des Dienstkontos für Team Foundation Server zur Gruppe Farmadministratoren.

  6. Klicken Sie unter Authentifizierungsmethode auf NTLM, um die NTLM-Authentifizierung zu verwenden, oder auf Aushandlung (Kerberos), damit zuerst die sicherere Kerberos-Authentifizierung versucht wird. Wenn dies fehlschlägt, greifen Sie auf NTLM zurück. Wählen Sie Weiter aus.

    Der Standardwert ist NTLM.

  7. Überprüfen Sie auf der Seite "Überprüfen" die Einstellungen, und wählen Sie dann Weiter aus.

    Die Konfiguration wird überprüft.

  8. Wählen Sie Konfigurieren aus.

    Die Konfigurationseinstellungen werden angewendet.

  9. Wählen Sie Weiter aus.

  10. Wählen Sie Schließen aus.

  11. Wählen Sie Schließen aus.

    Die Team Foundation-Server-Verwaltungskonsole wird angezeigt.

Tipp Tipp

Wenn Sie eine Verbindung mit einem NLB-Cluster von einem Client herstellen, der auf einem der Anwendungsebenenserver im Cluster läuft, sollten Sie die Verbindung mit localhost als Servername herstellen, statt den Domain Name System (DNS)-Namen des Lastenausgleichs zu verwenden. Standardmäßig verhindert Internetinformationsdienste (IIS), dass von einem der Server im Cluster eine Verbindung mit einem NLB-Cluster hergestellt wird, es sei denn, es wird localhost als Name des Clusters verwendet.


SQL Server-Anforderungen für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

SQL Server-Anforderungen für Team Foundation Server
Siehe auch Feedback senden

Für Team Foundation Server ist SQL Server 2008 R2 oder SQL Server 2012 erforderlich. Sie haben für SQL Server mehrere Möglichkeiten:

  • Sie können die grundlegende Konfiguration von Team Foundation Server verwenden, die in SQL Server 2012 Express enthalten ist.

  • Sie können eine der unterstützten Editionen von SQL Server 2008 oder SQL Server 2012 installieren.

  • Sie können eine vorhandene Installation von SQL Server 2008 oder SQL Server 2012 verwenden.

Tipp Tipp

Unabhängig davon, welche Version Sie auswählen, können Sie Daten für Team Foundation Server auf einem SQL Server-Cluster hosten. Wenn alle Server im Cluster die aufgeführten Anforderungen erfüllen, müssen Sie für den Cluster keine besonderen Konfigurationen vornehmen.

Unabhängig von der ausgewählten Option müssen für die Instanz von SQL Server die folgenden Anforderungen erfüllt sein:

Unterstützte Editionen

  • SQL Server 2008, R2 Express

  • SQL Server 2008, R2 Standard Edition

  • SQL Server 2008, R2 Enterprise Edition mit SP 1 CU1 (25. August 2011)¹

  • SQL Server 2012, Express

  • SQL Server 2012 Standard Edition

  • SQL Server 2012 Enterprise Edition

Für Team Foundation Server erforderlich.

  • Datenbankmoduldienste

  • Volltextsuche (oder Volltext- und semantische Extraktion für die Suche in SQL Server 2012)

Erforderlich für Berichte

  • Reporting Services (oder Reporting Services - systemeigen in SQL Server 2012)

  • Analysis Services

Sortiereinstellungen

  • Muss Akzente berücksichtigen

  • Darf Groß- und Kleinschreibung nicht berücksichtigen

  • Darf nicht binär sein

  • Darf nicht binär sein - Codepunkt

Weitere Informationen finden Sie unter SQL Server-Sortierungsanforderungen für Team Foundation Server.

Authentifizierung

Windows-Authentifizierung

Dienstkonto

Sie können ein Domänenkonto oder ein integriertes Konto verwenden.

¹ Wenn Sie die R2 Enterprise Edition von SQL Server 2008 verwenden, müssen Sie Paket 1 des kumulativen Updates für SQL Server 2008 R2-Service Pack 1 aktualisieren, um ein SQL Server-Problem mit Tabellenkomprimierung beheben zu können.

So installieren Sie SQL Server für Team Foundation Server

Manuelle Installation von SQL Server für Team Foundation Server

Enthält Schritte für das Installieren von SQL Server für Team Foundation Server. Verwenden Sie diese Schritte, unabhängig davon, ob Sie die Installation auf einem einzigen Server oder auf mehreren Servern vornehmen.

Hinzufügen des Dienstkontos von Team Foundation Server zum Berichtsserver

In diesem Thema wird beschrieben, wie Sie dem Dienstkonto für Team Foundation Server die Berechtigung für die Verwendung des Berichtsservers zuweisen.

Überprüfen von SQL Server für Team Foundation Server

Enthält Schritte für das Überprüfen, ob eine SQL Server-Instanz zusammen mit Team Foundation Server ausgeführt werden kann.

Weitere SQL Server-Aufgaben für Team Foundation Server

Bereitstellen von SQL Server-Datenbanken für Team Foundation Server

In diesem Thema wird beschrieben, wie Sie leere Datenbanken erstellen, in denen die Daten von Team Foundation Server mit SQL Server gehostet werden können.

Arbeiten mit benannten SQL Server-Instanzen

Was ist eine benannte Instanz von SQL Server und wie wird sie verwendet?

Grundlegende Informationen zu SQL Server und Team Foundation Server

SQL Server und SQL Server Reporting Services

Zusammenfassend gesagt: Interaktionen zwischen Team Foundation Server und SQL Server

Team Foundation Server-Datenbanken

Eine umfassende Liste der Datenbanken zum Speichern von Team Foundation Server-Daten

SQL Server Reporting Services-Rollen

Eine kurze Erklärung der jeweiligen Rollen in SQL Server Reporting Services

SQL Server-Sortierungsanforderungen für Team Foundation Server

In diesem Thema werden die Team Foundation Server-Anforderungen für SQL Server-Sortiereinstellungen erläutert.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Aktualisieren von Team Foundation Server


Manuelle Installation von SQL Server für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Manuelle Installation von SQL Server für Team Foundation Server
Siehe auch Feedback senden

Wenn Sie SQL Server für Team Foundation Server installieren, müssen Sie bestimmte SQL Server-Funktionen installieren. Andere Funktionen sind nur erforderlich, wenn Sie Berichte generieren möchten. Um Team Foundation Server auszuführen, müssen Sie sowohl das Datenbankmodul als auch die Volltextsuche auf derselben Instanz von SQL Server installieren. Diese Instanz muss jedoch nicht auf demselben Server wie Team Foundation Server ausgeführt werden.

Anforderungen für die Berichterstellung

Wenn Sie Berichte erzeugen möchten, müssen Sie sowohl Analysis Services als auch Reporting Services installieren. Sie können eine oder beide dieser Funktionen auf demselben Server wie Team Foundation Server installieren, oder Sie können jede Funktion auf einem anderen Server als Team Foundation Server installieren.

Wenn sich SQL Server Reporting Services nicht auf dem Server befindet, auf dem Team Foundation Server ausgeführt wird, und Sie die Berichterstellung verwenden, müssen Sie Clientkonnektivitätstools auf Team Foundation Server installieren.

Tipp Tipp

SQL Server Express umfasst keine Konnektivität der Clienttools. Sie können diese aber mithilfe der folgenden Vorgehensweise in diesem Thema hinzufügen.

Empfehlungen für SQL Server-Topologien

Team Foundation Server unterstützt zahlreiche SQL Server-Topologien, um teilweise Teams mit vorhandenen SQL Server-Installationen anzupassen. Es gibt jedoch einige Richtlinien dafür, wie SQL Server für Team Foundation Server eingerichtet wird. Es wird empfohlen, die gleiche Version von SQL Server für alle Server zu verwenden, die Daten für Team Foundation Server hosten. Wenn Sie z. B. beabsichtigen, einen separaten Server zur Berichterstellung zu verwenden, sollten Sie sicherstellen, dass die gleiche Edition von SQL Server wie auf dem Server ausgeführt wird, auf dem die Konfigurationsdatenbank für Team Foundation Server gehostet wird.

Dies sind die empfohlenen Setups - abhängig davon, wie viele Server Sie verwenden:

  • Einzelner Server: Installieren Sie das Datenbankmodul, Volltextsuche, SQL Server Reporting Services und Analysis Services auf demselben Server, auf dem Team Foundation Server ausgeführt wird. Wenn Sie die Berichterstellung nicht verwenden, benötigen Sie SQL Server Reporting Services und Analysis Services nicht. Weitere Informationen finden Sie unter Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration.

  • Dualer Server: Installieren Sie SQL Server Reporting Services und Team Foundation Server auf demselben Server. Installieren Sie das Datenbankmodul, die Volltextsuche und SQL Server Analysis Services auf einem anderen Server. Das Szenario trennt den HTTP-Datenverkehr vom SQL Server-Datenverkehr. Wenn Sie keine Berichterstellung benötigen, sind SQL Server Reporting Services und Analysis Services nicht erforderlich.

  • Mehrere Server: Installieren Sie das Datenbankmodul und die Volltextsuche auf einem Server; SQL Server Reporting Services auf einem zweiten Server; Analysis Services auf einem dritten Server (Reporting Services und Analysis Services können sich alternativ auch auf demselben Server befinden) und Konnektivität der Clienttools auf dem Server, auf dem Team Foundation Server ausgeführt wird. Wenn Sie keine Berichterstellung benötigen, sind SQL Server Reporting Services, Analysis Services und Clientkonnektivitätstools nicht erforderlich. Wenn Sie diese wirksam ausschließen, entsteht hieraus eine Topologie mit zwei Servern.

Weitere Informationen zu Bereitstellungen, die mehrere Serverkombinationen verwenden, finden Sie unter Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration

Berichtsserver

Wenn Sie die Berichterstellung verwenden, erfordert Team Foundation Server einen dedizierten Berichtsserver.

Der Berichtsserver benötigt eine dedizierte relationale Datenbank. Diese Datenbank ist von der relationalen Datenbank getrennt, die Team Foundation Server zur Bereitstellung von Berichten verwendet. Wenn Sie SQL Server Reporting Services und das Datenbankmodul auf dem gleichen Server installieren, kann das Setup von SQL Server die Reporting Services durch das Einrichten der dafür erforderlichen relationalen Datenbank auf der Datenbankmodul-Instanz konfigurieren

Wenn Sie Reporting Services ohne das Datenbankmodul installieren, müssen Sie Reporting Services manuell konfigurieren, nachdem Sie SQL Server installiert haben. Dies beinhaltet das Angeben einer Instanz des Datenbankmoduls, auf der die relationale Datenbank für den Berichtsserver gehostet werden kann. Weitere Informationen finden Sie unter Manuelles Konfigurieren des Berichtsservers.

Als empfohlene Vorgehensweise für Bereitstellungen von Team Foundation Server, die die Berichterstellung verwenden, konfigurieren Sie den Windows-Dienst für Analysis Services so, dass beim Auftreten eines Fehlers eine Wiederherstellung durchgeführt wird. Weitere Informationen finden Sie unter Konfigurieren von Analysis Services für die Wiederherstellung nach einem Fehler.

Erforderliche Berechtigungen

Zum Ausführen dieser Schritte müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Sie SQL Server installieren.

Um einen Berichtsserver manuell zu konfigurieren, müssen Sie auch Mitglied der Sicherheitsgruppe Administratoren auf dem SQL Server sein, der die Berichtsserver-Datenbank hostet, wenn sich diese Instanz von SQL Server nicht auf dem Berichtsserver befindet.

So installieren Sie SQL Server

  1. Legen Sie die Installations-DVD für eine unterstützte Version von SQL Server ein, und starten Sie "setup.exe". Weitere Informationen: SQL Server-Anforderungen für Team Foundation Server.

  2. Wählen Sie auf der Seite SQL Server-Installationscenter die Option Installation und dann Neue Installation oder Hinzufügen von Features zu einer vorhandenen Installation aus.

  3. Wählen Sie auf der Seite Setupunterstützungsregeln die Option OK aus.

  4. Geben Sie auf der Seite Product Key Ihren Product Key ein, oder geben Sie eine kostenlose Edition an, und wählen Sie dann Weiter aus.

  5. Akzeptieren Sie auf der Seite Lizenzbedingungen die Lizenzbedingungen, und wählen Sie Weiter aus.

  6. Wählen Sie auf der Seite Setup-Unterstützungsdateien die Option Installieren (nur SQL Server 2008 R2) aus.

  7. Wählen Sie auf der Seite Setupunterstützungsregeln die Option Weiter aus.

    Tipp Tipp

    Eine Windows-Firewall-Warnung wird möglicherweise angezeigt. Sie können diese Warnung gefahrlos ignorieren. Weitere Informationen zu den für Team Foundation Server erforderlichen SQL Server-Ports finden Sie unter Erforderliche Ports für die Installation von Team Foundation Server.

  8. Wählen Sie auf der Seite Setuprolle die Option SQL Server-Funktionsinstallation aus, und wählen Sie anschließend Weiter aus.

  9. Aktivieren Sie auf der Seite Funktionsauswahl die Kontrollkästchen für mindestens eine der folgenden Komponenten, und zwar in Abhängigkeit der von Ihnen verwendeten Topologie, und wählen Sie anschließend Weiter aus.

    • Datenbankmoduldienste (für Team Foundation Server erforderlich)

    • Volltextsuche oder Volltext- und semantische Extraktion für die Suche ¹ (für Team Foundation Server erforderlich)

    • Analysis Services (erforderlich für Berichterstellung)

    • Reporting Services oder Reporting Services - systemeigen¹ (erforderlich für Berichterstellung)

    • Konnektivität der Clienttools (erforderlich, wenn keine anderen SQL Server-Komponenten auf dem Server installiert sind, auf dem Team Foundation Server ausgeführt wird.)

    • Verwaltungstools - Einfach ²

  10. Wählen Sie auf der Seite Installationsregeln die Option Weiter aus.

  11. Wählen Sie auf der Seite Instanzkonfiguration die Option Standardinstanz oder Benannte Instanz aus. Wenn Sie Benannte Instanz auswählen, geben Sie einen Namen der Instanz ein. Wählen Sie Weiter aus.

  12. Wählen Sie auf der Seite Erforderlicher Speicherplatz die Option Weiter aus.

  13. Führen Sie auf der Seite Server-Konfiguration eine der folgenden Optionen aus:

    • Für SQL Server 2012 können Sie die Standardeinstellungen übernehmen, oder den Namen eines Domänenkontos oder NT-AUTORITÄT\NETZWERKDIENST im Feld Kontoname für jeden Dienst eingeben.

    • Wählen Sie für SQL Server 200 R2 die Option Gleiches Konto für alle SQL Server-Dienste verwenden,³ oder geben Sie den Namen eines Domänenkontos oder NT-AUTORITÄT\NETZWERKDIENST im Feld Kontoname für jeden Dienst ein.

    Geben Sie unabhängig von der SQL Server-Version das Kennwort im Feld Kennwort ein, wenn Sie ein Domänenkonto angeben. Wenn Sie NT-Autorität\Netzwerkdienst verwenden, lassen Sie das Feld Kennwort leer.

  14. Überprüfen Sie in der Spalte Starttyp, dass der Wert Automatisch für alle Dienste angezeigt wird, die Sie bearbeiten können, und klicken Sie dann auf Weiter.

    Hinweis Hinweis

    Auf dieser Seite können Sie Sortierungseinstellungen festlegen. Weitere Informationen finden Sie unter SQL Server-Sortierungsanforderungen für Team Foundation Server.

  15. Wenn Sie in Schritt 9 das Kontrollkästchen für Datenbankmoduldienste aktiviert haben, wählen Sie auf der Seite Datenbankmodulkonfiguration die Option Windows-Authentifizierungsmodus, dann Aktuellen Benutzer hinzufügen und anschließend Weiter. Fahren Sie andernfalls mit dem nächsten Schritt fort.

  16. Wenn Sie in Schritt 9 das Kontrollkästchen für Analysis Services aktiviert haben, wählen Sie auf der Seite Analysis Services-Konfiguration die Option Aktuellen Benutzer hinzufügen und anschließend Weiter. Fahren Sie andernfalls mit dem nächsten Schritt fort.

  17. Wenn Sie in Schritt 9 das Kontrollkästchen für Reporting Services aktiviert haben, wählen Sie auf der Seite Reporting Services-Konfiguration die Option Standardkonfiguration des systemeigenen Modus installieren (SQL Server 2008) oder Installieren und Konfigurieren (SQL Server 2012) aus. Wenn diese Optionen nicht verfügbar sind, wählen Sie Berichtsserver installieren, aber nicht konfigurieren (SQL Server 2008) oder Nur Installation (SQL Server 2012) aus, und klicken Sie dann auf Weiter.

    Wenn Sie Berichtsserver installieren, aber nicht konfigurieren oder Nur Installation auswählen mussten, planen Sie möglicherweise, den Berichtsserver und Team Foundation Server auf unterschiedlichen Servern zu installieren. Dies ist eine unterstützte Topologie, aber Sie müssen den Berichtsserver manuell konfigurieren, nachdem Sie die Installation von SQL Server abgeschlossen haben. Verwenden Sie diese Anweisungen: Manuelles Konfigurieren des Berichtsservers

    Hinweis Hinweis

    Klicken Sie nicht auf Standardkonfiguration des integrierten SharePoint-Modus installieren. Team Foundation Server unterstützt diesen Konfigurationsmodus nicht.

  18. (Optional) Geben Sie auf der Seite Fehler- und Verwendungsberichterstellung an, ob Informationen zu Fehlern zu senden sind. Wählen Sie dann Weiter.

  19. Wählen Sie auf der Seite Installationsregeln die Option Weiter aus.

  20. Überprüfen Sie auf der Seite Installationsbereit die Liste der zu installierenden Komponenten, und wählen Sie dann Installieren aus.

    Auf der Seite Installationsstatus wird der Status der einzelnen Komponenten angezeigt.

  21. Wählen Sie auf der Seite Abgeschlossen die Option Schließen aus.

¹ In SQL Server 2012 weichen die Funktionsnamen geringfügig von denen in SQL Server 2008 R2 ab. Diese Prozedur listet Funktionsnamen beider Versionen auf, aber Sie müssen nur die Funktion installieren, die der installierten Version von SQL Server entspricht.

² Um Team Foundation Server zu installieren, müssen Sie die Verwaltungstools (Einfach oder Vollständig) nicht auf dem gleichen Computer wie SQL Server installieren. Sie müssen jedoch die Installation von SQL Server mit dem SQL Server Management Studio-Verwaltungstool überprüfen.

³ Wenn Sie auf Gleiches Konto für alle SQL Server-Dienste verwenden (nur SQL Server 2008 R2) klicken, müssen Sie möglicherweise immer noch Kontoinformationen für einige Dienste manuell eingeben.

Manuelles Konfigurieren des Berichtsservers

SQL Server 2008 R2 - keine automatische Konfiguration von Reporting Services

SQL Server 2008 R2 - keine automatische SSRS-Konfiguration

Wenn Sie das Datenbankmodul nicht auf dem gleichen Server wie Reporting Services installieren, stehen Ihnen diese Reporting Services-Konfigurationsoptionen in SQL Server 2008 R2 zur Verfügung. Sie werden einen etwas anderen Bildschirm in SQL Server 2012 bemerken, aber das Endergebnis ist dasselbe: Sie müssen den Berichtsserver mithilfe der nachfolgenden Schritte manuell konfigurieren, nachdem Sie die Installation von SQL Server beendet haben.

Im unwahrscheinlichen Fall, dass sich Reporting Services und Team Foundation Server auf demselben Server befinden und Sie den Berichtsserver nicht konfiguriert haben, werden Sie während der Installation von Team Foundation Server aufgefordert, die bei Schritt 3 beginnende Berichtsserverkonfiguration abzuschließen.

So konfigurieren Sie einen Berichtsserver manuell

  1. Starten Sie den Konfigurations-Manager für Reporting Services über das Startmenü.

    Das Dialogfeld Konfigurationsverbindung für Reporting Services wird angezeigt.

  2. Geben Sie unter Servername den Namen des Berichtsservers ein. Wenn Sie einen Instanznamen verwenden, geben Sie den Namen der Instanz in Berichtsserverinstanz ein. Wählen Sie Verbinden aus.

  3. Wählen Sie auf der Seite Konfigurations-Manager für Reporting Services die Option Starten aus, wenn als Status für den Berichtsdienst Beendet angezeigt wird.

  4. Klicken Sie in der Navigationsleiste auf Webdienst-URL.

  5. Wählen Sie auf der Seite Webdienst-URL die Option Übernehmen aus, um die Standardwerte in den Feldern Virtuelles Verzeichnis, IP-Adresse, und TCP-Port zu übernehmen.

  6. Klicken Sie in der Navigationsleiste auf Datenbank.

  7. Wählen Sie auf der Seite Berichtsserver-Datenbank die Option Datenbank ändern aus.

    Der Assistent zum Konfigurieren der Berichtsserver-Datenbank wird gestartet.

  8. Wählen Sie auf der Seite Aktion des Assistenten Neue Berichtsserver-Datenbank erstellen und dann Weiter aus.

  9. Geben Sie auf der Seite Datenbankserver des Assistenten im Feld Servername den Namen einer lokalen oder einer Remoteinstanz von SQL Server ein, auf der die Datenbank für den Berichtsserver gehostet werden soll, und wählen Sie anschließend Weiter aus.

  10. Wählen Sie auf der Seite Datenbank des Assistenten Weiter aus, um die Standardwerte in den Feldern Datenbankname, Sprache, und Systemeigener Modus zu übernehmen.

  11. Wählen Sie unter Anmeldeinformationen die Option Weiter, um die Standardwerte in den Feldern Authentifizierungstyp, Benutzername und Kennwort zu übernehmen.

  12. Überprüfen Sie die Angaben auf der Seite Zusammenfassung des Assistenten, und wählen Sie dann Weiter aus.

  13. Wählen Sie auf der Seite Fortsetzen und Fertigstellen des Assistenten Fertig stellen aus.

  14. Klicken Sie in der Navigationsleiste für Konfigurations-Manager für Reporting Services auf Berichts-Manager-URL.

  15. Wählen Sie auf der Seite Berichts-Manager-URL die Option Übernehmen aus, um den Standardwert im Feld Virtuelles Verzeichnis zu übernehmen, und wählen Sie dann Beenden aus.

Konfigurieren von Analysis Services für die Wiederherstellung nach einem Fehler

Konfigurieren Sie den Windows-Dienst für Analysis Services so, dass er nach einem Fehler neu gestartet wird.

So konfigurieren Sie Analysis Services für die Wiederherstellung

  1. Aktivieren Sie über das Menü Start die Option Dienste in der Systemsteuerung.

  2. Öffnen Sie das Kontextmenü für den Windows-Dienst für SQL Server Analysis Services (MSSQLSERVER), und wählen Sie dann Eigenschaften aus.

    Wenn Sie eine benannte Instanz von Analysis Services verwenden, wird der Name der Instanz in Klammern angegeben.

  3. Wählen Sie Wiederherstellung aus.

  4. Klicken Sie in der Liste Erster Fehler auf Dienst neu starten.

  5. Klicken Sie in der Liste Zweiter Fehler auf Dienst neu starten.

  6. Klicken Sie in der Liste Weitere Fehler auf Dienst neu starten, und klicken Sie dann auf OK.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Aktualisieren von Team Foundation Server
SQL Server-Sortierungsanforderungen für Team Foundation Server


Hinzufügen des Dienstkontos von Team Foundation Server zum Berichtsserver

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Hinzufügen des Dienstkontos von Team Foundation Server zum Berichtsserver
Siehe auch Feedback senden

Wenn sich Berichtsserver und Team Foundation Server nicht auf demselben Server befinden, müssen Sie der Gruppe "Inhalts-Manager" auf dem Berichtsserver den Namen des Dienstkontos hinzufügen, das Sie für Team Foundation Server (TFSSERVICE) verwenden. Dieser Schritt wird beim Setup von Team Foundation Server automatisch ausgeführt, wenn der Berichtsserver unter Team Foundation Server installiert wird.

Wenn Sie das Netzwerkdienstkonto für TFSSERVICE verwenden, müssen Sie anstelle von Netzwerkdienst den Computernamen des Servers hinzufügen, auf dem Team Foundation Server ausgeführt wird. Der Computername ist der Servername, gefolgt vom $-Symbol. Beispiel: Domäne\Servername$.

Weitere Informationen zu Dienstkonten finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Berichtsserver sein.

So fügen Sie der Gruppe Inhalts-Manager auf dem Berichtsserver das Dienstkonto für Team Foundation Server hinzu

  1. Wählen Sie im Startmenü die Option Konfigurations-Manager für Reporting Services aus.

    Hinweis Hinweis

    Öffnen Sie unter Windows Server 2008 das Kontextmenü für Konfigurations-Manager für Reporting Services, und wählen Sie Als Administrator ausführen aus.

    Das Dialogfeld Konfigurationsverbindung für Reporting Services wird angezeigt.

  2. Geben Sie im Feld Servername den Namen des Berichtsservers ein. Wenn Sie einen Instanznamen verwenden, wählen Sie den Namen der Instanz in der Liste Berichtsserverinstanz aus. Wählen Sie Verbinden aus.

  3. Wählen Sie URL des Berichts-Managers und anschließend den Link zur Berichts-Manager-Website aus.

    Die Berichts-Manager-Website für den Berichtsserver wird in einem Internetbrowserfenster geöffnet.

  4. Klicken Sie auf der Berichts-Manager-Website auf die Registerkarte Eigenschaften und anschließend auf Neue Rollenzuweisung.

  5. Geben Sie im Feld Gruppen- oder Benutzername den Namen des Dienstkontos ein, das Sie für Team Foundation Server verwenden (TFSSERVICE), aktivieren Sie das Kontrollkästchen Inhalts-Manager, und klicken Sie dann auf OK.

Siehe auch

Konzepte

Gewusst wie: Aktualisieren von Team Foundation Server


Überprüfen von SQL Server für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Überprüfen von SQL Server für Team Foundation Server
Siehe auch Feedback senden

Um zu gewährleisten, dass die Installation von SQL Server zusammen mit Team Foundation Server verwendet werden kann, müssen Sie sicherstellen, dass alle erforderlichen Funktionen von SQL Server verfügbar sind, die zugrunde liegenden und SQL Server zugeordneten Windows-Dienste ausgeführt werden, dass die Verbindungseinstellungen konfiguriert wurden und dass alle benötigten Netzwerkports geöffnet sind.

Wenn sich SQL Server Reporting Services nicht auf dem Server befindet, auf dem Team Foundation Server ausgeführt wird, und Sie die Berichterstellung verwenden, müssen Sie die Clientkonnektivitätstools auf Team Foundation Server installieren.

Wenn das Datenbankmodul, Analysis Services und Reporting Services auf unterschiedlichen Instanzen von SQL Server ausgeführt werden, müssen Sie sich an jedem Server anmelden, um die einzelnen Instanzen zu überprüfen.

Hinweis Hinweis

Wenn Sie die Team Foundation Server-Berichterstellung nicht verwenden, müssen Sie SQL Server Reporting Services oder Analysis Services nicht überprüfen.

Erforderliche Berechtigungen

Zum Ausführen des Konfigurations-Managers für SQL Server müssen Sie Mitglied der Sicherheitsgruppe Benutzer auf dem Server sein, auf dem SQL Server gehostet wird. Für die Verwendung des Konfigurations-Managers für SQL Server zum Ändern von Diensten müssen Sie Mitglied der Sicherheitsgruppe Administratoren sein.

Um den Konfigurations-Manager für SQL Server Reporting Services oder SQL Server Management Studio auszuführen, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Betriebssystem des Servers sein, auf dem die zu überprüfende Instanz von SQL Server ausgeführt wird. Für SQL Server Management Studio müssen Sie außerdem Mitglied der Serverrolle Öffentlich auf der Instanz von SQL Server sein, die Sie überprüfen möchten.

Überprüfen von Reporting Services

So überprüfen Sie mit dem Konfigurations-Manager von SQL Server, ob der Windows-Dienst ausgeführt wird

  1. Klicken Sie auf dem Server, auf dem SQL Server Reporting Services ausgeführt wird, auf Start, zeigen Sie nacheinander auf Alle Programme, Microsoft SQL Server 2008 und Konfigurationstools, und klicken Sie dann auf SQL Server-Konfigurations-Manager.

  2. Klicken Sie auf SQL Server-Dienste, und stellen Sie sicher, dass in der Spalte Status für SQL Server Reporting Services der Wert Wird ausgeführt angezeigt wird.

So überprüfen Sie mit dem Konfigurations-Manager von SQL Server Reporting Services, ob die Berichtsserver-URLs ausgeführt werden

  1. Klicken Sie auf dem Server, auf dem SQL Server Reporting Services ausgeführt wird, auf Start, zeigen Sie nacheinander auf Alle Programme, Microsoft SQL Server 2008 und Konfigurationstools, und klicken Sie dann auf Konfigurations-Manager für Reporting Services.

    Hinweis Hinweis

    Unter Windows Server 2008 müssen Sie mit der rechten Maustaste auf Konfigurations-Manager für Reporting Services klicken und anschließend Als Administrator ausführen auswählen.

    Das Dialogfeld Konfigurationsverbindung für Reporting Services wird angezeigt.

  2. Geben Sie in Servername den Namen des Berichtsservers ein. Wenn Sie einen Instanznamen verwenden, geben Sie den Namen der Instanz in Berichtsserverinstanz ein. Klicken Sie auf Verbinden.

  3. Klicken Sie auf Berichts-Manager-URL, und klicken Sie auf den Link zur Berichts-Manager-Website.

    Die Berichts-Manager-Website für den Berichtsserver wird in einem Internetbrowserfenster geöffnet.

  4. Klicken Sie auf Webdienst-URL, und klicken Sie auf den Link zur Berichtsserver-Website.

    Die Berichtsserverwebsite wird in einem Internetbrowserfenster geöffnet.

Hinweis Hinweis

Wenn sich SQL Server Reporting Services und Team Foundation Server nicht auf demselben Server befinden, müssen Sie der Gruppe Inhalts-Manager auf dem Berichtsserver den Namen des Dienstkontos hinzufügen, das Sie für Team Foundation Server verwenden (TFSSERVICE). Dieser Schritt wird automatisch beim Setup von Team Foundation Server ausgeführt, wenn der Berichtsserver unter Team Foundation Server installiert wird. Weitere Informationen finden Sie unter Hinzufügen des Dienstkontos von Team Foundation Server zum Berichtsserver.

Überprüfen des Datenbankmoduls und von Analysis Services

Auf der Instanz von SQL Server, auf der das Datenbankmodul ausgeführt wird, müssen Sie sicherstellen, dass die Volltextsuche verfügbar ist. Öffnen Sie zum Überprüfen dieser Funktion das SQL Server-Installationscenter, und klicken Sie anschließend auf Neue eigenständige SQL Server-Installation oder Hinzufügen von Features zu einer vorhandenen Installation. Wenn die Volltextsuche auf der Instanz von SQL Server, auf der das Datenbankmodul ausgeführt wird, nicht verfügbar ist, müssen Sie die Volltextsuche installieren. Weitere Informationen zum Arbeiten mit SQL Server-Installationscenter finden Sie unter Manuelle Installation von SQL Server für Team Foundation Server.

So überprüfen Sie mit dem Konfigurations-Manager von SQL Server, ob die Windows-Dienste ausgeführt werden

  1. Klicken Sie in der Instanz von SQL Server, auf der das Datenbankmodul, SQL Server Analysis Services oder beide ausgeführt werden, auf Start, zeigen Sie auf Alle Programme, Microsoft SQL Server 2008 und Konfigurationstools, und klicken Sie anschließend auf SQL Server-Konfigurations-Manager.

  2. Klicken Sie auf SQL Server-Dienste, und stellen Sie sicher, dass in der Spalte Status der Wert Wird ausgeführt für alle Dienste angezeigt wird und dass der Startmodus auf automatisch festgelegt ist.

    • Um das automatische Starten eines Diensts festzulegen, klicken Sie mit der rechten Maustaste auf den Dienst, klicken Sie auf Eigenschaften und anschließend auf die Registerkarte Dienst, und klicken Sie dann rechts neben Startmodus in der Dropdownliste auf Automatisch.

    • Um einen beendeten Dienst zu starten, klicken Sie mit der rechten Maustaste auf den beendeten Dienst, und klicken Sie dann auf Starten.

  3. Klicken Sie auf SQL Server-Netzwerkkonfiguration, doppelklicken Sie auf Protokolle für MeinInstanzname, und vergewissern Sie sich anschließend, dass in der Spalte Status für TCP/IP der Wert Aktiviert angezeigt wird.

    Wenn Sie während der Installation die Standardinstanz angegeben haben, wird MeinInstanzname durch MSSQLSERVER ersetzt.

Hinweis Hinweis

Als empfohlene Vorgehensweise sollten Sie den Windows-Dienst für Analysis Services für die Wiederherstellung nach dem Auftreten eines Fehlers konfigurieren. Weitere Informationen finden Sie unter "Konfigurieren von Analysis Services für die Wiederherstellung nach einem Fehler" in Manuelle Installation von SQL Server für Team Foundation Server.

Für die folgende Vorgehensweise muss SQL Server Management Studio installiert sein. Es muss jedoch nicht auf dem Server installiert sein, auf dem die Instanz von SQL Server ausgeführt wird, die Sie überprüfen. Informationen zur Installation von SQL Server Management Studio finden Sie unter Manuelle Installation von SQL Server für Team Foundation Server.

So überprüfen Sie mithilfe von SQL Server Management Studio die Verbindung mit einer SQL Server-Instanz

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme und auf Microsoft SQL Server 2008, und klicken Sie anschließend auf SQL Server Management Studio.

    Das Dialogfeld Mit Server verbinden wird angezeigt.

  2. Klicken Sie in der Liste Servertyp auf Datenbankmodul oder auf Analysis Services, je nachdem, welchen Installationstyp Sie überprüfen möchten.

  3. Geben Sie den Namen des Servers ein, mit dem Sie eine Verbindung herstellen möchten, und klicken Sie anschließend auf Verbinden.

    Wenn SQL Server in einem Cluster installiert ist, müssen Sie den Servernamen angeben, nicht den Computernamen. Wenn Sie eine benannte Instanz von SQL Server verwenden, müssen Sie den Namen des Servers sowie der Instanz angeben. Überprüfen Sie die Firewalleinstellungen, wenn Sie keine Verbindung mit dem Server herstellen können, und versuchen Sie dann erneut, eine Verbindung herzustellen.

  4. Prüfen Sie im Objekt-Explorer, ob neben dem Servernamen ein grüner Pfeil angezeigt wird.

Siehe auch

Konzepte

Manuelle Installation von SQL Server für Team Foundation Server
Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration


Bereitstellen von SQL Server-Datenbanken für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Bereitstellen von SQL Server-Datenbanken für Team Foundation Server
Siehe auch Feedback senden

Sie können leere Datenbanken für Team Foundation Server erstellen, da dies für die Verwaltung der Datenbanken mehrerer Instanzen von Team Foundation Server in einer einzelnen Instanz von SQL Server oder zum Hosten von Team Foundation Server-Datenbanken in einer verwalteten Instanz von SQL Server nützlich sein kann. Unabhängig von den Gründen finden Sie in diesem Thema Informationen zum Bereitstellen leerer SQL Server-Datenbanken für die Verwendung mit Team Foundation Server.

Die vorliegende Vorgehensweise besteht konzeptionell aus zwei Schritten:

  1. Sie erstellen die Datenbanken und benennen diese gemäß festgelegten Richtlinien.

  2. Sie geben diese Datenbanken beim Installieren von Team Foundation Server an.

Konfigurationsdatenbank

Team Foundation Server umfasst zwei Datenbanken, die Sie während der Installation so konfigurieren können, dass leere Datenbanken verwendet werden.

  • Tfs_DatenbankbezeichnungWarehouse

  • Tfs_DatenbankbezeichnungApplication

Für diese Datenbanken muss die dargestellte Benennungsstruktur verwendet werden. Sie können jedoch entweder die Zeichenfolge Datenbankbezeichnung auslassen oder eine beliebige benutzerdefinierte Zeichenfolge angeben, mit der beide Datenbanken eindeutig beschrieben werden.

Beim Installieren von Team Foundation Server müssen Sie das Kontrollkästchen Bereits vorhandene leere Datenbank(en) verwenden aktivieren. Wenn Sie eine Bezeichnung hinzugefügt haben, müssen Sie darüber hinaus diese unter Bezeichnung für Serverdatenbanken eingeben. Anschließend richtet der Installations-Assistent die Konfigurationsdatenbank mit den erstellten leeren Datenbanken ein.

Hinweis Hinweis

Jede Projektauflistung benötigt eine eigene Datenbank. Sie können jedoch Team Foundation Server während der Installation so konfigurieren, dass eine leere Projektauflistungsdatenbank verwendet wird. Nach der Installation müssen Sie mit der Team Foundation Server-Verwaltungskonsole eine leere Projektauflistungsdatenbank hinzufügen.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Aktualisieren von Team Foundation Server


Arbeiten mit benannten SQL Server-Instanzen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Arbeiten mit benannten SQL Server-Instanzen
Siehe auch Feedback senden

Sie können Team Foundation Server mit der Standardinstanz von SQL Server oder mit einer benannten Instanz von SQL Server installieren. Je nach Geschäftsinfrastruktur und Bereitstellungsanforderungen könnten Sie eine benannte Instanz vorziehen. Wenn Sie eine benannte Instanz in Ihrer Bereitstellung von Team Foundation Server verwenden möchten, müssen Sie diese benannte Instanz vor der Installation von Team Foundation Server in SQL Server erstellen, oder Sie erstellen eine Teamprojektsammlung, die diese Instanz verwendet. Während der Installation von Team Foundation Server können Sie keine benannte Instanz erstellen.

So verwenden Sie eine benannte Instanz von SQL Server in einer Team Foundation Server-Bereitstellung

  • Um eine benannte Instanz mit Team Foundation Server zu verwenden, müssen Sie SQL Server entweder mit einer benannten Instanz installieren, oder Team Foundation Server-Daten auf eine benannte Instanz verschieben bzw. auf dieser wiederherstellen, oder eine Teamprojektsammlung auf einer benannten Instanz erstellen. Weitere Informationen zur Installation von SQL Server als benannte Instanz finden Sie unter Manuelle Installation von SQL Server für Team Foundation Server.

Siehe auch

Konzepte

SQL Server und SQL Server Reporting Services


SQL Server und SQL Server Reporting Services

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
SQL Server und SQL Server Reporting Services
Siehe auch Feedback senden

Visual Studio Team Foundation Server kann einfacher verwaltet werden, wenn SQL Server und SQL Server Reporting Services sowie deren Interaktionsweise mit Team Foundation Server bekannt sind. Schwerpunkt dieses Themas ist die Interaktion von SQL Server und SQL Server Reporting Services mit Team Foundation Server.

Interaktionen zwischen Team Foundation Server und SQL Server

Die logische Datenebene für Team Foundation hängt von SQL Server ab und besteht aus mehreren SQL Server-Datenbanken. Standardmäßig haben diese Datenbanken die folgenden Namen:

  • TFS_Configuration. Diese Datenbank enthält alle Konfigurationsinformationen für die Team Foundation Server-Ressourcen.

  • TFS_Warehouse. Dies ist die Datenbank für alle Berichte in Team Foundation Server.

  • TFS_Analysis. In dieser mehrdimensionalen Datenbank werden die aggregierten Daten aus Teamprojektsammlungen gespeichert.

  • TFS_Name_der_Sammlung. Dies sind die individuellen Datenbanken für Teamprojektsammlungen (für jede Sammlung besteht eine eigene Datenbank).

Diese logische Ebene kann sich auf einem oder mehreren physischen Servern befinden und über ein SQL Server-Servercluster verteilt sein.

Das folgende Diagramm veranschaulicht die logische Architektur einer Bereitstellung von Team Foundation Server, die sowohl in SQL Server Reporting Services als auch in SharePoint-Produkte integriert ist:

Datenbankbeziehungen mit SharePoint-Produkten

Ein Vorteil des Speicherns aller Daten in einer Datenbank ist, dass die Datenverwaltung vereinfacht wird, da Sie keine einzelnen Clientcomputer sichern müssen. Wenn Sie mit dem Sichern von SQL Server-Datenbanken Erfahrung haben, wird Ihnen das Sichern und Wiederherstellen von Team Foundation Server-Datenbanken gleichermaßen vertraut sein.

Tipp Tipp

Für Team Foundation Server dürfen die Einstellungen für die Sortierreihenfolge die Groß-/Kleinschreibung nicht berücksichtigen und nicht binär sein, während Akzente berücksichtigt werden müssen. Wenn Sie eine vorhandene Installation von SQL Server mit Team Foundation Server verwenden möchten, müssen Sie überprüfen, ob die Sortierungseinstellungen diese Anforderungen erfüllen. Anderenfalls schlägt die Installation von Team Foundation Server fehl. Weitere Informationen finden Sie unter SQL Server-Sortierungsanforderungen für Team Foundation Server.

SQL Server muss auf einem Server installiert sein, auf dem die erforderlichen Vertrauensstellungen zu dem Server konfiguriert sind, der als Host für die Team Foundation-Anwendungsebene fungiert. (In beiden Fällen kann es sich auch um mehrere Server handeln.)

Interaktionen zwischen Team Foundation Server und SQL Server Reporting Services

SQL Server Reporting Services wird als Teil der logischen Anwendungsebene für Team Foundation Server betrachtet. Die Installation von Reporting Services muss sich jedoch nicht auf demselben physischen Server befinden wie weitere logische Aspekte dieser Anwendungsebene wie SharePoint-Produkte. Weitere Informationen finden Sie unter Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration.

Bei der Konfiguration von Benutzer- und Gruppenberechtigungen sowie Gruppenmitgliedschaft in Team Foundation Server müssen Sie die Rollenmitgliedschaft und Berechtigungen für diese Benutzer und Gruppen in Reporting Services entsprechend manuell konfigurieren. Weitere Informationen finden Sie unter SQL Server Reporting Services-Rollen.

Neben der Konfiguration der Rollenmitgliedschaft und Berechtigungen in Reporting Services müssen Sie das Berichtsleserkonto verwalten, das Team Foundation Server verwendet, um mit dem Berichtsserver zu kommunizieren. Dieses Konto wird häufig als Datenquellenkonto für Reporting Services oder TFSREPORTS bezeichnet. Wie das Team Foundation Server-Dienstkonto muss auch das Berichtsleserkonto einer Arbeitsgruppe oder Domäne angehören, die von jedem Computer, der eine Verbindung mit Team Foundation Server herstellt, als vertrauenswürdig eingestuft wird. Weitere Informationen finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

Tipp Tipp

Selbst wenn Sie mit Administratoranmeldeinformationen angemeldet sind, können Sie auf den Berichts-Manager oder auf die http://localhost/Reports-Sites möglicherweise nur zugreifen, wenn Sie diese Sites in Internet Explorer als vertrauenswürdige Websites festlegen oder Internet Explorer als Administrator starten. Zum Starten von Internet Explorer als Administrator wählen Sie Start und Alle Programme. Öffnen Sie dann das Kontextmenü Internet Explorer und wählen Sie anschließend die Option Als Administrator ausführen aus. Weitere Informationen finden Sie auf der Microsoft-Website.

Siehe auch

Konzepte

SQL Server Reporting Services-Rollen


Team Foundation Server-Datenbanken

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Team Foundation Server-Datenbanken
Feedback senden

Team Foundation Server speichert Daten in SQL Server und, bei konfigurierter Berichterstellung, in SQL Server Analysis Services und Reporting Services. Sie können die Bereitstellung besser verwalten, wenn Sie wissen, welche Datenbanken Team Foundation Server verwendet.

In der folgenden Tabelle werden die Datenbanken beschrieben, die in der Bereitstellung von Team Foundation Server vorhanden sein können:

Datenbank | Verwendung | Beschreibung
Tfs_Configuration | Immer | Hier werden die Daten gespeichert, in denen die Bereitstellung von Team Foundation Server beschrieben wird, einschließlich des Namens und des Speicherorts der anderen Datenbanken.
Tfs_Sammlung | Immer | Pro Teamprojektsammlung gibt es eine Datenbank. In den einzelnen Datenbanken werden die Daten der Teamprojekte (Versionskontrolle, Builds und Arbeitsaufgaben) in der betreffenden Sammlung speichert.
Tfs_Warehouse | Bei konfigurierter Berichterstellung | Daten aus allen Projektsammlungen werden erfasst und in Tabellen gespeichert, die für die Berichterstellung optimiert sind.
Tfs_Analysis | Bei konfigurierter Berichterstellung | In dieser Analysis Services-Datenbank werden die Daten aus der Warehouse-Datenbank in eine Cubestruktur organisiert.
ReportServer | Bei konfigurierter Berichterstellung | Hier werden Berichte und Berichtskonfigurationsdaten für Reporting Services gespeichert.
ReportServer_TempDB | Bei konfigurierter Berichterstellung | Hier werden temporäre Berichtsdaten für Reporting Services gespeichert.
WSS_Config | Bei konfigurierter Integration in SharePoint-Produkte | Hier werden Konfigurationsdaten für SharePoint-Produkte gespeichert.
WSS_Content | Bei konfigurierter Integration in SharePoint-Produkte | Hier wird der Inhalt für die Websites für SharePoint-Produkte gespeichert.
WSS_AdminContent | Bei konfigurierter Integration in SharePoint-Produkte | Hier werden die Verwaltungsinformationen für SharePoint-Produkte gespeichert.


SQL Server Reporting Services-Rollen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
SQL Server Reporting Services-Rollen
Siehe auch Feedback senden

Sie können die Rollen in SQL Server Reporting Services verwenden, um Visual Studio Team Foundation Server-Benutzern bestimmte Berechtigungen zuzuweisen. Allen Team Foundation Server-Benutzern und -Gruppen müssen geeignete Berechtigungen in Reporting Services zugewiesen werden. Reporting Services stellt durch Rollenzuweisungen eine Standardsicherheit bereit. Mit verschiedenen Verwaltungstools für SQL Server wie Management Studio und dem Berichts-Manager können Sie Benutzern und Gruppen vordefinierte Rollen zuweisen.

Mithilfe der Team Foundation Server-Gruppenmitgliedschaft können Sie die geeignete Mitgliedschaft in einer der in Reporting Services vordefinierten Rollen ermitteln. Es ist keine weitere Konfiguration der Rolle erforderlich. Sie können die vordefinierten Rollen jedoch ändern und benutzerdefinierte Rollen hinzufügen, um Ihren Geschäftsanforderungen besser gerecht zu werden. Wenn Sie benutzerdefinierte Rollen hinzufügen oder vordefinierte Rollen ändern, müssen Sie sicher stellen, dass die Rollen über die erforderlichen Berechtigungen für die entsprechende Zugriffsebene auf Berichte und Berichterstellungsfeatures verfügen. Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Erteilen von Berechtigungen für einen Berichtsserver im systemeigenen Modus.

Die folgenden vordefinierten Rollen werden zur Verwendung mit Team Foundation Server empfohlen:

  • Systemadministrator

  • Team Foundation-Inhalts-Manager

  • Browser

Weitere Informationen zu vordefinierten Rollen in Reporting Services finden Sie im folgenden Thema auf der Microsoft-Website: Verwenden vordefinierter Rollen.

Wichtiger Hinweis Wichtig

Sie sollten die Mitgliedschaft in Reporting Services auf die Benutzer begrenzen, für die die speziellen Zugriffsebenen und Berechtigungen, die durch die Mitgliedschaft in der entsprechenden vordefinierten Rolle gewährt werden, wirklich erforderlich sind. Fügen Sie Benutzer oder Gruppen der vordefinierten Rolle mit den minimalen Berechtigungen hinzu, die zum Ausüben der jeweiligen Rolle des Benutzers bzw. der Gruppe innerhalb eines Teamprojekts erforderlich sind. Wenn ein Benutzer beispielsweise nur den Projektzeitplan anzeigen muss, sollten Sie ihn der Rolle Browser, nicht jedoch der Rolle Inhalts-Manager hinzufügen.

Systemadministrator

Die Rolle Systemadministrator verfügt über Berechtigungen, die für den Administrator eines Berichtsservers hilfreich sind, der die Gesamtverantwortung für den Berichtsserver, jedoch nicht notwendigerweise für dessen Inhalte trägt. Die Rolle Systemadministrator verfügt möglicherweise nicht über so umfangreiche Berechtigungen wie ein lokaler Administrator eines Computers. Sie müssen Team Foundation-Administratoren sowohl der Rolle Systemadministrator als auch der Rolle Inhalts-Manager hinzufügen. Gemeinsam stellen diese beiden Rollendefinitionen den vollständigen Satz an Berechtigungen bereit, der für die Mitglieder der Team Foundation-Administratorgruppe erforderlich ist.

Team Foundation-Inhalts-Manager

Im Gegensatz zu den anderen in diesem Thema beschriebenen Rollen ist die Rolle "Team Foundation-Inhalts-Manager" keine Standardrolle in SQL Server. Die Rolle wird speziell für die Integration zwischen Team Foundation Server und SQL Server Reporting Services erstellt, wenn Team Foundation Server installiert ist. Die Rolle weist eine ähnliche Struktur und ähnliche Berechtigungen wie die Rolle "Inhalts-Manager" auf, die eine systemeigene Rolle in SQL Server ist. Die Rolle "Team Foundation-Inhalts-Manager" verfügt über Berechtigungen, die für Benutzer hilfreich sind, die Berichte und Webinhalte verwalten, jedoch nicht notwendigerweise Berichte schreiben oder einen Webserver bzw. eine Instanz von SQL Server verwalten. Ein Inhalts-Manager stellt Berichte bereit, verwaltet Berichtsmodelle sowie Datenquellenverbindungen und entscheidet, wie Berichte verwendet werden. Die Rolle "Team Foundation-Inhalts-Manager" stellt die Berechtigungen bereit, die üblicherweise für Benutzer erforderlich sind, die in einem Teamprojekt zur Gruppe der Projektadministratoren oder die zur Gruppe der Projektauflistungsadministratoren gehören. Sie sollten dieser Rolle auch Mitglieder der Team Foundation-Administratorgruppe hinzufügen.

Browser

Die Rolle Browser verfügt über Berechtigungen, die für Benutzer hilfreich sind, die Berichte anzeigen, sie jedoch nicht notwendigerweise schreiben oder verwalten. Diese Rolle stellt grundlegende Fähigkeiten für Benutzer bereit, die in einem Teamprojekt zur Gruppe der beteiligten Personen oder der Leser gehören.

Siehe auch

Konzepte

SQL Server und SQL Server Reporting Services


SQL Server-Sortierungsanforderungen für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

SQL Server-Sortierungsanforderungen für Team Foundation Server
Siehe auch Feedback senden

Beim Installieren von SQL Server sind zwei Punkte in Bezug auf Sortierungseinstellungen zu beachten, die sich auf die Team Foundation Server-Bereitstellung auswirken können:

  • Anforderungen für Team Foundation Server

  • Für alle Instanzen von SQL Server in der Team Foundation Server-Bereitstellung müssen dieselben Einstellungen festgelegt sein.

Sie können Sortierungseinstellungen für das Datenbankmodul und SQL Server Analysis Services festlegen. Sortierungseinstellungen schließen den Zeichensatz, die Sortierreihenfolge und weitere gebietsschemaspezifische Einstellungen ein, die für Struktur und Funktion von SQL Server-Datenbanken grundlegend sind. Nach der Installation können diese Einstellungen nicht mehr geändert werden.

Anforderungen für Team Foundation Server

Um mit Team Foundation Server arbeiten zu können, dürfen die Sortierungseinstellungen für SQL Server die Groß-/Kleinschreibung nicht berücksichtigen, müssen jedoch Akzente berücksichtigen und dürfen nicht binär sein. Wenn von mehreren SQL Server-Bereitstellungen eine Instanz des Datenbankmoduls oder von SQL Server Analysis Services für Team Foundation Server ausgeführt werden, müssen für alle diese Server dieselben Sortierungseinstellungen festgelegt sein.

SQL Server legt den standardmäßigen Sortierungseinstellungen das Gebietsschema des Betriebssystems zugrunde. Die Standardeinstellung für U.S.-Englisch und die meisten anderen Gebietsschemas erfüllt in den meisten Fällen die Anforderungen für Team Foundation Server. Diese Einstellungen unterstützen jedoch möglicherweise nicht alle Daten, die von Ihrem Unternehmen in Team Foundation Server gespeichert werden müssen. In einem solchen Fall müssen Sie nach einer Einstellung suchen, die die Daten unterstützt. Diese darf die Groß- und Kleinschreibung nicht beachten, muss jedoch Akzente berücksichtigen und nicht binär sein.

Wenn Sie Datenbankmoduldienste oder Analysis Services installieren, können Sie die Sortierungseinstellungen auf der Seite Serverkonfiguration ändern. Klicken Sie dazu auf die Registerkarte Sortierreihenfolge und anschließend auf Anpassen. Sie können eine Option unter Windows-Sortierungskennzeichner und -Sortierreihenfolge angeben. Sie können z. B. Latin1_General angeben und das Kontrollkästchen AS aktivieren, wenn Sie Unterstützung für zusätzliche Zeichen benötigen.

Für die meisten anderen Gebietsschemas ist die Standardeinstellung eine Option unter Windows-Sortierungskennzeichner und -Sortierreihenfolge. Stellen Sie sicher, dass die Einstellungen den Anforderungen für Team Foundation Server entsprechen. Wenn Sie diese Einstellung ändern müssen, sollten Sie nach Möglichkeit die Option angeben, auf deren Benennung im entsprechenden Gebietsschema "_100" folgt. Sie können beispielsweise die Sortierung "Japanese_100" auf folgende Weise mit Unicode CJK-Zeichen der Erweiterung A oder Unicode-Surrogaten verwenden:

  • Namen von Objekten in Team Foundation Server, wie z. B. Abfragen oder Projekte.

  • Dateien oder Pfade, die in das Versionskontrollsystem eingecheckt werden

  • Alle Arbeitsaufgabenfelder, die bei Suchvorgängen verwendet werden

Um eventuelle Probleme mit Zeichen in Doppelbreite bzw. Hiragana/Katakana-äquivalenten Zeichen zu vermeiden, sollten Sie beim Installieren von SQL Server die Kontrollkästchen für Kana und die Unterscheidung nach Breite aktivieren.

Weitere Informationen finden Sie auf der Microsoft-Website unter Sortierungseinstellungen im Setup-Programm.

Volltextsuchabfragen und Sortierungseinstellungen

Um Abfragen für eine Volltextsuche zu unterstützen, müssen die Sortierungseinstellungen der SQL Server-Datenbank einer Sprache entsprechen, die über eine Wörtertrennung verfügt, die in SQL Server registriert ist. Wenn Sie eine nicht unterstützte Sprache verwenden und eine Arbeitsaufgabenabfrage ausführen, die Contains oder Contains Words-Operatoren mit Textzeichenfolgen angibt, könnten Sie unerwartete Ergebnisse erhalten.

Einige Sprachen haben Wörtertrennungen von Drittanbietern, die Sie installieren und registrieren können. Sie können ALTER FULLTEXT INDEX verwenden, um eine andere Sprache als die Standardsprache (US-Englisch) anzugeben, wenn Sie den Index für die Volltextsuche erstellen.

Weitere Informationen finden Sie in einem der folgenden Themen:

  • Volltextsuche (SQL Server)

  • sys.fulltext_languages (Transact-SQL)

  • ALTER FULLTEXT INDEX (Transact-SQL)

  • SQL Server 2008-Volltextsuche: Interne Funktionen und Erweiterungen

  • Abfragefelder, Operatoren, Werte und Variablen

Siehe auch

Konzepte

Manuelle Installation von SQL Server für Team Foundation Server
Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Aktualisieren von Team Foundation Server


Gewusst wie: Aktualisieren von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Aktualisieren von Team Foundation Server
Feedback senden

Überprüfen Sie die hier aufgeführten Anforderungen, und wählen Sie dann einen Serverupgradepfad aus. Team Foundation Server ist eine Aktivierungsveröffentlichung und wird durch Upgrades über RTM unterstützt. Sie können eine der folgenden früheren Versionen aktualisieren:

  • Vorschau für Entwickler, Beta- oder RC-Version von Team Foundation Server 2012

  • Team Foundation Server 2010 mit oder ohne Service Pack 1

  • Team Foundation Server 2008 mit Service Pack 1

Tipp Tipp

Wir verfügen über ein End-to-End-Upgradehandbuch, das alle Schritte zum Aktualisieren von Team Foundation Server enthält, darunter auch das Bereitstellen von neuen Buildcomputern und Aktivieren von neuen Funktionen für die aktualisierten Projekte. Siehe: Aktualisieren von Team Foundation Server.

Neue erforderliche Komponenten

SQL Server: Bevor Sie das Upgrade beginnen, müssen Sie möglicherweise SQL Server aktualisieren, um neue Team Foundation Server-Anforderungen zu erfüllen. SQL Server 2008 wird nicht mehr unterstützt. SQL Server 2008 R2 und SQL Server 2012 werden unterstützt. Weitere Informationen finden Sie unter SQL Server-Anforderungen für Team Foundation Server.

SharePoint-Produkte: Wenn Sie über einen Portalserver verfügen, können Sie diesen weiterhin verwenden, ohne ihn zu aktualisieren. Alle zuvor unterstützten Versionen von SharePoint-Produkten werden unterstützt, einschließlich Windows SharePoint Services 3.0, Microsoft Office SharePoint Server 2007, Microsoft SharePoint Foundation oder Microsoft SharePoint Server 2010. Weitere Informationen finden Sie unter Anforderungen von SharePoint-Produkten für Team Foundation Server.

Kann die Berichterstellung oder SharePoint während des Upgrades übersprungen werden?

Sie können die Bereitstellung vereinfachen und diese Funktionen überspringen; das sollten Sie aber nur tun, wenn Sie die Berichterstellung oder SharePoint nicht mehr verwenden möchten. Andernfalls lassen Sie diese beiden Funktionen während des Upgrades aktiviert. Die Upgradekonfiguration verknüpft automatisch aktualisierte Projekte mit dem Portal und den Berichtsfunktionen. Wenn Sie ein Portal oder die Berichterstellung nach dem Upgrade hinzufügen, wird die Erstellung dieser Links zwischen den aktualisierten Projekten und dem Portal schwieriger.

Nächster Schritt: Auswählen eines Serverupgradepfads

Nachdem das Upgrade des Servers abgeschlossen ist, möchten Sie die Anwendungsebene des Team Foundation Server 2012 verwenden:

Upgrade von TFS und Beibehalten der gleichen Hardware | Upgrade von TFS und Verschieben auf neue Hardware
Installieren Sie TFS auf derselben Hardware | installieren Sie TFS auf anderer Hardware
Tipp Tipp

Wenn Sie eine TFS-Basisinstallation (SQL Server Express, keine Berichterstellung, kein SharePoint) aktualisieren möchten, ist diese vereinfachte Vorgehensweise optimal für Sie: Upgrade von TFS Basic oder Express

Upgradeanweisung, die Sie wahrscheinlich überspringen können

Wenn Sie keine Team Foundation Server-Farm verwenden und keines der Teammitglieder Project Server verwendet, können Sie diesen Abschnitt wahrscheinlich überspringen.

Aktualisieren einer Team Foundation Server-Farm

Wenn Sie eine Team Foundation Server-Bereitstellung, die Sie aktualisieren möchten, horizontal skaliert haben, sollten Sie eine der Anwendungsebenen auswählen und das Upgrade auf die gleiche Weise wie für eine eigenständige Bereitstellung ausführen. Wählen Sie eine beliebige Anwendungsebene in der Farm aus. Wenn das Upgrade abgeschlossen ist, deinstallieren Sie die alte Version von Team Foundation Server von allen verbleibenden Mitgliedern der Farm, und installieren Sie anschließend Team Foundation Server 2012 mithilfe des Assistenten zum Hinzufügen von Anwendungsebenen. Dadurch wird die Farm wieder zusammengesetzt und das Farmupgrade abgeschlossen. Weitere Informationen finden Sie unter dem Thema: Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit)

Aktualisieren der TFS-Erweiterungen für Project Server

Wenn Project Server mit der TFS-Bereitstellung integriert wurde und Sie TFS aktualisieren, sollten die Teamprojekte weiterhin wie zuvor funktionieren, Sie können jedoch auf keine der neuen Funktionen zugreifen, bis Sie die neuen TFS-Erweiterungen für Project Server installieren. Sie sollten die alten Erweiterungen in Project Server deinstallieren und die neueste Version der Erweiterungen auf allen Servern installieren, auf denen diese zuvor installiert waren. Die Version der Erweiterungen, die Sie für Project Server verwenden, sollte immer mit der ausgeführten Version von Team Foundation Server übereinstimmen. Weitere Informationen finden Sie unter dem Thema Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server.


Gewusst wie: Installieren des Team Foundation Build-Diensts

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Installieren des Team Foundation Build-Diensts
Siehe auch Feedback senden

Wenn Sie Builds der Softwareprojekte automatisieren möchten, können Sie den Team Foundation-Builddienst von der Team Foundation Server-Produkt-DVD installieren und einen Buildcomputer erstellen. Nachdem der Buildcomputer eingerichtet wurde, möchten Sie möglicherweise eine Builddefinition in Visual Studio mit Anweisungen darüber erstellen, welche Codeprojekte zu kompilieren sind und viele andere Konfigurationen. Zunächst jedoch müssen Sie den Buildcomputer einrichten.

Team Foundation-Builddienst installieren

Die wichtigste Aufgabe bei der Installation besteht darin, die passende Hardware auszuwählen, um die optimale Leistung zu erzielen (Empfehlungen finden Sie weiter unten). Wenn Ihr Team Windows-Apps erstellt, müssen Sie den Builddienst auf Windows 8 installieren. Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Erstellen und Testen einer Windows-App mit Team Foundation Build. Alle Einstellungen, die Sie während der Erstkonfiguration des Team Foundation-Builddienstes auswählen, können Sie nach der Installation ändern. Sie müssen somit nicht befürchten, eine falsche Auswahl zu treffen, die sich nicht mehr rückgängig machen lässt. Eine umfassende Erläuterung der Architektur des Team Foundation Builddiensts und aller möglichen Topologien finden Sie im folgenden Thema auf der Microsoft-Website: Team Foundation Build-System.

Obwohl Sie den Team Foundation-Builddienst auf demselben Computer wie Team Foundation Server installieren können, sollten Sie dies nach Möglichkeit unterlassen. Sie möchten die Leistung von Team Foundation Server nicht beeinträchtigen oder die Angriffsfläche vergrößern, wenn Builds ausgeführt werden.

Tipp Tipp

Wenn Sie einen Buildcomputer von Team Foundation Server 2010 auf die aktuelle Version aktualisieren, müssen Sie die frühere Version des Team Foundation-Builddiensts nicht sofort entfernen. Beide Versionen können parallel ausgeführt werden. Wenn Sie eine TFS-Installation aktualisieren, die SSL-gesichert ist, denken Sie daran, den neuen Buildserver so zu konfigurieren, dass er SSL-Ports verwendet, bevor Sie versuchen, eine Verbindung mit einer SSL-gesicherten Anwendungsebene herzustellen. Weitere Informationen finden Sie unter: So ändern Sie eine Build-Konfiguration für HTTPS

So installieren Sie den Team Foundation-Builddienst

Schritt 1 Stellen Sie sicher, dass das Betriebssystem und die Hardware den Anforderungen des Team Foundation-Builddiensts entspricht. Standardgemäß verwendet Team Foundation-Builddienst einen Netzwerkdienst für das Dienstkonto (TFSBUILD). Wenn Sie eine Verbindung mit der Team Foundation-Dienstvorschau herstellen möchten, benötigen Sie auch das Microsoft-Konto, das Sie für die Einrichtung des gehosteten Diensts verwendet haben.

Weitere Informationen finden Sie unter: Systemanforderungen für den Team Foundation Build-Dienst, Erforderliche Konten für die Installation von Team Foundation Server.

Schritt 2 Führen Sie das Team Foundation Server-Installationsprogramm von der Produkt-DVD aus, und verwenden Sie anschließend den Konfigurations-Assistenten für Builddienste, um Ihre Installation zu konfigurieren. Mit diesem Assistenten wird der Team Foundation-Builddienst installiert und konfiguriert.

Team Foundation Server-Build installieren

Weitere Informationen finden Sie unter: Ausführen der Team Foundation Server-Installation, Konfigurieren des Team Foundation Build-Diensts mithilfe des Team Foundation Server-Konfigurationstools

Tipp Tipp

Laden Sie die aktuelle Version dieses Handbuchs von der folgenden Seite auf der Microsoft-Website herunter: Installationshandbuch für Team Foundation, alle aktuellen Änderungen an diesem Schritt anzuzeigen.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Aktualisieren von Team Foundation Server


Systemanforderungen für den Team Foundation Build-Dienst

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Systemanforderungen für den Team Foundation Build-Dienst
Siehe auch Feedback senden

Sie können den Team Foundation-Builddienst auf vielen verschiedenen Betriebssystemen installieren, was bei Team Foundation Server nicht der Fall ist:

Serverbetriebssysteme: ¹

  • 64-Bit-Version von Windows Server 2008 (Standard oder Enterprise Edition)

  • 64-Bit-Version von Windows Server 2008 R2 (Standard oder Enterprise Edition)

  • 64-Bit-Version von Windows Server 2012

Clientbetriebssysteme:

  • 32-Bit- und 64-Bit-Versionen von Windows 7 (Home Premium, Professional, Enterprise oder Ultimate Edition)

  • 32-Bit- und 64-Bit-Versionen von Windows 8

¹ Team Foundation-Builddienst unterstützt nicht die Server Core-Installationsoption.

Hardwareempfehlungen

Die Hardwareanforderungen für den Team Foundation-Builddienst entsprechen denen für das zugrunde liegende Betriebssystem. Sie können demnach die Leistung Ihres Buildcomputers optimieren, indem Sie den Team Foundation-Builddienst für die Hardware installieren, und zwar in Abhängigkeit, wie Ihr Team Builds automatisieren möchte.

Um die Hardwareoptimierung zu verstehen, sollten Sie die Grundlagen der Builddienst-Architektur kennen. Wenn Sie den Team Foundation-Builddienst mit den Standardeinstellungen installieren, erstellen Sie einen Buildcomputer mit einem Buildcontroller und einem einzelnen Build-Agent. Buildcontroller stellen eine Verbindung vom Buildcomputer mit Team Foundation Server her. Wenn Sie gleichzeitig mehrere Builds ausführen, können Buildcontroller beträchtlichen Speicherplatz erfordern. Da die Build-Agents wiederum die prozess- und datenträgerintensiven Arbeitsschritte ausführen, sollten Sie sicherstellen, dass die CPU auf dem Buildcomputer leistungsstark genug ist, sodass die Build-Agents die Aufgaben in einem akzeptablen Zeitraum ausführen können.

Um die erforderliche Mindestmenge an Speicherplatz zu bestimmen, müssen Sie die Größe der Gesamtquellkonfiguration bestimmen und dazu die Größe aller Zwischenausgaben und Binärdateien aus dem Buildprozess addieren. Multiplizieren Sie diesen berechneten Wert mit der Anzahl der Builddefinitionen, die wahrscheinlich auf einem bestimmten Server erstellt werden, und verdoppeln Sie diese Zahl, um die mindestens erforderliche Menge an verfügbarem Speicherplatz für diesen Server zu bestimmen.

Tipp Tipp

Setzen Sie einen Server mit schnellen Festplatten ein. Dies ist eine kostengünstige Möglichkeit, die Buildleistung zu verbessern. Die Verwendung von Hardware mit Multikern-CPUs stellt eine weitere Möglichkeit dar, die Leistung des Team Foundation-Builddienstes zu maximieren.

Verwenden eines Servers oder mehrerer Server

Sie können die Buildfrequenz als Maß verwenden, um die Höhe der Hardwareinvestitionen für den Team Foundation-Builddienst festzulegen. Wenn das Team wöchentliche oder nächtliche Builds ausführt, darf das Installieren des Team Foundation- Builddienstes auf dem Server, auf dem auch Team Foundation Server ausgeführt wird, keine negativen Auswirkungen auf die Produktivität haben. Wenn das Team jedoch parallele Builds oder fortlaufende Integrationsbuilds ausführt oder wenn Sie eine Kompilierungsstelle für mehrere Teams erstellen möchten, empfiehlt es sich, den Team Foundation-Builddienst auf einem eigenen Server oder möglicherweise sogar auf mehreren Servern zu installieren.

Weitere Überlegungen

Sie können eine Netzwerkfreigabe als Ablageordner einrichten, in dem Builds gespeichert werden. Wegen der Einschränkungen für den gleichzeitigen Dateizugriff auf Nicht-Serverbetriebssysteme müssen Sie diesen Ordner auf einem Computer erstellen, auf dem ein unterstütztes Serverbetriebssystem ausgeführt wird. Dieser Ordner muss sich nicht auf demselben Server wie der Team Foundation-Builddienst befinden. Weitere Informationen: Einrichten von Ablageordnern

Siehe auch

Konzepte

Gewusst wie: Installieren des Team Foundation Build-Diensts


Konfigurieren des Team Foundation Build-Diensts mithilfe des Team Foundation Server-Konfigurationstools

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren des Team Foundation Build-Diensts mithilfe des Team Foundation Server-Konfigurationstools
Siehe auch Feedback senden

Mit diesem Verfahren können Sie den Team Foundation-Builddienst mit den Standardoptionen konfigurieren.

Tipp Tipp

Sie können über das Menü Start auf das Team Foundation Server-Konfigurationstool zugreifen, indem Sie die Team Foundation Server-Verwaltungskonsole starten und dann Anwendungsebene und Installierte Funktionen konfigurieren auswählen.

Erforderliche Berechtigungen

Zum Ausführen dieses Verfahrens müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Team Foundation-Builddienstkonfiguriert wird. Sie müssen Mitglied der Gruppe "Projektauflistungsadministratoren" auf TFS sein. Wenn Sie eine Verbindung mit einer Auflistung in der Team Foundation-Dienstvorschau herstellen möchten, benötigen Sie auch das Microsoft-Konto, das Sie für die Einrichtung des gehosteten Diensts verwendet haben.

So konfigurieren Sie den Team Foundation-Builddienst

  1. Wählen Sie Team Foundation-Builddienst konfigurieren und dann Assistent starten.

    Der Builddienstkonfigurations-Assistentwird angezeigt.

  2. Lesen Sie die Willkommensseite, und wählen Sie dann Weiter aus.

  3. Wählen Sie Durchsuchen und anschließend die Teamprojektsammlung, mit der dieser Buildcontroller eine Verbindung herstellen soll. Wenn sich die Teamprojektsammlung auf dem gehosteten Dienst befindet, werden Sie zur Authentifizierung aufgefordert. Geben Sie das Microsoft-Konto ein, das Sie für die Einrichtung des Diensts verwendet haben. Wählen Sie Weiter aus.

  4. Führen Sie einen der folgenden Schritte aus, und wählen Sie anschließend Weiter aus:

    • Wählen Sie Standardeinstellung verwenden, und geben Sie die Anzahl von Build-Agents an.

      Wenn Sie Team Foundation-Builddienst auf dem gleichen Server wie Team Foundation Server installiert haben oder den gehosteten Dienst verwenden, ist die Standardeinstellung für Anzahl der auf diesem Buildcomputer auszuführenden Build-Agents der Wert 1 (empfohlen).

    • Wählen Sie Builddienste erweitern aus, um gleichzeitige Buildvorgänge auf mehreren Computern auszuführen. Wenn Sie diese Option auswählen, müssen Sie die Anzahl von Build-Agents für diesen Computer angeben und die Build-Agents dann einem neuen oder vorhandenen Buildcontroller hinzufügen.

      Wenn Sie Team Foundation-Builddienst auf einem eigenen Server installiert haben, ist die Standardeinstellung für Anzahl der auf diesem Buildcomputer auszuführenden Build-Agents gleich der Anzahl der Prozessorkerne auf diesem Server.

    • Wählen Sie Vorhandenen Buildcomputer ersetzen, und geben Sie dann den zu ersetzenden Buildcomputer an.

    • Wählen Sie Später konfigurieren aus, um die Einrichtung von Buildcontrollern und Build-Agents in dieser Instanz von Team Foundation-Builddienst zu überspringen.

      Wenn Sie diese Option auswählen, müssen Sie den Buildcontroller manuell mit Team Foundation Server verbinden, damit Sie den Buildcomputer verwenden können.

  5. Führen Sie unter der Option Team Foundation Builddienst ausführen als einen der folgenden Schritte aus, und klicken Sie dann auf Weiter:

    • Wählen Sie Systemkonto verwenden und anschließend ein Systemkonto aus.

      Klicken Sie z. B. auf NT-Autorität\Netzwerkdienst, um den Netzwerkdienst zu verwenden.

    • Wählen Sie Benutzerkonto verwenden, um ein Domänenkonto oder ein lokales Konto zu verwenden, und geben Sie anschließend den Kontonamen und ein Kennwort ein. Wählen Sie Test, um das Benutzerkonto und das Kennwort zu testen.

    Ist dieser Buildcomputer mit dem gehosteten Dienst verbunden, wird Ihnen unter Erweiterte Konfiguration die Option Kontoname angezeigt.

    Wenn Sie die Instanz von Team Foundation Server auf dem gehosteten Dienst erstellt haben, wurde ein Kontoname automatisch für Sie erstellt. Dieses Konto wird der Gruppe Builddienstkonten für die Projektauflistung im gehosteten Dienst automatisch hinzugefügt. Wenn Sie ein anderes Konto erstellen möchten, rufen Sie die Verwaltungsseite auf der gehosteten Site auf. Weitere Informationen finden Sie unter diesem Thema.

  6. Überprüfen Sie die Informationen, und wählen Sie dann Weiter aus.

    Die Konfiguration wird überprüft.

  7. Wählen Sie Konfigurieren aus.

    Die Konfigurationseinstellungen werden angewendet.

  8. Wählen Sie Weiter aus.

  9. Wählen Sie Schließen aus.

  10. Wählen Sie Schließen aus.

    Die Team Foundation Server-Verwaltungskonsole wird angezeigt.

Siehe auch

Konzepte

Gewusst wie: Installieren des Team Foundation Build-Diensts


Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server
Siehe auch Feedback senden

Installieren der Team Foundation Server-Erweiterungen für SharePoint-Produkte auf einem Remoteserver

Erweiterungen auf Remoteportal installieren

Wenn Sie SharePoint-Produkte auf einem anderen als dem Team Foundation Server ausführen möchten, müssen Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte von der Team Foundation Server-DVD installieren.

Als Neuheit in dieser Version von Team Foundation Server können Sie SharePoint Foundation 2010 während der Erweiterungskonfiguration installieren und konfigurieren. Wenn Sie über einen vorhandenen Server verfügen, auf dem SharePoint-Produkte ausgeführt wird, können Sie wie in früheren Versionen nur die Erweiterungen auf diesem Server installieren und konfigurieren. In dieser Version von Team Foundation Server stellt die Erweiterungskonfiguration allerdings automatisch eine SharePoint-Webanwendung für Sie bereit. Diesen Prozess mussten Kunden in früheren Versionen manuell konfigurieren. Ebenfalls neu - Sie können die Erweiterungen getrennt von den übrigen Team Foundation Server-Installationsdateien installieren. Dies ist hilfreich, wenn Sie SharePoint-Administratoren außerhalb Ihrer Organisation überzeugen müssen, die Erweiterungen auf einer SharePoint-Serverfarm zu installieren.

Fügen Sie nach der Team Foundation Server-Installation das Portal für die SharePoint-Produkte hinzu.

Zusätzlich zum Einrichten von SharePoint-Remoteprodukten können Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte verwenden, um einer Installation von Team Foundation Server ein Portal hinzuzufügen, nachdem sie bereits installiert und konfiguriert wurde.

So installieren Sie Team Foundation Server-Erweiterungen für SharePoint-Produkte

Schritt 1 Stellen Sie sicher, dass das Betriebssystem und die Hardware oder die vorhandene Installation der SharePoint-Produkte den Anforderungen der Team Foundation Server-Erweiterungen für SharePoint-Produkte entspricht. Wenn Sie SharePoint Foundation 2010 nicht verwenden möchten, können Sie eine beliebige unterstützte Version von SharePoint-Produkte installieren. Wenn Sie die Enterprise-Version von SharePoint Office 2007 oder SharePoint Server 2010 installieren, müssen Sie sie für Dashboards konfigurieren.

Weitere Informationen finden Sie unter: Anforderungen von SharePoint-Produkten für Team Foundation Server, Überprüfen von SharePoint-Produkten für Team Foundation Server, Manuelle Installation von SharePoint-Produkten für Team Foundation Server auf Windows Server, Konfigurieren der Enterprise Editionen von SharePoint Server 2010 oder Office SharePoint Server 2007 für eine Dashboardkompatibilität.

Schritt 2 Führen Sie das Team Foundation Server-Installationsprogramm von der Produkt-DVD aus, und verwenden Sie anschließend die Team Foundation Server-Erweiterungen für den Konfigurations-Assistenten für SharePoint-Produkte, um Ihre Installation zu konfigurieren. Dieser Assistent installiert und konfiguriert die Erweiterungen und SharePoint Foundation 2010, wenn Sie möchten.

Fügen Sie das Dienstkonto, das für Team Foundation Server (TFSSERVICE) verwendet wird, zur Gruppe "Farmadministratoren" hinzu.

Weitere Informationen finden Sie unter: Ausführen der Team Foundation Server-Installation, Konfigurieren von Team Foundation Server-Erweiterungen für SharePoint-Produkte, Hinzufügen des Dienstkontos für Team Foundation Server zur Gruppe Farmadministratoren.

Tipp Tipp

Wenn Sie nicht alle Komponenten von Team Foundation Server auf dem Server installieren möchten, auf dem SharePoint-Produkte ausgeführt wird, wählen Sie auf dem Team Foundation Server-Begrüßungsbildschirm die Option zur Installation der SharePoint-Remoteerweiterungen aus.

Schritt 3 Wenn Sie die Enterprise-Version von SharePoint Office 2007 oder SharePoint Server 2010 installiert haben, müssen Sie einige abschließende Konfigurationen in den Erweiterungen vornehmen. Führen Sie diesen Schritt erst aus, nachdem Sie Team Foundation Server installiert haben.

Weitere Informationen finden Sie unter: Konfigurieren der Unternehmensanwendungsdefinition für Team Foundation Server.

Tipp Tipp

Laden Sie die neueste Version des Installationshandbuchs für Team Foundation Server herunter, um sich über aktuelle Änderungen an diesen Schritten zu informieren.

Siehe auch

Konzepte

Gewusst wie: Aktualisieren von Team Foundation Server


Konfigurieren von Team Foundation Server-Erweiterungen für SharePoint-Produkte

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Team Foundation Server-Erweiterungen für SharePoint-Produkte
Siehe auch Feedback senden

Wenn SharePoint-Produkte sich nicht auf dem Server befindet, auf dem Team Foundation Server ausgeführt wird, verfügen Sie über ein Remoteportal. Wenn dies der Fall ist, müssen Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte auf dem Remoteportal installieren und konfigurieren.

Wenn mehrere Server in einer Webfarm ausgeführt werden, müssen Sie die Erweiterungen auf jedem Server in der Farm installieren und konfigurieren. Nach dem Installieren der Erweiterungen müssen Sie auf jedem Server die folgenden Konfigurationsschritte ausführen. Während der Konfiguration wird eventuell eine Fehlermeldung angezeigt, in der Sie aufgefordert werden zu überprüfen, ob die Erweiterungen auf jedem Server in der Farm installiert wurden. Sie können diesen Fehler gefahrlos ignorieren. Nachdem die Erweiterungen auf jedem Server installiert und konfiguriert wurden, wird dieser Fehler nicht mehr angezeigt.

Tipp Tipp

Sie können über das Menü Start auf das Team Foundation Server-Konfigurationstool zugreifen, indem Sie die Team Foundation Server-Verwaltungskonsole starten und dann Anwendungsebene und Installierte Funktionen konfigurieren auswählen.

Erforderliche Berechtigungen

Um diese Vorgehensweise ausführen zu können, müssen Sie Mitglied der Gruppe Farmadministratoren der SharePoint-Produkte-Verwaltungswebsite sein.

So konfigurieren Sie Team Foundation Server-Erweiterungen für SharePoint-Produkte

  1. Klicken Sie im Tool Team Foundation Server-Konfiguration auf Erweiterungen für SharePoint-Produkte und -Technologien konfigurieren und dann auf Assistent starten.

    Der Assistent SharePoint-Erweiterungskonfiguration für Team Foundation Server wird angezeigt.

  2. Lesen Sie die Willkommensseite, und wählen Sie dann Weiter aus.

  3. Wenn SharePoint-Produkte installiert ist, wechseln Sie zum nächsten Schritt. Wenn SharePoint nicht installiert ist, führen Sie die folgenden Schritte aus:

    1. Klicken Sie auf die große Schaltfläche SharePoint Foundation 2010 installieren. Wählen Sie Weiter aus, wenn die Installation abgeschlossen ist.

    2. Geben Sie den Namen des SQL Server-Computers oder der benannten Instanz ein, die die Konfigurationsdatenbanken für SharePoint Foundation 2010 hostet, und wählen Sie Weiter aus.

    3. Geben Sie ein Benutzerkonto und das Kennwort für das Dienstkonto von SharePoint Foundation 2010 (WSSSERVICE) ein, und wählen Sie dann Weiter aus.

      Weitere Informationen finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

  4. Überprüfen Sie auf der Seite Überprüfen die Einstellungen, und wählen Sie Weiter aus.

    Die Konfiguration wird überprüft.

  5. Wählen Sie Konfigurieren aus.

    Die Konfigurationseinstellungen werden angewendet. Dieser Prozess kann mehrere Minuten in Anspruch nehmen.

  6. Wählen Sie Weiter aus.

  7. Wählen Sie Schließen aus.

  8. Wählen Sie Schließen aus.

Die Team Foundation Server-Verwaltungskonsole wird angezeigt.

Siehe auch

Konzepte

Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server
Gewusst wie: Aktualisieren von Team Foundation Server


Hinzufügen des Dienstkontos für Team Foundation Server zur Gruppe Farmadministratoren

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Hinzufügen des Dienstkontos für Team Foundation Server zur Gruppe Farmadministratoren
Siehe auch Feedback senden

Sie müssen das Dienstkonto für Team Foundation Server (TFSSERVICE) auf der SharePoint-Produkte-Website der Gruppe "Farmadministratoren" hinzufügen. Wenn Sie den Netzwerkdienst für TFSSERVICE verwenden und SharePoint-Produkte nicht auf demselben Server wie Team Foundation Server ausgeführt werden, müssen Sie statt des Netzwerkdiensts den Computernamen des Servers hinzufügen, auf dem Team Foundation Server ausgeführt wird. Der erforderliche Computername besteht aus dem Servernamen, gefolgt von dem Symbol $ (z. B. Domäne\Servername$).

Weitere Informationen zu Dienstkonten finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem SharePoint-Produkte-Server sein.

So fügen Sie der Gruppe Farmadministratoren in SharePoint Foundation 2010 oder SharePoint Server 2010 das Dienstkonto für Team Foundation Server hinzu

  1. Öffnen Sie in einem Webbrowser die Website für die SharePoint-Zentraladministration.

  2. Wählen Sie unter "Sicherheit" die Option Farmadministratorgruppe verwalten.

  3. Wählen Sie Neu aus.

  4. Geben Sie im Feld Benutzer/Gruppen den Namen des Dienstkontos für Team Foundation Server (TFSSERVICE) ein.

  5. Klicken Sie auf OK.

So fügen Sie der Gruppe Farmadministratoren in Windows SharePoint Server 3.0 oder Office SharePoint 2007 das Dienstkonto für Team Foundation Server hinzu

  1. Öffnen Sie in einem Webbrowser die Website für die SharePoint-Zentraladministration.

  2. Wählen Sie die Registerkarte Vorgänge aus.

  3. Klicken Sie unter Sicherheitskonfiguration auf Farmadministratorgruppe aktualisieren.

  4. Wählen Sie unter Gruppen die Option Farmadministratoren.

  5. Wählen Sie Neu aus.

  6. Geben Sie im Feld Benutzer/Gruppen den Namen des Dienstkontos für Team Foundation Server (TFSSERVICE) ein.

  7. Klicken Sie auf OK.

Hinweis Hinweis

Wenn sich der SharePoint-Produkte-Server nicht auf dem Team Foundation Server-Server befindet, verfügen Sie über ein Remoteportal. Wenn Sie dies der Fall ist, müssen Sie der Gruppe "Farmadministratoren" auch das Konto hinzufügen, mit dem Team Foundation Server installiert wird.

Siehe auch

Konzepte

Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server


Anforderungen von SharePoint-Produkten für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Anforderungen von SharePoint-Produkten für Team Foundation Server
Feedback senden

SharePoint-Produkte sind für Team Foundation Server nicht erforderlich. Wenn Sie SharePoint-Produkte verwenden möchten, müssen Sie eine unterstützte Version mit der Team Foundation Server-Erweiterung für SharePoint-Produkte verwenden. Sie verfügen über mehrere Möglichkeiten:

  • Sie können den Team Foundation Server-Assistenten für die Standardkonfiguration oder den Assistenten für die erweiterte Konfiguration verwenden, um SharePoint Foundation 2010 auf demselben Server wie Team Foundation Server zu installieren. Die Team Foundation Server-Erweiterungen für SharePoint-Produkte werden während der Installation von Team Foundation Server automatisch installiert.

  • Sie können Team Foundation Server-Erweiterungen verwenden, sodass der Konfigurations-Assistent für SharePoint-Produkte SharePoint Foundation 2010 auf einem anderen Server als Team Foundation Server installiert.

  • Sie können Office SharePoint Server 2007 oder SharePoint Server 2010 verwenden. Wenn Sie die Enterprise-Version dieser Produkte verwenden, müssen Sie diese für Dashboardkompatibilität konfigurieren. Weitere Informationen zu Dashboardanforderungen finden Sie unten.

  • Sie können Windows SharePoint Services 3.0 verwenden. Obwohl Team Foundation Server keine Service Pack-Anforderungen für SharePoint-Produkte besitzt, weisen bestimmte Betriebssysteme Anforderungen für Windows SharePoint Services 3.0 auf.

Unabhängig von der ausgewählten Option müssen für die SharePoint-Produkte die folgenden Anforderungen erfüllt sein:

Unterstützte Versionen, Editionen

  • SharePoint Foundation 2010

  • SharePoint Server 2010, Enterprise Edition

  • SharePoint Server 2010, Standard Edition

  • Office SharePoint Server 2007, Enterprise Edition

  • Office SharePoint Server 2007, Standard Edition

  • Windows SharePoint Services 3.0

Authentifizierung

NTLM wird für die Authentifizierung empfohlen. Standardauthentifizierungen oder anonyme Authentifizierung werden von Team Foundation Server-Erweiterungen für SharePoint-Produkte nicht unterstützt.

Dashboardanforderungen

Team Foundation Server enthält Dashboards, die SharePoint-Produktfunktionen verwenden, um Teamdaten anzuzeigen. Welche Dashboards verfügbar sind, hängt von der installierten Version der SharePoint-Produkte ab.

  • Wenn Sie die Enterprise Edition von Office SharePoint Server 2007 oder SharePoint Server 2010 installieren, können Sie fünf Dashboards verwenden, die mit auf Microsoft Excel basierenden Berichten konfiguriert sind.

  • Wenn Sie Office SharePoint Server 2007 Standard, SharePoint Server 2010 Standard oder Windows SharePoint Services 3.0 installieren, können Sie zwei Dashboards verwenden, die mit auf SQL Server Reporting Services basierenden Berichten konfiguriert sind.

Bereitstellungsverweise auf SharePoint-Produkte

SharePoint-Produkte verfügen über eigene erforderliche Komponenten für die Bereitstellung.

  • Weitere Informationen zum Bereitstellen und Konfigurieren von SharePoint Server 2010 finden Sie auf der folgenden Seite der Microsoft-Website: Bereitstellung von SharePoint Server 2010

  • Weitere Informationen zum Bereitstellen und Konfigurieren von Office SharePoint Server 2007 finden Sie auf der folgenden Seite der Microsoft-Website: Deployment for Office SharePoint Server 2007

  • Weitere Informationen zum Bereitstellen und Konfigurieren von Windows SharePoint Services 3.0 finden Sie auf der folgenden Seite der Microsoft-Website: Bereitstellung der Windows SharePoint Services 3.0-Technologie

Service Pack-Anforderungen für SharePoint-Produkte

Team Foundation Server hat keine Service Pack-Anforderungen für SharePoint-Produkte. Für bestimmte Betriebssysteme gelten jedoch Anforderungen für Windows SharePoint Services 3.0.

Wenn Sie Windows Server 2008 ausführen, müssen Sie ein Installationsprogramm für Windows SharePoint Services 3.0 mit einem bereits hinzugefügten Service Pack herunterladen (Service Pack 1 für Windows Server 2008 oder Service Pack 2 für Windows Server 2008 R2). Aus Gründen der Benutzerfreundlichkeit sind im Folgenden die Links zum 32-Bit- und 64-Bit-Installationsprogramm für Windows SharePoint Services 3.0 mit dem neuesten Service Pack auf der Microsoft-Website aufgeführt:

  • Windows SharePoint Services 3.0 mit Service Pack 2

  • Windows SharePoint Services 3.0 x64 mit Service Pack 2

Für Windows Server 2003 gelten zwar nicht dieselben Anforderungen wie für Windows Server 2008, das neueste Service Pack wird jedoch empfohlen.

Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 haben keine Betriebssystemanforderungen in Bezug auf Service Packs und Team Foundation Server.

So installieren Sie SharePoint-Produkte für Team Foundation Server

Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server

Sie können Team Foundation Server-Erweiterungen verwenden, sodass der Konfigurations-Assistent für SharePoint-Produkte SharePoint Foundation 2010 auf einem anderen Server als Team Foundation Server installiert.

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration

Sie können die Team Foundation Server-Standardkonfigurations-Assistenten verwenden, um SharePoint Foundation 2010 auf demselben Server wie Team Foundation Server zu installieren. Die Team Foundation Server-Erweiterungen für SharePoint-Produkte werden während der Installation von Team Foundation Server automatisch installiert.

Weitere Aufgaben mit SharePoint-Produkten für Team Foundation Server

Manuelle Installation von SharePoint-Produkten für Team Foundation Server auf Windows Server

Installieren Sie SharePoint Server 2010, Office SharePoint Server 2007 oder Windows SharePoint Services 3.0 für die gemeinsame Verwendung mit Team Foundation Server.

Konfigurieren der Enterprise Editionen von SharePoint Server 2010 oder Office SharePoint Server 2007 für eine Dashboardkompatibilität

Enthält Schritte für das Konfigurieren der Enterprise-Edition von Microsoft Office SharePoint Server 2007 oder Microsoft SharePoint Server 2010, sodass die Dashboardfunktionalität ausgeführt wird, nachdem Sie Team Foundation Server installiert haben.

Hinzufügen des Dienstkontos für Team Foundation Server zur Gruppe Farmadministratoren

Sie müssen der Gruppe "Farmadministratoren" auf der SharePoint-Produkte-Website das Dienstkonto für Team Foundation Server hinzufügen. Dies wird von Team Foundation Server automatisch konfiguriert, wenn Sie SharePoint-Produkte auf demselben Server wie Team Foundation Server installieren.

Konfigurieren der Unternehmensanwendungsdefinition für Team Foundation Server

Die abschließende Konfiguration in den Team Foundation Server-Erweiterungen für SharePoint-Produkte ist nur erforderlich, wenn Sie Enterprise Edition von Microsoft Office SharePoint Server 2007 oder Microsoft SharePoint Server 2010 verwenden.

Überprüfen von SharePoint-Produkten für Team Foundation Server

Enthält Schritte zum Sicherstellen, dass SharePoint-Produkte zusammen mit Team Foundation Server ausgeführt werden können.


Manuelle Installation von SharePoint-Produkten für Team Foundation Server auf Windows Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Manuelle Installation von SharePoint-Produkten für Team Foundation Server auf Windows Server
Siehe auch Feedback senden

Sie können SharePoint Foundation 2010 mit den TFS-Installations-Assistenten installieren, einschließlich dem TFS-Standardinstallations-Assistenten, und, neu in dieser Version von TFS, dem Assistenten zum Installieren von TFS-Erweiterungen für SharePoint. Führen Sie diese Prozedur nur aus, wenn Sie eine andere Version von SharePoint-Produkten installieren möchten.

Team Foundation Server empfohlene Vorgehensweisen für SharePoint-Produkte

  • Wenn Sie SharePoint-Produkte installieren, können Sie einen beliebigen Port für die Zentraladministrationswebsite verwenden. Sie sind nicht auf Port 17012 beschränkt.

  • NTLM wird für die Authentifizierung empfohlen.

  • Team Foundation Server-Erweiterungen für Windows SharePoint Services bieten keine Unterstützung für die anonyme oder die Standardauthentifizierung.

Tipp Tipp

Weitere Informationen zum Bereitstellen und Konfigurieren von SharePoint Server 2010 und Office SharePoint Server 2007 finden Sie auf den folgenden Seiten der Microsoft-Website: Bereitstellung für SharePoint Server 2010, Bereitstellung von Office SharePoint Server 2007

Erforderliche Berechtigungen

Zum Ausführen dieser Schritte müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Computer sein, auf dem SharePoint-Produkte installiert wird und die Datenbanken gehostet werden.

So installieren Sie SharePoint-Produkte für die Verwendung mit Team Foundation Server

  1. Starten Sie den Installations-Assistenten für SharePoint-Produkte.

    Sie können diesen Assistenten starten, indem Sie die Installations-DVD einlegen. Wenn Sie Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 installieren, geben Sie den Product Key ein, und klicken Sie auf Weiter.

  2. Lesen Sie die Lizenzvereinbarung auf der Seite Microsoft-Software-Lizenzbestimmungen lesen. Wenn Sie die Bestimmungen akzeptieren, wählen Sie Ich stimme den Bestimmungen dieses Vertrags zu aus, und klicken Sie dann auf Weiter.

  3. Führen Sie auf der Seite Gewünschte Installation auswählen einen der folgenden Schritte aus:

    • Wenn Sie Windows SharePoint Services 3.0 oder Microsoft Office SharePoint Server 2007 installieren, klicken Sie auf Erweitert.

    • Wenn Sie SharePoint Server 2010 installieren, klicken Sie auf Serverfarm.

  4. Führen Sie auf der Registerkarte Servertyp einen der folgenden Schritte aus:

    • Wenn Sie Windows SharePoint Services 3.0 installieren, klicken Sie auf Web-Front-End.

    • Wenn Sie Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 installieren, klicken Sie auf Vollständig.

  5. Überspringen Sie diesen Schritt, wenn Sie SharePoint Server 2010 installieren. Geben Sie andernfalls auf der Registerkarte Feedback eine Option an. (Dies Schritt ist nicht erforderlich.)

    Weitere Informationen zum Programm erhalten Sie, wenn Sie auf den Link klicken. Zum Anzeigen der Programminformationen benötigen Sie eine Internetverbindung.

  6. Klicken Sie auf Jetzt installieren.

    Nach Abschluss des Installations-Assistenten wird ein Dialogfeld angezeigt, in dem Sie aufgefordert werden, die Konfiguration des Servers abzuschließen.

  7. Vergewissern Sie sich, dass in diesem Dialogfeld das Kontrollkästchen Führen Sie den Konfigurations-Assistenten für SharePoint-Produkte und -Technologien jetzt aus aktiviert ist.

  8. Klicken Sie auf Schließen, um den Konfigurations-Assistenten zu starten.

  9. Klicken Sie auf der Seite Willkommen bei den SharePoint-Produkten und -Technologien auf Weiter.

    Hinweis Hinweis

    Wird eine Warnung zum Neustart bestimmter Diensten angezeigt, klicken Sie auf Ja. Einige Dienste werden während der Konfigurationsphase unter Umständen neu gestartet.

  10. Klicken Sie auf der Seite Verbindung mit einer Serverfarm herstellen auf Nein, ich möchte eine neue Serverfarm erstellen, und klicken Sie dann auf Weiter.

  11. Führen Sie auf der Seite Einstellungen für die Konfigurationsdatenbank angeben die folgenden Schritte aus:

    1. Geben Sie im Feld Datenbankserver den Namen des Servers ein, auf dem SQL Server ausgeführt wird und den Sie zum Hosten der Datenbanken für Team Foundation Server verwenden möchten. Wenn Sie eine benannte Instanz verwenden, fügen Sie deren Namen nach dem Namen des Datenbankservers hinzu, getrennt durch einen Schrägstrich. Beispiel: Datenbankserver\Instanzname.

    2. Geben Sie in Datenbankname den Namen der Datenbank ein, die Sie verwenden möchten, oder übernehmen Sie den Standardwert.

    3. Geben Sie unter Datenbankzugriffskonto angeben in Benutzername den Namen des Benutzerkontos ein, das Sie als Dienstkonto für SharePoint-Produkte verwenden möchten (WSSSERVICE).

      Sie können dasselbe Dienstkonto wie für Team Foundation Server verwenden (TFSSERVICE).

    4. Geben Sie unter Datenbankzugriffskonto angeben in Kennwort das Kennwort für das Dienstkonto ein.

    5. Klicken Sie auf Weiter, nachdem Sie alle erforderlichen Informationen angegeben haben.

  12. Überspringen Sie diesen Schritt, wenn Sie Windows SharePoint Services 3.0 oder Microsoft Office SharePoint Server 2007 installieren. Andernfalls müssen Sie in Passphrase ein Kennwort eingeben. Bestätigen Sie das Kennwort in Passphrase bestätigen, und klicken Sie dann auf Weiter.

  13. Aktivieren Sie auf der Seite Webanwendung für die SharePoint-Zentraladministration konfigurieren das Kontrollkästchen Portnummer angeben, und geben Sie 17012 ein.

    Team Foundation Server verwendet diese Angabe als Portnummer für die SharePoint-Produkte-Verwaltungswebsite. Sie können eine beliebige Portnummer angeben. Für Team Foundation Server wird jedoch als Portnummer für die SharePoint-Produkte-Verwaltungswebsite immer 17012 verwendet.

  14. Klicken Sie in Sicherheitseinstellungen konfigurieren auf NTLM, und klicken Sie dann auf Weiter.

  15. Überprüfen Sie die Informationen auf der Seite Der Konfigurations-Assistent für SharePoint-Produkte und -Technologien wird abgeschlossen, und klicken Sie auf Weiter.

  16. Klicken Sie auf der Seite Die Konfiguration war erfolgreich auf Fertig stellen.

Nächste Schritte

In diesem Thema wird nur die Installation von SharePoint behandelt. Wenn Sie SharePoint ohne einen der TFS-Assistenten installieren, müssen Sie möglicherweise diverse andere Aufgaben ausführen, je nachdem, ob Sie SharePoint auf demselben Server wie TFS oder auf einem Remoteserver installieren, und welche Version von SharePoint Sie installieren. Beachten Sie für weitere Schritte folgende Richtlinien:

  • Wenn Sie SharePoint manuell installieren, müssen Sie SharePoint bereitstellen.¹ Die Website für die SharePoint-Zentraladministration unterstützt Sie bei der Erstellung einer Webanwendung mit Port 80² und NTLM-Authentifizierung.³ Weitere Informationen finden Sie je nach SharePoint-Version unter: Microsoft SharePoint Server 2010 (klassische Windows-Authentifizierung verwenden), Microsoft Office SharePoint Server 2007 oder Windows SharePoint Services 3.0.

  • Bei der Installation der Enterprise Edition von Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 müssen nach der Bereitstellung von SharePoint zusätzliche SharePoint-Einstellungen konfiguriert werden, bevor Dashboards verwendet werden. Nehmen Sie diese Konfigurationen vor, bevor Sie das Portal mit TFS verbinden. Weitere Informationen finden Sie unter Konfigurieren der Enterprise Editionen von SharePoint Server 2010 oder Office SharePoint Server 2007 für eine Dashboardkompatibilität. Sollten Sie keine Enterprise Edition dieser SharePoint-Produkte verwenden, können Sie dies ignorieren.

  • Bei der Installation von SharePoint-Produkte auf einem Remoteserver (ein Server, auf dem TFS nicht ausgeführt wird), müssen alle zuvor genannten Anforderungen (Bereitstellen von SharePoint, Vornehmen aller erforderlichen Dashboard-Konfigurationen der Enterprise Edition) erfüllt und die TFS-Erweiterungen für SharePoint auf dem SharePoint-Server installiert werden. Weitere Informationen finden Sie unter Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server. Sollten Sie SharePoint auf demselben Server wie TFS installieren, können Sie dies ignorieren.

¹SharePoint Foundation 2010 wird von den TFS-Installations-Assistenten automatisch bei der Installation von SharePoint bereitgestellt.

²Sollte eine andere Portnummer als 80 angegeben werden, müssen Benutzer diese als Teil der Adresse angeben, damit Team Foundation Server ordnungsgemäß funktioniert.

³In SharePoint Server 2010 wird die NTLM-Authentifizierung als "klassische Windows-Authentifizierung" bezeichnet.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server


Konfigurieren der Enterprise Editionen von SharePoint Server 2010 oder Office SharePoint Server 2007 für eine Dashboardkompatibilität

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren der Enterprise Editionen von SharePoint Server 2010 oder Office SharePoint Server 2007 für eine Dashboardkompatibilität
Feedback senden

Bevor Sie die Enterprise Edition entweder von Microsoft Office SharePoint Server 2007 oder von Microsoft SharePoint Server 2010 verwenden können, müssen Sie sie dergestalt konfigurieren, dass sie mit der Bereitstellung vom Team Foundation Server arbeitet. Wenn Sie die in diesem Thema beschriebenen Einstellungen nicht konfigurieren, bieten die in Teamprojektportalen verfügbaren Berichte und Dashboards möglicherweise nicht die gesamte erwartete Funktionalität und funktionieren ggf. nicht ordnungsgemäß.

Tipp Tipp

Nach der Veröffentlichung von Team Foundation Server 2010 hat Microsoft ein Tool erstellt, mit dem Microsoft Office SharePoint Server 2007 und SharePoint Server 2010 automatisch für die Verwendung dieser Version von Team Foundation Server konfiguriert werden. Dieses Tool umfasst eine eigene Dokumentation, die die Ausführung und die Einschränkungen des Tools erläutert. Wenn Sie dieses Tool verwenden, müssen Sie die Prozeduren in diesem Thema nicht abschließen. Sie können das Tool über die folgende Seite auf der Microsoft-Website beziehen: Microsoft Team Foundation Server 2010-MOSS-Konfigurationstool.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Team Foundation Server ausgeführt wird. Sie müssen außerdem Mitglied der Gruppe "Farmadministratoren" in SharePoint-Produkte sein.

Konfigurieren von SharePoint Server 2010

Um die Enterprise Edition von SharePoint Server 2010 manuell für die Kompatibilität mit Team Foundation Server zu konfigurieren, müssen Sie die Schritte in diesem Abschnitt ausführen.

Benötigte Dienste in Office SharePoint Server 2010 konfigurieren

Team Foundation Server erfordert für die Ausführung in SharePoint Server 2010 bestimmte Dienste, damit Berichte und Dashboards in Teamprojektportalen ordnungsgemäß angezeigt werden.

So konfigurieren Sie Dienste in SharePoint Server 2010

  1. Öffnen Sie auf dem Server, auf dem SharePoint Server 2010 ausgeführt wird, die SharePoint-Zentraladministration, und wählen Sie anschließend Konfigurations-Assistenten aus.

  2. Wählen Sie Assistent starten aus.

  3. Stellen Sie sicher, dass die Kontrollkästchen Excel Services-Anwendung und Secure Store Service aktiviert sind, und wählen Sie dann Weiter aus.

Konfigurieren von Excel Services

Für eine ordnungsgemäße Funktion von Berichten müssen Sie zudem die Webanwendung, die Sie für Team Foundation Server erstellt haben, als vertrauenswürdigen Speicherort für Excel Services konfigurieren.

So fügen Sie einen vertrauenswürdigen Speicherort hinzu

  1. Wählen Sie in der SharePoint-Zentraladministration unter Anwendungsverwaltung die Option Dienstanwendungen verwalten aus.

  2. Wählen Sie auf der Seite für das Verwalten der Dienstanwendungen die Option Excel Services-Anwendung aus.

  3. Wählen Sie auf der Seite für das Verwalten der Excel Services-Anwendung die Option Vertrauenswürdige Dateispeicherorte aus.

  4. Wählen Sie Vertrauenswürdigen Dateispeicherort hinzufügen aus.

  5. Geben Sie unter Adresse die URL für die Stammsite der Webanwendung ein, die Sie mit Team Foundation Server verwenden möchten.

    Sie sollten die Webanwendung angeben, die Sie für Team Foundation Server erstellt haben.

  6. Wählen Sie unter Speicherorttyp die Option Microsoft SharePoint Foundation aus.

  7. Aktivieren Sie unter Untergeordneten Speicherorten vertrauen das Kontrollkästchen Untergeordneten Speicherorten wird vertraut.

  8. Klicken Sie im Abschnitt Externe Daten unter Externe Daten zulassen auf Vertrauenswürdige Datenverbindungsbibliotheken und eingebettete Verbindungen.

  9. (Optional) Deaktivieren Sie das Kontrollkästchen Aktualisierungswarnung aktiviert.

  10. Ändern Sie die Zahl unter Maximale Anzahl gleichzeitiger Abfragen pro Sitzung auf "20", und wählen Sie dann OK aus.

Konfigurieren von Secure Store Service (optional)

In SharePoint Server 2010 ersetzt der sichere Speicherdienst den Dienst für einmaliges Anmelden in Microsoft Office SharePoint Server 2007. Um den sicheren Speicherdienst zu konfigurieren, müssen Sie eine Zielanwendung für den sicheren Speicher erstellen. In Microsoft Office SharePoint Server 2007 wurde diese Anwendung als Unternehmensanwendungsdefinition bezeichnet.

So konfigurieren Sie den sicheren Speicherdienst

  1. Wählen Sie in der SharePoint-Zentraladministration unter Anwendungsverwaltung die Option Dienstanwendungen verwalten aus.

  2. Wählen Sie auf der Seite für das Verwalten der Dienstanwendungen die Option Secure Store Service aus.

  3. Wählen Sie Neu aus, um eine Zielanwendung für einmaliges Anmelden für Team Foundation Server zu erstellen.

    Tipp Tipp

    Wenn Sie noch keinen Schlüssel erstellt haben, werden Sie von SharePoint-Produkte dazu aufgefordert, durch Auswahl von Neuen Schlüssel generieren einen neuen Schlüssel zu erstellen. Sie können keine Zielanwendung für den sicheren Speicher ohne einen Schlüssel erstellen.

  4. Geben Sie auf der Seite "Neue Zielanwendung für einmaliges Anmelden erstellen" unter Zielanwendungs-ID und Anzeigename den Ausdruck TFS ein.

    Tipp Tipp

    Sie müssen TFS nicht für Zielanwendungs-ID oder Anzeigename verwenden, sondern sich merken, was Sie hier verwenden, da Sie dies zu einem späteren Zeitpunkt zur Konfiguration von Team Foundation Server benötigen.

  5. Geben Sie unter E-Mail-Adresse für Kontaktaufnahme die E-Mail-Adresse der Person oder Gruppe ein, an die E-Mails zu dieser Anwendung gesendet werden sollen.

  6. Wählen Sie in der Liste Zielanwendungstyp den Eintrag Gruppe aus.

  7. Wählen Sie in Seiten-URL der Zielanwendung die Option Keine aus, und wählen Sie anschließend Weiter aus.

  8. Wählen Sie in Geben Sie die Anmeldeinformationsfelder für die Zielanwendung für einmaliges Anmelden an. die Option Weiter aus, um die Standardeinstellungen für die Anmeldeinformationsfelder zu akzeptieren.

  9. Geben Sie in Geben Sie die Mitgliedschaftseinstellungen an. unter Administratoren für die Zielanwendung das Administratorkonto für die Anwendung ein.

  10. Geben Sie unter Mitglieder den Namen einer globalen Sicherheitsgruppe aus der Domäne ein, die alle Benutzer enthält, denen Sie Zugriff auf Dashboards und Berichte in Team Foundation Server erteilen möchten, und wählen Sie dann OK.

  11. Aktivieren Sie auf der Seite "Secure Store Service-Anwendung" das Kontrollkästchen für die Zielanwendung, die Sie soeben erstellt haben (mit dem Namen "TFS", wenn Sie den zuvor in diesem Thema beschriebenen Namensleitfaden verwendet haben), und wählen Sie anschließend auf dem Menüband Anmeldeinformationen festlegen aus.

  12. Geben Sie im Dialogfeld Anmeldeinformationen für Zielanwendung für einmaliges Anmelden (Gruppe) festlegen den Namen und das Kennwort ein, bestätigen Sie das Kennwort des Berichtsleserkontos für Team Foundation Server, und wählen Sie anschließend OK aus.

    Tipp Tipp

    TFSReports ist der Platzhaltername des Berichtsleserkontos.

Konfigurieren von Office SharePoint Server 2007

Um die Enterprise Edition von Microsoft Office SharePoint Server 2007 manuell für die Kompatibilität mit Team Foundation Server zu konfigurieren, müssen Sie die Schritte in diesem Abschnitt ausführen.

Benötigte Dienste in Office SharePoint Server 2007 konfigurieren

Team Foundation Server erfordert für die Ausführung in Microsoft Office SharePoint Server 2007 bestimmte Dienste, damit Berichte und Dashboards in Teamprojektportalen ordnungsgemäß angezeigt werden.

So konfigurieren Sie Dienste in Office SharePoint Server 2007

  1. Öffnen Sie auf dem Server, auf dem Microsoft Office SharePoint Server 2007 ausgeführt wird, die SharePoint-Zentraladministration.

  2. Wählen Sie die Registerkarte Vorgänge, und wählen Sie dann unter Topologie und Dienste die Option Dienste auf dem Server.

  3. Wählen Sie unter Serverrolle zum Anzeigen der zu startenden Dienste in folgender Tabelle auswählen die Option Einzelner Server oder Webserver für kleine Serverfarmen oder Webserver für mittlere Serverfarmen.

    Hinweis Hinweis

    In dieser Prozedur sind beide Optionen gleichermaßen gültig. Die Dienste sind für beide Optionen gleich.

  4. Suchen Sie unter Dienste in der folgenden Tabelle starten den Eintrag Dienste für Excel-Berechnungen, wählen Sie Start, und warten Sie, bis der Vorgang abgeschlossen ist.

  5. Suchen Sie unter Dienste in der folgenden Tabelle starten den Eintrag Office SharePoint Server-Suche, und wählen Sie dann Start.

    Die Seite Einstellungen für den Office SharePoint Server-Suchdienst konfigurieren wird geöffnet.

  6. Aktivieren Sie unter Abfrage und Indizierung die Kontrollkästchen Diesen Server zum Indizieren von Inhalt verwenden und Diesen Server zum Beantworten von Suchabfragen verwenden.

  7. Geben Sie unter E-Mail-Adresse für Kontaktaufnahme die Adresse eines E-Mail-Kontos ein, an das externe Benutzer E-Mails zu Problemen mit diesem Server senden sollten.

  8. Geben Sie unter Suchdienstkonto für Farm den Benutzernamen und das Kennwort eines Domänenkontos ein, das als Suchdienstkonto für Office SharePoint Server verwendet werden soll.

  9. Übernehmen Sie für die restlichen Einstellungen die Standardkonfigurationen, klicken Sie auf Start, und warten Sie, bis der Vorgang abgeschlossen ist.

    Hinweis Hinweis

    Das Suchdienstkonto, das Sie für Office SharePoint Server angeben, erfordert spezielle Berechtigungen und wirkt sich auf die Sicherheit aus. Geben Sie für dieses Konto nicht das Dienstkonto, das Sie für SharePoint-Produkte verwenden, oder ein Systemkonto an, z. B. Netzwerkdienste. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Dienstkonten und Abhängigkeiten Team Foundation Server.

  10. Suchen Sie unter Dienste in der folgenden Tabelle starten den Eintrag Windows SharePoint Services-Suche, und wählen Sie dann Start.

    Die Seite Einstellungen für den Windows SharePoint Services-Suchdienst konfigurieren wird geöffnet.

  11. Geben Sie unter Dienstkonto den Benutzernamen und das Kennwort eines Domänenkontos ein, das als Dienstkonto verwendet werden soll.

  12. Geben Sie unter Inhaltszugriffskonto den Benutzernamen und das Kennwort eines Kontos ein, das als schreibgeschütztes Zugriffskonto verwendet werden soll.

  13. Übernehmen Sie für die restlichen Einstellungen die Standardkonfigurationen, klicken Sie auf Start, und warten Sie, bis der Vorgang abgeschlossen ist.

    Hinweis Hinweis

    Die Konten, die Sie als Dienstkonto und Inhaltszugriffskonto angeben, erfordern spezielle Berechtigungen und wirken sich auf die Sicherheit aus. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Dienstkonten und Abhängigkeiten Team Foundation Server.

Erstellen eines Anbieters für gemeinsame Dienste für Team Foundation Server

Nachdem Sie die Dienste aktiviert haben, die Team Foundation Server erfordert, müssen Sie einen Anbieter für gemeinsame Dienste (Shared Service Provider, SSP) für die Verwendung mit Team Foundation Server erstellen. Darüber hinaus erstellen Sie zur Unterstützung dieses SSP eine SharePoint-Webanwendung.

So erstellen Sie einen Anbieter für gemeinsame Dienste und die zugehörige Webanwendung

  1. Wählen Sie Startseite, um die Hauptseite für die Zentraladministration anzuzeigen, und wählen Sie dann Verwaltung der gemeinsamen Dienste.

  2. Wählen Sie auf der Seite Gemeinsame Dienste dieser Farm verwalten die Option Neuer SSP aus.

    Die Seite Neuer Anbieter für gemeinsame Dienste wird angezeigt.

  3. Geben Sie unter Name des SSP einen Namen für den neuen SSP ein, oder übernehmen Sie den Standardnamen.

    Der Standardname lautet SharedServices, direkt gefolgt von einer Nummer (z. B. SharedServices1).

  4. Wählen Sie Neue Webanwendung erstellen.

    Die Seite Neue Webanwendung erstellen wird angezeigt.

  5. Wählen Sie unter IIS-Website die Option Neue IIS-Website erstellen.

  6. (Optional) Ändern Sie unter Beschreibung den Standardwert SharePoint in den Namen, den Sie im vorherigen Schritt angegeben haben (z. B. SharedServices1).

    Wichtiger Hinweis Wichtig

    Achten Sie darauf, dass Sie die Anschlussnummer nicht ändern oder dass Sie den Anschlussnummernverweis aus der Beschreibung nicht löschen.

  7. Wählen Sie unter Sicherheitskonfiguration die Option NTLM und dann Neuen Anwendungspool erstellen.

  8. Konfigurieren Sie unter Anwendungspool die folgenden Optionen:

    • Stellen Sie sicher, dass der Name im Feld Anwendungspoolname mit dem Namen im Feld Beschreibung übereinstimmt.

    • Klicken Sie im Abschnitt Wählen Sie ein Sicherheitskonto für diesen Anwendungspool aus auf Konfigurierbar, und geben Sie dann den Benutzernamen und das Kennwort des Dienstkontos für SharePoint-Produkte ein.

  9. Übernehmen Sie für die restlichen Einstellungen die Standardkonfigurationen, und klicken Sie dann auf OK.

    Nachdem die Webanwendung erstellt wurde, wird die Seite Neuer Anbieter für gemeinsame Dienste mit einer Fehlermeldung in der Titelleiste angezeigt. Dabei handelt es sich um ein erwartetes Verhalten.

  10. Überprüfen Sie unter Name des SSP und Webanwendung, dass der Name der soeben für den SSP erstellten Webanwendung angezeigt wird. Ändern Sie in diesem Abschnitt keinen Wert.

  11. Geben Sie unter Speicherort meiner Website, URL des Speicherorts meiner Website und Relative URL eine relative URL ein, wenn bereits eine Website in dem Verzeichnis vorhanden ist.

    Diese URL ist nur erforderlich, wenn bereits eine Site bereits in dem Verzeichnis (/) vorhanden ist. Die meisten Benutzer verwenden /My, Sie können jedoch jeden Namen angeben, der keine unzulässigen Zeichen enthält. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Benennungseinschränkungen in Team Foundation.

  12. Geben Sie unter SSP-Dienstanmeldeinformationen eingeben den Benutzernamen und das Kennwort eines Domänenkontos ein, die Sie als Konto für die Dienstanmeldeinformationen verwenden möchten.

    Hinweis Hinweis

    Sie müssen ein Domänenbenutzerkonto angeben, dieses muss jedoch nicht Mitglied einer bestimmten Sicherheitsgruppe sein. Geben Sie ein eindeutiges Benutzerkonto an, das nicht über Administratorberechtigungen verfügt. Verwenden Sie nicht das Dienstkonto für Team Foundation (TFSService) oder das Datenreaderkonto (TFSReports). Diese beide Konten erfordern Berechtigungen, über die dieses Konto nicht verfügen sollte. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Dienstkonten und Abhängigkeiten Team Foundation Server.

  13. Übernehmen Sie für die restlichen Einstellungen die Standardkonfigurationen, klicken Sie auf OK, und warten Sie, bis der Vorgang abgeschlossen ist.

    Hinweis Hinweis

    Wenn eine Warnmeldung angezeigt wird, weil die Verwaltungswebsite für SSP und die Stammsite auf dem gleichen Server gehostet werden, wählen Sie OK aus.

  14. Wählen Sie auf der Seite Erfolgreich die Option OK aus.

Konfigurieren der einmaligen Anmeldung

Zum Konfigurieren des einmaligen Anmeldens müssen Sie eine Unternehmensanwendungsdefinition erstellen. Während der folgenden Prozedur müssen Sie sich ggf. mit zwei verschiedenen Sätzen von Anmeldeinformationen anmelden. Um dieses Verfahren ausführen zu können, muss das Konto, mit dem Sie sich beim Server mit Microsoft Office SharePoint Server 2007 anmelden, folgendes Konto sein:

  • Ein Domänenbenutzerkonto, kein Gruppenkonto.

  • Ein Mitglied der Gruppe Farmadministratoren

  • Ein Mitglied der lokalen Gruppe "Administratoren" auf dem Server für den Verschlüsselungsschlüssel

  • Ein Mitglied der securityadmin- und db_creator-Rollen auf der Instanz von SQL Server, die die Datenbank für das einmalige Anmelden hostet

  • Entweder dasselbe Konto, das als Administratorkonto für einmaliges Anmelden verwendet wird, oder Mitglied des als Administratorkonto für einmaliges Anmelden verwendeten Gruppenkontos.

So konfigurieren Sie das einmalige Anmelden

  1. Wählen Sie in der SharePoint-Zentraladministration die Registerkarte Vorgänge.

  2. Klicken Sie unter Sicherheitskonfiguration auf Dienstkonten.

  3. Wählen Sie auf der Seite "Dienstkonten" im Abschnitt Verwaltung von Anmeldeinformationen die Option Windows-Dienst und dann in der Liste der Dienste Dienst für einmaliges Anmelden aus.

  4. Klicken Sie im Abschnitt Konto für diese Komponente auswählen auf Konfigurierbar.

  5. Geben Sie den Benutzernamen und das Kennwort eines Kontos ein, die Sie als Anmeldekonto konfiguriert haben, und wählen Sie dann OK.

    Hinweis Hinweis

    Das angegebene Dienstkonto erfordert spezielle Berechtigungen und wirkt sich auf die Sicherheit aus. Das Konto muss über die Berechtigungen verfügen, die für eine interaktive Anmeldung am Server erforderlich sind, und muss zudem Mitglied der Gruppe "Administratoren" auf dem Server für einmaliges Anmelden sein. Geben Sie für dieses Konto nicht das Dienstkonto, das Sie für SharePoint-Produkte verwenden, oder ein Systemkonto an, z. B. Netzwerkdienste. Weitere Informationen finden Sie auf den folgenden Seiten der Microsoft-Website: Dienstkonten und Abhängigkeiten in Team Foundation Server, Planen administrativer Konten und Planen von Dienstkonten, Einmaliges Anmelden und Starten des Diensts zum einmaligen Anmelden.

  6. Wählen Sie nacheinander Start, Verwaltung und Dienste aus.

  7. Öffnen Sie unter Dienste das Kontextmenü für Microsoft-Dienst für einmaliges Anmelden, und wählen Sie dann Eigenschaften aus.

  8. Wählen Sie auf der Registerkarte Allgemein unter Starttyp die Option Automatisch aus. Wählen Sie dann Start und OK aus.

  9. Wählen Sie in der SharePoint-Zentraladministration die Registerkarte Vorgänge.

  10. Klicken Sie unter Sicherheitskonfiguration auf Einstellungen für einmaliges Anmelden verwalten.

    Hinweis Hinweis

    Um diese Seite zu öffnen, müssen Sie sich ggf. mit dem Konto und den Anmeldeinformationen anmelden, die Sie im vorherigen Schritt konfiguriert haben. Wechseln Sie in diesem Fall die Benutzer, oder starten Sie eine weitere Sitzung, und melden Sie sich mit diesem Konto am Server an. Sie sollten die aktuelle Benutzersitzung nicht beenden. Sie können alternativ auch die Funktion Mit anderem Benutzernamen anmelden in der SharePoint-Zentraladministration verwenden, diese Funktion funktioniert bei diesem Vorgang jedoch möglicherweise nicht. Wählen Sie zum Aufrufen dieser Funktion oben im Fenster Willkommen Benutzername, wählen Sie Mit anderem Benutzernamen anmelden, und melden Sie sich dann mit diesem Konto an.

  11. Wählen Sie auf der Seite Einstellungen für einmaliges Anmelden verwalten die Option Servereinstellungen verwalten aus.

    Die Seite Servereinstellungen für einmaliges Anmelden verwalten wird angezeigt.

  12. Geben Sie unter Administratorkonto für einmaliges Anmelden den Benutzernamen und das Kennwort eines Kontos ein, die Sie als Anmeldekonto konfiguriert haben.

    Hinweis Hinweis

    Das angegebene Dienstkonto erfordert spezielle Berechtigungen und wirkt sich auf die Sicherheit aus. Das Konto muss über die Berechtigungen verfügen, die für eine interaktive Anmeldung am Server erforderlich sind, und muss zudem Mitglied der Gruppe "Administratoren" auf dem Server für einmaliges Anmelden sein. Geben Sie für dieses Konto nicht das Dienstkonto, das Sie für SharePoint-Produkte verwenden, oder ein Systemkonto an, z. B. Netzwerkdienste. Weitere Informationen finden Sie auf den folgenden Seiten der Microsoft-Website: Dienstkonten und Abhängigkeiten in Team Foundation Server, Planen administrativer Konten und Planen von Dienstkonten, Einmaliges Anmelden und Starten des Diensts zum einmaligen Anmelden.

  13. Geben Sie unter Administratorkonto für die Enterpriseanwendungsdefinition den Benutzernamen der Person oder Personengruppe ein, die Sie als Manager der Unternehmensanwendungsdefinitionen auf diesem Server zuweisen möchten.

    Sie sollten ggf. eine Gruppe erstellen, die Sie für alle Mitglieder der Gruppe "Team Foundation-Administratoren" verwenden.

  14. Übernehmen Sie für die restlichen Einstellungen die Standardkonfigurationen, und klicken Sie dann auf OK.

  15. Wählen Sie auf der Seite Einstellungen für einmaliges Anmelden verwalten die Option Verschlüsselungsschlüssel verwalten aus.

  16. Wählen Sie auf der Seite Verschlüsselungsschlüssel verwalten die Option Verschlüsselungsschlüssel erstellen aus.

  17. Wählen Sie auf der Seite Verschlüsselungsschlüssel erstellen die Option OK aus.

    Wichtiger Hinweis Wichtig

    Stellen Sie sicher, dass Sie den Verschlüsselungsschlüssel an einem sicheren Speicherort sichern.

  18. Kehren Sie zur Seite Einstellungen für einmaliges Anmelden verwalten zurück.

    Hinweis Hinweis

    Wenn Sie sich bei der SharePoint-Zentraladministration mit einem anderen Benutzerkonto angemeldet haben, um die Einstellungen für einmaliges Anmelden zu ändern, sollten Sie zu einer Sitzung zurückkehren, die Sie unter Ihrem eigenen Konto ausführen. Nach dieser Änderung werden die beiden oberen Optionen auf der Seite Einstellungen für einmaliges Anmelden verwalten ausgeblendet.

  19. Wählen Sie Einstellungen für Enterpriseanwendungsdefinitionen verwalten.

  20. Wählen Sie auf der Seite Einstellungen für Enterpriseanwendungsdefinitionen verwalten die Option Neues Element aus.

    Die Seite Enterpriseanwendungsdefinition erstellen wird angezeigt.

  21. (Optional) Geben Sie im Abschnitt Anwendungs- und Kontaktinformationen unter Anzeigename und Anwendungsname TFS ein.

    Dieser Schritt ist nicht erforderlich, erleichtert aber ggf. die späterer Identifikation.

  22. Geben Sie unter E-Mail-Adresse für Kontaktaufnahme die E-Mail-Adresse der Person oder Gruppe ein, an die E-Mails zu dieser Anwendung gesendet werden sollen.

  23. Wählen Sie unter Kontotyp die Option Gruppe.

  24. Wählen Sie unter Authentifizierungstyp die Option Windows-Authentifizierung und dann OK.

  25. Kehren Sie zur Seite Einstellungen für einmaliges Anmelden verwalten zurück, und wählen Sie dann Kontoinformationen für Enterpriseanwendungsdefinitionen verwalten aus.

    Die Seite Kontoinformationen für Enterpriseanwendungsdefinitionen verwalten wird angezeigt.

  26. Klicken Sie im Abschnitt Kontoinformationen der Liste Unternehmenskontodefinition auf den Namen der Unternehmenskontodefinition, die Sie zur Unterstützung von Team Foundation Server erstellt haben.

    Wenn Sie sich an die vorgeschlagene Namenskonvention gehalten haben, lautet dieser Name TFS.

  27. Geben Sie unter Gruppenkontoname den Namen einer globalen Sicherheitsgruppe in der Domäne ein, die alle Benutzer enthält, denen Sie Zugriff auf Dashboards und Berichte in Team Foundation Server erteilen möchten, und wählen Sie dann Festlegen.

  28. Geben Sie unter Serverkontoinformationen angeben den Namen und das Kennwort für das Berichtsleserkonto ein (entspricht dem Platzhalter TFSReports), und wählen Sie dann OK.

  29. Wählen Sie auf der Seite Kontoinformationen für Enterpriseanwendungsdefinitionen verwalten die Option Fertig aus.

Hinzufügen eines vertrauenswürdigen Speicherorts für Excel Services

Für eine ordnungsgemäße Funktion von Berichten müssen Sie zudem die Webanwendung, die Sie für Team Foundation Server erstellt haben, als vertrauenswürdigen Speicherort für Excel Services konfigurieren.

So fügen Sie einen vertrauenswürdigen Speicherort hinzu

  1. Wählen Sie in der SharePoint-Zentraladministration Homepage, um zur Homepage für die SharePoint-Zentraladministration zurückzukehren.

  2. Klicken Sie unter Verwaltung der gemeinsamen Dienste auf den Namen des Anbieters für gemeinsame Dienste, den Sie erstellt haben.

    Wenn Sie sich an die vorgeschlagene Namenskonvention gehalten haben, lautet der Name dieser Anwendung SharedServices1.

    Die Homepage für die Verwaltung der Webanwendung wird geöffnet.

  3. Klicken Sie unter Excel Services-Einstellungen auf Vertrauenswürdige Dateispeicherorte.

  4. Wählen Sie auf der Seite Vertrauenswürdige Dateispeicherorte die Option Vertrauenswürdigen Dateispeicherort hinzufügen aus.

    Die Seite Excel Services - Vertrauenswürdigen Dateispeicherort hinzufügen wird angezeigt.

  5. Geben Sie unter Adresse die URL für die Stammsite der Webanwendung ein, die Sie mit Team Foundation Server verwenden möchten.

    Geben Sie die Webanwendung an, die Sie im Abschnitt Erstellen einer Webanwendung erstellt haben.

  6. Wählen Sie unter Speicherorttyp die Option Windows SharePoint Services.

  7. Aktivieren Sie unter Untergeordneten Speicherorten vertrauen das Kontrollkästchen Untergeordneten Speicherorten wird vertraut.

  8. Klicken Sie im Abschnitt Externe Daten unter Externe Daten zulassen auf Vertrauenswürdige Datenverbindungsbibliotheken und eingebettete Verbindungen.

  9. (Optional) Deaktivieren Sie das Kontrollkästchen Aktualisierungswarnung aktiviert.

  10. Ändern Sie den Wert unter Maximale Anzahl gleichzeitiger Abfragen pro Sitzung auf "20", stellen Sie sicher, dass das Kontrollkästchen Aktualisierungswarnung aktiviert deaktiviert ist, und wählen Sie dann OK.

Festlegen des Zugriffsmodells

Nachdem Sie alle Einstellungen und Dienste konfiguriert haben, die Team Foundation Server erfordert, müssen Sie das Zugriffsmodell für die Webanwendung für einmaliges Anmelden für die Delegation konfigurieren. Wenn Sie das Zugriffsmodell nicht konfigurieren, können Team Foundation Server und die Webanwendung nicht zusammenarbeiten.

So legen Sie das Zugriffsmodell fest

  1. Öffnen Sie auf dem Server, auf dem die SharePoint-Zentraladministration ausgeführt wird, ein Eingabeaufforderungsfenster.

  2. Wechseln Sie in das Verzeichnis %programfiles%\Common Files\Microsoft Shared\Web Server Extensions\12\bin, und geben Sie den folgenden Befehl ein:

    stsadm -o set-ecssecurity -ssp SharedServiceProviderName -accessmodel delegation

    SharedServiceWebApplicationName ist der Name des Anbieters für gemeinsame Dienste, den Sie erstellt haben. Wenn Sie sich an die vorgeschlagene Namenskonvention gehalten haben, lautet dieser Name jenes Anbieters SharedServices1.

  3. Geben Sie an der Eingabeaufforderung iisreset ein, um IIS neu zu starten.


Überprüfen von SharePoint-Produkten für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Überprüfen von SharePoint-Produkten für Team Foundation Server
Siehe auch Feedback senden

Wenn Sie eine andere Installation von SharePoint-Produkten verwenden möchten, die nicht während der Installation von Team Foundation Server installiert wurde, müssen Sie überprüfen, ob die Installation von SharePoint-Produkten den folgenden Anforderungen entspricht:

  • Die Verwaltungswebsite und die Standardwebsite werden ausgeführt, und andere Computer im Netzwerk können darauf zugreifen.

  • SharePoint-Produkte verwendet NTLM (empfohlene Authentifizierung). (Die Standardauthentifizierung wird von Team Foundation Server-Erweiterungen für SharePoint-Produkte nicht unterstützt.)

  • Wenn Sie Enterprise Edition von Office SharePoint Server 2007 oder SharePoint Server 2010 verwenden, müssen Sie Einstellungen für die Dashboardkompatibilität konfigurieren.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem SharePoint-Produkte ausgeführt wird.

So überprüfen Sie, ob die Verwaltungswebsite und die Standardwebsite ausgeführt werden und ob andere Computer im Netzwerk darauf zugreifen können

  1. Wählen Sie auf dem SharePoint-Produkte-Server Start, Ausführen aus, geben Sie inetmgr ein, und wählen Sie dann OK aus.

    Der Internetinformationsdienste-Manager wird geöffnet.

  2. Öffnen Sie im Internetinformationsdienste-Manager (IIS) Servername (lokaler Computer).

    Servername ist der Name des Webservers.

  3. Führen Sie die entsprechenden Schritte für Ihr jeweiliges Betriebssystem aus:

    Für Windows Server 2008:

    1. Wählen Sie Sites und anschließend die Standardwebsite aus.

    2. Wählen Sie im Aktionsbereich Durchsuchen: 80 (http) aus.

      Die Standardwebsite wird im Standardbrowser angezeigt.

    3. Wählen Sie die Website für die SharePoint-Zentraladministration aus.

      Wählen Sie im Aktionsbereich Durchsuchen: Port (http) aus.

      Port ist die Nummer des Ports, der der Website für die SharePoint-Zentraladministration zugeordnet ist.

      Die Website für die SharePoint-Zentraladministration wird im Standardbrowser angezeigt.

    Für Windows Server 2003:

    1. Wählen Sie im Kontextmenü für die standardmäßige Website die Option Durchsuchen aus.

      Die Standardwebsite wird im Internetinformationsdienste-Manager (IIS) angezeigt.

    2. Wählen Sie im Kontextmenü für die SharePoint-Zentraladministration die Option Durchsuchen aus.

      Die Website für die SharePoint-Zentraladministration wird im Internetinformationsdienste-Manager (IIS) angezeigt.

So überprüfen Sie, ob die Standardwebsite die empfohlene Authentifizierung verwendet

  1. Öffnen Sie in einem Webbrowser die Website für die SharePoint-Zentraladministration, und wählen Sie die Registerkarte Anwendungsverwaltung.

  2. Klicken Sie unter Anwendungssicherheit auf Authentifizierungsanbieter.

  3. Klicken Sie in der Spalte Zone auf Standard.

  4. Vergewissern Sie sich, dass unter IIS-Authentifizierungseinstellungen das Kontrollkästchen Integrierte Windows-Authentifizierung und die Option NTLM ausgewählt sind.

    Hinweis Hinweis

    Stellen Sie sicher, dass die Authentifizierungseinstellung, die auf der SharePoint-Zentraladministrationswebsite angezeigt wird, der Authentifizierungseinstellung in IIS entspricht.

So überprüfen Sie, ob Office SharePoint Server 2007 oder SharePoint Server 2010 für die Dashboardkompatibilität konfiguriert ist

  • Wenn Sie Enterprise Edition von Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 verwenden, müssen Sie die erforderlichen Konfigurationen für Dashboardkompatibilität ausführen. Wenn Sie eine andere Version von SharePoint-Produkte verwenden, können Sie diese Prozedur ignorieren. Weitere Informationen finden Sie unter Konfigurieren der Enterprise Editionen von SharePoint Server 2010 oder Office SharePoint Server 2007 für eine Dashboardkompatibilität.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server


Konfigurieren der Unternehmensanwendungsdefinition für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren der Unternehmensanwendungsdefinition für Team Foundation Server
Siehe auch Feedback senden

Wenn Sie einen Server verwenden möchten, auf dem die Enterprise-Edition von Office SharePoint Server 2007 oder SharePoint Server 2010 ausgeführt wird, müssen Sie Ihrer Bereitstellung von Team Foundation Server die Unternehmensanwendungsdefinition hinzufügen. Sie haben die Unternehmensanwendungsdefinition erstellt, als Sie SharePoint-Produkte für Dashboardkompatibilität konfiguriert haben. Sie müssen diese Konfiguration durchführen, damit Berichte und Dashboards in Team Foundation Server ordnungsgemäß angezeigt werden.

So konfigurieren Sie die Unternehmensanwendungsdefinition

  1. Öffnen Sie auf dem Server, auf dem Team Foundation Server-Erweiterungen für SharePoint-Produkte ausgeführt werden, die Verwaltungskonsole für Team Foundation Server.

  2. Wählen Sie Erweiterungen für SharePoint-Produkte und -Technologien und anschließend die SharePoint-Webanwendung, für die Sie die Unternehmensanwendungsdefinition konfigurieren möchten.

  3. Wählen Sie Zugriff ändern aus, geben Sie in Definition für Unternehmensanwendung (optional) den Namen der Unternehmensanwendungsdefinition ein, und klicken Sie dann auf OK.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Remote-SharePoint-Produkten für Team Foundation Server


Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server
Siehe auch Feedback senden

Installieren von Team Foundation Server-Erweiterungen für Project Server

Project Server-Integration in TFS

Wenn Sie Project Server zu Ihrer Team Foundation Server-Bereitstellung hinzufügen möchten, müssen Sie in Project Server zunächst die Team Foundation Server-Erweiterungen für Project Server installieren. Mit den Erweiterungen können Sie Berechtigungen zuweisen und die Integration mithilfe der folgenden Schritte konfigurieren.

Tipp Tipp

Wenn Sie Team Foundation Server aktualisieren, müssen Sie die Erweiterungen von Project Server deinstallieren und dann die neueste Version von Team Foundation Server-Erweiterungen für Project Server auf allen Servern einrichten, auf denen es zuvor installiert war. Die Version der Erweiterungen, die Sie verwenden, sollte immer mit der ausgeführten Version von Team Foundation Server übereinstimmen.

So installieren Sie Team Foundation Server-Erweiterungen für Project Server

Schritt 1 Stellen Sie sicher, dass die Project Server-Installation den Anforderungen der Team Foundation Server-Erweiterungen für Project Server entspricht. Team Foundation Server unterstützt die Integration in Project Server 2010 mit Service Pack 1 (SP1) oder Project Server 2007 mit SP2. Jede Installation hat jedoch bestimmte Vorsichtsmaßnahmen, die im unten befindlichen Thema zu den Project Server-Anforderungen für Team Foundation Server zusammen mit einigen Topologieempfehlungen genannt werden.

Weitere Informationen finden Sie unter: Project Server-Anforderungen für Team Foundation Server.

Schritt 2 Führen Sie in Project Server die Installation von der Team Foundation Server-Produkt-DVD aus. Erteilen Sie Berechtigungen in Team Foundation Server, Project Server und der SharePoint-Produkte-Farm, die Project Server hostet. Dies ist möglicherweise die gleiche Farm mit SharePoint-Produkten, die Sie verwenden, um die Team Foundation Server-Teamportalsites zu hosten, jedoch nicht notwendigerweise.

Weitere Informationen finden Sie unter: Installieren von Team Foundation Server-Erweiterungen für Project Server, Gewähren von Berechtigungen zur Unterstützung der Integration von Project Server und Team Foundation Server.

Schritt 3 Führen Sie das Befehlszeilentool "TFSAdmin" aus, um die Integration zu konfigurieren. Nachdem Sie die Konfiguration abgeschlossen haben, überprüfen Sie, ob sie funktioniert. Die Schritte für die Überprüfung sind die sechs Schritte unten in der Konfigurations-Kurzübersicht im Abschnitt "Überprüfen der Datensynchronisierung". Die Schritte für die Verwendung von TFSAdmin werden in "Konfigurieren der Integration von Team Foundation Server und Project Server" angezeigt (Links zu beiden Themen finden Sie weiter unten).

Weitere Informationen: Konfigurieren der Integration von Team Foundation Server und Project Server, Kurzübersicht zur Konfiguration (siehe Abschnitt "Überprüfen der Datensynchronisierung").

Tipp Tipp

Laden Sie die neueste Version des Installationshandbuchs für Team Foundation Server herunter, um sich über aktuelle Änderungen an diesen Schritten zu informieren.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Aktualisieren von Team Foundation Server


Installieren von Team Foundation Server-Erweiterungen für Project Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Installieren von Team Foundation Server-Erweiterungen für Project Server
Siehe auch Feedback senden

Führen Sie folgende Schritte aus, um Team Foundation Server-Erweiterungen für Project Server in Project Server zu installieren. Mit diesem Prozess wird Team Foundation Server nicht installiert, sondern nur die Erweiterungen für Project Server.

Tipp Tipp

Wenn Project Server auf mehreren Servern in einer Webfarm ausgeführt wird, müssen diese Erweiterungen auf jedem Server in dieser Farm installiert und konfiguriert werden.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren sein.

So installieren Sie Team Foundation Server-Erweiterungen für Project Server

  1. Legen Sie die Team Foundation Server-DVD ins Laufwerk ein, und starten Sie die Datei "tfs_projectServerExtensions.exe" vom Ordner "Project Server Extensions", um die Installation zu starten.

  2. Akzeptieren Sie im Dialogfeld mit den Lizenzbedingungen die Lizenzbedingungen, wählen Sie aus, ob Sie Microsoft dabei behilflich sein möchten, die Installationserfahrung zu verbessern, und wählen Sie anschließend Weiter aus. Wenn Sie Erweiterungen für Project Server an einem bestimmten Speicherort im Dateisystem installieren möchten, wählen Sie Anpassen aus.

  3. Wählen Sie auf dem nächsten Bildschirm Jetzt installieren aus. Sie können auch angeben, ob Sie Team Foundation Server während des Setups aktualisieren möchten, indem Sie Microsoft-Updates aktivieren.

  4. Wählen Sie auf dem nächsten Bildschirm Schließen aus.

Siehe auch

Konzepte

Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server


Project Server-Anforderungen für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Project Server-Anforderungen für Team Foundation Server
Siehe auch Feedback senden

Project Server ist für Team Foundation Server nicht erforderlich, wenn Sie es jedoch verwenden möchten, müssen Sie eine unterstützte Version verwenden. Die Version, die Sie verwenden, muss über die für Project Server installierte Team Foundation Server-Erweiterung verfügen.

Tipp Tipp

Wenn Project Server auf mehreren Servern in einer Webfarm ausgeführt wird, müssen diese Erweiterungen auf jedem Anwendungsebenenserver in dieser Farm installiert und konfiguriert werden. Für Project Server 2010 müssen Sie die Erweiterungen auch auf allen Webebenenservern in der Farm installieren.

Unterstützte Versionen, Editionen

  • Project Server 2010 mit SP1

  • Project Server 2007 mit SP2 ¹

Authentifizierung

NTLM wird für die Authentifizierung empfohlen.

In SharePoint Server 2010 wurden neue Authentifizierungsmodi zu SharePoint-Produkten eingeführt. Team Foundation Server erfordert jedoch eine Webanwendung, die die klassische Windows-Authentifizierung verwendet.

¹ Für das Datenbank-Back-End muss Project Server 2007 entweder SQL Server 2005 oder SQL Server 2008 verwenden, um mit dem Team Foundation Server arbeiten zu können.

Sollten Sie Project Server der aktuellen Teamprojektportal-Website hinzufügen?

Project Server ist eine Erweiterung von SharePoint-Produkten. Sie können Project Server problemlos auf der gleichen Farm mit SharePoint-Produkten ausführen, die Sie für Team Foundation Server verwenden. Wenn Sie Project Server auf diese Weise ausführen, müssen Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte und die Erweiterungen für Project Server auf dem gleichen Server installieren. Team Foundation Server empfiehlt Ihnen die Verwendung einer Webanwendung, die auf Port 80 ausgeführt wird, und zwar für die Integration in SharePoint-Produkte. Und Sie können diese gleiche Webanwendung zum Hosten von Projekt Server-Projekten verwenden. Die URL für Teamportalsites und Microsoft Project Web App-Websites (PWA-Websites), die beide in einer Webanwendung am Port 80 gehostet werden, könnte beispielsweise folgendermaßen aussehen:

  • http://MOSS2010Server/sites/DefaultCollection/TFSProject

  • http://MOSS2010Server/pwa/EnterpriseProject

Sie können Project Server auch in der eigenen zugehörigen SharePoint-Farm ausführen, getrennt von Farmen, in denen Sie möglicherweise Teamprojekt-Portalsites hosten. Auf diese Weise erhalten Sie zwei Farmintegrationen für SharePoint-Produkte in einer einzelnen Team Foundation Server-Bereitstellung.

Tipp Tipp

Team Foundation Server besitzt keine Topologieanforderungen für Project Server. Aus Leistungsgründen wird empfohlen, Project Server auf einem anderen Server als Team Foundation Server auszuführen. Wenn Sie eine Sandkastenintegration von Project Server und Team Foundation Server installieren möchten, können Sie alle Produkte zu Demonstrations- oder Testzwecken auf einem einzelnen Server installieren.

Siehe auch

Konzepte

Gewusst wie: Hinzufügen von Project Server zu Team Foundation Server
Anforderungen von SharePoint-Produkten für Team Foundation Server


Gewusst wie: Zwischenspeichern von Versionskontrolldateien auf einer Remotesite

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Zwischenspeichern von Versionskontrolldateien auf einer Remotesite
Feedback senden

Wenn Sie über Entwickler an einem Remotestandort verfügen, die Code an Entwickler am Hauptstandort freigeben, können Sie möglicherweise Bandbreite einsparen, indem Sie Versionskontrolldateien am Remotestandort zwischenspeichern. Team Foundation Server-Proxy verteilt häufig verwendete Versionskontrolldateien aus dem Cache am Remotestandort, damit nicht mehrere Entwickler vom Remotestandort jeweils dieselbe Datei vom Hauptstandort herunterladen müssen. Ihr Team am Remotestandort kann wie gewohnt weiterarbeiten, ohne steuern zu müssen, welche Versionskontrolldateien in den Cache geladen werden.

Zur Einrichtung installieren und konfigurieren Sie den Proxyserver auf der Remotewebsite, verbinden den Proxyserver mit der Anwendungsebene und dann die Versionskontrollfunktion von Team Explorer mit dem Proxy. Bevor Sie mit dem Zwischenspeichern von Dateien auf der Remotesite beginnen können, müssen Sie Team Foundation Server auf der Hauptseite das Dienstkonto für den Proxyserver hinzufügen.

So führen Sie die Zwischenspeicherung von Versionskontrolldateien auf einer Remotesite durch

Aufgabe

Ausführliche Anweisungen

Schritt 1

Überprüfen Sie die unterstützte Hard- und Software. Vergewissern Sie sich, dass das Betriebssystem die Anforderungen für Team Foundation Server-Proxy und die Ausführung durch die Hardware möglich ist.

  • Systemanforderungen für Team Foundation Server Proxy

Schritt 2

Richten Sie Team Foundation Server-Proxy ein. Installieren Sie Team Foundation Server Proxy. Verwenden Sie nach dem Abschluss der Installation das Team Foundation Server-Konfigurationstool, um den Proxyserver zu konfigurieren.

  • Ausführen der Team Foundation Server-Installation

  • Gewusst wie: Konfigurieren von Team Foundation Server Proxy mit dem Team Foundation Server-Konfigurationstool

Schritt 3

Verbinden Sie Team Explorer mit Team Foundation Server-Proxy. Nach dem Konfigurieren des Proxyservers für eine Verbindung mit Team Foundation Server müssen Sie Team Explorer so konfigurieren, dass der Zugriff auf Versionskontrolldateien über den Proxyserver erfolgt.

  • Gewusst wie: Konfigurieren der Team Foundation-Versionskontrolle für die Verwendung eines Proxyservers


Systemanforderungen für Team Foundation Server Proxy

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Systemanforderungen für Team Foundation Server Proxy
Siehe auch Feedback senden

Sie können Team Foundation Server Proxy nur auf Computern unter den in diesem Thema beschriebenen Betriebssystemen installieren. Außerdem sollten Sie die Hardwareempfehlungen in diesem Thema überprüfen, um zu bestimmen, welche Voraussetzungen in Abhängigkeit der Größe des Remoteteams für eine optimale Leistung erfüllt sein müssen. Im Allgemeinen müssen für Team Foundation Server Proxy nicht dieselben strengen Hardwareanforderungen beachtet werden wie für Team Foundation Server. Für große Teams benötigen Sie jedoch robustere Hardware.

Betriebssystemanforderungen

Sie können Team Foundation Server-Proxy auf Servern unter einem der folgenden Serverbetriebssysteme installieren:

  • 64-Bit-Versionen von Windows Server 2008 mit SP2 (Standard oder Enterprise Edition)

  • 64-Bit-Versionen von Windows Server 2008 R2 (Standard oder Enterprise Edition)

  • 64-Bit-Versionen von Windows Server 2012

Hinweis Hinweis

Die Server Core-Installationsoption wird von Team Foundation Server-Proxy nicht unterstützt.

Hardwareempfehlungen

Suchen Sie in der folgenden Tabelle die Zeile, die die Größe des Teams am genauesten beschreibt, und verwenden Sie die entsprechende Hardwareempfehlung als Richtlinie für die Hardware, die Sie für Team Foundation Server Proxy verwenden.

Größe des Remoteteams | Hardwareempfehlungen (CPU/RAM) für Team Foundation Server-Proxy
Teams mit 450 oder weniger Benutzern | 1 Prozessor, CPU mit 2,2 GHz, 2 GB RAM
Teams mit zwischen 450 und 2.200 Benutzern | 2 Prozessoren, CPU mit 2,0 GHz, 2 GB RAM
Teams mit zwischen 2.200 und 3.600 Benutzern | 4 Prozessoren, CPU mit 2,0 GHz, 2 GB RAM

Siehe auch

Konzepte

Systemanforderungen für Team Foundation Server


Gewusst wie: Konfigurieren von Team Foundation Server Proxy mit dem Team Foundation Server-Konfigurationstool

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Konfigurieren von Team Foundation Server Proxy mit dem Team Foundation Server-Konfigurationstool
Feedback senden

Sie können die Vorgehensweisen in diesem Thema verwenden, um Team Foundation Server-Proxy zu konfigurieren.

Hinweis Hinweis

Sie können über das Menü Start auf das Team Foundation Server-Konfigurationstool zugreifen, indem Sie die Team Foundation Server-Verwaltungskonsole starten, Proxyserver wählen und dann auf Installierte Funktionen konfigurieren klicken.

Erforderliche Berechtigungen

Zum Ausführen dieses Verfahrens müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Team Foundation Server-Proxy konfiguriert wird. Sie müssen Mitglied der Gruppe "Projektauflistungsadministratoren" in TFS sein. Wenn Sie den Proxy mit einer Auflistung in der Team Foundation-Dienstvorschau verbinden, benötigen Sie das Microsoft-Konto, das Sie verwendet haben, um den Dienst einzurichten.

So konfigurieren Sie Team Foundation Server-Proxy mit dem Team Foundation Server-Konfigurationstool

  1. Wählen Sie zuerst Team Foundation-Server-Proxy konfigurieren und dann Assistent starten.

    Der Assistent für die Konfiguration von Team Foundation Server-Proxy wird angezeigt.

  2. Lesen Sie die Willkommensseite, und wählen Sie dann Weiter aus.

  3. Wählen Sie über Durchsuchen die Teamprojektauflistung aus, mit der dieser Proxyserver eine Verbindung herstellen soll. Wählen Sie Weiter aus.

    Hinweis Hinweis

    Wenn sich die Teamprojektauflistung in der Team Foundation-Dienstvorschau befindet, werden Sie zur Authentifizierung aufgefordert. Geben Sie das Microsoft-Konto ein, das Sie für die Einrichtung des Diensts verwendet haben.

  4. Wählen Sie unter Dienstkonto die Option Systemkonto verwenden, um das Netzwerkdienstkonto zu verwenden, oder die Option Benutzerkonto verwenden, um ein Domänenkonto oder ein lokales Konto zu verwenden. Wenn Sie ein Benutzerkonto verwenden, müssen Sie das Kennwort eingeben. Wählen Sie Test aus, um die Kombination aus Benutzerkonto und Kennwort zu testen.

    Das Netzwerkdienstkonto ist der Standardwert für das Dienstkonto des Proxyservers.

  5. Unter Erweiterte Konfiguration werden die folgenden optionalen Konfigurationen angezeigt:

    • Wenn Sie mit dem gehosteten Dienst verbunden sind, wird hier Kontoname angezeigt.

      Wenn Sie die Instanz von Team Foundation Server auf dem gehosteten Dienst erstellt haben, wurde ein Kontoname automatisch für Sie erstellt. Dieses Konto wird der Gruppe Proxydienstkonten für die Projektauflistung im gehosteten Dienst hinzugefügt. Wenn Sie ein anderes Konto erstellen möchten, rufen Sie die Verwaltungsseite auf der gehosteten Site auf. Weitere Informationen finden Sie unter diesem Thema.

    • Wenn Sie nicht mit dem gehosteten Dienst verbunden sind, können Sie die Authentifizierungseinstellungen ändern. Wählen Sie unter Authentifizierungsmethode die Option NTLM, um die NTLM-Authentifizierung zu verwenden, oder auf Aushandlung (Kerberos), damit nach Möglichkeit zuerst die sicherere Kerberos-Authentifizierung versucht wird und dann auf NTLM zurückgegriffen wird.

      Der Standardwert ist NTLM.

  6. Wählen Sie Weiter aus.

  7. Übernehmen Sie in Port den Standardwert 8081, oder geben Sie eine andere Portnummer für Verbindungen mit Team Foundation Server-Proxy ein.

    Der Standardwert ist 8081.

  8. Übernehmen Sie in Cachestammverzeichnis den Standardwert, oder geben Sie den Pfad für einen anderen Speicherort der Cachedateien ein.

    Der Standardwert ist Laufwerk: \Programme\Microsoft Team Foundation Server 11.0\Version Control Proxy\Web Services\_tfs_data

    Laufwerk steht für den Buchstaben des Laufwerks, auf dem Sie die Cachedateien speichern möchten. Sie können auch ein zugeordnetes Netzlaufwerk angeben.

  9. Wählen Sie Weiter aus.

  10. Überprüfen Sie auf der Seite "Überprüfen" die Einstellungen, und wählen Sie dann Weiter aus.

    Die Konfiguration wird überprüft.

  11. Wählen Sie Konfigurieren aus.

    Die Konfigurationseinstellungen werden angewendet.

  12. Wählen Sie Weiter aus.

  13. Wählen Sie Schließen aus.

  14. Wählen Sie Schließen aus.

    Die Team Foundation-Verwaltungskonsole wird angezeigt.


Gewusst wie: Konfigurieren der Team Foundation-Versionskontrolle für die Verwendung eines Proxyservers

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Konfigurieren der Team Foundation-Versionskontrolle für die Verwendung eines Proxyservers
Feedback senden

Sie können Team Foundation-Versionskontrolle für die Verwendung eines Proxyservers konfigurieren, der Kopien von Versionskontrolldateien im Verzeichnis des verteilten Teams zwischenspeichert. Sie können die Bandbreitenanforderungen für Remoteentwickler mithilfe eines Proxyservers reduzieren.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Benutzer auf dem Computer sein, auf dem Sie Team Explorer konfigurieren.

So konfigurieren Sie Team Explorer für die Verwendung von Team Foundation Server-Proxy

  1. Startet Microsoft Visual Studio 2012.

  2. Wählen Sie im Menü Extras den Befehl Optionen aus.

    Das Dialogfeld Optionen wird angezeigt.

  3. Erweitern Sie das Menü Quellcodeverwaltung, und wählen Sie dann Visual Studio Team Foundation Server.

  4. Aktivieren Sie das Kontrollkästchen Proxyserver für Dateidownloads verwenden.

  5. Geben Sie im Feld Proxyservername den Namen des Computers ein, der Team Foundation Server-Proxy hostet.

  6. Geben Sie im Feld Port die Portnummer für Team Foundation Server-Proxy ein, und klicken Sie anschließend auf OK.

    Team Foundation Server-Proxy überwacht in der Regel Clientanforderungen auf Port 8081.


Erforderliche Konten für die Installation von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Erforderliche Konten für die Installation von Team Foundation Server
Siehe auch Feedback senden

Sie müssen Dienstkonten verwenden, um Team Foundation Server, Team Foundation Build und Team Foundation Server-Proxy zu installieren. Wenn Sie die Berichterstellung verwenden, ist beim Installieren von Team Foundation Server außerdem ein Berichtsleserkonto erforderlich. In diesem Thema werden die Anforderungen für Dienstkonten und das Berichtsleserkonto für die Installation beschrieben. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server.

Team Foundation Server benötigt für die Installation mehrere Identitäten. Sie können jedoch ein einziges Konto für alle Identitäten verwenden. Dieses muss jedoch die Anforderungen für alle Identitäten erfüllen, für die Sie es verwenden.

Tipp Tipp

Fragen zu Konten? Diese Version enthält jetzt auch ein Tutorial für die Installation von Team Foundation Server, das Fragen zum Erstellen von Konten und Gruppen für eine Einzelserverinstallation beantwortet. Weitere Informationen finden Sie unter Vorbereitung der Installation

Empfohlene Vorgehensweisen für Konten

  • Keines der Konten in diesem Thema sollte zur Sicherheitsgruppe Administratoren gehören.

  • Wenn Sie Domänenkonten für die Dienstkonten verwenden, müssen Sie eine andere Identität für das Berichtsleserkonto verwenden.

  • Beim Installieren einer Komponente in einer Arbeitsgruppe müssen Sie lokale Konten als Benutzerkonten verwenden.

Berichtsleserkonto

Das Berichtleserkonto ist die Identität, mit der Informationen für Berichte erfasst werden. Wenn Sie mit Berichten arbeiten, müssen Sie beim Installieren von Team Foundation Server ein Berichtsleserkonto angeben.

Wenn Sie Team Foundation Server mit den Standardoptionen installieren, wird das Berichtsleserkonto auch als Identität des Dienstkontos für SharePoint Foundation 2010 verwendet.

Feature | Beispielname für die Benutzeranmeldung ¹ | Anforderungen
Berichte | TFSREPORTS | Sie müssen ein Benutzerkonto angeben, das über die Berechtigung Lokal anmelden zulassen verfügt. Standardeinstellung: Sie werden aufgefordert, dieses Konto anzugeben. Sie können kein integriertes Konto als Berichtsleserkonto verwenden.

Dienstkonten

Alle Team Foundation Server, Team Foundation Build und Team Foundation Server Proxy erfordern ein Dienstkonto. Diese Dienstkonten werden die Identität für die installierte Komponente. . Standardmäßig verwendet jede Komponente ein integriertes Konto (z. B. Netzwerkdienst) als Dienstkonto. Sie können stattdessen beim Installieren der Komponente ein Benutzerkonto angeben. Sie müssen jedoch sicherstellen, dass alle verwendeten Benutzerkonten über die Berechtigung Anmelden als Dienst verfügen.

Tipp Tipp

Von integrierten Konten werden keine Kennwörter verwendet, und sie verfügen bereits über die Berechtigung Anmelden als Dienst, wodurch sie insbesondere in einer Domänenumgebung leichter zu verwalten sind.

Dienstkonten für Team Foundation Server

Bei den Dienstkonten in der folgenden Tabelle handelt es sich um die Identitäten für Team Foundation Server und seine Komponenten.

Das Dienstkonto für Team Foundation Server wird auch in Internetinformationsdienste (IIS) als Identität für den Anwendungspool für Team Foundation Server verwendet.

Komponente

Beispielname für die Benutzeranmeldung ¹

Anforderungen

Team Foundation Server

TFSSERVICE

Sie können ein integriertes Konto oder ein Benutzerkonto angeben. Wenn Sie ein Benutzerkonto angeben, muss dieses über die Berechtigung Anmelden als Dienst verfügen.

Das Konto, mit dem Team Foundation Server installiert wird, darf nicht als Konto für TFSSERVICE verwendet werden. Wenn Sie beispielsweise beim Installieren von Team Foundation Server als domain\user1 angemeldet sind, dürfen Sie domain\user1 nicht als Konto für TFSSERVICE verwenden.

Wenn Sie Berichte verwenden, müssen Sie TFSSERVICE der Rolle Inhalts-Manager auf dem Server hinzufügen, auf dem SQL Server Reporting Services ausgeführt wird. Weitere Informationen finden Sie unter Hinzufügen des Dienstkontos von Team Foundation Server zum Berichtsserver.

Wenn die SharePoint-Website nicht zusammen mit Team Foundation Server installiert wurde, müssen Sie TFSSERVICE der Gruppe Farmadministratoren für die Website für die SharePoint-Zentraladministration hinzufügen. Weitere Informationen finden Sie unter Hinzufügen des Dienstkontos für Team Foundation Server zur Gruppe Farmadministratoren.

Standardeinstellung: Netzwerkdienst

Team Foundation Build

TFSBUILD

Sie können ein integriertes Konto oder ein Benutzerkonto angeben. Wenn Sie ein Benutzerkonto verwenden, muss dieses über die Berechtigung Anmelden als Dienst verfügen.

Team Foundation Server-Proxy

TFSPROXY

Sie können ein integriertes Konto oder ein Benutzerkonto angeben. Wenn Sie ein Benutzerkonto verwenden, muss dieses über die Berechtigung Anmelden als Dienst verfügen.

Dienstkonten für zusätzliche Software

In der folgenden Tabelle sind die Dienstkonten aufgeführt, die die Identitäten sind, mit denen Windows-Dienste für SharePoint-Produkte und SQL Server ausgeführt werden.

Das Dienstkonto für SharePoint-Produkte ist auch die Identität des Anwendungspools für die Website für die SharePoint-Zentraladministration.

Software | Beispielname für die Benutzeranmeldung ¹ | Anforderungen
SharePoint-Produkte | WSSSERVICE | Sie müssen ein Benutzerkonto angeben. Standardeinstellung: Wenn Sie Team Foundation Server mit den Standardoptionen installieren, wird das als Berichtsleserkonto angegebene Konto auch für dieses Konto verwendet.
SQL Server | SQLSERVICE | Sie können ein integriertes Systemkonto verwenden oder ein Konto einrichten, bevor Sie SQL Server installieren. Team Foundation Server stellt keine Anforderungen in Bezug auf dieses Konto.

¹ In diesem Handbuch werden die Platzhalternamen verwendet, die in den obigen Tabellen angegeben werden, um die verschiedenen Konten zu erläutern, die für Team Foundation Server erforderlich sind. Diese Platzhalternamen müssen beim Erstellen von Konten nicht angegeben werden.

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit)
Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren des Team Foundation Build-Diensts
Gewusst wie: Zwischenspeichern von Versionskontrolldateien auf einer Remotesite


Erforderliche Ports für die Installation von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Erforderliche Ports für die Installation von Team Foundation Server
Siehe auch Feedback senden

Die Firewall steuert Remoteverbindungen, und für Team Foundation Server sind Remoteverbindungen erforderlich. Sie müssen sicherstellen, dass durch die Firewall nicht die für Team Foundation Server erforderlichen Verbindungen blockiert werden. In den Tabellen in diesem Thema sind die Standardeinstellungen für TCP-Portnummern aufgeführt, die für Team Foundation Server, SQL Server und SharePoint-Produkte erforderlich sind.

Firewalls

Wenn Sie die Windows-Firewall verwenden und diese so konfiguriert ist, dass Ausnahmen zugelassen sind, erstellt der Installations-Assistent für Team Foundation Server Firewallausnahmen für die Komponenten, die Sie installieren, z. B. SharePoint Foundation 2010. Wenn die Windows-Firewall so konfiguriert ist, dass keine Ausnahmen zugelassen sind, sollten Sie die Firewall so konfigurieren, dass während der Installation von Team Foundation Server Ausnahmen zugelassen sind. Andernfalls müssen Sie Ausnahmen manuell erstellen. Weitere Informationen finden Sie auf der Microsoft-Website auf der Seite zum Thema: Konfigurieren der Windows-Firewall auf einem einzelnen Computer.

Wenn Sie eine Software oder Hardwarefirewall eines anderen Anbieters verwenden, sollten Sie in der zugehörigen Dokumentation nachsehen, wie die für diese Installation benötigten TCP-Ports geöffnet werden.

Erforderliche Ports für SQL Server

In der folgenden Tabelle werden die erforderlichen TCP-Ports für SQL Server (Standard oder Enterprise Edition) angegeben.

Server- oder Anwendungskontext | TCP-Port
SQL-Dienst (Datenbankmodul) | 14331
SQL-Browser-Dienst (Datenbankmodul) | 1434
SQL Server Analysis Services Redirector | 2382
SQL Server Analysis Services | 2383
SQL Server Reporting Services | 80

1SQL Server verwendet Port 1433 für die Standardinstanz. Für benannte Instanzen verwendet SQL Server einen dynamischen Anschluss, der vom Betriebssystem zugewiesen wird. Mithilfe des SQL Server-Konfigurations-Mangers können Sie die SQL Server-Anschlussnummer für eine beliebige benannte Instanz bestimmen. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Konfigurieren der Windows-Firewall für den SQL Server-Zugriff.

Portanforderungen des Berichtsservers

Sie müssen sicherstellen, dass der Berichtsserver in der Windows-Firewall eine Ausnahme für die Windows-Verwaltungsinstrumentation (Windows Management Instrumentation, WMI) enthält, sofern sich der Berichtsserver nicht auf dem Server befindet, auf dem Team Foundation Server ausgeführt wird. Die Anweisungen zum Ausführen dieser Aufgabe unterscheiden sich je nach verwendetem Betriebssystem. Wenn Sie Windows Server 2003 oder Windows Server 2003 R2 verwenden, lesen Sie die folgende Seite auf der Microsoft-Website: Herstellen von Verbindungen über Windows-Firewall. Wenn Sie Windows Server 2008, Windows Server 2008 R2, Windows Vista oder Windows 7 verwenden, lesen Sie die folgende Seite auf der Microsoft-Website: Herstellen einer Remoteverbindung mit WMI über Windows Vista.

Erforderliche Ports für SharePoint-Produkte

In der Tabelle in diesem Abschnitt sind die TCP-Portnummern ausgeführt, die SharePoint Foundation 2010 verwendet, wenn es über den Installations-Assistenten für Team Foundation Server installiert wird.

Diese Portnummern können für vorhandene Bereitstellungen von SharePoint-Produkte unterschiedlich sein. Sie können die von SharePoint-Produkte verwendeten Portnummern bestimmen, indem Sie den Internetinformationsdienste-Manager öffnen und die Websiteeigenschaften überprüfen. Weitere Informationen finden Sie unter Überprüfen von SharePoint-Produkten für Team Foundation Server.

Server- oder Anwendungskontext | TCP-Port
Standardwebsite | 80
SharePoint-Zentraladministration | 17012

Erforderliche Ports für Team Foundation Server

Standardgemäß verwendet Team Foundation Server die folgenden TCP-Ports:

Server- oder Anwendungskontext | TCP-Port
Team Foundation Server | 8080
Team Foundation Server Proxy | 8081
Team Foundation-Builddienst | 9191

Siehe auch

Konzepte

Gewusst wie: Installieren von Team Foundation Server mithilfe der Standardkonfiguration
Gewusst wie: Installieren von Team Foundation Server mit der erweiterten Konfiguration
Gewusst wie: Installieren einer Team Foundation Server-Farm (Hochverfügbarkeit)
Gewusst wie: Aktualisieren von Team Foundation Server
Gewusst wie: Installieren des Team Foundation Build-Diensts
Gewusst wie: Zwischenspeichern von Versionskontrolldateien auf einer Remotesite


Gewusst wie: Hinzufügen des Dienstkontos für Team Foundation Server zur SQL Server-Datenbankrolle TFSEXECROLE

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Hinzufügen des Dienstkontos für Team Foundation Server zur SQL Server-Datenbankrolle TFSEXECROLE
Feedback senden

Diese Fehlermeldung kann darauf hinweisen, dass das Dienstkonto für Team Foundation Server (TFSSERVICE) nicht mehr Mitglied von TFSEXECROLE ist, einer SQL Server-Datenbankrolle, die während der Team Foundation Server-Installation erstellt wird.

Um dieses Problem zu beheben, müssen Sie das Dienstkonto (TFSSERVICE) für die primäre Anwendungsebene manuell zur TFSEXECROLE auf der Instanz von SQL Server hinzufügen, die die Konfigurationsdatenbank hostet.

Weitere Informationen zu Dienstkonten finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

Erforderliche Berechtigungen

Um diese Vorgehensweisen auszuführen, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf der Instanz von SQL Server sein, die die Konfigurationsdatenbank für die primäre Anwendungsebene hostet.

So fügen Sie das Dienstkonto für Team Foundation Server zur SQL Server-Datenbankrolle TFSEXECROLE hinzu

  1. Klicken Sie auf Start, zeigen Sie auf Alle Programme und auf Microsoft SQL Server 2008, und klicken Sie anschließend auf SQL Server Management Studio.

    Das Dialogfeld Mit Server verbinden wird angezeigt.

  2. Klicken Sie in der Liste Servertyp auf Datenbankmodul.

  3. Geben Sie den Namen des Servers ein, der die Konfigurationsdatenbank für die primäre Anwendungsebene hostet, und klicken Sie dann auf Verbinden.

  4. Erweitern Sie in Objekt-Explorer den Eintrag Datenbanken, erweitern Sie Tfs_DatabaseLabelApplication, erweitern Sie Sicherheit, erweitern Sie Rollen, erweitern Sie Datenbankrollen, klicken Sie mit der rechten Maustaste auf TFSEXECROLE, und klicken Sie dann auf Eigenschaften.

    Tfs_DatabaseLabelApplication kann statt DatabaseLabel eine Bezeichnung enthalten oder kurz als Tfs_Application angezeigt werden.

    Das Dialogfeld Datenbankrolle-Eigenschaften für TFSEXECROLE wird angezeigt.

  5. Klicken Sie unter Rollenmitglieder auf Hinzufügen.

    Das Dialogfeld Datenbankbenutzer oder -rolle auswählen wird geöffnet.

  6. Geben Sie das Dienstkonto (TFSSERVICE) für die primäre Anwendungsebene ein, und klicken Sie auf OK.

  7. Klicken Sie auf OK.