Verwalten von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Verwalten von Team Foundation Server
Siehe auch Feedback senden

Willkommen beim Administratorhandbuch für Visual Studio Team Foundation Server 2012, auch als TFS bekannt. Es bietet eine optimale Einführung in die Konfiguration, Verwaltung und Verwendung von TFS zur Unterstützung Ihrer geschäftlichen Anforderungen. Diese Informationen sind so konzipiert, dass sowohl Einsteiger an TFS herangeführt werden, als auch erfahrene Administratoren den bestmöglichen Vorteil aus dieser neuesten Version nutzen können.

Administratoren von TFS installieren, konfigurieren und verwalten die Bereitstellung. Sie führen u. a. folgende Aufgaben aus:

  • Sichern und Wiederherstellen von Daten

  • Hinzufügen von Servern, Funktionen und anderen Ressourcen zur Bereitstellung

  • Verwalten von Berechtigungen und Sicherheit

  • Organisieren von Projekten und zugehörigen Ressourcen durch das Erstellen und Verwalten von Teamprojektsammlungen

  • Gewährleisten der Sicherheit der Bereitstellung durch das Erstellen von Gruppen auf Server- und Auflistungsebene für die Verwaltung von Benutzern und deren Berechtigungen

  • Verwalten von Gruppen und Berechtigungen auf Servern, die in die Bereitstellung integriert sind, z. B. SQL Server Reporting Services und SharePoint-Produkte, oder Koordinieren der Aufgaben mit den Administratoren dieser Server für einen fehlerfreien Betrieb von Team Foundation Server mit den Ressourcen

  • Verwalten von Diensten und Dienstkonten, die in der Bereitstellung verwendet werden

Als Administrator von TFS sollten Sie sich mit den Windows-Sicherheitseinschränkungen, der Benutzerkontensteuerung sowie dem Betrieb und der Sicherheit von SQL Server-Datenbanken vertraut machen. Wenn die Bereitstellung in SharePoint-Produkte integriert ist, sollten Sie sich zudem informieren, wie Siteauflistungen und Webanwendungen verwaltet werden.

Als Administrator einer neuen oder noch nicht installierten Bereitstellung sollten Sie sorgfältig überprüfen, welche Funktionen von TFS Sie installieren möchten und wie Sie diese installieren. Durch die Auswahl einer geeigneten Bereitstellungstopologie für die Anforderungen Ihres Unternehmens tragen Sie dazu bei, die langfristige Verwaltbarkeit und Nachhaltigkeit der von Ihnen unterstützten Softwareprojekte aufrechtzuerhalten. Anhand der Beispieltopologien von TFS können Sie überprüfen, welche Art von Topologie am besten für Ihre Anforderungen geeignet ist, oder Sie können den Anweisungen des Lernprogramms folgen, das Sie beim Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] unterstützt. Eventuell kommt Team Foundation-Dienst, eine gehostete Version von TFS, als beste Lösung für Sie und Ihr Unternehmen infrage.

Dieses Handbuch und das Installationshandbuch sind als Online- und Offlineversion verfügbar:

  • Die aktuelle Version dieses Handbuchs finden Sie auf der folgenden Seite der Microsoft-Website: Verwalten von Team Foundation Server. Laden Sie die aktuelle Version dieses Handbuchs von der folgenden Seite auf der Microsoft-Website herunter: Administratorhandbuch zum Herunterladen.

  • Aktuelle Informationen über das Installieren von Team Foundation sowie eine herunterladbare Version des Installationshandbuchs finden Sie auf dieser Seite der Microsoft-Website: Installieren von Team Foundation Server und Visual Studio ALM.

  • Die Offlineversionen dieser Handbücher sind kompilierte Dateien des Hilfemoduls (.chm). Sollten Sie eine heruntergeladene CHM-Datei nicht öffnen können, lesen Sie den letzten Abschnitt dieses Themas, um dieses Problem zu lösen.

Ressourcen, die Sie beim Verwalten von TFS unterstützen

Inhalt

Allgemeine Aufgaben

Lernprogramme für Team Foundation Server

Grundlagen zu Verwaltungskonzepten und -tools

Organisieren des Servers mit Teamprojektsammlungen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten

Zugriff auf Funktionen über Webberechtigungen

Erfahren Sie mehr zu Team Foundation Server: Sie können die Features und Funktionen von TFS überprüfen, die Serverarchitektur sowie Beispielbereitstellungstopologien durchsuchen, die für Ihre Geschäftsanforderungen bestmögliche Bereitstellungsstruktur auswählen und den Lernprogrammen folgen, die Ihnen helfen sollen, die ersten Schritte einer Einzelserverbereitstellung zu bewältigen.

Installieren von Team Foundation Server und Visual Studio ALM

Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]

Installieren von Team Foundation Server: Sie können das Installations- oder das Upgradeszenario für die Bereitstellung wählen und erforderliche Komponenten sowie Team Foundation-Komponenten zur Unterstützung Ihrer Softwareentwicklungsprojekte installieren.

Informationen zur Aktualisierung Ihrer Version von Team Foundation Server finden Sie unter Gewusst wie: Aktualisieren von Team Foundation Server.

Upgrade von Team Foundation Server: Sie können von einer Version von TFS auf eine andere Version aktualisieren. Sie können auch eine frühere Version von TFS auf Visual Studio Team Foundation Server 2012 aktualisieren.

Verwalten der Serverkonfiguration

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Dienstkonten und Abhängigkeiten in Team Foundation Server

Sichern und Wiederherstellen der Bereitstellung

Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]

Beenden und Starten von Diensten, Anwendungspools und Websites

Konfigurieren von E-Mail-Benachrichtigungen und Angeben des SMTP-Servers

Sichern von Team Foundation Server

Verwalten der Server und Ressourcen in der Bereitstellung: Nach der Installation und Erstkonfiguration von TFS können Sie die Konfiguration zur Unterstützung der Entwicklungsprojekte oder zur Erhöhung der Sicherheit der Bereitstellung überwachen und ändern. Sie sollten auch einen Sicherungsplan erstellen, um Ihre Daten zu schützen. Sie können Teile der Bereitstellung auch erweitern oder verschieben, um diese den Geschäftsanforderungen anzupassen.

Erstellen einer Teamprojektsammlung

Ändern einer Teamprojektsammlung

Erstellen von Teamprojektsammlungen: Sie können eine Gruppe von Entwicklungsprojekten und die Ressourcen, die diese unterstützen, in einer Teamprojektsammlung organisieren. Es können beliebig viele Teamprojektsammlung zur Unterstützung Ihrer Entwicklungsaufgaben erstellt werden.

Konfigurieren und Verwalten von Lab-Management

Hinzufügen von virtuellen Computern als Entwicklungs- und Testressourcen: Sie können Visual Studio Lab Management so konfigurieren, dass der vom Team erzeugte Code in virtuellen Umgebungen entwickelt und getestet werden kann.

Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten

Hinzufügen von Berichts- oder Projektportalressourcen zu vorhandenen Teamprojekten: Sie können die Ressourcen erweitern oder ändern, die den Mitgliedern des Teams zur Verfügung stehen. Zu diesen Ressourcen zählen Prozessleitfäden, ein Teamprojektportal und eine freigegebene Dokumentbibliothek.

Verwalten der Team Foundation-Versionskontrolle

Ändern der Speicherung von Quellcode und des Zugriffs: Sie können die hohe Qualität des Codes sicherstellen, indem Sie Eincheckrichtlinien und Auscheckeinstellungen konfigurieren und den Zugriff auf den Quellcode optimieren.

Verwalten von Team Foundation Build

Ändern der Erstellung von Quellcode: Sie können das automatisierte Build-System so konfigurieren und verwalten, dass das Team Software automatisch und einheitlich in einer verteilten Umgebung erstellen und testen kann.

Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams

Erste Schritte im Team

Verwalten des Profils und Anzeigen von Berechtigungen

Hinzufügen von Benutzern zu Teamprojekten

Festlegen von Administratorberechtigungen für Teamprojektsammlungen

Festlegen von Administratorberechtigungen für Team Foundation Server

Team Foundation Server-Berechtigungen

Team Foundation Server: Standardgruppen, Berechtigungen und Rollen

Verwalten von Benutzern und Gruppen: Sie können steuern, welche Benutzer Zugriff auf die Teamprojekte, die Teamprojektsammlungen und die Server haben, auf denen die Komponenten von Team Foundation ausgeführt werden. Darüber hinaus können Sie steuern, welchen Satz von Aufgaben jeder Benutzertyp ausführen kann.

  • Verwalten von Gruppen und Gruppenmitgliedschaft: Sie können Benutzer in TFS leichter organisieren und verwalten, indem Sie die Standardgruppen und zugehörigen Berechtigungen in einem Teamprojekt, einer Teamprojektsammlung oder auf Serverebene verwenden. Zudem können Sie benutzerdefinierte Gruppen erstellen und ihnen bestimmte Berechtigungen für die Aufgaben der Benutzer erteilen, die an den Projekten mitarbeiten.

  • Verwalten von Benutzern außerhalb von Gruppen: Sie können TFS einen Benutzer mit anderen als die für diese Gruppenmitgliedschaft erteilten Berechtigungen hinzufügen.

  • Verwalten von Berechtigungen: Sie können die einem Benutzer oder einer Gruppe auf Server-, Auflistungs- und Projektebene erteilten Berechtigungen anzeigen und ändern. Durch Kenntnisse über die Systemberechtigungen können Sie benutzerdefinierte Gruppen und deren Berechtigungen besser definieren und auf die Sicherheitsanforderungen der Bereitstellung abstimmen.

Technische Referenz für Team Foundation

Technische Referenz: Erfahren Sie mehr über die Befehlszeilentools für die Verwaltung der Bereitstellung.

TFS-Verwaltungsforum

Projektmappen und Projekte von Visual Studio ALM Rangers

Team Foundation Server-Blog

Fachartikel zu Visual Studio Application Lifecycle Management

Showcase für agile Entwicklung

TFS mit CodePlex

Zusätzliche Ressourcen: Der Austausch mit gleichgesinnten Administratoren in Foren und Blogs sowie realitätsgetreue Bereitstellungsbeispiele sind manchmal der beste Weg, sich mit TFS vertraut zu machen.

Öffnen einer heruntergeladenen CHM-Datei

Auf Computern, auf denen das Sicherheitsupdate 896358 installiert ist, können heruntergeladene CHM-Dateien nicht geöffnet werden. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Nach der Installation von Sicherheitsupdate 896358 oder Windows Server 2003 Service Pack 1 können Hilfe-Dateien im HTML-Format nicht mehr mit Internet Explorer geöffnet werden.

Um dieses Problem zu umgehen, verwenden Sie eine dieser Methoden:

Methode 1

  1. Öffnen Sie die CHM-Datei.

  2. Deaktivieren Sie im angezeigten Dialogfeld Datei öffnen - Sicherheitswarnung das Kontrollkästchen Vor dem Öffnen dieser Datei immer bestätigen.

  3. Wählen Sie Öffnen aus.

Methode 2

  1. Öffnen Sie das Kontextmenü der CHM-Datei, und wählen Sie dann Eigenschaften aus.

  2. Wählen Sie Zulassen aus.

  3. Öffnen Sie die CHM-Datei.

Siehe auch

Konzepte

Planen und Nachverfolgen von Projekten
Qualitätsverbesserung mit Visual Studio-Diagnosetools
Neues in der Verwaltung des Lebenszyklus von Anwendungen in Visual Studio 2012
Bild für Footer
Senden Sie Feedback zu diesem Thema an Microsoft.


Lernprogramme für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Lernprogramme für Team Foundation Server
Siehe auch Feedback senden

Das Installieren und Verwalten einer Team Foundation Server-Bereitstellung kann mit der Zeit einschüchternd wirken, insbesondere wenn die Verwaltung von Team Foundation Server neu für Sie ist. Sie können jedoch die folgenden Lernprogramme heranziehen, die Ihnen beim Verständnis des Installations- und Konfigurationsprozesses helfen, die erforderlichen Schritte zum Erstellen von Teamprojekten und zum Hinzufügen von Benutzern zu Teamprojekten aufzeigen und beschreiben, wie Sie die Bereitstellung für diese Vorabversion von Team Foundation Server sichern und wiederherstellen. Selbst wenn die ausgewählte Bereitstellungskonfiguration nicht genau mit der Konfiguration übereinstimmt, die in den Beispielen in diesen Lernprogrammen dargestellt ist, können Ihnen diese Themen dennoch bei der Konfiguration und Verwaltung Ihrer eigenen Bereitstellung helfen.

Hinweis Hinweis

Die in den Lernprogrammen verwendeten Namen von Firmen, Organisationen, Produkten, Domänen, Personen, Orten, Ereignissen sowie E-Mail-Adressen und Logos sind frei erfunden. Jede Ähnlichkeit mit tatsächlichen Firmen, Organisationen, Produkten, Domänen, Personen, Orten, Ereignissen, E-Mail-Adressen und Logos ist rein zufällig.

In diesem Abschnitt

Titel | Beschreibung
Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] | Erfahren Sie, wie Sie eine Bereitstellung von Team Foundation Server in einer einzelnen Konfiguration, einschließlich SQL Server Reporting Services und SharePoint Foundation 2010, installieren, konfigurieren und verwalten können. Erfahren Sie, wie Sie Skripts konfigurieren, mit denen die Bereitstellung auf einem Einzelserver bei einem Hardwarefehler oder in einem anderen Notfall gesichert wird.
Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm] | Erfahren Sie, wie Sie die von Ihnen konfigurierten Gruppen und von Ihnen erstellten Sicherungen der Team Foundation Server-Datenbanken und der SharePoint Foundation 2010-Farm verwenden können, um die Bereitstellung auf einem neuen Server im Falle eines Hardwarefehlers der Originalbereitstellung bereitstellen können.

Siehe auch

Konzepte

Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen
Erste Schritte im Team
Agile-Planung und -Iterationen
Arbeiten mit Team Foundation-Clients
Installieren von Team Foundation Server und Visual Studio ALM
Grundlagen zu Verwaltungskonzepten und -tools
Konfigurieren von Benutzern, Gruppen und Berechtigungen
Technische Referenz für Team Foundation

Weitere Ressourcen

Prozessleitfaden und Prozessvorlagen


Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]
Feedback senden

Das Installieren von Team Foundation Server ist recht einfach. Die Verwaltung dieser Installation kann sich jedoch komplex gestalten. Als ein Administrator, müssen Sie Projekte erstellen, Benutzer zum System hinzufügen und Berechtigungen für diese Benutzer festlegen. Sie müssen alle Benutzer im System verwalten, damit die Bereitstellung für diejenigen sofort verfügbar und funktionsfähig ist, die darauf zugreifen dürfen. Nicht berechtigte Benutzer sollten davon ausgeschlossen sein. Sie möchten auch sicherstellen, dass die Bereitstellung gesichert wird, wenn ein Problem mit der Serverhardware oder andere Probleme auftreten, beispielsweise ein Virus, wodurch die Daten beschädigt werden.

Das frühzeitige Vorbereiten Ihrer Installation kann das Verwalten von Benutzern über die gesamte Bereitstellungslebensdauer einfacher gestalten. Entsprechend kann das Einrichten von Sicherungen für das System nach der Installation und Konfiguration der Software Ihnen beim Wiederherstellen Ihrer Bereitstellung helfen, wenn dies erforderlich ist.

Hinweis Hinweis

Dieses Lernprogramm enthält fiktive Benutzer, Server und Unternehmen als Bestandteil der Beispiele, mit denen die Prozeduren veranschaulicht werden. Die in den Beispielen verwendeten Firmen, Organisationen, Produkte, Domänennamen, E-Mail-Adressen, Logos, Personen, Orte und Ereignisse sind frei erfunden. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Domänennamen, E-Mail-Adressen, Logos, Personen, Orten oder Ereignissen ist rein zufällig.

Inhalte des Lernprogramms

Titel | Beschreibung
Vorbereiten für die Installation | Erfahren Sie mehr über Benutzer, Gruppen und Berechtigungen in Team Foundation Server-Bereitstellungen, und planen Sie im Voraus, um das Verwalten dieser Berechtigungen über die Bereitstellung hinweg, die SQL Server Reporting Services, SharePoint Foundation 2010 und Team Foundation Server verwendet, einfacher zu gestalten. Erfahren Sie, wie Benutzergruppen erstellt und verwaltet und Konten als Dienstkonten verwendet werden können.
Installieren von erforderlichen Komponenten und Team Foundation Server | Erfahren Sie, wie Team Foundation Server in einem der häufigsten Installationstypen installiert wird. Sie lernen, wie die erforderlichen Komponenten für eine Einzelserverinstallation installiert werden und wie Team Foundation Server mithilfe des standardmäßigen Assistenten installiert wird.
Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams | Erfahren Sie, wie Projekte in Team Foundation Server erstellt werden. Sie lernen, wie Sie Benutzergruppen für diese Projekte so konfigurieren, dass sie über die Berechtigungen verfügen, die sie in Team Foundation Server, SQL Server Reporting Services und SharePoint Foundation 2010 benötigen. Außerdem erfahren Sie, wie eine Benutzergruppe über das Anzeigen eines Projekts im Team Foundation Server eingeschränkt werden kann.
Erstellen eines Backupplans | Erfahren Sie, wie Sie manuell Sicherungen für alle Komponenten konfigurieren können, die von einer einzelnen Serverbereitstellung von Team Foundation Server verwendet werden.


Vorbereiten für die Installation

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Vorbereiten für die Installation
Feedback senden

In diesem Thema, dem ersten Teil des Lernprogramms zur Einzelserverinstallation, lernen Sie, wie Gruppen erstellt werden, um Benutzer für Team Foundation Server, SharePoint Foundation 2010 und SQL Server Reporting Services zu verwalten. Darüber hinaus lernen Sie, welche Arten von Konten als Dienstkonten in der Bereitstellung verwendet werden können, damit Sie diese Konten ggf. erstellen können, bevor Sie mit der Installation beginnen.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber", und sie installiert Team Foundation Server in einer Einzelserverkonfiguration, um die Softwareentwicklungsteams zu unterstützen.

In diesem Thema

  • Benutzer, Gruppen und Berechtigungen in Team Foundation Server-Bereitstellungen

    • So erstellen Sie eine Gruppe in Active Directory

    • So erstellen Sie eine lokale Gruppe auf dem Server

    • So erstellen Sie ein Konto, das als Dienstkonto in Active Directory verwendet wird

    • So erstellen Sie ein lokales Konto, das als Dienstkonto auf dem Server verwendet wird

Erforderliche Berechtigungen

Zum Ausführen der Verfahren in diesem Lernprogramm müssen Sie Mitglied dieser Gruppen sein:

  • Der Sicherheitsgruppe Administratoren auf dem Server, auf dem Sie Team Foundation Server installieren möchten

  • Der Gruppe Kontooperatoren, Domänen-Admins oder Organisations-Admins; alternativ benötigen Sie die entsprechenden Berechtigungen in den Active Directory-Domänendiensten, wenn Sie beabsichtigen, Active Directory-Gruppen zu erstellen, um Benutzer in Ihrer Bereitstellung zu verwalten, oder ein Active Directory-Konto als Dienstkonto zu verwenden. Wenn Sie zudem beabsichtigen, verwaltete Dienstkonten als Teil der Bereitstellung zu verwenden, benötigen Sie eventuell weitere Berechtigungen und zusätzliche Software, um ein entsprechendes, verwaltetes Dienstkonto zu erstellen. Weitere Informationen finden Sie unter Schrittweise Anleitung zu Dienstkonten.

Benutzer, Gruppen und Berechtigungen in Team Foundation Server-Bereitstellungen

Team Foundation Server, SharePoint-Produkte und alle SQL Server Reporting Services erhalten ihre eigenen Informationen zu Gruppen, Benutzern und Berechtigungen aufrecht. Um das Verwalten von Benutzern und Berechtigungen für diese Programme einfacher zu machen, können Sie Benutzergruppen mit ähnlichen Zugriffsanforderungen in der Bereitstellung erstellen und diesen Gruppen die erforderlichen Zugriffsberechtigungen für die verschiedenen Softwareprogramme erteilen und dann einfach nach Bedarf Benutzer zur Gruppe hinzufügen oder Benutzer aus einer Gruppe entfernen. Dies ist deutlich einfacher als einzelne Benutzer oder Benutzergruppen separat in drei verschiedenen Programmen zu verwalten.

Wenn sich der Server in einer Active Directory-Domäne befindet, können Sie bestimmte Active Directory-Gruppen erstellen, um die Benutzer zu verwalten. Dabei kann es sich um eine Gruppe von Entwicklern und Testern für alle Projekte in der Teamprojektsammlung oder um eine Gruppe von Benutzern handeln, die Projekte in der Auflistung erstellen und verwalten können. Entsprechend können Sie ein Active Directory-Konto für Dienste erstellen, das nicht für die Verwendung des Netzwerkdienst-Systemkontos als Dienstkonto konfiguriert werden kann. Erstellen Sie dazu ein Active Directory-Konto für SharePoint Foundation 2010 und als Datenquellenkonto mit Lesezugriff für Berichte in SQL Server Reporting Services.

Tipp Tipp

In der Beispielsbereitstellung verwendet Jill das Netzwerkdienst-Systemkonto als Dienstkonto für Team Foundation Server und SQL Server 2008. Diese Option ist die Standardoption. Sie können ein bestimmtes Konto als Dienstkonto verwenden (aus Sicherheitsgründen oder anderen Gründen). Jill erstellt auch ein bestimmtes Active Directory-Konto, um es als Dienstkonto für SharePoint Foundation 2010 und als Datenquellen-Leserkonto für SQL Server Reporting Services zu verwenden. Sie benennt dieses Konto SVCSPTRS.

Wenn sich der Server in einer Active Directory-Domäne befindet und Sie keine Berechtigungen haben, Active Directory-Gruppen oder -Konten zu erstellen, oder wenn Sie den Server in einer Arbeitsgruppe anstatt einer Domäne installieren, können Sie lokale Gruppen erstellen und verwenden, um Benutzer für SQL Server 2008, SharePoint Foundation 2010 und Team Foundation Server zu verwalten. Entsprechend können Sie ein lokales Konto erstellen, um es als Dienstkonto zu verwenden. Beachten Sie jedoch, dass lokale Gruppen und Konten weniger stabil als Domänengruppen und -konten sind. Bei einem Serverfehler müssten Sie beispielsweise die Gruppen und Konten auf dem neuen Server vollkommen neu erstellen. Wenn Sie Active Directory-Gruppen und -Konten verwenden, werden die Gruppen und Konten beibehalten, auch wenn der Server ausfällt, der als Host für Team Foundation Server fungiert.

In der Beispielsbereitstellung analysiert Jill die Geschäftsanforderungen für die neue Bereitstellung und überprüft die Sicherheitsanforderungen mit den Projektmanagern. Sie erstellt drei Gruppen zum Verwalten der Mehrzahl an Benutzern in der Bereitstellung:

  • Eine allgemeine Gruppe für Entwickler und Tester, die durchweg an allen Projekten in der Standardteamprojektsammlung teilnehmen. Diese Gruppe enthält die Mehrzahl der Benutzer. Sie nennt diese Gruppe "TFS_ProjectContributors", die zum Anzeigenamen "Fabrikam-Entwickler und -Tester" aufgelöst wird.

  • Eine kleine Gruppe von Projektadministratoren, die über Berechtigungen zum Erstellen und Verwalten von Projekten in der Auflistung verfügen. Sie nennt diese Gruppe "TFS_ProjectAdmins", die zum Anzeigenamen "Fabrikam Project Administrators" aufgelöst wird.

  • Eine spezielle, eingeschränkte Gruppe von Vertragsnehmern, die lediglich über den Zugriff auf eines der Projekte verfügen. Sie nennt diese Gruppe "TFS_RestrictedAccess", die zum Anzeigenamen "Fabrikam - beschränkter Zugriff" aufgelöst wird.

Später, wenn die Bereitstellung erweitert wird, entscheidet sie sich möglicherweise dazu, eine andere Gruppe zu erstellen.

So erstellen Sie eine Gruppe in Active Directory

  • Erstellen Sie entsprechend Ihren geschäftlichen Anforderungen eine Sicherheitsgruppe, die eine lokale Domäne, eine globale Gruppe oder eine universelle Gruppe in Active Directory ist. Wenn die Gruppe beispielsweise Benutzer aus mehreren Domänen enthalten soll, erfüllt eine universelle Gruppe Ihre Anforderungen am besten. Weitere Informationen finden Sie unter Erstellen einer neuen Gruppe (Active Directory-Domänendienste).

    In der Beispielsbereitstellung hat Jill drei Active Directory-Gruppen, wie oben angegeben, erstellt.

So erstellen Sie eine lokale Gruppe auf dem Server

  • Erstellen Sie eine lokale Gruppe, und weisen Sie ihr einen Namen zu, aus dem ihr Zweck unmittelbar hervorgeht. Standardgemäß hat jede Gruppe, die Sie erstellen, die gleichen Berechtigungen der Benutzerstandardgruppe auf dem entsprechenden Computer. Weitere Informationen finden Sie unter Erstellen einer lokalen Gruppe.

So erstellen Sie ein Konto, das als Dienstkonto in Active Directory verwendet wird

  • Erstellen Sie ein Konto in Active Directory, legen Sie die Kennwortrichtlinie entsprechend Ihren geschäftlichen Anforderungen fest, und stellen Sie sicher, dass Konto wird für Delegierungszwecke vertraut für das Konto ausgewählt ist. Weitere Informationen finden Sie unter Erstellen eines neuen Benutzerkontos (Active Directory-Domänendienste) und Grundlegendes zu Benutzerkonten (Active Directory-Domänendienste).

    In diesem Lernprogramm verwendet Jill den Netzwerkdienst des Systemkontos als Dienstkonto für Team Foundation Server. Sie erstellt jedoch ein bestimmtes Active Directory-Konto, das als Dienstkonto für SharePoint Foundation 2010 und als Datenquellen-Leserkonto für SQL Server Reporting Services verwendet wird. Sie benennt dieses Konto SVCSPTRS.

So erstellen Sie ein lokales Konto, das als Dienstkonto auf dem Server verwendet wird

  • Erstellen Sie ein lokales Konto, das als Dienstkonto verwendet werden soll, und ändern Sie dann die Gruppenmitgliedschaft und andere Eigenschaften des Kontos entsprechend den Sicherheitsanforderungen Ihres Unternehmens. Weitere Informationen finden Sie unter Erstellen eines lokalen Benutzerkontos.

POS1 | Vorbereiten für die Installation | Installieren von erforderlichen Komponenten und Team Foundation Server | Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams | Erstellen eines Backupplans


Installieren von erforderlichen Komponenten und Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Installieren von erforderlichen Komponenten und Team Foundation Server
Feedback senden

In diesem zweiten Thema des Lernprogramms zur Einzelserverinstallation lernen Sie, wie die erforderlichen Komponenten installiert und konfiguriert werden, die von Team Foundation Server benötigt werden. Darüber hinaus lernen Sie, wie Team Foundation Server in einer Einzelserverkonfiguration installiert wird, die SharePoint Foundation 2010 und SQL Server Reporting Services verwendet.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber", und sie installiert Team Foundation Server in einer Einzelserverkonfiguration, um die Softwareentwicklungsteams zu unterstützen.

Das Installieren von Team Foundation Server und der erforderlichen Komponenten ist einfacher, als Sie es sich möglicherweise vorstellen. Da die Installation der Software Zeit und Geduld erfordert, können Sie die nachfolgenden Schritte ausführen, um den Prozess zu optimieren und eine neue Einzelserverbereitstellung von Team Foundation Server zu installieren, zusammen mit der Berichterstellung, die von SQL Server Reporting Services bereitgestellt wird, und mit Teamprojektportalen, die auf SharePoint Foundation 2010 gehostet werden.

Tipp Tipp

Es gibt viele verschiedene Möglichkeiten, wie Sie Team Foundation Server installieren und konfigurieren können. In diesem Lernprogramm wird gezeigt, wie Sie einen neuen Server mit sämtlichen neuen Installationen der erforderlichen Komponenten installieren. Sie können aber auch vorhandene Installationen der erforderlichen Komponenten verwenden oder Team Foundation Server in einer anderen Konfiguration installieren. Weitere Informationen finden Sie unter Installieren von Team Foundation Server und Visual Studio ALM.

In der Beispielsbereitstellung hat Jill die Systemanforderungen und verschiedene Konfigurationstypen für Team Foundation Server durch Lesen des Installationshandbuchs überprüft. Sie erläuterte die voraussichtliche Anzahl von Benutzern und Projekten mit den Projektmanagern und die Funktionen, die diese Manager am meisten interessierten. Nach der Überprüfung der Auswahlmöglichkeiten und Anforderungen hat Jill beschlossen, dass die beste Konfiguration für ihre Softwareentwicklungsteams und die Geschäftsanforderungen der Projektmanager darin besteht, den Team Foundation Server mithilfe des standardmäßigen Assistenten auf einem Einzelserver zu installieren. Die Konfiguration des standardmäßigen Assistenten ist relativ einfach und verwendet das Netzwerkdienstkonto als Dienstkonto für Team Foundation Server. Der Assistent installiert auch SharePoint Foundation 2010, wofür ein separates Dienstkonto erforderlich ist. Im vorherigen Thema in diesem Lernprogramm Vorbereiten für die Installation hat Jill ein Active Directory-Konto speziell für diesen Zweck erstellt.

Bevor Jill den Team Foundation Server installieren kann, muss sie zunächst die erforderlichen Komponenten auf dem Server installieren und konfigurieren, auf dem die 64-Bit-Edition des Windows Server 2008 R2-Betriebssystems mit installiertem Service Pack 1 läuft, der mit einem Dual-Core-Prozessor und mit einem 10 GB RAM ausgerüstet ist und der über 300 GB freien Speicherplatz verfügt. Um die Voraussetzungen für Team Foundation Server zu erfüllen, muss sie eine unterstützte Version von SQL Server installieren, damit sowohl Team Foundation Server als auch SharePoint Foundation 2010 verwendet werden können. Sie installiert SQL Server 2008 R2, Standard Edition.

In diesem Thema

  • Installieren von SQL Server 2008 R2 zur Unterstützung von Team Foundation Server

  • Installieren von Team Foundation Server auf dem Server

  • Installieren von Team Explorer auf dem Server

Erforderliche Berechtigungen

Um die Schritte in diesem Thema auszuführen, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Sie die Software installieren möchten.

So installieren Sie SQL Server 2008 R2 zur Unterstützung von Team Foundation Server

  1. Starten Sie das SQL Server-Installationscenter.

  2. Wählen Sie auf der Seite SQL Server-Installationscenter die Option Installation und dann Neue Installation oder Hinzufügen von Features zu einer vorhandenen Installation aus.

  3. Stellen Sie auf der Seite Setupunterstützungsregeln sicher, dass alle Regeln bestanden haben, und wählen Sie anschließend OK aus.

  4. Stellen Sie auf der Seite Product Key Ihren Product Key bereit, oder wählen Sie eine kostenlose Edition aus, und wählen Sie dann Weiter aus.

    Tipp Tipp

    Wenn Sie eine Evaluierungsversion auswählen und diese nicht vor dem Ablauf des Evaluierungszeitraums aktualisieren, kann die Bereitstellung von Team Foundation Server nicht mehr verwendet werden.

  5. Lesen Sie die Lizenzvereinbarung auf der Seite Lizenzbedingungen. Wenn Sie mit den Bedingungen einverstanden sind, wählen Sie Ich stimme den Lizenzbedingungen zu aus. Aktivieren Sie optional das Kontrollkästchen, um Nutzungsdaten an Microsoft zu senden, und wählen Sie anschließend Weiter aus.

  6. Wählen Sie auf der Seite Setup-Unterstützungsdateien die Option Installieren aus.

  7. Überprüfen Sie auf der Seite Setupunterstützungsregeln die Setupinformationen. Beheben Sie alle Fehlerbedingungen, und wählen Sie dann Weiter aus.

  8. Wählen Sie auf der Seite Setuprolle die Option SQL Server-Funktionsinstallation aus, und wählen Sie anschließend Weiter aus.

  9. Aktivieren Sie auf der Seite Featureauswahl die folgenden Kontrollkästchen, und wählen Sie dann Weiter aus:

    • Datenbankmoduldienste

    • Volltextsuche

    • Analysis Services

    • Reporting Services

    • Konnektivität der Clienttools

    • Verwaltungstools - Einfach

    • Verwaltungstools - vollständig

    SQL Server 2008 R2 installieren - Funktionen
    Tipp Tipp

    Obwohl die Verwaltungstools für Team Foundation Server technisch nicht erforderlich sind, sind sie für das Erstellen der Sicherungs-Skripte erforderlich, die Sie zur Sicherung der Bereitstellung in dieser Version benötigen. Die Verwaltung der Bereitstellung ist mithilfe der Verwaltungstools viel einfacher.

  10. Behandeln Sie auf der Seite Installationsregeln alle Fehler oder Warnungen, und wählen Sie dann Weiter aus.

  11. Wählen Sie auf der Seite Instanzkonfiguration die Option Standardinstanz aus, und wählen Sie dann Weiter aus.

  12. Überprüfen Sie auf der Seite Erforderlicher Speicherplatz die Informationen, um sicherzustellen, dass Sie über genügend Festplattenspeicher verfügen, und wählen Sie anschließend Weiter aus.

  13. Wählen Sie auf der Seite Serverkonfiguration die Option Gleiches Konto für alle SQL Server-Dienste verwenden aus. Wählen Sie im Fenster Gleiches Konto für alle SQL Server 2008 R2-Dienste verwenden NT AUTHORITY\NETWORK SERVICE aus, oder geben Sie es an, und wählen Sie anschließend OK aus.

    Überprüfen Sie in der Spalte Starttyp, dass der Wert Automatisch für alle Dienste angezeigt wird, die Sie bearbeiten können, und klicken Sie dann auf Weiter.

    Konten festgelegt auf Netzwerkdienst/Automatisch

  14. Wählen Sie auf der Seite Database Engine Services auf der Registerkarte Kontobereitstellung die Option Windows-Authentifizierungsmodus aus, und wählen Sie anschließend Aktuellen Benutzer hinzufügen aus, um dieser SQL Server-Instanz Ihr Konto als Administrator hinzuzufügen. Fügen Sie optional ein beliebiges Benutzerkonto für Benutzer hinzu, die als Datenbankadministratoren fungieren sollen, und wählen Sie anschließend Weiter aus.

  15. Wählen Sie auf der Seite Analysis Services-Konfiguration auf der Registerkarte Kontobereitstellung die Option Aktuellen Benutzer hinzufügen aus, um der Analysis Services-Datenbank Ihr Konto als Administrator hinzuzufügen. Fügen Sie optional ein beliebiges Benutzerkonto für Benutzer hinzu, die als Administratoren fungieren sollen, und wählen Sie anschließend Weiter aus.

  16. Wählen Sie auf der Seite Reporting Services-Konfiguration die Option Standardkonfiguration des systemeigenen Modus installieren aus, und wählen Sie anschließend Weiter aus.

  17. Wählen Sie auf der Seite Fehlerberichterstattung aus, ob Sie Informationen zu Fehlern an Microsoft senden möchten, und wählen Sie dann Weiter aus.

  18. Überprüfen Sie auf der Seite Installationsregeln alle Fehler oder Warnungen, und wählen Sie dann Weiter aus.

  19. Überprüfen Sie auf der Seite Bereit für die Installation die Liste der zu installierenden Komponenten und ob sie mit der unten abgebildeten Liste der Funktionen übereinstimmen, wählen Sie anschließend Installieren aus. Wenn Sie Änderungen vornehmen müssen, wählen Sie Zurück aus.

    SQL Server 2008 R2 installieren - Fertig

    Überwachen Sie auf der Seite Installationsstatus optional den Installationsstatus jeder Komponente. Wenn alle Komponenten installiert sind, wird die Seite Abgeschlossen angezeigt.

  20. Wählen Sie auf der Seite Abgeschlossen die Option Schließen aus.

  21. Wenn Sie die Installation beenden, navigieren Sie zur Microsoft Update-Site, um alle erforderlichen Service Packs oder Updates anzuwenden, die für das Produkt freigegeben wurden. Sie müssen SP1 installieren, um die grundlegenden Anforderungen für Team Foundation Server zu erfüllen.

Installieren von Team Foundation Server auf dem Server

Sobald Sie fertig sind, die erforderlichen Komponenten zu installieren, sind Sie bereit, Team Foundation Server selbst zu installieren. In der Beispielsbereitstellung hat Jill Team Foundation Server mithilfe des standardmäßigen Assistenten installiert.

So installieren Sie Team Foundation Server mit dem standardmäßigen Assistenten

  1. Starten Sie die Installationsmedien. Wählen Sie im Team Foundation Server-Konfigurationscenter die Option Standardeinzelserver und anschließend Assistent starten aus.

    Der Assistent Team Foundation Server-Standardkonfiguration wird angezeigt.

    Installieren Sie den Standardeinzelserver (TFS)

  2. Wählen Sie auf der Seite Willkommen die Option Weiter aus.

  3. Geben Sie auf der Seite Dienstkonto unter Benutzerkonto den Namen des Dienstkontos an, den Sie für SharePoint Foundation 2010 und als Datenquellenberichts-Leserkonto in SQL Server Reporting Services verwenden möchten.

    Geben Sie unter Kennwort das Kennwort für dieses Dienstkonto an.

    Wählen Sie optional Test aus, um zu testen, ob das Dienstkonto ein gültiges Konto ist. Dieser Schritt ist nicht erforderlich, wird aber empfohlen. Wenn Sie alle Informationen für das Konto bereitgestellt haben, wählen Sie Weiter aus.

    Konto und Kennwort angeben

  4. Überprüfen Sie auf der Seite Installation die Informationen und sämtliche Warnungen, und wählen Sie anschließend SharePoint Foundation 2010 installieren aus.

  5. Nachdem Team Foundation Server die Installation von SharePoint Foundation 2010 abgeschlossen hat, wird eine Erfolgsmeldung angezeigt. Wählen Sie Weiter aus.

  6. Überprüfen Sie auf der Seite Überprüfen die Installationsinformationen von Team Foundation Server. Wenn Änderungen erforderlich sind, klicken Sie auf Zurück, und nehmen Sie die Änderungen vor. Wählen Sie Weiter aus, wenn alle Informationen richtig sind.

    Überprüfen Sie die Informationen vor der Installation

  7. Der Assistent überprüft auf der Seite Bereitschaftsprüfungen, ob alle Komponenten bereit für die Installation sind. Wenn eine der Bereitschaftsprüfungen fehlschlägt oder Warnungen ausgegeben werden, prüfen Sie die Informationen, und nehmen Sie ggf. Anpassungen vor.

    Tipp Tipp

    Während bei einer fehlgeschlagenen Bereitschaftsprüfung die Installation der Software nicht möglich ist, bis das Problem behoben ist, weist eine Warnung Sie nicht darauf hin, dass die Installation nicht durchgeführt werden kann.

    Wenn Sie mit den Bereitschaftsprüfungen einverstanden sind, wählen Sie Konfigurieren aus.

  8. Überwachen Sie auf der Seite Konfigurationsstatus optional den Fortschritt der Installation. Wenn die Installation abgeschlossen ist, wählen Sie Weiter aus.

  9. Wählen Sie Schließen aus, um den Assistenten für die Standardkonfiguration zu schließen.

  10. Wählen Sie Schließen aus, um das Konfigurationscenter zu schließen.

    Die Team Foundation Server-Verwaltungskonsole wird geöffnet. Überprüfen Sie die Informationen für den neu konfigurierten Server.

Obwohl Team Explorer für die meisten Verwaltungsaufgaben nicht erforderlich ist, verfügt die Anwendung über einige administrative Funktionen, und darüber hinaus ist dies die einzige Möglichkeit, die Teamprojekte zu erstellen, die die Softwareentwicklungsteams benötigen. Das Installieren auf dem Server stellt eine einfache Möglichkeit dar, um sicherzustellen, dass Sie bei Bedarf Projekte erstellen können, ohne zu einem anderen Computer gehen zu müssen.

So installieren Sie Team Explorer

  1. Durchsuchen Sie die Installationsmedien für Team Foundation Server, und öffnen Sie den Team Explorer-Ordner.

  2. Suchen Sie nach der Anwendung vs_TeamExplorer, und führen Sie diese aus.

    Das Installationsfenster Visual Studio Team Explorer wird geöffnet.

  3. Wählen Sie Ich stimme den Bedingungen des Lizenzvertrags zu aus, und wählen dann Installieren aus.

Sie können nun die ersten Teamprojekte erstellen.

POS1 | Vorbereiten für die Installation | Installieren von erforderlichen Komponenten und Team Foundation Server | Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams | Erstellen eines Backupplans


Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams
Feedback senden

Im dritten Teil des Lernprogramms zur Einzelserverinstallation lernen Sie, wie Teamprojekte mit einer der Prozessvorlagen erstellt werden, die in Team Foundation Server enthalten sind. Sie lernen außerdem, wie entsprechenden Gruppen in Team Foundation Server, SharePoint Foundation 2010 und SQL Server Reporting Services Active Directory-Benutzer und -Gruppen hinzugefügt werden und wie Sie ggf. Berechtigungen für diese Sicherheitsgruppen ändern.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber", und sie installiert Team Foundation Server in einer Einzelserverkonfiguration, um die Softwareentwicklungsteams zu unterstützen.

Das Installieren der Software ist nur ein Teil, den der Administrator zu bewältigen hat. Ein weiterer gleichermaßen wichtiger Teil bei der Verwaltung einer Bereitstellung besteht darin sicherzustellen, dass die Benutzer in der Bereitstellung einen entsprechenden Zugriff auf die Ressourcen in der betreffenden Bereitstellung haben. Sie können die Gruppen verwenden, die Sie zuvor in diesem Lernprogramm erstellt haben, um den Mehraufwand zu verringern, der zum Verwalten der Benutzer erforderlich ist. Auf diese Weise stellen Sie darüber hinaus sicher, dass die Benutzer über die entsprechende Zugriffsebene für die Funktionen und Projekte in Team Foundation Server verfügen.

In diesem Thema

  • Erstellen und Konfigurieren von Teamprojekten

  • Einschränken des Zugriffs auf die Projekte in der Bereitstellung

  • Konfigurieren des Zugriffs auf Funktionen in Team Web Access

Erforderliche Berechtigungen

Zum Ausführen der Verfahren in diesem Lernprogramm müssen Sie Mitglied der folgenden Gruppen sein:

  • Der Sicherheitsgruppe Administratoren auf dem Server, auf dem Sie Team Foundation Server installieren möchten

  • der Gruppe der Team Foundation-Administratoren in Team Foundation Server

  • Die Sicherheitsgruppe SQL Server-Systemadministrator in SQL Server

  • Die Gruppe Farmadministratoren in SharePoint Foundation 2010

  • Wenn Sie die Active Directory-Gruppenmitgliedschaft verwenden und konfigurieren, müssen Sie Mitglied der Gruppe Konten-Operatoren, Domänen-Admins oder Organisations-Admins sein oder über die entsprechenden Berechtigungen in den Active Directory-Domänendiensten verfügen.

Erstellen und Konfigurieren von Teamprojekten

Ein Teamprojekt ist die grundlegende Einheit beim Team Foundation Server. Jedes Teamprojekt, das in einer Teamprojektauflistung gehostet wird, ist eine separate Einheit mit eigenen Gruppen, Berechtigungen und Arbeitsaufgaben. Sie können das Projekt verwenden, um den Quellcode, Fehler, Vorschläge zu neuen Funktionen und andere Arbeitsaufgaben zu speichern und die Arbeit für Teams sowie Zeitpläne und Funktionsbereiche zu koordinieren. Die Arten der Arbeitsaufgaben, die für die einzelnen Projekte verfügbar sind, hängen jedoch von der Prozessvorlage ab, die Sie beim Erstellen eines Teamprojekts auswählen. Für diese Version enthält Team Foundation Server drei Prozessvorlagen: MSF for Agile Software Development, MSF for CMMI Process Improvement und Microsoft Visual Studio Scrum.

In dieser Beispielsbereitstellung hat Jill die Prozessvorlagenanforderungen mit den Projektmanagern diskutiert und erfahren, dass alle drei Projektmanager den Scrum-Prozess in ihren Projekten verwenden möchten. Sie erstellt das Projekt mithilfe der Prozessvorlage und erstellt zusätzlich ein Repository der Quellcodeverwaltung für alle drei Projekte. Da sie SharePoint Foundation 2010 und SQL Server Reporting Services als Teil der Bereitstellung installiert und konfiguriert hat, ist sie sich bewusst, dass die Projekte über Teamprojektportale verfügen, die für diese in SharePoint Foundation 2010 erstellt wurden, und dass für die Projekte automatisch Berichte verfügbar sind. Ihr ist jedoch auch bekannt, dass sie in allen drei Softwareprogrammen Benutzerberechtigungen konfigurieren muss.

So erstellen Sie ein Teamprojekt

  1. Öffnen Sie Team Explorer, und stellen Sie eine Verbindung mit der Standardauflistung her.

    Tipp Tipp

    Wenn Sie Team Explorer unter Windows Server 2008 oder Windows 7 ausführen, müssen Sie Team Explorer starten, indem Sie die Option Als Administrator ausführen auswählen.

    In der Beispielsbereitstellung wählt Jill im Menü Team die Option Team aus, und wählt anschließend Mit Team Foundation Server verbinden aus. Da Jill niemals vorher mit einem Server verbunden war, ist die Liste der Server leer. Sie wählt Server aus, und sie wählt im Dialogfeld Team Foundation Server hinzufügen/entfernen die Option Hinzufügen aus. Unter Team Foundation Server hinzufügen gibt sie den Namen des Servers ein, der FabrikamPrime lautet. Sie wendet für die übrigen Verbindungsdetails die Standardeinstellungen an, da dies von ihrer Bereitstellung verwendet wird, anschließend klickt sie auf OK. Sie stellt sicher, dass der Servername in Team Foundation Server hinzufügen/entfernen angezeigt wird, und klickt auf Schließen, um das Dialogfeld zu schließen. Sie stellt sicher, dass "FabrikamPrime" im Dropdownfeld Team Foundation Server-Computer auswählen unter Server und "DefaultCollection" unter Teamprojektauflistungen angezeigt wird, und wählt dann Verbinden aus. Beim nächsten Aufruf von Team Explorer wird automatisch eine Verbindung mit diesem Server und der Auflistung hergestellt.

  2. Wählen Sie in der Team Explorer-Randleiste die Option Startseite aus, wählen Sie Projekte und Meine Teams aus, und wählen Sie dann Neues Teamprojekt aus.

    Der Assistent zum Erstellen von Teamprojekten wird geöffnet.

  3. Geben Sie auf der Seite Teamprojekteinstellungen angeben im Textfeld Wie lautet der Name des Teamprojekts? einen Namen für das Projekt an, mit dem es von den am Projekt beteiligten Benutzern einfach identifiziert werden kann. Optional können Sie eine Beschreibung des Projekts bereitstellen und anschließend Weiter auswählen.

    Tipp Tipp

    Es gibt einige Einschränkungen für Projektnamen, wie beispielsweise Zeichenbegrenzungen und eingeschränkte Zeichen. Weitere Informationen finden Sie unter Restrictions for Project Names.

  4. Wählen Sie auf der Seite Prozessvorlage auswählen eine Prozessvorlage aus der Dropdownliste aus, und wählen Sie anschließend Weiter aus.

    In dieser Beispielsbereitstellung wählt Jill Microsoft Visual Studio Scrum aus.

  5. Stellen Sie auf der Seite Teamsiteeinstellungen sicher, dass Neue SharePoint-Website erstellen angegeben ist, und wählen Sie anschließend Weiter aus.

    Tipp Tipp

    Wenn Sie nicht dafür entschieden haben, SharePoint-Produkte als Bestandteil der Bereitstellung zu installieren, steht Ihnen diese Option nicht zur Verfügung.

  6. Stellen Sie auf der Seite Einstellungen für Quellcodeverwaltung festlegen sicher, dass Leeren Quellcodeverwaltungsordner erstellen angegeben ist, und wählen Sie anschließend Weiter aus.

  7. Überprüfen Sie auf der Seite Teamprojekteinstellungen bestätigen Ihre Auswahl, und wählen Sie dann Fertig stellen aus.

    Für das Erstellen des Projekts benötigt der Assistent möglicherweise einige Minuten.

Jill wiederholt diesen Prozess dreimal und erstellt die folgenden Projekte:

  • Phone Saver

  • Fuel Tracker 2

  • Interne Tools von Fabrikam Fiber

Nachdem diese Projekte erstellt wurden, fügt sie die erstellten Gruppen zum Team Foundation Server, zu den SQL Server Reporting Services und zur SharePoint Foundation 2010 hinzu. In den unten angegebenen Prozeduren fügt Jill die Gruppe "TFS_ProjectContributors" - die zum Anzeigenamen "Fabrikam-Entwickler und -Tester" aufgelöst werden - auf der entsprechenden Berechtigungsebene für Benutzer hinzu, die vollständig am Projekt mitwirken. Weitere Informationen zu den verschiedenen Mitwirkungsebenen finden Sie unter Hinzufügen von Benutzern zu Teamprojekten.

So fügen Sie der Gruppe "Contributors" in einem Teamprojekt eine Gruppe hinzu

  1. Öffnen Sie in Team Explorer das Teamprojekt, dem Sie Benutzer hinzufügen möchten, und wählen Sie dann Einstellungen aus.

    Das Menü Einstellungen wird angezeigt.

  2. Wählen Sie im Einstellungsmenü unter Teamprojekt die Option Gruppenmitgliedschaft aus.

    Team Web Access wird im Verwaltungskontext für das Teamprojekt auf der Registerkarte Sicherheit geöffnet.

  3. Wählen Sie auf der Registerkarte Gruppen die Option Contributors aus, und wählen Sie auf der Registerkarte Mitglieder die Option Hinzufügen aus, und wählen Sie anschließend Benutzer hinzufügen aus.

    Das Fenster WINDOWS-BENUTZER ODER -GRUPPE HINZUFÜGEN wird geöffnet.

  4. Geben Sie unter Identitäten den Namen der Gruppe an, die Sie hinzufügen möchten. In der Beispielsbereitstellung hat Jill eine Gruppe mit dem Namen "Fabrikam-Entwickler und -Tester" für die Entwickler und Tester erstellt, die an allen Teamprojekten in der Auflistung arbeiten. Sie gibt diesen Namen in das Feld ein und drückt die EINGABETASTE.

    Gruppe den Projekt-Contributors hinzufügen
    Tipp Tipp

    Wenn Sie zum ersten Mal einen Benutzer oder eine Gruppe zu Team Foundation Server hinzufügen, können Sie diesen nicht aufrufen oder den Namen überprüfen. Nachdem die Identität an einem beliebigen Speicherort im Team Foundation Server hinzugefügt wurde, können Sie die Funktionen verwenden, um den entsprechenden Namen umgehend zu finden.

  5. Wenn Sie die gewünschten Gruppen oder Benutzer hinzugefügt haben, wählen Sie Änderungen speichern aus.

So fügen Sie der Teamprojekt-Website in SharePoint Foundation 2010 eine Gruppe als Contributors hinzu

  1. Wählen Sie in Team Explorer im Menü Team die Option Projektportal anzeigen aus.

    Das Portal für das Teamprojekt wird in einem separaten Fenster geöffnet.

  2. Wählen Sie Websiteaktionen und anschließend Websiteberechtigungen aus.

    Die Browserfenster wird in Berechtigungs-Tools geändert.

  3. Wählen Sie Berechtigungen erteilen aus.

    Das Fenster "Berechtigungen erteilen" wird geöffnet.

  4. Geben Sie unter Benutzer/Gruppen den Namen der Gruppe an, die Sie hinzufügen möchten. Wählen Sie unter Berechtigungen erteilen die Option Benutzern eine Berechtigung direkt erteilen aus, aktivieren Sie das Kontrollkästchen Mitwirken, und wählen Sie dann OK aus.

    Gruppe zu SharePoint-Produkten hinzufügen

Im Gegensatz zu Team Foundation Server und SharePoint Foundation 2010 unterscheidet SQL Server Reporting Services nicht zwischen Projekten. Wenn Sie den Reporting Services eine Gruppe hinzufügen, enthält diese Gruppe die gleichen Berechtigungen hinsichtlich der Berichte für alle Projekte in der Auflistung, unabhängig von deren Berechtigungen in einzelne Projekten. Beachten Sie dies, wenn Sie sich dazu entscheiden, welche Gruppen hinzugefügt werden.

So fügen Sie den SQL Server Reporting Services eine Gruppe hinzu

  1. Öffnen Sie Internet Explorer oder einen anderen Browser, der mit der Reporting Services-Verwaltung kompatibel ist.

  2. Geben Sie in die Adressleiste Folgendes ein. Dabei steht ReportServer für den Namen des Servers, auf dem SQL Server Reporting Services ausgeführt wird:

    http://ReportServer/Reports/Pages/Folder.aspx

    Jill gibt beispielsweise "http://FabrikamPrime/Reports/Pages/Folder.aspx" in die Adressleiste ein.

  3. Wählen Sie auf der Startseite die Option Ordnereinstellungen aus.

  4. Wählen Sie auf der Seite Sicherheit die Option Neue Rollenzuweisung aus.

  5. Geben Sie auf der Seite Neue Rollenzuweisung unter Gruppen- oder Benutzername den Namen der Gruppe an, die Sie hinzufügen möchten. Aktivieren Sie das Kontrollkästchen Browser, und wählen Sie anschließend OK aus.

    Gruppe den Reporting Services hinzufügen

Einschränken des Zugriffs auf die Projekte in der Bereitstellung

Manchmal möchten Sie, dass nicht alle Benutzer in Ihrer Bereitstellung alle Projekte in dieser Bereitstellung anzeigen können. Standardgemäß können Benutzer, die Berechtigungen für den Zugriff auf ein Projekt in einer Auflistung besitzen, auch andere Projekte in dieser Auflistung ansehen, selbst wenn sie über keine Berechtigungen verfügen, Arbeitsaufgaben zu ändern oder andere Aktionen in diesem Projekt auszuführen. Wenn Sie eine bestimmte Gruppe auf nur ein Projekt in der Auflistung beschränken möchten, müssen Sie zusätzliche Schritte ausführen.

In Team Foundation Server explizit auf Verweigern festgelegte Berechtigungen haben generell Vorrang gegenüber Berechtigungen, die auf Zulassen festgelegt sind, und zwar entweder über eine geerbte Zulassung oder durch das explizite Festlegen der Berechtigung auf "Zulassen". Es gibt Ausnahmen, aber im Allgemeinen gelten diese nicht für Benutzergruppen (weitere Informationen zu diesen Ausnahmen finden Sie in Team Foundation Server-Berechtigungen). Wenn Sie eine bestimmte Gruppe für das Anzeigen eines bestimmten Projekts einschränken möchten, müssen Sie demnach zuerst eine bestimmte Team Foundation Server-Gruppe in diesem Projekt erstellen. Fügen Sie anschließend der Gruppe auf Projektebene die eingeschränkte Gruppe hinzu, und legen Sie dann Projektebeneninformationen anzeigen explizit für diese Team Foundation Server-Gruppe auf Verweigern fest. Das heißt, Sie erstellen eine Gruppe für die Benutzer, die ein bestimmtes Projekt nicht anzeigen dürfen, fügen diese Gruppe dem entsprechenden Projekt hinzu, und legen dann die Berechtigungen für diese Gruppe fest, sodass die Anzeige dieses Projekts eingeschränkt ist. Das ist zwar nicht sonderlich eingängig, aber es funktioniert!

So schränken Sie die Berechtigungen einer Gruppe zum Anzeigen eines Projekts ein

  1. Öffnen Sie Team Web Access, ändern Sie die Ansichten zum Verwaltungskontext für das Projekt, und wählen Sie die Registerkarte Sicherheit aus.

  2. Wählen Sie auf der Registerkarte Gruppen die Option TFS-Gruppe erstellen aus.

    Das Fenster Neue Team Foundation Server-Gruppe erstellen wird geöffnet.

  3. Geben Sie unter Gruppenname einen Namen für diese Gruppe an. In der Beispielsbereitstellung benennt Jill diese Gruppe "Eingeschränkt". Geben Sie optional eine Beschreibung für diese Gruppe ein, und wählen Sie dann OK aus.

    Die Gruppe, die Sie gerade erstellt haben, wird in der Liste der TFS-Gruppen angezeigt. Stellen Sie sicher, dass dies in der Liste ausgewählt ist, und wählen Sie dann die Registerkarte Mitglieder aus.

  4. Wählen Sie Benutzer hinzufügen aus.

    Das Fenster WINDOWS-BENUTZER ODER -GRUPPE HINZUFÜGEN wird geöffnet.

  5. Geben Sie unter Identitäten den Namen der Gruppe an, die Sie hinzufügen möchten. In der Beispielsbereitstellung hat Jill eine Gruppe für die Vertragsmitarbeiter erstellt, die nur ein Projekt in der Auflistung bearbeiten. Sie gibt diesen Namen in das Feld ein und drückt die EINGABETASTE.

  6. Wenn Sie die gewünschten Gruppen oder Benutzer hinzugefügt haben, wählen Sie Änderungen speichern aus.

  7. Wählen Sie die Registerkarte Berechtigungen aus. Schalten Sie in der Liste der Berechtigungen den Wert von Berechtigungen auf Projektebene anzeigen auf Verweigern um, und wählen Sie dann Änderungen speichern aus.

Konfigurieren des Zugriffs auf Funktionen in Team Web Access

Nicht alle Funktionen von Team Web Access sind für Benutzer standardmäßig verfügbar. Der Zugriff auf Team Web Access-Funktionen wird durch den Verwaltungsmodus von Team Web Access gesteuert. Die Standard-Zugriffsebene ist für die gesamte Bereitstellung festgelegt, nicht für einzelne Teamprojektauflistungen oder -gruppen. Um Zugriffsebenen für bestimmte Benutzer von Auflistungen, Teamprojekten oder Teams zu konfigurieren, müssen Sie die Benutzer oder Gruppen manuell zu einer der drei Zugriffsgruppen in Team Web Access hinzufügen. Wenn die Benutzer Zugriff auf alle verfügbaren Funktionen haben sollen oder der Zugriff mancher Benutzer auf die standardmäßig verfügbaren Funktionen beschränkt werden soll, müssen Sie diesen Zugriff konfigurieren. Sie sollten auch überprüfen, ob Sie über die entsprechende Lizenzierung verfügen, um diese Funktionen zu verwenden. Weitere Informationen finden Sie im Team Foundation Server-Lizenzierungs-Whitepaper.

Zugriffsgruppen für Team Web Access

So zeigen Sie die Standard-Funktionszugriffsgruppe von Team Foundation Server an oder ändern diese

  1. Öffnen Sie Team Web Access im Verwaltungsmodus, und wählen Sie Systemsteuerung aus, um zum Verwaltungskontext auf oberster Ebene zu navigieren.

  2. Wählen Sie die Registerkarte Web Access aus.

  3. Wählen Sie in Web Access-Berechtigungen den Namen der Zugriffsgruppe, für die Informationen angezeigt werden sollen. Prüfen Sie Folgendes:

    • Die Liste der Funktionen, die für diese Gruppe verfügbar sind.

    • Ob die Gruppe als Standard für die Bereitstellung festgelegt ist. In diesem Fall folgt auf diesen Gruppennamen (Standard). Dies ist die Gruppe, der alle Benutzer der Bereitstellung von Team Foundation Server standardmäßig zugewiesen werden.

    • Ob alle Benutzer oder Gruppen explizit dieser Gruppe zugewiesen sind. Wenn Sie keine Benutzer oder Gruppen explizit für diese Gruppe konfigurieren, sehen Sie keine Liste von Identitäten, die dieser Gruppe zugewiesen sind.

  4. Wählen Sie, um eine andere Gruppe als Standard auszuwählen, diese Gruppe im Explorer-Fenster und in Web Access-Berechtigungen für diese Gruppe die Option Als Standardwebzugriff festlegen aus.

    Wurde die Gruppe bereits als Standard festgelegt, ist diese Option nicht verfügbar.

Weitere Informationen darüber, welche Funktionen für jede Zugriffsgruppe verfügbar sind, wie Benutzer in den Zugriffsgruppen verwaltet und der Zugriff überwacht wird, finden Sie unter Zugriff auf Funktionen über Webberechtigungen.

POS1 | Vorbereiten für die Installation | Installieren von erforderlichen Komponenten und Team Foundation Server | Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams | Erstellen eines Backupplans


Erstellen eines Backupplans

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Erstellen eines Backupplans
Feedback senden

In diesem vierten Thema des Lernprogramms zur Einzelserverinstallation lernen Sie, wie Sicherungen für eine Einzelserverbereitstellung von Team Foundation Server (TFS) konfiguriert werden, bei der auch SharePoint Foundation 2010 und SQL Server Reporting Services verwendet werden. Alle diese Produkte werden auf demselben Server installiert.

Hinweis Hinweis

Bei einigen Versionen von Team Foundation Server können Powertools den Prozess vereinfachen, wie in diesem Thema beschrieben. Die aktuelle Version des Powertools finden Sie hier. Wenn Sie das Tool verwenden möchten, können Sie dieses Thema überspringen. Sollte dieses Power Tool noch nicht verfügbar sein oder die nicht konfigurierbaren Optionen des Tools für die Bereitstellung nicht geeignet sein, können Sie Sicherungen manuell konfigurieren. Auch wenn Sie bislang noch keine Sicherungen konfiguriert haben, werden Sie hier schrittweise an jeden Teil des Prozesses herangeführt, und sollte Ihnen Transact-SQL zunächst nicht vertraut sein, wird sich dies im Anschluss an diese Heranführung geändert haben. Das heißt, machen Sie sich keine Sorgen. Auch wenn es viele auszuführende Schritte gibt, sind diese nicht besonders schwierig, und dieses Thema führt Sie durch alle diese Schritte.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber", und sie installiert Team Foundation Server in einer Einzelserverkonfiguration, um die Softwareentwicklungsteams zu unterstützen.

Wenn Sie Systeme verwalten, sind Sie Ihnen wahrscheinlich bereits alle Gründe bekannt, aus denen ein guter Sicherungssatz von entscheidender Bedeutung ist. Niemand möchte Administrator eines Servers sein, dessen Daten verloren gehen, ohne dass ein vollständiger Satz an Sicherungen vorliegt. Sie können Daten jedoch für TFS sichern, indem Sie SQL Server-Tools und markierte Transaktionen verwenden, um eine Reihe allgemeiner Wiederherstellungspunkte in den Datenbanken zu erstellen. Wenn Sie diese Datenbanken regelmäßig sichern, reduzieren Sie das Risiko, wegen Geräteausfalls oder anderer unerwarteter Ereignisse Produktivität oder Daten zu verlieren.

In der Beispielbereitstellung "Fabrikam Fiber" von Team Foundation Server in diesem Lernprogramm wird SharePoint-Produkte verwendet. SharePoint-Produkte verwendet verschiedene Tools und Strategien zum Sichern der Datenbanken. Jill muss zusätzliche Schritte entsprechend den in diesem Thema beschriebenen Prozeduren ausführen, um die SharePoint-Datenbanken zu sichern und wiederherzustellen.

Die Prozeduren in diesem Thema erklären, wie Wartungspläne, die entweder eine vollständige oder eine inkrementelle Sicherung der Datenbanken ausführen, erstellt werden, und wie Tabellen und gespeicherte Prozeduren für markierte Transaktionen erstellt werden. Um einen maximalen Schutz der Daten zu gewährleisten, sollten Sie vollständige Sicherungen, die täglich oder wöchentlich ausgeführt werden, und inkrementelle Sicherungen, die stündlich ausgeführt werden, planen. Sie können auch die Transaktionsprotokolle sichern. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Erstellen von Transaktionsprotokollsicherungen.

Wichtiger Hinweis Wichtig

Um das Beschädigen der Daten zu vermeiden, müssen Sie alle Sicherungen von Datenbanken synchronisieren, die die Bereitstellung von TFS zum gleichen Zeitstempel verwendet. In dieser Beispielsbereitstellung befinden sich alle Datenbanken auf demselben Server. Um die Bereitstellung vollständig zu sichern, müssen Sie alle Datenbanken sichern und synchronisieren, die Team Foundation Server in SQL Server verwendet. Außerdem müssen Sie SharePoint-Produkte sichern. Da SharePoint-Produkte über verschiedene Anforderungen zum Sichern und Wiederherstellen der Datenbanken von TFS verfügt, können Sie nicht die gleiche Sicherungsstrategie verwenden, die Sie für die anderen Datenbanken bei der Bereitstellung von TFS nutzen. Sie müssen den SharePoint-Produkte-Leitfaden zur Sicherung von SharePoint-Produkte-Datenbanken befolgen. Dieses Dokument enthält zwar eine Kurzfassung dieses Leitfadens für die Bereitstellung auf einem Einzelserver, bei der Konfiguration von Sicherungen für SharePoint Foundation 2010 sollten Sie jedoch zuerst den bereitgestellten Links folgen und die neuesten verfügbaren Informationen auf TechNet zurate ziehen.

Wenn Sie außerdem die Enterprise oder Datacenter Edition von SQL Server verwenden, und die Auflistungs- und Konfigurationsdatenbanken in einer Standard Edition von SQL Server wiederherstellen möchten, müssen sie vor der Sicherung die SQL Server-Komprimierung deaktivieren, indem Sie die Schritte in Microsoft Knowledge Base-Artikel ausführen.

In diesem Thema:

  • Erforderliche Berechtigungen

  • Identifizieren von Datenbanken

  • Erstellen von Tabellen in Datenbanken

  • Erstellen einer gespeicherten Prozedur zum Markieren von Tabellen

  • Erstellen einer gespeicherten Prozedur zum gleichzeitigen Markieren aller Tabellen

  • Erstellen einer gespeicherten Prozedur zum Automatischen Markieren von Tabellen

  • Erstellen eines geplanten Auftrags zum Ausführen der Tabellenmarkierungsprozedur

  • Erstellen eines Wartungsplans für vollständige Sicherungen

  • Erstellen eines Wartungsplans für differenzielle Sicherungen

  • Erstellen eines Wartungsplans für Transaktionssicherungen

  • Sichern des Reporting Services-Verschlüsselungsschlüssels

  • Erstellen eines Sicherungsplans für SharePoint Foundation 2010

Erforderliche Berechtigungen

Zum Ausführen der Verfahren in diesem Lernprogramm müssen Sie Mitglied der folgenden beiden Gruppen sein:

  • Die Sicherheitsgruppe Administratoren auf dem Server, der die Verwaltungskonsole für Team Foundation ausführt.

  • Die Sicherheitsgruppe SQL Server-Systemadministrator Alternativ müssen Ihre SQL Server-Berechtigungen zum Erstellen von Sicherungskopien und Wartungsplänen auf jeder Instanz von SQL Server, die die zu sichernden Datenbanken hostet, auf Zulassen festgelegt werden.

  • Die Gruppe Farmadministratoren in SharePoint Foundation 2010 oder ein Konto mit den Berechtigungen, die zum Erstellen einer Sicherungskopie der Farm erforderlich sind

Erstellen von Tabellen in Datenbanken

Um sicherzustellen dass alle Datenbanken auf denselben Punkt wiederhergestellt werden, können Sie eine Tabelle in jeder Datenbank erstellen, um Transaktionen zu markieren. Sie können die Query-Funktion in SQL Server Management Studio verwenden, um eine entsprechende Tabelle in jeder Datenbank zu erstellen.

Wichtiger Hinweis Wichtig

Erstellen Sie keine Tabellen in Datenbanken, die SharePoint-Produkte verwendet.

So erstellen Sie Tabellen, um verwandte Transaktionen in Datenbanken zu markieren, die Team Foundation verwendet

  1. Öffnen Sie SQL Server Management Studio, und stellen Sie eine Verbindung zum Datenbankmodul her.

  2. Markieren Sie in SQL Server Management Studio den Servernamen, öffnen Sie das Untermenü, und wählen Sie anschließend Neue Abfrage aus.

    Das Abfrage-Editor-Fenster des Datenbankmoduls wird geöffnet.

  3. Wählen Sie im Menü Abfrage die Option SQLCMD-Modus aus.

    Der Abfrage-Editor führt sqlcmd-Anweisungen im Kontext des Abfrage-Editors aus. Wenn das Abfragemenü nicht angezeigt wird, klicken Sie in der neuen Abfrage im Abfrage-Editor-Fenster des Datenbankmoduls auf eine beliebige Stelle.

  4. Öffnen Sie die Liste Verfügbare Datenbanken auf der Symbolleiste SQL-Editor, und wählen Sie dann TFS_Configuration aus.

    Hinweis Hinweis

    TFS_Configuration ist der Standardname der Konfigurationsdatenbank. Dieser Name ist vom Benutzer anpassbar und kann variieren.

  5. Geben Sie im Abfragefenster das folgende Skript ein, um eine Tabelle in der Konfigurationsdatenbank zu erstellen:

    Bild für Kopieren Code kopieren
    Use Tfs_Configuration
Create Table Tbl_TransactionLogMark
(
logmark int
)
GO
Insert into Tbl_TransactionLogMark (logmark) Values (1)
GO

  6. Drücken Sie die Taste F5, um das Skript auszuführen.

    Wenn das Skript wohlgeformt ist, wird die Meldung "(1 Zeile(n) betroffen)" im Abfrage-Editor angezeigt.

  7. (Optional) Speichern Sie das Skript.

  8. Wiederholen Sie Schritte 4 bis 7 für jede Datenbank in der Bereitstellung von TFS, außer denen, die von SharePoint-Produkte verwendet werden. In dieser Beispielsbereitstellung wiederholt Jill diesen Prozess für alle folgenden Datenbanken:

    • Tfs_Warehouse

    • Tfs_DefaultCollection

    • ReportServer

    • ReportServerTempDB

Erstellen einer gespeicherten Prozedur zum Markieren von Tabellen

Nachdem die Tabellen in den einzelnen Datenbanken, die Sie sichern möchten, erstellt wurden, müssen Sie eine Prozedur zum Markieren der Tabellen erstellen.

So erstellen Sie eine gespeicherte Prozedur, um Transaktionen in den Datenbanken, die Team Foundation Server verwendet, zu markieren

  1. Öffnen Sie in SQL Server Management Studio ein Abfragefenster, und stellen Sie sicher, dass SQLCMD-Modus aktiviert ist.

  2. Öffnen Sie die Liste Verfügbare Datenbanken auf der Symbolleiste SQL-Editor, und wählen Sie dann TFS_Configuration aus.

  3. Geben Sie im Abfragefenster das folgende Skript ein, um eine gespeicherte Prozedur zu erstellen, um Transaktionen in der Konfigurationsdatenbank zu markieren:

    Bild für Kopieren Code kopieren
    Create PROCEDURE sp_SetTransactionLogMark
@name nvarchar (128)
AS
BEGIN TRANSACTION @name WITH MARK
UPDATE Tfs_Configuration.dbo.Tbl_TransactionLogMark SET logmark = 1
COMMIT TRANSACTION
GO

  4. Drücken Sie die Taste F5, um die Prozedur auszuführen.

    Wenn die Prozedur wohlgeformt ist, wird die Meldung "Die Befehle wurden erfolgreich ausgeführt" im Abfrage-Editor angezeigt.

  5. (Optional) Speichern Sie die Prozedur.

  6. Wiederholen Sie die Schritte 2 bis 5 für jede Datenbank in der Bereitstellung von TFS. In dieser Beispielbereitstellung wiederholt Jill diesen Prozess für alle folgenden Datenbanken:

    • Tfs_Warehouse

    • Tfs_DefaultCollection

    • ReportServer

    • ReportServerTempDB

    Tipp Tipp

    Stellen Sie sicher, dass Sie den Datenbanknamen, wofür Sie die gespeicherte Prozedur erstellen möchten, von der Liste Verfügbare Datenbanken im Objekt-Explorer auswählen, bevor Sie die Prozedur erstellen. Wenn Sie das Skript andernfalls ausführen, wird vom Befehl ein Fehler angezeigt, dass die gespeicherte Prozedur bereits vorhanden ist.

Erstellen einer gespeicherten Prozedur zum gleichzeitigen Markieren aller Tabellen

Um sicherzustellen, dass alle Datenbanken markiert werden, können Sie eine Prozedur erstellen, die alle Prozeduren ausführt, die Sie zum Markieren der Tabellen erstellt haben. Im Gegensatz zu den vorherigen Prozeduren wird diese Prozedur nur in der Konfigurationsdatenbank ausgeführt.

So erstellen Sie eine gespeicherte Prozedur, die alle gespeicherten Prozeduren zum Markieren von Tabellen ausführt

  1. Öffnen Sie in SQL Server Management Studio ein Abfragefenster, und stellen Sie sicher, dass SQLCMD-Modus aktiviert ist.

  2. Öffnen Sie die Liste Verfügbare Datenbanken auf der Symbolleiste SQL-Editor, und wählen Sie dann TFS_Configuration aus.

  3. Erstellen Sie im Abfragefenster eine gespeicherte Prozedur, die die gespeicherten Prozeduren ausführt, die Sie in jeder Datenbank erstellt haben, die TFS verwendet. Ersetzen Sie Servername durch den Namen des Servers, der SQL Server ausführt, und ersetzen Sie Tfs_Auflistungsname durch den Namen der Datenbank für die einzelnen Teamprojektsammlungen.

    In der Beispielsbereitstellung ist der Name des Servers FABRIKAMPRIME, und es gibt nur eine Teamprojektauflistung in der Bereitstellung: die standardmäßige, die von ihr erstellt wurde, als Team Foundation Server (DefaultCollection) installiert wurde. In diesem Sinne erstellt Jill das folgende Skript:

    Bild für Kopieren Code kopieren
    CREATE PROCEDURE sp_SetTransactionLogMarkAll
@name nvarchar (128)
AS
BEGIN TRANSACTION
EXEC [FABRIKAMPRIME].Tfs_Configuration.dbo.sp_SetTransactionLogMark @name
EXEC [FABRIKAMPRIME].ReportServer.dbo.sp_SetTransactionLogMark @name
EXEC [FABRIKAMPRIME].ReportServerTempDB.dbo.sp_SetTransactionLogMark @name
EXEC [FABRIKAMPRIME].Tfs_DefaultCollection.dbo.sp_SetTransactionLogMark @name
EXEC [FABRIKAMPRIME].Tfs_Warehouse.dbo.sp_SetTransactionLogMark @name
COMMIT TRANSACTION
GO

  4. Drücken Sie die Taste F5, um die Prozedur auszuführen.

    Hinweis Hinweis

    Wenn Sie SQL Server Management Studio nicht neu gestartet haben, seitdem Sie die gespeicherten Prozeduren zum Markieren von Transaktionen erstellt haben, werden die Namen des Servers und der Datenbanken möglicherweise von einer oder mehreren roten, welligen Linien unterstrichen. Die Prozedur sollte immer trotzdem ausgeführt werden.

    Wenn die Prozedur wohlgeformt ist, wird die Meldung "Die Befehle wurden erfolgreich ausgeführt" im Abfrage-Editor angezeigt.

  5. (Optional) Speichern Sie die Prozedur.

Erstellen einer gespeicherten Prozedur zum Automatischen Markieren von Tabellen

Wenn Sie über eine Prozedur verfügen, die alle gespeicherten Prozeduren für die Tabellenmarkierung ausführt, müssen Sie eine Prozedur erstellen, die alle Tabellen mit demselben Transaktionsmarker markiert. Sie stellen alle Datenbanken zum gleichen Punkt mithilfe dieses Markers wieder her.

So erstellen Sie eine gespeicherte Prozedur, um Tabellen in den Datenbanken, die Team Foundation Server verwendet, zu markieren

  1. Öffnen Sie in SQL Server Management Studio ein Abfragefenster, und stellen Sie sicher, dass SQLCMD-Modus aktiviert ist.

  2. Öffnen Sie die Liste Verfügbare Datenbanken auf der Symbolleiste SQL-Editor, und wählen Sie dann TFS_Configuration aus.

  3. Geben Sie im Abfragefenster das folgende Skript ein, um die Tabellen mit 'TFSMark' zu markieren:

    Bild für Kopieren Code kopieren
    EXEC sp_SetTransactionLogMarkAll 'TFSMark'
GO
    Hinweis Hinweis

    TFSMark ist ein Beispiel für eine Markierung. Sie können eine beliebige Abfolge unterstützter Buchstaben und Zahlen für die Markierung verwenden. Wenn Sie mehr als eine markierte Tabelle in den Datenbanken haben, halten Sie fest, welche Markierung Sie zum Wiederherstellen der Datenbanken verwenden. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Verwenden markierter Transaktionen.

  4. Drücken Sie die Taste F5, um die Prozedur auszuführen.

    Wenn die Prozedur wohlgeformt ist, wird die Meldung "(1 Zeile(n) betroffen)" im Abfrage-Editor angezeigt. Die WITH MARK-Option gilt nur für die erste BEGIN TRAN WITH MARK-Anweisung für jede Tabelle, die markiert wurde.

  5. Speichern Sie die Prozedur.

Erstellen eines geplanten Auftrags zum Ausführen der Tabellenmarkierungsprozedur

Das Sie jetzt alle Prozeduren erstellt und gespeichert haben, die Sie benötigen, müssen Sie die Tabellenmarkierungs-Prozedur so planen, dass sie kurz vor den geplanten Sicherungen der Datenbanken ausgeführt wird. Sie sollten diesen Auftrag so planen, dass er ungefähr eine Minute vor der Ausführung des Wartungsplans für die Datenbanken ausgeführt wird.

So erstellen Sie einen geplanten Auftrag für die Tabellenmarkierung in SQL Server Management Studio

  1. Erweitern Sie im Objekt-Explorer den Knoten SQL Server-Agent, öffnen Sie das Menü Aufträge, und wählen Sie dann Neuer Auftrag.

    Das Fenster Neuer Auftrag wird geöffnet.

  2. Geben Sie im Feld Name einen Namen für den Auftrag an. Jill gibt beispielsweise den Namen "MarkTableJob" als Auftragsname ein.

  3. (Optional) Geben Sie unter Beschreibung eine Beschreibung des Auftrags ein.

  4. Wählen Sie unter Seite auswählen die Option Schritte und anschließend Neu aus.

  5. Das Fenster Neuer Auftragsschritt wird geöffnet.

  6. Geben Sie unter Schrittname einen Namen für den Schritt an.

  7. Wählen Sie unter Datenbank den Namen der Konfigurationsdatenbank aus. Bei der Bereitstellung von Jill wird beispielsweise der Standardname für diese Datenbank (TFS_Configuration) verwendet. Daher wählt sie diese Datenbank aus der Dropdownliste aus.

  8. Wählen Sie Öffnen, wechseln Sie zur Prozedur, die Sie zum Markieren der Tabellen erstellt haben, wählen Sie zweimal Öffnen und dann OK.

    Hinweis Hinweis

    Die Prozedur, die Sie zum Markieren den Tabellen erstellt haben, führt den folgenden Schritt aus:

    Bild für Kopieren Code kopieren
    EXEC sp_SetTransactionLogMarkAll 'TFSMark'

  9. Wählen Sie unter Seite auswählen die Option Zeitpläne und anschließend Neu aus.

    Das Fenster Neuer Auftragszeitplan wird geöffnet.

  10. Geben Sie unter Name einen Namen für den Zeitplan an.

  11. Ändern Sie unter Frequenz die Häufigkeit, um dem Plan zu entsprechen, den Sie zum Sichern der Datenbanken erstellen werden. In der Beispielsbereitstellung möchte Jill inkrementelle Sicherungen täglich um 2 Uhr und vollständige Sicherungen am Sonntag um 4 Uhr ausführen. Sie ändert den Wert von Auftreten in Täglich, um die Datenbanken für die inkrementellen Sicherungen zu markieren. Wenn sie einen anderen Auftrag erstellt, um die Datenbanken für die wöchentliche vollständige Sicherung zu markieren, behält sie den Wert von Auftreten für Täglich bei und aktiviert das Kontrollkästchen Sonntag.

  12. Ändern Sie das Vorkommen unter Häufigkeit pro Tag, damit der Auftrag so geplant wird, dass er eine Minute vor dem Sichern der Datenbanken ausgeführt wird, und wählen Sie dann OK. In der Beispielsbereitstellung gibt Jill im Auftrag für die inkrementellen Sicherungen "1:59 Uhr" an. Im Auftrag für die vollständige Sicherung gibt Jill "3:59 Uhr" an.

  13. Wählen Sie unter Neuer Auftrag die Option OK, um das Erstellen des geplanten Auftrags abzuschließen.

Erstellen eines Wartungsplans für vollständige Sicherungen

Nachdem Sie zum Markieren der Datenbanken einen geplanten Auftrag erstellt haben, können Sie vollständige Sicherungen aller Datenbanken, die die Bereitstellung von TFS verwendet, mithilfe des Wartungsplanungs-Assistenten planen.

Wichtiger Hinweis Wichtig

Wenn die Bereitstellung eine SQL Server Enterprise oder Datacenter Edition verwendet, aber möglicherweise Datenbanken auf einem Server mit Standard Edition wiederhergestellt werden sollen, müssen Sie einen Sicherungssatz verwenden, der bei deaktivierter SQL Server-Komprimierung erstellt wurde. Wird die Datenkomprimierung nicht deaktiviert, können Enterprise oder Datacenter Edition-Datenbanken auf einem Server mit Standard Edition nicht wiederhergestellt werden. Die Komprimierung muss vor dem Erstellen der Wartungspläne deaktiviert werden. Führen Sie zum Deaktivieren der Komprimierung die in Microsoft Knowledge Base-Artikel genannten Schritte aus.

So erstellen Sie einen Wartungsplan für vollständige Sicherungen

  1. Erweitern Sie unter SQL Server Management Studio den Knoten Verwaltung, öffnen Sie das Untermenü Wartungspläne, und wählen Sie dann Wartungsplanungs-Assistent.

  2. Wählen Sie auf der Willkommensseite des Wartungsplanungs-Assistenten von SQL Server Weiter aus.

    Die Seite Planeigenschaften auswählen wird angezeigt.

  3. Geben Sie im Feld Name einen Namen für den Wartungsplan ein.

    Jill entscheidet beispielsweise, einen Plan mit dem Namen "TfsFullDataBackup" für vollständige Sicherungen zu erstellen.

  4. Wählen Sie Einzelner Zeitplan für den gesamten Plan oder kein Zeitplan und dann Ändern.

  5. Geben Sie unter Häufigkeit und Häufigkeit pro Tag Optionen für den Plan an. Jill gibt beispielsweise in Häufigkeit an, dass wöchentlich eine Sicherung am Sonntag stattfinden soll, und gibt in Häufigkeit pro Tag "4 Uhr" an.

    Übernehmen Sie unter Dauer den Standardwert Kein Enddatum. Klicken Sie auf OK und dann auf Weiter.

  6. Aktivieren Sie die Kontrollkästchen Datenbank sichern (vollständig), Auftrag des SQL Server-Agents ausführen und Datenbank sichern (Transaktionsprotokoll) auf der Seite Wartungstasks auswählen, und wählen Sie dann Weiter aus.

  7. Ändern Sie auf der Seite Wartungstaskreihenfolge auswählen die Reihenfolge, damit die vollständige Sicherung zuerst ausgeführt wird, dann der Agentauftrag und dann die Transaktionsprotokollsicherung, und wählen Sie dann Weiter aus.

    Um weitere Informationen zu diesem Dialogfeld zu erhalten, klicken Sie auf den Schlüssel F1. Suchen Sie auch nach Wartungsplanungs-Assistenten auf der folgenden Seite der Microsoft-Website: SQL Server-Onlinedokumentation.

  8. Wählen Sie auf der Seite Task 'Datenbank sichern (vollständig)' definieren den Pfeil nach unten, dann Alle Datenbanken und anschließend OK aus.

  9. Geben Sie die Sicherungsoptionen zum Speichern der Dateien (entsprechend der Bereitstellung und den Ressourcen) auf einem Datenträger oder Band an, und klicken Sie dann auf Weiter.

  10. Aktivieren Sie auf der Seite Task 'Auftrag des SQL Server-Agents ausführen' definieren das Kontrollkästchen für den geplanten Auftrag, den Sie für die Tabellenmarkierung erstellt haben, und wählen Sie dann Weiter aus.

  11. Wählen Sie auf der Seite Task 'Datenbank sichern (Transaktionsprotokoll)' definieren den Pfeil nach unten, dann Alle Datenbanken und anschließend OK aus.

  12. Geben Sie die Sicherungsoptionen zum Speichern der Dateien (entsprechend der Bereitstellung und den Ressourcen) auf einem Datenträger oder Band an, und klicken Sie dann auf Weiter.

  13. Geben Sie auf der Seite Berichtsoptionen auswählen Berichtsverteilungsoptionen an, und wählen Sie zweimal Weiter aus.

  14. Wählen Sie auf der Seite Assistenten abschließen die Option Fertig stellen aus.

    SQL Server erstellt den Wartungsplan und sichert die angegebenen Datenbanken in der festgelegten Häufigkeit.

Erstellen eines Wartungsplans für differenzielle Sicherungen

Sie können differenzielle Sicherungen mithilfe des Wartungsplanungs-Assistenten für alle Datenbanken planen, die die Bereitstellung von TFS verwendet.

Wichtiger Hinweis Wichtig

SQL Server Express schließt den Wartungsplanungs-Assistenten nicht ein. Sie müssen den Zeitplan für die differenziellen Sicherungen manuell erstellen. Weitere Informationen finden Sie in folgendem Thema auf der Microsoft-Website: Vorgehensweise: Erstellen einer differenziellen Datenbanksicherung (Transact-SQL).

So erstellen Sie einen Wartungsplan für differenzielle Sicherungen

  1. Melden Sie sich am Server an, der die Instanz von SQL Server ausführt, die die zu sichernden Datenbanken enthält.

  2. Wählen Sie Start und dann Alle Programme aus. Anschließend wählen Sie Microsoft SQL Server 2008 gefolgt von SQL Server Management Studio aus.

    1. Klicken Sie in der Liste Servertyp auf Datenbankmodul.

    2. Klicken Sie in den Listen Servername und Authentifizierung auf den entsprechenden Server und das Authentifizierungsschema.

    3. Falls es die von Ihnen verwendete Instanz von SQL Server erfordert, geben Sie unter Benutzername und Kennwort die Anmeldeinformationen eines entsprechenden Kontos an.

    4. Wählen Sie Verbinden aus.

  3. Erweitern Sie unter SQL Server Management Studio den Knoten Verwaltung, öffnen Sie das Untermenü Wartungspläne, und wählen Sie dann Wartungsplanungs-Assistent.

  4. Wählen Sie auf der Willkommensseite des Wartungsplanungs-Assistenten von SQL Server Weiter aus.

  5. Geben Sie auf der Seite Planeigenschaften auswählen im Feld Name einen Namen für den Wartungsplan an.

    Sie können einen Plan für differenzielle Sicherungen beispielsweise TfsDifferenzielleSicherung nennen.

  6. Wählen Sie Einzelner Zeitplan für den gesamten Plan oder kein Zeitplan und dann Ändern.

  7. Geben Sie unter Häufigkeit und Häufigkeit pro Tag Optionen für den Sicherungsplan an.

    Übernehmen Sie unter Dauer den Standardwert Kein Enddatum. Klicken Sie auf OK und dann auf Weiter.

  8. Aktivieren Sie das Kontrollkästchen Datenbank sichern (differenziell) auf der Seite Wartungstasks auswählen, und wählen Sie dann Weiter aus.

  9. Wählen Sie auf der Seite Task 'Datenbank sichern (differenziell)' definieren den Pfeil nach unten, dann Alle Datenbanken und anschließend OK aus.

  10. Geben Sie die Sicherungsoptionen zum Speichern der Dateien (entsprechend der Bereitstellung und den Ressourcen) auf einem Datenträger oder Band an, und klicken Sie dann auf Weiter.

  11. Geben Sie auf der Seite Berichtsoptionen auswählen Berichtsverteilungsoptionen an, und wählen Sie zweimal Weiter aus.

  12. Wählen Sie auf der Seite Assistenten abschließen die Option Fertig stellen aus.

    SQL Server erstellt den Wartungsplan und sichert die angegebenen Datenbanken in der festgelegten Häufigkeit.

Erstellen eines Wartungsplans für Transaktionsprotokolle

Sie können Transaktionsprotokollsicherungen mithilfe des Wartungsplanungs-Assistenten für alle Datenbanken planen, die die Bereitstellung von TFS verwendet.

Wichtiger Hinweis Wichtig

SQL Server Express schließt den Wartungsplanungs-Assistenten nicht ein. Sie müssen den Zeitplan für Transaktionsprotokollsicherungen manuell erstellen. Weitere Informationen finden Sie in folgendem Thema auf der Microsoft-Website: Vorgehensweise: Erstellen einer Transaktionsprotokollsicherung (Transact-SQL).

So erstellen Sie einen Wartungsplan für Transaktionsprotokollsicherungen

  1. Melden Sie sich am Server an, der die Instanz von SQL Server ausführt, die die zu sichernden Datenbanken enthält.

  2. Wählen Sie Start und dann Alle Programme aus. Anschließend wählen Sie Microsoft SQL Server 2008 gefolgt von SQL Server Management Studio aus.

  3. Klicken Sie in der Liste Servertyp auf Datenbankmodul.

    1. Klicken Sie in den Listen Servername und Authentifizierung auf den entsprechenden Server und das Authentifizierungsschema.

    2. Falls es die von Ihnen verwendete Instanz von SQL Server erfordert, geben Sie unter Benutzername und Kennwort die Anmeldeinformationen eines entsprechenden Kontos an.

    3. Wählen Sie Verbinden aus.

  4. Erweitern Sie unter SQL Server Management Studio den Knoten Verwaltung, öffnen Sie das Untermenü Wartungspläne, und wählen Sie dann Wartungsplanungs-Assistent.

  5. Wählen Sie auf der Willkommensseite des Wartungsplanungs-Assistenten von SQL Server Weiter aus.

    Die Seite Planeigenschaften auswählen wird angezeigt.

  6. Geben Sie im Feld Name einen Namen für den Wartungsplan ein.

    Sie können einen Plan zum Sichern von Transaktionsprotokollen beispielsweise TfsTransaktionsprotokollsicherung nennen.

  7. Wählen Sie Einzelner Zeitplan für den gesamten Plan oder kein Zeitplan und dann Ändern.

  8. Geben Sie unter Häufigkeit und Häufigkeit pro Tag Optionen für den Plan an.

    Übernehmen Sie unter Dauer den Standardwert Kein Enddatum.

  9. Klicken Sie auf OK und dann auf Weiter.

  10. Aktivieren Sie die Kontrollkästchen Auftrag des SQL Server-Agents ausführen und Datenbank sichern (Transaktionsprotokoll) auf der Seite Wartungstasks auswählen, und wählen Sie dann Weiter aus.

  11. Ändern Sie auf der Seite Wartungstaskreihenfolge auswählen die Reihenfolge so, dass der Agentauftrag vor der Transaktionsprotokollsicherung ausgeführt wird, und wählen Sie dann Weiter aus.

    Um weitere Informationen zu diesem Dialogfeld zu erhalten, klicken Sie auf den Schlüssel F1. Suchen Sie auch nach Wartungsplanungs-Assistenten auf der folgenden Seite der Microsoft-Website: SQL Server-Onlinedokumentation.

  12. Aktivieren Sie auf der Seite Task 'Auftrag des SQL Server-Agents ausführen' definieren das Kontrollkästchen für den geplanten Auftrag, den Sie für die Tabellenmarkierung erstellt haben, und wählen Sie dann Weiter aus.

  13. Wählen Sie auf der Seite Task 'Datenbank sichern (Transaktionsprotokoll)' definieren den Pfeil nach unten, dann Alle Datenbanken und anschließend OK aus.

  14. Geben Sie die Sicherungsoptionen zum Speichern der Dateien (entsprechend der Bereitstellung und den Ressourcen) auf einem Datenträger oder Band an, und klicken Sie dann auf Weiter.

  15. Geben Sie auf der Seite Berichtsoptionen auswählen Berichtsverteilungsoptionen an, und wählen Sie zweimal Weiter aus.

  16. Wählen Sie auf der Seite Assistenten abschließen die Option Fertig stellen aus.

    SQL Server erstellt den Wartungsplan und sichert die Transaktionsprotokolle für die Datenbanken, die sie basierend auf der angegebenen Häufigkeit festgelegt haben.

Sichern des Verschlüsselungsschlüssels für Reporting Services

Sie müssen den Verschlüsselungsschlüssel für Reporting Services als Bestandteil der Systemsicherung sichern. Ohne diesen Verschlüsselungsschlüssel sind Sie nicht in der Lage, die Berichtsdaten wiederherzustellen. Für eine Bereitstellung von TFS auf einem Einzelserver können Sie den Verschlüsselungsschlüssel für SQL Server Reporting Services mit dem Reporting Services-Konfigurationstool sichern. Sie können auch das RSKEYMGMT-Befehlszeilentool verwenden, das Konfigurationstool ist aber einfacher. Weitere Informationen zu RSKEYMGMT finden Sie auf der folgenden Seite auf der Microsoft-Website: RSKEYMGMT Utility.

So sichern Sie den Verschlüsselungsschlüssel mithilfe des Reporting Services-Konfigurationstools

  1. Wählen Sie auf dem Server, auf dem Reporting Services ausgeführt wird, Start aus, zeigen Sie auf Alle Programme, Microsoft SQL Server, Konfigurationstools, und wählen Sie dann Konfigurations-Manager für Reporting Services aus.

    Es wird das Dialogfeld Auswahl der Berichtsserver-Installationsinstanz geöffnet.

  2. Geben Sie den Namen des Datenebenenservers und der Datenbankinstanz an, und wählen Sie dann Verbinden aus.

  3. Klicken Sie in der linken Navigationsleiste auf Verschlüsselungsschlüssel und dann auf Sichern.

    Das Dialogfeld Informationen zum Verschlüsselungsschlüssel wird geöffnet.

  4. Geben Sie unter Dateispeicherort den Speicherort an, wo Sie eine Kopie des Schlüssels speichern möchten.

    Sie sollten diesen Schlüssel möglichst auf einem anderen Computer speichern als dem, auf dem Reporting Services ausgeführt werden.

  5. Geben Sie unter Kennwort ein Kennwort für die Datei an.

  6. Geben Sie unter Kennwort bestätigen das Kennwort für die Datei erneut an, und wählen Sie dann OK aus.

Erstellen eines Sicherungsplans für SharePoint Foundation 2010

Im Gegensatz zu Team Foundation Server, der die Planungstools in SQL Server Management Studio nutzt, gibt es kein integriertes Planungssystem für Sicherungen in SharePoint Foundation 2010. SharePoint rät insbesondere von der Skripterstellung ab, mit der die Datenbanken markiert oder geändert werden. Um Sicherungen so zu planen, dass diese zur gleichen Zeit wie die Sicherungen für TFS erfolgen, wird im SharePoint Foundation 2010-Prozessleitfaden empfohlen, dass Sie ein Sicherungs-Skript mithilfe von Windows PowerShell erstellen und dann den Windows-Taskplaner verwenden, um das Sicherungs-Skript zur selben Zeit wie die geplanten Sicherungen der TFS-Datenbanken auszuführen. Die Datenbanksicherungen bleiben folglich synchronisiert.

Wichtiger Hinweis Wichtig

Bevor Sie mit den unten angegebenen Prozeduren fortfahren, sollten Sie den neuesten Prozessleitfaden für SharePoint Foundation 2010 lesen. Die folgenden Prozeduren basieren auf diesem Leitfaden, sind aber möglicherweise veraltet. Befolgen Sie stets die neuesten Empfehlungen und den neuesten Prozessleitfaden für SharePoint Foundation 2010, wenn Sie diesen Aspekt der Bereitstellung verwalten. Weitere Informationen erhalten Sie über die Links, die in den einzelnen Anleitungen in diesem Abschnitt enthalten sind.

So erstellen Sie Skripts, um vollständige und differenzielle Sicherungen der Farm in SharePoint Foundation 2010 durchzuführen

  1. Öffnen Sie einen Text-Editor, z. B. Editor.

  2. Geben Sie im Text-Editor Folgendes ein, wobei BackupFolder den UNC-Pfad zu einer Netzwerkfreigabe darstellt, in der Sie Ihre Daten sichern:

    Bild für Kopieren Code kopieren
    Backup-SPFarm -Directory BackupFolder -BackupMethod Full
    Tipp Tipp

    Es gibt eine Reihe weiterer Parameter, die Sie beim Sichern der Farm verwenden können. Weitere Informationen finden Sie unter Sichern einer Serverfarm und Backup-SPFarm.

  3. Speichern Sie das Skript als PS1-Datei. Geben Sie der Datei einen naheliegenden Namen wie "SharePointFarmFullBackupScript.PS1" oder einen anderen sinnvollen Namen.

  4. Öffnen Sie eine neue Datei, und erstellen Sie eine zweite Sicherungsdatei, wobei Sie nur dieses Mal eine differenzielle Sicherung angeben:

    Bild für Kopieren Code kopieren
    Backup-SPFarm -Directory BackupFolder -BackupMethod Differential

  5. Speichern Sie das Skript als PS1-Datei. Geben Sie der Datei einen naheliegenden Namen wie "SharePointFarmDiffBackupScript.PS1".

    Wichtiger Hinweis Wichtig

    Standardgemäß werden PowerShell-Skripte nicht auf dem System ausgeführt, sofern Sie die Ausführungsrichtlinie von PowerShell nicht dergestalt geändert haben, dass die Ausführung von Skripten zugelassen ist. Weitere Informationen finden Sie unter Ausführen von Windows PowerShell-Skripten.

Nachdem Sie die Skripts erstellt haben, müssen Sie diese entsprechend einplanen, damit sie nach demselben Zeitplan und mit derselben Häufigkeit wie bei jenem Zeitplan ausgeführt werden, den Sie zur Sicherung von Team Foundation Server-Datenbanken erstellt haben. Wenn beispielsweise gemäß Ihrem Plan differenzielle Sicherungen täglich um 2 Uhr morgens und vollständige Sicherungen sonntags um 4 Uhr morgens ausgeführt werden, sollen Sie genau denselben Plan für die Farmsicherungen verwenden.

Zum Planen der Sicherungen müssen Sie den Windows-Taskplaner verwenden. Außerdem müssen Sie die auszuführenden Aufgaben über ein Konto mit ausreichenden Berechtigungen konfigurieren, um Lese- und Schreibvorgänge im Sicherungsspeicherort und Sicherungen in SharePoint Foundation 2010 ausführen zu können. Im Allgemeinen besteht die einfachste Methode hierfür in der Verwendung eines Farmadministratorkontos. Sie können jedoch ein beliebiges Konto verwenden, solange die folgenden Kriterien vollständig erfüllt werden:

  • Das im Windows-Taskplaner angegebene Konto ist ein administratives Konto.

  • Das für den Anwendungspool der Zentraladministration angegebene Konto sowie das von Ihnen angegebene Konto für das Ausführen der Aufgabe verfügen über Lese-/Schreibzugriff für den Sicherungsort.

  • Auf den Speicherort der Sicherungskopie kann über den Server zugegriffen werden, auf dem SharePoint Foundation 2010, SQL Server und Team Foundation Server ausgeführt wird.

So planen Sie Sicherungen für die Farm

  1. Wählen Sie nacheinander Start, Verwaltung und Aufgabenplanung aus.

  2. Wählen Sie im Bereich Aktionen die Option Aufgabe erstellen aus.

  3. Geben Sie auf der Registerkarte Allgemein unter Name einen Namen für diesen Task an, beispielsweise "Vollständige Farmsicherung". Geben Sie unter Sicherheitsoptionen das Benutzerkonto an, unter dem die Aufgabe ausgeführt werden soll, falls es sich nicht um das verwendete Konto handelt. Wählen Sie dann Unabhängig von der Benutzeranmeldung ausführen aus, und aktivieren Sie das Kontrollkästchen Mit höchsten Privilegien ausführen.

  4. Wählen Sie auf der Registerkarte Aktionen die Option Neu aus.

    Wählen Sie im Fenster Neue Aktion unter Aktion die Option Programm starten aus. Geben Sie unter Programm/Skript den vollständigen Pfad und Dateinamen des Skripts der vollständigen Farmsicherung .PS1 ein, das Sie erstellt haben, und wählen Sie dann OK aus.

  5. Wählen Sie auf der Registerkarte Trigger die Option Neu aus.

    Geben Sie im Fenster Neuer Trigger unter Einstellungen den Zeitplan für das Ausführen der vollständigen Sicherung der Farm an. Stellen Sie sicher, dass dieser Zeitplan genau mit dem Zeitplan für vollständige Sicherungen der Team Foundation Server-Datenbanken übereinstimmt, einschließlich des Wiederholungszeitplans, und wählen Sie anschließend OK aus.

  6. Überprüfen Sie alle Informationen auf den Registerkarten, und wählen Sie dann OK aus, um die Aufgabe für die vollständige Sicherung für die Farm zu erstellen.

  7. Wählen Sie im Bereich Aktionen die Option Aufgabe erstellen aus.

  8. Geben Sie auf der Registerkarte Allgemein unter Name einen Namen für diesen Task an, beispielsweise "Differenzielle Farmsicherung". Geben Sie unter Sicherheitsoptionen das Benutzerkonto an, unter dem die Aufgabe ausgeführt werden soll, falls es sich nicht um das verwendete Konto handelt, wählen Sie Unabhängig von der Benutzeranmeldung ausführen aus, und aktivieren Sie das Kontrollkästchen Mit höchsten Privilegien ausführen.

  9. Wählen Sie auf der Registerkarte Aktionen die Option Neu aus.

    Wählen Sie im Fenster Neue Aktion unter Aktion die Option Programm starten aus. Geben Sie unter Programm/Skript den vollständigen Pfad und Dateinamen des Skripts der differenziellen Farmsicherung .PS1 ein, das Sie erstellt haben, und wählen Sie dann OK aus.

  10. Wählen Sie auf der Registerkarte Trigger die Option Neu aus.

    Geben Sie im Fenster Neuer Trigger unter Einstellungen den Zeitplan für das Ausführen der vollständigen Sicherung der Farm an. Stellen Sie sicher, dass dieser Zeitplan genau mit dem Zeitplan für vollständige Sicherungen der Team Foundation Server-Datenbanken übereinstimmt, einschließlich des Wiederholungszeitplans, und wählen Sie anschließend OK aus.

  11. Überprüfen Sie alle Informationen auf den Registerkarten, und wählen Sie dann OK aus, um die Aufgabe für die differenzielle Sicherung für die Farm zu erstellen.

  12. Aktualisieren Sie die Liste unter Aktive Aufgaben, und überprüfen Sie, ob die neuen Aufgaben entsprechend geplant werden. Schließen Sie dann den Taskplaner. Weitere Informationen zum Erstellen und Planen von Aufgaben im Taskplaner finden Sie unter Aufgabenplanung: So wird es gemacht.

POS1 | Vorbereiten für die Installation | Installieren von erforderlichen Komponenten und Team Foundation Server | Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams | Erstellen eines Backupplans


Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]
Feedback senden

Unabhängig davon, wie gut Sie die Hardware warten, sind Serverfehler nicht auszuschließen. Als erfahrener Administrator wissen Sie, wie Sie sich gegen ein derartiges Ereignis wappnen können. Wenn der Server, der die Bereitstellung von Team Foundation Server (TFS) hostet, ausfällt oder durch einen Unglücksfall zerstört wird, können Sie mithilfe der Sicherungen, die Sie für die Datenbanken und die SharePoint Foundation 2010-Farm erstellt haben, die Bereitstellung auf einem neuen Server wiederherstellen. Obwohl die Wiederherstellung einer gesamten Bereitstellung nicht einfach ist, können Sie mit zuverlässigen Datensicherungen und den Installationsmedien für die zu installierenden Programme die Bereitstellung so wiederherstellen, dass die vollständige Funktionalität verfügbar ist.

Zusätzlich zu den Datensicherungen benötigen Sie die Installationsmedien für TFS, SQL Server 2008 R2 SP1 und SharePoint Foundation 2010, einschließlich Zugriff auf alle Service Packs, die Sie auf die ursprüngliche Bereitstellung angewendet haben. Sie müssen die Software auf dem gleichen Betriebssystem wie den ursprünglichen Server installieren und konfigurieren, und Sie sollten sicherstellen, dass Sie die Sicherungen auf der gleichen Versions-, Editions- und Wartungsebene der Software wiederherstellen, die Sie gesichert haben.

Dieses Lernprogramm ist als Begleitlernprogramm zu Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] vorgesehen. Es wird Ihnen leichter fallen, den Informationen zu folgen, wenn Sie mit dem Lernprogramm vertraut sind.

Hinweis Hinweis

Dieses Lernprogramm enthält fiktive Benutzer, Server und Unternehmen als Bestandteil der Beispiele, mit denen die Prozeduren veranschaulicht werden. Die in den Beispielen genannten Unternehmen, Organisationen, Produkte, Domänennamen, E-Mail-Adressen, Logos, Personen, Orte und Ereignisse sind frei erfunden. Jede Ähnlichkeit mit tatsächlichen Firmen, Organisationen, Produkten, Domänen, Personen, Orten, Ereignissen, E-Mail-Adressen und Logos ist rein zufällig.

Inhalte des Lernprogramms

Titel | Beschreibung
Vorbereiten der neuen Hardware | Erfahren Sie, wie die richtige Ersatzhardware ausgewählt wird, überprüfen Sie die erforderlichen Komponenten für einen Ersatzserver, und installieren Sie die Software, die Sie benötigen, um die Bereitstellung wiederherzustellen. Als Teil dieses Prozesses müssen Sie einen Ersatzserver auswählen und anschließend SQL Server 2008 R2 SP1, SharePoint Foundation 2010 sowie jene Tools installieren, die erforderlich sind, um die wiederhergestellten TFS-Datenbanken neu zu konfigurieren.
Wiederherstellen von Datenbanken | Erfahren Sie, wie Sie die Datenbanken von den Sicherungen und die SharePoint-Farm wiederherstellen können. Als Teil dieses Prozesses müssen Sie die Konfiguration, die Auflistung, die Berichtsdatenbanken und die SharePoint-Farm über die Sicherungskopie wiederherstellen sowie die TFS-Datenbanken neu konfigurieren, damit diese für die Verwendung mit dem Team Foundation Server bereit sind.
Installieren und Konfigurieren von Team Foundation Server | Erfahren Sie, wie Sie den Nur für Anwendungsebene - Assistent verwenden, um die Webdienste und Anwendungen für TFS zu installieren. Als Teil dieses Prozesses müssen Sie Team Foundation Server und die Erweiterungen für SharePoint-Produkte installieren sowie Dienstkonten, die Berichterstellung und Analyseressourcen konfigurieren, damit der betreffende Teil der Datenwiederherstellung abgeschlossen werden kann.
Dienste und Benutzer erneut verbinden | Erfahren Sie, wie dem neuen Server Benutzergruppen hinzugefügt werden und wie die Datencaches gelöscht werden können, um Datenfehler zu verhindern. Als Teil dieses Prozesses müssen Sie die Benutzergruppen dergestalt konfigurieren, dass die Benutzer jene Berechtigungen besitzen, die sie in TFS, SQL Server Reporting Services und SharePoint Foundation 2010 benötigen. Erfahren Sie, wie der Arbeitsaufgabecache auf dem neuen Server gelöscht wird, und erfahren Sie, wie Benutzer ihre Caches für die Versionskontrolle auf ihren eigenen Computern löschen können, damit sie keine Datencacheprobleme haben, wenn sie eine Verbindung mit dem neuen Server herstellen.


Vorbereiten der neuen Hardware

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Vorbereiten der neuen Hardware
Feedback senden

In diesem Thema, dem ersten Teil des Lernprogramms zum Wiederherstellen eines Einzelservers, lernen Sie, wie die erforderlichen Komponenten installiert und konfiguriert werden, wie die Datenbanken und die SharePoint-Farm wiederhergestellt werden und wie die Tools für Team Foundation Server (TFS) installiert werden, die zum erneuten Konfigurieren dieser wiederhergestellten Datenbanken erforderlich sind, bevor Sie TFS auf der neuen Hardware installieren.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber" und sorgt nach einem Hardwarefehler der ursprünglichen Bereitstellung für die Wiederherstellung, was in Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] beschrieben wird. Die Vertrautheit mit diesem Lernprogramm, insbesondere mit den Software-Installationsverfahren und der Architektur, die in Installieren von erforderlichen Komponenten und Team Foundation Server beschrieben werden, kann Ihnen bei der Durchführung der Schritte in diesem Lernprogramm helfen.

In diesem Thema

  1. Auswählen der Hardware und Benennen des Servers

  2. Installieren von SQL Server 2008 R2 auf dem neuen Server

  3. Installieren von SharePoint Foundation 2010 auf dem neuen Server

  4. Installieren der Team Foundation Server-Tools

Erforderliche Berechtigungen

Um die Schritte in diesem Thema auszuführen, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein, auf dem Sie die Software installieren möchten.

Auswählen der Hardware und Benennen des Servers

Eine Bereitstellung wiederherzustellen, die aufgrund eines Hardwarefehlers unerwartet offline ist, ist immer stressig und beinhaltet gewöhnlich das schnellstmögliche Erfassen von Hardware. Möglicherweise möchten Sie einen nicht verwendeten Computer als neuen Server nutzen. Um die langfristige Integrität der Bereitstellung und eine erfolgreiche Wiederherstellung der Bereitstellung zu gewährleisten, sollten Sie keinen Server mit weniger Arbeitsspeicher als der vorherige Computer verwenden. Darüber hinaus sollten Sie sicherstellen, dass auf dem neuen Server dasselbe Betriebssystem wie auf dem alten Server ausgeführt wird. Die Service Pack-Stufe muss mit der Service Pack-Stufe des vorherigen Servers so genau wie möglich übereinstimmen.

Dies kann jedoch ein günstiger Zeitpunkt für die Erweiterung des Festplattenspeichers oder der Rechenleistung für die Bereitstellung sein, insbesondere wenn der vorherige Server nicht die gewünschte Leistung erbracht hat oder die Festplattenkapazität nahezu erschöpft war. Die Aktualisierung der Anzahl oder der Geschwindigkeit der Prozessoren, das Hinzufügen von zusätzlichem Arbeitsspeicher oder das Hinzufügen von zusätzlichem Festplattenspeicher sollte die Wiederherstellung nicht beeinträchtigen. Sie und die Benutzer können folglich von einem schnelleren und leistungsfähigeren Server profitieren.

Benennen von Servern

Für die Benutzer ist es einfacher, wenn der neue Server genau den gleichen Namen aufweist wie der alte Server. Sie werden die Wiederherstellung der Bereitstellung auch viel einfacher finden, wenn der neue Server den gleichen Namen hat wie der alte Server. Falls nichts gegen die Wiederverwendung des Namens spricht, nutzen Sie den Namen des alten Servers auch für den neuen Server.

Der neue Server für die Beispielsbereitstellung

In diesem Beispiel wird das Lernprogramm fortgesetzt, das Jill Frank verfolgt. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber" und sorgt nach einem Hardwarefehler der ursprünglichen Bereitstellung für die Wiederherstellung. Auf Jills vorherigen Server wurde die 64-Bit-Edition mit installiertem Betriebssystem Windows Server 2008 R2 mit Service Pack 1 ausgeführt. Er verfügte zudem über einen Doppelkernprozessor und 10 GB RAM und wies einen freien Speicherplatz von 300 GB auf. Bei der unerwarteten Anforderung, einen neuen Server zu nutzen, erwägt sie kurz, einen anderen Computer zu verwenden, der genau diesen Spezifikationen entspricht. Sie weiß jedoch, dass TFS in zunehmendem Maße verwendet wird und dass einige andere Abteilungen die Verwendung ihrer Bereitstellung erwägen. Sie kümmert sich um die Finanzierung, um einen neuen Server mit einem schnelleren Dual-Core-Prozessor-System, 16 GB RAM und zwei 500-GB-Festplatten zu erwerben. Ebenso wie der alte Server wird von diesem neuen Server die 64-Bit-Edition von Windows Server 2008 R2 mit dem installierten Service Pack 1 ausgeführt. Sie gibt dem neuen Server den gleichen Namen wie dem alten Server, nämlich "FabrikamPrime".

Installieren von SQL Server 2008 R2 auf dem neuen Server

Nachdem Sie einen Server abrufen, der die oben erwähnten Anforderungen erfüllt, und diesem den gleichen Namen geben, müssen Sie die gleiche Version und Edition von SQL Server auf der neuen Hardware installieren. Außerdem müssen Sie sicherstellen, dass Sie dieselben Sortierungseinstellungen wie bei der vorherigen Bereitstellung auswählen. Ansonsten können Sie die Datenbanken, die Sie für die alte Bereitstellung gesichert haben, nicht wiederherstellen.

Tipp Tipp

Die meisten Installationen von SQL Server verwenden die standardmäßigen Sortierungseinstellungen. Die standardmäßigen Sortierungseinstellungen werden durch das Windows-Systemgebietsschema auf dem Server festgelegt, auf dem Sie SQL Server installieren. In der Beispielbereitstellung im Lernprogramm Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] wurden die Standardeinstellungen verwendet, und der neue Server verfügt über das gleiche Systemgebietsschema wie der alte Server, sodass die Sortierungseinstellungen standardmäßig identisch sind.

In der Beispielsbereitstellung installiert Jill SQL Server R2 unter Verwendung der exakt gleichen Einstellungen und Optionen, die sie verwendet hatte, als sie die Software auf dem ursprünglichen Server installiert hat. Anschließend wendet sie das Service Pack 1 an. Diese Optionen werden in der folgenden Prozedur verwendet und sind mit denen identisch, die in Installieren von erforderlichen Komponenten und Team Foundation Server aufgeführt sind.

So installieren Sie SQL Server 2008 R2 zur Unterstützung von Team Foundation Server

  1. Starten Sie das SQL Server-Installationscenter.

  2. Wählen Sie auf der Seite SQL Server-Installationscenter die Option Installation und dann Neue Installation oder Hinzufügen von Features zu einer vorhandenen Installation aus.

  3. Stellen Sie auf der Seite Setupunterstützungsregeln sicher, dass alle Regeln bestanden haben, und wählen Sie anschließend OK aus.

  4. Stellen Sie auf der Seite Product Key Ihren Product Key bereit, und wählen Sie dann Weiter aus.

  5. Lesen Sie die Lizenzvereinbarung auf der Seite Lizenzbedingungen. Wenn Sie mit den Bedingungen einverstanden sind, wählen Sie Ich stimme den Lizenzbedingungen zu aus. Aktivieren Sie optional das Kontrollkästchen, um Nutzungsdaten an Microsoft zu senden, und wählen Sie anschließend Weiter aus.

  6. Wählen Sie auf der Seite Setup-Unterstützungsdateien die Option Installieren aus.

  7. Überprüfen Sie auf der Seite Setupunterstützungsregeln die Setupinformationen. Beheben Sie alle Fehlerbedingungen, und wählen Sie dann Weiter aus.

  8. Wählen Sie auf der Seite Setuprolle die Option SQL Server-Funktionsinstallation aus, und wählen Sie anschließend Weiter aus.

  9. Aktivieren Sie auf der Seite Featureauswahl die folgenden Kontrollkästchen, und wählen Sie dann Weiter aus:

    • Datenbankmoduldienste

    • Volltextsuche

    • Analysis Services

    • Reporting Services

    • Konnektivität der Clienttools

    • Verwaltungstools - Einfach

    • Verwaltungstools - vollständig

    SQL Server 2008 R2 installieren - Funktionen

  10. Überprüfen Sie auf der Seite Installationsregeln alle Warnungen, und beheben Sie alle Fehler, und wählen Sie dann Weiter aus.

  11. Wählen Sie auf der Seite Instanzkonfiguration die Option Standardinstanz aus, und wählen Sie dann Weiter aus.

  12. Überprüfen Sie auf der Seite Erforderlicher Speicherplatz die Informationen, um sicherzustellen, dass Sie über genügend Festplattenspeicher verfügen, und wählen Sie anschließend Weiter aus.

  13. Wählen Sie auf der Seite Serverkonfiguration die Option Gleiches Konto für alle SQL Server-Dienste verwenden aus. Wählen Sie im Fenster Gleiches Konto für alle SQL Server 2008 R2-Dienste verwenden NT AUTHORITY\NETWORK SERVICE aus, oder geben Sie es an, und wählen Sie anschließend OK aus.

    Überprüfen Sie in der Spalte Starttyp, dass der Wert Automatisch für alle Dienste angezeigt wird, die Sie bearbeiten können, und klicken Sie dann auf Weiter.

    Konten festgelegt auf Netzwerkdienst/Automatisch

  14. Wählen Sie auf der Seite Database Engine Services auf der Registerkarte Kontobereitstellung die Option Windows-Authentifizierungsmodus aus, und wählen Sie anschließend Aktuellen Benutzer hinzufügen aus, um dieser SQL Server-Instanz Ihr Konto als Administrator hinzuzufügen. Fügen Sie optional ein beliebiges Benutzerkonto für Benutzer hinzu, die als Datenbankadministratoren fungieren sollen, und wählen Sie anschließend Weiter aus.

  15. Wählen Sie auf der Seite Analysis Services-Konfiguration auf der Registerkarte Kontobereitstellung die Option Aktuellen Benutzer hinzufügen aus, um der Analysis Services-Datenbank Ihr Konto als Administrator hinzuzufügen. Fügen Sie optional ein beliebiges Benutzerkonto für Benutzer hinzu, die als Administratoren fungieren sollen, und wählen Sie anschließend Weiter aus.

  16. Wählen Sie auf der Seite Reporting Services-Konfiguration die Option Standardkonfiguration des systemeigenen Modus installieren aus, und wählen Sie anschließend Weiter aus.

  17. Wählen Sie auf der Seite Fehlerberichterstattung aus, ob Sie Informationen zu Fehlern an Microsoft senden möchten, und wählen Sie dann Weiter aus.

  18. Überprüfen Sie auf der Seite Installationsregeln alle Fehler oder Warnungen, und wählen Sie dann Weiter aus.

  19. Überprüfen Sie auf der Seite Bereit für die Installation die Liste der zu installierenden Komponenten und ob sie mit der unten abgebildeten Liste der Funktionen übereinstimmen, wählen Sie anschließend Installieren aus. Wenn Sie Änderungen vornehmen müssen, wählen Sie Zurück aus.

    SQL Server 2008 R2 installieren - Fertig

    Überwachen Sie auf der Seite Installationsstatus optional den Installationsstatus jeder Komponente. Wenn alle Komponenten installiert sind, wird die Seite Abgeschlossen angezeigt. Überprüfen Sie alle Meldungen, und schließen Sie die Seite.

  20. Wenn Sie die Installation beenden, navigieren Sie zur Microsoft Update-Site, um die gleichen Service Packs oder Updates anzuwenden, die Sie bei der Installation auf dem alten Server angewendet haben. TFS erfordert SQL Server 2008 R2 Service Pack 1. Stellen Sie sicher, dass das Service Pack installiert ist. Wenden Sie keine Service Packs oder Updates an, die nicht auf diesen Server angewendet wurden.

Installieren von SharePoint Foundation 2010 auf dem neuen Server

Anders als bei einer neuen Installation von Team Foundation Server, können Sie den Installations-Assistenten nicht für TFS verwenden, sodass SharePoint Foundation 2010 für Sie installiert wird. Wenn Sie die im SharePoint Foundation 2010-Teil der Bereitstellung verwendeten Teamprojektportale und andere Informationen wiederherstellen möchten, müssen Sie SharePoint Foundation 2010 zuerst manuell installieren und anschließend die Farm wiederherstellen.

Verwenden der SharePoint-Tools zum Installieren von SharePoint Foundation 2010

Sie können die Tools und Funktionen verwenden, die in SharePoint Foundation 2010 bereitgestellt werden, um die Anwendung auf dem neuen Server zu installieren. Sie sollten die gleiche Bereitstellungskonfiguration wie bei der vorherigen Bereitstellung auswählen. Wenn Sie beispielsweise SharePoint Foundation 2010 in der ursprünglichen Bereitstellung beim Installationsvorgang für Team Foundation Server automatisch installiert haben, sollten Sie SharePoint Foundation 2010 auf einem einzelnen Server, aber mit der Installation von SQL Server installieren, die Sie bereits auf dem neuen Server installiert haben. Sie sollten auch das Vorbereitungstool für Microsoft SharePoint-Produkte ausführen, bevor Sie SharePoint Foundation 2010 installieren.

So installieren Sie SharePoint Foundation 2010 in einer Einzelserver-Farmkonfiguration

  1. Starten Sie die Installationsmedien für SharePoint Foundation 2010. Wählen Sie auf der SharePoint Foundation 2010-Startseite die Option SharePoint Foundation installieren aus.

  2. Überprüfen Sie auf der Seite Microsoft-Software-Lizenzbedingungen lesen die Bedingungen, aktivieren Sie das Kontrollkästchen Ich stimme den Bedingungen dieses Vertrags zu, und wählen Sie anschließend Weiter aus.

  3. Wählen Sie auf der Seite Gewünschte Installation auswählen die Option Serverfarm aus.

  4. Wählen Sie auf der Registerkarte Servertyp die Option Vollständig aus.

    Wenn Sie SharePoint Foundation 2010 an einem benutzerdefinierten Speicherort installieren möchten, wählen Sie die Registerkarte Datenspeicherort aus, und geben Sie dann den Speicherort manuell ein, oder wählen Sie Durchsuchen, um den Speicherort anzugeben.

  5. Wählen Sie Jetzt installieren aus.

  6. Wenn das Setup abgeschlossen ist, wählen Sie Schließen aus. Führen Sie die Farmerstkonfiguration nicht durch.

Installieren von SharePoint Foundation 2010 mit Windows PowerShell

Obwohl es mehrere Möglichkeiten zum Installieren von SharePoint Foundation 2010 gibt, darunter auch die in SharePoint Foundation 2010 bereitgestellten Tools, ist für die Wiederherstellung der Farm die Anwendung Windows PowerShell erforderlich. Sie können auch Windows PowerShell verwenden, um SharePoint Foundation 2010 zu installieren. Der Einfachheit halber sollten Sie Windows PowerShell für die Installation und Wiederherstellung von SharePoint Foundation 2010 auf dem neuen Server verwenden. Weitere Informationen zu Windows PowerShell finden Sie unter Erste Schritte: Verwalten von Windows Server 2008 R2 mit der Windows PowerShell.

So installieren Sie SharePoint Foundation 2010 mit Windows PowerShell

  1. Öffnen Sie eine Windows PowerShell-Eingabeaufforderung.

  2. Geben Sie den folgenden Befehl ein, wobei Laufwerk den Speicherort der Installationsmedien für SharePoint Foundation 2010 darstellt:

    Bild für Kopieren Code kopieren
    Install-SharePoint -SetupExePath "Drive:\SharePoint 2010\Setup\setup.exe"

    SharePoint Foundation 2010 wird mit einem PID-Schlüssel in einer Farmbereitstellung installiert, aber nicht konfiguriert. Datenbanken werden auch nicht erstellt. Stattdessen stellen Sie die Farm und ihre Datenbanken für diese Installation wieder her.

    Tipp Tipp

    Alternativ können Sie auswählen, eine XML-Konfigurationsdatei mit dem Install-SharePoint-Befehl zu verwenden, um SharePoint Foundation 2010 zu installieren.

    Weitere Informationen finden Sie unter Installieren von SharePoint Foundation 2010 mithilfe von Windows PowerShell.

Installieren der Team Foundation Server-Tools

Bevor die wiederhergestellten Datenbanken ordnungsgemäß funktionieren, verwenden Sie den TFSConfig PrepSQL-Befehl, um SQL Server auf das Hosten der Datenbanken für Team Foundation Server vorzubereiten. Mit diesem Befehl werden auf dem neuen Server oder der neuen Instanz die Gruppen TFSEXECROLE und TFSADMINROLE erstellt und die Systemmeldungen hinzugefügt, die für den Vorgang erforderlich sind. Um Zugriff auf dieses Tool zu haben, müssen Sie Team Foundation Server installieren jedoch nicht konfigurieren.

So installieren Sie Team Foundation Server-Binärdateien und -Tools

  1. Starten Sie die Installationsmedien für Team Foundation Server. Wählen Sie auf der Seite Team Foundation Server - Setup die Option Installieren aus.

  2. Wenn die Installation abgeschlossen ist, wird das Team Foundation Server-Konfigurationscenter geöffnet. Wählen Sie Abbrechen aus.

    Die Verwaltungskonsole wird automatisch geöffnet, obwohl der Konfigurationsprozess für die Installation nicht abgeschlossen ist. Schließen Sie die Konsole.

POS1 | Vorbereiten der neuen Hardware | Wiederherstellen von Datenbanken | Installieren und Konfigurieren von Team Foundation Server | Dienste und Benutzer erneut verbinden


Wiederherstellen von Datenbanken

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Wiederherstellen von Datenbanken
Feedback senden

In diesem Thema, dem zweiten Teil des Lernprogramms zum Wiederherstellen eines Einzelservers, lernen Sie, wie die Sicherungen vom ursprünglichen Server verwendet werden, um die Datenbanken und die SharePoint-Farm auf dem neuen Server wiederherzustellen. Auf dem neuen Server können Sie anschließend Team Foundation Server (TFS) konfigurieren.

Sie können die Sicherungen verwenden, die Sie von der ursprünglichen Bereitstellung erstellt haben, um die Daten aus dieser Bereitstellung auf dem neuen Server wiederherzustellen. Wenn Sie die Daten wiederherstellen, sollten Sie sicherstellen, dass alle Datenbanken und die SharePoint-Farm auf den gleichen Zeitpunkt wiederhergestellt werden. Wenn Sie der Anleitung in Erstellen eines Backupplans gefolgt sind, wird mithilfe der markierten Transaktionen in den TFS-Datenbanken und der synchronisierten geplanten Sicherungen für TFS und SharePoint Foundation 2010 gewährleistet, dass alle Daten gleichzeitig wiederhergestellt werden, und die Wahrscheinlichkeit von Datenkonflikten wird reduziert.

Wichtiger Hinweis Wichtig

Wenn die ursprüngliche Bereitstellung eine SQL Server Enterprise oder Datacenter Edition verwendet hat und Datenbanken auf einem Server mit Standard Edition wiederhergestellt werden sollen, müssen Sie einen Sicherungssatz verwenden, der bei deaktivierter SQL Server-Komprimierung erstellt wurde. Wird die Datenkomprimierung nicht deaktiviert, können Enterprise oder Datacenter Edition-Datenbanken auf einem Server mit Standard Edition nicht wiederhergestellt werden. Führen Sie zum Deaktivieren der Komprimierung die in Microsoft Knowledge Base-Artikel genannten Schritte aus.

Nachdem Sie die Datenbanken wiederhergestellt haben, müssen Sie diese für die Verwendung mit TFS konfigurieren, indem Sie die Befehlszeilentools nutzen.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber" und sorgt nach einem Hardwarefehler der ursprünglichen Bereitstellung für die Wiederherstellung, was in Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] beschrieben wird. Die Vertrautheit mit diesem Lernprogramm und der darin beschriebenen Architektur kann Ihnen bei der Durchführung der Schritte in diesem Lernprogramm helfen.

In diesem Thema

  • Wiederherstellen von Team Foundation Server-Datenbanken

  • Wiederherstellen der SharePoint-Farm

  • Bereitmachen der Datenbanken für Team Foundation Server

Erforderliche Berechtigungen

Um diesen Vorgang auszuführen, müssen Sie Mitglied der folgenden Gruppen sein oder über folgende Berechtigungen verfügen:

  • Ein Member der Administratoren-Sicherheitsgruppe auf dem Server.

  • Es muss entweder ein Mitglied der Sicherheitsgruppe SQL Server-Systemadministrator, oder die Berechtigung SQL Server-Berechtigungen zum Erstellen von Sicherungskopien und zum Erstellen von Wartungsplänen auf Zulassen festgelegt sein.

  • Ein Member der sysadmin-Sicherheitsgruppe für die Datenbanken für Team Foundation.

  • Ein Mitglied der Gruppe Farmadministratoren

Wiederherstellen von Team Foundation Server-Datenbanken

Das Installieren und Konfigurieren von Software reicht nicht aus, um eine Bereitstellung wiederherzustellen. Sie müssen die Daten wiederherstellen, bevor die Benutzer wieder damit arbeiten. Sie können Daten für Team Foundation Server wiederherstellen, indem Sie Tools verwenden, die von SQL Server bereitgestellt werden. SQL Server Management Studio hilft Ihnen beim Wiederherstellen sämtlicher von TFS verwendeten Datenbanken und Verwendung der gleichen Sicherungssätze. Sie können vollständige und inkrementelle Sicherungen sowie Transaktionsprotokollsicherungen auf die neue Bereitstellung anwenden.

Hinweis Hinweis

Diese Prozedur ist speziell für das Wiederherstellen von TFS-Datenbanken in SQL Server konzipiert. Weitere allgemeine Informationen zum Wiederherstellen von Datenbanken in SQL Server 2008 R2 sowie zu anderen Wiederherstellungsmethoden finden Sie auf der folgenden Seite auf der Microsoft-Website: Implementieren von Wiederherstellungsszenarien für SQL Server-Datenbanken.

So öffnen Sie das Dialogfeld Datenbank wiederherstellen

  1. Wählen Sie Start und anschließend Alle Programme aus. Wählen Sie danach Microsoft SQL Server 2008 gefolgt von SQL Server Management Studio aus.

    Das Dialogfeld Mit Server verbinden wird angezeigt.

  2. Klicken Sie in der Liste Servertyp auf Datenbankmodul.

  3. Geben Sie unter Servername den Namen des Servers an, und wählen Sie dann Verbinden aus.

    Hinweis Hinweis

    In der Beispielsbereitstellung gibt Jill FABRIKAMPRIME als den Servernamen an. Sie verwendet die Standardinstanz, sodass sie keinen Instanznamen angeben muss.

    SQL Server Management Studio wird geöffnet.

  4. Erweitern Sie den Knoten Datenbanken.

Führen Sie den nächsten Vorgang "So stellen Sie eine Datenbank wieder her" für jede Datenbank durch, die von Team Foundation Server in der Bereitstellung verwendet wird. In der Beispielsbereitstellung hat Jill die folgenden Datenbanken wiederhergestellt:

  • TFS_Warehouse

  • TFS_DefaultCollection

    Dies ist der Standardname der Auflistungsdatenbank. Wenn Sie den Namen angepasst haben, müssen Sie den entsprechenden Namen verwenden.

  • TFS_Configuration

  • ReportServer

  • ReportServerTempDB

So stellen Sie eine Datenbank wieder her

  1. Markieren Sie "Datenbanken" im Objekt-Explorer, öffnen Sie das Untermenü, und wählen Sie dann Datenbank wiederherstellen aus.

    Das Dialogfeld Datenbank wiederherstellen wird angezeigt.

  2. Geben Sie unter "In Datenbank" den Namen der Datenbank ein, die Sie wiederherstellen möchten, beispielsweise TFS_Configuration. Klicken Sie unter Quelle für die Wiederherstellung auf Von Medium und dann auf die Schaltfläche mit den drei Auslassungszeichen (...).

  3. Klicken Sie im Dialogfeld Sicherung angeben auf Hinzufügen. Geben Sie den Speicherort der Sicherungsdatei für die Datenbank an, die Sie wiederherstellen möchten, und wählen Sie dann zweifach OK aus.

    Sie müssen zunächst die vollständige Sicherung wiederherstellen, danach die differenzielle Sicherung und zuletzt die Transaktionsprotokollsicherungen - in der Reihenfolge, in der diese erstellt wurden.

  4. Aktivieren Sie unter Wählen Sie die wiederherzustellenden Sicherungssätze aus die Kontrollkästchen für die Sicherungssätze, die wiederhergestellt werden sollen.

    Stellen Sie sicher, dass Sie die vollständigen, die differenziellen und die Transaktionsprotokolldatenbanken wiederherstellen, wenn Sie Sicherungssätze mit markierten Transaktionen erstellt haben.

  5. Klicken Sie im Bereich Seite auswählen auf Optionen, und aktivieren Sie dann das Kontrollkästchen Vorhandene Datenbank überschreiben.

  6. Überprüfen Sie, ob die Pfade in der Liste Datenbankdateien wiederherstellen als mit den aktuellen Datenbankpfaden übereinstimmen.

  7. Wählen Sie unter Wiederherstellungsstatus die Option Datenbank nicht betriebsbereit belassen und kein Rollback für Transaktionen ohne Commit ausführen. Zusätzliche Transaktionsprotokolle können nicht wiederhergestellt werden. (RESTORE WITH RECOVERY); wählen Sie dann OK.

    Eine Statusanzeige wird angezeigt.

  8. Wenn das SQL Server Management Studio-Dialogfeld angezeigt wird und die Wiederherstellung als erfolgreich bestätigt wird, wählen Sie OK aus, um zum Objekt-Explorer zurückzukehren.

  9. Öffnen Sie das Kontextmenü für die Datenbank, die Sie eben wiederhergestellt haben, und wählen Sie Aufgaben, Wiederherstellen und dann Transaktionsprotokoll aus.

    Das Fenster Transaktionsprotokoll wiederherstellen wird angezeigt.

  10. Stellen Sie sicher, dass auf der Seite Allgemein in der Liste Datenbank die entsprechende Datenbank hervorgehoben ist.

  11. Aktivieren Sie unter Transaktionsprotokoll auswählen, das wiederhergestellt werden soll das Kontrollkästchen neben dem Protokoll, das Sie wiederherstellen möchten.

  12. Klicken Sie unter Wiederherstellen in auf Markierte Transaktion.

    Das Fenster Markierte Transaktion auswählen wird geöffnet.

  13. Aktivieren Sie in der Liste Wählen Sie die markierte Transaktion aus, an der die Wiederherstellung beendet werden soll das Kontrollkästchen neben der Transaktionsmarkierung, die Sie für die Wiederherstellung verwenden möchten, und klicken Sie dann auf OK.

    Wichtiger Hinweis Wichtig

    Sie müssen dieselbe Transaktionsmarkierung mit demselben Datum und derselben Uhrzeit für alle Datenbanken verwenden, um die Daten erfolgreich wiederherzustellen.

  14. Klicken Sie im Fenster Transaktionsprotokoll wiederherstellen auf OK.

    Eine Statusanzeige wird angezeigt.

  15. Wählen Sie OK aus, wenn das SQL Server Management Studio-Dialogfeld angezeigt wird und die Wiederherstellung als erfolgreich bestätigt wird.

    Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Anwenden von Transaktionsprotokollsicherungen.

Wenn Sie alle Datenbanken wiederhergestellt haben, müssen Sie auch den Verschlüsselungsschlüssel für die Berichtsdatenbanken wiederherstellen.

So stellen Sie den Verschlüsselungsschlüssel für Reporting Services wieder her

  1. Wählen Sie nacheinander Start, Alle Programme und Microsoft SQL Server R2 aus. Anschließend wählen Sie Konfigurationstools und dann Konfigurations-Manager für Reporting Services aus.

  2. Geben Sie unter Konfigurationsverbindung für Reporting Services den Namen des Servers an, und wählen Sie dann Verbinden aus.

    In der Beispielsbereitstellung unter Servername gibt Jill FABRIKAMPRIME unter Servername ein. Da sie die Standardinstanz verwendet, braucht sie den Instanznamen vom Standardwert MSSQLSERVER nicht zu ändern.

  3. Wählen Sie im Bereich Verbinden die Option Verschlüsselungsschlüssel und im Bereich "Verschlüsselungsschlüssel" die Option Wiederherstellen aus.

    Das Fenster Verschlüsselungsschlüssel wiederherstellen wird geöffnet.

  4. Geben Sie unter Dateispeicherort den Speicherort der Sicherungsdatei für den Verschlüsselungsschlüssel an. Geben Sie unter Kennwort das Kennwort an, das Sie bei der Sicherung des Verschlüsselungsschlüssels verwendet haben, und wählen Sie dann OK aus.

  5. Der Status der Wiederherstellung wird unter Ergebnisse angezeigt. Wenn im Bereich Ergebnisse angezeigt wird, dass der Verschlüsselungsschlüssel wiederhergestellt wurde, schließen Sie den Konfigurations-Manager für Reporting Services.

Wiederherstellen der SharePoint-Farm

Anders als bei Team Foundation Server-Datenbanken können Sie die SQL Server Management Studio-Tools nicht zum Wiederherstellen der Farm verwenden. Sie müssen Windows PowerShell mit dem Befehl "Wiederherstellung-SPFarm" verwenden, um die Sicherung wiederherzustellen, die Sie von der SharePoint-Farm erstellt haben. In einigen Fällen können Sie die Zentraladministrationswebsite verwenden, um die Farm, anstelle den Befehl "Restore-SPFarm" zu verwenden, wiederherzustellen. Der PowerShell-Befehl ist jedoch die bevorzugte Methode zum Wiederherstellen einer Farm.

Um eine Farm wiederherzustellen, müssen Sie entweder mit einem Konto angemeldet sein, das Mitglied der Gruppe "Farmadministratoren" ist, oder Sie müssen die Anmeldeinformationen für ein Konto bereitstellen, das Mitglied dieser Gruppe ist, wenn Sie dazu aufgefordert werden.

So stellen Sie die Farm für SharePoint Foundation 2010 mit Wiederherstellung-SPFarm wieder her

  1. Öffnen Sie die Windows PowerShell oder die SharePoint 2010-Verwaltungsshell.

  2. Geben Sie bei der Windows PowerShell-Eingabeaufforderung den folgenden Befehl ein, wobei UNCPath der vollständig qualifizierte UNC-Pfad des Verzeichnisses ist, in dem sich die Farmsicherung befindet:

    Restore-SPFarm -Directory UNCPath -RestoreMethod Overwrite

    Dieser Befehl stellt die Farm mit der letzten verfügbaren Sicherung wieder her. Wenn Sie eine andere Sicherung verwenden möchten, müssen Sie angeben, welche Sicherung wiederhergestellt werden soll, indem Sie den -BackupID-Parameter mit der GUID der bestimmten Sicherung verwenden, die Sie verwenden möchten.

  3. Geben Sie bei der Windows PowerShell-Eingabeaufforderung den folgenden Befehl ein, wobei ServiceApplicationID die GUID der wiederhergestellten Farm ist:

    Start-SPServiceInstance -Identity ServiceApplicationID

    Tipp Tipp

    Wenn Sie die GUID nicht kennen, können Sie mit dem Get-SPServiceInstance-Befehl die Dienstinstanz-GUIDs für alle SharePoint-Anwendungen auf dem Server auflisten.

  4. Weitere Informationen zum Wiederherstellen einer Farm finden Sie unter Wiederherstellen einer Farm (SharePoint Foundation 2010) und Restore-SPFarm.

So stellen Sie die Farm mit der SharePoint-Zentraladministration wieder her

  1. Öffnen Sie die SharePoint-Zentraladministration, und wählen Sie auf der Startseite im Abschnitt "Sichern und wiederherstellen" die Option Wiederherstellung von Sicherung aus.

    Der Wiederherstellen-Assistent wird geöffnet.

  2. Wählen Sie auf der Seite Wiederherstellung von Sicherung - Schritt 1 von 3 den Farmsicherungsauftrag, den Sie wiederherstellen möchten, und wählen Sie anschließend Weiter aus.

  3. Aktivieren Sie auf der Seite Wiederherstellung von Sicherung - Schritt 2 von 3 das Kontrollkästchen, das sich neben der Farmoption befindet, und wählen Sie anschließend Weiter aus.

  4. Stellen Sie sicher, dass auf der Seite Wiederherstellung von Sicherung - Schritt 3 von 3 im Abschnitt Komponente wiederherstellen die Option Farm in der Liste Folgende Komponente wiederherstellen angezeigt wird. Wählen Sie im Abschnitt Nur Konfigurationseinstellungen wiederherstellen die Option Inhalt und Konfigurationseinstellungen wiederherstellen aus. Wählen Sie im Abschnitt Wiederherstellungsoptionen unter Wiederherstellungstyp die Option Gleiche Konfiguration aus. Wenn ein Dialogfeld angezeigt wird und Sie aufgefordert werden, die Auswahl zu bestätigen, wählen Sie OK aus, und klicken Sie dann auf Wiederherstellung starten.

  5. Überwachen Sie den allgemeinen Status der Wiederherstellung, wie sie im Abschnitt Bereitschaft der Seite Status von Sicherungs- und Wiederherstellungsaufträgen angezeigt wird. Der Status wird automatisch alle 30 Sekunden aktualisiert. Sie können den Status auch manuell aktualisieren, indem Sie Aktualisieren auswählen.

  6. Wenn die Wiederherstellung abgeschlossen ist, kehren Sie zur Startseite in der Zentraladministration zurück. Wählen Sie unter Anwendungsverwaltung die Option Dienste auf dem Server verwalten aus.

  7. Suchen Sie auf der Seite Dienste auf dem Server nach den Dienstanwendungen für die wiederhergestellte Farm. Wählen Sie zudem in der Spalte Aktionen die Option Start für alle diese Dienstanwendungen aus.

  8. Weitere Informationen zum Wiederherstellen einer Farm finden Sie unter Wiederherstellen einer Farm (SharePoint Foundation 2010).

Bereitmachen der Datenbanken für Team Foundation Server

Bevor die wiederhergestellten Datenbanken ordnungsgemäß funktionieren, müssen Sie den TFSConfig RemapDBs-Befehl verwenden, um die TFS-Konfigurationsdatenbank zur neuen Instanz von SQL Server erneut zuzuordnen. Außerdem müssen Sie mit dem TFSConfig Accounts ResetOwner-Befehl die Datenbankbesitzeranmeldung für die wiederhergestellten Datenbanken in den aktuellen Benutzer ändern. Abschließend müssen Sie den Befehl TFSConfig Accounts verwenden, um die Dienstkontoinformationen für die Datenbanken zu aktualisieren, selbst wenn Sie dieselben Dienstkonten weiterhin verwenden, die Sie auf dem vorherigen Server verwendet haben.

Verwenden Sie bei der Ausführung dieses Befehls nach Möglichkeit dasselbe Konto wie bei der Installation von Team Foundation Server auf dem ursprünglichen Server. Sie müssen mindestens ein Konto verwenden, das Member der Team Foundation Administrators-Gruppe in Team Foundation Server und Member der sysadmin-Gruppe in SQL Server auf dem ursprünglichen Server zum Zeitpunkt der Sicherung war, mit deren Hilfe Sie eine Wiederherstellung durchführen möchten.

Da Jill ihr eigenes Konto verwendet, wenn sie Team Foundation Server auf dem ursprünglichen Server und auf dem neuen Server installiert und konfiguriert, und ein Member der sysadmin- und Team Foundation Administrators-Gruppen bleibt, kann sie am eigenen Konto angemeldet bleiben, um diese Befehle auszuführen. Sie muss jedoch die Eingabeaufforderung als Administrator ausführen, um die Befehlszeilenprozeduren erfolgreich abschließen zu können.

So ordnen Sie die Datenbanken neu zu

  1. Öffnen Sie ein Eingabeaufforderungsfenster als Administrator, und ändern Sie die Verzeichnisse zu "Laufwerk:\%programfiles%\Microsoft Team Foundation Server 2012\Tools".

  2. Geben Sie den folgenden Befehl ein, wobei Datenbankname der Name der Konfigurationsdatenbank ist, einschließlich des Servers und des Namens der Instanz von SQL Server, die die Datenbank hostet, entweder im Format Servername oder im Format Servername\Instanzname, und es sich bei Instanzname um den Namen der SQL Server-Instanz handelt:

    TFSConfig RemapDBs /databaseName:Datenbankname /sqlInstances:Instanzname

    In der Beispielsbereitstellung hat Jill alle Datenbanken für Team Foundation Server auf dem gleichen Server wieder hergestellt, daher muss sie den Befehl nur einmal ausführen. Sie verwendete auch die Standardinstanz, wodurch sie keinen Instanznamen angeben muss. Sie muss lediglich den Servernamen angeben. Sie gibt TFSConfig RemapDBs /databaseName:FabrikamPrime;TFS_Configuration /sqlInstances:FabrikamPrime an der Befehlszeile ein.

So ändern Sie den Besitz der wiederhergestellten Datenbanken auf den aktuellen Benutzer

  • Geben Sie bei der Eingabeaufforderung den folgenden Befehl ein, wobei Servername der Name der Instanz von SQL Server ist, die eine Datenbank für Team Foundation Server hostet, und Datenbankname der Name der Konfigurationsdatenbank ist:

    TFSConfig Accounts /ResetOwner /SQLInstance:Servername /DatabaseName:Datenbankname

    In der Beispielsbereitstellung gibt Jill Folgendes an der Befehlszeile ein: TFSConfig Accounts /ResetOwner /SQLInstance:FABRIKAMPRIME /DatabaseName:TFS_Configuration

    Mit dieser Befehlszeile wird für alle von Team Foundation Server verwendeten Datenbanken der Besitz geändert.

So aktualisieren Sie Dienstkonten

  1. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, um das Dienstkonto für Team Foundation Server zu aktualisieren, wobei Datenbankname der Name der Konfigurationsdatenbank (standardmäßig TFS_Configuration) ist:

    TfsConfig Accounts /add /AccountType:ApplicationTier /account:Kontoname /SQLInstance:Servername /DatabaseName:Datenbankname

    In der Beispielsbereitstellung gibt Jill Folgendes an der Befehlszeile ein: TFSConfig Accounts /add /AccountType:ApplicationTier /account:"Network Service" /SQLInstance:FABRIKAMPRIME /DatabaseName:TFS_Configuration

  2. Geben Sie an der Eingabeaufforderung den folgenden Befehl zum Aktualisieren des Datenquellenkontos ein:

    TfsConfig Accounts /add /AccountType:ReportingDataSource /account:Kontoname /SQLInstance:Servername /DatabaseName:Datenbankname

    In der Beispielsbereitstellung gibt Jill Folgendes an der Befehlszeile ein: TFSConfig Accounts /add /AccountType:ReportingDataSource /account:SVCSPTRS /SQLInstance:FABRIKAMPRIME /DatabaseName:TFS_Configuration

    Weitere Informationen finden Sie unter Accounts-Befehl.

POS1 | Vorbereiten der neuen Hardware | Wiederherstellen von Datenbanken | Installieren und Konfigurieren von Team Foundation Server | Dienste und Benutzer erneut verbinden


Installieren und Konfigurieren von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Installieren und Konfigurieren von Team Foundation Server
Feedback senden

In diesem Thema, dem dritten Teil des Lernprogramms zum Wiederherstellen eines Einzelservers, lernen Sie, wie Team Foundation Server (TFS) mithilfe des Assistenten "Nur für Anwendungsebene" installiert wird. Darüber hinaus lernen Sie, wie Sie die Erweiterungen für SharePoint-Produkte auf dem neuen Server installieren. Außerdem erfahren Sie, wie SharePoint Foundation 2010 zu konfigurieren ist und wie Reporting und Analysis Services mit dem neuen Server arbeiten können.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber" und sorgt nach einem Hardwarefehler der ursprünglichen Bereitstellung für die Wiederherstellung, was in Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] beschrieben wird. Die Vertrautheit mit diesem Lernprogramm und der darin beschriebenen Architektur kann Ihnen bei der Durchführung der Schritte in diesem Lernprogramm helfen.

In diesem Thema

  1. Installieren von Team Foundation Server und den Erweiterungen für SharePoint-Produkte

  2. Konfigurieren von SharePoint Foundation 2010

  3. Konfigurieren von Berichterstellung und Analysis Services

Erforderliche Berechtigungen

Um diesen Vorgang auszuführen, müssen Sie Mitglied der folgenden Gruppen sein oder über folgende Berechtigungen verfügen:

  • Ein Member der Administratoren-Sicherheitsgruppe auf dem Server.

  • Ein Mitglied der Gruppe Team Foundation-Administratoren

  • Es muss entweder ein Mitglied der Sicherheitsgruppe SQL Server-Systemadministrator, oder die Berechtigung SQL Server-Berechtigungen zum Erstellen von Sicherungskopien und zum Erstellen von Wartungsplänen auf Zulassen festgelegt sein.

  • Ein Member der sysadmin-Sicherheitsgruppe für die Datenbanken für Team Foundation.

  • Ein Mitglied der Gruppe Farmadministratoren

Installieren von Team Foundation Server und den Erweiterungen für SharePoint-Produkte

Durch Wiederherstellung jener Datenbanken, die von TFS verwendet werden, haben Sie bereits die Datenebene der ursprünglichen Bereitstellung wiederhergestellt. Jetzt müssen Sie den Wiederherstellungsprozess abschließen, indem Sie die Anwendungsebene, die Anwendung und die Dienste installieren, aus denen Team Foundation Server besteht. Verwenden Sie hierzu den Assistenten "Nur für Anwendungsebene". Sie müssen auch die Erweiterungen installieren, die von TFS und SharePoint Foundation 2010 verwendet werden, indem Sie den Assistenten für die Erweiterungen für SharePoint-Produkte ausführen.

So installieren Sie die Anwendungsebene und die Erweiterungen

  1. Wählen Sie Start, Alle Programme, Microsoft Visual Studio Team Foundation Server und dann Team Foundation Server-Verwaltungskonsole aus.

    Die Konsole wird in einem neuen Fenster geöffnet.

    Tipp Tipp

    Obwohl Sie die Installation von Team Foundation Server in einem früheren Schritt dieses Lernprogramms nicht durchgeführt haben, wurde die Konsole als Teil der Tools installiert.

  2. Wählen Sie im Explorerbereich der Konsole die Option Anwendungsebene und im Bereich Anwendungsebene die Option Installierte Funktionen konfigurieren aus.

    Das Team Foundation Server-Konfigurationscenter wird geöffnet.

  3. Wählen Sie im Menü Konfigurationscenter die Option Nur für Anwendungsebene aus, und wählen Sie dann Assistent starten aus.

  4. Wählen Sie auf der Seite Willkommen die Option Weiter aus.

  5. Geben Sie auf der Seite Datenbanken unter SQL Server- Instanz den Namen des SQL-Servers an, auf dem Sie Ihre Datenbanken wiederhergestellt haben, und wählen Sie dann Verfügbare Datenbanken auflisten aus. Klicken Sie in der Liste Datenbanken auf die Konfigurationsdatenbank und dann auf Weiter.

    In der Beispielsbereitstellung gibt Jill FABRIKAMPRIME in der SQL Server-Instanz an und hebt TFS_Configuration hervor.

  6. Stellen Sie auf der Seite Anwendungsebeneneinstellungen sicher, dass sowohl das Dienstkonto mit dem Dienstkonto in der ursprünglichen Bereitstellung als auch die Authentifizierungsmethode mit der vorherigen Authentifizierungsmethode übereinstimmt. Führen Sie bei Bedarf Korrekturen aus, und wählen Sie dann Weiter aus.

    In der Beispielsbereitstellung stellt Jill sicher, dass NT AUTHORITY\NETWORK SERVICE im Dienstkonto angezeigt wird und dass die Authentifizierungsmethode auf den Standard NTLM festgelegt ist.

  7. Überprüfen Sie auf der Seite Überprüfen alle Einstellungen, und wählen Sie Weiter aus, wenn sie richtig sind. Wenn Sie eine der Einstellungen ändern müssen, wählen Sie Zurück aus.

  8. Der Assistent überprüft auf der Seite Bereitschaftsprüfungen, ob alle Komponenten bereit für die Installation sind. Wenn eine der Bereitschaftsprüfungen fehlschlägt oder Warnungen ausgegeben werden, prüfen Sie die Informationen, und nehmen Sie ggf. Anpassungen vor.

    Tipp Tipp

    Während bei einer fehlgeschlagenen Bereitschaftsprüfung die Installation der Software nicht möglich ist, bis das Problem behoben ist, weist eine Warnung Sie nicht darauf hin, dass die Installation nicht durchgeführt werden kann.

    Wenn Sie mit den Bereitschaftsprüfungen einverstanden sind, wählen Sie Konfigurieren aus.

  9. Überwachen Sie auf der Seite Konfigurationsstatus optional den Fortschritt der Installation. Wenn die Installation abgeschlossen ist, wählen Sie Weiter aus.

  10. Wählen Sie auf der Seite Erfolgreich die Option Schließen aus.

  11. Wählen Sie im Konfigurationscenter die Option Erweiterungen für SharePoint-Produkte konfigurieren aus.

  12. Wählen Sie auf der Seite Willkommen die Option Weiter aus.

  13. Überprüfen Sie auf der Seite Überprüfen alle Einstellungen, und wählen Sie dann Weiter aus.

  14. Der Assistent überprüft auf der Seite Bereitschaftsprüfungen, ob alle Komponenten bereit für die Installation sind. Wenn eine der Bereitschaftsprüfungen fehlschlägt oder Warnungen ausgegeben werden, prüfen Sie die Informationen, und nehmen Sie ggf. Anpassungen vor.

    Tipp Tipp

    Während bei einer fehlgeschlagenen Bereitschaftsprüfung die Installation der Software nicht möglich ist, bis das Problem behoben ist, weist eine Warnung Sie nicht darauf hin, dass die Installation nicht durchgeführt werden kann.

    Wenn Sie mit den Bereitschaftsprüfungen einverstanden sind, wählen Sie Konfigurieren aus.

  15. Überwachen Sie auf der Seite Konfigurationsstatus optional den Fortschritt der Installation. Wenn die Installation abgeschlossen ist, wählen Sie Weiter aus.

  16. Wählen Sie auf der Seite Erfolgreich die Option Schließen aus, und wählen Sie anschließend erneut Schließen aus, um das Konfigurationscenter zu schließen.

Konfigurieren von SharePoint-Produkten

Nachdem Sie die Anwendungsebene und die Erweiterungen installiert haben, müssen Sie die Einstellungen für die SharePoint-Webanwendungen, die die Bereitstellung verwendet, neu konfigurieren.

So konfigurieren die Einstellungen für SharePoint-Webanwendungen

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Klicken Sie in der Navigationsleiste auf SharePoint-Webanwendungen.

  3. Markieren Sie in der Liste SharePoint-Webanwendungen die Webanwendung, die von der ursprünglichen Bereitstellung verwendet wird, und wählen Sie dann Ändern aus.

    Tipp Tipp

    Standardgemäß sollte die Webanwendung automatisch in der Liste der Webanwendungen angezeigt werden. Wenn dies nicht der Fall ist, wählen Sie Hinzufügen aus, und fügen Sie sie dann manuell hinzu.

    In der Beispielsbereitstellung hebt Jill "http://fabrikamprime" hervor.

  4. Das Fenster SharePoint-Webanwendungseinstellungen wird geöffnet. Überprüfen Sie unter Webanwendungs-URL und URL der Zentraladministration die Einstellungen, und geben Sie bei Bedarf die Werte an, bzw. ändern Sie sie, um die URLs auf dem neuen Server zu reflektieren.

    In der Beispielsbereitstellung gibt Jill "http://fabrikamprime" in Anzeigename und Webanwendungs-URL an, und in URL der Zentraladministration gibt sie "http://fabrikamprime:17012" an. Dies sind die gleichen Einstellungen, die auf dem ursprünglichen Server verwendet werden.

  5. Wenn Sie mit den Einstellungen zufrieden sind, wählen Sie OK aus.

    Weitere Informationen zum Konfigurieren von SharePoint-Webanwendungen als Teil der Bereitstellung finden Sie unter Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung und Interactions Between SharePoint Products and Team Foundation Server.

Konfigurieren von Berichterstellung und Analysis Services

Nachdem Sie SharePoint Foundation 2010 konfiguriert haben, müssen Sie Team Foundation Server zum Speicherort des Berichtsservers umleiten, das Warehouse neu starten und die Datenbank für Analysis Services manuell neu erstellen.

Hinweis Hinweis

Sie müssen diesen Vorgang auch dann abschließen, wenn Sie die TFS_Warehouse-Datenbank und TFS_Analysis-Datenbank wiederhergestellt haben, wie im vorherigen Abschnitt beschrieben.

So konfigurieren Sie Reporting und Analysis Services

  1. Wählen Sie in der Navigationsleiste für die Verwaltungskonsole Berichterstellung aus.

  2. Wählen Sie auf der Seite Berichterstellung die Option Bearbeiten aus.

  3. Klicken Sie im Dialogfeld Offline schalten auf OK.

    Das Dialogfeld Berichterstellung wird geöffnet.

  4. Aktivieren Sie das Kontrollkästchen Berichterstellung verwenden.

  5. Geben Sie auf der Registerkarte Warehouse unter Server den Namen des Berichtsservers an, und geben Sie unter Datenbank den Namen der Warehouse-Datenbank an. Wählen Sie optional Verbindung testen aus, um sicherzustellen, dass die Datenbank gültig ist.

    In der Beispielsbereitstellung gibt Jill FABRIKAMPRIME als den Servernamen und TFS_Warehouse als Namen der Datenbank an.

  6. Geben Sie auf der Registerkarte Analysis Services in der Liste Server den Namen des Servers an, auf dem SQL Server Analysis Services ausgeführt wird. Geben Sie unter Datenbank den Namen der Analysis Services-Datenbank und unter Konto für den Zugriff auf Datenquellen den Benutzernamen und das Kennwort des Datenquellenkontos an.

    In der Beispielsbereitstellung gibt Jill FABRIKAMPRIME als den Servernamen und TFS_Analysis als Namen der Datenbank an. Sie stellt auch den von ihr erstellten Kontonamen bereit, um ihn als Datenquellen-Leserkonto (SVCSPTRS) und sein Kennwort zu verwenden.

  7. Geben Sie auf der Registerkarte Berichte in der Liste Server den Namen des Berichtsservers an, und wählen Sie dann URLs eingeben aus. Geben Sie unter Benutzername und Kennwort den Kontonamen und das Kennwort (falls vorhanden) für das Datenquellenkonto ein. Geben Sie unter Standardpfad den relativen Pfad zum Speicherort von Berichten an, und wählen Sie dann OK.

    In der Beispielsbereitstellung gibt Jill FABRIKAMPRIME als den Servernamen an. Sie stellt auch den von ihr erstellten Kontonamen bereit, um ihn als Datenquellen-Leserkonto (SVCSPTRS) und dessen Kennwort sowie /TFSReports als Standardpfad zu verwenden.

  8. Klicken Sie in der Verwaltungskonsole auf Aufträge starten, um die Berichterstellung neu zu starten.

  9. Öffnen Sie ein Eingabeaufforderungsfenster, und ändern Sie dann die Verzeichnisse in "%Programme%\Microsoft Team Foundation Server 2012\Tools".

  10. Geben Sie den folgenden Befehl ein, um die Datenbank für Analysis Services neu zu erstellen:

    TFSConfig RebuildWarehouse /AnalysisServices /ReportingDataSourcePassword:Kennwort

    Kennwort ist das Kennwort des Datenquellenkontos für Reporting Services.

    In der Beispielsbereitstellung Jill gibt Folgendes an der Befehlszeile ein: TFSConfig RebuildWarehouse /AnalysisServices /ReportingDataSourcePassword:Kennwort.

  11. Warten Sie, bis der Befehl erfolgreich ausgeführt wurde.

POS1 | Vorbereiten der neuen Hardware | Wiederherstellen von Datenbanken | Installieren und Konfigurieren von Team Foundation Server | Dienste und Benutzer erneut verbinden


Dienste und Benutzer erneut verbinden

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Dienste und Benutzer erneut verbinden
Feedback senden

In diesem Thema, dem vierten Teil des Lernprogramms zum Wiederherstellen eines Einzelservers, lernen Sie, wie die erstellten Benutzergruppen wieder dem neuen Server hinzugefügt werden. Sie lernen außerdem, wie die Datencaches auf dem neuen Server gelöscht werden und wie Sie sicherstellen, dass die Benutzer beim Zwischenspeichern von Daten nicht mit Problemen konfrontiert sind, wenn sie eine Verbindung mit dem neuen Server herstellen.

Die Beispiele in diesem Thema des Lernprogramms stammen von Jill Frank. Sie ist IT-Administrator bei dem fiktiven Unternehmen "Fabrikam Fiber" und sorgt nach einem Hardwarefehler der ursprünglichen Bereitstellung für die Wiederherstellung, was in Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] beschrieben wird. Die Vertrautheit mit diesem Lernprogramm kann Ihnen bei der Durchführung der Schritte in diesem Lernprogramm helfen.

In diesem Thema

  1. Überprüfen von Berechtigungen für Benutzer, Gruppen und Dienstkonten

  2. Aktualisieren des Caches für die Versionskontrolle auf Clientcomputern und erneutes Herstellen einer Verbindung mit Team Foundation Server

Erforderliche Berechtigungen

Um die Webmethode StampWorkitemCache aufzurufen, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Server sein.

Um den tf workspaces-Befehl auf dem Clientcomputer verwenden zu können, muss die Read-Berechtigung auf Allow festgelegt sein.

Überprüfen von Berechtigungen für Benutzer, Gruppen und Dienstkonten

Stellen Sie nach dem Wiederherstellen der Daten und Software auf dem neuen Server sicher, dass alle Benutzer, Gruppen und Dienstkonten für die Bereitstellung mit den Berechtigungen konfiguriert werden, die sie benötigen, um ordnungsgemäß Aufgaben auszuführen und zu funktionieren.

Sie können nicht alle Berechtigungen automatisch migrieren. Administratoren für Team Foundation müssen z. B. Mitglieder der lokalen Gruppe Administratoren auf dem Server sein, damit sie die Verwaltungskonsole öffnen können, und Sie müssen sie dieser Gruppe manuell hinzufügen. Wenn Sie das Lernprogramm zum Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm] absolviert haben, können Sie die Benutzergruppen verwenden, die Sie in Vorbereiten für die Installation erstellt haben, um diese Aufgabe zu vereinfachen.

So überprüfen Sie Berechtigungen

  • Melden Sie sich am Server an, und stellen Sie sicher, dass Benutzer, Gruppen und Dienstkonten mit den für den Betrieb erforderlichen Berechtigungen konfiguriert werden.

    In der Beispielbereitstellung fügt Jill beispielsweise auf der entsprechenden Berechtigungsstufe für Benutzer, die in vollem Umfang an dem Projekt mitarbeiten werden, die Gruppe "TFS_ProjectContributors" - die in den Anzeigenamen "Fabrikam Developers and Testers" aufgelöst wird - in Team Foundation Server, SQL Server Reporting Services und SharePoint Foundation 2010 hinzu. Beispiele dafür finden Sie unter Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams.

    Weitere Informationen finden Sie unter Hinzufügen von Benutzern zu Teamprojekten, Festlegen von Administratorberechtigungen für Teamprojektsammlungen, Festlegen von Administratorberechtigungen für Team Foundation Server und Dienstkonten und Abhängigkeiten in Team Foundation Server.

Aktualisieren des Arbeitsaufgabencaches

Hinweis Hinweis

Diese Prozedur ist optional. Sie sollten sie nur ausführen, wenn Fehler bei der Nachverfolgung von Arbeitsaufgaben auftreten.

Um den Cache für die Verfolgung von Arbeitsaufgaben zu aktualisieren, rufen Sie die StampWorkitemCache-Webmethode auf. Durch diese Methode wird erzwungen, dass Clientcomputer den Cache aktualisieren, wenn das nächste Mal eine Verbindung zum Anwendungsebenenserver hergestellt wird. Darüber hinaus werden durch diese Methode die auf den Clientcomputern definierten Arbeitsbereiche synchronisiert.

So aktualisieren Sie den Cache für die Verfolgung von Arbeitsaufgaben auf Clientcomputern

  1. Öffnen Sie Internet Explorer auf dem neuen Server.

  2. Geben Sie in der Adressleiste die folgende Adresse ein, um eine Verbindung mit dem ClientService-Webdienst herzustellen.

    http://ÖffentlicheURL/VirtuellesVerzeichnis:8080/WorkItemTracking/v3.0/ClientService.asmx

    Hinweis Hinweis

    Auch wenn Sie mit Administratorrechten angemeldet sind, müssen Sie möglicherweise Internet Explorer als Administrator starten, und Sie werden unter Umständen zur Eingabe Ihrer Anmeldeinformationen aufgefordert.

  3. Wählen Sie StampWorkitemCache und anschließend Aufrufen aus.

    Hinweis Hinweis

    Die StampWorkitemCache-Methode gibt keine Daten zurück.

Aktualisieren des Caches für die Versionskontrolle auf Clientcomputern und erneutes Herstellen einer Verbindung mit Team Foundation Server

Um während der Versionskontrolle oder bei Buildvorgängen in Team Foundation Fehler im Arbeitsbereich zu verhindern, müssen Sie den Datencache auf Clientcomputern aktualisieren.

Um den Cache für die Versionskontrolle zu aktualisieren, muss der Benutzer den Befehl tf workspaces auf jedem Computer ausführen, auf dem die Versionskontrolle verwendet wird und der mit dem wiederhergestellten Server verbunden ist.

So aktualisieren Sie den Cache für die Versionskontrolle auf Clientcomputern

  1. Öffnen Sie auf dem Clientcomputer ein Eingabeaufforderungsfenster mit Administratorberechtigungen, und ändern Sie die Verzeichnisse in " Laufwerk:\Programme (x86)\Microsoft Visual Studio 11.0\Common7\IDE".

  2. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, darunter auch die URL der Auflistung, die den Servernamen und die Portnummer des neuen Servers enthält:

    tf workspaces /collection:http://ServerName:Port/NameVirtuellesVerzeichnis/Sammlungsname

    In der Beispielsbereitstellung muss einer von Jills Entwicklern den Cache für die Versionskontrolle für ein Projekt aktualisieren, das ein Mitglied der Auflistung "DefaultCollection" ist, das in der FabrikamPrime-Bereitstellung von Team Foundation Server gehostet wird. Er gibt die folgende Zeichenfolge ein:

    tf workspaces /collection:http://FabrikamPrime:8080/tfs/DefaultCollection

    Weitere Informationen finden Sie unter Workspaces Command.

POS1 | Vorbereiten der neuen Hardware | Wiederherstellen von Datenbanken | Installieren und Konfigurieren von Team Foundation Server | Dienste und Benutzer erneut verbinden


Grundlagen zu Verwaltungskonzepten und -tools

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Grundlagen zu Verwaltungskonzepten und -tools
Siehe auch Feedback senden

Sie können Visual Studio Team Foundation Server (TFS) besser verwalten, wenn Sie die Architektur, die der Struktur zugrunde liegenden Konzepte und die im System enthaltenen Tools zum Verwalten der Bereitstellung verstehen. Für die Bereitstellung und Verwaltung von TFS müssen Sie verstehen, wie die Anwendung funktioniert und mit anderen Komponenten von Team Foundation kommuniziert. Als Administrator für TFS sollten Sie sich mit den Windows-Sicherheitseinschränkungen, der Benutzerkontensteuerung sowie SQL Server-Datenbanken und -Sicherheit vertraut machen. Wenn die Bereitstellung in SharePoint-Produkte integriert ist, müssen Sie sich zudem mit der Verwaltung von Siteauflistungen und Webanwendungen auseinandersetzen.

Durch die Auswahl einer geeigneten Bereitstellungstopologie für die Anforderungen Ihres Unternehmens tragen Sie dazu bei, die langfristige Verwaltbarkeit und Nachhaltigkeit der von Ihnen unterstützten Softwareprojekte aufrechtzuerhalten. Anhand der Beispieltopologien von TFS können Sie ermitteln, welche Art von Topologie für Ihre Anforderungen am besten geeignet ist.

TFS enthält eine Verwaltungskonsole, die Sie bei zahlreichen Verwaltungsaufgaben im Zusammenhang mit der Verwaltung und Wartung der Bereitstellung von TFS unterstützt. Mithilfe der Konsole können Sie Benutzer, Auflistungen von Softwareprojekten sowie Buildumgebungen und virtuelle Lab-Umgebungen organisieren und verwalten. Zudem können Sie den Status der Bereitstellung überprüfen und Protokolle zur Serveraktivität anzeigen.

Allgemeine Aufgaben

Allgemeine Aufgaben | Unterstützender Inhalt
Informationen zu den Konzepten und zur Architektur von Team Foundation Server: Planung und Verwaltung von TFS sind einfacher, wenn Sie mit der Architektur, den Anforderungen für die Bereitstellung in einer Domäne oder Arbeitsgruppe, den grundlegenden Konzepten und der in dieser Dokumentation verwendeten Terminologie vertraut sind. | Team Foundation Server-Konzepte Architektur von Team Foundation Server Die Team Foundation-Verwaltungskonsole Benennungseinschränkungen in Team Foundation Verwenden von Team Foundation Server-Befehlszeilentools Organisieren des Servers mit Teamprojektsammlungen Interactions Between SharePoint Products and Team Foundation Server SQL Server und SQL Server Reporting Services
Auswählen einer Bereitstellungstopologie: Sie können Team Foundation Server auf unterschiedliche Weise installieren und konfigurieren. Zudem kann die Bereitstellung erweitert oder reduziert werden, wie sich Ihre Anforderungen ändern. Ermitteln Sie anhand der Beispieltopologien, welche Konfiguration für Ihre Entwicklungsanforderungen am besten geeignet ist. | Beispiele für die einfache Topologie Beispiele für Topologie mit mittlerer Komplexität Beispiele für die komplexe Topologie Beispiele für gehostete Topologie Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]
Sicherstellen der Integrität der Bereitstellung: Sie können die Datenbanken sichern, die die Daten für die Bereitstellung von Team Foundation Server enthalten. | Sichern und Wiederherstellen der Bereitstellung

Siehe auch

Konzepte

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
Organisieren des Servers mit Teamprojektsammlungen
Konfigurieren von Benutzern, Gruppen und Berechtigungen

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten
Verwalten von Berechtigungen


Team Foundation Server-Konzepte

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Team Foundation Server-Konzepte
Siehe auch Feedback senden

Für eine effektive Bereitstellung und Verwaltung von Visual Studio Team Foundation Server müssen Sie verstehen, wie die Anwendung funktioniert und mit anderen Komponenten von Team Foundation kommuniziert. Als Administrator für Team Foundation Server müssen Sie mit der Authentifizierung, den Netzwerkprotokollen und dem Netzwerkverkehr in Windows sowie mit der Struktur des Geschäftsnetzwerks vertraut sein, in dem Team Foundation Server installiert ist. Sie sollten außerdem mit Gruppen und Berechtigungen in Team Foundation Server vertraut sein. Darüber hinaus können Kenntnisse über SQL Server, SQL Server Reporting Services und SharePoint-Produkte bei der Verwaltung von Team Foundation Server nützlich sein.

Grundlegendes zu Komponenten und Begriffen

Sie können Team Foundation Server einfacher planen, bereitstellen und verwalten, wenn Sie die folgenden Komponenten und Begriffe verstehen:

  • Anwendungsebene, Datenebene, Clientebene: Die logischen Ebenen, aus denen Team Foundation Server besteht. Diese Ebenen können alle auf demselben physischen Computer bereitgestellt werden, oder sie können auf mehreren Computern installiert werden. Weitere Informationen finden Sie unter Beispiele für die einfache Topologie, Beispiele für Topologie mit mittlerer Komplexität, Beispiele für die komplexe Topologie und unter Architektur von Team Foundation Server.

  • Teamprojektsammlung: Die primäre Organisationseinheit für alle Daten in Team Foundation Server. Sammlungen können ein oder mehrere Teamprojekte umfassen. Weitere Informationen finden Sie unter Organisieren des Servers mit Teamprojektsammlungen.

  • Teamprojekt: Ein zentraler Punkt für kooperative Aktivitäten Ihres Teams, mit denen bestimmte Softwaretechnologien oder Produkte entwickelt werden. Teamprojekte werden in Teamprojektsammlungen organisiert. Weitere Informationen finden Sie unter Planen und Nachverfolgen von Projekten.

  • Team Foundation-Verwaltungskonsole: Das zentrale Verwaltungstool für Administratoren in Team Foundation Server. In der Verwaltungskonsole können Sie abgesehen von der Erstellung und Verwaltung von Teamprojektsammlungen, dem Hinzufügen und Verwalten von SharePoint-Webanwendungen zur Verwendung in der Bereitstellung hinzufügen und verwalten, dem Erstellen von virtuellen Labors und der Überprüfung des Serverstatus auch Benutzer und Berechtigungen verwalten. Weitere Informationen finden Sie unter Die Team Foundation-Verwaltungskonsole.

  • Dienstkonten: Das Konto bzw. die Konten, die von Webdiensten und Anwendungen in Team Foundation verwendet werden. Team Foundation Server erfordert Dienstkonten, um Vorgänge über Server und Webdienste hinweg ausführen zu können. Diese Dienstkonten weisen bestimmte Anforderungen auf. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server.

  • SharePoint-Produkte: Software, die eine skalierbare, verwaltbare Plattform für die Zusammenarbeit und die Entwicklung webbasierter Geschäftsanwendungen bereitstellt. Sie können eine oder mehrere SharePoint-Webanwendungen als Teil der Bereitstellung von Team Foundation Server einschließen. Um eine dieser Anwendungen einzuschließen, müssen Sie Team Foundation Server-Erweiterungen für SharePoint-Produkte installieren und konfigurieren, und Sie müssen Berechtigungen in der gesamten Bereitstellung konfigurieren. Weitere Informationen finden Sie unter Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung und unter SharePoint Products and Technologies and Team Foundation Server.

  • SQL Server und SQL Server Reporting Services: Software, die eine Datenbankplattform für große Anwendungen für die Onlinetransaktionsverarbeitung (OLTP), Data Warehousing und E-Commerce bereitstellt. SQL Server ist auch eine Business Intelligence-Plattform für Datenintegration, Analyse und Berichtslösungen. Die Daten von Team Foundation Server werden in SQL Server-Datenbanken gespeichert. Sie können optional auch einen Server einschließen, auf dem SQL Server Reporting Services ausgeführt wird und der automatisch Berichte für Teamprojekte generiert. Weitere Informationen finden Sie unter Architektur von Team Foundation Server und unter Team Foundation Server-Datenbanken.

Grundlagen der Team Foundation Server-Sicherheit

Um die Sicherheit von Team Foundation Server zu optimieren, müssen Sie die folgenden Konzepte verstehen:

  • Die Topologie, die den Ort und die Art der Bereitstellung der Server umfasst, auf denen Komponenten von Team Foundation ausgeführt werden, der Netzwerkverkehr zwischen Team Foundation Server und den Team Foundation-Clients sowie die Dienste, die auf Team Foundation Server ausgeführt werden müssen.

  • Die Authentifizierung, zu der die Überprüfung der Gültigkeit von Benutzern, Gruppen und Diensten in Team Foundation Server gehört.

  • Die Autorisierung, die die Überprüfung beinhaltet, ob gültige Benutzer, Gruppen und Dienste in Team Foundation Server über die entsprechenden Berechtigungen zur Ausführung von bestimmten Aktionen verfügen.

Auch die anderen Komponenten und die Dienste, von denen Team Foundation Server abhängig ist, sollten nicht vernachlässigt werden.

Im Rahmen der Team Foundation Server-Sicherheit müssen Sie den Unterschied zwischen Authentifizierung und Autorisierung kennen. Authentifizierung bezeichnet die Überprüfung der Anmeldeinformationen bei einem Verbindungsversuch durch einen Client, Server oder Prozess. Bei der Autorisierung wird überprüft, ob der Benutzer, der eine Verbindung herstellt, über Berechtigungen für den Zugriff auf das Objekt oder die Methode verfügt. Die Autorisierung erfolgt erst nach erfolgreicher Authentifizierung. Wenn eine Verbindung nicht authentifiziert werden kann, schlägt der Verbindungsversuch bereits vor der Autorisierung fehl. Nach erfolgreicher Authentifizierung kann eine bestimmte Aktion trotzdem unzulässig sein, weil der Benutzer oder die Gruppe nicht zum Durchführen der Aktion autorisiert ist.

Topologien, Anschlüsse und Dienste

Das erste Element bei der Bereitstellung und Sicherheit von Team Foundation Server ist die Kommunikation zwischen den einzelnen Komponenten der Bereitstellung. Verbindungen zwischen Team Foundation-Clients und Team Foundation Server müssen ermöglicht werden, andere Verbindungen sollten jedoch eingeschränkt oder verhindert werden.

Team Foundation Server ist abhängig von bestimmten Anschlüssen und Diensten. Diese Anschlüsse können zur Einhaltung der Sicherheitsanforderungen des Unternehmens gesichert und überwacht werden. Sie müssen Team Foundation Server-Netzwerkverkehr zwischen Team Foundation-Clients, den Servern mit den logischen Komponenten der Team Foundation-Anwendungs- und -Datenebene, Team Foundation Build-Computern und Remoteclients zulassen, die Team Foundation Server Proxy verwenden. In der Standardeinstellung ist Team Foundation Server so konfiguriert, dass HTTP für die Webdienste verwendet wird. Eine vollständige Liste der Anschlüsse und Dienste, die Team Foundation Server verwendet, sowie Informationen zu deren Verwendung innerhalb der Architektur finden Sie unter Architektur von Team Foundation Server.

Sie können Team Foundation Server in einer Active Directory-Domäne oder einer Arbeitsgruppe bereitstellen. Active Directory stellt mehr integrierte Sicherheitsfunktionen bereit als Arbeitsgruppen. Sie können Active Directory-Funktionen verwenden, um die Bereitstellung von Team Foundation Server zu sichern. Beispielsweise können Sie Active Directory so konfigurieren, dass keine doppelten Computernamen zulässig sind. Dadurch können Angreifer den Computernamen nicht mehr mit einem nicht autorisierten Server, auf dem Team Foundation Server ausgeführt wird, vortäuschen. Um die gleiche Art von Bedrohung in einer Arbeitsgruppe zu verhindern, müssen Sie Computerzertifikate konfigurieren.

Unabhängig davon, ob Sie Team Foundation Server in einer Arbeitsgruppe oder einer Domäne bereitstellen, müssen Sie bestimmte Einschränkungen einhalten, die durch die Anforderungen von Team Foundation Server selbst entstehen. Weitere Informationen zu Topologien für Team Foundation Server finden Sie unter Beispiele für die einfache Topologie, Beispiele für Topologie mit mittlerer Komplexität, Beispiele für die komplexe Topologie, Understanding Windows SharePoint Services und unter SQL Server und SQL Server Reporting Services.

Authentifizierung

Die Team Foundation Server-Sicherheit ist in die Windows-Authentifizierung integriert und davon sowie von den Sicherheitsfunktionen des Windows-Betriebssystems abhängig. Sie können die integrierte Windows-Authentifizierung für Folgendes verwenden: Authentifizierung von Konten für Verbindungen zwischen Team Foundation- und Team Foundation Server-Clients, für Webdienste auf den Servern, die die logische Anwendung und Datenebenen für Team Foundation hosten und für Verbindungen zwischen Servern der Anwendungs- und Datenebenen selbst.

Hinweis Hinweis

Sie können Team Foundation Server so konfigurieren, dass nach der Installation von Team Foundation Server Kerberos für die gegenseitige Authentifizierung von Client und Server verwendet wird.

Konfigurieren Sie keine SQL Server-Datenbankverbindungen zwischen Team Foundation Server und SharePoint-Produkte für die Verwendung der SQL Server-Authentifizierung, da diese nicht so sicher wie die Windows-Authentifizierung ist. Bei der Verbindung mit der Datenbank werden Benutzername und Kennwort für das Administratorkonto der Datenbank unverschlüsselt übertragen. Bei der integrierten Windows-Authentifizierung werden Benutzername und Kennwort nicht gesendet. Stattdessen werden Dienstkonto-Identitätsinformationen, die mit dem Host-IIS-Anwendungspool verknüpft sind, über Sicherheitsprotokolle der integrierten Windows-Authentifizierung an SQL Server übertragen.

Autorisierung

Die Team Foundation Server-Autorisierung basiert auf Benutzern und Gruppen in Team Foundation sowie den Berechtigungen, die diesen Benutzern und Gruppen direkt zugewiesen sind, und den Berechtigungen, die diese Benutzer und Gruppen aufgrund ihrer Mitgliedschaft in anderen Team Foundation Server-Gruppen möglicherweise erben. Benutzer und Gruppen in Team Foundation können lokale Benutzer oder Gruppen, Active Directory-Benutzer und -Gruppen oder beides sein.

Team Foundation Server ist auf Server-, Auflistungs- und Projektebene mit Standardgruppen vorkonfiguriert. Sie können diesen Gruppen einzelne Benutzer hinzufügen. Sie sollten diese Gruppen jedoch mithilfe von Active Directory-Sicherheitsgruppen auffüllen, da diese einfacher verwaltet werden können. Mit diesem Ansatz können Sie die Gruppenmitgliedschaft und Berechtigungen über mehrere Computer oder Anwendungen hinweg, z. B. SharePoint-Produkte und SQL Server, effizienter verwalten.

Möglicherweise müssen Sie in Ihrer Bereitstellung Benutzer, Gruppen und Berechtigungen auf mehreren Computern und in verschiedenen Anwendungen konfigurieren. Wenn Ihre Bereitstellung z. B Berichte und Projektportale enthalten soll, müssen Sie Berechtigungen für Benutzer und Gruppen in Reporting Services, SharePoint-Produkte und in Team Foundation Server konfigurieren. In Team Foundation Server können Sie Berechtigungen für jedes Projekt, für jede Auflistung und in einer Bereitstellung (auf Serverebene) festlegen. Darüber hinaus werden bestimmte Berechtigungen standardmäßig allen zu Team Foundation Server hinzugefügten Benutzern oder Gruppen gewährt, da dieser Benutzer oder diese Gruppe automatisch zur Gruppe Gültige Team Foundation-Benutzer hinzugefügt wird. Weitere Informationen zum Festlegen von Berechtigungen finden Sie unter Verwalten von Berechtigungen. Weitere Informationen zum Verwalten von Benutzern und Gruppen in Team Foundation Server finden Sie unter Konfigurieren von Benutzern, Gruppen und Berechtigungen.

Zusätzlich zum Konfigurieren von Berechtigungen für die Autorisierung in Team Foundation Server müssen Sie u. U. auch eine Autorisierung für die Versionskontrolle und für Arbeitsaufgaben konfigurieren. Diese Berechtigungen werden separat in einer Befehlszeile verwaltet, sind jedoch in die Team Explorer-Schnittstelle integriert.

Siehe auch

Konzepte

Architektur von Team Foundation Server
Konfigurieren von Benutzern, Gruppen und Berechtigungen

Weitere Ressourcen

Verwalten von Berechtigungen


Architektur von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Architektur von Team Foundation Server
Siehe auch Feedback senden

Zur optimalen Planung und Verwaltung der Bereitstellung sollten Sie sich zunächst mit der zugrunde liegenden Architektur von Team Foundation Server (TFS) vertraut machen. Mit dem Verständnis in Bezug auf die Architektur können Sie die allgemeine Integrität der Bereitstellung beibehalten und die gesamte Verfügbarkeit der Server und Dienste sicherstellen, die für das Entwicklungsteam unerlässlich sind.

Sie können TFS auf verschiedene Arten bereitstellen: auf einem Server, auf verschiedenen Servern oder in einer Domäne oder Arbeitsgruppe oder in mehreren Domänen. Alternativ können Sie die Team Foundation-Dienst-Vorschau verwenden, in der alle Serverelemente der Bereitstellung für Sie von Microsoft gehostet werden. Durch das Verständnis der Architektur können Sie besser entscheiden, welche Topologie am ehesten zu Ihren Geschäftsanforderungen passt. Wenn Sie mit der TFS zugrundeliegenden Architektur vertraut sind, können Sie, unabhängig von der Auswahl der Topologie, die physischen und logischen Anforderungen besser verwalten. Dieses Thema enthält eine einfache Übersicht über die verschiedenen Architekturen mit Links zu weiteren Informationen über Beispielsbereitstellungen. Außerdem bietet es technische Informationen über die Dienste, die Datenbanken, die Konfigurationsinformationen und die Netzwerkports und die Protokolle der lokalen Bereitstellungen.

Um die Architektur von TFS zu verstehen und inwieweit sie sich auf die Bereitstellung auswirkt, sollten Sie Folgendes beachten:

  • Die logischen Anwendungs-, Daten- und Clientebenen von Team Foundation und ob Sie einen oder mehrere Server für die Anwendungs- und Datenebenen verwenden möchten oder ob die Anwendungs- und Datenebenen in der Cloud mithilfe der Team Foundation-Dienstvorschau gehostet werden sollen

  • Die Position der physischen oder virtuellen Server, die diese Ebenen hosten

  • Team Foundation Build sowie Anzahl und Standort von Buildcomputern in der Umgebung, einschließlich der Anzahl von Buildcomputern, die Sie zur Unterstützung Ihrer Entwicklungsverfahren benötigen

  • Die potenzielle Anforderung für Team Foundation Server-Proxy

Darüber hinaus müssen Sie die Interaktionen zwischen diesen Entitäten berücksichtigen. Wenn Sie sich beispielsweise für die Verwendung des gehosteten TFS-Diensts entscheiden, müssen Sie sicherstellen, dass die Clients über den Port 443 auf den Dienst zugreifen können. Wenn Sie sich für die lokale Bereitstellung von TFS entscheiden, müssen Sie wissen, welche Webdienste, Datenbanken und Objektmodelle von TFS verwendet werden. Außerdem müssen Sie wissen, welche Netzwerkports und -protokolle standardmäßig von TFS verwendet werden und welche Netzwerkports angepasst werden können. Schließlich müssen Sie mit den Berechtigungen vertraut sein, die Sie in Team Foundation Server und den Komponenten und Programmen festlegen müssen, von denen die Bereitstellung abhängt.

Die ordnungsgemäße Funktion von Team Foundation Server ist nicht nur von den eigenen Diensten, sondern auch von anderen Diensten abhängig. Weitere Informationen zu diesen Diensten finden Sie unter Team Foundation Server-Konzepte und Komponenten des Data Warehouse für Team Foundation. Weitere Informationen zu den Anforderungen und Abhängigkeiten für die Installation finden Sie unter Installieren von Team Foundation Server und Visual Studio ALM.

In diesem Thema

  • Team Foundation-Dienstvorschau

  • Das Objektmodell

  • Webdienste und Datenbanken für lokale Bereitstellungen

    • Dienste auf Auflistungsebene

    • Dienste auf Serverebene

    • Datenebene

    • Clientebene

  • Konfigurationsinformationen

  • Gruppen und Berechtigungen

  • Netzwerkanschlüsse und Protokolle

    • Standardnetzwerkeinstellungen

    • Anpassbare Netzwerkeinstellungen

Team Foundation-Dienstvorschau

Einfaches Diagramm eines gehosteten TFS-Dienstes.

Microsoft bietet die Möglichkeit der Verwendung der Team Foundation-Dienst-Vorschau an, in der alle serverseitigen Aspekte der Bereitstellung für Sie gehostet werden. Der Quellcode, die Arbeitsaufgaben, die Buildkonfigurationen und die Teamfunktionen werden in der Cloud gehostet. Aus der Architekturperspektive wird dadurch die Bereitstellung erheblich vereinfacht, da die einzigen Aspekte der Architektur, die Sie berücksichtigen müssen, die Clientkomponenten und deren Internetzugriff sind.

Wenn Sie den Dienst in Anspruch nehmen, verwenden Sie einen Webbrowser, um mit dem Microsoft-Konto eine Verbindung mit dem Dienst herzustellen. Sie können Teamprojekte erstellen, dem Team Mitglieder hinzuzufügen und so arbeiten wie bei einer lokal installierten Bereitstellung, aber ohne den Mehraufwand für die Verwaltung der Server. Die Anwendungsebene, die Datenebene und die Buildserver werden mithilfe der Microsoft Cloud-Plattform und SQL Server Azure für Sie in der Cloud gehostet.

Weitere Informationen finden Sie unter Beispiele für gehostete Topologie.

Das Objektmodell

Mit der gehosteten oder der lokal bereitgestellten Architektur können Sie die Funktionen und die Funktionalität von Team Foundation erweitern, indem Sie eine Anwendung schreiben, die auf dem entsprechenden Server oder Clientobjektmodell basiert. Sie können in allen Bereitstellungstypen Anwendungen schreiben, die Clientfunktionen erweitern. Wenn Sie jedoch die Serverfunktionen erweitern möchten, muss die Anwendung auf dem Anwendungsebenenserver ausgeführt werden. Um die Clientfunktionen zu erweitern, müssen Sie die Anwendung auf demselben Computer wie Team Explorer ausführen.

Objektmodelle für Team Foundation

Weitere Informationen finden Sie unter Erweitern von Team Foundation Server.

Webdienste und Datenbanken für lokale Bereitstellungen

Team Foundation Server beinhaltet einen Satz von Webdiensten und Datenbanken, die Sie separat auf den Servern installieren und konfigurieren, die die logischen Anwendungs-, Daten- und Clientebenen für Team Foundation hosten. Einige Funktionen, beispielsweise das Taskboard und teambasierte Funktionen für den Rückstand, sind vollständig webbasiert und können nur über den clientseitigen webbasierten Dienst Team Web Access erreicht werden. Andere Themen, wie die Versionskontrollenfunktionen, sind über Team Web Access oder durch eine Clientanwendung erreichbar. Die folgenden Abbildungen bieten eine allgemeine Übersicht über Webdienste, Anwendungen und Datenbanken für lokale Bereitstellungen von TFS.

Diagramm der Serverarchitektur In TFS zusätzlich verwendete Server Diagramm der Clientarchitektur

Dienste auf Auflistungsebene

Dienste auf Auflistungsebene stellen die Funktionalität für Vorgänge auf Ebene der Teamprojektsammlung bereit. Sie können Anwendungen erstellen, durch die Team Foundation Server mithilfe einiger dieser Dienste erweitert wird. Weitere Informationen zum Erstellen von Anwendungen für TFS finden Sie unter Erweitern von Team Foundation Server.

Tipp Tipp

Einige Dienste werden in mehr als einer Ebene angezeigt. Der Registrierungsdienst funktioniert beispielsweise sowohl auf der Auflistungsebene als auch auf der Serverebene und wird in beiden Listen angezeigt.

  • Team Foundation Framework-Dienste

    • Registrierungsdienst

    • Registrierungsdienst (um die Kompatibilität mit früheren Versionen von Team Foundation Server zu gewährleisten)

    • Eigenschaftendienst

    • Ereignisdienst

    • Sicherheitsdienst

    • Ortsdienst

    • Identitätsverwaltungsdienst

  • Webdienst zur Versionskontrolle

  • Webdienst zur Arbeitsaufgabenverfolgung

  • Team Foundation Build-Webdienst

  • Lab Management-Webdienst

  • VMM-Verwaltungs-Webdienst

  • Test-Agent-Controller-Webdienst

Dienste auf Serverebene

Dienste auf Serverebene (auch als Dienste auf Anwendungsebene bezeichnet) stellen die Funktionen für Vorgänge für Team Foundation Server als Softwareanwendung bereit. Sie können Anwendungen erstellen, durch die Team Foundation Server mithilfe einiger dieser Dienste erweitert wird. Weitere Informationen finden Sie unter Erweitern von Team Foundation Server.

  • Team Foundation Framework-Dienste

    • Registrierungsdienst

    • Ereignisdienst

    • Teamprojekt-Auflistungsdienst

    • Eigenschaftendienst

    • Sicherheitsdienst

    • Ortsdienst

    • Identitätsverwaltungsdienst

    • Verwaltungsdienst

    • Auflistungsverwaltungsdienst

    • Katalogdienst

Datenebene

Die Datenebene enthält Daten, gespeicherte Prozeduren und weitere zugeordnete Logiken. Wenn Sie die Team Foundation-Dienstvorschau verwenden, wird die Datenebene mithilfe von SQL Server Azure für Sie gehostet. In einer lokalen Bereitstellung von TFS besteht die logische Datenebene aus den folgenden betriebsinternen Speichern innerhalb von SQL Server. Diese Speicher können sich auf einem physischen Server befinden oder über mehrere Server verteilt sein. Sie können Anwendungen erstellen, durch die Team Foundation Server mithilfe einiger dieser betriebsinternen Speicher erweitert wird. Weitere Informationen finden Sie unter Erweitern von Team Foundation Server.

  • Konfigurationsdatenbank (TFS_Configuration)

  • Anwendungs-Warehouse (TFS_Warehouse)

  • Analysis Services-Datenbank (TFS_Analysis)

  • Datenbanken für Teamprojektsammlungen (TFS_SammlungsName)

Die folgende Tabelle enthält eine Liste der Datenbanken (mit Angabe des Speicherorts), die von Team Foundation Server in lokalen Bereitstellungen verwendet werden. Wenn nichts anderes angegeben ist, können Sie alle Datenbanken in dieser Liste von dem ursprünglichen Server und der Instanz, auf dem diese installiert und konfiguriert sind, auf andere Server oder Instanzen verschieben und dort wiederherstellen.

Datenbankname und -beschreibung | Server
TFS_Configuration. In dieser Datenbank werden der Ressourcenkatalog und die Konfigurationsinformationen für Team Foundation Server gespeichert. Die Datenbank enthält die betriebsinternen Speicher für Team Foundation Server. | Eine Instanz von SQL Server, die bei einer Installation und Konfiguration von Team Foundation Server verwendet wird.
TFS_Warehouse In dieser Datenbank werden die Daten für Berichte gespeichert. | Eine Instanz von SQL Server, die bei einer Installation und Konfiguration von Team Foundation Server verwendet wird.
TFS_Analysis. In dieser mehrdimensionalen Datenbank werden die aggregierten Daten aus Teamprojektsammlungen gespeichert. | Eine Instanz von SQL Server, die bei einer Installation und Konfiguration von Team Foundation Server verwendet wird.
Datenbanken für Teamprojektsammlungen Jede Teamprojektsammlung verfügt über eine eigene Datenbank, in der Daten aus allen Teamprojekten in der Auflistung gespeichert sind. | Instanz von SQL Server, die mit Team Foundation Server kompatibel ist

Clientebene

Die Clientebene kommuniziert mit der Anwendungsebene über das Serverobjektmodell und verwendet die gleichen Webdienste, die in der Anwendungsebene aufgeführt sind. Dies gilt unabhängig davon, ob Sie TFS lokal bereitstellen oder die Team Foundation-Dienstvorschau verwenden. Neben diesem Modell besteht die Clientebene aus VSIP-Komponenten (Visual Studio Industry Partners), Microsoft Office-Integration, Befehlszeilenschnittstellen und einem Framework für Eincheckrichtlinien.

Konfigurationsinformationen

Der gehostete Dienst ist von den lokal bereitgestellten Clientdiensten abhängig und von einer Internetverbindung mit den Anwendungs- und Datenebenen, die in der Cloud gehostet werden. Die lokale Bereitstellung von Team Foundation Server ist abhängig von SQL Server, Internetinformationsdiensten (IIS) und dem Betriebssystem Windows. Je nach Ihrer ausgewählten Topologie kann Team Foundation Server zudem von SQL Server Reporting Services oder SharePoint-Produkte abhängen. Daher können Konfigurationsinformationen für Team Foundation Server in jedem der folgenden Speicherorte gespeichert werden:

  • IIS-Datenspeicher.

  • Konfigurationsdateien für Team Foundation Server-

  • Datenquellen für Reporting Services (z. B. TFSREPORTS-Daten).

  • Konfigurationsdatenbank für Team Foundation Server. Die Team Foundation Server-Registrierung ist Bestandteil der Konfigurationsdatenbank.

  • Windows-Registrierung.

Beispiele für verschiedene lokale Bereitstellungstopologien und die Speicherorte dieser Ressourcen finden Sie unter Beispiele für die einfache Topologie, Beispiele für Topologie mit mittlerer Komplexität und Beispiele für die komplexe Topologie. Bei der Verwaltung einer lokalen Team Foundation Server-Bereitstellung müssen Sie diese Konfigurationsquellen berücksichtigen. Zur Änderung der Konfiguration müssen Sie ggf. Informationen in verschiedenen Speicherorten ändern. Des Weiteren müssen Sie u. U. Konfigurationsinformationen für die Daten- und Clientebene ändern. Team Foundation Server beinhaltet eine Verwaltungskonsole und verschiedene Befehlszeilendienstprogramme, mit denen Sie diese Änderungen vornehmen können. Weitere Informationen finden Sie unter Die Team Foundation-Verwaltungskonsole und Technische Referenz für Team Foundation.

Synchronisieren von Gruppenidentitäten zwischen Active Directory und Team Foundation Server

In lokalen Bereitstellungen, bei denen Team Foundation Server in einer Active Directory-Domäne ausgeführt wird, werden Gruppen- und Identitätsinformationen synchronisiert, wenn eines der folgenden Ereignisse eintritt:

  • Der Anwendungsebenenserver für Team Foundation wird gestartet.

  • Einer Gruppe in Team Foundation Server wird eine Active Directory-Gruppe hinzugefügt.

  • Der im geplanten Auftrag angegebene Zeitraum läuft ab. Die Standardeinstellung ist eine Stunde. Die Gruppen in Team Foundation Server werden alle 24 Stunden aktualisiert.

Identitätsverwaltungsdienste (Identity Management Services, IMS) werden mit Active Directory synchronisiert, und geänderte Identitäten werden vom Server an die Clients weitergegeben. Standardmäßig werden alle Gruppen innerhalb von 24 Stunden aktualisiert, Sie können diese Einstellung jedoch an die Anforderungen der Bereitstellung anpassen. Weitere Informationen finden Sie unter Aspekte zu Vertrauensstellungen und Gesamtstrukturen für Team Foundation Server. Informationen zu lokalen Bereitstellungen, bei denen Active Directory nicht verwendet wird, finden Sie unter Verwalten von Team Foundation Server in einer Arbeitsgruppe.

Gruppen und Berechtigungen

In einer lokalen Bereitstellung verfügt Team Foundation Server über einen eigenen Satz von Standardgruppen und Berechtigungen, die Sie auf Projekt-, Auflistungs- oder Serverebene festlegen können. Sie können benutzerdefinierte Gruppen erstellen und Berechtigungen auf Gruppen- und Benutzerebene anpassen. Benutzer oder Gruppen, die Sie zu Team Foundation Server hinzufügen, werden jedoch nicht automatisch zwei Komponenten hinzugefügt, von denen lokale Bereitstellungen von Team Foundation Server abhängen kann: SharePoint-Produkte und Reporting Services. Wenn diese Programme in der Bereitstellung verwendet werden, müssen Sie Benutzer und Gruppen zu diesen Programmen hinzufügen und diesen die entsprechenden Berechtigungen erteilen, damit die Benutzer und Gruppen in sämtlichen Team Foundation Server-Vorgängen ordnungsgemäß verwendet werden können. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zu Teamprojekten, Erste Schritte im Team, Konfigurieren von Benutzern, Gruppen und Berechtigungen, Verwalten von Berechtigungen, Verwalten des Profils und Anzeigen von Berechtigungen, Windows SharePoint Services Roles und SQL Server Reporting Services-Rollen.

Für gehostete Bereitstellungen wird der Zugriff durch eine Kombination aus Microsoft-Konten und Teammitgliedschaft gesteuert. Um weitere Informationen zu erhalten, melden Sie sich mit Ihrem Microsoft-Konto bei dem Dienst an, und wählen Sie Lernen aus.

Netzwerkanschlüsse und Protokolle

Standardmäßig ist eine lokale Bereitstellung von TFS für die Verwendung von bestimmten Netzwerkports und Netzwerkprotokollen konfiguriert. In der folgenden Abbildung ist der Netzwerkdatenverkehr für Team Foundation Server in einer einfachen Bereitstellung dargestellt.

Einfaches Anschluss- und Kommunikationsdiagramm

Entsprechend wird der gehostete Dienst für TFS konfiguriert, um bestimmte Netzwerkports und -protokolle zu verwenden. In der folgenden Abbildung ist der Netzwerkdatenverkehr in einer gehosteten Bereitstellung dargestellt.

Einfaches Diagramm eines gehosteten TFS-Dienstes.

In der folgenden Abbildung ist der Netzwerkdatenverkehr für eine komplexere Bereitstellung dargestellt, die die Komponenten für Visual Studio Lab Management einschließt.

Komplexes Anschluss- und Kommunikationsdiagramm (Teil 1) Komplexes Anschluss- und Kommunikationsdiagramm (Teil 3) Komplexes Anschluss- und Kommunikationsdiagramm (Teil 2)

Standardnetzwerkeinstellungen

Standardmäßig werden für die Kommunikation zwischen den Computern in einer Bereitstellung von Team Foundation die Protokolle und Ports verwendet, die in der folgenden Tabelle aufgeführt sind. Wenn auf die Portnummer ein Sternchen (*) folgt, können Sie den betreffenden Port anpassen.

Ebene und Dienst | Protokoll | Port
Anwendungsebene - Webdienste | HTTP/HTTPS | 8080/443*
Anwendungsebene - SharePoint-Produkte-Verwaltung | HTTP | 17012* falls SharePoint-Produkte mit Team Foundation Server installiert wurden); anderenfalls wird nach dem Zufallsprinzip generiert
Anwendungsebene - SharePoint-Produkte und Reporting Services | HTTP Windows-Verwaltungsinstrumentation-Dienst (Windows Management Instrumentation, WMI) (erforderlich bei der Installation, um die URLs für Reporting Services anzugeben und zu überprüfen) | 80* Dynamischer Port
Datenebene | MS-SQL TCP | 1433*
Team Foundation Server-Proxy - Client zu Proxy | HTTP | 8081*
Team Foundation Server-Proxy - Proxy zu Anwendungsebene | HTTP/HTTPS | 8080/443*
Clientebene - Reporting Services | HTTP | 80*
Clientebene - Webdienste | HTTP/HTTPS | 8080/443*
Buildcontroller - Anwendungsebene | HTTP/HTTPS | 8080/443
Build-Agent - Anwendungsebene | HTTP/HTTPS | 8080/443
Testcontroller - Anwendungsebene | HTTP/HTTPS | 8080/443*
Anwendungsebene - Testcontroller | .NET-Remoting | 6901*
Anwendungsebene - Domain Name System (DNS) | Dynamisches Update für DNS | 53
Anwendungsebene - Virtual Machine Manager | HTTP | 8100
Testcontroller - Test-Agent | .NET-Remoting | 6910*
Test-Agent - Testcontroller | .NET-Remoting | 6901*
Buildcontroller - Build-Agent | SOAP über HTTP | 9191
Labor-Agent - Labor-Agent in einer isolierten Umgebung | TCP-Sockets | 9050
Build-Agent - Buildcontroller | SOAP über HTTP | 9191
Virtual Machine Manager-Administratorkonsole - Virtual Machine Manager | HTTP | 8100
Virtual Machine Manager - Virtual Machine Manager-Hosts | Windows-Remoteverwaltung (Windows Remote Management, WinRM) zum Ausführen von Aktionen Intelligenter Hintergrundübertragungsdienst (Background Intelligent Transfer Service, BITS) zum Übertragen von Daten | 80 zum Ausführen von Aktionen 443 für Datenübertragung
Virtual Machine Manager - Virtual Machine Manager-Bibliotheksserver | WinRM zum Auszuführen von Aktionen BITS für Datenübertragung | 80 zum Ausführen von Aktionen 443 für Datenübertragung
Anwendungsebene - Virtual Machine Manager-Hosts | Kommunikation Distributed Component Object Model (DCOM)/Windows-Verwaltungsschnittstelle für Datenübertragung | 135 Dynamisch im Bereich von 49152 bis 65535 zugewiesen
Clientebene - Virtual Machine Manager-Hosts | Hostbasierte Verbindung zum virtuellen Computer. Weitere Informationen zu hostbasierten Verbindungen finden Sie unter Gewusst wie: Herstellen einer Verbindung mit einer Lab-Umgebung. | 2179 zum Ausführen von hostbasierten Verbindungen
Gehostete Dienste | HTTPS | 443

Anpassbare Netzwerkeinstellungen

Wie in der vorherige Tabelle zu sehen ist, können Sie die Kommunikation zwischen der Anwendungs-, Daten- und Clientebene bei lokalen Bereitstellungen ändern, indem Sie in Team Foundation Server benutzerdefinierte Ports festlegen. Die folgende Tabelle dient als Beispiel für Portänderungen von HTTP in HTTPS.

Hinweis Hinweis

Um Team Foundation Server für die Verwendung von HTTPS und Secure Sockets Layer zu konfigurieren, müssen Sie nicht nur Ports für HTTPS-Netzwerkverkehr aktivieren, sondern auch noch eine Reihe anderer Aufgaben ausführen. Weitere Informationen finden Sie unter Sichern von Team Foundation Server.

Dienst | Protokoll | Port
Webdienste mit SSL | HTTPS | Wird vom Administrator konfiguriert
SharePoint-Zentraladministration | HTTPS | Wird vom Administrator konfiguriert
SharePoint-Produkte | HTTPS | 443
Reporting Services | HTTPS | 443
Client-Webdienste | HTTPS | Wird vom Administrator konfiguriert

Siehe auch

Konzepte

Team Foundation Server-Konzepte
Team Foundation Server-Berechtigungen
Komponenten des Data Warehouse für Team Foundation


Die Team Foundation-Verwaltungskonsole

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Die Team Foundation-Verwaltungskonsole
Siehe auch Feedback senden

Mit der Verwaltungskonsole für Team Foundation können Sie Ressourcen verwalten und die meisten Verwaltungsaufgaben für Ihre Bereitstellung von Visual Studio Team Foundation Server (TFS) von einer zentralen Position aus durchführen. Sie können z. B. alle Protokolldateien suchen, in denen Systemereignisse für TFS aufgeführt werden. Außerdem können Sie die folgenden Aufgaben ausführen:

  • Verwalten von Benutzern und Berechtigungen auf Serverebene und Auflistungsebene

  • Erstellen und Verwalten von Teamprojektsammlungen

  • Hinzufügen und Verwalten von SharePoint-Webanwendungen für die Bereitstellung

  • Erstellen und Verwalten von virtuellen Labs zum Testen der Software

  • Hinzufügen und Verwalten von Buildumgebungen

  • Überprüfen des Serverstatus

Verwenden der Verwaltungskonsole

Sie können mit der Verwaltungskonsole für Team Foundation die meisten Verwaltungsaufgaben ausführen, die in TFS erforderlich sind. Die Funktionalität der Verwaltungskonsole hängt jedoch von den Berechtigungen des Benutzers ab, der diese öffnet. Die Konsole kann von jedem geöffnet werden, der ein gültiges Benutzerkonto auf den Servern hat, auf denen die Konsole installiert ist. Dies bedeutet jedoch nicht, dass die Benutzer mit der Konsole Aufgaben ausführen können, für die sie nicht die erforderlichen Berechtigungen haben. Wenn ein Benutzer die Konsole öffnet, aber nicht über die für bestimmte Funktionen erforderlichen Berechtigungen verfügt, schlägt die Operation fehl, wenn er versucht, diese Funktion auszuführen. Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

Diese Verwaltungskonsole wird standardmäßig auf allen Servern installiert, auf denen Sie eine oder mehrere der folgenden Komponenten installieren:

  • eine Anwendungsebene für TFS

  • TFS-Erweiterungen für SharePoint-Produkte

  • Team Foundation Build

  • Visual Studio Lab Management

Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

Verwalten von Serverressourcen

Wenn Sie die Verwaltungskonsole auf einem Server auf Anwendungsebene öffnen, können Sie die meisten Aspekte der Serverressourcen für Team Foundation verwalten. Im Knoten "Anwendungsebene" können Sie Zusammenfassungsinformationen für die Installation von TFS anzeigen und Gruppen auf Serverebene sowie Sicherheitseinstellungen verwalten. Im Knoten für die Datenebene können Sie Informationen zur Konfigurationsdatenbank für TFS anzeigen. Im Knoten für Reporting Services können Sie Informationen zu allen Ressourcen in SQL Server Reporting Services anzeigen, die für die Bereitstellung konfiguriert wurden. Weitere Informationen finden Sie unter Überprüfen von Serverstatus und -einstellungen.

Im Knoten "Teamprojektsammlungen" können Sie Teamprojektsammlungen erstellen, konfigurieren, anzeigen, starten und beenden. Diese ermöglichen Ihnen, Teamprojekte mit ähnlichen Anforderungen oder Funktionen zu organisieren. Weitere Informationen finden Sie unter Organisieren des Servers mit Teamprojektsammlungen.

Im Knoten "SharePoint-Webanwendungen" können Sie eine oder mehrere SharePoint-Webanwendungen für Teamprojektsammlungen konfigurieren. Wenn Sie eine oder mehrere Webanwendungen hinzufügen, können Mitglieder des Teams beim Erstellen eines Teamprojekts automatisch eine SharePoint-Site erstellen. Bevor Sie eine SharePoint-Webanwendung hinzufügen können, müssen Sie die Erweiterungen für SharePoint-Produkte auf einem Server in der Webfarm installieren, die die hinzuzufügende Anwendung hostet. Zudem müssen Sie das Dienstkonto, das die SharePoint-Webanwendung verwendet, zu TFS hinzufügen. Weitere Informationen finden Sie unter Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung und Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server.

Im Knoten "Lab-Management" können Sie einen oder mehrere virtuelle Computer so konfigurieren, dass diese als Ressourcen für die Entwicklung und den Test von Code verwendet werden. Weitere Informationen finden Sie unter How to: Configure or Reconfigure Lab Management und Managing Lab Services.

Verwalten von mit Team Foundation Server verwendeten SharePoint-Webanwendungen

Bevor Sie der Bereitstellung von TFS eine oder mehrere SharePoint-Webanwendungen hinzufügen können, müssen Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte installieren. Anschließend müssen Sie den Zugriff zwischen der SharePoint-Webanwendung und TFS konfigurieren. Abhängig von Ihren Berechtigungen müssen Sie den Zugriff entweder manuell konfigurieren, oder Sie können den Zugriff automatisch beim Hinzufügen der SharePoint-Webanwendung zu TFS konfigurieren. Nachdem der Zugriffserteilung können Sie die Erweiterungen verwalten, indem Sie die Verwaltungskonsole auf einem Server öffnen, auf dem die Team Foundation Server-Erweiterungen für SharePoint-Produkte installiert sind. Weitere Informationen finden Sie unter Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung und im Abschnitt zu den Erweiterungen.

Überprüfen von Protokolldateien

In der Verwaltungskonsole können Sie die Protokolldateien für die Installation und Systemänderungen überprüfen. Zudem können Sie den Ordner öffnen, in dem diese Dateien gespeichert sind, und diese manuell kopieren oder löschen. Weitere Informationen finden Sie unter Überprüfen von Serverstatus und -einstellungen.

Verwalten von Builds

Sie können Team Foundation Build so konfigurieren, dass Ihr Team Software automatisch und einheitlich in einer verteilten Umgebung erstellen und testen kann. Sie können die Buildeinstellungen überprüfen und verwalten, indem Sie die Verwaltungskonsole auf den Computern öffnen, auf denen Team Foundation Build installiert wurde. Weitere Informationen finden Sie unter Verwalten des Team Foundation Builds.

Öffnen von bestimmten Knoten in der Verwaltungskonsole

Die Verwaltungskonsole enthält unterschiedliche Knoten, je nachdem welche Komponenten von Team Foundation auf dem Server installiert sind. Wenn ein bestimmter Knoten nicht angezeigt wird, sollten Sie überprüfen, ob Sie an einem Server angemeldet werden, auf dem die jeweilige Komponente installiert ist.

So öffnen Sie den Knoten für Team Foundation Server

  1. Erweitern Sie im Strukturbereich den Namen des Servers und dann den Knoten Anwendungsebene.

    Die Zusammenfassungsinformationen für die Installation von TFS werden angezeigt. Unterhalb dieses Knotens können Sie Informationen zum Server anzeigen und Gruppenmitgliedschaften, Sicherheitseinstellungen sowie Dienstkonten konfigurieren.

  2. (Optional) Klicken Sie unterhalb des Knotens Anwendungsebene auf einen der folgenden Knoten, um die Einstellungen für diesen Knoten anzuzeigen oder zu ändern:

    • Datenebene

      Hier werden Informationen zu dem Server angezeigt, der die Konfigurationsdatenbank für Team Foundation Server hostet. Diese Informationen können nicht geändert werden.

    • Teamprojektsammlungen

      Hier können Sie auf dem Server vorhandene Teamprojektsammlungen anzeigen, erstellen, ändern oder löschen. Weitere Informationen finden Sie unter Organisieren des Servers mit Teamprojektsammlungen.

    • SharePoint-Webanwendungen

      Hier können Sie eine Zuordnung von einem Server, auf dem Team Foundation Server ausgeführt wird, zu einem Server, auf dem SharePoint-Produkte ausgeführt wird, anzeigen, erstellen, ändern oder löschen. Weitere Informationen finden Sie unter Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung.

    • Berichte

      Hier werden Informationen zu dem Server angezeigt, der die Warehouse-Datenbank und die Datenbank für SQL Server Analysis Services hostet. Weitere Informationen finden Sie unter Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung.

    • Lab-Management

      Hier können Sie Informationen zu Lab Management anzeigen oder konfigurieren. Weitere Informationen finden Sie unter How to: Configure or Edit Lab Management.

So öffnen Sie den Knoten mit den Erweiterungen für SharePoint-Produkte

  • Erweitern Sie im Strukturbereich den Namen des Servers und dann Erweiterungen für SharePoint-Produkte.

    In diesem Knoten können Sie eine Zuordnung von einem Server, auf dem SharePoint-Produkte ausgeführt wird, zu einem Server, auf dem Team Foundation Server ausgeführt wird, anzeigen, erstellen, ändern oder löschen. Weitere Informationen finden Sie unter Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung.

So öffnen Sie den Knoten für Team Foundation-Build

  • Erweitern Sie im Strukturbereich den Namen des Servers und dann auf den Knoten Team Foundation-Build.

    In diesem Knoten können Sie Builddienste für Team Foundation Build anzeigen, erstellen, ändern oder deaktivieren. Weitere Informationen finden Sie unter Verwalten des Team Foundation Builds.

So öffnen Sie den Protokollknoten.

  • Erweitern Sie im Strukturbereich den Namen des Servers und dann den Knoten Protokolle.

    In diesem Knoten können Sie die Protokolle für Konfigurationsänderungen in Team Foundation Server überprüfen. Doppelklicken Sie für weitere Informationen zu einer bestimmten Änderung im Ergebnisbereich auf die jeweilige Änderung.

So öffnen Sie den Knoten "Zusätzliche Tools"

  • Erweitern Sie im Strukturbereich den Namen des Servers und dann den Knoten Zusätzliche Tools.

    In diesem Knoten bleibt der oberste Knoten statisch und zeigt keine Informationen über installierte Tools in der Bereitstellung an. Wenn Sie jedoch zusätzliche Tools aus dem Abschnitt Zusätzliche Tools und Komponenten des Team Foundation Server-Konfigurationscenters installieren, sollten die einzelnen Tools unterhalb dieses Knotens als untergeordnete Knoten angezeigt werden. Um Informationen über jedes installierte Tool anzuzeigen, wählen Sie den entsprechenden Unterknoten unter Zusätzliche Tools.

Siehe auch

Aufgaben

Öffnen der Team Foundation-Verwaltungskonsole

Konzepte

Organisieren des Servers mit Teamprojektsammlungen
Konfigurieren von Benutzern, Gruppen und Berechtigungen

Weitere Ressourcen

Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]
Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Benennungseinschränkungen in Team Foundation

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Benennungseinschränkungen in Team Foundation
Siehe auch Feedback senden

Für viele Komponenten in Visual Studio Team Foundation Server (TFS) gelten bestimmte Benennungseinschränkungen. Durch diese Einschränkungen wird eine konsistente Benutzerfreundlichkeit und Kompatibilität mit anderen Programmen gewährleistet. Zu diesen Einschränkungen können Länge, Sonderzeichen, Eindeutigkeit oder andere Attribute gehören.

Dieses Thema enthält folgende Unterabschnitte:

Allgemeine Überlegungen

Einschränkungen für Team Foundation Server-Gruppenkontonamen

Einschränkungen für Computernamen

Einschränkungen für Teamprojektsammlungsnamen

Einschränkungen für Teamprojektnamen

Einschränkungen für Teamnamen

Einschränkungen für Arbeitsaufgaben

Einschränkungen für Arbeitsaufgabenanpassungen

Einschränkungen für Prozessvorlagen

Einschränkungen für Team Foundation Build

Einschränkungen für die Versionskontrolle

Siehe auch

Allgemeine Überlegungen

Die Längeneinschränkungen in diesem Thema ergeben sich anhand der Anzahl der zugelassenen Unicode-Zeichen. Weitere Informationen zu Unicode finden Sie im Artikel "About Unicode and Character Sets" unter http://go.microsoft.com/fwlink/?LinkId=76837. Ersatzzeichen setzen sich aus zwei Unicode-Zeichen zusammen und werden bei der Längeneinschränkung als zwei Zeichen gezählt.

Ähnlich wie bei anderen Betriebssystemdateien sind auch ASCII-Steuerzeichen (ASCII 1-31) und Ersatzzeichenkombinationen unzulässig. Allgemeine Informationen zu Betriebssystemeinschränkungen für Dateinamen finden Sie im Artikel "Naming a File" unter http://go.microsoft.com/fwlink/?LinkId=76838.

Einschränkungen für Team Foundation Server-Gruppenkontonamen

Mit Team Foundation-Gruppenkonten können Sie einer Benutzergruppe bestimmte Rechte oder Berechtigungen zuweisen. Diese Team Foundation-Gruppe kann aus Windows-Benutzerkonten, Windows-Gruppenkonten, Active Directory-Gruppenkonten, Team Foundation-Gruppenkonten oder einer Kombination dieser Kontotypen bestehen. Weitere Informationen zum Verwalten von Benutzern mit Gruppen finden Sie unter Benutzer, Gruppen und Berechtigungen in Team Foundation Server-Bereitstellungen und Konfigurieren von Benutzern, Gruppen und Berechtigungen. Beispiele dazu, wie einer in TFS, SharePoint-Produkte und SQL Server Reporting Services verwendeten Gruppe ein neues Mitglied hinzugefügt werden kann, finden Sie unter Hinzufügen von Benutzern zu Teamprojekten. Weitere Informationen zum Überprüfen der Berechtigungen für Ihr Konto finden Sie unter Verwalten des Profils und Anzeigen von Berechtigungen.

Wenn ein Team Foundation Gruppenkonto erstellt oder geändert wird, gelten dafür bestimmte Team Foundation Server-Einschränkungen. In der folgenden Tabelle werden diese Einschränkungen beschrieben.

Einschränkungstyp

Einschränkung

Länge von Gruppenkontonamen

  • Dürfen nicht mehr als 256 Unicode-Zeichen enthalten.

Eindeutigkeit (Gruppenkonten auf Auflistungsebene)

  • Müssen sich von allen anderen Gruppenkontennamen in der Teamprojektsammlung unterscheiden.

Eindeutigkeit (Gruppenkonten auf Projektebene)

  • Müssen sich von anderen Gruppennamen im gleichen Projekt unterscheiden.

Reservierte Gruppennamen

  • Dürfen weder auf Projektebene noch auf Serverebene $NAMESPACE genannt werden

Einschränkungen für Sonderzeichen

  • Dürfen folgende druckbaren Zeichen nicht enthalten: "/ \ [ ] : | < > + = ; ? *

  • Dürfen keine nicht druckbaren Zeichen im ASCII-Bereich von 1-31 enthalten

  • Dürfen nicht mit einem Punkt (.) enden

  • Dürfen keine Kommas (,) enthalten

Hinweis Hinweis

In Team Foundation Server werden keine Benutzerkonten erstellt.

Einschränkungen für Computernamen

Während des TFS-Installationsvorgangs wird der Computername dem Namen des Servers zugeordnet.

Sowohl das Betriebssystem als auch Active Directory geben bestimmte Einschränkungen für Computernamen vor. Weitere Informationen zum Umbenennen von Computern finden Sie im Artikel "Rename a Computer" unter http://go.microsoft.com/fwlink/?LinkId=76839. Weitere Informationen über Active Directory finden Sie im Artikel "Windows Server 2003 Active Directory" unter http://go.microsoft.com/fwlink/?LinkId=47541.

Einschränkungen für Teamprojektsammlungsnamen

Der Name einer Teamprojektsammlung kennzeichnet eine Gruppierung von Teamprojekten und zugehörigen Ressourcen. Eine Teamprojektauflistung ist eine Organisationsstruktur, mit der Sie eine Gruppe von Teamprojekten in TFS definieren und steuern können. Die Teammitglieder verwenden den Namen der Teamprojektauflistung, wenn sie eine Verbindung mit Teamprojekten in TFS herstellen. Weitere Informationen finden Sie unter Organisieren des Servers mit Teamprojektsammlungen.

In der folgenden Tabelle werden die Einschränkungen für Auflistungsnamen beschrieben.

Einschränkungstyp

Einschränkung

Länge

  • Dürfen nicht mehr als 64 Unicode-Zeichen enthalten.

Eindeutigkeit

  • Dürfen nicht mit anderen Auflistungsnamen in Ihrer Bereitstellung von Team Foundation Server übereinstimmen.

  • Dürfen nicht mit dem Namen und vollständigen Pfad einer SharePoint-Website, eines Berichtsservers oder einer Reporting Services-Website übereinstimmen, wenn die Bereitstellung SharePoint-Produkte oder SQL Server Reporting Services umfasst.

Sonderzeichen

  • Dürfen keine Unicode-Steuerzeichen oder Ersatzzeichen enthalten.

  • Dürfen folgende druckbare Zeichen nicht enthalten: / : \ ~ & % ; @ ' " ? < > | # $ * } { , + = [ ] < > | # $ * } { , + = [ ]

  • Dürfen keine Auslassungspunkte (...) oder doppelte Punkte (..) enthalten.

  • Dürfen nicht mit einem Unterstrich (_) beginnen

  • Dürfen nicht mit einem Punkt (.) beginnen oder enden

Reservierte Namen

  • Dürfen keine vom System reservierten Namen sein, wie beispielsweise PRN, COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, COM10, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9, NUL, CON, AUX, Web oder WEB.

    Weitere Informationen zu reservierten Namen finden Sie auf der folgenden Seite der Microsoft-Website: File Names, Paths, and Namespaces (in englischer Sprache).

Einschränkungen für Projektnamen

Der Projektname in TFS kennzeichnet eine Auflistung von Arbeitsaufgaben, Dokumenten, Berichten, Teambuilds und eine Versionskontrollstruktur für ein bestimmtes TFS-Projekt. Teammitglieder verwenden diesen Projektnamen, um in TFS eine Verbindung mit dem Projekt herzustellen.

In der folgenden Tabelle werden die Einschränkungen für Projektnamen beschrieben.

Einschränkungstyp

Einschränkung

Länge

  • Dürfen nicht mehr als 64 Unicode-Zeichen enthalten.

Eindeutigkeit

Darf nicht identisch mit einem anderen Namen in der Teamprojektsammlung sein, der SharePoint-Webanwendung, die die Auflistung unterstützt, oder die Instanz von SQL Server Reporting Services, die die Auflistung unterstützt

Sonderzeichen

  • Dürfen keine Unicode-Steuerzeichen oder Ersatzzeichen enthalten.

  • Dürfen folgende druckbare Zeichen nicht enthalten: / : \ ~ & % ; @ ' " ? < > | # $ * } { , + = [ ] < > | # $ * } { , + = [ ]

  • Dürfen keine Auslassungspunkte (...) oder doppelte Punkte (..) enthalten.

  • Dürfen nicht mit einem Unterstrich (_) beginnen

  • Dürfen nicht mit einem Punkt (.) beginnen oder enden

Reservierte Namen

  • Dürfen keine vom System reservierten Namen sein, wie beispielsweise PRN, COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, COM10, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9, NUL, CON oder AUX

  • Weitere Informationen zu reservierten Namen finden Sie im Artikel "Naming a File" unter http://go.microsoft.com/fwlink/?LinkId=76838.

Einschränkungen für Teamnamen

Die Teamnamen in TFS identifizieren eine Gruppe einzelner Benutzer oder Gruppen, die als Team an einem Projekt in TFS arbeiten. Teammitglieder verwenden diesen Projektnamen, um eine Verbindung in Team Web Access herzustellen. Der Teamname muss ein Name sein, der als Teil einer gültigen URL gerendert werden kann. Außerdem muss jeder Teamname innerhalb eines einzelnen Projekts eindeutig sein. Innerhalb verschiedener Projekte einer Teamprojektsammlung können auch die gleichen Teamnamen verwendet werden. Weitere Informationen zum Arbeiten in Teams in TFS finden Sie unter Erste Schritte im Team.

In der folgenden Tabelle werden die Einschränkungen für Teamnamen beschrieben.

Einschränkungstyp

Einschränkung

Länge

  • Dürfen nicht mehr als 64 Unicode-Zeichen enthalten.

Eindeutigkeit

Muss sich von anderen Feldverweisnamen im Projekt unterscheiden.

Sonderzeichen

  • Dürfen keine Unicode-Steuerzeichen oder Ersatzzeichen enthalten.

  • Dürfen folgende druckbare Zeichen nicht enthalten: / : \ ~ & % ; @ ' " ? < > | # $ * } { , + = [ ] < > | # $ * } { , + = [ ]

  • Dürfen keine Auslassungspunkte (...) oder doppelte Punkte (..) enthalten.

  • Dürfen nicht mit einem Unterstrich (_) beginnen

  • Dürfen nicht mit einem Punkt (.) beginnen oder enden

Reservierte Namen

  • Dürfen keine vom System reservierten Namen sein, wie beispielsweise PRN, COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, COM10, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9, NUL, CON oder AUX

  • Weitere Informationen zu reservierten Namen finden Sie im Artikel "Naming a File" unter http://go.microsoft.com/fwlink/?LinkId=76838.

Einschränkungen für Arbeitsaufgaben

Microsoft Visual Studio Application Lifecycle Management verfolgt den Status für ein Projekt, indem Elemente wie Fehler, Anforderungen, Aufgaben und Risiken verwendet werden. Diese Elemente werden üblicherweise als Arbeitsaufgaben bezeichnet. In diesem Abschnitt werden Einschränkungen für die in den Arbeitsaufgaben gespeicherten Daten beschrieben.

Einschränkungen für Anlagen zu Arbeitsaufgaben

Arbeitsaufgaben können Dateien angefügt werden. In der folgenden Tabelle werden die Einschränkungen für Anlagen zu Arbeitsaufgaben beschrieben.

Einschränkungstyp

Einschränkung

Dateigröße

  • Die Größe von Anlagen zu Arbeitsaufgaben ist standardmäßig auf 4.096 KB beschränkt. Dieser Wert kann vom Team Foundation-Administrator geändert werden. Die maximale Größe, die vom Administrator festgelegt werden kann, beträgt 2 Gigabyte.

  • Standardgröße: 4.096 Kilobyte

  • Maximale Größe: 2 Gigabyte

Einschränkungen für Arbeitsaufgabenbereiche und Arbeitsaufgabeniterationen

Arbeitsaufgaben enthalten ein Feld für Projektbereich und ein Feld für Projektiteration. Mit diesen Feldern werden Arbeitsaufgaben in logischen Gruppierungen geordnet und angezeigt.

Die Pfade Projektbereich und Projektiteration bestehen aus mehreren Knotenelementen, die durch umgekehrte Schrägstriche (\) getrennt sind. Der Team Foundation Server-Administrator definiert die Knoten, um die Projektbereiche und den Projektzyklus zu beschreiben. In der folgenden Tabelle werden die Einschränkungen für Knoten und Pfade beschrieben.

Einschränkungstyp

Einschränkung

Knotenlänge

  • Darf nicht mehr als 255 Zeichen enthalten

Sonderzeichen für Knoten

  • Unicode-Steuerzeichen sind nicht zulässig

  • Folgende Zeichen sind nicht zulässig: \ / $ ? * : " & > < # % | * : " & > < # % |

  • Dürfen keine für das lokale Dateisystem unzulässigen Zeichen enthalten. Weitere Informationen zu Zeicheneinschränkungen in Windows finden Sie im Artikel "Naming a File" unter http://go.microsoft.com/fwlink/?LinkId=76838.

Reservierte Namen

  • Dürfen keinen Punkt (.) oder zwei Punkte (..) enthalten.

  • Dürfen keine vom System reservierten Namen sein, wie beispielsweise PRN, COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, COM10, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, LPT9, NUL, CON oder AUX

  • Weitere Informationen zu reservierten Namen finden Sie im Artikel "Naming a File" unter http://go.microsoft.com/fwlink/?LinkId=76838.

Pfadlänge

  • Dürfen nicht mehr als 4000 Unicode-Zeichen enthalten.

Pfadhierarchietiefe

  • Darf nicht mehr als 14 Ebenen tief sein

Einschränkungen für Arbeitsaufgabenanpassungen

Team Foundation Server kann mithilfe von Elementen wie Fehlern, Anforderungen, Aufgaben und Risiken den Fortschritt eines Projekts verfolgen. Diese Elemente werden üblicherweise als Arbeitsaufgaben bezeichnet.

Teamprojektadministratoren können Arbeitsaufgaben-Typdefinitionen entweder auf Projektebene oder in einer Prozessvorlage ändern. Weitere Informationen zum Anpassen von Arbeitsaufgabentypen finden Sie unter Anpassen von Projektnachverfolgungsdaten, Formularen, Workflow und anderen Objekten. In diesem Abschnitt werden Einschränkungen beschrieben, die beim Anpassen von Arbeitsaufgaben und den zugeordneten Elementen auftreten.

Einschränkungen für Feldnamen von Arbeitsaufgaben

Jeder Arbeitsaufgabentyp enthält mindestens ein Arbeitsaufgabenfeld. Diese Felder definieren die in einem Arbeitsaufgabentyp gespeicherten Informationen. Ein Feldname für eine Arbeitsaufgabe legt jedes Arbeitsaufgabenfeld eindeutig fest.

In der folgenden Tabelle werden die Einschränkungen für Feldnamen von Arbeitsaufgaben beschrieben.

Einschränkungstyp

Einschränkung

Länge

Dürfen nicht mehr als 128 Unicode-Zeichen enthalten.

Sonderzeichen

  • Führende oder nachgestellte Leerzeichen sind nicht zulässig

  • Zwei oder mehr aufeinander folgende Leerzeichen sind nicht zulässig

  • Darf keine Punkte (.) enthalten

  • Darf keine eckigen Klammern ([ ]) enthalten

Umfang

  • Namen für Arbeitsaufgabenfelder gelten für die gesamte Bereitstellung von TFS. Wenn ein Feldname geändert wird, überträgt sich diese Änderung auf alle Projekte und Arbeitsaufgabentypen, die dieses Arbeitsaufgabenfeld enthalten.

Einschränkungen für Feldverweisnamen von Arbeitsaufgaben

Jedes Arbeitsaufgabenfeld verfügt über einen zugeordneten Feldverweisnamen. Der Feldverweisname kennzeichnet jedes Feld eindeutig und kann nach seiner Zuweisung nicht geändert werden. In der folgenden Tabelle werden die Einschränkungen für Feldverweisnamen beschrieben.

Einschränkungstyp

Einschränkung

Länge

  • Dürfen nicht mehr als 70 Unicode-Zeichen enthalten.

Sonderzeichen

  • Darf keine Bindestriche (-) enthalten

  • Muss mindestens einen Punkt (.) enthalten

  • Dürfen nicht mit einem Punkt (.) beginnen oder enden

  • Darf nicht mit einer Zahl beginnen

  • Dürfen nicht mit einem Unterstrich (_) beginnen

Eindeutigkeit

  • Muss sich von anderen Feldverweisnamen in Team Foundation Server unterscheiden

  • Dürfen nicht mit anderen Feldverweisnamen übereinstimmen, nachdem die Namen vom Computer verarbeitet und alle Punkte (.) durch Unterstriche (_) ersetzt wurden.

    Nach einer Verarbeitung werden beispielsweise die Feldverweisnamen My._Field und My_.Field übereinstimmend in My__Field umbenannt

Einschränkungen für Hilfetext für Arbeitsaufgabenfelder

Als Option können Sie mithilfe des < HELPTEXT >-Tags Arbeitsaufgabenfeldern Hilfetext zuordnen. Der Text wird zur Laufzeit angezeigt, um den Benutzern die Eingabe in das Feld zu erleichtern. Weitere Informationen zu Hilfetext für Arbeitsaufgabenfelder finden Sie unter Definieren des Hilfetexts für ein Arbeitsaufgabenfeld.

In der folgenden Tabelle werden die Einschränkungen für Hilfetext für Arbeitsaufgabenfelder beschrieben.

Einschränkungstyp

Einschränkung

Länge

  • Dürfen nicht mehr als 255 Unicode-Zeichen enthalten.

Umfang

Im Unterschied zum Feldnamen und Feldtyp beschränkt sich Hilfetext für Felder auf einen bestimmten Arbeitsaufgabentyp in einem bestimmten Teamprojekt.

Einschränkungen für globale Listen

In einer globalen Liste sind verschiedene Werte von Listenelementen gespeichert, die global von allen Team Foundation-Servern in einer Team Foundation Server-Implementierung verwendet werden. Möglicherweise stellen Sie beim Definieren von Arbeitsaufgabentypen fest, dass einige Felder die gleichen möglichen Werte verwenden. Mithilfe von globalen Listen können Sie diese Werte einmal festlegen und anschließend für mehrere Arbeitsaufgabentypen freigeben. Weitere Informationen finden Sie unter Definieren von globalen Listen.

Eine globale Liste (GLOBALLIST) enthält mindestens ein Listenelement (LISTITEM-Elemente).

In der folgenden Tabelle werden die Einschränkungen für Listenelemente beschrieben.

Einschränkungstyp

Einschränkung

Länge

  • Dürfen nicht mehr als 254 Unicode-Zeichen enthalten.

  • Dürfen nicht leer sein

Sonderzeichen

  • Dürfen keine führenden oder nachgestellten Leerzeichen enthalten

  • Dürfen keine zwei aufeinander folgenden Leerzeichen enthalten

  • Dürfen keine umgekehrten Schrägstriche (\) enthalten

Umfang

  • Da globale Listen für alle Projekte zur Verfügung stehen, dürfen sie keine Elemente enthalten, die auf Projektebene definiert wurden, wie beispielsweise projektspezifische Gruppenkontodefinitionen.

In der folgenden Tabelle werden die Einschränkungen für globale Listen beschrieben.

Einschränkungstyp

Einschränkung

Anzahl der Elemente

Die globale Liste darf nicht leer sein. Sie muss mindestens ein LISTITEM-Element enthalten.

Eindeutigkeit

  • Der globale Listenname muss sich von anderen globalen Listennamen in Team Foundation Server unterscheiden.

Einschränkungen für Prozessvorlagen

Eine Prozessvorlage umfasst einen Satz von Standardarbeitsaufgaben, Arbeitsaufgabenabfragen, Produktvorlagen, Berichten, Sicherheitsgruppen und Leitfäden, die sich auf die Struktur eines Projekts in Team Foundation auswirken. Team Foundation Server beinhaltet zwei Standardprozessvorlagen, die zwei verschiedene Formate zum Verwalten des Softwarezyklus umfassen. Diese Vorlagen können an die besonderen Anforderungen der Organisation angepasst werden. Weitere Informationen finden Sie unter Anpassen von Prozessvorlagen.

In der folgenden Tabelle werden die Einschränkungen für Prozessvorlagen beschrieben.

Einschränkungstyp

Einschränkung

Länge des Prozessvorlagennamens

Dürfen nicht mehr als 256 Unicode-Zeichen enthalten

Eindeutigkeit des Prozessvorlagennamens

  • Muss auf dem gesamten Team Foundation-Server eindeutig sein

  • Wenn Sie eine Vorlage hochladen, die den gleichen Namen wie eine bereits vorhandene Vorlage hat, wird die vorhandene überschrieben.

Größe der Prozessvorlagendatei

Die Prozessvorlagendatei darf nicht größer als 2 GB (Gigabyte) sein

Einschränkungen für Team Foundation Build

In Team Foundation Build können Sie alle Bereiche des Buildprozesses auf einem einzelnen Computer verwalten. Außerdem können Sie mithilfe von Team Foundation Build Quellen synchronisieren, die Anwendung kompilieren, zugehörige Komponententests ausführen, eine Codeanalyse durchführen, Builds auf einem Dateiserver bereitstellen und Buildberichte veröffentlichen.

Einschränkungen für Buildcomputer

Team Foundation Build ist eine von der Team Foundation Server-Anwendungsebene und -Datenebene bzw. vom Visual Studio-Client unabhängige Installation. Sie können einen separaten Computer verwenden. Sie haben auch die Möglichkeit, den Build parallel auf dem Clientcomputer und den Servern zu installieren.

In der folgenden Tabelle werden die Einschränkungen für Buildcomputer beschrieben.

Einschränkungstyp

Einschränkung

Speicherplatz

Es muss genügend Speicherplatz für den Build vorhanden sein (ungenügender Speicherplatz führt zu fehlerhaften Builds)

Buildverzeichnis

Muss ein lokaler Pfad sein (z. B. C:\Buildverzeichnis).

Verzeichnis des Ablagespeicherorts

Muss ein UNC-Pfad sein (z. B. \\Server\Freigabe).

Berechtigungen für den Ablagespeicherort

Jeder generierte Build wird in einem neuen Verzeichnis im Ablageordner abgelegt.

  • Das Team Foundation Server-Dienstkonto (z. B. Domäne\TFSSERVICE) muss über Berechtigungen für den Vollzugriff auf den UNC-Ablagespeicherort verfügen.

  • Der UNC-Ablagespeicherort muss ein freigegebener Ordner sein.

Team Foundation-Builddienstkonto

Wenn Sie das TFS-Dienstkonto nach der ersten Installation ändern, müssen Sie sicherstellen, dass die folgenden Bedingungen erfüllt sind.

  • Das Konto ist Mitglied der Gruppe Builddienste.

  • Das Konto verfügt über Lese-/Schreibberechtigungen für die temporären Ordner und den temporären ASP.NET-Ordner.

  • Das Konto hat Berechtigungen für den Vollzugriff auf das Buildverzeichnis und den Ablagespeicherort.

Firewallprobleme

Vergewissern Sie sich, dass das Programm tfsbuildservice in der Ausnahmeliste enthalten ist, wenn die Firewall des Buildcomputers aktiviert ist.

Namen von Buildtypen

In Team Foundation Build werden Buildtypen zum Konfigurieren der Bedingungen verwendet, unter denen eine einzelne Projektmappe oder eine Reihe von Projektmappen in einem Teamprojekt erstellt wird. Um einen Buildvorgang auszuführen, müssen Sie entweder einen neuen Buildtyp erstellen oder einen bereits vorhandenen Buildtyp verwenden. Weitere Informationen zu Buildtypen finden Sie unter Definieren des Buildprozesses.

In der folgenden Tabelle werden die Einschränkungen für Namen von Buildtypen beschrieben.

Einschränkungstyp

Einschränkung

Eindeutigkeit

Muss sich von anderen Buildtypnamen im Projekt unterscheiden

Sonderzeichen

  • Darf folgendes druckbares Zeichen nicht enthalten: $

Buildqualitätsnamen

Mithilfe der Buildqualität können Sie für einen abgeschlossenen Build eine Qualitätsstufe oder einen Abschlusszustand festlegen. Zudem können Sie in Team Foundation Build neue Werte für den Buildqualitätstyp erstellen. Weitere Informationen finden Sie unter Erstellen einer Builddefinition. Eine Liste der Standardwerte für die Buildqualität finden Sie unter Beurteilen der Qualität eines abgeschlossenen Builds.

In der folgenden Tabelle werden die Einschränkungen für Buildqualitätsnamen beschrieben.

Einschränkungstyp | Einschränkung
Länge | Dürfen nicht mehr als 256 Unicode-Zeichen enthalten.
Eindeutigkeit | Müssen sich von anderen Buildqualitätsnamen auf dem Team Foundation Build-Computer unterscheiden.

Einschränkungen für die Versionskontrolle

Die Team Foundation-Versionskontrolle bietet ein zentrales Repository für Dateien und für Befehle, die zur Verwaltung der Dateien innerhalb eines Teams erforderlich sind. Außerdem stehen in der Quellcodeverwaltung neben vielen anderen Features anpassbare Eincheckrichtlinien und verschiedene Optionen zur Verzweigung, Zusammenführung und zum Zurückstellen zur Verfügung.

Versionskontrollserver-Pfade

Der Versionskontrollserver-Pfad ist der vollqualifizierte Pfad einer in der Versionskontrolle gespeicherten Datei.

In der folgenden Tabelle werden die Längeneinschränkungen für den Versionskontrollserver-Pfad beschrieben.

Einschränkungstyp

Einschränkung

Länge

  • Ein Verzeichnispfad darf nicht mehr als 248 Unicode-Zeichen enthalten

  • Darf für einen kombinierten Verzeichnis- und Dateinamen nicht mehr als 260 Unicode-Zeichen enthalten

Hinzufügen von Dateien zur Versionskontrolle

Das Versionskontrollsystem speichert viele verschiedene Dateitypen. Weitere Informationen zum Hinzufügen von vorhandenen Visual Studio-Projekten oder -Projektmappen zur Versionskontrolle finden Sie unter Einrichten des Entwicklercomputers und Verwenden der Versionskontrolle.

In der folgenden Tabelle werden die Einschränkungen für Dateien und Ordner beschrieben, die der Versionskontrolle hinzugefügt werden sollen.

Einschränkungstyp

Einschränkung

Dateierweiterungen

  • Dürfen folgende druckbaren Zeichen nicht enthalten: / \ : * ? " < > | " < > | ;

Ordner

  • Dürfen nicht leer sein

  • Dürfen keine Dateien mit ausstehenden Änderungen enthalten

  • Dürfen sich nicht außerhalb des zugeordneten Verzeichnisses für den aktiven Arbeitsbereich befinden

Bezeichnungsnamen

In der Team Foundation-Versionskontrolle ist eine Bezeichnung ein auf einen bestimmten Satz von Revisionen angewendeter Name. Sie können Bezeichnungen an einen Satz nicht zusammenhängender Dateien der Versionskontrolle anfügen. Dadurch können Sie die Dateien abrufen oder sie als Gruppe verwenden. In der folgenden Tabelle werden die Einschränkungen für Bezeichnungsnamen beschrieben.

Einschränkungstyp

Einschränkung

Länge

Dürfen nicht mehr als 64 Unicode-Zeichen enthalten.

Sonderzeichen

  • Dürfen nicht mit einem Leerzeichen ( ) oder einem Punkt (.) enden

  • Dürfen die folgenden druckbaren Zeichen nicht enthalten: " / : < > \ | * ? @ @ ;

Shelvesets

Mit Shelvesets können Sie eine Reihe ausstehender Änderungen vorübergehend zurückstellen und die ausstehenden Änderungen wahlweise aus dem Arbeitsbereich entfernen. Sie können die Änderungen später in einem Shelveset für Ihren Arbeitsbereich oder den Arbeitsbereich eines anderen Benutzers wiederherstellen.

In der folgenden Tabelle werden die Einschränkungen für Shelvesetnamen beschrieben.

Einschränkungstyp

Einschränkung

Länge

Dürfen nicht mehr als 64 Unicode-Zeichen enthalten.

Sonderzeichen

  • Dürfen die folgenden druckbaren Zeichen nicht enthalten: " / : < > \ | * ? @ ;

Arbeitsbereichsnamen

Ein Arbeitsbereich ist eine clientseitige Kopie der Dateien und Ordner in Team Foundation-Versionskontrolle. Wenn Sie mehrere Arbeitsbereiche erstellen, können auf einem Clientcomputer verschiedene Versionen des gleichen Versionskontrollordners vorhanden sein. Weitere Informationen zu Arbeitsbereichen finden Sie unter Verwalten der Arbeitsbereiche. In der folgenden Tabelle werden die Einschränkungen für Arbeitsbereichsnamen beschrieben.

Einschränkungstyp

Einschränkung

Länge

Dürfen nicht mehr als 64 Unicode-Zeichen enthalten.

Sonderzeichen

  • Darf nicht mit einem Leerzeichen ( ) enden

  • Dürfen die folgenden druckbaren Zeichen nicht enthalten: " / : < > \ | * ? @ ;

Siehe auch

Aufgaben

Erstellen einer Builddefinition
Beurteilen der Qualität eines abgeschlossenen Builds

Konzepte

Anpassen von Projektnachverfolgungsdaten, Formularen, Workflow und anderen Objekten
Definieren des Hilfetexts für ein Arbeitsaufgabenfeld
Definieren von globalen Listen
Anpassen von Prozessvorlagen
Definieren des Buildprozesses
Verwalten der Arbeitsbereiche


Beispiele für die einfache Topologie

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Beispiele für die einfache Topologie
Siehe auch Feedback senden

Sie können Visual Studio Team Foundation Server in verschiedenen Topologiekonfigurationen installieren und konfigurieren. Je einfacher die Topologie ist, umso leichter ist die Verwaltung einer Bereitstellung von Team Foundation Server. Stellen Sie daher die einfachste Topologie bereit, die den Anforderungen Ihres Unternehmens entspricht. In diesem Thema werden zwei relativ einfache Topologien erläutert, in denen der Server und die Clients zu einer einzelnen Arbeitsgruppe oder Domäne gehören.

Einfachste Topologie

Bei der einfachsten Servertopologie werden möglichst wenige Server verwendet, um die Komponenten zu hosten, die die logischen Ebenen von Team Foundation bilden. Die folgende Abbildung zeigt die einfachste Topologie:

In diesem Beispiel werden alle Serverkomponenten auf einem physischen Server bereitgestellt. Der Zugriff erfolgt über Clientcomputer in derselben Domäne oder Arbeitsgruppe. Dieses Beispiel ist für ein kleines Produktentwicklungsteam mit weniger als 50 Benutzern vorgesehen.

In dieser Konfiguration können Sie den Computer, auf dem Team Foundation Build und die Testkomponenten des Teams ausgeführt werden, auf einem einzelnen Server mit Team Foundation Server oder auf einem bzw. mehreren Clientcomputern installieren. Diese Konfiguration eignet sich am besten für kleine Entwicklungsunternehmen oder Pilotprojekte innerhalb größerer Unternehmen.

Einfache Topologie

Bei der einfachen Servertopologie werden ebenfalls möglichst wenige Server verwendet, um die Komponenten zu hosten, die die logischen Ebenen von Team Foundation bilden. Diese Topologie berücksichtigt jedoch den höheren Bedarf der Rechenleistung, der mit dem Erstellen und Testen von Software einher geht. Die folgende Abbildung zeigt eine einfache Topologie für Team Foundation Server:

In diesem Beispiel werden die Webdiensten und Datenbanken für Team Foundation auf dem gleichen physischen Server gehostet, die Builddienste sind jedoch auf einem separaten Computer installiert. Der Zugriff auf Team Foundation Server erfolgt über Clientcomputer in derselben Domäne oder Arbeitsgruppe. Dieses Beispiel ist für ein kleines Produktentwicklungsteam mit weniger als 100 Benutzern vorgesehen.

In dieser Konfiguration installieren Sie den Computer, auf dem Team Foundation Build und die Testkomponenten des Teams ausgeführt werden, auf einem spezifischen Computer für diesen Zweck. Diese Konfiguration eignet sich am besten für kleinere Entwicklungsprojekte mit normalen Build- und Testanforderungen, in denen jedoch die Leistung wichtig ist.

Siehe auch

Konzepte

Beispiele für Topologie mit mittlerer Komplexität
Beispiele für die komplexe Topologie
Architektur von Team Foundation Server


Beispiele für Topologie mit mittlerer Komplexität

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Beispiele für Topologie mit mittlerer Komplexität
Siehe auch Feedback senden

Sie können Visual Studio Team Foundation Server in verschiedenen Topologiekonfigurationen konfigurieren. Je einfacher die Topologie ist, umso leichter ist die Verwaltung einer Team Foundation Server-Bereitstellung. Stellen Sie daher die einfachste Topologie bereit, die den Anforderungen Ihres Unternehmens entspricht. In diesem Thema wird eine Topologie mit mittlerer Komplexität beschrieben, in der die logischen Komponenten der Daten- und Anwendungsebene von Team Foundation auf separaten physischen Servern installiert sind. Clientcomputer innerhalb der vertrauenswürdigen Domänen können auf Team Foundation Server zugreifen.

Servertopologie mit mittlerer Komplexität

In einer Topologie mit mittlerer Komplexität werden mindestens zwei Server zum Hosten logischer Team Foundation-Komponenten der Anwendungs- und Datenebene verwendet. Die folgende Abbildung zeigt eine Topologie mit mittlerer Komplexität für Team Foundation Server:

In diesem Beispiel werden die Dienste für Team Foundation Server auf einem Server bereitgestellt, der auch als Anwendungsebenenserver bezeichnet wird. Die Datenbanken für Team Foundation Server werden auf einem separaten Server installiert, der als Datenebenenserver bezeichnet wird. Ein separater Server hostet die SharePoint-Webanwendung für Team Foundation Server, und ein weiterer Server hostet die Instanz von SQL Server Reporting Services für Team Foundation Server. Das Portal für jedes Teamprojekt wird in der SharePoint-Webanwendung gehostet. Daher muss der Administrator Berechtigungen für die Benutzer dieses Projekts in der Webanwendung konfigurieren. Das gleiche gilt für die Konfiguration von Benutzerberechtigungen in SQL Server Reporting Services. Team Foundation Build sowie die Test-Controller des Teams werden auf zusätzlichen Servern bereitgestellt. In dieser Abbildung ist die Domäne für die Clients in Cleveland eine untergeordnete Domäne der übergeordneten Domäne in Seattle. Die untergeordnete Domäne verfügt über eine bidirektionale transitive Vertrauensstellung mit der übergeordneten Domäne. Dem Dienstkonto für Team Foundation Server wird von beiden Domänen vertraut. Benutzer in der untergeordneten Domäne können auf den Server zugreifen, und sie werden automatisch von der integrierten Windows-Authentifizierung authentifiziert. In dieser Konfiguration ist Team Foundation Server-Proxy erforderlich und wird im Büro in Cleveland installiert. Dieses Beispiel ist für ein Produktentwicklungsteam mittlerer Größe mit weniger als 1.000 Benutzern vorgesehen.

Siehe auch

Konzepte

Beispiele für die einfache Topologie
Beispiele für die komplexe Topologie
Architektur von Team Foundation Server


Beispiele für die komplexe Topologie

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Beispiele für die komplexe Topologie
Siehe auch Feedback senden

Sie können Visual Studio Team Foundation Server in verschiedenen Topologiekonfigurationen konfigurieren. Je einfacher die Topologie ist, umso leichter ist die Verwaltung einer Team Foundation Server-Bereitstellung. Stellen Sie daher die einfachste Topologie bereit, die den Anforderungen Ihres Unternehmens entspricht.

In diesem Thema werden zwei komplexe Team Foundation Server-Topologien erläutert. Bei einer komplexe Topologie sind die Team Foundation Server-Komponenten auf mehrere Server verteilt. Darauf wird von Clients in mehreren Domänen an geographisch entfernten physischen Speicherorten zugegriffen. Team Foundation Server-Proxy wird zusätzlich zu optionalen Komponenten installiert, z. B. SharePoint-Produkte und SQL Server Reporting Services. Es gibt verschiedene CodeBases, die jeweils über eigene Teamprojektsammlungen für die Projekte verfügen, die sie verwenden. Die Datenbanken für Teamprojektsammlungen werden auf verschiedenen Servern gespeichert, auf denen SQL Server ausgeführt wird.

Komplexe Topologie mit einer einzelnen Domäne

Bei einer komplexen Servertopologie werden mehrere Server in Clustern oder anderen Failover-Konfigurationen zum Hosten logischer Team Foundation-Komponenten der Anwendungs- und Datenebene verwendet. Die folgende Abbildung veranschaulicht eine komplexe Topologie mit einer einzelnen Domäne:

Beispiel für eine komplexe Topologie mit einer Domäne

Diese Beispieltopologie ähnelt der Topologie mittlerer Komplexität (siehe Beispiele für Topologie mit mittlerer Komplexität). Die Team Foundation Server-Dienste werden auf einem Server bereitgestellt, und die Team Foundation Server-Datenbanken werden auf einem separaten Server installiert, wobei Team Foundation Build sowie die Test-Agents und Test-Agent-Controller des Teams auf zusätzlichen Servern bereitgestellt werden. Außerdem sind Failoverkomponenten hinzugefügt worden. Die Team Foundation-Datenbanken wurden auf einem SQL Server-Cluster installiert.

Das Beispieldiagramm zeigt untergeordnete Domänen in Seattle und Cleveland, jede mit einer bidirektionalen transitiven Vertrauensstellung zur übergeordneten Domäne. Dem Dienstkonto für Team Foundation Server wird von beiden Domänen vertraut. Von jeder geografisch entfernten untergeordneten Domäne wird eine Verbindung mit eingeschränkter Bandbreite verwendet. Da der Abruf einer Eintragung aus der Versionscodeverwaltungskomponente von Team Foundation Server bei eingeschränkter Bandbreite sehr viel Zeit in Anspruch nehmen kann, wird in jeder untergeordneten Domäne ein Team Foundation Server-Proxy installiert, der als Proxycache für Versionskontrolldateien fungiert. Alle Clientanforderungen mit Ausnahme von get-Anforderungen des Versionskontrollcodes werden direkt an die Anwendungsebene weitergeleitet. Diese Anforderungen werden über den Team Foundation Server-Proxy geleitet, auf dem alle heruntergeladenen Quelldateien zwischengespeichert werden.

Die Topologie in diesem Beispiel nimmt sich auch der Themen Fehlertoleranz und Hochleistung an. Die Fehlertoleranz auf Datenebene wird mithilfe der Cluster-Technologien von SQL Server bereitgestellt. Mehrere SharePoint-Webanwendungen für die Verwendung durch Teamprojekte innerhalb von Auflistungen werden in einer SharePoint-Webfarm konfiguriert. Die Datenbanken für Teamprojektsammlungen werden auf mehrere SQL Server-Instanzen verteilt, um eine höhere Leistung und leichtere Verwaltung zu ermöglichen. SQL Server Reporting Services und SQL Server Analysis Servers werden für eine höhere Leistung auf separaten Servern ausgeführt.

Dieses Beispiel ist für ein großes Produktentwicklungsteam (bis zu 2.000 Benutzer) vorgesehen.

Komplexe Topologie mit mehreren Domänen

In einer komplexen Servertopologie mit mehreren Domänen werden mehrere Server in zwei oder mehr Domänen verwendet. Ähnlich wie bei der komplexen Topologie mit einer einzelnen Domäne nutzt die Bereitstellung Cluster oder andere Failoverkonfigurationen, um die Komponenten der Datenebene für Team Foundation zu hosten. Die Administratoren dieser Bereitstellung haben einen Netzwerklastenausgleich konfiguriert und mehrere Anwendungsebenenserver hinzugefügt, um die Last zu verteilen. Die folgende Abbildung zeigt eine komplexe Topologie mit mehreren Domänen:

Komplexe Topologie mit mehreren Domänen Komplexe Topologie mit mehreren Domänen fortgesetzt

Wie im vorherigen Beispiel ist auch diese Topologie für Fehlertoleranz und Hochleistung konfiguriert. Zudem ist diese Topologie auf mehrere Domänen verteilt, von denen einige voll vertrauenswürdige untergeordnete Domänen der übergeordneten Domänen sind, während eine Domäne (IsolatedLab.com) vollkommen eigenständig ist. Die von Team Foundation Server verwendeten Dienstkonten sind voll vertrauenswürdige Mitglieder aller Domänen, und sowohl in der übergeordneten Domäne als auch in der separaten Domäne wurden die notwendigen Benutzerkonten für Benutzer konfiguriert, die in beiden Domänen arbeiten müssen. Die Firewalls wurden so konfiguriert, dass sie den Datenverkehr über die von Team Foundation Server benötigten Anschlüsse zuzulassen.

Siehe auch

Konzepte

Beispiele für die einfache Topologie
Beispiele für die komplexe Topologie


Beispiele für gehostete Topologie

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Beispiele für gehostete Topologie
Siehe auch Feedback senden

Anstelle Visual Studio Team Foundation Server (TFS) lokal zu installieren und zu konfigurieren, bietet Ihnen Microsoft die Möglichkeit, die Team Foundation-Dienstvorschau zu verwenden, wobei von Microsoft alle Serverelemente Ihrer Bereitstellung in der Cloud gehostet werden. Dies vereinfacht die Bereitstellung erheblich, da die einzigen Aspekte der Architektur, die Sie berücksichtigen müssen, sicherstellen, dass die Benutzer über den Internetzugang und die Berechtigungen verfügen, die für den Zugriff auf das Projekt erforderlich sind.

Die gehostete Umgebung.

TFS in der Cloud

Nicht von Microsoft stammende Marken, die in diesem Bild angezeigt werden, bleiben Eigentum der jeweiligen Inhaber.

Wenn Sie sich für die Verwendung des Diensts entscheiden, wird das gesamte Projekt, einschließlich Quellcode, Arbeitsaufgaben, Buildkonfigurationen und Teamfunktionen, in der Cloud gehostet. Von C# zu Python, von Windows zu Android - Ihnen steht eine Vielzahl von Sprachen, Plattformen und Tools zur Verfügung, aus denen Sie wählen können. Die einzigen Aspekte der Architektur, die Sie verwalten müssen, sind die Zugriffsanforderungen.

Wenn Sie die Team Foundation-Dienstvorschau nutzen, verwenden Sie einen Webbrowser und das Microsoft-Konto, um eine Verbindung mit dem gehosteten Dienst herzustellen. Sie können Teamprojekte erstellen, dem Team Mitglieder hinzuzufügen und so arbeiten wie bei einer lokal installierten Bereitstellung, aber ohne den Mehraufwand für die Verwaltung der Server. Die Anwendungsebene, die Datenebene und die Buildserver werden mithilfe der Microsoft Cloud-Plattform und SQL Server Azure für Sie gehostet. Dies ist die am besten geeignete Architektur, wenn Sie die Funktionen von TFS, wie beispielsweise die Quellcode-, Arbeitsaufgaben- und Agile-Projektverwaltung nutzen möchten, die Verwaltung der physischen Infrastruktur aber nicht unterstützt werden soll. Es ist zudem eine großartige Möglichkeit, die in Betracht gezogen werden sollte, wenn Ihre Teammitglieder weltweit verteilt sind. Da der Dienst vollständig webbasiert ist, sind die zu verwaltenden Aspekte ausschließlich jene, bei denen es darum geht, ob die Teammitglieder Zugriff auf das Internet haben, ob ihre Firewalls Port 443 blockieren oder ob ein Microsoft-Konto für jedes Teammitglied zu jedem der Projekte, die für Sie gehostet werden, hinzugefügt werden kann.

Einfaches Diagramm eines gehosteten TFS-Dienstes.

Da die Serverressourcen für die Team Foundation-Dienst-Vorschau für Sie verwaltet werden, kann dies eine gute Wahl für Teams sein, bei denen unvorhersehbare Verwendungsspitzen auftreten, oder die die Ressourcen für ein Projekt erheblich erweitern oder aber einschränken müssen. Die Dienstinfrastruktur ist so konzipiert, dass schwankende Anforderungen erfasst werden und die Struktur problemlos erweitert wird, um die größten Projekte zu verwalten. Es ist zudem eine großartige Möglichkeit für Teams mit geringen oder nicht vorhandenen IT-Supportressourcen.

Anders als bei lokalen Bereitstellungen unterstützt der gehostete Dienst nicht die Integration in SharePoint-Produkte oder SQL Server Reporting Services und auch nicht die vollständige Integration in Visual Studio Lab Management. Aufgrund dieser Einschränkung stellt der gehostete Dienst keine gute Wahl dar, wenn das Team ausführliche Berichte zum Fortschritt benötigt, die bei der Integration zwischen den TFS- und SQL Server-Berichterstellungsdiensten verfügbar sind, oder aber virtuelle Labcomputer und automatisierte Tests benötigt, die über Visual Studio Lab Management bereitgestellt werden. Obwohl der Dienst eine Teamseite und ein Dashboard bereitstellt, ist dieser nicht so aussagekräftig wie die Integration, die zwischen TFS, SQL Server Reporting Services und SharePoint Foundation 2010 verfügbar ist.

Außerdem ist die Team Foundation-Dienstvorschau keine gute Wahl, wenn für das Projekt strikte Richtlinien eingehalten werden müssen. Wählen Sie den gehosteten Dienst nicht aus, wenn Sie in einem streng regulierten Umfeld wie der Finanzbranche als Entwickler tätig sind oder das Projekt zu Überwachungszwecken die vollständige Kontrolle über die zugehörige Infrastruktur erfordert.

Beispiele für gehostete Bereitstellungen

Sie können festlegen, dass die Buildcomputerressourcen in der Cloud zusammen mit den übrigen serverseitigen Aspekten der Bereitstellung gehostet werden. Sie können aber auch lokale Buildserver verwenden. Sie verwenden möglicherweise einen gehosteten Buildserver für integrierte Builds, während die Entwickler lokale Buildserver verwenden, um vorläufige Builds auszuführen.

Gehostete Topologie mit Build in der Cloud

Gehostete Topologie mit lokalem Buildserver

Weitere Informationen zu dem Dienst und zu den Optionen für seine Verwendung finden Sie in der Team Foundation-Dienstvorschau.

Siehe auch

Konzepte

Architektur von Team Foundation Server
Installieren von Team Foundation Server und Visual Studio ALM
Planen und Nachverfolgen von Projekten


Verwalten der Serverkonfiguration

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten der Serverkonfiguration
Siehe auch Feedback senden

Je nach anfänglicher Installation und Konfiguration müssen Sie Visual Studio Team Foundation Server (TFS) über einen oder mehrere Server hinweg verwalten, um Ihre Bereitstellung zu warten und zu betreiben. Die folgende Abbildung veranschaulicht beispielsweise die logische Architektur einer Bereitstellung von TFS, die sowohl in SQL Server Reporting Services als auch in SharePoint-Produkte integriert ist:

Datenbankbeziehungen mit SharePoint-Produkten

Wie in der vorherigen Abbildung zu sehen ist, müssten Sie die Konfiguration der Komponenten, Benutzer, Gruppen und Berechtigungen über mehrere Server hinweg verwalten. Stellen Sie sicher, dass auf keinem der Server Firewalls oder andere Geräte, die den Netzwerkverkehr blockieren, an den für die Kommunikation zwischen den Servern erforderlichen Anschlüssen aktiv sind. Stellen Sie außerdem sicher, dass alle von der Bereitstellung benötigten Dienste ausgeführt werden und automatisch gestartet werden. Abschließend müssen Sie sicherstellen, dass dem von TFS verwendeten Dienstkonto von allen Computern in der Bereitstellung vertraut wird.

Sie können der Bereitstellung Ressourcen hinzufügen oder diese entfernen, um den veränderlichen Anforderungen des Unternehmens und der mit TFS unterstützten Softwareprojekte gerecht zu werden. Sie können die Berichterstellung und Webressourcen jederzeit hinzufügen oder entfernen. Zudem können Sie mehr als eine Instanz von SQL Server verwenden, um die Datenbanken für die Bereitstellung zu hosten. Sie können z. B. einen Server, der SQL Server Reporting Services ausführt, zur Bereitstellung hinzufügen, nachdem Sie TFS installiert und anfänglich konfiguriert haben. Sie können auch die Version von SharePoint-Produkte aktualisieren, die die Bereitstellung unterstützt, und die Funktionen dieses Produkts zu den Teamprojekten hinzufügen, die bereits in der Bereitstellung vorhanden sind.

Die Verwaltungskonsole für Team Foundation unterstützt Sie bei der Verwaltung und Überwachung der Serverkonfiguration. Zusätzlich dazu stehen Ihnen die Befehlszeilentools in TFS zur Verfügung. Sowohl die Konsole als auch die Tools werden zusammen mit TFS installiert.

Allgemeine Aufgaben

Allgemeine Aufgaben

Unterstützender Inhalt

Verwalten der Server und Ressourcen in der Bereitstellung: Nach der Installation und Erstkonfiguration von TFS können Sie die Konfiguration zur Unterstützung der Entwicklungsprojekte überwachen und ändern.

  • Hinzufügen und Verwalten von SharePoint-Webanwendungen: Sie können Teamprojekte mit Ressourcen in SharePoint-Produkte unterstützen, indem Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte auf einem oder mehreren Servern installieren und SharePoint-Webanwendungen als verfügbare Ressourcen für Teamprojekte und Teamprojektsammlungen hinzufügen.

  • Hinzufügen und Verwalten einer Berichtsressource: Sie können die Teamprojekte mit Berichten und Berichterstellungsfunktionen unterstützen, indem Sie einen Berichtsserver hinzufügen. Nachdem Sie der Bereitstellung einen Berichtsserver hinzugefügt haben, können Sie Berichtsressourcen für die Teamprojektsammlungen und die Projekte in diesen Auflistungen konfigurieren.

  • Hinzufügen von virtuellen Computern als Testressourcen: Sie können Visual Studio Lab Management so konfigurieren, dass die Entwicklung und der Test von Code unterstützt wird.

  • Überwachen der Server und Ressourcen in der Bereitstellung: Nach der Installation und Erstkonfiguration von TFS können Sie die Konfiguration zur Unterstützung der Entwicklungsprojekte überwachen und ändern.

  • Sichern der Daten: Sie können Wartungspläne erstellen, um die Bereitstellung zu schützen.

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung

Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server

Zugriff auf Funktionen über Webberechtigungen

Hinzufügen eines Berichtsservers zur Bereitstellung

Konfigurieren von Lab Management für SCVMM-Umgebungen

Ändern von vorhandenen Konfigurationen von Lab-Management

Öffnen der Team Foundation-Verwaltungskonsole

Überprüfen von Serverstatus und -einstellungen

Auf dem Server installierte Updates anzeigen

Beenden und Starten von Diensten, Anwendungspools und Websites

Sichern und Wiederherstellen der Bereitstellung

Organisieren und Verwalten verwandter Projekte: Sie können alle Entwicklungsprojekte für eine bestimmte Codebasis und die Ressourcen, die diese unterstützen, in einer Teamprojektsammlung organisieren. Es können beliebig viele Teamprojektsammlung zur Unterstützung Ihrer Entwicklungsaufgaben erstellt werden.

Organisieren des Servers mit Teamprojektsammlungen

Erstellen einer Teamprojektsammlung

Hinzufügen von Ressourcen zu vorhandenen Teamprojekten: Sie können die Ressourcen ergänzen oder ändern, die Teamprojektmitgliedern zur Verfügung stehen, z. B. Teamprojektportal, E-Mail-Benachrichtigung über Ereignisse oder freigegebene Dokumentbibliothek.

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten

Konfigurieren eines Standardspeicherorts für Teamprojektportale

Konfigurieren von E-Mail-Benachrichtigungen und Angeben des SMTP-Servers

Verwalten der Dienste und Dienstkonten: Sie können Dienste bei Bedarf für Wartungsaufgaben starten und beenden. Darüber hinaus können Sie die Konten oder Kennwörter ändern, die in TFS als Dienstkonten verwendet werden.

Team Foundation Server-Dienste und -Dienstkonten

Dienstkonten und Abhängigkeiten in Team Foundation Server

Team Foundation-Hintergrundauftrags-Agent

Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services

Ändern des Dienstkontos oder Kennworts für Team Foundation Server

Siehe auch

Aufgaben

Hinzufügen von Benutzern zu Teamprojekten

Konzepte

Planen und Nachverfolgen von Projekten
Planen und Nachverfolgen von Projekten
Sichern und Wiederherstellen der Bereitstellung
Technische Referenz für Team Foundation

Weitere Ressourcen

Verwalten von Berechtigungen
Verwalten der Team Foundation-Versionskontrolle
Verwalten des Team Foundation Builds


Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
Siehe auch Feedback senden

Sie können zahlreiche Konfigurations- und Wartungsaufgaben für die Bereitstellung von Visual Studio Team Foundation Server (TFS) mit der Verwaltungskonsole für Team Foundation ausführen. Diese Konsole ist standardmäßig auf allen Servern installiert, auf denen Sie eine Komponente von Team Foundation installieren. Wenn alle Komponenten auf einem einzelnen Server installiert sind, stellt die Verwaltungskonsole Verwaltungsknoten für alle Komponenten in der Bereitstellung bereit. Verwendet die Bereitstellung hingegen mehrere Server, Sie müssen die Konsole auf dem Server öffnen, auf dem die zu verwaltende Komponente ausgeführt wird.

Allgemeine Aufgaben

Titel | Beschreibung
Hinzufügen und Verwalten von SharePoint-Webanwendungen: Sie können Teamprojekte mit Ressourcen in SharePoint-Produkte unterstützen, indem Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte auf einem oder mehreren Servern installieren und SharePoint-Webanwendungen als verfügbare Ressourcen für Teamprojekte und Teamprojektsammlungen hinzufügen. | Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server
Hinzufügen und Verwalten einer Berichtsressource: Sie können die Teamprojekte mit Berichten und Berichtsfunktionen unterstützen, indem Sie einen Server hinzufügen, auf dem SQL Server Reporting Services ausgeführt wird. Nachdem Sie der Bereitstellung einen Berichtsserver hinzugefügt haben, können Sie Berichtsressourcen für die Teamprojektsammlungen und die Projekte in diesen Auflistungen konfigurieren. | Hinzufügen eines Berichtsservers zur Bereitstellung
Hinzufügen von virtuellen Computern als Entwicklungs- und Testressourcen: Sie können Visual Studio Lab Management so konfigurieren, dass für die Entwicklung, die Bereitstellung und den Test der Anwendung virtuelle Computern unterstützt werden. | Konfigurieren von Lab Management für SCVMM-Umgebungen Gewusst wie: Ändern der Hostgruppen für die Teamprojektsammlungen Gewusst wie: Ändern der Bibliotheksfreigabe für die Teamprojektsammlungen
Organisieren und Verwalten von Projekten und zugehörigen Ressourcen: Sie können die Teamprojekte effizienter verwalten, indem Sie diese gruppieren und ihnen die gleichen Ressourcen zuweisen. | Organisieren des Servers mit Teamprojektsammlungen Festlegen von Administratorberechtigungen für Teamprojektsammlungen Hinzufügen von Benutzern zu Teamprojekten Zugriff auf Funktionen über Webberechtigungen Erste Schritte im Team Agile-Planung und -Iterationen Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams
Verwalten von Benutzern und Gruppen auf Serverebene: Sie können die Standardgruppen und -berechtigungen auf Serverebene verwenden, um Benutzer und deren Berechtigungen in der Bereitstellung zu verwalten, oder Sie erstellen benutzerdefinierte Gruppen. | Festlegen von Administratorberechtigungen für Team Foundation Server
Überwachen der Server und Ressourcen in der Bereitstellung: Nach der Installation und Erstkonfiguration von Visual Studio Team Foundation Server können Sie die Konfiguration zur Unterstützung der Entwicklungsprojekte überwachen und ändern. | Öffnen der Team Foundation-Verwaltungskonsole Überprüfen von Serverstatus und -einstellungen

Siehe auch

Aufgaben

Erstellen einer Teamprojektsammlung

Konzepte

Organisieren des Servers mit Teamprojektsammlungen
Sichern und Wiederherstellen der Bereitstellung
Konfigurieren von Benutzern, Gruppen und Berechtigungen

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten
Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]
Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]


Öffnen der Team Foundation-Verwaltungskonsole

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Öffnen der Team Foundation-Verwaltungskonsole
Siehe auch Feedback senden

Sie können verschiedene Aspekte der Bereitstellung von Team Foundation mit der Verwaltungskonsole für Team Foundation konfigurieren und verwalten. Sie können zum Beispiel einen Server zum Hosten von Teamprojektportalen hinzufügen, Teamprojektsammlungen erstellen und ändern sowie das Dienstkonto für Visual Studio Team Foundation Server ändern. Diese Verwaltungskonsole wird installiert, wenn Sie eine oder mehrere der folgenden Komponenten auf einem Server installieren:

  • eine Anwendungsebene für Team Foundation Server

  • die Erweiterungen für SharePoint-Produkte

  • Team Foundation Build

  • Visual Studio Lab Management

Weitere Informationen finden Sie unter Die Team Foundation-Verwaltungskonsole.

Erforderliche Berechtigungen

Zur Durchführung dieser Prozeduren müssen Sie Mitglied der Gruppe Team Foundation Administratoren sein, oder Ihre Berechtigung Serverebeneninformationen bearbeiten muss auf Zulassen festgelegt sein. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So öffnen Sie die Verwaltungskonsole über das Startmenü

  1. Klicken Sie auf einem Server, auf dem eine oder mehrere Komponenten von Team Foundation ausgeführt werden (wie in diesem Thema aufgeführt, auf Start, zeigen Sie auf Alle Programme, und klicken Sie dann auf Microsoft Team Foundation Server.

  2. Wählen Sie Team Foundation Server-Verwaltungskonsole aus.

    Hinweis Hinweis

    Wenn Team Foundation Server-Verwaltungskonsole nicht als Menüoption angezeigt wird, haben Sie möglicherweise keine Berechtigung, sie zu öffnen. Sie können versuchen, die Konsole an einer Eingabeaufforderung zu öffnen. Möglicherweise sind Sie dann aber nicht in der Lage, auf einige oder alle Funktionen der Verwaltungskonsole zuzugreifen.

    Die Verwaltungskonsole wird geöffnet. Sie müssen ggf. kurz warten, bevor alle Informationen in allen Knoten der Konsole angezeigt werden.

So öffnen Sie die Verwaltungskonsole an einer Eingabeaufforderung

  1. Öffnen Sie auf einem Server, auf dem eine oder mehrere Komponenten von Team Foundation ausgeführt werden (wie weiter oben in diesem Thema aufgeführt) ein Eingabeaufforderungsfenster, und ändern Sie die Verzeichnisse in das Toolverzeichnis für Team Foundation Server.

    Das Toolverzeichnis befindet sich standardmäßig unter Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie TFSMgmt.exe ein, und drücken Sie dann die EINGABETASTE.

    Die Verwaltungskonsole wird geöffnet. Sie müssen ggf. kurz warten, bevor alle Informationen in allen Knoten der Verwaltungskonsole angezeigt werden.

    Hinweis Sie können die Verwaltungskonsole an einer Eingabeaufforderung öffnen, auch wenn Sie nicht alle erforderlichen Berechtigungen zum Anzeigen oder Ändern einiger oder aller Informationen in der Konsole haben.

Siehe auch

Konzepte

Die Team Foundation-Verwaltungskonsole
Architektur von Team Foundation Server
Organisieren des Servers mit Teamprojektsammlungen


Überprüfen von Serverstatus und -einstellungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Überprüfen von Serverstatus und -einstellungen
Siehe auch Feedback senden

In der Verwaltungskonsole von Team Foundation können Sie die aktuellen Konfigurationseinstellungen überprüft, die die Bereitstellung verwendet. Die Konsole bietet zudem Informationen über den Verbindungsstatus zwischen Visual Studio Team Foundation Server und den integrierten Komponenten, z. B. SQL Server Reporting Services und SharePoint-Produkte.

Team Foundation Server erstellt bei jeder Änderung der Bereitstellungskonfiguration eine Protokolldatei. Sie können diese Dateien überprüfen, um sich über den Verlauf von Änderungen oder die Ursache von Problemen und deren Behebung zu informieren.

So überprüfen Sie den Serverstatus

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Wählen Sie unter dem Servernamen Anwendungsebene aus.

  3. Überprüfen Sie den Status der Serverkomponenten von Team Foundation.

So überprüfen Sie Protokolldateien

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Wählen Sie unter dem Servernamen Protokolle aus.

  3. Suchen Sie in der Liste nach dem Protokoll, das Sie überprüfen möchten, und doppelklicken Sie dann darauf, um es zu öffnen. Sie können es auch markieren und dann die EINGABETASTE drücken.

    Wählen Sie alternativ Protokollordner öffnen aus, um den Ordner mit allen Protokolldateien zu öffnen.

Siehe auch

Aufgaben

Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung
Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server

Konzepte

Organisieren des Servers mit Teamprojektsammlungen

Weitere Ressourcen

Configure or Reconfigure Lab Management
Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung
Siehe auch Feedback senden

Um Teamprojekte in SharePoint-Websites zu integrieren, müssen Sie standardmäßigen und erweiterten Installationen von Visual Studio Team Foundation Server eine oder mehrere SharePoint-Webanwendungen hinzufügen. Standardinstallationen von Team Foundation Server können keine SharePoint-Webanwendungen hinzugefügt werden. Wenn Sie SharePoint-Webanwendungen hinzufügen, können Mitglieder Ihres Teams die folgenden Aufgaben ausführen:

  • Automatisches Erstellen und Konfigurieren eines Teamprojektportals beim Erstellen eines Teamprojekts oder einer Teamprojektsammlung

  • Erstellen eines Ordners mit freigegebenen Dokumenten für Projekte in Team Explorer

  • Erstellen, Speichern und Freigeben von Prozessleitfäden für das Projekt auf Grundlage der Prozessvorlage für dieses Projekt

Um eine Webanwendung hinzuzufügen, müssen Sie Einstellungen auf dem Server, der die Webanwendung hostet, und auf dem Server, der die Anwendungsebene für Team Foundation hostet, konfigurieren. Außerdem müssen Sie das von SharePoint-Produkte verwendete Dienstkonto zu der Gruppe SharePoint-Webanwendungsdienste in Team Foundation Server hinzufügen. Alle diese Aufgaben werden in der Verwaltungskonsole für Team Foundation ausgeführt.

Um Team Foundation Server und SharePoint-Produkte zu integrieren, müssen alle nachfolgenden Bedingungen erfüllt sein:

  • Team Foundation Server muss mit dem Speicherort jeder SharePoint-Webanwendung konfiguriert sein, die Sie in der Bereitstellung verwenden möchten.

  • Der Server, der die SharePoint-Webanwendung hostet, muss mit dem Speicherort von Team Foundation Server konfiguriert sein.

  • Das Dienstkonto für jede SharePoint-Webanwendung, die Sie verwenden möchten, muss der entsprechenden Berechtigungsgruppe in Team Foundation Server hinzugefügt werden.

  • Das Dienstkonto für Team Foundation Server (TFSService) muss über die notwendigen Berechtigungen verfügen, um Websites oder Siteauflistungen innerhalb der SharePoint-Webanwendung zu erstellen.

Sie können abhängig von Ihren geschäftlichen Anforderungen mehreren SharePoint-Webanwendungen Zugriff erteilen, um Ihre Bereitstellung von Team Foundation Server zu unterstützen. Sie können z. B. einer SharePoint-Webanwendung Zugriff erteilen, die in der aktuellen Version von Team Foundation Server erstellte Projekte unterstützt. Anschließend erstellen Sie eine Umleitung zu einer anderen Webanwendung, die in der früheren Version von Team Foundation Server erstellte Projekte unterstützt.

Erforderliche Berechtigungen

Um diese Prozeduren auszuführen, müssen Sie entweder Mitglied der folgenden Gruppen sein oder die folgenden Berechtigungen haben:

  • Gruppe Team Foundation-Administratoren, oder die Berechtigungen Instanzenebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten sind auf Zulassen festgelegt.

  • Gruppe Administratoren auf dem Server, auf dem die Anwendungsebene ausgeführt wird.

  • Gruppe Administratoren auf dem Server, auf dem die Team Foundation Server-Erweiterungen für SharePoint-Produkte installiert sind. Der Server, auf dem die Erweiterungen installiert sind, hostet die SharePoint-Webanwendung, für die Sie Zugriff erteilen möchten.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So erteilen Sie Zugriff zwischen einer SharePoint-Webanwendung und Team Foundation Server

  1. Öffnen Sie auf dem Server, auf dem Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte installiert haben, die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie die Struktur, und klicken Sie auf Erweiterungen für SharePoint-Produkte.

  3. Klicken Sie im Bereich Erweiterungen auf Zugriff erteilen.

    Das Fenster Zugriff für Team Foundation Server wird geöffnet.

  4. Geben Sie unter URL für Team Foundation Server die öffentliche URL für Team Foundation Server ein.

    Sie können diese Informationen im Knoten Anwendungsebene der Verwaltungskonsole überprüfen, an der Sie die Anwendungsebene für Team Foundation Server installiert haben.

  5. Wählen Sie in SharePoint-Webanwendung die URL für die SharePoint-Webanwendung aus, die Sie aus der Dropdownliste verwenden möchten.

    Wenn Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte auf dem Server installiert haben, der die SharePoint-Webanwendungen hostet, werden alle SharePoint-Webanwendungen auf diesem Server in der Liste angezeigt. Wenn keine Webanwendungen angezeigt werden, wurden entweder die Erweiterungen nicht ordnungsgemäß installiert, oder es wurden keine SharePoint-Webanwendungen konfiguriert. Weitere Informationen zum Installieren der Erweiterungen finden Sie unter Konfigurieren von Team Foundation Server-Erweiterungen für SharePoint-Produkte.

  6. (Optional) Geben Sie unter Websiteerstellung auf folgenden Pfad beschränken den Pfad der Siteauflistung an, in dem alle von Team Foundation Server verwendeten Sites erstellt werden sollen.

    Dieser Schritt wird für die meisten Bereitstellungen empfohlen, da dieser sicherstellt, dass die Bereitstellung ordnungsgemäß gesichert und wiederhergestellt werden kann.

  7. Geben Sie unter Definition für Unternehmensanwendung den Namen der Definition an, die Sie für Team Foundation Server erstellt haben.

    Dieser Schritt ist nur erforderlich, wenn Sie eine Webanwendung konfigurieren, die auf Microsoft Office SharePoint Server 2007 oder SharePoint Server 2010 gehostet wird, und Berichte und Dashboards fehlerfrei ausgeführt werden sollen. Füllen Sie dieses Feld nicht aus, wenn Sie eine Webanwendung konfigurieren, die auf SharePoint Foundation 2010 gehostet wird.

  8. Wählen Sie nach dem Bereitstellen der erforderlichen Informationen OK aus.

    Wenn alle Werte korrekt sind, wird der Zugriff erteilt. Dieser Vorgang kann einen Moment dauern.

So erstellen Sie eine Umleitung, damit eine SharePoint-Webanwendung Team Foundation Server 2008 oder 2005 unterstützt

  1. Öffnen Sie auf dem Server, auf dem Sie die Team Foundation Server-Erweiterungen für SharePoint-Produkte installiert haben, die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie die Struktur, und klicken Sie auf Erweiterungen für SharePoint-Produkte.

  3. Klicken Sie im Bereich Erweiterungen auf Umleitung für frühere Versionen erstellen.

    Das Fenster Umleitung für Berichtsserver wird geöffnet.

  4. Wählen Sie in SharePoint-Webanwendung die URL für die Webanwendung aus, die Sie aus der Dropdownliste verwenden möchten.

  5. (Optional) Geben Sie unter Relativer Pfad den Pfad für den Speicherort an, an dem Sie Projektwebsites für frühere Versionen von Team Foundation Server erstellen und unterstützen möchten.

    Wichtiger Hinweis Wichtig

    Sie müssen einen Pfad angeben, der bereits vorhanden ist. Sie können auf dieser Seite keinen Pfad erstellen.

  6. Geben Sie unter URL des Berichts-Managers die URL für den Berichts-Manager an (ggf. einschließlich des Instanznamens).

  7. Geben Sie unter Reporting Services-Webdienst-URL die URL für den Webdienst von SQL Server Reporting Services an.

  8. Wählen Sie nach dem Bereitstellen der erforderlichen Informationen OK aus.

    Wenn alle Werte korrekt sind, wird die Umleitung erstellt. Dieser Vorgang kann einen Moment dauern.

So erteilen Sie Zugriff zwischen Team Foundation Server und einer SharePoint-Webanwendung

  1. Öffnen Sie auf dem Server, auf dem Sie die Anwendungsebene für Team Foundation Server installiert haben, die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie die Struktur, und klicken Sie auf SharePoint-Webanwendungen.

  3. Klicken Sie im Bereich SharePoint-Webanwendungen auf Hinzufügen.

    Das Fenster SharePoint-Webanwendungseinstellungen wird geöffnet.

  4. Geben Sie auf der Registerkarte Allgemeinen unter Anzeigename einen Namen für diese SharePoint-Webanwendung an.

    Dieser Name wird in der Liste der Webanwendungen angezeigt. Wenn Sie beabsichtigen, mehr als eine SharePoint-Webanwendung in der Bereitstellung zu verwenden, sollten Sie einen Namen angeben, anhand dem Benutzer diese Zugriffserteilung von den Zugriffserteilungen für andere SharePoint-Webanwendungen unterscheiden können. Sie können darüber hinaus im Feld Beschreibung eine Beschreibung hinzufügen, um diese Zugriffserteilung leichter zu identifizieren, diese Beschreibung wird jedoch nicht in der Liste angezeigt.

  5. Geben Sie unter Webanwendungs-URL die URL der SharePoint-Webanwendung ein, für die Zugriff erteilt werden soll.

    Dieser Name sollte mit dem Namen der Webanwendung in SharePoint-Produkte übereinstimmen. Wenn die SharePoint-Webanwendung mit einer anderen Anschlussnummer als dem Standardanschluss (80) konfiguriert wurde, müssen Sie zudem die Anschlussnummer angeben.

  6. Geben Sie unter URL der Zentraladministration die URL und Anschlussnummer für die SharePoint-Zentraladministration an.

    Hinweis Hinweis

    Wenn Sie über Administratorberechtigungen für den Server verfügen, auf dem SharePoint-Produkte ausgeführt wird, können Sie diese URL und Anschlussnummer anzeigen, indem Sie die SharePoint-Zentraladministration öffnen. Andernfalls müssen Sie diese Informationen bei einem Administrator für diesen Server erfragen.

  7. Geben Sie unter Standardort für Teamprojektsammlungs-Websites den relativen Pfad für die Siteauflistung an, den Sie als Stamm für Teamprojektsammlungen nutzen möchten, die diese SharePoint-Webanwendung verwenden.

    Hinweis Hinweis

    Standardmäßig wird als Speicherortname /sites verwendet, aber Sie können einen beliebigen benannten Pfad für Websitesammlungen entsprechend der Konfiguration in der SharePoint-Zentraladministration verwenden. Wenn Sie Team Foundation Server in einer Umgebung bereitstellen, in der ein anderer Administrator SharePoint-Produkte verwaltet, können Sie sich für Informationen zu dem zu verwendenden Pfad an diesen Administrator wenden.

  8. (Optional) Wenn Sie sicherstellen möchten, dass der eingegebene relative Pfad gültig ist, wählen Sie Pfad überprüfen.

  9. Klicken Sie auf OK.

    Wenn alle Werte richtig sind, wird die SharePoint-Webanwendung in der Liste der Webanwendungen angezeigt, die in Team Foundation Server verfügbar sind. Dieser Vorgang kann einen Moment dauern.

    Hinweis Hinweis

    Team Foundation Server erteilt nicht nur Berechtigungen, sondern versucht zudem, die Dienstkonten für die SharePoint-Webanwendung zu der entsprechenden Gruppe in Team Foundation hinzuzufügen. Wenn einer dieser Versuche scheitert, werden die Konfigurationsinformationen für die Webanwendung gespeichert, und es wird eine Fehlermeldung angezeigt. Sie müssen dann die in der Meldung angegebenen Einstellungen manuell konfigurieren.

Hinzufügen des Dienstkontos für die SharePoint-Webanwendung

Wenn Sie Zugriff zwischen einer SharePoint-Webanwendung und Team Foundation Server erteilen, müssen Sie das Dienstkonto für die Webanwendung zu der Gruppe SharePoint-Webanwendungsdienste in Team Foundation Server hinzufügen.

Hinweis Hinweis

Sie müssen die Schritte zum Gewähren des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server nicht ausführen, wenn das Konto Mitglied der Gruppe "Farmadministratoren" ist. Wenn das Konto Mitglied dieser Gruppe ist, werden diese Einstellungen automatisch konfiguriert, wenn Sie Zugriff zwischen Team Foundation Server und der SharePoint-Webanwendung erteilen.

So fügen Sie ein Dienstkonto für eine SharePoint-Webanwendung zu den SharePoint-Webanwendungsdiensten hinzu

  1. Öffnen Sie auf dem Server, auf dem Sie die Anwendungsebene für Team Foundation Server installiert haben, die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie die Struktur, und klicken Sie auf SharePoint-Webanwendungen.

  3. Klicken Sie im Bereich SharePoint-Webanwendungen im Abschnitt Dienstkonten für die SharePoint-Webanwendungen auf Member hinzufügen.

    Das Dialogfeld Benutzer, Computer oder Gruppen auswählen wird angezeigt.

  4. Geben Sie unter Geben Sie die zu verwendenden Objektnamen ein das hinzuzufügende Konto an, und wählen Sie dann OK.

Siehe auch

Aufgaben

Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server

Konzepte

Team Foundation Server-Berechtigungen
Die Team Foundation-Verwaltungskonsole
Organisieren des Servers mit Teamprojektsammlungen

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server
Siehe auch Feedback senden

Nachdem Sie den Zugriff zwischen einer SharePoint-Webanwendung und Visual Studio Team Foundation Server erteilt haben, können Sie eine oder beide Zugriffserteilungen ändern bzw. löschen. Im Laufe der Zeit müssen Sie die Zugriffserteilungen in der Bereitstellung ggf. ändern, um Änderungen in der Organisation wiederzugeben. Wenn Sie die Bereitstellung beispielsweise so ändern, dass diese HTTPS und Secure Sockets Layer (SSL) anstelle von HTTP verwendet, müssen Sie die Zugriffserteilung für die Webanwendung mit diesen Änderungen aktualisieren.

Hinweis Hinweis

Wenn Sie eine Zugriffserteilung entfernen, sollten Sie überprüfen, ob das Dienstkonto für die SharePoint-Webanwendung von einer anderen Webanwendung in der Bereitstellung verwendet wird. Ist dies nicht der Fall, entfernen Sie das Konto aus der Gruppe "SharePoint-Webanwendungsdienste".

Erforderliche Berechtigungen

Zur Durchführung dieser Prozeduren müssen Sie Mitglied der Gruppe Team Foundation Administratoren sein, oder Ihre Berechtigung Serverebeneninformationen bearbeiten muss in Team Foundation Server auf Zulassen festgelegt sein. Zudem müssen Sie Mitglied der lokalen Gruppe Administratoren auf jedem Server sein, der die Verwaltungskonsole für Team Foundation hostet. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So ändern oder löschen Sie den Zugriff von einer SharePoint-Webanwendung auf Team Foundation Server

  1. Öffnen Sie auf dem Server, auf dem Team Foundation Server-Erweiterungen für SharePoint-Produkte ausgeführt werden, die Verwaltungskonsole für Team Foundation, und erweitern Sie die Struktur.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Klicken Sie unter Team Foundation auf Erweiterungen für SharePoint-Produkte.

  3. Markieren Sie im Bereich Einer SharePoint-Webanwendung Zugriff auf Team Foundation Server erteilen die Zugriffserteilung, die Sie ändern möchten, und führen Sie dann eine der folgenden Anweisungen aus:

    • Wählen Sie Zugriff ändern, ändern Sie die Zugriffserteilung, und wählen Sie dann OK.

    • Wählen Sie Zugriff entfernen, und wählen Sie im Bestätigungsdialogfeld Ja.

So ändern oder löschen Sie den Zugriff von Team Foundation Server auf eine SharePoint-Webanwendung

  1. Öffnen Sie auf dem Server, auf dem Sie die Anwendungsebene für Team Foundation Server installiert haben, die Verwaltungskonsole für Team Foundation, und erweitern Sie die Struktur.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Klicken Sie unter Team Foundation auf SharePoint-Webanwendungen.

  3. Markieren Sie im Bereich SharePoint-Webanwendungen die Zugriffserteilung, die Sie ändern oder löschen möchten, und führen Sie einen der folgenden Schritte aus:

    • Wählen Sie Ändern, ändern Sie die Zugriffserteilung, und wählen Sie dann OK.

      Hinweis Hinweis

      Alle Änderungen an den Zugriffseinstellungen für die Webanwendung können erhebliche Auswirkungen auf die Teamprojekte und Teamprojektauflistungen haben, die diese SharePoint-Webanwendung verwenden. Auf der Registerkarte Abhängige Elemente können Sie die Liste der Auflistungen und Projekte überprüfen, die diese Webanwendung verwenden. Nachdem Sie die Webanwendung geändert haben, sollten Sie ggf. überprüfen, ob die verschiedenen Sites wie gewohnt funktionieren.

    • Wählen Sie Entfernen aus. Klicken Sie im Dialogfeld SharePoint-Webanwendung entfernen auf Ja, wenn Sie sicher sind, dass Sie Zugriff auf die Webanwendung entfernen möchten. Wenn Sie sich nicht sicher sind, wählen Sie Nein.

      Wichtiger Hinweis Wichtig

      Wenn Sie eine Webanwendung entfernen, hat dies erhebliche Auswirkungen auf alle Teamprojekte und Teamprojektsammlungen, die diese SharePoint-Webanwendung verwenden. Wenn Sie den Zugriff für eine SharePoint-Webanwendung entfernen, gehen in allen Teamprojekten bzw. Teamprojektsammlungen, die diese Webanwendung verwenden, die in der Webanwendung gehosteten SharePoint-Bibliotheken oder Teamprojektportale verloren. Bevor Sie eine Webanwendung entfernen, sollten Sie daher sicherstellen, dass Sie die betroffenen Projekte und Auflistungen kennen. Wählen Sie zum Überprüfen der Liste mit den Auflistungen und Projekten, die diese Webanwendung verwenden, Ändern und dann die Registerkarte Abhängige Elemente. Bevor Sie den Zugriff für die Webanwendung entfernen, sollten Sie überprüfen, ob eine dieser Sites noch benötigt wird.

Entfernen des Dienstkontos für die SharePoint-Webanwendung

Wenn Sie eine SharePoint-Webanwendung entfernen oder das Dienstkonto ändern, das eine Webanwendung verwendet, müssen Sie das zugehörige Dienstkonto ggf. manuell entfernen. Wenn ein Dienstkonto von keiner SharePoint-Webanwendung in der Bereitstellung verwendet wird, sollten Sie dieses Dienstkonto aus der Gruppe SharePoint-Webanwendungsdienste von Team Foundation Server entfernen.

So entfernen Sie ein Dienstkonto für eine SharePoint-Webanwendung aus SharePoint-Webanwendungsdiensten

  1. Öffnen Sie auf dem Server, auf dem Sie die Anwendungsebene für Team Foundation Server installiert haben, die Verwaltungskonsole für Team Foundation, und erweitern Sie die Struktur.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Klicken Sie unter Team Foundation auf SharePoint-Webanwendungen.

  3. Markieren Sie im Bereich SharePoint-Webanwendungen im Abschnitt Dienstkonten für die SharePoint-Webanwendungen das Dienstkonto, das Sie entfernen möchten, und klicken Sie dann auf Entfernen.

    Wichtiger Hinweis Wichtig

    Sie werden nicht aufgefordert, das Löschen des Dienstkontos zu überprüfen. Stellen Sie daher vor dem Klicken auf Entfernen sicher, dass Sie das Dienstkonto ausgewählt haben, das entfernt werden soll. Wenn Sie das falsche Dienstkonto entfernen, beeinträchtigt dies die Funktionsweise der Portale, die die SharePoint-Webanwendung verwenden. Sie können das Dienstkonto jedoch jederzeit wieder hinzufügen.

Siehe auch

Aufgaben

Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung
Öffnen der Team Foundation-Verwaltungskonsole

Konzepte

Team Foundation Server-Berechtigungen
Die Team Foundation-Verwaltungskonsole

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Hinzufügen eines Berichtsservers zur Bereitstellung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Hinzufügen eines Berichtsservers zur Bereitstellung
Siehe auch Feedback senden

Projektmanager und andere Teammitglieder können mithilfe von Berichten den Fortschritt verfolgen, wenn Sie der Installation von Visual Studio Team Foundation Server einen Server hinzufügen, der SQL Server Reporting Services ausführt. Sie können einer Standard- oder einer erweiterten Installation einen Berichtsserver hinzufügen. Einfache Installationen bieten keine Unterstützung für das Hinzufügen eines Berichtsservers. Wenn Sie einen Berichtsserver hinzufügen, können Projektmitglieder die Berichte auch an ihre jeweiligen Anforderungen anpassen. Sie können einen Berichtsserver während der Installation von Team Foundation Server oder jederzeit nach Abschluss der anfänglichen Installation hinzufügen.

Hinweis Hinweis

Sie können vorhandenen Teamprojekten und Teamprojektsammlungen nicht automatisch Berichte hinzufügen, indem Sie einfach einen Berichtsserver zu einer Bereitstellung hinzufügen. Alle Teamprojektsammlungen, die Sie nach dem Hinzufügen eines Berichtsservers erstellen, verfügen über Berichtsfunktionen, genauso wie alle Teamprojekte, die in diesen Auflistungen erstellt werden. Wenn Sie vorhandenen Auflistungen und Projekten Berichterstellungsfunktionen hinzufügen möchten, sind zusätzliche Schritte erforderlich. Weitere Informationen finden Sie unter Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung und Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen.

Jede Bereitstellung von Team Foundation Server kann nur einen Berichtsserver umfassen. Alle Berichte in dieser Bereitstellung werden auf diesem Server verarbeitet und gespeichert. Wenn die Bereitstellung von Team Foundation Server auch SharePoint-Produkte verwendet, hängen die Berichte und Dashboards in SharePoint-Produkte von diesem Berichtsserver ab.

Erforderliche Berechtigungen

Zum Durchführen dieser Schritte müssen Sie Mitglied der folgenden Gruppen sein:

  • Die Gruppe Team Foundation-Administratoren oder die Berechtigung Instanzebeneninformationen bearbeiten muss auf Zulassen festgelegt sein.

  • Sie sind Mitglied der Gruppe Inhalts-Manager oder der Gruppe TFS-Inhalts-Manager in SQL Server Reporting Services.

  • Um beim Hinzufügen eines Berichtsservers einen Berichtsordner erstellen zu können, muss das vom Hintergrundauftrags-Agent für Visual Studio Team Foundation (TFSService) verwendete Dienstkonto über bestimmte Berechtigungen verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server und Team Foundation-Hintergrundauftrags-Agent.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So fügen Sie einer Bereitstellung von Team Foundation Server einen Berichtsserver hinzu

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Namen des Servers, erweitern Sie Anwendungsebene, und klicken Sie dann auf Berichterstellung.

  3. Wählen Sie unter Berichterstellung die Option Bearbeiten.

    Das Dialogfeld Reporting Services wird geöffnet.

  4. Geben Sie auf der Registerkarte Warehouse die folgenden Informationen an:

    1. Wählen Sie unter Server den Namen des Servers, der die Warehouse-Datenbank für Team Foundation Server hostet, aus, oder geben Sie einen an.

    2. Wenn Sie eine andere Instanz als die Standardinstanz verwenden möchten, aktivieren Sie das Kontrollkästchen Nicht standardmäßige Instanz angeben, und geben Sie dann den gewünschten Namen Instanz an oder wählen Sie ihn aus.

    3. Geben Sie unter Datenbank den Namen der Warehouse-Datenbank an.

      Standardmäßig lautet der Name dieser Datenbank "Tfs_Warehouse".

    4. (Optional) Wählen Sie Verbindung testen, um zu überprüfen, ob die angegebenen Informationen richtig sind und ob die angegebene Datenbank ein gültiges Schema aufweist.

  5. Geben Sie auf der Registerkarte Analysis Services die folgenden Informationen an:

    1. Wählen Sie unter Server den Namen des Servers, der die Analysedatenbank für Team Foundation Server hostet, aus, oder geben Sie einen an.

    2. Wenn Sie eine andere Instanz als die Standardinstanz verwenden möchten, aktivieren Sie das Kontrollkästchen Nicht standardmäßige Instanz angeben, und geben Sie dann den gewünschten Namen Instanz an oder wählen Sie ihn aus.

    3. Geben Sie unter Datenbank den Namen der Datenbank an.

      Standardmäßig lautet der Name dieser Datenbank "Tfs_Analysis".

    4. (Optional) Wählen Sie Verbindung testen, um zu überprüfen, ob die angegebenen Informationen richtig sind und ob die angegebene Datenbank ein gültiges Schema aufweist.

    5. Geben Sie in Konto für den Zugriff auf Datenquellen unter Benutzername das Datenquellenkonto an (angegeben durch den Platzhalter TFSReports), und geben Sie dann unter Kennwort das Kennwort für das Konto an.

  6. Aktivieren Sie auf der Registerkarte "Berichte" das Kontrollkästchen Berichtsserver verwenden.

    1. Wählen Sie unter Server den Namen des Berichtsservers aus, oder geben Sie einen an.

    2. Wählen Sie URLs eingeben, um die URLs für den Webdienst, den der Berichtsserver verwendet, und die URL für den Berichts-Manager automatisch zu füllen.

      Alternativ können Sie diese Werte auswählen oder manuell eingeben.

    3. Geben Sie in Konto für den Zugriff auf Datenquellen den Namen des TFSReports-Kontos unter Benutzername an, und geben Sie das Kennwort für dieses Konto unter Kennwort an.

    4. Geben Sie unter Team Foundation Server-Berichte den Pfad für Berichte unter Standardpfad an.

      Standardmäßig lautet der Wert in diesem Feld "/TfsReports".

  7. Klicken Sie auf OK.

  8. Wählen Sie unter Berichterstellung die Option Aufträge starten, um der Verarbeitung der Warehouse- und Analysis Services-Aufträge zu starten.

Siehe auch

Aufgaben

Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung
Erstellen einer Teamprojektsammlung

Konzepte

Planen und Nachverfolgen von Projekten
Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen


Auf dem Server installierte Updates anzeigen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Auf dem Server installierte Updates anzeigen
Siehe auch Feedback senden

Um zu bestimmen, welche Updates als Teil der Bereitstellung von Team Foundation Server installiert wurden, können Sie die Verwaltungskonsole für Team Foundation verwenden, oder Sie können die Versionsnummer einer bestimmten Datei überprüfen. Die Verwaltungskonsole stellt ausführlichere Informationen bereit, ist aber in bestimmten Szenarien evtl. nicht verfügbar, z. B. während eines Upgrades von einer früheren Version von Team Foundation Server. In solchen Fällen können Sie die Version überprüfen, indem Sie die Dateiversionsnummer der Datei Microsoft.TeamFoundation.Admin.dll anzeigen.

So zeigen Sie installierte Updates über die Verwaltungskonsole an

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Wählen Sie unter dem Servernamen Anwendungsebene aus.

  3. Klicken Sie im Abschnitt Zusammenfassung der Datenebene auf Installierte Updates.

    Das Fenster Team Foundation Server - Installierte Updates wird geöffnet.

  4. Überprüfen Sie die Informationen in den Spalten Name, KB-Artikel, Version und Installationsdatum.

  5. Wenn Sie die Überprüfung installierter Updates abgeschlossen haben, wählen Sie OK aus.

Anzeigen der Dateiversion zum Ermitteln von Updates

In einigen Fällen muss der Updatestatus einer Bereitstellung bestimmt werden, ohne auf die Verwaltungskonsole zuzugreifen. Der Link für installierte Updates in der Verwaltungskonsole ist jedoch erst nach der Konfiguration von Team Foundation Server aktiv. Daher müssen Sie die Dateiversion von Microsoft.TeamFoundation.Admin.dll überprüfen, um zu bestimmen, welche Updates bereits installiert sind.

So zeigen Sie die Dateiversion von Microsoft.TeamFoundation.Admin.dll an

  1. Öffnen Sie Windows-Explorer (oder Datei-Explorer), und wechseln Sie zu \Programme\Microsoft Team Foundation Server 2012\Tools.

  2. Erweitern Sie das Untermenü für Microsoft.TeamFoundation.Admin.dll, und wählen Sie dann Eigenschaften aus.

  3. Wählen Sie die Registerkarte Details, und überprüfen Sie die Angaben unter Dateiversion.

  4. Wählen Sie nach dem Überprüfen der Dateiversion OK aus.

Siehe auch

Konzepte

Die Team Foundation-Verwaltungskonsole
Sichern und Wiederherstellen der Bereitstellung


Suchen oder Ändern des Product Key für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Suchen oder Ändern des Product Key für Team Foundation Server
Siehe auch Feedback senden

Sie können den Lizenztyp, das Lizenzablaufdatum und den Product Key für Ihre Bereitstellung von Visual Studio Team Foundation Server überprüfen. Probleme aufgrund eines abgelaufenen oder ungültigen Product Key können Ihre Bereitstellung beeinträchtigen. Wenn Sie eine Testversion von Team Foundation Server installiertet haben, sollten Sie darauf achten, dass die Lizenz nicht abläuft. Nach Ablauf der Lizenz können die Benutzer Team Foundation Server erst wieder verwenden, wenn Sie diese Situation behoben haben. Eine Ermittlung des Product Key für Team Foundation Server kann auch für die Anforderung von Support oder zur Archivierung erforderlich sein.

Hinweis Hinweis

Sollten während des Upgrades der Lizenz Probleme auftreten, wenden Sie sich bitte an den Support für Visual Studio Application Lifecycle Management (ALM). Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Hilfe und Support und Team Foundation Server-Lizenzierungs-Whitepaper.

So suchen oder ändern Sie den Product Key

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Namen des Servers, und überprüfen Sie die Informationen unter Produkt-ID, Lizenztyp und Ablauf der Lizenz.

    Die Zahl, die unter Produkt-ID angezeigt wird, ist der Product Key.

  3. (Optional) Wenn Sie den Product Key ändern oder aktualisieren möchten, wählen Sie die Option Lizenz aktualisieren.

    Das Fenster Team Foundation Server-Lizenz wird geöffnet.

  4. Geben Sie den Product Key ein, und wählen Sie dann Aktivieren aus.

Siehe auch

Aufgaben

Gewusst wie: Suchen des Visual Studio Product Key

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


Organisieren des Servers mit Teamprojektsammlungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Organisieren des Servers mit Teamprojektsammlungen
Feedback senden

Sie können die Teamprojekte effizienter verwalten, indem Sie diese gruppieren und ihnen die gleichen Ressourcen zuweisen. Sie können beispielsweise Projekte mit den gleichen Anforderungen oder Zielen gruppieren, z. B. alle Projekte, die sich auf eine bestimmte CodeBase beziehen. Anschließend können Sie diese Gruppierung als eigenständige Ressource mit individuellen Benutzergruppen, Serverressourcen und Wartungszeitplänen verwalten. In Team Foundation Server (TFS) werden Teamprojekte in einer oder mehreren Organisationseinheiten namens Teamprojektsammlung gruppiert. Eine Teamprojektauflistung ist eine Organisationsstruktur, mit der Sie eine Gruppe von Teamprojekten in TFS definieren und steuern können. Beim Erstellen einer Auflistung geben Sie die logischen und physischen Ressourcen an, die von den Teamprojekten innerhalb dieser Auflistung verwendet werden können. Alle von diesen Projekten verwendeten Artefakte und Daten werden in der einzigen Datenbank der Auflistung gespeichert.

Teamprojektsammlungen bieten Serveradministratoren die folgenden Vorteile:

  • Eine einzelne Datenbank, in der alle Daten für alle Projekte in der Auflistung gespeichert werden. Administratoren können diese Datenbank unabhängig von anderen Auflistungen sichern und wiederherstellen.

  • Ein skalierbare Methode, mit der Administratoren die für die Entwicklungsaufgaben erforderlichen Ressourcen verwalten können. Administratoren können Ressourcen neu zuweisen, um die Anforderungen der Projekte in einer Auflistung besser zu erfüllen.

Teamprojektsammlungen bieten Projektadministratoren die folgenden Vorteile:

  • Gruppierung von verwandten Projekten, für die Berichte, Arbeitsaufgaben und Prozessleitfäden sowie eine CodeBase gemeinsam genutzt werden können.

  • Eine unabhängige CodeBase, die basierend auf den Anforderungen der Projekte in der Auflistung erstellt, verzweigt, zusammengeführt und wiederholt werden kann. Codeabhängigkeiten außerhalb der Auflistung können formell verwaltet werden.

Wenn Sie mehrere Auflistungen erstellen, können Sie alle Datenbanken für diese auf einer einzelnen Instanz von SQL Server speichern, oder Sie verteilen die Datenbanken auf mehrere Instanzen.

Die folgende Abbildung zeigt, wie Datenbanken für Teamprojektsammlungen in die logische Architektur von TFS integriert werden:

Beispiel: Möglicher Speicherort für Auflistungsdatenbanken

Beim Installieren von TFS können Sie eine Standardauflistung mit allen Teamprojekten erstellen, oder Sie verzögern das Erstellen einer Auflistung. Sie müssen jedoch mindestens eine Auflistung erstellen, bevor Sie das erste Teamprojekt erstellen können. Alle Projekte müssen innerhalb einer Auflistung erstellt werden.

Wenn Sie eine frühere Version von TFS aktualisieren, wird eine Standardauflistung erstellt, in der alle vorhandenen Projekte gespeichert werden. Nach der Installation bzw. dem Upgrade können Sie weitere Auflistungen entsprechend den Anforderungen Ihres Unternehmens erstellen.

Vorteile mehrerer Teamprojektsammlungen

Wenn Sie mehrere Auflistungen erstellen, können Sie die operationellen Anforderungen einer CodeBase oder andere Projektgruppierungen besser von den operationellen Anforderungen anderer Gruppierungen abgrenzen. Da die Daten für jede Auflistung in einer eigenen Datenbank gespeichert werden, können Sie zahlreiche Aspekte jeder Auflistung unabhängig von anderen Auflistungen in der Bereitstellung verwalten. Sie können beispielsweise jede Auflistung separat starten und beenden. Auf diese Weise lassen sich Wartungsvorgänge für jede Auflistung zu unterschiedlichen Zeiten planen.

Da jede Auflistung über einen eigenen Satz von Benutzern und Berechtigungen verfügt, können Sie die operationelle Sicherheit erhöhen, indem Sie unterschiedliche CodeBases in verschiedenen Auflistungen isolieren. Sie können so Benutzer nur zu der Auflistung hinzufügen, die die Projekte für die jeweilige CodeBase enthält.

Nachteile mehrerer Teamprojektsammlungen

Wenn Sie mehrere Auflistungen erstellen, erhöht sich die Komplexität Ihrer Bereitstellung von TFS. Sie müssen die Datenbank für jede Auflistung sichern und wiederherstellen, und auch andere Verwaltungs- und Wartungsaufgaben nehmen proportional zur Anzahl der Auflistungen zu. Sie müssen zum Beispiel den Satz von Benutzern und Berechtigungen für jede Teamprojektsammlung separat verwalten.

Außerdem sollten Sie bei der Überlegung, ob Sie mehrere Auflistungen erstellen, die folgenden Faktoren berücksichtigen:

  • Sie können Arbeitsaufgaben nicht über Auflistungen hinweg verknüpfen.

  • Sie können Code nicht über Auflistungen hinweg verzweigen oder zusammenführen.

  • Sie können Abfragen nicht über Auflistungen hinweg erstellen.

Sie können jedoch all diese Funktionen über Teamprojekte innerhalb der gleichen Auflistung hinweg ausführen. Sie sollten daher erwägen, die Teamaufgaben in Projekten innerhalb einer einzelnen Auflistung zu konsolidieren, wenn die Entwicklung von der Möglichkeit zum Verzweigen und Zusammenführen von Code profitiert oder wenn Sie den Status von Arbeitsaufgaben im Zusammenhang mit dem gleichen Code abfragen müssen.

Allgemeine Aufgaben

Themen | Description
Erstellen einer Teamprojektsammlung Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten Zugriff auf Funktionen über Webberechtigungen Erste Schritte im Team Agile-Planung und -Iterationen | Organisieren von Ressourcen zur Unterstützung von Teamprojekten: Sie können eine oder mehrere Teamprojektsammlungen erstellen, um verwandte Entwicklungsprojekte zu organisieren und zu unterstützen.
Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung Hinzufügen einer SharePoint-Webanwendung zu einer Teamprojektsammlung | Hinzufügen von Ressourcen zu vorhandenen Teamprojektsammlungen: Sie können eine SharePoint-Webanwendung oder einen Server, auf dem SQL Server Reporting Services ausgeführt wird, zu einer Teamprojektsammlung hinzufügen, nachdem Sie diese erstellt haben.
Ändern einer Teamprojektsammlung | Starten oder Beenden einer Teamprojektsammlung: Sie können eine Teamprojektsammlung beenden, um diese zu warten oder eine zugrunde liegende Komponente zu aktualisieren, von der Team Foundation Server abhängt.
Ändern einer Teamprojektsammlung Hinzufügen von Benutzern zu Teamprojekten Festlegen von Administratorberechtigungen für Teamprojektsammlungen | Ändern von Ressourcen für Teamprojekte in einer Auflistung: Sie können die Ressourcen ändern, die für Teamprojekte innerhalb einer Auflistung zur Verfügung stehen, z. B. die von Projekten in der Auflistung verwendete Webanwendung. Zudem können Sie Benutzerberechtigungen und Gruppen auf Auflistungsebene ändern.
Löschen einer Teamprojektsammlung | Löschen einer Teamprojektsammlung: Sie können die Ressourcen erweitern, die anderen Teamprojektsammlungen zur Verfügung stehen, und die Bereitstellung vereinfachen, indem Sie Auflistung ohne aktive oder gültige Projekte löschen.

Verweis

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten

Erste Schritte im Team

Planen und Nachverfolgen von Projekten


Erstellen einer Teamprojektsammlung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Erstellen einer Teamprojektsammlung
Siehe auch Feedback senden

Indem Sie Teamprojektsammlungen erstellen, können Sie Projekte in Gruppen organisieren, die Ihren Geschäftsanforderungen entsprechen. Sie können z. B. eine Auflistung für alle Projekte erstellen, die sich auf eine bestimmte CodeBase beziehen, oder Sie können eine Auflistung für jede Unternehmenseinheit in der Organisation erstellen. Weitere Informationen über Teamprojektsammlungen und deren Verwendung zum Organisieren von Servern finden Sie unter Organisieren des Servers mit Teamprojektsammlungen.

Bevor Sie eine Teamprojektsammlung erstellen, benötigen Sie die folgenden Informationen:

  • Der Name und die Instanz von SQL Server, die Sie zum Hosten der Datenbank für die Auflistung verwenden möchten. Sie möchten möglicherweise auch den Namen einer leeren Datenbank, die für die Auflistung verwendet werden soll, bereitstellen.

  • Ggf. die SharePoint-Webanwendung, die Portale für Teamprojekte in dieser Auflistung hostet. Wenn Ihr Benutzerkonto nicht über die Berechtigungen zum Erstellen von Websites in dieser SharePoint-Webanwendung verfügt, benötigen Sie auch den Namen und den relativen Pfad einer Website, die ein Mitglied der Gruppe "Farmadministratoren" für Sie erstellt hat.

    Wichtiger Hinweis Wichtig

    Beim Erstellen einer Auflistung können Sie eine vorhandene SharePoint-Website oder eine Websiteauflistung verwenden, statt eine zu erstellen. Sie müssen dann jedoch kompliziertere Schritte durchführen, wenn Sie die Bereitstellung konfigurieren. Auf dem Server, der die Website hostet, müssen bestimmte Erweiterungen installiert und konfiguriert werden, und die Systemverwaltung ist komplexer. Sie sollten die Standardoption des Assistenten für das Erstellen einer Teamprojektsammlung verwenden, es sei denn, die Geschäftsinfrastruktur erfordert die Verwendung einer vorhandenen SharePoint-Website.

  • Der Server, der SQL Server Reporting Services ausführt und der in dieser Auflistung alle Berichte für Teamprojekte hostet (wenn ein entsprechender Server für die Bereitstellung konfiguriert wurde und Sie diesen für die Auflistung verwenden möchten). Wenn das von Ihnen verwendete Benutzerkonto nicht über Berechtigungen verfügt, Ordner auf diesem Server zu erstellen, benötigen Sie auch den Namen und den relativen Pfad eines Ordners, den ein Administrator für Sie auf diesem Server erstellt hat.

    Wichtiger Hinweis Wichtig

    Sie können beim Erstellen einer Auflistung einen vorhandenen Ordner verwenden, wobei dieser Prozess jedoch komplizierter ist. Sie sollten beim Erstellen der Auflistung die Standardoption des Assistenten zum Erstellen des Ordners verwenden, es sei denn, Sicherheitseinschränkungen der Geschäftsinfrastruktur verhindern das Erstellen eines Ordners während der Erstellung einer Auflistung.

Erforderliche Berechtigungen

Zum Durchführen dieser Schritte müssen Sie Mitglied der folgenden Gruppen sein:

  • Die Gruppe Team Foundation-Administratoren, oder Sie müssen die auf Zulassen festgelegte Berechtigung Teamprojektsammlung erstellen haben.

  • Die Gruppe Windows SharePoint Server-Siteadministratoren und die Gruppe SharePoint-Verwaltung in SharePoint-Produkte.

  • Die Gruppe SQL Reporting Services-Inhalts-Manager und die Gruppe SQL Reporting Services-Projektinhalts-Manager

  • Die Gruppe serveradmin oder sysadmin auf dem Server, der die Datenbank für die Teamprojektsammlung hostet, wenn diese Datenbank als Teil der Auflistung erstellt werden soll. Wenn Sie eine vorhandene Datenbank verwenden möchten, müssen Sie über die Rolle dbo für diese Datenbank verfügen.

  • Wenn Sie im Rahmen der Erstellung einer Teamprojektsammlung eine Websiteauflistung, einen Berichtsordner oder eine Datenbank erstellen möchten, muss das vom Hintergrundauftrags-Agenten für Visual Studio Team Foundation verwendete Dienstkonto (auch als Dienstkonto für Team Foundation Server oder TFSService bezeichnet) über bestimmte Berechtigungen verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server und Team Foundation-Hintergrundauftrags-Agent.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So erstellen Sie eine Teamprojektsammlung

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Wählen Sie unter Teamprojektauflistungen die Option Auflistung erstellen aus.

    Der Assistent Teamprojektauflistung erstellen wird geöffnet.

  4. Geben Sie unter Name einen Namen für die Auflistung an. Unter Beschreibung können Sie optional eine kurze Beschreibung der Auflistung und ihres Zweckes eingeben. Wählen Sie Weiter aus.

Hinweis Hinweis

Sie können in Namen von Auflistungen bestimmte Zeichen nicht verwenden, z. B. Schrägstriche. Weitere Informationen finden Sie unter Benennungseinschränkungen in Team Foundation.

  1. Geben Sie unter SQL Server-Instanz den Namen des Servers an, auf dem SQL Server ausführt wird. Wenn Sie eine benannte Instanz verwenden möchten, um die Datenbank für diese Teamprojektsammlung zu hosten, müssen Sie auch den Namen der Instanz angeben, wie im folgenden Beispiel dargestellt:

    Servername\Instanzname

  2. Führen Sie unter Datenbank einen der folgenden Schritte aus:

    • Wenn Sie eine Datenbank für diese Teamprojektsammlung erstellen möchten, wählen Sie Neue Datenbank für diese Auflistung erstellen.

      Wichtiger Hinweis Wichtig

      Das Dienstkonto, das der Hintergrundauftrags-Agent für Visual Studio Team Foundation verwendet, muss über Berechtigungen zum Erstellen einer Datenbank auf der Instanz von SQL Server, verfügen, auf der Sie die Datenbank erstellen möchten.

    • Wenn Sie eine Datenbank verwenden möchten, die bereits auf der Instanz von SQL Server vorhanden ist, wählen Sie Vorhandene Datenbank verwenden, und geben den Namen der Datenbank im Textfeld ein.

      Hinweis Hinweis

      Um diese Option verwenden zu können, müssen Sie eine leere Datenbank angeben, die auf der Instanz von SQL Server vorhanden ist und für die Sie über Schreibberechtigungen verfügen.

  3. Wählen Sie Weiter aus.

  4. Wenn Sie eine oder mehrere SharePoint-Webanwendungen zur Unterstützung der Bereitstellung konfiguriert haben, wählen Sie in der Liste Webanwendung auf eine SharePoint-Webanwendung, und führen Sie einen der folgenden Schritte aus:

    • Wenn Sie die Standardoption zum Erstellen einer Websiteauflistung verwenden möchten, wählen Sie Weiter.

    Es wird eine SharePoint-Websiteauflistung erstellt, und der Name der Auflistung wird als Name der Unterwebsite der Stammwebsite, die in der SharePoint-Webanwendung konfiguriert ist, verwendet.

    • Wenn das Dienstkonto für Team Foundation Server kein Mitglied der Gruppe "Farmadministratoren" ist, können Sie mit diesem Assistenten keine Websiteauflistung erstellen. Sie müssen eine vorhandene Websiteauflistung verwenden, die ein Mitglied der Gruppe "Farmadministratoren" für Sie erstellt hat. Erweitern Sie in diesem Fall Erweiterte Konfiguration, klicken Sie auf die Option zum Angeben eines Pfads zu einer vorhandenen SharePoint-Website, und geben Sie dann den relativen Pfad zu der für Sie erstellten Websiteauflistung an. Wählen Sie Pfad überprüfen, und wählen Sie Weiter, wenn der Pfad richtig ist.

      Wichtiger Hinweis Wichtig

      Sie sollten eine Websiteauflistung anhand der Standardoption erstellen, es sei denn, die Geschäftsinfrastruktur macht die Verwendung einer vorhandenen Websiteauflistung erforderlich.

  5. Wenn Sie einen Server konfiguriert haben, der SQL Server Reporting Services ausführt, um die Bereitstellung zu unterstützen, führen Sie einen der folgenden Schritte aus:

    • Überprüfen Sie unter Berichte die Informationen für den Server und den Ordner, die Berichte für diese Auflistung hosten, und wählen Sie Weiter.

    • Wenn das von Ihnen verwendete Benutzerkonto nicht über Berechtigungen zum Erstellen eines Ordners auf dem Server, der Reporting Services ausführt, verfügt, müssen Sie einen Ordner verwenden, den ein Administrator für Sie auf diesem Server erstellt hat. Erweitern Sie in diesem Fall Erweiterte Konfiguration, klicken Sie auf Pfad zu einem vorhandenen Ordner angeben, und geben Sie den relativen Pfad des Ordners an, der für Sie erstellt wurde. Wählen Sie Pfad überprüfen, und wählen Sie Weiter, wenn der Pfad richtig ist.

    Wichtiger Hinweis Wichtig

    Sie sollten die Standardoption zum Erstellen eines Ordners verwenden, es sei denn, Sicherheitseinschränkungen in der Geschäftsinfrastruktur lassen das automatische Erstellen eines Ordners als Teil des Assistenten nicht zu.

  6. Wählen Sie unter Lab Management die Option Lab Management konfigurieren, und wählen Sie Weiter.

    Wichtiger Hinweis Wichtig

    Wenn Lab-Management in der Liste der Assistentenseiten deaktiviert ist, müssen Sie Lab Management in der Verwaltungskonsole für Team Foundation zuerst konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

    Wenn Sie Lab-Management nicht in der Bereitstellung verwenden, fahren Sie mit Schritt 12 fort.

  7. Wählen Sie unter Bibliotheksfreigaben die Option Hinzufügen und überprüfen, wählen Sie eine oder mehrere Bibliotheksfreigaben von Virtual Machine Manager (VMM), die zum Speichern von virtuellen Computerimages für Teamprojekte in dieser Sammlung verwendet werden sollen, und wählen Sie dann Hinzufügen.

    Sie können den Namen der Bibliotheksfreigabe auch in einen Anzeigenamen ändern, indem Sie darauf doppelklicken. Weitere Informationen finden Sie unter Gewusst wie: Ändern der Bibliotheksfreigabe für die Teamprojektsammlungen.

  8. Aktivieren oder deaktivieren Sie das Kontrollkästchen Automatische Bereitstellung für jede Bibliotheksfreigabe, und wählen Sie Weiter aus.

    Wenn Sie dieses Kontrollkästchen aktivieren, fügt Team Foundation Server die Bibliotheksfreigabe automatisch den in dieser Auflistung erstellten Teamprojekten hinzu. Für Teamprojekte, die noch nicht erstellt wurden, wird die Freigabe hinzugefügt, wenn der Assistent "Neues Teamprojekt" das Projekt erstellt.

    Wichtiger Hinweis Wichtig

    Sie müssen Teamprojektsammlungen mindestens eine Bibliotheksfreigabe hinzufügen, um Lab-Management zu aktivieren.

  9. Wählen Sie Weiter aus.

  10. Wählen Sie unter Hostgruppen die Option Hinzufügen und überprüfen, wählen Sie eine oder mehrere VMM-Hostgruppen, die zum Bereitstellen von virtuellen Computern für Teamprojekte in dieser Sammlung verwendet werden sollen, und wählen Sie dann Hinzufügen.

    Sie können den Namen der Hostgruppe auch in einen Anzeigenamen ändern, indem Sie ihn bearbeiten. Weitere Informationen finden Sie unter Gewusst wie: Ändern der Hostgruppen für die Teamprojektsammlungen.

    Wichtiger Hinweis Wichtig

    Zum Aktivieren von Lab-Management müssen Sie einer Teamprojektsammlung mindestens eine Hostgruppe hinzufügen.

    Beim Überprüfungsprozess werden jetzt die folgenden Änderungen überprüft:

    • Das Dienstkonto für Team Foundation Server wurde jedem Host in den von Ihnen angegebenen Hostgruppen hinzugefügt, sodass Team Foundation Server direkt mit den Hosts in der Hostgruppe kommunizieren kann.

    • Der zum Herstellen einer Verbindung mit den virtuellen Computern verwendete Netzwerkadapter ist angegeben.

    1. Falls das Dienstkonto für Team Foundation Server (TFSService) der Administratorgruppe auf einem oder mehreren Hosts in diesen Hostgruppen nicht hinzugefügt wurde, müssen Sie ein Domänenkonto angeben, das auf allen Hosts in den hinzugefügten Hostgruppen über Administratorberechtigungen verfügt. Dieser Schritt ermöglicht dem Dienstkonto für Team Foundation Server (TFSService) die direkte Kommunikation mit den Hosts in der Hostgruppe.

    2. Falls Hyper-V-Hosts über mehrere Netzwerkadapter verfügen und Team Foundation Server nicht bestimmen kann, welcher Adapter zum Herstellen einer Verbindung mit dem virtuellen Computer verwendet werden soll, wird für jeden dieser Hosts das Dialogfeld Mehrere Netzwerkadapter angezeigt. Wählen Sie in der Liste den Netzwerkadapter aus, der der gewünschten Netzwerkadresse entspricht.

    3. Aktivieren oder deaktivieren Sie für jede Hostgruppe das Kontrollkästchen Automatische Bereitstellung.

      Wenn Sie dieses Kontrollkästchen aktivieren, fügt Team Foundation Server die Hostgruppe automatisch den Teamprojekten dieser Teamprojektsammlung hinzu. Für Teamprojekte, die noch nicht erstellt wurden, wird die Hostgruppe hinzugefügt, wenn der Assistent für neue Teamprojekte das Projekt erstellt.

  11. Um das Benutzerkonto auszuwählen, das für die Kommunikation zwischen den Test-Agents und Build-Agents sowie zwischen den Testcontrollern und Team Foundation Server verwendet werden soll, wählen Sie Dienstkonto.

    Warnhinweis Vorsicht

    Für dieses Dienstkonto müssen Sie ein Domänenkonto mit eingeschränkten Berechtigungen angeben. Sie müssen ein Konto angeben, das über keine Administratorberechtigungen verfügt und das von keinem vertrauenswürdigen Dienst verwendet wird, einschließlich des Buildcontrollers und des Testcontrollers. Sie sollten erwägen, zwei Konten für dieses Dienstkonto zu erstellen. Weitere Informationen über diese beiden Konten finden Sie unter Gewusst wie: Konfigurieren des Dienstkontos.

    1. Geben Sie auf der Registerkarte Dienstkonto den Namen des Kontos unter Kontoname und das Kennwort unter Kennwort an.

    2. Um zu überprüfen, ob das Benutzerkonto gültig ist, wählen Sie Test.

    3. Wählen Sie Weiter aus.

  12. Überprüfen Sie die Daten unter Konfiguration überprüfen. Wenn Sie Änderungen vornehmen möchten, wählen Sie Zurück, bis Sie zu der Seite gelangen, die Sie ändern möchten. Wenn die Informationen richtig sind, wählen Sie Überprüfen aus.

  13. Überprüfen Sie unter Bereitschaftsprüfungen den Status der Überprüfungen.

    Ein blauer unterstrichener Fehlerindikator wird neben der Konfiguration angezeigt, die einen Fehler enthält. Sie können den Indikator auswählen, um eine ausführliche Beschreibung des Problems zu erhalten. Sie müssen alle Fehler behandeln, bevor Sie fortfahren können.

  14. Wurden alle Bereitschaftsüberprüfungen ohne Fehler durchgeführt, wählen Sie Erstellen aus.

    Die Erstellung der Teamprojektsammlung startet.

  15. Wählen Sie nach Beendigung des Assistenten Schließen aus.

Siehe auch

Konzepte

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
Dienstkonten und Abhängigkeiten in Team Foundation Server
Zugriff auf Funktionen über Webberechtigungen


Ändern einer Teamprojektsammlung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Ändern einer Teamprojektsammlung
Siehe auch Feedback senden

Sie können physischen und organisatorischen Änderungen in der Geschäftsinfrastruktur durch eine Bearbeitung der Einstellungen für die Teamprojektsammlungen begegnen. Sie können beispielsweise eine Auflistung beenden, bevor Sie einen anderen Vorgang ausführen, z. B. bevor Sie deren Daten sichern oder ein Service Pack auf den Server anwenden, auf dem sich eine Auflistung befindet. Nachdem Sie den Vorgang abgeschlossen haben, können Sie die Auflistung neu starten. Sie können die Benutzer, die Zugriff auf die Auflistung haben, deren Berechtigungen und die Ressourcen ändern, die für die Auflistung in SharePoint-Produkte und SQL Server Reporting Services zugeordnet werden. In der Verwaltungskonsole für Team Foundation können Sie alle Einstellungen für Auflistungen bearbeiten.

Informationen zu einer Teamprojektsammlung finden Sie auf den folgenden Registerkarten:

  • Allgemein: Anzeigen der Name und den URI der Auflistung an. Auf dieser Registerkarte können Sie die Auflistung zudem beenden und starten, die Beschreibung der Auflistung anzeigen oder bearbeiten und die Gruppenmitgliedschaft sowie die Berechtigungen für Benutzer und Gruppen in der Auflistung verwalten.

  • Status: Zeigt den Status der Auflistung an. Auf dieser Registerkarte können Sie zudem eine Protokolldatei mit Details zum Auflistungsstatus öffnen.

  • Teamprojekte: Zeigt die Liste der Teamprojekte an, die die Auflistung enthält. Auf dieser Registerkarte können Sie zudem die Beschreibung der eingeschlossenen Teamprojekte überprüfen.

  • SharePoint-Website: Zeigt den URI der Site an, unter dem Websites standardmäßig für alle Teamprojekte in der Auflistung erstellt werden. Wenn Sie ein Teamprojekt erstellen oder ändern, können Sie eine andere Site angeben. Diese Stammsite wird jedoch immer als Standard verwendet. Auf dieser Registerkarte können Sie zudem den Standardspeicherort für die Erstellung von Teamprojektportalen ändern und die Konfiguration hinzufügen oder entfernen.

  • Berichtsordner: Zeigt den Pfad an, in dem Berichtsordner standardmäßig erstellt werden. In diesen Ordnern werden die Berichte für Teamprojekte gespeichert, die in dieser Auflistung erstellt werden. Wenn Sie ein Teamprojekt erstellen oder ändern, können Sie einen anderen Ordner angeben. Dieser Stammpfad wird jedoch immer als Standard verwendet. Auf dieser Registerkarte können Sie zudem den Standardspeicherort ändern und die Konfiguration entfernen.

Erforderliche Berechtigungen

Um diese Prozeduren auszuführen, müssen Sie entweder die folgenden Berechtigungen haben oder Mitglied der folgenden Gruppen sein:

  • Die Berechtigungen Instanzebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten müssen auf Zulassen festgelegt sein, oder Sie müssen Mitglied der Gruppe Team Foundation-Administratoren sein.

  • Wenn Sie Einstellungen für SQL Server Reporting Services oder SharePoint-Produkte ändern möchten, müssen das Dienstkonto für Team Foundation Server und das vom Team Foundation Background Job Agent verwendete Konto über geeignete Berechtigungen für die Instanz von SQL Server oder die SharePoint-Webanwendung verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server und Team Foundation-Hintergrundauftrags-Agent.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Verwalten von allgemeinen Einstellungen

So beenden oder starten Sie eine Teamprojektsammlung

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, die Sie beenden oder starten möchten.

  4. Wählen Sie unter Allgemein die Option Auflistung beenden oder Auflistung starten aus.

    Wenn die Projektauflistung gestartet wurde, wird nur Auflistung beenden angezeigt. Wenn die Projektauflistung beendet wurde, wird nur Auflistung starten angezeigt.

    Hinweis Hinweis

    Das Beenden oder Starten einer Auflistung kann mehrere Minuten in Anspruch nehmen. Um Zustandsänderungen anzuzeigen, müssen Sie ggf. Aktualisieren auswählen.

So bearbeiten Sie die Beschreibung einer Teamprojektsammlung

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, deren Beschreibung Sie bearbeiten möchten.

  4. Wählen Sie unter Allgemein die Option Einstellungen bearbeiten aus.

  5. Aktualisieren Sie unter Teamprojekteinstellung bearbeiten den Text, und wählen Sie dann OK.

So verwalten Sie die Mitgliedschaft in Gruppen für Teamprojektsammlungen

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie die Mitgliedschaft verwalten möchten.

  4. Wählen Sie unter Allgemein die Option Gruppenmitgliedschaft aus.

  5. Führen Sie unter Globale Gruppen einen der folgenden Schritte aus:

    • Um eine Gruppe hinzuzufügen, wählen Sie die Option Neu und die erforderlichen Informationen aus.

    • Zum Hinzufügen von Benutzern zu einer Gruppe oder Entfernen von Benutzern aus einer Gruppe markieren Sie diese Gruppe, und wählen Sie Eigenschaften und Hinzufügen aus, oder markieren Sie den Benutzer oder die Gruppe, den bzw. die Sie entfernen möchten, und wählen Sie Entfernen aus.

    • Um eine Gruppe zu entfernen, wählen Sie Entfernen. Diese Option ist nur für Gruppen verfügbar, die Sie hinzugefügt haben.

    • Zum Umbenennen einer Gruppe auf Auflistungsebene markieren Sie diese, und wählen Sie Eigenschaften aus. Geben Sie anschließend einen anderen Namen an.

So verwalten Sie Berechtigungen für Benutzer und Gruppen in der Auflistung

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie die Berechtigungen verwalten möchten.

  4. Wählen Sie unter Allgemein die Option Sicherheit verwalten.

  5. Markieren Sie unter Globale Sicherheit den Benutzer oder die Gruppe, dessen/deren Berechtigungen Sie verwalten möchten, und aktivieren Sie dann die entsprechenden Kontrollkästchen Zulassen oder Verweigern.

    Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Anzeigen von Statusinformationen

So zeigen Sie den Status und die Protokolldatei für eine Teamprojektsammlung an

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie in Teamprojektauflistungen die Auflistung, für die Sie den Status anzeigen möchten, und wählen Sie dann die Registerkarte Status aus.

  4. Überprüfen Sie unter Status die Informationen im Feld Letzte Wartungsaktivität.

  5. Um das Protokoll anzuzeigen, doppelklicken Sie in der Liste auf das Protokoll, oder heben Sie es hervor, und drücken Sie die EINGABETASTE.

Anzeigen von Informationen zu Teamprojekten

So zeigen Sie eine Liste von Teamprojekten in einer Auflistung an

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie eine Liste von Teamprojekten anzeigen möchten.

  4. Überprüfen Sie die Liste der Projekte und deren Beschreibungen (falls vorhanden) unter Teamprojekte.

Verwalten von Einstellungen für SharePoint-Websites

So zeigen Sie das Standardstammverzeichnis für Teamprojektportale an

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie den Standardspeicherort, an dem Teamprojektportale erstellt werden, anzeigen möchten.

  4. Überprüfen Sie unter SharePoint-Website die Informationen im Feld Aktueller Standardort der Website.

So fügen Sie ein Standardstammverzeichnis für die Erstellung von Teamprojektportalen hinzu oder ändern dieses

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie den Standardspeicherort, an dem Teamprojektportale erstellt werden, ändern möchten.

  4. Wählen Sie unter SharePoint-Website die Option Standardmäßigen Websiteort bearbeiten.

  5. Führen Sie unter Standardmäßigen Websiteort bearbeiten einen der folgenden Schritte aus:

    • Wenn Sie eine andere SharePoint-Webanwendung angeben möchten, wählen Sie in der Liste SharePoint-Webanwendung eine Anwendung aus, und geben Sie dann den relativen Pfad für eine vorhandene Stammsite oder Siteauflistung ein.

      Hinweis Hinweis

      Wenn die Liste SharePoint-Webanwendung leer ist, wurden keine Anwendungen zur Verwendung durch Team Foundation Server konfiguriert. Weitere Informationen finden Sie unter Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung.

    • Wenn Sie die Webanwendung nicht ändern möchten, geben Sie den relativen Pfad für eine vorhandene Stammsite oder Siteauflistung an.

  6. Überprüfen Sie die Informationen unter Vollständiger Pfad, und wählen Sie OK, wenn diese korrekt sind.

So entfernen Sie den Standardspeicherort für Teamprojektportale

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie den Standardspeicherort entfernen möchten.

  4. Wählen Sie unter SharePoint-Website die Option Konfiguration löschen.

    Wichtiger Hinweis Wichtig

    Durch das Löschen der Konfiguration entfernen Sie den Standardspeicherort, in dem der Assistent für neue Teamprojekte Teamprojektportale erstellt. Sie entfernen jedoch nicht die Site selbst oder eines der bereits darin enthaltenen Teamprojektportale. Projektadministratoren können auch weiterhin ein Teamprojektportal erstellen, sie müssen jedoch einen Speicherort für dieses angeben.

Verwalten von Einstellungen für die Berichterstellung

So zeigen Sie den Stammordner für Berichtsunterordner an

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie Informationen anzeigen möchten.

  4. Überprüfen Sie im Berichtsordner die Informationen unter Aktueller Standardspeicherort des Ordners.

So fügen Sie einen Stammordner für Berichtsunterordner hinzu oder ändern diesen

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie den Standardstammordner hinzufügen oder ändern möchten.

    Wichtiger Hinweis Wichtig

    In dieser Version können Sie nach der Installation und Erstkonfiguration von Team Foundation Server keinen Berichtsserver hinzufügen. Wenn Sie zu diesem Zeitpunkt keinen Berichtsserver hinzugefügt haben, können Sie keinen Ordner zum Speichern von Berichten hinzufügen.

  4. Wählen Sie unter Berichtsordner die Option Standardmäßigen Ordnerspeicherort bearbeiten aus.

  5. Geben Sie unter Standardmäßigen Ordnerspeicherort bearbeiten im Feld Ordnerpfad auf dem Reporting Services-Server einen Pfad oder einen Ordnernamen ein, und wählen Sie dann OK.

    Hinweis Hinweis

    Dieser Vorgang schlägt fehl, wenn Sie den Pfad eines Ordners eingeben, der auf dem Server nicht vorhanden ist, und Sie nicht über die Berechtigung verfügen, einen Ordner auf diesem Server zu erstellen. Sie müssen einen vorhandenen Ordner angeben, wenn Sie nicht über die Berechtigungen verfügen, Ordner auf diesem Server zu erstellen.

So entfernen Sie den Standardspeicherort für Berichtsunterordner

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, für die Sie den Standardspeicherort entfernen möchten.

  4. Wählen Sie unter Berichtsordner die Option Konfiguration löschen und anschließend OK aus.

    Wichtiger Hinweis Wichtig

    Durch das Löschen der Konfiguration entfernen Sie die Berichtsfunktionalität für alle vorhandenen und zukünftigen Teamprojekte in dieser Auflistung. Diese Änderung kann erhebliche Auswirkungen auf die Funktionalität aller Teamprojekte in diese Auflistung haben. Wenn Sie nicht sicher sind, ob Sie diese Änderung tatsächlich vornehmen möchten, wählen Sie Abbrechen.

Siehe auch

Aufgaben

Erstellen einer Teamprojektsammlung

Konzepte

Architektur von Team Foundation Server
Team Foundation Server-Berechtigungen
Grundlagen zu Verwaltungskonzepten und -tools
Zugriff auf Funktionen über Webberechtigungen

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten
Team Foundation Server-Dienste und -Dienstkonten


Löschen einer Teamprojektsammlung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Löschen einer Teamprojektsammlung
Siehe auch Feedback senden

Teamprojektsammlungen, die in der Bereitstellung von Visual Studio Team Foundation Server 2012 (TFS) nicht mehr verwendet werden, können Sie löschen. Durch das Löschen einer Auflistung stellen Sie sicher, dass Benutzer nicht versehentlich eine Verbindung mit dieser herstellen und Projekten in der Auflistung bearbeiten. Zudem vereinfachen Sie so Ihre Bereitstellung.

Um eine Auflistung zu löschen, müssen Sie diese zunächst von TFS trennen. Beim Trennen einer Auflistung wird jedoch nicht die Datenbank für die Auflistung aus SQL Server gelöscht. Um eine Auflistung vollständig zu löschen, müssen Sie die Datenbank für die Auflistung manuell aus der SQL Server-Instanz entfernen, die die Auflistungsdatenbank hostet. Ebenso wird beim Trennen einer Auflistung nicht die SharePoint-Siteauflistung gelöscht, die die Teamprojektportale für Projekte in dieser Auflistung gehostet hat. Um diese Portale zu löschen, müssen Sie die Siteauflistung entfernen, die diese Auflistung unterstützt hat.

Wichtiger Hinweis Wichtig

Im Idealfall unterstützt jede Siteauflistung nur eine Teamprojektsammlung. Es ist jedoch möglich, dass mehrere Auflistungen die gleiche Siteauflistung verwenden. Überprüfen Sie daher, dass die Siteauflistung nicht von einer anderen Teamprojektsammlung oder für andere Zwecke verwendet wird, bevor Sie die Siteauflistung löschen.

Sie müssen die Datenbank oder Siteauflistung nicht löschen, die Auflistung ist jedoch erst nach diesen Schritten vollständig gelöscht. Wenn Sie eine Auflistung aufgrund von Leistungs- oder Speicherplatzaspekten löschen, empfiehlt sich ein manuelles Löschen der Datenbank aus SQL Server und der Siteauflistung aus SharePoint-Produkte, nachdem Sie die Auflistung getrennt haben.

Hinweis Hinweis

Sie können mit dem Befehl TFSConfig Collection eine Teamprojektsammlung an einer Eingabeaufforderung löschen. Im Gegensatz zum Löschen einer Auflistung in der Verwaltungskonsole besteht bei Verwendung des TFSConfig Collection-Tools keine Möglichkeit mehr, die Auflistungsdatenbank erneut zu verbinden. Weitere Informationen finden Sie unter Collection-Befehl.

Erforderliche Berechtigungen

Zum Durchführen der folgenden Prozeduren müssen Sie Mitglied der folgenden Gruppen sein:

  • Mitglied der Administratoren-Sicherheitsgruppe auf dem Server oder den Servern, die die Verwaltungskonsole für Team Foundation ausführen

  • Mitglied der Gruppe sysadmin auf den Servern, auf denen die Instanz von SQL Server ausgeführt wird, die die Datenbanken für TFS hostet

  • ein Mitglied der Gruppe Farmadministratoren für die Farm, aus der Sie die Siteauflistung löschen, wenn die Bereitstellung SharePoint-Produkte verwendet

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

So löschen Sie eine Teamprojektsammlung

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Namen des Servers, erweitern Sie Anwendungsebene, und klicken Sie dann auf Teamprojektsammlungen.

  3. Markieren Sie in der Liste der Auflistungen den Namen der Auflistung, die Sie löschen möchten.

  4. Wählen Sie auf der Registerkarte Allgemein die Option Teamprojektsammlung trennen aus.

    Der Assistent Teamprojektsammlung trennen wird geöffnet.

  5. (Optional) Geben Sie auf der Seite Geben Sie eine Wartungsmeldung für die Teamprojektauflistung ein unter Wartungsmeldung eine Meldung für Benutzer an, die möglicherweise versuchen, eine Verbindung mit Projekten in dieser Auflistung herzustellen.

  6. Wählen Sie Weiter aus.

  7. Überprüfen Sie die Details auf der Seite Überprüfen Sie die Einstellungen für das Trennen der Teamprojektsammlung.

  8. Wenn Sie Einstellungen ändern möchten, wählen Sie Zurück. Wenn sie korrekt zu sein scheinen, wählen Sie Überprüfen.

  9. Wenn alle Bereitschaftsprüfungen erfolgreich abgeschlossen wurden, wählen Sie Trennen aus.

  10. Wenn alle Prozesse abgeschlossen sind, wählen Sie auf der Seite Dient zum Überwachen des Trennstatus für die Teamprojektsammlung die Option Weiter aus.

  11. (Optional) Notieren Sie sich auf der Seite Prüft zusätzliche Informationen für die Teamprojektauflistung den Speicherort der Protokolldatei.

  12. Wählen Sie Schließen aus.

    Die Teamprojektsammlung wird in der Verwaltungskonsole nicht mehr in der Liste der Auflistungen angezeigt.

  13. Öffnen Sie SQL Server Management Studio, stellen Sie eine Verbindung mit der Instanz des SQL Server-Datenbankmoduls her, das die Auflistungsdatenbank hostet, und erweitern Sie die Instanz.

  14. Markieren Sie den Namen der Auflistungsdatenbank (standardmäßig, TFS_Auflistungsname), und löschen Sie dann die Datenbank.

    Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Vorgehensweise: Löschen einer Datenbank.

  15. Öffnen Sie die SharePoint-Zentraladministration, und löschen Sie die Siteauflistung, die die gelöschte Auflistung unterstützt hat.

    Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Löschen einer Websitesammlung (SharePoint Foundation 2010) oder Löschen einer Websitesammlung (Microsoft Office SharePoint Server 2007).

Siehe auch

Aufgaben

Erstellen einer Teamprojektsammlung
Ändern einer Teamprojektsammlung

Konzepte

Architektur von Team Foundation Server


Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung
Siehe auch Feedback senden

Wenn Sie einer Auflistung einen Berichtsserver hinzufügen, können Projektmitglieder Standardberichte verwenden, um den Status von Teamprojekten in dieser Auflistung zu verfolgen. Zudem können Projektmitglieder die Berichte an ihre spezifischen Anforderungen anpassen. Standardmäßig wird einer Auflistung beim Erstellen Berichterstellungsunterstützung hinzufügt, wenn ein Server, auf dem SQL Server Reporting Services ausgeführt wird, als Berichtsserver für die Bereitstellung von Team Foundation Server (TFS) konfiguriert wurde. Es kann jedoch vorkommen, dass beim Erstellen der Auflistung kein Berichtsserver für die Bereitstellung konfiguriert war oder dass Sie die Standardeinstellungen überschrieben und daher keine Berichterstellung für die Auflistung konfiguriert haben. In beiden Fällen können Sie jederzeit Unterstützung für die Berichterstellung zu einer Auflistung hinzufügen, nachdem der Bereitstellung ein Berichtsserver hinzugefügt wurde.

Hinweis Hinweis

Es ist nicht möglich, den bereits in der Auflistung enthaltenen Projekten Berichte und Berichtsfunktionen hinzuzufügen, indem Sie einfach einen Berichtsserver zur Auflistung hinzufügen. Alle Teamprojekte, die Sie nach dem Hinzufügen eines Berichtsservers erstellen, verfügen über Berichtsfunktionen, während die bereits in der Auflistung vorhandenen Projekte keine Berichterstellung aufweisen.

Erforderliche Berechtigungen

Zum Durchführen dieser Schritte müssen Sie Mitglied der folgenden Gruppen sein:

  • Die Gruppe Team Foundation-Administratoren oder die Berechtigung Instanzebeneninformationen bearbeiten muss auf Zulassen festgelegt sein.

  • Sie sind Mitglied der Gruppe Inhalts-Manager oder der Gruppe TFS-Inhalts-Manager in SQL Server Reporting Services.

  • Um beim Hinzufügen eines Berichtsservers zu einer Auflistung einen Berichtsordner zu erstellen, muss das vom Hintergrundauftrags-Agent für Visual Studio Team Foundation (TFSService) verwendete Dienstkonto über bestimmte Berechtigungen verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server und Team Foundation-Hintergrundauftrags-Agent.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So fügen Sie einer Bereitstellung von Team Foundation Server einen Berichtsserver hinzu

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Namen des Servers, erweitern Sie Anwendungsebene, und klicken Sie dann auf Teamprojektsammlungen.

  3. Markieren Sie unter Teamprojektsammlungen die Auflistung, der Sie die Berichterstellung hinzufügen möchten, und klicken Sie dann auf die Registerkarte Berichtsordner.

  4. Wählen Sie auf der Registerkarte Berichtsordner die Option Standardmäßigen Speicherort des Ordners bearbeiten aus.

    Das Fenster Standardmäßigen Speicherort des Ordners bearbeiten wird geöffnet.

  5. Geben Sie unter Ordnerpfad auf dem Reporting Services-Server den relativen Pfad und Ordnernamen für Berichte für diese Auflistung an, und wählen Sie dann OK. Wenn beispielsweise der relative Pfad "tfsreports" und der Auflistungsname "Contoso1" lautet, würden Sie "/tfsreports/Contoso1" eingeben.

    Hinweis Hinweis

    Wenn das Benutzerkonto über die entsprechenden Berechtigungen verfügt, müssen Sie diesen Ordner nicht im voraus erstellen. Dieser wird automatisch erzeugt. Wenn das Dienstkonto nicht über die erforderlichen Berechtigungen verfügt, um einen Ordner in dem Pfad zu erstellen, müssen Sie einen Ordner in diesem Pfad angeben, der zu diesem Zweck erstellt wurde.

  6. Wenn eine Warnung angezeigt wird, derzufolge kein solcher Ordner vorhanden ist, überprüfen Sie, ob Sie den richtigen Ordnernamen und relativen Pfad angegeben haben. Wenn Sie einen Ordner an diesem Speicherort erstellen möchten, wählen Sie OK. Wenn Sie den Namen oder den Pfad ändern möchten, wählen Sie Abbrechen.

Siehe auch

Aufgaben

Erstellen eines Teamprojekts
Hinzufügen eines Berichtsservers zur Bereitstellung
Erstellen einer Teamprojektsammlung

Konzepte

Planen und Nachverfolgen von Projekten
Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten
Add Reports to a Team Project


Hinzufügen einer SharePoint-Webanwendung zu einer Teamprojektsammlung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Hinzufügen einer SharePoint-Webanwendung zu einer Teamprojektsammlung
Siehe auch Feedback senden

Wenn Sie einer Teamprojektsammlung eine oder mehrere SharePoint-Webanwendungen hinzufügen, können Projektadministratoren Teamprojektportale für die Teamprojekte in dieser Auflistung erstellen. Standardmäßig unterstützt eine Auflistung bei ihrer Erstellung Teamprojektportale, wenn eine Webanwendung als Teil der Bereitstellung von Team Foundation Server (TFS) konfiguriert wurde. Es kann jedoch vorkommen, dass beim Erstellen der Auflistung keine Webanwendung für die Bereitstellung konfiguriert war oder dass Sie die Standardeinstellungen überschrieben und daher keine Webanwendung für die Auflistung konfiguriert haben. In beiden Fällen können Sie einer Auflistung jederzeit eine oder mehrere Webanwendungen hinzufügen, nachdem eine Webanwendung zur Unterstützung der Bereitstellung hinzugefügt wurde.

Hinweis Hinweis

Sie können den Projekten, die bereits in einer Auflistung enthalten sind, nicht automatisch Teamprojektportale hinzufügen, indem Sie einfach eine SharePoint-Webanwendung zu einer Auflistung hinzufügen. Nachdem Sie eine Webanwendung hinzugefügt haben, können Sie im Assistenten für die Erstellung eines neuen Teamprojekts ein Projektportal für das erstellte Projekt erstellen. Für die bereits in der Auflistung enthaltenen Teamprojekte werden jedoch keine Portale automatisch in der Webanwendung erstellt.

Erforderliche Berechtigungen

Zum Durchführen dieser Schritte müssen Sie Mitglied der folgenden Gruppen sein:

  • Die Gruppe Team Foundation-Administratoren oder die Berechtigung Instanzebeneninformationen bearbeiten muss auf Zulassen festgelegt sein.

  • Die Gruppe Siteauflistungsadministratoren oder die Berechtigung Vollzugriff muss in SharePoint-Produkte auf Zulassen festgelegt sein.

  • Für eine korrekte Interaktion von TFS und SharePoint-Produkte müssen sowohl das Dienstkonto, das der Hintergrundauftrags-Agent für Visual Studio Team Foundation (TFSService) verwendet, als auch das Dienstkonto, das die SharePoint-Webanwendung verwendet, über bestimmte Berechtigungen verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server und unter Team Foundation-Hintergrundauftrags-Agent.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So fügen Sie eine SharePoint-Webanwendung und ein Standardstammverzeichnis hinzu, in dem Projektadministratoren Teamprojektportale erstellen

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Namen des Servers, erweitern Sie Anwendungsebene, und klicken Sie dann auf Teamprojektsammlungen.

  3. Klicken Sie in der Liste Teamprojektsammlungen auf die Auflistung, für die Sie eine Webanwendung und einen Standardspeicherort, an dem Teamprojektportale erstellt werden, hinzufügen möchten.

  4. Wählen Sie auf der Registerkarte SharePoint-Website die Option Standardmäßigen Websiteort bearbeiten aus.

    Das Fenster Standardmäßigen Websiteort bearbeiten wird angezeigt.

  5. Klicken Sie in der Liste SharePoint-Webanwendung auf eine Anwendung.

  6. Geben Sie unter Relativer Pfad den relativen Pfad des Speicherorts an, an dem Websites und Unterwebsites in der Webanwendung für diese Auflistung erstellt werden sollen.

    Wenn die Website nicht vorhanden ist, wird das Dialogfeld SharePoint-Website angezeigt, in dem Sie aufgefordert werden, die Erstellung der Website zu bestätigen. Klicken Sie auf Ja.

  7. Überprüfen Sie die Informationen unter Vollständiger Pfad, und wählen Sie dann OK, wenn diese korrekt sind.

Siehe auch

Aufgaben

Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung
Hinzufügen von Benutzern zu Teamprojekten

Konzepte

Organisieren des Servers mit Teamprojektsammlungen

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten
Siehe auch Feedback senden

Nachdem Sie eine Teamprojektsammlung erstellt haben, können Sie Ressourcen für diese und für die von ihr unterstützten Projekte hinzufügen und ändern. Sie können einer Auflistung nach dem Erstellen beispielsweise eine SharePoint-Webanwendung hinzufügen. Wenn Sie einer Auflistung eine Ressource hinzufügen, haben alle Projekte, die im Anschluss in dieser Auflistung erstellt werden, Zugriff auf diese Ressource. Sie können eine Ressource aber auch zu einem Projekt hinzufügen, das vor dem Hinzufügen der Ressource erstellt wurde.

Sie können die folgenden Ressourcen für die Unterstützung von Teamprojekten hinzufügen und konfigurieren:

  • Eine SharePoint-Webanwendung und eine Siteauflistung, um Teamprojektportale für Projekte in der Auflistung zu hosten

  • Eine SharePoint-Site oder eine Website, die als Portal für ein Teamprojekt fungiert

  • Ein Server, auf dem SQL Server Reporting Services ausgeführt wird, um Standardberichte und Dashboards mit Informationen zum Status eines Teamprojekts bereitzustellen

  • Leitfäden für Teamprojektmitglieder zu den Prozessen, die bei der Bearbeitung des Teamprojekts zu befolgen sind

  • Web Access-Funktionen, z. B. Planungs- und Rückstandsverwaltungstools

  • Automatisierte E-Mails, die die Projektmitglieder über Änderungen im Teamprojekt informieren

Allgemeine Aufgaben

Titel | Beschreibung
Bereitstellen von Berichten und Dashboards für Teamprojekte: Sie können Standardberichte aktivieren, die den Status der Projekten anzeigen, sowie benutzerdefinierte Berichte entwickeln, indem Sie der Bereitstellung von Visual Studio Team Foundation Server einen Berichtsserver hinzufügen. | Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen
Fördern der Zusammenarbeit zwischen Mitgliedern eines Teamprojekts: Sie können die Zusammenarbeit des Team verbessern, indem Sie Teams in Team Web Access erstellen und konfigurieren, und die Funktionen konfigurieren, die für diese Teams verfügbar sind. | Zugriff auf Funktionen über WebberechtigungenFunktionen Erste Schritte im Team Agile-Planung und -Iterationen
Automatische Weiterleitung aktueller Informationen an die Benutzer: Sie können E-Mail-Ressourcen konfigurieren, sodass die Teamprojektmitglieder E-Mail-Benachrichtigungen empfangen können, wenn bestimmte Ereignisse in einem Teamprojekt auftreten, z. B. wenn ihnen eine Arbeitsaufgabe zugewiesen wird oder ein Build abgeschlossen wird. | Konfigurieren von E-Mail-Benachrichtigungen und Angeben des SMTP-Servers Anpassen des Formats von E-Mail-Benachrichtigungen für Änderungen von Arbeitsaufgaben
Löschen eines Teamprojekts: Sie können Benutzern die Suche nach benötigten Projekten erleichtern, indem Sie alle Teamprojekte in einer Teamprojektsammlung löschen, die nicht mehr in Gebrauch sind. | Löschen eines Teamprojekts

Siehe auch

Aufgaben

Erstellen eines Teamprojekts
Hinzufügen von Benutzern zu Teamprojekten

Konzepte

Planen und Nachverfolgen von Projekten
Herstellen einer Verbindung mit Teamprojekten in Team Foundation Server
Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
Konfigurieren von Benutzern, Gruppen und Berechtigungen


Konfigurieren eines Standardspeicherorts für Teamprojektportale

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren eines Standardspeicherorts für Teamprojektportale
Siehe auch Feedback senden

Teamprojektportale lassen sich leichter organisieren und verwalten, wenn Sie einen Standardspeicherort definieren, in dem die Portale für alle Projekte in einer Teamprojektsammlung erstellt werden. Sie können diesen Speicherort beim Erstellen der Auflistung mit dem Assistenten für das Erstellen einer Teamprojektsammlung definieren. Weitere Informationen finden Sie unter Erstellen einer Teamprojektsammlung.

Sie können vorhandene Auflistungen ändern, um eine SharePoint-Website oder eine Siteauflistung als Standardspeicherort für die Erstellung von Portalen anzugeben. Beide Optionen sind zwar gültig, Sie erzielen jedoch erhebliche Vorteile, wenn Sie anstelle einer Site eine Siteauflistung angeben. Eine Siteauflistung und deren SharePoint-Websites besteht aus einer einzelnen Datenbank in SharePoint-Produkte, ebenso wie eine Teamprojektsammlung eine einzelne Datenbank in Visual Studio Team Foundation Server ist. Wenn Sie eine Siteauflistung als Stamm für alle Portale in einer Teamprojektsammlung angeben, können Sie die Datenbanken für eine Siteauflistung und eine Teamprojektsammlung basierend auf dem gleichen Zeitplan aktualisieren und verwalten. Einzelne SharePoint-Websites sind Teil einer Auflistungsdatenbank. Deren Verwaltung ist daher wesentlich schwieriger als die einer kompletten Siteauflistung. Eine Siteauflistung können Sie beispielsweise als eine Einheit in SharePoint-Produkte sichern und wiederherstellen, es ist jedoch nicht möglich, eine einzelne Site zu sichern und wiederherzustellen.

Erforderliche Berechtigungen

Zur Durchführung dieser Prozeduren müssen Sie Mitglied der Gruppe Team Foundation Administratoren sein, oder Ihre Berechtigung Serverebeneninformationen bearbeiten muss auf Zulassen festgelegt sein. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So ändern Sie den Standardspeicherort für die Erstellung von Teamprojektportalen

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie unter Team Foundation den Namen des Servers, erweitern Sie dann Anwendungsebene, und klicken Sie auf Teamprojektsammlungen.

  3. Klicken Sie auf die Teamprojektsammlung, die Sie ändern möchten, und dann auf die Registerkarte SharePoint-Website.

    Hinweis Hinweis

    Die Registerkarte wird nicht angezeigt, wenn keine SharePoint-Webanwendungen für die Verwendung in der Bereitstellung konfiguriert wurden. Sie müssen eine Anwendung konfigurieren, bevor Sie einen Standardspeicherort für Portale konfigurieren können. Weitere Informationen finden Sie unter Ändern oder Entfernen des Zugriffs zwischen einer SharePoint-Webanwendung und Team Foundation Server.

  4. Klicken Sie auf Standardmäßigen Websiteort bearbeiten.

    Das Dialogfeld Standardmäßigen Websiteort bearbeiten wird geöffnet.

  5. Klicken Sie in der Liste SharePoint-Webanwendung auf die Webanwendung, die Sie verwenden möchten.

  6. Geben Sie unter Relativer Pfad den relativen Pfad der Site oder Siteauflistung ein, die Sie als Stammsite angeben möchten, in der Teamprojektportale für diese Auflistung erstellt werden.

    Hinweis Hinweis

    Wenn an den angegebenen Speicherort keine Site vorhanden ist, wird ein Dialogfeld angezeigt, in dem Sie bestätigen müssen, dass Sie eine Site an diesem Speicherort erstellen möchten.

    Alle Teamprojektportale werden als Unterwebsites dieses Speicherorts erstellt, sofern der Administrator, der das Teamprojekt erstellt, keinen anderen Speicherort angibt.

  7. Stellen Sie sicher, dass die Pfadangabe unter Vollständiger Pfad korrekt ist, und klicken Sie dann auf OK.

Siehe auch

Konzepte

Organisieren des Servers mit Teamprojektsammlungen

Weitere Ressourcen

How to: Add a Team Project Portal
Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Zugriff auf Funktionen über Webberechtigungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Zugriff auf Funktionen über Webberechtigungen
Siehe auch Feedback senden

Die Benutzer können bestimmte Funktionen in Team Web Access standardmäßig anzeigen. Als Mitglied der Gruppe Team Foundation Administrators können Sie diese Standardfunktionsebene für einige oder alle Benutzer ändern, müssen für diese Benutzer allerdings über die entsprechende Lizenzierung verfügen. Um Team Web Access und seine Funktionen besser verstehen zu lernen, müssen Sie wissen, dass es drei Funktionsebenen gibt. Jede Funktion entspricht der für den Benutzer verfügbaren Lizenz:

  • Eingeschränkt:

    • Bei dieser Zugriffsebene kann der Benutzer nur Arbeitsaufgaben anzeigen, die in Team Web Access erstellt werden (auch als "Arbeitsaufgabenexklusive Ansicht" bezeichnet). Weitere Funktionen, z. B. Teamseiten, sind für Benutzer dieser Gruppe nicht verfügbar. Weitere Informationen finden Sie unter Verwalten von Arbeitsaufgaben in der arbeitsaufgabenexklusiven Ansicht (Team Web Access).

    • Für diese Ebene von Team Web Access ist keine Clientzugriffslizenz (CAL) erforderlich.

  • Standard:

    • Dies ist in Team Web Access die Standardzugriffsebene für Benutzer. Mitglieder dieser Gruppe können alle Team Web Access-Funktionen anzeigen, mit Ausnahme der folgenden Funktionen:

      • Sprintplanungs- und Rückstandsansichten

      • Funktionen für die Anforderung von Feedback von Benutzern und für die Verwaltung dieses Feedbacks

    • Eine Team Foundation Server (TFS)-CAL ist für alle Benutzer dieser Ebene erforderlich.

  • Uneingeschränkt:

    • Diese Ebene ist für Benutzer vorbehalten, die über eine Lizenz für alle Funktionen von Team Web Access verfügen, einschließlich der Sprintplanungs- und Rückstandsverwaltungstools und Tools zur Feedbackanforderung und -verwaltung.

    • Für diese Funktionen muss der Benutzer über eine Lizenz für eines der folgenden MSDN-Abonnements verfügen: Visual Studio Test Professional mit MSDN, Visual Studio Premium mit MSDN oder Visual Studio Ultimate mit MSDN.Jedes dieser MSDN-Abonnements umfasst eine TFS-CAL für den Abonnenten.

Tipp Tipp

Ausführliche Lizenzierungsinformationen finden Sie unter Visual Studio 2012 und MSDN - Lizenzierungs-Whitepaper.

Abgesehen von den Lizenzierungsüberlegungen benötigen nicht alle Benutzer die gleiche Funktionsebene, um ihre Arbeit auszuführen. Die Serverauslastung lässt sich besser verwalten, indem Sie die Team Web Access-Funktionen steuern, die für die verschiedenen Benutzergruppen verfügbar sind, wenn sie mit der Bereitstellung von Team Foundation Server (TFS) eine Verbindung herstellen.

Durch den Zugriff auf Funktionen in Team Web Access werden Benutzern nicht automatisch Berechtigungen erteilt, die für die Verwendung dieser Funktionen erforderlich sind. Die Verwaltung von Berechtigungen ist eine separate Aufgabe. Weitere Informationen finden Sie unter Erstellen und Konfigurieren eines Teams und Hinzufügen von Benutzern zu Teamprojekten.

Wichtiger Hinweis Wichtig

Wenn Sie Funktionen für ein Projekt aktivieren möchten, das Sie von einer früheren Version von TFS aktualisiert haben, müssen Sie zusätzliche Schritte ausführen. Folgen Sie diesem Leitfaden: Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen.

Team Web Access-Funktionen und -Ansichten, wie von den Zugriffsgruppen gesteuert

Standardmäßig steht allen Benutzern der Bereitstellung die Standard-Funktionszugriffsebene in Team Web Access, wie oben aufgeführt, zur Verfügung. Sie können die Standard-Zugriffsebene für alle Benutzer ändern oder den Zugriff auf bestimmte Funktionsebenen für einzelne Benutzer und Gruppen konfigurieren. Auch wenn sich mit der Standard-Funktionszugriffsebene die Benutzererfahrung erheblich verbessern lässt, kann diese eine zusätzliche Belastung für den Server darstellen, vor allem dann, wenn der Server nur über begrenzte Ressourcen verfügt. Die Erweiterung der Zugriffsebene hat auch Auswirkungen auf die Lizenzierung. Aus diesen Gründen ist die Änderung der Standard-Zugriffsebene für alle Benutzer möglicherweise nicht gewünscht. Außerdem soll möglicherweise das Anzeigen von Funktionen, die von Benutzern nicht benötigt werden oder für deren Verwendung ihnen keine Lizenz zur Verfügung steht, für diese Benutzer eingeschränkt werden. So können Sie den Zugriff von Benutzern, die nur auf die im Rahmen ihrer täglichen Arbeit erforderlichen eigenen Aufgaben zugreifen müssen, so konfigurieren, dass ihnen Funktionen nur eingeschränkt zur Verfügung stehen.

Der Zugriff auf Team Web Access-Funktionen wird durch die Verwaltungswebsite von Team Web Access gesteuert, nicht über die Team Foundation Server-Verwaltungskonsole. Die Standardzugriffsebene wird für die gesamte Bereitstellung festgelegt. Um bestimmte Zugriffsebenen für Benutzer von Auflistungen, Teamprojekten oder Teams zu konfigurieren, müssen Sie die Benutzer oder Gruppen manuell zu einer der drei Zugriffsgruppen in Team Web Access hinzufügen.

Zugriffsgruppen für Team Web Access

Die Ansichten und Funktionen, die in Team Web Access verfügbar sind, richten sich nach folgenden Kriterien:

  • Eingeschränkt. Ausführliche Informationen und Beispiele dafür, was welche Mitglieder dieser Gruppe anzeigen können, finden Sie unter Verwalten von Arbeitsaufgaben in der arbeitsaufgabenexklusiven Ansicht (Team Web Access).

  • Standard. Mitglieder dieser Gruppe können die Homepages für Teams anzeigen, denen sie angehören. Ihnen stehen Schnellzugriffslinks zum Taskboard, zu den Teamfavoriten, Arbeitsaufgaben und allen Funktionen außer Feedback- und Rückstandsansichten zur Verfügung.

    Verfügbare Funktionen in "Aktivitäten" - Standardansicht

  • Uneingeschränkt. Mitglieder dieser Gruppe können alle Standardfunktionen inklusive der Rückstands- und Feedbackansicht anzeigen. Ihnen stehen Schnellzugriffslinks zu allen Aktivitäten zur Verfügung.

    Lightweight-Dashboard für Team Web Access Link zur Feedbackanforderung unter Aktivitäten

Wenn Sie einen Benutzer mehr als einer Zugriffsgruppe hinzufügen, hat dieser Benutzer Zugriff auf die Funktionen, die in der Zugriffsgruppe mit den meisten Funktionen zulässig sind. Wenn Sie beispielsweise den Benutzer der Eingeschränkt- und auch der Standard-Gruppe hinzufügen, kann der Benutzer die Funktionen anzeigen, auf die die Standardgruppe Zugriff hat.

Funktionszugriffskonfiguration und -verwaltung

Erforderliche Berechtigungen

Um die nachfolgenden Schritte ausführen zu können, müssen Sie Mitglied der Gruppe Team Foundation-Administratoren sein. Wenn Sie kein Mitglied dieser Gruppe sind, können Sie die Registerkarte Webzugriff nicht anzeigen und auch keine Änderungen vornehmen.

So zeigen Sie die Standard-Funktionszugriffsgruppe für Team Foundation Server an oder ändern diese

  1. Öffnen Sie Team Web Access im Verwaltungsmodus, und wählen Sie Systemsteuerung aus, um zum Verwaltungskontext auf oberster Ebene zu navigieren.

  2. Wählen Sie die Registerkarte Web Access aus.

  3. Wählen Sie in Web Access-Berechtigungen den Namen der Zugriffsgruppe, für die Informationen angezeigt werden sollen. Überprüfen Sie Folgendes:

    • Die Liste der Funktionen, die für diese Gruppe verfügbar sind.

    • Ob die Gruppe als Standard für die Bereitstellung festgelegt ist. In diesem Fall folgt auf diesen Gruppennamen (Standard). Dies ist die Gruppe, der alle Benutzer der Bereitstellung von Team Foundation Server standardmäßig zugewiesen werden.

    • Ob alle Benutzer oder Gruppen explizit dieser Gruppe zugewiesen sind. Wenn Sie keine Benutzer oder Gruppen explizit für diese Gruppe konfigurieren, sehen Sie keine Liste von Identitäten, die dieser Gruppe zugewiesen sind.

  4. Wählen Sie, um eine andere Gruppe als Standard auszuwählen, diese Gruppe im Explorer-Fenster und in Web Access-Berechtigungen für diese Gruppe die Option Als Standardwebzugriff festlegen aus.

    Wurde die Gruppe bereits als Standard festgelegt, ist diese Option nicht verfügbar.

So fügen Sie Benutzer oder Gruppen zu einer Funktionszugriffsgruppe hinzu

  1. Öffnen Sie die Registerkarte Webzugriff und wählen Sie die Gruppe aus, der Sie Mitglieder hinzufügen möchten.

  2. Wählen Sie in Web Access-Berechtigungen die Option Hinzufügen, und wählen Sie dann eine der folgenden Optionen:

    • Windows-Benutzer oder -Gruppe hinzufügen, wenn Sie Benutzer oder Gruppen vom lokalen Computer oder aus dem Active Directory hinzufügen möchten;

    • TFS-Gruppe hinzufügen, wenn Sie eine Gruppe auf Serverebene hinzufügen möchten.

      Hinweis Hinweis

      Sie können in diesem Kontext nur Gruppen auf Serverebene hinzufügen, nicht auf Auflistungsebene oder Projektebene. Möchten Sie den Zugriff auf Funktionen für Benutzer von bestimmten Teamprojektauflistungen oder Teamprojekten steuern, ist dies nur durch Hinzufügen mithilfe von Windows-Benutzer oder -Gruppe hinzufügen möglich.

  3. Wählen Sie die Benutzer oder Gruppen aus, die Sie hinzufügen möchten. Auf Dauer ist es meistens einfacher, Benutzer mithilfe von Gruppen zu verwalten, anstatt bestimmte Benutzerkonten. Wenn Sie die Benutzer oder Gruppen hinzugefügt haben, gehen Sie auf Änderungen speichern.

So überprüfen Sie für Benutzer verfügbare Funktionen durch Exportieren des Überwachungsprotokolls

  1. Öffnen Sie die Registerkarte Webzugriff, und wählen Sie im Explorer-Fenster die Option Überwachungsprotokoll exportieren aus.

  2. Führen Sie einen der folgenden Schritte aus:

    1. Wählen Sie Speichern, um die Datei am gewünschten Speicherort zu speichern. Der Dateityp ist eine Microsoft Excel-CSV-Datei (.csv). Nachdem Sie die Datei gespeichert haben, können Sie sie mit einem beliebigen Programm öffnen, das eine durch Trennzeichen getrennte Datei, z. B. Microsoft Excel, lesen kann.

    2. Wählen Sie Öffnen, um die Datei mit einem Programm zu öffnen, das eine CSV-Datei lesen kann.

  3. Öffnen Sie die Datei, und überprüfen Sie die Informationen. Die Datei enthält Informationen für jeden Benutzer und jede Gruppe in "Gültige Team Foundation-Benutzer", mit einzelnen Identitäten in Zeilen, und Werten in den folgenden Spalten, und zwar wie folgt:

    • Anzeigename: der Name des Benutzers oder der Gruppe, wie in TFS angezeigt. TFS-Gruppennamen wird die Projekt-, Auflistungs- oder Serverebenenbezeichnung in Klammern vorangestellt. Beispielsweise wird die Gruppe "Leser" für das Teamprojekt "Telefon Bildschirmschoner" als "[Telefon Bildschirmschoner]\Leser" angezeigt.

    • Eindeutiger Name: der eindeutige Name des Benutzers oder der Gruppe gemäß Domäne oder Arbeitsgruppe auf dem Computer und in TFS. Beispiel: Die Gruppe "Lokale Administratoren" wird als "VORDEFINIERT\Administratoren" angezeigt, die eindeutigen Namen der Gruppen auf Projektebene in TFS enthalten ein Präfix vstfs:///Classification/TeamProject, Domänen-Benutzer oder -Gruppen verfügen über ihre eindeutige Active Directory-Domäne und -Benutzernamen usw.

    • Servername: der Name des Servers, auf dem die Anwendungsebene bereitgestellt wird. In NLB-Bereitstellungen werden möglicherweise mehrere Servernamen aufgeführt.

    • Zuletzt aufgerufen (UTC): Datum und Uhrzeit des letzten TFS-Zugriffs eines Benutzers im Format Coordinated Universal Time (UTC).

    • IsGroup: gibt an, ob die Identität ein Benutzer oder eine Gruppe ist. Eine 0 bedeutet "Nein"; eine 1 "Ja". Beispielsweise wird der Eintrag für "Telefon Bildschirmschoner\Mitwirkende" mit einer 1 in der IsGroup-Spalte gekennzeichnet, was angibt, dass es sich um eine Gruppe handelt.

    • Eingeschränkt: gibt an, ob es sich bei der Identität explizit um ein Mitglied der Gruppe mit eingeschränktem Zugriff handelt. Eine 0 bedeutet "Nein"; eine 1 "Ja". Die Mitgliedschaft in der Standard-Zugriffsgruppe ist nicht in dieser Spalte angegeben, selbst dann nicht, wenn die Mitgliedschaftsebene einer bestimmten Gruppe entspricht. Beispielsweise ist die Standard-Zugriffsgruppe "Eingeschränkt", aber die Identität wurde nicht explizit zu dieser Gruppe hinzugefügt, der Wert dieser Spalte wird als 0 angezeigt, und die IsDefault-Spalte als 1, was bedeutet, dass diese Identität nur Zugriff auf den eingeschränkte Satz von Team Web Access-Funktionen hat, da dies der Standardsatz von Funktionen ist, der Benutzern zur Verfügung steht.

    • Standard: gibt an, ob es sich bei der Identität explizit um ein Mitglied der Gruppe mit Standard-Zugriff handelt. Eine 0 bedeutet "Nein"; eine 1 "Ja". Die Mitgliedschaft in der Standard-Zugriffsgruppe ist nicht in dieser Spalte angegeben, selbst dann nicht, wenn die Mitgliedschaftsebene einer bestimmten Gruppe entspricht.

    • Uneingeschränkt: gibt an, ob es sich bei der Identität explizit um ein Mitglied der Gruppe mit uneingeschränktem Zugriff handelt. Eine 0 bedeutet "Nein"; eine 1 "Ja". Die Mitgliedschaft in der Standard-Zugriffsgruppe ist nicht in dieser Spalte angegeben, selbst dann nicht, wenn die Mitgliedschaftsebene einer bestimmten Gruppe entspricht.

    • IsDefault: gibt an, ob die Identität die Standard-Zugriffsebene auf Team Web Access-Funktionen für die Bereitstellung verwendet. Eine 0 bedeutet "Nein"; eine 1 "Ja". Wenn Sie keine Zugriffsebenen für Benutzer oder Gruppen in der Bereitstellung festlegen, werden alle Identitäten auf 1 festgelegt.

    Weitere Informationen zu Lizenzierungsebenen und Funktionen in Team Foundation Server finden Sie unter Visual Studio 2012 und MSDN - Lizenzierungs-Whitepaper.

Siehe auch

Aufgaben

Hinzufügen von Benutzern zu Teamprojekten

Konzepte

Erste Schritte im Team
Agile-Planung und -Iterationen
Kompatibilität zwischen Team Foundation-Clients und Team Foundation Server
Fragen Sie die Projektbeteiligte-Feed-back und verarbeiten Sie mit Team Web Access verwenden

Weitere Ressourcen

View or change your permissions or join another team
Arbeiten innerhalb von Team Web Access


Konfigurieren von E-Mail-Benachrichtigungen und Angeben des SMTP-Servers

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von E-Mail-Benachrichtigungen und Angeben des SMTP-Servers
Siehe auch Feedback senden

Mithilfe von E-Mail-Benachrichtigungen können Sie Teammitglieder über Änderungen an Projekten, Arbeitsaufgaben und Builds informieren. Die Teammitglieder können dann festlegen, welche E-Mail-Benachrichtigungen sie zu verschiedenen Änderungen an Projekten, Arbeitsaufgaben und Builds erhalten möchten. Um E-Mail-Benachrichtigungen verwenden zu können, müssen Sie Team Foundation Server so konfigurieren, dass ein vorhandener SMTP-Server zum Senden von E-Mail-Warnungen verwendet wird. Hierzu können Sie entweder die Verwaltungskonsole von Team Foundation oder TFSConfig mit dem ConfigureMail-Befehl verwenden. Um E-Mail-Benachrichtigungen senden zu können, müssen Sie in der Bereitstellung Folgendes konfigurieren:

  • Die Firewall muss so konfiguriert werden, dass die Kommunikation zwischen Team Foundation Server und dem SMTP-Server möglich ist.

  • Das Dienstkonto für Team Foundation Server (angegeben durch den Platzhalter TFSService) muss entweder ein Domänenkonto mit Berechtigungen zum Senden von E-Mails sein (der SMTP-Server muss so konfiguriert werden, dass anonyme Absender E-Mails senden können), oder Sie müssen zuvor ein Konto erstellt haben, das als E-Mail-Konto für Warnungen verwendet wird.

Wichtiger Hinweis Wichtig

Wenn Sie ein Systemkonto (wie Netzwerkdienst) als Dienstkonto für Team Foundation Server verwendet haben, müssen Sie den SMTP-Server so konfigurieren, dass anonyme Absender E-Mails senden können, oder Sie müssen sicherstellen, dass eine für die Bereitstellung geeignete Konfiguration der integrierten Authentifizierungseinstellungen erfolgt. Andernfalls werden keine E-Mail-Benachrichtigungen gesendet.

Sie können auch den Inhalt und das Format von Team Foundation Server-Benachrichtigungs-E-Mails anpassen. Weitere Informationen finden Sie unter Anpassen des Formats von E-Mail-Benachrichtigungen für Änderungen von Arbeitsaufgaben.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie auf dem Team Foundation-Anwendungsebenenserver Mitglied der Gruppe Administratoren und Mitglied der Gruppe Team Foundation-Administratoren sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

So konfigurieren Sie E-Mail-Benachrichtigungen mit der Verwaltungskonsole

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie unter Team Foundation den Namen des Servers, und klicken Sie dann auf Anwendungsebene.

  3. Klicken Sie unter Anwendungsebene im Bereich E-Mail-Warnungseinstellungen auf Warnungseinstellungen.

    Das Fenster E-Mail-Warnungseinstellungen wird geöffnet.

  4. Aktivieren Sie das Kontrollkästchen E-Mail-Warnungen aktivieren.

  5. Geben Sie im Feld SMTP-Server den Namen des SMTP-Servers an, den Sie verwenden möchten.

  6. Geben Sie unter E-Mail von Adresse den Namen des E-Mail-Kontos an, von dem Warnungen gesendet werden.

    Hinweis Hinweis

    Sie müssen sowohl die E-Mail-Adresse angeben, von der die Warnungen gesendet werden, als auch den SMTP-Server.

  7. Erweitern Sie den Abschnitt Erweiterte SMTP-Einstellungen.

  8. Wenn Sie ein Systemkonto wie "Netzwerkdienst" als Dienstkonto für Team Foundation Server verwenden, lassen Sie die Felder "Benutzer" und "Kennwort" leer, und stellen Sie sicher, dass der SMTP-Server so konfiguriert ist, dass anonyme Benutzer E-Mail-Nachrichten senden können. Alternativ können Sie ein E-Mail-aktiviertes Domänenkonto spezifizieren, um dieses als E-Mail-Konto für Warnungen zu verwenden.

  9. Konfigurieren Sie die Werte für Port und Fingerabdruck des Zertifikats entsprechend der SMTP-Bereitstellung. Wenn die Bereitstellung HTTPS/SSL verwendet, aktivieren Sie das Kontrollkästchen SSL aktivieren.

  10. Überprüfen Sie alle Einstellungen, und wählen Sie dann OK aus.

So konfigurieren Sie E-Mail-Warnungen mit dem ConfigureMail-Befehl

  1. Öffnen Sie auf dem Anwendungsebenenserver ein Eingabeaufforderungsfenster, und wechseln Sie in das Verzeichnis, in dem sich das TFSConfig-Hilfsprogramm befindet.

    Standardmäßig befindet sich dieses Hilfsprogramm unter Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie an der Eingabeaufforderung folgenden Befehl ein, und drücken Sie danach die EINGABETASTE:

    TFSConfig ConfigureMail /FromEmailAddress:E-Mail-Adresse /SmtpHost:SMTPHostName

    Sie müssen sowohl die "von"-Adresse für E-Mail-Benachrichtigungen von Team Foundation Server (E-Mail-Adresse) als auch den Namen des Servers angeben, der den SMTP-Mailserver (SMTPHostName) hostet.

Siehe auch

Aufgaben

Anpassen des Formats von E-Mail-Benachrichtigungen für Änderungen von Arbeitsaufgaben

Referenz

ConfigureMail-Befehl

Konzepte

Die Team Foundation-Verwaltungskonsole

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Anpassen des Formats von E-Mail-Benachrichtigungen für Änderungen von Arbeitsaufgaben

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Anpassen des Formats von E-Mail-Benachrichtigungen für Änderungen von Arbeitsaufgaben
Siehe auch Feedback senden

Sie können den Inhalt und das Format von E-Mail-Benachrichtigungen bei Änderungen anpassen, die Sie oder die Teammitglieder an Arbeitsaufgaben vornehmen, indem Sie ihre zugeordneten XSL-Transformationsdateien ändern. Die Teammitglieder können Projektwarnungen in Team Explorer für verschiedene Benachrichtigungen konfigurieren und angeben, ob sie HTML oder Nur-Text als Format verwenden möchten. Sie können z. B. Benachrichtigungen für Projekte, Arbeitsaufgaben und Buildereignisse generieren, und Sie können das Erscheinungsbild der Benachrichtigungen anpassen, die an den Team Foundation-Benutzer gesendet werden.

Die Transformationsdateien für E-Mail-Benachrichtigungen werden im folgenden Ordner auf dem Anwendungsebenenserver gespeichert:

Laufwerk:\Programme\Microsoft Visual Studio 2010 Team Foundation Server\Application Tier\TFSJobAgent\Transforms

Zum Ändern der Transformationsdateien können Sie einen XML-Editor wie Visual Studio verwenden. Die folgende Liste stellt die beiden Transformationsdateien für das Arbeitsaufgabenereignis dar:

WorkItemChangedEvent.xsl | Formatierung für E-Mails im HTML-Format
WorkItemChangedEvent.plaintextXsl | Formatierung für Nur-Text-E-Mails

Der Ereignisdienst wandelt die XML-Daten für ein Ereignis mithilfe der XSL- und der plaintextXsl-Dateien in eine E-Mail-Nachricht um. Bearbeiten Sie die XSL-Datei, um ein anderes Format für die E-Mail-Benachrichtigung zu erhalten. Für HTML-formatierte E-Mail-Nachrichten wird das Hauptlayout für alle Ereignisse in der Datei "TeamFoundation.xsl" gespeichert. Sie sollten eine Sicherungskopie der Dateien erstellen, die Sie ändern möchten, und die Änderungen anschließend testen. Nachdem Sie die Änderungen vorgenommen haben, verwendet Team Foundation Server die geänderte Transformation bei der nächsten Erstellung einer Benachrichtigung für ein Ereignis.

Hinweis Hinweis

Der Inhalt der ausgegebenen E-Mail-Nachrichten wird automatisch von der Datei "TeamFoundation.xsl" und den oben erwähnten WorkItemChangedEvent-XSL-Dateien generiert. Es wird nicht empfohlen, die Datei "TeamFoundation.xsl" zu ändern. Wenn Sie den Inhalt dieser Datei ändern, müssen Sie die Änderungen gründlich testen. Nicht korrekte Änderungen an dieser Datei können dazu führen, dass Team Foundation-E-Mail-Benachrichtigungen fehlschlagen und Sie Arbeitsaufgaben, Changesets oder Dateien von Team Foundation nicht in einem Webbrowser anzeigen können.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Administratoren-Sicherheitsgruppe auf dem Team Foundation-Anwendungsebenenserver sein.

So bearbeiten Sie die E-Mail-Vorlage, um bei Änderungen der Arbeitsaufgabe E-Mail-Benachrichtigungen zu senden

  1. Öffnen Sie auf dem Anwendungsebenenserver folgenden Ordner:

    Laufwerk:\Programme\Microsoft Visual Studio 2010 Team Foundation Server\Application Tier\TFSJobAgent\Transforms

  2. Öffnen Sie die Datei "WorkItemChangedEvent.xsl" in Editor oder einem anderen Text-Editor.

    Hinweis Hinweis

    Selbst wenn Sie mit Administratorrechten angemeldet sind, müssen Sie Editor oder einen anderen Text-Editor als Administrator öffnen, um diese Funktion auf einem Server auszuführen, auf dem Windows Server 2008 ausgeführt wird. Um den Editor als Administrator zu öffnen, klicken Sie auf Start, klicken mit der rechten Maustaste auf Eingabeaufforderung und klicken dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der Microsoft-Website: "Benutzerkontensteuerung".

  3. Bearbeiten Sie die Datei, sodass sie den für die Benachrichtigungs-E-Mail gewünschten Inhalt anzeigt.

    Hinweis Hinweis

    Nehmen Sie an der Datei "WorkItemChangedEvent.plaintextXsl" für alle Benutzer, die Nur-Text-Nachrichten erhalten, ähnliche Änderungen vor.

  4. Speichern Sie die Datei WorkItemChangedEvent.xsl.

Siehe auch

Aufgaben

Konfigurieren von E-Mail-Benachrichtigungen und Angeben des SMTP-Servers

Weitere Ressourcen

Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten


Löschen eines Teamprojekts

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Löschen eines Teamprojekts
Siehe auch Feedback senden

Sie können die Komplexität eines Teamprojekts reduzieren und die Navigation für Benutzer vereinfachen, indem Sie nicht mehr verwendete Teamprojekte aus der Teamprojektsammlung löschen. Bevor Sie ein Projekt löschen, sollten Sie sicherstellen, dass das Projekt und die zugehörigen Daten nicht mehr benötigt werden. Durch das Löschen eines Teamprojekts werden die Daten für das Projekt aus der Sammlungsdatenbank in SQL Server entfernt. Wenn die Berichterstellung für das Projekt verwendet wurde, können Sie beim Löschen des Projekts auch die Berichte und Berichtsdaten entfernen. Bei einem Projekt mit Teamprojektportal werden alle Verweise auf dieses Portal entfernt, die SharePoint-Website bzw. die als Portal fungierende Website wird jedoch nicht gelöscht. Wenn Sie das Portal löschen möchten, müssen Sie diesen Schritt nach dem Löschen des Projekts manuell durchführen.

Ein Teamprojekt kann über die Verwaltungskonsole für Team Foundation gelöscht werden. Es ist auch möglich, die Befehlszeile zu verwenden, die Vorgehensweise unterscheidet sich dabei jedoch erheblich, und zudem werden andere Elemente entfernt. Weitere Informationen über die Verwendung der Befehlszeile finden Sie unter TFSDeleteProject: Löschen von Teamprojekten.

Erforderliche Berechtigungen

Um diese Vorgänge auszuführen, müssen Sie Mitglied der folgenden Gruppen sein oder über folgende Berechtigungen verfügen:

  • Gruppe Team Foundation-Administratoren, oder die Berechtigungen Instanzebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten müssen auf Zulassen festgelegt sein.

  • Wenn Sie die Berichterstellungskomponente für dieses Projekt aus SQL Server Reporting Services entfernen möchten, müssen Sie Mitglied der Gruppe Team Foundation-Inhalts-Manager oder der Gruppe Systemadministratoren sein.

    Wichtiger Hinweis Wichtig

    Zum Ausführen von Verwaltungsaufgaben wie dem Löschen von Teamprojekten müssen Ihrem Benutzerkonto Administratorberechtigungen zugewiesen sein, und das vom Team Foundation-Hintergrundauftrags-Agent verwendete Dienstkonto muss ebenfalls über bestimmte Berechtigungen verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server und Team Foundation-Hintergrundauftrags-Agent.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Neben diesen Berechtigungen müssen Sie auf einem Computer, auf dem Windows Server 2008 oder Windows Vista ausgeführt wird, gegebenenfalls Folgendes durchführen:

  • Zum Ausführen einer Prozedur, für die Internet Explorer erforderlich ist, müssen Sie Internet Explorer möglicherweise als Administrator starten. Klicken Sie hierzu auf Start, Alle Programme und dann mit der rechten Maustaste auf Internet Explorer. Klicken Sie anschließend auf Als Administrator ausführen.

  • Um Zugriff auf den Berichts-Manager, Berichte oder Websites für Reporting Services zu erhalten, müssen Sie diese Sites möglicherweise in Internet Explorer der Liste der vertrauenswürdigen Sites hinzufügen oder Internet Explorer als Administrator starten.

Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

So löschen Sie ein Teamprojekt über die Verwaltungskonsole

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Server, und klicken Sie dann auf Teamprojektsammlungen.

  3. Klicken Sie unter Teamprojektsammlungen auf die Sammlung mit dem zu löschenden Projekt, und klicken Sie dann auf die Registerkarte Teamprojekte.

  4. Klicken Sie in Teamprojekte auf das zu löschende Projekt und dann auf Löschen.

    Das Fenster Teamprojekte löschen wird geöffnet.

  5. (Optional) Aktivieren Sie im Fenster Teamprojekte löschen die folgenden Kontrollkästchen (eines oder beide).

    • Aktivieren Sie das Kontrollkästchen Externe Artefakte löschen, wenn Sie Daten für dieses Teamprojekt aus Reporting Services und Visual Studio Lab Management entfernen möchten.

    • Aktivieren Sie das Kontrollkästchen Arbeitsbereichsdaten, wenn Sie diesem Teamprojekt zugeordnete Arbeitsbereiche entfernen möchten.

  6. Klicken Sie in Teamprojekte löschen auf Löschen.

    Das Fenster Teamprojekte löschen wird geschlossen.

  7. Überprüfen Sie auf der Registerkarte Teamprojekte den Zustand des Teamprojekts.

    Für den Status wird Gelöscht angezeigt, und in Klammern sind weitere Informationen zum Zustand des Löschprozesses aufgeführt.

    • (Verarbeitung) bedeutet, dass der Prozess gestartet wurde und ausgeführt wird.

    • (Ausstehend) bedeutet, dass der Löschprozess von einer Clientanwendung aus gestartet wurde. Der Löschprozess kann noch ausgeführt werden oder fehlgeschlagen sein. Da der Prozess von einer Clientanwendung aus gestartet wurde, kann der Server den genauen Status des Löschprozesses nicht melden. Wenn der Löschprozess für ein Projekt lange als ausstehend angezeigt wird, sollten Sie erneut versuchen, das Projekt über die Verwaltungskonsole zu löschen.

    • (Fehler) bedeutet, dass der Löschprozess gestartet, aber nicht erfolgreich abgeschlossen wurde. Die Protokolldatei enthält spezifische Informationen zum Fehler. Überprüfen Sie die Informationen zum Fehler, und versuchen Sie dann erneut, das Projekt zu löschen.

  8. (Optional) Überprüfen Sie im Abschnitt Protokolle in der Konsole die Informationen zum Löschprozess in der Protokolldatei.

Siehe auch

Aufgaben

Erstellen eines Teamprojekts

Weitere Ressourcen

Move a Team Project Collection
Split a Team Project Collection


Team Foundation Server-Dienste und -Dienstkonten

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Team Foundation Server-Dienste und -Dienstkonten
Feedback senden

Visual Studio Team Foundation Server (TFS), Team Foundation und die Produkte, in die diese integriert werden, enthalten verschiedene Dienste und Dienstkonten, die auf einigen oder allen logischen Ebenen und physischen Computern innerhalb einer Bereitstellung ausgeführt werden. Abhängig von der Konfiguration der Bereitstellung, den Sicherheitsanforderungen und den installierten Komponenten, können Sie das gleiche Konto für all diese Dienstkonten verwenden, oder Sie verwenden unterschiedliche Konten. Zur besseren Unterscheidung wird mit Platzhalternamen auf jedes Dienstkonto getrennt verwiesen. In den Themen dieses Abschnitts werden die Dienste, die in einer Bereitstellung von TFS verwendet werden, die Dienstkonten, unter denen diese Dienste ausgeführt werden, und die Verwaltung dieser Konten beschrieben.

In diesem Abschnitt

Team Foundation-Hintergrundauftrags-Agent

Beschreibt, wie der Hintergrundauftrags-Agent von Team Foundation einen allgemeinen Ablaufplanungsmechanismus für Webdienste bereitstellt, auf den TFS aufbaut.

Anzeigen von Team Foundation Server-Diensten

Beschreibt, wie die Dienste für TFS und die mit TFS installierten Webdienst-Anwendungspools angezeigt werden.

Dienstkonten und Abhängigkeiten in Team Foundation Server

Hier werden die Dienstkonten aufgeführt, die für TFS erforderlich sind, und Anleitungen zur Verwaltung dieser Konten sowie der erforderlichen Berechtigungen gegeben. Von der Verteilung der Funktionen in der Bereitstellung hängt ab, auf welchen physischen Computern welche Dienste und Dienstkonten ausgeführt werden. Zusätzlich zu den von Team Foundation verwendeten Diensten und Dienstkonten müssen Sie möglicherweise die Dienstkonten für Softwareprogramme verwalten, die für TFS konfiguriert sind, z. B. SharePoint-Produkte und SQL Server.

Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services

Stellt eine schrittweise Anweisung zum Ändern des Dienstkontos für SQL Server Reporting Services-Datenquellen sowie zum Ändern des Kennworts für dieses Konto bereit.

Ändern des Dienstkontos oder Kennworts für Team Foundation Server

Stellt eine schrittweise Anweisung zum Ändern des Dienstkontos für TFS sowie des Kennworts für dieses Konto bereit.

Referenz

Verwalten der Serverkonfiguration mit TFSConfig

Beschreibt, wie TFS mithilfe von TFSAdminUtil.exe so aktualisiert wird, dass neue Anmeldeinformationen für die Dienstkonten verwendet werden, auf denen TFS beruht.

Verwandte Abschnitte

Architektur von Team Foundation Server

TFS-Verwaltungsforum


Team Foundation-Hintergrundauftrags-Agent

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Team Foundation-Hintergrundauftrags-Agent
Siehe auch Feedback senden

Der Hintergrundauftrags-Agent für Visual Studio Team Foundation stellt einen allgemeinen Planungsmechanismus für Webdienste und Aufträge in Team Foundation bereit. Dieser Windows-Dienst wird zudem verwendet, um die von verschiedenen Assistenten erzeugten Aufgaben auszuführen, z. B. vom Assistent für neue Teamprojekte und für die Erstellung einer Teamprojektsammlung. Der Dienst verwendet das Dienstkonto für Team Foundation Server, das auch als TFSService bezeichnet wird. Der Dienst kann auf jedem Server mit einem Webdienst oder einer Webanwendung in der logischen Anwendungsebene für Team Foundation ausgeführt werden. Für einen ordnungsgemäßen Betrieb muss das Dienstkonto für den Hintergrundauftrags-Agent für Team Foundation über die erforderlichen Berechtigungen für die ausgeführten Aufgaben verfügen.

Einige Team Foundation-Dienste umfassen Aufgaben, die sich in regelmäßigen Abständen wiederholen. Beispielsweise möchten Administratoren u. U. jede Nacht Builds planen. Damit dies möglich ist, müssen die Builddienste ein automatisch geplantes Ereignis in der Registrierungsdatenbank einrichten können. Der Hintergrundauftrags-Agent für Team Foundation stellt Ihnen einen einzelnen Windows-basierten Dienst bereit, um wiederkehrende Aufgaben auf Servern mit Team Foundation zu planen. Dieser Dienst durchsucht die Registrierungsdatenbank, identifiziert alle Team Foundation Server-Webdienste mit geplanten Ereignissen und plant diese Aufgaben.

Wichtiger Hinweis Wichtig

Um Aufgaben wie das Erstellen von Teamprojektsammlungen auszuführen, muss das vom Hintergrundauftrags-Agent für Team Foundation verwendete Dienstkonto über bestimmte Berechtigungen verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server.

Instanzen

Führen Sie auf einem Team Foundation-Anwendungsebenenserver jeweils nur eine Instanz des Hintergrundauftrags-Agent für Team Foundation aus. Standardmäßig wird der Dienst unter dem Dienstkonto ausgeführt, das Sie bei der Installation von Team Foundation Server angegeben haben. Um den Status dieses Diensts auf einem Anwendungsebenenserver anzuzeigen, klicken Sie auf Start, auf Verwaltung und auf Dienste. Navigieren Sie anschließend zu dem Dienst.

Berechtigungen

Der Hintergrundauftrags-Agent für Team Foundation verwendet das gleiche Dienstkonto wie Team Foundation Server (TFSService). Für einen ordnungsgemäßen Betrieb erfordert dieses Konto die folgenden Berechtigungen:

  • Anmelden als Dienst

  • Gruppe "Farmadministratoren" für alle SharePoint-Webanwendungen, die Team Foundation Server verwendet

  • TFSExecRole oder die beide folgenden Berechtigungen für alle Datenbanken, die Team Foundation Server verwendet:

    • db_owner

    • db_create

Vorraussetzungen und Einschränkungen

Der Hintergrundauftrags-Agent für Team Foundation wird kontinuierlich auf allen Anwendungsebenenservern ausgeführt. Administratoren müssen diesen Dienst außer bei der Systemwiederherstellung in der Regel nicht manuell beenden oder starten. Der Dienst muss z. B. vor der Wiederherstellung von Datenbanken beendet werden. Beim Neustart eines Servers wird der Dienst in der Regel automatisch neu gestartet.

Der Hintergrundauftrags-Agent für Team Foundation wird nicht direkt von den Administratoren konfiguriert. Zu planende Aufgaben werden direkt in einzelnen Komponenten von Team Foundation konfiguriert, wie z. B. Team Foundation Build. Wenn ein Ereignis hinzugefügt oder gelöscht wird, konfiguriert der Dienst die in der Registrierungsdatenbank geplanten Aufgaben automatisch neu.

Der Hintergrundauftrags-Agent für Team Foundation protokolliert jeden aufgetretenen Fehler nur einmal, bis dieser Fehler behoben und eine Erfolgsmeldung im Ereignisprotokoll aufgezeichnet wird oder bis der Dienst manuell neu gestartet wurde. Wenn das Ereignisprotokoll hinsichtlich dieser Fehlermeldung überwacht werden soll, müssen Sie den Dienst zuvor beenden und neu starten.

Der Hintergrundauftrags-Agent für Team Foundation Server ist nicht als Allzweckablaufplanungsmechanismus vorgesehen. Er kann nicht für eine Planung verwendet werden, für die mehr Details als der Wochentag und die Zeit in Stunden und Minuten nötig sind. Die meisten Administratoren brauchen keine Aufgaben zu planen, die diese Detailtiefe übersteigen.

Siehe auch

Aufgaben

Ändern des Dienstkontos oder Kennworts für Team Foundation Server
Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services

Konzepte

Dienstkonten und Abhängigkeiten in Team Foundation Server


Anzeigen von Team Foundation Server-Diensten

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Anzeigen von Team Foundation Server-Diensten
Siehe auch Feedback senden

Auf einem Server für Team Foundation können Sie die Dienste, die Visual Studio Team Foundation Server verwendet, und die Webdienstanwendungspools, die Team Foundation Server installiert, anzeigen. Team Foundation Server enthält zahlreiche Dienste, die auf der Anwendungsebene ausgeführt werden. Die tatsächlich vorhandenen Dienste hängen davon ab, welche Funktionen von Team Foundation installiert sind.

Hinweis Hinweis

Melden Sie sich bei einer Bereitstellung mit einem Server am Anwendungsebenenserver an, um alle Dienste und Anwendungspools anzuzeigen. Bei einer Bereitstellung mit mehreren Servern müssen Sie sich an dem entsprechenden Server anmelden, der den spezifischen Dienst oder die Anwendung für Team Foundation Server hostet.

Erforderliche Berechtigungen

Zum Ausführen dieser Schritte müssen Sie Mitglied der Gruppe Team Foundation-Administratoren und Mitglied der Gruppe Administratoren auf dem Server, auf dem die Verwaltungskonsole installiert ist, sein. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So zeigen Sie die von Team Foundation Server verwendeten Dienste an

  1. Klicken Sie auf dem Server für Team Foundation auf Start, zeigen Sie auf Verwaltungstools, und klicken Sie anschließend auf Computerverwaltung.

  2. Erweitern Sie im Navigationsbereich Dienste und Anwendungen, und öffnen Sie anschließend Dienste.

  3. Klicken Sie auf den Spaltenheader Anmelden als, um die Dienste nach den Konten zu sortieren, unter denen sie ausgeführt werden.

    Eine Liste der möglichen Diensten und der Dienstkonten, unter denen diese ausgeführt werden, finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server.

    Standardmäßig werden alle Dienste für Team Foundation Server unter dem Dienstkonto ausgeführt, das beim Installieren von Team Foundation Server angegeben wurde und das als TFSService bezeichnet wird. Diese Dienste können die Codeabdeckungsanalyse, den Hintergrundauftrags-Agent von Team Foundation und den Visual Studio Team Foundation-Build enthalten.

    Hinweis Hinweis

    Die in der Liste angezeigten Dienste hängen von den installierten Komponenten ab. Der Dienst Visual Studio Team Foundation-Build wird beispielsweise nur installiert, wenn ein Buildcomputer installiert ist.

So zeigen Sie die von Team Foundation Server verwendeten Webdienst-Anwendungspools an

  1. Klicken Sie auf dem Server für Team Foundation auf Start, zeigen Sie auf Verwaltungstools, und klicken Sie anschließend auf Computerverwaltung.

  2. Erweitern Sie im Navigationsbereich den Eintrag Dienste und Anwendungen und danach den Eintrag Internetinformationsdienste-Manager, und klicken Sie anschließend auf Anwendungspools.

  3. Überprüfen Sie unter Status oder Zustand, dass Wird ausgeführt oder Gestartet angezeigt wird.

  4. Weitere Informationen zur Überprüfung oder Korrektur der Anwendungspoolidentität finden Sie unter How to: Verify or Correct the IIS Configuration for an Application Pool.

Siehe auch

Aufgaben

Beenden und Starten von Diensten, Anwendungspools und Websites
Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services
Ändern des Dienstkontos oder Kennworts für Team Foundation Server

Konzepte

Dienstkonten und Abhängigkeiten in Team Foundation Server
Team Foundation Server-Konzepte
Architektur von Team Foundation Server

Weitere Ressourcen

Team Foundation Server-Dienste und -Dienstkonten
How to: Verify or Correct the IIS Configuration for an Application Pool


Dienstkonten und Abhängigkeiten in Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Dienstkonten und Abhängigkeiten in Team Foundation Server
Siehe auch Feedback senden

Sie können Visual Studio Team Foundation Server (TFS) besser verwalten, wenn Sie die Dienste und unterschiedlichen Dienstkonten verstehen, die jede Bereitstellung von TFS umfasst und von denen jede Bereitstellung abhängig ist. In Abhängigkeit davon, wie Sie TFS installiert und konfiguriert haben, werden diese Dienste und Dienstkonten alle auf einem Computer oder auf mehreren Computern ausgeführt. Hierdurch ändern sich bestimmte Aspekte der Bereitstellungsverwaltung. Wenn Sie beispielsweise die serverseitigen Komponenten der Bereitstellung auf mehreren Computern ausführen, müssen Sie sicherstellen, dass die Dienstkonten, die Ihre Bereitstellung verwendet, über die Zugriffsrechte und Berechtigungen verfügen, die sie benötigen, um ordnungsgemäß zu funktionieren.

Team Foundation Server umfasst Dienste und Dienstkonten, die in einer Bereitstellung auf den folgenden Computern ausgeführt werden:

  • Auf einem Server, der eine oder mehrere Datenbanken für Team Foundation Server hostet.

  • Auf einem Server, der Komponenten der Anwendungsebene in Team Foundation hostet.

  • Auf einem Computer, auf dem Team Foundation Server Proxy ausgeführt wird.

  • Auf einem Buildcomputer.

  • Auf einem Testcomputer.

  • Auf einem Computer, auf dem eine oder mehrere Komponenten von Visual Studio Lab Management ausgeführt werden.

Sie können verschiedene Funktionen von TFS auf verschiedene Weise installieren und bereitstellen. Die Verteilung von Funktionen in der Bereitstellung bestimmt, welche Dienste und Dienstkonten auf welchen physischen Computern ausgeführt werden. Außerdem müssen Sie möglicherweise die Dienstkonten für Softwareprogramme verwalten, die für TFS konfiguriert sind, z. B. die Dienstkonten für SharePoint-Produkte und SQL Server.

In diesem Thema

  • Dienstkonten für Team Foundation Server

  • Dienste, die unter Dienstkonten ausgeführt werden

Dienstkonten für Team Foundation Server

Obwohl in TFS verschiedene Dienstkonten verwendet werden, kann dasselbe Domänen- oder Arbeitsgruppenkonto für den Großteil aller Dienstkonten verwendet werden. Beispielsweise kann dasselbe Domänenkonto "Contoso\Example" sowohl als Dienstkonto für Team Foundation Server (TFSService) als auch als Datenquellenkonto für SQL Server Reporting Services (TFSReports) verwendet werden. Andere Dienstkonten können jedoch andere Berechtigungsstufen erfordern. TFSService muss beispielsweise über die Berechtigung Anmelden als Dienst, und TFSReports muss über die Berechtigung Lokal anmelden zulassen verfügen. Wenn Sie dasselbe Konto "Contoso\Example" für beide verwenden, müssen Sie dem Konto diese beiden Berechtigungen gewähren. Außerdem erfordert TFSService für die ordnungsgemäße Funktion wesentlich mehr Berechtigungen als TFSReports, wie in der Tabelle weiter unten in diesem Thema dargestellt ist. Aus Sicherheitsgründen sollten Sie erwägen, separate Konten für diese beiden Dienstkonten zu verwenden.

Wichtiger Hinweis Wichtig

Sie dürfen das Konto, das zum Installieren von Team Foundation Server verwendet wurde, nicht als das Konto für eines dieser Dienstkonten verwenden.

Wenn Team Foundation Server in einer Active Directory-Domäne bereitgestellt wurde, sollte für Dienstkonten die Option Konto ist vertraulich und kann nicht delegiert werden festgelegt werden. In der folgenden Tabelle muss diese Option beispielsweise für TFSService festgelegt werden. Weitere Informationen zu erforderlichen Dienstkonten und zu den in der Dokumentation für Team Foundation Server verwendeten Platzhalternamen finden Sie im Thema "Erforderliche Konten für die Installation von Team Foundation Server" im Installationshandbuch für Team Foundation. Weitere Informationen über das Einschränken der Kontendelegierung in Active Directory finden Sie auf der folgenden Seite auf der Microsoft-Website: Enabling Delegated Authentication.

Da Sie mehrere Dienstkonten verwalten müssen, wird auf jedes Dienstkonto durch einen Platzhalternamen verwiesen, der die entsprechende Funktion angibt, wie in der Tabelle weiter unten in diesem Thema aufgeführt. Der Platzhaltername ist nicht der tatsächliche Name des Kontos, das Sie für jedes Dienstkonto verwenden. Der tatsächliche Name des Kontos ist von der Bereitstellung abhängig. Im vorherigen Beispiel lautete das sowohl für TFSService als auch für TFSReports verwendete Konto "Contoso\Example". In Ihrer eigenen Bereitstellung können Sie Domänenkonten mit dem Namen "TFSService" und "TFSReports" erstellen, oder Sie können das Systemkonto für den Netzwerkdienst als Dienstkonto für Team Foundation Server verwenden.

Wichtiger Hinweis Wichtig

Sofern nicht ausdrücklich angegeben, dürfen die Gruppen oder Konten in der folgenden Tabelle nicht Mitglied der Gruppe "Administratoren" auf einem der Server in der Bereitstellung von Team Foundation Server sein.

In der folgenden Tabelle sind alle Dienstkonten dargestellt, die Sie in einer Bereitstellung von TFS verwenden können:

Dienstkonto

Platzhaltername und verwendbarer Kontotyp

Erforderliche Berechtigung und Gruppenmitgliedschaft

Hinweise

Dienstkonto für Team Foundation Server

TFSService kann ein lokales Konto, ein lokaler Dienst in einer Arbeitsgruppe oder ein Netzwerkdienst in einer Domäne sein

  • Anmelden als Dienst auf dem Anwendungsebenenserver

  • Gruppe Farm Administrators für SharePoint-Webanwendungen, für die Team Foundation Server 1 verwendet

  • TFSExecRole oder, wenn diese Rolle für die Datenbank nicht vorhanden ist, eine Kombination der folgenden Rollen für alle Datenbanken, die Team Foundation Server verwendet:

    • db_owner

    • db_create

Dieses Dienstkonto wird für alle Webdienste für Team Foundation Server verwendet. Wenn Sie ein Domänenkonto für dieses Konto verwenden, muss es Mitglied einer Domäne sein, der alle Computer in der gesamten Bereitstellung vollständig vertrauen.

Datenquellenkonto für SQL Server Reporting Services

TFSReports (kann ein lokales Konto, ein Domänenkonto oder ein lokaler Dienst in einer Arbeitsgruppe sein)

  • Lokal anmelden zulassen auf dem Anwendungsebenenserver und dem Server, der SQL Server Reporting Services ausführt

  • TFSWareHouseDataReader auf dem Berichtsserver

Dieses Dienstkonto ruft Daten für Berichte aus Reporting Services ab.

Dienstkonto für Team Foundation Build

TFSBuild (kann ein lokales Konto, ein Domänenkonto oder ein lokaler Dienst in einer Arbeitsgruppe sein)

Anmelden als Dienst

Dieses Dienstkonto wird verwendet, wenn Builds konfiguriert und Buildstatusinformationen zwischen dem Buildcontroller und den Build-Agents übermittelt werden.

Dienstkonto für Lab Management

TFSLab (kann ein lokales Konto, ein Domänenkonto, ein lokaler Dienst in einer Arbeitsgruppe oder ein Netzwerkdienst in einer Domäne sein)

Anmelden als Dienst

Dieses Dienstkonto wird verwendet, wenn Informationen zu Lab Management zwischen Team Foundation Server und dem Labor-Agent übermittelt werden, der auf einem virtuellen Computer ausgeführt wird.

Dienstkonto für Team Foundation Server Proxy

TFSProxy (kann ein lokales Konto, ein Domänenkonto, ein lokaler Dienst in einer Arbeitsgruppe oder ein Netzwerkdienst in einer Domäne sein)

Anmelden als Dienst

Dieses Dienstkonto wird für alle Proxydienste verwendet. Wenn Sie ein Domänenkonto für dieses Konto verwenden, muss es Mitglied einer Domäne sein, der alle Computer in der gesamten Bereitstellung vollständig vertrauen.

Dienstkonto für Test-Agent und Test-Agent-Controller

TFSTest (kann ein lokales Konto, ein Domänenkonto oder einer Netzwerkdienst in einer Domäne sein)

Anmelden als Dienst

Dieses Dienstkonto wird verwendet, wenn Informationen zu Tests zwischen dem Test-Agent-Controller und dem Test-Agent übermittelt werden.

Dienstkonten bei SharePoint-Webanwendungen

WebAppService

Lokal anmelden zulassen

Sie müssen mindestens ein Dienstkonto zu jeder SharePoint-Webanwendung hinzufügen, die Sie zur Verwendung mit Team Foundation Server konfigurieren. Dieses Dienstkonto wird verwendet, um Teamprojektportale zu erstellen und die Dashboardfunktionalität zu aktivieren.

Dienstkonto für Team Foundation-Dienstvorschau

Kontodienst (CollectionName)

Keine. Dieses Konto wird nur verwendet, wenn Sie eine gehostete Bereitstellung von TFS verwenden. Es wird automatisch für Sie erstellt und kann über die Verwaltungsseite von Team Web Access angezeigt werden.

Dieses Dienstkonto wird automatisch erstellt, wenn Sie in Team Foundation-Dienstvorschau eine Auflistung erstellen, und wird verwendet, wenn Clients mit dem gehosteten Dienst kommunizieren.

1 Sie können die Bereitstellung ohne diese Berechtigung in SharePoint-Produkte integrieren, aber Sie müssen zusätzliche Schritte ausführen, wenn das Dienstkonto kein Mitglied der Gruppe der Farmadministratoren ist. Weitere Informationen finden Sie unter Integrate with SharePoint Products Without Administrative Permissions.

Dienste, die unter Dienstkonten ausgeführt werden

Die folgenden Dienste werden unter Dienstkonten in einer Bereitstellung von Team Foundation Server ausgeführt:

Dienstname | Dienstkonto | Logische Ebene
Codeabdeckungsdienst | TFSService | Anwendungsebene
Team Foundation ServerWebdienste | TFSService | Anwendungsebene
SQL Server Reporting Services (MSSQLSERVER oder Instanzname bei Verwendung einer benannten Instanz) | Lokales System oder ein Domänenkonto | Anwendungsebene
Berichtswebdienst | Lokales System, Netzwerkdienst oder ein Domänenkonto | Anwendungsebene
SharePoint-Verwaltung (wenn SharePoint-Produkte installiert und zur Verwendung mit Team Foundation Server konfiguriert ist) | Lokales System, Netzwerkdienst oder ein Domänenkonto | Anwendungsebene
SharePoint-Zeitgeber (wenn SharePoint-Produkte installiert und zur Verwendung mit Team Foundation Server konfiguriert ist) | Domänenkonto | Anwendungsebene
Visual Studio Team Foundation-Builddiensthost (wenn Team Foundation Build installiert ist) | TFSBuild | Buildcomputer
Visual Studio Team Foundation-Hintergrundauftrags-Agent | TFSService | Anwendungsebene
Visual Studio-Testcontroller | TFSTest | Beliebiger Computer
Visual Studio-Test-Agent | TFSTest | Testcomputer
Analysis-Server (MSSQLSERVER oder Instanzname, wenn eine benannte Instanz verwendet wird) | Lokales System oder ein Domänenkonto | Datenebene
SQL Server-Browser | Lokaler Dienst oder ein Domänenkonto | Datenebene
SQL Server (MSSQLSERVER oder Instanzname, wenn eine benannte Instanz verwendet wird) | Lokales System, Netzwerkdienst oder ein Domänenkonto | Datenebene
SQL Server-Agent (MSSQLSERVER oder InstanceName, wenn eine benannte Instanz verwendet wird) | Lokales System, Netzwerkdienst oder ein Domänenkonto | Datenebene
Kontodienst (CollectionName) | Automatisch | Webebene (nur Team Foundation-Dienstvorschau)

Weitere Informationen über Dienstkonten für SQL Server finden Sie auf der folgenden Seite auf der Microsoft-Website: Onlinedokumentation. Aktuelle Informationen über Dienstkonten in Team Foundation finden Sie unter Installieren von Team Foundation Server und Visual Studio ALM.

Hinweis Hinweis

Wenn Sie das Dienstkonto für Team Foundation Build ändern, müssen Sie sicherstellen, dass das neue Dienstkonto Mitglied der Gruppe "Builddienste" ist. Vergewissern Sie sich auch, dass das Konto über Lese-/Schreibberechtigungen für die temporären Ordner und den temporären ASP.NET-Ordner verfügt. Wenn das Dienstkonto für den Team Foundation Server-Proxydienst geändert wurde, muss sicher gestellt sein, dass das Konto Mitglied der entsprechenden Gruppen ist. Weitere Informationen finden Sie unter Setting Up a Build Computer.

Siehe auch

Aufgaben

Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services
Ändern des Dienstkontos oder Kennworts für Team Foundation Server

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services
Siehe auch Feedback senden

Sie können die Sicherheit von Team Foundation Server (TFS) erhöhen, indem Sie das Dienstkonto ändern, das für die Datenquellen von SQL Server Reporting Services verwendet wird, oder indem Sie das für das Konto verwendete Kennwort ändern. TFS fungiert im Sicherheitskontext eines Dienstkontos, wenn Projektdaten aus den Datenquellen in SQL Server Reporting Services abgerufen werden. In der TFS-Dokumentation wird der Platzhalter TFSReports für dieses Dienstkonto verwendet. Der tatsächliche Kontoname hängt von der Installation ab. Sie müssen ggf. das Kennwort dieses Kontos ändern oder ein anderes Konto festlegen. Wenn das Kennwort des zugrunde liegenden Kontos beispielsweise abläuft und Sie ein neues Kennwort zuweisen, müssen Sie das Kennwort des TFSReports-Kontos in TFS ändern, damit diese übereinstimmen.

Mit dem TFSConfig-Hilfsprogramm wird kein neues Konto erstellt, das als Datenquellenkonto verwendet werden soll, und es wird auch nicht das Kontokennwort geändert. Stattdessen aktualisiert das Hilfsprogramm TFS zur Verwendung anderer Anmeldeinformationen.

Sie ändern das Kennwort oder das Konto, das als TFSReports-Konto verwendet wird, indem Sie das TFSConfig-Befehlszeilenhilfsprogramm mit der Konten-Option verwenden.

Wichtiger Hinweis Wichtig

Das Dienstprogramm TFSConfig ändert nur die Dienste, die unter dem alten Konto ausgeführt werden.

Sie können das gleiche Hilfsprogramm verwenden, um ein anderes Konto als das TFSReports-Konto zuzuweisen. Sie müssen dann ggf. eine oder mehrere der folgenden zusätzlichen Aktionen ausführen:

  • Bevor Sie ein Konto zuweisen, das als TFSReports-Konto verwendet werden soll, müssen Sie überprüfen, ob es Mitglied von einer Arbeitsgruppe oder einer Domäne ist, der von jedem Computer in der Bereitstellung von Team Foundation vertraut wird.

  • Sie müssen dem Konto, das Sie als TFSReports-Konto verwenden möchten, manuell die Berechtigung Lokal anmelden zulassen gewähren. Das TFSConfig-Hilfsprogramm gewährt diese Berechtigung nicht, wenn es das Konto zuweist.

  • Nachdem Sie mit TFSConfig ein Konto als TFSReports-Konto festgelegt haben, können Sie optional die Benachrichtigung Anmelden als Dienst widerrufen, die von TFSConfig dem TFSReports-Konto automatisch gewährt wird. TFSReports benötigt diese Berechtigung nicht, jedoch das TFSService-Konto. Daher sollten Sie diese Berechtigung nicht entfernen, wenn Sie die gleiche Domäne oder das Arbeitsgruppenkonto für beide Dienstkonten verwenden.

    Weitere Informationen über die Berechtigung Anmelden als Dienst finden Sie auf der folgenden Seite auf der Microsoft-Website: "Add the Log on as a service right to an account". Weitere Informationen über die Berechtigung Lokal Anmelden zulassen finden Sie auf der folgenden Seite auf der Microsoft-Website: "Lokal Anmelden zulassen".

Weitere Informationen zu erforderlichen Dienstkonten finden Sie unter dem Thema Dienstkonten und Abhängigkeiten in Team Foundation Server und auch unter dem Thema "Erforderliche Konten für die Installation von Team Foundation Server" im Installationshandbuch für Team Foundation.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Administratoren-Gruppe auf dem Server sein, auf dem TFSConfig installiert ist. Sie müssen auch Mitglied der sysadmin-Gruppe auf dem Server sein, der die Konfigurationsdatenbank hostet. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Über diese Berechtigungen hinaus gelten unter Umständen folgende Anforderungen:

  • Um eine Befehlszeilenprozedur auszuführen, müssen Sie möglicherweise eine erweiterte Eingabeaufforderung öffnen. Klicken Sie hierzu auf Start, klicken Sie anschließend mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen.

  • Für den Zugriff auf den Berichts-Manager, Berichte oder Websites für SQL Server Reporting Services müssen Sie diese Sites gegebenenfalls der Liste vertrauenswürdiger Sites in Internet Explorer hinzufügen oder Internet Explorer als Administrator starten.

Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Benutzerkontensteuerung.

Ändern des Kennworts oder Kontos für das Reporting Services-Konto

Um das Kennwort des TFSReports-Kontos zu ändern oder ein anderes Konto zuzuweisen, müssen Sie sich bei einem Server anmelden, der die Anwendungsdienste für Team Foundation hostet, und das TfsConfig Accounts-Hilfsprogramm verwenden.

Hinweis Hinweis

Je nach Bereitstellungskonfiguration müssen Sie Internetinformationsdienste (IIS) nach Abschluss dieses Vorgangs neu starten, damit die Änderungen wirksam werden.

So ändern Sie das Kennwort mit dem TFSConfig-Hilfsprogramm

  1. Öffnen Sie ein Eingabeaufforderungsfenster, und wechseln Sie in das Verzeichnis, das das TFSConfig-Hilfsprogramm enthält:

    Das Hilfsprogramm befindet sich standardmäßig unter Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie in der Befehlszeile TFSConfig Accounts /UpdatePassword /accountType:ReportingDatasource /account:AccountName /password:newPassword ein, und drücken Sie die EINGABETASTE.

    Ersetzen Sie AccountName durch den Namen des aktuellen TFSReports-Kontos. Ersetzen Sie newPassword durch das neue Kennwort des Kontos.

So verwenden Sie die Verwaltungskonsole zum Ändern des Kennworts

  1. Öffnen Sie auf dem Server, der die Anwendungsebene hostet, die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie in der Konsole den Servernamen, und wählen Sie Anwendungsebene.

  3. Navigieren Sie im Bereich der Anwendungsebene zu Reporting Services - Zusammenfassung und wählen Sie die Option Kontokennwort aktualisieren.

    Das Fenster Kontokennwort aktualisieren wird geöffnet.

    Hinweis Hinweis

    Wenn Sie ein Systemkonto als Dienstkonto verwendet haben, sehen Sie eine Fehlermeldung, wenn Sie die Option Kontokennwort aktualisieren wählen. Sie müssen das Kennwort dieses Kontos nicht ändern. Systemkonten haben keine benutzerverwalteten Kennwörter.

  4. Geben Sie das neue Kennwort in Kennwort ein, und wählen Sie dann OK.

    Das Fenster Berichtsleserkonto ändern wird geöffnet.

  5. Warten Sie, bis alle Statusmeldungen in Status abgeschlossen sind, und wählen Sie dann Schließen.

    Hinweis Hinweis

    Dies kann einige Minuten dauern.

So weisen Sie allen Team Foundation Server-Diensten mit dem TFSConfig-Hilfsprogramm ein neues Reporting Services-Dienstkonto zu

  1. Öffnen Sie ein Eingabeaufforderungsfenster, und wechseln Sie in das Verzeichnis, das das TFSConfig-Hilfsprogramm enthält:

    Das Hilfsprogramm befindet sich standardmäßig unter Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie in der Befehlszeile TFSConfig Accounts /change /accountType:ReportingDatasource /account:NewAccountName /password:newPassword ein, und drücken Sie die EINGABETASTE.

    Ersetzen Sie NewAccountName durch den Namen des neuen TFSReports-Kontos. Ersetzen Sie newPassword durch das Kennwort des Kontos.

So verwenden Sie die Verwaltungskonsole zum Ändern des Kontos

  1. Öffnen Sie auf dem Server, der die Anwendungsebene hostet, die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie in der Konsole den Servernamen, und wählen Sie Anwendungsebene.

  3. Navigieren Sie im Bereich der Anwendungsebene zu Reporting Services - Zusammenfassung, und wählen Sie dann Konto ändern aus.

    Das Fenster Berichtsleserkonto ändern wird geöffnet.

  4. Führen Sie einen der folgenden Schritte aus:

    1. Wenn Sie ein Systemkonto verwenden möchten, wählen Sie die Option Systemkonto verwenden, und wählen Sie dann ein Systemkonto aus der Dropdownliste aus.

      Hinweis Hinweis

      Systemkonten haben keine benutzerverwalteten Kennwörter. Wenn Sie ein Systemkonto als TFSReports verwenden, geben Sie kein Kennwort im Kennwortfeld ein.

    2. Wenn Sie ein Domänenkonto oder Arbeitsgruppenkonto verwenden möchten, wählen Sie die Option Benutzerkonto verwenden, geben den Namen des Kontos unter Kontoname ein, und geben dann das Kennwort für das Konto unter Kennwort ein.

  5. Klicken Sie auf OK.

    Das Fenster Berichtsleserkonto ändern wird geöffnet.

  6. Warten Sie, bis alle Statusmeldungen in Status abgeschlossen sind, und wählen Sie dann Schließen.

    Hinweis Hinweis

    Dies kann einige Minuten dauern.

Siehe auch

Aufgaben

Ändern des Dienstkontos oder Kennworts für Team Foundation Server

Referenz

Accounts-Befehl

Konzepte

Dienstkonten und Abhängigkeiten in Team Foundation Server

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


Ändern des Dienstkontos oder Kennworts für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Ändern des Dienstkontos oder Kennworts für Team Foundation Server
Siehe auch Feedback senden

Sie können die Sicherheit von Visual Studio Team Foundation Server 2012 (TFS) verbessern, indem Sie das Dienstkonto oder das für dieses Konto verwendete Kennwort ändern. TFS führt Dienste, wie z. B. seine Webdienste und den Hintergrundauftrags-Agent für Team Foundation, im Kontext eines Dienstkontos aus. Der Einfachheit halber verweist die TFS-Dokumentation auf dieses Konto als TFSService, obwohl dies nicht der tatsächliche Kontoname ist, es sei denn, Sie erstellen ausdrücklich ein Konto mit diesem Namen. TFS speichert einen Datensatz des Namens des tatsächlichen Kontos, das als Dienstkonto verwendet wird. Sie können ein anderes Konto als Dienstkonto festlegen, indem Sie den Datensatz ändern. Sie können auch das Kennwort für dieses Konto ändern. Änderungen des Kontos oder Kennworts werden auf andere Komponenten in der Bereitstellung synchronisiert. Wenn zum Beispiel eine Active Directory-Domänenrichtlinie erfordert, dass alle Kennwörter in regelmäßigen Abständen ablaufen, können Sie die Kennwortinformationen für das Dienstkonto in TFS aktualisieren, wenn sich dieses Kennwort ändert.

Hinweis Hinweis

TFS und die dazugehörigen Hilfsprogramme können kein neues lokales Konto oder Domänenkonto erstellen, das als TFSService verwendet werden soll, und sie können das Kennwort für dieses Konto in der Arbeitsgruppe oder in der Domäne nicht aktualisieren. Stattdessen aktualisieren die Hilfsprogramme die Datensätze, sodass diese den neuen Anmeldeinformationen entsprechen. Wenn die Bereitstellung mehr als einen Anwendungsebenenserver umfasst, müssen Sie alle Änderungen des Dienstkontos oder Kennworts manuell auf jedem Server vornehmen.

Weitere Informationen über Dienstkonten in TFS finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server. Weitere Informationen zu den für die Installation erforderlichen Konten, einschließlich des Dienstkontos für TFS, finden Sie unter Erforderliche Konten für die Installation von Team Foundation Server.

Erforderliche Berechtigungen

Zur Durchführung dieser Schritte müssen Sie Mitglied der Gruppe Administratoren auf dem Team Foundation-Anwendungsebenenserver sowie Mitglied der Gruppe sysadmin auf dem Server und in der Instanz von SQL Server sein, die die Konfigurationsdatenbank für Team Foundation hostet. Weitere Informationen finden Sie unter Architektur von Team Foundation Server sowie unter Team Foundation Server-Berechtigungen.

Für eine Befehlszeilenprozedur müssen Sie gegebenenfalls ein Fenster für die Eingabeaufforderung mit erhöhten Rechten öffnen. Klicken Sie zum Ausführen dieser Aufgabe auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Benutzerkontensteuerung.

Ändern des Kennworts für das Dienstkonto

Um das Kennwort für TFSService zu ändern, müssen Sie sich am Anwendungsebenenserver für Team Foundation anmelden und entweder die Verwaltungskonsole für Team Foundation verwenden oder eine Eingabeaufforderung öffnen und das TFSConfig-Hilfsprogramm verwenden. Wenn mehr als ein Anwendungsebenenserver in der Bereitstellung verwendet wird, müssen Sie diese Aufgabe auf jedem Server ausführen, da die Kontoinformationen andernfalls nicht mehr synchronisiert sind.

Hinweis Hinweis

Je nach Bereitstellungskonfiguration müssen Sie Internetinformationsdienste (IIS) nach Abschluss des Vorgangs neu starten, bevor die Änderungen wirksam werden.

So verwenden Sie die Verwaltungskonsole zum Ändern des Kennworts

  1. Öffnen Sie auf dem Server, der die Anwendungsebene hostet, die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie in der Konsole den Servernamen, und wählen Sie Anwendungsebene.

  3. Wählen Sie im Bereich der Anwendungsebene die Option Kontokennwort aktualisieren.

    Das Fenster Kontokennwort aktualisieren wird geöffnet.

    Hinweis Hinweis

    Wenn Sie ein Systemkonto als Dienstkonto verwendet haben, sehen Sie eine Fehlermeldung, wenn Sie die Option Kontokennwort aktualisieren wählen. Sie müssen das Kennwort dieses Kontos nicht ändern. Systemkonten haben keine benutzerverwalteten Kennwörter.

  4. Geben Sie das neue Kennwort in Kennwort ein, und wählen Sie dann OK.

    Das Fenster Dienstkonto ändern wird geöffnet.

  5. Warten Sie, bis alle Statusmeldungen in Status abgeschlossen sind, und wählen Sie dann Schließen.

    Hinweis Hinweis

    Dies kann einige Minuten dauern.

So verwenden Sie das TFSConfig-Hilfsprogramm zum Ändern des Kennworts

  1. Öffnen Sie auf dem Anwendungsebenenserver ein Eingabeaufforderungsfenster, und wechseln Sie in das Verzeichnis, in dem sich das TFSConfig-Hilfsprogramm befindet.

    Standardmäßig befindet sich dieses Hilfsprogramm unter Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie in der Befehlszeile TFSConfig Accounts /UpdatePassword /accountType:ApplicationTier /account:AccountName /password:NewPassword ein, und drücken Sie die EINGABETASTE.

  3. Sie müssen den Namen des Kontos, das Sie als TFSService verwenden möchten (KontoName), und das Kennwort des Kontos (NeuesKennwort) angeben.

Zuweisen eines anderen Kontos als Dienstkonto

Wenn Sie TFS für die Verwendung eines anderen Kontos als des Dienstkontos für Team Foundation konfigurieren möchten, können Sie entweder die Verwaltungskonsole oder das TFSConfig-Befehlszeilen-Hilfsprogramm verwenden. Wenn mehr als ein Anwendungsebenenserver in der Bereitstellung verwendet wird, müssen Sie diese Aufgabe auf jedem Server ausführen, da die Kontoinformationen andernfalls nicht mehr synchronisiert sind. Bevor Sie eines der beiden Hilfsprogramm verwenden, um die Änderung vorzunehmen, berücksichtigen Sie die folgenden Punkte:

  • Sie müssen ein neues Konto auswählen, das entweder ein Systemkonto oder Mitglied einer Arbeitsgruppe oder einer Domäne ist, der von jedem Computer in dieser Bereitstellung von TFS vertraut wird.

  • Die Konfigurationshilfsprogramme gewähren dem neuen Dienstkonto die Berechtigung Anmelden als Dienst, wobei die Hilfsprogramme diese Berechtigung jedoch nicht für das zuvor als Dienstkonto verwendete Konto widerrufen, wenn ein anderer Dienst dieses Konto weiterhin verwendet. Wenn das alte Konto diese Berechtigung für den Dienst, für den es weiterhin verwendet wird, nicht mehr benötigt, sollten Sie diese Berechtigung ggf. manuell aus dem alten Konto entfernen.

    Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Add the Log on as a service right to an account (in englischer Sprache).

  • Sie müssen IIS nach Abschluss des Vorgangs möglicherweise neu starten, bevor die Änderungen wirksam werden.

  • Das TFSConfig-Hilfsprogramm ändert nur die Dienste, die unter dem alten Konto ausgeführt werden.

So verwenden Sie die Verwaltungskonsole zum Ändern des Dienstkontos

  1. Öffnen Sie auf dem Server, der die Anwendungsebene hostet, die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie in der Konsole den Servernamen, und wählen Sie Anwendungsebene.

  3. Wählen Sie im Bereich der Anwendungsebene die Option Konto ändern.

    Das Fenster Dienstkonto aktualisieren wird geöffnet.

  4. Führen Sie einen der folgenden Schritte aus:

    1. Wenn Sie ein Systemkonto verwenden möchten, wählen Sie die Option Systemkonto verwenden, und wählen Sie dann ein Systemkonto aus der Dropdownliste aus.

      Wenn der Server Mitglied einer Active Directory-Domäne ist, ist "Netzwerkdienst" die Standardauswahl für das zu verwendende Systemkonto. Wenn der Server Mitglied einer Arbeitsgruppe ist, lautet die Standardauswahl "Lokaler Dienst". Abhängig von den Details der Bereitstellung steht möglicherweise nur die Standardauswahl zur Verfügung.

      Hinweis Hinweis

      Systemkonten haben keine benutzerverwalteten Kennwörter. Wenn Sie ein Systemkonto als TFSService verwenden, geben Sie kein Kennwort im Kennwortfeld ein.

    2. Wenn Sie ein Domänenkonto oder Arbeitsgruppenkonto verwenden möchten, wählen Sie die Option Benutzerkonto verwenden, geben den Namen des Kontos unter Kontoname ein, und geben dann das Kennwort für das Konto unter Kennwort ein.

  5. Klicken Sie auf OK.

    Das Fenster Dienstkonto ändern wird geöffnet.

  6. Warten Sie, bis alle Statusmeldungen in Status abgeschlossen sind, und wählen Sie dann Schließen.

    Hinweis Hinweis

    Dies kann einige Minuten dauern.

So verwenden Sie das TFSConfig-Hilfsprogramm zum Ändern des Dienstkontos

  1. Öffnen Sie auf dem Anwendungsebenenserver ein Eingabeaufforderungsfenster, und wechseln Sie in das Verzeichnis, in dem sich das TFSConfig-Hilfsprogramm befindet.

    Standardmäßig befindet sich dieses Hilfsprogramm unter Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie in der Befehlszeile TFSConfig Accounts /change /accountType:ApplicationTier /account:AccountName /password:NewPassword ein, und drücken Sie die EINGABETASTE.

    Weitere Informationen finden Sie unter Accounts-Befehl.

Siehe auch

Aufgaben

Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services

Referenz

Accounts-Befehl

Konzepte

Dienstkonten und Abhängigkeiten in Team Foundation Server

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig
How to: Change the Password for Visual Studio Team Foundation Build Service


Beenden und Starten von Diensten, Anwendungspools und Websites

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Beenden und Starten von Diensten, Anwendungspools und Websites
Siehe auch Feedback senden

Um die korrekte Funktionsweise von Visual Studio Team Foundation Server sicherzustellen, müssen Sie überprüfen, ob auf dem entsprechenden Server alle erforderlichen Dienste, Anwendungspools und Websites ausgeführt werden. Bei Bereitstellungen auf einem Server muss jedes Element auf dem Server ausgeführt werden, auf dem Team Foundation Server ausgeführt wird. Bei Bereitstellungen auf mehreren Servern muss jedes Element auf dem entsprechenden Server ausgeführt werden. Darüber hinaus muss ein Element ggf. beendet werden, um eine bestimmte Aufgabe durchzuführen, z. B. wenn Sie die Bereitstellung auf andere Hardware verschieben möchten. Ausführliche Informationen zum Starten bzw. Beenden dieser Elementen für Vorgänge wie das Sichern oder Wiederherstellen von Datenbanken finden Sie unter Befehl "TFSServiceControl". Informationen zum Beenden einzelner Diensten oder Anwendungspools finden Sie in den Schritten am Ende dieses Themas.

Wichtiger Hinweis Wichtig

Sie müssen bestimmte Verwaltungsaufgaben auf dem Server, wie das Sichern oder Wiederherstellen von Datenbanken, mithilfe des TFSServiceControl-Befehls ausführen. Verwenden Sie die Schritte am Ende dieses Themas nicht, um alle Dienste und Anwendungspools für Aufgaben manuell zu beenden, die den TFSServiceControl-Befehl erfordern.

In der folgenden Tabelle werden die Server aufgeführt, auf denen die einzelnen Dienste, Anwendungspools und Websites ausgeführt werden müssen. In der Spalte Name werden der Anzeigename für jedes Element sowie der Dienstname in Klammern angezeigt. Die benötigten Dienste hängen davon ab, welche Features von Team Foundation installiert sind.

Element

Speicherort

Name

Dienste

Server der Anwendungsebene

  • Codeabdeckungsanalyse-Dienst

  • Internetinformationsdienste-Verwaltungsdienst (IISADMIN)

  • HTTP-SSL (HTTPFilter)

  • Visual Studio Team Foundation Build (VSTFBUILD) (nur, wenn Team Foundation Build installiert ist)

  • Visual Studio Team Foundation Background Job Agent (TFSJobAgent)

  • WWW-Publishingdienst (W3SVC)

Server, der als Host für die Datenbanken für Team Foundation fungiert

  • SQL Server (TFSINSTANCE)

  • SQL Server-Agent (TFSINSTANCE) (SQLSERVERAGENT)

Server, der als Host für SQL Server Reporting Services fungiert

  • IIS-Verwaltungsdienst (IISADMIN)

  • HTTP-SSL (HTTPFilter)

  • SQL Server Reporting Services (TFSINSTANCE) (ReportServer)

  • WWW-Publishingdienst (W3SVC)

Server, der als Host für SQL Server Analysis Services fungiert

  • SQL Server Analysis Services

Server, der als Host für SharePoint-Produkte fungiert

  • Internetinformationsdienste-Verwaltung (IISADMIN)

  • HTTP-SSL (HTTPFilter)

  • Windows SharePoint Services Timer (SPTimer) (Windows SharePoint Services 3.0 oder Microsoft Office SharePoint Server 2007)

  • WWW-Publishingdienst (W3SVC)

Anwendungspools

Server der Anwendungsebene

  • Microsoft Team Foundation Server-Anwendungspool

  • Microsoft Team Foundation Server Proxy-Anwendungspool (nur wenn der Team Foundation Server-Proxy installiert ist)

Server, der als Host für SharePoint-Produkte fungiert

  • DefaultAppPool (wird vom Teamprojektportal verwendet)

    Hinweis Hinweis

    Der Name kann variieren, je nachdem wie SharePoint-Produkte installiert wurde.

  • SharePoint-Zentraladministration Version 3

Websites

Server der Anwendungsebene

  • Team Foundation Server

  • Team Foundation Server Proxy (nur, wenn Team Foundation Server-Proxy installiert ist)

Server, der als Host für SharePoint-Produkte fungiert

  • Standardwebsite oder Teamwebsite

    Hinweis Hinweis

    Der Name kann variieren, je nachdem wie SharePoint-Produkte installiert wurde.

  • SharePoint-Zentraladministration Version 3

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie auf dem Server, der als Host für den Dienst, den Anwendungspool oder die Website, die Sie verwalten möchten, als Host fungiert, Mitglied der Gruppe Administratoren sein. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So beenden oder starten Sie einen Dienst, einen Anwendungspool oder eine Website

  1. Melden Sie sich an dem Server an, der als Host für den Dienst, den Anwendungspool oder die Website fungiert.

  2. Klicken Sie auf Start, Verwaltung und Computerverwaltung.

  3. Erweitern Sie im Navigationsbereich Dienste und Anwendungen.

  4. Führen Sie einen der folgenden Schritte aus, je nachdem, welches Element Sie beenden oder starten möchten:

    • Klicken Sie für einen Dienst auf Dienste. Klicken Sie dann mit der rechten Maustaste auf den Dienst, und wählen Sie Beenden oder Starten aus.

    • Klicken Sie für einen Anwendungspool auf Internetinformationsdienste-Manager, erweitern Sie den lokalen Computer, und doppelklicken Sie auf Anwendungspools. Klicken Sie mit der rechten Maustaste auf den Anwendungspool, und wählen Sie Beenden oder Starten aus.

    • Klicken Sie für eine Website auf Internetinformationsdienste-Manager, erweitern Sie den lokalen Computer, und doppelklicken Sie auf Websites oder Sites.

      Wenn auf dem Server Windows Server 2003 ausgeführt wird, klicken Sie mit der rechten Maustaste auf die Website, und wählen Sie dann Beenden oder Starten aus.

      Wenn auf dem Server Windows Server 2008 ausgeführt wird, klicken Sie mit der rechten Maustaste auf die Website, zeigen Sie auf Website verwalten, und wählen Sie dann Beenden oder Starten aus.

Siehe auch

Aufgaben

Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services
Ändern des Dienstkontos oder Kennworts für Team Foundation Server

Konzepte

Dienstkonten und Abhängigkeiten in Team Foundation Server
Team Foundation Server-Konzepte
Architektur von Team Foundation Server

Weitere Ressourcen

How to: Verify or Correct the IIS Configuration for an Application Pool
Team Foundation Server-Dienste und -Dienstkonten


Ändern von Cacheeinstellungen für einen Anwendungsebenenserver

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Ändern von Cacheeinstellungen für einen Anwendungsebenenserver
Siehe auch Feedback senden

Sie können die Leistung in der Bereitstellung von Team Foundation verbessern oder ausbalancieren, indem Sie die Einstellungen des Caches für Dateien ändern, die der Versionskontrolle auf dem Anwendungsebenenserver unterliegen. Standardgemäß ist der Cache aktiviert, sodass Benutzer Dateien schneller aus dem Cache herunterladen können anstatt direkt aus der Datenbank. Als Administrator für Team Foundation können Sie die Einstellungen des Cache nach der Installation jederzeit ändern.

Hinweis Hinweis

Sie können auch die Leistung verbessern, indem Sie den Cache auf dem Team Foundation Server-Proxy aktivieren, falls dieser installiert ist. Weitere Informationen finden Sie unter Managing Remote Connections to Team Foundation Server Proxy.

Die folgenden Einstellungen können geändert werden.

  • Geben Sie einen anderen Cachestammordner an.

  • Ändern Sie das Limit zum Entfernen alter Dateien aus dem Cache.

Sie können diese Aufgaben ausführen, indem Sie die Datei "web.config" für die Versionskontrolle bearbeiten, die im Installationsverzeichnis auf dem Anwendungsebenenserver vorhanden ist.

Hinweis Hinweis

Standardgemäß ist das Installationsverzeichnis für die Anwendungsebene %programfiles% \Microsoft Team Foundation Server 2012\Application Tier\Web Services.

Erforderliche Berechtigungen

Damit Sie diese Schritte ausführen können, müssen Sie auf dem Anwendungsebenenserver für Team Foundation Mitglied der Sicherheitsgruppe Administratoren sein.

Neben diesen Berechtigungen müssen Sie auf einem Computer, auf dem Windows Server 2008, Windows Vista oder Windows 7 ausgeführt wird, gegebenenfalls Folgendes durchführen:

  • Um eine Befehlszeilenprozedur auszuführen, müssen Sie möglicherweise eine Eingabeaufforderung mit erhöhten Rechten öffnen. Wählen Sie dazu Start, öffnen Sie das Kontextmenü für die Eingabeaufforderung, und wählen Sie dann Als Administrator ausführen.

  • Um eine Prozedur auszuführen, für die Internet Explorer erforderlich ist, müssen Sie Internet Explorer möglicherweise als Administrator starten. Wählen Sie dazu Start, Alle Programme, und öffnen Sie das Kontextmenü für den Internet Explorer. Wählen Sie anschließend Als Administrator ausführen.

  • Um web.config-Dateien zu bearbeiten, müssen Sie möglicherweise den Text-Editor als Administrator starten, indem Sie Start und anschließend Alle Programme auswählen, das Kontextmenü für den Editor öffnen und dann Als Administrator ausführen auswählen.

Weitere Informationen finden Sie auf der Microsoft-Website.

So geben Sie einen anderen Cachestammordner an

  1. Erstellen Sie auf dem Anwendungsebenenserver einen Cacheordner.

    Sie können den Ordner auf einem lokalen Datenträger im UNC-Pfad oder auf einem eingebundenen Laufwerk erstellen. Sie könnten z. B. den folgenden Ordner erstellen:

    d:\temp\cacheroot

    Sicherheitshinweis Sicherheitshinweis

    Der Cacheordner speichert vertrauliche Informationen, die nicht verschlüsselt ist. Daher sollten Sie sicherstellen, dass nur das Dienstkonto für die Anwendungsebene (TFSService) über Lese- und Schreibberechtigungen für diesen Ordner verfügt.

  2. Öffnen Sie das Kontextmenü für den Ordner, und wählen Sie dann Eigenschaften aus.

    Das Dialogfeld Eigenschaften für die aktive Ansicht wird geöffnet.

  3. Wählen Sie auf der Registerkarte Sicherheit die Option Bearbeiten aus.

    Das Dialogfeld Berechtigungen wird geöffnet.

  4. Wählen Sie Hinzufügen aus.

    Das Dialogfeld Benutzer, Computer oder Gruppen auswählen wird angezeigt.

  5. Fügen Sie die lokale Gruppe TFS_APPTIER_SERVICE_WPG hinzu, und wählen Sie anschließend OK.

  6. Aktivieren Sie die Kontrollkästchen Read und Write, deaktivieren Sie alle anderen Kontrollkästchen, und wählen Sie dann OK aus.

  7. Navigieren Sie im Windows-Explorer (oder Datei-Explorer) zu "%programfiles%\Microsoft Team Foundation Server 2012\Application Tier\Web Services".

  8. Öffnen Sie die Datei "web.config" in einem Text- oder XML-Editor, und suchen Sie dann den <appSettings>-Abschnitt.

  9. Fügen Sie eine Zeile zum appSettings-Abschnitt hinzu, um auf den Ordner zu verweisen, den Sie gerade erstellt haben:

    Bild für Kopieren Code kopieren
    <add key="dataDirectory" value="NewCacheRootFolderLocation" />

    Wenn Sie beispielsweise wie im Beispiel oben einen Cachestammordner mit dem Namen cacheroot im temporären Verzeichnis einer Festplatte erstellt haben, fügen Sie die folgende Zeile hinzu:

    Bild für Kopieren Code kopieren
    <add key="dataDirectory" value="d:\temp\cacheroot" />

  10. Speichern und schließen Sie die Datei "web.config".

    Hinweis Hinweis

    Um die Leistung zu maximieren, kopieren Sie die Dateien aus dem alten Cacheordner in den neuen Cacheordner.

  11. Öffnen Sie ein Eingabeaufforderungsfenster, geben Sie iisreset ein, und drücken Sie dann die EINGABETASTE.

  12. Löschen Sie den alten Cachestammordner.

    Hinweis Hinweis

    Standardgemäß befindet sich der Cachestammordner in %programfiles%\Microsoft Team Foundation Server 2012\Version Control Proxy\Web Services\VersionControlProxy\Data.

Ändern des Limits zum Entfernen alter Dateien aus dem Cache

Sie können die maximale Menge an Speicherplatz ändern, die der Anwendungsebenenserver zum Zwischenspeichern von Dateien verwenden kann. Wenn diese Grenze erreicht ist, wird mithilfe einer Bereinigungsroutine Speicherplatz für neu angeforderte Dateien freigegeben, indem die Dateien gelöscht werden, auf die seit langer Zeit nicht mehr zugegriffen wurde.

So ändern Sie das Limit zum Entfernen alter Dateien aus dem Cache

  1. Öffnen Sie auf dem Anwendungsebenenserver den Windows-Explorer (oder Datei-Explorer), und navigieren Sie zu "\%programfiles%\Microsoft Team Foundation Server 2012\Application Tier\Web Services".

  2. Öffnen Sie die Datei "web.config" in einem Text- oder XML-Editor, und suchen Sie dann das <appSettings>-Element.

  3. Hinzufügen eines der folgenden Elemente:

    • Um einen Prozentsatz des verfügbaren Festplattenspeichers anzugeben, der belegt werden soll, bevor alte Dateien aus dem Cache entfernt werden, fügen Sie das PercentageBasedPolicy-Element hinzu. Sie müssen eine ganze Zahl als Wert für dieses Element angeben.

      Die folgende Zeile gibt beispielsweise an, dass bis zu 60 % des verfügbaren Festplattenspeichers vom Cache belegt werden können, bevor alte Dateien entfernt werden:

      Bild für Kopieren Code kopieren
      <add key="PercentageBasedPolicy" value="60" />

    • Um eine feste Größe in Megabyte (MB) für den Cache anzugeben, die vor dem Entfernen alter Dateien belegt werden soll, fügen Sie das FixedSizeBasedPolicy-Element hinzu. Sie müssen eine ganze Zahl als Wert für dieses Element angeben.

      Die folgende Zeile gibt beispielsweise an, dass der Cache eine Größe von 500 MB erreichen kann, bevor alte Dateien entfernt werden:

      Bild für Kopieren Code kopieren
      <add key="FixedSizeBasedPolicy" value="500" />
      Hinweis Hinweis

      Wenn sowohl das FixedSizeBasedPolicy-Element als auch das PercentageBasedPolicy-Element angegeben wird, wird der Wert des FixedSizeBasedPolicy-Elements verwendet, und der Wert des PercentageBasedPolicy-Elements wird ignoriert.

  4. Speichern und schließen Sie die Datei "web.config".

  5. Öffnen Sie ein Eingabeaufforderungsfenster, geben Sie iisreset ein, und drücken Sie dann die EINGABETASTE.

So ändern Sie die beim Entfernen alter Dateien freizugebende Cachegröße

  1. Öffnen Sie auf dem Anwendungsebenenserver den Windows-Explorer (oder Datei-Explorer), und navigieren Sie zu "%programfiles%\Microsoft Team Foundation Server 2012\Application Tier\Web Services\".

  2. Öffnen Sie die Datei "web.config" in einem Text- oder XML-Editor, suchen Sie das <appSettings>-Element, und fügen Sie dann das CacheDeletionPercent-Element hinzu.

    Die folgende Zeile gibt beispielsweise an, dass 50 % des Caches beim Entfernen alter Dateien freigegeben werden.

    Bild für Kopieren Code kopieren
    <add key="CacheDeletionPercent" value="50" />

  3. Speichern und schließen Sie die Datei "web.config".

  4. Öffnen Sie ein Eingabeaufforderungsfenster, geben Sie iisreset ein, und drücken Sie dann die EINGABETASTE.

Siehe auch

Konzepte

Dienstkonten und Abhängigkeiten in Team Foundation Server


Konfigurieren von Benutzern, Gruppen und Berechtigungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Benutzern, Gruppen und Berechtigungen
Feedback senden

Die Sicherheit von Team Foundation beruht auf Benutzern und Gruppen. Mithilfe der Standardgruppen in Visual Studio Team Foundation Server (TFS) können Sie Benutzer und Gruppen im Rahmen der Implementierung eines Sicherheitsmodells für Ihr Unternehmen verwalten. Standardgruppen gibt es auf Server-, Auflistungs- und Projektebene. Darüber hinaus können Sie auf allen diesen Ebenen benutzerdefinierte Gruppen mit bestimmten Berechtigungen für Ihr spezifisches Sicherheitsmodell erstellen. Ein gruppenbasiertes Sicherheitsmodell versetzt Benutzer in die Lage, auf die benötigten Daten zuzugreifen, ohne dass Sie jedem Benutzerkonto separat Berechtigungen erteilen müssen. Diese Strategie unterstützt Sie dabei, vertrauliche Informationen zu schützen und gleichzeitig den Mehraufwand für die Verwaltung des Benutzerzugriffs auf die Bereitstellung zu reduzieren.

Sie müssen für jede Rolle in Ihrem Unternehmen ermitteln, welche Gruppenmitgliedschaft erforderlich ist, damit die Benutzer ihre Aufgaben durchführen können. In TFS, SharePoint-Produkte und SQL Server Reporting Services werden eigene Informationen über Gruppen, Benutzer und Berechtigungen verwaltet. Sie müssen sorgfältig planen, wie Sie Benutzer und Berechtigungen verwalten möchten. Diese Planung betrifft nicht nur einzelne Projekte in TFS, sondern auch TFS selbst, das Windows-Betriebssystem und, sofern diese für die Bereitstellung konfiguriert sind, SharePoint-Produkte und SQL Server Reporting Services. Sie können innerhalb von TFS Berechtigungen auf verschiedenen Ebenen erteilen oder verweigern, z. B. für Arbeitsaufgaben, den Zugriff auf die Versionskontrolle, den Zugriff auf ein Projekt oder eine Projektauflistung und den Zugriff auf TFS selbst.

Sie können einen Benutzer in bestimmten Fällen auch direkt zu einem Teamprojekt oder einer Teamprojektsammlung hinzufügen, anstatt den Benutzer zu einer Gruppe auf Projekt- oder Auflistungsebene hinzuzufügen. In diesen Fällen müssen Sie dem jeweiligen Benutzerkonto Berechtigungen direkt erteilen.

Allgemeine Aufgaben

Titel | Beschreibung
Hinzufügen von Benutzern oder Benutzergruppen: Sie können Benutzer schnell zu Teamprojekten, Teamprojektsammlungen oder TFS selbst hinzufügen, indem Sie diese den entsprechenden Standardgruppen für die jeweilige Rolle hinzufügen. | Hinzufügen von Benutzern zu Teamprojekten Festlegen von Administratorberechtigungen für Teamprojektsammlungen Festlegen von Administratorberechtigungen für Team Foundation Server Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams
Ändern oder Bearbeiten von Standardgruppen: Sie können die Mitgliedschaft von Standardgruppen ändern. Zudem können Sie die Standardberechtigungen, die einigen Gruppen erteilt wurden, bearbeiten und an Ihre Sicherheitsanforderungen anpassen. | Team Foundation Server-Berechtigungen Team Foundation Server: Standardgruppen, Berechtigungen und Rollen
Verstehen und Verwalten von Berechtigungen: Sie können alle einzeln konfigurierbaren Berechtigungen für Team Foundation Server überprüfen, die standardmäßig zugewiesenen Berechtigungen ermitteln und die Berechtigungen für bestimmte Gruppen oder Benutzer anzeigen. | Team Foundation Server-Berechtigungen Team Foundation Server: Standardgruppen, Berechtigungen und Rollen Zugriff auf Funktionen über Webberechtigungen Ansichtsberechtigungen Ändern der Berechtigungen für eine Gruppe oder einen Benutzer
Verstehen von Dienstkonten und Gruppen: Sie müssen nicht nur die Berechtigungen für die Benutzer, sondern auch die Berechtigungen für die Dienstkonten verwalten, auf denen Team Foundation Server basiert. | Dienstkonten und Abhängigkeiten in Team Foundation Server Ändern des Dienstkontos oder Kennworts für Team Foundation Server Ändern des Dienstkontos oder Kennworts für SQL Server Reporting Services

Verwandte Abschnitte

Verwalten von Team Foundation Server

Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]

Agile-Planung und -Iterationen

Erste Schritte im Team

Planen und Nachverfolgen von Projekten


Hinzufügen von Benutzern zu Teamprojekten

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Hinzufügen von Benutzern zu Teamprojekten
Siehe auch Feedback senden

Sie können steuern, in welchem Umfang einzelne Teammitglieder auf Teamprojekte zugreifen können, indem Sie jedes Mitglied verschiedenen Gruppen für die jeweiligen Projekte zuweisen. Um Teammitglieder vollen Zugriff auf die gesamte Funktionalität des Projekts zu erteilen, müssen Sie sie ggf. auch Gruppen in SQL Server Reporting Services und SharePoint-Produkte hinzufügen.

Wichtiger Hinweis Wichtig

Selbst nachdem Sie die Benutzer mit den von ihnen benötigten Berechtigungen konfiguriert haben, können die Benutzer unter Umständen nicht auf bestimmte Funktionen von Team Foundation Server zugreifen. Einige Funktionen, wie das Team-Taskboard, sind von der Lizenzierungsebene dieses Benutzers abhängig. Um einen entsprechenden Zugriff auf Funktionen sicherzustellen, sollten Sie auch die Mitgliedschaft des Benutzers in den Lizenzierungsgruppen für Team Foundation Server überprüfen.

Standardmäßig erstellt Visual Studio Team Foundation Server mehrere Gruppen für jedes Projekt, wobei jede Gruppe eine individuelle Berechtigungsstufe und individuelle Rechte für das jeweilige Projekt aufweist. Sie können diese Standardgruppen verwenden oder benutzerdefinierte Gruppen mit spezifischen Berechtigungen erstellen. Sie können z. B. der Gruppe "Leser" Benutzer hinzufügen, damit sie Arbeitsaufgaben für ein Projekt anzeigen, aber nicht erstellen, ändern oder löschen können. Darüber hinaus können Sie festlegen, dass andere Benutzer Arbeitsaufgaben aktualisieren, jedoch keine Verwaltungsaufgaben (z. B. Projekte löschen und Testergebnisse veröffentlichen) dürfen. Weitere Informationen zu den Standardbenutzergruppen in Team Foundation Server finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Selbst Benutzer, die über entsprechende Berechtigungen verfügen, können Teamprojektportale oder Berichte möglicherweise erst korrekt anzeigen, nachdem sie die Websites in Internet Explorer zur Liste der vertrauenswürdigen Sites hinzugefügt haben. Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

Wenn das Projekt Ressourcen in SharePoint-Produkte und Reporting Services verwendet, müssen Sie Benutzer, die diese Ressourcen benötigen, zu Gruppen mit entsprechenden Berechtigungen für diese Programmen hinzufügen. Um Benutzern vollen Zugriff auf die gesamte Funktionalität für das Projekt zu erteilen, müssen Sie sie zu den Standardgruppen in der folgenden Tabelle hinzufügen:

Software | Leser | Mitwirkende | Projektleiter
Team Foundation Server | Leser | Mitwirkende | Projektadministratoren
SharePoint-Produkte | Gäste | Mitglieder | Besitzer
SQL Server Reporting Services | Browser | Browser | Team Foundation-Inhalts-Manager
Tipp Tipp

Im Gegensatz zu Team Foundation Server und SharePoint Foundation 2010 unterscheidet SQL Server Reporting Services nicht zwischen Projekten. Wenn Sie den Reporting Services eine Gruppe hinzufügen, enthält diese Gruppe die gleichen Berechtigungen hinsichtlich der Berichte für alle Projekte in der Auflistung, unabhängig von deren Berechtigungen in einzelne Projekten. Beachten Sie dies, wenn Sie sich dazu entscheiden, welche Gruppen hinzugefügt werden.

Weitere Informationen zum Festlegen von Berechtigungen für Administratoren in Team Foundation finden Sie unter Festlegen von Administratorberechtigungen für Teamprojektsammlungen und Festlegen von Administratorberechtigungen für Team Foundation Server.

Erforderliche Berechtigungen

Zum Durchführen dieser Schritte müssen Sie Mitglied der folgenden Gruppen sein:

  • Gruppe Projektadministratoren, oder die Berechtigung Serverebeneninformationen bearbeiten muss in Team Foundation Server auf Zulassen festgelegt sein

  • Gruppe Siteadministratoren oder Gruppe Siteauflistungsadministratoren in SharePoint-Produkte

  • Gruppe Inhalts-Manager oder Gruppe Projektinhalts-Manager in SQL Server Reporting Services

  • Um die Mitgliedschaft eines Benutzers in einer Lizenzierungsgruppe zu überprüfen oder zu ändern, müssen Sie Mitglied der Gruppe Team Foundation Server-Administratoren sein.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Neben diesen Berechtigungen müssen Sie auf einem Computer, auf dem Windows Server 2008 oder Windows Vista ausgeführt wird, gegebenenfalls Folgendes durchführen:

  • Zum Ausführen einer Prozedur, für die Internet Explorer erforderlich ist, müssen Sie Internet Explorer möglicherweise als Administrator starten. Klicken Sie hierzu auf Start, Alle Programme und dann mit der rechten Maustaste auf Internet Explorer. Klicken Sie anschließend auf Als Administrator ausführen.

  • Um Zugriff auf den Berichts-Manager, Berichte oder Websites für Reporting Services zu erhalten, müssen Sie diese Sites möglicherweise in Internet Explorer der Liste der vertrauenswürdigen Sites hinzufügen oder Internet Explorer als Administrator starten.

Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

So fügen Sie Benutzer oder Gruppen in Team Foundation Server hinzu

  1. Öffnen Sie in Team Explorer das Teamprojekt, dem Sie Benutzer hinzufügen möchten, und wählen Sie dann Einstellungen aus.

    Das Menü Einstellungen wird angezeigt.

  2. Wählen Sie im Einstellungsmenü unter Teamprojekt die Option Gruppenmitgliedschaft aus.

    Team Web Access wird im Verwaltungskontext für das Teamprojekt auf der Registerkarte Sicherheit geöffnet.

  3. Wählen Sie auf der Registerkarte Gruppen eine der folgenden Optionen aus:

    • Um Benutzer hinzuzufügen, die minimalen Zugriff auf das Projekt benötigen, wählen Sie Leser.

    • Um Benutzer hinzuzufügen, die in vollem Umfang zu diesem Projekt beitragen, wählen Sie Mitwirkende.

    • Um Benutzer hinzuzufügen, die als Projektleiter fungieren, wählen Sie Projektadministratoren.

    Nachdem Sie eine Gruppe oder einen Benutzer ausgewählt haben, wählen Sie auf der Registerkarte Mitglieder die Option Hinzufügen aus, und wählen Sie anschließend Benutzer hinzufügen aus.

    Das Fenster WINDOWS-BENUTZER ODER -GRUPPE HINZUFÜGEN wird geöffnet.

  4. Geben Sie unter Identitäten den Namen des Benutzers oder der Gruppe an, die Sie hinzufügen möchten.

    Tipp Tipp

    Wenn Sie zum ersten Mal einen Benutzer oder eine Gruppe zu Team Foundation Server hinzufügen, können Sie diesen nicht aufrufen oder den Namen überprüfen. Nachdem die Identität an einem beliebigen Speicherort im Team Foundation Server hinzugefügt wurde, können Sie die Funktionen verwenden, um den entsprechenden Namen umgehend zu finden.

  5. Wenn Sie die gewünschten Gruppen oder Benutzer hinzugefügt haben, wählen Sie Änderungen speichern aus.

So fügen Sie Benutzer oder Gruppen in SharePoint Foundation 2010 hinzu

  1. Wählen Sie in Team Explorer im Menü Team die Option Projektportal anzeigen aus.

    Das Portal für das Teamprojekt wird in einem separaten Fenster geöffnet.

  2. Wählen Sie Websiteaktionen und anschließend Websiteberechtigungen aus.

    Die Browserfenster wird in Berechtigungs-Tools geändert.

  3. Wählen Sie Berechtigungen erteilen aus.

    Das Fenster "Berechtigungen erteilen" wird geöffnet.

  4. Geben Sie unter Benutzer/Gruppen den Namen der Gruppe an, die Sie hinzufügen möchten. Wählen Sie unter Berechtigungen erteilen die Option Benutzern eine Berechtigung direkt erteilen aus, und aktivieren Sie anschließend eines der folgenden Kontrollkästchen:

    • Um Benutzer hinzuzufügen, die minimalen Zugriff auf das Projekt benötigen, aktivieren Sie das Kontrollkästchen Leser.

    • Um Benutzer hinzuzufügen, die in vollem Umfang zu diesem Projekt beitragen, aktivieren Sie das Kontrollkästchen Mitwirkende.

    • Um Benutzer hinzuzufügen, die als Projektleiter fungieren, aktivieren Sie das Kontrollkästchen Vollzugriff.

  5. Wenn Sie die gewünschten Gruppen oder Benutzer hinzugefügt haben, wählen Sie OK aus.

So fügen Sie Benutzer oder Gruppen in SQL Server Reporting Services hinzu

  1. Öffnen Sie Internet Explorer oder einen anderen Browser, der mit der Reporting Services-Verwaltung kompatibel ist.

  2. Geben Sie in die Adressleiste Folgendes ein. Dabei steht ReportServer für den Namen des Servers, auf dem SQL Server Reporting Services ausgeführt wird:

    http://ReportServer/Reports/Pages/Folder.aspx

  3. Wählen Sie auf der Startseite die Option Ordnereinstellungen aus.

  4. Wählen Sie auf der Seite Sicherheit die Option Neue Rollenzuweisung aus.

  5. Geben Sie auf der Seite Neue Rollenzuweisung unter Gruppen- oder Benutzername den Namen der Gruppe an, die Sie hinzufügen möchten, und aktivieren Sie anschließend eines der folgenden Kontrollkästchen:

    • Um Benutzer hinzuzufügen, die als Leser oder Mitwirkende für das Projekt fungieren können, aktivieren Sie das Kontrollkästchen Browser.

    • Um Benutzer hinzuzufügen, die als Projektleiter fungieren, aktivieren Sie das Kontrollkästchen Team Foundation-Inhalts-Manager.

    Sobald Sie fertig sind, den Benutzer oder die Gruppe hinzuzufügen und das entsprechende Kontrollkästchen aktiviert haben, wählen Sie OK aus.

So überprüfen Sie die für einen Benutzer verfügbaren Funktionen

  1. Öffnen Sie Team Web Access im Verwaltungsmodus, und wählen Sie Systemsteuerung aus, um zum Verwaltungskontext auf oberster Ebene zu navigieren.

  2. Wählen Sie die Registerkarte Web Access aus.

  3. Wählen Sie wiederum unter Web Access-Berechtigungen den Namen jeder Lizenzgruppe aus, und überprüfen Sie die folgenden Informationen:

    1. Welche Lizenzierungsgruppe als Standardgruppe für die Bereitstellung festgelegt ist. Auf diesen Gruppennamen folgt (Standard). Dies ist die Gruppe, der alle Benutzer der Bereitstellung von Team Foundation Server standardmäßig zugewiesen werden.

      Tipp Tipp

      Die Standardgruppe wird auf Standard festgelegt.

  4. Ob der Benutzer, für den Sie die Lizenzierungsebenen festlegen, Mitglied einer anderen Lizenzierungsgruppe als der Standardgruppe ist. Ist dies der Fall, lesen Sie die Beschreibung der Funktionen dieser Lizenzierungsgruppe, um besser zu verstehen, welche Funktionen für diesen Benutzer verfügbar bzw. nicht verfügbar sind.

  5. Um die Mitgliedschaft in der Lizenzierungsgruppe für alle Benutzer in der Bereitstellung gleichzeitig zu überprüfen, wählen Sie Export-Überprüfungsprotokoll aus. Die Mitgliedschaftsinformationen werden in eine durch Trennzeichen getrennte Datei exportiert. Speichern oder öffnen Sie die Datei.

    Weitere Informationen zu den Lizenzierungsstufen und den in Team Foundation Server verfügbaren Funktionen finden Sie im Whitepaper zur Team Foundation Server-Lizenzierung.

Siehe auch

Aufgaben

Festlegen von Administratorberechtigungen für Team Foundation Server
Festlegen von Administratorberechtigungen für Teamprojektsammlungen

Konzepte

Team Foundation Server-Berechtigungen
Team Foundation Server: Standardgruppen, Berechtigungen und Rollen
Konfigurieren von Benutzern, Gruppen und Berechtigungen

Weitere Ressourcen

Server-Level Groups


Festlegen von Administratorberechtigungen für Teamprojektsammlungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Festlegen von Administratorberechtigungen für Teamprojektsammlungen
Siehe auch Feedback senden

Um Benutzern Administratorberechtigungen für eine Teamprojektsammlung zu gewähren, fügen Sie die Benutzer den entsprechenden Gruppen hinzu oder gewähren ihnen bestimmte Berechtigungen in Visual Studio Team Foundation Server. Wenn die Sammlung Ressourcen auf SharePoint-Produkte und SQL Server Reporting Services verwendet, gewähren Sie diese Berechtigungen ebenfalls den Benutzern dieser Programme.

Projektsammlungsadministratoren pflegen die Sammlung und verwalten die Berechtigungen sowie die Sicherheit anderer Rollen auf Sammlungsebene. Mitglieder der Gruppe Projektauflistungsadministratoren verfügen über die höchste Stufe der Berechtigungen aller Benutzer in der Sammlung und die zweithöchste Stufe der Berechtigungen einer Standardgruppe in Team Foundation Server. In den meisten Unternehmen, die Team Foundation Server verwenden, verwalten die Projektsammlungsadministratoren die Sammlungen, die von den Mitgliedern der Gruppe Team Foundation-Administratoren erstellt werden. Mitglieder der Gruppe Projektauflistungsadministratoren erstellen die Sammlungen jedoch nicht selbst. Projektsammlungsadministratoren führen außerdem Aufgaben zur Verwaltung der Sammlung durch, wie z. B. das Erstellen von Teamprojekten, das Hinzufügen von Benutzern zu Gruppen oder das Ändern der Einstellungen für die Sammlung.

Informationen darüber, wie Berechtigungen für andere Teammitglieder festgelegt werden, finden Sie unter Hinzufügen von Benutzern zu Teamprojekten.

Ein Administrator für Teamprojektsammlungen muss zu den folgenden Gruppen gehören:

  • Team Foundation Server: Projektauflistungsadministratoren, oder die entsprechenden Berechtigungen auf Sammlungsebene müssen auf Zulassen festgelegt sein.

    Weitere Informationen finden Sie unter Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

  • SharePoint-Produkte: Siehe Websiteauflistungsadministratoren, wenn die Auflistung mit einer Websiteauflistungsressource konfiguriert ist

    Diese Gruppe kann abhängig von der SharePoint-Produkte-Version und den Sicherheitsanforderungen der Bereitstellung variieren. Weitere Informationen finden Sie unter Interactions Between SharePoint Products and Team Foundation Server und Roles in SharePoint Products.

  • Reporting Services: Siehe Team Foundation-Inhalts-Manager, wenn die Auflistung mit Berichtsressourcen konfiguriert ist

Hinweis Hinweis

Selbst Benutzer, die über entsprechende Berechtigungen verfügen, können Teamprojektportale oder Berichte möglicherweise erst korrekt anzeigen, nachdem sie die Websites in Internet Explorer zu den vertrauenswürdigen Sites hinzugefügt haben. Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

Erforderliche Berechtigungen

Um diese Verfahren durchführen zu können, müssen Sie entweder über die folgenden Berechtigungen verfügen oder Mitglied der folgenden Gruppen sein:

  • Projektauflistungsadministratoren-Gruppe oder die Berechtigungen Serverebeneninformationen anzeigen und Serverebeneninformationen bearbeiten müssen auf Zulassen festgelegt sein.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  • Um Berechtigungen für SharePoint-Produkte hinzuzufügen, die Gruppe Websitesammlungsadministratoren oder die Gruppe Farmadministratoren für SharePoint-Produkte

  • Um Berechtigungen für Reporting Services hinzuzufügen, die Gruppe Inhalts-Manager oder die Gruppe Projektinhalts-Manager für Reporting Services

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Neben diesen Berechtigungen müssen Sie auf einem Computer, auf dem Windows Server 2008 oder Windows Vista ausgeführt wird, gegebenenfalls Folgendes durchführen:

  • Zum Ausführen einer Prozedur, für die Internet Explorer erforderlich ist, müssen Sie Internet Explorer möglicherweise als Administrator starten. Klicken Sie hierzu auf Start, Alle Programme und dann mit der rechten Maustaste auf Internet Explorer. Klicken Sie anschließend auf Als Administrator ausführen.

  • Für den Zugriff auf den Berichts-Manager, Berichte oder Websites für SQL Server Reporting Services müssen Sie diese Sites gegebenenfalls der Liste vertrauenswürdiger Sites in Internet Explorer hinzufügen oder Internet Explorer als Administrator starten.

Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

So fügen Sie Benutzer oder Gruppen in Team Foundation Server hinzu

  1. Wählen Sie in Team Explorer das Menü Team, gefolgt von "Teamprojektsammlungs-Einstellungen" aus, und wählen Sie dann Sicherheit aus.

    Team Web Access wird im Verwaltungskontext für das Teamprojekt auf der Registerkarte Sicherheit geöffnet.

  2. Wählen Sie auf der Registerkarte Gruppen die Option Projektauflistungsadministratoren aus.

    Wählen Sie die Registerkarte Mitglieder und dann Hinzufügen aus. Anschließend wählen Sie Windows-Benutzer oder -Gruppe hinzufügen aus.

    Das Fenster WINDOWS-BENUTZER ODER -GRUPPE HINZUFÜGEN wird geöffnet.

  3. Geben Sie unter Identitäten den Namen des Benutzers oder der Gruppe an, die Sie hinzufügen möchten.

    Tipp Tipp

    Wenn Sie zum ersten Mal einen Benutzer oder eine Gruppe zu Team Foundation Server hinzufügen, können Sie diesen nicht aufrufen oder den Namen überprüfen. Nachdem die Identität an einem beliebigen Speicherort im Team Foundation Server hinzugefügt wurde, können Sie die Funktionen verwenden, um den entsprechenden Namen zu suchen.

  4. Wenn Sie die gewünschten Gruppen oder Benutzer hinzugefügt haben, wählen Sie Änderungen speichern aus.

So gewähren Sie Administratorberechtigungen in SharePoint Foundation 2010

  1. Öffnen Sie auf dem Server, auf dem SharePoint-Produkte ausgeführt wird, die SharePoint-Zentraladministration.

    Weitere Informationen finden Sie unter Access Site Administration or Central Administration for SharePoint Products.

  2. Gewähren Sie entsprechend den Sicherheitsanforderungen auf der Farm- oder Webanwendungsebene geeignete Berechtigungen für diesen Benutzer.

    Weitere Informationen finden Sie unter Windows SharePoint Services Roles und auf der Microsoft-Website im SharePoint-Produkte-TechCenter (möglicherweise in englischer Sprache). Für optimale Interoperabilität sollten Benutzer in der Gruppe Projektauflistungsadministratoren ggf. den folgenden Gruppen in SharePoint-Produkte hinzugefügt werden:

    • Gruppe Websitesammlungsadministratoren für die von der Teamprojektsammlung verwendete Websitesammlung

So gewähren Sie Administratorberechtigungen für eine Teamprojektsammlung in Reporting Services

  1. Öffnen Sie Internet Explorer.

    Hinweis Hinweis

    Selbst wenn Sie mit Administratorrechten angemeldet sind, müssen Sie Internet Explorer als Administrator starten, um diese Funktion auf einem Computer auszuführen, auf dem Windows Server 2008 oder Windows Vista ausgeführt wird. Klicken Sie zum Starten von Internet Explorer als Administrator auf Start, klicken Sie auf Alle Programme, klicken Sie mit der rechten Maustaste auf Internet Explorer, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

  2. Geben Sie in der Adressleiste die folgende URL ein, wobei ReportServer der Name des Servers ist, auf dem Reporting Services ausgeführt wird: http:// ReportServer/Reports/Pages/Folder.aspx

    Wichtiger Hinweis Wichtig

    Wenn Sie eine benannte Instanz verwenden, muss der Pfad zu den Berichten den entsprechenden Namen enthalten. Verwenden Sie folgende Syntax, wobei ReportServer für den Namen des Team Foundation-Berichtsservers und Instanzname für den Namen der SQL Server-Instanz steht: http://ReportServer/Reports_Instanzname/Pages/Folder.aspx

  3. Wählen Sie auf der Startseite die Option Ordnereinstellungen aus.

  4. Wählen Sie auf der Seite Sicherheit die Option Neue Rollenzuweisung aus.

  5. Geben Sie auf der Seite Neue Rollenzuweisung unter Gruppen- oder Benutzername den Kontonamen des Benutzers oder der Gruppe an, dem bzw. der Sie Administratorberechtigungen gewähren möchten.

  6. Aktivieren Sie unter Rolle das Kontrollkästchen Team Foundation-Inhalts-Manager, und wählen Sie dann OK aus.

Siehe auch

Aufgaben

Hinzufügen von Benutzern zu Teamprojekten
Öffnen der Team Foundation-Verwaltungskonsole
Festlegen von Administratorberechtigungen für Team Foundation Server

Konzepte

Team Foundation Server-Berechtigungen
SQL Server und SQL Server Reporting Services

Weitere Ressourcen

Interactions Between SharePoint Products and Team Foundation Server


Festlegen von Administratorberechtigungen für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Festlegen von Administratorberechtigungen für Team Foundation Server
Siehe auch Feedback senden

Sie können Benutzern in Visual Studio Team Foundation Server Administratorberechtigungen gewähren, indem Sie sie der Gruppe Team Foundation-Administratoren in Team Foundation Server hinzufügen. Wenn in der Bereitstellung Ressourcen in SQL Server Reporting Services verwendet werden, müssen Sie diesen Benutzern auch in diesem Programm Berechtigungen gewähren. Anders als in früheren Versionen von Team Foundation Server müssen Administratoren von Team Foundation keine Berechtigungen in SharePoint-Produkte gewährt werden. Die für die Interoperabilität der SharePoint-Produkte erforderlichen Berechtigungen werden dem Dienstkonto für Team Foundation Server zugewiesen. Für optimale Interoperabilität und Benutzerfreundlichkeit können Sie Mitglieder der Gruppe Team Foundation-Administratoren bestimmten Gruppen in SharePoint-Produkte als Mitglieder hinzufügen.

Administratoren verwalten mindestens einen Server, auf dem Team Foundation Server ausgeführt wird, und verwalten Berechtigungen und Sicherheit für andere Rollen auf der Serverebene und der Ebene von Teamprojektsammlungen. Mitglieder der Gruppe Team Foundation-Administratoren verfügen unter den Team Foundation Server-Benutzern über die meisten Berechtigungen. Für die meisten Organisationen, dieTeam Foundation Server verwenden, erstellen und verwalten Administratoren Teamprojektsammlungen und führen auch weitere Vorgänge aus, die zur Verwaltung des Servers erforderlich sind.

Informationen darüber, wie Berechtigungen für Teammitglieder festgelegt werden, finden Sie unter Hinzufügen von Benutzern zu Teamprojekten und unter Festlegen von Administratorberechtigungen für Teamprojektsammlungen

Ein Administrator für Team Foundation Server muss Mitglied der folgenden Gruppen sein oder über die folgenden Berechtigungen verfügen:

  • Team Foundation Server: Team Foundation-Administratoren, oder die entsprechenden Berechtigungen auf Serverebene sind auf Zulassen festgelegt. Weitere Informationen finden Sie unter Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

  • Windows: Die Administratoren-Gruppe auf dem Server, der die Verwaltungskonsole für Team Foundation ausführt. Zur ordnungsgemäßen Verwendung der Verwaltungskonsole sind Administratorberechtigungen erforderlich.

  • SharePoint-Produkte: Die entsprechenden Gruppen oder Berechtigungen in der SharePoint-Zentraladministration. Abhängig von der Bereitstellungskonfiguration und den Sicherheitsanforderungen ist es möglicherweise nicht erforderlich, Benutzer in SharePoint-Produkte Gruppen hinzuzufügen. Fügen Sie die Benutzer für optimale Interoperabilität ggf. den folgenden SharePoint-Produkte-Gruppen hinzu:

    • Farm-Administratoren

    • Gruppe Websitesammlungsadministratoren für alle Websitesammlungen, die von der Bereitstellung von Team Foundation Server verwendet werden.

    Weitere Informationen finden Sie unter Interactions Between SharePoint Products and Team Foundation Server und Dienstkonten und Abhängigkeiten in Team Foundation Server.

  • Reporting Services: Team Foundation-Inhalts-Manager und entweder die sysadmin- oder die db_owner-Gruppenmitgliedschaft für die Konfigurationsdatenbank, die Berichterstellungs- und Analysedatenbanken und die Datenbanken für Teamprojektsammlungen.

  • SQL Server: Rolle serveradmin, wenn der Benutzer beim Erstellen einer Teamprojektsammlung eine Datenbank erstellen können soll. Wenn die Sicherheitsanforderungen die Mitgliedschaft bei dieser Rolle einschränken, muss ein SQL Server-Administrator eine zu verwendende Datenbank erstellen, bevor eine Teamprojektsammlung erstellt werden kann.

Hinweis Hinweis

Selbst Benutzer, die über entsprechende Berechtigungen verfügen, können Teamprojektportale oder Berichte möglicherweise erst korrekt anzeigen, nachdem sie die Websites in Internet Explorer zu den vertrauenswürdigen Sites hinzugefügt haben. Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

Zum Gewähren von Administratorberechtigungen für Team Foundation Server stehen Ihnen zwei Methoden zur Verfügung: über die Verwaltungskonsole oder direkt in jedem Programm, für das Sie Berechtigungen gewähren möchten. Das Gewähren von Berechtigungen über die Verwaltungskonsole ist einfacher, setzt jedoch voraus, dass bestimmte Anforderungen erfüllt werden. Die Verwaltungskonsole kann verwendet werden, wenn die folgenden Bedingungen zutreffen:

  • Die Team Foundation Server-Bereitstellung befindet sich in einer vertrauenswürdigen Umgebung, in der das Dienstkonto für Team Foundation Server über Berechtigungen in SharePoint-Produkte und SQL Server Reporting Services verfügt.

  • Alle Programme werden auf dem gleichen Computer ausgeführt (Bereitstellung auf einem Server).

  • Aufgrund der Sicherheitsanforderungen für die Bereitstellung gelten keine Einschränkungen für die Berechtigungen in der unten stehenden Liste.

Bei einer Team Foundation Server-Bereitstellung auf einem Server wird über die Verwaltungskonsole hinzugefügten Benutzern standardmäßig die Mitgliedschaft in den folgenden Gruppen gewährt:

  • Gruppe der Team Foundation-Administratoren in Team Foundation Server

  • Gruppen IIS_IUSRS und TFS_APPTIER_SERVICE_WPG in Internetinformationsdiensten (IIS)

  • Inhalts-Manager-Rolle in SQL Server Reporting Services, wenn die Berichterstellung konfiguriert ist

  • Gruppe Farmadministratoren in SharePoint-Produkte, wenn die Bereitstellung zur Verwendung von SharePT konfiguriert ist

  • DBO- und TFSExecRole-Rolle für alle von Team Foundation Server verwendeten Datenbanken, einschließlich Sammlungsdatenbanken

Wichtiger Hinweis Wichtig

Sie können der lokalen Gruppe Administratoren keinen Benutzer hinzufügen, indem Sie das Konto dieses Benutzers als Konsolenbenutzer hinzufügen. Der Benutzer verfügt erst dann über alle Berechtigungen, die zum Öffnen und Verwenden der Konsole erforderlich sind, wenn Sie ihn manuell dieser Gruppe hinzugefügt haben. Wenn der Benutzer außerdem über ausreichende Berechtigungen zum Erstellen einer Datenbank als Teil einer Teamprojektsammlung verfügen soll, müssen Sie diesem Benutzer die Mitgliedschaft in der Rolle serveradmin in SQL Server gewähren.

Das direkte Gewähren von Berechtigungen in jedem Programm in der Team Foundation Server-Bereitstellung ist zeitaufwändiger, bietet aber die Möglichkeit, die genauen Berechtigungen, die Sie einem Benutzer gewähren möchten, exakt zu konfigurieren. Wenn eine der folgenden Bedingungen zutrifft, sollten Sie erwägen, die Berechtigungen direkt in jedem Programm zu gewähren:

  • Die Team Foundation Server-Bereitstellung ist eine Bereitstellung auf mehreren Servern.

  • Die Bereitstellung befindet sich in einer Umgebung, in der Sicherheitseinschränkungen zwischen Team Foundation Server und den Servern gelten, auf denen SQL Server und SharePoint-Produkte ausgeführt werden.

  • Sie möchten in SharePoint-Produkte, SQL Server Reporting Services und Team Foundation Server nicht die Gruppenmitgliedschaften und Berechtigungsstufen konfigurieren, die automatisch über die Verwaltungskonsole gewährt werden.

Erforderliche Berechtigungen

Um diese Vorgänge auszuführen, müssen Sie Mitglied der folgenden Gruppen sein oder über folgende Berechtigungen verfügen:

  • Gruppe Team Foundation-Administratoren, oder die Berechtigungen Instanzebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten sind auf Zulassen festgelegt.

  • Wenn Sie Berechtigungen für SQL Server Reporting Services hinzufügen möchten, müssen Sie Mitglied der Gruppe Team Foundation-Inhalts-Manager oder der Gruppe Systemadministratoren sein.

  • Wenn Sie Berechtigungen für SharePoint-Produkte hinzufügen möchten, die Gruppe Farmadministratoren, die Administratorgruppe für die Webanwendung, die Team Foundation Server unterstützt, oder die Gruppe SharePoint-Administration. Die Gruppenmitgliedschaft hängt von der Sicherheitsarchitektur der Bereitstellung und den Gruppen ab, denen Sie den Benutzer hinzufügen möchten.

  • Wenn Sie die Rollenmitgliedschaft für SQL Server hinzufügen möchten, benötigen Sie die Rolle sysadmin auf jedem Server, der Datenbanken für Team Foundation Server hostet.

Wichtiger Hinweis Wichtig

Um Verwaltungsaufgaben wie das Erstellen von Teamprojektsammlungen auszuführen, erfordert Ihr Benutzerkonto Administratorberechtigungen, und das Dienstkonto, das der Team Foundation-Hintergrundauftrags-Agent verwendet, muss ebenfalls über bestimmte Berechtigungen verfügen. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server und unter Team Foundation-Hintergrundauftrags-Agent.

Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Neben diesen Berechtigungen müssen Sie auf einem Computer, auf dem Windows Server 2008, Windows Server 2008 R2, Windows Vista oder Windows 7 ausgeführt wird, gegebenenfalls Folgendes durchführen:

  • Zum Ausführen einer Prozedur, für die Internet Explorer erforderlich ist, müssen Sie Internet Explorer möglicherweise als Administrator starten. Klicken Sie dazu auf Start, Alle Programme und dann mit der rechten Maustaste auf Internet Explorer. Klicken Sie anschließend auf Als Administrator ausführen.

  • Für den Zugriff auf den Berichts-Manager, Berichte oder Websites für SQL Server Reporting Services müssen Sie diese Sites gegebenenfalls der Liste vertrauenswürdiger Sites in Internet Explorer hinzufügen oder Internet Explorer als Administrator starten.

Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

So gewähren Sie Administratorberechtigungen in einer vertrauenswürdigen Umgebung über die Team Foundation-Verwaltungskonsole

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Server, und klicken Sie auf Anwendungsebene.

  3. Klicken Sie im Abschnitt Benutzer der Verwaltungskonsole auf Hinzufügen.

  4. Geben Sie unter Benutzer für Team Foundation Server-Verwaltungskonsole hinzufügen das Benutzerkonto an, das Sie als Mitglied der Gruppe "Team Foundation-Administratoren" hinzufügen möchten.

    Wählen Sie Suchen, wenn Sie den Alias nicht kennen. Sie können auch den Abschnitt Erweiterte Funktionen erweitern und die Einstellungen für Erforderliche Berechtigungen zum Erstellen von Auflistungen hinzufügen und Erforderliche Berechtigungen zum Ändern von Dienstkonten hinzufügen entsprechend den betrieblichen Erfordernissen und den Sicherheitsanforderungen für den hinzugefügten Benutzer ändern.

  5. Wenn Sie die gewünschten Einstellungen vorgenommen haben, wählen Sie OK aus.

  6. Überprüfen Sie die Statusinformationen im Fenster Benutzer für Verwaltungskonsole hinzufügen.

  7. (Optional) Wählen Sie nach Abschluss des Prozesses den Link aus, um die Protokolldatei zu öffnen.

  8. Wählen Sie Schließen, um zur Verwaltungskonsole zurückzukehren.

    Wichtiger Hinweis Wichtig

    Sie können der lokalen Gruppe Administratoren keinen Benutzer hinzufügen, indem Sie das Konto dieses Benutzers als Konsolenbenutzer hinzufügen. Der Benutzer verfügt erst dann über alle Berechtigungen, die zum Öffnen und Verwenden der Konsole erforderlich sind, wenn Sie ihn manuell dieser Gruppe hinzugefügt haben. Wenn der Benutzer außerdem über ausreichende Berechtigungen zum Erstellen einer Datenbank als Teil einer Teamprojektsammlung verfügen soll, müssen Sie diesem Benutzer die Mitgliedschaft in der Rolle serveradmin in SQL Server gewähren.

Gewähren von Administratorberechtigungen in Team Foundation Server

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie den Server, und klicken Sie auf Anwendungsebene.

  3. Klicken Sie im Abschnitt Benutzer der Verwaltungskonsole auf Hinzufügen.

  4. Geben Sie unter Benutzer für Team Foundation Server-Verwaltungskonsole hinzufügen das Benutzerkonto an, das Sie als Mitglied der Gruppe "Team Foundation-Administratoren" hinzufügen möchten.

    Wählen Sie Suchen, wenn Sie den Alias nicht kennen.

    Sie können auch den Abschnitt Erweiterte Funktionen erweitern und die Einstellungen für Erforderliche Berechtigungen zum Erstellen von Auflistungen hinzufügen und Erforderliche Berechtigungen zum Ändern von Dienstkonten hinzufügen entsprechend den betrieblichen Erfordernissen und den Sicherheitsanforderungen für den hinzugefügten Benutzer ändern. Lassen Sie diese Kontrollkästchen standardgemäß aktiviert.

  5. Wenn Sie die gewünschten Einstellungen vorgenommen haben, wählen Sie OK aus.

  6. Überprüfen Sie die Statusinformationen im Fenster Benutzer für Verwaltungskonsole hinzufügen.

  7. (Optional) Wählen Sie nach Abschluss des Prozesses den Link aus, um die Protokolldatei zu öffnen.

  8. Wählen Sie Schließen, um zur Verwaltungskonsole zurückzukehren.

    Wichtiger Hinweis Wichtig

    Sie können der lokalen Gruppe Administratoren keinen Benutzer hinzufügen, indem Sie das Konto dieses Benutzers als Konsolenbenutzer hinzufügen. Der Benutzer verfügt erst dann über alle Berechtigungen, die zum Öffnen und Verwenden der Konsole erforderlich sind, wenn Sie ihn manuell dieser Gruppe hinzugefügt haben. Wenn der Benutzer außerdem über ausreichende Berechtigungen zum Erstellen einer Datenbank als Teil einer Teamprojektsammlung verfügen soll, müssen Sie diesem Benutzer die Mitgliedschaft in der Rolle serveradmin in SQL Server gewähren.

So gewähren Sie Administratorberechtigungen in SharePoint Foundation 2010

  1. Öffnen Sie auf dem Server, auf dem SharePoint-Produkte ausgeführt wird, die SharePoint-Zentraladministration.

    Weitere Informationen finden Sie unter Access Site Administration or Central Administration for SharePoint Products.

  2. Gewähren Sie entsprechend den Sicherheitsanforderungen auf der Farm- oder Webanwendungsebene geeignete Berechtigungen für diesen Benutzer.

    Weitere Informationen finden Sie unter Windows SharePoint Services Roles und auf der Microsoft-Website im SharePoint-Produkte-TechCenter (möglicherweise in englischer Sprache). Für optimale Interoperabilität können Benutzer in der Gruppe Team Foundation-Administratoren den folgenden Gruppen in SharePoint-Produkte hinzugefügt werden:

    • Farm-Administratoren

    • Gruppe Websitesammlungsadministratoren für alle von der Team Foundation Server-Bereitstellung verwendeten Websitesammlungen

So gewähren Sie Administratorberechtigungen in Reporting Services

  1. Öffnen Sie Internet Explorer.

    Hinweis Hinweis

    Selbst wenn Sie mit Administratorrechten angemeldet sind, müssen Sie Internet Explorer als Administrator starten, um diese Funktion auf einem Computer auszuführen, auf dem Windows Server 2008 oder Windows Vista ausgeführt wird. Wählen Sie zum Starten von Internet Explorer als Administrator Start, wählen Sie Alle Programme, öffnen Sie das Untermenü für Internet Explorer, und wählen Sie dann Als Administrator ausführen. Weitere Informationen finden Sie im folgenden Thema auf der Microsoft-Website: Benutzerkontensteuerung.

  2. Geben Sie in der Adressleiste die folgende URL ein, wobei ReportServer der Name des Servers ist, auf dem Reporting Services ausgeführt wird: http:// ReportServer/Reports/Pages/Folder.aspx

    Wichtiger Hinweis Wichtig

    Wenn Sie eine benannte Instanz verwenden, muss der Pfad zu den Berichten den entsprechenden Namen enthalten. Verwenden Sie folgende Syntax, wobei ReportServer für den Namen des Team Foundation-Berichtsservers und Instanzname für den Namen der SQL Server-Instanz steht: http://ReportServer/Reports_Instanzname/Pages/Folder.aspx

  3. Wählen Sie auf der Startseite die Option Ordnereinstellungen aus.

  4. Wählen Sie auf der Seite Sicherheit die Option Neue Rollenzuweisung aus.

  5. Geben Sie auf der Seite Neue Rollenzuweisung unter Gruppen- oder Benutzername den Kontonamen des Benutzers oder der Gruppe an, dem bzw. der Sie Administratorberechtigungen gewähren möchten.

  6. Aktivieren Sie unter Rolle das Kontrollkästchen Team Foundation-Inhalts-Manager, und wählen Sie dann OK aus.

Siehe auch

Aufgaben

Hinzufügen von Benutzern zu Teamprojekten

Konzepte

Team Foundation Server-Berechtigungen
Team Foundation Server: Standardgruppen, Berechtigungen und Rollen
Konfigurieren von Benutzern, Gruppen und Berechtigungen


Verwalten von Berechtigungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten von Berechtigungen
Feedback senden

Sie können Berechtigungen für Benutzer und Gruppen in Visual Studio Team Foundation Server (TFS) hinzufügen, ändern oder entfernen. Berechtigungen in TFS können explizit festgelegt werden, und sie können abhängig von der Mitgliedschaft eines Benutzers in bestimmten Gruppen in jeder der vier Berechtigungsstufen ebenfalls geerbt werden: die Teamebene, die Projektebene, die Auflistungs- und die Serverebene. Sie können die expliziten und die impliziten Berechtigungen für jeden Benutzer oder jede Gruppe in TFS anzeigen, und Sie können Berechtigungen für Benutzer und Gruppen auf allen Ebenen, mit Ausnahme der Teamebene, ändern. Berechtigungen auf Teamebene werden nach der Mitgliedschaft innerhalb des Teams bestimmt und können nicht manuell festgelegt oder geändert werden.

Wenn Sie einen Benutzer oder eine Gruppe zu TFS hinzufügen, müssen Sie diesen Benutzer bzw. diese Gruppe ggf. auch zu zwei weiteren Komponenten hinzufügen, von denen die Bereitstellung abhängen kann: SharePoint-Produkte und SQL Server Reporting Services. Wenn diese Ressourcen in der Bereitstellung konfiguriert sind, müssen Sie Benutzer und Gruppen zu diesen Programmen hinzufügen und diesen die entsprechenden Berechtigungen erteilen, damit sämtliche Vorgänge in TFS ordnungsgemäß ausgeführt werden.

Aufgrund dieser Komplexität ist es möglicherweise schwierig, einzelne Benutzer und ihre Berechtigungen in Bereitstellungen von TFS zu verwalten. Es ist viel einfacher, Active Directory zu verwenden, um Benutzer in rollenbasierten Gruppen zusammenzufassen und dann jede Gruppe mit den entsprechenden Berechtigungen TFS, SharePoint-Produkte und Reporting Services hinzuzufügen. Bei diesem Ansatz können anstelle von vielen einzelnen Benutzern nur wenige Gruppen in diesen drei Programmen verwaltet werden. Sie können Active Directory-Gruppen nach Bedarf Benutzer hinzufügen, ohne in den drei Programmen Gruppenmitgliedschaft oder Berechtigungen ändern zu müssen. Hier finden Sie ein entsprechendes Beispiel: Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams.

Als Administrator steuern Sie mithilfe von Gruppenmitgliedschaften und Berechtigungen, welche Aufgaben Benutzer ausführen können. Um diese Aufgabe zu vereinfachen, stellt Team Foundation Standardeinstellungen für Gruppen und Berechtigungen bereit. Sie können die Standardgruppen und -einstellungen unverändert übernehmen oder anpassen, oder Sie erstellen eigene Gruppen. Die Themen in diesem Abschnitt enthalten Detailinformationen zu Berechtigungen.

In Visual Studio Team Foundation Server 2012 können Sie die neuen Funktionen in Team Web Access verwenden, um die Berechtigungen für Benutzer und Gruppen auf Projekt- und Auflistungsebene anzeigen und verwalten zu können. Dies schließt die Möglichkeit ein, geerbte und explizit festgelegte Berechtigungen schnell anzuzeigen und die Mitgliedschaft eines Benutzers in Gruppen anzuzeigen:

Berechtigungen in Team Web Access

Sie müssen den Zugriff auf Team Web Access-Funktionen auch im Verwaltungskontext von Team Web Access konfigurieren:

Zugriffsgruppen für Team Web Access

Sie müssen die Verwaltungskonsole für Team Foundation verwenden, um Berechtigungen auf Serverebene für Benutzer, Gruppen und Dienstkonten anzuzeigen und zu verwalten.

In diesem Abschnitt

Team Foundation Server-Berechtigungen

Dieser Abschnitt enthält eine Beschreibung des Berechtigungsmodells für TFS sowie der einzelnen Berechtigungen, die Sie für Benutzer und Gruppen festlegen können.

Team Foundation Server: Standardgruppen, Berechtigungen und Rollen

In diesem Abschnitt werden die Gruppen und Berechtigungen beschrieben, die standardmäßig erstellt werden, wenn Sie TFS installieren oder ein Teamprojekt erstellen - einschließlich der Berechtigungen, die diesen Gruppen standardmäßig zugewiesen werden.

Ändern der Berechtigungen für eine Gruppe oder einen Benutzer

Beschreibt, wie Sie die Berechtigungen für eine Gruppe in TFS oder für ein einzelnes Benutzerkonto, das TFS direkt hinzugefügt wurde, ändern.

Ansichtsberechtigungen

Beschreibt, wie Sie Berechtigungen für Benutzer und Gruppen auf Server- oder Projektebene anzeigen.

Hinzufügen von Benutzern zu Teamprojekten

Beschreibt, wie Sie Benutzer zu Standardgruppen in TFS, SharePoint-Produkte und Reporting Services hinzufügen und diesen die erforderlichen Berechtigungen erteilen, um als Leser, Mitwirkende oder Administratoren in dem Projekt zu fungieren.

Festlegen von Administratorberechtigungen für Teamprojektsammlungen

Beschreibt, wie Sie Benutzer zu Standardgruppen in TFS, SharePoint-Produkte und Reporting Services hinzufügen und diesen die erforderlichen Berechtigungen erteilen, um eine Teamprojektsammlung zu verwalten.

Festlegen von Administratorberechtigungen für Team Foundation Server

Beschreibt, wie Sie Benutzer zu Standardgruppen in TFS, SharePoint-Produkte und Reporting Services hinzufügen und diesen die erforderlichen Berechtigungen erteilen, um TFS zu verwalten.

Zugriff auf Funktionen über Webberechtigungen

Beschreibt, wie die Standardebene der in Team Web Access verfügbaren Funktionen festgelegt wird, wie Gruppen Funktionsebenen hinzugefügt und aus diesen entfernt werden, und wie die Verwendung überwacht wird.

Verwandte Abschnitte

Konfigurieren von Team Foundation Server zur Unterstützung des Entwicklungsteams

Erste Schritte im Team

Konfigurieren von Benutzern, Gruppen und Berechtigungen

Team Foundation Server-Dienste und -Dienstkonten

How to: Control Access to Team Foundation Version Control

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Organisieren des Servers mit Teamprojektsammlungen

Architektur von Team Foundation Server

Team Foundation Server-Konzepte


Team Foundation Server-Berechtigungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Team Foundation Server-Berechtigungen
Siehe auch Feedback senden

Sie können den Zugriff auf die Teamprojekte und Teamprojektsammlungen in der Bereitstellung von Visual Studio Team Foundation Server (TFS) steuern, indem Sie sich mit den Berechtigungen, die den Benutzern und Gruppen in dieser Bereitstellung zugewiesen werden, vertraut machen und diese konfigurieren. Team Foundation Server enthält verschiedene Hilfsprogramme zum Anzeigen und Verwalten von Berechtigungen. Verwenden Sie für einzelne Benutzer und Gruppen Team Web Access, indem Sie die Prozeduren in View or change your permissions or join another team ausführen, oder verwenden Sie Team Explorer, indem Sie die Prozeduren in Ändern der Berechtigungen für eine Gruppe oder einen Benutzer befolgen. Sie können diese Tools auch verwenden, um Benutzern den Zugriff auf Teamprojekte zu verweigern. Weitere Informationen finden Sie unter Restricting access to projects in the deployment.

Hinweis Hinweis

Die Berechtigungen für Reporting Services für SharePoint-Produkte oder SQL Server werden hier nicht erläutert. In diesem Thema werden ausschließlich in TFS festgelegte Berechtigungen beschrieben. Weitere Informationen zum Festlegen von Berechtigungen in Reporting Services und SharePoint-Produkte für Benutzer in TFS finden Sie unter Hinzufügen von Benutzern zu Teamprojekten, Festlegen von Administratorberechtigungen für Teamprojektsammlungen und Festlegen von Administratorberechtigungen für Team Foundation Server.

In diesem Thema

  • Neues bei Berechtigungen

  • Überblick über die Gruppen mit Standardberechtigungen

  • Berechtigungszustände

    • Verweigern

    • Zulassen

    • Nicht festgelegt

  • Vererbung

  • Festlegen von Berechtigungen

    • Berechtigungen auf Serverebene

    • Berechtigungen auf Auflistungsebene

    • Berechtigungen auf Projektebene

    • Berechtigungen auf Buildebene

    • Arbeitsaufgabenabfrage-Berechtigungen

    • Berechtigungen auf Bereichsebene für die Arbeitsaufgabennachverfolgung

    • Berechtigungen auf Iterationsebene für die Arbeitsaufgabenverfolgung

    • Berechtigungen für die Versionskontrolle

    • Berechtigungen für Lab Management

Neues bei Berechtigungen

In dieser Version von Team Foundation Server wurde die Verwaltungsschnittstelle für Berechtigungen größtenteils auf Team Web Access verschoben. Sie können Team Web Access im Verwaltungskontext öffnen und Berechtigungen auf allen Ebenen, mit Ausnahme der Serverebene, anzeigen und verwalten. Außerdem können Sie Informationen dazu anzeigen, warum und wie eine einzelne Berechtigung für einen Benutzer oder eine Gruppe festgelegt wurde, indem Sie auf die entsprechende Berechtigung zeigen und Warum? auswählen.

Diese Version von Team Foundation Server enthält auch die Erstellung einer Standard-Teamgruppe, wenn Sie ein Teamprojekt erstellen. Auch wenn Teamgruppen selbst nicht über manuell konfigurierbare Berechtigungen verfügen, ist die Mitgliedschaft in dieser Gruppe für Benutzer, die Team-Funktionen im Team Web Access verwenden, erforderlich. Darüber hinaus wird diese Standard-Teamgruppe automatisch zur Standardgruppe Mitwirkende für das Projekt hinzugefügt. Wenn Sie keine Änderungen vornehmen, verfügen alle Benutzer, die dem Team hinzugefügt werden, über alle Berechtigungen, die der Gruppe "Mitwirkende" erteilt wurden.

Team Web Access verfügt über neue Steuerelemente zum Anzeigen der Funktionen, die für Benutzer verfügbar sind, und über die Mitgliedschaft in den Zugriffsgruppen für Team Web Access wird gesteuert, ob ein Benutzer diese Steuerelemente anzeigen und verwenden kann. Sie können Zugriffsebenen für Gruppen und Benutzer sowie die Standardebene für die gesamte TFS-Bereitstellung festgelegen. Weitere Informationen finden Sie unter Zugriff auf Funktionen über Webberechtigungen.

Überblick über die Gruppen mit Standardberechtigung

Die Autorisierungen für Benutzeraktionen wie Arbeitsbereichsverwaltung und Projekterstellung werden durch Berechtigungen festgelegt. Wenn Sie in TFS ein Projekt erstellen, werden unabhängig von der ausgewählten Prozessvorlage für dieses Projekt fünf Standardgruppen erstellt. Jede dieser Gruppen verfügt standardmäßig über eine Reihe von Berechtigungen, die für sie definiert wurden. Durch diese Berechtigungen wird festgelegt, welche Aufgaben die Mitglieder dieser Gruppen ausführen dürfen.

  • Projektadministratoren

  • Mitwirkende

  • Leser

  • Buildadministratoren

  • Die standardmäßige Teamgruppe mit dem Namen des Projekts, dem "Team" angehängt wird. Wenn Sie beispielsweise ein Teamprojekt mit dem Namen "Codebeispiel" erstellen, lautet der Gruppenname für das Team "Codebeispiel-Team".

Zusätzlich zu den Standardgruppen, die beim Erstellen einer Teamprojektsammlung für jedes Teamprojekt erstellt werden, werden unabhängig von der ausgewählten Prozessvorlage sieben Standardgruppen für diese Auflistung erstellt. Jede dieser Gruppen verfügt über eine Reihe von Berechtigungen, die für sie definiert werden.

  • Projektauflistungsadministratoren

  • Dienstkonten für die Projektauflistung

  • Projektauflistungsbuild-Administratoren

  • Builddienstkonten für die Projektauflistung

  • Gültige Benutzer für Projektauflistung

  • Proxydienstkonten für die Projektauflistung

  • Testdienstkonten für die Projektauflistung

Bei der Installation von Team Foundation Server werden vier Gruppen auf Serverebene erstellt. Jede dieser Gruppen verfügt über eine Reihe von Berechtigungen, die für sie definiert werden.

  • Team Foundation-Administratoren

  • Team Foundation-Dienstkonten

  • Gültige Team Foundation-Benutzer

  • SharePoint-Webanwendungsdienste

Um die Benutzermitgliedschaft in diesen Standardgruppen auf effektive Weise zu verwalten und benutzerdefinierte Gruppen zu erstellen, müssen Sie sich zunächst mit der Bedeutung der Berechtigungen und den Auswirkungen der expliziten Festlegung von Berechtigungen auf die Sicherheit vertraut machen. Weitere Informationen darüber, welche Berechtigungen standardmäßig jeder Gruppe zugewiesen sind, finden Sie unter Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Tipp Tipp

Bestimmte Funktionen in TFS sind nur für jene Benutzer verfügbar, die über die entsprechende Lizenzierung für derartige Funktionen verfügen. Der Zugriff auf diese Funktionen wird nicht über Berechtigungen sondern durch die Mitgliedschaft in den Lizenzierungsgruppen für Team Web Access gesteuert. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zu Teamprojekten, Zugriff auf Funktionen über Webberechtigungen und im Lizenzierungswhitepaper für Team Foundation Server.

Berechtigungszustände

Sie können zwei explizite Autorisierungszustände für Berechtigungen in Team Foundation Server festlegen: Verweigern und Zulassen. Weiterhin ist eine implizite Autorisierung verfügbar, mit der die Berechtigung weder auf Zulassen noch auf Verweigern festgelegt wird. Diese Autorisierung ist ein impliziter Verweigern-Zustand, der als Nicht Festgelegt bezeichnet wird.

Verweigern

Durch die Einstellung "Verweigern" wird dem Benutzer oder der Gruppe die Berechtigung zum Ausführen der Aktionen verweigert, die in der Berechtigungsbeschreibung aufgeführt werden. Verweigern ist der Berechtigungszustand mit höchster Priorität in TFS. Wenn ein Benutzer zu einer TFS-Gruppe gehört, für die eine bestimmte Berechtigung auf Verweigern festgelegt ist, kann der Benutzer diese Funktion nicht anwenden. Dies ist auch dann der Fall, wenn der Benutzer zu einer anderen Gruppe gehört, für die diese Berechtigung auf Zulassen festgelegt ist. Die einzige Ausnahme von dieser Regel sind Benutzer, die Mitglied der Gruppe Projektauflistungsadministratoren für eine Teamprojektauflistung oder Mitglied der Gruppe Team Foundation-Administratoren sind. Wenn ein Benutzer Mitglied der Gruppe "Projektauflistungsadministratoren" ist, werden für diesen Benutzer die Autorisierungseinstellungen, die in der Auflistung explizit auf "Verweigern" festgelegt sind, durch die Berechtigungen dieser Gruppe überschrieben. Für Mitglieder der Gruppe "Team Foundation-Administratoren" werden Autorisierungseinstellungen, die für diese Benutzer in Team Foundation Server explizit auf "Verweigern" festgelegt sind, durch die Berechtigungen dieser Gruppe überschrieben.

Zulassen

Durch die Einstellung "Zulassen" wird dem Benutzer oder der Gruppe die Berechtigung zum Ausführen der Aktionen erteilt, die in der Berechtigungsbeschreibung aufgeführt werden. Die Option zum "Zulassen" stellt jenen Berechtigungszustand mit der zweithöchsten Priorität in TFS dar und wird häufig, sowohl explizit als auch durch Vererbung, auf Geerbte Zulassung festgelegt. Wenn Sie eine Berechtigung nicht explizit auf Zulassen festlegen, oder die Mitgliedschaft in einer Standardgruppe eine Berechtigung nicht auf Geerbte Zulassung festlegt, können Benutzer oder Gruppen diese Aktion in Team Foundation Server nicht ausführen.

Nicht festgelegt

Standardmäßig sind die meisten Berechtigungen in TFS weder auf Verweigern noch auf Zulassen festgelegt. Die Berechtigungen werden als nicht festgelegt beibehalten, wodurch sowohl den Benutzern als auch den Gruppen die Berechtigung zum Ausführen der Aktionen gemäß der Berechtigungsbeschreibung implizit verweigert wird. Da die Berechtigung jedoch weder explizit auf Verweigern noch explizit auf Zulassen festgelegt ist, kann die Autorisierung für diese Berechtigung aus anderen Gruppen übernommen werden, in denen der Benutzer oder die Gruppe Mitglied ist.

Vererbung

Wenn eine Berechtigung für einen Benutzer oder eine Gruppe nicht festgelegt ist, kann für den Benutzer oder die Gruppe der explizite Zustand für die Berechtigung der Gruppen gelten, in denen er bzw. sie Mitglied ist, da Berechtigungen in TFS vererbbar sind. Wenn Sie beispielsweise die Berechtigungen für einen Benutzer oder eine Gruppe überprüfen, stellen Sie möglicherweise fest, dass sowohl Zulassen als auch Geerbte Zulassung für Berechtigungen festgelegt ist. Die letzte Berechtigung wird von einer anderen Gruppe geerbt, zu der der Benutzer oder die Gruppe gehört. In diesem Beispiel gehört ein Benutzer möglicherweise zu einer Gruppe auf Projektebene und zu einer Gruppe auf Auflistungsebene in einem Projekt. Wenn eine dieser Gruppen über eine Berechtigung verfügt, die explizit auf Zulassen festgelegt ist, und die gleiche Berechtigung in der anderen Gruppe Nicht festgelegt ist, verfügt der Benutzer über die Berechtigung Geerbte Zulassung, um die durch diese Berechtigung gesteuerten Aktionen auszuführen. Der Benutzer übernimmt die Berechtigungen aus beiden Gruppen, und die Berechtigung Zulassen hat Vorrang gegenüber der Berechtigung Nicht festgelegt.

Um zu verstehen, warum eine Berechtigung geerbt wird, können Sie mit der Maus auf die Berechtigungseinstellung zeigen und dann Warum? auswählen. Ein neues Fenster wird geöffnet, in dem die Vererbungsinformationen für diese Berechtigung anzeigt werden.

Berechtigungen in Team Web Access
Hinweis Hinweis

Berechtigungen, die außerhalb von TFS festgelegt werden, z. B. in SharePoint-Produkte, werden in TFS nicht übernommen. Diese Berechtigungen werden in diesem Thema nicht erläutert.

Bestimmte Autorisierungseinstellungen haben Vorrang gegenüber anderen Autorisierungseinstellungen. In TFS hat die Berechtigung Verweigern Vorrang gegenüber allen anderen Berechtigungseinstellungen, einschließlich Zulassen, für diese explizite Struktur. Die Berechtigung Verweigern hat keinen Vorrang, wenn sie von einem hierarchisch übergeordneten Element übernommen wurde, z. B. in der Versionskontrolle. Angenommen, ein Benutzer gehört zu zwei Gruppen in einem Projekt. Für eine Gruppe ist die Berechtigung Testergebnisse veröffentlichen auf Verweigern festgelegt, für die andere Gruppe auf Zulassen. Die Einstellung Verweigern hat Vorrang, und der Benutzer ist somit nicht zum Veröffentlichen von Testergebnissen autorisiert. Die einzigen Ausnahmen von dieser Regel bestehen, wenn die explizite Berechtigung Verweigern entweder von einem hierarchisch übergeordneten Element übernommen wurde oder wenn der Benutzer Mitglied in einer der folgenden Gruppen ist:

  • Projektadministratoren

  • Projektauflistungsadministratoren

  • Team Foundation-Administratoren

In hierarchischen Strukturen wie der Versionskontrolle und Arbeitsaufgabenverfolgung überschreiben die expliziten Berechtigungen, die für ein bestimmtes Objekt festgelegt werden, die von übergeordneten Objekten übernommenen Berechtigungen.

Festlegen von Berechtigungen

Viele der Berechtigungen, die Sie ggf. für TFS festlegen möchten, werden über die Team Web Access-Benutzeroberfläche gesteuert, die Sie direkt über Team Web Access oder auch über Team Explorer öffnen können. Sie können diese Berechtigungen auf Auflistungsbasis (Berechtigungen auf Auflistungsebene), auf Projektbasis (Berechtigungen auf Projektebene) oder durch Hinzufügen eines Benutzers zu einer Teamgruppe auf Teambasis festlegen. (Team-Ebenen-Berechtigungen sind in der Mitgliedschaft für ein Team eingeschlossen und können nicht direkt konfiguriert werden.) Zudem können Sie Berechtigungen auf Bereichs- und Iterationsebene zum Anzeigen und Interagieren mit Arbeitsaufgaben auf Projektbasis festlegen. Weitere Informationen über das Festlegen von Berechtigungen für Benutzer und Gruppen finden Sie unter Erste Schritte im Team und Hinzufügen von Benutzern zu Teamprojekten.

Zum Festlegen von Berechtigungen auf Serverbasis (Berechtigungen auf Serverebene) können Sie Team Web Access nicht verwenden. Sie müssen die Verwaltungskonsole für Team Foundation Server verwenden, um Berechtigungen auf Serverebene festzulegen.

Berechtigungen auf Serverebene

Berechtigungen auf Serverebene sind nicht für ein bestimmtes Teamprojekt oder eine bestimmte Teamprojektsammlung spezifisch. Sie werden für die gesamte Bereitstellung festgelegt und können sich auf alle Projekte und Auflistungen in der Bereitstellung auswirken.

Sie können diese Berechtigungen nur für drei Kategorien von Benutzern festlegen:

  • Benutzer und Gruppen auf Serverebene, z. B. Team Foundation-Administratoren

  • Benutzerdefinierte Gruppen, die Sie erstellen und der Serverebene hinzufügen

Sie können diese Berechtigungen festlegen, indem Sie die Verwaltungskonsole für Team Foundation öffnen. Darüber hinaus können Sie diese Berechtigungen mithilfe des TFSSecurity-Befehlszeilentools festlegen. Weitere Informationen finden Sie unter Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole und Ändern von Gruppen und Berechtigungen mit TFSSecurity.

In der folgenden Tabelle sind alle Berechtigung auf Serverebene mit einer kurzen Beschreibung des jeweiligen Zwecks aufgeführt.

Berechtigungsname

Name in der Befehlszeile

Beschreibung

Warehouse verwalten

ADMINISTER_WAREHOUSE

Benutzer mit dieser Berechtigung können Warehouseeinstellungen mithilfe der ChangeSetting-Webmethode des Webdiensts WarehouseController.asmx ändern. Zum Beispiel können Sie zulassen, dass Benutzer das Aktualisierungsintervall zum Berechnen der OLAP-Cubes festlegen.

Teamprojektsammlung erstellen

CreateCollection

Benutzer mit dieser Berechtigung können Teamprojektsammlungen in Team Foundation Server erstellen und verwalten.

Teamprojektsammlung löschen

DeleteCollection

Benutzer mit dieser Berechtigung können eine Teamprojektsammlung aus der Bereitstellung löschen.

Hinweis Hinweis

Durch das Löschen einer Teamprojektsammlung wird nicht die Datenbank für die Auflistung aus SQL Server gelöscht.

Instanzebeneninformationen bearbeiten

GENERIC_WRITE

tf: AdminConfiguration

tf: AdminConnections

Benutzer mit dieser Berechtigung können Berechtigungen auf Serverebene für Benutzer und Gruppen in Team Foundation Server bearbeiten. Sie können Anwendungsgruppen auf Serverebene zu der Auflistung hinzufügen bzw. aus dieser entfernen. Durch Erteilen der Berechtigung Instanzebeneninformation bearbeiten in allen Menüs erhält der Benutzer implizit die Berechtigung zum Ändern von Versionskontrollberechtigungen. Um alle diese Berechtigungen über die Befehlszeile zu erteilen, müssen Sie mit dem Befehl tf.exe Permission die AdminConfiguration-Berechtigung, die AdminConnections-Berechtigung sowie GENERIC_WRITE gewähren.

Hinweis Standardgruppen auf Serverebene, wie Team Foundation-Administratoren, können nicht gelöscht werden.

Anforderungen im Auftrag von anderen Benutzern einreichen

Identitätswechsel

Benutzer mit dieser Berechtigung können Vorgänge im Namen anderer Benutzer oder Dienste ausführen. Diese Berechtigung darf nur Dienstkonten zugewiesen werden.

Triggerereignisse

TRIGGER_EVENT

Benutzer mit dieser Berechtigung können Warnungsereignisse in Team Foundation Server auslösen. Diese Berechtigung sollte ausschließlich Dienstkonten und Mitgliedern der Gruppe "Team Foundation-Administratoren" zugewiesen werden.

Funktionen für uneingeschränkten Webzugriff verwenden

FullAccess

Benutzer mit dieser Berechtigung können alle Funktionen von Team Web Access verwenden.

Instanzebeneninformationen anzeigen

GENERIC_READ

Benutzer mit dieser Berechtigung können die Gruppenmitgliedschaften auf Serverebene und die Berechtigungen der entsprechenden Benutzer anzeigen.

Berechtigungen auf Auflistungsebene

Berechtigungen auf Auflistungsebene sind nicht projektspezifisch. Diese Berechtigungen werden auf einer auflistungsweiten Basis festgelegt. Sie können diese Berechtigungen nur für drei Kategorien von Benutzern festlegen:

  • Benutzer und Gruppen auf Auflistungsebene, z. B. Projektauflistungsadministratoren

  • Gruppen auf Projektebene, die auf dem Server, auf dem Team Foundation ausgeführt wird, zur Auflistungsebene hinzugefügt wurden

  • Benutzerdefinierte Gruppen, die Sie erstellen und zur Auflistungsebene hinzufügen

Sie können diese Berechtigungen festlegen, indem Sie die Auflistung in Team Explorer auswählen und auf das Menü Team klicken. Wählen Sie dann Teamprojekt-Auflistungseinstellungen und Sicherheit aus, oder öffnen Sie Team Web Access im Verwaltungsmodus, navigieren Sie zur Auflistungsebene, und wählen Sie dann die Registerkarte Sicherheit aus. Sie können auch das TFSSecurity-Befehlszeilentool verwenden, sofern es sich nicht um ein Befehlszeilentool mit der Bezeichnung tf: handelt. Verwenden Sie für Tools mit der Bezeichnung tf: den Befehl Permission des tf-Befehlszeilendienstprogramms für die Versionskontrolle, um die Berechtigungen festzulegen. Weitere Informationen finden Sie unter Ändern von Gruppen und Berechtigungen mit TFSSecurity und Permission Command.

Berechtigungsname

Name in der Befehlszeile

Beschreibung

Berechtigungen für Buildressourcen verwalten

Benutzer mit dieser Berechtigung können Buildressourcen verwalten.

Project Server-Integration verwalten

AdministerProjectServer

Benutzer mit dieser Berechtigung können die Integration von Team Foundation Server in Project Server konfigurieren, um die Synchronisierung zwischen den beiden Serverprodukten zu unterstützen.

Abgelegte Änderungen verwalten

tf: AdminShelvesets

Benutzer mit dieser Berechtigung können von anderen Benutzern erstellte Shelvesets löschen.

Arbeitsbereiche verwalten

tf: AdminWorkspaces

Benutzer mit dieser Berechtigung können Arbeitsbereiche für andere Benutzer erstellen und von anderen Benutzern erstellte Arbeitsbereiche löschen.

Ablaufverfolgungseinstellungen ändern

DIAGNOSTIC_TRACE

Benutzer mit dieser Berechtigung können die Ablaufverfolgungseinstellungen zum Erfassen genauerer Diagnoseinformationen über Webdienste für Team Foundation Server ändern.

Arbeitsbereich erstellen

tf: CreateWorkspace

Benutzer mit dieser Berechtigung können einen Arbeitsbereich der Versionskontrolle erstellen.

Neue Projekte erstellen

CREATE_PROJECTS

Benutzer mit dieser Berechtigung können Projekte in der Teamprojektsammlung erstellen.

Hinweis Hinweis

Sie müssen nicht nur über diese Berechtigung verfügen, sondern Visual Studio außerdem als Administrator ausführen, damit der Assistent für neue Teamprojekte erfolgreich abgeschlossen wird. Weitere Informationen finden Sie unter Erstellen eines Teamprojekts.

Teamprojekt löschen

Delete

Benutzer mit dieser Berechtigung können Teamprojekte aus der Teamprojektsammlung löschen.

Wichtiger Hinweis Wichtig

Durch das Löschen eines Teamprojekts werden alle mit dem Projekt verbundenen Daten entfernt. Sie können das Löschen eines Teamprojekts nur rückgängig machen, indem Sie die Auflistung auf einen Zeitpunkt vor dem Löschen des Projekts zurücksetzen.

Informationen auf Auflistungsebene bearbeiten

GENERIC_WRITE

tf: AdminConfiguration

tf: AdminConnections

Benutzer mit dieser Berechtigung können Berechtigungen auf Auflistungsebene für Benutzer und Gruppen in der Teamprojektsammlung bearbeiten. Sie können Team Foundation Server-Anwendungsgruppen auf Auflistungsebene zu der Auflistung hinzufügen bzw. aus dieser entfernen. Durch Erteilen der Berechtigung Information auf Auflistungsebene bearbeiten in allen Menüs erhält der Benutzer implizit die Berechtigung zum Ändern von Versionskontrollberechtigungen. Um alle diese Berechtigungen über die Befehlszeile zu erteilen, müssen Sie mit dem Befehl tf.exe Permission die AdminConfiguration-Berechtigung, die AdminConnections-Berechtigung sowie GENERIC_WRITE gewähren.

Hinweis Hinweis

Standardgruppen auf Auflistungsebene, z. B. die Gruppe "Projektauflistungsadministratoren", können nicht entfernt werden.

Anforderungen im Auftrag von anderen Benutzern einreichen

Identitätswechsel

Benutzer mit dieser Berechtigung können Vorgänge im Namen anderer Benutzer oder Dienste ausführen. Diese Berechtigung darf nur Dienstkonten zugewiesen werden.

Buildressourcen verwalten

ManageBuildResources

Benutzer mit dieser Berechtigung können die Buildcomputer, Build-Agents und Buildcontroller für die Teamprojektsammlung verwalten. Darüber hinaus können diese Benutzer anderen Benutzern die Berechtigungen Buildressourcen anzeigen und Buildressourcen verwenden erteilen oder verweigern.

Prozessvorlage verwalten

MANAGE_TEMPLATE

Benutzer mit dieser Berechtigung können Prozessvorlagen herunterladen, erstellen, bearbeiten und in die Teamprojektsammlung hochladen.

Testcontroller verwalten

MANAGE_TEST_CONTROLLERS

Benutzer mit dieser Berechtigung Testcontroller für die Teamprojektsammlung registrieren und deren Registrierung aufheben.

Linktypen für Arbeitsaufgaben verwalten

WORK_ITEM_WRITE

Benutzer mit dieser Berechtigung Linktypen für Arbeitsaufgaben hinzufügen, entfernen und ändern.

Triggerereignisse

TRIGGER_EVENT

Benutzer mit dieser Berechtigung können Projektwarnungsereignisse innerhalb der Teamprojektsammlung auslösen. Diese Berechtigung darf nur Dienstkonten zugewiesen werden.

Buildressourcen verwenden

UseBuildResources

Benutzer mit dieser Berechtigung können Build-Agents reservieren und zuordnen. Diese Berechtigung darf nur Dienstkonten für Builddienste zugewiesen werden.

Buildressourcen anzeigen

ViewBuildResources

Benutzer mit dieser Berechtigung können Buildcontroller und Build-Agents anzeigen, die für die Auflistung konfiguriert sind. Um diese Ressourcen zu verwenden, benötigen Sie zusätzliche Berechtigungen.

Informationen auf Auflistungsebene anzeigen

GENERIC_READ

Benutzer mit dieser Berechtigung können die Gruppenmitgliedschaften auf Auflistungsebene und die Berechtigungen der entsprechenden Benutzer anzeigen.

Systemsynchronisierungsinformationen anzeigen

SYNCHRONIZE_READ

Benutzer mit dieser Berechtigung können die Synchronisierungsanwendungsprogrammierschnittstellen aufrufen. Diese Berechtigung darf nur Dienstkonten zugewiesen werden.

Berechtigungen auf Projektebene

Berechtigungen auf Projektebene sind an die Benutzer und Gruppen eines einzelnen Projekts gebunden. Sie können diese Berechtigungen festlegen, indem Sie das Projekt in Team Explorer auswählen, auf Einstellungen und dann auf Sicherheit klicken, oder Sie öffnen Team Web Access im Verwaltungsmodus, navigieren zum Projekt, und wählen dann die Registerkarte Sicherheit aus. Darüber hinaus können Sie diese Berechtigungen mithilfe des TFSSecurity-Befehlszeilentools festlegen.

Berechtigungsname | Name in der Befehlszeile | Beschreibung
Testläufe erstellen | PUBLISH_TEST_RESULTS | Benutzer mit dieser Berechtigung können Testergebnisse hinzufügen und entfernen sowie Testläufe für das Teamprojekt hinzufügen oder ändern.
Teamprojekt löschen | DELETE | Benutzer mit dieser Berechtigung können das entsprechende Projekt auf dem Team Foundation Server löschen.
Testläufe löschen | DELETE_TEST_RESULTS | Benutzer mit dieser Berechtigung können einen geplanten Test für dieses Teamprojekt löschen.
Projektebeneninformationen bearbeiten | GENERIC_WRITE | Benutzer mit dieser Berechtigung können Berechtigungen auf Projektebene für Benutzer und Gruppen auf dem Team Foundation Server festlegen.
Testkonfigurationen verwalten | MANAGE_TEST_CONFIGURATIONS | Benutzer mit dieser Berechtigung können Testkonfigurationen für dieses Teamprojekt erstellen und löschen.
Testumgebungen verwalten | MANAGE_TEST_ENVIRONMENTS | Benutzer mit dieser Berechtigung können Testumgebungen für dieses Teamprojekt erstellen und löschen.
Projektebeneninformationen anzeigen | GENERIC_READ | Benutzer mit dieser Berechtigung können die Gruppenmitgliedschaften auf Projektebene und die Berechtigungen der entsprechenden Projektbenutzer anzeigen.
Testläufe anzeigen | VIEW_TEST_RESULTS | Benutzer mit dieser Berechtigung können Testpläne in diesem Knoten anzeigen.

Berechtigungen auf Buildebene

Berechtigungen auf Buildebene sind an die Benutzer und Gruppen eines einzelnen Projekts gebunden. Sie können Buildberechtigungen auf Teamprojektebene oder Berechtigungen für bestimmte Builddefinitionen festlegen. Öffnen Sie zum Festlegen dieser Berechtigungen das Projekt in Team Explorer, wählen Sie Builds, und dann unter Aktionen die Option Sicherheit aus. Sie können Berechtigungen auf eine bestimmte Builddefinition anwenden, indem Sie die Builddefinition und dann Sicherheit auswählen. Wenn Sie Berechtigungen auf einen Buildordner anwenden möchten, wählen Sie den Ordner aus, und wählen Sie dann aus dem Untermenü die Option Sicherheit. Darüber hinaus können Sie diese Berechtigungen mithilfe des TFSSecurity-Befehlszeilentools festlegen.

Berechtigungsname | Name in der Befehlszeile | Beschreibung
Buildberechtigungen verwalten |  | Benutzer mit dieser Berechtigung können die Buildberechtigungen für andere Benutzer verwalten.
Builds anzeigen | ViewBuilds | Benutzer mit dieser Berechtigung können die in der Warteschlange stehenden und abgeschlossenen Builds für dieses Teamprojekt anzeigen.
Buildqualität bearbeiten | EditBuildQuality | Benutzer mit dieser Berechtigung können über die Benutzeroberfläche von Team Foundation Build Informationen zur Qualität des Builds hinzufügen.
Unbegrenzt beibehalten | RetainIndefinitely | Benutzer mit dieser Berechtigung können einen Build kennzeichnen, damit dieser nicht durch eine gültige Beibehaltungsrichtlinie automatisch gelöscht wird.
Builds löschen | DeleteBuilds | Benutzer mit dieser Berechtigung können einen abgeschlossenen Build löschen.
Buildqualität verwalten | ManageBuildQualities | Benutzer mit dieser Berechtigung können Buildqualitäten hinzufügen oder entfernen.
Builds zerstören | DestroyBuilds | Benutzer mit dieser Berechtigung können einen abgeschlossenen Build dauerhaft löschen.
Buildinformationen aktualisieren | UpdateBuildInformation | Benutzer mit dieser Berechtigung können dem System Buildinformationsknoten und auch Informationen zur Qualität eines Builds hinzufügen. Diese Berechtigung darf nur Dienstkonten zugewiesen werden.
Hinzufügen von Builds zur Warteschlange | QueueBuilds | Benutzer mit dieser Berechtigung können über die Benutzeroberfläche von Team Foundation Build oder an einer Eingabeaufforderung einen Build in die Warteschlange stellen. Sie können auch die Builds beenden, die sie in die Warteschlange gestellt haben.
Buildwarteschlange verwalten | ManageBuildQueue | Benutzer mit dieser Berechtigung können in die Warteschlange gestellte Builds abbrechen, verschieben oder deren Priorität ändern.
Builds beenden | StopBuilds | Benutzer mit dieser Berechtigung können jeden ausgeführten Build beenden, darunter auch die Builds, die von einem anderen Benutzer in die Warteschlange gestellt und gestartet werden.
Builddefinition anzeigen | ViewBuildDefinition | Benutzer mit dieser Berechtigung können die Builddefinitionen anzeigen, die für das Teamprojekt erstellt wurden.
Builddefinition bearbeiten | EditBuildDefinition | Benutzer mit dieser Berechtigung können Builddefinitionen für dieses Projekt erstellen und ändern.
Builddefinition löschen | DeleteBuildDefinition | Benutzer mit dieser Berechtigung können Builddefinitionen für dieses Projekt löschen.
Eincheckvalidierung durch Build überschreiben | OverrideBuildCheckInValidation | Benutzer mit dieser Berechtigung können einen Commit für ein Changeset ausführen, das sich auf eine abgegrenzte Builddefinition auswirkt, ohne dass das System zunächst den Code ablegt und die Änderungen erstellt. Diese Berechtigung darf nur Dienstkonten für Builddienste und Buildadministratoren, die für die Qualität des Codes zuständig sind, erteilt werden. Weitere Informationen finden Sie unter Einchecken ausstehender Änderungen für einen abgegrenzten Eincheckbuild.

Arbeitsaufgabenabfrage-Berechtigungen

Arbeitsaufgabenabfrage-Berechtigungen gelten für die Abfragen und Abfrageordner, die Sie erstellen. Außerdem können Sie Berechtigungen für Abfragen und Ordner festlegen, die unter Teamabfragen erstellt werden, um den Zugriff zuzulassen oder zu beschränken. Sie können diese Berechtigungen festlegen, indem Sie das Projekt in Team Explorer auswählen und Arbeitsaufgaben und das Untermenü für die Abfrage oder den Ordner öffnen, für die bzw. für den Sie Berechtigungen festlegen möchten. Klicken Sie dann auf Sicherheit. Sie können diese Berechtigungen auch für die Abfrage in Team Web Access festlegen. Darüber hinaus können Sie diese Berechtigungen mithilfe des TFSSecurity-Befehlszeilentools festlegen.

Berechtigungsname | Name in der Befehlszeile | Beschreibung
Mitwirken | MITWIRKEN | Benutzer mit dieser Berechtigung können diese Abfrage oder den Abfrageordner anzeigen und ändern.
Löschen | ENTF-TASTE | Benutzer mit dieser Berechtigung können eine Abfrage oder einen Abfrageordner und seinen Inhalt löschen.
Berechtigungen verwalten | MANAGEPERMISSIONS | Benutzer mit dieser Berechtigung können die Berechtigungen für diese Abfrage oder den Abfrageordner verwalten.
Lesen | LESEN | Benutzer mit dieser Berechtigung können die Abfrage oder die Abfragen in einem Ordner anzeigen und verwenden, jedoch kann der Inhalt der Abfrage oder der Inhalt des Abfrageordners nicht geändert werden.

Berechtigungen auf Bereichsebene für die Arbeitsaufgabennachverfolgung

Berechtigungen auf Bereichsebene sind an die Benutzer und Gruppen eines einzelnen Projekts gebunden. Sie können diese Berechtigungen festlegen, indem Sie das Projekt in Team Explorer auswählen und dann auf "Einstellungen" und "Arbeitsaufgabenbereiche" klicken. Wählen Sie den Nach-unten-Pfeil und anschließend "Sicherheit" aus, oder öffnen Sie Team Web Access im Verwaltungskontext, navigieren Sie zur Projektebene, wählen Sie die Registerkarte Bereiche und den Nach-unten-Pfeil aus, und klicken Sie dann auf Sicherheit. Darüber hinaus können Sie diese Berechtigungen mithilfe des TFSSecurity-Befehlszeilentools festlegen.

Hinweis Hinweis

Für einige Vorgänge in der Arbeitsaufgabenverfolgung sind mehrere Berechtigungen erforderlich. Zum Beispiel benötigen Sie mehrere Berechtigungen, um einen Knoten zu löschen.

Berechtigungsname | Name in der Befehlszeile | Beschreibung
Erstellen von untergeordneten Knoten | CREATE_CHILDREN | Benutzer mit dieser Berechtigung können Bereichsknoten erstellen. Benutzer mit diesen beiden Berechtigungen und der Berechtigung Diesen Knoten bearbeiten können beliebige untergeordnete Bereichsknoten verschieben und neu anordnen.
Diesen Knoten löschen | ENTFERNEN | Benutzer mit diesen beiden Berechtigungen und der Berechtigung Diesen Knoten bearbeiten für einen anderen Knoten können Bereichsknoten löschen und vorhandene Arbeitsaufgaben aus dem gelöschten Knoten neu klassifizieren. Wenn der gelöschte Knoten über untergeordnete Knoten verfügt, werden diese ebenfalls gelöscht.
Diesen Knoten bearbeiten | GENERIC_WRITE | Benutzer mit dieser Berechtigung können Berechtigungen für diesen Knoten festlegen und Bereichsknoten umbenennen.
Arbeitsaufgaben in diesem Knoten bearbeiten | WORK_ITEM_WRITE | Benutzer mit dieser Berechtigung können Arbeitsaufgaben in diesem Bereichsknoten bearbeiten.
Testplänen verwalten | MANAGE_TEST_PLANS | Benutzer mit dieser Berechtigung können Testpläne für diesen Knoten erstellen und bearbeiten. Wenn Testpläne nicht ausgeführt wurden, können Sie diese auch löschen.
Berechtigungen des Knotens anzeigen | GENERIC_READ | Benutzer mit dieser Berechtigung können die Sicherheitseinstellungen für diesen Knoten anzeigen.
Arbeitsaufgaben in diesem Knoten anzeigen | WORK_ITEM_READ | Benutzer mit dieser Berechtigung können Arbeitsaufgaben in diesem Bereichsknoten zwar anzeigen, aber nicht ändern.

Berechtigungen auf Iterationsebene für die Arbeitsaufgabenverfolgung

Berechtigungen auf Iterationsebene sind an die Benutzer und Gruppen eines einzelnen Projekts gebunden. Sie können diese Berechtigungen festlegen, indem Sie das Projekt in Team Explorer auswählen und dann auf Einstellungen und Arbeitsaufgabeniterationen klicken. Wählen Sie den Nach-unten-Pfeil und anschließend Sicherheit aus, oder öffnen Sie Team Web Access im Verwaltungskontext, navigieren Sie zur Projektebene, wählen Sie die Registerkarte Iterationen und den Nach-unten-Pfeil aus, und klicken Sie dann auf Sicherheit. Darüber hinaus können Sie diese Berechtigungen mithilfe des TFSSecurity-Befehlszeilentools festlegen.

Hinweis Hinweis

Für einige Vorgänge in der Arbeitsaufgabenverfolgung sind mehrere Berechtigungen erforderlich. Zum Beispiel benötigen Sie mehrere Berechtigungen, um einen Knoten zu löschen.

Berechtigungsname | Name in der Befehlszeile | Beschreibung
Erstellen von untergeordneten Knoten | CREATE_CHILDREN | Benutzer mit dieser Berechtigung können Iterationsknoten erstellen. Benutzer mit diesen beiden Berechtigungen und der Berechtigung Diesen Knoten bearbeiten können beliebige untergeordnete Iterationsknoten verschieben und neu anordnen.
Diesen Knoten löschen | ENTFERNEN | Benutzer mit diesen beiden Berechtigungen und der Berechtigung Diesen Knoten bearbeiten für einen anderen Knoten können Iterationsknoten löschen und vorhandene Arbeitsaufgaben aus dem gelöschten Knoten neu klassifizieren. Wenn der gelöschte Knoten über untergeordnete Knoten verfügt, werden diese ebenfalls gelöscht.
Diesen Knoten bearbeiten | GENERIC_WRITE | Benutzer mit dieser Berechtigung können Berechtigungen für diesen Knoten festlegen und Iterationsknoten umbenennen.
Berechtigungen des Knotens anzeigen | GENERIC_READ | Benutzer mit dieser Berechtigung können die Sicherheitseinstellungen für diesen Knoten anzeigen.

Berechtigungen für die Versionskontrolle

Die Berechtigungen der Versionskontrolle sind an Quellcodedateien und Quellcodeordner gebunden. Sie können diese Berechtigungen festlegen, indem Sie das Untermenü für den Ordner oder die Datei im Quellcodeverwaltungs-Explorer öffnen und dann Sicherheit auswählen. Sie können diese Berechtigungen auch mithilfe des tf-Befehlszeilentools für die Versionskontrolle festlegen.

Berechtigungsname

Name in der Befehlszeile

Beschreibung

Lesen

tf: Read

Benutzer mit dieser Berechtigung können den Inhalt einer Datei oder eines Ordners lesen. Benutzer mit der Berechtigung Lesen für einen Ordner können den Inhalt des Ordners und die Eigenschaften der darin enthaltenen Dateien anzeigen. Dies ist auch dann der Fall, wenn der Benutzer nicht über die Berechtigungen zum Öffnen dieser Dateien verfügt.

Auschecken

tf: PendChange

Benutzer mit dieser Berechtigung können Elemente in einem Ordner auschecken und ausstehende Änderungen an den Elementen in einem Ordner vornehmen. Beispiele für ausstehende Änderungen sind u. a. das Hinzufügen, Bearbeiten, Umbenennen, Löschen, Wiederherstellen, Verzweigen und Zusammenführen einer Datei. Ausstehende Änderungen müssen eingecheckt werden, folglich benötigen Benutzer auch die Berechtigung Einchecken, um ihre Änderungen für das Team freigeben.

Einchecken

tf: Checkin

Benutzer mit dieser Berechtigung können Elemente einchecken und alle übernommenen Changesetkommentare überarbeiten. Ausstehende Änderungen werden beim Einchecken übernommen.

Bezeichnung

tf: Label

Benutzer mit dieser Berechtigung können Elemente beschriften.

Sperren

tf: Lock

Benutzer mit dieser Berechtigung können Ordner oder Dateien sperren und entsperren.

Änderungen anderer Benutzer überarbeiten

tf: ReviseOther

Benutzer mit dieser Berechtigung können die Kommentare zu eingecheckten Dateien bearbeiten. Dies ist auch dann möglich, wenn ein anderer Benutzer die Datei eingecheckt hat.

Änderungen anderer Benutzer entsperren

tf: UnlockOther

Benutzer mit dieser Berechtigung können von anderen Benutzern gesperrte Dateien entsperren.

Änderungen anderer Benutzer rückgängig machen

tf: UndoOther

Benutzer mit dieser Berechtigung können eine von einem anderen Benutzer vorgenommene ausstehende Änderung rückgängig machen.

Bezeichnungen verwalten

tf: LabelOther

Benutzer mit dieser Berechtigung können von einem anderen Benutzer erstellte Bezeichnungen bearbeiten oder löschen.

Berechtigungen verwalten

tf: AdminProjectRights

Benutzer mit dieser Berechtigung können die Berechtigungen anderer Benutzer für Ordner und Dateien in der Versionskontrolle verwalten.

Änderungen anderer Benutzer einchecken

tf: CheckinOther

Benutzer mit dieser Berechtigung können von anderen Benutzern vorgenommene Änderungen einchecken. Beim Einchecken werden ausstehende Änderungen übernommen.

Zusammenführen

tf: Merge

Benutzer mit dieser Berechtigung für einen angegebenen Pfad können Änderungen mit diesem Pfad zusammenführen.

Verzweigung verwalten

tf: ManageBranch

Benutzer mit dieser Berechtigung für einen angegebenen Pfad können alle Ordner in diesem Pfad in eine Verzweigung konvertieren. Darüber hinaus können Benutzer mit dieser Berechtigung die folgenden Aktionen für eine Verzweigung ausführen: Bearbeiten der Eigenschaften, Erstellen einer neuen Überordnung und Konvertieren in einen Ordner.

Benutzer mit dieser Berechtigung können diese Verzweigung nur verzweigen, wenn sie auch über die Berechtigung Zusammenführen für den Zielpfad verfügen. Benutzer können keine Verzweigungen aus einer Verzweigung erstellen, für die sie nicht die Berechtigung Verzweigung verwalten haben.

Berechtigungen für Lab Management

Visual Studio Lab Management-Berechtigungen sind für virtuelle Computer, Umgebungen und andere Ressourcen spezifisch. Verwenden Sie zum Festlegen dieser Berechtigungen das TFSLabConfig-Befehlszeilentool.

Berechtigungsname

Name in der Befehlszeile

Beschreibung

Lab-Ressourcen anzeigen

Read

Benutzer mit dieser Berechtigung können Informationen für die verschiedenen Lab Management-Ressourcen anzeigen, einschließlich Informationen zu Auflistungshostgruppen, Projekthostgruppen und Umgebung. Um Informationen zu einer bestimmten Lab-Ressource anzuzeigen, müssen Sie über die Berechtigung Lab-Ressourcen anzeigen für diese Ressource verfügen.

Lab-Speicherorte verwalten

ManageLocation

Benutzer mit dieser Berechtigung können die Speicherorte von Lab Management-Ressourcen bearbeiten, einschließlich der Speicherorte für Sammlungshostgruppen, Sammlungsbibliotheksfreigaben, Projekthostgruppen und Projektbibliotheksfreigaben. Zum Bearbeiten eines bestimmten Speicherorts müssen Sie über die Berechtigung Lab-Speicherorte verwalten für den betreffenden Speicherort verfügen.

Diese Berechtigung für Speicherorte auf Auflistungsebene (Auflistungshostgruppen und Auflistungsbibliotheksfreigaben) ermöglicht Ihnen auch, Speicherorte auf Projektebene (Projekthostgruppen und Projektbibliotheksfreigaben) zu erstellen.

Lab-Speicherorte löschen

DeleteLocation

Benutzer mit dieser Berechtigung können die Speicherorte von Lab Management-Ressourcen löschen, einschließlich der Speicherorte für Auflistungshostgruppen, Auflistungsbibliotheksfreigaben, Projekthostgruppen und Projektbibliotheksfreigaben. Zum Löschen eines Speicherorts müssen Sie über die Berechtigung Lab-Speicherorte löschen für den betreffenden Speicherort verfügen.

Umgebung und virtuelle Computer schreiben

Write

Benutzer mit dieser Berechtigung für eine Projekthostgruppe können Umgebungen erstellen. Benutzer mit dieser Berechtigung für eine Projektbibliotheksfreigabe können Umgebungen und Vorlagen speichern.

Umgebung und virtuelle Computer bearbeiten

Edit

Benutzer mit dieser Berechtigung können Umgebungen und Vorlagen bearbeiten. Die Berechtigung wird für das zu bearbeitende Objekt überprüft.

Umgebung und virtuellen Computer löschen

Delete

Benutzer mit dieser Berechtigung können Umgebungen und Vorlagen löschen. Die Berechtigung wird für das zu löschende Objekt überprüft.

Virtuellen Computer importieren

Create

Benutzer mit dieser Berechtigung können einen virtuellen Computer aus einer VMM-Bibliotheksfreigabe importieren.

Diese Berechtigung unterscheidet sich von "Schreiben", da nur ein Objekt in Lab Management erstellt wird, jedoch nichts in die Virtual Machine Manager-Hostgruppe oder -Bibliotheksfreigabe geschrieben wird.

Berechtigungen verwalten

ManagePermissions

Benutzer mit dieser Berechtigung können die Berechtigungen für ein Lab Management-Objekt ändern. Diese Berechtigung wird für das Objekt überprüft, dessen Berechtigungen geändert werden.

Untergeordnete Berechtigungen verwalten

ManageChildPermissions

Benutzer mit dieser Berechtigung, können die Berechtigungen aller untergeordneten Lab Management-Objekte ändern. Verfügt ein Benutzer beispielsweise über die Berechtigung Untergeordnete Berechtigungen verwalten für eine Teamprojekt-Hostgruppe, kann er die Berechtigungen für alle Umgebungen unterhalb dieser Teamprojekt-Hostgruppe ändern.

Start

Start

Benutzer mit dieser Berechtigung können eine Umgebung starten.

Beenden

Stop

Benutzer mit dieser Berechtigung können eine Umgebung beenden.

Umgebung anhalten

Pause

Benutzer mit dieser Berechtigung können eine Umgebung anhalten.

Momentaufnahmen verwalten

ManageSnapshots

Benutzer mit dieser Berechtigung können alle Verwaltungsaufgaben für Momentaufnahmen einer Umgebung ausführen, u. a. das Erstellen, Wiederherstellen, Umbenennen, Löschen und Lesen von Momentaufnahmen.

Siehe auch

Aufgaben

Öffnen der Team Foundation-Verwaltungskonsole

Konzepte

Erste Schritte im Team
Konfigurieren von Benutzern, Gruppen und Berechtigungen
Konfigurieren von Lab-Management mit TFSLabConfig
Definieren des Testaufwands mit Testplänen

Weitere Ressourcen

Einrichten und Ausführen einer Einzelserverinstallation [Lernprogramm]
Ändern von Gruppen und Berechtigungen mit TFSSecurity
Befehlszeilenreferenz der Team Foundation-Versionskontrolle
Verwalten von Berechtigungen
Ändern von Gruppen und Berechtigungen mit TFSSecurity


Team Foundation Server: Standardgruppen, Berechtigungen und Rollen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Team Foundation Server: Standardgruppen, Berechtigungen und Rollen
Siehe auch Feedback senden

Team Foundation Server umfasst Standardgruppen zum Verwalten von Benutzern und Berechtigungen innerhalb der Bereitstellung. Diese Gruppen werden beim Installieren des Produkts automatisch auf Server- und Auflistungsebene erstellt. Auch wenn Sie ein Projekt in Visual Studio Team Foundation Server erstellen, werden mehrere Gruppen auf verschiedenen Ebenen für dieses Projekt erstellt:

  • Vier Gruppen im Projekt selbst, auf Projektebene

  • Eine Standardteamgruppe, die standardmäßig der Gruppe "Mitwirkende" auf Projektebene hinzugefügt wird

  • Gruppen auf Bereichsebene und auf Iterationsebene für das Projekt

  • Gruppen auf Buildebene für das Teamprojekt

Wenn Sie Lab Management zur Bereitstellung hinzufügen, werden Gruppen für Lab Management hinzugefügt.

Um Projekte besser an Ihre geschäftlichen Anforderungen anzupassen, sollten Sie wissen, welche Berechtigungen bestimmten Benutzern und Gruppen zugewiesen sind und welche Berechtigungen Sie auf Serverebene, Auflistungsebene und Projektebene hinzugefügten Benutzern bzw. Gruppen erteilen möchten. Wenn Sie Benutzer genau auf bestimmte Rollen und Verantwortlichkeiten ausrichten möchten, sollten Sie auch wissen, wie diese Rollen auf die Standardgruppen ausgerichtet werden, die dem Projekt bereits zugewiesen sind. Alternativ können Sie Gruppen erstellen, die jeder dieser Rollen direkt zugeordnet sind, und diesen Gruppen die der Rolle entsprechenden Berechtigungen zuweisen.

In diesem Thema

  • Standardgruppen und -berechtigungen

    • Gruppen und Berechtigungen auf Serverebene

    • Gruppen und Berechtigungen auf Auflistungsebene

    • Gruppen und Berechtigungen auf Projektebene

    • Gruppen und Berechtigungen auf Bereichsebene

    • Gruppen und Berechtigungen auf Iterationsebene

    • Gruppen und Berechtigungen für die Versionskontrolle

    • Gruppen und Berechtigungen auf Build-Ebene

    • Gruppen und Berechtigungen für Lab Management

Standardgruppen und -berechtigungen

Wenn Sie in Team Foundation Server ein Projekt erstellen, werden Gruppen auf Projektebene erstellt. Standardmäßig hat jede dieser Gruppen bestimmte ihr zugewiesene Berechtigungen. Sie können Berechtigungen zu diesen Standardgruppen hinzufügen sowie zu den Gruppen oder Benutzern, die Sie auf Server-, Auflistungs- oder Projektebene hinzufügen möchten.

Gruppen und Berechtigungen auf Serverebene

Wenn Sie Team Foundation Server installieren, sind auf Serverebene standardmäßig die folgenden Gruppen vorhanden:

  • Team Foundation\Team Foundation Administrators Mitglieder dieser Gruppe können alle Vorgänge Team Foundation Server ausführen. Diese Gruppe sollte so wenige Benutzer wie möglich enthalten und nur solche, die die vollständige Kontrolle zur Verwaltung von Team Foundation Server benötigen. Standardmäßig enthält diese Gruppe die Gruppe Lokale Administratoren (BUILTIN\Administratoren) für jeden Server, der die Anwendungsdienste für Team Foundation hostet. Zudem enthält diese Gruppe die Mitglieder der Gruppe Server\Team Foundation Service Accounts und die Mitglieder der Gruppe \Project Server Integration Service Accounts.

  • Team Foundation\Team Foundation Valid Users Die Mitglieder dieser Gruppe können auf Team Foundation Server zugreifen. Diese Gruppe enthält automatisch alle Benutzer und Gruppen, die in Team Foundation Server hinzugefügt wurden. Sie können die Mitgliedschaft dieser Gruppe nicht ändern.

    Wichtiger Hinweis Wichtig

    Wenn Sie die Berechtigung Instanzebeneninformationen anzeigen für diese Gruppe nicht oder auf Verweigern festlegen, können keine Benutzer auf die Bereitstellung zugreifen.

  • Team Foundation\Team Foundation Service Accounts Mitglieder dieser Gruppe verfügen über Berechtigungen auf Dienstebene für Team Foundation Server. Diese Gruppe enthält standardmäßig das während der Installation angegebene Dienstkonto. Diese Gruppe darf nur Dienstkonten enthalten und keine Benutzerkonten oder Gruppen, die Benutzerkonten enthalten. Standardmäßig ist diese Gruppe ein Mitglied der Gruppe Team Foundation-Administratoren.

  • Team Foundation\Project Server Integration Service Accounts Mitglieder dieser Gruppe verfügen über Berechtigungen auf Dienstebene für die Project Server-Bereitstellungen, die für die Interoperation mit Team Foundation Server konfiguriert werden. Darüber hinaus verfügen Mitglieder dieser Gruppe über bestimmte Berechtigungen auf Dienstebene für Team Foundation Server. Diese Gruppe darf nur Dienstkonten enthalten und keine Benutzerkonten oder Gruppen, die Benutzerkonten enthalten. Standardmäßig ist diese Gruppe ein Mitglied der Gruppe Team Foundation-Administratoren.

  • Team Foundation\SharePoint Web Application Services Mitglieder dieser Gruppe verfügen über Berechtigungen auf Dienstebene für die SharePoint-Webanwendungen, die für die Verwendung mit Team Foundation Server konfiguriert sind, sowie über bestimmte Berechtigungen auf Dienstebene für Team Foundation Server. Diese Gruppe darf nur Dienstkonten enthalten und keine Benutzerkonten oder Gruppen, die Benutzerkonten enthalten. Im Gegensatz zur Gruppe "Dienstkonten" ist diese Gruppe kein Mitglied von Team Foundation-Administratoren.

  • Team Foundation\Team Foundation Proxy Service Accounts Mitglieder dieser Gruppe verfügen über Berechtigungen auf Dienstebene für Team Foundation Server Proxy und verfügen über bestimmte Berechtigungen auf Dienstebene für Team Foundation Server. Diese Gruppe darf nur Dienstkonten enthalten und keine Benutzerkonten oder Gruppen, die Benutzerkonten enthalten.

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Wenn nichts anderes angegeben ist, sind die Berechtigung auf Zulassen festgelegt. Vollständige Beschreibungen der einzelnen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Warehouse verwalten | Team Foundation-Administratoren Team Foundation-Dienstkonten | Manuell hinzugefügte Benutzer oder Gruppen, die Warehouse-Einstellungen über die ChangeSetting-Webmethode des WarehouseController.asmx-Webdiensts ändern müssen
Teamprojektsammlung erstellen | Team Foundation-Administratoren Team Foundation-Dienstkonten | Benutzer oder Gruppen, die für das Verwalten der allgemeinen Integrität und Ressourcenverfügbarkeit in der Bereitstellung zuständig sind.
Teamprojektsammlung löschen | Team Foundation-Administratoren Team Foundation-Dienstkonten | Benutzer oder Gruppen, die für das Verwalten der allgemeinen Integrität und Ressourcenverfügbarkeit in der Bereitstellung zuständig sind.
Instanzebeneninformationen bearbeiten | Team Foundation-Administratoren Team Foundation-Dienstkonten | Benutzer oder Gruppen, die für das Verwalten der allgemeinen Integrität und Ressourcenverfügbarkeit in der Bereitstellung zuständig sind.
Anforderungen im Auftrag von anderen Benutzern einreichen | Team Foundation-Dienstkonten SharePoint-Webanwendungsdienste | Diese Berechtigung darf nur Dienstkonten und Gruppen, die ausschließlich Dienstkonten enthalten, zugewiesen werden.
Triggerereignisse | Team Foundation-Administratoren Team Foundation-Dienstkonten | Benutzer oder Gruppen, die für das Verwalten der allgemeinen Integrität und Ressourcenverfügbarkeit in der Bereitstellung zuständig sind.
Funktionen für uneingeschränkten Webzugriff verwenden | Team Foundation-Administratoren Gültige Team Foundation-Benutzer | Benutzer und Gruppen, die den vollen Umfang der in Team Web Access verfügbaren Funktionen benötigen. Wenn Sie Benutzern nur eine schreibgeschützte Ansicht in Team Web Access bereitstellen möchten, müssen Sie diese Berechtigung auf Verweigern festlegen.
Instanzebeneninformationen anzeigen | Team Foundation-Administratoren Team Foundation-Dienstkonten SharePoint-Webanwendungsdienste Gültige Team Foundation-Benutzer | Alle Benutzer oder Gruppen, die mit Team Foundation Server interagieren.

Gruppen und Berechtigungen auf Auflistungsebene

Wenn Sie Team Foundation Server installieren, sind auf Auflistungsebene standardmäßig die folgenden Gruppen vorhanden:

  • Teamprojektsammlung_Name\Project Collection Administrators Mitglieder dieser Gruppe können alle Vorgänge für die betreffende Teamprojektsammlung ausführen. Diese Gruppe sollte so wenige Benutzer wie möglich enthalten und nur solche, die eine umfassende Verwaltungskontrolle über die Auflistung benötigen. Standardmäßig enthält diese Gruppe die Gruppe Lokale Administratoren (BUILTIN\Administratoren) für den Server, auf dem die Dienste auf Anwendungsebene für Team Foundation installiert wurden. Zudem enthält diese Gruppe die Mitglieder der Gruppe TeamProjectCollectionName\Service Accounts.

  • Teamprojektsammlung_Name \Project Collection Valid Users Mitglieder dieser Gruppe verfügen über Zugriff auf die entsprechende Teamprojektsammlung in Team Foundation Server. Diese Gruppe enthält automatisch alle Benutzer und Gruppen, die an einer beliebigen Position in der Teamprojektsammlung hinzugefügt wurden. Sie können die Mitgliedschaft dieser Gruppe nicht ändern.

    Wichtiger Hinweis Wichtig

    Sie dürfen die Berechtigung Auflistungsebeneninformationen anzeigen für diese Gruppe nicht aufheben oder auf Verweigern festlegen.

  • Teamprojektsammlung_Name\Project Collection Service Accounts Mitglieder dieser Gruppe verfügen über Berechtigungen auf Dienstebene für die entsprechende Sammlung und für Team Foundation Server. Diese Gruppe enthält standardmäßig das während der Installation angegebene Dienstkonto. In dieser Gruppe dürfen sich nur Dienstkonten und Gruppen befinden, die ausschließlich Dienstkonten enthalten. Standardmäßig ist diese Gruppe Mitglied Team Foundation-Administratoren und Team Foundation-Dienstkonten.

  • TeamProjektAuflistungsname\Project Collection Build Administrators Mitglieder dieser Gruppe verfügen über Build-Administratorberechtigungen für die betreffende Auflistung. Diese Gruppe sollte so wenige Benutzer wie möglich enthalten und nur solche, die die vollständige Kontrolle zur Verwaltung von Buildservern und Diensten für diese Auflistung benötigen.

  • Teamprojektsammlung_Name\Project Collection Build Service Accounts Mitglieder dieser Gruppe verfügen über Builddienstberechtigungen für die betreffende Sammlung. In dieser Gruppe dürfen sich nur Dienstkonten und Gruppen befinden, die ausschließlich Dienstkonten enthalten.

  • Teamprojektsammlung_Name\Project Collection Proxy Service Accounts Mitglieder dieser Gruppe verfügen über Proxydienstberechtigungen für die betreffende Sammlung. In dieser Gruppe dürfen sich nur Dienstkonten und Gruppen befinden, die ausschließlich Dienstkonten enthalten.

  • Teamprojektsammlung_Name\Project Collection Test Service Accounts Mitglieder dieser Gruppe verfügen über Testdienstberechtigungen für die betreffende Sammlung. In dieser Gruppe dürfen sich nur Dienstkonten und Gruppen befinden, die ausschließlich Dienstkonten enthalten.

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Vollständige Beschreibungen der einzelnen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Berechtigungen für Buildressourcen verwalten | Projektauflistungsadministratoren Projektauflistungsbuild-Administratoren Dienstkonten für die Projektauflistung | Build-Administratoren, die regelmäßig Buildserver und -ressourcen für die Auflistung verwalten.
Project Server-Integration verwalten | Projektauflistungsadministratoren Dienstkonten für die Projektauflistung | Keine.
Abgelegte Änderungen verwalten | Projektauflistungsadministratoren Dienstkonten für die Projektauflistung Builddienstkonten für die Projektauflistung | Build-Administratoren, die von anderen Benutzern erstellte Shelvesets löschen.
Arbeitsbereiche verwalten | Projektauflistungsadministratoren Dienstkonten für die Projektauflistung | Build-Administratoren, die Arbeitsbereiche für andere Benutzer erstellen und von anderen Benutzern erstellte Shelvesets löschen.
Ablaufverfolgungseinstellungen ändern | Projektauflistungsadministratoren | Andere Serveradministratoren, die Ablaufverfolgungseinstellungen zum Erfassen genauerer Diagnoseinformationen zu Webdiensten für Team Foundation Server ändern müssen
Arbeitsbereich erstellen | Projektauflistungsadministratoren Projektauflistungsbuild-Administratoren Builddienstkonten für die Projektauflistung Mitwirkende an der Projektauflistung Proxydienstkonten für die Projektauflistung Dienstkonten für die Projektauflistung Testdienstkonten für die Projektauflistung Gültige Benutzer für Projektauflistung | Keine. Alle Benutzer verfügen über diese Berechtigung, da sie Mitglieder der Gruppe "Gültige Benutzer für Projektauflistung" sind
Neue Projekte erstellen | Projektauflistungsadministratoren | Projektadministratoren, die regelmäßig Projekte erstellen.
Teamprojekt löschen | Projektauflistungsadministratoren | Benutzer oder Gruppen, die für das Verwalten der allgemeinen Integrität und Ressourcenverfügbarkeit in der Bereitstellung zuständig sind
Informationen auf Auflistungsebene bearbeiten | Projektauflistungsadministratoren Dienstkonten für die Projektauflistung | Keine.
Anforderungen im Auftrag von anderen Benutzern einreichen | Projektauflistungsadministratoren Dienstkonten für die Projektauflistung SharePoint-Webanwendungsdienste | Keine.
Buildressourcen verwalten | Projektauflistungsadministratoren Projektauflistungsbuild-Administratoren Builddienstkonten für die Projektauflistung Projektadministratoren Projektname\Build Administrators | Manuell hinzugefügte Benutzer oder Gruppen, die Builds für die Buildressourcen in der Auflistung verwalten oder planen müssen
Prozessvorlage verwalten | Projektauflistungsadministratoren | Projektadministratoren und alle manuell hinzugefügten Benutzer oder Gruppen, z. B. Prozessexperten, die Prozessvorlagen erstellen, bearbeiten, herunterladen oder in Team Foundation Server hochladen müssen
Testcontroller verwalten | Projektauflistungsadministratoren Testdienstkonten für die Projektauflistung | Keine.
Linktypen für Arbeitsaufgaben verwalten | Projektauflistungsadministratoren | Keine.
Triggerereignisse | Projektauflistungsadministratoren Dienstkonten für die Projektauflistung | Keine. Wenn diese Berechtigung anderen Benutzern hinzugefügt wird, können möglicherweise Denial of Service-Angriffe verursacht werden.
Buildressourcen verwenden | Projektauflistungsadministratoren Builddienstkonten für die Projektauflistung | Manuell hinzugefügte Benutzer oder Gruppen, die neue Builds in die Warteschlange stellen oder abgeschlossene Builds in der Auflistung durchsuchen müssen
Buildressourcen anzeigen | Projektauflistungsadministratoren Projektauflistungsbuild-Administratoren Builddienstkonten für die Projektauflistung Gültige Benutzer für Projektauflistung | Keine.
Informationen auf Auflistungsebene anzeigen | Projektauflistungsadministratoren Projektauflistungsbuild-Administratoren Builddienstkonten für die Projektauflistung Dienstkonten für die Projektauflistung Testdienstkonten für die Projektauflistung Gültige Benutzer für Projektauflistung SharePoint-Webanwendungsdienste Proxydienstkonten für die Projektauflistung | Keine.
Systemsynchronisierungsinformationen anzeigen | Projektauflistungsadministratoren | Keine.

Gruppen und Berechtigungen auf Projektebene

Auf Projektebene sind standardmäßig die folgenden Gruppen vorhanden:

  • Projektname\Project Administrators Mitglieder dieser Gruppe können alle Aspekte des betreffenden Teamprojekts verwalten, jedoch keine Projekte erstellen.

  • ProjectName\Contributors Mitglieder dieser Gruppe können an dem betreffenden Projekt mitwirken, z. B. durch Hinzufügen, Ändern und Löschen von Code oder durch Erstellen und Ändern von Arbeitsaufgaben. Standardmäßig wird die beim Erstellen eines Teamprojekts erstellte Team-Gruppe dieser Gruppe hinzugefügt, und jeder diesem Team hinzugefügte Benutzer wird Mitglied dieser Gruppe. Darüber hinaus wird jedes für ein Teamprojekt erstellte Team standardmäßig dieser Gruppe hinzugefügt, wenn Sie keine andere Gruppe aus der Liste auswählen.

  • ProjektName\Readers Mitglieder dieser Gruppe können das angegebene Projekt anzeigen, es jedoch nicht ändern.

  • Projektname\Build Administrators Mitglieder dieser Gruppe haben Buildberechtigungen für das betreffende Projekt. Die Mitglieder können Testumgebungen verwalten, Testläufe erstellen und Builds verwalten.

  • Projektname\Teamname Team Mitglieder dieser Gruppe können auf verschiedene Arten zu dem betreffenden Projekt beitragen, z. B. durch Hinzufügen, Ändern und Löschen von Code oder durch Erstellen und Ändern von Arbeitsaufgaben. Die standardmäßige Teamgruppe wird erstellt, wenn Sie ein Teamprojekt erstellen. Diese wird standardmäßig der Gruppe "Contributors" für das Teamprojekt hinzugefügt. Alle neuen Teams, die Sie erstellen, haben ebenfalls eine für sie erstellte Gruppe und werden zur Gruppe der Contributors hinzugefügt.

Zusätzlich zu diesen Gruppen auf Projektebene werden in jedem Projekt von Team Foundation Server zwei Gruppen auf Auflistungsebene angezeigt:

  • TeamProjectCollectionName\Project Collection Administrators

    Hinweis Hinweis

    Sie können die Berechtigungen für diese Gruppe auf Auflistungsebene nicht ändern.

  • TeamProjectCollectionName\Project Collection Build Service Accounts

    Wichtiger Hinweis Wichtig

    Sie dürfen die Berechtigung Projektebeneninformationen anzeigen für diese Gruppe nicht aufheben oder auf Verweigern festlegen.

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Vollständige Beschreibungen der jeweiligen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Zum Hinzufügen von Gruppen auf Projektebene zu Gruppen auf Serverebene können Sie das Befehlszeilentool TFSSecurity verwenden.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Testläufe erstellen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Testdienstkonten für die Projektauflistung, Teamname-Team | Keine.
Teamprojekt löschen | Projektadministratoren, Projektauflistungsadministratoren | Keine.
Testläufe löschen | Projektadministratoren, Team Foundation-Administratoren, Mitwirkende, Teamname Team | Manuell hinzugefügte Benutzer oder Gruppen, die laufende oder veraltete Testläufe beenden müssen
Projektebeneninformationen bearbeiten | Projektadministratoren, Projektauflistungsadministratoren | Keine.
Testkonfigurationen verwalten | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Testdienstkonten für die Projektauflistung, Teamname-Team | Keine.
Testumgebungen verwalten | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Testdienstkonten für die Projektauflistung, Teamname-Team | Keine.
Projektebeneninformationen anzeigen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Teamname-Team | Alle manuell hinzugefügten Benutzer oder Gruppen, die Zugriff auf dieses Projekt benötigen
Testläufe anzeigen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Teamname-Team | Alle manuell hinzugefügten Benutzer oder Gruppen, die Zugriff auf dieses Projekt benötigen

Gruppen und Berechtigungen auf Bereichsebene

Auf Bereichsebene sind standardmäßig die folgenden Gruppen vorhanden:

  • Projektname\Project Administrators

  • Projektname\Contributors

  • Projektname\Readers

  • Projektname\Builders

  • Projektname\Teamname Team

  • TeamProjektAuflistungsname\Project Collection Administrators

  • TeamProjektAuflistungsname\Project Collection Build Service Accounts

  • TeamProjektAuflistungsname\Project Collection Test Service Accounts

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Vollständige Beschreibungen der einzelnen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Erstellen von untergeordneten Knoten | Projektadministratoren, Projektauflistungsadministratoren | Keine.
Diesen Knoten löschen | Projektadministratoren, Projektauflistungsadministratoren | Alle manuell hinzugefügten Benutzer oder Gruppen, die Bereichsknoten löschen müssen
Diesen Knoten bearbeiten | Projektadministratoren, Projektauflistungsadministratoren | Alle manuell hinzugefügten Benutzer oder Gruppen, die Bereichsknoten umbenennen müssen
Arbeitsaufgaben in diesem Knoten bearbeiten | Projektadministratoren, Mitwirkende, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Teamname-Team | Alle manuell hinzugefügten Benutzer oder Gruppen, die Arbeitsaufgaben in diesem Bereichsknoten bearbeiten müssen
Testpläne verwalten | Projektadministratoren, Mitwirkende, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Teamname-Team | Alle manuell hinzugefügten Benutzer oder Gruppen, die Testpläne in diesem Bereichsknoten verwalten müssen
Berechtigungen des Knotens anzeigen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Testdienstkonten für die Projektauflistung, Teamname-Team | Alle manuell hinzugefügten Benutzer oder Gruppen, die Zugriff auf Arbeitsaufgaben in diesem Bereichsknoten benötigen
Arbeitsaufgaben in diesem Knoten anzeigen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Builddienstkonten für die Projektauflistung, Testdienstkonten für die Projektauflistung, Teamname-Team | Alle manuell hinzugefügten Benutzer oder Gruppen, die Arbeitsaufgaben in diesem Bereichsknoten anzeigen, jedoch nicht bearbeiten oder ändern müssen

Gruppen und Berechtigungen auf Iterationsebene

Auf Iterationsebene sind standardmäßig die folgenden Gruppen vorhanden:

  • ProjectName\Project Administrators

  • TeamProjectCollectionName\Project Collection Administrators

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Vollständige Beschreibungen der einzelnen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Erstellen von untergeordneten Knoten | Projektadministratoren, Projektauflistungsadministratoren | Keine.
Diesen Knoten löschen | Projektadministratoren, Projektauflistungsadministratoren | Alle manuell hinzugefügten Benutzer oder Gruppen, die Iterationsknoten löschen müssen
Diesen Knoten bearbeiten | Projektadministratoren, Projektauflistungsadministratoren | Alle manuell hinzugefügten Benutzer oder Gruppen, die Iterationsknoten umbenennen müssen
Berechtigungen des Knotens anzeigen | Projektadministratoren, Projektauflistungsadministratoren | Alle manuell hinzugefügten Benutzer oder Gruppen, die Iterationsknoten anzeigen müssen

Gruppen und Berechtigungen für die Versionskontrolle

Auf Versionskontrollebene sind standardmäßig die folgenden Gruppen vorhanden:

  • ProjectName\Project Administrators

  • ProjectName\Contributors

  • ProjectName\Readers

  • ProjectName\Builders

  • TeamProjectCollectionName\Project Collection Administrators

  • TeamProjectCollectionName\Project Collection Service Accounts

  • TeamProjectCollectionName\Project Collection Build Service Accounts

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Vollständige Beschreibungen der einzelnen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Lesen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Alle Benutzer oder Gruppen, die an der Entwicklung dieses Projekts beteiligt sind; alle Benutzer, die den Inhalt einer Datei oder eines Ordners lesen müssen.
Auschecken | Projektadministratoren, Mitwirkende, Generatoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Alle Benutzer oder Gruppen, die an der Entwicklung dieses Projekts beteiligt sind; alle Benutzer, die Elemente in einem Ordner auschecken oder ausstehende Änderungen an ihnen vornehmen müssen.
Einchecken | Projektadministratoren, Mitwirkende, Generatoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Alle Benutzer oder Gruppen, die an der Entwicklung dieses Projekts beteiligt sind; alle Benutzer, die Elemente einchecken oder übernommene Changeset-Kommentare überarbeiten müssen.
Bezeichnung | Projektadministratoren, Mitwirkende, Generatoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Alle manuell hinzugefügten Benutzer oder Gruppen, die Elemente beschriften müssen
Sperren | Projektadministratoren, Mitwirkende, Generatoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Alle manuell hinzugefügten Benutzer oder Gruppen, die Ordner oder Dateien sperren bzw. die entsprechenden Sperren wieder aufheben müssen
Änderungen anderer Benutzer überarbeiten | Projektadministratoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung | Manuell hinzugefügte Benutzer oder Gruppen, die für Beaufsichtigung oder Überwachung des Projekts zuständig sind und die die Kommentare zu eingecheckten Dateien bearbeiten müssen, auch wenn die betreffende Datei von einem anderen Benutzer eingecheckt wurde
Änderungen anderer Benutzer entsperren | Projektadministratoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung | Manuell hinzugefügte Benutzer oder Gruppen, die für Beaufsichtigung oder Überwachung des Projekts zuständig sind und die durch andere Benutzer gesperrte Dateien entsperren müssen.
Änderungen anderer Benutzer rückgängig machen | Projektadministratoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung | Manuell hinzugefügte Benutzer oder Gruppen, die für Beaufsichtigung oder Überwachung des Projekts zuständig sind und die ausstehende Änderungen von anderen Benutzern rückgängig machen müssen.
Bezeichnungen verwalten | Projektadministratoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung | Manuell hinzugefügte Benutzer oder Gruppen, die für Beaufsichtigung oder Überwachung des Projekts zuständig sind und die von einem anderen Benutzer erstellte Bezeichnungen bearbeiten oder löschen müssen.
Berechtigungen verwalten | Projektadministratoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung | Keine.
Änderungen anderer Benutzer einchecken | Projektadministratoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Keine.
Zusammenführen | Projektadministratoren, Mitwirkende, Generatoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Die meisten Benutzer oder Gruppen, die an der Entwicklung dieses Projekts beteiligt sind und Quelldateien zusammenführen müssen, sofern das Projekt nicht restriktiveren Entwicklungsverfahren unterliegt.
Verzweigung verwalten | Projektadministratoren, Projektauflistungsadministratoren, Dienstkonten für die Projektauflistung, Builddienstkonten für die Projektauflistung | Alle Benutzer oder Gruppen, die an der Entwicklung dieses Projekts beteiligt sind und private Verzweigungen erstellen müssen, sofern das Projekt nicht restriktiveren Entwicklungsverfahren unterliegt.

Berechtigungen auf Buildebene

Auf Buildebene sind standardmäßig die folgenden Gruppen vorhanden:

  • ProjectName\Project Administrators

  • ProjectName\Contributors

  • ProjectName\Readers

  • ProjectName\Builders

  • TeamProjectCollectionName\Project Collection Administrators

  • TeamProjectCollectionName\Project Collection Build Service Accounts

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Vollständige Beschreibungen der einzelnen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Buildberechtigungen verwalten | Projektauflistungsadministratoren, Projektadministratoren, Projektauflistungsbuildadministratoren, Buildadministratoren, | Alle Benutzer oder Gruppen, die die Buildserver verwalten.
Builds anzeigen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Builddienstkonten für die Projektauflistung, Projektauflistungsadministratoren | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Builds anzeigen müssen
Buildqualität bearbeiten | Projektadministratoren, Mitwirkende, Generatoren, Builddienstkonten für die Projektauflistung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Unbegrenzt beibehalten | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Builds löschen | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Buildqualität verwalten | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Builds zerstören | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Buildinformationen aktualisieren | Builddienstkonten für die Projektauflistung | Keine.
Build zur Warteschlange hinzufügen | Projektadministratoren, Mitwirkende, Generatoren, Builddienstkonten für die Projektauflistung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Buildwarteschlange verwalten | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Builds beenden | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Builddefinition anzeigen | Projektadministratoren, Mitwirkende, Leser, Generatoren, Builddienstkonten für die Projektauflistung, Projektauflistungsadministratoren | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Builddefinitionen anzeigen müssen
Builddefinition bearbeiten | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Builddefinition löschen | Projektadministratoren, Generatoren, Builddienstkonten für die Projektsammlung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.
Eincheckvalidierung durch Build überschreiben | Builddienstkonten für die Projektauflistung, Projektauflistungsadministratoren | Alle Benutzer oder Gruppen, die Builds verwalten.

Gruppen und Berechtigungen für Lab Management

Auf Lab-Management-Ebene sind standardmäßig die folgenden Gruppen vorhanden:

  • ProjectName\Project Administrators

  • ProjectName\Contributors

  • ProjectName\Readers

  • TeamProjectCollectionName\Project Collection Administrators

  • TeamProjectCollectionName\Project Collection Build Service accounts

  • Server\Team Foundation Administrators

Diese Gruppen verfügen standardmäßig über die Berechtigungen in der folgenden Tabelle. Außerdem werden dem Ersteller eines Objekts in Lab-Management automatisch alle Berechtigungen für dieses Objekt erteilt. Vollständige Beschreibungen der einzelnen Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Berechtigungsname | Standardmäßig festgelegt für: | Kann hinzugefügt werden für:
Lab-Ressourcen anzeigen | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Leser, Builddienstkonten für die Projektauflistung | Alle manuell hinzugefügten Benutzer oder Gruppen, die Lab-Ressourcen anzeigen müssen
Lab-Speicherorte verwalten | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren (beschränkt auf Speicherorte auf Projektebene, d. h. auf die Projekthostgruppe und Projektbibliotheksfreigabe) | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Objekte verwalten müssen
Lab-Speicherorte löschen | Team Foundation-Administratoren, Projektauflistungsadministratoren Projektadministratoren (beschränkt auf Speicherorte auf Projektebene, z. B. auf Projekthostgruppen und Projektbibliotheksfreigaben) | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Objekte verwalten müssen
Umgebung und virtuelle Computer schreiben | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Builddienstkonten für die Projektauflistung | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Umgebung und virtuelle Computer bearbeiten | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Builddienstkonten für die Projektauflistung | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Umgebung und virtuellen Computer löschen | Team Foundation-Administratoren, Projektauflistungsadministratoren Projektadministratoren | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Virtuellen Computer importieren | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Vorgänge in der Umgebung | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Builddienstkonten für die Projektauflistung | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Berechtigungen verwalten | Team Foundation-Administratoren, Projektauflistungsadministratoren | Administratoren, die Lab-Objekte verwalten müssen
Untergeordnete Berechtigungen verwalten | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren (beschränkt auf Speicherorte auf Projektebene, d. h. auf die Projekthostgruppe und Projektbibliotheksfreigabe) | Administratoren, die Lab-Objekte verwalten müssen
Starten | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Builddienstkonten für die Projektauflistung | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Beenden | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Builddienstkonten für die Projektauflistung | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Anhalten | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Builddienstkonten für die Projektauflistung | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen
Momentaufnahmen verwalten | Team Foundation-Administratoren, Projektauflistungsadministratoren, Projektadministratoren, Mitwirkende, Builddienstkonten für die Projektauflistung | Die meisten manuell hinzugefügten Benutzer oder Gruppen; alle, die Lab-Umgebungen verwenden müssen

Siehe auch

Aufgaben

Festlegen von Administratorberechtigungen für Team Foundation Server
Hinzufügen von Benutzern zu Teamprojekten
Ändern der Berechtigungen für eine Gruppe oder einen Benutzer
Ansichtsberechtigungen

Konzepte

Team Foundation Server-Berechtigungen

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity


Ändern der Berechtigungen für eine Gruppe oder einen Benutzer

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Ändern der Berechtigungen für eine Gruppe oder einen Benutzer
Siehe auch Feedback senden

Sie können Berechtigungen für einen Benutzer oder eine Gruppe auf Projektebene, Auflistungsebene oder Serverebene in Visual Studio Team Foundation Server explizit ändern. Wenn Sie die Berechtigung für eine Gruppe ändern, wirkt sich dies ggf. auf die Berechtigungen aller Benutzer aus, die Mitglied dieser Gruppe sind. Ein Benutzer kann z. B. Mitglied in zwei Gruppen eines Projekts sein. Wenn eine bestimmte Berechtigung für eine Gruppe auf Verweigern und dieselbe Berechtigung für die andere Gruppe auf Zulassen festgelegt ist, wird dem Benutzer diese Berechtigung verweigert. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Wenn Sie Berechtigungen für Benutzer und Gruppen in Team Foundation Server ändern, werden hierdurch nicht automatisch die Berechtigungen angepasst, über die diese Benutzer und Gruppen in SQL Server Reporting Services oder SharePoint-Produkte verfügen. Sie müssen Berechtigungen für Benutzer und Gruppen in diesen Produkten manuell ändern.

Erforderliche Berechtigungen

Um diese Prozedur ausführen zu können, müssen Sie Mitglied der Administratorgruppe auf Ebene der zu ändernden Gruppe sein. Wenn Sie z. B. Berechtigungen für eine Gruppe oder einen Benutzer auf Auflistungsebene ändern möchten, müssen Sie Mitglied der Gruppe Projektauflistungsadministratoren für diese Auflistung sein, oder Ihre Berechtigung Informationen auf Auflistungsebene bearbeiten muss auf Zulassen festgelegt sein. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So ändern Sie Berechtigungen für eine Gruppe oder einen Benutzer auf Projektebene

  1. Öffnen Sie in Team Explorer das Teamprojekt, für das Sie Berechtigungen für eine Gruppe oder einen Benutzer ändern möchten, und wählen Sie dann Einstellungen aus.

    Das Menü Einstellungen wird angezeigt.

  2. Wählen Sie im Einstellungsmenü unter Teamprojekt die Option Sicherheit aus.

    Team Web Access wird im Verwaltungskontext für das Teamprojekt auf der Registerkarte Sicherheit geöffnet.

  3. Wählen Sie auf der Registerkarte Gruppen die Gruppe aus, deren Berechtigungen Sie ändern möchten. Alternativ können Sie auf der Registerkarte Benutzer den Benutzer auswählen, dessen Berechtigungen Sie ändern möchten.

    Nachdem Sie eine Gruppe oder einen Benutzer ausgewählt haben, wählen Sie auf der Registerkarte Berechtigungen die zu ändernde Berechtigung aus, und schalten Sie anschließend den Wert dieser Berechtigung in den Wert um, den Sie für diesen Benutzer bzw. diese Gruppe festlegen möchten.

    Sie können zwischen den folgenden Werten auswählen:

    1. zulassen

    2. deny

    3. Nicht festgelegt

    4. Geerbte Zulassung oder Geerbte Verweigerung, wenn einer dieser Werte der ursprüngliche Wert für die Berechtigung war

    Tipp Tipp

    Wenn der Wert für eine Berechtigung Geerbte Zulassung oder Geerbte Verweigerung lautet, können Sie Warum? auswählen, um zurückzuverfolgen, woher die Vererbung stammt.

  4. Wenn Sie die Berechtigungen geändert haben, wählen Sie Änderungen speichern aus.

So ändern Sie Berechtigungen für eine Gruppe oder einen Benutzer auf Auflistungsebene

  1. Wählen Sie in Team Explorer Team aus, wählen Sie Teamprojektauflistung aus, und wählen Sie dann Sicherheit aus.

    Team Web Access wird im Verwaltungskontext für die Teamprojektsammlung auf der Registerkarte Sicherheit geöffnet.

  2. Wählen Sie auf der Registerkarte Gruppen die Gruppe aus, deren Berechtigungen Sie ändern möchten. Alternativ können Sie auf der Registerkarte Benutzer den Benutzer auswählen, dessen Berechtigungen Sie ändern möchten.

    Nachdem Sie eine Gruppe oder einen Benutzer ausgewählt haben, wählen Sie auf der Registerkarte Berechtigungen die zu ändernde Berechtigung aus, und schalten Sie anschließend den Wert dieser Berechtigung in den Wert um, den Sie für diesen Benutzer bzw. diese Gruppe festlegen möchten.

    Sie können zwischen den folgenden Werten auswählen:

    1. zulassen

    2. deny

    3. Nicht festgelegt

    4. Geerbte Zulassung oder Geerbte Verweigerung, wenn einer dieser Werte der ursprüngliche Wert für die Berechtigung war

    Tipp Tipp

    Wenn der Wert für eine Berechtigung Geerbte Zulassung oder Geerbte Verweigerung lautet, können Sie Warum? auswählen, um zurückzuverfolgen, woher die Vererbung stammt.

  3. Wenn Sie die Berechtigungen geändert haben, wählen Sie Änderungen speichern aus.

So ändern Sie Berechtigungen für Gruppen auf Serverebene

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation auf dem Anwendungsebenenserver, auf dem Sie Berechtigungen für eine Gruppe auf Serverebene ändern möchten.

  2. Wählen Sie Anwendungsebene und dann Sicherheit verwalten.

    Das Fenster Globale Sicherheit wird geöffnet.

  3. Klicken Sie unter Benutzer und Gruppen auf die Gruppe, für die Sie Berechtigungen ändern möchten.

    Hinweis Hinweis

    Wenn die Gruppe, die Sie ändern möchten, in der Liste nicht angezeigt wird, müssen Sie diese mit den Steuerelementen im Abschnitt Benutzer und Gruppen hinzufügen hinzufügen.

  4. Aktivieren oder deaktivieren Sie unter Berechtigungen das Kontrollkästchen Zulassen oder Verweigern für die Berechtigung, die Sie ändern möchten.

    Hinweis Hinweis

    Wenn weder das Kontrollkästchen Zulassen noch das Kontrollkästchen Verweigern aktiviert wird, wird als Berechtigungsstufe "Nicht festgelegt" definiert. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

  5. Wählen Sie Schließen aus, wenn Sie die Änderung der Berechtigungen abgeschlossen haben.

Siehe auch

Konzepte

Konfigurieren von Benutzern, Gruppen und Berechtigungen

Weitere Ressourcen

How to: Add Users to Groups


Ansichtsberechtigungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Ansichtsberechtigungen
Siehe auch Feedback senden

Beim Verwalten von Team Foundation Server müssen Sie u. U. die den einzelnen Benutzern oder Gruppen erteilten Berechtigungen anzeigen. Mithilfe dieser Informationen können Sie die Zugriffsebenen besser zu verstehen, die Benutzer und Gruppen für die Bereitstellung zur Verfügung stehen. Außerdem können Sie mit diesen Informationen Zugriffsprobleme beheben. Sie können Berechtigungen auf zwei Arten anzeigen: über Team Web Access oder mit der Verwaltungskonsole für Team Foundation Server. Mit Team Explorer oder Team Web Access können Sie auf die Sicherheit und die Berechtigungen für die Team-, Projekt- und Auflistungsebene zugreifen. Für Berechtigungen auf der Teamebene müssen Sie Team Web Access verwenden. Für Berechtigungen auf der Serverebene müssen Sie die Verwaltungskonsole verwenden.

Tipp Tipp

Neben den Berechtigungen kann die Lizenzierungsebene bestimmen, welche Funktionen für die Benutzer verfügbar sind. Weitere Informationen zum Anzeigen von Lizenzierungsebenen finden Sie unter Hinzufügen von Benutzern zu Teamprojekten.

Erforderliche Berechtigungen

Um diese Prozedur ausführen zu können, müssen Sie ein Mitglied der Gruppe Gültige Benutzer für Projektauflistung sein, oder die Berechtigung Projektebeneninformationen anzeigen muss auf Zulassen festgelegt sein. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

So zeigen Sie Berechtigungen auf Auflistungsebene an

  1. Führen Sie eine der folgenden Schritte aus:

    • Wählen Sie in Team Explorer unter Teamprojektauflistung die Option Sicherheit aus.

      In einem Browserfenster wird das Verwaltungsmenü für Team Web Access geöffnet.

    • Öffnen Sie in Team Web Access das Verwaltungsmenü, und wählen Sie im Kontextmenü den Namen der Teamprojektauflistung aus.

  2. Wählen Sie im Hubmenübereich die Registerkarte Sicherheit aus.

  3. Wählen Sie unter Mitglieder die Option Gruppen oder die Option Benutzer, und wählen Sie anschließend den Benutzer oder die Gruppe aus, für den bzw. für die Sie Berechtigungen anzeigen möchten.

    Berechtigungen werden im Bereich Zusammenfassung angezeigt. Wenn Sie die Mitglieder einer Gruppe anzeigen möchten, wählen Sie die Registerkarte Mitglieder aus. Wenn Sie die Gruppen anzeigen möchten, zu denen dieser Benutzer oder diese Gruppe gehört, wählen Sie die Registerkarte Mitglied von aus.

    In der folgenden Abbildung wird die Zusammenfassungsansicht der Gruppe Projektauflistungsadministratoren für das fiktive Unternehmen "Fabrikam Fiber" angezeigt:

    Gruppensicherheit auf Auflistungsebene

So zeigen Sie Berechtigungen auf Projektebene an

  1. Führen Sie eine der folgenden Schritte aus:

    • Wählen Sie in Team Explorer unter Teamprojekt die Option Sicherheit aus.

      In einem Browserfenster wird das Verwaltungsmenü für Team Web Access geöffnet.

    • Öffnen Sie in Team Web Access das Verwaltungsmenü, und wählen Sie im Kontextmenü den Namen des Teamprojekts aus.

  2. Wählen Sie im Hubmenübereich die Registerkarte Sicherheit aus.

  3. Wählen Sie unter Mitglieder die Option Gruppen oder die Option Benutzer, und wählen Sie anschließend den Benutzer oder die Gruppe aus, für den bzw. für die Sie Berechtigungen anzeigen möchten.

    Berechtigungen werden im Bereich Zusammenfassung angezeigt. Wenn Sie die Mitglieder einer Gruppe anzeigen möchten, wählen Sie die Registerkarte Mitglieder aus. Wenn Sie die Gruppen anzeigen möchten, zu denen dieser Benutzer oder diese Gruppe gehört, wählen Sie die Registerkarte Mitglied von aus.

So zeigen Sie Berechtigungen auf Teamebene an

  1. Öffnen Sie Team Web Access, stellen Sie eine Verbindung mit Ihrem Projekt her, und wählen Sie im Kontextmenü das Verwaltungssymbol und anschließend die Option Einstellungen aus.

  2. Wählen Sie im Hubmenübereich die Registerkarte Übersicht aus.

  3. Überprüfen Sie unter Übersicht die Liste der Administratoren für das Team und die Liste der Teammitglieder.

    Keine Teamberechtigungen sind explizit sichtbar. Der einzige Unterschied zwischen Berechtigungen für einen Teamadministrator und für Teammitglieder besteht darin, dass Teamadministratoren die einzigen Benutzer sind, die dem Team Mitglieder hinzufügen oder diese entfernen können. Wenn Sie die Registerkarte Sicherheit auswählen, werden die Berechtigungen für jedes Teammitglied auf Projektebene und nicht auf Teamebene angezeigt.

So zeigen Sie Berechtigungen auf Serverebene an

  1. Öffnen Sie die Verwaltungskonsole, und wählen Sie Anwendungsebene aus.

  2. Wählen Sie im Bereich Anwendungsebene die Option Sicherheit verwalten aus.

  3. Wählen Sie unter Benutzer und Gruppen den Benutzer oder die Gruppe aus, für den bzw. für die Sie Berechtigungen anzeigen möchten.

    Die Berechtigungen werden im Bereich Berechtigungen angezeigt.

Siehe auch

Aufgaben

Ändern der Berechtigungen für eine Gruppe oder einen Benutzer

Weitere Ressourcen

Verwalten von Berechtigungen


Sichern und Wiederherstellen der Bereitstellung

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Sichern und Wiederherstellen der Bereitstellung
Siehe auch Feedback senden

Sie können die Datenbanken sichern, von denen Team Foundation Server (TFS) abhängt, um so einen möglichen Datenverlust zu vermeiden und die Ausfallzeiten aufgrund von Hardware- und Softwarefehlern zu verringern. Wenn Sie mit dem Sichern und Wiederherstellen von SQL Server-Datenbanken vertraut sind, wird Ihnen der Sicherungs- und Wiederherstellungsvorgang bei TFS sehr bekannt vorkommen. Alle Informationen, die zum Wiederherstellen einer TFS-Bereitstellung benötigt werden, sind in SQL Server-Datenbanken gespeichert. Sie müssen sich nicht um die Sicherung von Team Foundation-Clientcomputern oder Anwendungsebenenservern kümmern.

Wie kompliziert die Sicherung und Wiederherstellung der Bereitstellung ist, hängt zum großen Teil von der Topologie der Bereitstellung ab sowie davon, ob Sie Daten auf vorhandener Hardware wiederherstellen oder ob Sie eine Bereitstellung nach einem Hardwarefehler wiederherstellen. Das Sichern und Wiederherstellen einer Bereitstellung ist auch dann komplizierter, wenn Sie die Bereitstellung mit SQL Server Reporting Services oder SharePoint-Produkte erweitert haben. Zusätzlich zu den TFS-Datenbanken müssen Sie auch die Datenbanken für die Programme sichern und wiederherstellen, die der Bereitstellung zugeordnet sind.

Wenn es bei einem der Server in der Bereitstellung zu einem Hardwarefehler kommt oder der Server aus einem anderen Grund nicht verfügbar ist, können Sie mit den in diesem Abschnitt beschriebenen Vorgängen die Bereitstellung wieder in einen betriebsbereiten Zustand versetzen. Sie müssen außerdem die Software auf neuen Servern installieren, bevor Sie die Datenbanken wiederherstellen können. Ein Lernprogramm ist speziell verfügbar, um Administratoren von Bereitstellungen auf einem Einzelserver bei der Wiederherstellung auf neuer Hardware zu unterstützen. Die Informationen in dem Lernprogramm sollten für jeden Administrator bei der Wiederherstellung einer Bereitstellung nützlich sein. Weitere Informationen finden Sie unter Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm].

Allgemeine Aufgaben

Allgemeine Aufgaben | Unterstützender Inhalt
Bestimmen Sie die beste Sicherungsstrategie für die Bereitstellung: Sie können die Typen von Sicherungen, die für die Daten verfügbar sind, überprüfen und eine Sicherungsstrategie auswählen, die Ihren Geschäftsanforderungen am besten entspricht. | Grundlagen zum Sichern von Team Foundation Server
Sichern Sie die Daten: Sie können Aufträge planen, um die Datenbanken zu sichern, die TFS verwendet. Sie können auch den Verschlüsselungsschlüssel für Berichtserstellungsdaten sichern. | Erstellen eines Backupplans
Stellen Sie Datenbanken von der Sicherung wieder her: Sie können die Datenbanken, die TFS verwendet, auf denselben Servern wiederherstellen, auf denen sie installiert wurden, oder Sie können sie auf anderen Servern wiederherstellen. | Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm] Wiederherstellen von Datenbanken Wiederherstellen von Daten an demselben Speicherort
Stellen Sie von einem Hardwarefehler wieder her: Wenn der Anwendungsebenenserver einen Hardwarefehler aufweist, können Sie Software installieren und einen neuen Server konfigurieren, um als Anwendungsebenenserver zu fungieren. Wenn der Datenebenenserver einen Hardwarefehler aufweist, können Sie Software installieren und die Datenbanken, die TFS verwendet, auf dem neuen Server wiederherstellen. Wenn die Hardware, die die Einzelserverbereitstellung unterstützt, ausfällt, können Sie sie auf einem neuen Server wiederherstellen. | Wiederherstellen eines Servers der Anwendungsebene Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]
Sichern Sie Lab Management-Komponenten, und stellen Sie sie wieder her: In dieser Version erfordert das Sichern und Wiederherstellen von Visual Studio Lab Management zusätzliche Schritte. | Wiederherstellen von Lab-Management-Komponenten

Siehe auch

Konzepte

Organisieren des Servers mit Teamprojektsammlungen
Architektur von Team Foundation Server

Weitere Ressourcen

Team Foundation Server-Dienste und -Dienstkonten
Verwalten von Berechtigungen


Grundlagen zum Sichern von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Grundlagen zum Sichern von Team Foundation Server
Siehe auch Feedback senden

Sie können die Bereitstellung vor Datenverlust schützen, indem Sie regelmäßige Sicherungen der Datenbanken durchführen, von denen Visual Studio Team Foundation Server abhängt. Um die Bereitstellung von Team Foundation in ihrer Gesamtheit wiederherzustellen, falls ein Fehler auftreten sollte, müssen Sie zunächst alle Datenbanken für Team Foundation Server sichern. Wenn die Bereitstellung SharePoint-Produkte oder SQL Server Reporting Services einschließt, müssen Sie auch die Datenbanken sichern, die Team Foundation Server für diese Komponenten verwendet. Sie müssen alle Sicherungen mit dem gleichen Zeitstempel synchronisieren, um zu vermeiden, dass es zu einer nicht übereinstimmenden Synchronisierung oder nicht übereinstimmenden Daten kommt. Die einfachste Art, um die Synchronisierung sicherzustellen, besteht darin, markierte Transaktionen zu verwenden. Durch das routinemäßige Markieren zugehöriger Transaktionen in allen Team Foundation- Datenbanken werden eine Reihe allgemeiner Wiederherstellungspunkte in den Datenbanken erstellt. Schrittweise Anweisungen zum Sichern einer Bereitstellung auf einem Einzelserver, bei der SharePoint Foundation 2010 und Berichterstellung verwendet werden, finden Sie unter Erstellen eines Backupplans.

Sichern von Datenbanken

Das Erstellen von Sicherungen der Datenbanken, die Team Foundation Server verwendet, stellt einen wichtigen Aspekt beim Schutz der Bereitstellung von Team Foundation gegen Datenverluste dar. In der folgenden Tabelle und den dazu gehörenden Abbildungen wird dargestellt, welche Datenbanken Sie sichern müssen, und es werden Beispiele dafür aufgeführt, wie diese Datenbanken physisch in einer Bereitstellung verteilt sein können.

Datenbanktyp | Produkt | Optionale Komponente?
Konfigurationsdatenbank | Team Foundation Server | Nein
Warehouse-Datenbank | Team Foundation Server | Nein
Teamprojekt-Auflistungsdatenbanken | Team Foundation Server | Nein
SharePoint-Produkte-Datenbanken | SharePoint-Produkte | Ja
Berichtsdatenbanken | SQL Server Reporting Services | Ja
Analysedatenbanken | SQL Server Analysis Services | ja

Bereitstellungstopologien

Auf Grundlage der Bereitstellungskonfiguration können sich alle Datenbanken, die gesichert werden müssen, auf dem gleichen physischen Server befinden, wie in dieser Beispieltopologie dargestellt. Dieses Beispiel umfasst nicht SharePoint-Produkte oder Reporting Services, sodass keine Datenbanken gesichert werden müssen, die mit der Berichterstellung, der Analyse oder SharePoint-Produkte zusammenhängen.

Einfache Topologie mit Datenbanken

Die Datenbanken können alternativ jedoch auch auf verschiedenen Servern oder Serverfarmen verteilt sein. In dieser Beispieltopologie müssen Sie die folgenden Datenbanken auf sechs Servern oder Serverfarmen sichern:

  • Konfigurationsdatenbank

  • Warehouse-Datenbank

  • Teamprojekt-Auflistungsdatenbanken im SQL Server-Cluster

  • Auflistungsdatenbank auf dem eigenständigen Server, der SQL Server ausführt

  • SharePoint-Produkte-Verwaltungsdatenbanken und Siteauflistungsdatenbanken für beide SharePoint-Webanwendungen

  • Datenbanken auf dem Server, der Reporting Services ausführt

  • Datenbank auf dem Server, der Analysis Services ausführt

Beispiel: Komplexe Verteilung von Datenbanken

In diesen beiden Beispielen müssen Sie keine der Clients sichern, die eine Verbindung mit dem Server herstellen. Sie müssen jedoch ggf. die Zwischenspeicher für Team Foundation Server auf den Clientcomputern löschen, bevor eine Verbindung zur wiederhergestellten Bereitstellung erstellt werden kann.

Zu sichernde Datenbanken

In der folgenden Liste sind weitere Details dazu aufgeführt, welche Sicherungen Sie abhängig von den Bereitstellungsressourcen noch durchführen müssen.

Warnhinweis Vorsicht

Alle Datenbanken in der folgenden Liste sind SQL Server-Datenbanken. Obwohl Sie jederzeit einzelne Datenbanken mithilfe von SQL Server Management Studio sichern können, sollten Sie möglichst vermeiden, solche individuellen Sicherungen zu verwenden. Es können unerwartete Ergebnisse auftreten, wenn Sie aus individuellen Sicherungen wiederherstellen, da die Datenbanken, die Team Foundation Server verwendet, alle miteinander verknüpft sind. Wenn Sie nur eine Datenbank sichern, sind die Daten in dieser Datenbank nicht mehr synchron mit den Daten in den anderen Datenbanken.

  • Datenbanken für Team Foundation Server Die logische Datenebene für Team Foundation Server schließt mehrere SQL Server-Datenbanken ein, einschließlich der Konfigurationsdatenbank, der Warehouse-Datenbank und einer Datenbank für jede Teamprojektsammlung in der Bereitstellung. Diese Datenbanken können sich alle auf dem gleichen Server befinden, können auf mehrere Instanzen in der gleichen SQL Server-Bereitstellung oder auf mehrere Server verteilt sein. Unabhängig von ihrer physischen Verteilung müssen Sie alle Datenbanken mit dem gleichen Zeitstempel sichern, damit ein ausreichender Schutz vor Datenverlust gegeben ist. Sie können Datenbanksicherungen manuell oder automatisch mithilfe von Wartungsplänen durchführen, die zu bestimmten Zeiten oder in bestimmten Intervallen ausgeführt werden.

    Warnhinweis Vorsicht

    Die Liste der Datenbanken für Team Foundation Server ist nicht statisch. Eine neue Datenbank wird jedes Mal erstellt, wenn Sie eine Auflistung erstellen. Wenn Sie eine Auflistung erstellen, stellen Sie sicher, dass Sie dem Wartungsplan zum Sichern von Team Foundation Server-Datenbanken in SQL Server für diese Auflistung die Datenbank hinzufügen.

  • Datenbanken für SharePoint-Produkte Wenn die Bereitstellung SharePoint-Produkte zum Hosten von Teamprojekten verwendet, müssen Sie mehrere Datenbanken sichern. Diese Datenbanken enthalten die Verwaltungsdatenbank für alle SharePoint-Webanwendungen, die die Bereitstellung verwenden, und die Websiteauflistungsdatenbanken, die Teamprojektportale hosten. Idealerweise wurde die Bereitstellung so konfiguriert, dass sie eine separate Websiteauflistung für jede Teamprojektsammlung in der Bereitstellung verwendet. Ebenso wie Teamprojektsammlungen in Team Foundation Server als Einheit gesichert und wiederhergestellt werden können, können Siteauflistungen in SharePoint-Produkte gesichert und wiederhergestellt werden. Wenn eine oder mehrere Auflistungen in der Bereitstellung Sites oder untergeordnete Sites von Siteauflistungen als Stammsite verwenden, können Sie die Auflistungen möglicherweise nicht vollständig sichern und wiederherstellen. Weitere Informationen finden Sie unter Organisieren des Servers mit Teamprojektsammlungen.

    Hinweis Hinweis

    Auf den ersten Blick scheint es notwendig, sowohl die Datenbanken als auch die Websites der Teamprojekt-Portalseiten zu sichern. SharePoint-Produkte generiert die Websites jedoch dynamisch aus den Datenbanken. Wenn Sie die Datenbanken sichern, sichern Sie daher auch die Bereiche des Teamprojekts, die als Websites angezeigt werden. Wenn Sie benutzerdefinierte Websitesammlungen, Websitevorlagen oder Webparts in SharePoint-Produkte, jedoch außerhalb von Team Foundation, erstellt haben, müssen Sie diese separat sichern. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Sicherung (SharePoint Foundation 2010.

  • Datenbanken für Berichterstellungs- und Analysedienste Wenn die Bereitstellung SQL Server Reporting Services oder SQL Server Analysis Services zum Erstellen von Berichten für Team Foundation Server verwendet, müssen Sie die Berichterstellungs- und Analysedatenbanken sichern. Sie müssen jedoch weiterhin bestimmte Datenbanken nach der Wiederherstellung erneut generieren.

  • Verschlüsselungsschlüssel für den Berichtsserver Der Berichtsserver verfügt über einen Verschlüsselungsschlüssel, den Sie sichern müssen. Dieser Schlüssel schützt vertrauliche Informationen, die in der Berichtsserverdatenbank gespeichert sind. Sie können diesen Schlüssel manuell sichern, indem Sie entweder das Reporting Services-Konfigurationstool oder ein Befehlszeilentool verwenden.

Erweiterte Vorbereitung für Sicherungen

Notieren Sie sich bei der Bereitstellung von Team Foundation die erstellten Konten und alle festgelegten Computernamen, Kennwörter sowie Setupoptionen. Bewahren Sie außerdem stets eine Kopie aller Wiederherstellungsmaterialien, Dokumente und Datenbanken- sowie Transaktionsprotokollsicherungen an einem sicheren Ort auf. Um auch für Unglücksfälle aller Art gerüstet zu sein, z. B. für Feuer oder Naturkatastrophen, bewahren Sie Duplikate Ihrer Serversicherungen an einem anderen Ort als dem Serverstandort auf. Dies hilft Ihnen, sich vor dem Verlust wichtiger Daten zu schützen. Am besten ist es, jeweils drei Kopien der Sicherungsmedien aufzubewahren, davon mindestens eine extern in einer sorgfältig kontrollierten Umgebung.

Wichtiger Hinweis Wichtig

Führen Sie regelmäßig eine Testdatenwiederherstellung aus, um sicherzustellen, dass die Dateien korrekt gesichert wurden. Eine Testwiederherstellung kann Hardwareprobleme aufzeigen, die bei Softwareüberprüfungen nicht auftreten.

Die Daten müssen beim Sichern und Wiederherstellen einer Datenbank auf Medien (z. B. Bändern und Festplatten) gesichert werden. Der Sicherungsplan sollte Vorschriften für die Verwaltung von Medien enthalten, wie z. B. folgende Vorgehensweisen:

  • Einen Verfolgungs- und Verwaltungsplan für die Aufbewahrung und den Wiedereinsatz von Sicherungssätzen

  • Einen Plan für das Überschreiben von Sicherungsmedien

  • Bei Multiserverumgebungen die Festlegung, ob zentralisierte oder verteilte Sicherungen zu verwenden sind

  • Eine Möglichkeit, die Haltbarkeit von Medien zu verfolgen

  • Ein Verfahren, um die Auswirkungen beim Verlust eines Sicherungssatzes oder Sicherungsmediums, z. B. eines Bands, möglichst gering zu halten

  • Eine Entscheidung, ob Sicherungssätze vor Ort oder an einem anderen Ort zu lagern sind und eine Analyse über deren mögliche Auswirkungen auf die Wiederherstellungszeit

Da die Team Foundation-Daten in SQL Server-Datenbanken gespeichert werden, müssen die Computer, auf denen Team Foundation-Clients installiert sind, nicht gesichert werden. Wenn ein Medienfehler oder ein Notfall eintritt, der diese Computer betrifft, können Sie die Clientsoftware neu installieren und erneut eine Verbindung mit dem Server herstellen. Das Neuinstallieren der Clientsoftware stellt für die Benutzer eine einfachere und zuverlässigere Alternative als die Wiederherstellung eines Clientcomputers von einer Sicherung dar.

Sie können einen Server mithilfe der Wartungspläne in SQL Server sichern, um die mit der Team Foundation-Bereitstellung verknüpften Datenbanken zu sichern. Die Datenbanken für Team Foundation Server stehen in Beziehung zueinander und sollten gleichzeitig gesichert und wiederhergestellt werden. Weitere Informationen über Strategien zum Sichern von Datenbanken finden Sie auf der folgenden Seite auf der Microsoft-Website: "Einführung in Sicherungs- und Wiederherstellungsstrategien in SQL Server".

Typen von Sicherungen

Vollständige Datensicherung (Datenbanken) Eine vollständige Datenbanksicherung ist Voraussetzung, um die Bereitstellung wiederherstellen zu können. Eine vollständige Sicherung schließt einen Teil des Transaktionsprotokolls ein, sodass die vollständige Sicherung wiederhergestellt werden kann. Vollständige Sicherungen sind darin in sich abgeschlossen, dass sie die gesamte Datenbank in dem Zustand darstellen, in dem sie sich zum Zeitpunkt der Sicherung befand. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: "Vollständige Datenbanksicherungen".

Differenzielle Datensicherungen (Datenbanken) Eine differenzielle Datenbanksicherung zeichnet nur die Daten auf, die sich seit der letzten vollständigen Datenbanksicherung geändert haben, die als differenzielle Basis bezeichnet wird. Differenzielle Datenbanksicherungen sind kleiner und schneller als vollständige Datenbanksicherungen. Diese Option benötigt weniger Zeit für die Sicherung, büßt dabei aber eine größere Komplexität ein. Für große Datenbanken können differenzielle Sicherungen in kürzeren Intervallen auftreten als Datenbanksicherungen, die die Gefahr des Datenverlusts reduzieren. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: "Differenzielle Datenbanksicherungen".

Sie sollten die Transaktionsprotokolle ebenfalls regelmäßig sichern. Diese Sicherungen sind für das Wiederherstellen von Daten notwendig, wenn Sie das Vollständige Datenbanksicherungsmodell verwenden. Mithilfe von Transaktionsprotokollsicherungen können Sie die Datenbank bis zum Fehlerzeitpunkt oder einem anderen Zeitpunkt wiederherstellen.

Sicherungen von Transaktionsprotokollen Das Transaktionsprotokoll ist ein Seriendatensatz, in dem zusätzlich zu den Transaktionen, die Änderungen in einer Datenbank ausführen, auch sämtliche Änderungen in der Datenbank selbst aufgezeichnet werden. Das Transaktionsprotokoll zeichnet den Beginn jeder Transaktion, die Änderungen an den Daten und ggf. ausreichende Informationen auf, um die während der Transaktion durchgeführten Änderungen rückgängig zu machen. Die Protokollgröße nimmt kontinuierlich in dem Maße zu, wie protokollierte Vorgänge in der Datenbank auftreten.

Wenn Sie Transaktionsprotokolle sichern, können Sie die Datenbank so wiederherstellen, wie sie zu einem früheren Zeitpunkt war. Sie können die Datenbank beispielsweise auf einen Zeitpunkt vor der Eingabe unerwünschter Daten oder vor einem Fehler zurücksetzen. Neben Datenbanksicherungen muss Ihre Wiederherstellungsstrategie auch Transaktionsprotokollsicherungen umfassen. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: "Verwenden von Transaktionsprotokollsicherungen".

Transaktionsprotokollsicherungen benötigen im Allgemeinen weniger Ressourcen als vollständige Sicherungen. Aus diesem Grund können Sie Transaktionsprotokollsicherungen häufiger als vollständige Sicherungen erstellen und so das Risiko eines Datenverlusts verringern. Dennoch können Transaktionsprotokollsicherungen mitunter größer als vollständige Sicherungen sein. Dies ist z. B. bei Datenbanken mit einer hohen Transaktionsrate der Fall; eine hohe Transaktionsrate bewirkt, dass das Transaktionsprotokoll schnell an Größe zunimmt. In diesem Fall sollten Sie häufiger Transaktionsprotokollsicherungen erstellen. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: "Problembehandlung bei vollen Transaktionsprotokollen".

Es stehen die folgenden Sicherungstypen für Transaktionsprotokolle zur Verfügung:

  • Eine reine Protokollsicherung enthält nur Transaktionsprotokolldatensätze für ein Intervall, keine Massenänderungen.

  • Eine Massenprotokollsicherung schließt Protokoll- und Datenseiten ein, die durch Massenvorgänge geändert wurden. Die Zeitpunktwiederherstellung ist nicht zulässig.

  • Eine Sicherung des Protokollfragments wird von einer möglicherweise beschädigten Datenbank erstellt, um die noch nicht gesicherten Protokolldatensätze zu erfassen. Sicherungen des Protokollfragments werden nach Auftreten eines Fehlers erstellt, um den Verlust von Daten zu verhindern, und können entweder reine Protokoll- oder Massenprotokolldaten enthalten.

Da die Synchronisierung der Daten für die erfolgreiche Wiederherstellung von Team Foundation Server wichtig ist, sollten Sie markierte Transaktionen als Teil der Sicherungsstrategie verwenden. Weitere Informationen finden Sie unter Back Up Team Foundation Server.

Sicherungskopien von Diensten (Anwendungsebene)

Die einzige Sicherung, die auf logischer Anwendungsebene ausgeführt wird, sichert den Verschlüsselungsschlüssel von Reporting Services. Sie gehen möglicherweise davon aus, dass Sie Websites sichern müssen, die als Teamprojektportale verwendet werden. Wenn Sie SharePoint-Produkte als Teil der Bereitstellung von Team Foundation Server integriert haben, werden die Portale als Teil der Sicherung der Datenbanken für Team Foundation Server und SharePoint-Produkte gesichert. Wenn Sie jedoch eine Website angegeben haben, die nicht mit einer integrierten Webanwendung erstellt wurde, müssen Sie diese Sites manuell sichern und wiederherstellen. Wenn Sie an SharePoint-Produkte oder an Diensten außerdem Anpassungen vorgenommen haben, müssen Sie diese ebenfalls sichern oder andernfalls aufzeichnen, damit sie auf einem neuen Server reproduziert werden können.

Obwohl Sie eine Anwendungsebene einfacher als eine Datenebene sichern können, müssen Sie beim Wiederherstellen einer Anwendungsebene zahlreiche Schritte ausführen. Sie müssen eine andere Anwendungsebene für Team Foundation installieren, Teamprojektsammlungen umleiten, um die neue Anwendungsebene zu verwenden, und die Portalsites für Teamprojekte umleiten.

Siehe auch

Konzepte

Sichern und Wiederherstellen der Bereitstellung
Team Foundation Server-Datenbanken

Weitere Ressourcen

Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]


Wiederherstellen eines Servers der Anwendungsebene

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Wiederherstellen eines Servers der Anwendungsebene
Siehe auch Feedback senden

In den Datenbanken für Team Foundation werden alle Daten für die Bereitstellung von Team Foundation Server gespeichert. Auch wenn Sie den Anwendungsebenenserver sichern, sichern Sie keine Daten für Team Foundation Server. Wenn jedoch die Hardware eines Anwendungsebenenservers einen Fehler verursacht, können Sie einen weiteren Anwendungsebenenserver installieren und so konfigurieren, dass die Datenbanken für die Bereitstellung verwendet werden. Dieser Server ersetzt dann den Server, der offline ist, als Anwendungsebenenserver für die Bereitstellung. Wenn der Anwendungsebenenserver SharePoint-Produkte gehostet hat, müssen Sie auch diese Software auf der neuen Hardware wiederherstellen. Weitere Informationen finden Sie unter Sicherung (SharePoint Foundation 2010), Sicherung und Wiederherstellung (SharePoint Server 2010) und Schützen und Wiederherstellen einer Serverfarm (Office SharePoint Server 2007).

Hinweis Hinweis

Nachdem Sie eine Anwendungsebene auf neuer Hardware wiederhergestellt haben, stellen Sie sicher, dass alle Benutzer, Gruppen und Dienstkonten für die Bereitstellung mit den Berechtigungen konfiguriert sind, die sie benötigen, um erforderliche Aufgaben auszuführen. Administratoren für Team Foundation müssen z. B. Mitglieder der lokalen Gruppe Administratoren auf dem Anwendungsebenenserver sein, damit sie die Verwaltungskonsole öffnen können. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zu Teamprojekten, Festlegen von Administratorberechtigungen für Teamprojektsammlungen, Festlegen von Administratorberechtigungen für Team Foundation Server und Dienstkonten und Abhängigkeiten in Team Foundation Server.

Sie können einer Bereitstellung von Team Foundation Server auch mehr als einen Anwendungsebenenserver hinzufügen. Sie müssen jedoch Clients so konfigurieren, dass sie eine Verbindung zu diesem Server als separate Anwendungsebene herstellen. Sie können keinen automatischen Lastenausgleich zwischen Anwendungsebenenservern konfigurieren. Für den tatsächlichen Lastenausgleich und Transparenz für Clients müssen Sie zuerst ein Hardware- oder Softwaregerät für Netzwerklastenausgleich (NLB) installieren und konfigurieren.

So installieren und konfigurieren Sie einen Server als Anwendungsebenenserver

  1. Beenden Sie alle Anwendungspools und Dienste, die von Team Foundation Server verwendet werden.

    Weitere Informationen finden Sie unter Befehl "TFSServiceControl".

  2. Wenn Sie den Netzwerkdienst als Dienstkonto für Team Foundation (TFSService) verwenden, öffnen Sie auf dem Anwendungsebenenserver ein Eingabeaufforderungsfenster, und ändern Sie die Verzeichnisse in Laufwerk:%Program Files%\ Microsoft Team Foundation Server 2012\Tools. Geben Sie an der Eingabeaufforderung folgenden Befehl ein:

    TfsConfig Accounts /add /account:"NT Authority\Network Service" /SQLInstance:Servername /DatabaseName:Datenbankname

    Hinweis Hinweis

    Weitere Informationen finden Sie unter Accounts-Befehl.

  3. Installieren Sie Team Foundation Server auf dem neuen Server, und starten Sie den Assistenten "Nur für Anwendungsebenen".

  4. Wenn Sie Visual Studio Lab Management verwenden, installieren Sie die System Center Virtual Machine Manager (SCVMM)-Administratorkonsole auf der Anwendungsebene, und konfigurieren sie so, dass eine Verbindung mit dem Server hergestellt wird, der SCVMM ausführt.

    Weitere Informationen finden Sie unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

  5. Wenn sich der Computername geändert hat, öffnen Sie die Verwaltungskonsole für Team Foundation.

  6. Klicken Sie in der Navigationsleiste auf Anwendungsebene und dann auf URLs ändern.

    Das Fenster URLs ändern wird geöffnet.

  7. Geben Sie unter Benachrichtigungs-URL die URL für den neuen Anwendungsebenenserver an, und wählen Sie dann OK.

    Hinweis Hinweis

    Der Name des alten Anwendungsebenenservers wird immer noch in der Liste der Anwendungsebenenserver in der Verwaltungskonsole für Team Foundation angezeigt. Wenn Sie das Kontrollkästchen Computer herausfiltern, die mehr als drei Tage nicht verbunden waren aktivieren, wird der alte Server nach drei Tagen nicht mehr in der Liste angezeigt.

Siehe auch

Aufgaben

Öffnen der Team Foundation-Verwaltungskonsole

Konzepte

Wiederherstellen von Lab-Management-Komponenten
Architektur von Team Foundation Server

Weitere Ressourcen

Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]


Wiederherstellen von Daten an demselben Speicherort

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Wiederherstellen von Daten an demselben Speicherort
Siehe auch Feedback senden

Sie können Daten von einer Sicherung auf demselben Server und derselben Instanz von SQL Server für Team Foundation wiederherstellen, auf denen die Sicherung erstellt wurde. Sie können zum Beispiel eine Reihe von beschädigten Datenbanken in der letzten Version wiederherstellen, von der bekannt ist, dass sie unbeschädigt ist. Konfigurieren Sie als Teil der Sicherungsstrategie markierte Transaktionen, um die erfolgreiche Datenwiederherstellung sicherzustellen. Weitere Informationen finden Sie unter Back Up Team Foundation Server.

Zur Durchführung der Prozeduren in diesem Thema muss die Serverhardware ordnungsgemäß funktionieren. Wenn für die Bereitstellung SharePoint-Produkte oder Microsoft Project Server verwendet wird, müssen Sie zusätzliche Schritte entsprechend den in diesem Thema beschriebenen Prozeduren ausführen, um die Datenbanken zu sichern und wiederherzustellen. Wenn Sie Daten auf einem anderen Server oder einer anderen Instanz von SQL Server wiederherstellen möchten, finden Sie weitere Informationen unter Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm].

Hinweis Hinweis

Wenn Sie in der Bereitstellung SharePoint-Produkte verwenden, ist es beim Wiederherstellen von Daten nicht erforderlich, die Websites wiederherzustellen, die anhand der Daten für die einzelnen Teamprojekte automatisch erstellt werden. Die Daten für die Teamprojektportale sind in den Datenbanken enthalten, die Sie wiederherstellen.

Die Schritte zum Wiederherstellen der Daten auf demselben Server oder denselben Servern hängen davon ab, wie Team Foundation Server installiert und konfiguriert wurde. Der Einfachheit halber sind die Vorgänge in diesem Thema entsprechend einer nicht allzu komplexen Bereitstellung von Team Foundation Server strukturiert, wie in der folgenden Abbildung dargestellt:

Beispiel für Topologie mittlerer Komplexität mit Datenbanken

Wenn die von Ihnen verwendete Topologie nicht genau diesem Beispiel entspricht, müssen Sie die Schritte für diesen Vorgang möglicherweise anpassen, damit Sie diesen erfolgreich durchführen können. Wenn Sie z. B. über eine Bereitstellung verfügen, bei der alle Komponenten auf einem einzelnen physischen Server installiert sind, würden Sie alle Vorgänge auf diesem Server ausführen. Wenn Datenbanken für Teamprojektsammlungen auf mehr als einem Server bereitgestellt werden, müssen Sie die Schritte ausführen, um jede Auflistungsdatenbank auf dem entsprechenden Server wiederherzustellen. Weitere Informationen darüber, welche Komponenten auf den einzelnen Servern bereitgestellt werden können, finden Sie in den folgenden Themen:

  • Grundlagen zum Sichern von Team Foundation Server

  • Architektur von Team Foundation Server

  • Beispiele für die einfache Topologie

  • Beispiele für Topologie mit mittlerer Komplexität

  • Beispiele für die komplexe Topologie

In diesem Thema

  1. Erforderliche Berechtigungen

  2. Beenden der von Team Foundation Server verwendeten Dienste

  3. Wiederherstellen von Team Foundation-Datenbanken

  4. Aktualisieren aller Dienstkonten

  5. Wiederherstellen des Warehouses

  6. Löschen des Datencache auf Servern

  7. Neustarten von Diensten, die von Team Foundation Server verwendet werden

  8. Aktualisieren des Datencaches auf Clientcomputern

Erforderliche Berechtigungen

Um diesen Vorgang auszuführen, müssen Sie Mitglied der folgenden Gruppen sein oder über folgende Berechtigungen verfügen:

  • Mitglied der Sicherheitsgruppe Administratoren auf dem Server oder den Servern, auf denen die Verwaltungskonsole für Team Foundation ausgeführt wird.

  • Mitglied der Sicherheitsgruppe SQL Server-Systemadministrator, oder die Berechtigung SQL Server-Berechtigungen zum Erstellen von Sicherungskopien und zum Erstellen von Wartungsplänen muss in der Instanz von SQL Server, in der die Datenbanken gehostet werden, auf Zulassen festgelegt sein.

  • Mitglied der sysadmin-Sicherheitsgruppe für die Datenbankinstanz für Team Foundation und für die Analysis Services-Instanz der Warehouse-Datenbank.

  • Autorisierter Benutzer der TFS_Warehouse-Datenbank.

  • Mitglied der TFSEXECROLE-Datenbankrolle.

  • Wenn für die Bereitstellung SharePoint-Produkte verwendet werden, Mitglied der Farmadministratoren-Gruppe für die Farm, auf der die Datenbanken für SharePoint-Produkte wiederhergestellt werden.

Zusätzlich zu diesen Berechtigungen müssen Sie auf einem Computer unter Windows Server 2008 gegebenenfalls Folgendes durchführen:

  • Zum Ausführen von Befehlszeilenprozeduren müssen Sie möglicherweise eine Eingabeaufforderung mit erhöhten Rechten öffnen. Klicken Sie dazu auf Start, klicken Sie anschließend mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen.

  • Zum Ausführen einer Prozedur, für die Internet Explorer erforderlich ist, müssen Sie Internet Explorer möglicherweise als Administrator starten. Klicken Sie dazu auf Start und Alle Programme und dann mit der rechten Maustaste auf Internet Explorer. Klicken Sie anschließend auf Als Administrator ausführen.

  • Für den Zugriff auf den Berichts-Manager, Berichte oder Websites für SQL Server Reporting Services müssen Sie diese Websites möglicherweise in Internet Explorer der Liste der vertrauenswürdigen Websites hinzufügen oder Internet Explorer als Administrator starten.

Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Benutzerkontensteuerung.

Beenden der von Team Foundation Server verwendeten Dienste

So beenden Sie von Team Foundation Server verwendete Dienste

  1. Öffnen Sie auf dem Server, auf dem die Anwendungsebenendienste für Team Foundation ausgeführt werden, ein Eingabeaufforderungsfenster, und ändern Sie die Verzeichnisse in Laufwerk:\%programfiles%\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie folgenden Befehl ein:

    TFSServiceControl quiesce

    Weitere Informationen finden Sie unter Befehl "TFSServiceControl".

Wiederherstellen von Team Foundation-Datenbanken

Nachdem Sie die Dienste beendet haben, können Sie die Daten für Team Foundation wiederherstellen, indem Sie die von SQL Server bereitgestellten Wiederherstellungstools verwenden.

Warnhinweis Vorsicht

Alle Datenbanken müssen auf den gleichen Zeitpunkt wiederhergestellt werden. Andernfalls sind die Datenbanken nicht mehr synchron. In den folgenden Prozeduren wird davon ausgegangen, dass Sie markierte Transaktionen verwenden, damit die Synchronisierung der von Team Foundation Server verwendeten Datenbanken sichergestellt ist. Weitere Informationen finden Sie unter Back Up Team Foundation Server. Wenn für die Bereitstellung SharePoint-Produkte verwendet werden, müssen Sie der Anleitung für die Version des betreffenden Produkts in der Bereitstellung folgen. Weitere Informationen finden Sie unter Sicherung und Wiederherstellung (SharePoint Foundation 2010), Sicherung und Wiederherstellung (SharePoint Server 2010) und Schützen und Wiederherstellen einer Serverfarm (Office SharePoint Server 2007). Wenn die Bereitstellung mit Microsoft Project Server integriert wurde, folgen Sie der Anleitung für die entsprechende Version dieses Produkts in der Bereitstellung. Weitere Informationen finden Sie unter Wiederherstellen von Datenbanken (Project Server 2007) und Wiederherstellen von Datenbanken (Project Server 2010).

So öffnen Sie das Dialogfeld Datenbank wiederherstellen

  1. Melden Sie sich bei dem Server an, auf dem Sie Datenbanken wiederherstellen möchten.

  2. Wählen Sie Start und anschließend Alle Programme. Wählen Sie danach Microsoft SQL Server 2008 gefolgt von SQL Server Management Studio.

    Hinweis Hinweis

    Weitere Informationen zum Wiederherstellen von Datenbanken finden Sie auf der folgenden Seite auf der Microsoft-Website: Implementieren von Wiederherstellungsszenarien für SQL Server-Datenbanken.

    Das Dialogfeld Mit Server verbinden wird angezeigt.

  3. Wählen Sie unter Servertyp die Option Datenbankmodul.

  4. Wählen Sie unter Servername den Namen des Datenebenenservers und der Datenbankinstanz, oder geben Sie diese ein, und wählen Sie dann Verbinden.

    Hinweis Hinweis

    Wenn SQL Server in einem Cluster installiert ist, entspricht der Servername nicht dem Computernamen, sondern dem Namen des Clusters.

    SQL Server Management Studio wird geöffnet.

  5. Erweitern Sie den Knoten Datenbanken, um die Liste der Datenbanken anzuzeigen, aus denen sich die Datenebene für Team Foundation zusammensetzt.

Schließen Sie den nächsten Vorgang "So stellen Sie eine Datenbank wieder her" für jede der folgenden Datenbanken auf jedem Server ab, von dem diese ursprünglich stammen:

Auf dem Server oder den Servern, die die Datenbanken für Team Foundation Server hosten:

  • TFS_Configuration

    Hinweis Hinweis

    Dieser Datenbankname kann zwischen TFS_ und Configuration weitere Zeichen enthalten.

  • TFS_CollectionName

    Hinweis Hinweis

    Jede Teamprojektsammlung verfügt über eine eigene Datenbank. Wenn Sie z. B. über fünf Teamprojektsammlungen verfügen, haben Sie fünf Datenbanken, die jeweils durch den Namen der Teamprojektsammlung gekennzeichnet sind. Diese Datenbanken können sich auf der gleichen Instanz von SQL Server, auf separaten Instanzen oder auf separaten physischen Servern befinden. Sie müssen jede Datenbank sichern und anschließend auf dem Server und der Instanz wiederherstellen, von denen diese ursprünglich jeweils stammen.

  • VirtualManagerDB

    In der Verwaltungsdatenbank für System Center Virtual Machine Manager (SCVMM) sind die Informationen enthalten, die Sie in der SCVMM-Administratorkonsole anzeigen, z. B. virtuelle Computer, Hosts für virtuelle Computer und Bibliotheksserver für virtuelle Computer sowie deren jeweilige Eigenschaften.

    Hinweis Hinweis

    Wenn SCVMM auf einem anderen Server als Team Foundation Server installiert ist, ist diese Datenbank möglicherweise nicht auf dem Datenebenenserver für Team Foundation vorhanden. In dem Fall müssen Konfiguration, Sicherung und Wiederherstellung unabhängig von Team Foundation Server erfolgen. Sie sollten jedoch markierte Transaktionen verwenden und die Wartung der Datenbanken synchronisieren, um Synchronisierungsfehler zu vermeiden.

Auf dem Server, der SQL Server Reporting Services ausführt, wenn für die Bereitstellung konfiguriert:

  • ReportServer

    Hinweis Hinweis

    Wenn Sie eine benannte Instanz verwendet haben, erhält diese Datenbank den Namen ReportServer$InstanceName.

  • ReportServerTempDB

    Hinweis Hinweis

    Wenn Sie eine benannte Instanz verwendet haben, erhält diese Datenbank den Namen ReportServerTempDB$InstanceName.

Auf dem Server oder den Servern, auf denen SharePoint-Produkte ausgeführt werden, wenn Sie die Bereitstellung mit einer oder mehreren SharePoint-Webanwendungen konfiguriert haben:

  • Die Verwaltungsdatenbank für SharePoint-Produkte (WSS_AdminContent), wenn Sie die gesamte Bereitstellung von SharePoint-Produkte wiederherstellen.

  • Die Konfigurationsdatenbank für SharePoint-Produkte (WSS_Config).

  • Die Inhaltsdatenbank für SharePoint-Produkte (WSS_Content).

    Hinweis Hinweis

    Die Namen der Datenbanken, die Daten für SharePoint-Produkte enthalten, hängen davon ab, welche Version von SharePoint-Produkte installiert ist und ob der Name der Datenbank von der Person, die die Software installiert hat, geändert wurde. Außerdem sind diese Datenbanken u. U. auf dem Datenebenenserver nicht vorhanden, wenn SharePoint-Produkte getrennt von Team Foundation Server auf einem anderen Server installiert wurde. Wenn sich die Datenbanken auf einem anderen Server befinden, müssen Sie ihre Sicherung, Wiederherstellung und Konfiguration getrennt von Team Foundation Server verwalten. Sie sollten jedoch die Wartung der Datenbanken synchronisieren, um Synchronisierungsfehler zu vermeiden.

    Zum Wiederherstellen der von SharePoint-Produkte verwendeten Datenbanken müssen Sie der Anleitung für die in der Bereitstellung verwendete Produktversion folgen. Weitere Informationen finden Sie unter Sicherung und Wiederherstellung (SharePoint Foundation 2010), Sicherung und Wiederherstellung (SharePoint Server 2010) und Schützen und Wiederherstellen einer Serverfarm (Office SharePoint Server 2007).

Auf dem Server oder den Servern, die Microsoft Project Server ausführen, sofern Sie die Bereitstellung in Project Server integriert haben und die Datenbanken auf einem anderen Server wiederherstellen müssen:

  • Die Datenbanken, von denen die Bereitstellung von Project Server abhängig ist. Weitere Informationen finden Sie unter Wiederherstellen von Datenbanken (Project Server 2007) oder Wiederherstellen von Datenbanken (Project Server 2010).

Wenn Sie nicht beabsichtigen, das Warehouse neu zu erstellen:

  • TFS_Warehouse

    Hinweis Hinweis

    Dieser Datenbankname kann zwischen TFS_ und Warehouse weitere Zeichen enthalten.

  • TFS_Analysis

Weitere Informationen zu diesen Datenbanken finden Sie unter Grundlagen zum Sichern von Team Foundation Server.

So stellen Sie eine Datenbank wieder her

  1. Markieren Sie Datenbanken im Objekt-Explorer, öffnen Sie das Untermenü, und wählen Sie dann Datenbank wiederherstellen aus.

    Das Dialogfeld Datenbank wiederherstellen wird angezeigt.

  2. Geben Sie unter In Datenbank den Namen der Datenbank ein, die Sie wiederherstellen möchten, beispielsweise TFS_Configuration. Klicken Sie unter Quelle für die Wiederherstellung auf Von Medium und dann auf die Schaltfläche mit den drei Auslassungszeichen (...).

  3. Klicken Sie im Dialogfeld Sicherung angeben auf Hinzufügen. Geben Sie den Speicherort der Sicherungsdatei für die Datenbank an, die Sie wiederherstellen möchten, und wählen Sie dann zweifach OK aus.

    Sie müssen zunächst die vollständige Sicherung wiederherstellen, danach die differenzielle Sicherung und zuletzt die Transaktionsprotokollsicherungen - in der Reihenfolge, in der diese erstellt wurden.

  4. Aktivieren Sie unter Wählen Sie die wiederherzustellenden Sicherungssätze aus die Kontrollkästchen für die Sicherungssätze, die wiederhergestellt werden sollen.

    Stellen Sie sicher, dass Sie die vollständigen, die differenziellen und die Transaktionsprotokolldatenbanken wiederherstellen, wenn Sie Sicherungssätze mit markierten Transaktionen erstellt haben.

  5. Klicken Sie im Bereich Seite auswählen auf Optionen, und aktivieren Sie dann das Kontrollkästchen Vorhandene Datenbank überschreiben.

  6. Überprüfen Sie, ob die Pfade in der Liste Datenbankdateien wiederherstellen als mit den aktuellen Datenbankpfaden übereinstimmen.

  7. Wählen Sie unter Wiederherstellungsstatus die Option Datenbank nicht betriebsbereit belassen und kein Rollback für Transaktionen ohne Commit ausführen. Zusätzliche Transaktionsprotokolle können nicht wiederhergestellt werden. (RESTORE WITH RECOVERY); wählen Sie dann OK.

    Eine Statusanzeige wird angezeigt.

  8. Wenn das SQL Server Management Studio-Dialogfeld angezeigt wird und die Wiederherstellung als erfolgreich bestätigt wird, wählen Sie OK aus, um zum Objekt-Explorer zurückzukehren.

  9. Öffnen Sie das Kontextmenü für die Datenbank, die Sie eben wiederhergestellt haben, und wählen Sie Aufgaben, Wiederherstellen und dann Transaktionsprotokoll aus.

    Das Fenster Transaktionsprotokoll wiederherstellen wird angezeigt.

  10. Stellen Sie sicher, dass auf der Seite Allgemein in der Liste Datenbank die entsprechende Datenbank hervorgehoben ist.

  11. Aktivieren Sie unter Transaktionsprotokoll auswählen, das wiederhergestellt werden soll das Kontrollkästchen neben dem Protokoll, das Sie wiederherstellen möchten.

  12. Klicken Sie unter Wiederherstellen in auf Markierte Transaktion.

    Das Fenster Markierte Transaktion auswählen wird geöffnet.

  13. Aktivieren Sie in der Liste Wählen Sie die markierte Transaktion aus, an der die Wiederherstellung beendet werden soll das Kontrollkästchen neben der Transaktionsmarkierung, die Sie für die Wiederherstellung verwenden möchten, und klicken Sie dann auf OK.

    Wichtiger Hinweis Wichtig

    Sie müssen dieselbe Transaktionsmarkierung mit demselben Datum und derselben Uhrzeit für alle Datenbanken verwenden, um die Daten erfolgreich wiederherzustellen.

  14. Klicken Sie im Fenster Transaktionsprotokoll wiederherstellen auf OK.

    Eine Statusanzeige wird angezeigt.

  15. Wählen Sie OK aus, wenn das SQL Server Management Studio-Dialogfeld angezeigt wird und die Wiederherstellung als erfolgreich bestätigt wird.

    Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Anwenden von Transaktionsprotokollsicherungen.

Hinweis Hinweis

Wenn Sie die Datenbanken für Reporting Services wiederhergestellt haben, müssen Sie auch den Verschlüsselungsschlüssel für diese Datenbanken wiederherstellen.

So stellen Sie den Verschlüsselungsschlüssel für Reporting Services wieder her

  1. Wählen Sie nacheinander Start, Alle Programme und Microsoft SQL Server R2 aus. Anschließend wählen Sie Konfigurationstools und dann Konfigurations-Manager für Reporting Services aus.

  2. Geben Sie unter Konfigurationsverbindung für Reporting Services den Namen des Servers an, und wählen Sie dann Verbinden aus.

    In der Beispielsbereitstellung unter Servername gibt Jill FABRIKAMPRIME unter Servername ein. Da sie die Standardinstanz verwendet, muss sie den Standardinstanznamen MSSQLSERVER nicht ändern.

  3. Wählen Sie im Bereich Verbinden die Option Verschlüsselungsschlüssel und im Bereich "Verschlüsselungsschlüssel" die Option Wiederherstellen aus.

    Das Fenster Verschlüsselungsschlüssel wiederherstellen wird geöffnet.

  4. Geben Sie unter Dateispeicherort den Speicherort der Sicherungsdatei für den Verschlüsselungsschlüssel an. Geben Sie unter Kennwort das Kennwort an, das Sie bei der Sicherung des Verschlüsselungsschlüssels verwendet haben, und wählen Sie dann OK aus.

  5. Der Status der Wiederherstellung wird unter Ergebnisse angezeigt. Wenn im Bereich Ergebnisse angezeigt wird, dass der Verschlüsselungsschlüssel wiederhergestellt wurde, schließen Sie den Konfigurations-Manager für Reporting Services.

Aktualisieren aller Dienstkonten

Sie müssen das Dienstkonto für Team Foundation Server (TFSService) und das Datenquellenkonto (TFSReports) aktualisieren. Auch wenn sich diese Konten nicht geändert haben, müssen Sie die Informationen aktualisieren, um sicherzustellen, dass Identität und Format der Konten geeignet sind.

So aktualisieren Sie Dienstkonten

  1. Öffnen Sie den Computer-Manager auf dem Server, auf dem SQL Server Reporting Services ausgeführt wird, und starten Sie die folgenden Komponenten, sofern diese noch nicht gestartet wurden:

    • ReportServer oder ReportServer$InstanceName (Anwendungspool)

    • SQL Server Reporting Services (TFSINSTANCE)

  2. Öffnen Sie auf dem Anwendungsebenenserver ein Eingabeaufforderungsfenster, und ändern Sie die Verzeichnisse in Laufwerk:\%programfiles%\ Microsoft Team Foundation Server 2012\Tools.

  3. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, um das Dienstkonto für Team Foundation hinzuzufügen, wobei Datenbankname der Name der Konfigurationsdatenbank (standardmäßig TFS_Configuration) ist:

    TfsConfig Accounts /add /AccountType:ApplicationTier /account:AccountName

    Weitere Informationen zum Verwenden dieses Befehls finden Sie unter Accounts-Befehl.

  4. Verwenden Sie den Accounts-Befehl, um das Datenquellenkonto für den Berichtsserver und das Proxykonto für Team Foundation Server Proxy hinzuzufügen, sofern diese Ressourcen von der Bereitstellung verwendet werden.

Neuerstellen des Warehouses

Sie können das Data Warehouse neu erstellen, statt die Datenbanken TFS_Warehouse und TFS_Analysis wiederherzustellen. Die Neuerstellung des Warehouses kann lange dauern, wenn die Bereitstellung viele Daten enthält. Mit dieser Strategie können Sie jedoch sicherstellen, dass alle Daten richtig synchronisiert werden. Wenn Sie das Warehouse neu erstellen, wird von Team Foundation Server eine Instanz davon erstellt, die Sie dann für die Auffüllung mit Daten aus den betriebsinternen Speichern verarbeiten müssen.

Hinweis Hinweis

Wenn Sie die TFS_Warehouse- und die TFS_Analysis-Datenbanken im vorherigen Abschnitt wiederhergestellt haben, müssen Sie den folgenden Vorgang nicht ausführen.

So erstellen Sie das Warehouse neu

  1. Öffnen Sie auf dem Server, auf dem die Anwendungsebenendienste für Team Foundation ausgeführt werden, ein Eingabeaufforderungsfenster, und ändern Sie die Verzeichnisse in Laufwerk:\%programfiles%\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie folgenden Befehl ein:

    TFSConfig rebuildwarehouse /all /ReportingDataSourcePassword:Kennwort

    wobei Kennwort das Kennwort des Datenquellenkontos für Reporting Services (TFSReports) ist.

  3. Warten Sie, bis der Befehl erfolgreich ausgeführt wurde.

    Hinweis Hinweis

    Wenn der Befehl nicht erfolgreich ausgeführt wurde, sollten Sie überprüfen, ob Sie über alle erforderlichen Berechtigungen verfügen. Weitere Informationen finden Sie unter Troubleshooting the Data Warehouse.

  4. Öffnen Sie auf dem Berichtsserver Internet Explorer, und geben Sie in der Adressleiste die folgende Zeichenfolge ein:

    http://localhost:8080/Virtuelles_Verzeichnis/TeamFoundation/Administration/v3.0/WarehouseControlService.asmx

    Geben Sie für VirtuellesVerzeichnis das virtuelle Verzeichnis für Internetinformationsdienste (IIS) ein, das bei der Installation von Team Foundation Server angegeben wurde. Standardmäßig heißt dieses Verzeichnis tfs.

    Die Seite WarehouseControlWebService wird angezeigt.

    Hinweis Hinweis

    Der Microsoft Team Foundation Server-Anwendungspool muss ausgeführt werden, damit der Warehouse Control-Webdienst verfügbar ist.

  5. Wählen Sie GetProcessingStatus und anschließend Aufrufen aus.

    Wichtiger Hinweis Wichtig

    Von dem Dienst muss der Wert Leerlauf zurückgegeben werden, mit dem angegeben wird, dass der Cube nicht verarbeitet wird. Wiederholen Sie diesen Schritt, solange ein anderer Wert zurückgegeben wird, bis der Wert für alle Aufträge Leerlauf ist.

  6. Wählen Sie auf der Seite WarehouseControlWebService die Option ProcessAnalysisDatabase und dann Aufrufen aus.

    Ein Browserfenster wird geöffnet. Von dem Dienst wird True zurückgegeben, wenn die Verarbeitung des Cubes erfolgreich gestartet wurde, und False, wenn der Start nicht erfolgreich war oder der Cube gerade verarbeitet wird.

  7. Kehren Sie zu der Seite WarehouseControlWebService zurück, und wählen Sie GetProcessingStatus und anschließend Aufrufen, um festzustellen, wann der Cube verarbeitet wurde.

    Die Verarbeitung ist abgeschlossen, wenn von dem GetProcessingStatus-Dienst für alle Aufträge der Wert Leerlauf zurückgegeben wird.

  8. Öffnen Sie auf dem Anwendungsebenenserver für Team Foundation die Computer Management, und starten Sie den Hintergrundauftrags-Agenten für Visual Studio Team Foundation.

Neustarten von Diensten, die von Team Foundation Server verwendet werden

Nachdem Sie die Daten wiederhergestellt haben, müssen Sie die Dienste neu starten, damit der Server wieder betriebsbereit ist.

So starten Sie von Team Foundation Server verwendete Dienste erneut

  1. Öffnen Sie auf dem Server, auf dem die Anwendungsebenendienste für Team Foundation ausgeführt werden, ein Eingabeaufforderungsfenster, und ändern Sie die Verzeichnisse in Laufwerk:\%programfiles%\Microsoft Team Foundation Server 2012\Tools.

  2. Geben Sie folgenden Befehl ein:

    TFSServiceControl unquiesce

    Weitere Informationen finden Sie unter Befehl "TFSServiceControl".

Aktualisieren des Caches auf Clientcomputern

So aktualisieren Sie den Cache für die Verfolgung von Arbeitsaufgaben auf Clientcomputern

  1. Öffnen Sie Internet Explorer auf dem neuen Server.

  2. Geben Sie in der Adressleiste die folgende Adresse ein, um eine Verbindung mit dem ClientService-Webdienst herzustellen.

    http://ÖffentlicheURL/VirtuellesVerzeichnis:8080/WorkItemTracking/v3.0/ClientService.asmx

    Hinweis Hinweis

    Auch wenn Sie mit Administratorrechten angemeldet sind, müssen Sie möglicherweise Internet Explorer als Administrator starten, und Sie werden unter Umständen zur Eingabe Ihrer Anmeldeinformationen aufgefordert.

  3. Wählen Sie StampWorkitemCache und anschließend Aufrufen aus.

    Hinweis Hinweis

    Die StampWorkitemCache-Methode gibt keine Daten zurück.

So aktualisieren Sie den Cache für die Versionskontrolle auf Clientcomputern

  1. Öffnen Sie auf dem Clientcomputer ein Eingabeaufforderungsfenster mit Administratorberechtigungen, und ändern Sie die Verzeichnisse in " Laufwerk:\Programme (x86)\Microsoft Visual Studio 11.0\Common7\IDE".

  2. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, darunter auch die URL der Auflistung, die den Servernamen und die Portnummer des neuen Servers enthält:

    tf workspaces /collection:http://ServerName:Port/NameVirtuellesVerzeichnis/Sammlungsname

    In der Beispielsbereitstellung muss einer von Jills Entwicklern den Cache für die Versionskontrolle für ein Projekt aktualisieren, das ein Mitglied der Auflistung "DefaultCollection" ist, das in der FabrikamPrime-Bereitstellung von Team Foundation Server gehostet wird. Er gibt die folgende Zeichenfolge ein:

    tf workspaces /collection:http://FabrikamPrime:8080/tfs/DefaultCollection

    Weitere Informationen finden Sie unter Workspaces Command.

Siehe auch

Konzepte

Team Foundation Server-Berechtigungen
Architektur von Team Foundation Server
Wiederherstellen von Datenbanken
Wiederherstellen von Lab-Management-Komponenten

Weitere Ressourcen

Team Foundation Server-Dienste und -Dienstkonten
Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]
Managing Data
Managing Team Foundation Server


Aktualisieren der Datencaches auf Clientcomputern

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Aktualisieren der Datencaches auf Clientcomputern
Siehe auch Feedback senden

Um während Versionskontroll- oder Buildvorgängen in Team Foundation Fehler im Arbeitsbereich zu verhindern, muss der Datencache auf Clientcomputern nach bestimmten Wartungsvorgängen aktualisiert werden. Nach dem Verschieben, Wiederherstellen, Umbenennen oder Failover eines Datenebenen- oder Anwendungsebenenservers oder nach dem Wiederherstellen aufgrund eines Hardwarefehlers müssen Sie den Cache für die Verfolgung von Arbeitsaufgaben aktualisieren, und die Benutzer müssen den Cache für die Versionskontrolle auf den Clientcomputern aktualisieren.

Erforderliche Berechtigungen

Um die StampWorkitemCache-Webmethode aufzurufen, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Anwendungsebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen

Um den tf workspaces-Befehl auf dem Clientcomputer verwenden zu können, muss die Read-Berechtigung auf Allow festgelegt sein.

Aktualisieren des Arbeitsaufgabencaches

Hinweis Hinweis

Diese Prozedur ist optional. Sie sollten diese nur ausführen, wenn Fehler bei der Verfolgung von Arbeitsaufgaben auftreten.

Um den Cache für die Verfolgung von Arbeitsaufgaben zu aktualisieren, rufen Sie die StampWorkitemCache-Webmethode auf. Durch diese Methode wird erzwungen, dass Clientcomputer den Cache aktualisieren, wenn das nächste Mal eine Verbindung zum Anwendungsebenenserver hergestellt wird. Darüber hinaus werden durch diese Methode die auf den Clientcomputern definierten Arbeitsbereiche synchronisiert.

Hinweis Hinweis

Wenn Sie die StampWorkitemCache-Webmethode aufrufen, kann dies die Leistung von Visual Studio Team Foundation Server vorübergehend beeinträchtigen. Die Leistungseinbußen hängen davon ab, wie viele Team Foundation-Benutzer beim Aufruf der Methode verbunden sind.

So aktualisieren Sie den Cache für die Verfolgung von Arbeitsaufgaben auf Clientcomputern

  1. Öffnen Sie Internet Explorer auf dem neuen Server.

  2. Geben Sie in der Adressleiste die folgende Adresse ein, um eine Verbindung mit dem ClientService-Webdienst herzustellen.

    http://ÖffentlicheURL/VirtuellesVerzeichnis:8080/WorkItemTracking/v3.0/ClientService.asmx

    Hinweis Hinweis

    Auch wenn Sie mit Administratorrechten angemeldet sind, müssen Sie möglicherweise Internet Explorer als Administrator starten, und Sie werden unter Umständen zur Eingabe Ihrer Anmeldeinformationen aufgefordert.

  3. Wählen Sie StampWorkitemCache und anschließend Aufrufen aus.

    Hinweis Hinweis

    Die StampWorkitemCache-Methode gibt keine Daten zurück.

Aktualisieren des Caches für die Versionskontrolle

Zum Aktualisieren des Caches für die Versionskontrolle führt der Benutzer den Befehl tf workspaces auf allen zu aktualisierenden Computern aus. Es müssen alle Computer aktualisiert werden, die die Versionskontrolle verwenden und die eine Verbindung zu einer Teamprojektsammlung herstellen, deren Datenbanken verschoben wurden.

So aktualisieren Sie den Cache für die Versionskontrolle auf Clientcomputern

  1. Öffnen Sie auf dem Clientcomputer ein Eingabeaufforderungsfenster mit Administratorberechtigungen, und ändern Sie die Verzeichnisse in " Laufwerk:\Programme (x86)\Microsoft Visual Studio 11.0\Common7\IDE".

  2. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, darunter auch die URL der Auflistung, die den Servernamen und die Portnummer des neuen Servers enthält:

    tf workspaces /collection:http://ServerName:Port/NameVirtuellesVerzeichnis/Sammlungsname

    In der Beispielsbereitstellung muss einer von Jills Entwicklern den Cache für die Versionskontrolle für ein Projekt aktualisieren, das ein Mitglied der Auflistung "DefaultCollection" ist, das in der FabrikamPrime-Bereitstellung von Team Foundation Server gehostet wird. Er gibt die folgende Zeichenfolge ein:

    tf workspaces /collection:http://FabrikamPrime:8080/tfs/DefaultCollection

    Weitere Informationen finden Sie unter Workspaces Command.

Siehe auch

Aufgaben

Öffnen der Team Foundation-Verwaltungskonsole

Weitere Ressourcen

Workspaces Command
Managing Data


Wiederherstellen von Lab-Management-Komponenten

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Wiederherstellen von Lab-Management-Komponenten
Siehe auch Feedback senden

Sie können eine oder mehrere fehlgeschlagene Komponenten von Visual Studio Lab Management wiederherstellen, indem Sie den Prozeduren in diesem Thema folgen. Sie können basierend auf den fehlgeschlagenen Komponenten entscheiden, welche Prozeduren abgeschlossen werden sollen, aber Sie sollten die Prozeduren in der folgenden Reihenfolge abschließen:

  1. Wiederherstellen des Bibliotheksservers von für System Center Virtual Machine Manager (SCVMM)

  2. Wiederherstellen des Servers, auf dem SCVMM ausgeführt wird

  3. Wiederherstellen von Team Foundation Server

  4. Wiederherstellen der Hyper-V-Hosts

Wenn Sie der empfohlenen Reihenfolge folgen, erkennt Team Foundation Server alle virtuellen Computer, Vorlagen, Hosts und anderen Objekte in SCVMM. Team Foundation Server erkennt jedoch keine Objekte, die aus SCVMM gelöscht wurden, nachdem es gesichert worden ist, aber bevor Team Foundation Server gesichert wurde. Sie können diese Objekte aus Microsoft Test Manager entfernen, wie weiter unten in diesem Thema beschrieben.

Bevor Sie diese Prozeduren abschließen können, müssen die folgenden Bedingungen erfüllt sein:

  • Die Netzwerknamen der neuen Computer müssen mit den Namen der Computer übereinstimmen, die ersetzt wurden.

  • Alle Sicherheitskonten müssen wiederhergestellt worden sein.

  • Alle Softwareanwendungen müssen auf den gleichen Zustand wiederhergestellt worden sein.

Erforderliche Berechtigungen

Um diese Prozedur ausführen zu können, müssen Sie Mitglied der folgenden Gruppen sein:

  • Die Sicherheitsgruppe Administratoren auf dem Server, der die Verwaltungskonsole für Team Foundation ausführt.

  • Die Sicherheitsgruppe SQL Server-Systemadministrator oder Ihre SQL Server-Berechtigungen zum Erstellen von Sicherungskopien und Wartungsplänen müssen auf jeder Instanz von SQL Server, die die zu sichernden Datenbanken hostet, auf Zulassen festgelegt werden.

  • Die Benutzerrolle Administrator in SCVMM.

Wiederherstellen des Bibliotheksservers für SCVMM

Stellen Sie beim Wiederherstellen des Bibliotheksservers sicher, dass Sie den gleichen Hostnamen und die gleichen Bibliotheksfreigaben verwenden. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Sichern und Wiederherstellen der SCVMM-Datenbank.

Wiederherstellen des Servers, auf dem SCVMM ausgeführt wird

So stellen Sie den Server wieder her, auf dem SCVMM ausgeführt wird

  1. Stellen Sie den Server wieder her, der SCVMM ausführt, und geben Sie ihm den Computernamen des alten Servers.

    Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Sichern und Wiederherstellen der SCVMM-Datenbank.

  2. Stellen Sie sicher, dass der Computername des Anwendungsebenenservers für Team Foundation Mitglied der Gruppe "Administratoren" auf dem Server ist, auf dem SCVMM ausgeführt wird.

  3. Fügen Sie Hostgruppen oder Bibliotheksfreigaben hinzu, die nach der letzten Sicherung hinzugefügt wurden, oder entfernen Sie sie. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Sichern und Wiederherstellen der SCVMM-Datenbank.

Wiederherstellen von Team Foundation Server

Wenn Team Foundation Server fehlgeschlagen ist, müssen Sie den Anwendungsebenen- und den Datenebenenserver wiederherstellen, aus denen sich die Bereitstellung zusammensetzt. Diese Komponenten könnten auf dem gleichen Server oder mehreren Servern gehostet werden.

So stellen Sie Team Foundation Server wieder her

  1. Stellen Sie den Server oder die Server wieder her, die Team Foundation Server ausführen.

    Weitere Informationen finden Sie unter Wiederherstellen eines Servers der Anwendungsebene, Wiederherstellen von Daten an demselben Speicherort, Restore Data to a Different Server or Instance oder Restore a Single Server Deployment to New Hardware.

    Der Computername, die Konten und die Software müssen alle auf den gleichen Zustand zurückgesetzt werden. Der Computer muss mit der Domäne verknüpft und verbunden werden.

    Wenn Sie Team Foundation Server auf einem neuen Computer wiederherstellen, müssen Sie die Benachrichtigungs-URL für Lab Management entsprechend der URL des neuen Computers aktualisieren. Weitere Informationen zum Festlegen der Lab-URL in der Team Foundation-Verwaltungskonsole finden Sie unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

  2. Stellen Sie sicher, dass das Benutzerkonto, unter dem Team Foundation Server ausgeführt wird, Mitglied der Gruppe "Administratoren" auf dem Server mit SCVMM ist. Wenn Team Foundation Server als Netzwerkdienst ausgeführt wird, sollte das Konto TFS_MACHINE$ Mitglied der Gruppe "Administratoren" auf dem Server mit SCVMM sein.

  3. Führen Sie die folgenden Schritte aus, um sicherzustellen, dass das Benutzerkonto, unter dem Team Foundation Server ausgeführt wird, Mitglied der Gruppe "Administratoren" auf allen Hyper-V-Hosts ist.

    1. Öffnen Sie die Verwaltungskonsole von Team Foundation.

    2. Klicken Sie auf die Registerkarte Lab-Management, auf Hostgruppen konfigurieren und dann auf Überprüfen.

    3. Geben Sie an der entsprechenden Eingabeaufforderung den Benutzernamen und das Kennwort eines Mitglieds der Gruppe "Administratoren" auf allen Hyper-V-Hosts ein. Das Dienstkonto für Team Foundation Server wird automatisch konfiguriert.

    4. Wiederholen Sie die Schritte b und c für jede Teamprojektsammlung.

  4. Löschen Sie in SCVMM manuell alle virtuellen Computer, die nach dem Punkt erstellt wurden, auf den Sie Team Foundation Server wiederhergestellt haben.

    Diese Computer werden in Microsoft Test Manager und Microsoft Environment Viewer nicht angezeigt. Sie finden sie in SCVMM, indem Sie im Beschreibungsfeld des virtuellen Computers nach dem Teamprojektnamen suchen.

  5. Löschen Sie in Microsoft Test Manager manuell alle virtuellen Computer, die nach dem Punkt gelöscht wurden, auf den Sie Team Foundation Server wiederhergestellt haben.

    Diese Computer sind nicht mehr in SCVMM vorhanden. In Microsoft Test Manager und Microsoft Environment Viewer hat die Umgebung den Status Fehler, und die virtuellen Computer haben den Status Gelöscht. Wenn ein Host zu einer SCVMM-Hostgruppe hinzugefügt wurde, die bereits einer Teamprojektsammlung zugeordnet war, steht der Host für die Ersetzung zur Verfügung, wenn Sie nächstes mal eine Umgebung bereitstellen.

  6. Löschen Sie in Microsoft Test Manager manuell alle Hosts, die nach dem Punkt, auf den Sie Team Foundation Server wiederhergestellt haben, aus SCVMM entfernt wurden.

    Da diese Hosts keine virtuellen Computer und Umgebungen mehr ausführen können, werden alle Umgebungen auf diesen Hosts in Microsoft Test Manager und Microsoft Environment Viewer als Fehler angezeigt.

  7. Ordnen Sie alle Hostgruppen, die einer Teamprojektsammlung und einem Teamprojekt nach dem Punkt zugeordnet waren, auf den Sie Team Foundation Server wiederhergestellt haben, manuell neu zu.

    Die virtuellen Computer in dieser Hostgruppe sind nicht dem Teamprojekt zugeordnet.

  8. Auf den Ebenen von Teamprojektsammlungen und Teamprojekten ordnen Sie alle Hostgruppen, die nach dem Punkt, auf den Sie Team Foundation Server wiederhergestellt haben, nicht zugeordnet waren, neu zu.

    Weitere Informationen finden Sie unter Gewusst wie: Ändern der Hostgruppen für die Teamprojektsammlungen.

  9. Ordnen Sie alle Hostgruppen, die einem Teamprojekt nach dem Punkt, auf den Sie Team Foundation Server wiederhergestellt haben, zugeordnet waren, neu zu.

  10. Ordnen Sie alle Bibliotheksfreigaben, die einem Teamprojekt nach dem Punkt, auf den Sie Team Foundation Server wiederhergestellt haben, zugeordnet waren, neu zu, und importiert alle virtuellen Computer und Vorlagen, die in das Teamprojekt importiert wurden, erneut.

Wiederherstellen der Hyper-V-Hosts

Wenn auf einem Host virtuelle Umgebungen ausgefallen sind, befinden sie sich im Status Fehler.

So stellen Sie einem physischen Host wieder her, auf dem virtuelle Computer ausgeführt wurden

  1. Stellen Sie den Host aus der Sicherung wieder her, und verbinden Sie ihn mit SCVMM.

    Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Sichern und Wiederherstellen der SCVMM-Datenbank.

    Wenn die virtuellen Computer wieder auf dem Host ausgeführt werden, sind keine zusätzlichen Aktionen erforderlich. Lab Management aktualisiert alle ausgeführten virtuellen Computern mit dem korrekten Status. Wenn Sie die virtuellen Computer nicht wiederherstellen können und dies ein neuer Host ist, wird in Microsoft Test Manager oder in Microsoft Environment Viewer für die Umgebungen Fehler und für die virtuellen Computer Gelöscht angezeigt.

  2. Aktualisieren Sie Microsoft Test Manager, löschen Sie manuell die Umgebungen, die auf diesem Host ausgeführt wurden, und erstellen Sie sie dann neu.

    Wenn Sie die Umgebungen ermitteln müssen, die auf diesem Host ausgeführt wurden, können Sie die in SCVMM bereitgestellte Liste der ausgeführten virtuellen Computer anzeigen.

Siehe auch

Konzepte

Sichern und Wiederherstellen der Bereitstellung

Weitere Ressourcen

Back Up Team Foundation Server
Move a Team Project Collection


Sichern von Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Sichern von Team Foundation Server
Siehe auch Feedback senden

Die Sicherheit für Team Foundation ist in die Windows-Authentifizierung integriert und basiert auf Benutzern und Gruppen. Die Windows-Authentifizierung wird verwendet, um Konten für Verbindungen zwischen Visual Studio Team Foundation Server und Team Foundation-Clients zu authentifizieren. Darüber hinaus basiert die Autorisierung in Team Foundation Server auf Benutzern, Gruppen und Berechtigungen in Team Foundation Server. Die Sicherheit der Bereitstellung kann unter anderem auf folgende Arten verbessert werden:

  • Zuweisen von Berechtigungen zu Benutzern und Gruppen

  • Zugrunde liegende Architektur der Bereitstellung

  • Durch Erhöhen der Sicherheit der Netzwerkports und des Datenverkehrs zwischen Clients und Servern

Sie können die Bereitstellung für die Verwendung von HTTPS (Hypertext Transfer Protocol Secure) mit SSL (Secure Sockets Layer) konfigurieren. Mit dieser Konfiguration wird der Netzwerkdatenverkehr zwischen Team Foundation Server und den Clients verschlüsselt, von denen Zugriff auf die Ressourcen angefordert wird. Hierzu zählen Teamprojektportale, Berichte und Arbeitsaufgaben. Sie können die Bereitstellung so konfigurieren, dass neben HTTP auch HTTPS mit SSL unterstützt wird. Alternativ können Sie für die Benutzer von Team Foundation Server die Verwendung von HTTPS mit SSL vorschreiben.

In diesem Abschnitt

Team Foundation Server, Authentifizierung und Zugriff

Hier werden die Authentifizierungsmodi beschrieben, die von Team Foundation Server unterstützt werden, wenn Visual Studio 2012 installiert ist.

Einrichten von HTTPS mit SSL (Secure Sockets Layer) für Team Foundation Server

Hier werden die Vor- und Nachteile der Verwendung von HTTPS mit SSL für die Bereitstellung erläutert. Außerdem wird in diesem Thema beschrieben, wie Visual Studio 2012 konfiguriert werden muss, damit HTTPS mit SSL für Webverbindungen zwischen der Daten-, der Anwendungs- und der Clientebene von Team Foundation unterstützt oder erforderlich gemacht wird.

Siehe auch

Konzepte

Architektur von Team Foundation Server
Team Foundation Server-Berechtigungen
Konfigurieren von Benutzern, Gruppen und Berechtigungen

Weitere Ressourcen

Administering Team Foundation Server
Arbeiten innerhalb von Team Web Access


Team Foundation Server, Authentifizierung und Zugriff

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Team Foundation Server, Authentifizierung und Zugriff
Siehe auch Feedback senden

Sie können Ihre Bereitstellung so konfigurieren, dass zwischen den Benutzern und der Visual Studio Team Foundation Server-Bereitstellung eine sichere Verbindung besteht. Von Team Foundation Server (TFS) werden Standardauthentifizierung, Digestauthentifizierung und Zertifikate unterstützt. Daher können Sie die Bereitstellung von TFS für die Verwendung von HTTPS (Hypertext Transfer Protocol Secure) mit SSL (Secure Sockets Layer) und entweder Standard- oder Digestauthentifizierung konfigurieren. Bei Anwendung dieser Strategie können die Benutzer eine sicherere Verbindung mit der Bereitstellung herstellen, ohne ein VPN (Virtuelles Privates Netzwerk) verwenden zu müssen.

Konfigurationen

Zur Erhöhung der Sicherheit bei externen Verbindungen mit der Team Foundation Server-Bereitstellung muss mithilfe von Internetinformationsdienste (IIS) die Standard- bzw. die Digestauthentifizierung aktiviert werden. Zudem empfiehlt es sich, für sämtliche externe Verbindungen die Verwendung von Zertifikaten erforderlich zu machen.

Standardauthentifizierung und Digestauthentifizierung

Die Standardauthentifizierung ist Teil der HTTP 1.0-Spezifikation und verwendet Windows-Benutzerkonten. Bei der Standardauthentifizierung wird der Benutzer vom Browser zur Angabe eines Benutzernamens und eines Kennworts aufgefordert. Diese Informationen werden dann per HTTP mit Base64-Codierung übertragen. Standardmäßig werden für die Standardauthentifizierung Windows-Benutzerkonten mit lokalen Anmelderechten am Webserver benötigt. Die Standardauthentifizierung kann sowohl in Arbeitsgruppen- als auch in Domänenbereitstellungen verwendet werden. Die Standardauthentifizierung wird zwar von den meisten Webservern, Proxyservern und Webbrowsern unterstützt, sie ist jedoch nicht sicher. Da sich Daten mit Base64-Codierung auf einfache Weise dekodieren lassen, wird bei der Standardauthentifizierung das Kennwort im Grunde im Nur-Text-Format gesendet. Diese Kennwörter können durch die Überwachung der Netzwerkkommunikation mithilfe öffentlich verfügbarer Tools problemlos von einem böswilligen Benutzer abgefangen und entschlüsselt werden. Ein höheres Maß an Sicherheit lässt sich durch die Verwendung von HTTPS mit SSL erreichen.

Die Digestauthentifizierung ist ein auf Abfrage und Rückmeldung basierender Mechanismus, von dem anstelle eines Kennworts ein Digest (auch: Hash) über das Netzwerk gesendet wird. Bei der Digestauthentifizierung wird von IIS eine Abfrage an den Client gesendet, um ein Digest zu erstellen und dieses anschließend an den Server zu senden. Als Rückmeldung auf die Abfrage werden vom Client ein auf dem Kennwort des Benutzers basierendes Digest sowie Daten gesendet, die sowohl dem Client als auch dem Server bekannt sind. Vom Server wird auf die gleiche Weise ein eigenes Digest mit den Benutzerinformationen aus Active Directory erstellt. Der Client wird nur dann von IIS authentifiziert, wenn das vom Server erstellte Digest dem vom Client erstellten Digest entspricht. Die Digestauthentifizierung kann ausschließlich in Active Directory-Bereitstellungen verwendet werden. Die Digestauthentifizierung stellt im Grunde nur eine geringe Verbesserung gegenüber der Standardauthentifizierung dar. Ein böswilliger Benutzer kann die Kommunikation zwischen Client und Server aufzeichnen und diese Informationen nutzen, um die Transaktion wiederzugeben. Die Digestauthentifizierung ist außerdem vom HTTP 1.1-Protokoll abhängig, das nicht von allen Webbrowsern unterstützt wird. Darüber hinaus kann nicht auf Team Foundation Server zugegriffen werden, wenn die Digestauthentifizierung nicht ordnungsgemäß konfiguriert wurde. Entscheiden Sie sich nur dann für die Digestauthentifizierung, wenn Ihre Bereitstellung alle Anforderungen an diesen Modus erfüllt. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Konfigurieren der Digestauthentifizierung (IIS 7.0).

Authentifizierungsprotokolle

Standardgemäß verwendet Team Foundation Server das Authentifizierungsprotokoll von Windows Challenge/Response (NTLM). NTLM-Anmeldeinformationen basieren auf Daten, die während des interaktiven Anmeldevorgangs abgerufen wurden, und sie enthalten einen Einweg-Hashcode des Kennworts.

Team Foundation Server unterstützt auch Microsoft Negotiate als Authentifizierungsprotokoll. Im Negotiate-Protokoll ist Kerberos aktiviert, es sei denn, es kann nicht von einem der Systeme verwendet werden, die am Authentifizierungsprozess beteiligt sind. Für Systeme, die nicht für Kerberos konfiguriert sind, wird NTLM verwendet. Die Option für die Aushandlung ist die sicherere Option für die meisten Bereitstellungen, kann jedoch weitere Konfigurationsaufgaben erfordern.

Einschränkungen

Zusätzlich zu den in diesem Thema erwähnten Domänen- und Arbeitsgruppenanforderungen sind sowohl die Standard- als auch die Digestauthentifizierung alleine nicht ausreichend, um Netzwerksicherheit für externe Clients zu gewährleisten. Daher sollten Sie die Unterstützung externer Clients für Team Foundation Server nur konfigurieren, wenn Sie für diese Verbindungen auch die Nutzung von HTTPS mit SSL vorschreiben.

Siehe auch

Konzepte

Architektur von Team Foundation Server

Weitere Ressourcen

Securing Team Foundation Server with HTTPS and Secure Sockets Layer (SSL)


Einrichten von HTTPS mit SSL (Secure Sockets Layer) für Team Foundation Server

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Einrichten von HTTPS mit SSL (Secure Sockets Layer) für Team Foundation Server
Siehe auch Feedback senden

Sie können die Sicherheit der Bereitstellung von Visual Studio Team Foundation Server (TFS) erhöhen, indem Sie die verwendeten Dienste für die Verwendung von Hypertext Transfer Protocol Secure (HTTPS) mit Secure Sockets Layer (SSL) konfigurieren. Sie können die Bereitstellung so konfigurieren, dass entweder dieses Protokoll erforderlich sein soll, das die Sicherheit der Bereitstellung erhöht, oder dass zusätzlich zum Standardprotokoll (HTTP) HTTPS mit SSL unterstützt wird. Bevor Sie eine Konfiguration auswählen, führen Sie sich deutlich die Vor- und Nachteile vor Augen, die in diesem Thema beschrieben werden. Wenn Sie die am besten für die Sicherheitsanforderungen in Ihrer Organisation geeignete Konfiguration gefunden haben, führen Sie zur Konfiguration der Bereitstellung die in diesem Thema beschriebenen Schritte aus.

In diesem Thema

  • Konzeptionelle Informationen

    • Vorteile einer zusätzlichen Unterstützung von HTTPS mit SSL neben HTTP

    • Vorteile der verbindlichen Verwendung von HTTPS mit SSL für alle Verbindungen

    • Nachteile der Unterstützung oder verbindlichen Verwendung von HTTPS mit SSL

    • Voraussetzungen

    • Annahmen

  • Serverkonfiguration

    • Abrufen eines Zertifikats

    • Anfordern eines Zertifikats

    • Installieren und Zuweisen des Zertifikats

    • Konfigurieren der Firewall

    • Konfigurieren von SQL Server Reporting Services

    • Konfigurieren der Bereitstellung für die zusätzliche Unterstützung von HTTPS mit SSL neben HTTP

  • Optionale Konfigurationsaufgaben

    • Testen des Zugriffs auf die Bereitstellung (optional)

    • Konfigurieren der Bereitstellung für die verbindliche Verwendung von HTTPS mit SSL (optional)

  • Buildkonfiguration

    • Installieren des Zertifikats auf Buildservern

    • Aktualisieren der Buildkonfiguration

  • Clientkonfiguration

    1. Konfigurieren von Clientcomputern

Vorteile einer zusätzlichen Unterstützung von HTTPS mit SSL neben HTTP

Wenn Sie die Bereitstellung von TFS für die Unterstützung von beiden Protokollen konfigurieren, stellen Benutzer, deren Computer für die Verwendung von HTTPS mit SSL konfiguriert wurden, mithilfe dieses Protokolls eine Verbindung her. Die Sicherheit der Bereitstellung wird dadurch erhöht. Außerdem können Benutzer, deren Computer für HTTP konfiguriert wurden, nach wie vor eine Verbindung mit der Bereitstellung herstellen. Obwohl Sie diese Konfiguration nicht über öffentliche Netzwerke bereitstellen sollten, können Sie die folgenden Vorteile nutzen, indem Sie weiterhin HTTP-Verbindungen in einer gesteuerten Netzwerkumgebung unterstützen:

  • Sie können die Sicherheit der Bereitstellung im Laufe der Zeit erhöhen, indem Sie Clientcomputer für HTTPS mit SSL konfigurieren (je nach Vereinbarkeit mit Ihrem Zeitplan). Wenn Sie die entsprechenden Schritte in Phasen ausführen möchten, müssen Sie nicht alle Computer gleichzeitig aktualisieren, und Benutzer, deren Computer noch nicht aktualisiert wurden, können nach wie vor eine Verbindung mit der Bereitstellung herstellen.

  • Sie können Team Foundation Server leichter konfigurieren und verwalten.

  • Aufrufe, die von einem Webdienst an einen anderen Webdienst gerichtet werden, laufen über HTTP schneller ab als über HTTPS mit SSL. Sie können daher weiterhin HTTP-Verbindungen von Clientcomputern unterstützen, bei denen Sicherheitsrisiken zugunsten von Leistungsanforderungen in den Hintergrund rücken.

Vorteile der verbindlichen Verwendung von HTTPS mit SSL für alle Verbindungen

Wenn Sie für alle Verbindungen HTTPS mit SSL als verbindlich festlegen, bietet dies folgende Vorteile:

  • Alle Webverbindungen zwischen der Anwendungs-, Daten- und Clientebene für Team Foundation sind sicherer, da sie Zertifikate erfordern.

  • Sie können Zugriffe einfacher steuern, indem Sie Zertifikate so konfigurieren, dass sie am voraussichtlichen Ende einer Projektphase ablaufen.

Nachteile der Unterstützung oder verbindlichen Verwendung von HTTPS mit SSL

Bevor Sie TFS so konfigurieren, dass HTTPS mit SSL unterstützt oder als verbindlich festgelegt wird, sollten Sie sich über die folgenden Nachteile im Klaren sein:

  • Laufende Verwaltungsaufgaben könnten verkompliziert werden. Beispiel: Unter Umständen muss die Bereitstellung neu konfiguriert werden, um die Unterstützung von HTTPS mit SSL zu beenden, bevor Service Packs oder andere Updates angewendet werden können.

  • Eine Zertifizierungsstelle und Zertifikatsvertrauenslisten müssen nicht nur konfiguriert, sondern auch verwaltet werden. Sie können Zertifikatdienste in Windows Server 2003 und Windows Server 2008 verwenden, möchten aber möglicherweise nicht die Zeit und die Ressourcen investieren, die für die Bereitstellung einer sicheren Public Key-Infrastruktur (PKI) erforderlich sind.

  • Sie müssen mit einem hohen Zeitaufwand für das Einrichten und Testen der Konfigurationen rechnen, und die Problembehandlung für die Bereitstellung wird komplizierter.

  • Wenn Sie weiterhin beide Protokolle unterstützen, werden externe Verbindungen unter Umständen nicht verschlüsselt, wenn die Anwendungsebene für Team Foundation nicht angemessen gesichert wird.

  • Wenn Sie die Verwendung von HTTPS mit SSL als verbindlich festlegen, laufen Vorgänge in der Bereitstellung langsamer ab.

Konfigurieren der Bereitstellung für die Unterstützung oder die verbindliche Verwendung von HTTPS mit SSL

Die Prozeduren in diesem Thema beschreiben einen Prozess zum Anfordern, Ausgeben und Zuweisen von Zertifikaten, die für SSL-Verbindungen in Team Foundation Server erforderlich sind. Wenn Sie andere Software als die in diesem Thema beschriebene verwenden, müssen Sie ggf. andere Schritte ausführen. Zur Unterstützung von externen Verbindungen mit der Bereitstellung von TFS müssen Sie in Internetinformationsdienste (IIS) die Standard- oder die Digestauthentifizierung bzw. beide Authentifizierungsformen aktivieren.

Durch Ausführen der folgenden Prozeduren in diesem Thema führen Sie die folgenden Aufgaben aus:

  1. Abrufen von Zertifikaten für die Bereitstellung von Team Foundation Server und die Websites, die für die Bereitstellung verwendet werden.

  2. Installieren und Zuweisen der Zertifikate.

  3. Konfigurieren von Team Foundation Server.

  4. Konfigurieren von Team Foundation Build.

  5. Konfigurieren von Clientcomputern.

Voraussetzungen

Zum Ausführen der Prozeduren in diesem Thema müssen zunächst die folgenden Voraussetzungen erfüllt sein:

  • Die logischen Komponenten in den Daten- und Anwendungsebenen von Team Foundation müssen installiert und funktionsfähig sein. Diese Ebenen schließen IIS, SQL Server, SharePoint-Produkte, Team Foundation Build und SQL Server Reporting Services ein, wenn die Bereitstellung diese Komponenten einschließt. Die Prozeduren in diesem Thema beziehen sich auf den Server bzw. die Server, auf denen die logischen Komponenten in der Anwendungsebene für Team Foundation als Anwendungsebenenserver für Team Foundation ausgeführt werden. Die Prozeduren in diesem Thema beziehen sich auf den Server bzw. die Server, auf denen die logischen Komponenten in der Datenebene für Team Foundation als Datenebenenserver für Team Foundation ausgeführt werden. Die Anwendungs- und Datenebenen werden möglicherweise auf dem gleichen Server oder auf mehreren Servern ausgeführt. Weitere Informationen finden Sie unter Installieren von Team Foundation Server und Visual Studio ALM.

  • Sie müssen über eine Zertifizierungsstelle verfügen, mit der Sie Zertifikate ausstellen können. In diesem Thema wird davon ausgegangen, dass Sie als Zertifizierungsstelle Zertifikatdienste verwenden, doch Sie können jede Zertifizierungsstelle verwenden, die Sie für die Bereitstellung konfiguriert haben. Wenn Sie keine Zertifizierungsstelle besitzen, können Sie Zertifikatdienste installieren und eine Zertifizierungsstelle konfigurieren. Weitere Informationen finden Sie in einer der folgenden Dokumentationen auf der Microsoft-Website:

    • Für Windows Server 2003: Zertifikatdienste

    • Für Windows Server 2008: Active Directory Certificate Services and Public Key Management

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie der Gruppe Team Foundation-Administratoren angehören. Außerdem müssen Sie der Gruppe Administratoren auf dem Anwendungsebenen- und Datenebenenserver (bzw. den Servern) für Team Foundation angehören. Um einen Buildserver konfigurieren zu können, müssen Sie der Gruppe Administratoren auf dem Server angehören. Wenn für die Bereitstellung SharePoint-Produkte verwendet wird, müssen Sie der Gruppe Administratoren auf dem Server angehören, der als Host für die SharePoint-Zentraladministration fungiert. Sie müssen auch der Gruppe Farmadministratoren angehören. Weitere Informationen zu Berechtigungen finden Sie unter Team Foundation Server-Berechtigungen.

Annahmen

In den Prozeduren in diesem Thema wird davon ausgegangen, dass die folgenden Bedingungen erfüllt sind:

  • Der bzw. die Datenebenen- und Anwendungsebenenserver wurden in einer sicheren Umgebung installiert und bereitgestellt und entsprechend den empfohlenen Sicherheitsvorgehensweisen konfiguriert.

  • Sie kennen sich mit der Konfiguration und Verwaltung von PKIs und der Anforderung, Ausstellung und Zuweisung von Zertifikaten aus. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Infrastruktur öffentlicher Schlüssel.

  • Sie haben praktische Erfahrungen mit der Netzwerktopologie der Entwicklungsumgebung, und Sie sind mit der Konfiguration von Netzwerkeinstellungen, IIS und SQL Server vertraut.

Abrufen eines Zertifikats

Bevor Sie TFS für die Verwendung von HTTPS mit SSL konfigurieren, müssen Sie ein Serverzertifikat für die Server in der Bereitstellung abrufen und installieren. Um ein Serverzertifikat abzurufen, müssen Sie eine eigene Zertifizierungsstelle installieren und konfigurieren oder eine Zertifizierungsstelle einer externen Organisation verwenden, der Sie vertrauen.

Weitere Informationen zum Installieren einer Zertifizierungsstelle finden Sie in den folgenden Themen auf der Microsoft-Website:

  • Für Windows Server 2003: Zertifikatdienste

  • Für Windows Server 2008: Active Directory Certificate Services and Public Key Management

Anfordern eines Zertifikats

Nachdem Sie sich bei einer Zertifizierungsstelle eingetragen haben, müssen Sie entweder mit IIS-Manager ein Zertifikat anfordern oder das Zertifikat manuell auf jedem der folgenden Server in der Bereitstellung installieren:

  • Jeder Anwendungsebenenserver.

  • Jeder Server, auf dem Team Foundation Server Proxy ausgeführt wird, sofern Server für die Bereitstellung konfiguriert wurden.

  • Jeder Server, auf dem Team Foundation-Builddienst entweder als Buildcontroller oder Build-Agent ausgeführt wird, sofern Server für die Bereitstellung konfiguriert wurden.

  • Jeder Server, auf dem SharePoint-Produkte ausgeführt wird, sofern SharePoint-Produkte für die Bereitstellung konfiguriert wurden.

  • Der Server, auf dem SQL Server Reporting Services ausgeführt wird, sofern ein Server für die Bereitstellung konfiguriert wurde.

So fordern Sie ein Zertifikat in IIS an

  1. Wählen Sie Start und Verwaltung und anschließend Internetinformationsdienste (IIS)-Manager aus.

  2. Erweitern Sie Websites oder Sites, und navigieren Sie zu der Website, für die Sie ein Zertifikat anfordern möchten.

    Um ein Zertifikat für einen Anwendungsebenenserver anzufordern, navigieren Sie z. B. zu Team Foundation Server. Um ein Zertifikat für einen Proxyserver anzufordern, navigieren Sie zu Microsoft Team Foundation Server Proxy.

  3. Folgen Sie den entsprechenden Anweisungen für Ihre Version von IIS, um ein Serverzertifikat anzufordern oder zu erstellen, das die Sicherheitsanforderungen der Organisation erfüllt:

    • Wenn Sie IIS 7.0 verwenden, bereiten Sie ein Serverzertifikat für IIS 7.0 vor, benennen Sie die Anforderung, laden Sie das Zertifikat herunter, und speichern Sie es an einem sicheren Ort auf dem Server.

      Weitere Informationen finden Sie unter Konfigurieren von Serverzertifikaten in IIS 7.0.

Installieren und Zuweisen des Zertifikats

Bevor Sie SSL mit TFS verwenden können, müssen Sie das Serverzertifikat auf den Websites installieren, die von TFS verwendet werden, z. B. die Websites in der folgenden Liste:

  • Standardwebsite

  • Team Foundation Server

  • Microsoft Team Foundation Server-Proxy

  • SharePoint-Zentraladministration

Nach der Installation des Zertifikats müssen Sie es explizit an jede Website binden oder dieser zuweisen, die Authentifizierungsmethoden aktivieren, die Sie für jede Website verwenden möchten, und dann für jede Website HTTPS konfigurieren.

Je nach Bereitstellungskonfiguration kann es notwendig sein, das Zertifikat auf mehr als einem Computer zu installieren und zu konfigurieren. Die Bereitstellung kann z. B. Team Foundation Build und SharePoint-Produkte auf einem anderen Computer als dem Anwendungsebenenserver einschließen. In diesem Fall muss das Serverzertifikat nicht nur auf dem Server installiert und konfiguriert werden, der SharePoint-Produkte hostet, sondern auch auf den Computern, die den Buildcontroller und die Build-Agents hosten.

Installieren des Serverzertifikats

Durch Ausführen der folgenden Schritte installieren Sie das Serverzertifikat bzw. die Serverzertifikate, das bzw. die Sie für die Bereitstellung von TFS verwenden möchten.

So installieren Sie das Serverzertifikat für eine Website

  1. Wählen Sie auf dem Server, der die zu konfigurierende Website hostet, Start aus, wählen Sie Verwaltung und dann Internetinformationsdienste (IIS)-Manager aus.

  2. Führen Sie die entsprechenden Schritte für Ihre Version von IIS aus:

    • Wenn Sie IIS 7.0 verwenden, importieren Sie das Serverzertifikat aus dem Bereich Serverzertifikate.

      Weitere Informationen finden Sie unter Importieren eines Serverzertifikats (IIS 7).

Aktivieren von Authentifizierungsmethoden, Aktivieren von HTTPS und Angeben des Zertifikats für die Websites, die von der Bereitstellung verwendet werden

Durch Ausführen dieser Schritte können Sie die zu verwendenden Authentifizierungsmethoden einrichten und HTTPS in ISS für die Websites aktivieren, die von der Bereitstellung verwendet werden. Diese Websites werden möglicherweise auf separaten Servern gehostet. Sie müssen diese Schritte auf jeder Website ausführen, die Sie in der vorherigen Prozedur konfiguriert haben.

Nachdem Sie HTTPS konfiguriert haben, können Sie die Bereitstellung zusätzlich sichern, indem Sie HTTP aus der Liste der Bindungen für jede konfigurierte Website entfernen.

Abhängig von der Zertifizierungshierarchie und der Public Key-Infrastruktur sollten Sie auch IIS für die Authentifizierung von Clientzertifikaten konfigurieren. Weitere Informationen finden Sie unter Zertifikatdienste und Zertifikate.

Die Bereitstellung von SharePoint-Produkte erfordert unter Umständen eine zusätzliche Konfiguration, z. B. alternative Zugriffszuordnungen und Formularauthentifizierung, um ordnungsgemäß mit HTTPS, SSL und Zertifikaten zu funktionieren. Weitere Informationen finden Sie unter What Every SharePoint Administrator Needs to Know About Alternate Access Mappings, Forms Authentication in SharePoint Products and Technologies und im Konfigurationsthema für Ihre Version von SharePoint-Produkte:

  • Konfigurieren alternativer Zugriffszuordnungen (Office SharePoint Server 2007)

  • How Do I: Configure an Alternate Access Mapping in SharePoint Server 2010? (Video)

So richten Sie HTTPS ein und geben das Zertifikat an

  1. Wählen Sie auf dem Server, der die zu konfigurierende Website hostet, Start aus, wählen Sie Verwaltung und dann Internetinformationsdienste (IIS)-Manager aus.

  2. Führen Sie die Schritte für die Version von IIS aus:

    Für Bereitstellungen, die IIS 7.0 verwenden:

    1. Erweitern Sie Computername und Websites, öffnen Sie das Untermenü für die Website, die Sie konfigurieren möchten, und klicken Sie dann auf Bindungen bearbeiten.

    2. Wählen Sie unter Websitebindungen die Option Hinzufügen.

      Das Dialogfeld Websitebindung hinzufügen wird angezeigt.

    3. Klicken Sie in der Liste Typ auf https.

      (Optional.) Geben Sie in Port eine andere Portnummer ein.

      Wichtiger Hinweis Wichtig

      Die Standardportnummer für SSL-Verbindungen ist 443, doch Sie müssen eine eindeutige Portnummer für jede der folgenden Websites zuweisen: Standardwebsite, Team Foundation Server, Microsoft Team Foundation Server Proxy (bei Verwendung durch die Bereitstellung) und SharePoint-Zentraladministration.

      Erfassen Sie die SSL-Portnummer für jede Website, die Sie konfigurieren, da Sie diese Nummern in der Verwaltungskonsole für Team Foundation angeben müssen.

      Wählen Sie unter SSL-Zertifikat das Zertifikat, das Sie importiert haben, und dann OK.

    4. Wählen Sie unter Websitebindungen die Option Schließen.

    5. Öffnen Sie auf der Homepage für die Website, die Sie konfigurieren, die Ansicht Funktionen.

    6. Klicken Sie unter IIS auf Authentifizierung.

    7. Wählen Sie eine Authentifizierungsmethode, die Sie konfigurieren möchten, öffnen Sie deren Untermenü und wählen Sie anschließen Aktivieren, Deaktivieren oder Bearbeiten aus, um die Methode zu aktivieren, zu deaktivieren oder zusätzlich zu konfigurieren.

Konfigurieren der Firewall

Sie müssen die Firewall so konfigurieren, dass Datenverkehr durch die SSL-Ports zugelassen wird, die Sie soeben in IIS angegeben haben. Weitere Informationen finden Sie in der Dokumentation zu Ihrer Firewall.

Konfigurieren von SQL Server Reporting Services

Wenn die Bereitstellung Berichterstellung verwendet, müssen Sie SQL Server Reporting Services so konfigurieren, dass HTTPS mit SSL unterstützt wird und der Port verwendet wird, den Sie in IIS für Team Foundation Server angegeben haben. Andernfalls funktioniert der Berichtsserver für die Bereitstellung nicht ordnungsgemäß. Weitere Informationen finden Sie unter Konfigurieren eines Berichtsservers für SSL-Verbindungen (Secure Sockets Layer).

Tipp Tipp

Wenn in Ihrer Bereitstellung keine Berichterstellung verwendet wird, können Sie diese Prozedur auslassen.

Konfigurieren der Bereitstellung

Führen Sie die folgenden Schritte aus, um die Bereitstellung mit den HTTPS-Ports und den Werten zu konfigurieren, die Sie in IIS für die Standardwebsites und die Team Foundation Server-Websites konfiguriert haben.

So konfigurieren Sie Team Foundation Server neu

  1. Öffnen Sie die Verwaltungskonsole für Team Foundation.

    Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

  2. Erweitern Sie unter Team Foundation den Namen des Servers, und klicken Sie dann auf Anwendungsebene.

  3. Wählen Sie unter Anwendungsebene - Zusammenfassung die Option URLs ändern.

    Das Fenster URLs ändern wird geöffnet.

  4. Geben Sie in Benachrichtigungs-URL die HTTPS-URL ein, die Sie für die Team Foundation Server-Website in IIS konfiguriert haben.

    Beispiel: Sie haben konfiguriert, dass für die Website Port 443 verwendet werden soll. In diesem Fall geben Sie https://ServerName:443/tfs ein. Stellen Sie sicher, dass Sie den vollqualifizierten Domänennamen des Servers anstelle von "localhost" verwenden.

  5. Wählen Sie Testen, und wählen Sie dann OK, wenn der Test erfolgreich verlaufen ist.

  6. Wenn Sie HTTPS als verbindlich festlegen möchten, wählen Sie in Server-URL Verwenden, und geben Sie dann die HTTPS-URL ein, die Sie für die Team Foundation Server-Website konfiguriert haben.

    Stellen Sie sicher, dass Sie den vollqualifizierten Domänennamen des Servers anstelle von "localhost" verwenden.

  7. Wählen Sie Testen, und wählen Sie dann OK, wenn der Test erfolgreich verlaufen ist.

  8. Öffnen Sie die Datei "web.config" für Team Foundation Server in einem beliebigen Text-Editor, z. B. Editor. Standardmäßig befindet sich diese Datei im folgenden Verzeichnis: %PROGRAMFILES%\Microsoft Team Foundation Server 2012\Application Tier\Message Queue\web.config.

  9. Entfernen Sie die folgenden Endpunkte aus der Datei:

    <!-- An empty relative address means the endpoint will pick up the base address of the svc file -->

    <endpoint address=""

    binding="customBinding"

    bindingConfiguration="TfsSoapBinding"

    contract="Microsoft.TeamFoundation.Framework.Server.WebServices.MessageQueueWebService" />

    <!-- An empty relative address means the endpoint will pick up the base address of the svc file -->

    <endpoint address=""

    binding="customBinding"

    bindingConfiguration="TfsSoapBinding"

    contract="Microsoft.TeamFoundation.Framework.Server.WebServices.MessageQueueWebService2" />

  10. Navigieren Sie zum Abschnitt <system.serviceModel>, und fügen Sie die folgenden Protokollzuordnungen hinzu:

    <protocolMapping>

    <remove scheme="http" />

    <add scheme="http" binding="customBinding" bindingConfiguration="TfsSoapBinding"/>

    <add scheme="https" binding="customBinding" bindingConfiguration="TfsSoapBindingHttps"/>

    </protocolMapping>

  11. Fügen Sie im gleichen <system.serviceModel>-Abschnitt die folgende Bindung <customBinding> hinzu:

    <binding name="TfsSoapBindingHttps">

    <textMessageEncoding messageVersion="Soap12WSAddressing10" />

    <httpsTransport authenticationScheme="IntegratedWindowsAuthentication" manualAddressing="true" />

    </binding>

  12. Speichern und schließen Sie die Datei.

  13. Wenn von der Bereitstellung SharePoint-Produkte verwendet wird, wählen Sie in der Verwaltungskonsole SharePoint-Webanwendungen.

  14. Wählen Sie unter SharePoint-Webanwendungen in der Liste Name eine Webanwendung und dann Ändern.

    Die Seite SharePoint-Webanwendungseinstellungen wird geöffnet.

  15. Ändern Sie in Webanwendungs-URL die URL in den HTTPS-Wert für die Anwendung.

  16. Ändern Sie in URL der Zentraladministration die URL in den HTTPS-Wert für die Zentraladministrationswebsite.

  17. (Optional.) Ändern Sie in Anzeigename den Wert entsprechend der HTTPS-Adresse dieser Anwendung.

  18. Klicken Sie auf OK.

  19. Wiederholen Sie die vorherigen fünf Schritte für jede SharePoint-Webanwendung in der Bereitstellung.

  20. Wenn von der Bereitstellung Reporting Services verwendet werden, wählen Sie in der Verwaltungskonsole auf Berichterstellung.

  21. Wählen Sie unter Berichterstellung die Option Bearbeiten.

    Wenn das Dialogfeld Offline schalten geöffnet wird, wählen Sie OK aus.

    Das Fenster Berichterstellung wird geöffnet.

  22. Wählen Sie die Registerkarte Berichte. Geben Sie in URLs für Berichtsserver die HTTPS-URLs für Webdienst und Berichts-Manager ein, und klicken Sie dann auf OK.

Testen des Zugriffs auf die Bereitstellung (optional)

Sie können testen, ob die Änderungen erwartungsgemäß funktionieren. Dieser Schritt ist optional, wird jedoch empfohlen.

So testen Sie den Zugriff auf die Bereitstellung

  1. Öffnen Sie auf dem Server, der die Anwendungsebene hostet, einen Webbrowser.

  2. Geben Sie in der Adressleiste die URL ein, mit der Sie über Team Web Access eine Verbindung mit der Bereitstellung herstellen.

    Hinweis Hinweis

    Sie finden diese URL auf dem Anwendungsebenenknoten in der Verwaltungskonsole für Team Foundation.

  3. Überprüfen Sie, ob Sie auf die Teamprojektsammlungen und Projekte von Team Web Access zugreifen können.

  4. Wenn Sie über Team Web Access nicht auf die Bereitstellung zugreifen können, prüfen Sie die Schritte, die Sie soeben ausgeführt haben, und vergewissern Sie sich, ob Sie alle Konfigurationsänderungen ordnungsgemäß vorgenommen haben.

Konfigurieren der Bereitstellung für die verbindliche Verwendung von HTTPS mit SSL (optional)

Sie können für alle Verbindungen mit der Bereitstellung die Verwendung von HTTPS mit SSL als verbindlich festlegen. Diese zusätzliche Sicherheitsmaßnahme ist optional, wird jedoch empfohlen.

So legen Sie SSL-Verbindungen als verbindlich fest

  1. Wählen Sie auf dem Server, der die zu konfigurierende Website hostet, Start aus, wählen Sie Verwaltung und dann Internetinformationsdienste (IIS)-Manager aus.

  2. Führen Sie die entsprechenden Schritte für die von Ihnen verwendete Version von IIS aus:

    Für Bereitstellungen, die IIS 7.0 verwenden:

    1. Erweitern Sie Computername und Websites, und wählen Sie dann die Website aus, die Sie konfigurieren möchten.

    2. Wählen Sie auf der Homepage für diese Website SSL-Einstellungen aus.

    3. Aktivieren Sie im Bereich SSL-Einstellungen das Kontrollkästchen SSL erforderlich.

      Aktivieren Sie das Kontrollkästchen 128-Bit-SSL erforderlich (optional).

    4. Wählen Sie unter Clientzertifikate je nach den Sicherheitsanforderungen für die Bereitstellung Ignorieren, Akzeptieren oder Erfordern.

    5. Wählen Sie in Aktionen die Option Übernehmen.

    6. Wiederholen Sie diese Schritte für jede Website, für die Sie die verbindliche Verwendung von SSL festlegen möchten.

Installieren des Zertifikats auf Buildservern

Wenn Sie Team Foundation-Builddienst auf mindestens einem Server installiert haben, müssen Sie das Zertifikat im Speicher für vertrauenswürdige Stammzertifizierungsstellen der einzelnen Server installieren. Weitere Informationen finden Sie an anderer Stelle in diesem Thema unter Abrufen eines Zertifikats und Installieren und Zuweisen des Zertifikats. Sowohl der Controller als auch der Agent erfordern ein Zertifikat mit einem privaten Schlüssel, mit dem sie sich in HTTPS-Verbindungen identifizieren.

Hinweis Hinweis

Um Buildvorgänge über SSL auszuführen, muss das Zertifikat im vertrauenswürdigen Stammspeicher sowohl auf dem Buildcontroller als auch auf dem Build-Agent installiert sein.

Aktualisieren von Buildkonfigurationen

Um Team Foundation Build für SSL-Verbindungen zu konfigurieren, müssen Sie den Builddienst für die Verwendung der HTTPS-URL konfigurieren, die Sie für die Anwendungsebene und die Auflistung konfiguriert haben, die von der Buildkonfiguration unterstützt werden. Sie müssen diese URL für jede Buildkonfiguration in der Bereitstellung konfigurieren.

So legen Sie fest, dass für eine Buildkonfiguration HTTPS verwendet werden soll

  1. Auf dem Server, der als Host für die Buildkonfiguration fungiert, die Sie konfigurieren möchten, öffnen Sie die Verwaltungskonsole für Team Foundation.

  2. Erweitern Sie unter Team Foundation den Namen des Servers, und klicken Sie dann auf Buildkonfiguration.

    Der Bereich Buildkonfiguration wird angezeigt.

  3. Klicken Sie unter der Dienstkonfiguration auf Beenden und dann auf Eigenschaften.

    Das Dialogfeld Builddiensteigenschaften wird geöffnet.

  4. Stellen Sie in Kommunikation sicher, dass in der URL für die Teamprojektsammlung die richtige HTTPS-Adresse und der vollständigen Servername verwendet werden.

  5. Wählen Sie unter Lokaler Builddienst-Endpunkt (eingehend) die Option Ändern.

    Das Dialogfeld Builddienst-Endpunkt wird geöffnet.

  6. Überprüfen Sie in Endpunktdetails, ob die Portnummer den Konfigurationsdetails entspricht.

  7. Wählen Sie unter Protokoll die Option HTTPS.

  8. Klicken Sie in der Liste SSL-Zertifikate auf das Zertifikat, das Sie installiert und für die Verwendung mit dieser Bereitstellung konfiguriert haben, und klicken Sie dann auf OK.

  9. Klicken Sie im Dialogfeld Builddiensteigenschaften auf Start.

Konfigurieren von Clientcomputern

Auf jedem Clientcomputer, von dem Benutzer auf Team Foundation zugreifen, müssen Sie das Zertifikat lokal installieren und den Clientcache für jeden Benutzer löschen, der von diesem Computer aus auf Team Foundation zugegriffen hat. Andernfalls sind die Benutzer nicht in der Lage, von diesem Computer aus eine Verbindung mit Team Foundation herzustellen. Weitere Informationen finden Sie unter Verwalten von vertrauenswürdigen Stammzertifikaten.

Wichtiger Hinweis Wichtig

Führen Sie diese Schritte nicht für Computer aus, auf denen sowohl Team Foundation Server als auch mindestens ein Client von Team Foundation ausgeführt werden.

So installieren Sie das Zertifikat auf einem Clientcomputer

  1. Melden Sie sich mit einem Konto, das zur Gruppe Administratoren gehört, an diesem Computer an.

  2. Installieren Sie das Zertifikat im Ordner Vertrauenswürdige Stammzertifizierungsstellen für den lokalen Computer.

    Weitere Informationen finden Sie in der Dokumentation für das Betriebssystem und die Zertifizierungsstelle.

So löschen Sie den Cache auf einem Clientcomputer

  1. Melden Sie sich mit den Anmeldeinformationen des Benutzers, dessen Cache Sie löschen möchten, am Computer an.

  2. Schließen Sie alle geöffneten Instanzen von Visual Studio.

  3. Öffnen Sie in einem Browserfenster den folgenden Ordner:

    Laufwerk:\Users\Benutzername\AppData\Local\Microsoft\Team Foundation\4.0\Cache

  4. Löschen Sie den Inhalt des Cacheverzeichnisses. Stellen Sie sicher, dass alle Unterordner gelöscht werden.

  5. Wählen Sie Start und dann Ausführen aus. Geben Sie devenv /resetuserdata ein, und klicken Sie anschließend auf OK.

  6. Wiederholen Sie diese Schritte für das Konto jedes Benutzers, der von diesem Computer aus auf Team Foundation zugegriffen hat.

    Hinweis Hinweis

    Sie möchten ggf. Anweisungen zum Löschen des Caches an alle Team Foundation-Benutzer verteilen, damit sie die Caches selbst löschen können.

So verbinden Sie Clientcomputer mit der neu konfigurierten Bereitstellung

  • Stellen Sie in Visual Studio mithilfe der neuen HTTPS-URL eine Verbindung mit Team Foundation Server her.

    Weitere Informationen finden Sie unter Herstellen einer Verbindung mit Teamprojekten in Team Foundation Server.

Siehe auch

Weitere Ressourcen

Securing Team Foundation Server with HTTPS and Secure Sockets Layer (SSL)
Team Foundation Server, HTTPS, and Secure Sockets Layer (SSL)


Konfigurieren und Verwalten von Lab-Management

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren und Verwalten von Lab-Management
Siehe auch Feedback senden

Mit Visual Studio Lab Management können Sie Lab-Umgebungen für ein Teamprojekt auf Team Foundation Server erstellen und verwalten. Sie können Laborumgebungen verwenden, um eine Anwendung zu entwickeln, zu testen oder auszuführen. Jeder Computer in einer Lab-Umgebung stellt eine Rolle dar, die für die Anwendung, die Sie entwickeln, testen bzw. ausführen möchten, erforderlich ist. Beispiel: Sie entwickeln eine Anwendung mit mehreren Ebenen, die drei Rollen erfordert: einen Desktopclient, einen Webserver und einen Datenbankserver. Es gibt zwei Typen von Lab-Umgebungen: die Standardumgebung und die SCVMM-Umgebung. Eine Standardumgebung kann physische und virtuelle Computer mit einer beliebigen Virtualisierungsplattform enthalten. Eine SCVMM-Umgebung kann ausschließlich virtuelle Computer enthalten, die von SCVMM auf der Hyper-V-Virtualisierungsplattform verwaltet werden. Weitere Informationen zu Lab-Umgebungen finden Sie unter Verwenden einer Lab-Umgebung für den Anwendungslebenszyklus.

Aufgaben

In den folgenden Themen finden Sie Informationen zum Konfigurieren und Verwalten von Lab Management:

Aufgaben

Verwandte Themen

Erstmaliges Einrichten von Lab-Management: Sie müssen einen Testcontroller einrichten, um Lab Management zum Erstellen von Standardumgebungen zu verwenden. Um SCVMM-Umgebungen mithilfe von Lab Management zu erstellen, müssen Sie zuerst Hyper-V und SCVMM konfigurieren.

  • Konfigurieren von Lab Management für SCVMM-Umgebungen

Ändern der Konfiguration von Lab-Management: Sie können weitere Hostgruppen hinzufügen, die verwendete Bibliotheksfreigabe ändern, das Integrationsdienstkonto bearbeiten oder Buildcontroller bzw. Testcontroller hinzufügen, nachdem Sie die Erstkonfiguration von Lab Management abgeschlossen haben.

  • Ändern von vorhandenen Konfigurationen von Lab-Management

Zuweisung von Berechtigungen für die Verwendung von Lab Management-Ressourcen: Mit den Standardsicherheitsgruppen in Team Foundation Server werden Mitgliedern bestimmte Berechtigungen für die Verwendung von Lab Management-Ressourcen automatisch zugewiesen. Möglicherweise möchten Sie diese Berechtigungen ändern oder benutzerdefinierten Gruppen oder Benutzern Berechtigungen zuweisen.

  • Verwalten von Benutzerberechtigungen für Lab-Management

Lab-Umgebungen sichern und wiederherstellen: Sie können die Lab-Umgebungen sichern und wiederherstellen.

  • Sichern und Wiederherstellen der Bereitstellung

  • Wiederherstellen von Lab-Management-Komponenten

Foren

Visual Studio Lab Management

Blogs

Visual Studio Lab Management-Teamblog

Siehe auch

Konzepte

Verwenden einer Lab-Umgebung für den Anwendungslebenszyklus
Verwalten von Team Foundation Server


Konfigurieren von Lab Management für SCVMM-Umgebungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Lab Management für SCVMM-Umgebungen
Siehe auch Feedback senden

Um System Center Virtual Machine Manager (SCVMM)-Umgebungen zu erstellen und zu verwalten, müssen Sie zunächst die erforderlichen Komponenten für Lab Management konfigurieren. Diese Komponenten sind Folgende:

  • Hyper-V-Hosts

  • SCVMM

  • Team Foundation Server

  • Ein Testcontroller

Weitere Informationen zu Lab Management finden Sie unter Verwenden einer Lab-Umgebung für den Anwendungslebenszyklus.

Hinweis Hinweis

Alle Computer, die Sie als Bibliotheksserver (einschließlich des SCVMM-Computers, der einen Standardbibliotheksserver nutzt) und als Hyper-V-Hosts verwenden, sollten sich in einem Gigabitnetzwerk befinden, das mit einem allgemeinen Netzwerkswitch verbunden ist. Die höhere Netzwerkgeschwindigkeit trägt zur Leistungssteigerung bei, wenn Sie virtuelle Computer auf Hosts bereitstellen und wenn Sie virtuelle Computer vom Host in der Bibliothek speichern.

Voraussetzungen

Vor dem Konfigurieren von Lab Management muss der Team Foundation Server-Administrator zunächst Team Foundation Server einrichten und konfigurieren. Weitere Informationen zum Einrichten und Konfigurieren von Team Foundation Server finden Sie im Team Foundation Server-Installationshandbuch. Nachdem der Administrator Team Foundation Server konfiguriert und eine standardmäßige Teamprojektsammlung erstellt hat, müssen Sie sicherstellen, dass Ihnen die folgenden Informationen vorliegen:

  • TfsMachine: Der Name des Computers, auf dem Team Foundation Server ausgeführt wird.

  • domain: Die von allen Computern verwendete Active Directory-Domäne.

  • tfssvc: Der Konto, unter dem Team Foundation Server ausgeführt wird.

    Hinweis Hinweis

    Sie müssen ein Domänenbenutzerkonto und ein Kennwort für das TFSservice-Konto verwenden, um eine SCVMM-Umgebung für das Lab-Management einzurichten.

  • domain\tfsadmin: Das Konto des Team Foundation Server-Administrators.

Systemanforderungen

Die folgende Tabelle enthält die minimalen und die empfohlenen Hardware- und Softwareanforderungen für Computer, die mit Lab Management verwendet werden: Damit die Anforderungen verständlicher sind, wird jede Rolle so aufgeteilt, als ob sie auf einem separaten Computer installiert wäre. Für ein einfacheres Setup können Sie HyperVHost, VmmMachine und LibraryMachine auf dem gleichen Computer ausführen.

Rolle/System

Prozessor

Unterstütztes Betriebssystem

RAM

(min./

empfohlen)

Festplatte (min./empfohlen)

HyperVHost

64 Bit mit aktivierter Hardwarevirtualisierung

Windows Server 2008 R2 mit Hyper-V (64 Bit) - Standard Edition, Enterprise Edition und Datacenter Edition

Windows Server 2008 R2 (Server Core-Installation) - Standard Edition, Enterprise Edition und Datacenter Edition

Windows Server 2008 mit Hyper-V (64 Bit) - Standard Edition, Enterprise Edition und Datacenter Edition mit Service Pack 2

Betriebssystem Hyper-V Server 2008 R2

Wichtiger Hinweis Wichtig

Ein Windows Server 2012-Host kann nicht in SCVMM Server und Lab Management verwendet werden.

4 GB/8 GB

100 GB/200 GB

VmmMachine

64 Bit

Windows Server 2008 R2 (64 Bit) - Standard Edition, Enterprise Edition und Datacenter Edition

Windows Server 2008 - Standard Edition, Enterprise Edition und Datacenter Edition mit Service Pack 2

Hinweis Hinweis

2 GB/4 GB

200 GB

LibraryMachine

64 Bit

Windows Server 2008 R2 (64 Bit) - Standard Edition, Enterprise Edition und Datacenter Edition

2 GB/4 GB

200 GB/500 GB

TfsMachine

32 Bit, x86

64 Bit, x64

Alle Betriebssysteme, die von Team Foundation Server unterstützt werden, werden auch von Visual Studio Lab Management unterstützt - mit Ausnahme von Windows 8-Clients und -Servern.

2 GB/4 GB

120 GB/230 GB

Controllercomputer

32 Bit, x86

64 Bit, x64

Mit Ausnahme von Betriebssystemen, die keiner Domäne hinzugefügt werden, werden alle von Team Foundation Server unterstützten Betriebssysteme von Visual Studio Lab Management unterstützt.

2 GB/4 GB

120 GB/230 GB

Konfigurationsverfahren

In der folgenden Tabelle wird erläutert, wie Sie die Konfiguration für Hyper-V, SCVMM und Lab Management und die erforderlichen Berechtigungen definieren. Für ein einfaches Setup kann es sich bei HyperVHost, VmmMachine und LibraryMachine um den gleichen Computer handeln.

Hinweis Hinweis

Alle für Lab Management verwendeten Computer müssen entweder derselben Domäne hinzugefügt werden oder Domänen, zwischen denen eine bidirektionale Vertrauensstellung besteht.

Schrittnummer

Verfahren

Details

Computername in der Prozedur

Erforderliche Berechtigungen

Abgeschlossener Schritt

1

Einrichten und Konfigurieren von Hyper-V-Hosts

Hyper-V ermöglicht Ihnen, virtuelle Computer und deren Ressourcen zu verwalten.

HyperVHost

Administrator für den HyperVHost

2

Installieren und Konfigurieren von SCVMM

SCVMM unterstützt Sie, die virtuellen Computer und Vorlagen sowie die verwendeten Speicherorte und -methoden zu verwalten.

VmmMachine

Hinweis Hinweis

Sie können einen separaten Computer als LibraryMachine verwenden, auf dem die Bibliotheksfreigabe die virtuellen Computer speichert.

Administrator für VmmMachine

3

Konfigurieren von Team Foundation Server für die Aktivierung von Lab Management

Sie konfigurieren TFS, sodass Sie Zugriff auf die erstellten virtuellen Computer und Vorlagen erhalten.

TfsMachine

Team Foundation Server-Administrator

4

Überprüfen der Konfiguration mit Microsoft Test Manager

Vergewissern Sie sich, dass Sie mit Microsoft Test Manager eine Verbindung mit einem Teamprojekt herstellen und auf das Lab-Center zugreifen können.

DesktopClient

Alle Benutzerkonten, die dem Computer hinzugefügt wurden

5

Installieren eines Testcontrollers

Wenn Sie die Anwendung mit Team Foundation Build erstellen und bereitstellen sowie Tests ausführen möchten, benötigen Sie Buildcontroller und Testcontroller.

TfsMachine

Hinweis Hinweis

Es wird empfohlen, für die Installation des Testcontrollers einen separaten Computer als Controllercomputer zu verwenden.

Teamprojektsammlungsadministrator

Einrichten und Konfigurieren von Hyper-V-Hosts

Zum Einrichten von Hyper-V stehen Ihnen die folgenden Methoden zur Auswahl:

  • Aktivieren Sie die Rolle für Hyper-V auf dem Computer, auf dem Windows Server 2008 R2 installiert ist. Wenn die Rolle für Hyper-V auf dem HyperVHost-Computer nicht aktiviert ist, müssen Sie sie zunächst mithilfe des Server-Managers auf jedem Hyper-V-Host aktivieren, damit Sie anhand der Schritte im folgenden Verfahren virtuelle Computer erstellen und verwalten können. Weitere Informationen zu Hyper-V finden Sie auf der folgenden Microsoft-Website.

  • Installieren Sie Hyper-V Server 2008 R2 auf dem HyperVHost. Informationen zu Hyper-V Server und zur Installation finden Sie auf dieser Seite der Microsoft-Website (möglicherweise in englischer Sprache).

So aktivieren Sie die Rolle für Hyper-V auf jedem Hyper-V-Host mit Windows Server 2008 R2

  1. Melden Sie sich am Hyper-V-Host als Administrator an.

  2. Wählen Sie Start, zeigen Sie auf Verwaltung, und wählen Sie anschließend Server-Manager.

  3. Klicken Sie im linken Bereich von Server-Manager mit der rechten Maustaste auf Rollen, und zeigen Sie auf Rollen hinzufügen.

  4. Befolgen Sie die Anweisungen im Assistent zum Hinzufügen von Rollen. Wählen Sie auf allen außer den folgenden Seiten des Assistenten Weiter aus:

    1. Wählen Sie auf der Seite Serverrollen auswählen die Option Hyper-V und dann Weiter aus.

    2. Wählen Sie auf der Seite Virtuelle Netzwerke erstellen einen aktiven Netzwerkadapter und dann Weiter aus.

      Hinweis Hinweis

      Aktive Netzwerkadapter können mithilfe des Befehls ipconfig ermittelt werden. So können Sie feststellen, welche Netzwerkadapter über eine IP-Adresse verfügen. Wählen Sie im Assistenten den Netzwerkadapter aus, der zum Erstellen eines virtuellen Netzwerks verwendet werden soll. Sie müssen einen Adapter auswählen, der mit dem gleichen Netzwerk verbunden ist wie die anderen Computer im Lab. Sollten mehrere Adapter vorhanden sein, wählen Sie den Adapter aus, mit dem die von Lab Management erstellten virtuellen Computer verbunden werden sollen.

    3. Wählen Sie auf der Seite Installationsauswahl bestätigen die Option Installieren aus.

    4. Wählen Sie auf der Seite Installationsergebnisse die Option Schließen aus.

    5. Wählen Sie im Dialogfeldmit der Frage, ob der Computer jetzt neu gestartet werden soll, Ja aus.

      Der Computer wird neu gestartet, und derAssistent zum Fortsetzen der Konfiguration wird gestartet.

    6. Auf der Seite Installationsergebnisse wird eine Meldung mit dem folgenden Hinweis angezeigt: Installation succeeded. Wählen Sie Schließen aus.

  5. Installieren Sie das auf dieser Microsoft-Website beschriebene Update. Mit diesem Update wird die Netzwerkisolationsfunktion für SCVMM-Umgebungen unterstützt.

Verbessern der Zuverlässigkeit von WinRM

Die Windows-Remoteverwaltung (WinRM) wird von SCVMM verwendet, um mit Hyper-V-Hosts zu kommunizieren. Sie müssen die folgenden Änderungen an den Standardkonfigurationseinstellungen für WinRM vornehmen. Die Änderungen an diesen Einstellungen erhöhen die Zuverlässigkeit von WinRM, da Lab Management eine größere Anzahl von Vorgängen als in einem herkömmlichen Produktionsszenario für Hyper-V auf Hyper-V-Hosts ausführt. Diese Änderungen an den WinRM-Einstellungen müssen auch auf jedem Computer ausgeführt werden, der für eine Bibliotheksfreigabe verwendet wird.

So ändern Sie die Konfigurationseinstellungen der Windows-Remoteverwaltung

  1. Wählen Sie Start aus, öffnen Sie das Kontextmenü für die Eingabeaufforderung, und wählen Sie dann Als Administrator ausführen aus.

    Hinweis Hinweis

    Sie müssen ein Domänenbenutzer sein, der der Administratorgruppe für diesen Computer hinzugefügt wurde.

  2. Führen Sie an der Eingabeaufforderung folgenden Befehl aus:

    winrm set winrm/config @{MaxTimeoutms = "1800000"}

  3. Starten Sie den winrm-Dienst und den SCVMM-Agent auf dem Host mit den folgenden Befehlen neu:

    net stop winrm

    net start winrm

    net start vmmagent

  4. Wenn Windows Server 2008 das Hostbetriebssystem ist:

    1. Führen Sie den folgenden Befehl aus:

      winrm set winrm/config/Service @{MaxConcurrentOperations="200"}

    2. Starten Sie winrm und den SCVMM-Agent auf dem Host mit den folgenden Befehlen neu:

      net stop winrm

      net start winrm

      net start vmmagent

Überprüfen des Hyper-V-Setups

So überprüfen Sie, ob Hyper-V ordnungsgemäß installiert ist und funktioniert

  • Erstellen Sie mit Hyper-V einen virtuellen Computer, und überprüfen Sie, ob Sie den virtuellen Computer starten können.

    Wenn Sie die Rolle für Hyper-V für den HyperVHost aktiviert haben, erstellen Sie wie auf dieser Seite der Microsoft -Website (möglicherweise in englischer Sprache) beschrieben einen virtuellen Computer.

    Hinweis Hinweis

    Sie können die Einstellungen für den virtuellen Computer abhängig von Ihren Anforderungen ändern. Sie können die Festplattengröße und den Arbeitsspeicher aktualisieren. Weitere Informationen zu diesen Einstellungen finden Sie auf dieser Seite der Microsoft-Website (möglicherweise in englischer Sprache).

    Wenn Sie Hyper-V Server verwenden, erstellen Sie wie im Leitfaden für erste Schritte mit Hyper-V Server beschrieben einen virtuellen Computer. Den Leitfaden finden Sie auf dieser Microsoft -Website (möglicherweise in englischer Sprache).

    Hinweis Hinweis

    Wenn der Hyper-V-Computer mehrere Festplattenlaufwerke aufweist, müssen Sie die Pfade so konfigurieren, dass die virtuellen Computer der größere Datenträger sind. Andernfalls verfügen Sie möglicherweise nicht über genügend Speicherplatz, um die virtuellen Computer zu erstellen.

Weitere Informationen zu Hyper-V finden Sie in der Übersicht über Hyper-V (möglicherweise in englischer Sprache).

Hinweis Hinweis

Beim Erstellen oder Starten eines virtuellen Computers können aufgrund der Antivirensoftware Probleme auftreten. Weitere Informationen finden Sie auf der folgenden Microsoft-Website.

Installieren und Konfigurieren von SCVMM

Installieren und konfigurieren Sie SCVMM, um auf die virtuellen Computer zuzugreifen, die Sie mit Hyper-V von Lab Management erstellen. SCVMM ist ein Tool zum Verwalten der Hyper-V-Hostcomputer in einer zentralen Konsole. Lab Management kommuniziert mit SCVMM, um mithilfe der virtuellen Computer und Vorlagen Umgebungen zu erstellen. Zwei Versionen von System Center Virtual Machine Manager werden für Lab Management unterstützt: SCVMM 2012 oder SCVMM 2008 R2.

Hinweis Hinweis

Wenn Sie das eigenständige Betriebssystem Hyper-V Server 2008 R2 verwenden, müssen Sie SCVMM auf einem separaten Computer (VmmMachine) installieren. Der HyperVHost-Computer kann nicht verwendet werden. Weitere Informationen zu den besonderen Eigenschaften von Hyper-V Server 2008 R2 finden Sie auf dieser Microsoft-Website.

Installieren und Konfigurieren von SCVMM 2012

Um den VMM-Verwaltungsserver zu installieren, müssen Sie über eine unterstützte Instanz von SQL Server verfügen und das Windows Automated Installation Kit (AIK) für Windows 7 installiert sein. Weitere Informationen finden Sie auf der folgenden Microsoft-Website: Systemanforderungen: VMM Management Server

Installieren des SCVMM-Servers und seiner SCVMM-Administratorkonsole auf VMMMachine

  1. Melden Sie sich auf VmmMachine als Domänenbenutzer an, der gleichzeitig lokaler Administrator auf dem Computer ist.

  2. Führen Sie "setup.exe" aus.

  3. Wählen Sie beim Setup von System Center 2012 die Option Installieren aus.

    Tipp Tipp

    Wenn Microsoft .NET Framework 3.5 SP1 nicht installiert ist, werden Sie beim VMM-Setup zur Installation der Komponente aufgefordert. Klicken Sie auf OK.

  4. Wählen Sie für die hinzuzufügenden Funktionen VMM-Verwaltungsserver und anschließend Weiter aus. Die VMM-Konsole wird automatisch auf dem Server installiert.

  5. Geben Sie den Namen, die Organisation und den Product Key ein, und klicken Sie auf Weiter.

  6. Wählen Sie Ich habe die Bedingungen des Lizenzvertrags sorgfältig durchgelesen und stimme diesen zu aus, und klicken Sie auf Weiter.

  7. Wählen Sie aus, ob Sie am Programm zur Verbesserung der Benutzerfreundlichkeit teilnehmen möchten, und klicken Sie auf Weiter.

  8. Um den empfohlenen Installationspfad zu akzeptieren, wählen Sie Weiter.

  9. Geben Sie die zu verwendende SQL Server-Instanz sowie sämtliche Besonderheiten dazu an, und wählen Sie Weiter aus.

  10. Geben Sie das Konto des lokalen Systems oder ein Domänenkonto als Identität des VMM-Diensts an, und wählen Sie Weiter aus.

  11. Wählen Sie Weiter aus, um die Standardportzuweisungen zu übernehmen oder andere Werte einzugeben.

  12. Wählen Sie Neue Bibliotheksfreigabe erstellen aus, und klicken Sie auf Weiter.

  13. Wählen Sie auf dem Bildschirm "Zusammenfassung der Installation" die Option Installieren aus, und wählen Sie anschließend Schließen aus, nachdem der Assistent beendet wurde.

Nach der Installation des VMM-Managers müssen Sie die Hyper-V-Hostcomputer einer Hostgruppe und optional weitere Bibliotheksfreigaben hinzuzufügen.

So konfigurieren Sie SCVMM

  1. Öffnen Sie die Virtual Machine Manager-Konsole.

    1. Wählen Sie Start, Alle Programme, Microsoft System Center 2012, Virtual Machine Manager und anschließend auf Virtual Machine Manager-Konsole.

    2. Geben Sie im Dialogfeld Mit Server verbinden "localhost: <Anschlussnummer> oder <Name des SCVMM-Servers>:<Anschlussnummer> ein, und wählen Sie dann Verbinden aus.

  2. Um die HyperVHost-Computer einer Hostgruppe in SCVMM hinzuzufügen, wählen Sie Fabric aus, und klicken Sie dann auf Ressourcen hinzufügen und Hyper-V-Hosts und -Cluster. Wählen Sie dann auf allen Seiten des Assistenten mit Ausnahme der folgenden Seiten Weiter:

    1. Wählen Sie unter Anmeldedaten für die Suche angeben die Option Anmeldedaten manuell eingeben aus, geben Sie die Anmeldedaten eines Administrators für den Hyper-V-Host ein, und wählen Sie Weiter aus.

    2. Wählen Sie auf der Assistentenseite Geben Sie den Suchbereich für Hostkandidaten des virtuellen Computers an die Option Windows Server-Computer nach Namen angeben im Feld Computernamen aus, geben Sie den Computernamen des Hosts ein, den Sie SCVMM hinzufügen (beispielsweise HyperVHost), und wählen Sie anschließend Weiter aus.

    3. Wählen Sie auf der Seite Wählen Sie die Computer aus, den Sie als Hosts hinzufügen möchten die Hyper-V-Hostcomputer und anschließend Weiter aus.

    4. Wählen Sie auf der Assistentenseite Zusammenfassung die Option Fertig stellen aus.

      Hinweis Hinweis

      Es empfiehlt sich, für jede Teamprojektauflistung eine separate Hostgruppe zu konfigurieren. Wenn Sie beispielsweise vorhaben, Lab Management in zwei Projektauflistungen in Team Foundation Server zu konfigurieren, können Sie in System Center Virtual Machine Manager zwei Hostgruppen erstellen.

  3. (Optional) Standardmäßig fungiert der Computer, auf dem SCVMM installiert ist, als Bibliotheksserver. Zudem wird auf dem Computer eine Standardbibliotheksfreigabe eingerichtet. Sie können weitere Bibliotheksserver oder Bibliotheksfreigaben hinzufügen, um die Leistung zu verbessern.

    1. Wählen Sie Bibliothek aus, um SCVMM einen neuen Bibliotheksserver hinzuzufügen, und wählen Sie im Menüband die Schaltfläche Bibliothekserver hinzufügen aus, und befolgen Sie die Anweisungen im Assistenten.

    2. Wenn Sie SCVMM eine neue Bibliotheksfreigabe hinzufügen möchten, erstellen Sie zunächst auf einem Bibliotheksserver eine Windows-Dateifreigabe. Wählen Sie anschließend im Navigationsbereich Bibliothek und dann den Bibliotheksserver, auf dem Sie die Windows-Dateifreigabe erstellt haben. Wählen Sie im Menü Bibliothekserver aus. Wählen Sie auf dem Menüband Bibliotheksfreigaben hinzufügen aus, und befolgen Sie die Anweisungen des Assistenten.

      Hinweis Hinweis

      Wir empfehlen, für jede Teamprojektauflistung eine separate Bibliotheksfreigabe zu konfigurieren.

  4. Legen Sie die Mindestmenge an Arbeitsspeicher fest, die dauerhaft als Reserve für den HyperVHost-Computer verfügbar ist, damit sichergestellt ist, dass virtuelle Computer schnell gestartet werden und für Hostdienst und Netzwerk-Agents kein Timeout eintritt. Die Standardspeicherreserven auf dem Hostcomputer sind oft auf zu niedrige Werte festgelegt, sodass die erforderliche längere Startzeit für virtuelle Computer nicht unbedingt gewährleistet ist.

    1. Klicken Sie in der SCVMM-Administratorkonsole auf Fabric.

    2. Erweitern Sie im Navigationsbereich Server, Alle Hosts, wählen Sie den Hyper-V-Hostcomputer aus, und wählen Sie dann die Schaltfläche Eigenschaften auf dem Menüband aus.

    3. Wählen Sie im Dialogfeld die Option Reserven aus, und aktivieren Sie dann das Kontrollkästchen Hostreserveeinstellungen von der übergeordneten Hostgruppe überschreiben.

    4. Wählen Sie im Eingabefeld Arbeitsspeicher (MB) 1024 aus, und klicken Sie dann auf OK.

    5. Wiederholen Sie die Schritte b. bis d. für jeden Host.

Installieren und Konfigurieren von SCVMM 2008 R2

So installieren Sie den SCVMM-Server und die SCVMM-Administratorkonsole auf VmmMachine

  1. Melden Sie sich auf VmmMachine als Domänenbenutzer an, der gleichzeitig Administrator auf dem Computer ist.

  2. Führen Sie zum Installieren von System Center Virtual Machine Manager "setup.exe" aus.

  3. Um den SCVMM-Server zu installieren, wählen Sie unter Setup VMM Server. Wählen Sie Ich stimme den Bedingungen dieses Vertrags zu. Wählen Sie dann auf allen Seiten des Assistenten mit Ausnahme der folgenden Seiten Weiter:

    1. Wählen Sie auf der Assistentenseite SQL Server-Einstellungen die Option SQL Server 2005 Express Edition SP3 installieren und anschließend Weiter aus.

      Hinweis Hinweis

      Wenn eine Instanz von SQL vorhanden ist und Sie diese verwenden möchten, wählen Sie Unterstützte Version von SQL Server verwenden aus.

    2. Wählen Sie auf der Assistentenseite Bibliotheksfreigabeeinstellungen die Option Neue Bibliotheksfreigabe erstellen aus.

      Hinweis Hinweis

      Sie können die Standardnamen und -speicherorte für die Bibliotheksfreigabe übernehmen oder andere Werte eingeben.

    3. Auf der Seite Installationseinstellungen des Assistenten können Sie entweder die standardmäßigen Portnummern und das VMM-Dienstkonto übernehmen oder andere Werte eingeben.

    4. Wählen Sie auf der Assistentenseite Zusammenfassung der Einstellungen die Option Installieren aus.

    5. Wählen Sie auf der Assistentenseite Installation die Option Schließen aus.

  4. Wählen Sie zum Installieren der Virtual Machine Manager-Administratorkonsole unter Setup die Option VMM-Administratorkonsole. Wählen Sie Ich stimme den Bedingungen dieses Vertrags zu. Wählen Sie dann auf allen Seiten des Assistenten mit Ausnahme der folgenden Seiten Weiter:

    1. Wählen Sie auf der Assistentenseite Zusammenfassung der Einstellungen die Option Installieren aus.

    2. Wählen Sie auf der Assistentenseite Installation die Option Schließen aus.

  5. Wählen Sie auf der Startseite System Center Virtual Machine Manager 2008 die Option Beenden aus.

Nach der Installation des VMM-Managers müssen Sie den Hyper-V-Hostcomputer einer Hostgruppe und optional weitere Bibliotheksfreigaben hinzuzufügen.

Hinweis Hinweis

In einer Hostgruppe können Sie die Hyper-V-Hostcomputer logisch basierend auf dem Zweck des Hostcomputers gruppieren. Ein Satz von Hostcomputern kann z. B. zu einer bestimmten Abteilung im Unternehmen gehören.

So konfigurieren Sie SCVMM

  1. Öffnen Sie die Virtual Machine Manager-Administratorkonsole.

    1. Wählen Sie Start, Alle Programme, Microsoft System Center, Virtual Machine Manager 2008 R2 und anschließend auf Virtual Machine Manager-Administratorkonsole.

    2. Geben Sie im Dialogfeld Mit Server verbinden "localhost: <Anschlussnummer> oder <Name des SCVMM-Servers>:<Anschlussnummer> ein, und wählen Sie dann Verbinden aus.

      Hinweis Hinweis

      Wenn Sie eine Fehlermeldung empfangen, derzufolge keine Verbindung hergestellt werden kann, weil der Dienst nicht ausgeführt wird, müssen Sie "services.msc" ausführen und überprüfen, ob der Virtual Machine Manager-Dienst ausgeführt wird.

  2. Um die HyperVHost-Computer zu einer Hostgruppe in SCVMM hinzuzufügen, klicken Sie im Bereich Aktionen auf Host hinzufügen. Wählen Sie dann auf allen Seiten des Assistenten mit Ausnahme der folgenden Seiten Weiter:

    1. Geben Sie im Assistentenzum Hinzufügen von Hosts auf der Assistentenseite Hostspeicherort auswählen die Anmeldeinformationen eines Administrators für den Hyper-V-Host ein.

    2. Geben Sie auf der Assistentenseite Hostserver auswählen den Computernamen des Hosts ein, den Sie SCVMM hinzufügen möchten (beispielsweise HyperVHost), und wählen Sie anschließend Hinzufügen aus.

    3. Wählen Sie auf der Assistentenseite Zusammenfassung die Option Hosts hinzufügen aus.

      Hinweis Hinweis

      Wir empfehlen, für jede Teamprojektauflistung eine separate Hostgruppe zu konfigurieren. Wenn Sie beispielsweise vorhaben, Lab Management in zwei Projektauflistungen in Team Foundation Server zu konfigurieren, können Sie in System Center Virtual Machine Manager zwei Hostgruppen erstellen.

  3. (Optional) Standardmäßig fungiert der Computer, auf dem SCVMM installiert ist, als Bibliotheksserver. Zudem wird auf dem Computer eine Standardbibliotheksfreigabe eingerichtet. Sie können weitere Bibliotheksserver oder Bibliotheksfreigaben hinzufügen, um die Leistung zu verbessern.

    1. Wählen Sie rechts im Bereich Aktionen die Option Bibliotheksserver hinzufügen, und befolgen Sie die Anweisungen im Assistenten, um SCVMM einen neuen Bibliotheksserver hinzuzufügen.

    2. Wenn Sie SCVMM eine neue Bibliotheksfreigabe hinzufügen möchten, erstellen Sie zunächst auf einem Bibliotheksserver eine Windows-Dateifreigabe. Wählen Sie anschließend in der SCVMM-Administratorkonsole auf der Registerkarte Bibliothek den Bibliotheksserver aus, und wählen Sie rechts im Bereich Aktionen Bibliotheksfreigaben hinzufügen.

      Hinweis Hinweis

      Wir empfehlen, für jede Teamprojektauflistung eine separate Bibliotheksfreigabe zu konfigurieren.

    3. Installieren Sie auf allen SCVMM-Bibliotheksservern das auf dieser Microsoft-Website beschriebene Update. Mit diesem Update wird die Netzwerkisolationsfunktion für SCVMM-Umgebungen unterstützt.

  4. Legen Sie die Mindestmenge an Arbeitsspeicher fest, die dauerhaft als Reserve für den HyperVHost-Computer verfügbar ist, damit sichergestellt ist, dass virtuelle Computer schnell gestartet werden und für Hostdienst und Netzwerk-Agents kein Timeout eintritt. Die Standardspeicherreserven auf dem Hostcomputer sind oft auf zu niedrige Werte festgelegt, sodass die erforderliche längere Startzeit für virtuelle Computer nicht unbedingt gewährleistet ist.

    1. Klicken Sie in der SCVMM-Administratorkonsole auf Gehe zu, Hosts.

    2. Öffnen Sie im mittleren Bereich Alle Hosts das Kontextmenü für den Namen des Hostcomputers, und wählen Sie dann Eigenschaften aus.

    3. Klicken Sie im Dialogfeld Hostgruppeneigenschaften für Hostcomputer auf die Registerkarte Reserven.

    4. Wählen Sie im Eingabefeld Arbeitsspeicher 1024 aus, oder geben Sie diesen Wert ein, und klicken Sie dann auf OK. Weitere Informationen zu dem mindestens erforderlichen Arbeitsspeicher für Hyper-V-Hosts finden Sie auf dieser Microsoft-Website.

    5. Wiederholen Sie die Schritte b bis d für jeden Host.

Wichtiger Hinweis Wichtig

Wenn zwei SCVMM-Server zur Verwendung durch Lab Management mit einem bestimmten Team Foundation Server konfiguriert sind, muss für jeden SCVMM-Server ein eindeutiger MAC-Bereich konfiguriert werden. Wählen Sie zum Konfigurieren des MAC-Bereichs auf der Virtual Machine Manager-Verwaltungskonsole im Navigationsfenster unten links Verwaltung, wählen Sie Netzwerk, und öffnen Sie dann auf Bereich für globale statische MAC-Adresse. Weitere Informationen zum Konfigurieren des MAC-Bereichs finden Sie auf dieser Seite der Microsoft-Website (möglicherweise in englischer Sprache).

So überprüfen Sie, ob SCVMM ordnungsgemäß installiert ist und funktioniert

  1. Klicken Sie in der Virtual Machine Manager-Administratorkonsole rechts im Bereich Aktionen auf Neue virtuelle Maschine. Wählen Sie dann auf allen Seiten des Assistenten mit Ausnahme der folgenden Seiten Weiter.

    1. Wählen Sie auf der Assistentenseite Quelle auswählen die Option Neue virtuelle Maschine mit leerer virtueller Festplatte erstellen aus.

    2. Geben Sie auf der Assistentenseite Identität der virtuellen Maschine unter Name der virtuellen Maschine den Text "Leer" ein.

    3. Wählen Sie auf der Assistentenseite Ziel auswählen die Option Virtuelle Maschine auf einem Host platzieren aus.

    4. Sehen Sie sich auf der Assistentenseite Host auswählen die Bewertungen an, und wählen Sie anschließend Weiter aus.

      Alle Computer vom Typ HyperVHost, die Sie für Lab Management verwenden, werden angezeigt. Diese weisen alle positive Sternbewertungen auf. Falls nicht, liegt ein Problem vor, das behoben werden muss. Lesen Sie unter Erklärung der Bewertung nach, warum die Computer vom Typ HyperVHost von SCVMM nicht verwendet werden können.

    5. Wählen Sie auf der Assistentenseite Zusammenfassung die Option Erstellen aus.

      Ein neuer virtueller Computer mit dem Namen Leer sollte ohne Fehler erstellt und auf der Registerkarte Virtuelle Computer von SCVMM angezeigt werden. Möglicherweise wird eine Warnung mit dem Hinweis angezeigt, dass das Startvolume nicht gefunden wurde. Diese Warnung ist zu erwarten und kann ignoriert werden.

  2. Klicken Sie in der Virtual Machine Manager-Administratorkonsole auf Virtuelle Computer, klicken Sie mit der rechten Maustaste auf den in der Liste angezeigten virtuellen Computer, und klicken Sie dann auf Start. Wird der virtuelle Computer nicht gestartet, ermitteln Sie anhand der Informationen auf den folgenden Websites die Ursache des Problems:

    • Neue Installation von SCVMM 2008

    • TechCenter für System Center Virtual Machine Manager

  3. Nachdem der Status des virtuellen Computers Aktiv ist, öffnen Sie das Kontextmenü für den virtuellen Computer und wählen Beenden.

    Dies kennzeichnet, dass die Hyper-V-Hosts ordnungsgemäß konfiguriert wurden.

  4. Um den virtuellen Computer in der Bibliothek zu speichern, öffnen Sie das Kontextmenü für den virtuellen Computer, und wählen Sie dann In Bibliothek speichern aus.

    1. Wählen Sie auf der Seite Bibliotheksserver auswählen des Assistenten eine der Bibliotheksfreigaben aus.

    2. Wechseln Sie auf der Seite Pfad auswählen des Assistenten zu dem Pfad für die Bibliotheksfreigabe, die Sie für die Teamprojektsammlung in Team Foundation Server verwenden möchten.

    3. Vergewissern Sie sich anschließend, dass in der SCVMM-Administratorkonsole im Bereich Bibliothek ein virtueller Computer mit dem Namen Leer angezeigt wird.

      Dies kennzeichnet, dass die Bibliotheksfreigabe ordnungsgemäß konfiguriert wurde.

Sie können die Leistung von Übertragungen virtueller Computer zwischen der SCVMM-Bibliotheksfreigabe zu einem Host sowie beim Speichern eines virtuellen Computers in der SCVMM-Bibliotheksfreigabe mithilfe der folgenden Prozedur verbessern. Durch diese Leistungsverbesserung wird die Verschlüsselung entfernt, was bei einer unverschlüsselten Übertragung über das Netzwerk Sicherheitsauswirkungen hat.

So verbessern Sie die Leistung von VM-Übertragungen

  1. Aktivieren Sie unverschlüsselte Dateiübertragungen für Bibliothekserver.

    1. Wählen Sie in der SCVMM-Administratorkonsole die Registerkarte Bibliothek. Öffnen Sie das Kontextmenü für jeden Bibliotheksserver in der Struktur Bibliothekserver, und wählen Sie dann Eigenschaften aus.

    2. Wählen Sie die Option Unverschlüsselte Dateiübertragungen zulassen aus.

    3. Wählen Sie OK, um das Dialogfeld zu schließen.

  2. Aktivieren Sie unverschlüsselte Dateiübertragungen für Hostgruppen.

    1. Wählen Sie in der SCVMM-Administratorkonsole die Registerkarte Hosts aus. Öffnen Sie das Kontextmenü für jede Hostgruppe in der Struktur Hosts, und wählen Sie dann Eigenschaften aus.

    2. Wählen Sie die Option Unverschlüsselte Dateiübertragungen zulassen aus.

    3. Wählen Sie OK, um das Dialogfeld zu schließen.

Konfigurieren von Lab Management für Team Foundation Server

Um die Kommunikation zwischen Team Foundation Server und dem SCVMM-Server zu aktivieren, müssen Sie die SCVMM-Administratorkonsole auf TfsMachine installieren, wenn dieser nicht mit dem Computer identisch ist, den Sie als VmmMachine verwenden.

Hinweis Hinweis

Wenn die Bereitstellung von Team Foundation Server mehr als einen Computer auf Anwendungsebene umfasst, installieren Sie die Konsole auf jeder Anwendungsebene in der Bereitstellung.

So installieren Sie die SCVMM 2012-Konsole auf <TFSMachine>

  1. Melden Sie sich bei TfsMachine als domain\tfsadmin an.

  2. Führen Sie zum Installieren der Virtual Machine Manager-Administratorkonsole "setup.exe" für Virtual Machine Manager aus.

  3. Wählen Sie unter "VMM-Setup" die Option Installieren aus.

  4. Wählen Sie auf allen außer den folgenden Seiten des Assistenten Weiter aus:

    1. Wählen Sie auf der Seite Zu installierende Features auswählen: die Option VMM-Konsole aus, und wählen Sie anschließend Weiter aus.

    2. Auf der Lizenzseite müssen Sie die Option für das Zustimmen der Bedingungen dieser Notiz und anschließend Weiter auswählen.

    3. Wählen Sie auf der Seite Zusammenfassung der Installation die Option Installieren aus.

    4. Wählen Sie auf der Seite Setup wurde erfolgreich abgeschlossen. die Option Schließen aus.

So installieren Sie die SCVMM 2008 R2-Administratorkonsole auf <TfsMachine>

  1. Melden Sie sich bei TfsMachine als domain\tfsadmin an.

  2. Führen Sie zum Installieren der Virtual Machine Manager-Administratorkonsole "setup.exe" für Virtual Machine Manager aus.

  3. Klicken Sie auf der Startseite System Center Virtual Machine Manager 2008 R2 des Assistenten unter Setup auf VMM-Administratorkonsole.

  4. Wählen Sie auf allen außer den folgenden Seiten des Assistenten Weiter aus:

    1. Wählen Sie auf der Assistentenseite Zusammenfassung der Einstellungen die Option Installieren aus.

    2. Wählen Sie auf der Assistentenseite Installation die Option Schließen aus.

Konfigurieren von Lab Management für Visual Studio Team Foundation Server 2012

Sie müssen Lab Management in Team Foundation Server konfigurieren. Damit wird der Zugriff auf die virtuellen Computer und die Vorlagen aktiviert, die Sie in Microsoft Test Manager erstellen. Sie können dann diese virtuellen Computer oder die Vorlagen verwenden, um virtuelle SCVMM-Umgebungen zu erstellen und diese in einer Bibliotheksfreigabe zu speichern. Hierzu müssen Sie den SCVMM-Server auswählen, der mit Team Foundation Server verwendet werden soll.

So konfigurieren Sie Lab Management für Visual Studio Team Foundation Server 2012

  1. Wählen Sie unter TfsMachine die Option Start, Alle Programme, Microsoft Visual Studio Team Foundation Server 2012 und dann Team Foundation Server-Verwaltungskonsole aus.

    Hinweis Hinweis

    Sie müssen sich bei TfsMachine alsdomain\tfsadmin anmelden.

  2. Klicken Sie in der Verwaltungskonsole im Knoten Anwendungsebene auf Lab Management.

  3. Wählen Sie Konfigurieren aus.

    Das Dialogfeld Lab Management-Einstellungen wird angezeigt.

  4. Geben Sie auf der Registerkarte Virtual Machine Manager im Feld Name des VMM-Servers den Namen von VmmMachine ein. Dies ist der Server, auf dem Virtual Machine Manager ausgeführt wird und den Sie zum Verwalten der virtuellen Computer verwenden.

  5. Wählen Sie Test, um festzustellen, ob Team Foundation Server mit dem SCVMM-Server kommunizieren kann.

    1. Wenn dem Team Foundation Server-Dienstkonto für den angegebenen SCVMM-Server nicht die erforderlichen Berechtigungen zugewiesen sind, werden Sie in einem Dialogfeld aufgefordert, einen Benutzernamen und ein Kennwort anzugeben.

    2. Geben Sie die Anmeldeinformationen eines vorhandenen Mitglieds der SCVMM-Administratorrolle an. Mithilfe dieses Benutzernamens und Kennworts kann der SCVMM-Administratorrolle das Team Foundation Server-Dienstkonto hinzugefügt.

    Wenn Team Foundation Server den SCVMM-Server nicht kontaktieren kann, werden ein rotes X und eine Fehlermeldung angezeigt. Weitere Informationen zum Beheben von Installationsfehlern finden Sie unter Problembehandlung im Lab-Management.

  6. Sie können die Netzwerkisolation in Visual Studio Lab Management verwenden, um die gleichzeitige Ausführung von mehreren Kopien einer Lab-Umgebung ohne Netzwerkkonflikte zu ermöglichen. Konflikte können beispielsweise mit Computernamen und der DNS-Registrierung (Domain Name System) auftreten. Weitere Informationen zur Netzwerkisolation finden Sie unter Gewusst wie: Erstellen und Verwenden einer netzwerkisolierten Umgebung. Führen Sie auf der Registerkarte Netzwerkisolation die folgenden Schritte aus:

    1. Geben Sie unter IP-Sperre den Bereich von IP-Adressen ein, der den virtuellen Computern in einer Umgebung zugewiesen werden soll, wenn ein isoliertes Netzwerk erstellt wird.

      Sie müssen den IP-Block in der Notation für klassenloses domänenübergreifendes Routing (Classless Inter-Domain Routing, CIDR) eingeben. Die CIDR-Notation besteht aus der IP-Adresse, einem Schrägstrich (/) und der Präfixgröße. Beispiel: 192.168.0.0/24.

      Die Adressen, die Sie angeben, werden nur für das interne Routing zwischen virtuellen Computern verwendet und nicht über die Grenzen einer Umgebung hinaus verfügbar gemacht. Aus diesem Grund können Sie einen beliebigen Adressbereich angeben, der nicht innerhalb Ihres öffentlichen Netzwerks verwendet wird. In den meisten Fällen können Sie den Standardbereich von 192.168.23.0 bis 24 verwenden.

    2. Geben Sie unter DNS-Suffix das Suffix des Domänennamens ein, das der Umgebung zugewiesen werden soll, wenn ein isoliertes Netzwerk erstellt wird.

      Team Foundation Server verwendet das eingegebene Suffix bei der Registrierung eines eindeutigen externen Namens mit DNS für jeden virtuellen Computer in einer netzwerkisolierten Umgebung. Mit dem DNS-Aliasdatensatz ist die Kommunikation von Computern und anderen Objekten außerhalb des isolierten Netzwerks mit Computern innerhalb des isolierten Netzwerks möglich. Da sich Team Foundation Server für die Registrierung des Aliasdatensatzes in der DNS-Zone befindet, müssen für das Dienstkonto, mit dem Team Foundation ausgeführt wird, Berechtigungen zum Hinzuzufügen und Löschen von Aliasdatensätzen in der angegebenen DNS-Zone bestehen.

      Wenn die Team Foundation Server-Bereitstellung mehr als eine Anwendungsebene umfasst und jede Anwendungsebene mit einem anderen Dienstkonto ausgeführt wird, dann muss jedes Dienstkonto auf Anwendungsebene über die Berechtigung zum Bearbeiten der DNS-Aliasdatensätze verfügen, die durch die anderen Anwendungsebenen erstellt wurden.

      Wählen Sie Test aus, um festzustellen, ob Team Foundation Server das Suffix verwenden kann.

      Wenn das Suffix gültig ist, wird ein grünes Häkchen angezeigt. Klicken Sie auf OK.

      Wenn das Suffix nicht gültig ist, werden ein rotes X und eine Fehlermeldung angezeigt. Sie müssen den Fehler beheben, bevor Sie fortfahren können.

  7. Führen Sie die folgenden Schritte auf allen Computern auf Anwendungsebene aus, wenn die Bereitstellung von Team Foundation Server mehrere Computer auf Anwendungsebene umfasst:

    1. Klicken Sie in der Team Foundation Server-Verwaltungskonsole auf den Knoten Anwendungsebene und dann auf Lab Management, und klicken Sie anschließend auf Neu konfigurieren.

      Das Dialogfeld Lab Management-Einstellungen wird angezeigt.

    2. Wählen Sie die Registerkarte Virtual Machine Manager und dann Testen, um zu prüfen, ob von der Anwendungsebene eine Verbindung mit SCVMM hergestellt werden kann.

      Wenn dem Team Foundation Server-Dienstkonto nicht die erforderlichen Berechtigungen für den angegebenen SCVMM zugeordnet sind, wird ein Dialogfeld mit der Aufforderung zur Eingabe eines Benutzernamens und eines Kennworts angezeigt. Geben Sie die Anmeldeinformationen eines bestehenden Mitglieds der SCVMM-Administratorrolle ein. Wenn Sie den Benutzernamen und das Kennwort eingeben und OK auswählen, wird das Team Foundation Server-Dienstkonto dieser Anwendungsebene der SCVMM-Administratorrolle hinzugefügt.

Konfigurieren von Lab Management für jede Teamprojektsammlung

Sie müssen die Hostgruppe und Bibliotheksfreigabe in SCVMM konfigurieren, die Sie mit jeder Teamprojektsammlung verwenden möchten. Sie könnten beispielsweise jeder Teamprojektsammlung eine Hostgruppe zuzuordnen, um die Ressourcen des virtuellen Computers gleichmäßig zu verteilen.

Um die Workflowfunktion aus einer Team Foundation Build-Builddefinition zum Bereitstellen der Anwendung oder zum Ausführen von Tests der SCVMM-Umgebungen mit dem Testcontroller zu verwenden, müssen Sie ein Domänenbenutzerkonto hinzufügen, das von Test- und Build-Agents verwendet wird.

Hinweis Hinweis

Für diesen Konfigurationsschritt muss bereits eine Teamprojektsammlung erstellt worden sein.

So konfigurieren Sie Lab Management für jede Teamprojektsammlung

  1. Um die Bibliotheksfreigabe für die Speicherung von virtuellen Computern, Vorlagen und SCVMM-Umgebungen auszuwählen, wählen Sie unter Anwendungsebene Teamprojektauflistungen.

    Wichtiger Hinweis Wichtig

    Sie müssen für jede Teamprojektauflistung, die Sie für Lab Management konfigurieren möchten, eine Bibliotheksfreigabe konfigurieren.

  2. Klicken Sie im rechten Bereich in der Liste mit den Projektauflistungen auf die gewünschte Teamprojektsammlung.

  3. Wählen Sie die Registerkarte Lab Management und anschließend Bibliotheksfreigaben konfigurieren aus.

    Das Dialogfeld Lab Management-Einstellungen wird angezeigt.

  4. Wählen Sie auf der Registerkarte Bibliotheksfreigaben die Option Hinzufügen und überprüfen aus.

    Das Dialogfeld "Bibliotheksfreigaben auswählen" wird angezeigt.

  5. Klicken Sie im Dialogfeld Bibliotheksfreigaben auswählen auf mindestens eine SCVMM-Bibliotheksfreigabe, die von dieser Teamprojektsammlung verwendet werden soll, und klicken Sie anschließend auf Hinzufügen.

    Durch den Überprüfungsprozess wird jetzt bestätigt, dass Team Foundation Server eine Verbindung mit der Bibliotheksfreigabe herstellen kann. Wenn die Überprüfung fehlschlägt, wird ein Protokoll generiert. Sie können das Protokoll anzeigen, um die Probleme zu identifizieren und sie dann zu korrigieren. Nach dem Beheben der Probleme können Sie Überprüfen auswählen, um zu bestätigen, dass Team Foundation Server eine Verbindung mit der Bibliotheksfreigabe herstellen kann.

  6. Um jedem Teamprojekt in der Teamprojektsammlung die Bibliotheksfreigabe hinzuzufügen, aktivieren Sie das Kontrollkästchen Automatische Bereitstellung für die Bibliotheksfreigabe.

    Hinweis Hinweis

    Wenn Sie die Bibliotheksfreigabe automatisch bereitstellen, fügt Team Foundation Server die Bibliotheksfreigabe automatisch allen Teamprojekten in dieser Teamprojektsammlung hinzu. Für Teamprojekte, die noch nicht erstellt wurden, wird die Bibliotheksfreigabe hinzugefügt, wenn der Assistent "Neues Teamprojekt" das Projekt erstellt. Für Teamprojekte, die in dieser Teamprojektsammlung bereits erstellt wurden, wird die Bibliotheksfreigabe hinzugefügt, wenn diese Einstellungen gespeichert werden. Wenn Sie "Automatische Bereitstellung" deaktivieren, wird die Bibliotheksfreigabe nicht mehr zu neuen Teamprojekten hinzugefügt, die Sie der Teamprojektsammlung hinzufügen.

  7. Um die Hostgruppe auszuwählen, die für eine Teamprojektauflistung verwendet werden soll, wählen Sie Hostgruppen.

    Wichtiger Hinweis Wichtig

    Sie müssen die Hostgruppe für jede Teamprojektsammlung auswählen, die Sie für Lab Management konfigurieren möchten.

  8. Wählen Sie auf der Registerkarte Hostgruppen die Option Hinzufügen und überprüfen aus.

  9. Klicken Sie im Dialogfeld Hostgruppen auswählen auf mindestens eine SCVMM-Hostgruppe, die von dieser Teamprojektsammlung verwendet werden soll, und klicken Sie anschließend auf Hinzufügen.

  10. Um jedem Teamprojekt in der Teamprojektauflistung die Hostgruppe hinzuzufügen, aktivieren Sie das Kontrollkästchen Automatische Bereitstellung für die Hostgruppe.

    Hinweis Hinweis

    Wenn Sie die Hostgruppe automatisch bereitstellen, wird die Hostgruppe von Team Foundation Server automatisch zu allen Teamprojekten in dieser Teamprojektsammlung hinzugefügt. Für Teamprojekte, die noch nicht erstellt wurden, wird die Hostgruppe hinzugefügt, wenn der Assistent für neue Teamprojekte das Projekt erstellt. Für Teamprojekte, die in dieser Teamprojektsammlung bereits erstellt wurden, wird die Hostgruppe hinzugefügt, wenn diese Einstellungen gespeichert werden. Wenn Sie Automatische Bereitstellung deaktivieren, wird die Hostgruppe nicht mehr zu neuen Teamprojekten hinzugefügt, die Sie der Teamprojektsammlung hinzufügen.

  11. Um das Benutzerkonto auszuwählen, das für die Kommunikation zwischen den Test-Agents und Build-Agents sowie zwischen den Testcontrollern und Team Foundation Server verwendet werden soll, wählen Sie Dienstkonto.

    Warnhinweis Vorsicht

    Das hinzugefügte Dienstkonto muss ein Domänenkonto sein. Aus Sicherheitsgründen muss dieses Konto eingeschränkte Rechte aufweisen. Das verwendete Konto darf nicht über Administratorberechtigungen verfügen oder von einem vertrauenswürdigen Dienst genutzt werden. Dies schließt den Buildcontroller und den Testcontroller ein.

    Es empfiehlt sich, dass Sie zwei Konten für dieses Dienstkonto erstellen. Weitere Informationen zum Wechseln zwischen diese beiden Konten und zum Aktualisieren vorhandener Umgebungen mit dem Dienstkonto finden Sie unter Gewusst wie: Konfigurieren des Dienstkontos.

  12. Geben Sie auf der Registerkarte Dienstkonto im Feld Kontoname den Namen des Kontos, das Sie für das Dienstkonto verwenden möchten, und im Feld Kennwort das Kennwort für dieses Konto ein.

  13. Klicken Sie zum Überprüfen, ob das Benutzerkonto gültig ist, auf Test.

    Wichtiger Hinweis Wichtig

    Sie müssen das Benutzerkonto für jede Teamprojektauflistung konfigurieren, die Sie für Lab Management konfigurieren möchten.

  14. Klicken Sie auf OK.

Installieren eines Testcontrollers

Sie können mit Lab Management eine Anwendung in der SCVMM-Umgebung bereitstellen und Tests für diese Umgebung ausführen. Dies erfordert einen Testcontroller. Weitere Informationen zum Ausführen von Tests mit Testeinstellungen und Umgebungen finden Sie unter Einrichten von Testcomputern zum Ausführen von Tests oder Sammeln von Daten.

So installieren Sie den Testcontroller

  • Installieren Sie den Testcontroller auf Controllercomputer oder auf einem anderen Computer. Weitere Informationen zum Installieren und Konfigurieren eines Testcontrollers finden Sie unter Installieren und Konfigurieren von Test Agents und Testcontrollern.

    Hinweis Hinweis

    Sie müssen den Testcontroller in der Teamprojektsammlung registrieren, die Sie für Lab Management verwenden.

Siehe auch

Konzepte

Konfigurieren und Verwalten von Lab-Management


Gewusst wie: Erstellen und Speichern virtueller Computer und Vorlagen, die für Lab-Management verwendet werden können

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Erstellen und Speichern virtueller Computer und Vorlagen, die für Lab-Management verwendet werden können
Siehe auch Feedback senden

Als Systemadministrator müssen Sie unter Umständen regelmäßig neue Gold-Versionen von virtuellen Computern erstellen, um die Anforderungen verschiedener Teamprojekte zu erfüllen. Da mit Lab Management keine vollständig neuen virtuellen Computer (VMs) erstellt werden können, muss als Ausgangspunkt ein vorhandener, in Hyper-V oder System Center Virtual Machine Manager (SCVMM) erstellter virtueller Computer verwendet und in ein Teamprojekt importiert werden. Nachdem Sie die virtuellen Computer in SCVMM erstellen, können Sie Folgendes tun:

  • Belassen Sie den virtuellen Computer auf dem Host, und erstellen Sie eine Umgebung um den Computer herum.

  • Konvertieren Sie den virtuellen Computer in eine Vorlage, und speichern Sie die Vorlage in der Teamprojektbibliothek.

Installieren Sie Test-Agents nicht manuell auf den virtuellen Computern, wenn Sie beabsichtigen, diese Computer der Umgebung hinzuzufügen. Die Test-Agents werden von Lab Management automatisch auf den Computern installiert, wenn Sie sie einer Lab-Umgebung hinzufügen. Wenn Sie jedoch beabsichtigen, einen virtuellen Computer in eine Vorlage zu konvertieren, wird empfohlen, dass Sie einen Test-Agent auf dem virtuellen Computer installieren, bevor Sie ihn in eine Vorlage konvertieren. Wenn Sie beabsichtigen, mithilfe der Vorlage eine netzwerkisolierte Umgebung zu erstellen, müssen Sie darüber hinaus einen Test-Agent auf dem Computer installieren, bevor Sie diesen in eine Vorlage konvertieren.

Im folgenden Diagramm wird die Interaktion der verschiedenen Computer und Agents untereinander veranschaulicht.

Komponenten eines integrierten Lab Management-Setups

Dieses Thema enthält Anweisungen zum Erstellen von virtuellen Computern mit allen notwendigen Agents unter Verwendung von SCVMM zum Konvertieren dieser virtuellen Computer in Vorlagen und zum Speichern der Vorlagen in der SCVMM-Bibliothek.

Vorbereiten eines virtuellen Computers mit einem Test-Agent

So erstellen Sie einen virtuellen Computer

  1. Melden Sie sich an dem Server, auf dem Virtual Machine Manager ausgeführt wird, als Administrator an.

  2. Öffnen Sie die Virtual Machine Manager-Administratorkonsole.

  3. Erstellen Sie in SCVMM anhand einer der drei folgenden Methoden einen virtuellen Computer:

    1. So erstellen Sie einen virtuellen Computer unter Verwendung einer vorhandenen virtuellen Festplatte.

    2. So erstellen Sie einen virtuellen Computer unter Verwendung einer leeren virtuellen Festplatte.

    3. Erstellen virtueller Computer mithilfe einer Vorlage.

  4. Stellen Sie in der SCVMM-Administratorkonsole mithilfe der VM-Konsole eine Verbindung mit dem virtuellen Computer her.

    1. Klicken Sie unter SCVMM auf die Registerkarte Virtuelle Maschinen, klicken Sie mit der rechten Maustaste auf den virtuellen Computer, und klicken Sie anschließend auf Verbindung mit virtueller Maschine herstellen.

    2. Vergewissern Sie sich, dass auf dem virtuellen Computer die erforderlichen Betriebssystem- und Anwendungskomponenten installiert sind.

  5. Aktivieren Sie Remotedesktopverbindungen mit diesem virtuellen Computer.

    Dies ermöglicht gastbasierte Verbindungen mit dem virtuellen Computer. Weitere Informationen zu den Verbindungsarten finden Sie unter Gewusst wie: Herstellen einer Verbindung mit einer Lab-Umgebung.

    1. Klicken Sie auf dem virtuellen Computer auf Start, klicken Sie mit der rechten Maustaste auf Arbeitsplatz, und klicken Sie anschließend auf Eigenschaften.

    2. Klicken Sie im Dialogfeld System auf Remoteeinstellungen.

    3. Klicken Sie im Dialogfeld Systemeigenschaften auf der Registerkarte Remote auf die geeignete Option zum Zulassen von Verbindungen, und klicken Sie anschließend auf Benutzer auswählen.

    4. Vergewissern Sie sich im Dialogfeld Remotedesktopbenutzer, dass die entsprechenden Benutzernamen angezeigt werden, oder klicken auf Hinzufügen, um weitere Benutzerkonten hinzuzufügen. Klicken Sie anschließend auf OK.

Mit Lab Management können Sie eine Anwendung in der Umgebung bereitstellen und Tests der Umgebung ausführen. Diese Funktionen werden als Workflowintegrations- und Testfunktionen für Lab Management bezeichnet. Zum Bereitstellen der Anwendung mithilfe der Workflowintegration wird eine Builddefinition mit dem Workflow erstellt, durch den die Anwendung auf allen virtuellen Computern in der Umgebung bereitgestellt wird. Anschließend können Sie Tests für die Rolle ausführen, die Sie in den Testeinstellungen ausgewählt haben. Weitere Informationen zu Umgebungen und Rollen finden Sie unter Einrichten von Testcomputern zum Ausführen von Tests oder Sammeln von Daten.

Danach installieren Sie einen Test-Agent auf jedem virtuellen Computer, den Sie erstellt haben.

So installieren Sie einen Test-Agent auf einem virtuellen Computer

  • Installieren Sie einen Test-Agent auf dem virtuellen Computer. Weitere Informationen zum Installieren eines Test-Agents finden Sie unter Installieren und Konfigurieren von Test Agents und Testcontrollern.

    Hinweis Hinweis

    Der Test-Agent muss bei der Installation nicht bei einem Testcontroller registriert werden. Dieser Schritt wird automatisch ausgeführt, wenn der virtuelle Computer von Lab Management bereitgestellt wird.

Wenn Sie anhand dieses virtuellen Computers eine virtuelle Umgebung erstellen, sind Sie an diesem Punkt fertig. Wenn Sie den virtuellen Computer in der Bibliothek speichern möchten, fahren Sie mit dem nächsten Abschnitt fort.

Warnhinweis Vorsicht

Lab-Management stellt sehr strenge Anforderungen an die Netzwerkkonfiguration, wenn Sie eine isolierte Umgebung erstellen. Folgende Punkte müssen vermieden werden:

  • Legen Sie keine virtuellen LAN-IDs für Netzwerkadapter fest. Die VLAN-ID wird gelöscht, wenn der virtuelle Computer bereitgestellt wird. Weitere Informationen zur Verwendung von VLAN-IDs finden Sie unter Konfigurieren virtueller Netzwerke in VMM.

  • Erstellen Sie keine mehrfachen Netzwerkadapter auf einem virtuellen Computer, der eine Verbindung mit bestimmten Netzwerken herstellt. Lab-Management überschreibt diese Konfiguration und erstellt zwei Adapter. Ein Adapter stellt eine Verbindung mit dem Labornetzwerk her, und der andere Adapter behandelt die Kommunikation zwischen virtuellen Computern.

  • Konfigurieren Sie keine MAC-Adresse für einen Netzwerkadapter. Lab-Management löscht die MAC-Adresse, sobald die netzwerkisolierte Umgebung erstellt wird.

Speichern des virtuellen Computers in der SCVMM-Bibliothek

Wenn Sie einen virtuellen Computer in der SCVMM-Bibliothek speichern, müssen Sie entscheiden, ob er als virtueller Computer oder als Vorlage gespeichert werden soll. Die Entscheidung, ob der virtuelle Computer unverändert oder als Vorlage gespeichert werden soll, hängt von mehreren Faktoren ab:

  • Funktionieren die auf dem virtuellen Computer installierten Anwendungen auch nach dem Entfernen der eindeutigen Identitätsinformationen des virtuellen Computers?

  • Werden die virtuellen Computer nur als Teil einer Netzwerkisolationsumgebung verwendet?

Wenn Sie z. B. vorhaben, mehrere Kopien des virtuellen Computers zu erstellen und in der gleichen Umgebung zu verwenden (d. h., der Computer wird nur in einer Umgebung verwendet), erstellen Sie eine virtuelle Umgebung aus dem virtuellen Computer, ohne ihn in der Bibliothek zu speichern. Wenn Sie den virtuellen Computer in mehreren Umgebungen im gleichen Netzwerk verwenden möchten, müssen Sie ihn entweder in eine Vorlage konvertieren und in der Bibliothek speichern oder jede Umgebung zur Verwendung der Netzwerkisolation konfigurieren. Weitere Informationen zu den zu berücksichtigenden Faktoren finden Sie unter Verwalten von gespeicherten SCVMM-Umgebungen und virtuellen Computern.

So speichern Sie einen virtuellen Computer unverändert in der Bibliothek

  • Speichern Sie den virtuellen Computer, damit er in das Teamprojekt importiert werden kann. Klicken Sie hierzu mit der rechten Maustaste auf den virtuellen Computer, und klicken Sie anschließend auf In Bibliothek speichern.

    1. Klicken Sie in der SCVMM-Administratorkonsole mit der rechten Maustaste auf den virtuellen Computer, und klicken Sie anschließend auf Herunterfahren.

    2. Wählen Sie die SCVMM-Bibliotheksfreigabe aus, die Sie der Teamprojektsammlung hinzugefügt haben, und klicken Sie auf Weiter.

    3. Wählen Sie den Freigabepfad dieses virtuellen Computers aus, und klicken Sie auf Weiter.

    4. Klicken Sie auf Speichern.

So konvertieren Sie einen virtuellen Computer zunächst zu einer Vorlage und speichern diese anschließend in der Bibliothek

  1. Bereiten Sie den virtuellen Computer auf die Konvertierung zu einer Vorlage vor, indem Sie das Administratorkennwort sowie die lokale Kennwortrichtlinie löschen.

    1. Wenn der virtuelle Computer einer Domäne hinzugefügt wurde, entfernen Sie ihn aus der Domäne, und verknüpfen Sie ihn mit einer Arbeitsgruppe. Starten Sie den Computer neu, wenn Sie dazu aufgefordert werden.

    2. Öffnen Sie "gpedit.msc", und klicken Sie auf Richtlinie für "Lokaler Computer", Computerkonfiguration, Windows-Einstellungen, Sicherheitseinstellungen, Kontorichtlinien und anschließend auf Kennwortrichtlinie.

      Geben Sie die folgenden Werte an:

      Kennwortverlauf erzwingen: 0

      Minimale Kennwortlänge: 0

      Kennwort muss Komplexitätsvoraussetzungen entsprechen: Deaktiviert

    3. Schließen Sie "gpedit.msc".

    4. Legen Sie als Kennwort für das lokale Administratorkonto eine leere Zeichenfolge fest. Melden Sie sich hierzu als "\Administrator" an, und ändern Sie das Kennwort durch Drücken von STRG+ALT+ENTF.

  2. Stellen Sie sicher, dass alle bereits auf dem virtuellen Computer installierten Anwendungen weiterhin ordnungsgemäß funktionieren, nachdem der Name des virtuellen Computers geändert wurde.

    Warnhinweis Vorsicht

    Wenn die Anwendung von einem bestimmten Computernamen oder der Zugehörigkeit zu einer bestimmten Domäne abhängig ist, funktioniert die Anwendung möglicherweise nicht, wenn ein neuer virtueller Computer anhand der Vorlage bereitgestellt wird.

  3. Vergewissern Sie sich, dass auf dem virtuellen Computer kein Medium (DVD) geladen ist. Weitere Informationen zum Entfernen von Medien finden Sie unter Vorgehensweise beim Hinzufügen eines DVD- oder CD-Laufwerks zu einer virtuellen Maschine.

  4. Fahren Sie den virtuellen Computer herunter. Klicken Sie in der SCVMM-Administratorkonsole mit der rechten Maustaste auf den virtuellen Computer, und klicken Sie auf Herunterfahren.

  5. Wählen Sie den virtuellen Computer aus, und erstellen Sie einen Klon. Dieser Schritt wird empfohlen, da der ursprüngliche virtuelle Computer beim Konvertieren zu einer Vorlage zerstört wird.

  6. Wählen Sie den Klon aus, und entfernen Sie alle Prüfpunkte auf dem virtuellen Computer. Dies ist erforderlich, da ein virtueller Computer mit Prüfpunkten von SCVMM nicht zu einer Vorlage konvertiert werden kann.

    1. Klicken Sie mit der rechten Maustaste auf den virtuellen Computer, und klicken Sie anschließend auf Prüfpunkte verwalten.

    2. Klicken Sie auf die einzelnen Prüfpunkte und anschließend auf Entfernen.

  7. Wenn Sie die Prüfpunkte eines virtuellen Computers entfernen, werden die den Prüfpunkten zugeordneten Datenträger von Hyper-V zusammengeführt. Dies kann je nach Größe der Prüfpunkte einige Minuten dauern. Verwenden Sie zum Überprüfen des Zusammenführungsstatus den Hyper-V-Manager auf dem Host, auf dem der virtuelle Computer bereitgestellt wird. Warten Sie, bis die Zusammenführung abgeschlossen ist, und fahren Sie dann mit dem nächsten Schritt fort.

  8. Klicken Sie in der SCVMM-Administratorkonsole mit der rechten Maustaste auf den virtuellen Computer, und klicken Sie anschließend auf Neue Vorlage.

    1. Übernehmen Sie auf allen Bildschirmen die Standardeinstellungen. Wählen Sie die SCVMM-Bibliotheksfreigabe aus, wenn Sie zum Eingeben eines Speicherorts für die Bibliotheksfreigabe aufgefordert werden.

    2. Klicken Sie auf Erstellen, um den SCVMM-Auftrag zu starten. Wird der SCVMM-Auftrag nicht erfolgreich abgeschlossen, lesen Sie die Fehlermeldung, und führen Sie die entsprechenden Aktionen aus.

Siehe auch

Konzepte

Konfigurieren von Lab Management für SCVMM-Umgebungen
Erstellen von Lab-Umgebungen
Gewusst wie: Erstellen und Verwenden einer netzwerkisolierten Umgebung


Gewusst wie: Vorbereiten eines virtuellen Domänencontrollercomputers mit SCVMM

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Vorbereiten eines virtuellen Domänencontrollercomputers mit SCVMM
Siehe auch Feedback senden

Eine virtuelle Umgebung mit Netzwerkisolation erfordert, dass die virtuellen Computer in der Umgebung sich entweder in Arbeitsgruppen befinden oder einer privaten Domäne angehören, die von einem virtuellen Domänencontrollercomputer in der Umgebung gesteuert werden. Die Schritte zum Einrichten einer Umgebung, die Netzwerkisolation verwendet, umfassen auch das Vorbereiten eines virtuellen Domänencontrollercomputers. Weitere Informationen zu den anderen Schritten finden Sie unter Gewusst wie: Erstellen und Verwenden einer netzwerkisolierten Umgebung.

Erforderliche Berechtigungen

Zum Durchführen dieser Schritte müssen Sie Mitglied der folgenden Gruppen sein:

  • Entweder die Benutzerrolle Administrator oder die Rolle Self-Service-Benutzer in System Center Virtual Machine Manager (SCVMM).

Weitere Informationen zu SCVMM-Rollen finden Sie unter Verwalten von Benutzerrollen.

So bereiten Sie einen virtuellen Domänencontrollercomputer vor

  1. Erstellen Sie mithilfe der SCVMM-Administratorkonsole einen neuen virtuellen Computer mit dem Windows Server 2008 R2-Betriebssystem.

    1. Es wird empfohlen, eine Neuinstallation des Betriebssystems zu verwenden, anstatt ein vorhandenes Image wiederzuverwenden oder anzupassen.

    2. Stellen Sie sicher, dass Sie dem virtuellen Computer mindestens 1 GB Arbeitsspeicher zuordnen.

  2. Installieren Sie Active Directory und DNS-Serverrollen auf dem virtuellen Computer. Weitere Informationen zum Installieren von Active Directory unter Windows Server 2008 R2 finden Sie unter Schrittweise Anleitung zum Installieren und Entfernen von Active Directory-Domänendiensten unter Windows Server 2008.

    1. Die Verwendung separater virtueller Computer in einer Umgebung für Active Directory und DNS wird von Lab Management nicht unterstützt.

    2. Stellen Sie sicher, dass der Domänencontroller der einzige Domänencontroller in der Gesamtstruktur ist, und dass er den Stamm der Gesamtstruktur darstellt.

    3. Verwenden Sie keinen Domänennamen, der bereits im Unternehmensnetzwerk oder Labornetzwerk verwendet wird. Wenn eine der Domänen im Netzwerk beispielsweise test.contoso.com heißt, verwenden Sie nicht denselben Namen für die private Domäne.

  3. Installieren Sie den Test-Agent auf dem virtuellen Domänencontrollercomputer. Weitere Informationen finden Sie unter Installieren und Konfigurieren von Test Agents und Testcontrollern.

  4. Überprüfen Sie, ob Active Directory und DNS ordnungsgemäß installiert sind.

  5. Wenn der virtuelle Computer mit einem Netzwerk verbunden war, stellen Sie sicher, dass nur DNS-Einträge für den virtuellen Computer vorhanden sind. Sie müssen diese Schritte nur einmal ausführen: nachdem Sie Active Directory und DNS installiert haben und bevor Sie den virtuellen Computer in Bibliothek speichern. Führen Sie diese Schritte aus, und fahren Sie den virtuellen Computer anschließend umgehend herunter. Wenn Sie den virtuellen Computer neu starten, nachdem Sie diese Schritte ausgeführt haben, oder wenn der virtuelle Computer nach dem Ausführen dieser Schritte noch über einen längeren Zeitraum ausgeführt wird, müssen die Schritte wiederholt werden.

    1. Öffnen Sie das DNS-Tool, indem Sie auf Start, Verwaltung und DNS klicken.

    2. Navigieren Sie im DNS-Tool zu Forward-Lookupzonen. Wählen Sie alle unter Forward-Lookupzonen aufgeführten Zonen aus. Löschen Sie anschließend alle DNS-Einträge unter dieser Zone, für die in der Spalte Daten eine IP-Adresse aufgeführt wird.

    3. Navigieren Sie im DNS-Tool zu Reverse-Lookupzonen. Wenn eine Reverse-Lookupzone konfiguriert ist, löschen Sie alle DNS-Einträge unter der betreffenden Zone.

    4. Schließen Sie das DNS-Tool.

  6. Fahren Sie den virtuellen Computer herunter, und speichern Sie ihn in der SCVMM-Bibliothek.

    1. Deaktivieren Sie nicht den virtuellen Active Directory-Computer. Diesen Computer müssen Sie ordnungsgemäß ausschalten.

    2. Führen Sie keine Generalisierung des virtuellen Active Directory-Computers aus, weder durch Ausführen von Sysprep noch durch Speichern des virtuellen Computers als Vorlage in SCVMM.

Siehe auch

Konzepte

Gewusst wie: Erstellen und Verwenden einer netzwerkisolierten Umgebung
Konfigurieren von Lab Management für SCVMM-Umgebungen


Ändern von vorhandenen Konfigurationen von Lab-Management

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Ändern von vorhandenen Konfigurationen von Lab-Management
Siehe auch Feedback senden

Nachdem Sie Lab Management konfiguriert haben, können Sie die Ressourcen ändern, die Sie für eine Teamprojektsammlung verwenden. Sie können beispielsweise mehr Ressourcen hinzufügen, wenn Sie weitere virtuelle Computer, Vorlagen und Umgebungen erstellen, das Integrationsdienstkonto ändern oder einen Build- oder Testcontroller hinzufügen.

Aufgaben

In den folgenden Themen erfahren Sie, wie Sie vorhandene Lab Management-Konfigurationen ändern:

Aufgaben

Verwandte Themen

Ändern der Hostgruppen für die Teamprojektsammlung: Sie können Hostgruppen zu der Teamprojektsammlung hinzufügen oder auf dieser entfernen. Verwenden Sie hierzu die Verwaltungskonsole für Team Foundation oder das Befehlszeilenprogramm TFSLabConfig.

  • Gewusst wie: Ändern der Hostgruppen für die Teamprojektsammlungen

Ändern der Bibliotheksfreigaben für die Teamprojektsammlung: Sie können weitere Bibliotheksfreigabe hinzufügen, um mehr Speicherplatz für die virtuellen Umgebungen, Vorlagen oder virtuellen Computer bereitzustellen.

  • Gewusst wie: Ändern der Bibliotheksfreigabe für die Teamprojektsammlungen

Ändern des Integrationsdienstkontos für die Kommunikation zwischen den Agents und Controllern: Es wird empfohlen, dieses Benutzerkonto aus Sicherheitsgründen regelmäßig zu ändern.

  • Gewusst wie: Konfigurieren des Dienstkontos

Ändern Sie die Active Directory-Domäne, der der SCVMM-Server angehört.

  • Gewusst wie: Verknüpfen des SCVMM-Servers mit einer anderen Domäne

Siehe auch

Konzepte

Konfigurieren von Lab Management für SCVMM-Umgebungen
Konfigurieren und Verwalten von Lab-Management
Verwalten von Team Foundation Server


Gewusst wie: Ändern der Hostgruppen für die Teamprojektsammlungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Ändern der Hostgruppen für die Teamprojektsammlungen
Siehe auch Feedback senden

Sie können die Hostgruppen in System Center Virtual Machine Manager nutzen, um die Hosts virtueller Computer auf einfache Weise zu überwachen. Hosts sind die Computer in der Hostgruppe, mit der Sie virtuelle Umgebungen in Visual Studio Lab Management bereitstellen. Sie erstellen und verwalten Hostgruppen mit SCVMM. In Lab Management können Sie angeben, welche Hostgruppen für eine Teamprojektsammlung verwendet werden.

Wenn Sie einer vorhandenen Hostgruppe einen Host hinzufügen möchten, müssen Sie zur Ausführung dieser Aufgabe SCVMM verwenden. Weitere Informationen finden Sie auf der Microsoft-Website. Wenn Sie einen Host hinzufügen, müssen Sie auch Folgendes überprüfen:

  • Das logische Netzwerk der Hostgruppe ist das gleiche wie bei den anderen Hosts, damit die virtuellen Computer miteinander kommunizieren können.

  • Der Host wurde der richtigen Hostgruppe hinzugefügt.

Nach der ersten Konfiguration von Lab Management möchten Sie später ggf. die Hostgruppen ändern, die von der Teamprojektsammlung verwendet werden. Sie benötigen z. B. weitere Hosts, da der Umfang der Verwendung zugenommen hat. Sie können beispielsweise eine andere Hostgruppe, die Sie verwenden können, der vorhandenen Teamprojektsammlung hinzufügen, um die Kapazität zu erhöhen. Sie können jeder Teamprojektsammlung mehrere Hostgruppen hinzufügen.

Hinweis Hinweis

Informationen zur ersten Konfiguration von Lab Management finden Sie unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

Sie können die Hostgruppen für eine Teamprojektsammlung mithilfe der Verwaltungskonsole für Team Foundation ändern. Sie können für diese Aufgabe aber auch die Befehlszeile verwenden. Weitere Informationen zum Befehlszeilenprogramm TFSLabConfig finden Sie unter Konfigurieren von Lab-Management mit TFSLabConfig.

Hinweis Hinweis

Wenn Sie eine Hostgruppe, die Sie mit SCVMM erstellt haben, einem bestimmten Teamprojekt zuweisen möchten, das Sie der Teamprojektsammlung hinzugefügt haben, müssen Sie zur Ausführung dieser Aufgabe das Befehlszeilenprogramm verwenden. Sie können Hostgruppen nicht mithilfe der Verwaltungskonsole bestimmten Teamprojekten zuweisen. Weitere Informationen finden Sie unter TFSLabConfig CreateTeamProjectHostGroup-Befehl.

Führen Sie das folgende Verfahren aus, um die Hostgruppen für die Teamprojektsammlung mit der Verwaltungskonsole für Team Foundation zu ändern. Sie müssen die Schritte des Verfahrens ebenfalls für jeden Host in einer hinzugefügten Hostgruppe ausführen, um die Zuverlässigkeit von WinRM zu verbessern. Informationen zum Erweitern des virtuellen Lab finden Sie unter Erweitern oder Ändern des virtuellen Labs.

So können Sie Hostgruppen für die Teamprojektsammlung hinzufügen oder entfernen

  1. Klicken Sie in der Team Foundation-Verwaltungskonsole unter Anwendungsebene auf Teamprojektsammlungen.

  2. Klicken Sie im rechten Bereich in der Liste mit den Projektauflistungen auf die gewünschte Teamprojektsammlung.

  3. Klicken Sie auf die Registerkarte Lab Management und anschließend auf Hostgruppen konfigurieren.

    Das Dialogfeld Lab-Management-Einstellungen auf Projektauflistungsebene bearbeiten wird angezeigt.

  4. Klicken Sie zum Hinzufügen einer Hostgruppe auf der Registerkarte Hostgruppen auf Hinzufügen und überprüfen.

    1. Klicken Sie im Dialogfeld Hostgruppen auswählen auf mindestens eine SCVMM-Hostgruppe, die von dieser Teamprojektsammlung verwendet werden soll, und klicken Sie anschließend auf Hinzufügen.

    2. Um jedem Teamprojekt in der Teamprojektsammlung die Hostgruppe hinzuzufügen, wählen Sie Automatische Bereitstellung für die Hostgruppe aus.

      Hinweis Hinweis

      Wenn Sie die Hostgruppe automatisch bereitstellen, wird die Hostgruppe von Team Foundation Server automatisch zu allen Teamprojekten in dieser Teamprojektsammlung hinzugefügt. Für Teamprojekte, die noch nicht erstellt wurden, wird die Hostgruppe hinzugefügt, wenn der Assistent für neue Teamprojekte das Projekt erstellt. Für Teamprojekte, die in dieser Teamprojektsammlung bereits erstellt wurden, wird die Hostgruppe hinzugefügt, wenn diese Einstellungen gespeichert werden. Wenn Sie Automatische Bereitstellung deaktivieren, wird die Hostgruppe nicht mehr zu neuen Teamprojekten hinzugefügt, die Sie der Teamprojektsammlung hinzufügen.

  5. Um eine Hostgruppe aus der Teamprojektsammlung zu löschen, wählen Sie die Hostgruppe auf der Registerkarte Hostgruppen aus, und klicken Sie auf Löschen.

    Wichtiger Hinweis Wichtig

    Bevor Sie eine Hostgruppe aus einer Teamprojektsammlung löschen können, müssen Sie zuerst alle Lab Management-Umgebungen, die sich in dieser Hostgruppe befinden, mit Microsoft Test Manager entfernen. Dann müssen Sie mit dem Befehlszeilenprogramm TFSLabConfig die Zuordnung dieser Hostgruppe aus jedem Teamprojekt in dieser Projektsammlung entfernen. Weitere Informationen hierzu finden Sie unter TFSLabConfig DeleteTeamProjectHostGroup-Befehl.

  6. Klicken Sie auf OK.

Verbessern der Zuverlässigkeit von WinRM

Sie müssen folgende Änderungen an den Standardkonfigurationseinstellungen der Windows-Remoteverwaltung (WinRM) für jeden Host in einer Hostgruppe vornehmen, die Sie hinzugefügt haben. Die Änderungen an diesen Einstellungen erhöhen die Zuverlässigkeit von WinRM, da Lab Management eine größere Anzahl von Vorgängen als in einem herkömmlichen Produktionsszenario für Hyper-V auf Hyper-V-Hosts ausführt.

So ändern Sie die Konfigurationseinstellungen der Windows-Remoteverwaltung

  1. Klicken Sie auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie anschließend auf Als Administrator ausführen.

    Hinweis Hinweis

    Sie müssen ein Domänenbenutzer sein, der der Administratorgruppe für diesen Computer hinzugefügt wurde.

  2. Führen Sie an der Eingabeaufforderung folgenden Befehl aus:

    winrm set winrm/config @{MaxTimeoutms = "1800000"}

  3. Handelt es sich bei dem Betriebssystem auf dem Host um Windows Server 2008 SP2, führen Sie auch den folgenden Befehl aus:

    winrm set winrm/config/Service @{MaxConcurrentOperations="200"} -r:http://<HyperVHost>

    (Ersetzen Sie HyperVHost durch den Computernamen des Hyper-V-Hosts.)

    Hinweis Hinweis

    Um einen WinRM-Listener unter "http://<HyperVHost>" zu erstellen, müssen Sie ggf. auch den folgenden Befehl ausführen:

    winrm quickconfig

  4. Starten Sie WinRM und den SCVMM-Agent auf den Hosts mit den folgenden Befehlen neu, nachdem Sie diese Änderungen vorgenommen haben:

    net stop winrm

    net start winrm

    net start vmmagent

Siehe auch

Aufgaben

Erstellen einer Teamprojektsammlung

Konzepte

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Weitere Ressourcen

Ändern von vorhandenen Konfigurationen von Lab-Management


Gewusst wie: Ändern der Bibliotheksfreigabe für die Teamprojektsammlungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Ändern der Bibliotheksfreigabe für die Teamprojektsammlungen
Siehe auch Feedback senden

Sie können die Bibliotheksfreigaben in der System Center Virtual Machine Manager (SVVMM)-Bibliothek als Ort zum Erstellen und Speichern der virtuellen Computer, Vorlagen und Umgebungen in den Teamprojekten verwenden. Sie verwenden SCVMM, um Bibliotheksfreigaben zu erstellen und zu verwalten und um den Computer anzugeben, auf dem sich eine Bibliotheksfreigabe befindet.

Nach der ersten Konfiguration von Lab Management möchten Sie später ggf. die Bibliotheksfreigaben ändern, die von der Teamprojektsammlung verwendet werden.

Hinweis Hinweis

Informationen zur ersten Konfiguration von Lab Management finden Sie unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

Mit SCVMM können Sie mehrere Bibliotheksfreigaben auf einem einzelnen Bibliotheksserver erstellen. Die Bibliotheksfreigaben ermöglichen es Ihnen, den Speicherplatz auf dem Bibliotheksserver zu reservieren. Insbesondere können Sie Speicherplatz für jede Teamprojektsammlung reservieren. Sie können jeder Teamprojektsammlung mehrere Bibliotheksfreigaben hinzufügen. Sie können z. B. eine zusätzliche Bibliotheksfreigabe von einem anderen Bibliotheksserver einer bestimmten Teamprojektsammlung hinzufügen, um mehr Speicherplatz für die Umgebungen, virtuellen Computer und Vorlagen für die Teams bereitzustellen, die diese Teamprojektsammlung verwenden. Wenn Sie die Netzwerkbandbreite zu einem bestimmten Bibliotheksserver für die Teamprojektsammlung maximieren, möchten Sie ggf. eine Bibliotheksfreigabe von einem anderen Bibliotheksserver hinzufügen. Oder Sie möchten eine Bibliotheksfreigabe hinzufügen, die einem Bibliotheksserver an einem anderen physischen Speicherort hinzugefügt wurde.

Hinweis Hinweis

Um die Leistung zu verbessern, sollten Sie für Bibliotheksfreigaben und Hostgruppen den gleichen physischen Speicherort verwenden. Wenn Sie beispielsweise ein verteiltes Team haben und sich eine Hälfte des Teams in einem Land und die andere Hälfte in einem anderen Land befindet, ist es effizienter, Bibliotheksfreigaben und Hostgruppen zu verwenden, die sich physisch in dem jeweiligen Land befinden und dort für die jeweiligen Teammitgliedern in ihrem Land zur Verfügung stehen. Sie können die Bibliotheksfreigaben mit der Verwaltungskonsole für Team Foundation ändern. Sie können für diese Aufgabe aber auch die Befehlszeile verwenden. Weitere Informationen zum Befehlszeilenprogramm TFSLabConfig finden Sie unter Konfigurieren von Lab-Management mit TFSLabConfig.

Führen Sie das folgende Verfahren aus, um die Bibliotheksfreigaben für die Teamprojektsammlung mit der Verwaltungskonsole für Team Foundation zu ändern. Für jede Bibliotheksfreigabe, die Sie hinzufügen und die sich auf einem anderen Bibliotheksserver befindet, müssen die Schritte des Verfahrens ebenfalls ausgeführt werden, um die Zuverlässigkeit von WinRM zu verbessern. Informationen zum Erweitern des virtuellen Lab finden Sie unter Erweitern oder Ändern des virtuellen Labs.

So können Sie Bibliotheksfreigaben für eine Teamprojektsammlung hinzufügen oder entfernen

  1. Klicken Sie in der Team Foundation-Verwaltungskonsole unter Anwendungsebene auf Teamprojektsammlungen.

  2. Klicken Sie im rechten Bereich in der Liste mit den Projektauflistungen auf die gewünschte Teamprojektsammlung.

  3. Klicken Sie auf die Registerkarte Lab-Management und anschließend auf Bibliotheksfreigaben konfigurieren.

    Hinweis Hinweis

    Sie müssen eine Bibliotheksfreigabe mithilfe von SCVMM erstellen, bevor Sie diese hinzufügen können, damit sie von der Teamprojektsammlung verwendet werden kann.

  4. Klicken Sie zum Hinzufügen einer Bibliotheksfreigabe auf der Registerkarte Bibliotheksfreigaben auf Hinzufügen und überprüfen.

    Das Dialogfeld Bibliotheksfreigaben auswählen wird angezeigt.

    1. Klicken Sie auf eine oder mehrere SCVMM-Bibliotheksfreigaben, die diese Teamprojektsammlung verwendet, und klicken Sie dann auf Hinzufügen.

    2. Um jedem Teamprojekt in der Teamprojektsammlung die Bibliotheksfreigabe hinzuzufügen, wählen Sie Automatische Bereitstellung für die Bibliotheksfreigabe aus.

      Hinweis Hinweis

      Wenn Sie die Bibliotheksfreigabe automatisch bereitstellen, fügt Team Foundation Server die Bibliotheksfreigabe automatisch allen Teamprojekten in dieser Teamprojektsammlung hinzu. Für Teamprojekte, die noch nicht erstellt wurden, wird die Bibliotheksfreigabe hinzugefügt, wenn der Assistent für neue Teamprojekte das Projekt erstellt. Für Teamprojekte, die in dieser Teamprojektsammlung bereits erstellt wurden, wird die Bibliotheksfreigabe hinzugefügt, wenn diese Einstellungen gespeichert werden. Wenn Sie Automatische Bereitstellung deaktivieren, wird die Bibliotheksfreigabe nicht mehr zu neuen Teamprojekten hinzugefügt, die Sie der Teamprojektsammlung hinzufügen.

  5. Um eine Bibliotheksfreigabe zu löschen, wählen Sie auf der Registerkarte Bibliotheksfreigaben die entsprechende Bibliotheksfreigabe in der Liste aus, und klicken Sie dann auf Löschen.

    Wichtiger Hinweis Wichtig

    Bevor Sie eine Bibliotheksfreigabe aus einer Teamprojektsammlung löschen können, müssen Sie zuerst mit Microsoft Test Manager alle Lab Management-Umgebungen, virtuellen Computer und Vorlagen entfernen, die auf dieser Bibliotheksfreigabe gespeichert werden. Dann müssen Sie mit dem Befehlszeilenprogramm TFSLabConfig die Zuordnung dieser Bibliotheksfreigabe aus jedem Teamprojekt in dieser Projektsammlung entfernen. Weitere Informationen hierzu finden Sie unter TFSLabConfig DeleteTeamProjectLibraryShare-Befehl.

  6. Klicken Sie auf Überprüfen, um zu überprüfen, ob Visual Studio Team Foundation Server eine Verbindung mit der Bibliotheksfreigabe herstellen kann.

  7. Klicken Sie auf OK.

Verbessern der Zuverlässigkeit von WinRM

Sie müssen folgende Änderungen an den Standardkonfigurationseinstellungen der Windows-Remoteverwaltung (WinRM) für jeden Bibliotheksserver vornehmen, der über Bibliotheksfreigaben verfügt, die Sie für Lab Management verwenden. Die Änderungen an diesen Einstellungen erhöhen die Zuverlässigkeit von WinRM, da Lab Management eine größere Anzahl von Vorgängen als in einem herkömmlichen Produktionsszenario für Hyper-V auf Hyper-V-Hosts ausführt.

So ändern Sie die Konfigurationseinstellungen der Windows-Remoteverwaltung

  1. Klicken Sie auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie anschließend auf Als Administrator ausführen.

    Hinweis Hinweis

    Sie müssen ein Domänenbenutzer sein, der der Administratorgruppe für diesen Computer hinzugefügt wurde.

  2. Führen Sie an der Eingabeaufforderung folgenden Befehl aus:

    winrm set winrm/config @{MaxTimeoutms = "1800000"}

  3. Handelt es sich bei dem Betriebssystem auf dem Host um Windows Server 2008 SP2, führen Sie auch den folgenden Befehl aus:

    winrm set winrm/config/Service @{MaxConcurrentOperations="200"} -r:http://<LibraryServerMachine>

    (Ersetzen Sie LibraryServerMachine durch den Computernamen des Bibliotheksservers.

    Hinweis Hinweis

    Um einen WinRM-Listener unter "http://<LibrayServerMachine>" zu erstellen, müssen Sie ggf. auch den folgenden Befehl ausführen:

    winrm quickconfig

  4. Starten Sie WinRM und den SCVMM-Agent auf den Hosts mit den folgenden Befehlen neu, nachdem Sie diese Änderungen vorgenommen haben:

    net stop winrm

    net start winrm

    net start vmmagent

Siehe auch

Aufgaben

Erstellen einer Teamprojektsammlung

Konzepte

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Weitere Ressourcen

Ändern von vorhandenen Konfigurationen von Lab-Management


Gewusst wie: Konfigurieren des Dienstkontos

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Konfigurieren des Dienstkontos
Siehe auch Feedback senden

Wenn Sie den Lab Management -Workflow verwenden möchten, um eine Anwendung zu erstellen, bereitzustellen und zu testen, oder um automatisierte Tests oder manuelle Tests in einer virtuellen Umgebung auszuführen, müssen Sie das Lab-Dienstkonto konfigurieren. In diesem Thema werden die Funktion, die Berechtigungen und die Konfiguration des Lab-Dienstkontos beschrieben. Weitere Informationen zum Lab-Dienstkonto finden Sie auch auf dieser Microsoft-Website.

In diesem Thema werden die Funktion, die Berechtigungen und die Konfiguration des Lab-Dienstkontos beschrieben. Weitere Informationen zum Lab-Dienstkonto finden Sie auf dieser Microsoft-Website.

Das Lab-Dienstkonto

In Lab Management wird das Lab-Dienstkonto für die Kommunikation zwischen dem Test-Agent und dem Testcontroller sowie zwischen dem Build-Agent und Team Foundation verwendet.

Hinweis Hinweis

Die Verwendung des Lab-Dienstkontos wird zwar dringend empfohlen, ist aber nicht zwingend erforderlich, da Sie auch die lokalen Konten auf jedem Computer verwenden können. Indem Sie das Lab-Dienstkonto in der Team Foundation-Verwaltungskonsole konfigurieren, müssen Sie sich jedoch nicht die Mühe machen und Berechtigungen manuell gewähren bzw. Agents und Controller bestimmten Dienstkonten zuweisen.

Mit dem Lab-Dienstkonto können Sie Build-Agents und Test Agents unter einem beliebigen Systemkonto ausführen. Wenn Sie jedoch das Lab-Dienstkonto konfigurieren, wird dem Konto automatisch nur der minimale Satz von Berechtigungen gewährt, der für die Kommunikation des Test- und Build-Agents mit deren Controllern erforderlich ist. Diese Berechtigungen lassen die folgende Kommunikation zu:

  • Der Test-Agent kann mit dem Testcontroller kommunizieren. In Lab-Umgebungen verwendet der Test Agent ein Lab-Dienstkonto, um mit dem Testcontroller zu kommunizieren; dieses Konto wird jedoch nicht zur Ausführung des Test Agents verwendet. Der Test Agent verwendet das Konto, das bei Verwendung des Test-Agent-Konfigurationstools konfiguriert wurde. Der Test Agent greift mithilfe des Lab-Dienstkontos auf den Ablagespeicherort des Builds zu.

    Warnhinweis Vorsicht

    Durch die Konfiguration des Lab-Dienstkontos werden dem Konto nicht automatisch Leseberechtigungen für den Ablagespeicherort des Builds gewährt. Sie müssen das Lab-Dienstkonto den Konten, die den Ablagespeicherort des Builds lesen können, manuell hinzufügen.

  • Der Build-Agent kann mit Team Foundation Server kommunizieren. Das Lab-Dienstkonto wird der Gruppe Builddienstkonten für die Projektauflistung automatisch hinzugefügt. In workflowfähigen Lab-Umgebungen kommuniziert der Build-Agent mithilfe des Lab-Dienstkontos mit Team Foundation. Dieses Konto wird nur für die Kommunikation zwischen dem Build-Agent und Team Foundation verwendet, und nicht zum Ausführen des Build-Agents. Der Build-Agent verwendet das Konto, das bei Verwendung der Verwaltungskonsole konfiguriert wurde. Stellen Sie sicher, dass der Build-Agent unter einer Domäne oder einem Systemkonto ausgeführt wird, das Administratorrechte auf dem lokalen Computer hat.

    Warnhinweis Vorsicht

    Durch die Konfiguration des Lab-Dienstkontos werden dem Konto nicht automatisch Leseberechtigungen für den Ablagespeicherort des Builds gewährt. Sie müssen das Lab-Dienstkonto den Konten, die den Ablagespeicherort des Builds lesen können, manuell hinzufügen.

  • Der Build-Agent greift mithilfe des Lab-Dienstkontos auf den Ablagespeicherort des Builds zu. Die vom Lab-Workflow verwendeten Build-Agents werden nicht mit den gleichen Berechtigungen konfiguriert, die die Build-Agents zur Kompilierung eines Builds verwendet haben. Den zur Kompilierung der Quelldateien verwendeten Build-Agents werden Leseberechtigungen im Quellcodeverwaltungssystem gewährt. Da die vom Lab-Workflow verwendeten Build-Agents die Quelldateien nicht lesen müssen, werden ihnen explizit alle Berechtigungen für Quellcodeverwaltungsartefakte in der Projektauflistung verweigert. Die Build-Agents im Lab-Workflow werden nur verwendet, um die in der Workflowvorlage angegebenen Bereitstellungsskripts auszuführen. Bevor die einzelnen Bereitstellungsskripte ausgeführt werden, konfiguriert der Build-Agent seine angemeldete Sitzung so, dass er mithilfe des Lab-Dienstkontos auf den Ablagespeicherort zugreift. Wenn das Skript abgeschlossen ist, entfernt der Build-Agent diese Konfiguration.

Konfigurieren des Dienstkontos

Verwenden Sie bei der ersten Konfiguration des Lab-Dienstkontos die Team Foundation-Verwaltungskonsole. Weitere Informationen finden Sie unter Konfigurieren von Lab Management für SCVMM-Umgebungen. Beachten Sie die folgenden Richtlinien, wenn Sie ein Systemkonto auswählen, das für das Lab-Dienstkonto verwendet werden soll:

  • Das Lab-Dienstkonto muss ein Domänenkonto sein.

  • Das Lab-Dienstkonto darf nicht Mitglied der Sicherheitsgruppe Administratoren auf dem Computer sein. Die Kontoinformationen für das Lab-Dienstkonto sind zwar sicher in Team Foundation Server gespeichert, sie sind jedoch möglicherweise auf einzelnen virtuellen Computern nicht sicher gespeichert.

  • Das Dienstkonto sollte nicht das Konto sein, das für den Buildcontroller, den Testcontroller oder einen anderen vertrauenswürdigen Dienst verwendet wird. Diese Dienstkonten benötigen mehr Berechtigungen als die Agents.

  • Das Dienstkonto sollte über eingeschränkte Benutzerberechtigungen verfügen.

    Hinweis Hinweis

    Es wird auch empfohlen, zwei Konten für dieses Dienstkonto zu erstellen. So wird die Wahrscheinlichkeit verringert, dass die Test- oder Workflowfunktionen aufgrund einer Kennwortänderung für dieses Konto nicht verfügbar sind.

  • Der Administrator für Teamprojektsammlungen sollte der einzige Benutzer sein, der über die Berechtigung zum Ändern des Kennworts für das Dienstkonto verfügt.

Nachdem Sie das Lab-Dienstkonto für die Teamprojektauflistung konfiguriert haben, können Sie die konfigurierten Kontoinformationen auf der Registerkarte Lab Management für die Projektauflistung in der Team Foundation-Verwaltungskonsole anzeigen. Es wird empfohlen, dass Sie dieses Dienstkonto aus Sicherheitsgründen regelmäßig ändern.

Sie können das Dienstkonto mithilfe der Verwaltungskonsole für Team Foundation ändern. Sie können das Dienstkonto auch über die Befehlszeile ändern. Weitere Informationen finden Sie unter zum Befehlszeilenprogramm TFSLabConfig finden Sie unter Konfigurieren von Lab-Management mit TFSLabConfig.

Führen Sie zum Konfigurieren des Diensts die folgenden Verfahren aus:

So konfigurieren Sie das Dienstkonto, um die Test- und Buildworkflowfunktionen zu aktivieren

  1. Klicken Sie in der Team Foundation-Verwaltungskonsole unter Anwendungsebene auf Teamprojektsammlungen.

  2. Klicken Sie im rechten Bereich in der Liste mit den Projektauflistungen auf die gewünschte Teamprojektsammlung.

  3. Klicken Sie auf die Registerkarte Lab-Management und anschließend auf Benutzerkonto konfigurieren.

  4. Um das Dienstkonto zu ändern, klicken Sie auf Dienstkonto.

  5. Geben Sie auf der Registerkarte Dienstkonto den Namen des Kontos unter Kontoname und das Kennwort unter Kennwort ein.

  6. Klicken Sie zum Überprüfen, ob das Benutzerkonto gültig ist, auf Test.

  7. Klicken Sie auf OK.

    Hinweis Hinweis

    Wenn beim Ändern des Dienstkontos Umgebungen vorhanden sind, werden diese Umgebungen nicht automatisch aktualisiert. Für die Test- und Workflowfunktionen wird möglicherweise anhand eines Status angezeigt, dass sie nicht bereit sind. In der Ansicht "Umgebungen" wird für Microsoft Test Manager eine Fehlermeldung angezeigt. Klicken Sie dort auf Wiederholen, damit der neue Benutzername und das Kennwort aktualisiert werden. Anhand eines Status wird angezeigt, dass die Funktionen bereit sind. Sie können auch das Befehlszeilenprogramm TFSLabConfig verwenden, um alle vorhandenen Umgebungen zu aktualisieren: TFSLabConfig UpdateServiceAccountOnDeployedEnvironments-Befehl. Das Befehlszeilenprogramm hat keine Auswirkungen auf Vorgänge, die derzeit ausgeführt werden, z. B. Workflow oder Tests.

Verwenden Sie die folgenden Verfahren, um zwischen zwei Dienstkonten zu wechseln. So wird die Wahrscheinlichkeit verringert, dass die Test- oder Workflowfunktionen nicht verfügbar sind.

So wechseln Sie zwischen zwei Dienstkonten, um das Risiko zu verringern, dass die Test- oder Workflowfunktionen nicht verfügbar sind

  1. Suchen Sie die Kennwortablaufrichtlinie für die Domäne. In diesem Verfahren wird ein Standardwert von 42 Tagen angenommen.

  2. Legen Sie den Kennwortablauf für beide Konten, Account1 und Account2, auf 42 Tage fest.

  3. Verwenden Sie Account1 als Dienstkonto.

  4. Setzen Sie nach 21 Tagen (die Hälfte des Ablaufzeitraums) das Kennwort für Account2 zurück. Konfigurieren Sie dann mithilfe des vorherigen Verfahrens Account2 als Dienstkonto.

  5. Alle 21 Tage (die Hälfte des Ablaufzeitraums) müssen Sie Schritt 4 wiederholen, indem Sie das Kennwort zurücksetzen und das Konto, das derzeit nicht verwendet wird, als Dienstkonto konfigurieren.

Wenn Sie das Dienstkonto für Team Foundation konfigurieren oder aktualisieren, wird das Konto nicht automatisch in jeder vorhandenen Umgebung aktualisiert. Es gibt zwei Möglichkeiten, das aktualisierte Konto an die vorhandenen Umgebungen weiterzugeben:

  • Führen Sie den Befehl UpdateServiceAccountOnDeployedEnvironments aus, der das Konto in eine Projektauflistung in jeder Umgebung schiebt. Weitere Informationen zu diesem Befehl finden Sie unter TFSLabConfig UpdateServiceAccountOnDeployedEnvironments-Befehl.

  • Führen Sie einen der folgenden Vorgänge in jeder Umgebung aus.

    • Reparieren Sie die Umgebung.

    • Nehmen Sie eine Änderung an der Lab-Umgebung vor.

    • Stellen Sie eine SCVMM-Umgebung in einer Momentaufnahme wieder her.

Es wird empfohlen, dass Sie das Dienstkonto mithilfe des UpdateServiceAccountOnDeployedEnvironments-Befehls aktualisieren. Dieser Befehl hat keine Auswirkungen auf laufende Vorgänge, wie z. B. Workflows oder Testläufe, in einer der Umgebungen. Nach Verwendung dieses Befehls wird das Konto in die Umgebung geschoben, und die Agents wenden den Befehl folgendermaßen an:

  • Auf Test-Agents, auf denen keine Tests ausgeführt werden, wird er sofort angewendet.

  • Auf Test-Agents, auf denen Tests ausgeführt werden, wird der Befehl angewendet, nachdem der Testlauf beendet wurde.

  • Build-Agents wenden das neue Dienstkonto an, wenn Build-Agent-Dienst neu gestartet wird. Der Agent-Dienst wird neu gestartet, wenn die Workflowfunktion repariert, die Umgebung gestartet oder eine Momentaufnahme für eine Umgebung wiederhergestellt wird.

Siehe auch

Aufgaben

Erstellen einer Teamprojektsammlung

Konzepte

Konfigurieren von Lab Management für SCVMM-Umgebungen
Ausführen von Tests in Lab-Umgebungen
Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Weitere Ressourcen

Ändern von vorhandenen Konfigurationen von Lab-Management


Erweitern oder Ändern des virtuellen Labs

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Erweitern oder Ändern des virtuellen Labs
Siehe auch Feedback senden

Nachdem Sie eine Weile mit einem virtuellen Lab gearbeitet und seine Funktionen kennen gelernt haben, können Sie es auf unterschiedliche Weise erweitern oder ändern:

  • Verschieben von Team Foundation Server auf einen anderen Server

    Möglicherweise muss der Server, auf dem die Team Foundation Server-Anwendungsebene ausgeführt wird, geändert oder ersetzt werden.

  • Verschieben einer Teamprojektsammlung auf einen anderen Team Foundation Server

    Möglicherweise möchten Sie die Computer und anderen Ressourcen im ursprünglichen Teamprojekt wiederverwenden und diese Ressourcen verschieben.

  • Hinzufügen eines neuen Bibliotheksservers und Zurückziehen eines alten Bibliotheksservers

    Möglicherweise benötigen Sie mehr Platz zum Speichern von virtuellen Computern, Vorlagen und Umgebungen. Sie können weitere Bibliotheksfreigaben hinzufügen oder vorhandene Bibliotheksfreigaben durch Freigaben auf größeren SCVMM-Bibliotheksservern ersetzen.

  • Hinzufügen eines neuen und Zurückziehen eines alten Hyper-V-Hosts

    Möglicherweise benötigen Sie mehr Platz zum Ausführen von virtuellen Computern und Umgebungen. Sie können vorhandenen Hostgruppen weitere physische Hosts hinzufügen, um die Kapazität transparent zu erhöhen.

  • Verschieben von System Center Virtual Machine Manager auf einen anderen Server

    Möglicherweise müssen Sie den Server, auf dem SCVMM ausgeführt wird, ändern oder ersetzen.

  • Verschieben eines Testcontrollers

    Möglicherweise müssen Sie den Computer, auf dem der Testcontroller ausgeführt wird, verschieben oder ersetzen.

Für jede dieser Änderungen muss die Konfiguration von Lab Management-Ressourcen geändert werden.

Verschieben von Team Foundation Server auf einen anderen Server

Wenn Sie Team Foundation Server von einem Server auf einen anderen verschieben oder den Namen des Servers, auf dem Team Foundation Server ausgeführt wird, auf anderem Wege ändern, müssen Sie die URL aktualisieren, die Lab Management-Komponenten für die Kommunikation mit Team Foundation Server verwenden. Weitere Informationen finden Sie unter Verwalten von Team Foundation Server, wenn Sie mehr über das Verschieben von Team Foundation Server erfahren möchten.

Aktualisieren Sie nach dem Verschieben von Team Foundation Server die Team Foundation Server-URL an den folgenden Orten:

  • Auf dem Computer, auf dem Team Foundation Server auf Anwendungsebene ausgeführt wird, wird die URL in der Team Foundation Server-Verwaltungskonsole angezeigt. Wechseln Sie in der Verwaltungskonsole zum Knoten Lab Management, klicken Sie auf Lab Management neu konfigurieren und dann auf die Registerkarte Erweitert. Geben Sie in das Textfeld Lab-URL den neuen Servernamen ein.

  • Auf Computern, auf denen ein Build-Agent installiert ist, wird die URL in der von Hyper-V verwalteten Registrierungsstruktur gespeichert. Klicken Sie beim Umbenennen des Servers, auf dem Team Foundation Server ausgeführt wird, für diese Umgebung auf Workflowfunktion reparieren. Die Einstellung wird automatisch auf allen virtuellen Computern dieser Umgebung aktualisiert. Da die URL von Team Foundation Server in LVR-Dateien intern gespeichert wird, müssen Sie die LVR-Datei manuell ändern, um das XML zu aktualisieren.

    Hinweis Hinweis

    Sie müssen keine Momentaufnahmen wiederherstellen, da die URL auf den virtuellen Computern nach dem Wiederherstellen einer Momentaufnahme von Team Foundation Server aktualisiert wird.

Verschieben einer Teamprojektsammlung auf einen anderen Team Foundation Server

Wenn Sie zum Kennenlernen von Lab Management zunächst zusammengesetzte Umgebungen verwendet oder ein kleines Teamprojekt zum Testen von Team Foundation Server erstellt haben, können Sie die Lab-Ressourcen später in eine andere Team Foundation Server-Instanz migrieren. Da Team Foundation Server das Zusammenführen von Teamprojekten nicht unterstützt, müssen Sie die Lab-Ressourcen manuell verschieben. Weitere Informationen finden Sie unter Verwalten von Team Foundation Server, wenn Sie mehr zum Migrieren von Quellcode, Arbeitsaufgaben und Builddefinitionen erfahren möchten.

Hinweis Hinweis

Virtuelle Computer können nur innerhalb des gleichen Netzwerkspeicherorts verschoben werden, da sie bereits zur Verwendung dieses Netzwerkspeicherorts konfiguriert sind. Wenn Sie eine Teamprojektsammlung zwischen Team Foundation Server-Instanzen in unterschiedlichen Domänen verschieben, müssen Sie die Projektsammlung verschieben, die Konfiguration von Lab Management für diese Projektsammlung aufheben und Lab Management anhand der Einstellungen der neuen Team Foundation Server-Instanz und Domäne neu konfigurieren.

Da die Verschiebung zwischen Domänen erfolgt, ist eine Wiederherstellung nicht möglich.

So verschieben Sie zwischen zwei Servern, auf denen Team Foundation Server ausgeführt wird

  1. Verschieben Sie die Teamprojektsammlung in eine neue Anwendungsebene. Anweisungen dazu finden Sie unter Move a Team Project Collection.

  2. Heben Sie die Konfiguration von Lab Management für die Teamprojektsammlung auf, nachdem Sie die Sammlung an die Team Foundation Server-Zielinstanz angefügt haben. Anweisungen zum Aufheben der Konfiguration finden Sie unter TFSConfig Lab /Delete-Befehl.

  3. Konfigurieren Sie das Lab-Management für die Sammlung in der Team Foundation Server-Zielinstanz neu. Anweisungen zum Konfigurieren von Lab-Management finden Sie unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

Hinzufügen eines neuen Bibliotheksservers und Zurückziehen eines alten Bibliotheksservers

Wenn Sie den Speicher für System Center Virtual Machine Manager (SCVMM) erweitern müssen, können Sie neue Bibliotheksfreigaben hinzufügen. Sie können auch vorhandene Freigaben durch Freigaben auf Servern mit schnelleren Prozessoren, mehr Festplatten oder beidem ersetzen. Gehen Sie wie folgt vor, um dem von Lab Management verwendeten SCVMM-Server eine Bibliotheksfreigabe hinzuzufügen oder eine Bibliotheksfreigabe zu entfernen:

  1. Bereiten Sie das Verschieben in eine neue Bibliotheksfreigabe vor.

  2. Verschieben Sie die Vorlagen.

  3. Verschieben Sie die importierten virtuellen Computer, die zurzeit nicht in virtuellen Umgebungen verwendet werden.

  4. Verschieben Sie die gespeicherten Umgebungen.

  5. Entfernen Sie die alte Bibliotheksfreigabe.

    Hinweis Hinweis

    In diesem Szenario werden keine vorhandenen LVR-Dateien aktualisiert, die u. U. zu aktiven Fehlern gehören. Wenn gespeicherte Umgebungen vorhanden sind, die zum Reproduzieren von Fehlern erforderlich sind, sollten diese Umgebungen in der Quellbibliothek belassen werden, bis die Fehler behoben wurden.

So bereiten Sie das Verschieben vor

  1. Stellen Sie sicher, dass der neue Bibliotheksserver die Systemanforderungen für einen SCVMM-Bibliotheksserver erfüllt. Weitere Informationen finden Sie unter zu den Systemanforderungen finden Sie im Thema zu den Systemanforderungen für VMM-Bibliotheksserver (möglicherweise in englischer Sprache).

  2. Fügen Sie auf dem neuen Server eine neue Bibliotheksfreigabe hinzu:

    1. Erstellen Sie in Windows-Explorer einen neuen Ordner mit dem Namen der neuen Bibliotheksfreigabe.

    2. Geben Sie den neuen Ordner für den SCVMM-Server frei, indem Sie VMM_MACHINE$ der Liste der Benutzer, für die dieser Ordner freigegeben ist, als Teilnehmer hinzufügen.

    3. Ordnen Sie diese Bibliotheksfreigabe in der Virtual Machine Manager-Administratorkonsole zu.

  3. Fügen Sie den betreffenden Teamprojektsammlungen und Teamprojekten die neue Bibliotheksfreigabe hinzu.

    1. Klicken Sie in der TFS-Verwaltungskonsole auf TFS-Server. Klicken Sie auf Anwendungsebene und dann auf Teamprojektsammlungen.

    2. Klicken Sie auf der Registerkarte Lab-Management auf Bibliotheksfreigaben konfigurieren.

    3. Fügen Sie die in SCVMM erstellte Freigabe hinzu.

  4. Sichern Sie die ursprüngliche Bibliotheksfreigabe. Eine Anleitung zum Sichern der Bibliotheksfreigabe finden Sie unter Sichern und Wiederherstellen der VMM-Datenbank.

  5. Führen Sie eine der folgenden Aktionen aus:

    Schalten Sie die Projektsammlungen offline. Es wird empfohlen, die relevanten Projektsammlungen während der Verschiebung offline zu schalten. Dieser Schritt ist jedoch optional.

    - oder -

    Bitten Sie den Systemadministrator, alle Benutzer zu benachrichtigen, dass während der Verschiebung keine Umgebungen bereitgestellt und keine virtuellen Computer oder Vorlagen importiert werden dürfen.

So verschieben Sie Vorlagen

  1. Identifizieren Sie die Dateien, die mit der zu verschiebenden Vorlage zusammenhängen. Verschieben Sie diese Dateien von der Quelle in das Ziel. Stellen Sie im Fall von VHDs von differenzierenden Datenträgern sicher, dass Sie alle Versionen der VHD-Datei verschieben. Für die Suche nach dem Pfad für die VHD-Datei, auf die diese Vorlage zeigt, klicken Sie mit der rechten Maustaste auf die Vorlage und anschließend auf Eigenschaften. Klicken Sie auf Hardwarekonfiguration. Verschieben Sie diese VHD-Datei in die neue Bibliotheksfreigabe.

  2. Klicken Sie in der SCVMM-Administratorkonsole auf Bibliothek. Klicken Sie im Bereich Aktion auf Aktualisieren. Aktualisieren Sie sowohl die alte als auch die neue Bibliotheksfreigabe.

  3. Klicken Sie in Microsoft Test Manager auf Bibliothek. Zeigen Sie auf die neue Bibliotheksfreigabe, und importieren Sie die Vorlagen erneut. Wiederholen Sie diese Schritte für jedes Teamprojekt, das für Lab Management aktiviert ist. Stellen Sie sicher, dass das Betriebssystemprofil und das Hardwareprofil, das Sie für die neue Instanz der Vorlage definieren, mit den Profilen für die alte Vorlage identisch sind.

  4. Wenn die Bibliothek Umgebungen enthält, die auf Vorlagen basieren, sollten Sie die Umgebungsdefinitionen manuell aktualisieren. Klicken Sie in Microsoft Test Manager auf Bibliothek. Klicken Sie auf Umgebungen und dann auf jede Umgebung, von der die Vorlagen verwendet werden. Entfernen Sie die alte Vorlage, und fügen Sie die neue Vorlage hinzu.

  5. Löschen Sie die alten Vorlagen aus der Bibliothek. Klicken Sie in Microsoft Test Manager auf Lab-Center. Klicken Sie auf die Registerkarte Bibliothek und anschließend auf VMs und Vorlagen.

    Alte und neue Vorlagen können anhand der Angabe in der Bibliotheksfreigabespalte unterschieden werden. Die zugrunde liegende Vorlage wird hierdurch nicht gelöscht.

  6. Überprüfen Sie, ob das Verschieben erfolgreich war. Wenn Sie die Teamprojektsammlung nicht offline geschaltet haben, stellen Sie eine der Vorlagen auf einem Host bereit. Die Bereitstellung sollte ohne Fehler ausgeführt werden.

Wenn in einer Bibliothek virtuelle Computer enthalten sind, die zurzeit nicht in einer Umgebung verwendet werden, müssen Sie diese virtuellen Computer auf einem Host bereitstellen und dann in der neuen Bibliothek speichern.

So verschieben Sie importierte virtuelle Computer

  1. Erstellen Sie eine neue virtuelle Umgebung.

  2. Fügen Sie alle virtuellen Computer hinzu, die verschoben werden müssen. Wählen Sie keine Funktionen aus.

  3. Stellen Sie die Umgebung bereit, starten Sie aber nicht.

    Hinweis Hinweis

    Wenn beim Starten der Umgebung virtuelle Computer mit denselben Namen wie den Namen der verschobenen virtuellen Computer ausgeführt werden, können in der Domäne Namenskonflikte auftreten.

  4. Klicken Sie in Microsoft Test Manager auf den ersten virtuellen Computer in der Umgebung. Klicken Sie auf In Bibliothek speichern, und wählen Sie dann die Zielbibliothek aus, in der Sie diesen speichern möchten. Wiederholen Sie diese Schritte für alle virtuellen Computer in der Umgebung.

  5. Nachdem alle virtuellen Computer in der Bibliothek gespeichert wurden, löschen Sie die Umgebung

  6. Löschen Sie die virtuellen Computer in der Quellbibliothek.

    Hinweis Hinweis

    Nach dem Verschieben können Sie die virtuellen Computer nicht mehr in andere Teamprojekte importieren.

So verschieben Sie gespeicherte Umgebungen

  1. Stellen Sie die Umgebung in Microsoft Test Manager bereit.

    Die Umgebung muss nicht gestartet werden.

  2. Klicken Sie auf der Registerkarte Umgebung auf In Bibliothek speichern, und wählen Sie die Zielbibliotheksfreigabe aus.

  3. Überprüfen Sie, ob das Verschieben erfolgreich war:

    1. Stellen Sie die Umgebung bereit.

    2. Erstellen Sie eine Momentaufnahme.

    3. Stellen Sie eine frühere Momentaufnahme wieder her.

    4. Stellen Sie die letzte Momentaufnahme wieder her.

  4. Wenn die Wiederherstellung erfolgreich ausgeführt werden kann, löschen Sie die Umgebung aus der Quellbibliotheksfreigabe.

Schalten Sie die Teamprojektsammlung nach dem Verschieben wieder online.

Wenn Fehler mit Momentaufnahmen für Umgebungen in der Bibliothek vorliegen, empfiehlt es sich, die Umgebungen in dieser Bibliothek zu belassen, bis die Fehler behoben wurden. Es ist keine Methode verfügbar, mit der einfach festgestellt werden kann, auf welche Umgebungen LVR-Dateien zeigen. Daher sollten Umgebungen aufbewahrt werden, die in den letzten 60 Tagen erstellt wurden.

So entfernen Sie die Freigabe

  1. Löschen Sie virtuelle Computer und Vorlagen aus der ursprünglichen Bibliotheksfreigabe: Klicken Sie in Microsoft Test Manager auf Lab-Center. Klicken Sie auf Bibliothek und Virtuelle Computer und Vorlagen, und löschen Sie dann die virtuellen Computer in der Bibliotheksfreigabe, die weiterhin in der ursprünglichen Bibliotheksfreigabe angezeigt werden.

    Sie können die virtuellen Computer nach Bibliotheksfreigabe gruppieren, indem Sie die Spaltenüberschrift Bibliotheksfreigabe per Drag & Drop auf die Überschriftenzeile ziehen.

  2. Löschen Sie die Bibliotheksfreigabezuordnung aus Teamprojekten:

    1. Öffnen Sie eine Eingabeaufforderung.

      Führen Sie an der Eingabeaufforderung das Befehlszeilentool TFSLabConfig für jedes Projekt aus, das der zu löschenden Bibliotheksfreigabe zugeordnet ist.

    2. Führen Sie den Befehl TFSLabConfig DeleteTeamProjectLibraryShare aus, um zusätzlich zum Bibliotheksfreigabenamen die Projektsammlung und den Projektnamen anzugeben.

      Weitere Informationen finden Sie unter TFSLabConfig DeleteTeamProjectLibraryShare-Befehl, wenn Sie mehr über den Befehl TFSLabConfig DeleteTeamProjectLibraryShare erfahren möchten.

    3. Wiederholen Sie diesen Schritt für jedes Teamprojekt.

  3. Löschen Sie in der Team Foundation Server-Verwaltungskonsole die ursprüngliche Bibliotheksfreigabe aus den Teamprojektsammlungen, denen diese zugeordnet war.

Hinzufügen eines neuen und Zurückziehen eines alten Hyper-V-Hosts

So fügen Sie einen Hyper-V-Host hinzu

  1. Fügen Sie in der SCVMM-Administratorkonsole der Hostgruppe den neuen Hyper-V-Server hinzu. Anweisungen zum Hinzufügen eines Servers zur Hostgruppe finden Sie im Thema zum Hinzufügen von Hosts (möglicherweise in englischer Sprache).

  2. Klicken Sie in Team Foundation Server-Verwaltungskonsole auf TFS-Server. Klicken Sie auf Lab-Management und dann auf Hostgruppen. Klicken Sie auf Überprüfen. Geben Sie die Anmeldeinformationen eines Benutzers ein, der Mitglied der Sicherheitsgruppe "Administratoren" auf dem neuen Host ist, wenn Sie zur Eingabe eines Benutzernamens und Kennworts aufgefordert werden.

  3. Verhindern Sie, dass dem Host, von dem Sie migrieren, neue virtuelle Computer hinzugefügt werden.

    1. Klicken Sie in der SCVMM-Administratorkonsole auf Hosts. Klicken Sie auf den Namen des Hosts, von dem Sie migrieren, und dann auf Eigenschaften.

    2. Klicken Sie im Fenster Hosteigenschaften auf die Registerkarte Status. Deaktivieren Sie das Kontrollkästchen Dieser Host ist zur Platzierung verfügbar, und klicken Sie dann auf OK.

  4. Klicken Sie im Fenster Hosteigenschaften auf die Registerkarte Status. Deaktivieren Sie das Kontrollkästchen Dieser Host ist zur Platzierung verfügbar, und klicken Sie dann auf OK.

  5. Migrieren Sie Umgebungen, die nicht netzwerkisoliert sind:

    1. Klicken Sie in Microsoft Test Manager auf Lab-Center. Klicken Sie auf die Registerkarte Lab und anschließend auf Umgebungen. Identifizieren Sie die Umgebungen, die sich in der Hostgruppe mit den Quell- und Zielhosts befinden.

    2. Öffnen Sie jede Umgebung, und überprüfen Sie, für welche Umgebungen die Netzwerkisolationsfunktion deaktiviert ist. Das weitere Vorgehen in diesem Schritt gilt nur für Umgebungen, die nicht netzwerkisoliert sind.

    3. Suchen Sie in der SCVMM-Administratorkonsole nach den virtuellen Computern, die Teil der nicht netzwerkisolierten Umgebungen sind.

      Geben Sie dazu den Umgebungsnamen in das Suchfeld des Bereichs "Virtuelle Computer" ein.

    4. Verschieben Sie alle der im vorherigen Schritt gefundenen virtuellen Computer, die sich auf dem nicht mehr verwendeten Host befinden, auf den neuen Host.

  6. Migrieren Sie netzwerkisolierte Umgebungen:

    1. Klicken Sie in Microsoft Test Manager auf Lab-Center. Klicken Sie anschließend auf die Registerkarte Lab und dann auf Umgebungen. Identifizieren Sie die Umgebungen, die sich in der Hostgruppe mit den Quell- und Zielhosts befinden.

    2. Öffnen Sie jede Umgebung, und überprüfen Sie, für welche Umgebungen die Funktion Netzwerkisolation aktiviert ist.

    3. Suchen Sie in der SCVMM-Administratorkonsole nach den virtuellen Computern, die Teil der netzwerkisolierten Umgebung sind.

      Geben Sie dazu den Umgebungsnamen in das Suchfeld des Bereichs "Virtuelle Computer" ein.

    4. Speichern Sie die netzwerkisolierte Umgebung in der Teamprojektbibliothek, wenn sich die virtuellen Computer einer netzwerkisolierten Umgebung auf dem nicht mehr verwendeten Host befinden.

      Alle virtuellen Computer in einer netzwerkisolierten Umgebung befinden sich auf demselben physischen Host.

    5. Stellen Sie die Umgebung aus der Bibliothek wieder in der Hostgruppe bereit.

  7. Halten Sie in Microsoft Test Manager jede Umgebung an, und setzen Sie die Ausführung dann fort. Dadurch wird überprüft, ob die Umgebung erfolgreich migriert wurde.

  8. Klicken Sie in der SCVMM-Administratorkonsole auf Hosts, klicken Sie auf den Namen des alten Hosts und dann auf Host entfernen.

Verschieben von System Center Virtual Machine Manager auf einen anderen Server

Es gibt mindestens zwei Situationen, in denen Sie SCVMM möglicherweise von einem Server auf einen anderen verschieben können oder müssen. In der ersten Situation haben Sie Lab Management zunächst im Pilotversuch auf temporären Computern verwendet und möchten die Funktionalität jetzt auf Produktionsservern bereitstellen. Da Sie im Produktionsmodus neu beginnen, müssen Sie die Umgebungen, Vorlagen und sonstigen Lab-Ressourcen aus der Pilotphase nicht aufbewahren. In der zweiten Situation müssen Sie den Server, auf dem SCVMM ausgeführt wird, aufgrund von Kapazitäts- oder Verfügbarkeitsproblemen ändern. Da der Betrieb unverändert fortgesetzt werden soll, müssen Sie Umgebungen und Ressourcen beibehalten.

So verschieben Sie SCVMM ohne Beibehaltung von Lab-Ressourcen

  1. Löschen Sie die Lab-Objekte aus den einzelnen Teamprojektsammlungen.

    1. Öffnen Sie auf der Anwendungsebene für Team Foundation Server eine Eingabeaufforderung, und geben Sie den Befehl Tfsconfig.exe lab /delete /collectionName:Meine_Sammlung ein. Sie müssen TFSConfig auf einem Server ausführen, auf dem die Team Foundation-Anwendungsebene ausgeführt wird. Standardmäßig befindet sich TFSConfig im Verzeichnis Laufwerk:\Programme\Microsoft Team Foundation Server 2010\Tools. Weitere Informationen zu dem Befehl TfsConfig Lab /Delete finden Sie unter TFSConfig Lab /Delete-Befehl.

    2. Führen Sie diesen Befehl für jede Teamprojektsammlung auf dem Server aus.

  2. Geben Sie in der Team Foundation Server-Verwaltungskonsole den neuen Namen ein.

    1. Klicken Sie in der Team Foundation Server-Verwaltungskonsole auf den Knoten Lab Management.

    2. Klicken Sie auf der Seite Lab Management auf Lab Management neu konfigurieren.

    3. Geben Sie auf der Registerkarte Virtual Machine Manager den vollqualifizierten Domänennamen des neuen Servers ein, auf dem SCVMM ausgeführt wird. Klicken Sie dann auf Test, um zu prüfen, ob der neue Server verfügbar ist.

      1. Wenn dem Team Foundation Server-Dienstkonto für den angegebenen SCVMM-Server nicht die erforderlichen Berechtigungen zugewiesen sind, werden Sie in einem Dialogfeld aufgefordert, einen Benutzernamen und ein Kennwort anzugeben.

      2. Geben Sie den Namen und das Kennwort eines Benutzers ein, der bereits Mitglied der SCVMM-Administratorrolle ist. Der SCVMM-Administratorrolle wird das Team Foundation Server-Dienstkonto hinzugefügt.

    4. Klicken Sie auf OK.

So verschieben Sie SCVMM unter Beibehaltung von Lab-Ressourcen

  1. Sichern Sie die Datenbank des ursprünglichen SCVMM:

    1. Klicken Sie in der SCVMM-Administratorkonsole auf Verwaltung und dann auf Allgemein. Klicken Sie im Bereich Aktionen auf Virtual Machine Manager sichern.

    2. Geben Sie im Dialogfeld Virtual Machine Manager-Sicherung den Pfad eines Zielordners für die Sicherungsdatei ein. Bei dem Ordner darf es sich nicht um ein Stammverzeichnis handeln, und SQL Server muss auf den Ordner zugreifen.

    Hinweis Hinweis

    Sie können den Status der Sicherung in der Ansicht Aufträge verfolgen.

  2. Kopieren Sie die Datenbanksicherungsdateien aus Schritt 1b an einen Speicherort auf dem neuen SCVMM-Computer.

  3. Installieren Sie SCVMM auf dem neuen Server. Zeigen Sie mit dem Assistenten auf die aktuelle SCVMM-Datenbank, oder erstellen Sie eine neue Datenbank. Anweisungen zum Wiederherstellen der Sicherung finden Sie im Thema zum Sichern und Wiederherstellen der VMM-Datenbank (möglicherweise in englischer Sprache).

  4. Aktualisieren Sie den SCVMM-Servernamen in Team Foundation Server.

    1. Öffnen Sie eine Eingabeaufforderung, und führen Sie den Befehl Tfsconfig.exe lab /settings / scvmmservername:mein_neuer_scvmmservername /force aus. Sie müssen TFSConfig auf einem Server ausführen, auf dem die Team Foundation-Anwendungsebene ausgeführt wird. Standardmäßig befindet sich TFSConfig im Verzeichnis Laufwerk:\Programme\Microsoft Team Foundation Server 2010\Tools. Sie müssen den /force-Schalter verwenden, da der Bibliotheksserver und die Hostgruppen bereits an eine Teamprojektsammlung gebunden sind; der SCVMM-Server darf nur unter Verwendung der /force-Option geändert werden. Weitere Informationen zu dem Befehl TFSConfig Lab Settings finden Sie unter TFSConfig Lab /Settings-Befehle.

    2. Klicken Sie in der Team Foundation Server-Verwaltungskonsole auf den Knoten Lab Management. Klicken Sie auf Lab Management neu konfigurieren und dann neben Name des VMM-Servers auf Test. Dadurch wird überprüft, ob Team Foundation Server eine Verbindung mit dem neuen SCVMM-Computer herstellen kann und über die erforderlichen Berechtigungen verfügt.

      1. Wenn dem Team Foundation Server-Dienstkonto für den angegebenen SCVMM-Server nicht die erforderlichen Berechtigungen zugewiesen sind, werden Sie in einem Dialogfeld aufgefordert, einen Benutzernamen und ein Kennwort anzugeben.

      2. Geben Sie den Namen und das Kennwort eines Benutzers ein, der bereits Mitglied der SCVMM-Administratorrolle ist. Der SCVMM-Administratorrolle wird das Team Foundation Server-Dienstkonto hinzugefügt.

    3. Gehen Sie in der Team Foundation Server-Verwaltungskonsole für jede Teamprojektsammlung wie folgt vor.

      1. Klicken Sie auf die Registerkarte Lab Management und anschließend auf Hostgruppen konfigurieren. Wählen Sie alle Hostgruppen aus, und klicken Sie dann auf Überprüfen. Damit wird überprüft, ob Team Foundation Server und der neue SCVMM-Server eine Verbindung mit den Hosts herstellen können und über die erforderlichen Berechtigungen verfügen.

      2. Klicken Sie auf Lab Management und anschließend auf Bibliotheksfreigaben konfigurieren. Wählen Sie alle Bibliotheksfreigaben aus, und klicken Sie dann auf Überprüfen. Dadurch wird überprüft, ob Team Foundation Server und der neue SCVMM-Computer eine Verbindung mit den Bibliotheksfreigaben herstellen können und über die erforderlichen Berechtigungen verfügen.

  5. Überprüfen Sie, ob das Verschieben erfolgreich war:

    1. Klicken Sie in Microsoft Test Manager auf Lab-Center und dann auf Umgebungen. Überprüfen Sie, ob die vorhandenen Umgebungen in der Liste angezeigt werden und den richtigen Zustand aufweisen.

    2. Klicken Sie auf Bibliothek und dann auf VMs und Vorlagen. Überprüfen Sie, ob alle vorhandenen virtuellen Computer und Vorlagen ohne neue Fehler in der Liste angezeigt werden.

Verschieben eines Testcontrollers

Wenn Sie einen Testcontroller, der Umgebungen zugeordnet ist, verschieben oder neu installieren müssen (z. B. aufgrund eines Hardwareupgrades oder weil der aktuelle Server zu alt ist), müssen Sie die Datenbank sichern und auf dem neuen Computer neu installieren. Wenn Sie einen für Auslastungstests verwendeten Testcontroller verschieben, wird auch die Auslastungstest-Datenbank gesichert und wiederhergestellt. Zudem müssen Sie jeden Agent erneut beim neuen Controller registrieren.

So verschieben Sie einen Testcontroller oder installieren Sie ihn neu

  1. Suchen Sie nach der Datei "QTControllerConfig.XML", und erstellen Sie eine Sicherungskopie.

    Diese Datei befindet sich normalerweise im Visual Studio-Installationsverzeichnis im Ordner "Common7\IDE".

  2. Erstellen Sie den Computer mit dem gleichen Namen neu.

  3. Installieren Sie den Testcontroller auf dem neuen Computer neu.

    Konfigurieren Sie den Testcontroller noch nicht.

  4. Ersetzen Sie die standardmäßige Datei "QTControllerConfig.XML" auf dem Computer durch die Datei, die Sie in Schritt 1 gesichert haben.

  5. Konfigurieren Sie den Testcontroller, und verbinden Sie ihn mit der Projektsammlung, mit der er zuvor verbunden war.

  6. Starten Sie den Computer neu.

  7. Wenn Sie den Namen eines Computers, auf dem ein Testcontroller installiert ist, ändern und die Testfunktion für eine Umgebung konfiguriert ist, müssen Sie den Namen des Testcontrollers in den Umgebungen aktualisieren, in denen dieser Testcontroller verwendet wird. Zum Ändern der Umgebung verwenden Sie Microsoft Test Manager:

    1. Beenden Sie der Umgebung.

    2. Bearbeiten Sie die Umgebung, und aktualisieren Sie die Testcontrollereinstellung auf der Seite Funktionen. Wählen Sie den Testcontroller anhand seines neuen Namens aus.

    3. Starten Sie die Umgebung neu.

Siehe auch

Aufgaben

Gewusst wie: Ändern der Bibliotheksfreigabe für die Teamprojektsammlungen


Gewusst wie: Verknüpfen des SCVMM-Servers mit einer anderen Domäne

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Verknüpfen des SCVMM-Servers mit einer anderen Domäne
Feedback senden

Gelegentlich kann es erforderlich sein, Ihr Team Foundation Server aus einer Active Directory-Domäne zu einer anderen oder von einer Arbeitsgruppe in eine Domäne zu ändern. Weitere Informationen finden Sie unter Move TFS. Im Rahmen dieser Aufgabe sollten Sie SCVMM und Lab Management in die neue Domäne verschieben.

Um einen SCVMM-Server in eine Domäne verschieben oder die Domäne ändern zu können, muss SCVMM neu installiert werden. Daher müssen Sie die virtuellen Computer und Vorlagen speichern und anschließend die Umgebungen in der neuen Installation erneut definieren. In diesem Thema werden diese Schritte ausführlicher beschrieben.

Deinstallieren von SCVMM

  1. Entfernen Sie die Hosts und Bibliotheksserver aus dem SCVMM-Server.

    1. Öffnen Sie die Virtual Machine Manager-Administratorkonsole:

      Wählen Sie Start, Microsoft System Center, Virtual Machine Manager und anschließend Virtual Machine Manager-Administratorkonsole aus.

    2. Löschen Sie die Bibliotheksserver.

    3. Löschen Sie die Hostgruppen.

  2. Löschen Sie alle Lab-Artefakte aus dem Microsoft Test Manager-Bibliothekscenter:

    Löschen Sie auf der Registerkarte Lab die Umgebungen. Löschen Sie auf der Registerkarte Bibliothek die virtuellen Computer und Umgebungen.

    Da die Hosts und Bibliotheksserver nicht länger mit SCVMM verknüpft sind, werden durch das Entfernen dieser Elemente aus Microsoft Test Manager nicht die tatsächlichen virtuellen Computer oder die VHDs gelöscht.

  3. Heben Sie die Konfiguration von SCVMM in Team Foundation Server auf.

    1. Melden Sie sich bei Team Foundation Server als tfsadmin an.

    2. Öffnen Sie Team Foundation-Verwaltungskonsole.

    3. Wählen Sie im Knoten Anwendungsebene die Option Lab Management aus, und wählen Sie anschließend Lab Management neu konfigurieren aus.

    4. Löschen Sie die Links zwischen den Bibliotheksfreigaben und der Teamprojektauflistung.

  4. Deinstallieren Sie SCVMM auf dem Computer, auf dem dieses installiert wurde.

Verknüpfen von Computern mit der Domäne

  1. Ändern Sie die Domäne der Hosts und Bibliotheksserver.

  2. Ändern Sie die Domäne des SCVMM-Servercomputers.

Erneutes Installieren von SCVMM und Neuerstellung von Artefakten

  1. Installieren Sie SCVMM auf dem Computer neu.

  2. Fügen Sie die Hosts und Bibliotheksserver erneut zu SCVMM hinzu.

    Weitere Informationen finden Sie im SCVMM-Abschnitt unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

  3. Wenn einer der virtuellen Computer der neuen Domäne hinzugefügt werden muss, führen Sie diesen Vorgang durch.

    Netzwerkisolierte Umgebungen verfügen über eine eigene Domäne oder Arbeitsgruppe. Daher müssen die einzelnen Computer nicht geändert werden.

  4. Konfigurieren Sie die neue SCVMM-Instanz, um sie mit der Teamprojektauflistung zu verknüpfen.

    Legen Sie das neue Lab-Dienstkonto in Team Foundation Server fest.

    Weitere Informationen finden Sie im SCVMM-Abschnitt unter Konfigurieren von Lab Management für SCVMM-Umgebungen.

  5. Mit Lab Management werden die virtuellen Computer und Vorlagen erneut in die Bibliothek importiert.

    Weitere Informationen finden Sie unter Gewusst wie: Importieren eines virtuellen Computers oder einer Vorlage von SCVMM in Microsoft Test Manager.

  6. Stellen Sie in Microsoft Test Manager virtuelle Computer zu Umgebungen zusammen.

    Weitere Informationen finden Sie unter Gewusst wie: Speichern einer SCVMM-Umgebung in der Bibliothek.


Verwalten von Benutzerberechtigungen für Lab-Management

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten von Benutzerberechtigungen für Lab-Management
Siehe auch Feedback senden

Sie können steuern, in welchem Umfang einzelne Teammitglieder auf Lab Management-Ressourcen zugreifen können, indem Sie die Mitglieder Sicherheitsgruppen für die einzelnen Teamprojekte hinzufügen. Standardmäßig werden von Team Foundation mehrere Gruppen für jedes Projekt erstellt, wobei es für jede Gruppe einen eigenen Satz an Berechtigungen und Rechten für das jeweilige Projekt gibt. Wenn die Standardgruppen die entsprechenden Berechtigungen nicht enthalten, können Sie benutzerdefinierte Gruppen mit einer bestimmten Kombination von Berechtigungen erstellen. Weitere Informationen finden Sie unter Adding and Removing Users To and From Groups, wenn Sie mehr über das Hinzufügen von Benutzern zu den Standardgruppen erfahren möchten. Weitere Informationen finden Sie unter Custom Groups, wenn Sie mehr über das Erstellen von benutzerdefinierten Gruppen erfahren möchten.

Standardgruppen und -berechtigungen

Beim Erstellen einer Teamprojektsammlung werden von Team Foundation automatisch die folgenden Standardgruppen auf Sammlungsebene erstellt:

  • Projektauflistungsadministratoren

  • Gültige Benutzer für Projektauflistung

  • Dienstkonten für die Projektauflistung

  • Builddienstkonten für die Projektauflistung

  • Proxydienstkonten für die Projektauflistung

  • Testdienstkonten für die Projektauflistung

Von diesen Gruppen werden den Gruppen Projektauflistungsadministratoren und Builddienstkonten für die Projektauflistung explizite Berechtigungen für Zugriff oder Steuerung von Lab Management-Ressourcen zugewiesen. Weitere Informationen finden Sie unter Default Groups in Team Foundation Server, wenn mehr über alle Standardgruppen auf Sammlungsebene erfahren möchten.

Ebenso werden von Team Foundation beim Erstellen eines Teamprojekts automatisch die folgenden Standardgruppen auf Projektebene erstellt:

  • Projektadministratoren

  • Mitwirkende

  • Leser

  • Generatoren

Von diesen Gruppen werden den Gruppen Projektadministratoren, Contributors und Leser explizite Berechtigungen für Zugriff oder Steuerung von Lab Management-Ressourcen zugewiesen. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen, wenn Sie mehr über die Berechtigungen für alle Standardgruppen auf Sammlungs- und Projektebene erfahren möchten.

In der folgenden Tabelle sind die einzelnen Lab Management-Berechtigungen aufgeführt, die Benutzern beim Hinzufügen zu einer Standardgruppe zugewiesen werden. Für viele Teamprojekte ist es ausreichend, Benutzer einer der Gruppen Projektadministratoren oder Contributors zuzuweisen, damit diese Personen ihre Tätigkeit ausüben können.

Bezeichnung der Lab Management-Berechtigung | Bezeichnung der Berechtigung in der Befehlszeile | Benutzer mit dieser Berechtigung können Folgendes tun: | Projektauflistungsadministratoren | Builddienstkonten für die Projektauflistung | Projektadministratoren | Mitwirkende | Leser
Lab-Ressourcen anzeigen | Read | Es können Informationen zu den verschiedenen Lab Management-Ressourcen angezeigt werden, einschließlich Informationen zu Sammlungshostgruppen, Projekthostgruppen und Umgebungen. Um Informationen zu einer bestimmten Lab-Ressource anzuzeigen, müssen Sie über die Berechtigung Lab-Ressourcen anzeigen für diese Ressource verfügen. | X | X | X | X | X
Virtuellen Computer importieren | Create | Es können virtuelle Computer aus einer VMM-Bibliotheksfreigabe importiert werden. Diese Berechtigung unterscheidet sich von der Schreibberechtigung, da Benutzer in Lab Management Objekte erstellen, jedoch nicht in die Virtual Machine Manager-Hostgruppe oder -Bibliotheksfreigabe schreiben können. | X |  | X | X |
Umgebung und virtuelle Computer schreiben | Write | Benutzer mit dieser Berechtigung für eine Projekthostgruppe können Umgebungen erstellen. Benutzer mit dieser Berechtigung für eine Projektbibliotheksfreigabe können Umgebungen und Vorlagen speichern. | X | X | X | X |
Umgebung und virtuelle Computer bearbeiten | Edit | Benutzer mit dieser Berechtigung können Umgebungen und Vorlagen bearbeiten. Die Berechtigung wird für das zu bearbeitende Objekt überprüft. | X | X | X | X |
Starten | Start | Umgebungen können gestartet werden. | X | X | X | X |
Beenden | Stop | Umgebungen können beendet werden. | X | X | X | X |
Umgebung anhalten | Pause | Umgebung können angehalten werden. | X | X | X | X |
Momentaufnahmen verwalten | ManageSnapshots | Benutzer mit dieser Berechtigung können alle Verwaltungsaufgaben für Momentaufnahmen einer Umgebung ausführen, u. a. das Erstellen, Wiederherstellen, Umbenennen, Löschen und Lesen von Momentaufnahmen. | X | X | X | X |
Umgebung und virtuellen Computer löschen | Delete | Umgebungen und Vorlagen können gelöscht werden. Die Berechtigung wird für das zu löschende Objekt überprüft. | X |  | X |  |
Lab-Speicherorte verwalten | ManageLocation | Die Speicherorte von Lab Management-Ressourcen einschließlich Sammlungshostgruppen, Sammlungsbibliotheksfreigaben, Projekthostgruppen und Projektbibliotheksfreigaben können bearbeitet werden. Zum Ändern eines bestimmten Speicherorts müssen Sie über die Berechtigung Lab-Speicherorte verwalten für den betreffenden Speicherort verfügen. Mit dieser Berechtigung für Speicherorte auf Sammlungsebene (Sammlungshostgruppen und Sammlungsbibliotheksfreigaben) können Sie außerdem Speicherorte auf Projektebene (Projekthostgruppen und Projektbibliotheksfreigaben) zu erstellen. | X |  | X |  |
Lab-Speicherorte löschen | DeleteLocation | Die Speicherorte von Lab Management-Ressourcen einschließlich Sammlungshostgruppen, Sammlungsbibliotheksfreigaben, Projekthostgruppen und Projektbibliotheksfreigaben können gelöscht werden. Zum Löschen eines Speicherorts müssen Sie über die Berechtigung Lab-Speicherorte löschen für den betreffenden Speicherort verfügen. | X |  | X |  |
Untergeordnete Berechtigungen verwalten | ManageChildPermissions | Benutzer mit dieser Berechtigung, können die Berechtigungen aller untergeordneten Lab Management-Objekte ändern. Verfügt ein Benutzer beispielsweise über die Berechtigung Untergeordnete Berechtigungen verwalten für eine Teamprojekt-Hostgruppe, kann er die Berechtigungen für alle Umgebungen unterhalb dieser Teamprojekt-Hostgruppe ändern. | X |  | X |  |
Berechtigungen verwalten | ManagePermissions | Die Berechtigungen für Lab Management-Objekte können geändert werden. Diese Berechtigung wird für das Objekt überprüft, dessen Berechtigungen geändert werden. | X |  |  |  |

Benutzerdefinierte Gruppen und Berechtigungen

Wenn die Berechtigungen der Standardsicherheitsgruppen in Team Foundation zu umfassend oder zu eingeschränkt sind, können Sie neue Sicherheitsgruppen mit anderen Kombinationen von Berechtigungen erstellen. Das Team kann z. B. Benutzer umfassen, die Testleiter sind, und andere Benutzer, die nur als Tester fungieren. Die Richtlinien der Organisation erfordern, dass nur Testleiter berechtigt sind, virtuelle Computer und Vorlagen zu erstellen. Da einem Tester, der der Standardgruppe Contributors hinzugefügt wird, automatisch die Berechtigung zum Erstellen von neuen virtuellen Computern und Vorlagen zugewiesen wird, möchten Sie möglicherweise eine benutzerdefinierte Gruppe mit der Bezeichnung "Tester" erstellen, die nur über die in der folgenden Tabelle angegebenen Berechtigungen verfügt. In der Organisation gibt es außerdem eine Reihe von Benutzern, die als Teamprojektadministratoren fungieren, und andere Benutzer, die Testumgebungsadministratoren sind. Die Richtlinien in der Organisation erfordern, dass nur Teamprojektadministratoren Benutzerberechtigungen verwalten können. Wenn ein Testumgebungsadministrator der Standardgruppe Projektadministratoren hinzugefügt wird, kann dieser jedoch automatisch Berechtigungen verwalten. Daher möchten Sie möglicherweise eine benutzerdefinierte Gruppe mit dem Namen "Lab-Administratoren" erstellen. In Der folgenden Tabelle werden die einzelnen Berechtigungen aufgeführt, die der Gruppe "Lab-Administratoren" zugewiesen werden können, sowie drei weitere benutzerdefinierte Gruppen, deren Berechtigungen sich von den Berechtigungen für die Standardgruppen unterscheiden. Anleitungen zum Erstellen benutzerdefinierter Gruppen finden Sie unter Custom Groups in Team Foundation Server.

Bezeichnung der Lab Management-Berechtigung | Benutzerdefinierte Gruppe: Lab-Administratoren | Benutzerdefinierte Gruppe: Testleiter | Benutzerdefinierte Gruppe: Tester | Benutzerdefinierte Gruppe: Entwickler
Lab-Ressourcen anzeigen | X | X | X | X
VM-Vorlage mit VMM Virtual Machines erstellen | X | X |  |
Umgebungen und Vorlagen schreiben | X | X |  |
Umgebungen und Vorlagen bearbeiten | X | X | X | X
Umgebung starten | X | X | X | X
Umgebung beenden | X | X | X | X
Umgebung anhalten | X | X | X | X
Momentaufnahmen der Umgebung verwalten | X | X | X | X
Umgebungen und Vorlagen löschen | X | X |  |
Lab-Speicherorte verwalten | X |  |  |
Lab-Speicherorte löschen | X |  |  |
Untergeordnete Berechtigungen verwalten |  |  |  |
Berechtigungen verwalten |  |  |  |

Nach dem Erstellen der benutzerdefinierten Gruppen müssen Sie diesen Benutzer hinzufügen. Verwenden Sie das Befehlszeilenprogramm TFSLabConfig, um die Lab Management-Berechtigungen für Gruppen oder Benutzer zu verwalten. Informationen zu Syntax und weiteren Aspekten finden Sie unter Konfigurieren von Lab-Management mit TFSLabConfig.

Informationen zu vorhandenen Berechtigungen der einzelnen Gruppen bzw. Benutzer für die verschiedenen Lab Management-Objekte finden Sie unter TFSLabConfig Permissions-Befehl.

Siehe auch

Konzepte

Konfigurieren von Lab Management für SCVMM-Umgebungen

Weitere Ressourcen

Ändern von vorhandenen Konfigurationen von Lab-Management


Planen des Labs

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Planen des Labs
Siehe auch Feedback senden

Während Sie sich auf die umfassende Verwendung von Lab-Management in Ihrer Testumgebung vorbereiten, kommen Ihnen wahrscheinliche mehrere Fragen in den Sinn:

  • Wie viele physische Server benötige ich?

  • Welche Art von Server sollte ich kaufen?

  • Wie viel Speicherkapazität benötige ich?

  • Kann ich ein SAN als Speicher verwenden?

  • Kann ich alles auf einem leistungsstarken Computer einrichten?

  • Wie richte ich ein isoliertes Lab ein?

Dieses Thema enthält allgemeine Richtlinien zur Schätzung der Anzahl und Arten von physischen Servern, virtuellen Computern und Controllern, die Sie zur Verwendung von Visual Studio Lab Management benötigen. Im Allgemeinen ist die Anzahl der Server nicht so wichtig wie die Kapazität der einzelnen Server. Ein Server mit einem Zweikern- oder Vierkernprozessor kann beispielsweise mehr virtuelle Computer unterstützen als ein Server mit einem Einzelkernprozessor. Auf ähnliche Weise kann ein Server mit 32 GB RAM hat mehr virtuelle Computer gleichzeitig hosten als ein Server mit nur 8 GB RAM.

Kapazitätsplanung

Die folgenden Abschnitte enthalten Richtlinien, mit deren Hilfe Sie ausreichend Kapazität für Ihr virtuelles Test-Lab bereitstellen können. Die Richtlinien werden als Empfehlungen (Dos) und Warnungen (Don'ts) ausgedrückt, wenn Sie Hardware erwerben oder konfigurieren oder die erforderliche Software installieren oder konfigurieren. Diese Richtlinien werden ständig aktualisiert, halten Sie in diesem Thema und auf dieser Microsoft-Webseite daher in regelmäßigen Abständen nach Updates Ausschau.

Planen für Team Foundation Server

Don't

  • Richten Sie nicht alles auf einem einzigen Computer ein. Richten Sie nur dann alle Komponenten auf einem einzigen Computer ein, wenn Sie diesen lediglich zu Demonstrationszwecken oder für Machbarkeitsstudien verwenden.

  • Verwenden Sie das NetworkService-Konto nicht als Dienstkonto für Team Foundation Server, wenn die Instanz von Team Foundation Server mehr als ein Server zum Ausführen der logischen Anwendungsebene verwendet, und Sie Lab-Management-Funktion von Visual Studio 2010 verwenden. Die Verwendung des NetworkService-Kontos erfordert später mehr manuelle Arbeit bei der Verwaltung der physischen Hostcomputer für virtuelle Umgebungen. Dieser zusätzliche Aufwand ist notwendig, da das NetworkService-Konto für jeden neuen Computer auf Anwendungsebene der lokalen Administratorgruppe auf jedem physischen Hostcomputer hinzugefügt werden muss. Wenn Sie zum Beispiel ein virtuelles Lab mit 20 physischen Hosts ausführen und einen Computer auf Anwendungsebene hinzufügen oder ersetzen, müssten Sie alle 20 Hostcomputer mit dem Namen des neuen Computers auf Anwendungsebene aktualisieren und Berechtigungen zuweisen. Verwenden Sie statt dem NetworkService-Konto ein standardmäßiges Domänenbenutzerkonto und ein Kennwort für das TFSservice-Konto. Dadurch wird das Domänenbenutzerkonto einmal bei der Erstkonfiguration des physischen Hosts hinzugefügt, und jeder nachfolgende Computer auf Anwendungsebene verwendet dasselbe Konto. Weitere Informationen zu den Einschränkungen des NetworkService-Kontos finden Sie unter NetworkService-Konto.

Planen für System Center Virtual Machine Manager

Don't

  • Installieren Sie SCVMM nicht auf einem virtuellen Computer. Wenn Sie SCVMM auf einem virtuellen Computer installieren, wird die Verwaltung des physischen Hosts, auf dem dieser virtuelle Computer ausgeführt wird, schwieriger, und die Leistung der Bibliothek wird beeinträchtigt, wenn Sie diese auf demselben virtuellen Computer einrichten.

  • Verwenden Sie Clustering bei den SCVMM 2008 R2-Bibliotheksservern. Von Lab Management wird Clustering nur in SCVMM-Umgebungen unterstützt, wenn SCVMM 2012 verwendet wird. Dies ist bei SCVMM 2008 R2 jedoch nicht möglich.

  • Legen Sie keine virtuellen LAN-IDs für Netzwerkadapter fest. Lab-Management bietet keine Unterstützung für das Festlegen und Verwenden einer virtuellen LAN-ID in System Center Virtual Machine Manager. Wenn Sie die VLAN-ID eines Netzwerkadapters auf einem virtuellen Computer manuell festlegen und dann den virtuellen Computer in der SCVMM-Bibliothek speichern, wird die VLAN-ID bei der Bereitstellung des virtuellen Computers gelöscht. Weitere Informationen zur Verwendung von VLAN-IDs finden Sie unter Konfigurieren virtueller Netzwerke in VMM.

Do

  • Stellen Sie dem SCVMM-Computer ausreichend Ressourcen zur Verfügung. Wenn Sie in Ihrem Lab weniger als 50 virtuelle Computer haben werden, sollte der Computer, auf dem SCVMM ausgeführt wird, mindestens über Folgendes verfügen:

    • Einen 64-Bit-Prozessor

    • 4 GB Arbeitsspeicher

    • Ein Festplattenlaufwerk mit 300 GB

    • Windows Server 2008 R2-Betriebssystem

    Wenn Sie mehr als 50 virtuelle Computer haben werden, stellen Sie mehr Ressourcen bereit. Wenn Sie planen, SCVMM zusammen mit einer anderen Software auf demselben Computer zu installieren, stellen Sie dem SCVMM-Server die zuvor in diesem Thema beschriebene Ressourcenmenge zur Verfügung. Ermitteln Sie die Menge jedoch, nachdem Sie den Ressourcenverbrauch der anderen Software abgezogen haben. Wenn Sie beispielsweise SCVMM auf dem Computer installieren möchten, auf dem Team Foundation Server ausgeführt wird, fügen Sie die Anforderungen zu denen von Team Foundation Server hinzu, und stellen Sie sicher, dass der Computer über ausreichend Kapazität verfügt.

  • Stellen Sie dem Server, auf dem die Bibliothek ausgeführt wird, mindestens 200 GB freien Speicherplatz auf dem Festplattenlaufwerk zur Verfügung. Stellen Sie in der Standardinstallation sicher, dass das von der Bibliotheksfreigabe verwendete Laufwerk mehr als 200 GB freien Speicherplatz aufweist.

  • Erstellen Sie die Standardbibliotheksfreigabe auf Laufwerk D: und nicht auf Laufwerk C:. Standardmäßig erstellt SCVMM die Bibliotheksfreigabe auf demselben Computer, auf dem er installiert ist, und erstellt die Bibliothek auf Laufwerk C:. Durch Ändern der Standardbibliotheksfreigabe auf Laufwerk D: kann der Computer später einfacher aktualisiert werden.

  • Verwenden Sie ein Festplattenlaufwerk mit ausreichender Geschwindigkeit für die Bibliothek. Wenn Sie planen, die Bibliothek mit geringer Auslastung zu verwenden, genügt eine Festplatte mit ausreichender Geschwindigkeit. Wenn Sie eine moderate Verwendung der Bibliothek planen, verwenden Sie eine RAID 5-Datenträgerkonfiguration mit 6 bis 12 Datenträger für besseren Durchsatz. Wenn Sie beabsichtigen, die Bibliothek stark auszulasten, verwenden Sie mehrere Bibliotheksserver. Sie können einen direkt angeschlossenen Speicher oder ein SAN verwenden. Wenn Sie ein SAN verwenden, erstellen Sie eine LUN, die einzig und allein für den Bibliothekscomputer verwendet wird.

  • Führen Sie Team Foundation Server unter einem regulären Domänenbenutzerkonto anstatt des Netzwerkdienstkontos aus. Dies ist erforderlich, wenn Sie Team Foundation Server und SCVMM auf demselben Computer installieren.

  • Wenn SCVMM auf einem Hyper-V-Host installiert ist, speichern Sie die von Hyper-V gehosteten virtuellen Computer auf einem anderen Festplattenlaufwerk als die SCVMM-Bibliothek. Verwenden Sie beispielsweise Laufwerk C: von einem Datenträger für die Bibliothek, und Laufwerk D: von einem anderen Datenträger für virtuelle Hyper-V-Computer. Der SCVMM-Server wird in diesem Fall auf dem primären Betriebssystem in Hyper-V ausgeführt. Dadurch wird sichergestellt, dass beim Laden des primären Betriebssystems alle Gastbetriebssysteme (in Hyper-V bereitgestellte virtuelle Computer) betroffen sind. Um diese Auswirkungen zu reduzieren, konfigurieren Sie die Hostreserven für diesen Computer, indem Sie die Hyper-V-Hostreserven (nachfolgend beschrieben) den zuvor erwähnten SCVMM-Computeranforderungen hinzufügen. Hostreserven können mit der SCVMM-Administratorkonsole konfiguriert werden.

  • Stellen Sie Line-of-Sight-Netzwerkrouting zwischen SCVMM und Team Foundation Server, Hosts und anderen Bibliotheksservern bereit.

  • Aktualisieren Sie den SCVMM-Computer mit allen neuesten Windows-Updates, und stellen Sie sicher, dass die Updates automatisch angewendet werden. Wenn dies nicht möglich ist, sollten Sie planen, Windows- und SCVMM-Updates zu verfolgen, und diese dann manuell anwenden, sobald sie verfügbar sind.

Planen für die Hyper-V-Hosts

Don't

  • Installieren Sie keine zusätzliche Software wie Team Foundation Server auf dem physischen Hostcomputer. Wenn Sie über ausreichend leistungsstarke Hosts verfügen (die die Aggregatanforderungen des Hypervisors und des virtuellen Computers überschreiten), können Sie SCVMM oder den Bibliotheksserver auf demselben Host platzieren, solange Sie auch die Ressourceneinschränkungen dieser Server berücksichtigen. Wenn Sie SCVMM z. B. auf einem Hyper-V-Hostcomputer installieren möchten, fügen Sie die Hostanforderungen, die Anforderungen des virtuellen Computers und die SCVMM-Anforderungen hinzu, und vergewissern Sie sich dann, dass der Computer über ausreichend Kapazität verfügt.

  • Verwenden Sie bei Hyper-V-Hostservern kein Clustering. Clustering wird von Lab Management in SCVMM-Umgebungen unterstützt.

  • Planen nicht mehrere Bereitstellungen von virtuellen Computern gleichzeitig. Beschränken Sie die Anzahl gleichzeitiger Umgebungsbereitstellungen auf Hosts.

  • Verwenden Sie keine physischen Hosts, die sich an anderen geografischen Orten als die Bibliotheksserver befinden. Wenn Sie Hosts verwenden müssen, die sich an einem anderen geografischen Ort als die SCVMM-Bibliotheksserver befinden, muss die Netzwerkgeschwindigkeit zwischen SCVMM und Hosts mindestens 100 MBit/s betragen und keinen langen Wartezeiten aufweisen.

  • Erstellen Sie keine mehrfachen Netzwerkadapter auf einem virtuellen Computer, der eine Verbindung mit einem bestimmten Netzwerk herstellt. Lab-Management überschreibt diese Konfiguration und erstellt zwei Adapter. Ein Adapter stellt eine Verbindung mit dem Labornetzwerk her, und der andere Adapter behandelt die interne Kommunikation zwischen virtuellen Computern.

  • Konfigurieren Sie keine MAC-Adresse für einen Netzwerkadapter, der in einer netzwerkisolierten Umgebung verwendet wird. Lab-Management löscht die MAC-Adresse, sobald die netzwerkisolierte Umgebung erstellt wird.

Do

  • Stellen Sie den Hostcomputern ausreichend Ressourcen zur Verfügung, und konfigurieren Sie sie korrekt. Die Anzahl der Hyper-V-Hosts und die Kapazität jedes Hosts sind von der Anzahl von virtuellen Computern abhängig, die im Lab gehostet werden. Wenn Sie sich entscheiden, ein verhältnismäßig kleines Lab einzurichten, installieren Sie die Hyper-V-Rolle auf Computern mit der folgenden Konfiguration:

    • Zwei Zweikernprozessoren mit 64-Bit, die Hyper-V-fähig sind

    • 16 GB Arbeitsspeicher

    • 300 GB Festplattenspeicherplatz

    • Windows Server 2008 R2-Betriebssystem

    • Die neuesten Updates des Windows-Betriebssystems.

    Wenn Sie bei einer verhältnismäßig größeren Anzahl von virtuellen Computern einige leistungsstarke Hosts einrichten möchten, konfigurieren Sie jeden Host wie folgt:

    • Zwei Vierkernprozessoren mit 64-Bit, die Hyper-V-fähig sind

    • 64 GB Arbeitsspeicher

    • 1 TB Festplattenspeicherplatz

    • Windows Server 2008 R2-Betriebssystem

    • Die neuesten Updates des Windows-Betriebssystems.

  • Reservieren Sie ausreichend RAM-Arbeitsspeicher auf dem Host. Aus den oben aufgeführten Hostkapazitätsanforderungen müssen Sie die folgenden Ressourcen reservieren, damit der Hypervisor reibungslos funktioniert. Reservieren Sie für einen 16-GB-Host 20 % für die CPU und 2 GB Arbeitsspeicher. Reservieren Sie für einen 64-GB-Host 30 % für die CPU und 4 GB Arbeitsspeicher. Diese Hostreserven müssen im Bereich der Hosteigenschaften der SCVMM-Administratorkonsole konfiguriert werden. Für virtuelle Computer können nur die Ressourcen verwendet werden, die nach Abzug der Hostreserven auf dem Host übrig sind.

  • Stellen Sie ausreichend Speicher für virtuelle Computer bereit. Verwenden Sie eine andere Datenträgerpartition für virtuellen Computerspeicher als für die primäre Partition des Hyper-V-Servers. Verwenden Sie beispielsweise Laufwerk D: für virtuellen Computerspeicher und Laufwerk C: für die primäre Partition für den Hypervisor. Nachdem Sie sich für einen Speicherort für den virtuellen Computerspeicher entschieden haben, konfigurieren Sie diesen Speicherort in Hyper-V-Manager oder mithilfe der SCVMM-Administratorkonsole. Ändern Sie in Hyper-V-Manager den Ordner Virtuelle Festplatten und den Ordner Virtuelle Computer. Ändern Sie in der SCVMM-Administratorkonsole den Platzierungspfad in den Hosteigenschaften.

  • Stellen Sie den Hosts schnelle Festplattenlaufwerke bereit, und konfigurieren Sie die Laufwerke ordnungsgemäß. Datenträgertypen für Hosts: Ein Datenträger mit ausreichender Geschwindigkeit ist erforderlich. RAID 5-konfigurierte Datenträger werden dringend empfohlen. Der Speicher für Hosts kann von einem direkt angeschlossenen Speicher oder von einem SAN stammen. Wenn jedoch der Datenträger des Hosts von einem SAN-Laufwerk für Speicher- und Zuverlässigkeitsanforderungen stammt, benötigen Sie separate LUNs, die jedem Host zugeordnet sind. Selbst wenn die LUNs von demselben Controller verwaltet werden, erfolgt das zugrunde liegende Kopieren von BITS während der Bereitstellung eines virtuellen Computers von der Bibliothek über das LAN-Netzwerk, da Visual Studio Lab Management 2010 keine SAN-Funktionalitäten nutzt.

  • Damit SCVMM auf einem Hyper-V-Host installiert werden kann, wird dringend empfohlen, dass das Festplattenlaufwerk, das zum Speichern von auf Hyper-V gehosteten virtuellen Computern verwendet wird, ein anderes Laufwerk als das ist, das für die Bibliothek verwendet wird. Der SCVMM-Server wird in diesem Fall auf dem primären Betriebssystem in Hyper-V ausgeführt. Wenn das primäre Betriebssystem geladen, tritt daher auf allen Gastbetriebssystemen (in Hyper-V bereitgestellte virtuelle Computer) eine Leistungsbeeinträchtigung auf. Um diese Auswirkungen zu reduzieren, konfigurieren Sie die Hostreserven für diesen Computer, indem Sie die Hostreserven des Hyper-V-Computers den zuvor erwähnten SCVMM-Computeranforderungen hinzufügen. Hostreserven können mit der SCVMM-Administratorkonsole konfiguriert werden.

  • Damit ein Hyper-V-Host auch als Bibliotheksserver verwendet werden kann, müssen mehrere Datenträger im Computer vorhanden sein. Sie sollten separate Festplatten auf dem Host für die virtuellen Computer und den Bibliotheksspeicher verwenden.

  • Stellen Sie den Hyper-V-Host mit LOS-Netzwerkfunktionen für Team Foundation Server, SCVMM und andere Bibliotheksserver bereit.

  • Wenn sich die Hyper-V-Hosts an unterschiedlichen geografischen Standorten befinden, benötigen Sie auch einen lokalen Bibliotheksserver für jeden Standort.

  • Aktualisieren Sie die Hosts regelmäßig. Hyper-V-Hosts sollte sich in einem Netzwerk befinden, von dem aus Betriebssystemupdates automatisch angewendet werden können. Wenn dies nicht möglich ist, sollten Sie planen, Windows- und SCVMM-Updates zu verfolgen, und diese dann manuell anwenden, sobald sie verfügbar sind.

Planen für Controller und Agents

Don't

  • Installieren Sie keinen Testcontroller in einer Umgebung. Auf den virtuellen Computern in einer Umgebung sollte nur der Build-, Test- und Labor-Agent installiert werden.

Do

  • Verwenden Sie beim Erstellen und Bereitstellen einer Anwendung für Tests mehrere Buildcontroller. Der erste Controller wird vom Buildprozess verwendet und ist nicht stark ausgelastet. Der zweite Controller wird zum Bereitstellen des Builds auf virtuellen Computern und zum Ausführen von Tests verwendet. Dieser kann daher stark ausgelastet sein, wenn eine große Anzahl virtueller Computer im Lab vorhanden ist. Der zweite Controller wird auch für Momentaufnahmen der Umgebung verwendet.

  • Verwenden Sie Testcontroller in der gleichen Domäne wie Team Foundation Server. Wenn sich und ein Testcontroller in einer Arbeitsgruppe oder einer nicht vertrauenswürdigen Domäne befinden, müssen Sie auf beiden Computern ein lokales Benutzerkonto mit demselben Benutzernamen und Kennwort erstellen, diesen Benutzer auf Team Foundation Server zur Sicherheitsgruppe "[Projektauflistung]\Testdienstkonten für die Projektauflistung" hinzufügen, und den Testcontroller dann mit diesem lokalen Konto bei der Teamprojektsammlung registrieren.

Planen der Topologie

Do

  • Verbinden Sie den Server, auf dem SCVMM installiert ist, über ein Gigabitnetzwerk mit den Bibliotheksservern und den Hyper-V-Hosts.

  • Richten Sie eine vollständige bidirektionale Vertrauensstellungsbeziehung unter den Domänen ein, auf denen Team Foundation Server, der Testcontroller, der Buildcontroller, SCVMM und der physische Host der virtuellen Computer ausgeführt werden.

Es gibt mehrere Topologien, die Sie beim Einrichten von Lab Management zum Testen der Anwendung verwenden können. Die einfachste Topologie zur Verwendung von Lab Management erfordert nur zwei Server: Installieren Sie alle Team Foundation Server-Komponenten auf dem gleichen Server, und installieren Sie alle SCVMM 2008 Komponenten auf einem zusätzlichen Server. Für den Fall, dass Sie komplexe Netzwerktopologieanforderungen haben, durch die die Netzwerke eingeschränkt werden, in denen Team Foundation Server, SCVMM, Hyper-V-Hosts und virtuelle Computer, auf denen die zu testende Anwendung ausgeführt wird, platziert werden können. Vielleicht möchten Sie auch einen Netzwerklastenausgleich für Team Foundation Server konfigurieren. Die folgende Liste enthält mehrere Vorschläge für mögliche Dimensionen für Ihre Topologie sowie die Variationen innerhalb jeder Dimension.

Netzwerkfunktionen

  • DNS

  • Firewall

  • Threat Management Gateway

Domäne

  • Unidirektionale Vertrauensstellung

  • Bidirektionale Vertrauensstellung

  • Keine -Vertrauensstellung

Logische Team Foundation Server-Anwendungsebene

  • Einzelner Server

  • Mehrere Server ohne Netzwerklastenausgleich

  • Mehrere Server mit Netzwerklastenausgleich

Logische Team Foundation Server-Datenebene

  • Einzelner Server

  • Mehrere Server ohne Clustering

  • Mehrere Server mit Clustering

Tests

  • Innerhalb der Umgebung

  • Außerhalb der Umgebung

Die folgenden vier Beispieltopologien sind Beispiele dafür, wie Sie je nach Ihren Testanforderungen Kombinationen der oben erwähnten Dimensionen einrichten können.

Beispieltopologie 1

Die logische Team Foundation Server-Anwendungsebene wird auf mehreren Servern ausgeführt, und diese Server werden von einem Netzwerklastenausgleich gesteuert. Es gibt auch ein separates Testnetzwerk mit Firewalleinstellungen, um den Testdatenverkehr in und aus dem Domänennetzwerk zu steuern. Im folgenden Diagramm ist Topologie 1 veranschaulicht.

Alle Computer wurden zu einem Unternehmensnetzwerk verknüpft

Anweisungen zur Einrichtung dieser Topologie finden Sie unter Einrichten verschiedener Topologien für Tests mit Visual Studio Lab Management - Teil 1.

Beispieltopologie 2

Die logische Anwendungsebene sowie die Datenebenen von Team Foundation Server werden auf mehreren Servern ausgeführt, diese werden jedoch nicht von einem Lastenausgleich gesteuert. Es gibt auch ein separates Testnetzwerk mit einer SAN-basierten Bibliothek und einem Host. Im folgenden Diagramm ist Topologie 2 veranschaulicht.

Computer ohne Lastenausgleich mit SAN

Anweisungen zur Einrichtung dieser Topologie finden Sie unter Einrichten verschiedener Topologien für Tests mit Visual Studio Lab Management - Teil 2.

Beispieltopologie 3

Die logische Team Foundation Server-Anwendungsebene wird auf mehreren Servern ausgeführt, und diese Server werden von einem Netzwerklastenausgleich gesteuert. Es gibt auch ein separates Testnetzwerk. Die getesteten Anwendungen rufen eine Datenbank außerhalb der virtuellen Umgebung auf. Im folgenden Diagramm ist Topologie 3 veranschaulicht.

Computer mit Datenbank außerhalb der Umgebung

Anweisungen zur Einrichtung dieser Topologie finden Sie unter Einrichten verschiedener Topologien für Tests mit Visual Studio Lab Management - Teil 3.

Beispieltopologie 4

Die logische Anwendungsebene sowie die Datenebenen von Team Foundation Server werden auf mehreren Servern ausgeführt, und diese werden von einem Lastenausgleich gesteuert. Das Testnetzwerk und die Umgebungen befinden sich in einer separaten Domäne. Im folgenden Diagramm ist Topologie 4 veranschaulicht.

Computer in zwei Domänen

Anweisungen zur Einrichtung dieser Topologie finden Sie unter Einrichten verschiedener Topologien für Tests mit Visual Studio Lab Management - Teil 4.

Siehe auch

Konzepte

Architektur von Team Foundation Server
Beispiele für die einfache Topologie
Beispiele für Topologie mit mittlerer Komplexität
Beispiele für die komplexe Topologie
Konfigurieren und Verwalten von Lab-Management


Technische Referenz für Team Foundation

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Technische Referenz für Team Foundation
Siehe auch Feedback senden

Sie können zahlreiche Verwaltungs- und Konfigurationsaufgaben für Visual Studio Team Foundation Server an einer Eingabeaufforderung ausführen. Zudem stehen Befehlszeilentools für Aufgaben im Zusammenhang mit der Versionskontrolle und Builds zur Verfügung. Diese technische Referenz enthält eine Liste aller Befehlszeilentools, die in Team Foundation Server verfügbar sind.

Die Arbeitsaufgabentypen und der Prozessleitfaden, die Benutzern in Teamprojekten zur Verfügung stehen, können ebenfalls angepasst werden. Diese technische Referenz enthält detaillierte Informationen zu den Schemas für Arbeitsaufgabentypen und den Prozessleitfaden. Überprüfen Sie die Informationen zu den Schemas, bevor Sie Anpassungen vornehmen.

Allgemeine Aufgaben

Titel

Beschreibung

Verwalten der Serverkonfiguration oder Schreiben von Scripts: Sie können verschiedene Aspekte der Bereitstellung von Team Foundation Server in der Befehlszeile verwalten. Verwenden Sie die Befehlszeilentools für Team Foundation Server, um Änderungen oder Updates der Bereitstellung in ein Script zu schreiben.

  • Verwalten der Serverkonfiguration mit TFSConfig

  • Ändern von Gruppen und Berechtigungen mit TFSSecurity

  • Konfigurieren von Lab-Management mit TFSLabConfig

  • Angeben des mit Microsoft Test Manager aufzuzeichnenden Fehlertyps

  • TFSDeleteProject: Löschen von Teamprojekten

  • TFSFieldMapping

Arbeiten mit der Versionskontrolle: Sie können die Versionskontrolle verwalten und Aufgaben ausführen, indem Sie eine Eingabeaufforderung verwenden.

  • Befehlsverzeichnis der Team Foundation-Versionskontrolle

Verwalten von Builds: Über eine Eingabeaufforderung können Sie Aufgaben wie das Starten und Beenden von Builds sowie das Löschen oder Zerstören abgeschlossener Builds ausführen.

  • Team Foundation Build-Befehle

Importieren, Exportieren und Verwalten von Objekten für die Arbeitsaufgabenverfolgung: Mit dem Befehlszeilentool witadmin können Sie Kategorien, globale Listen, Linktypen, Arbeitsaufgabentypen und Arbeitsaufgabenfelder erstellen, löschen, importieren und exportieren. Die Verwaltung dieser Objekte erfolgt für eine Teamprojektsammlung oder für ein bestimmtes Teamprojekt.

  • witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben

Suchen der Definition für ein Element in einem Arbeitsaufgabentyp: Sie können Arbeitsaufgabentypen, Arbeitsaufgabenformulare und andere Objekte mithilfe von Elementen anpassen.

  • Anpassen von Projektnachverfolgungsdaten, Formularen, Workflow und anderen Objekten

  • Ermitteln der Anforderungen für die Prozess- und Nachverfolgungsanpassung

Suchen der Definition für ein Prozessvorlagen-Plug-In: Sie können Prozessvorlagen erstellen und anpassen, die Sie zum Erstellen von Teamprojekten und Standardisieren neuer Prozesse verwenden.

  • Anpassen von Prozessvorlagen

Siehe auch

Konzepte

Anpassen von Teamprojekten und -prozessen
Anpassen von Prozessvorlagen
Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole


Verwenden von Team Foundation Server-Befehlszeilentools

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwenden von Team Foundation Server-Befehlszeilentools
Feedback senden

Sie können zahlreiche Verwaltungs- und Konfigurationsaufgaben für Visual Studio Team Foundation Server an einer Eingabeaufforderung ausführen. Zudem stehen Befehlszeilentools für Aufgaben im Zusammenhang mit der Versionskontrolle und Builds zur Verfügung. Sie können alternativ auch die Verwaltungskonsole für Team Foundation verwenden, um die Bereitstellung von Team Foundation Server zu verwalten und zu konfigurieren.

Hinweis Hinweis

Selbst wenn Sie mit Administratorrechten angemeldet sind, müssen Sie eine erweiterte Eingabeaufforderung öffnen, um diese Befehle auf einem Server auszuführen, auf dem Windows Server 2008 installiert ist. Um eine erweiterte Eingabeaufforderung zu öffnen, klicken Sie auf Start, klicken mit der rechten Maustaste auf Eingabeaufforderung und klicken dann auf Ausführen als Administrator. Weitere Informationen finden Sie auf der Microsoft-Website.

In diesem Abschnitt

Verwalten der Serverkonfiguration mit TFSConfig

Beschreibt die Optionen und die Parameter von TFSConfig, ein Befehlszeilentool zum Überprüfen und Verwalten der Konfigurationseinstellungen für Team Foundation Server.

Konfigurieren von Lab-Management mit TFSLabConfig

Beschreibt die Optionen und die Parameter von TFSLabConfig, ein Befehlszeilentool zum Verwalten des von Visual Studio Lab Management bereitgestellten Lab-Dienstes.

Ändern von Gruppen und Berechtigungen mit TFSSecurity

Beschreibt die Optionen und Parameter von TFSSecurity, einem Befehlszeilentool zum Überprüfen und Verwalten von Objekten, Anwendungsgruppen, Benutzern und Berechtigungen für Visual Studio Application Lifecycle Management (ALM).

Angeben des mit Microsoft Test Manager aufzuzeichnenden Fehlertyps

Mit dem tcm bugfieldmapping-Befehlszeilentool können Sie eine Zuordnungsdatei in das Teamprojekt importieren und exportieren. Wenn Sie diese Datei verwenden, kann ein Tester für einen Codefehler, der mit Microsoft Test Manager gefunden wurde, automatisch eine Arbeitsaufgabe erstellen.

TFSDeleteProject: Löschen von Teamprojekten

Beschreibt die Optionen und Parameter von TFSDeleteProject, ein Befehlszeilentool zum Löschen eines Teamprojekts.

Verwalten der Integration von Project Server in TfsAdmin ProjectServer

Beschreibt die Optionen und Parameter von TfsAdmin ProjectServer, ein Befehlszeilentool, das Sie verwenden können, um die Integration von TFS und Project Server zu konfigurieren.

TFSFieldMapping

Beschreibt die Optionen und Parameter von TFSFieldMapping, ein Befehlszeilentool, das Sie verwenden können, um die Datei, die Felder in Microsoft Project zuordnet, hoch- oder herunterzuladen. Durch die Bearbeitung dieser Datei können Sie anpassen, wie Felder für Arbeitsaufgaben definiert werden, die in Team Foundation gespeichert und den Feldern zugeordnet sind, die für Microsoft Project definiert werden.

witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben

Beschreibt die Optionen und Parameter von witAdmin, ein Befehlszeilentool, mit dem Sie die Funktionen von Visual Studio ALM erweitern können. Sie können dieses Tool auch verwenden, um die Prozesse anzupassen, indem Sie Objekte, die Ihnen beim Verfolgen von Arbeitsaufgaben helfen, ändern und verwalten.

Verwandte Abschnitte

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole

Konfigurieren von Benutzern, Gruppen und Berechtigungen


Verwalten der Serverkonfiguration mit TFSConfig

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten der Serverkonfiguration mit TFSConfig
Feedback senden

Mithilfe des Befehlszeilentools TFSConfig können Sie zahlreiche Aspekte der Bereitstellung von Visual Studio Team Foundation Server 2012 (TFS) konfigurieren oder ein Script für deren Konfiguration erstellen. Beispielsweise können Sie mit den Befehlen in TFSConfig die folgenden Elemente in Team Foundation Server ändern oder nach Informationen zu diesen Elementen suchen:

  • Dienstkonten und deren Kennwörter

  • Von TFS verwendete Adressen und Ports

  • Status der Teamprojektsammlungen in der Bereitstellung

  • Softwareupdates, die für die Anwendungsebene für Team Foundation und die Datenbanken für TFS übernommen werden

  • Informationen zu weiteren Komponenten, z. B. Team Foundation Build oder Visual Studio Lab Management

    Hinweis Hinweis

    Sie können einen Server auch interaktiv mit der Verwaltungskonsole für Team Foundation konfigurieren. Weitere Informationen finden Sie unter Die Team Foundation-Verwaltungskonsole.

Mithilfe von TFSConfig können Sie TFS so konfigurieren, dass bereits definierte Anmeldeinformationen, Adressen und Anschlüsse verwendet werden. Sie können das Tool nicht verwenden, um Konten zu erstellen oder die von Komponenten wie SharePoint-Produkte verwendeten Adressen zu ändern. Beispielsweise können Sie mithilfe von TFSConfig Dienstkonten und Kennwörter ändern, sofern die betreffenden Konten und Kennwörter bereits vorhanden sind. Sie können TFSConfig auch verwenden, um die Bereitstellung bei Eintreten eines unerwarteten Ereignisses zu reparieren oder wiederherzustellen. Beispielsweise können Sie damit die Bereitstellung reparieren, wenn ein Softwareupdate nicht für alle Komponenten im System gilt oder wenn bei einer Datenbank-Wiederherstellung von einer Sicherung eine Sammlungsdatenbank nicht richtig getrennt wurde.

Sie müssen TFSConfig auf der Anwendungsebene für Team Foundation ausführen. Standardmäßig befindet sich TFSConfig im Verzeichnis Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um TFSConfig auszuführen. Klicken Sie zum Öffnen eines Eingabeaufforderungsfensters mit erhöhten Rechten auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der folgenden Seite auf der Microsoft-Website: Benutzerkontensteuerung.

Für einen ordnungsgemäßen Betrieb muss TFSConfig eine Verbindung mit den folgenden Servern und Diensten herstellen können:

  • Die Instanz oder Instanzen von SQL Server, in denen von dieser TFS-Bereitstellung verwendete Datenbanken gehostet werden, z. B. die Konfigurationsdatenbank oder die Datenbanken für Teamprojektsammlungen.

  • Alle SharePoint-Webanwendungen, die von dieser Bereitstellung von TFS verwendet werden.

  • Alle Instanzen von SQL Server Reporting Services, die von dieser Bereitstellung von TFS verwendet werden.

  • Die Active Directory-Domänencontroller, wenn Team Foundation Server in einer Domäne bereitgestellt wird.

  • Internetinformationsdienste (IIS) auf den Servern der Anwendungsebene.

  • Alle Server, auf denen Team Foundation Build ausgeführt wird und die von dieser Bereitstellung verwendet werden.

  • Alle Server, auf denen Visual Studio Lab Management ausgeführt wird und die von dieser Bereitstellung verwendet werden.

Die globalen Optionen in der folgenden Tabelle können Sie mit den meisten TFSConfig-Befehlen verwenden. Die Ausnahmen werden in den jeweiligen Themen für diese Befehle aufgeführt.

Option | Beschreibung
/? | Zeigt die Befehlssyntax und Optionen für TFSConfig an.
/NoPrompt oder /i | Gibt an, dass der Administrator keine Aufforderung zum Übernehmen von Änderungen erhält.

In diesem Abschnitt

Accounts-Befehl

Befehl Authentication

Certificates-Befehl

ChangeServerID-Befehl

Collection-Befehl

ConfigureMail-Befehl

Diagnosebefehl

Identities-Befehl

Befehl "Import" (TFSConfig)

Jobs-Befehl

Lab-Befehle

License-Befehl

Proxybefehl (TFSConfig)

RebuildWarehouse-Befehl

Befehl "Recover"

RegisterDB-Befehl

RemapDBs-Befehl

Repair-Befehl

Settings-Befehl

Befehl "Updates"


Accounts-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Accounts-Befehl
Beispiel Siehe auch Feedback senden

Sie können die Konten und Kennwörter für alle Dienstkonten, die Visual Studio Team Foundation Server verwendet, mithilfe des Accounts-Befehls ändern. Diese Konten enthalten das Dienstkonto für Team Foundation Server (TFSService), das Datenquellenkonto für SQL Server Reporting Services (TFSReports) und das Dienstkonto für den Team Foundation Server-Proxy (TFSProxy). Mit diesem Befehl kann auch der Besitz der Datenbanken geändert werden, die von Team Foundation Server verwendet werden.

Um das Benutzerkonto oder das Kennwort interaktiv für das Dienstkonto für Team Foundation Server (TFSService) zu ändern, verwenden Sie die Verwaltungskonsole für Team Foundation. Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

Erforderliche Berechtigungen

Zum Verwenden des Accounts-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren und der Sicherheitsgruppe sysadmin für alle SQL Server-Datenbanken sein, die von Team Foundation Server verwendet werden. Wenn Sie die /proxy-Option verwenden, müssen Sie Administrator auf dem Proxyserver sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine Eingabeaufforderung mit erhöhten Rechten öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auf einem Server auszuführen, auf dem Windows Server 2008 ausgeführt wird. Klicken Sie zum Öffnen eines Eingabeaufforderungsfensters mit erhöhten Rechten auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Benutzerkontensteuerung.

TFSConfig Accounts /change|add|set|delete|updatepassword|resetowner [/AccountType:{ApplicationTier|ReportingDataSource|Proxy}] [/Account:AccountName] [/Password:Password] [/SQLInstance:ServerName] [/DatabaseName:DatabaseName] [/Continue]

Parameter

Argument | Beschreibung
AccountName | Gibt den Namen des Kontos an, das als Dienstkonto verwendet wird (im Format Domäne\Benutzername oder Computer\Benutzername).
Password | Gibt das Kennwort für das Konto an, das als Dienstkonto verwendet wird.
ServerName | Wird nur zusammen mit /resetowner /SQLInstance verwendet. Gibt den Namen des Servers, der die Datenbanken für Team Foundation Server hostet, und, falls eine andere Instanz als die Standardinstanz verwendet wird, den Namen der Instanz an. Wenn Sie eine Instanz angeben, müssen Sie das folgende Format verwenden: Servername\Instanzname
DatabaseName | Wird nur zusammen mit /resetowner /DatabaseName verwendet. Gibt den Namen der Datenbank an, deren Besitz geändert wird.

Option

Beschreibung

/change

Ändert das Konto, das als Dienstkonto verwendet wird. Mit dieser Option wird das angegebene Konto allen notwendigen Gruppen hinzugefügt, es werden die erforderlichen Berechtigungen für das Konto werden (sofern möglich) erteilt, und der Dienst wird für die Verwendung des Kontos festgelegt. Wenn Sie die /AccountType-Option nicht mit dieser Option verwenden, wird das Dienstkonto für die Anwendungsebene geändert.

/add

Fügt den Gruppen, die erforderlich zum Verwenden des Kontos als Dienstkonto sind, ein Konto hinzu. Mit dieser Option wird das angegebene Konto allen notwendigen Gruppen hinzugefügt, und die Berechtigungen, die für ein Dienstkonto erforderlich sind, werden erteilt (sofern möglich). Diese Option ändert jedoch das Konto nicht, das als Dienstkonto verwendet wird. Diese Option wird normalerweise in Netzwerk-Lastenausgleichsszenarien (NLB) verwendet. Sie können diese Option in Verbindung mit "/continue" verwenden, wenn bestimmte Dienste oder Datenbanken möglicherweise in der Umgebung nicht verfügbar sind.

/set

Legt ein Konto als Dienstkonto fest. Mit dieser Option wird das Konto keinen Gruppen hinzugefügt. Daher dürfen Sie diese Option nur mit Konten verwenden, die den erforderlichen Gruppen bereits hinzugefügt wurden und die erforderlichen Berechtigungen enthalten. Diese Option wird normalerweise in NLB-Szenarien verwendet.

/delete

Entfernt ein Konto aus dem Kontotyp, den Sie angeben. Mit dieser Option wird das Konto entfernt, das in allen notwendigen Gruppen angegeben wird, und die Berechtigungen, die für ein Dienstkonto erforderlich sind, werden entfernt (sofern möglich). Diese Option ändert jedoch das Konto nicht, das als Dienstkonto verwendet wird. Stellen Sie sicher, dass Sie diese Option nicht für ein Konto verwenden, das die Server in der Bereitstellung derzeit als Dienstkonto verwenden.

/ResetOwner

Ändert den Besitz an den Datenbanken, die Team Foundation Server für das Konto verwendet, unter dem der Befehl ausgeführt wird. Diese Option durchläuft alle Datenbanken und legt die dbo-Anmeldung auf das Konto fest, mit dem Sie diesen Befehl ausführen. Sie müssen diese Option möglicherweise verwenden, wenn Sie eine Bereitstellung verschieben oder wiederherstellen.

/UpdatePassword

Ändert das Kennwort eines Kontos, das als Dienstkonto verwendet wird. Mit dieser Option wird das Kennwort für das Konto aktualisiert, das Sie für alle Dienste in Team Foundation Server angeben, die dieses Konto verwendet.

/AccountType:{AdminConsole|ApplicationTier|ReportingDataSource|Proxy}

Gibt die zu ändernde Kontogruppe an: die Gruppe von Benutzern, die über die minimal erforderlichen Berechtigungen zum Öffnen und Verwenden der Verwaltungskonsole für Team Foundation (AdminConsole) verfügen; das Dienstkonto, das für Team Foundation Server (TFSService) verwendet wird, das Datenquellenkonto für Reporting Services (TFSReports) oder das Dienstkonto für Team Foundation Server Proxy (TFSProxy). Wenn Sie diese Option auslassen, lautet der Standardwert ApplicationTier.

/Account:AccountName

Gibt den Namen des Kontos an, das Sie hinzufügen, ändern oder aus einem Kontotyp entfernen möchten, auf den verwiesen wird, z. B. /AccountType:ApplicationTier. Geben Sie Account in einem der folgenden Formate an: Domain\AccountName oder Computer\AccountName. Wenn Sie ein Systemkonto, z. B. Netzwerkdienst oder lokales System, verwenden möchten, verwenden Sie das Format Computer\Kontoname. Weitere Informationen zum Angeben eines Systemkontos finden Sie weiter unten in diesem Thema in den Verwendungsbeispielen.

/Password:Password

Gibt das Kennwort des Dienstkontos an.

Hinweis Hinweis

Dieser Parameter ist optional, wenn Sie ein Systemkonto oder ein Konto verwenden, das kein Kennwort besitzt, z. B. Netzwerkdienst.

/SQLInstance:ServerName

Wird nur zusammen mit /ResetOwner verwendet. Gibt den Namen des Servers an, auf dem SQL Server ausgeführt wird, sowie den Namen der Instanz, wenn Sie nicht die Standardinstanz verwenden möchten. Sie müssen den Namen und die Instanz im folgenden Format angeben:

Servername\Instanzname

/DatabaseName:DatabaseName

Wird nur zusammen mit /ResetOwner verwendet. Gibt den Namen der Datenbank an, deren Besitz geändert werden soll. Mit diesem Befehl haben Sie den Besitz an der Datenbank zurückgesetzt, die Sie zum Konto, unter dem der Befehl ausführt wird, zuordnen.

/continue

Aktualisiert alle Gruppen, die nicht verfügbar sind, wenn Sie den Befehl ausführen. Diese Option wird normalerweise in NLB-Szenarien verwendet.

Hinweise

Mit dem Accounts-Befehl automatisieren Sie Änderungen an den Dienstkonten, Datenbanken und Dienstkontogruppen von Team Foundation Server. Mit diesem Befehl können Sie Konten konfigurieren, die Sie bereits erstellt haben, aber Sie können keine Konten erstellen.

Damit Sie die Domäne oder Arbeitsgruppe für das Konto ändern können, muss das Konto über die Account is sensitive and cannot be delegated-Berechtigung auf dem Anwendungsebenenserver verfügen. Weitere Informationen finden Sie auf der Microsoft-Website auf der Seite zum Thema Aktivieren der delegierten Authentifizierung.

Beispiel

Im folgenden Beispiel wird gezeigt, wie das Dienstkonto der Datenquellen für Reporting Services in ein neues Konto in der Contoso-Domäne (Contoso \NeuesKonto) und das Kennwort in Kennwort geändert wird.

Hinweis Hinweis

Die in den Beispielen verwendeten Firmen, Organisationen, Produkte, Domänennamen, E-Mail-Adressen, Logos, Personen, Orte und Ereignisse sind frei erfunden. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Domänennamen, E-Mail-Adressen, Logos, Personen, Orten oder Ereignissen ist rein zufällig.

Bild für Kopieren Code kopieren
TFSConfig Accounts /change /AccountType:ReportingDataSource /Account:Contoso\NewAccount /Password:Password

Im folgenden Beispiel wird gezeigt, wie den Dienstkontogruppen für Team Foundation Server das Netzwerkdienstsystemkonto hinzugefügt wird. Systemkonten besitzen keine Kennwörter.

Bild für Kopieren Code kopieren
TFSConfig Accounts /add /AccountType:ApplicationTier /Account:"NT Authority\Network Service"

Im folgenden Beispiel wird gezeigt, wie der Besitz der Datenbank, die TFS_Warehouse auf dem Server genannt wird, auf dem "ssnoversion" ausgeführt wird, und die in der benannten Instanz "Teamdatenbanken" "ContosoMain" genannt wird, auf das Benutzerkonto übergeht, unter dem Sie den Befehl ausführen.

Hinweis Hinweis

Wenn Sie diesen Befehl verwenden, können Sie nicht angeben, welches Konto als Besitzer der Datenbanken festgelegt werden soll. Der Besitzer wird auf das Konto festgelegt, unter dem Sie den Befehl ausführen.

Bild für Kopieren Code kopieren
TFSConfig Accounts /ResetOwner /SQLInstance:ContosoMain\TeamDatabases /DatabaseName:TFS_Warehouse

Siehe auch

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools
Team Foundation Server-Dienste und -Dienstkonten


Befehl Authentication

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Befehl Authentication
Beispiel Siehe auch Feedback senden

Mit dem Befehl Authentication können Sie das Netzwerkauthentifizierungsprotokoll ändern, das eine Website für Team Foundation Server (TFS) verwendet.

Wichtiger Hinweis Wichtig

In Internetinformationsdienste (IIS) 6.0 sind standardmäßig Negotiate und NTLM aktiviert. Windows SharePoint Services 2.0 unterstützt nur das integrierte Windows-Authentifizierung-Protokoll (NTLM) zur Netzwerkauthentifizierung. Benutzer können ggf. nicht auf Websites für Team Foundation zugreifen, wenn die Kerberos-Authentifizierung (Negotiate) aktiviert ist.

Erforderliche Berechtigungen

Um den Befehl Authentication verwenden zu können, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation sein. Bei Verwendung der Option /proxy müssen Sie ein Administrator auf dem Anwendungsebenenserver für Team Foundation oder auf dem Proxyserver sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSAdminUtil Authentication [/provider:NTLM|Negotiate] [/proxy] [/view] [/site:WebSiteName]

Parameter

Argument | Beschreibung
NTLM | Verwenden Sie dieses Argument mit der Option /provider, um das NTLM-Authentifizierungsprotokoll anzugeben.
Negotiate | Verwenden Sie dieses Argument mit der Option /provider, um das Kerberos-Authentifizierungsprotokoll (Negotiate) anzugeben.
WebSiteName | Verwenden Sie dieses Argument, um die Website anzugeben, deren Authentifizierungsprotokoll Sie ändern möchten.
Option | Beschreibung
/view | Zeigt die aktuellen Authentifizierungseinstellungen für TFS an.
/proxy | Führt den Befehl für die Website auf dem Computer aus, auf dem der Team Foundation Server-Proxy ausgeführt wird.
/site | Gibt die Website an, deren Netzwerkauthentifizierungsprotokoll Sie ändern möchten. Wenn Sie keinen Namen angeben, wird TFS verwendet. Wenn Sie den Proxyschalter angeben, wird der Team Foundation Server-Proxy verwendet.

Hinweise

Der Befehl Authentication wird von Administratoren verwendet, die das Netzwerkauthentifizierungsprotokoll für eine oder mehrere Websites ändern möchten, auf denen TFS basiert. Der Administrator führt diesen Befehl von der Anwendungsebene aus, um die Websites zu aktualisieren, deren Netzwerkauthentifizierungsprotokoll geändert werden muss. Durch den Befehl wird die Eigenschaft NTAuthenticationProviders in der IIS Metabase angepasst.

Wichtiger Hinweis Wichtig

Bevor Sie mit dem Befehl Authentication das Authentifizierungsprotokoll ändern, sollten Sie den Befehl mit der Option /view ausführen, um die aktuellen Einstellungen anzuzeigen.

Beispiel

Im folgenden Beispiel wird der aktuelle Wert angezeigt, der für das Netzwerkauthentifizierungsprotokoll zugewiesen ist.

Bild für Kopieren Code kopieren
>TFSAdminUtil Authentication /view

Siehe auch

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools
Administering Team Foundation Server
Team Foundation Server-Dienste und -Dienstkonten


Certificates-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Certificates-Befehl
Beispiel Siehe auch Feedback senden

Sie können den Certificates-Befehl verwenden, um zu ändern, wie Zertifikate zur Clientauthentifizierung in einer Bereitstellung von Visual Studio Team Foundation Server (TFS) konfiguriert werden, die HTTPS, Secure Sockets Layer (SSL) und Zertifikate verwendet. Standardmäßig wählt der Befehl Certificates automatisch ein Clientzertifikat für den aktuellen Benutzer aus der Zertifikatliste aus. Sie können die Optionen jedoch verwenden, damit der Befehl ein bestimmtes Zertifikat oder bestimmte Zertifikate aus dem aktuellen Benutzerkontext oder aus dem lokalen Computerkontext angibt.

Bevor Sie den Certificates-Befehl verwenden, müssen Sie zuerst die Server in der Bereitstellung von TFS konfigurieren, sodass sie Zertifikate verwenden. Weitere Informationen finden Sie unter Einrichten von HTTPS mit SSL (Secure Sockets Layer) für Team Foundation Server.

Erforderliche Berechtigungen

Um den Certificates-Befehl verwenden zu können, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren und der lokalen Administratoren-Gruppe auf dem Computer sein, von dem Sie den Befehl ausführen. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig Certificates [/machine] [/disable] [/autoSelect] [/noprompt] [/thumbprints:thumbprint1[,thumbprint2,...]]

Parameter

Platzhalter | Beschreibung
Thumbprint | Gibt die Hexadezimalzeichenfolge an, die den sicheren Hashalgorithmus (SHA) in SHA-1-Hashform des Zertifikats enthält, das Sie verwenden möchten. Weitere Informationen zum Suchen des Fingerabdrucks für ein Zertifikat finden Sie auf der folgenden Seite der Microsoft-Website: Gewusst wie: Abrufen des Fingerabdrucks eines Zertifikats.
Option | Beschreibung
/machine | Gibt an, dass die Zertifikatliste aus dem lokalen Computerkontext statt des aktuellen Benutzerkontexts stammt.
/disable | Gibt an, dass die Clientauthentifizierungszertifikateinstellung deaktiviert wird.
/autoSelect | Gibt an, dass ein Zertifikat automatisch aus der Zertifikatliste ausgewählt wird. Das Fenster Clientzertifikate verwalten wird nicht geöffnet.
/noprompt | Gibt an, dass das Fenster "Clientzertifikate verwalten" nicht geöffnet wird, wenn der Befehl Zertifikate ausgeführt wird.
/thumbprints:thumbprint | Gibt an, dass das Zertifikat, das eine Entsprechung für den angegebenen Fingerabdruck findet, verwendet wird. Sie können mehr als ein Zertifikat angeben, indem Sie einzelne Fingerabdrücke mit einem Komma trennen.

Hinweise

Mit dem Certificates-Befehl konfigurieren Sie die Clientzertifikate, die von einer Bereitstellung von TFS verwendet werden, die für die Verwendung von HTTPS/SSL und Zertifikaten konfiguriert wurde. Wenn Sie den Zertifikate-Befehl ohne Optionen verwenden, wird aus dem derzeitigen Benutzerkontext, von dem aus Sie den Befehl ausführen, automatisch ein Clientzertifikat ausgewählt.

Beispiel

Im folgenden Beispiel wird gezeigt, wie das lokale Computerzertifikat, das den Fingerabdruck "aa bb cc dd ee" hat, ohne Aufforderungen angegeben wird.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Certificates /machine /thumbprint:aa bb cc dd ee /noprompt

Im folgenden Beispiel wird gezeigt, wie mit der automatischen Auswahl eines Clientzertifikats für den aktuellen Benutzerspeicher angegeben wird.

Bild für Kopieren Code kopieren
TFSConfig Certificates /autoselect

Siehe auch

Konzepte

Architektur von Team Foundation Server
Beispiele für die komplexe Topologie

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


ChangeServerID-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

ChangeServerID-Befehl
Beispiel Siehe auch Feedback senden

Sie können die eindeutigen Bezeichner (GUIDs), die den Datenbanken für Visual Studio Team Foundation Server (TFS) zugeordnet sind, mithilfe des ChangeServerID-Befehls ändern. GUIDs müssen innerhalb einer Bereitstellung von TFS eindeutig sein. Wenn mehr als eine Datenbank die gleiche GUID hat, kann die Bereitstellung instabil oder unbrauchbar werden. Sie können die GUID für die Konfigurationsdatenbank ändern, die GUIDs für alle Teamprojektsammlungsdatenbanken in der Bereitstellung oder beides. Obwohl Sie diesen Befehl in täglichen Operationen in der Regel nicht verwenden würden, könnten Sie diesen Befehl in den folgenden Umständen verwenden:

  • Sie haben die Bereitstellung auf neuer Hardware wiederhergestellt, die alte Bereitstellung ist immer noch funktionstüchtig, und Sie möchten beide Bereitstellungen verwenden. Dieses Szenario wird manchmal als Klonen des Servers bezeichnet.

  • Sie möchten ein Softwareupdate oder eine Hardwarekonfiguration in einer doppelten Bereitstellung testen, um keine Störung der Produktionsumgebung zu riskieren.

  • Sie möchten die Wiederherstellung von Datenbanken auf neuer Hardware in einer Testumgebung oder in einer separaten Umgebung umfassend testen, um sicherzustellen, dass die Bereitstellung wiederhergestellt werden kann.

  • Sie müssen die GUID für eine Auflistungsdatenbank zurücksetzen, nachdem Sie sie in eine andere Bereitstellung verschoben haben, für die diese GUID bereits reserviert ist.

    Hinweis Hinweis

    Der Befehl ChangeServerID ist nicht umkehrbar. Nachdem eine GUID geändert wurde, können Sie diese Änderung nur rückgängig machen, indem Sie eine frühere Version dieser Datenbank wiederherstellen.

Erforderliche Berechtigungen

Zum Verwenden des ChangeServerID-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren und der Sicherheitsgruppe sysadmin für alle SQL Server-Datenbanken sein, die von Team Foundation Server verwendet werden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig ChangeServerID /SQLInstance:ServerName] /DatabaseName:ConfigurationDatabaseName [/ProjectCollectionsOnly] [/ConfigDBOnly]

Parameter

Platzhalter | Beschreibung
ServerName | Gibt den Namen des Servers an, der die Konfigurationsdatenbank für TFS hostet, und den Namen der Instanz, wenn Sie eine von der Standardinstanz abweichende Instanz verwenden. Wenn Sie eine Instanz angeben, muss das folgende Format verwendet werden: Servername\Instanzname
DatabaseName | Gibt den Namen der Konfigurationsdatenbank an. Standardmäßig lautet der Name dieser Datenbank TFS_ConfigurationDB.
Option | Beschreibung
/SQLInstance:ServerName | Erforderlich. Gibt den Namen des Servers an, auf dem SQL Server ausgeführt wird, sowie den Namen der Instanz, wenn Sie nicht die Standardinstanz verwenden möchten. Wenn Sie eine Instanz angeben, muss das folgende Format verwendet werden: Servername\Instanzname
/DatabaseName:DatabaseName | Erforderlich. Gibt den Namen der Konfigurationsdatenbank für TFS an.
/ProjectCollectionsOnly | Gibt an, dass nur die GUIDs für Auflistungen geändert werden.
/ConfigDBOnly | Gibt an, dass nur die GUID für die Konfigurationsdatenbank geändert wird.

Hinweise

Sie verwenden den ChangeServerID-Befehl, um ein einzelnes Duplikat einer Bereitstellung von Team Foundation Server für Tests oder zum Klonen zu erstellen. Nachdem Sie den ChangeServerID-Befehl verwendet haben, müssen Sie Clients anweisen, eine Verbindung mit dem geänderten Server zu erstellen, bevor er verwendet werden kann.

Beispiel

Im folgenden Beispiel wird gezeigt, wie die GUIDs aller Datenbanken in der Contoso1-Bereitstellung von TFS, auf der die Konfigurationsdatenbank auf dem Server "ContosoMain" in der benannten Instanz "TeamDatabases" in SQL Server gehostet wird, geändert werden.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig ChangeServerID /SQLInstance:ContosoMain\TeamDatabases /DatabaseName:TFS_ConfigurationDB

Siehe auch

Konzepte

Sichern und Wiederherstellen der Bereitstellung

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig
Move a Team Project Collection
Split a Team Project Collection


Collection-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Collection-Befehl
Beispiel Siehe auch Feedback senden

Sie können den Collection-Befehl verwenden, um eine Teamprojektsammlung anzufügen, zu trennen oder aus einer Bereitstellung von Visual Studio Team Foundation Server (TFS) zu löschen. Sie können auch die Datenbank einer vorhandenen Auflistung mithilfe des Collection-Befehls duplizieren, umbenennen und an die Bereitstellung anfügen. Dieser Prozess wird manchmal als Klonen einer Auflistung bezeichnet. Sie können jedoch mithilfe des Collection-Befehls eine Teamprojektsammlung erstellen. Weitere Informationen finden Sie unter Erstellen einer Teamprojektsammlung.

Um Auflistungen interaktiv zu verwalten oder um eine Auflistung zu erstellen, können Sie den Knoten Teamprojektauflistungen in der Verwaltungskonsole für Team Foundation verwenden. Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole und Organisieren des Servers mit Teamprojektsammlungen.

Erforderliche Berechtigungen

Zum Verwenden des Collections-Befehls müssen Sie Mitglied der folgenden Gruppen sein:

  • der Sicherheitsgruppe Team Foundation-Administratoren und der Administratoren-Sicherheitsgruppe auf dem Server oder den Servern, die die Verwaltungskonsole für Team Foundation ausführen

  • der Gruppe sysadmin auf den Servern, auf denen die Instanz von SQL Server ausgeführt wird, die die Datenbanken für Team Foundation Server hostet

  • Die Gruppe Farmadministratoren für die Farm, aus der Sie die Siteauflistung löschen, wenn die Bereitstellung SharePoint-Produkte verwendet und Sie die /delete-Option verwenden.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig Collection {/attach | /detach | /delete} [/collectionName:CollectionName] [/collectionDB:ServerName;DatabaseName] [/clone]

Parameter

Platzhalter | Beschreibung
CollectionName | Gibt den Namen der Teamprojektauflistung an. Wenn der Name der Auflistung Leerzeichen enthält, müssen Sie den Namen in Anführungszeichen einschließen (z. B. "My Collection").
ServerName | Gibt den Namen des Servers an, der die Konfigurationsdatenbank für TFS hostet, und den Namen der Instanz, wenn Sie eine von der Standardinstanz abweichende Instanz verwenden. Wenn Sie eine Instanz angeben, muss das folgende Format verwendet werden: Servername\Instanzname
DatabaseName | Gibt den Namen der Konfigurationsdatenbank an. Standardmäßig lautet der Name dieser Datenbank TFS_ConfigurationDB.
Option | Beschreibung
/attach | Erforderlich, wenn weder /detach noch /delete verwendet wird. Wenn Sie diese Option angeben, müssen Sie auch die /collectionDB-Option angeben. Als Option können Sie auch /collectionName und /clone mit dieser Option verwenden. Wenn Sie die /attach-Option verwenden, wird die angegebene Auflistungsdatenbank der Bereitstellung von TFS hinzugefügt.
/detach | Erforderlich, wenn weder /attach noch /delete verwendet wird. Wenn Sie diese Option angeben, müssen Sie auch die /collectionName-Option angeben. Wenn Sie die /detach-Option verwenden, wird die Datenbank für die angegebene Auflistung beendet, und die Auflistung wird von der Bereitstellung von TFS getrennt.
/delete | Erforderlich, wenn weder /detach noch /attach verwendet wird. Wenn Sie diese Option angeben, müssen Sie auch die /collectionName-Option angeben. Wenn Sie die /delete-Option verwenden, wird die Datenbank für die angegebene Auflistung beendet, und die Auflistung wird permanent von TFS getrennt. Sie können die Auflistungsdatenbank nicht wieder an diese oder eine andere Bereitstellung anfügen.
/CollectionName:CollectionName | Erforderlich, wenn /detach oder /delete verwendet wird. Wenn Sie diese Option mit /detach oder /delete verwenden, gibt sie die Auflistung an, die getrennt oder gelöscht wird. Wenn Sie diese Option mit /attach verwenden, gibt sie einen neuen Namen für die Auflistung an. Wenn Sie diese Option mit /attach und /clone verwenden, gibt sie den Namen für die duplizierte Auflistung an.
/CollectionDB:ServerName;DatabaseName | Erforderlich, wenn /attach verwendet wird. Diese Option gibt den Namen des Servers an, der SQL Server ausführt, und den Namen der Auflistungsdatenbank, die auf diesem Server gehostet wird.
/clone | Wenn Sie diese Option angeben, wird die ursprüngliche Auflistungsdatenbank als Klon in SQL Server angefügt, und diese Datenbank wird an TFS angefügt. Diese Option wird hauptsächlich im Rahmen des Teilens einer Teamprojektauflistung verwendet.

Beispiel

Im folgenden Beispiel wird gezeigt, wie die "Contoso Summer Intern Projects"-Teamprojektauflistung permanent aus einer Bereitstellung von Team Foundation Server entfernt wird.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Collection /delete /CollectionName:"Contoso Summer Intern Projects"
TFSConfig - Team Foundation Server-Konfigurationstool Copyright © Microsoft Corporation.Alle Rechte vorbehalten.Das Löschen einer Teamprojektauflistung ist ein unumkehrbarer Vorgang.Eine gelöschte Auflistung kann kein weiteres Mal an den gleichen oder einen anderen Team Foundation Server-Computer angefügt werden.Möchten Sie wirklich 'Contoso Summer Intern Projects' löschen?(Ja/Nein) Ja Gefundene Auflistung 'Contoso Summer Intern Projects' wird gelöscht ...Die Löschung der Auflistung 'Contoso Summer Intern Projects' war erfolgreich.

Im folgenden Beispiel wird gezeigt, wie die Teamprojektauflistung "Contoso Summer Interns Project" dupliziert, "Contoso Winter Interns Projects" benannt und die doppelte Auflistung an die Bereitstellung von Team Foundation Server angefügt wird.

Bild für Kopieren Code kopieren
TFSConfig Collection /attach /collectiondb:"ContosoMain;TFS_Contoso Summer Interns Projects" /CollectionName:"Contoso Winter Intern Projects" /clone

Siehe auch

Konzepte

Sichern und Wiederherstellen der Bereitstellung

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig
Move a Team Project Collection
Split a Team Project Collection


ConfigureMail-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

ConfigureMail-Befehl
Beispiel Siehe auch Feedback senden

Sie können die Generierung automatischer Warnungen unterstützen, wenn Änderungen an Arbeitsaufgaben und anderen Bedingungen vorgenommen werden, indem Sie den E-Mail-Server konfigurieren. Der E-Mail-Server, den Sie angeben, unterstützt alle Teamprojekte, die für alle Projektauflistungen definiert wurden, die wiederum auf dem Anwendungsebenenserver definiert wurden, auf dem Sie den Befehl ausführen. Damit E-Mail-Benachrichtigungen an Teammitglieder gesendet werden, müssen Sie den Server konfigurieren, der Team Foundation Server (TFS) ausführt. Mit dem ConfigureMail-Befehl können Sie dann einen vorhandenen SMTP-Server verwenden.

Erforderliche Berechtigungen

Um den ConfigureMail-Befehl verwenden zu können, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren auf dem Team Foundation-Anwendungsebenenserver sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auszuführen.

TFSConfig ConfigureMail /FromEmailAddress:emailAddress /SmtpHost:SMTPHostName

Parameter

Option

Beschreibung

/FromEmailAddress:emailAddress

Gibt die Adresse an, über die E-Mail-Benachrichtigungen aus TFS für einen Eincheckvorgang, eine zugewiesene Arbeitsaufgabe oder andere Arten von Benachrichtigungen gesendet werden. Diese Adresse wird auf Gültigkeit überprüft und muss, je nach Serverkonfiguration, möglicherweise ein gültiges E-Mail-Konto auf dem E-Mail-Server darstellen.

Falls die Adresse nicht vorhanden oder nicht gültig ist, wird die standardmäßige E-Mail-Adresse verwendet.

/SmtpHost:SMTPHostName

Gibt den Namen des Servers an, auf dem der E-Mail-Server gehostet wird.

Beispiel

Das folgende Beispiel zeigt die Syntax, mit der die E-Mail-Adresse zum Versenden auf TFS@contoso.com und der SMTP-Mailserver auf ContosoMailServer festgelegt wird:

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig ConfigureMail /FromEmailAddress:TFS@contoso.com /SmtpHost:ContosoMailServer

Siehe auch

Aufgaben

Konfigurieren von E-Mail-Benachrichtigungen und Angeben des SMTP-Servers

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools


Diagnosebefehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Diagnosebefehl
Beispiel Siehe auch Feedback senden

Sie können den Diagnose-Befehl verwenden, um nicht übereinstimmende Softwareupdates der Anwendungsebene und der Datenbanken für Visual Studio Team Foundation Server (TFS) zu ermitteln. Für einen ordnungsgemäßen Betrieb müssen dieselben Softwareupdates auf die Anwendungsebene und die Datenbanken angewendet werden. Wenn ein Softwareupdatekonflikt auftritt, können Sie diesen Befehl verwenden, um das Problem zu identifizieren und Informationen dazu zu erhalten, welche zusätzlichen Schritten Sie zur Lösung der Probleme ausführen müssen.

Hinweis Hinweis

Wenn der Diagnose-Befehl feststellt, dass ein Softwareupdate für die Anwendungsebene übernommen wurde, nicht aber für eine oder mehrere Datenbanken für TFS, können Sie versuchen, das Update für die Datenbanken mithilfe des Updates-Befehls automatisch zu übernehmen. Weitere Informationen finden Sie unter Befehl "Updates". Wenn jedoch ein Softwareupdate auf eine oder mehrere Datenbanken angewendet wurde, nicht aber auf die Anwendungsebene, können Sie dieses Update nicht mithilfe des Updates-Befehls für die Anwendungsebene übernehmen. Der Updates-Befehl wendet die Updates nur auf die Datenbanken an. Um das Problem eines fehlenden Updates auf der Anwendungsebene zu behandeln, müssen Sie das Update manuell auf die Anwendungsebene anwenden.

Erforderliche Berechtigungen

Zum Verwenden des Diagnose-Befehls müssen Sie Mitglied der Gruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation und Mitglied der Gruppe sysadmin in SQL Server auf dem Datenebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSConfig Diagnose /scope:updates

Parameter

Option | Beschreibung
/scope:updates | Gibt an, dass im Rahmen der Diagnose die Softwareupdatestufen der Anwendungsebene und der Datenbanken für Team Foundation Server bestimmt werden sollen.

Hinweise

Wenn der Diagnose-Befehl einen Konflikt feststellt, stellt der Befehl Informationen zum Konflikt bereit und schlägt Lösungen vor, um das Problem zu beheben.

Beispiel

Im folgenden Beispiel wird gezeigt, wie der Diagnose-Befehl ausgeführt wird, mit dem bestimmt wird, ob die gleichen Softwareupdates auf die Datenbanken und die Anwendungsebene angewendet wurden.

Bild für Kopieren Code kopieren
TFSConfig Diagnose /scope:updates

Siehe auch

Referenz

Befehl "Updates"

Konzepte

Architektur von Team Foundation Server

Weitere Ressourcen

Upgrading Team Foundation Server


Identities-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Identities-Befehl
Siehe auch Feedback senden

Sie können den Identities-Befehl verwenden, um die Sicherheits-ID (SID) von Benutzern und Gruppen in der Bereitstellung von Visual Studio Team Foundation Server 2012 (TFS) aufzuführen oder zu ändern. In einem der folgenden Szenarien müssen Sie möglicherweise die SID für Benutzer und Gruppen ändern oder aktualisieren:

  • Ändern der Domäne der Bereitstellung

  • Wechseln von einer Arbeitsgruppe in eine Domäne oder von einer Domäne in eine Arbeitsgruppe

  • Migrieren von Konten über Domänen hinweg zu Active Directory

    Hinweis Hinweis

    Sie müssen diesen Befehl nicht ausführen, wenn Sie Domänen innerhalb derselben Active Directory-Gesamtstruktur ändern. TFS behandelt SID-Änderungen für Verschiebungen innerhalb der gleichen Gesamtstruktur automatisch.

Erforderliche Berechtigungen

Um den Identities-Befehl zu verwenden, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation sein. Sie müssen außerdem Mitglied der Sicherheitsgruppe sysadmin für SQL Server auf dem Datenebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSConfig Identities [/change /fromdomain:DomainName1 /todomain:DomainName2 [/account:AccountName] [/toaccount:AccountName]] [/sqlInstance:ServerName /databaseName:DatabaseName] [/account:AccountName]

Parameter

Platzhalter | Beschreibung
DomainName | Gibt den Namen der Domäne an, von der (/fromdomain) oder in die (/todomain) Sie SIDs ändern. Wenn Sie eine Arbeitsgruppe angeben müssen, verwenden Sie den Computernamen als Domänennamen.
AccountName | Gibt den Namen des Kontos an, das Sie auflisten oder ändern möchten. Wenn Sie diesen Parameter mit /change verwenden, geben Sie das Konto an, das Sie nach /account ändern möchten, und Sie geben das Konto an, zu dem Sie nach /toaccount wechseln möchten. Der Kontoname darf keine Domänen- oder Computernamen enthalten.
ServerName | Gibt den Namen des Servers an, der die Konfigurationsdatenbank für TFS hostet, und den Namen der Instanz, wenn Sie eine von der Standardinstanz abweichende Instanz verwenden. Wenn Sie eine Instanz angeben, muss das folgende Format verwendet werden: Servername\Instanzname
DatabaseName | Gibt den Namen der Konfigurationsdatenbank an. Standardmäßig lautet der Name dieser Datenbank TFS_ConfigurationDB.
Option | Beschreibung
/change | Gibt an, dass Sie Identitäten ändern möchten, statt sie aufzuführen.
/fromdomain:DomainName | Erforderlich, wenn /change verwendet wird. Gibt die ursprüngliche Domäne der Identitäten an, die Sie ändern möchten. Wenn Sie aus einer Arbeitsgruppenumgebung wechseln, gibt dies den Namen des Computers an.
/todomain:DomainName | Erforderlich, wenn /change verwendet wird. Gibt die Domäne an, für die Sie Identitäten ändern möchten. Wenn Sie zu einer Arbeitsgruppenumgebung wechseln, gibt dies den Namen des Computers an.
/account:AccountName | Gibt den Namen eines Kontos an, für das Sie Identitäten aufführen oder ändern möchten.
/toaccount:AccountName | Gibt den Namen eines Kontos an, in das Sie Identitäten ändern möchten.
/SQLInstance:ServerName | Gibt den Namen des Servers an, auf dem SQL Server ausgeführt wird, sowie den Namen der Instanz, wenn Sie nicht die Standardinstanz verwenden möchten. Wenn Sie eine Instanz angeben, muss das folgende Format verwendet werden: Servername\Instanzname
/DatabaseName:DatabaseName | Gibt den Namen der Konfigurationsdatenbank für TFS an.

Hinweise

Sie können die Datenbank optional angeben, um Identitäten zu ändern, bevor Sie einen Anwendungsebenenserver für die Bereitstellung konfigurieren. Möglicherweise geben Sie z. B. die Datenbank an, um das Dienstkonto zu ändern, wenn Sie eine Bereitstellung von TFS klonen.

Wenn Sie Identitäten ändern, müssen das Zielkonto oder die Konten bereits in Windows vorhanden sein.

Sie müssen auf die nächste Identitätssynchronisierung mit Windows warten, damit die Eigenschaften von Konten, die Sie mit diesem Befehl ändern, aktualisiert werden. Diese Anforderung schließt Änderungen von Gruppe zu Benutzer, Benutzer zu Gruppe und Domänenkonto zu lokalem Konto ein.

Beispiele

Das folgende Beispiel zeigt, wie die Namen von allen Windows-Benutzern und -Gruppen aufgeführt werden, die in TFS gespeichert sind, und wie angezeigt wird, ob die SID für jeden Benutzer oder jede Gruppe der SID in Windows entspricht. Die Contoso1-Domänenadministratoren haben Domänengruppen wie "Contoso1\Developers" und "Contoso1\Testers" erstellt, um die Verwaltung von Berechtigungen über TFS, SQL Server Reporting Services und SharePoint-Produkte zu erleichtern.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Identities

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSConfig - Team Foundation Server Configuration Tool
Copyright © Microsoft Corporation. All rights reserved.

Account Name Exists (see note 1) Matches (see note 2)
--------------------------------------------------------------------
CREATOR OWNER True True
Contoso1\hholt True True
BUILTIN\Administrators True True
Contoso1\Developers True True
Contoso1\Testers True True
Contoso1\PMs True True
Contoso1\jpeoples True True
Contoso1\Domain Admins True True
Contoso1\SVCACCT1 True True

9 security identifiers (SIDs) were found stored in Team Foundation Server. Of these, 9 were found in Windows. 0 had differing SIDs.

Im folgenden Beispiel wird gezeigt, wie die SIDs für alle Konten in Team Foundation Server von der Domäne Contoso1 in die SIDs für Konten, die entsprechende Namen in der Domäne ContosoPrime haben, geändert werden. Nur die SIDs übereinstimmender Kontonamen werden aktualisiert. Wenn das Konto "hholt" z. B. als "Contoso1\hholt" und "ContosoPrime\hholt" vorhanden ist, wird die Konto-SID in die SID für "ContosoPrime\hholt" geändert. Wenn das Konto "ContosoPrime\hholt" nicht vorhanden ist, wird die SID nicht für Contoso1\hholt aktualisiert.

Bild für Kopieren Code kopieren
TFSConfig Identities /change /fromdomain:Contoso1 /todomain:ContosoPrime

Im folgenden Beispiel wird gezeigt, wie das Konto für ein einzelnes Benutzerkonto "Contoso1\hholt" in das Konto für ein anderes Benutzerkonto "ContosoPrime\jpeoples" geändert wird.

Bild für Kopieren Code kopieren
TFSConfig Identities /change /fromdomain:Contoso1 /todomain:ContosoPrime /account:hholt /toaccount:jpeoples

Im folgenden Beispiel wird gezeigt, wie die SID des "NT-AUTORITÄT\NETZWERKDIENST"-Dienstkontos geändert wird, das in der Bereitstellung von Team Foundation Server verwendet wird, wenn es die Domäne der Bereitstellung von Contoso1 in ContosoPrime ändert. Um ein Systemkonto, beispielsweise Netzwerkdienst, zu ändern, müssen Sie einem zweistufigen Prozess folgen. Sie ändern zuerst das Dienstkonto von NT-AUTORITÄT\NETZWERKDIENST in ein Domänenkonto in der neuen Domäne (TempSVC). Dann ändern Sie das Konto auf dem Server in der neuen Domäne wieder in NETZWERKDIENST. Die Konfigurationsdatenbank wird auf dem Server, der den Namen "ContosoMain" besitzt, auf der benannten Instanz "Teamdatenbanken" in SQL Server gehostet.

Bild für Kopieren Code kopieren
TFSConfig Identities /change /fromdomain:"NT AUTHORITY" /todomain:ContosoPrime /account:"NETWORK SERVICE" /toaccount:TempSVC /SQLInstance:ContosoMain\TeamDatabases /DatabaseName:TFS_ConfigurationDB

TFSConfig Identities /change /fromdomain:ContosoPrime /todomain:"NT AUTHORITY" /account:TempSVC /toaccount:"NETWORK SERVICE"

Siehe auch

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools
Administering Team Foundation Server
Team Foundation Server-Dienste und -Dienstkonten


Befehl "Import" (TFSConfig)

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Befehl "Import" (TFSConfig)
Beispiel Siehe auch Feedback senden

Sie können mithilfe des Import-Befehls die Daten und Projekte von Visual Studio 2005 Team Foundation Server oder von Visual Studio Team System 2008 Team Foundation Server in eine neue Teamprojektsammlung importieren. Hierzu müssen die Datenbanken, die Sie importieren, auf einem Server gehostet werden, der SQL Server 2008 ausführt, und ihre Namen dürfen nicht das Präfix TFS_ enthalten. Wenn die Datenbanken auf einem Server gehostet werden, der SQL Server 2005 ausführt, müssen Sie sie zuerst auf eine von SQL Server unterstützte Version aktualisieren, bevor Sie den Import-Befehl verwenden können. Wenn Sie mehrere Server in eine einzelne Bereitstellung von TFS aggregieren, müssen Sie den Befehl Importieren für jeden Server getrennt ausführen. Die Projekte von jedem Server, auf dem der Import-Befehl ausgeführt wird, werden in eine einzelne Teamprojektauflistung integriert. Wenn Sie z. B. den Befehl Importieren auf zwei separaten Servern ausführen, erstellen Sie zwei Teamprojektsammlungen. Jede Auflistung enthält alle Projekte und Daten von einem Server.

Der Import-Befehl ändert die Datenbanken unwiderruflich für die Verwendung mit der aktuellen Version von TFS. Nachdem Sie den Import-Befehl ausgeführt haben, sind Sie nicht mehr in der Lage, die Datenbanken mit früheren Versionen von TFS zu verwenden. Nachdem Sie die Datenbanken importiert haben, müssen Benutzer der Projekte und der Daten, die in jenen Datenbanken enthalten sind, eine Verbindung mit der Auflistung erstellen, die die Projekte enthält, auf die sie zugreifen möchten, bevor sie in jenen Projekten arbeiten können. Weitere Informationen finden Sie unter Herstellen einer Verbindung mit Teamprojekten in Team Foundation Server. Wenn der Befehl fehlschlägt oder Sie die Projekte auf eine frühere Version von TFS zurücksetzen möchten, besteht die einzige Möglichkeit darin, die Datenbanken von einer Sicherung wiederherzustellen, die erstellt wurde, bevor Sie den Import-Befehl verwendet haben.

Wichtiger Hinweis Wichtig

Stellen Sie sicher, dass Sie alle Datenbanken sichern, bevor Sie den Import-Befehl tatsächlich ausführen.

Der Import-Befehl ist nicht als Ersatz für den Upgrade-Assistenten für TFS vorgesehen. Dieser Befehl aktualisiert Berichte oder Teamprojektportale, die den Projekten und den Datenbanken zugeordnet sind, nicht auf TFS. Primäre Verwendung für diesen Befehl ist das Zusammenführen mehrerer Bereitstellungen von früheren Versionen von TFS in einer aktuellen Bereitstellung von TFS. In den meisten Fällen sollten Sie zuerst mit dem Upgrade-Assistenten die Bereitstellung von TFS aktualisieren. Verschieben oder unterteilen Sie dann die Projekte in Auflistungen, nachdem das Upgrade abgeschlossen wurde. Dieser Ansatz aktualisiert Berichte zusammen mit den Bereitstellungen und hilft, die Funktionalität von Berichten und Teamprojektportalen in der Bereitstellung beizubehalten. Weitere Informationen finden Sie unter Move a Team Project Collection und Split a Team Project Collection. Um aktuelle Informationen zur Aktualisierung von früheren Versionen von Team Foundation Server zu erhalten, laden Sie das Installationshandbuch für Team Foundation herunter. Die aktuelle Version dieses Handbuchs finden Sie auf der folgenden Seite der Microsoft-Website: Installieren von Team Foundation Server und Visual Studio ALM.

Erforderliche Berechtigungen

Um den Import-Befehl verwenden zu können, müssen Sie Mitglied der Gruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation sein. Sie müssen außerdem Mitglied der Gruppe sysadmin für SQL Server auf dem Datenebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSConfig Import /SQLInstance:ServerName /CollectionName:NameOfNewCollection /confirmed

Parameter

Argument

Beschreibung

ServerName

Gibt den Namen des Servers an, auf dem die Datenbanken gehostet werden. Wenn Sie eine andere Instanz als die Standardinstanz verwenden, müssen Sie auch deren Namen im folgenden Format angeben:

Servername\Instanzname

Der Name des Servers und der Instanz, der angegeben wurde, muss ein tatsächlicher Computername, eine IP-Adresse oder ein Systemname, z. B. "localhost", sein. Der Befehl schlägt fehl, wenn Sie einen Platzhalter verwenden, z. B. "." oder "(lokal)".

NameOfNewCollection

Gibt den Namen der Teamprojektauflistung an, die während des Datenbankimports erstellt werden soll. Wenn der Name der zu erstellenden Auflistung Leerzeichen enthält, müssen Sie den Namen in Anführungszeichen einschließen (z. B. "My Collection").

Option | Beschreibung
/SQLInstance:ServerName | Gibt den Server an, der die Datenbanken hostet, die Sie in eine Teamprojektauflistung importieren möchten.
/CollectionName:NameOfNewCollection | Gibt den Namen der Auflistung an, die die importierten Datenbanken hosten wird.
/confirmed | Bestätigt, dass Sie alle Datenbanken gesichert haben, bevor Sie den Befehl ausführen.

Beispiel

Im folgenden Beispiel wird gezeigt, wie die Datenbanken in die Contoso1-Bereitstellung von TFS importiert werden. In diesem Beispiel werden die Datenbanken auf der 2008Projects-Instanz auf dem Server mit dem Namen DataServer2 (DataServer2\2008Projects) gehostet, der SQL Server ausführt. Die Projekte werden alle in die Teamprojektauflistung mit dem Namen "Old Server" importiert.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Import /SQLInstance:DataServer2\2008Projects /CollectionName:"Old Server" /confirmed

Siehe auch

Aufgaben

Erstellen einer Teamprojektsammlung
Hinzufügen einer SharePoint-Webanwendung zur Bereitstellung
Hinzufügen einer SharePoint-Webanwendung zu einer Teamprojektsammlung
Hinzufügen eines Berichtsservers zur Bereitstellung
Hinzufügen eines Berichtsservers zu einer Teamprojektsammlung

Weitere Ressourcen

Upgrading Team Foundation Server
Add a Team Project Portal
Add Reports to a Team Project


Jobs-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Jobs-Befehl
Beispiel Siehe auch Feedback senden

Sie können mithilfe des Jobs-Befehls eine Protokolldatei erstellen, die die Details der letzten Auftragsaktivitäten für eine bestimmte Teamprojektauflistung enthält. Aufträge werden immer dann ausgeführt, wenn ein Update erforderlich ist, um die Informationen oder die Konfiguration für eine Auflistung zu ändern. Sie können auch diesen Befehl verwenden, um einen Auftrag für eine oder alle Teamprojektsammlungen zu wiederholen.

Um einen Auftrag interaktiv zu wiederholen, können Sie die Verwaltungskonsole für Team Foundation öffnen, auf die Registerkarte Status für die Auflistung und dann auf Auftrag wiederholen klicken. Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

Erforderliche Berechtigungen

Zum Verwenden des Jobs-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig Jobs /retry [/CollectionName:CollectionName] [/CollectionID:ID]
TFSConfig Jobs /dumplog [/CollectionName:CollectionName] [/CollectionID:ID]

Parameter

Platzhalter | Beschreibung
CollectionName | Gibt den Namen der Teamprojektauflistung an. Wenn der Name der Auflistung Leerzeichen enthält, müssen Sie den Namen in Anführungszeichen einschließen (z. B. "My Collection"). Wenn Sie alle Auflistungen angeben möchten, können Sie ein Sternchen (*) verwenden.
ID | Gibt die ID der Teamprojektauflistung an.
Option | Beschreibung
/retry | Erforderlich, wenn /dumplog nicht verwendet wird. Gibt an, dass der letzte Auftrag für die angegebene Teamprojektauflistung erneut versucht wird. Wenn Sie diese Option verwenden, müssen Sie auch entweder die /CollectionName- oder die /CollectionID-Option verwenden.
/dumplog | Erforderlich, wenn /retry nicht verwendet wird. Gibt an, dass die letzte Auftragsaktivität für die Auflistung an eine Protokolldatei gesendet wird. Wenn Sie diese Option verwenden, müssen Sie auch entweder die /CollectionName- oder die /CollectionID-Option verwenden.
/CollectionName:CollectionName | Erforderlich, wenn /CollectionID nicht verwendet wird. Gibt den Namen der Auflistung an, für die der letzte Auftrag entweder wiederholt wird (/retry) oder protokolliert wird (/dumplog). Wenn Sie alle Auflistungen angeben möchten, können Sie ein Sternchen (*) verwenden.
/CollectionID:ID | Erforderlich, wenn /CollectionName nicht verwendet wird. Gibt die ID der Auflistung an, für die der letzte Auftrag entweder wiederholt wird (/retry) oder protokolliert wird (/dumplog).

Beispiel

Im folgenden Beispiel wird gezeigt, wie eine Protokolldatei, die die letzte Auftragsaktivität für die Teamprojektauflistung "Contoso Summer Intern Projects" in Team Foundation Server aufführt, erstellt wird.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Jobs /dumplog /CollectionName:"Contoso Summer Intern Projects"

Siehe auch

Konzepte

Sichern und Wiederherstellen der Bereitstellung

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig
Move a Team Project Collection
Split a Team Project Collection


Lab-Befehle

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Lab-Befehle
Siehe auch Feedback senden

Mit Visual Studio Lab Management können Sie virtuellen Umgebungen verwalten, die bei Entwicklung, Bereitstellung und Test von Softwareanwendungen zum Einsatz kommen. Für diese Aufgaben wird von Lab Management Microsoft System Center Virtual Machine Manager (SCVMM) verwendet.

Mit den Befehlen von TfsConfig Lab können Sie Lab Management in der Anwendungsebene von Team Foundation Server konfigurieren und SCVMM-Hostgruppen sowie Bibliotheksfreigaben zu Teamprojektsammlungen hinzufügen.

  • Eine Hostgruppe ist ein logischer Container, der verwendet wird, um einen oder mehrere physische Computer zu verwalten, die virtuelle Computer hosten. Hostgruppen werden von einem Administrator in SCVMM erstellt.

  • Eine Bibliotheksfreigabe ist eine bestimmte Freigabe, die Zugriff auf die dateibasierten Ressourcen bietet, z. B. ISO-Images und virtuelle Festplatten, die Lab Management zum Erstellen und Bereitstellen von virtuellen Umgebungen verwendet. Bibliotheksfreigaben werden vom SCVMM-Administrator in SCVMM erstellt.

Verwenden Sie das Tool TfsLabConfig, um die Hostgruppen und die Bibliothek eines einzelnen Teamprojekts in der Befehlszeile zu verwalten. Weitere Informationen finden Sie unter Konfigurieren von Lab-Management mit TFSLabConfig.

Allgemeine Aufgaben

Aufgabe | Verwandter Inhalt
Einrichten von Team Lab Management und Konfigurieren der Netzwerkisolation. Die Settings-Optionen geben den SCVMM, der von Lab Management verwendet wird, und die Netzwerkadresse für virtuelle Computer an. Die weiteren Optionen ermöglichen Ihnen, die Netzwerkisolation zu konfigurieren. Diese versetzt Sie in die Lage, mehrere Kopien einer Labumgebung gleichzeitig auszuführen, ohne dass Netzwerkkonflikte entstehen. Konflikte können beispielsweise mit Computernamen und der DNS-Registrierung (Domain Name System) auftreten. | TFSConfig Lab /Settings-Befehle
Verwalten von SCVMM-Hostgruppen für eine Teamprojektsammlung. Mithilfe der HostGroup-Optionen können Sie einer Teamprojektsammlung eine Hostgruppe zuweisen, die in SCVMM erstellt wurde, eine Zuweisung entfernen oder die Lab Management-Eigenschaften der Hostgruppe ändern. | TFSConfig Lab /HostGroup-Befehle
Verwalten von SCVMM-Bibliotheksfreigaben für eine Teamprojektsammlung. Mithilfe der LibraryShare-Optionen können Sie einer Teamprojektsammlung eine Bibliotheksfreigabe zuweisen, eine Zuweisung entfernen oder die Lab Management-Eigenschaften der Bibliotheksfreigabe ändern. | TFSConfig Lab /LibraryShare-Befehle
Neuzuweisen von DNS-Datensätzen zu verschobenen oder geänderten Teamprojektsammlungen. Wenn Sie eine Teamprojektsammlung von einer Instanz von Team Foundation Server in eine andere verschieben oder wenn Sie das Team Foundation Server-Dienstkonto ändern, müssen Sie ggf. die DNS-Namen neu zuweisen, die von Lab Management generiert wurden. Die DNS-Optionen aktivieren diese Prozedur. | TFSConfig Lab /DNS-Befehle

Siehe auch

Konzepte

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
Konfigurieren von Lab-Management mit TFSLabConfig

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


TFSConfig Lab /Settings-Befehle

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSConfig Lab /Settings-Befehle
Beispiel Siehe auch Feedback senden

Sie können Visual Studio Lab Management mit der TFSConfig Lab /Settings-Option konfigurieren. Die Einstellungen-Option

  • Legt den Namen des Servers fest, auf dem System Center Virtual Machine Manager (SCVMM)-Server ausgeführt wird, der wiederum die Verwaltung der virtuellen Computer im Lab steuert.

  • Legt den Netzwerkspeicherort fest, z. B. die Netzwerkdomäne oder die Arbeitsgruppe, mit der die physischen Computer in allen Hostgruppen eine Verbindung herstellen können.

  • Legt die IP-Adressen und das virtuelle DNS-Suffix für netzwerkisolierte Netzwerke im Lab fest.

TfsConfig Lab
/Settings
       [/ScVmmServerName:VMMServerName]
       [/NetworkLocation:networkLocation]
       [/IpBlock:networkIsolationIpRange]
       [/DnsSuffix:networkIsolationDnsSuffix]
       [/NoPrompt]
       [/List]

Optionen

Option

Beschreibung

ScvmmServerName:VMMServerName

Dies ist optional. Legt den vollqualifizierten Namen des System Center Virtual Machine Manager 2008 (SCVMM)-Servers fest, den Team Foundation Server verwendet. Dies ist der Name des SCVMM-Servers, der zum Verwalten der virtuellen Computer verwendet wird.

Damit Team Foundation Server mit SCVMM kommunizieren kann, müssen Sie das Konto, unter dem Team Foundation Server ausgeführt wird, der Administratorrolle in SCVMM hinzufügen.

NetworkLocation:networkLocation

Dies ist optional. Legt den vollqualifizierten Namen eines Netzwerks fest, z. B. eine Netzwerkdomäne oder Arbeitsgruppe, das auf allen Hosts im Lab-Netzwerk verfügbar ist. Beim Bereitstellen eines virtuellen Computers verbindet Lab Management den virtuellen Computer automatisch mit dem angegebenen Netzwerk. Sie können nach den verfügbaren Netzwerkspeicherorten auf einem Host suchen, indem Sie die SCVMM-Administratorkonsole verwenden.

IpBlock:networkIsolationIpRange

Dies ist optional. Legt den Bereich von IP-Adressen fest, die den virtuellen Computern in einer Umgebung zugewiesen werden sollen, wenn ein isoliertes Netzwerk erstellt wird. Da die IP-Adressen nur für das interne Routing zwischen virtuellen Computern verwendet werden und nicht über die Grenzen einer Umgebung hinaus verfügbar gemacht werden, können Sie einen beliebigen IP-Bereich angeben, der nicht innerhalb des mit der Option /NetworkLocation angegebenen Netzwerks verwendet wird. In den meisten Fällen sollte der Standardbereich 192.168.23.0/24 funktionieren. Wenn beim Herstellen einer Verbindung mit Umgebungen mit Netzwerkisolation Probleme auftreten, müssen Sie ggf. einen anderen Bereich auswählen.

DnsSuffix:networkIsolationDnsSuffix

Dies ist optional. Legt das DNS-Suffix fest, das verwendet wird, um die Namen virtueller Computer im isolierten Netzwerk für die virtuelle Umgebung zu registrieren. Um zu bestätigen, dass das Suffix in der DNS-Hierarchie richtig konfiguriert ist, wenden Sie sich an den Netzwerkadministrator.

NoPrompt

Dies ist optional. Es wird keine Eingabeaufforderung zur Bestätigung angezeigt. Nicht mit der Option /List verwenden.

List

Listet die aktuellen Konfigurationswerte für Lab Management auf.

Hinweise

Eine der Optionen /ScvmmServerName, /NetworkLocation, /IpBlock, /DnsSuffix oder /List muss in jeder TfsConfig Lab /Settings-Befehlszeile angegeben werden.

Um Lab Management einzurichten, müssen Sie sowohl die /ScVmmServerName-Option als auch die /NetworkLocation-Option angeben. Sie können diese Optionen jedoch in separaten Befehlszeilen angeben.

Um Netzwerkisolation einzurichten, müssen Sie sowohl die /IpBlock-Option als auch die /DnsSuffix-Option angeben. Sie können diese Optionen jedoch in separaten Befehlszeilen angeben.

Mithilfe der Netzwerkisolation können Sie mehrere Kopien eines virtuellen Computers ohne Konflikte mit Computernamen oder IP-Adressen verwenden. Sie müssen für ein isoliertes Netzwerk sowohl ein DNS-Suffix als auch einen IP-Bereich zuweisen. Da die IP-Adressen nur für internes Routing zwischen virtuellen Maschinen verwendet und nicht über die Grenzen einer Umgebung hinaus verfügbar gemacht werden, kann jeder IP-Bereich angegeben werden, der nicht im öffentlichen Netzwerk verwendet wird. In den meisten Fällen sollte der Standardbereich 192.168.1.0/24 funktionieren. Wenn beim Herstellen einer Verbindung mit Umgebungen mit Netzwerkisolation Probleme auftreten, müssen Sie ggf. einen anderen Bereich auswählen.

Beispiel

Im ersten Beispiel wird Lab Management mit der /ScvmmServerName-Option und der /NetworkLocation-Option in einer einzelnen Befehlszeile eingerichtet. Im zweiten Beispiel wird die Netzwerkisolation in separaten Befehlszeilen mit der /IpBlock-Option und der /DNSSuffix-Option konfiguriert.

Bild für Kopieren Code kopieren
REM First example
tfsconfig lab /settings /scvmmservername:vmmserver /networklocation:lab1.contoso.com

REM Second example
tfsconfig lab /settings /ipblock: 192.168.23.0/24
tfsconfig lab /settings /dnssuffix:virtual1.lab1.contoso.com

Siehe auch

Referenz

TFSConfig Lab /LibraryShare-Befehle
TFSConfig Lab /HostGroup-Befehle

Konzepte

TFSConfig-Lab-Befehlsreferenz
TFSLabConfig-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


TFSConfig Lab /HostGroup-Befehle

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSConfig Lab /HostGroup-Befehle
Beispiel Siehe auch Feedback senden

Sie können mithilfe der TfsConfig Lab /HostGroup -Befehle die Zuweisung einer Hostgruppe von System Center Virtual Machine Manager (SCVMM) zu einer Teamprojektauflistung hinzufügen, bearbeiten oder löschen. Hostgruppen, die auf diese Weise zugewiesen werden, werden von Visual Studio Lab Management verwaltet.

TfsConfig Lab /hostgroup /CollectionName:collectionName
      { /Add
            /SCVMMHostGroup:vmmHostPath
            /Name:name
            [LabEnvironmentPlacementPolicy:{Conservative|Aggressive}]
            [/AutoProvision:{True|False}]
            [/DNSSuffix:dnsSuffix]
       | /Delete
            /Name:name
            [/NoPrompt]
       | /Edit
            /Name:name
            {[/AutoProvision:{True|False}]
            [/LabEnvironmentPlacementPolicy:{Conservative|Aggressive}]
            [/DNSSuffix:dnsSuffix]}
            [/NoPrompt]]
       | /List
       | /ListVmmHostGroups }

Parameter

Option

Beschreibung

CollectionName:collectionName

Erforderlich. Die Name der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server.

Add

Fügt die angegebene SCVMM-Hostgruppe den Hostgruppen der Teamprojektauflistung hinzu. Sie müssen die /SCVmmHostGroup-Option und die /Name-Option in Verbindung mit Add angeben.

Delete

Entfernt die angegebene Hostgruppe aus der Teamprojektauflistung. Sie müssen die /Name-Option in Verbindung mit Delete angeben.

Edit

Legt eine oder beide der Lab Management AutoProvision-Eigenschaften und LabEnvironmentPlacementPolicy-Eigenschaften für die Hostgruppe fest.

Sie müssen die /Name-Option und mindestens eine der Optionen /AutoProvision oder /LabEnvironmentPlacementPolicy in Verbindung mit Edit angeben.

SCVMMHostGroup:vmmH ostGroupPath

Mit der /Add-Option erforderlich. Gibt den Hostpfad der SCVMM-Hostgruppe an.

Name:name

Erforderlich mit den Optionen /Add, /Delete oder /Edit. Geben Sie den Namen der hinzuzufügenden, zu löschenden oder zu bearbeitenden Teamprojektauflistungs-Hostgruppe an.

AutoProvision:{True|False}

Optional mit der /Add-Option oder der /Edit-Option. Legt die AutoProvision-Eigenschaft der Hostgruppe fest (True) bzw. löscht diese (False). AutoProvision gibt an, ob die Hostgruppe automatisch jedem Teamprojekt in der Auflistung zugewiesen wird. Standardmäßig werden Hostgruppen den Teamprojekten in einer Auflistung zugewiesen, wenn Sie den TfsConfig Lab/HostGroup-Befehl verwenden.

LabEnvironmentPlacementPolicy:{Conservative|Aggressive}

Optional mit der /Add-Option oder der /Edit-Option. Gibt an, wie Lab Management die physischen Computer in einer Hostgruppe behandelt, auf denen es neue virtuelle Lab-Umgebungen bereitstellt.

  • Conservative (Standard). Berücksichtigen Sie bei Bereitstellungsentscheidungen auch virtuelle Umgebungen, die derzeit nicht ausgeführt werden. Dies schließt alle virtuellen Computer ein, die Teil von Umgebungen sind, die sich im Zustand "Beendet" befinden.

  • Aggressive Lassen Sie das Ausführen von virtuellen Umgebungen in Bereitstellungsentscheidungen nicht außer Acht.

DNSSuffix:[dnsSuffix]

Dies ist optional. Legt das DNS-Suffix der virtuellen Computer in der Hostgruppe fest.

  • Wenn die /DNSSuffix:-Option ohne einen dnsSuffix-Wert angegeben wird, legt das DNS-Suffix das Suffix der virtuellen Computer auf das Suffix des Hostcomputer in der Hostgruppe fest oder setzt es zurück.

  • Wenn die /DNSSuffix-Option nicht mit der /Add-Option angegeben wird, wird das Suffix virtueller Computer auf die Suffixe ihrer Hostcomputer in der Hostgruppe festgelegt.

  • Wenn die /DNSSuffix-Option nicht mit der /Edit-Option angegeben wird, wird das Suffix virtueller Computer nicht geändert.

NoPrompt

Optional mit der /Delete-Option oder der /Edit-Option. Benutzer werden nicht zum Bestätigen aufgefordert.

List

Zeigt die Hostgruppen an, die der Teamprojektauflistung zugewiesen sind.

ListVmmHostGroups

Zeigt die über SCVMM verfügbaren Hostgruppen an.

Hinweise

Hostgruppen sind Container, die ein Administrator innerhalb von SCVMM erstellt, um einen Satz virtueller Computerhosts zu gruppieren und so die einfache Verwaltung zu ermöglichen. Hostgruppen sind hierarchisch aufgebaut, und eine Hostgruppe kann andere Hostgruppen enthalten.

Jede Hostgruppe wird über seinen Hostpfad, eine Sequenz von Hostgruppennamen, die die Position eines Hosts oder einer Hostgruppe in der Hierarchie von Hostgruppen in SCVMM angibt, identifiziert. Alle Hostpfade beginnen mit der Stammhostgruppe. Der Hostpfad "All Hosts\New York\Site21\VMHost05" gibt beispielsweise an, dass der Host "VMHost05" zur Hostgruppe "Site21" gehört, die eine untergeordnete Hostgruppe der Hostgruppe "New York" ist.

Verwenden Sie nur eine der Optionen /Add, /Delete oder /Edit in einer Befehlszeile. Verwenden Sie separate TfsConfig Lab /HostGroup-Befehlszeilen, um mehrere Hostgruppen einer Teamprojektauflistung zuzuweisen.

Sie können auch TfsConfig Lab /HostGroup-Befehle verwenden, um Eigenschaften festzulegen, die für Lab Management spezifisch sind:

  • AutoProvision gibt an, ob die Hostgruppe automatisch jedem Teamprojekt in der Teamprojektauflistung zugewiesen wird. AutoProvision ist standardmäßig aktiviert. Um eine Hostgruppe in einer Projektauflistung einem einzelnen Teamprojekt zuzuweisen, verwenden Sie TFSLabConfig CreateTeamProjectHostGroup-Befehl.

    • True (Standard). Die Hostgruppe wird automatisch jedem Teamprojekt in der Teamprojektauflistung zugewiesen.

    • False. Die Hostgruppe wird nicht automatisch jedem Teamprojekt in der Teamprojektauflistung zugewiesen.

  • LabEnvironmentPlacementPolicy gibt an, ob Lab Management die vorhandenen virtuellen Computer berücksichtigt, wenn neue Umgebungen auf einem physischen Computer in einer Hostgruppe bereitgestellt werden.

    • Conservative (Standard). Berücksichtigen Sie bei Bereitstellungsentscheidungen auch virtuelle Umgebungen, die derzeit nicht ausgeführt werden. Dies schließt alle virtuellen Computer ein, die Teil von Umgebungen sind und sich außerdem im Zustand "Beendet" befinden.

    • Aggressive Lassen Sie das Ausführen von virtuellen Umgebungen in Bereitstellungsentscheidungen nicht außer Acht.

  • DNSSuffix gibt ein DNS-Suffix an, das für die in der Hostgruppe erstellten virtuellen Computer verwendet werden soll. In der folgenden Tabelle wird beschrieben, wie die DNS-Suffixe virtueller Computer von der /DNSSuffix-Einstellung betroffen sind.

    DNSSuffix

    /Hinzufügen

    /Bearbeiten

    DNSSuffix:dnsValue

    Das DNS-Suffix wird auf dnsValue festgelegt.

    Das DNS-Suffix wird auf dnsValue festgelegt.

    DNSSuffix:

    Das DNS-Suffix wird vom Hostcomputer geerbt.

    Der vorhandene Suffixwert wird entfernt, und das DNS-Suffix wird von Hostcomputer geerbt.

    <Nicht angegeben>

    Das DNS-Suffix wird vom Hostcomputer geerbt.

    DNS-Suffix wurde nicht geändert.

Beispiel

Im folgenden Beispiel wird eine SCVMM-Hostgruppe einer Teamprojektauflistung zugewiesen. Da die /AutoProvision-Option nicht angegeben wird, wird die Hostgruppe automatisch allen Teamprojekten in der Auflistung zugewiesen.

Bild für Kopieren Code kopieren
tfsconfig lab /hostgroup /add /scvmmhostgroup:"All Hosts\Lab1\HostGroup1" /collection:Collection0 /name:Lab1Collection0_Lab1_HostGroup1

Siehe auch

Referenz

TFSConfig Lab /Settings-Befehle
TFSConfig Lab /LibraryShare-Befehle
TFSConfig Lab /HostGroup-Befehle

Konzepte

TFSConfig-Lab-Befehlsreferenz
TFSLabConfig-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


TFSConfig Lab /LibraryShare-Befehle

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSConfig Lab /LibraryShare-Befehle
Siehe auch Feedback senden

Sie können mithilfe des TfsConfig Lab /LibraryShare -Befehls die Zuweisung einer Bibliotheksfreigabe von System Center Virtual Machine Manager (SCVMM) zu einer Teamprojektauflistung hinzufügen, entfernen oder bearbeiten. Sie können den Befehl auch verwenden, um Visual Studio Lab Management-spezifische Eigenschaften festzulegen und die Bibliotheksfreigaben anzuzeigen, die momentan einer Auflistung in Lab Management zugewiesen sind, oder um alle Bibliotheksfreigaben in SCVMM anzuzeigen.

TfsConfig Lab /LibraryShare
      /CollectionName:collectionName
      { /Add
            /SCVMMLibraryShare:librarySharePath
            /Name:name
            [/AutoProvision:{True|False}]
      | /Delete
            /Name:name
            [/NoPrompt]
      | /Edit
            /Name:name
            /AutoProvision:{True|False}
            [/NoPrompt]
      | /List
      | /ListSCVMMLibraryShares }

Parameter

Option

Beschreibung

Add

Fügt die angegebene Bibliotheksfreigabe der Teamprojektauflistung hinzu. Sie müssen die /SCVMMLibraryShare-Option und die /Name-Option in Verbindung mit Add angeben.

Delete

Entfernt die angegebene Bibliotheksfreigabe aus der Teamprojektauflistung. Sie müssen die /Name-Option in Verbindung mit Delete angeben.

Edit

Legt die AutoProvision-Eigenschaft der Bibliotheksfreigabe fest bzw. löscht diese. Sie müssen die /Name-Option und die /AutoProvision-Option in Verbindung mit Edit angeben.

Standardmäßig werden Bibliotheksfreigaben den Teamprojekten in einer Auflistung zugewiesen.

Hinweis Hinweis

Das Ändern der automatischen Bereitstellung wirkt sich auf vorhandene Teamprojekte aus.

CollectionName:collectionName

Erforderlich. Geben Sie den Namen der Teamprojektauflistung auf der Team Foundation Server-Anwendungsebene an.

SCVMMLibraryShare:librarysharePath

Erforderlich mit Add. Gibt den Pfad zur Virtual Machine Manager-Bibliotheksfreigabe an.

Name:libraryShareName

Erforderlich mit Add, Delete und Edit. Gibt den Namen der Bibliotheksfreigabe in der Teamprojektauflistung an.

AutoProvision

Optional mit Add, erforderlich mit Edit. Gibt an, ob die Bibliotheksfreigaben automatisch den einzelnen Teamprojekten in der Auflistung zugewiesen werden. Standardmäßig werden Bibliotheksfreigaben den Teamprojekten zugewiesen.

NoPrompt

Optional mit Add und Edit. Der Benutzer wird nicht zur Bestätigung aufgefordert.

List

Führt alle Bibliotheksfreigaben auf, die der angegebenen Teamprojektauflistung zugewiesen sind.

ListSCVMMLibraryShares

Führt alle Bibliotheksfreigaben auf, die in Virtual Machine Manager verfügbar sind.

Hinweise

Eine Bibliotheksfreigabe ist eine feste Freigabe auf einem Virtual Machine Manager-Bibliotheksserver. Eine Bibliotheksfreigabe ermöglicht den Zugriff auf dateibasierte Ressourcen für virtuelle Lab Management-Umgebungen, die auf den Bibliotheksservern gespeichert sind, z. B. ISO-Images und virtuelle Festplatten. Bibliotheksfreigaben werden in Virtual Machine Manager erstellt. Visual Studio Lab Management stellt virtuelle Computer im Lab mithilfe von Bibliotheksfreigaben bereit.

Verwenden Sie nur eine der Optionen /Add, /Edit oder /Delete in einer TfsConfig Lab /LibraryShare-Befehlszeile. Verwenden Sie separate TfsConfig Lab /LibraryShare-Befehlszeilen, um einer Auflistung mehrere Bibliotheksfreigaben zuzuweisen.

Bibliotheksfreigaben in einer Teamprojektauflistung werden automatisch jedem Teamprojekt in der Auflistung zugewiesen. Sie können die /AutoProvision-Option mit den Befehlen /Add und /Edit verwenden, um die zugewiesenen Bibliotheksfreigaben zu ändern.

  • Legen Sie die /AutoProvision-Option auf False fest, um die automatische Zuweisung der Bibliotheksfreigabe zu Teamprojekten zu deaktivieren. Um eine Bibliotheksfreigabe in einem einzelnen Teamprojekt zuzuweisen oder aus diesem zu entfernen, verwenden Sie TfsLabConfig TFSLabConfig CreateTeamProjectLibraryShare-Befehl.

  • Legen Sie die /AutoProvision-Option auf True fest, um die automatischen Zuweisungen zu aktivieren.

Siehe auch

Referenz

TFSConfig Lab /Settings-Befehle
TFSConfig Lab /HostGroup-Befehle

Konzepte

TFSConfig-Lab-Befehlsreferenz
TFSLabConfig-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


TFSConfig Lab /DNS-Befehle

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSConfig Lab /DNS-Befehle
Beispiel Siehe auch Feedback senden

Der TfsConfig Lab /DNS-Befehl fügt DNS-Datensätze hinzu, die von Visual Studio Lab Management für netzwerkisolierte Umgebungen erstellt wurden, löscht sie oder zeigt sie an.

Team Foundation Server verwendet das eingegebene Suffix bei der Registrierung eines eindeutigen externen Namens mit DNS für jeden virtuellen Computer in einer netzwerkisolierten Umgebung. Mit dem DNS-Aliasdatensatz ist die Kommunikation von Computern und anderen Objekten außerhalb des isolierten Netzwerks mit Computern innerhalb des isolierten Netzwerks möglich. Da sich Team Foundation Server für die Registrierung des Aliasdatensatzes in der DNS-Zone befindet, müssen für das Dienstkonto, mit dem Team Foundation ausgeführt wird, Berechtigungen zum Hinzuzufügen und Löschen von Aliasdatensätzen in der angegebenen DNS-Zone bestehen.

Wenn die Team Foundation Server-Bereitstellung mehr als eine Anwendungsebene umfasst und jede Anwendungsebene mit einem anderen Dienstkonto ausgeführt wird, dann muss jedes Dienstkonto auf Anwendungsebene über die Berechtigung zum Bearbeiten der DNS-Aliasdatensätze verfügen, die durch die anderen Anwendungsebenen erstellt wurden.

Hinweis Die DNS-Datensatzverwaltung wird automatisch von Lab Management ausgeführt. Sie sollten den /DNS-Befehl nur in den folgenden Situationen verwenden:

  • Sie ändern das Konto, mit dem Visual Studio Team Foundation Server (TFS) ausgeführt wird.

  • Sie verschieben eine Teamprojektauflistung von einer Instanz von Team Foundation Server in eine andere.

In diesen beiden Fällen müssen die DNS-Datensätze, die mit dem alten TFS-Dienstkonto erstellt wurden, entfernt werden, und dann müssen die gleichen DNS-Datensätze mit dem neuen TFS-Dienstkonto neu erstellt werden. Wenn diese Schritte nicht in den vorherigen Szenarien ausgeführt werden, ist das neue TFS-Dienstkonto nicht in der Lage, die automatische Verwaltung jener DNS-Datensätze auszuführen. Als Ergebnis sind Benutzer nicht in der Lage, eine Verbindung mit virtuellen Umgebungen herzustellen.

TfsConfig Lab /DNS
{/Add | /Delete | /List}
    [/CollectionName:collectionName |
    / CollectionName:collectionName /TeamProject:projectName |
    / CollectionName:collectionName /TeamProject:projectName /LabEnvironment:environmentUri |
    /Name:FQDN /IP:IpAddress]
    [/NoPrompt]

Optionen

Option

Beschreibung

Add

Fügt die angegebenen DNS-Datensätze hinzu. Zur Verwendung der /Add-Option muss die Zielumgebung ausgeführt werden.

Delete

Entfernt die angegebenen DNS-Datensätze.

List

Zeigt die angegebenen DNS-Datensätze an.

LabEnvironment:environmentUri

Verweist die /Add, /Delete oder /List-Optionen auf eine einzelne netzwerkisolierte Umgebung, die von environmentUri angegeben wird.

Um die LabEnvironment-Option verwenden zu können, müssen Sie auch die /Collection-Option und die /TeamProject-Option angeben.

TeamProject:projectName

Legt bei Verwendung ohne /LabEnvironment alle von projectName angegebenen netzwerkisolierten Umgebungen im Teamprojekt als Ziele der Optionen /Add, /Delete oder /List fest. Andernfalls gibt /TeamProject das Teamprojekt an, das die Umgebung enthält.

Zum Verwenden der /TeamProject-Option müssen Sie auch die /Collection-Option angeben.

CollectionName:collectionName

Legt bei Verwendung ohne /TeamProject alle von collectionName angegebenen netzwerkisolierten Umgebungen in der Teamprojektauflistung als Ziele der Optionen /Add, /Delete oder /List fest. Andernfalls gibt /Collection die Teamprojektsammlung an, die das Teamprojekt enthält.

Name:FQDN

Gibt den vollqualifizierten Domänennamen des Netzwerkspeicherorts an, der die Zielumgebung enthält.

Sie müssen die /Name-Option und die /IP-Option zusammen angeben.

IP:IPAddress

Gibt die IP-Adresse der Zielumgebung an.

Sie müssen die /Name-Option und die /IP-Option zusammen angeben.

Hinweise

Geben Sie nur eine der Optionen /Add, /Delete oder /List in einer TfsConfig Lab /DNS-Befehlszeile an. Wenn Sie keine weitere Zieloptionen angeben, wird die Operation auf alle virtuellen Computer aller netzwerkisolierten Umgebungen angewendet, die zu allen Projektsammlungen in der Team Foundation Server-Datenbank gehören.

Um auf die DNS-Einträge von netzwerkisolierten Umgebungen eines Objekts in der Lab Management-Objekthierarchie abzuzielen, verwenden Sie die entsprechende Kombination der Optionen /Collection, /TeamProject und /LabEnvironment

  • Die /LabEnvironment-Option richtet den Befehl auf die angegebene netzwerkisolierte Umgebung. Sie müssen die /CollectionName-Option und die /TeamProject-Option in Verbindung mit der /LabEnvironment-Option verwenden, um die Teamprojektauflistung und das Teamprojekt mit der Umgebung anzugeben.

    Verwenden Sie das Format vstfs:///LabManagement/LabEnvironment/environmentID, um die Umgebungs-URI anzugeben. Sie können den Umgebungsbezeichner (environmnetID) im Umgebungs-Viewer von Lab Management oder über die Beschreibung des virtuellen Computers in der SCVMM-Administratorkonsole anzeigen.

  • Die /TeamProject-Option richtet den Vorgang auf netzwerkisolierte Umgebungen im angegebenen Teamprojekt aus. Die /TeamProject-Option muss mit der /CollectionName-Option verwendet werden, und die /CollectionName-Option muss die Teamprojektauflistung mit dem Teamprojekt angeben.

  • Die /CollectionName-Option richtet den Vorgang auf netzwerkisolierte Umgebungen in der angegebenen Teamprojektauflistung aus.

Die zweite Möglichkeit, auf eine netzwerkisolierte Umgebung abzuzielen, ist, die /Name- und /IP-Optionen zu verwenden, um den vollqualifizierten externen Namen und externe IP-Adresse eines einzelnen virtuellen Computers anzugeben. Sie müssen sowohl die /Name-Option als auch die /IP-Option in der Befehlszeile angeben. Sie können den externen Namen und die externe IP-Adresse eines virtuellen Computers im Umgebungs-Viewer von Lab Management oder über die Beschreibung des virtuellen Computers in der SCVMM-Administratorkonsole anzeigen.

Beispiel

Im ersten Beispiel werden Datensätze für alle netzwerkisolierten Umgebungen in einem Teamprojekt dem DNS hinzugefügt. Im zweiten Beispiel wird ein einzelner DNS-Datensatz entfernt.

Bild für Kopieren Code kopieren
REM First example
tfsconfig lab /dns /add /collectionname:Collection0 /teamproject:Project1

REM Second example
tfsconfig lab /dns /delete /name:0b668996-2736-46d2-88ac-0733acbd0d9c.contoso.com /ip:111.00.000.000

Siehe auch

Konzepte

TFSConfig-Lab-Befehlsreferenz
TFSLabConfig-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSConfig Lab /Delete-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSConfig Lab /Delete-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie die TfsConfig Lab /Delete-Option, um alle Gruppenhosts, Bibliotheksfreigaben und Umgebungen aus einer angegebenen Teamprojektauflistung zu entfernen. Standardmäßig werden die zugeordneten Objekte im System Center Virtual Machine Manager (SCVMM) nicht gelöscht. Sie können der Befehlszeile die /External-Option hinzufügen, um die Objekte aus der Projektsammlung und aus SCVMM zu entfernen.

Hinweis Hinweis

Die /Delete-Option arbeitet nur an allen Lab-Ressourcen in einer Teamprojektauflistung, wenn die /LibraryShare- und /GroupHost-Optionen nicht in der Befehlszeile angegeben sind. Weitere Informationen finden Sie unter TFSConfig Lab /LibraryShare-Befehle und TFSConfig Lab /HostGroup-Befehle.

TfsConfig Lab /Delete
    /CollectionName:collectionName
    [/External]
    [/NoPrompt]

Optionen

Option | Beschreibung
CollectionName:collectionName | Erforderlich. Gibt den Namen der Teamprojektauflistung auf der Team Foundation Server-Anwendungsebene an.
External | Dies ist optional. Entfernt bei Angabe die Bibliotheksfreigaben und Hostgruppen in SCVMM zusätzlich zu den Objekten in der Teamprojektsammlung. Wenn /External nicht angegeben wird, entfernt der TfsConfig Lab /Delete-Befehl nur die Objekte in der Teamprojektsammlung.
NoPrompt | Dies ist optional. Zeigt bei Angabe keine Status- und Erfolgsinformationen an.

Hinweise

Verwenden Sie den /Delete-Befehl, um die Lab-Objekte aus einer Projektauflistung zu entfernen, wenn Sie die Lab-Konfiguration einer Projektauflistung trennen möchten. Dies ist nützlich beim Verschieben einer Projektauflistung von einer Team Foundation Server (TFS)-Instanz in eine andere Instanz, und wenn die neue Team Foundation Server-Instanz einen anderen SCVMM-Server als den ursprünglichen Server verwendet. In diesem Fall müssen Sie alle Lab-Ressourcen löschen und Lab für die Projektsammlung neu konfigurieren.

Beispiel

Im folgenden Beispiel werden alle Lab-Objekte in der DefaultCollection-Teamprojektsammlung entfernt. Da die /External-Option nicht angegeben ist, werden die Objekte in SCVMM zurückgehalten.

Bild für Kopieren Code kopieren
tfsconfig lab /delete /collectionName:DefaultCollection

Siehe auch

Konzepte

TFSConfig-Lab-Befehlsreferenz
TFSLabConfig-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


License-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

License-Befehl
Beispiel Siehe auch Feedback senden

Sie können mithilfe des License-Befehls den Lizenzschlüssel für die Bereitstellung von Visual Studio Team Foundation Server anzeigen, ändern oder erweitern.

Um die Lizenzierung für die Bereitstellung anzuzeigen oder interaktiv zu ändern, können Sie die Verwaltungskonsole für Team Foundation verwenden. Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole und Suchen oder Ändern des Product Key für Team Foundation Server.

Erforderliche Berechtigungen

Zum Verwenden des License-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine Eingabeaufforderung mit erhöhten Rechten öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auf einem Server auszuführen, auf dem Windows Server 2008 ausgeführt wird. Klicken Sie zum Öffnen eines Eingabeaufforderungsfensters mit erhöhten Rechten auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Benutzerkontensteuerung.

TFSConfig License [/ProductKey:Key] [/extend [NewTrialID]]

Parameter

Platzhalter | Beschreibung
Key | Gibt beim Ändern der Bereitstellung von Team Foundation Server von einer Testlizenz in eine Lizenz für die Vollversion einen zu verwendenden gültigen Product Key an.
NewTrialID | Gibt einen zweiten Testlizenzschlüssel an. Ein zweiter Testlizenzschlüssel kann von Microsoft Corporation erhalten werden. Der primäre Testlizenzschlüssel gilt 90 Tage lang, während der sekundäre Testlizenzschlüssel die Bereitstellung nur um 30 Tage verlängert.
Option | Beschreibung
/ProductKey:Key | Gibt an, dass der Lizenzschlüssel zur Bereitstellung mit dem Wert Key aktualisiert wird.
/extend | Gibt an, dass der Testlizenzierungszeitraum für Team Foundation Server um 30 Tage verlängert wird. Diese Option kann nur einmal verwendet werden. Wenn eine zweite Erweiterung erforderlich ist, müssen Sie eine zweite Testlizenz von Microsoft beziehen.

Beispiel

Im folgenden Beispiel wird gezeigt, wie die Lizenzierungsinformationen für eine Bereitstellung von Team Foundation Server angezeigt werden. In diesem Beispiel verwendet die Bereitstellung eine Testlizenz.

Hinweis Hinweis

Die in den Beispielen verwendeten Firmen, Organisationen, Produkte, Domänennamen, E-Mail-Adressen, Logos, Personen, Orte und Ereignisse sind frei erfunden. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Domänennamen, E-Mail-Adressen, Logos, Personen, Orten oder Ereignissen ist rein zufällig.

Bild für Kopieren Code kopieren
TFSConfig License
TFSConfig - Team Foundation Server-Konfigurationstool Copyright © Microsoft Corporation.Alle Rechte vorbehalten.Team Foundation Server-Standardlizenz - die folgenden Funktionen werden installiert: Team Foundation Server-Builddienst-Build: 21106.00 - Produkt-ID: 01234-567-8910 - Testlizenz mit 74 verbleibenden Tagen, die am 30.06.2010 abläuft - Test-ID: ABCD-EFGH-IJKL

Im folgenden Beispiel wird gezeigt, wie die Testlizenz für eine Bereitstellung von Team Foundation Server erweitert wird. In diesem Beispiel wird der Testzeitraum aus dem vorherigen Beispiel um 30 Tage verlängert.

Bild für Kopieren Code kopieren
TFSConfig License /extend
TFSConfig - Team Foundation Server-Konfigurationstool Copyright © Microsoft Corporation.Alle Rechte vorbehalten.Die Testversion von Team Foundation Server Standard-Lizenz wird jetzt erweitert - die folgenden Funktionen werden installiert: Team Foundation Server-Builddienst-Build 21106.00 - Produkt-ID: 01234-567-7654987 - Testlizenz mit 134 verbleibenden Tagen, läuft am 30.08.2010 ab - Test-ID: XYZZY-REDFG-WESDF

Im folgenden Beispiel wird gezeigt, wie die Testlizenz auf eine Lizenz für die Vollversion aktualisiert wird.

Bild für Kopieren Code kopieren
TFSConfig License /ProductKey:abcde-fghij-klmno-pqrst-uvwxy
TFSConfig - Team Foundation Server-Konfigurationstool Copyright © Microsoft Corporation.Alle Rechte vorbehalten.Product Key 'abcde-fghij-klmno-pqrst-uvwxy' wird nun angewendet - Team Foundation Server Standard-Lizenz - die folgenden Funktionen werden installiert: Team Foundation Server-Builddienst-Build: 21106.00 Produkt-ID: 01234-567-765456 Einzelhandelslizenz

Siehe auch

Aufgaben

Suchen oder Ändern des Product Key für Team Foundation Server

Konzepte

Verwalten von Team Foundation Server

Weitere Ressourcen

Upgrading Team Foundation Server


Proxybefehl (TFSConfig)

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Proxybefehl (TFSConfig)
Beispiel Siehe auch Feedback senden

Über den TFSConfig Proxy-Befehl können Einstellungen von Team Foundation Server-Proxy aktualisiert oder geändert werden. Team Foundation Server-Proxy unterstützt verteilte Teams bei der Versionskontrolle, indem ein Cache von heruntergeladenen Versionskontrolldateien am Speicherort des verteilten Teams verwaltet wird. Wenn Sie den Team Foundation Server-Proxy konfigurieren, können Sie die Bandbreite, die für WAN-Verbindungen erforderlich ist, deutlich reduzieren. Außerdem müssen Sie das Herunterladen und Zwischenspeichern von Versionsdateien nicht verwalten; die Verwaltung der Dateien ist für den Entwickler, der die Dateien verwendet, ersichtlich. In der Zwischenzeit werden der Metadatenaustausch und die Dateiuploads weiterhin in Team Foundation Server (TFS) angezeigt. Wenn Sie den Team Foundation-Dienst verwenden, um das Entwicklungsprojekt in der Cloud zu hosten, können Sie mit dem Proxybefehl nicht nur den Cache für Projekte in der gehosteten Auflistung, sondern auch einige der Einstellungen dieses Dienstes verwalten.

Weitere Informationen zum Installieren von Team Foundation Server-Proxy und zur Erstkonfiguration des Proxys finden Sie unter Gewusst wie: Zwischenspeichern von Versionskontrolldateien auf einer Remotesite. Weitere Informationen zum Konfigurieren des Proxys auf Clientcomputern finden Sie unter Befehlszeilenreferenz der Team Foundation-Versionskontrolle.

Anforderungen

Zum Verwenden des Proxy-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation Administrators und Adminstrator auf dem Proxyserver sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Verwenden von TFSConfig-Proxy

TFSConfig Proxy /add|delete|change [/Collection:TeamProjectCollectionURL /account:AccountName] /ServerURL:TeamFoundationServerURL [/Continue]
Argument | Beschreibung
TeamProjectCollectionURL | Wird mit /Collection verwendet. Gibt die URL der Teamprojektsammlung, die im Team Foundation-Dienst gehostet wird, im AccountName.DomainName/CollectionName-Format an.
AccountName | Wird mit /Collection verwendet. Gibt den Namen des Kontos an, das als Dienstkonto für den Team Foundation-Dienst verwendet wird. Enthält der Kontoname Leerzeichen, muss der Name in Anführungszeichen ("") eingeschlossen sein. Alle Sonderzeichen in Kontonamen müssen entsprechend der Befehlszeilensyntax angegeben werden.
ServerURL | Wird mit /ServerURL verwendet. Gibt die URL einer TFS-Bereitstellung im Format ServerURL:Port/tfs an.
Option | Beschreibung
/add | Fügt den angegebenen Server oder die angegebene Auflistung der Proxyliste in der Datei Proxy.config hinzu. Sie können /add mehrmals ausführen, um weitere Auflistungen oder Server einzuschließen. Wird /add mit einer Auflistung verwendet, die im Team Foundation-Dienst gehostet wird, werden Sie zur Eingabe der Anmeldeinformationen beim Team Foundation-Dienst aufgefordert.
/change | Ändert die Anmeldeinformationen, die als Dienstkonto für den Team Foundation-Dienst gespeichert sind. Die /change-Option wird nur für den Team Foundation-Dienst verwendet; und nicht für lokale Bereitstellungen von TFS.
/delete | Entfernt den angegebenen Server oder die angegebene Auflistung von der Proxyliste in der Datei Proxy.config.
/account | Gibt das Konto an, das als Dienstkonto für den Proxy im Team Foundation-Dienst verwendet wird. Diese Option wird nur für den Team Foundation-Dienst zusammen mit der /change-Option verwendet. Das Standarddienstkonto für den Team Foundation-Dienst ist "Kontodienst".
/continue | Setzt die Ausführung des Befehls fort, auch wenn bei der Überprüfung Warnungen ausgegeben werden.

Hinweise

Über den Proxy-Befehl können Sie die vorhandene Konfiguration von Team Foundation Server-Proxy aktualisieren. Sie können den Proxybefehl nicht zur Erstinstallation und -konfiguration des Proxys verwenden.

Beispiel

Das folgende Beispiel zeigt, wie eine TFS-Bereitstellung namens FABRIKAM zur Proxyliste hinzugefügt wird.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Proxy /add /ServerURL:http://www.fabrikam.com:8080/tfs

Im folgenden Beispiel wird gezeigt, wie eine im Team Foundation-Dienst gehostete Teamprojektsammlung der Proxyliste hinzugefügt wird. Die Auflistung heißt PhoneSaver, und der Kontoname für den Team Foundation-Dienst lautet JillFrank.fabrikam.com. Da die /account-Option nicht angegeben wird, wird das Standarddienstkonto verwendet.

Bild für Kopieren Code kopieren
TFSConfig Proxy /add /Collection:https://JillFrank.tfspreview.com/PhoneSaver

Im folgenden Beispiel wird gezeigt, wie das Dienstkonto geändert wird, das der Proxy für die Teamprojektsammlung verwendet, die im Team Foundation-Dienst gehostet wird. Die Auflistung heißt PhoneSaver, der Kontoname für den Team Foundation-Dienst lautet JillFrank.fabrikam.com, und das Dienstkonto für den Proxy wird in "Mein Proxydienstkonto" geändert. Da der Kontoname Leerzeichen enthält, werden Anführungszeichen verwendet, um den Namen einzuschließen.

Bild für Kopieren Code kopieren
TFSConfig Proxy /change /Collection:https://JillFrank.tfspreview.com/PhoneSaver /account:"My Proxy Service Account"

Siehe auch

Konzepte

Gewusst wie: Zwischenspeichern von Versionskontrolldateien auf einer Remotesite

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools


RebuildWarehouse-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

RebuildWarehouse-Befehl
Beispiel Siehe auch Feedback senden

Sie können mithilfe des RebuildWarehouse-Befehls die von Visual Studio Team Foundation Server (TFS) verwendeten SQL Server Reporting Services- und SQL Server Analysis Services-Datenbanken neu erstellen.

Um die Neuerstellung dieser Datenbanken interaktiv zu starten, können Sie den Knoten Berichterstellung in der Verwaltungskonsole für Team Foundation verwenden. Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

Erforderliche Berechtigungen

Zum Verwenden des RebuildWarehouse-Befehls müssen Sie Mitglied der folgenden Gruppen sein:

  • der Sicherheitsgruppe Team Foundation-Administratoren und der Administratoren-Sicherheitsgruppe auf dem Server oder den Servern, die die Verwaltungskonsole für Team Foundation ausführen

  • der Gruppe sysadmin auf den Servern, auf denen die Instanz von SQL Server ausgeführt wird, die die Datenbanken für TFS hostet

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig RebuildWarehouse /analysisServices | /all [/ReportingDataSourcePassword:Password]

Parameter

Platzhalter | Beschreibung
Password | Gibt das Kennwort an, das das Datenquellenkonto für SQL Server Reporting Services verwendet. Auf dieses Konto wird in der Dokumentation als TFSReports verwiesen.
Option | Beschreibung
/analysisServices | Erforderlich, wenn /all nicht verwendet wird. Gibt an, dass nur die Datenbank für Analysis Services neu erstellt wird. Wenn keine Datenbank für Analysis Services vorhanden ist, müssen Sie auch die /reportingDataSourcePassword-Option verwenden.
/all | Erforderlich, wenn /analysisServices nicht verwendet wird. Gibt an, dass alle Berichterstellungs- und Analysedatenbanken, die TFS verwendet, neu erstellt werden.
/reportingDataSourcePassword:Password | Erforderlich, wenn die Datenbank "TFS_Analysis" nicht vorhanden ist. Gibt das Kennwort des Kontos an, das als Datenquellenkonto für SQL Server Reporting Services (TFSReports) verwendet wird. Weitere Informationen finden Sie unter Dienstkonten und Abhängigkeiten in Team Foundation Server.

Hinweise

Sie verwenden diesen Befehl beispielsweise beim Verschieben oder Teilen einer Teamprojektauflistung, Wiederherstellen von Daten oder sonstigen Ändern der Konfiguration der Bereitstellung.

Beispiel

Im folgenden Beispiel wird gezeigt, wie die Analysis Services-Datenbank für eine Bereitstellung von TFS neu erstellt wird.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig RebuildWarehouse /analysisServices
TFSConfig - Team Foundation Server-Konfigurationstool Copyright © Microsoft Corporation.Alle Rechte vorbehalten.Die Analysis Services-Datenbank wurde neu erstellt.

Siehe auch

Aufgaben

Hinzufügen eines Berichtsservers zur Bereitstellung

Konzepte

Architektur von Team Foundation Server
SQL Server und SQL Server Reporting Services
Die Team Foundation-Verwaltungskonsole


Befehl "Recover"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Befehl "Recover"
Beispiel Siehe auch Feedback senden

Mit dem Recover-Befehl wird versucht, beschädigte oder verwaiste Teamprojektauflistungen und Teamprojekte zu reparieren und erneut anzufügen. Sie können diesen Befehl zum Beispiel verwenden, wenn Sicherungen nicht ordnungsgemäß synchronisiert werden und eine oder mehrere Auflistungen nicht erneut angefügt werden können, oder wenn eine Auflistung nicht ordnungsgemäß getrennt wurde. Dieser Befehl sollte nur verwendet werden, wenn ein Serverfehler oder ein Datenbanksynchronisierungsfehler zu einem Zustand geführt hat, in dem eine Auflistung oder ein Projekt nicht vollständig wiederhergestellt und aus den Sicherungen neu angefügt werden konnte.

Erforderliche Berechtigungen

Zum Verwenden des Recover-Befehls müssen Sie Mitglied der Gruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation und Mitglied der Gruppe sysadmin in SQL Server auf dem Datenebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSConfig Recover [/SQLInstances:ServerName1[,ServerName2,...]] [/ConfigurationDB:ServerName;DatabaseName /CollectionDB:ServerName;CollectionDatabaseName]

Parameter

Argument | Beschreibung
ServerName | Gibt den Namen des Servers an, der die Datenbanken für Visual Studio Team Foundation Server (TFS) hostet. Wenn Sie eine andere Instanz als die Standardinstanz verwenden, geben Sie sie im folgenden Format an: Servername\Instanzname
DatabaseName | Gibt den Namen der Konfigurationsdatenbank für TFS an. Standardmäßig ist der Name dieser Datenbank TFS_Configuration, aber dieser Datenbankname könnte angepasst worden sein.
CollectionDatabaseName | Gibt den Namen der Auflistungsdatenbank an, die Sie wiederherstellen oder erneut anfügen möchten. Wenn diese Datenbank auf einem separaten Server oder in einer separaten Instanz von SQL Server gehostet wird, müssen Sie den Servernamen und den Instanznamen angeben. Wenn der Name der Auflistung Leerzeichen enthält, müssen Sie den Namen in Anführungszeichen (z. B. "Meine Auflistung") einschließen.

Option

Beschreibung

/SQLInstances:ServerName1,ServerName2,...

Sie können diese Option nicht zusammen mit anderen Optionen verwenden. Gibt den Namen des Servers an, auf dem SQL Server ausgeführt wird. Wenn Sie eine andere Instanz als die Standardinstanz verwenden, geben Sie sie im folgenden Format an:

Servername\Instanzname

Wenn die Bereitstellung mehr als einen Server verwendet, der SQL Server ausführt, müssen Sie alle Server und Instanzen, durch Kommas getrennt, im folgenden Format angeben:

Servername1\Instanzname1,Servername2\Instanzname2

/ConfigurationDB:ServerName:DatabaseName

Sie müssen diese Option in Verbindung mit /CollectionDB verwenden. Sie können diese Option nicht in Verbindung mit /SQLInstances verwenden. Gibt den Namen des Servers an, der die Konfigurationsdatenbank für TFS hostet, und den Namen der Konfigurationsdatenbank für TFS. Wenn Sie die Konfigurationsdatenbank für eine Instanz von SQL Server, die nicht die Standardinstanz ist, hosten, geben Sie den Namen und die Instanz im folgenden Format an:

Servername\Instanzname

/CollectionDB:Servername;Auflistungsdatenbankname

Sie müssen diese Option in Verbindung mit /ConfigurationDB verwenden. Sie können diese Option nicht in Verbindung mit /SQLInstances verwenden. Gibt den Namen des Servers an, der SQL Server ausführt, und den Namen der Auflistungsdatenbank, die auf diesem Server gehostet wird. Wenn Sie die Auflistungsdatenbank für eine Instanz von SQL Server, die nicht die Standardinstanz ist, hosten, geben Sie den Namen und die Instanz im folgenden Format an:

Servername\Instanzname

Hinweise

Der Recover-Befehl ist nicht umkehrbar und sollte nur dann verwendet werden, wenn alle herkömmlichen Versuche, die Datenbanken für eine Bereitstellung wiederherzustellen, gescheitert sind. Der Recover-Befehl überprüft alle in den Optionen angegebenen SQL Server-Instanzen auf eine Konfigurationsdatenbank. Alle Auflistungsdatenbanken, die der Befehl während der Überprüfung findet, werden an die Konfigurationsdatenbank angefügt, die der Befehl in der Überprüfung findet. Der Recover-Befehl gibt einen Fehler zurück, wenn während der Überprüfung mehrere Konfigurationsdatenbanken oder mehr als eine Auflistungsdatenbank mit dem gleichen Namen gefunden werden. In einer Bereitstellung von TFS darf nur eine Konfigurationsdatenbank vorhanden sein, und alle Auflistungen müssen innerhalb dieser Bereitstellung über eindeutige Namen verfügen.

Warnhinweis Vorsicht

Der Recover-Befehl bindet jede gefundene Auflistungsdatenbank an die gefundene Konfigurationsdatenbank, unabhängig von, ob die betreffende Auflistungsdatenbank bereits von einer anderen Konfigurationsdatenbank verwendet wird. Diese Aktion kann dazu führen, dass eine Auflistung, die in einer anderen Bereitstellung von TFS fehlerfrei war, nun nicht mehr funktioniert.

Beispiel

Im folgenden Beispiel wird gezeigt, wie die Auflistungsdatenbank "Experimental Projects" in der Contoso1-Bereitstellung von Team Foundation Server wiederhergestellt wird. In diesem Beispiel wird die Konfigurationsdatenbank (ContosoSQLServer1\Team2) auf einer separaten Instanz von SQL Server, getrennt von der Auflistungsdatenbank (ContosoSQLServer2\Projects), gehostet.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Recover /ConfigurationDB:ContosoSQLServer1\Team2;TFS_ConfigurationDB /CollectionDB:ContosoSQLServer2\Projects;"Experimental Projects"

Im folgenden Beispiel wird gezeigt, wie eine Bereitstellung von Team Foundation Server repariert wird, die die folgenden Instanzen von SQL Server auf zwei Servern verwendet: die Instanz "Team2" auf ContosoSQLServer1 und die Standardinstanz auf dem Server ContosoSQLServer2.

Bild für Kopieren Code kopieren
TFSConfig Recover /SQLInstances:ContosoSQLServer1\Team2,ContosoSQLServer2

Siehe auch

Konzepte

Organisieren des Servers mit Teamprojektsammlungen
Sichern und Wiederherstellen der Bereitstellung


RegisterDB-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

RegisterDB-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie RegisterDB, um den Namen des Servers zu aktualisieren, der die Konfigurationsdatenbank in Visual Studio Team Foundation Server (TFS) hostet. Sie können diesen Befehl beim Wiederherstellen der Konfigurationsdatenbank auf neuer Hardware oder beim Ändern der Domäne einer Bereitstellung verwenden.

Wichtiger Hinweis Wichtig

Damit der RegisterDB-Befehl erfolgreich ausgeführt werden kann, müssen die folgenden Anwendungspools und Programme ausgeführt werden:

  • Team Foundation Server-Anwendungspool (Anwendungspool)

  • ReportServer (Anwendungspool)

  • SQL Server Reporting Services (Programm)

Außerdem dürfen die folgenden Komponenten nicht geöffnet sein oder ausgeführt werden:

Erforderliche Berechtigungen

Zum Verwenden des RegisterDB-Befehls müssen Sie Mitglied der Gruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation und Mitglied der Gruppe sysadmin in SQL Server auf dem Datenebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSConfig RegisterDB /SQLInstance:ServerName

Parameter

Platzhalter | Beschreibung
ServerName | Gibt den Namen des Servers an, der die Konfigurationsdatenbank für TFS hostet, und den Namen der Instanz, wenn Sie eine von der Standardinstanz abweichende Instanz verwenden. Wenn Sie eine Instanz angeben, muss das folgende Format verwendet werden: Servername\Instanzname
Argument | Beschreibung
/SQLInstance:ServerName | Erforderlich. Gibt den Namen des Servers an, auf dem SQL Server ausgeführt wird, sowie den Namen der Instanz, wenn Sie nicht die Standardinstanz verwenden möchten. Wenn Sie eine Instanz angeben, muss das folgende Format verwendet werden: Servername\Instanzname

Hinweise

Wichtiger Hinweis Wichtig

Sichern Sie die Datenbanken für TFS, bevor Sie diesen Befehl verwenden.

Sie müssen den genauen Namen oder die Adresse der Konfigurationsdatenbank angeben, damit dieser Befehl ordnungsgemäß funktioniert. Wenn Sie den Server ändern müssen, auf dem diese Datenbank gespeichert wird, müssen Sie sicherstellen, dass TFS auf den neuen Speicherort verweist.

Beispiel

Im folgenden Beispiel wird TFS an eine Konfigurationsdatenbank umgeleitet, die sich auf dem Server ContosoMain in der SQL Server-Instanz TeamDatabases befindet.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig RegisterDB /SQLInstance:ContosoMain\TeamDatabases

Siehe auch

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig
Verwenden von Team Foundation Server-Befehlszeilentools
Team Foundation Server-Dienste und -Dienstkonten


RemapDBs-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

RemapDBs-Befehl
Beispiel Siehe auch Feedback senden

Sie können mithilfe des RemapDBs-Befehls Visual Studio Team Foundation Server (TFS) zu den zugehörigen Datenbanken umleiten, wenn diese auf mehreren Servern gespeichert sind und Sie die Konfiguration der Bereitstellung wiederherstellen, verschieben oder anderweitig ändern. Sie müssen z. B. TFS an alle Datenbanken für Teamprojektauflistungen umleiten, wenn diese auf einem separaten Server oder Servern von der Konfigurationsdatenbank gehostet werden. Sie müssen zudem TFS an die Server umleiten, die SQL Server Analysis Services oder SQL Server Reporting Services ausführen, wenn diese Datenbanken auf einem anderen Server oder in einer anderen Instanz als die Konfigurationsdatenbank gehostet werden.

Erforderliche Berechtigungen

Zum Verwenden des RemapDBs-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren und der Sicherheitsgruppe sysadmin für alle SQL Server-Datenbanken sein, die von Team Foundation Server verwendet werden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig RemapDBs /DatabaseName:ServerName;DatabaseName /SQLInstances:ServerName1,ServerName2 [/AnalysisInstance:ServerName] [/AnalysisDatabaseName:DatabaseName] [/preview] [/continue]

Parameter

Argument | Beschreibung
ServerName | Gibt den Namen des Servers an, den Sie als Server zuordnen möchten, der mindestens eine Datenbank für TFS hostet. Wenn eine andere als die Standardinstanz eine Datenbank hostet, müssen Sie auch den Namen der Instanz im folgenden Format angeben: Servername\Instanzname
DatabaseName | Gibt den Namen der Datenbank an, die Sie TFS zuordnen.

Option

Beschreibung

/DatabaseName

Gibt zusätzlich zum Namen der Datenbank den Namen des Servers an, der die Datenbank hostet, die Sie für TFS zuordnen möchten.

/SQLInstances:ServerName1,ServerName2

Gibt den Namen des Servers an, auf dem SQL Server ausgeführt wird, sowie den Namen der Instanz, wenn Sie nicht die Standardinstanz verwenden möchten.

Wenn Sie mehr als einen Server angeben, müssen mehrere Paare von Server- und Instanznamen durch ein Komma getrennt werden.

/AnalysisInstance:ServerName

Dies ist optional. Gibt den Namen des Servers und der Instanz an, die SQL Server Analysis Services hostet. Verwenden Sie diese Option, um den Server und die Instanz anzugeben, die die Analysis Services-Datenbank hostet.

/AnalysisDatabaseName:DatabaseName

Dies ist optional. Gibt den Namen der Analysis Services-Datenbank an, die Sie mit TFS verwenden möchten, wenn mehr als eine Datenbank auf dem Server vorhanden ist, den Sie mit der /AnalysisInstance-Option angegeben haben.

/preview

Dies ist optional. Zeigt die Aktionen an, die Sie ausführen müssen, um die Konfiguration zu aktualisieren.

/continue

Dies ist optional. Gibt an, dass der Befehl RemapDB fortgesetzt werden soll, auch wenn bei dem Versuch, eine oder mehrere Datenbanken zu finden, ein Fehler auftritt. Wenn Sie die /continue-Option verwenden, werden alle Auflistungen, deren Datenbanken nicht auf den von Ihnen angegebenen Servern gefunden werden, so neu konfiguriert, dass der Server und die Instanz verwendet werden, die die Konfigurationsdatenbank hosten.

Hinweise

Mit dem RemapDBs-Befehl konfigurieren Sie TFS neu, um andere Server und Instanzen von SQL Server als die Server und Instanzen der ursprünglichen Installation zu verwenden.

Beispiel

Im folgenden Beispiel wird gezeigt, wie TFS an seine Konfigurationsdatenbank "TFS_Configuration" umgeleitet wird. Diese Datenbank wird auf ContosoMain in der benannten Instanz "Teamdatenbanken"gehostet. Die Projektauflistungsdatenbanken werden in ContosoMain\Teamdatenbanken und in der Standardinstanz von Contoso2 gespeichert.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig RemapDBs /DatabaseName:ContosoMain\TeamDatabases;TFS_Configuration /SQLInstances:ContosoMain\TeamDatabases,Contoso2

Siehe auch

Weitere Ressourcen

Verwalten der Serverkonfiguration mit TFSConfig


Repair-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Repair-Befehl
Beispiel Siehe auch Feedback senden

Mit dem TFSConfig Repair-Befehl wird versucht, Verbindungen oder Probleme mit den Datenbanken in der Bereitstellung zu reparieren. Wenn Sie den Befehl "Reparieren" verwenden, werden alle Dienste beendet, Team Foundation Server (TFS) wird offline geschaltet, und eine Reparaturoperation wird für die Konfigurationsdatenbank ausgeführt. Nachdem diese Operation abgeschlossen wurde, werden Reparaturoperationen für die Auflistungsdatenbanken in die Warteschlange gestellt, und TFS kehrt in einen Onlinezustand zurück.

Erforderliche Berechtigungen

Um den Repair-Befehl verwenden zu können, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation sein. Sie müssen zudem Mitglied der Sicherheitsgruppe sysadmin auf allen Servern und in allen Instanzen von SQL Server sein, die eine Datenbank für Team Foundation hosten. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig Repair

Hinweise

Der Repair-Befehl schaltet die Bereitstellung von TFS offline, während die Reparaturoperation ausgeführt wird. Während dieser Befehl ausgeführt wird, sind keine Benutzer in der Lage, eine Verbindung mit der Bereitstellung herzustellen.

Beispiel

Im folgenden Beispiel wird gezeigt, wie versucht wird, die Datenbanken für eine Bereitstellung von Team Foundation Server zu reparieren.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Repair
TFSConfig - Team Foundation Server-Konfigurationstool Copyright © Microsoft Corporation.Alle Rechte vorbehalten.Das Abrufen der WartungssperreWartungssperre wurde abgerufen.Anwendung wird beendet...Anwendung wurde erfolgreich gestoppt.Anwendung wird gestartet...Anwendung wurde erfolgreich gestartet.

Siehe auch

Konzepte

Architektur von Team Foundation Server
Sichern und Wiederherstellen der Bereitstellung
Die Team Foundation-Verwaltungskonsole


Settings-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Settings-Befehl
Beispiel Siehe auch Feedback senden

Sie können mithilfe des Settings-Befehls Änderungen der URL (Uniform Resource Locator) automatisieren, die von der Benachrichtigungsschnittstelle und für die Serveradresse von Visual Studio Team Foundation Server (TFS) verwendet wird. Standardmäßig stimmen die URL der Benachrichtigungsschnittstelle und die Server-URL in TFS überein. Sie können jedoch separate URLs konfigurieren. Sie möchten z. B. eine andere URL für die automatischen E-Mails verwenden, die TFS generiert. Dieses Tool muss auf der Anwendungsebene ausgeführt werden, um alle Server zu so aktualisieren, dass sie die neuen URLs verwenden.

Um diese URLs interaktiv zu ändern oder um nur die aktuellen Einstellungen anzuzeigen, können Sie die Verwaltungskonsole für Team Foundation verwenden. Weitere Informationen finden Sie unter Öffnen der Team Foundation-Verwaltungskonsole.

Erforderliche Berechtigungen

Um den Settings-Befehl verwenden zu können, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren und der Gruppe Administratoren auf dem Anwendungsebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSConfig Settings [/ServerURL:URL] [/NotificationURL:URL]

Parameter

Platzhalter | Beschreibung
URL | Dient zum Festlegen des Uniform Resource Locator (URL) mit der entsprechenden Option.
Option | Beschreibung
/ServerURL:URL | Gibt die URL des Anwendungsebenenservers für Team Foundation an. Dieser Wert wird in der Konfigurationsdatenbank für Team Foundation gespeichert.
/NotificationURL:URL | Gibt die URL an, die im Text von E-Mail-Warnungen verwendet werden soll, wenn sich diese URL von der URL des Anwendungsebenenservers für Team Foundation unterscheidet. Dieser Wert wird in der Konfigurationsdatenbank gespeichert.

Hinweise

Der Settings-Befehl ändert Verbindungsinformationen für Server-zu-Server-Kommunikation in einer Bereitstellung von TFS. Die URL, die in /ServerURL angegeben wird, muss für alle Server innerhalb der Bereitstellung zur Verfügung stehen.

Beispiel

Im folgenden Beispiel wird der Wert von NotificationURL in http://contoso.example.com/tfs und der Wert von ServerURL in http://contoso.example.com:8080/tfs umgewandelt:

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
TFSConfig Settings /NotificationURL:http://contoso.example.com/tfs /ServerURL:http://contoso.example.com:8080/tfs

Siehe auch

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools
Team Foundation Server-Dienste und -Dienstkonten


Befehl "Updates"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Befehl "Updates"
Beispiel Siehe auch Feedback senden

Sie können mithilfe des Updates-Befehls alle Softwareupdates installieren, die noch nicht auf die Datenbanken für Visual Studio Team Foundation Server (TFS) angewendet wurden. In den meisten Fällen treten keine Softwareupdatekonflikte auf, da Updates normalerweise für die ganze Bereitstellung übernommen werden. Für einen ordnungsgemäßen Betrieb müssen dieselben Softwareupdates auf die Anwendungsebene und die Datenbanken angewendet werden. Wenn ein Softwareupdatekonflikt auftritt, bei dem in den Datenbanken ein oder mehrere Updates fehlen, die für die Anwendungsebene übernommen wurden, können Sie versuchen, die fehlenden Updates für die Datenbanken automatisch mithilfe des Updates-Befehls zu übernehmen.

Hinweis Hinweis

Der Updates-Befehl wendet die Updates nur auf die Datenbanken an. Wenn ein Softwareupdatekonflikt auftritt, bei dem die Datenbanken ein Softwareupdate haben, das nicht für die Anwendungsebene übernommen wurde, müssen Sie dieses Update für die Anwendungsebene manuell übernehmen. Weitere Informationen darüber, wie Sie feststellen, ob ein Softwareupdatekonflikt aufgetreten sein könnte, finden Sie unter Diagnosebefehl.

Erforderliche Berechtigungen

Zum Verwenden des Updates-Befehls müssen Sie Mitglied der Gruppe Team Foundation-Administratoren auf dem Anwendungsebenenserver für Team Foundation und Mitglied der Gruppe sysadmin in SQL Server auf dem Datenebenenserver für Team Foundation sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSConfig Updates /reapply

Parameter

Option | Beschreibung
/reapply | Gibt an, dass alle Softwareupdates, die auf die Anwendungsebene für Team Foundation angewendet wurden, auch auf die Datenbanken für TFS angewendet werden, sofern noch nicht geschehen.

Hinweise

Mit dem Updates-Befehl wird versucht, alle Softwareupdates, die auf die Anwendungsebene angewendet wurden, automatisch auch auf die TFS-Datenbanken anzuwenden. Wenn Sie diesen Befehl ausführen, informieren Meldungen über den Status der Updateversuche. Update-Aufträge werden für alle Datenbanken, bei denen die Updates fehlen, der Warteschlange hinzugefügt. Dies kann die Konfigurationsdatenbank, die Warehouse-Datenbank und alle Datenbanken für Teamprojektauflistungen umfassen. Wenn ein oder mehrere Aufträge nicht abgeschlossen werden können, geben Fehlermeldungen an, welche Datenbanken nicht aktualisiert werden konnten, und stellen, sofern verfügbar, weitere Informationen bereit.

Beispiel

Im folgenden Beispiel wird gezeigt, wie der Updates-Befehl ausgeführt wird, um alle Softwareupdates auf die Datenbanken für Team Foundation Server anzuwenden, die bereits auf die Anwendungsebene angewendet wurden.

Bild für Kopieren Code kopieren
TFSConfig Updates /reapply

Siehe auch

Referenz

Diagnosebefehl

Konzepte

Architektur von Team Foundation Server

Weitere Ressourcen

Upgrading Team Foundation Server


Konfigurieren von Lab-Management mit TFSLabConfig

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Konfigurieren von Lab-Management mit TFSLabConfig
Siehe auch Feedback senden

Team Foundation Server enthält ein Befehlszeilentool, mit dem Sie beim Konfigurieren und Verwalten des von Visual Studio Lab Management bereitgestellten Lab-Diensts unterstützt werden.

Das Befehlszeilentool von TFSLabConfig befindet sich im Verzeichnis Laufwerk:\Programme\Microsoft Team Foundation Server 2010\Tools auf der Team Foundation Server-Anwendungsebene. Zudem ist es im Verzeichnis Laufwerk: \Programme\Microsoft Visual Studio 10.0\Common7\IDE auf dem Clientcomputer verfügbar, auf dem Microsoft Test Manager installiert ist.

Erforderliche Berechtigungen

Um TFSLabConfig verwenden zu können, müssen Sie über die entsprechenden Berechtigungen für den gewünschten Vorgang verfügen. Die erforderlichen Berechtigungen für jeden Befehl werden im Befehlsreferenzthema beschrieben.

Befehle

Dieses Tool stellt Befehle für die folgenden Aufgaben bereit.

Aufgabe

  • Befehl

Verwalten von Hostgruppen in einem Teamprojekt. Hinzufügen einer Hostgruppe zu einem bestimmten Teamprojekt oder Entfernen einer Hostgruppe.

  • TFSLabConfig CreateTeamProjectHostGroup-Befehl

  • TFSLabConfig DeleteTeamProjectHostGroup-Befehl

  • TFSLabConfig ListTeamProjectHostGroups-Befehl

  • TFSLabConfig ListTeamProjectCollectionHostGroups-Befehl

  • TFSLabConfig TPCHostGroup-Befehl

  • TFSLabConfig-TPCLibraryShare-Befehl

Verwalten von Bibliotheksfreigaben in einem Teamprojekt. Hinzufügen einer Bibliotheksfreigabe zu einem bestimmten Teamprojekt in der Auflistung oder Entfernen einer Bibliotheksfreigabe.

  • TFSLabConfig CreateTeamProjectLibraryShare-Befehl

  • TFSLabConfig DeleteTeamProjectLibraryShare-Befehl

  • TFSLabConfig ListTeamProjectLibraryShares-Befehl

  • TFSLabConfig ListTeamProjectCollectionLibraryShares-Befehl

  • TFSLabConfig-TPCLibraryShare-Befehl

Verwalten von Benutzerberechtigungen für angegebene Lab-Management-Objekte. Hinzufügen von Berechtigungen für Benutzer oder Benutzergruppen zu einem Objekt in einem Teamprojekt oder einer Teamprojektsammlung oder Entfernen von Berechtigungen.

  • TFSLabConfig Permissions-Befehl

Verwalten des Dienstkontos einer Teamprojektsammlung. Hinzufügen der Benutzerkontoanmeldeinformationen, die von Test-Agents und Build-Agents für die Kommunikation mit Test- und Buildcontrollern verwendet werden, oder Entfernen der Benutzerkontoanmeldeinformationen.

  • TFSLabConfig SetServiceAccount-Befehl

  • TFSLabConfig GetServiceAccount-Befehl

  • TFSLabConfig ClearServiceAccount-Befehl

  • TFSLabConfig UpdateServiceAccountOnDeployedEnvironments-Befehl

Siehe auch

Konzepte

Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
Konfigurieren und Verwalten von Lab-Management
TFSConfig Lab-Befehle

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools


TFSLabConfig CreateTeamProjectHostGroup-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig CreateTeamProjectHostGroup-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie den CreateTeamProjectHostGroup-Befehl, um eine Hostgruppe aus einer Teamprojektauflistung einem einzelnen Teamprojekt in der Auflistung zuzuweisen. Hostgruppen geben einen oder mehrere physische Computer an, bei denen es sich um die Bereitstellungsziele für virtuelle Umgebungen in Visual Studio Lab Management handelt. Hostgruppen werden in System Center Virtual Machine Manager (SCVMM) erstellt und von Visual Studio Lab Management einer Projektsammlung zugewiesen. Verwenden Sie separate CreateTeamProjectHostGroup-Befehle, um einem Teamprojekt mehrere Hostgruppen zuzuweisen.

Hinweis Hinweis

Sie können automatisch eine Hostgruppe allen Projekten in einer Teamprojektsammlung zuweisen, wenn Sie die Hostgruppe der Teamprojektsammlung zuweisen. Weitere Informationen finden Sie unter TFSConfig Lab /HostGroup-Befehle und Gewusst wie: Ändern der Hostgruppen für die Teamprojektsammlungen.

Erforderliche Berechtigungen

Zum Verwenden des CreateTeamProjectHostGroup-Befehls müssen Sie die Manage Lab Locations-Berechtigung auf der Teamprojektauflistung-Hostgruppenebene besitzen. Standardmäßig verfügen die Team Foundation Server-Administratoren und Mitglieder der Projektauflistungsadministratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig CreateTeamProjectHostGroup
      /Collection:collectionUrl
      /TeamProject:{* |teamProjectName}
      /TeamProjectCollectionHostGroup:(* |teamProjectCollectionHostGroupName}
      /Name:teamProjectHostGroupName
      [/Description:teamProjectHostGroupDescription]
      [/NoPrompt]

Parameter

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server, worin die Teamprojektauflistung enthalten ist. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.
TeamProject:{* |teamProjectName>} | Erforderlich. Den Namen des Teamprojekts. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält. Verwenden Sie ein Sternchen (*), um die angegebene Hostgruppe allen Teamprojekten in der Auflistung zuzuweisen.
TeamProjectCollectionHostGroup:{* |teamProjectCollectionHostGroupName} | Erforderlich. Der Name der Hostgruppe in der Teamprojektauflistung. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält. Verwenden Sie ein Sternchen (*), um alle Hostgruppen der Auflistung dem angegebenen Teamprojekt zuzuweisen. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält.
Name:teamProjectHostGroupName | Erforderlich. Der Name, der der Hostgruppe im Teamprojekt zugewiesen wird.
Description:teamProjectHostGroupDescription | Dies ist optional. Eine Beschreibung des Teamprojekts der Hostgruppe
NoPrompt | Dies ist optional. Der Benutzer wird nicht zur Bestätigung aufgefordert.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Im ersten Beispiel werden alle Hostgruppen in der Teamprojektauflistung jedem Teamprojekt in der Auflistung zugewiesen. Im zweiten Beispiel wird eine Hostgruppe in der Teamprojektauflistung einem bestimmten Teamprojekt zugewiesen.

Bild für Kopieren Code kopieren
REM First example
TFSLabConfig CreateTeamProjectHostGroup
             /collection:http://abc:8080/TFS/Collection0
             /teamProject:*
             /teamProjectCollectionHostGroup:*
REM Second example
TFSLabConfig CreateTeamProjectHostGroup
             /collection:http://abc:8080/TFS/Collection0
             /teamProject:Project1
             /teamProjectCollectionHostGroup:tpchg1
             /name:hg1

Siehe auch

Referenz

TFSLabConfig ListTeamProjectCollectionHostGroups-Befehl
TFSLabConfig ListTeamProjectHostGroups-Befehl
TFSLabConfig DeleteTeamProjectHostGroup-Befehl

Konzepte

TFSLabConfig-Befehlsreferenz
Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig CreateTeamProjectLibraryShare-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig CreateTeamProjectLibraryShare-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie den CreateTeamProjectLibraryShare-Befehl, um eine Bibliotheksfreigabe aus einer Teamprojektauflistung einem einzelnen Teamprojekt in der Auflistung zuzuweisen. Eine Bibliotheksfreigabe ermöglicht den Zugriff auf dateibasierte Ressourcen für virtuelle Umgebungen, z. B. ISO-Images und virtuelle Festplatten. Bibliotheksfreigaben werden im System Center Virtual Machine Manager (SCVMM) erstellt und von Visual Studio Lab Management einer Projektauflistung zugewiesen. Verwenden Sie separate CreateTeamProjectLibraryShare-Befehle, um einem Teamprojekt mehrere Bibliotheksfreigaben zuzuweisen.

Hinweis Hinweis

Sie können automatisch allen Projekten in einer Teamprojektsammlung eine Bibliotheksfreigabe zuweisen. Informationen dazu finden Sie unter TFSConfig Lab /LibraryShare-Befehle und Gewusst wie: Ändern der Bibliotheksfreigabe für die Teamprojektsammlungen.

Erforderliche Berechtigungen

Zum Verwenden des CreateTeamProjectLibraryShare-Befehls müssen Sie die Manage Lab Locations-Berechtigung auf der Teamprojektauflistung-Bibliotheksfreigabenebene besitzen. Standardmäßig verfügen Team Foundation Server-Administratoren und Mitglieder der Projektauflistungsadministratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig CreateTeamProjectLibraryShare
Collection:collectionUrl
      /TeamProject:{* |teamProjectName}
      /TeamProjectCollectionLibraryShare:{* |teamProjectCollectionLibraryShareName}
      /Name:teamProjectLibraryShareName
       [/Description:teamProjectLibraryShareDescription]
       [/NoPrompt]

Parameter

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server, worin die Teamprojektauflistung enthalten ist. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.
TeamProject:{* |teamProjectName} | Erforderlich. Den Namen des Teamprojekts. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält. Verwenden Sie ein Sternchen (*), um alle Bibliotheksfreigaben in der Auflistung dem angegebenen Teamprojekt zuzuweisen.
TeamProjectCollectionLibraryShare:{* |teamProjectCollectionLibraryShareName} | Erforderlich. Der Name der Bibliotheksfreigabe in der Teamprojektauflistung. Verwenden Sie ein Sternchen (*), um eine Teamprojekt-Bibliotheksfreigabe für alle Bibliotheksfreigaben in der Teamprojektauflistung zu erstellen.
Name:teamProjectLibraryShareName | Erforderlich. Der Name, der der Bibliotheksfreigabe im Teamprojekt zugewiesen wird.
Description: teamProjectLibraryShareDescription | Dies ist optional. Eine Beschreibung der Teamprojekt-Bibliotheksfreigabe
NoPrompt | Dies ist optional. Der Benutzer wird nicht zur Bestätigung aufgefordert.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Im ersten Beispiel werden alle Bibliotheksfreigaben in der Teamprojektauflistung den Teamprojekten in der Auflistung zugewiesen. Im zweiten Beispiel wird eine Bibliotheksfreigabe in der Teamprojektauflistung einem bestimmten Teamprojekt zugewiesen.

Bild für Kopieren Code kopieren
REM First example
TFSLabConfig CreateTeamProjectLibraryShare
    /collection:http://abc:8080/TFS/Collection0
    /TeamProject:*
    /TeamProjectCollectionLibraryShare:*

REM Second example
TFSLabConfig CreateTeamProjectLibraryShare

    /collection:http://abc:8080/TFS/Collection0
    /TeamProject:Project1
    /TeamProjectCollectionLibraryShare:tpcls1
    /name:ls1

Siehe auch

Referenz

TFSLabConfig ListTeamProjectCollectionLibraryShares-Befehl
TFSLabConfig ListTeamProjectLibraryShares-Befehl
TFSLabConfig DeleteTeamProjectLibraryShare-Befehl

Konzepte

TFSConfig-Lab-Befehlsreferenz
Konfigurieren des Servers mit der Team Foundation-Verwaltungskonsole
TFSLabConfig-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig DeleteTeamProjectHostGroup-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig DeleteTeamProjectHostGroup-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie den DeleteTeamProjectHostGroup-Befehl, um die Zuweisung einer Hostgruppe aus einem einzelnen Teamprojekt zu entfernen. Hostgruppen geben einen oder mehrere physische Computer an, bei denen es sich um die Bereitstellungsziele für virtuelle Umgebungen in Visual Studio Lab Management handelt.

Hostgruppen werden in System Center Virtual Machine Manager (SCVMM) erstellt. In Lab Management werden Hostgruppen einer oder mehreren Teamprojektauflistungen und dann einem oder mehreren Teamprojekten in den Auflistungen zugewiesen. Der DeleteTeamProjectHostGroup-Befehl entfernt nicht die Zuweisung der Hostgruppe zur Teamprojektauflistung.

Erforderliche Berechtigungen

Zum Verwenden des DeleteTeamProjectHostGroup-Befehls müssen Sie die Berechtigung Lab-Speicherorte löschen für die Teamprojekt-Hostgruppe besitzen. Standardmäßig verfügen die Team Foundation Server-Administratoren, Teamprojektsammlungsadministratoren und Teamprojektadministratoren über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig DeleteTeamProjectHostGroup
      /Collection:collectionUrl
      /TeamProject:{* |teamProjectName>}
      /Name:{* |teamProjectHostGroupName}
      [/NoPrompt]

Parameter

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server, worin die Teamprojektauflistung enthalten ist. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.
TeamProject:{* |teamProjectName} | Erforderlich. Der Name des Teamprojekts, aus dem die Hostgruppe entfernt werden soll. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält. Verwenden Sie ein Sternchen (*), um alle Teamprojekte der Teamprojektauflistung anzugeben.
Name:{* |teamProjectHostGroupName} | Erforderlich. Der Name der Hostgruppe, der aus einem Teamprojekt gelöscht werden soll. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält. Verwenden Sie ein Sternchen (*), um alle Hostgruppen des Teamprojekts anzugeben.
NoPrompt | Dies ist optional. Der Benutzer wird nicht zur Bestätigung aufgefordert.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Im ersten Beispiel werden alle den einzelnen Teamprojekten in der Teamprojektsammlung zugewiesenen Hostgruppen entfernt. Im zweiten Beispiel wird eine Hostgruppe aus einem bestimmten Teamprojekt entfernt.

Bild für Kopieren Code kopieren
REM First example
TFSLabConfig DeleteTeamProjectLibraryShare
    /collection:http://abc:8080/TFS/DefaultCollection
    /teamProject:*
    /name:*

REM Second example
TFSLabConfig DeleteTeamProjectLibraryShare
    /collection:http://abc:8080/TFS/DefaultCollection
    /teamProject:Project1
    /name:hg1

Siehe auch

Referenz

TFSLabConfig ListTeamProjectCollectionHostGroups-Befehl
TFSLabConfig ListTeamProjectHostGroups-Befehl
TFSLabConfig CreateTeamProjectHostGroup-Befehl

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig DeleteTeamProjectLibraryShare-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig DeleteTeamProjectLibraryShare-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie den DeleteTeamProjectLibraryShare-Befehl, um die Zuweisung einer Bibliotheksfreigabe zu einem einzelnen Teamprojekt zu entfernen. Eine Bibliotheksfreigabe ermöglicht den Zugriff auf dateibasierte Ressourcen für virtuelle Umgebungen, z. B. ISO-Images und virtuelle Festplatten. Bibliotheksfreigaben werden vom SCVMM (System Center Virtual Machine Manager) erstellt. In Visual Studio Lab Management werden Bibliotheksfreigaben einer oder mehreren Teamprojektauflistungen und dann einem oder mehreren Teamprojekten in den Auflistungen zugewiesen. Der DeleteTeamProjectLibraryShare-Befehl entfernt nicht die Zuweisung der Bibliotheksfreigabe zur Teamprojektauflistung.

Erforderliche Berechtigungen

Zum Verwenden des DeleteTeamProjectLibraryShare-Befehls müssen Sie die Delete Lab Locations-Berechtigung für die Teamprojekt-Bibliotheksfreigabe besitzen. Standardmäßig verfügen die Mitglieder der Gruppen Team Foundation Server-Administratoren, Projektsammlungsadministratoren und Teamprojektadministratoren über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig DeleteTeamProjectLibraryShare
Collection:collectionUrl
      /TeamProject:{* |teamProjectName}
      /Name:{* |teamProjectLibraryShareName}
      [/NoPrompt]

Parameter

Argument | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung, die das Teamprojekt enthält. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.
TeamProject:{* |teamProjectName} | Erforderlich. Der Namen des Teamprojekts, das die zu löschende Bibliotheksfreigabe enthält. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält. Verwenden Sie ein Sternchen (*), um alle Teamprojekte der Teamprojektauflistung anzugeben.
Name:(* |teamProjectLibraryShareName) | Erforderlich. Der Name der aus einem Teamprojekt zu löschenden Bibliotheksfreigabe. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält. Verwenden Sie ein Sternchen (*), um alle Bibliotheksfreigaben des Teamprojekts anzugeben.
NoPrompt | Dies ist optional. Der Benutzer wird nicht zur Bestätigung aufgefordert.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Im ersten Beispiel werden alle den einzelnen Teamprojekten in der Teamprojektauflistung zugewiesenen Bibliotheksfreigaben entfernt. Im zweiten Beispiel wird eine Bibliotheksfreigabe aus einem bestimmten Teamprojekt entfernt.

Bild für Kopieren Code kopieren
REM First example
TFSLabConfig DeleteTeamProjectLibraryShare
    /collection:http://abc:8080/TFS/DefaultCollection
    /teamProject:*
    /name:*

REM Second example
TFSLabConfig DeleteTeamProjectLibraryShare
    /collection:http://abc:8080/TFS/DefaultCollection
    /teamProject:Project1
    /name:ls1

Siehe auch

Referenz

TFSLabConfig ListTeamProjectCollectionLibraryShares-Befehl
TFSLabConfig ListTeamProjectLibraryShares-Befehl
TFSLabConfig CreateTeamProjectLibraryShare-Befehl

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig ListTeamProjectCollectionHostGroups-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig ListTeamProjectCollectionHostGroups-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie den ListTeamProjectCollectionHostGroups-Befehl, um die Hostgruppen von System Center Virtual Machine Manager (SCVMM) aufzulisten, die einer Teamprojektauflistung zugewiesen sind und für die Sie Leseberechtigungen besitzen. Einem Teamprojekt können mit dem CreateTeamProjectHostGroup-Befehl diese Auflistungshostgruppen hinzugefügt werden. Weitere Informationen finden Sie unter TFSLabConfig CreateTeamProjectHostGroup-Befehl.

Erforderliche Berechtigungen

Zum Verwenden des ListTeamProjectCollectionHostGroups-Befehls müssen Sie die View Lab Resources-Berechtigung auf der Teamprojektauflistungsebene besitzen. Standardmäßig verfügen TFS-Administratoren und Mitglieder der Teamprojektsammlungs-Administratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig ListTeamProjectCollectionHostGroups
      /Collection:collectionUrl

Parameter

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Bild für Kopieren Code kopieren
TFSLabConfig ListTeamProjectCollectionHostGroups
    /collection:http://abc:8080/TFS/Collection0

Siehe auch

Referenz

TFSLabConfig ListTeamProjectHostGroups-Befehl
TFSLabConfig CreateTeamProjectHostGroup-Befehl
TFSLabConfig DeleteTeamProjectHostGroup-Befehl

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig ListTeamProjectCollectionLibraryShares-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig ListTeamProjectCollectionLibraryShares-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie den ListTeamProjectCollectionLibraryShares-Befehl, um die Bibliotheksfreigaben aufzulisten, die einer Teamprojektauflistung zugewiesen wurden und für die Sie Leseberechtigungen besitzen. Bibliotheksfreigaben werden im System Center Virtual Machine Manager (SCVMM) erstellt. und werden mit den TFSConfig Lab /LibraryShare-Befehle-Teamprojektauflistungs-Bibliotheksfreigaben hinzugefügt und können mit dem CreateTeamProjectLibraryShare-Befehl einem Teamprojekt hinzugefügt werden. Weitere Informationen finden Sie unter TFSLabConfig CreateTeamProjectLibraryShare-Befehl.

Erforderliche Berechtigungen

Zum Verwenden des ListTeamProjectCollectionLibraryShares-Befehls müssen Sie die View Lab Resources-Berechtigung auf der Teamprojektauflistungsebene besitzen. Standardmäßig verfügen TFS-Administratoren und Mitglieder der Teamprojektsammlungs-Administratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig ListTeamProjectCollectionLibraryShares
Collection:collectionUrl

Parameter

Argument | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Bild für Kopieren Code kopieren
TFSLabConfig ListTeamProjectCollectionLibraryShares
    /collection:http://abc:8080/TFS/Collection0

Siehe auch

Referenz

TFSLabConfig ListTeamProjectLibraryShares-Befehl
TFSLabConfig CreateTeamProjectLibraryShare-Befehl
TFSLabConfig DeleteTeamProjectLibraryShare-Befehl

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig ListTeamProjectHostGroups-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig ListTeamProjectHostGroups-Befehl
Beispiel Siehe auch Feedback senden

Verwenden Sie den ListTeamProjectHostGroups-Befehl, um die Hostgruppen aufzulisten, die einem Teamprojekt zugewiesen wurden und für das Sie Leseberechtigungen besitzen.

Erforderliche Berechtigungen

Zum Verwenden des ListTeamProjectHostGroups-Befehls müssen Sie die View Lab Resources-Berechtigungen auf der Teamprojektebene besitzen. Standardmäßig verfügen die Mitglieder der Gruppen Team Foundation Server-Administratoren, Teamprojektsammlungsadministratoren, Teamprojektadministratoren, Teamprojektteilnehmer und Teamprojektleser über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig ListTeamProjectHostGroups
Collection:collectionUrl
      /TeamProject:teamProjectName

Parameter

Argument | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server, worin die Teamprojektauflistung enthalten ist. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.
TeamProject:teamProjectName | Erforderlich. Den Namen des Teamprojekts. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Bild für Kopieren Code kopieren
TFSLabConfig ListTeamProjectHostGroups
    /collection:http://abc:8080/TFS/DefaultCollection
    /teamProject:Project1

Siehe auch

Referenz

TFSLabConfig ListTeamProjectCollectionHostGroups-Befehl
TFSLabConfig CreateTeamProjectHostGroup-Befehl
TFSLabConfig DeleteTeamProjectHostGroup-Befehl

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig ListTeamProjectLibraryShares-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig ListTeamProjectLibraryShares-Befehl
Siehe auch Feedback senden

Verwenden Sie den ListTeamProjectLibraryShares-Befehl, um alle Bibliotheksfreigaben aufzulisten, die einem Teamprojekt zugewiesen wurden und für das Sie Leseberechtigungen besitzen.

Erforderliche Berechtigungen

Zum Verwenden des ListTeamProjectLibraryShares-Befehls müssen Sie die View Lab Resources-Berechtigung auf der Teamprojektebene besitzen. Standardmäßig verfügen die Mitglieder der Gruppen TFS-Administratoren, Teamprojektsammlungsadministratoren, Teamprojektadministratoren, Teamprojektteilnehmer und Teamprojektleser über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig ListTeamProjectLibraryShares
Collection:collectionUrl
      /TeamProject:teamProjectName

Parameter

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server, worin die Teamprojektauflistung enthalten ist. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.
TeamProject:teamProjectName | Erforderlich. Den Namen des Teamprojekts. Verwenden Sie Anführungszeichen, wenn der Name Leerzeichen enthält.

Siehe auch

Referenz

TFSLabConfig ListTeamProjectCollectionLibraryShares-Befehl
TFSLabConfig DeleteTeamProjectLibraryShare-Befehl
TFSLabConfig CreateTeamProjectLibraryShare-Befehl

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig Permissions-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig Permissions-Befehl
Siehe auch Feedback senden

Verwenden Sie den TFSLabConfig Permissions-Befehl, um für einen bestimmten Benutzer oder für mehrere Benutzer Berechtigungen für ein angegebenes Objekt in Visual Studio Lab Management festzulegen. Weitere Informationen über einzelne Berechtigungen finden Sie im Abschnitt zu Lab Management-Berechtigungen unter Team Foundation Server-Berechtigungen.

Erforderliche Berechtigungen

Um Berechtigungen für ein Objekt abzufragen, müssen Sie Leseberechtigungen für das Objekt besitzen. Um Berechtigungen für ein Objekt mit dem Permissions-Befehl zu ändern, müssen Sie über die Berechtigung Manage Permissions verfügen. Standardmäßig verfügt der Ersteller des Objekts über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig Permissions
      /Collection:collectionUrl
      [objectSpec]
      {[/User:userName1[,userName2][,...]]
      [/Group:groupName1[,groupName2][,...]]}
      [/Allow:{* |perm1[,perm2][,...] }]
      [/Deny:{* |perm1[,perm2][,...]}]
      [/Remove:{* |perm1[,perm2][,...]}]
      [/Inherit:Yes|No]

Parameter

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server. Beispiel: /collection:http://abc:8080/TFS/DefaultCollection.
objectSpec | Dies ist optional. Gibt das Zielobjekt an, z. B. ein Teamprojekt oder eine Bibliotheksfreigabe, auf das die Berechtigungen angewendet werden. Weitere Informationen zum Angeben von Objekten finden Sie weiter unten unter objectSpec.
User:userName1[,userName2][,...] | Dies ist optional. Gibt einen oder mehrere Benutzer an, auf die die Berechtigungen angewendet werden. Trennen Sie mehrere Benutzernamen durch Kommas.
Group:groupName1[,groupName2][,...] | Dies ist optional. Gibt eine oder mehrere Gruppen an, auf die die Berechtigungen angewendet werden. Trennen Sie mehrere Gruppennamen durch Kommas.
Allow:{* |perm1[,perm2][,...]} | Dies ist optional. Aktiviert die angegebenen Berechtigungen für die angegebenen Benutzer oder Gruppen. Geben Sie alle Berechtigungen mithilfe eines Sternchens (*) an. Um eine einzelne Berechtigung anzugeben, verwenden Sie die Bezeichner in der Spalte Name at command line der Tabelle im Abschnitt Berechtigungen für Lab-Management von Team Foundation Server-Berechtigungen. Trennen Sie mehrere Berechtigungen durch Kommas.
Deny:{* |perm1[,perm2][,...]} | Dies ist optional. Verweigert die angegebenen Berechtigungen für die angegebenen Benutzer oder Gruppen. Geben Sie alle Berechtigungen mithilfe eines Sternchens (*) an. Um eine einzelne Berechtigung anzugeben, verwenden Sie die Bezeichner in der Spalte Name at command line der Tabelle im Abschnitt Berechtigungen für Lab-Management von Team Foundation Server-Berechtigungen. Trennen Sie mehrere Berechtigungen durch Kommas.
Remove:{* |perm1[,perm2][,...]} | Dies ist optional. Setzt die angegebenen Berechtigungen zurück, die dem Benutzer oder der Gruppe zuvor gewährt oder verweigert wurden. Um eine einzelne Berechtigung anzugeben, verwenden Sie die Bezeichner in der Spalte Name at command line der Tabelle im Abschnitt Berechtigungen für Lab-Management von Team Foundation Server-Berechtigungen. Trennen Sie mehrere Berechtigungen durch Kommas.
Inherit:Yes|No | Dies ist optional. Wenn Sie Yes angeben, erbt ein Element alle einer übergeordneten Zugriffssteuerungsliste zugeordneten Berechtigungen. Sie kann nicht mit den Optionen /remove, /user oder /group kombiniert werden.

objectSpec

Sie können die Objekte, die Sie in den TFSLabConfig Permissions-Befehl einschließen möchten, auf zwei Arten angeben:

  • Verwenden Sie einem oder mehrere Speicherortoptionen, um das Objekt in der Lab Management-Hierarchie anzugeben.

  • Verwenden Sie die /Url-Option, um das Objekt als URI anzugeben.

Wenn die objectSpec-Parameteroption nicht angegeben wird, werden die Berechtigungen für alle Objekte in der Teamprojektsammlung übernommen.

Objekttypoptionen

In der folgenden Tabelle ist die gültige Kombination von Optionen aufgeführt, mit denen Sie ein Objekt als objectSpec-Parameter eines TFSLabConfig permissions-Befehls angeben können.

So legen Sie Berechtigungen fest | Verwenden dieser Optionen
Eine bestimmte Hostgruppe in einer Teamprojektauflistung | /TeamProjectCollectionHostGroup:teamProjectCollectionHostGroupName
Eine bestimmte Bibliotheksfreigabe in einer Teamprojektauflistung | /TeamProjectCollectionLibraryShare:teamProjectCollectionLibraryShareName
Alle Gruppenhosts in einem Teamprojekt | /TeamProject:projectName /TeamProjectHostGroup:*
Ein Gruppenhost in einem Teamprojekt | /TeamProject:projectName /TeamProjectHostGroup:teamProjectHostGroupName
Eine Lab-Umgebung in einer Hostgruppe für ein Teamprojekt | /TeamProject:projectName /TeamProjectHostGroup:teamProjectHostGroupName /LabEnvironment:labEnvironmentName
Alle Bibliotheksfreigaben in einem Teamprojekt | /TeamProject: projectName /TeamProjectLibraryShare:*
Eine Bibliotheksfreigabe in einem Teamprojekt | /TeamProject: projectName /TeamProjectLibraryShare:teamProjectLibraryShareName
Eine Lab-Vorlage in einer Bibliotheksfreigabe eines Teamprojekts | /TeamProject:projectName /TeamProjectLibraryShare:teamProjectLibraryShareName /LabTemplate:labTemplateName
Eine Lab-Umgebung in einer Bibliotheksfreigabe eines Teamprojekts | /TeamProject:projectName /TeamProjectLibraryShare:teamProjectLibraryShareName /LabEnvironment:labEnvironmentName

Url

Geben Sie das objectSpec-Zielobjekt eines TFSLabConfig permissions-Befehls mit der /Url-Option mit der folgenden Syntax an:

/url:VSTFS:///LabManagement/objectType/objectId

Die objectId ist der eindeutige numerische Bezeichner des Objekts.

In der folgenden Tabelle sind die gültigen Schlüsselwörter für das objectType-Schlüsselwort aufgeführt.

Object-Datentyp | Beschreibung
TeamProjectCollectionHostGroup | Eine Hostgruppe einer Teamprojektauflistung
TeamProjectCollectionLibraryShare | Eine Bibliotheksfreigabe einer Teamprojektauflistung
TeamProject | Ein Teamprojekt
TeamProjectHostGroup | Eine Hostgruppe eines Teamprojekts
TeamProjectLibraryShare | Eine Bibliotheksfreigabe eines Teamprojekts
LabTemplate | Ein virtueller Computer oder eine Vorlage in einer Teamprojekt-Bibliotheksfreigabe
LabEnvironment | Eine Umgebung, die in einer Teamprojekt-Hostgruppe bereitgestellt oder in einer Teamprojekt-Bibliotheksfreigabe gespeichert wird.

Berechtigungen

Sie können eine oder mehrere Lab Management-Berechtigungen als Ziel der Optionen /Allow, /Deny oder /Remove angeben. Eine Liste der verfügbaren Berechtigungen finden Sie im Abschnitt Lab Management Permissions des Themas Team Foundation Server-Berechtigungen.

  • Geben Sie alle Lab-Berechtigungen mithilfe eines Sternchens (*) an.

  • Trennen Sie mehrere Berechtigungen durch Kommas.

Hinweise

Wenn weder die /User-Option noch die /Group-Option angegeben wird, werden die aktuellen Berechtigungen des angegebenen Objekts angezeigt.

Wenn die objectSpec-Parameteroption nicht angegeben wird, werden die Berechtigungen für alle Objekte in der Teamprojektsammlung übernommen.

Siehe auch

Konzepte

TFSLabConfig-Befehlsreferenz
Team Foundation Server-Berechtigungen
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig SetServiceAccount-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig SetServiceAccount-Befehl
Siehe auch Feedback senden

Legt die Dienstkontoanmeldeinformationen einer Teamprojektauflistung auf den angegebenen Benutzer in Visual Studio Team Foundation Server fest. Das Dienstkonto wird den folgenden Gruppen der Teamprojektauflistung hinzugefügt:

  • Build Service- für Bereitstellungsaktivitäten im Build-Agent und Zugriff auf Ablagespeicherorte.

  • Test Service: für die Autorisierung der Kommunikation zwischen Test-Agents und Testcontrollern.

Das Dienstkonto wird von Test-Agents und Build-Agents in einer Teamprojektauflistung verwendet, um mit Test- und Buildcontrollern zu kommunizieren.

Hinweis Hinweis

Die Anmeldeinformationen des Dienstkontos werden in Team Foundation Server nicht gesichert. Das Dienstkonto sollte mit den minimalen Rechten auf dem System erstellt werden. Der SetServiceAccount-Befehl gewährt dem angegebenen Benutzer die Berechtigungen, die erforderlich sind, um Kommunikation zwischen Agents und Controllern zu ermöglichen.

Erforderliche Berechtigungen

Zum Verwenden des SetServiceAccount-Befehls müssen Sie die Manage Lab Locations-Berechtigung auf der Teamprojektauflistung-Hostgruppenebene besitzen. Standardmäßig verfügen die TFS-Administratoren und die Mitglieder der Teamprojektsammlungs-Administratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig SetServiceAccount
    /Collection:collectionURL
    /User:userName

Optionen

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server, die dem Dienstkonto zugeordnet werden soll.
User:userName | Erforderlich. Bei Bedarf die Domäne und der Benutzername des Dienstkontos.

Hinweise

Der SetServiceAccount-Befehl ersetzt alle vorhandenen Dienstkontoanmeldeinformationen in der Konfiguration der Teamprojektauflistung. Die Anmeldeinformationen, die in bereitgestellten Umgebungen verwendet werden, werden jedoch nicht ersetzt. Verwenden Sie den UpdateCredentialsOnDeployedEnvironments-Befehl, um die Anmeldeinformationen in vorhandenen Umgebungen zu ersetzen.

Beschreibung

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

In diesem Beispiel wird ein Dienstkonto für eine Teamprojektauflistung hinzugefügt.

Code

Bild für Kopieren Code kopieren
TFSLabConfig SetServiceAccount
    /collection:http://contoso:8080/TFS/DefaultCollection
    /user:contoso\user1

Siehe auch

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig GetServiceAccount-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig GetServiceAccount-Befehl
Beispiel Siehe auch Feedback senden

Listet das aktuelle Dienstkonto auf, das von Test-Agents und Build-Agents für die Kommunikation mit Test- und Buildcontrollern in einer Teamprojektauflistung verwendet wird.

Erforderliche Berechtigungen

Zum Verwenden des GetServiceAccount-Befehls müssen Sie die Manage Lab Locations-Berechtigung auf der Teamprojektauflistung-Hostgruppenebene besitzen. Standardmäßig verfügen die TFS-Administratoren und die Mitglieder der Teamprojektsammlungs-Administratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig GetServiceAccount
    /collection:collectionUrl

Optionen

Option | Beschreibung
Collection:collectionUrl | Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server.

Hinweise

Das Dienstkonto einer Teamprojektauflistung wird durch den TfsLabConfig SetServiceAccount-Befehl oder auf der Registerkarte "Benutzerkonto" im Dialogfeld "Teamprojektauflistung erstellen" festgelegt.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen in diesem Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

In diesem Beispiel wird das Benutzerkonto für eine Teamprojektauflistung aufgelistet.

Bild für Kopieren Code kopieren
tfslabconfig /getserviceaccount
    /collection:http://contoso:8080/TFS/DefaultCollection

Siehe auch

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig ClearServiceAccount-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig ClearServiceAccount-Befehl
Beispiel Siehe auch Feedback senden

Entfernt die Dienstkontoanmeldeinformationen, die von Test- und Build-Agents einer Teamprojektauflistung für die Kommunikation mit Test- und Buildcontrollern verwendet werden.

Erforderliche Berechtigungen

Zum Verwenden des ClearServiceAccount-Befehls müssen Sie die Manage Lab Locations-Berechtigung auf der Teamprojektauflistung-Hostgruppenebene besitzen. Standardmäßig verfügen die Team Foundation Server-Administratoren und Mitglieder der Projektauflistungsadministratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig ClearServiceAccount
    /collection:collectionURL

Optionen

Option | Beschreibung
Collection:collectionUrl | Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server.

Hinweise

Das Dienstkonto einer Teamprojektauflistung wird durch den TfsLabConfig SetServiceAccount-Befehl oder auf der Registerkarte "Benutzerkonto" im Dialogfeld "Teamprojektauflistung erstellen" festgelegt.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

In diesem Beispiel werden die Benutzerkonten für eine Teamprojektauflistung gelöscht.

Bild für Kopieren Code kopieren
tfslabconfig clearserviceaccount
    /collection:http:// contosotfs:8080/TFS/DefaultCollection

Siehe auch

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig UpdateServiceAccountOnDeployedEnvironments-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig UpdateServiceAccountOnDeployedEnvironments-Befehl
Beispiel Siehe auch Feedback senden

Fügt das Dienstkonto aller oder einiger der vorhandenen Umgebungen in einer Teamprojektauflistung dem aktuellen Dienstkonto der Teamprojektauflistung hinzu oder ändert es. Das Dienstkonto wird von Test-Agents und Build-Agents in einer Teamprojektauflistung verwendet, um mit Test- und Buildcontrollern zu kommunizieren.

Erforderliche Berechtigungen

Zum Verwenden des UpdateServiceAccountOnDeployedEnvironments-Befehls müssen Sie die Manage Lab Locations-Berechtigung auf der Teamprojektauflistung-Hostgruppenebene besitzen. Standardmäßig verfügen die Team Foundation Server-Administratoren und Mitglieder der Projektauflistungsadministratorgruppen über diese Berechtigung. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSLabConfig UpdateServiceAccountOnDeployedEnvironments
    /Collection:collectionUrl,
    [/LabEnvironmentIds:id1,id2,...]

Parameter

Option | Beschreibung
Collection:collectionUrl | Erforderlich. Die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server, die den Anmeldeinformationen zugeordnet werden soll. die das Teamprojekt enthält. Wenn die LabEnvironmentIds-Option nicht angegeben wird, werden alle Umgebungen in der Teamprojektsammlung aktualisiert.
LabEnvironmentIds:id1,id2,... | Ein oder mehrere durch Trennzeichen getrennte Bezeichner der Teamprojektsammlungs-Umgebungen, die Sie aktualisieren möchten. Sie können die Umgebungsbezeichner im Umgebungs-Viewer von Lab Management und über die XML-Beschreibung des virtuellen Computers in der SCVMM-Administratorkonsole anzeigen.

Hinweise

Das Dienstkonto einer Teamprojektauflistung wird durch den TfsLabConfig SetServiceAccount-Befehl oder auf der Registerkarte "Benutzerkonto" im Dialogfeld "Teamprojektauflistung erstellen" festgelegt.

Beispiel

Zur besseren Lesbarkeit sind Befehlsoptionen im Beispiel in separaten Zeilen aufgeführt. Geben Sie im Eingabeaufforderungsfenster alle Optionen für einen Befehl in der gleichen Zeile ein.

Im ersten Beispiel wird das Dienstkonto aller Umgebungen einer Teamprojektauflistung aktualisiert. Im zweiten Beispiel werden nur die angegebenen Umgebungen aktualisiert.

Bild für Kopieren Code kopieren
REM First example
TFSLabConfig UpdateServiceAccountOnDeployedEnvironments
    /collection:http://contosotfs:8080/TFS/DefaultCollection

REM Second example
TFSLabConfig UpdateServiceAccountOnDeployedEnvironments
    /collection:http:// contosotfs:8080/TFS/DefaultCollection
    /labEnvironmentIds:5,8

Siehe auch

Konzepte

TFSLabConfig-Befehlsreferenz
TFSConfig-Lab-Befehlsreferenz
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig TPCHostGroup-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig TPCHostGroup-Befehl
Beispiel Siehe auch Feedback senden

Hinweis Hinweis

Diese Befehle funktionieren nur auf dem SCVMM 2012-Server und werden auf dem SCVMM 2008 R2-Server nicht unterstützt.

Verwenden Sie den Befehl TPCHostGroup, um einer Teamprojektauflistung eine Hostgruppe hinzuzufügen oder aus dieser zu entfernen oder die Lab Management-Einstellungen für die Hostgruppe zu ändern.

Um diese Befehle auszuführen, müssen Sie Mitglied der Gruppe "Teamprojektsammlungsadministratoren" in Team Foundation Server für die Auflistung sein, die Sie angeben. Außerdem müssen Sie Mitglied der Administrator- oder der delegierten Administratorrolle im SCVMM-Server sein, von dem die Hostgruppen hinzugefügt werden. Darüber hinaus müssen Sie sicherstellen, dass für keine andere Teamprojektauflistung in einer Team Foundation Server-Instanz bereits dieselbe SCVMM-Hostgruppe verwendet wird.

TfsLabConfig TPCHostGroup
      /collection:collectionUrl
      [/add
            /scvmmhostgroup:scvmmHostGroupPath
            /name:name
            [/dnssuffix:dnsSuffixForNetworkIsolation]
            [/autoprovision:{True|False}]]
      [/delete
            /name:name
            [/noprompt]]
      [/edit
            /name:hostGroupName
            [/autoprovision:{True|False}]
            [/dnssuffix:dnSuffixForNetworkIsolation]
            [/noprompt]]
      [/list]
      [/listscvmmhostgroups]

Parameter

Option | Beschreibung
collection:collectionUrl | Erforderlich. Gibt die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server an.
add | Fügt die angegebene Hostgruppe der Teamprojektauflistung hinzu. Sie müssen die /collection-Option, die /scvmmhostgroup-Option und die name-Option in Verbindung mit /add angeben.
scvmmhostgroup:scvmmHostGroupPath | Erforderlich mit /add. Gibt den vollqualifizierten Domänennamen (FDQN) der VMM-Hostgruppe an. Der FQDN-Pfad kann mithilfe der VMM-Administrator-Konsole gesucht werden.
name:hostGroupName | Erforderlich mit /add. Gibt den Namen der Hostgruppe in der Teamprojektauflistung an.
dnsSuffix:dnsSuffixForNetworkIsolation | Optional mit /add oder /edit. Legt das DNS-Suffix fest, das verwendet wird, um die Namen virtueller Computer im isolierten Netzwerk für die virtuelle Umgebung in dieser Hostgruppe zu registrieren. Um zu bestätigen, dass das Suffix in der DNS-Hierarchie richtig konfiguriert ist, wenden Sie sich an den Netzwerkadministrator.
autoProvision:True|False | Optional mit /add oder /edit. Gibt an, ob die Hostgruppe automatisch jedem Teamprojekt in der Auflistung zugewiesen wird. Standardgemäß wird /autoProvision auf True eingestellt. Die Hostgruppe wird automatisch jedem Teamprojekt in der Auflistung zugewiesen. Hinweis: Die /autoProvision-Option wirkt sich auf vorhandene Teamprojekte aus.
Delete | Entfernt die angegebene Hostgruppe aus der Teamprojektauflistung. Sie müssen die /collection- Option und die /name-Option angeben.
noPrompt | Optional mit /add, /edit oder /delete. Unterdrückt die Anzeige von Status- und Ergebnisdaten im Befehlsfenster.
edit | Ändert die Lab Management-Einstellungen der Hostgruppe. Sie müssen die /collection- Option und die /name-Option angeben.
list | Listet alle Hostgruppen auf, die dem angegebenen Teamprojekt zugewiesen sind.
listVmmHostGroups | Führt alle Hostgruppen auf, die in VMM verfügbar sind.

Beispiel

In diesem Beispiel wird einer Teamprojektauflistung eine Hostgruppe hinzugefügt:

Bild für Kopieren Code kopieren
TFSLabConfig TPCHostGroup
      /collection:http://abc:8080/TFS/Collection0
      /name:HostGroup1

Siehe auch

Referenz

TFSLabConfig-TPCLibraryShare-Befehl

Konzepte

Konfigurieren von Lab-Management mit TFSLabConfig
Konfigurieren und Verwalten von Lab-Management


TFSLabConfig-TPCLibraryShare-Befehl

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSLabConfig-TPCLibraryShare-Befehl
Beispiel Siehe auch Feedback senden

Hinweis Hinweis

Diese Befehle funktionieren nur auf dem SCVMM 2012-Server und werden auf dem SCVMM 2008 R2-Server nicht unterstützt.

Verwenden Sie den Befehl TPCLibraryShare, um einer Teamprojektauflistung eine Bibliotheksfreigabe hinzuzufügen oder aus dieser zu entfernen oder die Lab Management-Einstellungen für die Bibliotheksfreigabe zu ändern.

Um diese Befehle auszuführen, müssen Sie Mitglied der Gruppe "Teamprojektsammlungsadministratoren" in Team Foundation Server für die Auflistung sein, die Sie angeben. Außerdem müssen Sie Mitglied der Administrator- oder der delegierten Administratorrolle im SCVMM-Server sein, von dem die Hostgruppen hinzugefügt werden. Darüber hinaus müssen Sie sicherstellen, dass für keine andere Teamprojektauflistung in einer Team Foundation Server-Instanz bereits dieselbe SCVMM-Bibliotheksfreigabe verwendet wird.

TfsLabConfig TPCLibraryShare
      /collection:collectionUrl
      [/add
            /scvmmLibraryShare:vmmLibrarySharePath
            /name:libraryShareName
            [/autoprovision:{True|False}]]
      [/delete
            /name:libraryShareName
            [/noprompt]]
      [/edit
            /name:libraryShareName
            [/autoprovision:{True|False}]
            [/noprompt]]
      [/list]
      [/listscvmmlibraryshares]

Parameter

Option | Beschreibung
collection:collectionUrl | Erforderlich. Gibt die URL der Teamprojektauflistung auf der Anwendungsebene von Team Foundation Server an.
add | Fügt die angegebene Bibliotheksfreigabe der Teamprojektauflistung hinzu. Sie müssen die /collection-Option, die /scvmmlibraryshare-Option und die /name-Option in Verbindung mit /add angeben.
scvmmLibraryShare:vmmLibrarySharePath | Erforderlich mit /add. Gibt den vollqualifizierte Domänennamen (FQDN) der VMM-Freigabe an. Der FDQN-Pfad kann mithilfe der VMM-Administrator-Konsole abgerufen werden.
name:libraryShareName | Erforderlich mit /add, edit und delete. Gibt den Namen der Bibliotheksfreigabe in der Teamprojektauflistung an.
autoProvision:True|False | Optional mit /add oder /edit. Gibt an, ob die Bibliotheksfreigabe automatisch den einzelnen Teamprojekten in der Auflistung zugewiesen wird. Standardgemäß wird /autoProvision auf True eingestellt. Die Bibliotheksfreigabe wird automatisch jedem Teamprojekt in der Auflistung zugewiesen. Die /autoProvision-Option wirkt sich nur auf vorhandene Teamprojekte aus.
Delete | Entfernt die angegebene Bibliotheksfreigabe aus der Teamprojektauflistung. Sie müssen die /collection- Option und die /name-Option angeben.
noPrompt | Optional mit /add, /edit oder /delete. Unterdrückt die Anzeige von Status- und Ergebnisdaten im Befehlsfenster.
edit | Ändert die Lab Management-Einstellungen der Bibliotheksfreigabe. Sie müssen die /collection- Option und die /name-Option angeben.
list | Führt alle Bibliotheksfreigaben auf, die der angegebenen Teamprojektauflistung zugewiesen sind.
listscvmmlibraryshares | Führt alle Bibliotheksfreigaben auf, die in VMM verfügbar sind.

Beispiel

In diesem Beispiel wird einer Teamprojektauflistung eine Bibliotheksfreigabe hinzugefügt:

Bild für Kopieren Code kopieren
TFSLabConfig TPCLibraryShare
      /collection:http://abc:8080/TFS/Collection0
      /add
      /scvmmLibraryShare:"LibraryShares\LibraryShare1"
      /name:LibraryShare1

Siehe auch

Referenz

TFSLabConfig TPCHostGroup-Befehl

Konzepte

Konfigurieren von Lab-Management mit TFSLabConfig
Konfigurieren und Verwalten von Lab-Management


Ändern von Gruppen und Berechtigungen mit TFSSecurity

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Ändern von Gruppen und Berechtigungen mit TFSSecurity
Feedback senden

Mit dem Befehlszeilen-Hilfsprogramm TFSSecurity können Sie Gruppen und Benutzer in Visual Studio Team Foundation Server (TFS) erstellen, ändern und löschen sowie Berechtigungen für Gruppen und Benutzer bearbeiten. Weitere Informationen zum Ausführen dieser Aufgaben in der Benutzeroberfläche finden Sie unter Konfigurieren von Benutzern, Gruppen und Berechtigungen.

Standardmäßig finden Sie dieses Dienstprogramm im Verzeichnis Laufwerk:\Programme\Microsoft Team Foundation Server 2012\Tools auf den Anwendungsebenenservern für Team Foundation.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

Sie können die Optionen in der folgenden Tabelle für alle Befehle in diesem Dienstprogramm verwenden.

Option | Beschreibung
/? | Zeigt Befehlssyntax und Optionen für TFSSecurity an.

In diesem Abschnitt

TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner

Befehl "/i"

Befehl "/im"

Befehl "/imx"

Befehl "/g"

Befehl "/gcg"

Befehl "/gc"

Befehl "/gun"

Befehl "/gud"

Befehl "/gd"

Befehl "/g+"

Befehl "/g-"

Befehl "/m"

Befehl "/a+"

Befehl "/a-"

Befehl "/acl"


TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner
Siehe auch Feedback senden

Die Eingabe und die Ausgabe für das Befehlszeilendienstprogramm TFSSecurity erfolgt nach einem Standardformat. In den Tabellen weiter unten in diesem Thema werden gültige Identitäts- und Ausgabespezifizierer für diesen Befehl beschrieben. Diese Spezifizierer gelten für alle TFSSecurity-Befehlszeilenprogramme.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Identitätsbezeichner

Sie können eine Identität mithilfe einer der Notationen in der folgenden Tabelle referenzieren.

Identitätsbezeichner | Beschreibung | Beispiel
sid:SID. | Verweist auf die Identität mit der angegebenen Sicherheits-ID (SID). | sid:S-1-5-21-2127521184-1604012920-1887927527-588340
n:[Domäne\]Name | Verweist auf die Identität mit dem angegebenen Namen. Unter Windows steht Name für den Kontonamen. Wenn sich die referenzierte Identität in einer Domäne befindet, ist der Domänenname erforderlich. Bei Anwendungsgruppen steht Name für den Anzeigenamen der Gruppe und Domäne für den URI bzw. die GUID des enthaltenden Projekts. Wenn in diesem Kontext Domäne weggelassen wird, wird als Bereich von der Auflistungsebene ausgegangen. | So verweisen Sie auf die Identität des Benutzers "John Peoples" in der Domäne "Datum1" im fiktiven Unternehmen "A Datum Corporation:" n:DATUM1\jpeoples So verweisen Sie auf Anwendungsgruppen: n:"Full-time Employees" n:00a10d23-7d45-4439-981b-d3b3e0b0b1ee\Vendors
adm:[Bereich] | Verweist auf die Administratoranwendungsgruppe für den Bereich, z. B. "Team Foundation-Administratoren" auf Serverebene oder "Projektauflistungsadministratoren" auf Auflistungsebene. Der optionale Parameter Bereich ist ein Projekt-URI oder eine URL, einschließlich der GUID und Verbindungszeichenfolge. Wenn der Bereich weggelassen wird, wird vom Server- oder Auflistungsbereich ausgegangen, abhängig davon ob der Parameter "/instance" oder "/server" verwendet wird. In beiden Fällen ist der Doppelpunkt erforderlich. | adm:vstfs:///Classification/TeamProject/GUID
srv: | Verweist auf die Anwendungsgruppe für Dienstkonten. | Nicht zutreffend
all: | Verweist auf alle Gruppen und Identitäten. | Nicht zutreffend
Zeichenfolge | Verweist auf eine nicht qualifizierte Zeichenfolge. Wenn die Zeichenfolge mit S-1- beginnt, wird sie als SID identifiziert. Wenn die Zeichenfolge mit CN= oder LDAP:// beginnt, wird sie als Distinguished Name identifiziert. Andernfalls wird die Zeichenfolge als Name identifiziert. | "Teamtester"

Typkennzeichnungen

Identitätstypkennzeichnungen

Die folgende Tabelle enthält Identitätstypkennzeichnungen, die in Ausgabemeldungen verwendet werden.

Identitätstypkennzeichnung | Beschreibung
U | Windows-Benutzer
G | Windows-Gruppe
A | Team Foundation Server (TFS)-Anwendungsgruppe
a [A] | Administrative Anwendungsgruppe
s [A] | Dienstkontenanwendungsgruppe
X | Die Identität ist ungültig.
? | Die Identität ist unbekannt.

Kennzeichnungen für Zugriffssteuerungseinträge

Die folgende Tabelle enthält in Ausgabemeldungen verwendete Kennzeichnungen für Zugriffssteuerungseinträge.

Kennzeichnung für Zugriffssteuerungseinträge | Beschreibung
+ | ALLOW-Zugriffssteuerungseintrag
- | DENY-Zugriffssteuerungseintrag
* [] | Geerbter Zugriffssteuerungseintrag

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity


Befehl "/i"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/i"
Siehe auch Feedback senden

Verwenden Sie /i, um Identitätsinformationen zu einer bestimmten Gruppe in einer Bereitstellung von Team Foundation Server anzuzeigen.

Erforderliche Berechtigungen

Um den /i-Befehl zu verwenden, müssen Sie die Berechtigung Informationen auf Auflistungsebene anzeigenoder Instanzebeneninformationen anzeigen auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /i Identity [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
Identity | Die Identität des Benutzers oder der Anwendungsgruppe. Weitere Informationen über Identitätsbezeichner finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Der /i-Befehl des TFSSecurity-Befehlszeilen-Hilfsprogramms zeigt Informationen zu jeder Gruppe innerhalb der Teamprojektauflistung (/server) oder dem Anwendungsebenenserver (/instance) an. Es werden keine Mitgliedschaftsinformationen angezeigt.

Beispiele

Im folgenden Beispiel werden Identitätsinformationen für die Gruppe "Team Foundation-Administratoren" angezeigt.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /i "Team Foundation Administrators" /server:ServerURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "Team Foundation Administrators"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: Team Foundation Administrators
  Description: Members of this application group can perform all privileged operations on the server.

Im folgenden Beispiel werden Identitätsinformationen für die Gruppe "Projektauflistungsadministratoren" mit dem adm:-Identitätsspezifizierer angezeigt.

Bild für Kopieren Code kopieren
>tfssecurity /i adm: /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "adm:"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: [DatumOne]\Project Collection Administrators
  Description: Members of this application group can perform all privileged operations on the team project collection.

Im folgenden Beispiel werden Identitätsinformationen für die Gruppe "Projektadministratoren" des "Datum"-Projekts mit dem adm:-Identitätsspezifizierer angezeigt.

Bild für Kopieren Code kopieren
>tfssecurity /i adm:vstfs:///Classification/TeamProject/ProjectGUID /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "adm:vstfs:///Classification/TeamProject/ProjectGUID"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Datum
 Display name: [Datum]\Project Administrators
  Description: Members of this application group can perform all operations in the team project.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups


Befehl "/im"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/im"
Siehe auch Feedback senden

Verwenden Sie /im, um Informationen zu den Identitäten anzuzeigen, aus denen sich die direkte Mitgliedschaft einer angegebenen Gruppe zusammensetzt.

Erforderliche Berechtigungen

Um den /im-Befehl zu verwenden, müssen Sie die Berechtigung Informationen auf Auflistungsebene anzeigenoder Instanzebeneninformationen anzeigen auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /im Identity [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
Identity | Die Identität des Benutzers oder der Gruppe. Weitere Informationen über Identitätsbezeichner finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Der /im-Befehl von TFSSecurity zeigt nur die direkten Mitglieder der angegebenen Gruppe an. Diese Liste umfasst weitere Gruppen, die Mitglieder der angegebenen Gruppe sind. Die tatsächlichen Mitglieder der Mitgliedsgruppen werden jedoch nicht aufgelistet.

Beispiele

Im folgenden Beispiel werden Identitätsinformationen zu direkten Mitgliedschaften angezeigt, für die Gruppe "Team Foundation-Administratoren" in der Domäne "Datum1" des fiktiven Unternehmens "A. Datum Corporation".

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /im "Team Foundation Administrators" /server:ServerURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "Team Foundation Administrators"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Server scope
Display name: Team Foundation Administrators
Description: Members of this application group can perform all privileged operations on the server.

3 member(s):
  [U] Datum1\hholt (Holt, Holly)
  [G] BUILTIN\Administrators (BUILTIN\Administrators)
s [A] [InstanceName]\Team Foundation Service Accounts

Member of 2 group(s):
a [A] [DatumOne]\Project Collection Administrators ([DatumOne]\Project Collection Administrators)
e [A] [InstanceName]\Team Foundation Valid Users

Done.

Im folgenden Beispiel werden Identitätsinformationen für die Gruppe der Projektauflistungsadministratoren in der Teamprojektauflistung "DatumOne" in der Domäne "Datum1" im fiktiven Unternehmen "A. Datum Corporation" unter Verwendung des adm:-Identitätsspezifizierers.

Bild für Kopieren Code kopieren
>tfssecurity /im adm: /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "adm: "...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Server scope
Display name: [DatumOne]\Project Collection Administrators
Description: Members of this application group can perform all privileged operations on the team project collection.

5 member(s):
  [U] Datum1\jpeoples (Peoples, John)
  [U] Datum1\hholt (Holt, Holly)
  [G] BUILTIN\Administrators (BUILTIN\Administrators)
a [A] [InstanceName]\Team Foundation Administrators
s [A] [DatumOne]\Project Collection Service Accounts ([DatumOne]\Project Collection Service Accounts)

Member of 1 group(s):
e [A] [DatumOne]\Project Collection Valid Users ([DatumOne]\Project Colleciton Valid Users)

Done.

Im folgenden Beispiel werden Identitätsinformationen für die Gruppe "Projektadministratoren" des "Datum"-Projekts angezeigt, in der Teamprojektauflistung "DatumOne" in der Domäne "Datum1" des fiktiven Unternehmens "A. Datum Corporation" unter Verwendung des adm:-Identitätsspezifizierers.

Bild für Kopieren Code kopieren
>tfssecurity /im adm:vstfs:///Classification/TeamProject/ProjectGUID /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "adm:vstfs:///Classification/TeamProject/ProjectGUID"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXX

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Datum
Display name: [Datum]\Project Administrators
Description: Members of this application group can perform all operations in the team project.

2 member(s):
  [U] Datum1\jpeoples (Peoples, John)
  [U] Datum1\hholt (Holt, Holly)

Member of 1 group(s):
e [A] [DatumOne]\Project Collection Valid Users ([DatumOne]\Project Collection Valid Users)

Done.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups


Befehl "/imx"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/imx"
Siehe auch Feedback senden

Verwenden Sie /imx, um Informationen zu den Identitäten anzuzeigen, aus denen sich die erweiterte Mitgliedschaft einer angegebenen Gruppe zusammensetzt.

Erforderliche Berechtigungen

Um den /imx-Befehl zu verwenden, müssen Sie die Berechtigung Informationen auf Auflistungsebene anzeigen oder Instanzebeneninformationen anzeigen auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /imx Identity [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
Identity | Die Identität des Benutzers oder der Gruppe. Weitere Informationen über Identitätsbezeichner finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Der /imx-Befehl von TFSSecurity zeigt nur die erweiterten Mitglieder der angegebenen Gruppe an. Diese Liste enthält nicht nur andere Gruppen, die Elemente der angegebenen Gruppe sind, sondern auch Elemente der Elementgruppen.

Beispiele

Im folgenden Beispiel werden Identitätsinformationen zu erweiterten Mitgliedschaften angezeigt, für die Gruppe "Team Foundation-Administratoren" in der Domäne "Datum1" des fiktiven Unternehmens "A. Datum Corporation".

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /imx "Team Foundation Administrators" /server:ServerURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "Team Foundation Administrators"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Server scope
Display name: Team Foundation Administrators
Description: Members of this application group can perform all privileged operations on the server.

10 member(s):
  [U] Datum1\hholt (Holly Holt)
  [U] Datum1\jpeoples (John Peoples)
  [U] Datum1\tommyh (Tommy Hartono)
  [U] Datum1\henriea (Henriette Andersen)
  [U] Datum1\djayne (Darcy Jayne)
  [U] Datum1\aprilr (April Reagan)
  [G] Datum1\InfoSec Secure Environment
  [U] Datum1\nbento (Nuno Bento)
  [U] Datum1\cristp (Cristian Petculescu)
  [G] BUILTIN\Administrators (BUILTIN\Administrators)
s [A] [InstanceName]\Team Foundation Service Accounts

Member of 3 group(s):
a [A] [DatumOne]\Project Collection Administrators ([DatumOne]\Project Collection Administrators)
e [A] [DatumOne]\Project Collection Valid Users ([DatumOne]\Project Collection Valid Users)
e [A] [InstanceName]\Team Foundation Valid Users

Done.

Im folgenden Beispiel werden Identitätsinformationen für die Gruppe der Projektauflistungsadministratoren in der Teamprojektauflistung "DatumOne" in der Domäne "Datum1" im fiktiven Unternehmen "A. Datum Corporation" unter Verwendung des adm:-Identitätsspezifizierers.

Bild für Kopieren Code kopieren
>tfssecurity /imx adm: /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "adm: "...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Server scope
Display name: [DatumOne]\Project Collection Administrators
Description: Members of this application group can perform all privileged operations on the team project collection.

6 member(s):
  [U] Datum1\jpeoples (Peoples, John)
  [U] Datum1\hholt (Holt, Holly)
  [G] BUILTIN\Administrators (BUILTIN\Administrators)
a [A] [InstanceName]\Team Foundation Administrators
s [A] [InstanceName]\Team Foundation Service Accounts
s [A] [DatumOne]\Project Collection Service Accounts ([DatumOne]\Project Collection Service Accounts)

Member of 1 group(s):
e [A] [DatumOne]\Project Collection Valid Users ([DatumOne]\Project Collection Valid Users)

Done.

Im folgenden Beispiel werden Identitätsinformationen für die Gruppe "Projektadministratoren" des "Datum"-Projekts angezeigt, in der Teamprojektauflistung "DatumOne" in der Domäne "Datum1" des fiktiven Unternehmens "A. Datum Corporation" unter Verwendung des adm:-Identitätsspezifizierers.

Bild für Kopieren Code kopieren
>tfssecurity /imx adm:vstfs:///Classification/TeamProject/ProjectGUID /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
Resolving identity "adm:vstfs:///Classification/TeamProject/ProjectGUID"...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXX

DN:

Identity type: Team Foundation Server application group
Group type: AdministrativeApplicationGroup
Project scope: Datum
Display name: [Datum]\Project Administrators
Description: Members of this application group can perform all operations in the team project.

2 member(s):
  [U] Datum1\jpeoples (Peoples, John)
  [U] Datum1\hholt (Holt, Holly)

Member of 2 group(s):
e [A] [DatumOne]\Project Collection Valid Users ([DatumOne]\Project Collection Valid Users)
e [A] [InstanceName]\Team Foundation Valid Users

Done.

Weitere Informationen über Ausgabebezeichner, z. B. [G] und [U], finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups


Befehl "/g"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/g"
Beispiel Siehe auch Feedback senden

Verwenden Sie /g, um die Gruppen in einem Teamprojekt, in einer Teamprojektauflistung oder irgendwo in Team Foundation Server aufzuführen.

Erforderliche Berechtigungen

Um den /g-Befehl zu verwenden, müssen Sie die Berechtigung Informationen auf Auflistungsebene anzeigen oder Instanzebeneninformationen anzeigen auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Um den /g-Befehl im Bereich eines einzelnen Teamprojekts zu verwenden, muss die Berechtigung Projektebeneninformationen anzeigen auf Zulassen festgelegt sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /g [scope] [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
scope | Dies ist optional. Gibt den URI des Teamprojekts an, für das Sie Gruppen anzeigen möchten. Um den URI für ein Teamprojekt zu erhalten, öffnen Sie Team Explorer, klicken Sie mit der rechten Maustaste auf das Teamprojekt, klicken Sie auf Eigenschaften, und kopieren Sie den ganzen URL-Eintrag.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Der /g-Befehl des TFSSecurity-Befehlszeilen-Hilfsprogramms zeigt Informationen zu jeder Gruppe innerhalb des ausgewählten Projektumfangs an. Dieser Bereich kann der Teamprojektauflistung (/server) oder dem Anwendungsebenenserver (/instance) entsprechen. Bei Verwendung mit dem Bereich eines Teamprojekts werden Informationen nur über die Gruppen angezeigt, die diesem Teamprojekt zugeordnet sind.

Beispiel

Im folgenden Beispiel werden Informationen für alle Gruppen innerhalb einer Teamprojektauflistung angezeigt.

Bild für Kopieren Code kopieren
>TFSSecurity /g /collection:CollectionURL

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups


Befehl "/gcg"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/gcg"
Beispiel Siehe auch Feedback senden

Verwenden Sie den /gcg-Befehl, um eine Gruppe auf Serverebene oder auf Auflistungsebene zu erstellen. Informationen zum Erstellen einer Gruppe auf Serverebene oder Auflistungsebene über die Benutzeroberfläche finden Sie unter Konfigurieren von Benutzern, Gruppen und Berechtigungen.

Erforderliche Berechtigungen

Zum Verwenden des /gcg-Befehls muss die Berechtigung Projektebeneninformationen bearbeiten für das Teamprojekt auf Zulassen festgelegt sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /gcg GroupName [GroupDescription] [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
GroupName | Der Gruppenname.
GroupDescription | Eine Beschreibung der Gruppe Dies ist optional.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Gruppen auf Serverebene werden direkt auf der Anwendungsebene erstellt und gelten für alle Teamprojektauflistungen. Auflistungsebenen werden auf der Auflistungsebene des Teamprojekts erstellt. Sie gelten für diese Auflistung und haben Auswirkungen auf alle Teamprojekte innerhalb der Auflistung. Im Gegensatz dazu gelten Teamprojektgruppen für ein bestimmtes Projekt innerhalb einer Auflistung, aber nicht für andere Projekte in dieser Auflistung. Sie können Gruppen auf Serverebene Berechtigungen zuweisen, damit Mitglieder dieser Gruppen Aufgaben in Team Foundation Server (TFS) ausführen können, z. B. das Erstellen von Teamprojektauflistungen. Sie können Gruppen auf Auflistungsebene Berechtigungen zuweisen, damit Mitglieder dieser Gruppen Aufgaben in einer gesamten Teamprojektsammlung ausführen können, z. B. das Verwalten von Benutzern.

Hinweis Hinweis

Sie können den /gcg-Befehl verwenden, um Gruppen zu erstellen. Sie können damit den Gruppen jedoch keine Benutzer hinzufügen oder Berechtigungen zuweisen. Weitere Informationen darüber, wie die Mitgliedschaft einer Gruppe geändert wird, finden Sie unter Befehl "/g+" und Befehl "/g-". Weitere Informationen darüber, wie die Berechtigungen einer Gruppe geändert werden, finden Sie unter Befehl "/a+" und Befehl "/a-".

Beispiel

Im folgenden Beispiel wird die Gruppe "Datum-Tester" auf Auflistungsebene erstellt, mit der Beschreibung "A. Datum Corporation-Tester".

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>TFSSecurity /gcg "Datum Testers" "A. Datum Corporation Testers" /collection:CollectionURL

Im folgenden Beispiel wird die Gruppe "Datum-Auditoren" auf Serverebene erstellt, mit der Beschreibung "A. Datum Corporation-Auditoren".

Bild für Kopieren Code kopieren
>TFSSecurity /gcg "Datum Auditors" "A. Datum Corporation Auditors" /server:ServerURL

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity


Befehl "/gc"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/gc"
Beispiel Siehe auch Feedback senden

Verwenden Sie /gc an einer Eingabeaufforderung, um eine Gruppe auf Projektebene zu erstellen. Informationen zum Erstellen einer Gruppe auf Projektebene über die Benutzeroberfläche finden Sie unter Konfigurieren von Benutzern, Gruppen und Berechtigungen.

Erforderliche Berechtigungen

Zum Verwenden des /gc-Befehls muss die Berechtigung Projektebeneninformationen bearbeiten für das Teamprojekt auf Zulassen festgelegt sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /gc Scope GroupName [GroupDescription] [/collection:CollectionURL]

Parameter

Argument | Beschreibung
Scope | Der URI des Teamprojekts, dem Sie eine Gruppe auf Projektebene hinzufügen möchten. Um den URI für ein Teamprojekt zu erhalten, öffnen Sie Team Explorer, klicken Sie mit der rechten Maustaste auf das Projekt, klicken Sie auf Eigenschaften, und kopieren Sie den ganzen Wert der URL-Eigenschaft.
GroupName | Der Name der neuen Gruppe.
GroupDescription | Eine Beschreibung der Projektgruppe Dies ist optional.
/collection:CollectionURL | Die URL der Teamprojektauflistung. Erforderlich. Die Gruppe wird innerhalb der Teamprojektauflistung erstellt. Das URL-Format ist http://ServerName:Port/VirtualDirectoryName/CollectionName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Eine Gruppe auf Projektebene ist eine Sicherheitsgruppe für Ihr Teamprojekt. Mithilfe von Projektgruppen können Sie Lese-, Schreib- und Verwaltungsberechtigungen gewähren, die den Sicherheitsanforderungen des Unternehmens entsprechen.

Beispiel

Im folgenden Beispiel wird eine Gruppe erstellt, die für das Projekt spezifisch ist, das der URI "vstfs://Classification/TeamProject/00000000-0000-0000-0000-000000000000" angibt. Die Gruppe heißt "Test Group", und die Beschreibung lautet "This group is for testing".

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Sie müssen die Platzhalter-GUID durch den URI des Teamprojekts ersetzen, für das diese Gruppe erstellt werden soll. Um den URI für ein Teamprojekt zu erhalten, öffnen Sie Team Explorer, klicken Sie mit der rechten Maustaste auf das Teamprojekt, klicken Sie auf Eigenschaften, und kopieren Sie den ganzen Wert der URL-Eigenschaft.

Nachdem Sie den Befehl ausgeführt haben, können Sie die Gruppe in Team Explorer überprüfen. Klicken Sie mit der rechten Maustaste auf das im Befehl verwendete Teamprojekt, klicken Sie auf Teamprojekteinstellungen, und klicken Sie dann auf Gruppenmitgliedschaften. Im Dialogfeld Projektgruppen auf Teamprojektname umfasst die Liste Gruppen den Testgruppeneintrag.

Hinweis Hinweis

Sie können den /gc-Befehl verwenden, um Gruppen zu erstellen. Sie können damit den Gruppen jedoch keine Benutzer hinzufügen oder Berechtigungen zuweisen. Informationen zum Ändern der Mitgliedschaft in einer Gruppe finden Sie unter Befehl "/g+" und Befehl "/g-". Informationen zum Ändern der Berechtigungen für eine Gruppe finden Sie unter Befehl "/a+" und Befehl "/a-".

Bild für Kopieren Code kopieren
>TFSSecurity /gc "vstfs:///Classification/TeamProject/00000000-0000-0000-0000-000000000000" "Test Group" "This group is for team members who test our code" /collection:CollectionURL

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity


Befehl "/gun"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/gun"
Beispiel Siehe auch Feedback senden

Verwenden Sie /gun, um eine Gruppe auf Serverebene oder auf Auflistungsebene umzubenennen.

Erforderliche Berechtigungen

Um den /gun-Befehl zu verwenden, müssen Sie die Berechtigungen Informationen auf Auflistungsebene anzeigen und Informationen auf Auflistungsebene bearbeiten oder Instanzebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /gun GroupIdentity GroupName [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
GroupIdentity | Gibt die Gruppenidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
GroupName | Gibt den neuen Namen der Gruppe an.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Beispiel

Im folgenden Beispiel wird die Gruppe auf Auflistungsebene umbenannt: "A. Datum Corporation-Tester" zu "A. Datum Corporation-Testingenieure".

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /gun "A. Datum Corporation Testers" "A. Datum Corporation Test Engineers" /collection:CollectionURL

Siehe auch

Konzepte

TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How To: Rename a Team Project Group
How to: Rename a Global Group


Befehl "/gud"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/gud"
Beispiel Siehe auch Feedback senden

Ändern Sie mithilfe von /gud die Beschreibung einer Gruppe auf Serverebene oder Auflistungsebene.

Erforderliche Berechtigungen

Zum Verwenden des /gud-Befehls muss die Projektebeneninformationen bearbeiten-Berechtigung auf Zulassen festgelegt sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /gud GroupIdentity GroupDescription [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
GroupIdentity | Gibt die Gruppenidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
GroupDescription | Gibt die neue Beschreibung der Gruppe an.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Beispiel

Das folgende Beispiel ordnet die Beschreibung "Die Mitglieder dieser Gruppe testen den Code für dieses Projekt" der Gruppe "Datum-Tester" zu.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>TFSSecurity /gud "Datum Testers" "The members of this group test the code for this project" /collection:CollectionURL

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
Managing Groups
Default Groups
Global Groups
Team Project Groups


Befehl "/gd"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/gd"
Beispiel Siehe auch Feedback senden

Verwenden Sie /gd, um eine Gruppe auf Serverebene oder auf Auflistungsebene zu löschen.

Erforderliche Berechtigungen

Um den /gd-Befehl zu verwenden, müssen Sie die Berechtigungen Informationen auf Auflistungsebene anzeigen und Informationen auf Auflistungsebene bearbeiten oder Instanzebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /gd groupIdentity [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
groupIdentity | Gibt die Gruppenidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter Ändern von Gruppen und Berechtigungen mit TFSSecurity.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Sie können auch Gruppen auf Team Explorer entfernen. Weitere Informationen finden Sie unter How to: Remove a Global Group und How To: Remove a Team Project Group.

Beispiel

Im folgenden Beispiel wird eine Gruppe aus der Teamprojektauflistung gelöscht. Die Gruppe wird durch die Sicherheits-ID (SID) "S-1-5-21-2127521184-1604012920-1887927527-588340" identifiziert. Weitere Informationen über die Ermittlung der SID einer Gruppe finden Sie unter Befehl "/im". Sie können auch den Anzeigenamen verwenden, um eine Gruppe zu löschen.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>TFSSecurity /gd S-1-5-21-2127521184-1604012920-1887927527-588340 /collection:CollectionURL

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups
Default Groups


Befehl "/g+"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/g+"
Siehe auch Feedback senden

Verwenden Sie /g+, um einer vorhandenen Gruppe einen Benutzer oder eine andere Gruppe hinzuzufügen.

Erforderliche Berechtigungen

Um den /g+-Befehl zu verwenden, müssen Sie die Berechtigungen Informationen auf Auflistungsebene anzeigen und Informationen auf Auflistungsebene bearbeiten oder Instanzebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /g+ groupIdentity memberIdentity [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
groupIdentity | Gibt die Gruppenidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
memberIdentity | Gibt die Mitgliedsidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Sie können Benutzer und Gruppen auch mit Team Explorer einer vorhandenen Gruppe hinzufügen. Weitere Informationen finden Sie unter How to: Add Users to a Global Group.

Beispiele

Im folgenden Beispiel wird der Benutzer John Peoples der Domäne Datum1 (Datum1\jpeoples) der Gruppe "Team Foundation-Administratoren" hinzugefügt.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /g+ "Team Foundation Administrators" n:Datum1\jpeoples ALLOW /server:http://ADatumCorporation:8080

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.
Resolving identity "Team Foundation Administrators"...
a [A] [INSTANCE]\Team Foundation Administrators
Resolving identity "n:Datum1\jpeoples"...
  [U] DATUM1\jpeoples (John Peoples)
Adding John Peoples to [INSTANCE]\Team Foundation Administrators...
Verifying...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: [INSTANCE]\Team Foundation Administrators
  Description: Members of this group can perform all operations on the Team Foundation Application Instance.

4 member(s):
  [U] Datum1\hholt (Holly Holt)
  [U] Datum1\jpeoples (John Peoples)
  [G] BUILTIN\Administrators (BUILTIN\Administrators)
s [A] [INSTANCE]\Team Foundation Service Accounts

Member of 2 group(s):
a [A] [Collection0]\Project Collection Administrators
e [A] [INSTANCE]\Team Foundation Valid Users

Done.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups
Default Groups


Befehl "/g-"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/g-"
Siehe auch Feedback senden

Verwenden Sie /g-, um einen Benutzer oder eine Benutzergruppe aus einer vorhandenen Gruppe zu entfernen.

Erforderliche Berechtigungen

Um den /g--Befehl zu verwenden, müssen Sie die Berechtigungen Informationen auf Auflistungsebene anzeigen und Informationen auf Auflistungsebene bearbeiten oder Instanzebeneninformationen anzeigen und Instanzebeneninformationen bearbeiten auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /g- groupIdentity memberIdentity [/server:CollectionURL] [/instance:ServerURL]

Parameter

Argument | Beschreibung
groupIdentity | Gibt die Gruppenidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
memberIdentity | Gibt die Mitgliedsidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Sie können Benutzer und Gruppen auch mit Team Explorer einer vorhandenen Gruppe hinzufügen. Weitere Informationen finden Sie unter How to: Remove Users from a Team Project Group, How to: Remove Users from a Default Group oder How to: Remove Users from a Server-Level Group.

Beispiele

Im folgenden Beispiel wird der Benutzer John Peoples der Domäne Datum1 (Datum1\jpeoples) aus der Gruppe "Team Foundation-Administratoren" entfernt.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /g- "Team Foundation Administrators" n:Datum1\jpeoples ALLOW /server:http://ADatumCorporation:8080

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.
Resolving identity "Team Foundation Administrators"...
a [A] [INSTANCE]\Team Foundation Administrators
Resolving identity "n:Datum1\jpeoples"...
  [U] DATUM1\jpeoples (John Peoples)
Removing John Peoples from [INSTANCE]\Team Foundation Administrators...
Verifying...

SID: S-1-9-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-0-0-0-0-1

DN:

Identity type: Team Foundation Server application group
   Group type: AdministrativeApplicationGroup
Project scope: Server scope
 Display name: [INSTANCE]\Team Foundation Administrators
  Description: Members of this group can perform all operations on the Team Foundation Application Instance.

3 member(s):
  [U] Datum1\hholt (Holly Holt)
  [G] BUILTIN\Administrators (BUILTIN\Administrators)
s [A] [INSTANCE]\Team Foundation Service Accounts

Member of 2 group(s):
a [A] [Collection0]\Project Collection Administrators
e [A] [INSTANCE]\Team Foundation Valid Users

Done.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity


Befehl "/m"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/m"
Siehe auch Feedback senden

Verwenden Sie /m, um explizite und implizite Informationen zur Gruppenmitgliedschaft für eine angegebene Gruppe oder einen angegebenen Benutzer zu überprüfen.

Erforderliche Berechtigungen

Zum Verwenden des /m-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann eine erweiterte Eingabeaufforderung öffnen, wenn Sie mit Administratoranmeldeinformationen angemeldet sind, um diese Funktion auszuführen.

TFSSecurity /m GroupIdentity [MemberIdentity] [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument | Beschreibung
GroupIdentity | Gibt die Gruppenidentität an. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
MemberIdentity | Gibt die Mitgliedsidentität an. Der Standardwert dieses Arguments ist die Identität des Benutzers, der den Befehl ausführt. Weitere Informationen zu gültigen Identitätsbezeichnern finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.
/collection:CollectionURL | Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName
/server:ServerURL | Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf dem lokalen Computer der Anwendungsebene aus.

Der Befehl /m des Befehlszeilen-Hilfsprogramms TFSSecurity überprüft sowohl direkte als auch erweiterte Mitgliedschaften.

Beispiele

Im folgenden Beispiel wird überprüft, ob der Benutzer "Datum1\jpeoples" zur Gruppe Team Foundation-Administratoren auf Serverebene gehört.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>TFSSecurity /m "Team Foundation Administrators" n:Datum1\jpeoples /server:http://ADatumCorporation:8080

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.
Resolving identity "Team Foundation Administrators"...
a [A] [INSTANCE]\Team Foundation Administrators
Resolving identity "n:Datum1\jpeoples"...
  [U] DATUM1\jpeoples (John Peoples)
Checking group membership...

John Peoples IS a member of [INSTANCE]\Team Foundation Administrators.

Done.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity


Befehl "/a+"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/a+"
Siehe auch Feedback senden

Verwenden Sie /a+, um Berechtigungen für einen Benutzer oder eine Gruppe in einer Gruppe auf Serverebene, Auflistungsebene oder Projektebene hinzuzufügen. Informationen zum Hinzufügen von Benutzern zu Gruppen über die Benutzeroberfläche finden Sie unter Konfigurieren von Benutzern, Gruppen und Berechtigungen.

Erforderliche Berechtigungen

Um den /a+-Befehl zu verwenden, müssen Sie die Berechtigung Informationen auf Auflistungsebene anzeigen oder Instanzebeneninformationen anzeigen auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Wenn Sie die Berechtigungen für ein Teamprojekt ändern, muss zudem die Berechtigung Projektebeneninformationen bearbeiten für das Teamprojekt auf Zulassen festgelegt sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /a+ Namespace Token Action Identity (ALLOW | DENY) [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument

Beschreibung

Namespace

Der Namespace, der die Gruppe enthält, der Sie Berechtigungen für einen Benutzer oder eine Gruppe hinzufügen möchten. Sie können auch den TFSSecurity /a-Befehl verwenden, um eine Liste von Namespaces auf der Server-, Auflistungs- und Projektebene anzuzeigen.

Token

Der Name oder die GUID des Objekts, für das Sie Berechtigungen hinzufügen möchten.

Hinweis Hinweis

Token hängen vom Namespace ab, den Sie angeben. Einige Namespaces verfügen nicht über Token, die für diesen Befehl gültig sind.

Action

Der Name der Berechtigung, für die Sie Zugriff gewähren oder verweigern. Eine Liste gültiger IDs finden Sie unter Team Foundation Server-Berechtigungen, oder verwenden Sie den TFSSecurity /a -Befehl, um eine Liste gültiger Aktionen für einen Namespace anzuzeigen, den Sie angeben.

Identity

Die Identität des Benutzers oder der Gruppe. Weitere Informationen über Identitätsbezeichner finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.

  • ALLOW

    Die Gruppe oder der Benutzer kann den von Action angegebenen Vorgang ausführen.

  • DENY

    Die Gruppe oder der Benutzer kann den von Action angegebenen Vorgang nicht ausführen.

/collection:CollectionURL

Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName

/server:ServerURL

Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Bei Zugriffssteuerungseinträgen handelt es sich um Sicherheitsmechanismen, die bestimmen, welche Vorgänge ein Benutzer, eine Gruppe, ein Dienst oder Computer ausführen darf.

Beispiele

Das folgende Beispiel zeigt, welche Namespaces auf der Serverebene für den Anwendungsebenenserver "ADatumCorporation" verfügbar sind.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /a /server:ServerURL

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.

The following security namespaces are available to have permissions set on them:

     Registry
     Identity
     Job
     Server
     CollectionManagement
     Warehouse
     Catalog
     EventSubscription
     Lab

Done.

Das folgende Beispiel zeigt, welche Aktionen auf Auflistungsebene für den Server-Namespace verfügbar sind.

Bild für Kopieren Code kopieren
>tfssecurity /a Server /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.

The following actions are available in the security namespace Server:
    GenericRead
    GenericWrite
    Impersonate
    TriggerEvent

Done.

Im folgenden Beispiel wird die Berechtigung "Informationen auf Instanzebene anzeigen" auf Serverebene der ADatumCorporation-Bereitstellung für den Benutzer John Peoples der Datum1-Domäne (Datum1\jpeoples) gewährt.

Bild für Kopieren Code kopieren
>tfssecurity /a+ Server FrameworkGlobalSecurity GenericRead n:Datum1\jpeoples ALLOW /server:http://ADatumCorporation:8080

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.
Resolving identity "n:Datum1\jpeoples"...
  [U] Datum1\jpeoples (John Peoples)
Adding the access control entry...
Verifying...

Effective ACL on object "FrameworkGlobalSecurity":
  [+] GenericRead                        [INSTANCE]\Team Foundation Valid Users
  [+] GenericRead                        [INSTANCE]\SharePoint Web Application Services
  [+] Impersonate                        [INSTANCE]\SharePoint Web Application Services
  [+] GenericRead                        [INSTANCE]\Team Foundation Service Accounts
  [+] GenericWrite                       [INSTANCE]\Team Foundation Service Accounts
  [+] Impersonate                        [INSTANCE]\Team Foundation Service Accounts
  [+] TriggerEvent                       [INSTANCE]\Team Foundation Service Accounts
  [+] GenericRead                        [INSTANCE]\Team Foundation Administrators
  [+] GenericWrite                       [INSTANCE]\Team Foundation Administrators
  [+] TriggerEvent                       [INSTANCE]\Team Foundation Administrators
  [+] GenericRead                        DATUM1\jpeoples

Done.

Im folgenden Beispiel wird die Berechtigung "Informationen auf Auflistungsebene anzeigen" auf Auflistungsebene der Collection0-Teamprojektauflistung für den Benutzer John Peoples der Datum1-Domäne (Datum1\jpeoples) gewährt.

Bild für Kopieren Code kopieren
>tfssecurity /a+ Server FrameworkGlobalSecurity GenericRead n:Datum1\jpeoples ALLOW /collection:http://ADatumCorporation:8080/Collection0

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.
The target Team Foundation Server is http://ADatumCorporation:8080/COLLECTION0.
Resolving identity "n:Datum1\jpeoples"...
  [U] DATUM1\jpeoples (John Peoples)
Adding the access control entry...
Verifying...

Effective ACL on object "FrameworkGlobalSecurity":
  [+] GenericRead                        [Collection0]\Project Collection ValidUsers
  [+] GenericRead                        [Collection0]\Project Collection Service Accounts
  [+] GenericWrite                       [Collection0]\Project Collection Service Accounts
  [+] Impersonate                        [Collection0]\Project Collection Service Accounts
  [+] TriggerEvent                       [Collection0]\Project Collection Service Accounts
  [+] GenericRead                        [Collection0]\Project Collection Administrators
  [+] GenericWrite                       [Collection0]\Project Collection Administrators
  [+] TriggerEvent                       [Collection0]\Project Collection Administrators
  [+] GenericRead                        [INSTANCE]\SharePoint Web Application Services
  [+] Impersonate                        [INSTANCE]\SharePoint Web Application Services
  [+] GenericRead                        [Collection0]\Project Collection Build Service Accounts
  [+] GenericRead                        DATUM1\jpeoples

Done.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups
Default Groups


Befehl "/a-"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/a-"
Siehe auch Feedback senden

Verwenden Sie den /a- -Befehl, um einen Benutzer oder eine Gruppe aus der Mitgliedschaft in einer Gruppe auf Serverebene, Auflistungsebene oder Projektebene zu entfernen. Informationen zum Hinzufügen von Benutzern zu Gruppen über die Benutzeroberfläche finden Sie unter Konfigurieren von Benutzern, Gruppen und Berechtigungen.

Erforderliche Berechtigungen

Um den /a--Befehl zu verwenden, müssen Sie die Berechtigung Informationen auf Auflistungsebene anzeigen oder Instanzebeneninformationen anzeigen auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Wenn Sie die Berechtigungen für ein Teamprojekt ändern, muss zudem die Berechtigung Projektebeneninformationen bearbeiten für das Teamprojekt auf Zulassen festgelegt sein.

TFSSecurity /a- Namespace Token Action Identity (ALLOW | DENY) [/collection:CollectionURL] [/server:ServerURI]

Parameter

Argument

Beschreibung

Namespace

Der Namespace, der die Gruppe enthält, aus der Sie den Benutzer oder die Gruppe entfernen möchten. Sie können auch den TFSSecurity /a-Befehl verwenden, um eine Liste von Namespaces auf der Serverebene, Auflistungsebene und Projektebene anzuzeigen.

Token

Der Name oder die GUID des Objekts, für das Sie Berechtigungen festlegen möchten.

Hinweis Hinweis

Token hängen vom Namespace ab, den Sie angeben. Einige Namespaces verfügen nicht über Token, die für diesen Befehl gültig sind.

Action

Der Name der Berechtigung, für die der Zugriff gewährt oder verweigert wird. Eine Liste gültiger IDs finden Sie unter Team Foundation Server-Berechtigungen, oder verwenden Sie den TFSSecurity /a-Befehl, um eine Liste gültiger Aktionen für einen Namespace anzuzeigen, den Sie angeben.

Identity

Die Identität des Benutzers oder der Gruppe. Weitere Informationen über Identitätsbezeichner finden Sie unter TFSSecurity-Identitätsbezeichner und -Ausgabebezeichner.

  • ALLOW

    Die Gruppe oder der Benutzer kann den von Action angegebenen Vorgang ausführen.

  • DENY

    Die Gruppe oder der Benutzer kann den von Action angegebenen Vorgang nicht ausführen.

/collection:CollectionURL

Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName

/server:ServerURL

Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Bei Zugriffssteuerungseinträgen handelt es sich um Sicherheitsmechanismen, die bestimmen, welche Vorgänge ein Benutzer, eine Gruppe, ein Dienst oder Computer auf einem bestimmten Computer oder Server ausführen darf.

Beispiele

Das folgende Beispiel zeigt, welche Namespaces auf der Serverebene für den Anwendungsebenenserver "ADatumCorporation" verfügbar sind.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
>tfssecurity /a /server:ServerURL

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.

The following security namespaces are available to have permissions set on them:

     Registry
     Identity
     Job
     Server
     CollectionManagement
     Warehouse
     Catalog
     EventSubscription
     Lab

Done.

Das folgende Beispiel zeigt, welche Aktionen auf Auflistungsebene für den Server-Namespace verfügbar sind.

Bild für Kopieren Code kopieren
>tfssecurity /a Server /collection:CollectionURL

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.

The following actions are available in the security namespace Server:
    GenericRead
    GenericWrite
    Impersonate
    TriggerEvent

Done.

Im folgenden Beispiel wird die Berechtigung "Informationen auf Instanzebene anzeigen" auf Serverebene der ADatumCorporation-Bereitstellung für den Benutzer John Peoples der Datum1-Domäne (Datum1\jpeoples) entfernt.

Bild für Kopieren Code kopieren
>tfssecurity /a- Server FrameworkGlobalSecurity GenericRead n:Datum1\jpeoples ALLOW /server:http://ADatumCorporation:8080

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.

The target Team Foundation Server is http://ADatumCorporation:8080/.
Resolving identity "n:Datum1\jpeoples"...
  [U] Datum1\jpeoples (John Peoples)
Removing the access control entry...
Verifying...

Effective ACL on object "FrameworkGlobalSecurity":
  [+] GenericRead                        [INSTANCE]\Team Foundation Valid Users
  [+] GenericRead                        [INSTANCE]\SharePoint Web Application Services
  [+] Impersonate                        [INSTANCE]\SharePoint Web Application Services
  [+] GenericRead                        [INSTANCE]\Team Foundation Service Accounts
  [+] GenericWrite                       [INSTANCE]\Team Foundation Service Accounts
  [+] Impersonate                        [INSTANCE]\Team Foundation Service Accounts
  [+] TriggerEvent                       [INSTANCE]\Team Foundation Service Accounts
  [+] GenericRead                        [INSTANCE]\Team Foundation Administrators
  [+] GenericWrite                       [INSTANCE]\Team Foundation Administrators
  [+] TriggerEvent                       [INSTANCE]\Team Foundation Administrators

Done.

Im folgenden Beispiel wird die Berechtigung "Informationen auf Auflistungsebene anzeigen" auf Auflistungsebene der Collection0-Teamprojektauflistung für den Benutzer John Peoples der Datum1-Domäne (Datum1\jpeoples) entfernt.

Bild für Kopieren Code kopieren
>tfssecurity /a+ Server FrameworkGlobalSecurity GenericRead n:Datum1\jpeoples ALLOW /collection:http://ADatumCorporation:8080/Collection0

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.
The target Team Foundation Server is http://ADatumCorporation:8080/COLLECTION0.
Resolving identity "n:Datum1\jpeoples"...
  [U] DATUM1\jpeoples (John Peoples)
Removing the access control entry...
Verifying...

Effective ACL on object "FrameworkGlobalSecurity":
  [+] GenericRead                        [Collection0]\Project Collection ValidUsers
  [+] GenericRead                        [Collection0]\Project Collection Service Accounts
  [+] GenericWrite                       [Collection0]\Project Collection Service Accounts
  [+] Impersonate                        [Collection0]\Project Collection Service Accounts
  [+] TriggerEvent                       [Collection0]\Project Collection Service Accounts
  [+] GenericRead                        [Collection0]\Project Collection Administrators
  [+] GenericWrite                       [Collection0]\Project Collection Administrators
  [+] TriggerEvent                       [Collection0]\Project Collection Administrators
  [+] GenericRead                        [INSTANCE]\SharePoint Web Application Services
  [+] Impersonate                        [INSTANCE]\SharePoint Web Application Services
  [+] GenericRead                        [Collection0]\Project Collection Build Service Accounts

Done.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups
Default Groups


Befehl "/acl"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Visual Studio Application Lifecycle Management
Befehl "/acl"
Siehe auch Feedback senden

Verwenden Sie /acl, um die Zugriffssteuerungsliste anzuzeigen, die für ein bestimmtes Objekt gilt.

Erforderliche Berechtigungen

Um den /acl-Befehl zu verwenden, müssen Sie die Berechtigung Informationen auf Auflistungsebene anzeigen oder Instanzebeneninformationen anzeigen auf Zulassen festlegen, abhängig davon, ob Sie den /collection-Parameter oder den /server-Parameter verwenden. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSSecurity /acl Namespace Token [/collection:CollectionURL] [/server:ServerURL]

Parameter

Argument

Beschreibung

Namespace

Der Namespace, der die Gruppe enthält, für die Sie Berechtigungen für einen Benutzer oder eine Gruppe anzeigen möchten.

Token

Der Name oder die GUID des Objekts, für das Sie Berechtigungen anzeigen möchten.

Hinweis Hinweis

Token hängen vom Namespace ab, den Sie angeben. Einige Namespaces verfügen nicht über Token, die für diesen Befehl gültig sind.

/collection:CollectionURL

Erforderlich, wenn /server nicht verwendet wird. Gibt die URL der Teamprojektauflistung im folgenden Format an: http://ServerName:Port/VirtualDirectoryName/CollectionName

/server:ServerURL

Erforderlich, wenn /collection nicht verwendet wird. Gibt die URL eines Anwendungsebenenservers im folgenden Format an: http://ServerName:Port/VirtualDirectoryName

Hinweise

Führen Sie diesen Befehl auf einem Anwendungsebenenserver für Team Foundation aus.

Bei Zugriffssteuerungseinträgen handelt es sich um Sicherheitsmechanismen, die bestimmen, welche Vorgänge ein Benutzer, eine Gruppe, ein Dienst oder Computer auf einem bestimmten Computer oder Server ausführen darf.

Beispiele

Im folgenden Beispiel wird gezeigt, welche Benutzer und Gruppen Zugriff auf das FrameworkGlobalSecurity-Token im Server-Namespace innerhalb der ADatumCorporation-Bereitstellung haben.

Hinweis Hinweis

Die Beispiele dienen nur zu Illustrationszwecken und sind frei erfunden. Ähnlichkeiten mit real existierenden Personen oder Gegebenheiten sind rein zufällig und nicht beabsichtigt.

Bild für Kopieren Code kopieren
> tfssecurity /acl Server FrameworkGlobalSecurity /server:ServerURL

Beispielausgabe:

Bild für Kopieren Code kopieren
TFSSecurity - Team Foundation Server Security Tool
Copyright (c) Microsoft Corporation.  All rights reserved.
The target Team Foundation Server is http://ADatumCorporation:8080/.
Retrieving the access control list for object "Server"...

Effective ACL on object "FrameworkGlobalSecurity":
  [+] GenericRead                        [INSTANCE]\Team Foundation Valid Users
  [+] GenericRead                        [INSTANCE]\SharePoint Web Application Services
  [+] Impersonate                        [INSTANCE]\SharePoint Web Application Services
  [+] GenericRead                        [INSTANCE]\Team Foundation Service Accounts
  [+] GenericWrite                       [INSTANCE]\Team Foundation Service Accounts
  [+] Impersonate                        [INSTANCE]\Team Foundation Service Accounts
  [+] TriggerEvent                       [INSTANCE]\Team Foundation Service Accounts
  [+] GenericRead                        [INSTANCE]\Team Foundation Administrators
  [+] GenericWrite                       [INSTANCE]\Team Foundation Administrators
  [+] TriggerEvent                       [INSTANCE]\Team Foundation Administrators
  [+] GenericRead                        DATUM1\jpeoples

Done.

Siehe auch

Weitere Ressourcen

Ändern von Gruppen und Berechtigungen mit TFSSecurity
How to: Create a Global Group
Team Project Groups
Default Groups


Befehl "TFSServiceControl"

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Befehl "TFSServiceControl"
Beispiel Siehe auch Feedback senden

Sie können mithilfe des TFSServiceControl-Befehls alle von Visual Studio Team Foundation Server 2012 (TFS) verwendeten Dienste und Anwendungspools beenden oder starten. Sie verwenden diesen Befehl beispielsweise, wenn Sie Datenbanken sichern oder wiederherstellen, oder wenn Sie die Bereitstellung von einem Computer auf einen anderen verschieben.

Hinweis Hinweis

Sie müssen den TFSServiceControl-Befehl verwenden, um sicherzustellen, dass alle erforderlichen Vorgänge, Dienste und Anwendungspools für Wartungsaufgaben wie Sicherung und Wiederherstellung beendet werden. Sie können nicht alle mit dem TFSServiceControl-Befehl ausgeführten Aufgaben manuell durchführen.

Erforderliche Berechtigungen

Um den TFSServiceControl-Befehl zu verwenden, müssen Sie ein Mitglied der Sicherheitsgruppe Team Foundation Administrators, ein Mitglied der Gruppe Administratoren auf dem Anwendungsebenenserver und ein Mitglied der Sicherheitsgruppe sysadmin für alle SQL Server-Datenbanken sein, die TFS verwendet. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Fenster für erweiterte Eingabeaufforderung öffnen, wenn Sie sich mit Administratoranmeldeinformationen anmelden, um diese Funktion auszuführen.

TFSServiceControl [quiesce|unquiesce]

Parameter

Option | Beschreibung
quiesce | Beendet oder hält alle Dienste, Anwendungspools und Vorgänge in der Bereitstellung von TFS an. Dies ist erforderlich für bestimmte Wartungsaufgaben, z. B. für das Wiederherstellen von Datenbanken.
unquiesce | Startet bzw. führt einen Neustart aller Dienste, Anwendungspools und Vorgänge in der Bereitstellung von TFS durch. Dies ist erforderlich, um den Server wieder in den Betriebszustand zu versetzen, nachdem Sie den Befehl mit der quiesce-Option ausgeführt haben.

Hinweise

Sie verwenden den TFSServiceControl-Befehl im Rahmen bestimmter Wartungsaufgaben. Nachdem Sie die quiesce-Option angegeben haben, funktioniert der Server erst, wenn Sie die unquiesce-Option angeben. Der Befehl TFSServiceControl befindet sich standardmäßig im Verzeichnis %programfiles%\Microsoft Team Foundation Server 2012\Tools.

Beispiel

Im folgenden Beispiel wird gezeigt, wie eine Bereitstellung von Team Foundation Server beendet wird.

Bild für Kopieren Code kopieren
TFSServiceControl quiesce

Im folgenden Beispiel wird gezeigt, wie eine Bereitstellung von Team Foundation Server gestartet wird.

Bild für Kopieren Code kopieren
TFSServiceControl unquiesce

Siehe auch

Aufgaben

Wiederherstellen von Daten an demselben Speicherort

Konzepte

Sichern und Wiederherstellen der Bereitstellung
Die Team Foundation-Verwaltungskonsole

Weitere Ressourcen

Wiederherstellen einer Bereitstellung mit einem Server auf neuer Hardware [Lernprogramm]


TFSDeleteProject: Löschen von Teamprojekten

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSDeleteProject: Löschen von Teamprojekten
Beispiel Siehe auch Feedback senden

Sie können ein Teamprojekt aus Team Foundation Server entfernen, wenn das Projekt nicht mehr erforderlich ist, indem Sie TFSDeleteProject verwenden. Wenn es darüber hinaus Komponenten gibt, die nach einer fehlgeschlagenen Teamprojekterstellung ungelöscht bleiben, können Sie sie mithilfe von TFSDeleteProject entfernen.

Wichtiger Hinweis Wichtig

TFSDeleteProject zerstört das Teamprojekt permanent, wonach es nicht wiederhergestellt werden kann. Sichern Sie alle wichtigen Projektdaten, bevor Sie TFSDeleteProject verwenden.

Um auf das TFSDeleteProject-Befehlszeilentool zuzugreifen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Klicken Sie zum Öffnen eines Eingabeaufforderungsfensters mit erhöhten Rechten auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der Microsoft-Website unter Benutzerkontensteuerung.

Erforderliche Berechtigungen

Zum Verwenden des TFSDeleteProject-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren oder Projektadministratoren sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

TFSDeleteproject [/q] [/force] [/excludewss] /collection:URL TeamProjectName

Parameter

Option | Beschreibung
/q | Dies ist optional. Verwenden des stillen Modus Der Benutzer wird nicht zur Bestätigung aufgefordert.
/force | Dies ist optional. Gibt an, dass der Löschprozess fortgesetzt werden soll, auch wenn einige Komponenten nicht gelöscht werden können.
/excludewss | Dies ist optional. Gibt an, dass die SharePoint-Website, die dem Teamprojekt zugeordnet ist, nicht gelöscht werden soll. Geben Sie diese Option an, um die vorhandene Website beizubehalten, damit andere Teamprojekte sie weiterhin verwenden können.
/collection:URL | Erforderlich. Gibt den URI der Teamprojektauflistung an. Folgendes Format muss für den URI verwendet werden: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname Wenn Sie kein virtuelles Verzeichnis angeben, müssen Sie das folgende Format für den URI verwenden: http://Servername:Port/Auflistungsname.
Teamprojektname | Erforderlich. Der Name des Projekts. Wenn der Name Leerzeichen enthält, schließen Sie sie in Anführungszeichen ein.

Hinweise

Wenn Sie ein Teamprojekt erstellen, erstellt Team Foundation Server Datenobjekte auf dem Server, der Team Foundation Server hostet, und erstellt ggf. Datenobjekte auf dem Server, der SharePoint-Produkte hostet, und auf dem Server, der SQL Server Reporting Services hostet. Wenn Sie ein Teamprojekt entfernen, werden die Berichte automatisch aus SQL Server Reporting Services entfernt.

Wenn Sie ein Teamprojekt entfernen, können Sie auswählen, ob Sie die Objekte entfernen möchten, die erstellt wurden, um die SharePoint-Website zu unterstützen. Ein Fehler kann jedoch Team Foundation Server daran hindern, alle Objekte zu erstellen oder zu löschen. Zur Behebung dieser Probleme finden Sie in den folgenden Abschnitte Hintergrundinformationen, Links zu anderen Ressourcen und bestimmte Schritte, die Ihnen die Bestimmung der Ursache des Problems, die Lösung des Problems, und wenn nötig das Löschen von Datenobjekten ermöglichen, die nach dem Ausführen von TFSDeleteProject übrig bleiben.

  • TFSDeleteProject-Prozess

  • Daten, die ungelöscht bleiben dürfen

  • Überprüfen, ob die Teamprojektkomponenten gelöscht wurden

  • Entfernen von verbleibenden Komponenten nach unvollständigem Löschen des Projekts

  • Timeout-Zeitraum vergrößern

TFSDeleteProject-Prozess

Wenn Sie das TFSDeleteProject-Befehlszeilentool verwenden, werden zuerst Projektdaten und anschließend Projektwebsites gelöscht.

Phase 1: TFSDeleteProject löscht Projektdaten

In der ersten Phase führt TFSDeleteProject die folgenden Schritte automatisch aus, um Teamprojektdaten zu entfernen:

  1. TFSDeleteProject erstellt ein Inventar aller Komponenten, die für das Löschen infrage kommen. Dies schließt Komponenten ein, die mit Test Manager, Team Foundation Build und Team Foundation-Versionskontrolle interagieren.

  2. TFSDeleteProject löscht die Komponente, die den Projektknoten in Team Explorer anzeigt.

  3. TFSDeleteProject kennzeichnet die Versionskontrollinformationen zum Löschen, aber löscht nicht sofort diese Informationen. Die Informationen enthalten alle Versionskontrollenverzweigungen im angegebenen Projekt, aber keine anderen Verzweigungen außerhalb des Projekts.

    • Wenn eine übergeordnete Verzweigung und eine untergeordnete Verzweigung im Projekt vorhanden sind, kennzeichnet TFSDeleteProject beide zum Löschen.

    • Wenn übergeordnete und untergeordnete Verzweigungen in unterschiedlichen Projekten vorhanden sind, kennzeichnet TFSDeleteProject nur die angegebene Verzweigung.

    • Wenn ein anderes Projekt eine Verzweigung aus dem angegebenen Projekt ist, kennzeichnet TFSDeleteProject nur das angegebene Projekt. Wenn das angegebene Projekt gelöscht wird, wird das Verzweigungsprojekt ein Waise.

  4. TFSDeleteProject löscht sofort Builddaten, einschließlich Informations- und Kerndaten, Builddefinitionen, Build-Agents und Testergebnisse, die dem Teamprojekt zugeordnet sind. Das Tool löscht keine Buildablagespeicherorte. Sie müssen nicht den Ablagespeicherort für Builds eines alten Teamprojekts löschen, bevor Sie ein Teamprojekt erstellen, für das derselbe Ablagespeicherort verwendet wird.

    Wenn das angegebene Projekt eine große Menge an Builddaten enthält, kann der Löschvorgang möglicherweise nicht innerhalb des Timeouts beendet werden. Informationen zur Umgehung des Problems finden Sie unter Timeout-Zeitraum vergrößern. Führen Sie anschließend erneut TFSDeleteProject aus.

  5. TFSDeleteProject löscht sofort Arbeitsaufgaben und Arbeitsaufgabenfelder, die zum angegebenen Projekt gehören, und alle nicht freigegebenen Metadaten.

    Wenn das angegebene Projekt eine große Menge an Arbeitsaufgabendaten enthält, kann der Löschvorgang möglicherweise nicht innerhalb des Timeouts beendet werden. Informationen zur Lösung des Problems finden Sie unter Timeout-Zeitraum vergrößern. Führen Sie anschließend erneut TFSDeleteProject aus.

Phase 2: TFSDeleteProject löscht Projektwebsites

In der zweiten Phase löscht TFSDeleteProject die folgenden Daten:

Wichtiger Hinweis Wichtig

Diese Schritte können viel Zeit in Anspruch nehmen. In dieser Zeit kann die Serverleistung abnehmen.

  • TFSDeleteProject Verwendet die Reporting Services-APIs, um Berichte auf dem Server zu löschen, der Reporting Services hostet.

  • TFSDeleteProject löscht die Projektportalwebsite vom Server, der SharePoint-Produkte hostet. Dieser Schritt tritt nur auf, wenn das Projekt die Website besitzt und die Websitelöschung nicht in der Befehlszeile ausgeschlossen ist. (Bedenken Sie, dass mehrere Projekte möglicherweise auf eine einzelne Website verweisen, aber nur eines über die Website verfügen und Berichte/Dashboards standardmäßig verwenden kann.)

    Hinweis Hinweis

    Vor dem Löschen eines Teamprojekts können Sie bestätigen, dass Reporting Services und SharePoint-Produkte die richtigen Projekt-URLs verwenden, indem Sie die Portaleinstellungen überprüfen. Weitere Informationen finden Sie unter How to: Add a Team Project Portal.

Wenn TFSDeleteProject alle oben erwähnten Datenelemente erfolgreich löscht, wird die Meldung Fertig zurückgegeben. Informationen zum Überprüfen dieses Ergebnisses finden Sie unter Überprüfen, ob Teamprojektkomponenten gelöscht wurden.

Wenn eine oder mehrere Komponenten nicht entfernt werden, können Sie TFSProjectDelete mit der /force-Option erneut ausführen, um den Löschprozess fortzusetzen, auch wenn nicht alle Datenelemente gelöscht werden können. Mit dieser Option überspringt TFSDeleteProject eine Komponente, die nicht gelöscht werden kann. Anschließend wird eine Fehlermeldung zurückgegeben, die nächste Komponente wird gelöscht, und die Metadaten und Sicherheitseinstellungen des Teamprojekts bleiben unverändert.

Daten, die ungelöscht bleiben dürfen

Die folgenden Daten könnten in der Bereitstellung bleiben, nachdem TFSDeleteProject erfolgreich abgeschlossen wurde:

  • Teamprojektdaten im Cube. Teamprojektdatenüberreste bleiben im Cube, bis der Cube neu erstellt wird. Zu diesem Zeitpunkt entfernt der Warehouse-Controllerdienst alle historischen Builddaten, die aus den Team Foundation-Datenbanken gelöscht wurden.

  • Buildablagedateien und Ordner. Buildbinärdateien, Buildprotokolldateien und Protokolldateien mit Testergebnissen werden während des Erstellungsprozesses aufgerufen. Die Speicherorte für diese Dateien werden nicht gelöscht. Sie müssen die Dateien gegebenenfalls manuell entfernen.

  • Arbeitsaufgaben-Verfolgungsmetadaten, die freigegeben sind. TFSDeleteProject löscht keine Metadaten für Arbeitsaufgabenverfolgung, die zwischen Teamprojekten freigegeben ist.

  • Versionskontrollen-Shelvesets, die freigegebenen Code enthalten. Versionskontrollen-Shelvesets werden nicht gelöscht, wenn Code im Shelveset aus mehreren Teamprojekten stammt.

Überprüfen von Projektlöschungen

Sie können überprüfen, ob ein Projekt erfolgreich gelöscht wurde, indem Sie sich vergewissern, dass der Teamprojektknoten nicht mehr in Team Explorer angezeigt wird und die zugehörige Projektportal-Website sowie die entsprechenden Berichtsordner nicht mehr vorhanden sind.

So überprüfen Sie, ob ein Teamprojekt gelöscht wurde

  1. Öffnen Sie Team Explorer, und überprüfen Sie, ob das Projekt nicht als Projektknoten angezeigt wird.

  2. Öffnen Sie Internet Explorer, und geben Sie die URL der Projektportalwebsite ein. Überprüfen Sie, ob die Website nicht mehr vorhanden ist.

  3. Geben Sie im Adressfeld von Internet Explorer die URL der Reporting Services-Website in einem der folgenden URL-Formate ein:

    • http://ReportingServices/Reports

    • http://ReportingServices/Reports_TFSInstanz

  4. Klicken Sie im Berichts-Manager auf Details anzeigen.

  5. Überprüfen Sie, ob der Ordner für das gelöschte Teamprojekt nicht mehr angezeigt wird. Klicken Sie auf den Stammordner TfsReports und dann auf den Ordner für die Teamprojektauflistung. Es darf keinen Ordner mit dem Namen des gelöschten Projekts mehr geben.

  6. Wenn entweder die Berichte oder die Website verbleiben, fahren Sie mit der nächsten Prozedur fort.

Entfernen von verbleibenden Komponenten nach unvollständigem Löschen des Projekts

Wenn Projektportalwebsite und -berichtsordner zurückbleiben, nachdem Sie ein Teamprojekt gelöscht haben, entfernen Sie Website und Ordner manuell.

So entfernen Sie manuell Berichte und die Projektportal-Website eines gelöschten Teamprojekts

  1. Melden Sie sich an dem Server an, der Reporting Services für das Teamprojekt hostet, das Sie gelöscht haben.

  2. Öffnen Sie Internet Explorer, und geben Sie im Adressfeld die URL der Reporting Services-Website in einem der folgenden URL-Formate ein:

    • http://localhost/Reports

    • http://localhost/Reports_TFSInstanz

  3. Klicken Sie im Berichts-Manager auf Details anzeigen.

  4. Klicken Sie auf den Stammordner TfsReports und dann auf den Ordner für die Teamprojektauflistung.

  5. Aktivieren Sie das Kontrollkästchen für das gelöschte Teamprojekt.

  6. Klicken Sie auf Löschen.

  7. Klicken Sie auf OK, um zu bestätigen, dass Sie den Berichtsordner für das Teamprojekt löschen möchten.

  8. Informationen zum Entfernen der Projektportalwebsite eines gelöschten Teamprojekts finden Sie auf der folgenden Seite der Microsoft-Website: Gewusst wie: Erstellen von SharePoint-Webanwendungen und -Websites für die Verwendung mit Team Foundation Server.

Timeout-Zeitraum vergrößern

Standardmäßig muss jeder Webdienstaufruf, den der TFSDeleteProject-Befehl ausgibt, um eine Komponente zu löschen, innerhalb von 10 Minuten abgeschlossen werden. Wenn es sechs Aufrufe gibt, kann der Prozess bis zu einer Stunde dauern. Wenn Sie ein Teamprojekt löschen möchten, das einer großen Datenmenge zugeordnet ist, können Sie dieses Timeout vorübergehend vergrößern.

Hinweis Hinweis

Wenn Sie das Timeout vergrößern, wirkt sich die Änderung auf alle Webdienstaufrufe aus. Im Allgemeinen sollte das Timeout nicht länger als 10 Minuten sein, damit Webdienstaufrufe die Serverleistung nicht beeinträchtigen und Benutzer nicht für lange Zeiträume von der Verwendung der Benutzeroberfläche abgehalten werden. Nachdem das Projekt erfolgreich gelöscht wurde, sollten Sie daher als Timeout-Periode wieder 10 Minuten festlegen.

Erforderliche Berechtigungen

Um diese Verfahren durchführen zu können, müssen Sie als Windows-Administrator auf dem Server für die Anwendungsebene angemeldet sein.

Wichtiger Hinweis Wichtig

Eine unsachgemäße Bearbeitung der Registrierung des Computers kann zur Folge haben, dass der Computer instabil wird. Wenn Sie mit der Registrierung nicht vertraut sind, sollten Sie keine Einträge hinzufügen bzw. entfernen oder die Registrierung auf andere Art bearbeiten.

So erhöhen Sie das Timeout für den TFSDeleteProject-Befehl

  1. Melden Sie sich am Anwendungsebenenserver an.

  2. Klicken Sie auf Start und auf Ausführen, geben Sie „regedit" ein, und klicken Sie anschließend auf OK.

  3. Erweitern Sie im Browserfenster HKEY_ LOCAL_MACHINE.

    • Wenn der Server ein 32-Bit-Betriebssystem ausführt, erweitern Sie folgendermaßen: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\11.0\TeamFoundation\RequestSettings.

    • Wenn der Server ein 64-Bit-Betriebssystem ausführt, erweitern Sie folgendermaßen: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432\Microsoft\VisualStudio\11.0\TeamFoundation\RequestSettings.

  4. Wenn der TeamFoundation\RequestSettings-Schlüssel nicht vorhanden ist, führen Sie folgende Schritte aus, um ihn zu erstellen:

    1. Klicken Sie mit der rechten Maustaste auf TeamFoundation, zeigen Sie auf Neu, und klicken Sie dann auf Schlüssel.

    2. Nennen Sie den Schlüssel RequestSettings.

    3. Klicken Sie mit der rechten Maustaste auf RequestSettings. Zeigen Sie dann auf Neu, und klicken Sie auf DWORD-Wert.

    4. Nennen Sie den neuen Wert DefaultTimeout.

  5. Klicken Sie mit der rechten Maustaste auf DefaultTimeout, und wählen Sie die Option Ändern aus.

  6. Geben Sie in Wertdaten das Timeout in Millisekunden ein, und klicken Sie dann auf Dezimal.

    Beispiel: Um das Timeout auf 30 Minuten zu erhöhen, geben Sie 1800000 ein. Um als Timeout wieder eine Dauer von 10 Minuten festzulegen, geben Sie 600000 ein.

  7. Klicken Sie auf OK.

  8. Klicken Sie im Menü Datei auf Beenden.

Beispiel

Der folgende Befehl entfernt alle dem Teamprojekt "StoreFront" auf dem Team Foundation Server-Server "AdventureWorks1" zugeordneten Komponenten in Projektauflistung "Collection1" und von Team Explorer.

Bild für Kopieren Code kopieren
TFSDeleteProject /force /collection:http://AdventureWorks1:8080/tfs/Collection1 StoreFront

Siehe auch

Aufgaben

Erstellen eines Teamprojekts

Konzepte

Herstellen einer Verbindung mit Teamprojekten in Team Foundation Server

Weitere Ressourcen

Verwalten von Berechtigungen
Konfigurieren von Ressourcen für die Unterstützung von Teamprojekten
Verwenden von Team Foundation Server-Befehlszeilentools


TFSFieldMapping

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

TFSFieldMapping
Beispiel Siehe auch Feedback senden

Verwenden Sie das Hilfsprogramm TFSFieldMapping, um die XML-Datei für Projektzuordnungen zu ändern oder anzupassen, nachdem das Teamprojekt erstellt wurde. Sie können zum Beispiel Arbeitsaufgabentypen erstellen oder vorhandene Arbeitsaufgabentypen so ändern, dass sie über neue Attribute verfügen. Weitere Informationen über die Projektzuordnung der XML-Datei finden Sie unter Microsoft Project-Feldzuordnungsdatei.

Um auf das TFSFieldMapping-Befehlszeilentool zuzugreifen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie mit Administratorrechten angemeldet sind, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Klicken Sie zum Öffnen einer Eingabeaufforderung mit erhöhten Rechten auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der Microsoft-Website.

Erforderliche Berechtigungen

Zum Verwenden des TFSFieldMapping-Befehls müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren oder Mitglied der Sicherheitsgruppe Projektadministratoren sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

TFSFieldMapping upload | download /collection:CollectionURL /teamproject:ProjectName /mappingfile:MappingFile

Parameter

Argument

Beschreibung

/collection:CollectionURL

Gibt den URI der Teamprojektauflistung im folgenden Format an: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname

Wenn Sie kein virtuelles Verzeichnis angeben, müssen Sie das folgende Format verwenden:

http://Servername:Port/Auflistungsname

Wenn Sie zuvor eine Verbindung mit dem Server hergestellt haben, können Sie den Anzeigenamen für den Server statt des URIs angeben.

/teamproject:Projektname

Gibt den Namen des Teamprojekts an, dessen Zuordnungsparameter Sie ändern möchten. Wenn der Name Leerzeichen enthält, schließen Sie sie in Anführungszeichen ein.

/mappingfile:Zuordnungsdatei

Gibt den Namen und den Dateipfad der Zuordnungsdatei an.

Befehl | Beschreibung
upload | download | Gibt an, ob die Feldzuordnungsdatei herunter- oder hochgeladen werden soll.

Hinweise

Führen Sie folgende Schritte aus, um die Feldzuordnungsdatei anzupassen:

  1. Laden Sie die Feldzuordnungsdatei mithilfe des Befehlszeilenhilfsprogramms TFSFieldMapping herunter.

  2. Bearbeiten Sie die Feldzuordnungsdatei, indem Sie vorhandene Felder ändern oder benutzerdefinierte Felder und Attribute hinzufügen. Weitere Informationen finden Sie unter Ändern der Zuordnung von Feldern zu Microsoft Project.

  3. Laden Sie die Feldzuordnungsdatei mithilfe des Befehlszeilen-Hilfsprogramms TFSFieldMapping hoch.

Beispiel

Durch den folgenden Befehl wird das Hilfsprogramm TFSFieldMapping angewiesen, die Zuordnungsdatei MappingFile.xml herunterzuladen, die sich auf Laufwerk C befindet. Der Speicherort Ihrer Zuordnungsdatei kann sich unterscheiden.

Bild für Kopieren Code kopieren
>TFSFieldMapping download /collection:http://AdventureWorksServer:8080/tfs/Collection1 /teamproject:AdventureWorks /mappingfile:C:\MappingFile.xml

Im vorherigen Beispiel gelten folgende Werte:

  • URI für die Teamprojektauflistung: http://AdventureWorksServer:8080/tfs/Collection1

  • Projektname: AdventureWorks

  • Zuordnungsdateiname und Pfad: C;\MappingFile.xml

Siehe auch

Aufgaben

Festlegen von Administratorberechtigungen für Teamprojektsammlungen
Ändern der Zuordnung von Feldern zu Microsoft Project

Referenz

Feldzuordnungen in Microsoft Project

Konzepte

Microsoft Project-Feldzuordnungsdatei
Anpassen von Microsoft Project-Feldzuordnungen

Weitere Ressourcen

Einfache Tipps und Unterschiede bei der Nachverfolgung von Aufgaben mit Microsoft Project und Team Foundation
Verwenden von Team Foundation Server-Befehlszeilentools


Angeben des mit Microsoft Test Manager aufzuzeichnenden Fehlertyps

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Angeben des mit Microsoft Test Manager aufzuzeichnenden Fehlertyps
Siehe auch Feedback senden

Wenn Sie Microsoft Test Manager verwenden, können Sie angeben, dass automatisch eine Arbeitsaufgabe erstellt werden soll, wenn ein Tester einen Codefehler entdeckt. Das tcm bugfieldmapping-Befehlszeilentool unterstützt das Importieren und Exportieren einer Zuordnungsdatei in das Teamprojekt. Die Zuordnungsdatei definiert den Typ der zu erstellenden Arbeitsaufgabe sowie die drei Datenfelder, die von Microsoft Test Manager ausgefüllt werden müssen. Die drei Felder sind reproduzierbare Schritte, Systeminformationen und der Build, in dem der Fehler gefunden wurde. Wenn ein Tester einen Test ausführt und einen Defekt findet, kann er einen Fehler erstellen, in dem die drei Felder automatisch ausgefüllt werden.

Hinweis Hinweis

Wurde das Teamprojekt mit einer der Standard-Prozessvorlagen von Team Foundation Server erstellt, ist der Fehlertyp der Arbeitsaufgabe bereits aktiviert. Wenn Sie jedoch der Fehlerkategorie einen anderen Typ von Arbeitsaufgabe hinzufügen oder Sie mit einer benutzerdefinierten Prozessvorlage arbeiten, müssen Sie möglicherweise den tcm-Befehl verwenden.

Um auf das tcm-Befehlszeilentool zuzugreifen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Weitere Informationen zu weiteren tcm-Befehlszeilenoptionen finden Sie unter tcm: Importing and Running Automated Tests for a Test Plan from the Command Line.

Weitere Informationen zum Fehlertyp der Arbeitsaufgabe finden Sie unter Fehler (Scrum), Fehler (Agile) oder Fehler (CMMI).

Erforderliche Berechtigungen

Für das Teamprojekt, in dem die Arbeitsaufgabentypen definiert werden, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation Administrators oder Projektadministratoren sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Klicken Sie zum Öffnen eines Eingabeaufforderungsfensters mit erhöhten Rechten auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Benutzerkontensteuerung.

tcm bugfieldmapping /export /mappingfile:path /collection:CollectionURL /teamproject:Project [/login:username,[password]]
tcm bugfieldmapping /import /mappingfile:path /collection:CollectionURL /teamproject:Project [/login:username,[password]]

Parameter

Parameter

Beschreibung

/export

Gibt einen Export der Fehlerfeldzuordnungsdatei an. Diese Datei definiert den Arbeitsaufgabentyp, der erstellt werden soll, wenn mit Microsoft Test Manager ein Codefehler gefunden wird. Gibt außerdem die Arbeitsaufgabenfelder an, die mit Daten aufgefüllt werden, die in Microsoft Test Manager definiert sind, z. B. die Reproduktionsschritte, Systeminformationen und der Build, in dem der Codefehler gefunden wurde. Weitere Informationen finden Sie weiter unten in diesem Thema unter Inhalt der Fehlerfeldzuordnungsdatei.

/import

Gibt einen Import der Fehlerfeldzuordnungsdatei an.

/mappingfile:Path

Der Pfad und Dateiname der XML-Definitionsdatei, die die Fehlerfeldzuordnungen enthält.

Hinweis Hinweis

Unter Windows Vista verfügen Sie möglicherweise für bestimmte Ordner über keine Berechtigungen. Wenn Sie versuchen, den Arbeitsaufgabentyp nach einem Speicherort zu exportieren, für den Sie keine Berechtigungen festgelegt haben, wird die exportierte Datei durch die Technologie zur Registrierungsvirtualisierung automatisch umgeleitet und in einem virtuellen Speicher gespeichert. Um diese Umleitung zu vermeiden, können Sie die Datei an einen Speicherort exportieren, an dem Sie über ausreichende Berechtigungen verfügen. Weitere Informationen zur Registrierungsvirtualisierung finden Sie auf den folgenden Seiten der Microsoft-Website: Registry Virtualization und Häufige Probleme mit der Datei- und Registrierungsvirtualisierung in Windows Vista.

/collection:CollectionURL

Gibt den URI (Uniform Resource Identifier) der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/VirtuellerVerzeichnisname/Sammlungsname

Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format:

http://Servername:Port/Auflistungsname

/teamproject:Project

Gibt den Namen des Teamprojekts an, für das die Fehlerfeldzuordnungen gelten sollen. Dieses Teamprojekt muss in der vom /collection-Parameter angegebenen Teamprojektauflistung definiert sein.

/login:UserName,Password

Dies ist optional. Gibt den Namen und das Kennwort eines Benutzers an, der am Anwendungsebenenserver für Team Foundation angemeldet ist und über Berechtigungen zum Ausführen des Befehls verfügt.

Sie verwenden diese Option, wenn die Windows-Anmeldeinformationen nicht mit ausreichenden Berechtigungen verbunden sind, wenn Sie die Standardauthentifizierung verwenden oder wenn Sie sich nicht in einer Domäne befinden.

/? oder help

Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Die Fehlerfeldzuordnungsdatei stellt Microsoft Test Manager mit dem Namen des zu erstellenden Arbeitsaufgabentyps und die Felder bereit, die für erstellte Arbeitsaufgaben ausgefüllt werden müssen.

Sie können nur einen zu erstellenden Arbeitsaufgabentyp definieren, wenn Sie Tests ausführen, die Microsoft Test Manager verwenden. Jedes Mal, wenn Sie den tcm bugfieldmapping import-Befehl ausführen, ersetzt der Arbeitsaufgabentyp, der vom BugFilerMappings-Element angegeben wird, den jeweiligen Typ der Arbeitsaufgabe, die zuvor angegeben war. Im folgenden Code wird z. B. die Erstellung der Arbeitsaufgaben, die auf dem Typ "AWBug" basieren, angegeben.

Bild für Kopieren Code kopieren
<BugFilerMappings workitemtypetocreate="AWBug">

Weitere Informationen finden Sie unter Gewusst wie: Senden eines Fehlers mit Microsoft Test-Manager.

Inhalt der Fehlerfeldzuordnungsdatei

Die folgende XML-Syntax führt den Standardinhalt der Fehlerfeldzuordnungsdatei auf. Die Datei gibt den Typ der zu erstellenden Arbeitsaufgabe an sowie die drei Arbeitsaufgabenfelder, die Microsoft Test Manager automatisch basierend auf Daten ausfüllt, die während des Testlaufs ermittelt wurden. Alle drei Felder müssen angegeben werden, wenn Sie eine Fehlerfeldzuordnungsdatei importieren.

Bild für Kopieren Code kopieren
<?xml version="1.0" encoding="utf-16"?>
<BugFilerMappings workitemtypetocreate="Bug">
   <ReproSteps>Microsoft.VSTS.TCM.ReproSteps</ReproSteps>
   <SystemInformation>Microsoft.VSTS.TCM.SystemInfo</SystemInformation>
   <BuildFoundIn>Microsoft.VSTS.Build.FoundIn</BuildFoundIn>
</BugFilerMappings>

Weitere Informationen zu Feldern, die verwendet werden, um von Microsoft Test Manager gefundene Informationen zu verfolgen, finden Sie unter Build and Test Integration.

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URI für die Teamprojektauflistung: http://AdventureWorksServer:8080/tfs/Collection1

  • Projektname: AdventureWorks

  • Fehlerfeldzuordnungs-Dateiname: bugfieldmappings.xml

  • Speicherort des Ordners: "C:\Users\AdminUser\Documents\"

Importieren der Fehlerfeldzuordnungsdatei

Der folgende Befehl importiert den Inhalt der Datei bugfieldmappings.xml in das AdventureWorks-Teamprojekt, das in Collection1 auf dem Server mit dem Namen AdventureWorksServer definiert ist.

Bild für Kopieren Code kopieren
tcm bugfieldmapping /import /mappingfile:"C:\Users\AdminUser\Documents\bugfieldmappings.xml" /collection:http://AdventureWorksServer:8080/tfs/Collection1 /teamproject:AdventureWorks

Siehe auch

Aufgaben

Gewusst wie: Senden eines Fehlers mit Microsoft Test-Manager

Konzepte

Anpassen von Prozessvorlagen
Gewusst wie: Ausführen von automatisierten Tests über die Befehlszeile mit TCM

Weitere Ressourcen

Verwenden von Team Foundation Server-Befehlszeilentools


witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben
Siehe auch Feedback senden

Durch Erstellen und Anpassen von Objekten zur Nachverfolgung von Arbeitsaufgaben können Sie die Art der Nachverfolgung des Teamstatus ändern. Mit dem Befehlszeilentool witadmin können Sie Objekte wie Kategorien, globale Listen, globale Workflows, Linktypen und Arbeitsaufgabentypen erstellen, löschen, importieren und exportieren. Sie können Arbeitsaufgabentypen auch permanent löschen und die Attribute der Felder in einer Arbeitsaufgabe löschen, auflisten oder ändern.

Wie die folgende Abbildung zeigt, verwalten Sie Kategorien und Arbeitsaufgabentypen für jedes Teamprojekt. Sie verwalten globale Listen, Linktypen und Felder in der Arbeitsaufgabe für jede Teamprojektsammlung. Sie können den globalen Workflow für ein Teamprojekt oder für eine Auflistung anpassen.

Objekte für Arbeitsaufgabenverfolgung
Hinweis Hinweis

Sie können Objekte erstellen und ändern, um Arbeitsaufgaben mit dem Prozess-Editor nachzuverfolgen, einem Leistungstool für Visual Studio. Dieses Tool wird nicht unterstützt. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Team Foundation Server Power Tools.

In diesem Thema

  • Anforderungen

  • Globale Parameter

  • Befehlsindex

Anforderungen

Für die Verwendung des witadmin-Befehlszeilentools müssen Sie eine Verbindung mit einem Netzwerk herstellen, auf dem die folgenden Server und die Dienste für Team Foundation Server ausgeführt werden:

  • Anwendungsebenenserver für Team Foundation Server

  • Microsoft SQL Server 2008

  • SQL Server Reporting Services

  • Active Directory-Domänencontroller

  • Internetinformationsdienste (IIS) 6.0 oder 7.0

  • .NET Framework

Um auf das witadmin-Befehlszeilentool zuzugreifen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Das Eingabeaufforderungsfenster wird für das Verzeichnis geöffnet, das das witadmin-Befehlszeilentool enthält.

Globale Parameter

Sie können Hilfetext für witadmin mithilfe der folgenden Parameter anzeigen.

Parameter | Beschreibung
/help oder /? | Zeigt die Syntax und die Parameter für das witadmin-Befehlszeilentool an.
command /help oder command /? | Zeigt die Syntax und die Parameter für den von Ihnen angegebenen witadmin-Befehl an.

Befehlsindex

Aufgaben

Verwandter Inhalt

Erstellen und Ändern von Arbeitsaufgabentypen Anhand von Arbeitsaufgabentypen werden die Felder und Verhaltensweisen für die Erstellung und Verwaltung von Arbeitsaufgaben definiert. Sie können Arbeitsaufgabentypen erstellen und ändern, um die Prozessziele des Teams und des Teamprojekts zu unterstützen.

Sie können die Arbeitsaufgabentypen für ein Teamprojekt verwalten, indem Sie folgende witadmin-Befehle verwenden:

  • destroywitd: Löscht einen Arbeitsaufgabentyp.

  • exportwitd: Exportiert die XML-Definition eines Arbeitsaufgabentyps.

  • importwitd: Importiert die XML-Definition eines Arbeitsaufgabentyps.

  • listwitd: Führt die Namen der Arbeitsaufgabentypen auf.

  • renamewitd: Ändert den Anzeigenamen eines Arbeitsaufgabentyps.

  • Anpassen und Verwalten von Arbeitsaufgabentypen [witadmin]

  • Anpassen von Projektnachverfolgungsdaten, Formularen, Workflow und anderen Objekten

Anpassen der Prozesskonfiguration: Sie können mehrere Prozesskonfigurationselemente so anpassen, dass diese der Agile-Planung und den Scrum-Prozessen entsprechen. Viele dieser Elemente steuern die interaktiven Tools und die visuellen Anzeigen, die mit Visual Studio Team Foundation Server 2012 und Team Web Access bereitgestellt werden.

  • exportagileprocessconfig: Exportiert die XML-Definition für die Prozesskonfigurationsdatei (AgileConfiguration), durch die die Rückstandsseiten für Team Web Access angepasst werden.

  • exportcommonprocessconfig: Exportiert die XML-Definition für die Prozesskonfigurationsdatei (CommonConfiguration), mit der die gemeinsamen Bereiche für Team Web Access und andere Funktionen angepasst werden.

  • importagileprocessconfig: Importiert die XML-Definition für die AgileConfiguration-Datei.

  • importcommonprocessconfig: Importiert die XML-Definition für die CommonConfiguration-Datei.

  • Verwalten der Prozesskonfiguration [witadmin]

  • Anpassen der Prozesskonfiguration

  • XML-Elementreferenz für die Prozesskonfiguration

  • Anpassen der Rückstandsseiten

Definieren und Verwalten von Gruppen für Arbeitsaufgabentypen Mit Kategorien können Sie Arbeitsaufgabentypen gruppieren und Vorgänge für einen gesamten Satz ausführen. Sie können beim Definieren der Kriterien für eine Arbeitsaufgabenabfrage z. B. eine Kategorie angeben, sodass nach allen Arbeitsaufgaben in dieser Kategorie gesucht wird, unabhängig von, ob die Aufgaben unterschiedlichen Typs sind.

Sie können die Arbeitsaufgabenkategorien für ein Teamprojekt verwalten, indem Sie folgende witadmin-Befehle verwenden:

  • exportcategories: Exportiert die XML-Definitionen aller Kategorien.

  • importcategories: Importiert die XML-Definitionen aller Kategorien.

  • Anpassen von Kategorien für Arbeitsaufgabentypen [witadmin]

  • Definieren von Kategorien für Arbeitsaufgabentypen

Erstellen, Ändern, Exportieren, Importieren und Anzeigen globaler Listen für Arbeitsaufgabentypen Mit globalen Listen können Sie Listenelemente für mehrere Arbeitsaufgabentypen freigeben.

Globale Listen für eine Auflistung können Sie mithilfe der folgenden witadmin-Befehle verwalten:

  • destroygloballist: Löscht eine globale Liste.

  • exportgloballist: Exportiert die XML-Definitionsdatei, die mindestens eine globale Liste enthält.

  • importgloballist: Importiert die XML-Datei, mit der mindestens eine globale Liste definiert wird.

  • listgloballist: Führt den Namen der einzelnen globalen Listen auf, die für die Auflistung definiert sind.

  • Verwalten von globalen Listen für Arbeitsaufgabentypen [witadmin]

  • Definieren von globalen Listen

Erstellen, Ändern, Exportieren oder Importieren eines globalen Workflows Mithilfe des globalen Workflows können Sie den Arbeitsaufwand beim Definieren und Aktualisieren von globalen Listen und Feldern in Arbeitsaufgaben verringern, die für zahlreiche Teamprojekte und Arbeitsaufgabentypen verwendet werden. Sie können Definitionen von Feldern und Listenelementen für mehrere Arbeitsaufgabentypen freigeben.

Sie verwalten den globalen Workflow für jedes Teamprojekt oder jede Auflistung mit den folgenden witadmin-Befehlen:

  • exportglobalworkflow: Exportiert die XML-Datei, die einen globalen Workflow definiert.

  • importglobalworkflow: Importiert die XML-Datei, die einen globalen Workflow definiert.

  • Verwalten des globalen Workflows [witadmin]

  • Anpassen des globalen Workflows

Erstellen, Ändern, Aufführen, Aktivieren, Deaktivieren, Importieren und Exportieren von Linktypen. Mithilfe von Linktypen können Sie Arbeitsaufgaben anhand eines Satzes von Linkregeln verknüpfen. Wenn Sie benutzerdefinierte Linktypen erstellen, stehen Ihnen mehr Möglichkeiten für die Nachverfolgung von Arbeitsaufgaben und deren Abhängigkeiten zur Verfügung.

Linktypen für eine Auflistung können Sie mithilfe der folgenden witadmin-Befehle verwalten:

  • deactivatelinktype: Deaktiviert einen angegebenen Linktyp.

  • deletelinktype: Entfernt den angegebenen Linktyp unwiderruflich aus der Datenbank.

  • exportlinktype: Exportiert die XML-Definitionsdateien für einen oder mehrere Linktypen.

  • importlinktype: Importiert die XML-Definitionsdateien für einen oder mehrere Linktypen.

  • listlinktypes: Führt den Satz an Linktypen auf einem Server auf.

  • reactivatelinktype: Aktiviert den angegebenen Linktyp erneut. Sie können Linktypen auch umbenennen.

  • Anpassen und Verwalten von Linktypen [witadmin]

  • Definieren von Linktypen

  • Auswählen von Linktypen für die effektive Nachverfolgung von Projekten

Löschen, Aufführen und Umbenennen der Felder für Arbeitsaufgabentypen sowie Neudefinieren der Felder für Indizierungs- und Berichterstellungsmerkmale. Felder werden zur Suche nach Arbeitsaufgaben und zur Nachverfolgung der darin enthaltenen Informationen verwendet.

Felder für eine Auflistung können Sie mithilfe der folgenden witadmin-Befehle verwalten:

  • deletefield: Löscht das angegebene Feld.

  • listfields:Führt die Attribute für ein angegebenes Feld oder für alle Felder auf.

  • indexfield: Aktiviert bzw. deaktiviert die Indizierung für ein angegebenes Feld.

  • changefield: Ändert eines oder mehrere Attribute eines angegebenen Felds.

  • Verwalten von Arbeitsaufgabenfeldern [witadmin]

  • Definieren von Arbeitsaufgabenfeldern

  • Hinzufügen und Ändern von Arbeitsaufgabenfeldern zum Unterstützen von Berichten

Zerstören von Arbeitsaufgaben Mit dem witadmin destroywi-Befehl können Sie Arbeitsaufgaben permanent aus einer Teamprojektsammlung entfernen.

  • Permanentes Entfernen von Arbeitsaufgaben [witadmin]

Erzwingen einer Neuerstellung des Clientcaches Nach bestimmten Wartungsvorgängen können Sie die Neuerstellung des Caches auf allen Clientcomputern erzwingen, wenn von diesen das nächste Mal eine Verbindung mit einer Teamprojektsammlung hergestellt wird. Sie können die Neuerstellung z. B. erzwingen, nachdem Sie einen Datenebenenserver oder Anwendungsebenenserver verschoben, umbenannt oder wiederhergestellt oder ein Failover ausgeführt haben. Durch das Erzwingen der Neuerstellung vermeiden Sie Arbeitsbereichsfehler während der Versionskontrolle oder bei Buildvorgängen. Für diesen Vorgang verwenden Sie den witadmin rebuildcache-Befehl.

  • Neuerstellen des Clientcaches [witadmin]

Siehe auch

Konzepte

Anpassen von Projektnachverfolgungsdaten, Formularen, Workflow und anderen Objekten

Weitere Ressourcen

Ermitteln der Anforderungen für die Prozess- und Nachverfolgungsanpassung


Anpassen und Verwalten von Arbeitsaufgabentypen [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Anpassen und Verwalten von Arbeitsaufgabentypen [witadmin]
Siehe auch Feedback senden

Sie können die Arbeitsaufgabentypen für ein Teamprojekt verwalten, indem Sie folgende witadmin-Befehle verwenden:

  • destroywitd: Zerstört einen Arbeitsaufgabentyp, und zerstört jede Arbeitsaufgabe dieses Typs permanent ohne Wiederherstellungsmöglichkeit.

  • exportwitd: Exportiert die Definition eines Arbeitsaufgabentyps in eine XML-Datei oder in das Eingabeaufforderungsfenster.

  • importwitd: Importiert Arbeitsaufgabentypen von einer XML-Definitionsdatei in ein Teamprojekt auf einem Server, der Team Foundation Server ausführt. Wenn bereits ein Arbeitsaufgabentyp mit demselben Namen vorhanden ist, wird der vorhandene Arbeitsaufgabentyp durch den neuen überschrieben. Wenn der Arbeitsaufgabentyp nicht bereits vorhanden ist, erstellt dieser Befehl einen neuen Arbeitsaufgabentyp. Zum Überprüfen der XML, die den Arbeitsaufgabentyp definiert, verwenden Sie die /v-Option, jedoch nicht zum Importieren der Datei.

  • listwitd: Zeigt die Namen der Arbeitsaufgabentypen im angegebenen Projekt im Eingabeaufforderungsfenster an.

  • renamewitd: Ändert den Anzeigenamen einer Arbeitsaufgabentyps innerhalb eines bestimmten Projekts. Nachdem Sie diesen Befehl ausgeführt haben, zeigen Arbeitsaufgaben dieses Typs den neuen Namen.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Weitere Informationen zu Arbeitsaufgabentypen finden Sie unter Hinzufügen von Typdefinitionen für Arbeitsaufgaben zu einer Prozessvorlage.

Hinweis Hinweis

Sie können Arbeitsaufgabentypen mit dem Prozess-Editor erstellen und ändern, einem Powertool für Visual Studio. Dieses Tool wird nicht unterstützt. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Team Foundation Server Power Tools.

Anforderungen

Für das Teamprojekt, in dem die Arbeitsaufgabentypen definiert sind, müssen die folgenden Berechtigungen festgelegt sein:

  • Um Arbeitsaufgabentypen zu exportieren oder aufzulisten, müssen Sie Mitglied der Sicherheitsgruppe Projektadministratoren sein, oder für die Berechtigung Projektebeneninformationen anzeigen muss Zulassen festgelegt sein.

  • Zum Zerstören, Importieren oder Umbenennen von Arbeitselementtypen müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren oder der Sicherheitsgruppe Projektadministratoren sein.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Eingabeaufforderungsfenster mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü für die Eingabeaufforderung, und wählen Sie anschließend Als Administrator ausführen aus. Weitere Informationen finden Sie auf der Microsoft-Website unter Benutzerkontensteuerung.

witadmin destroywitd /collection:CollectionURL /p:Project /n:TypeName [/noprompt]
witadmin exportwitd /collection:CollectionURL /p:Project /n:TypeName [/f:FileName] [/e:Encoding] [/exportglobalists]
witadmin importwitd /collection:CollectionURL [/p:Project] /f:FileName [/e:Encoding] [/v]
witadmin listwitd /collection:CollectionURL /p:Project
witadmin renamewitd /collection:CollectionURL /p:Project /n:TypeName /new:NewName [/noprompt]

Parameter

Parameter

Beschreibung

/collection:CollectionURL

Gibt den URI der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname

Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format:

http://Servername:Port/Auflistungsname

/p:Project

Das Teamprojekt, für das die Typen von Arbeitsaufgaben verwaltet werden sollen. Dieses Teamprojekt muss in der vom /collection-Parameter angegebenen Projektsammlung definiert werden.

Der /p -Parameter ist erforderlich, außer wenn Sie den importwitd-Befehl mit der /v-Option ausführen.

/n:TypeName

Der Name des Arbeitsaufgabentyps, der zerstört, exportiert, importiert oder umbenannt werden soll.

/f:FileName

Der Pfad und der Dateiname der XML-Definitionsdatei, die die zu exportierenden oder importierenden Arbeitsaufgabentypen enthält. Wenn Sie diesen Parameter bei Verwendung des Befehls exportwitd weglassen, wird das XML im Eingabeaufforderungsfenster aufgeführt.

Hinweis Hinweis

Wenn Sie Windows Vista verwenden, besitzen Sie möglicherweise für bestimmte Ordner keine Berechtigungen. Wenn Sie versuchen, den Arbeitsaufgabentyp nach einem Speicherort zu exportieren, für den Sie keine Berechtigungen festgelegt haben, wird die exportierte Datei durch die Technologie zur Registrierungsvirtualisierung automatisch umgeleitet und in einem virtuellen Speicher gespeichert. Um diese Umleitung zu vermeiden, können Sie die Datei an einen Speicherort exportieren, an dem Sie über ausreichende Berechtigungen verfügen. Weitere Informationen zur Registrierungsvirtualisierung finden Sie auf der Microsoft-Website: Registrierungsvirtualisierung und Häufige Probleme mit der Datei- und Registrierungsvirtualisierung in Windows Vista.

/e:Codierung

Der Name eines .NET Framework 2.0-Codierungsformats. Der Befehl verwendet die angegebene Codierung, um die XML-Daten zu exportieren oder zu importieren. /e:utf-7 gibt beispielsweise die Unicode (UTF-7)-Codierung an. Wenn Sie diesen Parameter weglassen, versucht witadmin, die Codierung zu erkennen, und bei fehlgeschlagener Erkennung verwendet witadmin UTF-8.

/exportgloballists

Exportiert die Definitionen von globalen Listen, auf die vom Arbeitsaufgabentyp verwiesen wird. Die Definitionen für globale Listen werden in das XML der Arbeitsaufgabentypdefinition eingebettet. Falls nicht angegeben, werden die Definitionen für globale Listen weggelassen.

/v

Überprüft das XML, das den Arbeitsaufgabentyp definiert, importiert jedoch nicht die XML-Definitionsdatei.

Hinweis Hinweis

Sie können die Typdefinition überprüfen, ohne ein Teamprojekt anzugeben. Verweise auf Gruppen aus dem Projektumfang werden ignoriert.

/new:NeuerName

Der neue Name des Arbeitsaufgabentyps.

/noprompt

Deaktiviert die Eingabeaufforderung zur Bestätigung.

/? oder help

Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Wenn Sie den destroywitd-Befehl verwenden, werden damit die folgenden Objekte zerstört:

  • Der Arbeitsaufgabentyp

  • Alle Arbeitsaufgaben dieses Typs

  • Entsprechende Einträge in den Arbeitsaufgabentabellen, den Langtexttabellen und den Linktabellen

  • Objekte im Metadatencache für Arbeitsaufgabentypen

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URI für die Teamprojektauflistung: http://AdventureWorksServer:8080/tfs/DefaultCollection

  • Projektname: AdventureWorks

  • Eingabe- oder Ausgabedateiname: myworkitems.xml

  • Name des Arbeitsaufgabentyps: myworkitem

  • Standardcodierung: UTF-8

Exportieren der Definition eines Arbeitsaufgabentyps

Der folgende Befehl exportiert die Definition für "myworkitem" in die Datei myworkitems.xml.

Bild für Kopieren Code kopieren
witadmin exportwitd /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:AdventureWorks /f:myworkitems.xml /n:myworkitem

Im folgenden Beispiel wird die Arbeitsaufgabe mit Unicode-Codierung (UTF-7) exportiert.

Bild für Kopieren Code kopieren
witadmin exportwitd /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:AdventureWorks /f:myworkitems.xml /n:myworkitem /e:utf-7

Exportieren der Definition eines Arbeitsaufgabentyps und seiner globalen Listen, auf die verwiesen wird.

Im folgenden Beispiel werden sowohl der Arbeitsaufgabentyp als auch die globalen Listen exportiert, auf die er verweist.

Bild für Kopieren Code kopieren
witadmin exportwitd /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:AdventureWorks /f:myworkitems.xml /n:myworkitem /exportgloballists

Auflisten der Definition eines Arbeitsaufgabentyps

Im folgenden Beispiel wird die Definition des Arbeitsaufgabentyps im Eingabeaufforderungsfenster angezeigt.

Bild für Kopieren Code kopieren
witadmin exportwitd /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:AdventureWorks /n:myworkitem

Importieren der Definition von Arbeitsaufgabentypen

Im folgenden Beispiel wird die Arbeitsaufgabendefinition aus der XML-Datei importiert.

Bild für Kopieren Code kopieren
witadmin importwitd /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:myworkitem.xml /p:AdventureWorks

Überprüfen der XML-Definition von Arbeitsaufgabentypen

Im folgenden Beispiel wird das XML überprüft, das den Arbeitsaufgabentyp definiert, aber nicht die Definition importiert.

Bild für Kopieren Code kopieren
witadmin importwitd /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:myworkitem.xml /p:AdventureWorks /v

Siehe auch

Aufgaben

Erstellen eines Arbeitsaufgabentyps

Konzepte

Anpassen von Projektnachverfolgungsdaten, Formularen, Workflow und anderen Objekten

Weitere Ressourcen

witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Anpassen von Kategorien für Arbeitsaufgabentypen [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Anpassen von Kategorien für Arbeitsaufgabentypen [witadmin]
Siehe auch Feedback senden

Sie können die Kategorien für Arbeitsaufgabentypen verwalten, die für ein Teamprojekt definiert sind, indem Sie folgende witadmin-Befehle verwenden:

  • exportcategories: Exportiert die XML-Definition von Kategorien, die auf einem Server definiert wurden, der Team Foundation Server ausführt.

  • importcategories: Importiert eine XML-Definitionsdatei für Arbeitsaufgabentypen in ein Teamprojekt auf einem Server, der Team Foundation Server ausführt.

    Wenn eine Kategorie mit dem gleichen Namen bereits vorhanden ist, überschreibt dieser Befehl die vorhandene Definition. Wenn der Arbeitsaufgabentyp nicht bereits vorhanden ist, erstellt dieser Befehl eine neue Kategorie.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Hinweis Hinweis

Mit dem Prozess-Editor, einem Powertool für Visual Studio, können Sie Kategorien erstellen und bearbeiten. Dieses Powertool wird nicht unterstützt. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Team Foundation Server Power Tools.

Anforderungen

Für das Teamprojekt, für das die Kategorien definiert sind, müssen die folgenden Berechtigungen festgelegt sein:

  • Um Kategorien von Arbeitsaufgabentypen zu exportieren, muss die Berechtigung Projektebeneninformationen anzeigen auf Zulassen festgelegt werden.

  • Um Kategorien von Arbeitsaufgabentypen zu importieren, müssen Sie Mitglied der Sicherheitsgruppe Projektadministratoren sein, oder die Berechtigung Projektebeneninformationen bearbeiten muss auf Zulassen festgelegt werden.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Eingabeaufforderungsfenster mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü Eingabeaufforderung, und wählen Sie Als Administrator ausführen aus. Weitere Informationen finden Sie auf der Microsoft-Website unter Benutzerkontensteuerung.

witadmin exportcategories /collection:CollectionURL /p:Project [/f:FileName] [/e:Encoding]
witadmin importcategories /collection:CollectionURL /p:Project /f:FileName [/e:Encoding]

Parameter

Parameter | Beschreibung
/collection:CollectionURL | Gibt den URI der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format: http://Servername:Port/Auflistungsname.
/p:Project | Der Name des Teamprojekts, aus dem die Kategorien exportiert werden oder in das die Kategorien importiert werden.
/f:Dateiname | Der Pfad und der Dateiname der XML-Definitionsdatei, die die zu exportierenden oder importierenden Kategorien enthält. Wenn Sie diesen Parameter bei Verwendung des Befehls exportcategories weglassen, führt der Befehl die Kategorien im Eingabeaufforderungsfenster auf.
/e:Codierung | Der Name eines .NET Framework 2.0-Codierungsformats. Die angegebene Codierung wird verwendet, um die XML-Daten zu exportieren oder zu importieren. /e:utf-7 gibt beispielsweise die Unicode (UTF-7)-Codierung an. Wenn Sie diesen Parameter weglassen, versucht witadmin die Codierung zu erkennen, und bei fehlgeschlagener Erkennung verwendet witadmin UTF-8.
/? oder help | Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Durch den Import einer Kategoriendatei werden die Kategorien erstellt, sofern sie nicht bereits vorhanden sind. Wenn bereits Kategorien vorhanden sind, gibt der witadmin importcategories-Befehl eine Warnung aus, die darauf hinweist, dass die aktuelle Liste überschrieben wird. Sie können ein eigenes Programm zur Aktualisierung eines vorhandenen Satzes von Kategorien schreiben oder die Kategorien selbst mit neuen Daten aktualisieren.

Wichtiger Hinweis Wichtig

Änderungen an Kategorien können sich auf die Prozesskonfiguration auswirken. Informationen hierzu finden Sie unter Anpassen der Prozesskonfiguration.

Weitere Informationen über die Kategorien der XML-Dateistruktur finden Sie unter Kategorien-Definitionsschemareferenz.

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URI für die Teamprojektauflistung: http://AdventureWorksServer:8080/tfs/DefaultCollection

  • Projektname: AdventureWorks

  • Eingabe- oder Ausgabedateiname: myCategories.xml

  • Standardcodierung: UTF-8

Auflisten der Kategorien von Arbeitsaufgabentypen

Mit dem folgenden Befehl werden die für das Projekt AdventureWorks definierten Arbeitsaufgabentyp-Kategorien aufgelistet.

Bild für Kopieren Code kopieren
witadmin exportcategories /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:AdventureWorks

Exportieren der Kategorien von Arbeitsaufgabentypen

Mit dem folgenden Befehl werden die für das Projekt AdventureWorks definierten Arbeitsaufgabentyp-Kategorien in die XML-Datei myCategories exportiert.

Bild für Kopieren Code kopieren
witadmin exportcategories /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:AdventureWorks /f:myCategories.xml

Importieren der Kategorien von Arbeitsaufgabentypen

Im folgenden Beispiel werden Kategorien aus der XML-Datei "myCategories" in das AdventureWorks-Projekt importiert.

Bild für Kopieren Code kopieren
witadmin importcategories /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:AdventureWorks /f:myCategories.xml

Siehe auch

Konzepte

Anpassen der Prozesskonfiguration

Weitere Ressourcen

Definieren von Kategorien für Arbeitsaufgabentypen
Arbeitsaufgabentypkategorien-Elementverweis
witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Verwalten von globalen Listen für Arbeitsaufgabentypen [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten von globalen Listen für Arbeitsaufgabentypen [witadmin]
Siehe auch Feedback senden

Mit globalen Listen können Sie den Aufwand verringern, der mit der Aktualisierung einer Liste verbunden ist, die von mehreren Arbeitsaufgabentypen genutzt wird. Globale Listen sind Auswahllisten, die Sie in mehrere Felder und Arbeitsaufgabentypen aufnehmen können. Sie können globale Listen für ein Teamprojekt, eine Teamprojektsammlung, eine Prozessvorlage oder den globalen Workflow definieren.

Sie können eine globale Liste in Ihrer eigenen Definitionsdatei, in einer Datei für einen Arbeitsaufgabentyp oder im globalen Workflow definieren. Wenn Sie die global-list-Definition verwenden, können Sie die die für eine Auflistung definierten globalen Listen mit den folgenden Befehlen im witadmin-Befehlszeilentool verwalten:

  • destroygloballist: Zerstört eine globale Liste.

  • exportgloballist: Exportiert die globalen Listen in eine XML-Datei oder in das Eingabeaufforderungsfenster.

  • importgloballist: Importiert globale Listen von einer XML-Datei. Wenn Sie versuchen, eine globale Liste, die bereits auf dem Server vorhanden ist, zu importieren, werden Sie in einer Warnung gefragt, ob Sie die auf dem Server vorhandene Liste überschreiben möchten. Wenn Sie versuchen, eine globale Liste zu importieren, die noch nicht vorhanden ist, erstellt der Befehl eine neue globale Liste.

  • listgloballist: Zeigt den Namen jeder globalen auf dem Server definierten Liste an.

Weitere Informationen finden Sie unter Definieren von globalen Listen und Anpassen des globalen Workflows.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Hinweis Hinweis

Mit dem Prozess-Editor, einem Powertool für Visual Studio, können Sie globale Listen erstellen und bearbeiten. Dieses Tool wird nicht unterstützt. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Team Foundation Server Power Tools.

Anforderungen

Für die Teamprojektauflistung, in der die globalen Listen definiert sind, müssen die folgenden Berechtigungen festgelegt sein:

  • Um globale Listen zu exportieren oder aufzurufen, müssen Sie ein Mitglied der Gruppe Gültige Benutzer für Projektauflistung sein, oder für die Berechtigung Informationen auf Auflistungsebene anzeigen muss Zulassen festgelegt sein.

  • Zum Zerstören oder Importieren von globalen Listen müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren oder der Sicherheitsgruppe Projektadministratoren sein.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Eingabeaufforderungsfenster mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü Eingabeaufforderung, und wählen Sie Als Administrator ausführen aus. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Benutzerkontensteuerung.

witadmin destroygloballist /collection:CollectionURL /n:GlobalListName [/noprompt] [/force]
witadmin exportgloballist /collection:CollectionURL [/f:FileName] [/e:Encoding]
witadmin importgloballist /collection:CollectionURL /f:FileName [/e:Encoding]
witadmin listgloballist /collection:CollectionURL

Parameter

Parameter

Beschreibung

/collection:CollectionURL

Gibt den URI der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname

Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format:

http://Servername:Port/Auflistungsname.

/n:GlobalListName

Der Name der globalen Liste, die zerstört werden soll.

/f:FileName

Der Pfad und der Name der zu exportierenden oder importierenden XML-Definitionsdatei der globalen Listen.

Hinweis Hinweis

Wenn auf dem Clientcomputer Windows Vista ausgeführt wird, haben Sie möglicherweise keine Berechtigungen für bestimmte Ordner. Wenn Sie versuchen, die globale Liste nach einem Speicherort zu exportieren, für den Sie keine Berechtigungen haben, wird die exportierte Datei durch die Technologie zur Registrierungsvirtualisierung automatisch umgeleitet und in einem virtuellen Speicher gespeichert. Weitere Informationen finden Sie auf den folgenden Seiten der Microsoft-Website: Registrierungsvirtualisierung und Häufig auftretende Datei- und Registrierungsvirtualisierungsprobleme in Windows Vista. Um diese Umleitung zu vermeiden, können Sie die Datei an einen Speicherort exportieren, an dem Sie über ausreichende Berechtigungen verfügen.

/e:Encoding

Der Name eines .NET Framework 2.0-Codierungsformats. Die angegebene Codierung wird verwendet, um die XML-Daten zu exportieren oder zu importieren. /e utf-7 gibt beispielsweise die Unicode (UTF-7)-Codierung an. Wenn Sie diesen Parameter weglassen, versucht witadmin die Codierung zu erkennen, und bei fehlgeschlagener Erkennung verwendet witadmin UTF-8.

/noprompt

Deaktiviert die Eingabeaufforderung zur Bestätigung.

/? oder help

Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Durch Importieren einer globalen Liste wird eine Liste erstellt, sofern noch keine vorhanden ist. Wenn die Liste bereits vorhanden ist, gibt der witadmin importgloballist-Befehl eine Warnung aus, die darauf hinweist, dass die aktuelle Liste überschrieben wird. Sie können ein eigenes Programm zur Aktualisierung einer vorhandenen globalen Liste schreiben oder die globale Liste selbst mit den neuen Daten aktualisieren.

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URI für die Teamprojektauflistung: http://AdventureWorksServer:8080/tfs/DefaultCollection

  • Anschlussnummer Serverwebsite: 8080

Anzeigen der Namen globaler Listen

Im folgenden Beispiel werden die auf dem Server definierten globalen Listen gezeigt. In diesem Beispiel werden die globalen Listen mit der Standard-UTF-8-Codierung exportiert:

Bild für Kopieren Code kopieren
witadmin listgloballist /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection

Exportieren der Definition globaler Listen

Im folgenden Beispiel werden die globalen Listen exportiert:

Bild für Kopieren Code kopieren
witadmin exportgloballist /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:C:mygloballists.xml

Im folgenden Beispiel werden dieselben globalen Listen auf denselben Server exportiert, allerdings mit Unicode-Codierung UTF-7.

Bild für Kopieren Code kopieren
witadmin exportgloballist /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:C:mygloballists.xml /e:utf-7

Importieren der Definition globaler Listen

Im folgenden Beispiel werden globale Listen importiert:

Bild für Kopieren Code kopieren
witadmin importgloballist /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:C:mygloballists.xml

Im folgenden Beispiel werden dieselben globalen Listen in denselben Server importiert, allerdings mit Unicode-Codierung UTF-7.

Bild für Kopieren Code kopieren
witadmin importgloballist /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:C:mygloballists.xml /e utf-7

Siehe auch

Aufgaben

Hinzufügen, Verwenden und Verwalten von globalen Listen

Konzepte

Definieren von globalen Listen

Weitere Ressourcen

Anpassen des globalen Workflows
witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Verwalten des globalen Workflows [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten des globalen Workflows [witadmin]
Siehe auch Feedback senden

Mithilfe des globalen Workflows können Sie den Arbeitsaufwand beim Definieren und Aktualisieren von Arbeitsaufgabenfeldern und globale Listen verringern, die für mehrere Teamprojekte und Arten von Arbeitsaufgaben verwendet werden. Mithilfe des globalen Workflows können Sie Felder und globale Listen definieren und aktualisieren. Sie können den globalen Workflow für eine Teamprojektsammlung oder ein Teamprojekt mit den folgenden Befehlen im witadmin-Befehlszeilentool verwalten:

  • exportglobalworkflow: Exportiert den globalen Workflow in eine XML-Datei oder in das Eingabeaufforderungsfenster.

  • importglobalworkflow: Importiert den globalen Workflow von einer XML-Datei.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Weitere Informationen zum globalen Workflow finden Sie unter Anpassen des globalen Workflows.

Anforderungen

  • Um einen globalen Workflow zu exportieren, müssen Sie ein gültiger Benutzer des Teamprojekts oder der Teamprojektauflistung sein.

  • Zum Importieren eines globalen Workflows in ein Teamprojekt müssen Sie Mitglied der folgenden Sicherheitsgruppen sein: Team Foundation Administrators, Projektauflistungsadministratoren oder Projektadministratoren.

  • Zum Importieren eines globalen Workflows in eine Teamprojektauflistung müssen Sie Mitglied einer der folgenden Gruppen sein: Team Foundation Administrators oder Projektauflistungsadministratoren.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Eingabeaufforderungsfenster mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü Eingabeaufforderung, und wählen Sie anschließend Als Administrator ausführen aus. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Benutzerkontensteuerung.

witadmin exportglobalworkflow /collection:CollectionURL [/p:ProjectName] [/f:FileName] [/e:Encoding] [/exportgloballists]
witadmin importglobalworkflow /collection:CollectionURL [/p:ProjectName] /f:FileName [/e:Encoding] [/v]

Parameter

Parameter

Beschreibung

/collection:CollectionURL

Gibt den URI der Auflistung an. Der URI muss im folgenden Format angegeben werden: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname

Wenn Sie kein virtuelles Verzeichnis angeben, muss die URI im folgenden Format angegeben werden:

http://Servername:Port/Auflistungsname.

/p:ProjectName

Dies ist optional. Das Teamprojekt, für das Sie den globalen Workflow exportieren oder importieren möchten. Dieses Teamprojekt muss in der Auflistung definiert sein, die Sie mit dem /collection-Parameter angegeben haben. Wenn Sie kein Teamprojekt angeben, wird der globale Workflow für die Sammlung importiert oder exportiert.

/f:FileName

Der Pfad und der Name der XML-Definitionsdatei für den zu exportierenden oder importierenden globalen Workflow.

Hinweis Hinweis

Wenn auf dem Clientcomputer Windows Vista ausgeführt wird, haben Sie möglicherweise keine Berechtigungen für bestimmte Ordner. Wenn Sie versuchen, die globale Liste nach einem Speicherort zu exportieren, für den Sie keine Berechtigungen haben, wird die exportierte Datei durch die Technologie zur Registrierungsvirtualisierung automatisch umgeleitet und in einem virtuellen Speicher gespeichert. Weitere Informationen finden Sie auf den folgenden Seiten der Microsoft-Website: Registrierungsvirtualisierung und Häufig auftretende Datei- und Registrierungsvirtualisierungsprobleme in Windows Vista. Um diese Umleitung zu vermeiden, können Sie die Datei an einen Speicherort exportieren, an dem Sie über ausreichende Berechtigungen verfügen.

/e:Encoding

Dies ist optional. Der Name eines .NET Framework 2.0-Codierungsformats. Die angegebene Codierung wird verwendet, um die XML-Daten zu exportieren oder zu importieren. /e utf-7 gibt beispielsweise die Unicode (UTF-7)-Codierung an. Wenn Sie diesen Parameter weglassen, versucht witadmin die Codierung zu erkennen und verwendet bei fehlgeschlagener Erkennung UTF-8.

/v

Dies ist optional. Überprüft das XML, das den globalen Workflow definiert, importiert jedoch nicht die Definitionsdatei.

/exportgloballists

Dies ist optional. Exportiert die Definitionen von globalen Listen, auf die der globale Workflow verweist. Die Definitionen für globale Listen werden in die XML-Definition des globalen Workflows eingebettet. Wenn Sie diesen Parameter nicht angeben, werden die Definitionen für globale Listen weggelassen.

/? oder help

Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Sie können Arbeitsaufgabenfelder definieren, indem Sie sie durch einen globalen Workflow importieren. Sie können jedoch die Eigenschaften vorhandener Felder nicht durch Verwendung von globalem Workflow ändern. Wenn Sie einen globalen Workflow importieren, der kein FIELDS-Element enthält, werden alle zuvor importierten Regeln für den globalen Workflow gelöscht. Felddefinitionen sind nicht betroffen.

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URI für die Auflistung: http://AdventureWorksServer:8080/tfs/DefaultCollection

  • Teamprojekt: Contoso

  • Portnummer für die Serverwebsite: 8080

Exportieren der Definition eines globalen Workflows für ein Teamprojekt

Im folgenden Beispiel wird der globale Workflow für ein Teamprojekt exportiert:

Bild für Kopieren Code kopieren
witadmin exportglobalworkflow /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:Contoso /f:C:myGlobalWorkflow.xml

Importieren der Definition eines globalen Workflows in ein Teamprojekt

Im folgenden Beispiel wird der globale Workflow in das Contoso-Teamprojekt importiert:

Bild für Kopieren Code kopieren
witadmin importglobalworkflow /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:Contoso /f:C:collectionGlobalWorkflow.xml

Importieren der Definition eines globalen Workflows in eine Sammlung

Im folgenden Beispiel wird der globale Workflow in die Sammlung importiert:

Bild für Kopieren Code kopieren
witadmin importglobalworkflow /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:C:collectionGlobalWorkflow.xml

Siehe auch

Aufgaben

Hinzufügen, Verwenden und Verwalten von globalen Listen

Konzepte

Definieren von globalen Listen

Weitere Ressourcen

Anpassen des globalen Workflows
witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Verwalten der Prozesskonfiguration [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten der Prozesskonfiguration [witadmin]
Siehe auch Feedback senden

Wenn Sie die Prozesskonfiguration anpassen, können Sie das Layout und die Funktionen anpassen, die über die Rückstands- und Taskboard-Seiten von Team Web Access verfügbar sind. Sie können die aufgelisteten Arbeitsaufgaben, die Reihenfolge, in der sie aufgelistet werden und die Felder konfigurieren, die angezeigt und zum Berechnen des Burndowns und der Kapazität verwendet werden.

Hinweis Hinweis

Wenn Sie die Prozessvorlage oder das Teamprojekt angepasst haben, müssen Sie möglicherweise die Prozesskonfiguration anpassen. Weitere Informationen finden Sie unter Anpassen der Prozesskonfiguration.

Sie können die Prozesskonfiguration für ein Teamprojekt verwalten, indem Sie die folgenden Befehle im witadmin-Befehlszeilentool verwenden:

  • exportagileprocessconfig: Exportiert die Prozesskonfigurationsdefinition, mit der die Rückstandsseiten angepasst werden, in eine XML-Datei oder das Eingabeaufforderungsfenster.

  • exportcommonprocessconfig: Exportiert die gemeinsam verwendete Prozesskonfigurationsdefinition in eine XML-Datei oder das Eingabeaufforderungsfenster.

  • importagileprocessconfig: Importiert die Prozesskonfigurationsdefinition, mit der die Rückstandsseiten aus einer XML-Datei angepasst werden.

  • importcommonprocessconfig: Importiert die gemeinsam verwendete Prozesskonfigurationsdefinition aus einer XML-Datei.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Anforderungen

  • Um Prozesskonfigurationsdefinitionen zu exportieren, müssen Sie ein gültiger Benutzer des Teamprojekts oder der Auflistung sein.

  • Um Prozesskonfigurationsdefinitionen zu importieren, müssen Sie Mitglied der folgenden Sicherheitsgruppen sein: Team Foundation Administrators oder Projektadministratoren.

  • Um die Prozesskonfiguration zu überprüfen und auf die Agile-Planungstools zuzugreifen, die nur von Team Web Access verfügbar sind, muss Ihnen der Team Foundation Server-Administrator Web Access-Berechtigungen erteilen. Möglicherweise gelten zusätzliche Lizenzanforderungen. Weitere Informationen finden Sie unter Zugriff auf Funktionen über Webberechtigungen.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Auch wenn Sie sich mit Administratorberechtigungen anmelden, müssen Sie ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, um den Befehl witadmin auf einem Server mit Windows Server 2008 auszuführen. Klicken Sie zum Öffnen eines Eingabeaufforderungsfensters mit erhöhten Rechten auf Start, klicken Sie mit der rechten Maustaste auf Eingabeaufforderung, und klicken Sie dann auf Als Administrator ausführen. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Benutzerkontensteuerung.

witadmin exportagileprocessconfig /collection:CollectionURL /p:ProjectName [/f:FileName] [/e:encoding]
witadmin exportcommonprocessconfig /collection:CollectionURL /p:ProjectName [/f:FileName] [/e:encoding]
witadmin importagileprocessconfig /collection:CollectionURL [/p:ProjectName] /f:FileName [/e:encoding] [/v]
witadmin importcommonprocessconfig /collection:CollectionURL [/p:ProjectName] /f:FileName [/e:encoding] [/v]

Parameter

Parameter

Beschreibung

/collection:CollectionURL

Gibt die URL der Auflistung an. Der URI muss im folgenden Format angegeben werden: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname

Wenn Sie kein virtuelles Verzeichnis angeben, muss die URI im folgenden Format angegeben werden:

http://Servername:Port/Auflistungsname.

/p:ProjectName

Erforderlich. Das Teamprojekt, für das Sie die Prozesskonfiguration exportieren oder importieren möchten. Dieses Teamprojekt muss in der Auflistung definiert sein, die Sie mit dem /collection-Parameter angegeben haben. Sie müssen kein Teamprojekt angeben, wenn Sie den /v-Schalter angeben.

/f:FileName

Der Pfad und der Name der XML-Definitionsdatei für die zu exportierende oder importierende Prozesskonfiguration.

Hinweis Hinweis

Wenn auf dem Clientcomputer Windows Vista ausgeführt wird, haben Sie möglicherweise keine Berechtigungen für bestimmte Ordner. Wenn Sie versuchen, die globale Liste nach einem Speicherort zu exportieren, für den Sie keine Berechtigungen haben, wird die exportierte Datei durch die Technologie zur Registrierungsvirtualisierung automatisch umgeleitet und in einem virtuellen Speicher gespeichert. Weitere Informationen finden Sie auf den folgenden Seiten der Microsoft-Website: Registrierungsvirtualisierung und Häufig auftretende Datei- und Registrierungsvirtualisierungsprobleme in Windows Vista. Um diese Umleitung zu vermeiden, können Sie die Datei an einen Speicherort exportieren, an dem Sie über ausreichende Berechtigungen verfügen.

/e:Encoding

Dies ist optional. Der Name eines .NET Framework 2.0-Codierungsformats. Die angegebene Codierung wird verwendet, um die XML-Daten zu exportieren oder zu importieren. /e utf-7 gibt beispielsweise die Unicode (UTF-7)-Codierung an. Wenn Sie diesen Parameter weglassen, versucht witadmin die Codierung zu erkennen und verwendet bei fehlgeschlagener Erkennung UTF-8.

/v

Dies ist optional. Überprüft das XML, das die Prozesskonfiguration definiert, importiert jedoch nicht die Definitionsdatei.

/? oder help

Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Wenn Sie ein aktualisiertes Teamprojekt aktualisieren und zum ersten Mal Prozesskonfigurationsdateien importieren, müssen Sie zuerst die Definitionsdatei für CommonConfiguration und dann die Definitionsdatei für AgileConfiguration importieren. Auch die Kategoriedatei muss die Definitionen für die Kategorien enthalten, auf die in der CommonConfiguration-Datei verwiesen wird. Weitere Informationen finden Sie unter Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen.

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URL für die Auflistung: http://AdventureWorksServer:8080/tfs/DefaultCollection

  • Teamprojekt: Contoso

  • Portnummer für die Serverwebsite: 8080

Exportieren der agilen Konfigurationsdefinition für ein Teamprojekt

Im folgenden Beispiel wird die Prozesskonfiguration für die Teamprojektrückstandsseiten exportiert:

Bild für Kopieren Code kopieren
witadmin exportagileprocessconfig /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:Contoso /f:C:AgileConfiguration.xml

Importieren der Agile-Konfigurationsdefinition für ein Teamprojekt

Im folgenden Beispiel wird die Prozesskonfiguration für die Rückstandsseiten in das Contoso-Teamprojekt importiert:

Bild für Kopieren Code kopieren
witadmin importagileprocessconfig /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /p:Contoso /f:C:AgileConfiguration.xml

Siehe auch

Konzepte

Update eines aktualisierten Teamprojekts für den Zugriff auf neue Funktionen
Anpassen der Prozesskonfiguration
XML-Elementreferenz für die Prozesskonfiguration

Weitere Ressourcen

witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Anpassen und Verwalten von Linktypen [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Anpassen und Verwalten von Linktypen [witadmin]
Siehe auch Feedback senden

Sie können die Linktypen verwalten, die für eine Teamprojektauflistung definiert sind, indem Sie folgende witadmin-Befehle verwenden:

  • deactivatelinktype: Deaktiviert den angegebenen Linktyp. Benutzer können keine Links von diesem Typ mehr erstellen. Bereits vorhandene Links dieses Typs funktionieren weiterhin ordnungsgemäß.

  • deletelinktype: Entfernt den angegebenen Linktyp unwiderruflich aus der Datenbank. Alle mit diesem Linktyp definierten Links werden auch entfernt.

  • exportlinktype: Exportiert die Definitionen von Linktypen. Sie können die Definition eines einzelnen Linktyps oder aller für den Server definierten Linktypen exportieren.

  • importlinktype: Importiert die Definitionen der Linktypen von einer XML-Datei. Ist bereits ein Linktyp mit gleichem Verweisnamen vorhanden, wird er aktualisiert, sodass er dem importierten Linktyp entspricht. Ist der Linktyp noch nicht vorhanden, wird ein neuer Linktyp erstellt.

  • listlinktypes: Listet die verfügbare Gruppe von Linktypen auf dem Server auf.

  • reactivatelinktype: Aktiviert den angegebenen Linktyp erneut und weist ihm optional einen neuen Namen zu.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Hinweis Hinweis

Mit dem Prozess-Editor, einem Powertool für Visual Studio, können Sie Linktypen erstellen und bearbeiten. Dieses Tool wird nicht unterstützt. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Team Foundation Server Power Tools.

Anforderungen

Für die Teamprojektauflistung, in der die Linktypen definiert sind, müssen die folgenden Berechtigungen festgelegt sein:

  • Um Linktypen aufzulisten oder zu exportieren, muss die Berechtigung Projektebeneninformationen anzeigen für ein Teamprojekt in der Auflistung auf Zulassen festgelegt werden.

  • Zum Löschen, Importieren oder Reaktivieren von Linktypen müssen Sie Mitglied der Sicherheitsgruppe Projektauflistungsadministratoren sein, oder die Berechtigung Linktypen für Arbeitsaufgaben verwalten muss auf Zulassen festgelegt werden.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Eingabeaufforderungsfenster mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü Eingabeaufforderung, und wählen Sie anschließend Als Administrator ausführen aus. Weitere Informationen finden Sie auf der Microsoft-Website unter Benutzerkontensteuerung.

witadmin deactivatelinktype /collection:CollectionURL /n:LinkName
witadmin deletelinktype /collection:CollectionURL /n:LinkName [/noprompt]
witadmin exportlinktype /collection:CollectionURL [/n:LinkName] [/f:FileName] [/e:Encoding]
witadmin importlinktype /collection:CollectionURL /f:FileName [/e:Encoding] [/v]
witadmin listlinktypes /collection:CollectionURL
witadmin reactivatelinktype /collection:CollectionURL /n:LinkName

Parameter

Parameter | Beschreibung
/collection:CollectionURL | Gibt den URI der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname Beispiel: http://ServerName: 8080/tfs/Collection0 Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format: http://Servername:Port/Auflistungsname
/n:LinkName | Der Name oder der Verweisname des Linktyps, der deaktiviert oder gelöscht werden soll.
/f:FileName | Die XML-Datei der Linktypen Für den Import erforderlich, optional für den Export. Wenn Sie diesen Parameter weglassen, wird die Befehlsausgabe auf der Anzeige angezeigt.
/e:encoding | Der Name eines .NET Framework 2.0-Codierungsformats. Die angegebene Codierung wird verwendet, um die XML-Daten zu exportieren oder zu importieren. /e:utf-7 gibt beispielsweise die Unicode (UTF-7)-Codierung an. Wenn Sie diesen Parameter weglassen, versucht witadmin die Codierung zu erkennen, und bei fehlgeschlagener Erkennung verwendet witadmin UTF-8.
/v | Überprüft den XML-Code für den Linktyp, ohne es zu importieren.
/noprompt | Deaktiviert die Eingabeaufforderung zur Bestätigung.
/? oder help | Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Die Struktur des Linktyp-Definitionsschemas finden Sie unter Linktyp-Elementverweis.

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URI für die Teamprojektauflistung: http://AdventureWorksServer:8080/tfs/DefaultCollection

  • Servername: AdventureWorksServer

  • Eingabe- oder Ausgabedateiname: myLinkTypes.xml

  • Linktyp-Name: mylinktype

  • Standardcodierung: UTF-8

Auflisten von Linktypen

Mit dem folgenden Befehl werden die benutzerdefinierten Linktypen angezeigt, die für Team Foundation AdventureWorksServer definiert wurden.

Bild für Kopieren Code kopieren
witadmin listlinktypes /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection

Auflisten der Definition eines Linktyps

Im folgenden Beispiel wird die Definition des Linktyps im Eingabeaufforderungsfenster angezeigt:

Bild für Kopieren Code kopieren
witadmin exportlinktype /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection

Deaktivieren und anschließend Reaktivieren eines Linktyps

In den folgenden Beispielen wird der Linktyp "mylinktype" deaktiviert und dann erneut aktiviert:

Bild für Kopieren Code kopieren
witadmin deactivatelinktype /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:mylinktype
witadmin activatelinktype /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:mylinktype

Exportieren der Definition eines Linktyps

Der folgende Befehl exportiert die Definition aller Linktypen in die Datei mylinktype.xml:

Bild für Kopieren Code kopieren
witadmin exportlinktype /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:mylinktype.xml

Importieren der Definition von Linktypen

Im folgenden Beispiel wird die Definition der in der XML-Datei definierten Linktypen importiert:

Bild für Kopieren Code kopieren
witadmin importlinktype /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /f:mylinktype.xml

Siehe auch

Aufgaben

Hinzufügen eines Linktyps

Konzepte

Linktyp-Elementverweis
Linking Work Items (Agile)

Weitere Ressourcen

Verknüpfen von Arbeitsaufgaben und Objekten zur Unterstützung der Rückverfolgbarkeit
witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Verwalten von Arbeitsaufgabenfeldern [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Verwalten von Arbeitsaufgabenfeldern [witadmin]
Siehe auch Feedback senden

Sie können die Arbeitsaufgabenfelder verwalten, die für eine Teamprojektauflistung definiert sind, indem Sie folgende witadmin-Befehle verwenden:

  • deletefield: Löscht das angegebene Feld.

  • listfields: Führt die Attribute für alle Felder oder ein angegebenes Feld auf.

  • indexfield: Aktiviert bzw. deaktiviert die Indizierung für das angegebene Feld. Wenn Sie die Indizierung für ein Feld aktivieren, wird möglicherweise mehr Leistung benötigt, um Arbeitsaufgaben zu finden, in deren Abfragen dieses Feld angegeben wird. Wenn Sie ein benutzerdefiniertes Feld hinzufügen, das Sie in vielen Abfragen von Arbeitsaufgaben verwenden, empfiehlt es sich, die Indizierung für dieses Feld zu aktivieren.

  • changefield: Ändert ein oder mehrere Attribute eines Felds, z. B. den Anzeigenamen des Felds, Attribute für die Data Warehouse-Berichterstellung, die Typzuweisung - nur für PlainText und HTML - oder die Fähigkeit, ein Feld zu synchronisieren, das Personennamen enthält. Wenn die Synchronisierung aktiviert ist, wird das Feld aktualisiert, sobald Updates an Active Directory oder einer Arbeitsgruppe vorgenommen werden. Weitere Informationen darüber, wie Felder für die Berichterstellung verwendet werden, finden Sie unter Arbeiten mit Arbeitsaufgabenfeldern.

    Wichtiger Hinweis Wichtig

    Wenn Sie Team Foundation Server von einer früheren Version auf die aktuelle Version aktualisieren, wird die Typzuweisung für das Feld Beschreibung (System.Description) automatisch von PlainText in HTML konvertiert. Mit dem Befehl changefield können Sie den Inhalt dieses Felds so wiederherstellen, dass einfacher Text angezeigt wird.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Eine Übersicht über die Felder, die in den Standardprozessvorlagen von Team Foundation Server definiert sind, finden Sie unter Arbeitsaufgabenfeldverweis für Visual Studio ALM.

Hinweis Hinweis

Mit dem Prozess-Editor, einem Powertool für Visual Studio, können Sie Arbeitsaufgabenfelder erstellen und ändern. Dieses Tool wird nicht unterstützt. Weitere Informationen finden Sie auf der folgenden Seite der Microsoft-Website: Team Foundation Server Power Tools.

Anforderungen

  • Um Felder aufzulisten, muss die Berechtigung Projektebeneninformationen anzeigen für das Teamprojekt in der Auflistung auf Zulassen festgelegt werden.

  • Um Felder zu löschen oder umzubenennen oder um das Attribut eines Felds zu ändern, müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren oder der Sicherheitsgruppe Projektauflistungsadministratoren sein.

Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Eingabeaufforderungsfenster mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü Eingabeaufforderung, und wählen Sie anschließend Als Administrator ausführen aus. Weitere Informationen finden Sie auf der Microsoft-Website unter Benutzerkontensteuerung.

witadmin deletefield /collection:CollectionURL /n:RefName [/noprompt]
witadmin listfields /collection:CollectionURL /n:RefName [/unused]
witadmin indexfield /collection:CollectionURL /n:Name /index:on|off
witadmin changefield /collection:CollectionURL /n:RefName [/name:NewName] [/syncnamechanges:true | false] [/reportingname:ReportingName] [/reportingrefname:ReportingRefName] [/reportingtype:Type] [/reportingformula:Formula]
[type:PlainText | HTML] [/noprompt]

Parameter

Parameter

Beschreibung

/collection:CollectionURL

Gibt den URI der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname

Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format:

http://Servername:Port/Auflistungsname

/n:RefName

/n:Name

Der Verweisname eines Felds des Typs Arbeitsaufgabe.

/index

Gibt an, ob die Indizierung für das angegebene Feld aktiviert oder deaktiviert werden soll. Geben Sie on an, um die Indizierung zu aktivieren, bzw. off, um sie zu deaktivieren.

/name:NewName

Gibt den neuen Namen für das Feld an.

/syncnamechanges

Gibt an, dass das Arbeitsaufgabenfeld zum Speichern von Namen und zur Aktualisierung bei Änderungen in Active Directory oder in einer Arbeitsgruppe verwendet werden sollen. Diese Option ist nur gültig, wenn ein Feld mit dem Datentyp "Zeichenfolge" als typename angegeben wird.

Geben Sie true an, um die Synchronisierung für das Datenfeld zu aktivieren. Geben Sie false an, um die Synchronisierung für das Datenfeld zu deaktivieren.

/reportingname:ReportingName

Gibt den Namen des Felds im Data Warehouse an, das zur Berichterstellung verwendet werden soll.

/reportingrefname:ReportingRefName

Gibt den Verweisnamen des Felds im Data Warehouse an, der zur Berichterstellung verwendet werden soll.

/reportingtype:Type

Dient zum Angeben der Verwendung des Felds im Warehouse für die Berichterstellung. Folgende Werte sind gültig:

  • dimension: Wird für Felder vom Typ Integer, String oder DateTime verwendet.

  • detail: Wird für Felder vom Typ Integer, Double, String oder DateTime verwendet.

  • measure: Wird für Felder vom Typ Integer und Double verwendet. Der Standardaggregationstyp ist "sum". Sie können mit dem formula-Parameter einen anderen Aggregationstyp angeben.

  • disable: Wird verwendet, um die Berichtsmöglichkeit im Feld zu deaktivieren.

Weitere Informationen finden Sie unter Arbeiten mit Arbeitsaufgabenfeldern.

/reportingformula:Formula

Gibt die Aggregationsformel an, die zu verwenden ist, wenn das Feld als measure gemeldet wird. sum ist die einzige unterstützte Formel.

/type:HTML | PlainText

Gibt an, die Inhalte des Felds von PlainText nach HTML oder von HTML nach PlainText zu konvertieren. Sie können diese Option nur für Felder angeben, deren Typzuweisung PlainText oder HTML ist. Siehe FIELD (Definition)-Element.

/unused

Führt alle Felder auf, die von keinem in der Teamprojektauflistung definierten Teamprojekt verwendet werden.

/noprompt

Deaktiviert die Eingabeaufforderung zur Bestätigung.

/? or help

Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Wenn Sie einem Zeichenfolgenfeld das syncnamechanges-Attribut zuweisen, akzeptiert das Feld immer gültige Benutzernamen. Das Feld lässt jedoch keine Gruppennamen zu, die in Team Foundation Server oder Active Directory gespeichert sind, wenn irgendeine der folgenden Bedingungen true ist:

  • Die VALIDUSER-Regel wird übergreifend für alle Arbeitsaufgabentypen angegeben.

  • Die VALIDUSER-Regel wird für einen Arbeitsaufgabentyp angegeben.

  • Die ALLOWEDVALUES-Regel wird für einen Arbeitsaufgabentyp angegeben, und diese Regel besitzt ein Filterkriterium, das Gruppen ausschließt.

Weitere Informationen finden Sie unter XML-Elementreferenz für FIELD.

Eine Zusammenfassung der Systemfelder, die indiziert werden, finden Sie unter Arbeitsaufgabenfeldverweis für Visual Studio ALM.

Beispiele

Falls nicht anders angegeben, gelten in jedem Beispiel die folgenden Werte:

  • URI für die Teamprojektauflistung: http://AdventureWorksServer:8080/tfs/DefaultCollection

  • Name des Arbeitsaufgabenfelds: AdventureWorks.Field

  • Standardcodierung: UTF-8

Auflisten von Feldern

Der folgende Befehl zeigt Informationen zu jedem Feld an, das für Collection1 auf dem Server AdventureWorksServer definiert wurde:

Bild für Kopieren Code kopieren
witadmin listfields /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection

Der folgende Befehl zeigt die Feldinformationen für das angegebene, von Collection1 verwendete Feld "AdventureWorks.Field" an:

Bild für Kopieren Code kopieren
witadmin listfields /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:AdventureWorks.Field

Der folgende Befehl zeigt alle Felder an, die Collection1 nicht verwendet:

Bild für Kopieren Code kopieren
witadmin listfields /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /unused

Umbenennen eines Felds

Mit dem folgenden Befehl wird der Anzeigename des Felds "AdventureWorks.Field", auf das verwiesen wird, für Collection1 in "NewFieldName" geändert:

Bild für Kopieren Code kopieren
witadmin changefield /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:AdventureWorks.Field /name:NewFieldName

Ändern des Berichts als Wert für ein Feld

Der folgende Befehl spezifiziert die Berichtsmöglichkeit für den Typ des DateTime-Felds "AdventureWorks.CreatedOn" gegenüber Dimension. Die Daten dieses Felds gelangen in die Warehouse- und Analysis Services-Datenbanken, damit sie zum Filtern von Berichten verwendet werden können.

Bild für Kopieren Code kopieren
witadmin changefield /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:AdventureWorks.CreatedOn /reportingtype:dimension

Der folgende Befehl spezifiziert die Berichtsmöglichkeit für den Typ des Double-Felds "AdventureWorks.Field" gegenüber Measure. Alle Measures werden durch SUM aggregiert.

Bild für Kopieren Code kopieren
witadmin reportfield /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:AdventureWorks.Field /reportingtype:measure

Aktivieren der Synchronisierung eines benutzerdefinierten Namensfelds

Der folgende Befehl aktiviert die Synchronisierung für das Arbeitsaufgabenfeld "AW.CustomerName", das für Collection1 auf dem AdventureWorksServer definiert wurde.

Bild für Kopieren Code kopieren
witadmin changefield /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:AW.CustomerName /syncnamechanges:true

Löschen eines Felds

Der folgende Befehl löscht das Feld "AdventureWorks.Field" aus Collection1:

Bild für Kopieren Code kopieren
witadmin deletefield /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /n:AdventureWorks.Field

Siehe auch

Aufgaben

Aufführen von Arbeitsaufgabenfeldern und Anzeigen von Attributen, die Feldern zugewiesen sind

Konzepte

Lösen von Schemakonflikten im Data Warehouse
Hinzufügen und Ändern von Arbeitsaufgabenfeldern zum Unterstützen von Berichten
Arbeitsaufgabenfeldverweis für Visual Studio ALM

Weitere Ressourcen

witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Permanentes Entfernen von Arbeitsaufgaben [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Permanentes Entfernen von Arbeitsaufgaben [witadmin]
Siehe auch Feedback senden

Mit dem witadmin destroywi-Befehl können ein oder mehrere Arbeitsaufgaben für eine Teamprojektauflistung endgültig aus der Team Foundation-Datenbank entfernt werden. Arbeitsaufgaben, deren Zustand auf "Geschlossen" festgelegt wurde, verbleiben in der Datenbank und können erneut aktiviert werden. Permanent entfernte Arbeitsaufgaben werden aus der Datenbank entfernt und können nicht wiederhergestellt oder reaktiviert werden.

Jede Arbeitsaufgabe stellt ein Objekt dar, das in der Team Foundation-Datenbank gespeichert wird und dem ein eindeutiger Bezeichner zugewiesen wird, der als Arbeitsaufgaben-ID bezeichnet wird. Arbeitsaufgaben-IDs sind innerhalb einer Projektauflistung eindeutig.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Anforderungen

  • Sie müssen Mitglied der Sicherheitsgruppe Team Foundation-Administratoren oder Mitglied der Sicherheitsgruppe Projektadministratoren für die Teamprojektauflistung sein. Weitere Informationen finden Sie unter Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Fenster für Eingabeaufforderungen mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü Eingabeaufforderung, und wählen Sie anschließend Als Administrator ausführen aus. Weitere Informationen finden Sie auf der Microsoft-Website.

witadmin destroywi /collection:CollectionURL /id:id [/noprompt]

Parameter

Parameter | Beschreibung
/collection:CollectionURL | Gibt den URI der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format: http://Servername:Port/Auflistungsname.
/id:id | Die ID einer zu zerstörenden Arbeitsaufgabe. Um mehrere Arbeitsaufgaben anzugeben, trennen Sie IDs nur mit Kommas (ohne Leerzeichen).
/noprompt | Deaktiviert die Eingabeaufforderung zur Bestätigung.
/? oder help | Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Beispiele

Permanentes Entfernen von Arbeitsaufgaben aus der Datenbank

Im folgenden Beispiel wird die Arbeitsaufgabe 2003 aus der Datenbank für Collection1 auf dem Server AdventureWorksServer gelöscht:

Bild für Kopieren Code kopieren
witadmin destroywi /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /id:2003

Im folgenden Beispiel werden die Arbeitsaufgaben mit den IDs 12, 15 und 23 aus der Datenbank für Collection1 auf dem Server AdventureWorksServer gelöscht:

Bild für Kopieren Code kopieren
witadmin destroywi /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection /id:12,15,23

Siehe auch

Weitere Ressourcen

Lösen, Schließen oder erneutes Aktivieren einer Arbeitsaufgabe
witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Neuerstellen des Clientcaches [witadmin]

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Neuerstellen des Clientcaches [witadmin]
Siehe auch Feedback senden

Sie können das Neuerstellen des Caches auf jedem Clientcomputer erzwingen, wenn er das nächste Mal mithilfe des witadminrebuildcache-Befehls eine Verbindung mit einer Teamprojektauflistung herstellt.

Um während Versionskontroll- oder Buildvorgängen in Team Foundation Fehler im Arbeitsbereich zu verhindern, muss der Datencache auf Clientcomputern nach bestimmten Wartungsvorgängen aktualisiert werden. Nach dem Verschieben, Wiederherstellen, Umbenennen oder Failover eines Datenebenen- oder Anwendungsebenenservers müssen Sie den Cache für die Verfolgung von Arbeitsaufgaben aktualisieren, und die Benutzer müssen den Cache für die Versionskontrolle auf den Clientcomputern aktualisieren.

Wichtiger Hinweis Wichtig

Zur Vermeidung von Problemen mit der Serverleistung empfiehlt es sich, diesen Befehl nicht während der üblichen Geschäftszeiten auszuführen.

Um das witadmin-Befehlszeilentool auszuführen, öffnen Sie ein Eingabeaufforderungsfenster, wo entweder Visual Studio oder Team Explorer installiert ist, und geben Sie Folgendes ein:

Bild für Kopieren Code kopieren
cd %programfiles%\Microsoft Visual Studio 11.0\Common7\IDE

Ersetzen Sie bei einer 64-Bit-Windows-Edition %programfiles% durch %programfiles(x86)%.

Anforderungen

  • Zum Verwenden des Befehls witadmin rebuildcache müssen Sie Mitglied der Sicherheitsgruppe Team Foundation-Administratoren oder der Sicherheitsgruppe Projektadministratoren für die Projektauflistung sein, die Sie verwalten möchten. Team Foundation Server-Berechtigungen und Team Foundation Server: Standardgruppen, Berechtigungen und Rollen.

Hinweis Hinweis

Sie müssen auch dann ein Eingabeaufforderungsfenster mit erhöhten Rechten öffnen, wenn Sie sich mit Administratorrechten anmelden, um diese Funktion auf einem Server nutzen zu können, auf dem Windows Server 2008 ausgeführt wird. Um ein Fenster für Eingabeaufforderungen mit erweiterten Rechten zu öffnen, wählen Sie Start, öffnen Sie das Kontextmenü Eingabeaufforderung, und wählen Sie anschließend Als Administrator ausführen aus. Weitere Informationen finden Sie auf der Microsoft-Website.

witadmin rebuildcache /collection:CollectionURL [/noprompt]

Parameter

Parameter | Beschreibung
/collection:CollectionURL | Gibt den URI der Teamprojektauflistung an. Das Format für den URI sieht folgendermaßen aus: http://Servername:Port/NameDesVirtuellenVerzeichnisses/Auflistungsname Wenn kein virtuelles Verzeichnis verwendet wird, hat der URI das folgende Format: http://Servername:Port/Auflistungsname.
/noprompt | Deaktiviert die Eingabeaufforderung zur Bestätigung.
/? oder help | Zeigt die Hilfe zum Befehl im Eingabeaufforderungsfenster an.

Hinweise

Durch den Befehl witadmin rebuildcache werden auf allen Clients zwischengespeicherte Daten für eine angegebene Teamprojektauflistung ungültig. Dies bewirkt, dass der Cache für jeden Client aktualisiert wird, wenn der Client sich das nächste Mal mit der Projektauflistung verbindet.

Beispiele

Der folgende Befehl macht den Metadatencache für alle Clients ungültig, die eine Verbindung mit DefaultCollection herstellen, die auf dem Server definiert ist, der AdventureWorksServer heißt. Die Clientcaches werden beim nächsten Herstellen der Verbindung mit der Projektauflistung aktualisiert.

Bild für Kopieren Code kopieren
witadmin rebuildcache /collection:http://AdventureWorksServer:8080/tfs/DefaultCollection

Siehe auch

Aufgaben

Aktualisieren des Team Foundation-Clients

Konzepte

Arbeiten mit Team Foundation-Clients

Weitere Ressourcen

witAdmin: Verwalten von Objekten für das Nachverfolgen von Arbeitsaufgaben


Gewusst wie: Ändern der BypassProxyOnLocal-Konfiguration

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Ändern der BypassProxyOnLocal-Konfiguration
Feedback senden

Wenn Visual Studio bei einer Benutzerabfrage in Team Explorer nicht mehr reagiert, müssen Sie Internet Explorer möglicherweise neu konfigurieren, damit dieser keine Anforderungen für lokale Netzwerkressourcen über einen Proxyserver sendet. Wenn in Ihrer Organisation zum Konfiguration von Internet Explorer ein Skript verwendet wird, wird dieses Problem möglicherweise durch einige der darin enthaltenen Einstellungen verursacht.

  • Wenn das Skript in Ihrer Organisation nicht notwendig ist, sollten Sie Internet Explorer so konfigurieren, dass das Skript ignoriert wird und Netzwerkeinstellungen automatisch erkannt werden.

  • Wenn das Skript in Ihrer Organisation erforderlich ist, können Sie dieses möglicherweise aktualisieren, um das Problem zu vermeiden.

  • Wenn Sie das Skript nicht ignorieren oder aktualisieren können, legen Sie den optionalen Registrierungsschlüssel BypassProxyOnLocal für HKEY_CURRENT_USER (für jeden Benutzer) und HKEY_LOCAL_MACHINE (global) auf "true" fest. Bei dieser Konfiguration werden von dem Computer lokale Ressourcen angefordert, ohne dass der LAN-Proxyserver verwendet wird.

    Hinweis Hinweis

    Wenn Sie BypassProxyOnLocal auf "true" festlegen, wird dadurch möglicherweise auch die Leistung beim Ausführen des tf.exe-Befehlszeilentools verbessert.

BypassProxyOnLocal ist standardmäßig nicht konfiguriert, und wenn Internet Explorer für die Verwendung eines automatischen Konfigurationsskripts oder die automatische Erkennung von Einstellungen eingerichtet ist, werden alle URL-Anforderungen über einen Proxyserver weitergeleitet. Wenn Sie diesen Schlüssel konfigurieren und auf "true" festlegen, werden URL-Anforderungen nur dann über den Proxyserver weitergeleitet, wenn sich die angeforderte Ressource außerhalb des Intranets der Organisation befindet. Wenn die Ressource im Intranet der Organisation verfügbar ist, wird die Anforderung nicht über den Proxyserver weitergeleitet. Bei diesen lokalen Anforderungen enthält der URI keinen Punkt (.). Der Browsereintrag http://webserver/ würde zum Beispiel nicht über den Proxyserver weitergeleitet werden. Der Browsereintrag http://www.microsoft.com dagegen würde über den Proxyserver weitergeleitet werden.

Wichtiger Hinweis Wichtig

Das System kann durch fehlerhaftes Bearbeiten der Registrierung schwerwiegend beschädigt werden. Bevor Sie die Registrierung ändern, sollten Sie alle wichtigen Daten auf dem Computer sichern.

Erforderliche Berechtigungen

Um diese Schritte ausführen zu können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren für den lokalen Computer sein.

So deaktivieren Sie die Verwendung eines automatischen Konfigurationsskripts

  1. Öffnen Sie Internet Explorer.

  2. Klicken Sie auf Extras und dann auf Internetoptionen.

  3. Klicken Sie auf der Registerkarte Verbindungen auf LAN-Einstellungen.

  4. Deaktivieren Sie im Dialogfeld Einstellungen für lokales Netzwerk (LAN) das Kontrollkästchen Automatisches Konfigurationsskript verwenden, und klicken Sie anschließend auf OK.

  5. Klicken Sie auf OK, um das Dialogfeld zu schließen.

So konfigurieren Sie den BypassProxyOnLocal-Registrierungsschlüssel

  1. Klicken Sie auf Start und auf Ausführen, geben Sie Regedit ein, und klicken Sie anschließend auf OK.

  2. So legen Sie den Schlüssel für den aktuellen Benutzer fest

    1. Suchen Sie unter HKEY_CURRENT_USER den folgenden Ordner, und klicken Sie darauf: Software\Microsoft\VisualStudio\10.0\TeamFoundation\.

    2. Klicken Sie auf Bearbeiten, auf Neu und anschließend auf Schlüssel.

    3. Geben Sie RequestSettings als Namen für den Schlüssel ein.

    4. Klicken Sie mit der rechten Maustaste auf RequestSettings. Klicken Sie dann auf Neu und Zeichenfolgenwert.

    5. Geben Sie BypassProxyOnLocal als Namen für Zeichenfolge ein.

    6. Klicken Sie mit der rechten Maustaste auf BypassProxyOnLocal und dann auf Ändern. Geben Sie unter Wertdaten den Wert True ein, und klicken Sie dann auf OK.

  3. So legen Sie den Schlüssel global (für alle Benutzer) fest

    1. Suchen Sie unter HKEY_LOCAL_MACHINE den folgenden Ordner, und klicken Sie darauf: Software\Microsoft\VisualStudio\10.0\TeamFoundation\.

    2. Führen Sie die Schritte 2.b. bis 2.d. aus.

  4. Klicken Sie im Menü Datei auf Beenden.


Gewusst wie: Überprüfen oder Korrigieren von Einschränkungen für IP-Adressen und Domänennamen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Überprüfen oder Korrigieren von Einschränkungen für IP-Adressen und Domänennamen
Siehe auch Feedback senden

Überprüfen Sie, ob der Zugriff auf eine Website für Team Foundation anhand der IP-Adresse oder des Domänennamens eingeschränkt wurde, wenn Verbindungsprobleme mit Team Foundation-Anwendungen auftreten. Standardmäßig ist Visual Studio Team Foundation Server so konfiguriert, dass allen Computern Zugriff auf alle Websites für Team Foundation gewährt wird. Bevor Sie Änderungen vornehmen, müssen Sie den Grund für die Einschränkungen bestimmen. Viele Organisationen ändern die Standardeinschränkungen entsprechend den Infrastrukturanforderungen oder Sicherheitsrichtlinien.

Erforderliche Berechtigungen

Damit Sie diese Schritte ausführen können, müssen Sie auf dem Anwendungsebenenserver für Team Foundation Mitglied der Sicherheitsgruppe Administratoren sein.

So prüfen oder ändern Sie Einschränkungen für Websites anhand von IP-Adresse oder Domänennamen in IIS 6.0

  1. Melden Sie sich bei dem Anwendungsebenenserver an.

  2. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetinformationsdienste-Manager.

  3. Erweitern Sie im Strukturbereich den lokalen Computer, und erweitern Sie Websites.

  4. Klicken Sie mit der rechten Maustaste auf die Website, für die Sie Einschränkungen anhand von IP-Adressen oder Domänennamen überprüfen oder ändern möchten (z. B. Standardwebsite), und klicken Sie auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Verzeichnissicherheit im Abschnitt Einschränkungen für IP-Adressen und Domänennamen auf Bearbeiten.

  6. Überprüfen Sie, ob Zugriff gewährt aktiviert ist.

  7. Löschen Sie alle unerwünschten Einschränkungen.

  8. Klicken Sie auf OK, auf Übernehmen und erneut auf OK.

  9. Wiederholen Sie die Schritte 4 bis 8 für alle weiteren Websites.

So prüfen oder ändern Sie Einschränkungen für Websites anhand von IP-Adresse oder Domänennamen in IIS 7.0

  1. Melden Sie sich bei dem Anwendungsebenenserver an.

  2. Klicken Sie auf Start und zeigen Sie auf Verwaltung, klicken Sie mit der rechten Maustaste auf Internetinformationsdienste-Manager, und klicken Sie dann auf Als Administrator ausführen.

  3. Erweitern Sie im Strukturbereich den lokalen Computer, und erweitern Sie Websites.

  4. Klicken Sie auf die Website, die Sie überprüfen oder ändern möchten (z. B. Team Foundation Server).

  5. Doppelklicken Sie im Bereich Website Privat auf Einschränkungen für IPv4-Adressen und Domänen.

  6. Klicken Sie auf eine IP-Adresse oder Domäne in der Liste und dann auf Entfernen. Klicken Sie auf Ja, um zu bestätigen, dass Sie die Einschränkung entfernen möchten.

    Wiederholen Sie diesen Schritt für alle Einschränkungen, die Sie entfernen möchten.

Siehe auch

Aufgaben

Überprüfen von Serverstatus und -einstellungen
Beenden und Starten von Diensten, Anwendungspools und Websites

Konzepte

Verwalten der Serverkonfiguration


Gewusst wie: Aktivieren des TCP/IP-Protokolls für eine Datenbankinstanz

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Aktivieren des TCP/IP-Protokolls für eine Datenbankinstanz
Siehe auch Feedback senden

Bei einer Bereitstellung von Team Foundation Server auf mehreren Servern müssen Sie das TCP/IP-Protokoll für die Team Foundation-Datenbank aktivieren. Mit der Aktivierung dieses Protokolls verfügen Sie über Unterstützung für Remoteverbindungen wie die Verbindung zwischen dem Anwendungsebenenserver und dem Datenebenenserver für Team Foundation. Wenn das TCP/IP-Protokoll nicht sowohl für die Datenbankinstanz als auch den SQL Server Native Client aktiviert ist, werden möglicherweise die folgenden Fehler angezeigt:

  • Fehler 29108. Team Foundation-Berichtsserverkonfiguration: Verbindung mit Team Foundation-Datenebene kann beim Konfigurieren der Berichtsserverdatenbank nicht hergestellt werden.

  • TF31001: Team Foundation kann die Liste von Teamprojekten aus Team Foundation Server nicht abrufen. Team Foundation Server gab folgenden Fehler zurück: Fehler bei der Anforderung mit HTTP-Status 503: TF30059: Schwerwiegender Fehler beim Initialisieren des Webdiensts.

Erforderliche Berechtigungen

Damit Sie diese Schritte ausführen können, müssen Sie Mitglied der Sicherheitsgruppe sysadmin für SQL Server auf dem Datenebenenserver für Team Foundation sein.

So aktivieren Sie das TCP/IP-Protokoll für die Datenbankinstanz

  1. Melden Sie sich bei dem Datenebenenserver an, auf dem die Datenbankinstanz definiert ist.

  2. Zeigen Sie im Menü Start auf Alle Programme, auf Microsoft SQL Server 2005 oder Microsoft SQL Server 2008, auf Konfigurationstools, und klicken Sie anschließend auf SQL Server-Konfigurations-Manager.

  3. Klicken Sie im Strukturbereich auf SQL Server 2005-Dienste oder SQL Server 2008-Dienste.

  4. Überprüfen Sie im Ergebnisbereich, ob in der Spalte Zustand neben dem Namen jedes Diensts Aktiv angezeigt wird.

    Wenn Beendet angezeigt wird, klicken Sie mit der rechten Maustaste auf den Namen des Diensts, und klicken Sie dann auf Starten.

  5. Klicken Sie im Strukturbereich zum Erweitern auf SQL Server 2005-Netzwerkkonfiguration oder SQL Server 2008-Netzwerkkonfiguration, und klicken Sie dann auf Protokolle für MSSQLServer/MeinInstanzname.

    Wenn Sie bei der Installation die Standardinstanz angegeben haben, ist der Instanzname MSSQLSERVER.

  6. Überprüfen Sie im Ergebnisbereich, ob in der Spalte Status neben dem Namen des TCP/IP-Protokolls Aktiviert angezeigt wird.

    Wenn Deaktiviert angezeigt wird, klicken Sie mit der rechten Maustaste auf TCP/IP, und klicken Sie dann auf Aktivieren.

  7. Klicken Sie im Strukturbereich zum Erweitern auf SQL Native Client-Konfiguration, und klicken Sie dann auf Clientprotokolle.

  8. Überprüfen Sie im Ergebnisbereich, ob in der Spalte Status neben dem Namen des TCP/IP-Protokolls Aktiviert angezeigt wird.

    Wenn Deaktiviert angezeigt wird, klicken Sie mit der rechten Maustaste auf TCP/IP, und klicken Sie dann auf Aktivieren.

  9. Klicken Sie im Strukturbereich auf SQL Server 2005-Dienste oder SQL Server 2008-Dienste.

  10. Klicken Sie im Ergebnisbereich mit der rechten Maustaste auf SQL Server (MSSQLServer/MeinInstanzname), und klicken Sie dann auf Neu starten.

Siehe auch

Konzepte

Team Foundation Server-Datenbanken
Verwalten der Serverkonfiguration


Gewusst wie: Überprüfen oder Korrigieren von Portzuweisungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Überprüfen oder Korrigieren von Portzuweisungen
Siehe auch Feedback senden

Standardmäßig wird Team Foundation Server für die Verwendung bestimmter Netzwerkports und Netzwerkprotokolle konfiguriert. Mit der Firewalllösung werden Remoteverbindungen und die Verwendung dieser Ports gesteuert. Änderungen an den Portzuweisungen für eine Website können sich auf den Zugriff auf die Website und Webdienste auswirken. Eine Liste von Webdiensten, Netzwerkports und Protokollen für Team Foundation finden Sie unter Architektur von Team Foundation Server.

Zunächst können Sie Portzuweisungen für Team Foundation-Websites und -Webdienste überprüfen, indem Sie die Verwaltungskonsole für Team Foundation öffnen, die Seite für die Anwendungsebene anzeigen und die URL-Zuweisungen überprüfen. Klicken Sie gegebenenfalls auf URL ändern, um die URL einer Website zu ändern. Weitere Informationen finden Sie unter Überprüfen von Serverstatus und -einstellungen.

Danach können Sie anhand der später in diesem Thema beschriebenen Prozeduren die Portzuweisungen für Internetinformationsdienste (IIS) und die für die Firewall zulässigen Ports überprüfen.

Wenn in Ihrer Organisation eine andere Firewalllösung als die Windows-Firewall verwendet wird, finden Sie weitere Informationen in der Dokumentation für die betreffende Lösung.

Hinweis Hinweis

Bestimmen Sie vor Änderungen, weshalb die Portbindungen für eine Website geändert wurden. Organisationen ändern die Standardportzuweisungen häufig entsprechend den Infrastrukturanforderungen oder Sicherheitsrichtlinien.

Erforderliche Berechtigungen

Damit Sie diese Schritte ausführen können, müssen Sie auf dem Anwendungsebenenserver für Team Foundation Mitglied der Sicherheitsgruppe Administratoren sein.

So überprüfen oder ändern Sie die Portzuweisung für eine Website in IIS 6.0

  1. Melden Sie sich bei dem Anwendungsebenenserver an.

  2. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und zeigen Sie anschließend auf Internetinformationsdienste-Manager.

  3. Erweitern Sie im Strukturbereich den lokalen Computer, und erweitern Sie Websites.

  4. Klicken Sie mit der rechten Maustaste auf die Website, deren Portzuweisungen Sie überprüfen oder ändern möchten (z. B. Standardwebsite), und klicken Sie auf Eigenschaften.

  5. Überprüfen oder ändern Sie auf der Registerkarte Website den Wert für TCP-Port wieder in den Standardwert oder einen von der Sicherheitsrichtlinie Ihrer Organisation festgelegten Wert.

  6. Klicken Sie auf Übernehmen, um die Änderung zu bestätigen, und dann auf OK.

So überprüfen oder ändern Sie die Portzuweisung für eine Website in IIS 7.0

  1. Melden Sie sich bei dem Anwendungsebenenserver an.

  2. Klicken Sie auf Start und zeigen Sie auf Verwaltung, klicken Sie mit der rechten Maustaste auf Internetinformationsdienste-Manager, und klicken Sie dann auf Als Administrator ausführen.

  3. Erweitern Sie im Strukturbereich den lokalen Computer, und erweitern Sie Websites.

  4. Klicken Sie auf die Website, deren Portzuweisungen Sie überprüfen oder ändern möchten (z. B. Standardwebsite).

  5. Klicken Sie im Bereich Aktionen auf Bindungen.

    Das Dialogfeld Websitebindungen wird geöffnet.

  6. Klicken Sie auf Bearbeiten, und ändern Sie dann den Wert für den Port in die Standardzuweisung.

  7. Klicken Sie auf OK, um die Änderung zu bestätigen, und klicken Sie dann auf Schließen.

So überprüfen oder ändern Sie die Portzuweisungen für die Windows-Firewall in Windows Server 2003

  1. Klicken Sie auf Start, zeigen Sie auf Systemsteuerung, und klicken Sie dann auf Windows-Firewall.

  2. Vergewissern Sie sich, dass auf der Registerkarte Ausnahmen die Kontrollkästchen für die Programme in der folgenden Tabelle aktiviert sind:

    Website

    Port

    Team Foundation Server TFSSharepointApplication:80

    80

    Team Foundation Server TFSSharepointAdmin:17012 oder SharePoint-Zentraladministrationsdienst 3.0

    17012 (bei Installation mit Team Foundation Server; andernfalls nach dem Zufallsprinzip generiert)

    Team Foundation Server TFSWebSite:8080

    8080

  3. Klicken Sie auf jede Website, klicken Sie auf Bearbeiten, und stellen Sie sicher, dass die Portnummer mit der Nummer für das Programm in der oben stehenden Tabelle oder für Ihre Organisation übereinstimmt.

    Hinweis Hinweis

    In der oben stehenden Tabelle sind die Standardports aufgeführt. Wenn Sie für die Bereitstellung nicht die Standardports verwenden, müssen Sie sicherstellen, dass die Portnummern für die Bereitstellung geeignet sind.

  4. Fügen Sie anhand der folgenden Anleitung eine Ausnahme hinzu, wenn der betreffende Dienst nicht aufgeführt wird:

    1. Klicken Sie auf Port hinzufügen.

    2. Geben Sie im Feld Name den Namen des Diensts ein.

      Dieser Text muss nicht mit dem Produktnamen übereinstimmen. Es muss sich nur um beschreibenden Text handeln.

    3. Geben Sie im Feld Portnummer die Portnummer ein.

    4. Stellen Sie sicher, dass TCP aktiviert ist.

    5. Klicken Sie auf OK.

  5. Klicken Sie auf OK.

  6. Vergewissern Sie sich, dass die Anwendungspools und Websites ausgeführt werden. Informationen zum Überprüfen und Neustarten von Anwendungspools und Websites finden Sie unter Beenden und Starten von Diensten, Anwendungspools und Websites.

So überprüfen oder ändern Sie die Portzuweisungen für die Windows-Firewall in Windows Server 2008

  1. Klicken Sie im Startmenü auf Systemsteuerung.

  2. Klicken Sie auf Netzwerk und Internet.

  3. Klicken Sie auf Programm durch die Windows-Firewall kommunizieren lassen.

    Das Dialogfeld Windows-Firewalleinstellungen wird geöffnet.

  4. Vergewissern Sie sich, dass auf der Registerkarte Ausnahmen die Kontrollkästchen für die Programme in der folgenden Tabelle aktiviert sind:

    Website

    Port

    Team Foundation Server TFSSharepointApplication:80

    80

    Team Foundation Server TFSWebSite:8080

    8080

    Team Foundation Server TFSSharepointAdmin:17012

    17012 (bei Installation mit Team Foundation Server; andernfalls nach dem Zufallsprinzip generiert)

  5. Klicken Sie auf jede Website, klicken Sie auf Eigenschaften, und stellen Sie sicher, dass die Portnummer mit der Nummer für das Programm in der oben stehenden Tabelle übereinstimmt.

    Hinweis Hinweis

    In der oben stehenden Tabelle sind die Standardports aufgeführt. Wenn Sie für die Bereitstellung nicht die Standardports verwenden, müssen Sie sicherstellen, dass die Portnummern für die Bereitstellung geeignet sind.

  6. Fügen Sie anhand der folgenden Anleitung eine Ausnahme hinzu, wenn das Programm nicht aufgeführt wird:

    1. Klicken Sie auf Port hinzufügen.

    2. Geben Sie im Feld Name den Namen des Programms ein.

      Dieser Text muss nicht mit dem Produktnamen übereinstimmen. Es muss sich nur um beschreibenden Text handeln.

    3. Geben Sie im Feld Portnummer die Portnummer ein.

    4. Stellen Sie sicher, dass TCP aktiviert ist.

    5. Klicken Sie auf OK.

  7. Klicken Sie auf OK.

  8. Vergewissern Sie sich, dass die Anwendungspools und Websites ausgeführt werden. Informationen zum Überprüfen und Neustarten von Anwendungspools und Websites finden Sie unter Beenden und Starten von Diensten, Anwendungspools und Websites.

Siehe auch

Konzepte

Verwalten der Serverkonfiguration


Gewusst wie: Überprüfen oder Korrigieren von Serverbindungszuweisungen

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Gewusst wie: Überprüfen oder Korrigieren von Serverbindungszuweisungen
Siehe auch Feedback senden

Wenn beim Zugriff auf Websites oder Webdienste für Team Foundation Probleme auftreten, sollten Sie überprüfen, ob die Serverbindungszuweisungen für eine oder mehrere Websites geändert wurden. Standardmäßig konfiguriert Team Foundation Server nicht mehrere Identitäten für die Team Foundation-Websites. Allerdings ändern Organisationen häufig die Standardserverzuweisungen entsprechend ihrer Infrastrukturanforderungen oder Sicherheitsrichtlinien.

Team Foundation Server verwendet die Standardidentitäten in der folgenden Tabelle:

Dienst | IP-Adresse | Hostheaderwert
Standardwebsite | (Keine zugewiesen) | Keine
Team Foundation Server Webdienst | (Keine zugewiesen) | Keine
SharePoint-Zentraladministration-Dienst | (Keine zugewiesen) | Keine
Hinweis Hinweis

Stellen Sie vor dem Ändern von Zuweisungen fest, warum die Serverbindungen für eine Website geändert wurden, um nicht gegen Organisationsrichtlinien zu verstoßen.

Erforderliche Berechtigungen

Damit Sie diese Prozedur ausführen können, müssen Sie Mitglied der Sicherheitsgruppe Administratoren auf dem Anwendungsebenenserver für Team Foundation sein.

So überprüfen oder ändern Sie die Serverbindungszuweisungen in IIS 6.0

  1. Melden Sie sich am Anwendungsebenenserver an.

  2. Klicken Sie auf Start, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetinformationsdienste-Manager.

  3. Erweitern Sie im Strukturbereich den lokalen Computer, und erweitern Sie Websites.

  4. Klicken Sie mit der rechten Maustaste auf die Website, die Sie überprüfen oder ändern möchten (z. B. Standardwebsite), und klicken Sie auf Eigenschaften.

  5. Klicken Sie auf der Registerkarte Website auf Erweitert.

  6. Ändern Sie im Dialogfeld Erweiterte Identifikation für Websites die Identitäten für die entsprechende Website.

  7. Klicken Sie auf OK, um die Änderung zu übernehmen.

  8. Klicken Sie auf OK, um das Dialogfeld zu schließen.

So überprüfen oder ändern Sie die Serverbindungszuweisungen in IIS 7.0

  1. Melden Sie sich am Anwendungsebenenserver an.

  2. Zeigen Sie im Startmenü auf Verwaltung, klicken Sie mit der rechten Maustaste auf Internetinformationsdienste-Manager, und klicken Sie dann auf Als Administrator ausführen.

  3. Erweitern Sie im Strukturbereich den lokalen Computer, und erweitern Sie Websites.

  4. Klicken Sie auf die Website, die Sie überprüfen oder ändern möchten (z. B. Standardwebsite).

  5. Klicken Sie im Bereich Aktionen auf Bindungen.

  6. Bearbeiten Sie im Dialogfeld Websitebindungen die Identitäten für die entsprechende Website, und klicken Sie dann auf Schließen.

Siehe auch

Aufgaben

Überprüfen von Serverstatus und -einstellungen

Konzepte

Verwalten der Serverkonfiguration


Sichern von Lab-Management-Komponenten

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

Sichern von Lab-Management-Komponenten
Feedback senden

Dieses Thema ist nicht mehr aktuell. Aktuelle Informationen finden Sie unter Back Up Team Foundation Server.


PreEmptive Analytics

 Bild für Reduzieren Bild für Erweitern Bild für Kopieren Bild für Mauszeiger über Kopieren
[image]

PreEmptive Analytics
Siehe auch Feedback senden

PreEmptive Analytics bietet eine Reihe von Tools, die Einblicke in Anwendungsübernahmen, Benutzerverhalten und Softwarequalität unterstützt.

Weitere Informationen

Weitere Informationen zu diesen Tools und zu deren Verwendung finden Sie auf der PreEmptive Solutions-Website.

Siehe auch

Aufgaben

Öffnen der Team Foundation-Verwaltungskonsole

Konzepte

Die Team Foundation-Verwaltungskonsole
Installieren von Team Foundation Server und Visual Studio ALM