Export-SPEnterpriseSearchTopology
Example
[image]

Saves an existing search topology.

Export-SPEnterpriseSearchTopology -Filename <String> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Filename

Required

System.String

Specifies the path and file name to use to create the topology XML file.

The type must be a valid path, in the form MyFeature\Feature.xml.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application with the topology to export.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Export-SPEnterpriseSearchTopology cmdlet exports the topology for a shared search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

            Click here to

      submit feedback
             on this topic.


Get-SPEnterpriseSearchCrawlContentSource
See Also Example
[image]

Returns a crawl content source.

Get-SPEnterpriseSearchCrawlContentSource [-Identity <ContentSourcePipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ContentSourcePipeBind

Specifies the content source to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a ContentSource object (for example, ContentSource1); or an instance of a valid ContentSource object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the content source.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchCrawlContentSource cmdlet reads the content source when the rules of content source are created, updated, or deleted, or reads a CrawlContentSource object when the search functionality is initially configured and after any new content source is added.

If the Identity parameter is not specified, this cmdlet returns the content source collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchCrawlContentSource
Set-SPEnterpriseSearchCrawlContentSource
Remove-SPEnterpriseSearchCrawlContentSource


Get-SPEnterpriseSearchCrawlExtension
Example
[image]

Returns the extension rule for the extension collection.

Get-SPEnterpriseSearchCrawlExtension [-Identity <ExtensionPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ExtensionPipeBind

Specifies the file name extension to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid file name extension (for example, .xml); or an instance of a valid CrawlExtension object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the extension collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchCrawlExtension cmdlet returns any extension rule or IsInclusionList property for a search application.

The IsInclusionList property denotes whether the list includes or excludes the set. Exclude is used for wikis that have non-standard file extensions.

Run this cmdlet at the initial search configuration, and after any new IFilter interface is added to read the rule when you create, update, or delete the extension rule. If the Identity parameter is not specified, this cmdlet returns the crawl extension collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code


Get-SPEnterpriseSearchCrawlMapping
[image]

Returns a crawl mapping for the search application.

Get-SPEnterpriseSearchCrawlMapping [-Identity <CrawlMappingPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawlMappingPipeBind

Specifies the crawl mapping to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://crawlmap1; or an instance of a valid CrawlMapping object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl mapping collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchCrawlMapping cmdlet reads a CrawlMapping object when one of the crawl mapping rules is created, updated, or deleted. Run this cmdlet when the search is initially configured, and when access is changed through a different mechanism to create the crawl mapping rule; for example, when a rule is changed to use file:\\ rather than http://.

If the Identity parameter is not specified, this cmdlet returns the crawl mapping collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchCrawlMapping
Remove-SPEnterpriseSearchCrawlMapping


Get-SPEnterpriseSearchCrawlTopology
Example
[image]

Returns a crawl topology.

Get-SPEnterpriseSearchCrawlTopology [-Identity <CrawlTopologyPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-Active <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawlTopologyPipeBind

Specifies the crawl topology to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid CrawlTopology object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl topology collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Active

Optional

System.Management.Automation.SwitchParameter

Filters to return only active crawl topologies. An active crawl topology is currently serving crawls for the search application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchCrawlTopology cmdlet returns a crawl topology for a search application. A crawl topology contains the crawl component collection for a topology.

If the Identity parameter is not specified, this cmdlet returns the crawl topology collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Get-SPEnterpriseSearchIndexPartition
[image]

Returns an index partition for a query topology.

Get-SPEnterpriseSearchIndexPartition [-Identity <IndexPartitionPipeBind>] -QueryTopology <QueryTopologyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-SearchApplication <SearchServiceApplicationPipeBind>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.IndexPartitionPipeBind

Specifies the index partition to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid IndexPartition object.

QueryTopology

Required

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the index partition collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Detailed Description

The Get-SPEnterpriseSearchIndexPartition cmdlet returns an index partition for a query topology. Index partitions define how document IDs are mapped to the query components for full-text user queries for a shared search application.

If the Identity parameter is not specified, this cmdlet returns the index partition collection for the specified query topology.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Set-SPEnterpriseSearchIndexPartition


Get-SPEnterpriseSearchLanguageResourcePhrase
[image]

Returns a language resource phrase.

Get-SPEnterpriseSearchLanguageResourcePhrase [-Identity <LanguageResourcePhrasePipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Language <String>] [-Mapping <String>] [-Type <Nullable>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.LanguageResourcePhrasePipeBind

Specifies the language resource phrase to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a language resource phrase (for example, LanguageResourcePhrase1); or an instance of a valid LanguageResourcePhrase object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the language resources.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Language

Optional

System.String

Filters to return phrases of a specified source language.

The type must be a valid name of a language; for example, en-us or ja-jp.

Type

Optional

System.Nullable

Filters to return phrases of a specified type.

The type must be one of the following valid types of phrases:

  • QuerySuggestionBlackList

  • QuerySuggestionAlwaysSuggest

  • SpellingSuggestionBlackList

  • SummaryNoiseList

Detailed Description

The Get-SPEnterpriseSearchLanguageResourcePhrase cmdlet reads a LanguageResourcePhrase object when the language resource phrase is created or deleted.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchLanguageResourcePhrase
Remove-SPEnterpriseSearchLanguageResourcePhrase


Get-SPEnterpriseSearchMetadataCategory
[image]

Returns a crawled property category.

Get-SPEnterpriseSearchMetadataCategory [-Identity <CategoryPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.CategoryPipeBind

Specifies the metadata category to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the enterprise search metadata categories.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchMetadataCategory cmdlet reads a MetadataCategory object when the category is created, updated, or deleted. Run this cmdlet when the initial search is configured and after a new crawled property category is discovered during a crawl. SPEnterpriseSearchMetadataCategory represents a category in the enterprise search metadata property schema.

If the Identity parameter is not specified, this cmdlet returns the metadata category collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchMetadataCategory
Set-SPEnterpriseSearchMetadataCategory
Remove-SPEnterpriseSearchMetadataCategory


Get-SPEnterpriseSearchMetadataCrawledProperty
Example
[image]

Returns a crawled property.

Get-SPEnterpriseSearchMetadataCrawledProperty [-Name <String>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Category <CategoryPipeBind>] [-Limit <String>] [-PropSet <Nullable>] [-VariantType <Nullable>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawledPropertyPipeBind

Specifies the crawled property to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawledProperty object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawled property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Category

Optional

Microsoft.Office.Server.Search.Cmdlet.CategoryPipeBind

Filters to return crawled properties for the specified crawled property category.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

PropSet

Optional

System.Nullable

Filters to return crawled properties with the specified property set.

The type must be a valid GUID that specifies the property set, in the form 12345678-90ab-cdef-1234-567890bcdefgh.

VariantType

Optional

System.Nullable

Filters to return crawled properties with the specified variant type.

The type must be an integer that specifies the variant data type of the property set.

Detailed Description

The Get-SPEnterpriseSearchMetadataCrawledProperty cmdlet reads a MetadataCrawledProperty object when the crawled category is created, updated, or deleted. Run this cmdlet when the search functionality is initially configured and after new crawled properties are discovered during a crawl. If the Identity parameter is not specified, this cmdlet returns the crawled property collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Get-SPEnterpriseSearchMetadataManagedProperty
[image]

Returns a managed property.

Get-SPEnterpriseSearchMetadataManagedProperty [-Identity <ManagedPropertyPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Specifies the managed property to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the managed property collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchMetadataManagedProperty cmdlet reads a ManagedProperty object when managed properties are created, updated, or deleted.

If the Identity parameter is not specified, this cmdlet returns the managed property collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchMetadataManagedProperty
Set-SPEnterpriseSearchMetadataManagedProperty
Remove-SPEnterpriseSearchMetadataManagedProperty


Get-SPEnterpriseSearchMetadataMapping
[image]

Returns the current state of a managed property mapping.

Get-SPEnterpriseSearchMetadataMapping -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-CrawledProperty <CrawledPropertyPipeBind>] [-ManagedProperty <ManagedPropertyPipeBind>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.MappingPipeBind

Specifies the metadata mapping to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawlMapping object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the metadata mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CrawledProperty

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawledPropertyPipeBind

Filters to return mappings to the specified crawled property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawledProperty object.

ManagedProperty

Optional

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Filters to return mappings to the specified managed property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

Detailed Description

The Get-SPEnterpriseSearchMetadataMapping cmdlet reads a Mapping object when the managed property mapping is created, updated, or deleted. SPEnterpriseSearchMetadataMapping represents a snapshot of a mapping between a managed property and one or more crawled properties in the enterprise search metadata property schema.

If the Identity parameter is not specified, this cmdlet returns the metadata mapping collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchMetadataMapping
Set-SPEnterpriseSearchMetadataMapping
Remove-SPEnterpriseSearchMetadataMapping


Get-SPEnterpriseSearchQueryAuthority
[image]

Returns an authoritative page.

Get-SPEnterpriseSearchQueryAuthority [-Identity <AuthorityPagePipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.AuthorityPagePipeBind

Specifies the query authority to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance a valid AuthorityPage object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the authority page to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchQueryAuthority cmdlet reads a QueryAuthority object when the authoritative page is created or deleted or when the query rank is modified.

If the Identity parameter is not specified, this cmdlet returns the authority page collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryAuthority
Set-SPEnterpriseSearchQueryAuthority
Remove-SPEnterpriseSearchQueryAuthority


Get-SPEnterpriseSearchQueryComponent
[image]

Returns a query component.

Get-SPEnterpriseSearchQueryComponent [-Identity <QueryComponentPipeBind>] -QueryTopology <QueryTopologyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-SearchApplication <SearchServiceApplicationPipeBind>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryComponentPipeBind

Specifies the query component to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryComponent object.

QueryTopology

Required

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the query component collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Detailed Description

The Get-SPEnterpriseSearchQueryComponent cmdlet reads a QueryComponent object when the query component is created, updated, or deleted.

If the Identity parameter is not specified, this cmdlet returns the query component collection from the specified query topology.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryComponent
Remove-SPEnterpriseSearchQueryComponent


Get-SPEnterpriseSearchQueryDemoted
[image]

Returns a demoted site rule.

Get-SPEnterpriseSearchQueryDemoted [-Identity <DemotedPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.DemotedPipeBind

Specifies the demoted site rule to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance a valid Demoted object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the demoted site rule collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchQueryDemoted cmdlet reads the DemotedSite object when a demoted site rule is created or deleted, or when the demoted site rule is updated to modify the query rank.

If the Identity parameter is not specified, this cmdlet returns the demoted site rule collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryDemoted
Remove-SPEnterpriseSearchQueryDemoted


Get-SPEnterpriseSearchQueryKeyword
[image]

Returns a keyword term.

Get-SPEnterpriseSearchQueryKeyword [-Identity <KeywordPipeBind>] -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.KeywordPipeBind

Specifies the keyword term to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid string that contains a keyword term (for example, KeywordTerm1); or an instance of a valid Keyword object.

Site

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Filters to return keywords with the specified results URL.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchQueryKeyword cmdlet reads a QueryKeyword object when the keyword rule is created, updated, or deleted.

If the Identity parameter is not specified, this cmdlet returns the query keyword collection from the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryKeyword
Set-SPEnterpriseSearchQueryKeyword
Remove-SPEnterpriseSearchQueryKeyword


Get-SPEnterpriseSearchQueryScope
[image]

Returns a query results scope.

Get-SPEnterpriseSearchQueryScope [-Identity <ScopePipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Url <Uri>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Specifies the results scope to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope (for example, Scope1); or an instance of a valid Scope object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Url

Optional

System.Uri

Filters to return scopes for the specified results URL.

The type must be a valid URL, in the form http://server_name.

Detailed Description

The Get-SPEnterpriseSearchQueryScope cmdlet reads a QueryScope object when the shared scope is created or deleted, or when the definition of the shared scope is updated.

If the Identity parameter is not specified, this cmdlet returns the query scope collection from the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryScope
Set-SPEnterpriseSearchQueryScope
Remove-SPEnterpriseSearchQueryScope
New-SPEnterpriseSearchQueryScopeRule


Get-SPEnterpriseSearchQueryScopeRule
[image]

Returns a shared scope rule.

Get-SPEnterpriseSearchQueryScopeRule [-Identity <ScopeRulePipeBind>] -Scope <ScopePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-Url <Uri>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ScopeRulePipeBind

Specifies the scope rule to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope rule (for example, ScopeRule1); or an instance of a valid ScopeRule object.

Scope

Required

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Returns query scope rules for the specified scope.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope (for example, Scope1); or an instance of a valid Scope object.

Url

Required

System.Uri

The type must be a valid URL, in the form http://server_name.

Returns query scope rules for the specified results URL.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope rule collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Detailed Description

The Get-SPEnterpriseSearchQueryScopeRule cmdlet reads a QueryScopeRule object when the shared scope rule is created, updated, or deleted. SPEnterpriseSearchQueryScopeRule represents a query result scope rule that can be applied to a scope.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryScopeRule
Set-SPEnterpriseSearchQueryScopeRule
Remove-SPEnterpriseSearchQueryScopeRule


Get-SPEnterpriseSearchQueryTopology
[image]

Returns a query topology.

Get-SPEnterpriseSearchQueryTopology [-Identity <QueryTopologyPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-Active <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Active

Optional

System.Management.Automation.SwitchParameter

Filters to return only active query topologies. An active query topology is currently serving queries for the search application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchQueryTopology cmdlet reads a QueryTopology object when the query topology is created, updated, or deleted.

If the Identity parameter is not specified, this cmdlet returns the query topology collection from a farm for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryTopology
Set-SPEnterpriseSearchQueryTopology
Remove-SPEnterpriseSearchQueryTopology


Get-SPEnterpriseSearchRankingModel
[image]

Returns a ranking model.

Get-SPEnterpriseSearchRankingModel [-Identity <RankingModelPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.RankingModelPipeBind

Specifies the ranking model to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid RankingModel object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the ranking model.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchRankingModel cmdlet reads the RankingModel object when a ranking model is created, removed, or updated.

If the Identity parameter is not specified or the identity does not match any of the ranking models in the collection, an exception is thrown and the default ranking model is used.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchRankingModel
Set-SPEnterpriseSearchRankingModel
Remove-SPEnterpriseSearchRankingModel


Get-SPEnterpriseSearchSecurityTrimmer
[image]

Returns a custom security trimmer.

Get-SPEnterpriseSearchSecurityTrimmer [-Identity <SecurityTrimmerPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SecurityTrimmerPipeBind

Specifies the pluggable security trimmer used for the specified search application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid SecurityTrimmer object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the security trimmer.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchSecurityTrimmer cmdlet returns the PluggableSecurityTrimmer object when a customized security trimmer is created, updated, or deleted for the query results of the specified search application. A custom security trimmer trims search results before the results are returned to the user.

If the Identity parameter is not specified, this cmdlet returns the security trimmer collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchSecurityTrimmer
Remove-SPEnterpriseSearchSecurityTrimmer


Get-SPEnterpriseSearchService
[image]

Returns the search service for the farm.

Get-SPEnterpriseSearchService [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchService cmdlet returns the SearchService object when the search service is updated or deleted.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Set-SPEnterpriseSearchService
Get-SPEnterpriseSearchServiceInstance
Start-SPEnterpriseSearchServiceInstance


Get-SPEnterpriseSearchServiceApplication
[image]

Returns the search service application for a farm.

Get-SPEnterpriseSearchServiceApplication [-Identity <SearchServiceApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search service application to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchServiceApplication cmdlet reads the SearchServiceApplication object when the search service application is updated or deleted.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchServiceApplication
Set-SPEnterpriseSearchServiceApplication
Remove-SPEnterpriseSearchServiceApplication


Get-SPEnterpriseSearchServiceInstance
[image]

Returns the search service instance for a farm.

Get-SPEnterpriseSearchServiceInstance [-Identity <SearchServiceInstancePipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Local <SwitchParameter>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the search service instance to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a query server (for example, MyQueryServer); or an instance of a valid SearchServiceInstance object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Local

Optional

System.Management.Automation.SwitchParameter

Returns the search service instance for the current search server.

Detailed Description

The Get-SPEnterpriseSearchServiceInstance cmdlet returns the SearchServiceInstance object when the object is created, updated, or deleted.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Set-SPEnterpriseSearchServiceInstance
Start-SPEnterpriseSearchServiceInstance
Stop-SPEnterpriseSearchServiceInstance


Get-SPEnterpriseSearchSiteHitRule
Example
[image]

Returns the shared site hit rule.

Get-SPEnterpriseSearchSiteHitRule [-Identity <SiteHitRulePipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-SearchService <SearchServicePipeBind>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SiteHitRulePipeBind

Specifies the site hit rule to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid SiteHitRule object.

SearchService

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServicePipeBind

Specifies the search service that hosts the crawler with the specified shared site search rules.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchSiteHitRule cmdlet reads a SiteHitRule object when the site hit rule is created, updated, or deleted. A SiteHitRule object sets how many crawler sessions (threads) can simultaneously crawl the given site.

If the Identity parameter is not specified, this cmdlet returns the site hit rule collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Import-SPEnterpriseSearchTopology
Example
[image]

Imports and activates a topology from an XML file.

Import-SPEnterpriseSearchTopology -Filename <String> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Filename

Optional

System.String

Specifies the path and file name of the topology XML file to import.

The type must be a valid path, in the form MyFeature\Feature.xml.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application to which to apply the topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Import-SPEnterpriseSearchTopology cmdlet imports from an XML file the topology for a shared search application. The Export-SPEnterpriseSearchTopology cmdlet is used to save a search topology.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


New-SPEnterpriseSearchCrawlComponent
Example
[image]

Creates a crawl component for a shared search application.

New-SPEnterpriseSearchCrawlComponent -CrawlDatabase <CrawlStorePipeBind> -CrawlTopology <CrawlTopologyPipeBind> -SearchServiceInstance <SearchServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-IndexLocation <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

CrawlStore

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlStorePipeBind

Creates the new crawl component in the specified crawl store.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a CrawlStore object (for example, CrawlStore1); or an instance of a valid CrawlStore object.

CrawlTopology

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlTopologyPipeBind

Specifies the crawl topology that contains the crawl component collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid CrawlTopology object.

SearchServiceInstance

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the search service instance to host the new crawl component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a query server (for example, MyQueryServer); or an instance of a valid SearchServiceInstance object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

IndexLocation

Optional

System.String

Specifies the path for the index directory where the full-text index files are created.

The type must be a valid path in either of the following forms:

  • C:\ folder_name

  • \\server_name\folder_name

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Detailed Description

The New-SPEnterpriseSearchCrawlComponent cmdlet is run when the search functionality is initially configured, or when a new crawl component is added to a crawl topology for a shared search application. A crawl topology can contain multiple crawl components.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code


New-SPEnterpriseSearchCrawlContentSource
Example
[image]

Creates a new crawl content source for a shared search application.

New-SPEnterpriseSearchCrawlContentSource -Identity <ContentSourcePipeBind> -SearchApplication <SearchServiceApplicationPipeBind> -Type <String> [-AssignmentCollection <SPAssignmentCollection>] [-BDCApplicationProxy <SPServiceApplicationProxyPipeBind>] [-Confirm [<SwitchParameter>]] [-CrawlPriority <Nullable>] [-FullCrawlSchedule <String>] [-FullCrawlScheduleDay <Nullable>] [-FullCrawlScheduleHour <Nullable>] [-FullCrawlScheduleMinute <Nullable>] [-FullCrawlScheduleMonth <Nullable>] [-FullCrawlScheduleRepeatDuration <Nullable>] [-FullCrawlScheduleRepeatInterval <Nullable>] [-FullCrawlScheduleStartDate <DateTime>] [-FullCrawlScheduleWeek <Nullable>] [-IncrementalCrawlSchedule <String>] [-IncrementalCrawlScheduleDay <Nullable>] [-IncrementalCrawlScheduleHour <Nullable>] [-IncrementalCrawlScheduleMinute <Nullable>] [-IncrementalCrawlScheduleMonth <Nullable>] [-IncrementalCrawlScheduleRepeatDuration <Nullable>] [-IncrementalCrawlScheduleRepeatInterval <Nullable>] [-IncrementalCrawlScheduleStartDate <DateTime>] [-IncrementalCrawlScheduleWeek <Nullable>] [-LOBSystemSet <String[]>] [-MaxPageEnumerationDepth <Nullable>] [-MaxSiteEnumerationDepth <Nullable>] [-SharePointCrawlBehavior <Nullable>] [-StartAddresses <String>] [-Tag <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ContentSourcePipeBind

Specifies the identity of the content source to create.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a ContentSource object (for example, ContentSource1); or an instance of a valid ContentSource object.

SearchApplication

Yes

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the content source.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Type

Required

System.String

Specifies the name of the content source type. Valid values are web, sharepoint, custom, lotusnotes, custom, file, exchange (for Microsoft Exchange public folders), and business (for the Business Data Catalog).

The type must be the valid name of a content source type; for example, custom.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

No

System.Management.Automation.SwitchParameter

FullCrawlSchedule

No

System.String

Specifies the description of the full crawl schedule.

The type must be one of the following values: daily, monthly, weekly, or monthlydayofweek.

FullCrawlScheduleDay

Optional

System.Nullable

Specifies the day of the month on which to start the full crawl.

FullCrawlScheduleHour

Optional

System.Nullable

Specifies the hour at which to start the full crawl.

FullCrawlScheduleMinute

Optional

System.Nullable

Specifies the minute at which to start the full crawl.

FullCrawlScheduleMonth

Optional

System.Nullable

Specifies the month of the year in which to start the full crawl.

FullCrawlScheduleRepeatDuration

Optional

System.Nullable

Specifies the number of times to repeat the full crawl schedule.

FullCrawlScheduleRepeatInterval

Optional

System.Nullable

Specifies the number of minutes between each repeat interval for the full crawl schedule.

FullCrawlScheduleStartDate

Optional

System.DateTime

Specifies the initial date of first full crawl.

FullCrawlScheduleWeek

Optional

System.Nullable

Specifies the weeks of the month in which the full crawl starts.

IncrementalCrawlSchedule

Optional

System.String

Describes the incremental crawl schedule.

The type must be one of the following values: daily, monthly, weekly, or monthlydayofweek.

IncrementalCrawlScheduleDay

Optional

System.Nullable

Specifies the day of the month to start the incremental crawl.

IncrementalCrawlScheduleHour

Optional

System.Nullable

Specifies the hour at which to start the incremental crawl.

IncrementalCrawlScheduleMinute

Optional

System.Nullable

Specifies the minute at which to start the incremental crawl.

IncrementalCrawlScheduleMonth

Optional

System.Nullable

Specifies the month of the year in which to start the incremental crawl.

IncrementalCrawlScheduleRepeatDuration

Optional

System.Nullable

Specifies the number of times to repeat the full incremental schedule.

IncrementalCrawlScheduleRepeatInterval

Optional

System.Nullable

Specifies the number of minutes between each repeat interval for the incremental crawl schedule.

IncrementalCrawlScheduleStartDate

Optional

System.DateTime

Specifies the initial date of the first incremental crawl.

IncrementalCrawlScheduleWeek

Optional

System.Nullable

Specifies the weeks of the month in which the full incremental starts.

StartAddresses

Optional

System.String

Tag

Optional

System.String

Specifies the URL for the page to modify the settings for a custom content source. The string that specifies the URL can contain a maximum of 1024 characters.

The type must be a valid URL, in the form http://server_name.

ThrottleBegin

Optional

System.Nullable

Not used

ThrottleDuration

Optional

System.Nullable

Not used.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Detailed Description

The New-SPEnterpriseSearchCrawlContentSource cmdlet creates a new content source.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


New-SPEnterpriseSearchCrawlExtension
[image]

Adds an extension rule to a shared search application.

New-SPEnterpriseSearchCrawlExtension [-Identity <ExtensionPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the file name extension to set.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid file name extension (for example, .xml); or an instance of a valid CrawlExtension object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the extension collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchCrawlExtension cmdlet adds an extension rule or IsInclusionList property for the extension collection. The IsInclusionList property denotes whether the list includes or excludes the set. Exclude is used for wikis that have nonstandard file extensions. Run this cmdlet at the initial search configuration, and after any new IFilter interface is added to read the rule when you create, update, or delete the extension rule.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlExtension
Remove-SPEnterpriseSearchCrawlExtension


New-SPEnterpriseSearchCrawlMapping
Example
[image]

Creates a crawl mapping rule for a shared search application.

New-SPEnterpriseSearchCrawlMapping -Identity <CrawlMappingPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> -Target <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlMappingPipeBind

Specifies the source URI for the crawl mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://crawlmap1, or an instance of a valid CrawlMapping object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl mapping collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Target

Required

System.String

Specifies the target URI for the crawl mapping to get.

The type must be a valid URI; for example, file:\\ server_name\sitedocs.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchCrawlMapping cmdlet is run when the search functionality is initially configured, and when access is changed through a different mechanism to create the crawl mapping rule; for example, when a rule is changed to use file:\\ rather than http://.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code


New-SPEnterpriseSearchCrawlTopology
[image]

Adds a crawl topology to a shared search application.

New-SPEnterpriseSearchCrawlTopology -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Clone <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-CrawlTopology <CrawlTopologyPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl topology collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that a new crawl topology is created by cloning an existing crawl topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

CrawlTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawlTopologyPipeBind

Specifies the identity of an existing query topology to clone for the new crawl topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid CrawlTopology object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchCrawlTopology cmdlet adds a crawl topology. A crawl topology contains the crawl component collection for a topology on a shared search application. A search service application can contain multiple crawl topologies when a change to a topology adds or deletes a crawl component.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlTopology
Set-SPEnterpriseSearchCrawlTopology
Remove-SPEnterpriseSearchCrawlTopology


New-SPEnterpriseSearchLanguageResourcePhrase
[image]

Adds a language resource phrase to a shared search application.

New-SPEnterpriseSearchLanguageResourcePhrase -Identity <LanguageResourcePhrasePipeBind> -Language <String> -SearchApplication <SearchServiceApplicationPipeBind> -Type <Nullable> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Mapping <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.LanguageResourcePhrasePipeBind

Specifies the term to add to the list specified in the Type parameter.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a language resource phrase (for example, LanguageResourcePhrase1); or an instance of a valid LanguageResourcePhrase object.

Language

Required

System.String

Adds the phrase for the specified source language.

The type must be a valid name of a language; for example, en-us or ja-jp.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the language resources.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Type

Required

System.Nullable

Specifies the type of the new phrase.

The type must be one of the following valid types of phrases:

  • QuerySuggestionBlackList

  • QuerySuggestionAlwaysSuggest

  • SpellingSuggestionBlackList

  • SummaryNoiseList

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchLanguageResourcePhrase cmdlet adds a query keyword phrase to a shared search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchLanguageResourcePhrase
Remove-SPEnterpriseSearchLanguageResourcePhrase


New-SPEnterpriseSearchMetadataCategory
[image]

Adds a crawled property category to a shared search application.

New-SPEnterpriseSearchMetadataCategory -Identity <CategoryPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-AutoCreateNewManagedProperties <Nullable>] [-Confirm [<SwitchParameter>]] [-DiscoverNewProperties <Nullable>] [-MapToContents <Nullable>] [-PropSet <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CategoryPipeBind

Specifies the identity of the new metadata category.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the enterprise search metadata property schema.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

AutoCreateNewManagedProperties

Optional

System.Nullable

Specifies that new managed properties are mapped when new crawled properties in this category are found.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DiscoverNewProperties

Optional

System.Nullable

Specifies that new properties in this category are discovered during a crawl.

MapToContents

Optional

System.Nullable

Specifies that string data from all crawled properties in this category is added to the full-text index catalog.

PropSet

Optional

System.Nullable

Creates the new metadata category with the specified property set.

The type must be a valid GUID that specifies the property set, in the form 12345678-90ab-cdef-1234-567890bcdefgh.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchMetadataCategory cmdlet is used when the search functionality is initially configured, and when a new custom search application to create the new crawled property category is installed. SPEnterpriseSearchMetadataCategory represents a category in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchMetadataCategory
Set-SPEnterpriseSearchMetadataCategory
Remove-SPEnterpriseSearchMetadataCategory


New-SPEnterpriseSearchMetadataCrawledProperty
[image]

Adds a crawled property category to a shared search application.

New-SPEnterpriseSearchMetadataCrawledProperty -Category <CategoryPipeBind> -IsNameEnum <$true | $false> -Name <String> -PropSet <Guid> -SearchApplication <SearchServiceApplicationPipeBind> -VariantType <Int32> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-IsMappedToContents <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawledPropertyPipeBind

Specifies the identity of the new crawled property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

Category

Required

Microsoft.Office.Server.Search.Cmdlet.CategoryPipeBind

Specifies the crawled property category to add.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

IsNameEnum

Required

System.Boolean

Specifies whether the crawled property name is a string that was converted from an integer; for example, if the crawled property name is the string 5 that was converted from the value 5.

PropSet

Optional

System.Guid

Creates the new metadata property with the specified property set.

The type must be a valid GUID that specifies the property set, in the form 12345678-90ab-cdef-1234-567890bcdefgh.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawled property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

VariantType

Required

System.Int32

Add the new crawled property as the specified variant type. For more information about valid values for this property, see VARIANT Type Constants (http://go.microsoft.com/fwlink/?LinkId=143322&clcid=0x409).

The type must be an integer that specifies the variant data type of the property set.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

IsMappedToContents

Optional

System.Nullable

Specifies that the crawled property is mapped to managed properties.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchMetadataCrawledProperty cmdlet is used when the search functionality is initially configured, and after any new crawled property is added to create the rules for the crawled property. SPEnterpriseSearchMetadataCrawledProperty represents a crawled property in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchMetadataCrawledProperty
Set-SPEnterpriseSearchMetadataCrawledProperty
Other Resources
VARIANT Type Constants (http://go.microsoft.com/fwlink/?LinkId=143322&clcid=0x409)


New-SPEnterpriseSearchMetadataManagedProperty
[image]

Adds a managed property to a shared search application.

New-SPEnterpriseSearchMetadataManagedProperty -Identity <ManagedPropertyPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> -Type <Int32> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultForQueryIndependentRank <Nullable>] [-Description <String>] [-EnabledForQueryIndependentRank <Nullable>] [-EnabledForScoping <Nullable>] [-FullTextQueriable <Nullable>] [-IncludeInMd5 <Nullable>] [-NameNormalized <Nullable>] [-NoWordBreaker <Nullable>] [-RemoveDuplicates <Nullable>] [-RespectPriority <Nullable>] [-Retrievable <Nullable>] [-UserFlags <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Specifies the identity of the new managed property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the managed property collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Type

Required

System.Int32

Specifies the data type of the new managed property.

The type must be one of the following data types:

  • Binary

  • DateTime

  • Decimal

  • Integer

  • Text

  • YesNo

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DefaultForQueryIndependentRank

Optional

System.Nullable

Specifies that the property is mandatory when it is used in query-independent rank (relevance). The default value is 0.

Description

Optional

System.String

Adds a description for the new metadata managed property.

The type must be a valid string; for example, a description for a metadata managed property.

EnabledForQueryIndependentRank

Optional

System.Nullable

Specifies that the property can be used in query-independent rank (relevance). The default value is 0.

EnabledForScoping

Optional

System.Nullable

Specifies that the property can be used in a scope definition. The default value is 0.

FullTextQueriable

Optional

System.Nullable

Specifies that the managed property can be used in enterprise search SQL queries.

IncludeInMd5

Optional

System.Nullable

Specifies that the managed property is included in the hash used by the crawler to determine whether a document has changed. The default value is 0.

NameNormalized

Optional

System.Nullable

Specifies that the managed property has been converted to the full name. The default value is 0.

NoWordBreaker

Optional

System.Nullable

Specifies that the values for this property are processed by a word breaker. The default value is 0.

RemoveDuplicates

Optional

System.Nullable

Specifies that duplicate values for the property are removed. The default value is 1.

RespectPriority

Optional

System.Nullable

Specifies that only one instance of the property exists for an item. The default value is 0.

Retrievable

Optional

System.Nullable

Specifies that the property can be used for advanced search or keyword queries, and that the value for this property can be retrieved in search results.

UserFlags

Optional

System.Nullable

Reserved for future use.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchMetadataManagedProperty cmdlet creates a new managed property for a crawled property mapping. SPEnterpriseSearchMetadataManagedProperty represents a managed property in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchMetadataManagedProperty
Set-SPEnterpriseSearchMetadataManagedProperty
Remove-SPEnterpriseSearchMetadataManagedProperty


New-SPEnterpriseSearchMetadataMapping
[image]

Adds a managed property mapping to a shared search application.

New-SPEnterpriseSearchMetadataMapping -CrawledProperty <CrawledPropertyPipeBind> -ManagedProperty <ManagedPropertyPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

CrawledProperty

Required

Microsoft.Office.Server.Search.Cmdlet.CrawledPropertyPipeBind

Filters the crawled property to map.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawledProperty object.

ManagedProperty

Required

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Specifies the managed property to receive the crawled property mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the managed property to receive the crawled property mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

CrawledPropertyPropSet

Optional

System.Nullable

Specifies the property set of the crawled property to map to the specified managed property.

The type must be a valid GUID, in the form12345678-90ab-cdef-1234-567890bcdefgh.

CrawledPropertyVariantType

Optional

System.Nullable

Specifies the variant type for the specified crawled property.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchMetadataMapping cmdlet maps a crawled property and adds the mapping to the managed property. SPEnterpriseSearchMetadataMapping represents a snapshot of a mapping between a managed property and one or more crawled properties in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchMetadataMapping
Set-SPEnterpriseSearchMetadataMapping
Remove-SPEnterpriseSearchMetadataMapping
Other Resources
VARIANT Type Constants (http://go.microsoft.com/fwlink/?LinkId=143322&clcid=0x409)


New-SPEnterpriseSearchQueryAuthority
[image]

Adds an authoritative page to a shared search application.

New-SPEnterpriseSearchQueryAuthority -Identity <AuthorityPagePipeBind> -Level <Single> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.AuthorityPagePipeBind

Specifies the identity of the query authority page to create.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid AuthorityPage object.

Level

Required

System.Single

Specifies the level of the new authoritative page. Authoritative pages, designated by the service application administrator, are expert pages that link to the most relevant information. Because a search service application can have several designated authoritative pages, you use the Level property to specify the value of a specific page. This parameter sets the level for the most valuable authoritative pages to 0.

The type must be one of the following floating-point numbers: 0, 1, or 2.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the authority page collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchQueryAuthority cmdlet adds an authoritative page to adjust query rank. SPEnterpriseSearchQueryAuthority represents authoritative sites that rank higher in relevance than demoted sites, which are de-emphasized in relevance.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryAuthority
Set-SPEnterpriseSearchQueryAuthority
Remove-SPEnterpriseSearchQueryAuthority


New-SPEnterpriseSearchQueryComponent
[image]

Adds a query component to a query topology.

New-SPEnterpriseSearchQueryComponent -IndexPartition <IndexPartitionPipeBind> -QueryTopology <QueryTopologyPipeBind> -SearchServiceInstance <SearchServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-FailoverOnly <SwitchParameter>] [-IndexLocation <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-ShareName <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

IndexPartition

Required

Microsoft.Office.Server.Search.Cmdlet.IndexPartitionPipeBind

Specifies the index partition to use for the query component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid IndexPartition object.

QueryTopology

Required

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the query component collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

SearchServiceInstance

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the search service instance to host the new query component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a query server, in the form MyQueryServer; or an instance of a valid SearchServiceInstance object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

HotSwap

Optional

System.Management.Automation.SwitchParameter

Specifies that the query component is not used for failover.

IndexLocation

Optional

System.String

Specifies the path to the index directory where the full-text index files are created.

The type must be a valid path in either of the following forms:

  • C:\ folder_name

  • \\server_name\folder_name

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

ShareName

Optional

System.String

Specifies the name for the file share at the path specified in IndexLocation. The string must contain only legal file share and registry characters.

The type must be a valid name of a file share; for example, FileShare1.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchQueryComponent cmdlet is used when the search functionality is initially configured and a new query component is added to a shared search application. Query components perform the full-text term search in index partitions of user queries.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryComponent
Remove-SPEnterpriseSearchQueryComponent


New-SPEnterpriseSearchQueryDemoted
[image]

Adds a demoted site rule to a shared search application.

New-SPEnterpriseSearchQueryDemoted -Identity <DemotedPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.DemotedPipeBind

Specifies the identity of the new demoted site rule.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid Demoted object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the demoted site rule collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchQueryDemoted cmdlet adjusts query rank by adding a demoted site rule to the shared search application. Query demoted sites are de-emphasized in relevance.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryDemoted
Remove-SPEnterpriseSearchQueryDemoted


New-SPEnterpriseSearchQueryKeyword
[image]

Adds a keyword term to a shared search application.

New-SPEnterpriseSearchQueryKeyword -Identity <KeywordPipeBind> -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Contact <String>] [-Definition <String>] [-EndDate <Nullable>] [-ReviewDate <Nullable>] [-StartDate <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.KeywordPipeBind

Specifies the keyword term to create.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid string that contains a keyword term (for example, KeywordTerm1); or an instance of a valid Keyword object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query keyword collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Site

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Associates the new keyword term to the specified results URL.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Contact

Optional

System.String

Specifies the user name associated with the new keyword.

The type must be a valid user name; for example, KeywordUser1.

Definition

Optional

System.String

Specifies the definition of the new keyword term.

The type must be a valid string; for example, a keyword term definition.

EndDate

Optional

System.Nullable

Specifies the expiration date of the keyword term. The default value is MaxDate.

The type must be a valid DateTime type, in the form 2010,12,05.

ReviewDate

Optional

System.Nullable

Specifies the review date of the keyword term. The default value is MaxDate.

The type must be a valid date, in the form 2010,12,05.

StartDate

Optional

System.Nullable

Specifies the activation date for the keyword term. The default value is the current date.

The type must be a valid date, in the form 2010,12,05.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchQueryKeyword cmdlet changes query results by creating a new keyword. A query keyword is a query component of a query topology. SPEnterpriseSearchQueryKeyword represents relevance setting through keywords.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryKeyword
Set-SPEnterpriseSearchQueryKeyword
Remove-SPEnterpriseSearchQueryKeyword


New-SPEnterpriseSearchQueryScope
[image]

Adds a query results scope to a shared search application.

New-SPEnterpriseSearchQueryScope -Identity <ScopePipeBind> -AlternateResultsPage <String> -Description <String> -DisplayInAdminUI <Nullable> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-CompilationType <Nullable>] [-Confirm [<SwitchParameter>]] [-ExtendedSearchFilter <String>] [-OwningSiteUrl <Uri>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Specifies the identity of the scope to create.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope (for example, Scope1); or an instance of a valid Scope object.

AlternateResultsPage

Required

System.String

Specifies the location to display results for the new query scope.

The type must be a valid URL, in the form http://server_name.

Description

Required

System.String

Adds a description of the new query scope.

The type must be a valid string; for example, a description of a query scope.

DisplayInAdminUI

Required

System.Nullable

Specifies that the new scope is displayed in the administration application user interface (UI). The default setting is to hide the new scope in the administration application UI.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CompilationType

Optional

System.Nullable

Specifies the compilation type of the new scope. The value 0 specifies the conditionally compiled scope type, and the value 1 specifies the always compiled scope type.

The type must be either of the following: 0 or 1.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

OwningSiteUrl

Optional

System.Uri

Specifies the SharePoint site that is associated with the new scope.

The type must be a valid SharePoint site URL, in the form http://server_name.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPEnterpriseSearchQueryScope cmdlet to create a new shared scope. SPEnterpriseSearchQueryScope represents a query results scope used by all shared search applications on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryScope
Set-SPEnterpriseSearchQueryScope
Remove-SPEnterpriseSearchQueryScope
New-SPEnterpriseSearchQueryScopeRule


New-SPEnterpriseSearchQueryScopeRule
[image]

Adds a shared scope rule to a query scope.

New-SPEnterpriseSearchQueryScopeRule -RuleType <String> -Scope <ScopePipeBind> -Url <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-FilterBehavior <String>] [-ManagedProperty <ManagedPropertyPipeBind>] [-MatchingString <String>] [-PropertyValue <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-UrlScopeRuleType <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

RuleType

Required

System.String

Specifies the type of scope rule to create.

The type must be one of the following values: AllContent, Url, or PropertyQuery.

Scope

Required

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Applies the query scope rule to the specified scope.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope (for example, Scope1); or an instance of a valid Scope object.

Url

Required

System.Uri

Specifies the results URL that is associated with the query scope rule.

The type must be a valid URL, in the form http://server_name.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

FilterBehavior

Optional

System.String

Specifies the type of scope rule to create for the query scope.

The type must be one of the following values: Exclude, Include, or Require.

ManagedProperty

Optional

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Specifies the managed property to use for the PropertyQuery scope rule.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

MatchingString

Optional

System.String

Specifies the string to use when matching the URL rule type.

PropertyValue

Optional

System.String

Specifies the property value to use when matching the PropertyQuery rule type.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope rule collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

UrlScopeRuleType

Optional

System.String

Specifies the value to use when matching the URL rule type.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchQueryScopeRule cmdlet creates a new shared scope rule. SPEnterpriseSearchQueryScopeRule represents a query results scope rule that can be applied to a scope.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Remove-SPEnterpriseSearchQueryScopeRule
Get-SPEnterpriseSearchQueryScopeRule
Set-SPEnterpriseSearchQueryScopeRule
Get-SPEnterpriseSearchQueryScope


New-SPEnterpriseSearchQueryTopology
[image]

Adds a query topology to a shared search application.

New-SPEnterpriseSearchQueryTopology -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Clone <SwitchParameter>] [-Clone <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-QueryTopology <QueryTopologyPipeBind>] [-WhatIf [<SwitchParameter>]]

New-SPEnterpriseSearchQueryTopology -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Clone <SwitchParameter>] [-Confirm [<SwitchParameter>]] [-Partitions <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Set 1

Parameter

Required

Type

Description

Parameter

Required

Type

Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

QueryTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology to clone for the new query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameter Set 2

Parameter

Required

Type

Description

Parameter

Required

Type

Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Partitions

Optional

System.String

Specifies the number of query partitions to use for the new query topology.

The type must be a valid string that indicates a number less than or equal to 256.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameters

Parameter Set 1

Parameter

Required

Type

Description

Parameter

Required

Type

Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

QueryTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology to clone for the new query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameter Set 2

Parameter

Required

Type

Description

Parameter

Required

Type

Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Clone

Optional

System.Management.Automation.SwitchParameter

Specifies that the new query topology is created by cloning an existing query topology.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Partitions

Optional

System.String

Specifies the number of query partitions to use for the new query topology.

The type must be a valid string that indicates a number less than or equal to 256.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchQueryTopology cmdlet is used when the search functionality is initially configured or when a new query topology is created. A topology can contain multiple query topologies when a query component or index partition is added to or deleted from a topology.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryTopology
Set-SPEnterpriseSearchQueryTopology
Remove-SPEnterpriseSearchQueryTopology


New-SPEnterpriseSearchRankingModel
[image]

Adds a ranking model to a shared search application.

New-SPEnterpriseSearchRankingModel -RankingModelXML <String> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

RankingModelXML

Required

System.String

Specifies the name of the XML representation of the new ranking model.

The type must be a valid name of an .xml file; for example, XMLfilename1.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the ranking model.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchRankingModel cmdlet adds a new ranking model to the collection. The name, description, and identifier (ID) for the new ranking model are contained in the .xml file specified in RankingModelXML.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchRankingModel
Set-SPEnterpriseSearchRankingModel
Remove-SPEnterpriseSearchRankingModel


New-SPEnterpriseSearchSecurityTrimmer
[image]

Adds a custom security trimmer to a shared search application.

New-SPEnterpriseSearchSecurityTrimmer -Identity <SecurityTrimmerPipeBind> -RulePath <String> -SearchApplication <SearchServiceApplicationPipeBind> -TypeName <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Properties <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SecurityTrimmerPipeBind

Specifies the identity of the pluggable security trimmer to use for the specified search application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid SecurityTrimmer object.

RulePath

Required

System.String

Specifies the content path to which the security trimmer will be applied.

The type must be a valid URI, in the form file:\\server_name\content.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Adds the security trimmer to the specified search application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

TypeName

Required

System.String

Specifies the strong name of the custom security trimmer assembly.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Properties

Optional

System.String

Specifies the name-value pairs that specify the configuration properties.

The type must be in the following name/value pair format: Name1~Value1~Name2~Value2~

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchSecurityTrimmer cmdlet creates a new object to configure the pluggable security trimmer. SPEnterpriseSearchSecurityTrimmer represents a pluggable security trimmer that performs customized security trimming of search results at query time, when the results are returned to the user.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchSecurityTrimmer
Remove-SPEnterpriseSearchSecurityTrimmer


New-SPEnterpriseSearchServiceApplication
[image]

Adds a search service application to a farm.

New-SPEnterpriseSearchServiceApplication -Name <String> -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AdminApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseName <String>] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-Partitioned <SwitchParameter>] [-SearchApplicationType <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the names of the new search application.

The type must be a valid name of a search application; for example, SearchApp1.

ApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the IIS application pool to use for the new search application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL of a search application, in the form http://server_name; or an instance of a valid SPIisWebServiceApplicationPool object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabaseName

Optional

System.String

Specifies the name of the database to create for the new search application.

The type must be a valid name of a SQL Server database; for example, SearchAppDB1.

DatabasePassword

Optional

System.String

Specifies the password for the user ID that is used for accessing the search application database on SQL Server.

The type must be a valid password.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database specified in DatabaseName.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the user ID to use for accessing the search application SQL Server database.

The type must be a valid user name; for example, SearchUserName1.

Partitioned

Optional

System.Management.Automation.SwitchParameter

Specifies that the search service application uses Web-hosted mode. Web-hosted mode segregates results for a given hosted subscription.

SearchApplicationType

Optional

System.Nullable

Specifies that the search service application is used as a connector for an extended search application.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchServiceApplication cmdlet is used when the search functionality is initially configured or when a new shared search application is added to a farm. SPEnterpriseSearchServiceApplication represents a self-contained aggregation of indexed content and properties available for search, and provides an anchor class for setting global search properties. A farm can include multiple search service applications.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchServiceApplication
Set-SPEnterpriseSearchServiceApplication
Remove-SPEnterpriseSearchServiceApplication


Remove-SPEnterpriseSearchCrawlComponent
[image]

Deletes a crawl component from a shared search application.

Remove-SPEnterpriseSearchCrawlComponent -Identity <CrawlComponentPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-CrawlTopology <CrawlTopologyPipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlComponentPipeBind

Specifies the crawl component to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid CrawlComponent object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

CrawlTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawlTopologyPipeBind

Specifies the crawl topology that contains the crawl component to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid CrawlTopology object.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl component.

Must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name, (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchCrawlComponentAdmin cmdlet deletes a specified crawl component from a shared service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchCrawlComponent
Other Resources
Get-SPEnterpriseSearchCrawlComponent


Remove-SPEnterpriseSearchCrawlContentSource
[image]

Deletes a specified crawl content source from a search application.

Remove-SPEnterpriseSearchCrawlContentSource -Identity <ContentSourcePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ContentSourcePipeBind

The crawl content source to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a ContentSource object (for example, ContentSource1); or an instance of a valid ContentSource object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl content source.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchCrawlContentSource cmdlet deletes a specified crawl content source from a service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlContentSource
New-SPEnterpriseSearchCrawlContentSource
Set-SPEnterpriseSearchCrawlContentSource


Remove-SPEnterpriseSearchCrawlExtension
[image]

Removes a file name extension from the list of files that can be crawled.

Remove-SPEnterpriseSearchCrawlExtension -Identity <ExtensionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ExtensionPipeBind

The file name extension to remove.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid file name extension (for example, .xml); or an instance of a valid CrawlExtension object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the extension collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchCrawlExtension cmdlet prevents files with this extension from being crawled.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlExtension
New-SPEnterpriseSearchCrawlExtension
Remove-SPEnterpriseSearchCrawlExtension


Remove-SPEnterpriseSearchCrawlMapping
[image]

Deletes a crawl mapping.

Remove-SPEnterpriseSearchCrawlMapping -Identity <CrawlMappingPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlMappingPipeBind

The crawl mapping to delete.

A valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawlMapping object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl mapping collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchCrawlMapping cmdlet deletes a crawl mapping from the crawl mapping collection.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlMapping
New-SPEnterpriseSearchCrawlMapping


Remove-SPEnterpriseSearchCrawlTopology
[image]

Deletes a crawl topology.

Remove-SPEnterpriseSearchCrawlTopology -Identity <CrawlTopologyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlTopologyPipeBind

Specifies the crawl topology to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid CrawlTopology object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl topology collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchCrawlTopology cmdlet deletes a specified crawl topology from the crawl topology collection. A crawl topology contains the crawl component collection for a topology on a shared search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlTopology
New-SPEnterpriseSearchCrawlTopology
Set-SPEnterpriseSearchCrawlTopology


Remove-SPEnterpriseSearchLanguageResourcePhrase
[image]

Deletes a language resource phrase from a shared search application.

Remove-SPEnterpriseSearchLanguageResourcePhrase -Identity <LanguageResourcePhrasePipeBind> -Language <String> -SearchApplication <SearchServiceApplicationPipeBind> -Type <Nullable> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Mapping <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.LanguageResourcePhrasePipeBind

The language resource phrase to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a language resource phrase (for example, LanguageResourcePhrase1); or an instance of a valid LanguageResourcePhrase object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Language

Optional

System.String

Deletes phrases of the specified language only.

The type must be a valid name of a language; for example, en_us.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the language resources.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Type

Optional

System.Nullable

Constrains to delete phrases of specified type.

The type must be one of the following valid types of phrases:

  • QuerySuggestionBlackList

  • QuerySuggestionAlwaysSuggest

  • SpellingSuggestionBlackList

  • SummaryNoiseList

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchLanguageResourcePhrase cmdlet deletes one or more language resource phrases from the collection of language resource phrases in a shared search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchLanguageResourcePhrase
New-SPEnterpriseSearchLanguageResourcePhrase


Remove-SPEnterpriseSearchMetadataCategory
[image]

Deletes a crawled property category.

Remove-SPEnterpriseSearchMetadataCategory -Identity <CategoryPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CategoryPipeBind

Specifies the metadata category to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the enterprise search metadata property schema.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchMetadataCategory cmdlet after a crawl to delete unused or unwanted categories from the metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchMetadataCategory
New-SPEnterpriseSearchMetadataCategory
Set-SPEnterpriseSearchMetadataCategory


Remove-SPEnterpriseSearchMetadataManagedProperty
[image]

Deletes a metadata managed property.

Remove-SPEnterpriseSearchMetadataManagedProperty -Identity <ManagedPropertyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Specifies the managed property to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the managed property collection.

The type must be a valid GUID, of the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchManagedProperty cmdlet deletes unused or unwanted managed properties from the managed property collection.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchMetadataManagedProperty
New-SPEnterpriseSearchMetadataManagedProperty
Set-SPEnterpriseSearchMetadataManagedProperty


Remove-SPEnterpriseSearchMetadataMapping
[image]

Deletes a metadata mapping from a managed property.

Remove-SPEnterpriseSearchMetadataMapping -Identity <MappingPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.MappingPipeBind

Specifies the metadata mapping to delete.

A valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawlMapping object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the managed property collection.

A valid GUID, such as 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchMetadataMapping cmdlet deletes unused or unwanted mappings from a managed property. A metadata mapping is the mapping between a managed property and one or more crawled properties in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchMetadataMapping
New-SPEnterpriseSearchMetadataMapping
Set-SPEnterpriseSearchMetadataMapping


Remove-SPEnterpriseSearchQueryAuthority
[image]

Deletes an authoritative page.

Remove-SPEnterpriseSearchQueryAuthority -Identity <AuthorityPagePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.AuthorityPagePipeBind

Specifies the query authority page to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance a valid AuthorityPage object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the authoritative page collection to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid Search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchQueryAuthority cmdlet adjusts query rank by deleting an authoritative page. SPEnterpriseSearchQueryAuthority represents authoritative sites that rank higher in relevance than demoted sites, which are de-emphasized in relevance.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryAuthority
New-SPEnterpriseSearchQueryAuthority
Set-SPEnterpriseSearchQueryAuthority


Remove-SPEnterpriseSearchQueryComponent
[image]

Deletes a query component.

Remove-SPEnterpriseSearchQueryComponent -Identity <QueryComponentPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-QueryTopology <QueryTopologyPipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.QueryComponentPipeBind

Specifies the query component to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryComponent object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

QueryTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the query component collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchQueryComponent cmdlet deletes a query component from the query component collection.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryComponent
New-SPEnterpriseSearchQueryComponent
Get-SPEnterpriseSearchQueryTopology


Remove-SPEnterpriseSearchQueryDemoted
[image]

Deletes a demoted site rule.

Remove-SPEnterpriseSearchQueryDemoted -Identity <DemotedPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.DemotedPipeBind

Specifies the demoted site rule to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid Demoted object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the demoted site collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchQueryDemoted cmdlet adjusts query rank by deleting a demoted site rule from the demoted site collection. Query demoted sites are de-emphasized in relevance.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryDemoted
New-SPEnterpriseSearchQueryDemoted


Remove-SPEnterpriseSearchQueryKeyword
[image]

Deletes a query keyword.

Remove-SPEnterpriseSearchQueryKeyword -Identity <KeywordPipeBind> -Site <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.KeywordPipeBind

Specifies the keyword term to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid string that contains a keyword term (for example, KeywordTerm1); or an instance of a valid Keyword object.

Site

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Filters to delete keywords from the specified site collection of results.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchQueryKeyword cmdlet deletes unused or unwanted keywords from the query keyword collection.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryKeyword
New-SPEnterpriseSearchQueryKeyword
Set-SPEnterpriseSearchQueryKeyword


Remove-SPEnterpriseSearchQueryScope
[image]

Deletes a query scope.

Remove-SPEnterpriseSearchQueryScope -Identity <ScopePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-Url <Uri>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Specifies the query scope to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope (for example, Scope1); or an instance of a valid Scope object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope collection.

The type must be a valid GUID, of the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Url

Optional

System.Uri

Filters to delete scopes of the specified results URL.

The type must be a valid URL, in the form http://server_name.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchQueryScope cmdlet deletes one or more specified shared scopes from the query scope collection. A query scope represents a query results scope used by all shared search applications on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryScope
New-SPEnterpriseSearchQueryScope
Set-SPEnterpriseSearchQueryScope
Get-SPEnterpriseSearchQueryScopeRule


Remove-SPEnterpriseSearchQueryScopeRule
[image]

Deletes query results scope rules.

Remove-SPEnterpriseSearchQueryScopeRule -Identity <ScopeRulePipeBind> -Url <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Scope <ScopePipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ScopeRulePipeBind

Specifies the scope rule to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope rule (for example, ScopeRule1); or an instance of a valid ScopeRule object.

Url

Required

System.Uri

Filters to delete query scope rules for the specified results URL.

The type must be a valid URL, in the form http://server_name.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Scope

Optional

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Filters to delete multiple rules for a specified scope.

The type must be a valid string that identifies the scope; for example, Scope1.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope rule collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchQueryScopeRule cmdlet deletes one or more shared scope rules from the scope rule collection.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryScopeRule
New-SPEnterpriseSearchQueryScopeRule
Set-SPEnterpriseSearchQueryScopeRule
Get-SPEnterpriseSearchQueryScope


Remove-SPEnterpriseSearchQueryTopology
[image]

Deletes a query topology.

Remove-SPEnterpriseSearchQueryTopology -Identity <QueryTopologyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchQueryTopology cmdlet deletes a specified query topology from the query topology collection.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchQueryTopology
New-SPEnterpriseSearchQueryTopology
Set-SPEnterpriseSearchQueryTopology


Remove-SPEnterpriseSearchRankingModel
[image]

Deletes a ranking model.

Remove-SPEnterpriseSearchRankingModel -Identity <RankingModelPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.RankingModelPipeBind

Specifies the ranking model to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid RankingModel object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the ranking model.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchRankingModel cmdlet deletes a specified ranking model.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchRankingModel
New-SPEnterpriseSearchRankingModel
Set-SPEnterpriseSearchRankingModel


Remove-SPEnterpriseSearchSecurityTrimmer
[image]

Deletes a custom security trimmer.

Remove-SPEnterpriseSearchSecurityTrimmer -Identity <SecurityTrimmerPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SecurityTrimmerPipeBind

Specifies the pluggable security trimmer to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid SecurityTrimmer object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the security trimmer.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchSecurityTrimmer cmdlet deletes the customized security trimmer that is used for a search application's query results. A custom security trimmer trims search results before the results are returned to the user.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchSecurityTrimmer
New-SPEnterpriseSearchSecurityTrimmer


Remove-SPEnterpriseSearchServiceApplication
[image]

Deletes a search service application.

Remove-SPEnterpriseSearchServiceApplication -Identity <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search service application to delete.

A valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchServiceApplication cmdlet deletes a specified search service application from a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchServiceApplication
New-SPEnterpriseSearchServiceApplication
Set-SPEnterpriseSearchServiceApplication
Get-SPEnterpriseSearchService
Get-SPEnterpriseSearchServiceInstance


Set-SPEnterpriseSearchCrawlContentSource
[image]

Sets the properties of a crawl content source for a shared search application.

Set-SPEnterpriseSearchCrawlContentSource -Identity <ContentSourcePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-BDCApplicationProxy <SPServiceApplicationProxyPipeBind>] [-Confirm [<SwitchParameter>]] [-CrawlPriority <Nullable>] [-FullCrawlSchedule <String>] [-FullCrawlScheduleDay <Nullable>] [-FullCrawlScheduleHour <Nullable>] [-FullCrawlScheduleMinute <Nullable>] [-FullCrawlScheduleMonth <Nullable>] [-FullCrawlScheduleRepeatDuration <Nullable>] [-FullCrawlScheduleRepeatInterval <Nullable>] [-FullCrawlScheduleStartDate <DateTime>] [-FullCrawlScheduleWeek <Nullable>] [-IncrementalCrawlSchedule <String>] [-IncrementalCrawlScheduleDay <Nullable>] [-IncrementalCrawlScheduleHour <Nullable>] [-IncrementalCrawlScheduleMinute <Nullable>] [-IncrementalCrawlScheduleMonth <Nullable>] [-IncrementalCrawlScheduleRepeatDuration <Nullable>] [-IncrementalCrawlScheduleRepeatInterval <Nullable>] [-IncrementalCrawlScheduleStartDate <DateTime>] [-IncrementalCrawlScheduleWeek <Nullable>] [-LOBSystemSet <String[]>] [-MaxPageEnumerationDepth <Nullable>] [-MaxSiteEnumerationDepth <Nullable>] [-Name <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-SharePointCrawlBehavior <Nullable>] [-StartAddresses <String>] [-Tag <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ContentSourcePipeBind

Specifies the crawl content source to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a ContentSource object (for example, ContentSource1); or an instance of a valid ContentSource object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

FullCrawlSchedule

Optional

System.String

Specifies the description of the full crawl schedule.

The type must be one of the following values: daily, monthly, weekly, or monthlydayofweek.

FullCrawlScheduleDay

Optional

System.Nullable

Specifies the day of the month to start the full crawl.

FullCrawlScheduleHour

Optional

System.Nullable

Specifies the hour at which to start the full crawl.

FullCrawlScheduleMinute

Optional

System.Nullable

Specifies the minute at which to start the full crawl.

FullCrawlScheduleMonth

Optional

System.Nullable

Specifies the month of the year in which to start the full crawl.

FullCrawlScheduleRepeatDuration

Optional

System.Nullable

Specifies the number of times to repeat the full crawl schedule.

FullCrawlScheduleRepeatInterval

Optional

System.Nullable

Specifies the number of minutes between each repeat interval for the full crawl schedule.

FullCrawlScheduleStartDate

Optional

System.DateTime

Specifies the initial date of first full crawl.

FullCrawlScheduleWeek

Optional

System.Nullable

Specifies the weeks of the month in which the full crawl starts.

IncrementalCrawlSchedule

Optional

System.String

Specifies the description of the incremental crawl schedule.

The type must be one of the following values: daily, monthly, weekly, or monthlydayofweek.

IncrementalCrawlScheduleDay

Optional

System.Nullable

Specifies the day of the month to start the incremental crawl.

IncrementalCrawlScheduleHour

Optional

System.Nullable

Specifies the hour at which to start the incremental crawl.

IncrementalCrawlScheduleMinute

Optional

System.Nullable

Specifies the minute at which to start the incremental crawl.

IncrementalCrawlScheduleMonth

Optional

System.Nullable

Specifies the month of the year in which to start the incremental crawl.

IncrementalCrawlScheduleRepeatDuration

Optional

System.Nullable

Specifies the number of times to repeat the full incremental schedule.

IncrementalCrawlScheduleRepeatInterval

Optional

System.Nullable

Specifies the number of minutes between each repeat interval for the incremental crawl schedule.

IncrementalCrawlScheduleStartDate

Optional

System.DateTime

Specifies the initial date of first incremental crawl.

IncrementalCrawlScheduleWeek

Optional

System.Nullable

Specifies the weeks of the month that the full incremental starts.

Name

Optional

System.String

Specifies the weeks of the month in which the full incremental starts.

The type must be a valid name of a content source; for example, ContentSource1.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the content source.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

StartAddresses

Optional

System.String

Tag

Optional

System.String

Specifies the URL for the page to modify the settings for a custom content source. The string that specifies the URL can contain a maximum of 1024 characters.

The type must be a valid URL, in the form http://server_name.

ThrottleBegin

Optional

System.Nullable

Not used

ThrottleDuration

Optional

System.Nullable

Not used

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchCrawlContentSource cmdlet updates the rules of content source when the search functionality is initially configured and after any new content source is added.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlContentSource
New-SPEnterpriseSearchCrawlContentSource
Remove-SPEnterpriseSearchCrawlContentSource


Set-SPEnterpriseSearchCrawlTopology
[image]

Sets the properties of a crawl topology on a shared search application.

Set-SPEnterpriseSearchCrawlTopology -Identity <CrawlTopologyPipeBind> [-Active <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlTopologyPipeBind

Specifies the crawl topology to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid CrawlTopology object.

Active

Optional

System.Management.Automation.SwitchParameter

Activates the specified topology. An active crawl topology is currently serving crawls for the search application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl topology collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchCrawlTopology cmdlet updates the properties of a specified crawl topology. A crawl topology contains the crawl component collection for a topology on a shared search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
Get-SPEnterpriseSearchCrawlTopology
New-SPEnterpriseSearchCrawlTopology
Remove-SPEnterpriseSearchCrawlTopology


Set-SPEnterpriseSearchIndexPartition
[image]

Sets properties of an index partition for a query topology.

Set-SPEnterpriseSearchIndexPartition -Identity <IndexPartitionPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-PropertyDatabase <PropertyStorePipeBind>] [-QueryTopology <QueryTopologyPipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.IndexPartitionPipeBind

Specifies the index partition to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid IndexPartition object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

PropertyStore

Optional

Microsoft.Office.Server.Search.Cmdlet.PropertyStorePipeBind

Specifies the property store to update.

A valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid property store name (for example, PropertyStore1); or an instance of a valid PropertyStore object.

QueryTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the index partition collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchIndexPartition cmdlet updates properties of an index partition. Index partitions define how document identifiers (IDs) are mapped to the query components for full-text user queries for a shared search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Get-SPEnterpriseSearchPropertyStore
Reference
Get-SPEnterpriseSearchIndexPartition
Get-SPEnterpriseSearchQueryTopology


Set-SPEnterpriseSearchMetadataCategory
[image]

Sets properties of a crawled property category for a shared search application.

Set-SPEnterpriseSearchMetadataCategory -Identity <CategoryPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-AutoCreateNewManagedProperties <Nullable>] [-Confirm [<SwitchParameter>]] [-DiscoverNewProperties <Nullable>] [-MapToContents <Nullable>] [-Name <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CategoryPipeBind

Specifies the metadata category to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

AutoCreateNewManagedProperties

Optional

System.Nullable

Specifies that new managed properties are mapped when new crawled properties in this category are found.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DiscoverNewProperties

Optional

System.Nullable

Specifies that new properties in this category are discovered during a crawl.

MapToContents

Optional

System.Nullable

Specifies that all string crawled properties are mapped to content.

Name

Optional

System.String

Specifies the name of the enterprise search metadata category.

The type must be a valid name of a metadata category; for example, MetadataCategory1.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the enterprise search metadata categories.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchMetadataCategory cmdlet updates properties of a crawled property category when the search functionality is initially configured and after a new crawled property category is discovered during a crawl. SPEnterpriseSearchMetadataCategory represents a category in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchMetadataCategory
Get-SPEnterpriseSearchMetadataCategory
Remove-SPEnterpriseSearchMetadataCategory


Set-SPEnterpriseSearchMetadataCrawledProperty
[image]

Sets the properties of a metadata crawled property for a shared search application.

Set-SPEnterpriseSearchMetadataCrawledProperty -Identity <CrawledPropertyPipeBind> -IsMappedToContents <Nullable> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawledPropertyPipeBind

Specifies the crawled property to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawledProperty object.

IsMappedToContents

Required

System.Nullable

Specifies that the crawled property is mapped to managed properties.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawled property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Category

Optional

Microsoft.Office.Server.Search.Cmdlet.CategoryPipeBind

Adds the crawled property to the specified metadata category.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a metadata category (for example, MetadataCategory1); or an instance of a valid Category object.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

PropSet

Optional

System.Nullable

Creates the new metadata property with the specified property set.

A valid GUID that specifies the property set, in the form 12345678-90ab-cdef-1234-567890bcdefgh.

VariantType

Optional

System.Nullable

Adds the crawled property as the specified variant type. For more information about valid values for this property, see VARIANT Type Constants (http://go.microsoft.com/fwlink/?LinkId=143322&clcid=0x409).

The type must be an integer that specifies a valid variant data type of the property set.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchMetadataCrawledProperty cmdlet updates properties of a crawled property when the search functionality is initially configured and after any new crawled property is added to create the rules for the crawled property. SPEnterpriseSearchMetadataCrawledProperty represents a crawled property in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchMetadataCrawledProperty
Get-SPEnterpriseSearchMetadataCrawledProperty
Other Resources
VARIANT Type Constants (http://go.microsoft.com/fwlink/?LinkId=143322&clcid=0x409)


Set-SPEnterpriseSearchMetadataManagedProperty
[image]

Sets the properties of a metadata managed property.

Set-SPEnterpriseSearchMetadataManagedProperty -Identity <ManagedPropertyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultForQueryIndependentRank <Nullable>] [-Description <String>] [-EnabledForQueryIndependentRank <Nullable>] [-EnabledForScoping <Nullable>] [-FullTextQueriable <Nullable>] [-IncludeInMd5 <Nullable>] [-Name <String>] [-NameNormalized <Nullable>] [-NoWordBreaker <Nullable>] [-RemoveDuplicates <Nullable>] [-RespectPriority <Nullable>] [-Retrievable <Nullable>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-UserFlags <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Specifies the managed property to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DefaultForQueryIndependentRank

Optional

System.Nullable

Specifies that the property is mandatory when it is used in query-independent rank (relevance).

Description

Optional

System.String

Adds a description for the new metadata managed property.

The type must be a valid string; for example, a description for a metadata managed property.

EnabledForQueryIndependentRank

Optional

System.Nullable

Specifies that the managed property is mandatory when it is used in the custom ranking model for the query-independent work of ranking.

The type must be one of the following query-independent ranking features in the custom model XML:

  • queryIndependentFeature

  • categoryFeature

  • languageFeature

EnabledForScoping

Optional

System.Nullable

Specifies that the property can be used in a scope definition. The default value is 0.

FullTextQueriable

Optional

System.Nullable

Specifies that the managed property can be used in enterprise search SQL queries.

IncludeInMd5

Optional

System.Nullable

Specifies that the managed property is included in the hash used by the crawler to determine whether a document has changed. The default value is 0.

Name

Optional

System.String

Specifies a name for the managed property.

The type must be a valid managed property name; for example, ManagedProperty1.

NameNormalized

Optional

System.Nullable

Specifies that the managed property has been converted to the full name. The default value is 0.

NoWordBreaker

Optional

System.Nullable

Specifies that the values for this property are processed by a word breaker. The default value is 0.

RemoveDuplicates

Optional

System.Nullable

Specifies that duplicate values for the property are removed. The default value is 1.

RespectPriority

Optional

System.Nullable

Specifies that only one instance of the property exists for an item. The default value is 0.

Retrievable

Optional

System.Nullable

Specifies that the property can be used for advanced search or keyword queries, and that the value for this property can be retrieved in search results.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the managed property collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

UserFlags

Optional

System.Nullable

Reserved for future use.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchMetadataManagedProperty cmdlet updates the properties of a managed property. This cmdlet is used typically to change the name or description of a managed property. SPEnterpriseSearchMetadataManagedProperty represents a managed property in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchMetadataManagedProperty
Get-SPEnterpriseSearchMetadataManagedProperty
Remove-SPEnterpriseSearchMetadataManagedProperty


Set-SPEnterpriseSearchMetadataMapping
[image]

Sets the properties of a managed property mapping for a shared search application.

Set-SPEnterpriseSearchMetadataMapping -Identity <MappingPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-CrawledProperty <CrawledPropertyPipeBind>] [-ManagedProperty <ManagedPropertyPipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.MappingPipeBind

Specifies the metadata mapping to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawlMapping object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the metadata mappings.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

CrawledProperty

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawledPropertyPipeBind

Specifies the crawled property to map.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid CrawledProperty object.

CrawledPropertyPropSet

Optional

System.Nullable

Specifies the property set of the crawled property to map to the specified managed property.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh.

CrawledPropertyVariantType

Optional

System.Int32

Specifies the variant type for the specified crawled property.

ManagedProperty

Optional

Microsoft.Office.Server.Search.Cmdlet.ManagedPropertyPipeBind

Specifies the managed property to receive the crawled property mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a managed property (for example, ManagedProperty1); or an instance of a valid ManagedProperty object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchMetadataMapping cmdlet updates properties of a managed property mapping. SPEnterpriseSearchMetadataMapping represents a snapshot of a mapping between a managed property and one or more crawled properties in the enterprise search metadata property schema.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchMetadataMapping
Get-SPEnterpriseSearchMetadataMapping
Remove-SPEnterpriseSearchMetadataMapping
Other Resources
VARIANT Type Constants


Set-SPEnterpriseSearchQueryAuthority
[image]

Sets the properties of an authoritative page for a shared search application.

Set-SPEnterpriseSearchQueryAuthority -Identity <AuthorityPagePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Level <Nullable>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.AuthorityPagePipeBind

Specifies the query authority page to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid AuthorityPage object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Level

Required

System.Single

Specifies the level of the new authoritative page. Authoritative pages, designated by the service application administrator, are expert pages that link to the most relevant information. Because a search service application can have several designated authoritative pages, you use the Level property to specify the value of a specific page. This parameter sets the level for the most valuable authoritative pages to 0.

The type must be one of the following floating-point numbers: 0, 1, or 2.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the authority page collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchQueryAuthority cmdlet updates properties of an authoritative page and adjusts the query rank of an authoritative page. SPEnterpriseSearchQueryAuthority represents authoritative sites that rank higher in relevance than demoted sites, which are de-emphasized in relevance.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.

Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryAuthority
Get-SPEnterpriseSearchQueryAuthority
Remove-SPEnterpriseSearchQueryAuthority


Set-SPEnterpriseSearchQueryKeyword
[image]

Sets the properties of a keyword term for a shared search application.

Set-SPEnterpriseSearchQueryKeyword -Identity <KeywordPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Contact <String>] [-Definition <String>] [-EndDate <Nullable>] [-ReviewDate <Nullable>] [-Site <SPSitePipeBind>] [-StartDate <Nullable>] [-Term <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.KeywordPipeBind

Specifies the keyword term to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid string that contains a keyword term (for example, KeywordTerm1); or an instance of a valid Keyword object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Contact

Optional

System.String

Specifies the user name associated with the new keyword.

The type must be a valid user name; for example, KeywordUser1.

Definition

Optional

System.String

Specifies the definition of the new keyword term.

The type must be a valid string; for example, a keyword term definition.

EndDate

Optional

System.Nullable

Specifies the expiration date of the keyword term. The default value is MaxDate.

The type must be a valid DateTime type, in the form 2010,12,05.

ReviewDate

Optional

System.Nullable

Specifies the review date of the keyword term. The default value is MaxDate.

The type must be a valid date, in the form 2010,12,05.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query keyword collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Site

Optional

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Associates the new keyword term to the specified results URL.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

StartDate

Optional

System.Nullable

Specifies the activation date for the keyword term. The default value is the current date.

The type must be a valid date, in the form 2010,12,05.

Term

Optional

System.String

Specifies the keyword term that triggers keyword results.

The type must be a valid string; for example, a keyword term.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchQueryKeyword cmdlet updates properties and rules of a keyword term. A query keyword is a query component of a query topology. SPEnterpriseSearchQueryKeyword represents relevance setting through keywords.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryKeyword
Get-SPEnterpriseSearchQueryKeyword
Remove-SPEnterpriseSearchQueryKeyword


Set-SPEnterpriseSearchQueryScope
[image]

Sets the properties of a query results scope for a shared search application.

Set-SPEnterpriseSearchQueryScope -Identity <ScopePipeBind> -AlternateResultsPage <String> [-AssignmentCollection <SPAssignmentCollection>] [-CompilationType <Nullable>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-DisplayInAdminUI <Nullable>] [-Name <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-Url <Uri>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Specifies the identity of the scope to create.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope (for example, Scope1); or an instance of a valid Scope object.

AlternateResultsPage

Required

System.String

Specifies the location to display results for the new query scope.

The type must be a valid URL, in the form http://server_name.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CompilationType

Optional

System.Nullable

Specifies the compilation type of the new scope. The value 0 specifies the conditionally compiled scope type, and the value 1 specifies the always compiled scope type.

The type must be either of the following: 0 or 1.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Description

Optional

System.String

Adds a description of the new query scope.

The type must be a valid string; for example, a description of a query scope.

DisplayInAdminUI

Optional

System.Nullable

Specifies that the new scope is displayed in the administration application user interface (UI). The default setting is to hide the new scope in the administration application UI.

Name

Optional

System.String

Specifies a name for the query scope.

The type must be a valid name of a query scope; for example, QueryScope1.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Url

Optional

System.Uri

Filters to delete scopes for the specified results URL.

The type must be a valid URL, in the form http://server_name.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchQueryScope cmdlet updates properties of a shared scope. SPEnterpriseSearchQueryScope represents a query results scope used by all shared search applications on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryScope
Get-SPEnterpriseSearchQueryScope
Remove-SPEnterpriseSearchQueryScope
Get-SPEnterpriseSearchQueryScopeRule


Set-SPEnterpriseSearchQueryScopeRule
[image]

Sets the properties of a shared scope rule for a query scope.

Set-SPEnterpriseSearchQueryScopeRule -Identity <ScopeRulePipeBind> -Url <Uri> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-FilterBehavior <String>] [-ManagedPropertyName <String>] [-MatchingString <String>] [-PropertyValue <String>] [-Scope <ScopePipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-UrlScopeRuleType <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ScopeRulePipeBind

Specifies the scope rule to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope rule (for example, ScopeRule1); or an instance a valid ScopeRule object.

Url

Required

System.Uri

Specifies the results URL that is associated with the query scope rule.

The type must be a valid URL, in the form http://server_name.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

FilterBehavior

Optional

System.String

Specifies the type of scope rule to create for the query scope.

The type must be one of the following values: Exclude, Include, or Require.

ManagedPropertyName

Optional

System.String

Specifies the name of the managed property to use for the PropertyQuery scope rule.

The type must be a valid name of a managed property; for example, ManagedProp1.

MatchingString

Optional

System.String

Specifies the string to use when matching the URL rule type.

PropertyValue

Optional

System.String

Specifies the property value to use when matching the PropertyQuery rule type.

Scope

Optional

Microsoft.Office.Server.Search.Cmdlet.ScopePipeBind

Applies the query scope rule to the specified scope.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a scope (for example, Scope1); or an instance of a valid Scope object.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query scope rule collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

UrlScopeRuleType

Optional

System.String

Specifies the value to use when matching the URL rule type.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchQueryScopeRule cmdlet updates the properties of a query scope. SPEnterpriseSearchQueryScopeRule represents a query results scope rule that can be applied to a scope.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryScopeRule
Get-SPEnterpriseSearchQueryScopeRule
Remove-SPEnterpriseSearchQueryScopeRule
Get-SPEnterpriseSearchQueryScope


Set-SPEnterpriseSearchQueryTopology
[image]

Sets the properties of a query topology for a shared search application.

Set-SPEnterpriseSearchQueryTopology -Identity <QueryTopologyPipeBind> [-Active <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

Active

Optional

System.Management.Automation.SwitchParameter

Activates the topology to assume handling queries. An active query topology is currently serving queries for the search application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchQueryTopology cmdlet updates properties of a query topology. A topology can contain multiple query topologies when a query component or index partition is added to or deleted from a topology.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchQueryTopology
Get-SPEnterpriseSearchQueryTopology
Remove-SPEnterpriseSearchQueryTopology


Set-SPEnterpriseSearchRankingModel
[image]

Sets the properties of a ranking model for a shared search application.

Set-SPEnterpriseSearchRankingModel -Identity <RankingModelPipeBind> -RankingModelXML <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.RankingModelPipeBind

Specifies the ranking model to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid RankingModel object.

RankingModelXML

Required

System.String

Specifies the name of the XML representation of the new ranking model.

The type must be a valid name of an .xml file; for example, XMLfilename1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the ranking model.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchRankingModel cmdlet updates properties of a ranking model for a query service application. The name, description, and identifier (ID) for a ranking model are contained in the .xml file specified in RankingModelXML. If the Identity parameter is not specified or the identity does not match any of the ranking models in the collection, an exception is thrown and the default ranking model is used.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchRankingModel
Get-SPEnterpriseSearchRankingModel
Remove-SPEnterpriseSearchRankingModel


Set-SPEnterpriseSearchService
Example
[image]

Sets the properties of a search service for a farm.

Set-SPEnterpriseSearchService [-Identity <SearchServicePipeBind>] [-AcknowledgementTimeout <String>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ConnectionTimeout <String>] [-ContactEmail <String>] [-IgnoreSSLWarnings <String>] [-InternetIdentity <String>] [-PerformanceLevel <String>] [-ProxyType <String>] [-ServiceAccount <String>] [-ServicePassword <SecureString>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServicePipeBind

Specifies the search service to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchService1); or an instance of a valid SearchService object.

AcknowledgementTimeout

Optional

System.String

Specifies the amount of time in seconds that the search server will wait for request acknowledgment while connecting to other services.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

ConnectionTimeout

Optional

System.String

Specifies the amount of time in seconds that the search server waits while connecting to other services.

ContactEmail

Optional

System.String

Specifies an e-mail address to which external site administrators can write if problems occur when the site is being crawled.

The type must be a valid e-mail address, in the form MyAddress@mycompany.com.

IgnoreSSLWarnings

Optional

System.String

Specifies that the search service will ignore Secure Sockets Layer (SSL) certificate name warnings.

InternetIdentity

Optional

System.String

Specifies the value that the crawler sends in the headers of its HTTP requests to sites when it fetches their pages.

PerformanceLevel

Optional

System.String

Specifies the relative number of threads for the indexer performance:

Reduced: Total number of threads = number of processors, Max Threads/host = number of processors

Partly Reduced: Total number of threads = 4 times the number of processors , Max Threads/host = 16 time the number of processors

Maximum: Total number of threads = number of processors

The type must be one of the following values: Reduced, PartlyReduced, or Maximum.

ProxyType

Optional

System.String

Specifies whether the search service uses a proxy server or connects directly when crawling content.

ServiceAccount

Optional

System.String

Specifies the user account or service account to use for running the Microsoft Office Server Search service.

The type must be a valid service account; for example, MyAdminAcct1.

ServicePassword

Optional

System.String

Specifies the password for the service account specified in ServiceAccount.

The type must be a valid password.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchService cmdlet updates properties of a search service for a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Set-SPEnterpriseSearchServiceApplication
[image]

Sets the properties of a search service application for a farm.

Set-SPEnterpriseSearchServiceApplication -Identity <SearchServiceApplicationPipeBind> [-AdminApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-ApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultContentAccessAccountName <String>] [-DefaultContentAccessAccountPassword <SecureString>] [-DefaultSearchProvider <Nullable>] [-DiacriticSensitive <String>] [-DuplicateTrimmingMultiplier <Nullable>] [-FailoverDatabaseServer <String>] [-JoinMultiplier <Nullable>] [-SdidJoinMultiplier <Nullable>] [-SecurityTrimmingCacheSize <Nullable>] [-SecurityTrimmingMultiplier <Nullable>] [-VerboseQueryMonitoring <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search service application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DefaultSearchProvider

Optional

System.Nullable

Specifies the search application type to be used for this application:

  • 0 = Default

  • 1 = SharePoint Search

  • 2 = Extended Search

DiacriticSensitive

Optional

System.String

Specifies that the search application respects diacritics (for example, ä).

ExtendedConnectorUrl

Optional

System.Uri

Specifies the path to the Extended Search Connector.

The type must be a valid URI, in the form file:\\server_name\searchapp.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchServiceApplication cmdlet updates properties of a search service application. SPEnterpriseSearchServiceApplication represents a self-contained aggregation of indexed content and properties available for search, and provides an anchor class for setting global search properties. A search application can include multiple search service applications.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
New-SPEnterpriseSearchServiceApplication
Get-SPEnterpriseSearchServiceApplication
Remove-SPEnterpriseSearchServiceApplication


Set-SPEnterpriseSearchServiceInstance
[image]

Sets the properties of a search service instance.

Set-SPEnterpriseSearchServiceInstance -Identity <SearchServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultIndexLocation <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the search service instance to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a query server (for example, MyQueryServer); or an instance of a valid SearchServiceInstance object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DefaultIndexLocation

Optional

System.String

Specifies the default path to use for creating an index of content.

The type must be a valid path in either of the following forms:

  • C:\folder_name

  • \\server_name\folder_name

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchServiceInstance cmdlet updates properties of the search service instance for a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Get-SPEnterpriseSearchServiceInstance
Start-SPEnterpriseSearchServiceInstance
Get-SPEnterpriseSearchService
Get-SPEnterpriseSearchServiceApplication


Start-SPEnterpriseSearchServiceInstance
[image]

Starts an instance of a search service.

Start-SPEnterpriseSearchServiceInstance -Identity <SearchServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the shared search service instance to start.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a query server (for example, MyQueryServer); or an instance of a valid SearchServiceInstance object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Start-SPEnterpriseSearchServiceInstance cmdlet starts an instance of a search service on a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code

  See Also
Reference
Stop-SPEnterpriseSearchServiceInstance
Get-SPEnterpriseSearchServiceInstance
Set-SPEnterpriseSearchServiceInstance


Stop-SPEnterpriseSearchServiceInstance
Example
[image]

Stops an instance of a search service.

Stop-SPEnterpriseSearchServiceInstance -Identity <SearchServiceInstancePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the shared search service instance to stop.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a query server (for example, MyQueryServer); or an instance of a valid SearchServiceInstance object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Stop-SPEnterpriseSearchServiceInstance cmdlet exits an instance of a search service.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Get-SPEnterpriseSearchExtendedClickThroughExtractorJobDefinition
Example
[image]

Gets an object representing the click-through extractor-job instance of a FAST Search for SharePoint specific search service application.

Get-SPEnterpriseSearchExtendedClickThroughExtractorJobDefinition -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the administration component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPEnterpriseSearchExtendedClickThroughExtractorJobDefinition cmdlet to get an object that represents the FASTSearch for SharePoint click-through extractor-job definition.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-------------EXAMPLE---------------
Copy Code
Get-SPEnterpriseSearchExtendedClickThroughExtractorJobDefinition -SearchApplication "Search Service Application"

This example retrieves the click-through extractor-job definition and display its information.
Click here to submit feedback on this topic.


Set-SPEnterpriseSearchExtendedQueryProperty
Example
[image]

Sets FAST Search for SharePoint service specific properties.

Set-SPEnterpriseSearchExtendedQueryProperty -Identity <ExtendedPropertyPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> -Value <Object> [-AssignmentCollection <SPAssignmentCollection>] [-Farm <SPFarmPipeBind>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ExtendedPropertyPipeBind

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the administration component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Value

Required

System.Object

Specifies the value to assign to the property indicated by the Identity parameter.

The expected format for "FASTSearchQueryServiceLocation", "FASTSearchAdminServiceLocation" and "FASTSearchResourceStoreLocation" is server name followed by the port number.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Set-SPEnterpriseSearchExtendedQueryProperty cmdlet to update properties used in a FAST Search for SharePoint specific search service application. The properties are needed to connect Microsoft SharePoint Server 2010with a FAST Search Server back-end and retain information about the location of the FAST Search Query Service and the FAST Search Admin Service. To get available properties, see Get-SPEnterpriseSearchExtendedQueryProperty

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-------------EXAMPLE 1------------

Copy Code
Set-SPEnterpriseSearchExtendedQueryProperty -SearchApplication "Search Service Application" -Identity "FASTSearchQueryServiceLocation" -Value "fastsearchquery.contoso.com:13285"

This example sets the location of the FAST Search Query Service to fastsearchquery.contoso.com port 13285.

-------------EXAMPLE 2------------
Copy Code
Set-SPEnterpriseSearchExtendedQueryProperty -SearchApplication "Search Service Application" -Identity "FASTSearchAdminServiceLocation" -Value "fastsearchadmin.contoso.com:13256"

This example sets the location of the FAST Search Admin Service to fastsearchadmin.contoso.com port 13256.

-------------EXAMPLE 3------------
Copy Code
Set-SPEnterpriseSearchExtendedQueryProperty -SearchApplication "Search Service Application" -Identity "FASTSearchResourceStoreLocation" -Value "http://fastsearchadmin.contoso.com:13255"

This example sets the location of the FAST Search Resource Store to fastsearchadmin.contoso.com port 13255.
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchExtendedConnectorProperty
Example
[image]

Returns the value of the property of the Search Service Application.

Get-SPEnterpriseSearchExtendedConnectorProperty [-Identity <ExtendedConnectorPropertyPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ExtendedConnectorPropertyPipeBind

Specifies the name of the property to be retrieved. The most common property to retrieve is "ContentDistributor".

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the administration component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPEnterpriseSearchExtendedConnectorProperty cmdlet to return the value of the property of a Search Service Application specified by the Identity parameter. The most common property to retrieve is "ContentDistributor". This cmdlet is only valid for a SPSearchServiceApplication whose SearchApplicationType is ExtendedConnector.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-------------EXAMPLE 1---------------
Copy Code
Get-SPEnterpriseSearchExtendedConnectorProperty -Identity "ContentDistributor" -SearchApplication "Search Service Application"

This example retrieves the value of the ContentDistributor property.

-------------EXAMPLE 2---------------
Copy Code
Get-SPEnterpriseSearchExtendedConnectorProperty -SearchApplication "Search Service Application"

This example retrieves all the extended connector properties and their values of the Search Service Application.
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchServiceApplicationProxy
Example
[image]

Returns the search service application proxy.

Get-SPEnterpriseSearchServiceApplicationProxy [-Identity <SearchServiceApplicationProxyPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationProxyPipeBind

Specifies the search service application proxy to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a search service application proxy (for example, SearchServiceAppProxy1); or an instance of a valid SearchServiceApplicationProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchServiceApplicationProxy cmdlet reads the SearchServiceApplicationProxy object when the search service application proxy is created, updated, or deleted. If the Identity parameter is not specified, this cmdlet returns the search service application proxy collection for the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


New-SPEnterpriseSearchServiceApplicationProxy
Example
[image]

Adds a new search application proxy to a farm.

New-SPEnterpriseSearchServiceApplicationProxy -Name <String> -SearchServiceApplicationUri <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Partitioned <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the name of the search application proxy to create.

The type must be a valid string; for example, SearchAppProxy1.

SearchServiceApplicationUri

Required

System.String

Specifies the URI to the search application to use for search.

The type must be a valid URI, in the form file:\\server_name\searchapp.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Partitioned

Optional

System.Management.Automation.SwitchParameter

Specifies that the search service application must use Web-hosted mode. Web-hosted mode segregates results for a given hosted subscription.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchServiceApplicationProxy cmdlet creates a proxy for a search service application. The search service application proxy can be used by a Web application or another service consumer to use the functionality provided by the search application..

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Remove-SPEnterpriseSearchServiceApplicationProxy
Example
[image]

Deletes a search service application proxy.

Remove-SPEnterpriseSearchServiceApplicationProxy -Identity <SearchServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationProxyPipeBind

Specifies the search service application proxy to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a service application proxy (for example, ServiceAppProxy1); or an instance of a valid SearchServiceApplicationProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchServiceApplicationProxy cmdlet deletes the specified search service application proxy from a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Restart-SPEnterpriseSearchQueryComponent
Example
[image]

Restarts a failed query component.

Restart-SPEnterpriseSearchQueryComponent -Identity <QueryComponentPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-QueryTopology <QueryTopologyPipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.QueryComponentPipeBind

Specifies the query component to restart.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryComponent object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

QueryTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the query component collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Restart-SPEnterpriseSearchQueryComponent cmdlet recovers a failed query component from its redundant component under the same index partition. There must be redundant query components (at least two) serving one index partition, one of which being in Ready state.

If this query component is offline because of some failures —for example, index corruption, low disk, or out-of- sync — a user can recover this component by running this cmdlet.

Note:
Although the Restart-SPEnterpriseSearchQueryComponent cmdlet is designed to recover a failed (offline) query component, it can also be called on a Ready component to clone one that has the same index files as its source component.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code


Restore-SPEnterpriseSearchServiceApplication
Example
[image]

Restores third-party backup of a search application.

Restore-SPEnterpriseSearchServiceApplication -Name <String> -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AdminApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-AdminSearchServiceInstance <SearchServiceInstancePipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseName <String>] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-TopologyFile <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Set 1

Parameter Required Type Description

Name

Required

System.String

Specifies the new Search application name.

ApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the application pool for the query Web service.

AdminApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the application pool for the administrative Web service.

AdminSearchServiceInstance

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the search service instance to be used with the administration component.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabaseName

Optional

System.String

Specifies the name of the database to create for the restoring the search application.

The type must be a valid name of a SQL Server database; for example, RestoreDB1.

DatabasePassword

Optional

System.String

Specifies the name of the password for the database server on the Microsoft SQL Server.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database specified in DatabaseName.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the account name specified in the Database Server parameter.

FailoverDatabaseServer

Optional

System.String

Use this parameter if you want the administration database to use a failover database server.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameters

Parameter Set 2

Parameter Required Type Description

ApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the application pool for the query Web service.

TopologyFile

Required

System.String

Specifies the path the the .XML file that contains the application topology information.

AdminApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the application pool for the administrative Web service.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Restore-SPEnterpriseSearchServiceApplication cmdlet is used by third-parties to create a search application that uses existing data.

Some third parties back up the application data and need to restore the application later. So the data is restored and uses the Restore-SPEnterpriseSearchServiceApplication cmdlet to create a new search application using the restored data.

This cmdlet supports parameter sets. The first set of parameters is for Application Configuration Attach mode and the second set of parameters is for Search Application Attach mode.

Application Configuration Attach only restores configuration data that is stored in the administration database. However, Search Application Attach restores configuration, topology and all crawled data.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-------------EXAMPLE 1--------------
Copy Code
$searchInstance = Get-SPEnterpriseSearchServiceInstance -local
$applicationPool = New-SPIisWebServiceApplicationPool -Name "SearchServiceApplicationPool"
Copy Code
Restore-SPEnterpriseSearchServiceApplication -Name "SearchServiceApplication" -ApplicationPool $applicationPool -AdminSearchServiceInstance $searchInstance -DatabaseName "SearchServiceApplication_Admindb" -DatabaseServer "SQLServer1"

This example uses Application Configuration Attach mode to restore configuration data.

-------------EXAMPLE 2--------------
Copy Code
$applicationPool = New-SPIisWebServiceApplicationPool -Name "SearchServiceApplicationPool"
Copy Code
Restore-SPEnterpriseSearchServiceApplication -Name "SearchServiceApplication" -ApplicationPool $applicationPool -TopologyFile "C:\TopologyFile.xml"

This example uses Search Application Attach mode to restore a toplogoy data in the file named "topology.xml".
Click here to submit feedback on this topic.


Set-SPEnterpriseSearchExtendedConnectorProperty
Example
[image]

Sets the value of an ExtendedConnector object.

Set-SPEnterpriseSearchExtendedConnectorProperty -Identity <ExtendedConnectorPropertyPipeBind> -Value <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.ExtendedConnectorPropertyPipeBind

Specifies the name of the property to be set. The most common property to set is ContentDistributor.

Value

Required

System.String

Specifies the format for ContentDistributor in the form of a fully qualified domain name followed by the port number.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the administration component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchExtendedConnectorProperty cmdlet sets the value of the ExtendedConnetor object. The most common property to set is ContentDistributor. This cmdlet is valid only for a SearchServiceApplication object whose SearchApplicationType is a ExtendedConnector property.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------EXAMPLE--------------
Copy Code
Set-SPEnterpriseSearchExtendedConnectorProperty -Identity "ContentDistributor" -Value "server.example.com:16100" -SearchApplication "Search Service Application"

This example sets the value of the ContentDistributor property.
Click here to submit feedback on this topic.


Set-SPEnterpriseSearchServiceApplicationProxy
Example
[image]

Sets properties of a search service application proxy.

Set-SPEnterpriseSearchServiceApplicationProxy -Identity <SearchServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationProxyPipeBind

Specified the search service application proxy to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a search service application proxy (for example, SearchServiceAppProxy1); or an instance of a valid SearchServiceApplicationProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Name

Optional

System.String

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchServiceApplicationProxy cmdlet updates properties of a site administration service application proxy for a search application. SPEnterpriseSearchServiceApplicationProxy represents the proxy for search site administration functionality. One search service application proxy exists for each search application on a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.
Copy Code


Upgrade-SPEnterpriseSearchServiceApplication
Example
[image]

Upgrades a search service application.

Upgrade-SPEnterpriseSearchServiceApplication -Identity <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search service application to upgrade.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Upgrade-SPEnterpriseSearchServiceApplication cmdlet starts an upgrade process on a search service application. This cmdlet runs the associated upgrade actions for the search service application. Also, you can upgrade multiple search service applications in parallel by launching several instances of this cmdlet. It is not necessary to run this cmdlet if you have already run the SharePoint Products and Technologies Configuration Wizard.

Note:
For the upgrade process to run successful, all of the computers in the farm must have the same version of binaries installed.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------EXAMPLE 1-----------------
Copy Code
Get-SPEnterpriseSearchServiceApplication | Upgrade-SPEnterpriseSearchServiceApplication

This example upgrades a search service application.

----------------EXAMPLE 2-----------------
Copy Code
Upgrade-SPEnterpriseSearchServiceApplication -Identity 846ceb0b-31d6-4c79-82c1-3a9deafe0b45

This example upgrades a search service application.

----------------EXAMPLE 3-----------------
Copy Code
Upgrade-SPEnterpriseSearchServiceApplication "DefaultSearchApplication"

This example upgrades a search service application.
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchAdministrationComponent
Example
[image]

Returns the administration component for a search service application.

Get-SPEnterpriseSearchAdministrationComponent -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the administration component.

The type must be a valid name (GUID), in the form 12345678-90ab-cdef-1234-567890bcdefgh; or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPEnterpriseSearchAdmininstrationComponent cmdlet to retrieve an administration component for a search service application in order to update or delete it.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE 1----------------

Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication ExampleSearchServiceApplication
$adminCmpnt = Get-SPEnterpriseSearchAdministrationComponent
  -SearchApplication $searchApp

This example obtains an object reference to the admin component of a search service application named "ExampleSearchServiceApplication"..
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchCrawlCustomConnector
Example
[image]

Returns a CustomConnector object type.

Get-SPEnterpriseSearchCrawlCustomConnector -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Protocol <String>]

Parameters

Parameter Required Type Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the Search application with which the CustomConnector objects are associated.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Protocol

Optional

System.String

Specifies the string version of the protocol for which to return the customconnector. For example, "dctm://"

Detailed Description

To display a custom connector for a specified Web application, use the Identity parameter. If no parameters are specified, all the objects of the CustomConnector object type are returned.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------------EXAMPLE----------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication MySearchServiceApp
$crawlConn = Get-SPEnterpriseSearchCrawlCustomConnector -SearchApplication
$searchApp -Protocol "http://"

This example obtains a reference to all custom crawl connectors for the http:// protocol for a search service application named "MySearchServiceApp".
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchCrawlDatabase
Example
[image]

Returns a crawl store.

Get-SPEnterpriseSearchCrawlDatabase [-Identity <CrawlStorePipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawlStorePipeBind

Specifies the crawl database to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a CrawlStore object, in the form CrawlStore1; or an instance of a valid CrawlStore object.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl database.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-SPEnterpriseSearchCrawlDatabase cmdlet returns a CrawlStore object for use during configuration and when a crawl database for a search service application is modified or deleted. A crawl database stores crawl history data for a search service application

If the Identity parameter is not specified, this cmdlet returns the crawl database collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-------------------EXAMPLE-------------

Copy Code
$crawlDatabase = Get-SPEnterpriseSearchCrawlDatabase -SearchApplication
MySearchServiceApp -Identity CrawlDB_1

This example gets a reference to the crawl database with the name "CrawlDB_1" from the search service application named "MySearchServiceApp".
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchCrawlRule
Example
[image]

Access crawl rules.

Get-SPEnterpriseSearchCrawlRule [-Identity <CrawlRulePipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.CrawlRulePipeBind

Specifies the search crawl rule path. A valid URL, such as "http://server_name", or an instance of a valid CrawlRule object

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the Search Application that contains the crawl rule. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPEnterpriseSearchCrawlRule cmdlet for a search administrator to run this procedure to retrieve the crawl rule when the crawl rule is updated or deleted.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

---------------EXAMPLE 1-----------------

Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication ExampleSearchServiceApplication
$crawlRule = Get-SPEnterpriseSearchCrawlRule -SearchApplication  $searchApp -Identity http://example
$crawlRule | Set-SPEnterpriseSearchCrawlRule -Type InclusionRule

This example uses the Get-SPEnterpriseSearchCrawlRule cmdlet to retrieve a crawl rule in order to change its Type from ExclusionRule to InclusionRule.

---------------EXAMPLE 2-----------------

Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication MySearchServiceApp Get-SPEnterpriseSearchCrawlRule -SearchApplication $searchApp | where
{$_.Path -like "*example*"}

This example returns a list of crawl rules with paths that contain the word "example" from the search service application, MySearchServiceApp.
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchExtendedQueryProperty
Example
[image]

This is the introduction.

Get-SPEnterpriseSearchExtendedQueryProperty [-Identity <ExtendedPropertyPipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.ExtendedPropertyPipeBind

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Enter detail description

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code


Get-SPEnterpriseSearchPropertyDatabase
Example
[image]

Returns a property store.

Get-SPEnterpriseSearchPropertyDatabase [-Identity <PropertyStorePipeBind>] -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-IndexPartition <IndexPartitionPipeBind>] [-QueryTopology <QueryTopologyPipeBind>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.PropertyStorePipeBind

Specifies the property store to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid property store name (for example, PropertyStore1); or an instance of a valid PropertyStore object.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the property store collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

IndexPartition

Optional

Microsoft.Office.Server.Search.Cmdlet.IndexPartitionPipeBind

Specifies the index partition that contains the property store.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, an ordinal that represents a specific partition, in the form 0, or an instance of a valid IndexPartition object.

QueryTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the property store.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

Detailed Description

The Get-SPEnterpriseSearchPropertyDatabase cmdlet reads a PropertyStore object for a search service application when the property store is created or updated. The PropertyStore object stores metadata about content for a search service application.

If the Identity parameter is not specified, this cmdlet returns the property store collection for the specified search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-----------------EXAMPLE----------------

Copy Code
$propertyDB = Get-SPEnterpriseSearchPropertyDatabase -SearchApplication
mySearchServiceApp -Identity ExamplePropertyDB

This example obtains a reference to the property database "ExamplePropertyDB" from the search application named "mySearchServiceApp".
Click here to submit feedback on this topic.


Get-SPEnterpriseSearchQuerySuggestionCandidates
Example
[image]

Displays a list of queries.

Get-SPEnterpriseSearchQuerySuggestionCandidates -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPEnterpriseSearchQuerySuggestionCandidates cmdlet to display a list of search queries one per line that is alphabetically sorted.

For permissions and the most current information, about search cmdlets, see the online documentation, (http://go.microsoft.com/fwlink/?LinkId=163185).

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

---------------------EXAMPLE------------------------
Copy Code


New-SPEnterpriseSearchCrawlCustomConnector
Example
[image]

Registers a protocol for custom crawling.

New-SPEnterpriseSearchCrawlCustomConnector -ModelFilePath <String> -Protocol <String> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

ModelFilePath

Required

System.String

Specifies the path to a model file.

Protocol

Required

System.String

Specifies the string version of the protocol; for example, dctm://.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that is associated with the protocol.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Name

Optional

System.String

Specifies the display name of the custom connector that appears on the SharePoint Central Administration Web site.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchCrawlCustomConnector cmdlet registers, for a search system, the protocol that is used to crawl the custom repository.

If the Name parameter is not provided, in the administration application user interface (UI) the name protocol identifies the protocol specified.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication mySearchServiceApp
New-SPEnterpriseSearchCrawlCustomConnector -SearchApplication $searchApp
-ModelFilePath \\models\myFileTypeModel.mft -Protocol "mftml://"

This example creates a custom connector for a file type whose model is located at \\models\myFileTypeModel.mft and has the protocol name mftml://.
Click here to submit feedback on this topic.


New-SPEnterpriseSearchCrawlDatabase
[image]

Creates a crawl database which can be added to a search service application.

New-SPEnterpriseSearchCrawlDatabase -DatabaseName <String> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-Dedicated <SwitchParameter>] [-FailoverDatabaseServer <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

DatabaseName

Required

System.String

Specifies the name of the database to create for the crawl database.

The type must be a valid name of a SQL Server database; for example, CrawlStoreDB1.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl database.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabasePassword

Optional

System.String

Specifies the name of the password for the Microsoft SQL Server database server.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database specified in DatabaseName.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the account name specified in the Database Server parameter.

Dedicated

Optional

System.Management.Automation.SwitchParameter

Used for scale-out optimization, this parameter specifies that the database is dedicated to one or more hosts using host distribution rules, and is not shared for all other hosts.

FailoverDatabaseServer

Optional

System.String

Server that is used for failover when SQL Server mirroring is used.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchCrawlDatabase cmdlet is used during initial configuration and farm scale-out to create a new crawl database, which can be added to a search service application. A crawl database stores crawl history for a search application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication mySearchServiceApp
New-SPEnterpriseSearchCrawlDatabase -SearchApplication $searchApp
-DatabaseName newCrawlDB

This example creates a new crawl database named newCrawlDB for the mySearchServiceApp search service application.

See Also

Reference

Set-SPEnterpriseSearchCrawlDatabase
Get-SPEnterpriseSearchCrawlDatabase
Remove-SPEnterpriseSearchCrawlDatabase

Click here to submit feedback on this topic.


New-SPEnterpriseSearchCrawlRule
[image]

Creates a new crawl rule.

New-SPEnterpriseSearchCrawlRule [-Path] <String> -SearchApplication <SearchServiceApplicationPipeBind> -Type <InclusionRule | ExclusionRule> [-AccountName <String>] [-AccountPassword <SecureString>] [-AssignmentCollection <SPAssignmentCollection>] [-AuthenticationType <Nullable>] [-Confirm [<SwitchParameter>]] [-ContentClass <String>] [-CrawlAsHttp <Nullable>] [-FollowComplexUrls <Nullable>] [-IsAdvancedRegularExpression <Nullable>] [-PluggableSecurityTrimmerId <Nullable>] [-Priority <Nullable>] [-SuppressIndexing <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlRulePipeBind

Specifies a unique path to which a crawl rule applies.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the Search application that is associated with the crawl rule to be modified.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Type

Required

Microsoft.Office.Server.Search.Administration.CrawlRuleType

Specifies the type of crawl rule. A value of zero (0) includes the rule, a value of 1 excludes the rule.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

AuthenticationType

Optional

System.Nullable

Specifies one of the following authentication types to access matching URLs:

BasicAccountRuleAccess — Specifies the account name and password that are required for this authentication type.

CertificateRuleAccess — Specifies the valid client certificate name that is required for this authentication type.

NTLMAccountRuleAccess — Specifies the account name for integrated authentication.

FormRuleAccess — Specifies a valid URL for HTTP POST or HTTP GET, public and private parameters, and a list of error pages that are used by this authentication type.

CookieRuleAccess — Specifies private parameters and a list of error pages that are used by this authentication type.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

ContentClass

Optional

System.String

Specifies the string that is sent to the protocol handler for any content that matches the crawl rule.

CrawlAsHttp

Optional

System.Nullable

Specifies whether the crawler should crawl content from a hierarchical content source as HTTP content.

FollowComplexUrls

Optional

System.Nullable

Specifies whether the index engine should crawl content with URLs that contain a question mark (?).

IsAdvancedRegularExpression

Optional

System.Nullable

Specifies whether the rule has a full regular expression syntax.

The default value is False.

PluggableSecurityTrimmerId

Optional

System.Nullable

Specifies the ID of the custom pluggable security trimmer to use, if registered.

Priority

Optional

System.Nullable

Defines where in the list of crawl rules this crawl rule should be applied.

The priority value cannot be less than 0 or greater than or equal to the number of crawl rules for the search application.

SuppressIndexing

Optional

System.Nullable

Specifies whether the crawler should exclude the content of items that this rule applies to from the content index.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchCrawlRule cmdlet creates special rules for crawling items that are contained in the specified path.

For permissions and the most current information about search cmdlets, see the online documentation, (http://go.microsoft.com/fwlink/?LinkId=163185).

Input Types

Return Types

Example

------------------EXAMPLE------------------

Copy Code
New-SPEnterpriseSearchCrawlRule -SearchApplication mySearchServiceApp -Identity http://ExampleSharePointSite -CrawlAsHttp 1 -Type InclusionRule

This example creates an inclusion type crawl rule for the site at http://ExampleSharePointSite. The rule specifies that the site be crawled as an HTTP site.

See Also

Reference

Set-SPEnterpriseSearchCrawlRule
Get-SPEnterpriseSearchCrawlRule
Remove-SPEnterpriseSearchCrawlRule

Click here to submit feedback on this topic.


New-SPEnterpriseSearchPropertyDatabase
[image]

Creates a new property store for use by a search service application.

New-SPEnterpriseSearchPropertyDatabase -DatabaseName <String> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

DatabaseName

Required

System.String

Specifies the database for the new property store.

The type must be a valid name of a database; for example, PropertyStoreDB1.

SearchApplication

Required

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the property store collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabasePassword

Optional

System.String

Specifies the password of the database associated with the Database Name parameter.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database that is specified in DatabaseName. The default value is the SQL Server host for the Central Administration database.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the account name from the Database Server parameter.

FailoverDatabaseServer

Optional

System.String

Specifies the server to be used for failover when SQL Server mirroring is used.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchPropertyDatabase cmdlet creates a new property store for use by a search service application. This cmdlet is used when the search functionality is initially configured to scale out a search application. The PropertyStore object stores metadata about content for a search service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication mySearchServiceApp
New-SPEnterpriseSearchPropertyDatabase -SearchApplication $searchApp
-DatabaseName newPropertyDB

This example creates a new property database, newPropertyDB, for the mySearchServiceApp search service application.

See Also

Reference

Get-SPEnterpriseSearchServiceApplication
Set-SPEnterpriseSearchPropertyDatabase
Get-SPEnterpriseSearchPropertyDatabase
Remove-SPEnterpriseSearchPropertyDatabase

Click here to submit feedback on this topic.


New-SPEnterpriseSearchSiteHitRule
[image]

Adds a new site hit rule for a search application.

New-SPEnterpriseSearchSiteHitRule [-Name] <String> -Behavior <String> -HitRate <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchService <SearchServicePipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SiteHitRulePipeBind

The name of the host to which the site hit rule should be applied.

Behavior

Required

System.String

Defines a rule to be followed when the farm's search service crawls the given site. If a value of zero is specified, then the hit rate is the maximum number of simultaneous requests. If a value of 1 is specified, then hit rate is the number of seconds to delay between requests to the server.

HitRate

Required

System.String

Value to use for maximum requests or seconds of delay, according to behavior.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchService

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServicePipeBind

Specifies the search service in the farm that hosts the crawl.

The type must be an instance of a valid SearchService object; otherwise, the local service on the server that hosts the Windows PowerShell cmdlet will be used.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPEnterpriseSearchSiteHitRule cmdlet sets the maximum limits for crawling a site. The new site hit rule is used by all search service applications on the current farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------EXAMPLE------------------
Copy Code
New-SPEnterpriseSearchSiteHitRule -Identity myHost -Behavior 0
-HitRate 40

This example creates a new site hit rule on the myHost host that limits to 40 the number of simultaneous requests.

See Also

Reference

Get-SPEnterpriseSearchSiteHitRule
Remove-SPEnterpriseSearchSiteHitRule

Click here to submit feedback on this topic.


Remove-SPEnterpriseSearchCrawlCustomConnector
[image]

Removes a CustomConnector object.

Remove-SPEnterpriseSearchCrawlCustomConnector -Identity <SPCustomConnectorPipeBind> -SearchApplication <SearchServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SPCustomConnectorPipeBind

Specifies the CustomConnector object to remove. The Identity parameter must be an instance of a valid CustomConnector object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Get-SPEnterpriseSearchCrawlCustomConnector selects the custom connector or connectors, and then pipes them to the Remove-SPEnterpriseSearchCrawlCustomConnector cmdlet.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------------EXAMPLE------------------

Copy Code
Get-SPEnterpriseSearchCrawlCustomConnector -SearchApplication MySearchServiceApp" - Identity "dctm://" | Remove-SPEnterpriseSearchCrawlCustomConnector

This example removes a custom connector for the dctm:// protocol from the MySearchServiceApp search service application.

See Also

Reference

New-SPEnterpriseSearchCrawlCustomConnector
Get-SPEnterpriseSearchCrawlCustomConnector

Click here to submit feedback on this topic.


Remove-SPEnterpriseSearchCrawlDatabase
[image]

Deletes a crawl database.

Remove-SPEnterpriseSearchCrawlDatabase -Identity <CrawlStorePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlStorePipeBind

Specifies the crawl database to delete.

A valid crawl database name, in the form CrawlStore1; or a valid GUID, such as 12345678-90ab-cdef-1234-567890bcdefgh; or an instance of a valid CrawlStore object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the crawl database collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchCrawlDatabase cmdlet deletes a specified crawl database from a search service application. A crawl database stores crawl history for a search service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
Remove-SPEnterpriseSearchCrawlDatabase -Identity CrawlDB-0
-SearchApplication mySearchServiceApp

This example removes the CrawlDB-0 crawl database from the mySearchServiceApp search service application.

See Also

Reference

Get-SPEnterpriseSearchCrawlDatabase
New-SPEnterpriseSearchCrawlDatabase
Set-SPEnterpriseSearchCrawlDatabase

Click here to submit feedback on this topic.


Remove-SPEnterpriseSearchCrawlRule
[image]

Deletes a crawl rule.

Remove-SPEnterpriseSearchCrawlRule -Identity <CrawlRulePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlRulePipeBind

The crawl rule to delete.

A valid crawl rule URL, such as "http://server_name", or an instance of a valid CrawlRule object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

The search application that contains the crawl rule collection.

A valid Search Application name, such as "SearchApp1", or a valid GUID, such as "12345678-90ab-cdef-1234-567890bcdefgh", or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchCrawlRule cmdlet deletes a crawl rule that is used to crawl content for a content source.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication mySearchServiceApp
Remove-SPEnterpriseSearchCrawlRule -Identity http://mySPSite
-SearchApplication $searchApp

This example removes a crawl rule pertaining to the path http://mySPSite from the mySearchServiceApp search service application.

See Also

Reference

Get-SPEnterpriseSearchCrawlRule
New-SPEnterpriseSearchCrawlRule
Set-SPEnterpriseSearchCrawlRule

Click here to submit feedback on this topic.


Remove-SPEnterpriseSearchPropertyDatabase
[image]

Deletes a property store.

Remove-SPEnterpriseSearchPropertyDatabase -Identity <PropertyStorePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.PropertyStorePipeBind

Specifies the property store to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid property store name (for example, PropertyStore1); or an instance of a valid PropertyStore object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the property store collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchPropertyDatabase cmdlet deletes a specified property store from the property store collection. A property store stores metadata about content for a search service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
Remove-SPEnterpriseSearchPropertyDatabase -Identity PropertyDB
-SearchApplication mySearchServiceApp

This example removes the property database, PropertyDB, from the mySearchServiceApp search service application.

See Also

Reference

Get-SPEnterpriseSearchPropertyDatabase
New-SPEnterpriseSearchPropertyDatabase
Set-SPEnterpriseSearchPropertyDatabase

Click here to submit feedback on this topic.


Remove-SPEnterpriseSearchSiteHitRule
[image]

Deletes a site hit rule.

Remove-SPEnterpriseSearchSiteHitRule -Identity <SiteHitRulePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-SearchService <SearchServicePipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.SiteHitRulePipeBind

The rule that is used for the specified site.

The type must be a valid site hit rule host or an instance of a valid SiteHitRule object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchService

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServicePipeBind

Specifies the search service in the farm that hosts the crawl.

The type must be an instance of a valid SearchService object; otherwise, the local service on the server that hosts the Windows PowerShell cmdlet is used.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Remove-SPEnterpriseSearchSiteHitRule cmdlet deletes the site hit rule that controls the number of threads used to crawl a given site.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE-------------------
Copy Code
Remove-SPEnterpriseSearchSiteHitRule -Identity myHost

This example removes a site hit rule for the myHost host.

See Also

Reference

Get-SPEnterpriseSearchSiteHitRule
New-SPEnterpriseSearchSiteHitRule

Click here to submit feedback on this topic.


Set-SPEnterpriseSearchAdministrationComponent
[image]

Sets properties of an administration component for a search service application.

Set-SPEnterpriseSearchAdministrationComponent [-Identity <AdminComponentPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Force <SwitchParameter>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-SearchServiceInstance <SearchServiceInstancePipeBind>] [-StoragePath <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Server.Search.Cmdlet.AdminComponentPipeBind

Specifies the administration component to update.

The type must be a valid name (GUID), such as 12345678-90ab-cdef-1234-567890bcdefgh; or an instance of a valid AdminComponent object

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the administration component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Force

Optional

System.Management.Automation.SwitchParameter

Specifies that the admin component must be moved to the new search service instance.

SearchServiceInstance

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceInstancePipeBind

Specifies the search service instance to host the administration component.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a search server (for example, MyQueryServer); or an instance of a valid SearchServiceInstance object.

StoragePath

Optional

System.String

Specifies the path for storing data for the administration component. The path must contain a valid file share and use valid registry characters.

The type must be a valid path in either of the following forms:

  • C:\ folder_name

  • \\server_name\folder_name

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchAdministrationComponent cmdlet updates properties of an AdministrationComponent object for a search service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchapp = Get-SPEnterpriseSearchServiceApplication "Sample Search Service Application" admin = Get-SPEnterpriseSearchAdministrationComponent -SearchApplication $searchapp
$admin | Set-SPEnterpriseSearchAdministrationComponent -SearchServiceInstance newserver -Force

This example moves the administration component to a different server.

See Also

Reference

Get-SPEnterpriseSearchAdministrationComponent

Click here to submit feedback on this topic.


Set-SPEnterpriseSearchCrawlDatabase
[image]

Sets properties of a crawl database for a search service application.

Set-SPEnterpriseSearchCrawlDatabase -Identity <CrawlStorePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseName <String>] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-Shared <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlStorePipeBind

Specifies the crawl database to modify.

A valid crawl database name, in the form CrawlStore1; or a valid GUID, such as 12345678-90ab-cdef-1234-567890bcdefgh; or an instance of a valid CrawlStore object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

FailoverDatabaseServer

Optional

System.String

Specifies the server to be used for failover when SQL Server mirroring is used.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the name of the search application to which the crawl database applies.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

Shared

Optional

System.Management.Automation.SwitchParameter

Used to denote that the search crawl database is to be used for all crawls instead of dedicated to a specific set of hosts through host distribution.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchCrawlDatabase cmdlet sets properties of a specified crawl database for a search service application. A crawl database stores crawl history for a search service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication mySearchServiceApp
Set-SPEnterpriseSearchCrawlDatabase -Identity SearchApp_CrawlStore
-SearchApplication $searchApp -FailoverDatabaseServer \\failoverServer

This example sets the failover database server for the crawl database, SearchApp_CrawlStore, to the \\failoverServer server .

See Also

Reference

Get-SPEnterpriseSearchCrawlDatabase
New-SPEnterpriseSearchCrawlDatabase
Remove-SPEnterpriseSearchCrawlDatabase

Click here to submit feedback on this topic.


Set-SPEnterpriseSearchCrawlRule
[image]

Sets properties for a crawl rule.

Set-SPEnterpriseSearchCrawlRule -Identity <CrawlRulePipeBind> [-AccountName <String>] [-AccountPassword <SecureString>] [-AssignmentCollection <SPAssignmentCollection>] [-AuthenticationType <Nullable>] [-Confirm [<SwitchParameter>]] [-ContentClass <String>] [-CrawlAsHttp <Nullable>] [-FollowComplexUrls <Nullable>] [-IsAdvancedRegularExpression <Nullable>] [-PluggableSecurityTimmerId <Nullable>] [-Priority <Nullable>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-SuppressIndexing <Nullable>] [-Type <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.CrawlRulePipeBind

Specifies the name of the crawl rule.

The type must be a valid crawl rule URL, such as http://server_name, or an instance of a valid CrawlRule object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

AuthenticationType

Optional

System.Nullable

Specifies one of the following authentication types:

  • BasicAccountRuleAccess Specifies basic authentication.

  • CertificateRuleAccess Specifies the X.509 certificate name.

  • NTLMAccountRuleAccess Specifies the account name for integrated authentication.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

ContentClass

Optional

System.String

Specifies a string that is sent to the protocol handler for any content that matches the crawl rule.

CrawlAsHttp

Optional

System.Nullable

Specifies whether the crawler crawls content from a hierarchical content source as HTTP content.

FollowComplexUrls

Optional

System.Nullable

Specifies whether the index engine crawls content from URLs that contain a question mark (?).

IsAdvancedRegularExpression

Optional

System.Nullable

Specifies whether the rule has full regular expression syntax.

The default value is False.

PluggableSecurityTimmerId

Optional

System.Nullable

Specifies the ID of the custom pluggable security trimmer to use, if registered.

Priority

Optional

System.Nullable

Defines where in the list of crawl rules this crawl rule is to be applied.

The priority value cannot be less than 0 or greater than or equal to the number of crawl rules for the search application.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

The name of the search application that is associated with the crawl rule to be modified.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

SuppressIndexing

Optional

System.Nullable

Specifies whether the crawler excludes the content of items, to which this rule applies, from the content index.

Type

Optional

System.Nullable

Specifies the type of crawl rule. A value of zero (0) includes the rule, and a value of 1 excludes the rule.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

A search administrator runs the Set-SPEnterpriseSearchCrawlRule cmdlet at initial search configuration or any other time, to set and/or update various attributes of a crawl rule.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$crawlRule = Get-SPEnterpriseSearchCrawlRule -Identity
file://fileserver/root -SearchApplication mySearchServiceApp
Set-SPEnterpriseSearchCrawlRule -Identity $crawlRule -Type "ExclusionRule"

This example sets the type of the crawl rule pertaining to the URL, file://fileserver/root, to exclude this path from future crawls.

See Also

Reference

Get-SPEnterpriseSearchCrawlRule
New-SPEnterpriseSearchCrawlRule
Remove-SPEnterpriseSearchCrawlRule

Click here to submit feedback on this topic.


Set-SPEnterpriseSearchPropertyDatabase
[image]

Modifies properties for a property store.

Set-SPEnterpriseSearchPropertyDatabase -Identity <PropertyStorePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseName <String>] [-DatabasePassword <String>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.PropertyStorePipeBind

Specifies the property database to modify.

The value must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid property store name (for example, PropertyStore1); or an instance of a valid PropertyStore object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

FailoverDatabaseServer

Optional

System.String

Specifies the server that is used for failover when SQL Server mirroring is used.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the property database.

The value must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchPropertyDatabase cmdlet modifies properties for a specified property store in the property store collection. A property store stores metadata about content for a search service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication mySearchServiceApp
Set-SPEnterpriseSearchPropertyDatabase -Identity PropertyStore-1
-SearchApplication $searchApp -FailoverDatabaseServer \\failoverServer

This example sets the failover database server for the property database, PropertyStore-1, to the \\failoverServer server.

See Also

Reference

Get-SPEnterpriseSearchPropertyDatabase
New-SPEnterpriseSearchPropertyDatabase
Remove-SPEnterpriseSearchPropertyDatabase

Click here to submit feedback on this topic.


Set-SPEnterpriseSearchQueryComponent
Example
[image]

Modifies properties for a query component.

Set-SPEnterpriseSearchQueryComponent -Identity <QueryComponentPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-FailoverOnly <Nullable>] [-QueryTopology <QueryTopologyPipeBind>] [-SearchApplication <SearchServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.Search.Cmdlet.QueryComponentPipeBind

Specifies the query component to set.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryComponent object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

FailoverOnly

Optional

System.Nullable

Specifies that the query component only serves queries as a last resort, after all query instances for the partition have failed.

QueryTopology

Optional

Microsoft.Office.Server.Search.Cmdlet.QueryTopologyPipeBind

Specifies the query topology that contains the query component collection.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh, or an instance of a valid QueryTopology object.

SearchApplication

Optional

Microsoft.Office.Server.Search.Cmdlet.SearchServiceApplicationPipeBind

Specifies the search application that contains the query topology.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid search application name (for example, SearchApp1); or an instance of a valid SearchServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPEnterpriseSearchQueryComponent cmdlet updates properties for a query component.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

------------------EXAMPLE------------------
Copy Code
$searchApp = Get-SPEnterpriseSearchServiceApplication mySearchServiceApp
Get-SPEnterpriseSearchQueryTopology -SearchApplication $searchApp
Get-SPEnterpriseSearchQueryComponent -QueryTopology $qt |
Set-SPEnterpriseSearchQueryComponent -FailoverOnly $true

This example sets the query component of the search service application, mySearchServiceApp, to serve as a failover-only query component.
Click here to submit feedback on this topic.