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Introduction  

By integrating the Microsoft Dynamics AX 2009 Project accounting module with Microsoft Office Project 
Server 2007, you can draw on features of both products for more granular control of the projects that 
your company manages. For example, you might want to use the complex resource scheduling 
capabilities of Office Project Server for a project that you are managing in Dynamics AX. 
When you integrate the two programs, data changes in one program can be transferred to the other, so 
that all of your project records are current and synchronized in both programs.  

About this document 

Use this document to help you set up integration between Microsoft Office Project Server and the 
Microsoft Dynamics AX Project accounting module. This document assumes that a system administrator 
in your organization will set up integration between the two programs and that a project manager will 
integrate specific projects. Accordingly, some sections in this document are marked either “System 
Administrator” or “Project Manager,” depending on the tasks that the section contains. 

Overview of data flow 

By using the flexible task hierarchy in Office Project Server, you can create a hierarchical structure that is 
similar to the hierarchical structure in Dynamics AX. Corresponding hierarchies make it possible for 
information about projects, subprojects, and activities to flow between the two programs. As part of the 
synchronization process, actuals for labor, expenses, and revenue that are posted in Dynamics AX are 
transferred to Office Project Server, and any changes to project or activity information in Office Project 
Server are transferred to the Dynamics AX database.  
The following illustration shows the areas of integration and the data flow between Office Project Server 
and Dynamics AX. 
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Figure 1: Data flow between Dynamics AX and Office Project Server 

A synchronization service component and a synchronization proxy component are used to transfer data 
between Dynamics AX and Office Project Server. Both the service and the proxy must be installed for 
successful integration. A system administrator installs these components by using Dynamics AX Setup.  
The Office Project Server synchronization service synchronizes project data in Dynamics AX with data in 
Office Project Server. When you install the synchronization service, Setup configures Microsoft Message 
Queuing (MSMQ) to include a queue for the service.  
For more information, see “Setting up the integration (System Administrator)” later in this paper. 
For detailed information about synchronization service and synchronization proxy architecture, see the 
Microsoft TechNet article, “Synchronization service and synchronization proxy architecture” at 
http://technet.microsoft.com/en-us/library/dd309600.aspx. 

Compound and simple entities 

The synchronization service uses the concepts of compound entities and simple entities to synchronize 
data between Dynamics AX and Office Project Server. A compound entity in Dynamics AX consists of one 
or more simple entities. 
For example, a compound entity of “Project” might have several simple entities associated with it, 
including a project header, task, assignment, and project team, as shown in the following illustration. 

Dynamics AX 

Basic, General ledger, 
AR, AP, 

Project accounting, 
Invoicing, Reporting 

Microsoft Office Project 

Server 

Projects, 
Resource assignments, 

Reporting, WSS 

 Projects 

 Activities 

 Employees 

 Cost price 

 Actual costs and 
quantity 

 Projects  

 Tasks 

http://technet.microsoft.com/en-us/library/dd309600.aspx
http://technet.microsoft.com/en-us/library/dd309600.aspx
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Figure 2: Compound entity 

During the synchronization process, simple entities are synchronized one at a time. 

Synchronization modes 

The synchronization service supports two modes: one-way synchronization and two-way 
synchronization: 
 In one-way synchronization, only one master application exists for a particular compound entity. 

Only the master application can create, update, delete, and unlink compound entities and their 

simple entities. The master application publishes the data and the other application subscribes to 
the data. 

 In two-way synchronization, a compound entity has two sources: Dynamics AX and Office Project 
Server. Both applications can create, update, delete, and unlink compound entities and their 
simple entities. 

Although simple entities are synchronized, the synchronization modes apply to compound entities. 
 
Note: If changes to a simple entity occur simultaneously in both systems, and the compound entity is 
configured for two-way synchronization, the change that occurs in the application that is designated as 
the master takes precedence. 
 
You can configure the synchronization mode for each compound entity by using the 
SyncCompoundType table in Dynamics AX. Each compound entity has a sync mode setting, and every 
simple entity inherits the sync mode setting of its parent. 
The following table lists the entities that can be synchronized between the two programs, the 
synchronization mode available for each entity, and the application that is designated as the master.  
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Simple entity Compound entity Synchronization 

mode 

Master application 

Project header Project Two-way Dynamics AX 

Hierarchy node Project Two-way Dynamics AX 

Activity Project Two-way Dynamics AX 

Project resource Project Two-way Office Project Server 

Employee Employee One-way Dynamics AX 

Table 1: Simple entities that can be synchronized between Dynamics AX and Office Project 

Server 

Entities and synchronization 

When a user performs an action on an entity, such as creating or updating a record, a message is sent to 
the synchronization service:  
 If the action is performed in Office Project Server, the message is sent through the 

synchronization proxy that is installed on the computer that is running Office Project Server.  

 If the action is performed in Dynamics AX, the message is sent through the Microsoft Message 
Queuing (MSMQ) database that the synchronization service uses. 

The synchronization process handles entity transactions based on the action being performed, as 
described in the following table  

Action Description 

Create Triggered when the project manager creates or updates a compound entity in either 
Dynamics AX or Office Project Server and integrates that entity. 

Update Triggered when the project manager updates an integrated compound entity in either 
Dynamics AX or Office Project Server. 

Delete Triggered when the project manager deletes an integrated compound entity in either 
Dynamics AX or Office Project Server. 

Unlink Triggered when the project manager deletes an integrated compound entity in Office 
Project Server or unlinks an integrated compound entity in Dynamics AX. 

Refresh Triggered when the project manager manually resynchronizes data between the two 
applications by using the Integration tab of the Projects form in Dynamics AX. 
Manually resynchronizing data may be necessary if synchronization fails. For more 
information, see “Refresh data from or to Office Project Server” later in this paper. 

Table 2: Actions that prompt synchronization between Dynamics AX and Office Project 
Server 

Setting up the integration (System Administrator) 

Setting up integration between Dynamics AX and Microsoft Office Project Server consists of the 
following tasks:  
1. Install the Office Project Server synchronization service. 

2. Install the Office Project Server synchronization proxy. 

3. Set parameters for the synchronization service. 

4. Enable the integration.  
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When planning your synchronization service and synchronization proxy topology, you must consider 
scalability, availability, the size of your deployment, and other issues. 
For details on these and other considerations, see the Microsoft TechNet article “Synchronization 
service and synchronization proxy topology” at http://technet.microsoft.com/en-
us/library/dd309715.aspx. 

Prerequisites 

The following software and security prerequisites must be met before you integrate the two 

programs. 

Software 

The following software must be installed: 
 Office Project Server 2007 with Service Pack 1 (SP 1) 

 The base components of Dynamics AX 2009 (application files, AOS, and database) 

 The Dynamics AX Project accounting module 

 Windows Message Queuing (MSMQ) 

 Windows SharePoint Services 3.0 SP 1 

 Office Project Professional SP 1 

Security requirements and roles in Office Project Server 

Office Project Server has the following security requirements: 
 The Microsoft Windows account that is used to run the synchronization service must be a member 

of the Admin group in Office Project Server and must have the role of dbowner for the Office 
Project Server reporting database. 

 The Microsoft Windows account that is used to run the Office Project Server eventing service must 
have the role of dbowner for the Office Project Server reporting database. 

Synchronization service account 

Before installing the synchronization service, you must specify a synchronization service account. 
1. In Dynamics AX, click Administration > Setup > Security > System service accounts. 

2. In the Synchronization service account area, click the second option button, and then select 
Admin from the associated list. 

3. Click OK. 

Install the Office Project Server synchronization service 

If you are using Windows Server 2003 and MSMQ has not yet been installed, Setup will install it on the 
local computer. If you are using Windows Server 2008, you must manually install MSMQ by using 
Windows Server Manager.  
If the .NET Business Connector has not been installed, Setup will install it. If the .NET Business Connector 
proxy account has not been set up, Setup will prompt you to specify its credentials. 
 
Note: If you are installing other Dynamics AX components at the same time, the installation screens may 
vary depending on the components being installed. 
 
1. Start Dynamics AX Setup, and then click Next to navigate through the initial wizard pages. 

http://technet.microsoft.com/en-us/library/dd309715.aspx
http://technet.microsoft.com/en-us/library/dd309715.aspx
http://technet.microsoft.com/en-us/library/dd309715.aspx
http://technet.microsoft.com/en-us/library/dd309715.aspx
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2. On the Select installation type page, select Custom installation, and then click Next. 

3. On the Select components page, select Synchronization service (Project Server 2007).  
 

Note: If MSMQ is not installed, the wizard will prompt you to install it. You may be prompted to 
install other prerequisite software. After completing these installations, click Next. 
 

4. On the Synchronization service: Select the installation type page, select the type of 
synchronization support to install, and click Next: 

 For most installations, select Synchronization services and Message queuing (standard) 

to install the synchronization services and message queuing on the same computer. 

 Select Message queuing only or Synchronization services only when you are installing a 
distributed system with message queuing on one computer and the synchronization service on 

another. 

5. On the Synchronization service: Enter the password for the service account page, enter 
the password for the synchronization service account that you previously set up, and then click 
Next. 

6. On the Specify the service accounts for synchronization message queues page, enter the 
names of the service accounts that will communicate through message queues. 
 

Note: For Setup to configure the proper permissions, you must provide a domain account that will 
be used by the Office Project Server eventing service, as well as the service account of at least one 
AOS instance. 
 

7. Click Next, and then click Install. 

Note: During installation, you might receive a message that says, “Access to Message Queuing 
system is denied”. This message either indicates that message queuing is already installed, or it can 
indicate that the account you are using does not have correct permissions to install queues. For 
more information, see “Issues with Office Project Server and MSMQ” in “Troubleshooting,” later in 
this document. 

Install the Office Project Server synchronization proxy 

The synchronization proxy must be installed on the same computer as the Project Server Interface (PSI) 
Web service. You must be a member of the dbowner database role for the Office Project Server 
database and an administrator on the computer running Office Project Server. 
 
Note: If you are installing other Dynamics AX components at the same time, the installation screens may 
vary depending on the components being installed. 
 
1. Start Dynamics AX Setup, and then click Next to navigate through the initial wizard pages. 

2. On the Select installation type page, click Custom installation, and then click Next. 

3. On the Select components page, select Synchronization proxy (Project Server 2007).  

4. If you are prompted for a domain user account on the Synchronization proxy/Message 
Queuing: Enter the service account information page, enter the domain user account that 
was set for the synchronization service in the Dynamics AX initialization checklist. 
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5. If you are prompted for a computer name on the Synchronization proxy: Connect to the 
synchronization service page, enter the name of the computer on which the synchronization 
service is installed. 

Note: If the message queue for the synchronization service is running on a different computer than 
the synchronization service, enter the name of the server running MSMQ. 
 

6. On the Synchronization proxy: Connect to Office Project Server page, enter the server name 
and database name that Office Project Server uses for reporting. In the Project web access URL 
box, enter the appropriate URL. 

Note: If the synchronization proxy must connect to multiple project URLs, install the synchronization 
proxy using the first URL, uninstall the synchronization proxy, and then install the synchronization 
proxy again using a different URL. Uninstalling the proxy does not prevent the proxy from 
connecting to URLs that were specified during previous installations. 
 

7. Click Next, and then click Install. 

Configure Microsoft Dynamics AX synchronization service 

parameters 

Use the Synchronization service parameters form to set the parameters that you want to use for the 
synchronization service, such as the MSMQ server name, the synchronization queue name, and other 
options. 
 To open the Synchronization service parameters form, click Basic > Setup > 

Synchronization service > Parameters.  

For more information about synchronization service parameters, see Dynamics AX Help. 

Enable the integration 

To complete the integration, lookup values from Dynamics AX must be duplicated in Office Project 
Server. 
1. In Dynamics AX, click Project > Setup > Parameters. 

2. On the Number sequences tab, right-click the Number sequence code field in the Project 
row, and then select Go to the Main Table Form. 

3. On the Number sequences form, click the General tab, clear the Manual check box, and then 
click Save. 

4. Click Project > Setup > Microsoft Project Server Integration > Configure integration, and 
then complete the following fields: 

 Application ID: The application identification for Office Project Server. 

 Project web access site: The URL for Office Project Web Access. 

 Reporting database server: The name of the SQL Server instance in which the reporting 
database is located. 

 Reporting database name: The name of the reporting database. 

Note: To view the name of the reporting database in Windows Server, click Start > All Programs > 
Microsoft Office Server > SharePoint 3.0 Central Administration; go to SharedServices1 > Project Web 

Access Sites; position the curser over http://<ComputerName>/pwa, and then select View in the list. 
 

5. Click Save. 

http://computername/pwa
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6. Click Install components, and then click Refresh status. 

7. After the installation is complete, select the Enable integration check box, and then click Save. 

Integrating project data (Project Manager) 

After the synchronization service and synchronization proxy are installed, the project manager can 
integrate projects and employees between Dynamics AX and Office Project Server. After you integrate 
an entity, it is good practice to verify that the entity appears correctly in the other program. 

Integrate an employee record that was created in Microsoft 
Dynamics AX 

Before you integrate an employee record, ensure that employee and project details will be written to 
journals. 
1. In Dynamics AX, click Project > Setup > Parameters. 

2. Click the Journals tab, and then in the Project/employee list, select Mandatory. 

After completing this step, you can integrate the employee record and verify it in Office Project Server. 
1. In Microsoft Dynamics AX, click Basic > Common Forms > Employee Details. 

2. Create a new employee record or select an existing employee. 

3. Click the Integration tab, and then select the Integrate to Project Server check box. 

4. Click Save. 

Verify the employee record in Office Project Server 

1. On the Office Project Web Access Web site (http://<ComputerName>/PWA), on the Resources 
menu, click Resource Center. 

2. Verify that the employee appears in the Resource Center list. 

3. Select the check box next to the employee’s name, and then click Edit Details to open the Edit 
Resource page. 

4. Scroll to the Custom Fields area and confirm that Yes is selected in the 

DAX_Resource_01_IntegrateResource list, and that the DAX_Resource_02_Company field 
is populated. 

Integrate a project that was created in Dynamics AX 

1. In Dynamics AX, click Project > Common Forms > Project Details. 

2. Create a new project or select an existing project. 

3. Click the General tab.  

4. In the Project manager list, select an employee record that has been integrated with Office 
Project Server, and then click Activities.  

5. In the Hierarchy form, create a hierarchical activity tree, including a category. 

Tip: Right-click the root node, and then select Create level to create and name an 

activity level. Right-click any levels you create and select Create activity to configure 

each activity. 

6. Close the Hierarchy form. 

7. Click the Integration tab, and then select the Integrate to Project Server check box. 
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Verify the project in Office Project Server 

1. Open Office Project Web Access (http://<ComputerName>/PWA), and on the Projects menu, 
click Project Center. 

2. Verify that the name of the project that you integrated appears in the Project Center list. 

3. Click the project name to open the Project Details page and verify that the tasks are integrated. 

4. Select the project name, and then click Edit Project Properties. 

5. Scroll to the Project Custom Fields area and confirm that Yes is selected in the 
DAX_Resource_01_IntegrateProject list, and that the other custom fields are populated. 

6. Click Back to return to the Project Center page. 

7. Click Build Team, and then verify that resources are assigned to the project.  

Verify the project in Microsoft Office Project Professional 2007 

1. Open Office Project Professional. 

2. Select File > Open to retrieve the list of all projects from Office Project Server, and then select 
the project. 

3. Verify that the task name and start and finish dates match those you specified when you 

integrated the project.  

Integrate a project that was created in Office Project Server 

1. Open Office Project Web Access (http://<ComputerName/PWA>), and on the Projects menu, 
click Project Center. 

 To integrate an existing project:  

1. Select the project, and then click Edit Project Properties. 

2. In the DAX_Project_01_IntegrateProject list, select Yes, and then complete the remainder 

of the Project Custom Fields area. 

3. Click Save and Publish. 

 To integrate a new project: 

1. Click New > Project to open Office Project Professional. 

2. Create one or more tasks.  

3. Open Project > Task information, click the Custom fields tab, enter a description, and then 

click OK. 

4. Click File > Save.  

5. Enter a name, complete the remainder of the project custom fields, and then click Save. 

6. Click File > Publish, and then click Publish. 

Verify the project in Dynamics AX 

1. In Dynamics AX, click Project > Common Forms > Project Details. 

2. Click the Overview tab, and then verify that the project you selected for integration in Office 
Project Professional is listed. 

3. Review the project details and confirm that the expected values appear. 

4. Click Activities to open the Hierarchy form, and then verify that the expected values for 
Purpose, Start date/time, and End date/time appear. 
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5. Close the Hierarchy form. 

6. In the Projects form, click the Integration tab and verify that the Integrate to Project Server 
check box is selected. 

Integrate a project’s build team resources that were created in 

Office Project Server 

Assign a project resource in Office Project Server.  
After a project has been selected for integration in Dynamics AX, follow these steps to add build team 
resources. 
1. Open Project Web Access (http://<ComputerName>/PWA), and then on the Projects menu, click 

Project Center. 

2. Verify that the project is listed on the Project Center page. 

3. Select the project, and then click Build team. 

4. On the Build Team page, add resources to the project. 

5. Click Save. 

Verify the project resource in Dynamics AX 
1. In Dynamics AX, click Project > Common Forms > Project Details. 

2. Select the project, and then click Setup > Employees to open the Validation – 
project/employee form. 

3. Click the Employees tab, and then verify that the employees that you selected are listed in the 

Selected employees pane. 

Viewing synchronization results and refreshing data 

(Project Manager) 

Follow this procedure to manage and view the status of integrated projects and to troubleshoot 
integration errors that may have occurred.  
1. In Dynamics AX, click Basic > Inquiries > Synchronization service > Queue manager. 

2. In the Show compound entity type filter, select Employee, Project, or All. 

3. Select the line of the simple entity that you want to review. 

4. In the lower half of the form, use the Transaction status filter to view synchronization 
transactions according to their status: 

 Waiting 

 Executing 

 Completed 

 Failed 

 Cancelled  

 
Tip: If an entity has failed to synchronize, click Actions > Resynchronize to try the synchronization 
process again, or click Error log to see the reason for the error.  

 
5. (Optional) Click Transaction data to review synchronization process results. 
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Refresh data from or to Office Project Server 

If the synchronization process fails or runs with errors, you can refresh the data, using the current state 
of the project in either Dynamics AX or Office Project Server as the starting point. 

Refresh data to Office Project Server 

1. In Dynamics AX, click Project > Common Forms > Project Details. 

2. Select the project, and then click the Integration tab. 

3. Click Refresh > Refresh to Microsoft Project Server. 

4. Open Office Project Web Access (http://<ComputerName/PWA>), and on the Projects menu, 
click Project Center. 

5. Verify that custom fields for the project tasks are updated and synchronized with Dynamics AX. 

Refresh data from Office Project Server 

1. In Dynamics AX, click Project > Common Forms > Project Details. 

2. Select the project, and then click the Integration tab. 

3. Click Refresh > Refresh from Microsoft Project Server. 

4. Note that project hierarchical activities or integrated project fields are updated and now 
synchronized with Office Project Server. 

Appendix A: Dynamics AX forms used in integration setup 

The Dynamics AX forms listed in the following table are used in the integration process with Office 
Project Server. 

Form Navigation path 

Employee Basic > Common Forms > Employee Details 

Enable Microsoft Project Server Integration Project > Setup > Microsoft Project Server Integration > 
Configure integration 

Project server integration settings Project > Setup > Microsoft Project Server Integration > 
Global settings 

Projects Project > Common Forms > Project Details 

Synchronization service parameters Basic > Setup > Synchronization service > Parameters 

Synchronization service queue manager Basic > Inquiries > Synchronization service > Queue 
manager 

Appendix B: Field mapping between Office Project Server 

and Dynamics AX 

Office Project Server Dynamics AX 

Enterprise project custom field Company account 

Enterprise project custom field Company name 

Enterprise project custom field Project/sub project name 

Enterprise project custom field Project manager 
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Enterprise project custom field Header project 

Enterprise project custom field Format 

Enterprise project custom field Customer account 

Enterprise project custom field Customer name 

Enterprise project custom field Project group 

Enterprise project custom field Project type 

Enterprise project custom field Project contract 

Proj_info_start_date Start date 

Proj_info_finish_date End date 

Enterprise project custom field Project stage 

Task name Activity name 

Enterprise task custom field Activity sequence number 

Enterprise task custom field Activity description 

Enterprise task custom field Activity category 

Task_act_start Appointment start date 

Task_act_finish Appointment end date 

Task_act_start Task start date 

Task_act_finish Task due date 

Actual_Work Actual hour quantity 

Enterprise task custom field Actual hour cost 

Enterprise task custom field Actual expense cost 

Enterprise task custom field Actual revenue cost 

Enterprise resource custom field Employee 

Resource name Employee name 

Enterprise resource custom field Cost price 

Enterprise resource custom field Utilization rate 

Enterprise project custom field Company account 

Appendix C: Troubleshooting 

Issues with Office Project Server and MSMQ 

During installation of the synchronization service, the process can fail with the error message, “Access to 
Message Queuing system is denied” if the user account through which MSMQ and the synchronization 
service are being installed has not been added to the list of users who have permissions to create 
queues. 
To avoid this situation, ensure that MSMQ and the synchronization service are installed using an 
account that has permission to create queues. 
To provide a user account with permissions to create queues: 
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1. Open the Computer Management console tree: Click Start > Administrative Tools > Computer 
Management. 

2. In the console tree, open Services and Applications. 

3. Right-click Message Queuing, and then select Properties. 

4. Select the Security tab, and then click Add. 

5. Use the Select Users, Computer, or Groups dialog box to select the user account for which you 
want to assign permissions, and then click OK. 

6. Click OK to close the Message Queuing Properties dialog box. 

Components are not deployed successfully when MSMQ is installed on a computer 

running on Windows Server 2008 and the AOS is not installed on the same 

computer 

If you install components to integrate with Office Project Server on a computer running Microsoft 
Windows Server 2008, the deployment will fail. This happens if both MSMQ and the synchronization 
service are installed on the computer without the AOS. To work around this issue, install the AOS on the 
same computer as MSMQ and the synchronization service. Because of this issue, multiple Office Project 
Server installations cannot be supported if MSMQ and synchronization service are running on Windows 
Server 2008. 

When synchronizing actuals hours from Dynamics AX to Office Project Server, all 

hours are assigned to a single date regardless of the dates they were assigned to 

in AX 

The Dynamics AX and Office Project Server integration system is designed to publish date information 
from Office Project Server to Dynamics AX, but not from Dynamics AX to Office Project Server, because 
Office Project Server is expected to be the primary scheduling tool. Therefore, publishing date 
information from Dynamics AX to Office Project Server is not supported. Dynamics AX does not perform 
a validation check on the number of hours posted against a budget. A Dynamics AX to Office Project 
Server synchronization publishes only the total number of hours for each task. 
To avoid losing date information during the synchronization process, use Office Project Server as your 
primary scheduling tool. 

Synchronization proxy setup may fail to install all the event handlers in Office 

Project Server 

Some of the event handlers may fail to be installed along with the synchronization proxy. (These event 
handlers package entity transactions in a message and send the message to the synchronization 
service.) 
If synchronization proxy setup fails, run the synchronization proxy setup again. If the event handlers are 
still not installed automatically, you must add them manually by using Office Project Web Access. Go to 
Server Settings > Server Event Handlers to add the event handlers. 
These event handlers include the following: 
 ProjectCreated 

 ProjectChanged 

 ProjectDeleted 
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