New-SPWordConversionServiceApplication
Example
[image]

Provisions a new instance of a Word Services application on the farm.

New-SPWordConversionServiceApplication -Name <String> -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DatabaseCredential <PSCredential>] [-DatabaseName <String>] [-DatabaseServer <String>] [-Default <SwitchParameter>] [-PartitionMode <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the name of the new Word Services application.

The type must be a valid name of a Word Services application; for example, WordSvcApp1.

ApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS managed application pool that this instance of Word Services will run in.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabaseName

Optional

System.String

Specifies the name of the database to create for the new Word Services application.

The type must be a valid name of a SQL Server database; for example MeatadataDB1.

DatabasePassword

Optional

System.String

Specifies the password for the user specified in DatabaseUserName. Use this parameter only if SQL authentication is used to access the Word Services application database.

The type must be a valid SQL Server password.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the Word Services database.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the user name to use for connecting to the database for the Word Services application. Use this parameter only if SQL authentication is used to access the service application database.

The type must be a valid user name; for example, UserName1.

Default

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application proxy is added to the farm's default proxy group for this Web application.

PartitionMode

Optional

System.Management.Automation.SwitchParameter

Specifies that this service behaves uniquely on a partitioned set of site collections. This property cannot be changed after the application is provisioned.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPWordConversionServiceApplication cmdlet to provision a new instance of a Word Services application on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

---------------EXAMPLE---------------
Copy Code
Get-SPDatabase … | New-SPWordConversionServiceApplication -Name WordServices1

This example creates a new Word Services application named, "WordServices1"
Click here to submit feedback on this topic.


Set-SPWordConversionServiceApplication
Example
[image]

Sets properties of a Word Services application.

Set-SPWordConversionServiceApplication -Identity <SPServiceApplicationPipeBind> [-ActiveProcesses <Nullable>] [-AddSupportedFormats <String[]>] [-ApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ConversionsPerInstance <Nullable>] [-ConversionTimeout <Nullable>] [-DatabaseCredential <PSCredential>] [-DatabaseName <String>] [-DatabaseServer <String>] [-DisableBinaryFileScan <SwitchParameter>] [-DisableEmbeddedFonts <SwitchParameter>] [-KeepAliveTimeout <Nullable>] [-MaximumConversionTime <Nullable>] [-MaximumMemoryUsage <Nullable>] [-MaximumRestartCount <Nullable>] [-Name <String>] [-RecycleProcessThreshold <Nullable>] [-RemoveSupportedFormats <String[]>] [-TimerJobFrequency <Nullable>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Specifies the Word Services application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Word Services application (for example, WordSvcApp1); or an instance of a valid SPServiceApplication object.

ActiveProcesses

Optional

System.Nullable

Specifies the number of instances of the Word server code which are spun up on a single machine. The default value is 8.

The type must be a valid integer in the range from 1 to 1000.

ApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS managed application pool that this instance of Word Services will run in.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

ConversionsPerInstance

Optional

System.Nullable

Specifies the number of conversions dispatched to each service instance every time the timer job is run. The default value is 12.

The type must be a valid integer.

ConversionTimeout

Optional

System.Nullable

Specifies the time, in minutes, when a conversion that is marked InProgress is confirmed to be still running. The default value is 5.

The type must be a valid integer in the range from 1 to 60.

DatabaseName

Optional

System.String

Specifies the name of the database to use for this instance of the Word Services application.

The type must be a valid name of a SQL Server database; for example MeatadataDB1.

DatabasePassword

Optional

System.String

Specifies the password for the user specified in DatabaseUserName. Use this parameter only if SQL authentication is used to access the Word Services application database.

The type must be a valid SQL Server password.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the Word Services database.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the user name to use for connecting to the database for the Word Services application. Use this parameter only if SQL authentication is used to access the service application database.

The type must be a valid user name; for example, UserName1.

DisableBinaryFileScan

Optional

System.Management.Automation.SwitchParameter

Specifies that Gatekeeper is run on binary files.

DisableEmbeddedFonts

Optional

System.Management.Automation.SwitchParameter

Specifies that embedded fonts are read and used coming from input documents.

KeepAliveTimeout

Optional

System.Nullable

Specifies the length of time, in seconds, that the worker can be suspended before the conversion terminates. The default value is 300.

The type must be a valid integer in the range from 10 to 60.

MaximumConversionTime

Optional

System.Nullable

Specifies the maximum length of time, in seconds, that a conversion can take. The default value is 300.

The type must be a valid integer in the range from 60 to MaxInt.

MaximumMemoryUsage

Optional

System.Nullable

Specifies the maximum percentage of system memory which can be used by the application manager (supported by the application manager). The default value is 100.

The type must be a valid integer in the range from 10 to 100.

MaximumRestartCount

Optional

System.Nullable

Specifies the maximum number of conversion attempts before the conversion fails. The default value is 2.

The type must be a valid integer.

Name

Optional

System.String

Specifies the display name of the Word Services application.

The type must be a valid name of a Word Services application; for example, WordSvcApp1.

RecycleProcessThreshold

Optional

System.Nullable

Specifies the number of documents which are converted before a single instance of the Word server code process is recycled.

The type must be a valid integer in the range from 10 to 1000.

TimerJobFrequency

Optional

System.Nullable

Specifies the frequency, in minutes, with which the timer job for this service application runs. The default value is 15.

The type must be a valid integer in the range from 10 to 1440.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPWordConversionServiceApplication cmdlet to set global properties of a Word Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-----------EXAMPLE-----------------
Copy Code
Get-SPWordConversionService -Identity WordServices1 | Set-SPWordConversionService -TimerJobFrequency 30

This example sets the timer job frequency of the WordServices1 application to 30 minutes.
Click here to submit feedback on this topic.