Get-WebAnalyticsServiceApplication
See Also Example
[image]

Returns the settings for a Web Analytics service application.

Get-WebAnalyticsServiceApplication -Identity <WebAnalyticsServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.WebAnalytics.Administration.Cmdlets.WebAnalyticsServiceApplicationPipeBind

Specifies the Web Analytics service application to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Web Analytics service application (for example, WebAnalyticsApp1); or an instance of a valid WebAnalyticsServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Get-WebAnalyticsServiceApplication cmdlet reads the settings for a Web Analytics service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Reference
New-WebAnalyticsServiceApplication
Set-WebAnalyticsServiceApplication

            Click here to

      submit feedback
             on this topic.


New-WebAnalyticsServiceApplication
See Also Example
[image]

Adds a new Web Analytics service application to the farm.

New-WebAnalyticsServiceApplication -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-EnableDataTrimming <SwitchParameter>] [-ListOfReportingDatabases <String>] [-ListOfStagingDatabases <String>] [-Name <String>] [-ReportingDataRetentionPeriod <Int32>] [-SamplingRate <Int32>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

ApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool to run the Web service in for the service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid URL of a search application, in the form http://server_name; or an instance of a valid SPIisWebServiceApplicationPool object.

Name

Optional

System.String

Specifies the display name for the new Web Analytics service application. The name that you use must be a unique name of a Web Analytics service application in this farm. The name can be a maximum of 128 characters and cannot include the invalid characters comma (","), equal ("="), and colon (":").

The type must be a valid name of a service application proxy; for example, WebAnalyticsSvc1.

ReportingDataRetentionPeriod

Optional

System.Int32

Specifies the period, in months, that data is retained in the Web Analytics Reporting database. The default value is 25 .

The type must be one of the following values: 13, 25.

ListOfReportingDatabases

Optional

System.String

Specifies the server and database name for the Web Analytics Reporting database. The parameter value is an XML string that contains the server name and the database name.

The type must be a valid XML string.

ListOfStagingDatabases

Optional

System.String

Specifies the server and database name for the Web Analytics Staging database. The parameter value is an XML string that contains the server name and the database name.

The type must be a valid XML string.

SamplingRate

Optional

System.Int32

Specifies the sample rate of incoming data. This controls the throttling to reduce the amount of data to be processed. A backend process estimates the original traffic numbers. The default value is 100 .

The type must be an integer in the range of 0 to 100.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-WebAnalyticsServiceApplication cmdlet to create a new Web Analytics service application in the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Reference
Get-WebAnalyticsServiceApplication
Set-WebAnalyticsServiceApplication

            Click here to

      submit feedback
             on this topic.


New-WebAnalyticsServiceApplicationProxy
Example
[image]

Adds a new Web Analytics service application proxy to the farm.

New-WebAnalyticsServiceApplicationProxy -ServiceApplicationProxyName <String> -ServiceApplicationName <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

ServiceApplicationProxyName

Required

System.String

Specifies a display name for the new Web Analytics service application proxy. The name that you use must be a unique name of a Web Analytics service application in this farm. The name can be a maximum of 128 characters and cannot include the invalid characters comma (","), equal ("="), and colon (":").

The type must be a valid name of a service application proxy; for example, WebAnalyticsSvcProxy1.

ServiceApplicationName

Required

System.String

Specifies the name of the existing Web Analytics service application associated with the new Web Analytics Service application proxy.

The type must be a valid name of a service application; for example, WebAnalyticsSvc1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-WebAnalyticsServiceApplicationProxy cmdlet to create a new Web Analytics service application proxy to the farm, or to create an instance of a Web Analytics service proxy.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.


Set-WebAnalyticsServiceApplication
Example
[image]

Sets properties of a Web Analytics service application.

Set-WebAnalyticsServiceApplication -Identity <WebAnalyticsServiceApplicationPipeBind> [-ApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-ListOfReportingDatabases <String>] [-ListOfStagingDatabases <String>] [-SamplingRate <Int32>] [-WarehouseDataRetentionPeriod <Int32>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Server.WebAnalytics.Administration.Cmdlets.WebAnalyticsServiceApplicationPipeBind

Specifies the Web Analytics service application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Web Analytics Service application (for example, WebAnalyticsApp1); or an instance of a valid WebAnalyticsServiceApplication object.

ApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the name of the application pool in the form of a GUID. You can pass in the object name from the New-SPIisWebServiceApplicationPool cmdlet.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WarehouseDataRetentionPeriod

Optional

System.Int32

Specifies the period, in months, that data is retained in the Web Analytics Reporting database. The default value is 25.

The type must be one of the following values: 13, 25.

SamplingRate

Optional

System.Int32

Specifies the sample rate of incoming data. This controls the throttling to reduce the amount of data to be processed. A backend process estimates the original traffic numbers. The default value is 100.

The type must be an integer in the range of 0 to 100.

ListOfReportingDatabases

Optional

System.String

Specifies the server and database name for the Web analytics reporting database. The parameter value is an XML string that contains the server name and the database name.

The type must be a valid XML string.

ListOfStagingDatabases

Optional

System.String

Specifies the server and database name for the Web analytics staging database. The parameter value is an XML string that contains the server name and the database name.

The type must be a valid XML string.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-WebAnalyticsServiceApplication cmdlet to set the properties of a Web Analytics service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.