Get-SPVisioExternalData
Example
[image]

Returns the settings for external data connections for a Visio Service application.

Get-SPVisioExternalData -VisioServiceApplication <SPVisioServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter | Required | Type | Description
VisioServiceApplication | Required | Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind | Specifies the Visio Services application that contains the SPVisioExternalData object. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.
AssignmentCollection | Optional | Microsoft.SharePoint.PowerShell.SPAssignmentCollection |

Detailed Description

Use the Get-SPVisioExternalData cmdlet to read the settings for managing external data connections for a Visio Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.


Get-SPVisioPerformance
Example
[image]

Returns the Visio Graphics Services settings for the performance of a Visio Service application.

Get-SPVisioPerformance -VisioServiceApplication <SPVisioServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter | Required | Type | Description
VisioServiceApplication | Required | Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind | Specifies the Visio Services application that contains the SPVisioPerformance object. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.
AssignmentCollection | Optional | Microsoft.SharePoint.PowerShell.SPAssignmentCollection |

Detailed Description

Use the Get-SPVisioPerformance cmdlet to read the service settings for managing and configuring peformance for a Visio Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.


Get-SPVisioSafeDataProvider
Example
[image]

Returns the settings of a safe data provider for a Visio Services application.

Get-SPVisioSafeDataProvider -VisioServiceApplication <SPVisioServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-DataProviderId <String>] [-DataProviderType <Int32>]

Parameters

Parameter | Required | Type | Description
VisioServiceApplication | Required | Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind | Specifies the Visio Services application that contains the SPVisioSafeDataProvider object. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.
AssignmentCollection | Optional | Microsoft.SharePoint.PowerShell.SPAssignmentCollection |
DataProviderId | Optional | System.String | Specifies the safe data provider to get. The combination of DataProviderID and DataProviderType uniquely identify a data provider for a Visio Graphics Service application. The string that identifies the data provider can be a maximum of 255 alphanumeric characters. The type must be a valid string that identifies the data provider; for example, VisioDataProvider1.
DataProviderType | Optional | System.Int32 | Specifies the supported type of the data provider to get. Custom data types are supported; for example, Excel services. The type must be a valid identity of a data provider type.

Detailed Description

Use the Get-SPVisioSafeDataProvider cmdlet to retrieve the settings of the safe provider for a Visio Graphics Services application. If the DataProviderID parameter is not specified, this cmdlet returns the collection of safe providers on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.


Get-SPVisioServiceApplication
Example
[image]

Returns properties of a Visio Services application or a collection of Visio Services applications.

Get-SPVisioServiceApplication [-Identity <SPVisioServiceApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter | Required | Type | Description
Identity | Optional | Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind | Specifies the Visio Graphics Service application to get. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.
AssignmentCollection | Optional | Microsoft.SharePoint.PowerShell.SPAssignmentCollection |

Detailed Description

Use the Get-SPVisioServiceApplication cmdlet to retrieve the settings of the specified Visio Services application. If the Identity parameter is not specified, this cmdlet returns the collection of Visio Services applications on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.


Get-SPVisioServiceApplicationProxy
Example
[image]

Returns properties of a Visio Services application proxy or a collection of Visio Services application proxies.

Get-SPVisioServiceApplicationProxy [-Identity <SPVisioServiceApplicationProxyPipeBind>] [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationProxyPipeBind

Specifies the Visio Services application proxy to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPVisioServiceApplicationProxy cmdlet to read the settings of a Visio Services application proxy. If the Identity parameter is not specified, this cmdlet returns the collection of Visio Services application proxies on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------EXAMPLE 1---------------------
Copy Code
Get-SPVisioServiceApplicationProxy

This example returns a list of Visio Graphics Service Application Proxies.

----------------EXAMPLE 2---------------------
Copy Code
Get-SPVisioServiceApplicationProxy "Connection to VGS2"

This example returns settings for a Visio Graphics Service Application Proxy.
Click here to submit feedback on this topic.


New-SPVisioSafeDataProvider
Example
[image]

Adds a new data provider to a Visio Services application.

New-SPVisioSafeDataProvider -DataProviderId <String> -DataProviderType <Int32> -VisioServiceApplication <SPVisioServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Description <String>]

Parameters

Parameter Required Type Description

DataProviderId

Required

System.String

Specifies the name of the data provider to create. The combination of DataProviderID and DataProviderType uniquely identify a data provider for a Visio Graphics Service application. The string that identifies the data provider can be a maximum of 255 alphanumeric characters.

The type must be a valid string that identifies the data provider; for example, VisioDataProvider1.

DataProviderType

Required

System.Int32

The type must be a valid identity of a data provider type.

Specifies the supported type of the data provider to add. Custom data types are supported; for example, Excel Services.

VisioServiceApplication

Required

Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind

Specifies the Visio Services application in which to add the new safe data provider.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Description

Optional

System.String

Specifies the description of the new safe data provider.

The type must be a string with a maximum of 4096 characters.

Detailed Description

Use the New-SPVisioSafeDataProvider cmdlet to add a new data provider to the list of safe data providers for a Visio Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-------------------EXAMPLE------------------------
Copy Code
New-SPVisioSafeDataProvider -VisioServiceApplication "VGS1" -DataProviderID "CustomProvider" -DataProviderType 5 -Description "Custom Data Provider"

This example creates a new Safe Data Provider for a specified Visio Graphics Service Application


New-SPVisioServiceApplication
Example
[image]

Adds a new Visio Services application to a farm.

New-SPVisioServiceApplication -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AddToDefaultGroup <SwitchParameter>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind

Specifies the Visio Services application to create.

The type must be a valid name of a Visio Service application; for example, such as MyVisioService1.

ServiceApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool in which to run the Web service for the service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

CreateDefaultProxy

Optional

System.Management.Automation.SwitchParameter

Specifies that a default proxy is created for the new Visio Services application.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPVisioServiceApplication cmdlet to add a new Visio Services application to a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------EXAMPLE 1---------------------
Copy Code
New-SPVisioServiceApplication -Identity "VGS2" -ServiceApplicationPool "SharePoint Web Services Default" -CreateDefaultProxy

This example creates a new Visio Graphics Service Application "VGS2", and also creates a Service Application Proxy associated with it.

----------------EXAMPLE 2---------------------
Copy Code
Get-SPIISWebServiceApplicationPool "SharePoint Web Services System Default" | New-SPVisioServiceApplication "VGS3"

This example creates a new Visio Graphics Service application "VGS3" without creating an associated Service Application Proxy. It uses a PipeBind from Get-SPIISWebServiceApplicationPool.


New-SPVisioServiceApplicationProxy
Example
[image]

Adds a new Visio Services application proxy to a farm.

New-SPVisioServiceApplicationProxy -ServiceApplication <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Name <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationProxyPipeBind

Specifies the Visio Services application proxy to create.

The type must be a valid name of a Visio Services application; for example, such as MyVisioService1.

ServiceApplicationName

Required

System.String

Specifies the Visio Services application that is associated with the application proxy.

The type must be a valid name of a Visio Services application; for example, MyVisioService1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPVisioServiceApplicationProxy cmdlet to add a new Visio Services application proxy to a farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------------EXAMPLE------------------------

Copy Code
New-SPVisioServiceApplicationProxy -Identity "ProxyToVGS3" -ServiceApplicationName "VGS3"

This example creates a new Visio Service Application Proxy connected to a Visio Service Application.


Remove-SPVisioSafeDataProvider
Example
[image]

Removes a data provider from a Visio Services application.

Remove-SPVisioSafeDataProvider -DataProviderId <String> -DataProviderType <Int32> -VisioServiceApplication <SPVisioServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter | Required | Type | Description
DataProviderId | Required | System.String | Specifies the name of the data provider to delete. The combination of DataProviderID and DataProviderType uniquely identify a data provider for a Visio Services application. The string that identifies the data provider can be a maximum of 255 alphanumeric characters. A valid string that identifies the data provider.
DataProviderType | Required | System.Int32 | Specifies the supported type of the data provider to delete. The type must be a valid identity of a data provider type.
VisioServiceApplication | Required | Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind | Specifies the Visio Services application that contains the SPVisioSafeDataProvider object. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.
AssignmentCollection | Optional | Microsoft.SharePoint.PowerShell.SPAssignmentCollection |

Detailed Description

Use the Remove-SPVisioSafeDataProvider cmdlet to delete the safe data provider specified in the DataProviderID parameter.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

            Click here to

      submit feedback
             on this topic.


Set-SPVisioPerformance
Example
[image]

Sets performance properties for a Visio Services application.

Set-SPVisioPerformance -MaxDiagramCacheAge <Int32> -MaxDiagramSize <Int64> -MaxRecalcDuration <Int32> -MinDiagramCacheAge <Int32> -VisioServiceApplication <SPVisioServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

MaxDiagramCacheAge

Required

System.Int32

Specifies the time, in minutes, after which cached items are purged. This value affects memory utilization on the server. A large cache age will decrease the rate at which diagrams may be refreshed by users and reduces CPU and Memory usage of the server. The default value is 60 minutes.

The type must be an integer in the range of 0 to 34560 (24 days).

MaxDiagramSize

Required

System.Int64

Specifies the maximum size, in MB, of a diagram that can be opened by the Visio Services application. The default value is 5.

The type must be an integer in the range of 1 to 10.

MaxRenderDuration

Required

System.Int32

Specifies the maximum time, in seconds, a diagram may be recalculated by the Visio Graphics Service Application. Diagram recalculation operations taking more than this number of seconds will be aborted by the service. A small value increases performance by only allowing simple diagrams to be processed by the server, minimizing CPU & memory usage. A larger value allows the recalculation of more complex diagrams while using more CPU cycles and memory.

A valid integer value is from 1 to 120 seconds (2 minutes). The default value is 60 seconds.

MinDiagramCacheAge

Required

System.Int32

Specifies the minimum time, in minutes, a diagram is cached in memory. This value affects memory utilization on the server. A small value allows users to refresh their diagrams more often, but will increase memory and CPU load of the server. The default value is 5.

The type must be an integer in the range of 0 to 34560 (24 days).

VisioServiceApplication

Required

Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind

Specifies the Visio Services application that contains the SPVisioPerformance object.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Set-SPVisioPerformance cmdlet to set properties related to performance for a Visio Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-------------------EXAMPLE 1----------------------
Copy Code
Set-SPVisioPerformance -VisioServiceApplication "VGS2" -MaxDiagramSize 10 -MaxRecalcDuration 120 -MinDiagramCacheAge 1 -MaxDiagramCacheAge 4

This example changes settings related to performance for a Visio Graphics Service Application.

-------------------EXAMPLE 2----------------------
Copy Code
Set-SPVisioPerformance -VisioServiceApplication "VGS2" -MaxDiagramSize 10

This example changes settings related to performance for a Visio Graphics Service Application. Note that only one setting value is specified. The cmdLet will prompt you for the other parameter values.


Set-SPVisioSafeDataProvider
See Also Example
[image]

Specifies a description of a safe data provider for a Visio Services application.

Set-SPVisioSafeDataProvider -DataProviderId <String> -DataProviderType <Int32> -Description <String> -VisioServiceApplication <SPVisioServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter | Required | Type | Description
DataProviderId | Required | System.String | Specifies the name of the data provider to update. The combination of DataProviderID and DataProviderType uniquely identify a data provider for a Visio Graphics Service application. The string that identifies the data provider can be a maximum of 255 alphanumeric characters. Custom data types are supported; for example, Excel services. The type must be a valid string that identifies the data provider.
DataProviderType | Required | System.Int32 | Specifies the supported type of the data provider to get. Custom data types are supported; for example, Excel services. The type must be a valid identity of a data provider type.
Description | Required | System.String | Specifies the description of the safe data provider to set. The type must be a string with a maximum of 4096 characters.
VisioServiceApplication | Required | Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind | Specifies the Visio Services application that contains the SPVisioSafeDataProvider object. The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.
AssignmentCollection | Optional | Microsoft.SharePoint.PowerShell.SPAssignmentCollection |

Detailed Description

Use the Set-SPVisioSafeDataProvider cmdlet to set the Description property of a safe data provider for a Visio Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Reference
Remove-SPVisioSafeDataProvider
Get-SPVisioSafeDataProvider
New-SPVisioSafeDataProvider

            Click here to

      submit feedback
             on this topic.


Set-SPVisioServiceApplication
See Also Example
[image]

Sets the ServiceApplicationPool property of a Visio Services application.

Set-SPVisioServiceApplication -Identity <SPVisioServiceApplicationPipeBind> -ServiceApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.Visio.Server.Cmdlet.SPVisioServiceApplicationPipeBind

Specifies the Visio Services application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Visio Services application (for example, MyVisioService1); or an instance of a valid SPVisioServiceApplication object.

ServiceApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the IIS application pool to change. The Web service for the service application runs in the specified application pool.

A valid name of a Visio Service application pool, such as "MyVisioServiceAppPool1"; or a valid GUID, such as "12345678-90ab-cdef-1234-567890bcdefgh", or an instance of a valid SPIisWebServiceApplicationPoolPipeBind object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPVisioServiceApplication cmdlet to set the ServiceApplicationPool property for a Visio Services application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-----------------EXAMPLE 1----------------------
Copy Code
Set-SPVisioServiceApplication -identity "VGS1" -ServiceApplicationPool "SharePoint Web Services System Default"

This example changes the Application Pool of the "VGS1" service application.

-----------------EXAMPLE 2----------------------
Copy Code
Get-SPIISWebServiceApplicationPool "SharePoint Web Services Default" | Set-SPVisioServiceApplication VGS1

This example changes the Application Pool of the "VGS1" service application using a PipeBind from Get-SPIISWebServiceApplicationPool.

See Also

Remove-SPVisioServiceApplication

Reference

New-SPVisioServiceApplication
Get-SPVisioServiceApplication
Get-SPVisioServiceApplication

Click here to submit feedback on this topic.