New-SPProfileServiceApplication
Example
[image]

Adds a User Profile Service application to a farm.

New-SPProfileServiceApplication -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MySiteHostLocation <SPSitePipeBind>] [-Name <String>] [-PartitionMode <SwitchParameter>] [-ProfileDBCredentials <PSCredential>] [-ProfileDBFailoverServer <String>] [-ProfileDBName <String>] [-ProfileDBServer <String>] [-ProfileSyncDBCredentials <PSCredential>] [-ProfileSyncDBFailoverServer <String>] [-ProfileSyncDBName <String>] [-ProfileSyncDBServer <String>] [-SocialDBCredentials <PSCredential>] [-SocialDBFailoverServer <String>] [-SocialDBName <String>] [-SocialDBServer <String>] [-SyncInstanceMachine <SPServerPipeBind>] [-WhatIf [<SwitchParameter>]]
New-SPProfileServiceApplication -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> -MySiteHostLocation <SPSitePipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MySiteHostLocation <SPSitePipeBind>] [-MySiteManagedPath <SPPrefixPipeBind>] [-Name <String>] [-PartitionMode <SwitchParameter>] [-ProfileDBCredentials <PSCredential>] [-ProfileDBFailoverServer <String>] [-ProfileDBName <String>] [-ProfileDBServer <String>] [-ProfileSyncDBCredentials <PSCredential>] [-ProfileSyncDBFailoverServer <String>] [-ProfileSyncDBName <String>] [-ProfileSyncDBServer <String>] [-SiteNamingConflictResolution <String>] [-SocialDBCredentials <PSCredential>] [-SocialDBFailoverServer <String>] [-SocialDBName <String>] [-SocialDBServer <String>] [-SyncInstanceMachine <SPServerPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Set 1

Parameter

Required

Type

Description

ApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool in which to run the Web service for the service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

Name

Required

System.String

Specifies the display name for the new User Profile Service application. The name must be a unique name of a User Profile Service application in this farm. The name can be a maximum of 64 characters.

The type must be a valid name of a service application; for example, UserProfileSvcApp1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

MySiteHostLocation

Optional

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the site collection where My Site Web site will be created.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

PartitionMode

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application restrict data by site group. Once the PartitionMode parameter is set, it cannot be changed after the service application is created.

ProfileDBCredentials

Optional

System.Management.Automation.PSCredential

Specifies the set of security credentials, such as a user name and a password, that is used to connect to the User Profile database that this cmdlet creates.

The type must be a valid PSCredential object.

ProfileDBName

Optional

System.String

Specifies the name of the database where the User Profile database is created.

ProfileDBServer

Optional

System.String

Specifies the database where the User Profile database will be created.

The type must be a valid name of a SQL Server database; for example, ProfileAppDB1.

ProfileSyncDBCredentials

Optional

System.Management.Automation.PSCredential

Specifies the set of security credentials, such as a user name and a password that will be used to connect to the ProfileSync database that is specified in the ProfileSyncDBName parameter.

The type must be a valid PSCredential object.

ProfileSyncDBName

Optional

System.String

Specifies the database where Profile Sync database will be created.

The type must be a valid name of a SQL Server database; for example, ProfileSyncAppDB1.

ProfileSyncDBServer

Optional

System.String

Specifies the database server that will host the ProfileSync database that is specified in the ProfileSyncDBName parameter.

The type must be a valid name of a SQL Server host; for example, SQLServerProfileSyncHost1.

SocialDBCredentials

Optional

System.Management.Automation.PSCredential

The set of security credentials, including a user name and a password, that is used to connect to the Social database that this cmdlet creates.

The type must be a valid PSCredential object.

SocialDBName

Optional

System.String

Specifies the database where the Social database will be created.

The type must be a valid name of a SQL Server host; for example, SQLServerSocialHost1.

SocialDBServer

Optional

System.String

Specifies the database server that will host the Social database that is specified in SocialDBName.

The type must be a valid name of a SQL Server host; for example, SQLServerSocialHost1.

SyncInstanceMachine

Optional

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Specifies the server computer that hosts the Profile Sync database.

The type must be a valid GUID, such as 12345678-90ab-cdef-1234-567890bcdefgh; the IP address of a server computer, in the form 208.77.188.166; a valid name of a SQL Server host service (for example, SQLServerHost1); or an instance of a valid SPServer object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameter Set 2

Parameter

Required

Type

Description

ApplicationPool

Required

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool in which to run the Web service for the service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

Name

Required

System.String

Specifies the display name for the new User Profile Service application. The name must be a unique name of a User Profile Service application in this farm. The name can be a maximum of 64 characters.

The type must be a valid name of a service application; for example, UserProfileSvcApp1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

MySiteHostLocation

Optional

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the site collection where My Site Web site will be created.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

PartitionMode

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application restrict data by site group. Once the PartitionMode parameter is set, it cannot be changed after the service application is created.

ProfileDBCredentials

Optional

System.Management.Automation.PSCredential

Specifies the set of security credentials, such as a user name and a password, that is used to connect to the User Profile database that this cmdlet creates.

The type must be a valid PSCredential object.

ProfileDBName

Optional

System.String

Specifies the name of the database where the User Profile database is created.

ProfileDBServer

Optional

System.String

Specifies the database where the User Profile database will be created.

The type must be a valid name of a SQL Server database; for example, ProfileAppDB1.

ProfileSyncDBCredentials

Optional

System.Management.Automation.PSCredential

Specifies the set of security credentials, such as a user name and a password that will be used to connect to the ProfileSync database that is specified in the ProfileSyncDBName parameter.

The type must be a valid PSCredential object.

ProfileSyncDBName

Optional

System.String

Specifies the database where Profile Sync database will be created.

The type must be a valid name of a SQL Server database; for example, ProfileSyncAppDB1.

ProfileSyncDBServer

Optional

System.String

Specifies the database server that will host the ProfileSync database that is specified in the ProfileSyncDBName parameter.

The type must be a valid name of a SQL Server host; for example, SQLServerProfileSyncHost1.

SocialDBCredentials

Optional

System.Management.Automation.PSCredential

The set of security credentials, including a user name and a password, that is used to connect to the Social database that this cmdlet creates.

The type must be a valid PSCredential object.

SocialDBName

Optional

System.String

Specifies the database where the Social database will be created.

The type must be a valid name of a SQL Server host; for example, SQLServerSocialHost1.

SocialDBServer

Optional

System.String

Specifies the database server that will host the Social database that is specified in SocialDBName.

The type must be a valid name of a SQL Server host; for example, SQLServerSocialHost1.

SyncInstanceMachine

Optional

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Specifies the server computer that hosts the Profile Sync database.

The type must be a valid GUID, such as 12345678-90ab-cdef-1234-567890bcdefgh; the IP address of a server computer, in the form 208.77.188.166; a valid name of a SQL Server host service (for example, SQLServerHost1); or an instance of a valid SPServer object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPProfileServiceApplication cmdlet adds and creates a new profile service application, or creates an instance of a profile service.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------------EXAMPLE-------------------------

Copy Code
$appPool = New-SPIisWebServiceApplicationPool -Name HostedAppPool -Account (Get-SPManagedAccount "contoso\AppPoolAccount")
New-SPProfileServiceApplication -Name PartitionedUserProfileApplication -PartitionMode -ApplicationPool $appPool

This example creates a new User Profile Service application.
Click here to submit feedback on this topic.


Set-SPProfileServiceApplication
Example
[image]

Sets properties of a profile service application.

Set-SPProfileServiceApplication -Identity <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MetadataWebServiceApplicationProxy <SPServiceApplicationProxyPipeBind>] [-MySiteHostLocation <SPSitePipeBind>] [-Name <String>] [-PersonalSiteRelativePath <SPPrefixPipeBind>] [-SiteNamingConflictResolution <String>] [-SyncInstanceMachine <SPServerPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Specifies the Profile service application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a subscription settings service application (for example, SubscriptionSettingsApp1); or an instance of a valid SPServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

MetadataWebServiceApplicationProxy

Optional

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the Taxonomy service proxy associated with Profile Service being provisioned.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a service application proxy (for example, ProfileSvcProxy1); or an instance of a valid SPServiceApplicationProxy object.

MySiteHostLocation

Optional

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the site collection where My Site will be provisioned.

The type must be a valid URL, in the form http://server_name; a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a site subscription (for example, SiteSubscription1); or an instance of a valid SiteSubscription object.

MySiteRelativePath

Optional

System.String

Specifies the managed path location of personal sites.

The type must be a valid URL, in the form http://server_name.

Name

Optional

System.String

Specifies the display name for the new Profile service application. The name that you use must be a unique name of a Profile service application in this farm. The name can be a maximum of 128 characters.

The type must be a valid name of a service application; for example, ProfileSvcApp1.

SyncInstanceMachine

Optional

Microsoft.SharePoint.PowerShell.SPServerPipeBind

Specifies the server computer that hosts the Profile Sync database.

The type must be a valid GUID, such as 12345678-90ab-cdef-1234-567890bcdefgh; the IP address of a server computer, in the form 208.77.188.166; a valid name of a SQL Server host service (for example, SQLServerHost1); or an instance of a valid SPServer object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPProfileServiceApplication cmdlet to set properties of a Profile service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

---------------EXAMPLE---------------------
Copy Code
$ap = Get-SPServiceApplication -Name PartitionedUserProfileApplication
#Change the name of the application
      Set-SPProfileServiceApplication -Identity $ap -Name  PartitionedUserProfileApplication2

This example set profile information using the specified identity.


Set-SPProfileServiceApplicationProxy
Example
[image]

Sets properties of a proxy for a Profile service application.

Set-SPProfileServiceApplicationProxy -Identity <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultProxyGroup <SwitchParameter>] [-Name <String>] [-ProfileServiceApplication <SPServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the Profile service application proxy to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a service application proxy (for example, ProfileSvcProxy1); or an instance of a valid SPServiceApplicationProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DefaultProxyGroup

Optional

System.Management.Automation.SwitchParameter

Specifies that the Profile service application proxy is added to the default proxy group for the local farm.

Name

Optional

System.String

Specifies the display name for the Profile service application. The name that you use must be a unique name of a Profile service application in this farm. The name can be a maximum of 128 characters.

The type must be a name of a valid service application proxy; for example, ProfileSvcProxy1.

ProfileServiceApplication

Optional

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Specifies the local Profile service application associated with the proxy specified in the Identity parameter.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a subscription settings service application (for example, SubscriptionSettingsApp1); or an instance of a valid SPServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPProfileServiceApplicationProxy cmdlet to set properties of a proxy for a Profile service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------EXAMPLE---------------------

Copy Code
#Get UPA Proxy
$pr = Get-SPServiceApplicationProxy | ? {$_.DisplayName.Contains(PartitionedUserProfileApplication_Proxy)}
#Change the name of the proxy
Set-SPProfileServiceApplicationProxy -Identity $pr -Name  PartitionedUserProfileApplication_Proxy2


Remove-SPProfileServiceApplicationTenant
Example
[image]

Deletes a site subscription from a Profile service application.

Remove-SPProfileServiceApplicationTenant -Identity <SPSiteSubscriptionPipeBind> -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the proxy of the Profile service application that contains the site subscription to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a service application proxy (for example, ProfileSvcProxy1); or an instance of a valid SPServiceApplicationProxy object.

ProfileServiceApplicationProxy

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove- SPProfileServiceApplicationTenant cmdlet to delete a site subscription from a Profile service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------EXAMPLE-----------------

Copy Code
$sub = Get-SPSiteSubscription http://contoso/my
$pr = Get-SPServiceApplicationProxy | ? {$_.DisplayName.Contains(PartitionedUserProfileApplication_Proxy)}
Remove- SPProfileServiceApplicationTenant -Identity $sub -ProfileServiceApplicationProxy $pr

This example removes tenant data.


Set-SPProfileServiceApplicationTenant
See Also Example
[image]

Sets the parameters of a site subscription.

Set-SPSiteSubscriptionProfileConfig [-Identity] <SPSiteSubscriptionPipeBind> -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MySiteHostLocation <SPSitePipeBind>] [-SynchronizationOU <String>] [-WhatIf [<SwitchParameter>]]
Set-SPSiteSubscriptionProfileConfig [-Identity] <SPSiteSubscriptionPipeBind> -MySiteHostLocation <SPSitePipeBind> -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MySiteHostLocation <SPSitePipeBind>] [-MySiteManagedPath <SPPrefixPipeBind>] [-SiteNamingConflictResolution <String>] [-SynchronizationOU <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Set 1

Parameter

Required

Type

Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the proxy of the User Profile Service application that contains the site subscription to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a User Profile Service application proxy (for example, UserProfileSvcProxy1); or an instance of a valid SPServiceApplicationProxy object.

MySiteHostLocation

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the site collection where the My Site host for the site subscription is provisioned.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

ProfileServiceApplicationProxy

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the name of the proxy for the User Profile Service application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SynchronizationOU

Optional

System.String

Specifies the organizational unit that serves the site subscription.

The type must be a valid name of an organizational unit; for example, OrgUnit1.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameter Set 2

Parameter

Required

Type

Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the proxy of the User Profile Service application that contains the site subscription to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a User Profile Service application proxy (for example, UserProfileSvcProxy1); or an instance of a valid SPServiceApplicationProxy object.

MySiteHostLocation

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the site collection where the My Site host for the site subscription is provisioned.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

ProfileServiceApplicationProxy

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the name of the proxy for the User Profile Service application.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

MySiteManagedPath

Optional

Microsoft.SharePoint.PowerShell.SPPrefixPipeBind

Specifies the managed path where personal sites will be created.

The type must be a valid URL, in the form http://server_name.

SiteNamingConflictResolution

Optional

System.String

Specifies the format to use to name personal sites.

Use one of the following integer values:

1-- Personal site collections to be named after user names without any conflict resolution. For example, http://portal_site/location/username/

2 -- Personal site collections to be named after user names with conflict resolution by using domain names. For example, .../username/ or .../domain_username/

3-- Personal site collections to be named using domain and username always to avoid any conflicts. For example, http://portal_site/location/domain_username/

The default value is 1 (do not resolve conflicts).

SynchronizationOU

Optional

System.String

Specifies the organizational unit that serves the site subscription.

The type must be a valid name of an organizational unit; for example, OrgUnit1.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Set-SPSiteSubscriptionProfileConfig cmdlet sets the parameters of a site subscription.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example

Copy Code

  See Also
Export-SPSiteSubscriptionProfileConfigImport-SPSiteSubscriptionProfileConfig
Reference
Add-SPProfileServiceApplicationTenant
Remove-SPProfileServiceApplicationTenant

            Click here to

      submit feedback
             on this topic.


New-SPProfileServiceApplicationProxy
Example
[image]

Creates a Profile service application proxy on the local farm.

New-SPProfileServiceApplicationProxy -Name <String> -ProfileServiceApplication <SPServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-DefaultProxyGroup <SwitchParameter>] [-PartitionMode <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the display name for the new Profile Service application. The name that you use must be a unique name of a Profile Service application in this farm. The name can be a maximum of 128 characters.

The type must be a name of a valid service application proxy; for example, ProfileSvcProxy1.

ProfileServiceApplication

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Specifies the local Profile service application associated with the new proxy.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a subscription Profile service application (for example, ProfileSvcApp1); or an instance of a valid SPServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DefaultProxyGroup

Optional

System.Management.Automation.SwitchParameter

Specifies that the Profile service application proxy is added to the default proxy group for the local farm.

PartitionMode

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application restrict data by SiteGroup. This property cannot be changed after the service application is created.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPProfileServiceApplicationProxy to create a Profile service application proxy on the local farm. The proxy is added to the default proxy group for the local farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------------EXAMPLE---------------------
Copy Code
$app = Get-SPServiceApplication -Name PartitionedUserProfileApplication.
New-SPProfileServiceApplicationProxy -Name PartitionedUserProfileApplication_Proxy -ProfileServiceApplication $app -PartitionMode

This example creates a new service proxy.


Add-SPProfileServiceApplicationTenant
See Also Example
[image]

Adds a new site subscription to a User Profile Service application.

Add-SPSiteSubscriptionProfileConfig [-Identity] <SPSiteSubscriptionPipeBind> -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MySiteHostLocation <SPSitePipeBind>] [-SynchronizationOU <String>] [-WhatIf [<SwitchParameter>]]

Add-SPSiteSubscriptionProfileConfig [-Identity] <SPSiteSubscriptionPipeBind> -MySiteHostLocation <SPSitePipeBind> -ProfileServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-MySiteHostLocation <SPSitePipeBind>] [-MySiteManagedPath <SPPrefixPipeBind>] [-SiteNamingConflictResolution <String>] [-SynchronizationOU <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Set 1

Parameter

Required

Type

Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the proxy of the User Profile Service application to add the site subscription to.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a User Profile Service application proxy (for example, UserProfileSvcProxy1); or an instance of a valid SPServiceApplicationProxy object.

MySiteHostLocation

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the site collection where My Site host for the site subscription is provisioned.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

ProfileServiceApplicationProxy

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the identifier for the User Profile Service Application proxy where the tenant is to be created.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

SynchronizationOU

Optional

System.String

Specifies the organizational unit serving the site subscription.

The type must be a valid name of an organizational unit; for example, OrgUnit1.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameter Set 2

Parameter

Required

Type

Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the proxy of the User Profile Service application to add the site subscription to.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a User Profile Service application proxy (for example, UserProfileSvcProxy1); or an instance of a valid SPServiceApplicationProxy object.

MySiteHostLocation

Required

Microsoft.SharePoint.PowerShell.SPSitePipeBind

Specifies the site collection where My Site host for the site subscription is provisioned.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or a valid URL, in the form http://server_name; or an instance of a valid SPSite object.

ProfileServiceApplicationProxy

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the identifier for the User Profile Service Application proxy where the tenant is to be created.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

MySiteManagedPath

Optional

Microsoft.SharePoint.PowerShell.SPPrefixPipeBind

Specifies the managed path where personal sites will be created.

The type must be a valid URL, in the form http://server_name.

SiteNamingConflictResolution

Optional

System.String

Specifies the format to use to name personal sites.

Use one of the following integer values:

1-- Personal site collections to be named after user names without any conflict resolution. For example, http://portal_site/location/username/

2 -- Personal site collections to be named after user names with conflict resolution by using domain names. For example, .../username/ or .../domain_username/

3-- Personal site collections to be named using domain and username always to avoid any conflicts. For example, http://portal_site/location/domain_username/

The default value is 1 (do not resolve conflicts).

SynchronizationOU

Optional

System.String

Specifies the organizational unit serving the site subscription.

The type must be a valid name of an organizational unit; for example, OrgUnit1.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The Add-SPSiteSubscriptionProfileConfig cmdlet adds a new site subscription to a User Profile Service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------EXAMPLE------------------

Copy Code
#Get UPA Proxy
$pr = Get-SPServiceApplicationProxy | ? {$_.DisplayName.Contains(PartitionedUserProfileApplication_Proxy)}
Copy Code
#Add tenant to UPA
Add-SPSiteSubscriptionProfileConfig -Identity $sub -ProfileServiceApplicationProxy $pr -MySiteHostLocation http://contoso/my
Copy Code
#Create new site subscription
$sub = New-SPSiteSubscription

This example creates a new User Profile Service application tenant.

See Also

Export-SPSiteSubscriptionProfileConfigImport-SPSiteSubscriptionProfileConfig

Reference

Remove-SPProfileServiceApplicationTenant
Set-SPProfileServiceApplicationTenant

Click here to submit feedback on this topic.