Clear-SPSecureStoreCredentialMapping
Example
[image]

Deletes a credential mapping from a Secure Store application.

Clear-SPSecureStoreCredentialMapping -Identity <SPSecureStoreApplication> -Principal <SPClaim> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]
Clear-SPSecureStoreCredentialMapping -All <SwitchParameter> -Principal <SPClaim> -ServiceContext <SPServiceContextPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Set 1

Parameter

Required

Type

Description

Identity

Required

Microsoft.Office.SecureStoreService.PowerShellCmdlet.SPSecureStoreApplication

Specifies the Secure Store application (that contains the principal) from which to delete the credential mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Secure Store application (for example, SecureStoreApp1); or an instance of a valid SPSecureStoreApplication object.

Principal

Required

Microsoft.SharePoint.SPClaim

Specifies the SPClaims object that contains the principal.

The type must be a valid name of a user principal name; for example, jsmith@something.com.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Parameter Set 2

Parameter

Required

Type

Description

All

Required

System.Management.Automation.SwitchParameter

Specifies that the principal is deleted from all Secure Store applications.

Principal

Required

Microsoft.SharePoint.SPClaim

Specifies the SPClaims object that contains the principal.

The type must be a valid name of a user principal name; for example, jsmith@something.com.

ServiceContext

Required

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Specifies the service context for which the credential mapping will be deleted.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a service context (for example, ServiceContext1); or an instance of a valid SPServiceContext object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Clear-SPSecureStoreCredentialMapping cmdlet to delete a credential mapping from a Secure Store application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code examples

Copy Code

            Click here to

      submit feedback
             on this topic.


Disable-SPSingleSignOn
Example
[image]

Turns off the Microsoft Single Sign-On service on a farm server.

Disable-SPSingleSignOn -ServerName <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

ServerName

Required

System.String

Specifies the Office SharePoint Server in the farm that contains the SSOSrv to turn off.

The type must be a valid name of a SharePoint server; for example, MySPServer1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Disable-SPSingleSignOn cmdlet to turn off the Microsoft Single Sign-On (SSO) service on a farm server. After turning off the SSO, use the Upgrade-SPSingleSignOn cmdlet to convert a single sign-on database to a Secure Store database. Single sign-on (SSO) is a Microsoft SharePoint Server feature. SSO functionality is performed by the Secure Store service in Microsoft SharePoint Server 2010.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

The following example turns off the SSO service myOldSSO.
Copy Code
PS> Disable-SPSingleSignOn myOldSSO
Click here to submit feedback on this topic.


Get-SPSecureStoreApplication
Example
[image]

Returns a Secure Store application.

Get-SPSecureStoreApplication -Name <String> -ServiceContext <SPServiceContextPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the name of the Secure Store application to get.

The type must be a valid name of a Secure Store application; for example, SecureStoreApp1.

ServiceContext

Required

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Specifies the service context for the local Secure Store service application to connect to.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a service context (for example, ServiceContext1); or an instance of a valid SPServiceContext object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Get-SPSecureStoreApplication cmdlet to read a Secure Store service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example


New-SPSecureStoreApplication
Example
[image]

Creates a new Secure Store application.

New-SPSecureStoreApplication -ServiceContext <SPServiceContextPipeBind> -TargetApplication <TargetApplication> [-Administrator <SPClaim[]>] [-AssignmentCollection <SPAssignmentCollection>] [-CredentialsOwnerGroup <SPClaim[]>] [-Fields <TargetApplicationField[]>] [-TicketRedeemer <SPClaim[]>]

Parameters

Parameter Required Type Description

ServiceContext

Required

Microsoft.SharePoint.PowerShell.SPServiceContextPipeBind

Specifies the service context for the target application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a service context (for example, ServiceContext1); or an instance of a valid SPServiceContext object.

TargetApplication

Required

Microsoft.Office.SecureStoreService.Server.TargetApplication

Specifies information about the target application. For example, the TargetApplication object includes data values for application name, display name, contact info, enable ticketing flag, and URL address to set the credential. The schema for the TargetApplication object is defined in the ISecureSToreProviderExtended interface that exposes the target application metadata.

The type must be a valid TargetApplication object array.

Administrator

Optional

Microsoft.SharePoint.SPClaim[]

Specifies the administrator of the new Secure Store application.

The type must be a valid SPClaim object array.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CredentialsOwnerGroup

Optional

Microsoft.SharePoint.SPClaim[]

Specifies the claims object for the groups that own the group credentials.

The type must be a valid SPClaim object array.

Fields

Optional

Microsoft.Office.SecureStoreService.Server.TargetApplicationField[]

Specifies the field information for the application. The default fields are username and password.

The type must be a valid array of ApplicationField objects.

TicketRedeemer

Optional

Microsoft.SharePoint.SPClaim[]

Specifies the ticket redeemer claim value.

The type must be a valid SPClaim object array.

Detailed Description

Use the New-SPSecureStoreApplication cmdlet to create a new Secure Store application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example


New-SPSecureStoreServiceApplication
Example
[image]

Creates a new Secure Store service application in the farm.

New-SPSecureStoreServiceApplication -ApplicationPool <SPIisWebServiceApplicationPool> -AuditingEnabled <SwitchParameter> -Name <String> [-Administrators <String[]>] [-AssignmentCollection <SPAssignmentCollection>] [-AuditlogMaxSize <Nullable>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabasePassword <SecureString>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-PartitionMode <SwitchParameter>] [-Sharing <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

ApplicationPool

Required

Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool

Specifies the existing IIS application pool to run the Web service in for the new service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

AuditingEnabled

Required

System.Management.Automation.SwitchParameter

Turns on auditing for the Secure Store service.

Name

Required

System.String

Specifies the name of the new Secure Store Service service application.

The type must be a valid name of a service application; for example, SecureStoreSvcApp1 .

Administrators

Optional

System.String[]

Specifies the administrator of the new Secure Store service application.

The type must be an array of valid user names.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

AuditlogMaxSize

Optional

System.Nullable

Specifies the number of days to retain the audit log.

The type must be a valid integer.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabaseCredentials

Optional

System.Management.Automation.PSCredential

Specifies the PSCredential object that contains the user name and password to be used for database SQL authentication.

The type must be a valid PSCredential object.

DatabaseName

Optional

System.String

Specifies the name of the Secure Store service database.

The type must be a valid name of a SQL Server database; for example, SecureStoreDB1.

DatabasePassword

Optional

System.Security.SecureString

Specifies the password for the user specified in DatabaseUserName. Use this parameter only if SQL authentication is used to access the metadata service application database.

The type must be a valid SQL Server password.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database specified in DatabaseName.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the user name to use for connecting to the database for the Secure Store service application. Use this parameter only if SQL authentication is used to access the service application database.

The type must be a valid user name; for example, UserName1.

FailoverDatabaseServer

Optional

System.String

Specifies the name of the host server for the failover database server.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

PartitionMode

Optional

System.Management.Automation.SwitchParameter

Specifies that the service application restricts data by subscription ID. This property cannot be changed after the service application is created.

Sharing

Optional

System.Management.Automation.SwitchParameter

Specifies that the Secure Store service application is published and shared across the farm.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPSecureStoreServiceApplication cmdlet to create a new Secure Store Service service application in the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


New-SPSecureStoreTargetApplication
Example
[image]

Creates a new Secure Store Target application.

New-SPSecureStoreTargetApplication -ApplicationType <Individual | Group | IndividualWithTicketing | GroupWithTicketing | RestrictedIndividual | RestrictedGroup | IndividualWindows | GroupWindows | IndividualWindowsWithTicketing | GroupWindowsWithTicketing | RestrictedIndividualWindows | RestrictedGroupWindows> -FriendlyName <String> -Name <String> [-AssignmentCollection <SPAssignmentCollection>] [-ContactEmail <String>] [-SetCredentialsUri <Uri>] [-TimeoutInMinutes <Int32>]

Parameters

Parameter Required Type Description

ApplicationType

Required

Microsoft.BusinessData.Infrastructure.SecureStore.TargetApplicationType

Specifies the type of target application.

The type must be one of the following:

FriendlyName

Required

System.String

Specifies the display name of the new target application.

The type must be a valid name of a target application; for example, SecureStoreTargetApp1.

Name

Required

System.String

Specifies the display name of the new target application.

The type must be a valid name of a target application; for example, ABCExcelTargetApp1.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

ContactEmail

Optional

System.String

Specifies the contact information for the target application.

The type must be a valid user name; for example, MySPUser1@some.com.

SetCredentialsUri

Optional

System.Uri

Specifies the URI for setting the user application credentials.

The type must be a valid URI, in the form file:\\server_name\sitedocs.

TimeoutInMinutes

Optional

System.Int32

The time, in minutes, a ticket is valid if it is not redeemed by the target application. Make sure that the ticket time-out value is long enough to last between the time when the ticket is issued to the time that it is redeemed The default value is 2.

The type must be a valid integer.

Detailed Description

Use the New-SPSecureStoreTargetApplication cmdlet to create a new Secure Store Target application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


New-SPSecureStoreTargetApplicationField
Example
[image]

Creates a new Secure Store application fields object.

New-SPSecureStoreTargetApplicationField -Masked <SwitchParameter> -Name <String> -Type <UserName | Password | Pin | Key | Generic | WindowsUserName | WindowsPassword> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Masked

Required

System.Management.Automation.SwitchParameter

Specifies that the field be masked.

Name

Required

System.String

Specifies the name of the new target application field.

The type must be a valid name of an application field; for example, ABCDE.

Type

Required

Microsoft.BusinessData.Infrastructure.SecureStore.SecureStoreCredentialType

Specifies the type of credential field to add to a target application.

The type must be one of the following:

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the New-SPSecureStoreTargetApplicationField cmdlet to create a new Secure Store application fields object for a target application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


Remove-SPSecureStoreApplication
Example
[image]

Deletes a Secure Store application.

Remove-SPSecureStoreApplication -Identity <SPSecureStoreApplication> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.SecureStoreService.PowerShellCmdlet.SPSecureStoreApplication

Specifies the Secure Store application to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Secure Store application (for example, SecureStoreApp1); or an instance of a valid SPSecureStoreApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove-SPSecureStoreApplication cmdlet to delete a Secure Store application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


Set-SPSecureStoreApplication
Example
[image]

Sets properties of a Secure Store application.

Set-SPSecureStoreApplication -Identity <SPSecureStoreApplication> [-Administrator <SPClaim[]>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-CredentialsOwnerGroup <SPClaim[]>] [-Fields <TargetApplicationField[]>] [-TargetApplication <TargetApplication>] [-TicketRedeemer <SPClaim[]>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.Office.SecureStoreService.PowerShellCmdlet.SPSecureStoreApplication

Specifies the Secure Store application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Secure Store application (for example, SecureStoreApp1); or an instance of a valid SPSecureStoreApplication object.

Administrator

Optional

Microsoft.SharePoint.SPClaim[]

Specifies the administrator of the Secure Store application.

The type must be a valid SPClaim object array.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

CredentialsOwnerGroup

Optional

Microsoft.SharePoint.SPClaim[]

Specifies the claims object for the groups that own the group credentials.

The type must be a valid SPClaim object array.

Fields

Optional

Microsoft.Office.SecureStoreService.Server.TargetApplicationField[]

Specifies the field information for the application. The default fields are username and password.

The type must be a valid array of ApplicationField objects.

TargetApplication

Optional

Microsoft.Office.SecureStoreService.Server.TargetApplication

Specifies information about the target application. For example, the TargetApplication object includes data values for application name, display name, contact info, enable ticketing flag, and URL address to set the credential. The schema for the TargetApplication object is defined in the ISecureSToreProviderExtended interface that exposes the target application metadata.

The type must be a valid TargetApplication object array.

TicketRedeemer

Optional

Microsoft.SharePoint.SPClaim[]

Specifies the ticket redeemer claim value.

The type must be a valid SPClaim object array.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPSecureStoreApplication cmdlet to set properties of a Secure Store application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


Set-SPSecureStoreServiceApplication
Example
[image]

Sets properties of a Secure Store service application in the farm.

Set-SPSecureStoreServiceApplication -Identity <SPServiceApplicationPipeBind> [-Administrators <String[]>] [-ApplicationPool <SPIisWebServiceApplicationPool>] [-AssignmentCollection <SPAssignmentCollection>] [-AuditingEnabled <SwitchParameter>] [-AuditlogMaxSize <Nullable>] [-Confirm [<SwitchParameter>]] [-DatabaseCredentials <PSCredential>] [-DatabaseName <String>] [-DatabasePassword <SecureString>] [-DatabaseServer <String>] [-DatabaseUsername <String>] [-FailoverDatabaseServer <String>] [-Sharing <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationPipeBind

Specifies the service application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a subscription settings service application (for example, SubscriptionSettingsApp1); or an instance of a valid SPServiceApplication object.

Administrators

Optional

System.String[]

Specifies the administrators of the Secure Store service application.

The type must be an array of valid user names.

ApplicationPool

Optional

Microsoft.SharePoint.Administration.SPIisWebServiceApplicationPool

Specifies the existing IIS application pool to run the Web service in for the new service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

AuditingEnabled

Optional

System.Management.Automation.SwitchParameter

Turns on auditing for the Secure Store service.

AuditlogMaxSize

Optional

System.Nullable

Specifies the number of days to retain the audit log.

The type must be a valid integer.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DatabaseCredentials

Optional

System.Management.Automation.PSCredential

Specifies the PSCredential object that contains the user name and password to be used for database SQL authentication.

The type must be a valid PSCredential object.

DatabaseName

Optional

System.String

Specifies the name of the Secure Store service database.

The type must be a valid name of a SQL Server database; for example, SecureStoreDB1.

DatabasePassword

Optional

System.Security.SecureString

Specifies the password for the user specified in DatabaseUserName. Use this parameter only if SQL authentication is used to access the metadata service application database.

The type must be a valid SQL Server password.

DatabaseServer

Optional

System.String

Specifies the name of the host server for the database specified in DatabaseName.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

DatabaseUsername

Optional

System.String

Specifies the user name to use for connecting to the database for the Secure Store service application. Use this parameter only if SQL authentication is used to access the service application database.

The type must be a valid user name; for example, UserName1.

FailoverDatabaseServer

Optional

System.String

Specifies the name of the host server for the failover database server.

The type must be a valid SQL Server host name; for example, SQLServerHost1.

Sharing

Optional

System.Management.Automation.SwitchParameter

Specifies that the Secure Store service application is published and shared across the farm.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPSecureStoreServiceApplication cmdlet to set properties of a Secure Store service application in the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


Update-SPSecureStoreCredentialMapping
Example
[image]

Sets a new credential mapping for a Secure Store service application.

Update-SPSecureStoreCredentialMapping -FieldTypes <SecureStoreCredentialType[]> -Identity <SPSecureStoreApplication> -Principal <SPClaim> -Values <SecureString[]> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

FieldTypes

Required

Microsoft.BusinessData.Infrastructure.SecureStore.SecureStoreCredentialType[]

Specifies the field types of the credential mapping.

The type must be an array of field names for the credential mapping; for example, username, password, pin.

Identity

Required

Microsoft.Office.SecureStoreService.PowerShellCmdlet.SPSecureStoreApplication

Specifies the Secure Store application (that contains the principal) from which to delete the credential mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Secure Store application (for example, SecureStoreApp1); or an instance of a valid SPSecureStoreApplication object.

Principal

Required

Microsoft.SharePoint.SPClaim

Specifies the SPClaims object that contains the principal.

The type must be a valid name of a user principal name; for example, jsmith@some.com.

Values

Required

System.Security.SecureString[]

Specifies the field values for the credential mapping.

The type must be an array of field names; for example, JLBusernm1, MyPass@w, 4321

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Update-SPSecureStoreCredentialMapping cmdlet to set a new credential mapping for a Secure Store service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


Upgrade-SPSingleSignOnDatabase
Example
[image]

Converts a single sign-on database to a Secure Store database.

Upgrade-SPSingleSignOnDatabase -SecureStoreConnectionString <String> -SecureStorePassphrase <SecureString> -SSOConnectionString <String> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

SecureStoreConnectionString

Required

System.String

Specifies the SQL Server connection string for the Secure Store database.

The type must be a valid connection string; for example, securestoredbname.

SecureStorePassphrase

Required

System.Security.SecureString

Specifies the passphrase used for the Secure Store database.

The type must be a valid passphrase; for example, My Secure Store Phrase.

SSOConnectionString

Required

System.String

Specifies the SQL Server connection string for SSO database.

The type must be a valid connection string; for example, ssodbname.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

Use the Upgrade-SPSingleSignOnDatabase cmdlet to convert a single sign-on database to a Secure Store database. After turning off the SSO, use the Upgrade-SPSingleSignOn cmdlet to convert a single sign-on database to a Secure Store database. Single sign-on (SSO) is a Microsoft SharePoint Server feature. SSO functionality is performed by the Secure Store service in Microsoft SharePoint Server 2010.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

The following command migrate applications without passwords to an existing Secure Store database.
Copy Code
PS>Upgrade - SPSingleSignOnDatabase - SSOconnectionString[$SSOdb] - SecureStorePassphrase[$passphrase] - SecureStoreConnectionString [$SSdb]
Click here to submit feedback on this topic.


Update-SPSecureStoreGroupCredentialMapping
Example
[image]

Sets a new group credential mapping for a Secure Store service application.

Update-SPSecureStoreGroupCredentialMapping -FieldTypes <SecureStoreCredentialType[]> -Identity <SPSecureStoreApplication> -Values <SecureString[]> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

FieldTypes

Required

Microsoft.BusinessData.Infrastructure.SecureStore.SecureStoreCredentialType[]

Specifies the field types of the credential mapping.

The type must be an array of field names for the credential mapping; for example, username, password, pin.

Identity

Required

Microsoft.Office.SecureStoreService.PowerShellCmdlet.SPSecureStoreApplication

Specifies the Secure Store application (that contains the principal) from which to delete the credential mapping.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a Secure Store application (for example, SecureStoreApp1); or an instance of a valid SPSecureStoreApplication object.

Values

Required

System.Security.SecureString[]

Specifies the field values for the credential mapping.

The type must be an array of field names; for example, JLBusernm1, MyPass@w, 4321.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Detailed Description

Use the Update-SPSecureStoreGroupCredentialMapping cmdlet to set a new group credential mapping for a Secure Store service application. Group credentials is a set of credentials that are associated with multiple identities. Target applications will get credentials for a Secure Store application by using the current user. If the current user meets the authorization rule defined in the Secure Store application for the group credentials, then the data is provided.

Input Types

Return Types

Errors

Error | Description

Exceptions

Example


Update-SPSecureStoreMasterKey
Example
[image]

Changes the master secret key of a Secure Store service application.

Update-SPSecureStoreMasterKey -Passphrase <String> -ServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Reencrypt <SwitchParameter>]

Parameters

Parameter Required Type Description

Passphrase

Required

System.String

Specifies the passphrase that is used for the Secure Store database. The passphrase that you enter is not stored. Make sure that you write down the passphrase and store it in a secure location. The passphrase will be required to add new Secure Store service servers.

The type must be a valid passphrase; for example, MyBDCApp123masterkey.

ServiceApplicationProxy

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the proxy of the Secure Store service application that contains the master key to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a BDC Service application proxy (for example, BDCAppProxy1); or an instance of a valid SPServiceApplicationProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Reencrypt

Optional

System.Management.Automation.SwitchParameter

Specifies that the database for the Secure Store service application is re-encrypted. This synchonizes the master key in all servers that run an instance of the Secure Store application.

Detailed Description

The Update-SPSecureStoreApplicationServerKey cmdlet changes the master key of a Secure Store service application.

Updating the master key is required when:

  • A new instance of a service application is created and the database for the Secure Store service application is new or empty.

  • The master key or passphrase has been compromised.

  • Security guidelines require that the passphrase or key be replaced.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.


Update-SPSecureStoreApplicationServerKey
Example
[image]

Synchronizes the key on a Microsoft SharePoint server with the Secure Store master key.

Update-SPSecureStoreApplicationServerKey -Passphrase <String> -ServiceApplicationProxy <SPServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>]

Parameters

Parameter Required Type Description

Passphrase

Required

System.String

Specifies the passphrase that is used for the Secure Store service database.

The type must be a valid passphrase; for example, MyBDCApp1serverkey.

ServiceApplicationProxy

Required

Microsoft.SharePoint.PowerShell.SPServiceApplicationProxyPipeBind

Specifies the proxy of the service application that contains the server key to synchronize.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a BDC Service application proxy (for example, BDCAppProxy1); or an instance of a valid SPServiceApplicationProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Detailed Description

The Update-SPSecureStoreApplicationServerKey cmdlet synchronizes the key on a SharePoint server with the master key for the Secure Store service database.

Updating a server key is required when:

  • A new SharePoint server that will run a Secure Store service instance is joined to the farm.

  • The key stored in the server is not the key required for the current Secure Store service database (because of server or networking issues).

  • The master key is updated but during propagation of the new key, this process fails on one or more of the servers.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

Add code example.