Clear-SPPerformancePointMonitoringServiceApplicationTrustedLocation
[image]

Clears all the trusted locations for a Service Application identity.

Clear-SPPerformancePointMonitoringServiceApplicationTrustedLocation -ServiceApplication <SPPerformancePointMonitoringServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-TrustedLocationType <DataSource | Content>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

ServiceApplication

Required

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationPipeBind

Specifies the PerformancePoint service application that contains the trusted locations.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application (for example, PerfPointApp1); or an instance of a valid SPPerformancePointMonitoringServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

TrustedLocationType

Optional

System.Nullable

Specifies the type of trusted locations to clear. If the TrustedLocationType parameter is not specified, this cmdlet clears all the trusted locations for the specified PerformancePoint service application.

The type must be one of the following: content, data source.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Clear-SPPerformancePointMonitoringServiceApplicationTrustedLocation cmdlet to remove all the trusted locations for a PerformancePoint service application. Use the TrustedLocationType parameter to remove only the trusted locations for a trusted location type.

Input Types

Return Types

Click here to submit feedback on this topic.


Get-SPPerformancePointMonitoringServiceApplication
[image]

Returns a PerformancePoint service application object and properties.

Get-SPPerformancePointMonitoringServiceApplication [-Identity <SPPerformancePointMonitoringServiceApplicationPipeBind>] [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Optional

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationPipeBind

Specifies the PerformancePoint service application to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application (for example, PerfPointApp1); or an instance of a valid SPPerformancePointMonitoringServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Get-SPPerformancePointMonitoringServiceApplication cmdlet to read a PerformancePoint service application object and properties. If the Identity parameter is not specified, the cmdlet returns the collection of PerformancePoint service applications in the farm.

Input Types

Return Types

Click here to submit feedback on this topic.


Get-SPPerformancePointMonitoringServiceApplicationTrustedLocation
[image]

Returns a trusted location object and properties for a PerformancePoint service application.

Get-SPPerformancePointMonitoringServiceApplicationTrustedLocation [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Identity <SPPerformancePointMonitoringServiceApplicationTrustedLocationPipeBind>] [-ServiceApplication <SPPerformancePointMonitoringServiceApplicationPipeBind>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Identity

Optional

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationTrustedLocationPipeBind

Specifies the trusted location to get.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or an instance of a valid SPPerformancePointMonitoringServiceApplicationTrustedLocation object.

ServiceApplication

Optional

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationPipeBind

Specifies the PerformancePoint service application that contains the trusted location.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application (for example, PerfPointApp1); or an instance of a valid SPPerformancePointMonitoringServiceApplication object.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Get-SPPerformancePointMonitoringServiceApplicationTrustedLocation cmdlet to read a trusted location object and properties. If the Identity parameter is not specified, this cmdlet returns the list of all trusted locations and their properties for a PerformancePoint service application.

Input Types

Return Types

Click here to submit feedback on this topic.


New-SPPerformancePointMonitoringServiceApplication
Example
[image]

Creates a new service application for the PerformancePoint Service.

New-SPPerformancePointMonitoringServiceApplication -Name <String> -ApplicationPool <SPIisWebServiceApplicationPoolPipeBind> [-AnalyticQueryCellMax <Int32>] [-AnalyticQueryLoggingEnabled <$true | $false>] [-ApplicationCacheEnabled <$true | $false>] [-ApplicationCacheMinimumHitCount <Int32>] [-ApplicationProxyCacheEnabled <$true | $false>] [-AssignmentCollection <SPAssignmentCollection>] [-CommentsDisabled <$true | $false>] [-CommentsScorecardMax <Int32>] [-Confirm [<SwitchParameter>]] [-DataSourceQueryTimeoutSeconds <Int32>] [-DecompositionTreeMaximum <Int32>] [-ElementCacheSeconds <Int32>] [-FilterRememberUserSelectionsDays <Int32>] [-FilterTreeMembersMax <Int32>] [-IndicatorImageCacheSeconds <Int32>] [-MSMQEnabled <$true | $false>] [-MSMQName <String>] [-SelectMeasureMaximum <Int32>] [-SessionHistoryHours <Int32>] [-ShowDetailsInitialRows <Int32>] [-ShowDetailsMaxRows <Int32>] [-ShowDetailsMaxRowsDisabled <$true | $false>] [-TrustedContentLocationsRestricted <$true | $false>] [-TrustedDataSourceLocationsRestricted <$true | $false>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the name of the new PerformancePoint Service application.

The type must be a valid name of a PerformancePoint Service application; for example, PerfPointApp1.

ApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool to run the Web service in for the service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

AnalyticQueryCellMax

Optional

System.Int32

Specifies the maximum number of returned cells in an analytic grid.

A valid integer value between 1-1,000,000,000. The default value is 100,000.

AnalyticQueryLoggingEnabled

Optional

System.Nullable

Turns on verbose logging of query events.

The type must be one of the following: True or False. The default value is False.

ApplicationCacheEnabled

Optional

System.Nullable

Specifies whether the rendered output cache on the application server is on (True) or off (False). The default value is True.

ApplicationCacheMinimumHitCount

Optional

System.Nullable

Specifies the minimum number of times rendered output must be requested before it is added to cache. The default value is 2.

ApplicationProxyCacheEnabled

Optional

System.Nullable

Specifies rendered output cache on the web front end. The default value is True.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CommentsDisabled

Optional

System.Nullable

Specifies that users can add comments to scorecard cells.

The type must be one of the following: true or false.

CommentsScorecardMax

Optional

System.Nullable

Specifies the maximum number of comments that can be added to a scorecard. The default value is 1000.

The type must be an integer value in the range of 1 to 1,000,000.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DataSourceQueryTimeoutSeconds

Optional

System.Nullable

Specifies the time, in seconds, before a data source query times out. The default value is 300.

The type must be an integer value in the range of 1 to 36,000.

DecompositionTreeMaximum

Optional

System.Nullable

Specifies the maximum number of items (per level) returned to the decomposition tree visualization.

A valid integer value between 1-1,000,000. The default value is 25.

ElementCacheSeconds

Optional

System.Int32

Specifies the first class object cache expiration time. The default value is 15.

FilterRememberUserSelectionsDays

Optional

System.Nullable

Specifies the number of days that user filter selections are remembered. The default value is 90.

The type must be an integer value in the range of 1 to 10,000.

FilterTreeMembersMax

Optional

System.Nullable

Specifies the maximum number of records to show in filter treeview control. The default value is 500.

The type must be an integer value in the range of 1 to 100,000.

IndicatorImageCacheSeconds

Optional

System.Nullable

Specifies the time, in seconds, that key performance indicator (KPI) icons are cached. The default value is 10.

The type must be an integer value in the range of 1 to 3600.

MSMQEnabled

Optional

System.Nullable

Specifies that notifications are sent to Microsoft Message Queuing (MSMQ) on content change.

The type must be one of the following: true or false. The default value is False.

MSMQName

Optional

System.String

Specifies the name of the queue. The queue name can contain a maximum of 380 characters, and cannot contain the following characters: CR (ASCII 13), LF (ASCII 10), backslash (\), plus sign (+, comma (,), or quotation marks (""") .

The type must be a valid MSMQ name; for example, MessageQueue1.

SelectMeasureMaximum

Optional

System.Nullable

Specifies the maximum number of measures to show in a dashboard Select Measure control. The default value is 1000.

The type must be an integer value in the range of 1 to 1,000,000.

SessionHistoryHours

Optional

System.Nullable

Specifies the number of hours between clearing expired user navigation history. The default value is 2.

The type must be an integer value in the range of 1 to 48.

ShowDetailsInitialRows

Optional

System.Nullable

Specifies the initial number of rows to retrieve for show details. The default value is 1000.

The type must be an integer value in the range of 1 to 100,000.

ShowDetailsMaxRows

Optional

System.Nullable

Specifies the maximum number of rows to retrieve for show details.

The type must be an integer value in the range of 1 to 1,000,000. The default value is 10,000.

ShowDetailsMaxRowsDisabled

Optional

System.Nullable

Turns off the ShowDetailsInitialRows setting. If set to True, Analysis Services controls limit.

The type must be one of the following: True or False. The default value is False.

TrustedContentLocationsRestricted

Optional

System.Nullable

Specifies that only specified locations are trusted. The default setting is false (trust all content locations).

The type must be one of the following: True or False. The default value is False.

TrustedDataSourceLocationsRestricted

Optional

System.Nullable

Specifies that only specified locations are trusted. The default setting is false (trust all data source locations).

The type must be one of the following: True or False. The default value is False.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPPerformancePointMonitoringServiceApplication cmdlet creates a new PerformancePoint Service on the farm.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

-----------------EXAMPLE------------------------
Copy Code
New-SPPerformancePointMonitoringServiceApplication -Name PPS_Application_01 -ApplicationPool PPS_Application_Pool_01

This example creates a new PerformancePoint Service application named PPSApp_01 and sets it to run under an application pool named PPS_Application_Pool_01.


New-SPPerformancePointMonitoringServiceApplicationProxy
See Also Example
[image]

Creates a proxy for a PerformancePoint Service application.

New-SPPerformancePointMonitoringServiceApplicationProxy -Name <String> -ServiceApplication <SPPerformancePointMonitoringServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Default <SwitchParameter>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Name

Required

System.String

Specifies the name of the PerformancePoint Service application proxy to create.

The type must be a valid name of a PerformancePoint Service application proxy; for example, PerfPointAppProxy1.

ServiceApplication

Required

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationPipeBind

Specifies the PerformancePoint Service application that is associated with the new service application proxy.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application (for example, PerfPointApp1); or an instance of a valid SPPerformancePointMonitoringServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Default

Optional

System.Management.Automation.SwitchParameter

Specifies that the new application proxy will be added to the default service application proxy group.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

The New-SPPerformancePointMonitoringServiceApplicationProxy cmdlet creates a proxy for a PerformancePoint Service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

--------------------EXAMPLE--------------------
Copy Code
New-SPPerformancePointMonitoringServiceApplicationProxy -Name PPS_Application_Proxy_01 -ServiceApplication PPS_Application_01 -Default

This example creates a new PerformancePoint Service application proxy named PPS_Application_Proxy_01, associated with the aervice application named PPS_Application_01 and is added to the Default proxy group.

See Also

Reference

Remove-SPPerformancePointMonitoringServiceApplicationProxy


New-SPPerformancePointMonitoringServiceApplicationTrustedLocation
[image]

Creates a new trusted location for a PerformancePoint service application.

New-SPPerformancePointMonitoringServiceApplicationTrustedLocation -ServiceApplication <SPPerformancePointMonitoringServiceApplicationPipeBind> -TrustedLocationType <DataSource | Content> -Type <SiteCollection | Site | List | DocumentLibrary> -Url <String> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-Description <String>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

ServiceApplication

Required

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationPipeBind

Specifies the PerformancePoint service application that the new trusted location will be added to.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application (for example, PerfPointApp1); or an instance of a valid SPPerformancePointMonitoringServiceApplication object.

TrustedLocationType

Required

Microsoft.PerformancePoint.Scorecards.TrustedFileType

Specifies the type of trusted locations to clear. If TrustedLocationType is not specified, this cmdlet clears all the trusted locations for the specified PerformancePoint service application.

The type must be one of the following: content or data source.

Type

Required

Microsoft.PerformancePoint.Scorecards.RepositoryLocationType

The type of trusted location.

The type must be one of the following: Site Collection, Site, Document Library, List

Url

Required

System.String

Specifies the URL of the trusted location site.

The type must be a valid URL, in the form http://server_name.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

Description

Optional

System.String

Specifies the description of the new safe data provider.

The type must be a valid string with a maximum of 4096 characters.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the New-SPPerformancePointMonitoringServiceApplicationTrustedLocation cmdlet to create a new trusted location for a PerformancePoint service application. The new trusted location can be a Content or Data Source trusted location type.

Input Types

Return Types

Click here to submit feedback on this topic.


Remove-SPPerformancePointMonitoringServiceApplication
[image]

Deletes a PerformancePoint service application from a farm.

Remove-SPPerformancePointMonitoringServiceApplication -Identity <SPPerformancePointMonitoringServiceApplicationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationPipeBind

Specifies the PerformancePoint service application to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application (for example, PerfPointApp1); or an instance of a valid SPPerformancePointMonitoringServiceApplication object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove-SPPerformancePointMonitoringServiceApplication cmdlet to delete a PerformancePoint service application.

Input Types

Return Types

Click here to submit feedback on this topic.


Remove-SPPerformancePointMonitoringServiceApplicationProxy
[image]

Deletes the proxy for a service application.

Remove-SPPerformancePointMonitoringServiceApplicationProxy -Identity <SPPerformancePointMonitoringServiceApplicationProxyPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationProxyPipeBind

Specifies the PerformancePoint service application proxy to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application proxy (for example, PerfPointAppProxy1); or an instance of a valid SPPerformancePointMonitoringServiceApplicationProxy object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove-SPPerformancePointMonitoringServiceApplicationProxy cmdlet to delete the proxy for a PerformancePoint service application.

Input Types

Return Types

Click here to submit feedback on this topic.


Remove-SPPerformancePointMonitoringServiceApplicationTrustedLocation
[image]

Removes a single trusted location from a PerformancePoint service application.

Remove-SPPerformancePointMonitoringServiceApplicationTrustedLocation -Identity <SPPerformancePointMonitoringServiceApplicationTrustedLocationPipeBind> [-AssignmentCollection <SPAssignmentCollection>] [-Confirm [<SwitchParameter>]] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationTrustedLocationPipeBind

Specifies the trusted location to delete.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; or an instance of a valid SPPerformancePointMonitoringServiceApplicationTrustedLocation object.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Remove-SPPerformancePointMonitoringServiceApplicationTrustedLocation cmdlet to delete a single trusted location from a PerformancePoint service application.

Input Types

Return Types

Click here to submit feedback on this topic.


Set-SPPerformancePointMonitoringServiceApplication
Example
[image]

Sets global runtime properties for a PerformancePoint service application.

Set-SPPerformancePointMonitoringServiceApplication -Identity <SPPerformancePointMonitoringServiceApplicationPipeBind> [-AnalyticQueryCellMax <Int32>] [-AnalyticQueryLoggingEnabled <$true | $false>] [-ApplicationCacheEnabled <$true | $false>] [-ApplicationCacheMinimumHitCount <Int32>] [-ApplicationPool <SPIisWebServiceApplicationPoolPipeBind>] [-ApplicationProxyCacheEnabled <$true | $false>] [-AssignmentCollection <SPAssignmentCollection>] [-CommentsDisabled <$true | $false>] [-CommentsScorecardMax <Int32>] [-Confirm [<SwitchParameter>]] [-DataSourceQueryTimeoutSeconds <Int32>] [-DecompositionTreeMaximum <Int32>] [-ElementCacheSeconds <Int32>] [-FilterRememberUserSelectionsDays <Int32>] [-FilterTreeMembersMax <Int32>] [-IndicatorImageCacheSeconds <Int32>] [-MSMQEnabled <$true | $false>] [-MSMQName <String>] [-SelectMeasureMaximum <Int32>] [-SessionHistoryHours <Int32>] [-SettingsDatabase <String>] [-ShowDetailsInitialRows <Int32>] [-ShowDetailsMaxRows <Int32>] [-ShowDetailsMaxRowsDisabled <$true | $false>] [-TrustedContentLocationsRestricted <$true | $false>] [-TrustedDataSourceLocationsRestricted <$true | $false>] [-WhatIf [<SwitchParameter>]]

Parameters

Parameter Required Type Description

Identity

Required

Microsoft.PerformancePoint.Scorecards.SPPerformancePointMonitoringServiceApplicationPipeBind

Specifies the PerformancePoint service application to update.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of a PerformancePoint service application (for example, PerfPointApp1); or an instance of a valid SPPerformancePointMonitoringServiceApplication object.

AnalyticQueryCellMax

Optional

System.Int32

Specifies the maximum number of returned cells in an analytic grid.

A valid integer between 1-1,000,000,000. The default value is 100,000.

AnalyticQueryLoggingEnabled

Optional

System.Nullable

Turns on verbose logging of query events.

The type must be one of the following: true, false. The default value is False.

ApplicationCacheEnabled

Optional

System.Nullable

Specifies whether rendered output cache on the application server is on (True) or off (False). The default value is True.

ApplicationCacheMinimumHitCount

Optional

System.Nullable

Specifies the minimum number of times rendered output must be requested before it is added to cache. The default value is 2.

ApplicationPool

Optional

Microsoft.SharePoint.PowerShell.SPIisWebServiceApplicationPoolPipeBind

Specifies the existing IIS application pool to run the Web service in for the service application.

The type must be a valid GUID, in the form 12345678-90ab-cdef-1234-567890bcdefgh; a valid name of an application pool (for example, AppPoolName1); or an instance of a valid IISWebServiceApplicationPool object.

ApplicationProxyCacheEnabled

Optional

System.Nullable

Specifies rendered output cache on the web front end. The default value is True.

AssignmentCollection

Optional

Microsoft.SharePoint.PowerShell.SPAssignmentCollection

Manages objects for the purpose of proper disposal. Use of objects, such as SPWeb or SPSite, can use large amounts of memory and use of these objects in Windows PowerShell scripts requires proper memory management. Using the SPAssignment object, you can assign objects to a variable and dispose of the objects after they are needed to free up memory. When SPWeb, SPSite, or SPSiteAdministration objects are used, the objects are automatically disposed of if an assignment collection or the Global parameter is not used.

Note:
When the Global parameter is used, all objects are contained in the global store. If objects are not immediately used, or disposed of by using the Stop-SPAssignment command, an out-of-memory scenario can occur.

CommentsDisabled

Optional

System.Nullable

Specifies that users can add comments to scorecoard cells.

The type must be one of the following: true, false. The default value is False.

CommentsScorecardMax

Optional

System.Nullable

Specifies the maximum number of comments that can be added to a scorecard. The default value is 1000.

The type must be an integer value in the range of 1 to 1,000,000.

Confirm

Optional

System.Management.Automation.SwitchParameter

Prompts you for confirmation before executing the command. For more information, type the following command: get-help about_commonparameters

DataSourceQueryTimeoutSeconds

Optional

System.Nullable

Specifies the time, in seconds, before a data source query times out. The default value is 300.

The type must be an integer value in the range of 1 to 36,000.

DecompositionTreeMaximum

Optional

System.Nullable

Specifies the maximum number of items (per level) returned to the decomposition tree visualization.

A valid integer value between 1-1,000,000. The default value is 25.

ElementCacheSeconds

Optional

System.Int32

Specifies the first class object cache expiration time. The default value is 15.

FilterRememberUserSelectionsDays

Optional

System.Nullable

Specifies the number of days that user filter selections are remembered. The default value is 90.

The type must be an integer value in the range of 1 to 10,000.

FilterTreeMembersMax

Optional

System.Nullable

The maximum number of records to show in filter treeview control. The default value is 500.

An integer value in the range of 1 to 100,000

IndicatorImageCacheSeconds

Optional

System.Nullable

Specifies the time, in seconds, that key performance indicator (KPI) icons are cached. The default value is 10.

The type must be an integer value in the range of 1 to 3600.

MSMQEnabled

Optional

System.Nullable

Specifies that notifications are sent to Microsoft Message Queuing (MSMQ) on content change.

The type must be one of the following: true, false. The default value is False.

MSMQName

Optional

System.String

Specifies the name of the queue. The queue name can contain a maixmum of 380 characters, and cannot contain the following characters: CR (ASCII 13), LF (ASCII 10), "\" (backslash), "+" (plus), "," (comma), """ (quote).

The type must be a valid MSMQ name; for example, MessageQueue1.

SelectMeasureMaximum

Optional

System.Nullable

Specifies the maximum number of measures to show in a dashboard Select Measure control. The default value is 1000.

The type must be an integer value in the range of 1 to 1,000,000.

SessionHistoryHours

Optional

System.Nullable

Specifies the number of hours between clearing expired user navigation history. The default value is 2.

The type must be an integer value in the range of 1 to 48.

SettingsDatabase

Optional

System.String

Specifies the name of the PPS database used for that service application.

ShowDetailsInitialRows

Optional

System.Nullable

Specifies the initial number of rows to retrieve for show details. The default value is 1000.

The type must be an integer value in the range of 1 to 100,000.

ShowDetailsMaxRows

Optional

System.Nullable

Specifies the maximum number of rows to retrieve for show details.

The type must be an integer value in the range of 1 to 1,000,000.

ShowDetailsMaxRowsDisabled

Optional

System.Nullable

Turns off the ShowDetailsInitialRows setting. If set to true, Analysis Services controls limit.

The type must be one of the following: true, false. The default value is False.

TrustedContentLocationsRestricted

Optional

System.Nullable

Specifies that only specified locations are trusted. The default setting is false (trust all content locations).

One of the following: true, false. The default value is False.

TrustedDataSourceLocationsRestricted

Optional

System.Nullable

Specify to trust only specified data source locations. The default is to trust all data source locations.

The type must be one of the following: true, false. The default value is False.

WhatIf

Optional

System.Management.Automation.SwitchParameter

Displays a message that describes the effect of the command instead of executing the command. For more information, type the following command: get-help about_commonparameters

Detailed Description

Use the Set-SPPerformancePointMonitoringServiceApplication cmdlet to update global runtime properties for a PerformancePoint service application. The changes made to properties by using this cmdlet affect all servers in the farm that are running the instance of the specified PerformancePoint service application.

Input Types

Return Types

Errors

Error | Description

Exceptions

Exceptions | Description

Example

----------------EXAMPLE----------------------
Copy Code
Set-SPPerformancePointMonitoringServiceApplication -Identity PPSApp_01 -DataSourceQueryTimeoutSeconds 5000

This example sets the Data Source Query Timeout setting to a value of 5000. This cmdlet is equivalent to the PerformancePoint Service Settings Page on the Central Administration Web site,.